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Introduction
This guide is intended for Siebel Marketing and Siebel Campaigns administrators, 
managers, and end users with different levels of expertise in customer relationship 
and database management. Depending on your implementation strategy, 
administrator duties may be assumed by end users who have advanced expertise in 
this area.

Although job titles and duties at your company may differ, this book will be useful 
primarily to people whose title or job description matches one of the following:

Database 
Administrators

Persons who administer the database system, including data 
loading, system monitoring, backup and recovery, space 
allocation and sizing, and user account management.

Marketing and 
Campaigns 
Administrators

Persons responsible for setting up and maintaining access to 
marketing data. Duties include managing databases of customer 
information, mapping to tables and fields, designing metrics for 
use in segmentation and filters, creating hierarchies of data, and 
so on.

Analytics 
Administrators

Persons responsible for creating and maintaining Siebel Analytics 
repositories and administering the Siebel Analytics Server 
environment.

Marketing and 
Campaigns 
Managers

Persons responsible for setting up and maintaining a marketing 
department. Duties include designing and managing campaigns, 
product marketing information, and product distribution lists.

Siebel Application 
Administrators

Persons responsible for planning, setting up, and maintaining 
Siebel applications.

Siebel Application 
Developers

Persons who plan, implement, and configure Siebel applications.

Siebel Marketing 
and Campaigns 
End Users

Persons responsible for implementing campaign strategy by 
generating snapshots and lists and launching campaigns.
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Introduction
Special skills or knowledge you might need to use this guide with Siebel Marketing 
and Siebel Campaigns are in the following list:

■ Database Administrators should be familiar with SQL and RDBMS design and 
performance practices.

■ Siebel Application Administrators should be familiar with core Siebel 
architecture, tools, and frameworks.

■ Siebel Application Developers should be familiar with core Siebel architecture, 
tools, and frameworks. Some of the relevant tools to understand include Siebel 
EAI and Siebel Workflow/Business Process Designer.

■ Marketing and Campaigns Managers and End Users might need to be familiar 
with the basics of HTML for working with Web and email offers.

Product Modules and Options
This Siebel Bookshelf contains descriptions of modules that are optional and for 
which you may not have purchased a license. Siebel’s Sample Database also 
includes data related to these optional modules. As a result, your software 
implementation may differ from descriptions in this Bookshelf. To find out more 
about the modules your organization has purchased, see your corporate purchasing 
agent or your Siebel sales representative.
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How This Guide Is Organized
How This Guide Is Organized
Most chapters of this guide document key tasks and commonly used screens based 
upon a job role.

This book focuses on tasks commonly performed by marketing and campaigns 
administrators or those with a familiarity with database tables and fields. 
Initialization and data mapping tasks are typically performed once, with 
modifications dependant on changes in data sources and marketing and campaigns 
strategy.
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Revision History
Revision History
Siebel Marketing Guide

Version 7.5.3
Table 1. Changes Made in Version 7.5.3

Topic Revision

Marketing Features Deleted this topic from the “About Siebel 
Marketing” chapter.

“Verifying Database Page Size Parameter 
(DB2 Only)”

Revised for 7.5.2.2xx and 7.5.3: Added this 
topic.

“Performing Setup Tasks for Target Group 
Segments”

New for 7.5.2.2xx and 7.5.3: Added this 
topic.

“Setting Up Target Group Segmentation on a 
UNIX Platform”

New for 7.5.2.2xx and 7.5.3: Added this 
topic.

Mapping Data for Visual Segmentation Revised for 7.5.2.2xx and 7.5.3: Deleted this 
section from the “External Data Mapping” 
chapter.

“Setting Up Target Group Segment Tables 
and Joins”

New for 7.5.2.2xx and 7.5.3: Added this 
topic to replace Visual Segmentation 
material.

Using the Answers Screen Revised for 7.5.2.2xx and 7.5.3: Deleted this 
topic from the “Defining Filter and Segment 
Criteria” chapter.

“Building a Criteria-Based Segment” Revised for 7.5.2.2xx and 7.5.3: Changed 
the name of this topic from Building 
Segment Criteria.

“About Target Group Segmentation” Added this topic to replace Visual 
Segmentation material. Applies to versions 
7.5.2.2xx and 7.5.3.

“Creating, Loading, and Refreshing a Target 
Group Segment”

New for 7.5.2.2xx and 7.5.3: Added this 
topic to replace Visual Segmentation 
material. 

“Setting Up Campaign Groups” Modified step 1.
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Revision History
Additional Changes:

■ Changed Visual Segmentation to Target Group Segmentation throughout the 
book.

■ Made various quality enhancements throughout the book.

January 2003 Bookshelf

“Response Type Definitions” Added response types to the table.

Chapter 22, “Troubleshooting in Siebel 
Marketing”

Added this chapter to assist with problem 
resolution.

Appendix A, “Marketing Reference” Added this appendix to provide additional 
reference material for marketing 
administrators and system administrators.

Table 2. Changes Made in Rev. A for January 2003 Bookshelf

Topic Revision

“Adding a Position to the Marketing 
Administrators Access Group”

Added this topic.

“Verifying Database Page Size Parameter 
(DB2 Only)”

Added information for setting up DB2 on 
the IBM 390 platform.

“Adjusting the Max EAI Records Parameter” Revised to explain what happens when you 
increase and decrease the value of this 
parameter.

“About Server Definitions” Revised the Marketing Repository definition 
to clarify what tasks this server performs.

“Using Start Point Joins” Revised definition to clarify why you need 
to define start point joins.

“Designing Marketing Program Plans” Changed chapter title from Designing 
Marketing Programs.

Table 1. Changes Made in Version 7.5.3

Topic Revision
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Revision History
Additional Changes:

■ Changed Dun & Bradstreet to D&B throughout the book.

■ Changed the name of the Start Schedule button to Activate Schedule.

“Creating an Attribute Family From the 
Siebel Database Campaign History”

Added this topic.

“Planning and Budgeting for Marketing” Changed chapter title from Marketing Plans.

“Generating and Maintaining Snapshot 
Files”

Changed chapter title from Generating 
Snapshots and added more overview 
material.

“Stopping a Snapshot File Generation” Added this topic.

“Deleting a Snapshot File” Added this topic.

“Setting Up and Using eMarketing” Changed the title of this chapter to reflect 
the addition of setup topics.

“About the Siebel eMarketing Web Site” Added this topic.

“Using the eMarketing Offers Page” Added this topic.

“Using the eMarketing Information Page” Added this topic.

“Setting Up Siebel eMarketing” Added setup task topics to the eMarketing 
chapter.

Table 2. Changes Made in Rev. A for January 2003 Bookshelf

Topic Revision
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About Siebel Marketing 1
Siebel Marketing provides an integrated, closed-loop solution that supports 
campaign design, campaign management, and campaign launching at each 
customer touch point.

Siebel Marketing provides tools that you can use to design campaigns, create 
reusable offers, and segment customers and prospects based on multilevel profile 
information. It also allows you to execute targeted direct and indirect multistage 
programs across telemarketing, field sales, field service, mail, fax, and Internet 
channels. Customer response information, including clickstream data, can be 
captured for campaign measurement, analysis, and refinement.

In addition, you can support ongoing, interactive communications with customers 
through Web surveys and eNewsletters to strengthen relationships and build 
customer loyalty.

Siebel Marketing and Siebel Campaigns provides marketing and campaigns 
managers with enhanced capabilities for working with partners on specific 
marketing activities and overall marketing collaboration. Siebel Marketing assists 
marketers in developing and executing marketing plans, while working with 
partners throughout the process. 

The Marketing Manager for Partners module allows you to distribute marketing 
programs and campaign details through the Siebel Partner Portal. This module 
allows marketers to coordinate efforts across partners and allow partners to take a 
more active role in campaign execution. It also allows partner organizations to 
create, manage, and execute programs and campaigns. Partners can contribute to 
the marketing process through the same set of views and functionality available in 
the employee application. However, partners are not able to edit segments or use 
the program flow due to limitations of the Partner Portal. For more information, see 
Siebel Partner Relationship Management Administration Guide.
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The Siebel Marketing Server engine allows you to query transactions in a single pass 
of the source relational databases that supply your target segment data. The Siebel 
Server extracts, transforms, and aggregates customer data in memory before writing 
the data to a campaign load (snapshot) file. The Siebel Server provides you with 
opportunity to compare various campaign strategies before executing the campaign.

Using campaign forecasting, you can design scenarios based on real or hypothetical 
financial information that model the performance of campaigns. You can track 
program and campaign operations and plans, using the Activity Plan, Explorer, and 
Campaigns views. Siebel Marketing users can use Siebel Analytics tools to analyze 
program and campaign performance, and generate reports.

For information about terms used in Siebel Marketing, see Terms Used in Siebel 
Marketing on page 27.
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Terms Used in Siebel Marketing
Table 3 lists some of the terms used frequently in Siebel Marketing and Siebel 
Campaigns.

Table 3. Siebel Marketing and Siebel Campaigns Terms

Element Definition

Allocation The process of specifying how many customers and prospects 
should be assigned to each campaign and wave within a program 
stage. You use allocation to divide a segment into subsets of people 
that you assign to campaign offers. Members of many segments may 
be assigned to a single campaign, or members of one segment may 
be assigned to multiple campaigns.

Campaign One instance of an executed campaign plan. A campaign is one or 
more offers presented to a group of individuals to foster the 
relationship between the company and the individual. A campaign 
may offer a special deal on a new product, may promote accessories 
or options for a previous purchase, or may follow up on an offer 
delivered in a previous step of the customer dialogue.

Prior to the 7.5 release, this was called a campaign occurrence.

Campaign Plan A template for a campaign that can be applied any number of times 
for a launch.

Prior to the 7.5 release, this was called a campaign in the Siebel 
Marketing application.

Filter A set of criteria intended to exclude specified customers or 
prospects from a marketing program.

Forecast Forecasts are financial predictions developed for each campaign 
plan. Forecast results are derived from a set of segments, lists, 
response rates, cost inputs, and revenue. Forecasts are also 
aggregated to programs and marketing plans to allow higher level 
analysis. Prior to the 7.5 release, this was called Financial Modeler.

Load Campaign The process of physically assigning customers or prospects to a 
campaign by creating records within the Siebel database campaign 
tables. 

Prior to the 7.5 release, this was called Campaign Population.

Marketing Plan A high-level business plan combining any number of programs, 
events, and stand-alone campaigns.
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Offer A marketing message in a campaign intended for the targeted 
customers. It can contain information about products, services, 
prices, or any other information.

Output File Layouts Determines the information that appears in a generated list of 
contacts. The output file layout might be as complex as a full 
mailing address, or as uncomplicated as an email address.

Output Lists Contain the names and contact information for individuals that 
qualified for each campaign. Lists are generated from information 
gathered when you generate a snapshot. The contents of the list are 
defined by the output file layout assigned to the list.

Program An instance of an executed program plan. A marketing program is 
a collection of campaigns that target multiple segments over 
multiple stages. It contains segments, campaigns, and lists with a 
similar theme, goal, or economic purpose. A program can have 
multiple segments, each with multiple campaigns and offers.

Prior to the 7.5 release, this was called a Program Occurrence.

Program Plan A template for a Program that can be applied any number of times 
for execution.

Prior to the 7.5 release, this was called a Program.

Response The customer or prospect's reaction to a specific offer as part of a 
specific campaign. May be a positive such as Respondent Purchased 
or a negative response such as Not Interested.

Results The actual results of a marketing campaign based on customer 
counts, response rates, revenues, and expenses.

Segment A set of target customers or prospects for a given marketing 
program. Typically defined as a set of selection criteria that can be 
reapplied to a source database.

Snapshot A binary file that collects the information necessary to support the 
segments, output lists, source code formats, and campaign load 
mappings for a marketing program. Siebel Marketing builds the 
snapshot by querying your source database, and obtaining the 
counts for each segment before allocating segments to campaigns 
and offers.

Table 3. Siebel Marketing and Siebel Campaigns Terms

Element Definition
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Source Codes An alphanumeric value assigned to each campaign contact and 
prospect for tracking purposes. The source code format is defined 
by source code components from the program, segment, campaign, 
or wave in which the campaign contact was targeted.

Stage Plan Each program plan may have multiple stage plans, which define the 
steps in a customer dialogue and define how responses are 
managed.

Suppressions Records that should be excluded from a campaign, such as 
customers with Do Not Solicit flags.

Wave Waves separate a campaign contact list into sections divided by 
time or vendor. For example, a campaign might be distributed into 
multiple waves to avoid overloading an inbound call centers.    
Some companies launch a campaign with a small wave, around 5% 
of the entire distribution, to check that their processes (outbound 
mailing, order entry, order delivery, response tracking, and so on) 
are working as expected.

Table 3. Siebel Marketing and Siebel Campaigns Terms

Element Definition
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Initializing Siebel Marketing 2
After installation is complete, your database administrator or marketing 
administrator needs to verify that basic initialization tasks have been performed 
before using Siebel Marketing. This chapter contains information about the 
following initialization tasks:

■ Siebel Marketing Initialization Checklist on page 32

■ Performing Setup Tasks for Target Group Segments on page 45

■ Setting Up Target Group Segmentation on a UNIX Platform on page 50
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Siebel Marketing Initialization Checklist
You must perform several tasks before using Siebel Marketing to create single stage 
and multistage programs. Therefore, before using Siebel Marketing, complete the 
tasks in the following list in the sequence shown:

1 Gateway Server and Siebel Server. Verify that the Siebel Gateway Server and the 
Siebel Server are running before you begin initialization.

2 Define data source names. Create ODBC data source names for each data source 
used in Siebel Marketing using “Defining Data Source Names” on page 33.

3 Make sure Siebel Marketing Server components are enabled. See “Enabling 
Marketing Server Components” on page 34.

NOTE: Your system administrator configures server components when setting up 
Siebel Communications Server. For information about this process, see Siebel 
Communications Server Administration Guide.

4 Create a user name that uses the database tableowner login. See “Verifying Create 
Table Privileges for the User Name Parameter” on page 36.

5 Stop and restart the Siebel Server. See “Stopping and Restarting the Siebel Server” 
on page 37.

6 Verify the Page Size Parameter for DB2. See “Verifying Database Page Size 
Parameter (DB2 Only)” on page 37.

7 Create the Repository server. See “Creating the Marketing Repository Server 
Definition” on page 37.

8 Verify the Wave Batch Size parameter. “Configuring Wave Batch Size Parameter” 
on page 38.

9 Verify the Max EAI Records parameter. See “Adjusting the Max EAI Records 
Parameter” on page 38.

10 Initialize multistage programs. Set up the tables and joins to initialize multistage 
programs using “Initializing Multistage Programs” on page 40.
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11 Set up Analytic Adapter Components. For instructions, see “Setting Up Analytic 
Adapters” on page 78.

12 Revise and activate workflow processes. See “Activating Workflow Processes” on 
page 42.

13 Enable auto-response creation in specified screens. For details, see “Enabling 
Automatic Response for Opportunities and Orders” on page 43.

14 Set up users who launch campaigns, start a schedule, or reschedule a stage. For more 
information, see “Adding a Position to the Marketing Administrators Access 
Group” on page 43.

15 Set up Target Group Segmentation. Perform tasks in “Performing Setup Tasks for 
Target Group Segments” on page 45 and “Setting Up Target Group Segmentation 
on a UNIX Platform” on page 50.

Defining Data Source Names
Segments can be created based on data that resides in the Siebel database or other 
external data sources. After you define your external data sources, you can create 
segment definitions and link those segments to one or more campaigns. Customers 
from external data sources are automatically added as new contact records in the 
Siebel database, after they have been included in campaigns.

Define ODBC (Open Database Connectivity) data source names (DSNs) for each 
data source that contains information you need for Siebel Marketing programs. Also 
define an ODBC DSN for the marketing repository. The marketing repository is a 
group of administrative tables in the Siebel application transactional database used 
by the Siebel Marketing application.

NOTE: If Siebel Analytics is installed, you must create a DSN for the Siebel Data 
Warehouse in addition to the marketing repository. If you use DB2, the ODBC data 
source name must be the same as the database name. The Marketing Server 
requires a system DSN, not a user DSN.
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Each time you add a data source, you need to repeat this task, creating a DSN that 
points to the new data source. Prior to implementation, confer with your Technical 
Account Manager or Technical Support team for the latest list of supported ODBC 
drivers.

Enabling Marketing Server Components
During Siebel Server installation and configuration, you can set up a number of 
server component groups used by Siebel Marketing. If you did not set up the 
components during installation, you can accomplish this task using the following 
procedure. For more information about enabling component groups, see the Siebel 
Server installation guide written for your operating system.

Check the status of the Marketing Server component groups, making sure they are 
enabled using the Component Groups view in the Server Administration screen. The 
Component Groups view is a list of installed Siebel Enterprise Server component 
groups and associated components, servers, and tasks. 

Table 4 contains a list of Siebel Marketing component groups and components.

For a list of component groups that should be enabled for Siebel Marketing, see “To 
locate and verify component group status” on page 35.

Table 4. Marketing Component Groups and Components

Group 
Name Full Name Description Components

MktgOM Marketing Object 
Manager

Marketing Object 
Manager components

■ Marketing Obj Mgr

■ eMarketing Obj Mgr

■ eEvents Obj Mgr

MktgSrv Marketing Server Marketing Server 
components

■ Data Dictionary Manager

■ Marketing Server

■ List Import Service Manager
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Determining Component Group Status
Use the following procedure to make sure component groups are enabled. Enabled 
component groups must be assigned only to the Siebel Server running Marketing 
tasks, except for the List Import Service Manager which can be enabled on multiple 
Siebel Servers. The server assigned to the selected component group appears in the 
Servers view tab list.

To locate and verify component group status

1 From the application-level menu, choose View > Site Map > Server 
Administration > Component Groups.

2 In the Enterprise Component Groups list, locate each component group, and 
make sure the group’s Enable State is Enabled. 

The following groups should be enabled:

■ Marketing Object Manager

■ Marketing Server

■ Workflow Management

■ Communications Management

■ System Management

■ Enterprise Application Integration (eAI)

■ Assignment Manager (Needed if you will use Assignment Manager to 
automatically assign the organization owner and position owner based on 
specific criteria in predefined rules.) For more information, see “Setting Up 
Campaign Execution Options” on page 359.

Enabling and Synchronizing Component Groups
If the component group is not enabled, use the following procedure to enable it. 
When the component groups are enabled, synchronize the component groups.

To enable component groups

1 From the application-level menu, choose View > Site Map >Server 
Administration screen > Enterprise Configuration.
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2 In the Enterprise Component Groups list, select the component group, click the 
menu button, and choose Enable Component Group.

To synchronize component groups

1 From the application-level menu, choose View > Site Map > Server 
Administration screen > Enterprise Configuration.

2 Click the Batch Component Admin view tab.

3 In the Batch Components list, click Synchronize.

You do not have to select any components in this view. The synchronization task 
may take a few minutes.

Verifying Create Table Privileges for the User Name Parameter
When accessing the Siebel database, the Marketing application uses a specific user 
name to gain access internally. To make sure that the Marketing Server processes 
will be completed successfully, you need to create a user name that uses the 
database tableowner login and start the Enterprise Server with this login. You 
specify the Enterprise User Name parameter during Siebel Server installation. This 
user name must have Create Table privileges in the Siebel tableowner schema 
because the server programs use the Enterprise server’s User Name parameter to 
create tables in the Siebel database. The tableowner, or database user ID, that Siebel 
Marketing uses needs to have the following rights at the database level within the 
Siebel database schema:

■ Drop table

■ Drop index

■ Create table

■ Create index

NOTE: Some database vendors such as Oracle might have unique requirements. Use 
the documentation provided by your vendor to verify their requirements.
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In addition, this user (tableowner) must have the same responsibilities and 
positions as the system administrator (SADMIN). Responsibilities and privileges are 
assigned by a Siebel system administrator from within the Siebel Application. 

Stopping and Restarting the Siebel Server
The Siebel Server must be restarted each time synchronization occurs. 

NOTE: You cannot Resume or Restart more than once for the same set of requests.

To restart the Siebel Server process using Microsoft Windows

1 In the Microsoft Windows’ Control Panel, click the Services icon to open the 
Services window.

2 Locate Siebel Server and click Stop.

3 Click Start.

Verifying Database Page Size Parameter (DB2 Only)
If you use an IBM DB2 database on an IBM 390 mainframe, it is required that you 
set the database Page Size parameter to 16384 (no less and no more). 

If you use an IBM DB2 database on any other hardware platform, it is recommended 
that you set the database parameter named Page Size (bytes) for the Siebel Database 
tablespace to a minimum of 16384. Setting this parameter to 16384 improves 
performance.

For more information, contact your system administrator and see Siebel Data 
Warehouse Installation and Administration Guide.

Creating the Marketing Repository Server Definition
The Marketing Repository consists of a set of system tables in the Siebel database. 
As a result, the Marketing Repository shares the same system DSN as the main 
Siebel database.
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You need to create a Marketing Repository server definition that points to the 
Marketing Repository database, using the tableowner’s (Marketing Repository) user 
name and password. This server definition is used by the Marketing component 
group to connect to the database. For instructions, see “Creating Server Definitions” 
on page 89.

NOTE: When you create the Marketing Repository server definition, make sure the 
Type field is set to Marketing Repository, not Data Source. 

Although only one Marketing Repository record can be created, the values for 
reference name, DSN, user name, and password can be updated at any time.

Configuring Wave Batch Size Parameter
Certain Communication Server parameters and Marketing Server component 
parameters affect the performance of eMarketing campaigns. The first of these 
parameters is the Wave Batch Size parameter in the Marketing Server component. 
This parameter effectively, but not directly, specifies the number of communication 
server requests that will be spawned for every wave. If the number of people in a 
wave is 1000 and the Wave Batch Size is set to 50, then 20 communication server 
requests are spawned. Depending on the SMTP server being used, a higher number 
of communication server requests can speed up the execution of the eMarketing 
campaign. The Max Tasks parameter in the communication server component 
however sets the limit on the number of such requests that can be spawned at one 
time. For details about setting up Communication Server parameters, see Siebel 
Communications Server Administration Guide.

Adjusting the Max EAI Records Parameter
During the campaign load process, text files containing information about the 
contacts and prospects for the campaign are created in the [Siebel File 
System]\Marketing\EAI directory. These files are used to check for records in the 
Siebel Contacts table (S_CONTACT) and create new records prior to populating the 
Marketing external key table (S_DD_USER_KEY) and the Campaign Contacts table 
(S_CAMP_CON).
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The size of these files is controlled by the MAX EAI Records parameter in the 
Marketing Server component. By default, the system creates one file for every 
10,000 contacts. When 10,000 contacts have been read into a file the file is saved 
(committed).

Adjusting the MAX EAI Records parameter is not needed to run the marketing 
application. However, you may need to increase or decrease the value of this 
parameter based on your business needs.

Reducing the Max EAI Records parameter. Loading a campaign is an all-or-none 
process because the commit occurs only after the campaign load process completes 
successfully. If record 10,000 fails during a campaign load, the previous 9,999 
records that were inserted will not be saved in a file. Siebel Marketing does not 
support partial commits and there is no way to restart the process. However, you 
can reduce the number of records that load for each commit by decreasing the Max 
EAI Records parameter from its default of 10,000. You set the Max EAI Records 
parameter on the Marketing Server (MktgSrvr) component. Reducing the Max EAI 
Records can also help prevent a time out from causing a load to fail.

To clean up records from an earlier EAI load, you can use EIM to delete the old 
records. If a campaign load fails, an administrator uses EIM to back out of the 
committed records in the EIM promotion history table for each campaign. This 
deletes S_CAMP_CON records for that campaign.

NOTE: You need to delete records only from S_CAMP_CON. You do not need to delete 
records from S_DD_USER_KEY because these records are reused.

Increasing the Max EAI Records parameter. If your EAI transaction volume is very 
high, you may need to increase the value of this parameter to improve performance.

To view or change the Max EAI Records parameter

1 From the application-level menu, choose View > Site Map > Server 
Administration > Components.

2 In the Components list, select Marketing Server.

3 Click the Component Parameters view tab.

4 In the Component Parameters list, locate Max EAI Records.
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5 To change the value, use one of the following steps:

■ To change the value for only the current session, increase the number in 
Current Value to be higher.

■ To change the value for the current and future sessions, change Current Value 
and Value on Restart to a higher value.

NOTE: When you restart the Marketing Server, the parameter value reverts to 
the value in Value on Restart.

Initializing Multistage Programs
Before you execute multistage programs, set up your Marketing Repository to track 
the campaign history of customers across multiple stages of a marketing program. 
For more information, see “Working With Tables” on page 91 and “Joining Tables 
and Fields” on page 118.

Set up multistage program processes by creating a new record (mapping) for each 
of the following tables and setting up table joins:

■ S_CAMP_CON. This table holds the identifiers of contacts for specific 
campaigns. 

■ S_DD_USER_KEY. Use this table to map external contact keys (contacts, 
customers) to the Contact ID in the S_CONTACT table during Campaign Load.

Mapping Tables
Use the following procedure to map tables required for multistage marketing 
programs. After you create and save the table records, columns for both tables will 
be populated in the Siebel Marketing Repository.

These joins are only used when funneling is enforced. Funneling is enforced when 
the program is on an automatic schedule and you have set the Suppress Same Stage 
flag.

To map tables S_CAMP_CON and S_DD_USER_KEY

1 From the application-level menu, choose View > Site Map > Marketing 
Administration screen > External Data Mapping.
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2 Click the Tables view tab.

3 In the Tables list, create a new record.

4 Type the required parameters for each new table, including Reference Name, 
Table Name, Server, and so on and save the record.

NOTE: Make sure you type the case-sensitive reference names correctly for these 
two tables. The server searches the Marketing Repository by exact name.

a Map the Siebel Database table S_CAMP_CON using the case-sensitive 
reference name S_Camp_Con.

b Map the Siebel Marketing Repository table S_DD_USER_KEY using the case-
sensitive reference name S_DD_User_Key.

5 Map the S_DD_USER_KEY table, using Key1, Key2, and so on, based on 
targeting levels.

For more information, see “Creating Customer Hierarchies and Adding Targeting 
Levels” on page 108 and “Mapping Tables to Customer Hierarchies” on page 110.

Creating Joins for Multistage Programs
The S_CAMP_CON and S_DD_USER_KEY tables must be joined before you can 
execute multistage marketing programs with recurring stages. The join may use 
several Parent fields and Child fields to join Key 1, 2, and so on. Use the following 
procedure to set up the joins necessary to execute multistage marketing programs. 
For more information, see “Understanding Joins” on page 113.

To create joins for multistage programs

1 From the application-level menu, choose View > Site Map > Marketing 
Administration screen > External Data Mapping.

2 Click the Joins view tab.

3 In the Joins list, create a new record.
Version 7.5.3 Siebel Marketing Guide 41



Initializing Siebel Marketing

Siebel Marketing Initialization Checklist
4 Join the external table to S_DD_USER_KEY table using Key01, Key02, and so on.

The S_DD_User_Key table is used to map external contact keys (contacts and 
customers) to the contact ID in the S_CONTACT table during campaign load. 
The S_Camp_Con table contains the identifiers of contacts for specific 
campaigns.

5 Join S_DD_User_Key to S_Camp_Con, using S_DD_User_Key.ROW_ID to 
S_Camp_Con.DD_USER_KEY_ID. 

CAUTION: Make sure that you select the Cache check box, select 1:N in the 
Cardinality field, and select Equal in the Type field.

6 In the Joins list, complete the fields. 

For additional information, see “Guidelines for Caching” on page 119.

Activating Workflow Processes
Workflow processes must be activated before you can use them. To activate a 
workflow process, navigate to the Workflow Processes view of the Business Process 
Administration screen and select a workflow process. Then you click Revise, make 
any changes, and click Activate. When activated, the workflow process Status field 
will contain a value of Active. For details about making changes necessary for your 
business needs, see Siebel Business Process Designer Administration Guide.

Make sure that the following workflow processes (listed in alphabetical order) have 
been activated in the Business Process Administration screen before attempting to 
use Siebel Marketing:

■ Analytic Adapters. See “Editing the Workflow Process for Siebel Analytics” on 
page 81.

■ Automatic Data Retrieval. This workflow is invoked any time you insert a new 
record in the ETL Result (S_ETL_RUN) table. For more information, see 
“Automatic Data Retrieval” on page 155.

■ Campaign Launch. This workflow is called when you launch a campaign. For 
more information, see Chapter 21, “Launching Programs and Campaigns.”
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■ Campaign Load. This workflow is called when you load a campaign. For 
information about manually loading a campaign, see “Manually Loading a 
Campaign (Generating a List)” on page 487. For information about loading a 
campaign (generating a list) automatically, see “Using the Schedule Calendar 
View” on page 535.

■ Campaign List Association. This workflow associates a list with a campaign and 
deleting a list from a campaign.

■ Marketing Plan Recalculation. This workflow is called when you navigate to the 
Marketing Plans screen and click Recalculate in the More Info view tab. This 
rolls up values across campaigns, programs, sub-plans and plans.

■ Program Execution. Program Execution is used for executing programs 
automatically. For more information, see Chapter 21, “Launching Programs and 
Campaigns.”

Enabling Automatic Response for Opportunities and Orders
Responses can be created automatically when you associate a campaign with an 
order, associate a campaign as a source for an opportunity, or create an opportunity 
using the Create Oppty button in the Campaign screen. By default, the user 
properties for automatic response creation are disabled.

To enable auto-response creation in the Orders, Opportunities, and Campaigns 
screens, perform the following tasks in Siebel Tools:

■ Orders screen. Set the User property Create Auto Response Service to Y in the 
Order Entry - Orders business component.

■ Opportunity screen, Contacts view. Set the User property Create Auto Response 
Service to Y in the Contact business component.

■ Campaigns screen, Contacts/Prospects view tab. Enable the Create Oppty button 
in this view tab by setting the User property Create Auto Response Service to Y 
in the Opportunity business component. 

Adding a Position to the Marketing Administrators Access Group
If a user's position is not assigned to the Marketing Administrators access group, 
the user will be unable to perform any of the following three actions:
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■ Selecting Launch Campaign in the Program Flow view. Launching a campaign 
sends email offers for an email campaign and invokes FTP to send output list 
files to vendors.

NOTE: You cannot execute campaigns by selecting Send on the application-level 
menu.

■ Starting a schedule. The Activate Schedule button on the Program Schedule view 
is only available if the user’s position is a member of the Marketing 
Administrators access group. Clicking this button causes the marketing program 
to activate at the scheduled time on the calendar.

■ Rescheduling a stage of a marketing program if the stage fails.

For more information about access groups, see Security Guide for Siebel eBusiness 
Applications.

To add a position to the Marketing Administrators access group

1 From the application-level menu, select View > Site Map > Group 
Administration > Access Groups.

2 In the Access Groups list, query for Marketing Administrators.

3 In the Members list, create a new record and select the appropriate position.
44 Siebel Marketing Guide Version 7.5.3



Initializing Siebel Marketing

Performing Setup Tasks for Target Group Segments
Performing Setup Tasks for Target Group Segments
Target Group Segments allow users of Siebel Analytics dashboards and Siebel 
Answers to generate target lists of customers from a report or Answers request. To 
enable this feature there are several setup steps that need to be completed.

Siebel Marketing allows you to set up and use target group segments by providing 
three .dll files, a new SIF file, and an XML file containing the Analytic Adapters 
workflow. You need to import the new SIF file (using Siebel Tools) and the XML file 
containing the Analytic Adapters workflow (using Siebel’s Business Process 
Designer).

NOTE: To use Target Group Segments, you must be running Siebel Marketing version 
7.5.2.2xx or 7.5.3.

To setup Siebel Marketing to support target group segments, perform the following 
tasks in the sequence shown:

■ “Verifying Target Group Segmentation Prerequisites”

■ “Importing SIF File Changes to Support Target Group Segments”

■ “Importing the Revised Analytic Adapters Workflow” on page 47

■ “Adding the Target Groups View to Responsibilities” on page 48

■ “Modifying the HTTP Host Record to Allow Single Signon” on page 49

Verifying Target Group Segmentation Prerequisites
The following conditions must exist to use Target Group Segmentation:

■ Siebel Server and Siebel Analytics Server must be running in the same network 
domain, for example, Siebel.com.

■ The Web server component of Siebel Analytics should be running on the same 
machine as the Siebel Web server extension.

■ If you use secure connections, such as those provided by HTTP, both Siebel 
Server and Analytics Server should be running in secure mode.
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Importing SIF File Changes to Support Target Group Segments
Before importing the SIF file, you need to shut down the Siebel Server. For more 
information, see the Siebel Server Installation Guide for the operating system you 
are using.

To import the SIF file using Siebel Tools

1 Open Siebel Tools and navigate to Menus > Tools > Checkout.

2 Select All Projects and click Get.

3 Lock the following projects:

■ Analytic Adaptors (SM)

■ SME nQuire Integration

■ Segment (DBM)

■ Server (DD)

■ Data Dictionary (DBM)

4  Use the Import Wizard to import the SIF file.

a Choose Tools > Import from Archive.

b In your file system locate and open the file named StaticSegments.sif.

c In the Conflict Resolution screen, select the Merge option and click Next.

In the Review Conflicts and Actions screen, you can see the difference 
between the repository and file objects.

d In the Review Conflicts and Actions screen, click Next.

The dialog box contains a summary of the upcoming changes and the 
number of impacted objects.

e In the dialog box, click Yes.

A summary of the requested changes appears.
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f In the screen, click Finish.

NOTE: During validation, Siebel Tools will report a few errors that indicate minor 
differences in the repository to support Target Group Segments. For example, 
using Date when DateTime should have been used. These changes will not have 
any material impact on the functioning of other features that depend on this 
module.

5 Compile the modified projects.

a Go to Tools > Compile Projects.

b In the Object Compiler, select the five locked projects.

c Under the Siebel Repository File, select the SRF file location.

d Click Compile.

Importing the Revised Analytic Adapters Workflow
After importing the SIF file and compiling the modified projects in Siebel Tools, you 
need to import the Analytic Adapters workflow. The AnalyticAdapters.xml file 
contains the new Analytic Adapters workflow and is one of the files included with 
the 7.5.2.2xx and 7.5.3 patches. When the new Analytic Adapters workflow is 
successfully imported, its status will be In Progress. When you activate this 
imported workflow, it becomes the active workflow and can be used immediately. 
The previous Analytic Adapters workflow status is changed to Outdated.

NOTE: Make sure that you have started the Siebel Server.
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To import the revised Analytic Adapters workflow

1 From the application-level menu, choose View > Site Map >Business Process 
Administration > Workflow Processes.

2 In the Workflow Processes list, click the menu button and select Import 
workflow.

You do not need to select or create a record before you import the Analytic 
Adapters workflow. The import creates a new workflow record with a status of 
In Progress.

3 In the Workflow Process Import dialog box, click Browse.

4 Locate and select the AnalyticAdapters.xml file, and then click Import.

5 In the Workflow Processes list, query for Analytic Adapters in the Name column.

6 Select the imported Analytic Adapters workflow, and then click Activate.

It will be the latest version and will have a status of In Progress.

TIP: Check the Version column to locate the latest version.

Adding the Target Groups View to Responsibilities
Installing the SIF file and importing the Analytic Adapters workflow creates a new 
view (Target Groups) in the Siebel Repository file. The new Target Groups view 
must be added to the Marketing Manager and Siebel Administrator responsibilities 
so that it will be visible to people with these responsibilities.

To add the Target Groups view to Responsibilities

1 From the application-level menu, choose View > Site Map > Application 
Administration > Views.

2 In the Views list, create a record.

3 In the Name field, type Target Groups.
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4 In the Show drop-down list, select Responsibilities.

5 In the Responsibilities list, select the Siebel Administrator record, and then 
perform the following steps.

a In the Views list, click New.

If the New button is not available, you may need to set the editseeddata 
parameter. For instructions, see your Siebel administrator.

b In the Add Views dialog box, select the Target Groups view.

Repeat Step 5 to add the view to the Marketing Manager record.

Modifying the HTTP Host Record to Allow Single Signon
The single signon allows you to access the Siebel Analytics application without 
having to sign on each time you select an Analytics screen. To set up the single 
signon, you change the Analytics Server name to match your Analytics Server name 
and change the URL to the Analytics URL.

To modify the HTTP host record to allow single signon

1 From the application-level menu, choose View > Site Map > Integration 
Administration > Host Administration.

2 In the HTTP Host list, select the record that has a value of [NQHOST] in the 
Virtual Name field.

3 In the Name field, replace AnalyticsServerName with the name of your Analytics 
Server, for example, smthqddy01.

Do not change the value in the Virtual Name field.

4 From the Show drop-down list select Symbolic URL Administration.

5 In the Symbolic URL list, in the Name field, query for SiebelAnswers.

6 In the SiebelAnswers record, change the value in the URL field to 
http://NQHOST/Analytics/saw.dll.

7 In the Symbolic URL Arguments list, note the value in the Argument Value field 
for nqUser and nqPassword records to use later.
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Setting Up Target Group Segmentation on a UNIX 
Platform

This section contains setup instructions for the Marketing administrator that are 
required to support Target Group Segmentation on a Unix platform. The Target 
Group Segmentation feature allows you to use Siebel Analytics report criteria to 
create Siebel Marketing segments. In Siebel Analytics, when you click a link called 
Create Segment, the Segment screen in Siebel Marketing appears. In the Segment 
screen, you can create a segment based on the Siebel Analytics query. The query 
results are retrieved when the Analytic Adaptor workflow executes and are stored 
in a target group table in Siebel Marketing.

NOTE: To use Target Group Segments, you must be running Siebel Marketing version 
7.5.2.2xx or 7.5.3.

The following conditions must exist to use Target Group Segmentation:

■ Siebel Server and Analytics Server must be running in the same network 
domain, for example, Siebel.com.

■ The Web server component of Siebel Analytics and Siebel Web Server extension 
should be running within the same fully qualified domain name.

■ If you use secure connections, such as those provided by HTTP, both Siebel 
Server and Analytics Server should be running in secure mode.

NOTE: The Marketing Server does not have to be installed on the same machine as 
the Siebel Server.

The Marketing administrator must perform both of the following tasks on the 
machine that runs Siebel Server to allow Target Group Segmentation to work in a 
UNIX environment.

■ Setting Up Environment Variables for Target Group Segmentation on page 51

■ Configuring the Odbc.ini File for Target Group Segmentation on page 52
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Setting Up Environment Variables for Target Group Segmentation
The Marketing administrator must setup and export environment variables on the 
machine that runs Siebel Server to allow Target Group Segmentation to work in a 
UNIX environment. 

To set and export environment variables

1 Install the Siebel Analytics client and identify the ODBC data source name 
(default is AnalyticsWeb) so that you can use this name in subsequent tasks.

If Siebel Analytics is already installed, you can verify the ODBC data source 
name later in this section.

2 Before starting the Siebel Server, source the siebenv.csh file to make sure that 
the Siebel environment variables are set.

Siebenv.csh is in the [Siebel Server install directory]/siebsrvr subdirectory.

3 Set and export the following environment variables:

a SIEBEL_UNIXUNICODE_DB=ORACLE

The value of this variable must always be ORACLE, no matter what database 
you use.

NOTE: Setting the value to ORACLE makes sure that the Merant driver 
manager is loaded.

b SAID=[Siebel Analytics client install directory]

4 Make sure that $SAID directory is included and correct in the library path using 
one of the following steps:

■ If you use the Solaris operating environment, set and export the following 
environment variable:

LD_LIBRARY_PATH=$SAID/Bin:$SAID/odbc/lib:$LD_LIBRARY_PATH

■ If you use the AIX operating system, set and export the following 
environment variable:

LIB_PATH=$SAID/Bin:$SAID/odbc/lib:$LIB_PATH
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■ If you use the HP-UX operating system, set and export the following 
environment variable:

SHLIB_PATH=$SAID/Bin:$SAID/odbc/lib:$SHLIB_PATH

5 Execute the following command to make sure that the Analytics ODBC libraries 
are registered.

regedit -c -s $SAID/setup/sa.reg

6 Open the userodbc.reg file in the $SAID/setup directory and identify the ODBC 
data source name for Analytics.

If you used the default ODBC data source name (AnalyticsWeb), the ODBC entry 
looks like the following statement:

HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI\[AnalyticsWeb]

7 Execute the following command:

regedit -c -s $SAID/setup/userodbc.reg

This step allows Marketing to access the Analytics ODBC data source.

After completing this task, the Marketing administrator needs to configure the 
odbc.ini file. For instructions, see “Configuring the Odbc.ini File for Target Group 
Segmentation” on page 52.

Configuring the Odbc.ini File for Target Group Segmentation
After setting up and exporting environment variables, the Marketing administrator 
must configure the odbc.ini file. This needs to be done on the machine that runs 
Siebel Server to allow Target Group Segmentation to work in a UNIX environment. 
For information about setting up and exporting environment variables, see “Setting 
Up Environment Variables for Target Group Segmentation” on page 51.
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To configure your odbc.ini file

1 In your directory named [Analytics install folder]/Setup, locate and open the 
odbc.ini file.

2 Copy the [AnalyticsWeb] section (including the section name) so that you can 
paste it into your odbc.ini file.

This section should include the following information:

Driver=[Siebel Analytics install client directory]/libnqsodbc.so

Description=Siebel Analytics Server

ServerMachine=[Siebel Analytics Server’s machine nme]

Port=[Siebel Analytics Server’s machine name port numbert]

3 In the directory named [Siebel Server install folder]/ses/siebsrvr/sys, open your 
odbc.ini file and paste the [AnalyticsWeb] section that you copied in Step 2.

4 In your odbc.ini file, locate the Analytics ODBC DSN that was identified in Step 6 
of “To set and export environment variables” on page 51.

You use [AnalyticsWeb] if you did not change the default.

5 In the [ODBC Data Sources] section, add the Merant supported driver for 
Analytics using the following as an example:

AnalyticsWeb=MERANT 4.1 Oracle 9 Driver

6 Restart the Siebel Server.

7 Set and export the following environment variable:

DISPLAY=[any machine running X-Term server]:0.0

NOTE: It is recommended that you add this statement to the siebsrvr.csh file.

8 Verify that the user can connect through ODBCSQL to the Analytics data source 
by typing the following command in the command line.

odbcsql /s [Analytics data source name] /u [user name] /p 
[password]
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Campaign load mappings define the way campaign-related data is copied from an 
internal or external marketing data source into the Siebel database for launching a 
campaign. You must define campaign load mappings for internal and external data 
sources before you can use Siebel eBusiness Application Integration (eAI) 
technology to import this information. For example, contact information such as 
first and last name, phone number, and email address can be brought into the Siebel 
database during campaign load only if you define campaign load mappings for this 
data. The Campaign Load workflow process is used to manage the load process.

A campaign load mapping must be associated with a program stage even if the data 
source comes from the Siebel Data Warehouse. Refer to “Using the Marketing 
Person Integration Object” on page 67 for creating a campaign load mapping for the 
Data Warehouse.

The following topics are covered in this chapter:

■ About Marketing Integration Objects and Components on page 56

■ About Analytic Adapters on page 77
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About Marketing Integration Objects and Components
The Marketing application provides two integration objects, Marketing Contact and 
Marketing Person. For each campaign load mapping, you must select only one of 
these two integration objects described in the following list:

■ Marketing Contact integration object. If any campaign contact names do not exist 
within the Siebel transactional database, you must use the Marketing Contact 
integration object. It provides the field mappings necessary to import new 
contacts and accounts. For more information, see “Using the Marketing Contact 
Integration Object.”

■ Marketing Person integration object. If all your campaign contacts and prospects 
exist within the Siebel transactional database, then you can also use the 
Marketing Person integration object. Typically, this configuration occurs for 
installations that use the Siebel Data Warehouse populated from the Siebel 
transactional database and that do not introduce new customers into the Data 
Warehouse from other sources. In this configuration, you only need to provide 
a mapping of Contact and Prospect IDs between the data warehouse and Siebel 
transaction database to load the campaign, because the contact field information 
is already recorded. For more information, see “Using the Marketing Person 
Integration Object” on page 67.

You can see examples of contact key component mappings for sample customer 
hierarchies in “Sample Mappings for Contact Key Components” on page 61.

The following topics are discussed in this section:

■ Using the Marketing Contact Integration Object on page 57

■ Mapping Rules for Integration Components (Marketing Contact) on page 59

■ Sample Mappings for Contact Key Components on page 61

■ Creating Campaign Load Mappings on page 62

■ Mapping Integration Components and Fields on page 63

■ Siebel Contact and Campaign History Tables on page 65

■ Creating Campaign Load Mappings for Target Group Segments on page 66

■ Using the Marketing Person Integration Object on page 67
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■ Mapping Rules for Integration Components (Marketing Person) on page 67

■ Recommended Campaign Load Mappings–Examples on page 70

Using the Marketing Contact Integration Object
The Marketing Contact integration object provides field mappings to typical 
contact- or account-related information from the external data sources.

The Marketing Contact integration object has seven integration components, as 
shown in Figure 1 on page 58. These components are described in Table 5 on 
page 59.
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During campaign load, Integration component User Keys determine if a record 
already exists in the component for the given values and if the record is unique. The 
required fields are fields that cannot be a null value for the new record. 

Figure 1. Marketing Contact Integration Components
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Mapping Rules for Integration Components (Marketing Contact)
Siebel Marketing integration requires at least three integration components: 
Contact, Contact Key, and Campaign Contact. Campaign Contact is automatically 
generated by the Marketing Server component. 

Use the following rules when mapping components:

■ A parent integration component must be mapped before mapping a child 
component. For example, the Account Address component cannot be mapped 
unless Account is mapped.

■ User Key fields must be mapped for each integration component if one or more 
fields for the component is mapped. There are two exceptions:

Table 5. Marketing Person Integration Component Description

Component Comment 

Account Maps account information associated with the contact.

Account Address Maps the account address.

Account 
Organization

Maps information about the account’s organization.

Campaign Contact Maps campaign history level information. This integration 
component is not exposed in the user interface as the mappings are 
system generated.

Contact Maps contact-level information such as the contact’s name, 
telephone number, email address, and so on.

Contact Address Maps the contact’s address information.

Contact Key The Contact Key component matches each level in the customer 
hierarchy with the relevant fields in the external database.

For example, Key 1 might be the external Account ID, and Key 2, the 
external Contact ID. By including these keys in the Campaign Load 
Mapping, customer hierarchy keys are recorded in the Siebel 
Marketing Repository.
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■ Siebel Marketing Server will generate user key fields Master Key and Family 
Level ID for the Contact Key integration component. However, Key1 is a 
required field and must be mapped.

■ If Contact Organization is not mapped for a campaign contact, the Marketing 
Server will default the Contact Organization to the organization set for the 
Enterprise server user name (usually SADMIN).

■ Required fields must be mapped for each integration component if one or more 
fields for the component are mapped.

■ Map Contact Keys (Key 1, Key 2, and so on) for the targeting level at which the 
Campaign Load Mapping is defined, and the levels above it. 

For example, a customer hierarchy might have three targeting levels—Household 
(primary targeting level), Individual, and Personal Accounts. You might choose 
the third targeting level, Personal Accounts, as the level for the campaign load 
mapping. If you map the keys for the Personal Accounts level, you must also 
map the keys for the Individual level and Household level. 

When the targeting level that equates to a Siebel Contact is below the level at 
which the Campaign Load Mapping is defined, then the level identifying a Siebel 
Contact should also be mapped. Using the previous example, if you select 
Household as the level for the Campaign Load Mapping, you must map the 
Individual level as well. Typically the targeting level that maps to Contact 
Integration component fields such as first name and last name is the equivalent 
of a Siebel Contact.

■ Siebel Marketing defaults the Account Organization for the campaign contact to 
Default Organization if the account organization field is not mapped.

■ Fields that are mapped to keys should not contain the tilde (~) character. For 
example, if Customer_ID is mapped to Key1, Customer_ID data should not 
contain the tilde character.
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Sample Mappings for Contact Key Components
Table 6 describes examples of Contact Key component mappings for sample 
customer hierarchies.

Table 6. Component Mappings for Sample Customer Hierarchies

Customer Hierarchy
Targeting Level Equal 
to Siebel Contact

Targeting Level for 
Campaign Load 
Mapping

Keys Requiring 
Mapping

Accounts

Contacts

Contacts Accounts Key 1, Key 2

Accounts

Contacts

Contacts Contacts Key 1, Key 2

Business Unit

Account

Decision Maker

Key 4

Customer Customer Customer Key 1

Household

Individual

Individual Household Key 1, Key 2

Household

Individual

Individual Individual Key 1, Key 2

Household

Individual

Personal Account

Individual Individual Key 1, Key 2

Household

Individual

Personal Account

Individual Personal Account Key 1, Key 2, Key 3

Household

Individual

Personal Account 
(Bank Account)

Individual Household Key 1, Key 2
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For more information on targeting levels, see “About Customer Hierarchies” on 
page 105. For more information about eAI, see Overview: Siebel eBusiness 
Application Integration Volume I.

Creating Campaign Load Mappings
The predefined integration object, Marketing Contact, defines the information that 
will be exchanged between the external data source and Siebel Marketing, using eAI 
technology.

To create campaign load mappings

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > External Data Mapping.

2 Click the Campaign Load Mapping view tab.

Organization Decision Maker Business Unit Key 1, Key 2, Key 3

Organization

Business Unit

Account

Decision Maker

Decision Maker Organization Key 1, Key 2, Key 3, 
Key 4

Organization

Business Unit

Account

Decision Maker

Decision Maker Account Key 1, Key 2, Key 3, 
Key 4

Organization

Business Unit

Account

Decision Maker

Decision Maker Decision Maker Key 1, Key 2, Key 3, 
Key 4

Table 6. Component Mappings for Sample Customer Hierarchies

Customer Hierarchy
Targeting Level Equal 
to Siebel Contact

Targeting Level for 
Campaign Load 
Mapping

Keys Requiring 
Mapping
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3 In the Campaign Load Mapping list, create a new record.

4 Complete the necessary fields.

a Type a Name and a Description.

The name and description should identify the purpose of the data mapping 
or the source of the data.

b Click the Customer Hierarchy select button, select a predefined customer 
hierarchy, and click OK.

c Click the Targeting Level select button, select a level, and click OK.

d In the Integration Object field drop-down list, select Marketing Contact 
(default) or Marketing Person. 

For guidelines about when to use each integration object, see “About 
Marketing Integration Objects and Components” on page 56.

5 You can check the flag in the Default field if you want this campaign load 
mapping to be the default mapping for the Marketing application. 

This mapping will be the default mapping each time you create a new program 
or stage. However, you can override the default mapping later. Make sure that 
the default campaign load mapping derives from the default customer hierarchy 
to avoid incompatible defaults.

6 You can set the Allow Repeated Contacts flag by selecting the check box in this 
field.

This allows the same contact to appear more than once in the same campaign. 
For example, if you are marketing to businesses, an individual may be listed as 
a contact for more than one business. You may wish to send an offer to the 
contact at both business locations. The majority of campaigns will not require 
this setting.

Mapping Integration Components and Fields
Before you begin mapping Integration components, create the list measures you 
need, including list measures for Contact First Name, Middle Name, Last Name, 
Key 1, Key 2, and so on (for example, Contact ID, Account ID). For more 
information on creating list measures, see “Defining List Measures” on page 173.
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To map integration components and fields

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > External Data Mapping.

2 Click the Campaign Load Mapping view tab.

3 In the Campaign Load Mapping list, select the format to be mapped.

4 In the Mapping list, create a new record.

5 Create the required mappings for each integration component.

Create as many mappings as you need to fully identify the contact and to provide 
other relevant fields. For more information, see “Mapping Rules for Integration 
Components (Marketing Contact)” on page 59.

If a secondary level is chosen, a customer key must be mapped for that level as 
well as parent levels. For example, if a mapping is created at level 2 of a customer 
hierarchy, then Key 1 and Key 2 should be mapped.

a Choose an integration component from the list. 

Example: Contact

b Choose the Integration Component Field from the list. 

Example: First Name

c Choose a Measure from the list. 

Example: list measure FIRST_NAME

6 Click Save after each mapping record is completed.

7 When you are finished, click Validate. 

Validation makes sure that every mandatory eAI field has been specified.

Validating Campaign Load Mapping
When validating a campaign load mapping, Siebel Marketing checks the mappings 
against the field definitions in the Marketing Repository for each integration 
component in the mapping list. It also verifies that the following requirements are 
met:
64 Siebel Marketing Guide Version 7.5.3



Campaign Load Mapping and Analytic Adapters

About Marketing Integration Objects and Components
■ User Key fields are mapped for every integration component that has at least one 
field mapped by the user.

■ Required fields are mapped.

■ The mapping includes Contact Keys (Key1, Key 2, and so on) for the targeting 
level at which the Campaign Load Mapping is defined, and the levels above it.

■ The parent integration component is mapped for every child component.

Validation does not check the Contact Organization and Account Organization fields 
for the contact integration component because the Marketing Server provides a 
default value if they are not mapped.

Siebel Contact and Campaign History Tables
When you generate a contact list (Load Campaign), the Marketing Server modifies 
data in the Siebel database after Contact and Contact Key integration components 
are mapped and campaign load mapping data is modified.

■ Contacts table (S_CONTACT). The Contacts table stores contact-level information.

■ Campaign History table (S_CAMP_CON). The Campaign History table contains the 
history of contacts that qualify for campaigns, as well as the Campaigns ID, 
Segment ID, Wave ID, and so on.

■ External Keys table (S_DD_USER_KEY). The External Keys table contains customer 
hierarchy keys data for a contact in addition to target-level ID. Database keys 
(such as Account Number and Customer ID) that are mapped to the Contact Key 
integration component fields for each targeting level are recorded in this table 
for every contact targeted by a marketing program.

If you include optional integration component fields such as Account or Contact 
Address in the campaign load mapping, other Siebel tables are updated with data 
according to the integration fields that are mapped.
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For every record that qualifies for a campaign the Campaign Load process first 
determines if the contact record exists based on the Contact component user key. 
The following actions are performed, as shown in Table 7:

NOTE: If you use the Marketing Contact integration object, the lookup uses the User 
Key fields for Contacts and Accounts (see Figure 1 on page 58). If you use the 
Marketing Person integration object, the lookup only requires the Contact ID or 
Prospect ID to confirm that the person is present in the transaction database.

Creating Campaign Load Mappings for Target Group Segments
For Target Group segments, all campaign load mapping information will come from 
logical columns in a Siebel Analytics subject area. To create a campaign load 
mapping for your subject area perform the following tasks:

■ Create list measures for all required mapping fields plus any other information 
you want to import for the campaign.

For example, you need to create a list measure for Contact First Name which 
maps to a Siebel Analytics logical column such as "Consumers"."First Name" 
(or the logical column that corresponds to First Name in the selected 
segmentation subject area).

■ After you create the list measures, create a campaign load mapping based on the 
customer hierarchy that is mapped to the target group segment subject area and 
load tables.

Table 7. Campaign Load Table Update Rules

Siebel Contact Record S_CONTACT S_DD_USER_KEY S_CAMP_CON

Exists Update existing 
record

Update existing record Insert new record

Does not exist Insert new record Insert new record Insert new record
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Using the Marketing Person Integration Object
Most deployments of the Siebel Marketing application use the Marketing Contact 
Integration Object for loading campaign data. Marketing Contact Integration Object 
is most commonly used because it supports inserting new contact and account 
names in the transaction database.

The Marketing Person integration object should be used only when all target 
contacts and prospects in the campaign already exist in the transaction database. 
The only mapping required is a mapping between the Row ID from the Contact and 
Prospect tables in the Siebel transaction database and the external data source, 
typically the Siebel Data Warehouse.

The Marketing Person integration object contains the two integration components 
described in Table 8.

Mapping Rules for Integration Components (Marketing Person)
When creating a campaign load mapping using the Marketing Person integration 
object, use the following guidelines:

■ Only the Contact Key integration component is required to be mapped. The only 
required field is Key 1.

■ The Contact ID and Prospect ID values imported from the external data source 
must match the Row IDs for the Contact or Prospect in the Siebel contact or 
prospect tables.

Table 8. Marketing Person Integration Component Description

Component Comment 

Campaign Contact Identifies the Account ID for the contact (Optional)

Contact Key Maps the Contact and Prospect IDs from the external data source 
(Required)
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■ A Campaign Load Mapping can only be mapped to a single source table for 
contact information. Because a program stage and all included campaigns can 
use only a single campaign load mapping, this means that a campaign is limited 
to a single source table for contacts or prospects.

In a single campaign load record, you can map an integration component's 
integration component field to only one measure. For example, in a campaign 
load record for the Contact integration component, if you map the First Name 
integration component field to a measure called HH First Name, you cannot 
create another mapping record in the same campaign load mapping for the First 
Name integration component field to a different measure.

■ If all incoming target names are contacts, then you do not need to map Prospect 
ID. Alternatively, you might use the Marketing Contact integration object. If all 
incoming target names are prospects, then you do not need to use Contact ID. If 
the target list includes both contacts and prospects, then both fields are required.

■ Mappings for the Campaign Contact integration component are required only if 
Allow Repeated Contacts is selected for the campaign load mapping. This is 
because a contact might appear in the campaign for more than one account.

To create a campaign load mapping using the Marketing Person integration object

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > External Data Mapping.

2 Map the data source table that contains Contact ID and Prospect ID. For the 
Siebel Data Warehouse, this table is W_PERSON_D.

3 Click the Tables view tab and add two pseudo-fields to the table using the 
following information:

4 From the Show drop-down list, select Measures.

Reference Name Expression

Contact_ID Case when contact_type_i = ‘Contact’ then 
integration_id else null end

Prospect_ID Case when contact_type_i = ‘Prospect’ then 
integration_id else null end
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5 Click the List view tab and create list measures for the following:

a Contact_ID.

b Prospect_ID.

6 Create a list measure for Customer or Integration ID in the Data Warehouse (this 
value will map to Key 1).

In the Siebel Data Warehouse, this field is INTEGRATION_ID field in the 
W_PERSON_D table and should uniquely identify the contact or prospect in the 
external data source.

7 From the Show drop-down list, select External Data Mapping and click the 
Campaign Load Mapping view tab.

8 In the Campaign Load Mapping list, create a new record, selecting Marketing 
Person in the Integration Object field.

9 In the Mappings list, create a new record.

a In the new record, select the Contact Key integration component and map the 
following fields:

b As an optional step, if you selected the Allow Repeated Contacts check box, 
create another record in the mappings list for the Campaign Contact 
integration component and map the Account ID field.

10 Create a new customer hierarchy with one targeting level, mapping the 
Integration ID field from the external table to the targeting level.

For instructions, see procedures in “Creating Customer Hierarchies” on 
page 109.

Integration Component Field Measure

Contact Id Contact ID

Key 1 Integration ID

Prospect Id Prospect ID
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Recommended Campaign Load Mappings–Examples
Settings for campaign load mappings depend on the following:

■ The Data source. The data source includes Siebel Data Warehouse, Siebel 
database, or a non-Siebel data source.

■ The Data elements required to be imported into Siebel. These elements include 
Contact fields, Account fields, Contact address, and so on.

■ Contact Qualification. Determine if new contacts or existing contacts qualify for a 
campaign.

■ Presence of contacts and prospects in the Siebel database. Determine if all contacts 
and prospects are already present in the contact and prospect tables in the Siebel 
database.

The examples in this section describe a few recommended mappings. The examples 
do not include all the required fields but do provide the recommended field 
mappings for certain integration component fields.

The following topics contain examples of recommended campaign load mappings:

■ Mapping to the Siebel Data Warehouse

■ Mapping to the Siebel Database

■ Mapping to a Non-Siebel Database

Mapping to the Siebel Data Warehouse
Table 9 on page 71 contains the recommended mappings when no contacts have 
been deleted and no new contacts have been added to the Siebel database during 
Campaign Load. Use the recommended mappings in Table 10 on page 72 when 
contacts have been deleted. Other fields from available components may need to be 
mapped based on program or campaign requirements.

Table 9 on page 71 shows the recommended mappings when the following 
conditions are met:

■ Data source. Siebel Data Warehouse.
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■ New contacts. No new contacts added to Siebel database during Campaign Load 
and no contacts deleted.

■ Prospects. Prospects are not included in the campaign.

■ Customer hierarchy. Accounts to Contacts.

Table 10 on page 72 shows the recommended mappings when the following 
conditions are met:

■ Data source. Siebel Data Warehouse.

■ New contacts. Contacts have been deleted.

■ Prospects. Prospects are not included in the campaign.

■ Customer hierarchy. Accounts to Contacts.

Table 9. Mapping to the Siebel Data Warehouse

Integration 
Component

Integration 
Component 
Field List Measure Field Comment

Contact Person UID W_PERSON_D.PRSP_CON_UID

Contact Contact 
Organization

W_PERSON_D.CON_BU_NAME

Contact Key Key 1 W_PERSON_F.ACCNT_WID, 
W_ORG_D.ROW_ID

The field can vary 
depending on 
customer hierarchy 
mappings.

Contact Key Key 2 W_PERSON_F.CONTACT_WID, 
W_CONTACT_DM.ROW_WID

The field can vary 
depending on 
customer hierarchy 
mappings.
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Siebel Data Warehouse may not be synchronized with the Siebel database when 
contacts have been deleted and the deleted contacts should not be included in 
campaigns. Use the recommended mappings in Table 10 when contacts have been 
deleted.

Mapping to the Siebel Database
Use the recommended mappings in Table 11 on page 73 when prospects are not 
included in the campaign. Use the recommended mappings in Table 12 on page 74 
when prospects might be included. Other fields from available components may 
need to be mapped based on program or campaign requirements. 

Table 11 shows recommended mappings when the following conditions are met:

■ Data Source. Siebel database.

■ Prospects. Prospects are not included in the campaign.

Table 10. Mapping to the Siebel Data Warehouse When Contacts Deleted

Integration 
Component

Integration 
Component 
Field List Measure Field Comment

Contact Person UID S_CONTACT.PERSON_UID Equal join from 
W_PERSON_D.PRSP_CON_
UID to 
S_CONTACT.PERSON_UID.

Contact Contact 
Organization

S_BU.NAME Equal join 
S_CONTACT.BU_ID to 
S_BU.PAR.ROW_ID.

Contact Key Key 1 W_PERSON_F.ACCNT_WI
D, W_ORG_D.ROW_ID

The field can vary 
depending on customer 
hierarchy mappings.

Contact Key Key 2 W_PERSON_F.CONTACT_
WID, 
W_CONTACT_DM.ROW_
WID

The field can vary 
depending on customer 
hierarchy mappings.
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■ Customer hierarchy. Accounts to Contacts.

Use the recommended mappings in Table 12 on page 74 when the following 
conditions are met:

■ Data Source. Siebel database.

■ Prospects. Prospects might be included in the campaign.

■ New contacts. No new contacts or prospects are introduced into the Siebel 
database during Campaign Load.

Table 11. Mapping to the Siebel Database–Prospects Not Included

Integration 
Component

Integration 
Component 
Field List Measure Field Comment

Contact Person UID S_CONTACT.PERSON_UID Equal join from 
W_PERSON_D.PRSP
_CON_UID to 
S_CONTACT.PERSO
N_UID.

Contact Contact 
Organization

S_BU.NAME Equal join 
S_CONTACT.BU_ID 
to 
S_BU.PAR_ROW_ID.

Contact Key Key 1 S_ORG_EXT.ROW_ID The field can vary 
depending on 
customer hierarchy 
mappings.

Contact Key Key 2 S_CONTACT.ROW_ID The field can vary 
depending on 
customer hierarchy 
mappings.
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■ Customer hierarchy. Person (one targeting level).

Mapping to a Non-Siebel Database
Use the recommended mappings shown in Table 13 on page 75 when new contacts 
are added to the Siebel database during Campaign Load. Use the recommended 
mappings shown in Table 14 on page 76 when new contacts are added to the Siebel 
database during Campaign Load. Other fields from available components may need 
to be mapped based on program or campaign requirements. 

Table 13 on page 75 contains the recommended minimum mapping requirement 
when the following conditions are met:

■ Data source. Non-Siebel database.

■ New contacts. New contacts are introduced into the Siebel database during 
Campaign Load. External contacts have a pre-assigned Organization.

Table 12. Mapping to the Siebel Database–Prospects Might Be Included

Integration 
Component 

Integration Component 
Field List Measure 

Contact Key Key 1 Integration ID

Contact Key Contact Id Contact ID (Pseudo-field)

Contact Key Prospect Id Prospect ID (Pseudo-field)
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■ Customer hierarchy. Household to Individual.

Table 14 on page 76 contains the recommended minimum mapping requirement 
when the following conditions are met:

■ Data source. Non-Siebel database.

■ New contacts. During campaign load, no new contacts are introduced into the 
Siebel database. External contacts do not have a preassigned organization.

■ Customer hierarchy. Household to Individual.

Table 13. Mapping to a Non-Siebel Database–New Contacts in Campaign Load

Integration 
Component 

Integration 
Component 
Field Required List Measure Comment

Contact Person UID Yes Individual ID ID of the customer 
hierarchy mapping to 
Siebel Contact.

Contact Contact 
Organization

No Organization field The organization names in 
the source database must 
match exactly with Siebel 
organization setup (S_BU).

Contact First Name Yes Individual’s First 
Name

Contact Last Name Yes Individual’s Last 
Name

Contact Key Key 1 Yes Household ID

Contact Key Key 2 No Individual ID
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■ Targeting level equivalent to Siebel Contact. Individual.

Table 14. Mapping to a Non-Siebel Database–No New Contacts in Campaign Load

Integration 
Component

Integration 
Component Field Required List Measure Comment

Contact Person UID Yes Individual ID ID of the 
customer 
hierarchy 
mapping to Siebel 
Contact.

Contact Key Key 1 Yes Household ID

Contact Key Key 2 No Individual ID
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About Analytic Adapters 
An analytic adapter is a data interface that allows Siebel Marketing to integrate and 
use analysis results from Siebel Analytics, other analysis applications, query tools, 
online analytical processing (OLAP) tools, and scores from data mining tools.

The analysis results, called target groups, consist of sets of customers sharing 
similar attributes. Target groups can be derived from various targeting levels such 
as Contacts, Accounts, Households, and Individuals. Target groups can also include 
related data elements such as model scores, cluster numbers, and lifetime values.

During the analytic adapter process, the target groups are loaded into prebuilt 
analytical adapter tables in the Siebel database. You can map these tables to build 
hierarchical attributes, measures, buckets, and fields to be used in the following:

■ Segmentation criteria

■ Filter criteria

■ Output file layouts

■ Launching campaigns

An analytic adapter includes the following components:

■ Extractor. This component extracts results from the analytical tool or application. 
Siebel Marketing partners or customers who use Siebel Analytics develop the 
extractor, which is custom-configured for each analytical tool. An Analytic 
Adapter extractor for Siebel Analytics is included as part of the Marketing Server 
component group.

■ Analytic adapter tables. These tables in the Siebel database hold information 
related to analytic adapter target groups. 

■ The Analytic Adapter lookup table (S_DD_TRGT_GRP) holds information 
about the target group, including fields such as Name, Source, Number of 
records, Created date, and Expiration date. 

■ The Analytic Adapter data table (X_DD_TRGTGRPMBR) holds target group 
details and a link (foreign key) to the Analytic Adapter lookup table. The data 
table can hold up to seven target group attributes or fields that might include 
customer hierarchy IDs and related information. In addition, there is one 
placeholder for a data mining score.
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■ Analytic Adapter workflow process. This workflow process creates a target group 
record in the Analytic Adapter lookup table and loads data into the Analytic 
Adapter data table.

The workflow runs the Analytic Adapter server component, that is part of 
Marketing Server component Group. The workflow process also retrieves data for 
attribute families defined on the Analytic Adapter data table, so that the latest list 
of target groups is visible and accessible to the marketer. The Analytic Adapter 
workflow process for Siebel Analytics is called Analytic Adapter. For more 
information on workflow processes and the Siebel Business Process Designer, see 
Siebel Business Process Designer Administration Guide.

To complete the setup for Analytic Adapters, perform the following tasks:

■ Setting Up Analytic Adapters

■ Editing the Workflow Process for Siebel Analytics on page 81

■ Creating Analytic Adapter Workflow Process for Other Analytic Tools on page 82

■ Loading Target Groups on page 84

■ Checking the Target Group Load on page 85

Setting Up Analytic Adapters
Mappings and other setup procedures that need to be performed on Analytic 
Adapter tables depend on the type of information imported into Siebel Marketing 
and other end-user requirements. 

Some general recommendations for mapping tables, setting up joins, and building 
attribute families are provided in the following sections. For details, see Chapter 4, 
“External Data Mapping.”

Mapping Tables for Analytic Adapters
Map the following tables from Siebel Marketing Repository server:

■ Analytic Adapter data table (X_DD_TRGTGRPMBR). Set the table Type as 
Analytic Adapter.

■ Analytic Adapter lookup table (S_DD_TRGT_GRP). Set the table Type as Regular.
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Mapping Analytic Adapter Tables to a Customer Hierarchy
The mapping depends on the level at which the data is exported from the analytic 
tool and the Siebel Marketing customer hierarchy. Table 15 shows some sample 
mappings.

Creating Joins for Analytic Adapters
In the Joins view, you must join the customer table in the data source to the 
Analytic Adapter data table. The parent table and the joining fields depend on the 
level at which the data is exported from the analytical tool. In the join examples 
shown in Table 16 on page 80, the parent table may differ depending on your 
implementation requirements.

■ Join X_DD_TRGTGRPMBR to S_DD_TRGT_GRP using the S_DD_TRGT_GRP_ID 
and ROW_ID fields respectively. Set this join for Cache.

■ Set up a start point join to both the Analytic Adapter data table and the lookup 
table.

Table 15. Sample Mapping to Customer Hierarchy

Data Source Exported Data
Customer 
Hierarchy Mappings Comment

Siebel Data 
Warehouse

Account ID, 
Contact ID

Account to 
Contact

X_DD_TRGTGRP
MBR.KEY_01 to 
Account Level 
and 
X_DD_TRGTGRP
MBR.KEY_02 to 
Contact level

Siebel Data 
Warehouse

Contact ID Account to 
Contact

No 
mappings 
needed

External Data 
Source

Customer ID, 
Model score

Customer X_DD_TRGTGRP
MBR.KEY_01 to 
Targeting level

External Data 
Source

Individual ID Household to 
Individual

No 
mappings 
needed
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The sample joins may need to be set as Outer joins, if records that are not part of 
the target group are needed for a snapshot build (for example, if you are combining 
members of a target group with other contacts in your database). In addition, the 
joins should be designed for Cache (Cache check box) if X_DD_TRGTGRPMBR is 
not mapped in the Customer Hierarchies view.

Using Fields for Data Retrieval
Enable the target group name in the Analytic Adapter Lookup table for Data 
Retrieval (S_DD_TRGT_GRP.NAME). Data is not automatically retrieved for this 
field after a target group load. 

Table 16. Sample Joins

Data Source
Exported 
Data

Customer 
Hierarchy Parent Table Join

Siebel Data 
Warehouse

Account ID, 
Contact ID

Account to 
Contact

W_PERSON_F W_PERSON_F.ACCNT
_WID to 
X_DD_TRGTGRPMBR.
KEY_01 and 
W_PERSON_F.CONTA
CT_WID to 
X_DD_TRGTGRPMBR.
KEY_02

Siebel Data 
Warehouse

Contact ID Account to 
Contact

W_PERSON_F.C
ONTACT_WID

W_PERSON_F.CONTA
CT_WID to 
X_DD_TRGTGRPMBR.
KEY_01

External Data 
Source

Customer 
ID, Model 
score

Customer CUSTOMER.ID to 
X_DD_TRGTGRPMBR.
KEY_01

External Data 
Source

Individual 
ID

Household 
to 
Individual

INDIVIDUAL.ID to 
X_DD_TRGTGRPMBR.
KEY_01
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Creating Attribute Families for Analytic Adapters
You must create an attribute family based on the Analytic Adapter tables, using the 
source of the Target Group and the Target Group Name as attributes. The base field 
is X_DD_TRGTGRPMBR.DD_TRGT_GRP_ID. The attributes are detailed in Table 17.

When you have finished defining the attribute family, define an attribute hierarchy 
using Sources to Target Groups as attributes in the hierarchy.

Editing the Workflow Process for Siebel Analytics
The Analytic Adapter workflow process is used to load target groups for Siebel 
Analytics. You can add the Analytic Adapter data table to this workflow for Siebel 
Analytics. For more information on workflow processes and the Siebel Business 
Process Designer, see Siebel Business Process Designer Administration Guide.

To add the Analytic Adapter data table to the workflow process

1 From the application-level menu, choose View > Site Map > Business Process 
Administration > Workflow Processes.

2 In the Workflow Processes list, select the Analytic Adapters workflow process 
and click the Process Properties view tab.

3 In the Process Properties list, locate the TableReference property.

4 In the Default String field, type the reference name of the Analytic Adapter data 
table that you plan to use.

5 Save the modified record.

Table 17. Attributes for Attribute Family

Attribute Name Code Table Code Field Label Table Label Field

Target Groups S_DD_TRGT_GRP ROWID S_DD_TRGT_GRP NAME

Sources S_DD_TRGT_GRP SRC_TOOL_NAME S_DD_TRGT_GRP SRC_TOOL_NAME
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Creating Analytic Adapter Workflow Process for Other Analytic Tools
Create an Analytic Adapter workflow process for each analytical tool from which 
data will be loaded using the Analytic Adapter.

NOTE: You do not need to add a process for Siebel Analytic Adapter.

To set up a new workflow process

1 From the application-level menu, choose View > Site Map > Business Process 
Administration > Workflow Processes.

2 In the Workflow Processes list, select the Analytic Adapters workflow process.

3 Copy the Analytic Adapter workflow process, and name the copy.

a Click the menu button and choose Copy Record.

b In the name field, type a name for the copy, and save the record.

4 In the Workflow Processes list, select the new process and click the Process 
Properties view tab.

5 Change the properties for the new workflow process using Table 18 on page 83 
as a guide. 

6 Click the All Processes view tab to return to the Workflow Processes list.
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7 In the Workflow Processes list, click Activate when the workflow is ready to use.

The property values that you set are defaults and can be changed during a target 
group load.

Table 18. Workflow Process Properties

Property Name Field Action

AnalyticTool In the Default String Field, change the value to the name of the 
Analytical tool. 

This parameter stores the source of the Target Group in 
S_DD_TRGT_GRP.SRC_TOOL_NAME

NumberOfDataKeys In the Default Number field, type the number of data elements 
that will be exported from the analytical tool, excluding the data 
mining score. 

For example, if customer ID and a model score will be extracted 
from an analytical tool, then type 1 for this property.

Process Name In the Default String field, type the name of the new workflow 
process.

ReportFileName In the Default String field type the path to the directory where the 
target groups for the analytical tool are stored.

This optional property stores the path and file name of the target 
group.

TableReference In the Default String field, type the reference name for the Analytic 
Adapter data table.

TargetGroupName In the Default String field, type a default name for the target group.

This optional property is the name of the target group stored in 
S_DD_TRGT_GRP.NAME.
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Loading Target Groups
Multiple Target Groups can be loaded into the Siebel database using the appropriate 
workflow process. The source file for Analytic Adapters should not contain 
quotation marks, and the file should have a fixed format with tab-delimited data in 
each row tab.

NOTE: Target Groups created in Siebel Analytics are automatically loaded into the 
Siebel database. For information, see “About Target Group Segmentation” on 
page 251.

To load target groups

1 From the application-level menu, choose View > Site Map > Business Process 
Administration > Workflow Processes.

2 In the Workflow Processes list, select the Analytic Adapters workflow process 
created for the target group.

3 Click the Process Simulator view tab.

For details, see “Creating Analytic Adapter Workflow Process for Other Analytic 
Tools” on page 82.

4 In the Simulator designer, click Start.

5 In the Process Simulator list, click the select button in the Process Property 
Name field.

6 In the list of properties, modify the default values for properties such as 
TargetGroupName, ReportFileName, and so on.

7 Save the changes and click Close to close the properties list.

8 In the Simulator designer, click Continue.

In the Process Simulator list, the status of Completed in the Process Status field 
indicates that a request to the server to load the target group has been submitted. 

An existing target group is overwritten if a new target group with the same name is 
loaded. The target group record is written to the Analytic Adapter lookup table 
(S_DD_TRGT_GRP table) when the server component starts the load process.
84 Siebel Marketing Guide Version 7.5.3



Campaign Load Mapping and Analytic Adapters

About Analytic Adapters
The first column of a target group (Key_01) cannot have a null value because a not-
null database index exists on the Key_01 column.

Checking the Target Group Load
Siebel Marketing’s Analytic Adapters view allows you to verify the target group has 
loaded and is visible in the Analytic Adapters list.

To verify that the target load completed successfully

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > External Data Mapping.

2 Click the Analytic Adapters view tab.

The Analytic Adapters list shows the server and table names for the analytic 
adapter, for example, SQLServer MetaModel and 
user_name.X_DD_TRGRGRPMBR.

3 In the read-only Target Groups list, locate your target group. 

The following table describes the information that is displayed in the fields.

Field Comment

Count The number of contacts in the target group. This number is provided 
by Siebel Marketing when the target group is loaded. If this field is 
blank, the target group has not yet been loaded.

Date Loaded The date the target group was loaded.

Description Automatically populated with the target group’s description.

Expiration Date The date the selected target group expires.

File Name Provides the name of the Target Group file.

Name Provides the path name to the target group. The file can reside in any 
directory specified by your marketing administrator.

Source Siebel Analytics, or another source for the data.
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This chapter contains information about mapping server definitions, tables and 
fields, and customer hierarchies. In addition, it describes how to join tables from 
the data sources and map them to customer hierarchies. Information about joining 
tables and fields provides a way to associate and merge related data from data 
sources into Siebel Repository tables and fields. For more information, see the 
following topics:

■ About Server Definitions on page 88

■ Mapping to Tables from the Servers View Tab on page 90

■ Working With Tables on page 91

■ Working With Fields on page 100

■ About Customer Hierarchies on page 105

■ Designing Customer Hierarchies on page 106

■ Creating Customer Hierarchies and Adding Targeting Levels on page 108

■ Mapping Tables to Customer Hierarchies on page 110

■ Understanding Joins on page 113

■ Joining Tables and Fields on page 118

■ Setting Up Target Group Segment Tables and Joins on page 125
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About Server Definitions
Siebel Marketing can access multiple servers (data sources) that hold customer 
data. When you create server definitions, you provide the ODBC connection 
information to access selected tables in each of your supported relational database 
management system (RDBMS) sources. Siebel Marketing Server also connects to the 
Marketing Repository tables in the same way that it accesses other data sources.

Because Siebel Marketing can extract information from multiple servers 
simultaneously and can join tables that are in separate RDBMSs, you can create as 
many data source server definitions as necessary. For example, if customer data and 
transactions data are in separate physical databases, you might create two Data 
Source server definitions. For more information, see “Creating Server Definitions” 
on page 89.

The Marketing Repository is a set of tables that record the information to support 
Marketing Server processes such as segment criteria, attributes, measures, and data 
mapping metadata. In addition, it handles processes for counts, snapshots, and 
lists. The Marketing Repository consists of a set of system tables in the Siebel 
database, thus it shares the same system DSN as the main Siebel Database. 
Although the Marketing Repository record can only be created once, the values for 
the reference name, DSN, user name, and password can be updated at any time.

As part of initialization, an administrator needs to set up a server of type Marketing 
Repository that points to the Siebel transactional database so that the Marketing 
Server can map and join temporary tables (attribute tables) that are created by the 
Marketing Server during data synchronization. There can be only one Marketing 
Repository server and the user name and password must match the Siebel OLTP 
table owner.

■ Marketing Server. Refers to the metadata contained in the Marketing Repository 
tables before performing tasks such as a records extract, count, or data retrieval.

■ Test Server. If you are testing new measures and attributes and your data 
warehouse has many millions of records, you may benefit from creating a special 
test server that loads only a fraction of your total records. Creating a test server 
can save time when designing and testing measures and attributes, as well as 
freeing the main server for other work.
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Creating Server Definitions
Using the Servers view tab, you can create definitions that point to each data source 
server and the Marketing Repository server. The Siebel server does not validate the 
data source name (DSN). You need to make sure that the DSN is valid and points 
to the correct data source. For Windows NT, make sure that the DSN is a system 
DSN on NT to avoid errors that could result from using different NT logins.

NOTE: For data integrity reasons, once you have saved a server definition, you 
cannot delete the server definition from the list.

To add a new server definition for a data source

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > External Data Mapping.

2 In the Servers list, create a new record.

3 Complete the necessary fields for each server record, using the following table 
as a guide.

Field Comment

Name Type a name for the server. The server name does not have to correspond 
to an actual server name on your network.

ODBC DSN Type the ODBC Data Source Name (DSN) exactly as identified in the 
ODBC control panel. 

Password Type the user password.

Type Choose Data Source (default) or Marketing Repository. 

If the Marketing Repository server definition already exists, you must 
choose Data Source as the server Type. You can create more than one 
Data Source Server, depending on how your data is stored. Only one 
Marketing Repository server can be defined. If you attempt to define a 
second Marketing Repository Server, an error message is displayed.

User Name Type a user name. Be sure to check whether your database has a case-
sensitive user name and password before mapping tables.
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Mapping to Tables from the Servers View Tab
You use the Tables list in the Servers view tab to add and view tables associated 
with a particular data source server. Tables in this view are sorted by data source 
(server) definition.

You can also map to tables using the Tables view tab, where the list of tables is 
sorted alphabetically. For details, see “Working With Tables” on page 91.

To map to tables from the Servers list

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > External Data Mapping.

2 In the Servers list, select the server record.

3 In the Tables list, create a new record.

4 In the new record, complete the fields, using Table 19 on page 93 as a guide.

NOTE: Be sure you spell the table name correctly and preface the table name with 
the database table owner name (for example, Table_Owner.Table_Name). The 
table owner name may be different from the User Name for the data source 
Server record in the Servers list.
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Working With Tables
Siebel Marketing can use data from any supported ODBC-accessible data source. 
Typically data source means your data warehouse or data mart, but you can use 
imported data (such as a file with demographics information).

NOTE: Because some databases such as Oracle do not support Unicode characters in 
their table names, we cannot support Unicode characters in table names and field 
names in the Siebel Data Warehouse.

Sometimes, the underlying data source tables need to be renamed or moved to a 
different schema or database instance. To preserve the mappings and other 
definitions that are sourced from this table, perform the following tasks:

■ If the table was renamed, edit the appropriate table record in Tables view to 
reflect the change. 

■ If the table was moved, create a new DSN (if one does not exist) to the new 
location, edit the table record, and change the DSN.

NOTE: There is no system validation to verify that a table record is edited correctly.

To map tables, perform the following tasks:

■ Mapping Tables From a Data Source on page 92

■ Understanding Partition and Union Tables on page 94

■ Creating Union and Partition Tables on page 98
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Mapping Tables From a Data Source
When you add (map) a table in Siebel Marketing Administration, a server process 
links to the physical table in the data source and maps the definition of its fields. 
Because you might need the same data for many different purposes, you can map 
a table multiple times. The process to retrieve the table definition is referred to as a 
data dictionary task.

NOTE: You cannot delete a table after it is saved because others may be using fields 
from an existing table.

Use the Tables view to map the Marketing Server metadata to tables within your 
target data source that contain data relevant to your marketing programs and 
campaigns. 

To map a table

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > External Data Mapping.

2 Click the Tables view tab.

3 In the Tables list, create a new record.
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4 Complete the necessary fields, using Table 19 as a guide, and save the record.

Table 19. Table Fields

Field Description

Constraint (Optional) Type a constraint (SQL expression) to create a restricted 
view of the table by applying SQL WHERE clauses to the table. 
Constraints are applied every time the table is accessed. The syntax of 
the clause is not validated when you add the table record. If you want 
to apply Program or Stage specific constraints use the Filter 
functionality. The Marketing Server will prefix the constraint with 
WHERE before executing SQL For examples, see the following list:

■ If you want to create a subset of a transaction table for a specific 
geographic region, you might type the constraint: State=CA.

■ If you want to create a constraint limiting the data to accounts with 
an opening balance greater than $500,000, you might type 
OPENING_BALANCE>500000.

The field name for a constraint should be in upper case for SQL Server 
databases.

If you add a constraint to a union table, the constraint applies to each 
of the partition tables as well.

Description Type a description for the new table. If it is a union or partition table, 
note that in the description.

Reference Name Type a name for the table as you would want it to appear in the Tables 
list. 

If you are not adding a constraint (SQL expression), you might want to 
use the same value as in the Table Name field. If you are using a 
constraint, you should use a name that indicates the original table’s 
name and the constraint.

Server Click the Server select button. In the Pick Server dialog box, choose a 
previously defined data source server, and click OK. 

If the Marketing Repository server is not listed as an option, create this 
server definition before continuing.

Size Not currently used. You can type the estimated number of records 
(rows) in the table. The default is 100.
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Understanding Partition and Union Tables
In large data warehouses, tables can grow to an unmanageable size. Typically, this 
occurs with tables containing transaction data that expands over time. You can use 
the following table types to manage table size:

Table Name Type the name of the table to which you are mapping or linking, using 
this form: TableOwner.ActualTableName. 

The table name is case sensitive because supported platforms have 
different requirements. Use the following convention when typing table 
names:

■ IBM DB2. The tableowner and table name should always be 
uppercase, for example, TABLEOWNER_NAME.TABLE_NAME.

■ Microsoft SQL Server. The tableowner is case sensitive, and the 
table name should always be uppercase, for example, 
tableowner_name.TABLE_NAME. If the table name is not 
uppercase, attribute synchronization fails.

■ ORACLE. The tableowner should always be uppercase. The table 
name case does not matter. For example, 
TABLEOWNER_NAME.TABLE_NAME, or 
TABLEOWNER_NAME.table_name.

If you want to create union or partition tables, see “Understanding 
Partition and Union Tables” on page 94.

Table Type Choose the Table Type from the list of values. Options are Regular, 
Union, or Analytic Adapters.

Most tables will be of type Regular.

Use Union tables only if you are partitioning large tables. For more 
information on creating union tables, see “Understanding Partition and 
Union Tables” on page 94.

Analytic Adapter tables have a specific structure that accommodates 
data import from a third-party analysis tool. When you load tables 
using the Analytic Adapters view, only tables of type Analytic Adapter 
appear in the Analytic Adapters view list. For more details, see “About 
Analytic Adapters” on page 77.

You cannot change the table type after the table is saved.

Table 19. Table Fields

Field Description
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■ Partition tables. Large tables can be divided into smaller tables (partitioned) to 
improve performance. Partition tables can be individually accessed.

■ Union tables. Tables created to logically (not physically) reconnect the partition 
tables.

Union tables cannot be used as pass-through tables. You use information in 
pass-through tables to join one table to another but you cannot use any of the 
union table’s data in your list. For example, you have three tables labeled A-C-
D. Table C is a union table. If you need to use data from table C in your list, you 
cannot use table C as a pass-through table. You must select a different pass-
through table, perhaps one of the partitioned tables in your union table.

Consider the following guidelines when creating union tables:

■ Have identical common fields. The partition tables must have common fields for 
you to include those fields in a union table. Therefore, the reference name, 
expression, data type, and data size for each field must be identical across 
partitions. The comparison process is case sensitive. For example, the expression 
AAA would be evaluated differently than the expression Aaa.

CAUTION: Some tasks will fail if Marketing cannot use the Merge method with 
union tables. For additional information, see “Understanding Joins” on page 113 
and “Designing Customer Hierarchies” on page 106.

■ Use at least two tables. You can create a union table that has only one partition 
table. However, the purpose of creating a union table is to join two or more 
partition tables.

The following examples illustrate union table rules.

Example 1. You want to create a union table that uses three partition tables. Because 
the five fields in each partition table are identical, the union table contains the five 
fields.

Partition 1 Partition 2 Partition 3 Union

Field1 Field1 Field1 Field1

Field2 Field2 Field2 Field2
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Example 2. You want to create a union table using partition tables that have no 
common fields. The union table contains no fields.

Example 3. You want to create a union table using three partition tables. Examples 
1 and 3 have common fields. However, because Example 2 fields are not identical, 
the union table contains no fields.

Field3 Field3 Field3 Field3

Field4 Field4 Field4 Field4

Field5 Field5 Field5 Field5

Partition 1 Partition 2 Union

Field1 Field6

Field2 Field7

Field3 Field8

Field4 Field9

Field5 Field10

Partition 1 Partition 2 Partition 3 Union

Field1 Field6 Field1

Field2 Field7 Field2

Field3 Field8 Field3

Field4 Field9 Field4

Field5 Field10 Field5

Partition 1 Partition 2 Partition 3 Union
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Example 4. You want to create a union table using three partition tables. The tables 
have some fields which are identical, and others that are not. The fields that are 
identical across the three tables are included in the union table.

Example 5. You are editing partition tables and plan to create a new union table. You 
add a new field to each partition table. However, the fields are not identical. The 
new union table reflects no changes from the old union table.

Partition 1 Partition 2 Partition 3 Union

Field1 Field1 Field1 Field1

Field2 Field7 Field2

Field3 Field8 Field3

Field4 Field4 Field4 Field4

Field5 Field10 Field5

Old Union Partition 1 Partition 2 New Union

Field1 Field1 Field1 Field1

Field2 Field2 Field2 Field2

Field3 Field3 Field3 Field3

Field4 Field4 Field4 Field4

Field5 Field5 Field5 Field5

Field6 Field7
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Example 6. You are editing partition tables and plan to create a new union table. You 
add a new field to each partition table, and the fields are identical. The new union 
table reflects the addition of the new field.

Creating Union and Partition Tables
Use the Partition Tables view to associate partition tables to a union table you have 
created. When you partition transaction data, you typically choose a date field as 
the partition field. This method allows you to create separate tables for data such 
as time periods (1999, 2000, 2001). Some companies need to partition by months 
and even weeks to keep tables at a manageable size.

■ Create the partition tables as you would any other table, with the table Type as 
Regular. If required, apply a constraint statement to the table (for example, 
CUSTOMER_ID < '1004000402') to restrict the records accessed in that 
partition. 

■ When creating partition tables, use the description field to indicate that these 
records are partition tables. For example, you might use Transactions Partition 1 
as the description for one partition table and Transactions Partition 2 as the 
description for another.

■ When creating a union table, designate the table as a union table by choosing 
Union as the type. In this case, you do not need to specify a data source server 
or a table name. For a better understanding of the rules governing union tables, 
see “Understanding Partition and Union Tables” on page 94.

Old Union Partition 1 Partition 2 New Union

Field1 Field1 Field1 Field1

Field2 Field2 Field2 Field2

Field3 Field3 Field3 Field3

Field4 Field4 Field4 Field4

Field5 Field5 Field5 Field5

Field6 Field6 Field6
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■ Table names for physical tables are typically in uppercase letters. To make the 
table names easier to identify, make only the first letter of each word in the 
union table name uppercase, for example, Transactions_All.

■ If you modify the partition tables to add new fields, you can regenerate the union 
table by clicking Create Union Table again.

To create union tables with associated partition tables

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > External Data Mapping.

2 Click the Partition Tables view tab.

3 To create the union table, in the top list, create a new record.

4 Set the table type to Union and complete other fields using Table 19 on page 93 
as a guide.

5 In the lower Partition Tables list, create a new record that you will use to 
associate the first partition table with the union table.

a Create a new record.

b Click the Reference Name select button.

c In the Pick Tables dialog box, choose the partition table and click OK. 

NOTE: Repeat Step 5 to choose additional partition tables to associate with the 
union table.

6 In the lower Partition Tables list, click Create Union Table.

This action connects associated partition tables to the union table. The union 
table allows access to the fields in each partition table. The partition tables now 
behave as if they were in one physical table. 
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Working With Fields
When you add (map) a table to the Siebel Marketing Repository, you automatically 
have access to every field in the table as defined by the data source. 

NOTE: Because some databases such as Oracle do not support Unicode characters in 
their table names, we cannot support Unicode characters in table names and field 
names in the Siebel Data Warehouse.

When you map a character field to a numeric field, you need to convert the 
character field to a numeric field. This can be done using the to_number attribute. 
For example, to map substr(telephone,1,3) to SHORT in the Fields view, you need 
to set the to_number attribute in Expression as follows:

to_number(substr(telephone,1,3))

CAUTION: If you do not convert these character fields, you might receive an error 
message (Error in Row).

The following topics are discussed in this section:

■ Retrieving Field Names During Data Mapping on page 100

■ Maintaining Fields After Data Mapping on page 101

Retrieving Field Names During Data Mapping
When you map a new table and save the record, the Data Dictionary Manager server 
process starts and retrieves the field names. This retrieval process only runs once, 
when the table record is initially created.

Troubleshooting During Field Name Retrieval
If you add a table and do not see any of its fields, either the table has no fields or 
an error has occurred in the Data Dictionary server process. Check the Data 
Dictionary Manager server log for reasons why the process failed. Possible errors 
include the following:
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■ Table setup errors. Make sure the case-sensitive tableowner and the table name 
are correct.

■ ODBC setup errors. Make sure the server name, ODBC setup, case-sensitive 
password, and case-sensitive user ID are correct.

Maintaining Fields After Data Mapping
You can add and edit fields using the Fields list in the Tables view. You cannot delete 
a table (or its fields) once saved because other Siebel Marketing components may 
have established dependencies on the table and fields.

If a field’s data type is inappropriate for its intended use, you can change its type. 
(Examples include Social Security numbers that appear as numeric fields instead of 
characters and dollar values that appear as characters when they should be 
numeric.) To maintain fields after initial data mapping, perform the following tasks:

■ Adding New Fields After Data Mapping

■ Enabling Data Retrieval for Field Values on page 103

■ Creating Virtual Fields Using Expressions on page 104

For information specific to Marketing fields and Target Group Segmentation, see 
“Setting Up Target Group Segment Tables and Joins” on page 125.

Adding New Fields After Data Mapping
When you add a new field to a table in the data warehouse, it does not 
automatically appear as a field in the corresponding Siebel Marketing table. You use 
the Fields view to add the field (or edit existing fields). The field that you add will 
be included in the table definition in the Marketing Repository.

To add a new field after data mapping

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > External Data Mapping.

2 Click the Tables view tab.

3 In the Tables list, select the table to which fields will be added.

The Fields list displays the fields associated with the selected table.
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4 In the Fields list, create a new record.

5 Complete the necessary fields, using the following table as a guide.

Field Comment

Data Retrieval Enabled This system field is blank as the default. A check mark 
appears in this field when Enable Data Retrieval is selected, 
and the field appears in the list in the Data Retrieval view 
with a label similar to the following:

Accounts.LINE_OF_BUSINESS

For more information, see “Enabling Data Retrieval for Field 
Values” on page 103.

Data Type Choose the type of data this field contains from the list. The 
options are Char (alphabetic), and Double, Float, Long, and 
Short (numeric).

The choice should reflect how the data will be used, not how 
it is designated in the data warehouse. For example, if the 
field holds ZIP Code or postal code information, it may be 
stored as numerical data. However, because you do not 
perform mathematical operations (add, subtract) with ZIP 
Codes, its type should be set to Char.

Data from this field is automatically converted (if necessary) 
from its original type to the type specified.

Description Type a description for the field. The description might 
include the range of values if the data type selected is 
different than the data type in the data warehouse.

Expression Optional. Type an expression or use the default reference 
name.

The maximum size for the expression is 512 bytes 
(characters). Date fields use a yyyymmdd format and are 
bound to a character (8). For details, see “Creating Virtual 
Fields Using Expressions” on page 104.

Reference Name Type a name for the new field. Maximum of 50 characters.

Width This field is automatically populated when you select the 
field’s type. You can only edit the Width value if the Data 
Type is Char.
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6 Save the record.

7 In the Fields list, select the field and click Enable Data Retrieval.

Clicking this button retrieves a list of values associated with the field in your 
database. These values are available for use in segment and filter definitions. For 
more information, see “Enabling Data Retrieval for Field Values.”

Enabling Data Retrieval for Field Values
The Enable Data Retrieval function allows you to generate the list of distinct values 
associated with the field in a particular table. For example, a bank might want to 
create a hierarchy using a Region field.

When a table’s field is selected (indicated by a check mark in the check box) and 
the Enable Data Retrieval button clicked, a one-level attribute hierarchy is created. 

NOTE: Fields which contain values that have a width of more than 50 characters will 
be ignored when you click Enable Data Retrieval. You must shorten the invalid field 
name before attempting to retrieve data for these fields. During the validation 
process, a message notifies you that the field is invalid and asks if data retrieval 
should proceed with other valid fields. In addition, the combined total length of 
tablename.fieldname should not exceed 40 characters or data retrieval will fail for 
that field.

The one-level hierarchy is visible in the Data Retrieval list of records awaiting data 
retrieval (Marketing Administration > External Data Mapping >Data Retrieval 
view tab). When you select the one-level hierarchy in the Data Retrieval list, and 
click Retrieve Data, the results are available for selection in the Edit Segment view, 
and the Filters Detail view (Fields option). For more information, see “Enabling 
Data Retrieval for Field Values” on page 103 and Chapter 9, “Defining Filter and 
Segment Criteria.”

You can set up data retrieval to occur automatically when you refresh your data 
warehouse. Using this feature, you can make sure that fields and attributes with 
volatile datasets are regularly synchronized with the Marketing Repository. For 
more information, see “Automatic Data Retrieval” on page 155.
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Creating Virtual Fields Using Expressions
If you need a field that does not exist in the data warehouse but can be derived from 
an existing field, you can use the expression function to create virtual fields to 
provide data that is not explicitly available in your database. You can also use an 
expression to convert data, for example, converting nulls to strings.

Frequently, expressions are used to convert date information to character 
information. When you map or connect to a table that has a date field, the date field 
is automatically converted to a Long field using the following expression:

( { fn YEAR (DATE_FIELD) } * 10000) +

( { fn MONTH (DATE_FIELD) } * 100) +

( { fn DAYOFMONTH (DATE_FIELD) })

NOTE: This particular expression returns a date formatted as YYYYMMDD.

You might also use this method to create a new virtual field that provides only the 
month or only the year. 

You can create virtual field expressions by typing the expression in the Expression 
field on the Fields list tab in the Tables view. Using virtual fields you can build many 
kinds of new fields. The functions available to you are those provided by your ODBC 
driver, SQL, and your RDBMS.

When creating virtual fields, follow a consistent naming convention. For example, 
if you add a field based on an expression, make the first letter of each word 
uppercase (for example, Month, SSN, Year). Use uppercase letters for fields that 
exist in the data warehouse (with or without expressions). This method allows you 
to recognize which fields are from the data warehouse and which are virtual fields 
that you created using fields in the data warehouse.
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About Customer Hierarchies
A customer hierarchy is a structure that is used to sort data. You create customer 
hierarchies to specify how you want to sort and organize information when it is 
extracted from the data warehouse.

Customer hierarchies allow the marketer to design segmentation and filter criteria 
that take advantage of relationships between individuals or organizations within 
the customer base. A marketer may want to use a campaign to target individuals 
within a household or the household that contains several individuals. You can use 
the customer hierarchical structure to develop segmentation measures and set up 
custom functions that select customers based on aggregated data across any lower 
targeting levels of a hierarchy. For example, a bank might create a hierarchy with 
customers as the primary targeting level (sort). Each customer most likely will have 
multiple accounts (second targeting level), and each account will have multiple 
months of transactions (third targeting level). 

This Customer-Account hierarchy allows the bank to deliver a direct offer at the 
customer (primary) targeting level, or to decide that the best way to deliver an offer 
is by targeting specific accounts (second targeting level). Each banking customer 
has multiple accounts, and each account has multiple months of information. A 
measure might be created to target a customer based on the combined balances or 
transaction amounts across accounts.

By using Social Security number (SSN) and Account ID to identify customers and 
accounts, you can design measures that correspond to the targeting level. For an 
account-level measure, you can sort the data by Account IDs and calculate measures 
such as total deposits, average balance, minimum balance, and so on. For a 
customer-level measure, you can sort by SSN. Within the SSN group, you can sort 
by Account ID. The customer-level measures can then aggregate the data across 
multiple accounts, such as total balance, number of transactions, and so on. You 
can use those measures to create segment and filter criteria.

For more information about customer hierarchies, see the following topics:

■ Designing Customer Hierarchies on page 106

■ Creating Customer Hierarchies and Adding Targeting Levels on page 108

■ Mapping Tables to Customer Hierarchies on page 110
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Designing Customer Hierarchies
Siebel Marketing allows you to design whatever hierarchy is most appropriate for 
the data in your data sources. You can set up multiple hierarchies to accommodate 
different customer categories or industry segments in which you may compete.

Using Siebel Marketing, you can define hierarchies of up to seven targeting levels. 
When presenting campaign offers, you can target the most appropriate level in the 
hierarchy, making sure that only one, consistent offer is delivered to the customer.

NOTE: You should design and implement customer hierarchies before creating any 
measures, because some measures may be specific to a customer hierarchy.

Before creating your customer hierarchies in Siebel Marketing, you should analyze 
your needs and design the hierarchical structure. For example, you might want the 
following structure to target customers by location:

■ A country can contain many states or provinces, cities, street addresses, and 
postal codes.

■ A state or province can contain many cities, street addresses, and postal codes.

■ A city can contain many street addresses and postal codes.

■ A street address can have only one postal code.

First Targeting 
Level

Second 
Targeting Level

Third Targeting 
Level

Fourth Targeting 
Level  Field

Country

State or 
Province

City

Street Address Zip Code or 
Postal Code
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To design a customer hierarchy

1 Determine the customer hierarchies you need by identifying the ways you and 
others want to sort your data and the types of aggregations you need. 

Each customer hierarchy must have at least one targeting level and can have a 
maximum of seven.

2 For each customer hierarchy, define the primary sort (first targeting level), the 
secondary sort (second targeting level), and so on. 

a First define the lowest targeting level in your hierarchy. The lowest level has 
a one-to-one relationship to your data. There can only be one unique value 
for a particular record. For example, a street address can have only one postal 
code.

b Define the highest targeting level in your hierarchy. The highest level has the 
highest one-to-many relationship to your data. Many records can have this 
value. For example, in an address record, the highest sort might be based on 
country.

c Define targeting levels in between the lowest and highest in your hierarchy. 
These levels have a one-to-many relationship to your data.

3 For each targeting level, identify which tables and fields hold the data on which 
you need to sort. Each level must be associated with one or more tables and 
fields.

For a sample hierarchy design with multiple customer hierarchies, see Table 20 on 
page 110.
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Creating Customer Hierarchies and Adding Targeting 
Levels

Each targeting level of a customer hierarchy corresponds to a unique identifier in 
the database that identifies each entity. These unique identifiers are referred to as 
keys. Keys are the basis on which the data will be sorted for aggregation and 
retrieval.

For example, a marketing manager for an energy company may want data at the 
household targeting level. The household may have gas, electric, or oil accounts, 
but for its upsell marketing campaign, the manager decides to combine a number 
of offers in one direct mail campaign, targeted at the head of a household. Unique 
identifiers might include Household ID, Account ID, and Individual ID (for the head 
of household).

Depending on the available data, the manager might attempt to map to certain 
tables and fields to help identify the head of household contact. These fields might 
include:

■ Number of years the account has been in existence (Example: YEARS_ACCT)

■ The contact’s title (Example: TITLE)

■ The contact’s gender (Example: GENDER)

■ Which account within the household was the first to be established (Example: 
LOWEST_ROW_ID or lowest BASE_ROW_ID)

You can set a customer hierarchy and targeting level as default values for the 
application. If you do this, and then create a new source code format, new 
campaign load mapping, new output file layout, new segment, or new program, the 
Customer Hierarchy and Targeting Level fields in these new records will be 
populated with the default customer hierarchy, and default targeting level.

To create customer hierarchies and add targeting levels, perform the following tasks:

■ Creating Customer Hierarchies on page 109

■ Adding Targeting Levels to a Customer Hierarchy on page 109
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Creating Customer Hierarchies
You create customer hierarchies to specify how you want data sorted and organized 
when data is extracted from the data warehouse.

To create a customer hierarchy

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Customer Hierarchies.

2 In the Customer Hierarchies list and create a new record.

3 Type a name and description for the customer hierarchy.

4 Select the check box in the Default column if you want it to be the default 
customer hierarchy.

NOTE: There can only be only one default customer hierarchy at a time. 

For data integrity reasons, you cannot delete a customer hierarchy after it is saved.

Adding Targeting Levels to a Customer Hierarchy
The targeting level determines the availability of tables when mapping. Every table 
is available for the first level, but subsequent levels include only tables from the 
Parent level immediately above it. You can define as many as seven levels.

The order in which you add a level determines its sequence. If you want to reorder 
levels after you have saved the record, delete every level and add each level again 
in the correct sequence.

To add targeting levels to a customer hierarchy

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Customer Hierarchies.

2 In the Customer Hierarchies list, select the hierarchy.

3 In the Targeting Levels list, create a new record.

a In the new record, type a name and description for the level.
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b Select the check box in the Default column if you want it to be the default 
targeting level. 

NOTE: There can only be one default targeting level at a time.

Mapping Tables to Customer Hierarchies
Siebel Marketing constrains access to tables and fields using the following rules:

■ The first (primary) targeting level in a customer hierarchy can map to any table 
in the data source (provided it has the customer key for the primary level). 

■ Successive targeting levels of the hierarchy can only map to tables that were also 
included in the level above it.

See sample customer hierarchy in Table 20.

Table 20. Sample Customer Hierarchy Design

Customer Hierarchy Name Levels Tables Fields

Account hierarchy Account 
(primary level)

ACCOUNT ACCOUNT_ID

TRANSACTIONS ACCOUNT_ID

DEMOGRAPHICS SSN

SUMMARY ACCOUNT_ID

SSN/Account hierarchy SSN 
(primary level)

ACCOUNT SSN

DEMOGRAPHICS SSN

TRANSACTIONS SSN

SUMMARY SSN

Account 
(secondary level)

ACCOUNT ACCOUNT_ID

TRANSACTIONS ACCOUNT_ID

SUMMARY ACCOUNT_ID
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Use the following guidelines when selecting tables to map to each level of the 
customer hierarchy:

■ Locate each table that holds the identifier for the primary level (Key 1), and map 
those tables to the primary level. In Table 20, these tables include Account, 
Demographics, Transactions and Summary.

■ Determine which of the tables also contain the second level identifier (Key 2) 
and map those tables to the second level.

■ Continue this process for lower levels of the hierarchy if required, making sure 
that any tables mapped to a level consist only of tables included in the level 
immediately above it.

CAUTION: You must create the appropriate caching settings for the joins between 
fields that you map to the customer hierarchy. If settings are incorrect, some tasks 
will fail. For additional information, see “Guidelines for Caching” on page 119.

To map tables to customer hierarchies, perform the following tasks:

■ Mapping an Existing Table to Customer Hierarchies

■ Mapping a New Table to Customer Hierarchies on page 112

Mapping an Existing Table to Customer Hierarchies
If you add new tables at a later date, follow the instructions in “Mapping a New 
Table to Customer Hierarchies” on page 112 before mapping the customer 
hierarchies.

To map tables and fields to a targeting level

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Customer Hierarchies.

2 In the Customer Hierarchies list, choose a customer hierarchy record.

3 In the Targeting Levels list, select a level from within the hierarchy. 

4 In the Mapping list, create a new record.
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5 Complete the fields.

a In the new record, click the Table select button, select the table to be mapped, 
and click OK.

b Click the Field select button, select the field to be mapped, and click OK.

c If the physical table contains sorted data, select the Presorted check box.

NOTE: Data needs to be sorted for some processes that are performed in the 
background, for example, aggregating measures. If you know that the data 
has been sorted in the data source, check the Presorted check box and the 
Marketing Server will not sort the data again. If you are not sure, leave the 
check box blank and the Marketing Server will sort the data. Presorted can 
only be selected for the first level of the hierarchy.

Repeat Step 1 through Step 5 for each level in the Levels list.

Mapping a New Table to Customer Hierarchies
When you add new tables to your data warehouse, you may need to map them to 
existing targeting levels.

If a new table has a field that can supply sorting information, use the Customer 
Hierarchies view to determine to which targeting level the table should be mapped. 
At a minimum, the table must be mapped to the primary (top) level of that customer 
hierarchy. Then, follow the instructions in “Mapping an Existing Table to Customer 
Hierarchies” on page 111.
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Understanding Joins
Siebel Marketing can retrieve data from multiple RDBMS tables. To extract and 
process this data, the Marketing Server must be able to associate and merge related 
data from these data sources into Siebel Repository tables and fields. 

Joins allow Siebel Marketing to match and combine records. Siebel Marketing joins 
work like those in any true relational database. Records from two tables are merged 
when join keys match in each table. Although tables in your RDBMS have defined 
joins, you also need to define joins in Siebel Marketing. Siebel Marketing uses its 
own join definitions because the Marketing Server can join tables across separate 
RDBMS data sources that do not share the same physical database.

The Marketing Server decides which of three join methods to use to retrieve data 
from mapped tables. The join method selected depends on whether the join fields 
are also mapped to the customer hierarchy. Usually, merge joins and cache joins 
provide much better performance than nested loop joins. 

The Marketing Server applies rules in the following order to determine the method 
it will use to retrieve data. 

■ Merge. When customer hierarchy mappings are consistent with joined fields, the 
server uses the merge method, even if the cache flag is turned on. 

For example, when you have two tables (Table1 and Table2), the Marketing 
Server will use the join method if the following conditions are satisfied:

■ The join key value from Table1 matches the join key value from Table2.

■ Both the join key value from Table1 and the join key value from Table2 are 
in the customer hierarchy.

If one of the fields is not in the customer hierarchy, the Marketing Server will not 
use the Merge method.

■ Cache. If the Merge rule is not true and you turn on the cache flag for the join, 
the server will cache (read into memory) the child table.

■ Nested loop. If the cache rule is not true, the server uses the nested loop method. 
This method is only used when Merge and Cache do not apply. The nested loop 
method should be avoided to prevent performance slow downs, especially for 
large tables or when joining tables without indexes.
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For more information about joins, see the following topics:

■ Parent and Child Joins

■ Categories of Joins in Siebel Marketing on page 115

Parent and Child Joins
When you establish a join, you define a connection between two tables. One table 
is the parent and the other table is the child. You connect the parent table to the 
child table using at least one field that they have in common. By defining these join 
pairs, you can connect each of the relevant tables in your data warehouse. A join 
connection can be unidirectional or bidirectional. This section describes 
unidirectional and bidirectional joins.

■ Unidirectional join connection. By default, each join record in the Marketing 
Repository is a unidirectional join. The Marketing Server retrieves child 
information when it queries a parent record, but will not retrieve parent 
information when it queries a child record. This is the default behavior of a join 
in the Marketing Repository.

Figure 2 shows an example of unidirectional joins between four tables. Tables B 
and C are child tables when connected to A and are parent tables when 
connected to D.

Figure 2. Sample Table Joins

Join Pair Parent Child

A-B A B

A-C A C

B-D B D

C-D C D
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■ Bidirectional join connection. Most table joins in your physical database can be 
bidirectional. To create a bidirectional join in Siebel Marketing, you need to 
define two joins, one in which A is the parent and B is the child, the other in 
which B is the parent and A is the child.

Categories of Joins in Siebel Marketing
There are three categories of joins in Siebel Marketing:

■ Table joins. Most joins are table joins.

■ Start point joins. Used by the Marketing Server to perform queries.

■ Attribute joins. Created automatically by the Marketing Server during data 
retrieval.

To create a join, see “To create a new join between two tables” on page 119.

Using Table Joins 
Table joins define the relationships among the tables in selected data sources and 
are created by the Marketing Administrator in the Marketing Administration screen. 
For more information, see “Joining Tables and Fields” on page 118.

Using Start Point Joins
To extract data from the target data source, the Marketing Server needs to know the 
tables that are the starting points from which it will get to other tables. In a start 
point join, the parent table is null and the child table is flagged as a candidate to be 
the first table to start joining during a snapshot build or data synchronization. The 
application server needs at least one start point in the system. Typically every table 
that has a field enabled for data retrieval or has a field used as a base field in an 
attribute family should have a start point defined on it. This is a table that is usually 
needed for a campaign snapshot build (example: master customer table)

During a snapshot or data retrieval task, the Marketing Server may perform several 
separate queries accessing different groups of tables. During a query, if the 
Marketing Server cannot find a starting point, the table join might be ignored.
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To extract data most efficiently, the Marketing Server uses the start points with the 
other joins to determine the paths required to retrieve data using the least effort. It 
checks every possible join path and its cost (weight) to select the best start point. 
For more information about the Cost parameter, see “Using the Cost Parameter 
(Advanced)” on page 124.

Not every table is an appropriate starting point. The following are the basic 
guidelines for defining start points:

■ If the table is always included in every query, a starting point should be created 
for that table. For example, the table containing Customer IDs might be the 
logical parent for other tables involved in the query, such as products owned, 
service requests, orders, and activity information.

■ If you have defined any attribute families from a table, you should provide a start 
point for that table.

CAUTION: Do not associate a customer hierarchy with a start point join using the 
Customer Hierarchy field of the join. If you do, you will receive an error (No 
STARTPOINT specified on TABLE xxxxx) during data synchronization.

To create a start point join, see “To create a new join between two tables” on 
page 119.

Using Attribute Joins
Attribute joins are created automatically by the Marketing Server during data 
retrieval used to create an attribute family. When the Marketing Server retrieves an 
attribute family, a system table is created in the Marketing Repository to hold the 
data values for each field in the family. As part of this process, the Marketing Server 
also creates the necessary join between this new attribute table and the existing 
tables. This new join is an Attribute Join.
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The child table name of an attribute join contains the prefix Siebel.ATR. The fields 
in an attribute join record are read only, except for the join’s Type field. You may 
change the join type and subsequent data retrieval will be based on the join type. 
For example, if the inner join should be changed to an outer join, you can make that 
change in the attribute join record.

NOTE: Attribute synchronization (data retrieval) never uses joins defined with 
customer hierarchies. For more information, see “Retrieving Attribute Data” on 
page 150.
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Joining Tables and Fields
Use the Joins view to create joins between two tables. Use the Queries drop-down 
list to filter the Joins list by table, attribute, or start point joins.

For more information about joining tables and fields, see the following topics:

■ Guidelines for Customer Hierarchies and Joins

■ Guidelines for Caching

■ Joining Tables on page 119

■ Joining Fields on page 122

■ Using the Cost Parameter (Advanced) on page 124

Guidelines for Customer Hierarchies and Joins
Each join has an optional customer hierarchy field. This field only needs to be set 
in certain circumstances. Use the following guidelines for setting the Customer 
Hierarchy field on a join:

■ Only use the Customer Hierarchy field when you create joins to multiple 
hierarchies. You would create two joins on the same table and specify which 
customer hierarchy to use for each one. 

■ Do not associate a customer hierarchy with any start point join that you created 
for data retrieval of an attribute family. This returns the following error in the 
MktgSrvr log file:

No STARTPOINT specified on TABLE XXXXX

■ If you specify a customer hierarchy for a join, that join is restricted to that 
hierarchy. For example, if you specify customer hierarchy X for join A, join A will 
not be considered when the Marketing Server evaluates the available joins to 
process customer hierarchy Y.
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Guidelines for Caching
When defining joins, Siebel Marketing provides a Cache check box so that you can 
indicate if the table should be loaded into memory (cached) or accessed from a hard 
disk.

Use the following guidelines when deciding if you should cache a join.

■ Do not load large tables into memory unless the server has sufficient physical 
RAM.

■ Do not cache joins if the child table is mapped to the customer hierarchy. When 
a table is mapped to a hierarchy, the Marketing Server uses Merge functionality 
to retrieve the data.

■ If the table is not mapped to a customer hierarchy and the table size is 10,000 
rows and smaller, cache the join to reduce extract time.

Joining Tables
Use the following procedure to create joins between two tables.

To create a new join between two tables

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > External Data Mapping.

2 Click the Joins view tab.

NOTE: To see more details, in the Joins list, select a join record and choose Details 
from the Show drop-down list.

3 In the Joins list, create a new record.
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4 Complete the necessary fields using Table 21 as a guide and save the join.

Table 21. Fields in the Joins View

Field Comment

Cache Select this check box when the table should be loaded into memory or accessed off 
disk as necessary.

To reduce extract time, cache small tables (10,000 rows and smaller). Do not load large 
tables into memory unless the server has sufficient physical RAM.

Cardinality Cardinality is the ratio of occurrence of matching records between the two tables. This 
ratio helps the Marketing Server determine the fastest way to join the records. 

Select the cardinality between the parent and child tables from the list of values. 
Options are 1:N (one to many), 1:1 (one to one), N:N (many to many), and N:1 (many 
to one). The default is N:N.

For example, if the join keys are SSN and ACCOUNT_ID and the parent table has one 
record for each SSN/ACCOUNT_ID while the child table has two records for any SSN/
ACCOUNT_ID, this setting would be 1:N. 

In this case, the Marketing Server would scan for others after it has found one 
matching record.

Child Table Click the Child Table select button. In the Pick Tables dialog box, select the Child table 
(the table to which the parent table will be joined). Click OK.

Cost Type a cost value if you want the Marketing Server to evaluate which of two or more 
possible paths of joining tables is the most efficient. See “Using the Cost Parameter 
(Advanced)” on page 124.

Customer 
Hierarchy

If the join is specific to a particular customer hierarchy, click the Customer Hierarchy 
select button. In the Pick Customer Hierarchy dialog box, select the customer 
hierarchy from the list. Click OK. When you specify a customer hierarchy for a join, 
that join is restricted to that hierarchy.

For example, you may wish to use a different join strategy for one type of customer 
hierarchy versus another. By making each join specific to a different customer 
hierarchy, the marketing administrator can indicate which strategy should be used. 
For additional information see, “Guidelines for Customer Hierarchies and Joins” on 
page 118.
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Hint (Show Details) (Optional) Type a hint statement if applicable. This field is only applicable to Oracle 
databases.

Hint statements are passed on to the RDBMS through the SQL generated by the 
Marketing Server. 

Siebel Marketing includes these hints statements in the select statement against the 
child table. The following hints may be useful: 

■ /*+all rows*/ This statement bypasses any indexes. It is useful when caching a 
table. 

■ /*+first rows*/ This statement forces the use of an index. It is useful when you 
are not using the cache, the table is large, and the rows you want to retrieve are 
already in a sorted index. 

■ /*+parallel (fully qualified table name,1)*/ This statement invokes parallelism on 
the select statement. It is not necessary if parallelism is already enabled at the table 
level.

Do not invoke parallelism if tables are already physically stored in sorted order and 
you checked the Presorted option when mapping tables and fields. If you do invoke 
parallelism, the order will be incorrect because each thread delivers records when it 
can.

Parent Table Click the Parent Table select button. In the Pick Tables dialog box, select the table that 
is the start point for the join. Click OK.

For a start point join, leave this field blank.

Table 21. Fields in the Joins View

Field Comment
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Joining Fields
Use the Fields list to specify a join’s sequence, the parent and child fields, and the 
operator.

To join table fields

1 From the application-level menu, choose View > Site Map > Marketing 
Administration screen.

2 From the Show drop-down list, choose External Data Mapping.

3 Click the Joins view tab.

4 In the Joins list, select a join record.

RDBMS Join (Show 
Details)

Select this check box to display a check mark if you want the join to occur in the 
relational database management system (RDBMS) as opposed to the Marketing Server. 
The default is No (clear).

By default the Marketing Server performs the joins (faster). In some cases, you might 
want to reduce extraction time by having your RDBMS perform the join.

In general, you get the best extraction speed from RDBMS joins when joining to a large 
table but using a small percentage of its rows when using hierarchical attributes and 
filters. 

You must use Siebel Marketing joins if the two tables are not in the same RDBMS. 

Type Choose Outer or Equal (inner) as the join type.

When Marketing Server cannot find a record in the child table that corresponds with 
a record in the parent table, it can either discard the row of data or keep it even though 
the row is incomplete. 

To accept only complete rows (data in both parent and child), choose Equal. To accept 
partial rows (data only in the parent), choose Outer. A choice of Outer usually results 
in joining more rows than choosing Equal. 

Table 21. Fields in the Joins View

Field Comment
122 Siebel Marketing Guide Version 7.5.3



External Data Mapping

Joining Tables and Fields
5 In the Fields list, create a new record.

A new row is added with a sequence number.

The read-only Sequence field displays the join order. Siebel Marketing adds a 
number 1 in the Sequence field to indicate this record is the first join field 
between the two tables. If the tables can be joined on multiple fields, make sure 
each join follows the same order as in the customer hierarchy. 

For example, if the customer hierarchy has SSN as the first targeting level and 
Account_ID as the second, make the SSN join first and the Account_ID join 
second when joining tables that have both fields. This allows Siebel Marketing 
to perform a merge join between the two tables. For more information, see 
“Understanding Joins” on page 113.

6 Complete the necessary fields.

NOTE: Joined fields should not be greater than 255 characters.

a In the Parent Field field, click the select button. 

b In the Pick Fields dialog box, select a field from the list of fields available in 
the Parent table and click OK.

c In the Child Field field, click the select button. 

d In the Pick Fields dialog box, select the corresponding join field from fields 
available in the Child table and click OK.

e Choose a join type operator.

Available operators are =, <, >, <=, and >=. 

The majority of joins use the = operator as the default. In this case, when 
the Marketing Server joins a row from the parent table, it looks for the same 
value in the child table.

Some joins use the >= operator. This operator is most commonly used with 
date data, where the parent field contains an event date and you want to join 
to child data that occurred after the parent event.
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Using the Cost Parameter (Advanced)
You can use the join cost feature to influence the join path for Marketing Server 
queries. Each table join has an optional cost parameter. Cost is a unitless, relative 
number that the Marketing Server uses to calculate the most efficient query path. 
The Marketing Server selects the query path with the lowest total cost.

When multiple paths exist, the Marketing Server randomly selects one and runs a 
test query to compute the total cost of each path. Finally, the Marketing Server 
chooses the path with the lowest total cost and runs the full query.

You can exercise some control over this process by modifying the Cost parameter. 
Each table join has a Cost parameter (default 1000). If you want the Marketing 
Server to use a particular path, you can raise its cost or lower the cost of other paths.

To set the cost parameter

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > External Data Mapping.

2 Click the Joins view tab.

3 In the Joins list, select the join record. 

4 In the Joins Show drop-down list, choose Details.

5 In the Joins form, type the Cost value that meets your business needs.
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Setting Up Target Group Segment Tables and Joins
If Siebel Analytics or Siebel Marketing are on a Unix platform, see “Setting Up Target 
Group Segmentation on a UNIX Platform” on page 50 before performing the tasks 
in this section. To map tables and joins for target group segments, Siebel Analytics 
and Siebel Marketing must be installed and running. 

The Target Group Segmentation feature allows you to use Siebel Analytics report 
criteria to create Siebel Marketing segments. With Target Group Segments, you can 
create Siebel Marketing segments by selecting Subject Area fields and applying filter 
criteria using the Siebel Answers screen. Using this method allows you to build 
segment criteria without having to write complex expressions.

In the Answers screen, you choose subject areas, select segment criteria based on 
fields, and define filters for fields based on your business needs. When you are 
satisfied with the results, you create the Siebel Marketing segment, name it, and 
assign a customer hierarchy and targeting level. Use Analytics screens (dashboards) 
to choose reports created in Siebel Analytics and create a segment from the report.

NOTE: You must be logged on to the Siebel Analytics Server to access the Analytics 
screens.

This feature is only available after you install and configure Siebel Analytics. For 
more information see Siebel Analytics Installation and Configuration Guide.

To set up tables and joins, perform the following tasks:

■ “Mapping the Marketing Server to the Analytics Server”

■ “Mapping an Analytics Subject Area Table in Siebel Marketing” on page 126

■ “Mapping the Analytic Adapter Tables to the Marketing Repository Server” on 
page 127

■ “Creating Joins for Target Groups” on page 129

■ “Mapping the Customer Hierarchy for Target Groups” on page 131
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Mapping the Marketing Server to the Analytics Server
The Marketing Server must be mapped to the Analytics Server before mapping 
tables and fields and creating joins for target groups. For instructions, see “Mapping 
the Marketing Server to the Analytics Server” on page 126.

Mapping an Analytics Subject Area Table in Siebel Marketing
For Target Group segmentation, the segment filter criteria are built against a specific 
subject area. This subject area is also the source of the customer name and address 
information that is loaded into the campaign. To support this load process, you need 
to map the Analytics subject area as a logical table in the Marketing Administration 
screen in the External Data Mapping view. For more information about how to map 
tables, see “Mapping to Tables from the Servers View Tab” on page 90 and 
“Working With Tables” on page 91.

After mapping, the data dictionary will process retrieve all the logical columns from 
the subject area displaying the format “Table_name”.”Column_name”. Use the 
following guidelines when you complete a new record in the Tables list.

For table mapping instructions, see “Mapping to Tables from the Servers View Tab” 
on page 90.

Table 22. Fields in the Tables List

Table Column Description

Reference Name When mapping tables, the reference name can be any name that 
you choose. However, you need to check other tables in the Siebel 
transactional database to obtain the necessary table owner syntax 
for specifying value in the Table Name column. Reference names 
for tables that contain any special characters must be enclosed in 
double quotes. Special characters include spaces and Unicode 
characters.

Table Name The value in this field must match the name of the subject area in 
the Analytics repository. Reference names for tables that contain 
special characters must be enclosed in double quotes, for example 
“Subject Area”. Special characters include spaces and Unicode 
characters.

Table Type The default value is Regular. Select Analytic Adapter from the Table 
Type drop-down list.
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Mapping the Analytic Adapter Tables to the Marketing Repository Server
The following two Analytic Adapter tables are used by Siebel Marketing when 
creating, loading, and using target group segments. The Analytic Adapter tables are 
system tables that reside in the Siebel transaction database and store the target 
group lists that result from the creation of a segment through Siebel Analytics.

■ S_DD_TRGT_GRP. Contains the name of the target group after you create it.

■ X_DD_TRGTGRPMBR. Contains the list of contacts and account ids obtained from 
Siebel Analytics and stored in the Marketing Repository after performing a load.

Each targeting level of your customer hierarchy requires separate references to the 
X_DD_TRGTGRPMBR and S_DD_TRGTGRP tables so that lists of Accounts, 
Households, Contacts, etc. are kept separate. During the load process, the 
application makes sure that each X_DD_TRGTGRPMBR reference is automatically 
given a search specification that includes only rows for that customer targeting 
level.

For additional information about mapping tables and creating table joins, see the 
related topics in this chapter.

You must perform all the steps in the following procedure (unless a step is 
specifically stated to be optional) for successful data retrieval:

To map the Analytic Adapter tables to the Marketing Repository

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > External Data Mapping.

2 In the Servers list, select Marketing Repository and scroll down to the Tables list.

3 In the Tables list, locate each alias of the S_DD_TRGT_GRP and 
X_DD_TRGTGRPMBR analytic adapter tables.

4 In the Tables list, create a new record for each alias and map the alias using 
guidelines in Table 22 on page 126.
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a Map the X_DD_TRGTGRPMBR table for each customer hierarchy level that 
will be used for target group segments.

For example, if you are using an Account - Contact hierarchy, you will have 
two levels, Account and Contact. You would map two aliases of the 
X_DD_TRGTGRPMBR table and assign easily identifiable reference names 
such as, Target Group Accounts and Target Group Consumers.

b  Map the S_DD_TRGT_GRP table once for each alias of the 
X_DD_TRGTGRPMBR table (for each customer hierarchy level).

This mapping allows you to create different branches on the Target Group 
attribute family for each customer hierarchy. It also makes sure that the 
extract process uses the correct join path.

Give each alias of S_DD_TRGT_GRP an easily identifiable reference name 
such as Account Group, Household Group, and Consumer Group.

5 Click the Tables view tab, scroll down to the Fields list.
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6 In the Fields list, in the Reference Name column, edit the NAME field for each 
alias of the S_DD_TRGT_GRP table.

a In the Reference Name field, change NAME to include the table reference 
name using the syntax “[table reference name]”.“NAME”.

In our example, this would be “Account Group”.“NAME”. The double quotes 
around the table reference name and field name are required.

NOTE: The field width for each name field can be a maximum of 50 characters 
or data retrieval will fail.

b Select the check box in the Data Retrieval Enabled field to enable this column 
for data retrieval.

7 Create a start point join (a join with no parent table) to each alias of the 
S_DD_TRGT_GRP table.

8 Perform data retrieval for NAME fields in each alias of the S_DD_TRGT_GRP 
table.

a In the Fields list, select the NAME field.

b Click Enable Data Retrieval to make sure that the attribute joins are created 
by the Marketing Server.

Creating Joins for Target Groups
After completing all tasks in the “Mapping the Analytic Adapter Tables to the 
Marketing Repository Server” on page 127 section, you will need to create joins to 
support the process of extracting a target group from the source database through 
the Analytics Server and load the customer list into a campaign. This section 
contains recommended joins for the tables required to generate a snapshot using a 
target group segment.

NOTE: The Subject Area in Siebel Analytics is treated as a single logical table name 
in Siebel Marketing.
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To create joins for target group segmentation

1 Create the following joins: Create a start point join to each subject area table that 
you want to use to create segments. For example:

2 Create a start point join to each alias of the S_DD_TRGT_GRP table. You mapped 
these in Step 4 on page 127. For example:

3 Create a table join from the subject area table to one of the aliases of the 
X_DD_TRGTGRPMBR table. You mapped these in Step 4 on page 127. For 
example:

■ Create a field join to the alias of the X_DD_TRGTGRPMBR table for the 
corresponding customer level. For example:

Join Parent Table Child Table Type Cardinality

Table <null> “[name of the subject area]” default

Join Parent Table Child Table Type Cardinality

Table <null> “Account Group” default

<null> “Consumers Group” default

Join Parent Table Child Table Type Cardinality

Table “Subject Area” “Target Group Accounts” Equal N:N

Sequence Parent Field Child Field Operator

1 “Subject Area”.“Account ID” Key 01 =
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4 Join each alias of the X_DD_TRGTGRPMBR table to each alias of 
S_DD_TRGT_GRP table. For example: 

■ Create field joins, repeating for Consumers or Households. For example:

5 Repeat Step 3 on page 130 and Step 4 to create joins for the other levels of your 
customer hierarchy.

Mapping the Customer Hierarchy for Target Groups
After “Creating Joins for Target Groups” on page 129, you can map the customer 
hierarchy. For more information about mapping a customer hierarchy and targeting 
levels, see the related topics in this chapter.

To create a customer hierarchy

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Customer Hierarchies.

2 In the Customer Hierarchies list, create or select the customer hierarchy you 
want to use for Target Group Segments.

This example uses an Account - Contact hierarchy.

Join Parent Table Child Table Type Cardinality

Table “Target Group Accounts” “Account Group” Equal N:1

Sequence Parent Field Child Field Operator

1 DD_TRGT_GRP_ID ROW_ID =
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3 Select the check box in the Default column to make it your default customer 
hierarchy.

NOTE: There can be only one default customer hierarchy.

4 Modify the targeting levels for target group segments.

a In the Targeting Levels list, type or select values for the fields in Table 23 at 
the end of this procedure.

b In the Mappings list, add a field mapping to the customer Id field in the 
Subject Area table, for example, “Accounts”.“Account ID”.

Repeat Step 4 for each targeting level, adjusting the values in Table 23 to match 
the corresponding table aliases and customer IDs.

Table 23. Field Values for Modifying Targeting Levels

Field Name Description

Analytics Columns This is the column from the Analytics Subject Area that 
contains the Customer ID, for example 
“Accounts”.”Account ID”.

Default Select the check box in the Default column to assign the 
default targeting level.

There can be only one default targeting level.

Target Group Column This is the Name column from the S_DD_TRGT_GTP 
table, for example, “Account Group”.“NAME”.

Target Group Data Table Type the X_DD_TRGTGRPMBR alias, for example “Target 
Group Accounts”. Use the drop-down list to select the 
table.
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Attributes are discrete variables that may be grouped, or rolled up, into collections 
of related information. Examples of attributes are geographical values (city, state, 
region) and time values (month, quarter, year). The data elements that make up 
attributes are derived from attribute tables in your data warehouse. 

Creating a rollup is simply ordering attribute values so that you can segment the 
data at the highest level, or at any level in between. For example, ZIP Codes roll up 
into counties, counties roll up into states, and states roll up into regions and 
markets. You can group attributes into families, then order the values in each 
attribute family into different hierarchies for convenience and to make the data 
easier to select for segments, filters, and custom measure aggregations.

You use the attributes you build in Siebel Marketing for many purposes:

■ To create groupings for time, demographics, and product data.

■ To provide record filtering abilities (for example, only analyze customers who 
live in Michigan and have bought a specific product).

■ To provide customer segmentation (for example, segment customers by account 
balance, resulting in mailings to customers who have a high or very high 
balance).

In Siebel Marketing, there are number of ways to group data values:
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■ Buckets. These are ranges of continuously varying numbers that reference 
measures, for example, high, medium, and low. For buckets, you create and 
produce counts based on the value of the measure. For example, a marketer 
creates a bound measure that is mapped to the ANNUAL_INCOME field in his 
company’s Customers table, and derives numeric information from that field.

The marketer decides to group ranges of income into buckets and then count 
how many customers fall into each bucket. Table 24 shows how annual income 
data can be divided into distinct ranges. Siebel Marketing calculates the total 
balance for each household, determines the qualifying bucket for the household, 
and adds one to the count for that bucket.

■ Attribute Families. Logical families of related data mapped from fields in a table.

Attribute families are unordered collections of related information that are used 
as the basis for building attribute hierarchies. Each attribute family can have a 
number of attributes, and each attribute, a number of values.

Like buckets, attribute families are mapped to a base table and field in your 
database.

■ Buckets reference a measure that is mapped to a numeric database field.

■ Attribute families provide a loose structure for individual attributes that 
reference and derive information from other alphanumeric fields in your 
database.

Table 24. Measure: Total Balance by Household

Buckets Definition

Low <$20,000

Medium Between $20,000 and $50,000

High Between $50,001 and $100,000

Very High >$100,000
134 Siebel Marketing Guide Version 7.5.3



Defining Attributes and Buckets
For example, a retail marketer wants to group account data to track how many 
accounts were opened in certain time periods. The marketer creates an attribute 
family called Date Opened and maps the attribute family to the Accounts table 
in his database and the DATE_OPENED field in the table. The marketer decides 
to set up quarterly, yearly, and two-year ranges for the data.

Within the attribute family, the marketer creates the three attributes and defines 
values for each, as Table 25 illustrates. Attributes are mapped to the accounts 
table and DATE_OPENED field.

Although these data elements are assigned to an attribute family, the marketer 
can organize the individual attributes in a number of different ways using 
attribute hierarchies.

Table 25. Date Opened Attribute Family with Values

Attribute Family Attributes  Labels Value

Date Opened Yearly 1995 Between 19950101 and 19951231

1996 Between 19960101 and 19961231

1997 Between 19970101 and 19971231

1998 Between 19980101 and 19981231

1999 Between 19990101 and 19991231

2000 Between 20000101 and 20001231

Two-Year Periods Period 1 Between 19950101 and 19961231

Period 2 Between 19970101 and 19981231

Period 3 Between 19990101 and 20001231

Quarterly Q1 1995 Between 19950101 and 19950331

Q2 1995 Between 19950401 and 19950630

Q3 1995 Between 19950701 and 19950930

Q4 1995 Between 19951001 and 19951231
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■ Attribute Hierarchies. These are used to order the various attribute values found 
in attribute families. 

Attribute Hierarchies allow you to look at your data in different ways by allowing 
you to create distinctive rankings, or hierarchies, using mapped, unordered 
attributes of an Attribute Family.

Using the previous example, the attributes in the Date Opened attribute family 
might be arranged in a hierarchy with two-year periods, yearly, and quarterly as 
successive levels. The hierarchy levels also might be arranged as quarterly, 
yearly, and two-year periods. An attribute hierarchy can have up to nine levels.

A retail marketer might design different hierarchies using the attributes in the 
Products attribute family. Individual attributes such as Product, Category, 
Brand, and Size might be arranged in hierarchy levels such as Category, Brand, 
Product, Size, or Brand, Product, Size, Category, and so on. Four data elements 
in an attribute family can be arranged into 64 different hierarchies.

When attributes are arranged in a hierarchy, they form rollups.

Using a bank as an example, if the hierarchy is State, Region, and ZIP Code, the 
measures (Number of ATMs and Number of Tellers) that can be calculated for 
the ZIP Code roll up to provide a total for the Region, and the Regions roll up to 
provide a total for the State, as shown in Table 26.
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ZIP Codes roll up to Region (12+8+20=40 for the South and 7+35+22=64 
for the North). Regions roll up to the state level (64+40=104).

You can create as many rollups as needed. For example, even though the data 
warehouse may not have an attribute for All States, you can create a rollup that 
combines the information from every state to give you the total you need.

Table 26. State, Region, and ZIP Code Rollup

State Region ZIP Code Number of ATMs Number of Tellers

Virginia 14 104

North 8 64

20148 2 7

20191 4 35

20215 2 22

South 6 40

20451 2 12

20476 1 8

20497 3 20
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The Buckets view allows you to assign a range of values or attributes to existing 
measures. This view displays previously defined buckets of values, and provides a 
means to define the range of each bucket, using the Values list.

To create buckets

1 From the application-level menu, choose View > Site Map > Marketing 
Administration screen, and from the Show drop-down list, choose Buckets.

2 In the Buckets list, create a new record.

3 Complete the necessary fields.

a Type a name for the bucket and a description of the bucket’s range of values.

b Click the Measure select button.

c In the Pick Measure dialog box, choose a measure from the list of previously 
defined bound and custom measures and click OK.

The read-only Measure Type field is filled in automatically.

To create values for the bucket

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Buckets.

2 In the Buckets list, select a bucket record.

3 In the Values list, create a new record.

4 Complete the necessary fields, using the following table as a guide.

Field Comment

Code Type up to 50 characters to be used as a code for the value. 

For example, LOW (code) might have a value of between 0 and 10,000. 

First Value Type a numerical value, up to 75 characters long. 

For example, LOW might have a value of between 0 (first value) and 
10,000. 
138 Siebel Marketing Guide Version 7.5.3



Defining Attributes and Buckets

Defining Bucket Values
5 Save the record after each value is defined.

Siebel Marketing automatically assigns a sequence number as each value is typed.

To change the sequence of a value

■ Select a value and click Move Up and Move Down. 

■ Click the menu button and choose Resequence if a value is deleted and you want 
to resequence the remaining values.

Designing Buckets and Ranges of Values
When defining bucket values, be sure to cover every possible range, including 
negative numbers. 

NOTE: You can create two buckets and overlap their values, but each record that 
qualifies for more than one bucket is assigned to the first one for which it qualifies, 
starting from the top to the bottom of the Values list.

Label Type up to 75 characters as a label for the bucket value. Examples of 
labels are Low, Medium, High.

Operator Choose an operator from the list. Options are =, < >, <, <=, >, 
>=, BETWEEN. 

For example, LOW might have a value of BETWEEN (operator) 0 and 
10,000. 

Second Value Type a second value, up to 75 characters, if the operator BETWEEN is 
used. Make sure that the values for BETWEEN are inclusive.

For example, LOW might have a value of between 0 and 10,000 
(second value). 

Field Comment
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Table 27 shows a flawed design of a bucket of values.

This design has several flaws:

■ No provision for negative values. A value of -5 fails to qualify for any bucket, and 
the data is lost.

■ No provision for high values. The highest value for a bucket is 50. Values higher 
than 50 fail to qualify for any bucket.

■ There is a gap between 10 and 11. The first bucket covers values up and including 
10, and the second bucket covers values beginning with 11. If values are not 
whole numbers, (such as a value of 10.5), they do not qualify for any bucket. A 
value of 20 qualifies for both the Medium and High buckets, but the qualified 
value is assigned to the Medium bucket because it is evaluated before the High 
bucket.

■ The Special bucket will never get any assignments. The Medium bucket already 
covers the value of 13.

Table 28 illustrates a corrected design for a set of buckets:

Table 27. Problem Bucket Design

Label Code Operator Value

Low L Between 0 and 10

Medium M Between 11 and 20

High H Between 20 and 50

Special S = 13

Table 28. Corrected Bucket Design

Label Code Operator Value

Special S = 13

Low L <= 11
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Building Rollups for Buckets
Frequently, you need to have both a set of buckets and a total for the bucket values. 
To create a rollup, you have to construct a bucket that uses the same base measure 
as the original. Verify that this rollup has one bucket that encompasses every 
possible value the base variable may have. You can use one of the following two 
methods for making one bucket cover all values: 

■ If the base measure is likely to return only positive numbers, use >= 0 (greater 
than or equal to zero). If you prefer, you might replace the zero with a negative 
number, for example, -99. 

■ The other method is to choose an unlikely value for the measure and use the 
<> (not equal to) operator. For example, Account Balance returns a value with 
dollars and cents. Thus, -0.001 is an unlikely value because of the number of 
digits after the decimal point. By setting the bucket to <> -0.001, the bucket 
should catch all records.

Medium M Between 11 and 20

High H > 20

Table 28. Corrected Bucket Design

Label Code Operator Value
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Use the Attribute Families view to define, map, and build attribute families with 
attributes. The attributes in attribute families can be used to create attribute 
hierarchies. Using this view, you map every attribute to a data warehouse base table 
(primary table) and a base field, then create multiple attribute hierarchies using 
some or all of the attributes. The base field corresponds to the set of unique values 
at the lowest level of the Attribute Family.

The Attribute Families list displays available attribute families, every attribute 
member defined within the attribute family, and the associated table and field 
mappings. Create user-defined labels as an alternative when labels for an attribute 
level need to be defined manually. You can create an unlimited number of labels.

To create attribute Families

1 From the application-level menu, choose View > Site Map > Marketing 
Administration screen.

2 In the Attribute Families list, create a new record.

3 Complete the necessary fields using the table at the end of this procedure as a 
guide.

When you save the record, the new record appears in the Attribute Families list.

4 In the Attribute Families list, select the attribute family for data retrieval.

Use SHIFT select or CTRL select to choose more than one Attribute Family for 
data retrieval.

5 Click Retrieve Data. 

6 In the Pick Start Time dialog box, click the field’s arrow button.
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7 Use the calendar controls to choose a date and the time for the Retrieve Data job 
and click OK.

A validation process begins to ascertain each attribute in the list contains values 
in the Label Table and Label Field fields. If there are no values in these fields, 
validation checks for records in the user-defined labels list for the attribute.

If validation fails, the attribute family’s Data Retrieval Required field will contain 
a Y (Yes), and the Last Data Retrieval and Size fields will contain no values.

Field Comment

Base Field Click the Base Field select button. In the Pick Fields dialog 
box, select the base field from the list of fields in the selected 
table.

The base field should be the lowest level of the attribute 
hierarchy. For example, if a time-based hierarchy has levels 
of Years, Weeks, and Days, select Day as the base field.

The base field should be a field that is unlikely to have 
duplicate values and can be joined to.

The field width accommodates a maximum of 50 characters.

Base Table Click the Base Table select button. In the Pick Tables dialog 
box, select the table and click OK.

The base table contains the base field for the attributes in 
this family. An example would be a time table with a day 
field.

A start-point join must exist for the base table for it to be 
retrieved.
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Data Retrieval Required 
(Yes/No)

This system-monitored and automatically populated field 
indicates whether an attribute data retrieval (rebuild) is 
required. 

Data Retrieval is required if:

■ A new attribute family is added.

■ A new attribute member is added to an existing attribute 
family, or attribute elements are changed.

■ A new attribute hierarchy is added that uses this 
attribute family.

■ An attribute hierarchy which uses this attribute family is 
deleted.

■ An attribute hierarchy using this attribute family is 
modified (levels added or deleted, or a change is made to 
the rollup).

Description (Optional) Type a description of the attribute family’s 
properties. 

Last Data Retrieval This field contains the date of the last attribute data retrieval 
(rebuild).

Name Type a unique name for the attribute family.

Number of Attributes The number of attributes defined in the attribute family is 
automatically generated in this field when data retrieval is 
completed.

Size The number of unique values in the data source for the 
attribute family. This field is automatically filled in after an 
attribute build.

Field Comment
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Adding Attributes to Attribute Families
For each attribute you want to include in the attribute family, you need to identify 
the table and field that holds the attribute. Then you should map to a descriptive 
label or create one in the User Defined Labels list. The Attributes list displays every 
attribute defined within a table and associated mappings to tables and fields. 

NOTE: For data integrity reasons, you cannot delete attribute members after an 
attribute family is saved. Instead, create a new attribute family with only those 
attributes you want to include.

To add attributes to an attribute family

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Attributes.

2 In the Attribute Families list, select the attribute family.

3 In the Attributes list, create a new record.

4 Complete the necessary fields, using the table at the end of this procedure as a 
guide.

5 Save the record after you define each attribute member.

Repeat this procedure until every member of the attribute family has been defined.

Field Comment

Code Field Click the Code Field select button. In the Pick Fields dialog box, select the 
field from the list of fields in the selected code table. Click OK.

The code field allows a maximum of 50 characters.

Code Table This field is automatically populated using the base table specified for the 
attribute family.
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Creating User-Defined Attribute Labels
Attributes must have labels (understandable explanatory text), which identify the 
attribute’s value. For some attributes, the Code field is acceptable as a label, for 
example, values for Country, Province, and City. Labels for other attributes might 
need to be relabeled to more clearly identify the field for the end user. To define a 
label for the attribute, map to existing labels using the fields in the Attributes list, 
or create new labels in the User Defined Labels list.

In a user-defined label record, it is recommended that you set up a one-to-one 
relationship between the value in the Label field and the Code field. Siebel 
Marketing identifies every label using the Code field so that when a label is 
changed, the label value is not deleted from the system during resynchronization of 
an attribute family. For example, a label value of Siebel has the code 01 and is used 
in segment or filter criteria. If you rename the label value to Siebel Systems and do 
not change the code (01), after the attribute family resynchronization, the Siebel 
label value automatically appears as Siebel Systems.

Label Field (Optional) Leave this field blank if you are creating user-defined labels.

To add a label field:

Click the Label Field select button. In the Pick Fields dialog box, select the 
label field from the list of fields in the code table. 

The label field allows a maximum of 75 characters.

Label Table (Optional) Leave this field blank if you are creating user-defined labels.

If you map a label field and define additional labels using the User Defined 
Labels list, the labels that are mapped take precedence. You cannot create 
user-defined labels for fields that are mapped.

To add a label table:

Click the Label Table select button. In the Pick Tables dialog box, select the 
table. Click OK.

Name Type a name for the attribute member.

Field Comment
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For example, to provide labels for the Marital Status attribute, you might connect to 
the Customers table, which has a field called Marital_Status. The values are 1, 2, 3, 
and 4. You know from a reference source that 1 means Single, 2 means Married, 3 
means Divorced, and 4 means Widowed.

To create the attribute members, select the Customers table and the Marital_Status 
field for both the code table and code field. Then, create user-defined labels.

Use the guidelines in Table 29 to help you determine when to use labels that exist 
in the data warehouse, and when to define new labels.

To create user-defined labels

1 From the application-level menu, choose View > Site Map > Marketing 
Administration screen.

2 In the Attribute Families list, select an attribute family.

3 In the Attributes list, select an attribute belonging to the attribute family.

4 In the User Defined Labels list, create a new record.

5 Complete the fields for the labels, using the table at the end of this procedure as 
a guide.

Table 29. When to Use Existing Labels or Create New Attribute Labels

If the Attribute... Then...

Is already text (for example, a ZIP Code or a 
city name)

Choose the same table and field as the label 
(Attribute’s Label Table and Label Field 
fields).

Is an alphabetic or numeric code that 
references a lookup table for its label (for 
example, the attribute Education is joined to 
a lookup table that provides several text 
descriptions for each education code)

Map to the lookup table and select the field 
that contains the text description 
(Attribute’s Label Table and Label Field 
fields).

Is an alphabetic or numeric code for which 
there is no text description in your database 
(an example might be a credit rating, a flag 
value where zero stands for No and 1 stands 
for Yes)

Use the User Defined Labels list, add 
records and use the Label (name) and Value 
fields to provide a text description for each 
possible code the attribute might have.
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6 Save the record after defining each label.

Using the MARITAL_STATUS example, you might create user-defined labels as 
shown in Table 31.

The STATUS value of 1 is now linked to the label Single, a STATUS of 2 to Married, 
and so on.

Table 30. User Defined Labels Fields

Field Comment

Code Type a short code for the label. For example, a code for Low 
Income might be LI.

Label Type the text for the label, up to 75 characters.

Operator Choose an operator from the list. Options are =, <>, <, 
>, <=, >=, and BETWEEN.

Value (First and Second) Add the alphanumeric value that decodes the label. 

If the operator BETWEEN is used, add a second value.

Multiple values can not be used in user-defined labels. You 
can not type values separated by a semicolon (;) in the 
values field. For example:

User Defined Label: Sample

Operator: =

First Value: 0;1;2

Table 31. Sample User-Defined Labels

Label Code Operator Value

Single S = 1

Married M = 2

Divorced W = 3

Widowed D = 4
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The label entries are evaluated in order. The top label, Single, is evaluated first and 
the bottom one, Divorced, is evaluated last. Make sure that each value qualifies for 
at least one entry.

In the User Defined Label Value field, you can type alphabetic characters in addition 
to numeric. For example, if the attribute contains letters such as Y or N, you can use 
the label to expand those values into Yes and No.

Because characters are valid entries, you should verify that numeric-style data is 
stored as numeric values. For example, a field called BRANCH_ID might be 
described as a character field, not a numeric field (integer, double and so on). If so, 
Siebel Marketing interprets it as a character entity. Thus, if North is defined as 
“Between 1 and 3,” the values of 20 and 200 would qualify as being between 1 and 
3. If the data is stored as a character, you can use Siebel Marketing to convert the 
values to numerics.

You can put multiple values in a single line, separated by semicolons. As Table 32 
shows, a credit rating of A, C, or H qualifies as good credit.

Table 32. Multiple Values Separated by Semicolons

Label Code Operator Values

Good G = A;C;H
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Trapping Unclean Data
Even the best data warehouse can have values that are outside the expected range. 
This is referred to as unclean data. In the MARITAL_STATUS example, possible 
values are 1 through 4. If the data is corrupt, values such as -2, -4.5, or 297 may 
exist.

To trap unclean data, you can create entries to trap the bad values, as shown in 
Table 33.

When you review your data, check the traps for data. If data is being captured, you 
should check the source data to locate and correct the unclean data.

Remember, data changes over time, and you may not have data in the traps the first 
time you extract information.

Retrieving Attribute Data
When you have finished defining attribute families, attributes, and user-defined 
labels, synchronize the new attributes with those in the data source’s tables and 
fields using the Retrieve Data functionality.

Attribute families requiring synchronization display a Y (Yes) in the Data Retrieval 
field. You can initiate this task from the Attribute Families view or the Data Retrieval 
view by selecting the attribute family record and clicking Retrieve Data. For more 
information, see “Data Retrieval” on page 154.

Table 33. Creating Entries to Trap Data

Label Code Operator Value

Single S = 1

Married M = 2

Divorced D = 3

Widowed W = 4

Negative Trap NT <= 0

Positive Trap PT >= 0
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Use the Attribute Hierarchies view to create ordered groups of attributes based on 
defined attribute families and member attributes. The Attribute Hierarchies list 
displays the predefined hierarchies that are available to you. The Attribute 
Hierarchy Levels list shows the rollup of attribute levels within each hierarchy.

Attribute hierarchies are built in two stages. First, you define a hierarchy and specify 
the attribute family from which you will be drawing attributes. Then, you define a 
hierarchical order (sequence) of up to nine levels. 

NOTE: Siebel Marketing does not prevent you from adding more than nine. 

The benefit is that you can define an attribute family once, and from it create 
multiple attribute hierarchies with as many as nine levels. Each attribute level can 
occur only once in a hierarchy.

To create an attribute hierarchy

1 From the application-level menu, choose View > Site Map > Marketing 
Administration.

2 Click the Attribute Hierarchies view tab.

3 In the Attribute Hierarchies list, create a new record.

4 Complete the necessary fields, using the following list as a guide, and save the 
new hierarchy.

Field Comment

Attribute Family Click the Attribute Family select button. In the Pick Attribute 
Family dialog box, select the attribute family from the list. Click 
OK.

Description (Optional) Type a description.

Filters Click the Filters select button to view a read-only list of filters that 
use this attribute.
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To specify attribute levels in the hierarchy

1 From the application-level menu, choose View > Site Map > Marketing 
Administration.

2 Click the Attribute Hierarchies view tab.

3 In the Attribute Hierarchies list, select the hierarchy for which levels will be 
added.

4 In the Attribute Hierarchy Levels list, create a new record.

A new row appears, and the Sequence field automatically registers the order of 
the level.

5 In the Attribute Hierarchy Levels field, click the arrow and select an Attribute 
Level from the list.

The list includes available levels within the selected Attribute Family. Each 
Attribute Level can occur only once in an hierarchy.

Repeat this procedure to add additional levels in order. The levels appear in the 
order in which you add them.

To resequence levels

■ On the Levels list, click Move Up and Move Down to adjust the sequence (order) 
of the level in the hierarchy.

Sequence numbers automatically reflect position changes. 

Name Type a unique name for the attribute hierarchy.

Number of Levels This field is automatically completed when you pick hierarchy 
levels, and save the record.

Field Comment
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■ If you remove elements of a hierarchy, reorder the remaining attribute Levels 
sequentially before saving the record by clicking the menu button and choosing 
Resequence.

CAUTION: Deleting an attribute hierarchy also removes every reference to it, 
including segments and filters, from Siebel Marketing. Delete with care to avoid 
unintentional loss of data.
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Data Retrieval
Attribute families and related fields must be periodically synchronized with actual 
attributes and fields in the data warehouse so that the number of entries in each 
attribute and field is accurate.

Use the Data Retrieval view to review database fields and attribute families in the 
system, and start the Retrieve Data (synchronization) task. For attribute families, 
you can perform this task from the Attribute Families view by selecting the record 
and clicking Retrieve Data.

NOTE: Attribute families that have been incorrectly created will not be submitted for 
data retrieval. Examples of incorrect setup for attribute families are attribute 
families with no attributes, and attributes with no label table and field and no user 
defined labels.

Resynchronizing Data and Retrieving Field Values
The Data Retrieval view provides information such as when the last data retrieval 
occurred, the number of attributes, the base table and field, and so on. 

Data should be resynchronized (retrieved again) if attributes in an attribute family 
have changed, or if a list of values is needed for a database field. Use the following 
procedure:

To resynchronize attributes and get field values using data retrieval

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > External Data Mapping.

2 Click the Data Retrieval view tab.

3 In the Data Retrieval list, select the record for which data retrieval or 
synchronization will be performed.

You can select multiple records for data retrieval by pressing CTRL or SHIFT and 
then selecting the records.
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4 Click Retrieve Data to start the process.

The data retrieval task may take several seconds to several minutes to complete 
depending on the size of the data source. 

To check data retrieval task status

1 From the application-level menu, choose View > Site Map > Server 
Administration > Servers.

2 Click the Server Tasks view tab.

3 In the Server Tasks list, locate the task and view its status in the Task State field.

4 Drill down on the Task ID hyperlink to view the task log.

Automatic Data Retrieval
You can set up data retrieval to occur automatically when you refresh your data 
warehouse. Using this feature, you can make sure that fields and attributes with 
volatile datasets are regularly synchronized with the Marketing Repository. After 
enabling automatic data retrieval, every time a new record is added to the ETL 
History table in the Siebel application, the Automatic Data Retrieval workflow 
process resynchronizes all attribute hierarchies.

NOTE: You can find the ETL History status for each load in the Diagnostics view of 
the Analytics Administration screen.

To enable automatic data retrieval

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > External Data Mapping.

2 Click the Data Retrieval view tab.

3 Select the field or attribute hierarchy.

4 In the Auto-Update field, select the check box.
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The Automatic Data Retrieval workflow is invoked anytime you insert a new record 
in the ETL Result (S_ETL_RUN) table. The workflow calls the Attribute Resync 
Service as part of its process.

To invoke automatic data retrieval, perform the following two steps in the Business 
Process Administration screen after you deploy Siebel Marketing:

■ In the Workflow Policy view, search for the Automatic Data Retrieval policy and 
set the expiration date to the date that you want the automatic data retrieval to 
run.

■ Activate the Automatic Data Retrieval workflow process as discussed in 
“Activating Workflow Processes” on page 42.

NOTE: This feature is only supported for Siebel customers that have deployed 
Siebel Analytics with the Siebel Data Warehouse.

Deleting List-of-Value Data for Fields
In the Tables and Fields view, the Enable Data Retrieval function allows you to 
create a list of values associated with a field in a particular table. If you select a 
table’s field and click Enable Data Retrieval, a list of values is created, and this list 
of values appears in the Data Retrieval list.

You can delete the record from the Data Retrieval list. Upon deletion, each reference 
to that record is removed and the check box in the Fields list is cleared. For more 
information, see “Enabling Data Retrieval for Field Values” on page 103.

To cancel data retrieval for field values

1 From the application-level menu, choose View > Site Map > Marketing 
Administration screen, and from the Show drop-down list, select External Data 
Mapping.

2 Click the Data Retrieval view tab.

3 In the Data Retrieval list, select the record.

4 Click the menu button and choose Delete Record.
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As a marketer, you continually develop new segment criteria to target specific 
segments. Sometimes this information is maintained in the data warehouse, but, 
more often, it needs to be derived. Siebel Marketing allows you to define measures 
based on complex mathematical scores, ratios, and formulas that can be used to 
refine segment definition criteria. This provides much greater flexibility for the 
marketer, bypassing the typical scenario of requiring a database administrator to 
add new fields or otherwise modify the Siebel database itself. Defined segments can 
be used with multiple programs and campaigns.

Measures provide a flexible and powerful way to define straightforward building 
blocks for use in segment design and launching campaigns. Measures can be based 
on a numeric value that is derived directly from your database (bound measures), 
calculated using other measures (custom measures), or drawn from database fields 
(List Measures).

Siebel Marketing’s Measures views allow you to create, modify, or delete these 
measures, which are used as building blocks for buckets, filters, segments, and 
campaign load mappings. 

This chapter covers how to create bound and custom measures. It also discusses 
how to use List Measures which reference alphanumeric database fields (such as 
name, address, customer key, and so on). Although list measures cannot be used in 
other measure definitions, they are applied when creating distribution lists of 
contacts, and when mapping to external contact data. 

Chapter 5, “Defining Attributes and Buckets” explains how to define values for each 
measure. Chapter 9, “Defining Filter and Segment Criteria” explains how to use 
these measures in a segment definition.

When creating measures, you perform the following tasks:

1 Create Bound Measures by mapping to numeric fields in your database. For more 
information, see “Bound Measures” on page 159.
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2 Use Bound Measures to perform calculations at any level in your customer hierarchy. 
For more information, see “Using Bound Measures in Calculations” on page 160.

3 Define Custom Measures with expression-type logic. For more information, see 
“Custom Measures” on page 161 and “Building Custom Measure Expressions” 
on page 164.

4 Aggregate a custom measure, as applicable. For more information, see “About 
Aggregation Levels” on page 169 and “Adding an Aggregation Function” on 
page 170.

5 Restrict the custom measure to a portion of the data. For more information, see 
“Adding Restrictions to Custom Measures” on page 171.

6 Create List Measures for use in campaign load mappings and output file layouts. For 
more information, see “Defining List Measures” on page 173.
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Bound Measures
Bound measures are typically used for calculation or with other measures to create 
custom measures. Bound measures are mapped to, and derive information only 
from numeric database fields such as HOME_VALUE, ANNUAL_INCOME, 
CREDIT_RATING, and so on. For information about defining a measure on a 
character field, see “Defining List Measures” on page 173.

NOTE: If you use a bound measure, records returned in the snapshot may be 
aggregated to other targeting levels of the customer hierarchy. The Marketing Server 
stores only one record for the targeting level in the snapshot. If you expect a field 
to have multiple values and you want to generate a record for each one, you should 
enable the field for data retrieval, create the segment using this field, and retrieve 
the information in this way. For additional information, see Chapter 9, “Defining 
Filter and Segment Criteria.”

Bound measures may be created in the All Measures view as well as the Bound 
Measures tabbed view. From the All Measures view, drill down on the measure’s 
name to open the measure-specific details view. Alternately, click the Bound 
Measures view tab to list every bound measure. 

The Parent Measures list displays every custom measure that uses the selected 
bound measure. Drill down on the parent measure name to view details.

Creating Bound Measures
Use the following procedure to create bound measures.

To create bound measures

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Measures.

2 In the All Measures list, create a new record.

3 Complete the necessary fields.
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a Type a Name and Description for the measure.

The name field has a maximum length of 50 characters.

b In the Type field, choose Bound from the list.

The measure type automatically is set to bound if you are creating a measure 
from the Bound Measures view. If you are creating a measure from the All 
Measures list, set the measure type as bound.

c Click the Table select button.

d In the Pick Tables dialog box, choose a table and click OK.

e Click the Field select button.

f In the Pick Fields dialog box, choose the field from the table that the measure 
will reference and click OK.

The section “Defining Bucket Values” on page 138 explains how to define buckets 
using a bound measure.

Using Bound Measures in Calculations
Bound measures are used for record-level computation or are included as part of a 
custom measure definition.

For example, a bank might want to create measures that help determine how many 
times a customer interacts with a teller for an account transaction, and then 
compute the number of teller transactions that have occurred at the household 
level. 

A bank customer might have several accounts (checking, savings, money market, 
IRA, and so on). One household (defined here as a mailing address) can have 
several customers (husband, wife, children). The bank might set up the following 
one-to-many (1:M) customer hierarchy:

■ Household (highest level)

■ Customer (intermediate level)

■ Account (lowest level)
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Using measures, the bank can perform calculations to get numeric data at any of 
those levels. The bank can calculate how many teller transactions each single 
customer has by adding up the teller transactions for each of the customer's 
accounts. It can then determine how many teller transactions were performed at the 
household level by adding teller transactions by each customer in the household. 
The process of adding up from a lower level (such as Account) to a higher level 
(such as Customer or Household) is called aggregation.

Custom Measures
Custom Measures are derived metrics that are built by using formulas and 
calculations based on other measures. They may include logical functions such as 
IsPositive, IsZero, and Not, and mathematical functions such as Absolute, Random, 
and Sign. Custom measures can also be aggregated to various targeting levels of a 
customer hierarchy using aggregate functions such as Sum, Count, Average, 
Minimum, or Maximum.

The Custom measure detail view includes the Custom measure form at top, and the 
measure-builder panes, which contains Available Measures, and Expression Builder 
elements. In addition, you can use the optional custom measure Aggregation view 
and Restriction view to refine the data set to which the custom expression applies.

Custom measures can be aggregated to each targeting level within the customer 
hierarchy. If you select a customer hierarchy and targeting level for a custom 
measure, Siebel Marketing assumes that you intend to aggregate the measure, and 
requires an aggregation function before you can save the custom measure.

When you specify the level, you are indicating that data from the level below should 
be aggregated up to the level selected. For example, if a customer has multiple bank 
accounts, calculating a Total Balance (sum) across accounts would be a custom 
measure for the targeting level.

The choice of aggregation levels determines what measures are available to use in 
the measure you are building. If you select a secondary targeting level as your 
aggregation level, you can only work with measures at that level and below. 
Measures aggregated at higher levels are not available.
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Restrictions imposed using the custom measure Restriction view are flagged with a 
check mark in the Restrictions check box after you save the restriction. Measure 
restrictions are useful if you want to see list measure output that is computed at a 
certain hierarchical level, a specific bucket definition, and so on without restricting 
the counts of a targeted segment or the entire stage. For example, you might want 
to know the average dollars that were spent in the last quarter of 2000 but see this 
data for customers that spent money in the four quarters of 2000.

Table 34 provides examples of some uncomplicated custom measures and 
expressions.

Creating Custom Measure Records
The following procedure details how to create custom measures using the custom 
view tab. A custom measure also may be defined using the All Measures view, with 
the measure type set to custom, or in the Aggregation, and Restriction views. 

When defining the measure from the All Measures view, drill down on the measure 
name to open the Custom view and complete the rest of the mandatory details in 
the form before building the custom measure criteria.

Table 34. Custom Measure Expressions

Custom Measure Name Base Measure Type
Targeting 
Level

Aggregation 
Function Expression

Average Opening Account 
Balance

Bound: Opening 
Account Balance

Customers Avg Opening Account 
Balance / 12

Maximum Opening 
Account Balance

Bound: Opening 
Account Balance

Customers Max Opening Account 
Balance 

Minimum Opening Account 
Balance

Bound: Opening 
Account Balance

Customers Min Opening Account Balance

Number of ATM 
Transactions

Bound: Transaction 
Amount

Account Count Transaction Value

Number of ATM 
Transactions by Customer

Custom: Number of 
ATM Transactions

Customers Sum Number of ATM 
Transactions

Number of Orders Per 
Month

Bound: Annual 
Orders

Account Sum Annual Orders/12
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When creating a custom measure, you may choose to specify a customer hierarchy, 
or a customer hierarchy and a targeting level within that hierarchy. 

If you specify a customer hierarchy, measures built on that selected customer 
hierarchy are available for use in the expression. Measures not affiliated with any 
customer hierarchy are also available for selection.

If neither a customer hierarchy nor targeting level has been specified, only measures 
that do not have any affiliation with any customer hierarchy are available for 
selection.

To create a custom measure 

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Measures.

2 Click the Custom view tab.

3 In the Custom measures form, create a new record.

4 Complete the necessary fields.

a Type a name for the measure.

The name field has a maximum length of 50 characters.

b Type a description.

Include descriptive information on planned aggregations, restrictions, or 
both.

c If you want to aggregate the measure, click the Customer Hierarchy select 
button. 

d In the Pick Customer Hierarchy dialog box, select a predefined customer 
hierarchy and click OK.

❏ You cannot add a customer hierarchy after the measure is saved.

❏ If you are copying a custom measure with an established customer 
hierarchy, you cannot change the customer hierarchy in the copy. You can 
change the targeting level (if there is more than one), and the expression.

e If you are aggregating the measure and have selected a customer hierarchy, 
click the Targeting Level select button. 
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f In the Pick Targeting Level dialog box, choose a level from within the selected 
customer hierarchy and click OK. 

g If you specified a customer hierarchy and targeting level, click the 
Aggregation Function select button. 

h In the Pick Aggregation Function dialog box, choose a function and click OK.

Options are Avg, Count, Distinct, Min, Max and Sum.

Building Custom Measure Expressions
When creating custom measures, you can use measures listed in the Available 
Measures list, the operator buttons, the computer’s keypad, and the available 
mathematical and logical function values to build the expression.

The Available Measures list shows: 

■ Bound measures

■ Measures defined within the selected customer hierarchy

■ Custom measures not associated with a particular customer hierarchy

Table 35 describes the functions that are available when creating logical custom 
measure expressions.

Table 35. Logical Functions

Logical Function Description Syntax

IsNegative Returns 1 if the number is negative or 0 if the 
number is positive. 

IsNegative(number)

IsPositive Returns 1 if the number is positive or 0 if the 
number is negative. 

IsPositive(number)

IsZero Returns 1 if the number is zero or 0 if the 
number is nonzero.

IsZero(number)

NOT Reverses the value of its argument. Use NOT 
when you want to verify that a value is not 
equal to one particular value.

Not(logical)
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Table 36 describes the functions that are available when creating mathematical 
custom measure expressions.

To add expressions to custom measures

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Measures.

2 In the All Measures list, select a custom measure.

3 Click the Custom view tab.

The custom measure’s details appear in the form above the expression builder.

Table 36. Mathematical Functions

Mathematical 
Function Description Syntax

Abs

(Absolute value)

Returns the absolute value of a number. The 
absolute value of a number is the number 
without its sign.

ABS(number) 

Exp

(Exponential)

Returns e raised to the power of number. The 
constant e equals 2.71828182845904, the base of 
the natural logarithm.

Exp(number)

Ln

(Natural log)

Returns the natural logarithm of a number. 
Natural logarithms are based on the constant e 
(2.71828182845904).

ln(number)

Random Returns an evenly distributed random number 
greater than or equal to 0 and less than 1. 

No argument is needed for this function. If a 
user adds an argument, Random still will 
generate a random number between 0 and 1.

Random (number) 

Sign Determines the sign of a number. Returns 1 if 
the number is positive, zero (0) if the number is 
0, and -1 if the number is negative.

Sign(number)

Sqrt

(Square root)

Returns a positive square root. Sqrt(number)
Version 7.5.3 Siebel Marketing Guide 165



Creating Measures

Custom Measures
4 In the Available Measures pane, select a measure and click Add to Expression.

NOTE: To show fields such as measure type and customer hierarchy, click the 
menu button and choose Columns Displayed.

5 To use logical or mathematical functions in the expression:

a Select the category (Mathematical, Logical, or All).

The elements of each function category appear in the pane at right.

b Double-click the function in the elements list. 

The function appears in the expression pane at the cursor location. 

Function syntax is detailed in Table 35 on page 164 and Table 36 on 
page 165.

6 Add numerical values to the expression using the computer’s keypad. 

The values appear at the cursor location in the expression. 

When typing numbers greater than 999, do not use digit grouping symbols such 
as commas or periods. For example, do not type 45,386 (comma separating 
groups) or 45.386 (period separating groups). Instead, type 45386.

7 To build compound expressions, click the operator buttons and add additional 
measures and expressions.

Make sure to position the cursor where you want to insert the operator before 
inserting an item.

To use parentheses, select the expression to be contained within the 
parentheses, and then click the open parenthesis button and the close 
parenthesis button. Use parentheses whenever possible to isolate pairs of values 
and an operator.

8 When you have finished building the custom measure expression, click Validate 
& Save.
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To delete all or a portion of the expression

■ In the Expression Builder pane, select the part of the expression to be removed, 
and press the Delete key on your keyboard. 

To edit the custom measure from this view

■ In the Custom form, make changes as needed and save the record.
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Aggregation and Restrictions for Custom Measures
Chapter 4, “External Data Mapping,” explains customer hierarchies, and targeting 
levels within a hierarchy. Using measures, you can extend these concepts with 
aggregation and restrictions. 

Aggregation determines how a custom measure is calculated. If you want to 
aggregate a custom measure, make sure you select a customer hierarchy and 
targeting level when creating the custom measure because aggregation is tied to the 
targeting level. After you have chosen a hierarchy and targeting level, an 
aggregation function is required.

Restrictions allow you to limit a measure to a portion of the data and the rest of the 
records in the table are ignored when the measure is computed. For example, you 
might want to restrict data to a geographic region by ZIP (Postal) Code, or by a time 
period. The restriction applies to any related measure that uses this restricted 
custom measure. The restrictions can be defined by buckets or attribute hierarchies 
that belong to the selected customer hierarchy and targeting level.

NOTE: A measure used at the bucket level should be aggregated to the same level as 
the bucket. Attempting to use data at a lower level will typically result in undesired 
selections.
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About Aggregation Levels
There are three aggregation levels in Siebel Marketing.

■ Record. Measures aggregated at the record level are calculated for each record. 
Typically, this level is used when you want to perform a simple transformation 
on a bound measure, for example, converting annual income into monthly 
income. To use record-level aggregation, do not select an aggregation level when 
creating a custom measure.

■ Targeting Level. Measures aggregated at a level within a customer hierarchy are 
calculated when records for a distinct value of the primary targeting level are 
collected.

For example, if the customer hierarchy has SSN as the primary targeting level, 
and Account_ID as the secondary targeting level, account information for one 
Social Security number (SSN) is collected before the measure is calculated. Each 
time Siebel Marketing gets a new SSN, it repeats the customer hierarchy 
aggregations.

■ Customer Hierarchy. The customer hierarchy is where measures aggregated at a 
lower level get added up. For example, you might have a Customer-Account 
Hierarchy, with Customer as the primary level, Account as the secondary level, 
and other levels under Account. If your measure is derived at the Account level, 
the lower levels are rolled up for aggregation.

For example, if you are using a function such as MIN, you would not apply the 
function to records aggregated at the record level, because the MIN of one record 
is no different than the record itself. You get value out of applying the MIN 
function to records aggregated at a level within the customer hierarchy, or the 
customer hierarchy itself.
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Adding an Aggregation Function
The custom measure Aggregation view displays information about the selected 
custom measure in the form at the top. The Minor Aggregation list expands to 
display Attribute Hierarchies and Buckets belonging to the measure’s customer 
hierarchy. By selecting a Bucket or Attribute Hierarchy value, you specify how the 
record-level data should be aggregated (for example, Average by Month, Quarter, or 
Year).

NOTE: Whenever you modify a custom measure expression, save it first before 
beginning aggregation.

To apply aggregation to the custom measure

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Measures.

2 In the All Measures list, select the custom measure, and drill down on the 
measure name.

3 Click the Aggregation view tab.

4 In the Minor Aggregation list, expand the folders to display Attribute Hierarchy 
and Bucket values.

5 Select the desired attribute or bucket value check box.

Selected values have a check mark. To discard a selected item, select it again to 
remove the check mark.

NOTE: You cannot select multiple levels within the same attribute hierarchy, 
however, you can select values from different hierarchies, for example, Yearly 
and Region. 

6 Save the record to commit the aggregation.
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Adding Restrictions to Custom Measures
Build a restriction for the measure using the custom measure Restriction view. This 
view provides information about the selected custom measure in the form and 
allows you to select attribute hierarchies and buckets to use as restrictions from the 
Restriction tree. When you select a specific value from an Attribute Hierarchy or 
Bucket, you restrict the aggregation to records with the selected value.

Table 37 provides examples of custom measure aggregations and restrictions.

To apply restrictions to custom measures

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Measures.

2 In the All Measures list, select the custom measure, and drill down on the 
measure name.

3 Click the Restriction view tab.

4 In the Restriction tree pane, expand the folders for Attribute Hierarchies and 
Buckets to display values.

5 Select a value:

a To include a value, click a value’s check box and a check mark appears.

b To exclude a value, clear the check mark by clicking on it.

Table 37. Custom Measure Restrictions

Measure Name Level
Aggregation 
Function Expression Restricted to Result

Monthly Account 
Usage

Account Sum Transactions 2001 (from a time-
based attribute 
hierarchy)

Only aggregates 
transactions that 
occur during 2001

Number of 
Customer 
Withdrawals

Customers Sum Transactions 
per Account

Transaction Type = 
Withdrawal

Only aggregates 
transactions of type 
withdrawal
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c To select values in a range of values, click Select Group and select the range 
of values. 

Selected attributes have a check mark. 
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Defining List Measures
List measures are mappings to database fields such as name, address, state, postal 
code, customer key, and so on. 

These measures are used as columns in output file layouts for distribution lists and 
to help you define Campaign Load Mappings, which specify the data on each 
campaign contact that is recorded in the Siebel transaction database. Unlike bound 
measures, list measures do not support calculations, so they cannot be used in other 
measure definitions.

Use either the All Measures list or click the List view tab, to create list measures by 
mapping to a table and field in your data warehouse. For example, you might define 
a list measure called First Name and map it to a field called FNAME in a table called 
CUST_INFO. When you define your list formats and generate a campaign 
distribution list that uses the First Name field as part of the format, the process 
retrieves your customers’ first names from the CUST_INFO.FNAME field.

When you create a list measure from the All Measures list, set the measure Type to 
List. The measure type is automatically set to list when you create the measure from 
the List tab view.

The List view tab displays defined list measures and output file layouts that use the 
measure. To view details of the output file layout, drill down on the name link. For 
more information, see “Working With Output File Layouts” on page 183.

Use the following procedure to create list measures that are used for output file 
layouts for distribution lists and Campaign Load Mappings for external data 
mapping.

To create a list measure

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Measures.

2 In the All Measures list, select the custom measure, and drill down on the 
measure name.

3 Click the List view tab.

4 In the List measures list, create a new record.
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5 Complete the necessary fields.

a Type a Name and Description for the list measure.

The name field has a maximum length of 50 characters.

b Click the Table select button.

c In the Pick Tables dialog box, choose the table that contains the field that will 
be referenced by list measure and click OK.

For example, you might choose a table called CUSTOMERS. 

d Click the Fields select button.

e In the Pick Fields dialog box, choose the field from the list of fields in the 
table and click OK.

For example, you might choose the reference field TELEPHONE in the 
CUSTOMER table.

Repeat this procedure to create list measures for every table and field that contain 
information you might use in a contact list. 

Typical list measures might include the following:

■ Customer ID

■ Title (Mr., Mrs., Ms., Dr., and so on)

■ Name

■ Address (including street, city, state, and ZIP or postal code)

■ Telephone number

■ Email address

■ Account information (balances, service level, service bundle, and so on)

NOTE: You will need to create list measures for each unique identifier that 
corresponds to each targeting level (Key 1, Key 2, and so on). For more information, 
see “About Customer Hierarchies” on page 105. 
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Siebel Marketing uses source code capabilities with exported lists, allowing proper 
campaign tracking and reporting. The source code format can include encoded 
information about each customer or prospect based on any database field, whether 
real or derived. You can also define and maintain multiple formats for use in 
different campaign scenarios. After you launch the campaign, the source codes 
assigned to each customer can be captured as part of the response and decoded for 
closed-loop tracking.

Siebel Marketing supports the assignment of source codes to each contact in a 
campaign. A source code appears to the customer as a seemingly indecipherable 
mix of alphanumeric characters that typically can be found on a mailer. Marketers, 
however, can gather a wealth of information about the demographic makeup of the 
consumer responding to an offer, as well as the particulars of the marketing 
campaign that delivered the promotion, by decoding the source code. 

In a typical scenario, a customer contacts a company’s call center to place an order 
for merchandise or ask questions about an item advertised in a catalog. During the 
first few minutes of the call, the representative asks the customer to read the code 
that appears on the catalog’s label or order form. Depending on the information 
received, the call center representative may be authorized to present to the 
customer a better offer on the merchandise than the one in the catalog.
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The call center representative can also capture the customer’s source code to make 
sure that the marketing organization can make the link that this customer is 
responding to a direct marketing campaign.

In Siebel Marketing, a unique source code is assigned to a marketing program 
element each time an element is created. Marketing program elements include 
program plans, stages, segments, campaigns, and waves.

NOTE: When marketing programs, segments, and campaigns are created, Siebel 
Marketing assigns a unique source code value to new program stages, segments, 
and campaigns. Although the stage or campaign’s name may be duplicated, the 
source code field is the actual identifier. If you change the system-assigned source 
code to something more meaningful to you, make sure it is a unique value.

These individual source code components are concatenated and grouped according 
to the sequence and format that you specify in the Source Code Formats view, 
shown in Figure 3 on page 176, to help you track your marketing program and 
analyze response to campaigns and offers. The source code format can contain up 
to 75 characters and may optionally include other tracking information.

When you build a distribution list, the source code for each contact is assembled, 
based on the characteristics associated with the target contact in the marketing 
program. For example, the source code for a contact who is in Segment 1 and is in 
the first wave of Campaign 1 can be different from the source code for a contact who 
is in Segment 3 and the second wave of Campaign 1.

Figure 3. Typical Output List Layout and Source Code Format on Mail Label
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In addition, you can tailor the contact information that is generated for the 
distribution list to suit your business requirements. At minimum, a list has a 
contact’s name or some other identifier and a source code. It may also contain an 
address (if you are mailing to the contact), phone number (if you are calling the 
contact), email address, account number, and so on. 

Using the Output List Layouts view, you can define, edit, and sequence the fields 
(types of information) that appear in your distribution list or mail label, and specify 
which seed contacts (quality control personnel receiving the offer) will be included 
in the list. Output file layout elements include a measure, a field, and a source code.
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Creating Source Code Formats
The Source Code Formats view allows you to define a source code format, specify 
the individual components that will be included, and determine how these 
components will be arranged or sequenced.

After creating a source code format, you can use the source code in the following 
ways:

■ Include in an output file layout.

■ Embed as a personalization element in an email offer.

■ As input in the customer-facing eMarketing home page (in the applet named Do 
you have another offer?).

■ As a direct input to a response from any of the Response views.

NOTE: Always associate the source code format with the program plan stage before 
generating the snapshot.

The Source Code Formats list shows available source code formats. The All 
Components list displays details of the source code format selected in the list and 
is used to create the structure of the source code grouping, or format. The All 
Components list contains the automatically computed length of each source code 
(maximum of 75 characters).

By clicking Move Up or Move Down, you can rearrange components in the format. 
If you delete components (for example, component 2 and component 4 of 5), click 
the menu button and choose Resequence to reorder the remaining components 
before saving the record. 
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To create a source code formats

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Source Code Formats.

2 In the Source Code Formats list, create a new record.

NOTE: The customer hierarchy and the targeting levels (within the specified 
hierarchy) determine the custom measures and buckets (based on custom 
measures) that are available in your source code format. If you copy a source 
code format, you cannot change the selected customer hierarchy. However, you 
can change the code’s sequence, measures, and attributes. For more information 
on customer hierarchies and targeting levels, see Chapter 4, “External Data 
Mapping.”

3 Complete the necessary fields for the Source Code Format.

a Type a name and a description for the format. 

b Click the Customer Hierarchy select button.

c In the Pick Customer Hierarchy dialog box, select the predefined customer 
hierarchy and click OK.

NOTE: To view details of the customer hierarchy and any targeting levels 
associated with the source code format, click the hierarchy or targeting level 
name links to open the Customer Hierarchies view.

d Click the Targeting Level select button.

e In the Pick Targeting Level dialog box, select a level and click OK.

4 When you save the source code format, the new format appears in the Source 
Code Formats list.

The Stages read-only field lists program stages that use this source code format. 
Click the Stages select button to open the Stages dialog box and review the list.
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To define source code format components

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Source Code Formats.

2 In the Source Code Formats list, select a source code format.

3 In the All Components list, create a new record. 
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4 Complete the fields for the component, using the following information as a 
guide.

Field Description

Buckets If the source code format component is a bucket (a range of values), 
click the Buckets select button. In the Pick Buckets dialog box, 
choose a bucket and click OK. An example of a bucket that might be 
used in a source code format is one that identifies the customer’s 
credit rating.

Measure If the source code format component is a measure, click the Measure 
select button. In the Pick Measure dialog box, select the measure 
from the list of available measures and click OK. An example of a 
measure that might be used in a source code format is Account ID or 
Social Security number. Measure can include values for bound, 
custom or list measures.

Name Choose the name of the source code component from the list. 
Options are Stage, Segment, Campaign, Wave, Measure, and 
Buckets.

Sequence Sequence determines the position of the code component in the 
source code format. Sequence is automatically set when source code 
components are added to the format. Use Move Up, Move Down or 
Resequence to adjust the order.

Width The width of the source code component is automatically added. 
Change the width if desired. Defaults are wave=1, bucket=5, 
measure=16, stage=10, segment=10, and campaign=10.

If the component’s source code width is 16 characters and you 
specify 6 as the width in this field, the component’s individual 
source code is truncated to the first 6 characters.

If the component’s code has a width of 10 characters, and you 
specify 20 as the width, 10 blank spaces appear in your source code 
format.

The maximum width for the entire source code format is 75 
characters.
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5 Save the component.

NOTE: Repeat Step 3 through Step 5 to add more components one row at a time. 

6 Adjust the sequence of the components by clicking Move Up and Move Down.

To reorder deleted components before saving the changes, click the menu button 
and choose Resequence.

Modifications in the Source Code Format are reflected the next time a program 
snapshot is built. For information on how to associate a source code with a 
stage, see “Adding a Stage to the Program” on page 411.
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Working With Output File Layouts
An output or distribution list of contacts is generated when your campaign is 
loaded. The customer information is arranged according to the predefined output 
file layout, which is designed according to how the list will be used. A fulfillment 
vendor might require a full name and address for each contact in the list to ship a 
product sample. A call center representative might only require the customer’s 
name, telephone number. and account rating.

For example, if your direct mail output file layout requires a full address as well as 
a source code, you add predefined list measures such as first name, last name, 
address, city, state, and ZIP and a source code format in sequential order as you 
define the list format.

You can define, edit, and sequence the fields (types of information) that you want 
to appear in your distribution list. In addition to customer contact information, you 
can also specify that you want to integrate seed contacts—quality control personnel 
that will receive the offer and evaluate its timeliness, appearance, and so on. For 
details, see “Creating and Modifying Seed Lists for Output File Layouts” on 
page 187.

The Output File Layouts list displays predefined list formats. Selecting an output file 
layout displays its properties in the All Components list where you can display a list 
of components or details about the selected component.

Creating Output File Layouts
Use the Output File Layouts view to define, edit, and sequence the fields that you 
want to appear in your distribution list. 

To create output file layouts

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Output File Layouts.

2 In the Output File Layouts list, create a new record.

3 Complete the necessary fields.

a Type a name and description for the format.
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b Select the Header check box if list header information is required by your 
vendor. 

If this check box is selected, header information is automatically added to the 
list when it is generated. The header format includes the following:

❏ Stage name

❏ Campaign name

❏ Campaign source code

❏ Vendor name

❏ Wave source code

❏ Output file layout ID

❏ Location of the list file (path)

❏ Time stamp

❏ Number of records

❏ Record length (the sum of the width of the components in the output file 
layout)

c Click the Customer Hierarchy select button.

d In the Pick Customer Hierarchy dialog box, select the customer hierarchy for 
the format and click OK.

You cannot change the customer hierarchy after the record is saved.

e Click the Targeting Level select button.

f In the Pick Targeting Level dialog box, choose a level and click OK.

The customer hierarchy and targeting level chosen here determine the 
availability of custom measures when you define components of the output 
file layout. All bound and list measures are available, regardless of customer 
hierarchy.

g If you include seed names in the list, click the Seed List select button. 
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h In the Pick Seed Lists dialog box, choose the predefined Seed List and then 
click OK. 

For more information on creating a seed list, see “Creating and Modifying 
Seed Lists for Output File Layouts” on page 187.

If you later disassociate a seed list from the format, make sure you remove 
seed list information from the Seed List Column and Seed List Default fields 
in the Details view fields. These fields are discussed in Table 38.

Adding Components to Output File Layouts
In the All Components list, you can choose All Components or Details from the 
Show drop-down list to display a list of components or editable details of the 
selected component.

To add components to output file layouts

1 From the application-level menu, choose View > Site Map > Marketing 
Administration screen > Output File Layouts.

2 In the Output File Layouts list, select a format.

3 In the All Components list, create a new record.

4 Complete the fields for each component, using Table 38 as a guide.

5 Save the record after creating each component.

Table 38. Fields for Output File Layout Components 

Field Comment

Alignment Select the alignment for the Output File Layouts field. The options are Left and 
Right. For example, you might want the name and address of the contact to be 
aligned at left and a code to appear at right.

Database Field If the Type is field, click the Field select button. In the Pick Fields dialog box, 
select a database field and click OK.
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Field Format (Optional) The default is the native format for the stored data. 

Choose a format value (mask) to assign to a field. Options are MM/DD/YY and 
YYYYMMDD, (999) 999-9999 (phone number), 999-99-9999 (SSN), AAAAA 
(ZIP), AAAAA-AAAA (ZIP+4).

Your administrator should set up this list of values to conform to your business 
and regional needs.

Measure Name If the Type is a measure, click the Measure select button. In the Pick Measures 
dialog box, select a measure and click OK.

Number of Values Type a number that controls the number of values that appear in the list for this 
field. The maximum number of values is 50000.

For example, if vehicle name (Veh_Name) is the field value, and you are only 
interested in the first two vehicles per household, you would add 2 values here. 
When the list is distributed, two fields are created to hold this information. 

Another example is if a consumer has two addresses associated with his or her 
account. If the value of the Address field format is 1, only the primary address 
associated with the consumer appears on the list.

Seed List Column Choose the seed list column name that closely matches the Database Field or 
Measure. For example, the field entry might be customer.first name and the seed 
list column name, FRST_NAME.

If you copy a list format without seeds and then attach a seed list to the format, 
make sure you complete this field in the copied list format.

Seed List Default If there is no close match for the seed column name, type a series of numerals as 
a default.

If you copy an output file layout without seeds and then attach a seed list to the 
layout, make sure you complete this field in the copied list format.

Sequence This field is automatically populated as you add output file layout components. 

■ To change the sequence after saving a component, select the component and 
click Move Up or Move Down. 

■ If you delete a component, reorder the remaining components by clicking the 
menu button and choosing Resequence.

Table 38. Fields for Output File Layout Components 

Field Comment
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Creating and Modifying Seed Lists for Output File Layouts
Use the List Management views to add or edit prospects that you want to designate 
as seeds. Then compile those prospects as a new internal list, which can be chosen 
as a seed list in the Marketing Administration screen’s Output File Layouts view.

To add prospects and create a seed list

1 From the application-level menu, choose View > Site Map >List Management 
> Prospects.

2 In the Prospects list, create a new record.

3 In the More Info form, complete the necessary fields for the prospect that will 
be used as a quality control seed and save the record.

NOTE: Repeat Step 2 and Step 3 to add more prospects.

4 In the Prospects list, select the name of each quality control prospect that you 
want to include in the seed list.

TIP: Use CTRL select to choose nonsequential and SHIFT select to choose 
sequential names in the prospects list.

5 In the Prospects list, click New Internal List. 

Type Choose the component type. Options are Measure, Source Code, and Field.

Width A default value is automatically added. The default output when generating a list 
is ASCII. ASCII format has a maximum record width of 4K.

When you send list files to vendors you can indicate that you want to use fixed-
width output instead of ASCII. To use a fixed-width output, you can specify 
EBCDIC as the form in the Campaign Waves view (Campaigns screen, Waves 
view tab, List Distribution list).

To change the Width value, click the calculator button and type a numerical value 
not to exceed 2,000, for fixed-width output.

Table 38. Fields for Output File Layout Components 

Field Comment
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6 From the Show drop-down list, select Lists. 

7 In the Lists list, find the list record with a name consisting of your user ID and 
the date and time that you created the list. 

Rename the seed list, if desired. 

To change the name of the seed list

1 In the Prospect Lists list, drill down on the list name.

2 In the List Name field, edit the name and save the record.

For information on associating the seed list with a marketing program list, see 
“Working With Output File Layouts” on page 183.

Previewing Distribution Lists and Formats
After a snapshot has been built, you can review the output file layout, using the 
Programs screen’s List Preview view, before generating the list. This view shows the 
order in which the fields occur, their width, and alignment. 

NOTE: If you modify an output file layout, the changes are reflected in the next 
snapshot that is generated.

For more information, see Chapter 19, “Previewing and Generating Lists.”

Associating an Output File Layout With a Program Stage
The output file layout is associated with a program stage in the Stage Detail form.
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Navigate to the Stage Detail form by double clicking on the stage object in the 
program flow workspace. Then, associate the output file layout by clicking the 
select button in the Output File Layout field and choosing the format from the list. 
For more information, see Chapter 13, “Designing Marketing Program Plans.”

NOTE: Output files are generated when you load the campaign. If you add or remove 
any contacts from the campaign after the campaign load, the changes will not be 
reflected in the output list.
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Vendors are external partners that receive lists of target contacts when you launch 
a campaign. Your campaign strategy might call for vendors such as call centers, 
fulfillment centers, and printers to split lists of contacts. Some customers would 
receive a telephone call, others a direct mail offer, and a third group would receive 
promotion samples.

Use the Vendors view to create a library of vendor profiles for your marketing 
programs. Vendors include telemarketers, fulfillment houses, and any other 
company you retain to help you with campaign distribution.

Vendor Tasks
When you launch a marketing campaign, the generated output list is automatically 
sent to the specified vendor using the vendor’s preferred distribution method and 
communications protocol (File Transfer Protocol, email, and so on). 

Before creating a vendor record, make sure the following tasks have been 
performed:

■ Create Output File Layouts. Ask your vendor what format they prefer for the 
automatically generated distribution lists. For example, do they want the list to 
contain a header or do they prefer ASCII (default) or fixed-width output. Then, 
create an output file layout tailored to the vendor’s preferences. 

You will be asked to specify the output file layout when creating the vendor 
profile. For details, see “Working With Output File Layouts” on page 183.
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■ Determine Distribution Method and Create Distribution Profile. As you are creating 
the vendor record, you will need to select a distribution method and a 
distribution (communications) profile for the method. Set up distribution 
profiles that reflect each vendor’s requirements. 

For example, if your vendor prefers to receive list files using File Transfer 
Protocol (FTP), you would need to set up a communications profile for that 
vendor containing information on HostName, IP Address, Password, and so on. 
Communications profiles are set up using the Communications Administration 
screen’s Communications Drivers and Profiles view.

If the list files will be sent to the vendor attached to email, set up a 
communications profile for email, and verify that the vendor contact has 
provided an email address. For more details, see “Defining Distribution Profiles 
for Vendors” on page 193.

If someone in your marketing department will be receiving the distribution list, 
rather than an outside vendor, a vendor record and communications profile that 
includes the team member’s email address should be set up.

Defining Vendors
Use the following procedure to set up profiles for the third-party vendors that will 
receive the distribution list of contacts. If your marketing department is the list 
recipient, set up a vendor profile using the marketing department contact as the 
vendor.

To define vendors and assign list distribution methods

1 From the application-level menu, choose View > Site Map > Marketing 
Administration screen > Vendors.

2 In the Vendors list, create a new record.
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3 Complete the fields for the vendor definition, using Table 39 on page 192 as a 
guide and save the record.

NOTE: If one vendor can handle multiple list formats, such as a direct mail format 
and a telemarketing format, create separate vendor profiles for each type. For 
example, the profiles might be named: Ace Fulfillment: Direct Mail, and Ace 
Fulfillment: Telemarketing.

Table 39. Vendors View Fields

Field Comment

Address, City, State, ZIP 
(Postal Code), Country

Click the select button and in the Account Addresses dialog 
box, add a new account address by clicking New.

Type the vendor’s address city and postal code in the fields 
provided. Choose State and Country from the lists.

Contact Name Click the Contact Name select button. In the Add Contacts 
dialog box, select the contact name and click OK. 

If the contact does not appear in the list, add the relevant 
information using the All Contacts list. (From the application-
level menu, choose View > Site Map > Contacts > All 
Contacts). 

By default, the system looks for the email address in the 
EMAIL_ADDR column of the S_CONTACT table. If you store 
the email address in a different column, refer to Siebel 
Communications Server Administration Guide to configure 
the Recipient Email Address Field.

Default List Format Click the Default List Fmt select button. In the Pick Output 
File Layouts dialog box, choose a predefined output file 
layout and then click OK. For more information on creating 
List Formats, see “Working With Output File Layouts” on 
page 183.

Distribution Method Choose the method that describes how the distribution list 
will be sent to the vendor. Options are Direct Mail, Email, Fax, 
or FTP.

Distribution Profile Choose from the list of predefined distribution profiles. 
Distribution Profiles are defined using the Communications 
Administration > Communications Drivers and Profiles 
view.
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Defining Distribution Profiles for Vendors
Use the Communication Administration screen’s Drivers and Profiles view to define 
communications profiles for email, fax, and FTP distribution of lists to vendors. 
Output file layouts and vendor profiles must be defined for all types of lists. If you 
are using email or FTP, you must also define Email Address, Distribution Method, 
and Distribution Profile in the Vendor profile. For more information, see “Using 
Delivery Profiles - Email, eNewsletter, and Fax” on page 294.

Siebel Marketing provides default drivers in its library that can be modified for use 
when sending files to a vendor. A system or marketing administrator can create 
distribution profiles for each of these driver types that override the default 
parameters for that driver. For more information on communications drivers and 
profiles, see Siebel Communications Server Administration Guide.

Email Address The email address for the vendor is automatically added if it 
has been defined for the selected vendor contact. You cannot 
add the email address in this view.

If you are planning to send a generated list to the vendor 
using email, the contact’s email address must be added in the 
All Contacts or My Contacts view.

Fax Type the vendor’s fax number.

Name Type the vendor’s name.

Phone Type the vendor’s telephone number.

Table 39. Vendors View Fields

Field Comment
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Real-time marketing offers are based on new customer information received during 
a phone call or a Web session. For example, if a customer provides a new address 
during a phone call or on a Web site, the offers and the order in which offers are 
presented may change.

This ability to adjust offers in real time can provide several benefits. It can increase 
revenue by using information obtained during inbound customer communications 
to create cross-sell and up-sell opportunities. It can also reduce marketing costs, 
increase the relevance of offers, and increase the chance that customers will 
respond.

The following is a list of some important features of Siebel Real-Time Marketing:

■ Offer qualification. Siebel Marketing segments and campaigns handle offer 
qualification. As components of marketing programs, segments and campaigns 
allow for customers who meet a certain set of criteria to see a set of offers. In 
addition, Siebel Personalization rules can be used to limit the set of offers 
returned.

■ Offer sorting. You set rules in Siebel Personalization and allow the list of available 
offers to be sorted based on offer or customer attributes. By default, real-time 
offers are sorted in standard ASCII sort based on the offer name. In addition, 
targeted offers sort before non-targeted general offers. You can change the 
standard sort sequence and filter the records to match your business needs. 
Sorting and filtering methods that are available to you are based on the features 
you selected when you purchased Siebel Marketing. Some methods are available 
with basic Real-Time Marketing. If you use Siebel Analytics, you have additional 
sort and filter capabilities. For more information, see “Setting Up Real-Time 
Marketing With Siebel Analytics” on page 210. 

■ Offer delivery. This can take place at any customer interaction point. One example 
that is preconfigured for Siebel Marketing is the Featured Offers area on the 
Siebel eMarketing homepage.
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Based on your organization’s priorities, you can use real-time marketing in the 
following ways:

■ Real-Time Marketing—Basic. You use Siebel Marketing to qualify customers for 
offers and configure offer content and use straightforward sorting and filtering 
techniques to determine which offers to display to each customer. For example, 
you can sort offers based on the inbound priority that you assign to each offer.

■ Real-Time Marketing and Analytics. You add the Siebel Analytics Server and a 
third-party predictive modeling application to basic real-time marketing. This 
allows the list of offers to be limited and sorted based on real-time behavioral 
predictions or scores. Both versions return a list of offers to the customer.
196 Siebel Marketing Guide Version 7.5.3



Administering Siebel Real-Time Marketing

Setting Up Real-Time Marketing—Basic
Setting Up Real-Time Marketing—Basic
Siebel Real-Time Marketing uses the My Offers business component to select and 
display personalized offers to a customer. For example, the Featured Offers List 
Applet (based on the My Offer business component) appears on the Siebel 
eMarketing home page. 

You might want a Call Center representative to provide the best offer to a customer 
at the end of a service contact. To accomplish this, you need to create a list or form 
based on the My Offer business component in Siebel Tools. For instructions about 
creating applets, see Siebel Tools Reference.

The My Offer business component finds qualified offers for a particular customer 
and arranges them by the standard or a specified sort order. In addition, offers can 
be filtered to return only those offers that match a customer’s profile information. 
This section discusses the following topics:

■ Creating Offers for Real-Time Marketing on page 198

■ Qualifying Offers on page 199

■ Sorting and Filtering Offers on page 199

■ Tracking Offer Rejections on page 207

■ Real Time Marketing API Methods on page 208
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Creating Offers for Real-Time Marketing
To create outbound Web and phone offers, see Chapter 10, “Creating and Using 
Offers.” For inbound offers you need to specify the additional fields shown in 
Table 40 that only appear in the More Info form in the All Offers, the Web Offers, 
and the Phone Offers views of the Offers screen. To see these fields, you may need 
to click the show more button in the in the More Info form. 

Table 40. Real-Time Marketing Offer Fields

Field Description

Activation Date/Expiration 
Date

You can complete these fields and the offer will only be 
displayed for the specified period of time. If you do not 
specify offer dates, the offer will be available when it is 
included in a valid campaign.

Inbound Active Flag You must select this check box if you want an offer to be 
visible to customers. This flag is unchecked by default, 
so you need to check it for each offer you intend to 
display. It is recommended that you wait to select this 
flag until you are ready to launch or test the campaign. 
This flag also allows you to remove an offer after you 
activate a campaign. For example, if you ran out of 
product inventory for the offered product and this was 
causing customer satisfaction problems, you might 
choose to make the offer inactive for a period of time 
until more stock comes in.

Inbound Priority For information, see “Sorting by Offer Metric Fields” on 
page 200.

Margin For information, see “Sorting by Offer Metric Fields” on 
page 200.
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Qualifying Offers
Siebel Marketing segments and campaigns handle offer qualifications. Segments 
and campaigns allow customers who meet specified criteria to receive a set of 
offers. To learn more about setting up segments, campaigns, and offers, see the 
chapters about these topics in this guide. 

Offer qualification allows you to identify the contacts or prospects who can see 
different offers. For example, a particular credit card is only available to people with 
a high credit score. You can create a segment definition that selects only people with 
a high credit score to be part of the segment. This segment is attached to a campaign 
that contains credit card offers. After you load the campaign (based on the segment 
criteria) only the people in that campaign will receive the offers for this particular 
credit card. Campaigns and offers activate and expire based on the start and end 
dates that you assign. This changes the pool of available offers.

Sorting and Filtering Offers
Sorting offers is a critical element of providing “better” and “best” offers to a 
customer. If a contact qualifies for multiple offers, the offers can be sorted and 
filtered based on that contact’s Personalization profile attributes. Profile attributes 
can be taken directly from the static or dynamic profile properties found in 
Personalization. Siebel Real-Time Marketing can use Siebel Personalization rules to 
create filter and sort specifications.

Real-time Marketing provides several ways to sort and filter offers:

■ Standard sort based on targeting and offer name (default).

■ Sort by offer metrics fields.

■ Sort an Offer List Dynamically Using Profile Information.

■ Filter an Offer List Dynamically Using Profile Information.

Using Standard Sort Based on Targeting and Offer Name
By default, the My Offer business component sorts any offers that are part of 
targeted marketing campaigns at the top of the offer list. Offers that are part of the 
default campaign appear next. Within each of these groups the offers will be sorted 
by name using ASCII sorting.
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In standard ASCII sorting, numbers take precedence over letters and letters are 
listed alphabetically. The sort is case sensitive. Upper case letters precede lower 
case letters. 

In Table 41, the standard sort specification will take the unsorted list in the left 
column and sort the list as shown in the right column:

Sorting by Offer Metric Fields
Custom Offer sorting can be accomplished in two ways. For a persistent sort 
customization, you can modify the Sort Specification property for the My Offer 
business component and recompile the SRF file. For sort specifications that you 
need for a limited set of campaigns or for situations that require dynamic sorting 
based on more complex logic, you can use a special profile attribute named 
MyOfferSortSpec. 

Table 41. Example of a Standard Sort

Unsorted List of Offers Sorted List of Offers Type of Campaign

2000 Model Phone for $300 1000 Minutes for $20 Targeted

2001 Model Phone for $400 2000 Model Phone for $300 Targeted

7000 Minutes for $75 7000 Minutes for $75 Targeted

X3000 Phone for $200 2001 Model Phone for $400 Targeted

1000 Minutes for $20 Offer 1 Targeted

Offer 1 Offer 10 Default

Offer 2 Offer 2 Default

Offer 10 Offer 20 Default

Offer 20 X3000 Phone for $200 Default
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You can establish a sort specification using the My Offer business component for 
offer fields such as Inbound Priority (the offer’s importance to you) and Margin (the 
offer’s advantage or profitability rating for you). These two fields exist specifically 
for sorting. For example, if you want to use Inbound Priority or Margin as a way to 
sort offers, you need to identify the meaning of the each value (high, medium, low, 
and so on) that you will apply to each offer. Table 42 on page 201 contains an 
example of an uncomplicated matrix for Inbound Priority values.

This sample strategy allows the marketer to constantly prioritize new offers based 
on past offers. As new offers are created and old offers expire, the list of available 
offers for customers changes.

Table 42. Inbound Priority Value Matrix

Inbound 
Priority 
Value Offers Meaning

Very High New Product bundles New product bundles take priority over other 
product types.

High Popular Products Any time the offer is for a top 10 product, it will 
receive a high priority.

Medium Products with Excess 
Inventory

Products will excess inventory should be displayed 
to try and sell them.

Low Standard Low Margin 
Products

Products with lower margins may be desirable to 
customers, but less important to the company than 
those with higher margins.

Very Low Standard Volume 
Discount Pricing

Standard volume discount offers such as Buy 5 and 
Get 10% Off have the lowest priority.
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You can add an inbound priority and a margin value to each offer that you create. 
When you receive responses to the offer, you can sort them by that value. Table 43 
shows a sample offer list sorted by Inbound Priority. 

Table 44 shows the result of sorting the same sample list by the offer’s Inbound 
Priority and then by Margin.

NOTE: The sequence of the two offers with a medium priority changed because one 
has a margin value of Medium and one has a margin value of Low.

Table 43. Sample Sort by Inbound Priority 

Offer Name Inbound Priority

7000 Minutes for $75 Very High

2001 Model Phone for $400 High

2000 Model Phone for $300 Medium

X3000 Phone for $200 Medium

1000 Minutes for $20 Low

Table 44. Sample Sort by Inbound Priority and Margin

Offer Name Inbound Priority Margin

7000 Minutes for $75 Very High High

2001 Model Phone for $400 High High

X3000 Phone for $200 Medium Medium

2000 Model Phone for $300 Medium Low

1000 Minutes for $20 Low Low
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Sorting an Offer List Dynamically Using Profile Information
Sorting based on real-time information is sometimes called dynamic sorting 
because the sort can change immediately upon completion of an action or activity. 
A dynamic sort specification is set as a dynamic profile property for a contact and 
overrides the default sort specs that were established in the business component 
definition in Siebel Tools.

Dynamic sort specifications for an offer applet can be setup in Siebel 
Personalization. It is invoked when you associate the applet that contains the 
content with a personalization rule set that contains a rule that sets the dynamic 
sort profile attribute.

The MyOfferSortSpec attribute can be set using a special business service method 
name RTM – Scores from Decision Broker.SetDynamicSortSpec. The most common 
way to execute this business service method is to define a personalization rule that 
is associated with the appropriate My Offer-based applet. For more information 
about creating Personalization Rules, see the sections about creating rule sets and 
rules in Personalization Administration Guide.

To create personalization rules to establish sort specifications

1 From the application-level menu, choose View > Site Map > Personalization 
Administration > Rule Sets.

2 In the Rule Sets list, create a new record.

3 Type a name for the rule set in the Name field and select the Active check box.

4 In the Rules list, create a new record.
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5 In the new record complete the fields using information in Table 45.

To create a rule set and associate it with an applet

1 From the application-level menu, choose View > Site Map > Personalization 
Administration > Applets.

2 In the Applets list, create a new record.

a Click the Name select button and select the applet you wish to associate with 
the rule set.

Table 45. Rules Fields for Sort Specifications

Field Name Description

Active TRUE

Business Service Context The sort specification to apply based on your 
requirements, for example:

■ Valid End Date (DESC)

■ Margin, Name

■ Offer Score (DESC), Margin, Name

Business Service Method SetDynamicSortSpec

Business Service Name RTM – Scores from Decision Broker

Conditional Expression Based on your requirements.

To apply the sort specification to all users, leave this 
property blank. To apply to certain users conditionally, 
type a suitable logic expression using profile attributes. 
Multiple sort rules can be created for complex sort rules. 
See the following sample expression:

GetProfileAttrAsNum('Customer Value') >= 50 AND 
GetProfileAttrAsNum('Churn Possibility') >= 70

Rule Type Business Service. For more information, see 
Personalization Administration Guide.

Sequence Each rule should be assigned a number that establishes 
its order in the rule set. Each rule will be executed in 
sequence.
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b Click the Conditional Expression select button.

c In the Expression Designer, create the expression you wish to use.

3 Scroll down to the Rule Sets list and, in the Rule Sets list, create a new record.

a Click the Name select button and select the rule set you wish to associate 
with the applet.

b In the Sequence field, type 1. 

Each rule should be assigned a number that establishes the rule set’s order. 
Each rule set will be executed in sequence.

c Click the Conditional Expression select button.

d In the Expression Designer, create the expression you wish to use.

Filtering an Offer List Dynamically Using Profile Information
Real-Time Offers can be filtered to return an offers list based on customer profile 
information. The marketer may want to limit the types of offers displayed. A 
Personalization Rule can be set to include or exclude offers that have only specified 
attributes such as the following:

■ Activation Date < 30 days ago

■ Campaign Type = Retention

To create an offer filter rule set

1 From the application-level menu, choose View > Site Map > Personalization 
Administration > Rule Set.

2 In the Rule Sets list, select a rule set and scroll down to the Rules list.

3 In the Rules list, create a new Rule and scroll down to the More Info form.
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4 In the More Info form, define the rules for the filter using information in 
Table 46.

Table 46. Rules Fields for Filter Specifications

Field Name Description

Active TRUE

Conditional Expression Based on your requirements. To apply this filter 
specification to all users, leave this property blank.

To apply to certain users conditionally, type a suitable 
logic expression using profile attributes.

Multiple filter rules can be created for complex filtering

Example:
GetProfileAttr(‘Is Anonymous’) <> 'TRUE’ AND
GetProfileAttrAsNum(‘Income’) >= 50000

Include Expression Based on your requirements. Offer property criteria to 
include in list if the Rule conditional expression is true.

Example:
[Margin] <= LookupValue(“OFFER_MARGIN”, “3 – 
Medium”)

Example:
[Valid Start Date] < (Today() - 30)

Exclude Expression Based on your requirements. Offer property criteria to 
exclude from the list if the Rule conditional expression is 
true. 

Example:
[Inbound Priority] >= LookupValue(“OFFER_PRIORITY”, 
“4 – Low”)

Rule Type Expression

Sequence Each rule should be assigned a number that establishes 
its order in the rule set. Each rule will be executed in 
sequence.
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Tracking Offer Rejections
Offer Groups provide a way to track acceptance or rejection of similar offers across 
different channels. Offer groups appear in the Offer Groups view.

Creating an Offer Group
To create a new offer group, make sure the offers you want to include have been 
created, create a new offer group, and add the existing offers. Adding or deleting 
offers adds or removes them from the group, it does not create a new offer or delete 
an existing offer.

To create an offer group

1 From the application-level menu, choose View > Site Map > Offers > Offer 
Groups.

2 In the Offer Groups list, create a new record.

3 In the Offers list, create a new record.

4 In the Pick Offers dialog box, select the offers that you want to add to the offer 
group and click OK.

Suppressing Offers in a Group
For each offer group, the Group Suppression must be either enabled (default) or 
disabled. When group suppression is enabled, then the rejection of one offer in the 
group by a customer will suppress the other offers in that group for that customer. 
This is particularly helpful when the offers are similar across the multichannel 
environment. When group suppression is disabled, offers in these groups are not 
tracked. If you experience problems when tracking an offer group, you may want to 
disable group suppression (not delete the offer group) until the problem is resolved. 

For example, a customer is not interested in a call center offer for a mortgage 
because they have just purchased a home. This is a missed opportunity, but even 
worse would be to make the same customer the same offer over again in another 
channel. Because the Web and call center offers can be linked together in an offer 
group, the rejection of a call center offer automatically suppresses the web content, 
which increases the likelihood that the customer will be exposed to an offer which 
will actually be of interest.
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Changing Offer Group Suppression Behavior
The My Offer business component uses the Rejected Offers business component to 
control offer group suppression behavior. When you enable suppression for an offer 
group, the My Offer business component suppresses all offers if any offer in that 
group has a response of type Rejected.

This behavior is controlled by the search specification property of the Rejected 
Offers business component. The default search specification is:

[Response Type] = LookupValue( "COMM_RESPONSE_TYPE", "Rejected")

You can specify more than one response type for the lookup value. For example, You 
might want to suppress all other offers in a group if the customer rejects or makes 
a purchase in response to an offer.

To suppress a group of offers based on a rejection or a purchase, change the Rejected 
Offers search specification property to:

[Response Type] = LookupValue( "COMM_RESPONSE_TYPE", "Rejected") OR 

[Response Type] = LookupValue( "COMM_RESPONSE_TYPE", "Respondent 
purchased")

NOTE: After you modify the search specification in Siebel Tools, you need to 
recompile the SRF file.

Real Time Marketing API Methods
Real time marketing provides two Application Programming Interface (API) 
methods, RejectOffer() and IncrementDisplayCount() from My Offer Business 
component. These methods can be incorporated in the Siebel application as needed 
to collect the customer reject responses for an offer and number of times an offer 
was presented to a particular customer.

The Real-time Marketing API methods can be invoked from Siebel Business 
Processes (workflow), Runtime Events, Personalization Rules, Siebel Browser Script 
and Siebel eScript.
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■ RejectOffer(). You can incorporate this method into Siebel applications to allow 
a customer to reject an offer. Offer suppressing rules will prevent the rejected 
offers from being presented during customer’s subsequent inbound 
communication. The following is a list of input parameters:

■ IncrementDisplayCount (). Can be incorporated into Siebel applications to 
increment a count of the number of times an Offer was presented to a specific 
customer. Offer Status for Contact Business component can be used to retrieve 
display count information. The following is a list of input parameters:

Input Parameter Description

Campaign Offer Id Campaign Offer Id of an Offer

Contact Id Customer Id 

Reason Code Reason Code from OFFER_REJECT_REASON LOV 

Reason Comment Comments about Rejection

Prospective Contact false by Default, True if the Customer is a Prospect

Input Parameter Description

Campaign Offer Id Campaign Offer Id of an offer 

Contact Id Customer Id 
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Setting Up Real-Time Marketing With Siebel Analytics
Siebel Decision Manager allows you to define and manage decisions as part of 
Siebel Marketing real-time offers for inbound channels. Decision Manager allows 
Siebel applications to access information and third-party predictive models through 
the Analytics Server. It is required that the Analytics Server you use for decisions 
reside on a dedicated machine or set of clustered machines to meet real-time 
processing requirements. To use real-time marketing offers, one option in each of 
the following is required:

■ Siebel Marketing or Campaigns to create and format content

■ Siebel Call Center, Siebel eMarketing, or other Siebel application to deliver 
content

Sort options available with the standard installation are available for use with Siebel 
Analytics. Offers can be filtered to return offers based on customer specific profile 
information or real-time behavioral scores. 

To use Real-Time Marketing with Siebel Analytics, perform the following tasks:

■ Setting Up the Analytics Server on page 211

■ Creating and Testing Decisions on page 215

■ Sorting and Filtering By Scores Using Decision Broker on page 221

■ Configuring the Decision Broker Business Service—Advanced on page 225
210 Siebel Marketing Guide Version 7.5.3



Administering Siebel Real-Time Marketing

Setting Up the Analytics Server
Setting Up the Analytics Server
The Analytics Server must be configured before you can set up Real-Time 
Marketing. You need to configure a system containing the Siebel Marketing 
application, an Analytics Server, and third-party scoring engine software so that you 
can create decisions and use them in Siebel Marketing. For additional information, 
see Siebel Analytics Installation and Configuration Guide. To set up the Analytics 
Server, complete the tasks in the following sections:

■ Prerequisites for Setting Up Siebel Analytics

■ Creating an Interface to a Third-Party Scoring Engine on page 212

■ Creating Siebel Analytics repository mappings. Allows Siebel Marketing to issue 
SQL queries to the Analytics Server that retrieve scoring information based on a 
customer, an account, or a household ID. For instructions, see the section about 
Marketing in Siebel Analytics Installation and Configuration Guide.

Prerequisites for Setting Up Siebel Analytics
The following products need to be installed and configured before attempting to use 
Siebel Analytics with Siebel Marketing:

■ Siebel Marketing application

■ Siebel Analytics Server

■ Siebel Analytics Administration Tool

■ Third-party scoring engine
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Creating an Interface to a Third-Party Scoring Engine
To establish an interface to the scoring engine, you need to create an intermediate 
DLL that translates communications between Siebel Analytics and your third-party 
scoring engine software. 

During processing, Siebel Analytics loads the customer-created intermediate DLL, 
passing in input parameters. The intermediate DLL packages (translates) the input 
parameters, invoking the third-party scoring engine software. When the third-party 
scoring engine software returns results, the results are packaged (translated) to 
return to analytics.

Intermediate DLL Code—An Example
This section contains an example of a framework (or skeleton) function. The 
framework illustrates the type of function that a customer needs to implement and 
the operations that the function usually performs. For more information, see Siebel 
Analytics Installation and Configuration Guide. Intermediate DLL code should 
define the following:

■ A function named SiebelAnalyticIterativeExecutionStatus

■ A structure named SiebelAnalyticColumnMetaInfo

To create an intermediate DLL you need to code the following logical steps:

#ifdef ITERATIVEGATEWAYDLL_EXPORTS

#define ITERATIVEGATEWAYDLL_API __declspec(dllexport)

#else

#define ITERATIVEGATEWAYDLL_API __declspec(dllimport)

#endif

typedef unsigned char uint8;

typedef enum SiebelAnalyticColumnValueType { VarCharData = 0 };

// This structure can currently support string types only

struct SiebelAnalyticColumnMetaInfo
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{

wchar_t * columnName;

SiebelAnalyticColumnValueType columnValueType;

int columnWidth; // actual size of the column values in bytes for 
both in/out

};

extern "C" ITERATIVEGATEWAYDLL_API 

int ExecuteIterativeQuery (

/* [in] */ const  wchar_t* modelId,

/* [in] */ const int inputColumnCount,

/* [in] */ const SiebelAnalyticColumnMetaInfo* 
pInputColumnMetaInfoArray,

/* [in] */ const uint8* inputColumnValueBuffer,

/* [in] */ const int outputColumnCount, // actual count of columns 
returned

/* [in/out] */ SiebelAnalyticColumnMetaInfo* 
pOutputColumnMetaInfoArray,

/* [out] */ uint8* outputColumnValueBuffer)

{

// Retrieve the input column names, width, and values

// Retrieve the output column names and width

// Call third-party scoring engine DLL functions to retrieve the 
outputs value

// Set outputs column width 

// Package the outputs value into outputColumnValueBuffer 

// Return

}
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Table 47 describes the meaning of each parameter that is passed for the function 
that the customer needs to implement.

Creating Siebel Analytics Repository Mappings
For instructions, see the section about Marketing in Siebel Analytics Installation and 
Configuration Guide.

Table 47. Function Parameter Definitions

Term Description

inputColumnCount The number of input columns.

inputColumnValueBuffer A buffer of bytes containing the value of the input 
columns. The actual size of each column value is 
specified in the columnWidth field of the 
SiebelAnalyticColumnMetaInfo. The column values are 
placed in the buffer in the order in which the columns 
appear in the pInputColumnMetaInfoArray.

modelId An optional argument that the user may specify in the 
Search Utility box in the XML tab of the Physical table.

OutputColumnCount The number of output columns. 
pOutputColumnMetaInfoArray is an array of meta column 
information for the output column. 
SiebelAnalyticColumnMetaInfo is declared in the public 
header file IterativeGatewayDll.h that we ship with Siebel 
Analytics. The caller of the API provides the column name 
and the call recipient sets the data type of the column 
(currently we only support VarCharData) and the size of 
the column value.

outputColumnValueBuffer A buffer of bytes containing the value of the output 
columns. The actual size of each column value is 
specified in the columnWidth field of the 
SiebelAnalyticColumnMetaInfo. The column values must 
be placed in the buffer in the order in which the columns 
appear in the pOutputColumnMetaInfoArray.

pInputColumnMetaInfoArray An array of meta information for the input columns. 
SiebelAnalyticColumnMetaInfo is declared in the public 
header file IterativeGatewayDll.h which we ship with 
Siebel Analytics.
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Creating and Testing Decisions
Decision Manager and the associated Decision Broker business service allow you to 
create and execute SQL queries against the Analytics Server to obtain a real-time 
score or result. The Decision Administration screen and Decision Wizard allow you 
to create the SQL request and the specification for real-time variables.

Before creating a decision you need to map the appropriate information in the 
Analytics Server. For more information, see “Setting Up the Analytics Server” on 
page 211. 

You can create a decision using the Decision Wizard that is started in the Decision 
Administration screen, or by using step-by-step procedures in the Decision 
Administration screen. This section contains the following procedures for creating 
and deleting a decision in the Decision Administration screen:

■ Using the Decision Wizard to Create a Decision

■ Creating and Deleting a Decision Record on page 216

■ Testing a Decision on page 220

Using the Decision Wizard to Create a Decision
Clicking Decision Wizard starts a wizard that provides a guided method for creating 
a decision.

1 From the application-level menu, choose View > Site Map > Decision 
Administration > My Decisions.

2 In the Decisions list, click Decision Wizard.

3 Follow the Decision Wizard instructions to create the decision.

For additional information, see “Creating and Deleting a Decision Record” on 
page 216.
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Creating and Deleting a Decision Record
If you want to use the result of the decision in a Siebel Real-Time Marketing process, 
the decision should have a status of Released. After a decision has been released, 
you should not delete it.

To create a decision

1 From the application-level menu, choose View > Site Map > Decision 
Administration > My Decisions.

2 In the Decisions list, create a new record.

3 Complete the fields using the information in Table 48, at the end of this 
procedure.

The name must be unique and the description should help others understand 
how the decision will be used.

4 Click the Identifiers view tab,

5 In the Identifiers list, create a new record and complete the fields using 
information in Table 48.

In the Name field, you can select multiple identifiers. These values will be used 
as part of the WHERE clause in the SQL query. For example, if the decision will 
be run for each customer, then select the Customer ID.

6 Click the Real-Time Inputs view tab.

7 In the Real Time Inputs list, create a new record and complete the fields using 
information in Table 48. 

Select real-time values from the personalization profile that will be used by a 
model or calculation.

8 Click the Outputs view tab.
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9 In the Outputs list, create a new record and complete the fields using 
information in Table 48. 

In the Name field, select a single value as the output. This value will be used as 
part of the SQL query select statement clause. For example, select output from 
the table specified where identifier is equal to the customer ID. This will allow 
the decision request the result or value of a particular field or column.

Table 48. Decision Fields

Field
Decision 
Administration Views Description

Default 
Value

Identifiers and Real 
Time Inputs

Used during decision testing and when no value is 
passed or available to the decision.

Name All views Can select multiple values. Used in the WHERE clause 
of the SQL query. For example, the customer ID 
identifier allows the decision request to obtain 
information about that customer.

Profile 
Name

Identifiers and Real 
Time Inputs

Select the value from the drop-down list. In the 
Identifiers list, it is used to associate a profile attribute 
value with indentifier that will be used in the 
construction of the actual SQL select statement.

Server Decisions Required. The name of your Analytics Server. For 
information, see “Defining Data Source Names” on 
page 33.

Status Decisions Required. When the decision is working properly, 
change the status to verified. Other values are:

■ Unverified. Default value. You can delete decisions 
in this status.

■ Verified. Change after you confirm that the 
decision is working properly.

■ Released. You can use for any application.

■ Retracted. Currently in use, but you should not 
use this in any new applications.

■ Inactive. Not currently used. Can be deleted.
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Creating a Decision That Produces a Score (Example)
You can use the values in the following list to create a decision.

1 Create a decision with the following values:

2 Create first Identifiers with the following values:

Subject 
Area

Decisions Required. The drop-down list shows the tables for the 
server that you selected in the Server field. Choose the 
table in which you created the decision identifier and 
output columns.

Test Result Outputs Read only. This column will be populated with the 
results of a test.

Table 48. Decision Fields

Field
Decision 
Administration Views Description

Field Value

Name ScoreOffer

Server ScoreServer

Subject Area Siebel

Field Value

Default Value 1

Name ContactId
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3 Create second Identifiers with the following values:

4 Create Outputs with the following values:

Your SQL field value result should be the following statement:

Select Score from Siebel.OfferScore where ContactId = '%' And 
OfferId = '%'

Deleting a Decision
Someone might be using a decision in Released status. Deleting it might cause the 
application to function improperly.

CAUTION: Only decisions with a status of Inactive, Unverified, and Verified can be 
deleted. Decisions in Retracted status should not be deleted because they may still 
be used.

To delete a decision

1 From the application-level menu, choose View > Site Map > Decision 
Administration > My Decisions.

2 In the Decisions list, select a decision.

3 Click the menu button and select Delete Record.

Field Value

Default Value 1

Name OfferID

Field Value

Name Score
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Testing a Decision
The test feature in decision administration allows you to confirm that your decision 
and model are functioning properly. You can test the decision using default values 
for identifiers and real-time inputs. This test produces a result in the Results field 
and populates the Test Time field with the number of seconds it took to complete 
the operation.

Execute several tests, each with different values in the Default Value field to make 
sure that the decision produces the desired results. For example, if you know that a 
default value of two in a certain field should make the output score low, then type 
2 in the default field for the variable and test the decision. All the Default Value 
fields must have values for a test to execute successfully.

After you create and test your decision, you are ready to use it in an application. 
Two ways to use a decision are to associate it with an offer or use a field in the user 
interface to guide the decision-making process. 

■ Associating decisions with offers. If the decision and model provide the probability 
to respond to a particular offer, then you can associate the decision with an offer 
in the offers detail view by selecting the offer, and then selecting the decision 
name in the decision field.

■ Use a field in the application. If the decision is for a behavioral score, then you 
might add a field to the user interface to help users make decisions during 
customer interactions. 

To test a decision

1 From the application-level menu, choose View > Site Map > Decision 
Administration > My Decisions.

2 In the Decisions list, select a decision.

3 Click Test Decision.
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Sorting and Filtering By Scores Using Decision Broker
You can sort and filter offers based on real-time behavioral scores and customer 
profile information. The following topics show you how to set up personalization 
rules and Decision Manager to deliver real-time scores to Siebel eBusiness 
Applications.

■ Sorting on Real-Time Behavioral Scores. If you want decision scores to be 
generated for offers that will be presented to a user, a decision must be 
associated with the offer and the Offer Score field must be included in the active 
sort specification. 

■ Filtering on Dynamically Calculated Data on page 222. You can establish 
personalization rules to filter offers based on customer profile information. 
Profile attributes can be dynamically calculated using Siebel Decision Manager 
(Analytics). 

Sorting on Real-Time Behavioral Scores
One way to sort offers is by using a score that indicates that a customer might 
respond to or purchase from an offer. If the scores generate using real-time 
information, then the score reflects the most current information that you have 
about the customer’s preferences. For more information, see “Sorting an Offer List 
Dynamically Using Profile Information” on page 203.

For example, Table 49 shows how the sort-by-score method sorts the offers for a 
qualified customer.

Table 49. Sort by Score

Offer Name Score

X3000 Phone for $200 .88

1000 Minutes for $20 .75

2001 Model Phone for $400 .56

7000 Minutes for $75 .45

2000 Model Phone for $300 .12
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Filtering on Dynamically Calculated Data
You write personalization rules that use these calculated dynamic profile attributes 
to specify filter specifications and sort specifications for the offers to be presented 
to contacts. For more information, see “Filtering an Offer List Dynamically Using 
Profile Information” on page 205.

If the expressions use dynamic profile properties created during the Decision 
Manager set-up process, make sure you use exactly the same property names in 
your expression statements or the rule will not work. For more information, see 
“Creating and Testing Decisions” on page 215.

To filter on dynamically calculated data

1 Create a Personalization Rule Set with one or more rules to execute a decision 
using the Decision Broker Service.ExecuteDecision business service method.

The following list contains descriptions and values for the Rules field:

Field Name Description and Values

Active TRUE

Business 
Service 
Context

The name of the Decision and any arguments required by the 
decision configuration based on your requirements. Examples:

Decision=Get Customer Value Score

Decision=GetChurnScore,ContactId=GetProfileAttr(“Id”)

Business 
Service 
Method

ExecuteDecision

Business 
Service Name

Decision Broker Service

Conditional 
Expression 

Based on your requirements.

■ If you leave this property blank, this filter specification will apply 
to all users. (Not recommended.)

■ Anonymous users should always be excluded. To apply to certain 
users conditionally, type a suitable logic expression using profile 
attributes. For example:
GetProfileAttr(‘Me.Is Anonymous’) <> TRUE
222 Siebel Marketing Guide Version 7.5.3



Administering Siebel Real-Time Marketing

Sorting and Filtering By Scores Using Decision Broker
Rule Type Business Service

Sequence Each rule should be assigned a number that establishes its order in 
the rule set. Each rule will be executed in sequence.

Field Name Description and Values
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2 Include the profile attributes returned by the Rules invoked in Step 1 in the 
Conditional Expression, the Include Expression, or the Exclude Expression in 
another personalization rule designed for filtering the offers. 

The following list describes rules fields for offer filters that use decision 
customer scores:

Outputs from a decision executed from a personalization rule are stored as a 
dynamic profile attribute with a name of the format [decision name].[decision 
output argument name]. For example, if a decision named GetChurnScore has 
an output argument named ChurnValue, then the result will be stored in a profile 
attribute named GetChurnScore.ChurnValue.

Field Name Description and Values

Active TRUE

Conditional 
Expression

Based on your requirements. To apply this filter specification to all 
users, leave this property blank (not recommended) Anonymous 
users should always be excluded using the following example:

To apply to certain users conditionally, type a suitable logic 
expression using profile attributes. Example:

GetProfileAttr(‘Me.Is Anonymous’) <> TRUE AND 
GetProfileAttrAsNum(‘GetChurnScore.ChurnValue’) > .85

Exclude 
Expression

Based on your requirements. Offer property criteria to exclude from 
the list if the Rule conditional expression is true. Example:

[Inbound Priority] >= LookupValue(“OFFER_PRIORITY”, “4 – 
Low”)

Include 
Expression

Based on your requirements. Offer property criteria to include in list 
if the Rule conditional expression is true. Example:

[Margin] <= LookupValue(“OFFER_MARGIN”, “3 – Medium”)

Rule Type Expression

Sequence Each rule should be assigned a number that establishes its order in 
the rule set. Each rule will be executed in sequence
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Configuring the Decision Broker Business Service—
Advanced

This option allows you to work directly with Siebel Analytics in an unrestricted way. 
Using direct access to the business service, you can integrate decisions into your 
application separately from Real-Time Marketing.

The Siebel Decision Manager uses the Decision Broker business service to execute 
decisions that retrieve information from the Siebel Analytic Server. The purpose of 
this section is to show how the Decision Broker business service can be invoked 
using workflow, personalization, Siebel VB script, and Siebel eScript. The results 
from any of these integrations can be used to create dynamic content, alter the flow 
of business processes, and so on.

Perform the following tasks:

■ Prerequisites to Configuring the Decision Broker Business Service 

■ Invoke Business Service Using Workflow—Example on page 226

■ Invoking Decision Broker Using Personalization—Example on page 228

■ Invoke Business Service Using Siebel VB Script—Example on page 230

■ Invoke Business Service Using Siebel eScript—Example on page 231

■ Testing Real-Time Marketing Campaigns with the My Offer View on page 232

This section discusses the Decision Broker business service interface and the 
Decisions business component.

Prerequisites to Configuring the Decision Broker Business Service
Complete the following steps before you configure Decision Broker:

■ Install and set up Siebel Analytics and Siebel Marketing.

■ Map the required databases to the Analytics Server.

■ Map the Server Name field to your Siebel Analytics repository DSN in Siebel 
Marketing. For instructions, see “Creating Server Definitions” on page 89.
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■ Knowledge of Workflow, Personalization, Siebel Visual Basic and Siebel eScript 
are required to integrate the business server through each method. This section 
provides examples for each method that you can use and adapt to invoke the 
Decision Broker business service to meet your needs. For information about 
tools and programming languages required for integration, see the following 
resources:

■ Siebel Business Process Designer Administration Guide contains details about 
creating and maintaining workflow processes.

■ Siebel Tools Reference contains information about Siebel VB and eScript. For 
Tools overview information, see the section about server side scripting.

■ Personalization Administration Guide contains information about Siebel 
Personalization.

■ Create a decision record. Make sure the decision record you want to invoke has 
been created in the Decision Administration screen. For instructions, see 
“Creating and Testing Decisions” on page 215.

Invoke Business Service Using Workflow—Example
This section explains the integration of Siebel Business Process Designer (contains 
Siebel workflows) with the Decision Broker Service. If you understand the basics of 
Siebel business process design and infrastructure, using the following example will 
help you understand how to invoke the Decision Broker business service. For more 
information about Siebel workflows, see Siebel Business Process Designer 
Administration Guide.

This following example describes the steps you need to follow to invoke the 
Decision Broker business service from Siebel Business Process Designer. 

NOTE: The decision you want to invoke must exist in the Decision Administration 
screen. For information about creating a decision, see “Creating and Deleting a 
Decision Record” on page 216.

Create a workflow example in the Business Process Designer using the following 
information.
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■ Create a new workflow process. In the Business Process Administration screen, 
select Workflow Processes from the Show drop-down list. In the Workflow 
Processes list, create a new record and type a unique, descriptive name.

■ Create a graphical workflow in Process Designer. In the Process Designer view tab, 
create a workflow using the following information:

■ Drag a Start object, a Business Service object, and an End object from the 
Palette to the Process Designer workspace.

■ Drag and connect a Connector object from the Start object to the Business 
Service object and the Business Service object to the End object.

■ Create process properties. In the Process Properties list, create new records using 
the following list as a guideline:

■ Define the business service. In the Process Designer workspace, double-click the 
New Business Service object. In the Business Service form, select values for the 
following fields using the following list as an example:

■ In the Input Arguments list, create a single record using information in the 
following list as a guideline:

 Name Data Type

[name of output argument1] String

[name of output argument2] String

Field Name Value

Business Service Decision Broker

Method Execute

Field Name Value

Input Argument Decision
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■ In the Output Arguments list, create a record for each output argument that 
you created in the Process Properties list.

■ Test your workflow. Click Return to Designer and test your workflow. In the 
Process Simulator, click Start. Scroll down to the Process Property list and click 
the Process Property Name select button. The Process Property Value column 
should be empty for [name of the output argument1] and [name of the output 
argument2]. Click Continue until all steps have been tested. If the test completes 
successfully, the new workflow can invoke the business service and return 
results.

Invoking Decision Broker Using Personalization—Example
This example describes how you can invoke the Decision Broker business service 
by creating a personalization rule and using the rule set to invoke the Decision 
Broker business service.

NOTE: The decision you want to invoke must exist in the Decision Administration 
screen. For information about creating a decision, see “Creating and Deleting a 
Decision Record” on page 216.

For detailed instructions, see Personalization Administration Guide. Use the 
following list to define your process:

Type Literal

Value [decision name]

Property Name Type Output Argument

[name of the output 
argument1]

Output Argument [name of the output 
argument1]

[name of the output 
argument 2]

Output Argument [name of the output 
argument2]

Field Name Value
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■ Add a business service. In the Personalization Administration screen, select the 
rule set for the applet that you wish to personalize. To invoke the Decision 
Broker business service, add a rule of type Business Service, making sure that 
the Active Flag is checked. In the More Info list complete the fields, using the 
following information:

■ Add personalization rules. Use the following information as general guidelines and 
then save the rule sets. Test Decision.Finish and Test Decision.Size X are values 
used to test in this example. Use your output value using the following syntax:

[decision name].[output name].

Field Name Value

Business Service Name Decision Broker Service

Business Service Method ExecuteDecision

Business Service Context [name of decision you want to invoke]

Name For example, Decision Broker Caller

Sequence The number you assign should be higher than rules 
that must be executed before this step

Field Name Rule Type Include Expression

Decision Output 1 
Prefix

Expression ".&nbsp;&nbsp;<b><BR>Output Parameter 
'<Name>' : "

Decision Output 1 Expression GetProfileAttr('Test Decision.Finish')

Decision Output 1 
Suffix

Expression ".</b></div>"

Decision Output 2 
Prefix

Expression ".&nbsp;&nbsp;<b><BR>Output Parameter 
'Size X' : "

Decision Output 2 Expression GetProfileAttr('Test Decision.Size X')

Decision Output 2 
Suffix

Expression ".</b></div>"
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■ Reload personalization rules. Click the menu button and select Reload 
Personalization to apply the changes of the rule set to the Salutation Applet.

You can confirm your change by select the Home Page tab in a customer application 
that uses this business service.

Invoke Business Service Using Siebel VB Script—Example
This example covers invoking the Decision Broker business service from VB script. 
For detailed instructions about how to use Siebel VB Script, see Siebel Tools 
Reference.

Create a new business service and write a VB Script that will call the Decision 
Broker business service as part of its operations. The following example describes 
the process:

■ Add a business service. In the Business Service Administration screen, select 
Details from the Show drop-down list. In the Business Service list, add a new 
business service, and save the record.

■ Add a VB Scripts record. From the Show drop-down list, select Scripts. and create 
a new record. In the Business Service Scripts form, select 
Service_PreInvokeMethod as the Name and Siebel VB as the Programming 
Language.

■ Add custom VB code. In the Business Service Scripts workspace, add your custom 
VB code, click Check Syntax, and correct any errors. Make sure that you save the 
script. so that the simulator for the test will run successfully. If you do not save 
the script, errors such as Method Not Supported will appear.

■ Add two methods. From the Show drop-down list, select Methods. In the Methods 
list, add two new methods as shown in the following list:

■ Type test_ExecuteDecision as the method name and save the record.

■ Type test_getSqlStmt as the method name and save the record.

■ Test your new VB-based business service. 

■ Go to the Business Service Simulator view. In the Service Methods list, add 
a service for test. Select the name of your Business Service in the Service 
Name field and select test_ExecuteDecision in the Method Name field.
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■ (Optional because a default decision name is set as Test Decision exists in the 
business service.) In the Input Property Set list, add a new record. Set the 
Property Name to Decision and set the Property Value to a decision name 
such as Test Decision.

■ In the Service Methods list, click Run.

■ You should see the results in the Output Property Set list.

■ Repeat this test process for test_getSqlStmt method, if needed. 

Invoke Business Service Using Siebel eScript—Example
This example covers invoking the Decision Broker business service from Siebel 
eScript. An example business service is defined in eScript and it will be used to 
invoke the Decision Broker business service. Both methods (ExecuteDecision and 
getSqlStmt) of the Decision Broker Service are shown as part of the example. For 
detailed instructions about how to use Siebel eScript, see Siebel Tools Reference.

Write a business service using eScript that will call the Decision Broker Business 
Service as part of its operations. The following example describes the process:

Add a business service. In the Business Service Administration screen, select Details 
from the Show drop-down list. In the Business Service list, add a new business 
service and save the record.

■ Add an eScripts record. In the Business Service Administration screen, select 
Scripts from the Show drop-down list, and create a new record. In the Business 
Service Scripts form, select Service_PreInvokeMethod as the Name and eScript 
as the Programming Language.

■ Add your custom eScript code. In the Business Service Scripts workspace, add your 
custom eScript code. Make sure that you save the script so that the simulator for 
the test will run successfully. If you do not save the script, errors such as Method 
Not Supported will appear. 

■ Add two methods. From the Show drop-down list, select Methods. In the Methods 
list, add two new methods as shown in the following list:

■ Type test_ExecuteDecision as the method name and save the record.

■ Type test_getSqlStmt as the method name and save the record.
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■ Test your new eScript based business service. 

■ Go to the Business Service Simulator view. In the Service Methods list, add 
a service for test. Select the name of your Business Service and select 
test_ExecuteDecision in the Method Name field.

■ (Optional) because a default decision name is set as MyTest exists in the 
business service. In the Input Property Set list, add a new record. Set the 
Property Name to Decision and set the Property Value to a decision name 
such as MyTest.

■ In the Service Methods list, click Run.

■ You should see the results in the Output Property Set list.

■ Repeat this test process for test_getSqlStmt method, if needed. 

Testing Real-Time Marketing Campaigns with the My Offer View
You can use the Offers screen and views to test Real-Time Marketing campaigns, 
offers, and the associated personalization rules and decisions. In the Offers screen, 
the My Offers view lists offers appropriate for the current login user. The My Offers 
view is available for testing purposes during your deployment. In this way, a 
marketing administrator can verify that decision scores, dynamic sorting and 
filtering, and offer group rejection configurations are setup properly. The Offer Score 
column allows you to view the actual score returned from the decision if one is 
associated with the offer. The Reject Offer button creates a Rejected response record 
for the selected offer and the login user. When you return to this view, the Reject 
Flag column contains a value of Y, for offers that will not appear to the user.

It is recommended that you add a test user (the marketing manager or another user) 
to the campaigns that you are configuring so that you can test the scoring and 
rejection mechanisms using the My Offer view.

To make this view available, associate the test user with the My Offer View. 

To associate responsibilities with My Offer View

1 From the application-level menu, choose View > Site Map > Application 
Administration > Responsibilities.

2 In the Responsibility list, select the desired responsibility.

3 For example, Siebel Administrator or Marketing Manager.

4 In the View list, create a new record and select the My Offer View view.
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Siebel Marketing provides two methods for creating segments and filters for 
marketing programs:

■ Filter and segment editors. For customers who do not use Siebel Analytics for 
segmentation. Filters and segments are constructed using the Filter views in the 
Marketing Administration screen and the Edit Segment view tab in the Segments 
screen. 

■ Target Group Segmentation using dashboards and Siebel Answers requests. For 
customers using Siebel Analytics to develop Target Group segments, all filter 
criteria are built using the Analytics Web interface.

This chapter contains the following topics:

■ About Filters and Segments on page 234

■ Creating Filters and Defining Filter Criteria on page 236

■ About Segmentation Approaches on page 241

■ About Criteria-Based Segments on page 242

■ Building a Criteria-Based Segment on page 243

■ About Target Group Segmentation on page 251

■ Creating, Loading, and Refreshing a Target Group Segment on page 252
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About Filters and Segments
Siebel Marketing’s point-and-click Segment and Filter editors allow you to create 
complex expressions for campaign inclusion and exclusion without the need for in-
depth familiarity with the physical database. Filters allow designers to exclude 
segment members from a marketing program based on predefined rules.

Using the Filters Detail and Edit Segment views, you can build criteria expressions 
using predefined measures, database fields, attribute values, and bucket values as 
criteria. Logical operators such as AND, OR, and NOT allow you to construct 
compound expressions.

When you want to select all contacts from an external table, you still need to define 
at least one segment criteria in your segment. A segment must have at least one 
segment criteria.

Although filters are commonly viewed as suppression tools, Siebel Marketing does 
not use them to resolve duplicates (deduplicate). In Siebel Marketing, filters can 
prevent some potential customers from being included in the snapshot (the target 
data set) for a marketing program stage. While creating a snapshot, the Marketing 
Server automatically eliminates duplicates of qualified persons who fall into more 
than one segment during segment allocation. This means that a contact will be 
assigned to only one campaign within a stage.

While segment criteria determine which contacts and customer data are included 
in the snapshot, filters prevent a those who do not qualify from being included in 
the snapshot. Filters use inclusion or exclusion criteria to restrict the snapshot data 
to only those contacts which satisfy the filter criteria. For more information on 
snapshots, see Chapter 16, “Generating and Maintaining Snapshot Files.”

The following describes a typical business scenario for using filters and segments:

A marketer for a telecommunications company plans to roll out a campaign that 
provides a discount on long distance access for profitable cell phone customers 
within a certain area. Before performing segmentation to target her best customers, 
the marketer designs a filter that will be applied to the account data. The filter will 
include the residents of a particular state, but exclude every record flagged with a 
“do not mail” preference.
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Because many households have multiple cell phone accounts, the marketer plans 
to target the primary account, those customers with the largest monthly account 
balance in the last quarter, when defining segmentation criteria for the campaign 
offer.

The marketer would, however, like to include other elements in the snapshot to 
broaden the information being collected, so that if her initial query does not result 
in the desired segment counts, the criteria can be revised using the additional 
elements, without having to generate another snapshot.

Use the following topics to define filter and segment criteria:

■ About Filters and Segments on page 234

■ Creating Filters and Defining Filter Criteria on page 236

■ About Segmentation Approaches on page 241

■ About Criteria-Based Segments on page 242

■ Building a Criteria-Based Segment on page 243

■ About Target Group Segmentation on page 251

■ Creating, Loading, and Refreshing a Target Group Segment on page 252
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Creating Filters and Defining Filter Criteria 
A filter is a collection of inclusion and exclusion criteria that narrow the number of 
records in the source database that a snapshot will capture. Exclusion criteria are 
applied before inclusion criteria. For example, if a contact record meets the 
exclusion criteria, the record is not considered when Siebel Marketing performs the 
extraction of data for the snapshot. If your filter criteria specify that you only want 
to include residents of California and exclude records with a do-not-contact flag, 
those records are excluded before California records are included.

During snapshot generation, the filter expression is applied first. This includes or 
excludes groups of people, depending on the filters you create. Then segment 
criteria are applied, and contacts that meet the criteria are included in the segment 
counts.

The All Filters list displays defined filters. The read-only Inclusion and Exclusion 
boxes show filter criteria for the selected record. Criteria details for the selected 
filter may be viewed or edited by clicking the Filters Detail view tab.

To create filters and define filter criteria, perform the following tasks:

■ Creating Filter Records

■ Defining Criteria for Filters on page 237

■ Selecting Available Values for Filter Expressions on page 238

■ Building Filter Expressions on page 238

■ Combining Filter Statements on page 239

Creating Filter Records
Filters are used at the stage level of a program plan and are optional. You should 
create a filter only if you need to restrict the overall data set to certain records. If 
your filters are too restrictive, you limit the records available for segmentation when 
you take a snapshot of your data.

To create filter records

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Filters.

2 In the All Filters list, create a new record.
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3 Complete the necessary fields.

a Type a name and description for the filter.

b Click the Customer Hierarchy select button.

c In the Pick Customer Hierarchy dialog box, select a customer hierarchy from 
the list of available customer hierarchies and click OK.

NOTE: If the filter criteria use custom measures or buckets that are specific to 
a customer hierarchy, you must select that hierarchy when you create the 
filter. This avoids integrity errors later when generating a snapshot.

After you have saved a filter record, you cannot change the customer 
hierarchy or select a customer hierarchy where none existed. If you do not 
select a customer hierarchy and then later decide to select a customer 
hierarchy for a filter, you must create a new filter and associate a customer 
hierarchy with the new record before you save it. You can copy, edit, or delete 
an existing filter. However, the customer hierarchy specified in the original 
filter cannot be changed.

4 Click the Stages select button to display the marketing program stages that use 
this filter.

A filter can be applied to more than one stage of a program.

If this filter has not been associated with a stage in a marketing program, the 
read-only Stages field will be blank.

Defining Criteria for Filters
The Filters Detail view allows you to define criteria for a new filter using previously 
defined attributes, buckets, measures, and database fields. This view may also be 
used to edit filter criteria, although changes in a filter’s criteria do not take effect 
until the next snapshot of the data is performed. 

The Filters Detail view displays the selected filter’s information at the top. In the 
bottom left area, you select available values for Attributes, Buckets, Fields, and 
Measures.
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The Criteria view tab allows you to construct simple or compound filter statements 
and then designate the expressions as inclusion or exclusion criteria.

Selecting Available Values for Filter Expressions
When you choose Attributes, Buckets, Fields, or Measures from the drop-down list, 
values are displayed in a tree pane. Choosing Measures from the list displays a select 
button for available measures and fields that you can use to select logical operators 
and provide values.

As you build a filter statement, expand the folders in the tree pane, click a value’s 
check box to select it, or complete the measure fields.

Selected values have a check mark. To clear a value, click it again to remove the 
check mark. To select all values on a branch of the tree, select the first value and 
click Select Group.

Click Add to move the value to the Criteria workspace area. Then designate the 
expression as an inclusion or exclusion criteria by clicking Add To Inclusion or Add 
To Exclusion. Finally, click Validate & Save to verify the filter criteria syntax and 
save the record.

Building Filter Expressions
Use the following procedure to build inclusion or exclusion criteria expressions for 
your filters.

To build filter criteria

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Filters.

2 In the All Filters list, select the filter record and click the Filters Detail tab.

3 Choose criteria values for the filter, using Table 50 on page 239.

CAUTION: Do not select measure, attribute, bucket, or field names containing the 
following characters: apostrophe (’), greater than (>), greater than or equal to 
(>=), less than (<), less than or equal to (<=), BETWEEN, colon (:), period 
(.), semicolon (;), or tilde (~).
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4 Click Add to Workspace after each selection.

Each time you move a new value to the Criteria Workspace, it is separated from 
previous values by AND. Until the statements are moved to the Inclusion or 
Exclusion boxes, the statements will be joined by AND.

5 When you have finished building the statement, click Add To Inclusion or Add 
To Exclusion to move the criteria to the Inclusion or Exclusion boxes.

6 Click Validate & Save to authenticate the filter syntax and save the criteria.

Combining Filter Statements
You can use logical OR operators to create compound filters. 

To use OR in a filter expression

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Filters.

Table 50. Criteria Values for Filters

Criteria Comment

Attributes From the Filter Details drop-down list, select Attributes. In the tree pane, 
expand the Attribute Hierarchies folder to display values and click the 
value’s check box to select it.

Buckets From the Filter Details drop-down list, select Buckets. In the tree pane, 
expand the buckets folder to display values and click a value’s check box 
to select it.

Fields From the Filter Details drop-down list, select Fields. In the tree pane, 
expand the Fields folder to display values and click the value’s check box 
to select it.

Measures From the Filters Detail drop-down list, select Measures and in the 
Available Measures form, click the Measure select button. 

■ In the Pick Measure dialog box, select a predefined measure and click 
OK. 

■ Choose an operator, and type a number for Value 1.

■ If the operator is BETWEEN, type a number for Value 2.
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2 In the All Filters list, select the filter record and click the Filters Detail tab.

3 Create a filter statement, using the steps in “To build filter criteria” on page 238.

4 Move it from the Criteria workspace to the Inclusion or Exclusion box, where the 
restriction is enclosed in parentheses. 

5 Create another statement, and move the criteria to the same Inclusion or 
Exclusion box. 

When you click Add To Inclusion or Add To Exclusion, additional filter criteria 
are separated from the original criteria with an OR operator.

6 Click Validate and Save to authenticate syntax and save the filter statement.

To remove statements from the Inclusion, Exclusion, or Workspace boxes

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Filters.

2 In the All Filters list, select the filter record and click the Filters Detail tab.

3 In the Exclusion or Inclusion box, double-click the expression to move it to the 
Criteria workspace.

4 In the workspace box, place the cursor in the expression, right-click and choose 
Delete or Delete All from the menu. 

5 If you have created compound expressions in the Inclusion or Exclusion boxes 
perform the following steps:

a Double-click the first expression to move it to the workspace box and remove 
it completely from the workspace box before double-clicking the second 
expression.

b Double-click the second expression to move it to the workspace box and 
remove it completely from the workspace box.
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About Segmentation Approaches
When creating a segment, you save it as one of the following segment types:

■ Target Group Segment (Target Group). You can use this method if you install and 
use Siebel Analytics to create marketing segments. For more information see 
Siebel Analytics Installation and Configuration Guide.

This type of segment allows marketing users to create and save a list of 
customers or prospects who qualify for a set of analytics criteria (report filters). 
By creating a target group segment, you can save the list of customers from a 
report and use that list in any segment for any marketing program. When using 
a target group segment in a marketing program, customers are selected when the 
target group is loaded. When you create a segment from an Analytics 
Dashboard, the type of the segment defaults to Target Group. For more 
information, see “Saving Segments as Target Group Segments” on page 563.

■ Criteria-Based Segment (DD Segment). Use this method when you plan to use the 
snapshot process to perform the full segment evaluation.

This type of segment creates segments in the Marketing application using 
boolean criteria. When using a criteria-based segment in a marketing program, 
customers are selected when the snapshot is generated by applying the segment 
criteria. When you create a new segment in the Segments screen, the Segment 
Type defaults to DD Segment.
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About Criteria-Based Segments
Segments are collections of customers with common characteristics that are 
significant from a marketing or data analysis perspective.

Segment criteria, like filter criteria, are defined using expressions that represent the 
characteristics of the population you are targeting with offers. For example, segment 
criteria might be designed to locate customers with high account balances, who 
demonstrate brand loyalty and whose age is between 30 and 40 years old. When 
you define segments using Siebel Marketing’s Segments views, you can make sure 
only those customers that meet the criteria are included in your target list. Segment 
criteria are applied to the data during snapshot generation after the data has been 
filtered.

Segment criteria can include bucket and attribute values, database fields, and 
numeric and date measures. You might create a complex segment by linking 
multiple attributes and measures using AND, OR, and NOT logical operators. You 
might also create a simple segment by using a single measure or attribute. Segments 
are reusable across marketing programs and are not tied to any specific list of 
customers.

You can modify segment criteria without having to regenerate the snapshot as long 
as the criteria do not require values from new fields or use new measures, or 
attributes. However, if you modify a segment’s criteria to include a measure, field, 
or attribute that is not included in the current snapshot, the snapshot must be 
regenerated. In addition, if you modify the definition for a bucket or custom 
measure used in the snapshot, it must be regenerated.
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Building a Criteria-Based Segment
In the Segments screen, segment details appear in the Segment form. To edit 
information, change the values in the Segment form. To create a different segment, 
create a new record.

The Edit Segment view tab allows you to build, view, and edit segment criteria. This 
view provides access to attribute values, bucket values, database fields values, and 
numeric and date measures by selecting values from the Attributes drop-down list.

■ Creating a Criteria-Based Segment

■ Working with Segment Definitions on page 244

■ Defining Segment Criteria in the Segments Screen on page 245

■ Using Wildcard Searches for Segment Attributes and Fields on page 248

Creating a Criteria-Based Segment
Use the following procedure to create a segment record and use the Edit Segment 
view to specify segment criteria. Do not use segments without defining criteria. 

To create a criteria-based segment

1 From the application-level menu, choose View > Site Map > Segments.

2 In the Segments list, create a new record.

3 Type a name and description for the segment.

4 Accept the default source code (record ID) or type a new, unique source code for 
the segment.

The segment source code can be used in the Source Code format for the 
marketing program.

5 Click the Customer Hierarchy select button.

6 In the Pick Customer Hierarchy dialog box, choose a hierarchy and click OK.

You cannot change the customer hierarchy after the segment is saved.
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7 Click the Targeting Level select button.

8 In the Pick Targeting Level dialog box, choose a level from within the selected 
hierarchy and click OK.

You cannot change the targeting level after the segment is saved. The selected 
level determines the availability of buckets and custom measures (at the selected 
targeting level or higher). For example, if you have a primary (top) level called 
Customer and a secondary (lower) level called Account and you select the 
Targeting level, only buckets and measures at this level are available. If you 
select the secondary level, Account, buckets and measures at the Customer and 
Account levels are available.

Working with Segment Definitions
The following procedures describe other ways to work with segment definitions:

■ To edit a segment definition, select the segment record in the All Segments (or 
My Segments) list and then click the Edit Segment view tab. 

You also can drill down on the segment name hyperlink to open the Edit 
Segment view.

■ To display a list of marketing programs and stages that use the segment 
definition, click the Programs view tab and then click the Program or Stage name 
hyperlink.

This hyperlink takes you directly to the programs list, or the programs stages 
view tab.

■ To view a list of team members that can create or modify segment definitions, 
click the Team view tab.
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Defining Segment Criteria in the Segments Screen
The method for defining segment criteria is similar to the method for defining filter 
criteria. Use the Attributes drop-down list to choose Attributes, Buckets, Fields, 
Numeric Measures, or Date Measures. To transfer values to the Criteria workspace 
box, place your cursor in the Criteria workspace where you want to insert a value, 
select or type a value, and click Add. If you want to choose a range of values, click 
Select Group and choose values.

NOTE: The Criteria view tab contains the workspace box where you build complex 
definitions using AND, OR, NOT, and ( ) logical operators. 

When building segment criteria, follow the following rules:

■ After adding criteria, click the AND or OR logical operator before adding more 
members or measures. If you are using NOT, add the criteria statement first and 
click NOT to negate it.

■ Whenever possible, surround multiple selections with parentheses. The open 
and close parentheses will be placed on the line below the cursor position. Place 
the cursor on the line above the line on which you want the open or close 
parenthesis and click the corresponding parenthesis.

■ When you have completed the segment definition, click Validate & Save to 
commit the segment criteria. This process validates the syntax of the segment 
criteria, checking for missing parentheses, and so on.

■ To delete segment criteria, place the cursor on the line to be deleted, right-click 
and choose Delete, or Delete All.

To build a segment definition

1 From the application-level menu, choose View > Site Map > Segments.

2 In the Segments list, select the segment for which criteria will be defined.

3 Click the Edit Segment view tab or drill down on the segment name.

4 In the Attributes form, in the Attributes drop-down list, select one of the items 
from which you want to choose a value.

5 In the tree list, expand the folders to display the values.

■ To select a single value, click a value’s check box.
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■ To select a range of values, click Select Group and select a range of values.

Selected values will have a check mark. To discard a value, click the selected 
value’s check box again to remove the check mark. 

If the object you want is not listed, refer to the Customer Hierarchy view and see 
to which targeting level it belongs. Your marketing or database administrator 
may have to create the object for the selected Customer Hierarchy.

6 Click Add to transfer the values to the Workspace box. 

Criteria values are added to the line following the cursor position. 

7 If your segment requires a measure or date measure, choose Numeric Measure 
or Date Measure from the drop-down list to display the measure-builders. 

8 When you have finished defining the segment criteria, click Validate & Save.

To create numeric measure criteria

1 From the application-level menu, choose View > Site Map > Segments.

2 In the Segments list, select the segment for which criteria will be defined.

3 Click the Edit Segment view tab or drill down on the segment name.

The Edit Segment view appears with the Attributes tab and tree list as the 
default. 

4 From the drop-down list, choose Numeric Measures.

5 In the Numeric Measures form, shown in the following illustration, complete the 
fields.

a Click the Name select button.

b In the Pick Measures dialog box, select a measure and click OK.

The measure name appears in the name field.

c Click the Operator select button, and choose a logical operator from the list.

Options are =, <>, >, <, >=, <=, and BETWEEN. 

d In the Value 1 field, type a number.
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e If BETWEEN is the operator, type a number in the Value 2 field.

6 Click Add to transfer the measure value to the Criteria workspace.

7 Click Validate & Save.

To create date measure criteria

1 From the application-level menu, choose View > Site Map > Segments.

2 In the Segments list, select the segment for which criteria will be defined.

3 Click the Edit Segment view tab or drill down on the segment name.

The Edit Segment view appears with the Attributes tab and tree list as the 
default.

4 From the drop-down list, choose Date Measures.

5 In the Date Measures form, complete the fields.

a Click the Name select button.

b In the Pick Measures dialog box, select a predefined measure and click OK.

c In the Value (Days) field, click the select button and use the calculator 
controls to type the number of days.

d Click the Operator select arrow, and choose BEFORE or AFTER from the list. 

e In the Value (Date) field, click the select arrow and use the calendar to type 
a date or select the Run Date check box if you plan to use the server run date.

6 Click Validate & Save.

NOTE: The Date Measure value must be greater than January 1, 1970.

For example, to capture every response in the last seven days, based on the 
server run date, the Date Measure fields would contain the following values:

■ Measure: Response Date

■ Value 1 (Days): 7
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■ Operator: Before

■ Run Date box: Selected

Using Wildcard Searches for Segment Attributes and Fields
Using the Edit Segment’s Attribute Search and Field Search functions, you can 
perform a wildcard search for fields or attribute level values with certain 
characteristics, without having to manually select individual values in the 
Attributes or Fields tree lists.

For example, you might want to select states whose name begins with the letter A. 
Using the Attributes tree pane, you might expand the folders to reach state values, 
and then choose individual states such as Alabama and Alaska. Using Attribute 
Search, you might select the state values folder, and specify search criteria of A* to 
automatically select qualifying states. Because you are not selecting values 
individually, no values appear for the attributes or fields in the Attributes Search or 
Fields Search lists.

Valid search characters are asterisk (*) and the number symbol (#).

■ An asterisk (*) in the search pattern results in a match containing more than one 
character in the value.

If the search value is City=C*, the search returns Charleston, Columbia, 
Chicago, and so on.

■ A number sign (#) in the search pattern results in a match containing exactly 
one character in the value.

If the search value is VALUE=M#Y, the search returns MAY, MEY, MeY.

■ Search pattern values are case sensitive, for example, V* will produce different 
results than v*.

■ A combination of * and # can be used in the search pattern, but only when using 
the equal (=) operator.
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Table 51 shows an example of wildcard results when searching for a State field in a 
Customers table.

To perform a wildcard search for attributes 

1 From the application-level menu, choose View > Site Map > Segments.

2 In the All Segments list, create a segment record and save it.

3 In the All Segments list, select the segment and click the Edit Segment view tab.

The segment form appears with the Attributes and Criteria panes in the lower 
half of the view.

4 In the Attributes tree pane, select Attribute Search from the drop-down list.

The view refreshes and the Wild Card Search entry field appears. 

5 In the Wild Card Search field, type your search criteria.

6 In the Attributes tree pane, expand the folders to display values, and select the 
attribute level you want to find.

7 Click Add.

The attribute, including the search criteria is moved to the Criteria workspace.

8 When you have finished defining your segment criteria, click Validate & Save.

To perform a wildcard search for fields

1 From the application-level menu, choose View > Site Map > Segments.

2 In the All Segments list, create a segment record and save it.

Table 51. Wildcard Search for Attribute and Field Values

Customers.State (values)
Wildcard Search = 
V*(result)

Wildcard Search =
V# (result)

Wildcard Search VALUE= 
V*a

Virginia, VA, VT, 
Vermont, MD, Utah

Virginia, VA, VT, 
Vermont

VA, VT Virginia
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3 In the All Segments list, select the segment and click the Edit Segment view tab.

The segment form appears with the Attributes and Criteria panes in the lower 
half of the view.

4 In the Attributes tree pane, select Field Search from the drop-down list.

The view refreshes and the Wild Card Search entry field appears along with the 
Fields tree list.

5 In the Wild Card Search field, type your search criteria.

6 In the Fields tree pane, expand the folders to display values, and select the check 
box for the field you want to find. 

7 Click Add.

The field value, including the search criteria is moved to the Criteria workspace.

8 When you have finished defining your segment criteria, click Validate & Save.
250 Siebel Marketing Guide Version 7.5.3



Defining Filter and Segment Criteria

About Target Group Segmentation
About Target Group Segmentation
The Target Group Segmentation feature allows you to use Siebel Analytics report 
criteria to create Siebel Marketing segments without having to write complex 
expressions in the Segments screen.

In the Answers screen, you can create a Siebel Analytics report and, if you wish, 
save it for future use. When you are satisfied with the report results, you create the 
Siebel Marketing segment, name it, and assign a customer hierarchy and targeting 
level. You have the option to use Analytics screens (dashboards) to choose reports 
created in Siebel Analytics and create a segment from the report.

NOTE: You must be logged on to the Siebel Analytics Server to have access to the 
Analytics screens.

This feature is only available after you install and configure Siebel Analytics. For 
more information see Siebel Analytics Installation and Configuration Guide.

For information about what happens in your application when you create a target 
group segment, see “Saving Segments as Target Group Segments” on page 563.
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Creating, Loading, and Refreshing a Target Group 
Segment

A target group segment is any segment that is created from a Siebel Analytics report. 
You use Siebel Marketing and Siebel Analytics to create target group segments from 
an Analytics report. 

To create a target group segment, you can use an existing Analytics report, 
customize an existing report, or create a new report. When you load a target group 
segment, the target group is created, the Analytics file is read, and data is loaded 
into the target group segment based on criteria in the Analytics report. To update 
the segment, you can refresh the target group segment list at any time. To create, 
load, and refresh a target group segment, perform the following tasks:

■ “Creating and Loading a Target Group Segment”

■ “Refreshing a Target Group Segment List” on page 255

Creating and Loading a Target Group Segment
You can use an existing report or create a new report in the Answers screen. The 
report must be based on the Subject Area table that was mapped during the target 
group setup process. For mapping information, see “Setting Up Target Group 
Segment Tables and Joins” on page 125.

After creating a target group segment, you must load the customers before the 
segment list is saved.

To create, customize, and load a target group segment

1 From the application-level menu, choose View > Site Map > Answers > 
Answers.

2 In the Answers screen, in the left pane, click the Catalog tab.

3 In the Catalog area, select a report or in the New Request area, create a new 
report, and then click the Results view tab to see the report.

For more information about creating and customizing a report, see the sections 
about Siebel Answers and Siebel Marketing Analytics in Siebel Analytics User 
Guide.
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4 To customize a report, in the upper left of the Results view tab, click Customize 
View and perform the following steps:

a In the Add View section, locate the Other View section and click Create 
Segment to add a Create Segment section to the report.

b To view the final report, in the upper left of the pane, click Show Results.

c In the upper right of the pane, click Save.

This is a multiple step process that allows you to name your report and save 
it in a specific location. After specifying the report name and save location, 
the Criteria tab appears with the name of your report at the top.

d In the Criteria tab, you can apply additional filters or drill down on any 
portion of the report to constrain the dataset to the appropriate audience. 

e Click Save.

5 Click the Results tab, and then click Create Segment.

The Segment screen appears with a new record created in the segment list.

6 In the Segments list, complete the following fields before stepping off or saving 
the record:

Field Description

Customer Hierarchy Confirm defaulted value is correct.

Customer Level (Targeting Level) Confirm defaulted value is correct.

Name User-defined descriptive name.

Type Type of Segment you want to create. Values are:

■ Target Group. Saves a static list of customers who 
qualified for the report as well as the logical SQL that was 
used by the report.

■ Segment DD. This value is for legacy use only.

■ Criteria. Identifies criteria-based segments (Target Group 
Segmentation). When you install the maintenance 
release, pre-existing segments are assigned this value.
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7 Save the segment record, and then click the Target Groups view tab.

NOTE: The SQL field displays the logical SQL that was used by the Analytics 
report and the Count, Status and Date Loaded fields are empty. The group of 
customers is not saved as a static list until you load the customers.

8 To load the customers who qualify, in the Target Groups form, click Load/
Refresh.

When the load process is complete, the read-only fields in the Target Groups 
form show the following information:

Field Description

Count When the load is complete, this field shows the number of 
customers who were selected by the segment criteria/report filters.

Date Loaded The date and time that the load completed. The format of this 
information is YYYY.MM.DD.HH.MM.SS.

Last Modified By The user ID of the last person to modify the record or refresh the 
target group segment.

Name The new target group name appears in the following format:

“[creator’s user ID]- [segment name]”

SQL The logical SQL that generated this segment. This data can be 
copied and pasted for reuse.

Status Load status. Messages indicate if the load is being imported, is 
successful, or if it failed.
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9 To verify that your target group loaded correctly, click the Edit Segment view tab.

In the Criteria work space, one line points to the new target group name. You 
can now use your segment in a marketing program.

CAUTION: It is strongly recommended that you do not change this target group 
name statement in the Criteria work space. This is a system-generated definition 
based on the information specified when creating the target group segment. Any 
change to this definition might produce unintended results.

Refreshing a Target Group Segment List
You can refresh a target group at any time. This process overwrites the previous list 
of customers in the target group segment with the most recent customer 
information from Siebel Analytics. To save the previous list and generate a new list, 
return to your original Siebel Analytics report before you refresh the target group 
segment, and then use the Create Segment link to create a new segment. You can 
give the new segment a similar name, for example, My Segment - version 2. Now 
you have two identical segments and, if you refresh one, the other will not be 
changed.

You can refresh a target segment list in the following ways:

■ Processing a One-Time Refresh of a Target Group Segment List on page 255

■ Scheduling a Repeating Refresh of a Target Group Segment List on page 256

Processing a One-Time Refresh of a Target Group Segment List
You can request that a target group segment list be refreshed immediately or 
schedule the refresh for another time.

To refresh a target group segment list

1 From the application-level menu, choose View > Site Map >Segments > My 
Segments.

2 In the Segments list, query for your segment.

3 Click the Target Groups view tab.
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4 Click Load/Refresh.

5 In the Pick Start Time dialog box, select a start time for the refresh.

NOTE: the Start Time field defaults to the current date and time.

a To start the refresh immediately, do not change the start date and time.

b To schedule a start time, in the start time field, change the date and time.

6 Click OK.

Scheduling a Repeating Refresh of a Target Group Segment List
The Analytic Adapter workflow process loads customer IDs for the target group into 
a staging table (X_DD_TRGTGRPMBR) in the Siebel transactional database. If your 
organization wants to schedule specific target groups to be refreshed on a regular 
basis, you can create a workflow process using the Analytic Adaptor Manager 
business service. This business service needs the input arguments shown in 
Table 52. For more information about creating a workflow process, see Siebel 
Business Process Designer Administration Guide.

Table 52. Analytic Adaptor Manager Input Arguments

Input Argument Default Value Description

AnalyticTool Default to correct value 
for Siebel Analytics.

Optional. Indicates the analytic tool 
where the input result set will be 
generate.

NumberofDataKeys =7 Optional. Specifies the maximum 
number of IDs that can load.

SegmentId Required. Type the ID of the target 
group segment to be refreshed.
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Offers are a way to present content on product and services to current and potential 
customers as part of a campaign. Offers are associated with a campaign, and then 
presented to contacts and prospects when the campaign is launched. A campaign 
might focus on developing awareness of product branding, increasing or reinforcing 
product usage or customer loyalty, or it might contain a special offer on a new 
product related to products that customers have already purchased.

Offers can be reused in many campaigns, but the campaign is a one-time event that 
is associated with a marketing program stage.

Offers associated with campaigns are created using the Offers screen. Typically each 
campaign has a single offer, but you can associate multiple offers with one 
campaign. For example, a single campaign might have email and Web offer 
components.

Using the Offers views, you can create, edit, and preview reusable multichannel 
offers, which can be associated with your campaigns.

In addition, you can design personalized HTML and text templates for email, 
eNewsletters, and Web Offers and create rules-based eNewsletters that deliver 
content based on contact and prospect attributes. Email and eNewsletter can 
contain embedded links to items such as Web offers, Web surveys, and forms, 
which allow the marketer to assess and capture campaign responses. Web Offers 
can contain embedded links to Web surveys, events and related URLs, downloads, 
and response forms.

This chapter contains the following topics:

■ Creating and Modifying Offers - Basic Steps on page 259

■ Creating and Editing Offer Templates on page 265

■ Working With Email Offers on page 277

■ Creating and Editing eNewsletter Offers on page 281
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■ Associating Web Offers, Web Surveys, Events, and URLs With Offers on 
page 289

■ Working With Fax Offers on page 292

■ Using Delivery Profiles - Email, eNewsletter, and Fax on page 294

■ Working With Phone Offers on page 297

■ About Direct Mail Offers on page 299

■ About Media Offers on page 300

■ Associating Literature with Offers on page 301

■ Working With Web Offers on page 302
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Creating and Modifying Offers - Basic Steps
You can create offers in Siebel Marketing, Siebel eMarketing, and Siebel Campaigns. 
The All Offers list displays reusable offers that you define. You can create a new 
offer record and click the offer name hyperlink to add details, templates, literature, 
and so on. For information about using offer templates to create an offer, see 
“Creating an Offer Template and Adding it to the Template List” on page 266.

Use the Show drop-down list to navigate directly to an offer type. The types of offers 
that are available to you depend on the features your company is licensed to use.

To create and modify offers, perform the following tasks:

■ Creating an Offer

■ Modifying an Offer on page 263

■ Applying Globalization Rules to Offers on page 264

■ Associating Products with Offers on page 264

Creating an Offer
You can use the following procedure and table to create offers. For instructions 
about how to create eNewsletter offers, see “Creating and Editing eNewsletter 
Offers” on page 281. After creating an offer you can associate an offer template with 
it.

To create an offer

1 From the application-level menu, choose View > Site Map > Offers > All 
Offers.

2 In the All Offers list, add a new record.
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3 Complete the fields, using Table 53 as a guide.

Table 53. Selected Offer Fields

Fields Comment

(Legal) Approved By Indicates the Employee designated as the Legal approver. 
Only the creator of an offer can define the approver.

(Marketing) Approved By Indicates the Employee designated as the Marketing 
approver. Only the creator of an offer can define the 
approver.

(Marketing, Legal) 
Approved Date

Each of these fields are automatically populated with the 
date that the marketing or legal designate approved the 
offer.

Activation Date Use the calendar controls to select the offer’s activation 
date. You can associate an inactive offer with a campaign, 
but when you launch the campaign, only active offers will 
be executed.

Create Activity check box Used for email offer templates. Select this option to set 
activity logging. When the email is sent, an activity is 
created for each recipient of the email, stating that the 
email was sent. The activity record is created through the 
System Activity Object for either the Campaign Recipient 
or Campaign Position business components.

Delivery Profile Used for email offer templates. Select the name of the 
communications profile from the list.

The profile is used when sending the email. Profiles are 
created using the Communications Administration 
screen’s Communications Drivers and Profiles view. For 
details, see “Creating a Delivery Profile” on page 295.

If you want to send out HTML email offers, select a profile 
based on the Internet SMTP/POP3 Server driver. If you 
select a different driver, the HTML in your email may not 
be coded properly.

Description Type a description of the offer.
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Expiration Date Click in the field and use the calendar controls to select 
the offer’s expiration date. 

Expired offers should not be associated with campaigns 
because they will not be sent out when the campaign is 
launched.

Legal Approved When checked, this indicates that the designated person 
in the Legal Approved By field has approved the offer.

The creator of the offer can select any employee as the 
designated approver of the offer. Only the creator of an 
offer can define the approver. 

When that approver logs in to the system, the approver 
can select the Legal Approved check box to approve the 
offer. No one else can approve the offer. The date field for 
the approval is populated automatically as soon as the 
approver selects the Legal Approved check box.

The creator of the offer can change the approver name 
before approval. After the approver has approved the 
offer, however, the creator cannot modify the approver 
name.

Marketing Approved When checked, this indicates that the designated person 
in the Marketing Approved By field has approved the 
offer.

The creator of the offer can select any employee as the 
designated marketing approver of the offer. Only the 
creator of an offer can define the approver. 

When that approver logs in to the system, the approver 
can select the Marketing Approved check box to approve 
the offer. No one else can approve the offer. The date field 
for the approval is populated automatically as soon as the 
approver selects the Marketing Approved check box.

The creator of the offer can change the approver name 
before approval. After the approver has approved the 
offer, however, the creator cannot modify the approver 
name.

Name Name of the offer.

Table 53. Selected Offer Fields

Fields Comment
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Offer Code This system-populated field contains a unique code to 
identify the offer. You can change this code, but make 
sure the new value is unique.

Price List A previously defined price list can be associated with this 
offer.

A marketer can create promotional prices for specific 
products. When an offer recipient clicks a product item 
hyperlink in an email or Web offer and goes to the 
product detail Web page, the recipient sees the 
promotional price that was defined using Siebel ePricer.

The set of products associated with the selected price list 
can be different from the set of products defined in the 
offer’s product list. When a contact responds to an offer, 
clicks a product link, and goes to the product detail page, 
the contact sees the promotional price that is defined for 
that product only if that product is a part of the price list 
that was selected for this offer. Otherwise, the contact will 
see the default price for the product.

Subject Text Used for email offer templates. Type the text that will be 
used in the subject line of the email. 

You can include merge fields in the subject line if desired. 
For example: Exciting offer for [Field: M/M] [Field: First 
Name] [Field: Last Name].

Table 53. Selected Offer Fields

Fields Comment
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Modifying an Offer
You can use the following procedure to modify offers. For instructions about how 
to modify eNewsletter offers, see “Creating and Editing eNewsletter Offers” on 
page 281.

Type The channel used to distribute the offer, such as email, 
eNewsletter, fax, media, phone, Web, or direct mail. 

Web Server Used for email offer templates. Type the URL (path) for 
the computer and directory on your Web server where the 
Siebel Web templates are stored.

■ Template locations. When a contact clicks a Web 
offer, response form, or product catalog item in an 
email, a particular Web server receives that request. 
You must specify the Web server and directory where 
these templates can be found. A Web server URL 
looks something like the following:
http://www.siebel.com/eMarketing 

■ Embedded links. When eMarketing encodes 
embedded Web offers, Web surveys, response forms, 
or product item links in an email, it assumes that the 
Web templates used for a particular offer, survey, 
response form, or product catalog are present at the 
specified URL.

■ Event links. If you include an event link in your email, 
you must reference the Web Server for the Events 
views. The eMarketing Web Server location must be 
first and the Events Web Server location must be 
second, separated by a semicolon without a space 
before or after the semicolon. For example, your Web 
server field will look like the following:
http://www.siebel.com/eMarketing;http://
www.siebel.com/eEvents.

Table 53. Selected Offer Fields

Fields Comment
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To modify an offer

1 From the application-level menu, choose View > Site Map > Offers > All 
Offers.

2 In the All Offers list, select the offer that you want to change.

3 Make the necessary changes, using guidelines in Table 53 on page 260.

Applying Globalization Rules to Offers
Each offer record contains a language and a locale value. When you create an email 
or eNewsletter offer record, the language and locale values default to the values set 
in your profile. You can change the values to match your business needs. When you 
launch the campaign, the language and locale assigned to the email offer will be 
used for all recipients. When Communication Server processes an email request for 
this campaign, it identifies the language and locale of the first offer, changes to that 
offer's language and locale, and processes that offer and all associated offers using 
that language and locale.

Associating Products with Offers
You can associate predefined products with the offer. Ideally, you should only select 
a subset of products from the price list associated with an offer, because there is a 
many-to-one relationship between the products and the price list. The products that 
you associate with the offer determine which product catalog page links can be 
embedded in Email, Web, and eNewsletter offers.

To associate a product with an offer

1 From the application-level menu, choose View > Site Map > Offers > All 
Offers.

2 In the All Offers list, select the offer and click the Products view tab.

3 In the Products list, create a new record.

4 In the Add Internal Products dialog box, select a previously defined product and 
click OK. 
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Creating and Editing Offer Templates
Offer templates are available in Siebel Marketing, Siebel eMarketing, and Siebel 
Campaigns. You can create a template using HTML tools or text editors such as 
Microsoft Front Page and Windows Notepad. After creating a template, you add the 
file to the template list, add embeddable objects (personalization elements), and 
associate the template with an offer. After you associate a template with an offer 
you can edit, verify, and preview text and HTML templates by drilling down on the 
template name hyperlink.

Offer templates can be associated with the following offer types:

■ Fax offers. For more information on Fax offers, see “About Fax Offers” on 
page 292.

■ Email offers. When creating an email offer, you can use the Email Templates view 
tab to associate a template with the offer.

■ eNewsletter offers. When creating an eNewsletter Offer, you can use the 
eNewsletter Section view tab to specify templates for each section of the 
newsletter. For more information about creating and editing eNewsletter offers, 
see “Creating eNewsletter Offers” on page 282.

■ Web offers. When creating a Web Offer, you can use the Edit Web Offer view tab 
to associate a template with the offer.

You can modify template files using your preferred HTML editor or Siebel HTML 
Editor. When you upload the changed template to the server, you overwrite the 
original template and all the offers associated with that template inherit the edited 
template. 

Before a template has been added to (associated with) an offer, you can modify the 
template using your preferred HTML editor. After an offer template has been added 
to an offer, you can edit the template and add personalization elements in the Offers 
screen (Edit views).

CAUTION: You should establish a version-control policy for template changes. Any 
changes made to a template through the Edit views will appear in all of the offers 
that use that template.
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To create and edit offer templates, perform the following tasks:

■ Creating an Offer Template and Adding it to the Template List

■ Using Hyperlinks (HREF) in an Offer Template on page 267

■ Editing a Template That is Not Associated With an Offer on page 268

■ Editing a Template That is Associated With an Offer on page 269

■ Using Personalization Categories on page 273

Creating an Offer Template and Adding it to the Template List
Offer templates are usually created with a file type of either ASCII text (.txt) or 
HTML (.htm or .html). You create the template using HTML tools and text editors 
such as Microsoft Front Page and Windows Notepad. 

NOTE: You can create offer templates with other types of files such as PDF and DOC. 
Because you use offer templates primarily for email, Web, and eNewsletter offers. 
HTML and text files are the most common file types used.

After creating the template, you must add the new template to the Offer Templates 
list so that you can associate it with an offer.

To create an HTML or text offer template

1 Create an HTML template, using the HTML or text editor of your choice.

a Using Microsoft Word, Front Page, Notepad, or another editor, create a new 
file.

b For HTML templates, save the file as a text document using an .htm file 
extension.

2 If it does not already exist, create a subdirectory of your HTML templates 
directory and call it Images.

In this directory, you store the graphics that will be used in the offer. Make sure 
that you refer to each image as follows, replacing image.gif with the name of the 
embedded image:
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<IMG BORDER=0 SRC="http://<server name>/emarketing/images/ 
image.gif">

NOTE: You cannot use HTML or embedded images in text email.

3 Add the template you created to the Offer Templates list using the following 
procedure, “To add a template to the Offer Templates list.”

4 Copy the images you embedded in your offer to the subdirectory you created or 
the image folder you referenced in Step 2.

To add a template to the Offer Templates list

1 From the application-level menu, choose View > Site Map > Offers > All 
Offers.

2 From the Show drop-down list, select Offer Templates.

3 In the Offer Template Files list, add a new record.

4 Complete the fields to add the offer template to the list.

a In the Name field, type a name for the template.

b In the File Name field, click the select button, navigate to the template file, 
and select it.

Using Hyperlinks (HREF) in an Offer Template
Siebel Marketing can perform a special processing task for HTML-based emails, 
eNewsletters, and Web offers. A URL address typed directly into the body of an 
HTML template, such as http://www.siebel.com, is not recognized as a hyperlink 
by the HTML parser. The generic HTML syntax for a hyperlink is:

<a href="target url">highlighted text or picture</a>

The link includes both the URL and the anchor, which is the text or image that 
appears in the template and links to the URL. Thus, if you want to create a link to 
the URL http://www.siebel.com and display Siebel Web Site as the text in the 
message, you must type the following:

<a href="http://www.siebel.com">Siebel Web Site</a>
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Using this method, Web offers, response forms, and product items are replaced 
differently in HTML templates from the way they are replaced in text templates. The 
following list describes the default method for processing hyperlinks.

■ For Web offers, Web surveys, and product links, Siebel Marketing creates the 
hyperlink so that the hyperlinked text is the Web offer name, Web survey name, 
or product name such as in the following reference:

<a href="[Web Offer: 10% discount offer]">10% discount offer</a>

For more information, see “Using Personalization Categories” on page 273.

■ For Response forms, Siebel Marketing creates the hyperlink so that the 
hyperlinked text is the same as the Response form’s description in the Response 
Types view. The hyperlinked text for a response form can be modified in the 
Response Types view, where, for each response form, a description field 
represents the value used for highlighted text.

These default methods for processing hyperlinks in Siebel Marketing can be 
modified. You can put an asterisk (*) before the Siebel tag to tell the Siebel 
application that you will manually define the hyperlink format in the HTML body. 
The asterisk tells the Siebel application not to create the hyperlink.

For example, instead of pasting [Web Offer: Great Discount], the marketing 
manager can type the following:

<a href=[*Web Offer: Great Discount]>Whatever I want to highlight 
be it text or picture</a>

In this case, Siebel Marketing replaces the Web Offer with the proper URL but does 
not create the HREF syntax. You can then create a Web offer link, product item link, 
and response form link with any text or picture you desire.

Editing a Template That is Not Associated With an Offer
If you have not added a template to an offer, you can change it using the application 
that you used to create the file, for example, Microsoft FrontPage or Notepad.

To modify and upload an offer template file

1 Make the necessary modifications to the template file saved on your local drive, 
using the same text editor used to create the file.
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2 Save and close the file.

3 From the application-level menu, choose View > Site Map > Offers > Offer 
Templates.

4 In the Offer Template Files list, select the template you just changed.

5 Upload the changed template file using the following steps:

a Click the File Name select button.

b In the Add Attachment dialog box, click Browse.

c Select the file and click Open.

Editing a Template That is Associated With an Offer
After you add a template to an offer, you can edit it in the following ways: 

■ Edit a template in the Offers screen. Make basic changes to your template using 
Siebel HTML Editor or a text editor. In the Edit views of the Offers screen, you 
click Edit Template in the Edit Email, Edit Web Offer, Edit Fax, and Edit Section 
(eNewsletter Offers) view tabs. 

If you created your template as an HTML file, Siebel HTML Editor displays the 
offer contents for editing.

If you created your template as a text file, a text editor displays the offer contents 
for editing. The offer appears with the merge fields inserted and the embedded 
links active. Previewing allows you to verify the offer’s syntax, including merge 
fields and embeddable objects.

■ Modify a template using your default HTML editor. Use to export the template file, 
make changes and import back into the Siebel file system. Examples of content 
editors are Microsoft Front Page and Notepad. For more information, see 
“Editing a Template Using Your Default HTML Editor” on page 271.

To edit an offer template in the edit views of the Offers screen

1 From the application-level menu, choose View > Site Map > Offers > All 
Offers.

2 From the Show drop-down list, select the type of offer, for example Email Offers.
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3 In the Offers list, select an offer and click the appropriate templates view tab.

4 Select the template you want to change and click the appropriate edit view tab.

5 Click Edit Template to open the template for editing and start the appropriate 
editor. One of the following editors starts:

■ Text editor. You use this tool to make simple changes to the text. The text 
editor starts by default, if the selected template is a text (.txt) file.

■ Siebel HTML editor. You can use this tool to make more complex changes than 
you can make in a text editor. The Siebel HTML editor starts by default, if the 
selected template is an HTML (.htm or .html) file. For more detail, see “Using 
the Siebel HTML Editor” on page 270.

6 To edit the contents of the template, click in the Template Contents workspace 
to display the editor’s toolbar.

The editor’s toolbar does not display until you click in the workspace.

7 From the Personalization Categories list, select a category type (for example, 
Merge Fields), and then copy and paste personalization elements from that 
category into the email offer template. 

For details, see “Using Personalization Categories” on page 273.

8 When you finish making changes, click Save Template.

9 Click Verify & Preview to preview your changes and verify that the template still 
performs correctly.

Repeat Step 5 through Step 9 to continue editing the template.

Using the Siebel HTML Editor
You can use Siebel HTML Editor to make changes to your HTML template. To make 
more complex changes than allowed in the Siebel HTML Editor, see “Editing a 
Template Using Your Default HTML Editor” on page 271.
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To make changes using the Siebel HTML Editor, you type your changes directly in 
the workspace. In addition, you can use the editing toolbar at the bottom of the 
Template Contents workspace for formatting text. Most of the buttons on the toolbar 
are the same buttons that appear in standard text editing software. For more 
information about the export and import buttons, see “Editing a Template Using 
Your Default HTML Editor” on page 271.

CAUTION: In the HTML editor, you must explicitly save your changes using one of the 
save functions in the application. You can click the Save Template button when it is 
available, or you can select Save Record after clicking a list or form menu button. 
The CTRL+S keyboard shortcut does not work in the HTML Editor workspace. If 
you want to use this keyboard shortcut, you must step off the editor into another 
field before clicking CTRL+S.

Editing a Template Using Your Default HTML Editor
If you want to make more complex changes or if you are more comfortable making 
changes in your HTML editor, you can export the template file, use your preferred 
(default) HTML editor, and import the file back into the Siebel file system. To use 
this method, perform the following tasks:

■ Set your default HTML editor.

■ Map the User Environment variable called TEMP to your local Temp folder.

■ Edit a template file using your default HTML editor.

To set your default HTML editor

1 Open your Web browser.

2 Set your default HTML editor in the browser’s user preferences.

For example, in Microsoft Internet Explorer, you find the HTML editor setting in 
the Tools application menu, using the following path:

Tools > Internet Options > Programs

3 Save your change.
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To map the User Environment variable to your local temporary folder

1 From the Windows task bar, choose Start > Settings > Control Panel.

2 Double-click System and perform Step 3 for Windows NT or Step 4 for Windows 
2000.

3 If you use Windows NT, perform the following steps.

a Click Environment.

b Select the User Variables window.

c In the User variables for [username] workspace, in the Variables column, 
select TEMP.

d Click Set.

4 If you use Windows 2000, perform the following steps.

a Click the Advanced tab and click Environment Variables.

b In the User variables for [username] workspace, in the Variables column, 
select TEMP and click Edit.

c In the Edit Variables dialog box, in the Variables Value field, type c:\temp.

d Click OK in each dialog box until you return to your desktop.

To edit a template file using your default HTML editor

1 From the application-level menu, choose View > Site Map > Offers > All 
Offers.

2 From the Show drop-down list, select the type of offer.

3 Select an offer and click the appropriate templates view tab.

4 Select the template you want to change and click the appropriate edit view tab.

5 Click Edit Template to open the template for editing and start the appropriate 
editor.

a To display the editor’s toolbar, click in the Template Contents workspace.

The editor’s toolbar does not display until you click in the workspace.
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b Edit the contents of the template.

6 In the HTML Editor toolbar, click the export button.

The default editor starts and the template file opens for editing.

7 In the Editor menu, choose save to save the template file on your local machine.

This saves the template file in your desktop/temp directory with the file name 
of template.htm.

8 Make changes to the template and save the file.

CAUTION: Do not change the file name. If you change the file name the application 
will not be able to automatically locate the file and you will have to manually 
locate the file and location while importing. 

9 In the HTML Editor toolbar, click the import button.

a In the Import dialog box, select the template you want to import and click 
Open.

b By default, template.htm is automatically selected. If you need to import a 
different file, locate and select the appropriate file.

10 In the Edit Email list, click Save Template.

Using Personalization Categories
The Personalization Categories drop-down list contains the categories of supported 
embeddable object types. Depending on which category type you select, the lower 
list displays the available personalization elements of that category.

The available personalization categories are:

■ Events

■ Merge Fields

■ Product Catalog Items

■ Related URLS
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■ Response Forms

■ Web Offers

■ Web Surveys

Each category has a number of personalization elements. For example, the Merge 
Fields category has the following personalization elements:

■ [Field: M/M]

■ [Field: First Name]

■ [Field: Middle Name]

■ [Field: Last Name]

■ [Field: Account]

■ [Field: Account Location]

■ [Field: Job Title]

■ [Field: Work Phone #]

■ [Field: Home Phone #]

■ [Field: Cellular Phone #]

■ [Field: Fax Phone #]

■ [Field: Email Address]

■ [Field: Current Date]

■ [Field: Source Code]

For Web offers, surveys, events, and URLs to be available as personalization 
elements within the Web Offers, Web Surveys, Events, and Related URLs categories, 
you must add the records to the Web Offers, Web Surveys Related Events, or Related 
URLs lists. For details, see “Associating Web Offers, Web Surveys, Events, and URLs 
With Offers” on page 289.
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You can copy any field from the Personalization Elements list and paste it into the 
body of the email message. For related information, see “Using Hyperlinks (HREF) 
in an Offer Template” on page 267.

For example you might want to personalize the offer with the contact’s name. For 
example, Exciting Offer for [Field: First Name] [Field: Last Name].

Using the Merge Fields category, you would select the personalization element 
[Field: First Name] and press CTRL+C to copy it. Then, you would paste 
(CTRL+V) the field or fields into the offer template text, or the subject line of the 
email. You would repeat this procedure to add a last name.

Typically, the tags for personalization elements are enclosed in brackets ([ and ]).

During run time, the target values are substituted for these personalization 
elements. The response forms, product links, Web offer links, and Web survey links 
are encoded so that they become URL links containing the destination address, with 
campaign, offer, and recipient codes included. Thus, the URL in any text-based 
email can become long. The following list contains guidelines for setting up 
personalization elements:

■ The Merge Fields list is limited to the contact or prospect business component. 
This list can be extended using Siebel Tools by modifying the user property 
Substitution Field in the Campaign Recipient business component. Additional 
merge fields may be added through configuration.

■ The list of Merge Fields includes a calculated field called Current Date. This 
merge field is replaced by the Campaign Send Date when the campaign is 
launched. 

■ The Product Catalog Items are limited to those defined for the Product catalog 
page for the products associated with the offer.

■ The list of Web offers is limited to those defined for this offer in the Related Web 
Offers list (view tab).

■ The list of Web surveys is limited to those defined for this offer in the Related 
Web Surveys view tab.

■ The list of related events is limited to those events defined for this offer in the 
Related Events view tab. When you add a related event, you will only see events 
with active dates and that have a status code of Executing or In Progress. 
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■ Related URLs allow you to embed hyperlinks to Web pages in an offer. These 
hyperlinks can contain commands such as GetContactId and GetOfferId that 
retrieve data elements and insert them in a related URL. Related URLs must start 
with http://. If the URL does not begin with http://, the Web server address is 
inserted at the start of the URL that you specified.

For example, you can create a related URL that looks like the following:

NOTE: There are no spaces in the following URL. It is typed as one string of 
characters.

http://www.siebel.com/
response.asp?ContactId=[GetContactId]&OfferId=[GetOfferId]&Campa
ignId=[GetCampaignId]

When the offer is rendered, the actual values for Contact ID, Offer ID, and 
Campaign ID are retrieved and substituted into a URL. The destination URL 
(http://www.siebel.com/response.asp) needs to be configured to parse the data 
elements passed and then take action. You perform this task outside of Siebel 
Marketing.

■ Response forms are Web forms that a contact or prospect can use to respond to 
an offer through the Web. The response forms for an email offer are Request 
Unsubscribe, Request More Info, and Request Call Back.
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Working With Email Offers
Email offers are available in Siebel Marketing. For instructions about how to create 
an email offer, see “Creating an Offer” on page 259. For instructions about how to 
modify an email offer, see “Modifying an Offer” on page 263.

For information about working with email offers, see the following topics:

■ About Email Offers

■ Associating a Template With an Email Offer on page 278

■ Adding Attachments to Email Offers on page 279

About Email Offers
Using the Email Offers view, a marketer can design and distribute a personalized 
email offer to target recipients of a campaign. An email offer can be associated with 
a price list for various products. If the recipient clicks on a product link in an email 
offer, the product detail page will show the promotional price for that product rather 
than the list price.

The Email Offers view includes the More Info, Email Templates, Edit Email, Delivery 
Profile, Attachments, Related Web Offers, Related Web Surveys, Related Events, and 
Related URLs view tabs.

■ More Info. This form contains additional fields that you can use if the email offer 
requires approvals from your company’s marketing and legal departments. It 
also provides a unique identifier for the offer in the Offer Code field, and allows 
you to specify the email offer’s Subject Text, the Delivery Profile (driver 
parameters) that will be used to distribute the offer, and the Web server path.

■ Email Templates. This form allows you to attach templates containing the content 
of your email offer. To be selected in this view, templates must first be added to 
the Offer Templates list. For details, see “Creating and Editing Offer Templates” 
on page 265. 

■ Edit Email. This form allows you to edit the template content as well as select 
Personalization Categories. Category elements can be copied and pasted into the 
template.
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■ Delivery Profile. This read-only list provides a list of delivery profiles 
(communications drivers) that are associated with the offer. For more 
information on communications drivers and profiles, see “Using Delivery 
Profiles - Email, eNewsletter, and Fax” on page 294.

■ Attachments. This list allows you to include literature items with your email 
offer. These items are delivered with the email when the campaign is launched.

■ Related Web Offers, Related Web Surveys, Related Events, and Related URLs lists. 
These lists allow you to specify the Web offers, Web surveys, events, and URLs 
that you plan to include as hyperlinks in the email offer. Adding these elements 
allows you to embed them as a Personalization Element. Web Surveys are 
created using Siebel SmartScript. For more information, see Siebel SmartScript 
Administration Guide.

Whenever an offer recipient clicks a Web offer, Web survey, or product link in 
an email offer, the click is captured as a response. The available response types 
are Clicked On Web Offer, Clicked On Web Survey, and Clicked On Product URL.

NOTE: Siebel eEvents views are not currently included in the Siebel eMarketing 
application. Therefore, if you embed a related event in an email or eNewsletter 
offer, related events must be directed to the Web Server on which Siebel eEvents 
is installed. To accomplish this, the Web Server field must contain the location 
of the eMarketing Web Server and the location of the eEvents server. For more 
information see the Web Server field in Table 53 on page 260.

Associating a Template With an Email Offer
This section describes how to associate a template with an email offer. To edit the 
offer template, see “Creating and Editing Offer Templates” on page 265.

To associate an offer template with an email offer 

1 From the application-level menu, choose View > Site Map > Offers > Email 
Offers.

2 In the Email Offers list, select the offer and click the Email Templates view tab.

3 In the Email Templates list, create a new record.
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4 In the Email Templates form, complete the necessary fields.

a The sequence field is automatically populated. Change the sequence if you 
are adding multiple templates with rich and plain format. The sequence field 
includes email attachments. Therefore, when you add your first template, 
you can see a sequence number other than 1.

For example, if you have two templates (one HTML and one text) associated 
with the email offer, adjust the sequence so that you associate the plain 
format (text) first and the rich format (HTML) last. This satisfies the MIME 
Alternate standard. The MIME Alternate standard allows your customers to 
receive the HTML version if their email program supports HTML emails. If 
their email program does not support HTML, the customer will receive the 
text version of the offer.

b In the Template Name field, click the select button.

You can associate one HTML template and one text template to the offer.

c In the Pick Offer Template dialog box, select the template record and click 
OK.

5 Save the record to associate the template with the offer.

Adding Attachments to Email Offers
Use the following procedure to add literature items as email offer attachments. 

To add an attachment

1 From the application-level menu, choose View > Site Map > Offers > Email 
Offers.

2 In the Email Offers list, drill down on the offer name.

3 Click the Attachments view tab.

4 In the Attachments list, create a new record.

5 In the Attachments form, complete the fields.

6 Click the Name select button, select the literature file you want to attach, and 
click OK.
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7 For each file, type an attachments label.
280 Siebel Marketing Guide Version 7.5.3



Creating and Using Offers

Creating and Editing eNewsletter Offers
Creating and Editing eNewsletter Offers
eNewsletter offers are available in Siebel Marketing. Like email offers, eNewsletters 
can contain links to Web offers, Web surveys, related events, and related URLs. In 
addition they can contain personalized elements, such as a salutation. You can 
target specific customers with some sections of the eNewsletter, while other 
sections can be aimed at a more general audience.

Using the eNewsletter Offer and eNewsletter Rules views, you can create an 
eNewsletter that uses rules to determine the content the recipient sees. By applying 
rules-based criteria, you can create eNewsletter offers with sections that are only 
relevant to the campaign offer recipient and other sections that include details of 
interest to the general audience.

The eNewsletter Offer tabbed views allow you to identify links to related Web offers, 
Web surveys, events, and URLs. You can also edit rule-specific sections, identify a 
communications delivery profile, and attach relevant documents to the offer.

The eNewsletter view includes the following view tabs:

■ More Info. This form contains additional fields that you can use if the eNewsletter 
Offer requires approvals from your company’s marketing and legal departments. 
It also provides a unique identifier for the offer in the Offer Code field, and 
allows you to specify the Subject line text, Delivery Profile (communication 
driver parameters) that will be used to distribute the offer, and the Web server 
path.

■ eNewsletter Sections. This list allows you to attach templates containing the 
section content for your eNewsletter. To be selected in this view, templates must 
first be added to the Offer Templates list. For details, see “Creating and Editing 
Offer Templates” on page 265.

■ Edit Sections. This form provides you with the means to edit the content of your 
section templates as well as select Personalization Categories, and copy and 
paste category elements into template content.

■ Attachments. This list allows you to include literature items with your 
eNewsletter offer.
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Because eNewsletters are delivered to target recipients using email, many of the 
procedures that describe how to create email offers are also valid for creation of 
eNewsletter offers. Thus, many of the view tabs such as Delivery Profile, Related 
Web Offers, and Related Web Surveys, use the same creation procedures and have 
the same functionality as in the Email Offers view. 

For more information on creating communications drivers and profiles, see “Using 
Delivery Profiles - Email, eNewsletter, and Fax” on page 294. For information on 
using Web offer and Web survey hyperlinks in the eNewsletter, see “Associating 
Web Offers, Web Surveys, Events, and URLs With Offers” on page 289.

To create and edit eNewsletter Offers, perform the following tasks:

■ Creating eNewsletter Offers

■ Adding eNewsletter Sections on page 283

■ Resequencing eNewsletter Sections on page 284

■ Editing eNewsletter Sections on page 285

■ Developing eNewsletter Rules on page 286

■ Adding Attachments to eNewsletter Offers on page 287

Creating eNewsletter Offers
You create an eNewsletter offer, by performing the steps in “Creating and Modifying 
Offers - Basic Steps” on page 259.

To create an eNewsletter offer

1 From the application-level menu, choose View > Site Map > Offers > 
eNewsletter Offers.

2 In the eNewsletter Offers list, create a new eNewsletter offer, and save the offer. 

For details, see “Creating and Modifying Offers - Basic Steps” on page 259.

3 Drill down on the eNewsletter Offer name hyperlink.

4 In the details form, complete other necessary fields for the eNewsletter offer 
including:
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■ The communications Delivery Profile. For details, see “Using Delivery 
Profiles - Email, eNewsletter, and Fax” on page 294.

■ The Web Server URL for your Siebel Marketing installation. Remember to 
include the Web server for eMarketing and Events when you include links to 
each one.

■ The eNewsletter subject text with merge fields, if appropriate. For details, see 
“Using Personalization Categories” on page 273.

Adding eNewsletter Sections
Before you create your eNewsletter, outline the sections you want to include, 
compose the content of each section and determine the contacts you want to target 
with each section. Use the eNewsletter Rules view to define and implement 
visibility rules for each section of the eNewsletter.

The eNewsletter Sections view lists the sections in the eNewsletter. The inclusion 
of each text or HTML portion of the eNewsletter is based on rules. You apply these 
rules in the eNewsletter Sections form by clicking the select button in the Rules field 
and choosing a predefined rule to apply to the section. The Sequence field shows 
the order that the sections will be presented in the eNewsletter after the rules are 
applied.

NOTE: If you have multiple templates associated with the eNewsletter offer that are 
both HTML and text, adjust the sequence with the plainest template format (text) 
first and the richest format (HTML) last on the list to satisfy the MIME Alternate 
standard. If your customer’s email program supports HTML emails, then they 
receive the HTML version. If it does not support HTML, the customer receives the 
text version of the offer. As long as the sequence of the sections within a type (like 
HTML) is correct, then Siebel Marketing will put the sections together in the right 
order.

To add an eNewsletter section and apply a rule

1 From the application-level menu, choose View > Site Map > Offers > 
eNewsletter Offers.

2 In the eNewsletter Offers list, select the offer.
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3 Click the eNewsletter Sections view tab.

4 In the Sections list, create a new record.

The section form appears, with the sequence automatically set to 1.

5 In the eNewsletter Sections form, complete the fields.

a Type a unique section name and a section description.

The sequence field is automatically populated. If you need to change the 
sequence of the section, type a new value.

b Click the Template Name select button. 

c In the Pick Offer Template dialog box, select a section from the list of 
predefined section templates and click OK.

The File Type field displays whether the template is HTML or text.

d Click the Rule select button.

e In the Pick Rule dialog box, select the rule that controls whether this section 
is sent to an eNewsletter recipient and click OK.

If a description has been defined for the rule, it will appear in the Rule 
Description field.

Repeat the procedure, adding sections one at a time, and clicking save after each 
section has been defined.

Resequencing eNewsletter Sections
If you plan to resequence your eNewsletter sections, remember that you cannot 
assign a section to a sequence position that is already occupied by another section.

For example, if you wish to switch the sequence of sections 1 and 2, you must make 
sure that position 1 in the sequence list is vacant before you assign section 2 to that 
position. 

To resequence eNewsletter sections

1 From the application-level menu, choose View > Site Map > Offers > 
eNewsletter Offers.
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2 In the eNewsletter Offers list, select the offer, and click the eNewsletter Sections 
view tab.

3 In the Sections list, remove or reposition the section occupying the target 
position in the sequential list.

a Select the section record, click the menu button and choose Edit Record.

b Edit the number in the Sequence field, and save the record.

4 Add the new section, editing the Sequence number for the correct position on 
the list.

a Create a new record.

b In the Section form, click the Template Name select button and choose the 
section template.

c In the Sequence field, adjust the number, and complete the other necessary 
fields.

d Save the section record.

Editing eNewsletter Sections
The Edit Section view tab allows you to change the newsletter section template, 
select a personalization category with associated personalization elements, edit the 
template contents, and apply the rule that governs the section’s visibility. 

As with email offers, the list of personalization categories for eNewsletters includes 
Merge Fields, Product Catalog Items, Response Forms, Web Offers, Web Surveys, 
Events, and URLs. The only available type of response form for eNewsletters is 
Unsubscribe.

The Edit Section view includes two controls:

■ Edit Template. Click Edit Template to edit the read-only section template 
displayed in the Edit Section view. This provides the same functionality that the 
corresponding control does in the Edit Email view.

■ Verify & Preview. Click Verify & Preview to test the syntax of the edited template 
and display the actual eNewsletter offer section. This provides the same 
functionality that the corresponding control does in the Edit Email view.
Version 7.5.3 Siebel Marketing Guide 285



Creating and Using Offers

Creating and Editing eNewsletter Offers
For additional information, see “Creating and Editing Offer Templates” on page 265.

Developing eNewsletter Rules
The eNewsletter Rules view allows you to set up rules to determine which 
customers see each section of your eNewsletter. The Rules list displays the rules 
created for any eNewsletter section. Fields displayed include Name and Description. 
The conditions list displays conditions for the rule selected in the Rules list.

To create an eNewsletter rule

1 From the application-level menu, choose View > Site Map > Offers > 
eNewsletter Rules.

2 In the Rules list, create a new record.

3 Complete the fields, typing a name and description for the rule.

To create a condition for an eNewsletter rule

1 From the application-level menu, choose View > Site Map > Offers > 
eNewsletter Rules.

2 In the Rules list, select the rule.

3 In the Conditions list, create a new record.

4 Complete the Conditions fields.

a Type a new value in the Sequence field if you want to modify the sequence 
of the rule.

The Sequence field determines the order in which a condition is evaluated 
for a specific rule. For example, a condition with a sequence of 2 is evaluated 
before a condition with a sequence of 3.

b Click the Field select button.

c In the Business Component Fields dialog box, select a field from the contact 
or prospect list of fields and click OK.
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d Choose a Comparison operator from the list.

Options are =, >, <, <>, LIKE, NOT LIKE, >=, <=. 

An example would be Account Location (business component field) = 
(comparison operator).

e Type the value to be compared, using wildcards if needed. 

For example, CONTACT HOME PHONE NUMBER LIKE 415*. 

f Choose AND or OR from the Next: list to set inclusion or exclusion criteria 
for the next condition evaluation.

For example: 

Condition1: Contact Job Title LIKE *Manager* OR

Condition 2: Contact Job Title LIKE *Vice* OR

Condition 3: Contact Job Title LIKE *CEO*

NOTE: The rules criteria are case sensitive.

5 When you have finished defining a condition, save the record.

NOTE: You should create rules to cover all possible scenarios, including null 
values for the field. During the execution process, if a value is null the recipient 
may receive a blank email.

Adding Attachments to eNewsletter Offers
Use the following procedure to add literature items to your eNewsletter offer. 

To add an attachment

1 From the application-level menu, choose View > Site Map > Offers > 
eNewsletter Offers.

2 In the eNewsletter Offers list, select the offer and click the Attachments view tab.
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3 In the Attachments list, create a new record.

4 In the Attachments form, click the Name select button.

5 In the Pick Literature Item dialog box, select the literature file you want to attach 
to your email offer. 

For each file, type an attachments label.

6 Save the record.
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Associating Web Offers, Web Surveys, Events, and URLs 
With Offers

The ability to associate Web offers, Web surveys, Events, and URLs with offers is 
available in Siebel Marketing and Siebel eMarketing.

Each offer element (Related Events, Web surveys, Web offers, and URLs) can be 
associated with any offer type with one exception. Web offers cannot include links 
to other Web offers. However, you can relate the same Web offer to more than one 
email offer. For example you might have an eService Web Offer and want to 
associate that Web offer with multiple email offers. In this case, each of these email 
offers will have a link to that same web offer.

Use the Related Web Offers, Related Web Surveys, Related Events, and Related URLs 
view tabs to add each offer element to the appropriate offer. After you add an 
element to the list, it is available as a personalization element in the appropriate 
Offer view tab. For example, after you add a Web offer on the Related Web Offers 
view tab, you can navigate to an Edit view and select Web Offers in the 
Personalization Category field. Your newly added Web offer appears in the list of 
elements. 

When the Web site visitor clicks a Web survey link on the Offers or Information 
views, a survey wizard appears that steps the user through a series of questions 
about the product. You can use Web Surveys to capture customer feedback or 
qualify leads. Using the Web Survey designer, you can design a survey once, reuse 
questions and answers across multiple surveys, and deploy the survey on the Web 
and in the Call Center. The hyperlink takes the customer to a predefined Web survey 
page.

NOTE: Web Surveys are created using Siebel SmartScript. For more information, see 
Siebel SmartScript Administration Guide.

The Related Web Surveys list contains a list of Web surveys related to this campaign 
that can be included in Web Offer page as URL hyperlinks. Drill down on the survey 
name in the Related Web Surveys list to display the Smart Script Administration 
screen's Scripts list where you can select and modify the survey.
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The following list contains descriptions of how links to offer elements appear in an 
offer:

■ Web offer link. The following is an example of how a link to a Web offer appears 
in an offer. The hyperlink is the image (banner_midsize.gif). When you click the 
link, the Web offer (Introducing Siebel eService, MidMarket Edition) appears.

<a href="[*Web Offer: Introducing Siebel eService MidMarket 
Edition]"> <img src="banner_midsize.gif" border=0 width="149" 
height="43"> </a>

■ Event link. The following is an example of how a link to an Event appears in an 
offer. The hyperlink is Click Here. When you click Click Here, the specific Event 
appears.

<a href="[*Web Offer: Introducing Siebel eService MidMarket 
Edition]">Click here</a>

■ Web survey link. The following is an example of how a link to a Survey appears 
in an offer. The hyperlink is the image (customer_survey.gif). When you click 
the image, the specific survey appears.

<a href="[*Web Survey: eMarketing-eService Survey]"><img 
src="images/customer_survey.gif" border=0 width="156" 
height="23">

■ URLs link. The following is an example of how a link to a related URL appears in 
an offer. The hyperlink is Click Here. When you click the words Click Here, the 
specific URL appears, showing any specified data elements.

<a href="[*Related URL: Siebel URL]">Click here</a>

■ Products link. The following is an example of how a link to a Product URL 
appears in an offer. The hyperlink is the image (order_now.gif). When you click 
the image, the specific product page appears.

<a href="[*Product: Siebel eService, MME]"><img src="images/
order_now.gif" border=0 width="81" height="23">
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To associate Web offers, Web surveys, Events, and Related URLs with offers

1 From the application-level menu, choose View > Site Map > Offers.

2 In the Show drop-down list, choose the offer type with which you want to 
associate an offer element.

3 In the selected offers list, drill down on the offer name.

4 Click the view tab for the Web offer or offer element that you want to associate 
with the selected offer.

5 In the selected list, create a new record.

NOTE: Related URLs must start with http:// or the Web server address will be 
inserted.

6 In the add dialog box, select the Web offer or offer element and click OK.
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Working With Fax Offers
Fax offers are available in Siebel Marketing and Siebel eMarketing. For instructions 
about how to create a fax offer, see “Creating an Offer” on page 259. For instructions 
about how to modify a fax offer, see “Modifying an Offer” on page 263.

For information about working with fax offers, see the following topics:

■ About Fax Offers

■ Associating a Template With an Fax Offer on page 293

About Fax Offers
Using the Fax Offer view, a marketer can create personalized faxes for targeted 
distribution during a campaign.

The Fax Offer view contains four view tabs.

■ More Info. This form contains additional fields that you can use to specify a 
predefined communications Delivery Profile for fax distribution, an Activity 
check box that may be used to track the offer as an activity, and approval check 
boxes and fields if the fax offer requires approval from your company’s 
marketing and legal departments. The More Info form also displays a unique 
identifier for the offer in the Offer Code field.

■ Edit Fax. This form allows you to choose an offer template and specify the 
personalization elements that are included in your fax design. 

■ Delivery Profile. This read-only list displays parameters of the Siebel 
Communications profile chosen for the fax offer. For more information on setting 
up a delivery profile for a fax offer, see Siebel Communications Server 
Administration Guide. For information on testing and distributing fax 
campaigns, see “Testing Campaign Offers Before Launching a Campaign” on 
page 374.

■ Literature. This list shows the company and product information associated with 
the media offer. You can add additional items to this list if desired. For more 
information, see “Associating Literature with Offers” on page 301.
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Associating a Template With an Fax Offer
This section describes how to associate a template with a fax offer. To edit the 
template, see “Creating and Editing Offer Templates” on page 265.

To associate an offer template with a fax offer

1 From the application-level menu, choose View > Site Map > Offers > Fax 
Offers.

2 In the Fax Offers list, select the fax offer and click the Edit Fax view tab.

3 In the Edit Fax form, create a new record.

4 Click the Template Name select button. 

5 In the Pick Offer Template dialog box, select the predefined template for the fax 
offer and click OK.

Only offer templates that you add to the Offer Templates list will be available for 
selection. For details, see “Creating and Editing Offer Templates” on page 265.

6 Save the record.

The template contents appear on the right side of the view, and Edit Template 
and Verify & Preview buttons are available.
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Using Delivery Profiles - Email, eNewsletter, and Fax
Delivery Profiles are available in Siebel Marketing and Siebel Campaigns. They are 
required for fax, email, and eNewsletter offers. Delivery Profiles are created using 
the Communication Administration screen’s Communications Drivers and Profiles 
view. Email and eNewsletters are sent out using the SMTP/POP3 communications 
driver, and fax offers are distributed using the fax communications driver provided 
with your fax application.

The Internet SMTP/POP3 communications driver, which supports HTML email and 
plain-text email, can be used for both inbound and outbound communications. It 
supports Internet mail servers that use the SMTP protocol for outbound email or the 
POP3 protocol for inbound email (applicable only to Siebel eMail Response).

Siebel Communications Server does not interface directly to fax servers. Most 
popular fax servers provide email system gateways that connect themselves to an 
email system such as Microsoft Exchange Server or an SMTP server. The host email 
system recognizes messages with specially formatted email addresses and directs 
those messages to the fax server.

Siebel Communications Server interfaces indirectly with this type of fax server 
through the host email system. Except for the email address format, it makes no 
difference to Siebel Communications Server whether it is sending an email or a fax.

Before email, eNewsletter, or fax offers can be sent out, you must select one of the 
defined profiles. You select a profile from the Delivery Profile list in the More Info 
form for email, eNewsletter, or fax offers.

You can view parameters and values for the delivery profile by selecting the email, 
eNewsletter, or fax offer, and clicking the Delivery Profile view tab. 

Default parameter values are set for each communications driver within the 
Communication Administration screen’s Communications Drivers and Profiles 
view. You can create customized communications profiles for each of these driver 
types that override the default values for that driver. For example, a profile might 
specify customized From and Reply-To email addresses.

For more information about communications drivers and profiles, see Siebel 
Communications Server Administration Guide.

For information about using delivery profiles, see the following topics: 
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■ Creating a Delivery Profile

■ Associating a Delivery Profile With an Offer on page 296

Creating a Delivery Profile
Use the following procedure to select a communications driver and create a profile 
for email, eNewsletter, and fax offers.

CAUTION: If you want to send out HTML email offers, select a profile based on the 
Internet SMTP/POP3 Server driver. If you select a different driver, the HTML in your 
email may not be coded properly.

To create a delivery profile

1 From the application-level menu, choose View > Site Map > Communications 
Administration > Communications Drivers and Profiles.

2 In the Communications Drivers list, select a driver and click the Profiles view 
tab.

For example, for email and eNewsletter offers, select Internet SMTP/POP3 
Server.

3 In the Profiles list, create a new record.

a In the Name field, type a name for the new profile.

b In the Organization field, accept the default organization, or click the select 
button and select another organization.

c In the Responsibilities field, click the select button, and in the 
Responsibilities list, select the responsibility associated with profile access.

The Responsibilities field is used in conjunction with Siebel eMail Response. 
It does not apply to outbound email campaigns.

4 Save the profile and click the Driver Parameters view tab.

5 Edit the parameters for the profile and save the record.
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Associating a Delivery Profile With an Offer
Use the following procedure to associate a delivery profile with email, eNewsletter 
and fax offers.

To associate a delivery profile with an offer

1 From the application-level menu, choose View > Site Map > Offers > All 
Offers.

2 From the Show drop-down list select Email, eNewsletter or Fax Offer.

3 Select the offer.

4 In the Delivery Profile field, select the delivery profile for the offer.

5 Save the record.
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Working With Phone Offers
Phone offers are available in Siebel Marketing and Siebel Campaigns. For 
instructions about how to create a phone offer, see “Creating an Offer” on page 259. 
For instructions about how to modify a phone offer, see “Modifying an Offer” on 
page 263.

For information about working with phone offers, see the following topics:

■ About Phone Offers

■ Creating Call Guides for Phone Offers

About Phone Offers
The Phone Offers view allows you to define telemarketing offers that will be 
executed using Siebel Call Center or another application. 

The Phone Offers view consists of three view tabs.

■ More Info. This form contains more fields that you can use if the phone offer 
requires approvals from your company’s marketing and legal departments. It 
also provides a unique identifier for the offer in the Offer Code field. 

■ Literature. This list shows the company and product information associated with 
the phone offer. You can add additional items to this list if desired. For more 
information, see “Associating Literature with Offers” on page 301.

■ Call Guide. This text form allows you to add information about your offer. The 
Call Guide note field is visible to call center agents as they launch campaigns.

Creating Call Guides for Phone Offers
A call guide is a read-only note field visible to call center agents as they launch 
campaigns. The information in the Call Guide field is useful to agents as they 
prepare for inbound and outbound telephone calls and when they talk to clients. 
You create the call guide in the Offers screen. 

The Call Guide field is intended to display more detailed information about the 
campaign, answer common questions, and provide offer options. The following 
example shows what a Call Guide field might contain:
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Call Guide example. Through the end of December, we are offering a special bonus 
to our current customers upgrading a Basic service agreement to Premium. For 
$149, we will upgrade your service package as well as provide a coupon book worth 
$1,000 toward the purchase of our Signature brand of products.

If the customer agrees, the call center agent can click the Script button and start the 
call script.

NOTE: A call script is written using Siebel SmartScript. You associate a script with a 
campaign at the campaign plan level. For more information, see “Creating a 
Campaign” on page 342 and “Using SmartScripts” on page 347. For information 
about creating smartscripts, see Siebel SmartScript Administration Guide.

To create a call guide

1 From the application-level menu, choose View > Site Map > Offers > Phone 
Offers.

2 In the Phone Offers list, select the phone offer and click the Call Guide view tab.

3 In the Call Guide text field, type the information you wish to use for the phone 
offer.
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About Direct Mail Offers
Direct mail offers are available in the Siebel Marketing application. For instructions 
about how to create a direct mail offer, see “Creating an Offer” on page 259. For 
instructions about how to modify a direct mail offer, see “Modifying an Offer” on 
page 263.

Using the Direct Mail Offer view, you can associate Literature documents with an 
Offer. Siebel Marketing does not provide a mechanism to print direct mail offers, but 
can pass output lists to vendors for execution.

You can generate output or distribution list of contacts during the marketing 
program execution. The customer information is arranged according to a predefined 
list format and the list can be delivered to the appropriate vendors through a 
predefined method (for example FTP or email). For more information about List 
Output and Vendors, see Chapter 20, “List Management.”

The Direct Mail Offer contains the More Info and Literature view tabs. 

■ More Info. This form contains additional fields that you can use if the Direct Mail 
Offer requires approvals from your company’s marketing and legal departments. 
It also provides a unique identifier for the offer in the Offer Code field.

■ Literature. This list shows the company and product information associated with 
the offer. To add literature to the list, see “Associating Literature with Offers” on 
page 301.
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About Media Offers
Media offers are available in Siebel Marketing and Siebel Campaigns. For 
instructions about how to create a media offer, see “Creating an Offer” on page 259. 
For instructions about how to modify a media offer, see “Modifying an Offer” on 
page 263.

The Media Offers view allows you to define indirect offers. Types of media offers 
available in the standard product are Billboard, Print Ad, Press Release, Radio, TV, 
Seminar and Trade Show. When you define indirect offers, you know the general 
characteristics of your audience but not its exact composition.

The Media Offers view contains the More Info and Literature view tabs. 

■ More Info. This form contains additional fields that you can use if the Media Offer 
requires approvals from your company’s marketing and legal departments. It 
also provides a unique identifier for the offer in the Offer Code field. You can 
specify the type of media you will use to distribute the offer using the Type field.

■ Literature. This shows the company and product information associated with the 
media offer. You can add additional items to this list if desired. For example, if 
the media offer type is press release, you can associate the press release content 
with the offer for later referral. For more information, see “Associating Literature 
with Offers” on page 301.
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Associating Literature with Offers
Literature about the products or services offered during a campaign can be 
associated with a campaign offer using the Literature view tab in the Direct Mail, 
Media, Phone, and Fax Offer views. To add attachments to email offers, see “Adding 
Attachments to Email Offers” on page 279. To add attachments to eNewsletter 
offers, see “Adding Attachments to eNewsletter Offers” on page 287.

You can associate literature items, such as white papers, presentations, brochures, 
advertising material, and product specifications with your offer to create a 
specialized library of information. You can use this library when reviewing details 
of offers that are being reused in current campaigns.

In addition, a call center agent can view the literature while executing the 
campaign. The agent can also include literature items with faxes, email messages, 
or correspondence sent to a contact. Literature items are automatically included 
when you create a new correspondence record for a contact.

Before you can select literature to associate with an offer, you must add the 
literature items to the Literature screen’s All Literature Across Organizations list. For 
more information about adding literature that you can associate with your offers, 
see the chapter about literature in Applications Administration Guide.

Use the following procedure to associate specific literature items with your offers.

To associate a literature item with an offer

1 From the application-level menu, choose View > Site Map > Offers > All 
Offers.

2 From the Show drop-down list, select the appropriate offer type.

3 In the Offers list, select the offer and click the Literature view tab.

4 In the Literature list, create a new record.

5 In the Literature form, click the Name select button. 

6 In the Pick Literature Item dialog box, select the literature and click OK.
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Working With Web Offers
Web offers are available in Siebel Marketing and Siebel eMarketing. The Web Offers 
view allows you to create offers that can be used on your company’s Web pages. 
For instructions about how to create a Web offer, see “Creating an Offer” on 
page 259. To modify a Web offer, see “Modifying an Offer” on page 263.

About Web Offers
Using the Web Offers view tabs, you can specify a template containing content for 
the Web Offer, edit the template and add personalization elements, identify links to 
related Web offers, surveys, related events and related URLs and attach relevant 
product information that can be downloaded by the Web site visitor. 

The Web Offers view includes the following view tabs:

■ More Info. This form contains additional fields that you can use if the Web Offer 
requires approvals from your company’s marketing and legal departments. It 
also provides a unique identifier for the offer in the Offer Code field. 

NOTE: If you select the Inbound Active Flag check box, the Web Offer appears to 
eligible users in the eMarketing home page. The Featured Offers applet checks 
this flag before displaying a Web offer to an eligible contact or prospect.

■ Edit Web Offer. This form allows you to attach templates containing the content 
of the web offer. To be selected here, templates must first be added to the Offer 
Templates list. For details, see “Creating and Editing Offer Templates” on 
page 265.

■ The Edit Templates button allows you to edit the template content, as well 
select personalization categories, and copy and paste category elements into 
the template.

■ The Verify & Preview button verifies the template edits and displays the finished 
Web offer as it will appear on the Web page.
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■ Related Web Surveys, Related Events, and Related URLs. These lists allow you to 
specify Web surveys, related events, and related URLs that you can embed in 
your Web offer, using the Edit Web Offer personalization elements controls. For 
information, see “Associating Web Offers, Web Surveys, Events, and URLs With 
Offers” on page 289.

■ Downloads. This list allows you to provide a list of literature related to the offer 
that is available for download by the Web site visitor.

The following sections detail how to create a basic Web offer:

■ Associating a Template With a Web Offer

■ Adding Attachments to Web Offers - Downloads List

Associating a Template With a Web Offer
This section describes how to associate a template with a Web offer. To edit the offer 
template, see “Creating and Editing Offer Templates” on page 265. Templates must 
first be added to the Offer Templates list to be available for selection in the Edit Web 
Offer view tab. For details, see “Creating and Editing Offer Templates” on page 265.

To associate an offer template with an email offer

1 From the application-level menu, choose View > Site Map > Offers > Web 
Offers.

2 In the Web Offers list, select the offer and click the Edit Web Offer view tab.

3 Click the Template Name select button.

4 In the Pick Offer Template dialog box, select the template and click OK.

To be available for selection, templates must first be added to the Offer 
Templates list. For details, see “Creating an Offer Template and Adding it to the 
Template List” on page 266.

5 Save the record to associate the template with the offer.
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Adding Attachments to Web Offers - Downloads List
The Web Offer Downloads list displays literature and other files that can be 
downloaded in conjunction with the offer. Literature items must be included in the 
literature list to be available for selection in this view.

The Downloads list shows files that can be included in the selected Web offer for 
download. Any literature other than offer templates can be included in an offer as 
a download. 

The fields in this view are shown in Table 54.

Files added here are not automatically available for downloading. In this view, you 
select a set of files that you want to be able to include as downloads from your Web 
offer. These files then appear in the Personalization Elements list of embeddable 
objects in the Edit Web Offer form when you select the Downloads category from 
the Personalization Categories list.

You can select any file from that list and copy it into the template file and that file 
will be available for downloading. These files are displayed in the Embedded Object 
list as [Download:Literature Item Name].

Table 54. Fields in the Web Offer Downloads View

Field Comment

Comments Automatically populated from the literature table.

Description Automatically populated from the literature table.

File Name Automatically populated from the literature table.

File Type Automatically populated with the file extension.

Modified Automatically populated with the file modification date.

Name Click the Name select button to select a literature item.

Release Date Automatically populated with the date that the literature item was 
released.

Size (In Bytes) Automatically populated with the file size in kilobytes. 
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When the Siebel Marketing software encodes this tag, it uses the Literature Item 
Name as the hyperlink text. The marketer can override this default behavior by 
using the wildcard (*) functionality and manually defining the HREF link, as 
described in “Using Hyperlinks (HREF) in an Offer Template” on page 267.
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To attach literature in the Downloads view

1 From the application-level menu, choose View > Site Map > Offers > Web 
Offers.

2 In the Web Offers list, select the offer and click the Downloads view tab.

3 In the Downloads list, select the literature you want to make available for 
downloading from the Web offer.

a Click the menu button and create a new record.

b In the Downloads form, click the Name select button.

c In the Pick Literature Item list, select the item and click OK.
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Siebel eMarketing is an optional Siebel Marketing module that provides you with 
the tools and templates to manage and execute Web-based marketing. It provides 
the Web site visitor a method of viewing a Web offer, downloading literature, and 
using preconfigured Web response forms to request more information or ask you to 
contact them by telephone.

You can modify the look and feel of eMarketing to match your existing Web site. 
Additionally, you can use Siebel Personalization and Real-Time Marketing to 
personalize the offers and content being delivered.

Siebel eMarketing Web sites can be deployed in more than one language. For 
information about deploying Siebel applications in a multilingual environment, see 
Global Deployment Guide.

This chapter contains the following topics:

■ About eMarketing Web Site Visitors on page 308

■ Setting Up Siebel eMarketing on page 311

■ About the Siebel eMarketing Web Site on page 319

■ Using the eMarketing Offers Page on page 320

■ Using the eMarketing Information Page on page 324
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About eMarketing Web Site Visitors
A Web site visitor can navigate to the eMarketing home page by typing the URL or 
by clicking a hyperlink on another Web page. At this point, the user is an 
anonymous visitor and can choose to register, log in (if they have an existing user 
name and password), or continue to navigate anonymously. When the anonymous 
visitor arrives at the eMarketing home page, the default campaign offers and the 
details for the first offer in the Featured Offers list appear. If the visitor registers or 
logs in, the visitor sees other campaign offers for which they are eligible. For more 
information about default offers and default campaigns, see the description of 
featured offers in “Using the eMarketing Offers Page.”

If a contact logs in using the contact’s user ID and password, any responses 
generated by this customer are tagged with the customer’s account ID and with the 
associated campaign ID. For information about setting up users, see “Setting Up 
Default Responsibilities and Users for eMarketing” on page 313.

Web site visitors can also navigate to the eMarketing site by clicking on an 
embedded URL from within an email or eNewsletter offer. Only contacts or 
prospects receive these offers. When an email contact or email prospect clicks an 
embedded URL, the Web Offer page for this offer appears. Any responses to the 
offer from this contact or prospect are tagged with the associated campaign ID and 
offer ID, allowing marketers to track response rates for specific campaigns. For a list 
of responses that are captured, see “Response Management” on page 317.

Visitors access the eMarketing home page in the following ways:

■ Anonymous visitor. Any visitor can type the eMarketing URL into a Web browser 
and navigate to your eMarketing home page. This visitor sees no personalized 
Welcome message and responses are not captured when the visitor clicks a 
Recommended Product link or downloads literature. An anonymous visitor can 
create a product information or call response by clicking on the Send Product 
Information or Request a Call link in the Offers page or Information page. The 
profile information that the anonymous visitor types creates a prospect record 
that is associated with the responses.
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■ Email contact. When a contact clicks an embedded link in an email or 
eNewsletter, your eMarketing home page appears and the Contact Id is set in an 
anonymous session. At this point, the email contact is not logged in. The contact 
must be a registered contact and must log in to access profile information in the 
My Accounts link or to perform any other tasks that require the contact to be a 
registered contact. The email contact can generate responses by clicking a 
Recommended Product link, downloading literature, or requesting product 
information or a telephone call.

In the eMarketing home page, the contact can log in. After logging in, the email 
contact becomes a logged-in contact.

If an email contact clicks the My Accounts link during an anonymous session, 
the User Login (user registration) view appears, requiring the anonymous visitor 
to log in before continuing.
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■ Email prospect. When a prospect clicks an embedded link in an email or 
eNewsletter, your eMarketing home page appears and the Prospect Id is set in 
an anonymous session. At this point, the email prospect is not logged in. The 
prospect must become a registered contact and must log in to access profile 
information in the My Accounts link or to perform any other tasks that require 
the prospect to be a registered contact. The email prospect can generate 
responses by clicking a Recommended Product link, downloading literature, or 
requesting product information or a telephone call.

In the eMarketing home page, the email prospect must register as a new contact 
before the prospect can log in. In the User Login applet, the email prospect can 
type a user ID and password or click the New User link to register as a new 
contact and obtain a user ID and password. 

In the User Login view, the User Login (user registration) view appears, 
requiring the anonymous visitor to log in or to register as a new user before 
continuing. When registration is complete, the prospect is converted to a new 
logged-in contact. However, the original email prospect’s responses are not 
associated with the new contact record. After logging in, the email prospect 
becomes a logged-in contact.

NOTE: If an email prospect clicks the My Accounts link during an anonymous 
session, the User Login (user registration) view appears, requiring the 
anonymous visitor to log in or to register as a new user before continuing.

■ Logged-in contact. This contact has access to the My Account link and can 
perform all other tasks that a registered contact is eligible to perform. The 
logged-in contact can generate responses by clicking a Recommended Product 
link, downloading literature, or by requesting product information or a 
telephone call. These responses are associated with the contact record in the 
database.
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Setting Up Siebel eMarketing
This section describes how to set up Siebel eMarketing. It includes information 
about customizing the user interface, controlling user access, setting up 
responsibilities, and managing default campaigns and offers.

Before Siebel eMarketing can be used, certain setup tasks must be performed. These 
include:

■ Installing eMarketing

■ Controlling User Access to the eMarketing Web Site on page 312

■ Setting Up Default Responsibilities and Users for eMarketing on page 313

■ Setting Up a Default Campaign and Default Offer on page 314

■ Using Siebel Personalization with eMarketing on page 314

■ Customizing the eMarketing User Interface on page 315

Installing eMarketing
Before you install and use eMarketing, you must install the following:

■ Siebel Web Engine and related components. To deploy information on the Web and 
customer applications, you must install the Siebel Web Engine and the 
components on which it depends. These include a Web server, Siebel Gateway 
Server, and Siebel Server. For information about installing Siebel components, 
see the Siebel Server installation guide for the operating system you are using.
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■ Siebel Applications. To perform administrative tasks such as server 
administration, creating Web offers, and managing marketing activities, you 
must install a Siebel employee application such as Siebel eSales and add the 
Siebel eMarketing license key. For information about installing your Siebel 
employee application, see the appropriate administration guide, for example, 
Siebel eSales Administration Guide.

Siebel eMarketing is an add-on module to Siebel Marketing. Siebel eMarketing 
requires the eMarketing Object Manager component, which is part of the 
Marketing Component Group. For information about installing Siebel Marketing, 
see Chapter 2, “Initializing Siebel Marketing” and the Siebel Server installation 
guide for the operating system you are using.

Controlling User Access to the eMarketing Web Site
You might want to perform some of the following tasks to control user access in 
your Siebel eMarketing Web site:

■ Using external authentication using LDAP (Lightweight Directory Access 
Protocol)

LDAP is an Internet protocol that email programs use to look up contact 
information from a server.

■ Creating database users for LDAP to use in database access

■ Defining visibility for views and products

■ Assigning a proxy employee

■ Creating users through registration or user administration

■ Associating users with accounts

■ Allowing various levels of access such as Anonymous, Implicit login, and 
Explicit login

■ Customizing access to home and login pages. For more information, see 
information about the New User link in “Using the eMarketing Offers Page” on 
page 320.

■ Using single-sign on functionality
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■ Allowing another system to log in

■ Adding fields to registration forms

For more information on controlling user access, see Security Guide for Siebel 
eBusiness Applications.

Setting Up Default Responsibilities and Users for eMarketing
Responsibilities control which views the users can see. The views to which a user 
has access determines the links and page tabs that the user sees. For example, if a 
user has a responsibility that does not permit access to the Credit Cards view, no 
Credit Cards link appears in the My Settings view. If no views within a business 
object are visible, the page tab that maps to that business object will not be visible.

The responsibilities predefined for Siebel eMarketing include:

■ Web Anonymous User. Grants view visibility to anonymous users such as 
anonymous visitors, email prospects, and email contacts. For more information 
about these user types, see “About eMarketing Web Site Visitors” on page 308. 
This responsibility allows the user to access views that do not have the 
Requires_Explicit_Login flags set to TRUE in Siebel Tools. For more information, 
see Siebel Tools Reference.

■ Web Registered User. End user of the application in a business-to-consumer 
model such as logged-in contact. For more information about these user types, 
see “About eMarketing Web Site Visitors” on page 308. This user has registered 
and is recognized by the Siebel application either through their login, or because 
the user enters the site by clicking an embedded link in an email or eNewsletter 
offer.

■ Web Corporate User. End user of the application in a business-to-business model. 
A Web corporate user is associated with an account and must be authorized by 
the Web Delegated Customer Administrator to access the site. A Siebel 
Administrator can add new Web corporate users.

For more information about setting up and managing responsibilities, see Security 
Guide for Siebel eBusiness Applications.
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Setting Up a Default Campaign and Default Offer
Assigning a default campaign and offer is part of the eMarketing setup process. An 
offer associated with the default campaign can be designated as the default offer. 

You specify the default campaign and default offer in the Application 
Administration screen in the System Preferences view. To assign a default campaign, 
complete the Default Campaign Source Code field. To assign the default offer, 
complete the Default Offer Code field. 

The default campaign and default offer determine which offers are presented to the 
customer during their eMarketing session. These offers appear in addition to any 
targeted offers such as an embedded link in an email offer.

CAUTION: The default campaign must be a campaign not a campaign plan. If you 
associate the default campaign with the campaign plan, the response records from 
your campaign will not be associated correctly.

For more information about default offers and default campaigns, see the Featured 
Offers topic in “Using the eMarketing Offers Page.”

Using Siebel Personalization with eMarketing
Siebel Personalization allows you to deliver personalized content and offers to a 
customer profile, needs, interests, and history. Personalized content includes 
greeting users by name, presenting them with content targeted to their needs and 
interests, and showing them recommended products and offers based on their 
needs and history. 

Using Siebel Personalization, you can define rules to show and hide content 
dynamically during a user's experience with Siebel eMarketing. Personalization 
deployment rules can depend on data such as user's profile information, date 
ranges, company information, products and services they already purchased or 
reviewed, and specific session information.
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The home page in Siebel eMarketing includes the salutation applet in the upper left 
corner. It typically includes a personal greeting but it can be configured to deliver 
targeted content such as product promotions, announcements, birthday greetings, 
and offer updates. The home page also contains a list of recommended products and 
featured offers, both of which can be personalized based on user-specific 
information. Conditional expressions can be used to hide applets under certain 
conditions.

You manage personalization in the Personalization Administration screen in your 
Siebel Application. For information about administering personalization, see 
Personalization Administration Guide.

Personalizing eMarketing Using Siebel Real-Time Marketing
Siebel Real-Time Marketing can be used to adjust the offers displayed on the 
eMarketing Home Page (Featured Offers applet). For more information, see 
Chapter 8, “Administering Siebel Real-Time Marketing.”

Customizing the eMarketing User Interface
The Siebel product provides a set of Web templates and cascading style sheets (CSS) 
to create the look and feel of a Siebel application. Customers can create their own 
look and feel by modifying corporate logos, colors, and fonts in the style sheets and 
Web templates. When modifying these elements, make sure you save a backup copy 
in case you want to restore the original files.

NOTE: These elements are not automatically upgraded during the upgrade process.

The Siebel Web architecture uses the Siebel Web Engine (SWE) to dynamically 
generate HTML pages. The SWE uses configuration information in the Siebel 
Repository (SRF) and HTML layout information in the Siebel Web Template (SWT) 
to merge data with the template when creating the HTML page.

To customize the eMarketing User Interface, perform the following tasks:

■ Using Web Templates on page 316

■ Implementing eMarketing Without Frames on page 317

■ Full-Text Search on page 317
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■ Response Management on page 317

Using Web Templates
A Web template defines the layout and formatting elements of the user interface 
(UI), such as views, applets, and controls. These UI elements are associated with 
the templates by using Siebel Tools. The associated information is stored in the SRF 
file. For example, you may have a View object with three applets. You associate a 
View Template with the view, and map each applet to a placeholder in that 
template. The advantage of this approach is that the UI objects in the repository are 
not hard-coded in individual templates. As a result, a number of View objects can 
share the same template if they share the same layout. The same process and design 
applies to Applet objects.

The three primary templates types are Container, View and Applet. The final HTML 
pages created by the SWE places the applet in the view and the view in the 
container. Siebel eBusiness Applications provide numerous applet and view 
templates with the product. They can be viewed in Tools, but are edited in an 
external editor. For information about the physical user interface layer, see Siebel 
Tools Reference. 

The following is a list of some modifications that you might want to perform to 
change the look and feel of your Web site:

■ Modifying Views and Applets

■ Modifying Web Templates

■ Changing colors

■ Modifying behavior caused by clicking a button

■ Adding or removing applets

■ Changing controls

■ Making fields in a form appear

For more information about customizing the user interface, see Siebel Tools 
Reference.
316 Siebel Marketing Guide Version 7.5.3



Setting Up and Using eMarketing

Setting Up Siebel eMarketing
Implementing eMarketing Without Frames
Customer and partner applications use HTML frames for compatibility when 
running in browser-based applications. HTML frames allow portions of the browser 
window to scroll independently of the rest of the window. For example, you can 
place the navigation elements in one frame and content in another frame. You can 
scroll the content while the navigation elements remain in a fixed location.

Customer and partner applications can be implemented without using frames. 
Before choosing this method, consider the following limitation. In an unframed 
application, all UI elements exist in the same window. Therefore, the contents list 
may scroll off the page as a user scrolls down. For example, if the user scrolls down 
to review content, the navigation elements might not be visible.

Full-Text Search
Siebel Search for Customers is a subset of the Siebel Search product. It allows users 
to scan database tables and documents for pertinent information. Siebel Search is 
included with every license of a Siebel application. For information about Siebel 
Search and Siebel Search for Customers, see Siebel Search Administration Guide.

Response Management
Siebel eMarketing allows marketers to capture a series of responses during a 
customer interaction. Siebel eMarketing supports automatic capture of the 
following responses:

■ Clicked on Web Offer. Captured when the recipient clicks the embedded link for 
a Web offer in an email or eNewsletter offer.

■ Clicked on Product URL. Captured when the recipient clicks the embedded link 
for the product in an email, eNewsletter or Web offer.

■ Clicked on Web Survey. Captured when the recipient clicks the embedded link 
for the Web survey in an email, eNewsletter or Web offer.

■ Completed Web Survey. Captured when the recipient clicks Finish on the Web 
survey view. The survey answers are captured if the Save Answer field is 
checked for the question on the Smartscript Administration views. For more 
information, see Siebel SmartScript Administration Guide.

■ Downloaded Info/File. Captured when the recipient clicks the embedded link for 
the document that is downloaded in a Web offer.
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■ Requested Unsubscribe. Captured when the recipient submits their subscription 
preference updates after clicking the embedded link in the email or eNewsletter 
offer. In addition to the response, the contact profile is automatically updated.

■ Requested call back. Captured when the recipient submits their request after 
clicking the embedded link in an email or Web offer.

■ Requested more info. Captured when the recipient submits their request after 
clicking the embedded link in an email or Web offer.

■ Submitted Source Code. Captured when a contact or prospect types a source 
code and offer code in the Do you have Another Offer form in the Offers page.

Additional responses and Siebel events can be captured through configuration. For 
more information, see event tracking topics in Siebel Tools Reference.
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The Siebel eMarketing Web site consists of the Offers page, the Information page, 
and their related views. Using the navigation bar, you can manage your personal 
profile by changing preferences in the My Settings view.

Web visitors access the My Settings view by clicking the My Account link in the 
navigation bar of any eMarketing page. The My Settings view has the following 
links that allow users and visitors to manage their personal profiles.

■ Address Book. A list of available addresses for the visitor. A visitor can add, 
delete, and modify their address and the changes automatically update their 
information in the Siebel database.

■ Credit Cards. A list of available credit cards for the visitor. This view is not 
required if you do not implement the Siebel eSales module or if you do not want 
to use credit card management.

■ Subscription Preferences. A series of channel-specific and general communication 
preferences for each visitor. This view could be modified through Siebel Tools to 
include additional subscription preferences, for example by product or area of 
interest. These preferences could then be used to drive marketing activities for 
that visitor. This view appears when a user clicks on the Request Unsubscribe 
embedded URL in an email or eNewsletter and a Response is automatically 
created when the visitor clicks Submit. The individuals preferences are also 
updated automatically in the Siebel database.

■ User Profile. A series of user profile fields, which the user can modify. Once 
again, this view can be extended to display additional profile information.

NOTE: Notification Preferences, Lister Payment and Shipping Terms, and Auction 
Privilege are not used at this time.
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Using the eMarketing Offers Page
The default home page for eMarketing is the Offers page. The center applet of this 
view contains the specific Web offer intended for each Web site visitor. The Offers 
page provides links to other views, including additional offers, product information, 
Web surveys, and account and contact profile information.

The Offers page has the following configurable applets:

■ Salutation. The salutation text that appears depends on the personalization rules 
that are applied for the user that accesses the page. After logging in, registered 
email recipients or Web users see a greeting customized with their name. An 
anonymous Web visitor’s greeting says “Welcome!”. You can change the 
salutation greeting text in the Personalization Administration views.

NOTE: When eMarketing is deployed as part of the eCustomer application (a 
bundle of eSales, eService and eMarketing), the user can see the Offers page 
(eMarketing home page) and the eCustomer home page. Because the eCustomer 
home page has a salutation greeting, the salutation greeting is suppressed in the 
Offers page (eMarketing home page).

■ The New User Link. You can set up the New User link that appears in the User 
Login applet to allow a Web site visitor to create a user ID and password for 
limited access to your eMarketing Web site. When a visitor clicks New User on 
the eMarketing home page, the registration views appear, allowing the visitor to 
complete their profile. The process is managed by a workflow business process 
that you can modify in Siebel Business Process Designer. For more information, 
see Siebel Business Process Designer Administration Guide.

NOTE: If a prospect registers, the prospect is automatically converted to a contact. 
After becoming a contact, responses captured for the prospect are not associated 
with the new contact record. For more information, see Security Guide for Siebel 
eBusiness Applications.

■ Web Offer. The center applet of the Offers page displays Web offer details. The 
applet contains the contents of the Web offer presented to the visitor. The Offer 
that appears is determined in the following ways:
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■ The offer details are based on the Web-offer link that the visitor selects in an 
email.

■ The offer details are based on how Siebel Personalization or Real-Time 
Marketing sort the offers in the Featured Offers applet. Details for the top 
offer in the Featured Offers applet are automatically presented in the center 
applet.

NOTE: The Featured Offers area will be empty if no featured offers exist.

■ Recommended Products. This applet contains a list of recommended products, 
customized for each user based on that user’s Web profile attributes. This list 
can be modified using the Personalization Administration views. Unidentified 
users will see a default listing.

■ Featured Offers. This applet displays every Web offer for which the contact or 
prospect is eligible. When a visitor logs onto a Web site and clicks the Request 
More Information or Request Call Back link, the response is captured for the 
default campaign and offer. 

Web-offer types include the following:

■ Web offers associated with the default campaign. When you specify a default 
campaign, the offers associated with that campaign appear in the Featured 
Offers list. The default campaign does not need to be loaded with campaign 
contacts and prospects. However, the campaign and associated Web offers 
must have active dates and the Inbound Active flag must be checked. For 
more information about selecting a default campaign, see 
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■ Web offers associated with other active campaigns. These have been loaded 
with contacts and prospects. The offers must have active dates and the 
Inbound Active flag must be checked. Only those contacts and prospects will 
see these Web offers in the Featured Offers applet.

For more information about setting the default campaign or default offer, see 
“Setting Up a Default Campaign and Default Offer” on page 314.

NOTE: You can control what appears in the Featured Offers applet using Siebel 
Real-Time Marketing rules. For additional information, see “Sorting and Filtering 
By Scores Using Decision Broker” on page 221.

■ Information. This applet contains hyperlinks to the following applets in the 
Information page: 

■ Downloads.

■ Send Product Information.

■ Request a Call.

For more information about these applets, see “Using the eMarketing 
Information Page” on page 324.

■ Do you have another offer? After the user types the offer code and source code in 
these required fields and then clicks OK, that Web offer appears and a response 
is automatically created.

Using eMarketing Views and Additional Unstructured Content
For information about eMarketing views and content that the visitor might use, see 
the following topics:

■ Using the eMarketing Product Detail View on page 323

■ Using the eMarketing Web Survey View on page 323

■ Adding Unstructured Content on page 323
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Using the eMarketing Product Detail View
When a visitor responds to an offer (email, Web, or eNewsletter) by clicking an 
embedded product URL, a page with product details appears for that offer. This 
view displays details and incentive pricing for the selected offer. The price list 
associated with the offer determines the price shown in this view. The person who 
created the offer is responsible for associating the products and the correct price list 
with the offer. This combination determines the products that can be embedded in 
the offers and the price that appears. For more information about price list 
administration, see Pricing Administration Guide.

Additionally, this view contains the Related Items applet, showing products that 
might be of interest to the Web visitor. Items in the Related Items list are based on 
previous purchases or literature requests.

In addition to viewing details, the Web visitor using Siebel eCustomer may purchase 
the product from this view by clicking Add Item. After adding the product, the 
selected item appears in the Last Item Added applet.

NOTE: Checkout functionality exists only if the customer has purchased Siebel 
eCustomer. If you are not using eCustomer, the Add Item button is unavailable.

Using the eMarketing Web Survey View
When the Web site visitor clicks an embedded URL for a Web survey in an email, 
eNewsletter, or Web offer, a survey wizard appears that navigates the user through 
a series of questions about the product. Survey results can be automatically stored 
and then analyzed and used for future marketing activities. Web surveys are 
administered using Siebel Smartscripts. For more information, see Siebel 
SmartScript Administration Guide.

Adding Unstructured Content
Siebel eMarketing has the ability to display general external and unstructured 
content in the eMarketing site using the Microsite Management module. For more 
information, see Applications Administration Guide.
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Using the eMarketing Information Page
The Information page allows Web site visitors to download product information and 
request more information. The visitor can reach this page clicking the Information 
page tab. The Information page contains the following applets:

■ Downloads. Clicking a hyperlink opens the literature using the default viewer for 
that type of literature. The visitor can sort this list or search for any specific 
literature item by name, description, type, or date.

■ Request More Information. Allows visitors to request product information (Send 
Product Information) and request a telephone call (Request a Call) using 
response forms. For more information about this applet, see the following topics:

■ Using the eMarketing Send Product Information View

■ Using the eMarketing Request a Call View on page 325

Using the eMarketing Send Product Information View
The Send Product Information view displays a form that Web site visitors can 
complete to request that product information be sent to them.

This view can be accessed from the Offers and Information pages or as an 
embedded URL link in an email offer or a Web offer. The Available Products area 
lists products for which additional information is available. This is determined by 
Catalog visibility. For additional information, see Product Administration Guide.

When the Request More Info or Request Call Back views are accessed using an 
offer’s embedded URL, the list of products is restricted to the products associated 
with the offer. The user can browse the list, selecting products of interest, and then 
move the items to the Selected Products list by clicking Add.
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A visitor can request information about the one or more items in the Selected 
Products list by selecting the check boxes. To clear an item from the list, choose a 
Selected Product item, and then click Remove. After the Web site visitor chooses the 
products for which he or she wants more information, the visitor clicks Continue to 
move to the delivery form. In the delivery form, the Web site visitor can choose 
direct mail, email, fax, or phone as the delivery method, and then fill in the 
necessary information for the delivery method. When the visitor clicks Submit, the 
Confirmation view appears listing the products for which the visitor requested 
information and the delivery information. This information is stored as a response 
of the type Requested More Info.

Using the eMarketing Request a Call View
The Request a Call view allows the Web site visitor to request a callback about one 
or more products. This view can be accessed from the Offers or Information pages 
or as an embedded URL in an email offer or a Web offer. When accessed from an 
email or Web offer, the products available are limited to those products associated 
with the offer. When accessed from the Offers or Information pages, the products 
are limited by Catalog visibility.

Requests for a telephone call are initiated in the same way as requests for product 
information, using Available and Selected product lists. After the visitor chooses the 
products that he or she wants to discuss in a callback, the visitor clicks Continue to 
move to the Request Call form. There the visitor provides a phone number, the time 
of day to call, and adds comments. When the visitor clicks Submit, a Confirmation 
appears containing a list of products for which the visitor requested a callback and 
a list of call preferences. This information is stored as a response of the type 
Requested Call Back.
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The Siebel Campaigns module is available to users with a license for Siebel 
Marketing or Siebel Campaigns. 

A campaign plan is a planning template that includes many of the details typically 
associated with a campaign, such as offers, lists, and team members. Typically, 
campaign plans are used by marketing professionals and are specific to the Siebel 
Marketing application.

A campaign is the vehicle or project in which you convey a marketing message to 
one or more groups of people. Typically, campaigns deliver a promotional offer to 
retain current customers or to acquire new customers across channels of 
communication. For example, you might launch a phone campaign that invites 
contacts to sign up for a special promotion, such as a visit to a resort, or deliver a 
direct mail campaign that provides a sample of a new product and a coupon offer 
to existing customers. You might also set up a recurring loyalty campaign that sends 
a monthly eNewsletter to your customers containing special deals on your products 
or services. 

The goal of a marketing campaign is to create an opportunity that ultimately results 
in a sale or brand recognition. Marketers use both direct and indirect campaigns to 
achieve these objectives. 

■ Direct campaigns target individuals using multichannel approaches—direct 
mail, email, telephone, fax, eNewsletter, or the Web. Contacts for the campaign 
are derived by applying segmentation criteria against a database of customer 
information and generating a list or by purchasing or renting a list of prospects. 
Multiple campaigns can use the same segment criteria.
Version 7.5.3 Siebel Marketing Guide 327



Campaign Plans and Campaigns
■ Indirect campaigns target indeterminate groups of people whose general 
characteristics you may know, but whose exact composition you do not know. 
Examples of indirect campaigns are those that use television, radio, print ads or 
other forms of media for delivery of the message. An indirect campaign is 
associated with a marketing program’s stage rather than with a specific segment 
or list.

For more information about using campaign plans and campaigns in a specific 
product, see “About Campaign Plans and Campaigns in Siebel Marketing” on 
page 329 and “About Campaigns in Siebel Campaigns” on page 330, and 
Chapter 11, “Setting Up and Using eMarketing”.

This chapter contains the following topics:

■ About Campaign Plans and Campaigns in Siebel Marketing on page 329

■ About Campaigns in Siebel Campaigns on page 330

■ Setting Up Campaign Plans in Siebel Marketing on page 331

■ Preparing a Campaign on page 340

■ Setting Up a Campaign on page 342

■ Working With Campaign Contacts and Prospects on page 350

■ Working With Campaign Teams and Groups on page 356

■ Setting Up Campaign Execution Options on page 359

■ Setting Up Campaign Quotas on page 362

■ Setting Up Campaign Assignment Skills on page 368

■ About Testing Campaigns and Offers on page 373

■ Launching Email and Fax Campaigns on page 376

■ Using Response Management on page 377

■ Using Campaign Explorer on page 387

■ Viewing Campaign Charts in Siebel Campaigns on page 388

■ Viewing Response Charts in Siebel Campaigns on page 395
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About Campaign Plans and Campaigns in Siebel 
Marketing

When a campaign plan is launched in the Siebel Marketing application, a campaign 
based on that campaign plan is created. If the campaign plan is launched multiple 
times, multiple campaigns are created and linked to the same campaign plan. Also, 
when the campaign is created from the plan, many of the associated entities such 
as offers, team members and organizations are automatically associated with the 
new campaign. Therefore, a campaign plan is a campaign template that can be 
applied any number of times within a program.

Campaigns are used by a more broad audience because they contain the 
information to manage active, day-to-day campaigns. For example, campaigns are 
accessible to users in other applications including Call Center, Field Sales, and the 
Partner Portal. Often, the users of these applications, only have visibility into the 
specific campaigns and offers to which they have been assigned, and do not interact 
with the program plans and campaign plans that were designed by the Marketers 
and originally launched each campaign. For more information, see “About 
Campaigns in Siebel Campaigns” on page 330.

In the Marketing application, the campaign creation process begins when you create 
a campaign plan. After you create the campaign plan, you can associate it with a 
program plan and add more detailed planning information. The administrator and 
other team members can associate any required information with the campaign 
plan, such as offers, call scripts, literature, lists, or related documents. The 
campaign plan team can also make sure that the correct team members, 
organizations, and partners are associated with the plan.

When the program plan starts and a campaign plan loads, a campaign is created 
using the associated information (offers, team members, partners, organizations, 
and so on) set up in the campaign plan. This campaign can be reviewed by other 
users that will participate in the campaign launch such as sales or call center 
managers.
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About Campaigns in Siebel Campaigns
Campaigns in the Siebel Campaigns module represent the day-to-day activities of a 
campaign. They are the same as the campaigns that result from a campaign plan in 
the marketing application. Campaigns contain contacts and prospects, offers, 
activities and other campaign execution elements.

Using Siebel Campaigns you can distribute your company’s offer using television, 
radio, billboards, direct mail, fax, and phone.

The campaign creation process begins with an administrator, who creates the offers 
and associates the offers with a campaign. The administrator then adds the 
literature, contacts and prospects, call summary, and call guide. The administrator 
also determines which script, if any, is associated with the campaign and who is on 
the campaign team. A campaign manager might associate quotas and incentive 
awards with the campaign to track progress and reward performance.

The administrator can monitor the status of campaigns using the Campaign 
Explorer view to see the subcampaigns, Contacts, Activities, and Offers Literature 
for each campaign, and by using Campaign and Response Charts.
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Setting Up Campaign Plans in Siebel Marketing
In Siebel Marketing, to launch a campaign, you must create a campaign plan and 
associate it with a program plan. A campaign plan is a template that contains details 
such as offers, team members, organizations, and documents. When you add 
organizations to a campaign plan, those organizations are copied to the campaign 
when it is created. If a lead partner is associated with the campaign plan, that lead 
partner will also be copied to the campaign. Team members associated with 
campaign plans are also automatically copied to the campaign when it is created.

When you launch a campaign plan, most of the planning elements are 
automatically copied to (inherited by) the campaign, including offers, waves, and 
forecast inputs.

NOTE: You can turn off the teams and organizations inheritance features in Siebel 
Tools. In the appropriate business component, change the User Prop value for the 
Copy Teams and Copy Organizations property from Y to N. For more information, 
see Siebel Tools Reference. 

Campaign plans are available only in Siebel Marketing. To set up a campaign plan 
in Siebel Marketing, you need to perform the following tasks:

■ Creating a Campaign Plan

■ Associating Offers With a Campaign Plan on page 335

■ Assigning a Team to a Campaign Plan on page 336

■ Setting Up Execution Options for a Campaign Plan on page 337
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Creating a Campaign Plan
Use this procedure to create a campaign plan in the Campaigns screen.

To create a campaign plan

1 From the application-level menu, choose View > Site Map > Campaigns > My 
Campaign Plans.

2 In the My Campaign Plans list, create a new record.

3 Complete the necessary fields for the campaign plan record, using Table 55 as a 
guide.

Table 55. Fields for Campaign Plans

Field Comments

Execution 
Period

Click the Period select button. In the Pick Period dialog box, choose 
the predefined time period during which the campaign will be active.

Lead Partner Choose a partner organization to associate with the selected record. 
If a lead partner was assigned at the program plan level and the 
campaign plan associated with that program plan does not have a 
lead partner, the campaign plan inherits the lead partner from the 
program plan. 

You can change the value, selecting from any of the partners 
associated with a campaign plan or campaign. This lead partner will 
be copied to any campaigns created from this campaign plan and to 
response or opportunities that result from this campaign.

Name Type a name for the campaign. 

The uniqueness of a campaign is based on its source code. You can 
have two campaigns with the same name but the source codes for 
each campaign must be unique.

Objective Type a description of the campaign’s objective.

Organization Click the Organization select button and select the predefined 
organization that is responsible for the campaign plan. You can 
choose more than one organization.

You can also associate Partner Organizations with the campaign 
plan. Partner organizations are created and administered through 
Partner Administration. For more information, see Siebel Partner 
Relationship Management Administration Guide.
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Creating a Campaign Plan in the Program Explorer
To create a campaign plan in the Program Explorer, navigate to the Program 
Explorer. Expand the node of the program plan and stage in which you plan to use 
the campaign plan. In the Campaign Plans list, create a new record and complete 
the required fields.

Program Plan This field is automatically completed when the campaign is 
associated with a specific marketing program.

Region Choose from the list the region in which the campaign will be active.

Source Code Automatically added. To change the value, type a source code for the 
campaign, or use the default record ID for the code. 

The source code for this campaign is available for use as part of the 
source code format for the program. The value must be unique.

Stage Plan This field is automatically populated with stage information when 
the campaign is associated with a specific program plan’s stage.

Start/End For a campaign plan in Siebel Marketing and a campaign in Siebel 
Campaigns, the start and end dates default to the day and time you 
create the campaign. For campaigns in Siebel Marketing, the Start 
field is based on the date and time the campaign is loaded and the 
End field is inherited from the Campaign Plan.

These dates do not affect launching campaigns. A campaign will 
launch even if the end date has passed.

Status By default, campaign status is Planned (start and end dates in the 
future). Status values may be changed at any time. During automatic 
program execution, the status automatically changes to active when 
a campaign is loaded, and at the conclusion of the program, the 
campaign’s status automatically changes to completed. If the 
program is executed manually, status does not automatically change. 

To change the status, use the status drop-down list to choose Active 
(start date in the past and end date in future) or Completed (start and 
end date in the past).

Type Choose from the list the type of campaign you are creating. Options 
include Acquire, Retain, Win-Back, Cross-Sell, and Up-Sell.

Table 55. Fields for Campaign Plans

Field Comments
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Creating a Campaign Plan in the Program Flow
To create a campaign plan in the Program Flow, navigate to the Program Flow view 
tab. Select the program stage with which you want to associate the campaign plan. 
Drag the campaign plan icon from the palette into the workspace. In the dialog box, 
click New and complete the required fields.

Associating Other Entities With a Campaign Plan
Table 56 contains descriptions of many entities that can be associated with a 
campaign plan.

Table 56. Entities That Can Be Associated With a Campaign Plan

Entity Description

Activities Team members can create and assign activities related to the 
Campaign Plan.

Activity Plans Templates of activities can be associated with a Campaign Plan.   
For more information, see “Creating and Using Activity Plans” on 
page 449.

Documents Any team member can associate documents as attachments to the 
Campaign Plan.

Execution Options The campaign plan execution options specify the default values 
for these settings each time the campaign plan is loaded.

Forecasts Each Campaign Plan can have a Forecast that predicts the 
financial performance of the Plan. The actual results versus the 
Forecast can be tracked for each Campaign. For more information 
on developing Campaign Forecasts, see “Forecasting for 
Campaigns” on page 438.

Lead Partner Anytime a Campaign Plan is loaded, the Lead Partner is 
automatically added to the associated Campaign.

Offers Each time the Campaign Plan is loaded or launched the associated 
offers will be copied to the campaign.

Organizations These are the organizations that will have visibility to the 
Campaign Plan under All Campaign Plans. When the Campaign 
Plan is loaded, each organization is automatically included on the 
associated Campaign.
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Associating Offers With a Campaign Plan
Before you implement a marketing program, you should associate one or more 
offers with the campaign plan, depending on your marketing strategy. Offers 
associated with the campaign plan can be viewed by choosing a campaign plan in 
the list, and clicking the Offers view tab. In this view the form displays details of 
the selected campaign. The Offers list provides information about each offer, 
including the name and description, the offer type, the source code assigned to this 
particular offer, and any associated product and price list.

When the campaign plan is loaded, a campaign record is created, and valid offers 
are copied to the campaign. Any views showing the offers for each Campaign have 
built-in visibility to prevent invalid offers from appearing to end users. A valid offer 
is defined as an offer with a current date that falls between its defined activation 
and expiration dates. If activation and expiration dates are not defined for the offer, 
the offer is valid by default. To edit the details of the offer, drill down on the offer 
Name hyperlink.

To associate offers with a campaign plan

1 From the application-level menu, choose View > Site Map > Campaigns > My 
Campaign Plans.

2 In the Campaign Plans list, select a campaign plan.

3 Click the Offers view tab.

4 In the Offers list, create a new record.

Team Members These are the employee positions that have visibility to the 
Campaign Plan under the My Campaign Plans option. When the 
Campaign Plan is loaded, each team member is automatically 
included on the associated Campaign.

Waves and 
Distribution Lists

For more information, see Chapter 18, “Specifying Waves and 
Vendor-Specific Lists.”

Table 56. Entities That Can Be Associated With a Campaign Plan

Entity Description
Version 7.5.3 Siebel Marketing Guide 335



Campaign Plans and Campaigns

Setting Up Campaign Plans in Siebel Marketing
5 In the Add Offer dialog box, select a predefined offer and click OK.

NOTE: Campaign Plan offers are copied to the Campaign each time the Campaign is 
loaded and when it is launched.

Assigning a Team to a Campaign Plan
Campaign Plan teams are set up by assigning individual employees to a team that 
is associated with the campaign plan. Each employee position on the campaign 
team has access to the campaign plan in the Campaigns screen’s My Campaign 
Plans list.

If you are working with partners in developing the Campaign Plan, you can also 
include a partner as a team member by adding that partner’s position. The partner 
might then view the campaign plan within the Partner Portal under Site Map > 
Campaign Planning > My Campaign Plans.

To assign a team to a campaign plan

1 From the application-level menu, choose View > Site Map > Campaigns > My 
Campaign Plans.

2 In the Campaign Plans list, select the campaign and click the Team view tab. 

The creator of the campaign is automatically assigned as the primary member 
of the Campaign Team. This position may be removed from the team only after 
you select a different member of the team to be the Primary.

3 In the Team list, create a new record.

4 Select employees from the Add Employees list and click OK.

To select multiple consecutive employees, hold down SHIFT as you select each 
name. To select multiple nonconsecutive employees, hold down CTRL as you 
select names.
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5 Click the Primary field to select the primary team member. 

The default primary team member is the position that created the campaign.

NOTE: When you load the campaign plan, the team members from the plan are 
automatically copied to the associated campaign.

Setting Up Execution Options for a Campaign Plan
You can select the default options for each campaign when you set up the campaign 
plan. The default execution options control the assignment of campaign contacts 
and editing privileges for the campaign contact list. You can specify the default 
settings for assigning campaign contacts and editing privileges in the contact list. 
When you load the campaign plan, these settings will default on the associated 
campaign.

For more information about execution options, see “Setting Up Campaign Execution 
Options” on page 359. 

To set execution options for the campaign plan

1 From the application menu, choose Site Map > Campaigns > My Campaign 
Plans.

2 In the Campaign Plans list, select a campaign plan.
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3 Click the Execution Options view tab and complete the fields using the 
information in Table 57 as a guide.

NOTE: After the campaign plan is loaded, you can modify the execution options for 
the associated campaign at any time.

Table 57. Execution Option Fields

Field Action

Assignment Rule 
Group

Required if you select Yes - Assignment Manager in the Campaign 
Contact Ownership field. Use if you want Assignment Manager 
to assign the organization owner and position owner to contacts 
in the campaign. Select a rule group to apply to contacts in the 
campaign.

Campaign Contact 
Ownership

Default is No. Values are:

■ No. You do not want to assign ownership. When you select 
this option, the Organization Owner and Position Owner 
fields are locked on the campaign contacts and prospect 
records.

■ Yes - Manually. When you select this option, you can 
manually assign organization and position owners on the 
campaign contacts and prospect records.

■ Yes - Assignment Manager. You want Assignment Manager 
to assign ownership based on Assignment Manager rule 
groups. If none of the rules apply, the default organization 
and position owners set in Siebel Tools will be applied. That 
is why it is very important that you create rules to cover all of 
your contacts and prospects. For additional information, see 
the description for Default Organization Owner in this table.
When you select this option, the Organization Owner and 
Position Owner fields are locked on the campaign contacts 
and prospect records.
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Default Organization 
Owner

Optional. Shows only organizations associated with the 
campaign plan or campaign. When the campaign is loaded and 
the Campaign Contact Ownership value is Yes, Manually, these 
default values are automatically populated into the Default 
Organization Owner and Default Position Owner fields.

When the campaign is loaded and the Campaign Contact 
Ownership value is Yes, Assignment Manager, the default values 
set in Siebel Tools are used by Assignment Manager. For more 
information, see Siebel Assignment Manager Administration 
Guide.

Default Position 
Owner

Optional. Shows only positions related to the selected 
Organization Owner. If you use Assignment Manager to assign 
ownership, you should complete this field so that a default value 
will be available for Assignment manager to use.

Enable Contact Editing Default is on (True). Clear the check box if you want to prevent 
any one from changing the owner fields and adding and deleting 
contacts. This flag controls the ability to edit the following fields 
on the campaign contact or prospect record:

■ Done Flag

■ Contact Last Name

■ Prospect Last Name

■ Organization Owner

■ Position Owner

In addition, when this value is True, the New and Delete buttons 
are available.

Enable Partner Editing 
of Contacts

Default is on (True). Clear the check box if you want to prevent 
partners from editing the fields and using the buttons controlled 
by the Enable Contact Editing check box.

Table 57. Execution Option Fields

Field Action
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You use campaigns in Siebel Marketing and Siebel Campaigns. Prior to creating or 
modifying a campaign, you need to perform some or all of the following tasks:

■ Import or create lists. Import lists or create lists of campaign contacts, prospects, 
or existing customers you need for the campaign. For details, see Importing and 
Managing External Lists on page 493 and Creating and Managing Internal 
Lists on page 508.

■ Associate lists with a campaign. Associating a List of Prospects or Contacts With 
a Campaign on page 351.

■ Select the contacts and prospects. Add the names of contacts and prospects you 
will be targeting with the campaign. For details, see Adding Contacts and 
Prospects to a Campaign Individually on page 353.

■ Determine campaign activities and milestones. Create activity plans with associated 
activities for your campaigns. For details, see the chapter about activities in 
Applications Administration Guide.

■ Set up campaign groups and teams. Specify group or team members to launch the 
campaign. For details, see Working With Campaign Teams and Groups on 
page 356.

■ Establish employee skills. Determine what employee skills are needed to launch 
the campaign. Setting Up Campaign Assignment Skills on page 368.

■ Develop quotas. Set up quota plans for campaign team members to meet and 
determine incentives or rewards for those who meet their quotas. For details, see 
Setting Up Campaign Quotas on page 362.

■ Define the Segments. For more information, see Chapter 9, “Defining Filter and 
Segment Criteria.”

■ Set up campaign execution options. For more information, see Setting Up 
Campaign Execution Options on page 359.

■ Define the offers. Create the offer that your customers will receive, and associate 
the offers with campaigns. For details, see Chapter 10, “Creating and Using 
Offers.”
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■ Create a SmartScript. This SmartScript will guide agents through a campaign call. 
For details, see Using SmartScripts on page 347.

■ Prepare literature items. Prepare any literature items associated with the 
campaign. For details, see the chapter about literature in Applications 
Administration Guide.
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You can set up campaigns by performing the following tasks:

■ Creating a Campaign. Used in Siebel Marketing and Siebel Campaigns.

■ Associating an Offer with a Campaign on page 348. Used in Siebel Marketing 
and Siebel Campaigns.

■ Setting Up a Subcampaign in Siebel Campaigns on page 348. Used only in Siebel 
Campaigns.

Creating a Campaign
Use this procedure to create a campaign.

To create a new campaign

1 Use the step in the following list that applies to your product:

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > All Campaigns Across Organizations.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > All Campaigns Across Organizations.

2 In the Campaigns list, add a new record.
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3 In the Campaigns form, complete the fields.

Some fields are described in Table 58. To view all fields, in the Campaigns form, 
click the Show more button.

Table 58. Selected Campaign Fields

Field Comment

Adjusted Cost Click in the field and use the calculator controls to type an 
adjusted cost, if the total calculated cost is shared with other 
organizations.

DBM This read-only field displays a check mark for TRUE if the 
campaign was created in Siebel Marketing. This field is not 
selected if the campaign was created using Siebel Campaigns.

Division Select the internal division responsible for the campaign.

DNIS Type the telephone number associated with the campaign. This 
number must be set up separately in Siebel CTI (Computer 
Telephony Integration).

The DNIS field for a campaign is used in CTI to query for this 
campaign and drive a screen pop to this campaign. See Siebel 
Communications Server Administration Guide for more 
information.

Type only numerals in this field. Do not use hyphens, spaces, 
parentheses, periods, or any characters other than numbers.

End The default is the current date and time. Click in the field and use 
the calendar controls to select the campaign’s end date. 

The start and end dates drive which campaigns are visible to the 
agents in the My Campaigns View. 

Start date must be less than or equal to today and end date must 
be greater than or equal to today. 

Language From the drop-down list, select the language in which the call 
script was created and click in the field you wish to complete next.

If no language is specified, the selected SmartScript runs in the 
default language for the application. If the script does not have a 
translation for the language selected, you will get an error when 
trying to run the script.
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Lead Partner Select from the partner organizations associated with the 
campaign. The lead partner will automatically be copied to the 
responses and opportunities associated with this Campaign. This 
field allows you to track partner participation in marketing efforts.

Lock Assignment Select the Lock Assignment check box if the campaign team 
cannot be changed by the Territory Assignment Manager.

Name (Required) Type a campaign name.

Objective Type a description of the campaign objective—for example, “To 
increase sales by 10%.”

Organization You can associate internal and external (partner) organizations. 
When you add a campaign to a program, it inherits the 
organizations associated with the program.

Parent Campaign If the campaign is a subcampaign, identify the parent campaign.

Period Select the predefined period that the campaign will be active. The 
Start and End Dates reflect the period selected.

Purpose Type the purpose of a campaign—for example, “To cross sell 
products to existing customers.”

Region Select the region of the country that the campaign targets. Options 
in the standard product are North, South, East, or West.

Table 58. Selected Campaign Fields

Field Comment
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Response Type (Required) Select either Opportunity or Response from the drop-
down list. The default value for this field is Opportunity. The 
value in this field affects which fields are enabled during a 
customer interaction.

■ Select Opportunity if your campaign targets contacts or 
prospects who have already expressed interest in your 
offerings. This choice allows you to use the Create 
Opportunity menu option to promote the response to an 
opportunity based on the customer’s interest. Only one 
opportunity may be created for a campaign contact or 
prospect.

If you have defined the response type of your campaign as 
Opportunity, and if the person who responded is a prospect, the 
prospect will be promoted to a contact when you select the 
prospect in the campaign Overview list and click Create 
Opportunity.

■ Select Response if your campaign targets prospects that have 
not been qualified. This choice enables the Create Response 
and View Response buttons. Once a response is created, it can 
be promoted to an opportunity from the Response view. 
Because an agent may contact a prospect multiple times, this 
activity can generate multiple responses for a Campaign 
Contact or Prospect.

Route Contacts Select this check box if you want to dispatch campaign contact 
records to mobile users defined as members of the campaign team 
or group.

By default, routing rules for campaign contacts are not included 
in the application. If your company wishes to route campaign 
contacts to mobile users, please contact Siebel Professional 
Services. 

Route Prospects Select this check box if you want to dispatch campaign prospect 
records to mobile users defined as members of the campaign team 
or group.

Table 58. Selected Campaign Fields

Field Comment
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SmartScript Select a call script, if needed, to guide the agent’s interaction with 
the customer. To appear in the list, scripts must be set up in 
advance using Siebel SmartScript. For instructions, see Siebel 
SmartScript Administration Guide.

The call script starts when an agent clicks the Script button in the 
Campaign Contacts or Prospects view.

You can use the Call Guide as an alternative to a SmartScript call 
script.

If more than one script is associated with a campaign, the script 
flagged as primary runs when the agent clicks the Script button.

Source Code This unique campaign identifier based on the RowID is 
automatically filled in. The source code can be changed to a more 
meaningful value as long as the value is unique.

Start/End The default is the current date and time. Click in the field and use 
the calendar controls to select the campaign’s start date. 

The start and end dates drive which campaigns are visible to the 
agents in the Campaigns > My Campaigns View. 

To appear in the Campaigns screen, The start date must be less 
than or equal to today and the end date must be greater than or 
equal to today.

Status Options for status in the standard product are Planned (start and 
end dates in the future), Active (start date in the past and end date 
in the future), and Completed (start and end date in the past). The 
status must be set by the user and does not automatically change 
when the campaign is launched.

Summary Type a summary of the campaign.

Target Calls Per 
Day

Type the number of calls you expect to be made per day. 

Using Siebel Tools, you can configure Campaign charts to 
compare these target values with the actual call activity recorded 
during the campaign.

Territory You can select more than one territory. If more than one territory 
is selected, designate one territory as the primary.

A value in this field can be used by Siebel Assignment Manager.

Table 58. Selected Campaign Fields

Field Comment
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Using SmartScripts
A smartscript is a script that the salesperson or call center agent uses to interact 
with the customer. It can be associated with any campaign. 

If a SmartScript is associated with a business component and will be run for a 
campaign, then that business component’s name must be the same as the value in 
the Response Type field for the campaign. For example, if the Response Type field 
is set to Response, then the script’s business component must be Response. If the 
Response Type field is set to Opportunity, then the script's business component 
must be Opportunity.

To set up a SmartScript

1 Use the step in the following list that applies to your product:

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > All Campaigns Across Organizations.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > All Campaigns Across Organizations.

2 Select a campaign.

3 In the SmartScript field, click the select button.

4 In the Smart Scripts dialog box, click New.

Total Cost Click in the field and use the calculator controls to type the total 
cost of the campaign. If the campaign is a parent campaign, costs 
from any child campaigns are not rolled up to the parent.

Total Target Calls Type the total number of calls that is the goal for the campaign. 

Using Siebel Tools, you can configure Campaign charts to 
compare this value with the actual call activity recorded during 
the campaign.

Type Options for Type in the standard product are Acquire, Retain, Win-
Back, Cross-Sell, or Up-Sell.

Table 58. Selected Campaign Fields

Field Comment
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5 Select the script from the list of available scripts and click OK.

NOTE: Repeat Step 3 through Step 5 to add all the scripts that will be used in this 
campaign. 

6 In the SmartScript dialog box, select the check box of the primary script and click 
OK.

Associating an Offer with a Campaign
Use this procedure to associate an offer with a campaign.

To associate an offer with a campaign

1 Use the step in the following list that applies to your product:

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > All Campaigns Across Organizations.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > All Campaigns Across Organizations.

2 In the Campaign list, select a campaign.

3 Click the Offers view tab.

4 In the Offers list, create a new record.

5 In the Add Offer dialog box, select a predefined offer and click OK.

Setting Up a Subcampaign in Siebel Campaigns
Typically, you use subcampaigns only in Siebel Campaigns. You can create a 
hierarchy of Campaigns by using the Parent Campaign field on each Campaign. If 
you are planning a hierarchy of campaigns, you must design the campaign structure 
and then determine which offers will be presented by parent campaigns and which 
will be delivered by subcampaigns. 
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To set up subcampaigns

1 From the application-level menu, choose View > Site Map > Campaign 
Administration > All Campaigns Across Organizations.

2 In the Campaigns list, add a new record.

A new campaign record appears with default values in the campaign’s Source 
Code, Start, End, and Response Type fields.

3 In the Campaign form, complete the fields, using the table in “Creating a 
Campaign” on page 342 as a guide.
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Working With Campaign Contacts and Prospects
In Siebel Marketing and Siebel Campaigns, lists are sets of contact information, 
usually purchased from third-party companies or imported from another 
application. You can include one or more lists of contacts and prospects for a 
campaign. In addition, you can add individuals using the Contacts/Prospects view 
tab.

In Siebel Marketing, when you load a campaign plan, the campaign contacts are 
loaded primarily based on allocated segment members. For details about segment 
allocation, see Chapter 17, “Allocating Segment Counts to Campaigns.” In addition 
to using segments, Siebel Marketing allows you to link lists directly to a campaign.

There are three types of lists used by Siebel Marketing and Siebel Campaigns:

■ External lists. You can import purchased or rented lists into your Siebel system 
using List Management. When you use List Management with Siebel Data 
Quality you can scrub lists for duplicates during the import process. For details, 
see “Importing and Managing External Lists” on page 493.

■ Internal lists. You can also use List Management to maintain lists created from 
records that already exist in your contacts or prospects databases. For details, 
see “Creating and Managing Internal Lists” on page 508.

■ D&B lists. D&B lists are generated from D&B libraries of companies based on 
criteria you define. The D&B module provides a library of incorporated 
businesses that you can market to. Using the D&B screen you can create a list of 
D&B contacts to use in your campaign. For details, see the chapter about D&B 
in Applications Administration Guide.

You perform the following tasks when managing your contacts and prospects:

■ Associating a List of Prospects or Contacts With a Campaign on page 351

■ Checking the Status of Associating a List With a Campaign on page 352

■ Adding Contacts and Prospects to a Campaign Individually on page 353

■ Viewing Contacts and Prospects on page 354
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Associating a List of Prospects or Contacts With a Campaign
This topic discusses associating an imported (or purchased) list and an internal list 
of prospects or contacts with a campaign.

When you associate a purchased list with a campaign, you import the list, and then 
associate the list with a campaign. Prospects will only be visible in the Campaign 
Contacts list if you successfully import the purchased list before associating it with 
a campaign. If contacts or prospects are added to a list after you associate that list 
with a campaign, you need to delete the list from the Campaign Lists view and 
associate it with the campaign again.

CAUTION: If you associate an empty list (a list prepared for import but not yet 
imported) with a campaign and then import the list, the prospects are not 
associated with the campaign and are not visible in the Campaign Prospects list.

When you associate a list with a campaign, you will not immediately see data in 
the Contact/Prospect List. The list is populated after the Campaign List Association 
workflow process runs and you may need to refresh the browser view to see the 
newly associated names. However, if you do not see names appearing in your 
Contacts/Prospects list after several minutes and after refreshing the view, the 
Campaign List Association workflow may not be activated. For more information, 
see “Activating Workflow Processes” on page 42. 

Use the following procedure to associate available imported or internal lists of 
contacts and prospects with your campaigns. You can also associate a list of 
prospects or contacts with campaign plans using the Program Flow or Program 
Explorer views. Before you associate a list with a campaign, make sure that the 
Siebel Server, the Object Manager component, and Workflow Process Manager 
component are running.

NOTE: Only active campaign lists can be associated with a campaign.

To associate a list of prospects or contacts with a campaign

1 Use the step in the following list that applies to your product:
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■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > All Campaigns Across Organizations.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > All Campaigns Across Organizations.

2 In the Campaigns list, select the campaign and click the Lists view tab.

3 In the Lists list, add a new record.

4 In the Add Lists dialog box, select the list you want and click OK.

NOTE: When you associate a campaign list with a campaign, contacts in that list 
are associated with the campaign. If you change the campaign list to be inactive 
or if you delete it, the contacts still appear in the Contacts/Prospects list for that 
campaign.

5 Click the Position select button, select a position, and click OK.

List position ownership should be coordinated with campaign contact 
ownership parameters set on the execution option views. Campaign contact 
position owner can be controlled by the list position owner or by assignment 
manager and execution options settings.

Checking the Status of Associating a List With a Campaign
After you associate a list of contacts or prospects with a campaign, you can review 
the status of this request in the Server Component Requests screen.

To review the status of associating a list with a campaign 

1 In the Component requests list, locate and review the Workflow Process 
Manager request status.

2 When the Status value is Success, you can see the records in the Contacts/
Prospects list.

3 When the Status value is Error, you need to check the WfProcMgr.log file for 
errors.
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Adding Contacts and Prospects to a Campaign Individually
In addition to using lists of contacts and prospects in a campaign, you can add 
individual contacts and prospects to a campaign. The ability to add or delete 
contacts and prospects can be controlled in the Execution Options view by using 
two flags (Enable Contact Editing and Enable Partner Editing of Contacts). If these 
flags are checked, the New and Delete buttons will be available. The buttons are 
available in Siebel Campaigns in the Campaign Administration views, but not the 
other Campaign views. For more information, see “Setting Up Campaign Execution 
Options” on page 359. 

After you add a list of contacts and prospects, all contacts and prospects in the list 
appear in the Campaign Contacts or Campaign Prospects view. From this view, you 
can also add contacts and prospects one at a time. For more information, see 
Chapter 20, “List Management.”

To add a contact or prospect to a campaign

1 Use the step in the following list that applies to your product:

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > All Campaigns Across Organizations.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > All Campaigns Across Organizations.

2 In the Campaigns list, select the campaign to which you want to add a contact 
or prospect.

3 Click the Contacts/Prospects view tab.

The list of available contacts or prospects appears, with information on the 
selected contact or prospect record displayed in the Contact or Prospect Details 
form.

4 In the Contacts or Prospects list, add a new record. 

5 In the Contact Last Name or Prospect Last Name field, click the select button 
and in the Pick Dialog Box perform one of the following actions:

a Select an existing record and click OK.
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b Click New to create a new contact or prospect, then type the information and 
click OK.

6 In the Contacts/Prospects Detail form, complete the remaining fields using 
Table 59 on page 354 as a guideline.

NOTE: The Organization Owner and Position Owner fields are automatically 
populated with the information of the person creating the record.

Viewing Contacts and Prospects
If you have access to the campaign, you can view the assigned contacts and 
prospects using one of the following procedures.

To view contacts and prospects in Siebel Marketing

1 From the application-level menu, choose View > Site Map > Campaigns > My 
Campaign Plans.

2 In the Campaign Plans list, select a campaign plan.

3 Click the Status view tab.

Campaigns associated with the campaign plan appear.

4 Drill down on the campaign hyperlink.

The Contacts/Prospects list appears, showing only the assigned contacts and 
prospects for that campaign.

Table 59. Contact and Prospect Detail Form Fields

Field Comment

# Attempts Type the number of contact attempts for this contact or prospect.

Call Status Options in the standard product are: In Progress, Busy, No Answer, Left 
Message, Call Back Later, Call Completed, Not Completed.

Outcome Describes the outcome of the call. Options in the standard product are: 
Created Opportunity, Created Response, No Interest, Unable to Reach 
Contact.
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To view contacts and prospects in Siebel Campaigns

1 From the application-level menu, choose View > Site Map > Campaign 
Administration > All Campaigns Across Organizations.

2 In the Campaigns list, select a campaign.

3 Click the Contacts/Prospects view tab.

The list appears, showing the assigned contacts or prospects.
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Working With Campaign Teams and Groups
Many organizations assign groups of agents to particular campaigns based on skill 
or territory.

The most straightforward way to provide access to the campaign is by assigning 
positions to a team. However, if you have a large call center where agents are 
organized by predefined groups of agents, you can set up assignments once and 
then assign the group to each campaign. Setting up campaign groups lets you add 
the key positions to a campaign group, without having to remember individual 
employees. 

Some call centers do not have predefined groups, or the groups change often. In this 
case you can assign positions directly to the campaign team. Every employee 
position in the team has access to the campaign. To work with campaign teams and 
groups, perform the following tasks:

■ Setting Up Campaign Teams. Used by Siebel Marketing and Siebel Campaigns.

■ Setting Up Campaign Groups on page 357. Used by Siebel Campaigns.

■ Associating Groups with Campaigns on page 358. Used by Siebel Campaigns.

Setting Up Campaign Teams
Campaign teams are used by Siebel Marketing and Siebel Campaigns. Campaign 
Teams are set up by assigning individual employees to a team that is associated with 
a campaign. Each employee position on the campaign team has access to the 
campaign in the Campaigns screen’s My Campaigns list.

To set up a campaign team

1 Use the step in the following list that applies to your product:

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > My Campaign Plans.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > All Campaigns Across Organizations.
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2 Select the campaign plan or campaign and click the Team view tab.

The creator selected record is automatically assigned as the primary member of 
the team. This position may be removed from the team as long as you specify a 
member of the team as the Primary.

3 In the Team list, create a new record.

4 Select employees from the Add Employees list, and click OK.

■ To select multiple consecutive employees, hold down SHIFT as you select 
names.

■ To select multiple nonconsecutive employees, hold down CTRL as you select 
names.

5 Click in the Primary field to designate the primary team member.

The default primary team member is the position that created the campaign.

Setting Up Campaign Groups
Campaign groups are positions within your company, not individual employees. 
After you add a group to a campaign, anyone occupying a position listed in the 
group has access to the campaign. Campaign groups are used by Siebel Campaigns 
and can be associated with a campaign in Siebel Marketing.

To create a campaign group and add group members

1 Use the step in the following list that applies to your product:

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > All Campaigns Across Organizations.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > All Campaigns Across Organizations.

2 Click the Groups view tab.

3 In the Campaign Groups list, add a new record.

4 Type a name and description for the group.

5 In the Campaign Groups list, select the group.
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6 In the Positions list, add a new record.

7 In the Add Positions dialog box, select the positions for the group and click OK.

Associating Groups with Campaigns
After you have created the campaign group, you can associate the group with your 
campaign. Campaign groups are used by Siebel Campaigns. 

To add a group to a campaign

1 From the application-level menu, choose View > Site Map > Campaign 
Administration > All Campaigns Across Organizations.

2 In the Campaigns list, select the campaign and click the Groups view tab.

3 In the Groups list, create a new record.

4 In the Add Groups dialog box, select the group and click Add.
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Setting Up Campaign Execution Options
Campaign execution options are available in Siebel Marketing and Siebel 
Campaigns. Campaign execution options allow you to specify campaign contact 
ownership and control the user’s ability to edit campaign contacts and prospects. 
You specify the ownership type, complete the default owners (organization and 
position). In addition, you can apply assignment rule groups (optional) that will 
allow automatic owner assignment.

Campaign contact ownership is a feature that allows you to control team members 
visibility into the campaign contacts. Team members accessing the campaign 
contacts view will only be able to see those campaign contacts and prospects for 
which they own.

You create these assignment rules in the Assignment Rules view in the Assignment 
Administration screen. For more information, see Siebel Assignment Manager 
Administration Guide. You select a rule group for a campaign in the Campaigns 
screen.

To establish execution options and apply Assignment Manager rules to campaign 
contacts, perform the following tasks:

■ Setting Up Campaign Execution Options.

■ Using Assignment Manager with Campaign Contacts on page 360.

Setting Up Campaign Execution Options
If you want to assign contact ownership, make sure that you select the appropriate 
Campaign Contact Ownership value, your default owners, the Contact editing flags, 
and an Assignment Manager rule group.

To set up campaign execution options

1 From the application-level menu, choose View > Site Map > Campaigns.

2 In the Campaign Plans list, select a campaign plan.

3 Click the Execution Options view tab and complete the fields using the 
information in Table 57 on page 338 as a guide.
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Using Assignment Manager with Campaign Contacts
After setting execution options, you can load and launch the campaign. If you chose 
to automatically assign an owner and associate an assignment rule group with the 
campaign, Assignment Manager runs against the contacts in S_CAMP_CON at the 
end of the campaign loading process.

Before launching a campaign, you can add or delete campaign contacts and 
prospects or change the organization and position owners associated with a contact 
or prospect.

When this editing process is complete, you can run assignment manager against the 
campaign contacts and prospects to make sure ownership and visibility are correct. 
To run Assignment Manager, click the Run Assignment Manager button in the 
Execution Options view tab. You will be prompted to select a campaign, and then 
Assignment Manager will run against S_CAMP_CON for that campaign’s contacts 
and prospects. For example, partners or employees might add new contacts to the 
campaign during the review process. Because these new leads might not have the 
correct owner, you can rerun Assignment Manager to assign these new records.

NOTE: You cannot run Assignment Manager until the campaign has successfully 
loaded.

To automatically assign owners to campaign contacts

1 From the application-level menu, choose View > Site Map > Campaigns > All 
Campaign Plans.

2 In the Campaign Plans list, select a campaign plan.

3 Click the Execution Options view tab.

4 Verify that the values in the following fields are correct:

■ Default Organization Owner.

■ Default Position Owner.

■ Assignment Rule Group 
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5 Load and Launch the campaign.

When the Campaign is loaded, Assignment Manager automatically assigns 
owners to the campaign contacts.

6 If you wish to run Assignment Manager again, you can click the Run Assignment 
Manager button and select the campaign that you want to load and launch.

7 Click Run Assignment Manager.

The Run Assignment Manager button is only available if you choose Yes - 
Assignment Manager in the Campaign Contact Ownership field.

8 In the Pick Campaign dialog box, select a campaign and click OK.
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Setting Up Campaign Quotas
Quotas are used by Siebel Marketing and Siebel Campaigns and may be set up for 
a campaign as an incentive for agents to meet target goals. The quota may be a 
monetary goal such as generating a certain amount of revenue for a campaign or it 
may be a nonmonetary goal such as making a certain number of calls within a time 
period.

To develop a quota plan with measurable objectives and rewards for success, use 
the following process and the quota view tabs to define details. For more 
information, see Siebel Incentive Compensation Administration Guide.

1 Creating Campaign Quota Plans. Create the quota plan and specify the period it 
will be in effect.

2 Defining Quotas for the Plan on page 363. Specify the objectives for each quota, 
and how performance is measured.

3 Assigning Awards to the Campaign Quota Objective on page 365. Define the 
incentives that participants receive for meeting quota objectives.

4 Assigning Campaign Quota Plan Participants on page 366. Select team members 
eligible to participate in the quota plan.

Creating Campaign Quota Plans
Use the following procedure to set up quota plan for your campaign. Then, using 
the procedures that follow, define the details of the quota plan.

To create a quota plan

1 Use the step in the following list that applies to your product:

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > All Campaigns Across Organizations.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > All Campaigns Across Organizations.

2 In the Campaigns list, select the campaign and click the Quotas view tab.

3 In the Quotas list, create a new record.
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4 Complete the fields for the quota plan.

Some fields are described in Table 60.

Defining Quotas for the Plan
After you define the quota plan, add quota objectives that participants must meet 
to receive incentives. Prior to adding new quotas, add the appropriate Quotas, 
Awards, and Plan Participants.

To add quota objectives to the quota plan

1 Use the step in the following list that applies to your product:

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > All Campaigns Across Organizations.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > All Campaigns Across Organizations.

2 In the Campaigns list, select the campaign and click the Quotas view tab.

3 In the Quotas list, locate the quota plan and drill down on the Name hyperlink.

The quota plan details are displayed in the Plan Quotas form, and quota 
objectives are displayed in the Quotas list.

Table 60. Quota Plan Fields

Field Comment

Active Flag Automatically set to True upon quota creation.

Description Description of the Quota Plan.

End Automatically populated when the Period field is completed. 

Internal Division Name The name of the internal division associated with this quota.

Period (Required) The time period for which the quota is active.

Plan Name (Required) Type a relevant name for the Quota Plan.

Start Automatically populated when the Period field is completed. 
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4 In the Quotas list, create a new record.

5 In the Add Quota Objectives dialog box, select an objective and click OK.

Repeat Step 4 and Step 5 to add additional quota objectives to the quota plan.

To edit quota objective values 

1 Use the step in the following list that applies to your product:

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > All Campaigns Across Organizations.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > All Campaigns Across Organizations.

2 In the Campaigns list, select the campaign and click the Quotas view tab.

3 In the Quotas list, locate the quota plan for which you want to edit objectives 
and drill down on the Name hyperlink.

The quota plan details are displayed in the form, and quota objectives are 
displayed in the Quotas list.

4 Select the quota objective, and change values in the appropriate fields.

Some fields are described in the following table.

The modifications appear in the record when it is subsequently opened.

Field Comment

Description Type a detailed summary of the quota objective.

Performance Measure Select the performance measure from the drop-down list. 
Options are Revenue and Units. Revenue typically corresponds 
to Amount and Units corresponds to Quantity.

Quota (Required) Any name that makes sense for the quota.

Quota Type Select the performance type from the drop-down list. Options 
are Amount and Quantity.
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Assigning Awards to the Campaign Quota Objective
Quota plan participants may receive awards for meeting campaign objective goals. 
A number of awards for different performance achievements may be set up using 
the Awards view tab list. These awards can then be assigned to quota objectives.

To assign predefined awards to a quota objective

1 Use the step in the following list that applies to your product:

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > All Campaigns Across Organizations.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > All Campaigns Across Organizations.

2 In the Campaigns list, select the campaign and click the Quotas view tab.

3 In the Quotas list, locate the quota plan and drill down on the Name hyperlink.

The quota plan details are displayed in the form, and quota objectives appear in 
the Quotas list.

4 In the Quotas list, select a quota objective and tab to the Award field.

5 Click the Award select button and, in the Pick Quota Incentive dialog box, select 
the award for meeting the quota.

After you click OK, the selection appears in the Award field.

6 In the Target Quantity field, click the calculator button and use the calculator to 
type the number of units that represents the quota target.

To create new awards

1 Use the step in the following list that applies to your product:

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > All Campaigns Across Organizations.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > All Campaigns Across Organizations.

2 In the Campaigns list, select the campaign and click the Quotas view tab.
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3 In the Quotas list, locate the quota plan and drill down on the Name hyperlink.

The quota plan details are displayed in the form, and quota objectives appear in 
the Quotas list.

4 Click the Awards view tab.

5 In the Awards list, create a new record.

6 Complete the necessary fields for the award.

Some fields are described in the following table.

Assigning Campaign Quota Plan Participants
Assign eligible participants to your quota plan using the Participants view tab.

To add participants to the campaign quota plan

1 Use the step in the following list that applies to your product:

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > All Campaigns Across Organizations.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > All Campaigns Across Organizations.

Field Comment

Amount In the field, click the arrow and use the calculator controls to type the 
dollar amount for the award. If the type is cash, then this is the amount 
of cash given with the award.

Award Date In the field, click the arrow and use the calendar controls to specify the 
date the reward will be given.

Description Type a description of the award.

Name Type a reference name for the award.

Type Select the award type from the drop-down list. Options are Dinner, Cash, 
Trip, and Other. Your administrator may change these values to reflect 
your company’s requirements.
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2 In the Campaigns list, select the campaign and click the Quotas view tab.

3 In the Quotas list, locate the quota plan and drill down on the Name hyperlink.

Quota objectives appear in the Quotas list.

4 Click the Quota Plan Participants view tab.

5 In the Participants list, create a new record. 

6 In the Add Positions dialog box, select the people targeted for quota plan 
participation and click OK.

Repeat this procedure to add other participants.
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Setting Up Campaign Assignment Skills
Campaign assignment skills are set up only in Siebel Campaigns. Setting up 
campaign assignment skills is a way to identify which employees have certain skills 
and to define the attributes of each skill.

Assignment Manager uses assignment skill rules to assign telesales agents to a 
campaign. Assignment skills are categories, such as Product or Language. 
Campaign Skill Items are subsets of campaign skills. For example, a skill item for 
the product campaign skill might be 486 Laptop or Pentium Desktop. A skill item 
for the language campaign skill might be French or English.

When associating skills with a campaign, first define the assignment skill, and then 
assign properties to the skill using the Campaign Skill Item list. Fields in the 
Campaign Skill Item list vary according to the skill. Repeat these procedures to add 
as many skills as needed to the campaign. 

To set up assignment skills for a campaign, perform the following tasks:

■ Associating Assignment Skills with a Campaign

■ Defining Campaign Skill Items on page 369

■ Deleting Assignment Skills and Campaign Skill Items on page 371

Associating Assignment Skills with a Campaign
Use the following procedure to define and associate assignment skills required for 
your campaign.

To associate multiple assignment skills with a campaign

1 Use the step in the following list that applies to your product: 

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > All Campaigns Across Organizations.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > All Campaigns Across Organizations.

2 In the Campaigns list, select the campaign and click the Assignment Skills view 
tab.
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3 In the Assignment Skills list, create a new record.

4 Complete the necessary fields.

Some fields are described in the following table.

Defining Campaign Skill Items
Use the following procedure to define items for each campaign skill associated with 
your campaign. 

To associate skill items with a skill

1 Use the step in the following list that applies to your product: 

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > All Campaigns Across Organizations.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > All Campaigns Across Organizations.

Field Description

Comments Type comments that describe the skill and how it will be used in the 
campaign.

Skill Options in the standard product are:

■ Activity Category

■ Email Language Code

■ Email Recipient Profile

■ Industry

■ Language

■ Product

■ Product Line

■ Product Line Wildcard

■ Product Wildcard

■ Revenue
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2 In the Campaigns list, select the campaign and click the Assignment Skills view 
tab.

3 In the Assignment Skills list, select a skill.

4 Scroll down to the Campaign Skill Item list and create a new record.

5 In the Campaign Skill Item list, complete the fields defining the properties for 
each Skill item.

Table 61 defines the skill items in the standard product that may be associated with 
a skill. Some items are associated with more than one skill.

Table 61. Skill Item Fields

Skill Item Field Action

Activity Category The activity category that must be performed for the campaign. 
For example, a campaign might need agents skilled in performing 
outbound calls to knowledgeable individuals or agents that can 
perform a demonstration.

Currency The type of currency skill needed for the campaign.

Email Recipient Profile The profile for the email recipient. If you have groups of agents 
with different types of email addresses, such as @support.com 
or @sales.com, Assignment Manager will assign based on a 
section of the email address of agents.

Expertise The expertise required for this skill. Options in the standard 
product are Novice, Intermediate, and Expert.

Industry The industry that the skill references.

Language Code The language associated with the skill.

Product The product associated with the skill

Product Line The product line associated with the skill.
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Deleting Assignment Skills and Campaign Skill Items
You can delete assignment skills and campaign skill items. When you delete an 
assignment skill, all its campaign skill items are deleted.

To delete an assignment skill and all its campaign skill items

1 Use the step in the following list that applies to your product: 

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > All Campaigns Across Organizations.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > All Campaigns Across Organizations.

2 In the Campaigns list, select the campaign and click the Assignment Skills view 
tab.

3 In the Assignment Skills list, select the skill and delete the record.

You have deleted the assignment skill and the campaign skill items that were 
associated with it.

Product Wildcard or 
Product Line Wildcard

Select Product Wildcard or Product Line Wildcard if you want 
Assignment Manager to evaluate the specified string value 
during a search of Product or Product Line names. For example, 
if you type Product Wildcard criteria with a value of Sales, a 
search will be performed for products containing that string of 
characters, such as Siebel Sales, Siebel eSales, and so on. 

Revenue Revenue can be used to assign agents to a campaign based on a 
revenue number. For example, only certain agents may be 
qualified to handle high value customers who generate revenue 
over $1M.

Click the Revenue select button and use the calculator to type the 
revenue figure and click the equal (=) sign.

Table 61. Skill Item Fields

Skill Item Field Action
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To delete a campaign skill item

1 Use the step in the following list that applies to your product: 

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > All Campaigns Across Organizations.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > All Campaigns Across Organizations.

2 In the Campaigns list, select the campaign and click the Assignment Skills view 
tab.

3 In the Assignment Skills list, select the skill.

4 Scroll down to the Campaign Skill Item list and select the item you want to delete 
from the assignment skill.

5 Delete the record.
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About Testing Campaigns and Offers
You can test outbound email, eNewsletter and fax campaigns in Siebel Marketing 
and Siebel Campaigns before actually sending them to target recipients. You can 
preview the offer delivery distribution using Test Email, and then launch the email 
campaign using the Send functionality.

Test Email sends a sample of the offer to a designated team member, based on his 
or her position. Because the test functionality references a position rather than a 
person, if the individual holding the position changes, the test offer automatically 
will be sent to the person actually holding the position.

To test campaigns and offers, perform the following tasks:

■ Testing Campaigns Business Scenario on page 373

■ Prerequisite Tasks for Testing Offers

■ Testing Campaign Offers Before Launching a Campaign on page 374

Testing Campaigns Business Scenario
The marketing manager of a telecommunications company plans to roll out a 
campaign that targets mobile communications customers whose service agreements 
will expire in the next quarter. The campaign features an eNewsletter containing 
information on the latest wireless communications offers. The business goal is to 
retain the accounts of those customers by offering incentives for signing a new 
service agreement.

The marketing manager uses Test Email to view the content and format of the 
eNewsletter before it is sent to targeted customers.

Prerequisite Tasks for Testing Offers
Before you set up an email, eNewsletter or fax offer for testing, make sure the 
following tasks are completed.

■ Siebel Marketing or Siebel Campaigns is running with the outbound 
communication server enabled.
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■ A valid communications delivery profile is assigned to the email or eNewsletter 
offer. Communication profiles are defined using the Communications 
Administration screen’s Communications Drivers and Profiles view. For more 
information, see “Using Delivery Profiles - Email, eNewsletter, and Fax” on 
page 294.

■ The record for the team member contains a valid email address (for example, 
memberlogin@siebel.com).

Testing Campaign Offers Before Launching a Campaign
Test Email sends samples of every email or fax offer associated with a particular 
campaign to designated team members, based on positions. Before testing or 
sending email offers, make sure you complete the following tasks:

■ Make sure the offer is active. The date in the Start field for the email offer must 
have arrived, and the date in the End field must be current or in the future for 
the Test Email and Send commands to be enabled. 

■ Associate the offer with a campaign. Associate the offer with an active campaign. 
For details, see “Associating an Offer with a Campaign” on page 348. 

■ Complete Web Server URL field. Make sure the Web Server field in the Email Offer 
form contains the URL (path) to your Web server (for example, http://
eCampaigns/Customer).

To test an email campaign

1 Use the step in the following list that applies to your product:

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > All Campaigns Across Organizations.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > All Campaigns Across Organizations.

2 In the Campaigns list, locate and select the campaign with the offer that you 
want to test.

3 In the Campaigns form, click the Team select button.
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4 In the Team Members dialog box, select the appropriate members of the 
campaign team to include and click OK.

You can also add team members by creating a new record.

5 Click the Offers view tab.

6 In the Campaigns form, click the menu button and choose Test Email.

7 In the Campaign Team list, select the position to receive the offer, and click OK.

Email, eNewsletter, or fax offers associated with the campaign are automatically 
distributed to the team member occupying the position.

8 Verify that the employee on your team has received the email offer.

NOTE: URL links included in the offer are inoperative for tests because the links 
only work for Contact and Prospect IDs and not Positions.
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Launching Email and Fax Campaigns
If you have tested your email or fax campaign, and the results are satisfactory, you 
are ready to send the email offers to campaign recipients. For more information, see 
Chapter 21, “Launching Programs and Campaigns” and “Adding a Position to the 
Marketing Administrators Access Group” on page 43.

To send email and fax offers

1 Use the step in the following list that applies to your product:

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > All Campaigns Across Organizations.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > All Campaigns Across Organizations.

2 In the Campaigns list, select the campaign and click the Offers view tab.

3 In the Campaigns form, click the menu button and select Send.
376 Siebel Marketing Guide Version 7.5.3



Campaign Plans and Campaigns

Using Response Management
Using Response Management
Siebel Marketing and Siebel Campaigns use Response Management. Whenever 
prospects or contacts respond to an offer through any channel (by inbound email, 
the Web, a call center, or sales representative), their responses may be captured in 
detail using the Responses screen. Using Response views, you can determine which 
contacts to pursue as opportunities.

Campaign media can be different from response media. Recipients of an Internet 
campaign can respond through a call center, and recipients of a direct mail offer 
may respond by going to a Web offer URL. A Web site can automatically capture 
response details, while phone calls or direct mail responses must be recorded 
manually. 

NOTE: In Siebel Marketing, inbound emails are not automatically captured as 
responses. You must configure your email response product to support inbound 
email processing. For Siebel eMail Response set-up instructions, see Siebel eMail 
Response Administration Guide.

There are several response types and each response type has several parameters that 
store details about a given response. You can modify an automatically captured 
response if you have permission. Responses are tracked for an offer and for a 
campaign. 

Adding Response Information to Prospect or Contact Records
The All Responses list allows you to view responses to selected campaigns and 
offers and to add response information to existing prospect or contact records. You 
can use this view to promote a contact to an opportunity, specify the response type 
and channel, and score the response. An optional Details form allows you to type 
additional information about the response.

To add response information to prospect or contact records

1 From the application-level menu, choose View > Site Map > Responses > All 
Responses.

2 In the All Responses list, create a new record.
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3 In the Responses form, complete the fields using the following table as a guide.

Fields Comment

Campaign Required. Select a Campaign.

Description Required. Type a description that contains details of the response.

Last Name Select the Last Name for a prospect or contact.

A number of fields are automatically populated based on this 
selection. These include:

■ The respondent’s first name.

■ The account associated with the respondent. If no account is 
associated, use the Account select button to choose one.

■ The account address (city, state, country, telephone number, and 
so on), that are associated with the respondent are automatically 
filled in the form.

Lead Partner Choose a partner organization to associate with the response. If a 
lead partner was assigned at the program level or campaign level, it 
will automatically appear in this field. If you do choose to change the 
Lead Partner value, the drop-down list shows only those partners 
associated with the campaign source.

Method In the Method field, choose the method used to capture the response. 
This field is optional.

Options are Mail, Other Lists, Web Demo, Direct mail, Other, Email, 
Fax, Phone, BRC (Business Reply Card), Web, Event Registration List, 
Event Attendee List, Purchased Lists, Partner List, and Sales Created 
List.

Offer Required. Select an Offer.

Only offers associated with the selected campaign appear in the list.

Response Type Required. Choose the type of response from the list. Options include 
Clicked on Web Offer, Clicked on Product URL, Email Reply, 
Requested Call Back, and so on.

Score Type a numeric value that represents a score for the response.

Source Code In Siebel Marketing and Siebel Campaigns, source codes are assigned 
to each campaign contact according to the source code format 
associated with the program stage. If this information is included in 
offer materials, the code can be added by the user on the response.
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Using Automatic Source Code and Offer Code Lookups
Behind each Responses view is an automatic business service that will look up and 
decode information based on any source codes or offer codes added in a response.

Source Code Lookups
To perform a source code lookup, type the campaign contact’s source code into the 
Source Code field on the response form and leave the field. You do not have to save 
the record to perform the lookup. As soon as you click or step off the field, the 
lookup service will determine whether the campaign is recognized and whether the 
contact name can be uniquely determined. If the source code is recognized, the 
correct campaign name will be defaulted. If the contact name can be uniquely 
determined within a campaign, the contact name will also be defaulted. The source 
code value is stored in the Campaign Contact table (S_CAMP_CON) for each contact 
record.

Offer Code Lookups
To perform an offer code lookup, type the offer code in the response form. When 
you save the record, if the lookup service recognizes the offer code, it defaults the 
correct offer name.

NOTE: If the source code or the offer code is not recognized by the application or if 
the two codes conflict, both values will be saved with the response to preserve the 
user data.

If your deployment does not require source code lookups, you can disable the 
Response Lookup business service in Siebel Tools.

Offer Code Each offer has a unique offer code. If the offer code is included in the 
offer materials, the code can be added by the user on the response.

Status Choose a status of Open, Pending or Closed.

Fields Comment
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Adding a Product to a Response
This view tab displays a list of products associated with the response, for example, 
products for which a respondent requested information using a product link in an 
email or Web offer.

To add products to a response

1 From the application-level menu, choose View > Site Map > Responses > All 
Responses.

2 In the Responses list, select the response record and click the Products view tab.

3 In the Products list, create a new record.

4 In the Products dialog box, select the product from the list and click Add.

The list contains products that have been associated with the offer.

Adding an Order to a Response
This view tab displays a list of the respondent’s product orders. An order record 
contains information on the order status, the order number, type, account 
associated with the order, the date, priority and description of the order.

To add orders to a response

1 From the application-level menu, choose View > Site Map > Responses > All 
Responses.

2 In the Responses list, select the response record and click the Orders view tab.

3 In the Orders list, create a new record.

4 In the Orders dialog box, select the order from the list and click Add.

Adding an Opportunity to a Response
This view tab displays a list of opportunities associated with the response.
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To add opportunities to a response

1 From the application-level menu, choose View > Site Map > Responses >All 
Responses.

2 In the Responses list, select the response record and click the Opportunities view 
tab.

3 In the Opportunities list, create a new record.

4 In the Opportunities dialog box, select the opportunity from the list and click 
Add.

Adding an Attachment to a Response
This view tab displays a list of documents and other items that are associated with 
the response record.

To add attachments to a response

1 From the application-level menu, choose View > Site Map > Responses >All 
Responses.

2 In the Responses list, select the response record and click the Attachments view 
tab.

3 In the Attachments list, create a new record.

4 In the Attachment Name field, click the select button.

5 In the Add Attachment dialog box, use one of the following steps:

a To add a URL, in the URL field, type the URL.

b To attach a file, click the Browse button, locate the file, and click Open.

6 Click Add.
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Response Type Definitions
The information captured and stored in the More Info and Response Details forms 
depends on the response type selected. Table 62 identifies the fields in which 
information is captured and what that information is. 

NOTE: A Response is not automatically created when you click a Related Events link 
in an email or Web offer. Siebel Marketing and Siebel Campaigns do not provide 
responses for Clicked on Related Event.

.

Table 62. Response Type Fields in the Response Details Form

Response Type Field Name Captured Information and Description

Clicked on 
Product URL

Summary Name of the product. (The list of product URLs the 
respondent clicked appears in the Responses 
screen, Products view.)

Clicked on Web 
Offer

Summary Name of the Web offer that was clicked.

Clicked on Web 
Survey

Summary Name of the Web survey that was clicked.

Completed Web 
Survey

Summary Name of the Web survey that was clicked.

Downloaded 
Info Files

Downloaded File Name of the downloaded file.

Subject Subject of the file.

Summary Optional comment.

Email 
Bounceback

Subject Subject of the file.

Summary Optional comment.

Email Reply Subject Subject of the file.

Summary Optional comment.
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Read Receipt Not applicable An optional response type that requires additional 
configuration to support automatic creation.

Marketers can embed an HTML tag in HTML 
emails that allows Siebel Marketing to count each 
time the email is opened (read). The read receipt 
tag contains an image request. When that image is 
requested it is interpreted as an opened email. 
Additional configuration is required to construct an 
Active Server Page (ASP) or Java Server Page (JSP) 
to receive the image request and create the 
response record in Siebel Marketing. For additional 
information, see Technical Note 443 on 
SupportWeb.

Requested Call 
Back 

Phone # Respondent’s phone number.

Time of day Allows the respondent to specify a preference for 
the time of callback. Choices are Morning, 
Afternoon, and Evening.

Priority Priority level of the callback request. Choices are 
Urgent, High, Medium, and Low.

Summary Automatically stores the comments for a Web-
generated response or can be edited manually.

Topic Can store the subject line of an inbound email or 
be edited manually.The list of products for which 
the respondent requested a callback appears in the 
Responses screen, Products list.

Table 62. Response Type Fields in the Response Details Form

Response Type Field Name Captured Information and Description
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Requested 
More Info

Ship Method The preferred method of delivery—direct mail, 
email, fax, or phone— that the customer has 
specified be used for delivery of information.

Fax Fax number, if the delivery method is fax.

Email Email address, if the delivery method is email.

Phone Phone number, if the delivery method is phone.

Comments Automatically stores the comments for a Web-
generated response. Other comments may be 
entered manually.

Topic Can store the subject line of an inbound email or 
be edited manually.

Street Address, 
City, State, ZIP, 
Country

The address to which the information will be 
mailed if the preferred delivery method is direct 
mail.

The list of products for which the respondent 
requested information appears in the Responses 
screen, Products list.

Requested 
Unsubscribe 
Response

Email, Fax, 
Phone, Direct 
Mail

The choices are subscribe and unsubscribe.

Time of Day 
(Subscribe by 
phone)

Allows the respondent to specify a preference for a 
time if the respondent wishes to subscribe by 
telephone. Choices are Morning, Afternoon and 
Evening.

Subject Can store the subject line of an inbound email or 
be edited manually

Summary Contents of the email. Applies only to campaign 
responses.

Respondent 
Purchased

Not applicable This response is not created automatically. You 
must use Siebel Business Process Designer to 
capture responses of this type.

The orders for this purchase are displayed in the 
Responses screen’s Orders view.

Table 62. Response Type Fields in the Response Details Form

Response Type Field Name Captured Information and Description
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Promoting a Response to an Opportunity
If the customer is interested in the product offered by the campaign, you can 
promote the response to an opportunity. If the customer is an existing contact, the 
account is automatically associated with the opportunity. If the customer is a 
prospect, the customer is automatically promoted to a contact, and then associated 
with an account.

To promote a response to an opportunity

1 From the application-level menu, choose View > Site Map > Responses > All 
Responses.

2 In the Responses list, select the response to promote.

3 In the More Info form, click Create Opportunity.

The Opportunity form appears, with the response information in the form, and 
the contact information in the Campaign Leads Contacts list.

Respondent 
Unreachable

Summary Optional comment.

Response 
Created 
Opportunity 

Summary The list of opportunities can be accessed by 
selecting the Responses Opportunities view.

Unclassified 
Response 

Not applicable The response does not fall into one of the main 
response type categories or is a campaign response 
that requires manual processing.

Subject Subject of the email. Applies only to campaign 
responses.

Summary Contents of the email. Applies only to campaign 
responses.

Table 62. Response Type Fields in the Response Details Form

Response Type Field Name Captured Information and Description
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Creating Automatic Responses from Opportunities and Orders
When you create an opportunity in the Contacts/Prospects view using the Create 
Opty button, Siebel Marketing and Siebel Campaigns create a response record using 
the Create Auto Response business service.

For opportunities, the response is created for each contact added to an opportunity 
after a campaign is associated as an opportunity source. To create the response, 
associate a campaign with the opportunity using the Source field MVG (multi-value 
group) and then add a contact to the opportunity. All responses default to a type of 
Created Opportunity.

For orders, the response is created whenever a campaign is associated with a sales 
order. To create the response, you associate a campaign with the Sales Order using 
the Campaign field. All responses default to a Type of Respondent Purchased.
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Using Campaign Explorer
You can use the Campaign Explorer view in Siebel Marketing and Siebel Campaigns 
to monitor subcampaigns, contacts, activities, and offers for each campaign. The 
left pane of this view contains an explorer and the right pane shows the details of 
the selected campaign.

You can use the detail list to add folder items. For example, to add an activity, you 
select the Activity folder in the left pane, and the Activities list appears on the right. 
Then, from the list, you add a new activity record.

To review campaign elements

1 Use the step in the following list that applies to your product:

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > Explorer.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > Campaign Explorer.

2 In the Campaign Explorer, expand the folders for each campaign to display 
subfolders of campaign elements.

3 Click a folder to display detail of the subcampaign, contacts, activities and offers 
in the list on the right.

To add items to folders

1 Use the step in the following list that applies to your product:

■ In Siebel Marketing, from the application-level menu, choose View > Site 
Map > Campaigns > Explorer.

■ In Siebel Campaigns, from the application-level menu, choose View > Site 
Map > Campaign Administration > Campaign Explorer.

2 In the Campaign Explorer, expand the campaign item to show its subfolders.

3 Click a subfolder.

4 In the details list, add a new record and complete the fields.
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Viewing Campaign Charts in Siebel Campaigns
Campaign charts are used by Siebel Campaigns and allow you to review 
performance and graphically display results in a chart for areas such as incentive 
compensation, completed calls, lead quality by campaign, and so on. When you 
view a chart, the saved query in the upper-right corner filters the information 
shown in the chart.

Available charts include:

■ Campaign Achievement

■ Call Status Analysis

■ Call Status Analysis by Employee

■ Lead Quality Analysis by Campaign

■ Lead Quality Analysis by Response

■ Opportunity Revenue Analysis

■ Opportunity Revenue Analysis by Employee

■ Campaign Trend Analysis

■ Campaign Trend Analysis by Employee

■ Order Revenue Analysis

Viewing a Campaign Achievement Chart
The Campaign Achievement chart displays the results of the Sales Quota Plan set 
up for each campaign. The chart represents the percent achievement of quota for 
each campaign, and applies Incentive Compensation functionality to campaigns.

Perform the following tasks before viewing campaign achievement charts.

1 Create a quota plan, and associate quota plan objectives and participants with 
the plan. 

Quotas are discussed in “Creating Campaign Quota Plans” on page 362. For 
more information, see Siebel Incentive Compensation Administration Guide.
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2 Type achievement values by performing these tasks:

a From the application-level menu, choose View > Site Map > Sales Quotas 
> Sales Quotas.

b In the Quota Achievement list, select the quota plan.

c Type the amount you achieved compared to quota numbers. 

Achievements may be added manually or by using a workflow process that 
automatically completes achievements based on actions in Siebel Call Center. 
For more information, see Siebel Call Center User Guide.

You can view the Campaign Achievement Chart from the Achievement Analysis 
view of the Sales Quota screen or the Charts view of the Campaigns screen.

To view Campaign Achievements in Siebel Marketing

1 From the application-level menu, choose View > Site Map > Sales Quotas > 
Sales Quotas.

2 In the Quota Achievement list, select the quota plan and click the Achievement 
Analysis view tab.

3 In the By drop-down list, select either Plan Name or Quota, then select the chart 
type from the drop-down list.

4 In the Achievement Analysis form, click Go to display the chart.

To view Campaign Achievements in Siebel Campaigns

1 From the application-level menu, choose View > Site Map > Campaigns > My 
Campaigns.

2 Click the Charts view tab.

3 In the Objectives vs. Achievement list, select the plan name.

4 In the Show drop-down list of the Charts list, select Campaign Achievements.

5 In the By drop-down list, select Campaign Name or Objective Name and select 
the chart type from the second drop-down list.

6 In the Objectives vs. Achievement form, click Go to display the chart.
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Viewing a Call Status Analysis Chart
The Call Status Analysis chart displays the number of calls that have been 
completed compared to the number of calls that have not been completed for each 
campaign. This chart can be used by a call center manager to determine which 
campaigns are lagging and where to shift resources. 

Perform the following tasks before creating the Call Status Analysis chart:

1 Assign any contacts and prospects you will be contacting to the campaign.

For details, see “Adding Contacts and Prospects to a Campaign Individually” on 
page 353.

2 After each contact or prospect is called, update the status in the Call Status field 
in the Contacts or Prospects list or form.

The chart is based on information from this field—a Call Completed flag 
indicates that the call is completed—and the number of contacts and prospects 
targeted by the campaign. 

Viewing a Call Status Analysis by Employee Chart
The Call Status Analysis by Employee chart displays completed and uncompleted 
calls by a specified employee for each campaign. The values for this chart may be 
derived from lists of contacts and prospects assigned to the position and the Calls 
Completed field for the contact or prospect record in the Contacts or Prospects view.

A campaign list can be associated with a position. When this occurs, the position 
becomes the owner of the Campaign Contacts or Campaign Prospects. If the 
OwnerID is assigned, then only the employees of that position can view the 
Campaign Contacts or Prospects for a particular campaign. If the list is not assigned, 
then the OwnerID is NULL and all employees assigned to the Campaign Team or 
Campaign Group can see the Contacts or Prospects view.
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Perform the following tasks before generating the Call Status Analysis by Employee 
chart.

1 If the employee position will be evaluated based on lists of contacts and 
prospects, assign the lists to the position in the Campaign Lists view. 

The position becomes the owner of the list’s contacts and prospects.

When you associate a list with a campaign, if the Position field is not empty, 
then the OwnerID or each contact or prospect in that list is associated with that 
position. 

Most companies do not assign the contacts or prospects to a position, so the 
OwnerID is NULL. In such cases, the chart shows only one employee: Unknown. 

2 Update call status in the Campaign Contacts view. 

The chart draws its values on which contacts have been called based on the 
Done flag in the Call Status field. Make sure this field reflects the current status 
of the call.

Viewing a Lead Quality Analysis by Campaign Chart
The Lead Quality Analysis by Campaign chart displays the opportunities that have 
been created for the campaign when the Response Type is set to Opportunity. Using 
this chart, you can display opportunities by number of opportunities, by total 
opportunity revenue, or by average opportunity broken out by lead quality.

Perform the following tasks before viewing the chart:

1 In the Campaigns list, make sure the Response Type is set to Opportunity.

2 In the Opportunities screen, for each opportunity created for a campaign, make 
sure values are typed in the Revenue, Lead Quality and Source fields. 

You can use the My Opportunities or All Opportunities views to see the 
opportunities you need to check.
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Viewing a Lead Quality Analysis by Response Chart
The Lead Quality by Response chart displays the opportunities that have been 
created for a campaign when the campaign’s Response Type is set to Response. The 
chart displays opportunities by number of opportunities, by total opportunity 
revenue, or by average opportunity broken out by lead quality.

Perform the following tasks before generating the chart:

1 In the Campaigns list, make sure the Response Type is set to Opportunity.

2 In the Opportunities screen, make sure that the Revenue, Lead Quality, and 
Source fields are completed for each opportunity.

Viewing an Opportunity Revenue Analysis Chart
The Opportunity Revenue Analysis chart displays the campaign’s Number of 
Opportunities and the Expected Revenue for those Opportunities. The left axis is 
Opportunity Revenue and the bar chart corresponds to Revenue. The right axis is 
the Number of Opportunities and the line chart corresponds to Revenue. 

When using the chart, Opportunity Revenue Analysis by Campaign, only campaigns 
set to response type Response are used to create the chart.

This chart allows you to view the relationship between the amount of revenue and 
the number of opportunities for campaigns. For example, a campaign administrator 
might use the chart to identify campaigns that are generating a high volume of 
opportunities but have a low potential for revenue and campaigns which generate 
a smaller number of opportunities but have a higher potential revenue per 
opportunity.

Before generating the chart, navigate to the Opportunities screen and make sure 
that, for each opportunity associated with the campaign, the Revenue field contains 
a value.
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Viewing an Opportunity Revenue Analysis by Employee Chart
The Opportunity Revenue Analysis by Employee chart shows the number of 
Opportunities and the potential revenue for opportunities for each employee. It 
displays information in the same way as the Opportunity Revenue Analysis chart, 
but targets employees in the analysis.

Perform the following tasks before generating the chart:

1 From the application-level menu, choose View > Site Map > Opportunities.

2 Select an opportunity associated with the campaign.

3 Make sure that the Revenue contains a value.

4 In the Sales Team field, type the User ID of the agent generating the opportunity.

Viewing an Order Revenue Analysis Chart
The Order Revenue Analysis Chart shows the total revenue for orders generated by 
campaign.

Perform the following tasks before generating the chart:

1 From the application level menu, choose View > Site Map > Campaigns > My 
Campaigns. 

2 Select a Campaign with the Response Type set to Response. (This chart only 
shows data for campaigns with Response Type set to Response.)

3 Select the Contacts/Prospects view tab and click Create Response.

4 For this response, click the Orders tab and create a new record.

5 Click the Order number hyperlink to type details for the order.
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Viewing a Campaign Trend Analysis Chart
The Campaign Trend Analysis chart displays the total number of responses for each 
campaign over a period of time. The period can be set to day, week, month, quarter, 
or year. 

Before generating the chart, review responses for each campaign by navigating to 
the Campaigns view, selecting the campaign, and clicking the Responses view tab.

Viewing a Trend Analysis by Employee Chart
The Campaign Trend Analysis chart displays the total number of responses 
generated by each employee across campaigns over a period of time. The period can 
be specified by day, week, month, quarter, or year. 

Perform the following tasks before generating the chart:

1 From the application-level menu, choose View > Site Map > Campaign 
Administration > All Campaigns Across Organizations.

2 Select the campaign and click the Responses view tab.

3 Review the list of responses, making a note of the description and user.

4 From the application-level menu, choose View > Site Map > Responses > All 
Responses.

5 For each response you found in Step 3, make sure that the Created By field 
contains the User ID of the employee who handled the response and, therefore, 
owns it.
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Viewing Response Charts in Siebel Campaigns
Siebel Marketing and Siebel Campaigns include response charts. Response charts 
allow you to analyze response to your campaigns in areas such as opportunities, 
revenue, campaign offers, and so on. When you view a chart, the saved query in 
the upper-right corner filters the information shown in the chart.

Available Response charts include:

■ Campaign Analysis

■ Opportunity Analysis

■ Offer Analysis

■ Offer Type Analysis

■ Offer Type Analysis by Campaign

■ Revenue Analysis

■ Average Opportunity Revenue Analysis

To access Response charts

1 From the application-level menu, choose View > Site Map > Responses > All 
Responses > Charts.

2 In the Charts view use the Show drop-down list to select the type of data you 
want to display.

3 In the drop-down list below the Show field, select the type of chart and click Go.

To change the type of chart, select a different type and click Go.

Campaign Analysis (Response)
The Campaign Analysis chart displays the total number of responses for each 
campaign.

Perform the following tasks before generating the chart:
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1 From the application-level menu, choose View > Site Map > Responses > All 
Responses (or My Responses).

2 Select the Response Record.

3 In the Campaign Name field, associate the response with a campaign.

Viewing an Opportunity Analysis (Response) Chart
The Opportunity Analysis chart displays the total number of opportunities created 
for each campaign, based on the Source field in the opportunity record.

Perform the following tasks before generating the chart:

1 From the application-level menu, choose View > Site Map > Responses > All 
Responses (or My Responses).

2 For each response to your campaign, verify that opportunities are created (if 
applicable).

To create an opportunity for the campaign

1 Select the response record in the Responses list.

2 In the More Info form, click Create Opportunity.

An opportunity is created for the campaign and the campaign name is typed in 
the Source field for the opportunity.

Viewing an Offer Analysis (Response) Chart
The Offer Analysis chart shows the total number of responses per offer based on the 
offer associated with the response. 

Perform the following tasks before generating the chart:

1 From the application-level menu, choose View > Site Map > Responses > All 
Responses (or My Responses).

2 For each response to campaigns featuring the offer, make sure the correct offer 
is associated with the response by reviewing the response record’s Offer field.
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Viewing an Offer Type Analysis (Response) Chart
The Offer Type Analysis chart displays the total number of responses for each offer 
type across all campaigns.

Perform the following tasks before generating the chart:

1 Confirm that each offer associated with the campaign has an offer type and offer 
name specified. For information about finding or completing these fields, see 
“Creating an Offer” on page 259.

2 Type responses during the campaign. The offer is identified for the response in 
the Offer Name field.

3 Generate the chart, using the procedure on “Viewing Response Charts in Siebel 
Campaigns” on page 395.

Viewing an Offer Type Analysis (Response) by Campaign Chart
The Offer Type Analysis by Campaign chart displays the total number of responses 
per offer type for each campaign. Each campaign can have many offers.

Perform the following tasks before generating the chart:

1 Confirm that each offer associated with the campaign has an offer type and offer 
name specified. For information about finding or completing these fields, see 
“Creating an Offer” on page 259.

2 Confirm that the offers you want in the chart have been added to the campaign. 
For information about this procedure, see “Associating an Offer with a 
Campaign” on page 348.

3 Type responses during the campaign.

4 Generate the chart, using the procedure on “Viewing Response Charts in Siebel 
Campaigns” on page 395. 
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Viewing a Revenue Analysis (Response) Chart
The Revenue Analysis (Response) chart displays the total revenue for each 
campaign and the total number of opportunities for each campaign. The bar chart 
shows the revenue by campaign and the line graph shows the number of 
opportunities for each campaign.

Values for this chart are derived from the Revenue and Source fields in the 
Opportunity screen’s My Opportunities or All Opportunities list. The revenue 
number is derived from the sum of the Revenue fields in the Opportunity records, 
with the Source field set to the campaign name. Before generating this chart, make 
sure to complete these fields for opportunities used in this analysis.

Viewing an Average Opportunity Revenue Analysis (Response) Chart
The Average Opportunity Revenue Analysis chart displays the average revenue for 
each campaign. For each opportunity created for the campaign, the revenue is 
added and the average is taken across opportunities created for the campaign. 

Values for this chart are derived from the Revenue and Source fields in the 
Opportunity screen’s My Opportunities or All Opportunities list. The revenue 
number is derived from the average of the Revenue fields in the Opportunity 
records, with the Source field set to the campaign name. Before generating this 
chart, make sure to complete these fields for opportunities used in this analysis.
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The program plan is the template for the program flow that is applied when you 
execute the program. In the Programs screen, you can use the graphical drag-and-
drop Program Flow view or the Program Explorer view to design and execute 
multistage, triggered, and recurring marketing programs using new or existing 
segments, lists, and campaigns. If you prefer, you can use the Program Wizard 
button in the Program Plans list to guide you through the process.

You can establish multiple stages for a marketing program. Each stage can have 
multiple segments, campaigns, offers, and waves. Subsequent stages can be based 
on a customer response or any other event. For example, a premium customer 
visiting the products catalog might trigger an email offer to that customer for the 
selected product.

In the workspace, you can use the right-click menu to manually start Marketing 
Server tasks such as generating a snapshot. To schedule server tasks to be started 
automatically, use the Schedule calendar.

The graphical Program Flow designer is integrated with Siebel’s workflow engine 
and Marketing Server. Therefore, once defined, the entire program can be 
automated from the initial customer segmentation through communication, to 
response collection and analysis. This capability is especially useful when programs 
are set to automatically recur, as in the case of a monthly welcome package 
campaign to new customers.

Each time you design and implement a marketing program, you perform a number 
of tasks in the sequence shown in the following list:

1 Creating a program plan. Define the details of the program plan, such as the 
customer hierarchy and targeting level, the campaign load mapping for external 
data, the start and end date, and so on. For details, see Creating a Program 
Plan on page 405.
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2 Adding a stage to the program. Using the Program Flow view, add a stage 
milestone to the program plan and complete stage details, such as assigning a 
filter or output file layout to the stage. For details, see Using the Program Flow on 
page 410, and Adding a Stage to the Program on page 411.

3 Assigning segments to a stage. Using the Program Flow view, select predefined 
segments that define the target customer you are trying to reach, and associate 
the segments to the stage. For details, see Assigning Segments to a Stage on 
page 414.

4 Adding a campaign plan to a stage. Using the Program Flow view, select one or 
more predefined campaign plans with associated offers and link these campaign 
plans to the program stage. For details, read Adding a Campaign Plan to a 
Stage on page 415.

5 Adding lists to the campaign. If you have imported lists of prospects or contacts, 
you can optionally add these lists to the campaign plan. For details, see Adding 
Imported or Internal Lists to a Campaign on page 416.

6 Generating a snapshot. After you have designed your program logic, you can 
generate a snapshot manually from the Program Flow view or schedule the 
snapshot to automatically occur using the Schedule view. For details, see 
Chapter 16, “Generating and Maintaining Snapshot Files.”

7 Allocating segment net counts to campaigns. After snapshot generation is 
completed you can distribute actual counts, or forecast percentages of counts to 
campaign offers. For details, see Chapter 17, “Allocating Segment Counts to 
Campaigns.”

8 Defining waved distribution and vendor lists. To pace your distribution and avoid 
overloading your vendors and fulfillment center, you can set up wave periods 
and divide contact lists among vendors. For details, see Setting Up Waves on 
page 478 and Creating Vendor-Specific Lists on page 480.

9 Previewing the list. You can preview the first 500 names in your distribution list 
to make sure the list is formatted correctly and contains the contact information 
you need. For details, see Previewing a List on page 485.
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10 Loading the campaign. When you are ready to save your campaign lists in the 
Siebel database, you can perform the Load Campaign task from the Program 
Flow or Program Explorer views, or schedule the task using the Schedule view. 
Loading the campaign saves contacts in the Siebel transaction database and 
generates output list files and eAI list files. For details, see Manually Loading a 
Campaign (Generating a List) on page 487.

11 Executing the campaign. After loading the campaign and generating the lists, you 
can launch the campaign from the Program Flow or Program Explorer views or 
schedule the program start, which automatically launches the campaign. The 
Launch Campaign task distributes lists to vendors using FTP or email, and sends 
email, eNewsletter and Web offers to contacts. For details, see Chapter 21, 
“Launching Programs and Campaigns.”
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About Multistage Programs
Siebel Marketing supports both single-stage and multistage marketing programs. In 
a single-stage program, contacts are targeted in a stand-alone campaign, with no 
follow-up campaigns planned. During a multistage program, contacts in the first 
stage receive follow-up treatment in the program’s second and third stages, often 
based on the contact’s response to the original campaign. Multistage programs use 
stages to mark each phase of the program, campaigns to track separate instances of 
a marketing program’s execution, and the Program Execution workflow to manage 
the process. The following are types of multistage programs:

■ Marketing Program with Recurring Campaign. Scheduled to recur at standard 
intervals or specific times (daily, weekly, monthly, quarterly, yearly). Each run 
of a program plan, stage plan, and campaign plan generates a program, stage 
and campaign. For example, your company sends out a welcome kit and free gift 
to new customers on a monthly basis. Each month, a program stage occurs, new 
customers are identified (based on the segment criteria of account longevity of 
less than a month), and the welcome campaign is launched.

■ Event-triggered marketing program. Provides an automatic follow-up activity based 
on an action. For example, a customer visiting a product catalog might trigger 
an email offer to that customer based on items included in the prospect’s cart. 
If no response to the email is received, a telesales campaign is automatically 
launched to offer the customer a special offer on the product.

■ Response triggered marketing program. Uses response data to drive the next stage 
of the marketing program.

For example, the marketing manager of a bank designs a program implementing 
the company’s goal of increasing the number of bank-affiliated credit card 
customers. Within the program, he creates two campaigns, one offering a card 
with 10% interest and a $25 annual fee, the other offering 14% interest but no 
annual fee. These offers are sent to 250,000 of the company’s customers who do 
not already have credit card accounts with the bank.

After 30 days, response information is used to:

■ Send a welcome packet of information to each new credit card customer
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■ Offer an 8%, $25 annual fee card to everyone who did not respond

In the initial stage of the campaign, the manager generates a snapshot, based on 
segment criteria, which results in a list of contacts. By default, segment criteria 
for a stage apply to everyone in the database, whether or not they were included 
in the previous stage. Successive stages can be set to add contacts who qualify 
or use only the list of contacts from the prior stage.
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About the Program Execution Workflow
Multistage programs can be launched manually or use the automatic Program 
Execution workflow, with multiple processes, that trigger key events such as 
building the snapshot, loading a campaign (list generation), and launching a 
campaign (sending lists to vendors and sending offers to targeted contacts). The 
Program Schedule drives the process, with activities typed into Schedule, triggering 
the execution of each program. Each of these key events can be executed manually, 
using the Program Flow menu or the Program Explorer menus.

The Program Execution workflow process shows how executing a program, 
launching a campaign, and loading a campaign occur in a multistage process.

When the stage is activated, Siebel Marketing builds a snapshot and applies a 
predefined allocation of segment counts to campaign plans. Campaigns are loaded 
and executed, and the next stage is scheduled. This process continues until the last 
stage occurs, and the program is completed. Each stage of a program is a unique 
event, and Siebel Marketing tracks campaign and response history at the unique 
stage level (for each run). For more information about workflow processes and the 
Siebel Business Process Designer, see Siebel Business Process Designer 
Administration Guide.
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Creating a Program Plan
When you create a new program plan, you specify an objective, a type (for example, 
Cross-sell or Win-back), a status (Planned, Active or Completed), a revenue goal, 
and a budget figure. You also identify the customer hierarchy, targeting level and 
campaign load mapping that will be used to sort and link to contact data.

When you add organizations to a program plan, those organizations are copied to 
the program when it is created. If a lead partner is associated with the program plan, 
that lead partner will also be copied to the program. Any campaign plan that is 
added to a program plan (using the program flow or program explorer) will inherit 
the program plan's organizations. The campaign plan being added will retain any 
existing organizations and any existing lead partner.

The organizations on the campaign plan represent the union of the program plan 
and campaign plan's organizations. After you add the campaign plan to the 
program plan, changes made to the organizations at the program plan will not be 
automatically reflected at the associated campaign plan level. Segments added to 
the program plan will not inherit the organizations. For additional information, see 
“Creating a Campaign Plan” on page 332.

NOTE: You can turn off the teams and organizations inheritance features in Siebel 
Tools. In the appropriate business component, change the User Prop value for the 
Copy Teams and Copy Organizations property from Y to N. For more information, 
see Siebel Tools Reference.

You can attach documents and other files and view program stages and status. In 
addition, you can add team members, activity plans, and design the actual program 
flow, using a graphical designer workspace.

To create a program plan

1 From the application-level menu, choose View > Site Map > Programs > My 
Program Plans.

2 In the Program Plans list, create a new record.

3 Complete the fields using Table 63 on page 406 as a guide.

4 Click the More Info tab to view additional fields.
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5 Save the program.

To see available fields, in the Program Plans form, click the Show more button.

Table 63. Fields in the Program Plans Form

Field Comment

Assigned Budget Click the Budget select button to select the program’s 
currency code, exchange date, and budget amount. The 
budget value is a top-down figure, rather than a calculated 
bottom-up figure such as the Expected Cost field.

Campaign Load 
Mapping

Required. Click the Campaign Load Mapping select button. 
In the Pick Campaign Load Mapping dialog box, select the 
predefined mapping for accessing external data sources and 
click OK. For details, see “Creating Campaign Load 
Mappings” on page 62.

If your administrator set a default campaign load mapping, 
this value defaults for you. The campaign load mappings 
that are available for selection depend on the program’s 
customer hierarchy and targeting level.

Customer Hierarchy Required. Click the Customer Hierarchy select button. In the 
Pick Customer Hierarchy dialog box, choose the customer 
hierarchy for the program and click OK. For details, see 
“About Customer Hierarchies” on page 105.

Forecast Expense This read-only field displays the sum of the expense data 
added in the Forecast view for campaign plans associated 
with the program plan. For details, see “Forecasting for 
Campaigns” on page 438.

Forecast Revenue This read-only field displays the sum of the revenue 
predictions (based on data added in the Forecast view) for 
campaign plans associated with the program plan. For 
details, see “Forecasting for Campaigns” on page 438.

Lead Partner Choose a partner organization to associate with the program 
plan.

Organization Click the Organization select button and select the 
predefined organization that will be responsible for the 
program plan. An organization that you assign to a program 
plan will be inherited by programs in that plan.
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Region Choose the geographic region that the program targets in the 
list. Options are North, South, East, and West.

Start/End Required. Defaults to the current date and time. Use the 
select button to change the defaults.

Status The default program status is Planned. Options are Active 
and Completed. The status is changed from Planned, to 
Active, and Completed during automatic program execution. 
Manual execution of the program does not affect this field.

Summary Type a summary that describes the program’s goals.

Targeting Level Click the Targeting Level select button and choose a level. 

For information on targeting levels, see “About Customer 
Hierarchies” on page 105.

Type Choose the program type. Options are Acquire, Retain, Win-
Back, Cross-Sell, Up-Sell.

Table 63. Fields in the Program Plans Form

Field Comment
Version 7.5.3 Siebel Marketing Guide 407



Designing Marketing Program Plans

Using the Program Wizard
Using the Program Wizard
You can use the Marketing Program Wizard to create a marketing program and 
schedule it for automatic execution. The Program Wizard is designed to be used by 
marketers building uncomplicated Program Flows (less than five segments and five 
campaigns per stage). If you wish to include more segments in your program plan, 
you can specify five while using the Wizard and add the other segments later.

Before starting the wizard you need to create required elements in Marketing 
Administration such as customer hierarchies, campaign load mapping, output file 
layouts, and filters. You may also wish to create your campaigns and segments 
ahead of time, although you can create new records for campaigns and segments 
while using the Wizard. Be sure to check the supporting details for the program’s 
components before execution, including segment criteria, campaign details and 
filters. When you have finished, the Program Flow view appears showing program 
components placed in the workspace.

Use the following procedure to start the Program Wizard.

To use the program wizard

1 From the application-level menu, choose View > Site Map > Programs > My 
Program Plans.

2 In the Program Plans list, click Program Wizard.

3 In the New Program Wizard, type a name for your Program and click Next.

Select the appropriate Customer Hierarchy, targeting level, and Campaign Load 
Mapping for the program and click Next.

4 Type a name for Stage 1 of your Program, complete other fields, and click Next.

a Select from one to five segments to include in Stage 1 and click Next.

NOTE: If you have not created your segments yet, click New on the Segments 
list to create new segment records without leaving the Wizard.
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b Type the priority for each of the segments in your stage and click Next.

Priority is used during Allocation to resolve contacts that quality for more 
than one segment. For Wizard fields that do not display a segment (because 
fewer than five were assigned to the stage), simply leave the priority values 
as the defaults.

5 Select from one to five campaign plans to include in Stage 1 and click Next.

If you have not created some of your campaign plans, you can create new 
campaign plan records without leaving the Wizard.

6 For the first segment, type the percentage of contacts that should be allocated to 
each campaign and click Next.

If you selected fewer than five campaigns, do not type a value in a Wizard field 
that does not show a campaign name.

NOTE: Repeat Step 6 for each of the remaining segments and click Next.

7 Verify Stage 1 information and click Next to continue. If a Stage 1 entry is 
incorrect, click Previous to return to the Wizard form containing the incorrect 
information, and modify the information.

8 If you wish to add another stage, choose Yes and click Next to continue.

If you have completed your program stages, choose No and click Next.

9 To schedule the program, perform the following steps:

NOTE: If you do not wish to schedule the program, leave the fields empty and 
click Finish.

a Type the start date and indicate whether the program should recur and how 
often.

b To put the program on the active calendar, select Activate Schedule.

c Click Finish.
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Using the Program Flow
The logical flow for both single-stage and multistage programs is designed using the 
Program Flow view. In this view, you graphically define the program’s single-stage 
or multistage logic by dragging and dropping program components such as stages, 
segments, lists, and campaigns into the workspace. 

You can manually execute the program from this view. Use the right click-menu to 
generate a snapshot, load a campaign, and launch a campaign. You can 
automatically execute the program by scheduling the program. You use the calendar 
in the Program Schedule view to automatically invoke the workflow process and 
execute the server tasks.

Before setting up the Program Flow, verify that the following tasks have been 
completed:

■ Define segments and associate them with the same hierarchy as the program.

■ Define campaigns and associated offers.

■ Identify internal lists that will be associated with the program.

The Program Flow view displays the selected program’s details and the interactive 
workspace with a palette of objects representing program elements such as stages, 
segments, campaigns, and internal lists. To set up a program flow, perform the 
following tasks:

■ Adding a Stage to the Program on page 411

■ Using Repeating Stages Within a Program on page 413

■ Assigning Segments to a Stage on page 414

■ Adding a Campaign Plan to a Stage on page 415

■ Adding Imported or Internal Lists to a Campaign on page 416

■ Enabling Multistage Segmentation and Targeting Using Campaign History on 
page 417
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Adding a Stage to the Program
Use the following procedure to add a stage to the program, using the Program Flow 
workspace.

To add a stage to the program

1 From the application-level menu, choose View > Site Map > Programs > My 
Program Plans.

2 In the My Programs list, select the program and click the Program Flow view tab.

3 In the Program Flow workspace, select the Stage object from the palette and drag 
and drop it on the workspace.

4 To complete stage details, double-click the stage object in the workspace.

5 In the Stage Plan Details form, add or modify stage details, using Table 64 on 
page 411 as a guide.

To show available fields, click the Show more button.

Table 64. Fields in the Stage Detail Form

Field Comment

Actual 
Revenue, /
Actual 
Expense

Actual Revenue displays the total revenue across all campaigns 
associated with any campaign plans in the program plan. This value 
comes from the Campaign Plan Results views and updates when you 
click Recalculate in the Forecast or Result view of the Campaign screen.

Actual Expense displays the total costs across all campaigns associated 
with any campaign plans in the program plan. This value comes from the 
Results views of the Campaign screen and updates when you click 
Recalculate in the Forecast or Result view of the Campaign screen.

Budget Type the budgeted amount for the stage. A program may have several 
stages, and each stage may have a different budget.

Click the arrow in the Budget field and use the currency controls to. type 
the amount, choose a currency code and exchange date.
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Campaign 
Load Mapping

Required. The Campaign Load Mapping defaults to the Campaign Load 
Mapping associated with the program.

Click the Campaign Load Mapping select button. In the Pick Campaign 
Load Mapping dialog box, select the format used to access external 
contact information. Click OK. 

The Campaign Load Mappings that are available for selection depend on 
the customer hierarchy and targeting level chosen when the program is 
defined. For example: 

A customer hierarchy has two targeting levels, Customer (primary or top 
level) and Account (secondary or lower level). A campaign load mapping 
is defined for each level.

■ If the primary targeting level is selected for the program, only the 
format defined for that level is available. 

■ If the secondary targeting level of the hierarchy is selected, campaign 
load mappings for both the secondary and primary targeting levels 
are available.

Filter Click the Filter select button. In the Pick Filter dialog box, choose the 
filter that will be applied to the data before a snapshot is generated and 
click OK.

Forecast Mode Select the check box if you plan to use automatic program execution or 
if this is a secondary stage in a multistage program and you will use 
Forecast allocation rather than counts. If you select and then clear the 
Forecast Mode check box, counts and percentages will be cleared. For 
more information, see “Forecasting Allocation” on page 473.

Lag (Days) This field is read-only for the first stage of a program, and the default 
value is zero. Lag days can be assigned to subsequent stages of a 
program, and the field displays the number of days after the start of the 
program that the selected stage will start.

The number of Lag days is specified in the Campaigns > Waves view.

Name Name of the stage plan. Change the stage plan name from the default 
value to something more meaningful such as Stage 1: Summer Program.

Objective Type the program’s objectives.

Table 64. Fields in the Stage Detail Form

Field Comment
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Using Repeating Stages Within a Program
In most multistage programs, each stage occurs only once, separated by a specified 
number of days between stages. In some circumstances, you may wish to have a 
follow-up stage repeat at a different frequency than a previous stage. For example, 
in Stage 1, you send a direct mailing with a Web site link to a large audience. In 
Stage 2, every day you monitor the Web site mentioned in the direct mail offer and 
call any customers who visit the Web site immediately. In this example, Stage 1 only 
occurs once and Stage 2 repeats daily until the end of the campaign.

NOTE: By default, contacts that were contacted in a previous run of a stage are 
automatically excluded from subsequent runs of the same stage.

To specify a repeating stage

1 From the application-level menu, choose View > Site Map > Programs > My 
Program Plans.

Output File 
Layout

Click the Output File Layout select button select the layout that will be 
applied to the distribution list. 

You can choose multiple formats because different campaigns in the 
stage might use different formats. Even within one wave of one 
campaign, you might split the wave and use different vendors for 
execution and each might have their own format.

Source Code The default is the record identifier for the stage. Change the identifier for 
the stage source code if desired, but make sure the value is unique.

Source Code 
Format

Click the Source Code Format select button. In the Pick Source Code 
Format dialog box, select the source code format that concatenates 
individual program component source codes. Click OK.

Summary Type summary text that describes the stage’s implementation.

Table 64. Fields in the Stage Detail Form

Field Comment
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2 In the Program Plans list, select your multistage program and click the Stages 
view tab.

NOTE: You cannot repeat Stage 1.

3 In the Stages list, select the stage that you wish to repeat and complete the fields 
using the following descriptions:

Assigning Segments to a Stage
You previously defined segments with criteria derived from attributes, buckets, 
numeric and date measures, and database fields. Now you can assign these 
segments to the program stage.

To add segments to the program stage

1 From the application-level menu, choose View > Site Map > Programs > My 
Program Plans.

2 In the Program list, select the program and click the Program Flow view tab.

3 In the Program Flow workspace, select the Stage object.

4 In the palette, select the Segment object and drag the object to the workspace.

5 In the Pick Segment dialog box, select the predefined segment and click OK.

a To create a new segment, click New in the Pick Segments dialog box and type 
a name and description.

Field Description

Lag (Days) The number of days after the start of the previous stage that the 
selected stage should begin.

Repeat Every 
/ Units

Repeat frequency. For example, if the stage should repeat every 7 days, 
type 7 in the Repeat Every field and type Days in the Units field.

Until Day Type the number of days that the stage will run. This value cannot be 
greater than the Lag (Days) value for the next stage. All repeats of a 
stage must complete before the next stage can begin.
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b In the Pick Segments dialog box, select the new segment and click OK.

The segment object appears in the workspace.

c Double-click the segment object to open the Edit Segment view, where you 
can define the segment’s criteria.

Repeat Step 5 if you want to add more segments to a stage.

NOTE: You can only use segments in your marketing programs that have defined 
criteria. After creating a new segment and adding it to the program, you must go to 
the Edit Segment view to define the relevant criteria. For instructions, see “About 
Criteria-Based Segments” on page 242.

Adding a Campaign Plan to a Stage
If you previously defined and saved campaigns with associated offers using the All 
Campaign Plans form, you can add them to the Program Plan.

To add predefined campaigns with associated offers

1 From the application-level menu, choose View > Site Map > Programs > My 
Program Plans.

2 In the Programs list, select the program and click the Program Flow view tab.

3 In the Program Flow workspace, select the Stage object.

4 In the palette, select the Campaign Plan object and drag it from the palette to the 
workspace.

5 In the Pick Campaign dialog box, select the campaign, and click OK.

NOTE: If you do not see the campaign you want in the Pick Campaign dialog box, 
it may be already associated with another program. Although offers are reusable, 
campaigns are not. Use the My Campaigns or All Campaigns view to determine 
which program is using the inaccessible campaign. Then, create a campaign 
with a different name and the same offers.
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To define a new campaign with offer from the Pick Campaign dialog box

1 In the Pick Campaigns dialog box, click New.

2 In the Pick Campaign form, type a name and description for the campaign and 
save the record.

3 In the Pick Campaign dialog box, select the campaign and click OK.

4 In the workspace, double-click the Campaign object to open the Campaign detail 
form. 

5 Click the menu button and choose Edit Record to add details.

6 Click the Offers view tab. 

7 In the Offers list, create a new record.

8 In the Add Offer dialog box, select an offer and then click OK.

9 Click the Waves view tab and change the percentage in the default wave, if 
desired. 

The Waves list shows a default wave of 100%. For more information on waves, 
see Chapter 18, “Specifying Waves and Vendor-Specific Lists.”

10 Save the record before defining additional waves.

11 To define another wave, create a new record.

NOTE: In some marketing programs, a control segment of customers may be targeted 
by a test campaign with no associated offer, to gauge response to the offer. For 
details, see “Testing Campaign Offers Before Launching a Campaign” on page 374.

Adding Imported or Internal Lists to a Campaign
Imported or internal lists of contacts may be added to the campaign. Added lists 
must follow the first stage in the flow, and the List status must be active. To check 
the status of an imported list, double-click the list icon in the Program Flow 
workspace to display the List Contacts and Prospects view.
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To add a list to the campaign

1 From the application-level menu, choose View > Site Map > Programs > My 
Program Plans.

2 In the Programs list, select the program and click the Program Flow view tab.

3 In the Program Flow workspace, select the Campaign Plan object.

4 From the object palette, select the List object and drag it to the workspace.

appears.

5 In the Pick List dialog box, select an imported or internal list and click OK.

The List object appears in the workspace, linked to the stage and referencing the 
campaign.

To view and edit list details, double-click the List object in the workspace.

Enabling Multistage Segmentation and Targeting Using Campaign History
By default, any customer in your database can be included in any stage of a program 
plan. This means that segment members are not automatically restricted to people 
who were targeted or who responded to a previous stage. The following are some 
examples of reasons you might need to use campaign history to select segment 
members in a stage:

■ To include or exclude customers who were part of a particular program or 
campaign.

■ To exclude customers who have had marketing activity in the last 60 days.

■ To exclude customers who have been targeted more than five times in the last 
year.

■ To include customers who were targeted based on a particular wave.

■ To include customers who have responded by purchasing a product.

■ To include, as part of an output list, the most recent date that the customer was 
targeted.
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This history information can be mapped directly from the Siebel transactional 
database and can be used to build segmentation or filter criteria. If the customer 
uses the Siebel Data Warehouse, the Promotion star schema may be used for 
mapping.

NOTE: Siebel Analytics uses third-party products for the extract, transform, and load 
(ETL) process. This process draws specific data from the Siebel transactional 
database (OLTP), transforms the data, and loads the data into the Siebel Data 
Warehouse (OLAP). The load process builds a series of star schemas. Siebel 
Analytics uses these star schemas as the basis for reports and graphs.

For more information about this process and the Promotion star, see Siebel Data 
Warehouse Data Model Reference. 

You can allow segmentation by creating attribute families based on stage campaign 
history in the following ways:

■ Create attribute families from the Siebel Data Warehouse.

■ Create attribute families from the Siebel Database.

For more information about attribute families, see “Defining Attribute Families” on 
page 142. For more information about mapping tables and joining tables and fields, 
see Chapter 4, “External Data Mapping.”

Creating an Attribute Family From the Siebel Data Warehouse 
Campaign History
Creating attribute families based on stage campaign history allows you to use 
segmentation. One method is to use campaign history from the Siebel Data 
Warehouse.

To create an attribute family from the Siebel Data Warehouse campaign history

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > External Data Mapping.

2 Click the Tables view tab and in the Tables list perform the following tasks:

a In the Tables list, create mappings to W_PERSON_D and W_CAMPHIST_F.
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b In the Tables list, create the following new records for the W_PROGRAM_D 
table:

❏ Create a record for W_PROGRAM_D and place a constraint on it for 
records in which the Type value is Campaign Occurrence. Give the table 
a reference name of Campaigns.

❏ Create a record on W_PROGRAM_D and place a constraint on it for 
records in which the Type value is Stage Occurrence. Give the table a 
reference name of Stages.

❏ Create a record on W_PROGRAM_D and place a constraint on it for 
records in which the Type value is Program Occurrence. Give the table a 
reference name of Programs.

3 Click the Joins view tab and create the following joins:

a Create two table joins using the information in the following table:

b Create a start point join to the W_PERSON_D table.

4 From the show drop-down list, select the Attributes view. 

5 In the Attribute Families list, create a new attribute family called Program 
HIstory, setting the Base Field to PROG_ID.

6 In the Attributes list, create new records as shown in the following list:

Parent Field.Table Child Field.Table Cardinality

CON_ID.W_PERSON_D CON_ID.W_CAMPHIST_F N:N

PROG_ID.W_CAMPHIST_F PROG_ID.Campaigns N:

Code Table Code Field Label Table Label Field

Programs Name Programs Name

Stages Name Stages Name

Campaigns Name Campaigns Name
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7 Click the Attribute Hierarchies view tab and create a three-level hierarchy as 
shown in the following list:

■ Level 1= Programs

■ Level 2 = Stages

■ Level 3 = Campaigns

Creating an Attribute Family From the Siebel Database Campaign 
History
Creating attribute families based on stage campaign history allows you to use 
segmentation. One method is to use campaign history from the Siebel database.

Use the following guidelines to create an attribute family from the Siebel 
transactional database campaign history:

■ Make sure that S_CAMP_CON and S_DD_USER_KEY are mapped in the 
Marketing Repository. For instructions, see “Initializing Multistage Programs” on 
page 40.

■ The following is a list and brief description of the tables you use:

■ S_CAMP_CON. The primary campaign history intersection table between the 
CAMPAIGNS and CONTACTS tables. CAMP_CON_NUM is the source code 
field in this table.

■ S_SRC. The table that stores campaign occurrences, campaigns, stages and 
programs and their details.

■ S_CONTACT. The table that stores the details about contacts.

■ S_DD_USER_KEY. A cross-reference table between external database keys 
and Siebel contact ID.

■ S_CALL_LST. The segments table. 

■ S_S_DD_CAMP_WAVE. The lookup table for waves.

■ S_DD_LST_DRSTR. The table that stores the list distribution details.

■ S_ORG_FUL. The Vendor table.
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To create an attribute family from the Siebel database campaign history

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > External Data Mapping.

2 Click the Tables view tab and in the Tables list map the tables as shown in the 
following table. 

3 Click the Joins view tab and create the following joins: 

4 From the show drop-down list, select the Attributes view. 

Reference Name Table Name Restriction

Program Table [DB Owner].S_SRC CAMP_TYPE_CD = 
'PROGRAM CONTAINER'

Stage Table [DB Owner].S_SRC CAMP_TYPE_CD = 
'PROGRAM'

Campaign Table [DB Owner].S_SRC CAMP_TYPE_CD IS NULL

S_CAMP_CON [DB Owner].S_CAMP_CON

S_DD_USER_KEY [DB Owner].S_DD_USER_KEY

Parent Table Child Table Parent Field Child Field Cardinality
Cache 
(Y/N)

External Source Table (Sort-
Merge Join)

S_DD_USER_KEY [CH Field 1] Key1 1:1 N

[CH Field 2] Key2

[CH Field n] Key[n]

S_DD_USER_KEY S_CAMP_CON ROW_ID DD_USER_KEY_ID 1:N Y

S_CAMP_CON Campaign Table SRC_ID ROW_ID N:1 Y

Campaign Table Stage Table TEMPL_ID ROW_ID N:1 Y

Stage Table Program Table TEMPL_ID ROW_ID N:1 Y
Version 7.5.3 Siebel Marketing Guide 421



Designing Marketing Program Plans

Using the Program Flow
5 In the Attribute Families list, create a new attribute family called Program 
HIstory, setting the Base Field to PROG_ID.

6 In the Attributes list, create new records as shown in the following list:

7 Click the Attribute Hierarchies view tab and create a three-level hierarchy as 
shown in the following list:

■ Level 1 = Programs

■ Level 2 = Stages

■ Level 3 = Campaigns

You can map a hierarchical attribute to the Program, Stage, and Campaign tables 
and use the resulting hierarchy in segmentation criteria. You need to map the 
ROW_ID (Campaign Table) for the base field, map the NAME for the Label, and map 
the ROW_ID for the Code field for each Hierarchical level. This mapping imports the 
containers, not the individual occurrences. To import the occurrences, the condition 
for the Program table must be changed to CAMP_TYPE_CD = ‘PROGRAM 
CONTAINER OCCURRENCE’ and Stage table must be changed to CAMP_TYPE_CD 
= ‘PROGRAM OCCURRENCE’.

NOTE: The Base Field for the attribute family should always be mapped to the 
ROW_ID of the lowest level. In our example, it is ROW_ID of the Campaign table.

To map a hierarchical attribute for use in segmentation criteria

1 From the application-level menu, choose View > Site Map > Marketing 
Administration > Attributes.

Code Table Code Field Label Table Label Field

Programs Name Programs Name

Stages Name Stages Name

Campaigns Name Campaigns Name
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2 Select the Attribute Families view tab and in the Attribute Families list, create a 
new record.

3 Map the Campaign table to the base table and map ROW_ID to the base field 
using the following information.

4 In the Attributes list, create the following records.

5 Click the Attribute Hierarchies view tab and create a new record using the 
following information.

6 In the Attribute Hierarchy Levels list, create the 3 records using the following 
information.

Name Base Table Base Field

Program Hierarchy Campaign ROW_ID

Name Code Table Code Field Label Table Label Field

Program Program ROW_ID Program NAME

Stage Stage ROW_ID Stage NAME

Campaign Campaign ROW_ID Campaign NAME

Name Attribute Family

Program Hierarchy Program Hierarchy

Sequence Attribute

1 Program

2 Stage

3 Campaign
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7 Click the Attribute Families view tab.

8 In the Attribute Families list, select the program hierarchy attribute family and 
click Retrieve Data.
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Siebel Marketing provides support for planning and budgeting across the marketing 
organization. Using marketing plans, marketing executives and managers can create 
high-level business plans that cover a broad set of tactics, including outbound and 
inbound campaigns and hosted marketing events. For each plan, the marketing 
executive or team can set goals and objectives, identify available funds, assign 
budgets, associate multichannel marketing tactics, share documents, and generate 
campaign forecasts.

The Marketing Planning module can be applied to fit any organizational planning 
approach, including plans based on time periods (such as quarterly or annual 
planning cycles), business units, product lines, or any other management structure. 
Plans can be organized in hierarchies with any number of levels to support small 
marketing organizations as well as more complex planning processes. Each 
business unit marketing plan can be organized under a higher level marketing plan 
to facilitate management approvals and budget allocations.

Executives can also set high-level corporate objectives and then assign goals to each 
business unit that is participating in the plan. Each business unit can then create its 
marketing plan to meet its own assigned goals, forecast the organization’s ability to 
achieve the assigned goals, and submit the plan for approval. Based on common 
goals and performance metrics, marketing organizations can develop their own set 
of key performance metrics and institute the use of those metrics across all 
marketing plans.

This chapter discusses the creation of marketing plans and subplans.
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Creating a Marketing Plan
You create a marketing plan in the Marketing Plans screen. The More Info view tab 
provides a list of all the marketing plans to which you have access.

The Show drop-down list provides several levels of visibility, including the 
following views:

■ My Marketing Plans displays marketing plans for which you are on the team.

■ All Marketing Plans displays marketing plans in your assigned organizations. 

■ All Marketing Plans across My Organizations displays marketing plans that exist 
in your organizations and in any suborganizations in your organizations.

■ All Marketing Plans across Organizations displays the marketing plans that exist 
in all organizations in the your Siebel Application.

To create a marketing plan

1 From the application-level menu, choose View > Site Map > Marketing Plans 
> My Marketing Plans.

2 In the Marketing Plans list, create a new record.

3 Complete the fields using Table 65 on page 427 as a guide.

NOTE: The Forecast Revenue, Forecast Expenses, Actual Revenue, Actual 
Expenses and Total Funds fields contain read-only values that are determined by 
calculations from other views. For more information about these fields, see “To 
calculate forecast and actual expenses for the marketing plan” on page 433 and 
“To associate a fund request with a marketing plan” on page 434.
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Table 65. Marketing Plans Fields

Field Description

Assigned Budget Optional. A user-typed value for the amount of money approved 
for use on the marketing plan.

Budget Period Optional. You associate the budget period with the plan for 
expense recognition. For example, you might need to track a 
quarterly or annual budget period.

Code Required. An identification code determined by the user. Must be 
a unique value.

Comments Optional. A text field for any special comments for the plan.

Execution Period Optional. The period in which the plan will actually be executed.

Executive 
Approval

Optional. A status field indicating whether the plan has been 
approved by the appropriate executive.

Marketing 
Approval

Optional. A status field indicating whether the plan has been 
approved by the appropriate marketing director.

Name Required. The name of the marketing plan.

Objective Optional. A text description of the objective of the marketing 
plan.

Organization Optional. A multi-value field displaying all organizations 
associated with the plan. All organizations that appear in this list 
have visibility to the plan.

Parent Plan Optional. Choose a parent plan in this field when you want to 
make the current marketing plan record a subplan (child 
marketing plan). By selecting a parent plan you associate it with 
another marketing plan (child or subplan). One marketing plan 
can only have only parent plan. One parent plan can have 
multiple subplans.

Product Lines Optional. A dialog box containing product lines associated with 
this plan. May include one or more product lines.

Products Optional. A dialog box containing products associated with this 
plan. May include one or more products.

Region Optional. A listing of regions that you can associate with this 
plan.
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Creating a Marketing Subplan
A marketing plan that has a parent marketing plan is called a subplan. A marketing 
plan can have any number of other subplans (child marketing plans). For example, 
an annual plan may have four subplans, one for each quarter. For example, Q1Plan, 
Q2Plan, Q3Plan, and Q4Plan. 

To create a subplan

1 From the application-level menu, choose View > Site Map > Marketing Plans 
> My Marketing Plans.

2 Click the Subplans view tab.

3 In the Subplans list, create a new record.

4 Complete the fields using the values in Table 65 on page 427. 

a In the Marketing Plans form, click the Parent Plan select button.

b Choose the parent plan for this subplan and click OK.

Changing a Marketing Plan to a Marketing Subplan
You can change an existing marketing plan to a subplan by associating it with the 
parent marketing plan.

To change a marketing plan to a marketing subplan

1 From the application-level menu, choose View > Site Map > Marketing Plans 
> My Marketing Plans.

Team Optional. A multi-value field containing members of the team for 
the plan.

Type Optional. A list of the category types of marketing plans. Values 
include Corporate, Regional, Business Unit, and Department.

Table 65. Marketing Plans Fields

Field Description
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2 In the Marketing Plans list, query for the marketing plan that you want to change 
to a subplan.

3 In the Marketing Plans form, click the Parent Plan select button.

4 In the Pick Marketing Plan dialog box, choose the marketing plan that you want 
to be the parent marketing plan and click OK.

Setting Goals for the Marketing Plan
Each marketing plan can be associated with a set of goals. Each goal is a metric 
against which the performance of the plan will be measured.

To create a goal for a marketing plan

1 From the application-level menu, choose View > Site Map > Marketing Plans 
> My Marketing Plans.

2 In the Marketing Plans list, query for the marketing plan.

3 Click the Goals view tab.

4 In the Goals list, create a new record.

5 In the new record, select the Goal using values in Table 66 on page 430 and 
complete one of the following steps:

■ If the goal is a financial goal, type the target value for the goal in the Target 
Amount column.

■ If the goal is a non-financial goal, type the target value for the goal in the 
Target Quantity column.
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6 If you know the expected forecast value, type the forecast value in the Forecast 
Amount column. If you do not know the expected forecast value, leave the 
forecast column empty and type the value after you develop a forecast.

NOTE: If the goal has a Number Format of Percentage be sure to type whole 
number values, not decimal values. For example, an ROI goal of 15% should be 
typed as 15, not .15.

Table 66. Values for the Goals Field

Goal
Number Format 
Default Description

Average Cost 
per Lead

Currency The expected cost of all marketing activities in the 
plan divided by the number of sales leads 
generated

Average Cost 
per Opportunity

Currency The expected cost of all marketing activities in the 
plan divided by the number of sales opportunities 
generated

Average Cost 
per Order

Currency The expected cost of all marketing activities in the 
plan divided by the number of sales orders 
generated

# Leads Integer The number of sales leads this plan is expected to 
yield. The definition of lead may vary based on 
your company’s business process.

# Opportunities Integer The number of sales opportunities this plan is 
expected to yield

# Orders Integer The number of sales orders this plan is expected 
to yield

Revenue Goal Currency The incremental revenue that this plan is 
expected to yield

ROI % Percentage The percent Return on Investment that this plan 
is expected to earn

Unit Volume Integer The number of product units that are expected to 
be sold as a result of this plan
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Associating Marketing Plan Tactics With the Marketing Plan
A plan tactic is a marketing program, event, or standalone campaign that you have 
associated with a marketing plan. A marketing plan can be associated with any 
number of marketing programs, events, or standalone campaigns.

■ A marketing program is any program plan created in the Programs screen.

■ An event can be any event created in the Events screen.

■ A standalone campaign can be any campaign created in the Campaigns screen 
that is not associated with a marketing program.

To associate a plan tactic with a marketing plan

1 Create a marketing program, event, or standalone campaign.

2 From the application-level menu, choose View > Site Map > Marketing Plans.

3 In the Marketing Plans list, query for the appropriate marketing plan.

4 Click the Plan Tactics view tab.

5 In the Plan Tactics list, create a new record.

6 In the Plan Tactics dialog box, query for the program, event, or standalone 
campaign that you want to associate with the plan and click OK.

NOTE: Each tactic can only be associated with one marketing plan.

7 You can modify all the fields in this record except Plan Item, Type, and 
Organization.
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Developing and Assigning Budgets for a Marketing Plan
Use the marketing plan to review and approve budgets for all the programs, 
campaigns, and events in your organization. The marketing plan provides three 
categories of values for managing marketing budgets: Assigned budget, forecast 
expenses, and revenues.

■ Assigned Budget. The amount of money that has been approved for use on the 
tactics and activities within the marketing plan. The Assigned Budget value is 
typically input by a marketing executive with budget approval authority.

■ Forecast Expenses and Revenues. The total forecast expenses and revenues across 
subplans and tactics in the marketing plan. These values are automatically 
calculated using the values from fields shown in Table 67.

■ Actual Expenses and Revenue. The total actual expenses and revenues across all 
subplans and tactics in the marketing plan. These values are automatically 
calculated using the values from fields shown in Table 68.

Table 67. Forecast Expenses and Revenues Source Fields

Contributing Product Area Where to find it

Marketing Plan - Subplans Marketing Plans screen, Subplans view tab.

Program Plan Expenses Programs screen, Expenses view tab.

Campaign Plan Forecasts Campaigns screen, Forecast view tab.

Event Costs Events screen, Cost view tab (estimated cost column).

Event Revenues Events screen, Revenue view tab (estimated revenue 
column).

Table 68. Actual Expenses and Revenue Source Fields

Contributing Product Area Where to find it

Marketing Plan - Subplans Marketing Plans screen, Subplans view tab.

Program Plan Expenses Programs screen, Status view tab.

Campaign Plan Results Campaigns screen, Results view tab.

Event Costs Events screen, Cost view tab (actual cost column).

Event Revenues Events screen, Revenue view tab (actual revenue 
column).
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Recalculating a Marketing Plan
When you recalculate a marketing plan, the application automatically refreshes the 
totals for the forecast and actual expenses and revenues from all the contributing 
product areas. The application notifies you when the recalculation is complete and 
the updated forecast and actual values appear in the marketing plan views. 

If a marketing plan has subplans, the application automatically includes the 
subplans’ forecast and actual totals in its calculation. The recalculation also 
automatically refreshes any campaign plan forecasts and actuals as part of the 
update.

You can update your marketing plan forecast and actual expenses and revenues at 
any time. For a description of the elements that are included in the calculation, see 
Table 67 on page 432 and Table 68 on page 432.

CAUTION: Closing the browser window before the recalculate is completed will abort 
the “recalculate” with incomplete results. Be sure to wait until the completion 
summary window appears before existing the browser.

You can reschedule the recalculate functionality to run automatically by including 
the rollup business service in a workflow process. This is particularly useful for 
keeping the recalculated totals coordinated with ETL processes which populate a 
Data Warehouse for Campaign Analysis. The name of business service that can be 
used for this purpose is Marketing Plan Recalculation.

To calculate forecast and actual expenses for the marketing plan

1 From the application-level menu, choose View > Site Map > Marketing Plans.

2 In the Marketing Plans list, select the marketing plan and click Recalculate.

To assign a budget to marketing plan tactics

1 From the application-level menu, choose View > Site Map > Marketing Plans.

2 In the Marketing Plans list, query for the appropriate marketing plan.

3 Click the Plan Tactics view tab and verify that you have associated your targeted 
programs, events, and standalone campaigns. 

For information on associating plan tactics, see “Associating Marketing Plan 
Tactics With the Marketing Plan” on page 431.
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4 Click the Budget view tab. 

5 Type the approved budget amount in the Assigned Budget column. 

If the you developed forecast values, you can verify the plan is within budget by 
comparing your assigned budget to the forecast expenses.

Associating Fund Requests With a Marketing Plan
If your company uses the Market Development Funds module (MDF), any fund 
request can be associated with a marketing plan or with a campaign. For 
information about creating fund requests, see the section about fund requests in 
Siebel Partner Relationship Management Administration Guide.

To associate a fund request with a marketing plan, each fund request needs a link 
to the Marketing Purpose field in the request. After you associate fund requests with 
a marketing plan, you can view associated fund requests in the Marketing Plan 
Funds view. The total value of all associated fund requests appears in the Total 
Funds field in the Marketing Plan form. 

To associate a fund request with a marketing plan

1 From the application-level menu, choose View > Site Map > Fund Requests > 
My Fund Requests.

2 In the Fund Requests list, locate and select the fund request.

3 In the Fund Request form, click the Marketing Purpose select button.

To see the Marketing Purpose field, you may need to add the column. In the 
Marketing Plans form, click the menu button, choose Columns Displayed, and 
add the column.

4 In the Pick Source dialog box, locate and select the marketing plan.

To view a fund request associated with a marketing plan

1 From the application-level menu, choose View > Site Map > Marketing Plans.

2 In the Marketing Plans list, query for the appropriate marketing plan.

3 Click the Funds view tab.

Only associated fund requests appear in the list. 
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Attaching Documents to a Marketing Plan
You can attach planning documents to a marketing plan using the Documents view. 
These documents are visible to anyone who has access to the Plan.

To attach a document to a marketing plan

1 From the application-level menu, choose View > Site Map > Marketing Plans.

2 In the Marketing Plans list, query for the appropriate marketing plan.

3 Click the Documents view tab and create a new record.

4 Click the Attachment Name select button, locate the document on your local 
machine or network, and click Open.

Using the Marketing Plan Explorer
You can use the Plan Explorer to review the organization of your marketing plans 
and its associated plan tactics. 

To use the Plan Explorer

1 From the application-level menu, choose View > Site Map > Marketing Plans 
> Plan Explorer.

2 Expand the Marketing Plans folder.

3 To see subplans associated with a marketing plan, expand a marketing plan 
folder.

4 To see plan tactics associated with a marketing plan, expand a plan tactics folder 
in the parent plan folder.
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Siebel Marketing’s program and campaign organizational tools allow management 
of activities, milestones, documentation and schedules for your marketing 
campaign plans.

■ Forecast. Siebel Marketing offers cost management for marketing program and 
campaign plans. Forecast allows the marketing manager to predict the cost and 
revenue for each campaign plan within a marketing program. These figures are 
automatically rolled up and associated with the marketing program.

■ Activity Plans. Siebel Marketing’s Activity Plans can help you help you plan and 
execute the marketing program’s activities and milestones.

■ Timelines. Program plan, campaign plan, and campaign charts provide an at-a-
glance weekly and monthly overview of planned, active and completed 
programs and campaigns.

■ Campaigns Explorer. The Campaigns Explorer provides an overview of campaigns 
and their associated components. The dual-tree pane view provides a list of 
campaigns, contacts, activities and offers on the left side. When you drill down 
on each element, details are displayed on the right side of the view.

■ Program Explorer. The Explorer view in the Programs screen provides a view of 
the marketing program’s stages and campaigns. It is an alternate way to create 
and view program plans.

■ Document Library. The Documents view in the Programs screen allows you to 
create a library of proposals, white papers, artwork and other files associated 
with the marketing program.
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Forecasting for Campaigns
The Forecast view tab in the Campaigns screen allows you to examine the financial 
outlook of a marketing campaign based on your budget numbers and other 
assumptions you add.

■ Details of the selected campaign appear in the Campaign Plans form. 

■ The Forecast PREDICTED RESULTS read-only form displays the results after 
calculations have been performed on the modeled data.

■ The other input view tabs allow you to type values for segments, lists, costs, and 
so on.

A marketing analyst might model a number of different campaign scenarios by 
varying the segment count, response rate, conversion rate, and so, on to test the 
expected results for different types of campaigns or response rates. By changing the 
predicted response and conversion rates, the analyst can determine what the high-
end (optimistic) and low-end (pessimistic) predicted results are for each campaign 
as well as show results within a range of predicted values.

You can choose to model using an estimated total count and average response and 
conversion rates by typing them in the input summary form, or can type individual 
values for each segment and list on their respective input applets. Select the Use 
Segment and List Data menu option if you wish to use these individual inputs, and 
in either case, use Recalculate to update the predicted results.

To restrict the model to actual segment and list data without recalculating, click the 
menu button in the Input Summary form and choose Use Segment/List Data. This 
will use the assumptions for counts, response rates, and conversion rates you add 
in the Segment Inputs form and List Inputs form. Selecting the Use Segment/List 
Data overwrites your existing totals for counts, response rates, and conversion rates.

Forecast is also integrated with the Marketing Analysis reports in Siebel Analytics 
to provide financial reporting by program and campaign plans. 

The marketing reports use your inputs from Forecast to calculate predicted and 
actual values for revenue, margins, costs, response rates and ROI. In the reports, 
each set of Forecast assumptions is applied to each campaign. You can type your 
Forecast inputs as average values across all campaigns to estimate the predicted 
compared to the actual financial results of each campaign plan.
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Creating Forecasts
Use the following procedure to create a Forecast for your campaign plan.

To create forecasts

1 From the application-level menu, choose View > Site Map > Campaigns.

2 In the Campaign Plans list, select a campaign plan and click the Forecast view 
tab.

3 Scroll down to the subview tabs where you can perform the following tasks:

a In the Cost Inputs list, you can add a new record and update the fields.

b In the Input Summary, Segment Inputs, List Inputs, and Cost Allocation 
Inputs lists, you can update the fields.

4 Scroll up to the Forecast form and click Recalculate to display a refreshed total 
after you type new data.

Adding Campaign Plan Costs
Use the Cost Input form to add individual records for predictive costs associated 
with the campaign plan. 

■ Fixed costs can be two types of expenses, Per Campaign Plan and Per Campaign. 
You allocate Per Campaign expenses once for each campaign in the Campaign 
Plan. You allocate Per Campaign Plan expenses only once for the Campaign 
Plan. Fixed costs are costs you incur regardless of how many contacts receive an 
offer. Examples are artwork costs, design charges, set-up fees, and so on. When 
you select fixed and the cost type, the Per: (customer) field is inactive.

■ Outbound costs are variable expenses that reflect how much it costs to 
implement the offer per contact. Outbound costs have the expense type of Per 
Outbound Contact. Examples are printing or postage charges.

■ Inbound costs are expenses associated with managing responses to the 
campaign plan, such as the cost per inbound phone call. Inbound costs have the 
expense type of Per Inbound Contact.
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To add campaign plan costs

1 From the application-level menu, choose View > Site Map > Campaigns.

2 In the Campaign Plans list, select a campaign plan and click the Cost Input view 
tab.

3 In the Cost Input list, create a new record.

4 Type a descriptive name for the cost.

5 Choose the cost type (Per Campaign Plan, Per Campaign, Per Outbound Contact, 
Per Inbound Contact) from the list.

6 Click the Cost select button.

7 In the dialog box type a value and then click OK.

For costs of type Per Campaign Plan or Per Campaign type a single fixed value. 
For variable costs (Per Inbound and Per Outbound Contact), type the estimated 
number of contacts and repondents along with a unit cost per interaction.

8 Type a value in the Per: (contact) field.

This field is inactive if the Type is fixed cost.

NOTE: Repeat Step 1 through Step 8 until you have added and saved the 
individual records for each cost associated with the campaign plan.

9 In the Predicted Results form, click Recalculate.

During a recalculation, individual values are calculated and displayed in the 
Predicted Results and Input Summary forms.

Adding Segment Inputs
Clicking the Segment Inputs view tab displays segments assigned to the marketing 
program stage that includes the campaign plan. Type assumptions about segment 
counts, response rates and conversion rates in the fields. Clicking the menu button 
in the Input Summary form, and choosing Use Segment/List Data restricts the 
model to entries you have made.
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To add segment inputs

1 Click the Segment Inputs view tab.

The Segment Inputs list appears, displaying each segment associated with the 
campaign plan.

2 Complete the fields.

a Count: Type the estimated number of targeted customers associated with the 
campaign plan.

b Response Rate %: Type the predicted response rate as a percentage (0-100).

For example, for 2.5%, type 2.5.

c Conversion Rate %: Type the predicted percentage of respondents who will 
purchase the product (0-100).

d (Optional) Coded Responses %. Type what % of your responses you expect 
to include source codes or offer codes.

3 Save the record.

4 In the Predicted Results form, click Recalculate.

During a recalculation, individual values are calculated and displayed in the 
Predicted Results form, and in the Input Summary view tab form.

Using the Input Summary Form
In the Input Summary form, you can add estimated Revenue per Sale, and 
Contribution per Sale values, as well as view summary information for inbound, 
outbound and fixed costs, segment and list counts, response rate and conversion 
rate percentages.

If you are restricting the model to Segment Inputs and List Inputs, click the menu 
button and choose Use Segment/List Data.
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To add revenue or contributions per sale assumptions

1 Click the Input Summary view tab.

2  In the Revenue per Sale field, type the average total dollar amount of each sale 
generated by the campaign plan.

For example, if you hope to sell two items to each customer at $100 each, type 
$200.

3 In the Contribution per Sale field, type the average gross margin contribution for 
each sale.

For example, if you are selling $100 items that cost $60 to produce, type $40.

4 Save the record.

5 Click Recalculate.

During a recalculation, individual values are calculated and displayed in the 
Predicted Results form.

NOTE: When you load a campaign, you specify if you want the costs from the 
Campaign Plan forecast to be copied to the Campaign. If you want to copy the 
revenue, cost, segment, and list inputs to the campaign, check the Copy to 
Campaign check box on the Input Summary form.

Using List Inputs
The List Inputs view tab displays lists assigned to the marketing program. 

To use assumptions based on list inputs

1 Select a list, and in the List Input fields type assumptions for Counts, Response 
Rate % and Conversion Rate % in the fields.

2 Click the Input Summary view tab.

3 In the Input Summary form, click the menu button and then choose Use 
Segment/List Data to calculate the assumptions for Counts, Response Rate %, 
and Conversion Rate % typed in the List Inputs fields.

Results appear in the Input Summary form. Selecting Use Segment/List Data will 
overwrite your existing totals for counts, response rates, and conversion rates.
442 Siebel Marketing Guide Version 7.5.3



Program and Campaign Management Tools

Forecasting for Campaigns
Calculated Fields in Forecast
After you type values in the Input tab fields and click Recalculate, Forecast performs 
a number of calculations. The results appear in Forecast’s Predicted Results form. 
These calculations are detailed in Table 69. 

Table 69. Calculated Fields in Forecast

Field Calculation Formula and Description

# Responses # Responses = Response Rate * Count. Expected number of 
responses to your campaign plan.

# Sales # Sales = Conversion Rate * # Responses. Expected number of 
sales generated by your campaign plan.

Revenue Revenue = # Sales * Revenue Per Sale. Expected revenue 
generated by your campaign plan.

Gross Margin Gross Margin = Contribution per Sale * # Sales. Expected profit 
margin from sales generated by your campaign plan.

Marketing Cost Marketing Cost = Fixed Cost + Outbound Cost + Inbound Cost. 
Expected cost of designing and executing your campaign plan.

Net Margin Net Margin = Gross Margin = Marketing Cost. Expected total 
profit from sales generated by your campaign plan.

Cost/Response Cost/Response = Marketing Cost / # Responses. Expected cost 
per response generated by your campaign plan.

Cost/Sale Cost/Response = Marketing Cost / # Sales. Expected cost per 
sale generated by your campaign plan.

ROI % (Net Margin = Marketing Cost) / (Marketing Cost *100). 
Expected return on investment for your campaign plan.
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Tracking Campaign Results under a Forecast
You can track the performance for each campaign based on a Campaign Plan using 
the Campaign Plan Results view. his view appears next to the Campaign Plan 
Forecast view and displays the actual revenue, expenses, response rates, and ROI 
for each campaign.

To add the campaign results, select the campaign from the campaign list in the 
Results list. With a campaign selected in the list, each Result Input will be credited 
to that Campaign.

You can see that the Results view contains the same set of inputs as the Campaign 
Plan Forecast: Results Summary, Segment Results, List Results, Revenue Results, 
Cost Results, Cost Allocation Results. Use each of these tabs to record the actual 
results that your campaign achieved.

If you selected Copy to Campaign on the Campaign Plan Forecast (Input Summary), 
the forecast values from the forecast tabs are copied to each of the Result tabs. In 
this case, you will probably not need to add new records for most of your data, 
because the forecast value is already added. To add the actual amount spent for 
each forecasted input, type the values in the Actual columns on each tab. If 
required, you can also add new Costs in the Cost Results view that were not 
included in the original forecast. For new cost records, select the cost type (Per 
Campaign, Per Inbound Contact, or Per Outbound Contact). The forecast columns 
will equal zero.

Refreshing Values for Campaign Result Inputs
Several of the fields in the Results view can be automatically updated from the real 
data in the transaction database. The following is a list of fields that can be 
refreshed:

■ Count. The count of contacts or prospects in the campaign.

■ Segment Count. The count of contacts in the campaign from each Segment.

■ List Count. The count of contacts in the campaign from each List.

■ # Responses. The count of response records associated with that campaign.
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To update these values with the most recent information, click the Refresh Values 
button in the Results Summary form and then refresh the view to display the new 
values. After these fields are updated, you can recalculate the entire financial model 
by clicking the Recalculate button in the Results list.

The campaign results summary will also be recalculated anytime the marketing 
plan is recalculated that includes the campaign plan.
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About Timelines
Timelines are available for program and campaign plans and individual programs 
and campaigns. Timelines provide calendar view of scheduled and recurring 
campaigns and programs, in a Gantt chart format. The chart is divided into weeks 
and months. Start field and End field values determine the placement of the timeline 
bars.

Types of Timelines
The Program Plans timeline. This timeline chart shows planned, active, and 
completed program plans. It is immediately visible when logging onto the Siebel 
Marketing home page. Alternately, you can navigate to the Programs screen and 
choose Timeline from the Show drop-down list.

The Campaign Plans timeline. This timeline shows planned, active and completed 
campaign plans. To see the campaign plans timeline, navigate to the Campaigns 
screen and choose Timeline from the Show drop-down list.

The Status timeline. This timeline shows each program or campaign. To see the 
Status timeline, select a campaign plan in the All Campaign Plans list or a program 
plan in the All Program Plans list. Then click the Status view tab and choose 
Timeline from the Show drop-down list.

The Status Timeline view is helpful when you want to verify the status of a specific 
campaign in a multistage recurring campaign.
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Using Timelines
Timelines help you determine that scheduling is appropriate and on track for 
planned marketing efforts.

Understanding Color-Coded Status Bars
Timeline bars are color-coded to help you identify the status of programs and 
campaigns. You can place the cursor over a timeline bar to display more details. 

Program plan and campaign plan timelines use the following status colors:

■ Active: Green

■ Planned: Yellow

■ Completed: Gray

Status (programs and campaigns) timelines use the following status colors:

■ Error: Red

■ Manual: Light Blue

■ Active: Green

■ Pending: Yellow

■ Finished: Gray

Navigating To and From Timelines
The following list contains helpful information about navigating timelines:

■ In the Programs screen’s Timeline view, you can navigate in the following ways:

■ Click the timeline bar to see the Status Timeline view for a program.

■ Drill down on the program plan name to see the Program Flow.

■ In the Programs screen’s All or My Program Plans view, you can navigate in the 
following ways:

■ Drill down on the program plan name to see the Program Flow.

■ Select a program plan, click the Status view tab, choose timeline from the 
Status list’s show drop-down list, and drill down on the program name to 
access details for the program plan.
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■ In the Campaigns screen’s Timeline view, you can navigate in the following 
ways:

■ Click the campaign timeline bar to display the status timeline for the 
campaign. In the Status timeline you can drill down on a campaign name to 
access views (such as Offers and Activities) that are associated with the 
campaign.

■ Drill down on the campaign plan name to display offers associated with the 
campaign plan.

■ In the Campaigns screen’s All Campaign Plans view, you can navigate in the 
following ways:

■ Drill down on the name of a campaign plan and see offers associated with 
the campaign plan.

■ Select a campaign plan, click the Status view tab, and a list of campaigns for 
the campaign plan appears. In the Status list you can drill down on a 
campaign name to access views (such as Offers and Activities) that are 
associated with the campaign.
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Creating and Using Activity Plans
Siebel Marketing’s Activity Plans views allow you to associate predefined planning 
and milestone activities and tasks with a template (activity plan). Then you can 
assign the templates to your marketing program plans and campaign plans. This 
creates one or more activities that are associated with a campaign or a program.

NOTE: Activities are not created for contacts loaded into a campaign.

Activity Plans may be designed to help you plan the marketing program or 
campaign, or launch it. Before you link an activity plan to your campaign, you need 
to create activity templates or customize existing templates to reflect your business 
process and needs. Templates allow you to define a generic set of activities that may 
be reused. 

For example, a marketing department production manager might design an activity 
plan template called Direct Mail that contains regularly scheduled campaign 
planning activities (meetings with creative or budgetary staff) and start tasks (such 
as generating a campaign snapshot according to segmentation criteria). Using the 
Campaign Activity Plans view the manager can associate the activity plan template 
to the current campaign and then assign resources, define priorities and status and 
so on to each predefined task, adding comments where necessary. 

The activity plan record is flagged to indicate how the activity plan will be used. If 
the activity is designated as a planning task, none of its activities are copied to the 
campaign record when it is created. If the activity plan is designed for the execution 
of the program or campaign, select the Recurring check box, and the set of activities 
will be automatically recreated and associated with each occurrence.

If your marketing program or campaign has a mixture of planning and start 
activities, create two plans, one for planning and one for execution tasks, and assign 
them both to the program or campaign.
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Creating Activity Templates
Activity Plan Templates allow you to create and manage activities for programs and 
campaigns. You define templates using the Application Administration screen’s 
Activity Templates and Activity Template Details views.

A campaign’s activity plan template might include information on the type of 
activity, duration and status, a list of activities associated with the program or 
campaign (preparation, telephone calls, milestones, tasks), and so on.

To create an activity plan template

1 From the application-level menu, choose View > Site Map > Application 
Administration > Activity Templates.

2 In the Activity Plan Templates list, create a new record. 

3 In the Template form, complete the fields and save the record.

a Type a name for the template.

b In the Type field, choose Program Container for a marketing program 
template, and DBM Campaign as an activity template for campaigns.

c Type a template description.

d In the Auto Trigger field, select the check box if the activity should be 
associated with the occurrence level.

e Select the Public check box if the activity plan may be used by others not on 
your team.

To create activities for the template

1 From the application-level menu, choose View > Site Map > Application 
Administration > Activity Templates.

2 In the Activity Plan Templates list, select a template.

3 Click the Activity Template Details view tab. 

4 In the Activity Template Details list, create a new record.

5 Complete the necessary fields for each activity assigned to the template.
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6 From the drop-down list, choose an activity type.

NOTE: Repeat Step 2 through Step 6 to add activities to the template.

7 Save the activity.

Associating Activity Plans with Programs and Campaigns
Use the Campaigns or Programs screen’s Activity Plans view to associate a template 
containing predefined activities with a program plan or campaign plan. An Activity 
Plan Template’s type must be set to Program Container for marketing programs and 
DBM Campaign for marketing campaigns to be available for selection. 

NOTE: Siebel Communications Server includes several predefined recipient groups. 
A recipient group is a group of people who are to receive particular 
communications. DBM Campaign Recipient is among the predefined recipient 
groups, with the underlying Siebel business object (DBM Campaign) and business 
component (Campaign Recipient). For more information on Recipient Groups for 
outbound communications, see Siebel Communications Server Administration 
Guide.

The Activity Plans view consists of:

■ The Campaign or Program form, which provides details of the selected campaign 
or program.

■ The templates list, which can contain one or many activity plan templates.

■ The Activities list, which displays activities associated with the selected 
template.

To associate an activity plan and activities to a campaign or program

1 From the application-level menu, choose View > Site Map > Campaigns or 
Programs screen.

2 In the My Campaign Plans or My Program Plans list, select the campaign or 
program.
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3 Click the Activity Plans view tab.

4 In the Activity Plans list, create a new record.

A new row appears in the list, and the Recurring field displays a check mark.

5 Complete the necessary fields.

a Click the Template select button.

b In the Pick Template dialog box, choose a predefined template from the list 
and click OK.

c Edit the existing description if desired, or type a description of the plan.

d Select Suppress Calendar to populate the check box if you do not want these 
activities added to your calendar view.

e Clear Recurring if the activity should be not be written to the campaign 
record for every occurrence of the campaign or program.

When you clear the Recurring check box, you indicate that this set of 
planning tasks is only performed once across all occurrences. By default, 
each new activity plan is set to Recurring when you assign it to a campaign 
or activity.
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Using the Campaign or Program Explorer
Use the Campaign or Program Explorer views to monitor concurrent marketing 
programs and campaigns. 

The Program Explorer view uses a tree pane to display the structure of the program 
plan, campaign plan, stage plan, and campaigns, with details of the selected object 
displayed at right. Expand the folders in the tree pane to display additional details. 
Campaigns Explorer offers similar functionality.

Click name hyperlinks in the component’s list to navigate to detail screens.

To use the Explorer view

1 From the application-level menu, choose View > Site Map > Campaigns or 
Programs screen.

2 From the Show drop-down list, choose Explorer.

A split view appears, with a tree list of program or campaign components in the 
left pane, and details of the selected component in the right pane.

3 To navigate to the program or campaign component, click the component name 
in the tree pane and drill down on the component’s name in the tabbed list.
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Associating Documents with Programs and Campaigns
Most marketing teams generate documents such as proposals, white papers, press 
releases, and artwork used in advertising. These documents can be attached to 
programs and campaigns for future reference.

To attach documents to programs and campaigns

1 From the application-level menu, choose View > Site Map > Campaigns or 
Programs screen.

2 In the My Program Plans or My Campaign Plans list, select the program or 
campaign and click the Documents view tab.

3 In the Documents list, create a new record.

4 In the Attachment Name field, click the select button.

5 In the Add Attachment dialog box click Browse to locate the file, or type a URL.

6 In the Add Attachment dialog box, click Add.

7 In the Comments field, add information that identifies the file’s contents.

8 Select the Update File check box to set this preference if you want changes to 
the original file to be included in the attached file.

To access the attached document

■ In the Documents list, drill down on the Name hyperlink to view document 
details.
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The program snapshot is a temporary binary file containing the customer-level data 
elements for a marketing program stage. Data in a snapshot file is extracted based 
on the elements needed for the segment criteria, output list fields, source code 
format and campaign load mapping that is associated with the stage. This 
information is extracted once, allowing the Marketing Server to populate segments 
with counts and launch a campaign, without having to return to the original data 
sources to obtain additional information. After generating a snapshot file, you can 
modify segment criteria (if you do not introduce new elements) and regenerate the 
gross and net counts without having to requery the data sources and rebuild the 
result set. For more details about these internal processes, see “Understanding 
Snapshot Generation Internal Processes” on page 560.

A snapshot is similar to a logical spreadsheet in which the rows (for example, 
contacts) are determined by the filter that is applied and columns are determined 
by a union of segment criteria, output file layouts, source code formats and 
campaign load mapping fields. Filters are applied to the data before the snapshot 
file is built. Therefore, changing the filter criteria requires that you generate a new 
snapshot because new rows may need to be added.

The Marketing Server uses a snapshot to determine which customers qualify for 
each segment and deduplicate any overlapping customers between segments. For 
example, if your criteria include measures based on income, you might create low, 
medium and high buckets for ranges of income. The snapshot will contain a list of 
contacts that satisfy each segment’s criteria, indicating the bucket for which each 
contact qualifies.

When you allocate segments to a campaign offer, Siebel Marketing counts the 
contacts that meet the criteria and displays the totals to help you allocate segment 
counts to offers. In the example, if you anticipated mailing an offer to 50,000 
contacts in the high income segment and the snapshot shows that only 20,000 
contacts qualify in the high bucket, you might want to adjust the salary ranges in 
the segment criteria and then update the counts. 
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The following list contains general guidelines for generating and using snapshot 
files:

■ If the data in the data sources change, the updated data is not reflected in the 
snapshot unless you regenerate the snapshot.

■ Changing segment or output file layouts definitions does not require snapshot 
regeneration if the information was captured in the original snapshot.

■ A snapshot file is associated with a program stage and cannot be shared across 
different stages without additional onsite configuration.

■ Use filters to help keep snapshot files as small as possible.

■ Applying a constraint to a table can also limit data. A constraint (SQL 
expression) creates a restricted view of the table. If you add a constraint to the 
table record, it is applied every time the table is accessed. For more information, 
see the constraint description in “To map a table” on page 92.

To generate and maintain snapshot files, perform the following tasks:

■ Generating a Snapshot File on page 457

■ Stopping a Snapshot File Generation on page 461

■ Modifying the Contents of a Snapshot File on page 463

■ Deleting a Snapshot File on page 465
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Generating a Snapshot File
In Siebel Marketing, the first time you generate a snapshot or the first time data 
retrieval occurs, the following snapshot directories are created:

■ \\filesystem\marketing\snapshots.

■ \\filesystem\marketing\EAI.

■ \\filesystem\marketing\Lists.

The first time you generate a snapshot file for a stage, a temporary snapshot file is 
created in the \\filesystem\marketing\snapshots directory. Each time you 
regenerate a snapshot for that stage, the data in that stage’s snapshot file is 
overwritten. Snapshot files for all stages accumulate in the snapshots directory and 
can be deleted, if necessary.

When you generate a snapshot, any constraint on that table is applied, then filters, 
and then segment criteria. Snapshot files contain the information needed to bring 
in contact data from an external data source. Therefore, they are only created when 
you request a snapshot for a campaign that contains a segment. If you only want 
data that exists in an internal list, no snapshot file is needed and none is created. 
In addition, because there is no segment, you do not need to allocate segment 
counts to campaign offers. Generating a snapshot for a stage that has a list and no 
segment creates a campaign but no snapshot file. For example, when you generate 
a snapshot for a program that contains a single stage, a single list, and a single 
campaign, the following occurs:

■ If this is the first time you have generated a snapshot, no snapshot directory is 
created.

■ No snapshot file is created.

■ No component request is submitted.

■ A campaign is created.

A snapshot file can be generated automatically during the launch of a scheduled 
program or requested manually in the Program Flow workspace or using menus in 
the Program Explorer.

To generate and maintain a snapshot file, perform the following tasks:
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■ Generating a Snapshot File Automatically

■ Generating a Snapshot File Manually

■ Checking the Status of a Snapshot Task on page 459

Generating a Snapshot File Automatically
An automatic snapshot build occurs during the launch of a scheduled program. 
When a program is scheduled, the Program Execution workflow process initiates 
the stage, snapshot generation, list generation (load campaign), and campaign 
launch. For more information on automatic snapshot generation, see “Using the 
Schedule Calendar View” on page 535. For more information about workflow 
processes and the Siebel Business Process Designer, see Siebel Business Process 
Designer Administration Guide.

Generating a Snapshot File Manually
Make sure that required tasks are complete for the stage including, specifying the 
output file layout, source code format, and campaign load mappings, adding the 
segments, and adding the campaign.

To manually generate a snapshot

1 From the application-level menu, choose View > Site Map > Programs screen.

2 In the Program Plans list, select the program plan.

3 Click the Program Flow view tab.

4 In the Program Flow workspace, select the Stage object, right-click, and choose 
Generate Snapshot from the menu.

5 In the Manual Execution - Generate Snapshot dialog box, click OK.

This dialog box will contain no records.

6 In the Submit Start Date field, change the submit date, if desired, and click 
Submit.
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Checking the Status of a Snapshot Task
Generating a snapshot starts a snapshot task. You use the Server Administration 
screen and views to check for task completion or to view error messages using the 
Task Information Log if the server task fails. For more information, see “Snapshot 
Fails to Generate” on page 549.

To check the status of a snapshot task, you need to know the stage plan name. To 
obtain the stage plan name, navigate to the Programs screen and then click the 
Program Flow or the Stages view tab).

To check the status of a snapshot task

1 From the application-level menu, choose View > Site Map > Server 
Administration > Components.

2 In the Server Components list, select the Marketing Server component.

3 In the Component Tasks list, check the values in the fields shown in the 
following table:

4 To review the Task Info Log, in the Component Tasks list, drill down on the task 
number hyperlink in the Task field.

The Tasks list contains a summary of the task activity. The Task Information Log 
list displays the events associated with that task. The first record contains the 
stage name in the following format:

Field Name Description

Task Task number identifier.

Task State Running. The task is in progress.

Completed. The server job is done.

Exited. An error was encountered.

Status If the task is running or has completed, the stage name appears. For 
example, 
Siebel."Customers"."City"

If the task has exited, you will see a message (for example, SME-
00045: Task failed). To identify the stage and obtain details, see 
the task information log.

Start Time/
End Time

Automatically populated with the date and time the task was started 
and completed.
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Task Name: [stage name]
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Stopping a Snapshot File Generation
You might need to stop a snapshot after you submit the generation request. For 
example, while checking the status of a snapshot task, you notice that the extract is 
accessing the incorrect table. You can stop a snapshot generation in the following 
ways: 

■ Stopping a snapshot in Pending status. Use this method if the status of the 
snapshot is Pending. To stop the snapshot in the Programs screen, you need to 
know the stage name. This cancels the snapshot process.

■ Stopping a snapshot in Active status. Use this method if the status of the snapshot 
is Active. To stop the snapshot task on the Marketing Server, you need to know 
the Siebel Server name and the start time for the snapshot task. This shuts down 
the Marketing Server task.

To stop a snapshot task that is in Pending status

1 From the application-level menu, choose View > Site Map > Programs > My 
Programs.

2 Click the Status view tab.

3 If the status is Pending, in the Status list, drill down on the stage in the Name 
field.

4 In the Stages list, select the stage for which the snapshot is generating and click 
Stop.

This cancels the snapshot.

To stop a snapshot task that is in Active status

1 From the application-level menu, choose View > Site Map > Server 
Administration > Servers.

2 In the Servers list, select your Siebel Server and click the Server Tasks view tab.
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3 In the Server Tasks list, select the Marketing Server task for the snapshot you 
want to stop.

TIP: The stage name is in the Status field and the start time is in the Start Time 
field.

4 In the Server Tasks list, click the menu button and choose Stop Task.

This shuts down the selected Marketing Server task. If you regenerate this 
snapshot, a new task ID will be assigned.
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Each program stage has its own snapshot. You view the data elements of the stage’s 
snapshot in the Snapshot Contents view tab. The Snapshot Contents list provides 
the details of each data element in the snapshot. These include measures, buckets, 
attribute hierarchy and level, and fields that you specify for inclusion using segment 
criteria, output file layouts, and so on.

Advanced users might need to add or change snapshot contents. You can modify 
snapshot contents in the following ways:

■ Adding Data Elements to a Snapshot File

■ Modifying the Stage Plan Details of a Snapshot File on page 464

Adding Data Elements to a Snapshot File
You can add data elements such as measures to perform calculations that are not 
included in the segment or to extract information that may be needed later.

NOTE: You must define levels for all attributes and buckets that you use in your 
snapshot prior to generating it, even if all of the attribute levels are not used in the 
specific snapshot. If you do not define all these levels, you might experience various 
errors.

The time it takes to generate a snapshot depends on the number of specified data 
elements being extracted from the database. Therefore, you should carefully 
consider which elements you add to the snapshot list. Add elements only when the 
probability is high that inclusion of the extra information will boost counts and 
when adding elements avoids your having to generate the snapshot.

To add data elements to a snapshot

1 From the application-level menu, choose View > Site Map > Programs > My 
Program Plans.

2 In the Program Plans list, select the program and click the Stages view tab.

3 In the Stages list, drill down on the Stage Plan Name hyperlink.
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4 Click the Snapshot Contents view tab and review the Snapshot Contents list.

5 Add records to a snapshot.

a Create a new record.

b In the new record, click the appropriate select buttons for Measure, Bucket, 
Hierarchy Level, or Field.

c In the Pick dialog box, select the element from the list and click OK.

A check mark appears in the User Added field.

Modifying the Stage Plan Details of a Snapshot File
If you alter the definition of segments, output file layouts, source code format, or 
campaign load mapping, clicking Refresh updates the snapshot contents. If you add 
or delete filters, segments, output file layouts, or table constraints, you need to 
generate a new snapshot from the Program Flow workspace. The Snapshot Contents 
list refreshes automatically.

To modify the stage plan details of a snapshot

1 From the application-level menu, choose View > Site Map > Programs > My 
Program Plans.

2 In the Program Plans list, select the program and click the Stages view tab.

3 In the Stages list, drill down on the Stage Plan Name hyperlink.

4 In the Stage Plan Details form, complete the necessary fields such as Source 
Code Format and Campaign Load Mapping.

5 Click the Snapshot Contents view tab and review the Snapshot Contents list.

6 If the changes do not appear, click Refresh.
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Deleting a Snapshot File
If you have to create more space on your file server, you can delete old snapshot 
files. If there are no processes (for example, Load Campaign, Preview List or Update 
Counts) planned for the future or actively running against a snapshot file, you may 
delete it. Other than tasks such as these, which rely on information contained 
within a snapshot, snapshot files do not have dependencies on other processes or 
object definitions (such as Attribute or Measure definitions).

After you delete a snapshot file, attempting to run any task associated with that 
snapshot will cause the task to exit (fail). For example, if you delete a snapshot file 
for a campaign and then try to update the counts for that campaign, the Update 
Counts task will exit and log an error.

If this occurs, you should verify that the snapshot file exists. If it does not exist, 
regenerate the snapshot file and then process the tasks. If you accidentally delete a 
file that you need to use, you can recreate the snapshot by running the Generate 
Snapshot task again.

Use the following best practices to determine if you can delete a snapshot file:

■ Delete a snapshot file only when no campaigns are being loaded. This will make 
sure that you do not cause campaign load errors by deleting a snapshot against 
which a campaign load is actively running.

■ Verify that there are no other processes (for example, Update Counts or Preview 
List) currently running against the snapshot file you want to delete. 

■ Determine if any processes will require this snapshot file in the near future.

■ You might want to use the age of the snapshot file to determine if it can be 
deleted. For example, you could delete snapshots that were generated more than 
thirty days ago.

To delete a snapshot file

1 Navigate to the snapshot directory in your Siebel File System.
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2 Delete the files according to the guidelines in this section. By default, the 
snapshots directory is \\[siebelfilesystem]\marketing\snapshots.

In the directory path, [siebelfilesystem] represents your Siebel File System 
directory name.
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After you generate a snapshot, you can use the Allocation view to assign segment 
counts to specific campaigns. You can assign members of one segment to many 
campaigns, or members of many segments to one campaign.

Siebel Marketing allows flexibility in allocating segment net counts to campaigns. 
Customers can be allocated from multiple segments in a program to various 
campaigns for testing purposes, based on absolute numbers or percentages. If you 
generate counts by manually starting a snapshot from the Program Flow view, you 
can manually allocate the counts by adding values for Allocation and % Allocation 
fields in the Allocation form. You use Forecast Allocation if your program is set for 
automatic execution using Schedule. Forecast mode allocation is performed as part 
of the Program Execution workflow process. You use forecast allocation for 
automatic execution because once the snapshot is generated as part of the workflow 
process, you cannot change manual allocation numbers before list generation 
begins.

Deduplication of contacts is automatically handled during snapshot generation, 
making sure that contacts meeting criteria for more than one segment will not 
receive more than one offer in the same program stage.

If you have multiple segments, you can set the priority for each segment in the 
Allocation views. Duplicate contacts are then removed from the lower priority 
segments. Setting segment priority can be performed before a snapshot is 
generated, or following the snapshot generation. As a default, if you have more than 
one segment, each segment’s priority is set to 1. If you set the priority for each 
segment before snapshot generation, then no additional action is necessary. If you 
have more than one segment and change the priority of each segment after 
snapshot generation, you must refresh the displayed counts using the Update 
Counts functionality.
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If you manually generate a snapshot and segment counts are available, the 
Allocation view allows you to distribute segments to campaigns in a number of 
ways:

■ Allocating a specific percentage of the count for each campaign.

■ Allocating an even percent of the count across all campaigns.

■ Allocating the counts with a specific percent for one or more campaigns and 
distributing an even percentage of the remainder across the unallocated 
campaigns.

■ Allocation by priority.

For example, during basic allocation, you can allocate 50 percent of the contacts in 
Segment A to receive Campaign 1, and 50 percent of the contacts in Segment A to 
receive Campaign 2.

Using the campaign Waves and List Distribution views, segment counts can be 
allocated to a campaign with several vendors handling the distribution. For more 
information about campaign waves and vendors, see “Creating Vendor-Specific 
Lists” on page 480.

The Marketing Server allocates based on specified percentages. If these numbers are 
not integers, the count for allocation is rounded down and the remaining members 
are distributed to the campaigns. The Allocation view, however, displays the 
rounded-down count.

If a snapshot will be generated during automatic program execution, Forecast 
Allocation allows you to specify the percentage of contacts anticipated for each 
campaign, and, if desired, the maximum count allowed for each campaign in the 
absence of any real data.

These percentage counts can then be used when determining vendor-specific 
distribution lists. Forecasting is most often used when designing follow-up stages to 
a program.

NOTE: Switching from basic allocation with counts to Forecast Allocation clears 
previous counts and percentages.
468 Siebel Marketing Guide Version 7.5.3



Allocating Segment Counts to Campaigns
Before allocating segments to campaigns, you must perform the following tasks 
using the Program Flow and All Campaign Plans or My Campaign Plans views:

■ Define each campaign plan.

■ Assign segments to a program stage.

■ Assign campaigns to the segment.

■ Generate a snapshot (unless program execution is scheduled).

NOTE: In the Program Flow view, if you associate a campaign to a segment and then 
add another campaign, the second campaign is linked directly to the stage on the 
Program Flow workspace, until you complete allocation.
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Using the Allocation View
Allocation controls are accessible from the Stage Details view. Clicking the 
Allocation view tab displays the list of segments associated with the marketing 
program and the Allocation Detail list, which displays campaigns associated with 
the program. The active program is identified in the thread bar. To change the 
program and associated stage, choose All Program Plans or My Program Plans from 
the Show drop-down list.

■ Stage Detail. This editable form provides the details of the stage associated with 
the program and identifies key components such as the source code format, 
output file layout, campaign load mapping, filters, and so on. If you modify stage 
details in this form, make sure you save your changes.

■ Allocation and Segments. This list displays segments associated with the program. 
For segment details, click the segment name link to open the Edit Segment view.

■ Allocation Details. This list displays campaigns assigned to the program stage. 
Type a percentage in the % Allocation field, and save the record to automatically 
populate the Total Count and Allocation fields with counts for the campaign.

Allocating a Segment to a Campaign
Use the following procedure to allocate segment counts among campaigns when a 
snapshot has been generated.

To allocate a segment to a campaign

1 From the application-level menu, choose View > Site Map > Programs screen.

2 In the Program Plans list, select the program targeted for allocation and click the 
Stages view tab.

3 In the Stages list, click the Stage Plan Name hyperlink.
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4 In the Stage Plan Details form, complete the fields. Save the record to commit 
your changes.

If you plan to schedule your program for automatic execution, you will need to 
use Forecast Allocation. Select the Forecast Mode check box to enable Forecast 
Allocation fields in the Allocation Details list. Selection of Forecast Mode 
disables the Allocation and %Allocation fields. For more information, see 
“Forecasting Allocation” on page 473.

NOTE: When you use Forecast Mode for allocation, the allocation counts do not 
update on the allocation screen. They remain at zero.

5 In the Allocation list of segments, adjust the numbers in the priority field to set 
the priority for each segment used in the program. To view details of a segment, 
drill down on the segment name link to open the Edit Segment view.

A contact can qualify for more than one segment. If your program contains 
multiple segments, set a priority number, with 1 being the highest, to make sure 
that a contact that qualifies for every segment is counted in the one with the 
highest priority. If every segment has the same priority number, counts are 
proportionally distributed between the segments. 

If you change the priority of a segment, click the menu button in the Stages 
form, and choose Update Counts to recalculate Net Count. When this process is 
complete, the gross and net counts are updated according to the new priorities.

■ Gross (count). The Gross column indicates how many contacts qualify for 
each segment. A contact may qualify for multiple segments (for example, 
“Gold Customers,” “Longevity 16-19,” and “All Customers”) but Siebel 
Marketing assigns it to only one segment.

■ Net. The Net count shows the number of contacts Siebel Marketing assigned 
to each segment, based on the segment’s priority (deduplication). Siebel 
Marketing does not allow you to allocate more contacts for a segment than 
that value. For example, if the Net column shows 24,980 contacts for a 
segment, the contacts for campaigns assigned to that segment cannot exceed 
that value (unless you raise the priority of the segment and recalculate 
counts).
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If the Gross and Net columns do not have numbers in them, you must 
recalculate the counts by clicking Update Counts. Before doing so, prioritize the 
segments. For more information see Updating Counts and Clear Allocation 
Functions on page 475.

6 The Allocation and Allocation Details lists display segments and campaigns 
associated with the stage. Select a segment, and then a campaign to allocate Net 
Counts from the segment to the campaign. Use one of the following methods: 

■ In the % Allocation field, type the percentage of counts allocated to each 
campaign. The Total Count and Allocation fields are automatically updated 
with contact numbers when you save the record.

■ Type a number in the Allocation field.

The Total Count and % Allocation numbers automatically update when you 
save the record.

Using Other Allocation Methods
You can also allocate segments in two other ways.

To allocate segments

■ Even % for All Campaigns. In the Allocation list of segments, click the menu button 
and choose this option to distribute the net counts from the selected segment 
evenly across each campaign in the stage.

■ Even % for Unallocated Campaigns. In the Allocation list of segments, click the 
menu button and choose this option to evenly distribute any unallocated net 
counts from the selected segment to campaigns that have not received counts.
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Forecasting Allocation
Forecast Allocation is used when the program is scheduled for automatic execution 
using the Program Execution workflow process.

Switching to Forecast mode after traditional allocation counts have been returned 
clears those counts from the view. To return to basic allocation, clear the Forecast 
Mode check box in the Stage Detail form.

Forecast mode provides two controls for determining the number of contacts for 
each segment-campaign combination: Forecast Allocation and Forecast % 
Allocation.

■ Use the Forecast % Allocation field to distribute a percentage of a segment’s 
count to a campaign. 

For example, you might want 75% of a segment count to receive one campaign 
and the remaining 25% to receive a different campaign. 

In handling the response to a previous stage, you might create two segments: 
one for contacts who responded to the campaign, and one for contacts who did 
not respond. If you have two campaigns, a Welcome campaign for those who 
respond, and a campaign with a better offer for those who do not, you might 
allocate 100% of the responders for the Welcome campaign (0% of that segment 
would get the better offer). Then, you might set up 100% of those who do not 
respond to get the better campaign offer (0% of this group would get the 
Welcome campaign).

■ Use the Forecast Allocation (Max) field to set a limit on the quantity of contacts 
for each segment-campaign combination. For example, if you want a mailing of 
500,000 for one campaign, you might split that quantity between three 
segments.
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■ Combine the Forecast % and Forecast Allocation controls to specify an allocation 
percentage not to exceed a predetermined number. Siebel Marketing allocates 
based on the smaller number between a forecasted count and a % allocation. 

For example, you can specify a Forecast % allocation of 80%, with a maximum 
Forecast Allocation of 280,000. When the snapshot for that stage is generated, 
Siebel Marketing determines how many counts should be in each segment. For 
example, if the segment has 500,000, then 80% of that is 400,000, which is larger 
than the capped Forecast Allocation of 280,000. Siebel Marketing would allocate 
280,000 contacts to the segment-campaign combination.

If the segment had 300,000 contacts, 80% of that is 240,000, which is less than 
the capped Forecast Allocation value. Siebel Marketing would allocate 240,000 
contacts to the segment-campaign combination.

Using Forecast Mode
The following procedure describes how to use Forecast Mode for allocation.

To use Forecast Mode

1 From the application-level menu, choose View > Site Map > Programs screen.

2 In the Programs list, select the program targeted for allocation and click the 
Stages view tab.

3 In the Stages list, drill down on the Stage record hyperlink.

4 In the Stage Plan Details form, select the Forecast Mode box and save the record.

5 In the Allocation segments list, prioritize the segments associated with the 
program stage.

To change the priority of a segment, change the value in the Priority field.

6 In the Segments list, select a segment and select a campaign in the Allocation 
Details list.

7 In the Allocation Details list, type a Forecast Allocation, or a Forecast % 
Allocation, or both, depending on your allocation strategy.

To use only the Forecast Allocation, or the Forecast % Allocation, type a value 
in one of the fields and leave the other blank. 
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Repeat Step 6 through Step 7, selecting additional segments and campaigns and 
adding the forecast allocation.

When the snapshot is generated, the Gross and Net Counts fields are populated in 
the Segments list. The Gross count is the total count of those who met the segment 
criteria. The Net Count is the count after deduplication has been performed.

Updating Counts and Clear Allocation Functions
If you change the priority of a segment, change a segment definition in a way that 
does not affect the snapshot definition, or use a different allocation method, refresh 
the displayed counts. To refresh the counts, in the Stage Detail form, click the menu 
button and choose Update Counts.

To remove displayed allocation counts in the Allocation Details list, first select a 
segment and a campaign. Then, click the menu button in the Allocation Details list 
and choose Clear Allocation. Each allocation of a segment’s counts to a campaign 
must be cleared individually.
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If your marketing program consists of a one-time campaign and offer, and you are 
reasonably sure of the response, you probably do not need to define multiple waves. 
Siebel Marketing automatically provides a 100 percent fully allocated wave (with a 
wave code of A and a lag of 0) when a campaign is created.

If you are planning a multistage recurring campaign and anticipate a large 
distribution list of contacts that will receive an offer, you may want to take a 
measured approach to distribution and split fulfillment of the offer among a number 
of vendors.

Waves, or set distribution periods, are commonly used to:

■ Test the campaign concept. An initial sampling to gauge campaign response is 
followed by a larger distribution.

■ Examine the campaign mechanics. A measured distribution of the campaign offer 
provides information to guarantee the campaign mechanism works efficiently 
from order entry, to fulfillment, to response tracking.

■ Balance the load on a fulfillment center. In this case, each wave might consist of 10-
15% of the list to make sure existing resources can reasonably handle launching 
a campaign, including managing campaign responses.

In addition to setting up waved distribution periods, you can set a lag time for 
additional waves that reference the stage launch date, and then split the generated 
list by a percentage of contacts for each wave period. You can also split by a List 
Measure. The measure must be included in the list to be available for use in splitting 
the list.

Waves can be used only with campaigns that are launched through Siebel 
Marketing. Typically, these are email campaigns or campaigns that send a list to an 
outside vendor. Wave functionality does not apply to campaigns processed 
internally such as those through Siebel Call Center or Siebel Sales.
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Use the Campaigns screen’s Waves view tab to define distribution waves or time 
periods for the specified campaign. You can use the List Distribution list to specify 
a percentage of contacts in each wave that will be sent to each vendor, as well as 
the output file layout and the method for distributing the list.

Before creating a second wave, decrease the number in the % field of the first wave, 
which, by default, is 100%. The percent number for all waves cannot exceed 100.

To set up multiple waves

1 From the application-level menu, choose View > Site Map > Campaigns > My 
Campaign Plans.

2 In the Campaign Plans list, select the campaign.

3 Click the Waves view tab.

4 In the Waves list, create a new record.

5 Complete the necessary fields, using Table 70 as a guide and save the wave 
record.

Table 70. Fields in the Campaign Waves Form

Field Comment

% The default percent is 100 for a single wave. If you are planning 
multiple waves, first reduce the percentage number in the first wave 
and type the percentage of contacts that will be included in the 
second wave. The total percent for all waves cannot exceed 100%.

Count This field shows the corresponding number of contacts to be included 
in the wave. The number in this field is automatically calculated 
when you save the record.

It is possible for the displayed count to be one less than the actual 
count in the wave, due to rounding functionality.

Description Describe the characteristics of the wave.
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Lag (Days) The default is 0. Type the number of days the wave is delayed after 
loading a campaign. The maximum lag for all the waves cannot be 
greater than number of days between the start date and end date of 
the campaign.

The wave is launched when the server processes the Load Campaign 
request. 

This server process can be automatic, using a scheduled program 
launch or can be manually started using the right-click menu in the 
Program Flow workspace.

Wave Code Type a wave code, up to 10 characters. You cannot save the record 
without a wave code. The wave code appears as part of your 
program’s source code if you have set up the source code format to 
include it. The wave code for the default wave is A.

Table 70. Fields in the Campaign Waves Form

Field Comment
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In addition to splitting target contacts in your distribution list by wave, you can also 
split the contacts in each wave by vendor.

Before you set up vendor distribution, make sure you have defined an output file 
layout, vendor profiles, and distribution method profiles (if you are using email or 
FTP to deliver the list to the vendor). The output file layout must be specified in the 
Stage Details form. For more information, see “Working With Output File Layouts” 
on page 183, “Defining Distribution Profiles for Vendors” on page 193, and “Using 
Delivery Profiles - Email, eNewsletter, and Fax” on page 294.

For example, you create three waves for a selected campaign. You set up the list for 
the first wave, with a count of 500,000 (50 percent of the total), to be split equally 
between two vendors (each with approximately 250,000 names). If each wave’s 
contacts is split between two vendors, a total of six lists will be generated.

You can also split the distribution list by list measures. To be used, List measures 
must be included in the snapshot.

If you are splitting by list measures, Siebel Marketing creates a separate file for each 
unique value that it finds. For example, if you select CUSTOMER_STATE as the list 
measure, Siebel Marketing creates a separate file for each state it finds.

To set up vendor-specific lists

1 From the application-level menu, choose View > Site Map > Campaigns > My 
Campaign Plans.

2 In the Campaign Plans list, select the campaign and click the Waves view tab.

3 In the Waves list, select the wave.

4 In the List Distribution list, create a new record.
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5 Complete the necessary fields for each vendor, using Table 71 as a guide, and 
save the record.

Table 71. Fields, List Distribution Form

Field Comment

% Type the percentage of contacts that will be distributed to this vendor.

Distribution 
Method

This read-only field displays the defined distribution method associated 
with the vendor. For more information on defining distribution 
methods, see “Setting Up Vendor Profiles” on page 190.

File Format Choose the File Format from the list. The options are ASCII-Comma 
Separated, ASCII-Fixed Length, and EBCDIC-Fixed Length.

EBCDIC stands for Extended Binary Coded Decimal Interchange Code. 
This standard code uses 8 bits to represent each of up to 256 
alphanumeric characters.

Header This check box sets the header flag for the output list. If the flag for a 
header was set in the Output File Layouts view, this column contains a 
check mark.

A header includes the following information in the following order:

■ Stage name.

■ Campaign source code.

■ Vendor name.

■ Wave source code.

■ List format ID.

■ Location of the output list (path and timestamp).

■ Record length (the sum of the width of the components in the output 
file layout).

■ Column headers.

Output File 
Layout

Choose the output file layout from the list. To be available for selection, 
the output file layout must be associated with the program stage that the 
campaign references. 

Measure Name If you are splitting the list by a measure, click the Measure name select 
button. In the Measures dialog box, choose the measure from the list 
and click OK. The measure must be included in the output file layout 
associated with the stage.
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Seed Flag The Seed Flag (that indicates whether a seed list will be automatically 
merged with the distribution list) is set to No as a default, until the 
output file layout is selected. The seed list is associated with the 
generated list in the Output File Layouts view in the Marketing 
Administration screen.

If you did not associate a seed list with the list in the Output File Layout 
view, the field value will remain as No.

If a seed list is associated with the Output File Layout, and the seed flag 
is not selected, the seeds will not be added to the generated list.

Vendor Choose the vendor from the list of predefined vendors. For more 
information on setting up a vendor profile, see “Setting Up Vendor 
Profiles” on page 190.

Table 71. Fields, List Distribution Form

Field Comment
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Using Siebel Marketing you can create output lists of contacts for export to a 
fulfillment partner or another application. Direct mail vendors often require specific 
formatting of campaign lists. When a campaign is ready for launching, the target 
list may be exported according to a flexible list format, and distributed using FTP 
or email. You can define, manage, and preview the list format without the 
intervention of a system or marketing administrator. Default formats can be 
assigned for each vendor.

After a snapshot is generated, you can preview a sample of the list to determine if 
the output file layout is what you want, and then generate the actual distribution 
list that will be sent to vendors.

NOTE: If your program stage does not include any segments, Preview List will not 
work. When you generate a snapshot, a snapshot file is only created if a campaign 
contains a segment. When a campaign has a list (and no segment) in the program 
flow, generating a snapshot creates a campaign and no snapshot file. For more 
information, see “Generating a Snapshot File” on page 457.

Lists generated from your snapshot data contain names, addresses, and other 
information about individuals who will receive a particular campaign offer. After a 
list has been generated, the records in it will not change even when the contacts 
and prospects who meet the segmentation criteria change.
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Lists can be generated manually using a Program Flow workspace menu command 
(Load Campaign) or automatically scheduled as part of a program launch using the 
Schedule view. When you load a campaign, Siebel Marketing generates vendor and 
eAI list files, and associates imported lists of contacts and prospects with the 
campaign. The eAI list files are used to populate the campaign table S_CAMP_CON 
in the Marketing Repository. S_CAMP_CON contains the history of who was 
contacted in which campaign. 

NOTE: Because lists are based on the content of the snapshot file, changes made to 
the campaign contacts and prospects after the campaign is loaded will not be 
reflected in any output lists.

For more information on mapping to external data sources (eAI files), see 
Chapter 4, “External Data Mapping.”
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Previewing a List
Use the procedure that follows to create a sample list that you can preview. The 
sample includes a maximum of 500 records and a proportional number of seeds. A 
sample list contains the following information:

■ The identifier (name) of the preview file that is saved in the file system directory.

■ Example: P-31L200B 0001, P is the prefix for a previewed list.

■ The wave code identifies the wave that has a generated list associated with it.

■ The vendor assigned to receive the generated list.

■ The list format assigned to the campaign list.

■ The split value, if the list has been split by a measure.

■ The last time list values were modified.

Before you can preview a list, you must specify a vendor for list distribution using 
the Campaigns screen’s Waves view tab, and the List Distribution list. If Siebel Call 
Center is the list recipient, rather than a vendor, Preview List is unavailable.

CAUTION: If the RequestServer parameter is not configured correctly in the client.cfg 
file, an error occurs and you will see the following error message: Internal: 
Communication protocol error while instantiating new task.

To preview a list

1 From the application-level menu, choose View > Site Map > Programs > My 
Program Plans.

2 In the Program Plans list, select the Program, and click the Stages view tab.

3 In the Stages list, drill down on the appropriate Stage Plan Name hyperlink.

4 Click the Preview List view tab.

5 In the Preview List list, select the campaign list record.
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6 Scroll down to the Output Lists list and click Preview Sample. 

The Siebel Marketing Server extracts a sample of the list, and applies the list 
format. A record displays in the Output Lists list when the list preview is 
generated. However, you must refresh the view before the record displays. to 
refresh the view, leave the view and then return to it.

NOTE: If you generate the preview list again, the previous preview record will be 
replaced by a new record.

7 In the Output Lists list, click the Name hyperlink.

A window appears containing columns headed by elements included in the list 
format, and corresponding data related to the contact.

Waves, Distribution Lists, and List Previews
When you set up campaign waves, you first define a wave. Then, if the wave 
involves providing a list of contacts to a vendor, you provide the vendor information 
for each wave in the List Distribution list. 

If you do not specify a vendor for a wave, Siebel Marketing assumes you want to 
launch the campaign through the Siebel Campaign Execution Channel (Call Center, 
email, and so on) and does not generate a Preview List of contacts from that wave.

For example, your campaign has 420 contacts that will receive the offer in two 
distribution waves. Wave A will distribute the offer to 50 percent (210) of the 
contacts, and Wave B will distribute the offer to the remaining 50 percent (210).

However, a vendor has only been identified in the List Distribution list for Wave B. 
When you request a List Preview, the List Preview window displays a preview of 
the list of 210 contacts that will be sent for Wave B.

Previewing Lists That Will be Split by Measure
If you have defined a list distribution that will be split by a measure, Preview Lists 
will provide a sample of each split list. The Export Lists view also displays the split 
value. For more information on splitting a list by measure, see “Working With 
Output File Layouts” on page 183.
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Manually Loading a Campaign (Generating a List)
The following procedure explains how to manually generate a list from the Program 
Flow view. When you manually load a campaign, the scheduled task will not 
appear in the program’s Schedule calendar view. For more information, see “Using 
the Schedule Calendar View” on page 535.

For information about loading a campaign (generating a list) automatically, see 
Chapter 21, “Launching Programs and Campaigns.” 

To generate a list

1 From the application-level menu, choose View > Site Map > Programs > My 
Program Plans.

2 In the Program Plans list, select the program.

3 Click the Program Flow view tab.

The Program Flow workspace appears, containing stage, segment, and 
campaign objects.

4 In the Program Flow workspace, select the campaign plan object, right-click, and 
choose Load Campaign from the menu.

5 In the Manual Execution - Load Campaign dialog box, select the campaign 
name. If there are no campaign names, click Submit.

Loading a campaign plan creates the campaign record and links it to the selected 
stage occurrence.

NOTE: To generate the list at a later time, adjust the displayed date and time in 
the Manual Execution - Load Campaign dialog box.

6 Click Submit to queue the server task.
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To check the status of the server task

1 From the application-level menu, choose View > Site Map > Server 
Administration > Components. 

2  Locate the Marketing Server task state. 

The task state should be running, and the status field should contain the stage 
identifier and Counter List. 

3 When list generation completes, the status field should read Completed.

Understanding the Load Campaign Workflow Process
Siebel Business Process Designer shows the process flow. In the Business Process 
Administration screen, select the Campaign Load workflow process and click the 
Process Designer view tab. 

When you manually load a campaign, or as part of an automatic program execution, 
the following events occur:

■ A campaign record is created and associated information such as offers, teams, 
organizations, expenses, and so on is copied from the campaign plan. If an error 
occurs during the campaign load process, the status field for the campaign 
record shows Error and the error message appears in the Status field. 

■ A distribution list of contacts is generated by the Marketing Server.

■ Data is imported from an external data source according to the external contact 
mapping designed using the Campaign Load Mapping view and eAI technology.

■ Internal or purchased list contacts are assigned to campaigns for internal 
loading.

■ If the program has been launched automatically, campaign launch occurs, and 
the campaign record is marked as Finished.

■ The Campaign Launch workflow process creates the WfProcMgr_identifier.log 
file containing detailed information about the CommOutboundMgr requests 
submitted for vendor lists and offers to campaign recipients. Each submitted 
request includes a SRM ID and a description.
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For more information on workflow processes and the Siebel Business Process 
Designer, see Siebel Business Process Designer Administration Guide.

Viewing Exported Lists
Use the Exported Lists view to display lists generated for vendors by campaign.

The Exported List view provides the name of the exported list file, the number of 
records in the list, the designated distribution wave, the vendor receiving the list, 
the list format, seed count (if seeds have been included), and the list split by 
measure value. The exported list file is located in the \\filesystem\Marketing\Lists 
directory.

To view exported lists

1 From the application-level menu, choose View > Site Map > Campaigns > My 
Campaign Plans.

2 In the Campaign Plans list, select a campaign plan and click the Status view tab.

3 In the Status list, locate a campaign and drill down on the campaign name.

4 Click the Exported Lists view tab.

5 In the Exported Lists list, you can display other views using the following steps:

a To display the Vendors view with details, drill down on the Vendor name.

b To display the Output File Layout view with details, drill down on the List 
Format name.
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The List Management module is available to users with a license for Siebel 
Marketing or Siebel Campaigns. 

NOTE: The Siebel Campaigns module can be added to any base application, 
including Siebel Sales, Siebel Call Center, Siebel PRM.

List Management allows you to create and manage lists of contacts and prospects 
within Siebel applications for use in marketing campaigns. A list in Siebel Marketing 
is a grouping of contact or prospect records in the Siebel database.

Contacts are customers already in the Siebel database. Prospects are potential 
customers that have yet to be screened, qualified, and promoted to contacts. By 
using this distinction, List Management allows you to eliminate prospects that do 
not qualify for promotion to contacts.

For example, you rent a magazine subscriber list containing 1,000 names and 
addresses. You want to contact these people, but because the list is rented, you may 
not add the records into your Siebel database as contacts unless they become 
customers generating revenue. You must be able to remove the names from your 
database when you return the list. Siebel List Management allows you to identify 
these names and addresses as prospects until they can be promoted to contacts. For 
information about promoting prospects to contacts, see Siebel Call Center User 
Guide.

To create, manage and maintain lists, perform the following tasks:

■ “Importing and Managing External Lists” on page 493. List Management allows 
you to import any external file of customer names and their associated contact 
and profile information.
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■ “Creating and Managing Internal Lists” on page 508. You can use List 
Management to create and maintain lists created from records that already exist 
in your Siebel database.

■ “Promoting Prospects” on page 514.

■ “Viewing and Maintaining Lists” on page 519.

■ “Integrating List Management with D&B” on page 523. For customers who have 
licensed Siebel Dun & Bradstreet Integration Solution for Siebel Sales or another 
Siebel application, List Management allows you to use lists of prospects 
generated from the D&B source data in marketing campaigns.
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Importing and Managing External Lists
External lists are created by importing an external file into your Siebel application 
using the List Import utility. Imported lists can come from any source, as long the 
list can be saved in one of the supported file formats, including Comma Separated, 
Tab Delimited, and Fixed Width. Common examples of list sources include rented 
or purchased lists from marketing bureaus, registration lists from trade shows or 
events, and output lists from other applications.

When you integrate Siebel Marketing or Siebel Campaigns with Siebel Data Quality 
(optional module), incoming records can be cleansed and matched against all 
existing contacts and prospects in the database. This helps prevent creation of 
duplicate records for incoming prospects that are already contacts. For information 
about Siebel Data Quality, see Siebel Data Quality Administration Guide.

To import and manage external lists, perform the following tasks:

■ Prerequisites for Importing External Lists

■ Importing External Lists on page 496

■ Launching Import Requests and Tracking the Import Status on page 500

■ Importing Campaign and Response Data on page 501

■ Maintaining Attributes for List Records on page 503

■ Mapping Fields on page 504

■ Using List Import Formats on page 505

■ Editing the List Import Format Settings on page 506

■ Understanding Import Status and Error Messages on page 507

Prerequisites for Importing External Lists
Before importing a list, you need to perform the following tasks:

■ Verifying Status of Server Components and Tasks on page 494

■ Verifying Data Quality Settings on page 494
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■ Validating the Structure of the Incoming Data on page 496

Verifying Status of Server Components and Tasks
Before importing a list, you need to verify that server components are enabled and 
that server tasks are running.

To enable server components and run tasks, you can use two views on the Server 
Administration screen: Components and Tasks. For more information, see the Siebel 
Server Administration Guide.

Make sure that the following server components are enabled and the following 
server tasks are running:

■ List Import Service Manager: Enabled.

Clicking Launch Import in the List Import view tab of the List Management 
screen submits the import request. The actual import is performed by the List 
Manager server component on the Siebel Server. 

■ Server Request Processor: Running.

■ Server Request Broker: Enabled or running.

To import a list, you must be connected to the Siebel Server. If the Siebel client 
cannot detect a running Siebel Server at the time you launch the import, you will 
receive a warning message. You can continue to submit the import request if you 
are sure that a Siebel Server will be available to handle the request later. 

For the request to be queued, you must have a Siebel Gateway Server running in the 
background. The request will be routed through the gateway server to a Siebel 
Server which has the List Import Service Manager server component enabled. If you 
do not have a gateway server running, you will receive an error message saying 
“Unable to connect to gateway server.”

Verifying Data Quality Settings
When you use the optional Data Quality module, you should verify your settings for 
the following server components before importing files:

■ Data Quality Manager.

■ List Import Service Manager.
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■ The object manager for the application in which your users promote prospects. 
For example, if you promote prospects using Call Center, you need to enable the 
Call Center Object Manager.

For instructions, see “Determining Component Group Status” on page 35. If you 
need to enable a server component, see “Enabling and Synchronizing Component 
Groups” on page 35. For more information about data quality configuration, see 
Siebel Data Quality Administration Guide.

1 Verify that these server components are set to Enabled.

2 Verify the component parameters for these server components are set for 
deduplication and data cleansing.

■ If you want to enable Data Matching, use the Components view in the Server 
Administration screen and query for each of these server components. Click 
the Component Parameters view tab and query for the DeDuplication 
parameters. The DeDuplication Enable Flag should be set to TRUE.

■ If you want to enable Data Cleansing during import, query for the Data 
Cleansing parameters. The Data Cleansing Enable Flag should be set to 
TRUE.

3 Verify the matching threshold for List Import. The Match Threshold setting in 
the Data Quality Settings view of the Data Administration screen determines if 
an incoming name is considered a match with existing data. To specify a 
different threshold for List Import than the rest of the Data Quality module, 
navigate to the Components view of the Server Administration screen and select 
the List Import Service Manager. Click Component Parameters and query for 
Dedup Threshold. Set the value to the match score threshold that you want to 
apply to the List Import utility.

CAUTION: Reboot Siebel Server before launching any import tasks so that new 
parameter values take effect.

4 Make sure that you set the Data Quality Settings in the Data Administration 
screen. You should generate and refresh the match keys for the existing contact 
and prospect data before importing any files. 
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Validating the Structure of the Incoming Data
Some columns for a prospect correspond to an LOV or MLOV field in the 
application. Be sure that your incoming data for these columns only use values from 
the LOV or MLOV. Any nonmatching values will automatically be set to NULL in the 
new prospect record.

The date format is set by the system settings for the machine on which the Siebel 
Server is running. For date fields, you should make sure you use the correct date 
format that corresponds to the locale settings for your Siebel environment. 

Importing External Lists
Lists that you import must be in text (.txt) format. When you import a list, List 
Management performs the following tasks:

■ Loads the list names into the prospects table as individual records.

■ Allows you to set the import mode so that matches between incoming names 
and existing records can be handled according to your requirements.

■ Allows you to save and reuse the file structure you develop during the import 
process by mapping the columns of the file. 

■ Controls the matching and address cleansing settings applied by Siebel Data 
Quality (optional module).

When the import is finished, the imported list and its associated contacts and 
prospects display in the List Contacts and Prospects form.

NOTE: Imported records remain in the EIM_PRSP_CON interface table, unless you 
delete them. This causes the table size to increase every time you import a list. You 
might need to delete these records periodically to improve performance. To delete 
them, use standard SQL truncate or delete commands when no list import task or 
EIM task for this interface table is running. For example, DELETE FROM 
<table_owner>.EIM_PRSP_CON where IF_ROW_BATCH_NUM > 100000000.

Before you can import an external list, you need to perform the following tasks:

■ Creating a Record for Importing an External List on page 497
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■ Selecting the List Import Mode on page 498

■ Mapping External List Columns to Database Columns on page 500

Creating a Record for Importing an External List
Before you import an external list, you must create a record in your Siebel 
application that describes the list. This record tells the list import utility what file to 
import.

To create a record for importing an external list

1 From the application-level menu, choose View > Site Map > List Management 
> Lists.

2 In the Lists list, create a new record and complete the fields.

Some fields are described in Table 72.

3 Save the record.

Table 72. Fields Used to Create a List Record

Field Comments

Data Type List Import attempts to determine the format of the attached text file. Values 
are:

■ Fixed Width

■ Comma Delimited. If the first row of data in the file contains a comma in 
any of the field values, it is recommended that you use tab delimited 
format to make sure that the correct file format is detected.

■ Other Delimited. You can enter another character as the delimiter. If you 
attempt to add >1 character, the value will be truncated.

■ Tab Delimited

List Name Required. This field is automatically generated when you add the record but 
you can modify the name.

List Type Automatic. The possible values are Imported, Internal and D&B. If the file 
type is incorrectly detected during attachment, you can change it.

Source The company from which the list was purchased. The company must be an 
account record in the Siebel database.
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Selecting the List Import Mode
If you use the Siebel Data Quality optional module, you need to specify how you 
want duplicates handled before importing a list. If Data Quality is not enabled, new 
prospect records will be created for all incoming data no matter what mode you 
select. For more information, see Siebel Data Quality Administration Guide. You can 
choose one of the following modes:

■ Skip Incoming Duplicates Mode. In this mode, if a match is detected by the Data 
Quality business service, any incoming records matching existing contacts or 
prospects will not be added as new records in the database. Instead, the 
matching record which already exists in the database will be associated with the 
list. Each skipped record is recorded in the List Import log file for reference.

If the incoming record matches more than one existing record, all the existing 
matches will be added to the list and the duplicates will be noted in the List 
Import log file.

■ Update Existing Duplicates Mode. In this mode, if a match is detected by Data 
Quality, any incoming records can overwrite the existing match in the database. 
The columns that are allowed to be overwritten are set by the administrator for 
the List Import Format used by the file. To set which fields will be updated by 
an incoming record, navigate to the List Import Formats view in the List 
Management screen and select the Allow Field Updates check box. For reference, 
the List Import log file records all records that are updated as well as the old and 
new values for any updated fields. 

If you use Update Existing Duplicates as a list import mode and an imported field 
value does not match any value on the bounded LOV, then the application will 
not change the field on the existing prospect record (the original value is 
preserved).

NOTE: Update Existing Duplicates Mode only updates prospect records. It will not 
update contact records.
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■ Resolve Incoming Duplicates Mode. In this mode, matches are detected but the 
incoming record is added to the database without changing or overwriting the 
preexisting record. This allows the administrator to resolve any matches later on 
a case-by-case basis or by using the Siebel Data Quality module. To resolve 
duplicates, you can use the Duplicate Prospect Resolution view tab in the Data 
Quality view of the Data Administration screen. In Resolve Mode, all matches 
are recorded in the List Import log file.

To select an import mode

1 From the application-level menu, choose View > Site Map > List Management 
> Lists.

2 In the Lists list, select your list.

Some fields are described in Table 73.

3 Click the List Import view tab.

4 In the List Import Mode drop-down list, select the import mode that you wish to 
apply. 

For more details, see “Selecting the List Import Mode” on page 498.

5 Save the record.

Table 73. Fields Used for List Import view

Field Comments

Additional Actions Assign to Campaigns, Responses, or Campaigns and Responses. 
Used whenever the import file contains campaign history or 
response data about contacts and prospects. For more information, 
see “Importing Campaign and Response Data” on page 501.

Clean A check box for which the default is off. When this flag is 
checked, incoming records are cleansed by Siebel Data Quality. If 
your company has not licensed Siebel Data Quality, this feature is 
not functional.

List Import Format Indicates the saved column sequence for the file. Formats can be 
reused across lists. For more information, see “Using List Import 
Formats” on page 505.

List Import Mode For descriptions, see “Selecting the List Import Mode” on page 498.
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Mapping External List Columns to Database Columns
Every column in the file you want to import must be mapped to an existing column 
in the prospects table in the Siebel Database or to an attribute created for this 
purpose. If you import response or campaign data, you can also map to response 
and campaign fields. For information about mapping attributes, see “Adding 
Additional Attributes to a List” on page 504.

CAUTION: Make sure that you map every column before launching the import.

To map list columns to database columns in the prospect table

1 From the application-level menu, choose View > Site Map > List Management 
> Lists.

2 In the Lists list, select your list.

3 Click the List Import view tab.

4 Scroll down to the List Import Format list and map every column to an existing 
database column in the prospect table or to an attribute created for this purpose.

5 In the List Import Format list, save the format in one of the following ways:

a The first time you save a format, click Save as New.

This allows you to retain the original format and save the modified format 
separately. All saved formats appear in the List Management screen’s List 
Imports Formats view tab. 

b Click Save to overwrite the original format.

Use this save option if you make changes to the mappings and want to 
preserve them.

Launching Import Requests and Tracking the Import Status
After creating a list record, identifying the import mode, and mapping list columns 
to database columns, you can import the list and then track the request’s status.
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To launch a list import request

1 From the application-level menu, choose View > Site Map > List Management 
> Lists.

2 In the Lists list, select the list you want to import.

3 Click the List Import view tab.

4 In the List Import form, click Launch Import.

To track the status of an import request

After you submit the import request, the status field on the List Import list contains 
a value of In Progress. You can refresh this view to track the status of your request. 
When the import is finished, the status field contains a value of Successfully 
Completed.

NOTE: You can review the List Import task status in the Components view in the 
Server Administration screen. In the Component Tasks list, select tasks for the List 
Import Service Manager. Alternatively, you can review List Import log files stored in 
the Siebel file system.

Importing Campaign and Response Data
List Import can be used to import campaign and Response Data about contacts and 
prospects. For example, your company might run a campaign against a target list of 
contacts, but collect the responses in an external system or through an outside 
service company. You can import the response results from these sources and 
attribute the responses to the original campaign.

The List Import view provides the following additional actions that you can use to 
include response and campaign data in the file:

■ Assign to Responses. This action will create response records for all the contacts 
or prospects in the list. The action will not add, delete or modify the set of 
contacts and prospects already associated with the campaign.

■ Assign to Campaigns. This action will add the contacts and prospects in the 
import file to the campaign included in the file. This action will not create any 
response data.
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■ Assign to Campaigns/Responses. This action will take contacts and prospects 
records from the import file, add them to the campaign, and create responses for 
them.

Campaign and response data will not be created unless you select one of these 
additional actions, even if you mapped response or campaign fields. If you do not 
select an additional action, the import utility ignores response and campaign 
columns and only creates a list of contacts and prospects.

Mapping Response and Campaign Fields
The List Import view includes the following response and campaign fields for 
mapping import data:

Response fields. Fields are Response Description (required), Response Type 
(required), Response Method, Response Status, Response Date, Response Score, 
Offer Name (required), Offer Code, and Offer Language.

Campaign fields. Fields are Campaign Name (required) and Campaign Source Code.

When mapping, response and campaign fields, be sure to map all the fields required 
to create a response in the application. The import provides some default values if 
the user does not include all the required fields.

■ If you do not specify Offer Name, the response defaults to the primary offer for 
the campaign.

■ If you do not specify Response Type, the type defaults to Unclassified Response.

■ If you do not specify Response Description, the type defaults to the user and time 
that the record was imported.
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If you enable the response business service that performs automatic lookups for 
Campaign Source Code and Offer Code, you can map the Campaign Source Code 
and Offer Code fields as an alternative to Campaign Name and Offer Name. In this 
case, the import utility performs the lookup and default to the related Campaign 
Name and Offer Name automatically. For more information, see “Using Response 
Management” on page 377.

NOTE: The Campaign Source Code field in the List Import mappings indicates the 
source code value assigned individually to each Campaign Contact and Prospect. It 
does not refer to the Source Code field in the Campaign record (the field displayed 
on the Campaign form).

Maintaining Attributes for List Records
Prospects have a predefined set of information fields standard in the application. 
These are the standard types of information about your prospects that normally 
include address, phone number, email address, and so on. These values are defined 
in Siebel Tools under the Prospect Business Component.

If the list you want to import has attributes not contained in the standard Siebel 
prospect table, you can create additional attributes in order to capture the data. 
Once created, additional attributes appear on the list of available columns that can 
be mapped in the List Import view. 

An additional attribute can contain any type of information, as long as it can be 
contained in a single field and can relate directly to the prospect record. For 
example, additional attributes might include hobbies, special contact information 
(for example, pager #), product interests, survey responses, or demographic 
attributes.

Creating Additional Attributes for List Records
In order to make an additional attribute available during list mapping, you must first 
make sure your desired attribute exists and then associate the attribute with the 
specific list.
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To create additional attributes

1 From the application-level menu, choose View > Site Map > List Management 
> Additional Attributes.

2 In the Additional Attributes list, create a new record.

3 In the Additional Attribute field, type the name of the new attribute.

This is where you create the overall attribute type such as Hobby or Pager #.

4 Type a description for the additional attribute, if needed.

Adding Additional Attributes to a List
After you create the additional attributes needed to capture all the data in the list 
you want to import, you must add them to your specific prospect list and map them 
to one of the List Import columns.

To add additional attributes to a list

1 From the application-level menu, choose View > Site Map > List Management 
> Lists.

2 In the Lists list, query to find the list.

3 Click the List Additional Attributes view tab.

4 In the List Additional Attributes list, create a new record.

5 Complete the fields and then click OK to add the attribute to the list.

Mapping Fields
After you import a list, you must map the fields in the imported list to the fields in 
the Prospect Business Component. When you do this, the values in the list fields 
are transferred accurately into the correct fields in the prospect records.

When there is a dedicated column in the prospect table, you should map fields in 
the imported list to existing fields in the prospects record. Try to avoid mapping 
fields to additional attribute columns in the database extension table.
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To map fields when importing a list

1 Determine if an Additional Attribute exists for each special column in the import 
file that does not map to a Prospect field. 

2 Create additional attributes, if required.

3 Associate the attributes with the list using the List Additional Attributes tab.

4 Navigate to the List Import tab. At the top of each column in the external list, 
select the appropriate field or attribute to which the column should be mapped.

5 Click Save as New to save the List Import Format.

6 At the top of each column in the external list, select the appropriate prospects 
record attribute to which the column should be mapped.

7 Create additional attributes for columns in your list which have no 
corresponding prospect field.

Using List Import Formats
 Before you import a file, you must save the List Import Format (the sequence of 
columns that correspond to your file). The list format name consists of the list name 
followed by the saved date/time stamp. For example, My Target List 09/1/2003 
12:30:15pm. You can rename the list by navigating to the List Import Formats view 
and editing the record in the list. For more information, see “Mapping External List 
Columns to Database Columns” on page 500.

To apply an existing List Import Format to your list

1 From the application-level menu, choose View > Site Map > List Management 
> Lists.

2 In the Lists list, run a query for the list you created.

3 Select the list and click the List Import view tab.

NOTE: Make sure the list is of type Imported and has a file attached. If no file is 
attached, you will receive an error message.

4 In the List Import Formats field, click the select button.
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5 In the List Import Formats dialog box, select the format you wish to use. If 
necessary, perform a query to locate the format.

NOTE: You may not be able to apply an existing format to a fixed width file if the data 
was originally created for comma separated or tab delimited file. For .csv or tab 
delimited files, the column width value defaults to 20, and this may not match the 
width of the fixed width file that is being used.

Editing the List Import Format Settings
You can administer the precise settings associated with your list import format. If 
the Import Format is to be used in Update Mode, you can specify which columns 
are allowed to be overwritten in the database. You can see which columns are set 
to be overwritten by looking at the Allow Field Updates column in the lower list. If 
the column is checked, that field will be overwritten in any existing prospect record 
that matches the incoming record. By default, all columns are unchecked, so that 
no existing information can be overwritten without the administrator’s consent.

For files with a fixed width file type, the server will automatically detect the column 
width and display the width in the List Import Formats view. To see the column 
width settings, from the Show drop-down list, select List Import Formats and in the 
List Import Formats list, select the list that relates to your list. If the List Import 
Format was originally created from a comma separated or tab delimited file, the 
value will default to 20, although the width will not have any effect during the 
import task.

NOTE: Columns mapped to Additional Attributes cannot be updated in Update Mode. 
If you check Allow Field Updates for this column in the List Import Formats view, 
the system will ignore the setting.

List Import can load a text file in one of three types: comma separated, tab 
delimited, or fixed width. For files with a fixed-width data type, you can specify the 
width of each column. The default width is 20. In the bottom list, you can see the 
column sequence that you have defined in the List Import list. Type the width in the 
Width field. 
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Understanding Import Status and Error Messages
When you launch an import task, the List Import list will display the status of the 
task. The status may show any of the following messages: Submitted Import 
Request, In Progress, Successfully Complete, Error, or Completed with Errors.

You can view the detailed results of the List Import task by reviewing the log file 
from the Siebel Server. The log file contains the following information:

■ The status of the file import task (in progress, completed, error)

■ The number of incoming records

■ The number of records imported

■ Notification of any record that experienced an error

■ Notification of any record that detected a duplicate contact or prospect

■ Notification of any record that was updated (update mode only)

■ Notification of any response record or associated campaign that experienced an 
error

To view the log file for an import task

1 From the application-level menu, choose View > Site Map > Server 
Administration > Components.

2 In the Component list, query for List Import Service Manager in the Name field.

3 Scroll down to the Component Tasks view tab.

You will see component tasks for the import. There may be more than one task 
for the import job based on the Max Tasks parameter for the server component. 

4 In the Component Tasks list, drill down on the Task field hyperlink to view the 
Task Information Log.

NOTE: To review the List Import log file stored in the Siebel file system, click the 
List Import view tab.
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Creating and Managing Internal Lists
List Management allows you to create lists of contact and prospect records stored 
within your Siebel applications. Internal lists are created within the List 
Management module by querying existing contact or prospect records in the 
database. Once you have created these lists, you can reuse the list any number of 
times for campaigns. Lists are used by Siebel Marketing and Siebel Campaigns.

To create and manage internal lists, perform the following tasks:

■ Using Prospect Lists in Siebel Marketing

■ Creating Internal Lists on page 510

■ Adding to Internal Lists on page 511

■ Creating Lists of Prospects Using Additional Attributes on page 511

Using Prospect Lists in Siebel Marketing
Siebel Marketing Server creates contact records from snapshot segments during 
campaign load. To load prospects, use the following options:

■ Use Siebel List Management to load prospect lists into the Siebel transactional 
database and assign them to campaigns in the programs flow view.

■ Responses can be associated with prospects but responses for prospects 
cannot be captured without promoting the record to a contact.

■ If you install Siebel Data Quality, you can eliminate duplicate names that 
exist in prospect lists.

NOTE: List Management lists cannot be used by Siebel Marketing to create target 
group segments.

■ Extend the Contacts table to flag prospect records.

■ Prospects from external data sources or from the W_CONTACT_DM table can 
be loaded into the Siebel transactional database to execute campaigns and to 
track responses.
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■ To use this approach for Siebel List Management prospects, map directly to 
the Siebel database tables that hold prospect lists (S_CALL_LST, 
S_PRST_CONTACT, S_LIST_CON).

■ Prospects lists can be directly associated with a campaign in program flow 
view.

Table 74 describes how prospects can be supported for Marketing Server 
segmentation.

Table 74. Scenarios for Using Prospect Lists in Siebel Marketing

Scenario Data Source
Integration 
Object Comments

Campaign 
contains only 
contacts.

Siebel OLAP 
or Siebel OLTP

Marketing 
Contact

Fully supported. All contacts exist in 
Siebel database, so data is inserted only 
into S_CAMP_CON and 
S_DD_USER_KEY tables.

Campaign 
contains only 
contacts.

Non-Siebel 
database

Marketing 
Contact

Fully supported. New contacts and 
accounts (if mapped) are created in the 
Siebel transactional database.

Campaign 
contains only 
prospects.

Siebel OLAP 
or Siebel OLTP

Marketing 
Person

Fully supported. All prospects exist in 
Siebel database, so data is inserted only 
into S_CAMP_CON and 
S_DD_USER_KEY tables.

Campaign 
contains only 
prospects.

Non-Siebel 
database

Marketing 
Person

Needs on-site configuration. Need to 
create Marketing Prospects EAI 
integration component to create new 
prospect records.

Campaign 
contains 
contacts and 
prospects.

Siebel OLAP 
or Siebel OLTP

Marketing 
Person

Fully supported. All contacts and 
prospects exist in Siebel database, so 
data is inserted only into S_CAMP_CON 
and S_DD_USER_KEY tables.

Campaign 
contains 
contacts and 
prospects.

Non-Siebel 
database

Currently not supported.
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Creating Internal Lists
The contacts or prospects you target for each campaign will vary depending on the 
campaign objective. For example, you might want to select all the contacts who 
have a certain job title or live in a specific ZIP or Postal code. In another campaign, 
you might want to combine sets of contacts or prospects that were selected by 
several different criteria into a single list.

You create an internal list of contacts or prospects in the List Management screen 
using the Contacts or Prospects view. You can also use these views to add contacts 
or prospects to existing lists.

NOTE: To create an internal list, your employee login must have a responsibility 
associated with it that includes the List Management views.

You can reuse lists in any number of campaigns or marketing programs.

To create an internal list of contacts or prospects

1 From the application-level menu, choose View > Site Map > List Management 
> Contacts or Prospects.

2 In the Contacts or Prospects list, select the individuals that you would like to 
include or perform a query to find this information.

3 After you receive the results of your query, you can select any number of the 
records for inclusion in the list.

4 With the desired records highlighted, click New Internal List.

This will save a new list and default the list name to your login ID plus the date 
time stamp (for example, JSMITH 31/12/2001 5:00 pm).

5 To see the new list, from the Show drop-down list, select Lists.

NOTE: The list type is defaulted to Internal. You can rename the list to give it a 
more appropriate reference name at any time.
510 Siebel Marketing Guide Version 7.5.3



List Management

Creating and Managing Internal Lists
Adding to Internal Lists
Adding to an existing internal list is similar to creating a new internal list. You can 
use Add to List to attach prospects to a list of type Internal, D&B, or Imported. You 
can attach prospects from the All Prospects list or the Prospects by Attribute list.

To add contacts or prospects to an internal list

1 From the application-level menu, choose View > Site Map > List Management 
> Contacts or Prospects.

2 In the Contacts or Prospects list, select the individuals that you would like to 
include or perform a query to find this information.

Once you receive the results of your query, you can select any number of the 
records for inclusion in the list.

3 With the selected records highlighted, click Add to List.

4 In the Pick List dialog box, select the appropriate list and click OK.

5 To verify that the new records have been added to the list, from the Show drop-
down list, select Lists.

6 Select the appropriate list, and then click the List Contacts and Prospects view 
tab to verify that your selected contacts have been added.

Creating Lists of Prospects Using Additional Attributes
You can create lists of prospects by querying the additional attribute data for all 
prospects. For example, you might create an additional attribute for hobby and then 
record these values for many of your prospects. For a campaign, you might want to 
create a list of prospects with certain hobbies, such as sailing or painting.

You can create a list of prospects by using the Prospects by Attribute list. In this list, 
the New Internal List and Add to List functions are also available. Simply query the 
list of all prospects using the appropriate attribute and attribute value. Then 
highlight the desired records and either create a new list or add to an existing list.
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Due to the many-to-many relationship between prospects and attributes, you 
cannot have multiple combinations of attributes and values in a single query. If you 
wish to create of a list that combines queries, for example Hobby = Skiing AND 
Preferred Language = Spanish, perform separate queries and use the Add to List 
function to combine the results.

To create an internal list of prospects using attributes

1 From the application-level menu, choose View > Site Map > List Management 
> Prospects by Attribute.

2 In the Prospects by Attribute list, select the prospects that you would like to 
include in your internal list or perform a query, if necessary. 

After you receive the results of your query, you can select any number of the 
records for inclusion in the list.

3 With the records highlighted, click New Internal List.

This saves a new list. The list name defaults to your login ID plus the date time 
stamp (for example, “JSMITH 31/12/2001 5:00 pm”).

4 To see the new list, from the Show drop-down list, select Lists and find the 
default name on the list.

To add to an internal list using prospect attributes

1 From the application-level menu, choose View > Site Map > List Management 
> Prospects by Attribute.

2 In the Prospects by Attribute list, select the prospects that you would like to 
include in your internal list or perform a query if necessary.

Once you receive the results of your query, you can select any number of the 
records for inclusion in the list.

3 With your desired records highlighted, click Add to List.

4 In the Pick List dialog box, select the appropriate list and click OK.

5 To verify that the new prospects have been added to the list, from the Show 
drop-down list, select Lists.

6 Select the list to which prospects have been added.
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7 Click the List Contacts and Prospects view tab to see your selected prospects.
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Promoting Prospects
Prospects are prospective contacts, people who have the potential to become 
customers or to be involved in a business activity in some other way. Prospects are 
candidates for promotion to a contact, an account, or an opportunity. In addition, 
you can configure the promotion behavior by modifying the promotion map in 
Siebel Tools.

To promote prospects, perform the following tasks:

■ Promoting a Prospect to a Contact

■ Promoting a Prospect’s Response to an Opportunity on page 516

■ Modifying the Promotion Map on page 517

Promoting a Prospect to a Contact
When a prospect satisfies a set of screening criteria, he or she can be promoted to 
become a contact. The new contact record contains the same name and address 
information as the prospect record. The additional attribute data associated with the 
prospect is automatically promoted to categories and category values for the new 
contact.

When a prospect is promoted, the application checks for the following items:

■ List Management confirms whether Data Quality deduplication is enabled. If so, 
the promotion will match the prospect against all existing contacts. If a match is 
found, a pop-up window appears showing all the matching contacts. The user 
can then pick or ignore the matches and proceed with the promotion.

■ If the user chooses an existing contact from the pop-up window, the prospect 
record will be removed and its associations with any campaigns, lists, or 
responses will be linked to the selected contact.

■ If the user ignores all the matches in the Pop-up Window, the promotion 
continues as if no match was detected.

■ If Data Quality finds no matching contact or Data Quality is not enabled, the 
promotion checks if the combination of the Account Name and Account site 
fields match an existing account record, and one of the following occurs.
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■ If the combination of the Account Name and Account Site fields match an 
existing account record, one of the following occurs:

■ If the account name is empty but an account site is specified, an account will 
be created using the prospects last name as the Account Name value.

■ If the account name exists but the account site is empty, the promotion 
compares with existing Accounts that have the same Account Name and 
Account Site. If an identical account exists, the promotion will link the 
contact to the existing account. For the prospect address fields, either an 
update or an insert on the Account Address will be performed, based on the 
Address Name (the user key for Business Address). If there is not a match 
with an existing account, a new account will be created and the prospect 
personal address becomes the account address.

■ If no account location or account name is specified, an account will not be 
created or associated with the promoted prospect. The prospect personal 
address becomes the contact personal address.

Promoting Multiple Prospects
You can promote multiple prospects using the Promote Many button in some views 
in the List Management screen. This promotes any prospects for which Data Quality 
does not find any matches. 

CAUTION: Promotion is only intended for promoting relatively small numbers of 
prospects at one time (fewer than 100). If you select more prospects, the process 
could take many minutes to complete. 

Prospects that have at least one matching contact will not be promoted when you 
click Promote Many. If you do not enable Data Quality, selected prospects will be 
promoted to contacts.

When a prospect is promoted, a contact record is created with matching field 
information and the prospect is removed from the list of all prospects.

To promote a prospect using the Prospects More Info view

1 From the application-level menu, choose View > Site Map > List Management 
> Prospects.
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2 Use one of the following methods to promote prospects:

■ In the Prospects list, select a prospect record and click Promote.

■ To promote multiple prospects, select the prospect records that you want to 
promote and click Promote Many.

To promote a prospect using the List Contacts and Prospects view

1 From the application-level menu, choose View > Site Map > List Management 
> Lists.

2 Click the List Contacts and Prospects view tab.

3 Use one of the following methods to promote prospects:

■ In the Contacts and Prospects list, select a prospect record and click Promote.

■ To promote multiple prospects, select the prospect records that you want to 
promote and click Promote Many.

To promote a prospect using the Prospects by Attribute view

1 From the application-level menu, choose View > Site Map > List Management 
> Prospects by Attribute.

2 In the Prospects by Attribute list, select a prospect record and click Promote.

To promote a prospect to a Campaigns opportunity

1 From the application-level menu, choose View > Site Map > Campaigns > My 
Campaigns.

2 In the Campaigns list, select a campaign.

3 Click the Overview view tab.

4 In the Overview list, select a prospect record and click Create Opportunity.

Promoting a Prospect’s Response to an Opportunity
A prospect that responds to a campaign offer can be promoted by promoting the 
response to an opportunity in the Responses screen. For more information, see 
“Promoting a Response to an Opportunity” on page 385.
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Modifying the Promotion Map
List Management provides a default path for information to move from the prospect 
record to the contact record during promotion. Prebuilt maps specify where in the 
contact record prospect fields should be copied when a prospect is promoted. List 
Management provides three prebuilt maps for moving prospect information during 
promotion. Refer to Table 75.

Using Siebel Tools, you can redirect any of these prospect fields to a field associated 
with another Business Component. For example, you may decide that you do not 
want to use the Alias field for the prospect and would like it to hold some other 
information such as a Back Office Account ID. You may also want to promote that 
ID to populate a specific field on the contact record, possibly an extension column 
added to your implementation. To view or change the promotion map, in Siebel 
Tools, navigate to Business Components >List Mgmt Prospective Contact > 
Business Component User Properties.

You can see the destination business component by looking under Business 
Component User Properties for the List Mgmt Prospective Contact and searching for 
the Map Name in the Name column. The path for the map will be displayed as 
Destination Business Component: Source Business Component. For example, 
Contact: List Mgmt Prospective Contact.

Table 75. Prospect Information

Map Name Information Promoted
Source Business 
Component

Destination Business 
Component

LM Contact Map Contact related 
information such as 
First Name, Email 
Address, and Job Title.

List Mgmt 
Prospective Contact

Contact

LM Account Map Account related 
information such as 
Annual Revenue and 
Line of Business.

List Mgmt 
Prospective Contact

List Mgmt Account

LM Business 
Address Map

Business Address 
information such as 
City, Country, and 
Postal Code.

List Mgmt 
Prospective Contact

Business Address
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In this case, all three default maps use the List Mgmt Prospective Contact business 
component as the source.

To modify the promotion map, you can change a user property in the map to 
promote the information to a different field in the Destination Business Component 
for the map.

Alternatively, if you wish to promote user properties to a destination business 
component other than the three default maps, you might create a new map for those 
user properties. 

Modifying Map Entries
To insert or modify a map entry, first determine which map to use for a given set of 
source and destination fields. Then add an entry using the following syntax:

Name Column:  [MAP NAME]: [DESTINATION FIELD]

Value Column:  [SOURCE FIELD]

■ Map Name. The name of the map specified under the corresponding row in the 
Business Component User Properties.

■ Destination Field. Field in the Destination Business Component to receive source 
data. The Destination Business Component is map specific, but configurable.

■ Source Field. Field in the Source Business Component from which to extract data. 
Source Business Component is map specific, but configurable. 

Each map only works with a specific source and destination Business Component. 
However, users can make copies of the Business Components and rename them. 

To modify the source and destination Business Components of these mappings, the 
user must modify the following Business Component User Prop:

Name Column: [Map Name]

Value Column: [Destination Business Component]:[Source Business 
Component]
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Viewing and Maintaining Lists
A list in Siebel Marketing is a group of contact or prospect records in the Siebel 
database. The list file name is assigned by Siebel Marketing in the following format:

{P or L}/[campaign source code][wave code]_[unique identifier].txt

NOTE: P stands for Preview and L stands for List.

If there is a need to influence the list’s file name, you can change the Campaign 
Source Code by modifying the Source Code Field in the Campaigns screen’s All 
Campaigns across Organizations view or change the campaign’s Wave Code in the 
Campaigns screen’s Waves view tab.

List Management contains several features for helping you manage your list data. 

■ Viewing Lists of Contacts or Prospects on page 519

■ Deactivating Lists on page 521

■ Deleting Lists on page 521

■ Removing Prospects from Lists on page 521

■ Removing Contacts from Lists on page 522

Viewing Lists of Contacts or Prospects
You can view the list members and details about them in several ways. If you know 
the name of the list, you can start at the Lists view. If you want to see what other 
lists a contact or prospect may be on, you can also start at the Contacts or Prospects 
List view.

To view a contact or prospect list from the Lists view

1 From the application-level menu, choose View >Site Map >List Management 
>Lists.
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2 In the Lists list, select the list record and click the List Contacts and Prospects 
view tab.

The List Member view shows all of the contacts or prospects on the list you 
selected. If the Contact column is checked, the person is a contact. In addition, 
the person’s name appears either in the Contact Last Name or Prospect Last 
Name column to further identify if the person is a contact or prospect.

3 Click the last name hyperlink, and one of the following occurs:

■ If you clicked a Contact name, the Contact Detail view appears, with the 
Activity view tab selected.

■ If you clicked a Prospect name, the Prospective Contact Market Segment view 
appears, with the Prospect Additional Attributes view tab selected.

To view contact or prospect information from the Contacts or Prospects List view

1 From the application-level menu, choose View > Site Map > List Management 
>Lists.

2 From the Show drop-down list, select Contacts or Prospects.

Depending on which you chose, the Prospect List view or Contact List view 
appears.

3 Select the record of the Contact or Prospect you are interested in.

4 Click the last name hyperlink, and one of the following occurs:

■ If you clicked a Contact name, the Contact Detail view appears, with the 
Activity view tab selected.

■ If you clicked a Prospect name, the Prospective Contact Market Segment view 
appears, with the Prospect Additional Attributes view tab selected.
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Deactivating Lists
Many times lists are acquired from outside sources such as other companies, Web 
sites, and events such as seminars and trade shows. Because this data typically 
represents prospective customers who are not active customers, you may wish to 
deactivate any remaining prospects who have not been promoted to contacts. 
Additionally, lists can be generated by different users for a specific campaign or 
business situation, so you may want to keep lists active only for a specified period 
of time.

NOTE: To deactivate a list, change the values in the Status and Expiration Dates 
fields. navigate to the List Management screen and select the Lists view. In the Lists 
list, select the list you want to deactivate. In the Lists form, change the status to 
Inactive or set the expiration date. The expiration date is an information-only field 
and does not affect your use of the list.

Deleting Lists
To delete a list, navigate to the Lists view of the List Management screen and select 
your list from the Lists list. Click the menu button and select Delete Record. This 
will delete the list as well as the association with any contact or prospect records.

NOTE: When you delete a list, this does not delete the contact or prospect records 
themselves. This is because those names may also be used on other lists at the same 
time.

Removing Prospects from Lists
A prospect cannot be removed from a list using the List Contacts and Prospects 
view, because the prospect may appear on more than one list. You have more 
control over individual prospect lists when you remove the association between the 
prospect record and its list. If you remove all list associations for a prospect, the 
prospect record is deleted.
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To remove a Prospect from a list

1 From the application-level menu, choose View > Site Map > List Management 
> Lists.

2 In the Lists list, select the list and click the List Contacts and Prospects view tab.

3 In the List Contacts and Prospects list, select the record you wish to remove and 
drill down on the first or last name of the prospect.

4 Click the Prospect Lists tab.

5 In the Prospect Lists list, select and delete the list or lists from which you wish 
to remove the prospect.

If you select and delete all of the lists, the prospect record is also deleted.

Removing Contacts from Lists
Contacts can be removed from all lists, but the Contact record remains in the 
database.

To remove a Contact from a list

1 From the application-level menu, choose View > Site Map > List Management 
>Lists.

2 In the Lists list, select the list and click the List Contacts and Prospects view tab.

3 In the List Contacts and Prospects list, delete the record you wish to remove from 
the list.
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Integrating List Management with D&B
List Management can be used in conjunction with Siebel Dun & Bradstreet 
Integration Solution to generate lists of prospects from the D&B dataset. Within 
Siebel Dun & Bradstreet Integration Solution, the user can perform a query on D&B 
accounts and generate a list of prospects from the results of the query. These 
prospects can then be targeted in a campaign and promoted to active contacts.

List Management uses the D&B D-U-N-S number to provide data consistency 
throughout this process. The D-U-N-S number is associated with all prospects 
derived from the D&B data. After a D&B prospect is promoted to a contact, the D-
U-N-S number is used by the D&B update routine to continually refresh the data for 
those new contacts and their associated account information.

To use List Management with Siebel Dun & Bradstreet Integration Solution, perform 
the following tasks:

■ Viewing Account Data for a D&B Prospect

■ Promoting a D&B Prospect on page 524

Viewing Account Data for a D&B Prospect
The account related to a D&B prospect may already exist as a Siebel account. You 
can use the following procedure to view account information after you promote an 
account from a D&B account to a Siebel account.

To view the account information for a D&B prospect

1 From the application-level menu, choose View > Site Map > List Management 
>Lists.

2 In the Lists list, locate and drill down on the D&B list name.

3 In the List Contacts and Prospects list, drill down on the name in the Prospect 
Last Name field.

NOTE: Make sure you select the Prospect Last Name and not the Contact Last 
Name.
Version 7.5.3 Siebel Marketing Guide 523



List Management

Integrating List Management with D&B
4 Click the More Info view tab.

5 In the Prospects list, drill down on the Matched Account Name hyperlink.

The field will be blank if there is no matching account name.

Promoting a D&B Prospect
When you promote a D&B prospect to a contact, promotion checks to see if a Siebel 
Account with the same D-U-N-S number exists and the following actions occur:

■ If a Siebel account exists with that D-U-N-S number, the promotion proceeds 
according to the standard promotion process in “Promoting a Prospect to a 
Contact” on page 514. After the promotion, any other prospects from that same 
D&B account are removed from the list.

■ If there is no Siebel account with that D-U-N-S number, the application invokes 
the D&B account promotion, which then promotes the account and all its 
associated contacts, industry information, and other information. For more 
information, see the chapter about D&B in Applications Administration Guide.

NOTE: List Management will not promote a prospect with an invalid D-U-N-S 
number. A D-U-N-S number is considered invalid if it is not contained in the D&B 
Accounts table.
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When you launch a campaign, the Server Request Broker starts the Campaign 
Launch workflow process. This process automatically sends contact list files to 
specified vendors, most commonly using FTP (file transfer protocol), and offers are 
sent to targeted recipients.

You can launch a marketing program in the following two ways:

■ Launching Programs Manually. You can launch a marketing program manually 
using the Program Flow or Program Explorer views. For more information about 
manual execution, see “Launching Campaigns Manually” on page 529.

■ Launching Programs Automatically. You can launch a marketing program 
automatically and schedule recurring programs using the Schedule view. For 
more information about automatic execution, see “Using the Schedule Calendar 
View” on page 535.

Email, eNewsletter, and fax campaigns use Siebel Server’s Communications 
Manager component, which is started automatically when the Siebel Server starts. 
Communications Manager is a request-mode server component. It relies on the 
services of the Server Request Processor and Server Request Broker server 
components. Each of the three components must be running on the Siebel Server 
for communication requests to be dispatched successfully.

NOTE: On the Marketing Server component, a parameter called Wave Batch Size 
determines the number of subwaves created. Each subwave creates a new request 
or thread, so it is important to factor in the multithreading capabilities of your email 
server when you set this parameter. If your email server limits the number of 
threads, the Wave Batch Size parameter should reflect that limitation. 
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For email or eNewsletter offers, the Siebel Communication Manager distributes 
outbound email using a multithreading process. The Server Request Broker 
supports load balancing of outbound email across multiple Siebel Servers when 
launching campaigns targeting thousands of contacts, as shown Figure 4.

Figure 4. Load Balancing of Outbound Email
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Prerequisites for Launching Campaigns Manually
Before launching a campaign manually, make sure you have performed the 
following tasks:

■ “Adding a Position to the Marketing Administrators Access Group” on page 43 
The position of the person who launches the campaign must be a member of the 
Marketing Administrators access group. If the position is not part of this access 
group, the launch buttons will be unavailable.

NOTE: This also applies to a partner using the partner portal.

■ Create the marketing program in the All Program Plans view. For more 
information, see Chapter 13, “Designing Marketing Program Plans.”

NOTE: To successfully launch a campaign manually, you must set the end date of 
the stage and the End Date of the program in the Schedule view tab.

■ In the Program Flow view, associate stages, segments, campaigns, and internal 
lists to the program.

■ Using the right-click menu in the Program Flow view, generate a snapshot with 
counts.

NOTE: When you generate a snapshot, a snapshot file is only created if a 
campaign contains a segment. When a campaign has a list (and no segment) in 
the program flow, generating a snapshot creates a campaign and no snapshot 
file. For more information, see “Generating a Snapshot File” on page 457. You 
can launch this campaign in the same ways that you launch any other campaign.

■ In the Allocation view, allocate segment counts to campaigns.

■ In the Campaign Waves view, set up waves and distribution to vendors.

■ In the Program Flow view, use the right-click menu to load the campaign. This 
generates the vendor lists and adds the contacts to the Siebel Contacts and 
Campaign History tables for response tracking.
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■ If you are sending offers that use a distribution profile, you test the campaign to 
make sure using that the profile is set up correctly, and that offer is sent with 
expected results. For more information on testing campaigns, see “About Testing 
Campaigns and Offers” on page 373.
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Launching Campaigns Manually
You may choose to manually launch a campaign for a one-time occurrence of a 
program and campaign. You can manually launch a campaign using the Launch 
Campaign command from the Program Flow view’s right-click menu or from the 
Program Explorer menus. Automatic launch is always available as an option for a 
nonrecurring program. 

After performing tasks in “Prerequisites for Launching Campaigns Manually,” you 
are ready to launch the campaign from the Program Flow view. 

Launching a campaign calls the Campaign Launch workflow process. After 
launching a campaign, you can check the results by looking at history records—
Program, Stage, and Campaigns. For more information, see “Tracking Program, 
Stage, and Campaign History” on page 539. 

To manually launch campaigns 

1 From the application-level menu, choose View > Site Map > Programs > My 
Program Plans.

2 In the Programs list, select the program and click the Program Flow view tab.

3 In the Program Flow view, select the campaign object in the workspace, right- 
click, and choose Launch Campaign from the menu.

4 In the Launch Campaign dialog box, select the campaign and click Submit.
Version 7.5.3 Siebel Marketing Guide 529



Launching Programs and Campaigns

Checking Campaign Launch Status
Checking Campaign Launch Status
Navigate to the Server Components Requests screen to check the status of the 
campaign launch. If campaign launch fails, you can view an error log using the 
Server Administration screen’s Server Tasks view.

To monitor campaign launch status

1 From the application-level menu, choose View > Site Map >Server 
Administration > Enterprise Operations > Component Requests.

2 In the Component Requests list, locate the component/job for the campaign 
launch.

The job for Campaign Launch is Workflow Process Manager.

3 In the Status field, review the status of the component request. 

If campaign launch is successful, Success appears in the Status field. If a 
problem occurred, Error appears in the Status field, and additional information 
about the error appears in the Completion Information field.

If the campaign’s Status field does not show Completed, refresh the list to track 
changes in status.

To view the task log

1 From the application-level menu, choose View > Site Map >Server 
Administration > Tasks.

2 In the Tasks list, locate the component and task.

3 Click the Task Info log view tab.
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Stopping and Resuming or Restarting a Email Campaign
An email campaign can be stopped (suspended) and then resumed or restarted. To 
perform these actions, you need to enable email recipient logging using the Enable 
Campaign progress tracking check box in the Campaigns Screen. When you enable 
campaign progress tracking, the Done check box is checked in the Campaign 
Contacts/Prospects view for all contacts and prospects if the system tried to send 
an email offer. For example, if a recipient’s email address is invalid, the offer would 
not be received but the Done check box would be checked.

After you enable campaign progress tracking, you can launch the email campaign. 
After launch, one or more requests are created and submitted to Communications 
Server. The number submitted depends on the number of people allocated to each 
wave and the system settings in Communications Server and your email server.

To stop and resume or restart a campaign

1 From the application-level menu, choose View > Site Map > Campaigns > My 
Campaign Plans.

2 Click the Status view tab.

3 In the Status list, drill down on the Campaign Name hyperlink for the campaign 
you want to monitor.
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4 Click the Email Status tab and click the appropriate button.

When you click the Stop, Resume, or Restart buttons, a confirmation dialog box 
appears. If you click OK, another message appears explaining what actions were 
taken. If you click Cancel, the system will not stop, resume, or restart the 
selected campaign.

The following scenarios describe changing campaign wave information after 
launching a campaign:

■ Scenario—Changing Lag Days

Campaign X has five contacts, one wave (wave A) containing all contacts in the 
campaign, and no lag time. When you load and then launch the campaign, all 5 
offers are sent. Then, you change the wave definition as follows: 

■ Wave A. Do not change lag days and reduce the included contacts to 50%.

Button Description

Stop Click Stop to suspend the email campaign. This action cancels pending 
requests on the Communications Server that have not been executed. An 
email campaign can have many requests that are pending or in progress in 
the Communications Server. If all the requests are executing when you click 
Stop, the email campaign cannot be stopped.

Resume Click Resume to sent email requests that were not sent (cancelled) when 
you clicked Stop. Communication Server requests that were cancelled will 
be cleared and replaced by a new request. When you click Resume, only 
contacts and prospects without a check in their Done check box will be sent 
the email offer. You cannot resume a queued request without stopping it 
first.

Restart Click Restart to contact all contacts and prospects in the Campaign again, 
even if they were sent the email before you clicked Stop. When you click 
Restart, the Campaign's contact history is overwritten and will reflect the 
result of the latest launch. You cannot restart a queued request without 
stopping it first.
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■ Wave B. You add a second wave (wave B) with 2 days lag time and containing 
50% of the contacts.

When you click Restart, all five offers are sent a second time. The new wave 
information is ignored because it only takes effect the next time you load the 
campaign.

NOTE: Clicking Stop in this scenario would have no impact because Campaign X 
fully executed all offers.

■ Scenario—Stopping and Restarting When Requests are Queued

Campaign Y has five contacts and two waves (waves A and B). Wave A has no 
lag days, a Wave Code of A, and 50% of the contacts. Wave B has one lag day, 
a Wave Code of B, and 50% of the contacts.

When you load and then launch the campaign, three offers are sent (Wave A) 
and two offers are queued for Day 1 (Wave B). Then, you change the wave 
definition as follows:

■ Wave A. Do not change lag days. Change the Wave Code to A1 and increase 
the included contacts to 80%.

■ Wave B. Change lag days to 0, Wave Code to B1, and reduce the included 
contacts to 20%.

When you stop and then restart the campaign, all five offers are sent because 
the system recognizes the new lag day value and Wave Codes but ignores the 
wave %. Wave % won't take affect until the next time you load the campaign. 
You can see the new codes in the Contacts/Prospects and Email Status views 
tabs.
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Monitoring the Status of an Email Campaign
After campaign launch, you can monitor the campaign status. Each request in the 
Email Status list shows the number of recipients to whom the email has been sent 
in the Status Message column. 

1 From the application-level menu, choose View > Site Map > Campaigns > My 
Campaign Plans.

2 Click the Status view tab.

3 In the Status list, drill down on the Campaign Name hyperlink for the campaign 
you want to monitor.

4 Click the Email Status tab.

5 In the Email Status list, click Query and then click Go.

You do not need to type criteria. When you leave all fields blank, the list 
reappears with all fields updated.
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Using the Schedule Calendar View
When you complete a program design using Program Flow, you can schedule the 
program for automatic execution using the Schedule calendar view. During 
automatic program execution, a snapshot is generated and then the Campaign Load 
and Campaign Launch workflow processes run. When the first occurrence of a 
program plan is completed in a multistage program, program execution reschedules 
itself for the second occurrence. For more information about workflow processes, 
see Siebel Business Process Designer Administration Guide.

The Schedule view displays the details of the selected program in the Program form 
at the top and a calendar at the bottom.

Scheduling a Program Execution
Use the following procedure to schedule marketing programs for automatic 
execution.

To schedule a program execution

1 From the application-level menu, choose View > Site Map > Programs > My 
Program Plans.

2 In the Program Plans list, select the program and click the Schedule view tab.

3 In the Calendar view, click the calendar icon within the day that the program 
will start.

4 In the calendar form, complete the fields using the following table as a guide.

Field Comment

Type Required. The Type field displays Marketing Program as the default. 
If Marketing Program does not appear in the field, select it from the 
list.

Planned Start The default value in this field is the program start date. Click the 
calendar select button, use calendar controls to set the start date and 
time for program execution.
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5 Click Save This One when you are ready to save the schedule.

The program name and launch time appear in the Schedule calendar. The 
calendar also reflects any recurrence of the program.

6 In the Program form, click Activate Schedule to queue the program for 
execution.

Click OK in the message dialog box to confirm the start date and time. This 
submits a server request to run the Program Execution workflow process on the 
first calendar occurrence.

CAUTION: Do not schedule concurrent program executions. If you click the 
Activate Schedule button twice, and ignore the caution message about double-
scheduling a program, two server process requests will be generated, resulting 
in snapshot conflicts.

To edit the schedule

1 From the application-level menu, choose View > Site Map > Programs > My 
Program Plans.

2 In the Program Plans list, select the program and click the Schedule view tab.

3 In the Schedule’s calendar, drill down on the program name link.

Planned 
Completion

The default value in this field is the program’s end date. Click the 
calendar select button, use the calendar controls to set the date and 
time.

Description This field automatically displays the previously added program 
description. Type additional information if desired.

Until If the program is repeating, click the calendar select button, use the 
calendar controls to select a date.

Frequency If the program is repeating, choose the repeat cycle from the list. 
Options are Daily, Weekly, Monthly, Quarterly, Yearly.

Comment Type additional information about the program schedule, if desired.

Field Comment
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4 In the Schedule form, make changes and click Save This One. 

5 Click Activate Schedule.

NOTE: To perform this task, you must be assigned to the Marketing 
Administration access group. If you are not part of this access group, the Activate 
Schedule button will be unavailable.

To delete a schedule

1 From the application-level menu, choose View > Site Map > Programs > My 
Program Plans.

2 In the Program Plans list, select the program and click the Schedule view tab.

3 In the Schedule’s calendar, drill down on the program name link to open the 
Schedule form.

4 Click the menu button and choose Delete This One.

If the program repeats over time, you will be asked if you want to delete a single 
instance or every repeating instance.

5 Choose the appropriate answer and click OK.

In recurring programs, if an occurrence is deleted, subsequent occurrences are 
deleted.

Understanding the Campaign Launch Workflow Process
When you launch a campaign, the Campaign Launch workflow process initiates. 
For more information about workflow processes, see Siebel Business Process 
Designer Administration Guide.

The exported list file is sent to each vendor in the List Distribution list of the Waves 
view, using distribution adapters and profile information. For example:

■ Email. The exported list file is emailed to the vendor’s primary contact.

■ FTP. Each vendor has a profile specifying the host name, user name and 
password. The exported list file is sent using File Transfer Protocol to the 
vendor’s FTP server.
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For each wave, the server receives a request to send each valid offer in the campaign 
on the day the program is executed, adding to that date any lag days defined in the 
wave. Only those contacts or prospects assigned to a particular wave will receive 
the offer.
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Tracking Program, Stage, and Campaign History
You can track the execution history of programs, stages, and campaigns. Using the 
Status view, you view the status of a newly executed program and, if necessary, you 
can reschedule (relaunch) a program stage. This relaunches a stage that failed. 

When you select Reschedule, the second stage executes, including subsequent 
stages and recurrences. 

NOTE: If the program has multiple recurrences, be careful not to reschedule any that 
are already on the calendar and have not failed. Reschedule can only be used for 
single and multistage programs that are automatically executed.

You can find status history in two ways:

■ Programs screen. Select the program in the My Program Plans list and click the 
Status view tab for information about the program occurrences.

■ Campaigns screen. Select the campaign in the My Campaign Plans list and click 
the Status view tab for information about campaigns.

Each time Siebel Marketing launches a marketing program, it creates program and 
stage records and schedules the first stage for execution using the Server 
Component Request. The stage occurrence has an execution status field and a 
Server Component Request ID. that you can click to drill down to the Server 
Component Request record, which displays the status of the request. Depending on 
whether manual execution is performed (right-click from the Program Flow view), 
or automatic execution (Activate Schedule from the Schedule view), the Request ID 
reflects the different requests—either a request for the Marketing Server to generate 
a snapshot, or run the Program Execution Workflow process.

Program stages contain campaigns. When a campaign in the stage is loaded, Siebel 
Marketing creates a Campaign record. Contacts and prospects are associated with 
these campaign records rather than the actual campaign definitions. 

Because contacts and prospects are associated with the campaign, this is an 
important record. The campaign identifier (along with the stage ID) is added in the 
campaign history table (S_CAMP_CON), which contains the names of those who 
qualified for the campaign, and is used when managing responses. 
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Thus, the campaign ID, not the campaign, identifies contacts and prospects that 
have qualified for a campaign. For example, when you load a campaign, the process 
creates the campaign record, generates vendor list files, then flags qualified contacts 
in S_CAMP_CON with the campaign and stage identifiers. 

Handling Errors on the Campaign Record
If an error occurs during the execution of a program’s stage, the stage’s Status field 
is updated with the error message. The same error appears in the program’s 
occurrence record, indicating that a stage within the program failed. In the event of 
any error, the program’s occurrence stops. If a nonprimary stage for a program 
errors out, it will not affect the next occurrence. For example, if stage 2 of 
occurrence 1 fails, stage 1 and stage 2 of the second run of the program will not be 
stopped.

If an error occurs during the campaign load process, the campaign’s status fields are 
updated with the error message and the system passes the error message to the 
stage’s status and to the program status.

Programs with errors can be rescheduled from the Stages view (accessed by drilling 
down on the name in the Status view tab of the Program Plans view). For example, 
if a stage fails, the stage will have a status of Error. By choosing the Reschedule 
button from this view, you can submit a request to rerun the failed stage occurrence.

Selecting an Occurrence
When you load or launch a campaign plan or program plan, you must know which 
campaign or program to select in the dialog box, especially if your marketing 
program is multistage and recurring. In most cases, the occurrence you want will 
be the most recent occurrence record. But in some cases, you will need to find the 
correct record in the dialog box list of program and campaign occurrences.
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Table 76 shows a sample multistage program in which stages are set to occur every 
45 days and occurrences are associated with the stage.

■ In program 1, an offer is sent to contacts—new customers—who qualify for a 
campaign. During Stage 2, those that responded are sent a Welcome package.

■ In program 2, a repeat cycle, an offer is sent to new customers who are different 
from those in Program 1, but Stage 1 of program 2 is set to begin before Stage 2 
of program 1.

Which program record do you choose if Stage 2 in program 2 produces an error 
message and needs to be relaunched?

When in doubt, choose the parent occurrence. In this case it is Stage 1 of program 
1. In most cases, it will be the latest program or stage occurrence in the dialog box, 
but, as shown in the example in Table 76, the occurrence you need may be located 
further down the list.

If you have a multistage, recurring program and you are not sure you will be able 
to find the parent stage occurrence when you load a campaign, navigate to the stage 
occurrence record and rename it to something you will recognize, such as Execute 
Stage 1.

Table 76. Multistage Program with Occurrences

Occurrence 1/01 1/15 2/01 2/15 3/01 3/15 4/01

Program 1 Stage 1 Stage 2

Program 2 Stage 1 Stage 2

Program 3 Stage 1
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This chapter describes some error conditions you may encounter and suggests ways 
to correct them.

If this chapter does not contain an error that you encounter or if a solution provided 
in this chapter does not solve the problem, contact Siebel Technical Support. 
Table 77 contains descriptions of troubleshooting information headings used in this 
chapter.

This chapter discusses the following topics:

■ Error Messages in Siebel Marketing on page 544

■ Other Troubleshooting Issues in Siebel Marketing on page 546

Table 77. Troubleshooting Heading Descriptions

Heading Description

Possible Causes Possible causes for the error message, symptom or 
condition.

How to Diagnose Steps you can perform to identify the cause.

How to Resolve Instructions to resolve each possible cause of the error.
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Error Messages in Siebel Marketing
When you cannot perform a task and receive an error message, use the information 
in this topic to help you diagnose the problem, identify a possible cause, and 
determine a way to resolve the problem. 

If this section does not contain an error that you encounter or if a solution provided 
in this chapter does not solve the problem, contact Siebel Technical Support.

This section contains information about the following error message:

■ Invalid Join Path on page 544

Invalid Join Path
Invalid join path errors are caused when the application server cannot access one 
or more tables that are needed for data synchronization (data retrieval) or snapshot 
generation. When trying to synchronize data (data retrieval) or generate a snapshot, 
the following error appears:

Invalid Join Path

Possible Cause 1
No start point join has been created. 

Make sure that there is a start point join on a table being retrieved.

How to diagnose 1. Verify that you have set up at least one start point join. When you 
receive this error during data retrieval, verify that there is a start point join on the 
table being retrieved.

How to resolve 1. Create appropriate start point joins. For additional information, see 
“Joining Tables and Fields” on page 118.

Possible Cause 2
Joins are not set up correctly.

How to diagnose 2. Use the following methods to verify that joins are set up correctly:
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■ Verify the content of the snapshot to make sure joins are properly set up to 
extract data elements needed for the snapshot. Use the Screens > Programs > 
Snapshots view to see the contents of the snapshot.

■ Query the control table to obtain a list of tables and fields required for the 
snapshot build. 

CAUTION: It is recommended that you contact Siebel Technical Support engineers 
before you perform this task because it involves querying the Siebel database.

Siebel Marketing Server creates a temporary table called the control table that 
captures all the necessary definitions of a snapshot, including the list of tables 
and fields needed to build the snapshot. By querying this table, you can identify 
the tables needed to build the snapshot.

The Marketing Server log file reports the ROWID for the snapshot task and every 
stage has a unique task ROWID. The table name is the task ROWID without any 
special characters and containing a prefix of C_. So a task with ROWID 1-GXJ2 
creates a control table C_1GXJ2. Use the following query to troubleshoot:

Select distinct labels, db_table, db_name from <table name>

NOTE: The Labels column determines the Siebel object (list measure, bound 
measure, and so on) that is mapped to the table (db_table) and field (db_field).

How to resolve 2. Correct the setup for any joins that are set up incorrectly. For 
additional information, see the topics about joins in Chapter 4, “External Data 
Mapping”.
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Other Troubleshooting Issues in Siebel Marketing
When you cannot perform a task and do not receive an error message, use the 
information in these topics to diagnose and resolve the error.

This section provides ways to diagnose and resolve problems. If this chapter does 
not contain the information that you need or if a resolution provided in this chapter 
does not solve the problem, contact Siebel Technical Support. 

The following issues are described in this section:

■ Mapping a Table Does Not Retrieve Fields in Fields View

■ Snapshot Fails to Generate

■ Resolving Snapshot Counts Discrepancies

■ Improving Snapshot Performance

Mapping a Table Does Not Retrieve Fields in Fields View
When you step off a new table record in the Tables view of the Marketing 
Administration screen, a Data Dictionary server process retrieves field names and 
their data types for that table from the database server. 

Mapping a table does not retrieve fields. Check the status of the Data Dictionary task 
in the My Component Requests view.

CAUTION: Do not add field records manually and then map Measures to a table record 
that did not retrieve fields. Always wait for the data retrieval task to complete or 
measures on fields will not work.

Possible Cause 1
Data Dictionary task is in Error status.

How to diagnose 1. Check the status of the Data Dictionary task in the My 
Component Requests view. If its status is Error, perform the following tasks:
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■ Verify that the schema name is prefixed to the table name. For example, 
SIEBEL.S_CONTACT, OLAP.W_PERSON_FACT. For information, see table 
name information in Table 19 on page 93.

■ Verify that the table name is spelled correctly. Some databases are case 
sensitive to table names. For information, see “Creating Server Definitions” 
on page 89.

■ Verify that the correct Server is assigned to the table. For information, see 
“Mapping to Tables from the Servers View Tab” on page 90.

■ Verify that the database server is running. It is recommended to perform this 
task from the Siebel server machine using the ODBC test function. For 
assistance, see your system administrator.

■ Verify that the server DSN is the system DSN. For information, see “Creating 
Server Definitions” on page 89.

■ Verify that the correct ODBC driver was used to create a DSN. For example, 
ODBC drivers provided by Oracle and Microsoft for an Oracle database could 
be installed on the server for another application. They should not be used 
for Siebel Marketing. For information, see “Creating Server Definitions” on 
page 89.

■ Verify that the table actually exists in the database. For assistance, see your 
system administrator.

■ Verify that the user for this data source has read access to the table. It is 
recommended to run the ODBC test program, login as the user that you setup 
in the Servers view tab, and run a count(*) query on the table. For assistance, 
see your system administrator.

■ Verify that the task is run on the right Siebel server. Check the Server field in 
the My Components Requests view. For assistance, see your system 
administrator. 

How to resolve 1. If you find errors when diagnosing the problem, correct the 
errors and create the table again.

Possible Cause 2
The Data Dictionary task is still in queue.
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How to diagnose 2. Check the status of the Data Dictionary task in the My 
Component Requests view. For assistance, see your system administrator. If its 
status is Queued, perform the following tasks:

■ Verify that the Siebel server is running. If you map tables when Siebel server is 
down, the Data Dictionary task(s) will stay in queue till the Siebel server comes 
back up.

■ Verify that the Data Dictionary component and Marketing Server component 
group are enabled.

■ Verify that the Data Dictionary component is running.

■ Verify that the Request Server is running without errors.

■ Verify that the Siebel Server is configured properly (check the connect string and 
table owner in Siebel.cfg).

How to resolve 2. If you find errors when performing the diagnostic tasks, correct the 
errors and recheck the status of the Data Dictionary task in the My Component 
Requests View. If you have resolved the error, the Data Dictionary task should start 
running.

Possible Cause 3
The Data Dictionary completes successfully but does not retrieve fields.

How to diagnose 3. For assistance in performing the following tasks, see your system 
administrator:

■ Check the native data types for the table.

■ Check the ODBC driver documentation to see if SQLColumns is 3.x compliant.

How to resolve 3. If you find errors when performing the diagnostic tasks, correct the 
errors and create the table again.

Possible Cause 4
The Data Dictionary task errors out intermittently.

First, confirm that the problem is not a a result of other causes discussed in this 
topic.
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How to diagnose 3. Check the Marketing Server log for errors.

If you find a Memory Allocation error, your system ran out of memory causing the 
task to fail.

How to resolve 4. You might need more available memory on the server.

Snapshot Fails to Generate
When you request snapshot generation, a snapshot a server task starts. However, 
sometimes the server task does not generate a snapshot file. For details about how 
snapshot generation works, see “Understanding Snapshot Generation Internal 
Processes” on page 560.

Possible Cause
A snapshot task can fail due to insufficient memory.

How to diagnose. You use the Server Administration screen to verify that the task 
completed successfully or to view errors. In the Tasks view, the Task Information 
Log view tab shows more details if the server task generates errors. The following 
information will help you locate the Marketing Server log and make sure that you 
have set the correct level of detail to record the information that you need.

■ Finding the Marketing Server log file. The task information log file for snapshot 
generation can be found in the Siebel Server log directory. Check the log file 
named MktgSrvr_xxx.log in siebsrvr\log to review error messages. Several 
processes such as extract and counter execute during snapshot generation. Log 
information is created in the Marketing Server log file, not in a separate log file.

■ Setting the level of detail in the Marketing Server log. For the Marketing Server, 
the default log level for the event of type General Events is 3. Log level 3 should 
result in sufficient log detail for all components. You can change the level of 
detail in the log file (trace) before starting a snapshot task by changing the log 
level. To change the log detail level, use the Server Administration screen’s 
Components view. In the Component Event Configuration view tab, locate 
Marketing Server in the Server Components list and set the log level for General 
Events to a number greater than one.
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How to resolve. For information about performance enhancement recommendations, 
see “Improving Snapshot Performance” on page 552 or search for information on 
SupportWeb at www.siebel.com.

Resolving Snapshot Counts Discrepancies
After generating a snapshot, you identify a discrepancy between expected counts 
and actual counts.

How to diagnose. Verify segment and filter criteria, administrative setup, and data 
mapping. Review the snapshot log. Some problems may require you to work with 
your marketing administrator.

Possible Cause 1
Segment or filter criteria is incorrect.

How to diagnose 1. Verify segment and filter criteria. Some problems may require you 
to work with your marketing administrator.

How to resolve 1. Verify the following, correct any errors, and regenerate the 
snapshot.

■ Review segment and filter logic to make sure it maps correctly to the business 
requirement.

■ Validate segment criteria using SQL. Query the database directly to identify any 
data issues.

■ Troubleshoot using update counts. Start with simplified segment criteria, update 
counts using the snapshot and then keep adding more criteria till you identify 
the problem area.

Possible Cause 2
Measures and measure-based attributes or hierarchies setup is incorrect.

How to diagnose 2. Verify that measures are setup correctly. Some problems may 
require you to work with your marketing administrator.

How to resolve 2. Review the following, correct any errors, and regenerate the 
snapshot:
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■ Review measures and measure-based attributes or hierarchies to make sure they 
are defined correctly.

■ Verify that the fields and attribute families are synchronized with the latest data 
refresh.

Possible Cause 3
Data mapping is incorrect.

How to diagnose 3. Verify that data mapping is correct. Review the snapshot log. 
Some problems may require you to work with your marketing administrator.

How to resolve 3. Review Marketing Server snapshot log file for the following 
problems, correct any errors, and regenerate the snapshot:

■ When verifying the table joins, make sure that the join path is pointed at the 
correct tables.

■ Using the table count summary in the log file, look for data loss resulting from 
incorrect join types. For example, an Equal join can eliminate data if the criteria 
expects an Outer join.

■ Verify that the table counts are correct.

■ Check for any errors or warning from the Marketing Server or ODBC.

Possible Cause 4
Extraneous events can affect the Marketing Server or data.

How to diagnose. Verify segment and filter criteria, administrative setup, and data 
mapping. Review the snapshot log. Some problems may require you to work with 
your marketing administrator.

How to resolve 4. Check for occurrences of external events such as ETL refreshes that 
may affect the Marketing Server or the data. Check your ETL logs. For example, 
there might be 1 MM contacts in the Siebel OLTP database and 990K in the OLAP 
database. You might need to refresh the OLAP database.
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Improving Snapshot Performance
If generating a snapshot takes longer than it should, you can use information in the 
snapshot log file and monitor the system (using Performance Monitor on NT) to 
collect information about performance. Performance variables that affect snapshot 
generation include the following:

■ Database throughput

■ Database sorting time

■ Network throughput

■ Number of custom measures

■ Size of the snapshot (number of customer records)

■ Complexity of the data model

■ Number of tables needed for the snapshot

■ Number of records to process to build the snapshot

■ Number of custom measures

■ Number of list measures and fields used

■ Type of joins setup

■ Size of cached tables

■ I/O rate to Siebel file system

■ Memory and CPU availability on the Marketing Server

■ Size of attribute tables used

The resolution sections (How to resolve) in this topic contain some recommended 
guidelines to improve performance. Some of these recommendations may improve 
performance more than others. For more information about Siebel Marketing 
internal processes that execute when you request snapshot generation, see 
“Understanding Snapshot Generation Internal Processes” on page 560.
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Possible Cause 1
Too much time used by the rcontrol process. Time used by the rcontrol process 
should be a few seconds to a few minutes and depends on the complexity of the 
snapshot and the size of attribute tables. This can be caused by using nested loop 
joins.

How to diagnose 1. In the Marketing snapshot log file, compute the time between the 
comment line Application Name - Compute Snapshot and Application Name 
- Control Snapshot. This process should not take more than a few minutes unless 
there is an internal issue. Contact Siebel Technical Support if this takes too long.

How to resolve 1. Siebel strongly recommends avoiding nested loop joins which may 
lead to a major performance slow down based on table sizes and indexes. For more 
information about nested loop joins, see “Understanding Joins” on page 113.

Possible Cause 2
Too much time used by data sorting and caching. The time used should be a few 
minutes to an hour and depends on the size of cache tables, the size of merge tables, 
database sorting time, and network speed.

How to diagnose 2. In the marketing snapshot log file, compute the time between the 
comment line Joining Records and Application Name - Compute Snapshot.

How to resolve 2. Speed up network connectivity between database server and 
Marketing Server. Make sure that network connectivity is optimized between the 
data source server and the Marketing Server. Contact your systems administrator for 
assistance.

Possible Cause 3
Too many records for cache tables. The approximate number of record for each table 
should be fewer than 1,000,000 records.

How to diagnose 3. In the snapshot log file, note all the cursors that use Cache as the 
joining method. In the Cursor Summary, note the number of records read from each 
cache join cursor.
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How to resolve 3. Speed up network connectivity between Marketing Server and 
Siebel file system. Make sure network connectivity is optimized between the 
Marketing Server and Siebel file system. Contact your systems administrator for 
assistance.

Possible Cause 4
More memory needed for cached tables. The approximate amount of memory 
needed for each cached table is less than 300 MB.

How to diagnose 4. For each cache cursor, compute the memory usage. Memory 
requirements can be estimated by using the bytes per record value from the SQL 
SELECT statement for the table produced by the application server during a data 
extraction task. Multiply the bytes per record by the number of records in the table 
to be cached. The bytes needed for each selected field is determined by the value 
in the Width field in the Fields View.

How to resolve 4. Avoid caching large tables. You can ignore small cache tables 
(those with fewer than 10,000 records) unless the number of columns selected is 
unusually large (more than 20). Caching large tables (over 2,000,000 records or over 
500 MB) may impact performance. If possible, change joins from cache to merge for 
large tables to save memory and potentially speed up processing. For more 
information about join types, see “Understanding Joins” on page 113

Possible Cause 5
Number of nested loop joins.To avoid performance issues, nested loop joins should 
be avoided on large tables. For more information about nested loop joins, see 
“Understanding Joins” on page 113.

How to diagnose 5. In the marketing snapshot log file, identify cursors that use 
Nested Loop as the join method.

How to resolve 5. Use filters to reduce snapshot size. Depending on the filter criteria, 
filters may generate SQL WHERE clauses, reducing data shipping between the 
Siebel database and the Marketing Server. This can also improve snapshot 
performance. For more information about filters, see “Creating Filters and Defining 
Filter Criteria” on page 236.
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Possible Cause 6
Slow processing of denormalized records. The rate of denormalized records 
processed should be 10,000 records per second. In an ideal setup, the Marketing 
Server can process 20,000 to 30,000 records per second.

How to diagnose 6. Check the value in the Records Processed comment line and 
divide that number by the time difference between the Records Processed 
comment line and the Joining Records comment line.

How to resolve 6. Pass database hints to speed up sorts. The Hint field can be used 
to pass hints to SQL select statements that are generated by the Marketing Server 
during a snapshot build or data synchronization. This field can only be used on 
Oracle data sources. The hint is applied to the cursor opened on the child table. 
Typically parallel hints (/*+ parallel(<tablename>, <degree of parallelism> */) 
are setup for improved performance on data sorts. Hints can be also setup on start 
point joins. Refer to section 3.19 on how to setup and pass hints in SQL queries. 
Contact your systems administrator for assistance.

Possible Cause 7
CPU usage during data processing. Usage should be 60-80% on two CPUs.

How to diagnose 7. Monitor CPU usage on the Marketing Server for the rextract and 
rcompute processes during data processing. The Marketing Server is processing 
data when the log file contains a Joining Records comment line.

How to resolve 7. Use RDBMS joins to reduce data shipping between database and 
Marketing Servers. Using RDBMS joins will improve snapshot performance because 
of the reduction in data transfer. RDBMS joins will only improve performance if 
there is heavy use of filters and if the filters actually generate SQL WHERE clauses. 
Contact your systems administrator for assistance.

Possible Cause 8
Memory usage during data processing. Memory usage should be 500-600 MB.

How to diagnose 8. Monitor memory usage on the Marketing Server for the rextract 
and rcompute processes during data processing. The Marketing Server is processing 
data when the log file contains a Joining Records comment line.
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How to resolve 8. Partition large tables. Partitioning large fact tables will increase 
data read throughput. This should be considered only if sorting one large table is 
an issue or it is determined that there is a major bottleneck reading large tables in 
the rextract process. Contact your systems administrator for assistance.

Possible Cause 9
Average CPU usage by rextract process. Average CPU usage should be 60-80% on 1 
CPU.

How to diagnose 9. Monitor CPU usage on the Marketing Server for the rextract 
process during data processing. The Marketing Server is processing data when the 
log file contains a Joining Records comment line.

How to resolve 9. Consolidate multiple campaigns into a single snapshot by bundling 
multiple campaigns into a single snapshot. This may reduce overall processing time 
for the campaigns because you are generating a single snapshot instead of multiple 
snapshots.

Possible Cause 10
Average CPU usage of rcompute process. Average usage should be 30-50% of 1 CPU.

How to diagnose 10. Monitor CPU usage on the Marketing Server for the rcompute 
process during data processing. The Marketing Server is processing data when the 
log file contains a Joining Records comment line.

How to resolve 10. Contact Siebel Technical Support for assistance.

Possible Cause 11
Data transfer rate between data source server and Marketing Server. The transfer 
rate should be 8-10 MB per second.

How to diagnose 11. Transfer a relatively large file (around 500MB) from the data 
source server to the Marketing Server during the time of the day that snapshots are 
typically run.

How to resolve 11. Contact your systems administrator for assistance.
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Possible Cause 12
Data transfer rate between the Marketing Server and the Siebel file system. The 
Transfer rate should be 8-10 MB per second.

How to diagnose 12. Transfer a relatively large file (around 500MB) from the 
Marketing Server to the Siebel file system during the time of the day that snapshots 
are typically run.

How to resolve 12. Contact your systems administrator for assistance.

Possible Cause 13
Too much time used to count the snapshot. The count rate should be 200,000 to 
400,000 records per minute.

How to diagnose 13. In the marketing snapshot file, subtract the time stamp between 
the last log record and the Application Name - Counter Allocate comment line.

How to resolve 13. Contact Siebel Technical Support for assistance.
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Marketing Reference A
This appendix contains the following reference material topics for marketing 
administrators and system administrators.

■ “Understanding Snapshot Generation Internal Processes” on page 560 might 
help you diagnose problems that occur during snapshot generation.

■ Saving Segments as Target Group Segments on page 563 describes what 
happens when you create a target group segment.
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Understanding Snapshot Generation Internal Processes
This section describes the internal processes that are used to generate a snapshot 
file and where to locate information about these internal processes in the Marketing 
Server log file. Understanding these internal processes might help you diagnose 
some problems you encounter during snapshot generation.

Table 78 describes some important elements of snapshot generation and the 
relationship of these elements to the snapshot file or Marketing Server log file.

The following topics describe the three parts of a snapshot build:

■ Preparation for Building a Snapshot File—Rcontrol

■ Building a Snapshot File—Rextract and Rcompute on page 561

■ Counting Records in a Snapshot File—Rcounter on page 562

Table 78. Selected Snapshot Generation Elements

Snapshot Element Description

Marketing Server log 
filename

Names for the Marketing Server log file begin with MktgSrvr_ 
(MktgSrvr and an underscore) and are followed by the Siebel Task 
ID. You can find Marketing Server log file in the Siebel log 
directory. 

Snapshot filename Snapshot filenames begin with a stage ID– (stage ID and a 
hyphen) and end with .BIN. There could multiple snapshot files 
for any given stage. All snapshot files are overwritten each time a 
snapshot is regenerated.

Stage ID Every stage in the system is assigned an Analysis ID (or stage ID) 
that is written to the Marketing Server log file. This stage ID is 
persistent and is used for all snapshots generated for that stage. 
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Preparation for Building a Snapshot File—Rcontrol
The first process that the Marketing Server starts when you request snapshot 
generation is rcontrol. Rcontrol summarizes the definition and rules needed for 
generating the snapshot. Unless there is an error during this process, there is no 
need to track it. In the Marketing Server log file, the log information for this process 
is between sections Application Name - Control Snapshot and Application 
Name - Compute Snapshot.

Rcontrol creates a table called Control Table in the Siebel database. The name of the 
control table is created by adding the prefix C_ to the stage ID and removing the 
hyphen. For example, a snapshot with a stage ID of 1-K24GH has a control table 
named C_1K24GH.

This table contains the list of tables and columns required for snapshot generation 
and may be requested by Siebel Technical Support to troubleshoot certain errors. 
For more information about querying tables and columns required for the snapshot 
process, see “Invalid Join Path” on page 544.

Building a Snapshot File—Rextract and Rcompute
After the first snapshot generation internal process (rcontrol) is complete, the 
Marketing Server queries the database for columns needed for the snapshot, reads 
the data from the database, computes custom measures, if required, and writes the 
results to the snapshot files. In the Marketing Server log file, the information about 
this step can be found in the section between Application Name - Compute 
Snapshot and Application Name - Counter Allocate.

This step caches required tables and sorts the merge cursors and accounts for most 
of the time used by snapshot generation. For information about join methods, see 
“Understanding Joins” on page 113

The Marketing Server starts two internal processes in this step.

Rextract Process
The steps in this process repeat until you receive the End of Data message.

The following are the steps in the rextract process:
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■ Query your RDBMS for each required table using SQL SELECT statements. The 
required columns in the select list should have an Order By statement for one of 
the fields selected in customer hierarchy field mappings. 

■ The denormalized customer data set is passed to the rcompute process.

Rcompute Process
The following steps in this process repeat for each customer until you receive the 
End of Data message.

■ Reads the denormalized data set for a customer.

■ Calculates filter measures, if any.

■ Applies filter criteria and removes records that don't meet the filter criteria.

■ Calculates other required custom measures based on filtered data.

■ Writes results to the snapshot file for that customer.

After the Marketing Server completes caching all cache tables and starts receiving 
data from the database for merge cursors, the Marketing Server writes the message 
Joining Records to the Marketing Server log file. The number of denormalized 
records that were processed is written to the log file by the Marketing Server. 

Counting Records in a Snapshot File—Rcounter
After the second snapshot generation internal process step (rextract and rcompute) 
is complete, the Marketing Server starts rcounter, the last snapshot generation 
internal process.

Rcounter evaluates all segments using the snapshot file, computes the gross and net 
counts, and writes these counts to the Marketing Server log file. In the Marketing 
Server log file, the information about this step is in the section following 
Application Name - Counter Allocate.

NOTE: When you modify segment criteria, the Marketing Server runs rcounter again 
to recalculate gross and net counts based on the new version of the snapshot file.
562 Siebel Marketing Guide Version 7.5.3



Marketing Reference

Saving Segments as Target Group Segments
Saving Segments as Target Group Segments
The following describes what happens when you create a target group segment and 
include it in a marketing program:

■ You create a request using the Siebel Answers screen and click the Results tab. 
While designing the report, you click Customize View, select the Create Segment 
option, and then click Finished to complete the report. You have the option to 
save the report for future use.

■ In the report, you apply filters until the filters represent the final audience. When 
you click the Create Segment hyperlink, the Siebel Marketing Segment screen 
appears.

■ Before stepping off the record, you must perform the following tasks so that the 
segment can be used as a target group segment.

■ Type a segment name.

■ Confirm that values in the Customer Hierarchy and Targeting Level fields are 
correct. If the administrator sets the default customer hierarchy to match the 
hierarchy used for Target Group Segmentation, these values automatically 
appear.

■ Confirm that the Segment is Type = Target Group. If you change the segment 
type to DD Segment, the application treats the segment as a criteria-based 
segment and the rest of this section will not apply.

■ When you step off the new target group segment record, the Siebel Marketing 
application performs the following actions:

■ Creates a new target group in the target group table (S_DD_TRGTGRP) in the 
Siebel transaction database. Descriptive information such as the date loaded, 
the count size for the target group, and the text of the logical SQL expression 
from the original report is associated with the target group.

NOTE: The Date Loaded and Count are empty at this point because the target 
group has not yet been loaded.
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■ Records the Logical SQL statement from the original Analytics report in the 
target group table (S_DD_TRGTGRP) and displays it in the SQL field in the 
Target Group form in the Siebel Marketing application.

■ When you are ready to load the target group into the transaction database, you 
click the Load/Refresh button in the Segments screen. When you click Load/
Refresh, the following actions occur:

■ The Siebel Marketing application takes the logical SQL that is stored for the 
target group and modifies the expression to remove all the fields from the 
SELECT clause. The application then inserts the required Customer IDs into 
the SELECT statement based on the Customer IDs that were mapped in the 
Customer Hierarchy view. If the target level is a higher customer level than 
the original report specified (for example, if the report was based on Contacts 
but the targeting level is Accounts), the application makes sure that all 
necessary customer IDs are included in the query so that deduplication can 
be performed.

■ When the SQL is prepared, the Siebel Marketing application runs the query 
against the Siebel Analytics Server to retrieve the customer IDs that satisfy 
the WHERE clause in the SQL Statement.

■ The list of Customer IDs resulting from the query is loaded into the target 
group data table (X_DD_TRGTGRPMBR) using the Analytic Adapters 
workflow process.

■ The Date Loaded and Count fields are updated to reflect the load time and 
number of customers included in the load.

■ In the Edit Segment view of the Segments screen, the criteria is updated to 
show that the new target group is linked to the segment.

NOTE: Target groups can be scheduled to load automatically. For more 
information, see “Refreshing a Target Group Segment List” on page 255.

■ After the segment with a preloaded target group is included in a program stage, 
you can generate a snapshot of those customers and load the campaign or 
campaigns. 
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■ You allocate the customers in each segment to the appropriate campaign or 
campaigns using the Allocation view. When allocations are complete, you select 
Load Campaign using the Program Flow right-click menu or the menu in the 
Program Explorer.
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new campaign, creating 342
offer, associating with a campaign 348
SmartScript, setting up 347
subcampaign, setting up 349

charts
Average Opportunity Revenue Analysis 

(Response) chart, viewing 398
Call Status Analysis chart, viewing 390

Call Status by Employee chart, 
viewing 390

Campaign Achievement chart, steps 
before viewing 388

Campaign Achievements, viewing in 
Siebel Campaigns 389

Campaign Achievements, viewing in 
Siebel Marketing 389

Campaign Analysis (Response) chart, 
viewing 395

campaign charts, about 388
Campaign Trend Analysis chart, 

viewing 394
Lead Quality Analysis by Campaign chart, 

viewing 391
Lead Quality by Analysis chart, 

viewing 392
Offer Analysis (Response) chart, 

viewing 396
Offer Type Analysis (Response) by 

Campaign chart, viewing 397
Offer Type Analysis (Response) chart, 

viewing 397
Opportunity Analysis (Response) chart, 

viewing 396
Opportunity Revenue Analysis by 

Employee chart, viewing 393
Opportunity Revenue Analysis chart, 

viewing 392
Order Revenue Analysis chart, 

viewing 393
response charts, about viewing in Siebel 

Campaigns 395
response charts, accessing 

(procedure) 395
Revenue Analysis (Response) chart, 

viewing 398
Trend Analysis by Employee chart, 

viewing 394
child joins, about and unidirectional and 

bidirectional joins 114
communication server requests, 

configuring 38
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component groups
enabling 35
group status, determining 35
group status, locating and verifying 35
synchronizing 36

contact information, working with
associating a list with a campaign, 

checking status 352
contact and prospects, viewing in Siebel 

Campaigns 355
contacts and prospects, viewing 354
imported or internal list, about 

associating with campaign 351
lists of contact information, types of 350
prospects or contacts, adding to a 

campaign 353
prospects or contacts, associating with a 

campaign 351
prospects or contacts, reviewing the 

request to associate 352
contact lists, viewing from 519
contacts

See also output file layout, working with
data matching and data cleansing 493
definition 491
removing from a list 522

Contacts List view, using to view contact 
information 520

cost parameter, about using and 
procedure 124

counts, updating 475
custom measures

See also bound measures
See also source code formats, creating
about 161
aggregation and restrictions, about 168
aggregation levels, list of 169
aggregation, applying to 

(procedure) 170
building expressions, about and logical 

functions (table) 164
creating (procedure) 163
deleting all or portion of expression 167

editing (procedure) 167
expressions (table) 162
expressions, adding to 165
mathematical expressions (table) 165
restrictions (table) 171
restrictions, applying to 171

customer hierarchies
See also individual customer hierarchy 

entries
about and example 105
designing customer hierarchies and 

levels, about and process 106
viewing details associated with source 

code format 179
customer hierarchies, creating

See also individual customer hierarchy 
entries

about and example 108
creating (procedure) 109
targeting levels, adding to a customer 

hierarchy 109
customer hierarchies, mapping tables to

See also individual customer hierarchy 
entries and joins

guidelines 111
mapping tables and targeting levels, 

about 110
new table, about mapping to customer 

hierarchies 112
sample customer hierarchy design 

(table) 110
targeting level, mapping tables and fields 

to 111
customer hierarchy aggregation level, 

about 169

D
D&B lists, about 350
D&B, integrating list management with

about 523
account data, viewing for D&B 

prospect 523
D&B prospect, promoting 524
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data mapping
field, maintaining after data 

mapping 101
mapping a table does not retrieve 

fields 546
new fields, adding after 101

data quality settings, verifying 494
data retrieval

about 154
automatic data retrieval, about setting 

up 103
automatic data retrieval, enabling 155
automatic data retrieval, workflow 

described 156
data retrieval for field values, 

canceling 156
data retrieval task status, checking 155
Enable Data Retrieval function, about 

using to general list of distinct 
values 103

resynchronizing attributes and getting 
field values, using to 154

data source
new server definition, adding for 89

data source names, defining 33
date measure criteria, creating 247
Decision Broker business service, 

configuring
 See also scores
about using 225
example, invoking business service using 

Siebel eScript 231
example, invoking business service using 

Siebel VB script 230
example, invoking Decision Broker using 

Personalization 228
example, using workflow to invoke a 

business service 226
prerequisites to configuring 225
testing campaigns with My Offer 

view 232
Decision Manager

See also decisions, creating and testing

about using 210
Decision Wizard, using to create a 

decision 215
decisions, creating and testing

See also decisions, retrieving information 
from Decision Broker

about 215
decision record, creating 

(procedure) 216
Decision Wizard, using to create a 

decision 215
deleting a decision 219
score, example of a decision that 

produces 218
testing a decision, about 220
testing a decision, ways to and 

procedure 220
decisions, retrieving information from 

Decision Broker
See also decisions, creating and testing
about 225
example, invoking business service using 

Siebel eScript 231
example, invoking business service using 

Siebel VB script 230
example, invoking Decision Broker using 

Personalization 228
example, using workflow to invoke a 

business service 226
prerequisites to configuring 225
testing campaigns with My Offer 

view 232
default log level, using to troubleshoot 

failed snapshot task 549
deleting

assignment skills 371
snapshot 465

Delivery Profiles
about 294
delivery profile, creating 295
offer, associating with 296

direct campaigns, targeted at 327
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direct mail offers, about and Direct Mail 
Offer view 299

distribution list of contacts. See output file 
layout, working with

distribution list, generating
exported lists, viewing 489
generating a list 487
lists that will be split by measure, 

previewing 486
load campaign workflow process, 

understanding 488
note, previewing not working 483
previewing (procedure) 485
previewing, about 483
sample list example 485
server task, checking status of 488
waves, distribution lists, and list 

previews 486
distribution method, vendor task 191
distribution profiles

vendor task, described 191
vendors, defining for 193

Do you have another offer? applet, 
about 322

documents
marketing plan, attaching to 435
programs and campaigns, attaching 

to 454
Downloads applet, about 324
drag-and-drop, about Program Flow 

Designer 399
Dun & Bradstreet. See D&B, integrating list 

management with

E
EIM_PRSP_CON interface table, deleting 

records in list 496
email

campaign scenarios 532
campaign, testing 374
campaigns, stopping, resuming, or 

restarting 531
offers, sending 376

Siebel eMail Response, about configuring 
to capture email responses 377

email offers
See also Delivery Profiles; offers, creating 

and using
about and Email Offers view 277
attachments, adding to email offers 279
offer template, associating with 303
offer template, associating with an email 

offer 278
outbound email distribution 526
outbound email load balancing 526
protocols supported 294

eMarketing, setting up and using
about 307
home page, accessing by visitors 308
Information page, about and 

applets 324
installing, applications to install before 

eMarketing 311
Offers pages, using and configurable 

applets 320
Product Detail view, about using 323
Request a Call view, about using and 

accessing 325
responsibilities and users, setting up 

default 313
Send Product Information view, about 

using and accessing 324
Siebel Personalization, using with 

eMarketing 314
unstructured content, additional 323
user access, tasks to control user 

access 312
user interface, customizing 315
Web site visitor, about 308
Web site, about 319
Web Survey view, about using 323

employees
Call Status Analysis by Employee chart, 

viewing 390
Opportunity Revenue Analysis chart, 

viewing 393
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Trend Analysis by Employee chart, 
viewing 394

Enable Data Retrieval function, using to 
generate list of distinct values 103

eNewsletter offers, creating and editing
See also Delivery Profiles 294
about and eNewsletter Offer view 

tabs 281
attachments, adding to eNewsletter 

offers 287
creating eNewsletter offers 282
eNewsletter rules, creating 286
eNewsletter rules, creating conditions for 

the rule 286
eNewsletter sections, about adding 283
eNewsletter sections, about editing 285
eNewsletter sections, resequencing 284
eNewsletter sections. adding and 

applying rules 283
multiple templates, adjusting to MIME 

Alternative standard 283
outbound email distribution 526
outbound email load balancing 526

errors
campaign record, handling 540
field name retrieval, troubleshooting 

during 101
Internal Communication protocol error 

message 485
Even % for All Campaigns allocation 

method 472
Even % for Unallocated Campaigns 

allocation method 472
events

offers, about how links appear in an 
offer 290

offers. about associating with 289
offers. associating with (procedure) 291

Exclusion box, removing expressions 
from 240

exported lists, viewing 489
expressions

custom measure, adding to 165

deleting all or portion of 167
virtual field, using expressions to 

create 104
External Keys table (S_DD_USER_KEY), 

about 65
external lists, about 350
external lists, importing and managing

See also internal lists, creating and 
managing

about 493
campaign and response data, 

importing 501
campaign and response fields, 

mapping 502
database columns in the prospect table, 

mapping list columns to 500
existing List Import Format, applying to 

your list 505
fields, mapping to when importing a 

lists 505
import mode, selecting (procedure) 499
import request, tracking the status 

of 501
import status and error messages, 

understanding 507
importing an external list, creating a 

record 497
importing external lists, format and tasks 

performed 496
List Import Format, about editing the 

settings 506
List Import Format, about using 505
List Import mode, selecting 498
list import request, launching 501
list records, maintaining attributes 

for 503
log file, viewing for an import task 507
mapping fields when importing, 

about 504
server components and tasks, verifying 

status of 494
extractor, analytic adapter component 77
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F
fax offers

See also Delivery Profiles
about and Fax Offer view 292
offer template, associating with fax 

offer 293
sending 376

Featured Offers applet, about 321
fields, working with

automatic data retrieval, about setting 
up 103

field names, about retrieving during data 
mapping 100

field names, troubleshooting during 
retrieval 100

field values, data retrieval 103
fields, maintaining after data 

mapping 101
mapping a character field to a numeric 

field 100
new fields, adding after data 

mapping 101
virtual fields, creating using 

expressions 104
wildcard search, performing for 

(procedure) 249
wildcard searches, about performing 

for 248
filter and segment criteria, defining

See also segment criteria, creating and 
editing

about 234
business scenario 234
filter expressions, about selecting 

available values 238
filter expressions, building 

(procedure) 238
filter expressions, removing 240
filter expressions, using Or in an 

expression 239
filter records, creating (procedure) 236
filters, defined and displaying 236

segment information 242
filters

See also scores
creating (procedure) 236
criteria, about defining 238
criteria, building (procedure) 238
defined and displaying 236
definition 27
expression, using OR in an 

expression 239
expressions, removing 240
offer list, using profile information to 

filter dynamically 205
fixed costs, about 439
forecast allocation

See also segment count, allocating to 
campaigns

about using 473
counts, updating and Clear Allocation 

functions 475
Forecast Mode, using for allocation 474

forecast expenses and revenues, about and 
field (table) 432

forecast, definition 27
Forecast’s Predicted Results form fields 

(table) 443
forecasting for campaigns

See also activity plans, creating and using; 
activities, creating and using; 
timelines

about 438
campaign plan costs, adding 440
campaign plan costs, entering 439
campaign results under a forecast, 

tracking 444
creating forecasts 439
Forecast’s Predicted Results form fields 

(table) 443
list inputs, using assumptions based 

on 442
per sale consumptions, adding revenue or 

contributions 442
segment input, adding 440
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frames, implementing eMarketing without 
frames 317

fund request
marketing plan, associating with 434
marketing plan, viewing request 

associated with 434

G
global deployment, eMarketing 307
Globalization Rules

offers, applying to 264
Gross count, allocating segments 471
guide

audience for 19
organization of 21

H
hint field

setting up and passing in SQL 
queries 555

using in troubleshooting 555
history, ways to find status history 539
HTML

editor, using to edit the offer 
template 271

frames, implementing eMarketing 
without frames 317

I
IBM DB2, verifying database Page Size 

parameter 37
import request, tracking the status of 501
imported lists

campaign, about associating with 351
importing a list

mapping fields when importing 505
inbound costs, about 439
inbound offers, Real-Time Marketing Offer 

fields (table) 198
Inclusion box, removing expressions 

from 240

incoming data, validating the structure 
of 496

IncrementDisplayCount ( ), about and 
parameters 209

indirect campaigns, targeted at 327
Information applet, about 322
initializing Siebel Marketing

data source names, defining 33
initializing Siebel marketing

See also Marketing Administrators access 
group; Max EAI Records parameter

component groups, enabling 35
component groups, synchronizing 36
database Page Size parameter, verifying 

for DB2 37
initialization checklist 32
Marketing Repository server definition, 

creating 37
marketing server components, about 

setting up and list of (table) 34
multistage programs, initializing 40
opportunities and orders, enabling 

automatic response 43
Siebel Server process, restarting using 

Microsoft Windows 37
User Name parameter, verifying create 

table privileges for 36
Wave Batch Size parameter, 

configuring 38
workflow processes, activating 42

Input Summary form, using 441
integration components

about 56
campaign load mapping, validating 64
mapping integration components and 

fields 63
mapping rules (Marketing Contact) 59
mapping rules (Marketing Person) 67
Marketing Person integration object, 

creating a campaign load mapping 
using 68

Marketing Person integration object, 
mapping scenarios 70
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internal lists
about 350
campaign, about associating with 351

internal lists, creating and managing
See also external lists, importing and 

managing; prospects, promoting
about and list of tasks 508
contacts or prospects, adding to an 

internal list 511
creating internal lists, about 510
internal list, adding using prospect 

attributes 512
internal lists of contacts or prospects, 

creating 510
lists of prospects, about creating using 

attributes 511
lists of prospects, creating using attributes 

(procedure) 512
Internet SMTP/POP3 communications 

driver, about using for inbound and 
outbound communications 294

J
joining tables and fields

See also fields, working with; joins, 
understanding

caching, guidelines for 119
cost parameter, about using and 

procedure 124
customer hierarchies and joins, 

guidelines 118
new join between tables, creating 119
table fields, joining 122

joins, understanding
See also joining tables and fields
about and example 113
attribute joins, about using 116
multistage programs, creating for 41
parent and child joins, about and 

unidirectional and bidirectional 
joins 114

start point joins, about using 115
table joins, about using 115

L
Lead Quality Analysis by Campaign chart, 

viewing 391
Lead Quality by Analysis chart, 

viewing 392
List Contacts and Prospects view, using to 

promote a prospect 516
List Import Format

about using 505
editing the settings, about 506
existing List Import Format, applying to 

your list 505
import status and error messages, 

understanding 507
List Import mode, selecting 498
list import request, launching 501
list management

See also external lists, importing and 
managing; internal lists, creating and 
managing

about 491
list file name format 519
tasks, list of 491

list measures
defining, about 173

list output formats, definition 28
list records

additional attributes, adding to list 504
additional attributes, creating 504
attributes, maintaining for list 

records 503
Lists Split by Measure, previewing 486
Lists view. using to view a contact or 

prospect list 519
lists, generating

exported lists, viewing 489
generating a list 487
lists that will be split by measure, 

previewing 486
load campaign workflow process, 

understanding 488
note, previewing not working 483
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previewing (previewing) 485
previewing, about 483
sample list example 485
server task, checking status of 488

lists, viewing and maintaining
about and format 519
Contact or Prospects List view, using to 

view contact or prospect 
information 520

contacts, removing from a list 522
deactivating lists 521
deleting lists 521
Lists view, using to view a contact or 

prospect list 519
prospects, removing from a list 521

literature
offer, associating with 301

load campaign, definition 27
log file

import task, viewing 507
logical custom measure expressions 

(table) 164

M
manually launching programs, about 525
mapping fields

about 504
when importing a list (procedure) 505

Mapping tables, multistage program 
initialization 40

mapping tables, procedure 40
mappings

table mappings, about preserving 91
tables, mapping from a data source 92

Market Development Funds module (MDF)
fund request associated with marketing 

plan, viewing 434
fund request, associating with a 

marketing plan 434
Market Plan Explorer, using to review 

marketing plan organization and 
associated tactics 435

Marketing Administrators access groups

See also initializing Siebel marketing
user’s position, about adding to 43
user’s position, about adding to 

(procedure) 44
Marketing Contact integration object

about 56
mapping rules 59
User Key fields, about 66

marketing integration objects
about and diagram 57
campaign load mapping, used for 56
Contact Key components, sample 

mappings (table) 61
mapping rules for integration 

components (Marketing Contact) 59
marketing person integration component 

description (table) 59
Marketing Person integration object

about 56
about using and component description 

(table) 67
campaign mapping, creating using 68
integration components (table) 59
mapping scenarios 70
note, about ID required to confirm person 

in db 66
marketing plan, definition 27
marketing planning and budgeting

budgets, developing and assigning for a 
marketing plan 432

forecast and actual expenses for the 
marketing plan, calculating 433

fund request associated with a marketing 
plan, viewing 434

goal for marketing plan, creating 429
marketing plan organization and 

associated tactics, reviewing using 
Plan Explorer 435

marketing plan tactics, assigning a budget 
to 433

marketing plan tactics, associating with 
the marketing plan 431
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marketing plan to marketing subplan, 
changing 428

marketing plan, about creating 426
marketing plan, associating a fund 

request with 434
marketing plan, attaching a document 

to 435
marketing plan, creating 

(procedure) 426
marketing plan, recalculating 433
marketing subplan, creating 428

marketing program
See also automatic execution of programs
campaign launch status, monitoring 530
email campaign scenarios 532
email campaign, monitoring the status 

of 534
email campaign, stopping, resuming, or 

restarting 531
launching 525
manually launching campaigns 

(procedure) 529
manually launching campaigns, 

prerequisites 527
task log, viewing 530

marketing program plans, designing
See also Program Flow view
attribute family, guidelines for creating 

from Siebel Data Warehouse 418
attribute family, guidelines for creating 

from the Siebel Database Campaign 
History 420

marketing program tasks, list of 399
multistage programs, about and types of 

programs 402
multistage programs, about 

launching 404
multistage segmentation, enabling and 

targeting using campaign 
history 417

program plans, about 399
program plans, about creating 405
program plans, creating (procedure) 405

Program Wizard, about and 
launching 408

marketing program stage
segments, adding 440

marketing program, defined 28
marketing programs and campaigns

Explorer, using to monitor concurrent 
programs 453

Marketing Repository
about and setting up server types 88
server definition, creating 37

marketing server components
component group status, 

determining 35
component groups, enabling 35
component groups, synchronizing 36
setting up, about and list of (table) 34

Marketing Server task information log file, 
using to troubleshoot failed snapshot 
task 549

mathematical custom expressions 
(table) 165

Max EAI Records parameter
See also initializing Siebel marketing
adjusting the size, about 38
increasing the parameter, advantages 

to 39
reducing the parameter, advantages 

to 39
viewing or changing (procedure) 39

measures, creating
See also bound measures; list measures; 

custom measures
tasks, list of 157

media offers, about and Media Offers 
view 300

merge joins, about 113
Microsoft Exchange, customizing email 

protocols 294
Microsoft Windows

Siebel Server process, restarting 37
MIME Alternate standard, adjusting 

multiple templates 283
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multilingual deployment, eMarketing 307
multistage programs

about and types of programs 402
launching, about 404

multistage programs, initializing
about 40
joins, creating for multistage 

programs 41
S_CAMP_CON and S_DD_USER_KEY 

tables, mapping 40
multistage recurring campaigns

multiple waves, setting up 478
vendor-specific lists, creating 480

multistage segmentation, enabling 417
attribute family, guidelines for creating 

from the Siebel Data Warehouse 418
attribute family, guidelines for creating 

from the Siebel Database Campaign 
History 420

My Offer view, associating responsibilities 
with 232

N
nested loop joins

about 113
troubleshooting 553, 554

Net count, allocating segments 471
numeric measure criteria, creating 246

O
ODBC setup errors, troubleshooting during 

field name retrieval 101
Offer Analysis (Response) chart, 

viewing 396
offer delivery, about 195
offer group

creating (procedure) 207
group suppression, about and 

example 207
suppression behavior, changing 208

offer qualification, about 195
offer rejections, tracking

group suppression, about and 
example 207

offer group suppression, changing 
behavior 208

offer group, creating 207
offer sorting, about 195
offer templates, creating and editing

See also offers, creating and using
about and offer types associated 

with 265
creating an offer template 266
email offer, associating with 278, 303
hyperlinks (HREF). using in a 

template 267
offer template associated with an offer, 

editing in the default HTML 
editor 271

offer template associated with an offer, 
editing in the Offers screen 269

offer template associated with an offer, 
using the Siebel HTML editor 270

Offer Templates list, adding a template 
to 267

Personalization Categories, about 
using 273

template not associated with an offer, 
editing 268

Offer Type Analysis (Response) by 
Campaign chart, viewing 397

Offer Type Analysis (Response) chart, 
viewing 397

offer, definition 28
offers

campaign plan, associating with 335
campaign, associating with 348
custom sorting, ways to 200
inbound offers, creating (Real-Time 

Marketing Offer fields) 198
offer code lookups, performing 379
offer list, using profile information to 

filter dynamically 205
personalization rules, creating to 

establish sort specifications 203
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profile information, sorting an offer list 
dynamically using 203

qualifying offers, about 199
rule set, creating and associating with an 

applet 204
sorting and filtering, about 199
standard sort, using based on targeting 

and offer name 199
testing prerequisites 373

Offers page, using and configurable 
applets 320

offers, creating and using
See also Delivery Profiles; email offers; 

offer templates, creating and editing
Delivery Profiles, about 294
Delivery Profiles, associating with an 

offer 296
Delivery Profiles, creating a delivery 

profile 295
direct mail offers, about and Direct Mail 

Offer view 299
eNewsletter offers, creating and 

editing 281
fax offers, about and Fax Offer view 292
fax offers, associating an offer template 

with 293
Globalization Rules, applying to 

offers 264
literature, associating with an offer 301
media offers, about and Media Offers 

view 300
offer template, associating with an email 

offer 303
offer, creating 259
offers, about 257
offers, modifying 264
phone offers, working with 297
product, associating with an offer 264
Web offers, about and Web offers 

view 302
Web offers, adding attachments to 304

Web offers, Web surveys, events, and 
URLs. about associating with 
offers 289

Web offers, Web surveys, events, and 
URLs. about how links appear in an 
offer 290

Web offers, Web surveys, events, and 
URLs. about Web Survey view 289

Web offers, Web surveys, events, and 
URLs. associating with offers 
(procedure) 291

OLAP, online analytical processing 77
Open Database Connectivity data source 

names, defining 33
opportunities

automatic response, enabling 43
campaign, creating for 396

Opportunity Analysis (Response) chart, 
viewing 396

Opportunity Revenue Analysis by Employee 
chart, viewing 393

Opportunity Revenue Analysis chart, 
viewing 392

Order Revenue Analysis chart, 
viewing 393

orders, enabling automatic response 43
organization of 21
outbound costs, about 439
output file layout, working with

about 183
components, adding to output file 

layouts 185
creating output list layouts 

(procedure) 183
previewing distribution lists and 

formats 188
program stage, associating with 188
prospects, adding and creating a seed 

list 187
seed list, changing name of 188

output file layouts, working with
vendor task, about 190
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output list of contacts. See output file layout, 
working with

output lists, definition 28

P
parent joins, about and unidirectional and 

bidirectional joins 114
partition tables

examples 95
guidelines 95
understanding 94
union table rules, examples of 95
union table, about associating with 98
union tables, about creating with 

associated partition tables 99
pass-through table, about 95
Personalization Categories drop-down list, 

about and using 273
personalization rules, creating rules to 

establish sort specifications 203
Personalization, using with 

eMarketing 314
phone offers, working with

about phone orders 297
call guides, about and creating 297
call guides, creating a call guide 298

Pick Campaign dialog box, using to define 
new campaign with offer 416

Plan Explorer, using to review marketing 
plan organization and associated 
tactics 435

Preview List, about preview not 
working 483

previewing waves, distribution lists, and list 
previews 486

Product Detail view, about using 323
products, associating with offers 264
profile information

offer list, using to filter dynamically 205
offer list, using to sort dynamically 203

program and campaign organizational tools
about 437

program execution schedule

creating 535
deleting 537
editing 536

Program Execution workflow, about using 
to launch multistage programs 404

Program Explorer
campaign plan, using to create 333
concurrent marketing programs and 

campaigns, using to monitor 453
Program Flow Designer, about 399
Program Flow view

See also marketing program plans, 
designing

about using 410
campaign plan, using to create 334
campaign, adding list to 417
new campaign with offer, defining 416
predefined campaigns with associated 

offers, adding 415
segments, adding to a program 

stage 414
stage, adding to the program 411

program plan
definition 28
program plans timeline, about 446
See also marketing program plans, 

designing
program snapshot. See snapshot files, 

generating and maintaining
program stage, associating with output file 

layout 188
Program Wizard, about and launching 408
program, definition of a marketing 

program 28
programs

See also automatic execution of programs
campaign launch status, monitoring 530
campaign record, handling errors 

on 540
documents, attaching to 454
email campaign scenarios 532
email campaigns, monitoring the status 

of 534
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email campaigns, stopping, resuming, or 
restarting 531

execution history, about tracking 539
manually launching campaigns 

(procedure) 529
manually launching campaigns, 

prerequisites for 527
marketing programs, launching 525
occurrence, selecting an 540
task log, viewing 530

promotion map
about modifying and prospect 

information (table) 517
map entries, modifying 518

prospect lists
deleting prospects from list 522
Lists view, viewing from 519

Prospect records, about updating using 
Update Existing Duplicates Mode 498

prospects
campaign, adding to 353
campaign, associating with 351
data matching and data cleansing 493
definition 491
list, removing from 521
viewing in Siebel Marketing 354

Prospects by Attribute view, using to 
promote a prospect 516

Prospects List view, using to view prospect 
information 520

Prospects More Info view, using to promote 
a prospect 515

prospects, promoting
Campaigns Opportunity, using to promote 

a prospect 516
List Contacts and Prospects view, using to 

promote a prospect 516
promotion map, modifying, about and 

prospect information (table) 517
prospect, promoting to a contact, about 

and application checks 514
prospect’s response to an opportunity, 

about promoting 516

Prospects by Attribute view, using to 
promote a prospect 516

Prospects More Info view, using to 
promote a prospect 515

prospects, defined 514

Q
quotas. See campaign quotas, setting up

R
rcompute, generating snapshot internal 

process 562
rcontrol, generating snapshot internal 

process 561
rcounter, generating snapshot internal 

process 562
real-time marketing. See Siebel Real-Time 

Marketing
Recommended Products applet, about 321
record aggregation level, about 169
RejectOffer( ), about and parameters 209
Request a Call view, about using and 

accessing 325
Request More Information applet, 

about 324
resolve incoming duplicates mode, 

about 499
response charts

accessing (procedure) 395
Average Opportunity Revenue Analysis 

(Response) chart, viewing 398
Campaign Analysis (Response) chart, 

viewing 395
Offer Analysis (Response) chart, 

viewing 396
Offer Type Analysis (Response) by 

Campaign chart, viewing 397
Offer Type Analysis (Response) chart, 

viewing 397
Opportunity Analysis (Response) chart, 

viewing 396
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Revenue Analysis (Response) chart, 
viewing 398

Siebel Campaigns, about viewing in 395
response data

importing, about and List Import view 
described 501

response fields for mapping import 
data 502

Response Details form, fields (table) 382
response management, using

about 377
attachments, adding 381
automatic response, about creating from 

opportunities and orders 386
offer code lookups, performing 379
opportunities, adding 381
orders, adding 380
products, adding 380
Response Details form, fields 

(table) 382
response information, adding 377
response, promoting to an 

opportunity 385
source code lookups, performing 379

response, definition 28
responses

adding attachments to 381
adding opportunities to 381
adding orders to 380
adding products to 380

responses management, about 317
responsibilities, setting up for 

eMarketing 313
restrictions

custom measure restrictions (table) 171
custom measures, applying to 171

results, definition 28
Retrieve Data functionality, about 

synchronizing new attributes with 
those in the data source’s table 150

Revenue Analysis (Response) chart, 
viewing 398

rextract, generating snapshot internal 
process 561

rollups, definition 136
rule set, creating and associating with an 

applet 204

S
S_CAMP_CON table, mapping 40
S_DD_USER_KEY table, mapping 40
Salutation applet, about 320
Schedule Calendar view. See automatic 

execution of programs
scores

dynamically calculated data, filtering 
on 222

real-time behavioral scores, sorting 
on 221

sorting and filtering by, about 221
scoring engine, creating an interface to

intermediate DLL code, example 212
seed lists

name, changing name of 188
prospects, adding and creating a seed 

list 187
segment count, allocating to campaigns

See also forecast allocation
about 467
campaign, allocating a segment to 

(procedure) 470
distributing segments, about 468
segments, allocating (2 methods) 472

segment criteria, creating and editing
See also filter and segment criteria, 

defining
attributes and fields, about performing 

wildcard searches for 248
attributes, performing wildcard search 

for 249
date measure criteria, creating 247
fields, performing a wildcard search 

for 249
numeric measure criteria, creating 246
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segment criteria, about defining on the 
Segments screen 245

segment definitions, building 245
target group segmentation, about using to 

create segments 125, 251
segment definitions

displaying list of programs and stages that 
use 244

editing 244
viewing team who can create or 

modify 244
segment definitions, building 245
segment information

about 242
creating segments 243

segment, adding to campaign plan 440
segment, definition 28
Segments screen

attributes and fields, about performing 
wildcard searches for 248

attributes, performing wildcard searches 
for 249

date measure criteria, creating 247
fields, performing a wildcard search 

for 249
numeric measure criteria, creating 246
segment criteria, about defining 245
segment definitions, building 245

Send Product Information view, about using 
and accessing 324

server components and tasks, verifying 
status of

about and list of components 494
data quality settings, verifying 494
incoming data, validating the structure 

of 496
server definitions

about 88
data source server definitions, about 

creating 88
Marketing Repository, about and server 

type 88

new server definition, adding for a data 
source 89

server task, checking status of 488
Servers List, mapping from tables 90
set distribution periods. See waves
Siebel Analytics

data source names, defining 33
Siebel Analytics Server, setting up

about configuring 211
prerequisites, list of 211
Siebel Analytics repository mapping, 

about creating 214
third-party scoring engine, creating an 

interface to 212
Siebel Campaigns

See also campaigns; campaign plans; 
charts

Campaign Achievements, viewing 389
Siebel Contact table

about and list of tables 65
campaign load table update rule 

(table) 66
Siebel Data Warehouse Campaign History, 

guidelines for creating an attribute 
family from 418

Siebel Database Campaign History, 
guidelines for creating an attribute 
family from 420

Siebel Decision Manager
See also decisions, creating and testing
about using 210

Siebel Dun & Bradstreet
account data, viewing for a D&B 

prospect 523
D&B prospect, promoting 524
list management, about integrating 

with 523
Siebel eMail Response, about configuring to 

capture email responses 377
Siebel HTML Editor to edit the offer 

template 270
Siebel Marketing
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See also campaign plans, setting up in 
Siebel Marketing

Campaign Achievements, viewing 
in 389

campaign plans, about launching in 329
Siebel Marketing Server, about 88
Siebel Personalization, using with 

eMarketing 314
Siebel Real-Time Marketing

See also Siebel Real-Time Marketing-
basic, setting up; Siebel Real-Time 
Marketing with Siebel Analytics, 
setting up

features, list of 195
personalize eMarketing, about using 

to 315
ways to use, list of 196

Siebel Real-Time Marketing with Siebel 
Analytics, setting up

See also Siebel Real-Time Marketing; 
Siebel Real-Time Marketing-basic, 
setting up

about and list of tasks 210
Siebel Analytics Server, setting up 211

Siebel Real-Time Marketing-basic, setting 
up

See also Siebel Real-Time Marketing; 
Siebel Real-Time Marketing with 
Siebel Analytics, setting up; filters; 
offers

about 197
Application Programming Interface (API) 

methods, about 208
qualifying offers, about 199
Real-Time Marketing Offer fields 

(table) 198
sorting and filtering offers 199
tracking offer rejections 207

Siebel Server, restarting process using 
Microsoft Windows 37

Siebel Web Engine, about 311
skills

skill items defined 368

skill items, associating with a skill 369
skip incoming duplicates mode, about 498
SmartScript, setting up 347
SMTP protocols, customizing email 

protocols 294
snapshot

definition 28
snapshot files, generating and maintaining

automatically generating a snapshot 
file 458

data elements, adding to snapshot 
file 463

deleting a snapshot 465
generating a snapshot file, about and 

directories created 457
guidelines for using snapshot files 456
improving snapshot performance 552
manually generating a snapshot file 458
modifying contents of snapshot file, 

about 463
program snapshot, about 455
resolving snapshot counts 

discrepancies 550
snapshot task, checking status of 459
stage plan details, modifying 464
stopping a snapshot in Active status 461
stopping a snapshot task in Pending 

status 461
troubleshooting failed snapshot 

task 549
snapshot generation internal processes

rcompute 562
rcontrol 561
rcounter 562
rextract 561
rextract and rcompute 561
understanding 560

sorting
See also scores
custom offer sorting 200
offer list, using profile information to sort 

dynamically 203
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offers, using standard sort based on 
targeting and offer name 199

rule set, creating and associating with an 
applet 204

sort specifications, creating 
personalization rules to 
establish 203

Source Code Formats list
about 178
reordering list 182

source code formats, creating
creating source code formats 

(procedure) 179
source code format components, 

defining 180
Source Code Formats list, viewing 

available formats 178
ways to use, about 178

source code lookups, performing 379
source code, definition 29
stage

campaign record, handling errors 
on 540

definition 29
execution history, about tracking 539
occurrence, selecting an 540

start point join, about using 115
status bars, understanding timelines 447
status history, ways to find 539
Status timeline, about 446
stopping

snapshot task in Active status 461
snapshot task in Pending status 461

subcampaigns, setting up 349
subwaves, determining the number 

created 525
suppressions, definition 29
synchronizing

component groups 36

T
table joins, about using 115

See also joins, understanding

Table setup errors, troubleshooting during 
field name retrieval 100

tables
 See also customer hierarchies, mapping 

tables to
mapping tables from a data source 92
mappings, about preserving 91
parent and child joins, about and 

unidirectional and bidirectional 
joins 114

partition and union tables, 
guidelines 95

partition and union tables, 
understanding 94

partition tables, about associating with a 
union table 98

S_CAMP_CON and S_DD_USER_KEY 
tables, mapping 40

Servers List, mapping tables from 90
union table rules, examples of 95
union tables, creating with associated 

partition tables 99
target group segmentation. See segment 

criteria, creating and editing
target groups

load completed successfully, 
verifying 85

loading (procedure) 84
targeting level aggregation, about 169
targeting levels

customer hierarchy, adding to 109
tables and fields, mapping to 111

task information log file, using to 
troubleshoot failed snapshot task 549

teams
campaign plan, assigning to 336
organizations inheritance, turning 

off 405
telemarketing offers, about defining 297
templates. See offer templates, creating and 

editing
templates. See individual template entries
terms used (table) 27
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Test Server, about 88
response management, using. See 

individual campaign items
testing campaigns and offers

See individual campaign items
about 373
business scenario 373
email and fax offers, sending 376
email campaign, testing 374
testing offers, prerequisites 373

The New User Link applet. about 320
third-party scoring engine, creating an 

interface to 212
timelines

See also forecasting for campaigns
about 446
color-code status bars, 

understanding 447
navigating to and from timelines 447
types of 446

tools. See program and campaign 
organizational tools

Trend Analysis by Employee chart, 
viewing 394

troubleshooting
about 543
data dictionary process does not retrieve 

fields 546
failed snapshot task 549
fields name retrieval, possible errors 100
generating snapshot fails 549
improving snapshot performance 552
invalid join path error 544
mapping a table does not retrieve 

fields 546
mapping table, fields not retrieved 546
Marketing error messages, about 544
other Marketing issues, about 546
resolving snapshot counts 

discrepancies 550
setting the default log level 549

using the Marketing Server task 
information log file 549

using the task information log file 549

U
unclear data, about and trapping 150
unidirectional join connection, about and 

example (diagram) 114
union tables

creating with associated partition 
tables 99

examples 95
guidelines 95
partition table, about associating 

with 98
pass-through table, alternative to 95
understanding 94
union table rules, examples of 95

unordered collections, about 134
update existing duplicates mode

about 498
URLs

offers, about how links appear in an 
offer 290

offers, associating with 289
offers, associating with (procedure) 291

user interface, customizing
about 315
eMarketing without frames, 

implementing 317
full-text search, about 317
response management, about 317
Web templates, using 316

User Name parameter, verifying create table 
privileges for 36

user-defined label record
attribute labels, about creating 146
attribute labels, creating 

(procedure) 147
attribute labels, example 148
guidelines for when to create new labels 

(table) 147
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V
vendor profiles, setting up

defining vendors and assigning list 
distribution method 191

distribution profiles, defining for 
vendors 193

multiple list formats, handling 192
vendor tasks, list of 190
vendors defined 190

vendors
defined 190
multiple list formats, handling 192

vendor-specific lists, creating 480
virtual fields, creating using 

expressions 104

W
Wave Batch Size parameter

configuring 38
subwaves, determining the number 

created 525
waves

about using 477
definition 29
multiple waves, setting up 478
vendor-specific lists, creating 480

Web Anonymous User responsibility, 
about 313

Web Corporate User responsibility, 
about 313

Web Offer applet, about 320
Web offers

about and Web Offers view 302
attachments, adding to 304
offers, about associating with 289
offers, about associating with 

(procedures) 291

offers, about how links appear in an 
offer 290

Web Offers Downloads, using to add 
attachments to Web offers 304

Web Registered User responsibility, 
about 313

Web site
eMarketing home page, accessing by 

visitors 308
eMarketing Web site, about 319
user access, tasks to control user 

access 312
visitor, about 308

Web Survey view
eMarketing Offers page, about using 323

Web surveys
offers, about associating with 289
offers, about links appear in an 

offer 290
offers, associating with (procedure) 291
Web survey link, about clicking on 289

Web templates, using to customize the user 
interface 316

wildcard searches
attributes and fields, about performing 

for 248
attributes, performing search for 

(procedure) 249
fields, performing search for 

(procedure) 249
Windows, restarting Siebel Server 

process 37
workflow process

activating 42
analytic adapter components 78
analytic adapter data table, adding to 81

Workspace box, removing expressions 
from 240
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