
CallCenterAnywhere™

Administration Manager
User’s Guide

Version 7.1.7

CCA_AM.book  Page i  Wednesday, July 26, 2006  2:55 PM



CCA_AM.book  Page ii  Wednesday, July 26, 2006  2:55 PM



Telephony@Work, Inc., Confidential and Proprietary Information

iii

CCA USER GUIDE

The software described in this book is furnished under a license agreement and may be used only in 
accordance with the terms of the agreement.

COPYRIGHT NOTICE

USER GUIDE © 1998-2006 TELEPHONY@WORK, INC.

All Rights Reserved.

Released: 07/24/06 for CCA 7.1 [R7M1.7SP3]

All intellectual property rights in the CCA USER GUIDE are owned by TELEPHONY@WORK, INC. and 
are protected by United States copyright laws, other applicable copyright laws and international treaty 
provisions. TELEPHONY@WORK, INC. retains all rights not expressly granted. 

This document may not, in whole or in part, be copied, photocopied, reproduced, translated, stored in 
a retrieval system, reduced to any electronic medium or machine-readable form or transmitted by any 
means, without prior consent in writing from Telephony@Work, Inc., 4225 Executive Square, Suite 
600, La Jolla, CA 92037.

ALL EXAMPLES WITH NAMES, PROJECTS, COMPANY NAMES, OR COMPANIES THAT APPEAR IN THIS 
MANUAL ARE IMAGINARY AND DO NOT REFER TO, OR PORTRAY, IN NAME OR SUBSTANCE, ANY 
ACTUAL NAME, PROJECT, COMPANIES, ENTITIES, OR INSTITUTIONS.  ANY RESEMBLANCE TO ANY 
REAL PERSON, PROJECT, COMPANY, ENTITY OR INSTITUTION IS PURELY COINCIDENTAL.

TRADEMARKS

Telephony@Work, the Telephony@Work logo, CCA, the CCA logo, Interaction Manager, Supervision 
Manager, Administration Manager, Network Manager, Mail Manager, Programmers Not Required and 
Integration-By-Design are the trademarks, service marks and logos of Telephony@Work, Inc. in the 
United States and other countries. Use of these marks is not permitted without the prior written 
consent of Telephony@Work, Inc. 

Proxy Gateway is a trademark of Funk Software, Inc. Other product names mentioned in this manual 
may be trademarks or registered trademarks of their respective companies and are the sole property 
of their respective owners.

DISCLAIMERS

Every effort has been made to ensure the accuracy of this user manual.  However, information in this 
document is subject to change without notice and does not represent a commitment on the part of 
Telephony@Work, Inc.  Telephony@Work, Inc. provides this information on an “as is” basis and makes 
no warranties with respect to this documentation and disclaims any implied warranties, including, 
without limitation, implied warranties of merchantability and fitness for a particular purpose. 
Telephony@Work, Inc. shall not be liable for any errors or for incidental or consequential damages in 
connection with the furnishing, performance, or use of this user manual or the examples herein.  

TELEPHONY@WORK, INC. LICENSE AND WARRANTY

NOTICE:   IF YOU HAVE SIGNED TELEPHONY@WORK, INC.'S STANDARD FORM SOFTWARE LICENSE 
AGREEMENT THEN THE TERMS OF THAT AGREEMENT SHALL GOVERN.   
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IF TELEPHONY@WORK, INC.'S STANDARD FORM SOFTWARE LICENSE AGREEMENT HAS NOT BEEN 
SIGNED THEN TELEPHONY@WORK, INC. LICENSES THE ENCLOSED SOFTWARE TO YOU ONLY UPON 
THE CONDITION THAT YOU PAY ALL SOFTWARE LICENSE FEES AND ACCEPT ALL THE TERMS 
CONTAINED IN THIS LICENSE AGREEMENT.  PLEASE READ THE TERMS CAREFULLY BEFORE OPENING 
THIS PACKAGE, AS OPENING THE PACKAGE WILL INDICATE YOUR ASSENT TO THEM.  IF YOU DO NOT 
AGREE TO THESE TERMS, THEN TELEPHONY@WORK, INC. IS UNWILLING TO LICENSE THE 
SOFTWARE TO YOU, IN WHICH EVENT YOU SHOULD RETURN THE FULL PRODUCT WITH PROOF OF 
PURCHASE TO THE DEALER FROM WHOM IT WAS ACQUIRED WITHIN THIRTY DAYS OF PURCHASE, 
AND YOUR MONEY WILL BE REFUNDED.

LICENSE 

The software that accompanies this license (the “Software”) is the property of TELEPHONY@WORK, 
INC. or its licensors and is protected by copyright law. Except as may be modified by a license 
addendum which accompanies this license, your rights and obligations with respect to the use of this 
Software are as follows:

You may:

- use one copy of the Software contained on the enclosed CD on a single computer;

- use the Software on a network.

You shall not:

- copy the documentation which accompanies the Software;

- sublicense, rent or lease any portion of the Software;

- copy, reverse engineer, decompile, disassemble, modify, translate, make any attempt to discover the 
source code of the Software, or create derivative works from the Software; or 

-use a previous version or copy of the Software after you have received a disk replacement set or an 
upgraded version as a replacement of the prior version.  Upon upgrading the Software all copies of 
the prior version must be destroyed unless otherwise agreed in a written document that has been 
signed by both you and TELEPHONY@WORK, INC. 

Any actions by you which violate the terms of this Agreement shall result in the immediate 
termination of this license with no refund to you of License Fees paid.

LIMITED WARRANTY

TELEPHONY@WORK, INC. warrants that the media on which the Software is distributed will be free 
from defects for a period of thirty (30) days from the date of delivery of the Software to you.  Your 
sole remedy in the event of a breach of this warranty will be that TELEPHONY@WORK, INC. will 
replace any defective media returned to TELEPHONY@WORK, INC. within the warranty period.  
TELEPHONY@WORK, INC. does not warrant that the Software will meet your requirements or that the 
operation of the Software will be uninterrupted or that the Software will be error-free. 

THE ABOVE LIMITED WARRANTY IS IN LIEU OF ALL OTHER WARRANTIES, EXPRESS OR IMPLIED, 
INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A 
PARTICULAR PURPOSE, AND NONINFRINGEMENT. THIS WARRANTY GIVES YOU SPECIFIC LEGAL 
RIGHTS.  YOU MAY HAVE OTHER RIGHTS THAT VARY FROM STATE TO STATE.
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DISCLAIMER OF DAMAGES

 

TELEPHONY@WORK, INC. SHALL NOT BE LIABLE TO YOU FOR INDIRECT, SPECIAL, INCIDENTAL, 
EXEMPLARY, CONSEQUENTIAL DAMAGES OR SIMILAR DAMAGES (INCLUDING, WITHOUT LIMITATION, 
LOST PROFITS OR LOST DATA) RELATED TO THIS AGREEMENT OR RESULTING FROM CUSTOMER'S 
USE OR INABILITY TO USE THE SOFTWARE, ARISING FROM ANY CAUSE OF ACTION WHATSOEVER, 
INCLUDING CONTRACT, WARRANTY, STRICT LIABILITY, OR NEGLIGENCE, EVEN IF 
TELEPHONY@WORK, INC. HAS BEEN NOTIFIED OF THE POSSIBILITY OF SUCH DAMAGES. SOME 
STATES DO NOT ALLOW THE LIMITATION OR EXCLUSION OF LIABILITY FOR INDIRECT, SPECIAL, 
INCIDENTAL, EXEMPLARY, CONSEQUENTIAL DAMAGES OR SIMILAR DAMAGES SO THE ABOVE 
LIMITATION OR EXCLUSION MAY NOT APPLY TO YOU. IN NO CASE SHALL TELEPHONY@WORK, INC.'S 
LIABILITY EXCEED THE PURCHASE PRICE FOR THE SOFTWARE. The disclaimers and limitations set 
forth above will apply regardless of whether you accept the Software.

GENERAL

The laws of the State of California will govern this Agreement. This Agreement may only be modified 
by a license addendum that accompanies this license or a written document that has been signed by 
both you and TELEPHONY@WORK, INC. Should you have any questions about this Agreement, or if 
you desire to contact TELEPHONY@WORK, INC. for any reason, please write: Telephony@Work, Inc. 
Customer Sales, 4225 Executive Square, Suite 600, La Jolla, CA 92037 or call 1-888-854-4224.
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Introduction 1

What is the Administration Manager?
The Administration Manager is a browser-based software program 
allowing users to set up, configure, and maintain a CCATM (CCA) 
multi-media call center.

No programming experience is required to administer a CCA Call 
Center. However, some planning and information gathering is 
necessary to get your call center up and running quickly and smoothly.

This manual guides users through the call center planning process and 
describes how to use the Administration Manager to implement the call 
center.

Product Features

Using Administration Manager, you can perform all call center 
administration and configuration tasks from any computer with a 
browser and an Internet connection. Common tasks include:

• Creating Agent and Supervisor Accounts
• Configuring Agent Extensions
• Defining and assigning Agent Skills for intelligent call routing
• Creating Workgroups for handling various customer-types
• Assigning weight to Agent Skills within Agent Workgroups

You need Internet Explorer, version 6.0 or above, to use 
Administration Manager.
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• Creating routing strategies for incoming interactions of various 
media

• Creating Interactive Voice Response (IVR) Menus
• Building content libraries for your Agents to use when handling 

interactions
• Recording and storing prompts for greeting and handling telephone 

customers
• Assigning Priorities to customers
• Customizing, generating, and printing call center reports

Administration Manager Interface
The Administration Manager’s browser-hosted interface provides 
logically grouped controls for quickly navigating to all Administration 
Manager screens. The Administration Manager interface is divided into 
two re-sizable sections; the Navigation Pane on the left and the Results 
Pane on the right.

The Navigation Pane contains four groups of links to various 
Administration Manager screens. As you click links in the Navigation 
Pane, the Administration Manager displays a sortable, tabular list of 
member objects in the Results Pane.

The Results Pane is a dynamically updated area containing the 
members of the link you selected in the Navigation pane. The Results 
pane also contains, when you “drill-down” into a selected object, the 
editing screens you use to add and modify the properties of these 
objects.
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Figure 1-1. Example AM Screen: List of Editable Agent Accounts

Figure 1-1 Example AM Screen: List of Editable Agent Accounts

The Results Pane in the example screen shown in Figure 1-1 contains a 
list of agent accounts defined for a company. Each row in the Results 
Pane represents an editable agent account. Clicking anywhere on a 
row selects that object for editing (or deleting) using the Local 
Command buttons or by clicking the commands on the context 
(right-click) menu.

The Administration Manager Options, Library, and Reports 
links contain no objects for editing, until you add them 
(following the instructions in this manual).

Global Command Links

Navigation 
Links

Click to 
expand or 
collapse a 
Navigation 
Group

Navigation 
Group

Navigation Pane
Results Pane

Click Row to Work 
with an Object

Click Column Header to 
Sort by Column Content

Local Command ButtonsInformation Banner
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Figure 1-2. Example AM Screen: Editing the Selected Agent Account

Figure 1-2 Example AM Screen: Editing the Selected Agent Account

Figure 1-2 shows an example of a editing screen for an agent account 
called Jayr. This account contains editable properties, which CCA 
presents on additional screens or “tabs.” Click the labeled tabs to open 
each additional screen for editing or viewing.

CCA Reports
Use the Administration Manager to define, generate, and view the full 
suite of CCA Reports. See the Reports Chapters for a complete 
description of the supplied report types and how to create and view 
them.

Click Tabs to Open Additional Screens
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Call Flow Overview
1. A customer dials a call to the call center.

2. CCA finds the project, using the number that the customer dialed.

3. CCA verifies that the company receiving the call has a valid 
license.

4. CCA routes the call to a workgroup queue where it waits for the 
ACD Server to assign the call to an agent.

5. When an agent is available, the CTI Server finds the agent’s 
extension. CCA dials the agent’s extension and the IM Server 
offers the interaction to the agent.
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Planning a Call Center 2

Whether you are implementing a call center for your own company, or 
you are an Application Service Provider (ASP) setting up call center 
services for a customer, carefully planning the call center operations is 
the best and quickest way to get started.

The CCATM Administrator’s Planning Survey helps plan a call center by 
presenting questions about how the business is organized and 
identifying which CCA features to implement. Use the answers to the 
survey questions to guide you later, as you use the Administration 
Manager to set up the call center.

CCATM Administrator’s Planning Survey
Use the following pages to record your answers to the CCA Planning 
Survey:

Question 1: What kinds of interactions will the call center accept?

Use Table 2-1 to identify how customers will contact the call center. 
Place a check mark next to all media types the call center will accept.

Table 2-1. Possible Media Types and Descriptions

Check Media Description

Telephone Customers dial into the call center using their 
telephone

Email Customers reach the call center by writing to an email 
address

CCA_AM.book  Page 1  Wednesday, July 26, 2006  2:55 PM



2-2 CallCenterAnywhereTM Administration Manager

Question 2: What numbers will telephone-customers dial to reach the call center?

• Customers will dial one telephone number:
_________________

• Customers will dial different numbers to reach various phone 
projects in the business:

CCA Phone Projects allow you to create and save strategies for routing 
interactions to agents in your call center.

If you plan to accept telephone interactions, you must choose at least 
one telephone number (DNIS), which customers dial to reach your call 
center.

Chat Customers reach the call center by using your Web 
site to request a chat (real-time communication) with 
an agent

Web Customers reach the call center by using your web 
site to request that an Agent call them back on the 
telephone

Predictive 
Dialing

CCA calls customers on the telephone and connects 
them to a waiting agent, when successful

Preview 
Dialing

CCA calls customers and allows the agent to control 
placement of the call

Table 2-2. Phone Projects and Corresponding Telephone Numbers

Phone Project 
Name Telephone Number

Table 2-1. Possible Media Types and Descriptions

Check Media Description
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If you plan to use different Phone Projects to handle various customer 
types with various call routing strategies, you must reserve a unique 
phone number for each CCA Phone Project.

Question 3: What email addresses will email-customers use to contact the call 
center?

• My customers will write to one email address: 
_________________

• My customers will write to different email addresses to reach 
various contact center projects in my business:

Question 4: What fax numbers will fax-customers use to contact the call center?

• My customers will fax to one number: 
________________________

• My customers will fax to different numbers to reach various fax 
Projects in my business:

Table 2-3. Email Address and Corresponding Depts or Workgroups

Email Address Department/Workgroup

Table 2-4. Fax Number and Corresponding Dept or Workgroup

Fax Number Department/Workgroup
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Question 5: What Web addresses will customers use to request a chat or callback 
from an agent?

• My customers will access one Website: 
_______________________

• My customers will access different Websites to reach various 
projects:

Question 6: How will the call center handle different types of interactions?

CCA allows the call center to manage interactions originating from 
different media in different ways.

For example, customers calling the call center by phone can identify 
their needs using a menu and then CCA can route their call to an agent 
in the correct workgroup. In contrast, all CCA could route all chat 
interactions directly to technical support or another workgroup.

Consider diagramming the various routes interactions will take from 
the moment they enter your call center, until they reach their final 
destination (agent, fax machine, or other resource). 

Understanding how to route interactions of each media type is 
important for setting up CCA projects and workgroups using the 
Administration Manager.

Table 2-5. Website Address, Project, and Project Type

Website Address Project Name

Project Type 
(Chat or Web 
Callback)
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Question 7: What are the workgroup names, phone extension, and email address 
for each agent?

CCA lets you route calls to agents in the appropriate workgroup based 
on the caller’s needs. If all agents are serving the same customers, 
then there is no need to divide agents into multiple workgroups. In this 
case, you can route all callers to a single workgroup or directly to an 
agent’s phone extension.

However, if you plan to route callers to agents working in functional 
groups, use the Table 2-6 to define your company’s workgroups, and 
identify which agents belong to which group or groups.

Table 2-6. Agent Names, Workgroups, Extensions, and Email Addresses

Agent Name Workgroups Extension Email Address

An agent can be a member of multiple workgroups.
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Question 8: Will the call center need recordings to greet customers?

When customers reach your call center by telephone, there are a 
number of ways to greet the customer, including:

• Live Operator (operator transfers the caller to the appropriate 
workgroup or agent).

• Recorded greeting with no routing options (caller is immediately 
placed into a Workgroup queue).

• Recorded greeting with menu options (caller is routed to an agent 
or workgroup queue based on their selection).

In Table 2-7, specify a prompt file for each phone number callers dial 
to reach your call center (see “Question 2: What numbers will 
telephone-customers dial to reach the call center?” ). 

If you plan to organize your call center agents into workgroups, specify 
a prompt file that will greet callers entering each workgroup. It is 
important to identify early, which prompt file and text to use when 
greeting callers reach each call center project or workgroup.

Lean how to record prompts later in this manual.

Table 2-7. Project or Workgroup and a Corresponding Sound File or 
Text Greeting

Project or 
Workgroup 
Name

File Name 
(.wav)

Text for the 
Greeting/Prompt
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Question 9: Will you need to record prompts describing your touch-tone menus?

If the call center plans to use touch-tone menus to route callers to 
workgroups, agents, or other resources, then you must create 
recorded prompts describing the touch-tone options available for the 
caller. 

It is important, however, to identify now which prompt file to use for 
each menu and the text that the customer will hear describing the 
menu options.

Use Table 2-8 to identify sound files and prompt text.

Learn how to create menus and record the prompts (describing the 
menus) later in this manual. 

If the call center plans to have an agent act as a live 
operator and transfer callers to other agents or 
workgroups, then a recorded greeting for phone projects 
is not necessary.

Table 2-8. Sound File or Prompt Text

File Name (.wav) Text for the prompt
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Question 10: Will you need customized recordings for callers waiting for an agent?

In addition to the greeting that callers hear when they reach the call 
center, there are other recorded messages that they can hear while 
they are waiting to be connected to an agent. 

Prompts describing additional options (such as “Press two to enter 
your telephone number and receive a call back”) or notifying the caller 
of their estimated wait time (such as “Your estimated wait time is one 
minute”) are examples of Workgroup Queue Prompts (see “Workgroup 
Option Prompts” on page 5-22).

Although CCA provides pre-recorded prompts using a female voice, 
you can create unique recordings using a different voice or different 
text.

Question 11: What skills will your agents possess for call routing?

Agent skills are the abilities that agents possess that allow them to 
handle interactions coming into the call center. CCA matches the needs 
of the caller with the skills of all available agents, and routes the 
interaction to the agent most qualified to handle the interaction.

For example, if your call center receives callers who speak Spanish and 
French in addition to English, you might create two agent skills 
(“Speaks French” and “Speaks Spanish”) to supplement the ability to 
speak English, which all agents possess. Therefore, when a 
Spanish-speaking caller reaches the call center, CCA routes the caller 
to the available agent with the highest score for the “Speaks Spanish” 
skill.

Table 2-9. Agent Skills and Corresponding Descriptions

Skill Description
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Question 12: What statuses will you use for your agents?

CCA identifies the status of every agent presently logged into the 
system. Supervisors use these status indicators to monitor agent 
activity. Agents depend on their status indicator to control their 
availability.

If you want additional agent statuses to reflect activities of the agents 
in your call center, identify them in Table 2-10.

Question 13: Will your agents read prepared scripts?

By compiling a library of prepared scripts, your agents can access 
important information while providing service to customers. Example 
scripts include a sales pitch, responses to common questions, a list of 
troubleshooting steps, or any other information the agent uses to 
provide quality service to the customer.

In Table 2-11, identify the name, description, and URL (such as “Sales 
Pitch 1,” “Sales Copy for Ginsu Knife Set,” and 
http://mynet.sales.ginsupitch.htm) for each script you plan to 
provide your agents.

Table 2-10. Additional Agent Status Indicators and Descriptions

Agent Status Description/Purpose

See “Creating Agent Statuses” on page 4-6 for a list of 
pre-defined system statuses.

Table 2-11. Script Name, URL, and Corresponding Description

Name Description

URL:
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Question 14: Will your agents read from an FAQ?

By compiling a library of FAQ (frequently asked questions), your 
agents can immediately respond to common questions, ensuring 
consistent and quality service to the caller.

In Table 2-12, identify a question, answer, or supporting URL.

URL:

URL

URL

URL

Table 2-12. FAQ Question, Description, Supporting URL

Name Description

URL:

URL:

URL

URL

URL

Table 2-11. Script Name, URL, and Corresponding Description

Name Description
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Question 15: Will agents be allowed to provide Web pages for chat-based 
customers?

Using a library of website links, from which agents can select and send 
to chat-based customers, is an excellent way of quickly pointing 
customers to the information they need.

In Table 2-13, list the URLs agents can use when serving customers.

Table 2-13. Web Page Name, Description, and URL

Name Description

URL:

URL:

URL:

URL:

URL:
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Question 16: Will you automatically display Web pages to chat-based customers?

If desired, you can automatically display Web pages (“push pages”) to 
customers who request a chat session with an agent. 

Use the URL cell in Table 2-14 to record the URL for each Web page to 
display for each event, when a customer requests a chat with one of 
the call center agents.

Table 2-14. Chat Event, Name, Description, and URL

Chat Event Name Description

1. Waiting After the customer submits a request 
for a chat session, this page appears 
on their screen until they are 
connected with an agent. 
(Suggested content for this page is a 
‘thank you’ to the customer for their 
inquiry and notification that they will 
soon be chatting with an agent.)

URL:

2. Still Waiting These pages appear after the initial 
“Waiting” page, only if the chat 
customer is still waiting to be 
connected to an agent. 
(Suggested content for these pages are 
product information, answers to 
frequently asked questions, and so 
forth.)

URL:

URL:

URL:

URL:

URL:

3. Connected This page appears after the customer 
successfully connects to an agent.

URL:

4. Disconnected This page appears when the agent 
disconnects from the chat customer.

URL:
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Question 17: Will agents provide prepared content to customers contacted in 
response to a Web callback request?

By creating a library of pre-developed Web callback content, agents 
can respond to customers quickly and consistently.

In Table 2-15, provide a name for the Web callback response content, 
a description of the content, and the URL containing the text.

Question 18: Will agents provide prepared email responses to customers?

Creating a library of pre-developed email responses also allows agents 
to respond to customers quickly and consistently.

No Agents 
Available

This page appears when no agents are 
available.

URL:

You must create the HTML Web pages for each of the above 
events and place them on your Web server in the URL 
location you specify in Table 2-14.

Table 2-15. Web Callback Response Name, Description, and URL

Name Description URL

Table 2-14. Chat Event, Name, Description, and URL

Chat Event Name Description
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In Table 2-16, identify the subject of the email response, the URL 
containing the email response text, and workgroup that will use each 
prepared email.

Question 19: Will your agents provide prepared fax responses to customers?

You can create a library of pre-developed fax responses for your 
agents to provide customers. Providing agents with prepared facsimiles 
of the forms most frequently requested of them allows the agents to 
respond to your customers quickly and consistently

In Table 2-17, identify the name of the fax response, and the path and 
file name containing the fax contents.

Table 2-16. Email Response Subject, Workgroup, and URL

Email Subject Workgroup URL

Table 2-17. Fax Name and Corresponding File

Fax Name File Name (.TIF or .TIFF)

You must store CCA fax responses as Tagged Image File 
Format (TIFF) files in the Fax Library. When saving fax 
responses, select Class F with CCITT Group 3 1D 
compression to ensure compatibility with CCA and the 
telephony hardware.
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Question 20: Will you track interaction results?

Tracking the results of call center interactions is a good way to 
measure and compare the performance of agents. With the outcomes 
feature enabled, you can create administrative reports to analyze the 
results of all interactions handled by agents.

You can configure CCA to automatically display the outcome library 
and require agents to choose an outcome at the conclusion of every 
interaction. 

In Table 2-18, identify the outcome you create for the Outcome 
Library. (Example outcomes are “Placed Order,” “Issue Resolved,” 
“Issue Pending,” and so forth.)

Question 21: Will you send an automated email acknowledgment to email 
customers?

You can create a library of pre-developed email content that CCA can 
send automatically to customers who reach the call center by email. 
Typically, the content of the automated reply email is something like 
“Thank you for your inquiry, an agent will be contacting you shortly.”

In Table 2-19, identify the subject of each automated email reply you 
to use with the call center.

Table 2-18. Outcomes and Descriptions

Outcome Description

Table 2-19. Auto Email Response File Name and Description

Automated Email 
Acknowledgmen
t Name File Name Description
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Question 22: What email servers will the call center use to receive emails from 
customers?

CCA allows you to specify multiple email servers for automatic load 
balancing of email traffic. Identify these in Table 2-20.

Question 23: What email servers will call center agents use to send emails to 
customers?

CCA allows you to specify multiple email servers for automatic load 
balancing of email traffic. Identify them in Table 2-21.

Table 2-20. Email Servers, Hosts, Usernames, and Passwords

POP3 Servers Host Username Password

Table 2-21. SMTP Servers, Hosts, and Domains

SMTP Servers Host Domain

Table 2-19. Auto Email Response File Name and Description

Automated Email 
Acknowledgmen
t Name File Name Description
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Question 24: Will some or all agents and supervisors connect to the call center 
through a proxy server?

CCA supports agent and supervisor workstation connections through a 
proxy server. Use Table 2-22 to list the proxy servers to which agents 
and supervisors will connect. 

Provide the server name, the name of the host on which each proxy 
server resides, and the authentication information necessary to 
connect to the proxy server. 

Table 2-22. Proxy Server Name, Host Name and Authentication 
Information

Proxy 
Server 
Name

Proxy 
Server Host 
Name Authentication Information

Username: 

Password:

Domain:

Username:

Password:

Domain:

Username:

Password:

Domain:

Also see “To change your proxy settings in Internet 
Explorer” on page 3-6.
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Getting Started 3

This chapter describes how to launch the Administration Manager and 
begin setting up a call center.

Make sure to complete the CCA Planning Survey (see “CCATM 
Administrator’s Planning Survey” on page 2-1) and keep the responses 
handy.

Setting Up Your Call Center In Administration Manager

Administration Manager is a powerful program that supports a large 
number of features, options, and settings. You can configure many of 
the features in Administration Manager at any time. For example, you 
can add Intelligent Email Templates after getting your call center up 
and running. 

However, you must perform some configuration tasks in Administration 
Manager in a specific order. For example, you must to have your POP3 
server information on hand before you configure your company and 
agents.

Table 3-1 shows the tasks and their order, that you must perform to 
get a very simple call center up and running.
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Table 3-1. Tasks and Task Order To Set up Call Center

Task Description

1.  Create email 
accounts using 
your company mail 
server.

Create email accounts for:
• All of your Agents, Supervisors, and other 

Administrators.
• Your company voicemail, fax, alarm notification, 

and storage. (See “Setting Up the Company Email 
Addresses” on page 3-15.)

• Your Projects. (See “Adding Email Interactions to a 
Project” on page 10-66.)

2.  Configure your 
Administration 
settings.

Login to Administration Manager and configure the 
Administration settings (including the time zone and a 
few other settings). (See “Configuring the 
Administration Manager” on page 3-8.)

3.  Identify the POP3 
servers and SMTP 
server to 
Administration 
Manager.

• Refer to “Creating a POP3 Server Library” on page 
4-66.

• Refer to “Creating an SMTP Server Library” on page 
4-62 and “Creating an SMTP Server Group Library” 
on page 4-64.

4.  Create or 
configure a new 
company.

• If you have the Service Provider edition of CCA, 
create and configure a new company in 
Administration Manager for each company for 
which you provide services. (See “Adding/Editing a 
Company” on page 3-11.)

• If you have the Enterprise edition of CCA and you 
only need to set up one call center for your 
company, you will find that your company already 
exists in Administration Manager and you only need 
to configure it. (See “Adding/Editing a Company” 
on page 3-11.)

5.  Create the list of 
Agent Skills. 

Refer to “Creating an Agent Skills Library” on page 
4-2.

6.  Create accounts 
for Agents, 
Supervisors, and 
other 
Administrators. 

Refer to “To create user accounts” on page 6-4.

7.  Create 
Workgroups.

Refer to “Creating a Workgroup” on page 7-3.

8.  Create Projects. Refer to “Creating a Project Definition” on page 10-1.
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Synchronizing Server Time and Time Zone
It is critical that all CCA server machines are set to the same time 
(date and time properties for window machines). If one or more 
servers are not set to the same time as the other servers, severe 
operational errors may occur; including failures of master backups and 
scheduled activities.

We recommend setting all servers to run at the same time in the GMT 
time zone. If you don't want all of your servers to use the same time 
zone, make sure that they are still time synchronized. For example, if 
you have a server in San Diego and another in London, and both are 
running in local time zones, and: 

• The San Diego server time is 12:00 noon.
• You must set the London server to 8:00 PM, since London is 8 

hours ahead of San Diego.

Starting and Logging In
The first time you use the Administration Manager, you must use your 
browser to open the Administration Manager login screen, much as you 
would load a typical Internet website in a browser.

• If you are logging in through a proxy server, or would like to set up 
CCA to use a proxy server, see “Setting the Agent’s Proxy 
Information” on page 3-6.

To launch Administration Manager the first time

1. Start Internet Explorer (version 6.0 or above).

2. Enter the address of the Administration Manager that was provided 
by Telephony@Work or by your service provider.

The CCA Welcome screen (Figure 3-1) opens.
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Figure 3-1. CCA Login Screen

Figure 3-1 CCA Login Screen

a. If you are using the Service Provider Edition: 

i. Enter system in the Company Alias text box.

ii. Enter netadmin in the User name text box.

iii. Enter the password (provided by Telephony@Work) in the 
Password text box.

b. If you are using the Enterprise Edition: 

i. Enter the Company alias (supplied by your vendor or 
Application Service Provider).

Add this page to your Internet Explorer Favorites menu.

Administration Manager
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ii. Enter the user name and password that were supplied 
by your vendor or Application Service Provider.

3. From the drop-down menu, choose your Language. (All 
Administration Manager (AM) session screens will appear in the 
language you choose.)

4. Click the Administration Manager icon.

The AM screen opens to either the Company List screen (Figure 
3-2) or the Company Profile screen, depending upon which version 
you are using. 

Figure 3-2. Company List Screen (Service Provider Edition Only)

Figure 3-2 Company List Screen (Service Provider Edition Only)

The Service Provider Edition displays the Company List 
screen (Figure 3-2).
The Enterprise Edition displays the Company Profile screen.

Netadmin only
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Setting the Agent’s Proxy Information
CCA gets proxy information directly from the agent’s browser. The 
Options > Proxies screen in AM is obsolete. It should not be used 
and will be removed in a future build.

To change your proxy settings in Internet Explorer

1. Start Internet Explorer. From the Tools menu, choose Internet 
Options...

2. In the Internet Options dialog box, select the Connections tab, 
then click the LAN Settings… button.

3. In the Local Area Network Settings dialog box (Figure 3-3): 

Figure 3-3. Setting a Proxy in Internet Explorer

Figure 3-3 Setting a Proxy in Internet Explorer
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a. Click the Use a Proxy Server for Your LAN check box. 

b. In the Address text box, type the IP address of the proxy 
machine. 

c. In the Port text box, type the proxy machine port number. 

4. Click the OK button.
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Configuring the Administration Manager
Configure your Administration Manager workstation for:

• Setting Your Language
• Setting Your Time Zone and Date Format
• Setting Your Inactivity Timeout

Setting Your Language

If you work in a different time zone than most of your agents or 
different than your company headquarters, you may want to configure 
your settings to match their time zone and date format.

To set your language

1. Click the Configure link (top right) and then click the Regional 
Options tab (Figure 3-4).

Figure 3-4. Configuration Dialog Box: Regional Options

Figure 3-4 Configuration Dialog Box: Regional Options
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2. From the Select Language drop-down menu, select your language.

3. Click OK to save your configuration settings. All AM screens will 
now display text in the language you selected.

Setting Your Time Zone and Date Format

If you work in a different time zone than most of your agents or 
different than your company headquarters, you may want to configure 
your workstation settings to match their time zone and date format.

To set your time zone and date format

1. Click the Configure link (top right) and then click the Regional 
Options tab (Figure 3-5).

2. To set your time zone to the same time zone defined for your 
company, choose Company Defined Time Zone. 

or

To set a specific time zone, choose User Defined Time Zone and 
then select a time zone from the Set Time Zone drop-down list. 
Refer to Figure 3-5.

Figure 3-5. Setting User Defined Time Zone

Figure 3-5 Setting User Defined Time Zone
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3. To set your date format to the same date format defined for your 
company, choose Company Defined Date Format. 

or

To set a specific date format, choose User Defined Date Format, 
and then choose a format from the Set Date Format drop-down 
list.

4. Click OK to save your configuration settings. All AM screens display 
times and dates in the zone and format you selected.

Setting Your Inactivity Timeout

You can set an inactivity timeout for the Administration Manager 
program so that if the program sits idle (meaning no mouse clicks or 
keystrokes) for the amount of time you specify, the program 
automatically logs you out. 

To set your inactivity timeout

1. Click the Configure link (top right) and then select the Timeout 
tab (Figure 3-6).

Figure 3-6. Configuration: Timeout Tab

Figure 3-6 Configuration: Timeout Tab
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2. In the Timeout After text box, enter the number of minutes after 
which AM will automatically log you out.

3. Click OK to save your configuration settings.

Adding/Editing a Company
If you are an Application Service Provider (ASP) setting up a call center 
for a customer, you must use the Administration Manager to create a 
Company definition to hold the settings and definitions for the 
customer’s call center. You must create one company for each 
customer for whom you are providing call center application services.

If you are running the Enterprise Edition of CCA, you can modify your 
company information, but you cannot create new company 
definitions.

Adding or editing a Company definition consists of the following tasks:

• Configuring the Company Profile
• Supplying/Editing Company Contact Information
• Setting Up the Company Email Addresses
• Configuring Company Time Zone and Date Format
• Setting Company Business Hours
• Creating List of Project Phone Numbers

Configuring the Company Profile

Use the Profile tab to supply or edit the name, address, and Website 
of your company (or of the company for which you are providing call 
center services).

To configure the company profile

1. Log into the Administration Manager (see “Starting and Logging 
In” on page 3-3).

2. (Service Provider Edition Only) Perform a or b:
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a. To create a new Company definition, click Add.

b. To modify an existing Company, click the row for the Company, 
and then click Edit. The Company screen opens to the Profile 
tab (Figure 3-7).

Figure 3-7. Company Profile Tab

Figure 3-7 Company Profile Tab

3. Use the information in Table 3-2 to complete or edit the fields in 
the Company Profile tab.

Table 3-2. Profile Tab Fields and Descriptions

Field Description

Company Name (Service Provider Edition only) Enter the full 
name of the company for which you are 
providing call center services.

Company Alias (Service Provider Edition only) Enter a 
unique identifier for this company. CCA uses this 
alias to differentiate companies in the database, 
so you must provide a unique alias for each 
company.
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Display Name Enter the name to display for this company on 
the CCA Company List screen. 

Note: The display name does not appear 
elsewhere in the system or in any CCA reports.

Tip: If you administer a large number of 
companies (including companies with 
foreign-language names), enter a value that is 
intuitive to you to make it easier to locate the 
company from the Company List.

Note: This field accepts only Latin (ASCII) 
characters.

Address Enter the street address for the company for 
which you are providing call center services.

City Enter the city where the company for which you 
are providing services is located.

State/Region Enter the state or region where the company for 
which you are providing services is located.

Country Choose the country where the company for 
which you are providing services is located.

Postal/Zip Code Enter the zip code or postal code in which the 
company for which you are providing services is 
located.

Web Site Enter the URL of the website for the company for 
which you are providing services.

Statistics Do NOT enter any values in these fields. 

For the most part, these fields summarize 
settings that you may do in later chapters. For 
example, in a later chapter you will create 
accounts for your agents. After you create your 
agent accounts, the system updates the agents 
field in the Company > Profile tab, showing how 
many agent accounts you created. 

Inactive Session Timeout: 
Disable Session 
Timeout

Click this option so that CCA will never 
automatically log out agents and supervisors.

Table 3-2. Profile Tab Fields and Descriptions

Field Description
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4. Click OK to create the new company.

Supplying/Editing Company Contact Information

Use the Contact tab (Figure 3-8) to supply, edit, or view the names, 
addresses, and telephone numbers for the contact persons at your 
company (or at the company for which you are providing call center 
services).

To enter or edit company contact information

1. Select the company to edit (Service Provider Edition only).

2. Select Options > Company > Contact tab (Figure 3-8).

Inactive Session Timeout:
Enable Session 
Timeout

Select a timeout value between 5 minutes and 24 
hours. This is when CCA will automatically log 
out an agent or supervisor after a inactivity. You 
can enter a time for the entire company. 

If you change the session timeout at the 
company level, AM requests whether you want to 
apply the change to all agents.
• If you apply the change to all agents, CCA 

changes the session timeout for all agents to 
the new company value.

• If you do not apply the change to all agents, 
existing agents will keep their current session 
timeout value. New agents will get the new 
company session timeout value.

Note: To apply an inactive timeout to an 
individual agent, use the Inactive Session 
Timeout from the Options > Agents > Controls 
and Restrictions tab. See “Inactive Session 
Timeout” on page 6-9.

Table 3-2. Profile Tab Fields and Descriptions

Field Description
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Figure 3-8. Company Contact Tab

Figure 3-8 Company Contact Tab

3. Complete the company contact fields with the information 
necessary to contact the person in charge of the call center at the 
customer’s site.

4. Click Apply.

Setting Up the Company Email Addresses

Use the Email Configuration tab (Figure 3-9) to supply, edit, or view 
the email addresses and servers that CCA uses to handle incoming 
email interactions and outgoing agent responses for your company (or 
the company for which you are providing call center services).
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To set up the company email addresses

1. Select the company to edit (Service Provider Edition only).

2. Select Options > Company > Email Configuration tab.

Figure 3-9. Email Configuration Tab - General Addresses Subtab

Figure 3-9 Email Configuration Tab - General Addresses Subtab

3. Using the information provided in Table 3-3, complete the Email 
Configuration - General Addresses fields. 

Table 3-3. General Addresses Tab Fields and Descriptions

Field Description

Voice Mail address Enter the email address to use as the return 
address on emails sent to agents, which contain 
voice mail attachments. (This means, if there is a 
problem delivering an email containing a voice mail 
attachment to the agent, CCA sends the email and 
attachment to this address.)
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4. Click the Storage subtab (Figure 3-10).

Fax to Agent Enter the email address to use as the return 
address on emails sent to agents, which contain fax 
attachments. (This means, if there is a problem 
delivering an email containing a fax attachment to 
the agent, CCA sends the email and attachment to 
this address.)

Alarm notification to 
Supervisor

If an email error occurs, CCA sends an alarm 
notification to this address. This may happen when:
• An email could not be sent to an agent. 
• An email could not be parsed. (For example, the 

email body was corrupt.)
• The agent accepts the email interaction and then 

discards it without replying. (CCA forwards the 
email to the alarm address.)

• The Company Storage Email Address was 
changed. If the storage changes, CCA sends an 
alarm notification to the alarm address and 
requests that the administrator forward all email 
from the old storage address to the new storage 
address.

• Could not connect to the project’s POP3 server. 
• Emails were routed to a project and then the 

project was deleted. In this case, CCA forwards 
all of the emails for this project to the alarm 
address.

• The agent did not answer an email in time.
• The project mailbox received an email from an 

invalid email address. CCA forwards these emails 
to the alarm mailbox.

• The project received an invalid email from an 
agent. For example: 

The agent’s email address was invalid.
The agent responded to an interaction that 
had already been answered.

Select an SMTP Group 
to Send Alarm 
Notification

Select the SMTP Group to use to send alarm 
notifications.

Table 3-3. General Addresses Tab Fields and Descriptions

Field Description
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Figure 3-10. Company Email Storage Subtab

Figure 3-10 Company Email Storage Subtab

5. Using the information in Table 3-4, complete the Storage subtab 
fields.

Table 3-4. Storage Tab Fields and Descriptions

Field Description

Email storage 
address

This address is the address agents will see, if you configure 
the system to conceal the customer’s email address from 
the agent. (Refer to “Show customer email address to 
Agent” on page 10-70 for more information.) 

You must also enter an address (in the Select the storage 
location field below. This address must be from an account 
on the servers you specify.
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6. Click Apply.

Configuring Company Time Zone and Date Format

Use the Regional Settings tab (Figure 3-11) to set the time zone and 
date format to use on all CCA workstations in your company.

To set a time zone and date format for the company

1. Select Options > Company > Regional Settings tab.

2. From the Date Format drop-down menu, select a date format for 
the company. CCA uses the selected format when displaying dates 
on all Agent, Supervisor, and Administrator workstations for the 
company (unless users override the company settings from their 
own workstations).

3. From the Time Zone drop-down menu, select a time zone for the 
company. The company time zone appears on the workstations of 
all company’s Agents, Supervisors, and Administrators (unless the 
users override the company settings on their own workstations).

4. From the Select a Language drop-down menu, select the language 
for internal messages used by the company. Internal messages can 
be:

• Email alarms from the server.
• The default language selected for reports.

Even though the agent sees only the address you enter 
here, CCA sends the agent’s response to the customer’s 
true address. The customer sees the email address for the 
Project. 

Note: Do not use an email client to access the CCA email 
storage address. This prevents the system from accessing 
the account used to send agent replies to customers.

Select the 
storage location

Check the POP3 Servers supporting the address you 
provided for Email storage address above.

Table 3-4. Storage Tab Fields and Descriptions

Field Description
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Figure 3-11. Company Regional Settings Tab

Figure 3-11 Company Regional Settings Tab

5. Click OK or Apply.

Setting Company Business Hours

Use the Business Hours tab (Figure 3-12) to identify the days and 
times the company is open for business, and the days and times 
agents are available to handle chat and Web callback requests. 

When a Web-based customer attempts to contact your call center 
during non-business hours, CCA uses the specified business hours to 
inform the customer that the company is currently closed, and to 
assist the customer in reaching an agent during open business hours.

This company language selection does not affect what agents and 
supervisors see when they login. Agents and supervisors can select 
their own language preference each time they login.
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To set company business hours

1. Select Options > Company > the Business Hours tab (Figure 
3-12). 

Figure 3-12. Company Business Hours Tab

Figure 3-12 Company Business Hours Tab

2. Under Opening Days, check each day when the company is open 
for business and when agents are available to handle Web callback 
requests.

3. For each day you check, select the time (hours and minutes) the 
company opens on that day from the Opening Hours From 
drop-down menu, or select 24 Hours if the call center is always 
available for handling chat and Web callback interactions.

4. Identify the time (hours and minutes) the company closes on each 
day from the To drop-down menu. 

5. Click OK or Apply.
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Creating List of Project Phone Numbers

(Service Provider Edition Only)

If you provide CCA services for a company that handles telephone 
interactions, you must create a list of telephone numbers reserved for 
that company’s Phone Projects. Company Administrators can then 
choose from this list of phone numbers when creating Phone Projects. 

Figure 3-13. Company DNIS Tab

Figure 3-13 Company DNIS Tab

Use the Company DNIS tab (Figure 3-13) to supply the reserved 
phone numbers for handling calls from customers who reach the 
company’s Phone Projects.

Before agents and supervisors can log in to the company, your 
network Administrator must add the required servers and resources 
for the company to the machine hosting your CCA installation.
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To create a list of phone project numbers

1. Select Options > Company > DNIS tab (Figure 3-13).

2. Click .

CCA adds a blank line for adding a DNIS entry.

3. In the DNIS column, type a telephone number reserved to handle 
incoming phone interactions. 

4. In the Description column, type a description of the projects this 
phone number supports.

a. If you assign a DNIS to a project (see “Project Phone Number” 
on page 10-6) the project name appears in the Project Name 
column.

b. If you assign a DNIS to an agent (see “Direct Inward Dialing” 
on page 6-16) the agent’s name appears in the Agent’s Direct 
Inward Dialing column.

5. Click OK.

6. Repeat steps 3 through 5 until you have added all the phone 
numbers you compiled in “Question 2: What numbers will 
telephone-customers dial to reach the call center?” on page 2-2 of 
the CCA Planning Survey.

Proceed to the next section for information on populating the CCA 
libraries for a company.

Before agents and supervisors can log in to the company, the 
network Administrator must add the required servers and resources 
for the company to the machine hosting the CCA installation.
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Using SIP Billing

Call centers use the Billing tab for:

• Making outbound SIP calls. 
• Using a billing module that connects to SIP software proxy. The 

billing module examines the Diversion field of the SIP header 
to determine how to bill the call.

To use SIP billing

1. Select Options > Company > SIP Billing tab (Figure 3-14).

Figure 3-14. SIP Billing Tab

Figure 3-14 SIP Billing Tab

a. If your billing module expects to find a string in the SIP header 
for Outbound SIP calls, enter that value in the Outbound Call 
field. 

and
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b. If your billing module expects to find a string in the SIP header 
for calls that are routed to an agent, enter that value in the 
User Call field.

2. Click OK.

Remote Database Configuration

CCA uses a Web Services API that allows coding for unique Web client 
applications. Use the Remote Database Configuration tab to give your 
custom Web applications access to selected tables in the CCA database 
for synchronization.

To provide custom Web applications access to CCA database tables

1. You must login as a Network Administrator for the Remote 
Database Configuration tab to be available.

2. Select Options > Company > Remote Database Configuration 
tab (Figure 3-15).

3. Click the Enable Remote DB check box.

You can load a sound file anytime. However, for the sound file to 
play, you must check the Play Sound option.
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Figure 3-15. Remote Database Configuration Tab

Figure 3-15 Remote Database Configuration Tab

4. Using the information in Table 3-5, complete the Remote Database 
Configuration fields.

Table 3-5. Remote Database Configuration Fields and Descriptions

Field Description

URL The URL of the CCA Web server. 

Username Type a username and password to create a special 
account, used solely for giving a client application very 
limited access to the CCA database. 
Note: This “user” cannot login to any CCA application 
and does not appear in any reports.

Password The password for the client application to use to access 
the CCA database. 

Client History Allows synchronization of the Client History table.

Quality Control Allows synchronization of the Quality Control table.
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5. Click OK (or Apply).

CRM Integration

When invoking a Web page or Win32 application, CCA passes it several 
parameters containing information about the interaction. (Refer to the 
Technical Notes appendix for more details about these parameters.)

The CRM Integration tab (Figure 3-16) has two subtabs:

• The Custom tab for: 

• Creating a custom tab in Interaction Manager and then 
loading a unique Web page into that custom tab

• The External Application tab for: 

• Launching a separate browser on the agent’s machine and 
then loading a unique Web page into that browser, 

or 

• Launching a Win32 application on the agent’s machine.

To integrate CRM

1. Select Options > Company > CRM Integration > Custom 
subtab (Figure 3-16).

2. Click Enable custom tab in Interaction Manager.

Users Allows synchronization of the Users table.

Projects Allows synchronization of the Projects table.

Workgroups Allows synchronization of the Workgroups.

Interaction History Allows synchronization of the Interactions table.

Table 3-5. Remote Database Configuration Fields and Descriptions

Field Description
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Figure 3-16. CRM Integration - Custom Subtab

Figure 3-16 CRM Integration - Custom Subtab

3. Using the information in Table 3-6, complete the fields and make 
selections.

Table 3-6. CRM Integration - Custom Subtab Fields and Descriptions

Field Description

Enable custom 
tab in 
Interaction 
Manager

Click this check box so that your custom tab will appear in 
Interaction Manager. The bottom of your custom tab will 
have a frame and the Web page that you enter in this field 
will appear in that frame.

Note: There are additional ways to load an HTML page 
from a custom tab in Interaction Manager.

Enter Text Label Type the name of the tab that will appear in Interaction 
Manager.
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4. Click the External Application tab (Figure 3-17). 

Include HTML 
File

Enter a URL with a protocol, server, and a filename. For 
example: 

https://a_server/a_path

https://a_server/a_path/a_file.html

CCA supports any protocol that the browser supports (http, 
https, FTP, and so on).

Note: If the URL string does not contain a protocol, 
Interaction Manager automatically adds “http://” as a 
default prefix upon receiving the URL. In addition, since IM 
adds a default prefix, it does not appear in Administration 
Manager. 

Run Application These radio buttons let you choose when your HTML file will 
load into the custom tab in Interaction Manager.

• Every time a new interaction is received: 
When IM offers an interaction to an agent, IM loads the 
HTML file into the custom tab.

• When a new interaction is accepted: When the 
agent clicks the Accept Interaction button in IM, IM loads 
the HTML file into the custom tab. Furthermore, IM will 
not reload the HTML page if the agent puts the 
interaction on Hold (or some other action) and then 
moves the interaction back into the Active Area.

• Every time an interaction is accepted: When 
the agent clicks the Accept Interaction button in IM, IM 
loads the HTML file into the custom tab. Furthermore, IM 
will reload the HTML page if the agent puts the 
interaction on Hold (or some other action) and moves the 
interaction back into the Active Area.

• After each interaction is complete: When the 
interaction is disconnected, IM loads the HTML file into 
the custom tab. Furthermore, when IM loads the HTML, it 
passes everything known about the interaction (such as 
the interaction type, contact information, and so forth) as 
parameters in the URL string. 

Table 3-6. CRM Integration - Custom Subtab Fields and Descriptions

Field Description
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Figure 3-17. CRM Integration - External Application Subtab

Figure 3-17 CRM Integration - External Application Subtab

5. Click the Enable external application to invoke from 
Interaction Manager check box.

6. Using the information in Table 3-7, complete the fields and make 
selections.

Table 3-7. External Application Subtab Fields and Descriptions

Field Description

Application to 
Invoke

If you are loading an executable: 
• An executable is any file that can start in a Windows shell 

(bat, exe, and so forth). 
• The executable must already be installed on the agent’s 

machine. 
• Type the full path (including the executable name) or 

type just the executable name (if the location is already 
in the agent’s PATH variable). 
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If you are loading an HTML page: Type the full path to 
the page.

Configure a custom tab in Interaction Manager to load an 
HTML page in two ways:
• Use the Company > CRM Integration > Custom Tab so 

that IM loads the HTML page into a frame at the bottom 
of the custom tab. 

• Use the Company > CRM Integration > External 
Application Tab so that IM will spawn a browser 
process and load the HTML page. You can also choose 
whether the browser process is modal or non-modal. 
(See the next field, Application Type, below.) 

Application 
Type

From this drop-down menu, select: 

• HTML Modal: Select this setting if you entered the 
path of an HTML file in the Application to Invoke field and 
you want to force the agent to close the browser. In this 
case:

IM loads the HTML page by spawning an external 
browser. The browser window stays in the foreground 
and the agent cannot use IM until after closing the 
browser window.

• HTML Window: Select this setting if you entered the 
path of an HTML file in the Application to Invoke field and 
you want the agent to be able to keep the window in the 
background. In this case: 

IM loads the HTML page by spawning an external 
browser. and the agent can use a mouse (or Alt-tab) to 
go back to IM, sending the browser window to the 
background.

• Win32 Window: Select this setting if you entered the 
path of an executable file in the Application to Invoke 
field and you want IM to launch the executable file. 

Run Application These radio buttons let you choose when IM will load the 
HTML file or executable into the custom tab.

• Every time a new interaction is received: 
When IM offers an interaction to an agent, IM loads the 
HTML file or executable into the custom tab. 

Table 3-7. External Application Subtab Fields and Descriptions

Field Description
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Options

When logging in as a Network Administrator, use the Options tab 
(Figure 3-18) to enable or disable a number of features for the 
companies for which you provide service.

To enable or disable features

1. You must login as a Network Administrator to access the Options 
tab.

2. Click Options > Company > Options tab (Figure 3-18).

• When a new interaction is accepted: When the 
agent clicks the Accept interaction button in IM, IM loads 
the HTML file or executable into the custom tab. 
Furthermore, IM will not reload the HTML page if the 
agent puts the interaction on Hold (or some other action) 
and then moves the interaction back into the Active Area.

• Every time an interaction is accepted: When 
the agent clicks the Accept interaction button in IM, IM 
loads the HTML file or executable into the custom tab. 
Furthermore, IM reloads the HTML page if the agent puts 
the interaction on Hold (or some other action) and then 
moves the interaction back into the Active Area.

• After each interaction is complete: When the 
interaction is disconnected, IM loads the HTML file or 
executable into the custom tab.Furthermore, when IM 
loads the HTML page or executable, it passes everything 
known about the interaction (such as the interaction type, 
contact information, and so on) as parameters in the URL 
string. 

Changes in the Options tab may not take effect until you (and other 
Admins) log out and log back in.

Table 3-7. External Application Subtab Fields and Descriptions

Field Description
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Figure 3-18. Options Tab

Figure 3-18 Options Tab

3. Using the information in Table 3-8, complete the field selections.

Table 3-8. Options Tab Fields and Descriptions

Field Description

H323 If unchecked, the phone type H323 will not appear in 
Options > Agents > Phone > Select Type of Phone. 

PBX If unchecked, the phone type PBX will not appear in 
Options > Agents > Phone > Select Type of Phone. 

Outside Phone If unchecked, the phone type Outside Phone (Remote 
Extension) will not appear in Options > Agents > Phone > 
Select Type of Phone. 

Dialogic 
Extension

If unchecked, the phone type Dialog Analog Extension will 
not appear in Options > Agents > Phone > Select Type of 
Phone. 
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Voicemail If unchecked, the No Phone (Voicemail Only) radio 
button will be removed from Options > Agents > Phone 
tab. 

This radio button is used to send all calls directly to the 
Agent’s voicemail.

SIP If unchecked, the phone type SIP will not appear in Options 
> Agents > Phone > Select Type of Phone. 

DNIS Library If unchecked, the Options > Company > DNIS tab will not 
appear. The Project phone number (Options > Projects > 
Phone > Project Phone Number) will not be able to use the 
DNIS library. You will have to manually enter a Project 
phone number. 

Predictive If unchecked, all features related to Predictive dialing will be 
removed from the product, including the Options > Projects 
> Predictive tab and all Predictive reports. 

Preview If unchecked, all features related to Preview dialing are 
removed from the product.

Intelligent Email 
Template

If unchecked, removes the Libraries > Intelligent Email 
Template Navbar item.

IVR Routing If unchecked, removes the Options > Project Menus > 
Touch Tones tab > Route to IVR Server radio button.

System Prompts If unchecked, removes all features related to System 
Prompts, including the System Prompts Navbar heading.

Customer 
Relationship 
Management

If unchecked, removes the Options > Company > CRM tab.

Dialing Out If unchecked, removes the Options > Company > Company 
Configuration tab > Allow Outbound Calls list box.

Workgroup 
Prompts

If unchecked, removes the Options > Projects > 
Workgroups Prompts tab.

Table 3-8. Options Tab Fields and Descriptions

Field Description
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Applet Console Configuration

The Applet Console Configuration tab (Figure 3-19) contains 
settings mainly for advanced troubleshooting. This tab is only available 
to Network Administrators.

To perform advanced troubleshooting

1. Login as a Network Administrator.

2. Click Options > Company > Applet Console Configuration tab 
(Figure 3-19).

Figure 3-19. Applet Console Configuration

Figure 3-19 Applet Console Configuration
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3. Using the information in Table 3-9, complete the fields.

Table 3-9. Applet Console Configuration Fields and Descriptions

Field Description

Close 
Connection

CCA applications (Administration Manager, Interaction 
Manager, Supervision Manager, and so on) occasionally 
connect to the CCA Web server to determine if there are 
any messages (interactions, statistics updates, and so 
forth).

If the Close Connection box is not checked, the applications 
will continue to use the same HTTP connection to the web 
server forever. If this box is checked, the connection will be 
re-established every 60 requests

Disable Agents 
Cache

When a user logs into IM or SM, CCA downloads 
information (about status, workgroups, users, URLs, 
outcomes, and so forth) from the database so that it 
appears in the application. 

While the user is logged in, this information is in 
memory. However, when the user logs out, the 
application writes all the data to temporary files on the 
user’s hard drive. 

CCA does this so that the next time the user logs in, 
the application only needs to download new or 
changed information (like a new project or outcome, or 
a deleted or edited item) rather than downloading 
everything.

When you check this box, CCA downloads all information 
needed by the application (from the database) each time 
the user logs in. 

Please note: This can consume a large amount of 
resources on both the server and the user’s machine.
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Debug Level From the drop-down, select the level of debug information 
to generate. View debug information from a file, Telnet 
window, or the Java Console.

Select from: 
• Off: No debug information is generated.
• Debug: Most debugging information about the system is 

generated. 
• Info: Minimal debug information is generated.
• Error: Only error information is generated.
• Fatal: Only information about fatal errors is generated.
• All: All debug and error information is generated.

Note: If you choose to send the information to the Java 
Console or Telnet, the All option will consume most of your 
memory and CPU.

Enable Telnet To view debug information in a Telnet window:
• Check the Enable Telnet check box.
• Click OK (or Apply).
• Start a Telnet session: “telnet <hostname> <port>” 

where:

<hostname> = the name of the machine where the 
client application is running. (For example, the name of 
the machine where Administration Manager is running.)

<port> =: 
48000 for Interaction Manager
48001 for Supervisor Manager
48002 for Administration Manager

Time to Login 
(in minutes)

From the drop-down menu, select the time IM will wait 
before down loading all needed information from the 
database and logging into the IM server. This means, if the 
login takes more than this time, IM automatically logs out.

Enable Log File Select this check box to write debug information to a file. 
You must also enter a log file path and the path must 
include the filename. 
Note: The system creates folders if they do not exist. 
Note: The system writes a debug file to this path on every 
agent’s machine.

Table 3-9. Applet Console Configuration Fields and Descriptions

Field Description
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4. After changing the setting for any of the check boxes, click the OK 
(or Apply) button. A dialog box appears with two options: 

a. Don’t apply the new policy to every Agent:

This changes the company default setting. Only agents who 
use the company default setting are affected (Options > 
Agents > Controls and Restrictions > Allow Outbound Calls list 
box > Use Company’s Default).

Ping Delay in 
Seconds

CCA applications (Administration Manager, Interaction 
Manager, Supervision Manager, and so forth) occasionally 
connect to the CCA Web server to determine if there are 
any messages (interactions, statistics updates, and so on).

The Ping Delay in Seconds is the time the applications will 
wait before sending their next request to the Web server.

Disable Wrap 
Up Timer

If checked, the wrap up timer does not appear to agents in 
IM. (This prevents flicker on some screens.)

Disable Elapsed 
Timer 

If checked, the Interaction timer does not appear to the 
agent in IM. (This prevents flicker on some screens.)

Disable Phone 
State Timer

This is the animated phone icon that appears in the 
Interaction Manager Information Bar. If checked, the 
animated icon will not be displayed to the Agent. The Agent 
will always see the on-hook icon. This can prevent flicker on 
some screens.

Allow Multi ACD 
Interaction

Select this check box to allow multi ACD (automatic call 
distributor) incoming interactions.

URL Timeout 
(in Seconds)

From the drop-down menu, select the time that the 
application (Administration Manager, Interaction Manager, 
and so forth) will wait for a response from the Web server 
before killing the connection and re-sending the request.

Enable Hot Keys Check this box to enable CCA’s hot-keys.
If unchecked, CCA’s hot-keys do not work and will, 
therefore, not conflict with any third-party application hot 
keys.

Table 3-9. Applet Console Configuration Fields and Descriptions

Field Description
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b. Apply the new policy to every Agent:

This changes the company default setting and the setting for 
all agents in the Options > Agents > Controls and Restrictions 
> Allow Outbound Calls list box. 

For example, if the agent setting is “Always” and you change 
the Company setting to “Disable,” and select Apply the new 
policy to every Agent, then the agent setting changes to 
“Disable.” 

Company Configuration

The Company Configuration tab (Figure 3-20) allows you to add or 
remove several features to Interaction Manager and Supervisor 
Manager. 

To add or remove company configuration features

1. You must login as a Network Administrator for this option to 
become visible.

2. Select Options > Company > Company Configuration tab 
(Figure 3-20.)

Figure 3-20. Company Configuration Tab

Figure 3-20 Company Configuration Tab
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3. Using the information in Table 3-10, complete these fields.

4. Click OK (or Apply).

If you made changes, a dialog box appears with two options: 

• Don’t apply the new policy to every Agent:

This changes the company default setting. Only agents who 
use the company default setting are affected (Options > 
Agents > Controls and Restrictions > Allow Outbound Calls list 
box > Use Company’s Default.)

• Apply the new policy to every Agent:

This changes the company default setting and the setting for 
all agents in the Options > Agents > Controls and Restrictions 
> Allow Outbound Calls list box. 

For example, if the agent setting is “Always,” and you change 
the Company setting to “Disable,” and then select Apply the 
new policy to every Agent, the agent setting changes to 
“Disable.”

Table 3-10. Company Configuration Fields and Descriptions

Field Description

Enable 
Predictive

Check to make the Predictive tab visible to agents and 
supervisors at login. 

Enable Preview Check to make the Preview tab visible to agents and 
supervisors at login. 

Allow Outbound 
Calls

From the drop-down menu, select outbound call options:
• Always: The agent can always make outbound calls 

(including external calls, PBX, IP Call, Connect To Server, 
phone links in the Contact tab, Auto Redial, and so on).

• Enable with Interaction: If the Agent has an active 
interaction of any type, they can make outbound calls for 
the duration of the interaction.

• Disable: The agent can never make any type of 
outbound call. 

Note: As soon as you apply a change, CCA dynamically 
updates both SM and IM immediately.
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Login Policy

Use the Login Policy tab to enforce some password control over anyone 
who logs into Administration Manager, Interaction Manager, and 
Supervision Manager or to authenticate CCA users on an already 
configured LDAP server.

To set a login policy

1. Click Options > Company > Login Policy tab (Figure 3-21).

Figure 3-21. Login Policy - TAW Default Login Policy

Figure 3-21 Login Policy - TAW Default Login Policy
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2. Using the information in Table 3-11, complete the selections.

Table 3-11. Login Policy Fields and Descriptions

Field Description

Select Login Policy From the drop-down menu, select a login 
policy from:
• Select the TAW Default Login option to 

enforce some password control over anyone 
who logs into AM, IM, and SM. (For example, 
the password required length, required 
characters, lockout policy, and so forth.)

• Select the LDAP Authentication option 
to authenticate CCA users on an already 
configured LDAP server. When you select this 
option, different fields appear. Skip “To 
complete the LDAP authentication policy”  
below.

Password must include at 
least the following

Alphabetic Characters: Check so that the 
user’s password must contain at least one 
character in the set A-Z (uppercase or 
lowercase).

Numeric Characters: Check so that the 
user’s password must contain at least one 
character in the set 0-9.

Special Characters: Check so that the user’s 
password must contain at least one special 
character. A special character is any character 
that is not numeric or alphabetic (such as 
“!@#$%) and includes math symbols, 
punctuation, braces, parentheses, slashes, and 
so on.

Upper Case Characters: Check so that the 
user’s password must contain at least one 
uppercase character in the set A-Z.

Lower Case Characters: Check so that the 
user’s password must contain at least one 
lowercase character in the set a-z.

Password Minimum Length From the drop-down list, select a minimum 
password length forcing users to create a 
password with at least this many letters. 
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3. Click OK (or Apply).

To restore a user’s access after a permanent lock out

Follow these steps to restore a user’s access to the system if they have 
been permanently locked out: 

1. Change the lockout policy to Never Lock the User Account and 
click OK (or Apply).

2. Ask the user to login again. (They should be able to access the 
system as usual.)

3. Change the lockout policy back to the setting you prefer.

To complete the LDAP authentication policy

• If you select the LDAP Authentication policy, different fields 
appear on the screen (Figure 3-22).

Number of login attempts 
before locking the account

From the drop-down menu, select the number 
of attempts to give a user (to enter a correct 
username and password) before locking the 
account so that the user can no longer login. 

Note: How the system unlocks the user’s 
account depends on which locking option you 
select in the next check boxes.

Lock User Account for [ ] 
Minutes

Check this option and, from the drop-down list, 
select the maximum time the user must wait 
before being able to login to the account 
again, as usual. 

Lock User Account 
Permanently:

Check this option so that when the number of 
login attempts is reached, the user will not be 
able to login to the system until you unlock 
their account. 

Never Lock the User Account Check this option so there will be no limit on 
the number of incorrect username/password 
combinations that a user can enter.

Table 3-11. Login Policy Fields and Descriptions

Field Description
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Figure 3-22. LDAP Authentication - Additional Fields

Figure 3-22 LDAP Authentication - Additional Fields

4. Using the information in Table 3-12, complete these fields.

Table 3-12. LDAP Authentication Fields and Descriptions

Field Description

LDAP Server Hostname Type the host name of the network machine that 
is running an LDAP server.

LDAP DN Type the distinguished name of the LDAP server. 

Examples of the field syntax: 
• ou=Admin,ou=Global 

Preferences,ou=telephonyatwork.com,o=Netsc
apeRoot

• DC=telephonyatwork,DC=com

LDAP Port Number Type the port the LDAP server uses.

LDAP Search Attribute Type the field where a user exists on the LDAP 
server.
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If the Test LDP Connection fails

1. Change the LDAP information that you entered so that a successful 
test connection is made, 

or

Return to using the TAW Default Login Policy until you 
determine what is causing a problem with the LDAP information. 

2. If you log out of Administration Manager after the test fails, CCA 
forces you to manually edit the CCA database before you can log 
back into Administration Manager. 

To add agents when using LDP authentication

See “Password” on page 6-5 for how to add agents when you use LDAP 
authentication.

TAW LDAP Search User User’s DN: Type the distinguished name of the 
user you created on the LDAP server to allow 
CCA applications to be LDAP authenticated.

Password: Type the password of the user you 
created on the LDAP server to allow CCA 
applications to be LDAP authenticated.

Test LDAP Connection 
(button)

Click this button so that Administration Manager 
will test connect to your LDAP server using the 
information you have provided. (If the test fails, 
go to “If the Test LDP Connection fails”  below.

Note: When using LDAP Authentication, 
you must click this Test LDAP Connection 
button before logging out.

Table 3-12. LDAP Authentication Fields and Descriptions

Field Description
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Licensing

If you have the Service Provider Edition of Administration Manager, 
use the Licensing tab (Figure 3-23) to control:

• The maximum number of allowable simultaneous interactions 
for a company. 

• The maximum number of simultaneous users a company can 
have logged in. 

• The maximum number of channels Predictive Campaigns are 
allowed.

1. Log in as a Network Administrator to edit fields or as a System 
Administrator to only view the fields.

2. Click Options > Company > Licensing tab (Figure 3-23).

Figure 3-23. Licensing Tab

Figure 3-23 Licensing Tab

3. Using the information in Table 3-13, complete these fields.
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Table 3-13. Licensing Tab Fields and Descriptions

Field Description

Maximum Number of 
Simultaneous Interactions 
Permitted for this 
Company.

For each company that you provide service, type 
the maximum number of interactions the 
company can have at the same time.

Apply for Voice 
Interactions Only

Leave this box unchecked to tell CCA to count 
all interactions when calculating the total for the 
previous field. 

For example, if the previous field value is 
400, then CCA allows the company a total of 
400 Interactions of any kind at the same 
time. 

Check this box to give the company unlimited 
non-call interactions while still setting a limit on 
their call interactions.

The company can have as many fax, 
voicemail, email, and chat interactions as 
they want at the same time, but can only 
have a limited number of call Interactions at 
the same time (ACD Call, Inbound/Outbound 
Extension, Direct Inbound/Outbound). 

Interaction Limitations: 
Ability to limit and reserve 
interaction licenses for 
Emails and Chats

You can limit or reserve license “slots” for online, 
offline, and chat interactions. The limitations are 
by company and defined by NetAdmin 
permission. These thresholds, in combination 
with the Peak Interactions Report, allow you to 
better track and allocate your system licenses. 

Type the maximum number of interactions the 
company can have at the same time for Online 
(voice calls, ACD callback, and Web callback), 
Offline (email, ACD fax, and voicemail), and Chat.

Maximum Number of 
Logged in Users

Type the maximum number of agents and 
supervisors the company can have logged in at 
the same time.

Note: CCA does not include Administrators in the 
count. 
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4. Click OK (or Apply).

Unified Messaging

For fast access to voicemails and for more flexible functions, you can 
choose to store voicemail messages as wave files on your local drive; 
using an FTP Server to store the fields and the database to store the 
information and status of the voice mail.

1. Log in as a Network Administrator to edit fields or as a System 
Administrator to only view the fields.

2. Click Options > Company > Unified Messaging tab (Figure 
3-24).

Figure 3-24. Unified Messaging Tab

Figure 3-24 Unified Messaging Tab

Maximum Number of 
Channels Allowed to be 
Used by a Predictive 
Campaign

Type the maximum number of channels a 
Predictive Campaign can use. (This limits the 
impact Predictive dialing has on channel use.)

Table 3-13. Licensing Tab Fields and Descriptions

Field Description
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3. Select how to store voicemails as the default for the entire 
company:

• Click Mail Server to store voice mails on the Network Email 
Server or

• Click Internal Voicemail to store voicemails locally

4. Click OK (or Apply).

You can also identify how to store voicemails at the agent level. 
See Unified Messaging tab on page 6-26.
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Finding a Company
(Service Provider Edition Only)

If you provide call center services for several companies, use the 
Administration Manager Company List search tool to quickly locate a 
company definition from a large list.

To search for a company definition

1. Login to the Administration Manager (see “Starting and Logging 
In” on page 3-3).

The Company List screen (Figure 3-25) appears.

Figure 3-25. Company List Screen

Figure 3-25 Company List Screen

2. Perform a or b:

a. In the character bar above the company list (A B C D, and so 
on), click the first character of the company name.

or
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b. In the Find a Company text box, enter as much of the 
company’s name as you can and then click Go.

CCA lists all companies beginning with the character you clicked or 
beginning with the text you entered in the Find a Company text 
box. 

To manipulate columns of information

1. To sort a list based on column contents, click a column header. 

2. To restore the list so that it displays all companies, click Remove 
Filter.

3. To traverse the list, click the controls at the bottom of the company 
list.

4. To limit the number of companies in the list, from the numeric 
drop-down menu, select the maximum number of company 
definitions to display.

5. Use the information in Table 3-14 for additional ways to manipulate 
the results.

Table 3-14. Company List Results 

Click... To Display...

<<First Click to go to the beginning of the company list.

<Previous Click to go to the previous group of company definitions (based 
on the maximum number to display).

Next> Click to show the next group of company definitions (based on 
the maximum number to display).

Last>> Click to go to the end of the company list.
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4

Creating CCA Libraries 4

CCA Libraries help set up call centers, help agents work more 
efficiently, and help call centers run more smoothly.

In some cases, CCA Libraries represent your company resources (like 
POP3 servers or departments). In other cases, CCA Libraries consist of 
settings (like Prefix Routing Patterns) or information (such as custom 
statuses or faxes). In all cases, create your libraries so that you can 
use them in other parts of the program (such as when setting up your 
agents, workgroups, and projects). 

For example, when you set up an agent for email, Administration 
Manager requires a POP3 server and an SMTP group for that agent. So 
before setting up an agent’s email, you must create at least one record 
(or object) in:

• Libraries > POP3 Servers
• Libraries > SMTP Servers
• Libraries > SMTP Groups

In most cases, creating libraries is extremely easy. However, you may 
need information from other people in your company, such as agent 
supervisors or your IT staff.

Service Provider Edition Users: Before creating libraries, 
you must select a company. Click the Back to List of 
Companies link and double-click on a company name.
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Creating an Agent Skills Library
Agent skills are the abilities each agents possess allowing them to 
handle interactions coming into the call center. CCA matches the needs 
of the caller with the skills of available agents, and routes the 
interaction to the agent most qualified to handle the interaction.

For example, if your call center handles callers who speak French and 
Spanish in addition to English, you might create two agent skills 
(“Speaks French” and “Speaks Spanish”) to supplement the ability to 
speak English, which all your agents possess. Thus, when a 
Spanish-speaking caller reaches the call center, CCA routes the caller 
to the available agent with the highest score for the “Speaks Spanish” 
skill.

To create agent skills

1. Click Options > Skills.

The Skills screen (Figure 4-1) opens.

Figure 4-1. Skills Screen

Figure 4-1 Skills Screen

2. Click Add.

The Add Skill screen (Figure 4-2) opens.

Click Add
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Figure 4-2. Add Skill Screen

Figure 4-2 Add Skill Screen

3. In the Skill Name text box, type the name of the first skill from 
“Question 11: What skills will your agents possess for call routing?” 
of the CCA Planning Survey on page 2-8.

4. In the Description text box, describe the abilities an agent with this 
skill must possess.

5. Click OK. The Skills screen reappears, showing the new skill name 
and description.

6. Repeat steps 1 through 5 to create all the skills specified on the 
CCATM Administrator’s Planning Survey.

7. See page 6-16 for how to assign these skills to individual agents.

Idle Time is a system-defined skill, which you cannot 
delete or edit.
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Creating a URL Library
CCA lets you compile a library of Uniform Resource Locators (Web 
pages) containing content agents can use when assisting customers.

To create a library of URLs

1. Click Options > URLs > Add button. The Add URL screen (Figure 
4-3) opens.

Figure 4-3. Add URL Screen

Figure 4-3 Add URL Screen

2. In the URL Name text box, type a name for the first URL from 
“Question 13: Will your agents read prepared scripts?” of the CCA 
Planning Survey on page 2-9.

3. In the Description text box, describe the purpose or contents of 
this URL.

4. In the URL text box, enter the URL address. 
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5. Click View to preview the contents of the URL and verify the link.

6. Use the information in Table 4-1 to check all the applications this 
URL serves.

7. Click OK (or Apply).

8. Repeat steps 1 through 8 to enter all desired URLs.

Table 4-1. URL Application and Description

URL Application Description

Chat Push Page Check to make the content of this URL available to 
agents handling chat customers, or to make this URL 
available for automatically “pushing” to a chat customer 
who is waiting for an agent. (For example, agents can 
quickly direct chat-based customers to a Web page by 
sending them a Chat Push URL.)

Intelligent Chat Check to make the content of this URL available to an 
agent who has a suggested response to a customer 
based on automatic text analysis of the customer’s chat 
message.

Intelligent Email Check to make the content of this URL available to an 
agent who has a suggested response to a customer 
based on automatic text analysis of the customer’s 
email message.

Web Callback Check to make the content of this URL available to 
agents handling Web callback interactions.

FAQ Check to make the content of this URL available to 
agents providing service to customers reaching the call 
center by phone, chat, email, or Web. (Suggested 
content is a list of approved responses to your 
customer’s most frequently asked questions.)

Script Check to make the content of this URL available to 
agents providing service to customers reaching the call 
center by phone, chat, email, or Web. (Suggested 
content is company-approved text for introducing a 
product or service to the customer.)

If checked, then you must enter an opening script in 
the text box. The opening script appears in the 
Opening Script area of the agent’s IM screen. The 
agent clicks Load Script to view the content specified 
in the script URL
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Creating Agent Statuses
CCA indicates the status of every agent presently logged into the 
system. Supervisors use these agent status indicators to monitor 
agent activity. Agents depend on the IM status indicator to control 
their availability.

To understand system statuses

Table 4-2 lists the predefined system statuses, the condition that 
triggers the status, and whether agents can receive new interactions 
while they are set to the status.:

Table 4-2. System Statuses, Meanings, and Conditions

Status Meaning Condition

ACD Call Busy The agent is handling a call.

ACD Callback Busy The agent is handling a callback request

ACD Chat Busy The agent is handling a chat interaction

ACD Email Busy The agent is handling an email 
interaction.

ACD Fax Busy The agent is handling a fax interaction

ACD Status 
Outbound Email

Busy The agent used IM (Contact tab) to 
initiate an outbound email.

ACD Voicemail Busy The agent is responding to a voice mail 
interaction.

ACD Web Callback Busy The agent is handling a Web callback 
request.

Available Available The agent is not presently handling an 
interaction. An agent can manually 
select this status or can receive this 
status after completing an interaction 
(configured by Administrator).

Busy Busy The agent is not available to receive any 
other ACD interactions.

Direct Chat Busy A supervisor and an agent are chatting.

Last Call Busy Set by agent to indicate that the agent 
will not take anymore interactions after 
completing the current interaction.
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Login Available Reserved for future use.

Logout On Break The agent logged out of IM. This status 
appears in the Company Directory.

New Inbound Call Busy The agent accepted a call made directly 
to their number from a number outside 
the call center.

New Inbound 
Extension

Busy The agent accepted a call made directly 
to their number from an internal 
extension.

New Outbound Call Busy The agent directly dialed a number 
outside the call center.

New Outbound 
Extension

Busy The agent directly dialed a company 
extension.

New Predictive Call Busy The agent accepted a predictive call.

New Preview Call Busy The agent accepted a preview call.

No Answer On break The agent did not answer a workgroup 
call after the maximum allowed number 
of rings.

On Break On break Set by agent to identify that the agent is 
not available to receive interactions.

Selecting Outcome Busy The agent disconnected from the last 
interaction, but is still selecting an 
outcome for that interaction.

Supervising Busy A user logged into Supervision Manager 
and is not available to receive ACD 
interactions.

Wrap Up Busy The agent is wrapping up an interaction. 
The agent status changes to Available 
automatically upon expiration of 
wrap-up time.

You can supplement the above list with additional statuses 
for your call center. For example, “Ten Minute Break” or 
“Out to Lunch.”

Table 4-2. System Statuses, Meanings, and Conditions

Status Meaning Condition
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To create a status

1. Click Libraries > Agent Status > Add button. 

The Add Agent Status screen (Figure 4-4) opens.

2. Locate the row for the language the new status supports. 

a. In the Status Name column, type a name for the first Agent 
Status from “Question 12: What statuses will you use for your 
agents?” of the CCA Planning Survey on page 2-9.

b. In the Description column, describe the activity an agent must 
engage to receive this status.

Figure 4-4. Add Agent Status Screen

Figure 4-4 Add Agent Status Screen
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3. Using the information in Table 4-3, choose a meaning for this 
status.

4. Repeat steps 3 and 4 for all the languages the status supports

5. Click OK.

6. Repeat steps 1 through 6 until you have entered all the statuses 
you specified on the Planning Survey.

Table 4-3. Status Meanings and Descriptions

Meaning Description

Busy This means the agent is busy handling a task.
If the task the agent is handling an online interaction (call, 
callback, or Web callback), then CCA routes incoming 
interactions to another agent.

If the agent is handling an offline interaction (fax, email, or 
voicemail), CCA continues to route incoming interactions to 
the agent until reaching the maximum number of offline 
interactions allowed for the agent. (Refer to “Offline: Type 
the maximum number of simultaneous offline (fax and 
email) interactions CCA can route to the agent while the 
agent is logged into IM.” on page 6-8).

If the agent is handling a chat interaction, CCA continues to 
route incoming chat interactions to the agent until the 
maximum number of chat interactions allowed for the 
agent is reached. (Refer to “Chat: Type the maximum 
number of simultaneous chat Interactions that the system 
can route to the agent while they are logged into IM.” on 
page 6-8).

Available The agent is available to handle interactions. While the agent is 
set to available, CCA considers this agent when routing 
interactions. 

WARNING: If you set No Answer status to mean available, 
CCA may mis-route interactions if an agent forgets to log out of 
IM before leaving their workstation.

On Break The agent is logged into CCA, but is currently unavailable to 
receive interactions.
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When an agent clicks the Change Status button in IM, CCA displays 
the status list so the agent can select one. 

Statuses from the Agent Status Library appear in the My Status 
banner area of IM. The status meaning (Busy, Available, or On Break) 
appears in the Current Status area of IM.

To delete a status

1. Click Libraries > Agent Status. The Agent Status list appears.

2. Click the status to delete and then click the Delete button. A 
confirmation message (Figure 4-5) appears.

Figure 4-5. Delete Status Confirmation Message

Figure 4-5 Delete Status Confirmation Message

Click OK.

To restore system statuses back to their default name and 
meaning, click Restore Default.

You cannot delete a system status.
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Interaction Timeouts
Interaction timeout is not the same as inactivity timeout.

After CCA offers an ACD interaction to an agent, the interaction returns 
to a queue, if the agent does not accept within a specific time. The 
time the agent has to accept the interaction varies, depending on the 
interaction type.

Table 4-4 provides each interaction type and its default timeout or the 
timeout parameters, if configurable.

Only ACD interactions have timeouts. CCA automatically 
accepts interactions that do not go through workgroups.

Table 4-4. Interaction Types and Timeout Descriptions

Interaction Type Timeout Description

ACD Voicemail Hard coded to 5 minutes.

ACD Fax Hard coded to 5 minutes.

ACD Email Hard coded to 5 minutes.

ACD Chat Hard coded to 1 minute.

ACD Call Configurable. See “Set the number of rings the 
system will wait for an Agent to answer” on page 
6-7.

ACD Callback 1 minute.

ACD Web Callback 1 minute.
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Outcomes and Rescheduled Callbacks
What are Outcomes?

An outcome describes the result of an interaction. Example outcomes 
include: Sale, Request for Information, and so on. 

• See “Selecting Interaction Outcomes for the Project” on page 
10-78.

What are Callbacks?

If a customer tries to reach the call center, either by phone or through 
the Web, and no agents are available, configure AM so that the 
customer can ask to be called back. If the customer requested a call 
back from a Web page, the customer can specify when to call back. If 
the customer requested a callback over the phone, the customer is 
called back as soon as an agent is available.

• Web Callbacks: See “Adding Web Callback Interactions to a 
Project” on page 10-72.

• ACD (phone) Callbacks: See “Allow customer to request a 
callback” on page 7-15.

What are Rescheduled Callbacks?

CCA considers the customer’s request to be called back an interaction. 
When the customer makes the request (for Web Callbacks) and/or as 
soon as an agent becomes available, CCA offers the call back to an 
agent. If the agent accepts the call back interaction, CCA calls the 
customer. If the customer does not answer their phone, the agent can 
reschedule by asking CCA to call the customer again, later. 

In IM, the “Reschedule a Callback” feature is in the same dialog box as 
the outcomes (Figure 4-6) feature.
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Figure 4-6. Outcomes Dialog Box in IM

Figure 4-6 Outcomes Dialog Box in IM

Since both features are in the same dialog box, for agents to 
reschedule a call back for a later time, outcomes must also be enabled 
(see “Selecting Interaction Outcomes for the Project” on page 10-78).

Agent can reschedule 
the Callback here.

Agent selects an 
Outcome here.
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Creating Interaction Outcomes
Outcomes basically describe the result of an interaction. Example 
outcomes include “Sale,” “Request for Literature,” and “Complaint.” 
With the Outcomes feature enabled, you can create administrative 
reports that analyze the results of all interactions handled by your 
agents.

You can configure CCA to automatically display the Outcome Library 
and require agents to choose an outcome at the end of these types of 
interactions:

Workgroup Emails
Workgroup Calls
Chats
Web Callbacks
Outbound Calls
Preview Calls
Predictive Calls
Callbacks
Voicemails

You cannot configure outcomes for these types of interactions:

Internal/External extension calls
Direct Inbound calls

To make outcomes required for an agent

1. Select required the Requires Outcome check box for the agent 
by clicking Options > Agents > Add (or Edit) > Controls and 
Restrictions tab > Require Outcome check box. (See page 
6-10.)

2. Create one or more outcomes (see “To create interaction 
outcomes” below).

3. Add required outcomes to your project by clicking Options > 
Projects > New (or Edit) > Outcomes tab. (See page 10-78.)

Also refer to “Outcomes and Rescheduled Callbacks” on 
page 4-12.
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To create interaction outcomes

1. Click Libraries > Outcomes > Add button. The Outcomes screen 
(Figure 4-7) opens.

Figure 4-7. Outcomes Screen

Figure 4-7 Outcomes Screen

2. In the Outcome Name text box, enter the name of the first 
outcome from “Question 20: Will you track interaction results?” of 
the CCA Planning Survey on page 2-15.

3. In the Description text box, describe the results or criteria an 
interaction must meet to qualify for this outcome.

4. Click OK (or Apply).

5. Repeat step 1 through 5 to create all the outcomes specified on 
the Planning Survey.
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Later, you can decide whether to activate the Mandatory Outcomes 
feature for your agents, which requires them to assign an outcome to 
each completed interaction (see “Require outcome” on page 6-10).

Creating a Company Prompt Library
CCA company prompts are sound recordings (in .wav format) which 
greet and inform callers dialing into your company.

CCA provides a set of default System Prompts (see “System Prompts 
Overview” on page 5-2) but you can also create custom company 
prompts. Table 4-5 provides a list of ways CCA uses custom 
recordings from the Prompt Library.

Table 4-5 Applications for the Company Prompt Library (Part 1 of 2)

Prompt Purpose CCA Feature System Default

A touch-tone menu 
description explaining 
how to navigate the call 
center.

Create touch-tone menus for callers hear 
explaining how to navigate your call center. 
See the “Prompt” control on page 8-12 for 
information on assigning a recording from 
your Prompt Library to a touch-tone menu.

None.

Ask the caller to enter 
their ID number.

To identify callers for prioritization, configure 
CCA to ask callers to enter an ID number or 
other personal information. See the “Use 
Prompt to ask for customer ID” control on 
page 10-8 for information on using a 
recording from the Prompt Library to 
request that callers enter an ID.

“Please enter your 
customer ID number 
followed by the pound 
key.”

A menu of options 
available to a caller who 
has finished leaving a 
voicemail message.

Create touch-tone menus for callers who 
finished leaving a voicemail message. See 
the “Menu played after voicemail” control on 
page 10-11 for information on assigning a 
recording from the Prompt Library to a 
touch-tone menu created for this purpose.

None.

Greet callers entering a 
workgroup queue and 
must wait for an agent.

See Intro under the “Select Prompts for 
this workgroup” control on page 7-17 for 
information on choosing a recording from 
the Prompt Library to greet callers entering 
a workgroup.

“All Agents are currently 
busy with other callers. 
Please continue to hold 
to maintain your priority 
sequence. This call may 
be monitored for quality 
assurance purposes.”
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To add a prompt to the Prompt Library

1. Click Libraries > Company Prompts > Add button.

The Company Prompts screen (Figure 4-8) opens.

2. In the Prompt Name text box, type a name that will appear in the 
prompt list after setting Administration Manager to the language 
supported by this prompt.

Play an informational 
message for callers 
waiting to be connected 
to a workgroup agent

See Hold under the “Select Prompts for this 
workgroup” control on page 7-17 for 
information on choosing a recording from 
the Prompt Library to play an message for 
callers waiting to be connected to a 
workgroup agent.

“Your call is very 
important to us. Please 
hold for the next 
available agent. All calls 
are answered in the 
order in which they are 
received.”

Inform the caller that an 
agent is available and 
they are about to be 
connected.

See Ring under the “Select Prompts for this 
workgroup” control on page 7-17 for 
information on choosing a recording from 
the Prompt Library for this purpose.

Thirty-five seconds of 
ringing (7 rings).

Entertain callers who are 
waiting to be connected 
to a workgroup agent.

See Music under the “Select Prompts for 
this workgroup” control on page 7-17 for 
information on choosing a recording from 
the Prompt Library to entertain callers 
waiting to be connected to a workgroup 
agent.

Fifty-six seconds of 
pre-recorded music.

Leave a message for a 
prospective customer’s 
answering machine 
reached through a 
Predictive call.

See “Leave message” on page 10-24 for 
information on leaving a message for a 
customer reached through a Predictive call.

None

You must record and save your prompt recordings before 
adding them to the Prompt Library. See Chapter 5, 
“Customizing Prompts,” for a complete discussion of 
recording, saving, and how to use customized and supplied 
default prompts in CCA.

Table 4-5 Applications for the Company Prompt Library (Part 2 of 2)

Prompt Purpose CCA Feature System Default
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3. Click on the language in which you recorded your prompt.

Figure 4-8. Company Prompts Screen

Figure 4-8 Company Prompts Screen

4. In the Description text box, type a description that will appear in 
the prompt list after setting Administration Manager to the 
language supported by this prompt.

5. Enter the file name and path to the prompt, or click Browse... to 
choose the file from your computer or network. AM uploads the 
file.

6. Click  to listen to the recording to verify that it is correct, or 
click  to cancel a prompt recording previously uploaded.

7. Repeat steps 4 through 7 for each language for which you 
recorded a prompt.

8. Click OK (or Apply).

CCA stores the new prompt in the CCA database and plays it for 
callers (or agents), as necessary.
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Data Sources

CCA ships with a fairly large database containing many tables. One of 
these tables, the Contacts table, is highly customizable. The Contacts 
table is where CCA stores contact records created by agents and 
supervisors.

The Contacts table arrives pre-configured and ready to use. You can 
use it immediately without any changes. In some cases, customers 
customize this table or replace it with a table of their own. For example 
a customer with a lot of contact data in a separate database might find 
it easier to replace the Contact table than customize the existing table. 

What is a Data Source?

A Data Source is a record that passes CCA information about your 
contact record structure and where the data is stored.

The Data Source feature works together with the Display Templates 
feature:

• The Data Source identifies what contact data to store and 
where it is stored. You cannot edit the default System Data 
Source.

• The Display Templates feature provides default templates for 
identifying how contact data appears to agents and 
supervisors. You cannot edit default Display Templates.

You may find this chapter easier to understand if you first read 
“Creating New Display Templates” on page 4-38.

Creating Data Sources is an advanced topic. It can require 
knowledge of the call center server architecture and 
planning, administrator level access to the default CCA 
database, as well as other back end databases used by a 
call center, and administrator rights on one or more call 
center servers.
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Types of Customization

Table 4-6 provides an overview of six main configuration for 
customizing contact record storage.

Table 4-6. Ways to Customize Contact Record Storage

Configuration Description

1
Also see 
“Configuration 1: 
Out of Box” on 
page 4-22.

Keep your contact records in the default table. Use the 
default System Contact Template. 

• default System Contact Template
• default Data Source
• default Contact Table
• CCA database
• CCA Web server

2
Also see 
“Configuration 2: 
Contact Records 
Stored in 
Contacts 
Database” on 
page 4-24.

Keep your contact records in the default table. Create a 
new Contact Template.

• custom Contact Template
• default Data Source
• default Contact Table
• CCA database
• CCA Web server

3
Also see 
“Configuration 3: 
Contact Records 
Stored in Default 
Contact Table” on 
page 4-26.

Keep your contact records in the default table. Create a 
new Contact Template and a new Data Source.

• custom Contact Template
• custom Data Source
• default Contact Table
• CCA database
• CCA Web server

4
Also see 
“Configuration 4: 
Storing Your 
Contact Records” 
on page 4-29.

Keep your contact records in a new table that you create 
in the CCA database. Create a new Contact Template and 
a new Data Source.

• custom Contact Template
• custom Data Source
• custom Contact Table
• CCA database
• CCA Web server
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Database and Table Requirements

• If you are using a table in your own database, the database must 
support JDBC.

• The primary key of the table must consist of a single column.
• You must know the structure of the table that you want to access: 

• Table name
• Column names
• Column data types
• Column max len/value;
• Primary key
• CCA expects the contact data to be in a single table. To use 

multiple tables, you must create a view or create your own 
database access component (ContactBean.class).

• The table can only use data types of integer or string.

5
Also see 
“Configuration 5: 
Storing Same 
Contact Records” 
on page 4-32.

Keep your contact records in a new table that you create 
in your database. Create a new Contact Template and a 
new Data Source.

• custom Contact Template
• custom Data Source
• custom Contact Table
• your database
• CCA Web server

6
Also see 
“Configuration 6: 
Storing Your 
Contact Records” 
on page 4-35.

Keep your Contact records in a new table that you create 
in your database. Use your own Web server to manage 
the database connection pool. Create a new Contact 
Template and a new Data Source.

• custom Contact Template
• custom Data Source
• custom Contact Table
• your database
• your Web server

Table 4-6. Ways to Customize Contact Record Storage

Configuration Description
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Web Server Requirements

• Your Web server must be able to configure a pool of connections 
on the Web server (IIS, WebSphere, Resin, and so on). This is in 
the web.xml file on the Web server that you want to access. 

• You must install the Contact Component - a set of class files and 
JSP files.

• The Web server must have a JDBC driver to connect to your 
database.

• The Web server must have JVM 1.4.2_03.

Installing the Supported Configurations

Refer to Table 4-6 on page page 4-20 for an overview of each 
configuration.

Configuration 1: Out of Box

Figure 4-9. Configuration 1: “Out of the Box” Configuration

Figure 4-9 Configuration 1: “Out of the Box” Configuration

CCA
Web Server

CCA
Database

Default
Contacts
Table

System
Contact
Template
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An “out of the box” configuration is where you use the CCA pre-defined 
as:

• System Contact Template
• Web Server
• Database, and 
• Contacts table

In this configuration:

• You cannot edit the System Contact Template. This 
identifies the default contact record fields agents see when 
they use Interaction Manager.

• When agents and supervisors login, they will select the 
System Contact List in the Contact tab. From their view, all 
of contact records appear in this list. From the database view, 
all contact records are in the default Contacts table.

Figure 4-10.  Agents Select System Contact List At Login

Figure 4-10 Agents Select System Contact List at Login

You cannot delete the System Contact Template.
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To install configuration 1

1. Select Libraries > Display Templates.

2. In the Display Templates main screen, right click System Contact.

3. Click OK.

Configuration 2: Contact Records Stored in Contacts Database

Figure 4-11. Configuration 2: Contact Records Stored in Contacts DB

Figure 4-11 Configuration 2: Contact Records Stored in Contacts DB

In this configuration:

• All contact records are stored in the default Contacts table. 

• When agents and supervisors login, they will see the System 
Contact List and your new Contact List (the name of your 
template). However, both lists are the same. 

For example, if you have 50 contact records in the System 
Contact List, the same 50 records appear when the agent 
selects your Contact List.
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Default
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Your Custom
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System
Data
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Figure 4-12. IM - Contact Information Drop-Down Menu Item

Figure 4-12 IM - Contact Information Drop-Down Menu Item

To install configuration 2

1. Create a new contact template. (See “Creating New Display 
Templates” on page 4-38 for complete information.)

2. Click Libraries > Display Templates > Add button. The Add 
Display Templates screen opens.

3. In the Add Display Templates screen:

a. In the Name tab, type a unique name and description for your 
new Contact Template.

b. From the Data Source list box, select System Contact 
Datasource.

c. Click the Layout and List Header tabs to make any changes 
you desire.

d. Click OK (or Apply) to save your changes.

The label name you give your Custom Contact 
Template appears as a Contact Information 
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Configuration 3: Contact Records Stored in Default Contact Table

Figure 4-13. Configuration 3: Contact Records Stored in Default Contact Table

Figure 4-13 Configuration 3: Contact Records Stored in Default Contact Table

In this configuration:

• All contact records are stored in the default Contacts table. 

• When agents and supervisors login, they will see the System 
Contact List and your new Custom Contact List (the name of 
your new Contact Template). However, both lists are different 
(compare this to Configuration 2). For example, if you have 50 
contact records in the System Contact List, none of them 
appear when the agent selects your new Custom Contact List.

You can have completely separate lists of contact records 
in the same default Contacts table. This is because the 
table uses a Data Source ID column to identify which Data 
Source was used when the Contact record was created.
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Process Example

You’ve created a new Contact Template called “US Contacts,” which 
uses a new Data Source. (The name of the Data Source does not 
matter in this example.)

An agent logs into IM, selects the System Contact List from the 
Contact Information drop-down menu and creates three contact 
records: Mike Roberts, Susan Dawson, and Anthony Anderson. 

The agent then selects your new Custom Contact Template (named 
“US Contacts”), which appears as a item in the Contact 
Information drop-down menu. Then agent them creates another 
three contact records: Evan Lewis, Steve Callard, and Joanne 
Ritchie.

Figure 4-14. The Default Contacts Table

Figure 4-14 The Default Contacts Table

For Configuration 3, Figure 4-14 shows how those records appear in 
the database:

Figure 4-15. Two Contact Lists With Different Records

Figure 4-15 Two Contact Lists With Different Records
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To install configuration 3

1. Create a new Data Source:

a. Click Libraries > Data Source > Add button. The Add Data 
Source screen opens.

b. In the Name tab, type a unique name and description for the 
Data Source.

c. In the Data Source tab:

i. Under Data Format, click System Default.

ii. Under Database Pool Name, click System Default.

iii. Under URL, click System Default. 

d. Click on OK (or Apply) to save your changes.

2. Create a new Contact Template:

(See “Creating New Display Templates” on page 4-38 for complete 
information.)

a. Click Libraries > Display Templates > Add button. The Add 
Display Templates screen opens.

b. In the Name tab:

i. In the Label Name column, type a unique name for your 
new Contact Template.

ii. From the Data Source drop-down menu, select the name 
of the new Data Source that you created in the previous 
step.

c. Click the Layout and List Header tabs, and make any 
changes.

d. Click OK (or Apply) to save your changes.

When an Agent logs in, your Custom Template is not selected by 
default. However, you can assign your Custom Template to a project so 
that when CCA routes a call to that project, the system searches your 
data source in an attempt to make the contact assignment.
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Configuration 4: Storing Your Contact Records

Figure 4-16. Configuration 4: Storing Your Contact Records

Figure 4-16 Configuration 4: Storing Your Contact Records

In this configuration:

• You can store some or all of your contact records in the new 
table that you create in the CCA database.

• When agents and supervisors login, the System Contact List 
and your new Custom Contact List (the name of your Contact 
Template) appears. However, both lists are different (compare 
this to Configuration 2). For example, if you have 50 contact 
records in the System Contact List, none of them appear when 
the agent selects your new Custom Contact List.

The fact that system contact records exist in one table and 
your other contact records are in another table is 
completely transparent to agents and supervisors.
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To install configuration 4

1. Create your new table in the CCA database:

a. Your contact data must be in a single table or a view.

b. The primary key for your contact table must consist of a single 
column.

c. The columns in your contact table must use a data type of 
integer or string.

2. Create a new Data Source:

a. Click Libraries > Data Source > Add button. The Add Data 
Source screen opens.

b. In the Name tab, type a unique name and description for the 
data source.

c. In the Data Source tab, under Data Format, click User 
Defined. A new box (Figure 4-17) appears.

Figure 4-17. Data Format > User Defined Selection

Figure 4-17 Data Format > User Defined Selection

d. Click the plus icon . The column heading (Figure 4-17) 
appear.

e. Type the Table Name, Field Name, Field Type, and Max Length 
of the first column in your custom Contact table. 
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f. Under Database Pool Name, click System Default. 

g. Under URL, click System Default.

h. Click OK (or Apply) to save your changes.

3. Create a new Contact template:

See “Creating New Display Templates” on page 4-38 for complete 
information. 

a. Click Libraries > Display Templates > Add button. The Add 
Display Templates screen opens.

a. In the Name tab:

i. In the Label Name column, type a unique name for your 
Contact Template. 

ii. From the Data Source drop-down menu, select the name 
of the Data Source that you created in the previous step.

b. Click the Layout and List Header tabs, and make any 
changes.

c. Click OK (or Apply) to save your changes.

4. You can assign your new template to a project. 

When an agent logs in, your new template is not selected by 
default. However, when CCA routes a call to that project, the 
system searches your data source in an attempt to make the 
contact assignment.

You only need to enter the columns that you want agents 
and supervisors to see when they login. If you have a 
column in your custom Contacts table that you do not 
need agents and supervisors to see, you do not need to 
add it in the Data Source screen. 

Even if you do add a column here, you can always hide it 
from users later when you create your new Contact 
Template.
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Configuration 5: Storing Same Contact Records

Figure 4-18. Configuration 5: Storing Some Contact Records

Figure 4-18 Configuration 5: Storing Some Contact Records

In this configuration:

• You can store some or all of your contact records in the new 
table you create in your database.

• When agents and supervisors login, they will see the System 
Contact List and your new Custom Contact List (the name of 
your Contact Template). However, both lists are different 
(compare this to Configuration 2). For example, if you have 50 
contact records in the System Contact List, none of them 
appear when the agent selects your Custom Contact List.

The fact that system contact records are in one database 
and your other contact records are in another database is 
completely transparent to agents and supervisors. 
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To install configuration 5

1. Verify that your new database supports JDBC.

2. Create a new Contact table in your database: 

a. Your Contact data must be in a single table or a view.

b. The primary key for your Contact table must consist of a single 
column.

c. The columns in your Contact table must use a data type of 
integer or string.

3. Create a new Data Source.

a. Click Libraries > Data Source > Add button. The Add Data 
Source screen opens.

b. In the Name tab, type a unique name and description for the 
the data source.

c. In the Data Source tab:

i. Under Data Format, click User Defined. A new box (Figure 
4-16 on page 4-29) appears.

ii. Click the plus icon . The column headings appear 
(Figure 4-16 on page 4-29).

iii. Type a Table Name, Field Name, Field Type, and Max 
Length of the first column in your custom Contact table. 

d. Under Database Pool Name, click User Defined and type the 
name of the database that you entered in your web.xml file.

You only need to enter the columns that you want agents 
and supervisors to see when they login. If you have a 
column in your custom Contacts table that you do not need 
agents and supervisors to see, you do not need to add it in 
the Data Format screen. 

Even if you do add a column here, you can always hide it 
from users later when you create your custom Contact 
Display Template. 

CCA_AM.book  Page 33  Wednesday, July 26, 2006  2:55 PM



4-34 CallCenterAnywhereTM Administration Manager

e. Under URL, click User Defined and type the URL of your Web 
server in the text box.

f. Click OK (or Apply) to save your changes.

4. Create a new Contact template:

(See “Creating New Display Templates” on page 4-38 for complete 
information.)

a. Click Libraries > Display Templates > Add button. The Add 
Displays Templates screen opens.

b. In the Name tab:

i. In the Label Name column, type a unique name for your 
Contact Template.

ii. From the Data Source drop-down menu, select the name 
of the Data Source that you created in the previous step.

a. Click the Layout and List Header tabs, and make any 
changes.

b. Click OK (or Apply) to save your changes.

5. You can assign your new template to a project. When an Agent 
logs in, your new template is not selected by default. However, but 
when CCA routes a call to that project, the system searches your 
new data source in an attempt to make the contact assignment.
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Configuration 6: Storing Your Contact Records

Figure 4-19. Configuration 6: Storing Your Contact Records

Figure 4-19 Configuration 6: Storing Your Contact Records

In this configuration:

• You can store some or all of your contact records in the new 
table that you create in your database.

• You can manage the connection pool to your new database 
with your own Web server.

• When agents and supervisors login, they will see the System 
Contact List and your new Custom Contact List (the name of 
your Contact Template). However, both lists will be different 
(compare this to Configuration 2). 

For example, if you have 50 contact records in the System 
Contact List, none of them will appear when the agent selects 
your new Custom Contact List.
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To install configuration 6

1. Configure your Web server.

a. Create a connection pool in your Web server for your database.

b. Install the CCA Contact Component on your Web server. 

c. Verify that your Web server has a JDBC driver that can connect 
to your database.

d. Install JVM 1.4.2_03 on your Web server.

2. Verify that your new database supports JDBC.

3. Create a new Contact table in your database: 

a. Your contact data must be in a single table or a view.

b. The primary key for your contact table must consist of a single 
column.

c. The columns in your contact table must use a data type of 
integer or string.

4. Create a new Data Source:

a. Click Libraries > Data Source > Add button. The Add Data 
Source screen opens.

b. In the Name tab, type a unique name for the data source.

c. In the Data Source tab:

i. Under the Data Format, click User Defined. A new box 
appears (Figure 4-16 on page 4-29).

ii. Click the plus icon . Row headings appear (Figure 4-16 
on page 4-29).

The fact that system contact records exist in one table and 
your other contact records are in another table is 
completely transparent to agents and supervisors.
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iii. Type the Table Name, Field Name, Field Type, and Max 
Length of the first column in your custom Contact table. 

iv. Under Database Pool Name, click User Defined and type 
the name of the database that you entered in your 
web.xml file.

v. Under URL, click User Defined and type the URL of your 
Web server.

vi. Click OK (or Apply) to save your changes.

5. Create a new Contact template:

(See “Creating New Display Templates” on page 4-38 for complete 
information.)

a. Click Libraries > Display Templates > Add button. The Add 
Display Templates screen opens.

b. In the Name tab:

i. In the Label Name column, type a unique name for your 
new Contact Template. 

ii. From the Data Source drop-down menu, select the name 
of the new Data Source you created in the previous step.

c. Click the Layout and List Header tabs, and make any 
changes.

d. Click OK (or Apply) to save your changes.

You only need to enter the columns that you want agents 
and supervisors to see when they login. If you have a 
column in your new Contacts table that you do not need 
agents and supervisors to see, you do not need to add it in 
the Data Format screen. 

Even if you do add a column here, you can always hide it 
from users later when you create your custom Contact 
Display Template. 
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6. You can assign your custom template to a project. When an agent 
logs in, your new template is not selected by default. However, 
when CCA routes a call to that project, the system searches your 
new data source in an attempt to make the contact assignment.

Creating New Display Templates
Administration Manager provides three default display templates:

• The System Contact Template. 

You cannot delete the System Contact Template but you can create 
a new System Contact Template.

By default, contact records are stored in the CCA database. You 
can customize the storage of your contact records by using Data 
Sources. See “Types of Customization” on page 4-20 for more 
information.

• The System Directory Template.

You can use this template as is or you can customize it, changing 
the way agents and supervisors view and search in the Company 
Directory dialog box in Interaction Manager. 

You can customize this template, but you cannot create new 
Directory Templates.

• The System Transfer Template.

You can use this template as is or you can customize it, changing 
the way agents and supervisors view and search in the Transfer 
dialog box in Interaction Manager. 

You can customize this template, but you cannot create new 
Transfer Templates.

CCA_AM.book  Page 38  Wednesday, July 26, 2006  2:55 PM



Creating CCA Libraries 4-39

Contact Templates

A contact is anyone who has called, emailed, or started a Web chat 
with a call center. Agents and supervisors use the Contact tab in IM to 
create contact records and associate the record with a phone number 
or email address. The contact record usually contains information 
(such as name, address, phone number, email address, and so on), 
but can also contain agent notes.

When a customer reaches the call center, IM automatically shows the 
customer’s contact record to the agent. 

Using Contact Templates you can customize the way supervisors and 
agents view, add, and edit contact information. AM comes with a 
default template for contacts (the System Contact Template). You 
cannot modify or delete this template but you can create your own.

To create a new Contact Template

1. Click Libraries > Display Templates > Add button. The Add 
Display Templates screen (Figure 4-20) opens.

Figure 4-20. Add Display Templates: Name Tab 

Figure 4-20 Add Display Templates: Name Tab
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2. Using the information in Table 4-7, complete the Name tab.

3. Click Apply.

4. Click the Layout tab (Figure 4-21) to customize the screen that 
agents and supervisors see when they add and view contacts.

Table 4-7. Name Tab Fields and Descriptions

Item Description

Label Name The label name appears in the list of templates after clicking 
the Contact Templates link in AM. 
The label name also appears to agents and supervisors when 
they log into IM. (Contacts tab > Contact Information).

For example: 
• Enter the string “Contacts Sud Californiens” as a French 

Label Name.
• When an agent logs into IM, the agent chooses French as 

the language. 

Then, when agent clicks the Contact Information drop-down 
menu (in the Contacts tab), the string “Contacts Sud 
Californiens” appears as a menu item.

Description The description appears in the list of templates after clicking 
Contact Templates in IM.

Data Source The location where information is stored. (AM provides a 
default System Data Source already configured for use.)

Assign New 
Contacts 
Automatically 

Check this box so that an agent or supervisor can create a 
new contact record during a current interaction, and CCA will 
automatically assign it to the current interaction. 
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Figure 4-21. Contact Template: Layout Tab 

Figure 4-21 Contact Template: Layout Tab

The Label field holds some information about a contact (such as 
the first name, last name, phone number, and so on). Agents and 
supervisors complete these fields when adding or editing contact 
information.

A Header, like a column heading, serves as a title for several fields 
(such as “Contact Information” or “Additional Phone Numbers”).

Use the Options Used by Agent to control how much access 
agents and supervisors have to contact information. (Table 4-8, 
“Agent Options,” on page 4-43.)

Use the four buttons in the center of the tab  to 
add or delete labels and headers, and change their position. In 
addition, you can click on a label or header and drag it to a new 
location. 
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To create a sample Contact Template

The following steps describe how to create a sample Contact Template. 

1. Click Libraries > Display Templates > Add button. The Add 
Display Templates screen opens.

2. Select the Layout tab. The Contact - Layout screen (Figure 4-21 
on page 4-41) opens.

3. Under Select Options used by Agent, click each option you 
would like available to agents. (Refer to Table 4-8 for a description 
of each option.)

Figure 4-22. Select Options Used by Agents 

Figure 4-22 Select Options Used by Agents

It may be easier to create a Contact Template when 
running two Web browsers:

1.  In the first browser, login to AM.
2.  In the second browser, login to IM as an agent and select the 

Contact tab.

With two browsers open, you can view your new Contact 
Template in IM. However, you must log out of IM and log 
back in each time you make a change to the template in 
AM.

View Contact

Contact History

Edit Contact

Assign Contact

Write Note

Delete Contact

Add Contact

Find Contact
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4. Edit the Labels and Headers for the Contact Template:

a. Under Contact Tab Layout, double-click the first position (“1.”) 
(You can also click the Edit icon.)

The Edit Label/Header - Label dialog box (Figure 4-23) 
appears.

Table 4-8. Agent Options

Agent 
Option Meaning

View Contact Agents and supervisors can view current interactions for the 
contact. 

Contact History Agents and supervisors can select a contact and view all 
interactions for that contact.

Edit Contact The agent can change or delete the information in the 
contact record. 

Assign Contact Agents and supervisors can assign a contact to a customer.

Write Note Agents and supervisors can attach a note to a contact. 

Note: Each contact can have multiple notes using a 
maximum of 1024 characters for each. (Agents and 
supervisors view notes from the Contact tab > View Contact 
button > History tab.)

Delete Contact Agents and supervisors can delete the contact from the list. 

Note: CCA does not permanently remove deleted contacts 
from the data source and only flags them as deleted. 
However, only a user with direct access to the data source 
can change the deletion flag and restore the contact 
information. You cannot do this from AM.

Add Contact Agents and supervisors can add contacts.

Find Contact Agents and supervisors can access a contact search screen.

CCA_AM.book  Page 43  Wednesday, July 26, 2006  2:55 PM



4-44 CallCenterAnywhereTM Administration Manager

Figure 4-23. Edit Label/Header Dialog Box: Label

Figure 4-23 Edit Label/Header Dialog Box: Label

b. Click Header. The Defined Label - Header dialog box (Figure 
4-24) opens.
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Figure 4-24. Edit Label/Header Dialog Box: Header

Figure 4-24 Edit Label/Header Dialog Box: Header Selected

5. In the second column, type a name for the corresponding header, 
such as Contact Information next to English (US).

Type a name in every possible language agents might select when 
logging into IM. If you do not have a specific language preference, 
you can either leave it blank or just copy the name from your most 
commonly used language.

6. Click OK to save your new Header. The Add Display Templates 
screen (Figure 4-20 on page 4-39) reappears.

7. Double-click field number 2.

8. Select Label. The Edit Label/Header Dialog Box: Label (Figure 
4-23 on page 4-44) appears.

9. Using the information in Table 4-9, complete this dialog box.

Table 4-9. Label Box Fields and Descriptions

Field Description

Name Type a name in several different languages.

In AM, this name appears in the Contact Template > Layout 
tab.

In IM, this name appears when an agent or supervisor click 
the Contact tab.
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Here’s an example: 

English: Home Address
French: Adresse personnelle
German: Heimadresse

If an agent selects French language when logging into 
IM, then CCA displays a field called “Adresse 
personnelle” when the agent views, edits, or searches 
for contacts.

If an agent selects English when logging into IM, then 
CCA displays a field called “Home Address.”

Associate Label 
with Action
Category

From the drop-down menu, select an action to associate 
with this label. (Table 4-10 on page 4-50 provides a 
complete list of actions to associate with a label.)

For example, to associate the “Email” label with an action to 
open an new email message using the contact’s email 
address, follow these steps:

1.  Enter Email as the Label Name.
2.  Select Email from the Associate Label with Action 

list box.
3.  Select contacts.email from the Field Name list box.

Now, when an agent or supervisor views a contact in IM, 
the contact’s email address appears as a hyperlink. When 
the agent clicks the hyperlink, IM opens a new mail 
message (using the agent’s mail program) with the 
contact’s email address in the “To” line.

Note: If you select Other, the label will not be associated 
with an action.

Mandatory field Click this box to make the associated action (identified in 
the previous field) mandatory.

Table 4-9. Label Box Fields and Descriptions

Field Description

CCA_AM.book  Page 46  Wednesday, July 26, 2006  2:55 PM



Creating CCA Libraries 4-47

10. For this example, use this information:

Label Name: First Name
Action: Other
Field Name: contacts.firstname

11. Click OK to save your new label. The Add Display Templates screen 
reappears, showing the new field in the contact tab layout.

12. Follow these instructions to create 2 more labels:

Label Name: Last Name
Action: Other
Field Name: contacts.lastname

Label Name: Home Phone
Action: Phone
Field Name: contacts.homephone

13. When finished, the Layout tab reappears (Figure 4-25) showing the 
new information.

Country Code 
Field Name

This field appears in the Edit Label/Header dialog box only if 
you select one of the following from the Associate Label 
with Action drop-down menu:

• Phone
• Fax
• Pager

For these menu items, select contacts.country from the 
Country Code Field Name drop-down menu. Thus, when the 
agent views a contact in IM, the contacts.country field 
appears as a drop-down menu of country codes.

Field Name Field names correspond to locations in the data source 
(such as a column in a database table or view) where 
information is stored. 

Note: When using the default system data source, CCA 
creates a set of fields. When using a custom data source, 
you must create the fields yourself.

Table 4-9. Label Box Fields and Descriptions

Field Description
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Figure 4-25. Sample Layout: One Header With Three Labels

Figure 4-25 Sample Layout: One Header With Three Labels

To delete a label and header

Delete labels and headers by selecting the label or header and clicking 
the delete button (trash can icon). 

To rearrange labels and headers

Rearrange labels and headers by clicking on the up or down arrows, or 
by clicking on the label or header and dragging it to a new position.

Viewing example complex layouts

The sample in Figure 4-25 shows a very simple layout. However, you 
can also create layouts that are more complex, such as with two 
headers in the same column (Figure 4-26) and multiple headers in two 
columns (Figure 4-27).
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Figure 4-26. Sample Layout: Two Headers in Same Column

Figure 4-26 Sample Layout: Two Headers in Same Column

Figure 4-27. Sample Layout: Multiple Headers in Two Columns

Figure 4-27 Sample Layout: Multiple Headers in Two Columns

Remember that the appearance of your layout is exactly 
what agents and supervisors see when viewing and editing 
contacts in IM.
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Table 4-10 provides a description of the label action categories 
available from the “Associate Label with Action - Category” drop-down 
menu.

To select the columns the agent sees when viewing a list of contacts

1. In the Add Display Templates screen, click the List Header tab.

The Add Display Templates - List Header screen (Figure 4-28) 
appears.

Table 4-10. Label Action Categories

List Box 
Selection Action That Occurs in Interaction Manager

Email The contact’s email address appears a hyperlink, so that 
when the agent clicks the hyperlink, IM opens a new mail 
message (using the agent’s mail program), with the 
contact’s email address in the “To” line.

Phone The contact’s phone number appears as a hyperlink, so that 
when the agent clicks the hyperlink, IM dials the number.

Fax The contact’s fax number appears as a hyperlink, so that 
when the agent clicks the hyperlink, IM dials the number.

Web Site The Website appears as a hyperlink, so that when the agent 
clicks the hyperlink, IM launches a browser on the agent’s 
machine and opens the site.

Pager The contact’s pager number appears as a hyperlink., so that 
when the agent clicks the hyperlink, IM dials the number.

External 
Application

A hyperlink to an external application appears, so that when 
the agent clicks the hyperlink, IM launches the application.

CCA_AM.book  Page 50  Wednesday, July 26, 2006  2:55 PM



Creating CCA Libraries 4-51

Figure 4-28. Add Display Templates - List Header Tab

Figure 4-28 Add Display Templates - List Header Tab

2. Click any column heading (None). 

A list box appears (Figure 4-29) showing all of the labels you 
created in the Layout tab.

Figure 4-29. Example List Box With Your Labels

Figure 4-29 Example List Box With Your Labels
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3. Select an item from the menu, which becomes the column 
heading. For example, select First Name from the pop-up list box. 
First Name appears as the first column heading.

4. Do the same for columns 2 and 3, selecting Last Name and 
Phone Number, respectively.

When finished, the List Header tab displays the new column 
headings, as shown in Figure 4-30.

Figure 4-30. Example List Header Tab

Figure 4-30 Example List Header Tab

5. Click OK (or Apply) to save your changes. 

Deleting a Custom Contact Template

You cannot delete System Templates, however you can delete Contact 
Templates that you have created.

To delete a custom contact template

1. Click Libraries > Display Templates. The Display Templates 
main screen (Figure 4-31) opens.

Agents and supervisors must log out and log back into IM 
before they can see the changes.
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Figure 4-31. Display Templates Main Screen

Figure 4-31 Display Templates Main Screen

2. Select the Contact Template you created and then click the Delete 
button. (You can also right-click on a Contact Template and select 
Delete.) 

A confirmation message (Figure 4-32) appears.

Figure 4-32. Delete Confirmation Message

Figure 4-32 Delete Confirmation Message

3. Click OK to confirm the deletion.
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Editing a Custom Contact Template

You cannot edit the default System Contact Template, but you can edit 
a contact template you made. Also, you cannot delete the default 
System Contact Template. 

To edit your custom Contact Template

1. Click Libraries > Display Templates. The Display Templates 
main menu (Figure 4-31 on page 4-53) opens.

2. Select the template to change and click Edit. (You can also 
right-click on the template and select Edit or double-click the 
template.) The Edit Display Templates screen (Figure 4-33) opens.

Figure 4-33. Edit Display Templates Screen

Figure 4-33 Edit Display Templates Screen

3. In the Name tab, modify the name and description of your custom 
Contact Template in different languages.

This name is what agents and supervisors see after selecting a 
Contact Template in IM. See “Label Name” on page 4-40 for more 
information.
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4. Click the Layout tab, where you can:

• Change the options agents use. 

• Create, delete, and edit labels and headers. 

• Rearrange labels and headers to organize the System Contact 
Template differently. 

A Label holds some information about a contact (such as first 
name, last name, phone number, and so on). Agents and 
supervisors complete these fields when adding or editing 
contact information.

A Header (like a column header in a table) serves as a title for 
several fields (such as Contact Information or Additional Phone 
Numbers).

5. Click the List Header tab, so select the columns that agents see 
when viewing a list of contacts.

6. Click OK or Apply to save your changes. 

See Table 4-8 on page 4-43 for information about 
customizing Agent access to contact information.

Instructions for changing Labels and Headers begins with 
Step 4 on page 4-43.

Instructions for changing the List Header starts in Step 1 
on page 4-50.

Agents and supervisors must log out and log back into IM 
before they can see any changes.
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Editing the System Directory Template

The System Directory Template controls the layout and content of 
the Company Directory dialog box in IM. Agents and supervisors see 
this layout when viewing or searching in the Company Directory.

To edit the System Directory Template

1. Click Libraries > Display Templates. The Display Templates 
main menu (Figure 4-31 on page 4-53) opens.

2. Select the System Directory Template and click the Edit button. 
(You can also right-click on the System Directory Template and 
select Edit.) The Edit Display Templates screen (Figure 4-34) 
opens.

Figure 4-34. Edit Display Template Screen

Figure 4-34 Edit Display Template Screen

3. Click the Layout tab, where you can:

CCA_AM.book  Page 56  Wednesday, July 26, 2006  2:55 PM



Creating CCA Libraries 4-57

• Change the options agents use. See the table Table 4-8 on 
page page 4-43 for information about customizing agent 
access to contact information.

• Create, delete, and edit labels and headers. 

• Rearrange labels and headers to organize the System Directory 
Template differently. 

A Label holds some information about a contact (such as first 
name, last name, phone number, and so on). Agents and 
supervisors complete these fields when adding or editing 
contact information.

A Header (like a column header in a table) serves as a title for 
several fields (such as Contact Information or Additional Phone 
Numbers).

4. Click OK (or Apply) to save the changes. 

Editing the System Transfer Template

The System Transfer Template controls the layout and content of 
the Transfer dialog box in IM. Agents and supervisors see this layout 
when viewing or searching in the Transfer dialog box.

To edit the System Transfer Template

1. Click Libraries > Display Templates. The Display Templates 
main menu (Figure 4-31 on page 4-53) appears.

2. Select the System Transfer Template and click the Edit button. 
(You can also right-click System Transfer Template and select 
Edit.) 

3. Click the Layout tab, where you can:

• Change the options agents use. See the table Table 4-8 on 
page page 4-43 for information about customizing agent 
access to contact information.

Instructions for changing labels and headers begins with 
Step 4 on page 4-43.
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• Create, delete, and edit labels and headers. 

• Rearrange labels and headers to organize the System Transfer 
Template differently. 

A Label holds some information about a contact (such as first 
name, last name, phone number, and so on). Agents and 
supervisors complete these fields when adding or editing 
contact information.

A Header (like a column header in a table) serves as a title for 
several fields (such as Contact Information or Additional Phone 
Numbers).

4. Click the List Header tab, where you can select the columns the 
agent sees when viewing a list of contacts. 

5. Click OK (or Apply) to save your changes.

Restoring a System Template

After making changes to any System Template, you can restore all 
default settings.

Instructions for changing labels and headers begins with 
Step 4 on page 4-43.

If you click on any column heading None, a list box 
appears showing all of the labels you created in the Layout 
tab.

Instructions for changing the list header begins with Step 1 
on page 4-50.
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To restore a System Template

1. Click Libraries > Display Templates. The Display Templates 
main menu (Figure 4-31 on page 4-53) opens.

2. Select the System Template and click the Edit button. 

3. In the Name tab, click the Restore Default Contact Template 
button.

Agents and supervisors must log out and log back into IM 
before they can see the changes.
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Creating a Fax Library
With CCA, you can compile a library of pre-developed fax responses 
that agents can use to send to customers. The fax library ensures that 
your agents provide accurate and consistent responses to all 
customers.

To create a library of faxes

1. Click Libraries > Faxes > Add button. 

The Add Fax screen (Figure 4-35) opens.

Figure 4-35. Add Fax Screen

Figure 4-35 Add Fax Screen

You must store CCA fax responses as Tagged Image File 
Format (TIFF) files in the Fax Library. When saving your fax 
responses, select Class F with CCITT Group 3 1D 
compression to ensure compatibility with CCA and your 
telephony hardware.
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2. In the FAX Name field, type a name for the fax.

3. In the Description text box, type a description for, purpose of, or 
contents of the fax.

4. In the Select TIF file text box, enter the filename and path to the 
image file to fax to the customer (or click Browse to locate the file 
on your computer or network.)

5. Click View to display the fax to verify that it is the one you want.

6. Click OK.

7. Repeat steps 1 through 7 to enter additional faxes.

The Current File box displays the filename of a previously 
entered fax.
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Creating an SMTP Server Library
With CCA, you can compile a library of SMTP Server definitions for 
sending email traffic from agents to customers. From this library, 
specify multiple SMTP (outgoing) email servers for call center email 
functions.

CCA automatically balances email traffic loads by using servers in a 
round-robin (rotating) fashion. That is, if one server is busy handling 
email traffic, CCA uses the next server in the list of servers you supply.

To create a library of SMTP Servers

1. Click Libraries > SMTP Servers > Add button. The SMTP Server 
screen (Figure 4-36) opens.

Figure 4-36. SMTP Servers Screen

Figure 4-36 SMTP Servers Screen

2. In the Name text box, type a name for the SMTP server.

3. In the Description text box, type a description of this SMTP server.
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4. Check the Enable SSL box to use a Secure Sockets Layer protocol 
for transmitting sensitive or confidential information securely over 
the Internet. The following must also exist:

• The SMTP port is 25.

• CA certificate location is <CCA installation 
directory>\tmp\cacert.pem

5. In the Host text box, type the name of the computer hosting the 
server.

6. In the Domain text box, type the network domain where this 
server resides.

7. Click OK.

8. Repeat steps 1 through 7 to enter additional SMTP servers.

Support for secure SMTP connections to Mail Servers (using 
secure POP3) is supported for Win32 and Solairs 
applications only.

Depending on the type of SMTP server, if authentication is 
turned off on the SMTP server and you do not enter 
anything in the Domain text box, a connection error may 
occur that will prevent CCA from sending any emails, 
faxes, or voicemails. In this case, all emails, faxes, and 
voicemails end up in the Mail Manager. See your Network 
Manager for more information.
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Creating an SMTP Server Group Library
Create an SMTP Server Group Library with definitions, which CCA can 
use to identify the SMTP email servers when delivering email for email 
projects.

CCA automatically balances email traffic loads by using SMTP servers 
in a round-robin (rotating) method. That is, if one server is busy 
handling email traffic, CCA uses the next server in your group.

To create a library of SMTP server groups

1. Click Libraries > SMTP Groups > Add button. The Add SMTP 
Groups screen (Figure 4-37) appears.

2. In the Name text box, type a name for the group of SMTP servers 
you are creating.

3. In the Description text box, type a description about this group of 
SMTP servers.

You must add SMTP Servers to CCA before creating a 
group of SMTP Servers. If you have not created an SMTP 
Server Library, see “Creating an SMTP Server Library” on 
page 4-62 before creating an SMTP Server Group.
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Figure 4-37. SMTP Group Screen

Figure 4-37 SMTP Group Screen

4. Check the servers to include in the group.

a. From the Importance drop-down menu (next to each selected 
server):

i. Choose High to use the server to handle email 
transactions under normal conditions. 

ii. Choose Low to use the server only if all other servers of 
High importance are unavailable.

5. Click OK.

6. Repeat steps 1 through 5 for all SMTP Server Groups required to 
handle outgoing email for the email Projects.
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Creating a POP3 Server Library
Create a library of POP3 Server definitions, which CCA uses to receive 
email traffic from customers. Use the library to specify multiple POP3 
(incoming) email servers for call center email functions.

CCA automatically balances email traffic loads by using servers in a 
round-robin (rotating) method. If one server is busy handling 
email traffic, CCA uses the next server in the your list of servers. 
For example, if an email project identifies POP1, POP2, and POP3 
and POP2 is busy or not responding, the email distributor checks 
POP1 first, then POP2, and then POP3. When the distributor finds 
POP2 to be not responding, the distributor sends an email to alarm 
and then checks POP3. This cycle continues, except when the 
distributor finds that POP2 is not responding a second time. In this 
case, the distributor does not send any emails to alarm.

Select more than one POP3 server only when sending email to the 
email address of the project. This way the email server for the account 
evenly distributes the email to different POP3 accounts on different 
hosts to ensure load balancing.

When you specify only one POP3 server, then email address of the 
project should also specify that POP3 account. This way, if a customer 
replies to the agent’s email, which uses the email address specified in 
the project, the email goes to the correct POP3 account.

To create a library of POP3 servers

1. Click Libraries > POP3 Servers > Add button. The Add POP3 
Servers screen (Figure 4-38) appears.

2. In the Name text box, type the name of the POP3 server.

3. In the Description text box, type a description of this POP3 server.

4. Check the Enable SSL box to use a Secure Sockets Layer protocol 
for transmitting sensitive or confidential information securely over 
the Internet. The following must also exist:

• The POP3 secure port is 995.

• CA certificate location is <CCA installation 
directory>\tmp\cacert.pem
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5. In the Host text box, type the name of the computer hosting the 
server.

6. In the User text box, type a unique user name for CCA to use 
when logging into this POP3 server.

Figure 4-38. POP3 Servers Screen

Figure 4-38 POP3 Servers Screen

7. In the Password text box, type a password for the user name 
provided in step 6.

8. Click OK.

9. Repeat steps 1 through 8 for all of the POP3 servers.

Support for secure POP3 connections to Mail Servers (using 
secure POP3) is supported for Win32 and Solairs 
applications only.
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Creating an Email Acknowledgment Library
Compile a library of email responses, which CCA sends automatically in 
response to a customer who emailed the call center.

To create a library of email acknowledgments

1. From AM, click Libraries > Email Acknowledgements > Add 
button. The Add Email Acknowledgements screen (Figure 4-39) 
appears.

Figure 4-39. Email Acknowledgments Screen

Figure 4-39 Email Acknowledgements Screen

2. In the Email Acknowledgement Name text box, type a name for 
this email response. 

3. In the Description text box, type a description (or describe the 
purpose or contents) of this email response.

4. In the Subject text box, type a subject line for this response.
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a. If the customer’s original email subject line was blank, CCA 
uses the information in this text box for the subject line of the 
email.

b. If the customer’s original email message contains a subject, 
CCA uses the customer’s subject content.

5. In the File Name text box, type the name of the text file that 
contains the text to place into the body of this response email 
message. 

6. Click the Browse... button to locate a file to use on your computer 
or network. 

7. Click the View button to preview the file you have selected.

8. Click OK.

9. Repeat steps 1 through 8 for all of email acknowledgments.

The file must be a text file (.txt) or a web file (.html).
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Creating an Intelligent Email Template Library
CCA uses Intelligent Email templates to scan incoming email 
interactions for specific key words and then sends automatic responses 
or provides suggested responses to agents. 

When agents receive an email interaction, they can view a list of 
Intelligent Email templates along with the confidence score of each 
template (based on CCA’s analysis of the content of the customer’s 
email). The agent can then send the reply associated with the highest 
scoring template.

Intelligent Email templates are collections of logical “statements” 
consisting of combinations of words, which CCA searches when 
scanning incoming email interactions.

Compile a library to specify which Intelligent Email templates to use in 
your email projects. The templates identify the actions to take based 
on the content of customer’s email inquiries.

To create a library of Intelligent Email Templates

1. Click Libraries > Intelligent Email Templates > Add button. 
The Add Intelligent Email Templates screen (Figure 4-40) appears.

Figure 4-40. Intelligent Email Templates Screen

Figure 4-40 Intelligent Email Templates Screen
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2. In the Email Template Name text box, type a name for the first 
Intelligent Email template.

3. In the Description text box, type a description of the template’s 
purpose.

4. From the URL drop-down menu, choose the URL containing the 
email text for agents who receive an email from a customer where 
the customer’s inquiries match the words or phrases in this 
template. 

5. From the Select Email Acknowledgment to Send drop-down menu, 
choose a response to automatically email to the customer 
(provided the email project is configured to send auto responses).

6. In the Associated Keywords boxes, type the search words for CCA 
to use when scanning the subject line and body of the customer’s 
email message. 

a. For CCA to search using multiple words or phrases, you must 
connect the words using selections from the adjacent 
drop-down menu, where:

i. and = email must contain all words
ii. or = email must contain at least one of the words.
iii. none = separates each logical statement.

7. Click OK and repeat steps 1 through 7 for all the necessary 
Intelligent Email Templates for the email projects.

If there are no entries in the drop-down menu, then refer 
to Intelligent Email under “Creating a URL Library” on 
page 4-4.

Also see “Creating an SMTP Server Library” on page 4-62 
and “Adding Email Interactions to a Project” on page 
10-66.

Refer to “Example Intelligent Template Example” on page 
4-72 for an explanation of how CCA uses this template 
when scanning an incoming email interaction.

To learn how to attach your Intelligent Email Templates to 
an Email Project, see “Email Tab - Select Intelligent Email 
Templates Subtab” on page 10-71.
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Example Intelligent Template Example

When comparing the contents of a customer’s incoming email or chat 
messages against the logical statements in your templates, CCA 
calculates an accuracy level or “score” between 0 (no statements are 
true) and 100 (all statements are true) for each template.

Consider the two Intelligent Email templates in Table 4-11:

The CCA Email Project, which uses the templates in Table 4-11, 
receives an email containing the following text:

“Hello: Please send me information about your GREEN unicycles.”

CCA assigns Template A a score of 50 because the email contents 
contained a word appearing in 50% of the template statements. The 
first statement (“red AND blue OR green”) was true, but the second 
statement (“purple”) was false.

The score for Template B is 0 because the email contained no words in 
either the first statement (“red AND blue OR yellow”) or the second 
statement (“purple”). You can: 

• Configure CCA to send a reply to the customer automatically if one 
of your Intelligent Email Templates exceeds a specified score.

• Configure CCA to suggest email responses to your agents based on 
the Intelligent Email Template scores.

Table 4-11. Example Two Intelligent Email Templates

Template A: red AND blue OR green NONE 
purple NONE 

(statement 1)
(statement 2)

Template B: red AND blue OR yellow NONE 
purple NONE

(statement 1)
(statement 2)

Also see “Adding Email Interactions to a Project” on page 
10-66.
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Creating an Intelligent Chat Template Library
CCA can use Intelligent Chat Templates to scan the content of 
incoming chat interactions for specific key words and then provide 
suggested responses to agents. 

Upon receiving the chat interaction, agents can then view the list of 
Intelligent Chat Templates and the confidence score CCA assigns each 
template (based on analysis of the content of the customer’s chat 
text). 

Intelligent Chat Templates are collections of logical “statements” 
consisting of combinations of words that CCA searches for when 
scanning the content of incoming chat interactions.

Once you compile a library, you can choose which Intelligent Chat 
Templates to use in chat projects. You can also associate one or more 
Intelligent Chat Templates with a specific chat project, to control which 
responses to suggest to agents handling chat customers.

To create a library of Intelligent Chat Templates

1. Click Libraries > Intelligent Chat Templates > Add button. 

The Add Intelligent Chat Templates screen (Figure 4-41) appears.

2. In the Chat Template Name text box, type a name for the first 
Intelligent Chat Template.

3. In the Description text box, type a description of the template’s 
purpose.

The highest scoring template is appears first. However, the 
agent can send a reply associated with any of the matching 
templates.

CCA_AM.book  Page 73  Wednesday, July 26, 2006  2:55 PM



4-74 CallCenterAnywhereTM Administration Manager

Figure 4-41. Intelligent Chat Templates Screen

Figure 4-41 Intelligent Chat Templates Screen

4. From the URL drop-down menu, choose the Intelligent Chat URL 
entry to recommend to agents who receive a chat interaction from 
customers whose inquiries match the words or phrases in this 
template.

5. In the Associated Keywords boxes, type the search words for CCA 
to use when scanning the subject line and body of the customer’s 
email message. 
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a. For CCA to search using multiple words or phrases, you must 
connect the words using selections from the adjacent 
drop-down menu, where:

i. and = email must contain all words

ii. or = email must contain at least one of the words.

iii. none = separates each logical statement.

6. Click Apply.

7. Repeat steps 1 through 6 to enter all necessary the Intelligent 
Chat Templates for all Chat Projects.

8. Click OK.

Refer to “Example Intelligent Template Example” on page 
4-72 for an explanation of how CCA uses this template 
when scanning an incoming email interaction.

To learn how to add your Intelligent Chat Templates to a 
Chat Project, see page 10-58.
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Creating a Department Library
Create a library of Departments to represent the various business 
departments in which the company’s agents work. Though CCA does 
not consider departments when routing interactions, department 
assignments make agents easier to locate using the Company 
Directory in IM.

For example, when agents handling customers in the IM need to 
transfer a call to another agent or transfer to an agent dialog box, the 
Department Library identifies the department in which each agent 
works. This additional search category makes it easier for agents to 
locate other agents in the company.

To create a library of departments

1. Click Libraries > Departments > Add button.

The New Departments screen (Figure 4-42) appears.

Figure 4-42. New Departments Screen

Figure 4-42 New Departments Screen

CCA_AM.book  Page 76  Wednesday, July 26, 2006  2:55 PM



Creating CCA Libraries 4-77

2. In the Department Name and Description columns, type a 
department name and description for each language the call center 
supports.

3. Click OK.

4. Repeat steps 2 through 3 to add a definition for all the 
departments in your company.

Creating an Prefix Routing Pattern Library
Prefix Routing Groups:

• Predictive Projects uses prefix routing to call only selected 
phone numbers in a Dialer List. 

• Allow CCA to route phone customers to specific call center 
areas, based on the number from which the customer is 
calling. By creating a custom routing strategy based on the 
customer’s phone number, you can provide services that are 
tailored to the needs of customers from specific regions or 
locales.

For example:

Consider a Phone Project that takes callers from every state in 
the US. Callers from all states, except New York for example, 
must be routed to your standard agent pool for normal 
processing. Callers from New York, however, require handling 
by agents specially trained to process orders from New York 
customers.

For information on specifying the department to which 
agents and supervisors belong, see “Creating 
Administrator, Agent, and Supervisor Accounts” on page 
6-1.

See “Examples of Predictive Dialing Schedules” on page 
10-28 for more information.
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To meet these routing requirements, you can define Prefix 
Routing Patterns (such as ‘212*’) to match all calls originating 
from New York numbers. The Phone Project routes callers from 
numbers that do not match the New York number pattern to 
the standard agent pool and re-routes New York callers to 
another Project, which implements a custom routing strategy 
to send these callers to the appropriate agents.

To create a Prefix Routing Pattern Library

1. Click Libraries > Prefix Routing > Add button. 

The New Prefix Routing Patterns screen (Figure 4-43) appears.

Figure 4-43. Prefix Routing Patterns Screen

Figure 4-43 Prefix Routing Patterns Screen

2. Use the information in Table 4-12 to complete the Prefix Routing 
Patterns screen.

Table 4-12. Prefix Routing Patterns Fields and Descriptions

Field Description

Name Type a name for this pattern. Create a name that reflects the 
geographical region of numbers you expect to match the 
pattern, or a name that reflects the purpose of the pattern.

Country From the drop-down menu, select a country code to match. 
CCA flags calls made from this country for re-routing to 
another project.
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3. Click OK.

Pattern Type a phone number pattern. Use the ‘*’ wildcard character 
to match all digits in zero or more positions of the number. 

For example, enter 9* to match all numbers beginning with 9, 
including ‘900-123-4567,’ ‘988-765-4321,’ ‘999-123-4567,’ and 
so on. 

Note: This pattern does not match calls from ‘888-854-4224’ 
or any other number that does not begin with 9.

Use the ? wildcard character to match all digits in a single 
position of the number. For example, enter 90?1234567 
to match the phone number ‘123-4567’ in all area codes 
beginning with 90, including ‘901,’ ‘902,’ ‘903,’ up to ‘909.’

Note: This pattern does not match the number 
‘910-123-4567’ or any other number that does not begin with 
90.

Description Type a description for the pattern to help identify it quickly in 
the pattern library.

Table 4-12. Prefix Routing Patterns Fields and Descriptions

Field Description
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Creating a Prefix Routing Group Library
A Prefix Routing Group is a collection of Prefix Routing Patterns. 
With Prefix Routing Groups, you can quickly implement strategies to 
route calls originating from different geographic regions to Projects 
created specifically for handling callers from those regions.

To create a Prefix Routing Group Library

1. Click Libraries > Prefix Routing Groups > Add button.

The Add Prefix Routing Groups screen (Figure 4-44) appears.

Figure 4-44. Prefix Routing Groups Screen

Figure 4-44 Prefix Routing Groups Screen

You cannot create a Prefix Routing Group until you have 
created at least one Prefix Routing Pattern. See “Creating 
an Prefix Routing Pattern Library” on page 4-77 for more 
information.
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2. Use the information in Table 4-13 to complete the Prefix Routing 
Groups screen.

3. Click OK.

4. Repeat steps 2 through 3 to create all the Prefix Routing Groups 
necessary to meet the call center’s custom routing needs.

Table 4-13. Prefix Routing Groups Fields and Descriptions

Field Description

Name Type a name for this Prefix Routing Group. Create 
a name that reflects the geographic region 
represented by the Prefix Routing Patterns you 
plan to include in this group.

Description Type a description for this Prefix Routing Group to 
help quickly identify it in the Prefix Routing Group 
Library.

Select the prefix patterns 
for this Group

Check the Prefix Routing Patterns to match 
against the caller’s phone number. If the 
customer’s number matches one of the checked 
patterns, CCA re-routes the call to the specified 
Project (see “Routing Phone Interactions Based on 
the Caller’s Number” on page 10-13.
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Creating a Matching Patterns Library
Matching Patterns support features like Predictive Dialing, where you 
want to call only selected customers in a Dialer List. 

For example, to call customers where a string column in the Dialer List 
(City, State, Time Zone, and so on) matches a specific pattern, use a 
Matching Pattern. See “Examples of Predictive Dialing Schedules” on 
page 10-28 for more information.

To create a Matching Patterns Library

1. From AM, click Libraries > Matching Patterns > Add button. 
The Add Matching Patters screen (Figure 4-45) appears.

Figure 4-45. Matching Patterns Screen

Figure 4-45 Matching Patterns Screen

2. Use the information in Table 4-14 to complete the Matching 
Patterns screen.

Table 4-14. Matching Patterns Fields and Descriptions

Field Description

Name Type a name that reflects the purpose of this 
pattern.
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3. Click OK.

4. Repeat steps 2 through 3 to create all the Matching Patterns the 
call center needs.

Pattern Type a string pattern. Use the * (wildcard) 
character to match all characters in zero or more 
positions of the number. 

Description Type a description for this pattern to help quickly 
identify it in the Matching Patterns Library.

Table 4-14. Matching Patterns Fields and Descriptions

Field Description
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Creating a Pattern Matching Group Library
A Pattern Matching Group is a collection of Matching Patterns. See 
“Examples of Predictive Dialing Schedules” on page 10-28 for more 
information.

To create a Pattern Matching Group Library

1. Click Libraries > Pattern Matching Groups > Add button. The 
Add Pattern Matching Groups screen (Figure 4-46) appears.

Figure 4-46. Pattern Matching Groups Screen

Figure 4-46 Pattern Matching Groups Screen

You cannot create a Pattern Matching Group until you 
create at least one Matching Pattern. See “Creating a 
Matching Patterns Library” on page 4-82 for more 
information.
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2. Using the information in Table 4-15, complete the Pattern 
Matching Groups screen.

3. Click OK.

4. Repeat steps 2 through 3 to create all the Pattern Matching Groups 
the call center needs.

Table 4-15. Pattern Matching Groups Fields and Descriptions

Field Description

Name Type a name for this Pattern Matching Group.

Description Type a description for this Pattern Matching Group 
to help quickly identify it in the library.

Select the prefix patterns 
for this Group

Check the Matching Patterns that to include in this 
group.
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Hostname/Agent Phone Mapping
To connect a call to an agent, CCA must know:

• Which computer the agent is using. 
• What phone is associated with that computer. 

Usually CCA gets this information when:

• The agent logs into IM. During login, CCA sends the agent’s 
name and computer hostname to the server.

• The agent uses the Configuration dialog box in IM or the 
Administrator uses the Options > Agents > Phone screen to 
tell the server which phone the agent is using.

This process works well in call centers where agents use the same 
computer and phone every day. But in some call centers, agents may 
move from one computer and phone to another. In this case, every 
time the agent logs in, they must go to the Configuration dialog box 
and identify their phone number to the application, or an Admin must 
do this for them (using AM). It also assumes that the agent or Admin 
knows the IP addresses and extension, address, or ID of every phone 
and computer.

To make life easier in this type of call center, AM provides a 
Hostname/Agent Phone Mapping feature. With Hostname/Agent Phone 
mapping, you can associate a computer with a phone so that, when an 
agent logs into IM on a machine, the server:

• Retrieves the agent’s name and the computer hostname when 
the agent logs into IM. 

• Performs a lookup to determine which phone is associated with 
the computer that the agent is using. 

This is all the information that the server needs. By associating a 
phone with a computer, CCA can gather this information no matter 
which computer the agent is using.

To create a hostname/agent phone mapping

1. Click Libraries > Hostname/Agent Phone Mapping > Add 
button. 

The New Hostname/Agent Phone Mapping screen (Figure 4-47) 
appears.
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Figure 4-47. Hostname/Agent Phone Mapping Screen

Figure 4-47 Hostname/Agent Phone Mapping Screen

2. Using the information in Table 4-16, complete the Pattern 
Matching Groups screen.

Table 4-16. Pattern Matching Groups Fields and Descriptions

Field Description

Hostname Type the hostname of an agent’s computer.

Description Type a description for the mapping. 

H323 Click if the agent uses an H323 system and then type 
the IP address in Address box.
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3. Click OK.

4. Repeat steps 2 through 3 to create all the Hostname/Agent Phone 
Mappings the call center needs.

SIP Click if the agent uses a SIP system and then type 
the IP address in Address box

PBX Click if the agent is a member of a Public Branch 
Exchange system and then type the agent’s PBX 
extension number in the Phone box.

Outside phone Click if the agent works remotely and then type the 
agent’s country code and telephone number in the 
Country and Phone boxes, respectively.

Dialogic Analog 
Extension

Click if the agent is a member of a MSI system and 
then type their MSI ID number in the MSI ID box. 

Note: Users may select to have their MSI extensions 
to work Off Hook. There is no dial tone and beeps 
play for an incoming call. With Off Hook, users can 
also have ACD calls auto-accepted without having to 
answer their headset per call.

Table 4-16. Pattern Matching Groups Fields and Descriptions

Field Description
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5

Customizing Prompts 5

Create your own custom greetings and prompts for the touch-tone 
menus callers use to navigate your call center. You can also customize 
the prompts CCA provides to match your business practices.

This chapter describes how to:

• Record, save, and implement prompt files 
• Customize the system greetings and messages CCA provides

What are Prompts?
Prompts are sound recordings (in .wav file format) that CCA plays to 
greet and inform callers dialing into your company. CCA uses two types 
of prompts:

• System Prompts
• Custom Company Prompts

System Prompts are prompts CCA supplies to support core CCA 
features. Custom Company Prompts are prompts you create to 
support call center features that are unique to your company (such as 
touch-tone menus or workgroup greetings).

Each prompt type also has rules CCA uses to determine which prompt 
to play in different situations.
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System Prompts Overview

System prompts are general purpose prompts, which are not 
necessarily unique to a specific call center company, project or 
workgroup.

CCA provides a set of system prompts, which were recorded using a 
female voice. You can use these supplied system prompts in your call 
center with no customization. You can also customize any editable 
system prompt to meet the specific needs of your call center (by using 
a different voice, changing the wording, and so on).

CCA divides system prompts into the following logical groups based on 
how CCA uses them:

• Call Center Prompts
• Date and Time Prompts
• Number Prompts
• Agent Voicemail Prompts
• Company Directory Navigation Prompts
• Project Option Prompts
• Workgroup Option Prompts
• Call Blocking Prompts

Custom Company Prompts Overview

Custom Company Prompts are prompts you create to greet callers who 
dial into a project. They describe the touch-tone menus and other 
options so that callers can navigate the call center. Therefore, a 
Custom Company Prompt is any prompt that describes a unique 
characteristic of your call center, including:

• Greetings identifying the company name or the workgroup name
• Menus for navigating to workgroups in the company
• Menus for navigating to specific agents in the company

Before you can use Custom Prompts in CCA, you must record the 
prompts and save them in the Prompt Library. 

For a list of prompts in each group, see “Prompts Grouped 
by Application” on page 5-16. 

For a complete list of the supplied system prompts, see “All 
Prompts by File Name” on page 5-27.
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Creating a Custom Prompt
Custom Prompts can replace a supplied System Prompt or you can add 
them to the Company Prompt Library. You can then use any Custom 
Prompt from the library with any customized CCA features (such as 
touch-tone menus, workgroup greetings, and so on).

To create a custom prompt for your call center, you must:

• Plan the Prompt
• Record the Prompt
• Save the Prompt

Plan the Prompt

Before recording the prompt, make sure you understand how CCA uses 
it in the call center. Make sure you know:

• If your prompt replaces a CCA System Prompt. (See “Customizing 
System Prompts” on page 5-9.)

or 

• If your prompt supports options and touch-tone menus created 
specifically for the call center’s projects and workgroups. (See 
“Creating a Company Prompt Library” on page 4-16.)

• The name for the prompt as it appears in the CCA Company 
Prompt Library or in the CCA System Prompts.

• The key-presses (tones) the caller can enter in response to the 
prompt, if the prompt describes a touch-tone menu. (See “To 
create a Standard Menu” on page 8-11.)

• The action CCA takes in response to each tone

Instructions for adding the prompts to the Company 
Prompt Library are in “Creating a Company Prompt Library” 
on page 4-16.
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• The text for the prompt, including the text describing both the 
key-press and the action (such as “Press one to reach Sales”).

• The name of the prompt file.

Record the Prompt

Use a high quality sound recording software package (Adobe 
AuditionTM, GoldWave Inc.’s GoldWaveTM, and so on) when recording 
new prompts. Use a high quality microphone and sound card to 
produce the highest quality recordings.

Save the Prompt

To ensure compatibility with CCA, save your prompt recording to a file 
on your hard disk or network with the following characteristics:

Soft switch Installation:

Format: CCITT uLAW
Sampling Rate: 8,000 Khz (800 Mhz)
Resolution: 8 bits
Channels: 1 (mono)

Dialogic Installation:

Format: Windows PCM 
Sampling Rate: 8 Khz 
Resolution: 8 bits
Channels: 1 (mono)

In Solaris, the MP3 Server converts the Mulaw files to PCM 
before converting .wav files to MP3.
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Setting Up a Music Broadcast
Customers can be put on hold in different ways, and while a customer 
is waiting on hold you can configure the system to play audio to them:

• A customer can be on hold while they wait in a Workgroup 
queue. While they wait, you can play a hold prompt. See 
“Select Prompts for this workgroup” on page 7-17, for more 
information.

• After a customer has been connected to an Agent, the Agent 
can put them on hold. While the customer waits, you can play 
a prompt or streaming audio (music broadcast). 

• See “Play Audio on Hold Using” on page 10-5 to learn how 
to play a prompt to a customer who has been put on hold 
by an Agent.

• Follow the instructions in this section if you want to set up 
a music broadcast (streaming audio) to a customer who 
has been put on hold by an Agent.

To play streaming audio (music broadcast)

To play streaming audio for a caller on hold you must have a PC, or 
some other sound player device that can:

• Play music continuously.

• Make a SIP call to the machine where your music server 
resource is running. 

Use Network Manager to create a Music Server resource. The Music 
Server receives the audio stream from your player device and 
re-broadcasts it.

1. Start Network Manager and view by host.

2. Add a new resource. The New Server dialog box (Figure 5-1) 
appears.
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Figure 5-1. Add New Server Dialog Box

Figure 5-1 Add New Server Dialog Box

3. Complete the fields in the Add New Server dialog box.

4. Click the Advanced button. The Music Server dialog box (Figure 
5-2) appears.

Figure 5-2. Music Server Dialog Box

Figure 5-2 Music Server Dialog Box
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5. Complete the fields in the Music Server dialog box.

6. Configure the sound player device. If you use a PC as the audio 
streaming device, you can put a CD of music in the machine, and 
run an audio player software in “repeat” mode.

You also must configure your PC so that it makes a SIP call to the 
Music Server resource you created in the previous step. A simple 
way is to install a “software phone” on your PC. For this example, 
use SJPhone (Figure 5-3). 

Figure 5-3. SJPhone Dialog Box

Figure 5-3 SJPhone Dialog Box

In this example, we configured the Music Server to receive 
and broadcast 10 different audio streams (Max Music 
Channel). For example, use one channel for Jazz, another 
for Pop Music, and so on.
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a. The syntax of the SIP call is: 

sip:<Channel Number>@<IP address you entered in the 
Music Server dialog box>

For example:

SIP:1@192.168.4.65

b. You can enter any number as the Channel Number, as long as 
you do not use that Channel Number for any other audio 
stream. 

In this example, we configured the Music Server resource for a 
max of 10 audio streams. So, theoretically we could set up 10 
boxes that make 10 SIP calls, with 10 unique Channel 
Numbers, that would send our Music Server 10 different audio 
streams.

7. Configure Administration Manager: 

a. Login to Administration Manager as a Netadmin. 

b. View the list of companies.

c. In the Go To… menu, select Music Broadcast, then click the 
Add button.

d. In the Music Broadcast screen, enter a Name, Description and 
a SIP URL. The name and description can be anything, but the 
SIP URL must use this syntax: 

sip:CH<channel number from SIP phone>@<IP address 
you entered in the Music Server dialog box>

For example: 
sip:CH1@192.168.4.65

i. The Channel Number matches what we entered in our 
SJPhone.

ii. The CH must be uppercase. 

iii. The IP address is what you entered in the Music Server 
dialog box in Network Manager.

e. Now, go back to the list of companies (Go To.. > List of 
Companies) and select a company.
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f. Go to Options > Projects > General tab > “Play Audio on 
Hold Using” and select the Music Broadcast button. In the 
list box, the Music Broadcast entry that you just created 
appears.

Customizing System Prompts
Customize the CCA System Prompts to meet the call center needs by 
modifying the voice, language, or text.

To customize a System Prompt

1. Plan, record, and save the prompt file to replace the system 
prompt. (See “Creating a Custom Prompt” on page 5-3).

2. Click System Prompts and then click the group to customize.

For example, to customize a prompt in the Agent Voicemail group, 
click System Prompts > Agent Voicemail CCA displays the list 
of prompts for the group you chose.

3. From the list of prompts, click the prompt to customize, and then 
click Edit. The Edit (customize) System Prompt screen (Figure 5-4) 
appears. 

You can also select a Music Broadcast in a campaign.

To view a list of prompts in each group, see “Prompts 
Grouped by Application” on page 5-16.
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Figure 5-4. Editing (Customize) System Prompt Screen

Figure 5-4 Editing (Customize) System Prompt Screen

4. Click the language in which you recorded your prompt.

5. In the Description text box, type a description of the prompt. This 
description appears in the prompt list after setting AM to the 
language supported by this prompt.

6. Enter the file name and path to the prompt in step 1 (or click 
Browse... to choose the file from your computer or network).

7. Click  to listen to the recording to verify that it is correct (or 
click  to cancel all changes and return to the Prompt list).

8. Repeat steps 4 through 7 for each language for which you 
recorded a prompt.

9. Click OK.

CCA stores the new prompt in the CCA database and plays it for 
callers (or agents), as necessary.

Customized Prompt Icon

System Defined Prompt Icon
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Example: Jay’s Unicycle Company
In this example, the CCA Administrator for “Jay’s Unicycle Company” 
creates a project called “Sales,” which contains two workgroups, 
“English” and “Spanish” for handling English-speaking customers and 
Spanish-speaking customers, respectively.

The following sections describe the steps an Administrator must 
perform to create or customize prompts to route callers to the 
appropriate workgroup.

To create a Company Prompt for routing to a workgroup

As callers dial into Jay’s Unicycle Sales Phone Project, the 
Administrator wants to play a prompt giving the caller the option to be 
routed to either the Spanish-speaking workgroup or to the English 
(U.S.)-speaking workgroup. The Administrator performs the following 
steps to accomplish this routing task:

1. Records and saves the following prompt, describing the caller’s 
language choices, to the local hard disk. (See “Creating a Custom 
Prompt” on page 5-3.)

“Thank you for calling Jay’s Unicycles Sales Department! 
Press one for English. Presione el dos para español.”

If you modify only one or a few of the system prompts, but 
leave the others in their default condition (female, 
business-friendly voice), your customers might hear 
“mixed” prompts. 

For consistency across all prompts, consider customizing all 
system prompts in each language using the same speaker 
or using the system prompts as provided with CCA.

For illustration, some of the steps in this example refer to 
AM features discussed in later chapters of this manual. 
These chapters discuss how to set up projects and 
workgroups that make use of prompts recorded earlier 
using the procedures discussed in this chapter.
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2. Adds the prompt file to the Company Prompt Library under the 
name “Choose Workgroup.” (See “Creating a Company Prompt 
Library” on page 4-16). 

Because this prompt determines the language of the caller, the 
Administrator must place this prompt in the default language for 
the Project, which in this example is English (U.S.).

3. Creates a touch-tone menu that plays the “Choose Workgroup” 
prompt recorded in Step 1 and defines the actions to take when 
the caller presses one or two. (See “To create a Standard Menu” on 
page 8-11.)

4. Creates a Phone Project (Figure 5-5) to route the caller to the 
“Choose Workgroup” menu defined in step 3. (See “Adding Phone 
Interactions to a Project” on page 10-5.)

Figure 5-5. Setting up a Phone Project to Route Callers to a Menu

Figure 5-5 Setting up a Phone Project to Route Callers to a Menu

CCA_AM.book  Page 12  Wednesday, July 26, 2006  2:55 PM



Customizing Prompts 5-13

In this case, each response routes the caller to a second menu, which 
plays another prompt describing the menu choices for routing to a 
specific agent within that workgroup. (See “To create a prompt for 
routing to a specific agent within a workgroup” below).

To create a prompt for routing to a specific agent within a workgroup

In this example, assume the caller reaching the Project described 
above selects option 1 (English-speaking Workgroup) from the 
“Choose Workgroup” menu. The project would route the caller directly 
to the English (US) Workgroup, where the caller would wait in a queue 
for the next available agent in the workgroup.

For our example, assume the Administrator wants to allow the caller to 
reach a specific agent in the workgroup. To do this, the Administrator 
must route the caller to a second menu that describes the 
direct-to-agent routing options within the English (US) workgroup. The 
caller can choose from this menu to be connected to a specific agent in 
the workgroup.

The Administrator performs the following steps to accomplish this 
routing task:

1. Records and saves the following prompt to their local hard disk. 
(See “Creating a Custom Prompt” on page 5-3.)

“You’ve reached Jay’s Unicycles Sales Department. Press one 
for Ashley. Press two for Fred. Press three for Tom. Press 
four for Scott. Press nine to repeat this menu.”

2. Adds the prompt file to the Company Prompt Library under the 
name “Choose Agent.” (See “Creating a Company Prompt Library” 
on page 4-16).

Because the caller selected English as their language, the 
Administrator need only specify a wave file recorded in U.S. 
English for the “Choose Agent” prompt. If, however, the 
Administrator wishes to create a menu that allows Spanish 
speaking callers to choose to be routed to a specific agent, the 
Administrator must specify a wave file recorded in Spanish for the 
“Choose Agent” prompt.

3. Creates a touch-tone menu that plays the “Choose Agent” prompt 
recorded in Step 1 and defines the actions to take (Figure 5-6) 
when the caller presses each valid key. (See “To create a Standard 
Menu” on page 8-11.)
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Figure 5-6. Press 1 to Route Caller to Specific Agent in a Workgroup

Figure 5-6 Press 1 to Route Caller to Specific Agent in a Workgroup

To customize a System Prompt

When CCA routes callers to a workgroup, the caller hears the System 
Workgroup Option Prompts. (For a list of these prompts, see 
“Workgroup Option Prompts” on page 5-22.) 

If the Administrator does not customize these prompts, the caller 
hears CCA’s default recording (business-friendly female voice) in the 
default language for the project.

In this example, assume the Administrator wants to change the default 
Workgroup Option Prompts to match the voice used to create the 
menu prompts in the Company Prompt Library. The first prompt 
customized is the Play Estimated Wait Time prompt. (See “Play 
estimated wait time” on page 7-15.)

The Administrator changes the Play Estimated Wait Time prompt from 
a female voice speaking the default text “your estimated wait time 
is...”, to a male voice speaking slightly different text to match the 
conventions used in their company.

CCA_AM.book  Page 14  Wednesday, July 26, 2006  2:55 PM



Customizing Prompts 5-15

The Administrator performs the following steps to customize the 
prompt:

1. Records and saves the following prompt to their local hard disk or 
network. (See “Creating a Custom Prompt” on page 5-3.)

“A representative will be available in approximately...”

2. Replaces the English (U.S.) version of the “Estimated Wait Time” 
Workgroup Option System prompt with the new prompt created in 
Step 1. (See “Customizing System Prompts” on page 5-9.)

CCA now plays the customized prompt for all callers reaching the 
workgroup.

Restoring System Prompts
After customizing a System Prompt, you can restore it to the original 
prompt later, if conditions change.

To restore a System Prompt

1. Click the System Prompt group containing the prompt to restore. 
For example, to restore a prompt in the Agent Voicemail group, 
click Agent Voicemail.

CCA displays the list of prompts for the group you chose. Prompts 
that are available to restore are identifiable by the absence of a 
bullet in the System Defined column of the list.

2. Select the prompt to restore and click Edit.

3. Click the Restore Defaults button.

CCA restores the original system prompt in all languages, indicated by 
a bullet in the System Defined column of the prompt list.
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Prompts Grouped by Application
The following sections provide all the CCA prompts within the call 
center environment, grouped by application or purpose.

Call Center Prompts

Call Center Prompts (Table 5-1) are sounds or messages CCA plays to 
callers or agents attempting to make calls to or from the system.

Table 5-1 Call Center Prompts

File Name 
(.wav)

Default Recording Default Application

badext “Invalid extension” Plays for customers who dial an unassigned 
extension number.

errmsg “If you would like to make a call, 
please hang up and try again. If you 
need help, hang up and then dial 
your operator.”

Plays for agent if the phone is off hook and 
no keys are pressed.

invalidext “Invalid extension, please hang up 
and try your call again”

Played for agents who dial an invalid 
extension when attempting to call another 
agent.

remoteagent “This call has been forwarded from 
the call center. To accept this call, 
press one.” 

Agent option Play announcement to 
agent.

(See “Play announcement to agent” on 
page 6-15 for information on when CCA 
plays this prompt for agents.)
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Date and Time Prompts

CCA uses Date and Time Prompts (Table 5-2) to build messages 
requiring a date or a time stamp (such as those CCA plays for agents 
retrieving their voicemail messages).

Number Prompts

CCA uses Number Prompts (Table 5-3), the digits from 0 (pronounced 
as “oh”) through 99 (pronounced as “ninety-nine”) to build any 
greeting or message requiring a number.

Table 5-2. Date and Time Prompts

File Name 
(.wav) Default Recording Default Application

am “a.m.” Message time stamp.

april “April” Message time stamp.

august “August” Message time stamp.

day01 - day31 “First” through “Thirty-first” Message time stamp.

december “December” Message time stamp.

february “February” Message time stamp.

january “January” Message time stamp.

july “July” Message time stamp.

june “June” Message time stamp.

march “March” Message time stamp.

may “May” Message time stamp.

november “November” Message time stamp.

october “October” Message time stamp.

pm “p.m.” Message time stamp.

september “September” Message time stamp.

Table 5-3. Number Prompts

0 - 99 “oh” through “ninety-nine”
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Agent Voicemail Prompts

CCA plays Agent Voicemail Prompts (Table 5-4) for agents when are 
setting up or retrieving their voicemail messages. With the exception 
of goodafternoon, goodevening, and goodmorning, callers do not 
hear these prompts.

Table 5-4 Agent Voicemail Prompts  (Part 1 of 2)

File Name 
(.wav) Default Recording Default Application

at “at” Agent Voicemail retrieval

entermailbox “Please enter your mailbox number, followed 
by the pound key.”

Agent Voicemail retrieval

enterpassword “Please enter your password, followed by the 
pound key.”

Agent Voicemail retrieval

goodafternoon “Good Afternoon.” Agent Voicemail retrieval

goodevening “Good Evening” Agent Voicemail retrieval

goodmorning “Good Morning” Agent Voicemail retrieval

heardnewmsg “You have heard all of your new messages.” Agent Voicemail retrieval

heardsavedmsg “You have heard all of your saved messages.” Agent Voicemail retrieval

hundred “hundred” Agent Voicemail Retrieval

invalidmp “The password you entered does not match 
the mailbox you selected”

Agent Voicemail retrieval

listennewarcvm “Press 1 to listen to your new voicemail 
messages, press 2 to listen to your saved 
voicemail messages, press star to return to the 
main menu”

Agent Voicemail retrieval

mailboxmainmenu “Press 1 to retrieve your voicemail messages, 
faxes and emails, press 2 to record or rerecord 
your voicemail greeting, press 9 to repeat 
these choices”

Agent Voicemail retrieval

mailserverdown “The system is unable to connect you to the 
mail server, you may continue into the system 
and do anything you would ordinarily do 
except receive voicemail messages.“

Agent Voicemail retrieval

msgdeleted “Message deleted” Agent Voicemail Retrieval

msgreceivedon “Message received on” Agent Voicemail Retrieval
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msgsaved “Message saved” Agent Voicemail Retrieval

msgsent “Message sent” Agent Voicemail Retrieval

newmessage “New message” Agent Voicemail retrieval

newmessages “New messages” Agent Voicemail retrieval

nomessages “You have no messages in your mail box” Agent Voicemail retrieval

nonewmessages “You have no new messages” Agent Voicemail retrieval

nosavedmessages “You have no saved messages” Agent Voicemail retrieval

pleasehold “Please hold while we connect you to the Mail 
Server.”

Agent Voicemail retrieval

replymailmenu “To repeat this message, press two. To save 
this message, press three. To delete this 
message, press four. To return to the main 
menu, press star. To repeat these choices, 
press nine.”

Agent Voicemail retrieval

savedmessage “Saved message.” Agent Voicemail retrieval

savedmessages “Saved messages.” Agent Voicemail retrieval

selectgreeting “To listen to your busy message press one, to 
record or rerecord your busy message press 2, 
to listen to your recorded name press 7, to 
record or rerecord your recorded name press 
8, To repeat these choices press 9, to return to 
the main menu press star”

Agent Voicemail setup

thousand “Thousand” Agent Voicemail Retrieval.

unknowndate “The system is not able to retrieve the date 
and time of this message.”

Agent Voicemail retrieval

youhave “You have” Agent Voicemail retrieval

Table 5-4 Agent Voicemail Prompts  (Part 2 of 2)

File Name 
(.wav) Default Recording Default Application
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Company Directory Navigation Prompts

CCA plays Company Directory Navigation Prompts (Table 5-5) for 
callers who reach a project which has a menu option allowing the caller 
to reach an agent by choosing from a company directory. (For 
instructions on creating this menu, see “Company Directory” on page 
8-16.)

Project Option Prompts

CCA plays Project Option Prompts (Table 5-6) only if the caller reaches 
a project with the following options:

• Follow Me Forwarding (see page 10-12)

• Ask for Customer ID (see page 10-8)

• Validate Phone Number (see page 10-7)

Table 5-5. Company Directory Prompts 

File Name 
(.wav) Default Recording

entername “Please enter the last name of the person you wish to reach 
using your touch-tone telephone keypad. For the letter “Q”, 
use the number seven. For the letter “Z”, use the number 
nine.”

extnumber “Extension number.”

nopeople “There are no names that match your selection”

select “Press any key when you hear the name of the person you 
wish to reach.”

selectdir “People matching your selection.”

thereare “There are “

transferto “Please hold while I transfer you to “

Table 5-6 Project Option Prompts  (Part 1 of 2)

File Name 
(.wav) Default Recording Project Option

customeridentered “The customer id number you entered is” Ask for customer ID
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customeridnum “Please enter your customer id number 
followed by the pound key” (see “Use Prompt 
to ask for customer ID” on page 10-8 for 
information on replacing this prompt with a 
prompt from your Prompt Library)

Ask for customer ID

_welcome “Hello, and thank you for calling.” Ask for customer ID and 
Validate Phone Number

anotherlocation “To try to reach this person at another 
location, press one. To send this person a 
voicemail message, press two.” See “Enable 
Follow Me” on page 10-12.

Follow Me (played for 
Customer if Agent does not 
answer primary extension 
and Follow Me is enabled)

clientnumconfirm “If this is correct, press one. If this is not 
correct, press two.”

Validate Phone Number

entertelno “Please enter your area code and telephone 
number followed by the pound key.”

Validate phone number

goodbye “Goodbye, and thank you for calling.” Validate phone number, 
Use Prompt to ask for 
customer ID, Workgroup 
option Allow customer to 
leave a voicemail, and 
after input failure to Agent 
voicemail menus.

thankyou “Thank you.” Validate Phone Number 
and Ask for Customer ID

verification “If this is correct, press 1, if this is not correct, 
press 2.”

Ask for Customer ID

Table 5-6 Project Option Prompts  (Part 2 of 2)

File Name 
(.wav) Default Recording Project Option
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Workgroup Option Prompts

CCA plays Workgroup Option Prompts (Table 5-7) for those callers that 
have entered or are waiting in a workgroup queue for the next 
available agent.

If a workgroup option is listed for a prompt, then CCA plays 
that prompt only if the indicated workgroup option is 
enabled in the AM Workgroups screen. (See “Creating a 
Workgroup” on page 7-3.)

Table 5-7. Workgroup Option Prompts  (Part 1 of 3)

File Name 
(.wav) Default Workgroup Option

acdcallback “Press two to enter your 
telephone number and 
receive a call back. Your 
priority status in the 
queue will be preserved”

See “Allow customer to 
request a callback” on 
page 7-15.

acdentercountrycode “Please enter your country 
code followed by the 
pound key.”

Workgroup: Allow callers 
to request a callback. See 
“Allow customer to 
request a callback” on 
page 7-15.

acdentertelno “Please enter your area 
code and telephone 
number followed by the 
pound key.”

Workgroup: Allow callers 
to request a callback. See 
“Allow customer to 
request a callback” on 
page 7-15.

acdgoodbye “You will receive a call 
back as soon as a 
representative has 
become available. Please 
make sure your telephone 
line is free to receive the 
call. Thank you, and 
goodbye.”

“Allow customer to 
request a callback” on 
page 7-15.
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acdintro “All Agents are currently 
busy with other callers. 
Please continue to hold to 
maintain your priority 
sequence. This call may 
be monitored for quality 
assurance purposes.”

See Intro under the 
“Select Prompts for this 
workgroup” control on 
page 7-17 for information 
on replacing this prompt 
with a prompt from your 
Prompt Library.

acdmenu “At any time while you are 
on hold, you may choose 
among the following 
options, or, continue to 
hold for the next available 
Agent.”

See “Allow customer to 
request a callback” and 
“Allow customer to leave 
a voicemail” on page 
7-16.

acdnewmenu “for more options, press 
3”

See “Route to Project 
Menu” on page 7-14.

acdrepeat “Your call is very 
important to us. Please 
hold for the next available 
Agent. All calls are 
answered in the order in 
which they are received.”

See Hold under the 
“Select Prompts for this 
workgroup” control on 
page 7-17 for information 
on replacing this prompt 
with a prompt from your 
Prompt Library.

acdrepeatmenu “Press nine to repeat this 
menu.”

Played if either of Allow 
customer to request a 
callback or Allow 
customer to leave a 
Voice Mail is checked 
(see page 7-15).

acdring Two minutes and nineteen 
seconds of ringing (25 
rings)

See Ring under the 
“Select Prompts for this 
workgroup” control on 
page 7-17 for information 
on replacing this prompt 
with a prompt from your 
Prompt Library.

acdvoicemail “Press one to leave a 
voicemail message”

See “Allow customer to 
leave a voicemail” on 
page 7-16.

Table 5-7. Workgroup Option Prompts  (Part 2 of 3)

File Name 
(.wav) Default Workgroup Option
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acdwaitestimate “Your estimated wait time 
is”

See “Play estimated wait 
time” on page 7-15.

acdwaitminute “minute”

acdwaitminutes “minutes”

countrycodeenter “The country code you 
entered is “

Workgroup Option. See 
“Allow customer to 
request a callback” on 
page 7-15.

invalid “Invalid entry”

music Fifty-six seconds of 
pre-recorded music. 

See Music under the 
“Select Prompts for this 
workgroup” control on 
page 7-17 for information 
on replacing this prompt 
with a prompt from your 
Prompt Library.

numconfirm “If this is correct, press 
one. To re-enter, press 
two. To cancel and 
continue to hold, press 
three.”

See “Allow customer to 
request a callback” on 
page 7-15.

numenter “The number you entered 
is”

See “Allow customer to 
request a callback” on 
page 7-15.

recordmenu “To re-record your 
message, press one. To 
listen to your message, 
press two. To send your 
message, press three. To 
cancel and continue, 
press seven.”

Workgroup option Allow 
Customer to leave a 
Voicemail.

recordmsg “Please record your 
message at the tone. 
When you are finished, 
press the pound key.”

Workgroup option Allow 
Customer to leave a 
Voicemail.

Table 5-7. Workgroup Option Prompts  (Part 3 of 3)

File Name 
(.wav) Default Workgroup Option
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The Order of Workgroup Prompts

The order in which CCA plays workgroup prompts can be affected by 
these features: 

• Allow customer to leave a voicemail
• Allow customer to request a callback

Both features and the process of selecting workgroup prompts, are 
described beginning on page 7-14.

Order of workgroup prompts when not using leave voicemail or request callback

If you are not using either of the above features and you are using the 
default system prompts, CCA plays workgroup prompts in the order 
shown in Table 5-8.

After CCA plays the hold prompt, the customer hears a music 
prompt/hold prompt loop until an agent becomes available or until the 
customer hangs up. 

Order of workgroup prompts when using leave voicemail or request callback

If you are using either of the above features, CCA plays workgroup 
prompts play in the order shown in Table 5-9.

Table 5-8. Order of Workgroup Prompts When Not Using Voicemail or 
Request Callback

Prompt Default File

Intro Prompt acdintro

Music Prompt music

Hold Prompt acdrepeat

Table 5-9. Order of Workgroup Prompts When Using Voicemail or 
Request Callback

Prompt Default File

Intro Prompt acdintro

Music Prompt music

ACD Menu Prompt acdmenu
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After playing the Hold prompt, CCA loops (starting with the music) 
until an agent becomes available or until the customer hangs up. 

Call Blocking Prompts

CCA plays the Call Blocking prompts (Table 5-10) when a customer or 
agent attempts to enter a number that matches a number pattern 
labeled as blocked. (See “Creating a Call Blocking List” on page 14-2.)

For example, if a customer requesting a callback enters a blocked 
number, CCA plays a prompt notifying them that the callback cannot 
be completed. 

or

If an agent attempts to transfer a call to a number identified as 
blocked, CCA plays a prompt to notify them that the transfer cannot be 
completed.

ACD Voicemail Prompt

(If you enabled “Allow customer to leave a voicemail”)

acdvoicemail

ACD Callback Prompt

(If you enabled “Allow customer to request a callback”)

acdcallback

ACD Repeat Menu acdrepeatmenu

Music Prompt music

Hold Prompt acdrepeat

Table 5-10. Call Blocking Prompts

File Name 
(.wav) Default Recording

Default 
Application

countryblocked “We’re sorry, the country code 
you entered cannot be dialed 
from our system.”

Call blocking

Table 5-9. Order of Workgroup Prompts When Using Voicemail or 
Request Callback

Prompt Default File
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All Prompts by File Name
Table 5-11 lists all supplied CCA prompts, sorted by file name.

numberblocked “We’re sorry, the number you 
entered cannot be dialed from 
our system.”

Call blocking

Table 5-11 CCA System Prompts Sorted by File Name  (Part 1 of 9)

File Name 
(.wav) Default Recording Default Application

0 - 99 “oh” through “ninety-nine” Project option Ask for 
customer ID, workgroup 
option Play Estimated 
Wait Time, Validate 
Phone Number, and 
Company Directory 
Navigation

_welcome “Hello, and thank you for calling.” Project options Ask for 
customer ID and Validate 
Phone Number

acdcallback “Press two to enter your telephone number 
and receive a call back. Your priority status in 
the queue will be preserved”

Workgroup: Allow 
customer to request a 
callback option

acdentercountrycode “Please enter your country code followed by 
the pound key.”

Workgroup: Allow callers to 
request a callback. See 
“Allow customer to request a 
callback” on page 7-15.

acdentertelno “Please enter your area code and telephone 
number followed by the pound key.”

Workgroup: Allow callers to 
request a callback. See 
“Allow customer to request a 
callback” on page 7-15.

Table 5-10. Call Blocking Prompts

File Name 
(.wav) Default Recording

Default 
Application
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acdgoodbye “You will receive a call back as soon as a 
representative has become available. Please 
make sure your telephone line is free to 
receive the call. Thank you, and goodbye.”

Workgroup: Allow 
customer to request a 
callback option

acdintro “All Agents are currently busy with other 
callers. Please continue to hold to maintain 
your priority sequence. This call may be 
monitored for quality assurance purposes.”

Workgroup option: See 
Intro under the “Select 
Prompts for this workgroup” 
control on page 7-17 for 
information on replacing this 
prompt with a prompt from 
your Prompt Library.

acdmenu “At any time while you are on hold, you may 
choose among the following options, or, 
continue to hold for the next available Agent.”

Workgroup options Allow 
customer to leave a 
voicemail, Allow 
customer to request a 
callback, and Allow 
customer to leave a 
voicemail.

acdrepeat “Your call is very important to us. Please hold 
for the next available Agent. All calls are 
answered in the order in which they are 
received.”

Workgroup option: Hold 
prompt.

acdrepeatmenu “Press nine to repeat this menu.” Workgroup options Allow 
customer to request a 
callback or Allow 
customer to leave a Voice 
Mail (see page 7-15).

acdring Two minutes and nineteen seconds of ringing 
(25 rings)

Workgroup option: See Ring 
under the “Select Prompts 
for this workgroup” control 
on page 7-17 for information 
on replacing this prompt with 
a prompt from your Prompt 
Library.

acdvoicemail “Press one to leave a voicemail message.” Workgroup: Allow 
customer to leave a 
voicemail option

acdwaitestimate “Your estimated wait time is “ Workgroup option Play 
Estimated Wait Time

Table 5-11 CCA System Prompts Sorted by File Name  (Part 2 of 9)

File Name 
(.wav) Default Recording Default Application
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acdwaitminute “Minute.” Workgroup option Play 
Estimated Wait Time

acdwaitminutes “Minutes.” Workgroup option Play 
Estimated Wait Time

am “a.m.” Date/Time

anotherlocation “To try to reach this person at another 
location, press one. To send this person a 
voicemail message, press two.” See “Enable 
Follow Me” on page 10-12.

Project Option Follow Me 
(played for Customer if 
agent does not answer 
primary extension and 
Follow Me is enabled)

april “April” Date/Time

at “at” Agent voicemail retrieval

august “August” Date/Time

badext “Invalid extension” Played for customers who 
dial an extension that has 
not been assigned.

busytone Eight seconds of busy tone (eight tones) Played for agents to indicate 
a busy line.

Note: You cannot modify or 
delete this prompt using the 
Administration Manager.

clientnumconfirm “If this is correct, press one. If this is not 
correct, press two.”

Project option Validate 
Phone Number

confminutes “Using your touchtone telephone keypad, 
please enter a number between 1 and 300 to 
indicate the number of minutes you wish to 
extend this conference.”

Played to the agent who 
scheduled the conference.

confextend “The conference will be ending soon. To 
extend this conference, press 1. To rejoin the 
conference without extending the time, press 
pound (#).”

Played to conference 
participants.

countryblocked “We’re sorry, the country code you entered 
cannot be dialed from our system.”

Call blocking

Table 5-11 CCA System Prompts Sorted by File Name  (Part 3 of 9)

File Name 
(.wav) Default Recording Default Application
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countrycodeenter “The country code you entered is “ Workgroup option. See 
“Allow customer to request a 
callback” on page 7-15

customeridentered “The customer id number you entered is” Project option Ask for 
customer ID

customeridnum “Please enter your customer id number 
followed by the pound key”

Project option Ask for 
customer ID

day01 - day31 “First” through “Thirty-first” Date/Time

december “December” Date/Time

devicenotdefined “This MSI station id is not available. Please 
select another MSI station id or contact your 
network administrator.”

Played upon picking up an 
MSI agent extension that has 
not been configured.

Note: You cannot modify or 
delete this prompt using the 
Administration Manager.

entermailbox “Please enter your mailbox number, followed 
by the pound key.”

Agent voicemail retrieval

entername “Please enter the last name of the person you 
wish to reach using your touch-tone 
telephone keypad. For the letter “Q”, use the 
number seven. For the letter “Z”, use the 
number nine.”

Company Directory 
Navigation

enterpassword “Please enter your password, followed by the 
pound key.”

Agent voicemail retrieval

entertelno “Please enter your area code and telephone 
number followed by the pound key.”

Project option Validate 
Phone Number

errmsg “If you would like to make a call, please hang 
up and try again. If you need help, hang up 
and then dial your operator.”

Call Center prompt. Played 
for agent if phone is left off 
hook and no keys are 
pressed.

extnumber “Extension number.” Company Directory 
Navigation

february “February” Date/Time

goodafternoon “Good Afternoon.” Agent voicemail retrieval

Table 5-11 CCA System Prompts Sorted by File Name  (Part 4 of 9)

File Name 
(.wav) Default Recording Default Application
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goodbye “Goodbye, and thank you for calling.” Validate phone number, 
Use Prompt to ask for 
customer ID, Workgroup 
option Allow customer to 
leave a voicemail, and 
after input failure to Agent 
voicemail menus.

goodevening “Good Evening” Agent voicemail retrieval

goodmorning “Good Morning” Agent voicemail retrieval

heardnewmsg “You have heard all of your new messages.” Agent voicemail retrieval

heardsavedmsg “You have heard all of your saved messages.” Agent voicemail retrieval

hundred “hundred” Agent voicemail retrieval, 
workgroup option 
Estimated Wait Time

invalid “Invalid entry” Invalid Menu Entry

invalidext “Invalid extension, please hang up and try 
your call again”

Played for agents who dial 
an invalid extension when 
attempting to call another 
agent.

invalidmp “The password you entered does not match 
the mailbox you selected”

Agent voicemail retrieval

january “January” Date/Time

july “July” Date/Time

june “June” Date/Time

licensesnotavailable “The number you have dialed is temporarily 
unavailable due to excessive traffic. Please try 
your call again later.”

Played for callers who reach 
the call center while the 
maximum Interactions 
licensing limit has been met.

Note: You cannot modify or 
delete this prompt using the 
Administration Manager.

listennewarcvm “Press 1 to listen to your new voicemail 
messages, press 2 to listen to your saved 
voicemail messages, press star to return to 
the main menu”

Agent voicemail retrieval

Table 5-11 CCA System Prompts Sorted by File Name  (Part 5 of 9)

File Name 
(.wav) Default Recording Default Application
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mailboxmainmenu “Press 1 to retrieve your voicemail messages, 
faxes and emails, press 2 to record or 
rerecord your voicemail greeting, press 9 to 
repeat these choices”

Agent voicemail retrieval

mailserverdown “The system is unable to connect you to the 
mail server, you may continue into the system 
and do anything you would ordinarily do 
except receive voicemail messages.“

Agent voicemail retrieval

march “March” Date/Time

may “May” Date/Time

msgdeleted “Message deleted” Agent voicemail Retrieval

msgreceived “Message received on” Agent voicemail Retrieval

msgsaved “Message saved” Agent voicemail Retrieval

msgsent “Message sent” Agent voicemail Retrieval

music hold music (56 seconds of light jazz) Workgroup Option: See 
Music under the “Select 
Prompts for this workgroup” 
control on page 7-17 for 
information on replacing this 
prompt with a prompt from 
your Prompt Library.

newmessage “New message” Agent voicemail retrieval

newmessages “New messages” Agent voicemail retrieval

nomessages “You have no messages in your mail box” Agent voicemail retrieval

nonewmessages “You have no new messages” Agent voicemail retrieval

nopeople “There are no names that match your 
selection”

Company Directory 
Navigation

nosavedmessages “You have no saved messages” Agent Voicemail retrieval

november “November” Date/Time

numberblocked “We’re sorry, the number you entered cannot 
be dialed from our system.”

Call Blocking

Table 5-11 CCA System Prompts Sorted by File Name  (Part 6 of 9)

File Name 
(.wav) Default Recording Default Application
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numconfirm “If this is correct, press one. To re-enter, 
press two. To cancel and continue to hold, 
press three.”

Workgroup Option (see 
“Allow customer to request a 
callback” on page 7-15).

numenter “The number you entered is “ Workgroup Option. See 
“Allow customer to request a 
callback” on page 7-15

october “October” Date/Time

pleasehold “Please hold while we connect you to the Mail 
Server.”

Agent voicemail retrieval

pm “p.m.” Date/Time

recordmenu “To re-record your message, press one. To 
listen to your message, press two. To send 
your message, press three. To cancel and 
continue, press seven.”

Workgroup option Allow 
Customer to leave a 
Voicemail

recordmsg “Please record your message at the tone. 
When you are finished, press the pound key.”

Workgroup option Allow 
Customer to leave a 
Voicemail

remoteagent “This call has been forwarded from the call 
center. To accept this call, press one.” See 
“Play announcement to agent” on page 6-15 
for information on when this prompt is played 
for Agents.

Agent option Play 
announcement to agent.

replymailmenu “To repeat this message, press two. To save 
this message, press three. To delete this 
message, press four. To return to the main 
menu, press star. To repeat these choices, 
press nine.”

Agent voicemail retrieval

ring Two minutes and nineteen seconds of ringing 
(25 rings)

Played for direct-dialed calls 
to an extension.

Note: You cannot modify or 
delete this prompt using the 
Administration Manager.

savedmessage “Saved message.” Agent voicemail retrieval

savedmessages “Saved messages.” Agent voicemail retrieval

Table 5-11 CCA System Prompts Sorted by File Name  (Part 7 of 9)

File Name 
(.wav) Default Recording Default Application
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select “Press any key when you hear the name of 
the person you wish to reach.”

Company Directory 
Navigation

selectdir “People matching your selection.” Company Directory 
Navigation

selectgreeting “To listen to your busy message press one, to 
record or rerecord your busy message press 
2, to listen to your recorded name press 7, to 
record or rerecord your recorded name press 
8, To repeat these choices press 9, to return 
to the main menu press star”

Agent voicemail setup

september “September” Date/Time

servicenotavailable “The number you have dialed is temporarily 
unavailable. Please check the number and try 
your call again later.”

Played for callers reaching a 
phone number for which no 
CCA Project has been 
configured. 

Note: You cannot modify or 
delete this prompt using the 
Administration Manager.

silence One second of silence. Played if no prompt exists for 
a menu. 

Note: You cannot modify or 
delete this prompt using the 
Administration Manager.

thankyou “Thank you.” Project Options Validate 
Phone Number and Ask 
for Customer ID, and 
Workgroup Option Allow 
customer to request a 
callback

thereare “There are “ Company Directory 
Navigation

thousand “Thousand” Agent Voicemail Retrieval, 
Workgroup Option 
Estimated Wait Time

Table 5-11 CCA System Prompts Sorted by File Name  (Part 8 of 9)

File Name 
(.wav) Default Recording Default Application
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tone (21 seconds of high-pitched dial tone) Played for agent after 
pressing ‘9’ for an outside 
line.

Note: You cannot modify or 
delete this prompt using the 
Administration Manager.

tone2 (21 seconds of low-pitched dial tone) Played for agent prior to 
dialing. 

Note: You cannot modify or 
delete this prompt using the 
Administration Manager.

transferto “Please hold while I transfer you to “ Company Directory 
Navigation

unknowndate “The system is not able to retrieve the date 
and time of this message.”

Agent voicemail retrieval

verification “If this is correct, press 1, if this is not 
correct, press 2.”

Project option Ask for 
Customer ID

youHave “You have” Agent voicemail retrieval

Table 5-11 CCA System Prompts Sorted by File Name  (Part 9 of 9)

File Name 
(.wav) Default Recording Default Application
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6

Creating Administrator, Agent, and 
Supervisor Accounts 6

Create accounts for three main types of users:

• Agents use the Interaction Manager program to handle 
interactions that enter the call center. 

• Supervisors monitor agent activities using the Supervision 
Manager program, but can also log into the Interaction Manager to 
handle interactions. (Supervisors can have full or limited access to 
CCA and a Guest Supervisor has limited capabilities.)

• Administrators can log into Interaction Manager and Supervision 
Manager, but mainly use the Administration Manager program to 
create and configure companies and accounts.

Refer to Table 6-1 for a complete description of user roles and the 
capabilities of each role.

Table 6-1. User Permissions

User Role Capabilities

Agents can: • Login to Interaction Manager.
• Accept interactions.
• Create contacts.
• Transfer customers and participate in conferences.
• Use chat features.
• Manage tasks.
• Participate in predictive calling.
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When creating user accounts, keep the following in mind:

Supervisors can: • Login to Interaction Manager or Supervisor Manager.
• Access all agent features.
• Supervise agents (Listen, Coach, Join, Hang up, 

Logout, Broadcast, Chat, and Record).
• Set alarms.
• Monitor agent statistics, workgroups, and 

interactions. 
• Review recordings.
• Run any reports Administrators create.
• Control and monitor predictive dialing.

Note: Create Supervisors with both “full” and “limited” 
permissions. (See “Supervisor Permissions” on page 
6-11.

Guest 
Supervisors can:

• Login to Supervision Manager.
• Set alarms.
• Listen to and monitor the status of agents that have 

been assigned to them.

Administrators 
can: 

• Login to Administration Manager, Supervision 
Manager, and Interaction Manager.

• Edit the data, settings, and configurations in their 
company, which the System Administrator gave them.

• Create agents, supervisors, and Guest Supervisors.
• Create reports.

System 
Administrators 
can:

• Login to Administration Manager.
• Access all features available to administrators.
• Edit most of the data, settings, and configurations in 

their company.
• Restrict access of Administrators to program features.

Network 
Administrators 
can (Service 
Provider only):

• Login to Administration Manager.
• Access all features available to System 

Administrators.
• Create new companies.
• Edit all of the data, settings, and configurations in 

any company.
• Create Agents, Supervisors, Guest Supervisors, 

Administrators, System Administrators, and Network 
Administrators. 

Note: This account is only available in the Service 
Provider Edition in the ASP Services Company.

Table 6-1. User Permissions

User Role Capabilities
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• A Network Administrator account can create any account type.

• A System Administrator account can create Administrator 
accounts and below.

• An Administrator account can create Supervisor accounts and 
below.

• A Supervisor account can create Agent accounts.

• Agent accounts cannot create any accounts.

If you login with a Network Administrator account and create a System 
Administrator or another Network Administrator, you CANNOT change 
the access permissions for these accounts later.

For example, after creating a System Administrator account, you 
decide to change access permissions to only a Supervisor level. 
The only way to do this is to delete the System Administrator 
account and create a new Supervisor account from scratch.

If you login as a Network Administrator or a System Administrator and 
create an Administrator, Supervisor, Guest Supervisor, or Agent 
account, you can change the access permissions for these accounts at 
any time. 

For example, after creating an Agent account, you decide to 
change access permissions to a Supervisor or Administrator. You 
can do so at any time. 
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Creating User Accounts
Before creating accounts for agents and supervisors, you must create 
Agent Skills for your call center. See “Creating an Agent Skills 
Library” on page 4-2.

To create user accounts

1. Click Options > Agents > Add button. The Add Agents Screen 
(Figure 6-1) opens to the Profile tab.

Figure 6-1. Agents Screen: Profile Tab

Figure 6-1 Agents Screen: Profile Tab
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2. Use the information in Table 6-2 to complete the Agent - Profile 
fields.

Table 6-2. Agent - Profile Tab Fields and Descriptions

Field Description

First Name Type the agent’s first name.

Last Name The the agent’s last name.

Department Select the department where this agent works.

Address Fields Type contact information for the agent into the address 
fields.

Date Hired Type the date that this agent was hired to work in the call 
center. 
or
Click the  icon to open a calendar, from which you can 
choose the agent’s hire date.

Username Type the username the agent will use to log in to AM. 

Note: For an agent to retrieve voicemail messages from a 
remote telephone (or to set up voicemail greetings), the 
agent’s username must contain only digits (no letters).

Password Type a password for the user.

Notes: 
• For an agent or supervisor to retrieve voicemail messages 

from a remote telephone (or to set up voicemail 
greetings), the password must be digits only (no letters).

• If you are using LDAP authentication, the “Password” and 
“Confirm Password” fields are disabled. (See page 3-43 for 
more information on CCA support for LDAP.) 

When you create a new user (agent, supervisor, and so 
on) and you are using LDAP, AM sets the user’s TAW 
password to be the same as their username. This “default” 
password is never used, as long as you continue to use 
LDAP. But, if you decide to stop using LDAP and go back to 
the TAW Security Policy, your users will still be able to 
login by entering their username as their password. TAW 
designed this default password mechanism to make it 
easier to transition back to the TAW Security Policy after 
using LDAP. 
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3. Click the Controls and Restrictions tab to access the options in 
the Controls and Restrictions screen (Figure 6-2).

Figure 6-2. Agents Screen: Controls and Restrictions Tab

Figure 6-2 Agents Screen: Controls and Restrictions Tab
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4. Use the information in Table 6-3 to complete the Agent Controls 
and Restrictions screen.

Table 6-3. Agent Controls and Restrictions Fields and Descriptions

Field Description

Allow call recording In 
Interaction Manager

Check this box so that the agent can record 
conversations with callers when logged into IM. 

Note: Make sure call recording is allowed by law 
in the Agent’s location.

Enable automatic 
recording of Agent

Check this box to record this agent at random 
times for quality monitoring. 

Note: Agent to agent calls (internal extension) 
are not recorded using this feature. However, all 
other call types (ACD and direct external 
number) are recorded.

Percentage of calls to 
record

Select the percentage of interactions to record 
automatically when the agent is logged into IM. 
For example, if you select 20, then CCA records 
two of every ten Interactions the agent receives.

Note: Each time you change this value, CCA 
resets special counters it uses for "number
of calls received by the Agent" and "number of 
calls recorded for the Agent."

Set the number of rings 
the system will wait for an 
Agent to answer

Type the approximate number of times to ring 
the agent’s extension before setting the agent’s 
status to No Answer and placing the workgroup 
call back into the queue.

Note: The agent and customer may not hear the 
exact number of rings you specify. CCA plays 
ring.wav for ((n * 4)+6) seconds where n is 
the value specified.
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Set the Maximum Number 
of Interactions the Agent 
will Handle Simultaneously

Chat: Type the maximum number of 
simultaneous chat Interactions that the system 
can route to the agent while they are logged into 
IM.

Offline: Type the maximum number of 
simultaneous offline (fax and email) interactions 
CCA can route to the agent while the agent is 
logged into IM.

When an agent accepts an interaction, their 
status automatically changes to Busy. If you set 
the Max Number of Simultaneous Interactions to 
at least 2, the agent can click the Available 
button and accept another interaction. 

When the agent reaches the limit you set here, 
the agent cannot accept any more interactions, 
even if the agent clicks the Available button. 

Note: This field only affects chat and offline 
(fax and email) interactions. No matter what you 
set here, agents can always accept an unlimited 
number of phone interactions.

Also see “Managing Mail Interactions (Email and 
Voicemail)” on page 13-1.

Table 6-3. Agent Controls and Restrictions Fields and Descriptions

Field Description
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Inactive Session Timeout Use the Inactive Session Timeout to 
automatically log out an agent or supervisor after 
a period of inactivity. 

• Use the Inactive Session Timeout in the 
Controls and Restrictions tab to set an 
inactivity timeout for an individual account. 

• There is also an Inactive Session Timeout that 
you can apply to the entire company. (Options 
> Company > Profile tab > Inactive Session 
Timeout). See page 3-10.

Disable Session Timeout: CCA will never 
automatically log out the account. 

Enable Session Timeout: Select a timeout 
value between 5 minutes and 24 hours. 

Allow Outbound Calls Use Company’s Default: Check so that the 
agent can make outbound calls as defined in 
Options > Company > Company Configuration > 
Allow Outbound Calls list box.

Disable: Check so that the agent can never 
make outbound calls.

Enable international long 
distance dialing

Choose so that the agent can make long distance 
calls to any country code from their workstation.

Restrict long distance 
dialing to this country code

Choose so that the agent can make long distance 
calls only to the specified country code.

Project Billing Select the project to use as the default billing 
project for this agent in IM.

Allow wrap up time after 
calls

Check so that the agent has time to wrap up a 
concluded phone Interaction (ACD call, callback, 
and Web callback). After the Wrap up Time 
expires, the system changes the agent’s status to 
Available and routes interactions to the agent

Note: Wrap up does not apply to direct inbound 
or direct outbound calls. As soon as an agent 
disconnects from a direct inbound or outbound 
call, CCA changes the agent’s status immediately 
to Available. 

Table 6-3. Agent Controls and Restrictions Fields and Descriptions

Field Description

CCA_AM.book  Page 9  Wednesday, July 26, 2006  2:55 PM



6-10 CallCenterAnywhereTM Administration Manager

Wrap-up time Type the number of seconds the agent has to 
wrap-up a concluded phone interaction.

Require outcome Check so that the agent can view the Outcome 
Library at the conclusion of interactions. 
(Requiring agents to record an outcome after 
each interaction helps track the results of 
interactions.)

Notes: 

To enable outcomes, you must:
• Check this check box for the agent.
• Create one or more outcomes (Libraries > 

Outcomes).
• Add required outcomes to your project 

(Options > Projects > Outcomes tab).

In addition, you must enable outcomes so that 
agents can reschedule a Web callback or ACD 
callback interaction. 

Note: Outcomes are required for each agent 
handling Predictive Projects. 

Display this Agent in the 
Company Directory

Check to add the agent to the Company 
Directory.

When the Agent is logged 
out, send the call directly 
to voicemail

Check to have CCA immediately send all calls 
routed to the logged out agent to voicemail.

Status of the Agent at 
Login

From the drop-down menu, select a predefined 
system status (Available, Busy, Last Call, or On 
Break) to assign the agent when the agent first 
logs into CCA. After login, the agent's state can 
change as usual (either manually by the agent or 
by the system). 

Note: You cannot select a custom status.

Table 6-3. Agent Controls and Restrictions Fields and Descriptions

Field Description
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5. Click the Regional Settings tab to open the Regional Settings 
screen (Figure 6-3).

The agent will listen to the 
ACD Voicemail by:

Select how the agent uses their email or their 
phones to access an ACD voicemail.

Select Email so that the agent can access ACD 
voicemails by:
1. Accepting the voicemail as an interaction. 

2. The system starts the agent's email client. 
The voicemail appears as an email 
attachment. 

3. The agent opens the sound file attachment 
and listens. 

Select Phone so that the agent can access ACD 
voicemails by:
1. Accepting the voicemail as an interaction. 

2. The call center will ring the Agent's phone 
and give the Agent several options, one of 
which will be to listen to the voicemail. 

Supervisor Permissions If you are creating or editing a supervisor 
account, give the supervisor either limited or 
full permissions.

Limited access allows the supervisor to access 
information related to their assigned agents in 
SM. 

Full access allows the supervisor to access 
information for all agents, workgroups, and 
interactions for the entire company. 

The access level you give to a supervisor affects 
several screens in SM. (Refer to “Types of 
Supervisor Accounts” in the Supervision Manager 
manual for more details.)

Table 6-3. Agent Controls and Restrictions Fields and Descriptions

Field Description
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Figure 6-3. Agents Screen: Regional Settings Tab

Figure 6-3 Agents Screen: Regional Settings Tab

6. Use the information in Table 6-4 to complete the Agent Regional 
Settings.

Table 6-4. Agent Regional Settings Fields and Descriptions

Field Description

Select Time 
Zone

Choose the time zone in which this agent works. 

If the agent configures their IM to “User Defined Time Zone” 
(instead of the Company time zone; see “Configuring 
Company Time Zone and Date Format” on page 3-19), the 
time zone you choose here becomes the agent’s default time 
zone. However the agent can override your selection at their 
workstation.

Select Date 
Format

Click the date format for area in which this agent works. The 
date format you choose here becomes the agent’s default 
date format. However the agent can override your selection 
at their workstation to use a date format of their choice.

CCA_AM.book  Page 12  Wednesday, July 26, 2006  2:55 PM



Creating Administrator, Agent, and Supervisor Accounts 6-13

7. Click the Email tab to access the Email screen (Figure 6-4).

Figure 6-4. Agents Screen: Email Tab

Figure 6-4 Agents Screen: Email Tab

8. Use the information in Table 6-5 to complete the agent’s email 
information. 

Table 6-5. Email Fields and Descriptions

Field Description

Agent Email 
Address

Type the full email address for CCA to use to route email 
interactions to the agent.

Host Type the name of the computer hosting the POP3 Server this 
agent uses.

User Type the username for the agent to use when accessing the 
POP Server.

Password Type the password for the agent to use when accessing the 
POP Server.
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9. Click the Phone tab to access the Phone screen (Figure 6-5).

Figure 6-5. Agents Screen: Phone Tab

Figure 6-5 Agents Screen: Phone Tab

Enable SSL Check to add secure POP3 and SMTP connections to Mail 
Servers.

Note: This is supported for Win32 and Solairs applications 
only.

Select SMTP 
Group

From the drop-down menu, select the SMTP Server Group for 
CCA to use when handling mail sent by this agent.

Table 6-5. Email Fields and Descriptions

Field Description
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10. Using the information in Table 6-6, supply an extension number 
and phone type for the agent.

Table 6-6. Phone Screen Extension Types and Descriptions

Extension Type Description

Agent Extension 
Number

This is a required field. Type the extension number 
for the agent. 

If you do not know the agent’s extension number, 
contact the Administrator or the provisioning 
department at the customer site.

H323 Select if the agent uses a H323 system and type 
the IP address in Address box.

SIP Select if the agent uses a SIP system and type the 
IP address in Address box

PBX Select if the agent is a member of a Public Branch 
Exchange system and type the agent’s PBX 
extension number in the Phone box.

Outside phone Select if the agent works remotely. From the 
drop-down menu, select the agent’s country code 
and then type the telephone number in the Phone 
box.

Play announcement to 
agent

Check to play the prompt remoteagent.wav, 
which alerts the remote agent that the call is a CCA 
call, and gives the agent the opportunity to accept 
or reject the call.

Dialogic Analog 
Extension

Select if the agent is a member of a MSI system 
and type their MSI ID number in the MSI ID box. 

No Phone Select to send all calls directly to the agent’s 
voicemail.

Work Off Hook Users may select to have their MSI extensions set 
to work Off Hook. There is no dial tone and beeps 
play when a call is incoming. With Off Hook, users 
can also have ACD calls auto-accepted without 
having to answer their headset per call.

Automatic Call 
Acceptance

If you select Work Off Hook, select Automatic all 
Acceptance so that the ACD all interaction is 
automatically accepted by the agent.
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11. Click the Skills tab to access the Skills screen (Figure 6-6).

Figure 6-6. Agents Screen: Skills Tab

Figure 6-6 Agents Screen: Skills Tab

Direct Inward Dialing From the drop-down menu, select a company DNIS 
number. CCA automatically routes customers who 
call this number to this agent. The agent’s name 
appears in the Company > DNIS tab > Agent’s 
Direct Inward Dialing Number, identifying that the 
DNIS is assigned to the agent.

Note: For calls that are routed directly to an agent 
to appear in reports (such as Direct Dialing 
Statistics and Project Key Statistics), you must 
select a Billing Project for the agent (Options > 
Agents > Controls and Restrictions > Project Billing 
check box).

Note: If this box is empty, it means the DNIS 
library option is disabled. (To enable
it, go to Options > Company > Options tab > 
and check the DNIS Library check box.)

Table 6-6. Phone Screen Extension Types and Descriptions

Extension Type Description
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Agent skills are the abilities that agents possess that allow them to 
handle interactions coming into the call center. CCA matches the needs 
of the caller with the skills of all available agents and then routes the 
interaction to the agent most qualified to handle the interaction.

For example, if your call center agents handle callers who speak 
Spanish and French in addition to English, you might create two agent 
skills (“Speaks French” and “Speaks Spanish”). When a caller identifies 
themselves as a Spanish-speaker, CCA routes the caller to the 
available agent with the highest score for the “Speaks Spanish” skill.

12. Enter a rating between 1 and 100 for each skill in the Skill level 
rating column. 

The greater the rating you assign to the skill, the more you 
increase the likelihood that CCA routes interactions requiring this 
skill to this agent.

13. Click the Follow Me tab to access the Follow Me screen (Figure 
6-7).

Figure 6-7. Agents Screen: Follow Me Tab

Figure 6-7 Agents Screen: Follow Me Tab
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14. Click Activate Follow Me and use the information in Table 6-7 to 
complete the Follow Me options screen.

15. Click OK.

16. If you are logged in as a Network Administrator, then click the 
Applet Console Configuration tab to access the Applet Console 
Configuration screen (Figure 6-8). 

This tab contains settings for advanced troubleshooting. You can 
establish these settings at the company level (Options > 
Company > Applet Console Configuration) or for individual 
agents (Options > Agents > Applet Console Configuration), if 
you are logged in using a Network Administrator account. 

Table 6-7. Follow Me Fields and Descriptions

Field Description

Activate Follow Me When Follow Me is enabled, CCA forwards direct 
inbound calls (call made directly to an agent) to the 
Follow Me phone numbers or IP addresses (if the 
agent does not answer their primary extension). 

The Follow Me feature does not forward ACD calls 
(calls routed to an agent through a workgroup). 
CCA places these calls back into the queue for 
handling by the next available agent. 

Note: The Follow Me option must be enabled for 
both the agent and the agent’s project for call 
forwarding to occur. (For information on enabling 
the Follow Me option for a Phone Project, see 
“Enable Follow Me” on page 10-12.)

Define follow me 
numbers

Outside Phone: Select a country code from the 
list box, and enter the number that the system 
should forward the call to if the Agent does not 
answer their extension.

SIP: Enter the IP address that the call should be 
forwarded to. 

You must login as a Network Administrator to access the 
Applet Console Configuration tab.
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Figure 6-8. Agents Screen: Applet Console Configuration

Figure 6-8 Agents Screen: Applet Console Configuration

17. Use the information in Table 6-8 to complete the Applet Console 
Configuration screen.

Table 6-8. Applet Console Configuration Fields and Descriptions

Field Description

Close 
Connection

The CCA applications (AM, IM, SM, and so on) occasionally 
connect to the CCA Web server to determine if any messages 
(interactions, statistics updates, and so on) exist. 

If not checked, the applications continue to use the same 
HTTP connection to the Web server forever.

If checked, the connection is re-established every 60 requests.
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Disable 
Agents 
Cache

Check this box to change the way CCA normally works (not 
recommended). When checked, CCA downloads ALL 
information the application EACH time the user logs in. 

Note: This process can consume major resources on both the 
server and the user’s machine.

Unchecked, CCA downloads all information (about status, 
workgroups, users, URLs, outcomes, and so on) only when a 
user first logs into IM or SM. Thereafter, CCA keeps this 
information in memory until the user logs out. Then, CCA 
writes all the data to temporary files on the user’s hard drive. 

Therefore, the next time the user logs in, CCA only downloads 
new or changed information (like a new project or outcome) or 
deleted or edited information, rather than downloading 
everything.

Debug Level From the drop-down menu, select how CCA generates different 
levels of debug information. View debug information in a file, 
or Telnet window (see below), or the Java Console.

• Off: CCA will not generate any debug information.
• Debug: CCA generates most debugging information. 
• Info: CCA generates minimal debug information.
• Error: CCA generates only error information.
• Fatal: CCA generates only information about fatal errors.
• All: CCA generates all debug and error information.

Note: If you choose to send the information to the Java 
Console or Telnet, the All option will consume most of your 
memory and CPU.

Table 6-8. Applet Console Configuration Fields and Descriptions

Field Description
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Enable Telnet Check to view debug information in a Telnet window.

• Check the Enable Telnet check box.
• Click OK (or Apply).
• Start a Telnet session: “telnet <hostname> <port>”

For <hostname>, use the name of the machine where the 
client application is running. (For example, the name of 
the machine where Administration Manager is running.)

For <port>, use: 
48000 for Interaction Manager
48001 for Supervisor Manager
48002 for Administration Manager

Time to 
Login (in 
minutes)

From the drop-down menu, select how long IM waits before 
downloading all needed information from the database and 
logs into the IM server. 

Note: If login takes more than this time, IM automatically logs 
out.

Enable log 
file 
Log File Full 
Path

Check to allow writing debug information to a file. If checked, 
enter the log file name and path in the next text box.
• The path must include the filename. 
• Folders are created, if they do not exist. 
• A debug file writes to this path on every agent’s machine.

Ping Delay in 
Seconds

From the drop-down menu, select the time CCA applications 
(AM, IM, SM, and so on) wait before sending the next request 
to the Web server.

Occasionally, CCA applications connect to the CCA Web server 
to determine if messages (interactions, statistics updates, and 
so on) exist.

Disable wrap 
up timer

If checked, agents cannot see the wrap-up timer in IM. This 
may prevent flicker on some screens.

Disable 
elapsed 
(interaction) 
timer

If checked, the agent cannot see the interaction timer in IM. 
This may prevent flicker on some screens.

Table 6-8. Applet Console Configuration Fields and Descriptions

Field Description
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18. Click the Agents to Supervise tab to access the Agents to 
Supervise screen (Figure 6-9).

After creating a supervisor or an administrator account, use this 
tab to assign existing agents to supervise. 

When a supervisor has an assigned agent, the supervisor can 
interact (view, monitor, get agent statistics, and so on) with that 
agent using the SM application. 

Supervisors can only interact with agents assigned to them.

Disable 
Phone State 
timer

If checked, the agent cannot see the animated phone icon in 
IM’s Information Bar. The agent still sees the on-hook icon. 
This may prevent flicker on some screens.

Allow Multi 
ACD 
Interaction

If checked, CCA allows multiple ACD interactions.

URL Timeout 
in Seconds

From the drop-down menu, select how long the application 
(AM, IM, and so on) waits for a response from the Web server 
before killing the connection and re-sending the request.

You cannot assign more than 100 agents to the 
same supervisor.

Table 6-8. Applet Console Configuration Fields and Descriptions

Field Description
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Figure 6-9. Agents Screen: Agents to Supervise

Figure 6-9 Agents Screen: Agents to Supervise

19. Check the box next to each agent to assign to the supervisor.

20. Click the Administrator Configuration tab to access the 
Administrator Configuration screen (Figure 6-10) for limiting admin 
access to AM features.

Some changes to this screen are difficult to undo. Please 
consider changes carefully before you make them.

• Use this tab only when configuring an administrator.
• Both Network Administrators and System Administrators can 

access this tab. 
• The screen lists every navigation bar item in AM. If you 

uncheck an item, the administrator will not see that item the 
next time they login.

• Once an item is unchecked (and applied), you can only restore 
it by:
• Direct modification of the database.
• Deleting the administrator and re-creating the account.
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Figure 6-10. Agents Screen: Administrator Configuration

Figure 6-10 Agents Screen: Administrator Configuration

21. Click the Supervisors tab to access the Supervisors screen 
(Figure 6-11).

After creating an agent account, use this screen to assign them to 
a supervisor. (You can also assign agents to a supervisor when 
configuring an existing supervisor account, using the Agents to 
Supervise tab.)

The Supervisors tab only shows a supervisor if: 

• The supervisor has less than 100 agents, or 
• The supervisor has 100 agents, but is supervising the 

agent you are editing.

You cannot assign more than 100 agents to the same 
supervisor.
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Figure 6-11. Agents Screen: Supervisors

Figure 6-11 Agents Screen: Supervisors

22. Click the check box next to the name of each supervisor who can 
supervise this agent. (Agents can have multiple supervisors.)

23. Click the Workgroups tab to access the Workgroups screen 
(Figure 6-12).

24. Make the user a member of a specific workgroup by checking the 
corresponding check box. There is no limit to the number of 
workgroups to which a user can belong.
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Figure 6-12. Agents Screen: Workgroups

Figure 6-12 Agents Screen: Workgroups

25. Click the Unified Messaging tab (Figure 6-13) to identify how to 
store voicemails.

Storing voicemails as a wave file on the local drive allows 
fast access to voicemails by phone and provides greater 
flexibility. 

To store on a local drive, CCA uses an FTP Server to store 
the fields and the database to store the information and 
status of the voicemail.
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Figure 6-13. Unified Messaging Tab

Figure 6-13 Unified Messaging Tab

26. Select one of the following choices:

• Company Default: Sets the user to use the company default 
setting (set in the Unified Messaging tab of the Company 
screen). For more information, see “Unified Messaging” on 
page 3-48.

• Mail Server: Stores voicemails on the Network Email Server.

• Internal Voicemail: Stores voicemails locally.
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Finding an Agent
If your company employs many agents, use the agent search tool to 
quickly locate an agent from a list.

To search for an agent

1. Click Options > Agents. The Agents main screen (Figure 6-14) 
appears.

Figure 6-14. Agent List Screen

Figure 6-14 Agent List Screen

2. Click a column heading to search for items in that heading.

To see a list of all accounts 

1. Make sure the Find text box is blank.

2. Click the Go button.
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3. Sort the agent list by clicking on any column header.

To search on a column 

1. Select a column.

2. Click a letter or number (A - Z, 1 - 0).

3. Or select a column, enter a string or substring in the Find text 
box, and click the Go button.

To search with a wildcard 

1. Select a column.

2. Type % (percent) as a wildcard character. Enter a substring and 
wildcard in the Find text box. (For example, type Rog%, or 
%og%, or %er to match Roger.) 

Example 1: Display all agents (no supervisors or administrators).

1. Click the Permission column heading.

2. In the Find text box, enter agent.

3. Click the Go button. Only agents appear in the list.

Example 2: List everyone whose last name begins with “R”. 

1. Click the Last Name column heading.

2. From the alphabet (above the results), click the letter R.

3. All agents, supervisors, and administrators whose last name 
begins with R appears.

If your search returned more than one page of agents, use the 
controls at the bottom of the list to move from page to page. 

You cannot use wildcards when searching on the 
Permission column.
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Change how many agents to display on each page by clicking the 
number list box at the bottom of the screen.

Use the information in Table 6-9 to navigate this screen.

Table 6-9. Agent Screen Navigation

Click... To Display...

<<First Click to display the beginning of the agent list.

<Previous Click to display the previous group of agents (based on the 
maximum number to display).

Next> Click to display the next group of agents (based on the 
maximum number to display).

Last>> Click to display the end of the agent list.
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Deleting an Agent Account
Deleting departed or unused agents a frees space in the CCA database 
and ensures that an invalid agent account will not appear in AM 
screens.

Before deleting an agent account, ensure that CCA is not using the 
account by checking the following areas:

• Remove the agent account as the designated voicemail greeting 
for all workgroups. See the workgroup option: “Go to voicemail, 
play Agent greeting” on page 7-16.

• Remove the agent account assignment from all supervisors. See 
“Deleting an Agent Account” on page 6-31.

• Remove the agent account as the routing target for calls reaching 
a phone project. See the Agent option in “Adding Phone 
Interactions to a Project” on page 10-5.

• Remove the agent account as the routing target for a touch-tone 
menu selection. See the Extension option in “To create a 
Standard Menu” on page 8-11.

To delete an agent

1. Click Options > Agent > Profiles tab.

2. Find the Agent to delete (see “Finding an Agent” on page 6-28) 
and click it.

3. Click the Delete button. A delete confirmation message (Figure 
6-15) appears.

Figure 6-15. Delete Confirmation Message

Figure 6-15 Delete Confirmation Message

4. Click OK.
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7

Setting Up Workgroups 7

This chapter introduces CCA Workgroups and describes how to use AM 
to:

• Create workgroups
• Add agents to workgroups
• Add agent skills to a workgroup
• Specify the relative importance of each agent skill for the 

workgroup
• Set workgroup options
• Define workgroup overflow conditions and actions

What is a Workgroup?
A CCA Workgroup is a group of agents that do the same or similar job 
in the call center. In many cases, these workgroups parallel the 
company’s departments.

For example, you might create workgroups called “Sales,” “Technical 
Support,” and “Customer Service,” to represent the agents who work in 
those departments in the company.

The agents in a CCA workgroup do not need to be sitting in the same 
room or even in the same building. Because CCA agents can connect 
from any computer with an Internet connection, workgroup members 
can reside in various, distributed locations.

Workgroups also allow you to specify the agent skills that are 
important for agents in a workgroup to possess. By assigning weights 
(importance) to the agent skills in a workgroup, CCA can identify and 
route interactions to the agent most qualified to receive them.
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Finally, workgroups allow customer prioritization. For example, if a 
customer (identified as “Platinum”) enters a workgroup queue, you can 
make sure this caller reaches an agent before a “Standard” customer. 
See Chapter 12, “Customer Priority,” for information on assigning a 
priority level to each customer.

If No Workgroup Agents are Logged In

If CCA routes a phone interaction to a workgroup for which no agents 
are logged in, CCA lets the caller leave a message and changes the 
interaction type from “ACD Call” to “ACD Voicemail.”

Then, when an agent who is a member of the workgroup logs into the 
IM, CCA immediately sends the “ACD Voicemail” interaction to the 
agent for handling.

Call Flow Overview
Here is how CCA routes a call to an agent: 

1. A customer calls the call center.

2. CCA uses the number that the customer dialed to find the 
corresponding project.

3. The call center verifies that the company has a valid license.

4. CCA routes the call to a workgroup queue and waits for the ACD 
Server to assign the call to an agent.

5. When an agent is available, the CTI Server finds the agent’s 
extension. CCA dials the agent’s extension and the IM Server 
offers the interaction to the agent.

Not all call centers use workgroups. If you do not need to 
route customers to different groups of agents and you do 
not use customer prioritization, then you can route callers 
directly to specific agents and do not need to create 
workgroups for the call center.
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Creating a Workgroup
Before creating a workgroup, the following must exist:

• Agent accounts. (See “Creating Administrator, Agent, and 
Supervisor Accounts” on page 6-1.) 

• Defined agent skills to support the workgroup. (See “Creating 
an Agent Skills Library” on page 4-2).

To create a workgroup

1. Click Options > Workgroups > Add button. 

The Add Workgroups screen (Figure 7-1) opens to the Name tab.

Figure 7-1. Workgroups Screen: Name Tab

Figure 7-1 Workgroups Screen: Name Tab
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2. Using the information in Table 7-1, complete the field.

3. Click Apply.

Table 7-1. Workgroup Name Tab Fields and Descriptions

Field Description

Workgroup Name Enter the name for this Workgroup

Description Enter text describing how you will use this 
Workgroup, the common job function performed 
by Agents in this Workgroup, or the types of 
customers this Workgroup will handle.
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Adding and Removing Agents from Workgroups
Before adding agents to a workgroup, agent accounts must already 
exist. (For how to create agent accounts, see “Creating Administrator, 
Agent, and Supervisor Accounts” on page 6-1.)

To add and remove agents to and from a workgroup

1. Click Options > Workgroups.

2. Click the desired workgroup and then click Edit. The Workgroups 
screen appears.

3. Click the Agents tab to access the Workgroups screen, Agents tab 
(Figure 7-2).

Figure 7-2. Workgroups Screen: Agents Tab

Figure 7-2 Workgroups Screen: Agents Tab
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4. Click the check box next to an agent’s name to add the agent to 
the workgroup. (The same agent can belong to multiple 
workgroups.)

a. To add all agents to the workgroup, click the All button.

b. To remove all agents from the workgroup, click the Clear 
button.

5. Click Apply.
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Setting a Routing Association
Normally, CCA routes new interactions to the first available agent in 
the workgroup. However, you can use the Association tab to route a 
customer to the last agent who worked with that customer. 

1. Click Options > Workgroups.

2. Click the desired workgroup and click Edit. The Workgroup screen 
appears.

3. Click the Association tab (Figure 7-3).

Figure 7-3. Workgroups Screen: Association Tab

Figure 7-3 Workgroups Screen: Association Tab
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4. Using the information in Table 7-2, complete the Association 
screen.

Table 7-2. Workgroups Association Tab Fields and Descriptions

Field Description

Allow routing association 
to wait up to [ ]seconds

If checked, CCA tries to route the interaction to 
the agent who took the last interaction from this 
customer (the preferred Agent). If that agent 
is not available within the amount of time set, 
CCA routes the interaction to the first available 
agent in the workgroup.

CCA only tries to route to the preferred agent if: 
• The agent account was not deleted.
• The agent is still a member of the workgroup 

that received the interaction.
• The agent is logged in.

Force routing association 
even if Agent is logged 
out.

If checked, CCA tries to route the interaction to 
the preferred agent, even if the agent is logged 
out. CCA waits for the amount of time set in the 
Seconds text box (above). If the agent does not 
log in within that time, CCA routes the interaction 
to the next available agent.
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Assigning Skills to a Workgroup
CCA uses agent skills to identify and route callers to the agent most 
qualified to handle the interaction. Specify the importance of each skill 
in the workgroup so that customers reaching the workgroup are 
connected to the agent best qualified to handle the interaction.

When CCA routes a call requiring a specific agent skill to a workgroup, 
it chooses an agent based on a formula that considers both the agent’s 
score for the required skill and the weight you assign to that skill for 
agents in this workgroup.

To weigh the skills in a workgroup

1. Click Options > Workgroups. The Workgroups screen appears. 

2. Click the desired Workgroup and then click Edit. The Edit 
Workgroups screen opens.

3. Click the Skills tab (Figure 7-4).

Figure 7-4. Workgroups Screen: Skills Tab

Figure 7-4 Workgroups Screen: Skills Tab
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4. In the Skill-level Weight column, type the weight number 
(importance) to assign to each skill. Assign a weight of 0 to 
indicate that this skill should not be considered when selecting the 
best agent to receive the Interaction.

5. Click OK.

The combined weights for all skills in the workgroup 
must equal 100.
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Defining Workgroup Overflow Conditions
To make sure that interactions waiting too long for an agent are given 
immediate attention, define workgroup overflow conditions. CCA 
handles two workgroup overflow conditions:

• Interaction wait-time exceeded
• Number of queued interactions exceeded

CCA implements the overflow action you specify if a customer has 
been waiting in a workgroup queue longer than the maximum time or 
if the number of queued interactions exceeds the maximum.

You can configure all overflow conditions, parameters, and corrective 
actions. You can raise the customer's interaction priority or let the 
interaction go to a queue handled by both the original workgroup and 
the overflow workgroup, so that the interaction is answered in by the 
first available agent in either workgroup.

To set workgroup overflow conditions

1. Click Options > Workgroups. The Workgroups screen appears.

2. Click the desired Workgroup and then click Edit. The Edit 
Workgroups screen appears.

3. Click the Overflow tab to access the Overflow screen.

4. Check Enable Workgroup overflow. 

The screen refreshes to display the Workgroup Overflow screen 
(Figure 7-5).
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Figure 7-5. Workgroups Screen: Overflow Tab

Figure 7-5 Workgroups Screen: Overflow Tab

5. Using the information in Table 7-3, complete the fields on the 
Workgroup Overflow tab.

Table 7-3. Workgroup Overflow Fields and Descriptions

Field Description

Overflow occurs when 
an Interaction has been 
in queue for more than 
___ min.

Check to take the specified overflow action on the 
interaction in the front of the queue, if the 
interaction has been waiting longer than the time 
you specify.

Overflow occurs when 
the number of queued 
Interactions per Agent 
exceeds ___

Check to take the specified overflow action on the 
interaction in the front of the queue, if the ratio of 
interactions to agents exceeds the number you 
specify.

Use Max. Calls per 
Agent

Check this box and enter the maximum calls Agents 
can accept. You do not need to restart the ACD 
Server to enable this change.
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6. Click OK.

Overflow occurs when 
the number of queued 
Interactions exceeds 
___

Check to take the specified overflow action on the 
interaction in the front of the queue when the 
number of interactions in the queue exceeds the 
number you specify.

Increment Interaction 
priority by ___

Choose to increment the interaction’s priority** 
setting by the specified number, when the specified 
Overflow occurs condition is met.

Transfer Interaction to 
Workgroup ___ with a 
priority of ____

Choose to move the interaction to the specified 
workgroup and adjust the interaction’s priority** 
when the specified overflow occurs condition is 
met.

Note: A phone interaction transferred to an 
overflow workgroup does not hear the workgroup 
prompts for the overflow workgroup. (See “Select 
Prompts for this workgroup” on page 7-17 for 
information on Workgroup prompts.)

Route to Project Menu Route the call to a project menu (phone menu). 
(See Chapter 8, “Creating Project Menus” for more 
information.)

** The IM Information Bar displays the priority of the transferred interaction 
as selected when defining the workgroup overflow condition.

Table 7-3. Workgroup Overflow Fields and Descriptions

Field Description
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Setting Workgroup Options
1. Click Options > Workgroups. The Workgroups screen appears.

2. Click the desired Workgroup and then click Edit. The Edit 
Workgroups screen appears.

3. Click the Options tab (Figure 7-6).

Figure 7-6. Workgroups Screen: Options Tab

Figure 7-6 Workgroups Screen: Options Tab

4. Using the information in Table 7-4, complete the fields in the 
Workgroup Options tab.
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Table 7-4 Workgroups Options Tab Fields and Descriptions

Option Description

Initial Wait Time Type the number of minutes it takes an agent to complete a typical 
interaction. 

CCA uses this number as a baseline to begin calculating the average 
wait time to report to callers. The actual wait time reported to callers 
reflects the conditions in the workgroup and may be different than 
the wait time you enter here. CCA uses actual historical wait times to 
calculate average wait time, after new interactions enter the 
workgroup.

Play estimated wait time Check to inform the customer (phone or Web chat) of their estimated 
wait time. If the customer’s estimated wait time is greater than 99 
minutes, CCA does not inform the customer of the wait time.

Note: If you change the setting for Play estimated wait time, you 
must re-create your Chat Request form for the changes to take effect 
in your chat project. (See “Chat Request Forms” on page 10-64 for 
information on re-creating your Chat Request form.)

Allow customer to request a 
callback

Check to let the caller request a callback, if agents are busy. 

Checking this box causes the system to play the prompt 
acdcallback.wav to the customer and allows the customer to 
enter a number where they can be reached. (See “Workgroup Option 
Prompts” on page 5-22.)

Notes: 
• If the customer enters a callback number that is different than the 

number that originated the call, CCA uses the customer-supplied 
number to perform the callback and to look up the customer’s 
contact information during the callback interaction.

• For agents to reschedule a callback, you must also require 
outcomes. (See “Outcomes and Rescheduled Callbacks” on page 
4-12.)

Always Use This Country 
Code

If not checked, CCA prompts the customer for their country code. 

If checked, CCA calls the customer back using the country code 
specified here.

CCA_AM.book  Page 15  Wednesday, July 26, 2006  2:55 PM



7-16 CallCenterAnywhereTM Administration Manager

Allow customer to leave a 
voicemail

Check to allow a caller waiting in the queue to leave a voicemail 
message for the next available agent. CCA prompts the caller to enter 
the following prompts (played in this order):

1. acdmenu.wav
2. Greeting for the selected agent
3. acdvoicemail.wav

See “Workgroup Option Prompts” on page 5-22 for more information 
about the acdmenu.wav and acdvoicemail.wav prompts.

Allow Customer to Route to 
Project Menu

Check to allow a caller waiting in queue to select the option to be 
routed to a new project menu. CCA automatically plays a default 
prompt (acdnewmenu.wav). You may also choose another prompt 
from the Select Prompt list.

Stay in the Queue If selected, the caller remains in the queue until an agent logs in and 
becomes available. 

Disconnect If selected, and no agent is logged in, the caller is disconnected 
immediately. 

Go to voicemail, play Agent 
greeting

Tells CCA to select an agent with a recorded greeting. CCA sends the 
call to the voicemail and plays the agent’s greeting followed by 
acdvoicemail.wav (“press one to leave a voicemail message”). 
See “Allow customer to leave a voicemail” on page 7-16.

Route to Menu Routes the caller to the menu you select from the drop-down list. 
(Use this, after meeting specific thresholds, to discontinue answering 
calls and give new callers an intercept message. For more 
information, see Chapter 8, “Creating Project Menus”.)

Do not play ACD intro If checked, CCA does not play the prompt under “Select Prompts for 
this Workgroup > Intro list box” (bottom of the Options tab screen) if 
no agents are logged in. (If you know that no agents are available 
and you want to route the call to Disconnect, Go to Voicemail, or 
Route to Menu, you probably do not want to play an ACD intro 
prompt telling the customer to wait for an agent.) 

Table 7-4 Workgroups Options Tab Fields and Descriptions

Option Description
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Notes for “Select Prompts for this workgroup” 

• The “Select Prompts for this workgroup” list box only shows 
custom prompts created in your “current” login language. For 
example, if you: 

• Select English in the login page, login, and create a custom 
prompt, and then, 

• Logout, select Spanish in the login page, and login.

You won’t see your custom prompts, because you created 
them while you were logged in using English, and you are now 
logged in using Spanish.

Select Prompts for this 
workgroup

Workgroups can play several types of prompts. For each type, select 
the System Default or a custom prompt. (See “Creating a Company 
Prompt Library” on page 4-16.)

Intro: The initial greeting CCA plays to the caller when entering the 
workgroup. Choose System Default to play the acdintro prompt 
file (see page 5-22).

Hold: The prompt CCA plays to a caller who just entered the queue 
for the first time or who has returned to the queue after being unable 
to reach an agent. (The agent was logged out or did not answer). 
CCA plays the Hold prompt after the Music prompt ends. Choose 
System Default to play the acdrepeat prompt file (see page 5-22).

Whisper: The prompt CCA plays to an agent right after the agent 
accepts an ACD call and while working off-hook. The customer can’t 
hear the prompt. 

Ring: The prompt CCA plays when the system is connecting the 
caller to an available agent. Choose System Default to play the 
acdring prompt file (see page 5-22).

Music: CCA plays the Music prompt right after the Intro prompt, 
while the caller is waiting to be connected to an agent. When the 
Music prompt finishes playing, CCA plays the Hold prompt. The 
Music and Hold prompts repeat until an agent becomes available. 
Choose System Default to play the music prompt file (see page 
5-22).

Table 7-4 Workgroups Options Tab Fields and Descriptions

Option Description
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• The order in which CCA plays workgroup prompts can be 
affected by the “Allow customer to leave a voicemail” and 
“Allow customer to request a callback” features (described 
above). 

5. Click Apply.
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Setting Workgroup Service Levels
A Workgroup Service Level lets a supervisor monitor whether online 
and offline interactions are being accepted at a specific rate. For 
example, the managers of a call center may want:

• 50% of all online interactions to be accepted by an agent in 
one minute or less. 

• 50% of all offline interactions to be accepted by an agent in 
three minutes or less.

In the example in Figure 7-7, the Online Service Level is 60 seconds 
and the OffLine Service Level is 180 seconds. 

Therefore, when a supervisor looks at the Service Level 
Workgroups screen, the supervisor sees the percentage of online 
and offline interactions (since 12:00:00 AM today) meeting those 
requirements. 

Figure 7-7. Example Service Level Workgroups Monitoring

Figure 7-7 Example Service Level Workgroups Monitoring

34 of all online interactions since 
12:00 am today were accepted by 
an agent in 30 seconds or less

17 of all offline interactions since 
12:00 am today were accepted by an 
agent in 180 seconds or less

In this example,
- Online Service Level = 30 seconds
- Offline Service Level = 180 seconds

6 agents are currently available

21 agents are currently logged in

Since 12:00 am today, 
no interaction waited in 
the queue more than 
15 seconds
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For Service Levels, online and offline interactions are defined as:

• Online: ACD Phone, ACD Voicemail, ACD Callback, Web 
Callback, and Chat

• Offline: ACD Fax, ACD Email

When calculating service level, time:

• Starts when an interaction reaches the call center. 
• Stops when an agent accepts the interaction. 

Therefore, the Service Level Time includes:

• The time a customer spends waiting in a queue 
and 

• The time the customer spends listening to prompts 

To set service levels for a workgroup

1. Select Options > Workgroups > Service Level.

2. From the list box menus, select a service level for online and 
offline interactions. 

Figure 7-8. Workgroups Screen: Service Level Tab

Figure 7-8 Workgroups Screen: Service Level Tab

3. Click OK (or Apply).
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Deleting a Workgroup
Delete a workgroup when it is no longer needed. The deleted 
workgroup is no longer available to receive interactions, but it remains 
available for reporting on in AM Reports.

Before deleting a workgroup, ensure that the workgroup is not in use 
by checking these areas:

• Remove the workgroup as the routing destination for incoming 
interactions in all CCA Projects. See “Creating a Project Definition” 
on page 10-1.

• Remove the workgroup as a touch-tone option in all project 
menus. See the Workgroup option in the section “To create a 
Standard Menu” on page 8-11.

To delete a workgroup

1. Click Options > Workgroups.

2. Click the Workgroup to remove.

3. Click the Delete button. A confirmation message (Figure 7-9) 
appears.

Figure 7-9. Delete Confirmation Message

Figure 7-9 . Delete Confirmation Message

4. Click OK.
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8

Creating Project Menus 8

A basic call center does not require project menus (phone menus). 
CCA can route callers to agents using a simple project, which does not 
require the caller to make any choices from a menu. However, project 
menus are useful to:

• Give the caller choices in navigating the call center. 
• Complete some pre-work before delivering a call to an agent. 
• Have an interaction handled completely without the need for 

agent intervention.

Types of Menus
Administration Manager uses five types of menus for adding a new 
Project Menu. 

To access project menu types

1. Click Options > Project Menus > Add button. 

The Add Project Menus screen (Figure 8-1) appears.
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Figure 8-1. Standard Menu

Figure 8-1 Standard Menu

Table 8-1 shows each menu type and its purpose. Most call centers use 
all (or nearly all) of the menu types to accomplish their overall goal. 

Table 8-1. Menu Types and Descriptions

Menu Type Description

Standard For general purpose call routing: 
• CCA can route calls to many different locations (including 

agents, workgroups, projects, other menus, and so on).
• Supports using variables and a “case” like data structure.

Get Digits Allows CCA to capture data a caller enters in a variable. This 
menu supports the same routing features and “case” like 
data structure as a Standard menu.
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Think of menu types as building blocks for constructing features or 
routing solutions in the call center. 

Table 8-2 shows an example where the goal is to give the customer 
their account balance. Notice that

• Each menu only accomplishes a small part of the overall goal. 

• This design lets you combine menus to create a wide variety of 
very sophisticated features.

Play Value CCA plays a prompt or a value (the contents of a variable) to 
the caller. This menu supports the same routing features and 
“case” like data structure as a Standard menu.

Note: A Play Value menu can correctly read negative 
numbers.

SQL Query CCA runs an SQL query against almost any database. The 
SQL query can include project menu variables. CCA can 
capture the SQL result table in a project menu variable. 
This menu supports the same routing features and “case” like 
data structure as a Standard menu.

Record CCA records a caller for the time you specify. Later, you can 
listen to the recording. This menu supports the same routing 
features and “case” like data structure as a Standard menu.

Table 8-2. Customer Action and Call Center Response

Customer Call Center

A customer calls the call 
center.

The customer calls a phone number associated 
with a project. The project routes the call to a Play 
Value menu.

The caller is prompted 
to enter their account 
number.

The Play Value menu plays a prompt: “Welcome to 
the call center. Please enter your account number” 
and routes the call to a Get Digits menu.

The caller enters their 
account number.

The Get Digits menu captures the customer’s 
account number in a variable and routes it to an 
SQL Query menu.

Table 8-1. Menu Types and Descriptions

Menu Type Description
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Using Variables in Menus
Use Project Menu variables to:

• Share values between project menus.
• Trap values that are entered by customers in a menu.
• Add values to, and trap values coming back from, an SQL 

query.

AM uses system-variables and user-defined variables. You can use 
both in every type of menu. When using variables, CCA passes the 
information (such as a user's account number) as a URL parameter to 
the IM program.

User-Defined Variables

User-defined variables can store values, capture customer entries, and 
share values between menus.

To create user-defined variables

In any AM menu type, you can create and access user-defined 
variables. Every menu type provides several locations to enter the 
name of a variable. (This chapter explains all of these locations.) 

[No action] The SQL Query menu queries a database, using the 
customer’s account number, to find the customer’s 
account balance. The customer’s balance is stored 
in a variable and the call is routed to a Play Value 
menu.

[No action] The Play Value menu plays a prompt: “Your current 
balance is” and routes the call to another Play 
Value menu. 

[No action] The last Play Value menu reads the value of the 
account balance variable to the customer. For 
example, “four hundred and twenty three dollars.” 

Table 8-2. Customer Action and Call Center Response
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Entering the variable name in one of the many locations. CCA does not 
require any other action to instantiate or initialize the variable.

For example, when creating a Get Digits menu:

1. Click Options, Project Menus, Add button. 

The Add Project Menus screen (Figure 8-2) appears.

Figure 8-2. Get Digits Menu - Store User Input in Variable Field

Figure 8-2 Get Digits Menu - Store User Input in Variable Field

2. In the Store user input in variable field, enter a variable with 
the following requirements:

a. All variable names must begin with a dollar ($) character. For 
example: 

$custPhone
$projectName
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b. Variable names are case sensitive. For example, $custPhone 
is not the same variable as $CustPhone.

c. Variable Types: 

i. Variables can be handled as either integers or strings.

ii. For CCA to treat a variable as a string, you must wrap it in 
single quotes.

For example, CCA treats ‘$AccNum’ as string and $AccNum as 
an integer. 

d. Variable Scope: 

i. The scope of a user-defined variable is the interaction. 
When CCA creates a user-defined variable during a call, 
the variable continues to exist for the life of the call. When 
the call ends, CCA erases the variable from memory. 

ii. CCA can share user-defined variable among menus, but 
only for the same interaction.

Example: If CCA routes a call from one menu to another, a 
variable created in the first menu is available to the second 
menu. 

Example: Two calls reach the call center at the same time. 
CCA routes both calls to a project menu that creates a 
variable called $Account_Number. Since there are two 
interactions, CCA keeps the value of $Account_Number for 
the first call completely separate from the value of 
$Account_Number for the second call.

e. Length of a Variable Name: 

Theoretically, variable names can be any length, but because 
they can be passed between data systems, TAW recommends 
keeping variable names reasonably short. For example, when 
including variables in SQL queries, know that databases vary 
on the maximum allowable length of a query. 

System-Defined Variables

In addition to creating user-defined variables, there are also many 
system-defined variables in which CCA automatically sets the value. 
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Table 8-3 shows the available system-defined variables and their 
descriptions.

Table 8-3. System-Defined Variables and Descriptions

System Variables Description

$ACD_PRIORITY Initially, CCA sets this variable to the priority of the 
project (Options > Projects > Phone tab > Priority 
drop-down menu). 

After enabling Customer Priority Routing (Options > 
Projects > Phone tab > Options subtab > Enable 
Customer Priority Routing check box), CCA can 
change the value of this variable to the customer 
priority. See “Assigning Priority Levels to Customers” 
on page 12-1.

$ANI The current incoming phone number.

$CID If the project prompts the customer for a customer 
ID (Options > Projects > Phone tab > “Use Prompt 
to Ask for Customer ID” check box), CCA stores the 
value the customer enters in the $CID variable. 

If the project does not enable the “Use Prompt to 
Ask for Customer ID” check box, the $CID variable 
remain empty.

$CONVERTDATE This is a special system variable for converting a 
date (in the format YYYYMMDD) to a POSIX style 
format (number of seconds since January 1st, 
1970). 

For example: To convert the date “19900505” (May 
5th, 1990) to the POSIX value for that date, enter 
the following (in any project menu location where 
you can set a variable):

$CONVERTDATE = 19900505

The next time CCA access the value of 
$CONVERTDATE, it contains the POSIX equivalent of 
May 5th, 1990.

$CURRENTTIME Stores the current time (in the format HHMM).

$DATE The current POSIX time in seconds (number of 
seconds since January 1st, 1970).
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Operators

Use numeric and string operators to manipulate variables in a Project 
Menu. 

$DAYOFWEEK The day of the week (where 1 = Sunday, 2 = 
Monday,..., 7 = Saturday).

$DNIS The phone number the caller dialed.

$HOURS The hours part of the time when the current 
interaction began.

$INTDATE The date when the current interaction began. 
$INTDATE uses a POSIX time stamp format (the 
number of seconds since Midnight, January 1, 1970, 
UTC/GMT).

$INTID The ID of the current interaction.

$MINUTES The minutes part of the time when the current 
interaction began.

$PREDCID The Predictive Contact ID of the current predictive 
call.

$SECONDS The seconds part of the time when the current 
interaction began.

$SQLSTATUS The status of the last query executed from a SQL 
Query Project Menu. Possible values are:

FAIL
NOROWS
PENDING
SUCCESS

See “Creating SQL Query Menus” on page 8-35.

$TODAYSDATE Stores the current date (in the format: YYYYMMDD).

Table 8-3. System-Defined Variables and Descriptions

System Variables Description
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Numeric and String Operators

Use numeric and string operators in any menu location except the 
Case tab (described in “The Case Tab” on page 8-23). Table 8-4 
provides numeric operators and their descriptions.

.

Table 8-5 provides string operators and their descriptions.

Comparison Operators

Use comparison operators (also called logical or test operators) to 
test conditions, such as: “is variable A equal to variable B?” 

• One of the most common errors is to confuse the assignment 
operator “=” with the comparison operator “==”. They are similar 
looking, but have completely different meanings. See Table 8-6 for 
a comparison.

Table 8-4. Numeric Operators and Descriptions

Numeric Operators Description

+ Add values.

- Subtract values.

* Multiply values.

/ Divide values.

Table 8-5. String Operators and Descriptions

String Operators Description

+ Concatenate strings.
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Table 8-7 shows several comparison operators and provides a 
description for each.

Creating Standard Menus
Standard menus allow callers to navigate the call center by pressing 
keys on their phone. Standard menus also allow routing callers based 
on predefined decisions.

A standard menu has three parts:

1. A prompt (recorded message) describes the valid touch-tone 
menu choices.

2. The tones the customer can enter.
3. The CCA response to each valid tone.

A standard menu can route calls to many destinations, including:

• A workgroup for handling by the next available agent.
• A specific agent.
• A company directory based on agent last names.
• Other menus with additional options.

Table 8-6. Example Comparing an Assignment Operator and a 
Comparison Operator

Operator Meaning

$Balance = 5 Assign the variable “$Balance” the value of 5.

$Balance==5 Compare the value of $Balance to 5. This is similar to 
asking the question: is the value of $Balance equal to 
5? 

Table 8-7. Comparison Operators and Descriptions

Comparison Operators Description

== Equal to

!= Not equal

> Greater than

< Less than

CCA_AM.book  Page 10  Wednesday, July 26, 2006  2:55 PM



Creating Project Menus 8-11

To create a Standard Menu

1. Click Options > Project Menus > Add button. 

The Add Project Menus screen (Figure 8-3) opens to the Menus 
tab.

2. In the Menu tab, make sure to select Standard.

Figure 8-3. Add Project Menus - Select Standard

Figure 8-3 Add Project Menus - Select Standard

3. Use Table 8-8 to complete the fields.

Table 8-8. Add Project Menus Fields and Descriptions

Field Description

Menu Name Type a name for the menu.

Description Type a description for the menu. (Describe the 
menu’s function or purpose.)
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4. Click the Touch-Tones tab (Figure 8-4) to associate a customer 
key-press with a routing action.

a. Select one of the buttons on the left side of the tab (such as 
buttons 1-9, “*”, “#”, and so on).

b. Then, select one of the radio buttons on the right side of the 
tab. 

For example, click button 9 (on the left side), then click the 
Disconnect button on the right side. Then, if the user presses 
9 on their phone, they are disconnected.

c. Click the Timeout Action button to specify an action to take if 
the caller doesn’t make a choice from the menu.

d. CCA takes the Timeout Action after the menu repeats a specific 
number of times. (See the “Number of retries before 
disconnect/timeout” field in Table 8-8.)

Prompt From the drop-down menu, select the prompt that 
describes the options offered in this menu. 

If the correct prompt does not appear, record it and 
add it to the Prompt Library. (See “Creating a 
Custom Prompt” on page 5-3.)

Allow caller to select 
extension

Check to allow the caller to enter an agent’s 
extension.

For the customer to enter an agent’s extension 
without listening to the entire menu, also check the 
Allow Type-ahead check box (see next field). 

Allow type-ahead Check to allow the caller to choose menu options 
before the prompt completes playing.

Number of retries before 
disconnect/timeout

Type the number of times to play the menu before 
disconnecting the caller or jumping to the Timeout 
Action button (see next field).

Wait Time before 
replaying menu

Type the number of seconds to wait before 
replaying the menu, if the caller does not make a 
choice.

Table 8-8. Add Project Menus Fields and Descriptions

Field Description

CCA_AM.book  Page 12  Wednesday, July 26, 2006  2:55 PM



Creating Project Menus 8-13

Figure 8-4. Add Project Menus: Touch-Tones Tab

Figure 8-4 Add Project Menus - Touch-Tones Tab

5. Click the Default Link button to take an action (after a prompt, if 
any, plays) without giving the caller an opportunity to select from a 
menu.

6. Use the information in Table 8-9 to set actions for all of the allowed 
key presses.
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The action you select occurs as soon as the caller reaches this 
menu.

Table 8-9. Tone/Event Routs Caller Selection and Description

Tone/Event 
Routes Caller to Description

Invalid Entry Click to play the System Prompt invalid.wav (“Invalid 
Entry”).

Workgroup Click to route the caller to the workgroup specified in the 
drop-down menu. Then, click either: 

Route to Workgroup extension: Transfers the call 
to the best available agent. If no agent is available, 
CCA places the caller in a queue.

Route to Workgroup Fax: In this case, the 
customer is waiting to send a fax to the call center. 
The menu prompt may say something like: “Press 3 
to send a fax.” 

Now, when the user presses 3 (for example), the 
customer hears the fax tone and can send a fax. CCA 
routes the fax to the best available agent. If no agent 
is available, CCA puts the fax into a queue. Now, 
when an agent accepts the fax interaction, the agent 
receives an email with the fax as a TIFF attachment. 

Script From the drop-down menu, choose a script to display to 
the agent when CCA routes the call to them. (See 
“Creating a URL Library” on page 4-4.)

FAQ From the drop-down menu, choose an FAQ to display to 
the agent when CCA routes the call to them. (See 
“Creating a URL Library” on page 4-4.)
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Extension Click to route the caller to the agent specified in the 
drop-down box. Then, click either: 

Route to Agent Extension to route a voice call to 
the agent, or 

Route to Agent Fax to route a fax interaction to 
the agent. In this case, the customer sends a fax to a 
specific agent. The selected agent immediately 
receives an email, with the fax as a TIFF attachment. 

Route to IVR Server Click to transfer the caller to a custom Interactive Voice 
Response system. Type the name of the IVR Server in the 
adjacent text box. 

Note: This option appears only when CCA is configured 
to support a custom IVR Server.

Menu Check to transfer the caller to another project menu, 
select a project menu (from the drop-down list), and 
select a language (from the Select Language drop-down 
list).

Note: If routing the customer to a menu in the same 
language as the previous menu, choose Current 
Language from the Select Language drop-down menu. If 
routing the customer to a menu in a different language, 
choose that language from the Select Language 
drop-down menu. 

Click the plus (+) button to quickly add a new project 
menu without leaving the Touch-Tones tab.

1. Click the plus (+) icon. A message box appears.

2. In the Menu Name text box, type the name of a new 
project menu and click the Add button. AM creates a 
new project menu. CCA automatically selects the new 
project menu in the Menu list box and gives it the 
following default values:

• Prompt = None
• Menu Type = Standard
• Number of Retries Before Disconnect = 3
• Wait Time Before Disconnecting = 10 seconds

Table 8-9. Tone/Event Routs Caller Selection and Description

Tone/Event 
Routes Caller to Description
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Save your changes and then click the Go button to 
quickly switch from one project menu to another. 

1. Select a menu from the Menu drop-down menu.

2. Click the Go button. A confirmation message appears.

3. Click OK. AM then:

• Closes the current Project Menu.
• Opens the Project Menu you select.

Disconnect Click to disconnect the caller.

Company Directory Click to play the prompt entername.wav (“Please enter 
the last name of the person you wish to reach using your 
touch-tone telephone keypad...”) and allow the caller to 
navigate to an agent by pressing the first three letters of 
the agent’s last name.

Mailbox Manager Click to play the prompt entermailbox.wav (“Please 
enter your mailbox number, followed by the pound key”) 
and allow call center agents to access their non-ACD 
voicemail messages from a remote telephone and to set 
up their voicemail greetings. 

Notes: 
• For agents to access the Mailbox Manager remotely:

•  The agent’s username and password (Options > 
Agents > Profile) must consist only of numbers. 
For example, the agent’s username could be 
“1234” and their password could be “5678.” 

•  A POP3 Server must be configured for the agent 
(Options > Agents > Email > Defined POP3 
Server).

•  The project must use a Project Menu (phone 
menu) and the phone menu must have a 
touch-tone key that routes to the Mailbox Manager 
radio button.

• You can also allow users to access their ACD voicemail 
messages. See “Login to ACD Voicemail” on page 8-17.

• To stop customers from accessing the Mailbox Manager 
feature, leave it out of the recorded prompt. Tell agents 
that they can enter a key to access their voicemail 
messages and that the feature is not described as an 
option in the recorded prompt.

Table 8-9. Tone/Event Routs Caller Selection and Description

Tone/Event 
Routes Caller to Description
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Agent Voicemail Click this button only when creating a menu that plays 
before CCA routes the customer to an agent’s voicemail. 

For Example:

1. The customer calls a phone number associated with a 
project (Projects > Phone > Project Phone Number). 

2. CCA routes the customer to an agent, but the agent is 
not available. CCA then routes the customer to the 
agent’s voicemail. 

3. Before the customer leaves a voicemail, CCA plays a 
menu (Projects > Phone > Options subtab > Menu 
Played Before Voicemail).

4. One of the key presses in the menu allows the 
customer to leave a voicemail for the agent they are 
trying to reach. (Phone Menus > Touch-Tones > Agent 
Voicemail).

If you use the Agent Voicemail radio button in a menu 
that CCA does not play for a customer before they leave a 
voicemail, CCA will not know which agent voicemail to 
use.

Login to ACD 
Voicemail

Click this option so users can dial into the system and 
retrieve their ACD Voicemail. 
• Users dial the number you provide.
• The project menu routes the user to the “Login to ACD 

Voicemail” option.
• CCA plays a prompt giving the users several options, 

one of which is to listen to their ACD voicemails. 

Notes:
• Use this option for users who want to retrieve their ACD 

voicemails from a phone. (The user is typically not 
logged into IM.)

• The agent’s username and password (Options > Agents 
> Profile) must consist only of numbers. For example, 
the agent’s username could be “1234” and their 
password could be “5678.” 

• You can also allow users to access their non-ACD 
voicemail messages. See “Mailbox Manager” on page 
8-16.

Table 8-9. Tone/Event Routs Caller Selection and Description

Tone/Event 
Routes Caller to Description
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7. Click OK.

Campaign Click this feature to route a call to a Campaign and then 
select a campaign from the drop-down menu. (See 
Campaigns in chapter “Campaigns” on page 9-1.)

External Transfer Click to transfer the call to the specified external (not an 
internal extension) phone number. From the drop-down 
menu, select the country. Type the phone number in the 
adjacent box.

Note: CCA does not track calls transferred to an external 
number and the call will not appear in reports.

Supervised by From the drop-down menu, select a supervisor CCA will 
automatically call when an agent or a menu makes an 
external transfer.

Note: CCA calls the supervisor and joins to a conference 
only if the supervisor’s phone in on hook. If the 
supervisor is not available (or not on hook), you can 
control the call manually, using Hang Up, Join, or CRM.

Change Project Click to route the caller to the specified project. From the 
drop-down menu, select the project.

And Play Prompt Click and then, from the drop-down menu, select a 
prompt to play CCA takes a routing action. 

For example, if you selected the “Change Project” button, 
use the “And Play Prompt” to tell users “I’m transferring 
you to the sales group” before CCA routes the call.

Set Variable Use the Set Variable control to do the following before 
CCA takes a routing action:
1. Create variables.

2. Set the value of new and existing variables. 

3. Test the value of variables. 

Table 8-9. Tone/Event Routs Caller Selection and Description

Tone/Event 
Routes Caller to Description
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To use the Set Variable Control

Use the Set Variable Control to create variables, assign values to 
variables, and test variables. 

• Create as many “entries” as you want in the Set Variable 
control. CCA makes all of the assignments and tests before 
taking any routing action. 

• Use all operators in the Set Variable control (string, numeric, 
and comparison). See page 8-8. 

• Create equations and do math operations using new variables, 
existing variables, and system variables. 

Example 1: Create a variable and set its value to 5

1. Click the + (plus) icon. 

2. In the Set Variable dialog box (Figure 8-5):

a. In the Variable Name text box, type $tmp. 

b. Click the Value button. 

c. In the Value text box, type 5.

d. Click OK.

Figure 8-5. Example 1: Set Variable

Figure 8-5 Example 1: Set Variable

3. Follow the same steps to assign a string value to the variable 
$tmp.

Example 2: Increment a pre-existing variable

In this example, assume that a pre-existing integer variable ($tmp) 
was created in some other menu. 
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1. Click the + (plus) icon. 

2. In the Set Variable dialog box (Figure 8-6):

Figure 8-6. Example 2: Increment a Pre-Existing Variable

Figure 8-6 Example 2: Increment a Pre-Existing Variable

a. In the Variable Name text box, type $tmp.

b. Click the Value button.

c. In the Value text box, enter $tmp + 1.

d. Click OK.

Example 3: Assign a Company Prompt ID to a variable

In some situations (such as when constructing a menu system), it is 
convenient to store the ID number of a company prompt in a variable. 
After the ID of a company prompt is in a variable, route CCA to a Play 
Value menu and play the prompt to the caller.

In this example, assume that a company prompt called “Invalid Entry” 
already exists. 

1. In the Set Variable control, click the + (plus) icon. 

2. In the Set Variable dialog box (Figure 8-7):

You cannot store the ID of a System Prompt in a variable.
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Figure 8-7. Example 3: Assign a Company Prompt ID to a Variable

Figure 8-7 Example 3: Assign a Company Prompt ID to a Variable

a. In the Variable Name text box, type $invalid.

b. Click the Play Prompt radio button.

c. Select Invalid Entry from the Play Prompt list box.

d. Click OK.

After assigning the ID of a company prompt to a variable, play the 
prompt to a caller by routing CCA to a Play Value menu and 
entering the variable ($invalid) in the Add Play Value dialog box 
(Figure 8-8).

Figure 8-8. Play a Prompt or Value

Figure 8-8 Play a Prompt or Value

Example: Routing the Customer to a Menu in a Different Language

In this example, customers reaching the call center hear a prompt 
allowing them to continue in English or Spanish. 

If the customer chooses to continue in English, CCA routes the 
customer to an English-speaking workgroup. 
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If the customer chooses to continue in Spanish, CCA routes the 
customer to an Spanish-speaking Workgroup.

1. Create a Spanish-speaking workgroup and an English-speaking 
workgroup.

2. Create a company prompt that plays “Press 1 for English. 
Seleccionar dos para Espanol.”

3. Create a Spanish Project Menu:

a. In the Menu tab, click the Standard button.

b. In the Touch Tone tab:

i. Click the Default Link button.

ii. Then, click the Workgroup button.

iii. From the drop-down menu, select the Spanish 
Workgroup.

Now, when CCA routes any customer to your Spanish menu, CCA 
immediately transfers the customer to the Spanish workgroup.

4. Create an English menu:

a. In the Menu tab:

i. From the Prompt drop-down menu, select the company 
prompt.

ii. Click the Standard button.

b. In the Touch Tone tab:

i. Click button 1, click the Workgroup button, and select 
English Workgroup from the drop-down box. (Now, when 
a customer presses 1, CCA immediately transfers the 
customer to the English Workgroup.)

ii. Click button 2, click the Menu button, and select the 
Spanish Menu from the drop-down menu.

iii. From the Select Language drop-down menu, select 
Spanish. (Now, when a customer presses 2, CCA 
immediately transfers the customer to the Spanish 
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Workgroup. All further prompts that the customer hears 
are in Spanish. 

5. Create a project and route phone calls to an English Menu. 

a. Select Options > Projects > Phone tab.

b. Click the Menu button.

c. Then, from the drop-down menu, select English. 

CCA routes callers to the project to the English menu. The 
English menu provides the choice of continuing in English or 
Spanish.

The Case Tab

Use the Touch-Tones tab identify a routing action after a customer 
presses a key on their phone. Use the Case sub-tab to identify a 
routing action based on the value of one or more variables.

If (condition) then (take a routing action)

The Case tab is named after the case (or “switch”) statement that is 
common to many programming languages. However, in AM, this tab 
works more like an “If ... Then ... Else...” statement.

Access to variables: 

The Case tab allows access to all system variables (see 
“System-Defined Variables” on page 8-6) and all user-defined 
variables for the current interaction (see “d.Variable Scope:” on 
page 8-6.)

When routing callers to a menu in another language, make sure to 
record System Prompts for all Project Options and all 
Workgroup Options in that language.

After selecting a menu in a specific language, and no prompts exist 
in that language, callers hear silence when they reach the menu. 
(See “Creating a Custom Prompt” on page 5-3 for information on 
creating prompts.)
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Number of conditions: 

Create as many conditions/tests as desired. CCA executes the first 
true condition.

Default routing action: 

Create a default routing action (using the Other button). CCA 
takes this routing action if none of the conditions are true.

Use of operators: 

Use only the comparison (logical) operators for the conditions you 
create. See “Comparison Operators” on page 8-9. 

Do not use any of the numeric or string operators in the Case tab. 
CCA does not use the Case tab for arithmetic operations like:

$variable1 * $variable2

or for setting the value of a variable:

$variable1 = 5

CCA uses the Case tab only for testing or comparing values:

Is today Sunday? 
$DAYOFWEEK == 1
($DAYOFWEEK is a system variable)

If your condition requires time, such as comparing an 
entry to a third-party database (as in locating a social 
security number), then it is best to play a prompt while the 
search is being performed. (If you immediately route the 
call, the query may not have time to finish and, therefore, 
would result in incorrect routing.) The prompt provides 
additional time between the search and the final call 
routing based on the search results.

To play a prompt, create a default routing action to go 
back to the menu, where you can then identify the prompt 
to play.
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Is the customer balance less than then minimum balance?
$cust_balance < $min_balance
($cust_balance and $min_balance are examples of user 
defined variables)

To use the Case tab

1. Click Options > Project Menus > Add button > Touch-Tones 
tab > Case tab. 

The Case tab screen (Figure 8-9) appears.

Figure 8-9. Case Tab

Figure 8-9 Case Tab

2. Click the + (plus) icon to add condition/test. A dialog box (Figure 
8-10) appears.

CCA_AM.book  Page 25  Wednesday, July 26, 2006  2:55 PM



8-26 CallCenterAnywhereTM Administration Manager

Figure 8-10. Use Case Tab

Figure 8-10 Use Case Tab

3. Type the condition and click the OK button. The screen refreshes 
(Figure 8-11) showing additional options.

Figure 8-11. Routing Action to Take When True

Figure 8-11 Routing Action to Take When True

4. On the right side of the screen, select a routing action for CCA to 
take when this condition is true.

In this example, we created a condition/test that checks the 
customer’s account balance. The variable $acccountBalance was 
created and the value was set in some other menu. 
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First, we created the condition/test $accountBalance < 1000. 
Then, we selected a routing action for that condition. When the 
customer’s account balance is less than $1000.00, CCA routes the 
call to a menu called “Balance Too Low.” This menu might simply 
tell the customer that their balance is below $1000.00 and that 
they will be charged a service fee. 

5. Repeat the previous two steps until you finish adding all of the 
conditions and routing actions. 

6. As an option, create a default routing condition to execute if none 
of the other conditions are true:

a. Click the Other button.

b. Then, from the right side of the screen, select a routing 
condition.
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Creating Get Digits Menus
From a Get Digit menu, CCA can prompt the caller to enter a value, 
and then capture that value in a variable. 

To create a Get Digits menu

1. Click Options > Project Menus > Add button. The Get Digits 
Menu screen (Figure 8-12) appears.

2. In the Menu tab, make sure to select the Get Digits button.

Figure 8-12. Get Digits - Menu Tab

Figure 8-12 Get Digits - Menu Tab
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3. Use the information in Table 8-10 to complete the fields. 

Table 8-10. Get Digits Menu Tab Fields and Descriptions

Field Description

Menu Name Type a name for this menu.

Description Type a description for this menu. (Such as the 
menu’s function or purpose.)

Prompt From the drop-down menu, select a prompt that 
describes the options offered in this menu. 

Note: If the correct prompt does not appear in the 
list, record it and add it to the Prompt Library. See 
“Creating a Custom Prompt” on page 5-3).

Number of Digits Type the number of digits the caller must enter.

Note: This includes any terminator the customer 
must enter. For example, “Enter your account 
number and then press the # key.”

Store User Input in 
Variable

Type the variable name in which to store the digits 
that the caller enters. 

See “Using Variables in Menus” on page 8-4.

Validate Check to have what the caller’s enter read back to 
them to verify that it is correct. (The caller can 
select 1 for approval or 2 to re-enter the data.)

Terminator Check to allow the caller to enter a terminating key. 
Then, from the drop-down menu, select a key from 
0 to 9, *, or #.

A terminating key is a way that the caller can tell 
the system “I have finished entering the 
information you asked for.”

For example, you might ask the caller to enter their 
account number and then press the “#” key as a 
terminator. A terminator is useful if the caller’s 
information can be different lengths. For example, 
some account numbers are longer than others.

Number or retries 
before 
disconnect/time-out

Type the number of times CCA plays the menu 
prompt before disconnecting the call. (The default 
is 3 seconds.)
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4. Create routing actions using either the Touch-Tones tab and/or 
the Case tab.

a. For more about the Touch-Tones tab, see page 8-12.

b. For more about the Case tab, see page 8-23.

5. Click OK.

Wait time before 
replaying menu

Type the time (in seconds) for CCA to wait before 
replaying the menu prompt. (The default is 10 
seconds.)

Table 8-10. Get Digits Menu Tab Fields and Descriptions

Field Description
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Creating Play Value Menus
Using a Play Value menu, CCA plays a prompt to the caller or reads the 
contents of a variable to the caller. 

To create a Play Value menu

1. Click Options > Project Menus > Add button. 

The Add Project Menu screen (Figure 8-13) appears.

2. In the Menu tab, make sure to select the Play Value button.

Figure 8-13. Play Value Menu

Figure 8-13 Play Value Menu
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3. Using the information in Table 8-11, complete the fields.

4. Add the Play Value Options:

a. In the Play Value options area, select the prompts or values 
CCA plays to the customer.

b. Click the + (plus) icon. The Add Play Value dialog box (Figure 
8-14) appears.

Figure 8-14. Add Play Value

Figure 8-14 Add Play Value

c. To play a prompt to the caller: 

i. Click the Prompt radio button

ii. Then, from the Select Prompt drop-down menu, choose a 
prompt. 

Table 8-11. Play Value Menu Fields and Descriptions

Field Description

Menu Name Type a name for this menu.

Description Type a description for this menu. (Such as the 
menu’s function or purpose.).

Prompt From the drop-down menu, select the prompt that 
describes the options offered in this menu. 

If the correct prompt does not appear in the list, 
record it and add it to the Prompt Library. (See 
“Creating a Custom Prompt” on page 5-3.)
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d. To play a value (the contents of a variable):

i. Click the Value button.

ii. In the Select the Variable text box, type the name of the 
variable CCA plays. (The variable was created and given a 
value in some other menu. Be aware of a variable’s scope. 
See page 8-6.)

iii. From the As drop-down menu, choose the way CCA reads 
the value to the caller. Use the information in Table 8-12 
when making your selection.

You can only play company prompts to callers. You cannot play 
system prompts. For information about creating company prompts, 
see page 4-16.

Table 8-12. Values and What CCA Reads 

Value CCA Reads

Currency If the value of the variable is 12345, the 
caller hears “One hundred twenty-three 
dollars and forty-five cents.”

Number If the value of the variable is 12345, the 
caller hears “Twelve thousand three hundred 
and forty-five.”

Spelling If the value of the variable is 12345, the 
caller hears “One, two, three, four, five.”

Date (yyyymmdd) If the value of the variable is 20040710, the 
caller hears “July 10, two-thousand and four.”

Note: CCA assumes that the variable is a 
date in the format yyyymmdd.

Date (seconds since 
1970)

If the value of the variable is 20040710, the 
caller hears “Aug 21, nineteen seventy.”

Note: CCA assumes the variable has a POSIX 
formatted date (number of seconds since 
1970). 

Date at Time Same as above, but CCA also tells the caller 
the time.
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5. Create your routing actions using either the Touch-Tones tab 
and/or the Case tab.

a. For more about the Touch-Tones tab, see page 8-12.

b. For more about the Case tab, see page 8-23.

6. Click OK.

Time (seconds since 
1970)

If the value of your variable contains the 
POSIX equivalent of 10:35 AM, the caller 
hears “Ten thirty-five, AM.”

Note: CCA assumes that the variable 
contains a POSIX time value.

Time (hhmm) If the value of the variable is 1035, the caller 
hears “Ten thirty-five, AM.” 

Note: CCA assumes that the variable 
contains a time value in the 24-hour format 
(hhmm). 

Prompt CCA plays the prompt to the caller. 

Note: CCA assumes that the variable 
contains the ID of a company prompt. (See 
“Example 2: Increment a pre-existing 
variable” on page 8-19.)

CCA plays as many prompts or values to the caller as desired.

CCA only plays company prompts to callers. CCA cannot play 
system prompts. (See “Creating a Company Prompt Library” on 
page 4-16.)

Table 8-12. Values and What CCA Reads 

Value CCA Reads
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Creating SQL Query Menus

SQL Query menus allow CCA to run SQL statements against any SQL 
Server or Oracle database to retrieve or update data. 

• Include both AM system variables and user-defined variables in the 
SQL queries. CCA substitutes the variables before passing the 
query to the database server. 

• Capture the result table from an SQL query into a user-defined 
variable. 

• You must capitalize all SQL keywords (SELECT, AS, FROM, WHERE, 
SET, and so on).

• The only table actions that you can perform from a SQL Query 
menu are SELECT, INSERT, and UPDATE.

To create an SQL Query menu

1. Click Options > Project Menus > Add button. The Project Menus 
screen (Figure 8-15) appears.

2. In the Menu tab, make sure to check the SQL Query button.

Before creating an SQL Query menu, an ODBC System DSN entry 
for the database (to access) must exist. The DSN entry must exist 
on the machine where the CCA Statistics server is installed. See 
your Network Administrator for more information.
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Figure 8-15. SQL Query Menu

Figure 8-15 SQL Query Menu

3. Using the information in Table 8-13, complete the fields.

Table 8-13. SQL Query Menu Fields and Descriptions

Field Description

Menu Name Type a name for this menu.

Description Type a description for this menu. (Describe the 
menu’s function or purpose.)

Prompt From the drop-down menu, select the prompt that 
describes the options offered in this menu. 

Note: If the correct prompt does not appear in the 
list, record it and add it to the Prompt Library. (See 
“Creating a Custom Prompt” on page 5-3.)

SQL Query Type the SQL Query CCA runs. 

Note: Do not enter more than 1,900 characters.
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4. Create routing actions using either the Touch-Tones tab and/or 
the Case tab.

a. For more about the Touch-Tones tab, see page 8-12.

b. For more about the Case tab, see page 8-23.

5. Click OK.

Example 1: Update a table

The following statement updates a customer’s status. CCA treats 
the value in the $CustomerId variable as a character string, since 
it is surrounded by single quotes.

UPDATE Customers SET CustStatus = $NewStatus 
WHERE CustId = ‘$CustomerId’

Example 2: Result table with 1 row and 1 column

This statement returns the customer’s account balance in a 
variable called $Balance. 

SELECT CustBalance AS $Balance FROM Customers 
WHERE CustId = ‘$CustomerId’

Example 3: Result table with 1 row and multiple columns

Assume that the result table from the query has 1 row and 
multiple columns. For each column that to trap, provide a 
user-defined variable.

SELECT fname AS $fname, lname AS $lname FROM users
WHERE CustId = ‘$CustomerId’

Alias Type the data source name (from the Network 
Administrator).

Username Type the data source username (from the Network 
Administrator).

Password Type the data source password (from the Network 
Administrator).

Table 8-13. SQL Query Menu Fields and Descriptions

Field Description
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Example 4: Result table with multiple rows and multiple 
columns

If the result table from the query has multiple rows and columns, 
provide variables for the first row only. AM automatically creates a 
set of variables for accessing the values in all of the other rows, 
using a pre-defined naming pattern. 

For example, an SQL query returns the first and last names of 10 
customers. 

SELECT fname AS $fname, lname AS $lname FROM users
WHERE CustId <= 10

The result table looks like Table 8-14.

AM recognizes that the Result Table contains multiple rows and 
automatically creates a set of variables to access the data in each 
row, as shown in Table 8-15.

Notes:

• In the SQL query, provide variables names for the columns to 
trap ($fname, $lname, in our example) just as if the Result 
Table only had 1 row. AM does the rest. 

Table 8-14. Result Table

Rod Beck

Adam Eaton

Miguel Ojeda

Ryan Klesko

. . . . . .

Table 8-15. CCA Automatically Creates Variables

Variable Variable

Rod $fname_1 Beck $lname_1

Adam $fname_2 Eaton $lname_2

Miguel $fname_3 Ojeda $lname_3

Ryan $fname_4 Klesko $lname_4

. . . . . . . . . . . .
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• In this example, use $fname_1 and $lname_1 to reference the 
first and last name in the first row. Also use the variables 
$fname and $lname. This only applies to the first row of the 
Result Table. All other rows must use the $var_<number> 
format.

• Use the system variable ($NBROWS) to find the number of 
rows in the Result Table.

• If a loop to examine all rows in the result table exists, you can 
also see variables using the format: 

$variable_name@$index_variable

In the example above, reference “Ryan Klesko” as:

$index = 4
$fname@$index (“Ryan”)
$lname@$index (“Klesko”)
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Creating Record Menus
Using a Record menu, you can record a customer phone interaction 
and review it later.

To create a Record menu

1. Click Options > Project Menus > Add button. 

The Project Menu screen (Figure 8-16) appears.

Figure 8-16. Record Menu

Figure 8-16 Record Menu

2. In the Menu tab, make sure to select the Record.
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3. Using the information in Table 8-16, complete the fields.

Table 8-16. Record Fields and Descriptions

Field Description

Menu Name Type a name for this menu.

Description Type a description for this menu. (Type the menu’s 
function or purpose.)

Prompt From the drop-down menu, select the prompt that 
describes the options offered in this menu. 

Note: If the correct prompt does not appear in the 
list, record it and add it to the Prompt Library. (See 
“Creating a Custom Prompt” on page 5-3.)

Store filename in 
variable

Enter a variable in this box to find the .wav file 
name, which CCA automatically generates. (When 
your Record menu captures a customer message, 
CCA stores the message in a .wav file on a CCA 
server.)

Example:
• Create a record menu to capture a customer’s 

message. CCA stores the message in a .wav file 
with the generated name “412117512.wav.” 

• In the “Store filename in variable” text box, enter 
$RecordFileName. 

• After CCA captures the customer‘s message, the 
value of the variable $RecordFileName becomes 
“412117512.wav.”

Note: Remember that the scope of a variable is 
the interaction. (See “Variable Scope” on page 8-6.)

Validate If checked, CCA plays the recording back to the 
customer and provides the option to listen to the 
message, re-record the message, cancel the 
message, or save the message and continue. 

Terminator From the drop-down menu, select a terminator so 
that CCA asks the caller to press a button indicating 
they finished recording.

Note: If no terminator exists, the recording 
continues until the caller hangs up or until CCA 
reaches the max recording length.
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4. Create routing actions using either the Touch-Tones tab and/or 
the Case tab.

a. For more about the Touch-Tones tab, see page 8-12.

b. For more about the Case tab, see page 8-23.

5. Click OK.

Listening to a Recorded Message

CCA provides two ways to listen to a message captured by a Record 
menu. 

1. Interaction Manager:

If a contact is assigned to the interaction (see the Interaction 
Manager’s User Manual for information about assigning contacts), 
the recorded message appears as a link in the Interaction History 
for the contact.

2. Supervision Manager: 

Regardless of whether a contact is assigned to the interaction, the 
recording is always available through the Options > Interaction 
History screen in Supervision Manager. 

Maximum recording 
time

Type the maximum time that CCA will continue 
recording. 

Table 8-16. Record Fields and Descriptions

Field Description
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Implementing Your Project Menu
After creating a Project Menu, route callers dialing in to the project to 
the menu. To do this, refer to “Adding Phone Interactions to a Project” 
on page 10-5.

Scheduling a Conference
Interaction Manager allows agents to put active calls in conference. For 
example: 

• The agent accepts a call and puts the caller in conference, 
• The agent accepts a second call and puts them in the 

conference.
• and so forth

The agent can keep accepting calls, putting them in conference, and 
then all of the callers can speak together. However, you can only have 
this type of conference when all callers reach the same agent, and the 
agent manually adds the calls to the conference.

CCA also has a scheduled conference feature. In a scheduled 
conference: 

• Any user (netadmin, admin, sysadmin, supervisor, or agent) 
creates the scheduled conference, and then emails the date, 
time, phone number and conference password to anyone who 
wants to participate.

• At the appropriate time, people call the phone number, enter 
the conference password, and are added to the conference.

• None of the people in the conference need to be logged into 
AM, SM, or IM.

Creating the scheduled conference is easy - anyone can do it by 
starting Internet Explorer and connecting to a stand-alone Web page 
that comes with the CCA installation. 

Before scheduling a conference, an administrator (Netadmin, 
Sysadmin, or Admin) must: 

• Create a set of project menus to route callers to the 
conference. 
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• Tell the person scheduling the conference what number the 
participants should dial.

Setting Up Scheduled Conferences in Administration Manager

If you are not familiar with the process of creating project menus, read 
“Creating Project Menus” on page 8-1 before continuing.

The general process is to create three project menus:

1. A Get Digits menu: Prompts the caller to enter their 
conference password and then captures it in a variable.

2. A SQL Query menu: Verifies that the conference password is 
valid and determines if the conference is currently in progress. 

3. A Standard menu: Tests and initializes a few variables, and 
then adds the caller to the conference. 

To create the Project Menus for Scheduled Conferences

1. Create a custom prompt, such as: “Please enter the conference 
password.”

2. Click Options > Project Menus > the Add button. The Add 
Project Menus screen (Figure 8-17) appears.
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Figure 8-17. Project Menus 

Figure 8-17 Project Menus

3. Create a Get Digits Project Menu: 

a. This menu traps the caller’s conference password. Therefore, 
use menu name Conf - Get Password. 

b. In the Description box, type a description.

c. From the Prompt drop-down menu, select the custom prompt 
you created in step a.

d. Under Menu Type, click Get Digits.

e. In the Get Digits Options box:
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i. In the Number of Digits box, type 10.

ii. In the Store User Input in Variable field, type a variable 
name. (The conference password the caller enters ends up 
in this variable.)

f. Click OK.

4. Select the Touch-Tones tab (Figure 8-18).

Figure 8-18. Touch-Tones Tab

Figure 8-18 Touch-Tones Tab

a. In the left side of the screen, select the Default Link button.

b. In the right side of the screen, click the plus ( ) icon and 
create a new menu called Conf - Verify Password.

c. Then, from the Menu drop-down box, select the menu you just 
created (Conf - Verify Password).

d. Click OK.
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5. In the Project Menu main screen (Figure 8-19), edit the Conf - 
Verify Password menu.

Figure 8-19. Project Menu Main Screen

Figure 8-19 Project Menu Main Screen

In the previous menu, we asked the caller to enter their 
conference password and then trapped it in a variable. 

In the “Conf - verify password” menu, we will verify that the 
caller’s conference password is valid.

a. Set the Menu Type to SQL Query.

b. In the SQL Query text box, type the query shown in Figure 
8-19: 
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SELECT CONFERENCEID as $CONF_ID, 
isrecording as $CONF_REC, 
startdate as $START_DATE 
enddate as $END_DATE,
chairpassword as $CHAIR_PW,
FROM CONFERENCES 
WHERE conferencepassword = '$passcode' 
OR chairpassword = '$passcode' 
AND isdeleted = 0

We use this query to find some information about the 
conference in the database. Almost all of the information we 
are interested in was added to the database when the CCA 
user created the scheduled conference. 

Most of the $YADA variables shown above are custom variables 
we are creating to trap return values from the query. You can 
choose any names for these variables that you want, with two 
exceptions: 

• You must use variables named $CONF_ID, and 
$CONF_REC. 

• The system needs, and expects, to find variables with 
these names. 

Table 8-17. Variables and Descriptions

Variable Description

$CONF_ID The conference ID is created when a user schedules a 
conference. We’ll use this in a moment to verify that it’s 
a valid ID.

You must use a variable called “$CONF_ID” here. We’ll 
explain why later in this section.

$CONF_REC When a user creates a scheduled conference, they can 
click a check box to have the conference automatically 
recorded. If the conference will be recorded, 
$CONF_REC will equal 1. If the user did not select the 
record check box, $CONF_REC will be 0.

You must use a variable called “$CONF_REC” here. We’ll 
explain why later in this section.
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6. Select the Touch-Tones tab, then select the Case tab (Figure 
8-20).

$START_DATE
$END_DATE

When a user creates a scheduled conference, they enter 
a starting day and time and an ending day and time for 
the conference. In the database, these are converted to 
a POSIX start conference timestamp and a POSIX end 
conference timestamp.

$CHAIR_PW When you schedule a conference the stand alone web 
page generates two passwords: one for the “chairman” 
(the person who schedules the conference) and the 
other password for the participants. 

The only difference between the two passwords is that 
the system uses the chairman’s password as a way of 
notifying the chairman that the conference will end 
soon.

$passcode The conference password that the caller entered (and 
we trapped) in the previous Get Digits menu.

Table 8-17. Variables and Descriptions

Variable Description

CCA_AM.book  Page 49  Wednesday, July 26, 2006  2:55 PM



8-50 CallCenterAnywhereTM Administration Manager

Figure 8-20. Case Tab

Figure 8-20 Case Tab

a. Use the Case tab to create a condition: 

$CONF_ID != ““

Then select this condition and use the icon in the right side 
of the screen to create another menu called “Conf - Enter 
Conference”. Now we’ve set up a condition where if the 
conference ID is not a null string, we will route the caller to 
another menu for further processing. 

b. Select the Other condition and route it to the Disconnect 
option. In a more realistic example, you might want to send 
the caller to a menu that tells them you can’t find the 
conference password that they entered and give them a 
chance to enter it again.

c. Save your changes, then go back to the Project Menu main 
screen. 

Create the condition

Then, create a new menu and route 
the condition to the new menu
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7. In the Project Menu main screen, edit the “Conf - Enter 
Conference” menu you just created. 

In this menu, we’ll do a little more testing on some variables to 
make sure everything looks good, and then add the caller to the 
conference. 

a. In the Menu tab, select Standard as the Menu Type.

b. Select the Touch-Tones tab, then select the Case tab.

c. In the Case tab (Figure 8-21), create the following conditions: 

Figure 8-21. Case Tab

Figure 8-21 Case Tab

Refer to Table 8-18 for conditions.
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d. After routing the Other condition to the Enter Conference 
routing option, set up three special variables using the Set 
Variable feature. (Refer to “How to set these variables” on 
page 8-53.)

Table 8-18. Cast Tab Conditions

Condition Route To

$CONF_ID <= 0 In this example, if we determine that the conference ID 
is less than or equal to zero (invalid) we disconnect the 
call. 

In a more realistic example, you might want to send the 
caller to a menu that tells them you can’t find the 
conference password that they entered and give them a 
chance to enter it again.

$END_DATE < $DATE Here we are seeing if the conference end time 
($END_DATE which we got from our SQL Query Project 
menu) is less than the timestamp of “now” (using the 
system variable $DATE). If it is, it means that the 
conference is over, so we will route the caller to the 
disconnect option or to some other menu to handle that 
case. 

$START_DATE > $DATE Here we are seeing if the conference start time 
($START_DATE which we got from our SQL Query 
Project menu) is greater than the timestamp of “now” 
(using the system variable $DATE). If it is, it means that 
the conference hasn’t started yet, so we will route the 
caller to the disconnect option or to some other menu 
to handle that case. 

Other If the caller reaches this condition then the conference 
ID is valid, and the conference is still in progress. 

To add the caller to the conference we need to do two 
things: 
• Select the Other condition and then select the Enter 

Conference routing option.
• Use the Set Variable feature at the bottom of the 

screen to assign and test some important variables. 
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i. These variables must have the names $CONF_TIME, 
$CONF_SUP, and $CONF_NOTIFY. 

ii. Setting $CONF_TIME to “$END_DATE - $DATE” tells the 
system how much time is left in the conference.

iii. $CONF_SUP tests the conference password that the caller 
entered against the chairman’s password. It tells us who in 
the conference is the chairman (the person who scheduled 
the conference). Before the conference ends, the system 
will play a wav file that only the chairman will hear. The 
wav file notifies the chairman that the conference is about 
to end and gives them the option of extending the 
conference. 

iv. $CONF_NOTIFY can be set to any value (in seconds). If 
you set $CONF_NOTIFY to 60, the conference chairman will 
hear the warning wav file 60 seconds before the 
conference ends.

How to set these variables

1. Conference Time:

a. Variable Name = $CONF_TIME (Figure 8-22)

b. Value = $END_DATE - $DATE

Figure 8-22. Set Variable for Conference Time

Figure 8-22 Set Variable for Conference Time

2. Chair person password:

a. Variable Name = $CONF_SUP (Figure 8-23)

b. Value = $passcode ==$CHAIR_PERSON
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Figure 8-23. Set Variable for Chairperson’s Passcode

Figure 8-23 Set Variable for Chairperson’s Passcode

3. Notify time before conference ends:

a. Variable Name = $CONF_NOTIFY (Figure 8-24)

b. Value = 60 (seconds)

Figure 8-24. Set Variable for Notify Time Before Conference Ends

Figure 8-24 Set Variable for Notify Time Before Conference Ends

Figure 8-25 shows what the screen looks like when you finish.
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Figure 8-25. Finished Case Tab Screen

Figure 8-25 Finished Case Tab Screen

4. Create a Phone Project: 

a. Select a Project Phone number. (This is the number that 
participants call to join a conference.)

b. In the Route Caller To subtab (Figure 8-26), select the Menu 
button, then select your top-level conference menu (Conf - 
Get Password, in this example). 
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Figure 8-26. Route Caller To

Figure 8-26 Route Caller To

Your setup is done. Users can now use the stand-alone Web page 
to schedule conferences.

Creating a Scheduled Conference

After an Administrator has done the conference setup, anyone with a 
CCA account can schedule a conference. The Administrator can also 
tell you what phone number has been set up for the conference call.

1. Start Internet Explorer and open the Conference Web page: 

http://<web server host>/taw/CreateConference/

The Create Conference Web page (Figure 8-27) opens.
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Figure 8-27. Create Conference

Figure 8-27 Create Conference

2. Using the information in Table 8-19, complete the fields.

Table 8-19. Create Conference Fields and Descriptions

Field Description

Company Alias
Username
Password

Enter the same information that you use when you log 
into Administration Manager, Supervision Manager, or 
Interaction Manager. 

See your Supervisor or Administrator if you don’t know 
what to enter in these fields.

Is Recording Check this box if you want the conference call to be 
recorded. Supervisors can listen to the recorded 
conference later by using the Interaction History screen 
in Supervision Manager. 
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3. Click the Create Conference button. 

The Web page displays two passwords (Figure 8-28); Chair 
Password and a Conference Password

Figure 8-28. Chair Password and Conference Password

Figure 8-28 Chair Password and Conference Password

Immediately copy these passwords into a text or word processing 
document, because without these passwords, no one can join your 
conference. 

Custom ID The Custom ID is a string associated with the 
conference. It is not displayed anywhere in any CC@ 
application. But it does get stored in the CC@ database, 
so companies can write custom queries to report on 
scheduled conferences.

Start Time
End Time

Use these controls to set a start day and time and an 
end day and time for the conference. 

Table 8-19. Create Conference Fields and Descriptions

Field Description
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In general, you might want to keep the Chair password for 
yourself. The only difference between the two passwords is that, 
whoever joins the conference first using the Chair password can 
receive a warning notice that the conference will end soon. The 
chairperson can also choose to extend the conference if they wish.

• If more than one person joins the conference using the 
chair password, the first one to join the conference is 
considered the meeting chairperson and will receive the 
end of meeting notice. 

• If two people join the conference using the chair password, 
and the first exits the conference, the remaining person 
becomes the meeting chair and will receive the end of 
meeting notice. 

Once you have copied your passwords somewhere safe, you can 
use your email program to notify all of the participants about the 
upcoming conference. The participants need to know: 

• The start day and time and the end day and time for the 
conference. 

• The conference password. 
• The conference phone number. (Your Administrator can tell 

you what this is.)

At the appropriate time, participants call the phone number you 
give them. They will be prompted to enter the conference 
password. If they enter the correct password, and the conference 
is in progress, they will be added to the conference. 

However: 

• If they enter an incorrect conference password, or 
• If the conference has ended, or
• If the conference hasn’t started yet, 

these are all situations that are custom configured for your 
company and you should see your Administrator for more 
information. 
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9

Campaigns 9

Overview
In some call centers, you might want to:

• Give the customer access to a large number of options and 
services. 

• Get information from, and present information to, the 
customer.

• Route the customer in complex ways, depending on their 
choices and preferences.

An easy way to design a complex call flow is to make a series of 
flowcharts (Figure 9-1) that diagram how calls can move through the 
system.
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Figure 9-1. Call Flow Diagram

Figure 9-1 Call Flow Diagram

After finishing, create all of the pieces supporting the diagram (such as 
menus, prompts, SQL queries, and so forth). Then, link all of those 
pieces together to create the system. 

Like a Project Menu, use a Campaign to create a sophisticated call 
flow in the call center. The Campaign feature has two advantages:

1. It has a flowchart-like interface, so when you create a chart of 
the call flow, you are actually creating the “system” at the 
same time.

2. Most (and in some cases all) of the parts of the call flow are 
encapsulated in a single Campaign object. You can open one 
Campaign and see all of the prompts, options, and routing for 
the entire call flow in a single object. 

After creating a Campaign, route to it from either a Phone Project or a 
Project menu. CCA automatically routes anyone who reaches the 
Phone Project or Project Menu to the Campaign.

The customer dials the 
toll-free support number.

Next Step

The customer presses “1” to 
continue in English.

The customer presses “2” 
to continue in Spanish.Welcome the customer to the 

Support Center.

Ask if they want to continue 
in English or Spanish.

Next Step
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Campaign Tutorial
Follow the steps in this section to get a quick overview of the entire 
process of creating a Campaign.

1. Select Options > Campaign > the Add button. Wait until the 
Campaign editor loads.

2. In the first screen of the New Campaign Wizard (Figure 9-2), type 
a Name and Description for the campaign.

Figure 9-2. New Campaign Wizard - Screen 1

Figure 9-2 New Campaign Wizard - Screen 1

3. Click the Next button. The second screen appears.
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Figure 9-3. New Campaign Wizard - Screen 2

Figure 9-3 New Campaign Wizard - Screen 2

4. Using the information in Table 9-1, complete the fields.

Table 9-1. Campaign Wizard Screen 2 Fields and Descriptions

Item Description

In Case of Any 
System Error, Go 
To:

Set up the routing condition to execute when a system 
error occurs. A system error occurs when the campaign 
cannot take any other routing action. For example, if 
one node is configured to route to another node, and 
the second node was deleted, a system error occurs 
and CCA executes the routing action selected here.
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3. Click the Finish button. A new campaign window (Figure 9-4) 
appears with a Begin node. 

From the drop-down menu, select an area to route 
system errors from: 

• Workgroup
• Workgroup Voicemail
• User
• User Voicemail
Disconnect

Allow Type Ahead If a node exists, anywhere in the campaign, that plays a 
prompt and then traps the user’s keypress with a Get 
User Digit or Get DTMF action, the user can enter 
their response without listening to the entire prompt. 
• See “Get User Digit” on page 9-26.
• See “Get DTMF” on page 9-30.

Enter Digit Timeout This option applies to any place in the campaign where 
the customer must enter multiple key presses. The 
Enter Digit Timeout is the amount of time to wait 
between key presses. When the timeout is reached, the 
campaign moves on to the next action (such as 
validating the customer’s entry, making a routing 
decision, and so on).

Table 9-1. Campaign Wizard Screen 2 Fields and Descriptions

Item Description

CCA_AM.book  Page 5  Wednesday, July 26, 2006  2:55 PM



9-6 CallCenterAnywhereTM Administration Manager

Figure 9-4. New Campaign Screen

Figure 9-4 New Campaign Screen

A node is a like a block in a flowchart. When creating a new 
campaign, start with the Begin node. The Campaign Wizard 
automatically creates it. It represents the first thing to happen 
when people reach the campaign. The Begin node is the only node 
that you cannot delete. 

A node provides three main actions: 

• Take some action: For example, play a prompt, capture 
the customer’s key presses, run a SQL query, and so on. 
Take more than one action in the same node, if desired. 
For example, in one node ask the customer to enter their 
account number, capture the number that they enter, and 
verify the account number in the database - all in one 
node. 

(For more details about actions, see “Adding Actions to 
Nodes” on page 9-22.)

The Begin node is created 
by default. It is always the 
first node in the campaign.

Click the arrow buttons to 
move nodes up and down.

Click the Campaign 
Settings link to change 
information in the New 
Campaign Wizard screens

Click the Close button to save 
changes and close the window.
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• Route to a child node if some condition occurs: For 
example, if the customer presses 2 to continue in Spanish, 
route the caller to another node that plays a Spanish 
menu, and do further call flow from there. Routing to a 
child node is one way to create new nodes in the 
campaign.

(For more information about conditional routing, see “Menu 
Routing Conditions” on page 9-35.)

• Route to a feature: This is like a very powerful GoTo 
statement in programming. By “routing to a feature” CCA 
sends the call to any node in the current campaign or to 
the begin node of another campaign, or you can also take 
the caller out of the campaign and route them to some 
other feature of AM (such as a project or workgroup 
extension).

(For more about feature routing, see “Menu Types” on 
page 9-18.)
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Example: Set an action for the node

1. Right-click on a node and select Set Action Menu (Figure 
9-5).

Figure 9-5. Select Set Action Menu

Figure 9-5 Select Set Action Menu

The Action menu (Figure 9-6) appears.

Figure 9-6. Action Menu

Figure 9-6 Action Menu

Set many actions for a node. For more information about each 
action type, see “Adding Actions to Nodes” on page 9-22.

Give the node a name 
(such as “Prompt for 
Language”) Select an action and drag 

it to the top of the display 
area.
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2. For a simple campaign, add a Play Prompt action, and 
assume a Company Prompt like this already exists:

“Press 1 to continue in English. Press 2 to continue in Spanish.”

3. Click the Play Prompt action and drag it to the display area. A 
window (Figure 9-7) appears showing options for the action.

Figure 9-7. Add Play Prompt Action

Figure 9-7 Add Play Prompt Action

Double-click to expand or 
contract the window.

Click the Trash can icon 
to delete the action.
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4. After adding the Play Prompt action, drag a Get DTMF action 
to the top of the display area. 

5. Double-click the Get DTMF action (Figure 9-8) to show its 
properties. 

Figure 9-8. Get DTMF Properties

Figure 9-8 Get DTMF Properties
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For more information about the Get DTMF action, see page 
9-30. 

6. For this example, set the Number of Retries to 1 and the Wait 
Time to 5 seconds, so that this campaign uses the Get DTMF 
action to trap the customer’s response when they select a 
language.

7. When finish selecting options for the action, click the OK 
button to close the Action Menu window.

The main campaign window (Figure 9-9) shows a child 
“Default” node. 

Figure 9-9. Child Node

Figure 9-9 Child Node

The Campaign Wizard creates a child default node when:

• Setting an action on a node. 
• Routing to another node. 

Adding an action also creates a default Child Node.

You can delete any node (except 
the Begin node) by clicking the 
Trash Can icon.
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The default node provides the system a way to route the call, no 
matter what happens. For example, the customer hears a prompt 
to press 1 to continue in English or 2 to continue in Spanish. 
However, for some reason, the customer presses 3 or #.

The Default node is happens to the call if none of the other 
conditions are met.

If you delete a default node and the customer does something 
unexpected, the Campaign Wizard routes the call to the In Case 
of Any System Error, Go To setting you selected when creating 
the campaign. (View or edit this setting by clicking the Campaign 
Settings link, in the top right corner of the Campaign window, and 
then clicking the Advanced tab.)

For this example, set the default node to hang up if anything 
unexpected happens.

8. Right-click on the default node and select Set Menu Type.

Figure 9-10. Select Set Menu Type

Figure 9-10 Select Set Menu Type

The Menu Type window (Figure 9-11) appears. 
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Figure 9-11. Window Type

Figure 9-11 Window Type

The Campaign Wizard uses the Menu Type window to route 
the call to a feature. 

For more information about the choices in the Menu Type window, 
see page 9-18.

9. Select the Disconnect feature.

10. Type some text in the Name field to describe your choice. 

11. Click OK.

Route to a child node (add routing conditions) 

Now, the example campaign consists of a prompt asking the user 
to select 1 for English and 2 for Spanish. It also has a default child 
node that to disconnect the call if anything unexpected happens.
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Figure 9-12. Action Node and Menu Type Node

Figure 9-12 Action Node and Menu Type Node

1. Add the routing to route the customer to a Child node (based 
on their keypress, trapped with the Get DTMF action):

i. Click the plus ( ) icon in the Begin node. The Menu 
Routing Conditions window (Figure 9-13) appears:

Figure 9-13. Menu Routing Conditions

Figure 9-13 Menu Routing Conditions

Blue text shows 
Action Nodes

Red text shows 
Menu Type Nodes
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For more detailed information about this window, see “Menu 
Routing Conditions” on page 9-35, but for now:

ii. Click the DTMF button, to set up routing conditions based 
on a user keypress. 

iii. Click buttons 1 and 2 to highlight them and then click the 
OK button.

The Campaign window now looks like Figure 9-14:

Figure 9-14. Example Campaign

Figure 9-14 Example Campaign

At this point, the campaign prompts the customer to press a 
key routes them to a node based on the key that they pressed. 

2. Now, configure those new nodes to do something. For this 
example, configure the “keypress 1” node to set the prompt 
language to English, and the “keypress 2” node to set the 
prompt language to Spanish.

User presses 1, for this node.

User presses 2, for this node.

For each keypress to trap, the 
campaign adds an empty child node.

Next, 
configure each 
new node.

The default node is still here, so if the 
user presses any key other than 1 or 
2, the call is disconnected.
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i. Right-click the keypress 1 node and select Set Action 
Menu.

ii. In the Action Menu window, drag the Set Language 
option into the display area.

iii. Double-click the Set Language window. 

iv. From the Language drop-down menu, select English.

3. Repeat the above steps for the “keypress 2” node and set the 
language to Spanish. 

4. When finished, the campaign window should look like Figure 
9-15:

Figure 9-15. Example Campaign Window

Figure 9-15 Example Campaign Window
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5. Click the Close button.

6. Now, route to the Campaign from either a Phone Project or a 
Project Menu:

To associate a campaign with a project

1. Open a project and select the Phone tab.

2. At the bottom of the Phone tab, click the Campaign radio 
button.

3. From the drop-down menu, select the name of the campaign

Now, when a customer calls the project phone number, the 
campaign instantly routes them to the Begin node.

To associate a campaign with a project menu 

1. Open a project menu and select the Touch-Tones tab.

2. On the left side of the screen, select a key. 

3. On the right side of the screen, click the Campaign radio 
button.

4. From the drop-down menu, select a campaign.

When setting the language in “keypress 1” node and 
“keypress 2” node, the campaign also created a Default 
node for each. You can delete these extra default nodes, 
but in a real campaign, you would probably use them to 
continue routing the call, taking additional actions, and so 
on.
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A Closer Look
This section provides information about:

• Menu Types
• Actions
• Nodes and Routing Conditions

Menu Types

Use the Menu Type window to route the caller to a feature.

• You can route to features that are inside a campaign. (For 
example, use the Menu Types window to route a call to any 
node in the current campaign.) 

• You can route to AM features that are outside the campaign. 
(For example, route a call to an external number or to a 
project.)

A node with a Menu Type is a termination point and does not need any 
child nodes (see “Menu Types” on page 9-18). The campaign sends the 
call to another node or to some other feature.

To add a Menu Type to a node

1. Right-click a node and select Set Menu Type (Figure 9-16).

Figure 9-16. Select Set Menu Type

Figure 9-16 Select Set Menu Type

The Menu Type window (Figure 9-17) appears:
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Figure 9-17. Menu Type

Figure 9-17 Menu Type

2. Using the information in Table 9-2, complete the Menu Type 
screen.

Table 9-2. Menu Type Items and Descriptions

Item Description

Campaign Route the call to the Begin node of any campaign, 
including the current campaign.

Company Directory Play the Company Directory Navigation prompts, 
which allow a caller to reach an agent by entering the 
agent’s name.

Disconnect Immediately disconnect the call.

Existing Menus Route the call to an existing Project Menu.
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External Number
Country Code
Phone

Route the call to any external number (outside the 
company). 
From the drop-down menu, select a country code.
Type the complete phone number. (For example, in 
the United States, select 1 as the Country Code type a 
10-digit number.)

Mailbox Select this option to play the prompt 
entermailbox.wav (“Please enter your mailbox 
number, followed by the pound key”) to allow call 
center agents to access their non-ACD voicemail 
messages from a remote telephone and to set up their 
voicemail greetings. 

Notes: 
For agents to access the Mailbox Manager remotely:
• The agent’s user name and password (Options > 

Agents > Profile) must consist only of numbers. For 
example, the agent’s user name could be “1234” 
and their password could be “5678.” 

• A POP3 server must be configured for the agent 
(Options > Agents > Email > Defined POP3 Server).

To prevent customers from accessing the Mailbox 
Manager feature, leave it out of the recorded prompt. 
(Tell agents they can press a key to access their 
voicemail messages, but that the feature is not 
described as an option in the recorded prompt.)

Previous Campaign If the call was routed to the current campaign from 
another campaign, this option routes the call to the 
Begin node of that previous campaign. 

If the routing logic of the campaign allows this node 
to be reached and there is no “previous campaign,” a 
system error occurs and the campaign executes the 
system error routing decision (see “Changing the 
Campaign Settings” on page 9-56).

Project Route the call to an existing project. 

Table 9-2. Menu Type Items and Descriptions

Item Description
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To remove a Menu Type from a node

1. Right-click a node and select Remove Action Menu/Menu Type 
(Figure 9-18).

Figure 9-18. Select Remove Action Menu/Menu Type

Figure 9-18 Select Remove Action Menu/Menu Type

User Extension
User Fax
User Voicemail

Workgroup Extension
Workgroup Fax
Workgroup Voicemail

These six options work the same. From a drop-down 
menu, select a User/Workgroup name or enter a 
variable that was assigned the ID of a user or 
workgroup. (See “Using variable reference fields” on 
page 9-58.)

If you use a variable for one of these options and the 
variable has no value when it is executed, a system 
error occurs and the campaign executes the system 
error routing decision. (See “Changing the Campaign 
Settings” on page 9-56.)

Note: You can also route to a workgroup from an 
Action. See “Enter Workgroup” on page 9-29.

Existing Nodes Route the call to any node in the current campaign.

Table 9-2. Menu Type Items and Descriptions

Item Description

Blue text shows Action Nodes

Red text shows 
Menu Type Nodes
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Adding Actions to Nodes

Add an Action to a node to:

• Give the caller some information.
• Get information from the caller.
• Take action on behalf of the caller. 

To add an action to a node

1. Right-click a node and select Set Action Menu (Figure 9-19).

Figure 9-19. Select Set Action Menu

Figure 9-19 Select Set Action Menu

The Action Menu window (Figure 9-20) appears: 
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Figure 9-20. Action Menu

Figure 9-20 Action Menu

2. Set more than one action in the same node. For example, in the 
same node set:

• Play a prompt (to asks the customer to enter their account 
number.)

• Trap the user’s account number. 
• Run an SQL query (to verify that the account exists and to find 

the user’s balance).
• Read the user’s balance to them. 
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a. To add more than one action to a node, can use the arrow 
buttons (Figure 9-21) to rearrange the actions. 

Figure 9-21. Rearrange Actions

Figure 9-21 Rearrange Actions

Select an action. Then, click the 
arrow buttons to move the action 
up or down.
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b. Using the information in Table 9-3, complete the Action Menu

Table 9-3. Action Menu Items and Descriptions

Item Description

Play Variables Select Variable: Type the name of the variable to play. 
The variable must already exist and have a value. 

Select Type: Choose the way the caller hears the 
variable’s value:

• Currency: If the variable’s value is “12345,” the caller 
hears: “One hundred twenty three dollars and 
forty-five cents.”

• Number: If the variable’s value is “12345,” the caller 
hears: “Twelve thousand three hundred and forty-five.”

• Spelling: If the variable’s value is “12345,” the caller 
hears: “One, two, three, four, five.”

• Date (yyyymmdd): Assumes that the variable is a 
date in the format yyyymmdd. If the variable’s value is 
20040710, the caller hears “July 10, two-thousand and 
four.”

• Date (seconds since 1970): Assumes the variable 
has a POSIX formatted date (number of seconds since 
1970). If the variable’s value is 20040710, the caller 
hears “July 10, two-thousand and four.”

• Date at Time: Same as above, but also tells the 
caller the time.

• Time (seconds since 1970): Assumes that the 
variable contains a POSIX time value. If the variable’s 
value contains the POSIX equivalent of 10:35 AM, the 
caller hears “Ten thirty-five, AM.”

• Time (hhmm): Assumes that the variable contains a 
time value in the 24-hour format hhmm. If the 
variable’s value is 1035, the caller hears “Ten 
thirty-five, AM.”

• Prompt: Assumes that the variable contains the ID of 
a prompt. See “Using variable reference fields” on 
page 9-58.

Play Prompt Prompt Name: Select the prompt to play. 

Note: You can only select an existing company (custom) 
prompt. (You cannot select a system prompt.) 
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Variable Reference: Type a variable that contains the 
ID of a custom prompt. See “Using variable reference 
fields” on page 9-58.

Allow Caller to Interrupt: Check so that the customer 
can enter a keypress while the prompt is playing. As 
soon as the customer presses a key, the prompt stops 
playing.

Get User Digit Number of Digits: The number of digits entered by the 
caller. 

Note: This includes any terminator in the prompt. For 
example, “Enter your account number; then press the 
pound (#) key.”

Result Store in Variables: The variable name in which 
to store the digits that the caller enters. 

Validate: Check to have CCA read the caller’s entry 
back to them for verification. The caller can select 1 to 
approve or 2 to re-enter the data.

Terminator: Check o the caller can enter a terminating 
key telling the system “I have finished entering the 
information you asked for.” For example, after asking the 
caller to enter their account number, ask them to press 
the pound (#) key (the terminator). A terminator is 
useful if the caller’s information can be different lengths 
(as when some account numbers are longer than 
others).

Number of retries before disconnect/time-out: 
Type the number of times CCA replays the menu prompt 
before disconnecting the call.

Wait time before replaying menu: Type the time (in 
seconds) CCA waits before replaying the menu prompt.

Database Query Use the Database Query action to run an SQL query and 
trap the result table. 

• See the examples for writing SQL queries, beginning 
on page 8-35.

Table 9-3. Action Menu Items and Descriptions

Item Description
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• Before using the Database Query action, create a 
Database Connection. (See page 9-67 for more 
information.) A database connection points to a 
system DSN previously created. After creating a 
database connection, select it from the Database 
Source drop-down menu (below). Your query runs 
against the database you select.

SQL Query: Enter the SQL Query the system will run.

Query Result Status Variable: Type a variable name. 
After the query completes, system copies the value of 
$SQLSTATUS to the variable:

FAIL
NOROWS
PENDING
SUCCESS
TIMEOUT

Query Timeout (sec): Type a time limit for the query 
to return a status. If the timeout is exceeded, the Query 
Result Status Variable has the value ‘Timeout’. No result 
table is returned. However, the system does not 
terminate the query.

Maximum Number of Rows Variable: Type a 
variable name. When the query completes, the system 
assigns the variable the number of rows in the result 
table. 

Maximum Number of Rows: Type the maximum 
number of rows the result table contains. (You cannot 
enter a value greater than 99 in this field.)

Database Source: Select a Database Connection. The 
query runs against this database.

Table 9-3. Action Menu Items and Descriptions

Item Description
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Set Variables Use this action to: 
• Create and initialize new variables
• Set the value of an existing variable.

Type the variable name in the left text box and the value 
in the right text box. You can also use string, numeric, 
and comparison operators.

Examples:
$tmp = ‘hello’
$tmp = $tmp1 > $tmp2
$tmp = 1 + $tmp2

Set Variables to 
Object

Use this action to assign the ID of a workgroup, user, or 
prompt to a variable. See “Using variable reference 
fields” on page 9-58.

• From the Select Type drop-down menu, select an 
object type.

• In the left text box, type the name of a new or 
existing variable. 

• From the drop-down menu on the right, select a 
specific workgroup, user, or company (custom) 
prompt.

Set Language From the drop-down menu, select a language. From this 
point in the campaign, the system plays all prompts in 
this language. 

Make sure to record all prompts in the language you 
select. (If you are missing any prompts, the customer 
hears only silence when the system should play the 
prompt.)

Play Music Select to play streaming audio (music broadcast) to a 
caller. 

In the Play Music action, select a existing broadcast 
source. (See the tech note “Setting Up a Music 
Broadcast” on page 5-5 to learn how to create a music 
broadcast source.)

Select Source: Select an existing music broadcast 
source.

Table 9-3. Action Menu Items and Descriptions

Item Description
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Play For: Click the check box and type a time value (in 
seconds). The music broadcast plays for this duration. At 
the end of this time, the campaign continues to the next 
action in the current node or to the next node. 

Allow Caller to Interrupt: Check so that the caller can 
interrupt the music broadcast at any time by pressing 
any key. When the caller interrupts the music broadcast, 
the campaign continues to the next action in the current 
node or to the next node. 

Note: You must do at least one of the following:
• Enable the Play For option 
• Enable the Allow Caller to Interrupt option 
• Precede the Play Music action with an Enter 

Workgroup action
If you do not, the caller remains stuck listening to the 
music broadcast forever.

Send Emails Select to send an email to any valid address or email 
group. Before selecting this action, at least one SMTP 
Group must exist. (See “Creating an SMTP Server Group 
Library” on page 4-64.)

• Max length of the From field: 128 characters.
• Max length of the To field: 128 characters.
• Max length of the Subject field: 128 characters.
• Max length of the Message field: 2048 characters.

Enter Workgroup Select to route a call to a workgroup, but keep the 
option to bring the caller back to the campaign.

If you use the Menu Type dialog box to route to a 
Workgroup Extension/Fax/Voicemail (see page 9-21), the 
campaign immediately routes the call to the workgroup 
and cannot return to the campaign.

If you use the Enter Workgroup action, the campaign 
requests an available agent, but keeps control over the 
call until an agent accepts it. 

Table 9-3. Action Menu Items and Descriptions

Item Description
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• The campaign node can play music, prompt the 
customer for more information, and so on. 

• Any time before an agent accepts the call, you can use 
the Exit Workgroup action to return the call to the 
campaign.

• After an agent accepts the call, the call permanently 
exits from the campaign.

Select Workgroup: The campaign requests an 
available agent from the workgroup you select.

Variable Reference: Type the name of a variable that 
was assigned the ID of a workgroup. (See “Using 
variable reference fields” on page 9-58.)

If your variable has an invalid workgroup name, the 
campaign routes the call to the system error choice. 
(See “Changing the Campaign Settings” on page 9-56.)

Get DTMF Use the Get DTMF action to:

• Prompt the user to make a choice by pressing a key 
(Such as “Press 1 to continue in English...”)

• Trap the user’s keypress.
• Route to a special child node to handle their keypress. 

A Play Prompt action always precedes the Get DTMF 
action. The Get DTMF action always uses a special 
“DTMF child nodes” (to handle the keypress) and is 
created with the Menu Routing Conditions dialog box. 

The Get DTMF action only has two options:
• Number of Retries Before Disconnect/Timeout: 

The number of times to replay the prompt if the caller 
does not press a key or does not press a valid key.

• Wait Time Before Replaying Menu: The time to 
wait for the caller to press a key. 

However, much execution logic exists behind these two 
simple options. See Figure 9-22 on page 9-34 for all 
details. 

Table 9-3. Action Menu Items and Descriptions

Item Description
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See Also:
• The Campaign tutorial includes a simple example of 

how to use the Get DTMF action and the DTMF child 
nodes. See page 9-8.

• See “Routing a DTMF (customer keypress)”  on page 
9-41 for more information about the DTMF child 
nodes. 

Enable Quality 
Control Recording

Select to record both sides of a call as soon as an agent 
accepts the call. 
• The recording continues until disconnecting the call. 

Note: Supervisors can listen to the recording in the 
Supervision Manager program “Review Recording” 
screen.

Disable Quality 
Control Recording

Select to ensure calls are not recorded in the campaign. 

Note: AM overrides this action > Options > Agents > 
Controls and Restrictions > Enable Automatic Recording 
of Agent feature. See page 6-7 for more information.

Play Estimated 
Wait Time

Select to inform the customer (phone or Web chat) of 
their estimated wait time. 

Exit Workgroup The Enter Workgroup action always uses the Enter 
The Exit Workgroup action. Use the Enter Workgroup 
action to request an available agent from a workgroup 
while the campaign keeps control over the call. (See 
“Enter Workgroup” on page 9-29.) 

After an agent accepts the call, the call leaves the 
campaign forever. At any time before an agent accepts 
the call, you can “cancel” your request for a workgroup 
agent and return the call to normal execution by the 
campaign by adding an Exit Workgroup action to a node.

For example, your Campaign might:

• Ask the caller to press “1” to speak to an agent. 
• Trap the caller’s keypress. 
• Route to a child DTMF node if the caller pressed “1.” 
• Use Enter Workgroup to request an available agent. 
• Check estimated wait time. 

Table 9-3. Action Menu Items and Descriptions

Item Description
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Note: If the caller waits too long, use Exit Workgroup to 
route them to another option in the campaign.

Set Script URL From the drop-down menu, select a script to display to 
the agent when CCA routes the call to them.

Set FAQ URL From the drop-down menu, select an FAQ to display to 
the agent when CCA routes the call to them.

Workgroup 
Callback

Use the Workgroup Callback action to: 
• Get the caller’s country code and phone number. 
• Send a callback request to a workgroup.

The workgroup callback action submits the callback 
request to the workgroup and then disconnects the call. 

For example, one node could have these actions:

• Play Prompt: Prompt the caller for their country code. 
• Get User Digit: Trap the country code in a variable. 
• Play Prompt: Prompt the caller for their phone number. 
• Get User Digit: Trap the phone number in a variable. 
• Workgroup Callback: Send the caller’s country code 

and phone number to the selected workgroup, and 
then disconnect the call.

Variable Country Code: Enter a variable name that is 
populated with a country code.

Variable Phone Number: Enter a variable name that 
is populated with a country code.

Current Workgroup: Only use this option if a Enter 
Workgroup action was used previously. The system uses 
whatever workgroup is selected in “Enter Workgroup.” If, 
for some reason, the campaign cannot find a valid 
“current Workgroup,” it routes the call to the system 
error choice. (See “Changing the Campaign Settings” on 
page 9-56.)

Select Workgroup: Send the callback request to the 
selected workgroup.

Table 9-3. Action Menu Items and Descriptions

Item Description
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Variable: Type a variable name that is populated with 
the ID of a workgroup. See “Using variable reference 
fields” on page 9-58.

If your variable does not contain the name of a valid 
workgroup, the campaign routes the call to the system 
error choice. (See “Changing the Campaign Settings” on 
page 9-56.)

Table 9-3. Action Menu Items and Descriptions

Item Description
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Figure 9-22. Execution Logic of the Get DTMF Action

Figure 9-22 Execution Logic of the Get DTMF Action

MyNode (an “action” node)

Some Action

Some Action
.
.
.

Get DTMF

Some Action

Some Action
.
.
.

1 2 Default

DTMF child nodes created with the
Menu Routing Conditions dialog box.

Stop execution of the actions
in the node and wait for the
caller to press a key (Wait Time)

Decrement “Number of Retries”

 “Number of Retries” == 0?

Timeout (past Wait Time) or
caller pressed a key that does 
not match a DTMF child node.

In this example, we are expecting the
caller to press “1” or “2.” 

No. 
Execute all actions
 in the node again, 
starting with the first 
action.

Yes.
Resume execution with
the action after Get DTMF.
After the last action, go to 
the Default child node. If there
is no Default node, go to the 
system error routing choice. 

Resume execution with
the action after Get DTMF.
After the last action, go to 
the child node that matches
the caller’s keypress.

Caller pressed a key that
matches a DTMF child node.
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To remove a Menu Type from a node

1. Right-click a node and select Remove Action Menu/Menu Type 
(Figure 9-23).

Figure 9-23. Select Remove Action Menu/Menu Type

Figure 9-23 Select Remove Action Menu/Menu Type

Menu Routing Conditions

Menu Routing Conditions allow a campaign to route calls based on 
meeting some condition. Campaigns can route calls based on three 
types of conditions:

• Scheduled Event: The campaign routes calls based on the 
time that the call reaches the company. 

For example, route the call one way if it reaches the company 
during business hours, and another way if it comes in when 
after the company is closed. 

• DTMF: The campaign makes a routing decision based on a 
customer keypress. 

• Regular Expression: The campaign makes routing decisions 
by testing or comparing the value of variables. For example: If 
(some variable condition) then (route to...)
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Adding a menu routing condition

Add all Menu Routing Conditions the same way:

1. Set an action on a node (Figure 9-24). 

Figure 9-24. Set an Action on a Node

Figure 9-24 Set an Action on a Node

a. You must set at least one action on a node before adding a 
menu routing condition on that node. (See “Adding Actions to 
Nodes” on page 9-22.)

b. You cannot add a menu routing condition on a node that has a 
Menu Type. A Menu Type is like a termination point that does 
its own routing. If you are using a Menu Type in a node, there 
is no point to having a Menu Routing Condition.

2. On the node where you want to add the Menu Routing, click the 
plus ( ) icon (Figure 9-25). 

Figure 9-25. Node Plus Icon

Figure 9-25 Node Plus Icon

3. In the Menu Routing Conditions dialog box (Figure 9-26), select a 
condition type and then select one or more specific conditions.
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Figure 9-26. Menu Routing Conditions

Figure 9-26 Menu Routing Conditions

Menu routing conditions and child nodes

All Menu Routing Conditions create at least two child node:

• One child for each condition to handle 

• A Default child node that the campaign executes if none of the 
other conditions are met.

Figure 9-27. Example Business Event Child Nodes

Figure 9-27 Example Business Event Child Nodes

Business Event 
child nodes
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Figure 9-28. Example DTMF Child Nodes

Figure 9-28 Example DTMF Child Nodes

Figure 9-29. Example Regular Expression Child Node

Figure 9-29 Example Regular Expression Child Node

Routing a scheduled event (business event)

1. Create one or more Business Events. (See “Creating CCA Libraries” 
on page 4-1.)

2. Select a node, which has an existing action.

3. Click the plus ( ) icon of the node (Figure 9-30). 

DTMF child nodes.

DTMF child 
nodes

Regular 
Expression child 
node
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Figure 9-30. Node Plus Icon

Figure 9-30 Node Plus Icon

4. In the Menu Routing Conditions dialog box (Figure 9-31): 

Figure 9-31. Menu Routing Conditions

Figure 9-31 Menu Routing Conditions

a. Select Scheduled Event.

b. Then, select one or more of the existing Events.

c. Click the OK button. 

The Main Campaign window (Figure 9-32) appears.

We already used the 
Action Menu to add a 
Play Prompt action on 
this mode.
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Figure 9-32. Main Campaign Window

Figure 9-32 

5. One child node exists for each Business Event selected (Figure 
9-33), plus a default node to handle unexpected conditions.

Figure 9-33. Child Nodes and Default Nodes

Figure 9-33 Child Nodes and Default Nodes
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Normally, now select each node and set either: 

• A Menu Type (see page 9-18) to route the call to some 
feature (such as another campaign)

or

• An action (or several actions) and possibly some more 
Menu Routing Conditions.

Business Event Routing Logic

When routing to a Business Event child node, the campaign executes 
the first child node where the condition is “TRUE.” In Figure 9-33, if the 
customer calls during business hours, the campaign executes the 
“During Business Hours” node. However, if someone made a mistake in 
the hours when creating the Business Events, and a customer calls 
between 4:00 pm and 5:00 pm, the campaign considers the time both 
during business hours and after business hours. In this case, the 
campaign executes the “During Business Hours” node, because it is the 
first child node whose condition was met.

Routing a DTMF (customer keypress)

1. Use the Action Menu (Figure 9-34) to add a Get DTMF action to 
a node. (See “To add an action to a node” on page 9-22.)

Usually the node uses a Play Prompt action (page 9-25) to ask 
the caller to make a selection by pressing a key, and then traps the 
caller’s keypress using the Get DTMF action (page 9-30).
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Figure 9-34. Action Menu

Figure 9-34 Action Menu

2. Click the plus ( ) icon of the node (Figure 9-35). 

CCA_AM.book  Page 42  Wednesday, July 26, 2006  2:55 PM



Campaigns 9-43

Figure 9-35. Plus Icon

Figure 9-35 Plus Icon

3. In the Menu Routing Conditions dialog box (Figure 9-36): 

Figure 9-36. Menu Routing Conditions

Figure 9-36 Menu Routing Conditions

a. Select DTMF and click one or more of the keypress buttons (1, 
2, 3, and so on).

b. Click OK. 

The Main Campaign window (Figure 9-37) appears.
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Figure 9-37. Main Campaign Window

Figure 9-37 Main Campaign Window

4. One child node exists for each DTMF keypress selected, plus a 
default node to handle unexpected conditions. 

Figure 9-38. Child Nodes and Default Nodes

Figure 9-38 Child Nodes and Default Nodes
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c. Normally, select each node and set either: 

• A Menu Type (see page 9-18) to route the call to some 
feature (such as another campaign)

or

• An action (or several actions) and possibly some more 
Menu Routing Conditions.

DTMF Routing Logic

• Figure 9-22 on page 9-34 shows the details of how a campaign 
executes a node containing a Get DTMF action and how a 
campaign selects a DTMF child node.

• Find more about the Get DTMF action on page 9-30.

• The tutorial section includes an example of setting up DTMF 
routing in a Campaign, starting on page 9-14.

Routing a regular expression

1. Select a node which has an existing action.

2. Click the plus ( ) icon of the node (Figure 9-39).

Figure 9-39. Plus Node

Figure 9-39 Plus Node

3. In the Menu Routing Conditions dialog box (Figure 9-40): 

We already used the Action Menu 
to add a Play Prompt action on 
this mode.
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Figure 9-40. Menu Routing Conditions

Figure 9-40 Menu Routing Conditions

a. Select Regular Expression.

i. Type a regular expression in the text box and then click the 
plus (+) button to add it to the list. 

ii. Enter as many regular expressions as desired. Every 
regular expression you add creates one child node.

iii. Regular expressions can use system variables, variables 
you created or assigned in some other location in the 
campaign, and new variables. Entering a variable here for 
the first time creates the variable. 

iv. The regular expression can use any of the CCA operators. 
(See page 8-8.)

b. Click OK. 

4. In the main Campaign window (Figure 9-41), one child node for 
each regular expression exists, plus a default node to handle 
unexpected conditions. 

click OK.

Type a regular expression, 
then click the plus button.

The regular expression 
appears in the list.

When finished, click OK.
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Figure 9-41. Main Campaign Window

Figure 9-41 Main Campaign Window

Normally, now select each node and set either: 

• A Menu Type (see page 9-18) to route the call to some 
feature (such as another campaign)

or

• An action (or several actions) and possibly some more 
Menu Routing Conditions.

See Figure 9-42.

CCA_AM.book  Page 47  Wednesday, July 26, 2006  2:55 PM



9-48 CallCenterAnywhereTM Administration Manager

Figure 9-42. Example: Menu Types and Actions

Figure 9-42 Example: Menu Types and Actions

Regular Expression Routing Logic

• Routing goes to the first child node whose regular expression 
evaluated to “1.” 

• If none of the regular expression child nodes evaluate to “1,” the 
campaign executes the default node. 

• If the default node was deleted, the campaign uses the system 
error routing. See “Changing the Campaign Settings” on page 
9-56.
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Deleting Nodes

• You can delete any node except the Begin node.
• When deleting a node, the campaign deletes all of the child nodes.

To delete a node

1. Click the trash can ( ) icon in the top right corner of the node. A 
confirmation message appears.

2. Click Yes to delete the node and all of its children.

Adding Child Nodes

There are three ways to add child nodes:

1. Setting an action on a node automatically creates a child default 
node (Figure 9-43). (See “Adding Actions to Nodes” on page 9-22.)

Figure 9-43. Adding an Action

Figure 9-43 Adding an Action

Adding any action to a node automatically 
creates a default child node.
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2. If a parent node already has an action, but the default node was 
deleted, replace the default node by right-clicking on the parent 
and choosing Add Default Node (Figure 9-44).

Figure 9-44. Add Default Node

Figure 9-44 Add Default Node

3. Create child nodes by adding Menu Routing Conditions (see page 
9-35.) When you add Menu Routing conditions to a node, the 
campaign creates one child node for each condition, plus a default 
node (Figure 9-45).

Figure 9-45. Add Menu Routing Conditions

Figure 9-45 Add Menu Routing Conditions

Menu routing child 
nodes (Business 
Event type) 
created with the 
Menu Routing 
Conditions dialog 
box.
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Moving Nodes

The nodes in a campaign are generally executed from top to bottom. 
To move a node, by select it and then click the up or down arrow at 
the top of the campaign window. 

However, there are several restrictions (Figure 9-46).

Figure 9-46. Restrictions on Moving Nodes

Figure 9-46 Restrictions on Moving Nodes

Searching for a Node

If the campaign is large, locate nodes by searching on their names. 

1. Type the node name in the text box in the upper left corner of the 
campaign window. 

You cannot move the Begin node

You cannot move the DTMF child nodes

If you move a parent node, all of its 
child nodes move with it.

You cannot move a default node
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In the Campaign window, the node name appears in the lower part 
of a node. The node name is in blue text for action nodes, and red 
text for Menu Type nodes. 

2. Click the Search button. 

If the system finds a node with a matching name, it scrolls the 
campaign window to the location of that node and highlights the 
matching node. 

Figure 9-47. Searching for Nodes

Figure 9-47 Searching for Nodes

Draft Campaigns and Deployed Campaigns

A draft campaign is like a development version, to experiment with 
and test without exposing to the outside world. 

A deployed campaign is like a production version, where you take a 
developed and tested campaign and release it for general use.

Each campaign type has its own icon (Figure 9-48).

Searches are case sensitive and you can use an asterisk 
(*) wildcard when searching.

Type the node name in the text box.
Click Search

The node name appears:
- Blue = Action node 
- Red = Menu Type node

Node names are Case Sensitive
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Figure 9-48. Draft and Deployed Campaign Icons

Figure 9-48 Draft and Deployed Campaign Icons

Technically, it is possible to create a draft or a deployed campaign for 
public use, since the next step is to “connect” the campaign to a 
project DNIS (see “Now, route to the Campaign from either a Phone 
Project or a Project Menu:” on page 9-17.) 

However, in practice, it is best to connect a draft campaign to a “test” 
phone number and connect a deployed campaign to a live 
“commercial” phone number.

Creating a new draft campaign

1. Create a new draft campaign by clicking the Add button in the 
Campaign List window (Figure 9-49). 

Draft Campaign = Pencil Icon

Deployed Campaign = Diagram Icon
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Figure 9-49. Campaign List

Figure 9-49 Campaign List

CCA creates all new campaigns as drafts.

Deploying a campaign

CCA deploys a campaign by making a complete, separate copy of the 
draft campaign (with the same name) and then displaying it with the 

icon. 

CCA does not automatically synchronize a draft campaign and a 
deployed campaign:

• CCA does not automatically apply changes made to an existing 
draft campaign to the deployed version. 

• CCA does not automatically apply changes to the deployed 
campaign to the draft version. 

The draft and deployed versions of a campaign are independent of 
each other.
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Although you can edit either campaign, it is simpler to edit the draft 
and re-deploy it over and over. 

However, if you make changes to your deployed version, you can copy 
it and “overwrite” the original draft with a new draft version. (See “To 
create a draft campaign from a deployed campaign” .)

To deploy a campaign for the first time

• Select the draft campaign and click the Deploy button.

To re-deploy a campaign

After making changes to a draft campaign, you can “overwrite” an 
existing deployed version by:

1. Deleting the existing deployed version.

2. Selecting the draft campaign and clicking the Deploy button.

You must delete the existing deployed version first.

To create a draft campaign from a deployed campaign

If you have made changes to a deployed Campaign and want to 
“overwrite” an existing draft version:

• Delete the existing draft version.
• Select the deployed Campaign and click the Create a Draft 

Campaign button.

You must first delete the existing draft version.
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Changing the Campaign Settings

When creating a new campaign, the New Campaign Wizard requires 
some default options. However, you can modify these settings at any 
time by clicking on the Campaign Settings link (Figure 9-50), in the 
top right corner of the screen.

Figure 9-50. Campaign Settings Links

Figure 9-50 Campaign Setting Link

Table 9-4 provides the Items and Descriptions in the General tab of the 
Campaign Settings screen.

Table 9-4. Campaign Settings - General Tab

Item Description

Name The name of the campaign appears anywhere from 
which you can select the campaign.

Campaign Settings Link
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Description The campaign description only appears in the main 
screen showing the list of all campaigns.

Table 9-5. Campaign Settings - Advanced Tab

Item Description

In Case of Any 
System Error, Go 
To:

From the drop-down menu, select a routing action for 
the campaign to take when a system error occurs. A 
system error occurs when the campaign cannot take 
any other routing action. For example, if one node is 
configured to route to another node, and the second 
node was deleted, a system error occurs and the 
campaign executes the routing action you select here.

Route system errors to one of the following areas: 

• Workgroup
• Workgroup Voicemail
• User
• User Voicemail
• Disconnect

Allow Type Ahead Select this option if you have a node (anywhere in the 
campaign) that plays a prompt and then traps the user’s 
keypress with a Get User Digit or Get DTMF action. 
This option allows the user to enter a response without 
listening to the entire prompt. 

• See “Get User Digit” on page 9-26.
• See “Get DTMF” on page 9-30.

Enter Digit Timeout Type the time to wait between key presses. (This 
applies to any place in your campaign where the 
customer must enter multiple key presses.) 

When the timeout is reached, the campaign moves on 
to the next action (which could be validating the 
customer’s entry, making a routing decision, and do on).

Table 9-4. Campaign Settings - General Tab

Item Description
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Variables in Campaigns

The rules and requirements for variables in campaigns are the same as 
they are for variables in project menus. For more information, see 
“Using Variables in Menus” on page 8-4.

Using variable reference fields

You can enter a variable name in several places (in both the Menu 
Types dialog box and the Action dialog box). 

Example: In the Menu Type dialog box (Figure 9-51), select the User 
Extension option. Then, select a user’s name or type a variable. 

Figure 9-51. Menu Type - Variable Reference Field

Figure 9-51 Menu Type - Variable Reference Field

Example: In the Action dialog box (Figure 9-52), select the Play 
Prompt option. Then, select a prompt from the drop-down menu or 
type a variable. 
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Figure 9-52. Action > Play Prompt > Prompt or Variable

Figure 9-52 Action > Play Prompt > Prompt or Variable

There are many other Menu Type and Action options that work the 
same. What is not obvious is that, when typing a variable in a 
“Variable Reference” field, the system expects the variable to have an 
internal ID number (not the name of a prompt or a Workgroup).

For example: In the CCA database, all prompts have a unique 
identifier. If you have a prompt called “Play_Welcome.wav,” the ID of 
that prompt in the database might be 71. 

So, when you put a variable in the Variable Reference field of the 
Play Prompt action, the system expects the variable to have the ID 
of the prompt (71), not the prompt name (Play_Welcome.wav). 
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Use the Set Variable to Object Action Before Entering a 
Variable in a Variable Reference Field

Find the internal ID of a workgroup, user, or prompt using the Set 
Variable to Object Action. Then assign the internal ID to a variable. 
Next, type the variable name in any Variable Reference field. 

Example 1: Using Set Variable to Object with a Menu Type

In this example, set up a variable to route from a campaign node to a 
workgroup:

1. Select a node and add a Set Variable to Object action (Figure 
9-53). 

Figure 9-53. Select Node and Add Set Variable to Object

Figure 9-53 Select Node and Add Set Variable to Object
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In Figure 9-53, we created a variable called $Sales and gave it 
the internal ID of the Workgroup “Sales_Workgroup.”

The Campaign window now looks like Figure 9-54: 

Figure 9-54. Example Campaign Window

Figure 9-54 Example Campaign Window

We added a Set Variable to Object action in the Begin node, but we 
could have done it in any node. Since we added an action to a 
node, the system also created a default child node. 

2. Right-click the default child node and choose Set Menu Type 
(Figure 9-55).

Figure 9-55. Set Menu Type

Figure 9-55 Set Menu Type
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3. In the Menu Type dialog box: 

a. Select Workgroup Extension.

b. In the Variable Reference field, type $Sales.

The Campaign window now looks like Figure 9-56: 

Figure 9-56. Example Campaign Window

Figure 9-56 Example Campaign Window

Example 2: Using Set Variable to Object with Another Action

Many actions have a Variable Reference field. As in the previous 
example:

First, use the Set Variable to Object action to initialize the variable.

Second, use that variable in any other action. 

1. Select a node and add two actions (Figure 9-57): 

a. A Set Variable to Object action. 

b. An Enter Workgroup action.
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Figure 9-57. Set Variable to Object > Enter Workgroup

Figure 9-57 Set Variable to Object > Enter Workgroup

2. Set variable to object action to find the internal ID of a workgroup 
and assign it to a variable ($Sales). 

3. Then, enter the $Sales variable into the Variable Reference field of 
the Enter Workgroup action. 

4. After initializing a variable using Set Variable to Object, use that 
variable in any Variable Reference field. 
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In this example, both actions are in the same node, but this is not 
required. The only thing you must do is make sure to execute the Set 
Variable to Object action before entering that variable in a Variable 
Reference field (meaning initialize variables before using them).

Creating the Campaign Library Objects
These two library objects are used only by campaigns: 

1. Business Events (for routing a call in a campaign based on 
the day or time the customer called) 

2. Database Connections (for running an SQL query from a 
campaign) 

Creating Business Events

CCA uses Business Events only with the campaign feature. If a 
campaign exists, use a Business Event to route a call based on the 
day, date, and time the call reached the company. 

For example, if a call reaches the company during normal business 
hours, the campaign can handle the call one way. If the call reaches 
the company after business hours, the campaign can process the call 
using a different way. 

A Business Event is actually a group of one or more sub-events. For 
example, in the same Business Event, you could define: 

• Weekday business hours.
• Saturday business hours.
• All holiday business hours for the current year. 

Think about how to define Business Events while developing 
campaigns. When adding a Business Event to a campaign, add the 
entire event so the campaign handles everything in that Business 
Event the same.

• Follow the instructions below to create Business Events.

• For how to add Business Events to campaigns, see “Menu Routing 
Conditions” on page 9-35.
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To create a Business Event

1. Select Libraries > Business Events > Add. The Add New 
Business Event screen (Figure 9-58) appears.

Figure 9-58. Add New Business Event

Figure 9-58 Add New Business Event

2. Type a name for the event (such as “Weekday Business Hours” or 
“Weekday After Hours”).

3. Then, click the plus ( ) icon. The (Add) Define Sub-event dialog 
box (Figure 9-59) appears.
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Figure 9-59. Define Sub-Event - Add One Time Sub-Event

Figure 9-59 Define Sub-Event - Add One Time Sub-Event

4. Type a name for the sub-event.

5. Click the Specific Period or Weekly button (Figure 9-60).

Figure 9-60. Add a Weekly Sub-Event

Figure 9-60 Add a Weekly Sub-Event
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6. Select the Specific Period button to create a one-time event. 

For example, if the company is closed on Memorial Day in 
2005, select 05/30/05 in both the From and To dates, then 
enter 05/30/05, as shown in Figure 9-61.

Figure 9-61. Example Specific Period Sub-Event

Figure 9-61 Example Specific Period Sub-Event

7. for an event that occurs one or more times per week, and at the 
same time, select the Weekly button.

8. Click the OK button.

a. To edit an existing event, select the event and click the Edit 
( ) icon.

b. To delete an existing event, select the event and click the 
Trash Can ( ) icon.

9. In the main Business Events screen, add more sub-events or click 
the OK (or Apply) button.

Creating Database Connections

CCA uses Database Connections only with campaigns. From a 
campaign, run an SQL query and trap the result table. 

However, before running an SQL query from the campaign, you must: 

1. (Windows only) Create an ODBC System DSN entry for the 
database to access. You must create the DSN entry on the 
machine where the CCA Statistics Server is installed.

2. Create a Database Connection pointing to the System DSN.

3. Select the Database Connection from the Campaign Action Menu 
> Database Query.
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To create a database connection

1. Select Libraries > Database Connections > the Add button.

The Add Database Connections screen (Figure 9-62) appears.

Figure 9-62. Add Database Connections Screen

Figure 9-62 Add Database Connections Screen

2. Using the information in Table 9-6, complete the Database 
Connections screen.

3. Click OK (or Apply).

Table 9-6. Database Connections Fields and Descriptions

Field Description

Name Type any name for the Database Connection.

Description Type any description for the Database Connection.

Username Type the DSN user name.

Password Type the DSN password.

Alias Type the data source name.
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10

Creating Projects 10

Create a Project to save a group of settings and attributes for 
controlling how the call center receives and routes interactions (phone, 
email, Web chat). To completely customize the way the call center 
processes different types of interactions, create multiple projects.

The same project can handle one or more interaction types. This 
chapter shows how to create a project and set it up to handle specific 
types of interactions.

After creating a project, use Project Scheduling to activate and 
deactivate projects based on the company’s needs or operating hours 
(see “Setting Up Project Schedules” on page 11-1).

Also refer to “Note About Project Routing and Reporting” on page 
15-11.

Creating a Project Definition
Create a project definition, by assigning a project name, providing a 
description, and choosing the default language the project supports.

To create the project definition

1. Click Options > Projects > Add button. 

The Add Projects screen (Figure 10-1) opens to the General Tab.
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Figure 10-1. Projects Screen: General Tab

Figure 10-1 Projects Screen: General Tab

2. Complete the Project Name fields.

Table 10-1. General Tab Fields and Descriptions

Field Description

Name Type a name describing the purpose of the project. 
For example, “Investor Inquiries” might route 
potential investors to agents ready to answer their 
questions. “After-Hours” might send callers directly 
to a greeting informing them that the office is 
closed.

Description Type a description of the details of the customers 
who reach this project, and the strategy for routing 
customers. 

Note: This text is informational only and does not 
affect the functioning of the project.
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Select a Default 
Language for this 
Project

From the drop-down menu, select the language for 
this project. CCA plays prompts recorded in this 
language for callers reaching this project. 

To change the language in which CCA plays 
prompts, route callers to touch-tone menus or 
other projects which have an alternate language. 

• For how to route a caller to a menu and switch 
the language of the project, see “Menu” on page 
8-15. 

• For how to route a caller to another project, see 
“Change Project” on page 8-18.

Phone Number (Caller 
ID)

From the customer’s perspective, this is the phone 
number CCA calls. For example, if the customer has 
caller ID, the caller ID appears. 

Always Use Caller ID Check to always use the caller’s ID as the phone 
number.

Select Contact Template 
for this Project

From the drop-down menu, select a Contact 
Template for this project. Every project uses a 
template to support features like predictive dialing 
and auto-assignment. 

Select the default System Contact Template or 
create a different template. For how to create a 
template, see page 4-39.

Note: Click the display templates icon to view the 
default templates.

Use this Project for 
Billing

When checked, the agent can select this project for 
billing when making an outbound call. 

When not checked, agent’s cannot select this 
project for billing when making an outbound call 
and the project does not appear in the IM > 
Configuration dialog box > General tab > Project 
Billing list box.

Table 10-1. General Tab Fields and Descriptions

Field Description
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Enable Project 
Interaction Limit

Interaction Limit box

Check this box to enable a limit to the number of 
calls accepted per project. Then, in the Interaction 
Limit box, type the maximum number of calls for 
each project. When the number of calls for the 
project reaches this limit, CCA plays a busy signal 
to the caller.

Enable Dial Code When checked, CCA automatically dials additional 
digits following the phone number when dialing a 
long distance number. (These additional digits are 
the dial code.) 

NOTE: Enable this feature only if the telephone 
provider (or additional hardware) requires a dial 
code.

Long Distance Password Enter a password if the phone system requires a 
password before connecting a long distance 
outbound and if you don’t want agents or 
supervisors to enter the password themselves. 

When the agent or supervisor makes a long 
distance outbound call, CCA dials the number, 
enters the password, and then connects the call.

Note: This field only accepts digits (0-9) and a 
comma character. (Use the comma character to add 
a pause before or after the password.)

Number of Digits to 
Activate Dial Code

Enter the number of digits CCA needs to require a 
dial code. For example, enter 10 so that CCA knows 
to require a dial code for all numbers containing 10 
digits or higher.

Play Project Menu After 
Disconnect

If checked, CCA routes the call to a Project Menu 
after the agent disconnects or hangs up. The agent 
should remind the caller to stay on the line after 
the agent disconnects, because, if the caller hangs 
up, routing is much more difficult. 

Use this option to route a call to a Project Menu 
where the caller can take part in a survey or simply 
offer the caller more routing options after speaking 
with an agent.

Table 10-1. General Tab Fields and Descriptions

Field Description
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3. Click Apply.

Adding Phone Interactions to a Project
Phone projects handle incoming telephone-based interactions (phone 
calls and faxes). When using phone projects, set:

• The telephone number customers use to reach the project
• Where to route the caller who reaches the project
• Verification of the caller’s number
• Which scripts and FAQ content to display for agent’s working on 

the project

To set up a project to handle phone interactions (calls and faxes)

1. Click Options > Projects. A list of projects appears.

2. Click the Project to set up and then click Edit. The Edit Project 
screen appears.

3. Click the Phone tab (Figure 10-2). 

Play Audio on Hold 
Using

Prompt
Music Broadcast

Put customers on hold in different ways:
The first way:
• CCA places a customer on hold while waiting in a 

workgroup queue. (For how to set this type of 
hold, see “Select Prompts for this workgroup” on 
page 7-17).

• The agent places a customer on hold after 
connecting to them. 

The second way:
The customer reached an agent, the agent puts the 
customer on hold, and then the customer hears: 
• Prompt: From the drop-down, select the System 

Default prompt or a custom Company Prompt.
or
• Music Broadcast: Check so that the customer 

hears a streaming music feed while on hold. 

Table 10-1. General Tab Fields and Descriptions

Field Description
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Figure 10-2. Projects Screen: Phone Tab

Figure 10-2 Projects Screen: Phone Tab

4. Check Enable Phone Project.

5. Use Table 10-2 to complete the fields in the top half of the screen.

Table 10-2. Phone Tab Fields and Descriptions

Field Description

Project Phone Number From the drop-down menu, choose (or type) a 
telephone number for customers to dial to reach 
this project.

Service Provider Edition Users: Clicking the 
Project Phone Number drop-down box shows all 
phone numbers defined for use in CCA projects by 
the Network Administrator. 
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Numbers already in use by other projects do 
not appear in the list and cannot be selected 
for use by this project. For how to define 
Project Phone Numbers for a Company, see 
“Creating List of Project Phone Numbers” on 
page 3-22.

Priority From the drop-down menu, select the priority level 
to assign to interactions reaching this phone 
project. (CCA assigns this priority to the interaction 
only if Customer Priority is not enabled. For how to 
enable Customer Priority, see Use Prompt to ask 
for customer ID below). 

CCA routes High project interactions to an agent 
before routing Low priority project interactions for 
the same workgroup

Validate phone number

No
Yes
Only if received

Click No and CCA will not prompt the caller for 
their phone number.

Use the validated telephone number to identify 
the customer for prioritization. (For how to use 
telephone number information to prioritize 
customers, see “Identifying Customers for 
Prioritization” on page 12-4.)

Click Yes or Only if not received so that CCA 
plays the file (defined for the entertelno prompt), 
which asks the caller to key-in their telephone 
number. 

If the customer does not enter any digits or 
enters fewer than the expected number (as 
defined in the ANI Validation Size option of 
the Call Center resource in the CCA Network 
Manager), then CCA interprets the phone 
number as “not received.” CCA drops the call if 
it is unable to validate the phone number after 
three attempts by the customer to supply the 
number.

Note: For this feature to work correctly, also select 
Enable Customer Priority Rating.

Table 10-2. Phone Tab Fields and Descriptions

Field Description
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Play Confirmation If Validate Phone Number is checked, then select g 
Play Confirmation so that CCA plays the customer’s 
phone number back to them. 

Use Prompt to ask for 
customer ID

Check to enable customer prioritization. 

CCA plays the specified prompt from the Company 
Prompt Library and requires the customer to enter 
an ID number. (Use the digits supplied by the caller 
to identify the customer for prioritization. For how 
to use Customer ID information to prioritize 
customers, see “Identifying Customers for 
Prioritization” on page 12-4.) 

Note: Also enable Customer Priority Routing 
(from the Phone Project Options) for this prompt to 
work.

Script From the drop-down menu, select the script to 
display to agents receiving phone interactions 
coming into this project. 

Note: 
If you route the caller to a Menu (see Play 
Project Menu After Disconnect in the 
General tab, on page 10-4), CCA displays the 
script specified in the Menu definition.

If you specify None for the script in the menu 
definition, CCA does not display a script to the 
agent (even if a script for the project is 
specified).

FAQ From the drop-down menu, choose a list to display 
to agents receiving phone interactions coming into 
this project. 

Note:
If you route the caller to a Menu (see Play 
Project Menu After Disconnect in the 
General tab, on page 10-4), CCA displays the 
FAQ specified in the Menu definition.

Table 10-2. Phone Tab Fields and Descriptions

Field Description
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6. Click the Route caller to subtab (Figure 10-3), if not already 
selected.

Figure 10-3. Route Caller To Subtab

Figure 10-3 Route Caller To Subtab

Also Note:
If you specify None for the FAQ in the menu 
definition, CCA does not display a FAQ to the 
Agent, even if you have specified a FAQ for the 
Project.

Table 10-2. Phone Tab Fields and Descriptions

Field Description
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a. Use the information in Table 10-3 to complete the fields.

7. Click the Prefix Routing subtab (Figure 10-5), if prefix routing 
groups exist for the project. (For how to create them, see “Prefix 
Routing Groups:” on page 4-77.)

a. Follow the instructions beginning with “Routing Phone 
Interactions Based on the Caller’s Number” on page 10-13.

8. Click the Options subtab (Figure 10-4).

Table 10-3. Route Caller To Subtab Fields and Descriptions

Field Description

Workgroup Click Workgroup, select a workgroup from the 
drop-down menu (so that CCA routes callers to that 
workgroup), and then click either:

Route to Workgroup Agent (so that CCA 
routes the call to the best available agent 
working in the workgroup)
Route to Workgroup Fax (so that CCA 
routes incoming fax interactions to the best 
available agent in the workgroup)

Agent Click Agent, select an agent from the drop-down 
menu (so that CCA routes callers to that agent), 
and then click either: 

Route to Agent Phone (so that CCA routes 
the call to the agent’s telephone)

Route to Agent Fax (so that CCA routes 
incoming fax interactions to the agent’s 
workstation)

Menu Click Menu and then select a menu from the 
drop-down list (so that CCA routes the caller to that 
touch-tone menu).

Note: For how to create touch-tone menus callers 
can use to navigate the call center, see “Creating 
Project Menus” on page 8-1.)

Campaign Check to route a calls to a campaign. 

Note: For more about campaigns, see Chapter 9, 
“Campaigns”.
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Figure 10-4. Options Subtab

Figure 10-4 Options Subtab

a. Use Table 10-4 to complete the Options subtab.

Table 10-4. Options Subtab Fields and Descriptions

Field Description

Menu played before 
voicemail

From the drop-down menu, select the menu to 
trigger before the caller leaves a voicemail for an 
agent. (This gives the caller a chance to re-enter 
the call center before leaving a voicemail message.) 

Menu played after 
voicemail

From the drop-down menu, select the menu to 
trigger after the caller leaves a voicemail for an 
agent. (This the caller a chance to re-enter the call 
center after leaving a voicemail message.

If you do not specify a menu, after the caller leaves 
a voicemail message, CCA will disconnect them.
Notes:

CCA plays the menu only for callers who reach 
an agent’s voicemail because the agent did not 
answer or because the agent intentionally sent 
the caller to voicemail after accepting the 
interaction. (Callers who decide leave a 
voicemail instead of waiting in a workgroup 
queue do not hear the menu. For more 
information, see “Allow customer to leave a 
voicemail” on page 7-16.)
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9. Click OK.

Notes:
The drop-down list does not show any 
selections unless you already created them. 
(See “Creating Project Menus” on page 8-1.)

Enable Follow Me Click to play the anotherlocation.wav prompt, which 
enables the caller to try to reach an agent at their 
forwarding numbers. (For how to define forwarding 
numbers for an agent, see “Activate Follow Me” on 
page 6-18.)

Note: If Follow Me numbers for the agent do not 
exist, CCA routes the caller directly to the agent’s 
voicemail.

Enable Customer Priority 
Rating

Click so that CCA uses Customer Priorities in this 
project. (To create customer priorities, see 
“Customer Priority” on page 12-1). 

The customer priority can change how long the 
customer spends waiting to reach an agent. CCA 
routes customers with higher priority to agents 
before lower priority customers (even if the lower 
priority customer reached the call center first). 

Note: If a customer reaches the call center and 
they are not in the list, CCA gives the customer the 
lowest priority by default.

Whisper Prompt to 
Agent

From the drop-down menu, select the prompt only 
the agent hears when accepting an incoming call.

Note: For how to create whisper prompts, see 
“Customizing Prompts” on page 5-1.

Use Existing Interaction 
ID

This selection does not appear for every 
application. (This is a company-specific field which 
integrates to separate database.)

Table 10-4. Options Subtab Fields and Descriptions

Field Description
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Routing Phone Interactions Based on the Caller’s Number

By adding Prefix Routing Groups to a project, CCA routes calls based 
on the caller’s phone number. 

• See “Creating an Prefix Routing Pattern Library” on page 4-77.

• See “Creating a Prefix Routing Group Library” on page 4-80.

To route a call based on the caller’s telephone number

1. Create projects to handle routed calls (see “Creating a Project 
Definition” on page 10-1 and “Adding Phone Interactions to a 
Project” on page 10-5).

2. Click Options > Projects > Phone tab > Prefix Routing subtab 
(Figure 10-5).

Figure 10-5. Projects Screen: Prefix Routing Tab

Figure 10-5 Projects Screen: Prefix Routing Tab

3. Click Enable Phone Project check box. Additional selections 
appear.

4. In the Name column, check a prefix routing group.

5. In the Projects drop-down menu, select a project. 
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a. When CCA receives a call matching the Prefix Routing Group, 
CCA routes the call to the project identified in the drop-down 
menu.

b. If your project uses more than one Prefix Routing Group, CCA 
uses the first Routing Group matching the call. 

For example: The first Prefix Routing Group matches phone 
numbers with the pattern 858* and 619* and the second 
Routing Group matches numbers with the pattern 619*. CCA 
always executes the first Routing Group.

6. Click the Route caller to tab.

Complete the Route caller to tab to select a routing action for 
calls that do not match your Prefix Routing Groups. See Step 5 on 
page 10-6 for information on completing the Route Caller to tab.

7. Click OK.

Setting up Shared-Number Phone Projects for Scheduling

Though no two Phone Projects can have the same phone number, you 
can use the same phone number for different Projects scheduled to run 
at different times (see “Setting Up Project Schedules” on page 11-1).

In this situation, customers dial the same number at all times, but the 
scheduled projects route the call differently depending on the time of 
day or the day of the week on which the call is placed.

Defining shared-number projects for scheduling requires that you 
supply the true phone number for only one scheduled Project, and that 
you initially supply None (Service Provider Edition users) or a 
“dummy” phone number (Enterprise Edition users) for the additional 
Scheduled Projects that share the same number.
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To set up shared-number phone projects for scheduling

1. Create a phone project that defines the first routing strategy to 
schedule and that specifies the phone number customers dial to 
reach the project.

2. Create additional hone projects that define alternate interaction 
routing strategies to schedule, but do not supply the actual phone 
number for the project. Instead, perform a or b (depending upon 
which edition of CCA you use):

a. For the Service Provider Edition, select None for the phone 
number.

b. For the Enterprise Edition, supply a “dummy” phone number 
(such as, add the 0 digit to the beginning of the phone number 
in step 1) for these projects.

3. Create schedules to start each of the Projects defined in steps 1 
and 2 (see “Setting Up Project Schedules” on page 11-1).

4. When defining the schedules, specify a phone number to replace 
the “dummy” or empty number while the scheduled project is 
active.

Adding Predictive Calling to a Project
A Predictive Project makes automated, outgoing calls to customers (or 
prospective customers) and connects the customer to an agent who 
has configured their IM to accept predictive interactions.

From Administration Manager, control the:

• Number of predictive calls to dial simultaneously
• Agent scripts to associate with the project
• Actions to take for each possible predictive call result
• Number of agents to leave available for inbound phone project 

calls
• Predictive project state (On or Off)

Each agent must provide an outcome for the Predictive 
Project. Therefore, make sure to update each agent to 
enable outcome reporting.
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AM support for predictive dialing is powerful and customizable. To get 
the most out of this section:

• Previously set up other types of projects (such as email, phone, 
and so on)

• Have a basic understanding of Display Templates (see page 4-38). 

• Have a basic understanding of Dialer Lists (see page 10-81).

To set up a predictive project

1. Click Options > Projects. A list of project appears.

2. Click a Project to set up and then click Edit. The Edit Project 
screen appears.

3. Select the Predictive tab.

4. Click the Enable Predictive Project check box. Additional fields 
appear. 

5. Click the Options subtab (Figure 10-6).
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Figure 10-6. Predictive Tab - Options Subtab

Figure 10-6 Predictive Tab - Options Subtab

6. From the Priority drop-down menu, select the level to assign to 
interactions reaching this predictive project. 

CCA routes interactions routed to workgroups through a “High” 
priority project to an agent before routing interactions reaching the 
same workgroup through a “Low” priority project.

7. From the Select a Workgroup drop-down menu, select the 
workgroup to handle the predictive calls.
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8. Use the information in Table 10-5 to complete the settings in the 
Options subtab.

Table 10-5. Options Subtab Fields and Descriptions

Field Description

Set the minimum number of 
agents to keep available for 
inbound calls.

Type the number of agents that must be 
available to handle inbound phone 
project calls before dialing predictive 
numbers. 

For example, if you type the number 5 
and there are six agents available, CCA 
“reserves” 5 of the agents for receiving 
inbound calls. Only 1 agent receives 
predictive dialer calls.

Set the number of maximum voice 
channels to use for this project

Type the maximum number of predictive 
numbers to dial simultaneously. (This 
number cannot be greater than the 
number of physical channels that are 
available for dialing.)

Associate this predictive project 
with these screen pops
Script
FAQ

From the Script drop-down menu, select 
the script content to display on the 
agent’s screen when successfully 
connected to a predictive call.

From the FAQ drop-down menu, select 
the FAQ content to display on the 
agent’s screen when successfully 
connected to a predictive call.

Predicting Mode Select one of the following to identify 
how CCA determines whether to add an 
agent to the pool of agents who can 
receive predictive calls:

Wrap Up: CCA adds the agent to the 
pool if the agent’s status is “Wrap Up” or 
“Available.” (This is recommended.)

Agent Availability: CCA adds the 
agent to the pool only if the agent’s 
status is “Available.”
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9. Select the Regulations subtab (Figure 10-7).

Figure 10-7. Regulations Subtab

Figure 10-7 Regulations Subtab

10. Use the information in Table 10-6 to set the ring time and tone 
detection.

Estimated Wait Time: The Dialer 
looks at the Estimated Call Handle Time, 
Wrap up and abandon rate, and then 
makes calls based on a “forecasted” 
agent availability rate.

Maximum number of retries for a 
Callback

Type the number of times that CCA will 
attempt to reach a contact record that is 
marked as a callback.

Play Notification Beep to Agent Check so that agents hear a short beep 
when they connect to a predictive call.

Table 10-6. Regulations Subtab Fields and Descriptions

Field Description

Set Ring Time From the drop-down menu, select how long (in 
seconds) to ring the contact before disconnecting.

Table 10-5. Options Subtab Fields and Descriptions

Field Description
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11. Select the Dialer Ratio tab (Figure 10-8).

Dialer ratio is defined as:

Figure 10-8. Dialer Ratio Subtab

Figure 10-8 Dialer Ratio Subtab

Select Tone Detection From the drop-down menu, select how long CCA 
waits (in seconds) to determine whether the call 
was answered by a person or an answering 
machine. (CCA determines this by running an 
algorithm.)

Note:
The more time the algorithm has to work, the 
less likely CCA will connect agents, by mistake, 
to an answering machine. 

However, if the number is too high, a customer 
answering the phone may have to wait for a 
second or two before CCA connects them to an 
agent.

Table 10-6. Regulations Subtab Fields and Descriptions

 Number of predictive calls made for a specified time
Number of predictive calls answered in that specified time
---------------------------------------------------------------------------------------------------------------------------------------------------------
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12. Use the information in Table 10-7 to complete the fields.

Table 10-7. Dialer Ratio Subtab Fields and Descriptions

Field Description

Pacing Mode 
or
Fixed Mode

Select Pacing Mode to dynamically change the rate 
at which CCA places predictive calls. This rate is 
based on a number of parameters, such as the 
failure rate of predictive call attempts and the drop 
ratio. 
OR
To set a fixed predictive call rate, choose Fixed 
Mode. (See “Fixed Mode” on page 10-22.)

Maximum Dropped Calls 
Rate

Type the maximum percentage of dropped 
predictive calls to allow.

Sampling Size for pacing 
algorithm

From the drop-down menu, select the number of 
predictive call attempts to consider when adjusting 
the pacing algorithm. 

Note: A smaller number results in consideration of 
only the most recent call attempts. A larger number 
results in consideration of more calls, but some of 
the least recent calls may not reflect current calling 
conditions.

Agent Aggressivity 
Factor

Type an Agent Aggressivity Factor (AAF) number to 
modify the dialer ratio. For example, if the dialer is 
using a ratio of 3 and the AAF is set to 0.5, the 
dialer can use a new ratio of (3 x 0.5 = 1.5). 

The AAF value must be between 0.1 and 10. The 
default setting is 0.66. The AAF works in 
combination with the Minimum Pool Size (see next 
field).

Pool Aggressivity Factor Type a Pool Aggressivity Factor (PAF) number for 
modifying the dialer ratio. For example, if the dialer 
is using a ratio of 2 and the PAF is set to 0.5, the 
dialer can use a new ratio of (3 x 2 = 6).

The PAF value must be between 0.1 and 10. The 
default setting is 0.75. The PAF works in 
combination with the Minimum Pool Size (see the 
next field).
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13. Select the Actions subtab (Figure 10-9).

Minimum Pool Size Type the Minimum Pool Size (MPS), which 
determines whether the dialer ratio is multiplied by 
the Agent Aggressivity Factor or the Pool 
Aggressivity Factor. 

• If the number of agents who can receive 
predictive calls is greater than or equal to the 
Minimum Pool Size, CCA multiplies the dialer ratio 
by the Pool Aggressivity Factor.

• If the number of available agents is less than the 
Minimum Pool Size, CCA multiplies the dialer ratio 
by the Agent Aggressivity Factor.

The MPS value must be between 0 and 99. The 
default setting is 4.

Fixed Mode Click to determine the number of predictive call 
attempts to place based on the number of agents 
available at each hour of the 24-hour day. Then, 
type the number of predictive calls to make per 
available agent during each interval of the day.

For example, if the likelihood of a successful 
predictive call at 12:00 p.m. is very low, enter a 
large number to increase the chances of a 
successful predictive call. If the likelihood of 
successful predictive calls at 7:00 p.m. (19:00) is 
very high, enter a lower number.

Table 10-7. Dialer Ratio Subtab Fields and Descriptions

Field Description
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Figure 10-9. Actions Subtab

Figure 10-9 Actions Subtab

For each condition (If Busy, If No Answer, and so on) select an 
action for CCA to take. (Notice that new fields appear after making 
a selection.)

14. Use the information in Table 10-8 to complete the fields.

Not all actions are available for a specific condition. For 
example, the only actions available for “If Busy” are “Out of 
List” or “Callback.”

Table 10-8. Actions Subtab Fields and Descriptions

Action Description

Call back Select to call the number back later. Then, from the 
drop-down menu (Days column), choose the 
number of days from today to place the call back. 
From the drop-down menu (Hour column), select 
the time to place the call back.

Call back message Select to leave the selected message and call the 
number back later. Then, from the drop-down 
menu (Days column), choose the number of days 
from today to place the call back. From the 
drop-down menu (Hour column), select the time to 
place the call back.
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15. Select the Permissions subtab (Figure 10-10).

Figure 10-10. Permissions Subtab

Figure 10-10 Permissions Subtab

Connect Agent Connect the called number to an Agent. You can 
also select an action to take if no Agent is available.

Leave message Select to leave a message. Then, from the 
drop-down menu, select the message to leave. 

Note: At least one company prompt must exist 
before using this action. (See “Creating a Company 
Prompt Library” on page 4-16.)

Out of List Select to remove the number from the predictive 
project so CCA will not dial it again.

Route to Project Select to send the call to a specific project. Then, 
from the drop-down menu, select a project.

Send Fax Select to send a fax. Then, from the drop-down 
menu, select the fax to send.

Note: At least one fax must exist before using this 
action. (See “Creating a Fax Library” on page 4-60.) 

Table 10-8. Actions Subtab Fields and Descriptions

Action Description
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a. Click a check box next to a supervisor’s name so that the 
supervisor can see this project name and dialer list when 
logging into SM. In addition, the supervisor can start and stop 
dialing for the list. 

b. Do not select a supervisor’s check box so that the supervisor 
cannot see this project when logging into SM. In addition, the 
supervisor cannot start the predictive dialing for the project.

Starting and Stopping a Predictive Project

Conditions for Predictive Dialing:

Before predictive dialing can start, you must meet several 
conditions. When starting a Predictive Project in AM, you are really 
telling the server:

• Look at all the conditions required for predictive dialing to 
start.

• If all of the conditions are true, start dialing. 

Agent Conditions

• At least 1 agent must be available to receive predictive 
calls.

• The available agent(s) must be logged into IM and logged 
into a predictive project.

Supervisor Conditions

• A supervisor must start at least one dialer list in the SM 
program.

Administrator Conditions

• The available agents must be associated with the 
workgroup the Predictive Project uses (Options > Project 
> Predictive > Select a Workgroup drop-down menu)

• Supervisors must have permissions to use a dialer list 
(Options > Projects > Predictive > Permissions)

Agent conditions can vary, depending on what actions are 
set for predictive dialing. See page 10-23 for more 
information.
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• The company must have the predictive feature enabled 
(Options > Company > Company Configuration > 
Enable Predictive check box)

• The predictive project must be started in AM (either 
manually or using a Start/Stop Schedule).

• There must be some numbers in at least one dialer list that 
are available to be called. (For example, some numbers 
which have not already been called or marked as Do Not 
Call.)

• At least one dialer list must have been uploaded to the 
project.

Company Conditions

• The company must have a predictive license. If you set up 
a project without a license, the dialer will not function 
unless the company has purchased a predictive license 
from Telephony@Work.

To manually start a predictive project

When manually starting a predictive project, CCA tries to dial all 
numbers in the project’s dialer lists. To dial only selected numbers or 
to make calls at specific times, you must create a Start/Stop Schedule. 
(See “To create a Predictive Dialing Schedule” on page 10-27.)

1. Click Options > Projects > Predictive > Start/Stop Schedule 
subtab (Figure 10-11).

Figure 10-11. Start/Stop Schedule Subtab

Figure 10-11 Start/Stop Schedule Subtab

3. Click the Manual Start/Stop button.
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4. Click the Start button.

To manually stop a predictive project

1. Select Options > Projects > Predictive > Start/Stop 
Schedule subtab.

2. Click the Manual Start/Stop button.

3. Click the Stop button.

To create a Predictive Dialing Schedule

1. Select Options > Projects > Predictive > Start/Stop 
Schedule subtab.

2. Click the Scheduled Start/Stop button.

3. Click the plus (+) icon. The Weekly Predictive Scheduling 
dialog box (Figure 10-12) appears.

Figure 10-12. Weekly Predictive Schedule Dialog Box

Figure 10-12 Weekly Predictive Schedule Dialog Box

CCA_AM.book  Page 27  Wednesday, July 26, 2006  2:55 PM



10-28 CallCenterAnywhereTM Administration Manager

4. Type a name for the schedule. 

5. Under Select a Prefix Routing Group, select to dial only those 
numbers that match a specific pattern:

a. Choose Use Phone for Matching to call people whose phone 
number matches a specific pattern.

b. Choose Use Contact Customized field for matching to call 
people that match another pattern (such as income, State, Zip 
Code, and so on).

6. From the Days drop-down menu, select the days the predictive 
dialing schedule runs (such as Monday through Friday).

7. From the Daily Hours drop-down menu, select when the predictive 
dialing schedule runs (such as 8:00 to 5:00).

8. From the Time Zone drop-down menu, select where the project 
runs. 

9. Click OK to save the schedule. 

10. In the Predictive tab, click OK (or Apply).

Examples of Predictive Dialing Schedules

These examples take you step-by-step through the entire process of 
setting up predictive dialing schedules. Going through these examples 
helps you understand how predictive schedules work and why they are 
so useful. 

Create sample dialer list in a spreadsheet program and save it in CSV 
(Comma Separated Variable) format. A sample dialer list can be as 
simple as:

For examples showing how to dial all numbers or just 
selected numbers in a dialer list, see page 10-29.
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Figure 10-13. Simple Dialer List CSV

Figure 10-13 Simple Dialer List CSV

Example 1: Dial all numbers in the dialer list(s)

This example shows how to do pattern matching against phone 
numbers.

1. Create a Prefix Routing Pattern:

a. Click Libraries > Prefix Routing Patterns > Add button. 
The Add Prefix Routing screen (Figure 10-14) appears.

Figure 10-14. Prefix Routing Pattern

Figure 10-14 Prefix Routing Pattern

a. Under Name, type Pattern to match all numbers.

b. Under Pattern, type an asterisk (*).

c. Click OK. 

2. Create a Prefix Routing Group:
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a. Click Libraries > Prefix Routing Groups > Add button. 

The Add Prefix Routing Groups screen (Figure 10-15) appears.

Figure 10-15. Prefix Routing Group

Figure 10-15 Prefix Routing Group

b. Under Name, type Group to match all numbers.

c. Click the All button (next to Select the prefix patterns for this 
Group).

d. Click OK.

3. Create a Start/Stop Schedule:

a. Click Options > Projects > Add button. The Add Project 
screen appears.

b. Click the Predictive tab > check Enable Predictive Project.
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c. Click the Start/Stop Schedule subtab, the Scheduled 
Start/Stop button, and then the plus (+) icon.

The Weekly Scheduled Start/Stop dialog box (Figure 10-16) 
appears.

Figure 10-16. Weekly Scheduled Start/Stop Dialog Box

Figure 10-16 Weekly Schedule Start/Stop Dialog Box

a. Under Name, type Dial All Numbers.

b. Under Select a Prefix Routing Group, select Use Phone for 
Matching and choose Group to match all numbers. 

c. From the drop-down menus, select the Days, Daily Hours, and 
Time Zone for the schedule.

d. Click OK to save. 

e. In the Predictive tab, click OK (or Apply).

4. Upload a dialer list. (For this example, use a simple dialer list with 
the following columns: First Name, Last Name, and Phone.)

a. Click Options > Projects > Edit button. The Edit Projects 
screen appears.

b. Click the Dialer Lists tab (Figure 10-17).
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Figure 10-17. Dial Lists Tab

Figure 10-17 Dialer Lists Tab

c. From the Select Phone Field, drop-down menu, choose Work.

d. From the Select Last Name Field drop-down menu, choose 
Last Name. 

e. From the Select First Name Field drop-down menu, choose 
First Name.

f. Click the plus (+) icon. 

The Add Dialer List dialog box (Figure 10-18) opens.
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Figure 10-18. Add Dialer List Dialog Box

Figure 10-18 Add Dialer List Dialog Box

g. In the General box, type a name for the list.

h. In the Description box, type a description for the list.

i. Click Browse to locate and load the dialer list file.

j. Click Next. 

The Dialer List dialog box refreshes to show the Mapping Dialer 
List Columns to the Contact Template dialog box (Figure 
10-19).
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Figure 10-19. Mapping Dialer List Columns to the Contact Template

Figure 10-19 Mapping Dialer List Columns to the Contact Template

k. Associate the columns in the dialer list to fields in the Contact 
Template. This is an important step because it is the only way 
AM has to understanding what the dialer list data looks like. 

This example dialer list only has three fields, so those are the 
only ones to map. 

l. Click Next, then click Upload. 

m. After the dialer list finishes uploading (Figure 10-20), click 
Close Window.

Map the “Phone” column in the dialer list to the “Work 
Phone” field in the Contact Template.
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Figure 10-20. Dialer List Tab After Uploading Dialer List

Figure 10-20 Dialer List Tab After Uploading Dialer List

The Start/Stop Schedule is complete.

Example 2: Dial only selected area codes

This example shows how to create a Start/Stop Schedule that only 
calls customers if they are in San Diego County (pattern matching 
against a phone field). This project uses the System Contact Template 
from Options > Project > Name > the Select Contact Template 
for this Project drop-down menu.

1. Create a Prefix Routing Pattern:

a. Click Libraries > Prefix Routing Patterns > Add button. 

The Add Prefix Routing Patterns screen (Figure 10-21) 
appears.

CCA_AM.book  Page 35  Wednesday, July 26, 2006  2:55 PM



10-36 CallCenterAnywhereTM Administration Manager

Figure 10-21. Prefix Routing Pattern

Figure 10-21 Prefix Routing Pattern

b. Under Name, type South San Diego 619*.

c. Under Pattern, type 619*.

d. Click OK. 

e. Create two more patterns:

i. Name: Central San Diego 858* and Pattern: 858*

ii. Name: North San Diego 760* and Pattern: 760*

Figure 10-22 shows the three prefix patterns for San Diego.

Figure 10-22. Three Prefix Patterns Covering All of San Diego

Figure 10-22 THree Prefix Patterns Covering All of San Diego

2. Create a Prefix Routing Group.

a. Click Libraries > Prefix Routing Groups > Add button.

The Add Prefix Routing Groups screen (Figure 10-23) appears.
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Figure 10-23. Prefix Routing Group

Figure 10-23 Prefix Routing Group

b. Under Name, type San Diego County Area Codes.

c. Click the All button.

d. Click OK.

3. Create a Start/Stop Schedule:

a. Click Options > Projects > Add button. The Add Projects 
screen appears.

b. Click the Predictive tab and then click Enable Predictive 
Project.

c. Click the Start/Stop Schedule subtab.
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d. Click the Scheduled Start/Stop radio button. Additional fields 
appear.

e. Click the plus (+) icon. The Weekly Predictive Schedule dialog 
box appears.

f. Under Name, type Dial San Diego County Numbers.

g. Under Select a Prefix Routing Group, select Use Phone for 
Matching and choose San Diego County Area Codes. 

h. From the drop-down menus, select the Days, Daily Hours, and 
Time Zone for the schedule.

i. Click OK to save the schedule. 

j. In the Predictive tab, click OK (or Apply).

4. Upload a dialer list. For this example, use a simple dialer list with 
the following columns: First Name, Last Name, Country Code and 
Phone.

a. Click Options > Projects > Edit button. The Edit Projects 
screen appears. 

b. Click the Dialer Lists tab. The Dialer Lists screen appears.

c. From the Select Phone Field drop-down menu, choose Work.

d. From the Select Last Name Field drop-down menu, choose 
Last Name. 

e. From the Select First Name Field drop-down menu, choose 
First Name.

f. Click the plus (+) icon. The Weekly Predictive Schedule dialog 
box appears.

g. Type a name for the dialer list.

h. Click Browse to locate to locate and load the dialer list file.

i. Then, click Next. 

The Dialer List dialog box refreshes to show the Mapping Dialer 
List Columns to the Contact Template dialog box (Figure 
10-24).

CCA_AM.book  Page 38  Wednesday, July 26, 2006  2:55 PM



Creating Projects 10-39

Figure 10-24. Mapping the Dialer List Columns to the Contact Template

Figure 10-24 Mapping the Dialer List Columns to Contact Template

j. Associate the columns in the dialer list to fields in the Contact 
Template. This is an important step because its the only way 
AM has of understanding what the dialer list data looks like. 

This example dialer list only has four fields, so those are the 
only ones to map. 

k. Click Next, then click Upload. 

l. After the dialer list finishes uploading (Figure 10-25), click 
Close Window.

Map the “Phone” column in the dialer list to the “Work 
Phone” field in the Contact Template.
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Figure 10-25. Dialer List Tab After Uploading Dialer List

Figure 10-25 Dialer List Tab After Uploading Dialer List

The Start/Stop Schedule is complete.

Example 3: Dial only selected time zones

This example shows how to create a Start/Stop Schedule that only 
calls customers if they are in a specific time zone. For this example, 
use a simple dialer list that looks like Figure 10-26.

Figure 10-26. Example 3: Dial Only Selected Time Zones

Figure 10-26 Example 3: Dial Only Selected Time Zones
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Dialing selected time zones (pattern matching against a non-phone 
field) has one more step than dialing selected phone numbers (pattern 
matching against a phone field). You must add a “pattern matching” 
field to the Contact Template the project uses.

When uploading a dialer list, map the columns in the dialer list to the 
Contact Template that the project uses: 

1. Click Options > Projects > the Add button. The Add Project 
screen appears.

2. In the General tab and from the Select Display Template 
for this Project drop-down menu, select Contact Template.

3. Mapping the columns in the dialer list to the fields in the 
Contact Template helps CCA understand the data in the dialer 
list. For example, CCA needs some way to understand that a 
column in the dialer list contains phone numbers and that is 
the column to use for dialing. 

To do pattern matching against a non-phone column in the 
dialer list (for example, dial selected time zones, rather than 
selected phone numbers): 

i. Add a new field to the Contact Template. Assign the field 
an action type of Pattern Matching.

ii. Upload the dialer list and map the string column (time 
zone) in the dialer list to the Pattern Matching field on 
the Contact Template.

This tells CCA: “I want to call customers only if they match a 
specific pattern in one of the columns of my dialer list.”

To set up a Matching Pattern

1. Create a Matching Pattern:

a. Click Libraries > Matching Patterns > Add button.

The Add Matching Patters screen (Figure 10-27) appears.
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Figure 10-27. Matching Patterns Screen

Figure 10-27 Matching Patterns Screen

b. Under Name, type Pattern for pacific time zone.

c. Under Pattern, type pacific.

d. Click OK. 

2. Create a Pattern Matching Group:

a. Click Libraries > Pattern Matching Groups > Add button. 

The Add Pattern Matching Groups screen (Figure 10-28) 
appears.
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Figure 10-28. Pattern Matching Group

Figure 10-28 Pattern Matching Group

b. Under Name, type Pacific Time Zone Pattern Group.

c. Click the All button.

d. Click OK. 

3. Create a Start/Stop Schedule:

a. Click Options > Projects > Add button. The Add Projects 
screen appears.

b. Click the Predictive tab and then click Enable Predictive 
Project.

c. Click the Start/Stop Schedule subtab.
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d. Click the Scheduled Start/Stop button.

e. Click the plus (+) icon. The Weekly Predictive Schedule dialog 
box appears.

f. Under Name, type Call Customers in Pacific Time Zone.

g. Under Select a Prefix Routing Group, select Use Contact 
Customized field for Matching and choose Pacific Time 
Zone Pattern Group. 

h. From the drop-down menus, select the Days, Daily Hours, and 
Time Zone for the schedule.

i. Click OK to save the schedule. 

j. In the Predictive tab, click OK (or Apply).

4. Modify the System Contact Template:

To keep things simple, the Project uses the System Contact 
Template. In a real call center, create a custom Contact Template 
for the Project:

a. Click Libraries > Display Templates. A list of display 
templates appears.

b. Double-click System Contact. The Edit Display Templates 
screen opens. 

c. Click the Layout tab (Figure 10-29).
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Figure 10-29. Layout Tab

Figure 10-29 Layout Tab

d. Double-click an unused field. The Defined Label dialog box 
(Figure 10-30) appears.

Figure 10-30. Defined Label Dialog Box

Figure 10-30 Defined Label Dialog Box
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i. In the right column, type Time Zone as the field name.

ii. From the Associate Label with Action drop-down menu, 
choose Pattern Matching.

iii. From the Field Name drop-down menu, choose one of the 
contacts.field0X fields not previously used. (These are 
“extra” fields CCA includes in the Contacts table for 
customer use.)

iv. Click OK to close the dialog box.

v. Click OK again to save your changes to the template. 

5. Upload a dialer list. For this example, use a simple dialer list with 
the following columns: First Name, Last Name, Phone, Country 
Code, and Time Zone.

a. Click Options > Projects > Add button. The Add Project 
screen appears.

b. Click the Dialer Lists tab. 

i. From the Select Phone Field drop-down menu, choose 
Work.

ii. From the Select Last Name Field drop-down menu, choose 
Last Name. 

iii. From the Select First Name Field drop-down menu, choose 
First Name.

iv. From the Select Pattern Matching Field drop-down menu, 
choose Time Zone.

c. Click the plus (+) icon.

i. Type a name for the dialer list. 

ii. Click Browse to locate your dialer list and then click Next. 
The Mapping screen (Figure 10-31) appears.
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Figure 10-31. Mapping the Dialer List Columns to the Contact Template

Figure 10-31 Mapping the Dialer List Columns to the Contact Template

iii. Use the Map Fields to This Contact Template screen to 
associate the columns in the dialer list to fields in the 
Contact Template. This is an important step because its the 
only way AM has of understanding what the dialer list data 
looks like. 

This example dialer list only has five fields, so those are the 
only ones to map. 

iv. Click Next and then click Upload. 

v. After the dialer list finishes uploading, click Close 
Window. Figure 10-32 shows the Dialer List tab after 
uploading the dialer list.

Map the “Time Zone” column in the dialer list to the “Time 
Zone” field in the Contact Template.
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Figure 10-32. Dialer List Tab After Uploading Dialer List

Figure 10-32 Dialer List Tab After Uploading Dialer List

The Start/Stop Schedule is complete.

Predictive Summary and Detailed

Table 10-9 shows the possible results from a predictive call attempt 
and the actions CCA takes on predictive calls.

It is possible to create a report that breaks down the number of each 
predictive call result. (For how to create the Predictive Summary 
Report, see “The Predictive Reports” on page 18-1.).

Table 10-9. Predictive Call Results and Descriptions

Result Description

Answer A person answered the predictive call.

Answering Machine An answering machine answered the predictive call.
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Table 10-10 shows the possible actions CCA takes after a predictive 
call result. 

It is possible to create a report that displays the action taken for all 
predictive calls attempted by the project. (For how to create the 
Predictive Detailed Report, see “The Predictive Reports” on page 18-1.)

Busy The predictive call resulted in a busy signal.

Error An error (no dial tone, no line available, and so on) 
prevented CCA from placing the predictive call.

Fax A fax machine answered the predictive call.

Invalid The number used for the Predictive call was out of 
service or not a valid number.

No Answer There was no answer at the number dialed.

Table 10-10. CCA Action and Description

Action Description

Call Back CCA will call this number back at the specified time.

Call not connected An answering machine answered the predictive call.

Connected The predictive call was connected with an agent.

Failed to send fax An attempt to send a fax was unsuccessful.

Fax file not found The .TIF file to be faxed could not be found at the 
specified location.

Fax sent CCA sent the specified fax to the fax machine that 
answered the predictive call.

Left message and 
will call back

CCA left the specified message on the answering 
machine that answered the predictive call and CCA will 
call this number back at the specified time.

License not 
available

No license is available to permit connection of the 
predictive interaction to an agent. (Contact the vendor 
to purchase a license for additional interactions.)

Message on the 
answering machine

CCA left the specified message on the answering 
machine that answered the predictive call.

Remove from list The number was removed from the predictive database 
and CCA will not call it again.

Table 10-9. Predictive Call Results and Descriptions

Result Description
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Running the Clean List Tool for a Do Not Call List
CCA supplies a standalone Clean List Tool for adding and cleaning the 
FTC Do Not Call (DNC) List to your CCA database.

• You can only use the Clean List Tool with a DNC list in .csv 
format. CCA does not support the XML format. 

• You must have already created at least one predictive project.

• The Clean List Tool assumes that your DNC list does not 
contain duplicate phone numbers. (The utility fails if it finds 
duplicate numbers in the DNC list. The utility does not report 
an error message if it fails on duplicate phone numbers.)

• This tool may take minutes or even hours to run, depending 
on:
• Whether you are uploading the DNC list for the first time or 

running an update. (In 2004, the DNC list had over 60 
million records.)

• The number of contacts in the Predictive Contacts table.
• The computer hardware and network speed.

To start the DNC List Clean List Tool

1. Use AM to stop the predictive projects.

2. Start a browser and enter this URL: 

http://<hostname><:port>/taw/DoNotCall/

The Login screen (Figure 10-33) opens.
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Figure 10-33. Login Screen

Figure 10-33 Login Screen

3. Enter login information:

a. If you login as Netadmin, all predictive projects for all 
companies appear. 

b. If you login as Sysadmin, all predictive projects for only your 
company appears.

To upload a DNC List for the first time

Uploading a DNC list for the first time is a two step process. 

• First, the utility uploads the entire DNC list to the CCA 
database. 

• Second, the Clean List Tool removes DNC numbers from the 
predictive project contact lists. It also removes DNC numbers 
from preview projects that do not include a predictive project.

1. Start the utility and login.

2. Select Import Initial List.
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3. In the text box, type a valid UNIX- or Windows-based file path.

Your DNC list must be on your CCA Web server machine in a 
directory that the Web server can access.

4. Click the Submit button (Figure 10-34). 

Figure 10-34. Select the Company

Figure 10-34 Select the Company

Uploading a DNC list for the first time will take several hours, at 
least. 

5. When the DNC list finishes uploading, select the Update the 
Predictive Contact Table button. 

The Predictive Contact Table screen (Figure 10-35) appears.

To ensure that the entire list is updated in the database, 
you must upload the list from the Web server, not from 
your local machine. Therefore, before uploading, save a 
copy of the list on your Web server. (If the list is not 
updated from the Web server, the entire list may not be 
updated in the database.)
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Figure 10-35. Predictive Contact Table Screen

Figure 10-35 Predictive Contact Table Screen

6. In the left pane, under Projects Available to Clean, select one or 
more predictive projects and/or preview projects (preview projects 
that do not include a predictive project appear on the list, as well) 
and then click the Update Database button. 

The utility temporarily moves the selected projects to the right 
pane, to indicate that they are being worked on. 

The utility removes any phone number in a project you selected, if 
it finds the number in the DNC list. 

After updating all of the projects you selected, they are removed 
from the Projects Being Cleaned pane.

7. Close the browser that was running the DNC utility.

The phone numbers in your predictive projects are updated.
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To upload a DNC change list

Follow these steps if you already uploaded the initial DNC list and want 
to upload a DNC change list. 

Uploading a DNC change list is a two step process: 

• First, the utility uploads the DNC change list to your CCA 
database. 

• Then, the utility removes DNC numbers from your predictive 
project contact lists and from any preview projects that do not 
include a predictive project.

1. Start the utility and login.

2. Select Upload a Change List.

3. In the text box, type a valid UNIX or Windows based file path.

Your DNC change list must be on your CCA Web server machine in 
a directory that the Web server can access.

4. Click the Submit button (Figure 10-36). 

Figure 10-36. Submit

Figure 10-36 Submit

To ensure that the entire list is updated in the database, 
you must upload the list from the Web server, not from 
your local machine. Therefore, before uploading, you must 
save a copy of the list on your Web server. (If the list is 
not updated from the Web server, the entire list may not 
be updated in the database.)
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5. After the DNC list finishes uploading, select the Update the 
Predictive Contact Table button (Figure 10-37).

Figure 10-37. Update the Predictive Contact Table

Figure 10-37 Update the Predictive Contact Table

6. In the left pane, under Projects Available to Clean, select one or 
more predictive projects or preview projects (that do not include a 
predictive project), then click the Update Database button.

The utility temporarily moves the selected projects to the right 
pane, to indicate that they are being worked on. 

The utility removes any phone number in a project you selected, if 
it finds the number in the DNC list. 

When all of the projects you selected finish updating, they are 
removed from the Projects Being Cleaned pane.

7. Close the browser that was running the DNC utility. 

The phone numbers in your predictive projects and preview projects 
(that do not include a predictive project) are updated.
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Adding Chat Interactions to a Project
Chat Projects handle Web-based chat requests so you can control:

• How to route the chat request
• The Web pages to display to the customer while CCA handles their 

chat request
• The Web page content to provide to agents for sending to 

customers

To set up a chat project

1. Click Options > Projects > click the Project to set up and then 
click the Edit button. The Edit Project screen appears.

2. Click the Chat tab and then click Enable Chat Project. The 
screen opens to the Push pages subtab (Figure 10-38).

Figure 10-38. Chat Tab - Push Pages Subtab

Figure 10-38 Chat Tab - Push Pages Subtab
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3. Using the information in Table 10-11, complete the fields.

4. Under Define Chat Push Page Sequence:

Table 10-11. Chat Tab - Push Pages Subtab Fields and Descriptions

Field Description

Priority From the drop-down menu, select the priority level 
to assign to interactions reaching this chat project. 

Note: CCA routes interactions to workgroups 
through a project with High priority to an agent 
before interactions reaching the same workgroup 
through a project with a Low priority.

Route Chat to 
Workgroup

From the drop-down menu, select the workgroup 
containing the agents who will handle chat 
requests coming into this project.

Script
FAQ

From the drop-down menus, select the script and 
FAQ URLs to display on the agent’s screen upon 
receiving the chat interaction.

First Push Page From the drop-down menu, select the Web page to 
display to the customer after they submit their chat 
request and while CCA attempts to connect the 
customer with an agent. (Typically, this content 
thanks the customer for their inquiry and indicates 
that they are in the process of being connected to 
an agent.)

In the Duration text box, enter the length of time 
(in seconds) to display the first push page before 
cycling the custom push page sequence.

Connected From the drop-down menu, select the Web page to 
display to the customer after successfully 
connecting to an agent.

Disconnected From the drop-down menu, select the Web page to 
display to the customer when the agent 
disconnects from the customer.

If No Agent Available From the drop-down menu, select the Web page to 
display to the customer if no agents are available to 
handle the chat request.

If Call Center is Closed From the drop-down menu, select the Web page to 
display to the customer if the call center is closed.
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a. From the Page Names drop-down menu, select a page to 
specify a sequence of custom push pages in addition to the 
required push pages. 

Additional pages appear in a repeating sequence while the 
customer waits to be connected to an agent (meaning after the 
First Push Page but before the Connected page appears). 
For information on creating push pages for a chat project, see 
“Creating a URL Library” on page 4-4.

b. In the Duration field, type how long to display the page (in 
seconds).

c. Click  to add the selected push page to the sequence.

d. Repeat steps 6 and 7 for all the push pages to show the 
customer waiting for a connection to an agent.

e. To remove a push page from the sequence, click the page to 
delete and click .

5. Click the Chat Response subtab (Figure 10-39).
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Figure 10-39. Chat Tab - Chat Response Subtab

Figure 10-39 Chat Tab - Chat Response Subtab

a. Click the check box next to the Intelligent Chat Template to 
assign it to this project. (See “Creating an Intelligent Chat 
Template Library” on page 4-73.)

b. To assign all templates to the project, click the All button.

c. To remove all templates from the project, click the Clear 
button.

6. Click the Collaboration subtab (Figure 10-40).

If an agent has an active chat interaction, collaboration allows 
the agent to view and change the same Web page appearing to 
the customer. 
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Figure 10-40. Chat Tab - Collaboration Subtab

Figure 10-40 Chat Tab - Collaboration Subtab

a. Click the Enable Collaboration check box to enable the 
Collaboration button in the IM Chat tab. 

This way, if the agent has an active chat interaction and clicks 
the Collaboration button, a non-modal browser spawns on the 
agent’s machine and loads the same Web page appearing to 
the customer. 

i. Collaboration only works with Web pages opened using the 
Web Chat page. For example, if the customer opens a new 
browser window by themselves, there is no way for the 
agent to see it. 

ii. Both the agent and the customer view the same Web page 
and can see changes that the other makes. If the agent 
enters text in a form field, the customer sees the text. The 
same is true if the customer enters text in a form field. 
Both the agent and customer can click on Web links and 
both will see the new page when it loads.
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iii. If the agent closes their browser window, the customer’s 
browser window does not close.

iv. If the agent moves their mouse, the customer does not 
see their own mouse cursor move. 

b. Click the Enable Collaboration Across Domain check box. 

i. For security, browsers do not allow scripting across 
domains. If the agent tries to load a page that is not on 
the same domain as IM, the agent can view the page but 
cannot make any changes to the page. To get around this 
security feature, click this check box and re-save the 
Request a Chat page. Therefore, the next time the 
customer opens the chat page, the customer can also 
download an ActiveX dll. This allows the agent to interact 
with any Web page that the customer opens through the 
chat page, regardless of the domain.

ii. Normally, when a customer opens the chat page, they see 
a single browser window that is split into two frames. The 
frame on the left contains the chat screen. The frame on 
the right displays a Web page (such as a chat push page). 
By enabling Collaboration Across Domains, the customer 
has two separate browser windows; one for the chat 
screen, and one for the chat push page.

7. Click OK.

You can edit your Web pages to enable or disable 
collaboration for individual page elements. For example, 
remove collaboration on a specific text box to prevent an 
agent from viewing a password entered by a customer. 
See “Collaboration and Push Pages” below.
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Collaboration and Push Pages
Collaboration allows an agent and a customer to view and interact with 
the same Web page at the same time during a chat session. For 
example, an agent can push a Web page so that it appears on the 
customer’s screen, and (using collaboration) watch or help as the 
customer navigates a Web site, fills out forms, and so forth. 

Collaboration essentially means that CCA updates changes to the 
agent’s Web page in the customer’s Web page, and vice versa. For how 
to enable the collaboration feature, see “To set up a chat project” - 
Step 6 on page 10-59.

Security Settings

The collaboration feature assumes that both agents and customers 
have their Internet Explorer (IE) security settings at default levels for 
both the local intranet (Figure 10-41) and the Internet (Figure 10-42).

• The IE default setting for the Local Intranet is “Medium-Low.” 

• The IE default setting for the Internet is “Medium.” 

Figure 10-41. IE Settings for Local Intranet

Figure 10-41 IE Settings for Local Intranet
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Figure 10-42. IE Settings for Internet

Figure 10-42 IE Settings for Internet

Using Collaboration

In addition to enabling the collaboration feature in AM, edit the 
element IDs on your Web pages to support collaboration. Also enable 
or disable collaboration individual elements on the Web page. 

1. Any element (text box, radio button, and so forth) to update 
during collaboration must have a unique, alphabetic or 
alphanumeric ID. Refer to Table 10-12 for a description of invalid 
and valid elements. 

Table 10-12. Invalid and Valid Elements

Element ID Description

ID=”123” Not a valid ID because it does not contain any 
alphabetic characters.

ID=”A”
ID=”A123”
ID=“1ABC”
ID=“ABC1”
ID=“A1BC”

These are all valid IDs.
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2. Disable collaboration on a specific element by typing a negative 
number anywhere in the ID string.

For example, if you disable a text box element, the customer can 
enter data in that field, but the data will not appear on the agent’s 
screen (and vice versa). 

Disabling collaboration on an element is useful if it contains 
sensitive information, such as a password or Social Security 
number. Table 10-13 shows the differences between element 
types. 

Chat Request Forms

An important component of the chat project is the chat form 
customers use to request a chat with an agent. The Chat Request Form 
appears in the customer’s browser when they click the chat button or 
chat link on your company’s Website. Use AM to generate the code 
that produces the Chat Request Form.

Table 10-13. Example Element IDs and Descriptions

Element ID Description

ID=”-AB”
ID=”AB-”
ID=”A-B”

In these examples, CCA updates the field 
(collaboration enabled) because the IDs do not 
contain a negative number. 

ID=”-1AB”
ID=”A-123B”
ID=“ABC-3”

Disable collaboration (CCA will not update the field) 
by typing a negative number anywhere in the ID 
string.

When creating a Chat Request Form, the URL to access the 
AM login page must include a fully qualified host name 
(such as http://myserver.mydomain.com/). If you 
accessed AM through a URL alias or through an abbreviated 
host name (such as //myserver/), your customers will be 
unable to access your form.
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To create a customer chat window

1. Open the Chat Project created in “Adding Chat Interactions to a 
Project” on page 10-56.

2. Click the Create Page... button. 

AM displays a sample chat request form template (Figure 10-43).

Figure 10-43. Sample Chat Request Form Template

Figure 10-43 Sample Chat Request Form Template

3. Click File > Save As... and save the file to your local drive.

4. Edit and save the .HTML file created so that the customer Chat 
Request Form meets the company’s specifications.

5. Copy the .HTML file to the Web server providing call center 
services for your company. 

You must store the file in the root folder of the Web server, 
or in a subdirectory of the root folder.

Click File

Click Save As...
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6. Create a link on your company’s Web page to the .HTML file on the 
Web server.

Now, when a customer clicks the link, the Chat Request Form appears 
in the customer’s browser, allowing the customer to request a chat 
with an agent working on the project.

Adding Email Interactions to a Project
For agents and supervisors to receive email interactions, you must set 
up at least one project for email. 

To set up an email project

1. Click Options > Projects > click the Project to set up > click the 
Edit button. The Edit Project screen appears.

2. Click the Email tab and then check the Enable Email Project 
check box. The Email Servers Subtab screen (Figure 10-44) 
appears.

If agents and supervisors are receiving email spam, limit 
spam emails by using filtering rules and third party 
software on your POP3 servers.
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Figure 10-44. Email Tab - Email Servers Subtab

Figure 10-44 Email Tab - Email Servers Subtab

3. Use the information in Table 10-14 to complete the fields.

Table 10-14. Email Servers Subtab Fields and Descriptions

Field Description

Email address for 
this Project

Type the address customers write to reach this call center 
project. 

Note: Do not use an email client to access the project 
email address. Doing so prevents CCA from accessing the 
account to route customer emails to agents.

Route Email to 
Workgroup

From the drop-down menu, select the workgroup where 
CCA will route the emails.
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4. Click the Options subtab (Figure 10-45).

Priority From the drop-down menu, select the priority level to 
assign to interactions reaching this email project. 

Note: CCA routes interactions (routed to workgroups 
through a project) with High priority to an agent before 
routing interactions (reaching the same workgroup 
through a project) with a Low priority. 

Script
FAQ

From the drop-down menus, select the script and FAQ 
URLs to display on the agent’s screen upon receiving the 
email interaction.

Select POP3
All
Clear
POP3 Icon

Check the servers to handle incoming email. Click All to 
select all the POP3 servers. Click Clear to clear all the 
check boxes. Click the POP3 icon to create a new POP3 
sever and add it to the POP3 Library. (For how to create 
POP3 servers, refer to “Creating a POP3 Server Library” on 
page 4-66.)

CCA employs the servers using a round-robin method. If 
one server is busy, CCA uses the next selected server, and 
so on.

Note: If one or more POP3 servers do not appear in the 
list, make sure you did not specified them for use in 
another project. POP3 servers cannot be shared among 
projects.

Select SMTP 
Group

From the drop-down menu, select the SMTP Server Group 
to handle outgoing email for this project. CCA employs the 
servers in the selected group using a round-robin method. 
If one server is busy, CCA uses the next server, and so on. 
(For how to create an SMTP Server group, see “Creating 
an SMTP Server Group Library” on page 4-64.)

Table 10-14. Email Servers Subtab Fields and Descriptions

Field Description
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Figure 10-45. Email TAb - Options Subtab

Figure 10-45 Email Tab - Options Subtab

5. Using the information in Step 10-15 on page 10-69, complete the 
fields.

Table 10-15. Options Subtab Fields and Descriptions

Field Description

Select Automated Email 
Response

From the drop-down menu, select a number for the 
Automated Email Response to send to the 
customer. CCA sends the response to the customer 
only after the downloading the email message from 
the POP Server. Messages received by the POP 
Server, but not yet downloaded into CCA do not 
receive an acknowledgment of receipt.

If Agent does not reply 
to an Email, forward to 
another Agent after ___

Type the number of hours to wait for an agent to 
reply to an email interaction before forwarding the 
interaction to another agent.
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6. Click the Select Intelligent Email Templates subtab (Figure 
10-46).

Use this subtab to associate Intelligent Email Templates with an 
Email Project. (For how to create these templates, see “Creating 
an Intelligent Email Template Library” on page 4-70.)

Allow Agent to Respond 
Directly to the 
Customer___

Check to allow CCA to send email correspondence 
directly between the agent and the customer. This 
provides a means for the customer to communicate 
with the same agent on all subsequent emails.

Note: Selecting this option removes prevents CCA 
from setting alarms on late agent response times 
and also eliminates recording, tracking of client 
history, and reporting functionality (after the first 
reply to the customer) for this project.

Show customer email 
address to Agent

Check to allow agents receiving email interactions 
to see the email address of the customer in IM, see 
it in the FROM address in their email client, and to 
allow CCA to automatically record the email 
interaction in the History for the email customer’s 
contact record (if one exists). 

Clear this option so that CCA will not show the 
agents the customer’s email address in IM (shows 
only “ACD Email”) and so that the agents cannot 
see it in the FROM address in the agent email 
client. (Agents can still reply to the customer, but 
they will not know the destination address of the 
reply.)

Note: If you select Allow Agent to Respond 
Directly to the Customer, then CCA 
automatically selects this option by default.

Table 10-15. Options Subtab Fields and Descriptions

Field Description
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Figure 10-46. Email Tab - Select Intelligent Email Templates Subtab

Figure 10-46 Email Tab - Select Intelligent Email Templates Subtab

7. Check Intelligent Email routing.

8. Using the information in Table 10-16, complete the fields.

Table 10-16. Select Intelligent Email Templates Subtab Fields and 
Descriptions

Field Description

Route Template 
response to customer if 
accuracy is greater than 
or equal to ____%

Click to automatically send the Automated Email 
Response associated with the highest-scoring 
Intelligent Email template (see “Creating an 
Intelligent Email Template Library” on page 4-70) 
with a score higher than the value you specify in 
the percentage box. 

(For an description of how CCA calculates scores 
for each Intelligent Email template, see “Example 
Intelligent Template Example” on page 4-72.)
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9. Click OK.

Adding Web Callback Interactions to a Project
Web Callback Projects handle Web-based customer requests for a 
return phone call and control:

• How to route the call-back request

• The Web pages to display to the customer

• The Web pages to provide to agents for sending to customers

To set up a Web callback project

1. Click Options > Projects > click the Project to set up > click the 
Edit button. The Edit Project screen appears.

2. Click the Web Callback tab and then click Enable Web Callback 
Project check box. The Web Callback screen (Figure 10-47) 
appears.

If no templates yield an accuracy level above the 
specified value, CCA routes the email to an agent in 
the specified workgroup with a scored list of 
suggested responses based on all of the Project’s 
Intelligent Email templates.

Route Email to agents 
with suggested 
responses

Choose to always route the email to an agent in the 
specified workgroup with a scored, editable list of 
suggested responses based on all the Project’s 
Intelligent Email templates.

Select Intelligent Email 
Templates

Check to assign an email to the project. Click All to 
select all the templates. Click Clear to clear all the 
check boxes. Click the Email icon to create a new 
template to add to the library. (For how to create a 
new email template, see “Creating an Intelligent 
Email Template Library” on page 4-70.)

Table 10-16. Select Intelligent Email Templates Subtab Fields and 
Descriptions

Field Description
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Figure 10-47. Web Callback Tab

Figure 10-47 Web Callback Tab

3. Using the information in Table 10-17, complete the fields.

Table 10-17. Web Callback Fields and Descriptions

Field Description

Priority From the drop-down menu, select the priority level 
to assign to interactions reaching this Web callback 
project. CCA routes interactions (routed to 
Workgroups through a Project) with High priority to 
an agent before routing interactions (reaching the 
same workgroup through a project) with a low 
priority. 

Route Web Callback 
request to this 
Workgroup

From the drop-down menu, select the workgroup 
containing the agents that will handle Web callback 
requests coming into this project.
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4. Click OK.

Allow Agent to 
Reschedule a Web 
Callback

Check to allow agents to reschedule a callback 
after ending the call. 

If unchecked, the agent will not have the option of 
rescheduling the callback. 

Note: If checked, you must re-create and redeploy 
the Web callback page. 

Script From the drop-down menu, select the script to 
display to agents receiving Web callback requests 
for this project.

FAQ From the drop-down menu, select the FAQ content 
to display to agents receiving Web callback 
requests for this project.

Call Center is open From the drop-down menu, select Web page to 
display after CCA successfully delivers the Web 
callback request to an agent. (For how to set 
business hours for your company, see “Setting 
Company Business Hours” on page 3-20.)

Call Center is closed From the drop-down menu, select Web page to 
display during non-business hours or if no agents 
are logged into CCA. (For how to set business 
hours for your company, see “Setting Company 
Business Hours” on page 3-20.)

Phone Number is 
Blocked

If a customer’s phone number is blocked and the 
customer enters that number in the “Request a 
Callback” page and clicks the “Call Me!” button, the 
Web page you select here appears in the 
customer’s browser window. 

You can add a customer’s phone number to the 
blocked list using AM (see “Creating a Call Blocking 
List” on page 14-2), but you can also add numbers 
to the blocked list using IM and SM.

Table 10-17. Web Callback Fields and Descriptions

Field Description
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Web Callback Request Form

An important part of a Web callback project is the online form 
customers use to request a callback from an agent. The Callback 
Request Form appears in the customer’s browser when they click the 
“Request a callback” button or link on the company’s Website. You can 
use AM to generate the code that produces the Web callback request 
form.

To create a customer Web Callback Request form

1. Open the Web Callback Project you created on page 10-72.

2. Click the Create Page button. A sample customer Callback 
Request Form (Figure 10-48) appears. 

Figure 10-48. Sample Web Callback Request Form Template

Figure 10-48 Sample Web Callback Request Form Template

When creating a Web Callback Request Form, the URL to 
access the AM login page must include a fully qualified host 
name (such as http://myserver.mydomain.com/). If 
you accessed AM using a URL alias or an abbreviated host 
name (such as //myserver/), your customers will be 
unable to access the form you create.

Click File

Click Save As...
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3. Click File > Save As... save the file to your local drive.

4. Edit and save the .HTML file so that the Callback Request Form 
meets your company’s specifications.

5. Copy the .HTML file to the Web server providing call center 
services for the company. 

6. Create a link on the company’s Web page to the .HTML file on the 
Web server.

Now, when a customer clicks the link, your Callback Request Form 
appears in the customer’s browser, allowing the customer to enter and 
send the information necessary for an agent to call them back.

Selecting Fax Responses for the Project
Select the fax responses to provide agents working on a project.

To select fax responses for a project

1. Click Options > Projects > click the Project to edit > click the 
Edit button. The Edit Project screen appears.

2. Click the Fax Responses tab (Figure 10-49).

You must store the file in the root folder of the Web server, 
or in a subdirectory of the root folder.
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Figure 10-49. Fax Responses Tab

Figure 10-49 Fax Responses Tab

a. Select the Fax Response for this project by clicking the box 
next to its name.

b. To assign all faxes to the Project, click the All button.

c. To remove all faxes from the Project, click the Clear button.

3. Click OK.
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Selecting Interaction Outcomes for the Project
Tracking the results of call center interactions helps measure and 
compare the performance of agents. Enable the Outcomes feature (see 
“Require outcome” on page 6-10) to create reports for analyzing the 
results of all interactions handled by agents.

• Set Outcomes as a requirement for agents (Options > Agents 
> Controls and Restrictions tab > Require Outcome check 
box).

• Create one or more outcomes (Libraries > Outcomes).

• Add required outcomes to the project (see below).

To add outcomes to a project

1. Click Options > Projects > click the Project to edit > click the 
Edit button. The Edit Project screen appears.

2. Click the Outcomes tab (Figure 10-50).

Figure 10-50. Outcomes Tab

Figure 10-50 Outcomes Tab
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a. To select an outcome for this project, click the check box next 
to its name.

b. To assign all outcomes to the project, click the All button.

c. To remove all outcomes from the project, click the Clear 
button.

3. Click OK.

Overriding Workgroup Prompts for the Project
When CCA routes a phone customer to a workgroup queue, CCA greets 
the caller and keeps them informed with recorded prompts while they 
wait to be connected to an agent. Identify the workgroup prompts to 
play for the caller when setting up the workgroup (see “Setting 
Workgroup Options” on page 7-14).

For each project, AM lets you override the default prompts for the 
workgroups. Overriding the default workgroup prompts allows you to 
control the prompts that customers hear when they reach workgroups 
through the project.

To override workgroup prompts for a project

1. In AM > click Options > click Projects > click the Project to edit 
> click the Edit button. The Edit Projects screen appears.

2. Click the Workgroup Prompts tab (Figure 10-51).
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Figure 10-51. Workgroup Prompts Tab

Figure 10-51 Workgroup Prompts Tab

3. Using the information in Table 10-18, complete the fields.

Table 10-18. Workgroup Prompts Tab Fields and Descriptions

Field Description

Select Workgroup Click the workgroup to override prompts for, if the caller 
reaches the workgroup through this project.

Intro From the drop-down menu, select the initial greeting 
CCA plays the caller when entering the workgroup.

Ring From the drop-down menu, select the prompt CCA plays 
when an agent becomes available and CCA is in the 
process of connecting the caller to the agent.
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4. Click OK.

5. Repeat steps 2 to 6 to customize the prompts in other projects.

Adding Dialer Lists
A Dialer List is a CSV (comma separated variable) file that contains the 
names and phone numbers of customers to call in a predictive project. 
There are only a few restrictions on what a dialer list looks like:

• The Dialer List must be in CSV format.

• The Dialer List must have at least one column containing 
phone numbers and at least one column for the country code.

Adding a Dialer List to a Project consists of

1. Telling CCA where the CSV file resides on the hard drive.

2. Set the Select Fields list boxes (see below). 

3. Map the columns in the Dialer List to the fields in the Contact 
Template the project uses. 

Hold From the drop-down menu, select the message CCA 
plays for the caller while the caller waits to be 
connected to an agent. 

Note: CCA does not play this prompt until after the 
prompt selected for Music finishes playing.

Music From the drop-down menu, select the prompt CCA plays 
immediately after the Intro message while the caller 
waits to be connected to an agent. 

When the Music prompt finishes playing, the Hold 
prompt plays. CCA then cycles the Music and Hold 
prompts continuously until an agent becomes available.

Table 10-18. Workgroup Prompts Tab Fields and Descriptions

Field Description
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About Contact Templates

Every project uses a Contact Template. 

Information about templates in general (and particularly Contact 
Templates) begins with “Creating New Display Templates” on page 
4-38. It will be easier to understand this section if you are already 
familiar with how Contact Templates work.

CCA associates a Contact Template with a project to format the contact 
information that agents and supervisors use and to support other 
features (such as auto-assignment). Refer to the Interaction Manager 
User’s Manual, Contacts Management section for more information.

Select the Contact Template for a project from the Name tab:

Options > Projects > Name tab > Select Contact Template 
for this Project

When uploading a dialer list to a project, you must give AM some 
information about what the dialer list looks like. Do this by associating 
(or mapping) the columns in the dialer list with fields in the Contact 
Template. This mapping allows AM to do some intelligent processing of 
the dialer list. For example, mapping allows CCA to know that one or 
more columns in the dialer list contain phone numbers, which are 
processed differently than other data. 

The “Select Field” List Boxes

Six list boxes appear at the top of the Dialer List tab. The settings in 
these boxes apply to all of the dialer lists in your Project.

1. Select Phone Field

The phone number to call during predictive dialing. 

For example, the dialer list may have one column for the 
customer’s work phone and another column for their home 
phone. Use this box to tell CCA which number to call during 
predictive dialing.

2. Select Pattern Matching Field: 

The drop-down menu provides all fields in the system contact 
template. You can select any field to use for pattern matching.
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3. Select Last Name Field 

4. Select First Name Field

These two fields point to the customer’s first and last names and 
make predictive dialing more efficient.

When an agent is connected to a predictive call, the customer’s 
entire record appears to the agent. It is not efficient to retrieve all 
customer information before the agent takes the call, since there 
might be no answer, a busy signal, or so on. However, when the 
agent does take a call, it might take a few seconds to retrieve the 
entire customer record. 

To make efficient use of memory and to give the agent some 
information up front, select First Name and Last Name in these 
fields. The agent can always see the name of the customer being 
dialed. When they are connected to the customer, CCA displays the 
rest of the record.

5. Select Company Name Field

If the dialer list has a company name field, select it here. CCA 
displays the company name of the contact to the agent when they 
receive a predictive or preview call. 

6. Other Field

The “Other” field does two things: 

a. It takes any column of data from the dialer lists and loads it 
into the Contacts table in the CCA database. 

b. During predictive/preview dialing, CCA passes the current 
value of this “Other” field as a parameter to IM, where it can 
be displayed.

Below are examples of how the Select Phone Field list box works and 
how the Other Field list box works. Find additional examples in the 
“Examples of Predictive Dialing Schedules” on page 10-28.

Example 1: Using the Select Phone Field list box

1. Click Options > Projects > Name tab. 

2. In the Select Contact Template for this Project field, make sure to 
select System Contact. The project is now using the default 
System Contact Template. 
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3. Click Options > Projects > Predictive > Dialer List subtab. 

4. From the Select Phone Field drop-down menu, select the phone 
location (Figure 10-52).

Figure 10-52. Three Entries in List Box

Figure 10-52 Three Entries in List Box

5. Open the System Contact Template. 

a. Click Libraries > Display Templates. A list of templates 
appears.

b. Double-click on System Contact. The Edit Display Templates 
screen appears.

c. Click the Layout tab (Figure 10-53).

Unless you edited the System Contact Template, three 
entries should appear: Cell, Home, and Work.
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Figure 10-53. System Contact Template - Layout Tab

Figure 10-53 System Contact Template - Layout Tab

The System Contact Template has three fields for phone numbers: 
Work, Cell, and Home. 

These same fields appear when clicking the Select Phone Field in 
the Project > Dialer List tab.

6. Double-click the Work field. 

The Defined Label dialog box (Figure 10-54) appears. 

CCA_AM.book  Page 85  Wednesday, July 26, 2006  2:55 PM



10-86 CallCenterAnywhereTM Administration Manager

Figure 10-54. Defined Label Dialog Box

Figure 10-54 Defined Label Dialog Box

Notice that the Associate Label with Action list box is set to 
Phone. This tells CCA to give special attention to the data in this 
field. With an Action Type of Phone, CCA knows this field holds a 
phone number that it can dial.

How the Dialer Lists tab > Select Phone Field works

1. It goes to the Contact Template for this project.

2. It finds all fields in the template with an Action Type of Phone.

3. It puts those fields in the Select Phone Field list box.

The other “Select Field” list boxes in the Dialer List tab work the 
same way: Select First Name takes all the fields from the Contact 
Template with an Action Type of “First Name.” Select Last Name 
takes all the fields from the Contact Template with an Action Type 
of “Last Name,” and so on.

CCA works this way for two reasons: 
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1. The dialer list might have more than one column for phone 
numbers (such as Work and Home), but CCA must know which 
column to use for dialing. 

2. The same project might have several dialer lists with different 
formats. You might want CCA to call numbers from column 3 in 
the first dialer list and numbers from column 4 in the second 
dialer list. 

The mapping feature, along with the “Select Field” list boxes, are 
two of the ways to control how to set up dialer lists.

Example 2: Using the “Other” Field list box

Use the “Other” Field list box to add any column from the dialer list to 
the database. During predictive dialing, CCA takes the value of the 
“Other” field from the current contact and pass it to IM through a 
custom Web page you create yourself. Once the Web page receives the 
“Other” value, it displays it, performs a database search on the value, 
and so on.

1. Create a custom web page:

a. Your custom Web page must have code that can extract the 
parameters CCA passes to it.

b. Here is some sample code that parses and displays all of the 
parameters CCA passes to IM during Predictive dialing:

<html>
  <head>
    <meta http-equiv=”pragma” content=”no-cache”>
    <meta http-equiv=”Cache-Control” content=”no-cache, 

must-revalidate”>

    <title>Preview Params Test Page</title>

  <script language=”JavaScript”>
     function getArgs()
     {
       var retVal = ‘’;
       var args = new Object();
       var query = location.search.substring(1);
       var pairs = query.split('&');
       for(var i = 0; i< pairs.length; i++)
       {
          str = pairs[i] + '\n';
          retVal += str;
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       }
       textAreaArgs.value=retVal;

}
  </script>
  </head>
  <body onload=”getArgs()”>

    <TEXTAREA wrap=”off” id='textAreaArgs' cols=”50” 
rows=”30” width=”100%”></TEXTAREA>

  </body>
</html>

2. Create a Library URL that points to your custom Web page: 

a. Select Options > URLs, then click the Add button.

b. In the Add URL screen: 

i. Type a name and description for the custom Web page.

ii. In the URL text box, type the path to the custom Web 
page.

iii. Under Select the type of URL, click the Script check box.

iv. Click OK to save the changes. 

3. Add your custom web page to the Predictive Project:

a. Select Options > Projects > Predictive tab > Options 
subtab.

b. In the Script list box, select the URL created in the previous 
step. 

4. Upload your dialer list:

a. See “To upload a Dialer List” on page 10-90 for complete 
details.

b. As an example, upload a dialer list that looks like Figure 10-55.
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Figure 10-55. Uploaded Dialer List

Figure 10-55 Uploaded Dialer List

In this example, the Customer ID is a unique identifier for tracking 
customers in some external (non-CCA) database.

5. Set the “Other” Field:

a. Select Options > Projects > Dialer Lists tab.

b. In the Other Field list box, select Customer ID. 

6. Start Predictive Dialing:

a. See “Starting and Stopping a Predictive Project” on page 
10-25.

b. When a supervisor starts to use the dialer list, CCA calls the 
first number. 

c. If the call connects to an agent, CCA pushes the custom Web 
page to IM > Predictive tab > Scripts pane and passes it the 
value of the “Other” field for the current contact as a 
parameter (along with several other parameters). In this 
example, CCA passes the values in the Customer ID column of 
the dialer list.

d. After the Web page parses and extracts the value of the 
“Other” field, it can take any other action. For example, the 
Web page might look up the Customer ID in some non-CCA 
database and then spawn another browser window with more 
information about that customer. 
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To upload a Dialer List

Before uploading a dialer list: 

• A dialer list, in CSV format, with at least one column of phone 
numbers must exist.

• A company and a project must exist.

1. Click Options > Projects > Dialer Lists tab.

2. Click the plus (+) icon. The Add Dialer List dialog box appears.

a. Type a name for the dialer list. 

b. Click the Import New List > Browse button and then find 
the CSV file.

3. Click the Next button. The Map Fields to This Contact Template 
screen (Figure 10-57) appears.

Associate the columns in the dialer list to fields in the Contact 
Template. This is an important step because its the only way AM 
has of understanding what the dialer list data looks like. 

This example dialer list (Figure 10-56) only has three fields: 
fname, lname, and business phone number. So, those are the only 
fields to map.

Figure 10-56. Fields to Map

Figure 10-56 Fields to Map

Notice in Figure 10-57 that:

• The gray fields are from the Contact Template the project uses.

• The fields in the list boxes are from the columns in the dialer 
list. 
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a. Click the list box next to First Name. All of the columns in the 
dialer list appear.

Figure 10-57. Mapping Dialer List Columns to the Contact Template

Figure 10-57 Mapping Dialer List Columns to the Contact Template

As an example, refer to Table 10-19 to make the following map:

Table 10-19. Contact Template Fields and Corresponding Dialer List 
Columns

Contact 
Template 
Field

Dialer List Column

First Name fname

Last Name lname

Work business phone number
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Figure 10-58. Mapping Dialer List Columns to the Contact Template

Figure 10-58 Mapping Dialer List Columns to the Contact Template

b. Click Next and then click Upload. 

c. After the dialer list finishes uploading, click Close Window. 
The CSV file appears in the Dialer List tab (Figure 10-59).

CCA copies only the fields that you map from the dialer list 
CSV file into the CCA database. You can map as many or as 
few fields as you wish (as long as you map at least one 
phone field). If you do not map a field, agents cannot see it 
when they connect to a predictive call.

The names of the columns in the dialer list are not 
important. What matters is the data in those columns and 
which Contact Template fields you map them to.

Each phone number field in the Mapping dialog box has two 
parts. The first part is for a dialing prefix (such as 1) - if a 
separate column exists in the dialer list. The second part is 
for the main part of the number (such as 5551212).
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Figure 10-59. Dialer List Tab After Uploading Dialer List

Figure 10-59 Dialer List Tab After Uploading Dialer List

4. Set the Select Field list boxes at the top of the Dialer List tab. 
(For how to set these fields, see “The “Select Field” List Boxes” on 
page 10-82.)

The Dialer List upload is complete.
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11

Setting Up Project Schedules 11

Set up Project Schedules for handling and routing interactions 
differently during different times. Use Project Schedules to tailor call 
routing strategies to reflect the company’s business practices over the 
course of a week or over a 24-hour day.

Before creating Project Schedules, projects must already exist. For 
how to set up projects, see “Creating a Project Definition” on page 
10-1. 

Creating Project Schedules
Create, edit, and implement Project Schedules from AM.

To create a project schedule

1. Click Options > Schedules. A list of schedules appears.

2. Click the Add button. 

The Add Schedules screen (Figure 11-1) appears.
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Figure 11-1. Add Schedules Screen

Figure 11-1 Add Schedules Screen

3. Using the information in Table 11-1, complete the fields.

Table 11-1. Add Schedule Fields and Descriptions

Field Description

Schedule Name Type a name for the schedule.

Description Type a description (or purpose) of this schedule.

Select default 
Project

From the drop-down menu, select the Project definition 
to disable when the Scheduled Project (see below) starts.

Phone From the drop-down menu, select the country code and 
phone number to assign to the Scheduled Project (see 
next field). 

Note: This phone number replaces the “dummy,” or 
empty phone number supplied when defining this project 
(see “Setting up Shared-Number Phone Projects for 
Scheduling” on page 10-14).
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4. Click Apply to save the schedule.

5. Repeat steps 2 though 4 to finish creating schedules.

6. Click OK.

CCA runs the schedule during the specified times until another 
schedule starts another project or until you delete the schedule.

Select Scheduled 
Project

From the drop-down menu, select the project to activate 
during the scheduled times. 

This project runs, using the phone number from the 
Phone field until another scheduled project starts, or 
until you delete the schedule.

Select Time Zone From the drop-down menu, choose the time zone to use 
when starting the scheduled project. 

CCA begins running the scheduled project at the Start 
time (see next field) in this time zone.

Start time From the drop-down menu, select the time of day to 
activate the project.

Note: Time is in 24-hour notation (where13:00 is 01:00 
p.m.) in the time zone selected above. CCA starts the 
scheduled project at the specified start time on the days 
checked (see next field).

Monday, 
Tuesday....

Check the day (or days) to run the scheduled project.

Because a schedule runs continuously until another 
schedule starts, it is ineffective to create only one schedule 
definition. You must create a minimum of two schedules to 
switch between projects.

Table 11-1. Add Schedule Fields and Descriptions

Field Description
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Project Scheduling Example

One common use of CCA’s scheduling capabilities is the routing of 
after-hours calls directly to voicemail instead of routing to agents who 
have gone home for the night. Table 11-1 describes two schedules 
managing two different routing strategies for Jay’s Unicycle Company.

The first schedule (“Business Hours”) activates the “Sales” project, 
which routes callers to a workgroup for handling by an agent during 
business hours (Monday - Friday, 09:00 a.m. - 05:00 p.m.).

The second schedule (“Nights and Weekends”) activates the “Sales 
Voicemail” project, which routes callers directly to the voicemail 
system during non-business hours (Monday - Thursday, 05:01 p.m. - 
08:59 a.m. and Friday, 05:01 p.m. - Monday, 08:59 a.m.).

Figure 11-2 shows the schedules screen as it would appear if you were 
implementing the “Nights and Weekends” schedule described in the 
Table 11-1.

Table 11-2 Example Schedules

Schedule 
Name

Project 
Name Schedule Call Routing Strategy

Business 
Hours

“Sales” M - F, 09:00 a.m. - 
05:00 p.m.

Routes callers to the Sales 
Workgroup for handling by 
an available Sales Agent

Nights and 
Weekends

“Sales 
Voicemail”

M - Th, 05:01 
p.m. - 11:59 p.m.
F, 05:01 p.m. - 
M, 08:59 a.m.

Routes callers directly to a 
prompt notifying the caller 
that the office is closed, and 
then lets the caller leave a 
voicemail message.
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Figure 11-2. Example: Scheduling a Routing Strategy for Nights and Weekends

Figure 11-2 Example: Scheduling a Routing Strategy for Nights and Weekends

In Figure 11-2, the “Nights and Weekends” schedule specifies “Sales 
Voicemail” as the Scheduled project; meaning that it runs at the 
specified time on each selected day of the week. The “Nights and 
Weekends” schedule continues to run the “Sales Voicemail” Project 
until another Schedule starts and supersedes it.

To stop routing calls to voicemail and resume routing calls to agents, 
set up a schedule (such as “Business Hours”), which starts the “Sales” 
project at 09:00 a.m. Monday through Friday (see Figure 11-3).
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Figure 11-3. Example: Schedule to Resume Call-Routing Strategy for Business Hours

Figure 11-3 Example: Schedule to Resume Call-Routing Strategy for Business Hours
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12

Customer Priority 12

Use AM to prioritize phone customers so CCA handles the most 
important callers first. As CCA routes callers to workgroup queues and 
then agents, CCA uses the customer’s priority level to determine the 
customer’s position in the queue. CCA places callers with higher 
priority nearer to the front of the queue than customers with lower 
priority. 

Customer priority only affects interactions CCA routes through a 
workgroup. For example, if your call center has agents who receive 
direct inbound calls, customer priority is being circumvented, since 
CCA has no way of controlling direct inbound calls. 

Assigning Priority Levels to Customers
To assign a priority level to a customer, you must know either:

• The customer’s ID information
or

• The customer’s telephone number

If you have two customers with different priority levels and 
a shared phone number, CCA cannot positively identify the 
customer. In this case, CCA sets the priority of both 
customers to the level assigned to the first record in the 
database that matches the detected phone number.

Whenever possible, use Customer ID information that is 
unique to each customer. This helps CCA accurately 
identify and prioritize the caller.
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To set customer priority

1. Click Options > Customer Priority > the Add button. 

The Add Customer Priority screen (Figure 12-1) opens.

Figure 12-1. Customer Priority Screen

Figure 12-1 Customer Priority Screen

2. Using the information in Table 12-1, complete the fields with the 
information CCA uses to identify the customer for prioritization.

Table 12-1. Customer Priority Fields and Descriptions

Field Description

Customer Name Type the customer’s name.

Customer ID Type the customer’s ID. Your project must be 
configured to require customers to provide an ID 
for prioritization. For how to gather ID information 
from customers, see “Use Prompt to ask for 
customer ID” on page 10-8.)
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3. Click Apply.

4. Repeat steps 2 and 3 to assign all customers a priority level.

5. Click OK.

To enable customer priority for a project 

After creating Customer Priorities, edit each project that uses those 
priorities: 

1. Click Options > Projects > Phone tab > Options subtab > and 
click the Enable Customer Priority Rating check box. 

2. For more information, see “Enable Customer Priority Rating” on 
page 10-12.

Country Code From the drop-down menu, select the country code 
of the customer’s telephone number.

Phone From the drop-down menu, type the customer’s 
telephone number.

Standard, Bronze, Silver, 
Gold, Platinum

Click to choose the priority for this customer. 

CCA routes callers to agents based on this priority.

If a customer does not have a priority, CCA assign 
the customer the default Standard priority.

Table 12-1. Customer Priority Fields and Descriptions

Field Description
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Identifying Customers for Prioritization
To prioritize a phone customer, CCA must be able to match the caller’s 
Customer ID or phone number. Table 12-2 provides CCA identifiers and 
explains how CCA uses them.

For how to configure a Phone Project to gather the information 
necessary to identify customers for prioritization, see “Adding Phone 
Interactions to a Project” on page 10-5.

Table 12-2. Identifying Customers for Prioritization

Identifier Method For Obtain Identifier

Customer ID You must configure CCA to ask a customer to identify 
themselves by entering their ID number. For how to 
configure CCA to ask for an ID number from telephone 
customers, see “Use Prompt to ask for customer ID” on 
page 10-8.

Phone Number If no Customer ID number is available, CCA tries to identify 
the customer using their phone number. 

CCA can automatically detect the caller’s phone number 
as long as the caller did not block it.

If CCA cannot detect the caller’s phone number, you 
must ask the customer to identify themselves by 
entering their phone number. 

For how to configure CCA to ask a customer to enter their 
phone number, see “Validate phone number” on page 10-7.

Customer priority levels take precedence over project 
priority levels. If Customer prioritization is enabled 
(meaning you checked the Use Prompt to ask for 
customer ID box discussed on page 10-8), CCA always 
prioritizes the interaction based on a customer priority 
level, disregarding a project priority level (see “Priority” on 
page 10-7).

CCA_AM.book  Page 4  Wednesday, July 26, 2006  2:55 PM



Managing Mail Interactions (Email and Voicemail) 13-1

13

Managing Mail Interactions (Email and 
Voicemail) 13

CCA works with electronic mail interactions by factoring two things:

• The number of electronic mail interactions an agent is 
configured to receive.

• Whether the electronic mail interaction is in the active 
interaction window in the Interaction Manager.

Normally, the email distributor sends mail interactions to a specific 
project, which then routes them to a workgroup. However, unlike a 
voice call or a chat, an Email Interaction does not take up an 
interaction license until the Agent accepts the email and moves it to 
the active interaction window.

If you configure the agent to handle multiple interactions at one time, 
then the agent could receive three or more interactions. If, for 
example, the agent accepts all three interactions, then three 
interaction licenses are tied up until the agent either disconnects or 
sends the emails back. (This is not an ideal practice.)

Since the Email Distributor sends an email to the Agent’s Inbox with an 
Interaction ID, it is best to configure the Agent to accept only one 
interaction:

When the interaction is delivered to the Agent, if the Agent accepts 
the interaction and responds to it immediately, then the license is 
released. 
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If the Agent needs time to respond to the email, then the agent 
can disconnect it (to release the license) and when the mess 
“Discard Email” appears, simply do not select “yes.” The Agent can 
then respond from their email client, which forwards back through 
the Email Distributor, which closes interaction tracking.

As long as the Agent responds before the configured time for a 
response, then the email is not forwarded to another Agent.

If the email is forwarded to another Agent, and the other agent 
responds prior to the original Agent, then the Email Distributor 
intercepts the second message and deletes it.

Troubleshooting Emails
Use AM to troubleshoot your call center’s email system by listing 
details for failed email messages and by correcting and re-sending the 
messages.

For example, if an agent attempts to send an email to a customer, but 
enters an invalid email address, use the Mail Manager screen to 
identify the problem, correct the error, and re-send the email.

In addition to standard email messages, Mail Manager 
reports any failed communications that move through the 
call center using the email system (voicemails, faxes, and 
so on).
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Viewing Mail Interactions
Use AM to view the following types of mail interactions:

• All emails and voicemails

• Emails and voicemails with errors

• Corrected emails and voicemails now pending (waiting to be sent)

• Corrected and sent emails and voicemails

To view mail interactions

1. Click Options > Mail Manager. A list of mail interactions (Figure 
13-1) appears.

Figure 13-1. Mail Manager: Show All Emails

Figure 13-1 Mail Manager: Show All Emails

2. The default is to view ALL mail interactions.
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You can select one of the filter methods from the drop-down menu, 
to view only selected mail messages:

a. From the Show drop-down menu, select one of the following:

i. Mail Pending shows corrected mail interactions that are 
waiting to be sent by an SMTP Server.

ii. Mail with Errors shows mail interactions that never 
reached their destination.

iii. Mail already sent shows corrected mail interactions that 
were sent to customers.

b. To search for mail interactions:

i. Click on a letter or number at the top of the screen.

ii. Click the Remove Filter button to go back to the list of all 
mail interactions. 

iii. Enter a string in the Find box. 

iv. Click the Go button. 

When using the Find text box (or when clicking on a letter or 
number at the top of the screen), AM searches on the currently 
selected column. For example, if you click the Recipient 
column and then click the letter A, CCA only shows mail 
interactions where the recipient address begins with the letter 
“A.”

The same is true when typing a string in the Find text box. If 
you click the Originator column and then enter Steve in the 
Find text box, CCA only shows mail interactions where the 
originator address begins with the string “steve.”

CCA limits you to retrieve a maximum of 500 mail 
interactions.

The Find text box is not case sensitive.
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The Find text box also supports the percent (%) character as a 
wildcard. For example, enter: 

%@yahoo.com

to find all mail interactions from a single domain. Use the 
wildcard character anywhere in your search string. 

Use the information in Table 13-1 to understand the report.

3. To sort the list based on the contents of a column, click the column 
header. 

4. Click Refresh to update the list with current information.

5. Click the mail interaction to view and then click View/Edit. The 
Edit Mail screen (Figure 13-2) appears.

Table 13-1. Mail Manager Report Columns and Descriptions

Column Description

Interaction ID The system-assigned identification number for the 
interaction.

Recipient The mail address of the intended mail message recipient.

Originator The mail address of the sender of the mail.

Date The date the mail was sent.

SMTP Group The SMTP Group used (or to be used) to send the mail.
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Figure 13-2. Edit Mail Manager

Figure 13-2 Edit Mail Manager

6. Use the information in Table 13-2 to understand the attributes of 
the mail.

7. Click Ok.

Table 13-2. Mail Attributes and Descriptions

Attribute Description

Originator The mail address of the person who sent the mail.

Recipient The mail address of the intended recipient.

Group Name The SMTP Group used (or to be used) to send the mail.

Interaction ID The system-assigned identification number for the 
interaction.

Subject The subject line of the mail message.

File Name of the text file into which the mail was converted 
for handling by CCA.

File Path Location in which the mail file is stored for processing.

Error Message If an error was encountered, this text describes the error.
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Correcting Emails
If an email did not reach its intended recipient (due to agent error, 
server problems, or any other reason), you can correct the problem 
and re-send the message.

To correct an email error

1. Display all email with errors (see “Viewing Mail Interactions” on 
page 13-3).

2. Click the email to correct.

3. Click View/Edit. The Edit Email screen (Figure 13-3) appears.

Figure 13-3. Correcting an Email

Figure 13-3 Correcting an Email

If an email error occurred because the agent’s email 
address was incorrect, you must correct the agent’s email 
address first (Options > Agents > Email tab > Agent Email 
Address), then follow the steps below to fix the email 
messages.
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4. Correct any errors in the email Recipient or Group Name 
attributes.

5. Click Ok.

CCA moves the email into the Mail Pending group and queues the 
message for re-sending.
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Deleting Mail Interactions
You can delete failed mail interactions from the Mail with Errors 
group and from the Mail Already Sent group.

To delete mail interactions

1. Choose the email group containing the mail interactions to delete.

2. Click the mail to delete.

3. Click Delete to delete the selected mail (or click Delete All to 
delete all the mail interactions in the list). A confirmation message 
(Figure 13-4) appears.

Figure 13-4. Delete All Confirmation Message

Figure 13-4 Delete All Confirmation Message

4. Click a selection and then click OK.
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14

Call Blocking 14

Use Call Blocking to prevent agents and the CCA automated callback 
features from calling specific phone numbers. Block numbers that any 
outbound phone interaction could use, including:

• Outbound calls placed by agents

• Calls to an agent’s follow-me (forwarding) number

• Calls transferred by an agent

• Web callbacks

• ACD callbacks

• Predictive calls

• Preview calls

When an agent tries to call to a blocked number, IM displays an error 
message indicating that the number is blocked.

If a customer requests a callback (through either your Website or your 
workgroup callback menu) to a blocked country code or number, CCA 
plays a prompt for the customer indicating that their request cannot be 
processed.

Call blocking lists created by a Network Administrator can 
only be deleted by a Network Administrator.
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Creating a Call Blocking List
Identify the numbers to block so that campaigns and agents cannot 
use them when making outbound phone interactions.

To create a call blocking list

1. Click Options > Call Blocking. CCA displays the list of previously 
defined Call Blocking Patterns (Figure 14-1) if any exist. 

Figure 14-1. Call Blocking Pattern List

Figure 14-1 Call Blocking Pattern List

a. The System Defined column: If a bullet appears, then a 
Network Administrator added or modified the pattern. (Only a 
Net Admin can edit this pattern.)

b. The Company Defined column: If a bullet appears, then a 
System Administrator or an Administrator added the pattern. 
(Therefore, an Admin can edit this pattern.)

2. Click Add. The Add Call Blocking screen (Figure 14-2) appears.

Only a Network Administrator 
can edit this pattern.

An Administrator can 
edit this pattern.
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Figure 14-2. Call Blocking Screen

Figure 14-2 Call Blocking Screen

3. Using the information in Table 14-1, complete the fields.

Table 14-1. Call Blocking Fields and Descriptions

Field Description

Country From the drop-down menu, select a country code to block. 

CCA blocks all call attempts to the numbers specified in the 
Phone text box (next field) in this country code.

Pattern Type a phone number or pattern to block. For example, to 
block all calls to the number 858-410-1600, simply type the 
number, as shown. This blocks only calls placed to this 
specific number.
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4. Click Apply.

5. Repeat steps 2 through 4 for all the patterns to block.

6. Click OK.

Use the asterisk (*) wildcard character to block all digits in 
zero or more positions of the number. For example, enter 9* 
to block all numbers with an area code beginning with 9, 
including 900-123-4567, 988-765-4321, 999-123-4567, and 
so on. This pattern does not block, for example, calls to 
888-854-4224 or any other number that does not have an 
area code beginning with 9.

Use the question mark (?) wildcard character to block all 
digits in a single position of the number. For example, enter 
90?-123-4567 to block the phone number 123-4567 in all 
area codes beginning with 90 (including 901, 902, 903, up to 
909). This pattern does not block, for example, the number 
910-123-4567 or any other number that does not have an 
area code beginning with 90.

Description Type a description for this call blocking list. This information 
appears in the Description column of the Call Blocking list.

Outbound Call Check to prevent agents (or the CCA automated callback 
system) from placing calls to numbers matching the specified 
pattern.

Clear this check box to allow outbound calls to numbers 
matching the pattern. (This also applies to preview calls.)

Predictive Call Check to prevent CCA from placing predictive calls to 
numbers matching the specified pattern.

Clear this check box to allow predictive calls to numbers 
matching the pattern.

Table 14-1. Call Blocking Fields and Descriptions

Field Description
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15

Introduction to Standard and Custom 
Reports 15

Create tabular and graphical reports to help understand the trends, 
activities, and agent performance in your call center. Create reports 
showing:

• Agent activity, performance, and efficiency
• Interaction statistics
• Interaction outcomes
• Project billing and cost details
• Outcome of predictive calls
• Traffic information

CCA reports are customizable, so you can:

• Display as much or as little data as needed.
• Specify a report date range.
• Display data in the graphical format that makes the most 

sense to you.
• Control which Administrators and Supervisors can access 

reports.
• Specify the date format, time zone, and language for the 

report.
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Overview of Standard Reports
Table 15-1 shows the reports AM provides. For how to generate a 
specific standard report, see the individual report chapters.

Table 15-1. Administration Manager Standard Reports

Report Description

Weekly Project 
Routing Schedule

Lists all schedules defined for the call center.

Workgroup Skills Displays the skills assigned to a workgroup and the 
rating of those skills.

Billing Summarizes the number and duration of interactions in 
each call center for which you provide service.

Workgroup Key 
Statistics

Shows statistics to help understand the overall 
performance of the call center.

Workgroup Interval 
Time

Shows how agents are performing at specific times of 
the day.

Workgroup Interval 
Time by Media

Shows how many interactions of each media type the 
call center receives at specific times of the day.

Outcome Statistics Allows tracking interaction results based on interaction 
type (ACD call, Web callback, and so on).

Overdue Callbacks Lists all waiting Web call-back interactions.

Predictive Dialer 
Totals

Shows a group of call-related statistics (number of calls, 
answer rate, and so on) for predictive dialing.

Predictive 
Productivity

Displays a breakdown of the production statistics based 
on the agents used for any or all predictive call 
attempts. 

Note: Predictive reports are available only if you 
purchased Predictive Dialing capabilities with your 
version of CCA.

Predictive Summary Displays a breakdown of the actions (left message, 
callback, and so on) of all predictive call attempts.

Note: Predictive Reports are available only if you 
purchased Predictive Dialing capabilities with your 
version of CCA.
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Predictive Detailed Displays a breakdown of the results (busy, no answer, 
and so on) of all predictive call attempts. 

Note: Predictive reports are available only if you 
purchased Predictive Dialing capabilities with your 
version of CCA.

Preview Summary Displays a breakdown of the preview results based on 
the agents used for any or all predictive call attempts.

Note: Preview reports are available only if you 
purchased Preview Dialing capabilities with your version 
of CCA.

Agent Information Displays agent profile information (extension, email 
address, and so on).

Agent Interaction Displays details about the number and duration of 
selected interaction types for selected agents.

Agent Skills This report quickly shows which agents possess each 
skill in the call center by showing all the skills defined 
for your Company, identifying which agents possess 
each skill, and providing the agent’s skill rating. 

Agent Utilization Shows the time each agent spent handling interactions, 
awaiting interactions, or on break, which is good for 
evaluating agent use.

Direct Dialing 
Statistics

Shows statistics for calls dialed directly to agents or 
dialed by agents to external numbers.

Login by Groups of 
Users

Displays the agents who logged in, their login time, and 
login duration.

Login by User Provides information about the login activity of each 
agent.

Project Key 
Statistics

Shows a set of interaction statistics, by interaction type 
(phone, email, and so on) and as a summary across all 
interaction types.

Table 15-1. Administration Manager Standard Reports

Report Description
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Overview of Custom/Advanced Reports
The CCA Advanced Report Templates allow you to configure highly 
detailed reports that provide information not available in the Standard 
Reports.

In addition, CCA presents Advanced Report information differently than 
Standard Reports, which presents information in an “all or one” 
format. You can set Advanced Reports to run in ways that compare 
multiple projects/workgroups/users and so on.

Table 15-2 shows the Advanced Report templates available from 
Custom Reports > Advanced Reports. 

Table 15-2. Administration Manager Custom/Advanced Reports

Advanced Report Description

Daily Project 
Performance

This report provides a snapshot of Call Center 
Activity by Call Number and Type, Time 
Measurements of Call Center activity, along with 
Service Level performance against pre-set 
thresholds. You can configure this report to show 
all activity for all projects or for individual projects 
you select, by interval or by dates.

Interval Workgroup 
Performance

This report tracks Workgroup Activity in 
15-minutes intervals or daily by a single day or 
range of dates. Statistics tracked include:

Number, Type and Disposition of Calls
Service Levels
Collective time in ACD States
Agent Login activity and visibility into ACD 
States.

User Login/Logout This report tracks user login/logout activity and 
the duration and logout reason for a user-defined 
time range.

User Hourly Average This report tracks Agent Activity related to the 
Average Number of Calls handled, Average Talk 
Time (ATT), Average Available Time, and Average 
Busy Time per hour.

Daily User 
Performance

This report tracks Agent performance relative to 
time spent in the different ACD States, Call 
Counts, and Talk Times.
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These reports are produced in PDF format. You will need Adobe 
Acrobat Reader to view these reports. For more specific information 
about each of these Advanced Reports, refer to the Advanced Reports 
User’s Guide.

System Peak Interactions This report tracks the Maximum peak 
number of Interactions used by the system, 
reported in 15-minute intervals.

System Peaks (15 mins) This report tracks the number of peak interactions 
for a specified company or tenant, in 15-minute 
intervals. 

Interaction Outcome by 
Workgroup

This report tracks outcomes by Workgroup, 
Interaction Type, Outcome, Total Interaction time, 
and Average Interaction Time.

Service Billing Report 
- By Project

The report shows transaction times and billing 
rates by project, for a specified date range.

User Status Duration This report tracks Agent Activity through the daily 
use of User-Defined Agent Statuses. This provides 
more granularity in regards to the way that an 
Agent actually spends their time versus the 
standard ACD Statuses of Available, Busy, and On 
Break. This report tracks the following:

User
Date
Status (Company Defined)
Duration
ACD Status (System Default)
% of Total

Inbound Traffic Report The report provides a count of the number of calls 
offered by area code and exchange within that 
area code.

Table 15-2. Administration Manager Custom/Advanced Reports

Advanced Report Description
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Viewing and Printing Standard Reports
You can view and print reports you or another Administrator created 
and saved for your company.

To view or print Standard Reports

Expand the Reports links in the Navigation Pane, then expand one of 
the bold headings to see the reports under that heading.

1. Click a report name (for example, Billing). If no reports of that 
type exist, an empty Billing Report List (Figure 15-1) appears.

Figure 15-1. Example Empty Report List

Figure 15-1 Example Empty Report List

If any reports of that type exist, a list of Billing Reports (Figure 
15-2) appears.

Figure 15-2. Pop-Up Menu

Figure 15-2 Pop-Up Menu

CCA supervisors cannot create or edit report definitions.
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2. To view a report:

i. Right-click a report name.

ii. Choose View from the pop-up menu (Figure 15-2).

Or, you can also click the View button from the top of the screen. 
The Report dialog box opens to the Period Covered tab (Figure 
15-3).

Figure 15-3. Report Dialog Box: Period Covered Tab

Figure 15-3 Report Dialog Box: Period Covered Tab

3. If available, use the Period Covered tab to set the date range for 
the report (Table 15-3).

Table 15-3. Period Covered Tab Fields and Descriptions

Field Description

Start Date Click  to display a calendar for selecting the report range start 
date. 

Choose the report start date by clicking a day in the calendar, or 
click today to choose today’s date (based on your workstation’s 
system clock).

Click > or < to advance or roll back the calendar one month, 
respectively. 
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4. Click the Regional Options tab (Figure 15-4).

Figure 15-4. Regional Options Tab

Figure 15-4 Regional Options Tab

Click >> or << to advance or roll back the calendar one year, 
respectively. 

End Date Click  to display a calendar for selecting the report range end 
date. 

Choose the report end date by clicking a day in the calendar, or 
click today to choose today’s date (based on your workstation’s 
system clock).

Click > or < to advance or roll back the calendar one month, 
respectively. 

Click >> or << to advance or roll back the calendar one year, 
respectively. 

Start Time Choose the report range start hour (24-hour clock) and minute.

End Time Choose the report range end hour (24-hour clock) and minute.

Table 15-3. Period Covered Tab Fields and Descriptions

Field Description
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5. Using the information in Table 15-4, complete fields.

6. Click OK.

The report appears in a new browser window.

7. To print the report, use your browser’s Print command (File > 
Print).

Table 15-4. Regional Options Tab Fields and Descriptions

Field Description

Display Time Choose Company Default Time Zone to display all 
report times in your company’s default time zone 
defined.

Choose User Time Zone to display all report times in 
your AM workstation’s configured time zone.

Report Language From the drop-down menu, select the language to use in 
this report.

Select Date Format 
to Display in 
Report

Choose Company Default Date Format to display all 
report dates in your company’s default format. 

Choose User Defined Date Format to display all 
report dates in your AM workstation’s configured format.

CCA_AM.book  Page 9  Wednesday, July 26, 2006  2:55 PM



15-10 CallCenterAnywhereTM Administration Manager

Viewing and Printing Custom/Advanced Reports
You can view and print Custom/Advanced Reports you or another 
Administrator created and saved for your company.

To view or print Custom/Advanced Reports

1. Expand the Custom Reports link in the Navigation Pane. 

2. Then, expand the Advanced Reports link to see the reports 
under that heading.

3. Follow the same steps described under “To view or print Standard 
Reports” on page 15-6.

A Note About Start and End Times

For almost every report, the start and end times work the same. For 
example, run a Billing report using the following: 

Select: 

• Start date = 07/01/04
• End date = 07/30/04 
• Start time = 8:00 (AM)
• End time = 17:00 (5:00 pm)

The Bill Report includes events:

• Starting at 8:00 AM on 7/01/04 
• Through 5:00 PM on 07/30/04

Any event occurring between those times, twenty-four hours a day, 
seven days a week, is included in the report. Every CCA report works 
this way -- with two exceptions:

• The Workgroup Interval Time report
• The Workgroup Interval Time by Media report

You must install Adobe Acrobat Reader on all workstations 
of users who want to view Advanced Reports as well as 
Scheduled Advanced Reports.
CCA delivers Scheduled Reports in both Web (html) format 
as well as in Acrobat (pdf) format.
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If you run these reports (and select the same start and end times as 
above) the report would contain events occurring between 8:00 AM 
and 5:00 PM, every day between 07/01/04 and 07/30/04.

Note About Project Routing and Reporting

If CCA receives a call into Project A and this changes another project 
(such as Project B), the report will show the change to Project A. This 
is because the change actually came into Project A and if CCA reported 
it for both Project A and Project B, then the information would be 
doubled. If CCA reported the change for only Project B, then there 
would be no way to tack which project the call actually came into. This 
is important for some clients who use multiple project DNISs that 
reroute to the same project or menu for tracking which advertising 
source is generating the most calls.

Scheduling Reports
Use the View button to manually generate a report whenever you 
want (see page 15-6). In addition, you can schedule reports to run 
automatically, cover selected periods of time, and be automatically 
mailed to one or more email addresses.

CCA generates all scheduled reports at midnight (according to the 
company itemizing).

Configuring the report.xml File

The first time you use the report scheduling feature, you must make 
some minor edits to the report.xml file.

1. After installing the current build, find the report.xml file at: 

TAW/custom/report.xml

Before using the scheduling feature the first time, you 
must make some minor edits to the report.xml file. See 
“Configuring the report.xml File” below.
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2. Open the file in a text editing program and verify that the following 
tags have correct values. The examples below show the default 
directory paths, but you should verify that these are correct for 
your site.

The “url” parameter should contain the URL path of your 
TAW web server:
<parameter

name=“url”
value=“http://<machine name>/TAW”

/>

The “urlReportCss” parameter should contain the URL path 
to the web_clients.css file:
<parameter

name=“urlReportCss”

value=“http://<machine_name>/TAW/css/web_clients.css
” 

/>

The “urlReport” parameter should contain the URL path to 
the report directory:
<parameter

name=“urlReport”
value=“http://<machine_name>/TAW/AdministrationMana
ger/report”

/>

To schedule a report

1. Select a report type. For example: Click Reports > Call Center 
Operations > Workgroup Skills

2. Click the Add button (to create a new report) or the Edit button 
(to create a schedule for an existing report). 

3. When the report opens, click the Schedule Report tab.

4. Then, select the Enable Report Scheduling check box (Figure 
15-5).

After editing the report.xml file, you must restart the TAW 
Web server.
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Figure 15-5. Schedule a Report

Figure 15-5 Schedule a Report

5. Select a reporting period:

• Daily
• Weekly
• Monthly

6. Complete the fields under Send this Report by Email. 

a. In the To text box, enter one or more email addresses where 
CCA sends the report. Separate multiple email addresses with 
a semi-colon (;). For example: 

brice@indy500.com;gdefarran@indy500.com

The To field uses a maximum of 2048 characters.
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b. In the From text box, enter one email address. (The person 
who receives the report can see this address in the email’s 
From field.)

7. Select an SMTP group.

To delete a report

The following steps show how to delete a Workgroup Segments report, 
but you can delete all reports the same way.

1. Click the Reports link to expand it.

2. Then, click on a report group name (such as Workgroup 
Productivity) to see the reports in that group (Figure 15-6).

Figure 15-6. Reports Links

Figure 15-6 Reports Links

3. Click on a report name (such as Workgroup Segments). 

A list of reports of that type appears (Figure 15-7). 

The From field uses a maximum of 128 characters.

Click to Expand

Click to Expand
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Figure 15-7. Workgroup Key Statistics

Figure 15-7 Workgroup Segments

4. Right-click on the report to delete and select Delete from the 
pop-up menu (Figure 15-7). 

or

Select a report and then click the Delete button.

A delete confirmation message (Figure 15-8) appears.

Figure 15-8. Delete Confirmation Message

Figure 15-8 Delete Confirmation Message

5. Click OK confirm the deletion.
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Deleted Objects and Historical Reports
Deleting an object (such as companies, Workgroups, Agents, Projects, 
Data Sources, and so on) from AM does NOT remove the object from 
the CCA database.

For example, if you delete a workgroup in AM, the workgroup is 
still in the database. CCA marks the workgroup as “do not display 
this workgroup in any CCA GUI.”

Because objects remain in the database forever, they can be picked up 
by reports containing historical data. 

This means, if you delete a workgroup on January 15th and then 
run a report showing workgroup activity going back to January 1st, 
the report will show activity from the deleted workgroup.
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16

The Call Center Operations Reports 16

The available Call Center Operations Reports include:

• Weekly Project Routing Schedules Report
• Workgroup Skills Report
• Billing Report (for CCA’s Service Providers Edition only)
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Weekly Project Routing Schedules Report
The Weekly Project Routing Schedules Report lists all of the 
Schedules defined for your call center.

Figure 16-1. Sample Weekly Project Routing Schedules Report

Figure 16-1 Sample Weekly Project Routing Schedules Report

Report Elements

The Weekly Project Routing Schedules Report shows the 
information provided in Table 16-1 for each schedule:

Table 16-1. Project Schedules Report Columns

Column Description

DNIS The telephone number or email address customers use to 
reach the Scheduled Project.

Day The day the project begins (based on the number or 
address indicated by DNIS).

Start Time The time (24-hour clock) the project starts (on the indicated 
Day the project).
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To create a Weekly Project Routing Schedules Report

1. Click Reports > Call Center Operations > Weekly Project 
Routing Schedules. The Weekly Project Routing screen appears, 
listing any reports.

2. Click the Add button. The Name tab of the Weekly Project 
Routing Schedules Report screen (Figure 16-2) appears.

Figure 16-2. Name Tab

Figure 16-2 Name Tab

From Project The (previous) project, which the schedule will temporarily 
disable while the (current) To Project runs.

To Project The project the schedule runs (at the specified Day and 
Start Time).

TIme Zone The time zone used to generate the report. (The values in 
the Start Time column are for this time zone.)

Table 16-1. Project Schedules Report Columns

Column Description
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3. Using the information in Table 16-2, complete the Name tab for 
the Weekly Project Routing Schedules Report.

4. Click the Content tab. 

The Content tab of the Weekly Project Routing Schedules 
Report screen (Figure 16-3) appears.

Figure 16-3. Content Tab

Figure 16-3 Content Tab

Table 16-2. Name Tab Fields and Descriptions

Field Description

Report 
Name

Type a name for this report. The name appears on each page of 
the report and in the Name column of the list of Weekly Project 
Routing Schedules Report definitions.

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
This description appears in the Description column of the list 
of Weekly Project Routing Schedules Report definitions.
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5. Using the information in Table 16-3, complete the fields.

6. Click the Layout tab. The Layout tab of the Weekly Project 
Routing Schedules Report screen (Figure 16-4) appears.

Figure 16-4. Layout Tab

Figure 16-4 Layout Tab

7. Using the information in Table 16-4, complete the fields.

Table 16-3. Content Tab Fields and Descriptions

Field Description

Include 
Statistics On

In the Include Statistics On area, check the days of the 
week to include in the report. Click All to include all days or 
click Clear to clear all the check boxes.

Table 16-4. Layout Tab Fields and Descriptions

Field Description

Build Report A list of report columns appears in this box. Arrange the 
order of these columns by clicking a column element and 
then clicking the up arrow ( ) to move it up or click the 
down arrow ( ) to move it down.
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8. Click the Regional Options tab.

The Regional Options tab of the Weekly Project Routing 
Schedules Report screen (Figure 16-5) appears.

Figure 16-5. Regional Options Tab

Figure 16-5 Regional Options Tab

9. Using the information in Table 16-5, complete the fields.

Table 16-5. Regional Options FIelds and Descriptions

Choose... To Display...

Company Default 
Time Zone

All times using the specified time zone set for the 
company.

User Time Zone All times using the specified time zone set for your 
workstation.

Report Language All report contents in the language you choose.

Company Default 
Date Format

All dates using the format specified for the Company.
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10. Click the Permissions tab.

The Permissions tab of the Weekly Project Routing Schedules 
Report screen (Figure 16-6) appears.

Figure 16-6. Permissions Tab

Figure 16-6 Permissions Tab

11. Click the check box next to a supervisor to give that supervisor 
permission to view and print the report. Supervisors not checked 
will not see the report in SM. (Click All to include the entire list or 
click Clear to clear all selections.)

12. Click OK.

User Defined 
Date Format

All dates using the format specified for your workstation.

Table 16-5. Regional Options FIelds and Descriptions

Choose... To Display...
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CCA saves the report in the database. Any Administrator or 
Supervisor logged into your company and access the report. In 
addition, anyone to whom you have given permission, can also 
access the report. 

• For how to view and print a report, see page 15-6. 
• For how to delete a report, see page 15-14.
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Workgroup Skills Report
The Workgroup Skills Report (Figure 16-7) displays the skills 
assigned to a workgroup and the rating of those skills.

Figure 16-7. Sample Workgroup Skills Report 

Figure 16-7 Sample Workgroup Skills Report

Report Elements

CCA Supervisors viewing the Workgroup Skills Report 
should know that this report reflects activity for the entire 
company. Data presented includes all agents, not just the 
agents for a specific supervisor.
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Table 16-6 shows the elements of the Workgroup Skills Report.

To creating a Workgroup Skills Report

1. Click Reports > Call Center Operations > Workgroup Skills. 
The Workgroup Skills screen opens.

2. Click the Add button. The Name tab of the Workgroup Skills 
Report screen (Figure 16-8) appears.

Figure 16-8. Name Tab

Figure 16-8 Name Tab

Table 16-6. Workgroup Skills Report Fields and Descriptions

Item Description

Skill Name Displays the Skill Name you entered when you created the skill 
(Options > Skills). 

Rating Displays the Skill Level Weight you assigned to this skill when 
you created the Workgroup (Options > Workgroups > Skills).
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3. Using the information in Table 16-7, complete the fields.

4. Click the Content tab.

The Content tab of the Workgroup Skills Report screen (Figure 
16-9) appears.

Figure 16-9. Content Tab

Figure 16-9 Content Tab

Table 16-7. Name Tab Fields and Descriptions

Field Description

Report 
Name

Type a report name. This name appears on each page of the 
report and in the Name column of the list of Workgroup Skills 
Report definitions.

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list of 
Workgroup Skills Report definitions.
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5. From the Workgroups drop-down menu, select the Workgroups to 
appear in the report.

6. Click the Regional Options tab. The Regional Options tab of the 
Workgroup Skills Report screen (Figure 16-10) appears.

Figure 16-10. Regional Options Tab

Figure 16-10 Regional Options Tab

7. Using the information in Table 16-8, complete the fields.

Table 16-8. Regional Options Fields and Descriptions

Choose... To Display...

Company Default 
Time Zone

Report all times using the time zone set for the company.

User Time Zone Report all times using the time zone set for your 
workstation.

Report Language All report contents are in the language you selected.
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8. Click the Permissions tab. The Permission tab of the Workgroup 
Skills Report screen (Figure 16-11) appears.

Figure 16-11. Permissions Tab

Figure 16-11 Permissions Tab

9. Click the Any Supervisor button to give all Supervisors access to 
the report. 

10. Click The Following Supervisors, and then, from the list, select 
the individual supervisors.

11. Click OK (or Apply). 

• For how to view and print a report, see page 15-6. 
• For how to delete a report, see page 15-14.

Company Default 
Date Format

All dates are formatted using the format set for the 
company.

User Defined 
Date Format

All dates are formatted using the format set for your 
workstation.

Table 16-8. Regional Options Fields and Descriptions

Choose... To Display...
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Billing Report
The Billing Report (Figure 16-12) summarizes the number and 
duration of interactions in each call center for which you provide 
service.

Figure 16-12. Sample Billing Report 

Figure 16-12 Sample Billing Report

Report Elements

Table 16-9 shows the Billing Report elements.

The Billing Report is available for CCA’s Service Provider 
Edition only.

Table 16-9. Billing Report Fields and Descriptions

Item Description

Call Center The name of the call center for which you provide service.
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To create a Billing Report

1. Click Reports > Call Center Operations > Billing. The Billing 
screen appears, showing a list of reports.

2. Click the Add button. 

The Name tab of the Add Billing Report screen (Figure 16-13) 
appears.

Figure 16-13. Name Tab

Figure 16-13 Name Tab

Number of 
Interactions

The total number of interactions processed by that call 
center for the time period covered by the report. 

Duration of 
Interactions

The total amount of time that the call center spent 
processing those interactions. 

Table 16-9. Billing Report Fields and Descriptions

Item Description
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3. Using the information in Table 16-10, complete the fields.

4. Click the Regional Options tab.

The Regional Options tab of the Add Billing Report screen (Figure 
16-14) appears.

Figure 16-14. Regional Options Tab

Figure 16-14 Regional Options Tab

Table 16-10. Name Tab Fields and Descriptions

Field Description

Report 
Name

Type a report name. This name appears on each page of the 
report and in the Name column of the list of Billing Report 
definitions.

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list of 
Billing Report definitions.
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5. Using the information in Table 16-11 to complete the fields.

6. Click OK (or Apply).

• For how to view and print a report, see “Viewing and Printing 
Standard Reports” on page 15-6. 

• For how to delete a report, see “To delete a report” on page 
15-14.

Table 16-11. Regional Options Tab Fields and Descriptions

Choose... To Display...

Company Default 
Time Zone

Report all times using the time zone set for the company.

User Time Zone Report all times using the time zone set for your 
workstation.

Report Language All report contents are in the language you selected.

Company Default 
Date Format

All dates are formatted using the format set for the 
company.

User Defined 
Date Format

All dates are formatted using the format set for your 
workstation.
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17

The Workgroup Productivity Reports17

The available Workgroup Productivity Reports include:

• Workgroup Segments Report (formerly Workgroup Key 
Statistics Report) (formerly Workgroup Key Statistics Report)

• Workgroup Interval Time Report
• Workgroup Interval Time by Media Report
• Outcome Statistics Report
• Overdue Callbacks Report
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Workgroup Segments Report (formerly 
Workgroup Key Statistics Report)

The Workgroup Segments Report (Figure 17-1) shows call center 
use, agent performance, and billing statistics for selected projects and 
workgroups. 

• This report includes interactions which the Automatic Call 
Distribution system routes to workgroup agents. 

• This report does not include calls made directly to an agent or 
outbound calls made by an agent. 

Figure 17-1. Sample Workgroup Segment Report

Figure 17-1 Sample Workgroup Segment Report
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Report Elements

The areas of the Workgroup Segment Report include:

• Segment Events
• Abandoned Interval
• Agent Answered Interval
• Agent Segment Processing
• Summary

Segment Events

Table 17-1 shows the fields and descriptions for the Segment Events 
area, which displays information for interactions received by the call 
center.

Supervisors should remember that this report includes 
activity for all agents in the selected project or workgroup, 
not just the agents for a specific supervisor.

Table 17-1. Segment Events Fields and Descriptions

Item Description

Agent Answered The number of workgroup interactions routed to and 
accepted by agents.

Abandoned The number of workgroup interactions received by the call 
center but abandoned by the customer before being 
accepted by an agent.

Callback Calls The number of callback and Web callback interactions 
handled by the call center. 

Voicemail The number of calls in which the caller left a voicemail 
message for a workgroup agent - rather than wait in the 
queue to be connected to an agent.

Other 
Workgroups

The total number of agents busy working on interactions for 
other workgroups.

No Answer The total number of interactions sent to but not answered 
by an agent.

Other Events The total number of events that overflowed back to a 
project menu or where the project results are “other.”

Total Segments 
Received

The total number of interactions coming into the call center 
for this segment.
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Abandoned Interval

Table 17-2 shows the fields and descriptions for the Abandoned 
Interval area, which displays statistics for the time customers waited 
before deciding to abandon their attempt to reach the call center.

Agent Answered Interval

Table 17-3 shows the fields and descriptions for the Agent Answered 
Interval area, which displays statistics for how long customers waited 
before being connected to an agent.

Table 17-2. Abandoned Interval Fields and Descriptions

Item Description

under 0 min 30 
Seconds

The number of interactions that were abandoned in 
under 30 seconds.

0 min 31 sec to 1 
min 0 sec

The number of interactions that were abandoned 
after waiting 30 seconds, but less than 60 seconds.

1 min 1 sec to 1 min 
30 sec

The number of interactions that were abandoned 
after waiting 61 seconds, but less than 1 minute and 
30 seconds.

1 min 31 sec to 2 
min

The number of interactions that were abandoned 
after waiting between 1 minute and 30 seconds and 2 
minutes.

Over 2 min 0 sec The number of interactions that were abandoned 
after waiting more than 2 minutes.

Total Segments 
Abandoned

The total number of interactions that were abandoned 
for this segment.

Table 17-3. Wait Time to Accept Interaction Fields and Descriptions

Item Description

Below Threshold 1 The total number of interactions accepted by an agent 
before expiration of the Threshold 1 time limit (set in 
the Content tab of the report definition).

Below Threshold 2 The total number of interactions accepted by an agent 
before expiration of the Threshold 2 time limit (set in 
the Content tab of the report definition).

Greater than 
Threshold 2

The total number of interactions accepted by an agent 
exceeding the Threshold 2 value and expiration limits 
(set in the Content tab of the report definition).

CCA_AM.book  Page 4  Wednesday, July 26, 2006  2:55 PM



The Workgroup Productivity Reports 17-5

Media Type Segments Handled

Table 17-4 shows the fields and descriptions for the Media Type 
Segments Handled area, which displays the number of interactions 
of each media type handled by the selected projects or workgroups.

Total Segments 
Answered by Agent

The total number of interactions routed to and 
accepted by workgroup agents. Direct-dialed calls are 
not included in this report. (See “Direct Dialing 
Statistics Reports” on page 19-29 for information on 
direct-dialed calls).

Table 17-4. Media Type Segment Handled Fields and Descriptions

Item Description

Workgroup Calls The number and percentage of interactions that 
reached the call center by phone, were routed to a 
workgroup, and subsequently handled by an agent. 

Note: This does NOT include predictive calls and 
preview calls.

Workgroup 
Voicemails

The number and percentage of interactions that 
reached the call center by phone, were routed to a 
workgroup, and elected to leave a voicemail message 
rather than wait in the workgroup queue for an agent.

Callback The number and percentage of interactions that 
reached the call center by phone, were routed to a 
workgroup, and requested a call-back rather than wait 
in the workgroup queue for an agent.

Web Callback The number and percentage of customers who 
reached the call center by requesting a callback from 
an agent (using the company’s Website).

Chat The number and percentage of customers who 
reached the call center by requesting a chat with an 
agent (using the company’s Website).

Workgroup Email The number and percentage of interactions that 
reached the call center by email, were routed to a 
workgroup, and subsequently handled by an agent.

Table 17-3. Wait Time to Accept Interaction Fields and Descriptions

Item Description
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Agent Segment Processing

Table 17-5 shows the fields and descriptions for the Agent Segment 
Processing area, which displays the average time agents spent in 
various phases of the interaction.

Workgroup Fax The number and percentage of fax interactions that 
were routed to a workgroup and subsequently handled 
by an agent.

Total Segments 
Received

The total number of interactions received from all 
media types in this segment (including workgroup 
calls, workgroup voicemails, callbacks, Web callbacks, 
chat, workgroup emails, and workgroup faxes).

These statistics include only the interaction types you 
selected (from the Include Statistics On area of the 
Content tab).

Table 17-5. Agent Call Processing Fields and Descriptions

Item Description

Average Speed of 
Answer

The average time for agents to answer an 
interaction.

Average Talk Time The average time agents spent on a call. Time 
starts when agent accepts an ACD call and ends 
when the call is removed from agent (including any 
hold time inbetween). 

Note: The Wrap-up time is NOT included.

Average Wrap Up 
Time

The average time agents spent wrapping-up 
interactions (where agent status = Wrap Up).

Average Handle 
Time per Segment

The average time agents spent handling a call. 
(The sum of Average Talk Time + Average Wrap-up 
Time). 

Note: Hold time is NOT included.

Average Hold Time The average time agents kept callers on hold (for 
the segments that went on hold).

Table 17-4. Media Type Segment Handled Fields and Descriptions

Item Description
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Example Calculations:

The call center received:

98 calls: each 5 min long, none on hold, and 1 min wrap-up 
2 calls: each 5 min long, 5 min on hold, and 1 min wrap-up

The results are calculated as:

Therefore, 610/100 = 6.1 minutes of average handle time per 
segment.

Summary

Table 17-6 shows the fields and descriptions for the Summary area, 
which displays overview data for interactions received and for 
interaction wait times.

Calls Talk Time Hold Time Wrap-up Time

98 5 min 0 1 min

2 5 min 5 min 1 min

98 * (5 + 1) = 588

2 * (10 + 1) = 22

Total = 610

Table 17-6. Summary Fields and Descriptions

Item Descriptions

Total Segments 
Received

The total number of interactions received by your 
company.

Total Segments 
Answered by Agent

The total number of interactions received by CCA, 
routed to a workgroup, and handled by an agent.

Number of Times 
Segments Went to 
Hold

The total number of voice interactions placed on hold, 
at any time, by an agent.

Duration of Handled 
Segments

The total time interactions spent in the system. CCA 
calculates this as the difference between the time CCA 
received the interaction and the conclusion of the 
interaction.
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To create a Workgroup Segments Report

1. Click Reports > Workgroup Productivity > Workgroup 
Segments. The Workgroup Segments screen appears, listing 
reports.

2. Click the Add button. The Name tab of the Add Workgroup 
Segments report (Figure 17-8) appears.

Total Wait to Answer 
Time

The total time interactions spent waiting for an agent 
in a workgroup queue.

Shortest Wait to 
Answer Time

How long the interaction with the shortest queue time 
waited for an agent.

Longest Wait to 
Answer Time

How long the interaction with the longest queue time 
waited for an agent.

Average Ring Time The average ring time. (This is calculated as the total 
ring time / number of calls offered to the agent.)

Average Time to 
Abandoned

The average time before the interaction was 
abandoned for all segments of the interaction.

OverFlow In The total number of ACD interactions that were 
answered in the overflow workgroup. The count 
begins when the interaction is answered by the 
overflow workgroup. All answered segments are 
counted (even when answered by agent, voicemail, 
callback, and menu).

OverFlow Out The total number of ACD interactions that were 
answered in the original workgroup and overflowed. 
The count begins when the interaction is answered by 
the overflowed workgroup. All answered segments are 
counted (including those answered by agent, 
voicemail, callback, or menu.)

Transferred In The number of interactions that entered the 
workgroup by way of a transfer. 

Table 17-6. Summary Fields and Descriptions

Item Descriptions
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Figure 17-2. Name Tab

Figure 17-2 Name Tab

3. Using the information in Table 17-7, complete the fields.

4. Click the Content tab. The Content tab of the Workgroup 
Segments Report (Figure 17-3) appears.

Table 17-7. Name Tab Fields and Descriptions

Field Description

Report 
Name

Type a name for this report. The name appears on each page of 
the report and in the Name column of the list of Workgroup 
Segments Report definitions.

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list of 
Workgroup Segments Report definitions.
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Figure 17-3. Content Tab

Figure 17-3 Content Tab

5. Using the information in Table 17-8, complete the fields.

Table 17-8. Content Tab Fields and Descriptions

Field Description

Include 
Statistics On

In the report in the Include Statistics On area, check the 
interaction types to include. (Click All to include all interaction 
types or click Clear to clear all the check boxes.)

Threshold 1 For each interaction type, choose how long to measure agent 
performance for that interaction type. For example, if you 
enter 1 minute for Threshold 1, the Workgroup Segments 
Report shows the number and percentage of interactions the 
agent accepted before the customer waited 1 minute in the 
queue.
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6. Click the Regional Options tab. The Regional Options tab (Figure 
17-4) of the Workgroup Segments Report appears.

Figure 17-4. Regional Options Tab

Figure 17-4 Regional Options Tab

Threshold 2 For each interaction type, choose how long to measure agent 
performance for that interaction type. For example, if you 
enter 5 minutes for Threshold 2, the Workgroup Segments 
Report shows the number and percentage of interactions the 
agent accepted before the customer waited 5 minutes in the 
queue, as well as the number of interactions the agent 
accepted after the customer waited 5 minutes in the queue.

Using Data 
Source

Identify the data source to use by clicking the Projects check 
box and then select one or all projects from the drop-down 
menu. 

Click the Workgroups check box and then select one or all 
projects from the drop-down menu.

Table 17-8. Content Tab Fields and Descriptions

Field Description
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7. Using the information in Table 17-9, complete fields.

8. Click the Permissions tab. The Permissions tab (Figure 17-5) of 
the Workgroup Segments Report appears.

Figure 17-5. Permissions Tab

Figure 17-5 Permissions Tab

Table 17-9. Regional Options Tab Fields and Descriptions

Choose... To Display...

Company Default 
Time Zone

All times using the time zone set for the company.

User Time Zone All times using the time zone set for your workstation.

Report Language All report contents in the language you choose.

Company Default 
Date Format

All dates using format set for the company.

User Defined 
Date Format

All dates using the format set for your workstation.
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9. Grant permission to view and print this report to:

a. Check any Supervisor so that all supervisors have access.

b. Check the following Supervisors and then select the 
individual supervisors, which will have access. 

Supervisors not checked will not see the report definition in 
SM.

c. Click Clear to clear all selections.

a. Click OK (or Apply).

10. Click the Schedule Report tab (Figure 17-6).

Figure 17-6. Schedule Report Tab

Figure 17-6 Schedule Report Tab
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a. Check the Enable Report Scheduling check box.

b. Using the information in Table 17-10, complete fields.

11. Click OK (or Apply).

• For how to view and print a report, see page 15-6. Also, since 
selecting a start and end time for this report is slightly 
different than for other reports, see “A Note About Start and 
End Times” on page 15-10.

• For how to delete a report, see page 15-14.

Table 17-10. Schedule Report Tab Fields and Descriptions

Field Description

Daily
Weekly,
Monthly

Click the button identifying how often to run this report.

To Type the email address for everyone who should receive 
this report. Use a semicolon to separate addresses, such 
as joesmith@taw.com; tturner@alo.com.

From Type your email address (or the address of the person 
responsible for sending this report).

Select an SMTP 
Group to send 
the Report

From the drop-down menu, select the STMP group that 
also receives this report.
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Workgroup Interval Time Report
The Workgroup Interval Time Report shows how agents are 
performing at specific times of the day. You can report on time 
intervals as short as 1 minute and as long as 60 minutes. Figure 17-7 
shows an example Workgroup Interval Time Report for intervals of 
60 minutes.

Figure 17-7. Sample Workgroup Interval Report

Figure 17-7 Sample Workgroup Interval Report

Report Elements

Each row of the report shows a single time interval based on the value 
entered in the Set Threshold Times on the Content tab. 

Table 17-11 describes the contents of each column of the Workgroup 
Interval Time Report.
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Table 17-11. Workgroup Interval Time Report Columns

Column Description

Interval The time span to report on in each row of the 
report. You can set the length for each interval 
in the Set Interval field on the Content tab 
when creating the report definition.

The total number of rows in the report is based 
on your specified Interval Time and the period 
covered by your report. For example, if you 
create a report for the period between 2:00 
p.m. and 4:00 p.m. of a single day, and you 
specified an Interval Time of 15 minutes, your 
report will contain eight rows.

Agent Answered The three columns under this heading 
correspond to the number of interactions 
accepted by Agents.

Below Threshold 1 The total number of interactions accepted by 
agents within the first defined threshold for 
interactions set for the report.

Threshold 1 to 
Threshold 2

The total number of interactions accepted by 
agents within the second defined threshold for 
interactions set for the report.

Greater than 
Threshold 2

The total number of interactions accepted by 
agents outside of the second threshold for 
interactions set for the report.

Abandon Interactions The total number of interactions where the 
client disconnected after entering the queue 
but before reaching an agent.

Total Interactions Total number of interactions received.

Service Performance Level The percentage of calls answered within the 
time specified (up to 60 seconds and as little 
as 5 seconds) in the Calls must be 
answered within or Chats must be 
answered within controls of the Content tab.
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To create a Workgroup Interval Time Report

1. Click Reports > Workgroup Productivity > Workgroup 
Interval Time. The Workgroup Interval Time screen appears, 
listing reports

2. Click the Add button. The Name tab of the Add Workgroup 
Interval Time report (Figure 17-18) appears.

Figure 17-8. Name Tab

Figure 17-8 Name Tab

3. Using the information in Table 17-12, complete the fields.

Table 17-12. Name Tab Fields and Descriptions

Field Description

Report 
Name

Type a name for this report. The name appears on each page of 
the report and in the Name column of the list of Workgroup 
Interval Time report definitions.
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4. Click the Content tab. The Content tab of the Workgroup 
Interval Time Report (Figure 17-9) appears.

Figure 17-9. Content Tab

Figure 17-9 Content Tab

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list of 
Workgroup Interval Time report definitions.

Table 17-12. Name Tab Fields and Descriptions

Field Description
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5. Using the information in Table 17-13, complete fields.

6. Click the Layout tab. The Layout tab of the Workgroup Interval 
Time Report (Figure 17-10) appears.

Table 17-13. Content Tab Fields and Descriptions

Field Description

Include 
Statistics On

In the Include Statistics On area, click the elements to 
include in the report:

• Workgroup Calls to report on phone interactions
• Callbacks to report on ACD callback interactions
• Web Callback to report on ACD Web callback interactions
• Chats to report on chat interactions
• Emails to report on email interactions
• Voicemails to report on ACD voicemails
• Faxes to report on fax interactions

Interval Time Type how long to set the time interval for the report (15 min., 
60 min, and so on).

Set 
Threshold 
Times

From the drop-down menus, select values for first and second 
thresholds for agents to respond to each type of interaction. 
(Select the time in hours, minutes, and seconds, as 
appropriate.)

Using Data 
Source

Identify the data source:

Click Projects and then, from the drop-down menu, 
select one or all projects.

Click Workgroups and then, from the drop-down menu, 
select one or all workgroups.
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Figure 17-10. Layout Tab

Figure 17-10 Layout Tab

7. Using the information in Table 17-14, complete fields.

8. Click the Regional Options tab. The Regional Options tab of the 
Workgroup Interval Time Report (Figure 17-11) appears.

Table 17-14. Layout Tab Fields and Descriptions

Field Description

Build Report Identify which elements to include in the report.
Click the item and then click the left arrow  (or just click 
the double-left arrow  to include all elements).

Arrange the order of the report columns by clicking an 
element and then clicking the up arrow ( ) to move a 
column to the up or click the down arrow ( ) to move the 
column to the down.
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Figure 17-11. Regional Options Tab

Figure 17-11 Regional Options Tab

9. Using the information in Table 17-15, complete the fields.

10. Click the Permissions tab. The Regional Options tab of the 
Workgroup Interval Time Report (Figure 17-12) appears.

Table 17-15. Regional Options Tab Fields and Descriptions

Choose... To Display...

Company Default 
Time Zone

All times using the time zone set for the company.

User Time Zone All times using the time zone set for your workstation.

Report Language All report contents in the language you choose.

Company Default 
Date Format

All dates using the format set for the company.

User Defined 
Date Format

All dates using the format set for your workstation.
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Figure 17-12. Permissions Tab

Figure 17-12 Permissions Tab

11. Identify the supervisors who can view and print this report.

a. Click any Supervisor to grant permission to any supervisor.

b. Click the following Supervisors and then select individual 
supervisors to grant them access. (Supervisors not checked 
cannot see the report definition in SM.)

c. Click All to include the entire list or click Clear to clear all 
selections.

12. Click OK.

• For how to view and print a report, see page 15-6. Also, since 
selecting a start and end time for this report is slightly 
different than for other reports, see “A Note About Start and 
End Times” on page 15-10.

• For how to delete a report, see page 15-14.
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Workgroup Interval Time by Media Report
The Workgroup Interval Time by Media Report (Figure 17-13) 
shows how agents are performing at specific times of the day. Report 
on time intervals as short as 1 minute and as long as 60 minutes. 

Use the Set Interval Time control to specify the length of the time 
intervals for the report. Figure 17-13 shows a sample Workgroup 
Interval Time by Media Report displaying intervals of 60 minutes.

Figure 17-13. Sample Workgroup Interval Time By Media Report

Figure 17-13 Sample Workgroup Interval Time By Media Report
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Report Elements

Each row of the Workgroup Interval Time by Media Report is 
dedicated to a single time interval based on the value you set in the 
Set Interval Time on the Content tab. 

Table 17-16 shows the report columns and descriptions.

To create a Workgroup Interval Time by Media Report

1. Click Reports > Workgroup Productivity > Workgroup 
Interval Time by Media. The Workgroup Interval Time by Media 
screen appears.

2. Click the Add button.

Table 17-16. Workgroup Interval Time by Media Report Columns

Column Description

Interval The time span to report on in each row of the report. Set the 
length for each interval in the Set Interval Time field on the 
Content tab when creating the report definition.

The total number of rows in the report is based on your 
specified Interval Time and the period covered by the report. 
For example, if you create a report for between 2:00 p.m. and 
4:00 p.m. of a single day, and you specified an Interval Time 
of 15 minutes, your report will contain eight rows.

Workgroup 
Calls

The total number of workgroup phone calls accepted by 
agents.

Callback The total number of callback interactions accepted by agents.

Workgroup 
Email

The total number of workgroup email interactions accepted by 
agents.

Workgroup 
Fax

The total number of workgroup fax interactions accepted by 
agents.

Web Callback The total number of Web callback interactions accepted by 
agents.

Chat The total number of chat interactions accepted by agents.

Workgroup 
Voicemail

The total number of workgroup voicemail interactions accepted 
by agents.

Total Total number of interactions received.
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The Name tab of the Workgroup Interval Time by Media 
Report (Figure 17-14) appears.

Figure 17-14. Name Tab

Figure 17-14 Name Tab

3. Using the information in Table 17-17, complete the fields.

Table 17-17. Name Tab Fields and Descriptions

Field Description

Report 
Name

Type a name for this report. The name appears on each page of 
the report and in the Name column of the list of Workgroup 
Interval Time by Media report definitions.

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list of 
Workgroup Interval Time by Media report definitions.
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4. Click the Content tab. 

The Content tab of the Workgroup Interval Time by Media 
Report (Figure 17-15) appears.

Figure 17-15. Content Tab

Figure 17-15 Content Tab

5. Using the information in Table 17-18, complete the fields.

Table 17-18. Content Tab Fields and Descriptions

Field Description

Set Interval 
Time

Type the number of minutes to report on in each row of the 
report. (For example, an interval of 60 minutes produces 24 
rows per calendar day.)
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6. Click the Layout tab. The Layout tab of the Workgroup Interval 
Time by Media Report (Figure 17-16) appear.

Figure 17-16. Layout Tab

Figure 17-16 Layout Tab

Using Data 
Source

Identify the data source:

Click Projects and then, from the drop-down menu, 
select one or all projects defined for your company.

Click Workgroups and then, from the drop-down menu, 
select one or all workgroups defined for your company.

Click Users and then, from the drop-down menu, select 
one or all agents, supervisors, and administrators defined 
for your company.

Table 17-18. Content Tab Fields and Descriptions

Field Description
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7. Using the information in Table 17-19, complete fields.

8. Click the Regional Options tab. The Regional Options tab of the 
Workgroup Interval Time by Media Report (Figure 17-17) 
appears.

Figure 17-17. Add Report Definition: Regional Options Tab

Figure 17-17 Add Report Definition: Regional Options Tab

Table 17-19. Layout Tab Fields and Descriptions

Field Description

Build Report Identify the elements to include in the report:
• Click an item and then click the left arrow ( ) or

or
• Click the double-left arrow ( ) to include all elements.

Arrange the order of the report columns:
• Click an element and then click the up arrow ( ) to move 

it up 
or 

• Click the down arrow ( ) to move it down.
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9. Using the information in Table 17-20, complete the Regional 
Options tab. 

10. Click Permissions. The Permissions tab of the Workgroup 
Interval Time by Media Type report (Figure 17-18) appears.

Figure 17-18. Add Report Definition: Permissions Tab

Figure 17-18 Add Report Definition: Permissions Tab

Table 17-20. Regional Options Fields and Descriptions

Choose... To Display...

Company Default 
Time Zone

All times using the indicated time zone set for the 
company.

User Time Zone All times using the indicated time zone set for your 
workstation.

Report Language All report contents in the language you choose.

Company Default 
Date Format

All dates using the indicated format set for the company.

User Defined 
Date Format

All dates using the indicated format set for your 
workstation.
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11. Check the supervisors to grant them permission to view and print 
the report. 

Unchecked supervisors will not see the report definition in SM. 

Click All to include the entire list or click Clear to clear all 
selections.

12. Click OK.

CCA saves the report in the database for access by any Adm or 
Supervisor who is logged into the company and to whom you have 
given permission to access the report. 

• For how to view and print a report, see “Viewing and Printing 
Standard Reports” on page 15-6.

• Also, since selecting a Start and End time for this report is 
slightly different than other reports, see “A Note About Start 
and End Times” on page 15-10.

• For how to delete a report, see “To delete a report” on page 
15-14.
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Outcome Statistics Report
The Outcome Statistics Report (Figure 17-19) tracks the results of 
interactions based on interaction type (workgroup call, Web callback, 
and so on). For each interaction type, the Outcome Statistics Report 
shows the number of interactions that were assigned that outcome by 
agents at the conclusion of the interaction. 

Figure 17-19. Outcome Statistics Report

Figure 17-19 Outcome Statistics Report

Each Outcome defined for the call center appears in each report group. 
The number of interactions receiving that outcome appears in each 
column (one interaction type per column).

Report Elements

Each data group of the Outcome Statistics Report is dedicated to a 
single interaction outcome, while the columns of the report detail the 
number of interactions to receive that outcome.
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Table 17-21 describes the contents of each column of the Outcome 
Statistics Report.

To create an Outcome Statistics Report

1. Click Reports > Workgroup Productivity > Outcome 
Statistics > the Add button.

The Add Outcome Statistics screen opens to the Name tab (Figure 
17-10).

Table 17-21. Outcome Report Interaction Types

Interaction Type Description

Workgroup Emails Email interactions

Workgroup Fax Fax interactions

Chat Chat interactions

Workgroup Calls Inbound telephone interactions routed to a 
workgroup agent.

Note: This number includes ACD callback requests, 
but does not include calls routed to voicemail.

Web Callback Web callback interactions

Outbound Outbound calls dialed through the CCA system.

Note: This number does not include outbound calls 
made by agents on telephone lines not controlled by 
CCA.

Inbound Inbound calls routed directly to an agent’s 
extension.

Note: This number does not include calls routed 
through the ACD Server to an available workgroup 
agent.

Preview Preview interactions

Predictive Predictive interactions

Callback Callback interactions.

Workgroup Voicemail Voicemails that were left for the workgroup.
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Figure 17-20. Add Report Definition: Name Tab

Figure 17-20 Add Report Definition: Name Tab

2. Using the information in Table 17-22, complete the fields.

3. Click Content. The Content tab (Figure 17-21) of the Outcome 
Statistics report appears.

Table 17-22. Name Tab Fields and Descriptions

Field Description

Report 
Name

Type a name for this report. The name appears on each page of 
the report and in the Name column of the list of Outcome 
Statistics Report definitions.

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list of 
Outcome Statistics Report definitions.
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Figure 17-21. Outcome Statistics Report: Content Tab

Figure 17-21 Outcome Statistics Report: Content Tab

4. Using the information in Table 17-23, complete the fields.

Table 17-23. Content Tab Fields and Descriptions

Field Description

Include 
Statistics 
On

In the Include Statistics On area, check the outcomes to 
include in the report. 

Click All to include all elements or click Clear to clear all the 
check boxes.
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5. Click Layout. The Layout screen (Figure 17-22) appears.

Figure 17-22. Outcome Statistics Report: Layout Tab

Figure 17-22 Outcome Statistics Report: Layout Tab

Using Data 
Source

Click the data group for the report:

• Projects: Choose from all projects defined for the company
• Users: Choose selected agents, supervisors, and 

administrator accounts defined for the company
• Users supervised by: Report on agents who are supervised 

by selected supervisors or administrators.
• Users from this workgroup: Report on users in a specific 

workgroup.
• Users from this department: Report on selected 

departments.

Table 17-23. Content Tab Fields and Descriptions

Field Description
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6. Using the information in Table 17-24, complete the fields.

7. Click Regional Options. The Regional Options tab (Figure 17-23) 
of the Outcome Statistics Report appears.

Figure 17-23. Add Report Definition: Regional Options Tab

Figure 17-23 Add Report Definition: Regional Options Tab

Table 17-24. Layout Tab Fields and Descriptions

Field Description

Build Report In the Elements box, click an element to include 
in the report and then click  (or just click  to 
include all elements).

Order the report columns by clicking an included 
element and then clicking the up arrow ( ) to 
move a column up or clicking the down arrow 
( ) to move the column down.

Include Chart in the 
Report

Check Include Chart in the Report to include a 
graphical representation of the report information 
in the generated report. 

Verify the report layout in the Preview area.
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8. Using the information in Table 17-25Complete the Regional 
Options tab.

9. Click Permissions. The Permissions tab (Figure 17-24) of the 
Outcome Statistics Report appears.

Figure 17-24. Add Report Definition: Permissions Tab

Figure 17-24 Add Report Definition: Permissions Tab

Table 17-25. Regional Options Tab Fields and Descriptions

Choose... To Display...

Company Default 
Time Zone

All times using the indicated time zone set for the 
company.

User Time Zone All times using the indicated time zone set for your 
workstation.

Report Language All report contents in the language selected.

Company Default 
Date Format

All dates using the indicated format set for the company.

User Defined 
Date Format

All dates using the indicated format set for your 
workstation.
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10. Check the supervisors to grant them permission to view and print 
the report. 

Unchecked supervisors cannot see the report definition in SM.

Click All to include the entire list or click Clear to clear all 
selections.

11. Click OK.

• For how to view and print a report, see “Viewing and Printing 
Standard Reports” on page 15-6. 

• For how to delete a report, see “To delete a report” on page 
15-14.
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Overdue Callbacks Report
The Overdue Callbacks Report (Figure 17-25) lists all waiting Web 
callback interactions. Based on your overdue criteria and the date and 
time for which the customer scheduled the callback, this report 
identifies whether interactions are overdue, recently overdue, or 
upcoming.

Figure 17-25. Overdue Callbacks Report

Figure 17-25 Overdue Callbacks Report

Report Elements

Each unhandled Web callback interaction listed in the Overdue 
Callbacks Report shows the date and time the customer requested 
the callback, as well as the contact information provided by the 
customer.
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The report places each interaction into one of the following groups:

Creating an Overdue Callbacks Report

1. Click Reports > Workgroup Productivity > Overdue Callbacks 
> the Add button. The Add Overdue Callbacks screen opens to the 
Name tab (Figure 17-26).

Figure 17-26. Add Report Definition: Name Tab

Figure 17-26 Add Report Definition: Name Tab

Table 17-26. Overdue Callbacks Report Groups

Group Description

Overdue The specified Overdue Threshold time elapsed since 
the time for which the customer requested the callback.

Recently Overdue The time for which the customer requested the callback 
passed, but your specified Overdue Threshold time has 
not yet elapsed.

Upcoming The time for which the customer requested the callback 
has not yet arrived.
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2. Using the information in Table 17-27, complete the fields.

3. Click Content. The Content tab (Figure 17-27) of the Overdue 
Callbacks screen appears.

Figure 17-27. Overdue Callbacks Report: Content Tab

Figure 17-27 Overdue Callbacks Report: Content Tab

Table 17-27. Name Tab Fields and Descriptions

Field Description

Report 
Name

Type a name for this report. The name appears on each page of 
the report and in the Name column of the list of Overdue 
Callbacks Report definitions.

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list of 
Overdue Callbacks Report definitions.
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4. Using the information in Table 17-28, complete the field.

5. Click Layout. The Layout tab (Figure 17-28) of the Overdue 
Callback screen appears.

Figure 17-28. Overdue Callbacks Report: Layout Tab

Figure 17-28 Overdue Callbacks Report: Layout Tab

Table 17-28. Content Tab Fields and Descriptions

Field Description

Overdue Threshold Type the number of minutes after which CCA reports all 
unhandled Web callback interactions as overdue.

For example, enter a value of 30 minutes. If the 
customer requested the callback for noon, CCA reports 
the interaction as “Recently Overdue” at 12:29 p.m. and 
as “Overdue” at 12:31 p.m.

Specify the Report 
Time Period

Check to allow the supervisor or administrator 
generating the report to specify a report date range. 

Clear this box to report on all unhandled Web callback 
interactions.

Using Data Source From the drop-down menu, select one or all of the 
projects.
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6. Using the information in Table 17-29, complete the fields.

7. Click Regional Options. The Regional Options tab (Figure 17-29) 
of the Overdue Callbacks screen appears.

Figure 17-29. Add Report Definition: Regional Options Tab

Figure 17-29 Add Report Definition: Regional Options Tab

Table 17-29. Layout Tab Fields and Descriptions

Field Description

Build Report In the Elements box, click an item to include in 
the report and then click an arrow ( ), or just 
click the double arrow ( ) to include all elements.

Order the report columns by clicking an included 
element and then clicking the up arrow ( ) to 
move a column up or click the down arrow ( ) to 
move the column down.

Include Chart in the 
Report

Check Include Chart in the Report to include a 
graphical representation of the report information 
in the generated report. 

Verify the report layout in the Preview area.
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8. Using the information in Table 17-30, complete the fields.

9. Click Permissions. The Permission tab (Figure 17-30) of the 
Overdue Callbacks screen appears.

Figure 17-30. Add Report Definition: Permissions Tab

Figure 17-30 Add Report Definition: Permissions Tab

Table 17-30. Regional Options Tab Fields and Descriptions

Choose... To Display...

Company Default 
Time Zone

All times using the indicated time zone set for the 
company.

User Time Zone All times using the indicated time zone set for your 
workstation.

Report Language All report contents in the language selected.

Company Default 
Date Format

All dates using the indicated format set for the company.

User Defined 
Date Format

All dates using the indicated format set for your 
workstation.
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10. Check the supervisors to grant them permission to view and print 
the report. 

Unchecked supervisors cannot see the report definition in SM. 

Click All to include the entire list or click Clear to clear all 
selections.

11. Click OK.

• For how to view and print a report, see “Viewing and Printing 
Standard Reports” on page 15-6. 

• For how to delete a report, see “To delete a report” on page 
15-14.
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18

The Predictive Reports 18

Predictive Dialer Totals Report
The Predictive Dialer Totals Report (Figure 18-1) shows a group of 
call-related statistics (number of calls, answer rate, and so on) for 
predictive dialing.

Figure 18-1. Sample Predictive Dialer Totals Report 

Figure 18-1 Sample Predictive Dialer Totals Report
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Report Elements

Table 18-1 shows the Predictive Dialer Totals Report items and their 
descriptions.

Table 18-1. Predictive Dialer Totals Report Fields and Descriptions

Item Description

Project Name The name of the Project(s) you selected for the report.

Time Each row in the report shows the statistics for one minute 
of predictive dialing. For example, if you chose a report 
start time of 9:00 am, and a report end time of 5:00 pm 
(View dialog > Period Covered tab), your report will have 
480 rows for each project that you selected (Edit > Projects 
tab). 

Number of Calls The number of predictive dialing calls that were made since 
the dialing started. 

This number is cumulative for as long as the predictive 
project is runs. If you stop the project, the number of calls 
resets to 0.

Number of 
Active Calls

This field shows the number of calls that were “active” in 
the system during the reporting interval.

A call is considered “active” when the system begins 
dialing that number. 

A call is considered “inactive” when a customer or 
agent hangs up or when the system hangs up. 

For example, if the project is in the 5th minute of running, 
the total number of calls made (Number of Calls) might be 
50. However, during the 5th minute, only 15 calls might be 
active.

Dropped Rate A dropped call occurs when the system hangs up on the 
customer before connecting the customer to an agent 
(because of system shutdown, no available agents, and so 
on).

The Dropped Rate is defined as: 

This field is cumulative.

Total number of calls dropped
Total number of calls answered by a customer
--------------------------------------------------------------------------------------------------------------------------
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Answer Rate The Answer Rate is defined as: 

This field is cumulative. 

Average Waiting 
Time

Wait time is the amount time that an agent was available 
but was not given a call. 

The Average Wait Time is the average amount of time that 
all agents in the project spent waiting to be given a call 
since predictive dialing began. This field is cumulative.

To be considered “waiting” an agent must be 
1. Available

2. Associated with a predictive project that is running. 

3. Logged into predictive dialing.

Number of Calls 
Per Hour

The average number of calls made per hour. It is defined 
as: 

Number of Calls 
Per Agent

The Number of Calls Per Agent is defined as: 

This field is cumulative.

Dialer Ratio Dialer ratio is the number of calls that are made 
simultaneously for an agent.

The dialer ratio can either be “fixed” or “pacing.“See the 
Dialer Ratio tab on page 10-20.

Table 18-1. Predictive Dialer Totals Report Fields and Descriptions

Item Description

Total number of calls answered by a customer
Total number of calls made

--------------------------------------------------------------------------------------------------------------------------

Total number of calls made
Total dialing time

------------------------------------------------------------------------ 60¥

Total number of calls
Total  number of times agents were available
-----------------------------------------------------------------------------------------------------------------------
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To create a Predictive Dialer Totals Report

1. Click Reports > Predictive/Preview Reports > Predictive 
Dialer Totals > the Add button. 

The Add Predictive Dialer Totals screen opens to the Name tab 
(Figure 18-2).

Figure 18-2. Add Report Definition: Name Tab

Figure 18-2 Add Report Definition: Name Tab

2. Type a Report Name and Description for the report.

Table 18-2. Name Tab Fields and Descriptions

Field Description

Report 
Name

The report name appears on each page of the report and in the 
Name column of the list of Predictive Dialer Totals Report 
definitions.
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3. Click Content. The Content tab (Figure 18-3) of the Predictive 
Dialer Totals screen appears.

Figure 18-3. Predictive Dialer Totals Report: Content Tab

Figure 18-3 Predictive Dialer Totals Report: Content Tab

4. Complete the Content tab.

Select one or all of your Projects.

5. Select Layout. The Layout tab (Figure 18-4) of the Predictive 
Dialer Totals screen appears.

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list of 
Predictive Dialer Totals Report definitions.

Table 18-2. Name Tab Fields and Descriptions

Field Description
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Figure 18-4. Predictive Dialer Totals Report: Layout Tab

Figure 18-4 Predictive Dialer Totals Report: Layout Tab

6. Using the information in Table 18-3, complete the fields.

7. Click Regional Options.The Regional Options tab (Figure 18-5) of 
the Predictive Dialer Totals screen appears.

Table 18-3. Layout Tab Fields and Descriptions

Field Description

Build Report In the Elements box, check elements to include in the 
report and then click the right arrow ( ) or just click the 
double arrows ( ) to include all elements)

Order the report columns by clicking an included element 
and then clicking the up arrow ( ) to move a column up or 
click the down arrow ( ) to move the column down.
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Figure 18-5. Add Report Definition: Regional Options Tab

Figure 18-5 Add Report Definition: Regional Options Tab

8. Using the information in Table 18-4, complete the fields.

Table 18-4. Regional Options Tab Fields and Descriptions

Choose... To Display...

Company Default 
Time Zone

Report all times using the time zone that set for the 
company.

User Time Zone Report all times using the time zone set for your 
workstation.

Report Language All report contents are in the language selected.

Company Default 
Date Format

All dates are formatted using the format set for the 
company.

User Defined 
Date Format

All dates are formatted using the format set for your 
workstation.
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9. Click Permissions. The Permissions tab (Figure 18-16) of the 
Predictive Dialer Totals screen appears.

Figure 18-6. Add Report Definition: Permissions Tab

Figure 18-6 Add Report Definition: Permissions Tab

10. Click the Any Supervisor button to give all supervisors access to 
the report. 

or

Click The Following Supervisors to select supervisors from a 
list.

11. Click OK (or Apply).

• For how to view and print a report, see “Viewing and Printing 
Standard Reports” on page 15-6. 

• For how to delete a report, see “To delete a report” on page 
15-14.
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Predictive Productivity Report
The Predictive Productivity Report provides a snapshot of results 
for a specific Predictive Dialing Project.

Figure 18-7. Predictive Productivity Report

Figure 18-7 Predictive Productivity Report
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Report Elements

Table 18-5 shows the Predictive Productivity Report columns and 
descriptions.

.

To create a Predictive Productivity Report

1. Click Reports > Predictive/Preview Reports > Predictive 
Productivity > the Add button.

The Predictive Productivity screen (Figure 18-8) opens to the Name 
tab.

Table 18-5. Predictive Productivity Report Columns

Column Description

Agent Name The name of agent included in report.

Log in Duration How long the agent was logged into the predictive 
campaign.

Talk Time How long the agent spent in “Busy Status” during the 
predictive campaign.

Talk Time per Log In The percentage of time the agent spent in “Busy 
Status” during predictive campaign.

Calls Taken The number of calls taken during login.

Calls per Hour The number of calls taken per hour (Number of 
Calls/Login Time)

Number of Sales The number of sales.

Close Rate Sales The percentage of sales against the number of calls 
taken during login.

Sales per Hour The number of sales per hour (Number of Sales/Login 
Time).

CCA_AM.book  Page 10  Wednesday, July 26, 2006  2:55 PM



The Predictive Reports 18-11

Figure 18-8. Add Report Definition: Name Tab

Figure 18-8 Add Report Definition: Name Tab

2. Using the information in Table 18-6, complete the fields.

3. Click Content. The Content tab (Figure 18-9) of the Predictive 
Productivity screen appears.

Table 18-6. Name Tab Fields and Descriptions

Field Description

Report 
Name

Type a name for this report. The name appears on each page of 
the report and in the Name column of the list of Predictive 
Productivity Report definitions.

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list of 
Predictive Productivity Report definitions.
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Figure 18-9. Predictive Productivity Report: Content Tab

Figure 18-9 Predictive Productivity Report: Content Tab

4. Using the information in Table 18-7, complete the fields.

Table 18-7. Content Tab Fields and Descriptions

Field Description

Include 
Statistics On

In the Include Statistics On area, check the outcomes to 
include in the report. 

Click All to include all elements or click Clear to clear all the 
check boxes.
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5. Click Layout. The Layout tab (Figure 18-10) of the Predictive 
Productivity screen appears.

Figure 18-10. Predictive Productivity Report: Layout Tab

Figure 18-10 Predictive Productivity Report: Layout Tab

Using Data 
Source

Click the data group for the report:
• Projects: Select from all projects defined for the company
• Users: Choose agents, supervisors, and administrator 

accounts defined for the company
• Users supervised by: Report on agents who are 

supervised by selected supervisors or administrators.
• Users from this workgroup: Report on users in a specific 

workgroup.
• Users from this department: Report on selected 

departments.

Table 18-7. Content Tab Fields and Descriptions

Field Description
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6. Using the information in Table 18-8, complete the fields.

7. Click Regional Options. The Regional Options tab (Figure 18-11) 
of the Predictive Productivity screen appears.

Figure 18-11. Add Report Definition: Regional Options Tab

Figure 18-11 Add Report Definition: Regional Options Tab

Table 18-8. Layout Tab Fields and Descriptions

Field Description

Build Report In the Elements box, click elements to include in the report 
and then click the right arrow ( ) or just click the 
double-arrow ( ) to include all elements.

Order the report columns by clicking an included element and 
then clicking the up arrow ( ) to move a column up or 
clicking the down arrow ( ) to move the column down.

The format of the report appears on the right hand side of 
the page.
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8. Using the information in Table 18-9, complete the fields.

9. Click Permissions. The Permissions tab (Figure 18-12) of the 
Predictive Productivity screen appears.

Figure 18-12. Add Report Definition: Permissions Tab

Figure 18-12 Add Report Definition: Permissions Tab

Table 18-9. Regional Options Tab Fields and Descriptions

Choose... To Display...

Company Default 
Time Zone

All times using the indicated time zone set for the 
company.

User Time Zone All times using the indicated time zone set for your 
workstation.

Report Language All report contents in the language selected.

Company Default 
Date Format

All dates using the indicated format set for the company.

User Defined 
Date Format

All dates using the indicated format set for your 
workstation.
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10. Check the supervisors to grant them permission to view and print 
the report. 

Unchecked supervisors cannot see the report definition in SM. 

Click All to include the entire list or click Clear to clear all 
selections.

11. Click OK.

• For how to view and print a report, see “Viewing and Printing 
Standard Reports” on page 15-6. 

• For how to delete a report, see “To delete a report” on page 
15-14.
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Predictive Summary Report
The Predictive Summary Report (Figure 18-13) lists the total 
occurrences of each possible Predictive Call result for the selected 
projects or workgroups.

Figure 18-13. Example Predictive Summary Report

Figure 18-13 Example Predictive Summary Report

Report Elements

The sample report in Figure 18-13 shows the results of some 
predictive dialing, but this report can also show statistics for actions 
and outcomes.

Refer to Table 18-10 for a description of the Predictive Summary 
Report columns.
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Table 18-10. Predictive Summary Report Columns

Column Description

Result The result of the predictive call attempt can be:

Answer: A person answered the predictive call.
Answer, Not Connected: The predictive call was answered 
but the agent and the client were not connected.
Answering Machine: An answering machine answered the 
predictive call.
Answering Machine, Not Connected: The predictive call 
was answered but the agent and the answering machine were 
not connected.
Busy: The predictive call resulted in a busy signal.
Error: An error (no dial tone, no line available, and so on) 
prevented the predictive call from being placed.
Fax: A fax machine answered the predictive call
Invalid: The number used for the predictive call was out of 
service or not a valid number
No Answer: There was no answer at the number dialed.

Action The action taken as a result of the predictive call attempt can 
be:
Abandon before connect: Call was abandon before 
connecting.
Call back: Will call this number back at the specified time.
Call back message: Left the specified message on the 
answering machine that answered the Predictive call and will 
call this number back at the specified time.
Call back message failed: Failed to leave the specified 
message on the answering machine that answered the 
predictive call.
Call failed: The predictive call failed.
Connect to agent: The predictive call was connected with an 
agent.
Leave message: Left the specified message on the answering 
machine that answered the predictive call.
Leave message failed: Failed to leave the specified message 
on the answering machine that answered the predictive call.
Out of list: The number was removed from the predictive 
database and will not be called again
Route to project: The predictive call was answered then 
routed to a project.
Route to project failed: The predictive call was answered but 
routing to the specified project failed.
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To create a Predictive Summary Report

1. Click Reports > Predictive/Preview Reports > Predictive 
Summary > the Add button. The Add Predictive Summary screen 
(Figure 18-14) opens to the Name tab.

Figure 18-14. Add Report Definition: Name Tab

Figure 18-14 Add Report Definition: Name Tab

Send fax: Sent the specified fax to the fax machine that 
answered the predictive call.
Send fax failed: An attempt to send a fax was unsuccessful

Outcomes Outcomes are call results that are configured by the company 
Administrator and assigned to the predictive project.

Total The total number of predictive call attempts receiving the result.

Table 18-10. Predictive Summary Report Columns

Column Description
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2. Using the information in Table 18-11, complete the fields.

3. Click Content. The Content tab (Figure 18-15) of the Predictive 
Summary screen appears.

Figure 18-15. Predictive Summary Report: Content Tab

Figure 18-15 Predictive Summary Report: Content Tab

Table 18-11. Name Tab Fields and Descriptions

Field Description

Report 
Name

Type a name for this report. The name appears on each page of 
the report and in the Name column of the list of Predictive 
Summary Report definitions.

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list of 
Predictive Summary Report definitions.
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4. Using the information in Table 18-12, complete the fields.

5. Click Layout. The Layout tab (Figure 18-16) of the Predictive 
Summary screen appears.

Table 18-12. Content Tab Fields and Descriptions

Field Description

Include 
Statistics On

Check the predictive summary to include in the report. See 
Results for a description of each of the possible Predict Result 
Types. See Actions for a description of each of the possible 
Action Types. See Outcomes for a description of the possible 
Outcomes types.

Click All or Clear to check or clear, respectively, the specific 
Predictive Summary to include in the report.

Using Data 
Source

Click the data group source to report:
• Projects: Choose from all projects defined for the company.
• Users: Choose selected agents, supervisors, and 

administrator accounts defined for the company.
• Users supervised by: Report on agents who are 

supervised by selected supervisors or administrators.
• Users from this workgroup: Report on users in a specific 

workgroup.
• Users from this department: Report on selected 

departments.
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Figure 18-16. Predictive Summary Report: Layout Tab

Figure 18-16 Predictive Summary Report: Layout Tab

6. Using the information in Table 18-13, complete the fields.

Table 18-13. Layout Tab Fields and Descriptions

Field Description

Build Report Order the report columns by clicking an included 
element and then clicking the up arrow ( ) to 
move a column up or click the down arrow ( ) to 
move the column down.

To include a chart in the report, select the Include 
Chart box and then select the type of chart to 
include. 

The format of the report appears on the right hand 
side of the page.
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7. Click Regional Options. The Regional Options tab (Figure 18-17) 
of the Predictive Summary screen appears.

Figure 18-17. Add Report Definition: Regional Options Tab

Figure 18-17 Add Report Definition: Regional Options Tab

8. Using the information in Table 18-14, complete the fields.

Include Chart in 
the Report

Click this check box to include a chart in the report; 
then choose the chart type (vertical bar, horizontal 
bar, or pie chart.).

Table 18-14. Regional Options Tab Fields and Descriptions

Choose... To Display...

Company Default 
Time Zone

All times using the indicated time zone set for the 
company.

User Time Zone All times using the indicated time zone set for your 
workstation.

Table 18-13. Layout Tab Fields and Descriptions

Field Description
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9. Click Permissions. The Permissions tab (Figure 18-18) of the 
Predictive Summary screen appears.

Figure 18-18. Add Report Definition: Permissions Tab

Figure 18-18 Add Report Definition: Permissions Tab

10. Check the supervisors to grant them permission to view and print 
the report.

Unchecked supervisors cannot see the report definition in SM. 

Report Language All report contents in the language selected.

Company Default 
Date Format

All dates using the indicated format set for the company.

User Defined 
Date Format

All dates using the indicated format set for your 
workstation.

Table 18-14. Regional Options Tab Fields and Descriptions

Choose... To Display...
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Click All to include the entire list or click Clear to clear all 
selections.

11. Click OK.

• For how to view and print a report, see “Viewing and Printing 
Standard Reports” on page 15-6.

• For how to delete a report, see “To delete a report” on page 
15-14.
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Predictive Detailed Report
The Predictive Detailed Report runs in a number of ways and the 
report can become quite large. In general, the report shows:

• Results of the call (answered, error, answer machine, and so on)

• Outcome of the call (sale, sale pending, no sale, and so on) 

• Actions taken after the call (call back later, leave a message, and 
so on)

Figure 18-19 shows a sample report for all results for each action.

Figure 18-19. Sample Predictive Detailed Report

Figure 18-19 Sample Predictive Detailed Report
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Report Elements

Table 18-5 describes the elements of the Predictive Detailed Report.

Table 18-15. Predictive Detailed Report Columns and Descriptions

Column Description

Project Name The CCA Predictive Calling Project name.

Outcome The outcome the agent assigned to the interaction. See 
“Creating Interaction Outcomes” on page 4-14.

Workgroup 
Name

The workgroup that handled the predictive call.

Result Type The result of the predictive call attempt:
Answer: A person answered the predictive call
Answer, Not Connected: The predictive call was answered 
but the agent and the client were not connected.
Answering Machine: An answering machine answered the 
predictive call
Answering Machine, Not Connected: The predictive call 
was answered but the agent and the answering machine were 
not connected.
Busy: The predictive call resulted in a busy signal.
Error: An error (no dial tone, no line available, and so on) 
prevented the predictive call from being placed.
Fax: A fax machine answered the predictive call.
Invalid: The number used for the predictive call was out of 
service or not a valid number.
No Answer: There was no answer at the number dialed.

Action The action taken as a result of the predictive call attempt:
Abandon before connect: Call was abandon before 
connecting.
Call back: Will call this number back at the specified time.
Call back message: Left the specified message on the 
answering machine that answered the predictive call and will 
call this number back at the specified time.
Call back message failed: Failed to leave the specified 
message on the answering machine that answered the 
predictive call.
Call failed: The predictive call failed.
Connect to agent: The predictive call was connected with 
an agent.
Leave message: Left the specified message on the 
answering machine that answered the predictive call.
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To create a Predictive Detailed Report

1. Click Reports > Predictive/Preview Reports > Predictive 
Detailed > the Add button. The Name tab (Figure 18-20) of the 
Predictive Detailed screen appears.

Figure 18-20. Add Report Definition: Name Tab

Figure 18-20 Add Report Definition: Name Tab

Leave message failed: Failed to leave the specified 
message on the answering machine that answered the 
predictive call.
Out of list: The number was removed from the predictive 
database and will not be called again.
Route to project: The predictive call was answered then 
routed to a project.
Route to project failed: The predictive call was answered 
but routing to the specified project failed.
Send fax: Sent the specified fax to the fax machine that 
answered the predictive call.
Send fax failed: An attempt to send a fax was unsuccessful.

Table 18-15. Predictive Detailed Report Columns and Descriptions

Column Description
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2. Using the information in Table 18-16, complete the fields.

3. Click Content. The Content tab (Figure 18-21) of the Predictive 
Detailed screen appears.

Figure 18-21. Predictive Detailed Report: Content Tab

Figure 18-21 Predictive Detailed Report: Content Tab

4. Using the information in Table 18-17, complete the fields

Table 18-16. Name Tab Fields and Descriptions

Field Description

Report 
Name

Type a name for this report. The name appears on each page of 
the report and in the Name column of the list of Predictive 
Detailed Report definitions.

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list of 
Predictive Detailed Report definitions.
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.

Table 18-17. Content Tab Fields and Descriptions

Field Description

Include 
Statistics On

The Predictive Detailed Report is a nested report. Select the 
‘outer nest” from the top three buttons. The bottom two radio 
buttons are the “inner nest.” 

Example 1: 
• Choose Results from the top three buttons
• Choose Actions from the bottom two buttons. 
The report will look like: 

Error (Result 1)
Callback (Action 1)
Callback Message (Action 2)
Connect to Agent (Action 3)
. . . 

Busy (Result 2)
Callback (Action 1)
Callback Message (Action 2)
Connect to Agent (Action 3)
. . . 

Example 2 - Try the reverse: 
• Choose Actions from the top three buttons
• Choose Results from the bottom two buttons. 
The report will look like: 

Callback (Action 1)
Error (Result 1)
Busy (Result 2)
No Answer (Result 3)
. . . 

Callback Message (Action 2)
Error (Result 1)
Busy (Result 2)
No Answer (Result 3)
. . . 
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5. Click Layout. The Layout tab (Figure 18-22) of the Predictive 
Detailed screen appears.

Figure 18-22. Predictive Detailed Report: Layout Tab

Figure 18-22 Predictive Detailed Report: Layout Tab

Using Data 
Source

Click the data group source to report.
• Projects: Choose from all projects defined for the company.
• Users: Choose selected agents, supervisors, and 

administrator accounts defined for the company.
• Users supervised by: Report on agents who are 

supervised by selected supervisors or administrators.
• Users from this workgroup: Report on users in a specific 

workgroup.
• Users from this department: Report on selected 

departments.

Table 18-17. Content Tab Fields and Descriptions

Field Description
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6. Using the information in Table 18-18, complete the fields.

7. Click Regional Options. The Regional Options tab (Figure 18-23) 
of the Predictive Detailed screen appears.

Figure 18-23. Add Report Definition: Regional Options Tab

Figure 18-23 Add Report Definition: Regional Options Tab

Table 18-18. Layout Tab Fields and Descriptions

Field Description

Build Report Order the report columns by clicking an included element 
and then clicking the up arrow ( ) to move a column up 
or clicking the down arrow ( ) to move the column 
down.

Include a Chart Click the Include a Chart” button to include a chart in 
the report. Then, select the type of chart to include.

The layout of the report appears on the right of the page.
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8. Using the information in Table 18-19, complete the fields.

9. Click Permissions. The Permissions tab (Figure 18-24) of the 
Predictive Detailed screen appears.

Figure 18-24. Add Report Definition: Permissions Tab

Figure 18-24 Add Report Definition: Permissions Tab

Table 18-19. Regional Options Tab Fields and Descriptions

Choose... To Display...

Company Default 
Time Zone

All times using the indicated time zone set for the 
company.

User Time Zone All times using the indicated time zone set for your 
workstation.

Report Language All report contents in the language selected.

Company Default 
Date Format

All dates using the indicated format set for the company.

User Defined 
Date Format

All dates using the indicated format set for your 
workstation.
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10. Check the supervisors to grant them permission to view and print 
the report. ‘

Unchecked supervisors cannot see the report definition in SM. 

Click All to include the entire list or click Clear to clear all 
selections.

11. Click OK.

• For how to view and print a report, see “Viewing and Printing 
Standard Reports” on page 15-6. 

• For how to delete a report, see “To delete a report” on page 
15-14.
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Preview Summary Report
The Preview Summary Report (Figure 18-25) displays a breakdown 
of the results (busy, no answer, and so on) of all preview call attempts 
and the follow-up action taken in response to each result.

Figure 18-25. The Preview Summary Report

Figure 18-25 The Preview Summary Report

Report Elements

Table 18-20 provides the Preview Summary Report columns and 
descriptions.

Table 18-20. Preview Summary Report Columns

Column Description

Project The CCA preview calling project name.

Outcome The outcome the agent assigned to the interaction.

Phone The telephone number dialed in the preview call attempt.

Action The action taken as a result of the predictive call attempt:
Call Back: Will call this number back at the specified time.
Call not connected: An answering machine answered the 
predictive call.
Connected: Predictive call was connected with an agent.
Failed to send fax: An attempt to send a fax was 
unsuccessful.
Fax file not found: The .TIF file to be faxed could not be 
found at the specified location.
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To create a Preview Summary Report

1. Click Reports > Predictive/Preview Reports > Preview 
Summary > the Add button. The Add Preview Summary screen 
(Figure 18-26) opens to the Name tab.

Figure 18-26. Add Report Definition: Name Tab

Figure 18-26 Add Report Definition: Name Tab

Fax sent: Sent the specified fax to the fax machine that 
answered the predictive call.
Left message and will call back: Left the specified message 
on the answering machine that answered the predictive call and 
will call this number back at the specified time.
License not available: No license is available to permit 
connection of the predictive interaction to an agent.
Message on the answering machine: Left the specified 
message on the answering machine that answered the 
predictive call.
Remove from list: The number was removed from the 
predictive database and will not be called again.

Table 18-20. Preview Summary Report Columns

Column Description
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2. Using the information in Table 18-21, complete the fields.

3. Click the Content tab. The Content tab (Figure 18-27) appears.

Figure 18-27. Preview Summary Report: Content Tab

Figure 18-27 Preview Summary Report: Content Tab

Table 18-21. Name Tab Fields and Descriptions

Field Description

Report 
Name

Type a name for this report. The name appears on each page of 
the report and in the Name column of the list of Preview 
Summary Report definitions.

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list of 
Preview Summary Report definitions.
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4. Using the information in Table 18-22, complete the fields.

5. Click Layout. The Layout tab (Figure 18-28) appears.

Figure 18-28. Preview Summary Report: Layout Tab

Figure 18-28 Preview Summary Report: Layout Tab

Table 18-22. Content Tab Fields and Descriptions

Field Description

Include 
Statistics On

Check the predictive results to include in the report. 

Click All to include all predictive results or click Clear to clear 
all selections.

Using Data 
Source

Click the data group source to report:
• Projects: Choose from all projects defined for the company.
• Users: Choose selected agents, supervisors, and 

administrator accounts defined for the company.
• Users supervised by: Report on agents who are 

supervised by selected supervisors or administrators.
• Users from this department: Report on selected 

departments.
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6. Using the information in Table 18-23, complete the fields.

7. Click Regional Options. The Regional Options tab (Figure 18-29) 
appears.

Figure 18-29. Add Report Definition: Regional Options Tab

Figure 18-29 Add Report Definition: Regional Options Tab

Table 18-23. Layout Tab Fields and Descriptions

Field Description

Build Report Order the report columns by clicking an included element 
and then clicking the up arrow ( ) to move a column up or 
clicking the down arrow ( ) to move the column down.

CCA_AM.book  Page 39  Wednesday, July 26, 2006  2:55 PM



18-40 CallCenterAnywhereTM Administration Manager

8. Using the information in Table 18-24, complete the fields.

9. Click Permissions. The Permissions tab (Figure 18-30) appears.

Figure 18-30. Add Report Definition: Permissions Tab

Figure 18-30 Add Report Definition: Permissions Tab

Table 18-24. Regional Options Tab Fields and Descriptions

Choose... To Display...

Company Default 
Time Zone

All times using the indicated time zone set for the 
company.

User Time Zone All times using the indicated time zone set for your 
workstation.

Report Language All report contents in the language selected.

Company Default 
Date Format

All dates using the indicated format set for the company.

User Defined 
Date Format

All dates using the indicated format set for your 
workstation.
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10. Check the supervisors to grant them permission to view and print 
the report. 

Unchecked supervisors cannot see the report definition in SM. 

Click All to include the entire list or click Clear to clear all 
selections.

11. Click OK.

• For how to view and print a report, see “Viewing and Printing 
Standard Reports” on page 15-6. 

• For how to delete a report, see “To delete a report” on page 
15-14.
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19

The Agent Profile and Productivity 
Reports 19

Agent Information Report
The Agent Information Report (Figure 19-1) can show the following 
profile information for each agent in the selected Workgroups:

• First and last name

• Telephone number

• Phone Extension

• Email address

• Active Address

• Skills assigned to the Agent

• Workgroups the Agent is a member of

Although you can select and remove columns from the 
report, this report always sorts by the agent’s last name.
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Figure 19-1. Agent Information Report

Figure 19-1 Agent Information Report

To create an Agent Information Report

1. Click Reports > Agent Profile & Productivity > Agent 
Information > the Add button.

The Add Agent Information (Figure 19-2) screen opens to the 
Name tab.

CCA_AM.book  Page 2  Wednesday, July 26, 2006  2:55 PM



The Agent Profile and Productivity Reports 19-3

Figure 19-2. Add Report Definition: Name Tab

Figure 19-2 Add Report Definition: Name Tab

2. Using the information in Table 19-1, complete the fields.

3. Click Content. The Content tab (Figure 19-3) appears.

Table 19-1. Name Tab Fields and Descriptions

Field Description

Report 
Name

Type a name for this report. The name appears on each page of 
the report and in the Name column of the list of agent 
Information report definitions.

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list 
of agent Information report definitions.
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Figure 19-3. Agent Information Report: Content Tab

Figure 19-3 Agent Information Report: Content Tab

4. Using the information in Table 19-2, complete the fields.

5. Click Layout. The Layout tab (Figure 19-4) appears.

Table 19-2. Content Tab Fields and Descriptions

Field Description

Include 
Statistics 
On

Click the data group source to report:
• Users: Choose selected agents, supervisors, and administrator 

accounts defined for the company.
• Users supervised by: Report on agents who are 

supervised by selected supervisors or administrators.
• Users from this workgroup: Report on users in a 

specific workgroup.
• Users from this department: Report on selected 

departments.
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Figure 19-4. Agent Information Report: Layout Tab

Figure 19-4 Agent Information Report: Layout Tab

6. Using the information in Table 19-3, complete the fields.

7. Click Regional Options. The Regional Options tab (Figure 19-5) 
appears.

Table 19-3. Layout Tab Fields and Descriptions

Field Description

Build Report In the Elements box. include elements by clicking an item 
and then clicking the right arrow ( ) or clicking the double 
arrows ( ) to include all elements.

Order the report columns by clicking an included element 
and then clicking the up arrow ( ) to move a column up or 
clicking the down arrow ( ) to move the column down.

Note: Although you can select and remove columns from the 
report, this report always sorts by the agent’s last name.
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Figure 19-5. Add Report Definition: Regional Options Tab

Figure 19-5 Add Report Definition: Regional Options Tab

8. Using the information in Table 19-4, complete the fields.

9. Click Permissions. The Permissions tab (Figure 19-6) appears.

Table 19-4. Regional Options Tab Fields and Descriptions

Choose... To Display...

Company Default 
Time Zone

All times using the indicated time zone set for the 
company.

User Time Zone All times using the indicated time zone set for your 
workstation.

Report Language All report contents in the language selected.

Company Default 
Date Format

All dates using the indicated format set for the company.

User Defined 
Date Format

All dates using the indicated format set for your 
workstation.
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Figure 19-6. Add Report Definition: Permissions Tab

Figure 19-6 Add Report Definition: Permissions Tab

10. Check the supervisors to grant them permission to view and print 
the report. 

Unchecked supervisors cannot see the report definition in SM. 

Click All to include the entire list or click Clear to clear all 
selections.

11. Click OK.

• For how to view and print a report, see “Viewing and Printing 
Standard Reports” on page 15-6. 

• For how to delete a report, see “To delete a report” on page 
15-14.
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Agent Interaction Report
The Agent Interaction Report (Figure 19-7) lets you analyze agent 
use by showing how long each agent spent handling interactions, 
awaiting interactions, or on break.

Figure 19-7. Agent Interaction Report

Figure 19-7 Agent Interaction Report

Report Elements

Each row of the Agent Interaction Report is dedicated to a single 
agent. The report columns show details on the interaction types 
handled by the agent. Table 19-5 provides a description for each of the 
columns appearing in this report.

If you run this report “by workgroup” (see “Using Data 
Source” on page 19-11) the report will NOT contain direct 
inbound or direct outbound calls that the agent made or 
received, since direct calls are not routed through 
workgroups.

Table 19-5. Agent Interaction Report

Column Description

Workgroup Calls The number of workgroup calls the agent accepted.
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To create an Agent Interaction Report

1. Click Reports > Agent Profile & Productivity > Agent 
Interaction > the Add button.

The Agent Interaction screen (Figure 19-8) opens to the Name tab.

Voicemail The number of voicemail interactions the agent accepted.

CallBack The number of callback interactions the agent accepted.

Web CallBack The number of Web callback interactions the agent 
accepted.

Outbound The number of outbound calls the agent placed to 
customers.

Inbound The number of inbound calls originated by a customer and 
accepted by the agent.

In Ext The number of telephone calls the agent received from to 
another CCA agent.

Out Ext The number of telephone calls this agent placed to other 
CCA agents.

Email The number of email interactions the agent accepted.

Fax The number of fax interactions the agent accepted.

Chat The number of chat interactions the agent accepted.

Preview The number of preview call interactions the agent placed.

Predictive The number of predictive call interactions the agent 
accepted.

Total The total number of interactions the agent handled.

Table 19-5. Agent Interaction Report

Column Description
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Figure 19-8. Add Report Definition: Name Tab

Figure 19-8 Add Report Definition: Name Tab

2. Using the information in Table 19-6, complete the fields.

3. Click Content. The Content tab (Figure 19-9) appears.

Table 19-6. Name Tab Fields and Descriptions

Field Description

Report 
Name

Type a name for this report. The name appears on each page of 
the report and in the Name column of the list of agent 
interaction report definitions.

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list 
of agent interaction report definitions.
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Figure 19-9. Agent Interaction Report: Content Tab

Figure 19-9 Agent Interaction Report: Content Tab

4. Using the information in Table 19-7, complete the fields.

Table 19-7. Content Tab FIelds and Descriptions

Field Description

Using Data 
Source

Click the data group source to report:
• Projects: Choose from all projects defined for the 

company.
• Users: Choose selected agents, supervisors, and 

administrator accounts defined for the company.
• Users supervised by: Report on agents who are 

supervised by selected supervisors or administrators.
• Users from this workgroup: Report on users in a 

specific workgroup.
Note: If you choose “Users from this Workgroup,” the 
report will NOT contain direct inbound or direct outbound 
calls that the agent made or received, since direct calls 
are not routed through workgroups. 

• Users from this department: Report on selected 
departments.
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5. Click Layout. The Layout tab (Figure 19-10) appears.

Figure 19-10. Agent Interaction Report: Layout Tab

Figure 19-10 Agent Interaction Report: Layout Tab

6. Using the information in Table 19-8, complete the fields.

7. Click Regional Options. The Regional Options tab (Figure 19-11) 
appears.

Table 19-8. Layout Tab Fields and Descriptions

Field Description

Build Report In the Elements box, include elements in the report by 
clicking the item and then clicking the right arrow ( ) or 
clicking the double arrows ( ) to include all.

Order the report columns by clicking an included element and 
then clicking the up arrow ( ) to move a column up or 
clicking the down arrow ( ) to move the column down.

CCA_AM.book  Page 12  Wednesday, July 26, 2006  2:55 PM



The Agent Profile and Productivity Reports 19-13

Figure 19-11. Add Report Definition: Regional Options Tab

Figure 19-11 Add Report Definition: Regional Options Tab

8. Using the information in Table 19-9, complete the fields.

9. Click Permissions. The Permissions tab (Figure 19-12) appears.

Table 19-9. Regional Options Tab Fields and Descriptions

Choose... To Display...

Company Default 
Time Zone

All times using the indicated time zone set for the 
company.

User Time Zone All times using the indicated time zone set for your 
workstation.

Report Language All report contents in the language selected.

Company Default 
Date Format

All dates using the indicated format set for the company.

User Defined 
Date Format

All dates using the indicated format set for your 
workstation.
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Figure 19-12. Add Report Definition: Permissions Tab

Figure 19-12 Add Report Definition: Permissions Tab

10. Check the supervisors to grant them permission to view and print 
the report. 

Unchecked supervisors cannot see the report definition in SM. 

Click All to include the entire list or click Clear to clear all 
selections.

11. Click OK.

• For how to view and print a report, see “Viewing and Printing 
Standard Reports” on page 15-6. 

• For how to delete a report, see “To delete a report” on page 
15-14.
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Agent Skills Report
The Agent Skills Report (Figure 19-13) lists: 

• All skills defined for the company

• Which agents possess each skill 

• Each agent’s rating for that skill

The Agent Skills Report quickly shows which agents possess each 
skill in the call center. Use this report to decide which agents to include 
in a workgroup with specific skills or requirements.

Figure 19-13. Agent Skills Report

Figure 19-13 Agent Skills Report
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To create an Agent Skills Report

1. Click Reports > Agent Profile & Productivity > Agent Skills > 
the Add button.

The Add Agent Skills screen (Figure 19-14) opens to the Name tab.

Figure 19-14. Add Report Definition: Name Tab

Figure 19-14 Add Report Definition: Name Tab

2. Using the information in Table 19-10, complete the fields.

Table 19-10. Name Tab FIelds and Descriptions

Field Description

Report 
Name

Type a name for this report. The name appears on each page of 
the report and in the Name column of the list of agent skills 
report definitions.
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3. Click Content. The Content tab (Figure 19-15) appears.

Figure 19-15. Agent Skills Report: Content Tab

Figure 19-15 Agent Skills Report: Content Tab

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list 
of agent skills report definitions.

Table 19-10. Name Tab FIelds and Descriptions

Field Description
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4. Using the information in Table 19-11, complete the fields.

5. Click Layout. The Layout tab (Figure 19-16) appears.

Figure 19-16. Agent Skills Report: Layout Tab

Figure 19-16 Agent Skills Report: Layout Tab

Table 19-11. Content Tab Fields and Descriptions

Field Description

Include 
Statistics 
On

In the Include Statistics On area, check the skills to include 
in the report. Click All to include all elements or click Clear to 
clear all the check boxes.

Use Data 
Source

Click the data group source to report:
• Users: Choose selected agents, supervisors, and administrator 

accounts defined for the company.
• Users supervised by: Report on agents who are supervised 

by selected supervisors or administrators.
• Users from this workgroup: Report on users in a specific 

workgroup.
• Users from this department: Report on selected 

departments.
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6. Using the information in Table 19-12, complete the fields.

7. Click Regional Options. The Regional Options tab (Figure 19-17) 
appears.

Figure 19-17. Add Report Definition: Regional Options Tab

Figure 19-17 Add Report Definition: Regional Options Tab

Table 19-12. Layout Tab Fields and Descriptions

Field Description

Build Report Order the report columns by clicking an included element and 
then clicking the up arrow ( ) to move a column up or 
clicking the down arrow ( ) to move the column down.

CCA_AM.book  Page 19  Wednesday, July 26, 2006  2:55 PM



19-20 CallCenterAnywhereTM Administration Manager

8. Using the information in Table 19-13, complete the fields.

9. Click Permissions. The Permissions tab (Figure 19-18) appears.

Figure 19-18. Add Report Definition: Permissions Tab

Figure 19-18 Add Report Definition: Permissions Tab

Table 19-13. Regional Options Tab Fields and Descriptions

Choose... To Display...

Company Default 
Time Zone

All times using the indicated time zone set for the 
company.

User Time Zone All times using the indicated time zone set for your 
workstation.

Report Language All report contents in the language selected.

Company Default 
Date Format

All dates using the indicated format set for the company.

User Defined 
Date Format

All dates using the indicated format set for your 
workstation.
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10. Check the supervisors to grant them permission to view and print 
the report. 

Unchecked supervisors cannot see the report definition in SM.

Click All to include the entire list or click Clear to clear all 
selections.

11. Click OK.

• For how to view and print a report, see “Viewing and Printing 
Standard Reports” on page 15-6. 

• For how to delete a report, see “To delete a report” on page 
15-14.

CCA_AM.book  Page 21  Wednesday, July 26, 2006  2:55 PM



19-22 CallCenterAnywhereTM Administration Manager

Agent Utilization Report
The Agent Utilization Report (Figure 19-19) helps you analyze agent 
activity by showing how long each agent spent handling interactions, 
awaiting Interactions, or on break.

Figure 19-19. Agent Utilization Report

Figure 19-19 Agent Utilization Report

To create an Agent Utilization Report

1. Click Reports > Agent Profile & Productivity > Agent 
Utilization > the Add button.

The Agent Utilization screen (Figure 19-20) opens to the Name 
tab.
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Figure 19-20. Add Report Definition: Name Tab

Figure 19-20 Add Report Definition: Name Tab

2. Using the information in Table 19-14, complete the fields.

3. Click Content. The Content tab (Figure 19-21) appears.

Table 19-14. Name Tab Fields and Descriptions

Field Description

Report 
Name

Type a name for this report. The name appears on each page of 
the report and in the Name column of the list of agent 
utilization report definitions.

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list 
of agent utilization report definitions.
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Figure 19-21. Agent Utilization Report: Content Tab

Figure 19-21 Agent Utilization Report: Content Tab

4. Using the information in Table 19-15, complete the fields.

Table 19-15. Content Tab Fields and Descriptions

Field Description

Include 
Statistics 
On

Check Timing to display the elapsed time each agent spent in 
each status. 

Check Percentage to display the time, expressed as a relative 
percentage, that each agent spent in each status.
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5. Click Layout. The Layout tab (Figure 19-22) appears.

Figure 19-22. Agent Utilization Report: Layout Tab

Figure 19-22 Agent Utilization Report: Layout Tab

Use Data 
Source

Click the data group source to report:
• Projects: Choose from all projects defined for the company.
• Users: Choose selected agents, supervisors, and administrator 

accounts defined for the company.
• Users supervised by: Report on agents who are 

supervised by selected supervisors or administrators.
• Users from this workgroup: Report on users in a specific 

workgroup.
• Users from this department: Report on selected 

departments.

Table 19-15. Content Tab Fields and Descriptions

Field Description
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6. Using the information in Table 19-16, complete the fields.

7. Click Regional Options. The Regional Options tab (Figure 19-23) 
appears.

Figure 19-23. Add Report Definition: Regional Options Tab

Figure 19-23 Add Report Definition: Regional Options Tab

Table 19-16. Layout Tab Fields and Descriptions

Field Description

Build Report Order the report columns by clicking an included element and 
then clicking the up arrow ( ) to move a column up or 
clicking the down arrow ( ) to move the column down.
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8. Using the information in Table 19-17, complete the fields.

9. Click Permissions. The Permissions tab (Figure 19-24) appears.

Figure 19-24. Add Report Definition: Permissions Tab

Figure 19-24 Add Report Definition: Permissions Tab

Table 19-17. Regional Options Tab Fields and Descriptions

Choose... To Display...

Company Default 
Time Zone

All times using the indicated time zone set for the 
company.

User Time Zone All times using the indicated time zone set for your 
workstation.

Report Language All report contents in the language selected.

Company Default 
Date Format

All dates using the indicated format set for the company.

User Defined 
Date Format

All dates using the indicated format set for your 
workstation.
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10. Check the supervisors to grant them permission to view and print 
the report. 

Unchecked supervisors cannot see the report definition in SM. 

Click All to include the entire list or click Clear to clear all 
selections.

11. Click OK.

• For how to view and print a report, see “Viewing and Printing 
Standard Reports” on page 15-6.

• For how to delete a report, see “To delete a report” on page 
15-14.

CCA_AM.book  Page 28  Wednesday, July 26, 2006  2:55 PM



The Agent Profile and Productivity Reports 19-29

Direct Dialing Statistics Reports
The Direct Dialing Statistics Report (Figure 19-25) shows 
non-Workgroup calls where:

• An agent dialed another agent

• Agents called external numbers

• A caller dialed an agent’s extension directly

Figure 19-25. Direct Dialing Statistics Report

Figure 19-25 Direct Dialing Statistics Report

Report Elements

The following sections describe each element included in the following 
areas of the Direct Dialing Statistics Report:

• Agent Call Processing
• Summary
• Interaction Type
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Agent Call Processing

The Agent Call Processing area of the Direct Dialing Statistics 
Report shows the average time agents spent in various phases of the 
interaction. Table 19-18 provides the fields and descriptions for this 
section of the report. 

Summary

The Summary area of the Direct Dialing Statistics Report shows 
overview data for interactions received and overview data for 
interaction wait times. Table 19-19 provides the fields and descriptions 
for this section of the report.

CCA Supervisors viewing the Direct Dialing Statistics 
Report should know that this report shows activity for the 
entire company. Data presented includes all agents in the 
selected project or workgroup (not just the agents they 
supervise).

Table 19-18. Agent Call Processing Area Fields and Descriptions

Item Description

Average Talk Time The average number of seconds agents spent 
talking with callers.

Average Hold Time The average number of seconds agents kept callers 
on hold.

Average Process 
Time Per Call

The average number of seconds agents spent 
processing a call (including talk time, hold time, 
and wrap-up time).

Table 19-19. Summary Area Fields and Descriptions

Item Descriptions

Total Interactions 
Received

The total number of interactions the company received.

Number of Times 
Interactions Went 
to Hold

The total number of voice interactions agents placed on 
hold at any time.
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Interaction Type

The Interaction Type area of the Direct Dialing Statistics Report 
shows the number of interactions of each media type selected projects 
or workgroups handled. Table 19-20 provides the fields and 
descriptions for this section of the report.

To create a Direct Dialing Statistics Report

1. Click Reports > Agent Profile & Productivity > Direct Dialing 
Statistics > the Add button.

The Direct Dialing Statistics screen (Figure 19-26) opens to the 
Name tab.

Duration of 
Interactions

The total time interactions spent in the system. CCA 
calculates this as the difference between the time CCA 
receives the interaction and the conclusion of the 
interaction.

Table 19-20. Interaction Type Area Fields and Descriptions

Item Description

Direct Inbound The number of calls placed by callers directly to an 
specific agent plus calls abandoned in the IVR 
before becoming an ACD call (even if the call was 
not directed to an agent). A caller using the 
company directory to reach a specific agent is also 
counted as a Direct Inbound call.

Direct Outbound The number of calls agents placed directly to an 
external phone number.

Inbound Extension The number of calls agents received from other 
agents.

Outbound Extension The number of calls agents placed to other agents

Total Interactions The total number of direct dialed calls agents 
placed or handled.

Table 19-19. Summary Area Fields and Descriptions

Item Descriptions
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Figure 19-26. Add Report Definition: Name Tab

Figure 19-26 Add Report Definition: Name Tab

2. Using the information in Table 19-21, complete the fields.

3. Click Content. The Content tab (Figure 19-27) appears.

Table 19-21. Name Tab Fields and Descriptions

Field Description

Report 
Name

Type a name for this report. The name appears on each page of 
the report and in the Name column of the list of direct dialing 
statistics report definitions.

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list 
of direct dialing statistics report definitions.
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Figure 19-27. Add Report Definition: Content Tab

Figure 19-27 Add Report Definition: Content Tab

4. Using the information in Table 19-22, complete the fields.

5. Click Regional Options. The Regional Options tab (Figure 19-28) 
appears.

Table 19-22. Content Tab Fields and Descriptions

Field Description

Include 
Statistics 
On

In the Include Statistics On area, check the elements to 
include in the report.

Click All to include all elements or click Clear to clear all the 
check boxes. 
See “Interaction Type” on page 19-31 for a description of each 
interaction type.

Using Data 
Source

Select one or all of the projects.
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Figure 19-28. Add Report Definition: Regional Options Tab

Figure 19-28 Add Report Definition: Regional Options Tab

6. Using the information in Table 19-23, complete the fields.

7. Click Permissions. The Permission tab (Figure 19-29) appears.

Table 19-23. Regional Options Tab Fields and Descriptions

Choose... To Display...

Company Default 
Time Zone

All times using the indicated time zone set for the 
company.

User Time Zone All times using the indicated time zone set for your 
workstation.

Report Language All report contents in the language selected.

Company Default 
Date Format

All dates using the indicated format set for the company.

User Defined 
Date Format

All dates using the indicated format set for your 
workstation.
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Figure 19-29. Add Report Definition: Permissions Tab

Figure 19-29 Add Report Definition: Permissions Tab

8. Check the supervisors to grant them permission to view and print 
the report. 

Unchecked supervisors cannot see the report definition in SM.

Click All to include the entire list or click Clear to clear all 
selections.

9. Click OK.

• For how to view and print a report, see “Viewing and Printing 
Standard Reports” on page 15-6. 

• For how to delete a report, see “To delete a report” on page 
15-14.
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Login by Groups of Users Report
The Login by Groups of Users Report (Figure 19-30) shows the 
total time agents and supervisors were logged into IM and SM. 

See “Login by User Report” on page 19-43 for the exact time each 
agent signed into or out of IM or SM.

Figure 19-30. Login by Groups of Users Report

Figure 19-30 Login by Groups of Users Report

To create a Login by Groups of Users Report

1. Click Reports > Agent Profile & Productivity > Login by 
Groups of Users > the Add button.

The Login by Groups of Users screen (Figure 19-31) opens to the 
Name tab.

CCA does not calculate data for a user until the user logs 
out of IM or SM. CCA excludes users currently logged in 
from the Summary Login Report.

In addition, CCA includes users in the report only if the 
user logged out on a day falling within the requested 
report date range.
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Figure 19-31. Add Report Definition: Name Tab

Figure 19-31 Add Report Definition: Name Tab

2. Using the information in Table 19-24, complete the fields.

3. Click Content. The Content tab (Figure 19-32) appears.

Table 19-24. Name Tab Fields and Descriptions

Field Description

Report 
Name

Type a name for this report. The name appears on each page of 
the report and in the Name column of the list of Login by 
Groups of Users Report definitions.

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list 
of Login by Groups of Users Report definitions.
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Figure 19-32. Login by Groups of Users Report: Content Tab

Figure 19-32 Login by Groups of Users Report: Content Tab

4. Using the information in Table 19-25, complete the fields.

5. Click Layout. The Layout tab (Figure 19-33) appears.

Table 19-25. Content Tab

Field Description

Include 
Statistics 
On

Click the data group source to report:
• Users: Choose selected agents, supervisors, and administrator 

accounts defined for the company.
• Users supervised by: Report on agents who are 

supervised by selected supervisors or administrators.
• Users from this workgroup: Report on users in a specific 

workgroup.
• Users from this department: Report on selected 

departments.
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Figure 19-33. Login by Groups of Users Report: Layout Tab

Figure 19-33 Login by Groups of Users Report: Layout Tab

6. Using the information in Table 19-26, complete the fields.

Table 19-26. Layout Tab Fields and Descriptions

Field Description

Build Report In the Elements box, include elements in the report by 
clicking the item and then clicking the right arrow ( ) 
or clicking the double arrows ( ) to include all.

Order the report columns by clicking an included 
element and then clicking the up arrow ( ) to move a 
column up or clicking the down arrow ( ) to move 
the column down.
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7. Click Regional Options. The Regional Options tab (Figure 19-34) 
appears.

Include Chart in the 
Report

Check Include Chart in the Report to include a 
graphical representation of the report information in the 
generated report. 

Under Select the Type of Chart, click the type of 
chart to include in the report. Verify the report layout in 
the Preview area.

From the Select the number of items to 
display drop-down menu, select the number of items 
to include in the graphical portion of the report.

Note: When making the selection of number of items to 
include in the graphical portion of the report, the graph 
creates its own filter showing only the agents with the 
longest login times. To remedy this, select a number 
corresponding with the total number of agents assigned 
to the company.

Table 19-26. Layout Tab Fields and Descriptions

Field Description
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Figure 19-34. Add Report Definition: Regional Options Tab

Figure 19-34 Add Report Definition: Regional Options Tab

8. Using the information in Table 19-27, complete the fields.

9. Click Permissions. The Permissions tab (Figure 19-35) appears.

Table 19-27. Regional Options Tab Fields and Descriptions

Choose... To Display...

Company Default 
Time Zone

All times using the indicated time zone set for the 
company.

User Time Zone All times using the indicated time zone set for your 
workstation.

Report Language All report contents in the language selected.

Company Default 
Date Format

All dates using the indicated format set for the company.

User Defined 
Date Format

All dates using the indicated format set for your 
workstation.
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Figure 19-35. Add Report Definition: Permissions Tab

Figure 19-35 Add Report Definition: Permissions Tab

10. Check the Supervisors to grant them permission to view and print 
the report. 

Unchecked supervisors cannot see the report definition in SM.

Click All to include the entire list or click Clear to clear all 
selections.

11. Click OK.

• For how to view and print a report, see “Viewing and Printing 
Standard Reports” on page 15-6. 

• For how to delete a report, see “To delete a report” on page 
15-14.
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Login by User Report
The Login by User Report (Figure 19-36) shows the total time 
agents and supervisors were logged into IM and SM. The report shows:

• The Login Date and Login Time of each agent session

• The Duration of each login session

• The Total time the agent was logged into IM (sum of all 
session durations)

Figure 19-36. Login by User Report

Figure 19-36 Login by User Report
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To create a Login by User Report

1. Click Reports > Agent Profile & Productivity > Login by User 
> the Add button.

The Login by User screen (Figure 19-37) opens to the Name tab.

Figure 19-37. Add Report Definition: Name Tab

Figure 19-37 Add Report Definition: Name Tab

2. Using the information in Table 19-28, complete the fields.

Table 19-28. Name Tab Fields and Descriptions

Field Description

Report 
Name

Type a name for this report. The name appears on each page of 
the report and in the Name column of the list of Login by User 
Report definitions.
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3. Click Content. The Content tab (Figure 19-38) appears.

Figure 19-38. Login by User Report: Content Tab

Figure 19-38 Login by User Report: Content Tab

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list 
of Login by User Report definitions.

Table 19-28. Name Tab Fields and Descriptions

Field Description
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4. Using the information in Table 19-29, complete the fields.

5. Click Layout. The Layout tab (Figure 19-39) appears.

Figure 19-39. Login by User Report: Layout Tab

Figure 19-39 Login by User Report: Layout Tab

Table 19-29. Content Tab Fields and Descriptions

Field Description

Using Data 
Source

Click the data group source to report:
• Users: Choose selected agents, supervisors, and 

administrator accounts defined for the company.
• Users supervised by: Report on agents who are 

supervised by selected supervisors or administrators.
• Users from this workgroup: Report on users in a 

specific workgroup.
• Users from this department: Report on selected 

departments.
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6. Using the information in Table 19-30, complete the fields.

7. Click Regional Options. The Regional Options tab (Figure 19-40) 
appears.

Figure 19-40. Add Report Definition: Regional Options Tab

Figure 19-40 Add Report Definition: Regional Options Tab

Table 19-30. Layout Tab Fields and Descriptions

Field Description

Build Report In the Elements box, include elements in the report by 
clicking the item and then clicking the right arrow ( ) or 
clicking the double arrows ( ) to include all.

Order the report columns by clicking an included element and 
then clicking the up arrow ( ) to move a column up or 
clicking the down arrow ( ) to move the column down.
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8. Using the information in Table 19-31, complete the fields.

9. Click Permissions. The Permissions tab (Figure 19-41) appears.

Figure 19-41. Add Report Definition: Permissions Tab

Figure 19-41 Add Report Definition: Permissions Tab

Table 19-31. Regional Options Tab Fields and Descriptions

Choose... To Display...

Company Default 
Time Zone

All times using the indicated time zone set for the 
company.

User Time Zone All times using the indicated time zone set for your 
workstation.

Report Language All report contents in the language selected.

Company Default 
Date Format

All dates using the indicated format set for the company.

User Defined 
Date Format

All dates using the indicated format set for your 
workstation.
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10. Check the supervisors to grant them permission to view and print 
the report. 

Unchecked supervisors cannot see the report definition in SM.

Click All to include the entire list or click Clear to clear all 
selections.

11. Click OK.

• For how to view and print a report, see “Viewing and Printing 
Standard Reports” on page 15-6.

• For how to delete a report, see “To delete a report” on page 
15-14.
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20

The Project Reports 20

Project Segments Report (formerly Project Key 
Statistics Report)

The Project Segments Report (Figure 20-1) shows a set of 
interaction statistics, broken down by interaction type (phone, email, 
and so on), and as a summary across all interaction types.

Figure 20-1. Sample Project Segments Report 

Figure 20-1 Sample Project Segments Report
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Report Elements

Table 20-1 provides the fields and descriptions for the Project 
Segments Report.

Table 20-1. Project Segments Report Fields

Item Description

Total Interactions The total number of interactions that occurred for 
the report time range.

Total Talk Time The total time that agents spent on interactions for 
the report time range.

Average Talk Time The average time agents spent on interactions.

Total Hold Time The total time all customers spent on hold for the 
report time range.

Average Hold Time The average time customers spent on hold for the 
time report time range.

Total Queue Time The total time all customers spent in a queue for 
the report time range.

Average Queue Time The average time customers spent in a queue for 
the report time range.

Longest Queue Time The longest time any customer spent in a queue for 
the report time range.

Shortest Queue Time The shortest time any customer spent in a queue 
for the report time range

Total Wrap-up Time The total time for all agents spent on wrapping-up a 
concluded interaction.

Average Wrap Up Time The average time agents spent on wrapping-up a 
concluded interaction.

Direct Calls The total number of calls made directly to an agent.

Note:
If a Direct Inward Dialing number (a DNIS) was set 
for an agent (see Options > Agents > Phone > 
Direct Inward Dialing), Direct Inbound calls are not 
included in reports unless a billing project is also set 
for the agent. 
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To create a Project Segments Report

1. Click Reports > Project > Project Segments > the Add button.

2. The Add Report Definition screen (Figure 20-2) opens to the Name 
tab.

Set billing projects for agents in two ways:
• AM > Options > Agents > Controls and 

Restrictions tab > Project Billing check box.
IM > Configuration dialog box > General tab > 
Project Billing check box.

Outbound Calls The total number of calls agents made directly to 
outside numbers.

Chat The total number of chat interactions occurring 
during the report time range.

Workgroup Email The total number of workgroup emails made during 
the report time range.

Web Callback The total number of Web callbacks made during the 
report time range.

Predictive The total number of predictive calls made during 
the report time range.

Preview The total number of preview calls made during the 
report time range.

Table 20-1. Project Segments Report Fields

Item Description
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Figure 20-2. Add Report Definition: Name Tab

Figure 20-2 Add Report Definition: Name Tab

3. Using the information in Table 20-2, complete the fields.

4. Click Content. The Content tab (Figure 20-3) appears.

Table 20-2. Name Tab Fields and Descriptions

Field Description

Report 
Name

Type a report name. The report name appears on each page of 
the report and in the Name column of the list of Project 
Segments Report definitions.

Description Type a description of the information in this report (or some text 
for differentiating this report from other reports of this type). 
The description appears in the Description column of the list of 
Project Segments Report definitions.
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Figure 20-3. Project Segments Report: Content Tab

Figure 20-3 Project Segments Report: Content Tab

5. Using the information in Table 20-3, complete the fields.

6. Click Regional Options. The Regional Options tab (Figure 20-4) 
appears.

Table 20-3. Content Tab Fields and Descriptions

Field Description

Include 
Statistics 
On

Click the data group source to report:
• Inbound Calls
• Outbound Calls
• Chat
• Workgroup Email 
• Web Callback
• Predictive
• Preview

Projects Click the Project box and then, from the drop-down menu, select 
a project or All projects.
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Figure 20-4. Add Report Definition: Regional Options Tab

Figure 20-4 Add Report Definition: Regional Options Tab

7. Using the information in Table 20-4, complete the fields.

8. Click Permissions. The Permissions tab (Figure 20-5) appears.

Table 20-4. Regional Options Tab FIelds and Descriptions

Choose... To Display...

Company Default 
Time Zone

Report all times using the time zone that was set for the 
company.

User Time Zone Report all times using the time zone set for your 
workstation.

Report Language All report contents will be in the language selected.

Company Default 
Date Format

All dates will be formatted using the format set for the 
company.

User Defined 
Date Format

All dates will be formatted using the format set for your 
workstation.
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Figure 20-5. Add Report Definition: Permissions Tab

Figure 20-5 Add Report Definition: Permissions Tab

9. Click the Any Supervisor button to give ALL supervisors access to 
the report. 

or

Click The Following Supervisors and then select supervisors 
from the list.

10. Click OK (or Apply). 

• For how to view and print a report, see “Viewing and Printing 
Standard Reports” on page 15-6. 

• For how to delete a report, see “To delete a report” on page 
15-14.
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A

Customizing Application Interfaces 
(Service Provider Edition only) A

CCA allows you to customize almost any text that appears on 
Interaction Manager, Supervision Manager, or Administration Manager 
screens.

While you cannot change the function of the controls and fields in CCA 
(with the exception of the customizable Interaction Manager screen, 
see Appendix B,  “Extending the Interaction Manager” ), you can 
replace the titles, messages, and labels on the CCA user interfaces so 
that they make the most sense to your Agents, Supervisors, and 
Administrators.

Changes to the CCA workstation interfaces are 
system-wide. This means, your changes affect all 
companies in the system.
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Interface Object Keys and Resource Bundles
Interface Object Keys contain the text that CCA displays to users in 
the Interaction Manager, Supervision Manager, and Administration 
Manager programs:

• Menu names
• Menu items
• Labels for check boxes, radio buttons, list boxes, and so on

A Resource Bundle is a file where CCA stores groups of related 
Interface Object Keys. For example, CCA stores most of the 
configurable text for Interaction Manager screens in a Resource Bundle 
called “Interaction Manager.”

Customizing Interface Text
There are three general steps to customizing interface text: 

1. Find the text that to change in the resource bundle file where CCA 
stores the text.

2. Make any changes. 

3. Generate new resource bundle files. 

Finding and Changing Text

In the Chat screen of the Interaction Manager program there is a 
“Collaborate” button. To change the name of this button to “View 
Customer’s Browser,” find out which resource bundle file contains the 
text “Collaborate.” 

Remember that any text change you make applies to every 
company.

CCA_AM.book  Page 2  Wednesday, July 26, 2006  2:55 PM



Customizing Application Interfaces (Service Provider Edition only) A-3

1. Log into AM with the netadmin account (see “Starting and 
Logging In” on page 3-3) and view the list of companies. 

In the top right corner of the screen is a menu called “Go To...” 
(Figure A-1).

Figure A-1 “Go To...” Menu

Figure A-1. “Go To...” Menu

2. Click the Go To menu and choose Resource Bundle.

The Resource Bundle dialog box (Figure A-2) opens.
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Figure A-2 Resource Bundle Dialog Box - Database Tab

Figure A-2. Resource Bundle Dialog Box - Database Tab

3. To modify a button name in IM, click the Resource Bundle list box, 
scroll down the list and choose Interaction Manager. (This is the 
resource file where CCA stores “general” text for IM.)

Most of the resource files have obvious names. For example, a 
resource bundle called “Agent Status” contains agent status. 
However, not all of the customizable text for an application is in 
the same resource bundle. CCA might distribute customizable text 
for IM in approximately 10 different files.

4. At the top right of the Resource Bundle dialog box, click the Value 
button.

5. In the text box under the Key and Value buttons, type the word 
Collaborate, then click the Go button or press return.
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In this example, the search for Collaborate had two results. The first 
string is the name of the button. The second string is the mouse over 
text for the button.

Figure A-3 Resource Bundle Dialog Box - Display Search Results

Figure A-3. Resource Bundle Dialog Box - Display Search Results

6. Double-click on the first row of the search results 
(acdChat.collaborate). The Key page appears. 

Click the Value column and enter the new text for the button. (You 
can enter new text for any of the languages CCA supports.)

The search field also does a default substring search, so:
- Col matches Collaborate and Color in Graph.
- You can also use the “%” as a wildcard, so %uba 
matches Cuba and Aruba.

CCA_AM.book  Page 5  Wednesday, July 26, 2006  2:55 PM



A-6 CallCenterAnywhereTM Administration Manager

When you finish entering the new text for the button, click the OK 
button. 

Use the steps shown above to make any other text changes: 

• Use the Resource Bundle list box in the Database tab to select 
the resource bundle file containing your text. You might have 
to search in a few different files to find the text to change, but 
most of the resource bundle files have fairly obvious names. 

• Change the text in the Key page and save your changes.

Customizing Text in Administration Manager

There is a shortcut for finding customizable text, but it is only 
supported in the AM program.

To customize text in AM 

1. Find the text to change. For example, in the AM Navbar, change 
the hyperlink “Skills” to “Talent”:

2. Click and hold the left mouse button on the word “Skills,” and while 
holding the mouse button down, press the “Control + shift + R” 
keys.

The Resource Bundle dialog box opens, and the resource bundle 
file containing the text “Skills” is selected by default. 

This shortcut makes it easy to find which of the AM resource bundle 
files contains the text to edit. Follow the steps in the previous section 
to find the “Skills” key/value row and make your text changes. 

CCA_AM.book  Page 6  Wednesday, July 26, 2006  2:55 PM



Customizing Application Interfaces (Service Provider Edition only) A-7

Figure A-4 Using the “Control-Shift-R” Method

Figure A-4. Using the “Control-Shift-R” Method

Generating New Resource Bundle Files

After making all text file changes, generate new resource bundle files 
containing the changes: 

1. Open the Resource Bundle dialog box and select the Files tab. 

2. In the Resource Bundle list box, select the resource bundle file that 
you modified. 

If you modified text in several different resource bundle files, you 
could select All in the Resource Bundle list box. However, 
depending on your network speed, Web server configuration, 
database resources, and so on, it could take a long time to 
generate all of the resource bundle files. In general it is faster to 
regenerate only the files you modified. 

3. In the Language list box, select the language for which you created 
new text, or select All. 

4. Click the Generate button.

 

Click on the text to change.
- Hold down the left mouse button, while you 
press “Control+Shift+R.”

You can use this technique to find any 
customizable text in the Administration 
Manager program
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Figure A-5 Resource Bundle Dialog Box - Files Tab

Figure A-5. Resource Bundle Dialog Box - Files Tab

CCA generates new resource bundle files containing your changes.

The next time users login, they will see your changes. 
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B

Extending the Interaction Manager B

You can customize the Interaction Manager so that it integrates with 
other applications, such as a CRM or Help Desk. This appendix 
describes how to perform the following tasks:

• Adding a Button and a Screen to the Interaction Manager
• Launching an External Application
• Capturing Contact Information from Predictive and Preview 

Interactions

Adding a Button and a Screen to the Interaction 
Manager

Add a control button to the IM interface to give agents access to a 
custom screen. Then, access and display interaction information to 
agents in that custom screen.

In IM, you can:

• Display an additional control button with a unique label
• Display an HTML file
• Access and use eight parameters describing interaction properties

To add a button to the Interaction Manager

1. Click Company Profile > Add button. The Add Company screen 
appears.

2. Click CRM Integration. The CRM tab (Figure B-1) appears.
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Figure B-1 Company Screen: CRM Integration Tab

Figure B-1. Company Screen: CRM Integration Tab

3. Check Enable custom tab in Interaction Manager.

4. In the Enter Text Label text box, type the text for the button.

5. In the Include HTML File text box, type the name of the HTML or 
JSP file to display when the agent clicks the custom button.

6. Click OK.

When the agent clicks the custom button, IM displays the HTML or JSP 
file specified. When IM receives a new interaction, Interaction Manager 
passes parameters describing the interaction to your custom code. 

For information about the parameters code can access and use, see 
“Interaction Parameters” on page B-3.
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Interaction Parameters

Each time CCA receives a new interaction, IM passes seven parameters 
(Table B-1) containing information about the incoming interaction to 
the HTML or JSP file. 

• If you use Java Server Pages for script content, access the values 
for these parameters using standard methods. 

• If you use HTML for script content, you must create your own 
methods to access the values for the parameters.

Table B-1 Interaction Parameters 

Parameter Description

intid Interaction ID

projectId Project ID

From Interaction ANI information

To Interaction DNIS information

urlscriptId Script ID

urlfaqId FAQ ID

type Interaction Type. Can be the following:

2001 = New inbound call
2002 = New outbound call
2003 = New predictive call
2004 = End call
2005 = New inbound extension
2006 = New outbound extension
2007 = New ACD call
2008 = New ACD web callback
2009 = New ACD callback
2010 = New ACD web phone
2011 = New ACD chat
2012 = New ACD email
2013 = New ACD voicemail
2014 = New ACD fax
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Launching an External Application
Configure IM workstations so that they launch an external application 
when the following actions occur:

• IM receives a new interaction 
• IM accepts an interaction
• An interaction in IM becomes the active interaction

To run an executable from the Interaction Manager

1. Click Company > Add button. The Add Company screen appears.

2. Click CRM Integration. The CRM Integration tab (Figure B-2) 
appears.

Figure B-2 Company Screen: CRM Integration Tab

Figure B-2. Company Screen: CRM Integration Tab

3. To invoke an application within the custom tab inside IM:
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a. Check Enable custom tab in Interaction Manager

b. In the Enter Text Label text box, type a name for the 
application.

c. In the Include HTML File text box, type the URL to the file to 
load in the custom tab.

d. Indicate when IM is to launch the application by choosing:

i. Every time a new Interaction is received: Launches 
the application every time IM receives a new interaction.

ii. When a new Interaction is accepted: Launches the 
application the first time the agent accepts the new 
interaction.

iii. Each time Interaction is accepted: Launches the 
application every time the agent makes the interaction the 
“Active” interaction.

iv. After each Interaction is complete: Launches the 
application ever time the agent completes an interaction

4. To invoke an external application without using the custom tab 
inside IM:

a. Click the External Application tab

b. Check Enable external application to invoke from 
Interaction Manager.

c. In the Application to invoke text box, type the full path to the 
location of the executable.

d. From the Application Type drop-down menu, select the window 
behavior:

i. HTML Modal: Opens a new Web browser window with the 
URL from the “Application to Invoke” text box. (Use this 
option when you do not want the user return to another 
application until this window is closed.)

ii. HTML Window: Opens a new Web browser window with 
the URL from the “Application to Invoke” text box. (Use 
this option when you want the user to minimize or close 
the window without selecting an option in the new window. 
The behavior is similar to standard Windows behavior.)
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iii. Win32 Window: Launches a Windows32 executable.

iv. Check Enable external application to invoke from 
Interaction Manager.

5. Identify when IM is to launch the application by choosing:

• Every time a new Interaction is received: Launches 
the application every time IM receives a new interaction.

• When a new Interaction is accepted: Launches the 
application the first time the agent accepts the new 
interaction.

• Every time Interaction is accepted: Launches the 
application every time the agent makes the interaction the 
“Active” interaction.

• After each Interaction is complete: Launches the 
application every time the agent completes an interaction

6. When IM launches your application, CCA passes an array 
containing the following strings (Table B-2) to the application:

You must install the application to launch on all Interaction 
Manager workstations.

Table B-2 Array Elements

String

Interaction ANI information

Interaction DNIS information

Project ID

Script ID

QA ID

Interaction ID

Interaction Type
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Enabling Predictive Call Handling
For agents to log in to predictive projects and to handle predictive 
interactions, you must enable Predictive Call Handling to display the 
necessary IM screen controls.

To enable predictive call handling

1. Click Company > Add button. The Add Company screen appears.

2. Click the Company Configuration tab. 

The Company Configuration tab (Figure B-3) appears.

Figure B-3 Company Screen: Company Configuration Tab

Figure B-3. Company Screen: Company Configuration Tab

CCA does not begin placing predictive calls until you start 
a Predictive Project (see “Starting and Stopping a 
Predictive Project” on page 10-25). 

Enabling Predictive Call Handling simply adds the 
Predictive button and login screen to the agent’s IM 
console so agent’s can handle predictive interactions.
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3. Check Enable Predictive.

4. Click OK.

CCA dynamically updates IM so that it displays the predictive button. 
Agents do not need to log out and log back into IM to see the button.

CCA_AM.book  Page 8  Wednesday, July 26, 2006  2:55 PM



Extending the Interaction Manager B-9

Capturing Contact Information from Predictive 
and Preview Interactions

IM Predictive and Preview screens contain a script frame to display 
HTML or JSP content for the agent to use when handling a contact. You 
specify the URL containing the script content in the Predictive and 
Preview tabs of the projects screen (see “Adding Predictive Calling to a 
Project” on page 10-15 and “Adding Chat Interactions to a Project” on 
page 10-56).

When the agent is handling a predictive or preview interaction, IM 
passes the following parameters (Table B-3) describing the contact to 
the code you supply to populate the script frame:

• If you use Java Server Pages for script content, access the 
values for these parameters using standard methods. 

• If you use HTML for script content, you must create your own 
methods to access the values for the parameters.

Table B-3 Predictive and Preview Contact Parameters

Parameter Contains

title The contact’s title.

firstname The contact’s first name

lastname The contact’s last name

companyname The contact’s company name

contactid The contact’s CCA identifier

dnis The contact’s telephone number

countrycode The contact’s telephone country code
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C

Integrating HEAT Call Logging C

CCA has built-in support for the HEAT Call Logging program. You can 
configure Administration Manager so that Supervision Manager or 
Interaction Manager automatically passes the customer ANI to the 
HEAT Call Logging application.

• A simple configuration process exists for both AM and the HEAT 
Administrator program.

• Decide when to pass the customer ANI to the Call Logging 
program: 
• Every time a new interaction is received.
• When a new interaction is accepted.
• When an interaction is made active.
• When an interaction is completed.

Configuring Administration Manager
Follow these steps to enable AM support for the HEAT Call Logging 
program:

1. Start AM. 

2. Select Options > Company > CRM Integration tab.

If you have the Service Provider Edition of AM, select 
the company that will be using HEAT Call Logging.
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3. Click the External Application subtab. The External Application 
tab (Figure C-1) appears.

Figure C-1 External Application Tab

Figure C-1. Internal Application Tab

4. Click the Enable external application to invoke from 
Interaction Manager check box. 

5. Using the information in Table C-1, complete the rest of the fields.

Table C-1 External Application Tab Fields and Descriptions

Field Description

Application to Invoke If you are using the HEAT Call Logging program, 
your CCA installation includes a special 
executable called HeatIntegration.exe. 

Netadmin only
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6. Click OK (or Apply) to save the changes.

Configuring HEAT Administrator
Follow these steps to enable support for CCA in the HEAT Administrator 
program:

1. Start the HEAT Administrator program.

2. In the HEAT Service and Support Data Source dialog box:

a. Select a data source 

b. Click OK.

3. In the HEAT Administrator login page:

CCA uses this executable to pass customer ANI 
information to the Call Logging program. Every 
user (agent and supervisor) must have access to 
this program. 

Although you could install HeatIntegration.exe on 
every user’s machine, it is usually more efficient 
to install the program on a network server, and 
then map a network drive to that server on each 
user’s machine. 

In the Application to Invoke text box, type the 
full path to the HeatIntegration.exe file (for 
example: y:\HeatIntegration.exe)

Application Type You must select Win32 Window. 

Run Application Select when to pass the customer ANI to the Call 
Logging program.

For example, choose “After Each Interaction is 
Complete” so that the customer ANI will not be 
passed to the Call Logging program until the 
current interaction ends.

Table C-1 External Application Tab Fields and Descriptions

Field Description
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a. Type your User ID and Password.

b. Click OK.

4. When the HEAT Administrator module opens, select:

Defaults menu > DDE/Telephony > Telephony Setup

5. In the Telephony Settings dialog box, select the Enable 
Telephony tab (Figure C-2).

Figure C-2 Enable Telephony Tab

Figure C-2. Enable Telephony Tab

a. Click the Enable Telephony Integration check box.

b. In the Telephony Application Name text box, type 
HeatIntegration.

c. Click OK.
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6. Select the DDE Service and Topic tab (Figure C-3).

Figure C-3 DDE Service and Topic Tab

Figure C-3. DDE Service and Topic Tab

7. Using the information in Table C-2, complete the screen.

8. Click OK to save the changes.

9. In the HEAT Administrator module, select:

Defaults menu > DDE/Telephony > Customer Search

10. In the DDE/Telephony Customer Search Defaults dialog box 
(Figure C-4):

Table C-2 DDE Service and Topic Tab Fields and Descriptions

In this field . . . Enter this value . . .

DDE Service HEATService

DDETopic HEATTopic

Outgoing DDE Service HeatIntegration

Outgoing DDE Topic TAWHEATIntegration

Netadmin only
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Figure C-4 Search Defaults

Figure C-4. Search Defaults

a. Select the field(s) to use when searching for the customer’s 
ANI.

b. Then, click the Add button. 

11. Click OK to save the changes.

The configuration for CCA Call Logging support is now complete. 

For CCA to Pass the Customer ANI to the Call Logging Program:

• The user (agent or supervisor) must have the CCA application (SM 
or IM) and the Call Logging program running on their machine. 

• If any user was running the Call Logging program while you were 
performing this configuration, ask the user to close the Call 
Logging program and re-start it.

Netadmin only
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D

Technical Notes D

Parameters Passed to External Applications
You can configure AM so that an existing Web page (or Win32 
application) launches from IM. For how to do this, see “CRM 
Integration” on page 3-27. 

When the Web page (or Win32 application) launches on the agent’s 
machine, CCA passes it a set of parameters containing information 
about the current interaction. 

• For a Web page, CCA passes the parameters in the URL string.

• For a Win32 application, CCA passes the parameters as command 
line arguments.

The Web page (or Win32 application) can contain code to parse the 
parameters and make some use of the information.

Parameters Passed to Win32 Applications

Table 4-1 provides a list of parameters that CCA passes to Win32 
applications.

Table 4-2 shows interaction states.

Table 4-3 shows interaction types.
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Table 4-1. Parameters Passed to Win32 Applications

Parameter Description

-a This parameter contains the ID of the agent making the call 
(for these calls only):
• Inbound calls
• Outbound calls to company extensions.
• Direct outbound calls to external numbers.
• Predictive and Preview calls

This parameter contains the customer’s phone number (for 
these calls only):
• ACD
• Direct Inbound

-d This parameter contains the ID of the agent making the call 
(for these calls only): 
• Inbound calls
• Outbound calls to company extensions.

This parameter contains the number that the agent called (for 
these calls only):
• Direct outbound calls to external numbers.
• Predictive and Preview calls

This parameter contains the project phone number (for these 
calls only):
• ACD calls

This parameter contains the number that the customer called 
(for these calls only):
• Direct Inbound

-p The ProjectId. The application finds the project name from 
the Projects Table.

-s The ScriptId. The application finds the script name from the 
LibraryURL Table.

-q The FAQId. The application finds the FAQ name from the 
LibraryURL Table.

-i The interaction ID.

-t An integer representing the interaction type ID. See 
Table 4-3.

-b The session ID on the Web server.
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Interaction States

Interaction Types

-u The agent’s user ID. The application finds the script name in 
the Users Table.

Table 4-2. Interaction States

Interaction State ID Description

2209 INTERACTION_INCOMING

2210 INTERACTION_HOLD

2211 INTERACTION_VOICEMAIL

2212 INTERACTION_ACTIVE

2213 INTERACTION_CREATE_CONFERENCE

2214 INTERACTION_CHAT

Table 4-3. Interaction Types

Interaction Type ID Description

2001 NEW_INBOUND_CALL

2002 NEW_OUTBOUND_CALL

2003 NEW_PREDICTIVE_CALL

2005 NEW_INBOUND_EXTENSION

2006 NEW_OUTBOUND_EXTENSION

2007 NEW_ACD_CALL

2008 NEW_ACD_WEB_CALLBACK

2009 NEW_ACD_CALLBACK

2011 NEW_ACD_CHAT

2012 NEW_ACD_EMAIL

2013 NEW_ACD_VOICEMAIL

2014 NEW_ACD_FAX

Table 4-1. Parameters Passed to Win32 Applications

Parameter Description
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Parameters Passed to Web Pages

Table 4-4 provides a list of parameters CCA passes to Web pages.

Table 4-5 provides a list of parameters CCA passes for chat and Web 
callback.

2024 NEW_OUTBOUND_EMAIL

2033 NOTE

3007 NEW_PREVIEW_CALL

3340 NEW_DIRECT_CHAT

3341 DIRECT_CHAT_SEND_MESSAGE

Table 4-4. Parameters Passed to Web Pages

Parameter Description

interactionId A unique ID for each installation. (Even for Service 
Provider customers, we never repeat this number, 
no matter how many companies they provide 
service to.) The number could, however, be 
repeated at a separate CCA installation.

projectId A unique ID for each project.

to The number the customer dialed.

from The customer’s ANI.

scriptId The ID of the script the project uses.

faqId The ID of the FAQ the project uses.

interactionType The interaction type ID. See Table 4-3 for a list of 
interaction types. 

state The State ID of the interaction. See Table 4-2 for a 
list of states.

display A string describing the interaction. The description 
appears in active interaction area.

agentFirstName The agent’s first name.

Table 4-3. Interaction Types

Interaction Type ID Description
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Web Parameters Passed for Chat and Web Callback

These parameters are passed to all Web pages, but they may be 
empty unless the interaction is a chat callback or a Web callback.

agentLastName The agent’s last name.

agentCompanyName The company to which the agent is associated.

companyId The customer’s company.

agentId A unique agent ID number.

imFirstName The contact’s first name. CCA always passes, but 
doesn’t populate unless a contact is assigned.

imLastName The contact’s last name. CCA always passes, but 
doesn’t populate unless a contact is assigned.

imCompanyName The contact’s company name. CCA always passes, 
but doesn’t populate unless a contact is assigned.

imContactId The contact’s ID. CCA always passes, but doesn’t 
populate unless a contact is assigned.

Table 4-5. Parameters Passed for Chat and Web Callbacks

Parameter Description

requestTime Time when the customer wants a call back. 
(Integer in number of seconds GMT since 1970.) 

contactId preview/predictive id.

offset The time zone. Sent as an offset from GMT in 
seconds.

queueTime Time the customer has been in the queue.

countryCode The country code the customer selected in the 
Web Callback screen.

timezone The timezone of the person who requested the 
Web callback.

rescheduleTime A callback has been rescheduled at this time.

Table 4-4. Parameters Passed to Web Pages

Parameter Description
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Wallboard
A standalone product (WallboardServer or WallboardServerW.exe) 
streams CCA data to the customer’s wallboard. The difference is the 
first one will run in a command prompt and the other will not. 

To start the application you must pass the parameter of the property 
file. (This file contains the setting allowing the application to connect to 
the Web server through the Web Service and to determine the port on 
which the server will listen.) 

1. File

a. WallboardServerW.exe - Application not running in a console.

b. WallboardServer.exe - Application running in a console.

email The email address the customer entered in the 
Request a Chat page.

priority The priority of the current interaction, taken from 
the project.

title No longer used.

extension The extension the customer entered in the Web 
Callback page or Chat Request page.

firstName The first name the customer entered in the Web 
Callback page or the Chat Request page.

lastName The last name the customer entered in the Web 
Callback page or the Chat Request page.

companyName The company name the customer entered in the 
Web Callback page or the Chat Request page.

phoneNumber Phone number the customer entered in the Web 
Callback page or Chat Request page.

countryCode If the current interaction is predictive or preview, 
this parameter has the value from the country 
code column in the dialer list.

Table 4-5. Parameters Passed for Chat and Web Callbacks

Parameter Description
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c. statistic.properties - Configuration file.

d. StatClient.exe - Application client for test purpose. Need to 
pass the following parameters:

i. StatClient.exe -h<Wallboard Server hostname> 
-p<Wallboard Server port>

For example: 
StatClient.exe -hpierre -p8001

2. Configuration file

a. statistic.properties

b. debugTracelevel=<Level of log file> DEBUG, ERROR, 
WARNING or INFO

c. debugLogFile=<Full file name>

d. debugMaxLogFileSize=<Size of the log file>

e. debugMaxNumberLogFiles=<Number of log file>

f. debugLogPattern=<Pattern of the logging information>

g. port=<Port on which the server will listening to accept 
connection>

h. pingDelay=<Delay to get the information from the Web 
Server>

i. url=<UR of the Web Server>

j. alias=<Alias of the company>

k. username=<Username - Must be a supervisor>

l. password=<Password of the user>

For Example:

debugTracelevel=DEBUG
debugLogFile=./Statistics.log
debugMaxLogFileSize=1024000000
debugMaxNumberLogFiles=5
debugLogPattern=%d{DATE} [%t] %-5p %c.%M(%F:%L) %x 
- %m
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port=8001

pingDelay=1000
url=http://pierre/
alias=Pete
username=super1
password=1234
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Index

Index

Symbols

$CONF_ID and $CONF_REC 8-48
$CONF_NOTIFY 8-53
$CONF_SUP 8-53
$HOURS, system variable 8-8
$MINUTES, system variable 8-8
$SECONDS, system variable 8-8

A

Access Levels (Permissions Levels), for Supervi-
sors 6-11
Accounts

creating 6-1
deleting an Agent Account 6-31
locking 3-43

ACD Intro, do not play 7-16
ACD Voicemail

description of 7-2
ACD_PRIORITY, system variable 8-7
Action

adding actions to a node 9-22
example of setting an action in a Campaign

9-8
example of using Get DTMF 9-10
using the Set Variable to Object action 9-62

Action for Predictive dialing 10-23
Activate Dial Code 10-4
Administration Manager overview 1-1
Administrator

Conditions for Predictive dialing 10-25
creating Accounts for 6-1

Agent

adding to a Workgroup 7-5
Agent Voicemail Prompts 5-18
Aggressivity Factor 10-21
automatic recording of 6-7
Conditions for Predictive dialing 10-25
creating Accounts for 6-1
deleting an Agent’s Account 6-31
email address 6-13
extension number 6-15
Follow Me feature 6-17
Hostname Phone Mapping 4-86
min number available 10-18
notification during Predictive dialing 10-19
number of times to ring 6-7
Play Agent Greeting 7-16
searching for 6-28
setting the Agent Status at login 6-10
Skills Library 4-2
specified in a Project 10-10
Statuses Library 4-6
will listen to ACD Voicemail by Email/Phone

setting 6-11
Agent Information Report 19-1
Agent Interaction Report 19-8
Agent Skills Report 19-15
Agent Utilization Report 19-22
Agent Voicemail, Route to Agent Voicemail in a
Phone Menu 8-17
Alarm Notification to Supervisor 3-17
Alias

for a Company 3-12
in a SQL Query Menu 8-37

Allow
Agent to respond directly to customer 10-70
caller to interrupt a Campaign prompt 9-26
customer to leave a Voicemail 7-16
customer to request a Callback 7-15
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Outbound Calls 3-40
routing association to wait 7-8
type ahead in a Campaign 9-57

Allow Wrap Up Time After Calls 6-9
And Play Prompt checkbox 8-18
ANI

passing to HEAT C-1
system variable 8-7

Applet Console Configuration 3-35
Application

in CRM Integration 3-29
launching external B-4

Application Interfaces, customizing A-1
Application Type, in the CRM Integration tab 3-31
Apply for Voice Interactions Only 3-47
Area Codes calling selected in Predictive dialing
10-35
Association tab, for routing Interactions 7-7
Audio, for Customers on Hold 10-5
Audio, Streaming 5-5
Authenticating, with LDAP 3-41

B

Begin Node, in a Campaign 9-6
Billing

setting for a Project 10-3
SIP 3-24

Billing Report 16-14
Blocking

creating a list of blocked numbers 14-2
long distance calls 6-9
Outbound Calls 14-1
Phone Number is Blocked listbox 10-74
Predictive Calls 14-4
Prompts for 5-26

Broadcast Music (Streaming Audio) 5-5
Business Event (Scheduled Event)

routing 9-38
Business Hours, setting for a Company 3-20

C

Call Blocking
blocking Outbound Calls 14-1
creating a list of blocked numbers 14-2
long distance 6-9
Prompts for 5-26

Call Center
planning 2-1
Prompts for 5-16

Call Center Operations Reports 16-1
Call Flow, overview of 1-5
Call Logging application C-1
Call Recording, allowing in Interaction Manager
6-7
Callback

adding web Callback to a Project 10-72
allow caller to request 7-15
max number of retries for a Predictive Call-

back 10-19
Overdue Callbacks Report 17-39
rescheduled Callbacks and Outcomes 4-12
Web Callback Priority 10-73
Workgroup Callback in a Campaign 9-32

Campaigns
adding actions to a node 9-22
adding child nodes 9-49
and the begin node 9-6
changing the Campaign settings 9-56
creating a new Campaign 9-53
draft and deployed 9-52
example of using a Menu Type 9-13
example of using Menu Routing Conditions

9-14
example of using the Get DTMF action 9-10
linking to a Project 9-17
overview 9-1
routing from one Campaign to another 9-20
routing to a Campaign from a Phone Project

10-10
routing to a Campaign from a Project Menu

8-18, 9-17
Tutorial 9-3
using variable reference fields 9-58

Case Structure in Project Menus 8-23
Changing languages with a Project Menu 8-21
Channels

max number available for 3-46
max voice available 10-18

Chat
adding Intelligent Chat templates to a Project

10-58
adding to a Project 10-56
creating a Chat Request Form 10-64
creating Intelligent Chat templates 4-73
max number of simultaneous 6-8
Priority in a Chat Project 10-57
Push Page, creating 4-5

Child Nodes
adding 9-49
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and Menu Routing 9-37
deleting 9-49
moving 9-51
searching for 9-51

CID, system variable 8-7
Clean List Tool 10-50
Client History Table, Synchronizing 3-26
Close Connection, in the Company Applet Console
tab 3-36
Collaboration

and push pages 10-62
enabling for an Agent 10-59
security settings 10-62

Company
alias 3-12
Applet Console Configuration 3-35
business hours 3-20
Company Directory Navigation Prompts 5-20
Conditions for Predictive dialing 10-25
Configuration tab 3-39
Contact Information 3-14
CRM Integration 3-27
Directory in a Menu 8-16
DNIS phone numbers 3-22
email addresses 3-15
entering during login 3-4
Options tab 3-32
overview of adding 3-11
profile 3-11
Prompt Library 4-16
Prompt, assigning to a variable 8-20
searching for 3-50
Time Zone and Date Format 3-19

Company Directory, Using in a Campaign 9-19
Comparison Operators 8-9
Conditional Routing in a Campaign (Menu Rout-
ing) 9-35
Conference

creating menus for scheduled conferences
8-43

scheduling 8-56
Configuration

for remote database 3-25
Confirmation, playing 10-8
Contact

Company Contact Information 3-14
deleting a Contact Template 4-52
Editing the System Contact Template 4-52
overview of Contact Templates 4-39
Template for a Project 10-3

CONVERTDATE, system variable 8-7
Country

Code, for customer 7-15

in Call Blocking 14-3
CRM

Integration tab 3-27
Integration, enabling the feature 3-34
parameters passed to external applications

D-1
CURRENTTIME, system variable 8-7
Custom

Application Interfaces A-1
changes to Interaction Manager B-1
Prompts 5-3
System Prompts 5-9

Custom/Advanced Reports
Daily Project Performance 15-4
Daily User Performance 15-4
Interaction Outcomeby Workgroup 15-5
Interval Workgroup Performance 15-4
Peak Interactions 15-5
System Peak Interactions 15-5
User Hourly Average 15-4
User Login/Logout 15-4
User Status Duration 15-5

Customer
allow caller to request a Callback 7-15
allow to leave Voicemail 7-16
creating customer priorities 12-2
enable Customer Priority in a Project 10-12
prompt for customer ID 10-8
show email address to Agent 10-70

D

Data Sources, Library of 4-19
Database

Data Source requirements for 4-21
queries in a Campaign 9-26
remote configuration 3-25

Database Source (Database Connection), Select-
ing in a Campaign 9-27
Date and Time Prompts 5-17
Date Format

in the Configuration dialog box 3-9
setting for a Company 3-19
setting for Agent/Supervisor 6-12

DATE, system variable 8-7
DAYOFWEEK, system variable 8-8
Debug Level, in the Company Applet Console tab
3-37
Debugging, setting options for 3-35
Default Link button in Touch-Tones tab 8-13
Default Routing Action in the Case tab 8-24
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Deleted Objects, in Historical Reports 15-16
Deployed Campaigns 9-52
Dial Code, set in a Project 10-4
Dialer List

adding to a Project 10-81
uploading 10-90

Dialer Ratio, definition of 10-20
Dialing all numbers in a Dialer List 10-29
Dialogic

Enabling the Dialogic Extension 3-33
extension for an Agent 6-15
extensions, in Hostname Agent Phone Map-

ping 4-88
Direct Dialing Statistics Report 19-29
Direct Inbound Calls, Forwarding 6-17
Direct Inward Dialing

in Company > DNIS tab 3-23
setting for an Agent 6-16

Directory, Company, in a Menu 8-16
Disable Agent Cache, in the Company Applet Con-
sole tab 3-36
Disable Elapsed Interaction Time, in the Company
Applet Console tab 3-38
Disable Phone State Time, in the Company Applet
Console tab 3-38
Disable Wrap Up Timer, in the Company Applet
Console tab 3-38
Disconnect

Chat disconnect URL 10-57
if no Agent is available 7-16
in a Campaign 9-19
in a Menu 8-16

Display Name, for a Company 3-13
Display Name, setting for a Company 3-13
Display Templates, creating 4-38
Distinguished Name, in LDAP Authentication 3-45
DNIS

enabling 3-34
numbers for a Company 3-22

DNIS, system variable 8-8
Do Not Call List, Using 10-50
Do Not Play ACD Intro 7-16
Domains, enabling collaboration across 10-61
Draft Campaigns 9-52
Dropped Calls, max percent allowed 10-21
DTMF, Routing in a Campaign 9-41

E

Editing a Custom Contact Template 4-54
Email

(Fax) return address for Agents 3-17
adding to a Project 10-66
address for Email Project 10-67
Agent can use email to access ACD Voicemail

6-11
Agent Email Address 6-13
alarm notification to Supervisor 3-17
correcting emails that were not sent 13-7
creating an Email Acknowledgment library

4-68
deleting email Interactions 13-9
Intelligent Email Template 4-70
sending from a Campaign 9-29
setting addresses for a Company 3-15
show customer email address to Agent 10-70
Storage Address 3-18
viewing Email Interactions 13-3

Enable
automatic recording of Agents 6-7
collaboration for Agents 10-60
Customer Priority Rating in a Project 10-12
Predictive feature in the company configura-

tion 3-40
Preview feature in the company configuration

3-40
Remote DB checkbox 3-25
report scheduling 15-12

Enable Log File, in the Company Applet Console
tab 3-37
Enable Project Interaction Limit 10-4
Enable Quality Control Recordings 9-31
Enable Telnet, in the Company Applet Console tab
3-37
end time, reports 15-10
Enter Digit Timeout, in a Campaign 9-57
Enter Text Labels, in the CRM Integration tab
3-28
Error Routing, in a Campaign 9-57
Estimated Wait Time 7-15

playing in a Campaign 9-31
Executable, in the CRM Integration tab 3-30
Exit Workgroup (from a Campaign) 9-31
Extension, Agent’s, in a Menu 8-15
External Applications, and Parameters for D-1
External Number

transferring to from a Campaign 9-20
External Transfer, in a Menu 8-18

F

FAQ
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creating 4-5
in a Web Callback 10-74
in an Email Project 10-68
select for a Project 10-8
setting the FAQ URL in a Campaign 9-32
used by a Menu 8-14
used by a Predictive Project 10-18
used in a Chat Project 10-57

Fax
adding to a Project 10-76
creating a Library of 4-60
return address for Agents 3-17
routing to a Fax number from a Campaign

9-21
routing to from a Menu 8-14

Finding a Company 3-50
First Push Page for a Chat Project 10-57
Fixed Mode 10-22
Follow Me

enabling in a Project 10-12
setting for an Agent 6-17

Force routing association 7-8
FTC Do Not Call List, Using 10-50
Full Permissions for a Supervisor 6-11

G

Get Digits Menu, creating 8-28
Get DTMF

details of 9-30
diagram showing the execution logic of 9-34
Example 9-10
routing to a DTMF child node 9-41

Get User Digits Action 9-26

H

H323
enabling for a Company 3-33
for Agent 6-15
in Hostname Agent Phone Mapping 4-87

Header, in a Contact Template 4-41
HEAT Integration C-1
Historical Reports and Deleted Objects 15-16
Hold Prompt, in a Workgroup 7-17
Hostname, and Agent Phone Mapping 4-86
Hot Keys 3-38
How to

access project menu types 8-1
add a button to the Interaction Manager B-1
add a Menu Type to a node 9-18
add a prompt to the Prompt Library 4-17
add agents when using LDP authentication

3-45
add an action to a node 9-22
add and remove agents to and from a work-

group 7-5
add or remove company configuration fea-

tures 3-39
add outcomes to a project 10-78
associate a campaign with a project 9-17
associate a campaign with a project menu

9-17
change your proxy settings in IE 3-6
complete the LDAP authentication policy

3-43
configure the company profile 3-11
correct an email error 13-7
create a Billing Report 16-15
create a Business Event 9-65
create a call blocking list 14-2
create a Company Prompt for routing to a

workgroup 5-11
create a customer chat window 10-65
create a customer Web Callback Request

form 10-75
create a database connection 9-68
create a Direct Dialing Statistics Report

19-31
create a draft campaign from a deployed

campaign 9-55
create a Get Digits menu 8-28
create a hostname/agent phone mapping

4-86
create a library of departments 4-76
create a library of email acknowledgments

4-68
create a library of faxes 4-60
create a library of Intelligent Chat Templates

4-73
create a library of Intelligent Email Tem-

plates 4-70
create a library of POP3 servers 4-66
create a library of SMTP server groups 4-64
create a library of SMTP Servers 4-62
create a library of URLs 4-4
create a list of phone project numbers 3-23
create a Login by Groups of Users Report

19-36
create a Login by User Report 19-44
create a Matching Patterns Library 4-82
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create a new Contact Template 4-39
create a Pattern Matching Group Library 4-84
create a Play Value menu 8-31
create a Predictive Detailed Report 18-28
create a Predictive Dialer Totals Report 18-4
create a Predictive Dialing Schedule 10-27
create a Predictive Productivity Report 18-10
create a Predictive Summary Report 18-19
create a Prefix Routing Group Library 4-80
create a Prefix Routing Pattern Library 4-78
create a Preview Summary Report 18-36
create a Project Key Statistics Report 20-3
create a project schedule 11-1
create a prompt for routing to a specific

agent within a workgroup 5-13
create a Record menu 8-40
create a sample Contact Template 4-42
create a Standard Menu 8-11
create a status 4-8
create a Weekly Project Routing Schedules

Report 16-3
create a workgroup 7-3
create a Workgroup Interval Time by Media

Report 17-24
create a Workgroup Interval Time Report

17-17
create a Workgroup Segments Report 17-8
create agent skills 4-2
create an Agent Information Report 19-2
create an Agent Interaction Report 19-9
create an Agent Skills Report 19-16
create an Agent Utilization Report 19-22
create an Outcome Statistics Report 17-32
create an SQL Query menu 8-35
create interaction outcomes 4-15
create the project definition 10-1
create the Project Menus for Scheduled Con-

ferences 8-44
create user accounts 6-4
create user-defined variables 8-4
creating a Workgroup Skills Report 16-10
customize a System Prompt 5-9, 5-14
customize text in AM A-6
delete a custom contact template 4-52
delete a label and header 4-48
delete a node 9-49
delete a report 15-14
delete a status 4-10
delete a workgroup 7-21
delete an agent 6-31
delete email interactions 13-9
deploy a campaign for the first time 9-55
edit the System Contact Template 4-54

edit the System Directory Template 4-56
edit the System Transfer Template 4-57
enable customer priority for a project 12-3
enable or disable features 3-32
enable predictive call handling B-7
enter or edit company contact information

3-14
install configuration 1 4-24
install configuration 2 4-25
install configuration 3 4-28
install configuration 4 4-30
install configuration 5 4-33
install configuration 6 4-36
integrate CRM 3-27
launch AM the first time 3-3
make outcomes required for an agent 4-14
manipulate columns of information 3-51
manually start a predictive project 10-26
manually stop a predictive project 10-27
override workgroup prompts for a project

10-79
perform advanced troubleshooting 3-35
play streaming audio (music broadcast) 5-5
provide custom Web applications access to

CCA database tables 3-25
rearrange labels and headers 4-48
re-deploy a campaign 9-55
remove a Menu Type from a node 9-21, 9-35
restore a System Prompt 5-15
restore a System Template 4-59
restore a user’s access after a permanent

lock out 3-43
route a call based on the caller’s telephone

number 10-13
run an executable from the Interaction Man-

ager B-4
schedule a report 15-12
search for a company definition 3-50
search for an agent 6-28
search on a column 6-29
search with a wildcard 6-29
see a list of all accounts 6-28
select fax responses for a project 10-76
select the columns the agent sees when

viewing a list of contacts 4-50
set a login policy 3-41
set a time zone and date format for the com-

pany 3-19
set company business hours 3-21
set customer priority 12-2
set service levels for a workgroup 7-20
set up a chat project 10-56
set up a Matching Pattern 10-41
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set up a predictive project 10-16
set up a project to handle phone interactions

(calls and faxes) 10-5
set up a Web callback project 10-72
set up an email project 10-66
set up shared-number phone projects for

scheduling 10-15
set up the company email addresses 3-16
set workgroup overflow conditions 7-11
set your inactivity timeout 3-10
set your language 3-8
set your time zone and date format 3-9
start the DNC List Clean List Tool 10-50
understand system statuses 4-6
upload a Dialer List 10-90
upload a DNC change list 10-54
upload a DNC List for the first time 10-51
use SIP billing 3-24
use the Case tab 8-25
use the Set Variable Control 8-19
view email interactions 13-3
view or print reports 15-6, 15-10
weigh the skills in a workgroup 7-9

I

If 8-15
If Call Center Is Closed 10-57
If No Agent Available 10-57
Inactivity Timeout

for Administrators 3-10
for Agents and Supervisors (Company Level)

3-13, 3-14
for Agents and Supervisors Agent Level) 6-9

Inbound Calls, Forwarding 6-17
Inbound Traffic Report 15-5
Include HTML Files, in the CRM Integration tab
3-29
Initial Wait Time 7-15
INTDATE, system variable 8-8
Intelligent

Email Template 4-70
Email Templates in a Project 10-71
Email, enabling the feature 3-34
URL for Intelligent Email 4-5

Interaction History Table, Synchronizing 3-27
Interaction Limit box 10-4
Interaction Limitations 3-47
Interaction Manager, customizing B-1
Interaction Timeouts 4-11
Interactions

adding Chat to a Project 10-56
adding Email to a Project 10-66
adding Fax Responses to a Project 10-76
adding Interaction Outcomes to a Project

10-78
adding Phone Interactions to a Project 10-5
adding Web Callback 10-72
deleting email Interactions 13-9
Interaction Outcomes Library 4-14
max number of simultaneous 3-46, 6-8
Overflow of 7-12
viewing email Interactions 13-3

Internal Voicemail 3-49
International calls, enabling 6-9
Internet Explorer

setting a Proxy in 3-6
INTID, system variable 8-8
Intro Prompt, in a Workgroup 7-17
Invalid Entry, in a Menu 8-14
IVR Routing

enabling the feature 3-34
in a Menu 8-15

L

Language
choosing when you login 3-5
default for a Project 10-3
setting in a Campaign 9-28
setting in the Configuration dialog box 3-8
using a Project Menu to change languages

8-21
Launching external applications B-4
LDAP

and an Agent’s "default" password 6-5
in a login policy 3-41

Levels, Workgroup Service 7-19
Library

Agent Skills 4-2
Agent Statuses 4-6
Company Prompt 4-16
creating Intelligent Chat Templates 4-73
Data Sources 4-19
Department Library 4-76
Email Acknowledgment 4-68
Fax 4-60
Hostname Agent Phone Mapping 4-86
Intelligent Email Template 4-70
Interaction Outcomes 4-14
Matching Patterns 4-82
Pattern Matching Group 4-84
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POP3 Server 4-66
Prefix Routing Group 4-80
Prefix Routing Pattern 4-77
SMTP Server 4-62
SMTP Server Group 4-64
URL 4-4

licenses 3-47
Licensing tab 3-46
Limited Permissions for a Supervisor 6-11
Locking a user account 3-43
Logical Operators (Comparison Operators) 8-9
Login

max number of users allowed to login 3-46
policy in Company tab 3-41
setting the Agent Status at login 6-10
to Administration Manager 3-3

Login by Groups of Users Report 19-36
Login by User Report 19-43
Long Distance

calls, enabling 6-9
Password for 10-4

M

Mail Manager 13-3
Mail Server 3-49
Mailbox Manager

routing to from a Campaign 9-20
Mailbox Manager, routing to the Mailbox Manager
in a Phone Menu 8-16
Manually starting a Predictive Project 10-26
Matching Patterns Library 4-82
Max Number of Simultaneous Interactions Al-
lowed 3-47
Maximum

Dropped Call Rate 10-21
number of channels used by Predictive dial-

ing 3-46, 3-48
number of retries for a Predictive Callback

10-19
number of simultaneous Interactions for an

Agent 6-8
number of users that can login 3-46, 3-48
Recording Time 8-42
simultaneous Interactions for a company

3-46, 3-48
voice channels to use for a Project 10-18

Menu
allow customer to select 7-16
and scheduled conferences 8-44
creating a Project Menu 8-1

Get Digit 8-23, 8-28
Implementing Your Project Menu 8-43
Play Value Menu 8-31
played before/after a voicemail 10-11
playing after disconnect 10-4
Prompt in 8-12
Record Menu 8-40
routing to 7-16
routing to from a Campaign 9-19
SQL Query Menus 8-35
transfer from one Menu to another 8-15
types 8-1
used by a Project 10-10

Menu Played before/after Voicemail 10-11
Menu Routing Conditions 9-35
Menu Routing Conditions Example 9-14
Menu Type

adding to a node 9-18
and the Set Variable to Object Action 9-60
removing a Menu Type from a node 9-35

Menu Type Example 9-13
Menu Types

details of the Menu Types dialog box 9-18
Minimum number of available Agents 10-18
Minimum Pool Size 10-22
Mode

Pacing 10-21
Predicting 10-18

Music
configuring Music Broadcast 5-5
enabling Music Broadcast 10-5
for Workgroup Prompts 10-81

Music Broadcast
using in a Campaign 9-28

Music Prompt, in a Workgroup 7-17

N

Navigation Prompts 5-20
Node

adding 9-49
adding a Menu Type to a node 9-18
adding actions to a node 9-22
deleting 9-49
Menu Routing and child nodes 9-37
moving 9-51
remove a Menu Type from a node 9-21
removing a Menu Type from a node 9-35
routing from one node to another 9-21
searching for 9-51

Non-ACD Voicemails, allowing Agents to retrieve
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with the Mailbox Manager 8-16
Number

of Digits to Activate Dial Code 10-4
of retries before disconnect 8-29
of rings before Agent must answer 6-7
Prompts made from numbers 5-17

Number of Login Attempts 3-43
Numeric Operators 8-9

O

Objects, Deleted, and Historical Reports 15-16
Offline Interactions, and Service Levels 7-19
Online Interactions, and Service Levels 7-19
Operators

supported types 8-8
using in the Case tab 8-24

Options
setting for a Company 3-32
setting for Workgroups 7-14

Order of Workgroup Prompts 5-25
Outbound

blocking Outbound Calls 3-40
blocking outbound calls 14-1

Outcome Statistics Report 17-31
Outcomes

adding to a Project 10-78
and rescheduled Callbacks 4-12
Interaction Outcomes Library 4-14
requiring 6-10

Outside phone for Agent 6-15
Overdue Callbacks Report 17-39
Overflow Conditions in a Workgroup 7-11

P

Pacing Mode 10-21
Parameters Passed to External Applications D-1
Password

entering for an Agent 6-5
for Agent’s POP3 Server 6-13
for long distance 10-4
in a SQL Query Menu 8-37
in LDAP Authentication 3-45
restrictions in a login policy 3-42

Pattern
creating a Matching Patterns Library 4-82
creating a Pattern Matching Group Library

4-84
Prefix Routing Group Library 4-80
Prefix Routing Pattern Library 4-77

PBX
enabling for a Company 3-33
for Agent 6-15
in Hostname Agent Phone Mapping 4-88

Percentage of calls to record 6-7
Permission in a Predictive Project 10-24
Permission Levels, for Supervisors 6-11
Phone

adding Phone interactions to a Project 10-5
adding Predictive calling to a Project 10-15
Agent Extension Number 6-15
Agent has no phone 6-15
blocking Outbound Calls 14-1
creating a list of blocked numbers 14-2
enable long distance 6-9
enabling the Outside Phone option 3-33
Hostname Agent Phone Mapping 4-86
in a Scheduled Project 11-2
number for a Project 10-3
number of times to ring an Agent 6-7
outside for Agent 6-15
outside, in Hostname Agent Phone Mapping

4-88
recording calls in Interaction Manager 6-7
routing to a Campaign from a Phone Project

10-10
setting Company DNIS 3-22
sharing phone numbers between Projects

10-14
starting and stopping Predictive 10-25
transfer to an external number from a Cam-

paign 9-20
validate phone number 10-7

Phone Number is Blocked 10-74
Ping Delay in Seconds, in the Company Applet
Console tab 3-38
Planning Your Call Center 2-1
Play

Agent Greeting 7-16
audio on hold 10-5
Confirmation 10-8
estimated wait time 7-15
estimated wait time in a Campaign 9-31
Notification Beep (Predictive) 10-19
project menu after disconnect 10-4
Value Project Menus 8-31
variables in a Campaign 9-25

Play Music (Music Broadcast) in a Campaign 9-28
Pool

Aggressivity Factor 10-21
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Size, Minimum 10-22
POP3

creating a POP3 Server Library 4-66
server used by Agent 6-13
server, used in an Email Project 10-68
used for email storage address 3-19

PREDCID, system variable 8-8
Predictive

Actions 10-23
adding to a Project 10-15
blocking Predictive calls 14-4
calling selected Area Codes 10-35
calling selected Time Zones 10-40
creating a Predictive dialing schedule 10-27
dialing all numbers in a Dialer List 10-29
enabling for a Company 3-39
enabling for a company 3-40
enabling the feature 3-34
examples of dialing schedules 10-28
FAQ and Script used by 10-18
max number of channels available for 3-46,

3-48
Modes 10-18
starting and stopping 10-25

Predictive calling 3-46, 3-48
Predictive Detailed Report 18-26
Predictive Dialer Totals Report 18-1
Predictive Preview Reports 18-1
Predictive Productivity Report 18-9
Predictive Summary Report 18-17
Prefix Routing Group Library 4-80
Prefix Routing Pattern Library 4-77
Preview

enabling for a Company 3-39
enabling for a company 3-40
enabling the feature 3-34

Preview Summary Report 18-35
Printing and Viewing Reports 15-6, 15-10
Priority

creating customer priorities 12-2
enable Customer Priority in a Project 10-12
in a Chat Project 10-57
in a Project 10-7
in Web Callback 10-73
setting in an email Project 10-68

Profile, Company 3-11
Project

adding Chat Interactions 10-56
adding Dialer Lists 10-81
adding Email Interactions to 10-66
adding Fax Responses 10-76
adding Outcomes 10-78
adding Phone Interactions 10-5

adding Predictive calling 10-15
adding Web Callback 10-72
Billing 10-3
changing in a Menu 8-18
Contact Template for 10-3
creating 10-1
creating a Predictive dialing schedule 10-27
default language 10-3
examples of Predictive dialing schedules

10-28
FAQ 10-8
overriding Prompts in 10-79
Phone Number 10-6
Project Options Prompts 5-20
route to a Project from a Campaign 9-20
routing to a Campaign 9-17
routing to a Campaign from a Phone Project

10-10
Script 10-8
sharing phone numbers between 10-14
starting and stopping Predictive 10-25

Project Key Statistics Report 20-1
Project Menu

and scheduled conferences 8-44
case structure in 8-23
creating 8-1
example of using to change language 8-21
Get Digit 8-23
Get Digits 8-28
implementing 8-43
Play Value Menu 8-31
played before/after a voicemail 10-11
playing after disconnect 10-4
Prompt in 8-12
Record Menu 8-40
routing to 7-16
routing to a Campaign 8-18, 9-17
routing to from a Campaign 9-19
SQL Query Menu 8-35
standard 8-11
transfer from one Menu to another 8-15

project routing and reporting 15-11
Project Schedule

creating 11-1
example of 11-4
overview 11-1

Projects Table, Synchronizing 3-27
Prompts

Agent Voicemail 5-18
assigning a Company Prompt to a Variable

8-20
Call Blocking 5-26
Call Center 5-16
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Company Directory Navigation Prompts 5-20
complete list by file name 5-27
creating custom 5-3
customizing System Prompts 5-9
Date and Time 5-17
enabling System Prompts 3-34
enabling Workgroup Prompts 3-34
example for routing to a Workgroup 5-11
for a customer on hold 10-5
for customer ID 10-8
grouped by Application 5-16
in a Project Menu 8-12
Library of 4-16
Number 5-17
order of Workgroup prompts 5-25
overriding Prompts in Projects 10-79
overview of Custom Prompts 5-2
overview of customizing 5-1
overview of System Prompts 5-2
Playing in a Campaign 9-25
Project Options 5-20
restoring System Prompts 5-15
selecting for a Workgroup 7-17
Workgroup Options 5-22

Proxy, Setting for an Agent 3-6
Push Page

and collaboration 10-62
in a Chat Project 10-57

Q

Quality Control Table, Synchronizing 3-26
Queue, keeping Customer in 7-16

R

Record Menu
creating 8-40
listening to a recorded call 8-42

Recording Agents in Interaction Manager 6-7
Recording in a Campaign 9-31
Regional Options in the Configuration dialog box
3-8
Regular Expression, Routing in a Campaign 9-45
Remote

access to non-ACD voicemail 8-16
Database Configuration 3-25

Report

Agent Information Report 19-1
Agent Interaction Report 19-8
Agent Profile and Productivity Reports 19-1
Agent Skills Report 19-15
Agent Utilization Report 19-22
Billing 16-14
Call Center Operation Reports 16-1
deleting 15-14
Direct Dialing Statistics 19-29
introduction to 15-1
Login by Groups of Users 19-36
Login by User 19-43
Outcomes Statistics 17-31
Overdue Callbacks 17-39
Predictive Detailed Report 18-26
Predictive Dialer Totals 18-1
Predictive Preview Reports 18-1
Predictive Productivity Report 18-9
Predictive Summary Report 18-17
Preview Summary Report 18-35
scheduling 15-11
viewing and printing 15-6, 15-10
Weekly Project Routing Schedules 16-2
Workgroup Interval Time by Media 17-23
Workgroup Segments 17-2
Workgroup Skills 16-9

report start and end times 15-10
Report.xml File, Editing 15-11
reporting projects 15-11
Requiring Outcomes 6-10
Rescheduled Callbacks and Outcomes 4-12
reserve interaction licenses 3-47
Resource Bundles, customizing A-2
Retries, number of 8-12
Ring Prompt, in a Workgroup 7-17
Ring Time, during Predictive 10-19
Ringing an Agent 6-7
Routing

a Chat request to a Workgroup 10-57
a regular expression in a Campaign 9-45
a scheduled event (Business Event) 9-38
allow Customer to select Menu 7-16
conditional routing in a Campaign (Menu

Routing) 9-35
default routing in the Case tab 8-24
DTMF in a Campaign (Customer Keypress)

9-41
email to a Workgroup 10-67
to a Project Menu 7-13, 7-16
to a Workgroup extension 8-14
Touch-tone 8-12
with Intelligent Email Templates 10-71
with the Association tab 7-7
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routing projects 15-11
Run Applications, in the CRM Integration tab 3-29

S

Schedule
a conference 8-56
a report 15-11
a report (report.xml changes) 15-11
creating a Project Schedule 11-1
creating menus for scheduled conferences

8-43
example for Predictive dialing 10-28
for Predictive dialing 10-27
overview of Project Schedule 11-1
Project Schedule example 11-4

Scheduled Event (Business Event)
routing 9-38

Scope of variables 8-6
Script

creating an URL for 4-5
in a Chat Project 10-57
in a Menu 8-14
in a Predictive Project 10-18
in a Web Callback 10-74
in an Email Project 10-68
select for a Project 10-8
setting in a Campaign 9-32

Search Attributes
in LDAP authentication 3-44

Security Settings
for collaboration 10-62

Select
Field Listboxes 10-82
Tone Detection 10-20

Select an SMTP Group to Send Alarm Notification
3-17
Select Language Listbox, in a Project Menu 8-15
Select Prompts for a Workgroup 7-17
Select the Storage Location 3-19
Servers, Synchronizing Time and Time Zone 3-3
Service Billing Report - By Project 15-5
Service Levels, Setting 7-19
Session Timeout

for Administrators 3-10
for Agents and Supervisors (Agent Level) 6-9
for Agents and Supervisors (Company Level)

3-13, 3-14
Set FAQ URL 9-32
Set Language, in a Campaign 9-28
Set Menu Type 9-18

Set Ring Time, Predictive 10-19
Set Script URL 9-32
Set Variable to Object Action, using with Variable
Reference Fields 9-60
Set Variable, in Touch-Tones tab 8-18
Set Variables to Object Action 9-28
Sharing phone numbers between Projects 10-14
Simultaneous Interactions, setting the max num-
ber of 3-46
SIP

enabling the phone type 3-34
for Agent 6-15
in Hostname Agent Phone Mapping 4-88
SIP call for streaming audio (music broad-

cast) 5-7
SIP Billing tab 3-24
SJPhone, and Streaming Audio 5-7
Skills

Agent Skills Library 4-2
SMTP

group for Agent 6-14
group used in an Email Project 10-68
group used in Mail Manager 13-5
library of SMTP Servers 4-62
SMTP Server Group Library 4-64
using for Alarm notification 3-17

SQL Queries, in a Campaign 9-26
SQL Query Project Menu 8-35
SQL Query, for a Scheduled Conference 8-47
SQLSTATUS, in a Campaign 9-27
SQLSTATUS, system variable 8-8
Standard Menu, creating 8-11
Standard Reports

Agent Information 15-3
Agent Interaction 15-3
Agent Skills 15-3
Agent Utilization 15-3
Billing 15-2
Direct Dialing Statistics 15-3
Login by Groups of Users 15-3
Login by User 15-3
Outcome Statistics 15-2
Overdue Callbacks 15-2
Predictive Detailed 15-3
Predictive Dialer Totals 15-2
Predictive Productivity 15-2
Predictive Summary 15-2
Preview Summary 15-3
Project Key Statistics 15-3
Weekly Project Routing Schedule 15-2
Workgroup Interval Time 15-2
Workgroup Interval Time by Media 15-2
Workgroup Key Statistics 15-2
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Workgroup Skills 15-2
Start Time, for a Scheduled Project 11-3
start time, reports 15-10
Statistics, in the Company Profile tab 3-13
Status

setting for the Agent at login 6-10
Statuses, Library of 4-6
Storage address for email 3-18
Store Filename in Variable 8-41
Store User Input in Variable 8-29
Streaming Audio, Configuring 5-5
Streaming Audio, Enabling 10-5
String Operators 8-9
Supervisor

alarm notification to Supervisor 3-17
Conditions for Predictive dialing 10-25
creating accounts for 6-1
permission levels 6-11

Synchronizing Server Time and Time Zone 3-3
Synchronizing tables with the Remote DB feature
3-25
System Error Routing, in a Campaign 9-57
system licenses 3-47
System Peak Interactions 15-5
System Prompts

overview of 5-2
restoring 5-15

System Template
editing the System Directory Template 4-56
editing the System Transfer Template 4-57
restoring 4-58

System Variables 8-6

T

TAW Default Login Policy 3-41
Telnet, Enabling in the Company Applet Console
tab 3-37
Template

adding Intelligent Chat templates to a Project
10-58

Templates
adding Intelligent Chat templates to a Project

10-58
creating Intelligent Chat templates 4-73
deleting a Contact Template 4-52
Display 4-38
editing the System Directory Template 4-56
editing the System Transfer Template 4-57
Intelligent Email 4-70
overview of Contact Templates 4-39

Terminator
checkbox in Get Digits menu 8-29
in the Get User Digit action 9-26

Test LDAP Connection 3-45
Time and Date Prompts 5-17
Time to Login, in the Company Applet Console tab
3-37
Time Zone

calling selected in Predictive Dialing 10-40
in a Scheduled Project 11-3
in the Configuration dialog box 3-9
setting for a Company 3-19
setting for Agent/Supervisor 6-12
synchronizing for servers 3-3

Timeout
enter digit timeout in a Campaign 9-57
in a Campaign SQL Query 9-27
Inactivity Timeout for Administrators 3-10
Inactivity Timeout for Agents and Supervi-

sors (Agent Level) 6-9
Inactivity Timeout for Agents and Supervi-

sors (Company Level) 3-13, 3-14
number of rings before Agent must answer

6-7
Timeout Action button 8-12

Timeouts, for different types of Interactions 4-11
TODAYSDATE, system variable 8-8
Tone Detection, Predictive 10-20
Touch-Tones tab, using 8-12
Transfer, in a Menu 8-18
Troubleshooting, setting options for 3-35
Type Ahead

allowing in a Campaign 9-57
Type Ahead, allowing 8-12

U

Unified Messaging 3-48, 6-26
URL

displayed when Chat disconnects 10-57
for a Company 3-13
Library of 4-4
of the web server 3-26
setting for a company 3-13
setting the FAQ URL in a Campaign 9-32
setting the script URL in a Campaign 9-32
to display after Web Callback connects 10-74
to display when Call Center is closed 10-74

URL Timeout, in the Company Applet Console tab
3-38
User Login/Logout 15-4
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User Status Duration 15-5
Username

entering for an Agent 6-5
for Agent’s POP3 Server 6-13
in a SQL Query Menu 8-37

Users DN, in LDAP Authentication 3-45
Users Table, Synchronizing 3-27
Users, setting max allowed for a company 3-46

V

Validate
checkbox in Get Digits Menu 8-29
in a Record menu 8-41
Phone Number 10-7

Variable
assigning a Company Prompt to a Variable

8-20
name length 8-6
playing in a Campaign 9-25
Set Variable control 8-18
setting in a Campaign 9-28
system 8-6
types of 8-6
user defined 8-4
using variable reference fields 9-58

Viewing and Printing Reports 15-6, 15-10
Voice Channels, max available 10-18
Voicemail

address for a Company 3-16
Agent can use email to access ACD Voicemail

6-11
allow Agents to retrieve non-ACD voicemails

with the Mailbox Manager 8-16
allow customer to leave 7-16
disabling the Voicemail Only radio button in

Administration Manager 3-34
for an Agent with no phone 6-15
phone menu routes to Agent Voicemail 8-17
Prompts 5-18
routing to voicemail from a Campaign 9-21
select Agent greeting to play 7-16

voicemail, unified messaging 3-48
voicemails, company default 6-27
voicemails, Internal Voicemail 6-27
voicemails, Mail Server 6-27
voicemails, storing 6-26

W

Wait Time
before replaying a Menu 8-12
initial 7-15
play estimated wait time in a Campaign 9-31

Wallboard D-6
Web Callback

adding to a Project 10-72
creating an URL for 4-5
Priority in 10-73
routing to a Workgroup 10-73

Web Pages, Parameters Passed to D-4
Web Server Requirements (Data Source) 4-22
Web Server URL Address 3-26
Web Site, setting for a Company 3-13
Weekly Project Routing Schedules Report 16-2
Whisper Prompt, in a Workgroup 7-17
Win32 Window, for CRM Integration 3-31
Workgroup

adding Agents to 7-5
creating 7-3
customizing workgroup Prompts in a Project

10-79
definition of 7-1
deleting 7-21
enabling Prompts 3-34
entering from a Campaign 9-29
exiting in a Campaign 9-31
Options 7-14
order of Workgroup prompts 5-25
Overflow Conditions 7-11
route Web Callbacks to 10-73
routing a Chat request to 10-57
routing by association 7-7
routing email to 10-67
routing to from a Campaign 9-21
Service Levels 7-19
setting Workgroup Prompts 7-17
used by a Menu 8-14
used by a Project 10-10
Workgroup Callback in a Campaign 9-32
Workgroup Options Prompts 5-22

Workgroup Interval Time by Media Report 17-23
Workgroup Segment Report 17-2
Workgroup Skills Report 16-9
Workgroups Table, Synchronizing 3-27
Wrapup, setting time for 6-10
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