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Introduction
This guide covers general administration tasks for initial setup and ongoing 
maintenance of Siebel eBusiness Applications, MidMarket Edition. 

Specialized applications administration tasks are covered in a number of other 
books. See the Siebel Bookshelf CD-ROM.

NOTE: All Siebel MidMarket product names include the phrase MidMarket Edition to 
distinguish these products from other Siebel eBusiness Applications. However, in 
the interest of brevity, after the first mention of a MidMarket product in this 
document, the product name will be given in abbreviated form. For example, after 
Siebel Call Center MidMarket Edition, has been mentioned once, it will be referred 
to simply as Siebel Call Center. Such reference to a product using an abbreviated 
form should be understood as a specific reference to the associated Siebel 
MidMarket Edition product, and not any other Siebel Systems offering. When 
contacting Siebel Systems for technical support, sales, or other issues, note the full 
name of the product to make sure it will be properly identified and handled.

This guide is primarily useful to people whose title or job description matches one 
of the following:

Siebel Application 
Administrators

Persons responsible for planning, setting up, and maintaining 
Siebel applications possibly adding new functionality.

Siebel Application 
Developers 

Persons who plan, implement, and configure Siebel applications, 
possibly adding new functionality.

Database 
Administrators

Persons who administer the database system, including data 
loading, system monitoring, backup and recovery, space 
allocation and sizing, and user account management.

Call Center 
Administrators

Persons responsible for setting up and maintaining a call center. 
Duties include managing message broadcasts.
Version 7.5, Rev. A Applications Administration Guide MidMarket Edition 9



Introduction

How This Guide Is Organized
How This Guide Is Organized
The next four chapters of this guide should be read in the order presented. These 
chapters will be of interest to most readers.

The remaining chapters contain stand-alone topics about administering specific 
features of Siebel eBusiness Applications, MidMarket Edition. These chapters can 
be read in any order.

The appendix in this guide contains a table of system preferences.
10 Applications Administration Guide MidMarket Edition Version 7.5, Rev. A



Introduction

Additional Resources
Additional Resources 
You can find information about other administration tasks in the following books:

■ Siebel Campaigns Guide, MidMarket Edition

■ Siebel Service Guide, MidMarket Edition

■ Siebel Forecasting Guide, MidMarket Edition

■ Siebel Professional Services Automation Guide, MidMarket Edition

■ Security Guide for Siebel eBusiness Applications, MidMarket Edition

■ Global Deployment Guide, MidMarket Edition

■ Siebel eSales Administration Guide, MidMarket Edition

■ Siebel Territory Assignment Manager Administration Guide, MidMarket Edition

■ Siebel Communications Server Administration Guide, MidMarket Edition
Version 7.5, Rev. A Applications Administration Guide MidMarket Edition 11



Introduction

Revision History
Revision History
Applications Administration Guide, MidMarket Edition, Version 7.5, Rev. A

April 2003 Bookshelf
Table 1. Changes Made in Rev. A for April 2003 Bookshelf

Topic Revision

About Siebel eBusiness Applications Deleted this chapter.

“Assigning Skills” on page 34 Removed procedures from this section. 
The Assigning Skills procedures have 
been moved to the Siebel Assignment 
Manager Administration Guide.

“Setting Up Locales” on page 35 Added a note to the Short Date Format 
field description about how incorrect 
dates are handled.

“Modifying a List of Values” on page 98 Added the second bullet.

Chapter 5, “Audit Trail” In Siebel MidMarket Edition, the Siebel 
Web Client supports the database 
auditing only.

“Enabling and Disabling Message 
Broadcasting” on page 116

Added a procedure on how to enable 
and disable Message Broadcasting on 
the server.

“Creating a Message Broadcast” on page 119 Added a note about the importance of 
setting the correct server time to the 
field descriptions Activation Date/Time 
and Expiration Date/Time.

Chapter 7, “Messages” Added this chapter.

“Hardware Requirements” on page 199 The document Server is supported on 
both the Windows 2000 and Windows 
XP platforms.

“Enabling HTML Generation (Optional)” on 
page 201

Added a note.
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Getting Started 1
Once the Siebel system is successfully installed, you need to enter license keys so 
that you and your organization can access the Siebel products that your 
organization has purchased. After the license keys have been entered, you will be 
ready to set up your Siebel applications.

Before you can begin to use your Siebel applications, the software listed in Table 2 
must be correctly installed.

Once these Siebel servers and applications are successfully installed, you can 
proceed to enter license keys for specific Siebel applications.

Table 2. Required Software

Software For Information, See

Siebel Gateway Server Siebel Server Installation Guide for Microsoft 
Windows, MidMarket Edition

Siebel Server

Siebel Database Server

Siebel eBusiness Applications Application-specific administration guide and 
this guide.

Either Siebel Dedicated Web Client or 
Siebel Tools

Siebel Web Client Administration Guide, 
MidMarket Edition or Siebel Tools Reference, 
MidMarket Edition
Version 7.5, Rev. A Applications Administration Guide MidMarket Edition 13



Getting Started

Starting the Application for the First Time
Starting the Application for the First Time
In order to begin setting up your Siebel application, you must log in with 
administrative responsibilities. The Siebel database server installation script creates 
a Siebel administrator account that you can use to perform administrative tasks. 
The default user ID and password are SADMIN and SADMIN (case-sensitive). Your 
database administrator may also have created a user ID and password that allows 
you to access the Siebel Server and perform the required setup. To set up entities in 
the Group Administration view, you must be connected to the Siebel Server; you 
will not have full administrative capabilities for this view if you are connected to 
the local database or working in a mobile Web client. 

NOTE: The responsibility for the SADMIN ID that comes with Siebel applications 
cannot be modified. However, you can copy this responsibility and modify the copy. 
For more information, see Security Guide for Siebel eBusiness Applications, 
MidMarket Edition.

You can start Siebel applications from the Siebel Dedicated Web Client or from the 
Siebel Web Client. Instructions for both are described below.

TIP: If you have not yet entered any license keys, you must enter the first license key 
from the Siebel Dedicated Web Client or from Siebel Tools. For more information, 
see “Entering License Keys” on page 16.

To start a Siebel application from the Siebel Dedicated Web Client for the first time

1 From the Start menu, choose Programs and then choose your Siebel application.

2 Enter SADMIN in the User ID and Password fields.

3 In the Connect to field, choose the server database from the drop-down list and 
click OK.

For information about the other databases available in the Connect to drop-
down list, see “Selecting a Datasource” on page 22.

4 If a message tells you that there is no valid license key, click OK.
14 Applications Administration Guide MidMarket Edition Version 7.5, Rev. A



Getting Started

Starting the Application for the First Time
5 In the License Key dialog box, enter the Siebel eBusiness base application license 
key and click OK. 

For more information about license keys, see “Entering License Keys” on 
page 16. If you need to enter additional license keys, see “Entering an Additional 
License Key” on page 18.

To start a Siebel application from the Siebel Web Client for the first time

1 Open your Web browser.

2 Go to the URL for your Siebel Web Client.

The login screen appears.

3 Enter SADMIN in the User ID and Password fields and click OK.

NOTE: If a message tells you that you have not been licensed for this feature, you 
must enter a valid license key, using either Siebel Tools or the Siebel Dedicated Web 
Client, before you can access the application. For more information, see “Entering 
License Keys” on page 16. 
Version 7.5, Rev. A Applications Administration Guide MidMarket Edition 15



Getting Started

Entering License Keys
Entering License Keys
The Siebel license key is generated so that your organization's users can access the 
Siebel products that your organization has purchased. The license key is a series of 
numbers (up to 54 digits). Your organization’s specific license key is included in the 
Welcome Package. You must enter this license key before you begin to use the Siebel 
product, products, or optional modules that your organization has purchased. 
Because the license key resides in the database and not on the client machine, 
everyone who accesses the Siebel database uses the same license key. 

Your license key activates the screens and views associated with the applications 
and modules that your organization has purchased. If you have been assigned 
multiple license keys, their effect is cumulative, as you enter them.

Customers upgrading from earlier versions of Siebel software may notice differences 
between the Siebel product and the products listed in the Welcome Package. These 
generally reflects changes in naming and bundling of Siebel products. For example, 
a functionality that was previously sold separately might now be bundled into a 
single product, or included in a base application, or simply have been renamed. It 
is recommended that you run the application itself to verify that all of the 
functionality that you expected is there.

Customers using Siebel products which are upgrades from earlier versions may 
notice differences between the views in the previous product and the views in the 
upgraded product. Reasons for this may include the following:

■ The view you are looking for is not available from the application that you have 
launched.

■ You logged in as a user who does not have responsibilities for the view. In order 
to evaluate all of the views available in the product, log in as a Siebel 
administrator. 

■ The method of accessing the functionality may have changed, or the 
functionality may have been replaced by more comprehensive features that 
work differently. Consult the Siebel Bookshelf for information on functionality 
changes in the latest release.

■ The location or name of the screen or view may have changed. You can review 
the Site Map or consult the Siebel Bookshelf for information on current view 
locations.
16 Applications Administration Guide MidMarket Edition Version 7.5, Rev. A



Getting Started

Entering License Keys
However, if you do not see views that you expected, or if you see views that you did 
not expect, and feel that it impacts the functionality you have purchased, contact 
Siebel Technical Support as soon as possible. If your license key has expired, contact 
Siebel Technical Support.

Entering the First License Key
Before you enter the first license key, the following software must be correctly 
installed: Siebel Gateway Server, Siebel Server, Siebel Database Server, Siebel 
eBusiness Applications, and one of the following: Siebel Dedicated Web Client or 
Siebel Tools. After the first Siebel Dedicated Web Client or Siebel Tools installation, 
the first user to connect to the Siebel database is required to enter a license key in 
order to use the product. 

To enter the first license key

1 Start either Siebel Dedicated Web Client or Siebel Tools. 

NOTE: You have the choice of entering the first license key in either Siebel 
Dedicated Web Client or Siebel Tools. You can enter any Siebel license key in 
either Siebel Dedicated Web Client or Siebel Tools. 

2 Log in as the system administrator and connect to the server database. 

Use SADMIN as the login name and SADMIN as the password, and choose 
Server in the Connect to drop-down list. 

NOTE: If you are the first to log in to Siebel Dedicated Web Client after a new 
Siebel installation, you will get the error message “There is no valid license key 
in the database.” If you are the first to log in to Siebel Tools after a new Siebel 
installation, you will get the error message “No valid license keys were found in 
the database.” 

3 If you are logged in to Siebel Dedicated Web Client, click OK. If you are logged 
in to Siebel Tools, click Add Key. 
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4 In the License Key dialog box, enter the Siebel eBusiness base application license 
key or the Siebel Tools license key, and then click OK.

CAUTION: Enter only a Siebel eBusiness base application license key or the Siebel 
Tools license key. If you enter an optional-module license key without having a 
Siebel eBusiness base application license key already entered, an error message 
will appear. The error occurs because the Home Page view is required to start 
Siebel eBusiness base applications, and Home Page views are not included in 
optional module license keys.

5 Close Siebel Dedicated Web Client or Siebel Tools, whichever you started in 
Step 1 on page 17.

6 Start the Siebel application associated with the license key that you entered. 

For example, if your license key is for Siebel Sales, start Siebel Sales; if your 
license key is for Siebel Tools, start Siebel Tools. 

NOTE: After entering the initial license key, if you discover that you made an error 
when entering the license key, you can correct the license key in the Key Value field 
in the Application Administration screen, License Key view. 

Entering an Additional License Key
After entering the initial key, you can add or delete license keys as long as your 
Siebel user responsibility includes the Siebel License Key view. You can do this 
immediately if your purchase included more than one license key, or you can add 
license keys as your organization purchases more Siebel applications or optional 
modules. 

To enter an additional license key using a Siebel application

1 Start the Siebel application—for example, Siebel Call Center. You can use Siebel 
Web Client or Siebel Dedicated Web Client.
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2 Log in as the system administrator and connect to the server database. 

Use SADMIN as the login name and SADMIN as the password, and choose 
Server in the Connect to drop-down list. If the system administrator’s password 
has been changed, use the current password.

3 From the application-level menu, choose View > Site Map > Application 
Administration > License Keys.

4 Add the new license key:

a In the License Keys list, click New to create a new record. 

b In the new record, enter one license key in the Key Value field. 

c Repeat Step a and Step b for each license key to be entered.

5 Close the application.

Start any Siebel application or module associated with a license key you have 
entered.

If you have any problems installing your license keys, contact Siebel Technical 
Support.

To enter an additional license key using Siebel Tools

1 Start Siebel Tools.

NOTE: To enter additional license keys in Siebel Tools, you must have first entered 
the Siebel Tools license key. 

2 Log in as the system administrator and connect to the server database. 

Use SADMIN as the login name and SADMIN as the password, and choose 
Server in the Connect to drop-down list. If the system administrator’s password 
has been changed, use the current password.

3 Choose Help > Technical Support from the menu bar.

4 In the Technical Support Information dialog box, click License Key.
Version 7.5, Rev. A Applications Administration Guide MidMarket Edition 19



Getting Started

Entering License Keys
5 Add a license key:

a In the License Keys dialog box, click Add Key. 

b In the new record, type in one license key and then click OK.

c Repeat Steps a and b for each license key to be entered.

6 Close Siebel Tools.

Start any Siebel application or module associated with a license key you have 
entered.

License Key Fields
Table 3 describes the files in the license key record.

Hiding Access to License Keys
There are two ways that you can hide access to license keys: hiding the License Keys 
administrative view within Siebel applications and hiding the License Key button 
within Siebel Tools.

Table 3. Fields in the License Key Record

Field Description

Key Value The license key from your Welcome Package. Add a new record for 
each license key.

Status Automatically entered based on the license key.

OK means the license key has not expired.

Expired means the license key has expired. 

MaxUsers Automatically entered based on the license key.

The maximum number of concurrent users allowed in your license 
agreement with Siebel Systems.

Expires Automatically entered based on the license key.

The expiration date for the license key in your license agreement with 
Siebel Systems.
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■ Within Siebel Applications. You may want to hide the License Keys view in the 
Application Administration screen, in order to discourage unauthorized users 
from attempting to change license keys. To hide the License Keys view, remove 
it from the responsibility associated with the users who should not have access 
to it. Responsibilities control the views to which users have access. For more 
information about creating and modifying responsibilities, see Security Guide for 
Siebel eBusiness Applications, MidMarket Edition. 

■ Within Siebel Tools. You may want to disable the License Key button, found in the 
Technical Support Information dialog box (available from the Siebel Tools Help 
menu), in order to discourage unauthorized users from attempting to change 
license keys. You can disable the License Key button by selecting the Siebel 
Administrator responsibility and deleting the Edit License Key view.
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Selecting a Datasource
When you start a Siebel application from the Siebel Dedicated Web Client, you 
specify the datasource to which you want to connect.

The following databases are potentially available to administrators and end users:

■ Local. Resides on your local computer. Can be synchronized with the corporate 
database. Typically stored on a laptop computer and used by mobile users who 
are not connected to a server when working. 

■ Server. This is your enterprise server database.

■ Sample. A database of sample data, stored on your workstation. Using this 
database, you can experiment with a Siebel application without risk of damaging 
actual organizational data.

You should always perform system administration tasks against the server database. 
Although you can perform these tasks against your local database and synchronize, 
doing so has the potential to cause errors, including data conflicts. In addition, 
performance problems can result from a large local database, and from routing large 
numbers of transactions.

About the Sample Database
Siebel eBusiness Applications include a sample database to use in demonstrating, 
evaluating, or experimenting with the Siebel client and Siebel Tools. (For more 
information, see Siebel Web Client Administration Guide, MidMarket Edition.)

The sample database includes a number of demo user accounts (SADMIN is one of 
these). Each of these has a predefined responsibility that reflects the demo user’s 
position within the sample organization. If you log in to the sample database as a 
demo user, you can access certain views within Siebel eBusiness Applications based 
on the demo user’s responsibility.

You do not need to install server components to run the Siebel sample database. 
However, you cannot access the Server Administration screen if the server 
component is not running. The sample database cannot be copied to the server data 
sources.

For more information about the sample database, see Release Notes.
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Seed Data
The enterprise database of your default Siebel application contains some built-in 
seed data, such as organization, division, position, responsibility, and employee 
records. You can use this seed data for training or testing, or as templates for the 
real data that you enter. For more information on seed data, including descriptions 
of seed data records, see Security Guide for Siebel eBusiness Applications, 
MidMarket Edition.
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Table 4 summarizes the additional application administration tasks necessary to set 
up various Siebel eBusiness applications and optional modules.

Table 4. Application Administration Tasks

If You Want to You (May) Need to Perform For More Information, See

Use any base 
application (for 
example, Siebel Sales 
or Siebel Call Center)

Initial Setup tasks. Chapter 2, “Initial Setup”

Ongoing administration tasks. Chapter 3, “Ongoing Application 
Administration Tasks”

Control access to views 
or data

Establish a strategy for controlling access to 
views and data:

■ Establish the business environment (such 
as organizations, divisions, territories)

■ Add employees

■ Assign responsibilities to employees

Security Guide for Siebel 
eBusiness Applications, 
MidMarket Edition

Launch a global 
deployment

Locale and language administration tasks. “Setting Up Locales” on page 35

“Setting Up Languages” on 
page 78

Global Deployment Guide, 
MidMarket Edition

Manage global 
accounts

Account administration tasks: Set up global 
account hierarchies.

Chapter 8, “Global Accounts”

Use Application 
Services Interfaces 
(ASIs) for accounts or 
contacts

Set up Web services and activate workflows for 
the ASIs.

Chapter 16, “Integration Using 
ASIs”

Create catalogs for 
data, including 
products

Create catalogs for products, literature and 
solutions.

Siebel eSales Administration 
Guide, MidMarket Edition

Use Correspondence 
functionality

Set up the Siebel Document Server, and create 
templates.

Chapter 13, “Correspondence”
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Use the calendar to set 
up resources, such as 
conference rooms, 
equipment, and 
projectors

Calendar administration tasks. Chapter 11, “Calendar”

Use Territory 
Assignment Manager 
to automatically assign 
tasks to appropriate 
users

Create skills and other criteria. Siebel Territory Assignment 
Manager Administration Guide, 
MidMarket Edition

Use Siebel Marketing Marketing administration tasks. Siebel Campaigns Guide, 
MidMarket Edition

Manage lists of 
contacts and prospects

List Management tasks. Siebel Campaigns Guide, 
MidMarket Edition

Use Time Sheets and 
Expense Reports

Time Sheet and Expense Report setup tasks, 
such as creating work types.

Siebel Professional Services 
Automation Guide, MidMarket 
Edition

Manage Service 
schedules, Service 
Assets, Warranties

Service administration tasks. Siebel Service Guide, MidMarket 
Edition

Manage orders and the 
order process

Order administration tasks. Siebel Order Management Guide, 
MidMarket Edition

Table 4. Application Administration Tasks

If You Want to You (May) Need to Perform For More Information, See
Version 7.5, Rev. A Applications Administration Guide MidMarket Edition 25



Getting Started

Summary of Applications Administration Tasks
26 Applications Administration Guide MidMarket Edition Version 7.5, Rev. A



Initial Setup 2
Once your Siebel products are successfully installed, you need to perform a number 
of tasks to set up and administer the application.

Initial setup tasks are those which must be completed in order for your Siebel 
applications to work correctly, and then may be done infrequently, for instance, as 
your company grows.

Ongoing tasks are done on an occasional or ongoing basis, and are described in 
Chapter 3, “Ongoing Application Administration Tasks.”
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Table 5 summarizes the initial setup tasks and the order in which you should 
perform them.

Table 5. Required Tasks During Setup

Task Comments

Add any custom views. Custom views are created in Siebel Tools and must be 
added to your Siebel application. Custom views 
should be added to the Views view before you define 
responsibilities. For information about adding views, 
see “Adding Views to the Application” on page 30.

For information about creating custom views and 
about troubleshooting view visibility issues, see 
Siebel Tools Reference, MidMarket Edition.

Determine access control strategy 
and define business environment 
structure.

Siebel applications can be set up to support many 
strategies for your company to control access to 
views and data. These strategies include methods 
such as defining your business environment 
structure (organizations, internal and external 
divisions, and so on), defining employee positions, 
and creating access groups so that specific groups of 
people have access to specific views and data.

These decisions should be made early in the 
deployment process, so that the strategy can be 
implemented during the initial setup.

For more information about controlling access to 
views and data, and the procedures for 
implementing access control, see Security Guide for 
Siebel Applications, MidMarket Edition.

Enter employee records into 
system (database and application) 
and determine employee access to 
views and data.

Enter employee records after you have defined your 
business environment structure. You will need to 
assign at least one responsibility to each employee, 
and you may also assign organizations, positions, or 
other access control parameters.

For more information about entering or deactivating 
employee records, see Security Guide for Siebel 
Applications, MidMarket Edition.
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Complete employee setup. For information about associating additional 
information to an employee record, see “Completing 
Employee Setup” on page 31.

Set up locales. Locale Codes and parameters are necessary for a 
global deployment. For more information, see 
“Setting Up Locales” on page 35.

Table 5. Required Tasks During Setup

Task Comments
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Developers create new views through Siebel Tools. In order for the views to become 
available for administrators to work with, you must add them to the Views screen 
in the application before you define your business environment.

Example: You want to add an Opportunities view in the Activities screen. In Siebel 
Tools, you create the view and name it Activities Opportunities. (For details on 
creating views, see Siebel Tools Reference, MidMarket Edition.) In your Siebel 
application, you follow the steps below and add the Activities Opportunities view 
in the View Administration view. After it has been added in both places, the view 
can be made accessible to the appropriate users. For details about controlling 
visibility to views, see Security Guide for Siebel Applications, MidMarket Edition.

To add customized views to the Siebel application

1 From the application-level menu, choose View > Site Map > Application 
Administration > Views.

2 In the Views list, add a new record.

3 Enter the view name exactly as it is defined in Siebel Tools, and a description of 
the new view. 

You generally do not need to modify or delete views that are already listed. You 
would only need to modify a view if its name was changed in Siebel Tools. A view 
would need to be deleted only if it no longer existed in the data model schema, or 
if you did not want anyone to have access to it. Instead of deleting views, 
administrators should remove the views from responsibilities and keep them in the 
database.

NOTE: Only visibility-level views can be configured to appear in the Site Map. For 
more information, see Siebel Tools Reference, MidMarket Edition.
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After completing the employee setup procedures described in the Security Guide for 
Siebel Applications, MidMarket Edition, which are required to allow employee 
access to the Siebel application, views and data, you complete employee setup by 
providing additional information. This can include the following:

■ Territory Assignment Rules. Allows you to see and administer the assignment rules 
for an employee. For more information on assignment rules, see Siebel Territory 
Assignment Manager Administration Guide, MidMarket Edition.

NOTE: You must be logged on to a server database to use the Employee 
Assignment Rules view.

■ Availability. Used for Siebel Professional Services Automation. Lists the projects 
for which an employee is on staff, or for which an employee has been requested. 
For more information, see Siebel Professional Services Automation Guide, 
MidMarket Edition.

NOTE: Employees can also change their availability in the Availability view on the 
User Preferences screen.

■ Exception Hours. Specifies what days and hours an employee is not available.

■ Utilization. Displays a chart with the monthly and quarterly utilization of the 
currently selected employee. Managers use this chart for monitoring 
professional services projects and employees. For more information about 
professional services, see Siebel Professional Services Automation Guide, 
MidMarket Edition.

■ Tools. Defines the tools that service engineers carry with them or have access to. 
It allows a call center person to check whether the engineers have the correct 
tools for the jobs they are assigned to.

■ Job Information. Specifies the job profile, salary, compensation ratio, pay 
currency, and location of employee.
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■ Calendar administration. Defines the calendar properties and access for an 
employee. For more information about Calendar administration, see Chapter 11, 
“Calendar.”

■ Territory Assignment Skills. Defines an employee’s skills and skill items, along 
with their level of expertise. Skills can be used as assignment criteria in Siebel 
Territory Assignment Manager. For more information about how the Siebel 
application uses skills, see Siebel Territory Assignment Manager Administration 
Guide, MidMarket Edition.

Skills can also be used in the Professional Service Automation product for 
managing resources. For information about these types of skills, see Siebel 
Professional Services Automation Guide, MidMarket Edition.

■ Employee Query. Allows queries to identify employees with particular skills and 
expertise.

■ Service Details. Provides details about the shift start and end locations, hourly 
costs, overtime availability and other details for a service employee.

■ Competency. Provides a list of areas in which the employee has some 
demonstrated level of knowledge or accomplishment.

■ Education. Provides details of an employee’s education history.

■ Past Work Experience. Provides details of an employee’s work history.

■ Honor/Award. Provides list of honors and awards earned by an employee.

■ Membership. Provides details of an employee’s memberships in various 
organizations.

■ Certification. Provides details of an employee’s certification.

To complete the employee setup

1 From the application-level menu, choose View > Site Map > User 
Administration > Employees.

2 In the Employees list, select the employee for whom you want to add additional 
information.
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3 In the More Information form complete any necessary fields. Some of the fields 
are described in the following table.

4 Click any other appropriate view tab.

5 Add a new record, if needed. 

6 Enter the appropriate information.

Field Description

Configuration Specifies which Siebel product or group of software components to 
associate with the currently selected employee. For more 
information, see Siebel Anywhere Administration Guide, MidMarket 
Edition.

Available Until May be used to indicate the active period of an employee. Used in 
conjunction with the Availability, Overtime Availability, and Next 
Available fields.
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At the levels of organizations, positions, and employees, you can add skills. Skills 
are used to search for employees for certain projects. You create skills with Siebel 
Tools.

Employees can track and update their own skill profiles in the User Preferences 
Availability view.

For more information about how your Siebel application uses skills, see Siebel 
Territory Assignment Manager Administration Guide, MidMarket Edition.
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A locale is a set of rules guiding how common data is displayed to the user or 
received from the user. These rules are used to format data from a database before 
displaying the resulting information in output fields on the user interface. Siebel 
applications support language and geographical conventions for the display 
language of picklists, and formatting of data such as dates, time, numbers, and 
currency based on locale settings.

The Locale information is stored in the Locale Table (S_LOCALE). The data in this 
table is maintained by the administrator using the Locale Administration view.

The locale with which the Component Object Manager processes are initialized is 
determined by the value of the parameter Locale Code. Although this is set during 
installation, it may be changed to the locale code of any locale that is preconfigured 
with the Siebel application or added by the administrator. The Locale Code 
parameter can be set at the Enterprise, Server, or Component level.

A number of locales and their parameters come prebuilt with the standard Siebel 
application. You can also create and revise locales in the Locale Administration 
view.

After a locale and its parameters are defined, you can create translations for locale 
names that will display in the locale pick applet, rather than the three letter 
acronym locale code. For example, instead of showing ENU as locale name, the 
administrator provides English–United States as a translation for English speakers 
and Inglese–Stati Uniti d’America for Italian speakers. Only translated locale names 
are exposed to end-users on locale pick applets.

NOTE: Whereas the Siebel Web Clients use the locale settings specified on the Siebel 
Server, the Siebel Mobile Web Client and the Siebel Dedicated Web Client use the 
locale settings defined in the client operating system’s regional settings.

To create a locale

1 From the application-level menu, choose View > Site Map > Application 
Administration > Locale.
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2 In the Locale list, create a new record and fill in the necessary fields.

Some of the fields are described in the following table.

Field Description

Date Separator Designates the symbol that will be used to separate the 
components of the date.

International Dialing 
Code

Designates the country codes to display in phone numbers, 
suppressing the country code for phone numbers that are in 
the user’s locale. For example, if the phone numbers for two 
accounts are the following:

■ +33 1-23 42 34 56, for an account based in France (+33 
is the country code for France)

■ +1 6502955000, for an account based in the U.S. (+1 is 
the country code for the U.S.)

To a user based in the U.S.(locale ENU) the International 
Dialing Code value is “USA and Canada (1)”, and the above 
phone numbers will display as:

■ +33 1-23 42 34 56

■ (650) 295-5000

List Separator Designates the symbol that will be used to separate 
consecutive numbers in a list.

For example:

■ In the U.S., consecutive numbers are separated by a 
comma: 1.23,3.57,4.01

■ In France, consecutive numbers are separated by a semi-
colon: 1,23;3,57;4,01

Locale Code Siebel applications use the three letter acronym (TLA) code 
conventions of Microsoft for locale name. In most cases, the 
TLA is created by taking the two-letter language abbreviation 
from the ISO Standard 639 and adding a third letter as 
appropriate to form a unique identifier.

For examples of language (locale) codes, see Global 
Deployment Guide, MidMarket Edition.
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Locale Name The naming convention is generally Language Name–
Territory, for example, English–United States, English–United 
Kingdom, or French–France.

Long Date Format Not supported.

Negative Currency 
Format

Specifies the location of the negative sign (-) with respect to 
the currency symbols and digits (100).

For example:

■ For U.S. format, ($32.45), select (s100)

■ For British format, -£32.40, select -s100

Number Decimal 
Separator

Specifies the symbol used to indicate the decimal place.

For example:

■ French format: 1 234,34 (comma as decimal symbol)

■ U.S. format: 1,234.34 (period as decimal symbol)

Number Fractional 
Digits

Designates the number of digits after the decimal separator. 
For example, the number 12.340 has a number fractional of 
3.

This applies to data fields of type DTYPE_NUMBER.

Number Grouping 
Separator

Designates the symbol used to group numbers.

For example:

■ French format: 1 234 (space as number grouping 
separator)

■ German format: 1.234 (period as number grouping 
separator)

■ U.S. format: 1,234 (comma as number grouping 
separator)

Number Leading Zero Designates whether to display a leading zero in numbers less 
than one. For example, .7 or 0.7.

Positive Currency 
Format

Specifies the location of the currency symbols with respect to 
the digits (100).

For example: for U.S. format, $32.45, select s100.

Field Description
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Short Date Format Specifies the appropriate shortened date format.

For example:

■ International format: yymmdd

■ U.S. format: mm/dd/yy

■ German format: dd.mm.yy

The forward slash in the string mm/dd/yy is actually a place 
holder. It is replaced with the symbol specified in the Date 
Separator field. For example, if the Date Separator value is a 
dash, -, then April 10, 2002 will be displayed as 04-10-2002.

Note: If you enter a month number greater than 12, it defaults 
to 12. If you enter a day number greater than the number of 
days in the month, it defaults to the last day of the month. 
For example, if you enter 42/99/03 (U.S. format), the date 
defaults to 12/31/03.

Time AM Designator Specifies the symbol for designating time between 00:00 and 
12:00.

For example: AM, a.m., am

Time Leading Zero Designates whether to display a leading zero in time fields. 
For example:

12 hour clock with leading zero: 01:03 AM, 01:03 PM

12 hour clock without leading zero: 1:03 AM, 1:03 PM

24 hour clock with leading zero: 01:03, 13:03

24 hour clock without leading zero: 1:03, 13:03

Time PM Designator Specifies the symbol for designating time between 12:00 and 
24:00.

For example: PM, p.m., or pm

Time Separator Specifies the symbol used to separate the hours from the 
minutes.

UI Directionality Designates the direction of the text displayed.

Field Description
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To create a translation for a locale name

1 From the application-level menu, choose View > Site Map > Applications 
Administration > Locale, and select the appropriate record.

2 Click the Locale Name Translation view tab.

3 On the Locale Name Translation list, create a new record and fill in the necessary 
fields, as described in the following table.

Field Description

Language Designates the language code of the translation of the locale name. 
For examples of language codes, see Global Deployment Guide, 
MidMarket Edition.

Translated 
Name

The exact translation of the locale name to appear in the picklist for 
users with the designated language code. For example, for the locale 
English–United States:

■ With ENU language code, the locale name is English–United 
States.

■ With ITA language code, the locale name is Inglese–Stati Uniti 
d’America.

Description Translated description of this locale.
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NOTE: This section only applies to those who have purchased Siebel Satmetrix 
eSurveys or who have purchased surveys directly from Satmetrix Systems.

In order to view Satmetrix survey reports through your Siebel application, you need 
to:

■ Add the Account Satmetrix Survey View view to the appropriate user 
responsibilities. For information about how to add views to responsibilities, see 
Security Guide for Siebel Applications, MidMarket Edition.

■ Enter the secret key string provided by Satmetrix Systems into the Satmetrix Key 
Value system preference. For information about how to change system 
preferences, see Chapter 3, “Ongoing Application Administration Tasks.”

■ Extend the List of Values for WI_ARG_TYPE as described in “To extend the List 
of Values for WI_ARG_TYPE.”

■ Set up the symbolic URL for access to the Satmetrix reports server, as described 
in “To set up the symbolic URL for access to Satmetrix Reports.”

To extend the List of Values for WI_ARG_TYPE

1 From the application-level menu, choose View > Site Map > Application 
Administration > List of Values.
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2 Create a new record, and complete the fields as shown in the following table.

For more information about adding List of Values records, see Chapter 4, 
“Working with Lists of Values.”

To set up the symbolic URL for access to Satmetrix Reports

1 From the application-level menu, choose View > Site Map > Integration 
Administration > Symbolic URL Administration.

2 In the Symbolic URL list, select SatmetrixSurvey.

3 Make sure the URL is the URL for the reports server provided by Satmetrix 
Systems. 

4 In the Symbolic URL Arguments list, complete the fields, using the following 
table as a guide.

Field Value

Type WI_ARG_TYPE

Display Value Satmetrix

Language-Independent Code Satmetrix

Active Yes

Translate Yes

Replication Level All

Name
Required 
Argument

Argument 
Type Argument Value

Append as 
Argument Sequence

EncodeUrl Yes Command FALSE Yes 1

version Yes Constant Obtain from Satmetrix Yes 2

windowsize Yes Command WebControl 
width=1000 
height=500 
border=1

Yes 3
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type Yes Constant acct Yes 4

acctid Yes Field Id Yes 5

acctname Yes Field Name Yes 6

contactid Yes Constant * Yes 7

contactname Yes Constant * Yes 8

user Yes Profile 
Attribute

Login Name Yes 9

domain Yes Constant Obtain from Satmetrix Yes 10

model Yes Constant Obtain from Satmetrix Yes 11

created Yes Field Timestamp Yes 12

token No Satmetrix Satmetrix Surveys, 
CalculateToken

Yes 13

Name
Required 
Argument

Argument 
Type Argument Value

Append as 
Argument Sequence
42 Applications Administration Guide MidMarket Edition Version 7.5, Rev. A



Ongoing Application Administration Tasks 3
This chapter assumes that you have successfully installed your Siebel product and 
have completed the tasks in Chapter 2, “Initial Setup.”

The tasks described in this chapter set up defaults that are used throughout your 
Siebel application. For some implementations, the default settings provided through 
the seed data meet a company’s needs without customization. In other cases, 
administrators find it useful to make adjustments to these defaults. 
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Setting System Preferences
System preferences control how Siebel applications operate in your environment. 
You need to review default settings and modify these as appropriate for your 
environment.

For a list of the system preferences in Siebel applications, see Appendix A, “System 
Preferences.”

To set system preferences

1 From the application-level menu, choose View > Site Map > Application 
Administration > System Preferences.

2 Check that the default System Preference Values are correct in your 
environment, or change values for system preferences as needed.
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Setting Up Predefined Queries
Predefined queries (PDQ) automate queries that a user can perform online. Rather 
than creating a query, entering criteria, and running the query, the user selects a 
PDQ from the Queries drop-down list. 

Predefined queries can be private (available only to the person who created them) 
or they can be public (available to all the users of the application).

Both public and private predefined and user-defined queries are stored in the 
database table S_APP_QUERY.

There are two ways to set up predefined queries:

■ Create and execute a query in the usual way, and then save the query.

■ Create or modify a predefined query in the Predefined Query screen.

For more information about the syntax of Siebel queries, see Fundamentals, 
MidMarket Edition and Siebel Tools Reference, MidMarket Edition. 

When setting up queries, remember:

■ The Administrator can define a PDQ using both displayed and nondisplayed 
fields.

■ You can reference only fields from the current applet’s business component in 
your query.

■ On occasion, using the wildcard * to find all entries in a field may cause a 
performance problem. If it does, use IS NOT NULL instead. For more information 
about query operators, see Siebel Online Help.

■ Predefined queries are defined on a business object. All screens based on the 
same business object will display all the predefined queries created for that 
business object.

■ Do not query on fields of Siebel field data type DTYPE_NOTE.

To create a predefined query by saving a query

1 Navigate to the screen where you will run the query.
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2 Click the Query button in the applet title bar or select New Query from the applet 
drop-down menu. 

3 In the applet that is displayed, enter the criteria for the new query.

4 Click the Go button and then click Run Query.

The query’s results appear.

5 From the application-level menu, choose Edit > Query > Save As.

6 In the Save Query As dialog box, enter a name for the query, and click OK. 

The query is added to your list of predefined queries. This query is private, and 
only you can view it.

7 If you want to make the query public:

a From the application-level menu, choose View > Site Map > Application 
Administration > Predefined Queries. 

b In the Predefined Queries list, deselect the Private field in the record for the 
query you just created.

To set up a predefined query in the Predefined Query view

1 From the application-level menu, choose View > Site Map > Application 
Administration > Predefined Queries. 

2 In the Predefined Queries list, add a new record and complete the necessary 
fields.

Some fields are described in the following table.

Field Comments

Name This is the name that appears in the predefined query drop-down list.

Object The object upon which the query is performed. 
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Private Marked if the query is available only to the person who created it. 

When you unmark a query to make it public, the other users must 
first exit the application and reenter before they can see the newly 
public query.

Query The SQL code for the query. 

When you create a query for a field that is a multi-value group, you 
can use the EXISTS operator to query nonprimary child records.

Field Comments
Version 7.5, Rev. A Applications Administration Guide MidMarket Edition 47



Ongoing Application Administration Tasks

Setting Up Currencies
Setting Up Currencies
You specify the currencies your company uses by: 

■ Making Currencies Active. If the application includes the currency definitions you 
need, you make these currencies active. 

■ Defining Currencies. If you need additional currencies whose definitions the 
application does not include, you must also define these currencies. 

NOTE: If you use multiple currencies, you must also set up exchange rates before you 
import data that contains foreign currencies and before you use any of the Siebel 
currency features. 

Making Currencies Active
The application includes more than 30 currency definitions. If your currency is one 
of these, you need only mark it as active. 

To make currencies active

1 From the application-level menu, choose View > Site Map > Applications 
Administration > Currencies.

2 For any currency that you want to make active, click the Active column in the 
Currencies list. 

3 Enter the Start Date and End Date in the More Info form, to specify the date 
when this currency becomes active and the date when it is no longer active. This 
step is optional.

Defining Currencies
If your company uses any currencies that the application does not include, you must 
define them and mark them as active. 

If you modify the definition of currencies, you must reconnect to the application 
before the modification becomes visible in other screens or in clear cache. For more 
information about clear cache, see “Clearing the Cache” on page 94. 
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You cannot delete a currency once you have defined it. If you no longer use it, you 
can mark it as inactive.

To define a currency

1 From the application-level menu, choose View > Site Map > Applications 
Administration > Currencies.

2 In the More Info form, add a new record and complete the necessary fields. 

Some fields are described in the following table. 

Field Comments

Code A three-letter code for the currency.

Name The name of the currency.

Issuing Country The country that issues the currency.

Symbol The symbol for the currency, such as $.

Scale The number of places after the decimal used for displaying currency 
in the interface. For example, U.S. Dollars has a scale of 2 to 
accommodate the cents, so an amount would be displayed as 
$10.50. If the scale were 1, this same amount would be displayed as 
$10.5. 

Smallest 
Denomination

The smallest unit of currency available. For instance, the smallest 
unit of currency for the U.S. Dollar is one cent, or .01 dollars. If there 
were no cents, the scale would still be 2, but the smallest 
denomination would be $0.05.

EMU 
Triangulation

Check to indicate that this currency must be converted to other 
checked currencies using the EMU Triangulation method. 

Active Indicates whether or not the currency can be chosen by the end 
user.

Start Date The date when the currency becomes active.
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End Date The date when the currency is no longer active. 

Extended Scale The number of places after the decimal used for storing currency 
data in the database. If the values in the Extended Scale and Scale 
fields are different, results of currency calculations, for instance 
conversions or discounts, may be different than expected. This is 
because the currency values that are stored in the database are used 
for these calculations, rather than the displayed values.

Field Comments
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Setting Up Currency Conversion
This section discusses how to set up exchange rates and includes related 
background information. It includes the following topics:

■ Setting Up Exchange Rates. You must set up exchange rates used to convert 
currencies. 

■ Understanding the Euro and Triangulation. If a currency is part of the European 
Monetary Union, you convert it to other currencies through the Euro. 

■ Currency Conversion Functionality. The currency conversion rates that you set up 
are used by a number of features of Siebel applications. 

Setting Up Exchange Rates
After you have set up your currencies, but before you use any currency features or 
import data with foreign currencies, you must set up exchange rates that are used 
to convert currencies.

If you fail to set up an exchange rate, currency will be converted on a 1:1 basis. This 
means that the amount stays the same but the currency symbol changes.

NOTE: To calculate exchanges between currencies, you must set up an exchange rate 
twice—one for each currency. For instance, if you want to calculate exchange rates 
between U.S. dollars and Japanese yen, you must set up an exchange rate for yen 
to dollars, and set up another rate for dollars to yen.

To set up exchange rates

1 From the application-level menu, choose View > Site Map > Applications 
Administration > Currencies.

2 In the Currencies list, select the currency for which you want to establish 
exchange rates.

3 Click the Exchange Rates view tab.
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4 In the Exchange Rates list, add a new record and complete the necessary fields. 

Some fields are described in the following table. 

Repeat this process to add additional exchange rates.

You must restart the Siebel client or use the clear cache command before any 
changes to exchange rates can be seen in your Siebel application. For more 
information about clearing the cache, see “Clearing the Cache” on page 94.

The Euro and Triangulation

NOTE: As of January 2002, the Euro Triangulation method for converting between 
currencies belonging to EMU members is not needed for present and future 
currency exchanges. However, the method is still available in Siebel applications, as 
are the old currencies, so that historical data can be maintained accurately. The 
following description applies only to historical data needing conversion prior to the 
2002 switchover to the Euro for the EMU member countries.

Field Comments

Type Currently, Daily is the only type used. 

To Currency The currency to which you are converting the currency selected 
in the currencies list.

Exchange Rate The conversion rate. 

Exchange Date The date of this conversion rate. When converting currencies, 
Siebel applications use the exchange rate whose date is closest 
to, but not past, the date of the transaction. Depending on the 
accuracy that you need and on how much currency values are 
fluctuating, you may want to enter a new exchange rate every 
week, month, quarter, or year. 

Siebel applications use the Exchange Date only to convert 
currencies in transactions in which money has been or will be 
received. For example, Quote Item Price has an Exchange Date 
field, because it represents money that your company will 
receive, and your sales representatives should enter the date 
when the money will be received. 
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If a country is a member of the European Monetary Union (EMU), you should 
convert its currency to other currencies through the Euro. This is called 
triangulation, and it is used whenever either currency being converted has EMU 
Triangulation checked. 

For example, if you are converting from USD to DEM and DEM has EMU 
Triangulation checked, you must set up the conversion rates between US dollars and 
the Euro and between the Euro and US dollars. You do not have to check the EMU 
Triangulation field for USD. The DEM will be converted to EUR according to the 
fixed exchange rate set by the European Monetary Union, and then the amount in 
EUR will be converted to USD according the exchange rate you set up.

The EMU Triangulation field is already checked for the following European 
Monetary Union member nations: Germany (DEM), Belgium (BEF), Spain (ESP), 
France (FRF), Ireland (IEP), Italy (ITL), Netherlands (NLG), Austria (ATS), Portugal 
(PTE), Finland (FIM), and Luxembourg (LUF). However, you can check or clear this 
field. For instance, if the United Kingdom or Sweden joins the EMU, then you can 
check the field for that currency.

To calculate triangulation conversion, the conversion rate is always expressed to six 
significant figures. Conversions from one national currency unit into another are 
made by: 

1 Converting the monetary amount from the national currency unit into the Euro. 

2 Rounding the result to not less than three decimal places. 

3 Converting the result to the target national currency. 

4 Rounding the result to the lowest subunit of the target national currency, such 
as pfennig for the German mark or centime for the French franc.

NOTE: The EMU Triangulation field should be checked only for currencies that are 
subdivisions of the Euro. 

Currency Conversion Functionality
Currency conversions currently occur in your Siebel application in several features, 
including:
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■ Price lists. When you change the currency code of a price list, it will prompt you 
for an exchange date and convert the prices of all of the price list items. 

■ Quotes. When you change the currency code of a quote, it will convert the 
discount amounts and discount prices. 

■ Forecasting. When you update forecast information from the opportunity, it will 
do a currency conversion from the opportunity currency to the forecast currency 
if the currencies are different. When you roll up the forecast lines, it will do a 
conversion from the forecast line currency to the rollup forecast currency if the 
currencies are different.

■ Projects. When you create expenses in a currency different from the project’s 
currency and submit the expenses to the project, the expense amount will be 
converted from the expense currency to the project currency in the Project Time 
Expenses Summary and Project Time Expenses Adjustments views.

■ Rate lists. When you change the currency code of a rate list, it will prompt you 
for an exchange date and convert the prices of all of the price list items. 

■ Expense reports. When you prepare expense reports, you can perform currency 
conversion between the expense currency and your default currency. 

■ Reports. The following reports support currency conversion:

■ Opportunity Pipeline Report by Rep. Opportunity revenues created in different 
currencies will be converted in the Total and Subtotal fields to the user’s 
default currency.

■ Euro Expense Report. If expenses have been created in an EMU currency, all 
expenses will be displayed in dual currencies.

■ Project Limit Summary Report. 

■ Forecasting Reports. 

■ Current Quotes Report. 
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■ Charts. The following charts support currency conversion:

■ Opportunity Current Opportunity Analysis. Opportunity revenue will be 
converted to the user’s default currency if both the opportunity currency and 
the revenue currency are different from the user’s default currency.

■ Forecast Analysis. 
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Setting Up Expense Types
When employees create expense reports, they choose an expense type for each line 
item in the report. For examples, when employees travel on business, they might 
have to enter line items with expense types Food, Airfare, Car Rental, Hotel, and so 
on. 

When you set up expense types, you specify what expense types are available to 
employees in the drop-down list that they use to choose expense types. You also 
specify how these expense types will be categorized and summarized in expense 
reports. 

You can also create establishments that are associated with these expense types. For 
example, if the expense type is Airfare, you might associate establishments with it 
such as Air Canada and British Airways. For more information about associating 
expense types with establishments, see Siebel Professional Services Automation 
Guide, MidMarket Edition.

NOTE: Before you can add expense types and establishments, you must add them in 
the List of Values Administration screen so that they can be displayed in the drop-
down list. Add expense types under EXP_ITEM_TYPE, and add establishments 
under EXP_ITEM_ESTAB. When you add the expense types and establishments in 
the Expense Type screen, make sure they are identical to those in the List of Values 
Administration screen. For more details about List of Values administration, see 
Chapter 4, “Working with Lists of Values.” 

To set up expense types

1 From the application-level menu, choose View > Site Map > Applications 
Administration > Expense Types.
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2 In the Expense Types list, add a new record and complete the necessary fields. 

Some fields are described in the following table. 

Field Comments

Expense Type Enter the expense type that the employee will choose in the 
Expense Type drop-down list of expense report line items, such 
as Airfare. 

Report Category Enter a category for this expense type. This category will be used 
in summary reports, such as Air/Rail Fare.

Summary Enter a larger summary category for this expense type, such as 
Travel Cost. This summary category will be used in summary 
reports.
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Setting Up Payment Terms
Payment terms are the different terms that you offer to your customers, such as Net 
30 days and Net 60 days. You set up payment terms so that they are available in 
your Siebel application, for example in the Quotes screen.

To set up a payment term

1 From the application-level menu, choose View > Site Map > Applications 
Administration > Payment Terms.

2 In the Payment Terms list, add a new record and complete the necessary fields. 

Some fields are described in the following table. 

Field Comments

Payment Term Enter a name for the payment term, such as Net 30. 

Net Days If the payment term requires payment in a specific number of 
days after the order date, enter the number of days. Optional

Description Enter a description of the payment term. Optional. 

Discount If there is a discount for early payment, enter the amount of the 
discount. Optional. 

Discount Days If there is a discount for early payment, enter the number of days 
within which a customer must pay to qualify for the discount. 
Optional. 

Due If there is a specific due date for payment, enter the due date. 
Optional. 

Integration ID Users should not modify this system field. It is a cross-reference 
that links the Siebel application to corresponding payment term 
information in the back-office application. 
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Setting Up Periods
Periods are time periods that are used in your business, such as Q1 2002 or Jan 2001. 
Periods are used extensively in the Siebel application, such as in forecasting, time 
sheets, and expense reports. 

Be sure to set up periods far enough into the future that forecasting will work. For 
example, the default forecast is for seven months ahead. Therefore, if you keep this 
default, you must create periods defined for at least seven months from the current 
date for forecasting to work correctly. 

After setting up a period, you can associate Period Units with it. Period Units allow 
you to define one time unit in terms of another. For example, day periods can be 
associated with week periods for use in Timesheets. When a new timesheet is 
created, based on a week period, each day in that week is also added to the 
timesheet. This functionality requires the day periods to be associated as Period 
Units with the week period.

To set up periods

1 From the application-level menu, choose View > Site Map > Applications 
Administration > Periods.

2 In the Period Definition list, add a new record and complete the necessary fields. 

Some fields are described in the following table. 

Field Comments

Period Enter a name for the period, such as Q1 2001. 

Closed Select this to indicate that the period has already closed.

Start Enter the start date for the period. 

End Enter the end date for the period. 

Type Select the type of period, such as month, quarter, or year.

Description Enter a description of the period.
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To associate period units with a period

1 From the application-level menu, choose View > Site Map > Applications 
Administration > Periods, and select the appropriate period.

2 In the Period Units list, click New.

3 In the Period Units dialog box, select all the period units to associate with this 
period, and then click OK.
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Specifying Telephone Formats
Default telephone formats are specified in the List of Values view. You can only have 
one default telephone number format per country. The default format is applied 
when you enter only numbers, without slashes, dashes, or other formatting 
symbols. 

Before users enter telephone numbers:

■ Set the default country. See “Setting Up Locales” on page 35. The default phone 
format is determined by the locale setting. 

■ Define formats for countries outside the default country. See “Specifying Non-
North American Telephone Formats” on page 62.

If a user enters a telephone number from a country for which the format has not yet 
been specified, the telephone number may be formatted incorrectly.

NOTE: If you define any new telephone formats, coordinate with communications 
administrators who specify CTI functionality and define dialing filters. For more 
information, see Siebel Communications Server Administration Guide, MidMarket 
Edition. 

North American Telephone Formats
The default format for North American telephone numbers is (000) 000-0000. The 
telephone formatting logic for North American telephone numbers works as 
follows:

■ If the user enters 10 digits in a telephone number field, it is formatted as (123) 
123-1234.

■ If the user enters more than 10 digits, the first 10 digits are formatted as (123) 
123-1234, and the rest of the digits are used as the extension number. The user 
can enter up to 40 digits.

■ If the user enters fewer than 10 digits, an error message appears.

■ If the user begins the telephone number with a leading zero, an error message 
appears.
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This telephone formatting logic is followed even when the default country is not in 
North America.

Specifying Non-North American Telephone Formats
If your users need to enter telephone numbers for countries outside North America, 
you must specify telephone number formats for those countries.

To specify non-North American telephone formats

1 Choose View > Site Map > Application Administration > List of Values.

2 Query the Type field for the entry PHONE_FORMAT to see existing telephone 
formats.

3 Add a new record and complete the necessary fields. 

Some fields are described in the following table. For more field information, see 
Chapter 4, “Working with Lists of Values.”

Field Comments

Display Value

Language-
Independent Code

Enter the format string.

Use the number zero (0) to represent required digits, the 
character # to represent optional digits, and other formatting 
characters to represent how the telephone number should 
appear. Do not include any alphanumeric characters other 
than 0.

For example, to format an Australian phone number, which 
includes a two-digit area code and a six- or eight-digit number, 
use (00) 000# 000#.

You do not need to include characters to represent the country 
code in the format. When a user enters a number, the country 
code is automatically shown if the default country is different 
from the country code.

The maximum number of digits allowed in the format is 12. 
Any digits beyond 12 are used as the extension number. For 
example, even if the format is 000-000-0000-0000, 14 digits 
entered as 12345678901234 display as 123-456-7890-12x34.
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4 Follow the instructions in “Clearing the Cache” on page 94.

International Telephone Formats
To enter an international telephone number (a telephone number for a country 
other than the current default country) in a telephone field, the user must specify 
the country by preceding the telephone number with a plus sign (+) followed by 
the country code (for example, +44). If the user does not enter a country code, the 
default country code is assumed.

After the user indicates the country by entering the plus sign and country code, the 
telephone formatting logic for international telephone numbers works as follows:

■ If the user enters exactly the same number of digits in a telephone number field 
as there are in the telephone format for the indicated country, the entry is 
formatted as specified.

■ If the user enters more than the number of digits in the telephone format for the 
indicated country, the first digits are formatted as specified and the rest of the 
digits are used as an extension number. The user can enter up to 40 digits.

■ If the user enters fewer than the number of digits in the telephone format for 
indicated country, the entry is accepted without an error message. (This is to 
accommodate telephone numbers of different lengths.)

■ If there is no List of Values telephone format entry for the indicated country, the 
number is accepted, but not formatted. No error message is returned.

Order Enter the country code of the new format.

Type Enter PHONE_FORMAT or choose it in the drop-down list.

Field Comments
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Unformatted Telephone Numbers
When you change or add a telephone number format, the existing telephone 
numbers are not updated automatically.

CAUTION: When entering telephone numbers, users can enter letters in place of 
digits, but computer telephony integration (CTI) features, such as outbound dialing, 
do not work for these numbers. Queries for such numbers must include the letters, 
not the numeric equivalents. Siebel eBusiness Applications do not detect or warn 
users if they enter Q or Z (letters that do not appear on all telephones).

Examples
Table 6 shows how telephone numbers would appear under various circumstances. 
In this example, the default country is the United States and the default format is 
the North American format, (000) 000-0000. Another format has been entered for 
England (country code 44): 00.000-000.

The telephone format has no effect on sort order.

Table 6. Telephone Number Format Examples

User Enters Number Is Formatted As

1234567890 (123) 456-7890

1234567890123 (123) 456-7890 x123

123456 Error message: “Invalid data has been entered.”

+4412345678 +44 12.345-678

+441234567890 +44 12.345-678 x90

+4412345 +44 12345

+2512345 +2512345

?0+4412345678 ?0+4412345678 (you see the ‘?’ and the ‘0’)

?0HelloWorld ?0HelloWorld (you see the ‘?’ and the ‘0’)
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When performing a query on a telephone number, do not include any format 
characters such as (,), -, ., x, or spaces.

You can query for only country 61 by typing +61* but you cannot query for only 
North American telephone numbers this way, because +1* returns all telephone 
numbers. To query for North American telephone numbers, use not like (+)* 
instead.

Table 7 gives examples of how to query telephone numbers.

When the user performs a query using a telephone number, the country code of the 
default country automatically prefixes the query (unless the default country is in 
North America, in which case no prefix is added). For example, if the default 
country is Germany, and the user types “0181” in the telephone field of a query, the 
German country code (+49) is added to the query (that is, +49*0181*). 

To find a number for a country other than the default country, the user must specify 
the country code in the query. To avoid limiting the query to one country, the user 
must refine the query and remove the country code portion of the query 
specification.

Table 7. Querying Telephone Numbers

Desired Query Result Query Criteria

(123) 456-7890 1234567890

+61 (123) 45.67.89 x0 +611234567890 (if 61 is defined as a 
country code)

Country code 61 telephone numbers +61*

All telephone numbers +1*

415 area code numbers (North America only) 415*

Null telephone numbers is null

415 area code or null (North America only) 415* or is null

(800) SKY-PAGE 800SKY*
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To see a demonstration of this behavior, look at the Contacts screen. Every number 
for a country other than the default contains a “+n” at the beginning, while every 
number for the default country code appears as local (no +). Numbers that have 
the “+n” require explicit queries (country code plus number) while local numbers 
are returned normally.

Importing Information with EIM
Siebel Enterprise Integration Manager (EIM) manages the exchange of data between 
Siebel database tables and other corporate databases. When you use EIM to import 
information that includes international telephone numbers, the numbers are 
handled as described in the previous sections.

For more information about EIM, see Siebel Enterprise Integration Manager 
Administration Guide, MidMarket Edition.
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Setting Up Pager Companies
Pager companies can be set up so they are available from the File > Send > Page 
menu.

To set up a pager company

1 From the application-level menu, choose View > Site Map > Application 
Administration > Pager Companies.

2 In the Pager Companies list, add a new record and complete the necessary fields. 

Some fields are described in the following table.

NOTE: The pager companies you use to send pages must support Telocator 
Alphanumeric Protocol (TAP), which is an industry standard for sending 
alphanumeric pages.

Field Comment

Name Required.

Service Type The choices in this drop-down list are One-Way and 
Two-Way.

Computer Paging Phone # Required.
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Date Formats
For the Siebel Web Client the display format for date and time is determined by the 
locale settings of the application server. For more information, see “Setting Up 
Locales” on page 35.

For the Siebel Dedicated Web Client and the Siebel Mobile Web Client, the date 
format is determined by the specification in the client computer’s operating system. 

When a user creates a query using a date field, the user must use the appropriate 
date format.

CAUTION: Siebel applications do not support date formats containing alphabetic 
versions of the month, so the format 19-Jul-1997 causes an error message whenever 
the system attempts to write a date value to the database.
68 Applications Administration Guide MidMarket Edition Version 7.5, Rev. A



Ongoing Application Administration Tasks

Administering Global Time Zone Support
Administering Global Time Zone Support
The time zones records that are shipped with Siebel applications as seed data 
include the 74 world time zones. These are the same time zones used by Microsoft 
in its operating systems. Use the Time Zone administration view to:

■ Edit the text descriptions of time zones and their abbreviations 

■ Manage the active status of time zones to control which time zones are available 
to end users for use in the applications

■ Manage multilingual translations to control how time zone information is 
displayed to users in multiple languages

Tasks for administering time zones include:

■ “Modifying Time Zones” on page 69

■ “Maintaining Translations of Time Zones” on page 70

For more information on global time zone support, see Global Deployment Guide, 
MidMarket Edition.

Modifying Time Zones
You will rarely need to modify a time zone’s regional settings. However, you may 
want to modify other time zone settings such as the display name or daylight 
savings rules, as these occasionally change.

To modify time zone settings

1 From the application-level menu, choose View > Site Map > Application 
Administration > Time Zone Administration.

2 In the Time Zone list, select the time zone record you want to modify.
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3 Modify the fields as necessary.

Some fields are described in the following table.

Maintaining Translations of Time Zones 
You maintain translations of the text-based fields for each time zone using the Time 
Zone Administration view.

To maintain translations of time zones

1 From the application-level menu, choose View > Site Map > Application 
Administration > Time Zone Administration.

2 In the Time Zone list, select the time zone you want to translate.

3 In the Time Zone Translation list, add a record and complete the necessary 
fields, including the translation of the Name field for the selected language.

Field Description

Name Name of time zone.

Standard Abbreviation The abbreviation for the time zone. 

UTC Offset Offset, in minutes, from Coordinated Universal Time (UTC) 
when daylight savings is not in effect.

DST Abbreviation The abbreviations for daylight savings time (DST).

DST Bias Incremental DST offset, in minutes, from UTC when DST is 
not in effect.

DST Start Ordinal Part of the rule that determines when DST starts. For 
example, if the rule is the first Sunday in April, First is defined 
in this field.

DST Start Day Part of the rule that determines when DST starts. For 
example, if the rule is the first Sunday in April, Sunday is 
defined in this field.

DST Start Month Part of the rule that determines when DST starts. For 
example, if the rule is the first Sunday in April, April is 
defined in this field.

DST Start Time Start time for DST.
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4 Repeat Step 3 for each language required for translation.

Date and Time Stamps
The date and time used for time-stamping records are obtained by the Siebel Server. 
When a remote user runs the Siebel client in disconnected mode, the Siebel Server 
runs on the user’s machine and takes the date and time from that machine.

If global time zone support is enabled, the server converts the date and time value 
to UTC.
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Setting Up Email, Fax, and Mail Accounts (Contact Us)
Sales people use the Contact Us screen to answer questions and provide contact 
information to customers. If your organization uses Siebel eService, your customers 
can access this information directly from a Contact Us page on your Web site.

Creating a Contact Us Account
To help your sales people provide information on a chosen topic, you can create 
different accounts, such as Technical Support, Shipping, and Sales.

To add a Contact Us account

1 From the application-level menu, choose View > Site Map > Application 
Administration > Contact Us.

2 In the Email, Fax and Mail Accounts list, add a new record.

3 In the More Info form, complete the necessary fields. 

Some fields are described in the following table.

Adding Email Addresses and Subjects
If your organization uses Siebel eService, any email addresses you include in 
Contact Us accounts appear on a Contact Us page on your Web site. You can create 
default email subjects that are added to the user’s Subject line when the user sends 
email through your Web site.

For more information, see Siebel eService Administration Guide, MidMarket Edition.

Field Description

Account Required. The name of the account.

Account Type Choose the Contact Us type.

Access List Indicates which employees can view the Contact Us account.
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Using Keyboard Accelerators
Keyboard enablement allows users to operate the Siebel employee applications 
using sequences of keystrokes as an alternative to the mouse for executing 
commands and navigating through the application. This is accomplished through 
the use of keyboard accelerators, specific sequences of keystrokes that are mapped 
to commands within the Siebel application environment. Typically, these key 
sequences are combinations of the Ctrl, Alt, and Shift keys, along with standard 
alphanumeric keys.

A full set of keyboard accelerators ship with the Siebel employee applications. 
Accelerators are defined in Siebel Tools and are fully configurable, although care 
should be taken when modifying accelerators.

Much of the default keyboard enablement provided natively by Web browsers is 
also available for use in the Siebel applications. For example, users can navigate 
sequentially through enterable fields within the application views with the Tab key. 

For example, keyboard accelerators are provided for the following commands:

■ Record manipulation: New Record, Delete Record, Copy Record, Edit Record, 
Save Record, Undo Record

■ Query management: New Query, Execute Query, Refine Query, Save Query As

■ Record navigation: Next Record, Previous Record, Next Page, Previous Page
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Keyboard enablement is available in two modes: extended mode and basic mode. 
Extended mode keyboard enablement gives maximum flexibility in defining 
accelerators since any key sequence may be mapped to Siebel commands. However, 
extended mode keyboard accelerators may not be available to all users. Basic mode 
keyboard enablement is accessible to any user running the Siebel applications in 
High Interactivity mode. Each accelerator defined in the Siebel Repository can be 
specific to one keyboard enablement mode, or it can be common to both modes. For 
a list of basic and extended accelerators available, see Fundamentals, MidMarket 
Edition.

NOTE: Both extended and basic mode keyboard enablement require that the Siebel 
applications are running in High Interactivity mode. It is possible that a few applets 
within the Siebel applications will not enable High Interactivity mode due to special 
applet functionality, even if High Interactivity mode is in effect for the applications 
in general. In these cases, keyboard enablement will not be active when the user is 
working within one of these specialized applets.

Extended Mode
Extended mode keyboard enablement is the default mode of operation for Siebel 
applications. Applications running extended mode keyboard enablement can map 
any key sequence to Siebel commands. This includes key sequences that have 
default interpretations native to the browser in use (for example, Ctrl+N opens a 
new browser window in late versions of Microsoft Internet Explorer). In cases 
where both the active Siebel application and the active browser have the identical 
key sequence mapped, the Siebel applications will win in extended mode. Extended 
mode keyboard enablement also allows accelerator key sequences to include special 
keys, such as function keys and the arrow keys.

To provide accelerator access to all available key sequences, extended mode 
keyboard enablement uses a lightweight ActiveX control to capture keystrokes in 
the browser. Presence of the control is detected automatically and the control is 
loaded only if necessary. Once loaded, the control is automatically maintained. It 
will not be loaded again unless an upgraded version becomes available on the 
application server.

In order for keyboard enablement to be active in extended mode, the following 
conditions must be met:
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■ The line “ExtendedKeyboard=TRUE” must appear in the [SWE] section of the 
configuration file for the active application

■ The user's browser must be able to accept and correctly interpret the ActiveX 
control used to capture key sequences

■ Each client browser must accept the lightweight ActiveX control used to capture 
key sequences. Acceptance of the control may be silent, or it may require the 
user to explicitly accept the control depending on browser security settings. If 
current browser security settings prohibit downloading of ActiveX controls, the 
browser security settings will need to be modified to allow ActiveX controls.

Basic Mode
Basic mode keyboard enablement is accessible to all browser clients running the 
Siebel applications in High Interactivity mode. No ActiveX control is required to 
support basic mode. The functional differences between basic mode and extended 
mode keyboard enablement are:

■ Key sequences mapped natively by the current browser will take precedence 
over Siebel keyboard accelerators mapped to the same key sequences. For 
example, Ctrl+N in version 5.5 of Microsoft Internet Explorer will open a new 
browser window regardless of accelerator mappings for Ctrl+N in the Siebel 
applications.

■ Basic mode keyboard accelerators cannot include special keys in their mapped 
key sequences. Special keys include, but are not limited to, function keys and 
arrow keys.

Keyboard enablement will be active in basic mode if either of the following is true: 

■ The line “ExtendedKeyboard=FALSE” appears in the [SWE] section of the 
configuration file for the active application. 
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■ The current browser does not support extended mode keyboard enablement.

NOTE: Siebel applications use automatic browser detection to determine if a browser 
is capable of supporting extended mode keyboard enablement. If the current 
application is configured to run extended mode keyboard enablement but the 
browser on a particular client does not meet the minimum requirements, the 
application will be started with basic mode keyboard enablement in effect.

To configure new keyboard accelerators or modify existing ones, see Siebel Tools 
Reference, MidMarket Edition.
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Setting Up Industries
You can set up and maintain industry information used throughout the application. 
The information in the Industries view populates the Industries drop-down list, 
which is found in a variety of screens and views, such as in the Accounts screen.

To add an industry

1 From the application-level menu, choose View > Site Map > Application 
Administration > Industries.

2 In the Industries list, add a new record. 

3 Fill in the Industry, SIC Code, and Type fields. 

NOTE: The Industry and SIC Code values must be unique. If you add a value that 
already exists, you will receive an error message. 
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Setting Up Languages
You can set up and maintain language information used throughout the application. 
The information in the Languages view populates the Language drop-down list, 
which is found in a variety of screens and views, such as in the SmartScripts screen. 

For example, a sales representative for a German chemical manufacturing company 
could use a Danish SmartScript to make a sales call to a prospective customer in 
Copenhagen, and then make the same sales call using an Italian SmartScript when 
speaking to a prospective customer in Rome. In these cases, the Language field is 
used to identify the language into which each SmartScript has been translated.

To add a language

1 From the application-level menu, choose View > Site Map > Application 
Administration > Languages.

2 In the Languages list, add a new record. 

3 Complete the Name and Code fields.

NOTE: The Name and Code values must be unique. If you add a value that already 
exists, you will receive an error message.

NOTE: Languages cannot be deleted because deleting languages may cause problems 
with mobile Web client synchronization. While the delete language command can 
be restored using Siebel Tools, this is strongly discouraged. Additionally, ask for 
assistance from Siebel Technical Services before modifying any language code.
78 Applications Administration Guide MidMarket Edition Version 7.5, Rev. A



Ongoing Application Administration Tasks

About Case Sensitivity
About Case Sensitivity
By default, Siebel applications are case-sensitive. If you perform a query or search, 
there will be a match only if the search criteria you enter are capitalized in the same 
way the data is capitalized in the database. 

If you do not want queries and searches to be case-sensitive, you can enable case 
insensitivity either for the entire application or for selected fields. Please note the 
following: 

■ Application-wide case-insensitive searching can affect performance if you use a 
large database. The larger the database is, the greater the effect on performance 
will be. 

■ Field-specific case insensitivity has less of an effect on performance. If 
application-wide case insensitivity slows performance, you should use field-
specific case insensitivity. 

This setting determines whether simple queries and searches, where the user 
just enters a criterion in the field, are case-sensitive. 

Regardless of which setting you choose, users can use operators to force case-
sensitive or case-insensitive searches.

To force a case-sensitive search, use the operator = followed by the criterion in 
quotation marks. For example, if the user enters the criterion =’Computer’, the 
query will return only records that have “Computer” spelled with a capital C in the 
field.

To force a case-insensitive search, use the operator ~LIKE. For example, if the user 
enters the criterion ~LIKE computer, the query will return all records that have 
“computer” in the field, regardless of capitalization. 

The user must also use ~LIKE to force case insensitivity in searches with complex 
criteria, regardless of the setting for case sensitivity. 

NOTE: You should determine your requirements for case-insensitive searching and 
set the appropriate parameters for the application or individual field before users 
enter any data.
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Enabling Application-Wide Case Insensitivity
Application-wide case sensitivity is controlled through the CaseInsensitive 
parameter of the named subsystem representing the datasource definition. 

By default, each of these data source definitions has the following parameter 
setting:

CaseInsensitive = FALSE

To enable application-wide case insensitivity, you change this setting to TRUE.

NOTE: There may be a performance degradation when the CaseInsensitive parameter 
is set to TRUE. You may want to also change the InsensitivityFactor Parameter to 
minimize performance degradation. For more information, see “Modifying the 
InsensitivityFactor Parameter” on page 82.

The CaseInsensitive parameter only affects which data is retrieved by queries. It 
does not affect the order in which data appears on the screen. The sort sequence is 
database-dependent, and independent of the CaseInsensitive parameter.

In addition, the content of SRF files is case-sensitive in most cases and is not 
affected by how this parameter is set in the application configuration file.

You change the CaseInsensitive parameter in different ways, depending on whether 
you are working with Siebel Web Client or Siebel Dedicated Web Client.

Enabling Application-Wide Case Insensitivity for Siebel Web 
Client
For Siebel Web Client, you make changes to the CaseInsensitive parameter in the 
Server Administration screen. 

To enable application-wide case insensitivity for Siebel Web Client

1 From the application - level menu, choose View > Site Map > Server 
Administration > Enterprise Configuration.

2 Click the Enterprise Profile Configuration view tab.
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3 In the Component Profiles list, select the Named Subsystem Alias for the data 
source.

4 In the Enterprise Profile Configuration list, change the value of the 
DSCaseInsensitiveFlg to True.

5 Optionally, change the InsensitivityFactor Parameter as well, to control 
performance degradation. 

6 Stop and restart the Siebel Server.

For more information, see “Modifying the InsensitivityFactor Parameter” on 
page 82.

Enabling Application-Wide Case Insensitivity for Siebel Dedicated 
Web Client
For Siebel Dedicated Web Client, application-wide case sensitivity is controlled 
through the CaseInsensitive parameter in the configuration file for your application. 

The configuration file for each Siebel application has a section for each one of the 
potential data sources for the application. By default, each of these data source 
sections has the following line:

CaseInsensitive = FALSE

To enable application-wide case insensitivity for Siebel Dedicated Web Client

1 Use any text editor to open your application configuration (.cfg) file. 

2 Change the CaseInsensitive parameter to

CaseInsensitive = TRUE

3 Optionally, change the InsensitivityFactor parameter to control performance 
degradation. 

The InsensitivityFactor parameter follows the CaseInsensitive parameter in each 
application configuration file. For more information, see “Modifying the 
InsensitivityFactor Parameter” on page 82.
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Modifying the InsensitivityFactor Parameter
When you change the CaseInsensitive parameter, you may also want to change the 
InsensitivityFactor parameter to minimize performance degradation. 

The default setting for the InsensitivityFactor parameter is 2.

NOTE: Do not change the default value of InsensitivityFactor for Gateway Datasource 
(GatewayDataSrc). Gateway Datasource does not go against a database. Changing 
the value may cause problems.

You may want to test a number of values for this parameter with your database, 
spool the SQL to see the effect of different settings on response time, and then 
choose a value that meets your needs.
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Enabling Field-Specific Case Insensitivity
You can also make individual fields case-insensitive. If you are concerned about 
performance, it is better to make a few fields case-insensitive than to enable 
application-wide case insensitivity.

You control field-specific case insensitivity with the Use Default Sensitivity property. 
This property determines whether the field uses the default property specified by 
CaseInsensitive parameter in the .cfg file, described previously. Table 8 illustrates 
the relationship between the application-wide CaseInsenstive parameter and the 
field-specific Use Default Sensitivity property.

To enable case insensitivity for individual fields

1 Leave the CaseInsensitive parameter set to FALSE in the application 
configuration file.

2 In Siebel Tools, navigate to the Business Component/Field screen. 

3 For each field you want to be case-insensitive, set the Use Default Sensitivity 
property in the field object to FALSE for the Field level Object Type.

You can also force the case of data in a field to be UPPER (all uppercase), 
LOWER (all lowercase), FIRSTUPPER (first letter of each word is uppercase, or 
NONE (unchanged). 

4 After doing this for all of the fields you want to control, recompile your .srf file.

5 Replace the .srf file in your Siebel Server installation. 

Table 8. Case Sensitivity Behavior

Use Default Sensitivity = CaseInsensitive = TRUE CaseInsensitive = FALSE

TRUE Field is case insensitive Field is case sensitive

FALSE Field is case sensitive Field is case insensitive
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Adding Web Browser Capabilities
Siebel applications come with a number of browsers configured for use. Generally, 
you will not need to make changes to the Web browser settings. However, if you 
need to add a capability to a browser, you can do so through the Web Browser 
Administration screen. 

Web browser capabilities identify what an end user's browser can and cannot do. 
They support the Siebel Web Engine's ability to provide different HTML tags and 
other markup tags to different browsers, based on what each particular browser is 
capable of rendering. This can also allow an administrator or developer to specify 
what looks best in a particular browser. 

When a user logs into a Siebel Web application, the Siebel Web Engine reads 
information encapsulated in the requests coming from the user's browser to 
determine the browser’s version and make. It then correlates that information with 
the data contained in the Web Browser Administration views to determine the 
browser’s capabilities.

One of the primary ways this information is applied is through conditional tags in 
Web templates. For example, if some of your users use an older browser that does 
not support frames, your template might include a conditional tag that prevents 
these users from receiving pages with frames. Conditional Web engine tags that 
evaluate browser capabilities can be used in all Siebel Web templates and Web 
applications, but are used most prominently in those that support wireless devices. 
For example, the SWLSDetailApplet.swt template includes the following conditional 
tag:

<swe:switch>

<swe:case condition="Web Engine User Agent, TestCapability,          
DefaultMarkup:XML'">

<swe:xsl-stylesheet name="SWLSDetailApplet.xsl" mode="process"/>

</swe:case>
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By the time that the Web Engine interprets the swe:case tag, it has already 
determined what type of browser the user has. The usage of the tag causes the Web 
Engine to call the “TestCapability” method on the “Web Engine User Agent” 
business service. The “TestCapability” method will return TRUE if the user’s 
browser has a Capability called “DefaultMarkup” with a value of “XML.” When the 
condition is met (that is, the method returns TRUE) the tags between <swe:case> 
and </swe:case> are processed. In this example the Web engine is instructed to 
use a particular XSL style sheet. For more information about the syntax of 
conditional tags, see Siebel Tools Reference, MidMarket Edition.

Adding Additional Capabilities 
Siebel applications come with a number of predefined capabilities. These 
capabilities can be added to any browser. Some examples include:

■ FrameSupport. Indicates whether the browser can render frame tags (for example, 
<swe:frameset>).

■ CookiesAllowed. Indicates whether the browser supports cookies.

■ HighInteract. Indicates whether the browser is among those supported for 
Siebel's High Interactivity Web applications (such as Internet Explorer 5.5).

■ ActiveX. Indicates whether the browser can support ActiveX controls.

You can also add other capabilities that are not included in the standard Siebel 
application. For example, you could add a capability named SupportsWingDingFont. 
New capabilities then become available for use in any browser definition.

To add a capability

1 From the application-level menu, choose View > Site Map > Web Browser 
Administration > Capabilities.

2 In the Capabilities list, add a new record.

3 Complete a name and description for the new capability.
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Adding Additional Web Browsers
If you need to add a Web browser definition that is not included in the standard 
Siebel application, you can choose between the following two methods.

■ Add a parent browser definition. This definition includes all of the browser 
capabilities. Use this method if you need to add a completely new browser (such 
as Opera), or a major upgrade release of an existing browser (such as future 
releases of Microsoft Internet Explorer or Netscape). For information about this 
procedure, see “To add a parent Web browser” on page 87.

■ Add a child browser definition. Child browser definitions inherit the capabilities 
of the parent browser, and add additional capabilities as necessary. Use this 
method for adding interim releases based on a browser that is already defined. 
For example, a “dot” release, such as 5.7 or 5.8. For information about this 
procedure, see “To add a child Web browser” on page 88.

Required Browser Capabilities
For a browser to work correctly, it must include two capabilities that allow the 
browser to be identified at runtime. The required capabilities are:

■ User-Agent. This capability names the browser. 

■ Accept. This capability indicates what types of documents the browser can open. 

These capabilities are part of HTTP standard information and appear in HTTP 
request headers sent from a browser. For example, a request from a Microsoft 
Internet Explorer 5.5 browser sent to a Web application might include the following 
lines:

Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, 
application/vnd.ms-powerpoint, application/vnd.ms-excel, 
application/msword, */* 

User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 4.0)

In this example, the value for the User-Agent capability would be Mozilla/4.0 
(compatible; MSIE 5.5; Windows NT 4.0).
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Both the User-Agent and Accept capabilities must be included. This is because at 
runtime, the User-Agent is checked to identify the browser. If the User-Agent is not 
recognized, the values for the Accept parameter in the header will be compared to 
the Accept parameters of the browsers listed in the Web Browser Administration 
screen, to find the browser with the most closely matching Accept parameters. 

In addition to the User-Agent and Accept capabilities, if a browser is based on an 
existing parent browser, it must include the Parent capability.

NOTE: Parent browsers frequently do not have the User-Agent and Accept 
capabilities. This is because parent browsers are intended to serve as containers of 
other capabilities that can be inherited. If a browser does not have its own User 
Agent and Accept capabilities, then it is acting as a parent of another browser that 
has these capabilities.

Adding a Web Browser
Whether you are adding a parent browser or a child browser, the process is similar. 
However, in the case of a parent browser, you add all detailed components, and in 
the case of a child browser, you base the browser on an existing browser.

NOTE: Although a parent browser may contain the User-Agent and Accept 
capabilities, it does not have to. If you use parent browsers as templates for child 
browsers, do not include these two capabilities in the parent browser template. 

To add a parent Web browser

1 From the application-level menu, choose View > Site Map > Web Browser 
Administration > Browsers.

2 In the Browser list, add a new record.

3 Complete a name and description for the new browser.

4 Click the Capabilities view tab.
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5 In the Capabilities list, add records for each of the capabilities for this browser.

NOTE: If there is an existing browser that contains most of the appropriate 
capabilities, you can copy it and then make changes. To do so, in Step 2, click the 
menu button and choose Copy Record instead of New Record. 

To add a child Web browser

1 From the application-level menu, choose View > Site Map > Web Browser 
Administration > Browsers.

2 Scroll through the list of browsers and identify the parent browser (that is, the 
one on which you will base the new browser).

3 Add a new record.

4 Complete a name and description for the new browser.

5 Click the Capabilities view tab.

6 In the Capabilities list, add these three records:

■ Parent. Set the capability value to the parent browser you identified in Step 2.

■ User-Agent. Enter the appropriate User-Agent. 

■ Accept. Enter the types of documents that can be opened by the browser.

7 Add any additional capabilities that are not included in the parent browser.
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This chapter provides guidelines to administrators for working with lists of values 
within Siebel applications.

A list of values (LOV) is a set of values that populates a static pick list, which is 
accessed when a user clicks a drop-down list in the user interface. 

Drop-down lists can be based on two types of pick lists: static pick lists and dynamic 
pick lists. 

■ A static pick list has a selection list that is a static list of values. An example of 
a static pick list is a drop-down list containing postal abbreviations for states and 
countries. 

■ A dynamic pick list has a selection list that usually contains transactional data. 
An example of a dynamic pick list is a drop-down list containing account names. 

As a rule of thumb, dynamic pick lists include all pick lists that do not retrieve 
values stored in the S_LST_OF_VAL table. Dynamic pick lists are typically 
rendered through a pick applet, such as the pick list used to choose an account 
for a contact. However, they can be configured to appear as a drop-down list.

The remainder of this section focuses on static pick lists, whose contents can be 
administered from the List of Values views. For information on how to set up a new 
list of values and configure both static and dynamic pick lists, see Siebel Tools 
Reference, MidMarket Edition. 

This section describes how to work with the values that populate static pick lists, 
including how to add or modify values in an existing list of values, and inactivate 
values when you do not want them to display. In addition, it describes how lists of 
values can be constrained by selections in other lists. 

NOTE: If you will be creating multilingual lists of values (MLOV), you should also 
review Siebel Tools Reference, MidMarket Edition.
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There are two screens in which you can view list-of-values data: 

■ In a list view in the Application Administration screen, List of Values view

■ In an explorer view in the Application Administration screen, List of Values 
Explorer view

The values in these two views are the same. Only the format in which the 
information is presented is different. The procedures in this section give instructions 
that specify using the list view. If you prefer to use the explorer view, you may do so.

Your Siebel applications come with numerous lists of values that support the static 
pick lists used throughout Siebel screens. You can use these as they are, or you can 
modify them through the List of Values screen to support your organization’s 
requirements. 
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Adding a New Value to an Existing List of Values
In order to add an item to an existing list of values so that it shows up in a drop-
down list, you must know its type. You can find out the type by querying the List 
of Values list to determine the type associated with a specific display value. Then 
you can add a new record with that type. For instance, in the Accounts list you can 
see the Status drop-down list. Imagine that you use this field to indicate ratings for 
your accounts’ reliability. Initial settings are Gold and Silver. You might want to add 
another status of Bronze to this list, to give to customers that have a reliable account 
rating. The procedure below uses this example.

To identify the list-of-values type for a display value

1 Navigate to the screen displaying the drop-down list to which you want to add 
a value (for example, the Accounts screen).

2 Select the drop-down list and make note of one of the choices. 

For example, in the Accounts screen, select the Status drop-down list and make 
note of the value Gold.

TIP: Be sure to note the capitalization and spacing of the choice.

3 From the application-level menu, choose View > Site Map > Application 
Administration > List of Values. 

4 In the List of Values list, perform a query in the Display Value field, using the 
value you noted in Step 2.

5 In the list of records that is returned, identify the appropriate record by reviewing 
the entries in the Type field. 

List-of-values types usually have names that relate to the field labels in the 
screens where they are used. In this example, you would look for a type labeled 
something like ACCOUNT_STATUS. 

When you create a new value for this list, you will use this type.
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To add a new value to an existing list of values

1 From the application-level menu, choose View > Site Map > Application 
Administration > List of Values. 

2 Click New to create a new record, and then enter the list-of-values type in the 
Type field. 

3 Enter a new value in the Display Value field. 

For example, if Bronze is the status that your organization gives customers that 
have a reliable account rating, and you want to make Bronze available as in the 
Account Status drop-down, you would add a new record with 
ACCOUNT_STATUS as the type and Bronze as the display value. 

Make sure that the length of the Display Value you enter does not exceed the 
allowed length of the destination column.

4 Enter a value in the Language Independent Code field. This value is usually the 
same as the Display Value.

Make sure that the length of the Language Independent Code you enter does not 
exceed the allowed length of the destination column. 

NOTE: The Display Name and Language Independent Code must both be unique 
within a list-of-values type, except when configuring a multilingual list of values. 
If you add a value that already exists, you will get an error message. For example, 
there cannot be two ACCOUNT_STATUS records that have a display value of 
Bronze. For information about how this differs for multilingual lists of values, 
see the definition of the Language Independent Code field in Table 9 on page 95.

5 If applicable, in the Order field, you can enter a number to indicate the 
numerical order in which the value appears in a drop-down list. 

For example, if the order numbers for Gold and Silver are 1 and 2, respectively, 
the order number for Bronze would be 3.

6 If appropriate, fill in the remaining fields in the record. 

For a description of these fields, see “List of Values Fields” on page 95.
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7 Clear the LOV cache by clicking the menu button and then choosing Clear LOV 
Cache. 

After you have cleared the cache, you can navigate to a screen and select the new 
value in the related drop-down list. For example, you can navigate to the Accounts 
screen, select a record from the Accounts list, and then choose Bronze in the 
record’s Account Status drop-down list.
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Clearing the Cache
A particular list of values is cached the first time a user opens a drop-down list that 
uses the list of values. This improves performance by avoiding the need to retrieve 
the list from the database upon subsequent usage of the drop-down list. However, 
this also means that updates to a list of values will not show up in a drop-down list 
until you clear the cache. Clearing the cache instructs the Siebel application to read 
the updated values out of the database and display them. 

Users who log in after you add or change a list of values can see the addition or 
change that you made. However, in order for you to see the changes that you made 
in real time, you must do one of the following: 

■ For the Dedicated Web Client, log out of the application and log back in.

■ For either the Web Client or the Dedicated Web Client, clear the cache.

To clear the cache

1 From the application-level menu, choose View > Site Map > Application 
Administration > List of Values.

2 In the List of Values list, click Clear Cache. 
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List of Values Fields
List-of-values records have the fields shown in Table 9. Not all fields for list-of-
values records are displayed in the standard user interface. You can use the Columns 
Displayed menu option to see a field that is not displayed. 

Some list-of-values fields, such as High, Low, and Weighting Factor, are for use by 
specialized Siebel C++ code to store additional information about the selected list 
of values record. In addition, pick maps can use list-of-value fields such as High, 
Low, and Weighting Factor. Pick maps normally use the Display Value field, which 
causes the list item selected by the user to be stored in the database exactly as it 
appears in the list. These fields can be used to populate other fields of the business 
component in which the pick map is defined. 

If you need to use the High or Low fields, or other extra fields, use Siebel Tools to 
extend the PickList Generic BusComp by adding fields mapped to the corresponding 
columns on the S_LST_OF_VAL table. For example, you could use the High and Low 
fields to automatically fill in the high and low temperatures when a user picks a 
Month value in a Date drop-down list. To do so, you would add two pick maps to 
the Month field by adding the High and Low list of value fields to the Pick List field 
of Pick Map. For more information about the PickList Generic BusComp, and about 
configuring static pick lists and pick maps, see Siebel Tools Reference, MidMarket 
Edition.

NOTE: The Target High and Target Low fields are used exclusively with Smart 
Reports. For more information, see Siebel Reports Administration Guide, MidMarket 
Edition.

Table 9. List of Values Fields

Field Description

Type The type of list of values (the field name). 

Display Value Value as displayed in the drop-down list.

Translate When checked, indicates that internationalization is needed. 
(There is no client or server functionality associated with this 
field; for more information, see Siebel Tools Reference.)
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Multilingual When checked, indicates that the list of values is part of a 
multilingual list of values (MLOV). (There is no client or server 
functionality associated with this field; for more information, see 
Siebel Tools Reference.)

Language Independent 
Code (LIC)

Along with the Display Value, the Language Independent Code 
uniquely identifies a value for a particular LOV type. In most 
cases the Language Independent Code is the same as the Display 
Value. However, the Language Independent Code and Display 
Value are different for multilingual lists of values (MLOVs). 
MLOVs allow a single logical list item to support multiple display 
values for users who are accessing the Siebel application in 
different languages. 

For example if the MR_MS (Personal Title) list of values were 
multilingual, there might be three list of values items with a 
Language Independent Code of Mr. These might have a display 
value and language of Mr. (English-American), Senor (Spanish - 
Modern), and Herr (German), respectively. German users would 
see Herr in the Personal Title drop-down list, Spanish users 
would see Senor and English users would see Mr. Although the 
display values vary across language instances, the value stored 
in the database when a user selects any one of these will always 
be Mr. since that is the Language Independent Code associated 
with Herr, Senor, and Mr. 

For more information on configuring multilingual lists of values, 
see Siebel Tools Reference, MidMarket Edition. 

Values entered in the Language Independent Code field are 
sometimes referred to as LIVs (language independent values.)

Parent LIC (Language 
Independent Code)

The Language Independent Code of a parent list of values. Used 
in hierarchical lists of values, where the values that will display 
in a drop-down list are constrained by the value selected in the 
parent drop-down list of values. For more information, see 
“Constrained Lists of Values” on page 101.

There are only parents and children in this hierarchy. 
Grandchildren are not allowed. This is enforced by limiting the 
values in the Pick Parent dialog box to those values which do not 
themselves have parent display values.

Replication Level Specifies whether the translation is intended for use at all levels 
in the translation hierarchy or only at the regional level.

Table 9. List of Values Fields

Field Description
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High Extra field available for use by pick maps or for customization.

Low Extra field available for use by pick maps or for customization.

Order The numerical order in which a value is displayed within a drop-
down list.

Active When checked, indicates that the value is displayed to the end 
user. When unchecked, indicates that the value is not displayed 
to the end user.

Language Name Language used for the list of values Display Value field. 

Target Low Extra field used in Smart Reports. For more information, see 
Siebel Reports Administration Guide, MidMarket Edition.

Target High Extra field used in Smart Reports. For more information, see 
Siebel Reports Administration Guide, MidMarket Edition.

Weighting Factor Extra field available for use by pick maps or for customization.

Bitmap Bitmap file that is displayed.

Description Description of a specific value. 

Table 9. List of Values Fields

Field Description
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Modifying a List of Values

CAUTION: Use caution when modifying lists of values that are part of the seed data. 
Modifying some list of values fields that are used programmatically by the Siebel 
application can adversely impact standard Siebel functionality. However, you can 
modify the Display Value field without affecting standard Siebel functionality both 
when the list is a multilingual list of values (MLOV) and when it is a standard list 
of values. 

Modifying some lists of values can adversely impact standard Siebel functionality:

■ Do not change the Language Independent Code values for lists of values because 
the internal Siebel application uses the Language Independent Code field. 

■ Some lists of values are for use only by the internal Siebel application and should 
not be modified. For example, the List of Values SOURCE_TYPE (Internal) and 
list-of-values types that include REPOSITORY in the Type field name are for 
internal use only.

■ Some list of values modifications can have undesired results. For example, 
changing all lists of values in the application to uppercase or changing the 
Language Independent Code from the Siebel standard can result in values not 
being displayed or being displayed improperly.

NOTE: Modifying a Display Value field does not automatically update records that 
have been populated with the old value. For example, if you change Ms. to Miz in 
the Display Value field, Miz will show up in the drop-down list, but all contact 
records that were previously entered with Ms. in the Personal Title field will still 
have Ms. in the Personal Title field.

For more information about multilingual lists of values (MLOVs), see Siebel Tools 
Reference, MidMarket Edition.
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In order to modify a value in a drop-down list, you must know its display value and 
type. You can find out the type by querying the List of Values list for a specific 
display value. For example, if you needed to make a change to the value 1-ASAP in 
the Priority drop-down list in the Activities screen, you could do so using the 
following steps.

To modify an item in a list of values

1 From the application-level menu, choose View > Site Map > Application 
Administration > List of Values. 

2 Click the menu button, and then choose New Query.

3 Enter the Display Value for the record you want to change in the Display Value 
field. 

For example, you might enter the value 1-ASAP.

4 Click the menu button, and then choose Run Query.

A list of records appears that includes the display value that you entered. More 
than one record may appear, and the records may have different types. 

5 In the list of records, select the record that you want to modify, and make the 
desired change.

6 To see the list of values modification in the application, clear the cache. For 
instructions about how to clear the cache, see “To clear the cache” on page 94. 
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Inactivating a Value in a List of Values
You can inactivate individual values in a list, but you cannot delete values. Inactive 
values are values that the application does not display to end users in a drop-down 
list, whereas active values are displayed to end users.

CAUTION: Inactivating some lists of values can adversely impact standard Siebel 
functionality.

Do not inactivate list-of-values types or values used internally by the Siebel 
application. For example, do not inactivate list-of-values types that include 
“Repository” in the Type field name.

Be careful when inactivating a list of values, because the application may depend 
on the list of values being present. 

Be careful when inactivating individual values as well. For example, if you 
inactivate the value Commercial in the Account_Type list of values, but you have 
existing or old account data that stored Account Type = Commercial, you may 
introduce inconsistencies in your data. If you want to inactivate a display value, you 
need to clean up the account records in the database first.

To inactivate a value in a list of values

1 From the application-level menu, choose View > Site Map > Application 
Administration > List of Values. 

2 If necessary, perform a query to locate the record you want to make inactive.

3 Select the list of values record you want to make inactive.

4 In the Active field, click the check mark. When a square containing an x appears, 
click the x. 

The x disappears and the Active field no longer contains a check mark.

5 To see that the value has been inactivated, click the menu button and then click 
Clear LOV Cache. 
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Constrained Lists of Values
Some drop-down lists are set up to display a subset of values based on a value set 
in another drop-down list. For example, if you have two fields for Service Request, 
Area and Subarea, the values shown in the Area drop-down list might include 
Network and Upgrade. If the user chooses Network, that user might see a drop-down 
list for Subarea that includes Ethernet Card and 3rd Party Software. If on the other 
hand the user chooses Upgrade for the Area, that user might see CD-ROM, Disk 
Drive, Memory, and Operating System in the Subarea. Setting up this type of filtering 
is referred to as setting up a constrained pick list. In such a case, the lists of values 
have been configured to be dependent on one another. In this example, the Area 
drop-down list is considered to be the parent and the Subarea drop-down list is the 
child.

Figure 1 shows the values available in the Area drop-down list, and the values 
available in the Subarea list when Network and Upgrade have been selected, 
respectively.

Constrained pick lists (or lists of values) must first be set up through Siebel Tools. 
After they are configured through Siebel Tools, specific values in lists can be made 
hierarchically dependent through the List of Values screen. This is accomplished by 
using the Parent LIC attribute in the list of values record to specify which values will 
show up when a value is selected in the parent drop-down list.

Figure 1. Contents of Drop-Down List Constrained by Parent Drop-Down List
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For example, the LOV Type SR_AREA is used by both the Area and Subarea drop-
down lists in a Service Request. The values that show up in the Area drop-down list 
are constrained to those that have a Parent LIC value of External. Figure 2 shows 
how the records for these values appear in the List of Values list, including the 
Parent LIC value of External.

o

Figure 2. LOV Records with the Same Parent LIC 
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The values that show up in the Subarea drop-down list are constrained to those that 
have a Parent LIC value that matches the user’s selection for the Area. For example, 
if the user selects Network in the Area drop-down, only those values that have the 
Parent LIC set to Network show up in the Subarea drop-down list, while if the user 
selects Upgrade in the Area drop-down, only those values that have the Parent LIC 
set to Upgrade will show in the Subarea drop-down list. Figure 3 shows the records 
for the values that are available for both the Network and Upgrade parent values. 

Figure 3. LOV Records Constrained by the Values Upgrade and Network
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If you needed to change the parent Area to which a Subarea list item belongs, you 
would modify the Parent LIC code of the Subarea list item. Similarly, to add a new 
Subarea list item, you would add a new record, setting the list-of-values type to 
SR_AREA and the Display Value, Language Independent Code, and Language as 
described in “Adding a New Value to an Existing List of Values” on page 91. Then 
you would set the Parent LIC code to the appropriate parent area. By contrast, to 
add a new item to the Area drop-down list, you would follow the same steps, but 
specify that the Parent LIC code have the value External.

NOTE: The usage of the value External to identify items in the parent drop-down list 
is specific to this example. To determine what this value would be for any given pair 
of constrained pick lists, reference the underlying configuration in the Tools 
Repository.

For information about constraining both static pick lists (maintained through lists 
of values) and dynamic pick lists, see Siebel Tools Reference, MidMarket Edition. 

NOTE: In the example above using the Area and Subarea drop-down lists, both parent 
and child lists of values have the same list-of-values type. While this is not required, 
it has the advantage of avoiding EIM unique key violation errors. These errors can 
occur when constraining pick lists using Siebel Tools, when the parent and child 
lists of values contain different list-of-values types. If you plan to use Siebel EIM to 
exchange list of values data, you should consider constraining pick lists by 
configuring them so that the parent and child lists of values have the same list-of-
values type. 
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Audit Trail creates a history of the changes that have been made to service requests, 
campaigns, orders opportunities, and product defects. An audit trail is a record 
showing who has accessed an item, which operation was performed, when it was 
performed, and how the value was changed. Therefore, it is useful for maintaining 
security, examining the history of a particular record, and documenting 
modifications for future analysis and record keeping. Audit Trail logs information 
without requiring any interaction with, or input from, your users.

For example, by using Audit Trail, you can track which employee modified a certain 
field and what data has been changed. A call center user can track the status change 
of a service request or calculate the time it takes to solve it.

Audit Trail works for every Siebel Web deployment and configuration option, 
including synchronization. For Siebel Remote users making changes to records, 
Audit Trail records successfully committed transactions and also transactions that 
did not get synchronized to the server because of conflicts.

In Siebel MidMarket Edition, the Siebel Web Client supports the database auditing 
mode for Audit Trail. In this mode, the audit trail is written directly into the 
database, supporting both remote users and replicated databases. Changes to an 
audit trail field are cached in the application. Exiting from the Siebel application and 
restarting it writes all cached changes to the database. Alternatively, when the 
cache size is reached, all cached entries are automatically written to the database 
even without exiting from the application.
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The following features of Audit Trail are described:

■ Audit Trail Content

■ Audit Trail for Siebel Remote Users

■ Audit Trail Engine Business Service on page 107

Audit Trail Content
Audit Trail records the following information:

■ Field

■ Row ID of the record being changed

■ Operation being performed (Update/New/Delete/Copy)

■ Original value

■ Changed value

■ User ID performing the operation

■ Date and time the operation was performed

Audit Trail for Siebel Remote Users
The following information applies to remote users:

■ Disconnected users can use Audit Trail as well as connected users. Audit Trail 
will stamp transactions with local machine time.

■ Remote users should not use file auditing mode, only database auditing mode. 
Siebel MidMarket Edition supports database auditing only.

■ Audit trails are synchronized along with other data.

■ If the transaction is rejected during the conflict resolution, the corresponding 
audit trail record is not discarded.
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Audit Trail Engine Business Service
The Audit Trail Engine business service is located in the Object Manager and stays 
active as long as the Object Manager is active. The purpose of the Audit Trail Engine 
business service is to capture changes (updates and deletes) to records and to store 
them in the designated format (database or Siebel file system, according to the audit 
trail mode selected). For the various data operations, if the auditing condition is 
met, the business component being audited triggers the Audit Trail Engine business 
service. 

The methods listed in Table 10 are associated with the Audit Trail Engine business 
service. The Start, Stop, and ImportAll methods are accessible to an administrator 
and allow the performance of certain tasks.

The easiest way to use these methods is through a workflow process. If you want 
to stop or restart the Audit Trail Engine, create a new workflow process or reuse an 
existing one, and then create a business service node that implements the Stop 
method or the Start method. For more information about workflow processes, see 
Siebel Business Process Designer Administration Guide.

Table 10. Exposed Methods in the Audit Trail Engine Business Service 

Method Mode
Internal 
Use Only Description

Start Both Starts the Audit Trail Engine.

Stop Both Stops the Audit Trail Engine.

ImportAll File only Imports all the associated Audit Trail Item business component 
records.

AddTrailEntry Both X For the person specified, adds an audit trail entry to the pertinent 
data structure (unsaved audit list).

CommitTrail Both X Removes the uncommitted elements from the unsaved list and 
puts them on the saved list, and writes to the database or file if 
the cache size has been reached.

CrashRecover File only X Saves file from local system to the Siebel file system.

Kill Unsaved Trail Both X Kills the unsaved audit trail; this happens on an UndoRecord.
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Configuring Audit Trail in Siebel Tools
In the preconfigured Siebel application, the Audit Trail functionality is disabled. By 
enabling the Audit Trail business service within Siebel Tools, Audit Trail is enabled 
for all application objects. However, you can turn off Audit Trail for individual 
applications by inactivating the Audit Trail application event service for that 
application’s object. For custom application objects, you must add an Audit Trail 
application event service to the application object in order to use Audit Trail. 

NOTE: Audit Trail does not create history records for predefault values; predefault 
values are assumed to be part of the initial record.

To enable the Audit Trail Engine business service

1 Launch Siebel Tools.

2 In the Object Explorer, select the Business Service object, and then select the 
Business Service User Prop object.

3 Select Audit Trail Engine in the Business Services object list.
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4 Configure the Business Service User Properties to use the following values:

NOTE: Audit Trail data is cached by the business service and only written out 
when the number of Audit Trail changes exceeds the specified cache size. You 
can also flush cached entries by logging out of the current session and then 
logging back in to check the Audit Trail data.

To disable Audit Trail for an application

1 Launch Siebel Tools.

2 In the Object Explorer, double-click the Application object to expand it and select 
Application Event Services.

Name Field Value Field Description

Audit Source TABLE Can be TABLE or FILE. Signifies the database or 
file auditing mode in which you are going to 
run Audit Trail. Siebel MidMarket supports 
TABLE (database auditing mode) only.

Cache Entries Size 1 The number of records to cache before writing 
the audit trail records for the selected mode. For 
example, if this field is set to 10 and Audit 
Source is running in FILE mode, then after the 
user makes 10 audited changes for a particular 
business component, the Audit Trail engine 
creates one file in the Siebel file system. When 
running in TABLE mode, you should use the 
default value of 1 because there is no 
performance gain from increasing this value.

Enable TRUE Can be TRUE or FALSE. Determines the current 
state of the Audit Trail.
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3 In the Application Event Services list, inactivate the Audit Trail Engine business 
service record. (Look for a record with the following values.)

Use the following procedure to enable a customized application object for auditing, 
or to re-enable an application object that has been turned off.

To configure an application for Audit Trail

1 Launch Siebel Tools.

2 In the Object Explorer, double-click the Application object to expand it and select 
Application Event Services.

3 In the Application Event Services list, add the following record if it does not 
already exist.

Name Field Value Field

Business Service Audit Trail Engine

Event Name Start

Method Name Start

Name Field Value Field

Business Service Audit Trail Engine

Event Name Start

Method Name Start

Name Start

Sequence 1 or the next available sequence number
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This chapter explains the procedures necessary to administer message broadcasting 
and alerts for Siebel applications.

As an administrator, you can use message broadcasting and alerts to make sure that 
specific users get the necessary and time-critical information they need, displayed 
in a format that does not interfere with their work in progress.

About Message Broadcasting
Message broadcasting provides a platform for administrators and other users with 
access to the Message Broadcasts view to send important information directly to 
users’ screens. Typically, this information is time-critical, such as a due date, or it 
is updated frequently, such as a call queue’s status.

For example, to help agents manage their workflow and respond appropriately to 
calls, call centers may try to keep agents up-to-date on key statistics about call 
queues, such as the number of calls waiting, the average time in queue, and other 
important data. Traditionally, these statistics are displayed on a scrolling LED 
“ticker” on the wall. This approach presents several problems:

■ Agents have to look away from their screens to view the information.

■ Agents can miss important information, if they do not look at the right time.

■ Agents often get information that is not relevant to them.

Message Broadcasting addresses these problems by allowing administrators to send 
relevant messages to individuals, groups, or an entire team. The messages can be 
displayed by one of the following two methods:

■ Scroll messages in the message bar across the bottom of a user’s screen, visible 
at all times.

■ Display messages in a dialog box in the middle of the screen, in addition to 
scrolling across the bottom of the screen.
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Message Broadcasts can be created through the administration view, automatically 
from Siebel Business Process Designer, or remotely from a third-party application 
through Siebel EAI.

Message Broadcast messages are retrieved from the Message table through the 
Siebel application server and sent to the message bars of the targeted Siebel Web 
client sessions. There is no set order for the messages to appear on the message bar, 
that is, the order cannot be controlled by the administrator or the end user.

Users can disable their scrolling message bar, but the administrator can override this 
setting for broadcast messages.

About Alerts
Alerts provide a platform for administrators and other users with access to the Alert 
Administration view to send long, complex, and customized messages directly to 
selected groups of recipients. Typically, these messages are time-critical, but also 
need to have associations with data in the company database (for instance, 
literature or products) and to be customized for the recipient.

For example, to communicate product pricing changes to a sales team with 
members around the world, a sales manager would want to be able to distribute 
new pricing structures and product information as soon as they are approved. 
Traditionally, this would be done with email messages, phone calls, or mailed 
literature. This approach presents some problems:

■ To provide the necessary details, a large quantity of information may need to be 
distributed, with file attachments or links provided by the manager.

■ Different team members may require different price list or product information, 
depending on their organization, division, or position.

■ Distributing information to remote team members may produce a 
communication lag time.

As an administrator, you can use alerts to make sure that the specific users get the 
appropriate information that they need.

Features of alerts include the following:
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■ The abstract of alert messages are displayed in an applet on the recipients’ home 
page, listed in order of the priority specified by the sender. Recipients can click 
on the abstract to read the entire message.

■ Literature items and products can be associated with alerts.

■ Access to price list and product information available to different team members 
may be controlled by organization, division, or position.
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Business Scenario for Using Alerts
This scenario provides an example of a process flow performed by an administrator 
and sales manager. Your company may follow a different process flow according to 
its business requirements.

A multinational software development corporation uses the Siebel Sales application 
to automate their sales workforce. The company is organized geographically by 
division for the purpose of access control, and alerts are enabled.

An international sales manager has just been given the go-ahead for a new set of 
software product bundles, which include one new product. He needs to 
communicate these price changes to his company’s sales force as soon as possible. 
Because pricing varies by geography, each of the four major geographical regions 
represented by his company’s four sales divisions need to receive a customized 
message about the new product bundles. He tells the Siebel administrator the 
details of the alert message that needs to be sent.

The Siebel administrator creates the alert message, and associates a price list and 
the new product with the message. She creates keywords that users will be able to 
search on to find the message at a later date, if necessary.

When the Siebel administrator sends the alert, a customized message is sent to all 
members of the international sales force, with the appropriate price list for their 
division associated. Each member sees the alert message on their home page upon 
login to the Web client or downloads alerts during synchronization. These users can 
navigate through the home page or Site Map to read the text and any associated 
literature items or products.
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Example Process Flow for Message Broadcasting and 
Alerts

This is an example process flow for administering message broadcasting and alerts. 
Your company may follow a different process flow according to its business 
requirements.

1 Enable message broadcasting. For information, see “Enabling and Disabling 
Message Broadcasting” on page 116.

2 Create a Message Broadcast. For information, see “Creating a Message 
Broadcast” on page 119.

3 Optionally, create script to automatically update broadcast message text. For 
information, see “Creating Broadcast Messages with Multiple Severity Levels” 
on page 121.

4 Create an alert. For information, see “Creating Alerts” on page 126.
Version 7.5, Rev. A Applications Administration Guide MidMarket Edition 115



Message Broadcasting and Alerts

Enabling and Disabling Message Broadcasting
Enabling and Disabling Message Broadcasting
By default, message broadcasting is enabled. As an administrator, you can enable 
or disable message broadcasting at the server level using the following modes:

■ Always enabled

■ Always disabled

■ User enabled (default) 

To enable or disable message broadcasting at the server level

1 From the application-level menu, choose View > Site Map > Server 
Administration > Components.

2 In the Components list, choose the object manager for the application, for 
example, Field Service Object Manager (ENU).

3 Click the Component Parameters view tab.
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4 In the Component Parameters list, select the Application Message Bar Flag 
record and edit the Current Value field, referring to the following table: 

NOTE: If you set the Application Message Bar Flag parameter to true, you can 
specify the update interval for the message bar by selecting the Application 
Message Bar Update parameter and editing the Current Value. The default value 
is 120 seconds.

If you set the Application Message Bar Flag parameter to User Enable, the update 
interval is a user preference. For more information, see Fundamentals, 
MidMarket Edition.

Parameter Value Description

TRUE Message broadcasting is always enabled. Users cannot disable 
message broadcasting by setting their personal preferences. For a 
Web client deployment, the Siebel application will push messages to 
users. For mobile client users, messages will be synchronized.

FALSE Message broadcasting is always disabled. The message bar and 
message broadcast alerts will not appear on users’ screens. For a 
Web client deployment, the Siebel application server will not push 
messages to users. For a mobile client users, messages will not be 
synchronized.

User Enable 1

1. Or any value other than true or false. 

This is the default setting. Message broadcasting is enabled; 
however, users can set their user preferences to enable or disable 
message broadcasting. When a Web client user disables message 
broadcasting, the Siebel application server will not push messages to 
the user. When a mobile client user disables message broadcasting, 
messages will not be synchronized.

For information on how users can change user preferences, see 
Fundamentals, MidMarket Edition.

To send message broadcast alerts to users who have disabled the 
message bar, see “Enabling Broadcast Alerts with User-Disabled 
Message Bars” on page 118.
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To enable or disable message broadcasting on mobile and dedicated Web clients

1 Use a text editor to open the .cfg file for your Siebel application.

2 Find the ShowMessageBar parameter in the .cfg file.

For example:

ShowMessageBar="TRUE"

3 Set the parameter value to TRUE, FALSE, or User Enabled. 

See Step 4 on page 117 of the preceding procedure for more information. 

NOTE: If you set the ShowMessageBar parameter to true, specify the update 
interval for the message bar by adding the following line to the .cfg file:

MessageBarUpdateInterval = seconds
where seconds is the interval in seconds between message bar updates 
(refreshes). The default value is 120 seconds.

4 Save and close the .cfg file.

Enabling Broadcast Alerts with User-Disabled Message Bars
When message broadcasting is set to User Enabled, users can set their preferences 
to activate or deactivate the message bar on their screen. As an administrator, you 
can specify that message broadcast alerts appear to users in an alert box in the 
middle of their screen, even when they have chosen to deactivate their message bar. 
To do so, perform the following steps.

NOTE: To make sure your changes take effect for mobile users, follow these steps 
before extracting mobile user databases. For more information, see Siebel Remote 
Administration Guide, MidMarket Edition.

To show message broadcast alerts to users who deactivate their message bar

1 From the application-level menu, choose View > Site Map > Application 
Administration > System Preferences.

2 Change the Always Show Message Bar Alerts preference to TRUE.
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When you create a message broadcast, all connected users that you specify will 
receive the message immediately upon the date and time you have specified that 
the message be activated. Mobile users, such as field representatives, will receive 
the activated messages when they synchronize.

NOTE: To send a message broadcast, you must have responsibilities that include 
access to the Message Broadcasts view.

To create a message broadcast

1 From the application-level menu, choose View > Site Map > Communications 
Administration > Message Broadcasts. 

2 In the Message Broadcasts list, add a new record and complete the necessary 
fields. 

Some fields are described in the following table. 

Field Comments

Abstract A brief description of the message. 

Activation Date/
Time

Date and time at which you want to start broadcasting the 
message. If the Activation field is left blank, the message is 
broadcast immediately. 

Note: The date and time are taken from the Siebel server (not from 
the machine where the client browser is running). Make sure that 
the date and time are set correctly on the Siebel server.

All Check this option to broadcast the message to all users.

Broadcast Required to send the message broadcast to recipient’s message bar. 
Check this option to broadcast and display the message. If not 
checked, the message is not broadcast in the message bar at the 
bottom of the screen.

Division The broadcast message is sent to all users associated with the 
divisions selected in the Divisions dialog box.

This field can be used in combination with the Recipient field.
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Expiration Date/
Time

Date and time at which you want to stop broadcasting the message. 
If the Expiration field is left blank, the message will not expire and 
the message will continue to be broadcast.

Note: The date and time are taken from the Siebel server (not from 
the machine where the client browser is running). Make sure that 
the date and time are set correctly on the Siebel server.

Message Required to create the message broadcast record. The text you 
want to send as the message broadcast.This field accepts up to 
2,000 characters.

To use severity levels within the message text, see “Creating 
Broadcast Messages with Multiple Severity Levels” on page 121.

Recipient The broadcast message is sent to all users specified in the 
Recipients dialog box.

This field can be used in combination with the Division field.

For an employee name to show up in the Recipient dialog box, the 
employee must have a position defined and be marked active for 
that position. If multiple employees occupy the same position, the 
message will be sent to all of them, even though you only see the 
active employee on the list.

Employees with multiple positions see messages sent to any of 
their positions, regardless of what position they log in as. 

Severity Required to create the message broadcast record. Choose the 
severity level to indicate the importance and appearance of the 
message. 

To force the message broadcast to appear in an alert box in the 
middle of the screen, in addition to its appearance on the message 
bar, select Urgent with Alert.

Field Comments
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Creating Broadcast Messages with Multiple Severity 
Levels

Typically, the appearance of a message broadcast is designated by a single severity 
level, as specified in the Severity field. Each severity level is associated with a 
different color. The severity level that you choose determines the color of the 
message broadcast and how it is delivered.

In addition to using the Severity field to determine the appearance of a message, 
you can also combine multiple severity levels to create a message broadcast with 
unique formatting. By adding special tags to the text of a message broadcast, you 
can change the color of different sections of the message. The following tags are 
used to combine severity levels in a message:

■ [N] for Normal 

■ [H] for High

■ [U] for Urgent

For example, if your message has a severity of normal, but you want specific text to 
be highlighted, you can tag parts of the text with the code for High or Urgent. Here 
is an example:

The trunk line from [H]Chicago, Illinois [N]is [U]DOWN! 

The beginning of the message will appear in the color for the severity of the 
message, Normal; the words Chicago, Illinois will appear in the color for High; and 
the word DOWN! will appear in the color for Urgent. 

To send a message broadcast with multiple severity levels

1 From the application-level menu, choose View > Site Map > Communications 
Administration > Message Broadcasts.

2 In the Message Broadcast list, add a new record. 

3 Complete the required fields to broadcast your message.

For descriptions of the fields, see the table in Step 2 on page 121.

4 In the Message field, enter the message broadcast text you want to send.
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5 In the Message field, insert severity level tags as necessary to set the appearance 
of the message broadcast text.

For example: [H] All employees [N] must submit expense reports by [U] April 1, 
2002.
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Automatically Updating Message Broadcasting Text
As an administrator, you can customize message broadcasting to automatically 
update message text that changes frequently. For example, a call center’s queue 
statistics frequently change. Every few minutes, an administrator has to update the 
statistics to make sure agents have the most accurate information. This manual 
approach is very time consuming and inefficient when dealing with frequently 
changing data. 

You can use Siebel eAI to automatically update message broadcasting text. Your CTI 
middleware or ACD switch can provide the data for the Siebel application to 
distribute. 

The Broadcast Message business component manages the messages. The fields of 
this business component are listed and described in Table 11. These field names are 
necessary for developing the integration object.

Table 11. Field Names for the Broadcast Message Business Component

Field Description

Abstract Short summary for identifying the purpose of a message, such as 
“Calls In Queue”

Activation Date/
Time

When the message broadcasting should begin

All To broadcast the message to all employees with positions defined

Body The text of the message displayed in the message bar

Division Used to set recipients using division

Division Id The internal identification value for Division

Expiration Date/
Time

When the message broadcasting should end

Position Used to set recipients using position

Position Id The internal identification value for Position

Recipient Used to set recipients using employee

Recipient Id The internal identification value for Recipient
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A sample Visual Basic (VB) script follows, which demonstrates how to create and 
update a broadcast message with information, using the call center queue as an 
example. The sample Visual Basic script is generic; your CTI middleware’s API 
determines the structure of syntax like the Msg command. 

Sample Message Broadcasting Script
The script can be created through a button, an Excel macro, or another VB 
application. Because it is a script and not an application, it does not need the VB 
Set command. All the commands are standard to VB coding. 

This script is designed to update a message without an expiration date, not to create 
a new message every time. For more information on how to get or create a Siebel 
Application Object, refer to Siebel Tools Online Help, MidMarket Edition.

CAUTION: The code in this example updates single value fields. For information on 
how to update multi-value fields, refer to Siebel Tools Online Help, MidMarket 
Edition.

'Get "Broadcast Message" BusComp
Set BusObj = SiebelApplication.GetBusObject("Broadcast 

Message", errCode)
Set BusComp = BusObj.GetBusComp("Broadcast Message", errCode)

'Find "Calls Waiting" message
BusComp.SetSearchSpec "Abstract", "Calls In Queue", errCode
BusComp.ExecuteQuery 0, errCode
If BusComp.FirstRecord(errCode) <> True Then

'We need to create a new message
BusComp.NewRecord 0, errCode
BusComp.SetFieldValue "Abstract", "Calls In Queue", errCode

End If

Type Severity of the message as defined in the List of Values type 
BRDCST_MSG_TYPE

Via Broadcasting To send the message using message broadcasting

Table 11. Field Names for the Broadcast Message Business Component

Field Description
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‘Prepare message using middleware API info.
Set Msg = "[N]Calls Waiting: [U]10"

'Update the record
BusComp.SetFieldValue "Body", Msg, errCode
BusComp.SetFieldValue "All", "Y", errCode

'Write the record
BusComp.WriteRecord errCode

In addition to writing a script, you can use Siebel Business Process Designer to 
create or update a broadcast message. For more information, see Siebel Business 
Process Designer Administration Guide, MidMarket Edition.
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When you create an alert, all connected users that you specify will receive the alert 
immediately upon its activation date and time. Mobile users, such as a sales force, 
will receive an activated alert upon synchronization.

NOTE: Before creating alerts, review Release Notes for information about Alerts 
(Message Alerts). 

To create and send an alert

1 From the application-level menu, choose View > Site Map > Alert 
Administration.

2 In the Alerts list, add a new record and fill in the appropriate fields in the list 
and More Info form.

Some fields are described in the following table.

Field Comments

Priority The priority of the message determines where the message appears 
in the list of alerts on the users’ home pages. Messages with the 
highest priority will be at the top of the list.

Keyword Enter keywords that the user will be able to search on to find this 
message.

Type The type chosen from the drop-down list helps determine who will 
receive the alert, as follows:

■ Employee Home Page Alert: Displays the alert on all employees’ 
home pages.

■ Partner Alert: Displays alerts to employees of registered partner 
companies. 

■ Program Information: Displays the alert to self-registered, 
individual partners.

■ Public Information: Displays the alert to unregistered, 
anonymous users.
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3 If you want to add literature as an attachment to the message:

a Click the Literature view tab.

b In the Literature list, click Add.

Abstract Enter a brief abstract that summarizes the message. This will appear 
as a hyperlink on the appropriate users’ home pages.

Activation Enter the date when the message will first appear to users.

Expiration Enter the date when the message will no longer appear to users.

Partner Alert Indicates that the alert is intended for partner companies. Make sure 
that this field is selected so that your alert will be seen.

Employee 
Alert

Indicates that the alert is intended for employee users.

Make sure that this field is selected so that your alert will be seen.

All Users Select this box if you want the alert to appear to all users, as 
indicated by the Employee Alert or Partner Alert check boxes. 

For example, if the Employee Alert check box is checked, and the All 
Users check box is checked, all employees will receive the alert.

Message Body Type in the text of the message, including HTML formatting code if 
desired.

Alerts can be enhanced by using the following HTML formatting 
codes:

■ <b>text</b> = bold

■ <u>text</u> = underline

■ <i>text</i> = italics

■ <h4>text</h4> = font size

■ <a>href=“http:text”</a> = hyperlink to Web page or site

Message Body 
Preview

Displays message as it will look to users.

Field Comments
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c In the dialog box, select the Literature record or records you want to add, and 
click OK. 

NOTE: Only literature of type Sales Tool can be added.

4 If you want to add a product as an attachment to the message:

a Click the Product view tab.

b In the Product list, click Add.

c In the dialog box, select the product or products you want to add, and click 
OK.

5 If you want to specify the recipients of this message:

a Click the Recipients view tab.

b From the Show drop-down list, select Recipient Divisions or Recipient 
Positions, and click Add. 

c Select the record or records you want to add, and click OK.

Remember, if you selected the All Users check box in Step 2 on page 126, the 
message will automatically be sent to all recipients.
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This chapter describes the administrative setup tasks that need to be performed 
before the Messages screen and views are used.

For more information about the Messages screen and views, see Siebel Call Center 
User Guide, MidMarket Edition.

NOTE: The Messages functionality is unrelated to the message broadcasting and 
alerts discussed in Chapter 6, “Message Broadcasting and Alerts.”
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To set up workflows for the Messages screen and views

1 Make sure that the Communications Management and the Workflow 
Management component groups are enabled. 

For information, see Siebel Business Process Designer Administration Guide, 
MidMarket Edition.

2 Activate the Messages workflow policies. All Messages workflow policies are in 
the Siebel Messaging policy group. 

For information about activating workflow policies, see Siebel Business Process 
Designer Administration Guide, MidMarket Edition.

3 Activate Siebel Message send email and Siebel Message send email for activity 
owner workflow processes. 

For information about activating workflow processes, see Siebel Business Process 
Designer Administration Guide, MidMarket Edition.
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Setting Up Users with the Message User Responsibility
Users with the Message User responsibility have access to the Messages views.

To set up users with the Message User responsibility

1 Navigate to Applications Administration screen > Responsibilities view.

2 Make sure that all users who need access to the Messages views are assigned the 
Message User responsibility.

For more information about setting responsibilities for users, read about defining 
responsibilities in Security Guide for Siebel eBusiness Applications, MidMarket 
Edition.
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This chapter describes the administration tasks associated with Siebel Global 
Accounts.

Siebel Global Accounts is a module that provides sales professionals with global 
account-level visibility into the interactions that the company’s sales organization 
and partner’s sales organizations have had with the account. Users can view all 
accounts, opportunities, activities, contacts, and account team members across the 
account hierarchy on one screen, allowing sales professionals to build a deep 
understanding of target accounts.

For information about viewing Global Account information, see Siebel Sales User 
Guide, MidMarket Edition.

Global Account hierarchies are not provided out-of-the-box with your Siebel 
eBusiness Application. They must be set up by an administrator. There are two 
kinds of account hierarchies that can be set up by the administrator:

■ Default. This type of account hierarchy is based solely on the accounts’ Parent 
fields. This account hierarchy is self-maintaining in that whenever the Parent 
field of any account is updated, the default hierarchy is also updated. Once set 
up, the default hierarchy is applied to all organizations that do not already have 
an organization.

■ Custom. This type of hierarchy is created by the administrator, either by 
modifying the default hierarchy or from the beginning. Once set up, this 
hierarchy is independent of the accounts’ Parent fields, and as such must be 
updated by the administrator when changes occur.
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This scenario provides an example of a process flow performed by the accounts 
administrator. Your company may follow a different process flow according to its 
business requirements.

A large company, Corp 123, wants to view consolidated data at the global account 
level. This company has two organizations set up in its Siebel application: a sales 
organization and a financial organization. The accounts administrator sets up two 
account hierarchies, one for each organization. These hierarchies allow end users 
to view the opportunities and contact information associated with parent accounts. 

The sales organization uses the default hierarchy, which is based on the Parent 
account field. For various reasons, the financial organization requires a modified 
version of the account hierarchy. One of these reasons is that some accounts’ billing 
structures are different from the accounts’ purchasing structures. For example, in 
the case of XYZ Inc. there are four XYZ accounts who are customers of Corp 123: 
the XYZ Holding company, two regional subsidiaries, and a financial company. The 
123 sales organization wants to view the account hierarchy where all accounts 
report to the parent holding company. Because all account billing for the XYZ 
companies is funneled through XYZ Financial, Corp 123’s financial organization 
wants to view the account hierarchy where all accounts report to the XYZ Financial. 
Figure 4 shows the two hierarchies.

Figure 4. Examples of Account Hierarchies
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The default hierarchy used by the sales organization updates automatically when 
new accounts are added or Parent fields are changed. However, the accounts’ 
administrator updates the finance hierarchy on a weekly basis as new accounts are 
added and the structure of existing accounts changes.
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Example Process Flow for Global Accounts 
Administration

Figure 5 illustrates the business scenario, “Business Scenario for Global Account 
Administration” on page 134.

These tasks should be carried out in the order presented.

Figure 5. Example Process Flow for Global Account Administration
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Generating a Default Hierarchy
Follow this procedure to set up a default hierarchy. Once generated, this default 
hierarchy is automatically assigned to organizations without an account hierarchy. 

To change the account hierarchy assigned to an organization, see “Assigning a 
Custom Hierarchy to an Organization” on page 139.

To create a default hierarchy

1 From the application-level menu, choose View > Site Map > Data 
Administration > Global Accounts.

2 In the Account hierarchy list, click Generate Hierarchy.

A new account hierarchy is created.

Some fields are described in the following table.

3 In the Account Relationships list, review the hierarchy records.

TIP: If the generated hierarchy does not appear in the Account Relationships lists, 
refresh the view by navigating to a different view and then returning to the 
Global Accounts view.

Field Comments

Name A default name is generated based on your user ID and the date.

Default Select so that the account hierarchy is the default. The default 
hierarchy is assigned to all organizations without an account 
hierarchy and is updated when new Parent fields on the account 
records are added or modified.
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You can create a custom hierarchy by generating a hierarchy as described in the 
preceding section or by starting from the beginning and creating a series of new 
records in the Account Relationships list.

To create a custom hierarchy

1 From the application-level menu, choose View > Site Map > Data 
Administration > Global Accounts.

2 In the Account hierarchy list, create a new record and complete the fields. Do 
not check Default.

3 In the Accounts Relationship list: 

a Create new records for each of the top level parent accounts. Leave the Parent 
Account field blank for each of these.

b Create new records for the child accounts, entering the Parent Account for 
each.

To create a custom hierarchy based on the default hierarchy

1 Create an account hierarchy as described in “To create a default hierarchy” on 
page 137.

2 Select the account hierarchy record and make sure that the Default field is not 
selected.

3 In the Account Relationships list, edit the Parent Account field for existing 
accounts and create new relationship records as required. 

Accounts without Parent Accounts are at the top of the hierarchy and must be 
entered before their child records can be completed.
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Assigning a Custom Hierarchy to an Organization
An organization uses the default hierarchy unless a custom hierarchy has been 
assigned to it.

To assign a custom hierarchy to an organization

1 From the application-level menu, choose View > Site Map > Group 
Administration > Organizations.

2 Select the organization whose account hierarchy you want to change.

3 In the More Info form, in the Account hierarchy field, select the custom 
hierarchy that you want the organization to use when viewing global accounts.
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Maintaining a Custom Hierarchy
Custom hierarchies are static and must be maintained by the administrator. There 
are two approaches to updating an account hierarchy:

■ Edit the account relationships in the current hierarchy.

■ Restore the hierarchy to the default (parent account) hierarchy, and then edit the 
account relationships in the hierarchy.

To maintain a custom hierarchy

1 From the application-level menu, choose View > Site Map > Data 
Administration > Global Accounts.

2 Select the account hierarchy record.

3 Do one of the following:

■ In the Account Relationships list, edit the Parent Account fields for existing 
accounts and create new relationship records as required.

■ In the Account Relationships list, click Restore to return the hierarchy to the 
default, and then edit the Parent Account fields for existing accounts and 
create new relationship records as required.
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The Opportunities screen allows you to manage and track information associated 
with a potential revenue-generating event. Using the Opportunities screen, you can 
gather customer requirements, review information about the customer, assemble a 
sales team, review and update information about competitors, track activities, track 
private notes and team notes, and create quotes.
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Opportunity workflows enhance lead routing and provide sales professionals with 
greater visibility into their sales activities. These workflows are executed from the 
Opportunities screen. An opportunity record describes important information about 
the opportunity such as the account, potential revenue of the deal, the probability 
of closure, the lead status and sales stage, the sales team primary, and the expected 
close date. 

The predefined opportunity workflows allow you to use email to capture 
information related to the opportunity and distribute timely notifications to key 
members of the sales team. These workflows help improve the efficiency and 
effectiveness of the sales cycle while also providing sales representatives and sales 
managers greater visibility into sales activities. The email notification process is 
activated only if the opportunity has a possible revenue of more than $50,000. 

The seven predefined opportunity workflows are:

■ Opportunity Assigned Notification Process

■ Opportunity Inactive Notification Process

■ Opportunity Lost Notification Process

■ Opportunity Pending Notification Process

■ Opportunity Won Notification Process

■ Create rerouted Oppty Activity

■ Get Manager Email

For information about configuring, implementing, testing, and monitoring 
workflows, see Siebel Business Process Designer Administration Guide, MidMarket 
Edition.
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Follow these steps to correctly set up the opportunity workflows: 

■ Revise all Siebel workflows so that they are editable and have a status of In 
Progress. All Siebel workflows are initially inactive and cannot be edited. Make 
any necessary changes and activate the workflows.

■ Verify that the Workflow Server component and the Communication Manager 
component are enabled and running. For detailed instructions, see the system 
requirements and supported platform documentation for your Siebel 
application. 

■ Set up the communication profile. See “Setting Up the Communications Profile.”

■ Set up and activate the workflows and policies. 

■ Activate the opportunity workflow processes. See “Activating the 
Opportunity Notification Workflow Processes and Policies” on page 145.

■ Modify Opportunity workflows, as necessary. See “Modifying Opportunity 
Workflows” on page 150.

■ Set up the Create Reroute Oppty Activity. See “Rerouting an Opportunity” on 
page 149.

■ Set up the Get Manager Email. See “Setting Up the Get Manager Email” on 
page 153.

■ Load runtime events for the emails. See Siebel Business Process Designer 
Administration Guide, MidMarket Edition.

■ Generate the triggers. See Siebel Business Process Designer Administration Guide, 
MidMarket Edition.

■ Run the workflow monitoring agent. See Siebel Business Process Designer 
Administration Guide, MidMarket Edition.
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You must specify the communications profile before using the notification 
workflows.

To set up the communications profile

1 From the application level menu, choose View > Site Map > Communications 
Administration > Communications Drivers and Profiles.

2 Select the record for the Internet SMTP/POP3 Server driver.

3 Click on the Profiles tab, and create a new profile. Name the profile Opportunity 
Notification Profile.

4 In the Profile Parameter Overrides list, enter records and values for the following 
fields: 

■ From Address

■ SMTP Server

For more information about implementing and configuring communications 
integrations for your Siebel applications, including creating profiles for the Internet 
SMTP/POP3 Server driver, see Siebel Communications Server Administration Guide, 
MidMarket Edition.
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Activating the Opportunity Notification Workflow 
Processes and Policies

There are five different workflow processes that will generate automatic emails. All 
of these processes need to have the communication profile specified. See “Setting 
Up the Communications Profile” on page 144.

■ Opportunity Assigned Notification Process

■ Opportunity Inactive Notification Process

■ Opportunity Pending Notification Process

■ Opportunity Lost Notification Process

■ Opportunity Won Notification Process

The following procedure sets up this automatic notification process.

To set up the opportunity workflows

1 From the site menu, choose View > Site Map >Siebel Business Process 
Administration > Workflow Processes.

2 Query for Opportunity *Notification*.

The five processes are displayed.

3 Select each process and click Revise. Each time you click Revise, a new version 
of the process is created with a status of In Progress.

4 One by one, select each new In Progress process and click Process Properties.

5 In the Communication Profile field, enter Opportunity Notification Profile.

6 Make any other necessary modifications to the workflow processes.

7 Activate each process.

8 From the application-level menu, choose View > Site Map > Siebel Business 
Process Administration > Workflow Policies.

9 In the Policy Group list, query for Opportunity Workflow Group.
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10 Clear the Expiration field for each of the five workflow policies that result from 
the query.

Opportunity Assigned Notification Process
This workflow sends an email message to both the primary sales representative and 
the sales representative’s direct manager when a new lead is assigned to a sales 
representative. The email provides the basic information about the opportunity, 
including the opportunity ID and account, the primary revenue amount, and the 
number of days allowed before the lead is withdrawn and rerouted. The sales 
representative is directed to the Opportunities screen for further details.

Opportunity Inactive Notification Process
This workflow sends out an email notice when the sales representative has accepted 
a lead by changing the Status field to Accept, but has not taken any action on the 
lead for 30 consecutive days. An email reminder is sent to both the sales 
representative and the sales representatives direct manager. The notice reminds the 
sales representative that if no action is taken on the lead within seven days, the lead 
will be withdrawn from the queue and rerouted.

The default time lapse between when the lead is accepted (or last worked on) and 
when the email is delivered is 30 days. This default can be modified.

To change the time lapse between lead acceptance and inactive notification

1 From the application-level menu, choose View > Site Map > Business Process 
Administration > Workflow Processes.

2 Query and select the Opportunity Inactive Notification Process.

3 Click the Process Properties tab.

4 In the Duration Days column, click the Default Number field, and modify the 
number.

By default, the units are in days. To modify this, navigate to the Workflow 
Processes and click the Process Designer tab. Double-click the Wait step. In the 
Input Arguments applet, change the Sleep Unit value field.

5 In the Workflow Processes view, make sure the Opportunity Inactive 
Notification Process is selected.
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6 Activate the workflow and run the Workflow Monitor Agent. See Siebel Business 
Process Designer Administration Guide, MidMarket Edition.

NOTE: Out-of-the-box reassignment of leads is executed manually. You may want 
to create a workflow that automatically reassigns the lead to a sales manager or 
administrator after a specified amount of time.

Opportunity Pending Notification Process
This workflow sends an email notice when the sales representative has not 
responded or taken action on the opportunity for five days. This occurs when the 
sales representative has not changed the Status field from pending to accept, reject, 
or reroute. The email is sent to both the primary sales representative and the sales 
representative’s direct manager. The email reminds the sales representative to act 
on the lead or risk having the lead withdrawn from the queue. 

To modify the time lapse between lead assignment and email delivery

1 From the application-level menu, choose View > Site Map > Business Process 
Administration >Workflow Policies.

2 Query for E*N*P* (email notification of pending opportunity).

3 Verify that the policy is activated.

4 Select the policy and modify the Duration and Unit(s) fields.

5 Activate the workflow and run the Workflow Monitor Agent. See Siebel Business 
Process Designer Administration Guide, MidMarket Edition.

Opportunity Lost Notification Process
This workflow sends an email message to both the primary sales representative and 
the sales representative’s direct manager when an opportunity is closed with a loss. 
The status of the opportunity must change to lost before the email notice is 
generated. The email refers to the Opportunities screen and asks the sales 
representative to update the Reason field.
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Opportunity Won Notification Process
This workflow sends an email message to both the primary sales representative and 
the sales representative’s direct manager when an opportunity is closed with a win. 
The status of the opportunity must change to win before the email notice is 
generated. The email refers to the Opportunities screen and asks the sales 
representative to update the Reason field.
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Rerouting an Opportunity
The Create Rerouted Oppty Activity workflow is executed when a sales 
representative receives a lead and changes the Status field to Reroute. The workflow 
creates a new Activity record with Type = Reroute for the designated sales operator. 
This informs the sales operator that a specific opportunity has been requested for 
rerouting. All reassigned opportunities are listed in the Activities view as rerouted 
activities.

NOTE: If a sales manager or sales administrator is responsible for rerouting leads, you 
can modify the workflow so that the Create Rerouted Oppty Activity is assigned to 
the sales manager or administrator. You can also create a workflow that reassigns 
the lead to a sales manager or administrator.

To set up the opportunity reroute activity

1 From the Site Map, choose Siebel Business Process Administration > Workflow 
Processes.

2 Locate and select the Create Reroute Opportunity Activity workflow process.

3 Click Revise.

4 Click the Process Properties tab. 

The Status field should indicate In Progress.

5 In the Sales Operator Login field, replace the default with the login of the sales 
operator who will receive the activity. Remember that the login is case-sensitive.

6 Click the All Processes tab.

7 Click Activate.
Version 7.5, Rev. A Applications Administration Guide MidMarket Edition 149



Opportunities

Modifying Opportunity Workflows
Modifying Opportunity Workflows
An administrator can modify the opportunity workflows; the email language can be 
modified, the notification time can be changed, and lead notification restrictions 
can be set.

NOTE: The opportunity workflows are shipped as seed data. To modify a workflow, 
you should make a copy of the original workflow, and then modify the copy.

To modify the language of an opportunity workflow email

1 From the application-level menu, choose View > Site Map > Business Process 
Administration.

2 Select Workflow Processes.

3 Select or Query for the workflow you want to modify.

To view all seven opportunity workflows, type “O*N*”.

4 Click the Process Designer tab in the middle applet.

5 Double-click the Send Out Emails rectangle.

The Business Service Input Arguments view appears.

6 In the Input Arguments applet, find the input argument called Message Body 
and click on the Value field.

The email message text is displayed. 

7 Make any required text changes. The text includes field placeholders for data 
from the opportunity record. These placeholders appear as “+[Placeholder 
field]+”.

8 Activate the workflow and run the Workflow Monitor Agent. For more 
information, see Siebel Business Process Designer Administration Guide, 
MidMarket Edition.
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To restrict conditions for delivery of emails

1 From the application-level menu, choose View > Site Map > Business Process 
Administration > Workflow Policies.

2 Select or Query for the workflow you want to modify.

To view all five email notification policies, type “E*N*”.

3 Select the policy to modify.

4 In the Conditions applet, select a condition, or add a new condition.

5 Click on the Operation and Value fields and modify the condition.

For example, to send email notifications for leads that have a high lead quality, 
add the following condition:

Condition Field = Opportunity Lead Quality

Operation = “=”

Value = “1-excellent”

6 Activate the workflow and run the Workflow Monitor Agent. For more 
information, see Siebel Business Process Designer Administration Guide, 
MidMarket Edition.

To stop sending email notifications to a sales representative’s manager

1 From the application-level menu, choose View > Site Map > Business Process 
Administration.

2 Query for Get Manager Email.

3 Click Revise.

4 Click the Process Designer tab.

5 In the designer palette, click the Connector object and drag a connector between 
the Start and End boxes.

6 Delete all other arrows.
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7 Activate the workflow and run the Workflow Monitor Agent. For more 
information, see Siebel Business Process Designer Administration Guide, 
MidMarket Edition.
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Setting Up the Get Manager Email 
This process identifies the manager of the sales representative so that the manager 
can receive a copy of the five email notifications that are delivered. Because the Get 
Manager Email process is part of the five notification processes, the Get Manager 
Email process must be activated for the other processes to function correctly. 

An email is sent to the sales representative and the appropriate manager for each of 
the notification workflows. 

To enter the manager’s email ID

1 From the Site Map, choose Siebel Business Process Administration > Workflow 
Processes.

2 Query for the Get Manager Email workflow.

3 Click Revise.

4 Click Activate.
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Opportunity Audit Trail
The Opportunity Audit Trail allows users to track changes that have been made to 
the opportunity record. Any time a member of the opportunity sales team creates a 
new opportunity record, updates the opportunity, deletes data, or copies the 
opportunity, the action is tracked in the Opportunity Audit Trail view.

Initially, changes to the following fields are tracked:

■ Revenue class

■ Probability

■ Stage

■ Stage ID

■ Status

To track additional fields

1 From the Site Map, select Audit Trail Administration.

2 Query for the Opportunity Bus Comp.

3 Click on the Field tab in the bottom applet.

4 Create a new record and select the new field to track from the list of values.

To enable Audit Trail

1 By default, Audit Trail is not activated. To activate it, navigate to Siebel Tools > 
Business Services > Audit Trail Engine > User Property.

2 Set Enable to True. 
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Setting Up Lead Sources for Opportunities
(Lead) sources for opportunities are added, modified, and deleted through the Lead 
Sources view of the Data Administration screen.

The following procedure describes how to add lead sources so that they can be 
associated with opportunities.

In addition, campaigns automatically appear as lead sources of type Marketing 
Campaign. For more information about Campaigns, see Siebel Campaigns Guide, 
MidMarket Edition.

To create a lead source

1 From the application-level menu, choose View > Site Map > Data 
Administration > Lead Sources.

2 Create a new Lead Sources record and complete the necessary fields.
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This chapter contains information about activities and activity templates for activity 
plans and sales methods and stages. The chapter focuses on administrative tasks.

For information about creating activity templates for service activities, see Siebel 
Service Guide, MidMarket Edition.

For information about end-user tasks, see Siebel Call Center User Guide, MidMarket 
Edition and Siebel Sales User Guide, MidMarket Edition.
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About Activities
Siebel applications use activities to organize, track, and resolve a variety of tasks, 
from finding and pursuing opportunities to closing service requests. If a task 
requires multiple steps that one or more people may carry out, activities greatly 
simplify the job. Activities can help:

■ Define and assign the task

■ Provide information to complete the task

■ Track the progress of the task

■ Track costs and bill for the task

These are the major advantages of breaking down a task into one or more activities:

■ The ownership of the problem can remain at the management level, when 
required.

■ The employee looking at assigned activities can identify only the required 
information.

■ Reporting is simplified.

■ Activities can be assigned to more than one person.

Assignment Methods
Activities, once generated, are assigned to appropriate employees. Activity 
assignment can take place in a number of ways:

■ Manual assignment

■ Automatic assignment to the creator of the activity (by predefaulting the Owner 
field to the activity’s creator)

■ Automatic assignment using Territory Assignment Manager (see Siebel Territory 
Assignment Manager Administration Guide, MidMarket Edition).
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Business Objects Associated with Activities
Siebel activity objects may be associated with other Siebel business objects. Some 
common associations are listed in Table 12. In most cases, this association is with 
a set of activities defined by an activity plan and individual (or stand-alone) 
activities. In a few cases, an object is associated either with an activity template or 
with stand-alone activities.

Table 12. Association of Activity Object with Other Siebel Objects

Screen Name Business Object Stand-Alone Activities Activities from Templates

Accounts Account Yes Yes

Agreements Service Agreement Yes Yes

Assets Asset Management Yes No

Campaigns Campaign Yes No

Contacts Contact Yes Yes

Messages Messaging Yes No

Opportunities Opportunity Yes Yes

Orders (Order Line 
Items view)

Order Entry Yes Yes

Projects Project Yes Yes

Quality Product Defect Yes No

Service Service Request Yes Yes
Version 7.5, Rev. A Applications Administration Guide MidMarket Edition 159



Activities and Activity Plans

About Activity Templates and Activity Plans
About Activity Templates and Activity Plans
Activity templates are created by an administrator and are blueprints for sets of 
activities. Activity templates can be invoked by end users to create activity plans.

Activity plans are collections of activities that are created using the activity 
template. They are specific instances of activity templates that have been invoked 
by end users.

Each activity template is associated (through its Type value) with a certain business 
object. See Table 12 on page 159 for a list of business object and screens that use 
activity templates. 

In Activity Plans views, only activity templates that have been associated with the 
active business object can be invoked. For example, on the Opportunity screen, only 
templates for opportunity activities are visible. Selecting a template creates all the 
activities defined by that template.

When the activity plan is created from the activity template, activities are created 
based on the activity template details defined in the activity template. 

Typically, the administrator sets up the activity templates, and the end users apply 
the activity templates to create their activity plans.
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About Sales Methods
A sales method is an approach used in the sales process. The administrator sets up 
sales methods and sales stages that represent the organization’s desired sales 
process. A method may encompass every stage associated with the sales process, 
from prospecting to forecasting to closing deals. You can set up as many methods 
and sales stages as your organization needs. Sales representatives can then use the 
method most appropriate for their opportunities.

Sales methods can differ even within one organization. For instance, a sales method 
for dealing with complex multimillion dollar opportunities may include as many as 
fifteen stages, while a sales method of a low dollar opportunity may require only 
four. 

Sales methods and stages are only associated with activity templates of type 
Opportunity.
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This scenario provides an example of a process flows performed by the 
administrator and the end users in a sales situation. Your company may follow a 
different process flow according to its business requirements.

Business Scenario for Sales
A sales organization has adopted a new sales methodology in order to improve the 
effectiveness of its sales people. The business analyst has provided the 
administrator with a detailed document describing the sales method, the stages of 
the method, and the activities that each salesperson should perform at each stage 
of the deal. The outline of the document looks like this:

Our New Sales Method

> Stage 1, Prospecting, the lead discovery phase. (Status = Open)

> Stage 2, Qualification of the lead and working up the deal. 
(Status = Open)

∨  Stage 3, Closing the deal and entering the order. (Status = 
Won)

> Activity 1, Prepare the quote within 2 days

> Activity 2, Email the quote to manager for approval within 3 
days

> Activity 3, Create the contract within 1 week

> Stage 4, Lost deal. (Status = Lost)

The administrator creates a new sales method record (New Sales Method) and four 
associated sales stage records (Prospecting, Qualification, Closing, and Lost). 

Next, she creates four new activity templates, one for each stage. The activity 
template describes the activities and milestones that the sales people should 
perform at that stage. 

Because the sales people enter their own opportunities, the administrator sets up 
the activity template details so that the salesperson who enters the opportunity will 
be automatically assigned ownership of the activities. 
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By setting up lead times in the activity template details, the due dates for the 
activities will be calculated automatically from the date that the opportunity enters 
the sales stage.

Other Business Scenarios
Activities and activity templates are used in many ways throughout Siebel 
applications. For examples of other scenarios, see: 

■ Siebel Sales User Guide, MidMarket Edition

■ Siebel Call Center User Guide, MidMarket Edition

■ Siebel Service Guide, MidMarket Edition

■ Siebel Professional Services Automation Guide, MidMarket Edition

■ Siebel Order Management Guide, MidMarket Edition
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Example Process Flow for Activities Administration
Figure 6 illustrates the process flow for the business scenario (“Business Scenario 
for Sales” on page 162).

The tasks are typically, but not necessarily, carried out in the order presented.

Figure 6. Example Process Flow for Sales Business Scenario

Creating an 
Activity Template

Defining a Sales 
Methodology
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Defining a Sales Methodology
There are two parts to creating a sales methodology:

■ Creating the sales method record

■ Creating a sales stage record for each stage in the methodology

NOTE: Sales methods and stages are associated with activity templates of type 
Opportunity. If you are not intending to create a template of this type, you do not 
need to define a sales methodology.

You use the Sales Methods view of the Applications Administration screen to define 
sales methods and to create and associate sales stages with each of those methods.

To create a sales method and associated sales stages

1 From the application-level menu, choose View > Site Map > Application 
Administration > Sales Methods.

2 In the Sales Methods list, create a new record and complete the necessary fields.
Version 7.5, Rev. A Applications Administration Guide MidMarket Edition 165



Activities and Activity Plans

Defining a Sales Methodology
3 In the Sales Stages list, create a new record, and complete the necessary fields.

Some fields are described in the following table. 

Field Comments

Phase This value is used for rolling up many different stages into phases. 
Select the one that best matches the stage you are currently adding. 
For example, a stage called Prospecting would best match the lead 
discovery phase. 

The choices in this drop-down list are configured by using the 
SALES_STAGE_PHASE_TYPE type in the List of Values. For more 
information, see Chapter 4, “Working with Lists of Values.”

The default choices are:

■ A - Lead Discovery

■ B - Working the Deal

■ C - Closing

■ D - Lost Deal

Status The choices in this drop-down list are configured by using the 
SALES_STAGE_STATUS type in the List of Values. For more 
information, see Chapter 4, “Working with Lists of Values.” The 
default choices are Open, Won, and Lost.

Quota Factor The amount by which a sales representative’s quota will be multiplied 
by for that sales stage. 

As you move deals from one stage to another, some deals will fall out 
of the pipeline. In order to eventually close $1,000,000 in revenues, 
you might need $10,000,000 worth of stage 01 deals, or $5,000,000 
worth of stage 04 deals, or $1,500,000 of stage 08 deals. This means 
your quota factors in this case will be 10 for stage 01, 5 for stage 04, 
and 1.5 for stage 08.

In your Siebel application, a sales representative’s quota is the sum 
total of his or her revenue quota objectives on all of his or her active 
quota plans.

The default value is 1.

Order The sales stage’s position in the list of values in the Opportunities 
screen.
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Before the Sales Method and Sales Stage can be used, the cache may need to be 
refreshed. For more information, see “Clearing the Cache” on page 94. 

Win 
Probability

The probability or likelihood (out of 100) that, after successfully 
completing this stage, the deal will eventually be won. In theory, the 
later the stage, the higher the win probability should be, because each 
stage brings the salesperson closer to winning the deal.

Duration The number of days in a particular stage required for an average deal 
under average circumstances.

Stalled Deal 
Limit

The number of days that an opportunity can be in a particular sales 
stage. If the opportunity exceeds this limit, you can consider the deal 
to be stalled. There is no effect on the sales stage or any other aspect 
of the opportunity.

Field Comments
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Creating an Activity Template
You use the Activity Templates view of the Applications Administration screen to 
create activity templates.

NOTE: For information about creating service activity templates using the Service 
Details view, see Siebel Service Guide, MidMarket Edition.

To create an activity template without grandchild records

1 From the application-level menu, choose View > Site Map > Application 
Administration > Activity Templates.

2 In the Activity Templates list, create a new record and complete the necessary 
fields.

Some fields are described in the following table.

Field Comments

Sales Stage If you are creating a template of type Opportunity, select the sales 
stage with which you would like to associate the activity template. 
When the sales stage is selected, the Sales Method field is 
automatically filled in.

When this sales stage (and sales method) are specified for an 
opportunity, the activity template is used to automatically populate 
the Activity Plan and Activity lists for that opportunity. 

For information about creating sales stages and methods, see 
“Defining a Sales Methodology” on page 165.

Type Select the type that specifies where you would like the template to 
be available. For example, select Account if you want to use this 
template to create activity plans for accounts, or Milestone for TAS 
customer milestones.

The choices in this drop-down list are configured by using the 
TEMPLATE_OBJECT_TYPE type in the List of Values. For more 
information, see Chapter 4, “Working with Lists of Values.”
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3 Click the Activity Template Details view tab.

4 In the Activity Templates Details list, create a new record, and complete the 
fields.

Some fields are described in the following table.

Sales Method When the sales stage is selected, the Sales Method field is 
automatically filled in.

Public There is no logic associated with this field. You may choose to use it 
in conjunction with workflows and search specifications. 

Field Comments

Field Comments

Type The choices in this drop-down list are configured by using the 
TODO_TYPE type in the List of Values. For more information, 
see Chapter 4, “Working with Lists of Values.”

Duration The time in minutes needed to complete the activity. 

Lead The lead time for the activity.

Units Units of time to measure the lead time of the activity.

Employees User names of the people who are to perform the activity. 

See “About Activity Assignment” on page 172.

Lock Schedule This field is used for service activity templates. For more 
information, see Siebel Service Guide, MidMarket Edition.

Work Time This field is used for service activity templates. For more 
information, see Siebel Service Guide, MidMarket Edition.

Alarm Whether an alarm should go off when it is time for the activity.

Category See “About Activity Assignment” on page 172.

Lock Assignment Whether the Employees field should be locked. If it is unlocked, 
the territory Assignment Manager can reassign it.
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5 Create a new activity template detail record for each activity associated with the 
activity template.

Required This check box indicates that the activity must be completed. 
This is for information only; there is no associated code.

Display In Choose to display the activity in the Calendar screen, the 
Activity screen, or in both. This field is not displayed by default.

Field Comments
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Deleting an Activity Template

CAUTION: If you delete an activity template, all activities associated with activity 
plans that reference the template are also deleted.

To delete an activity template

1 From the application-level menu, choose View > Site Map > Application 
Administration > Activity Templates.

2 In the Activity Templates list, select and delete the activity template record.
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About Activity Assignment
Activities created using activity templates can be assigned automatically to:

■ The employee who is specified in the template 

■ The employee who creates the activity, using activity templates (this is usual in 
a sales situation)

■ No employee (this is recommended when Territory Assignment Manager will be 
used to assign the activity)

The assignment is determined by the values in the Employee and Category fields of 
the activity record in the Activity Template Details list, according to Table 13. 

NOTE: Activities created directly in the Activities screen are similarly affected by the 
Category value. If the Category value is changed to Field Engineer Activity, Repair 
Activity, Preventive Maintenance, or Other, the values of Owner and Category fields 
will be deleted and set to NULL when the record is saved.

Table 13. Employee and Category Values Determine Activity Assignment

If Employee Is... and Category Is... Then the Activity Is...

NOT NULL any value 
(NULL or NOT NULL)

assigned to the employee who is 
specified in the Employee field of 
the template.

NULL Field Engineer Activity
Repair Activity,
Preventive Maintenance, or Other

not assigned. The Employee and 
Owner fields are blank in the 
created activity.

NULL not Field Engineer Activity, Repair 
Activity, Preventative 
Maintenance, or Other

assigned to the employee who 
creates the activity (by applying 
the activity template).
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Information for Configurators of Activities
This section describes some aspects of the activities that configurators or 
administrators may want to change:

■ Configuring Owner and Employee Fields

■ Creating TAS Customer Milestone Templates in a Localized Application

Configuring Owner and Employee Fields
Depending on your business process, you may want to configure the Siebel 
application so that the Employees and Owner fields for activities are always left 
blank when the activity is created. (The Owner field displays the primary from the 
Employee field.)

To achieve this, use Siebel Tools to set the pre-default value of the Primary Owned 
By field (which maps to the Owner field that appears in the UI) in the Action 
business component to blank.

For information about using Siebel Tools, see Siebel Tools Reference, MidMarket 
Edition.

Creating TAS Customer Milestone Templates in a Localized 
Application
The sample TAS Customer Milestone activity template is available only in English. 
If you are running a localized version of the Siebel Sales application (that is, a 
version in a language other than English) and are using the Target Account Selling 
(TAS) module, you need to create an activity template of type Milestone, as outlined 
in the following procedure.

To translate a TAS Customer Milestone template for a localized application

1 From the application-level menu, choose View > Site Map > Application 
Administration > Activity Templates.
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2 In the Activity Templates list, query for records of type Milestone where 
Milestone is the translation of the English word in the localization language. 

NOTE: For the translation, see the Interface Terminology Look-up manual for your 
language, or, in the List of Values, look for the Display Value that corresponds to 
the Language-Independent Code for Milestone. For more information about List 
of Values, see Chapter 4, “Working with Lists of Values.”

Six records should be found by the query:

■ 1-Request Offering(s)

■ 2-Evaluate Offering(s)

■ 3-Approve / Select

■ 4-Legal / Purchasing

■ 5-Implement

■ 6-Measure

3 For each of the six templates:

a Click the Activity Templates Detail view tab.

b Make sure that for each detail record, the Type is Recommended Activity 
where Recommended Activity is the translation of the English phrase in the 
localized language. (See note in Step 2.)

c Optional: Translate the Description of each detail record into the localized 
language.

4 Follow the procedure for adding a milestone in the Siebel Sales User Guide, 
MidMarket Edition. Make sure that the six Activity Templates (Step 2) appear in 
the Event field drop-down list. 
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This chapter describes the resource and calendar access tasks performed by the 
administrator.

About Resources
Resources are typically things such as conference rooms and audio-visual 
equipment that are reserved and used by employees for meetings and other 
calendar activities. Resources have availability associated with them and can be 
invited as participants to calendar activities in much the same way as employees 
and contacts are invited to calendar activities. For more information about adding 
participants to activities, see Fundamentals, MidMarket Edition. The administrator 
is responsible for setting up and maintaining the list of resources.

About Calendar Access
Normally employees grant each other access to their calendars as described in 
Fundamentals, MidMarket Edition. However, there are various situations when the 
administrator may be required to add, modify, or delete calendar access for 
employees.
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These scenarios provide examples of calendar tasks performed by the administrator. 
Your company may follow a different process according to its business 
requirements.

Resource Administration
Here are two scenarios requiring resource administration:

■ Before the Siebel application is rolled out to end users, the administrator creates 
resource records. He creates resource records for all the conference rooms for the 
various floors and buildings of the company’s sites. He also creates resource 
records for the audio-visual equipment that employees may want to reserve for 
use at their meetings. 

■ After the Siebel application is rolled out, the company grows and more sites and 
conferences rooms are added. Old audio-visual equipment is discarded and new 
equipment is purchased. The administrator continues to maintain the list of 
resources, keeping it up-to-date. 

See “To administer resources for calendar activities” on page 179 for the procedure 
associated with these scenarios.

Calendar Access Administration
Here are three scenarios requiring calendar access administration:

■ Employee A is out of the office unexpectedly. Employee B needs to view 
Employee A’s calendar so that she can cancel his appointments. Employee B 
asks the administrator to give her access to Employee A’s calendar. See “To give 
Employee B access to Employee A’s calendar” on page 180.

■ An executive has been granted access to many of his colleagues calendars. When 
the executive moves to a new division, he no longer needs to access to these 
employees’ calendars. He asks the administrator to clear the list by removing his 
name from all employees’ Calendar Access List views. Alternatively, the 
executive could have contacted all the employees whose calendars are on his 
Owner drop-down list and asked each of them to remove his name from their 
calendar access lists. See “To remove all employees from an employee’s 
Calendar Owner drop-down list” on page 182.
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■ When an employee leaves the company, the administrator removes the 
employee’s name from the Owner lists of other employees. See “To remove an 
employee from all employees’ Calendar Access List views” on page 182.
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Example Process Flow for Calendar Administration
Figure 7 illustrates the process flow for the business scenario. 

Setting up of resources is completed before the end users begin to set up meetings. 
Other tasks are carried out according to the company’s business needs.

Figure 7. Example Process Flow
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To administer resources for calendar activities

1 From the application-level menu, choose View > Site Map > User 
Administration > Resources.

2 In the Resources list, create a new record or select an existing record, and 
complete the necessary fields.

Some fields are described in the following table.

TIP: If the Description and Site fields are not sufficient to identify the resource, 
other fields can be added to the Resources list applet. For example, your 
company may want to add Building Number and Floor fields to help end users 
find and identify resources. For information on adding creating and exposing 
fields, see Siebel Tools Reference, MidMarket Edition.

3 Delete resource records as required from this list.

Field Comments

Resource # An automatically generated unique number for the resource.

Site The choices in this drop-down list are configured by using the 
RESOURCE_SITE type in the List of Values.

Type The choices in this drop-down list are configured by using the 
RESOURCE_TYPE type in the List of Values.
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Adding and Modifying Calendar Access
There are two Calendar Administration applets on the Calendar Administration 
view; both can be used to modify calendar access:

■ Access Received lists all the calendars that the selected employee can access.

■ Access Granted lists all the employees who can access the selected employee’s 
calendar.

You can toggle between these applets using the Access Granted/Access Received 
drop-down list in the lower applet.

To give Employee B access to Employee A’s calendar

1 From the application-level menu, choose View > Site Map > User 
Administration > Employees.

2 In the Employees list, select the employee (Employee A).

3 Click the Calendar Administration view tab.

4 From the drop-down list on the Calendar list, select Access Granted.

5 In the Calendar list, create a new record or select an existing record and 
complete the Last Name and Update Access fields.

To view all the calendars to which an employee has access

1 From the application-level menu, choose View > Site Map > User 
Administration > Employees.

Field Comments

Last Name This is the name of the Employee B who wants to access 
Employee A’s calendar. 

Update Access If this is selected and marked Y, Employee B has read/write 
access to Employee A’s calendar.

If this is marked N, Employee B has read-only access to 
Employee A’s calendar.
180 Applications Administration Guide MidMarket Edition Version 7.5, Rev. A



Calendar

Adding and Modifying Calendar Access
2 In the Employees list, select the employee.

3 Click the Calendar Administration view tab.

4 From the drop-down list on the Calendar list, select Access Received.

The Calendar Administration list shows all calendars to which the employee has 
access.

NOTE: Records can be added, modified, and deleted from this view.
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Deleting Calendar Access
For a selected employee, the administrator can delete all employees from the Access 
Granted or the Access Received list.

To remove all employees from an employee’s Calendar Owner drop-down list

1 Navigate to the Calendar Administration view by following Step 1 to Step 4 in 
“To view all the calendars to which an employee has access” on page 180.

2 Make sure that you have selected the employee whose Calendar view Owner 
drop-down list you want to clear.

3 From the menu button in the Access Received list, select Delete All. 

This command deletes all records in the list. The employee selected in the 
Employees list no longer has access to any calendars other than his or her own. 

NOTE: Alternatively, you can use the Delete Record command to remove just one 
selected employee from the employee’s calendar owner drop-down list.

To remove an employee from all employees’ Calendar Access List views

1 Navigate to the Calendar Administration view by following Step 1 to Step 4 in 
“To give Employee B access to Employee A’s calendar” on page 180.

2 Make sure that you have selected the employee that you want to remove from 
all employees’ calendar access lists.

3 From the menu button in the Access Granted list, select Delete All.

This command deletes all records in the list. The calendar of the employee 
selected in the Employees list can not longer be accessed by any other 
employees.

NOTE: Alternatively, you can use the Delete Record command to delete the 
employee from one selected employee’s calendar access list.
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Information for Configurators of the Calendar
This section describes some aspects of the Calendar feature that configurators or 
administrators may want to change:

■ Alarm Manager Load Frequency

■ Days Displayed in Calendar Gantt Chart

■ Days for Retroactive Alarms on page 184

■ Changing Required Fields in the eCalendar Detail Applet on page 184

■ Removing the To Do List from the Calendar View on page 184

Alarm Manager Load Frequency
A system preference called Alarm Manager Load Frequency determines how 
frequently the calendar alarm queries the server for alarm-enabled appointments. 
The default value is 60 minutes, but you may want to change this time to better suit 
your business needs: querying the server less frequently results in fewer SQL calls. 
However, each SQL call will take longer to execute. In certain cases, this trade-off 
will result in improved performance. 

For information on how to edit system preferences, see “Setting System 
Preferences” on page 44.

Days Displayed in Calendar Gantt Chart
The number of days displayed in the Participant Availability Gantt chart (Calendar 
Detail view) can be changed using Siebel Tools. 

There are two user properties associated with the HI Gantt Chart Applet (see 
Table 14); these determine the days displayed.

Table 14. User Properties for HI Gantt Chart Applet

Applet User Property Description

Gantt Previous Days Number of days before current date that will be displayed

Gantt Lookahead Days Number of days after current date that will be displayed
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In the preconfigured application, the chart displays the day of the appointment plus 
the two days following the appointment day (Gantt Previous Days = 0 and Gantt 
Lookahead Days = 2).

For information about:

■ Participant Availability Gantt chart, see Fundamentals, MidMarket Edition.

■ Editing user properties, see Siebel Tools Reference, MidMarket Edition.

Days for Retroactive Alarms
Retroactive alarms are alarms for past events that did not display before the event 
because the user was not logged in. By default, the application is set to display 
retroactive alarms for missed events up to 14 days in the past. You can change the 
number of days for retroactive-alarm display by editing the RetroAlarmInterval user 
property of the Alarm Manager business service.

For more information about editing user properties, see Siebel Tools Reference, 
MidMarket Edition.

Changing Required Fields in the eCalendar Detail Applet
In the preconfigured application, the Type field is the only required field in the 
Calendar Detail form in the Calendar Detail view. If you make other fields required, 
you must predefault these fields. This is because when users create a new record or 
drill into a record from the calendar grid, an implicit save of the record is triggered. 
If any fields are required but not predefaulted, their values will be null when the 
implicit save is triggered and an error message will be generated.For more 
information about predefaulting fields, see Siebel Tools Reference, MidMarket 
Edition.

Removing the To Do List from the Calendar View
You can configure the daily, weekly, monthly calendar view (HI Activity Calendar 
View) so that the Calendar To Do list applet does not appear.

You might choose to do this if your employees do not use the To Do list or if you 
need more space for the calendar applet on the view.
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To remove the To Do list from Calendar views

1 Open the CCViewHIC.swt file in a text editor.

For more information about SWT (Siebel Web Template) files, see Siebel Tools 
Reference, MidMarket Edition.

2 Comment out the following text (the first line is already commented):

<!--Column 2 -->

<td valign="top" width="21%">

<swe:for-each count="20" iteratorName="currentId" startValue="201">

<swe:applet hintMapType="Applet" id="swe:currentId" property="Formatted…

</swe:for-each>

</td>

3 Save and close the file.
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This chapter describes the features of Siebel License Tracking.

Using Siebel License Tracking, you can:

■ Monitor and track the usage of the Siebel applications

■ View and maintain usage metrics

■ Automatically receive notification if the number of active clients exceeds the 
number of licenses 

There are two kinds of license tracked by Siebel License Tracking:

■ Named-user licenses. Employee and partner applications, such as Call Center and 
Siebel Partner Relationship Management, are usually licensed on a named-user 
basis.

■ Concurrent-usage licenses. Customer applications, such as eService and 
eCampaigns, are usually licensed on a concurrent-user basis.
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Business Scenario for License Tracking
This scenario provides an example of a process flow performed by the 
administrator. Your company may follow a different process flow according to its 
business requirements.

The system administrator for a large company is responsible for monitoring usage 
of the company’s Siebel applications. The company uses Siebel Sales internally. All 
employees in the sales department are registered users (named users) of Siebel 
Sales. In addition, the company has recently deployed Siebel eSales so that 
customers can place orders online through the Web.

The company’s licensing agreements state that there may be up to 2000 named 
users for Siebel Sales and 500 concurrent users for Siebel eSales.

When the company first upgraded to Siebel 7.5, the system administrator turned on 
Siebel License Tracking and configured the LicCustomerNotifyNU workflow so that 
he would receive email notification of any usage violations of the named-user 
license.

Some months later, the system administrator receives an email notification of a 
Siebel license exception. He navigates to the Named User Monitor view and selects 
the record for the Siebel Sales application; the Limit Exceed value is shown as Yes. 
The system administrator notices that a number of the named users are no longer 
with the sales organization. By deactivating the user IDs of these employees, the 
system administrator frees their user licenses.

When the company rolled out Siebel eSales for its customers, the system 
administrator configured the LicCustomerNotifyUH workflow. The eSales Web site 
is very popular. The system administrator monitors the daily usage of the Siebel 
eSales through the Concurrent Usage Monitor view. When he receives notification 
of usage violations, the company arranges to purchase additional concurrent-usage 
licenses.
188 Applications Administration Guide MidMarket Edition Version 7.5, Rev. A



License Tracking

Example Process Flows for License Tracking
Example Process Flows for License Tracking
Figure 8 illustrates the process flow for the business scenario, “Business Scenario 
for License Tracking” on page 188.

Figure 8. Example Process Flow for License Tracking Business Scenario
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There are two setup tasks for license tracking:

■ Configuring the Client Administration Server Components

■ Configuring the Usage Exception Workflows (Optional)

Configuring the Client Administration Server Components
License Tracking is off by default in your preconfigured Siebel application. The 
following procedures describe how to turn on License Tracking and how to 
configure License Tracking so that it is always turned on at restart.

To turn on (or turn off) Client Administration

1 From the application-level menu, choose View > Site Map > Server 
Administration > Servers.

2 Click the Server Components view tab.

3 For each server: in the Server Components list, select the Client Administration 
record and click Startup (or Shutdown).

To configure Client Administration to be on (or off) at restart

1 From the application-level menu, choose View > Site Map > Server 
Administration > Components.

2 In the Components list, select the component named Client Administration.

3 Click the Component Parameters view tab.

4 Select the Default Tasks parameter, and set the Value on Restart to 1 (on at 
restart) or to 0 (off at restart).

Configuring the Usage Exception Workflows (Optional)
Two predefined workflow processes for email notification of license violations are 
provided with, but not activated in, your preconfigured Siebel application:

■ LicCustomerNotifyNU. Configure the Email Recipient property and activate this 
workflow if you want to send email notification of named-user license violations 
to a designated email address.
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■ LicCustomerNotifyUH. Configure the Email Recipient property and activate this 
workflow if you want to send email notification of concurrent-usage license 
violations to a designated email address.

For information about activating workflows and editing process properties, see 
Siebel Business Process Designer Administration Guide, MidMarket Edition.
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The Named User Monitor view contains a usage history record for each Siebel 
application running. The usage history record shows a running total of all named 
users who have logged into the application. The total is initialized at zero and 
incremented each time a new user logs on.

The usage history record for each application has a set of user log records associated 
with it: one user log record for each user ID who has logged into the application.

License Tracking scans for login identifiers every 5 minutes. Any login IDs not 
previously encountered are added to the User Log list for the application.

When a user’s login is deactivated, the user log record is automatically deleted from 
the Named User Monitor view. For information about deactivating employees, see 
Security Guide for Siebel eBusiness Applications, MidMarket Edition.

To view named users

1 From the application-level menu, choose View > Site Map > Application 
Administration > Named User Monitor.

2 In the Usage History list, select the record for the application you want to review.

Some fields are described in the following table.

Field Comments

Limit Exceeded? Yes or No.

Application/Module The name of the Siebel application being monitored, for 
example Siebel Sales.

# of Named Licenses The number of named-user licenses purchased for the 
application.

# of Named Users Total number of named users who have logged on to date. An 
exception is flagged when this number exceeds the # of Named 
Licenses.
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3 In the User Log list, review the log records associated with the record selected 
in Step 2.

Some fields are described in the following table. 

Field Comments

Login ID User ID for login.

First Login The first day and time the client logged into the application.

Last Login The date and time of the user’s most recent login.
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The Concurrent Usage Monitor view does not indicate the names of users because 
users of customer applications do not need to be registered. Instead, the maximum 
number of concurrent users per day is monitored. 

The Concurrent Usage Monitor maintains daily usage records for each customer 
application for the past 180 days.

Tracking begins at 12 A.M. each day, and the number of users for each application 
is sampled every 5 minutes. 

To view concurrent client usage

1 From the application-level menu, choose View > Site Map > Application 
Administration > Concurrent Usage Monitor.

2 Review the records in the Usage History list, and select a record where the Limit 
Exceeded value is Yes.

Some fields are described in the following table. 

Field Comments

Limit Exceeded? Yes or No.

Peak Time The time at which the peak number of users was 
measured.

Application/Module The name of the Siebel application being monitored, 
for example Siebel eSales.

# of Concurrent Licenses The number of concurrent-user licenses purchased 
for the application.

# of Peak Concurrent Users The maximum number of concurrent users for that 
date.

Average # of Concurrent Users The arithmetic mean of the 288 samples taken during 
the 24-hour day.
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3 In the Usage Exceptions list, review the exception information associated with 
the record selected in Step 2 on page 194.

Some fields are described in the following table. 

Field Comments

Time The sample time when the number of concurrent users first exceeds 
the license limit.

Duration 
(minutes)

The exception period: the length of time (+/- 5 minutes) for which 
the number of concurrent users exceed the license limit.

# of Peak 
Concurrent 
Users

The maximum number of concurrent users measured during the 
exception period.
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Siebel Correspondence allows employees and partners to generate correspondence 
from any location with access to the Web. It also makes it easy for them to direct 
correspondence to fulfillment centers that print and mail it, so they can produce and 
send correspondence even if they are on the road and do not have access to a 
printer. 

For example, if salespeople want to do mass mailings to customers in cities where 
they are giving presentations, Siebel Correspondence allows them to log on from 
any location where they have Web access. Then they can create personalized form 
letters to invite customers in a specific city to a specific presentation, and direct 
these letters to be printed and mailed by a fulfillment center. 

First, an administrator creates templates (which are similar to form letters) that 
employees and partners can use for their everyday correspondence. Then, 
employees and partners can automatically generate correspondence based on this 
template and on information in Opportunity and Account records. 

This chapter describes how the administrator sets up Siebel Correspondence. 

For information about how the end user generates correspondence, see Siebel Sales 
User Guide, MidMarket Edition.
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System Requirements for the Web Client
To use Siebel Correspondence, you must have:

■ Siebel Document Server, including Siebel Correspondence engine, installed on a 
Windows server. The document server can be installed during installation of the 
Siebel Server. 

■ Microsoft Office installed on the server. 

■ All of the components that are required to use Siebel 7.5 software installed on 
the server, such as a Siebel Server and a Web Server. 

Siebel Correspondence uses the Document Server, a new component of the Siebel 
Server which lets users on the Web work with Word documents that are on the 
server. 

Your employees or partners who use Siebel Correspondence need:

■ A Web browser to use the product 

■ Optionally, Microsoft Word to edit documents

For information on the Web browsers that are supported, see Release Notes.

System Requirements for the Remote Web Client
Siebel Correspondence is available for the Siebel Remote Web Client as well as for 
the Siebel Web Client. The user interface for Correspondence is identical in the 
Remote Web Client and the Web Client. 

However, the Remote Web Client processes requests to generate documents locally, 
so field sales representatives can generate correspondences while traveling.    

To run Siebel Correspondence on the Remote client, you must have Microsoft Word 
installed on the same machine as the Remote Client. 
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Installing the Document Server
Siebel Correspondence uses the Siebel Document Server to generate Microsoft Word 
documents through the Web. 

To install the Document Server, perform the following steps:

■ Obtain the required hardware.

■ Install the Siebel Server.

■ Install third-party applications.

After installing the Siebel Server, you may have to follow some of the steps 
described in “Configuring the Document Server” on page 201. The Document 
Server is a component of Siebel eDocuments, which can be installed during 
installation of the Siebel Server. Consult with your system administrator to verify 
that the Document Server has been installed and configured according to the 
requirements listed in the following sections.

Hardware Requirements
The Document Server is supported on the Windows 2000 and Windows XP 
platforms. To maintain stability and performance, the Document Server must run 
on a dedicated host machine. The Siebel Server on this machine should host one 
instance of the Siebel eDocuments component group. No other components should 
be running other than required system components. 

To support more users, you can run additional instances of the Siebel eDocuments 
component group on additional dedicated host machines.

Installing the Siebel Server
Install the Siebel Server on the dedicated host machine of the Document Server. For 
more information about installing the Siebel Server, see Siebel Server Installation 
Guide for Microsoft Windows, MidMarket Edition. 

During installation, you will have the option to enable component groups. Select 
the Siebel eDocuments component group. Do not enable any other component 
groups. 
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This step can also be performed after installation is complete, as described in the 
section “Enabling the Component Group” on page 201. 

Installing Third-Party Applications
You must install Microsoft Word. 

To install Microsoft Office

1 Log on to the server machine using the same user account that the Siebel Server 
NT service uses. This user account must belong to the Administrators group. 

NOTE: The install must use the same account to be used by the NT Service. The 
installer configures COM security settings so that the installing user account will 
have the correct permissions to access and launch the application. If the install 
uses an account other than the Siebel Server NT service account, errors may 
occur when the Document Server tries to launch the application.

2 Install Microsoft Office using a Typical, or complete, installation. Verify that your 
version of Microsoft Office will install the Web Authoring Tools (HTML) 
component with the Typical installation. If it does not, you will need to use the 
Custom installation option, and install all of the typical components as well as 
the Web Authoring Tools (HTML) component. 

3 Start the applications that will be used by the Document Server. This forces the 
applications to register themselves.

4 Close the applications.
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After finishing the installation steps, perform the following steps to configure the 
Document Server:

■ Enable the component group 

■ Synchronize components

■ Enable HTML generation (optional)

■ Configure application recycle period (optional)

■ Specify the target server (optional) 

■ Enable additional logging (optional) 

Enabling the Component Group
If you have not already done so during installation, you must enable the component 
group named Siebel eDocuments. This group contains the DocServer component, 
which generates Correspondence. For more information about enabling this group, 
see Siebel Server Administration Guide, MidMarket Edition.

Synchronizing Components
This step is not specific to the Document Server, but is a required post-installation 
step for the server infrastructure. For information about synchronizing components, 
see Siebel Server Administration Guide, MidMarket Edition.

Enabling HTML Generation (Optional)
By default, correspondence is only saved in document format, not in HTML format. 
The user’s View HTML button is unavailable, and the user cannot view the 
correspondence in HTML format. 
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The server parameter DocumentServerViewHTML specifies whether the Document 
Server generates HTML versions of documents. The default value is FALSE. By 
default, the Document Server only generates documents in their native format, and 
not in HTML. To allow the user to display correspondence in HTML format, you 
must edit the parameter DocumentServerViewHTML to give it the value True 
instead of False. Any documents generated after the parameter is enabled is saved 
in both formats.

When you generate HTML documents, a copy of the generated document is created 
in HTML and stored in the Siebel File System. This may affect performance, and it 
will increase the storage space required in the File System. The clarity of the HTML 
document depends on your Office application’s ability to translate its native format 
into HTML.

Entering the following command allows generation of HTML versions of 
Correspondence. 

To enable generation of HTML versions of documents 

1 Start the Server Manager. 

2 Enter the command:

Srvrmgr> change param DocumentServerViewHTML=True for comp 
DocServer

NOTE: While this procedure uses the Server Manager, parameters can also be 
changed using the Server Administration interface. For more information, see the 
Siebel Server Administration Guide. 

Configuring Application Recycle Period (Optional)
You use the parameter MSWordLiveCount to control how often the office 
applications are restarted. 
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Each parameter can be set to a positive integer that specifies the number of 
documents to be processed before it shuts down and restarts the corresponding 
office application. A value of 0 (the default) indicates that the applications will not 
be shut down. If the parameter value is set to any integer other than 0 and the 
Document Server fails to launch, the corresponding application will be shut down 
and then restarted again.

To change the values of these parameters

1 Start the Server Manager.

2 To change the application recycling period for Microsoft Word, which is used by 
Correspondence, enter the command:

Srvrmgr> change param MSWordLiveCount=5 for comp DocServer

Specifying the Target Server (Optional)
If you are running multiple Document Servers within the same enterprise, then the 
server infrastructure will route document requests to different Document Servers in 
order to achieve load balancing. 

However, it sometimes may be useful to specify that all requests be routed to one 
Document Server. For example, you can do this to help diagnose a server problem.

To route all requests to one document server 

1 Start the Server Manager. 

2 Enter the command:

srvrmgr> change param DocumentServerName=DocSrvr1

Enabling Additional Logging (Optional)
Optionally, you may want to enable additional logging, which can be helpful for 
debugging. 
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The event logging system writes events to the log file based on the log level for each 
event type. The number you specify indicates the filtering level for logging. The 
default value is 3, which means that events with a level of 1, 2, or 3 will be logged, 
while events with a level of 4 or 5 will be suppressed. Setting the filtering level to 5 
means that all events will be logged.

NOTE: In the final command on the list, the parameter must be in quotation marks, 
because it has a space in it. In the other commands, quotation marks are optional 
and are not included in the list.

To enable additional logging

1 Start the Server Manager. 

2 Enter the following commands: 

srvrmgr> change evtloglvl GenericLog=5 for comp Docserver

srvrmgr> change evtloglvl ProposalDebug=5 for comp Docserver

srvrmgr> change evtloglvl ProposalDetail=5 for comp Docserver

srvrmgr> change evtloglvl PresentationDebug=5 for comp Docserver

srvrmgr> change evtloglvl PresentationDetail=5 for comp DocServer

srvrmgr> change evtloglvl DocServerDebug=5 for comp DocServer

srvrmgr> change evtloglvl DocServerDetail=5 for comp DocServer

srvrmgr> change evtloglvl CorrespDebug=5 for comp DocServer

srvrmgr> change evtloglvl CorrespDetail=5 for comp DocServer

srvrmgr> change evtloglvl MSProjectDebug=5 for comp DocServer

srvrmgr> change evtloglvl "MS ProjectDetail"=5 for comp DocServer

For more information about event logging, see Siebel Server Administration Guide, 
MidMarket Edition.
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About Working with Correspondence Templates
Siebel correspondence templates are created and edited in Microsoft Word (DOC file 
format). Templates contain fixed text and one or more merge field. The merge fields 
are placeholders that will be populated with variable information from your Siebel 
database, such as a Contact’s name and address, when users generate a 
correspondence for one or more recipients.

Users can create their own personal templates, and administrators can create 
templates for users. To modify or add a template, Microsoft Word must be installed 
on your computer.

The fixed text of each correspondence template is written using specific locale 
conventions and language. In order to support Global Deployment, the author of the 
template can explicitly indicate the locale and language using the Locale and 
Language fields in the template record. The Document Server then uses these 
settings to substitute correctly localized data into the mailmerge fields of the 
template. The following types of fields are affected:

■ MLOV fields

■ Global data fields

■ Locale-sensitive fields, such as dates and currencies

The data source for Word merge fields that are available to be included in Siebel 
correspondence templates is in the Siebel.html file. Administrators can augment the 
set of merge fields available using Siebel Tools. For information, see “Configuring 
Additional Merge Fields” on page 217.

Guidelines for working with correspondence templates include the following:

■ One correspondence must be generated before the Siebel.html file will appear 
for the first time. In most cases, the first generated correspondence template will 
be one of the Siebel sample templates. Once the Siebel.html file appears, you can 
use it to create custom templates. 

■ A template must contain at least one merge field in order to generate a 
correspondence.

■ Each time a user clicks Generate or Generate Label, the Siebel.html file is 
overwritten.
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■ Each time a user clicks Generate or Generate Label, the variable data in the data 
file replaces the merge fields in the Siebel.html file, based on the template format 
chosen, and a customized correspondence document is created for each 
recipient on the list.

■ Check the status of the document or label by clicking the Update button and 
reviewing the Document Status field. See Table 15.

■ It is recommended that you make the template inactive prior to modifying it. You 
make the template inactive by deselecting the Active field. This will prevent 
other users from attempting to create correspondences using this template at the 
same time you are modifying it. After you have finished your modifications, 
check the Active field again.

■ The Siebel.html file is located in the Reports subdirectory on the Siebel Server. 

NOTE: You should always perform system administration tasks, such as 
administration of correspondence templates, against the server database. Although 
you can perform these tasks against your local database and synchronize, doing so 
has the potential to cause errors, including data conflicts. In addition, performance 
problems can result from a large local database, and from routing large numbers of 
transactions.

For information about which versions of Microsoft Word are supported, see Release 
Notes and Siebel System Requirements and Supported Platforms for your Siebel 
application.

Table 15. Document Status Field

Status Meaning

In Queue Request sent to available document server.

Generating Document server is creating the Word merge document.

Completed Document is available and can be accessed from the Generated 
Document field.

Failed Document server encountered errors. Check the Document Error and 
Label Error fields for error messages.
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Using the Sample Correspondence Templates
You should change the text in the sample correspondence templates packaged with 
Siebel Correspondence to add text that is specific to your company and business. 

You may want to change both the text and the merge fields of these sample 
correspondence templates. 

Changing the Text of a Correspondence File
If you only want to modify the text of a correspondence template, you can simply 
drill down on the template link in Siebel Correspondence to open it and then edit it 
in Microsoft Word.

NOTE: Be careful not to change the merge fields when you edit the text. 

To change the text of a correspondence template file

1 From the application-level menu, choose View > Site Map > Document 
Administration > Correspondence Template.

2 In the Templates list, drill down on the Template Name hyperlink.

A dialog box appears asking whether you want to open the file or download it.

3 Select Open this file from its current location, and click OK. 

The template file appears in Microsoft Word.

4 Edit the text using Microsoft Word. 

5 Choose File and then click Save to save the changes when you are finished. 

6 In the template list, click the icon appearing in the Template Name field.

7 Click Browse.

8 Navigate to the saved template and select the file.

9 In the Add Attachment dialog box, click Add.
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Changing the Merge Fields of a Correspondence Template File
The easiest way to change the merge fields in a correspondence template file is to 
use the Mail Merge feature of Microsoft Word together with the Siebel.html file 
generated by the Document Server. The siebel.html file contains the names of the 
fields that are available for merging. After Microsoft Word reads this file, the fields 
can be selected from a drop-down menu. 

To change the merge fields of a correspondence template

1 In the Correspondence Template list applet, drill down on the Template Name 
field and select the template you want to modify. 

2 In the displayed dialog box, select Open this file from its current location and 
click OK. 

The template file appears in Microsoft Word.

3 Add merge fields to the template file. (See either “To add merge fields to the 
template in Microsoft Word 2000” or “To add merge fields to the template in 
Office XP.”)

4 In the template list, click the icon appearing in the Template Name field of the 
template you are modifying.

5 Use the Add Attachment dialog box to upload the modified template file.

To add merge fields to the template in Microsoft Word 2000

1 In Microsoft Word, choose Tools, and then Mail Merge. 

The Microsoft Word Mail Merge Helper window appears.

2 In the Mail Merge Helper window under the Main Document heading, click the 
Create button and choose Form Letters.

3 In the dialog box that appears, click the Active Window button.

4 In the Mail Merge Helper window under the Data Source heading, click the Get 
Data button and choose Open Data Source. 
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5 In the Open Data Source dialog box, locate and open the 
\Siebel\Reports\Siebel.html file.

NOTE: The Siebel.html appears only after the first correspondence template is 
generated. 

6 Click the Close button to dismiss the Mail Merge Helper window.

7 If the template file does not yet have merge fields, an information box states this. 
Click Edit Main Document in the box.

If the template file already contains merge fields, no box appears. Click the Close 
button to close the window.

8 When you are finished adding merge fields, click the Mail Merge Helper icon on 
the Mail Merge Tool bar. In the Mail Merge Helper window, click Create and 
choose Restore to Normal Word Document. Click Yes to continue.

9 Close the Mail Merge Helper window.

10 Choose File > Save As and save the file on your hard drive, with a new name.

11 Close Microsoft Word.

12 In the template list, click the icon in the Template Name field of the template 
you are modifying.

13 Use the Add Attachment dialog box to upload the modified template file.

To add merge fields to the template in Office XP

1 In Microsoft Word, choose Tools > Letter and Mailings > Show Mail Merge Tool 
bar.

2 In the tool bar, click Main Document Setup.

3 In the Main Document Type window, select Letters and click OK.

4 On the Mail Merge Tool bar, click the Open Data Source icon.

5 In the Select Data Source window, locate and open the 
\Siebel\Reports\Siebel.html file.
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6 In the Select Table window, click OK.

7 Edit the text and add merge fields. For each merge field, position the insertion 
point at the desired location in the template, click the Insert Merge Fields icon, 
and choose the merge field from the menu.

8 When you have finished adding merge fields, click the Main document setup 
icon on the Mail Merge tool bar.

9 In the Main Document Type window, select Normal Word Document and click 
OK.

10 Choose File > Save As and save the file on your hard drive with a new name.

11 Close Microsoft Word.

12 In the template list, click the icon in the Template Name field of the template 
you are modifying.

13 Use the Add Attachment dialog box to upload the modified template file.
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Creating a New Correspondence Template
To add a correspondence template, it is easiest to modify and rename an existing 
template. The following three procedures step you through this process, in which 
you:

■ Open an existing template file. 

■ Modify and rename the template in Microsoft Word. 

■ Add a template record for the new file in Siebel Correspondence.

NOTE: You may create a new correspondence template for a variety of purposes: for 
a company description, as a mailing label, and so on. 

Opening an Existing Template File 
To prepare to create a new template, you must drill down on the template link in 
Siebel Correspondence to open an existing template file. 

To open an existing template file

1 From the application-level menu, choose View > Site Map > Document 
Administration > Correspondence Templates.

2 In the Templates list, drill down on the Template Name hyperlink.

A dialog box appears asking whether you want to open the file or download it.

3 Select Open this file from its current location, and click OK. 

The template file appears in Microsoft Word.

Modifying and Renaming the Template 
Now that the file has been displayed in Microsoft Word, you use Word’s mail merge 
features to modify its merge fields and then save it under a different name. To 
modify merge fields, see “Changing the Merge Fields of a Correspondence Template 
File.”
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Adding a Correspondence Template Record for the New File
Once you have created a new correspondence template in Word, you need to add a 
record in your Siebel application so your users can access the Word file as a 
template. Users will see the template in the Template field in the My 
Correspondence Requests view.

To add a template record

1 From the application-level menu, choose View > Site Map > Document 
Administration > Correspondence Templates.

2 In the Templates list, add a new record. 

3 In the Template Name field, click the select button.

4 Click Browse.

5 Select the new file and then click Open. 

6 When the Add Attachment dialog box appears displaying the name of the 
selected file, click Add.

The file name is added in the Templates view tab, and some other fields are 
populated automatically.

7 Make sure that the Active field is checked. 

8 Optionally, complete the other fields described in the following table.

Field Comments

Active Indicates whether or not the template appears in the Template list in 
the My Correspondence Requests view.

Update File A check mark in this field indicates that users want their copy of the 
template to be updated automatically each time the original file is 
updated.

Comments A description, and information about the template.
212 Applications Administration Guide MidMarket Edition Version 7.5, Rev. A



Correspondence

Creating a New Correspondence Template
Local Indicates whether or not the template is available on the local hard 
disk. If a document is not available locally, you can request it by 
selecting the Request field. The file will be downloaded in your next 
synchronization session. This field applies to you only if you use 
Siebel Remote.

Modified The date that the template file was last modified.

Template 
Name

The name of the file. Required.

Personal A check mark in this field specifies that the template will appear in 
the Personal Template view.

Download File Allows users to request templates from the server. When a check 
mark appears in this field, the document is retrieved during the next 
synchronization session. This field applies to you only if you use 
Siebel Remote.

Size The size of the template file.

Type The file type of the template file.

Language The language used by the Document Server to render mail merge 
fields based on MLOV and Global Data Business Component fields. 
For more information on these types of fields, see Siebel Tools 
Reference, MidMarket Edition.

Locale The locale used by the Document Server to render mail merge fields 
based on locale-sensitive business component fields, such as dates 
and currencies. For more information on these types of fields, see 
Siebel Tools Reference, MidMarket Edition.

Field Comments
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Deleting a Template 
If a template is no longer valid, it you may want to delete it so that no one uses it 
by mistake. 

To delete a template

1 From the application-level menu, choose View > Site Map > Document 
Administration > Correspondence Templates.

2 In the Templates list, select the template to be deleted.

3 Click the menu button, and then click Delete Record. 

4 When the “Are you sure you want to delete the current record?” prompt appears, 
click OK.

The Templates List refreshes and appears without the deleted template.
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Inserting Files into Correspondence Templates
The Siebel Correspondence file insertion feature allows you to insert one or more 
files into a correspondence template.

You may insert file templates containing generic content into one or many 
correspondence templates. For example, you can create a company description in a 
separate file insert template and then include it into correspondence templates. If 
the description changes, you only have to modify the single insertion template 
instead of every template.

The administrator or user may add a comment indicating that the file is an insert 
template that should be used by mail merge and inserted into other documents. 

You may insert as many files into a correspondence template as necessary. Each file 
name must be unique. 

Each file must be inserted into the correspondence template independently. 
Insertion files can not be nested. For example, you may insert File1.doc, File2.doc, 
and File3.doc into a template named FollowUp.doc. But, you may not insert 
File1.doc into File2.doc, and then insert File2.doc into FollowUp.doc.

You may insert a file template into a public template created by an administrator or 
a personal template created by a user. Only Microsoft Word files are inserted into 
Microsoft Office templates. This process is described below.

To insert a file into a correspondence template

1 Create the file insert template.

a Using Microsoft Word, create the insert template.

b Under the Document Administration Screen, the Correspondence Templates 
view, add a new record and add the new insert template.

2 Open the Correspondence Template in which the new template file is to be 
included.

3 Insert a separate line with the following command at the location where the 
insert template is to be displayed:
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[[File Name]]

Here, File Name is the name of the file created in Step 1.

4 Save the Correspondence Template locally and then reload the template back 
into the Correspondence Template View.

At run time, the new insert template will merge with the Edited Correspondence 
Template.
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Configuring Additional Merge Fields
During the document generation process, the Document server exports mail merge 
data into the Siebel.html file. Microsoft Word then reads this file and inserts the data 
into the merge fields in the template. The exported data is taken from two places:

■ If the correspondence was created from a view based on service requests (such 
as the Service Request screen in Siebel Sales or the Service screen in Siebel Call 
Center), the data is taken from the Service Request Recipient business 
component.

■ If the correspondence was created by pressing the New button in the 
Correspondence list view, or from a view not based on service requests (such as 
the Opportunity screen), the data is taken from the Recipients business 
component.

New fields in the Recipients Business Component are restricted to those based on 
columns in the S_CONTACT table or those obtained through join relationships. 
Joins can be added for tables that have a master-detail relationship with 
S_CONTACT, where S_CONTACT is the detail table. You need to add the join to the 
Recipients Business Component if it does not already exist.

New fields in the Service Request Recipient Business Component are restricted to 
those based on columns in the S_CONTACT table, the S_SRV_REQ table, or columns 
available through joins to these tables.
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Table 16 summarizes the contents of the two Business components and the contexts 
in which they are used. For more information on adding fields, see Developing and 
Deploying Siebel eBusiness Applications, MidMarket Edition and Siebel Tools 
Reference, MidMarket Edition.

To configure an additional merge field

1 Open Siebel Tools.

2 Add the new field to either the Recipients Business Component or the Service 
Request Recipient Business component. The steps for this depend on the field 
type you are adding. For more information on adding fields, see Developing and 
Deploying Siebel eBusiness Applications, MidMarket Edition and Siebel Tools 
Reference, MidMarket Edition.

3 Add the name of the new field to the Business Component User Prop called 
“Export Field #”, where # is an integer. If necessary, create additional user 
properties by incrementing the integer.

4 Compile the project to create a new .srf file.

5 Stop the server.

Table 16. Summary of Merge Fields Sources and Uses

Source Business Component Source Tables Used In

Recipients ■ S_CONTACT

■ Joins with tables that have a 
master-detail relationship with 
S_CONTACT (with S_CONTACT 
as the detail table).

Correspondence created:

■ Directly in the Correspondence List 
View

■ From any view not based on service 
requests

Service Request Recipient ■ S_CONTACT

■ S_SRV_REQ

■ Joins with tables that have a 
master-detail relationship with 
one of these two (with 
S_CONTACT or S_SRV_REQ as 
the detail table).

Correspondence created from views 
based on service requests.
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6 Copy the newly compiled .srf file to the correct location where it will be used by 
the server (usually \siebel\objects\lang, where lang is the language code for the 
language setting of the server).

7 Restart the server.

8 Generate a new correspondence document to refresh the siebel.html file.

9 To insert fields into a template, see “Changing the Merge Fields of a 
Correspondence Template File.”

NOTE: You can configure up to 63 additional merge fields; WinWord does not display 
fields beyond this limit. 
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About Fulfillment Centers
When your users have completed correspondence and want to send it to the 
recipient, either they can print out and mail the letter themselves, or they can direct 
their correspondence to a fulfillment center that prints and mails it for them. A 
fulfillment center might be a division of your company, such as your marketing 
department. 

You might want to use a fulfillment center for several reasons:

■ To let your users produce correspondence in any location where they can access 
the Internet, even if they do not have a printer. 

■ To save your users time, since they do not have to print out and mail their 
correspondence.

■ To create consistency in your company’s outgoing correspondence.

■ To allow one location to fulfill all requests for collateral and literature materials 
included with correspondence as enclosures.

If you have set up fulfillment centers, the user can generate correspondence and 
then click Submit to submit the correspondence for fulfillment. When the user 
clicks Submit, the Status Field of the correspondence request is given the value 
Submitted, and the request is made read-only. You cannot make any further changes 
in it without using the Recall command.
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Setting Up Fulfillment Centers
To set up a fulfillment center, you perform the following tasks:

■ Add a fulfillment center record.

■ Give the fulfillment center access to Siebel Correspondence.

Adding, Modifying, and Deleting Fulfillment Center Records
You must create one or more fulfillment center records, so users can select a 
fulfillment center when they create a correspondence request.

To add a fulfillment center

1 From the application-level menu, choose View > Site Map > Data 
Administration > Fulfillment Centers. 

2 In the Fulfillment Centers list, click the New button. 

3 Enter the information described in the following table.

Field Description

Name Enter the name of the fulfillment center.

Main Phone # Enter the telephone of the fulfillment center.

Main Fax # Enter the fax number of the fulfillment center.

Fulfillment Team Click the select button, and use the Fulfillment Team dialog box to 
select one or more employees at the fulfillment center. If necessary, 
click New to add employees to this dialog box. After you have 
selected the employees, click Close. 

These people will be able to view correspondence submitted to 
this fulfillment center. If there is no one on a fulfillment team, no 
one will be able to see correspondence submitted to this 
fulfillment center.

Description Enter a description of the fulfillment center.
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To make other changes 

■ To modify a fulfillment center record, select a field and change the information. 

■ To delete a fulfillment center record, select the record, click the menu icon, and 
then click Delete Record. 

Giving the Fulfillment Center Access to Siebel Correspondence
The fulfillment team at the fulfillment center must monitor pending fulfillment 
requests. Everything submitted by a requestor is visible to the fulfillment team in 
the Fulfillment screen.

Fulfillment center employees fulfill the request by viewing and printing the 
correspondence request and including the enclosures listed. The fulfillment center 
employees may either print the enclosure, or get an already-printed copy (if the 
enclosure is a glossy brochure, for instance). 

If you have licensed Siebel Workflow, you can create a workflow to send email to 
the fulfillment center automatically whenever there is a new request for it to fulfill. 

To give the fulfillment center access to Siebel Correspondence

1 Set up fulfillment center employees as Siebel Correspondence users, in the same 
way that you set up your own employees or your channel partners as Siebel 
Correspondence users. For more information about setting up users of Siebel 
applications, see Security Guide for Siebel eBusiness Applications, MidMarket 
Edition. 

2 Give fulfillment center employees a responsibility that lets them see the 
Fulfillment screen. Use the responsibility in the seed data named Fulfillment 
Center Employee. For more information about responsibilities, see Chapter 2, 
“Initial Setup.”

3 Tell fulfillment center employees what URL they should use to view 
Correspondence through the Internet. 
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After they have processed a request, the fulfillment center employees click Done. 
Clicking Done updates the Status Field of the request to Done, and it creates an 
activity for each recipient indicating that correspondence has been sent.

Users monitor the status of their correspondence requests by looking at the entry in 
the Status column of the My Correspondence Requests view to see if the status is 
Done.

Similarly, a fulfillment center manager monitors the status of pending requests by 
looking at the entry in the Status column of records in the Fulfillment screen.
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About Batch Printing 
Batch printing simplifies the task of printing multiple correspondence items. The 
user first selects one or more Correspondence items, and then selects the Print 
option from the applet level menu. The documents are then printed on the 
appropriate printer. 

Siebel applications support two types of batch printing, server-based and client 
based. Initially, the print menu item appearing on the Correspondence and 
Fulfillment screens is configured to perform client-based printing. However, the 
Administrator can use Siebel Tools to reconfigure these menus to use server-based 
batch printing, either in addition to, or instead of, client-based batch printing.

Client-Based Batch Printing
When a user prints a document using client-based batch printing, the Siebel 
application launches Microsoft Word on the user’s client system. It then retrieves 
the document from the Siebel File System and prints it to the default printer 
configured for the user’s desktop session.

For this feature to work correctly, the end user must configure the browser to allow 
the Siebel application to launch Microsoft Word. This requires changing the security 
option called “Initialize and script ActiveX controls not marked safe” to either 
Enable or Prompt for the security zone containing the Siebel application URL. 
Typically, this is either the “Local intranet” zone or the ‘Trusted” zone. Users should 
verify that any other URL in this zone can be trusted with this security privilege.

Server-Based Batch Printing
When a user prints a document using server-based batch printing, a request is sent 
to the DocServer server component. This component then prints the document to 
the printer specified by the user in User Preferences. If the user has not specified a 
preference, the document is printed on the default printer configured on the 
DocServer machine by the System Administrator.
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Setting Up Batch Printing for Administrators and Users
Table 17 lists procedures for setting up batch printing for both administrators and 
users. Administrators need to set up server-based batch printing; users need to set 
up both server-based and client-based batch printing.

Table 17. Procedures for Setting Up Batch Printing

Setup Procedures for Administrators Setup Procedures for Users

Add server Print menu items on the 
Correspondence and Fulfillment screens

Verify system requirements for client-based 
batch printing

Set up the printer configuration Configure Internet Explorer to permit client-
based batch printing

Add a printer connection to the DocServer 
machine

Add a printer connection to the desktop for 
client-based batch printing

Change the default printer (if necessary) Change the default printer (if necessary)

Specify a printer for server-based batch 
printing
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Batch Printing Instructions for the Administrator
As an administrator, you need to set up the server-based batch printing function.

To add server Print menu items on the Correspondence and Fulfillment screens

1 Start Siebel Tools.

2 In the Object Explorer window, under Siebel Objects, select Applet.

3 In the Applets window on the right, enter “Correspondence List Applet” in the 
Name column and click Query.

4 In the Object Explorer, select Applet Method Menu Item.

5 In the Applet Method Menu Item window, enter “Server Printer” in the Menu 
Text column and click Query.

6 Highlight the record and uncheck the Inactive check box in the Inactive column.

7 In the Applet Method Menu Item window, enter “Server Print Label” in the 
Menu Text column and click Query.

8 Highlight the record, and deselect the Inactive check box in the Inactive column.

9 In the Application menu, click Tools and select Compile Projects. In the Project 
Selection window, pick project “Corresp (SSE)”. 

10 Browse and select the appropriate siebel.srf file, and click Compile.

11 Repeat Step 3 to Step 10 for the Fulfillment screen, querying for “Fulfillment List 
Applet” in the Applet window.

12 Verify that “Server Printer” and “Server Print Label” menu items appear in the 
applet menus of the Correspondence and Fulfillment screens.
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Configuring Printers for Server-Based Batch Printing
When a user invokes server-based batch printing on a correspondence document, 
a request is sent to the DocServer component. This request contains the values for 
the Default Printer and Printer Driver preferences the user has selected on the 
Correspondence User Preference screen. After receiving the request, DocServer uses 
Microsoft Word to convert the document into a PostScript file. The style of 
PostScript generated is determined by the value for the Printer Driver user 
preference. This parameter specifies the name of a network printer. The PostScript 
file generated by Microsoft Word is suitable for this printer and all other printers of 
the same model. After the PostScript file is generated, DocServer sends the file to 
the printer specified in the Default Printer user preference.

As an administrator, you need to complete the following tasks to support server-
based batch printing.

1 Identify the printer models within your enterprise that will be used for server-
based batch printing.

2 For each model, select one network printer and add a printer connection to it on 
the DocServer machine.

3 Designate one configured printer as the default printer for the DocServer 
machine.

4 Provide the list of configured printers to end users, who will use this list to select 
a Printer Driver in User Preferences.

For example, an organization has five Xerox Model A printers, named xrx001 to 
xrx005, and five Canon Model B printers, named cnn001 to cnn005. A printer server 
named hqsrvr is used to route requests to all of the printers. The administrator 
decides to use xrx005 to represent the Xerox Model A printers and cnn005 to 
represent the Canon Model B printers, then adds printer connections on the 
DocServer machine for each. The xrx005 printer is chosen as the default printer. 
These connections are used by the DocServer component to generate PostScript 
files. Only one printer for each model is actually configured on the DocServer 
machine. After creating the printer connections, the administrator notifies the end 
users of the network names of the configured printers (in this case: \\hqsrvr\xrx005 
and \\hqsrvr\cnn005).
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Continuing the example, a user now wants the cnn003 printer for her personal batch 
printing requests. To do this, she goes to the User Preference Screen, 
Correspondence View and enters \\hqsrvr\cnn003 in the Default Printer field and 
\\hqsrvr\cnn005 in the Printer Driver field. All subsequent batch printing requests 
she submits are sent to the cnn003 printer. 

If a user does not specify a User Preference, batch printing requests submitted by 
that user are sent to the default printer configured by the administrator on the 
DocServer machine.

To add a printer connection to the DocServer machine

1 Login to the DocServer machine using the same User ID used by the Windows 
Service running the Siebel Server.

2 Select Start > Settings > Printers.

3 Double click the Add Printer icon.

4 On the Welcome screen, click Next.

5 On the Local or Network Printer screen, select Network Printer and click Next.

6 On the Locate Your Printer screen, select Network Printer and click Next.

7 On the Default Printer screen, select either Yes or No and click Next.

8 Click Finish.

To change the default printer

1 Login to the docServer machine using the same User ID as used by the Windows 
Service running the Siebel Server.

2 Navigate to Start Menu > Settings > Printers.

3 In the printer list, right click on the desired printer and choose Set as Default.
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Batch Printing Instructions for the End User
To batch print, you select correspondence items and then select the Print option 
from the applet menu. The Print menu item is active only if all selected 
correspondence records have a value of Completed in the Document Status column. 

Initially the Print menu item on the Correspondence and Fulfillment screens is 
configured to perform client-based printing. However, your administrator can 
configure server-based printing in addition to, or instead of, client-based printing.

Using Client-Based Batch Printing
When you use client-based batch printing, the Siebel application launches 
Microsoft Word on your client system. It retrieves the document from the Siebel File 
System and prints it to the default printer configured for your desktop session. To 
use this feature, you need the following:

■ Microsoft Word must be installed on the client system.

■ Internet Explorer must be configured to launch Microsoft Word.

■ The default printer must be configured for your desktop.

To configure Internet Explorer to allow client-based batch printing

1 Start Internet Explorer and log on to the Siebel application.

2 In the Internet Explorer, select Tools > Internet Options.

3 Select the Security Tab. The security zone used by Siebel applications is 
highlighted (either Local intranet, or Trusted). Verify that any other URL in this 
zone can be trusted with extra security privileges.

4 Select Custom Level.

5 In the Security Settings dialog box, find “Initialize and script ActiveX controls 
not marked safe.” Change the setting to either Enable or Prompt.

6 Click OK.

7 To the question, “Are you sure you want to change the security for this zone?” 
click Yes.
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8 In the Internet Options dialog box, click OK.

To add a printer connection to your desktop

1 Select Start Menu > Settings > Printers.

2 Double-click the Add Printer icon.

3 Click Next on the Welcome screen.

4 On the Local or Network Printer screen, select Network Printer and click Next.

5 On the Locate Your Printer screen, select Type the Printer Name and either type 
the network name of the printer, or click Browse and select the printer.

6 Click Next.

7 On the Default Printer screen, choose either Yes, or No. Click Next.

8 On the Completing the Add Printer Wizard screen, click Finish.

To change the default printer

1 Select Start Menu > Settings > Printers.

2 The current default printer is marked with a check. To select a new default 
printer, right click on the desired printer and choose Set as Default.

To print documents using client-based printing

1 From the application-level menu, choose View > Site Map > Correspondence 
or Fulfillment.

2 Close any Word files.

3 Select one or more rows in the Correspondence List Applet. All selected rows 
must have a Document Status of Completed.

4 In the applet menu, select Print.

The selected documents are printed to the configured default printer.
230 Applications Administration Guide MidMarket Edition Version 7.5, Rev. A



Correspondence

Batch Printing Instructions for the End User
Using Server-Based Batch Printing
Server-based batch printing sends a printing request to the Siebel Document Server. 
The document is then sent to the printer specified in User Preferences. If you do not 
specify a printer, the document is printed on the default printer configured by the 
System Administrator.

To specify a printer for server-based batch printing

1 From the application-level menu, choose View > Site Map > User Preference 
> Correspondence.

2 In the Default Printer field, enter the network name of the printer used for 
Correspondence. The network name should contain both the printer server 
name and the printer name as follows:

\\printer_server_name\printer_name

3 In the Printer Driver field, enter the name of the printer driver used to generate 
an intermediate file during the printing process. The System Administrator 
should provide you with a list of printer drivers and their associated printer 
types. Select the Printer Driver associated with the printer you previously 
specified in Step 2.

4 Click Save.

To print documents using server-based printing

1 From the application-level menu, choose View > Site Map > Correspondence 
or Fulfillment.

2 Select one or more rows in the Correspondence List Applet. All selected rows 
must have a Document Status of Completed.

3 In the applet menu, select Print.

The selected documents are printed to the default printer specified in User 
Preferences.
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Siebel Literature allows you to give your users access to sales and marketing 
literature, such as product brochures, white papers, data sheets, and other types of 
literature items. Users view these documents using the application that created 
them, for example, Microsoft Word, Lotus Word Pro, or Adobe Acrobat.

Literature items may also be grouped into literature kits. Literature kits may include 
items not normally thought of as literature, such as promotional hats, coffee mugs, 
or T-Shirts. These kits may then be made available for distribution through 
fulfillment centers. Literature kits are covered later in this chapter. Fulfillment is 
covered in Chapter 13, “Correspondence.”

After you create literature records and associate documents with them, your 
employees can use literature in several ways: 

■ Employees can use the Literature or Infocenter Explorer to search through all the 
literature that is available to them. 

■ You can associate literature with business objects such as products or 
competitors. Then users can display the literature when they are looking at the 
record for the associated business object. For example, the user can navigate to 
the Product screen, select a product, and click the Product Literature view tab to 
find all literature items associated with that product. 

■ When your employees use the Correspondence screen to create correspondence, 
they can include literature as enclosures. The user or fulfillment center may print 
out this literature document, or it may use preprinted copies of literature such 
as glossy brochures. It may also enclose promotional items that are parts of 
literature kits.
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About Setting Up Literature Files
To set up a literature file, you must

■ Create the document in another program 

■ Add a Literature record that includes the document in your Siebel application 

NOTE: You may want to create a literature record without associating a document 
with it. For example, if the record represents an item such as a hat or cup, which is 
part of a literature kit, you need not associate a document with it. 
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Creating and Modifying Literature Files
Literature files can be created or saved using many kinds of software. The following 
file types are among the most common:

■ Adobe Acrobat (.pdf)

■ Excel (.xls)

■ Word (.doc)

■ PowerPoint (.ppt)

■ Bitmap (.bmp)

■ JPEG (.jpg)

To create a new literature file

1 Create a literature file in the appropriate software application.

2 Save the file on your hard drive.

To modify an existing literature file

1 From the application-level menu, choose View > Site Map > Document 
Administration > Literature. 

2 Click the literature file that you want to modify.

Information about the file is displayed in the More Info form. You can use this 
form to change existing comments or characteristics; for example, Distribution 
Method.

The actual literature file opens in the type of tool that was used to create it; for 
example, Word.

3 Modify the file, and save it locally. 

4 Upload the modified file to the existing Literature record.
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After you have created a literature file, you need to create a literature record in the 
Siebel database, in order to make the file available to Siebel applications users.

To add a literature record

1 From the application-level menu, choose View > Site Map > Document 
Administration > Literature. 

2 In the Literature list, add a record and attach the literature file.

The new file is added to the available literature. Appropriate information is 
displayed in the Literature list and the More Info form.

3 Enter the rest of the information required in the Literature list blank row and the 
More Info form of the new record. The following table briefly describes each 
field in the view.

Field Comments

Name Enter a name for the literature record.

Description Enter a description of the document. Because literature items 
can be in any language, you may want to indicate the language 
of the item in this field (or in the Name field).

Literature Type Select the type of the literature. You can create new literature 
types in the List of Values Administration view. 

Because the Literature Type field is used to filter literature items 
in various applets (by setting the Search Specification property 
for the applet in Siebel Tools), you should be careful when 
editing the Literature Type field.

Size The size of the literature file. The information is automatically 
entered based on the size of the file that you select.

File Type The file type of the literature file, for example DOC or PDF. The 
information is automatically entered based on the type of the 
file that you select.

Modified The date that the literature file was last modified. The 
information is automatically updated whenever the file is 
updated. 
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Update File A check mark in this field indicates that users’ copies of the 
literature will be updated automatically each time the original 
file is updated.

File Click Browse and, in the Choose File dialog box, select the 
document file. You can also enter the file name manually. 
Required.

Synopsis Optionally, enter a synopsis of the document’s content.

Author Optionally, click the select button and select the document’s 
author. 

Accounts Select accounts with which the literature is associated.

Competitors Select competitors with which the literature is associated. Use 
this field to allow the user to display the literature using the 
Competitors screen. 

If you also select the Internal field, this literature will be 
displayed in the Comparative Literature view of the 
Competitors screen. If you do not select the Internal field, this 
literature will be displayed in the Competitor’s Literature view 
of the Competitors screen. 

Internal Select this field if the document is internally sensitive and not 
intended for public distribution. 

If Internal is selected, the literature will not be available as an 
enclosure in the Correspondence screen, and it will be 
displayed in the Comparative Literature list of the Competitors 
screen.

If Internal is not selected, the literature will be available as an 
enclosure in the Correspondence screen, and it will be 
displayed in the Competitive Literature list of the Competitors 
screen.

Local For users of the Remote Client, this fields specifies whether the 
document is available on the local File System. If a document is 
not available locally, the user can request it by selecting the 
Request field.

Request For users of the Remote Client, if this check box is selected, the 
literature will be downloaded during each synchronization 
session. 

Field Comments
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Distribution Method Use this drop-down list to specify whether or not the file is 
automatically downloaded to users of the Remote Client.

Publish: During each synchronization session, if your user does 
nothing, the file is downloaded automatically. If your user 
explicitly skips the file, the file is not downloaded in that 
synchronization session. 

By Request: During synchronization, the user receives the 
record, but not the actual file. To receive the file, the user must 
select the Request field.

Industries Select any industries associated with the literature. 

Products Select any products associated with the literature. Use this field 
to allow the user to display the literature using the Products 
screen. 

Organization Select organizations that will have visibility to this data. 
Required.

Field Comments
238 Applications Administration Guide MidMarket Edition Version 7.5, Rev. A



Literature

Adding Translation Records
Adding Translation Records
Translated literature files can be created using any of the previously listed software 
tools. (See “Creating and Modifying Literature Files.”) You can create a record in the 
Siebel application for any translated file associated with your document. 

To associate a translated document with a literature record

1 From the application-level menu, choose View > Site Map > Document 
Administration > Literature. 

2 In the Literature list, select an existing record. 

3 Click the Translations view tab.

4 In the Translation list, add a record and attach the translated document.

Make sure that the file name clearly indicates that this is the translated file.
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After you have created more than one literature file, you can combine individual 
files and other material to create literature item kits. This feature allows you to 
combine individual literature items into groups, so you can work with the group 
instead of with of the individual files. Literature item kits are used only as 
enclosures in correspondence. 

For instance, you might have a set of literature items for prospective customers, 
including promotional brochures for your most popular products. You might also 
include items that are not documents: for example, a promotional kit for one of your 
products might include a brochure, a specifications sheet, a coffee cup, and a T-
shirt.

Creating a literature item kit makes it easier to send this information out. When the 
user adds an attachment to correspondence, the user only has to select one 
literature item kit instead of all the individual items. Then the fulfillment center can 
mail all the items with the correspondence. 

When you create a literature item kit, you create a Literature record that represents 
the entire kit, and you associate Literature Item records with it that represent the 
items in the kit. The fulfillment center can view the Literature record, but cannot 
view the Literature Item records. To let the fulfillment center know which items 
make up the kit, you can:

■ Pack kits together at the fulfillment center. For example, you have a kit named 
Sales Promo that includes a brochure and a hat. The brochure and hat might be 
be shrink wrapped together at the fulfillment center or they might be stored in 
one bin at the fulfillment center, so the fulfillment center can select one of each 
item in the bin. Then, when the fulfillment center sees that they must fulfill the 
Sales Promo literature record, they would mail out this shrink-wrapped package 
or the items from this bin. 
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■ Make the Literature record a bill of materials. You can include a document in the 
Literature record that describes all the Literature Items in the kit, or use the 
Literature records Description or Synopsis field to list all the Literature Items in 
the kit. For example, if the kit consists of a sales brochure and a hat, you would 
create a Literature record that represents the entire kit, you would attach two 
Literature Item records to it that represent the brochure and the hat, and you 
might also use the description field of the Literature record to say the kit includes 
a brochure and a hat. Then the fulfillment center would read the description 
field and mail out the items listed. 

To add a literature item kit

1 From the application-level menu, choose View > Site Map > Document 
Administration > Literature. 

2 In the Literature list, add a new record, or select an existing record. This record 
represents the literature item kit, so you should give it a name that indicates the 
kit contents.

3 Click the Literature Items tab.

The fields previously displayed in More Info are shown under the Literature list 
at the top. The fields in the Literature Items list, in the middle of the view, 
display specific item information. The Component Items list appears at the 
bottom of the view.

4 In the Literature Items list, add a record and complete the necessary fields.

Some fields are described in the following table.

Field Comments

Primary Indicates whether this is the primary item in the kit. 

Physical Form A description of the item’s physical form. This field supports 
multiple values to allow for multiple physical forms. For a document, 
you might choose 8 1/2 x 11 and Microfiche.

# of Pages The number of pages in the document, if applicable.
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5 In the Component Items list, add a new record.

6 Select the record to be added, and then click Add.

7 In the Component Items list, add any other new records that are needed to create 
the kit.

In Stock Select the check box to specify whether the item is in stock, if 
applicable.

Part # The item’s part number, if applicable.

Field Comments
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About Making Literature Visible to Users
You can make literature visible to users in the following ways: 

■ The Products Screen. You can associate literature with a product, and the user can 
display it using the Products screen. 

■ The Competitors Screen. You can associate literature with a competitor, and the 
user can display it using the Competitors screen. 

■ The Correspondence Screen. You can deselect the Internal field of a literature 
record and the user can select it as an enclosure in correspondence. 

■ The Literature Screen or Infocenter Explorer. You can make literature visible to 
users, so it is included in the list of literature that they display in the Literature 
or Infocenter Explorer. 
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Sharing Literature Through the Products Screen
End users who are salespeople find it useful to view literature about your products 
when they are viewing other information about the products. If you associate 
literature with a product, end users can view this literature when they view the 
product record in the Products screen. 

To share literature through the Products screen

1 From the application-level menu, choose View > Site Map > Document 
Administration > Literature. 

2 In the Literature list, select a literature record or add a new literature record. 

3 In the More Info form, click the select button in the Products field.

4 In the dialog box, select a Product and Part # to be associated with the literature 
record, and then click OK.

If no Products were previously associated with the literature record, you can use 
the Associated Products dialog to set up a new association.
244 Applications Administration Guide MidMarket Edition Version 7.5, Rev. A



Literature

Sharing Literature Through the Competitors Screen
Sharing Literature Through the Competitors Screen
Salespeople find it useful to view their competitors’ literature or to view literature 
that your company has prepared that compares your products with your 
competitors. If you associate literature with a competitor, end users can view this 
literature when they view the competitor record in the Competitors screen. 

To share literature through the Competitors screen, you must associate it with a 
competitor. You must also decide whether to select the Internal flag, which 
determines whether it is displayed in the Comparative Literature List or the 
Competitive Literature list of the Competitors screen: 

■ If you select the Internal flag, the literature will appear in the Comparative 
Literature list, and it will not be available as an enclosure in the Correspondence 
screen. 

■ If you do not select the Internal flag, the literature will appear in the Competitive 
Literature list, and it will be available as an enclosure in the Correspondence 
screen. 

Whether you select Internal depends on what type of literature it is:

■ Competitors’ literature. Your salespeople may want to use literature produced by 
competitors, such as sales brochures, to help them compare your products with 
what the competition is offering, However, you would not want to distribute this 
literature outside your company. You should select Internal, so the literature will 
not be available in the Enclosures list of the Correspondence screen, but it will 
appear in the Comparative Literature in the Competitors screen.

■ Comparative literature for internal use. You may develop comparative literature 
internally, such as competitive intelligence, that is meant for use by your sales 
people and that you do not want to distribute outside your company. You should 
select Internal, so the literature will not be available in the Enclosures list of the 
Correspondence screen, but it will appear in Comparative Literature in the 
Competitors screen. 
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■ Comparative literature for external use. You may develop comparative literature 
internally that is aimed at your customers, or you may have third party 
comparative reports that you want to distribute to your customers. You should 
not select Internal, so the literature will be available in the Enclosures list of the 
Correspondence screen, and it will also appear in Competitive Literature in the 
Competitors screen.

To share literature through the Competitors screen

1 From the application-level menu, choose View > Site Map > Document 
Administration > Literature. 

2 In the Literature list, select a literature record or add a new literature record. 

3 In the More Info form, click the select button in the Competitors field.

4 If the competitors that you want to list appear in the dialog box, select the 
competitors, and then click Close.

5 If the specific competitors are not listed in the dialog box, click New.

The Competitors dialog box changes, now listing all possible competitors. You 
can use the Find button to locate a specific company.

6 In the Competitors dialog box, select the competitors and click OK.

When users display this competitor record in the Competitors screen, they will 
be able to display the literature in Comparative Literature list if you selected 
Internal or in the Competitive Literature list if you did not select Internal.
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Sharing Literature Through the Correspondence Screen
End users may want to use literature as enclosures in correspondence. They may 
also use literature records that represent literature item kits as enclosures in 
correspondence. 

Literature is available to users in the correspondence screen if the Internal field of 
the Literature record is not selected. 

To share literature through the Correspondence screen

1 From the application-level menu, choose View > Site Map > Document 
Administration > Literature. 

2 In the Literature list, select a literature record or add a new literature record. 

Make sure the Internal field of this record is not selected. 

When users create correspondence, they will be able to add this literature as an 
enclosure. 
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Sharing Literature Through Literature or Infocenter
Your end users may work with literature by displaying the Literature screen or 
Infocenter Explorer and searching the Literature list in that screen for the piece of 
literature they need. 

You generally share literature with users by associating the user with access groups 
and associating literature with categories. Before you can do this, you must create 
categories that include literature, create access groups that include end users, and 
associate the categories with the access groups. For more information, see Security 
Guide for Siebel eBusiness Applications, MidMarket Edition. 

After you have completed this preliminary work, you can assign literature to end 
users as follows: 

■ When you produce new literature, associate it with the appropriate category and 
it will be visible to all end users in access groups associated with that category.

■ When you hire new employees, associate them to with the appropriate access 
group and they will have visibility to all the literature in categories associated 
with that category. 

A business manager who administers literature makes it visible to users by 
associating it with the appropriate category in either the Literature Administration 
screen or the Catalog Administration screen. After it is assigned in either of these 
ways, users in access groups associated with this category will be able to display it 
in the Literature screen.

To associate literature with a category using the Literature Administration screen

1 From the application-level menu, choose View > Site Map > Document 
Administration > Literature. 

2 In the Literature list, select the record for the literature you want to associate 
with a category. 

3 In the Category form, add a new record.

4 In the dialog box, select the item to be associated with the category, and then 
click OK.

The literature is associated with the category. 
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To associate literature with a category using the Catalog Administration screen

1 From the application-level menu, choose View > Site Map > Catalog 
Administration > Catalog Administration.

2 In the Catalogs list, drill down on the Name of the catalog to be associated with 
the literature. 

A Categories list appears. 

3 Click the Literature view tab.

4 In the Literature list, add a new record.

5 In the dialog box, enter identifying information about the literature (for example, 
the document Name), and then click Go.

6 When the dialog box reappears listing the needed literature, select the literature 
item and click OK.

The literature is associated with the category.
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This chapter describes the integration of D&B data with your Siebel application. 
Some topics included in this chapter are:

■ Business scenarios for using D&B data within your Siebel application.

■ Overview information about loading D&B data into the Siebel database.

■ Procedures for setting up the symbolic URL to allow real-time searches and on-
line report access.

■ Maps of D&B data to Siebel data fields.
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About D&B Data
D&B is a leading provider of business information. D&B’s information and 
technology solutions help businesses find profitable customers, reduce credit risk, 
manage receivables, and manage vendors. D&B’s database of commercial 
information consists of over 75 million records world wide. 

For connected users, you can use your Siebel application to integrate with D&B data 
and reports. As a mobile client, you can access D&B data for accounts and contacts 
that have been promoted from D&B marketing data.

This allows you to:

■ Use D&B marketing data within your Siebel application.

■ Access D&B business and credit reports from within your Siebel application.

You can use this D&B data to support the following:

■ New Business or Customer Acquisition. By querying on company size, line of 
business, and other criteria provided by D&B, you can generate lists of prospects 
to add to the sales pipeline or to support outbound marketing programs. By 
using the D&B corporate family linkage information, you can identify new 
prospects and opportunities within a company’s extended family.

■ Customer Segmentation and Penetration. You can profile specific market segments 
such as geography, industry, size, and other criteria to identify untapped 
opportunities or better align sales territories.

■ Customer Qualification. Use your access to D&B business and credit reports to 
obtain detailed background and risk information on a company in order to focus 
sales efforts on higher-probability accounts and shorten the sales cycle.

NOTE: This chapter describes how the administrator loads and updates D&B data. 
For information about viewing and using D&B data within the Siebel application, 
see Siebel Sales User Guide, MidMarket Edition.
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Business Scenarios
The following scenarios describe how you can use D&B data in your company.

Build and Grow Current Customer Relationships
D&B data can help you find out how many relationships you already have within 
the complete corporate family structure. Use the D&B D-U-N-S number to view the 
organizational hierarchy of your clients and also to aggregate account attributes at 
all levels within your clients. 

For example, you are selling to 20 IBM locations and you find out that there are 
locations that you have never contacted. 

Following the completion of a successful sales engagement, use D&B demographic 
data to query your existing customer base for other customers in the same industry 
who are approximately the same size. This gives you a targeted population for 
replicating the success and driving revenue. 

New Business or Customer Acquisition
Despite best efforts by an organization’s marketing department, the sales 
organization is constantly asking for more leads. To partially address the issue, the 
company provides all salespeople access to the companies in the D&B database so 
they can generate prospects in their territory. 

Individual salespeople can query the D&B database using criteria matching their 
ideal target to find new leads. After generating a list of leads, salespeople can 
automatically add the companies and contacts to their accounts.

Additionally, D&B demographic data can be used to analyze customer buying habits 
and then applied to the business universe to provide targeted marketing lists for 
specific campaigns or for distribution to the sales force.

Customer Satisfaction and Account Planning
Standardizing customer information on the D&B D-U-N-S number gives you a 
means for house-holding your customer data and eliminating duplicate customer 
records. This increases your ability to manage existing customer relationships 
because all opportunities for a customer are linked to the same customer record.
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Add D&B’s corporate family linkage, and you have the ability to manage and plan 
for customers at a local and global level. For example, you may want to see a roll 
up of all opportunities and potential revenue for all companies and locations related 
to Coca-Cola worldwide. 
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Understanding the D&B D-U-N-S Number
The D-U-N-S (Data Universal Numbering System) number is a crucial component 
of D&B data. A D&B D-U-N-S number is a nonindicative, nine-digit number assigned 
to each business location in the D&B database. Each D-U-N-S number has a unique, 
separate, and distinct operation, and is maintained solely by D&B. Industries and 
organizations around the world use the D&B D-U-N-S number as a global standard 
for business identification and tracking.

Each company has a unique D&B D-U-N-S number associated with it. It acts as a 
unique identifier for a company in the D&B database.

To uniquely identify the association between different companies in the D&B 
database, each company also has associated D&B D-U-N-S numbers.

Several categories of D&B D-U-N-S numbers exist:

■ D&B D-U-N-S Number—each unique business location listed in the D&B 
database is assigned a D&B D-U-N-S number. This column is called simply DUNS 
Number in your Siebel application.

■ Global Ultimate D-U-N-S—the D&B D-U-N-S number belonging to a business’s 
worldwide ultimate parent company. 

■ Domestic Ultimate D-U-N-S—the D&B D-U-N-S number belonging to the 
highest-level family member within a specific country.

■ Parent/HQ D-U-N-S—the D&B D-U-N-S number belonging to a business’s 
immediate headquarters or parent.

These numbers allow D&B to establish the relationships between different 
companies.
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Process for Integrating D&B Data
The process of integrating D&B data into the D&B Account tables and the Siebel 
Account tables in the Siebel database involves the following steps:

■ Obtaining D&B Data

■ Loading D&B Data into staging tables in the Siebel database

■ Running the Siebel Update Server Components
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Obtaining D&B Data
You must obtain three data files from D&B:

■ The Marketing Data file

■ The MRC file

■ The SIC file

Request these files in Siebel format, also referred to as 2202 or GDMDI data file 
format. D&B should be able to provide files in this format without difficulty.

To obtain MRC and SIC files, send email to:

dnb4siebel@dnb.com

In addition to these files, you can request D&B data layout documentation from 
D&B.

The Marketing Data File. This file contains detailed company information, such as the 
company’s legal name, address, contact information, and so forth.

The MRC and SIC Files. These are both reference files required by the Siebel D&B 
modules. Both files contain information referenced by the demographic company 
data provided by D&B.

MRC stands for Management Responsibility Code. The MRC file contains a list of 
lookup values for the contacts and their positions such as CEO, Vice President of 
Marketing, and so on. Each contact has an associated numerical code that is 
referenced by the D&B marketing data to determine the title or position of a 
company contact.

SIC stands for Standard Industrial Classification, and is a code developed by the 
Federal government to describe the type of activity performed by the business at 
this location. The SIC file contains a list of SIC codes assigned and maintained by 
D&B along with their definitions. D&B’s Primary SIC code indicates the line of 
business that provides the largest revenue contribution to the business. D&B also 
maintains and assigns six levels of subsidiary SIC codes to describe in greater detail 
additional lines of business activity for a given company. By default, the SIC code 
provided in the SIC file and the Marketing Data file is the 4-digit SIC code. 
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After you have obtained the three D&B data files, you can start to load the data into 
the Siebel database. You can load the files in any order, but you must load all three 
files before running the Siebel update server component.

When creating your data loading scripts, refer to the documentation provided by 
D&B and to Siebel Data Model Reference.

The scripts and processes differ according to your database platform.

NOTE: When you integrate D&B data for the first time, you may want to contact 
Siebel Professional Services to obtain sample loading scripts for use as templates. 
See “Loading D&B Data Using Sample Scripts” on page 260.

The scripts load D&B data into staging tables in the Siebel database, as shown in 
Table 18.

NOTE: Definitions of these tables can be found in Siebel Data Model Reference.

Because SIC and MRC files change only rarely, updating D&B data usually requires 
deleting and reloading the D&B marketing data in the S_DNB_UPDATE table alone.

If you need to load new versions of the SIC and MRC files, you must delete the 
previously used staging tables. 

Table 18. Staging Tables for Uploading D&B Data

File Upload Location

Marketing Data file S_DNB_UPDATE table

This table is used as a staging area for the un-normalized D&B 
Marketing data.

SIC file S_DNB_SIC table

MRC file S_DNB_MRC table
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Table 19 lists what D&B data to delete and what to load.

After loading files, you must run the D&B Update Manager (D&B) and the D&B 
Update Manager (Siebel) as described in “About Siebel Update Server Components” 
on page 264.

Table 19. Loading or Reloading D&B Data

If You Are... Then...

Loading D&B data for the first time ■ Load the three D&B data files: Marketing Data 
file, SIC file, and MRC file.

Updating D&B data with a new 
Marketing Data file, but the SIC and 
MRC files have not changed

■ Delete data from the S_DNB_UPDATE table.

■ Load the Marketing file.

Updating D&B data with new 
Marketing Data, SIC, and MRC files

■ Delete data from the S_DNB_UPDATE, the 
S_DNB_SIC, and the S_DNB_MRC tables.

■ Load the three D&B data files: Marketing Data 
file, SIC file, and MRC file.
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Loading D&B Data Using Sample Scripts
This section provides some guidance on how to load D&B data on Oracle, DB2, and 
Microsoft SQL Server platforms using sample scripts. These scripts are not provided 
as part of the Siebel product, but may be obtained from Siebel Professional Services.

CAUTION: Before running scripts, you should check them against the D&B data layout 
documentation and against the S_DNB_UPDATE table columns documented in 
Siebel Data Model Reference. Then, modify the scripts as required.

Loading D&B Data on Oracle
Oracle installations require you to run SQLLOADER control files. You need the 
following control files:

■ s_dnb_update.ctl (for loading Marketing Data file into S_DNB_UPDATE table)

■ s_dnb_sic.ctl (only required if loading the SIC file)

■ s_dnb_mrc.ctl (only required if loading the MRC file)

NOTE: This procedure is based on the assumption that you understand how to run 
SQLLOADER. SQLLOADER is described in the Oracle documentation.

To load D&B data if you are using Oracle

1 Verify that the column order of your D&B file matches the column requirements 
in the .ctl file before running the loading script.

2 Truncate the appropriate staging tables (see Table 19 on page 259). 

To optimize loading performance, drop all indexes on the S_DNB_UPDATE table 
and re-create them after the scripts have completed. This can be done using 
Siebel utilities ddlexp (to back up the indexes before dropping) and ddlimp (to 
re-create them).

3 Modify the .sql file as appropriate for:

■ The name of your database
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■ The D&B filename and directory location

■ The database table owner

■ The user ID and password (with loading privileges) that you are using to load 
the data

4 Run SQLLOADER.

Loading D&B Data on DB2
DB2 installations require you to run DB2 IMPORT. You need the following .sql files:

■ imp_update_new.sql (for loading Marketing Data file into S_DNB_UPDATE 
table)

■ imp_sic_new.sql (only required if loading the SIC file)

■ imp_mrc_new.sql (only required if loading the MRC file)

NOTE: This procedure is based on the assumption that you understand how to run 
DB2 IMPORT. DB2 IMPORT is described in the DB2 documentation.

To load D&B data if you are using DB2

1 Verify that the column order of your D&B file matches the column requirements 
in the .sql file before running the loading script.

2 Truncate the appropriate staging tables (see Table 19 on page 259). 

To optimize loading performance, drop all indexes on the S_DNB_UPDATE table 
and re-create them after the scripts have completed. This can be done using 
Siebel utilities ddlexp (to back up the indexes before dropping) and ddlimp (to 
re-create them).

3 Modify the .sql file as appropriate for:

■ The name of your database

■ The D&B filenames and directory location

■ The database table owner
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■ The user ID and password (with loading privileges) that you are using to load 
the data

4 Run DB2 IMPORT.

5 Optional: After running the import scripts, update the DB2 catalog statistics by 
executing RUNSTATS on the three tables that received the D&B data 
(S_DNB_MRC, S_DNB_SIC, S_DNB_UPDATE).

Loading D&B Data on Microsoft SQL Server
Microsoft SQL Server installations require you to run SQL scripts. You need the 
following format files and SQL scripts:

■ For loading the Marketing Data file:

■ S_DNB_UPDATE.fmt—a format file to load the data into the 
tempS_DNB_UPDATE table

■ S_DNB_UPDATE.sql—an SQL script that loads the data into S_DNB_UPDATE 
table

■ For loading the SIC file:

■ S_DNB_SIC.fmt—a format file to load the data into the tempS_DNB_SIC table

■ S_DNB_SIC.sql—an SQL script that loads the data into the S_DNB_SIC table

■ For loading the MRC file:

■ S_DNB_MRC.fmt—a format file to load the data into the tempS_DNB_MRC 
table

■ S_DNB_MRC.sql—an SQL script that loads the data into the S_DNB_MRC 
table

NOTE: This procedure is based on the assumption that you understand how to run 
bcp (bulk copy process) or similar data-loading utility. The bcp utility is described 
in the Microsoft SQL Server documentation.
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To load D&B data if you are using Microsoft SQL Server

1 Verify that the column order of your D&B file matches the column requirements 
in the .sql file before running the loading script.

2 Truncate the appropriate staging tables (see Table 19 on page 259). 

To optimize loading performance, drop all indexes on the S_DNB_UPDATE table 
and re-create them after the scripts have completed. This can be done using 
Siebel utilities ddlexp (to back up the indexes before dropping) and ddlimp (to 
re-create them).

3 Modify the .sql file as appropriate for:

■ The name of your database

■ The D&B filename and directory location

■ The database table owner

■ The user ID and password (with loading privileges) that you are using to load 
the data

4 Run bcp or another data loading utility.
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About Siebel Update Server Components
Whenever you load or reload D&B data, you must update the D&B Account tables 
and the Siebel Account tables in the Siebel database. This update is accomplished 
by running server components: 

■ D&B Update Manager (D&B): Moving D&B marketing data from the staging table 
(S_DNB_UPDATE) into the normalized D&B Account tables, which are the basis 
for the D&B All Accounts View (Figure 9 on page 266).

■ D&B Update Manager (Siebel): Updating the records in the Siebel Account tables 
for accounts with matching D-U-N-S numbers (Figure 10 on page 267). 

■ A third component, D&B Update Manager MultiTask, is also provided. This 
component can be used in place of D&B Update Manager (D&B) or D&B Update 
Manager (Siebel) to run the update using multiple, parallel processes (“About 
the Multiple Task Siebel Update Server Component” on page 267).

Overview of the Update Process
This section outlines the process of loading D&B data from the staging tables to the 
D&B Account tables and through to updating the Siebel account tables. 

This process recommends using the D&B Update Manager MultiTask server 
component to run server component tasks in parallel. However, use of the single 
task D&B Update Manager (D&B) and D&B Update Manager (Siebel) server 
components is also documented in this chapter.

1 Make sure you have loaded the D&B data into the staging tables as discussed in 
“Loading D&B Data” on page 258 and “Loading D&B Data Using Sample Scripts” 
on page 260.

2 Update the D&B Account tables with data from the staging tables:

■ To optimize performance, you may choose to do one of the following:

❏ For first time data loading, that is, when there are no D&B records in the 
database, drop the indexes on these D&B Account tables: S_DNB_ORG, 
S_DNB_ORG_SIC, S_DNB_CON_MRC, and S_PRSP_CONTACT. 
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❏ For subsequent updates, drop the indexes on the S_DNB_ORG table only, 
all except for the indexes S_DNB_ORG_U1 (DUNS_NUM), 
S_DNB_ORG_P1 (ROW_ID), and S_DNB_ORG_M01 (the clustered index) 
on this table. 

■ Create a search specification on the D-U-N-S number to set up your preferred 
batch sizes and determine the corresponding D-U-N-S number ranges per 
batch for loading the data from the staging tables to the D&B Account tables.

■ Execute concurrent D&B Update Manager (D&B) server tasks by running the 
D&B Update Manager MultiTask server component. See “About the Multiple 
Task Siebel Update Server Component” on page 267 and “Running the Siebel 
Update Server Components” on page 270.

■ Continue to execute the concurrent D&B Update Manager (D&B) server tasks 
until all data is loaded into the D&B Account tables.

■ If you dropped indexes on the D&B Account tables, re-create them. This can 
be done using Siebel utilities ddlexp (to back up the indexes before dropping) 
and ddlimp (to re-create them).

3 Update the Siebel Account tables from the D&B Account tables for accounts with 
matching D-U-N-S numbers by executing concurrent D&B Update Manager 
(Siebel) server tasks using the D&B Update Manager MultiTask server 
component. See “Multiple D&B Update Manager (Siebel) Processes” on 
page 269 and “Running the Siebel Update Server Components” on page 270.
Version 7.5, Rev. A Applications Administration Guide MidMarket Edition 265



D&B Integration

About Siebel Update Server Components
About the Single Task Siebel Update Server Components
The update server components are part of the Dun and Bradstreet Enterprise 
Component Group. This group and each of its D&B Batch Components must be 
enabled. Once enabled, each component can be run as a batch task. Figure 9 shows 
how the staging tables are mapped to the D&B Account tables.

Figure 9. D&B Update Manager (D&B) Table Names
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Figure 10 shows how the D&B Account tables are mapped to the Siebel Account 
tables.

“Field Mapping for the D&B Update Manager Process” on page 281 lists the default 
table mapping from the D&B Account tables to the Siebel Account tables that are 
used by the D&B Update Manager (Siebel) server component.

About the Multiple Task Siebel Update Server Component
You can use the server component DNBUpMgrMultiTask to spawn multiple Update 
Manager processes. Running several parallel processes helps you maximize your 
performance with large data loads and gives you greater scheduling flexibility. You 
can control the number of processes that are created by editing the dnbtask.cfg file. 
The dnbtask.cfg file contains two sections, one to set tasks for the D&B Update 
Manager (D&B) process and the second to set tasks for the D&B Update Manager 
(Siebel) process.

Figure 10. D&B Update Manager (Siebel) Table Names
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The dnbtask.cfg file is located in the sqltempl subdirectory, in the server installation 
directory. 

Multiple D&B Update Manager (D&B) Processes
By default the dnbtask.cfg file sets up three simultaneous tasks, based on D-U-N-S 
number ranges. The DNBUpMgrDNB portion of the file looks like this:

[DNB]

Task1 = ,100000000

Task2 = 100000000,200000000

Task3 = 200000000,

These four ranges translate into four DNBUpMgrDNB tasks, each taking care of 
loading records within a particular D-U-N-S number range:

,100000000 means D-U-N-S numbers < 100000000

100000000,200000000 means D-U-N-S numbers >=100000000 and < 200000000

200000000, means D-U-N-S numbers >=200000000

Edit the file to change the number of parallel processes created or the range of 
D-U-N-S numbers updated.

CAUTION: If you use DNBUpMgrMultiTask to run multiple UpdateMgr processes, you 
must make sure that processes running at the same time have mutually exclusive 
ranges. Unpredictable results will occur if multiple processes collide. 

Multiple D&B Update Manager (D&B) Processes with First Time 
Data Loading
The first time you load D&B data, that is, when there are no D&B records in the 
database, you may use a special .sql file (dnbinitial.sql) which is optimized to do 
only inserts. This results in faster loading of data than using the dnbmaps.tsq file.

To use the dnbinitial.sql file, set the server component parameter DNBConfigFile to 
dnbinitial.sql. (For examples, see Step 4 on page 272 and Step 2 on page 273.) This 
can be done from Server Manager or from your Siebel application.
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For subsequent updates, the DNBConfigFile should be set to dnbmaps.tsq.

NOTE: The dnbinitial.sql file assumes that you dropped the indexes on the D&B 
Account tables (Step 2 on page 264).

Multiple D&B Update Manager (Siebel) Processes
By default the dnbtask.cfg file sets up five simultaneous tasks, based on tables 
updated. The DNBUpMgrSieb portion of the file looks like this:

[Siebel]

Task1 = UPDATE_SIEBEL_ACCOUNT

Task2 = UPDATE_INDUST, COMMIT, UPDATE_SIEBEL_INDUST, COMMIT,
UPDATE_SIEBEL_SYNONYM 

Task3 = UPDATE_SIEBEL_ADDR_PHY, COMMIT, UPDATE_SIEBEL_ADDR_MAIL

Task4 = UPDATE_SIEBEL_CONTACT 

Task5 = UPDATE_SIEBEL_LOC1, COMMIT, UPDATE_SIEBEL_LOC2, COMMIT, 
UPDATE_SIEBEL_LOC3

You may edit the file to change the number of parallel processes created. However, 
note that the order of the updates within individual tasks is important; for example 
UPDATE_INDUST should be done before UPDATE_SIEBEL_INDUST. Use caution 
when updating the DNBUpMgrSieb portion of the dnbtask.cfg file.

CAUTION: If you have modified the RTI configuration file to insert new accounts into 
the Siebel Accounts table, do not run the multiple task process. Instead you must 
run the single task D&B Update Mgr (Siebel) server component. Make sure you have 
modified the dnbmaps.sql file used by the single task server component. The order 
of the updates is critical to data integrity if new accounts are being added.
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Running the Siebel Update Server Components
There are two ways to run the Siebel update server components:

■ From within the Siebel application

■ From a command line interface, using Server Manager

Procedures for running the update processes from both within the Siebel 
application and from the command line. (Whatever procedures you choose to 
follow, make sure that the D&B Update Manager (D&B) process is complete before 
you start the D&B Update Manager (Siebel) process.)

■ “To run the D&B Update Manager (D&B) server component from within your 
Siebel application (single task process)” on page 271

■ “To run the D&B Update Manager (D&B) server component from within your 
Siebel application (multiple task process)” on page 272

■ “To run the D&B Update Manager (Siebel) server component from within your 
Siebel application (single task process)” on page 272

■ “To run the D&B Update Manager (Siebel) server component from within your 
Siebel application (multiple task process)” on page 273

■ “To run the D&B Update Manager (D&B) server component from a command 
line (single or multiple task process)” on page 273
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■ “To run the D&B Update Manager (Siebel) server component from a command 
line (single or multiple task process)” on page 274

NOTE: If you have just installed the Siebel Server or if you have made changes to the 
Siebel Name Server, you need to synchronize before running the Siebel update 
server component. For more information about synchronizing server components, 
see Siebel Server Administration Guide, MidMarket Edition.

TIP: If you are going to run the D&B Update Mgr (Multi-task) component, make sure 
that the maximum number of tasks (MaxTasks parameter) is set correctly to 
accommodate the number of tasks that you specified in the dnbtask.cfg file. For 
information about MaxTasks, see Siebel Server Administration Guide, MidMarket 
Edition.

To run the D&B Update Manager (D&B) server component from within your Siebel 
application (single task process)

1 Check the state and mode for the Update Mgr component:

a From the application-level menu, choose View > Site Map > Server 
Administration > Enterprise Configuration.

b Click the Enterprise Component Groups view tab.

c In the Enterprise Component Groups list, select the Dun and Bradstreet 
component group.

d For the Dun and Bradstreet record, make sure that the state is Enabled.

If it is not enabled, enable it by clicking the menu button in the Enterprise 
Component Groups list and clicking Enable Component Group. Then 
synchronize. For more information on enabling component groups and 
synchronizing server components, see Siebel Server Administration Guide, 
MidMarket Edition.

2 From the Show drop-down list, select Enterprise Operations.

3 Click the Component Requests view tab. 

4 In the Component Requests list, click New.
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5 In the Component Requests form, in the Component/ Job field, select D&B 
Update Mgr (D&B). Make sure the Mode is set to Asynchronous.

6 In the Component Requests form, click the menu button and click Submit 
Request.

7 When the D&B Update Mgr (D&B) is done, open the log directory. If there have 
been problems with the process, there will be a log file, which you should 
review. The log file is named DNBUpMgrDNB_TaskNumber.log.

To run the D&B Update Manager (D&B) server component from within your Siebel 
application (multiple task process)

1 Follow Step 1 to Step 4 of the procedure “To run the D&B Update Manager 
(Siebel) server component from within your Siebel application (single task 
process)” on page 272.

2 In the Component Requests form, in the Component/ Job field, select D&B 
Update Mgr (Multi-task). Make sure the Mode is set to Asynchronous.

3 In the Component Request Parameters list, add a new record, set the Name field 
to DNBTaskCode, and in the Value field enter DNB.

4 If data is being loaded for the first time, add a second new request parameters 
record, set the Name field to DNBConfigFile and in the Value field enter 
dnbinitial.sql

5 In the Component Requests form, click the menu button and click Submit 
Request.

6 When the process is done, open the log directory. If there have been problems 
with the process, there will be a log file, which you should review.

To run the D&B Update Manager (Siebel) server component from within your Siebel 
application (single task process)

■ Follow the procedure “To run the D&B Update Manager (D&B) server component 
from within your Siebel application (single task process)” on page 271, except 
that at Step 5, set the Component/ Job field to D&B Update Mgr (Siebel).
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To run the D&B Update Manager (Siebel) server component from within your Siebel 
application (multiple task process)

1 Follow Step 1 to Step 4 of the procedure “To run the D&B Update Manager 
(Siebel) server component from within your Siebel application (single task 
process)” on page 272.

2 In the Component Requests form, in the Component/ Job field, select D&B 
Update Mgr (Multi-task). Make sure the Mode is set to Asynchronous.

3 In the Component Request Parameters list, add a new record, set the Name field 
to DNBTaskCode and in the Value field enter Siebel.

4 In the Component Requests form, click the menu button and click Submit 
Request.

5 When the process is done, open the log directory. If there have been problems 
with the process, there will be a log file, which you should review.

To run the D&B Update Manager (D&B) server component from a command line 
(single or multiple task process)

1 Log in to the server using Server Manager. Use a command with this format:

SIEBEL_ROOT\siebsrvr\bin\>srvrmgr /g gateway /e enterprise_name /
u db_username /p password /s siebserver

Examples:

>srvrmgr /g evlab6 /e siebel /u sadmin /p sadmin /s evlab6

>srvrmgr /g smte420s053:2321 /e siebel /u sadmin /p sadmin /s 
smte420s053

2 At the srvrmgr prompt, enter one of the following commands:

■ start task for comp DNBUpMgrDNB (for single task process)

■ start task for comp DNBUpMgrMultiTask with DNBTaskCode=DNB (for 
multitask process)

■ start task for comp DNBUpMgrMultiTask with DNBTaskCode=DNB 

DNBConfigFile=dnbinitial.sql (for initial data loading; see “Multiple 
D&B Update Manager (D&B) Processes with First Time Data Loading” on 
page 268)
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3 During the DNBUpMgrDNB or DNBUpMgrMultiTask server process, monitor the 
status by entering the list task command:

list task for comp DNB%

4 When the D&B Update Mgr (D&B) or D&B Update Mgr (Multi-task) server 
process is finished, open the log directory. If there have been problems with the 
process, there will be a log file, which you should review. The log files are named 
DNBUpMgrDNB_TaskNumber.log or DNBUpMgrMultiTask_TaskNumber.log.

To run the D&B Update Manager (Siebel) server component from a command line 
(single or multiple task process)

■ Follow the procedure “To run the D&B Update Manager (D&B) server component 
from a command line (single or multiple task process).” At the srvrmgr prompt 
(Step 2 on page 273), enter one of the following commands:

■ start task for comp DNBUpMgrSIEB (for single task process)

■ start task for comp DNBUpMgrMultiTask with DNBTaskCode=Siebel 
(for multitask process)
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Setting Up the Symbolic URL for Access to the D&B 
Database

When you have a connection to the Internet and have a D&B account set up already 
(with a user ID and password), you can:

■ Obtain the most current account information by invoking real-time searches of 
the D&B database and online purchase

■ Access and order D&B business and credit reports

For more information about D&B reports and about searching D&B for new 
accounts, see Siebel Call Center User Guide, MidMarket Edition.

To access D&B data live from your Siebel application through the D&B Web site, you 
must first contact D&B for a user ID, password, and payment options. Then you can 
set up your Siebel application to access the D&B database.

To set up the symbolic URL for D&B real-time search and update

1 From the application-level menu, choose View > Site Map > Integration 
Administration > Symbolic URL Administration.

2 In the Symbolic URL list, select DNBGlobalAccess.

3 Make sure the URL is https://globalaccess.dnb.com/access/scripts/broker.asp

4 In the Symbolic URL Arguments list:

a Select the USERID record, and enter the user ID provided by D&B in the 
Argument Value field.

NOTE: This field is not case-sensitive.

b Select the USERPASS record, and enter the password provided by D&B in the 
Argument Value field.

To set up the symbolic URL for D&B report ordering

1 From the application-level menu, choose View > Site Map > Integration 
Administration > Symbolic URL Administration.
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2 In the Symbolic URL list, select DNBReport.

3 Make sure the URL is https://reportserver/scripts/ProductRetriever and that the 
Host Name is www.dnb.com.

4 In the Symbolic URL Arguments list:

a Select the USERID record, and enter the user ID provided by D&B in the 
Argument Value field.

NOTE: This field is not case-sensitive.

b Select the USERPSWD record, and enter the password provided by D&B in 
the Argument Value field.

5 From the Show drop-down list, select Host Administration.

6 In the HTTP Host list, make sure that there is a record where Name is 
www.dnb.com and Virtual Name is reportserver.
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Additional Information for Configurators of D&B 
Integration

For general guidance on configuration, refer to Table 20.

A number of specific configuration topics are discussed in this section:

■ Update Server Process Configuration

■ Account Promotion and Prospect List Creation Configuration on page 278

■ Running the D&B Update Manager (Siebel) Process Without Updating Account 
Name or Account Location on page 279

Update Server Process Configuration
The D&B update server processes use the Batch Real-Time Integration (RTI) 
technology and the RTI configuration files (dnbmaps.sql for single task and 
dnbmaps.tsq for multiple tasks). You can edit the RTI configuration files to suit your 
business requirements. 

Table 20. What to Configure?

If You Need to Customize the… Then…

Single task server processes for D&B 
Update Manager (D&B) or D&B Update 
Manager (Siebel)

■ Edit the dnbmaps.sql file in the 
…\siebelserver\SQLTEMPL directory.

■ Determine and make, if necessary, 
corresponding changes for account 
promotion. 

Multiple task server processes for D&B 
Update Manager (D&B) or D&B Update 
Manager (Siebel)

■ Edit the dnbmaps.tsq file in the 
…\siebelserver\SQLTEMPL directory.

■ Determine and make, if necessary, 
corresponding changes for account 
promotion.

Account promotion ■ Configure the maps listed in Table 26.

■ Determine and make, if necessary, 
corresponding changes in the update 
server processes.
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The general syntax of the RTI maps specified in the configuration files is as follows:

UPDATE_SOME_TABLE.MOD1TABLE = [Target Table to update]

UPDATE_SOME_TABLE.MOD1WHERE = [A WHERE clause]

UPDATE_SOME_TABLE.MOD1INSERT = [TRUE/FALSE]

UPDATE_SOME_TABLE.MOD1UPDATE = [TRUE/FALSE]

UPDATE_SOME_TABLE.MOD1DELETE = [TRUE/FALSE]

UPDATE_SOME_TABLE.MOD1SQL = [A Valid SQL Query]

The RTI configuration files are located in the …\siebelserver\SQLTEMPL directory. 

“Field Mapping for the D&B Update Manager Process” on page 281 lists the default 
mapping for the D&B Update Manager (Siebel) server component.

Use caution when making changes to these RTI configuration files. It is 
recommended that you engage a qualified professional for your customization 
process.

CAUTION: Do not change the default DELETE setting in the existing UPDATE* 
sections. Do not set DELETE to TRUE. If your business need necessitates deleting 
rows in the target table as part of the D&B Update Manager process, consult Siebel 
Professional Services for help with this customization process.

Account Promotion and Prospect List Creation Configuration
You can select specific fields that will be populated by the D&B promotion to a 
Siebel account or by the D&B list-creation process. These are controlled by maps in 
the business component user properties within the DNB Account and DNB Contact 
business components. These maps are listed in Table 26 on page 287.

Using Siebel Tools, you can change, add, or delete source and destination field 
mapping. Reference the map descriptions given in Table 26 on page 287 to 
determine which map to use for a given set of source and destination fields. 
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Use caution when making changes to these maps. It is recommended that you 
engage a qualified professional for your customization process.

CAUTION: Although the delete capability is available, it is recommended that you 
deactivate unwanted map entries instead of deleting them. This is safer and can be 
accomplished by checking or clicking the deactivate column for the undesired entry.

You can add an entry using the following syntax:

Name Column: [MAP NAME]: [DESTINATION FIELD]

Value Column: [D&B SOURCE FIELD]

NOTE: Each map works only with a specific Destination Business Component and a 
specific Source Business Component.

Running the D&B Update Manager (Siebel) Process Without 
Updating Account Name or Account Location
Depending on your business process, you may want to run the D&B Update 
Manager (Siebel) server component without updating the existing account names 
and account locations. This is done by editing the RTI configuration file.

TIP: When debugging in your test environment, increase the event log level to 4 to 
see more details in the log file. However, it is strongly recommended that you set 
the level to 1 (the default) when you run in a production environment in order to 
prevent the log file from overflowing. For information on event logging, see Siebel 
Server Administration Guide, MidMarket Edition.

To edit the RTI configuration file so that account names are not updated

1 Open the RTI configuration file (dnbmaps.sql for single task or dnbmaps.tsq for 
multiple task) in a text editor.

2 Search for UPDATE_SIEBEL_ACCOUNT.MOD1SQL under the Oracle, Microsoft SQL 
Server, or DB2 SQL statements.
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3 Search for dnb.BUSINESS_NAME within the UPDATE_SIEBEL_ACCOUNT.MOD1SQL 
SELECT statement.

4 Comment out the line that begins dnb.BUSINESS_NAME… as shown.

UPDATE_SIEBEL_ACCOUNT.MOD1SQL = 

 SELECT acct.ROW_ID ROW_ID,

;dnb.BUSINESS_NAME NAME,

5 Save and close the file.

To edit the RTI configuration file so that account locations are not updated (single 
task)

1 Open the dnbmaps.sql file in a text editor.

2 Search for the UPDATE_SIEBEL = UPDATE_SIEBEL_ADDR_PHY… statement. This 
statement specifies the Siebel Table Groups to be updated when D&B Update 
Manager (Siebel) server component is run.

3 Within this statement, remove COMMIT, UPDATE_SIEBEL_LOC1, COMMIT, 
UPDATE_SIEBEL_LOC2, COMMIT, UPDATE_SIEBEL_LOC3.

4 Save and close the file.

To edit the RTI configuration file so that account locations are not updated 
(multiple task)

1 Open the dnbtask.cfg file in a text editor.

2 Under the [Siebel] section, comment out the line that begins Task5… as 
shown.

;;Task5 = UPDATE_SIEBEL_LOC1, COMMIT, UPDATE_SIEBEL_LOC2, COMMIT, 
UPDATE_SIEBEL_LOC3

3 Save and close the file.
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Field Mappings for Configuration of D&B Integration
This section provides field mapping information for three types of D&B integration 
processes:

■ Field Mapping for the D&B Update Manager Process

■ Field Mapping for D&B Real-Time Updates

■ Field Mapping for Account Promotion and Prospect Lists

Field Mapping for the D&B Update Manager Process
D&B Update Manager (D&B) server component. For the table mapping for the D&B 
Update Manager (D&B) component, examine the appropriate tables (Figure 9 on 
page 266) using Siebel Tools. The default field mappings can be determined by 
examining the UPDATE_DNB* sections of the RTI configuration file (dnbmaps.sql 
or dnbmaps.tsq).

D&B Update Manager (Siebel) server component. When the D&B Update Manager 
(Siebel) server component is run (Figure 10 on page 267), the fields listed in 
Table 21, Table 22 on page 283, and Table 23 on page 283 are mapped. The field 
mappings can also be determined by examining the UPDATE_SIEBEL* sections of 
the RTI configuration file.

For information about changing these default mappings, see “Update Server Process 
Configuration” on page 277.

Table 21. S_DNB_ORG Table Mapping for D&B Update Manager (Siebel)

From Column To Table To Column

DUNS_NUM S_ORG_EXT DUNS_NUMBER

BUSINESS_NAME S_ORG_EXT NAME

TRADESTYLE S_ORG_SYN NAME

SCND_TRADESTYLE S_ORG_SYN NAME

PHYS_STREET_ADDR       S_ADDR_ORG ADDR

SECOND_STREET_ADDR     S_ADDR_ORG ADDR
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PHYSICAL_CITY          S_ADDR_ORG CITY

PHYSICAL_STATE         S_ADDR_ORG PROVINCE or STATE

PHYSICAL_ZIP           S_ADDR_ORG ZIPCODE

COUNTRY_NAME S_ADDR_ORG COUNTRY

COUNTY_NAME S_ADDR_ORG COUNTY

MAIL_ADDRESS S_ADDR_ORG ADDR

MAIL_ADDRESS_2 S_ADDR_ORG ADDR

MAIL_CITY S_ADDR_ORG CITY

MAIL_STATE S_ADDR_ORG STATE

MAIL_ZIP S_ADDR_ORG ZIPCODE

TELEPHONE S_ORG_EXT PH_NUM

FAX_NUMBER S_ORG_EXT FAX_PH_NUM

ANNL_SLS_AMT S_ORG_EXT_X ATTRIB_14

CURRENCY_CODE S_ORG_EXT BASE_CURCY_CD

EMPLOYEES_TOTAL S_ORG_EXT_X ATTRIB_26

EMPLOYEES_HERE S_ORG_EXT EMP_COUNT

YEAR_STARTED S_ORG_EXT_X ATTRIB_27

LOC_TYPE_STAT_IND S_ORG_EXT included in LOC

PUBLIC_PRIVATE_IND S_ORG_EXT_X ATTRIB_08

GLBLULT_DUNS_NUM S_ORG_EXT GLBLULT_DUNS_NUM

DOM_ULT_DUNS_NUM       S_ORG_EXT DOM_ULT_DUNS_NUM

PAR_DUNS_NUM           S_ORG_EXT PAR_DUNS_NUM

LINE_OF_BUSINESS S_ORG_EXT_X ATTRIB 03

PCT_GROWTH_SLS_3YR     S_ORG_EXT_X ATTRIB_15

Table 21. S_DNB_ORG Table Mapping for D&B Update Manager (Siebel)

From Column To Table To Column
282 Applications Administration Guide MidMarket Edition Version 7.5, Rev. A



D&B Integration

Field Mappings for Configuration of D&B Integration
The S_PRSP_CONTACT table contains information about the D&B contacts such as 
the name of the CEO and various company executives. D&B provides up to four 
contacts per D&B account.

The S_DNB_ORG_SIC table contains the Standard Industrial Classification (SIC) 
code developed by the US Government. The code is assigned to businesses and 
other organizations by classifying and subdividing the activity performed by that 
establishment at that location. D&B provides up to six SICs per D&B account. In the 
D&B Update Manager process, the primary SIC code is mapped to the S_INDUST 
table and all SIC codes are mapped to the S_ORG_INDUST table.

Table 22. S_PRSP_CONTACT Table Mapping for D&B Update Manager

From Column To Table To Column

LAST_NAME S_CONTACT LAST_NAME

FST_NAME S_CONTACT FST_NAME

MID_NAME S_CONTACT MID_NAME

PER_TITLE S_CONTACT PER_TITLE

PER_TITLE_SUFFIX S_CONTACT PER_TITLE_SUFFIX

JOB_TITLE S_CONTACT JOB_TITLE

SEX_MF S_CONTACT SEX_MF

Table 23. S_DNB_ORG_SIC Table Mapping for D&B Update Manager

From Column To Table To Column

ROW_ID S_INDUST PR_INDUST_ID

S_ORG_INDUST  INDUST_ID
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Table 24 describes how address and contact information is updated by the D&B 
Update Manager (Siebel) process.

Field Mapping for D&B Real-Time Updates
When you purchase account information through the D&B Web site using the D&B 
real-time search and update feature in the Siebel application, certain fields in the 
Siebel business components are populated. These fields are a subset of the fields 
that are populated by the D&B Update Manager (D&B) server component. For 
example, D&B does not provide the contact first, last, and middle names fields in 
the real-time update.

Table 24. Update Rules for Addresses and Contacts

If This D&B Information Changes... Then...

Street address

City

(Abbreviated) state

A new address record is added to the 
Address table.

Address information other than street 
address, city, or state

The address record is updated in the 
Address table.

Phone number

Fax number

The address record is updated in the 
Address table.

Contact first name or

Contact last name

A new contact record is added to the 
Contact table.

Contact information other than first or last 
name

The contact record is updated in the Contact 
table.
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Table 25 lists the fields that may be populated or updated when you purchase 
account information using the D&B real-time search and update feature.

Table 25. Fields Populated by D&B Real-Time Search and Update

D&B WorldBase Marketing Plus with 
Linkage Siebel Business Component Name.Field Name

Business Structure Code (Location 
Type)

DNB Account.Location Type

Domestic Ultimate Name DNB Account.Domestic Ultimate Business 
Name

Global Ultimate Name DNB Account.Global Ultimate Business Name

Parent/HQ Business Name DNB Account.Parent HQ Name

Physical State DNB Account.State Name

Business Name DNB Account.Business Name

Trade Style DNB Account.Trade Style

Street Address DNB Account.Physical Address

Mail Address DNB Account.Mail Address

City Name DNB Account.Physical City

Mail City Name DNB Account.Mail City

Physical State/Province Abbreviation DNB Account.Physical State

Mailing State/Province Abbreviation DNB Account.Mail State

ZIP/Postal Code DNB Account.Physical Zip

Mail Postal/ZIP Code DNB Account.Mail Zip

Country Name DNB Account.Country Name

D&B D-U-N-S Number DNB Account.DUNS Number

Telephone Number DNB Account.Main Phone 2

Cable/Telex Code DNB Account.Cable Telex Number

Facsimile Number DNB Account.Main Fax 2
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Field Mapping for Account Promotion and Prospect Lists
When end users promote D&B accounts or create prospect lists from the D&B 
screen, fields in the DNB Account and DNB Contact business components are 
mapped to fields in other business components. These maps are listed in Table 26 
and can be viewed in detail in the Business Component User Properties window of 
Siebel Tools.

National ID DNB Account.National Identification Number 2

SIC Code DNB Account.SIC Code

Primary Local Activity Code DNB Account.Primary Local Activity Code

Year Started DNB Account.Year Started 1

Employees Here DNB Account.Employee Here

Employees Total DNB Account.Employee Total

Annual Sales US Dollars DNB Account.Sales Volume

Annual Sales Local DNB Account.Annual Sales Local Currency

Legal Status DNB Account.Legal Status

Subsidiary Code DNB Account.Subsidiary Indicator

Import / Export / Agent Ind. DNB Account.Import Export Code

Global Ultimate D&B D-U-N-S Number DNB Account.Global Ultimate DUNS

Global Ultimate Indicator DNB Account.Global Ultimate Indicator

Global Ultimate WorldBase Country 
Code

DNB Account.Global Ultimate Country Code

Domestic Ultimate D&B D-U-N-S 
Number

DNB Account.Domestic Ultimate DUNS

Headquarter/Parent D&B D-U-N-S 
Number

DNB Account.Parent HQ DUNS

HQ/Parent WorldBase Country Code DNB Account.Parent/HQ Country Code

Table 25. Fields Populated by D&B Real-Time Search and Update

D&B WorldBase Marketing Plus with 
Linkage Siebel Business Component Name.Field Name
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For information about promoting accounts and creating prospect lists, see Siebel 
Sales User Guide, MidMarket Edition.

Table 26. Maps of D&B to Siebel Fields for Promotion and List Creation

User Property 
Prefix and Map 
Name

D&B Source 
Business 
Component

Siebel 
Destination 
Business 
Component Process and Description

Account Map DNB Account Account Promotion

Specifies the fields in DNB 
Account that will be copied to 
Account business component

Contact Map DNB Contact Contact Promotion

Specifies the fields in DNB 
Contact that will be copied to 
Contact business component

Mailing Address 
Map

DNB Account Business 
Address

Promotion

Specifies the mailing address 
fields in DNB Account that will 
be copied to Business Address

Physical Address 
Map

DNB Account Business 
Address

Promotion

Specifies the physical address 
fields in DNB Account that will 
be copied to Business Address

Prospect Info Map DNB Contact List Mgmt 
Prospective 
Contact

Create Prospect List

Specifies the biological 
information (such as last name, 
first name, and so forth) 

Prospect Contact 
Info Map

DNB Account List Mgmt 
Prospective 
Contact

Create Prospect List

Specifies the contact information 
(such as company, address, 
phone number, and so forth) 
fields in the DNB Account that 
will be copied into the List Mgmt 
Prospective Contact
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ASIs allow you to integrate Siebel applications with other applications in real time. 

The Accounts or Contacts screens use ASIs to exchange data with any external 
system such as a back-office application. These are listed in Table 27.

You must set up these ASIs shipped with your Siebel application before they can be 
used. This chapter provides the procedures that you must perform to set up these 
ASIs. Depending on your business needs, you may choose to set up ASIs and 
activate workflows for some or all of the GUI commands listed in Table 27.

For general information about ASIs, see Application Services Interface 
ReferenceApplication Services Interface Reference: Siebel eBusiness Application 
Integration Volume VI, MidMarket Edition.

Table 27. ASIs for Accounts and Contacts

Screen GUI Command Workflow
Outbound and 
Inbound ASI Pairs

End-User 
Information

Accounts Update External 
System

Synchronize 
Account ASI

External Account

Siebel Account

Siebel Call Center 
User Guide, 
MidMarket Edition

Siebel Sales User 
Guide, MidMarket 
Edition

Accounts (Credit 
Profile view)

Refresh Get Account ASI

Contacts Update External 
System

Synchronize 
Contact ASI

External Contact

Siebel Contact

Siebel Call Center 
User Guide, 
MidMarket Edition

Siebel Sales User 
Guide, MidMarket 
Edition
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Setting Up Account and Contact ASIs
This section describes how to set up the prebuilt ASIs for Accounts and Contacts:

1 Set up outbound and inbound Web services. See Setting Up Web Services for 
Account and Contact ASIs.

2 Activate workflows. See Activate Workflows for Account and Contact ASIs on 
page 292.

Other tasks you may want to perform are:

■ Extending ASIs. See Application Services Interface ReferenceApplication Services 
Interface Reference: Siebel eBusiness Application Integration Volume VI, 
MidMarket Edition.

■ Deactivating fields in the ASIs. See Application Services Interface 
ReferenceApplication Services Interface Reference: Siebel eBusiness Application 
Integration Volume VI, MidMarket Edition.

■ Customizing ASI workflows. See Siebel Business Process Designer Administration 
Guide, MidMarket Edition.

Setting Up Web Services for Account and Contact ASIs
To set up the Web services, you must set up both outbound and inbound Web 
services for the ASIs. The procedures below show you the steps required for each 
ASI.

To set up an outbound Web service

1 From the application level menu, choose View > Site Map > Web Services 
Administration > Outbound Web Services. 

2 In the Outbound Web Services list, create a query to display the record with 
External Account or External Contact in the Name field.
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3 Verify that the fields in the Outbound Web Services list match those in the 
following table. 

4 In the Service Ports list, click New, and enter the following values in the fields 
of the new record.

To set up an inbound Web service

1 From Show drop-down list, select Inbound Web Service. 

2 In the Inbound Web Service list, create a query to display the record with Siebel 
Account or Siebel Contact in the Name field.

Namespace Name Status

http://siebel.com/asi/ One of the following:

External Account

External Contact

Active

Field Comments

Name Enter a name for the port.

Port Type Enter External Account or External Contact.

Transport Select from the drop-down list.

Address When you select a transport, the field will be populated with a 
template address. Edit the address based on where you are sending 
the data.

Binding If a SOAP header is expected by the receiving application, select 
SOAP_RPC.
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3 Verify that the fields in the Inbound Web Services list match those in the 
following table. 

4 In the Service Ports list, review the information in the fields for the service port 
and make any changes required for your system.

5 In the Operations list, review the information shown and make any changes 
required for your system.

Activate Workflows for Account and Contact ASIs
You must activate the following workflow processes used for real-time integration 
of account and contact data:

■ Synchronize Account ASI

■ Get Account ASI

■ Synchronize Contact ASI

For a description of these workflows, see “ASI Workflow Descriptions” on page 294.

To activate workflows used by Account and Contact ASIs

1 From the application level menu, choose View > Site Map > Business Process 
Administration > Workflow Processes.

2 In the Workflow Processes list, use a query to find all processes where the Name 
field contains the word ASI. You can query on *ASI*.

3 For the workflows listed above, activate each workflow process that has the 
status Inactive.

a Select the workflow process record.

Namespace Name Status

http://siebel.com/asi/ One of the following:

Siebel Account

Siebel Contact

Active
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b Click Revise.

A copy of the workflow process record is created with a status of In Progress. 
The copy is automatically selected.

c Click Activate. 

d Verify that the Status is Active. 

4 When you are finished activating the workflow processes, restart the server. 

For more information about workflow processes, see Siebel Business Process 
Designer Administration Guide, MidMarket Edition.
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ASI Workflow Descriptions
This section describes the workflow processes that are used to invoke the ASIs for 
account processes. The Synchronize Contact ASI process is essentially the same as 
the Synchronize Account ASI process, except that contact replaces account.

It is not necessary to modify these workflows, but you can modify them to suit your 
business model. 

Synchronize Account ASI
This workflow submits the account information to the outside system to 
synchronize the information between the two systems.

■ Query For Account By Id: Queries for the account on the current system using 
the object ID. Returns an account property set containing the account 
information.

■ External Account Proxy: Calls the Synchronize method on the outside system, 
passing in the account property set. This step returns an account property set, 
which will contain any changes the outside system made to the account.

■ Synchronize Account: Takes the account property set returned by the previous 
step and synchronizes it with the account in the current system.

Get Account ASI
This workflow queries the outside system to retrieve the latest information on the 
account. It returns the new information and synchronizes the account on the 
current system.

■ Query Account By Id: Queries for the account on the current system using the 
object ID. Returns an account property set containing the account information.

■ Isolate Integration Id: In the next step, the workflow uses a query by example. 
Query by example takes the property set and looks for an account with exactly 
the same values for the fields in the property set. If the account has changed on 
the outside system, those values will no longer match. The workflow needs to 
query by a value that does not change, that is, the integration ID. Isolate 
Integration Id takes in a property set and removes all the fields, except the 
integration ID.
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■ External Account Proxy: Using the property set, which only has an integration 
ID now, this step queries by example on the outside systems. Once it finds the 
account with that integration ID, it returns an account property set containing 
the account information.

■ Synchronize Account: Takes the account property set returned by the previous 
step and synchronizes it with the account in the current system.
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Table 28 lists the system preferences provided throughout your Siebel applications. 
For information about how to change system preferences, see Chapter 3, “Ongoing 
Application Administration Tasks.”

Table 28. System Preferences

Preference Description

Alarm Manager Load Frequency Number of minutes the system waits before rechecking for alarms.

Default: 60

AllocationRule Not applicable.

Always Show Message Bar Alerts Display message even if the message bar is turned off. Default: False

Auto Mgr Calendar Access Allow employee’s manager access to the employee’s calendar, even if 
the employee does not explicitly give the manager access.

Default: False

BucketAvailCDtobeCounted Not applicable.

BucketStatusCDtobeCounted Not applicable.

CSM Logging Enables logging of merge transactions. Merge transactions are created 
when connected users combine or merge two or more business 
components such as accounts or opportunities into one.

Information from this log can be used to relink orphaned records 
created when the merge process is crossed with an update process 
during a synchronization. 

This is only applicable if the installation uses Siebel Remote.

Default: False

DB2: Default Opt Level Default optimization level which defines the optimizing algorithm that 
DB2 will use to execute SQL statements.
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DBX Vis Rules per Statement 1 Number of visibility or routing rules checked per SQL statement 
processed by the Database Extract component for the first SQL 
statement with header information.

DBX Vis Rules per Statement N Number of visibility or routing rules checked per SQL statement 
processed by the Database Extract component for other SQL 
statements.

Default Campaign Source Code Default campaign for Web offers used in Siebel eCampaigns. All offers 
that are a part of the default campaign will appear in the Featured 
Offers Applet in Siebel eCampaigns.

Default Offer Code Code to track the click path of a customer on the eCampaigns Web site 
who does not select a specific offer.

Default Time Zone Default time zone for all users of that database.

When a user logs in, the Time Zone field of the User business 
component is checked. If it is empty, the Default Time Zone system 
preference is checked.

Default: UTC

DefaultFulfillInvloc Value that represents the default inventory location to use as a source 
inventory location for the Fulfillment Engine and Part Locator. Used as 
the Source Inventory Location if the user does not specify a Source 
Inventory Location at run time. 

The value must be the Row ID of the service inventory location. To find 
this ID, use the following procedure:

1. In any Service Inventory view, select an inventory location.

2. From the Help menu, select About Record.

3. In the dialog box, click Details.

The Row # field contains the Row ID.

For more information, see Siebel Service Guide, MidMarket Edition.

Docking: Get All PostnCon rows Enables the Transaction Router and Database Extract component to get 
all records in S_POSTN_CON table for a contact. Use this parameter to 
improve Siebel Remote performance. For more information, see Siebel 
Remote Administration Guide, MidMarket Edition.

Default: False 

Table 28. System Preferences

Preference Description
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Docking: Transaction Logging Enables docking transaction logging.

For more information, see Siebel Remote Administration Guide, 
MidMarket Edition.

Default: False

eAuc:AllowTimeStampAdvantage Not applicable.

eAuc:AsyncNoticeCalls Not applicable.

eAuc:AuctionURLRoot Not applicable.

eAuc:AutoApproveBidder Not applicable.

eAuc:AutoApproveLister Not applicable.

eAuc:AutobidToReservePrice Not applicable.

eAuc:BidIncrementMultiple Not applicable.

eAuc:BidIncrMultipleTolerance Not applicable.

eAuc:BidTimeTieBreakOption Not applicable.

eAuc:DynamicCloseEnabled Not applicable.

eAuc:DynamicCloseMaxDelay Not applicable.

eAuc:EnforceExactBidIncrement Not applicable.

eAuc:MaxMoneyValueAccepted Not applicable.

eAuc:MaxRatingsPerSale Not applicable.

eAuc:MaxThirdPartyListingDays Not applicable.

eAuc:Notice Wf-Auction Alert Not applicable.

eAuc:Notice Wf-Autobid Not applicable.

eAuc:Notice Wf-Bid Not applicable.

eAuc:Notice Wf-ListerBidAccept Not applicable.

eAuc:Notice Wf-ListerClose Not applicable.

eAuc:Notice Wf-ListerInvoiced Not applicable.
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eAuc:Notice Wf-Outbid Not applicable.

eAuc:Notice Wf-PartialOutbid Not applicable.

eAuc:Notice Wf-UserStatus Not applicable.

eAuc:Notice Wf-UserWelcome Not applicable.

eAuc:Notice Wf-Winner Not applicable.

Entitlement: Verify Consumer Check the authorization of the contact requesting service. If preference 
is set to TRUE, the entitlements displayed must meet one of these 
criteria:

■ The contact for the entitlement matches the service request 
contact.

■ The entitlement account is set to All Contacts, and the entitlement 
account matches the service request account or the account for the 
contact for the service request. 

If no contact is selected, Siebel Service tries to verify the entitlement 
using the other entitlement settings.

For more information, see Siebel Service Guide, MidMarket Edition.

Entitlement: Verify Dates Check that the service request falls within the time span of the 
entitlement. If the preference is set to TRUE, then the entitlements 
displayed are only those that provide coverage on the date the service 
request was opened: a date between the start and end dates for the 
entitlement.

If the entitlement has no start or end date, it is not displayed.

For more information, see Siebel Service Guide, MidMarket Edition.
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Entitlement: Verify Product Check that the asset or product is entitled to service. If the preference 
is set to TRUE, the agreements displayed must meet one of these 
criteria:

■ The entitlement asset matches an asset in the service request.

■ The entitlement product matches a product in the service request 
(no asset or serial number specified).

■ The entitlement is set to All Products and the product or asset for 
the entitlement matches the product or asset for the service 
request.

If no product is selected, Siebel Service tries to verify the entitlement 
using the other Entitlement settings.

For more information, see Siebel Service Guide, MidMarket Edition.

ETL Analysis End

ETL Analysis Start

ETL Date Format

ETL Date format indicates the way dates need to be interpreted. The 
other two parameters mention the date range for which the Exchange 
Rates will be adjusted. This does not indicate that only the data created 
within this range will be extracted. Select the earliest date for the 
Analysis Start Date—that is, when the transactions may have begun. 
In addition to considering the created and modified dates, consider 
other relevant dates such as order date. Setting this to an early value 
such as 19700101 (January 1, 1970) does not affect the processing time. 
A similar logic applies for choosing Analysis End Date. Note that the 
values need to be entered in the format defined by ETL Date Format.

Default Analysis End: 20101231

Default Analysis Start: 19940101

Default Date Format: YYYYMMDD.

ETL Base Exchange Currency Currency in which all the financial data will be converted. While the 
OLTP supports transactions in many different currencies, the data in 
the OLAP is converted to a single currency for analysis purposes. The 
Exchange rates are derived from the Exchange Rates table in the OLTP. 

Default: USD.

ETL Default Continent Value for any address that does not have Continent defined. Set this to 
a value, which will be used if the value of Continent is not defined in 
the OLTP. 

Default: North America.
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ETL Default Country Value for any address that does not have the Country defined. Set this 
to a value, which will be used if the value of Country is not defined in 
the OLTP. 

Default: USA.

ETL Default Currency Value for currency code that will be used if the currency code for a 
specific financial transaction is not set. 

Default: USA.

ETL Default Language Language code used when language translation occurs when looking 
up the List of Values table. 

Default: ENU.

ETL LOV Maximum Value

ETL LOV Minimum Value

In some fields, bucketing of values happens. Instead of saying the 
number of employees at an account is 45, 96, the values can be 
bucketed to 0-50, 50-100 and so on. In the List of Values, if the 
minimum and maximum values are not specified, the values of these 
parameters will be used.

Defaults: 9999999999 and 0.

ETL Unknown Exchange Rate Value used when an exchange rate for a currency to the Datamart 
Default Currency is undefined in the OLTP. 

Default: 1.

Forecast: Auto-Forecast Creates subordinates’ forecasts to be used in a rollup forecast, if the 
subordinates have not created forecasts themselves.

Forecast: Use Server Task Send forecast processing requests to the Siebel Server for batch 
processing. If the value is False, requests are processed locally.

FSDB:Override Service Region Maximum monetary value accepted in Bid and Fee currency fields.

FSPrevMnt: Def Act Owner ID Not applicable.

FSPrevMnt: Default Org ID Not applicable.

LOGMGR:Vis Rules per Statement Set to 50 by default. For implementations that use any database other 
than Oracle, you should change this value to 20.

MRG:Docking Timestamp Source Specifies whether the timestamp is based on the time a change was 
made on the client or on the server. For more information, see Siebel 
Remote Administration Guide, MidMarket Edition.
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MRG:System Conflict Resolution Sets the rule to be used for resolving database update conflicts. The 
rule may be either Server Wins (the default) or Client Wins. For more 
information, see Siebel Remote Administration Guide, MidMarket 
Edition.

MRG:Txns per Commit Number of database transactions the Transaction Merger processes 
before it issues a database commit. Setting a low value (1) reduces the 
frequency with which users encounter a locked database row and 
reduces the risk of deadlock. Setting a high value (10) minimizes 
processing overhead. 

For more information, see Siebel Remote Administration Guide, 
MidMarket Edition.

Default DB2: 10.

Default Microsoft SQL Server: 1.

Default Oracle: 1.

MRG:User Friendly Notification Determines whether Siebel Remote writes information about database 
updates to the Siebel Remote Status view on the Mobile Web Client. If 
the value is TRUE, Siebel Remote writes information about database 
updates. If the value is CONFLICTS, Siebel Remote writes information 
about database updates that caused conflicts. If the value is FALSE, 
Siebel Remote does not write any information about database updates.

For more information, see Siebel Remote Administration Guide, 
MidMarket Edition.

OrderItemStatusForOnOrderQty Specifies the valid values for the existing order item status. The values 
should be from the Order Item Status LOV and individual values 
should be language independent values (LIVs).

For more information, see Siebel Service Guide, MidMarket Edition.

OrderItemStatusToBeFulfilled Specifies the valid values for Order Item Status. The values are from 
the Order Item Status LOV and the individual values are language 
independent values (LIVs).

For more information, see Siebel Service Guide, MidMarket Edition.

OrderStatusForOnOrderQty Specifies the valid values for the existing order status. The values 
should be from the Order Status LOV and individual values should be 
LIVs.

For more information, see Siebel Service Guide, MidMarket Edition.
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OrderStatusToBeFulfilled Specifies the valid values for Order Status. The values should be from 
the Order Status LOV and individual values can be any of the language 
independent values (LIVs).

For more information, see Siebel Service Guide, MidMarket Edition.

OrderTypeForOnOrderQty Specifies the valid values for the existing order type. The values should 
be from the Order Type LOV and individual values should be language 
independent values (LIVs).

For more information, see Siebel Service Guide, MidMarket Edition.

OrderTypeToBeFulfilled Specifies the valid values for Order Type. The values should be from 
the Order Type LOV and individual values can be any of the language 
independent values (LIVs).

For more information, see Siebel Service Guide, MidMarket Edition.

ReplenishOrderPriority Specifies the default order priority. The values should be from the 
Order Priority LOV and individual values should be language 
independent values (LIVs).

For more information, see Siebel Service Guide, MidMarket Edition.

Satmetrix Key Value A string provided by Satmetrix to customers of Siebel Satmetrix 
eSurveys. Required for generating encrypted tokens that are part of 
URLs for displaying survey reports.

Sch:Break Time Id Specifies the Row ID of the work type to be used when calculating the 
schedule cost where activities contain breaks. The default value is -1. 

To find the Row ID, navigate to the Application Administration
screen > Work Type Administration view, select the record, choose 
About Record from the Help menu, and note the Row # value. 

Sch:Default Constraint Set Specifies the Row ID of the constraint set to be used where no 
constraint set is associated with the service region loaded. The default 
value is -1. 

To find the Row ID, navigate to the Scheduling Administration
screen > Constraint Sets view, select the record, select About Record 
from the Help menu and note the Row # value.
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Sch:Default Cost Function Specifies the Row ID of the cost function to be used where no cost 
function is associated with the service region loaded. The default value 
is -1. 

To find the Row ID, navigate to the Scheduling Administration screen 
> Cost Functions view, select the record, select About Record from the 
Help menu and note the Row # value.

Sch:Default Parameter Set Specifies the Row ID of the parameter set to be used where no cost 
function is associated with the service region loaded. The default value 
is -1. 

To find the Row ID, navigate to the Scheduling Administration
screen > Parameter Sets view, select the record, select About Record 
from the Help menu and note the Row # value.

Sch:Default Time Window Specifies the Row ID of the time window to be used where no cost 
function is associated with the service region loaded. The default value 
is -1. 

To find the Row ID, navigate to the Scheduling Administration screen 
> Time Window view, select the record, select About Record from the 
Help menu and note the Row # value.

SecExternalUserAdministration An entry of FALSE allows administration of the directory through the 
Siebel application. For more information, see Security Guide for Siebel 
eBusiness Applications, MidMarket Edition.

SecThickClientExtAuthent Allow changes to user data done on the dedicated client to propagate 
to the directory. Set this parameter to TRUE only on the dedicated Web 
client.

For more information, see Security Guide for Siebel eBusiness 
Applications, MidMarket Edition.

Security Adapter CRC Calculate the checksum value for your security adapter DLL, and enter 
the calculated value here. 

For more information, see Security Guide for Siebel eBusiness 
Applications, MidMarket Edition.

SM WebIntelligence Server The URL that points to the Web Intelligence server that serves up 
reports for Siebel Analytics.
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SqlStyle Indicate which SQL statements are to be used with this 
implementation—Oracle, Microsoft SQL Server, Informix, or Sybase. 
Case-sensitive.

SubSqlStyle An SQLStyle that falls within a family of similar database products.

Technical Support (Alt. 1) Specifies the telephone numbers to display in the Siebel Technical 
Support dialog box. Update this number to match your internal help 
desk number. The alternate numbers (Alt. 1 and Alt. 2) provide 
expansion for pager numbers and email addresses. 

Set a value to None to leave it blank in the dialog box.

Technical Support (Alt. 2) Specifies the telephone numbers to display in the Siebel Technical 
Support dialog box. Update this number to match your internal help 
desk number. The alternate numbers (Alt. 1 and Alt. 2) provide 
expansion for pager numbers and email addresses. 

Set a value to None to leave it blank in the dialog box.

Technical Support (FAX) Specifies the fax number to display in the Siebel Technical Support 
dialog box. Update this number to match your internal help desk fax 
number. 

Set a value to None to leave it blank in the dialog box.

Technical Support (URL) Specifies the support URL to display in the Siebel Technical Support 
dialog box. Update this URL to match your internal help desk Web 
address. 

Set a value to None to leave it blank in the dialog box.
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Technical Support (Voice) Specifies the voice number to display in the Siebel Technical Support 
dialog box. Update this number to match your internal help desk 
number. 

Set a value to None to leave it blank in the dialog box.

Universal Time Coordinated Turns on global time zone support for the entire system. Set this 
preference to TRUE to enable global time zone support. The default 
setting is TRUE.

Note: This is a one-time setting. Once you have turned on global time 
zone support in a production environment, you should not turn it off.

If you intend to operate your deployment with the Global Time Zone 
feature enabled, you must also set the operating system of your 
database servers to UTC time, or its equivalent. Failure to set the OS to 
UTC when the UTC parameter is set to TRUE will result in 
asynchronous server request errors.

For more information on enabling Global Time Zone, see Global 
Deployment Guide, MidMarket Edition. Although enabling this feature 
is optional, it is strongly recommended that you operate your 
production environment with Global Time Zone enabled.
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opportunity inactive notification process, 

about 146
opportunity lost notification process, 

about 147
opportunity reroute activity, setting up 

149
opportunity won notification process, 

about 148
opportunity workflow email, modifying 

the language of 150
opportunity workflows, setting up 

(procedure) 145
time lapse between lead acceptance and 

inactive notification, changing 146
time lapse between lead assignment and 

email delivery, modifying 147
Oracle, loading D&B data on 260
organization

custom hierarchy, assigning to 139
guide, of 10
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P
pager company, setting up 67
Parent LIC attribute

list of values, about making values 
hierarchically dependent 101

parent Area, about changing 104
parent Web browser, adding 87
password and default user ID 14
payment terms, setting up (procedure) 58
periods, setting up

about 59
period units, associating with a period 60
setting up (procedure) 59

pick lists. See dynamic pick lists; static pick 
lists

predefined queries, setting up
about 45
creating by saving a query 45
Predefined Query view, setting up 

predefined query in 46
preferences, system (table of) 297
price lists

currency conversion 54
printing

batch printing correspondence 224
batch printing, about setting up 225
client-based batch printing, changing 

default printer 230
client-based printing, printing documents 

(procedure) 230
DocServer machine, adding printer 

connection to 228
Internet Explorer, configuring to allow 

client-batch printing 229
printing connection, adding to your 

desktop 230
server print menu items, adding on 

Correspondence and Fulfillment 
screens 226

server-based batch printer, changing 
default printer 228

server-based batch printing, specifying a 
printer 231

server-based printing, printing 
(procedure) 231

projects, currency conversion 54
See also currency conversion, setting up

Q
queries

telephone number, examples (table) 65
quotes, about changing currency code 54

See also currency conversion, setting up

R
rate lists, about currency conversion 54

See also currency conversion, setting up
remote. See Siebel Remote
replication (Siebel Replication), about using 

audit trail 106
reports

currency conversion supported in 54
resources, about 175

See also calendar
retroactive alarms, about changing the 

number of days 184

S
SADMIN ID, about modifying responsibility 

14
sales methods

about 161
creating and associated sales stages 165

sales stage, defining 166
sample database, about and logging in 22
Satmetrix survey reports, setting up

about 40
access to Satmetrix Reports, setting up 

symbolic URL for 41
WI_ARG-TYPE, extending the List of 

Values for 40
script, sample message broadcasting script 

124
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seed data
about 23
list of values, modifying 98

server database, about 22
server-based batch printing

See also printing
about 224
configurating printers for 227
default printer, changing 228
DocServer machine, adding a printer 

connection 228
documents, printing 231
printer, specifying 231

setup tasks
application administration tasks, table of 

24
employee setup, completing (list of) 31
employee setup, completing (procedure) 

32
locale name, creating translation for 39
locales, about setting up 35
locales, creating (procedure) 35
Satmetrix survey reports, setting up 40
skills, associating with an organization 34
summary of (table) 28
views, defining 30

severity levels, about using for message 
broadcasting 121

ShowMessageBar parameter, about setting 
to true 118

SIC (Standard Industrial Classification code) 
file, about and D&B data 257

Siebel applications, hiding access to license 
keys 21

Siebel correspondence. See correspondence
Siebel Dedicated Web Client. See dedicated 

Web clients
Siebel Document Server

additional logging, enabling 203
application recycle period, configuring 

202
component group, about enabling 201

components, about synchronizing step 
201

configuration process overview 201
hardware requirements 199
HTML generation, about enabling 201
HTML generation, enabling (procedure) 

202
installation process overview 199
Siebel Server, about installing on 

dedicated host machine 199
steps to install 199
target server, specifying 203

Siebel eBriefings
eBriefing Bulletin, about option to 

distribute messages as bulletins 119
Siebel License Tracking

See also Siebel License Tracking, setting 
up

business scenario 188
concurrent client usage, viewing 194
licenses tracked, types of 187
process flows for license tracking, 

example 189
users, viewing named users 192

Siebel License Tracking, setting up
See also Siebel License Tracking
Client Administration, configuring on or 

off at restart 190
Client Administration, turning on or off 

190
usage exception workflows, configuring 

190
Siebel Literature

category, associating literature with a 
category using the Catalog 
Administration screen 249

category, associating literature with a 
category using the Literature 
Administration screen 248

existing literature file, modifying 235
item kits, about and fulfillment center 240
literature files, creating new 235
literature item kit, adding 241
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literature kits, about 233
literature record, adding 236
sharing literature though the 

Correspondence screen 247
sharing though the Product screen 244
sharing through the Competitors screen 

245
translated document, associating with a 

literature record 239
Siebel objects, association with activity 

objects (table) 159
Siebel OLE Automation, about 123

See also message broadcasting
Siebel Remote

audit trail, about using 106
Siebel Correspondence, system 

requirements 198
Siebel Replication, about using audit trail 

106
Siebel Sales Activity Plans

new sales method, defining 165
sales methods, described 161
sales stage, defining 165

Siebel Tools
Audit Trail Engine business service, 

enabling 108
audit trail, configuring customer 

application for 108
license keys, entering additional using 

Tools 19
license keys, hiding access to 21

Siebel Web Client
application-wide case insensitivity, 

enabling 80
starting application, first time 15

skills
about assigning 34

software required, table 13
.sql (dnbinitial.sql), using to load D&B data 

268
Standard Industrial Classification code, 

about and D&B data 257
static pick lists

about 89
constraining, about 101

Synchronization Account ASI, about 294
system preferences

setting 44
table of 297

T
TAS Customer Milestone activity template, 

creating in a localized application 173
telephone formats, specifying

See also telephone numbers
default telephone formats, about 61
EIM, about importing information with 

66
international telephone formats, about 

entering and format logic 63
non-North American telephone formats, 

specifying 62
North American telephone formats, 

default format for 61
querying for telephone numbers, table of 

examples 65
telephone number format examples 

(table) 64
telephone numbers, entering numbers in 

place of digits 64
unformatted telephone numbers, about 

adding or changing number format 64
telephone numbers

See also telephone formats, specifying
caution, entering letters in place of digits 

64
Telocator Alphanumeric Protocol (TAP), 

pager support of 67
third-party applications. See Microsoft 

Office; Microsoft PowerPoint; Microsoft 
Word

time zone support, administering
about 69
date and time stamps, about 71
time zone settings, modifying 69
translations of time zones, maintaining 70
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To Do List, removing from the calendar view 
184

U
[U] urgent message, severity level 121
Usage Exception workflows, configuring 

190
user ID and password, default 14

V
views

defining, about and procedure 30

W
Web browser

additional, adding Web browsers 86
capabilities, about adding 84
capability, adding (procedure) 85
child Web browser, adding 88
extended capabilities, list of 85
parent Web browser, adding 87
required browser capabilities 86

Web Client
Siebel Correspondence, system 

requirements 198
workflows

communications profile, setting up 144
Create Rerouted Oppty Activity, setting up 

149
delivery of emails, restricting conditions 

for 151
email notifications, stop sending 151
Get Manager Email process, setting up 

153
opportunity assigned notification process, 

about 146
opportunity inactive notification process, 

about 146
opportunity lost notification process, 

about 147
opportunity notification workflow, setup 

steps 143
opportunity won notification process 148
opportunity workflow email, modifying 

the language of 150
opportunity workflows, setting up 

(procedure) 145
time lapse between lead acceptance and 

inactive notification, changing 146
time lapse between lead assignment and 

email delivery, modifying 147
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