Stellent.IBPM.Interop.Imaging


BinaryCondition

BinaryCondition Object

A where clause expression comparing two values

Remarks

A BinaryCondition is a WhereClause expression comparing two values. It may optionally have a conjunction (AND, OR, NOT AND, or NOT OR) in front of it. It has the form

[conj] <LeftValue> <ComparisionOp> <RightValue>

conj - A conjunction value that combines the BinaryCondition items together in a SQL where clause. It may be AND, OR, NOT AND, or NOT OR. It may also be NOP indicating the condition has no conjunction preceding it (e.g. when it is the first item in a nested expression.)

LeftValue - The left had operand in the comparison. In an Imaging search, it is always a column name.

ComparsionOp - The comparison operation to be performed. (i.e., =, <. > , etc).

RightValue - The right hand operand in the comparison. It may be a literal value, or it may be a column name. It it is a column name, the condition might be a join condition joining two tables together.


Field Property (BinaryCondition)

Conjunction Property (BinaryCondition)

Specifies to conjunction preceding the Binary condition in the where clause

Settings and Return Values

Sets and returns a Conjunction value.

Remarks

None


IsRightLiteral Property (BinaryCondition)

Indicates whether the RightValue property is a literal value or the name of a table column

Settings and Return Values

Returns a Boolean value.

Remarks

True - The RightValue property specifies a literal value
False - The RightValue property is the name of a column


LeftValue Property (BinaryCondition)

The left hand operand in the comparison

Settings and Return Values

Returns a string value.

Remarks

For an Imaging query, this is always the name of a table column.


Operator Property (BinaryCondition)

The comparison operator for the where clause item

Settings and Return Values

Sets or returns an Operator value.

Remarks

None


RightValue Property (BinaryCondition)

The right hand operand in the comparison

Settings and Return Values

Sets or returns a variant value.

Remarks

The right hand operand may be either a literal value, or a column name. If the right hand operand is a literal value, the IsRightLiteral property will return true. If the right hand operand is a column, the condition will indicate whether or not the join condition is a join between two tables.

The type of this value should be compatible with the ValueType property.


Type Property (BinaryCondition)

Indicates the type of Condition

Settings and Return Values

Returns an ConditionType value.

Remark

For a BinaryCondition, the Type property should always return ConditionType.ctBinaryCondition.

BinaryConditions are contained in the Conditions collection. This collection can contain objects of two different types. The item should be returned into a variable of type _Condition, which is a base type that can be either a SearchCondition or a BinaryCondition. Once the _Condition is retrieved, its Type property can be checked to determine which condition type it is. Then it can be set into the appropriate typed variable. The following example demonstrates this procedure.

Dim objCondition As Stellent.IBPM.Interop.Imaging._Condition
Dim objSearchCondition As Stellent.IBPM.Interop.Imaging.SearchCondition
Dim objBinaryCondition As Stellent.IBPM.Interop.Imaging.BinaryCondition

'objConditions is a populated Conditions collection
For Each objCondition In objConditions
    Select Case objCondition.Type
        Case Stellent.IBPM.Interop.Imaging.ConditionType.ctSearchCondition
            objSearchCondition = objCondition
            'Do work with objSearchCondition
        Case Stellent.IBPM.Interop.Imaging.ConditionType.ctBinaryCondition
            objBinaryCondition = objCondition
            'Do work with objBinaryCondition
    End Select
Next


ValueType Property (BinaryCondition)

Specifies the Data Type for the columns involved in the comparison

Settings and Return Values

Sets and returns a DataType enumeration value.

Remarks

This value should be set to a type equivalent to the data type of the columns specified by the LeftValue property. When setting the RightValue property, the type of the variant provided should be compatible with the ValueType property.


CacheService

CacheService Object

Represents an object which allows for the ability to identify and handle objects stored in cache.

Remarks

None


CacheObject Method

CacheObject Method (CacheService)

The CacheObject method allows a user to cache one page of a document.

Syntax

object.CacheObject(DocumentID As Object, PageNumber As Long, CacheDuration As Long, Destination As String, ResponseType As otResponseType)

Parameters

Part | Description
DocumentID | The document object.
PageNumber | The page number of the document to cache.
CacheDuration | The number of days an object will be cached.
Destination | Not implemented.
ResponseType | Not implemented.

Remarks

CacheObject takes the specified object on storage and move it to the B2B Store's cache directory.


DeleteObject Method

DeleteObject Method (CacheService)

The DeleteObject method allows a user to delete one page of a document from cache.

Syntax

object.DeleteObject(DocumentID As Object, PageNumber As Long, SourceServer As String, ResponseType As otResponseType)

Parameters

Part | Description
DocumentID | The document object.
PageNumber | The page number of the document to delete..
SourceServer | Not implemented.
ResponseType | Not implemented.

Remarks

None


FindObject Method

FindObject Method (CacheService)

The FindObject method allows a user to determine if one page of a document is in cache.

Return Type

A Boolean value.

Syntax

object.FindObject(DocumentID As Object, PageNumber As Long, SourceServer As String)

Parameters

Part | Description
DocumentID | The document object.
PageNumber | The page number of the document to cache.
SourceServer | Not implemented.

Remarks

None


UserToken Property (CacheService)

UserToken is a property which sets a UserToken object.

Settings and Return Values

Set a UserToken object

Remarks

None


Conditions

Conditions Collection

The collection of BinaryCondition and/or SearchCondition objects nested in a WhereClause SearchCondition

Remarks

This collection can contain objects of two different types. The item should be returned into a variable of type _Condition, which is a base type that can be either a SearchCondition or a BinaryCondition. Once the _Condition is retrieved, its Type property can be checked to determine which condition type it is. Then it can be set into the appropriate typed variable. The following example demonstrates this procedure.

Dim objCondition As Stellent.IBPM.Interop.Imaging._Condition
Dim objSearchCondition As Stellent.IBPM.Interop.Imaging.SearchCondition
Dim objBinaryCondition As Stellent.IBPM.Interop.Imaging.BinaryCondition

'objConditions is a populated Conditions collection
For Each objCondition In objConditions
    Select Case objCondition.Type
        Case Stellent.IBPM.Interop.Imaging.ConditionType.ctSearchCondition
            objSearchCondition = objCondition
            'Do work with objSearchCondition
        Case Stellent.IBPM.Interop.Imaging.ConditionType.ctBinaryCondition
            objBinaryCondition = objCondition
            'Do work with objBinaryCondition
    End Select
Next


Add Method

Add Method (Conditions)

Adds a new SearchConditon or BinaryCondition to the collection

Syntax

object.Add(Item As ICondition)

Parameters

Part | Description
Item | The SearchConditon or BinaryCondition to be added to the collection

Remarks

None


Item Method

Item Method (Conditions)

Returns a specified object out of the collection

Return Type

Returns an _Condition. The _Condition may be either a SearchCondition object or a BinaryCondition object

Syntax

object.Item(Index As Variant)

Parameters

Part | Description
Index | A variant value indicating the ordinal index or the string name of the condition object to be retrieved from the collection

Remarks

Because this collection can contain objects of two different types, the item should be returned into a variable of type _Condition, which is a base type that can be either a SearchCondition or a BinaryCondition. Once the _Condition is retrieved, its Type property can be checked to determine which condition type it is. Then it can be set into the appropriate typed variable. The following example demonstrates this procedure.

Dim objCondition As Stellent.IBPM.Interop.Imaging._Condition
Dim objSearchCondition As Stellent.IBPM.Interop.Imaging.SearchCondition
Dim objBinaryCondition As Stellent.IBPM.Interop.Imaging.BinaryCondition

'objConditions is a populated Conditions collection
For Each objCondition In objConditions
    Select Case objCondition.Type
        Case Stellent.IBPM.Interop.Imaging.ConditionType.ctSearchCondition
            objSearchCondition = objCondition
            'Do work with objSearchCondition
        Case Stellent.IBPM.Interop.Imaging.ConditionType.ctBinaryCondition
            objBinaryCondition = objCondition
            'Do work with objBinaryCondition
    End Select
Next


Remove Method

Remove Method (Conditions)

Removes the specified object from the collection

Syntax

object.Remove(Index As Variant)

Parameters

Part | Description
Index | A variant value indicating the ordinal index of the SearchCondition or BinaryCondition to be removed from the collection

Remarks

None


RemoveAll Method

RemoveAll Method (Conditions)

Removes all objects from the collection

Syntax

object.RemoveAll

Remarks

None


Count Property (Conditions)

Indicates the number of SearchCondition and /or BinaryCondition objects populated in the collection.

Settings and Return Values

Returns a long value

Remarks

The property is read-only


Connection

Connection Object

Represents a Link Server connection defined in the IBPM system

Remarks

The Connection object is used to enumerate the properties of the Tables accessible from a given Link Server connection.


Description Property (Connection)

The description text for the connection

Settings and Return Values

Returns a string value.

Remarks

The property is read-only


Instance Property (Connection)

Specifies the Connection Instance Name

Settings and Return Values

Returns a string value.

Remarks

Table names in Imaging take the form

LinkedServer.Instance.Schema.Table

The first two values name the connection, and the second two name the table within the connection.

This property returns the second value.

The property is read-only.


LinkServer Property (Connection)

Specifies the Connection LinkServer Name

Settings and Return Values

Returns a string value.

Remarks

Table names in Imaging take the form

LinkedServer.Instance.Schema.Table

The first two values name the connection, and the second two name the table within the connection.

This property returns the first value.

The property is read-only.


Name Property (Connection)

The name of the connection

Settings and Return Values

Returns a string value.

Remarks

Table names in Imaging take the form

LinkedServer.Instance.Schema.Table

The first two values name the connection, and the second two name the table within the connection.

This property returns the first two values, LinkedServer.Instance

The property is read-only.


Tables Property (Connection)

Returns the collection of Table objects configured in the Imaging system

Settings and Return Values

Returns a Tables object.

Remarks

The tables populated in this collection can be modified by setting the TableFilter property on the Connections collection before refreshing the connections and getting the Tables property.


Connections

Connections Collection

Contains all of the Linked Server Connections defined on the Imaging servers.

Remarks

Each Linked Server is a Connection object in the collection


Item Method

Item Method (Connections)

Returns a specified object out of the collection

Return Type

Returns a Connection object

Syntax

object.Item(Index As Variant)

Parameters

Part | Description
Index | A variant value indicating either the ordinal index or the string name of the Connection to be retrieved from the collection

Remarks

The Refresh method must be called to populate the collection prior to accessing the Item method.


Refresh Method

Refresh Method (Connections)

Populates the collection with Connection objects

Syntax

object.Refresh

Remarks

The UserToken property must be set prior to calling this method.

The method used to populate the collection is affect by the ConnectionFilter property. This property specifies whether the collection should be populated with read-only connections, writable connections, Stellent internal connections, or some combination thereof.

The population of the collection and the subsequent objects in the Connections model are also affected by the Style property. If the style is set to csUseAccCache, the connections list is obtained from the cached Access Control Context (ACC) information for the user. If the style is set to csNone, the ACC cache is refreshed on each call to Connections.Refresh


ACCFilter Property (Connections)

Filters the Table objects in the Connection objects populated in the collection by the specific rights that have been granted on that Table

Settings and Return Values

Returns an ADO Fields object

Remarks

The Security tool in the IBPM client is used to grant various Access Control Context (ACC) permissions to the tables within the Imaging database to a user group (i.e., CreateIndex, ModifyIndex, Print, etc.) A user belonging to that group inherits those rights. If the user belongs to multiple groups, they inherit the aggregate of all the security rights granted to the groups to which the user belongs. (The NoAccess right is logically different in that it is really a denied rather than a granted right. If the table is marked with NoAccess for any group a user in in, then the user has no access the table, even if other groups the user is in does not have NoAccess marked.)

The ACCFilter property allows a custom application to populate the Connection.Tables collection only with tables that have a specific right granted to the user. For example, only show tables that have CreateIndex granted.

The value returned from the ACCFilter property is an ADO Fields collection containing a field for each of the schema ACC right. The field indices for the rights are determined by the SchemaACCFilter enumeration. Each field in the row is a Boolean value indicating whether the that should be filtered. A True value for a particular right means that the only Tables with that right granted will be populated into the Tables collection. A False value means that no filter will be applied regarding the right. Note that there is not way to specify the a right has NOT been granted. Again, the NoAccess right is exceptional. A False for the no access right will only show Tables for which NoAccess has NOT been specified. A True will only show Tables for which NoAccess HAS been specified.

The ACCFilter property works in conjunction with the TableFilter Property, which specifies the TableProperty type of tables that should be populated into the Connection.Tables collection (i.e., show only Writeable tables.) So, if a custom application were to specify an ACCFilter with CreateIndex and/or ModifyIndex (i.e., write rights) equal True, and then try to apply a table filter of TableProperty_ReadOnly, the tables, the resulting Tables collection would be empty.

The following code demonstrates the use of the ACCFilter property to filter out only Tables that have been granted CreateIndex and ModifyIndex.

Dim objConnections As Stellent.IBPM.Interop.Imaging.Connections
Dim objConnection As Stellent.IBPM.Interop.Imaging.Connection
Dim objTables As Stellent.IBPM.Interop.Imaging.Tables

objConnections = New Stellent.IBPM.Interop.Imaging.Connections
objConnections.UserToken = m_objUserToken
objConnections.ACCFilter(sfCreateIndex) = True
objConnections.ACCFilter(sfModifyIndex) = True

objConnections.Refresh

objTables = objConnections.Item("Documents.Context").Tables
'The objTables collection should now contain only tables with the
'CreateIndex and ModifyIndex permission granted


ConnectionFilter Property (Connections)

Sets the Filter to be used when refreshing the collection

Settings and Return Values

Sets a long value

Remarks

The long value is a bit mask of ConnectionProperty enumeration values. The mask is compared against the Connection.Properties property for each Connection when refreshing the Connections collection.


Count Property (Connections)

Indicates the number of Connection objects populated in the collection.

Settings and Return Values

Returns a long value

Remarks

The Count on an un-refreshed collection is always zero, so the Refresh method must be called on the collection before this property has any meaning.

The property is read-only


FieldsFilter Property (Connections)

Specifies the field type filter to be applied when refreshing the Table object Fields and FieldAttributes properties

Settings and Return Values

Sets and returns a long value.

Remarks

None


Style Property (Connections)

Specifies the method to be used to refresh the collection

Settings and Return Values

Sets a long value

Remarks

The long value is a bit mask of Style enumeration values

The property is write only


TableFilter Property (Connections)

Specifies the filter used when refreshing a connection's Tables collection

Settings and Return Values

Sets and returns a long value.

Remarks

The value is a bit mask of TableProperty enumeration values


UserToken Property (Connections)

Sets the UserToken object to specify the user credentials under which the collection will operate

Settings and Return Values

Sets a UserToken object

Remarks

By setting the UserToken, user security can be applied to the process of refreshing the connections and tables. This ensures that the calling user only has access to tables to which access has been granted.

The property is write only


DocumentManager

DocumentManager Object

DocumentManager is a utility object for working with documents in Imaging

Remarks

The DocumentManager object is used to:

1) Create new documents

2) Modify Indexes on a document

3) Insert pages into a document

4) Delete pages from a document

5) Retrieve the document


CreateDocument Method

CreateDocument Method (DocumentManager)

Creates a new document in Imaging

Return Type

Returns a DocInfo object

Syntax

object.CreateDocument(Table As Object, FileName As String, MimeType As String)

Parameters

Part | Description
Table | A Table object specifying the index table into which the document is to be indexed. The Table object contains the table definition and index values for the document being created. The Table.Fields should have the Value property for each index field filled out.
FileName | The path and filename to the file being added to the IBPM system.
MimeType | The MIMEType for the document being index. If this parameter is left blank, the default IBPM MIMETypes will be used. (tiff, or universal)

Remarks

The DocInfo output parameter contains the DocumentId and IndexId for the newly created IBPM document.

If duplicate index values are supplied to CreateDocument (i.e. the index values already exist for another document in the system), the document will be appended to the existing document that already contains the index values.

The UserToken property must be set prior to calling this function.

This method should only be used with Imaging or Universal applications.


DeleteDocument Method

DeleteDocument Method (DocumentManager)

Removes the specified document from the application.

Syntax

object.DeleteDocument(DocInfo As Object)

Parameters

Part | Description
DocInfo | DocInfo object referencing the document to be removed. The DocInfo object contains the DocumentId and IndexId for the document.

Remarks

The UserToken property must be set prior to calling this function.

This method should only be used with Imaging or Universal applications.


DeletePageFromDocument Method

DeletePageFromDocument Method (DocumentManager)

Removes the specified page from the document

Syntax

object.DeletePageFromDocument(DocInfo As Object, PageNumber As PageNumber)

Parameters

Part | Description
DocInfo | DocInfo object referencing the document from which the page is to be removed. The DocInfo object contains the DocumentId and IndexId for the document.
PageNumber | Page number to be removed. PageNumber may be pnFirst, pnLast, or any positive integer specifying the exact page number that should be deleted from the specified document.

Remarks

The UserToken property must be set prior to calling this function.

This method should only be used with Imaging or Universal applications.


InsertPageIntoDocument Method

InsertPageIntoDocument Method (DocumentManager)

Inserts a page into an existing document

Return Type

Returns a DocInfo object

Syntax

object.InsertPageIntoDocument(DocInfo As Object, FileName As String, PageNumber As PageNumber, MimeType As String)

Parameters

Part | Description
DocInfo | DocInfo object referencing the document into which the page is being inserted. The DocInfo object contains the DocumentId and IndexId for the document
FileName | The path and filename to the file being inserted.
PageNumber | Page number at which the new page should be inserted. PageNumber may be pnFirst, pnLast, or any positive integer specifying the exact page number at which the page should be inserted
MimeType | The MIMEType for the document being inserted. If this parameter is left blank, the default IBPM MIMETypes will be used. (tiff, or universal)

Remarks

The UserToken property must be set prior to calling this function.

This method should only be used with Imaging or Universal applications.


ModifyDocumentIndexes Method

ModifyDocumentIndexes Method (DocumentManager)

Changes the indexes for a document

Syntax

object.ModifyDocumentIndexes(IndexID As Object, Table As Object)

Parameters

Part | Description
IndexID | An IndexId object referencing the index values to be changes. The IndexId object contains the IndexId for the document whose index values are being modified
Table | A Table object whose Fields collection contains the new index values.

Remarks

The UserToken property must be set prior to calling this function.

The modification of system fields (LucId, IndexProvider, MimeType, etc.) is not supported, only modify user defined index fields.

This method should only be used with Imaging or Universal applications.

Text values that are supplied to this method and that exceed the length of the target field defined in the target I/PM application will cause this method to return an error. Previous versions of the I/PM SDK would automatically truncate the text to fit into the application table and would not return an error.


ReplaceDocument Method

ReplaceDocument Method (DocumentManager)

Replaces an Imaging document with a different file, maintaining the same index values.

Syntax

object.ReplaceDocument(DocInfo As Object, FileName As String, MimeType As String)

Parameters

Part | Description
DocInfo | DocInfo object referencing the document to replace.
FileName | The path and filename of the replacement document.
MimeType | The MIMEType for the replacement document. If this parameter is left blank, the default IBPM MIMETypes will be used. (tiff, or universal)

Remarks

The UserToken property must be set prior to calling this function.

This method should only be used with Imaging or Universal applications.


WritePageObjectToFile Method

WritePageObjectToFile Method (DocumentManager)

Retrieves a document from Imaging storage

Return Type

Returns a string value

Syntax

object.WritePageObjectToFile(DocInfo As Object, Directory As String, PageNumber As PageNumber)

Parameters

Part | Description
DocInfo | DocInfo object referencing the document to be retrieved
Directory | A string providing the path in which the retrieved file will be stored
PageNumber | Page number to be retrieved. May be the actual page number or one of the PageNumber enumeration values.

Remarks

The returned string is the path to the retrieved file.

The UserToken property must be set prior to calling this function.

This method can be used with any IBPM document type.


ImplicitAppend Property

IgnoreNullFields Property (DocumentManager)

Specifies whether to null values in the Field Collection passed the Table parameter to the ModifyDocumentIndexes method will be be ignored or or set to blank values.

Settings and Return Values

Sets a Boolean value.

Remarks

The property should be set before calling ModifyDocumentIndexes method on the DocumentManager object.

If set to True, the default value, any field left at Null in the Fields collection of the Table object passed in into the ModifyDocumentIndexes method will be ignored (i.e., they will not be a part of the update statement application the to the document indexes.)

If set to False, fields left as null will be set to "blank" values. The meaning of "blank" for a particular value is dependant on both the data type of the index field and the database backend (Oracle, SqlServer) in use.

By default, this value is True.


ImplicitAppend Property

ImplicitAppend Property (DocumentManager)

Specifies whether to append the document to an existing document if the index values are identical.

Settings and Return Values

Sets a Boolean value.

Remarks

The property should be set before calling CreateDocument method on the DocumentManager object.

If set to True, the document will be appended to an existing document in the IBPM system with the same index values.

If set to False, a new document will always be created, regardless of existing documents with the same index values.


UserToken Property (DocumentManager)

Sets the user credential under which the object will operate

Settings and Return Values

Sets a UserToken object.

Remarks

The property must be set before calling any method on the DocumentManager.


ExportedDocument

ExportedDocument Object

Represents a document to be exported for Imaging

Remarks

The ExportedDocument object contains the object data such as the DocumentId object, the IndexId object, the PageRanges object, and the actual ExportEnvironment object.

Access to the object will be allowed until a valid UserToken is provided. The export will not occur unless the above objects are attached to the ExportDocument object.


RecombineDocument Method

RecombineDocument Method (ExportedDocument)

Exports a multi-page document and combines and saves as a single Document.

Return Type

Returns an ExportedSection object.

Syntax

object.RecombineDocument(PageRanges As IPageRanges)

Parameters

Part | Description
PageRanges | PageRanges object which contains the pages to export and combine

Remarks

The RecombineDocument method only works when exporting a multi-page TIFF document.

When calling the Recombine method, a PageRanges object must be created and populated with a set of page ranges to export. Without this PageRanges object populated, the export will not occur.


DocInfo property (ExportedDocument)

property DocInfo

Property type

A _DocInfo value.

Syntax

object.DocInfo [= value]

The DocInfo property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type ExportedDocument.
value | A _DocInfo value.


ExportEnvironment Property (ExportedDocument)

Specifies the configuration setting to be used when exporting the document

Settings and Return Values

Sets and returns an ExportEnvironment object.

Remarks

The export environment provides the user of this object model with a way to specify the format to which the document should be exported, along with the properties for that format. This object also provides a mechanism for setting namespace information and purging that namespace.

This property must be set before getting the Pages property.


Pages Property (ExportedDocument)

Returns the exported pages for the document

Settings and Return Values

Returns an ExportedPages object.

Remarks

After setting the DocumentID, the IndexID, the ExportEnvironment, and the UserToken on the ExportedDocument the user can get the ExportedPages collection that represents the pages in the document.


UserToken Property (ExportedDocument)

Sets the user credentials under which the object will operate.

Settings and Return Values

Sets a UserToken object

Remarks

This property must be set before getting the Pages property.


ExportedPage

ExportedPage Object

Represents a single page exported from a document

Remarks

None


Sections Property (ExportedPage)

Returns the exported section for the page

Settings and Return Values

Returns an ExportedSections collection.

Remarks

None


ExportedPages

ExportedPages Collection

Contains all of the pages exported from a document

Remarks

None


Item Method

Item Method (ExportedPages)

Returns a specified object out of the collection

Return Type

Returns an ExportedPage object

Syntax

object.Item(Index As Long)

Parameters

Part | Description
Index | A long value indicating the ordinal index of the ExportedPage to be retrieved from the collection

Remarks

None


Count Property (ExportedPages)

Indicates the number of ExportedPage objects populated in the collection.

Settings and Return Values

Returns a long value

Remarks

The property is read-only


ExportedSection

ExportedSection Object

Represents a single section of an exported document

Remarks

Sections are a sub classification of a pages. For image documents, page have exactly one section. For more complex documents, there may be multiple sections on a page. For instance, a word document may be stored as a single page within the IBPM section. Internally, however, it may contain many pages. The IBPM system exports these internal "pages" as sections.

Each section for an exported document will result in a single exported image.

The ExportedSection object indicates the path (both the FullPath and RelativePath) to the exported section file.


FullPath Property (ExportedSection)

The full path of the file in which the exported section document was stored.

Settings and Return Values

Returns a string value.

Remarks

None


RelativePath Property (ExportedSection)

The relative path to the file in which the exported section document was stored.

Settings and Return Values

Returns a string value.

Remarks

The path is relative to the ExportEnvironment.ExportBasePath setting supplied to the ExportedDocument.


ExportedSections

ExportedSections Collection

Contains the ExportedSection objects for an ExportedDocument.

Remarks

None


Item Method

Item Method (ExportedSections)

Returns a specified object out of the collection

Return Type

Returns an ExportedSection object

Syntax

object.Item(Index As Long)

Parameters

Part | Description
Index | A long value indicating the ordinal index of the ExportedSection to be retrieved from the collection

Remarks

None


Count Property (ExportedSections)

Indicates the number of ExportedSection objects populated in the collection.

Settings and Return Values

Returns a long value

Remarks

The property is read-only


ExportEnvironment

ExportEnvironment Object

Describes how the document should be exported from the IBPM System.

Remarks

The object contains environmental information such as where the document will be exported, what the document will be exported to, the exported scale and dpi of the document, and the maximum number of pages to export. This object can also be set to purge the export directory.


PurgeNameSpace Method

PurgeNameSpace Method (ExportEnvironment)

Clears the NameSpace subdirectory of all exported documents

Syntax

object.PurgeNameSpace(Name As String)

Parameters

Part | Description
Name | The name space subdirectory to be purged

Remarks

None


ExportBasePath Property (ExportEnvironment)

The base path where exported documents will be stored

Settings and Return Values

Sets and returns a string value.

Remarks

This ExportBasePath directory path combined with the ExportNameSpace property determines what actual directory exported files are placed in.

When an ExportEnvironment object is created, the ExportBasePath is defaulted to the current working directory with the directory ‘\IBPMData’ appended to it.


ExportDPI Property (ExportEnvironment)

Specifies the DPI to use when exporting the document

Settings and Return Values

Sets and returns a long value.

Remarks

This is only used when exporting the document in the form of an image (i.e., TIFF or JPEG).

If the UseHighestResolution property is set to True, then this property is ignored.

The default for this property is 0.


ExportNameSpace Property (ExportEnvironment)

A namespace value to be used in the storage location for exported images

Settings and Return Values

Sets and returns a string value.

Remarks

All exported images will be stored in a subdirectory named with this property within the ExportBasePath directory.

This proprty allows the user of the ExportedDocument to segregate data from several groups of ExportedDocument objects. Assigning the ExportNameSpace property also allows the user of this object to make use of the PurgeNameSpace method on this object. This functionality provides a mechanism to manage the large amounts of data that can be generated when exporting several documents from IBPM.

The default for this property is "AcordeData".


ExportScale Property (ExportEnvironment)

Specifies the scale to use when exporting an object from the IBPM System

Settings and Return Values

Sets and returns a long value.

Remarks

This is only used when exporting the document in the form of an image (i.e. .TIFF or .JPEG).

If the UseHighestResolution property is set to True, then this property is ignored.

The default for this property is 0.


ExportType Property (ExportEnvironment)

Specifies the format to which the document should be exported.

Settings and Return Values

Sets and returns the ExportFileType constant value.

Remarks

The default for this property is otiExportGIF.


MaxOutputPages Property (ExportEnvironment)

Specifies the maximum number of pages that should be exported.

Settings and Return Values

Sets and returns a long value

Remarks

The default for this property is 10.


NoStickyNotes Property (ExportEnvironment)

Specifies whether sticky note annotation content should be exported along with the document. There will still be an indication that a sticky note is attached to the original document.

Settings and Return Values

Sets and returns a boolean value.

Remarks

The calling user must have proper permission to perform this operation for the setting to have effect.


UseHighestResolution Property (ExportEnvironment)

Specifies that the document should be exported in the highest possible resolution.

Settings and Return Values

Sets and returns a Boolean value.

Remarks

If this value is set to True, then the ExportScale and ExportDPI properties will be ignored.

The default for this property is False.


FieldAttribute

FieldAttribute Object

Represents the attributes for a field in a Table

Remarks

None


Name Property (FieldAttribute)

The name of the field represented by the FieldAttribute

Settings and Return Values

Returns a string value.

Remarks

None


PickList Property (FieldAttribute)

Returns the pick list associated with the field

Settings and Return Values

Returns a PickL:ist value.

Remarks

If no Pick List is associated with the field, then a Nothing value is returned


Type Property (FieldAttribute)

Indicates the data type of the field

Settings and Return Values

Returns a long value.

Remarks

The returned long value equates to a FieldProperty enumeration value.

The property is read-only


FieldAttributes

FieldAttributes Collection

The collection of field attributes for a Table

Remarks

None


Item Method

Item Method (FieldAttributes)

Returns a specified object out of the collection

Return Type

Returns a FieldAttribute object

Syntax

object.Item(Index As Variant)

Parameters

Part | Description
Index | A variant value indicating either the ordinal index or the string name of the FieldAttribute to be retrieved from the collection

Remarks

None


Count Property (FieldAttributes)

Indicates the number of FieldAttribute objects populated in the collection.

Settings and Return Values

Returns a long value

Remarks

The property is read-only


FromClause

FromClause Object

Represents the SQL from clause portion of a SQL statement

Remarks

The FromClause object is the from clause portion of a SQLSelect object, obtained from its FromClause property.

A select clause is composed of individual FromItemTable objects, each of which equates to single table name.

The SQL from clause:

...FROM Table1, Table2...

is build using the following code:

Dim objSQLSelect As Stellent.IBPM.Interop.Imaging.SQLSelect
Dim objFromClause As Stellent.IBPM.Interop.Imaging.FromClause
Dim objFromItemTable As Stellent.IBPM.Interop.Imaging.FromItemTable

objSQLSelect = New Stellent.IBPM.Interop.Imaging.SQLSelect
objFromClause = objSQLSelect.FromClause

objFromItemTable = New Stellent.IBPM.Interop.Imaging.FromItemTable
objFromItemTable.TableName = "Table1"
objFromClause.FromItems.Add objFromItemTable

objFromItemTable = New Stellent.IBPM.Interop.Imaging.FromItemTable
objFromItemTable.TableName = "Table2"
objFromClause.FromItems.Add objFromItemTable

MsgBox objFromClause.SQLSubString


Validate Method

Validate Method (FromClause)

Indicates whether a valid SQL from clause can be constructed from the FromClause object

Return Type

A Boolean value.

Syntax

object.Validate

Remarks

None


FromItems Property (FromClause)

Returns the collection of FromItemTable objects for the From clause

Settings and Return Values

Returns a FromItemTable object

Remarks

The order in which FromItemTable objects are added to the collection is the order they will be used within the from clause.


SQLSubString Property (FromClause)

Returns a textual representation of the from clause

Settings and Return Values

Returns a string value.

Remarks

This property is primarily used for debugging purposed to verify that the FromClause is accurately representing the desired statement

The property is read-only.


FromItems

FromItems Collection

A collection containing the FromItemTable objects for the select clause.

Remarks

The order in which the FromItemTable objects are added to the collection is the order they will be used in the SQL clause.


Add Method

Add Method (FromItems)

Adds a new FromItemTable to the collection

Syntax

object.Add(Item As IFromItem)

Parameters

Part | Description
Item | The FromItemTable object to be added to the collection

Remarks

None


Item Method

Item Method (FromItems)

Returns a specified object out of the collection

Return Type

Returns a FromItemTable object

Syntax

object.Item(Index As Variant)

Parameters

Part | Description
Index | A variant value indicating the ordinal index of the FromItemTable to be retrieved from the collection

Remarks

None


Remove Method

Remove Method (FromItems)

Removes the specified object from the collection

Syntax

object.Remove(Index As Variant)

Parameters

Part | Description
Index | A variant value indicating the ordinal index of the FromItemTable to be removed from the collection

Remarks

None


RemoveAll Method

RemoveAll Method (FromItems)

Removes all objects from the collection

Syntax

object.RemoveAll

Remarks

None


Count Property (FromItems)

Indicates the number of FromItemTable objects populated in the collection.

Settings and Return Values

Returns a long value

Remarks

The property is read-only


FromItem

FromItem object

Represents a single table in a from clause.

Remarks

The SQL from clause represented by the SelectClause object is of the form:

FROM table, table, table

Each table is represented by a single FromItem object.

FromItem objects are added to a FromClause.FromItems collection to form the SQL from clause.


TableName Property (FromItem)

The name of the table in the from clause.

Property type

A String value.

Syntax

object.TableName [= value]

The TableName property syntax has these parts:

Part | Description
value | A String value representing the name of the table.


NamedQueries

NamedQueries Collection

Contains NamedQuery objects defined in the Imaging system

Remarks

The NamedQueries collection contains NamedQuery objects. Each NamedQuery object represents a single named query which has been defined by the Query Builder tool in the IBPM client.

The NamedQueries collection is a creatable object. After NamedQueries has been created, the UserToken property must be set with a valid UserToken, and then the Refresh method should be called to populate the collection with objects.

After refresh, individual NamedQuery objects in the collection can be accessed using the Count and Item properties. The Item property will retrieve an item either by specifying the ordinal index into the collection or by specifying the name of the NamedQuery desired from the collection. The collection also supports For...Each syntax for enumeration sequentially through each member of the collection.

The collection will only populate with those NamedQuery objects to which the calling user (as defined by the UserToken object) has been granted access.


Item Method

Item Method (NamedQueries)

Returns a specified object out of the collection

Return Type

Returns a NamedQuery object

Syntax

object.Item(Index As Variant)

Parameters

Part | Description
Index | A variant value indicating either the ordinal index or the string name of the NamedQuery to be retrieved from the collection

Remarks

The Refresh method must be called to populate the collection prior to accessing the Item method.


Refresh Method

Refresh Method (NamedQueries)

Populates the collection with NamedQuery objects

Syntax

object.Refresh

Remarks

The UserToken property must be set prior to calling this method.


ACCFilter Property (NamedQueries)

Filters the collection by the specific rights that have been granted to NamedQuery objects

Settings and Return Values

Returns an ADO Fields object

Remarks

The Security tool in the IBPM client is used to grant various Access Control Context (ACC) permissions to the NamedQueries within the Imaging database to a user group (i.e., Execute, Modify, Delete.) A user belonging to that group inherits those rights. If the user belongs to multiple groups, they inherit the aggregate of all the security rights granted to the groups to which the user belongs.

The ACCFilter property allows a custom application to populate the NamedQueries collection only with NamedQuery objects that have a specific right granted to the user. For example, only show NamedQueries with Modify granted.

The value returned from the ACCFilter property is an ADO Fields collection containing a field for each of the NamedQuery ACC right. The field indices for the rights are determined by the NamedQueriesACCFilter enumeration. Each field in the row is a Boolean value indicating whether the right that should be filtered. A True value for a particular right means that the only named queries with that right granted will be populated into the Tables collection. A False value means that no filter will be applied regarding the right. Note that there is not way to specify the a right has NOT been granted.

The following code demonstrates the use of the ACCFilter property to filter out only NamedQueries that have been granted the Modify right.

Dim objNamedQueries As Stellent.IBPM.Interop.Imaging.NamedQueries
objNamedQueries = New Stellent.IBPM.Interop.Imaging.NamedQueries
objNamedQueries.UserToken = m_objUserToken
objNamedQueries.ACCFilter(nqfModify) = True

objNamedQueries.Refresh
'The objNamedQueries collection should now contain only tables with the
'Modify permission granted


Count Property (NamedQueries)

Indicates the number of NamedQuery objects populated in the collection.

Settings and Return Values

Returns a long value

Remarks

The Count on an un-refreshed collection is always zero, so the Refresh method must be called on the collection before this property has any meaning.

The property is read-only


Style Property (NamedQueries)

Sets the style to use when refreshing the collection

Settings and Return Values

Sets a Style

Remarks

The property is write only.


UserToken Property (NamedQueries)

Sets the UserToken object into the NamedQueries collection

Settings and Return Values

Set a UserToken object

Remarks

Setting the UserToken property defines the user credentials under which the collection will operate. After setting the UserToken, the Refresh method should be called to populate the collection with NamedQuery objects. The collection will only populate with NamedQuery objects to which the specified user has been granted access.


NamedQuery

NamedQuery Object

Represents a named query that has been defined by the Query Builder tool in the IBPM Client.

Remarks

Named Queries are predefined queries stored by the Imaging system that can be executed to retrieve row based data. The query ultimately resolves to a SQL statement that will be executed when the NamedQuery object is run.

NamedQueries may have NamedQueryCondtions that define the WhereClause for the resulting SQL statement. The query's NamedQueryCondtions may contain hard coded conditions or they may contained prompted values that must be filled in at the time the query is executed. Prompted values may be free for user defined entry, or they may contain a PickList from which valid conditional values may be chosen.

A NamedQuery is executed by an obtained QueryConnection from the QueryConnectionManager object. Once the NamedQuery is properly filled out with any required prompts or picklist conditions, the NamedQuery is passed into the QueryConnection.ExecuteQuery method. The query results are returned in the form of an ADO Recordset by calling the QueryConnection.GetResults method.


AutoPauseCnt Property (NamedQuery)

The count of records returned before auto pause is engaged

Settings and Return Values

Returns a long value.

Remarks

Auto pause is a feature of the Search Results tool in the IBPM client. When the number of rows returned by the search exceeds the Auto Pause Count, a dialog is displayed asking the user if they want to continue fetching results.

This property is predefined in the NamedQuery when it is created in the Query Builder tool in the IBPM client.

The property is read-only.


BatchQuery Property (NamedQuery)

Reserved for future use


ColumnsMerged Property (NamedQuery)

Reserved for future use


Conditions Property (NamedQuery)

Returns the NamedQueryConditions which define the query's SQL statement where clause.

Settings and Return Values

Returns a NamedQueryConditions collection

Remarks

None


MaxExecTime Property (NamedQuery)

The maximum duration the named query will be allowed to execute before timing out.

Settings and Return Values

Returns a long value.

Remarks

This property is predefined in the NamedQuery when it is created in the Query Builder tool in the IBPM client.

The property is read-only.


MaxRows Property (NamedQuery)

Indicates the maximum number of rows that the named query will be allowed to return.

Settings and Return Values

Returns a long value.

Remarks

This property is predefined in the NamedQuery when it is created in the Query Builder tool in the IBPM client.

The property is read-only.


MaxRunTime Property (NamedQuery)

Reserved for future use


Name Property (NamedQuery)

The Name of the NamedQuery object.

Settings and Return Values

Returns a string value.

Remarks

The property is read-only.


OffLine Property (NamedQuery)

Indicates whether the named query is currently marked as OffLine

Settings and Return Values

Returns a Boolean value.

Remarks

This property is predefined in the NamedQuery when it is created in the Query Builder tool in the IBPM client.

The property is read-only.


RowsDistinct Property (NamedQuery)

Indicates whether the rows in the result returned by the NamedQuery should be distinct rows

Settings and Return Values

Returns a Boolean value.

Remarks

This property indicates that the SQL Distinct keyword will be added the executed SQL Statement.

This property is predefined in the NamedQuery when is created in the Query Builder tool in the IBPM client.

The property is read-only.


SQLSelect Property (NamedQuery)

Returns a SQLSelect object that represents the SQL select statement which the named query defines.

Settings and Return Values

Returns a SQLSelect object.

Remarks

None


NamedQueryCondition

NamedQueryCondition Object

Represents a single where clause condition in a saved search

Remarks

The where clause conditions for a saved search are defined in the Search Builder tool in the Imaging client.

Search conditions in a saved search are always of the form <LeftValue> <ComparisonOp> <RightValue> (e.g. Col1 = 5 ). The LeftValue is always a column name from the database table to be searched. The ComparisonOp is a comparison operator. The ComparisonOp is set to the default operater, but may be set a execution time with any value out of the AvailableComparisonOps collection. RightValue is either a literal value or another column name. If it is another column, then this condition is likely a join condition. If the right value is a literal an not another column name, the IsRightLiteral value will be true.

The right value may have been left unfilled-in when the saved search was defined indicating that the condition is either a prompted or a pick list (i.e. (a prompt with a supplied pick list from which the value should be chosen.) condition. The type can be determined checking the DisplayStyle property. If the condition is prompted, the DisplayName and DisplayMask properties can be used in presenting the user with a prompt dialog.


DisplayMask Property (NamedQueryCondition)

The display mask string defined for the condition of the saved search.

Settings and Return Values

Returns a string value.

Remarks

This property is read-only


DisplayName Property (NamedQueryCondition)

The display name string defined for the condition of the saved search.

Settings and Return Values

Returns a string value.

Remarks

This property is read-only


DisplayStyle Property (NamedQueryCondition)

The display style for the where clause condition

Settings and Return Values

Returns a DisplayStyle enumeration value.

Remarks

The style can have the following settings

dsHidden | The condition should not be displayed to a user but will be evaluated when the search is executed.
dsDisplay | The condition should be displayed, but is hard coded. It does not require the that a RightValue be supplied
dsPrompt | RightValue can be supplied before executing the search. If not supplied, the condition will simply be ignored.
dsPromptReq | RightValue must be supplied before executing the search. The Search will fail if it is not supplied
dsPickList | RightValue can be supplied before executing the search, and a pick list of the set of values that are valid is provided by the PickList property.


IsRightLiteral Property (NamedQueryCondition)

Indicates whether the condition's RightValue is a literal or a column name

Settings and Return Values

Returns a Boolean value.

Remarks

If true, the RightValue property is a literal value. If false, it is a column.


LeftValue Property (NamedQueryCondition)

The left hand column name of the saved search condition

Settings and Return Values

Returns a string value.

Remarks

This property is read-only.


Operator Property (NamedQueryCondition)

The current operator on the where clause condition.

Settings and Return Values

Set and returns an Operator value.

Remarks

This value defaults to the default comparison operator as defined for the condition in the Search Builder tool in the IBPM client. If multiple comparison operators have been defined as options for this search, one of the multiple choices can be obtained from the Operators collection returned from the Operators property and set on this property.


Operators property (NamedQueryCondition)

A collection of the available operators that have been defined for the Prompted Saved Search.

Settings and Return Values

Returns a Operators collection

Remarks

The list of comparison operators that are available to be supplied to the saved search at the time it is executed are defined in the Search Builder tool in the IBPM Client.

The property is read-only.


PickList Property (NamedQueryCondition)

Returns the pick list collection for the prompted condition

Settings and Return Values

Returns a PickList object

Remarks

This property should be accessed if the condition DisplayStyle is set to a Pick List. The PickList collection should then be used to present the valid set of values for the RightValue property, which may be set prior to executing the search.


RightValue Property (NamedQueryCondition)

The right hand value of the named search condition.

Settings and Return Values

Sets a returns a variant value.

Remarks

This value determines the value for the right hand side the conditional operation. The value can either be a literal value or a table column name. This value should be set prior to executing the search if the DisplayStyle is Prompt, Prompt Required, or Pick List. Otherwise, it should not be modified.


ValueType Property (NamedQueryCondition)

The type of the LeftValue property of the saved search where condition

Settings and Return Values

Returns a DataType enumeration value.

Remarks

This property specifies the data type of the column specified by the LeftValue property. Any value set on the RightValue property must then be compatible with this type.

The property is read-only.


NamedQueryConditions

NamedQueryConditions Collection

Contains the NamedQueryCondition objects for the saved search

Remarks

The NamedQueryConditions collection represents the where clauses item for the saved search represented by a NamedQuery. The NamedQueryConditions cololection always obtained from the NamedQuery.Conditions property. Each NamedQueryCondition object in the collection represents a single where clause item. The conditions may indicate that the condition is prompted or has a pick list and must be filled in prior to executing the search.


Item Method

Item Method (NamedQueryConditions)

Returns a specified object out of the collection

Return Type

Returns a NamedQueryCondition object

Syntax

object.Item(Index As Long)

Parameters

Part | Description
Index | A long value indicating the ordinal index of the NamedQueryCondition to be retrieved from the collection

Remarks

None


Count Property (NamedQueryConditions)

Indicates the number of NamedQueryCondition objects populated in the collection.

Settings and Return Values

Returns a long value

Remarks

The property is read-only


NameParser

NameParser Object

A utility object for managing Table Names

Remarks

Fully qualified field names in Imaging take the form

LinkedServer.Instance.Schema.Table.Field

The first two values name the connection, and the second two name the table within the connection, and the final parameter is the field name.

The NameParser object facilitates interpreting the FullyQualifiedName of a field, breaking it up into the ConnectionName, TableName, and FieldName.


ConnectionName Property (NameParser)

Returns the parsed Connection Name.

Settings and Return Values

Returns a string value.

Remarks

Fully qualified field names in Imaging take the form

LinkedServer.Instance.Schema.Table.Field

This property returns the LinkedServer.Instance value.

The property is read-only.


FieldName Property (NameParser)

Returns the parsed Field Name.

Settings and Return Values

Returns a string value.

Remarks

Fully qualified field names in Imaging take the form

LinkedServer.Instance.Schema.Table.Field

This property returns the Field value.

The property is read-only.


FullyQualifiedName Property (NameParser)

Sets the fully qualified field name to be parsed

Settings and Return Values

Set and returns a string value.

Remarks

Fully qualified field names in Imaging take the form

LinkedServer.Instance.Schema.Table.Field

This property is used to set the full field name so that it can be parsed into the ConnectionName, TableName, and FieldName


TableName Property (NameParser)

Returns the parsed Table Name.

Settings and Return Values

Returns a string value.

Remarks

Fully qualified field names in Imaging take the form

LinkedServer.Instance.Schema.Table.Field

This property returns the Schema.Table value.

The property is read-only.


Operators

Operators object

The set of available comparison operators for a prompted saved search

Remarks

The items in the collection are long values equating to the Operator enumeration. The collection is accessed through the NamedQueryConditions.Operators property.


Exists method

Exists Method (Operators)

Indicates whether the specified operator exists in the collection.

Return Type

A Boolean value.

Syntax

object.Exists(Operator As Operator)

The Exists method syntax has these parts:

Part | Description
Operator | An Operator value that is checked for existence in the collection


Item Property (Operators)

Returns a specified operator out of the collection.

Property type

A Long value.

Syntax

object.Item(Index As Variant) [= value]

The Item property syntax has these parts:

Part | Description
value | A variant value indicating the ordinal index comparison operator item to be retrieved

Remarks

The long value return from the collection will equal one of the Operator enumerated values.


Count Property (Operators)

Indicates the number of comparison operator items populated in the collection.

Property type

A Long value.

Syntax

object.Count [= value]

The Count property syntax has these parts:

Part | Description
value | A Long value representing the operator.

Remarks

The property is read-only


PageRanges

PageRanges Object

A collection of page ranges to be used when recombine exporting a document

Remarks

Page ranges are simple pairs of page numbers, Start Page to End Page. The PageRanges object is used when calling the ExportedDocument.RecombineDocument method.


AddRange Method

AddRange Method (PageRanges)

Adds the page range to the object

Syntax

object.AddRange(StartPage As Long, EndPage As Long)

Parameters

Part | Description
StartPage | The long value of the starting page number
EndPage | The long value of the ending page number

Remarks

None


PasteSelect

PasteSelect Object

Performs document cut/copy/paste

Remarks

The PasteSelect object was created to mimic the Cut/Copy/Paste functionality. This object allows for taking a page of an existing document (either cut or copy) and pasting it into an existing document or creating a new document.


AddItem Method

AddItem Method (PasteSelect)

The AddItem method selects a page to be cut or copied from a document and subsequently pasted in another document.

Syntax

object.AddItem(pDocInfo As Object, PageNum As Long)

Parameters

Part | Description
pDocInfo | DocInfo object referencing the document from which the page is to be cut or copied.
PageNum | The page number within the document that is to be cut or copied.

Remarks

None


ClearAll Method

ClearAll Method (PasteSelect)

The ClearAll method removes all pages from the collection of pages to be pasted.

Syntax

object.ClearAll

Remarks

None


Paste Method

Paste Method (PasteSelect)

The Paste method will paste the selected pages into the document referenced by DocInfo at the page number specified by PageNum. Whether the pages are cut or copied from their source documents is determined by the Action parameter.

Syntax

object.Paste(pDocInfo As Object, PageNum As Long, action As PasteAction)

Parameters

Part | Description
pDocInfo | DocInfo object referencing the document from which the page is to be cut or copied.
PageNum | The page number within the document that is to be cut or copied.
action | Specifies whether the pages will be cut or copied from their original documents. This value is obtained from the PasteAction enumeration

Remarks

None


PasteNew Method

PasteNew Method (PasteSelect)

The PasteNew method will paste the selected pages into a new document. Whether the pages are cut or copied from their source documents is determined by the Action parameter.

Syntax

object.PasteNew(Table As Object, action As PasteAction)

Parameters

Part | Description
Table | A Table object specifying the table and field values under which the new document will be indexed.
action | Specifies whether the pages will be cut or copied from their original documents. This value is obtained from the PasteAction enumeration.

Remarks

None


UserToken Property (PasteSelect)

The UserToken property sets the UserToken to the object.

Settings and Return Values

Sets a UserToken object

Remarks

None


PickList

PickList Object

Represents a list of string values that are valid for a particular NamedQueryCondition of schema table FieldAttribute.

Remarks

Pick lists are defined by the Pick List Builder tool in the IBPM client. They are assigned to saved searches (i.e. NamedQueryCondition) from the Search Builder Tool. They are assigned to schema table field (FieldAttribute) from the PickList Mapper tool.


Item Method

Item Method (PickList)

Returns a specified object out of the collection

Return Type

Returns a string value

Syntax

object.Item(Index As Variant)

Parameters

Part | Description
Index | A variant value indicating the ordinal index pick list string item to be retrieved

Remarks

None


Caption Property (PickList)

The caption string for the pick list.

Settings and Return Values

Returns a string value.

Remarks

None


Count Property (PickList)

Indicates the number of pick list string items populated in the collection.

Settings and Return Values

Returns a long value

Remarks

The property is read-only


ForceSelect Property (PickList)

Indicates that the value to which the pick list applies should only be supplied with values from the pick list.

Settings and Return Values

Returns a Boolean value.

Remarks

A true value for this property is equivalent to a Style of psForcedSelection. A false value is equivalent to a Style of psNone.


Name Property (PickList)

The name of the pick list

Settings and Return Values

Sets or returns a string value.

Remarks

None


Style Property (PickList)

Indicates the style of the pick list

Settings and Return Values

Returns a PicklistStyle enumeration value.

Remarks

The Style property can have the following values:

psNone | Supplying a value from the pick list is optional. This is equivalent to ForceSelect = false
psForcedSelection | The value to which the pick list applies should only be supplied with values from the pick list. This is equivalent to ForceSelect = true


UserToken Property (PickList)

The UserToken which supplies the credentials for retrieving the pick list.

Settings and Return Values

Sets a UserToken object

Remarks

This property must be set before any other properties are accessed. It will already be set if the PickList is accessed through another object in the object model. (i.e., from NamedQueryCondition.PickList or from FieldAttribute.PickList)


QueryConnection

QueryConnection Object

Represents a connection on which a search can be executed

Remarks

The QueryConnection can either execute NamedQuery searches or Ad-Hoc searches with the SQLSelect object


CancelQuery Method

CancelQuery Method (QueryConnection)

Cancels an executing search and discards any results held by the Search Manager Server

Syntax

object.CancelQuery

Remarks

None


ExecuteQuery Method

ExecuteQuery Method (QueryConnection)

Submits a query to the IBPM system.

Syntax

object.ExecuteQuery(Query As Object, ManageStyle As RecordsetManagement, Granularity As Long)

Parameters

Part | Description
Query | Either the NamedQuery object or SQLSelect object representing the query to be executed.
ManageStyle | An RecordsetManagement enumeration value indicating how the query should be managed
Granularity | Number of row to return with each call to GetResults2

Remarks

ManageStyle can either be otQueryStyleManagedRecordset or otQueryStyleUnmanagedRecordset. When ExecuteQuery is called with otQueryStyleManagedRecordset, the QueryConnection owns the recordset and always returns the same recordset when GetResults2 is called. Each call to GetResults2 appends any new rows to the managed recordset. When ExecuteQuery is called with otQueryStyleUnmanagedRecordset, each call to GetResults2 returns a new recordset.

The granularity parameter specifies how many records to return with each call to GetResults2. When the ManageStyle is otQueryStyleManagedRecordset, GetResults2 appends the number of rows specified by the Granularity parameter to the managed recordset. When the ManageStyle otQueryStyleUnmanagedRecordset and the FirstRec and LastRec values are not specified in the GetResults2 method, each call to GetResults returns the next N rows, where N is the granularity.


GetResults Method

GetResults Method (QueryConnection)

Returns the results of an executed search.

Return Type

A QueryResults value.

Syntax

object.GetResults(ReturnStyle as RecordsetReturn, FirstRec as Object, LastRec as Object)

Parameters

Part | Description
ReturnStyle | RecordsetReturn - only rsrAll is supported
FirstRec | Optional Variant indicting the first record in range to be returned
LastRec | Optional Variant indicting the last record in range to be returned

Remarks

GetResults returns a QueryResults object which contains the record set and query status.

The optional FirstRec and LastRec parameters specify which records of query results to put into the returned QueryResults.Recordset

If the FirstRec and LastRec parameters are not specified and the ManageStyle specified in ExecuteQuery is rsmUnmanaged, GetResults returns the next N records, where N is the granularity. The FirstRec and LastRec values are ignored if the ManageStyle is rsmManaged.

The QueryResults.QueryStatus contains the status of the query according to the SearchManagerServer as well as how many records have been cached so far.


ConnectionId Property (QueryConnection)

Used to restore a connection with the Search Manager Server.

Settings and Return Values

Returns a string value.

Remarks

The ConnectionID property can be used to restore a connection with the Search Manager Server without the expense of establishing a completely new connection. The Search Manager Server keeps a query connection open until QueryConnectionManager.DestoryConnection is called or the connection times out. While the Search Manager Server connection is open, the results of any open query is cached.

The property is read-only


LocalColumns Property (QueryConnection)

Used to add additional columns to the returned recordset

Settings and Return Values

Sets an ADO Recordset.

Remarks

The LocalColumns property can be used to add additional columns to the returned recordset. To use the LocalColumns property, create a recordset with the additional fields to add. If you add values to the fields by opening the recordset and adding a row, those values are used to populate the local columns in the recordset that GetResults returns.


QueryStatus Property (QueryConnection)

Returns the status of the Search Manager Server query.

Settings and Return Values

Returns a QueryStatus object.

Remarks

The QueryStatus property returns the status of the Search Manager Server query. The QueryStatus object contains information as to the status of the query and the number of rows currently in the Search Manager Server cache.


QueryConnectionManager

QueryConnectionManager Object

Manages connections to the Search Manager Server for executing searches

Remarks

All Imaging SDK based searches are executed on the Search Manager Server (SMS). QueryConnectionManager is the root object for interfacing with the SMS.

To execute any search against the SMS, a connection must first be created to perform the search. This is done with the CreateConnection method, which returns a QueryConnection object representing a connection open on SMS. An SMS connection will hold on to un-fetched search results on the SMS server until the results are fetched, the connection is destroyed, or the connection times out.

A connection is destroyed by calling the DestroyConnection method, passing in a QueryConnection object.

The connection on SMS is maintained even if the QueryConnection object is release on the client (but not destroyed.) If the client holds onto the QueryConnection.ConnectionId, and the the SMS connection has not timeout, a QueryConnection can be restored with the RestoreConnection method.


CreateConnection Method

CreateConnection Method (QueryConnectionManager)

Creates a new connection and the Search Manager Server

Return Type

A QueryConnection object

Syntax

object.CreateConnection

Remarks

The UserToken property must be set before calling this method.


DestroyConnection Method

DestroyConnection Method (QueryConnectionManager)

Destroys a connection on the Search Manager Server

Syntax

object.DestroyConnection(ConnectionId As String)

Parameters

Part | Description
ConnectionId | ConnectionId of the QueryConnection being destroyed

Remarks

The ConnectionId is obtained from the QueryConnection.ConnectionId property of the connection being destroyed. Once DestroyConnection is called for a QueryConnection object, all references to the object should be release as it is no longer valid and can no longer be used to execute searches.

The UserToken property must be set before calling this method.


RestoreConnection Method

RestoreConnection Method (QueryConnectionManager)

Retores an open QueryConnection on the Search Manager Server

Return Type

A QueryConnection object.

Syntax

object.RestoreConnection(ConnectionId As String)

Parameters

Part | Description
ConnectionId | ConnectionId of the QueryConnection being destroyed

Remarks

The ConnectionId is obtained from the QueryConnection.ConnectionId property. If a QueryConnection object is released without destroying it, the ConnectionId should be retained so that the connection may be restored at a later time.

The UserToken property must be set before calling this method.


UserToken Property (QueryConnectionManager)

Sets the user credentials under which the QueryConnectionManager and all connections is creates will operate

Settings and Return Values

Sets a UserToken object

Remarks

All QueryConnections created by this manager will execute searches as the user identified by the UserToken. This property must be set before calling any other QueryConnectionManager methods.

The property is write only.


QueryResults

QueryResults Object

Holds the results of a search executing on a QueryConnection

Remarks

The results of a search are held in two parts.

1) The QueryStatus holds status information about the executing query.

2) The Recordset holds returned data rows.


QueryStatus Property (QueryResults)

The QueryStatus object holding execution status information

Settings and Return Values

Returns a QueryStatus object.

Remarks

None


Recordset Property (QueryResults)

An ADO Recordset containing the search result rows.

Settings and Return Values

Returns an ADO Recordset object.

Remarks

None


QueryStatus

QueryStatus Object

Holds status information for a currently executing search

Remarks

None


Description Property (QueryStatus)

Reserved for future use.


RowCount Property (QueryStatus)

The number of rows currently available in the Search Manager Server’s cache.

Settings and Return Values

Returns a long value.

Remarks

None


Status Property (QueryStatus)

The current status of the Search Manager Server query

Settings and Return Values

Returns an Status value.

Remarks

The status may be values such as completed, processing, error, etc.

The property is read-only


SearchCondition

SearchCondition Object

A nested expression within a where clause

Remarks

A SearchCondition represents an expression inside parenthesis (a nested expression.) in a WhereClause. It may optionally have a conjunction (AND, OR, NOT AND, or NOT OR) in front of it . Thus, a search condition always has the form:

[conj] ( <expression> )

conj - A conjunction value that combines the SearchCondition items together in a SQL where clause. It may be AND, OR, NOT AND, or NOT OR. It may also be NOP indicating the condition has no conjunction preceding it (e.g. when it is the first item in another nested expression.)

<expression> May be one or more BinaryCondition objects conjuncted together, or it may contain another SearchCondition representing a nested expression within a nested expression

For example, in the SQL where clause:

WHERE col1 = "A" AND (col2 = "B" OR col3="C")

The underlined text is a single SearchCondition. The "B" and "C" items inside the parenthesis are the expression that would be contained in the SearchCondition.Conditions collection.

The next SQL Statement shows nesting within nesting.

WHERE col1 = "A" AND (col2 = "B" OR (col3="C" and col4="D"))

In this case, the outer "AND" SearchCondition contains an inner "OR" SearchCondition .


Conditions Property (SearchCondition)

Returns the collection of items representing the nested expression for this where condition

Settings and Return Values

Returns a Conditions collection.

Remarks

A SearchCondition represents a expression inside parenthesis (a nested expression.)

[conj] ( <expression> )

The <expression> is the conjunction of the ICondition items contained in the Conditions collection.


Conjunction Property (SearchCondition)

Specifies to conjunction preceding the nested expression in the where clause

Settings and Return Values

Sets and returns a Conjunction value.

Remarks

None


Not Property (SearchCondition)

Indicates whether the condition conjunction uses the NOT keyword.

Settings and Return Values

Returns a Boolean value.

Remarks

A true value for this property is equivalent to the Conjunction property equaling either cjANDNOT or cjORNOT.


Type Property (SearchCondition)

Indicates the type of ICondition

Settings and Return Values

Returns an ConditionType value.

Remarks

For a SearchCondition, the Type property should always return ConditionType.ctSearchCondition.

SearchConditions are contained in the Conditions collection. This collection can contain objects of two different types. The item should be returned into a variable of type _Condition, which is a base type that can be either a SearchCondition or a BinaryCondition. Once the _Condition is retrieved, its Type property can be checked to determine which condition type it is. Then it can be set into the appropriate typed variable. The following example demonstrates this procedure.

Dim objCondition As Stellent.IBPM.Interop.Imaging._Condition
 Dim objSearchCondition As Stellent.IBPM.Interop.Imaging.SearchCondition
 Dim objBinaryCondition As Stellent.IBPM.Interop.Imaging.BinaryCondition

 'objConditions is a populated Conditions collection
 For Each objCondition In objConditions
     Select Case objCondition.Type
         Case Stellent.IBPM.Interop.Imaging.ConditionType.ctSearchCondition
             objSearchCondition = objCondition
             'Do work with objSearchCondition
         Case Stellent.IBPM.Interop.Imaging.ConditionType.ctBinaryCondition
             objBinaryCondition = objCondition
             'Do work with objBinaryCondition
     End Select
 Next


SelectClause

SelectClause Object

Represents the SQL select clause portion of a SQL statement

Remarks

The SelectClause object is the select clause portion of a SQLSelect object, obtained from its SelectClause property.

A select clause is composed of individual SelectItemsExpression objects, each of which equates to a Column Name/Alias pair.

The following represents an example SQL select clause that might be represented by the SelectClause object.

SELECT  Column1 as Name, Column2 as Address, Column3 as Zip

The following code sample populates a SelectClause object to match this statement

Dim objSQLSelect As Stellent.IBPM.Interop.Imaging.SQLSelect
Dim objSelectClause As Stellent.IBPM.Interop.Imaging.SelectClause
Dim objSelItemExp As Stellent.IBPM.Interop.Imaging.SelectItemExpression

objSQLSelect = New Stellent.IBPM.Interop.Imaging.SQLSelect
objSelectClause = objSQLSelect.SelectClause

objSelItemExp = New Stellent.IBPM.Interop.Imaging.SelectItemExpression
objSelItemExp.Expression = "Column1"
objSelItemExp.Alias = "Name"
objSelectClause.SelectItems.Add objSelItemExp

objSelItemExp = New Stellent.IBPM.Interop.Imaging.SelectItemExpression
objSelItemExp.Expression = "Column2"
objSelItemExp.Alias = "Address"
objSelectClause.SelectItems.Add objSelItemExp

objSelItemExp = New Stellent.IBPM.Interop.Imaging.SelectItemExpression
objSelItemExp.Expression = "Column3"
objSelItemExp.Alias = "Zip"
objSelectClause.SelectItems.Add objSelItemExp

MsgBox objSQLSelect.SelectClause.SQLSubString


Validate Method

Validate Method (SelectClause)

Indicates whether a valid SQL select clause can be constructed from the SelectClause object

Return Type

A Boolean value.

Syntax

object.Validate

Remarks

None


Distinct Property (SelectClause)

Specifies whether the "DISTINCT" SQL keyword should be added to the select clause

Settings and Return Values

Returns a Boolean value.

Remarks

The DISTINCT keyword on a SQL statement forces the result set returned by the search to only contain completely unique rows. Using this option may have performance implications and should be used cautiously.


SelectItems Property (SelectClause)

Returns the collection of SelectItemExpression objects for the Select clause

Settings and Return Values

Returns a SelectItemExpression object

Remarks

The order in which SelectItemExpression objects are added to the collection in the order they will be used within the select clause.


SQLSubString Property (SelectClause)

Returns a textual representation of the select clause

Settings and Return Values

Returns a string value.

Remarks

This property is primarily used for debugging purposed to verify that the SelectClause is accurately representing the desired statement

The property is read-only.


SelectItem

SelectItem Object

Represents a single item in a select clause.

Remarks

The SQL select clause represented by the SelectClause object is of the form

Select <expression> AS <alias>, <expression> AS <alias>,...

Each "<expression> AS <alias>" is represented in a single SelectItem object.

<expression> - Expression defining the source of data for the result set column

<alias> - The alias string to be the label for the result set column

SelectItem objects are added to a SelectClause.SelectItems collection to form the SQL select clause.


Alias Property (SelectItem)

The alias string to be the label for the result set column.

Property type

A String value.

Syntax

object.Alias [= value]

Remarks

SelectItem represent a single item in a SQL Select clause of the form:

<expression> AS <alias>

The <alias> value is set or returned by this property.


Expression Property (SelectItem)

Expression defining the source of data for the result set column.

Property type

A String value.

Syntax

object.Expression [= value]

Remarks

SelectItem represent a single item in a SQL Select clause of the form:

<expression> AS <alias>

The <expression> value is set or returned by this property.


SelectItems

SelectItems Collection

A collection containing the SelectItemExpression objects for the select clause.

Remarks

The order in which the SelectItemExpression objects are added to the collection is the order they will be used in the SQL clause.


Add Method

Add Method (SelectItems)

Adds a new SelectItemExpression to the collection

Syntax

object.Add(Item As ISelectItem)

Parameters

Part | Description
Item | The SelectItemExpression object to be added to the collection

Remarks

None


Item Method

Item Method (SelectItems)

Returns a specified object out of the collection

Return Type

Returns a SelectItemExpression object

Syntax

object.Item(Index As Variant)

Parameters

Part | Description
Index | A variant value indicating the ordinal index of the SelectItemExpression to be retrieved from the collection

Remarks

None


Remove Method

Remove Method (SelectItems)

Removes the specified object from the collection

Syntax

object.Remove(Index As Variant)

Parameters

Part | Description
Index | A variant value indicating the ordinal index of the SelectItemExpression to be removed from the collection

Remarks

None


RemoveAll Method

RemoveAll Method (SelectItems)

Removes all objects from the collection

Syntax

object.RemoveAll

Remarks

None


Count Property (SelectItems)

Indicates the number of SelectItemExpression objects populated in the collection.

Settings and Return Values

Returns a long value

Remarks

The property is read-only


SQLSelect

SQLSelect Object

Represents a SQL select statement for executing a search against the Imaging system

Remarks

The SQLSelect generically represents a SQL select statement. It can be created as a new object, filled in, and executed as an Ad-Hoc search. it can also be obtained from a NamedQuery object, in which case it will contain a representation of the SQL statement the the named search will execute.

The SQL statement represented by SQLSelect contains three basic components:

1) A SelectClause which lists the table column names and aliases that are to be returned in the result set.

2) A FromClause which lists the table named from which the data will be selected

3) A WhereClause which contains the criteria for selecting the data to be returned

Once the three clauses are filled in, the SQLString property will display a textual representation of the entire SQL select statement. A Validate method is available that will parse the entire SQLSelect object and return a Boolean indicating whether a valid SQL statement can been constructed.


Validate Method

Validate Method (SQLSelect)

Indicates whether a valid SQL statement can be constructed from the SQLSelect object

Return Type

A Boolean value.

Syntax

object.Validate

Remarks

None


FromClause Property (SQLSelect)

Returns an object representing the SQL statement from clause

Settings and Return Values

Returns a FromClause object

Remarks

The property is read-only


SelectClause Property (SQLSelect)

Returns an object representing the SQL statement select clause

Settings and Return Values

Returns a SelectClause object

Remarks

The property is read-only


SQLString Property (SQLSelect)

Returns a textual representation of the entire SQL select statement

Settings and Return Values

Returns a string value.

Remarks

This property is primarily used for debugging purposed to verify that the SQLSelect is accurately representing the desired statement

The property is read-only.


WhereClause Property (SQLSelect)

Returns an object representing the SQL statement where clause

Settings and Return Values

Returns a WhereClause value.

Remarks

The property is read-only.


Table

Table Object

Represents a table with the database

Remarks

None


FieldAttributes Property (Table)

A collection details the attribute for the field in the Table

Settings and Return Values

Returns a FieldAttributes value.

Remarks

None


Fields Property (Table)

Returns the fields collection for the tabs

Settings and Return Values

Returns an ADO Fields collection.

Remarks

The return value is an ADO Fields collection object containing a field for each column in the table.

The Table object is used as the container for passing index information into the DocumentManager object. The Field.Value property on each field object in the Fields collection is set, and then the entire Table object is passed in the DocumentManager method.


FullName Property (Table)

Returns the fully qualified table name

Settings and Return Values

Returns a string value.

Remarks

Table names in Imaging take the form

LinkedServer.Instance.Schema.Table

The first two values name the connection, and the second two name the table within the connection.

This property returns the full 4-dot separated table name

The property is read-only.


Name Property (Table)

Returns the table Name value

Settings and Return Values

Returns a String value.

Remarks

Table names in Imaging take the form

LinkedServer.Instance.Schema.Table

The first two values name the connection, and the second two name the table within the connection.

This property returns the second two values, Schema.Table

The property is read-only.


Schema Property (Table)

The schema name of the table

Settings and Return Values

Returns a string value.

Remarks

Table names in Imaging take the form

LinkedServer.Instance.Schema.Table

The first two values name the connection, and the second two name the table within the connection.

This property returns the third value, Schema

The property is read-only.


Table Property (Table)

The table name of the table

Settings and Return Values

Returns a string value.

Remarks

Table names in Imaging take the form

LinkedServer.Instance.Schema.Table

The first two values name the connection, and the second two name the table within the connection.

This property returns the fourth value, Table

The property is read-only.


Tables

Tables Collection

A collection of Table objects, each representing a table within the database

Remarks

This collection is obtained from the Connection.Tables property which automatically calls refresh before returning the collection.


Item Method

Item Method (Tables)

Returns a specified object out of the collection

Return Type

Returns a Table object

Syntax

object.Item(Index As Variant)

Parameters

Part | Description
Index | A variant value indicating either the ordinal index or the string name of the Table to be retrieved from the collection

Remarks

None


Refresh Method

Refresh Method (Tables)

Populates the collection with Table objects

Syntax

object.Refresh

Remarks

None


Count Property (Tables)

Indicates the number of Table objects populated in the collection.

Settings and Return Values

Returns a long value

Remarks

The property is read-only


Style Property (Tables)

Specifies the method to be used to refresh the collection

Settings and Return Values

Sets a long value

Remarks

The long value is a bit mask of Style enumeration values

The property is write only


WhereClause

WhereClause Object

Represents the SQL where clause portion of a SQL statement

Remarks

The WhereClause object is the where clause portion of a SQLSelect object, obtained from its WhereClause property.

A SQLSelect where clause is made of up two different types of items.

1) A BinaryCondition is an expression comparing two values, preceded by a Conjunction

2) A SearchCondition represents an expression inside parenthesis (a nested expression.) preceded by a Conjunction

Note that the WhereClause object has a SearchCondition property that represents the entire clause as if it were simply another nested expressions.

By containing expressions nested within other expressions, the WhereClause object can represent arbitrarily complex conditional statements in a hierarchical fashion.

For example, the following where clause:

WHERE col1="A" and (col2
  ="B" or (col3="C" and col4="D") or
  Col5="E")

is represented by the following object hierarchy. Notice that each instance of nesting in the object model correlates directly to the nesting in the SQL where clause.

The following code generate the above statement and hierarchy

Dim objSQLSelect
     As Stellent.IBPM.Interop.Imaging.SQLSelect
Dim objWhereClause  As
            Stellent.IBPM.Interop.Imaging.WhereClause
Dim objBC  As
            Stellent.IBPM.Interop.Imaging.BinaryCondition
Dim objSC_AND  As
            Stellent.IBPM.Interop.Imaging.SearchCondition
Dim objSC_OR  As
            Stellent.IBPM.Interop.Imaging.SearchCondition

' col1 = "A"
Set objBC =  New
            Stellent.IBPM.Interop.Imaging.BinaryCondition
objBC.LeftValue = "Col1"
objBC.Operator = opEqual
objBC.RightValue = "A"
objWhereClause.SearchCondition.Conditions.Add objBC

'And (
objSC_AND =  New
            Stellent.IBPM.Interop.Imaging.SearchCondition
objSC_AND.Conjunction = cjAND

' col2 = "B"
objBC =  New
            Stellent.IBPM.Interop.Imaging.BinaryCondition
objBC.LeftValue = "Col2"
objBC.Operator = opEqual
objBC.RightValue = "B"
objSC_AND.Conditions.Add objBC

'Or (
objSC_OR =  New
            Stellent.IBPM.Interop.Imaging.SearchCondition
objSC_OR.Conjunction = cjOR

' col3 = "C"
objBC =  New
            Stellent.IBPM.Interop.Imaging.BinaryCondition
objBC.LeftValue = "Col3"
objBC.Operator = opEqual
objBC.RightValue = "B"
objSC_OR.Conditions.Add objBC

'or col4 = "D"
objBC =  New
            Stellent.IBPM.Interop.Imaging.BinaryCondition
objBC.Conjunction = cjOR
objBC.LeftValue = "Col4"
objBC.Operator = opEqual
objBC.RightValue = "D"
objSC_OR.Conditions.Add objBC

' )
objSC_AND.Conditions.Add objSC_OR

'or col5 = "E"
objBC =  New
            Stellent.IBPM.Interop.Imaging.BinaryCondition
objBC.Conjunction = cjOR
objBC.LeftValue = "Col5"
objBC.Operator = opEqual
objBC.RightValue = "E"
objSC_AND.Conditions.Add objBC

')
objWhereClause.SearchCondition.Conditions.Add objSC_AND


Validate Method

Validate Method (WhereClause)

Indicates whether a valid SQL where clause can be constructed from the WhereClause object

Return Type

A Boolean value.

Syntax

object.Validate

Remarks

None


SearchCondition Property (WhereClause)

The SearchCondition object representing the entire nested where clause.

Settings and Return Values

Returns a SearchCondition object

Remarks

None


SQLSubString Property (WhereClause)

Returns a textual representation of the where clause

Settings and Return Values

Returns a string value.

Remarks

This property is primarily used for debugging purposed to verify that the WhereClause is accurately representing the desired statement

The property is read-only.


ConditionType enumeration

Members

Constant | Value
ctBinaryCondition | 1
ctSearchCondition | 0


Conjunction enumeration

Members

Constant | Value
cjAND | 0
cjANDNOT | 3
cjNOP | 2
cjOR | 1
cjORNOT | 4


ConnectionProperty enumeration

Members

Constant | Value
cpAll | 65535
cpDefault | 1
cpOptikaInternal | 2
cpReadOnly | 4
cpUnknown | 0
cpWriteOnly | 8


DataType enumeration

Members

Constant | Value
dtBigInt | 20
dtBinary | 128
dtBoolean | 11
dtBSTR | 8
dtChapter | 136
dtChar | 129
dtCurrency | 6
dtDate | 7
dtDBDate | 133
dtDBFileTime | 137
dtDBTime | 134
dtDBTimeStamp | 135
dtDecimal | 14
dtDouble | 5
dtEmpty | 0
dtError | 10
dtFileTime | 64
dtGUID | 72
dtIDispatch | 9
dtInteger | 3
dtIUnknown | 13
dtLongVarBinary | 205
dtLongVarChar | 201
dtLongVarWChar | 203
dtNumeric | 131
dtPropVariant | 138
dtSingle | 4
dtSmallInt | 2
dtTinyInt | 16
dtUnsignedBigInt | 21
dtUnsignedInt | 19
dtUnsignedSmallInt | 18
dtUnsignedTinyInt | 17
dtUserDefined | 132
dtVarBinary | 204
dtVarChar | 200
dtVariant | 12
dtVarNumeric | 139
dtVarWChar | 202
dtWChar | 130


DisplayStyle enumeration

Members

Constant | Value
dsDisplay | 1
dsHidden | 0
dsPickList | 4
dsPrompt | 2
dsPromptReq | 3


ExportFileType Enumeration

Members

Constant | Value
otiExportGIF | 0
otiExportBMP | 1
otiExportTIF | 2
otiExportJPG | 3
otiExportPCX | 4
otiExportOptika | 5
otiExportNative | 6
otiExportEMF | 7
otiExportPDF | 8
otiExportSmartMode | 9


FieldProperty enumeration

Members

Constant | Value
fpAll | 65535
fpDM | 8
fpFullText | 4
fpField | 1
fpSystem | 2
fpUnknown | 0


NamedQueriesACCFilter enumeration

Members

Constant | Value
nqfDelete | 2
nqfExecute | 0
nqfModify | 1


Operator enumeration

Members

Constant | Value
opAdvSearch | 19
opAllValues | 21
opBeginsWith | 6
opContains | 8
opEndsWith | 7
opEqual | 0
opExactPhrase | 20
opGreaterThan | 2
opGreaterThanEqual | 4
opIn | 14
opLessThan | 3
opLessThanEqual | 5
opLike | 9
opNotBeginsWith | 11
opNotContains | 13
opNotEndsWith | 12
opNotEqual | 1
opNotIn | 15
opNotLike | 10
opSearch | 18


PicklistStyle enumeration

Members

Constant | Value
psForcedSelection | 1
psNone | 0


PageNumber enumeration

Members

Constant | Value
pnFirst | 1
pnLast | -1


PasteAction Enumeration

Members

Constant | Value
Copy | 1
Cut | 2


RecordsetManagement enumeration

Members

Constant | Value
rsmManaged | 0
rsmUnmanaged | 1


RecordsetReturn enumeration

Members

Constant | Value
rsrAll | 2
rsrAvailable | 1


SchemaACCFilter enumeration

Members

Constant | Value
sfAdHocQuery | 15
sfAnnotate | 6
sfAnnotateAdmin | 7
sfBlackRedaction | 9
sfCreateIndex | 5
sfDelete | 0
sfDocAnnotation | 2
sfLaunch | 11
sfLockAccess | 3
sfLockOverride | 4
sfModifyIndex | 13
sfNamedQueryCreation | 16
sfPrintFax | 1
sfSpanDocs | 12
sfStampAdmin | 8
sfView | 14
sfWhiteRedaction | 10


Status enumeration

Members

Constant | Value
qsComplete | 2
qsError | 4
qsNoConnection | 8
qsNoQuery | 16
qsProcessing | 1
qsStopped | 32


Style enumeration

Members

Constant | Value
csNone | 0
csUseAccCache | 1


TableProperty enumeration

Members

Constant | Value
tpAcordeIndex | 1024
tpAlias | 1
tpAll | 65535
tpCIndex | 16384
tpCold2Sql | 8192
tpeMedia | 256
tpFullText | 4096
tpGlobalTemp | 32
tpImaging | 2048
tpLocalTemp | 64
tpReadOnly | 512
tpRecordsManaged | 32768
tpSynonym | 4
tpSystem | 8
tpSystemView | 128
tpTable | 2
tpUnknown | 0
tpView | 16


ApplicationName property (Table)

property ApplicationName

Property type

A String value.

Syntax

object.ApplicationName [= value]

The ApplicationName property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Table.
value | A String value.


BatchID property (Table)

property BatchID

Property type

A Long value.

Syntax

object.BatchID [= value]

The BatchID property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Table.
value | A Long value.


IndexName property (Table)

property IndexName

Property type

A String value.

Syntax

object.IndexName [= value]

The IndexName property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Table.
value | A String value.


NextVolume property (Table)

property NextVolume

Property type

A _Volume value.

Syntax

object.NextVolume [= value]

The NextVolume property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Table.
value | A _Volume value.


ReplaceEnabled property (Table)

property ReplaceEnabled

Property type

A Boolean value.

Syntax

object.ReplaceEnabled [= value]

The ReplaceEnabled property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Table.
value | A Boolean value.


StorageClassID property (Table)

property StorageClassID

Property type

A Long value.

Syntax

object.StorageClassID [= value]

The StorageClassID property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Table.
value | A Long value.


VersionEnabled property (Table)

property VersionEnabled

Property type

A Boolean value.

Syntax

object.VersionEnabled [= value]

The VersionEnabled property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Table.
value | A Boolean value.