BPM Object Library Overview

Stellent.IBPM.Interop.Process


Process Toolkit Collections

Process SDK™ Toolkit Collections

The relationships between these collections and the Toolkit objects are represented in the Process Toolkit Object Model.

Each collection can contain its corresponding object. For example, an Package object can be contained in an Packages collection. For more information about objects, see Process Toolkit Objects or a specific object topic.

Process Toolkit Collection Summary

Collection
Attachments
AttachmentTypes
Audits
AutoAttachments
Databases
DecisionChoices
Events
FieldCriteria
FieldDefinitions
FieldDistinctList
FieldPickList
FieldValues
Forms
LocationCriteria
MapHotSpots
Packages
Processes
ProcessTemplates
PromptCriteria
Prompts
Queues
SortCriteria
StartEvents
SubProfiles
TaskDefinitions
Tasks
TemplateProcesses
Templates
WFUsers


Attachments

Attachments Collection

Contains all of the Attachment objects for a specific Package.

Remarks

The Attachments collection is always obtained from the Attachments property of the Package object. It is used to contain and maintain the list of attachments on the given package.

When retrieved from the Package object, the Package calls the collection's Refresh method internally. As a result, the collection is returned "hydrated," and it is not necessary to call Refresh to initially fill the collection.


DataChanged Event (Attachments)

Fired when any changes to an Attachments Collection are committed to the database.

Syntax

DataChanged

Remarks

The Attachments DataChanged event is fired as a result of a call to the Commit method. This allows code with multiple views into the collection to synchronize changes that may have been made to the objects within the collection.


Commit Method

Commit Method (Attachments)

Used to update the BPM database with changes to the Attachments collection for a Package.

Syntax

object.Commit

Remarks

Commit will transmit to the BPM database all changes to the Attachments collection. Any new Attachment objects that have been created through the CreateAttachment property will added to the database. Any modified Attachment objects (i.e. with changes made to properties of a pre-existing object) will be updated in the database. Finally, any Attachment objects that have had their MarkDeleted property set to True will be removed from the package and database.

After Commit has been called, the internal status of all Attachment objects (either created, modified) will be reset to unmodified. Any MarkDeleted Attachment objects will no longer exist in the collection. As a result, calling Commit may change the Count of items in the collection. The calling code must account for this potential change when persisting Item ordinal values.

Calling the Attachments Refresh method without calling Commit will also reset the internal status of all objects, including those with MarkDeleted set, back to the unmodified state and will discard any newly created Attachment objects. This functionality can be used to roll-back any undesired changes to the objects within the collection.

A call to Commit will cause the Attachments collection to fire its DataChanged event.

Attempting to Commit Attachments with an invalid file path will not return an error.


CreateAttachment Method

CreateAttachment Method (Attachments)

Used to create a new Attachment object within the Attachments collection.

Return Type

Returns an object reference that evaluates to an Attachment object.

Syntax

Set object = Attachments.CreateAttachment

Remarks

The CreateAttachment method creates an new Attachment object with the collection. The newly created attachment is empty so its Title, DocumentId, and IndexId properties must be set for the attachment object to reference real data. Once created, the Attachment exists in a "new" state and has an AttachmentId which is less than 1. It does not get fully attached to the package until the Attachments Commit method is call. If Refresh is called before Commit, the "new" attachment is discarded.


FindById method

FindById Method (Attachments)

Finds a specific attachment in the collection based on the AttachmentId.

Return Type

Returns an object reference that evaluates to an Attachment object or Nothing if an attachment cannot be found with that AttachmentId.

Syntax

object.FindById(Id As Long)

The FindById method syntax has these parts:

Part | Description
Id | AttachmentId of the attachment you are trying to obtain.

Remarks

FindById will search through a collection attempting to match the provided id. The collection must be populated prior to calling FindById. If the given key does not match any member of the collection, a Nothing object reference is returned.


Refresh Method (Attachments)

Fills an Attachments collection with the Attachment objects for a specific Package.

Syntax

Attachments.Refresh

Remarks

The refresh method refills the Attachments collection with the Attachment objects for a specific Package instance, retrieving the most current information from the BPM database.

Calling the Attachments Refresh method without calling Commit will reset the internal status of all objects, including those with MarkDeleted set, back to the unmodified state and will discard any Attachment objects newly created by the CreateAttachment method. This functionality can be used to roll-back any undesired changes to the objects within the collection.

The Package object Attachments property calls the Refresh method internally. As a result, the collection is returned "hydrated," and it is not necessary to call Refresh to initially fill the collection.


_NewEnum Property

_NewEnum is a hidden property used to support the For Each ... Next syntax within VB.NET.

Remarks

This property is rarely called directly. Instead, it allows a collection to be accessed as in the following code:

Dim objDatabases As New Stellent.IBPM.Interop.Process.Databases
Dim objDatabase As Stellent.IBPM.Interop.Process.Database

objDatabases.Refresh()

For Each objDatabase In objDatabases
'Do Something
Next

For more information, see help for the For Each ... Next syntax in the VB.NET documentation.


Count Property

Indicates the number of objects in a collection.

Return Value

Returns a Long value.

Remarks

Use the Count property to determine how many objects are in a given collection.

Because numbering for members of a collection begins with one, you should always code loops starting with the one member and ending with the value of the Count. If you are using Microsoft Visual Basic and want to loop through the members of a collection without checking the Count property, use the For Each...Next command.

If the Count property is zero, there are no objects in the collection.


Item Property

Indicates a specific member of a collection by ordinal number.

Syntax

Set object = collection.Item ( Index )

Property type

Returns an object reference.

Parameters

Index - A Long expression that evaluates to the ordinal number of an object in a collection.

Remarks

Use the Item property to return a specific object in a collection. The index for a collection always starts at one and goes up to the value of the collections Count Property. If Item cannot find an object in the collection corresponding to the Index argument, an error occurs. The Item property is the default property for all collections; therefore, the following syntax forms are interchangeable:

collection.Item (Index)

collection (Index)


AttachmentTypes

AttachmentTypes Collection

Contains all of the AttachmentType objects for a specific package template definition.

Remarks

The Attachments collection is always obtained from either the Template.AttachmentTypes property or the ProcessTemplate.AttachmentTypes property. It is used to enumerate the list of attachment types for the given package template definition.

The Template.AttachmentTypes property and the ProcessTemplate.AttachmentTypes properties both call the collection's Refresh method internally. As a result, the collection is returned "hydrated," and it is not necessary to call Refresh to initially fill the collection.


FindById method

FindById Method (AttachmentTypes)

Finds a specific attachment type in the collection based on the AttachmentTypeId.

Return Type

Returns an object reference that evaluates to an AttachmentType object or Nothing if an attachment type cannot be found with that AttachmentTypeId.

Syntax

object.FindById(Id As Long)

The FindById method syntax has these parts:

Part | Description
Id | AttachmentTypeId of the attachment type you are trying to obtain.

Remarks

FindById will search through a collection attempting to match the provided id. The collection must be populated prior to calling FindById. If the given key does not match any member of the collection, a Nothing object reference is returned.


Refresh Method (AttachmentTypes)

Fills an AttachmentTypes collection with the AttachmentType objects for a specific package template.

Syntax

AttachmentTypes.Refresh

Remarks

Fills an AttachmentTypes collection with the AttachmentType objects for a specific package template, retrieving the most current information from the BPM database.

The Template.AttachmentTypes property and the ProcessTemplate.AttachmentType property both call the collection's Refresh method internally. As a result, the collection is returned "hydrated," and it is not necessary to call Refresh to initially fill the collection.


Audits

Audits Collection

Contains the Audit objects for a specific Package.

Remarks

The Audits collection contains Audit objects. Each Audit object represents a singe audit entry for the package. The Audits collection is retrievable from the Package.Audits property.


DataChanged Event

DataChanged Event (Audits)

Fired when any changes to an Audits collection are made.

Syntax

DataChanged

Remarks

The Audits DataChanged event is fired as a result of a call to the Refresh method or when a comment is added using Package.AddJournalEntry .


Refresh Method (Audits)

Fills an Audits collection with the Audit objects for a specific Package.

Syntax

Audits.Refresh

Remarks

Fills an Audits collection with the Audit objects for a specific Package, retrieving the most current information from the BPM database.

The Package object Audits property calls the Refresh method internally. As a result, the collection is returned "hydrated," and it is not necessary to call Refresh to initially fill the collection.


AutoAttachments

AutoAttachments Collection

Contains the Attachment objects that should be auto loaded for a locked package.

Remarks

The AutoAttachments collection is retrievable from the Package.AutoAttachments property. This collection should be retrieved in response to a Packages.AutoLoad Event. If the Count of the collection is non-zero during the handling of this Event, each Attachment in the collection should be launched. The Attachment objects that are included in the collection is determined by the auto load configuration for the queue in which the package is located and the AttachmentType values for the attachments in the package.


FindById method

FindById Method (AutoAttachments)

Finds a specific attachment in the collection based on the AttachmentId.

Return Type

Returns an object reference that evaluates to an Attachment object or Nothing if an attachment cannot be found with that AttachmentId.

Syntax

object.FindById(Id As Long)

The FindById method syntax has these parts:

Part | Description
Id | AttachmentId of the attachment you are trying to obtain.

Remarks

FindById will search through a collection attempting to match the provided id. The collection must be populated prior to calling FindById. If the given key does not match any member of the collection, a Nothing object reference is returned.


Databases

Databases Collection

Contains the Database objects defined on the Process Broker machine(s).

Remarks

The Databases collection is a creatable object. Once created, the Refresh method can be called to populate the collection with objects. The collection does not need a UserToken object to Refresh.


Refresh Method (Databases)

Fills a Databases collection with the Database objects defined on the Process Broker machine(s).

Syntax

Databases.Refresh

Remarks

Fills a Databases collection with the Database objects defined on the Process Broker machine(s), retrieving the most current information. The Databases collection is the only component within the Process SDK™ Toolkit Object Model that does not require a UserToken object to refresh.


ConnectedDatabase Property (Databases)

This property contains the databases that a UserToken is currently connected to.

Return Values

Returns an object indicating which databases a UserToken is currently connected to.


Default Property (Databases)

This property contains the database object that is used for the default database.

Settings and Return Values

Sets and returns an Object that indicates the default database to work with.


IsConnected Property (Databases)

This property specifies whether or not the UserToken is connected to the current database.

Return Values

Returns a Boolean value indicating whether or not a UserToken is currently connected to the database.


DecisionChoices

DecisionChoices Collection

Contains the DecisionChoice objects for a given Queue.

Remarks

The DecisionChoices object contains DecisionChoice objects. Each DecisionChoice object represents a path that a Package object can follow when completed. DecisionChoices are only available for a Queue when a user must decide the intended route of the Package. BPM Builder is used to set the DecisionChoices for a Queue.

The DecisionChoices collection is retrieved from the Queue object. The HasDecisions property of a Queue should be checked before trying to retrieve the DecisionChoices collection.

The DecisionChoices.Item methods can be used to find a DecisionChoice object based on the DecisionText as well.


Refresh Method (DecisionChoises)

Refresh Method (DecisionChoices)

Fills a DecisionChoices collection with the DecisionChoice objects for a specific queue.

Syntax

DecisionChoices.Refresh

Remarks

Fills a DecisionChoices collection with the DecisionChoice objects for a specific queue, retrieving the most current information from the BPM database.

The Queue.DecisionChoices property calls the collection's Refresh method internally. As a result, the collection is returned "hydrated," and it is not necessary to call Refresh to initially fill the collection.


Events

Events Collection

Contains the Event objects defined for a given process.

Remarks

The Events collection contains Event objects. Each Event object represents a single event within a process which has been applied from the BPM Builder.

The Events collection is retrieved from either Process.Events or from TemplateProcess.Events.


FindById method

FindById Method (Events)

Finds a specific event in the collection based on the EventId.

Return Type

Returns an object reference that evaluates to an Event object or Nothing if an event cannot be found with that EventId.

Syntax

object.FindById(Id As Long)

The FindById method syntax has these parts:

Part | Description
Id | EventId of the event you are trying to obtain.

Remarks

FindById will search through a collection attempting to match the provided id. The collection must be populated prior to calling FindById. If the given key does not match any member of the collection, a Nothing object reference is returned.


Refresh Method (Events)

Fills an Events collection with the Event objects for a specific process.

Syntax

Events.Refresh

Remarks

Fills an Events collection with the Event objects for a specific process, retrieving the most current information from the BPM database.

The Process. Events and the TemplateProcess.Events properties both call the collection's Refresh method internally. As a result, the collection is returned "hydrated," and it is not necessary to call Refresh to initially fill the collection.


FieldCriteria

FieldCriteria Collection

The FieldCriteria object represents a mechanism for expressing how Package objects will be (have been) selected for inclusion in a Packages collection. A FieldCriteria object is a collection of FieldCriterion objects.

See Also

ProfileCriteria


AddItem Method

AddItem Method (FieldCriteria)

Adds a FieldCriterion object to the collection.

Return Type

None.

Syntax

object.AddItem(newVal As FieldCriterion)

Parameters

Part | Description
newVal | The FieldCriterion object to be added to the collection.

See Also

ProfileCriteria


RemoveAll Method

RemoveAll Method (FieldCriteria)

Removes all FieldCriterion objects from the collection.

Return Type

None.

Syntax

object.RemoveAll

See Also

ProfileCriteria


RemoveItem Method

RemoveItem Method (FieldCriteria)

Removes the specified FieldCriterion from the collection.

Return Type

None.

Syntax

object.RemoveItem(Index As Long)

Parameters

Part | Description
Index | The index of the object to be removed.

See Also

ProfileCriteria


FieldDefinitions

FieldDefinitions Collection

Contains the FieldDefinition objects for a given Template object.

Remarks

The FieldDefinitions collection contains FieldDefinition objects. Each FieldDefinition object describes a data field in a Template object.


FindById method

FindById Method (FieldDefinitions)

Finds a specific field definition in the collection based on the FieldId.

Return Type

Returns an object reference that evaluates to an FieldDefinition object or Nothing if a field definition cannot be found with that FieldId.

Syntax

object.FindById(Id As Long)

The FindById method syntax has these parts:

Part | Description
Id | FieldId of the field definition you are trying to obtain.

Remarks

FindById will search through a collection attempting to match the provided id. The collection must be populated prior to calling FindById. If the given key does not match any member of the collection, a Nothing object reference is returned.

The SystemFieldId enumeration can be used to set the key to search for System Fields within the collection. To use this enumeration, set the Id to the desired SystemFieldId enumeration constant value.


Refresh Method (FieldDefinitions)

Fills a FieldDefinitions collection with the FieldDefinition objects for a specific package template.

Syntax

FieldDefinitions.Refresh

Remarks

Fills a FieldDefinitions collection with the FieldDefinition objects for a specific package template, retrieving the most current information from the BPM database.

The Template. FieldDefinitions property and the ProcessTemplate.FieldDefinitions property both call the collection's Refresh method internally. As a result, the collection is returned "hydrated," and it is not necessary to call Refresh to initially fill the collection.


FieldDistinctList

FieldDistinctList Object

Represents a list of distinct field values currently in the database for this field.

Remarks

The FieldDistinctList object can be retrieved from a FieldDefinition object.

Note: Since system fields are not specific to any particular template, distinct lists for system fields will return values from all package templates in the Process database. Also, because date values are unique down the millisecond (for most supported databases) retrieving the distinct list for a date field (especially a system field date) is a potentially time consuming operation, as there are likely to be a large number of unique date values.


Refresh Method (FieldDistinctList)

Fills a FieldDistinctList collection with the distinct list of values currently set across all packages instances a specific FieldDefinition of a given package template.

Syntax

FieldDistinctList.Refresh

Remarks

Fills a FieldDistinctList collection with the distinct list of values currently set across all packages instances a specific FieldDefinition of a given package template. The values are returned as Variant data type which matches the FieldDefinition's type.

The FieldDefinition.FieldDistinctList property calls the Refresh method internally. As a result, the collection is returned "hydrated," and it is not necessary to call Refresh to initially fill the collection.


Item Property (FieldDistinctList)

Indicates a specific member of a FieldDistinctList collection by ordinal number.

Syntax

variant = collection.Item> ( Index )

Property Type

Returns a Variant value

Parameters

Index A Long expression that evaluates to the ordinal number of an object in a collection.

Remarks

Use the Item property to return a specific object in a FieldDistinctList collection. The index for a collection always starts at one and goes up to the value of the collections Count Property. If Item cannot find an object in the collection corresponding to the Index argument, an error occurs. The Item property is the default property for all collections; therefore, the following syntax forms are interchangeable:

FieldDistinctList.Item (Index)

FieldDistinctList(Index)


FieldPickList

FieldPickList Object

The FieldPickList object contains string values for a field. The values are expected data field values that were set in BPM Builder.

Remarks

The FieldPickList object can be obtained from a FieldDefinition object.


Refresh Method (FieldPickList)

Fills a FieldPickList collection with the define pick list values for specific FieldDefinition of a given package template.

Syntax

FieldPickList.Refresh

Remarks

Fills a FieldPickList collection with the define pick list values for specific FieldDefinition of a given package template. The values are returned as String values. The FieldDefinition.HasPickList property will be True if a pick list has been define for the field. If the HasPickList Property is False, then the FieldPickList.Count property will equal zero.

The FieldDefinition.FieldPickList property calls the Refresh method internally. As a result, the collection is returned "hydrated," and it is not necessary to call Refresh to initially fill the collection.


Item Property (FieldPickList)

Indicates a specific member of a FieldPickList collection by ordinal number.

Syntax

string = collection.Item ( Index )

Property Type

Returns a String value

Parameters

Index A Long expression that evaluates to the ordinal number of an object in a collection.

Remarks

Use the Item property to return a specific object in a FieldPickList collection. The index for a collection always starts at one and goes up to the value of the collections Count Property. If Item cannot find an object in the collection corresponding to the Index argument, an error occurs. The Item property is the default property for all collections; therefore, the following syntax forms are interchangeable:

FieldPickList.Item (Index)

FieldPickList(Index)


FieldValues

FieldValues Collection

Contains the FieldValue objects available a given package.

Remarks

The FieldValues collection is retrieved from Package.FieldValues property. The collection is used to read and update the field values for a specific package instance.


Commit Method

Commit Method (FieldValues)

Updates the BPM database with all changes that have been made upon the FieldValue objects contained in the FieldValues collection.

Return Type

None.

Syntax

object.Commit

Remarks

Calling Refresh subsequent to any changes made upon the FieldValue objects contained in the FieldValues collection (and prior to any calls to Commit) has the effect of rolling back the uncommitted changes.


FindById method

FindById Method (FieldValues)

Finds a specific field value in the collection based on the FieldId.

Return Type

Returns an object reference that evaluates to a FieldValue object or Nothing if a field value cannot be found with that FieldId.

Syntax

object.FindById(Id As Long)

The FindById method syntax has these parts:

Part | Description
Id | FieldId of the field value you are trying to obtain.

Remarks

FindById will search through a collection attempting to match the provided id. The collection must be populated prior to calling FindById. If the given key does not match any member of the collection, a Nothing object reference is returned.

The SystemFieldId enumeration can be used to set the key to search for System Fields within the collection. To use this enumeration, set the Id to the desired SystemFieldId enumeration constant value.


Refresh Method (FieldValues)

Fills a FieldValues collection with the FieldValue objects for a specific Package instance.

Syntax

FieldValues.Refresh

Remarks

Fills a FieldValues collection with the FieldValue objects for a specific Package instance, retrieving the most current information from the BPM database.

The Package object FieldValues property calls the Refresh method internally. As a result, the collection is returned "hydrated," and it is not necessary to call Refresh to initially fill the collection.


Forms

Forms Collection

Contains the Form objects defined for a given template definition or for a given package.

Remarks

When the Forms collection is retrieved from Template.Forms or from a ProcessTemplate_Forms , the collection populate with all Form objects defined for that template. When the collection is retrieved from a Package object, it will populate the collection with all forms which are defined for display at the package's current queue location.


FindById method

FindById Method (Forms)

Finds a specific form in the collection based on the FormId.

Return Type

Returns an object reference that evaluates to a Form object or Nothing if a form cannot be found with that FormId.

Syntax

object.FindById(Id As Long)

The FindById method syntax has these parts:

Part | Description
Id | FormId of the form you are trying to obtain.

Remarks

FindById will search through a collection attempting to match the provided id. The collection must be populated prior to calling FindById. If the given key does not match any member of the collection, a Nothing object reference is returned.


Refresh Method (Forms)

Fills a Forms collection with the Form objects for a specific package template or for a specific package.

Syntax

Forms.Refresh

Remarks

Fills a Forms collection with the Form objects for a specific package template or for a specific package, retrieving the most current information from the BPM database. When the Forms collection is retrieved from a Template object or from a ProcessTemplate object, Refresh will populate the collection with all Form objects defined for that template. When the collection is retrieved from a Package object, Refresh will populate the collection with all forms which are defined for display at the package's queue location.

The Template.Forms property and the ProcessTemplate.Forms property both call the collection's Refresh method internally. As a result, the collection is returned "hydrated," and it is not necessary to call Refresh to initially fill the collection.


LocationCriteria

LocationCriteria Collection

The LocationCriteria object represents a mechanism for expressing how Package objects will be (have been) selected for inclusion in a Packages collection. A LocationCriteria object is a collection of LocationCriterion objects.

See Also

ProfileCriteria


AddItem Method

AddItem Method (LocationCriteria)

Adds a LocationCriterion to the collection.

Return Type

None.

Syntax

object.AddItem(newVal As LocationCriterion)

Parameters

Part | Description
newVal | The LocationCriterion object to be added to the collection.

See Also

ProfileCriteria


RemoveAll Method

RemoveAll Method (LocationCriteria)

Removes all LocationCriterion objects from the collection.

Return Type

None.

Syntax

object.RemoveAll

See Also

ProfileCriteria


RemoveItem Method

RemoveItem Method (LocationCriteria)

Removes the specified LocationCriterion from the collection.

Return Type

None.

Syntax

object.RemoveItem(Index As Long)

Parameters

Part | Description
Index | The index of the object to be removed.

See Also

ProfileCriteria


MapHotSpots

MapHotSpots Collection

Contains the MapHotSpot objects defined for a given Map object.

Remarks

The MapHotSpots collection is retrieved from the Map.MapHotSpots Property.


Packages

Packages Collection

Contains the Package objects stored in the BPM database.

Remarks

The Packages collection is the single component used to retrieve Package objects from an BPM database. By specifying different Profile objects, the Packages collection can be filled with a users Inbox items, packages from a specific queue, packages matching by predefined named or ad hoc criteria, or with packages matching specific a PkgId or PkgRecId.

The Packages collection is a creatable object. Once created, the UserToken property must be set with a UserToken that has been properly connected to an BPM Database. Once the UserToken property has been set, a Profile object can be created to specify the criteria to used for filling the collection. This profile must be set as the Packages.Profile property. Once the UserToken property and the Profile property are set, the Refresh method should be called to populate the collection with objects.

Regardless of the profile criteria, the collection will only populate with those Package objects which are in location to which the calling user (as defined by the UserToken object) has been granted access.


AutoLoad Event

AutoLoad Event (Packages)

This event is called when the packages are automatically loaded.

Syntax

AutoLoad(Package As Object, Handled As Boolean)

Parameters

Part | Description
Package | Object
Handled | Boolean


DataChanged Event

DataChanged Event (Packages)

This event is called after the package collection has been changed/modified.


FindById method

FindById Method (Packages)

Finds a specific package in the collection based on the PkgRecId.

Return Type

Returns an object reference that evaluates to a Package object or Nothing if a package cannot be found with that PkgRecId.

Syntax

object.FindById(Id As Long)

The FindById method syntax has these parts:

Part | Description
Id | PkgRecId of the package you are trying to obtain.

Remarks

FindById will search through a collection attempting to match the provided id. The collection must be populated prior to calling FindById. If the given key does not match any member of the collection, a Nothing object reference is returned.


Refresh Method (Packages)

Fills a Packages collection with Package objects based on the search criteria define by the Profile property.

Syntax

Packages.Refresh

Remarks

Fills a Packages collection with Package objects based on the search criteria define by the Profile property. Regardless of the Profile object definition, the collection will only populate with Package objects to which the calling user has access. The Packages.UserToken property must be set with a valid UserToken that has been properly connected to the BPM database and the Packages.Profile must be set with a valid Profile object or the Refresh method will return an error.


Reserved Method

Reserved Method (Packages)

Reserved for future use.


Profile Property (Packages)

This property is used to determine which packages should be used to populate the Packages Collection.

Settings

A Profile object is required.

Remarks

This property is write-only. This property is used when the Packages.Refresh method is called to determine the collection.

Setting this property to Nothing before refreshing the collection will clear the collection of packages.


UserToken Property

The UserToken Property.

Settings and Return Values

Sets or returns an Object reference which resolves to an UserToken.

Remarks

The UserToken is the sole means for providing user authentication with the Process SDK Object Model. Moreover, it is the mechanism used to connect the Process SDK components to an BPM database. Once a UserToken is obtained (from the User.Login method), it is connected to an BPM database by creating a Databases collection, calling Databases.Refresh, finding the desired Database object in the collection, and passing the UserToken to Database.Connect. From then on, that UserToken is considered to be connected and all Process SDK objects and collections activated by the UserToken (inheriting the UserToken from a parent object) will be directed to the chosen BPM database.

All objects which are not derived from a parent objects within the model must have their UserToken property set before call any methods or accessing property values.


Processes

Processes Collection

Contains the Process objects defined in the BPM database.

Remarks

The Processes collection contains Process objects. Each Process object represents a single process which has been applied from the BPM Builder.

The Processes collection is a creatable object. Once created, the UserToken property must be set with a UserToken that has been properly connected to an BPM Database. Once the UserToken property has been set, the Refresh method should be called to populate the collection with objects.

The collection will only populate with those Process objects to which the calling user (as defined by the UserToken object) has been granted access.


FindById method

FindById Method (Processes)

Finds a specific process in the collection based on the ProcessId.

Return Type

Returns an object reference that evaluates to a Process object or Nothing if a process cannot be found with that ProcessId.

Syntax

object.FindById(Id As Long)

The FindById method syntax has these parts:

Part | Description
Id | ProcessId of the process you are trying to obtain.

Remarks

FindById will search through a collection attempting to match the provided id. The collection must be populated prior to calling FindById. If the given key does not match any member of the collection, a Nothing object reference is returned.


Refresh Method (Processes)

Fills a Processes collection with the Process objects defined in the BPM database.

Syntax

Processes.Refresh

Remarks

Fills a Processes collection with the Process objects defined in the BPM database, retrieving the most current information from the database. The collection will only populate with Process objects to which the calling user has access. The Processes.UserToken property must be set with a valid UserToken that has been properly connected to an BPM database or the Refresh method will return an error.


ProcessTemplates

ProcessTemplates Collection

The ProcessTemplates Collection contains a collection of ProcessTemplate Objects. This lists the Process and Template relations indicating which Templates may be applied with specific Processes.


FindById method

FindById Method (ProcessTemplates)

Finds a specific template in the collection based on the TemplateId.

Return Type

Returns an object reference that evaluates to a ProcessTemplate object or Nothing if a process template cannot be found with that TemplateId.

Syntax

object.FindById(Id As Long)

The FindById method syntax has these parts:

Part | Description
Id | TempalteId of the process template you are trying to obtain.

Remarks

FindById will search through a collection attempting to match the provided id. The collection must be populated prior to calling FindById. If the given key does not match any member of the collection, a Nothing object reference is returned.


Refresh Method (ProcessTemplates)

Fills a ProcessTemplate collection with the ProcessTemplate objects for a specific process.

Syntax

ProcessTemplates.Refresh

Remarks

Fills a ProcessTemplate collection with the ProcessTemplate objects for a specific process, retrieving the most current information from the BPM database.

The Process.ProcessTemplates property calls the collection's Refresh method internally. As a result, the collection is returned "hydrated," and it is not necessary to call Refresh to initially fill the collection.


Profiles

Profiles Collection

Contains named Profile objects defined in the BPM database.

Remarks

The Profiles collection contains Profile objects. Each Profile object represents a single named profile. Because the collection only contains Named Profiles, all Profile objects populated in the collection will have a ProfileType property of ProfileType.prNamed (ProfileType enumeration.) See the Profile object itself for ways to create other profile types.

The Profiles collection is a creatable object. Once created, the UserToken property must be set with a UserToken that has been properly connected to an BPM Database. Once the UserToken property has been set, the Refresh method should be called to populate the collection with objects.

The collection will only populate with those Named Profiles to which the calling user (as defined by the UserToken object) has been granted access.


FindById method

FindById Method (Profiles)

Finds a specific profile in the collection based on the ProfileId.

Return Type

Returns an object reference that evaluates to a Profile object or Nothing if a profile cannot be found with that ProfileId.

Syntax

object.FindById(Id As Long)

The FindById method syntax has these parts:

Part | Description
Id | ProfileId of the profile you are trying to obtain.

Remarks

FindById will search through a collection attempting to match the provided id. The collection must be populated prior to calling FindById. If the given key does not match any member of the collection, a Nothing object reference is returned.


Refresh Method (Profiles)

Fills a Profiles collection with the named Profile objects defined in the BPM database.

Syntax

Profiles.Refresh

Remarks

Fills a Profiles collection with the named Profile objects defined in the BPM database, retrieving the most current information from the database. The collection will only populate with Profile objects to which the calling user has access. All Profile objects populated in the collection will have a ProfileType property of ProfileType.prNamed (ProfileType enumeration.)

The Profiles.UserToken property must be set with a valid UserToken that has been properly connected to an BPM database or the Refresh method will return an error.


PromptCriteria Collection

The PromptCriteria object represents a mechanism for expressing how Package objects will be (have been) selected for inclusion in a Packages collection. A PromptCriteria object is a collection of PromptCriterion objects.

See Also

ProfileCriteria


AddItem Method

AddItem Method (PromptCriteria)

Adds a PromptCriterion object to the collection.

Return Type

None.

Syntax

object.AddItem(newVal As PromptCriterion)

Parameters

Part | Description
newVal | The PromptCriterion object to be added to the collection.

See Also

ProfileCriteria


RemoveAll Method

RemoveAll Method (PromptCriteria)

Removes all PromptCriterion objects from the collection.

Return Type

None.

Syntax

object.RemoveAll

See Also

ProfileCriteria


RemoveItem method

RemoveItem method (PromptCriteria)

Removes the specified PromptCriterion from the collection.

Return Type

None.

Syntax

object.RemoveItem(Index As Long)

Parameters

Part | Description
Index | The index of the object to be removed.

See Also

ProfileCriteria


Prompts Collection

Contains the Prompt objects available for a given profile.

Remarks

The Prompts collection is retrieved from Profile.Prompts property. The collection is used to read and update the prompt values for a specific profile.


ClearAll Method

ClearAll Method (Prompts)

Clears all the information entered into the Prompt values of the profile.

Return Type

None.

Syntax

object.ClearAll

See Also

Profile


Queues

Queues Collection

Contains the Queue objects defined for a given process.

Remarks

The Queues collection contains Queue objects. Each Queue object represents a single queue within a process which has been applied from the BPM Builder. The collection will only populate with Queue objects to which the calling user has access.

The Queues collection is retrieved from either Process.Queues or from TemplateProcess.Queues.


FindById method

FindById Method (Queues)

Finds a specific queue in the collection based on the QueueId.

Return Type

Returns an object reference that evaluates to a Queue object or Nothing if a queue cannot be found with that QueueId.

Syntax

object.FindById(Id As Long)

The FindById method syntax has these parts:

Part | Description
Id | QueueId of the queue you are trying to obtain.

Remarks

FindById will search through a collection attempting to match the provided id. The collection must be populated prior to calling FindById. If the given key does not match any member of the collection, a Nothing object reference is returned.


Refresh Method (Queues)

Fills a Queues collection with the Queue objects for a specific process.

Syntax

Queues.Refresh

Remarks

Fills a Queues collection with the Queue objects for a specific process, retrieving the most current information from the BPM database. The collection will only populate with Queue objects to which the calling user has access.

The Process.Queues and the TemplateProcess.Queues properties both call the collection's Refresh method internally. As a result, the collection is returned "hydrated," and it is not necessary to call Refresh to initially fill the collection.


SortCriteria

SortCriteria Collection

The SortCriteria object represents a mechanism for expressing how Package objects will be (have been) ordered in a Packages collection. A SortCriteria object is a collection of SortCriterion objects.

Remarks

The individual SortCriterion objects contained within a SortCriteria collection object are applied in the order they were added to the collection to the results of a package search.

See Also

ProfileCriteria


AddItem Method

AddItem Method (SortCriteria)

Adds a SortCriterion to the collection.

Return Type

None.

Syntax

object.AddItem(newVal As SortCriterion)

Parameters

Part | Description
newVal | The SortCriterion object to be added to the collection.

See Also

ProfileCriteria


RemoveAll Method

RemoveAll Method (SortCrieria)

Removes all SortCriterion objects from the collection.

Return Type

None.

Syntax

object.RemoveAll

See Also

ProfileCriteria


RemoveItem Method

RemoveItem Method (SortCriteria)

Removes the specified SortCriterion from the collection.

Return Type

None.

Syntax

object.RemoveItem(Index As Long)

Parameters

Part | Description
Index | The index of the object to be removed.

See Also

ProfileCriteria


StartEvents

StartEvents Collection

This collection contains all of the start events that are valid for a given package template.


FindById method

FindById Method (StartEvents)

Finds a specific start event in the collection based on the ProcessId and EventId.

Return Type

Returns an object reference that evaluates to an Event object or Nothing if an start event cannot be found with that ProcessId and EventId.

Syntax

object.FindById(ProcessId As Long, EventId As Long)

The FindById method syntax has these parts:

Part | Description
ProcessId | ProcessId of the start event you are trying to obtain.
EventId | EventId of the start event you are trying to obtain.

Remarks

FindById will search through a collection attempting to match the provided ids. Because the StartEvents collection can contain events across multiple processes, both a ProcessId and an EventId must be provided. The collection must be populated prior to calling FindById. If the given key does not match any member of the collection, a Nothing object reference is returned.


Refresh Method (StartEvents)

Fills a StartEvents collection with the start Event objects for a specific package template.

Syntax

StartEvents.Refresh

Remarks

Fills a StartEvents collection with the Event objects for a specific package template, retrieving the most current information from the BPM database. The Event objects populated in the collection will all have an EventType property of EventType.etStart (EventType enumeration.) The Event objects may be from multiple processes since a template can be shared across multiple processes.

The Template.StartEvents property and the ProcessTemplate.StartEvents property both call the collection's Refresh method internally. As a result, the collection is returned "hydrated," and it is not necessary to call Refresh to initially fill the collection.


Default Property (StartEvents)

This property contains a default start event.

Settings and Return Values

Sets or Returns an Object value.


SubProfiles

SubProfiles Collection

Contains the list of Profiles that are 'subordinate' to a given ProfileCriteria.


AddItem Method

AddItem Method (SubProfiles)

Adds a Profile to the collection.

Return Type

None.

Syntax

object.AddItem(newVal As Profile)

Parameters

Part | Description
newVal | The Profile object to be added to the collection.


RemoveAll Method

RemoveAll Method (SubProfiles)

Removes all Profile objects from the collection.

Return Type

None.

Syntax

object.RemoveAll


RemoveItem Method

RemoveItem Method (SubProfiles)

Removes the specified Profile from the collection.

Return Type

None.

Syntax

object.RemoveItem(Index As Long)

Parameters

Part | Description
Index | The index of the object to be removed.


TaskDefinitions

TaskDefinitions Collection

Contains the TaskDefinition objects for a specific Queue.

Remarks

The TaskDefinitions collection contains TaskDefinition objects. Each TaskDefinition object represents a single task defined for the given Queue. The set of Task objects contained by the collection is determined by the Queue's configuration as applied from the BPM Builder.

The TaskDefinitionscollection is retrievable from the Queue.TaskDefinitions property.


FindById method

FindById Method (TaskDefinitions)

Finds a specific task definition in the collection based on the TaskId.

Return Type

Returns an object reference that evaluates to a TaskDefinition object or Nothing if a task definition cannot be found with that TaskId.

Syntax

object.FindById(Id As Long)

The FindById method syntax has these parts:

Part | Description
Id | TaskId of the task definition you are trying to obtain.

Remarks

FindById will search through a collection attempting to match the provided id. The collection must be populated prior to calling FindById. If the given key does not match any member of the collection, a Nothing object reference is returned.


Refresh Method (TaskDefinitions)

Fills a TaskDefinitions collection with TaskDefinition objects for a specific queue.

Syntax

TaskDefinitions.Refresh

Remarks

Fills a TaskDefinitions collection with TaskDefinition objects for a specific queue, retrieving the most current information from the BPM database.

The Queue.TaskDefinitions property calls the collection's Refresh method internally. As a result, the collection is returned "hydrated," and it is not necessary to call Refresh to initially fill the collection.


Tasks

Tasks Collection

Contains the Task objects for a specific Package.

Remarks

The Tasks collection contains Task objects. Each Task object represents a task. The set of Task objects contained by the collection is determined by the TaskDefinitions for the package's current queue location.

The Tasks collection is retrievable from the Package.Tasks property.


DataChanged Event

DataChanged Event (Tasks)

Fired when any changes to an Tasks Collection are committed.

Syntax

DataChanged

Remarks

The Tasks DataChanged event is fired as a result of a call to the Complete, or Undo methods. This allows code with multiple views into the collection to synchronize changes than may have been made to the objects within the collection.


FindById method

FindById Method (Tasks)

Finds a specific task in the collection based on the TaskId.

Return Type

Returns an object reference that evaluates to a Task object or Nothing if a task cannot be found with that TaskId.

Syntax

object.FindById(Id As Long)

The FindById method syntax has these parts:

Part | Description
Id | TaskId of the task you are trying to obtain.

Remarks

FindById will search through a collection attempting to match the provided id. The collection must be populated prior to calling FindById. If the given key does not match any member of the collection, a Nothing object reference is returned.


Refresh Method (Tasks)

Fills a Tasks collection with the Task objects for a specific Package instance.

Syntax

FieldValues.Refresh

Remarks

Fills a Tasks collection with the Task objects for a specific Package instance, retrieving the most current information from the BPM database. The Task objects are returned based on the Package objects current queue location. If the Package is not in a queue, the Count on the collection will be zero.

The Package object Tasks property calls the Refresh method internally. As a result, the collection is returned "hydrated," and it is not necessary to call Refresh to initially fill the collection.


TemplateProcesses

TemplateProcesses Collection

A collection of TemplateProcess objects that show the correlations between Processes and a Template.


FindById method

FindById Method (TemplateProcesses)

Finds a specific template process in the collection based on the ProcessId.

Return Type

Returns an object reference that evaluates to a TemplateProcess object or Nothing if a template process cannot be found with that ProcessId.

Syntax

object.FindById(Id As Long)

The FindById method syntax has these parts:

Part | Description
Id | ProcessId of the template process you are trying to obtain.

Remarks

FindById will search through a collection attempting to match the provided id. The collection must be populated prior to calling FindById. If the given key does not match any member of the collection, a Nothing object reference is returned.


Refresh Method (TemplateProcesses)

Fills a TemplateProcesses collection with the TemplateProcess objects for a specific package template.

Syntax

TemplateProcesses.Refresh

Remarks

Fills a TemplateProcesses collection with the TemplateProcess objects for a specific package template, retrieving the most current information from the BPM database.

The Template.TemplateProcesses property calls the collection's Refresh method internally. As a result, the collection is returned "hydrated," and it is not necessary to call Refresh to initially fill the collection.


Templates

Templates Collection

Contains the Template objects defined in the BPM database.

Remarks

The Templates collection contains Template objects. Each Template object represents a single template which has been applied from the BPM Builder..

The Templates collection is a creatable object. Once created, the UserToken property must be set with a UserToken that has been properly connected to an BPM Database. Once the UserToken property has been set, the Refresh method should be called to populate the collection with objects.

The collection will only populate with those Template objects to which the calling user (as defined by the UserToken object) has been granted access. However, the BPM Security model users are not directly granted access to templates. Rather, a users has access to a template by having access to the a process for which the template is valid.


FindById method

FindById Method (Templates)

Finds a specific template in the collection based on the TemplateId.

Return Type

Returns an object reference that evaluates to a Templates object or Nothing if a template cannot be found with that TemplateId.

Syntax

object.FindById(Id As Long)

The FindById method syntax has these parts:

Part | Description
Id | TemplateId of the template you are trying to obtain.

Remarks

FindById will search through a collection attempting to match the provided id. The collection must be populated prior to calling FindById. If the given key does not match any member of the collection, a Nothing object reference is returned.


Refresh Method (Templates)

Fills a Templates collection with the Template objects defined in the BPM database.

Syntax

Templates.Refresh

Remarks

Fills a Templates collection with the Template objects defined in the process database, retrieving the most current information from the BPM database. The collection will only populate with Template objects to which the calling user has access. The Templates.UserToken property must be set with a valid UserToken that has been properly connected to an BPM database or the Refresh method will return an error.


Default Property (Templates)

This property contains the default template object.

Settings and Return Values

Sets or Returns an Object value.


WFUsers

WFUsers Collection

Contains all of the WFUser objects defined in the BPM database.

Remarks

The WFUsers collection contains WFUser objects. Each WFUser object represents a single user known to the BPM database.

The WFUsers collection is a creatable object. Once created, the UserToken property must be set with a UserToken that has been properly connected to a BPM Database. Once the UserToken property has been set, the Refresh method should be called to populate the collection with objects.


FindById method

FindById Method (WFUsers)

Finds a specific user in the collection based on the UserId.

Return Type

Returns an object reference that evaluates to a WFUser object or Nothing if a user cannot be found with that UserId.

Syntax

object.FindById(Id As Long)

The FindById method syntax has these parts:

Part | Description
Id | UserId of the user you are trying to obtain.

Remarks

FindById will search through a collection attempting to match the provided id. The collection must be populated prior to calling FindById. If the given key does not match any member of the collection, a Nothing object reference is returned.


Refresh Method (WFUsers)

Fills a WFUsers collection with the WFUser objects defined in the BPM database.

Syntax

WFUsers.Refresh

Remarks

Fills a WFUsers collection with the WFUser objects defined in the BPM database, retrieving the most current information from the database. The WFUsers.UserToken property must be set with a valid UserToken that has been properly connected to a BPM database or the Refresh method will return an error.


ConnectedUser Property (WFUsers)

property ConnectedUser

Property Type

A object value.


Process Toolkit Objects

Process SDK™ Toolkit Objects

The relationships between these objects are represented in the Process SDK™ Toolkit Object Model.

Each object can be contained in its corresponding collection. For example, an Package object can be contained in an Packages collection. For more information, see Process SDK™ Toolkit Collections or a specific collection topic.

Process SDK™ Toolkit Objects Summary

Attachment
AttachmentType
Audit
Database
DecisionChoice
Event
FieldCriterion
FieldDefinition
FieldValue
Form
LocationCriterion
Map
MapHotSpot
Package
Process
ProcessTemplate
Profile
ProfileCriteria
PromptCriterion
Prompt
Queue
SortCriterion
Task
TaskDefinition
Template
TemplateProcess
WFUser


Attachment

Attachment Object

Represents an attachment to a Package object.

Remarks

Each Attachment object in an Attachments collection corresponds to a one item attached to a package. Use the CreateAttachment and Commit methods of the Attachments collection to create a new package attachment. To remove an Attachment from the Package, set the Attachment's MarkDeleted Property to True, and then call Commit on the Attachments collection in which it is contained.

An attachment to a package is in actuality a reference to an entity stored outside of the BPM System. This reference is encoded into DocumentId and the IndexId objects (available in the Stellent.IBPM.Interop.Common namespace) and stored in the DocumentId and IndexId properties.

Depending upon the MIME Type of the attachment (available from the DocumentId property), the attachment may provide any number of action verbs which can be performed on that attachment. These verbs may be operations such as Open or Print. The set of supported actions for a given Attachment object is available through the ActionModifers property.


MarkDeleted Method

MarkDeleted Method (Attachment)

Flags a Attachment object within an Attachments collection for deletion on the next Commit.

Syntax

object.MarkDeleted

Remarks

Calling the Attachments Refresh method without calling Commit will reset the internal status of all objects with MarkDeleted set back to the unmodified state.


ActionModifiers Property (Attachment)

This property returns the ActionModifers collection of the given attachment.

Settings and Return Values

Returns an object reference evaluating to a OTACTMODLib.ActionModifiers collection.

Remarks

The ActionModifiers collection provides the mechanism for enumerating the action verbs available for the Attachment. Action Verbs can be operations such as open or print and are determined by the MIMEType available through the DocumentId property.

The ActionModifiers collection contains ActionModifer objects, which in turn exposes a Verbs collection containing Verb objects. The Verb has a Caption property indicating the textual description for the verb as well as an Invoke method for performing the specified operation

The property is read-only.


AttachmentId Property (Attachment)

This property is a number that uniquely identifies the Attachment within an BPM database.

Settings and Return Values

Returns a Long value.

Remarks

Attachments that are newly created (Attachments.CreateAttachment) and have not yet been committed (Attachments.Commit) will have an AttachmentId less than 1.

The property is read-only.


AttachmentType Property (Attachment)

This property contains the AttachmentType object of the given attachment.

Settings and Return Values

Sets and returns an object reference which evaluates to an AttachmentType object.


DocInfo Property

DocInfo Property (Attachment)

Represents the reference to the stored entity to which the Attachment object corresponds.

Settings and Return Values

Sets and returns an object reference evaluating to a DocInfo object.

Remarks

An attachment to a package is a reference to an entity stored and indexed outside of the BPM System. The reference to the entity's storage is encoded into a DocInfo object (available in the Stellent.IBPM.Interop.Common namespace).


DocumentId Property (Attachment)

Represents the reference to the stored entity to which the Attachment object corresponds.

Settings and Return Values

Sets and returns an object reference evaluating to a DocumentId object.

Remarks

An attachment to a package is a reference to an entity stored and indexed outside of the BPM System. The reference to the entity's storage is encoded into a DocumentId object (available in the Stellent.IBPM.Interop.Common namespace). The DocumentId object represents the reference to the actual storage entity for the attachment and has the following properties:

UniqueId | A String value containing a unique key to the stored item. The actual value depends upon the requirements of the system managing the entity's storage.
ProviderId | A String value containing a GUID key which identifies the system managing the storage of the entity. The value of this parameter determines how the UniqueId property should be interpreted.
MIMEType | A String value containing an indicator of the type of data contained within the entity.

The following table details the typical values to the DocumentId properties for adding attachments stored by IBPM mechanisms.

For Imaging Documents
UniqueId
Image | - Imaging RECID
Cold | - Full Imaging OBJECTID
Universal | - Imaging RECID
MIMEType
Image | - image/tiff
Cold | - text/x-emedia.cold
Universal | - application/x-emedia.universal
ProviderId | {0BF3C340-4C13-11d3-8166-00C04F99E979}
For BPM File Attachments
UniqueId | Path to file
MIMEType | application/x-emedia.wfuniversal
ProviderId | {081016EE-F688-11D3-9E61-00C04F097031}


IndexId Property (Attachment)

Represents the reference to the index or metadata to which the Attachment object corresponds.

Settings and Return Values

Sets and returns an object reference evaluating to an IndexId object.

Remarks

An attachment to a package is a reference to an entity stored and indexed outside of the BPM System. The reference to the entity's index is encoded into an IndexId object (available in the Stellent.IBPM.Interop.Common namespace). The IndexId object represents the reference to the index or metadata for the attachment and has the following properties:

IndexId | A String value containing a unique key to the index values. The actual value depends upon the requirements of the system managing the index. It is only necessarily unique within the Index definition identified by the IndexName property..
IndexName | A String value which uniquely identifies the index definition or schema into which the index values are stored. The IndexId must be unique within the scope of a given IndexName.
IndexProvider | A String value containing a GUID key which identifies the system managing the index of the entity. The value of this parameter determines how the IndexId and IndexName properties should be interpreted.

The following table details the typical values to the IndexId properties for adding attachments stored by IBPM mechanisms.

For Imaging Documents
IndexId
Image | - Imaging RECID
Cold | - DocumentId:Physical COLD Number
Universal | - Imaging RECID
IndexName | Imaging TABLENAME (LinkServerName.Instance.Catalog.Table)
IndexProvider
Image | {608FCB70-10BF-11d4-A931-00C04F94786A}
Cold | {0BF3C340-4C13-11d3-8166-00C04F99E979}
Universal | {608FCB70-10BF-11d4-A931-00C04F94786A}
For BPM File Attachments
IndexId | These values are left blank since there are no indexes associated with file attachments
IndexName
IndexProvider | {081016EE-F688-11D3-9E61-00C04F097031}


PackageId Property (Attachment)

This property is a number that uniquely identifies the Package to which the Attachment is attached.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


Title Property (Attachment)

The title of the attachment for the given package.

Settings and Return Values

Sets and returns the title for the attachment as a String value.


AttachmentType

AttachmentType Object

Represents an attachment type defined for specific package template or designated on a specific package attachment.

Remarks

Each AttachmentType object in an AttachmentTypes collection corresponds to a attachment type defined within a package template definition. These attachment types are defined for the template in the IBPM Process Builder. An AttachmentType is generally defined to allow a specific Package attachment to be designated to serve a predetermined purpose. For instance, a given attachment might be designated the "Invoice" for package in an accounts payable process. A specific queue in a process can be configured from BPM Builder to automatically open all attachments of a particular AttachmentType when a package is locked. (See the AutoAttachments collection..)

The AttachmentType object is used to set and obtain information from the Attachment.AttachmentType property.


TemplateId Property (AttachmentType)

A number that identifies the package template in which the AttachmentType is defined.

Returns a Long value.

Remarks

The property is read-only.


TypeId Property (AttachmentType)

A number that uniquely identifies the AttachmentType within a package template definition.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


TypeName Property (AttachmentType)

A string that provides a textual description of an AttachmentType.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


Audit

Audit Object

Represents a single audit record entry for a specific Package.

Remarks

The Audit object is always a member of an Audits collection obtained from Package.Audits.


Duration Property (Audit)

This property is a number that identifies the time that elapsed between this timed auditable event and the previous timed auditable event.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only. The Long value represents time in seconds.


EventId Property (Audit)

Uniquely identifies the Event where the package was located when the audit record was generated.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


EventName Property (Audit)

Provides a textual description of the Event where the package was located when the audit record was generated.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


Message Property (Audit)

This property is a textual description for the audit entry.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


PkgId Property (Audit)

Uniquely identifies the Package for which the audit record was generated.

Settings and Return Values

Returns a Long value.

Remarks

See Package.PkgId.

The property is read-only.


ProcessId Property (Audit)

Uniquely identifies the Process where the package was located when the audit record was generated.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


ProcessName Property (Audit)

Provides a textual description of the Process where the package was located when the audit record was generated.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


QueueId Property (Audit)

Uniquely identifies the Queue where the package was located when the audit record was generated.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


ResultEventId Property (Audit)

This property is the unique id of the event where the package was moved to when the audit record was generated.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


ResultEventName Property (Audit)

Provides a textual description of the Event where the package was moved to when the audit record was generated.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


TaskId Property (Audit)

Uniquely identifies the Task that was being used when the audit record was generated.

Settings and Return Values

Returns a Long value.

Remarks

If the Audit is not does not have a Type of AuditType.atTaskComplete (from the AuditType enumeration), then the TaskId will be less than 1.

The property is read-only.


TaskName Property (Audit)

Provides a textual description of the Task that was being used when the audit record was generated.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


TimeStamp Property (Audit)

This property represents the date and time that the audit occurred.

Settings and Return Values

Returns a Date value.

Remarks

The property is read-only.


Type Property (Audit)

This property is an enumeration that identifies the type of the audit entry.

Settings and Return Values

Returns a AuditType value.

Remarks

The property is read-only.


UserId Property (Audit)

Uniquely identifies the user's id who performed the operation that generated the audit record.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


UserName Property (Audit)

Provides name of the user who performed the operation that generated the audit record.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


Database

Database Object

Represents as a single database as configured on the Process Broker machine.

Remarks

A Database object is always obtained as part of a Databases collection.

The Database object's primary purpose is to "connect" a UserToken to an BPM database. The UserToken is the sole means for providing user authentication with the Process SDK™ Toolkit Object Model. Once a UserToken is obtained (from the Stellent.IBPM.Interop.Common.User.Login method), it is connected to an BPM database through the Database object by passing it to Database.Connect. From then on, that UserToken is considered to be connected and all Process SDK™ Toolkit objects and collections activated by the UserToken (or inheriting it from a parent object) will be directed to the chosen BPM database.


Connect Method

Connect Method (Database)

This method connects a UserToken to an BPM database.

Return Type

None.

Syntax

object.Connect(UserToken As Object)

Parameters

Part | Description
UserToken | An Object reference which resolves to an Stellent.IBPM.Interop.Common.UserToken.


DatabaseName Property (Database)

Provides the textual name of the Database object.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


DecisionChoice

DecisionChoice Object

Each DecisionChoice object represents a path that a Package object can follow when completed from a Queue.

Remarks

A DecisionChoice has the following properties:

  • DecisionText
  • EventId
  • IsDefault


DecisionText Property (DecisionChoice)

Text which describes to a user the path a Package should follow.

Settings and Return Values

Returns a String value.

Remarks

This property is read only.


EventId Property (DecisionChoice)

Uniquely identifies the Event which corresponds to the Decision Choice.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


IsDefault Property

IsDefault Property (DecisionChoice)

Determines whether the DecisionChoice is the default decision for the Work Event.

Settings and Return Values

Returns a Boolean value.

Remarks

The property is read-only. A queue may or may not have a default decision, based on the configuration of the queue through Process Builder.


Event

Event Object

Represents a single event in a Process flow.


CanAdhocRouteFrom Property (Event)

Provides an indication regarding whether or not Packages can be Ad hoc Routed from the Event.

Settings and Return Values

Returns a Boolean value.

Remarks

This property is read-only


CanAdhocRouteTo Property (Event)

Provides an indication regarding whether or not Packages can be Ad hoc Routed to the Event.

Settings and Return Values

Returns a Boolean value.

Remarks

This property is read-only


Description Property (Event)

Represents a textual description of the Event.

Settings and Return Values

Returns a String value.

Remarks

This property is read-only


EventId Property (Event)

Uniquely identifies the Event within a given Process.

Settings and Return Values

Returns a Long value.

Remarks

EventId is also the unique numerical ID key into the Events collection (see Events.FindById.)

The property is read-only.


EventName Property (Event)

Provides the textual name of the Event.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


EventType Property (Event)

Represents the Event's type.

Settings and Return Values

Returns a value from the EventType enumeration.

Remarks

This property is read-only


HelpFile Property (Event)

Represents the location of the help file associated with the Event.

Settings and Return Values

Returns a String value.

Remarks

This property is read-only


IsDeleted Property (Event)

Provides an indication regarding whether or not the Event has been deleted from its Process.

Settings and Return Values

Returns a Boolean value.

Remarks

This property is read-only

See Also

Process.Events


ProcessId Property (Event)

Uniquely identifies the Process in which the Event is defined.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


ProcessName Property (Event)

Provides the textual name of the the Process in which the Event is defined.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


FieldCriterion

FieldCriterion Object

The FieldCriterion object represents a mechanism for expressing how Package objects will be (have been) selected for inclusion in a Packages collection.

Remarks

The FieldCriterion object describes the logical comparison of a package field value against one or more operands.

SetOperation should be called before any operands are added (a side effect of the SetOperation method is that all current operands are removed).

The number of operands required by a FieldCriterion is dependent upon the FieldCriterion's assigned operator as follows:

Operator | Required Number of Operands
Operator.opLessThan | 1
Operator.opGreaterThan | 1
Operator.opEqualTo | 1
Operator.opIn | > 0
Operator.opBetween | 2
Operator.opLike | 1
Operator.opNotEqualTo | 1


AddOperand Method

AddOperand Method (FieldCriterion)

Adds an operand for evaluation.

Return Type

None.

Syntax

object.AddOperand(Operand As Variant)

Parameters

Part | Description
Operand | An operand to be acted upon by the FieldCriterion


SetOperation Method

SetOperation Method (FieldCriterion)

Associates an operator and a FieldDefinition with the FieldCriterion.

Return Type

None.

Syntax

object.SetOperation(FieldDefinition As FieldDefinition, Operator As Operator)

Parameters

Part | Description
FieldDefinition | The FieldDefinition to be associated with the FieldCriterion.
Operator | The operator to be applied to the FieldCriterion operands.

Remarks

A side effect of this method is that all current operands are removed from the FieldCriterion.

See Also

ProfileCriteria


FieldId Property (FieldCriterion)

Represents the numeric identifier of the FieldDefinition that has been associated with the FieldCriterion.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only

See Also

SetOperation


OperandCount Property (FieldCriterion)

Represents the number of operands that have been associated with the FieldCriterion.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only


OperandItem Property (FieldCriterion)

Returns the specified operand from the FieldCriterion.

Return Type

Variant

Syntax

variant = object.OperandItem(Index As Long)

Parameters

Part | Description
Index | The index of the operand to be returned.

See Also

ProfileCriteria


Operator Property (FieldCriterion)

Represents the operator that has been assigned to the FieldCriterion.

Settings and Return Values

Returns a value from the Operator enumeration.

Remarks

This property is read-only

See Also

SetOperation


FieldDefinition

FieldDefinition Object

Each FieldDefinition object describes a data field in a Template object.

Remarks

A FieldDefinition works in conjunction with FieldValue object to completely describe a data field for a Package.


FieldDistinctList Property (FieldDefinition)

Represents a list of distinct field values currently in the database for this field.

Settings and Return Values

Returns an object reference evaluating to a FieldDistinctList object.

Remarks

This property is read only.

Note that because systems fields are not specific to any particular template, distinct lists for system fields will return values from all packages in the process database. Also, because date values are unique down the millisecond (for most supported databases) retrieving the distinct list for a date field (especially a system field date) is a potentially time consuming operation, as there are likely to be a large number of unique date values.


FieldId Property (FieldDefinition)

Uniquely identifies a field within a given package template definition.

Settings and Return Values

Returns a Long value.

Remarks

FieldId is the unique numerical ID key into the FieldDefinitions collection (see FieldDefintions.FindById.)

The FieldId property can be matched against the SystemFieldId enumeration constant values to determine if it is a system field.

The property is read-only.


FieldName Property (FieldDefinition)

Provides the textual name of the field within a package template definition..

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


FieldPickList Property (FieldDefinition)

Represents a list of expected field values for this field.

Settings and Return Values

Returns an object reference evaluating to a FieldPickList object.

Remarks

This property is read only.


HasPickList Property (FieldDefinition)

States if a list of expected field values has been associated with this field by BPM Builder.

Settings and Return Values

Returns a Boolean value.

Remarks

This property is read only.


IsReadOnly Property (FieldDefinition)

States if the field's data value is read only.

Settings and Return Values

Returns a Boolean value.

Remarks

This only applies to system fields. From this property it can be determined if the system field value can be edited.


IsSystemField Property (FieldDefinition)

States if the field is a system defined field or a user defined field.

Settings and Return Values

Returns a Boolean value.


Length Property (FieldDefinition)

States the maximum number of characters that can be inserted in a string field. See FieldDefinition.Type.

Settings and Return Values

Returns a Long value.

Remarks

This property is read only.


Type Property (FieldDefinition)

States the data type of the value stored by this field

Settings and Return Values

Returns an FieldType value.

Remarks

This property is read only.


FieldValue

FieldValue Object

Represents a field value for a specific Package instance.

Remarks

The structure of the field value is defined in a corresponding FieldDefinition.


FieldDefinition Property (FieldValue)

Defines the structure of the FieldValue.

Settings and Return Values

Returns an object reference that evaluates to a FieldDefinition object.

Remarks

This property is read-only.


FieldId Property (FieldValue)

Uniquely identifies a field within a given Package.

Settings and Return Values

Returns a Long value.

Remarks

FieldId is the unique numerical ID key into the FieldValues collection (see FieldValues.FindById.)

The FieldId property can be matched against the SystemFieldId enumeration constant values to determine if it is a system field.

The property is read-only.


FieldName Property (FieldValue)

Provides the textual name of the field within a package.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


IsModified Property (FieldValue)

Provides an indication regarding whether or not the FieldValue has been altered.

Settings and Return Values

Returns a Boolean value.

Remarks

A value of False indicates that the FieldValue has not been altered. Once the FieldValue has been altered, this property will return True until such time that Commit is called on the enclosing FieldValues collection (after which the property's value will revert to False).

This property is read-only

See Also

FieldValue.Value


Value Property (FieldValue)

This property contains the data value represented by the FieldValue.

Settings and Return Values

Sets and returns a Variant value.

Remarks

When setting this property, the data type enclosed in the assigned Variant must be compatible with (i.e., the same as or convertible to) the data type specified by the FieldDefinition property.


FileStore

FileStore Object

Stores and deletes files to and from the common file storage location.


DeleteFile method

DeleteFile Method (FileStore)

Used to remove the local file object from common file storage.

Syntax

object.DeleteFile(DocumentId As _DocumentID)

The DeleteFile method syntax has these parts:

Part | Description
DocumentId | Object which specifies MimeType, UniqueId and ProviderId of the file

Remarks

This method does not remove the attachment from the package.


GetFileRef method

GetFileRef Method (FileStore)

Used to obtain the UNC file path to the local file object in common file storage.

Return Type

A String value.

Syntax

object.GetFileRef(DocumentId As _DocumentID)

The GetFileRef method syntax has these parts:

Part | Description
DocumentId | Object which specifies MimeType, UniqueId and ProviderId of the file


StoreFile method

StoreFile Method (FileStore)

Used to store a local file object to the Process Broker's common file storage location.

Return Type

Returns an DocumentId object reference.

Syntax

object.StoreFile(FileName As String, MimeType As String)

The StoreFile method syntax has these parts:

Part | Description
FileName | Path to an existing file.
MimeType | Specifies the desired document MimeType.

Remarks

This method does not add the attachment to a package.


FileStoreUNCPath Property (FileStore)

This property contains the common file path.

Property type

A String value.

Syntax

object.FileStoreUNCPath [= value]

Remarks

The property is read-only.


Form

Form Object

Represents a Visual Basic, HTML, or ASP form.

Remarks

In the BPM Architecture, a form is a component used to customize the interaction of Process users with a process instance. In general, a form is used to present and/or manipulate the contents of a Package within the context of line of business systems and other business applications.

Forms can be read-only, web-based presentations (e.g., HTML and ASP forms) or interactive applets (Visual Basic forms).

See Also

IFormImpl2


CloseForm Method

CloseForm Method (Form)

Closes the Form's window and deinitializes the Form.

Return Type

None.

Syntax

object.CloseForm


CreateForm Method

CreateForm Method (Form)

Initializes the Form in preparation for display.

Return Type

A Variant value.

Syntax

variant = object.CreateForm

Remarks

The encapsulated type and meaning of the returned Variant are dependent upon the FormStyle property as follows:

Form Style | Type and Meaning of Returned Variant
Visual Basic (otFormStyle_InProcForm) | The Variant encapsulates a Long that represents the window handle of the Visual Basic form.
Visual Basic (otFormStyle_OutOfProcForm) | The Variant encapsulates a Long that represents the window handle of the Visual Basic form.
HTML (otFormStyle_HTMLForm) | The Variant encapsulates a String that represents the implementation file name of the form.
ASP (otFormStyle_ASPForm) | The Variant encapsulates a String that represents the implementation file name of the form.


DataChanged Method

DataChanged Method (Form)

Used to provide the Form with an indication that information contained in the Package property has changed.

Return Type

None.

Syntax

object.DataChanged


IsDefault Method

Provides an indication regarding whether or not the Form is the default form for the owning Package/Template/ProcessTemplate.

Return Type

A Boolean value.

Syntax

object.IsDefault


IsRestricted Method

Provides an indication regarding whether or not the Form is restricted by the owning Package/Template/ProcessTemplate.

Return Type

A Boolean value.

Syntax

object.IsRestricted


Refresh Method

Refresh Method (Form)

Updates the Form with the most current data in the BPM database.

Return Type

None.

Syntax

object.Refresh


SendData Method

SendData Method (Form)

SendData provides a generic mechanism for sending implementation-specific information to a Visual Basic form.

Return Type

None.

Syntax

object.SendData(Data As Variant)

Parameters

Part | Description
Data | Variant

Remarks

The Visual Basic form instance must implement the IFormImpl2 interface.

The interpretation of the Variant data is entirely up to the Visual Basic form implementation.


SetParentHWND Method

SetParentHWND Method (Form)

Sets the parent window handle for the Form.

Return Type

None.

Syntax

object.SetParentHWND(hwndParent As Long, bControlParent As Boolean)

Parameters

Part | Description
hwndParent | A Long representing the parent window handle
bControlParent | Reserved for future use


SetPhysicalFilePath Method

SetPhysicalFilePath Method (Form)

Sets the absolute path to file system directory that contains (will contain) the form implementation file.

Return Type

None.

Syntax

object.SetPhysicalFilePath(PhysicalFile As String, ForceRefresh As Boolean)

Parameters

Part | Description
PhysicalFile | The absolute path to the file system directory
ForceRefresh | An indication regarding whether or not the form implementation file should be downloaded to the specified directory

Remarks

In the case where the form implementation file has been previously downloaded to a file system directory other than the one specified in the PhysicalFile parameter, the Process client will not download the form implementation file to the newly specified directory unless the ForceRefresh parameter is set to True.


ShowForm Method

ShowForm Method (Form)

Displays/hides the form.

Return Type

None.

Syntax

object.ShowForm(Show As Boolean)

Parameters

Part | Description
Show | An indication specifying whether the form is to be shown (True) or hidden (False)


FormFile Property (Form)

Represents information regarding the implementation file of the Form.

Settings and Return Values

Returns a String value.

Syntax

string = object.FormFile(PathType As PathType)

Parameters

Part | Description
PathType | A value from the PathType enumeration

Remarks

This property is read-only

The values of the PathType enumeration are interpreted as follows:

  • PathType.ptFull - returns the full path to the implementation file
  • PathType.ptPathOnly - returns the path to the directory containing the implementation file
  • PathType.ptFileOnly - returns the name of the implementation file


FormId Property (Form)

Uniquely identifies a Form within a given package template definition.

Settings and Return Values

Returns a Long value.

Remarks

FormId is the unique numerical ID key into the Forms collection (see Forms.FindById.)

The property is read-only.


FormName Property (Form)

Provides the textual name of the Form.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


FormStyle Property (Form)

Indicates the implementation style of the Form.

Settings and Return Values

Returns a value from the FormStyle enumeration.

Remarks

This property is read-only


Package Property (Form)

Represents the Package object that the Form is to act upon.

Settings and Return Values

Sets and returns an object reference that evaluates to a Package object.

Remarks

This property should be set prior to calling ShowForm.


TemplateId Property (Form)

Uniquely identifies a Template in which the form is defined.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


LocationCriterion

LocationCriterion Object

The LocationCriterion object represents a mechanism for expressing how Package objects will be (have been) selected for inclusion in a Packages collection.

Remarks

A LocationCriterion object represents a list of Queue locations in a specific Process.

A Process should be selected before any Queue locations are added (a side effect of setting the Process is that all current Queue locations are removed from the LocationCriteria).

See Also

ProfileCriteria


AddQueue Method

AddQueue Method (LocationCriterion)

Adds a Queue to the list of locations represented by the LocationCriterion.

Return Type

None.

Syntax

object.AddQueue(Queue As Queue)

Parameters

Part | Description
Queue | The Queue to add to the list of locations

See Also

ProfileCriteria


AddQueueById Method

AddQueueById Method (LocationCriterion)

Adds a Queue to the list of locations represented by the LocationCriterion.

Return Type

None.

Syntax

object.AddQueueById(QueueId As Long)

Parameters

Part | Description
QueueId | The numeric identifier of the Queue that is to be added

See Also

ProfileCriteria


SetProcess Method

SetProcess Method (LocationCriterion)

Assigns a Process to the LocationCriterion.

Return Type

None.

Syntax

object.SetProcess(Process As Process)

Parameters

Part | Description
Process | The Process to be assigned

Remarks

A side effect of this method is that all current Queue locations are removed from the LocationCriteria.


SetProcessById Method

SetProcessById Method (LocatonCriterion)

Assigns a Process to the LocationCriterion.

Return Type

None.

Syntax

object.SetProcess(Process As Long)

Parameters

Part | Description
Process | The numeric identifier of the Process to be assigned

Remarks

A side effect of this method is that all current Queue locations are removed from the LocationCriteria.


ProcessId Property (LocationCriterion)

Represents the numeric identifier of the Process that owns all of the Queue locations represented by the LocationCriterion

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only


QueueCount Property (LocationCriterion)

Represents the number of Queue locations that have been assigned to the LocationCriterion.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only


QueueItem Property (LocationCriterion)

Returns the specified Queue from the LocationCriterion.

Return Type

Queue

Syntax

Set queue = object.QueueItem(Index As Long)

Parameters

Part | Description
Index | The index of the Queue that is to be returned.

Remarks

This property is read-only

See Also

ProfileCriteria


Map

Map Object

Represents an map for a Process object.

Remarks

Each Map object in an Maps Collection corresponds to one map for a Process. Maps are created by Builder, from the main map, and any sub-flow maps.


GetParentMap Method

GetParentMap Method (Map)

Returns the parent map for the given map.

Return Type

A Object value.

Syntax

object.GetParentMap


GetSubMap Method

Returns the sub map for the given map id.

Return Type

A Object value.

Syntax

object.GetSubMap(MapId As Long)

Parameters

Part | Description
MapId | Long


HitTest Method

Returns the event id from the entered coordinates.

Return Type

A Object value.

Syntax

object.HitTest(x As Long, y As Long)

Parameters

Part | Description
x | Long
y | Long


Refresh Method

Refresh Method (Map)

This method refreshes the map from Process Broker.

Return Type

None.

Syntax

object.Refresh


SetPhysicalFilePath Method

SetPhysicalFilePath Method (Map)

This map will set the file path that the Map should be stored at, along with whether the map should be refreshed regardless of its current state.

Syntax

object.SetPhysicalFilePath(PhysicalFile As String, ForceRefresh As Boolean)

Parameters

Part | Description
PhysicalFile | String
ForceRefresh | Boolean


MapFile Property (Map)

This property contains the path and file name of the temporary map file.

Settings and Return Values

Returns a String value using the PathType enumeration.


MapHotSpots Property (Map)

This property contains a MapHotSpots object for the map.

Settings and Return Values

Returns an Object value.

Remarks

The property is read-only.


MapId Property (Map)

Uniquely identifies a Map within a given Process.

Settings and Return Values

Returns a Long value.

Remarks

The MapId for the main map in any given Process (i.e. the one retrieved from Process.Map) is always 0.

The property is read-only.


ProcessId Property (Map)

Uniquely identifies the Process in which the Map is defined.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


MapHotSpot

MapHotSpot Object

The Object that contains the information for a MapHotSpot in the MapHotSpots collection.


EventId Property (MapHotSpot)

Uniquely identifies a Event for which the MapHotSpot provides coordinates on the process Map.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


EventType Property (MapHotSpot)

This property contains the type of the event represented by the MapHotSpot.

Settings and Return Values

Returns an Object of EventType enumeration.

Remarks

The property is read-only.


Height Property (MapHotSpot)

This property contains the height of the MapHotSpot.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


Left Property (MapHotSpot)

This property contains the left most coordinate of the MapHotSpot.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


Top Property (MapHotSpot)

This property contains the top most coordinate of the MapHotSpot.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


Width Property (MapHotSpot)

This property contains the width of the MapHotSpot.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


Package

Package Object

Represents a Package object.

Remarks

A Package is an electronic container for work objects as they travel through a Process flow. A work object can be anything - text, images, documents, faxes, etc. - that can be stored as a FieldValue or Attachment. The structure and behaviors of a Package are defined in a Template.


AddCustomAuditEntry Method

AddCustomAuditEntry Method (Package)

This method adds a custom history entry (Audit) to the package.

Return Type

None.

Syntax

object.AddCustomAuditEntry(Type As CustomAuditType, Entry As String)

Parameters

Part | Description
Type | A type specifying which level of custom audit.
Entry | A string value to be added to the package's history

Remarks

CanDoOperation(PackageOperation.poAddJournalEntry) should be performed before invoking this method.


AddJournalEntry Method

AddJournalEntry Method (Package)

This method adds a comment (Audit) to the package.

Return Type

None.

Syntax

object.AddJournalEntry(Entry As String)

Parameters

Part | Description
Entry | A string value to be added to the package's audit trail

Remarks

CanDoOperation should be performed before invoking this method.


Complete Method

Complete Method (Package)

This method completes the package from its current queue.

Return Type

None.

Syntax

object.Complete([DecisionChoice As DecisionChoice])

Parameters

Part | Description
DecisionChoice | An (optional) DecisionChoice indicating the path the package should take upon leaving the queue

Remarks

CanDoOperation should be performed before invoking this method.

A DecisionChoice object is obtained from the package's current Queue.

If a default Decision Choice is configured (through BPM Builder), the DecisionChoice parameter can be left blank. If there is no configured default Decision Choice, the DecisionChoice parameter is required on a Decision queue.

See Also

HasDecision, Package.Queue, Queue.DecisionChoices


Delete Method

Delete Method (Package)

This method deletes the package from the specified location(s).

Return Type

None.

Syntax

object.Delete(Option As PackageDelete)

Parameters

Part | Description
Option | An enumeration constant of type PackageDelete indicating specifics on how copies of the package should be deleted

Remarks

CanDoOperation should be performed before invoking this method.

The PackageDelete values are interpreted as follows:

  • PackageDelete.pdAll - Delete all copies of the package
  • PackageDelete.pdProcess - Delete all copies of the package in the current process
  • PackageDelete.pdEvent - Delete all copies of the package in the current event


Lock Method

Lock Method (Package)

Locks the package to the current user.

Return Type

None.

Syntax

object.Lock

Remarks

CanDoOperation should be performed before invoking this method.

See Also

PackageType, Unlock


PlaceInFlow Method

PlaceInFlow Method (Package)

Places the package into a process flow at the specified start event.

Return Type

None.

Syntax

object.PlaceInFlow(Event As Event, Priority As Long, Comment As String)

Parameters

Part | Description
Event | The Start Event into which the package is to be placed
Priority | A Long specifying the initial priority for the package
Comment | A String that will be added to the package's audit trail

Remarks

An appropriate Start Event is obtained from an associated Process.

See Also

Processes, Process.Events


RouteAdhoc Method

RouteAdhoc Method (Package)

Performs and adhoc route of the package to another event.

Return Type

None.

Syntax

object.RouteAdhoc(Event As Event, Priority As Long, Comment As String)

Parameters

Part | Description
Event | The Event to which the package is to be routed
Priority | A Long value indicating the new priority for the package
Comment | A String value to be added to the package's audit trail

Remarks

CanDoOperation should be performed before invoking this method.

An appropriate destination Event is obtained from the package's current Process.

The package's current Event and the destination Event should be checked to see if they support adhoc routing.

See Also

Event.CanAdhocRouteFrom, Event.CanAdhocRouteTo


RouteToEvent Method

RouteToEvent Method (Package)

Routes the package to the specified event.

Return Type

None.

Syntax

object.RouteToEvent(Event As Event)

Parameters

Part | Description
Event | An Event to which the package is to be routed

Remarks

CanDoOperation should be performed before invoking this method.

An appropriate destination Event is obtained from the package's current Process.


RouteToUser Method

RouteToUser Method (Package)

Routes the package to the specified user's Inbox.

Return Type

None.

Syntax

object.RouteToUser(WFUser As WFUser)

Parameters

Part | Description
WFUser | A WFUser object that represents the user to whose inbox the package is to be routed

Remarks

CanDoOperation should be performed before invoking this method.

A list of Process users can be obtained from the WFUsers collection.


Unlock Method

Unlock Method (Package)

Unlocks the package if it has been locked to the current user

Return Type

None.

Syntax

object.Unlock

Remarks

CanDoOperation should be performed before invoking this method.

See Also

PackageType, Lock


Attachments Property (Package)

Represents the documents that have been associated with the package.

Settings and Return Values

Returns an object reference evaluating to an Attachments collection.

Remarks

This property is read-only

See Also

Attachment


Audits Property (Package)

Represents the audit trail for the package.

Settings and Return Values

Returns an object reference evaluating to an Audits collection.

Remarks

This property is read-only

See Also

Audit


AutoAttachments Property (Package)

Represents the documents that should be auto-loaded for the package.

Settings and Return Values

Returns an object reference evaluating to an AutoAttachments collection.

Remarks

This property is read-only

See Also

Attachment


AutoForm Property (Package)

Represents the form to be automatically launched when the package is viewed.

Settings and Return Values

Returns an object reference evaluating to a Form object.

Remarks

This property is read-only


CanDoOperation Property (Package)

This property determines whether a particular operation can be performed on the package.

Settings and Return Values

Returns a Boolean value.

  • True - The given operation can be performed on the package.
  • False - The given operation cannot be performed on the package.

Syntax

value = object.CanDoOperation(Operation As PackageOperation)

Parameters

Part | Description
Operation | An enumeration constant of type PackageOperation

Remarks

This property is read-only


CreateDate Property (Package)

This property represents the date that the package was created.

Settings and Return Values

Returns a Date value.

Remarks

This property is read-only


CreatorName Property (Package)

This property contains the name of the package creator.

Settings and Return Values

Returns a String value.

Remarks

This property is read-only


CreatorUserId Property (Package)

This property contains the numeric identifier of the package creator.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only


DefaultDecisionChoice Property

DefaultDecisionChoice Property (Package)

Represents the decision choice that can be used to complete the package without prompting the user. .

Settings and Return Values

Returns an object reference evaluating to a DecisionChoice object.

Remarks

This property is read-only. A queue may or may not have a default decision, based on the configuration of the queue through Process Builder.


DueDate Property (Package)

Represents the date and time upon which the package's Due Date Trigger will be fired.

Settings and Return Values

Returns a Date value.

Remarks

This property is read-only


DueDateFired Property (Package)

This property provides an indication as to whether or not the package's Due Date Trigger has successfully fired.

Settings and Return Values

Returns a Boolean value.

Remarks

This property is read-only


Event Property (Package)

Represents the event in which the package is currently located.

Settings and Return Values

Returns an object reference evaluating to an Event object.

Remarks

This property is read-only


EventId Property (Package)

Represents the numeric identifier of the event in which the package is currently located.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only


EventName Property (Package)

Represents the name of the event in which the package is currently located.

Settings and Return Values

Returns a String value.

Remarks

This property is read-only


FieldValues Property (Package)

Represents the values of the package's field data.

Settings and Return Values

Returns an object reference evaluating to a FieldValues collection.

Remarks

This property is read-only


Forms Property (Package)

Represents the forms that have been associated with the package.

Settings and Return Values

Returns an object reference evaluating to a Forms collection.

Remarks

This property is read-only


HasDecision Property (Package)

Provides an indication regarding whether or not a routing decision can be provided during the completion of the package.

Settings and Return Values

Returns a Boolean value.

  • True - the package resides in a queue that incorporates a routing decision
  • False - the package does not reside in a queue that incorporates a routing decision

Remarks

This property is read-only

A routing decision can be provided programmatically during a call to Complete. This decision takes the form of a DecisionChoice object. A DecisionChoice is obtained from the package's current Queue.

See Also

Queue.DecisionChoices


InQueueDate Property (Package)

Represents the date and time at which the package arrived in its current queue.

Settings and Return Values

Returns a Date value.

Remarks

This property is read-only


LockedByName Property (Package)

Represents the name of the user to which the package is currently locked.

Settings and Return Values

Returns a String value.

Remarks

This property is read-only

See Also

PackageType, Lock, Unlock


LockedByUserId Property (Package)

Represents the numeric identifier of the user to which the package is currently locked.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only

See Also

PackageType, Lock, Unlock


PackageType Property (Package)

Represents the current type (or state) of the package.

Settings and Return Values

Returns a value from the PackageType enumeration.

Remarks

This property is read-only.

The value PackageType.ptInvalid is a meaningful state indicating that the local cache can no longer be considered an accurate representation of the package's true state.


PermissionLevel Property (Package)

Represents the permission level of the package.

Settings and Return Values

Returns a value from the PackagePermission enumeration.

Remarks

This property is read-only


PkgId Property (Package)

Represents the numeric identifier of the package.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only

This value is identical across all copies of a package.


PkgRecId Property (Package)

Represents the numeric identifier for this copy of the package.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only

This value is unique across all copies of a package.


Priority Property (Package)

Represents the package's current priority.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only


Process Property (Package)

Represents the process in which the package is currently located.

Settings and Return Values

Returns an object reference evaluating to a Process object.

Remarks

This property is read-only


ProcessId Property (Package)

Represents the numeric identifier of the process in which the package is currently located.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only


ProcessName Property (Package)

Represents the name of the process in which the package is currently located.

Settings and Return Values

Returns a String value.

Remarks

This property is read-only


Queue Property (Package)

Represents the event queue in which the package is currently located.

Settings and Return Values

Returns an object reference evaluating to a Queue collection.

Remarks

This property is read-only


QueueId Property (Package)

Represents the numeric identifier of the event queue in which the package is currently located.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only


QueueName Property (Package)

Represents the name of the event queue in which the package is currently located.

Settings and Return Values

Return a String value.

Remarks

This property is read-only


SenderName Property (Package)

Represents the name of the user that routed the package across Process domains.

Settings and Return Values

Returns a String value.

Remarks

This property is read-only

This property is only filled subsequent to a cross-domain route.


Tasks Property (Package)

Represents the tasks that have been assigned to the package through association with the package's current queue.

Settings and Return Values

Returns an object reference evaluating to a Tasks collection.

Remarks

This property is read-only

See Also

Task, Queue.TaskDefinitions


Template Property (Package)

Represents the template that defines the structure of the package.

Settings and Return Values

Returns an object reference evaluating to a Template object.

Remarks

This property is read-only

See Also

Templates


TemplateId Property (Package)

Represents the numeric identifier of the template that defines the structure of the package.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only

See Also

Package.Template


TemplateName Property (Package)

Represents the name of the template that defines the structure of the package.

Settings and Return Values

Returns a String value.

Remarks

This property is read-only

See Also

Package.Template


Threshold1 Property (Package)

Represents the first time threshold assigned to the package through association with the package's current queue.

Settings and Return Values

Returns a Date value.

Remarks

This property is read-only


Threshold2 Property (Package)

Represents the second time threshold assigned to the package through association with the package's current queue.

Settings and Return Values

Returns a Date value.

Remarks

This property is read-only


Threshold3 Property (Package)

Represents the third time threshold assigned to the package through association with the package's current queue.

Settings and Return Values

Returns a Date value.

Remarks

This property is read-only


ThresholdFired Property (Package)

Provides an indication of the time thresholds that have fired for the package.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only

The return value is interpreted as follows:

  • 0 - No threshold has fired.
  • 1 - Threshold 1 has fired.
  • 2 - Thresholds 1 and 2 have fired.
  • 3 - All three thresholds have fired.


Title Property (Package)

Represents the title of the package.

Settings and Return Values

Returns a String value.

Remarks

This property is read-only


UserToken Property

UserToken Property (Package)

Represents the user token of the user who refreshed the profile. This field is used internally within the Windows client.

Settings and Return Values

Returns an object reference evaluating to a UserToken object.

Remarks

This property is read-only. This property will have the same value that you passed into the Packages object.


XMLMetaData Property

XMLMetaData Property (Package)

This property contains the data value for the XML package field.

Settings and Return Values

Returns a String value.

Remarks

This value is not accessible through the Windows/Web client. There is only one XML package field per package.


Process

Process Object

The Object that contains the information for a Process in the Processes Collection.


ConstantPriority Property (Process)

Provides an indication regarding whether or not the Process resets a Package's priority at each Event in the flow.

Settings and Return Values

Returns a Boolean value.

  • True - A Package's priority is not reset at each Event.
  • False - A Package's priority is reset at each Event.

Remarks

This property is read-only.


Description Property (Process)

Represents a textual description of the the Process.

Settings and Return Values

Returns a String value.

Remarks

This property is read-only


Events Property (Process)

Represents the list of Events defined for the Process.

Settings and Return Values

Returns an object reference that evaluates to an Events collection.

Remarks

This property is read-only


HelpFile Property (Process)

Represents the location of the help file associated with the Process.

Settings and Return Values

Returns a String value.

Remarks

This property is read only.

The location can be a URL or UNC path.


Map Property (Process)

Provides a graphical representation of the Process.

Settings and Return Values

Returns an object reference that evaluates to a Map object.

Remarks

This property is read-only


ProcessId Property (Process)

Represents the numeric identifier of the Process.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only


ProcessName Property (Process)

Represents the name of the Process.

Settings and Return Values

Returns a String value.

Remarks

This property is read-only


ProcessTemplates Property (Process)

Represents the list of Templates that have been associated with the Process.

Settings and Return Values

Returns an object reference that evaluates to a ProcessTemplates collection.

Remarks

This property is read-only


Queues Property (Process)

Represents the list of Queues defined for the Process.

Settings and Return Values

Returns an object reference that evaluates to a Queues collection.

Remarks

This property is read-only


ProcessTemplate

ProcessTemplate Object

Represents a Process' view of a Template object.


CreatePackage Method

CreatePackage Method (ProcessTemplate)

See: Template.CreatePackage


AttachmentTypes Property (ProcessTemplate)

See: Template.AttachmentTypes


CanCreate Property (ProcessTemplate)

See: Template.CanCreate


Description Property (ProcessTemplate)

See: Template.Description


FieldDefinitions Property (ProcessTemplate)

See: Template.FieldDefinitions


Forms Property (ProcessTemplate)

See: Template.Forms


StartEvents Property (ProcessTemplate)

See: Template.StartEvents


TemplateId Property (ProcessTemplate)

See: Template.TemplateId

Remarks

This property is the numeric key into the ProcessTemplates collection.

See Also

ProcessTemplates.FindById


TemplateName Property (ProcessTemplate)

See: Template.TemplateName

Remarks

This property is the String key into the ProcessTemplates collection.


Profile

Profile Object

The Object that contains the information for a Profile in the Profiles Collection.


HasPrompts Property (Profile)

This property indicates whether prompt fields have been defined for this profile.

Settings and Return Values

Returns a Boolean value.

Remarks

The property is read-only.

It the value of this property is true, then the Prompts collection returned by the Profile.Prompts property will have a non-zero count.


Inbox Property (Profile)

Indicates whether or not the profile is an Inbox profile.

Return Values

Returns a Boolean value indicating whether or not the Profile is an Inbox profile.

Remarks

The property is read-only.


InboxUserId Property (Profile)

The id of the user whose Inbox this profile is set for.

Return Values

Returns a Long value for the users id.

Remarks

The property is read-only.


PkgId Property (Profile)

This property is a number that uniquely identifies the Package to which the profile can filter on.

Settings and Return Values

Sets or returns a Long value.


PkgRecId Property (Profile)

This property is a number that uniquely identifies the Package Record Id to which the profile can filter on.

Settings and Return Values

Sets or returns a Long value.


ProfileCriteria Property (Profile)

This property is an Object that uniquely identifies the ProfileCriteria for which the profile can filter on.

Settings and Return Values

Sets or returns an Object value.


ProfileId Property (Profile)

This property is a number that identifies the Profile Id to which the profile can filter on.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


ProfileName Property (Profile)

Provides the textual name of the named Profile.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


ProfileType Property (Profile)

This property is a enumeration that identifies the ProfileType for the profile.

Settings and Return Values

Returns a ProfileType value indicating the ProfileType enumeration.

Remarks

The property is read-only.


Prompts Property (Profile)

Returns the Prompts collection for the profile.

Settings and Return Values

Returns an object reference evaluating to a Prompts collection.

Remarks

This value is read-only. Before getting this property, calling code should test the Profile.HasPrompts property to ensure that the Prompts collection that is returned will have a non-zero count. Doing so will perform better since this save a call to the Process Broker to get prompts when none exist for the given profile.


Queue Property (Profile)

This property is an Object that uniquely identifies the Queue Id for which the profile can filter on.

Settings and Return Values

Sets or returns a Object value.


QueueSelectType Property (Profile)

The property describing what type of packages to retrieve; all, unlocked only, or lock first.

Property Type

A QSelectType value.

Settings and Return Values

Sets or Returns a QSelectType value indicating what the QueueSelectType enumeration is.


TemplateId Property (Profile)

This property is a number that identifies the Package Template Id for the profile.

Return Values

Returns a Long value.

Remarks

The property is read-only.


ProfileCriteria

ProfileCriteria Object

The ProfileCriteria object represents a mechanism for expressing how Package objects will be (have been) selected for inclusion in a Packages collection.

Remarks

A ProfileCriteria object contains zero or more FieldCriterion and LocationCriterion objects that are evaluated during a package search.

A ProfileCriteria object describes the sorting algorithm that is applied to the results of a package search via its SortCriteria property.

A ProfileCriteria may contain zero or more sub Profiles (in its SubProfiles property).

Conceptually, a ProfileCriteria and its SubProfiles are evaluated during a package search for each package in the BPM database as follows:

  1. Each subordinate Profile is evaluated to a Boolean result.
  2. All of the subordinate Profile evaluation results are OR'd together to produce an intermediate result.
  3. The main ProfileCriteria is evaluated to a Boolean result.
  4. The main ProfileCriteria result and the intermediate result are AND'd together to produce a final result.
  5. If the final result is True, the package is included in the search results.


Commit Method

Commit Method (ProfileCriteria)

Used to update the BPM database with any changes that have been made to the ProfileCriteria.

Return Type

None.

Syntax

object.Commit

Remarks

Commit will transmit to the BPM database all changes to the ProfileCriteria object.

Calling the ProfileCriteria's Refresh method without first calling Commit will reset the state of the ProfileCriteria object from the BPM database. This feature can be used to roll-back any undesired changes.


Delete Method

Delete Method (ProfileCriteria)

Used to remove the ProfileCriteria from the BPM database.

Return Type

None.

Syntax

object.Delete

Remarks

This method will succeed only for ProfileCriteria objects that have been assigned to a Named Profile.


Refresh Method

Refresh Method (ProfileCriteria)

Loads a ProfileCriteria object from the BPM database.

Return Type

None.

Syntax

object.Refresh

Remarks

The ProfileId property must be set prior to invoking this method.


FieldCriteria Property (ProfileCriteria)

Represents the template field selection criteria associated with the ProfileCriteria object.

Settings and Return Values

Returns an object reference evaluating to a FieldCriteria object.

Remarks

This property is read-only


LocationCriteria Property (ProfileCriteria)

Represents the location selection criteria associated with the ProfileCriteria object

Settings and Return Values

Returns an object reference evaluating to a LocationCriteria object.

Remarks

This property is read-only


ProfileId Property (ProfileCriteria)

Represents the numeric identifier of the Named Profile to which the ProfileCriteria has been assigned.

Settings and Return Values

Sets and returns a Long value.

Remarks

This property is initially -1 for ProfileCriteria objects that are unassigned or assigned to an Adhoc Profile.

Since this property can be programmatically altered, it should not be relied upon as reflecting an accurate state of the BPM database.


ProfileName Property (ProfileCriteria)

Represents the name of the Profile to which the ProfileCriteria has been assigned.

Settings and Return Values

Sets and returns a Long value.

Remarks

This property is initially empty for ProfileCriteria objects that are unassigned or assigned to an Adhoc Profile.

Since this property can be programmatically altered, it should not be relied upon as reflecting an accurate state of the BPM database.


ResultSetSize Property (ProfileCriteria)

Represents the maximum number of Packages that will be returned from a search that employs this ProfileCriteria.

If you intend to process all packages returned by a profile, it is recommended that you configure the ResultSetSize for a reasonable size (i.e 1000). If the Packages.Refresh statement returns the same number of rows (Pacakges.Count) as ResultSetSize property, work that set of packages then refresh the profile again to work the next set (of 1000). This assumes that when you have "processed" a package that it will no longer be returned by the profile.

Settings and Return Values

Sets and returns a Long value.


SelectType Property (ProfileCriteria)

Represents the type of packages that will be returned from a package search that employs the ProfileCriteria.

Settings and Return Values

Returns a value from the SelectType enumeration.


SortCriteria Property (ProfileCriteria)

Represents the sorting algorithm that will be applied to the collection of packages returned from a package search that employs the ProfileCriteria.

Settings and Return Values

Returns an object reference evaluating to a SortCriteria object.

Remarks

This property is read-only


SubProfiles Property (ProfileCriteria)

Represents the collection of Profiles that are 'subordinate' to the ProfileCriteria.

Settings and Return Values

Returns an object reference evaluating to a SubProfiles collection.

Remarks

This property is read-only

Conceptually, a ProfileCriteria and its SubProfiles are evaluated during a package search for each package in the BPM database as follows:

  1. Each subordinate Profile is evaluated to a Boolean result.
  2. All of the subordinate Profile evaluation results are OR'd together to produce an intermediate result.
  3. The main ProfileCriteria is evaluated to a Boolean result.
  4. The main ProfileCriteria result and the intermediate result are AND'd together to produce a final result.
  5. If the final result is True, the package is included in the search results.


TemplateId Property (ProfileCriteria)

Represents the numeric identifier of the Template to which the ProfileCriteria is specific.

Settings and Return Values

Sets and returns a Long value.

Remarks

A value of -1 indicates that the ProfileCriteria is applicable to all Templates in the BPM database.


Prompt Object

Represents a prompt field for a specific Profile.


AddOperand Method

AddOperand Method (Prompt)

Adds an operand value to prompt..

Return Type

None.

Syntax

object.AddOperand(Operand As Variant)

Parameters

Part | Description
Operand | An operand to be used in evaluating the profile.


Clear Method

Clear Method (Prompt)

Clears the operation and the operands of the Prompt.

Return Type

None

Syntax

object.Clear


DisplayText Property

DisplayText Property (Prompt)

Represents the text used to identify what field information is needed to be entered.

Settings and Return Values

Returns a String value.

Remarks

This property is read-only


FieldId Property

FieldId Property (Prompt)

Represents the numeric identifier of the FieldDefinition that has been associated with the PromptCriterion.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only


FieldType Property

FieldType Property (Prompt)

This property is an enumeration that identifies the type of the FieldDefinition that has been associated with the PromptCriterion.

Settings and Return Values

Returns a FieldType value.

Remarks

This property is read-only


OperandCount Property

OperandCount Property (Prompt)

Represents the number of operands that have been associated with the PromptCriterion.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only


OperandItem Property

OperandItem Property (Prompt)

Returns the specified operand from the PromptCriterion.

Return Type

Variant

Syntax

variant = object.OperandItem(Index As Long)

Parameters

Part | Description
Index | The index of the operand to be returned.


Operator Property

Operator Property (Prompt)

Sets the operator for to the Prompt.

Settings and Return Values

Sets and returns a value from the Operator enumeration.


OperatorCount Property

OperatorCount Property (Prompt)

Represents the number of operators that have been associated with the PromptCriterion.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only


OperatorItem Property

OperatorItem Property (Prompt)

Returns the specified operator from the PromptCriterion.

Return Type

Returns an Operator value.

Syntax

variant = object.OperatorItem(Index As Long)

Parameters

Part | Description
Index | The index of the operator to be returned.


Required Property

Required Property (Prompt)

Specifies whether or not the prompt information is required in order to execute the profile, as configured within the PromptCriterion.

Settings and Return Values

Returns a Boolean value.

Remarks

This property is read-only


UseDistinctList Property

UseDistinctList Property (Prompt)

Specifies whether or not the distinct list values can be used to enter the prompt information for the profile, as configured within the PromptCriterion.

Settings and Return Values

Returns a Boolean value.

Remarks

This property is read-only


UsePickList Property

UsePickList Property (Prompt)

Specifies whether or not the pick list values can be used to enter the prompt information for the profile, as configured within the PromptCriterion.

Settings and Return Values

Returns a Boolean value.

Remarks

This property is read-only


PromptCriterion Object

The PromptCriterion object represents a mechanism for expressing how Package objects will be (have been) selected for inclusion in a Packages collection.

Remarks

The PromptCriterion object defines a list of Prompts allowing the user to execute different package searches without defining a unique profile each time.


AddOperator Method

AddOperator Method (PromptCriterion)

Adds an Operator to the collection.

Return Type

None.

Syntax

object.AddOperator(Operator As Operator)

Parameters

Part | Description
Operator | The object to be added to the collection.

See Also

ProfileCriteria


RemoveAllOperators Method

RemoveAllOperators Method (PromptCriterion)

Clears the list of operators set in the PromptCriterion.

Return Type

None

Syntax

object.RemoveAllOperators


DisplayText Property

DisplayText Property (PromptCriterion)

Represents the text used to identify what field information is needed to be entered.

Settings and Return Values

Sets and returns a String value.


FieldDefinition Property

FieldDefinition Property (PromptCriterion)

Associates a FieldDefinition with the PromptCriterion.

Settings and Return Values

Sets and returns an object reference evaluating to a FieldDefinition object.


FieldId Property

FieldId Property (PromptCriterion)

Represents the numeric identifier of the FieldDefinition that has been associated with the PromptCriterion.

Settings and Return Values

Sets and returns a Long value.

Remarks

This property is read-only


FieldType Property

FieldType Property (PromptCriterion)

This property is an enumeration that identifies the type of the FieldDefinition that has been associated with the PromptCriterion.

Settings and Return Values

Returns a FieldType value.

Remarks

The property is read-only.


OperatorCount Property

OperatorCount Property (PromptCriterion)

Represents the number of operators that have been associated with the PromptCriterion.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only


OperatorItem Property

OperatorItem Property (PromptCriterion)

Returns the specified operator from the PromptCriterion.

Return Type

Returns a Operator value.

Syntax

variant = object.OperatorItem(Index As Long)

Parameters

Part | Description
Index | The index of the operator to be returned.


Required Property

Required Property (PromptCriterion)

Specifies whether or not the prompt information is required in order to execute the profile.

Settings and Return Values

Sets or returns a Boolean value.


UseDistinctList Property

UseDistinctList Property (PromptCriterion)

Specifies whether or not the distinct list values can be used to enter the prompt information for the profile.

Settings and Return Values

Sets or returns a Boolean value.


UsePickList Property

UsePickList Property (PromptCriterion)

Specifies whether or not the pick list values can be used to enter the prompt information for the profile.

Settings and Return Values

Sets or returns a Boolean value.


Queue

Queue Object

The Object that contains the information for a Queue in the Queues Collection.


Behavior Property (Queue)

States the type of work queue, either work in progress or first in first out.

Settings and Return Values

Returns a QueueBehavior value.

Remarks

Work in progress queues are designed so that the order of package processing is not limited. FIFO queues are used so that workers only see the next available (by date in queue) package.


DecisionChoices Property (Queue)

Returns an object that represents all the available destination paths for a Package to follow, if more than one destination is available.

Settings and Return Values

Returns a DecisionChoices object.

Remarks

This property is read only. The returned object will be Nothing if a decision is not necessary to complete the Package.


EventId Property (Queue)

Uniquely identifies the Event in which the Queue is located.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


EventName Property (Queue)

Provides the textual name of the the Event in which the Queue is located.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


HasDecision Property (Queue)

This property is used to find out if a destination path needs to be chosen before a package can be completed.

Settings and Return Values

Returns a Boolean value.

Remarks

This property is read only. See also Queue.DecisionChoices.


ProcessId Property (Queue)

Uniquely identifies the Process in which the Queue is defined.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


ProcessName Property (Queue)

Provides the textual name of the the Process in which the Queue is located.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


QueueId Property (Queue)

Uniquely identifies the Queue within a given Process.

Settings and Return Values

Returns a Long value.

Remarks

QueueId is also the unique numerical ID key into the Queues collection (see Queues.FindById.)

The property is read-only.


QueueName Property (Queue)

Provides the textual name of the Queue.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


TaskDefinitions Property (Queue)

Returns an object that represents all the tasks which may or may not have to be completed at this particular Queue before the Package is allowed to be completed.

Settings and Return Values

Returns a TaskDefinitions collection of all the BPM Builder defined tasks for this Queue.

Remarks

This property is read only. An empty collection will be returned for a Queue in which no tasks were defined.


SortCriterion

SortCriterion Object

The SortCriterion object represents a mechanism for expressing how Package objects will be (have been) ordered in a Packages collection.

Remarks

A SortCriterion object represents the sort order (ascending or descending) of a particular field in a Template.

See Also

ProfileCriteria


Set Method

Set Method (SortCriterion)

Assigns a FieldDefinition and sort direction to the SortCriterion.

Return Type

None.

Syntax

object.Set(FieldId As Long, Direction As SortDirection)

Parameters

Part | Description
FieldId | The numeric identifier of the FieldDefinition that is to be assigned
Direction | A value from the SortDirection enumeration

See Also

SetEx


SetEx Method

SetEx Method (SortCriterion)

Assigns a FieldDefinition and sort direction to the SortCriterion.

Return Type

None.

Syntax

object.SetEx(FieldDefinition As FieldDefinition, Direction As SortDirection)

Parameters

Part | Description
FieldId | The FieldDefinition that is to be assigned
Direction | A value from the SortDirection enumeration

See Also

Set


Direction Property (SortCriterion)

Represents the sort direction (ascending or descending) for the associated FieldDefinition.

Settings and Return Values

Sets and returns a value from the SortDirection enumeration.


FieldId Property (SortCriterion)

Represents the numeric identifier of the FieldDefinition that has been assigned to the SortCriterion.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only

See Also

Set, SetEx


Task

Task Object

Represents tasks for a Package object.

Remarks

Each task object in an Tasks Collection corresponds to one task for a package in that given queue. Tasks may be modified and created using Process Builder.


Complete Method

Complete Method (Task)

This method completes a task for a package.

Return Type

None.

Syntax

object.Complete()


Select Method

Select Method (Task)

This method selects a task for a package.

Return Type

None.

Syntax

object.Select


Undo Method

Undo Method (Task)

This method undoes a task for a package that has been previously committed..

Return Type

None.

Syntax

object.Undo

Remarks

The method IsCompleted may be used to verify that the task has been completed before calling Undo.


CompletedByUserName Property (Task)

Provides the full name of the WFUser who completed the Task.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


CompletedDate Property (Task)

This method returns the complete date for a task.

Property Type

A Date value.

Settings and Return Values

Returns a Date value.


Definition Property (Task)

This property is the description or name that uniquely identifies the task.

Property Type

Returns an object reference evaluating to a TaskDefinition object.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


IsCompleted Property (Task)

This method returns whether or not a task has been completed.

Settings and Return Values

Returns a Boolean value.

Remarks

The property is read-only.


TaskDefinition

TaskDefinition Object

Contains information that uniquely defines a Task in a Tasks Collection.


Description Property (TaskDefinition)

This property is the description or name that uniquely identifies the task.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


EventId Property (TaskDefinition)

Uniquely identifies the Event in which the task is defined.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


IsRequired Property (TaskDefinition)

This property specifies whether or not a task is required. If a task is required, then it must be completed before the package can be completed.

Settings and Return Values

Returns a Boolean value.

Remarks

The property is read-only.


ParentTaskId Property (TaskDefinition)

Uniquely identifies the parent TaskDefinition for this task, if one has been defined.

Settings and Return Values

Returns a Long value.

Remarks

Parent Tasks impose task dependencies where one task must be completed before completing another. If a tasks are not completed in the proper order, Task.Complete will generate an error. Whether Parent Task are dependent on child tasks or whether child tasks are dependent on parent task is determined by the Enable Parent Task Dependency setting on Process Broker.

If the TaskDefinition has no parent, then ParentTaskId will be less than 1.

The property is read-only.


ProcessId Property (TaskDefinition)

Uniquely identifies the Process in which the task is defined.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


TaskId Property (TaskDefinition)

Uniquely identifies the TaskDefinition within a given Queue.

Settings and Return Values

Returns a Long value.

Remarks

TaskId is also the unique numerical ID key into the TaskDefinitions collection (see TaskDefinitions.FindById.)

TaskId does not necessarily imply task order. A task is given its unique Id when it is created and it will not change regardless of how the task order is rearranged from BPM Builder. The ordinal number into the TaskDefinitions collection (and likewise the Tasks collection) should be used to determine task order.

The property is read-only.


TaskName Property (TaskDefinition)

Provides the textual name of the TaskDefinition and the Task to which it corresponds.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


Template

Template Object

The object that contains the information for a Template in the Templates Collection.


CreatePackage Method

CreatePackage Method (Template)

Creates a new Package based upon the Template.

Return Type

An object reference that evaluates to a Package.

Syntax

object.CreatePackage

Remarks

The CanCreate property should be checked prior to calling this method.


AttachmentTypes Property (Template)

Represents the types of Attachment that can be associated with a Package that has been derived from the Template.

Settings and Return Values

Returns an object reference evaluating to a AttachmentTypes collection.

Remarks

This property is read-only


CanCreate Property (Template)

Provides an indication regarding whether or not the Template is capable of creating a Package.

Settings and Return Values

Returns a Boolean value.

Remarks

This property is read-only

This property should be checked prior to calling CreatePackage.


Description Property (Template)

Represents a textual description of the Template.

Settings and Return Values

Returns a String value.

Remarks

This property is read-only


FieldDefinitions Property (Template)

Represents the field structure of the Template.

Settings and Return Values

Returns an object reference that evaluates to a FieldDefinitions collection.

Remarks

This property is read-only


Forms Property (Template)

Represents the Form objects that have been associated with the Template.

Settings and Return Values

Returns an object reference that evaluates to a Forms collection.

Remarks

This property is read-only


StartEvents Property (Template)

Represents the list of Start Events that can be used to place a created Package into a Process flow.

Settings and Return Values

Returns an object reference that evaluates to an Events collection.

Remarks

This property is read-only

See Also

CreatePackage, TemplateProcesses


TemplateId Property (Template)

Represents the numeric identifier of the Template.

Settings and Return Values

Returns a Long value.

Remarks

This property is read-only

This property is the numeric key into the Templates collection.

See Also

Templates.FindById


TemplateName Property (Template)

Represents the name of the Template.

Settings and Return Values

Returns a String value.

Remarks

This property is the String key into the Templates collection.


TemplateProcesses Property (Template)

Represents the Processes with which the Template has been associated.

Settings and Return Values

Returns an object reference that evaluates to a TemplateProcesses collection.

Remarks

This property is read-only

See Also

TemplateProcess


TemplateProcess

TemplateProcess Object

Represents a Template's view of a Process.


ConstantPriority Property (TemplateProcess)

See: Process.ConstantPriority


Description Property (TemplateProcess)

See: Process.Description


Events Property (TemplateProcess)

See: Process.Events


Map Property (TemplateProcess)

See: Process.Map


ProcessId Property (TemplateProcess)

See: Process.ProcessId


ProcessName Property (TemplateProcess)

See: Process.ProcessName


Queues Property (TemplateProcess)

See: Process.Queues


WFUser

WFUser Object

Represents a user in an BPM database.

Remarks

The WFUser object is always obtained from a WFUsers collection.

The WFUser object is used to perform the route to user operation in Package.RouteToUser.


IsActive Property (WFUser)

Indicates whether the user represented by the WFUser object has currently active.

Settings and Return Values

Returns a Boolean value.

Remarks

The property is read-only.


IsAdmin Property (WFUser)

Indicates whether the user represented by the WFUser object has Process Administrator privileges.

Settings and Return Values

Returns a Boolean value.

Remarks

The property is read-only.


UserId Property (WFUser)

Uniquely identifies the WFUser within the BPM database.

Settings and Return Values

Returns a Long value.

Remarks

UserId is the unique numerical ID key into the WFUsers collection (see WFUsers.FindById.)

The property is read-only.


UserLogin Property (WFUser)

The user login of the user represented by the WFUser object

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


UserName Property (WFUser)

Provides the full name of the WFUser.

Settings and Return Values

Returns a String value.

Remarks

For user authentication based on Windows NT security, this value is the user's "Full Name" property.

The property is read-only.


Process Toolkit Enumerated Constants

Process SDK™ Toolkit Enumerated Constants

To assist in debugging, the Process SDK™ Toolkit enumerations list a value for each constant. However, this value is purely advisory, and may change from one release of the Toolkit to another. Your code should only depend on the name, not the actual value, of each enumerated constant.

Process Toolkit Enumerated Constant Summary

AuditType
CustomAuditType
EventType
FieldType
FormStyle
Operator
PackageDelete
PackageOperation
PackagePermission
PackageType
PathType
ProfileType
QSelectType


AuditType Enumeration

Members

Constant | Value | Description
atAddAttachment | 21 | Audit record detailing the addition of an attachment to a package.
atCustom1 | 32 | Audit record detailing a Custom1 defined audit entry.
atCustom10 | 33 | Audit record detailing a Custom10 defined audit entry.
atCustom2 | 34 | Audit record detailing a Custom2 defined audit entry.
atCustom3 | 35 | Audit record detailing a Custom3 defined audit entry.
atCustom4 | 36 | Audit record detailing a Custom4 defined audit entry.
atCustom5 | 37 | Audit record detailing a Custom5 defined audit entry.
atCustom6 | 38 | Audit record detailing a Custom6 defined audit entry.
atCustom7 | 39 | Audit record detailing a Custom7 defined audit entry.
atCustom8 | 40 | Audit record detailing a Custom8 defined audit entry.
atCustom9 | 41 | Audit record detailing a Custom9 defined audit entry.
atDelete | 11 | Audit record detailing the deletion of the package.
atDeleteAttachment | 23 | Audit record detailing the removal of an attachment from a package.
atES_EventComplete | 1 | Audit record detailing the Process Broker's movement of the package after the user has completed it.
atES_RouteToEvent | 7 | Audit record detailing the Process Broker's movement of the package after the user has routed it to another event.
atES_Start | 19 | Audit record detailing the Process Broker's movement of the package into the Start event after the user has placed the package into the flow.
atExternalAudit | 12 | Audit record detailing the Process Broker's movement of the package into an external event.
atFieldModification | 26 | Audit record detailing the modification of a field value.
atJournal | 3 | Audit record detailing a user defined comment.
atLockPackage | 15 | Audit record detailing the user's operation, Lock.
atModifyAttachment | 22 | Audit record detailing the modification of a package attachment.
atRemoveFromProcess | 25 | Audit record detailing the user's operation, RemoveFromProcess.
atRemoveFromQueue | 24 | Audit record detailing the user's operation, RemoveFromQueue.
atRouteToUser | 9 | Audit record detailing the user's operation, RouteToUser.
atRouteToXDomain | 13 | Audit record detailing the Process Broker's movement of the package from one domain to another using XDomain Script. This audit is no longer used.
atRuleEvaluated | 8 | Audit record detailing the Process Broker's evaluation at a rule event.
atScriptOutput | 14 | Audit record detailing any errors reported by scripting failures.
atStart | 4 | Audit record detailing the user's operation, PlaceInFlow.
atStop | 5 | Audit record detailing the package's arrival at a stop event.
atTaskComplete | 2 | Audit record detailing the user's operation, CompleteTask.
atTaskSelect | 17 | Audit record detailing the user's operation, SelectTask.
atTaskUndo | 18 | Audit record detailing the user's operation, UndoTask.
atThresholdFired | 20 | Audit record detailing the information about the firing of a threshold trigger.
atUnlockPackage | 16 | Audit record detailing the user's operation, Unlock.
atVerbose | 27 | Verbose audit record detailing the modification of a field value.
atWS_EventComplete | 0 | Audit record detailing the user's operation, Complete.
atWS_RouteToEvent | 6 | Audit record detailing the user's operation, RouteToEvent or AdhocRoute


CustomAuditType Enumeration

Members

Constant | Value | Description
atCustom1 | 32 | This specifies that an entry is added into the history of a package with AuditType = Custom1
atCustom10 | 33 | This specifies that an entry is added into the history of a package with AuditType = Custom10
atCustom2 | 34 | This specifies that an entry is added into the history of a package with AuditType = Custom2
atCustom3 | 35 | This specifies that an entry is added into the history of a package with AuditType = Custom3
atCustom4 | 36 | This specifies that an entry is added into the history of a package with AuditType = Custom4
atCustom5 | 37 | This specifies that an entry is added into the history of a package with AuditType = Custom5
atCustom6 | 38 | This specifies that an entry is added into the history of a package with AuditType = Custom6
atCustom7 | 39 | This specifies that an entry is added into the history of a package with AuditType = Custom7
atCustom8 | 40 | This specifies that an entry is added into the history of a package with AuditType = Custom8
atCustom9 | 41 | This specifies that an entry is added into the history of a package with AuditType = Custom9


EventType Enumeration

Members

Constant | Value | Description
etBegin | 4017 | This type specifies a begin event.
etCollect | 4012 | This type specifies a collect event.
etDistribute | 4013 | This type specifies a distribute event.
etEnd | 4018 | This type specifies an end event.
etExternal | 4016 | This type specifies an external event.
etInbox | 4015 | This type specifies an in process route event.
etInProcessRoute | 4031 | This type specifies an inbox event.
etRule | 4011 | This type specifies a rule event.
etScript | 4028 | This type specifies a script event.
etStart | 4019 | This type specifies a start event.
etStop | 4020 | This type specifies a stop event.
etSubFlow | 4014 | This type specifies a subflow event.
etWork | 4010 | This type specifies a work event.

Additional Notes:

There is no event type for an Annotation event, since it is only used to document the process. An annotation event is never actually added to the database as an event, therefore a type is unnecessary.


FieldType Enumeration

Members

Constant | Value | Description
ftBoolean | 5 | This specifies that the field is of type boolean.
ftDateTime | 4 | This specifies that the field is of type date/time.
ftDecimal | 3 | This specifies that the field is of type decimal.
ftInvalid | 0 | This specifies that the field type is of an invalid type.
ftNumber | 2 | This specifies that the field is of type number.
ftString | 1 | This specifies that the field is of type string.


FormStyle Enumeration

Members

Constant | Value | Description
fsASPForm | 4 | This specifies that the form is an ASP form. This form type is only supported in the Web client.
fsHTMLForm | 3 | This specifies that the form is an HTML form. This form type is only supported in the Web client.
fsInProcForm | 1 | This specifies that the form is an in process VB6 form (*.DLL). This form type is only supported in the Windows client.
fsOutOfProcForm | 2 | This specifies that the form is an out of process VB6 form (*.EXE). This form type is only supported in the Windows client.
fsUnknown | 0 | This specifies that the form is of unknown type.
fsWinForm | 5 | This specifies that the form is a .NET Windows form. This form type is only supported in the Windows client.


Operator Enumeration

Members

Constant | Value | Description
opBetween | 4 | This value is used to specify the Between operator within a profile or package search.
opEqualTo | 2 | This value is used to specify the Equal To operator within a profile or package search.
opGreaterThan | 1 | This value is used to specify the Greater Than operator within a profile or package search.
opIn | 3 | This value is used to specify the In operator within a profile or package search.
opLessThan | 0 | This value is used to specify the the Less Than operator within a profile or package search.
opLike | 5 | This value is used to specify the Like operator within a profile or package search.
opNotEqualTo | 6 | This value is used to specify the Not Equal To operator within a profile or package search.


PackageDelete Enumeration

Members

Constant | Value | Description
pdAll | 0 | This value specifies that you would like to delete all instances of the package. This will remove all references of the package from the database.
pdFromProcess | 1 | This value specifies that you would like to remove all instances of the package from the process. This will leave the package in the out of process state.
pdFromQueue | 2 | This value specifies that you would like to remove this instance of the package from the queue. If there is only one instance of the package, the package will appear out of flow.


PackageOperation Enumeration

Members

Constant | Value | Description
poAddJournalEntry | 10 | This value specifies the AddJournalEntry and AddCustomAuditEntry user operations.
poComplete | 4 | This value specifies the Complete and Default Complete user operations.
poDelete | 1 | This value specifies the Delete user operation.
poDeleteAttachment | 33 | This value specifies the RemoveAttachment user operation.
poDeleteFromProcess | 31 | This value specifies the DeleteFromProcess user operation.
poDeleteFromQueue | 32 | This value specifies the DeleteFromQueue user operation.
poEditTasks | 34 | This value specifies the SelectTask, UndoTask, CompleteTak user operations.
poInsertAttachment | 7 | This value specifies the AddAttachment user operation.
poLock | 2 | This value specifies the Lock user operation.
poPlaceInFlow | 0 | This value specifies the PlaceInFlow user operation.
poRouteAdhoc | 5 | This value specifies the RouteAdhoc user operation.
poRouteToEvent | 30 | This value specifies the RouteToEvent user operation.
poRouteToUser | 6 | This value specifies the RouteToUser user operation.
poUnlock | 3 | This value specifies the Unlock user operation.
poViewAttachments | 29 | This value specifies the ViewAttachment user operation.
poViewAudits | 9 | This value specifies the History user operation.
poViewForms | 12 | This value specifies the ViewForm user operation.
poViewMap | 11 | This value specifies the ViewMap user operation.
poViewTasks | 8 | This value specifies the ViewTasks user operation.


PackagePermission Enumeration

Members

Constant | Value | Description
ppAdmin | 5 | This value indicates that the user has admin rights on the specified queue.
ppFull | 2 | This value indicates that the user has full rights on the specified queue.
ppNone | 0 | This value indicates that the user has no rights on the specified queue.
ppRestricted | 1 | This value indicates that the user has restricted/read-only rights on the queue.


PackageType Enumeration

Members

Constant | Value | Description
ptInboxEvent | 7 | This value specifies that the package is in an Inbox event and it is locked to the current user.
ptInboxEventOU | 10 | This value specifies that the package is in an Inbox event and it is locked to another user.
ptInvalid | 0 | This value specifies that the package is an invalid type.
ptLocked | 4 | This value specifies that the package is in the flow, and is locked by the current user.
ptLockedOU | 5 | This value specifies that the package is in the flow, and it is locked by another user.
ptLockedPB | 8 | This value specifies that the package is in the flow, and it is locked to the Process Broker.
ptNew | 1 | This value specifies that the package is new and is created by the current user.
ptNewOU | 2 | This value specifies that the package is new and is created/locked by another user.
ptOutOfProc | 6 | This value specifies that the package is out of flow.
ptPBEvent | 9 | This value specifies that the package is in the flow, and is currently located in a Process Broker event (Rule, Distribute, etc.)
ptUnlocked | 3 | This value specifies that the package is in the flow, and is not locked.


PathType Enumeration

Members

Constant | Value | Description
ptFileOnly | 3 | This value specifies to return only the filename of the map or form.
ptFull | 1 | This value specifies to return the full path of the map or form.
ptPathOnly | 2 | This value specifies to return only the path of the map or form.


ProfileType Enumeration

Members

Constant | Value | Description
prAdHoc | 3 | This value specifies that the profile is an Adhoc profile.
prInbox | 4 | This value specifies that the profile is an Inbox profile.
prInvalid | 0 | This value specifies that the profile is of an unknown type.
prNamed | 2 | This value specifies that the profile is a Named profile.
prPkgId | 6 | This value specifies that the profile is a PkgId profile.
prPkgRecId | 1 | This value specifies that the profile is a PkgRecId profile.
prQueue | 5 | This value specifies that the profile is a Queue profile.


QSelectType Enumeration

Members

Constant | Value | Description
qtAll | 0 | This value specifies to return all packages in a queue profile.
qtLockFirst | 2 | This value specifies to only return packages one at a time and to lock the one that it returns in a queue profile.
qtUnlockedOnly | 1 | This value specifies to only return unlocked packages in a queue profile.


QueueBehavior Enumeration

Members

Constant | Value | Description
qbFIFO | 2 | This value specifies that the queue is defined as a First In First Out queue.
qbWIP | 1 | This value specifies that the queue is defined as a Work In Progress queue.


SelectType Enumeration

Members

Constant | Value | Description
stAll | 0 | This value specifies that you want to return all packages that are in process
stInAndOut | 4 | This value specifies that you want to return all packages in and out of process.
stLFUnlocked | 5 | This value specifies that you want to return packages one at a time and to lock the package it returns. This type will only return unlocked packages.
stLockFirst | 2 | This value specifies that you want to return packages one at a time and to lock the package it returns. This type will return packages already locked to the user before unlocked packages.
stOutOfProcess | 3 | This value specifies that you want to return all packages out of process.
stUnlockedOnly | 1 | This value specifies that you only want to return Unlocked packages.


SortDirection Enumeration

Members

Constant | Value | Description
sdAscending | 1 | This value specifies that you wish the sorting to be in ascending order.
sdDescending | 2 | This value specifies that you wish the sorting to be in descending order.


SystemFieldId Enumeration

Members

Constant | Value | Description
sfCreator | 65280 | This value specifies the FieldId of the Creator system field.
sfDateCreated | 65282 | This value specifies the FieldId of the DateCreated system field.
sfDateInQueue | 65283 | This value specifies the FieldId of the DateInQueue system field.
sfDueDate | 65284 | This value specifies the FieldId of the DueDate system field.
sfDueDateFired | 65285 | This value specifies the FieldId of the DueDateFired system field.
sfPriority | 65281 | This value specifies the FieldId of the Priority system field.
sfThreshold1 | 65286 | This value specifies the FieldId of the Threshold1Date system field.
sfThreshold2 | 65287 | This value specifies the FieldId of the Threshold2Date system field.
sfThreshold3 | 65288 | This value specifies the FieldId of the Threshold3Date system field.
sfThresholdFired | 65289 | This value specifies the FieldId of the ThresholdFired system field.


IsSearchable property (FieldDefinition)

property IsSearchable

Property type

A Boolean value.

Syntax

object.IsSearchable [= value]

The IsSearchable property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type FieldDefinition.
value | A Boolean value.


Assembly property (Form)

property Assembly

Property type

A String value.

Syntax

object.Assembly [= value]

The Assembly property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Form.
value | A String value.


Class property (Form)

property Class

Property type

A String value.

Syntax

object.Class [= value]

The Class property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Form.
value | A String value.


Persist method

method Persist

Return Type

A String value.

Return Type

A Boolean value.

Syntax

object.Persist

The Persist method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Package.


Restore method

method Restore

Return Type

A Boolean value.

Syntax

object.Restore(newVal As String)

The Restore method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Packages.
newVal | String


UserToken property (Packages)

property UserToken

Property type

A No Return Value value.

Syntax

object.UserToken(rhs As _UserToken) [= value]

The UserToken property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Packages.
value | A No Return Value value.


UserToken property (Processes)

property UserToken

Property type

A No Return Value value.

Syntax

object.UserToken(rhs As _UserToken) [= value]

The UserToken property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Processes.
value | A No Return Value value.


_Persist method

method _Persist

Return Type

A Variant value.

Return Type

A Boolean value.

Syntax

object._Persist

The _Persist method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type ProfileCriteria.


_Restore method

method _Restore

Return Type

A Boolean value.

Syntax

object._Restore(Stream As Variant, UserToken As _UserToken)

The _Restore method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type ProfileCriteria.
Stream | Variant
UserToken | _UserToken


AllowSubProfiles property (ProfileCriteria)

property AllowSubProfiles

Property type

A Boolean value.

Syntax

object.AllowSubProfiles [= value]

The AllowSubProfiles property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type ProfileCriteria.
value | A Boolean value.


PromptCriteria Property

PromptCriteria Property (ProfileCriteria)

Represents the prompt criteria associated with the ProfileCriteria object.

Settings and Return Values

Returns an object reference evaluating to a PromptCriteria object.

Remarks

This property is read-only


UserToken property (ProfileCriteria)

property UserToken

Property type

A No Return Value value.

Syntax

object.UserToken(rhs As _UserToken) [= value]

The UserToken property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type ProfileCriteria.
value | A No Return Value value.


UserToken property (Profiles)

property UserToken

Property type

A No Return Value value.

Syntax

object.UserToken(rhs As _UserToken) [= value]

The UserToken property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Profiles.
value | A No Return Value value.


RemoveItem Method

RemoveItem Method (PromptCriterion)

Removes the specified PromptCriterion from the collection.

Return Type

None.

Syntax

object.RemoveItem(Index As Long)

Parameters

Part | Description
Index | The index of the object to be removed.

See Also

ProfileCriteria


FindByName method

method FindByName

Return Type

A _Event value.

Return Type

A Boolean value.

Syntax

object.FindByName(ProcessName As String, EventName As String)

The FindByName method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type StartEvents.
ProcessName | String
EventName | String


UserToken property (Templates)

property UserToken

Property type

A No Return Value value.

Syntax

object.UserToken(rhs As _UserToken) [= value]

The UserToken property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type Templates.
value | A No Return Value value.


UserDomain Property

UserDomain Property (WFUser)

This property allows you to obtain the domain of the WFUser , whether it is local or domain security.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


UserToken property (WFUsers)

property UserToken

Property type

A No Return Value value.

Syntax

object.UserToken(rhs As _UserToken) [= value]

The UserToken property syntax has these parts:

Part | Description
object | An expression evaluating to an object of type WFUsers.
value | A No Return Value value.