Stellent.IBPM.Client

Objects
ToolNotifier
MessageDictionary


ToolNotifier

ToolNotifier Object

The ToolNotifier object is the object that the custom tool component must interact with so that the IBPM Client Framework can recognize it as a client tool.

Remarks

All interaction requests to and from the IBPM Client Framework are done through the ToolNotifier object. The ToolNotifier object should be created at time of the custom tool creation and have a lifespan that is equivalent to the that of the custom tool.


AddMessageToListener Method

AddMessageToListener Method (ToolNotifier)

The AddMessageToListener method is used to register as a message handler for the message ids. The ToolNotifier object will fire a MessageReceived event when a message matching the id is received from the IBPM Client Framework.

Return Type

None.

Syntax

object.AddMessageToListener(ByVal messageId As String)

Parameters

Part | Description
messageId | String representation of a GUID identifier for the message


SendClientMessage Method

SendClientMessage Method (ToolNotifier)

The SendClientMessage method is used to interact with other IBPM Client Framework tools via messaging.

Return Type

Returns a Stellent.IBPM.Client.MessageDictionary object that represents the reply to the message sent.

Syntax

value = object.SendClientMessage(ByVal messageId As String, ByVal request As Stellent.IBPM.Client.MessageDictionary)

Parameters

Part | Description
messageId | String representation of the GUID that is the message identifier for the message being sent.
request | A Stellent.IBPM.Client.MessageDictionary object which contains the key/value pairs for the message request.


ShowTool Method

ShowTool Method (ToolNotifier)

The ShowTool method is used to change the active state of a custom tool to activated in the IBPM Client Framework outside of a ShowingTool event.

Return Type

None.

Syntax

object.ShowTool()


HideTool Method

HideTool Method (ToolNotifier)

The HideTool method is used to change the active state of a custom tool to deactivated in the IBPM Client Framework outside of a HidingTool event.

Return Type

None.

Syntax

object.HideTool()


UserToken Property (ToolNotifier)

This is the usertoken of the user logged into the IBPM Client Framework and can be used to interact with other IBPM SDK objects. It is available once the ToolNotifier object has been created.

Return Values

Returns a Stellent.IBPM.Interop.Common.UserToken object.

Syntax

value = object.UserToken

Remarks

This property is read-only


StatusBarText Property (ToolNotifier)

The StatusBarText property is used to set the text in the status bar of the IBPM Client Framework. To clear the text of the status bar populate with an empty string.

Settings Values

Sets the string value to be displayed on the status bar of the IBPM Client Framework.

Syntax

object.StatusBarText = value

Remarks

This property is write-only.


ToolBusy Property (ToolNotifier)

The ToolBusy property is used to turn on/off the IBPM Client Framework busy indicator, the spinning Stellent ‘S’ in the top right hand corner of the client.

Settings Values

Sets a Boolean value.

  • True - Turn on the busy status indicator
  • False - Turn off the busy status indicator

Syntax

object.ToolBusy = value

Remarks

This property is write-only.


ShowingTool Event

ShowingTool Event (ToolNotifier)

This event is fired when the IBPM Client Framework is requesting the custom tool activate. If the event is not subscribed to by the custom tool, the IBPM Client Framework will be notified the request to activate was accepted and the custom tool will be shown.

Syntax

object.ShowingTool(ByVal sender As Object, ByVal e As Stellent.IBPM.Client.ToolNotifier.ShowingToolEventArgs)

Parameters

Part | Description
e | The ShowingToolEventArgs that contains the reason for the request as well as the custom tool's response to the event firing.


HidingTool Event

HidingTool Event (ToolNotifier)

This event is fired when the IBPM Client Framework is requesting the custom tool deactivate. If the event is not subscribed to by the custom tool, the IBPM Client Framework will be notified the request to deactivate was accepted and the custom tool will be hidden.

Syntax

object.HidingTool(ByVal sender As Object, ByVal e As Stellent.IBPM.Client.ToolNotifier.HidingToolEventArgs)

Parameters

Part | Description
e | The HidingToolEventArgs that contains the reason for the request as well as the custom tool's response to the event firing.


MessageReceived Event

MessageReceived Event (ToolNotifier)

This event is fired in response to message being received that the custom tool has requested be listened for. The event must be subscribed for, or all messages received will be marked as unhandled.

Syntax

object.MessageReceived(ByVal sender As Object, ByVal e As Stellent.IBPM.Client.ToolNotifier.MessageEventArgs)

Parameters

Part | Description
e | The MessageEventArgs for interacting with the received message.


ToolNotifier.ShowingToolEventArgs

ToolNotifier.ShowingToolEventArgsObject

The ShowingToolEventArgs are passed when the ToolNotifier.ShowingTool event is fired.

Remarks

The ShowingToolEventArgs can be used to customize a Custom Tool's interaction with the IBPM Client Framework.


ShowToolSource Property (ToolNotifier.ShowingToolEventArgs)

The ShowToolSource is an identifier for why the ToolNotifier.ShowingTool event was fired.

Settings and Return Values

Returns a Stellent.IBPM.Client.ToolNotifier.ShowingToolEventArgs.Source object.

  • This represents the reason for the ShowingTool event request.

Syntax

value = object.ShowToolSource

Remarks

This property is read-only


Action Property (ToolNotifier.ShowingToolEventArgs)

The Action property is used to let the IBPM Client Framework know what state the Custom Tool would like to be in after the ShowingTool event.

Settings and Return Values

Returns a Stellent.IBPM.Client.ToolNotifier.ShowAction object.

Syntax

value = object.Action


MessageId Property (ToolNotifier.ShowingToolEventArgs)

The MessageId property is a string representation of a GUID. The value is only populated if the the ShowingTool event was fired due to a message being received by an inactive tool. The property can be used to determine whether the tools state should change prior to receiving the message.

Settings and Return Values

Returns a String value.

Syntax

value = object.MessageId

Remarks

This property is read-only


ShowingToolEventArgs.Source Enumeration

Members

Constant | Value | Description
External | 32 | An external source has requested the tool activate.
Menu | 1 | A user has clicked on the tool in the client View drop down menu.
MessageHandler | 16 | A message is being sent to an inactive tool.


ToolNotifier.HidingToolEventArgs

ToolNotifier.HidingToolEventArgs Object

The HidingToolEventArgs are passed when the ToolNotifier.HidingTool event is fired.

Remarks

The HidingToolEventArgs can be used to customize a Custom Tool's interaction with the IBPM Client Framework.


HideToolSource Property (ToolNotifier.HidingToolEventArgs)

The HideToolSource is an identifier for why the ToolNotifier.HidingTool event was fired.

Return Values

Returns a Stellent.IBPM.Client.ToolNotifier.HidingToolEventArgs.Source object.

  • This represents the reason for the HidingTool event request.

Syntax

value = object.HideToolSource

Remarks

This property is read-only


HideTool Property (ToolNotifier.HidingToolEventArgs)

The HideTool property is used by the CustomTool to either accept or reject the IBPM Client Framework's request to deactivate the tool.

Settings and Return Values

Returns a Boolean value.

  • True - Accept the IBPM Client Framework request to deactivate.
  • False - Reject the IBPM Client Framework request to deactivate.

Syntax

value = object.HideTool

object.HideTool = value


HidingToolEventArgs.Source Enumeration

Members

Constant | Value | Description
Application | 4 | The IBPM Client is changing galleries or is being logged out.
Close | 2 | The IBPM Client is being shut down.
CloseTool | 256 | The close 'X' has been pressed by the user.
External | 32 | An external source has requested the tool deactivate.
ForcedLogoff | 64 | An administrator has forced the user to logout.
Menu | 1 | A user has clicked on the tool in the client View drop down menu.


ToolNotifier.MessageEventArgs

ToolNotifier.MessageEventArgs Object

The MessageEventArgs are passed when a ToolNotifier.MessageReceived event is fired.

Remarks

The MessageEventArgs can be used to customize a Custom Tool's interaction with messages sent by the IBPM Client Framework.


MessageId Property (ToolNotifier.MessageEventArgs)

The MessageId property is a string representation of a GUID that the custom tool has registered for listening.

Return Values

Returns a String value.

Syntax

value = object.MessageId

Remarks

This property is read-only


Request Property (ToolNotifier.MessageEventArgs)

The Request object is a Stellent.IBPM.Client.MessageDictionary which has the key/value pairs for the message to be processed.

Settings and Return Values

Returns a Stellent.IBPM.Client.MessageDictionary object.

Syntax

value = object.Request


Reply Property (ToolNotifier.MessageEventArgs)

The Reply object is a MessageDictionary that can be filled out to with key/value pairs to be returned to the message sender after successfully handling a message request.

Settings and Return Values

Returns a Stellent.IBPM.Client.MessageDictionary object.

Syntax

value = object.Reply


MessageHandled Property (ToolNotifier.MessageEventArgs)

MessageHandled is used to respond to the IBPM Client Framework a value to determine if the custom tool handled a particular message.

Settings and Return Values

Returns a Boolean value.

  • True - The custom tool performed all actions to satisfy the message request
  • False - The custom tool was not able to handle or completely handle the message request. This value can be used to 'chain' messages so other message handlers can work with the message request.

Syntax

value = object.MessageHandled


PostProcessMessageAction Property (ToolNotifier.MessageEventArgs)

The PostProcessMessageAction property is used to determine what actions the IBPM Client Framework should perform after the custom tool has successfully handled a message request.

Settings and Return Values

Returns a Stellent.IBPM.Client.ToolNotifier.ShowAction object.

Syntax

value = object.PostProcessMessageAction

object.PostProcessMessageAction = value


ToolNotifier.ShowAction Enumeration

Members

Constant Value Description
BringToFront | 4 | The IBPM Client Framework should activate and bring the custom tool to the foreground.
RemainAsIs | 0 | The IBPM Client Framework should leave the custom tool in its current state.
Show | 2 | The IBPM Client Framework should activate the custom tool.


MessageDictionary

MessageDictionary Object

The MessageDictionary object is a key/value pair collection used for passing messages to and from the IBPM Client Framework.


Add Method

Add Method (MessageDictionary)

The Add method is used to place key/value pairs in to the MessageDictionary collection.

Return Type

None.

Syntax

object.Add(ByVal key As String, ByVal value As Object)

Parameters

Part | Description
key | String which uniquely identifies the value object.
value | The object to be stored in the collection.


Contains Method

Contains Method (MessageDictionary)

The Contains method can be used to determine if a key\value pair exists in the MessageDictionary collection.

Return Type

Boolean

Syntax

object.Contains(ByVal key As String)

Parameters

Part | Description
key | String key being searched.


Item Method

Item Property (MessageDictionary)

The Item property will retrieve the object that corresponds with the key.

Return Type

Object.

Syntax

object.Item(ByVal key As String)

Parameters

Part | Description
key | String identifier for the object wanted from the collection


Keys Property (MessageDictionary)

The Keys property can be used to retrieve the keys in the MessageDictionary collection.

Settings and Return Values

Returns an object value.

Syntax

value = object. Keys

Remarks

This property is read-only


Values Property (MessageDictionary)

The Values property returns a collection of the value objects stored in the MessageDictionary collection.

Settings and Return Values

Returns an object value.

Syntax

value = object.Values

Remarks

This property is read-only