BPM Controls Overview

Stellent.IBPM.Interop.Process.Controls

The Stellent.IBPM.Interop.Process.Controls namespace offers a set of full-featured reusable controls. The controls can easily be embedded into a custom application to rapidly produce a fully functional BPM application. The set of controls available are, in fact, those provided in the out-of-the-box IBPM Windows client. For more information on how to use a particular control, see one of the links below.

PackageList

PackageManager

PackageViewer

MapViewer

FormViewer

ProfileManager


PackageList

PackageList Control

A control to display the contents of any Packages Profile search in a list format.

Remarks

The PackageList control provides the functionality behind the Inbox Tool, the Package Search Tool, and the WorkList Tool in the IBPM Windows Client.


PackageSearch Event

This event is fired when a Package Search operation is selected from an ActiveX Control.

Syntax

PackageSearch(Profile As Object)

Parameters

Part | Description
Profile | The Profile object that is created through the Profile Editor to define the package search.


PostComplete Event

This event is called after a package is completed.

Syntax

PostComplete(Package As Object, Handled As Boolean)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.

Remarks

This event allows the container to implement the post process after the control has performed the given operation.


PostDelete Event

This event is called after a package is deleted.

Syntax

PostDelete(Package As Object)

Parameters

Part | Description
Package | An object value which evaluates to a Package object

Remarks

This event allows the container to implement the post process after the control has performed the given operation.


PostDeleteFromProcess Event

This event is called after a package is deleted from process.

Syntax

PostDeleteFromProcess(Package As Object)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.

Remarks

This event allows the container to implement the post process after the control has performed the given operation.


PostDeleteFromQueue Event

This event is called after a package is deleted from a queue.

Syntax

PostDeleteFromQueue(Package As Object)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.

Remarks

This event allows the container to implement the post process after the control has performed the given operation.


PostHistory Event

This event is called after package package history is displayed.

Syntax

PostHistory(Package As Object)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.

Remarks

This event allows the container to implement the post process after the control has performed the given operation.


PostInsertAttachment Event

This event is called after an attachment is added to a package.

Syntax

PostInsertAttachment(Package As Object)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.

Remarks

This event allows the container to implement the post process after the control has performed the given operation.


PostJournalEntry Event

This event is called after a package comment is added.

Syntax

PostJournalEntry(Package As Object)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.

Remarks

This event allows the container to implement the post process after the control has performed the given operation.


PostLock Event

This event is called after a package is locked.

Syntax

PostLock(Package As Object)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.

Remarks

This event allows the container to implement the post process after the control has performed the given operation.


PostPlaceInFlow Event

This event is called after a package is placed in flow.

Syntax

PostPlaceInFlow(Package As Object)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.

Remarks

This event allows the container to implement the post process after the control has performed the given operation.


PostRouteAdhoc Event

This event is called after a package is Ad hoc routed.

Syntax

PostRouteAdhoc(Package As Object)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.

Remarks

This event allows the container to implement the post process after the control has performed the given operation.


PostRouteToEvent Event

This event is called after a package is Routed to an Event.

Syntax

PostRouteToEvent(Package As Object)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.

Remarks

This event allows the container to implement the post process after the control has performed the given operation.


PostRouteToUser Event

This event is called after a package is routed to another user.

Syntax

PostRouteToUser(Package As Object)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.

Remarks

This event allows the container to implement the post process after the control has performed the given operation.


PostTasks Event

This event is called after a package task dialog is called.

Syntax

PostTasks(Package As Object)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.

Remarks

This event allows the container to implement the post process after the control has performed the given operation.


PostUnlock Event

This event is called after a package is unlocked.

Syntax

PostUnlock(Package As Object)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.

Remarks

This event allows the container to implement the post process after the control has performed the given operation.


PostViewProperties Event

This event is called after package properties are displayed.

Syntax

PostViewProperties(Package As Object)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.

Remarks

This event allows the container to implement the post process after the control has performed the given operation.


PreComplete Event

This event is called before a package is completed.

Syntax

PreComplete(Package As Object, Handled As Boolean)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.
Handled | A Boolean value allowing the event handler to tell the control not to perform its default processing.

Remarks

This event allows the container to override the default behavior of the control when performing the given package operation.

To prevent the control from performing its default behavior, set the Handled parameter to True before returning.


PreDelete Event

This event is called before a package is deleted.

Syntax

PreDelete(Package As Object, Handled As Boolean)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.
Handled | A Boolean value allowing the event handler to tell the control not to perform its default processing.

Remarks

This event allows the container to override the default behavior of the control when performing the given package operation.

To prevent the control from performing its default behavior, set the Handled parameter to True before returning.


PreDeleteFromProcess Event

This event is called before a package is deleted from process.

Syntax

PreDeleteFromProcess(Package As Object, Handled As Boolean)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.
Handled | A Boolean value allowing the event handler to tell the control not to perform its default processing.

Remarks

This event allows the container to override the default behavior of the control when performing the given package operation.

To prevent the control from performing its default behavior, set the Handled parameter to True before returning.


PreDeleteFromQueue Event

This event is called before a package is deleted from queue.

Syntax

PreDeleteFromQueue(Package As Object, Handled As Boolean)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.
Handled | A Boolean value allowing the event handler to tell the control not to perform its default processing.

Remarks

This event allows the container to override the default behavior of the control when performing the given package operation.

To prevent the control from performing its default behavior, set the Handled parameter to True before returning.


PreHistory Event

This event is called before a package history is displayed.

Syntax

PreHistory(Package As Object, Handled As Boolean)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.
Handled | A Boolean value allowing the event handler to tell the control not to perform its default processing.

Remarks

This event allows the container to override the default behavior of the control when performing the given package operation.

To prevent the control from performing its default behavior, set the Handled parameter to True before returning.


PreInsertAttachment Event

This event is called before an attachment is added to a package.

Syntax

PreInsertAttachment(Package As Object, Handled As Boolean)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.
Handled | A Boolean value allowing the event handler to tell the control not to perform its default processing.

Remarks

This event allows the container to override the default behavior of the control when performing the given package operation.

To prevent the control from performing its default behavior, set the Handled parameter to True before returning.


PreJournalEntry Event

This event is called before a package comment is added.

Syntax

PreJournalEntry(Package As Object, Handled As Boolean)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.
Handled | A Boolean value allowing the event handler to tell the control not to perform its default processing.

Remarks

This event allows the container to override the default behavior of the control when performing the given package operation.

To prevent the control from performing its default behavior, set the Handled parameter to True before returning.


PreLock Event

This event is called before a package is locked.

Syntax

PreLock(Package As Object, Handled As Boolean)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.
Handled | A Boolean value allowing the event handler to tell the control not to perform its default processing.

Remarks

This event allows the container to override the default behavior of the control when performing the given package operation.

To prevent the control from performing its default behavior, set the Handled parameter to True before returning.


PrePlaceInFlow Event

This event is called before a package is placed in flow.

Syntax

PrePlaceInFlow(Package As Object, Handled As Boolean)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.
Handled | A Boolean value allowing the event handler to tell the control not to perform its default processing.

Remarks

This event allows the container to override the default behavior of the control when performing the given package operation.

To prevent the control from performing its default behavior, set the Handled parameter to True before returning.


PreRouteAdhoc Event

This event is called before a package is Ad hoc routed.

Syntax

PreRouteAdhoc(Package As Object, Handled As Boolean)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.
Handled | A Boolean value allowing the event handler to tell the control not to perform its default processing.

Remarks

This event allows the container to override the default behavior of the control when performing the given package operation.

To prevent the control from performing its default behavior, set the Handled parameter to True before returning.


PreRouteToEvent Event

This event is called before a package is Routed to Event.

Syntax

PreRouteToEvent(Package As Object, Handled As Boolean)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.
Handled | A Boolean value allowing the event handler to tell the control not to perform its default processing.

Remarks

This event allows the container to override the default behavior of the control when performing the given package operation.

To prevent the control from performing its default behavior, set the Handled parameter to True before returning.


PreRouteToUser Event

This event is called before a package is routed to user.

Syntax

PreRouteToUser(Package As Object, Handled As Boolean)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.
Handled | A Boolean value allowing the event handler to tell the control not to perform its default processing.

Remarks

This event allows the container to override the default behavior of the control when performing the given package operation.

To prevent the control from performing its default behavior, set the Handled parameter to True before returning.


PreTasks Event

This event is called before a package task dialog is called.

Syntax

PreTasks(Package As Object, Handled As Boolean)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.
Handled | A Boolean value allowing the event handler to tell the control not to perform its default processing.

Remarks

This event allows the container to override the default behavior of the control when performing the given package operation.

To prevent the control from performing its default behavior, set the Handled parameter to True before returning.


PreUnlock Event

This event is called before a package is unlocked.

Syntax

PreUnlock(Package As Object, Handled As Boolean)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.
Handled | A Boolean value allowing the event handler to tell the control not to perform its default processing.

Remarks

This event allows the container to override the default behavior of the control when performing the given package operation.

To prevent the control from performing its default behavior, set the Handled parameter to True before returning.


PreViewProperties Event

This event is called before the package properties are displayed.

Syntax

PreViewProperties(Package As Object, Handled As Boolean)

Parameters

Part | Description
Package | An object value which evaluates to a Package object.
Handled | A Boolean value allowing the event handler to tell the control not to perform its default processing.

Remarks

This event allows the container to override the default behavior of the control when performing the given package operation.

To prevent the control from performing its default behavior, set the Handled parameter to True before returning.


ViewAttachment Event

This method is called when the attachment is selected to be displayed.

Syntax

ViewAttachment(Package As Object, Attachment As Object, Verb As Object, Handled As Boolean)

Parameters

Part | Description
Package | The Package object for which the attachment is a member of.
Attachment | The Attachment object selected.
Verb | The Verb object which is the action selected to be performed on the attachment.
Handled | This parameter specifies whether the default action should be performed or not.


ViewForm Event

This event is called when the form is selected to be viewed.

Syntax

ViewForm(Package As Object, Form As Object)

Parameters

Part | Description
Package | The package object for which the form is a member of.
Form | The form object for the form that was selected.


ViewMap Event

This event is called when the View Map option is selected.

Syntax

ViewMap(Map As Object)

Parameters

Part | Description
Map | The map object that was selected to be viewed.


ViewPackage Event

This event is called when the package is selected to be viewed.

Syntax

ViewPackage(Package As Object)

Parameters

Part | Description
Package | The package object that was selected.


Refresh Method

RefreshContext Method (PackageList)

This method refreshes the PackageList control.

Syntax

object.RefreshContext


Profile Property (PackageList)

This property contains the profile that filters the number of packages seen in the PackageList control.

Settings and Return Values

Sets and returns an Object value.


ProfileOptions Property (PackageList)

This property contains a value that determines what kind of profiles can be seen by the PackageList control.

Settings and Return Values

Sets a ProfileOption enumeration to a Boolean value to limit what can be seen in the PackageList control.

Remarks

True - The PackageList control has access to this type of profile.
False - The PackageList control does not have access to this type of profile.


RegistryKey Property (PackageList)

This property contains a GUID of where PackageList preferences are saved.

Settings Values

Sets a String value.


Title Property (PackageList)

This property contains the title of the Package List control.

Settings and Return Values

Sets and Returns a String value.


UserToken Property (PackageList)

UserToken Property (Controls)

The UserToken to user for connecting the control to any required Process SDK™ Toolkit objects.

Settings and Return Values

Sets an object reference evaluating to a UserToken object.

Remarks

In general, the UserToken must be set on the control before any other operations are performed.


otProfileOption Enumeration

ProfileOption Enumeration

Members

Constant | Value | Description
poCustom_AdHoc | 4 | This type allows you to customize the control to run an Adhoc profile.
poCustom_Inbox | 1 | This type allows you to customize the control to run an Inbox profile.
poCustom_Named | 2 | This type allows you to customize the control to run a Named profile.
poCustom_Queue | 8 | This type allows you to customize the control to run a Queue profile.
poExtProfile | 128 | This type allows you to have a control that only runs a single profile.
poInbox | 64 | This type specifies that you wish to use the stock Inbox options. The control will behave identically to the Inbox Tool within the Windows client.
poPkgSrch | 16 | This type specifies that you wish to use the stock Package Search options. The control will behave identically to the Package Search Tool within the Windows client.
poWorkList | 32 | This type specifies that you wish to use the stock WorkList options. The control will behave identically to the WorkList Tool within the Windows client.


PackageManager

PackageManager Control

A control to display packages in specific processes and queues, presenting them in a tree based format.

Remarks

The PackageManager control provides the functionality behind the Package Manager Tool in the IBPM Windows Client.


Refresh Method

RefreshContext Method (PackageManager)

This method refreshes the PackageManager control.

Syntax

object.RefreshContext


PackageViewer

PackageViewer Control

A control to display and manipulate a specific package.

Remarks

The PackageViewer control provides the functionality behind the Package View Tool in the IBPM Windows Client.


Package Property (PackageViewer)

This property contains the Package object of the package currently loaded into the PackageViewer control.

Settings and Return Values

Sets or Returns an Object value.


PkgRecId Property (PackageViewer)

This property contains the package record id of the package currently loaded into the PackageViewer control.

Settings and Return Values

Set or Returns an Long value.


MapViewer

MapViewer Control

A control to display BPM Maps.

Remarks

The MapViewer control provides the functionality behind the Map Viewer Tool in the IBPM Windows Client.

Because the MapViewer control embeds the Microsoft Browser Control, Microsoft Explorer 4.0 or later must be install on the machine for the MapViewer control to function properly.


Refresh Method

RefreshContext Method (MapViewer)

Fills an Maps collection with the Map objects for a specific process.

Syntax

object.RefreshContext


ProcessID Property (MapViewer)

This property contains the unique Process Id for a map being viewed in MapViewer.

Settings and Return Values

Sets and returns a Long value.


FormViewer

FormViewer Control

A control to display Visual Studio 6 Process OLE Forms.

Remarks

The FormViewer control will display a given Form Id for a Package. The Control handles displaying the form and positioning it within a page of the tab control. The Package title for the form on any given tab is displayed as the tab title. Any one package can only display one form at any time although forms from multiple packages can be displayed on separate tabs simultaneously. If a different is requested for form for a package which is a already display, the new form will replace the old one on that packages tab.

The control supports two options configurable via right click menu.

Single Tab Mode | If this option is checked, all package forms requested will always replace the first tab page. If it is not checked, the separate packages will create separate tab pages
Close on Empty | If this option is checked, the Close event is fired to the control container when the last form is closed. This allows the container to complete remove the display of the FormViewer control. If it is not checked, no event is fired.


Close Event

Reserved for future use


AddForm Method

AddForm Method (FormViewer)

This method adds a form to the FormViewer control.

Return Type

A Long value.

Syntax

object.AddForm(pForm As Object, pPackage As Object)

Parameters

Part | Description
pForm | The Form object to be opened into the Form Viewer control.
pPackage | The Package object for which the Form belongs to.


AddFormById Method

AddFormById Method (FormViewer)

This method adds a form to the FormViewer control using the form ID.

Return Type

A Long value.

Syntax

object.AddFormById(PkgRecId As Long, FormId As Long)

Parameters

Part | Description
PkgRecId | Long
FormId | Long


RemoveAll Method

RemoveAll Method (FormViewer)

This method removes all forms from the FormViewer control.

Syntax

object.RemoveAll


RemoveForm Method

RemoveForm Method (FormViewer)

This method removes the form from the FormViewer control.

Syntax

object.RemoveForm(Item As Long)

Parameters

Part | Description
Item | Long


SendCustomData Method

SendCustomData Method (FormViewer)

Reserved for future use.


FormCount Property (FormViewer)

This property contains the number of forms currently loaded into the FormViewer control.

Settings and Return Values

Returns a Long value.

Remarks

The property is read-only.


FormPkgRecId Property (FormViewer)

This property contains the unique Package Record Id for a form in the FormViewer control.

Settings and Return Values

Sets or returns a Long value.


ProfileManager

ProfileManager Control

A control for creating, modifying, and deleting named profiles.

Remarks

The ProfileManager control provides the functionality behind the Profile Manager Tool in the IBPM Windows Client.


DoModal Method

This method will display the dialog.

Return Type

A otDlgReturn value.

Syntax

object.DoModal


Refresh Method

RefreshContext Method (ProfileManager)

This method refreshes the PackageManager control.

Syntax

object.RefreshContext


otDlgReturn Enumeration

Members

Constant | Value
otDlgReturn_Ok | 1
otDlgReturn_Cancel | 2
otDlgReturn_Abort | 3 (not currently used)


ProfileEditor

ProfileEditor Object

This dialog allows you to define a profile or a package search.


ProfileCriteria Property (ProfileEditor)

This property contains the ProfileCriteria object that is needed to populate the ProfileEditor control.

Settings and Return Values

Sets or returns an Object value.