Stellent.IBPM.Interop.Process.Dialogs

The Stellent.IBPM.Interop.Process.Dialogs namespace offers a set of standard re-useable modal interface dialog for performing routine Toolkit functions. They all conform to the same basic model. One or more properties supply the input information for the dialog. The dialog will use that input to either present standard information about that input (i.e. properties) or to present a selection list.( For instance, the AttachmentTypeDialog requires a Template to specify the package template definitions which contains the attachment types to be listed.) In some instances, the input is simply a connected UserToken (see Database.Connect), which allows the dialog to instantiate what ever Process Toolkit Objects it needs to display.

Once the input properties have been set, the components DoModal function is called to display the dialog. Typically, the dialogs offer an OK button to acknowledge a particular selection or to close a properties type dialog. Selection dialogs will also offer a Cancel button to close the dialog without making a selection. In either case, the DoModal's return value will be an indicate which button was used. The return will either be DlgReturn.drOk or DlgReturn.drCancel (from the DlgReturn enumeration).

For selection based dialogs, if the value returned was DlgReturn.drOk, there will be one or more properties from which the selection made by the use can be retrieved. For DlgReturn.drCancel, the "output" properties are undefined.

For more information about a particular dialog, what its input and output requirements are, and what types of information it displays, see one of the links below.

Process SDK™ Dialogs Toolkit Objects Summary

AdhocRouteDialog
AttachmentDialog
AttachmentTypeDialog
ConfirmationDialog
DatabaseDialog
DecisionDialog
EventSelectDialog
JournalEntryDialog
LoginDialog
PackageHistoryDialog
PackagePropertyDialog
ProcessPropertyDialog
PackageTasksDialog
ProfileEditor
QueuePropertyDialog
QueueSelectDialog
StartEventDialog


AdhocRouteDialog

AdhocRouteDialog Object

Presents a selection dialog allowing the user to select an Event from list of available Ad hoc Route to Events.

Remarks

The Process property must be set before calling DoModal. After the user clicks OK, the Event property contains the selected event. If the user clicks Cancel, the value of the Event property is undefined. This dialog also presents entry fields for Priority and Comments. These two properties can be set prior to calling DoModal to have the dialog present default values. When the user clicks OK, these values can be read to retrieve the new values, if desired.

The information obtained from the dialog can be used to fill out the parameters for the Package.RouteAdhoc method.


DoModal Method

This method will display the dialog.

Return Type

A DlgReturn value.

Syntax

object.DoModal


Comments Property (AdhocRouteDialog)

Corresponds to the Comments edit field on the dialog.

Settings and Return Values

Sets and returns a string value corresponding to the Comments edit field on the dialog.

Remarks

The property can be set prior to calling DoModal to fill in a default value for the field and can be read after the user clicks OK to receive an updated value.


Event Property (AdhocRouteDialog)

The Event selected by the user.

Settings and Return Values

Returns an object reference evaluating to an Event object.

Remarks

This property is only valid after calling DoModal and after the user has clicked OK in the dialog.

The property is read-only.


Priority Property (AdhocRouteDialog)

Corresponds to the Priority edit field on the dialog.

Settings and Return Values

Sets and returns a Long value corresponding to the Priority edit field on the dialog.

Remarks

The property can be set prior to calling DoModal to fill in a default value for the field and can be read after the user clicks OK to receive an updated value.


Process Property (AdhocRouteDialog)

The Process for which Ad hoc route events will be presented for user selection.

Settings and Return Values

Sets an Object reference evaluating to a Process object.

Remarks

This property must be set before calling DoModal.

The property is write-only.


AttachmentDialog

AttachmentDialog Object

Presents a customizable dialog for selecting and inserting a Package Attachment.

Remarks

The Package property must be set prior to calling DoModal.

The Attachment dialog will search a specific component category CATID (87BCF8D0-F5E7-11D3-9E60-00C04F097031) for components that support the IAtmtSelectDlg interface. If more than one is found, a selection list will be presented, listed by IAtmtSelectDlg.Title, allowing the user to choose which dialog to present. If only one component is registered in the CATID, its IAtmtSelectDlg.DoModal will be called directly without presenting a list.

The IAtmtSelectDlg component is responsible for completing the Attachment insert before returning from DoModal.


Package Property (AttachmentDialog)

The Package to which the Attachment should be added.

Settings and Return Values

Sets an Object value evaluating to a Package object.

Remarks

This property must be set before calling DoModal.

The property is write-only.


AttachmentTypeDialog

AttachmentTypeDialog Object

Presents a selection dialog allowing the user to select an AttachmentType from a given Template.

Remarks

The Template property must be set before calling DoModal. After the user click OK, the AttachmentType property contains the selected AttachmentType. If the user clicks Cancel, the value of the AttachmentType property is undefined.

The information obtained from the dialog can be used to set the Attachment.AttachmentType property.


AttachmentType Property (AttachmentTypeDialog)

The AttachmentType selected by the user.

Settings and Return Values

Returns an object reference evaluating to an AttachmentType object.

Remarks

This property is only valid after calling DoModal and after the user has clicked OK in the dialog.

The property is read-only.


Template Property (AttachmentTypeDialog)

The Template for which attachment types will be presented for user selection.

Settings and Return Values

Sets an object reference evaluating to a Template object.

Remarks

This property must be set before calling DoModal.

The property is write-only.


ConfirmationDialog

ConfirmationDialog Object

Present a number of common confirmations pertaining to Package operations.

Remarks

The ConfirmationType must be specified before calling DoModal.

The dialog coheres to the IBPM Security Display Confirmation setting. If this setting is enabled, then DoModal will display the actual dialog. If confirmations are disabled, the DoModal will return DlgReturn.drOk (see DlgReturn) immediately.


ConfirmationType Property (ConfirmationDialog)

Specifies which confirmation text the dialog will display.

Settings and Return Values

Sets an ConfirmationType value.

Remarks

The property is write-only.


UserToken Property (Dialog)

The UserToken to user for connecting the dialog to any required Process SDK™ Toolkit objects.

Settings and Return Values

Sets an object reference evaluating to a UserToken object.

Remarks

This property must be set before calling DoModal. It must be set with a UserToken that has been properly connected to an BPM Database.

The property is write-only.


DatabaseDialog

DatabaseDialog Object

Presents a selection dialog allowing the user to select an Database from the Databases defined on the Process Broker machine(s).

Remarks

After the user click OK, the Database property contains the selection. If the user clicks Cancel, the value of the Database property is undefined.

The dialog is typically used to prompt the user with a list of databases to which they can connect and then call Database.Connect. This is particularly useful in situations where a UserToken was obtained previously. (Use the LoginDialog to retrieve a UserToken and connect to an BPM database in a single step.)


SetDBAccessFilter Method

Sets the filter of database names to be displayed in the dialog.

Syntax

object.SetDBAccessFilter(bstrDBNames As String, lNumDB As Long)

Parameters

Part | Description
bstrDBNames | A StringArray of database names.
lNumDB | A Long value indicating how name names are in bstrDBNames.

Remarks

If this method is called with a non-blank list of database names, only those Database objects from a Databases collection which match at least one item in bstrDBNames will be displayed in the dialog. To have any effect, the method must be called before DoModal

If the list is empty or the method is not called before DoModal, then all databases in the Databasescollection will be displayed.


Database Property (DatabaseDialog)

The Database selected by the user.

Settings and Return Values

Returns an object reference evaluating to an Database object.

Remarks

This property is only valid after calling DoModal and after the user has clicked OK in the dialog.

The property is read-only.


DecisionDialog

DecisionDialog Object

Presents a selection dialog allowing the user to select a DecisionChoice for a given Queue.

Remarks

The Queue property must be set before calling DoModal. After the user click OK, the DecisionChoice property contains the selection. If the user clicks Cancel, the value of the DecisionChoice property is undefined.

The information obtained from the dialog can be used a parameter to Package.Complete.


DecisionChoice Property (DecisionDialog)

The DecisionChoice selected by the user.

Settings and Return Values

Returns an object reference evaluating to an DecisionChoice object.

Remarks

This property is only valid after calling DoModal and after the user has clicked OK in the dialog.

The property is read-only.


Queue Property (DecisionDialog)

The Queue for which decision choices will be presented for user selection.

Settings and Return Values

Sets an object reference evaluating to a Queue object.

Remarks

This property must be set before calling DoModal.

The property is write-only.


EventSelectDialog

EventSelectDialog Object

Presents a selection dialog allowing the user to select an Event for a given Process.

Remarks

After the user click OK, the Event property contains the selection.


LimitByTemplate Method

Receives a Template object to limit the available events and processes displayed in the dialog to which the template has been defined in BPM Builder.

Syntax

object.LimitByTemplate(Template As Object)

Remarks

This property is write-only and must be set before calling DoModal.


Event Property (EventSelectDialog)

The Event selected by the user..

Settings and Return Values

Returns an Object reference evaluating to an Event object.

Remarks

This property is only valid after calling DoModal and after the user has clicked OK in the dialog.

The property is read-only.


InitialProcessId Property (EventSelectDialog)

Defaults the displayed events, to events which belong to the Process with this process id, in the EventSelectDialog.

Settings

A Long value that represents a valid process id.

Remarks

This property is write-only. To default the value it must be called before DoModal.


JournalEntryDialog

JournalEntryDialog Object

Presents a dialog to add a package comment to a given Package.

Remarks

The Package property must be set before calling DoModal. Once the user clicks OK, the dialog adds the comment to the package. If the user clicks Cancel, any entered text is discarded.


Text Property (JournalEntryDialog)

The textual information entered as a comment into the package history.

Settings and Return Values

Returns a String value.

Remarks

The property is read-only.


LoginDialog

LoginDialog Object

This dialog allows a user to login and obtain a UserToken from the IBPM System.

Remarks

In order for a successful login the Process Broker must be running.


AllowDatabaseChange Property (LoginDialog)

Sets whether a user can change the selected database on the LoginDialog.

Settings and Return Values

A Boolean value.

Remarks

The property must be set before calling DoModal.


Database Property (LoginDialog)

Returns a Database object that is representative of the Database selected in the LoginDialog.

Settings and Return Values

Returns a Database object

Remarks

The property is only valid after calling DoModal, if the user has selected OK.

This property is read only.


DatabaseName Property (LoginDialog)

Allows a Database to be defaulted for the LoginDialog.

Settings and Return Values

A string value.

Remarks

To default the value the property must be set before calling DoModal.

The database name supplied must match an BPM database supported by the Process Process Broker, or it will be ignored.

This property is write only.


Password Property (LoginDialog)

Allows a password to be defaulted for the LoginDialog.

Settings and Return Values

A string value.

Remarks

To default the value the property must be set before calling DoModal.

This property is write only.


UserLogin Property (LoginDialog)

This property is used to set and retrieve the User Id used to login.

Settings and Return Values

A string value.

Remarks

To default the value the property must be set before calling DoModal.


UserToken Property (LoginDialog)

If a login is successful this property will contain a valid UserToken.

Settings and Return Values

Returns an Object reference which resolves to an UserToken.

Remarks

The UserToken is the sole means for providing user authentication within the Process SDK Object Model. Moreover, it is the mechanism used to connect the Process SDK components to an BPM database. Once a UserToken is obtained (from the User.Login method), it is connected to an BPM database by creating a Databases collection, calling Databases.Refresh, finding the desired Database object in the collection, and passing the UserToken to Database.Connect. From then on, that UserToken is considered to be connected and all Process SDK objects and collections activated by the UserToken (inheriting the UserToken from a parent object) will be directed to the chosen BPM database.

All objects which are not derived from a parent objects within the model must have their UserToken property set before call any methods or accessing property values.


PackageHistoryDialog

PackageHistoryDialog Object

Presents and dialog displaying the history for a given Package.

Remarks

The Package property must be set before calling DoModal. The dialog is a read-only view of the package history.


Package Property (PackageHistoryDialog)

The Package for which the dialog will display history.

Settings and Return Values

Sets an Object reference evaluating to a Package object.

Remarks

This property must be set before calling DoModal.

The property is write-only.


PackagePropertyDialog

PackagePropertyDialog Object

Presents a dialog displaying the standard properties for a given Package.

Remarks

The Package property must be set before calling DoModal. Administrative users can see the Fields tab and are granted permission to modify the Priority, Due Date, and Threshold Dates. Users that do not have the 'View Fields' security preference will not see any fields and see the Priority, Due Date, and Threshold Dates as read-only.


Package Property (PackagePropertyDialog)

The Package for which the dialog will display properties.

Settings and Return Values

Sets an Object reference evaluating to a Package object.

Remarks

This property must be set before calling DoModal.

The property is write-only.


PackageTasksDialog

PackageTasksDialog Object

Presents a standard dialog displaying the Tasks for a given Package.

Remarks

The Package property must be set before calling DoModal. The dialog presents the Tasks' status information and offers buttons for Select, Complete, and Undo.


Package Property (PackageTasksDialog)

The Package for which the dialog will display tasks.

Settings and Return Values

Sets an Object reference evaluating to a Package object.

Remarks

This property must be set before calling DoModal.

The property is write-only.


ProcessPropertyDialog

ProcessPropertyDialog Object

Presents a standard dialog displaying the properties for a given Process.

Remarks

The Process property must be set before calling DoModal.


Process Property (ProcessPropertyDialog)

The Process for which the dialog will display properties.

Settings and Return Values

Sets an Object reference evaluating to a Process object.

Remarks

This property must be set before calling DoModal.

The property is write-only.


ProfileEditor

ProfileEditor Object

This dialog allows you to define a profile or a package search.


ProfileCriteria Property (ProfileEditor)

This property contains the ProfileCriteria object that is needed to populate the ProfileEditor control.

Settings and Return Values

Sets or returns an Object value.


ProfileSelectDialog Object

Presents a selection dialog allowing the user to select a saved Profile.

Remarks

After the user click OK, the Profile property contains the selection. The main purpose of the ProfileSelectDialog is to prompt users for a Profile to define which packages they want returned.


Profile Property (ProfileSelectDialog)

Retrieves the Profile object selected by a user.

Settings and Return Values

A reference to a Profile object.

Remarks

This property is only valid after calling DoModal and after the user has clicked OK in the dialog.

The Profile object is used to determine which Packages should be returned to the user.

The property is read-only.


PromptDialog Object

This dialog allows you to enter prompted information for a profile defined with PromptCriteria.


Profile Property

Profile Property (PromptDialog)

This property contains the Profile object that has prompted information to be entered by the user.

Settings and Return Values

Sets a Profile object.

Remarks

This property is write-only.


QueuePropertyDialog

QueuePropertyDialog Object

Presents a standard dialog displaying the properties for a given Queue.

Remarks

The Queue property must be set before calling DoModal.


Queue Property (QueuePropertyDialog)

The Queue for which the dialog will display properties.

Settings and Return Values

Sets an Object reference evaluating to a Queue object.

Remarks

This property must be set before calling DoModal.

The property is write-only.


QueueSelectDialog

QueueSelectDialog Object

Presents a selection dialog allowing the user to select a Queue for a given Process.

Remarks

After the user click OK, the Queue property contains the selection. The main purpose of the QueueSelectDialog is to help in defining an adhoc queue specific Profile.


LockFirst Property (QueueSelectDialog)

Sets or retrieves the state of the Lock First checkbox on the QueueSelectDialog.

Settings and Return Values

A Boolean value.

Remarks

To default the value, the property must be set before calling QueueSelectDialog.DoModal. The setting will only be visible if QueueSelectDialog.ShowProfileSwitches property is True. The main purpose of this value is to help define a Profile object, by stating return and lock the first package that matches.


Process Property (QueueSelectDialog)

By setting this property with a Process object the QueueSelectDialog will default the Process selection dropdown to this Process displaying the available Queues.

Settings and Return Values

A reference to a Process object.

Remarks

This property is write only. The property must be set before calling QueueSelectDialog.DoModal.


Queue Property (QueueSelectDialog)

Retrieves the Queue object selected by a user.

Settings and Return Values

A reference to a Queue object

Remarks

This property is only valid after calling DoModal and after the user has clicked OK in the dialog.

The Queue object is used to define a specific location in a Profile.

The property is read-only.


ShowProfileSwitches Property (QueueSelectDialog)

Determines if the UnlockedOnly and LockFirst check boxes will be visible.

Settings and Return Values

A Boolean value.

Remarks

This property is write-only. The property must be set before calling QueueSelectDialog.DoModal.


UnlockedOnly Property (QueueSelectDialog)

Sets or retrieves the state of the UnlockedOnly checkbox on the QueueSelectDialog.

Settings and Return Values

A Boolean value.

Remarks

To default the value, the property must be set before calling QueueSelectDialog.DoModal. The setting will only be visible if QueueSelectDialog.ShowProfileSwitches property is True. The main purpose of this value is to help define a Profile object, by stating return only unlocked packages.


StartEventDialog

StartEventDialog Object

Presents a selection dialog allowing the user to select a StartEvent, so the package can be placed into the process flow.

Remarks

After the user clicks OK, the StartEvent property contains the selection.


Comments Property (StartEventDialog)

Corresponds to the Comments edit field on the dialog.

Settings and Return Values

Sets and returns a String value corresponding to the Comments edit field on the dialog.

Remarks

The property can be set prior to calling DoModal to fill in a default value for the field and read after the user clicks OK to receive an updated value.


Priority Property (StartEventDialog)

Corresponds to the Priority edit field on the dialog.

Settings and Return Values

Sets and returns a Long value corresponding to the Priority edit field on the dialog.

Remarks

The property can be set prior to calling DoModal to fill in a default value for the field and read after the user clicks OK to receive an updated value.


StartEvent Property (StartEventDialog)

The Start Event selected by the user.

Settings and Return Values

Returns an Object reference evaluating to an Event object.

Remarks

This property is only valid after calling DoModal and after the user has clicked OK in the dialog.

The property is read-only.


Template Property (StartEventDialog)

Setting this property determines which start events will be available for the package to start in.

Settings and Return Values

Requires a Template object.

Remarks

This property is write only. The property must be set prior to calling DoModal.


TemplateSelectDialog

TemplateSelectDialog Object

Presents a selection dialog allowing the user to select a Template from the Templates defined in the BPM database.

Remarks

The UserToken property must be set before calling DoModal. After the user click OK, the Template property contains the selection. If the user clicks cancel, the value of the Template property is undefined.

The dialog is typically used to prompt the user with a list of templates to create as part of a create package operation. and then calling Template.CreatePackage on the returned value.


FilterCanCreate Property (TemplateSelectDialog)

Determines if dialog displays all Templates or only templates that can be created by the user.

Settings and Return Values

A Boolean value.

Remarks

The templates selected are based on the UserToken that was passed in before DoModal was called.

This property is write-only.


Template Property (TemplateSelectDialog)

The Template selected by the user.

Settings and Return Values

Returns an Object reference evaluating to an Template object.

Remarks

This property is only valid after calling DoModal and after the user has clicked OK in the dialog.

The property is read-only.


UserSelectDialog

UserSelectDialog Object

Presents a selection dialog allowing the user to select a WFUser from the WFUsers defined in the BPM database.

Remarks

The UserToken property must be set before calling DoModal. After the user click OK, the WFUser property contains the selection. If the user clicks cancel, the value of the WFUser property is undefined.

The dialog is typically used to prompt the user with a list of user to create as part of a route to user operation. and then calling Package.RouteToUser on the returned value.


ShowCurrentUser Property (UserSelectDialog)

A Boolean value indicating to the dialog whether to show the user represented by the UserToken property in the selection list.

Settings and Return Values

Sets a Boolean value

Remarks

True | Show the user represented by the UserToken property
False | Don't show the user represented by the UserToken property

By default, this property is True.

The property is write-only.


WFUser Property (UserSelectDialog)

The WFUser selected by the user..

Settings and Return Values

Returns an Object reference evaluating to an WFUser object.

Remarks

This property is only valid after calling DoModal and after the user has clicked OK in the dialog.

The property is read-only.


ConfirmationType enumeration

Members

Constant | Value | Description
ctComplete | 1 | This type specifies that you want to prompt the user to confirm that they want to complete the package.
ctDeleteAll | 4 | This type specifies that you want to prompt the user to confirm that they want to delete the package.
ctDeleteAttachment | 8 | This type specifies that you want to prompt the user to confirm that they want to remove the attachment from the package.
ctDeleteFromProcess | 6 | This type specifies that you want to prompt the user to confirm that they want to remove the package from the current process.
ctDeleteFromQueue | 7 | This type specifies that you want to prompt the user to confirm that they want to remove the package from the current queue.
ctInvalid | 0 | Not implemented.
ctLock | 2 | This type specifies that you want to prompt the user to confirm that they want to lock the package.
ctNew | 5 | Not implemented.
ctUnlock | 3 | This type specifies that you want to prompt the user to confirm that they want to unlock the package.


DlgReturn enumeration

Members

Constant | Value | Description
drAbort | 3 | Not implemented.
drCancel | 2 | This type is returned when the user cancels out of dialog.
drOk | 1 | This type is returned when the user clicks the OK button.