IBPM Web Services Overview

The following is a list of web services that exist for the IBPM product. This list is broken down into several categories and includes a brief description of the features in that category.

Objects
IBPM User - Logging into IBPM
Imaging Export - Obtaining images from IBPM
Imaging Indexing - Working with Document Meta Data in IBPM
Imaging Search - Searching for documents in IBPM
BPM Profiles - Working with Process Profiles in IBPM
BPM Packages - Working with Process Packages in IBPM
IBPM Web Client Utilities - Utility Services in IBPM
Objects

The following is a list of methods on Acorde2.asmx that are for internal IBPM product integration and are not supported as public web services:

  • AXFInvokeDocumentAction
  • IntegrationsInvokeDocumentAction
  • IntegrationsRegisterAlias
  • IntegrationsUpdatePackageViewNext
  • IntegrationsViewPackage
  • IntegrationsViewPublicDocuments

Do not use these in solutions you are creating because these methods are not fully document and could change behavior in future releases.


IBPM User Object

The User object is a utility object used to log in and out of the IBPM system.

Remarks

AcordeUser.WSDL is a file that uses "Web Services Description Language" (http://msdn.microsoft.com/library/default.asp?url=/library/en-us/dnwebsrv/html/wsdlexplained.asp?frame=true) to describe to a SOAP Client what "IBPM User" related services are available from the IBPM Web Server. These include Login and Logout SOAP Services.


ConnectLanguage Method

ConnectLanguage Method (User)

Allows the Web SDK user to connect an xmlAIID to a named language for use with an IBPM Web application.

When using the Interface(s): Acorde2.asmx, Acorde.asmx, AcordeUser.WSDL

Syntax

object.ConnectLanguage(xmlAIID As String, NewLanguageId As String)

Parameters

Part | Description
xmlAIID | An active IBPM Infrastructure Initialization Document (AIID). Obtain the xmlAIID from the various Login calls.
NewLanguageId | The IBPM code for the desired language. This release only supports "en-us". Future releases will support other languages.

Return Type

The return from this call is an xmlAIID. This call returns an IBPM Infrastructure Initialization Document (AIID). This is an XML document that contains information needed to reconnect and reactivate a session in the Web SDK environment. This AIID is analogous to the usertoken used by the IBPM COM SDK. The AIID document format could change in the future releases so DO NOT attempt to parse it. Treat it as a "blob". Will be the same as the one passed in except it will be returned connected to the requested language if that language is currently supported by this release.


ConnectProcess Method

ConnectProcess Method (User)

Allows the Web SDK user to connect an xmlAIID to a named BPM database.

When using the Interface(s): Acorde2.asmx, Acorde.asmx, AcordeUser.WSDL

Syntax

object.ConnectProcess(xmlAIID As String, ProcessDatabaseName As String)

Parameters

Part | Description
xmlAIID | An active IBPM Infrastructure Initialization Document (AIID). Obtain the xmlAIID from the various Login calls.
ProcessDatabaseName | The name of the BPM database that should be connected to.

Return Type

The return from this call is an xmlAIID. This call returns an IBPM Infrastructure Initialization Document (AIID). This is an XML document that contains information needed to reconnect and reactivate a session in the Web SDK environment. This AIID is analogous to the usertoken used by the IBPM COM SDK. The AIID document format could change in the future releases so DO NOT attempt to parse it. Treat it as a "blob". Will be the same as the one passed in except it will be returned connected to the named BPM Database. An xmlAIID can only be connected to one BPM Database at a time.


LoginAlias Method

LoginAlias Method (User)

Allows the Web SDK user to log a user into the Imaging system using an alias. The alias must have been previously registered using the User.RegisterAlias call described below. Allows a Web SDK user to get an xmlAIID for use in future functional calls.

When using the Interface(s): Acorde2.asmx, Acorde.asmx, AcordeUser.WSDL

Syntax

object.LoginAlias(AcordeAlias As String, PublicAliasKey As String, LicenseType As String, Style As String)

Parameters

Part | Description
AcordeAlias | The Alias you are using to login. This is just a string value.
PublicAliasKey The XML Public Alias Key (xmlAIIK) that was provided from the User.RegisterAlias.

LicenseType The name of the license type you want to use when logging in as a string. This value can be "WebView" or "FullSeat".

Style This value can be the following:
  • CheckTrust - Checks if the request is being made from a trusted IP.
  • WSSCONNECT - Indicates a session should be opened with WSS. Some Web Services in like DeleteDocument require the session be connected to WSS.

You can also combine the style flags by using a pipe delimiter.

Remarks

The return from this call is an xmlAIID. This call returns an IBPM Infrastructure Initialization Document (AIID). This is an XML document that contains information needed to reconnect and reactivate a session in the Web SDK environment. This AIID is analogous to the usertoken used by the IBPM COM SDK. The AIID document format could change in the future releases so DO NOT attempt to parse it. Treat it as a "blob". Will be the same as the one passed in except it will be returned connected to the named BPM Database. An xmlAIID can only be connected to one BPM Database at a time.


LoginAliasProcess Method

LoginAliasProcess Method (User)

Allows the Web SDK user to log in to the BPM system using an alias. The alias must have been previously registered using the User.RegisterAlias. Allows a Web SDK user to get an xmlAIID for use in future functional calls.

When using the Interface(s): Acorde2.asmx, Acorde.asmx, AcordeUser.WSDL

Syntax

object.LoginAliasProcess(AcordeAlias As String, PublicAliasKey As String, LicenseType As String, ProcessDatabaseName as String, Style As String)

Parameters

Part | Description
AcordeAlias | The Alias you are using to login. This is the same Alias string value used with RegisterAlias.
PublicAliasKey The XML Public Alias Key that was provided from the User.RegisterAlias.

LicenseType The name of the license type you want to use when logging in as a string. This value can be "WebView" or "FullSeat".

ProcessDatabaseName | The name of the BPM database you want to connect to. If an empty string is provided, the call will connect to the first BPM Database it finds in the Process Database List.
Style This value can be the following:
  • CheckTrust - Checks if the request is being made from a trusted IP.
  • WSSCONNECT - Indicates a session should be opened with WSS. Some Web Services in like DeleteDocument require the session be connected to WSS.

You can also combine the style flags by using a pipe delimiter.

Remarks

The return from this call is an xmlAIID. This call returns an IBPM Infrastructure Initialization Document (AIID). This is an XML document that contains information needed to reconnect and reactivate a session in the Web SDK environment. This AIID is analogous to the usertoken used by the IBPM COM SDK. The AIID document format could change in the future releases so DO NOT attempt to parse it. Treat it as a "blob". Will be the same as the one passed in except it will be returned connected to the named BPM Database. An xmlAIID can only be connected to one BPM Database at a time.


LoginUserName Method

LoginUserName Method (User)

Allows the Web SDK user to log a user in to the Imaging system using a username and password. Allows a Web SDK user to get an xmlAIID for use in future functional calls.

When using the Interface(s): Acorde2.asmx, Acorde.asmx, AcordeUser.WSDL

Syntax

object.LoginUserName(UserName As String, Password As String, LicenseType As String, Style As String)

Parameters

Part | Description
UserName | TThe Username that you are attempting to login as.
Password The password for the user you are logging in as.

LicenseType The name of the license type you want to use when logging in as a string. This value can be "WebView" or "FullSeat".

Style This value can be the following:
  • CheckTrust - Checks if the request is being made from a trusted IP.
  • WSSCONNECT - Indicates a session should be opened with WSS. Some Web Services in like DeleteDocument require the session be connected to WSS.

You can also combine the style flags by using a pipe delimiter.

Remarks

The return from this call is an xmlAIID. This call returns an IBPM Infrastructure Initialization Document (AIID). This is an XML document that contains information needed to reconnect and reactivate a session in the Web SDK environment. This AIID is analogous to the usertoken used by the IBPM COM SDK. The AIID document format could change in the future releases so DO NOT attempt to parse it. Treat it as a "blob". The AIID Obtained from this call will be used for functional calls into the IBPM Web SDK. The AIID Obtained from this call can also be provided on a URL to the IBPM Web Client to provide pass-through login to the IBPM Web Client. The AIID Obtained from this call will be connected to the "en-us" language.


LoginUserNameProcess Method

LoginUserNameProcess Method (User)

Allows the Web SDK user to log a user in to the Imaging system using a username and password; and in the same call connect to an BPM database. Allows a Web SDK user to get an xmlAIID for use in future functional calls.

When using the Interface(s): Acorde2.asmx, Acorde.asmx, AcordeUser.WSDL

Syntax

object.LoginUserNameProcess(UserName As String, Password As String, LicenseType As String, ProcessDatabaseName As String, Style As String)

Parameters

Part | Description
UserName | The Username that you are attempting to login as.
Password The password for the user you are logging in as.

LicenseType The name of the license type you want to use when logging in as a string. This value can be "WebView" or "FullSeat".

ProcessDatabaseName The name of the BPM database that you want to connect to in the login process. If an empty string is provided the call will connect to the first BPM Database it finds in the Process Database List.

Style This value can be the following:
  • CheckTrust - Checks if the request is being made from a trusted IP.
  • WSSCONNECT - Indicates a session should be opened with WSS. Some Web Services in like DeleteDocument require the session be connected to WSS.

You can also combine the style flags by using a pipe delimiter.

Remarks

The return from this call is an xmlAIID. This call returns an IBPM Infrastructure Initialization Document (AIID). This is an XML document that contains information needed to reconnect and reactivate a session in the Web SDK environment. This AIID is analogous to the usertoken used by the IBPM COM SDK. The AIID document format could change in the future releases so DO NOT attempt to parse it. Treat it as a "blob". The AIID obtained from this call will be used for functional calls into the IBPM Web SDK. The AIID obtained from this call can also be provided on a URL to the IBPM Web Client to provide pass-through login to the IBPM Web Client. The AIID obtained from this call will be connected to the "en-us" language.


Logout Method

Logout Method (User)

Allows the Web SDK user to logout (using an xmlAIID) to reclaim a license.

When using the Interface(s): Acorde2.asmx, Acorde.asmx, AcordeUser.WSDL

Syntax

object.Logout(xmlAIID As String)

Parameters

Part | Description
xmlAIID | An active IBPM Infrastructure Initialization Document (AIID).

Remarks

None


RegisterAlias Method

RegisterAlias Method (User)

Allows the Web SDK user to register an alias for a username/password combination. Allows a Web SDK user to get an xmlAIIK for use in future functional calls.

When using the Interface(s): Acorde2.asmx, Acorde.asmx, AcordeUser.WSDL

Syntax

object.RegisterAlias(Alias As String, UserName As String, Password As String)

Parameters

Part | Description
Alias | The Alias you are attempting to create (string-value).
UserName | The Username that you are attempting to create an Alias for.
Password | The password for the user attempting to create an Alias for.

Remarks

The return from this call is an xmlAIIK. This call returns an IBPM Infrastructure Initialization Key (AIIK). This is an XML document that contains information needed to validate an Alias in the Web SDK environment. This is an encrypted document that should be held by the system that is using the IBPM Web SDK. With this document and the Alias name a user will have full access to the Web SDK as well as the IBPM Web Client. This key should be stored on a network secure system and a physically secure system.


Imaging Export Object Overview

Imaging Export Object


Export Method

Export Method (Imaging Export)

Allows a user of the IBPM Web SDK to export a document.

When using the Interface(s): Acorde2.asmx

Syntax

object.Export(xmlAIID As String, SavedSearchResult As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SavedSearchResult | An object containing information about a single hit returned from a search. The IsSelected field must be set to "true" for an item to be exported.

Return Type

ExportResultsArray Object - An ExportResultsArray object containing information about documents that were exported. This object contains the web location of each exported image, the page number, sections number, and error information if the export was unsuccessful.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Syntax

object.Export(xmlAIID As String, LUCID As String, SSProviderID As String, MimeType As String, RowIdentifier As String, IndexProvider As String, TableName As String, FTSFilters As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
LUCID | A string value containing a unique key to the stored item. Known as the UniqueID or RECID in the Imaging SDK.
SSProviderID | A String value containing a GUID key which identifies the system managing the storage of the entity. Default is {0BF3C340-4C13-11d3-8166-00C04F99E979}.
MimeType | A String value containing an indicator of the type of data contained within the entity.
RowIdentifier | A String value containing a unique key to the index values. The actual value depends upon the requirements of the system managing the index. It is only necessarily unique within the Index definition identified by the IndexName property.
IndexProvider | A String value containing a GUID key which identifies the system managing the index of the entity.
TableName | A String value which uniquely identifies the index definition or schema into which the index values are stored. The table name must be fully qualified.
FTSFilters | Currently not supported. Reserved for future use. Pass in a blank string( "").

Return Type

A string containing an XML RS listing the documents that were exported. Each entry contains the web location of the exported image, the page number, sections number, and error information if the export was unsuccessful.


ExportBySystemFields Method

ExportBySystemFields Method (Imaging Export)

Allows a user of the IBPM Web SDK to export a document by providing the IBPM System Fields values.

When using the Interface(s): Acorde2.asmx

Syntax

object.ExportBySystemFields(xmlAIID As String, LUCID As String, SSProviderID As String, MimeType As String, RowIdentifier As String, IndexProvider As String, TableName As String, FTSFilters As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
LUCID | A string value containing a unique key to the stored item. Known as the UniqueID or RECID in the Imaging SDK.
SSProviderID | A String value containing a GUID key which identifies the system managing the storage of the entity. Default is {0BF3C340-4C13-11d3-8166-00C04F99E979}.
MimeType | A String value containing an indicator of the type of data contained within the entity.
RowIdentifier | A String value containing a unique key to the index values. The actual value depends upon the requirements of the system managing the index. It is only necessarily unique within the Index definition identified by the IndexName property.
IndexProvider | A String value containing a GUID key which identifies the system managing the index of the entity.
TableName | A String value which uniquely identifies the index definition or schema into which the index values are stored. The table name must be fully qualified.
FTSFilters | Currently not supported. Reserved for future use. Pass in a blank string( "").

Return Type

ExportResultsArray Object - An ExportResultsArray object containing information about documents that were exported. This object contains the web location of each exported image, the page number, sections number, and error information if the export was unsuccessful.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Method not available


ExportEx Method

ExportEx Method (Imaging Export)

Allows a user of the IBPM Web SDK to export a document by providing the IBPM System Fields values (using the SavedSearchResult object) and detailed Export Environment information.

When using the Interface(s): Acorde2.asmx

Syntax

object.ExportEx(xmlAIID As String, SavedSearchResult As Object, DPI As Integer, Type As Integer, NameSpace As String, Scale As Integer, HighestResolution As Boolean)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SavedSearchResult | An object containing information about a single hit returned from a search. The IsSelected field must be set to "true" for an item to be exported.
DPI | An integer stating the DPI setting of the exported document. Default is 96.
Type | An integer that represents the format of the exported document. Default is 3. (BMP=1, TIF=2, JPG=3, PCX=4, OPT=5, Native=6, EMF=7, PDF=8 , SmartMode=9) Note: Pure Native (6) vs SmartMode (9) Type 6 is a Pure Native format. The document is exported in its original format without re-rendering. There are no security or viewer flags passed with this message. All annotations are dropped. Type 9, SmartMode, is a Native format. Annotations are burned into the exported image if the user does not have rights to remove them. Security and viewer flags are applied. Annotations may only be removed with adequate security permissions.
NameSpace | The name of the session sub folder in which the documents will be exported. Default is "AcordeContextExport".
Scale | An integer stating the zoom percent of the exported document. Default is 140.
HighestResoltion | Default is false.

Return Type

ExportResultsArray Object - An ExportResultsArray object containing information about documents that were exported. This object contains the web location of each exported image, the page number, sections number, and error information if the export was unsuccessful.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Syntax

object.ExportEx(xmlAIID As String, LUCID As String, SSProviderID As String, MimeType As String, RowIdentifier As String, IndexProvider As String, TableName As String, FTSFilters As String, DPI As Integer, Type As Integer, NameSpace As String, Scale As Integer, HighestResolution As Boolean)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
LUCID | A string value containing a unique key to the stored item. Known as the UniqueID or RECID in the Imaging SDK.
SSProviderID | A String value containing a GUID key which identifies the system managing the storage of the entity. Default is {0BF3C340-4C13-11d3-8166-00C04F99E979}.
MimeType | A String value containing an indicator of the type of data contained within the entity.
RowIdentifier | A String value containing a unique key to the index values. The actual value depends upon the requirements of the system managing the index. It is only necessarily unique within the Index definition identified by the IndexName property.
IndexProvider | A String value containing a GUID key which identifies the system managing the index of the entity.
TableName | A String value which uniquely identifies the index definition or schema into which the index values are stored. The table name must be fully qualified.
FTSFilters | Currently not supported. Reserved for future use. Pass in a blank string( "").
DPI | An integer stating the DPI setting of the exported document. Default is 96.
Type | An integer that represents the format of the exported document. (3 = Image, 5 = Optika, 9 = Native, 8 = PDF) Default is 3.
NameSpace | The name of the session sub folder in which the documents will be exported. Default is "AcordeContextExport".
Scale | An integer stating the zoom percent of the exported document. Default is 140.
HighestResoltion | Default is false.

Return Type

A string containing an XML RS listing the documents that were exported. Each entry contains the web location of the exported image, the page number, sections number, and error information if the export was unsuccessful.


ExportExBySystemFields Method

ExportExBySystemFields Method (Imaging Export)

Allows a user of the IBPM Web SDK to export a document by providing the IBPM System Fields values and detailed export environment information.

When using the Interface(s): Acorde2.asmx

Syntax

object.ExportExBySystemFields(xmlAIID As String, LUCID As String, SSProviderID As String, MimeType As String, RowIdentifier As String, IndexProvider As String, TableName As String, FTSFilters As String, DPI As Integer, Type As Integer, NameSpace As String, Scale As Integer, HighestResolution As Boolean)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
LUCID | A string value containing a unique key to the stored item. Known as the UniqueID or RECID in the Imaging SDK.
SSProviderID | A String value containing a GUID key which identifies the system managing the storage of the entity. Default is {0BF3C340-4C13-11d3-8166-00C04F99E979}.
MimeType | A String value containing an indicator of the type of data contained within the entity.
RowIdentifier | A String value containing a unique key to the index values. The actual value depends upon the requirements of the system managing the index. It is only necessarily unique within the Index definition identified by the IndexName property.
IndexProvider | A String value containing a GUID key which identifies the system managing the index of the entity.
TableName | A String value which uniquely identifies the index definition or schema into which the index values are stored. The table name must be fully qualified.
FTSFilters | Currently not supported. Reserved for future use. Pass in a blank string( "").
DPI | An integer stating the DPI setting of the exported document. Default is 96.
Type | An integer that represents the format of the exported document. Default is 3. (BMP=1, TIF=2, JPG=3, PCX=4, OPT=5, Native=6, EMF=7, PDF=8 , SmartMode=9) Note: Pure Native (6) vs SmartMode (9) Type 6 is a Pure Native format. The document is exported in its original format without re-rendering. There are no security or viewer flags passed with this message. All annotations are dropped. Type 9, SmartMode, is a Native format. Annotations are burned into the exported image if the user does not have rights to remove them. Security and viewer flags are applied. Annotations may only be removed with adequate security permissions.
NameSpace | The name of the session sub folder in which the documents will be exported. Default is "AcordeContextExport".
Scale | An integer stating the zoom percent of the exported document. Default is 140.
HighestResoltion | Default is false.

Return Type

ExportResultsArray Object - An ExportResultsArray object containing information about documents that were exported. This object contains the web location of each exported image, the page number, sections number, and error information if the export was unsuccessful.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Method not available


ExportFromSearchResults Method

ExportFromSearchResults Method (Imaging Export)

Allows a user of the IBPM Web SDK to export documents from a SavedSearchResultsArray generated by a search call such as BeginSavedSearch.

When using the Interface(s): Acorde2.asmx

Syntax

object.ExportFromSearchResults(xmlAIID As String, SavedSearchResultArray As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SavedSearchResultsArray | An object containing information about hits returned from a search. The IsSelected field must be set to "true" for an item to be exported.

Return Type

ExportResultsArray Object - An ExportResultsArray object containing information about documents that were exported. This object contains the web location of each exported image, the page number, sections number, and error information if the export was unsuccessful.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Syntax

object.ExportFromSearchResults(xmlAIID As String, SearchResults As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SearchResults | A string containing an XML RS listing the hits that were returned from a search. The ACORDE_ITEMSELECTED field must be set to "true" for an item to be exported.

Return Type

A string containing an XML RS listing the documents that were exported. Each entry contains the web location of the exported image, the page number, sections number, and error information if the export was unsuccessful.


ExportFromSearchResultsEx Method

ExportFromSearchResultsEx Method (Imaging Export)

Allows a user of the IBPM Web SDK to export documents included in the SavedSearchResultsArray object (or an XML file), which is generated by a search based on detailed Export Environment information.

When using the Interface(s): Acorde2.asmx

Syntax

object.ExportFromSearchResultsEx(xmlAIID As String, SavedSearchResultsArray As Object, DPI As Integer, Type As Integer, NameSpace As String, Scale As Integer, HighestResolution As Boolean)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SavedSearchResult | An object containing information about a single hit returned from a search. The IsSelected field must be set to "true" for an item to be exported.
DPI | An integer stating the DPI setting of the exported document. Default is 96.
Type | An integer that represents the format of the exported document. Default is 3. (BMP=1, TIF=2, JPG=3, PCX=4, OPT=5, Native=6, EMF=7, PDF=8 , SmartMode=9) Note: Pure Native (6) vs SmartMode (9) Type 6 is a Pure Native format. The document is exported in its original format without re-rendering. There are no security or viewer flags passed with this message. All annotations are dropped. Type 9, SmartMode, is a Native format. Annotations are burned into the exported image if the user does not have rights to remove them. We do require/check security and viewer flags. Annotations may only be removed with adequate security permissions.
NameSpace | The name of the session sub folder in which the documents will be exported. Default is "AcordeContextExport".
Scale | An integer stating the zoom percent of the exported document. Default is 140.
HighestResoltion | Default is false.

Return Type

ExportResultsArray Object - An ExportResultsArray object containing information about documents that were exported. This object contains the web location of each exported image, the page number, sections number, and error information if the export was unsuccessful.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Syntax

object.ExportFromSearchResultsEx(xmlAIID As String, LUCID As String, SSProviderID As String, MimeType As String, RowIdentifier As String, IndexProvider As String, TableName As String, FTSFilters As String, DPI As Integer, Type As Integer, NameSpace As String, Scale As Integer, HighestResolution As Boolean)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
LUCID | A string value containing a unique key to the stored item. Known as the UniqueID or RECID in the Imaging SDK.
SSProviderID | A String value containing a GUID key which identifies the system managing the storage of the entity. Default is {0BF3C340-4C13-11d3-8166-00C04F99E979}.
MimeType | A String value containing an indicator of the type of data contained within the entity.
RowIdentifier | A String value containing a unique key to the index values. The actual value depends upon the requirements of the system managing the index. It is only necessarily unique within the Index definition identified by the IndexName property.
IndexProvider | A String value containing a GUID key which identifies the system managing the index of the entity.
TableName | A String value which uniquely identifies the index definition or schema into which the index values are stored. The table name must be fully qualified.
FTSFilters | Currently not supported. Reserved for future use. Pass in a blank string( "").
DPI | An integer stating the DPI setting of the exported document. Default is 96.
Type | An integer that represents the format of the exported document. Default is 3. (BMP=1, TIF=2, JPG=3, PCX=4, OPT=5, Native=6, EMF=7, PDF=8 , SmartMode=9) Note: Pure Native (6) vs SmartMode (9) Type 6 is a Pure Native format. The document is exported in its original format without re-rendering. There are no security or viewer flags passed with this message. All annotations are dropped. Type 9, SmartMode, is a Native format. Annotations are burned into the exported image if the user does not have rights to remove them. Security and viewer flags are applied. Annotations may only be removed with adequate security permissions.
NameSpace | The name of the session sub folder in which the documents will be exported. Default is "AcordeContextExport".
Scale | An integer stating the zoom percent of the exported document. Default is 140.
HighestResoltion | Default is false.

Return Type

A string containing an XML RS listing the documents that were exported. Each entry contains the web location of the exported image, the page number, sections number, and error information if the export was unsuccessful.


PurgeCache Method

PurgeCache Method (Imaging Export)

Allows a user of the IBPM Web SDK to delete the contents of the export folder.

When using the Interface(s): Acorde2.asmx

Syntax

object.PurgeCache(xmlAIID As String, NameSpace As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
NameSpace | The name of the session sub folder in which the documents will be exported. Default is "AcordeContextExport".

Return Type

ExportResultsArray Object - An ExportResultsArray object containing information about documents that were exported. This object contains the web location of each exported image, the page number, sections number, and error information if the export was unsuccessful.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Syntax

object.PurgeCache(xmlAIID As String, NameSpace As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
NameSpace | The name of the session sub folder in which the documents will be exported. Default is "AcordeContextExport".

Return Type

A string containing an XML RS listing the web location of the namespace that was purged and error information if the purge was unsuccessful.


Imaging Indexing Methods

The Imaging Indexing methods provide functionality allowing the Web Service Client to index new documents into the Imaging system. Additionally, functionality is provided to modify the indexes of existing Imaging documents.


GetApplicationFieldsForCreateDocument Method

CreateDocuments Method

This web service allows the web service client to create one or more new Imaging document. This call requires a filled out CreateDocumentRequest object. The CreateDocumentRequest object can be obtained through a call to the GetApplicationFieldsForCreateDocument Web Service. The document can either be pulled from a URL location or posted to the web service for indexing. For details on this see the topic on the CreateDocumentRequest object.

When using the Interface(s): Acorde2.asmx

Syntax

object.CreateDocuments(xmlAIID As String, objCDR As CreateDocumentRequest )

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
objCDR | A AvailableApplications object that contains one or more IndexDefinition objects.

Return Type

CreateDocumentResponse Object - the resulting information from the creation of the document.


GetApplicationFieldsForCreateDocument Method

This web service allows the web service client to obtain a collection the fields for a given set of Applications available to a user for which the user has create document rights.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetApplicationFieldsForCreateDocument(xmlAIID As String, SelectedApplications As AvailableApplications)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SelectedApplications | An AvailableApplications object that contains selected AvailableApplication objects in its collection. The original collection of AvailableApplications should be obtained from the GetApplicationsForCreateDocument Web Service Call.

Return Type

CreateDocumentRequest Object - the unpopulated Create Document Request that can be filled out and submitted to the CreateDocuments Web Service to create an Imaging document.


GetApplicationFieldsForCreateDocument Method

GetApplicationsForCreateDocument Method

This web service allows the web service client to obtain a collection of Applications that the currently logged in user has Create Document rights to. The content of the collection is based on the User Access rights. Once you call this method you can select the AvailableApplication object in the AvailableApplications return that you want to get more information on or want to perform a Create with. You will then call the GetApplicationFieldsForCreateDocument Web Service to obtain a CreateDocumentRequest for use with the CreateDocuments Web Service call.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetApplicationsForCreateDocument(xmlAIID As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.

Return Type

AvailableApplications Object - A collection of applications that are availble to the user for creating new documents.


ModifyIndexes Method

This web service allows the web service client to modify the indexes of a one or more documents. The call requires a SavedSearchResultsArray that has been obtained through the Searching Web Service Calls (BeginSavedSearch and its associated Web Service Calls). The SavedSearchResult objects that indicate updates should be updated to indicate they are selected by setting IsSelected to true.

When using the Interface(s): Acorde2.asmx

Syntax

object.ModifyIndexes(xmlAIID As String, objSelectSearchResults As SavedSearchResultsArray)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
objSelectSearchResults | A SavedSearchResultsArray object that contains the modified indexes and selected SavedSearchResult objects.

Return Type

ModifyIndexResponse Object - An object that summarizes the results of the modify index operations.


Imaging Search Object Overview

Imaging Search Object


BeginSavedSearch Method

BeginSavedSearch Method (Imaging Search)

Allows a user of the IBPM Web SDK to begin the execution of a Saved Search.

When using the Interface(s): Acorde2.asmx

Syntax

object.BeginSavedSearch(xmlAIID As String, SearchName As String, SavedSearchPromptsArray As Object, PageSize As Integer)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SearchName | The name of the saved search that the user wants to execute.
SavedSearchPromptsArray | SavedSearchPromptsArray object that was obtained from either GetSavedSearchPromptsBySearchName, GetSavedSearchPromptsMultiple, or GetSavedSearchPromptsSingle.
PageSize | The number of hits that should be obtained.

Return Type

A SavedSearchResultsArray object containing information about the hits that were returned. This will contain either the entire search results or it will contain a number of hits equal to the requests record count. The object will contain information that indicates if the search is completed, stopped or running. It will also contain information allowing the caller to get the next set of records.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Syntax

object.BeginSavedSearch(xmlAIID As String, SearchName As String, SearchPrompts As String, PageSize As Integer)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SearchName | The name of the Saved Search that we want to run.
SavedSearchPrompts | A well formed RS xml that was obtained from GetSavedSearchPrompts.
PageSize | The number of hits that should be obtained.

Return Type

A string containing an XML RS listing the hits that were returned. This will contain either the entire search results or it will contain a number of hits equal to the requests record count. The record set will contain information that indicates if the search is completed, stopped or running. It will also contain information allowing the caller to get the next set of records.


ContinueSavedSearchBySearchConnectionID Method

ContinueSavedSearchBySearchConnectionID Method (Imaging Search)

Allows a user of the IBPM Web SDK to continue retrieving search results from a search.

When using the Interface(s): Acorde2.asmx

Syntax

object.ContinueSavedSearchBySearchConnectionID(xmlAIID As String, SearchConnectionID As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SearchConnectionID | The Search Connection ID from the original results set obtained from BeginSavedSearch (or BeginAdhocSearch in a future release).

Return Type

A SavedSearchResultsArray object containing information about the hits that were returned. This will contain either the entire search results or it will contain a number of hits equal to the requests record count. The object will contain information that indicates if the search is completed, stopped or running. It will also contain information allowing the caller to get the next set of records.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Method Not Available


ContinueSearch Method

ContinueSearch Method (Imaging Search)

Allows a user of the IBPM Web SDK to continue retrieving search results from a search started with BeginSavedSearch.

When using the Interface(s): Acorde2.asmx

Method Not Available

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Syntax

object.ContinueSearch(xmlAIID As String, SearchConnectionID As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SearchConnectionID | The Search Connection ID from the original results set obtained from BeginSavedSearch (or BeginAdhocSearch in a future release).

Return Type

A string containing an XML RS listing the hits that were returned. This will contain either the entire search results or it will contain a number of hits equal to the requests record count. The record set will contain information that indicates if the search is completed, stopped or running. It will also contain information allowing the caller to get the next set of records.


GetAvailableSavedSearches Method

GetAvailableSavedSearches Method (Imaging Search)

Allows a user of the IBPM Web SDK to obtain a list of the available saved searches defined by the xmlAIID.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetAvailableSavedSearches(xmlAIID As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.

Return Type

A SavedSearchNamesArray object.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Syntax

object.GetAvailableSavedSearches(xmlAIID As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.

Return Type

A string containing an XML RS listing all the available Saved Searches for the user.


GetSavedSearchPrompts Method

GetSavedSearchPrompts Method (Imaging Search)

Allows a user of the IBPM Web SDK to get the prompts for one or more saved searches.

When using the Interface(s): Acorde2.asmx

Method Not Available

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Syntax

object.GetSavedSearchPrompts(xmlAIID As String, SearchNameList As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SearchNameList | A list of one or more Names of Imaging Searches.

Return Type

A string containing an XML RS listing the properties of each of the named searches.


GetSavedSearchPromptsBySearchName Method

GetSavedSearchPromptsBySearchName Method (Imaging Search)

Allows a user of the IBPM Web SDK to get the prompts for a saved searches by providing a single search name.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetSavedSearchPromptsBySearchName(xmlAIID As String, SearchName As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SearchName | The name of an Imaging search.

Return Type

A SavedSearchPromptsArray object listing the properties of the named search.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Method Not Available


GetSavedSearchPromptsMultiple Method

GetSavedSearchPromptsMultiple Method (Imaging Search)

Allows a user of the IBPM Web SDK to get the prompts for one or more saved searches.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetSavedSearchPromptsMultiple(xmlAIID As String, SavedSearchNameArray As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SavedSearchNameArray | A SavedSearchNameArray object.

Return Type

A SavedSearchPromptsArray object listing the properties of the named searches.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Method Not Available


GetSavedSearchPromptsSingle Method

GetSavedSearchPromptsSingle Method (Imaging Search)

Allows a user of the IBPM Web SDK to get the prompts for one search.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetSavedSearchPromptsSingle(xmlAIID As String, SavedSearchName As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SavedSearchName | A SavedSearchName object.

Return Type

A SavedSearchPromtpsArray object listing the properties of the named searches.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Method Not Available


GetSavedSearchProperties Method

GetSavedSearchProperties Method (Imaging Search)

Allows a user of the IBPM Web SDK to get the properties of one saved search.

When using the Interface(s): Acorde2.asmx

Method Not Available

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Syntax

object.GetSavedSearchProperties(xmlAIID As String, SearchName As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SearchName | An Imaging search name.

Return Type

A string containing an XML RS listing the properties of each of the saved searches.


GetSavedSearchPropertiesBySearchName Method

GetSavedSearchPropertiesBySearchName Method (Imaging Search)

Allows a user of the IBPM Web SDK to get the properties of a saved search.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetSavedSearchPropertiesBySearchName(xmlAIID As String, SearchName As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SearchName | The name of an Imaging search.

Return Type

A SavedSearchPropertiesArray object that contains information about the properties of the saved search.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Method Not Available


GetSavedSearchPropertiesMultiple Method

GetSavedSearchPropertiesMultiple Method (Imaging Search)

Allows a user of the IBPM Web SDK to get the properties of one or more saved searches.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetSavedSearchPropertiesMultiple(xmlAIID As String, SavedSearchNameArray As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SavedSearchNameArray | SavedSearchNameArray object.

Return Type

A SavedSearchPropertiesArray object that contains information about the properties of each of the named searches.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Method Not Available


GetSavedSearchPropertiesSingle Method

GetSavedSearchPropertiesSingle Method (Imaging Search)

Allows a user of the IBPM Web SDK to get the properties of a saved search.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetSavedSearchPropertiesSingle(xmlAIID As String, SavedSearchName As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SavedSearchName | A SavedSearchName object.

Return Type

A SavedSearchPropertiesArray object that contains information about the properties of each of the named searches.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Method Not Available


StopSavedSearchBySearchConnectionID Method

StopSavedSearchBySearchConnectionID Method (Imaging Search)

Allows a user of the IBPM Web SDK to stop a search by providing a search Connection ID.

When using the Interface(s): Acorde2.asmx

Syntax

object.StopSavedSearchBySearchConnectionID(xmlAIID As String, SearchConnectionID As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SearchConnectionID | A Search Connection ID.

Return Type

A SavedSearchStopArray object.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Method Not Available


StopSavedSearchMultiple Method

StopSavedSearchMultiple Method (Imaging Search)

Allows a user of the IBPM Web SDK to stop one or more saved searches by providing a string list of connection ids.

When using the Interface(s): Acorde2.asmx

Syntax

object.StopSavedSearchMultiple(xmlAIID As String, SearchConnectionID As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SearchConnectionID | A string array of search Connection IDs.

Return Type

A SavedSearchStopArray object.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Method Not Available


StopSearch Method

StopSearch Method (Imaging Search)

Allows a user of the IBPM Web SDK to stop a search by providing a Connection ID.

When using the Interface(s): Acorde2.asmx

Method Not Available

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Syntax

object.StopSearch(xmlAIID As String, SearchConnectionID As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
SearchConnectionID | The search Connection ID from the original results set obtained from BeginSavedSearch (or BeginAdhocSearch in a future release).

Return Type

A Boolean return record set.


BPM Profiles Object Overview

BPM Profiles Object

AcordeProcessProfiles.WSDL is a file that uses "Web Services Description Language" to describe to a SOAP Client what "BPM Profile" related services are available from the IBPM Web Server. As of the 3.0 release this only includes a call to get the available Process Profiles.


GetAvailable Method

GetAvailable Method (Process Profiles)

Allows the Web SDK user to get a list of the available profiles for a user.

When using the Interface(s): Acorde2.asmx

Method Not Available

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Syntax

object.GetAvailable(xmlAIID As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.

Return Type

The return from this call is an XML Microsoft Recordset (similar to the Profile object). This call returns a serialized Microsoft Recordset containing the following fields for each of the profiles that the logged in user has access too. Additionally you will notice that the property names found in this result set replicate the property names you would find on the IBPM COM SDK Profile Objects.

Field Name | Field Type | Description
ProfileName | adBSTR | The name of the profile. This is the name that should be used in the call to ProcessPackages.GetListByProfile
HasPrompts | adBoolean | A true/false value indicating that the profile has prompts or has no prompts. The SOAP SDK does not support Prompted Profiles in this release.
LastUsed | adBoolean | A Boolean indicating that this was the last used profile through the IBPM SOAP SDK.
ProfileId | adInteger | The ID of the Profile.
ProfileType | adInteger | The type of the Profile as defined in the IBPM COM SDK.
HasAcordeError | adBoolean | If an error occurred while retrieving the profile information this will be true
AcordeErrorMessage | adBSTR | The description of the error that was generated while retrieving the profile information (if an error occurred)


GetAvailableProcessProfiles Method

GetAvailableProcessProfiles Method (Process Profiles)

Allows the Web SDK user to get a list of the available profiles for a user.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetAvailableProcessProfiles(xmlAIID As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.

Return Type

A ProfileArray object that contains information about each available profile.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Syntax

Method Not Available


GetProfilePrompts Method

GetProfilePrompts Method (Process Profiles)

Allows the Web SDK User to get a list of prompts based on a Profile ID or a list of Profile IDs.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetProfilePrompts(xmlAIID As String, ProfileArray As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
ProfileArray | A ProfileArray object that contains a collection of profiles obtained from GetAvailableProcessProfiles.

Return Type

A PromptedProfileArray object that contains information about the prompts for each available profile.

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Syntax

object.GetProfilePrompts(xmlAIID As String, ProfileArray As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
ProfileIdList | The Profile ID or a comma delimited profile ID list for the Profile(s) of interest.

Return Type

The return from this call is an XML Microsoft Recordset.

Field Name | Field Type | Description
ProfileName | adBSTR | The name of the profile that the prompt row corresponds to.
ProfileId | adInteger | The id of the profile that the prompt row corresponds to.
FieldId | adBSTR | The id of the field that the prompt row corresponds to.
FieldType | adInteger | The type of the field that the prompt row corresponds to.
DisplayText | adBSTR | The display text for the prompt.
Operator | adInteger | The operator to use when the prompt set is submitted. (Same as the enum values in the COM toolkit.)
Operators | adBSTR | A comma delimited list of the available operators. (Same as the enum values in the COM toolkit )
Required | adBoolean | True if a value is required.
UsePicklist | adBoolean | Indicates if the prompt uses a picklist.
UseDistinctList | adBoolean | Indicates if the prompt use a distinct list.
DistinctListName | adBSTR | The name of the distinct list to use.
PicklistName | adBSTR | The name of the pick list to use.
Value | adBSTR | The value to use when this is submitted for a search.
HasAcordeError | adBoolean | Indicates if an error occurred while performing the operation.
AcordeErrorMessage | adBSTR | The description of the error that was generated while performing the operation (if an error occurred).


BPM Packages Object Overview

BPM Packages Object

AcordeProcessPackages.WSDL is a file that uses "Web Services Description Language" to describe to a SOAP Client what "BPM Package" related services are available from the IBPM Web Server. With the 3.0 release this includes Package Searches and some limited Package operations.


AddJournalEntryByPkgRecID Method

AddJournalEntryByPkgRecID Method (Process Packages)

Allows the Web SDK user to add a comment to one or more packages.

When using the Interface(s): Acorde2.asmx

Syntax

object.AddJournalEntryByPkgRecID(xmlAIID As String, PkgRecID As Integer, JournalEntry As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PkgRecID | The package record ID(s) for the package(s) that comments will be added to. If more than one package record ID is specified, then the list should be a comma delimited collection.
JournalEntry | The text of the comment to add to the packages.

Return Type

A PackageResultsArray object that contains a collection of PackageResults objects that provide information about the returned Packages (PkgRecId, AutoAttachmentTypeId, JournalEntry, Succeeded).

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Syntax

object.AddJournalEntryByPkgRecID(xmlAIID As String, PkgRecID As Integer, JournalEntry As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PkgRecID | The ID or IDs of the packages that the set field values operation should attempt to add a comment to. If more than one PackageRecID is specified, then the list should be a comma delimited collection of package recids.
JournalEntry | The text of the comment to add to the packages.

Return Type

The return from this call is an XML Microsoft Recordset.

Field Name | Field Type | Description
ProfileName | adBSTR | The name of the profile that the prompt row corresponds to.
ProfileId | adInteger | The id of the profile that the prompt row corresponds to.
FieldId | adBSTR | The id of the field that the prompt row corresponds to.
FieldType | adInteger | The type of the field that the prompt row corresponds to.
DisplayText | adBSTR | The display text for the prompt.
Operator | adInteger | The operator to use when the prompt set is submitted. (Same as the enum values in the COM toolkit.)
Operators | adBSTR | A comma delimited list of the available operators. (Same as the enum values in the COM toolkit )
Required | adBoolean | True if a value is required.
UsePicklist | adBoolean | Indicates if the prompt uses a picklist.
UseDistinctList | adBoolean | Indicates if the prompt use a distinct list.
DistinctListName | adBSTR | The name of the distinct list to use.
PicklistName | adBSTR | The name of the pick list to use.
Value | adBSTR | The value to use when this is submitted for a search.
HasAcordeError | adBoolean | Indicates if an error occurred while performing the operation.
AcordeErrorMessage | adBSTR | The description of the error that was generated while performing the operation (if an error occurred).


AddJournalEntryMultiple Method

AddJournalEntryMultiple Method (Process Packages)

Allows the Web SDK user to add a comment to one or more packages when using a PackageArray object.

When using the Interface(s): Acorde2.asmx

Syntax

object.AddJournalEntryMultiple(xmlAIID As String, PackageArray As Object, JournalEntry As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PackageArray | A PackageArray object. This method will extract the PkgRecID values from each package object found in PackageArray object.
JournalEntry | The text of the comment to add to the packages.

Return Type

A PackageResultsArray object that contains a collection of PackageResults objects that provide information about the returned Packages (PkgRecId, AutoAttachmentTypeId, JournalEntry, Succeeded).

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Method Not Available


AddJournalEntrySingle Method

AddJournalEntrySingle Method (Process Packages)

Allows the Web SDK user to add a comment to a package.

When using the Interface(s): Acorde2.asmx

Syntax

object.CompletePackage(xmlAIID As String, Package As Object, JournalEntry As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
Package | A Package object.
JournalEntry | The text of the comment to add to the packages.

Return Type

A PackageResultsArray object that contains a collection of PackageResults objects that provide information about the returned Packages (PkgRecId, AutoAttachmentTypeId, JournalEntry, Succeeded).

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Method Not Available


CompletePackage Method

CompletePackage Method (Process Packages)

Allows the Web SDK user to complete a package when supplied with the Package object. Only one package can be completed at a time through this call.

When using the Interface(s): Acorde2.asmx

Syntax

object.CompletePackage(xmlAIID As String, Package As Object, DecisionText As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
Package | A Package object.
DecisionText | The decision text for the decision that should be used to complete the package. If an empty string is provided then the default decision is used. An empty string can also be used when there is no decision for this event.

Return Type

A PackageResultsArray object which contains a collection of PackageResults objects that provide information about the returned Packages (PkgRecId, AutoAttachmentTypeId, JournalEntry, Succeeded).

When using the Interface(s): Acorde.asmx, AcordeUser.WSDL

Method Not Available


CompletePackageByPkgRecID Method

CompletePackageByPkgRecID Method (Process Packages)

Allows the Web SDK user to complete one package when using the Package Record ID. Only one package can be completed at a time through this call.

When using the Interface(s): Acorde2.asmx

Syntax

object.CompletePackageByPkgRecID(xmlAIID As String, PkgRecID As String, DecisionText As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PkgRecID | The ID of the package that the complete operation should be attempted on.
DecisionText | The decision text for the Decision that should be used to complete the package. If an empty string is provided then the default decision is used. An empty string can also be used when there is no decision for this event.

Return Type

A PackageResultsArray object which contains a collection of PackageResults objects that provide information about the returned Packages (PkgRecId, AutoAttachmentTypeId, JournalEntry, Succeeded).

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

object.CompletePackageByPkgRecID(xmlAIID As String, PkgRecID As String, DecisionText As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PkgRecID | The ID of the package that the complete operation should be attempted on.
DecisionText | The decision text for the decision that should be used to complete the package. If an empty string is provided then the default decision is used.

Return Type

The return from this call is an XML Microsoft Recordset. This call returns a serialized Microsoft Recordset containing the following fields for the package that was specified in the list. Because this is a simple operation this is a simple Boolean list with reported errors for any of the packages:

Field Name | Field Type | Description
PkgRecId | adInteger | The id of the package that this row indicates the result of the complete operation on.
Succeeded | adBoolean | True if the operation succeeded and false if it did not.
HasAcordeError | adBoolean | If an error occurred while attempting the complete of the package this will be true
AcordeErrorMessage | adBSTR | The description of the error that was generated while attempting the compete (if an error occurred)


CreatePackages Method

CreatePackages Method (Process Packages)

Allows the Web SDK user to create one or more packages. A single call can be used to create the packages and perform the following actions on the package:

Set package field values
Set the priority of the package
Add comments to the package history
Add Imaging attachments to the package
Attach XML Metadata to the package
Place the package in flow

When using the Interface(s): Acorde2.asmx

Syntax

object.CreatePackages(xmlAIID As String, CreatePackagesArray As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
CreatePackagesArray | A CreatePackagesArray object.

Return Type

CreatePackagesResultsArray object.

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

object.CreatePackages(xmlAIID As String, CreatePackages As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
CreatePackages | A well formed AcordeCreatePackages XML Document. The following is an example of a correctly formatted XML Document.

<?xml version="1.0" encoding="utf-8" ?>
<AcordeCreatePackages version="1.0" xmlns="http://Optika.com/schemas/AcordeInfrastructure/AcordeCreatePackages">
       <PackageCreationRequests>
       <!-- PackageCreationRequest
       This is the request to create a Package.  There can be
       multiple PackageCreationRequest nodes under the main
       PackageCreationRequests node.  The order of operations
       that occur when processing the PackageCreationRequest are
       as follows:

              1. Create the package based on Template and associate
              the RequestID with the PkgRecId in the return document.
              Both RequestID and Template are manditory nodes.

               2. Set the Package Field Values in the PackageFieldValues
              node collection.  PackageFieldValues is an optional node.

               3. Set the Priority of the Package.  Priority is an optional
              node.

               4. Add the Comments found in the JournalEntries node
              collection.  JournalEntries is an optional node.

               5. Attach the XML metadata found in the XMLMetaData node.

               6. Attach the Attachments described in the PackageAttachements
              node collection.  XMLMetaData is an optional node.

               7. Place the Package in flow based on the content of the
              PlaceInFlowRequest node.  PlaceInFlowRequest is an optional
              node.

        Notice that the nodes corresponding to steps 2 through 7 are optional
       nodes they may all be left out or any combination of them may be
       included in the PackageCreationRequest.

        Also notice that both RequestID and Template are mandatory nodes.  The
       processing of the PackageCreationRequest will fail all together if
        either of those elements are missing.
              -->
          <PackageCreationRequest>
             <!-- RequestID
             This is a reference ID used by the client to determine
             which PkgRecId corresponds to which request.  This element
             is required and a PackageCreationRequest will be rejected
             if this element is missing.
             -->
             <RequestID>AReferenceIdUsedByTheClient1</RequestID>

              <!-- Template
             The template to use when creating the package. This
             Element is required and a PackageCreationRequest will be                          rejected if this element is missing.
             -->
             <Template>TemplateName</Template>

              <!-- Priority
             Used if the package is being placed in flow or just
             when it is created. This element is optional and the
             Priority will be set to 0 if omitted.
             -->
             <Priority>9</Priority>

              <!-- PackageFieldValues
             The values that should be set in the package fields
             after the package has been created. This element is
             optional.
             -->
             <PackageFieldValues setfieldvalues="true">
                <PackageFieldValue id="1">Field1Value</PackageFieldValue>
                <PackageFieldValue id="2">Field2Value</PackageFieldValue>
                <PackageFieldValue id="3">Field3Value</PackageFieldValue>
                <PackageFieldValue id="4">Field4Value</PackageFieldValue>
             </PackageFieldValues>

              <!-- JournalEntries
             These are comments that should be added to the
             package after it has been created.  This element is
             optional.
             -->
             <JournalEntries addjournalentries="true">
                <JournalEntry>Initial Comment 1</JournalEntry>
                <JournalEntry>Another Initial Comment</JournalEntry>
             </JournalEntries>

              <!-- XMLMetaData
             This is XML data that should be added to the Package
             as Metadata after the Package is created.  The
             InnerXML for this node is converted to XML and added
             To the Package.  This element is  optional.
             -->
             <XMLMetaData addxmlmetadata="true">
                <AnyXMLDocument>...</AnyXMLDocument>
             </XMLMetaData>

              <!-- PackageAttachments
             This is a collection of attachments that should
             Be attached to the Package after it is created.
              At this time only ACORDECONTEXT type attachments
             are supported. This element is optional.
             -->
             <PackageAttachements addattachments="true">
                <PackageAttachement type="ACORDECONTEXT">
                   <Title>Attachment 1</Title>
                   <SystemFields>
                      <LUCID>LUCIDHere1</LUCID>
                      <MIMETYPE>MIMETYPE/Here1</MIMETYPE>
                      <SSPROVIDERID>SSPROVIDERIDHere1</SSPROVIDERID>
                      <TABLENAME>TABLENAMEHere1</TABLENAME>
                      <ROWIDENTIFIER>ROWIDENTIFIERHere1</ROWIDENTIFIER>
                      <INDEXPROVIDER>INDEXPROVIDERHere1</INDEXPROVIDER>
                    </SystemFields>
                 </PackageAttachement>
                 <PackageAttachement type="ACORDECONTEXT">
                    <Title>Attachment 2</Title>
                    <SystemFields>
                       <LUCID>LUCIDHere2</LUCID>
                       <MIMETYPE>MIMETYPE/Here2</MIMETYPE>
                       <SSPROVIDERID>SSPROVIDERIDHere2</SSPROVIDERID>
                       <TABLENAME>TABLENAMEHere2</TABLENAME>
                       <ROWIDENTIFIER>ROWIDENTIFIERHere2</ROWIDENTIFIER>
                       <INDEXPROVIDER>INDEXPROVIDERHere2</INDEXPROVIDER>
                    </SystemFields>
                 </PackageAttachement>
              </PackageAttachements>

               <!-- PlaceInFlowRequest
              Whether or not the package should be placed in flow after
              it has been created.  This element is optional.
              -->
              <PlaceInFlowRequest placeinflow="true">
                 <ProcessName>ProcessName</ProcessName>
                 <StartEvent>StartEventName</StartEvent>
                 <Comment>This is the place in flow comment</Comment>
              </PlaceInFlowRequest>
      </PackageCreationRequest>
   </PackageCreationRequests>
 </AcordeCreatePackages>

Return Type

The return from this call is an XML Microsoft Recordset. This call returns a serialized Microsoft Recordset containing the following fields:

Field Name | Field Type | Description
RequestID | adBSTR | The request id that was passed in for the PackageCreationRequest that corresponds to this row. This is how the user figures out which Package Record ID goes with wich of the PackageCreationRequests that were sent in.
PkgRecId | adInteger | The Package Record ID for the package that was created in response to the PackageCreationRequest that was sent in.
Created | adBoolean | True if the package was successfully created.
ValuesSet | adBoolean | True if the values were set on the package fields.
JournalEntriesMade | adBoolean | True if the comments/journal entries were made.
XMLMetaDataAdded | adBoolean | True if the XML Metadata was added to the package.
AttachementsAdded | adBoolean | True if package attachments were attached to the package.
AttachmentCount | adInteger | The count of the attachments added to the Package.
PlacedInFlow | adBoolean | True if the package was placed in flow.
HasAcordeError | adBoolean | If an error occurred while performing the operation
AcordeErrorMessage | adBSTR | The description of the error that was generated while performing the operation (if an error occurred)


GetDecisionsByPkgRecID Method

GetDecisionsByPkgRecID Method (Process Packages)

Allows the Web SDK user to get the "Complete Package" decisions for a particular Package as specified by the package record id.

When using the Interface(s): Acorde2.asmx

Method Not Available

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

object.GetDecisionsByPkgRecID(xmlAIID As String, PkgRecID As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PkgRecID | The ID of the package that the decisions are needed for.

Return Type

The return from this call is an XML Microsoft Recordset. This call returns a serialized Microsoft Recordset containing the following fields for each of the decision choices. Additionally you will notice that the property names found in this result set replicate the property names you would find on the IBPM COM SDK Decision Choice Objects. The intent with the IBPM SOAP SDK is to replicate the COM SDK, where possible, in functionality:
Field Name | Field Type | Description
DecisionText | adBSTR | The decision choice text for the decision. This is the text that should be provided in a call into ProcessPackages.CompletePackageByPkgRecID
EventId | adInteger | The EventId of the package.
IsDefault | adBoolean | Specifies if the decision is the default or not (true/false).
HasAcordeError | adBoolean | If an error occurred while retrieving the Decision Choice information this will be true.
AcordeErrorMessage | adBSTR | The description of the error that was generated while retrieving the Decision Choice information (if an error occurred).


GetFieldPicklistsFromTemplate Method

GetFieldPicklistsFromTemplate Method (Process Packages)

Allows the Web SDK User to get a list of "Field Picklists" based on a PackageTemplate object.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetFieldPicklistsFromTemplate(xmlAIID As String, PackageTemplate As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PackageTemplate | A Package Template object.

Return Type

A PackageFieldPicklistArray object containing information needed to build a picklist for a Package field.

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

object.GetFieldPicklistsFromTemplate(xmlAIID As String, Template As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
Template | The Template Name of interest; one Template at a time.

Return Type

The return from this call is an XML Microsoft Recordset. This call returns a serialized Microsoft Recordset containing the following fields. Notice that all the fields are returned and those that do not have picklists are indicated in the values:

Field Name | Field Type | Description
FieldName | adBSTR | The name of the field to which the picklist is associated.
TemplateId | adInteger | The ID of the Template that the row is referring to.
TemplateName | adBSTR | The name of the Template that the row is referring to. This is the name that was passed in.
HasPicklist | adBoolean | Does this field have a picklist.
Count | adInteger | The number if items in the picklist.
Index | adInteger | The index of the picklist value in the list of values.
Value | adBSTR | The value of the picklist item.
HasAcordeError | adBoolean | If an error occurred while performing the operation
AcordeErrorMessage | adBSTR | The description of the error that was generated while performing the operation (if an error occurred)


GetFieldPicklistsFromTemplateByTemplateName Method

GetFieldPicklistsFromTemplateByTemplateName Method (Process Packages)

Allows the Web SDK user to get a list of "Field Picklists" based on a template name.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetFieldPicklistsFromTemplateByTemplateName(xmlAIID As String, Template As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
Template | The Template Name of interest; one Template at a time.

Return Type

A PackageFieldPicklistArray object containing information needed to build a picklist for a Package field.

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Method Not Available


GetListByProfile Method

GetListByProfile Method (Process Packages)

Allows the Web SDK user to run a package search based on a named profile.

When using the Interface(s): Acorde2.asmx

Method Not Available

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

object.GetListByProfile(xmlAIID As String, ProfileName As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
ProfileName | The name of the profile that you want to run the package search with.

Return Type

The return from this call is an XML Microsoft Recordset. This call returns a serialized Microsoft Recordset containing the following fields for each of the packages that matched the search requirements. Additionally you will notice that the property names found in this result set replicate the property names you would find on the IBPM COM SDK Package Objects

Field Name | Field Type | Description
PackageType | adInteger | The type of the package. Values are the numeric values of the COM toolkit enum
Title | adBSTR | The title of the package. Values are the same as the COM toolkit.
QueueName | adBSTR | The name of the Queue the package is in.
ProcessName | adBSTR | The name of the process the package is in.
CreateDate | adDate | The date the package was created.
DueDate | adDate | The package due date.
CreatorName | adBSTR | The name of the package creator.
Priority | adInteger | The priority of the package.
InQueueDate | adDate | The in queue date of the package.
LockedByName | adBSTR | The name of the user that has the package locked.
PkgRecID | adInteger | The unique package id for the package.
HasAcordeError | adBoolean | If an error occurred while retrieving the package information this will be true
AcordeErrorMessage | adBSTR | The description of the error that was generated while retrieving the package information (if an error occurred)


GetListByPromptedProfile Method

GetListByPromptedProfile Method (Process Packages)

Allows the Web SDK user to get a list of packages based on a named profile containing prompts.

When using the Interface(s): Acorde2.asmx

Method Not Available

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

object.GetListByPromptedProfile(xmlAIID As String, ProfileID As String, PromptSet As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
ProfileID | The Profile ID for the Profile associated with the package.
PromptSet | An XML Prompt Set that has the values of the prompts filled in. Obtain an empty XML Prompt Set from the "GetProfilePrompts" call defined in "AcordeProcessProfiles.WSDL".

Return Type

The return from this call is an XML Microsoft Recordset. This call returns a serialized Microsoft Recordset containing the following fields for each of the packages that matched the search requirements. Additionally, the property names found in this result set replicate the property names found on the IBPM COM SDK Package Objects.

Field Name | Field Type | Description
PackageType | adInteger | The type of the package. Values are the numeric values of the COM toolkit enum.
Title | adBSTR | The title of the package. Values are the same as the COM toolkit.
QueueName | adBSTR | The name of the Queue the package is in.
ProcessName | adBSTR | The name of the process the package is in.
CreateDate | adDate | The date the package was created.
DueDate | adDate | The package due date.
CreatorName | adBSTR | The name of the package creator.
Priority | adInteger | The priority of the package.
InQueueDate | adDate | The in queue date of the package.
LockedByName | adBSTR | The name of the user that has the package locked.
PkgRecID | adInteger | The unique package id for the package.
HasAcordeError | adBoolean | If an error occurred while performing the operation
AcordeErrorMessage | adBSTR | The description of the error that was generated while performing the operation (if an error occurred)


GetPackageDecisions Method

GetPackageDecisions Method (Process Packages)

Allows the Web SDK user to get the "Complete Package" decisions for a particular Package as specified by the package object.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageDecisions(xmlAIID As String, Package As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
Package | A Package object.

Return Type

A PackageDecisionsListArray object that contains a collection of PackageDecisionsList objects that provide information about the returned Package decisions (EventId, IsDefault, DecisionText).

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageDecisionsByPkgRecId Method

GetPackageDecisionsByPkgRecId Method (Process Packages)

Allows the Web SDK user to get the "Complete Package" decisions for a particular Package as specified by the package record id.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageDecisions(xmlAIID As String, PkgRecID As Integer)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PkgRecID | The ID of a Package.

Return Type

A PackageDecisionsListArray object that contains a collection of PackageDecisionsList objects that provide information about the returned Package decisions (EventId, IsDefault, DecisionText).

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageFields Method

GetPackageFields Method (Process Packages)

Allows the Web SDK user to get the field values of one or more packages.

When using the Interface(s): Acorde2.asmx

Method Not Available

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

object.GetPackageFields(xmlAIID As String, PkgRecID As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PkgRecID | The ID or IDs of the packages that the get field values operation should be attempted on. If more than one PackagRecID is specified then the list should be a comma delimited collection of package rec ids.

Return Type

The return from this call is an XML Microsoft Recordset. This call returns a serialized Microsoft Recordset containing the following fields for the fields of the packages that were specified in the list:

Field Name | Field Type | Description
PkgRecId | adInteger | The id of the package that this row indicates the result of the field get operation on.
Value | adBSTR | The value of the field as a string.
FieldId | adBigInt | The ID of the field that this row is identifying the value for.
FieldName | adBSTR | The Name of the field that this row is identifying the value for.
IsModified | adBoolean | Same as the COM Toolkit property.
HasPicklist | adBoolean | Same as the COM Toolkit property.
IsIndexed | adBoolean | Same as the COM Toolkit property.
IsReadOnly | adBoolean | Same as the COM Toolkit property.
IsSystemField | adBoolean | Same as the COM Toolkit property.
Length | adBigInt | Same as the COM Toolkit property.
Type | adInteger | The type of the field as defined by the enums in the COM Toolkit.
Value | adBSTR | The value of the field as a string.
HasAcordeError | adBoolean | If an error occurred while attempting to get the field values of the package this will be true
AcordeErrorMessage | adBSTR | The description of the error that was generated while attempting to get the field values of the package(if an error occurred)


GetPackageFieldsByPkgRecId Method

GetPackageFieldsByPkgRecId Method (Process Packages)

Allows the Web SDK user to get the field values of a package based on the package record id.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageFields(xmlAIID As String, PkgRecID As Integer)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PkgRecID | The ID of a Package.

Return Type

A PackageFieldsArray object.

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageFieldsMultiple Method

GetPackageFieldsMultiple Method (Process Packages)

Allows the Web SDK user to get the field values of one or more packages.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageFieldsMultiple(xmlAIID As String, PackageArray As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PackageArray | A PackageArray object that contains a collection of Package objects.

Return Type

A PackageFieldsArray object.

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageFieldsSingle Method

GetPackageFieldsSingle Method (Process Packages)

Allows the Web SDK user to get the field values of a single package.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageFieldsSingle(xmlAIID As String, Package As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
Package | A Package object.

Return Type

A PackageFieldsArray object.

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageListByPkgRecId Method

GetPackageListByPkgRecId Method (Process Packages)

Allows the Web SDK user to retrieve the information for a specific Package based on a PkgRecId. The user will receive a PackageArray object containing a collection of single Package objects.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageListByPkgRecId(xmlAIID As String, PkgRecId As Integer)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PkgRecId | The ID of a Package.

Return Type

A PackageArray object that contains a collection of Package objects.

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageListByProfileName Method

GetPackageListByProfileName Method (Process Packages)

Allows the Web SDK user to run a package search based on a named profile.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageListByProfileName(xmlAIID As String, ProfileName As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
ProfileName | The name of the profile that you want to run the package search with.

Return Type

A PackageArray object that contains a collection of Package objects.

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageListByPromptedProfile Method

GetPackageListByPromptedProfile Method (Process Packages)

Allows the Web SDK user to get a list of packages based on a named profile containing prompts.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageListByPromptedProfile(xmlAIID As String, PromptedProfile As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PromptedProfile | A PromptedProfile object. Fill the values of for each prompt to refine your search.

Return Type

A PackageArray object which contains an array of Package objects representing Packages returned from the given Prompted Profile.

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageListMultiple Method

GetPackageListMultiple Method (Process Packages)

Allows the Web SDK user to retrieve the information for a multiple packages based on one or more PkgRecIds.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageListMultiple(xmlAIID As String, PkgRecID As Integer)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PkgRecId | An integer array of PkgRecIds.

Return Type

A PackageArray object which contains a collection of Package objects.

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageTemplateIdFields Method

GetPackageTemplateIdFields Method (Process Packages)

Allows the Web SDK user to get a listing of the Template Fields based on one or more Template Ids.

When using the Interface(s): Acorde2.asmx

Method Not Available

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

object.GetPackageTemplateIdFields(xmlAIID As String, TemplateIdList As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
TemplateIdList | One or more Template Ids in a comma delimited list.

Return Type

The return from this call is an XML Microsoft Recordset. This call returns a serialized Microsoft Recordset containing the following fields:

Field Name | Field Type | Description
TemplateId | adInteger | The ID of the template.
TemplateName | adBSTR | The name of the template.
FieldId | adInteger | The ID of the field.
FieldName | adBSTR | The name of the field.
HasPickList | adBoolean | True if the field has a picklist.
IsIndexed | adBoolean | True if the field is indexed.
IsReadOnly | adBoolean | True if the field is read only.
IsSystemField | adBoolean | True if the field is a system field.
Length | adInteger | Length of the field.
Type | adBoolean | The type of the field.
HasAcordeError | adBoolean | If an error occurred while performing the operation.
AcordeErrorMessage | adBSTR | The description of the error that was generated while performing the operation (if an error occurred).


GetPackageTemplateIdFieldsByTemplateId Method

GetPackageTemplateIdFieldsByTemplateId Method (Process Packages)

Allows the Web SDK User to get a listing of the Template Fields based on one or more Template Ids.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageTemplateIdFieldsByTemplateId(xmlAIID As String, TemplateId As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
TemplateId | One or more Template Ids in a comma delimited list.

Return Type

A PackageTemplateFieldsArray object which contains a collection of PackageTemplateFields objects. the PackageTemplateFields object contains information about the template fields for a Package (TemplateId, TemplateName, FieldId, FieldName, HasPickList, IsIndexed, IsReadOnly, IsSystemField, Length, Type).

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageTemplateIdFieldsMultiple Method

GetPackageTemplateIdFieldsMultiple Method (Process Packages)

Allows the Web SDK User to get a listing of the Template Fields based on a PackageTemplatesArray object.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageTemplateIdFieldsMultiple(xmlAIID As String, PackageTemplatesArray As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PackageTemplatesArray | A PackageTemplatesArray object.

Return Type

A PackageTemplateFieldsArray object which contains a collection of PackageTemplateFields objects. The PackageTemplateFields object contains information about the template fields for a Package (TemplateId, TemplateName, FieldId, FieldName, HasPickList, IsIndexed, IsReadOnly, IsSystemField, Length, Type).

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageTemplateIdFieldsSingle Method

GetPackageTemplateIdFieldsSingle Method (Process Packages)

Allows the Web SDK User to get a listing of the Template Fields based on a PackageTemplate object.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageTemplateIdFieldsSingle(xmlAIID As String, PackageTemplate As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PackageTemplate | A PackageTemplate object.

Return Type

A PackageTemplateFieldsArray object which contains a collection of PackageTemplateFields objects. The PackageTemplateFields object contains information about the template fields for a Package (TemplateId, TemplateName, FieldId, FieldName, HasPickList, IsIndexed, IsReadOnly, IsSystemField, Length, Type).

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageTemplateIdStartEventsByTemplateId Method

GetPackageTemplateIdStartEventsByTemplateId Method (Process Packages)

Allows the Web SDK user to get the start events for a Package Template.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageTemplateIdStartEventsByTemplateId(xmlAIID As String, TemplateID As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
TemplateId | A Template Id.

Return Type

A PackageTemplateStartEventsArray object which contains a collection of PackageTemplateStartEvents objects. A PackageTemplateStartEvents object contains information such as TemplateId, TemplateName, ProcessId, ProcessName, EventId, Event Name, Event Type, Description, CanAdhocRouteTo, CanAdhocRouteFrom, and HasStartEvents.

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageTemplateIDStartEventsMultiple Method

GetPackageTemplateIDStartEventsMultiple Method (Process Packages)

Allows the Web SDK user to get the start events for multiple Package Templates when using a PackageTemplatesArray object.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageTemplateNameStartEventsMultiple(xmlAIID As String, PackageTemplatesArray As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PackageTemplatesArray | A PackageTemplatesArray object which contains a collection of PackageTemplate objects. The PackageTemplate object provides information about a Package Template (TemplateId, TemplateName, Description, CanCreate).

Return Type

A PackageTemplateStartEventsArray object which contains a collection of PackageTemplateStartEvents objects. A PackageTemplateStartEvents objects contain information such as TemplateId, TemplateName, ProcessId, ProcessName, EventId, Event Name, Event Type, Description, CanAdhocRouteTo, CanAdhocRouteFrom, and HasStartEvents.

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageTemplateIdStartEventsSingle Method

GetPackageTemplateIdStartEventsSingle Method (Process Packages)

Allows the Web SDK user to get the start events for a single Package Template.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageTemplateIdStartEventsSingle(xmlAIID As String, PackageTemplate As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PackageTemplate | A PackageTemplate object which provides information about a Package Template (TemplateId, TemplateName, Description, CanCreate).

Return Type

A PackageTemplateStartEventsArray object which contains a collection of PackageTemplateStartEvents objects. A PackageTemplateStartEvents object contains information such as TemplateId, TemplateName, ProcessId, ProcessName, EventId, Event Name, Event Type, Description, CanAdhocRouteTo, CanAdhocRouteFrom, and HasStartEvents.

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageTemplateNameFields Method

GetPackageTemplateNameFields Method (Process Packages)

Allows the Web SDK User to get a listing of the Template Fields based on one or more Template Names.

When using the Interface(s): Acorde2.asmx

Method Not Available

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

object.GetPackageTemplateNameFields(xmlAIID As String, TemplateNameList As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
TemplateNameList | One or more Template Names in a comma delimited list.

Return Type

The return from this call is an XML Microsoft Recordset. This call returns a serialized Microsoft Recordset containing the following fields for the fields of the packages that were specified in the list:

Field Name | Field Type | Description
TemplateId | adInteger | The ID of the template.
TemplateName | adBSTR | The name of the template.
FieldId | adInteger | The ID of the field.
FieldName | adBSTR | The name of the field.
PkgRecIdHasPickList | adBoolean | True if the field has a picklist.
IsIndexed | adBoolean | True if the field is indexed.
IsReadOnly | adBoolean | True if the field is read only.
IsSystemField | adBoolean | True if the field is a system field.
Length | adInteger | Length of the field.
Type | adBoolean | The type of the field.
HasAcordeError | adBoolean | If an error occurred while performing the operation
AcordeErrorMessage | adBSTR | The description of the error that was generated while performing the operation (if an error occurred).


GetPackageTemplateNameFieldsByTemplateName Method

GetPackageTemplateNameFieldsByTemplateName Method (Process Packages)

Allows the Web SDK User to get a listing of the Template Fields based on one or more Template names.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageTemplateNameFieldsByTemplateName(xmlAIID As String, TemplateName As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
TemplateName | One or more Template Names in a comma delimited list.

Return Type

A PackageTemplateFieldsArray object which contains a collection of PackageTemplateFields objects. The PackageTemplateFields object contains information about the template fields for a Package (TemplateId, TemplateName, FieldId, FieldName, HasPickList, IsIndexed, IsReadOnly, IsSystemField, Length, Type).

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageTemplateNameFieldsMultiple Method

GetPackageTemplateNameFieldsMultiple Method (Process Packages)

Allows the Web SDK User to get a listing of the Template Fields based on one or more Template names when using a PackageTemplatesArray object.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageTemplateNameFieldsMultiple(xmlAIID As String, PackageTemplatesArray As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PackageTemplatesArray | A PackageTemplatesArray object.

Return Type

A PackageTemplateFieldsArray object which contains a collection of PackageTemplateFields objects. The PackageTemplateFields object contains information about the template fields for a Package (TemplateId, TemplateName, FieldId, FieldName, HasPickList, IsIndexed, IsReadOnly, IsSystemField, Length, Type).

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageTemplateNameFieldsSingle Method

GetPackageTemplateNameFieldsSingle Method (Process Packages)

Allows the Web SDK User to get a listing of the Template Fields based on one PackageTemplate object.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageTemplateNameFieldsSingle(xmlAIID As String, PackageTemplate As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PackageTemplate | A PackageTemplate object.

Return Type

A PackageTemplateFieldsArray object which contains a collection of PackageTemplateFields objects. The PackageTemplateFields object contains information about the template fields for a Package (TemplateId, TemplateName, FieldId, FieldName, HasPickList, IsIndexed, IsReadOnly, IsSystemField, Length, Type).

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageTemplateNameStartEventsByTemplateName Method

GetPackageTemplateNameStartEventsByTemplateName Method (Process Packages)

Allows the Web SDK user to get the start events for a Package Template when providing a Template Name.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageTemplateNameStartEventsByTemplateName(xmlAIID As String, TemplateName As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
TemplateName | A Template Name.

Return Type

A PackageTemplateStartEventsArray object which contains a collection of PackageTemplateStartEvents objects. A PackageTemplateStartEvents object contains information such as TemplateId, TemplateName, ProcessId, ProcessName, EventId, Event Name, Event Type, Description, CanAdhocRouteTo, CanAdhocRouteFrom, and HasStartEvents.

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageTemplateNameStartEventsMultiple Method

GetPackageTemplateNameStartEventsMultiple Method (Process Packages)

Allows the Web SDK user to get the start events for multiple Packages when providing a PackageTemplatesArray object.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageTemplateNameStartEventsMultiple(xmlAIID As String, PackageTemplatesArray As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PackageTemplatesArray | A PackageTemplatesArray object which contains a collection of PackageTemplate objects. The PackageTemplate objects provide information about a Package Template (TemplateId, TemplateName, Description, CanCreate).

Return Type

A PackageTemplateStartEventsArray object which contains a collection of PackageTemplateStartEvents objects. A PackageTemplateStartEvents object contains information such as TemplateId, TemplateName, ProcessId, ProcessName, EventId, Event Name, Event Type, Description, CanAdhocRouteTo, CanAdhocRouteFrom, and HasStartEvents.

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageTemplateNameStartEventsSingle Method

GetPackageTemplateNameStartEventsSingle Method (Process Packages)

Allows the Web SDK user to get the start events for a single Package Template.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageTemplateNameStartEventsSingle(xmlAIID As String, PackageTemplate As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PackageTemplate | A PackageTemplate object which provides information about a Package Template (TemplateId, TemplateName, Description, CanCreate).

Return Type

A PackageTemplateStartEventsArray object which contains a collection of PackageTemplateStartEvents objects. A PackageTemplateStartEvents object contains information such as TemplateId, TemplateName, ProcessId, ProcessName, EventId, Event Name, Event Type, Description, CanAdhocRouteTo, CanAdhocRouteFrom, and HasStartEvents.

When using the Interface(s): Acorde.asmx, AcordeProcessPackage.WSDL

Method Not Available


GetPackageTemplates Method

GetPackageTemplates Method (Process Packages)

Allows the Web SDK user to get the available package templates. This call also indicates which of those templates can be used for the creation of packages.

When using the Interface(s): Acorde2.asmx

Syntax

object.GetPackageTemplates(xmlAIID As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.

Return Type

A PackageTemplatesArray object which contains a collection of PackageTemplate objects. The PackageTemplate objects provide information about a Package Template (TemplateId, TemplateName, Description, CanCreate).

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

object.GetPackageTemplates(xmlAIID As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.

Return Type

The return from this call is an XML Microsoft Recordset. This call returns a serialized Microsoft Recordset containing the following fields. Notice that all the fields are returned and those that do not have picklists are indicated in the values:

Field Name | Field Type | Description
TemplateId | adInteger | The ID of the template.
TemplateName | adBSTR | The name of the template.
Description | adBSTR | The description for the template.
CanCreate | adBoolean | True if the template can be used to create a package.
HasAcordeError | adBoolean | If an error occurred while performing the operation
AcordeErrorMessage | adBSTR | The description of the error that was generated while performing the operation (if an error occurred).


GetTemplateIdStartEvents Method

GetTemplateIdStartEvents Method (Process Packages)

Allows the Web SDK User to get a listing of the Template Start Events based on one or more Template Ids.

When using the Interface(s): Acorde2.asmx

Method Not Available

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

object.GetTemplateIdStartEvents(xmlAIID As String, TemplateIdList As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
TemplateIdList | One or more Template Ids in a comma delimited list.

Return Type

The return from this call is an XML Microsoft Recordset. This call returns a serialized Microsoft Recordset containing the following fields for the fields of the packages that were specified in the list:

Field Name | Field Type | Description
TemplateId | adInteger | The ID of the template.
TemplateName | adBSTR | The name of the template.
ProcessName | adBSTR | The Name of the process the start event is in..
ProcessId | adInteger | The id of the process the start event is in.
EventId | adInteger | The Id of the start event.
EventName | adBSTR | The Name of the start event.
EventType | adInteger | The type of the start event.
Description | adBSTR | The description of the start event.
CanAdHocRouteTo | adBoolean | The CanAdHocRouteTo property of the start event.
CanAdHocRouteFrom | adBoolean | The CanAdHocRouteFrom property of the start event.
HasStartEvents | adBoolean | True if the template has start events.
HasAcordeError | adBoolean | If an error occurred while performing the operation
AcordeErrorMessage | adBSTR | The description of the error that was generated while performing the operation (if an error occurred).


GetTemplateNameStartEvents Method

GetTemplateNameStartEvents Method (Process Packages)

Allows the Web SDK User to get a listing of the Template Start Events based on one or more Template Names.

When using the Interface(s): Acorde2.asmx

Method Not Available

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

object.GetTemplateNameStartEvents(xmlAIID As String, TemplateIdList As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
TemplateNameList | One or more Template Names in a comma delimited list.

Return Type

The return from this call is an XML Microsoft Recordset. This call returns a serialized Microsoft Recordset containing the following fields for the fields of the packages that were specified in the list:

Field Name | Field Type | Description
TemplateId | adInteger | The ID of the template.
TemplateName | adBSTR | The name of the template.
ProcessName | adBSTR | The Name of the process the start event is in..
ProcessId | adInteger | The id of the process the start event is in.
EventId | adInteger | The Id of the start event.
EventName | adBSTR | The Name of the start event.
EventType | adInteger | The type of the start event.
Description | adBSTR | The description of the start event.
CanAdHocRouteTo | adBoolean | The CanAdHocRouteTo property of the start event.
CanAdHocRouteFrom | adBoolean | The CanAdHocRouteFrom property of the start event.
HasStartEvents | adBoolean | True if the template has start events.
HasAcordeError | adBoolean | If an error occurred while performing the operation
AcordeErrorMessage | adBSTR | The description of the error that was generated while performing the operation (if an error occurred).


LockPackageByPkgRecID Method

LockPackageByPkgRecID Method (Process Packages)

Allows the Web SDK user to Lock one Package by the Package Record ID.

When using the Interface(s): Acorde2.asmx

Syntax

object.LockPackageByPkgRecID(xmlAIID As String, PkgRecID As Integer)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PkgRecID |

Return Type

A PackageResultsArray object which contains a collection of PackageResults objects. The PackageResults objects provide information about the returned Packages (PkgRecId, AutoAttachmentTypeId, JournalEntry, Succeeded).

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

object.LockPackageByPkgRecID(xmlAIID As String, PkgRecID As Integer)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PkgRecID | The ID or IDs of the packages that the lock operation should be attempted on. If more than one PackagRecID is specified then the list should be a comma delimited collection of package rec ids.

Return Type

The return from this call is an XML Microsoft Recordset. This call returns a serialized Microsoft Recordset containing the following fields for each of the package that were specified in the list. Because this is a simple operation this is a simple Boolean list with reported errors for any of the packages:

Field Name | Field Type | Description
PkgRecId | adInteger | The id of the package that this row indicates the result of the lock operation on.
Succeeded | adBoolean | True if the operation succeeded and false if it did not.
HasAcordeError | adBoolean | If an error occurred while performing the operation
AcordeErrorMessage | adBSTR | The description of the error that was generated while performing the operation (if an error occurred).


LockPackageByPkgRecIDAndQueue Method

LockPackageByPkgRecIDAndQueue Method (Process Packages)

Allows the Web SDK user to lock packages only if they are in the specified queue.

When using the Interface(s): Acorde2.asmx

Method Not Available

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

object.LockPackageByPkgRecIDAndQueue(xmlAIID As String, PkgRecIdList As String, QueueName As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PkgRecIdList | The Package Record Ids of interest. Can be a comma delimited list for locking multiple packages.
QueueName | The queue the package(s) need to be in to lock them; otherwise, the package lock is rejected.

Return Type

The return from this call is an XML Microsoft Recordset. This call returns a serialized Microsoft Recordset containing the following fields for the fields of the packages that were specified in the list:

Field Name | Field Type | Description
PkgRecId | adInteger | The Package RecID of the package that the row refers too.
Succeeded | adBoolean | True, if the lock was successful or false if the lock failed or was rejected.
AutoAttachmentTypeId | adBSTR | The ID of the Auto Attachment for the package as it is locked.
HasAcordeError | adBoolean | If an error occurred while performing the operation
AcordeErrorMessage | adBSTR | The description of the error that was generated while performing the operation (if an error occurred).


LockPackageInQueueByPkgRecId Method

LockPackageInQueueByPkgRecId Method (Process Packages)

Allows the Web SDK user to lock packages only if they are in the specified queue.

When using the Interface(s): Acorde2.asmx

Syntax

object.LockPackageByInQueueByPkgRecId(xmlAIID As String, PkgRecId As Integer, Queue As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PkgRecId | Integer value representing the Package Record Id of interest.
QueueName | The queue the package(s) need to be in to lock them; otherwise, the package lock is rejected.

Return Type

A PackageResultsArray object which contains a collection of PackageResults objects that provide information about the returned Packages (PkgRecId, AutoAttachmentTypeId, JournalEntry, Succeeded).

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Method Not Available


LockPackageInQueueMultiple Method

LockPackageInQueueMultiple Method (Process Packages)

Allows the Web SDK user to lock multiple packages only if they are in the specified queue and when providing a PackageArray object.

When using the Interface(s): Acorde2.asmx

Syntax

object.LockPackageInQueueMultiple(xmlAIID As String, PackageArray As Object, Queue As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PackageArray | A PackageArray object.
Queue | The queue the package(s) need to be in to lock them; otherwise, the package lock is rejected.

Return Type

A PackageResultsArray object which contains a collection of PackageResults objects. The PackageResults objects provide information about the returned Packages (PkgRecId, AutoAttachmentTypeId, JournalEntry, Succeeded).

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Method Not Available


LockPackageInQueueSingle Method

LockPackageInQueueSingle Method (Process Packages)

Allows the Web SDK User to lock a single package only if they are in the specified queue.

When using the Interface(s): Acorde2.asmx

Syntax

object.LockPackageInQueueSingle(xmlAIID As String, Package As Object, Queue As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
Package | A Package object.
Queue | The queue the package needs to be in to lock them; otherwise, the package lock is rejected.

Return Type

A PackageResultsArray object which contains a collection of PackageResults objects. The PackageResults objects provide information about the returned Packages (PkgRecId, AutoAttachmentTypeId, JournalEntry, Succeeded).

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Method Not Available


LockPackageMultiple Method

LockPackageMultiple Method (Process Packages)

Allows the Web SDK user to Lock one or more Packages by the PackageArray object.

When using the Interface(s): Acorde2.asmx

Syntax

object.LockPackageMultiple(xmlAIID As String, PackageArray As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PackageArray | A PackageArray object which contains a collection of Package objects.

Return Type

A PackageResultsArray object which contains a collection of PackageResults objects. The PackageResults objects provide information about the returned Packages (PkgRecId, AutoAttachmentTypeId, JournalEntry, Succeeded).

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Method Not Available


LockPackageSingle Method

LockPackageSingle Method (Process Packages)

Allows the Web SDK user to lock one Package by providing the Package object.

When using the Interface(s): Acorde2.asmx

Syntax

object.LockPackageSingle(xmlAIID As String, Package As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
Package | A Package object.

Return Type

A PackageResultsArray object that contains a collection of PackageResults objects. The PackageResults objects provide information about the returned Packages (PkgRecId, AutoAttachmentTypeId, JournalEntry, Succeeded).

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Method Not Available


PlacePackagesInFlow Method

PlacePackagesInFlow Method (Process Packages)

Allows the Web SDK User to place one or more packages in the process.

When using the Interface(s): Acorde2.asmx

Syntax

object.PlacePackagesInFlow(xmlAIID As String, PlacePackagesInFlowRequestArray As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PlacePackagesInFlowRequestArray | A PlacePackagesInFlowRequestArray object contains PlacePackagesInFlowRequest objects. The PlacePackagesInFlowRequest object contains information such as PkgRecID, ProcessName, StartEvent, Comment, and Priority.

Return Type

A PlacePackagesInFlowArray object which contains PlacePackagesInFlowArray objects. The PlacePackagesInFlowArray objects contain information such as PkgRecID, RequestIndex, WasPlaceInFlow, HasAcordeError, and AcordeErrorMessage.

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

object.PlacePackagesInFlow(xmlAcordePlaceInFlow As String)

Parameters

Part | Description
xmlAcordePlaceInFlow | A well formed AcordePlaceInFlow XML Document. Below is a sample document for this parameter.

<?xml version="1.0" encoding="utf-8" ?>
<AcordePlaceInFlow version="1.0" xmlns="http://Optika.com/schemas/AcordeInfrastructure/AcordePlaceInFlow">
       <AcordePlaceInFlowRequests>
              <PlaceInFlowRequest PkgRecId="12345">
                     <ProcessName>ProcessName</ProcessName>
                     <StartEvent>StartEventName</StartEvent>
                     <Comment>This is the comment used in the place in flow command</Comment>
                     <Priority>9</Priority>
              </PlaceInFlowRequest>
              <PlaceInFlowRequest PkgRecId="23456">
                     <ProcessName>ProcessName</ProcessName>
                     <StartEvent>StartEventName</StartEvent>
                     <Comment>This is the comment used in the place in flow command</Comment>
                     <Priority>9</Priority>
              </PlaceInFlowRequest>
       </AcordePlaceInFlowRequests>
</AcordePlaceInFlow>

Return Type

The return from this call is an XML Microsoft Recordset. This call returns a serialized Microsoft Recordset containing the following fields:

Field Name | Field Type | Description
TemplateId | adInteger | The ID of the template.
TemplateName | adBSTR | The name of the template.
ProcessName | adBSTR | The Name of the process the start event is in.
ProcessId | adInteger | The Id of the process the start event is in.
PkgRecId | adInteger | The Id of the start event.
EventName | adBSTR | The Name of the start event.
EventType | adInteger | The type of the start event.
Description | adBSTR | A description of the start event.
CanAdhocRouteTo | adBoolean | The CanAdhocRouteTo property of the start event.
CanAdhocRouteFrom | adBoolean | The CanAdhocRouteFromproperty of the start event.
HasStartEvents | adBoolean | True if the template has start events.
HasAcordeError | adBoolean | If an error occurred while performing the operation
AcordeErrorMessage | adIntegeradBSTR | The description of the error that was generated while performing the operation (if an error occurred).


SetPackageFields Method

SetPackageFields Method (Process Packages)

Allows the Web SDK user to set the field values of one package by providing both the Package object and the PackageFieldsArray object.

When using the Interface(s): Acorde2.asmx

Syntax

object.SetPackageFields(xmlAIID As String, Package As Object, PackageFieldsArray As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
Package | A Package object.
PackageFieldsArray | A PackageFieldsArray object.

Return Type

A PackageFieldsArray object.

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

object.SetPackageFields(xmlAIID As String, PkgRecId As String, xmlPackageFields As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PkgRecID | The ID or IDs of the packages that the set field values operation should attempt to update. If more than one PackagRecID is specified then the list should be a comma delimited collection of package record ids.
xmlPackageFields | The XML document Obtained through a call to ProcessPackages.GetPackageFields with the modified field values.

Return Type

The return from this call is an XML Microsoft Recordset. This call returns a serialized Microsoft Recordset containing the following fields for the fields of the packages that were specified in the list:

Field Name | Field Type | Description
PkgRecId | adInteger | The id of the package that this row indicates the result of the field set operation on.
Value | adBSTR | The new value of the field as a string.
FieldId | adBigInt | The ID of the field that this row is identifying the value for.
FieldName | adBSTR | The Name of the field that this row is identifying the value for.
IsModified | adBoolean | Same as the COM Toolkit property.
HasPicklist | adBoolean | Same as the COM Toolkit property.
IsIndexed | adBoolean | Same as the COM Toolkit property.
IsReadOnly | adBoolean | Same as the COM Toolkit property.
IsSystemField | adBoolean | Same as the COM Toolkit property.
Length | adBigInt | Same as the COM Toolkit property.
Type | adInteger | The type of the field as defined by the enums in the COM Toolkit.
Value | adBSTR | The value of the field as a string.
HasAcordeError | adBoolean | If an error occurred while attempting to set the field values of the package this will be true
AcordeErrorMessage | adBSTR | The description of the error that was generated while attempting to set the field values of the package(if an error occurred)


SetPackageFieldsByPkgRecId Method

SetPackageFieldsByPkgRecId Method (Process Packages)

Allows the Web SDK user to set the field values of one package by providing both the Package Record ID and the PackageFieldsArray object.

When using the Interface(s): Acorde2.asmx

Syntax

object.SetPackageFieldsByPkgRecId(xmlAIID As String, PkgRecId As Integer, PackageFieldsArray As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PkgRecId | The ID of a Package.
PackageFieldsArray | A PackageFieldsArray object.

Return Type

A PackageFieldsArray object.

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

object.SetPackageFieldsByPkgRecId(xmlAIID As String, PkgRecId As String, xmlPackageFields As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PkgRecID | The ID or IDs of the packages that the set field values operation should attempt to update. If more than one PackagRecID is specified then the list should be a comma delimited collection of package record ids.
xmlPackageFields | The XML document Obtained through a call to ProcessPackages.GetPackageFields with the modified field values.

Return Type

The return from this call is an XML Microsoft Recordset. This call returns a serialized Microsoft Recordset containing the following fields for the fields of the packages that were specified in the list:

Field Name | Field Type | Description
PkgRecId | adInteger | The id of the package that this row indicates the result of the field set operation on.
Value | adBSTR | The new value of the field as a string.
FieldId | adBigInt | The ID of the field that this row is identifying the value for.
FieldName | adBSTR | The Name of the field that this row is identifying the value for.
IsModified | adBoolean | Same as the COM Toolkit property.
HasPicklist | adBoolean | Same as the COM Toolkit property.
IsIndexed | adBoolean | Same as the COM Toolkit property.
IsReadOnly | adBoolean | Same as the COM Toolkit property.
IsSystemField | adBoolean | Same as the COM Toolkit property.
Length | adBigInt | Same as the COM Toolkit property.
Type | adInteger | The type of the field as defined by the enums in the COM Toolkit.
Value | adBSTR | The value of the field as a string.
HasAcordeError | adBoolean | If an error occurred while attempting to set the field values of the package this will be true.
AcordeErrorMessage | adBSTR | The description of the error that was generated while attempting to set the field values of the package(if an error occurred).


UnlockPackageByPkgRecId Method

UnlockPackageByPkgRecId Method (Process Packages)

Allows the Web SDK user to unlock one Package by the Package Record ID.

When using the Interface(s): Acorde2.asmx

Syntax

object.UnlockPackageByPkgRecId(xmlAIID As String, PkgRecId As Integer)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PkgRecId | The ID of a Package.

Return Type

A PackageResultsArray object which contains a collection of PackageResults objects. The PackageResults objects provide information about the returned Packages (PkgRecId, AutoAttachmentTypeId, JournalEntry, Succeeded).

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

object.UnlockPackageByPkgRecId(xmlAIID As String, PkgRecId As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PkgRecID | The ID or IDs of the packages that the set field values operation should attempt to update. If more than one PackagRecID is specified then the list should be a comma delimited collection of package record ids.

Return Type

The return from this call is an XML Microsoft Recordset. This call returns a serialized Microsoft Recordset containing the following fields for each of the package that were specified in the list. Because this is a simple operation this is a simple Boolean list with reported errors for any of the packages:

Field Name | Field Type | Description
PkgRecId | adInteger | The id of the package that this row indicates the result of the lock operation on.
Succeeded | adBoolean | True if the operation succeeded and false if it did not.
HasAcordeError | adBoolean | If an error occurred while attempting the lock of the package this will be true
AcordeErrorMessage | adBSTR | The description of the error that was generated while attempting the lock (if an error occurred)


UnlockPackageMultiple Method

UnlockPackageMultiple Method (Process Packages)

Allows the Web SDK user to unlock one or more Packages by the PackageArray object.

When using the Interface(s): Acorde2.asmx

Syntax

object.UnlockPackageMultiple(xmlAIID As String, PackageArray As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
PackageArray | A PackageArray object which contains a collection of Package objects.

Return Type

A PackageResultsArray object which contains a collection of PackageResults objects. The PackageResults objects provide information about the returned Packages (PkgRecId, AutoAttachmentTypeId, JournalEntry, Succeeded).

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

Method Not Available


UnlockPackageSingle Method

UnlockPackageSingle Method (Process Packages)

Allows the Web SDK user to unlock one Package by the Package object.

When using the Interface(s): Acorde2.asmx

Syntax

object.UnlockPackageMultiple(xmlAIID As String, Package As Object)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
Package | A Package object.

Return Type

A PackageResultsArray object which contains a collection of PackageResults objects. The PackageResults objects provide information about the returned Packages (PkgRecId, AutoAttachmentTypeId, JournalEntry, Succeeded).

When using the Interface(s): Acorde.asmx, AcordeProcessPackages.WSDL

Syntax

Method Not Available


IBPM Web Client Utilities Object Overview

AcordeWebClientUtilities.WSDL is an object which contains the functionality provided by the IBPM Web Client Utilities SOAP interface. The functionality is defined by the WSDL “AcordeWebClientUtilities.wsdl” found in the SOAP directory on the IBPM Web Server once the IBPM Web SDK has been enabled.


GetAcordeWebServerURL Method

GetAcordeWebServerURL Method (Web Client Utilities)

Provides the name of the IBPM Web Server location which hosts the Web Services. This is a registry setting that is set by the IBPM Web administrator.

When using the Interface(s): Acorde2.asmx, Acorde.asmx, AcordeWebClientUtilities.WSDL

Syntax

object.GetAcordeWebServerURL(AIID As String)

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.

Remarks

The string return of this method contains the name of the IBPM Web Server that hosts the Web Services being called.


RegisterURLDescription Method

RegisterURLDescription Method (Web Client Utilities)

Allows the Web SDK user to register an XML string as a SOAP Ticket, which can be used in a URL call to the specified IBPM Web Server. The IBPM Web SDK must be enabled. You must specify if the registered SOAP Ticket is to be removed after a single use. The SOAP Ticket is returned to the user as a GUID string to be used in constructing an IBPM Web SDK URL.

When using the Interface(s): Acorde2.asmx, Acorde.asmx, AcordeWebClientUtlities.WSDL

Syntax

object.RegisterURLDescription(URLDescription As String, RemoveOnUse As Boolean)

Parameters

Part | Description
URLDescription | The XML to be registered as a SOAP Ticket. The XML must be structured in the following example to be interpreted correctly.
RemoveOnUse | Boolean value to make the SOAP Ticket single use or multiple use. By specifying TRUE, the SOAP Ticket will be deleted once it has been used a single time. When the value is FALSE, the SOAP Ticket will remain on the IBPM Web server to be accessed until a URLTools.RemoveTicket call is made.

<AcordeURLDescription>
<Parser>Default</Parser>
<OneTime>true</OneTime>
<Document>
<Items>
<Param name="Value1">This is value 1</Param>
<Param name="Value2">This is value 2</Param>
<Param name="Value3">This is value 3</Param>
<Param name="Value4">This is value 4</Param>
</Items>
</Document>
</AcordeURLDescription>

Return Type

The return from this call is a string value that is the SOAP ticket. This ticket represents the XmlURLDescription parameter and will perform the IBPM Web SDK Search and Retrieval or Package Viewer actions it specifies. The SOAP Ticket must be used in a URL in the following format to be beneficial to a user:

http://IBPMWebServerName/IBPMWebServiceName/default.asp?AcordeURLTicket=AcordeSOAPTicket&EOF=1

Field Name | Field Type | Description
IBPMWebServerName | string | The name of the IBPM Web server that has IBPM SOAP SDK enabled on it.
IBPMWebServiceName | string | The web shared name of the IBPM Web site.
AcordeSOAPTicket | string | The returned SOAP Ticket from the URLTools.RegisterURLDescription call.
EOF | boolean | This parameter may be omitted if EOF=1 has been defined in the SOAP Ticket.


RemoveTicket Method

RemoveTicket Method (Web Client Utilities)

Allows the Web SDK user to permanently remove a SOAP Ticket from the IBPM Web Server. This will only need to be accessed if the strRemoveOnUse parameter for the RegisterURLDescription is set to "FALSE".

When using the Interface(s): Acorde2.asmx, Acorde.asmx, AcordeWebClientUtilities.WSDL

Syntax

object.RemoveTicket(TicketNumber As String)

Parameters

Part | Description
TicketNumber | The SOAP Ticket number to be removed from the IBPM Web Server.

Return Type

The return from this call is a Boolean – "TRUE" or "FALSE". If the RemoveTicket was successful in removing the SOAP Ticket from the IBPM Web Server then "TRUE" will be returned. Otherwise "FALSE" is returned and the SOAP Ticket will need to be manually removed from the IBPM Web Server.


Web SDK Objects Overview

Web SDK Objects


AcordeError

The AcordeError object contains error information, if available.

public class AcordeError {

Properties:

// Boolean property indicating whether or not an error occurred during the Web Service method call.
public bool HasError;

// Information describing any errors that occurred during the Web Service method call.
public string ErrorMessage;


AcordeVersion

The AcordeError object contains IBPM version information.

public class AcordeVersion {

Properties:

// Major version number.
public int Major;

// Minor version number.
public int Minor;

// Patch version number.
public int Patch;


AvailableApplication

The AvailableApplication object is a description of an IBPM Application that is available to a user in some context. Along with infomation about the IBPM Application this object provides a Select property that allows you to select the application in a collection for use in subsequent web service calls. The default value of the Selected property will be false. In order to select the AvailableApplication in a collection you will need to set the value to true.

public class AvailableApplication {

Properties:

// The select property allows the selection of this object in collections. Teh
// default value is false.
public bool Select;

// The name of the Application the Connection and Table
// associated with this Available Application
public string Name;
public string Connection;
public string Table;

}

Associated Methods:

AvailableApplications GetApplicationsForCreateDocument (xmlAIID As String)

AvailableApplications GetApplicationFieldsForCreateDocument (xmlAIID As String, SelectedApplications As AvailableApplications)

CreateDocumentResponse CreateDocuments (xmlAIID as String, objCDR As CreateDocumentRequest)


AvailableApplications

The AvailableApplications object contains a collection of AvailableApplication objects. An AvailableApplication contains information about the Application as well as a Select property that allows you to select the application in the collection for use in subsequent web service calls. All AvailableApplications will be unselected initially. Set the Select value to true for each item you wish to select.

public class AvailableApplications {

Properties:

// The ACC Filter used to obtain the list of applications
public string Filter;

// Collection of AvailableApplication objects
public AvailableApplication[] Applications;

}

Associated Methods:

AvailableApplications GetApplicationsForCreateDocument (xmlAIID As String)

AvailableApplications GetApplicationFieldsForCreateDocument (xmlAIID As String, SelectedApplications As AvailableApplications)

CreateDocumentResponse CreateDocuments (xmlAIID as String, objCDR As CreateDocumentRequest)


CreateDocumentRequest

The CreateDocumentRequest describes a request to create a document in the Imaging system. It is obtained from the GetApplicationFieldsForCreateDocument Web Service call. The information in this object should be filled out by the client and then submitted as a paramter to the CreateDocuments Web Service call.

public class CreateDocumentRequest{

Properties:

// The collection of index definition objects
public IndexDefinition[] IndexDefinitions;

}

Associated Methods:

AvailableApplications GetApplicationsForCreateDocument (xmlAIID As String)

AvailableApplications GetApplicationFieldsForCreateDocument (xmlAIID As String, SelectedApplications As AvailableApplications)

CreateDocumentResponse CreateDocuments (xmlAIID as String, objCDR As CreateDocumentRequest)


CreateDocumentResponse

The CreateDocumentResponse describes the results of a call to the CreateDocuments Web Service. This object contains a collection of IndexResult objects that summarize what occured during the create document attempt.

public class CreateDocumentResponse{

Properties:

// The collection of objects describing the results
// of attempting to create one or more documents
public IndexResult[] IndexResults;
 }

Associated Methods:

AvailableApplications GetApplicationsForCreateDocument (xmlAIID As String)

AvailableApplications GetApplicationFieldsForCreateDocument (xmlAIID As String, SelectedApplications As AvailableApplications)

CreateDocumentResponse CreateDocuments (xmlAIID as String, objCDR As CreateDocumentRequest)


CreatePackage

The CreatePackage object contains the following information used in creating a new BPM Package.

public class CreatePackage {

Properties:

// Unique value that represents a particular CreatePackages() operation
public string RequestID;

// Represents the template that defines the structure of the package.
public string Template;

// Represents the package's current priority.
public int Priority;

// An object containing a collection of PackageField objects. Each PackageField object contains information regarding the structure and value of a field association with the given Package.
public PackageFieldsArray PackageFields;

// An object containing a collection of JournalEntry objects. Each JournalEntry object simply contains a value that represents the content of a desired comment.
public JournalEntriesArray JournalEntries;

// This property contains the data value for the XML package field. There is only one XML package field per package.
public string XMLMetaData;

// An object containing a collection of PackageAttachment objects that define Imaging documents that are to be attached to the given Package.
public PackageAttachmentsArray PackageAttachments;

//Places the package into a process flow at the specified start event.
public PlacePackagesInFlowRequest PlaceInFlowRequest;

Associated Methods:

CreatePackagesResultsArray CreatePackages(string AIID, AcordeWebCS.Acorde2Objects.CreatePackagesArray objCPA)

Associated Objects:

JournalEntry
JournalEntriesArray
PackageAttachment
PackageAttachmentsArray
PackageField
PackageFieldsArray
PlacePackagesInFlowRequest
PlacePackagesInFlowRequestArray


CreatePackageResult

The CreatePackagesResult object contains information pertaining to the status of a CreatePackages() web service call. This object informs the programmer as to whether or not various components of a Package were created successfully.

public class CreatePackageResult {

Properties:

// Represents the numeric identifier for this copy of the package.
public int PkgRecId;

// Unique value that represents a particular CreatePackages() operation.
public string RequestID;

// Boolean property indicating whether or not the particular entry was successfully created.
public bool Created;

// Boolean property indicating whether or not the field values for the Package were successfully created.
public bool ValuesSet;

// Boolean property indicating whether or not a comment was made for this package.
public boolJournalEntriesMade;

// Boolean property indicating whether or not XML Metadata was added to this package.
public bool XMLMetaData;

// The number of attachments associated with this Package.
public intAttachmentCount;

// Boolean property indicating whether or not this Package was placed in flow.
public bool PlacedInFlow;

// Boolean property indicating whether or not an error occurred during the Web Service method call.
public bool HasAcordeError;

// Information describing any errors that occurred during the Web Service method call.
public string AcordeErrorMessage;

Associated Methods:

CreatePackagesResultsArray CreatePackages(string AIID, AcordeWebCS.Acorde2Objects.CreatePackagesArray objCPA)


CreatePackagesArray

The CreatePackagesArray object contains a collection of CreatePackage objects. Declare a new CreatePackage object and populate it with information used to create a new BPM Package.

public class CreatePackagesArray {

Properties:

// Collection of CreatePackage objects
public CreatePackage[] CreatePackages;

Associated Methods:

CreatePackagesResultsArray CreatePackages(string AIID, AcordeWebCS.Acorde2Objects.CreatePackagesArray objCPA)

Associated Objects:

JournalEntry
JournalEntriesArray
PackageAttachment
PackageAttachmentsArray
PackageField
PackageFieldsArray
PlacePackagesInFlowRequest
PlacePackagesInFlowRequestArray


CreatePackagesResultsArray

The CreatePackagesResultsArray object contains a collection of CreatePackagesResult objects. A CreatePackageResult object contains information pertaining to the status of a CreatePackages() web service call. This object informs the programmer as to whether or not various components of a Package were created successfully.

public class CreatePackagesResultsArray {

Properties:

// Collection of CreatePackageResult objects
public CreatePackageResult[] CreatePackageResults;

Associated Methods:

CreatePackagesResultsArray CreatePackages(string AIID, AcordeWebCS.Acorde2Objects.CreatePackagesArray objCPA)


ExportResult

The ExportResult object contains information about how to access a document which was exported using one of the Export Web Service methods. Items populated are location, page number, and section of the exported document.

public class ExportResult {

Properties:

// The path of the exported document.
public string Location;

// The page number of the document.
public int Page;

// The Section of the document. Sections are a sub classification of a pages. For image documents, pages have exactly one section. For more complex documents, there may be multiple sections on a page. Each section for an exported document will result in a single exported image.
public int Section;

// Boolean property indicating whether or not an error occurred during the Web Service method call.
public bool HasAcordeError;

// Information describing any errors that occurred during the Web Service method call.
public string AcordeErrorMessage;

Associated Methods:

CreatePackagesResultsArray CreatePackages(string AIID, AcordeWebCS.Acorde2Objects.CreatePackagesArray objCPA)

ExportResultsArray Export(string AIID, Acorde2Objects.SavedSearchResult objSSR)

ExportResultsArray ExportEx(string AIID, Acorde2Objects.SavedSearchResult objSSR, int intDPI, int intType, string strNameSpace, int intScale, bool boolHighestResolution)

ExportResultsArray ExportBySystemFields(string AIID, string strLUCID, string strSSPROVIDERID, string strMIMETYPE, string strROWIDENTIFIER, string strINDEXPROVIDER, string strTABLENAME, string strFTSFILTERS)

ExportResultsArray ExportExBySystemFields(string AIID, string strLUCID, string strSSPROVIDERID, string strMIMETYPE, string strROWIDENTIFIER, string strINDEXPROVIDER, string strTABLENAME, string strFTSFILTERS, int intDPI, int intType, string strNameSpace, int intScale, bool boolHighestResolution)

ExportResultsArray PurgeCache(string AIID, string strNameSpace)

ExportResultsArray ExportFromSearchResults(string AIID, Acorde2Objects.SavedSearchResultsArray objSSRA)

ExportResultsArray ExportFromSearchResultsEx(string AIID, Acorde2Objects.SavedSearchResultsArray objSSRA, int intDPI, int intType, string strNameSpace, int intScale, bool boolHighestResolution)


ExportResultsArray

The ExportResultsArray object contains a collection of ExportResult objects. An ExportResult object contains information about how to access a document exported using one of the Export Web Service methods. Item available are location, page number, and section of the exported document.

public class ExportResultsArray {

Properties:

// Collection of ExportResult objects
public ExportResult[] Results;

Associated Methods:

CreatePackagesResultsArray CreatePackages(string AIID, AcordeWebCS.Acorde2Objects.CreatePackagesArray objCPA)

ExportResultsArray Export(string AIID, Acorde2Objects.SavedSearchResult objSSR)

ExportResultsArray ExportEx(string AIID, Acorde2Objects.SavedSearchResult objSSR, int intDPI, int intType, string strNameSpace, int intScale, bool boolHighestResolution)

ExportResultsArray ExportBySystemFields(string AIID, string strLUCID, string strSSPROVIDERID, string strMIMETYPE, string strROWIDENTIFIER, string strINDEXPROVIDER, string strTABLENAME, string strFTSFILTERS)

ExportResultsArray ExportExBySystemFields(string AIID, string strLUCID, string strSSPROVIDERID, string strMIMETYPE, string strROWIDENTIFIER, string strINDEXPROVIDER, string strTABLENAME, string strFTSFILTERS, int intDPI, int intType, string strNameSpace, int intScale, bool boolHighestResolution)

ExportResultsArray PurgeCache(string AIID, string strNameSpace)

ExportResultsArray ExportFromSearchResults(string AIID, Acorde2Objects.SavedSearchResultsArray objSSRA)

ExportResultsArray ExportFromSearchResultsEx(string AIID, Acorde2Objects.SavedSearchResultsArray objSSRA, int intDPI, int intType, string strNameSpace, int intScale, bool boolHighestResolution)


IndexDefinition

The IndexDefinition describes a single index of a document into Imaging through the Web Services. This objects is used as an element in a collection in the CreateDocumentRequest object. General you will obtain a CreateDocumentRequest object from the GetApplicationFieldsForCreateDocument Web Service call. After obtaining the empty object you will fill out each of the Index Definitions before submitting the CreateDocumentRequest to the CreateDocuments Web Service.

The URI placed in this object should contain either a valid HTTP URL that is accessable by the web server or a STEL ticket obtained by posting the document to the web server at the location shown below:

  • http://MyWebServer/IBPMWeb/OTInfrastructure/WebServiceFileReceiver.aspx

Use standard client posting techniques that are equivalent to the File primitive in the browser to post a file to that ASPX. In response you will get a string ticket value that begins with “STEL://”. Place that ticket into the URI element and the file will be used as the object indexed by the Web service. Once the file has been indexed the Web Service will delete it from the temp file location on the Web Server. This requires that the post of the file go to the same Web Server as the Web Service request.

public class IndexDefinition{

Properties:

// The universal resource identifier (URI) that should be used to obtain the
// document to be indexed.
public string URI = "";

// The reference id that will be returned in the response object to link this index
// definition to the resulting index response object. This ID is generated by the client
// and should be unique amoung all index definitions in a single Create Document request.
public string ReferenceID = "";

// determines if an implicite append should be used in the indexing of the document. This
// means that if there is already an Imaging document in the Application with the same
// index values this document will be appended to that document. If this is false
// a new document will be created.
public bool ImplicitAppend = true;

// The AvailableApplication that the new document should be indexed into.
public AvailableApplication Application;

// The collection of Index Definition Feild Value objects that contain the
// feild values for the new document.
public IndexDefinitionFieldValue[] FieldValues;

}

Associated Methods:

AvailableApplications GetApplicationsForCreateDocument (xmlAIID As String)

AvailableApplications GetApplicationFieldsForCreateDocument (xmlAIID As String, SelectedApplications As AvailableApplications)

CreateDocumentResponse CreateDocuments (xmlAIID as String, objCDR As CreateDocumentRequest)


IndexDefinitionFieldValue

The IndexDefinitionFieldValue describes a single value to be used when indexing a document into the Imaging system using the CreateDocuments Web Service. This object is normal used as an element in the field value collection on the IndexDefinition object. In that case the Value and Name properties will be prepopulated. You should only modify the Value property.

public class IndexDefinitionFieldValue{

Properties:

// The name value and type of the field. Only alter the
// value portion of the object. The other values should
// already be filled in by the web services call that provided
// the object
public string Name;
public string Value;
public string Type;

}

Associated Methods:

AvailableApplications GetApplicationsForCreateDocument (xmlAIID As String)

AvailableApplications GetApplicationFieldsForCreateDocument (xmlAIID As String, SelectedApplications As AvailableApplications)

CreateDocumentResponse CreateDocuments (xmlAIID as String, objCDR As CreateDocumentRequest)


IndexResult

The IndexResult describes the results of a call to the CreateDocuments Web Service. This object contains a description of what occured during the create document attempt for a single IndexDefinition.

public class IndexResult{

Properties:

// The URI that was provided in the IndexDefinition
public string URI;
// The reference ID that was provided by the client in the IndexDefinition
public string ReferenceID;
// The resulting system fields object from the index
public SystemFields SystemFields SystemFields;
}

Associated Methods:

AvailableApplications GetApplicationsForCreateDocument (xmlAIID As String)

AvailableApplications GetApplicationFieldsForCreateDocument (xmlAIID As String, SelectedApplications As AvailableApplications)

CreateDocumentResponse CreateDocuments (xmlAIID as String, objCDR As CreateDocumentRequest)


JournalEntriesArray

The JournalEntries collection contains JournalEntry objects. The JournalEntry object contains a comment value.

public class JournalEntriesArray {

Properties:

// Collection of JournalEntry objects
public JournalEntry[] JournalEntries;


JournalEntry

The JournalEntry object contains the comment value.

public class JournalEntry {

Properties:

// The text of the comment to add to the packages.
public string Value;


ModifyIndexResponse

The ModifyIndexResponse describes the results of a call to the ModifyIndexes Web Service. This object contains a description of what occured during the modify index attempt.

public class ModifyIndexResponse{

Properties:

// An indicator that the objects indexs were modified
public bool WasModified;
// The system fields for the object whos indexs were modified
public SystemFields SystemFields SystemFields;
}

Associated Methods:

ModifyIndexResponse ModifyIndexes (xmlAIID As String, objSelectSearchResults As SavedSearchResultsArray)


Package

The Package object is an electronic container for work objects as they travel through a Process flow. A work object can be anything - text, images, documents, faxes, etc. - that can be stored as a FieldValue or Attachment. The structure and behaviors of a Package are defined in a Template.

public class Package {

Properties:

// Represents the current type (or state) of the package.
public int PackageType;

// Represents the package's current priority.
public int Priority;

// Represents the numeric identifier for this copy of the package.
public int PkgRecId;

// Represents the title of the package.
public string Title;

// Represents the name of the event queue in which the package is currently located.
public string QueueName;

// Represents the name of the process in which the package is currently located.
public string ProcessName;

// Represents the name of the template that defines the structure of the package.
public string TemplateName;

// This property contains the name of the package creator.
public string CreatorName;

// Represents the name of the user to which the package is currently locked.
public string LockedByName;

// This property represents the date that the package was created.
public System.DateTime CreateDate;

// Represents the date and time upon which the package's Due Date Trigger will be fired.
public System.DateTime DueDate;

// Represents the date and time at which the package arrived in its current queue.
public System.DateTime InQueueDate;

Associated Methods:

PackageArray GetPackageListByProfileName(string AIID, string ProfileName)

PackageArray GetPackageListByPkgRecId(string AIID, int PkgRecId)

PackageArray GetPackageListMultiple(string AIID, int[] arrPkgRecId)

PackageArray GetPackageListByPromptedProfile(string AIID, AcordeWebCS.Acorde2Objects.PromptedProfile objPromptedProfile)

PackageResultsArray LockPackageMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray)

PackageResultsArray LockPackageInQueueMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray, string strQueue)

PackageResultsArray UnlockPackageMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray)

PackageResultsArray AddJournalEntryMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray, string strJournalEntry)

PackageFieldsArray GetPackageFieldsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray)


PackageArray

The PackageArray object contains a collection of Package objects. A Package is an electronic container for work objects as they travel through a Process flow. A work object or attachment can be any type (text, images, documents, faxes, etc.) which can be stored as a FieldValue or Attachment. The structure and behaviors of a Package are defined in a Template.

public class PackageArray {

Properties:

// Collection of Package objects
public Package[] Packages;

Associated Methods:

PackageArray GetPackageListByProfileName(string AIID, string ProfileName)

PackageArray GetPackageListByPkgRecId(string AIID, int PkgRecId)

PackageArray GetPackageListMultiple(string AIID, int[] arrPkgRecId)

PackageArray GetPackageListByPromptedProfile(string AIID, AcordeWebCS.Acorde2Objects.PromptedProfile objPromptedProfile)

PackageResultsArray LockPackageMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray)

PackageResultsArray LockPackageInQueueMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray, string strQueue)

PackageResultsArray UnlockPackageMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray)

PackageResultsArray AddJournalEntryMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray, string strJournalEntry)

PackageFieldsArray GetPackageFieldsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray)


PackageAttachment

The PackageAttachment object contains documents that are to be attached to the given Package.

public class PackageAttachment {

Properties:

// Represents the title of the attachment. The title is determined by Template Fields.
public string Title;

// Represents the attachment type.
public string Type;

// Contains the SystemFields for the attachment.
public SystemFields systemFields;

Associated Methods:

CreatePackagesResultsArray CreatePackages(xmlAIID As String, CreatePackagesArray As Object)


PackageAttachmentsArray

The PackageAttachmentsArray object contains a collection of PackageAttachment objects. The PackageAttachment object contains documents that are to be attached to the given Package.

public class PackageAttachmentsArray {

Properties:

// Collection of PackageAttachment objects
public PackageAttachment[] PackageAttachments;

Associated Methods:

CreatePackagesResultsArray CreatePackages(xmlAIID As String, CreatePackagesArray As Object)


PackageDecisionList

The PackageDecisionsList object represents a path that a Package object can follow when completed from a Queue.

public class PackageDecisionsList {

Properties:

// Text which describes to a user the path a Package should follow.
public string DecisionText;

// Uniquely identifies the Event which corresponds to the Decision Choice.
public int EventId;

// Determines whether the DecisionChoice is the default decision for the Work Event. A queue may or may not have a default decision, based on the configuration of the queue through Process Builder.
public bool IsDefault;

// Boolean property indicating whether or not an error occurred during the Web Service method call.
public bool HasAcordeError;

// Information describing any errors that occurred during the Web Service method call.
public string AcordeErrorMessage;

Associated Methods:

PackageDecisionsListArray GetPackageDecisions(string AIID, AcordeWebCS.Acorde2Objects.Package objPackage)

PackageDecisionsListArray GetPackageDecisionsByPkgRecId(string AIID, int PkgRecId)


PackageDecisionListArray

The PackageDecisionsListArray object contains a collection of PackageDecisionsList objects. Each PackageDecisionsList object represents a path that a Package object can follow when completed from a Queue.

public class PackageDecisionsListArray {

Properties:

// Collection of PackageDecisionsList objects
public PackageDecisionsList[] DecisionsLists;

Associated Methods:

PackageDecisionsListArray GetPackageDecisions(string AIID, AcordeWebCS.Acorde2Objects.Package objPackage)

PackageDecisionsListArray GetPackageDecisionsByPkgRecId(string AIID, int PkgRecId)


PackageField

The PackageField object contains information describing the values of data for a specific package field.

public class PackageField {

Properties:

// Represents the numeric identifier for this copy of the package.
public int PkgRecId;

// The value of the field.
public string Value;

// Uniquely identifies a field within a given Package.
public int FieldId;

// Provides the textual name of the field within a package.
public string FieldName;

// Provides an indication regarding whether or not the FieldValue has been altered.
public bool IsModified;

// States if a list of expected field values has been associated with this field by BPM Process Builder.
public bool HasPickList;

// States if this field's values have been indexed in the database. An indexed field speeds evaluations of Profiles.
public bool IsIndexed;

// States if the field's data value is read only.
public bool IsReadOnly;

// States if the field is a system defined field or a user defined field.
public bool IsSystemField;

// States the maximum number of characters that can be inserted in a string field.
public int Length;

// States the data type of the value stored by this field
public int Type;

// Boolean property indicating whether or not an error occurred during the Web Service method call.
public bool HasAcordeError;

// Information describing any errors that occurred during the Web Service method call.
public string AcordeErrorMessage;

Associated Methods:

PackageFieldsArray GetPackageFieldsSingle(string AIID, AcordeWebCS.Acorde2Objects.Package objPackage)

PackageFieldsArray GetPackageFieldsByPkgRecId(string AIID, int PkgRecId)

PackageFieldsArray GetPackageFieldsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray)

PackageFieldsArray SetPackageFields(string AIID, AcordeWebCS.Acorde2Objects.Package objPackage, AcordeWebCS.Acorde2Objects.PackageFieldsArray objPackageFieldsArray)

PackageFieldsArray SetPackageFieldsByPkgRecId(string AIID, int PkgRecId, AcordeWebCS.Acorde2Objects.PackageFieldsArray objPackageFieldsArray)


PackageFieldPicklist

The PackageFieldPicklist object contains information describing the picklist collection for the associated Package Field.

public class PackageFieldPicklist {

Properties:

// Uniquely identifies a field within a given Package.
public int FieldID;

// Provides the textual name of the field within a package.
public string FieldName;

// This property is the numeric key into the Templates collection.
public int TemplateId;

// Represents the name of the template that defines the structure of the package.
public string TemplateName;

// States if a list of expected field values has been associated with this field by BPM Process Builder.
public bool HasPickList;

// Indicates the number of objects in a collection.
public int Count;

// A long expression that evaluates to the ordinal number of an object in a collection.
public int Index;

// The Associated value for the Field.
public string Value;

// Boolean property indicating whether or not an error occurred during the Web Service method call.
public bool HasAcordeError;

// Information describing any errors that occurred during the Web Service method call.
public string AcordeErrorMessage;

Associated Methods:

PackageFieldPicklistArray GetFieldPicklistsFromTemplate(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplate objPackageTemplate)

PackageFieldPicklistArray GetFieldPicklistsFromTemplateByTemplateName(string AIID, string strTemplateName)


PackageFieldPicklistArray

The PackageFieldPicklistArray object contains a collection of PackageFieldPicklist objects. A PackageFieldPicklist object contains information describing the picklist collection for the associated Package Field.

public class PackageFieldPicklist {

Properties:

// Collection of PackageFieldPicklist objects
public PackageFieldPicklist[] FieldPicklists;

Associated Methods:

PackageFieldPicklistArray GetFieldPicklistsFromTemplate(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplate objPackageTemplate)

PackageFieldPicklistArray GetFieldPicklistsFromTemplateByTemplateName(string AIID, string strTemplateName)


PackageFieldsArray

The PackageFieldsArray object contains a collection of PackageField objects. A PackageField object contains information describing the values of data for a specific package field.

public class PackageFieldsArray {

Properties:

// Collection of PackageField objects
public PackageField[] Fields;

Associated Methods:

PackageFieldsArray GetPackageFieldsSingle(string AIID, AcordeWebCS.Acorde2Objects.Package objPackage)

PackageFieldsArray GetPackageFieldsByPkgRecId(string AIID, int PkgRecId)

PackageFieldsArray GetPackageFieldsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray)

PackageFieldsArray SetPackageFields(string AIID, AcordeWebCS.Acorde2Objects.Package objPackage, AcordeWebCS.Acorde2Objects.PackageFieldsArray objPackageFieldsArray)

PackageFieldsArray SetPackageFieldsByPkgRecId(string AIID, int PkgRecId, AcordeWebCS.Acorde2Objects.PackageFieldsArray objPackageFieldsArray)


PackageResult

The PackageResult object contains information related to the success or failure of an associated Package-related IBPM Web Service call.

public class PackageResults {

Properties:

// Represents the numeric identifier for this copy of the package.
public int PkgRecId;

// Boolean property detailing whether or not the associated web service call was successful for this particular PkgRecId.
public bool Succeeded;

// A number that uniquely identifies the AttachmentType within a package template definition.
public int AutoAttachmentTypeId;

// Returns the value of the comment added by the associated web service call.
public string JournalEntry;

// Boolean property indicating whether or not an error occurred during the Web Service method call.
public bool HasAcordeError;

// Information describing any errors that occurred during the Web Service method call.
public string AcordeErrorMessage;

Associated Methods:

PackageResultsArray LockPackageSingle(string AIID, AcordeWebCS.Acorde2Objects.Package objPackage)

PackageResultsArray LockPackageByPkgRecId(string AIID, int PkgRecId)

PackageResultsArray LockPackageMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray)

PackageResultsArray LockPackageInQueueSingle(string AIID, AcordeWebCS.Acorde2Objects.Package objPackage, string strQueue)

PackageResultsArray LockPackageInQueueByPkgRecId(string AIID, int PkgRecId, string strQueue)

PackageResultsArray LockPackageInQueueMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray, string strQueue)

PackageResultsArray UnlockPackageSingle(string AIID, AcordeWebCS.Acorde2Objects.Package objPackage)

PackageResultsArray UnlockPackageByPkgRecId(string AIID, int PkgRecId)

PackageResultsArray UnlockPackageMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray)

PackageResultsArray AddJournalEntrySingle(string AIID, AcordeWebCS.Acorde2Objects.Package objPackage, string strJournalEntry)

PackageResultsArray AddJournalEntryByPkgRecId(string AIID, int PkgRecId, string strJournalEntry)

PackageResultsArray AddJournalEntryMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray, string strJournalEntry)

PackageResultsArray CompletePackage(string AIID, AcordeWebCS.Acorde2Objects.Package objPackage, string strDecisionText)

PackageResultsArray CompletePackageByPkgRecId((string AIID, int PkgRecId, string strDecisionText)


PackageResultsArray

The PackageResultsArray object contains a collection of PackageResult objects. The PackageResult object contains information related to the success or failure of an associated Package-related IBPM Web Service call.

public class PackageResultsArray {

Properties:

// Collection of PackageResult objects
public PackageResults[] Results;

Associated Methods:

PackageResultsArray LockPackageSingle(string AIID, AcordeWebCS.Acorde2Objects.Package objPackage)

PackageResultsArray LockPackageByPkgRecId(string AIID, int PkgRecId)

PackageResultsArray LockPackageMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray)

PackageResultsArray LockPackageInQueueSingle(string AIID, AcordeWebCS.Acorde2Objects.Package objPackage, string strQueue)

PackageResultsArray LockPackageInQueueByPkgRecId(string AIID, int PkgRecId, string strQueue)

PackageResultsArray LockPackageInQueueMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray, string strQueue)

PackageResultsArray UnlockPackageSingle(string AIID, AcordeWebCS.Acorde2Objects.Package objPackage)

PackageResultsArray UnlockPackageByPkgRecId(string AIID, int PkgRecId)

PackageResultsArray UnlockPackageMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray)

PackageResultsArray AddJournalEntrySingle(string AIID, AcordeWebCS.Acorde2Objects.Package objPackage, string strJournalEntry)

PackageResultsArray AddJournalEntryByPkgRecId(string AIID, int PkgRecId, string strJournalEntry)

PackageResultsArray AddJournalEntryMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageArray objPackageArray, string strJournalEntry)

PackageResultsArray CompletePackage(string AIID, AcordeWebCS.Acorde2Objects.Package objPackage, string strDecisionText)

PackageResultsArray CompletePackageByPkgRecId((string AIID, int PkgRecId, string strDecisionText)


PackageTemplate

The PackageTemplate object represents a single template which has been created and applied using BPM Process Builder.

public class PackageTemplate {

Properties:

// Represents the numeric identifier of the template that defines the structure of the package.
public int TemplateId;

// Represents the name of the template that defines the structure of the package.
public string TemplateName;

// Represents a textual description of the Template.
public string Description;

// Provides an indication regarding whether or not the Template is capable of creating a Package.
public bool CanCreate;

// Boolean property indicating whether or not an error occurred during the Web Service method call.
public bool HasAcordeError;

// Information describing any errors that occurred during the Web Service method call.
public string AcordeErrorMessage;

Associated Methods:

PackageTemplatesArray GetPackageTemplates(string AIID)

PackageTemplateFieldsArray GetPackageTemplateIdFieldsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplatesArray objPackageTemplatesArray)

PackageTemplateFieldsArray GetPackageTemplateNameFieldsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplatesArray objPackageTemplatesArray)

PackageTemplateFieldsArray GetPackageTemplateIdStartEventsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplatesArray objPackageTemplatesArray)

PackageTemplateFieldsArray GetPackageTemplateNameStartEventsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplatesArray objPackageTemplatesArray)


PackageTemplateFields

The PackageTemplateFields object represents individual field information for a single template which has been created and applied within BPM Process Builder.

public class PackageTemplateFields {

Properties:

// Represents the numeric identifier of the template that defines the structure of the package.
public int TemplateId;

// Represents the name of the template that defines the structure of the package.
public string TemplateName;

// Uniquely identifies a field within a given Package.
public int FieldId;

// Provides the textual name of the field within a package.
public string FieldName;

// States if a list of expected field values has been associated with this field by BPM Process Builder.
public bool HasPickList;

// States if this field's values have been indexed in the database. An indexed field speeds evaluations of Profiles.
public bool IsIndexed;

// States if the field's data value is read only.
public bool IsReadOnly;

// States if the field is a system defined field or a user defined field.
public bool IsSystemField;

// States the maximum number of characters that can be inserted in a string field.
public int Length;

// States the data type of the value stored by this field
public int Type;

// Boolean property indicating whether or not an error occurred during the Web Service method call.
public bool HasAcordeError;

// Information describing any errors that occurred during the Web Service method call.
public string AcordeErrorMessage;

Associated Methods:

PackageTemplateFieldsArray GetPackageTemplateIdFieldsSingle(string AIID, string strTemplateName)

PackageTemplateFieldsArray GetPackageTemplateIdFieldsSingle(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplate objPackageTemplate)

PackageTemplateFieldsArray GetPackageTemplateIdFieldsByTemplateId(string AIID, string strTemplateId)

PackageTemplateFieldsArray GetPackageTemplateIdFieldsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplatesArray objPackageTemplatesArray)

PackageTemplateFieldsArray GetPackageTemplateNameFieldsSingle(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplate objPackageTemplate)

PackageTemplateFieldsArray GetPackageTemplateNameFieldsByTemplateName(string AIID, string strTemplateName)

PackageTemplateFieldsArray GetPackageTemplateNameFieldsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplatesArray objPackageTemplatesArray)


PackageTemplateFieldsArray

The PackageTemplateFieldsArray object contains a collection of PackageTemplateFields objects. Each PackageTemplateFields object represents individual field information for a single template which has been applied from the BPM Process Builder.

public class PackageTemplateFieldsArray {

Properties:

// Collection of PackageTemplateFields objects
public PackageTemplateFields[] TemplateFields;

Associated Methods:

PackageTemplateFieldsArray GetPackageTemplateIdFieldsSingle(string AIID, string strTemplateName)

PackageTemplateFieldsArray GetPackageTemplateIdFieldsSingle(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplate objPackageTemplate)

PackageTemplateFieldsArray GetPackageTemplateIdFieldsByTemplateId(string AIID, string strTemplateId)

PackageTemplateFieldsArray GetPackageTemplateIdFieldsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplatesArray objPackageTemplatesArray)

PackageTemplateFieldsArray GetPackageTemplateNameFieldsSingle(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplate objPackageTemplate)

PackageTemplateFieldsArray GetPackageTemplateNameFieldsByTemplateName(string AIID, string strTemplateName)

PackageTemplateFieldsArray GetPackageTemplateNameFieldsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplatesArray objPackageTemplatesArray)


PackageTemplatesArray

The PackageTemplatesArray object contains a collection of PackageTemplates objects. Each PackageTemplate object represents a single template which has been created and applied within BPM Process Builder.

public class PackageTemplatesArray {

Properties:

// Collection of PackageTemplate objects
public PackageTemplate[] Templates;

Associated Methods:

PackageTemplatesArray GetPackageTemplates(string AIID)

PackageTemplateFieldsArray GetPackageTemplateIdFieldsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplatesArray objPackageTemplatesArray)

PackageTemplateFieldsArray GetPackageTemplateNameFieldsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplatesArray objPackageTemplatesArray)

PackageTemplateFieldsArray GetPackageTemplateIdStartEventsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplatesArray objPackageTemplatesArray)

PackageTemplateFieldsArray GetPackageTemplateNameStartEventsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplatesArray objPackageTemplatesArray)


PackageTemplateStartEvents

The PackageTemplateStartEvent object represents the list of Start Events that can be used to place a created Package into a Process flow.

public class PackageTemplateStartEvents {

Properties:

// Represents the numeric identifier of the template that defines the structure of the package.
public int TemplateId;

// Represents the name of the template that defines the structure of the package.
public string TemplateName;

// Uniquely identifies the Process in which the Event is defined.
public int ProcessId;

// Provides the textual name of the Process in which the Event is defined
public string ProcessName;

// Uniquely identifies the Event within a given Process.
public int EventId;

// Provides the textual name of the Event.
public string EventName;

// Represents the Event's type.
public int EventType;

// Represents a textual description of the Event.
public string Description;

// Provides an indication regarding whether or not Packages can be Ad-hoc Routed to the Event.
public bool CanAdhocRouteTo;

// Provides an indication regarding whether or not Packages can be Ad hoc Routed from the Event.
public bool CanAdhocRouteFrom;

// Provides an indication regarding whether or not Packages can be Ad-hoc Routed from the Event.
public bool CanAdhocRouteFrom;

// Indicates whether or not this TemplateID has associated Start Events.
public bool HasStartEvents;

// Boolean property indicating whether or not an error occurred during the Web Service method call.
public bool HasAcordeError;

// Information describing any errors that occurred during the Web Service method call.
public string AcordeErrorMessage;

Associated Methods:

PackageTemplateStartEventsArray GetPackageTemplateIdStartEventsSingle(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplate objPackageTemplate)

PackageTemplateStartEventsArray GetPackageTemplateIdStartEventsByTemplateId(string AIID, string strTemplateId)

PackageTemplateStartEventsArray GetPackageTemplateIdStartEventsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplatesArray objPackageTemplatesArray)

PackageTemplateStartEventsArray GetPackageTemplateNameStartEventsSingle(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplate objPackageTemplate)

PackageTemplateStartEventsArray GetPackageTemplateNameStartEventsByTemplateName(string AIID, string strTemplateName)

PackageTemplateStartEventsArray GetPackageTemplateNameStartEventsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplatesArray objPackageTemplatesArray)


PackageTemplateStartEventsArray

The PackageTemplateStartEvent object represents the list of Start Events that can be used to place a created Package into a Process flow.

public class PackageTemplateStartEvents {

Properties:

// Collection of PackageTemplateStartEvents objects
public PackageTemplateStartEvents[] StartEvents;

Associated Methods:

PackageTemplateStartEventsArray GetPackageTemplateIdStartEventsSingle(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplate objPackageTemplate)

PackageTemplateStartEventsArray GetPackageTemplateIdStartEventsByTemplateId(string AIID, string strTemplateId)

PackageTemplateStartEventsArray GetPackageTemplateIdStartEventsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplatesArray objPackageTemplatesArray)

PackageTemplateStartEventsArray GetPackageTemplateNameStartEventsSingle(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplate objPackageTemplate)

PackageTemplateStartEventsArray GetPackageTemplateNameStartEventsByTemplateName(string AIID, string strTemplateName)

PackageTemplateStartEventsArray GetPackageTemplateNameStartEventsMultiple(string AIID, AcordeWebCS.Acorde2Objects.PackageTemplatesArray objPackageTemplatesArray)


PlacePackagesInFlow

The PlacePackagesInFlow object returns information regarding the success or failure from placing a Package in the flow.

public class PlacePackagesInFlow {

Properties:

// Represents the numeric identifier for this copy of the package.
public int PkgRecId;

//
public int RequestIndex;

// Boolean property that indicates whether or not the particular Package was placed into the flow.
public bool WasPlacedInFlow;

// Boolean property indicating whether or not an error occurred during the Web Service method call.
public bool HasAcordeError;

// Information describing any errors that occurred during the Web Service method call.
public string AcordeErrorMessage;

Associated Methods:

PlacePackagesInFlowArray PlacePackagesInFlow((string AIID, AcordeWebCS.Acorde2Objects.PlacePackagesInFlowRequestArray objPPIFR)


PlacePackagesInFlowArray

The PlacePackagesInFlowArray object contains a collection of PlacePackagesInFlow objects. A PlacePackagesInFlow object returns information regarding the success or failure of placing a Package in the flow. This occurs for each Package in the PlacePackagesInFlowRequestArray object passed into the PlacePackagesInFlow IBPM Web Services method.

public class PlacePackagesInFlowArray {

Properties:

// Collection of PlacePackagesInFlow objects
public PlacePackagesInFlow[] PackagesInFlow; }

Associated Methods:

PlacePackagesInFlowArray PlacePackagesInFlow((string AIID, AcordeWebCS.Acorde2Objects.PlacePackagesInFlowRequestArray objPPIFR)


PlacePackagesInFlowRequest

The PlacePackagesInFlowRequest object contains information for placing a package or group of packages into the flow via the PlacePackagesInFlow IBPM Web Service method.

public class PlacePackagesInFlowRequest {

Properties:

// Represents the numeric identifier for this copy of the package.
public int PkgRecId;

// The name of the associated Process
public string ProcessName;

// The Start Event into which the package is to be placed
public string StartEvent;

// A String that will be added to the package's audit trail
public string Comment;

// Represents the package's current priority.
public int Priority;

Associated Methods:

PlacePackagesInFlowArray PlacePackagesInFlow((string AIID, AcordeWebCS.Acorde2Objects.PlacePackagesInFlowRequestArray objPPIFR)


PlacePackagesInFlowRequestArray

The PlacePackagesInFlowRequestArray object contains a collection of PlacePackagesInFlowRequest objects. A PlacePackagesInFlowRequest object contains information for placing a package or group of packages into the flow via the PlacePackagesInFlow IBPM Web Service method.

public class PlacePackagesInFlowRequestArray {

Properties:

// Collection of PlacePackagesInFlowRequest objects
public PlacePackagesInFlowRequest[] PlacePackagesInFlowRequests;

Associated Methods:

PlacePackagesInFlowArray PlacePackagesInFlow((string AIID, AcordeWebCS.Acorde2Objects.PlacePackagesInFlowRequestArray objPPIFR)


ProcessOperator

The ProcessOperator object contains all available operators for a prompt object.

public class ProcessOperator {

Properties:

// Specifies the Operator Type.
public int Type;

// The display value of the Operator.
public string Display;

// A string value containing the description of the operator.
public string Description;


ProcessOperatorArray

The ProcessOperatorArray object contains a collection of ProcessOperator objects. This object contains all available operators for a prompt object.

public class ProcessOperatorArray {

Properties:

// Collection of ProcessOperator objects
public ProcessOperator[] Operators;


ProcessPrompt

Represents a prompt field for a specific Profile. This object is included in the PromptedProfile object.

public class ProcessPrompt {

Properties:

// Uniquely identifies a field within a given Package.
public int FieldId;

// This property is an enumeration that identifies the type of the FieldDefinition that has been associated with the PromptCriterion.
public int FieldType;

// Represents the text used to identify what field information is needed to be entered.
public string DisplayText;

// Object containing information about the operator for this prompt field.
public ProcessOperator Operator;

// Object containing all available operators for this prompt field.
public ProcessOperatorArray AvailableOperators;

// Specifies whether or not the prompt information is required in order to execute the profile, as configured within the PromptCriterion.
public bool Required;

// Specifies whether or not the pick list values can be used to enter the prompt information for the profile, as configured within the PromptCriterion.
public bool UserPicklist;

// Specifies whether or not the distinct list values can be used to enter the prompt information for the profile, as configured within the PromptCriterion.
public bool UseDistinctList;

// The name of the associated Distinct List.
public string DistinctListName;

// The name of the associated pick list, if any.
public string PicklistName;

// The value of the prompt field.
public string Value;


Profile

The Profile object represents a single named profile.

public class Profile {

Properties:

// Indicates if the profile has prompts
public bool HasPrompts;

//
public bool LastUsed;

// This property is a number that identifies the Profile Id to which the profile can filter on.
public int ProfileId;

// Provides the textual name of the named Profile.
public string ProfileName;

// This property is a enumeration that identifies the ProfileType for the profile.
public int ProfileType;

Associated Methods:

ProfileArray GetAvailableProcessProfiles(string AIID)

PromptedProfileArray GetProfilePrompts(string AIID, AcordeWebCS.Acorde2Objects.ProfileArray ProfileArray)


ProfileArray

The ProfileArray object contains a collection of Profile objects. Each Profile object represents a single named profile.

public class ProfileArray {

Properties:

// Collection of Profile objects
public Profile[] Profiles;

Associated Methods:

ProfileArray GetAvailableProcessProfiles(string AIID)

PromptedProfileArray GetProfilePrompts(string AIID, AcordeWebCS.Acorde2Objects.ProfileArray ProfileArray)


PromptedProfile

The PromptedProfile object contains information describing a Prompted Profile in in BPM.

public class PromptedProfile {

Properties:

// Indicates if the profile has prompts.
public bool HasPrompts;

// This property is a number that identifies the Profile Id to which the profile can filter on.
public int ProfileId;

// Provides the textual name of the named Profile.
public string ProfileName;

// An object containing a collection of Prompts objects.
public ProcessPrompt[] Prompts;

Associated Methods:

PromptedProfileArray GetProfilePrompts(string AIID, AcordeWebCS.Acorde2Objects.ProfileArray ProfileArray)


PromptedProfileArray

The PromptedProfileArray object contains a collection of PromptedProfile objects. Each PromptedProfile object contains information describing a Prompted Profile in BPM.

public class PromptedProfileArray {

Properties:

// Collection of PromptedProfile objects
public PromptedProfile[] Profile;

Associated Methods:

PromptedProfileArray GetProfilePrompts(string AIID, AcordeWebCS.Acorde2Objects.ProfileArray ProfileArray)


SavedSearchName

A SavedSearchName object contains the Name of a Saved Search.

public class SavedSearchName {

Properties:

// The Name of a Saved Search.
public string Name;

Associated Methods:

SavedSearchNamesArray GetAvailableSavedSearches(string AIID)

SavedSearchPromptsArray GetSavedSearchPromptsMultiple(string AIID, AcordeWebCS.Acorde2Objects.SavedSearchNamesArray objSavedSearchNameArray)

SavedSearchPromptsArray GetSavedSearchPropertiesMultiple(string AIID, AcordeWebCS.Acorde2Objects.SavedSearchNamesArray objSavedSearchNameArray)


SavedSearchNameArray

The SavedSearchNamesArray object contains a collection of SavedSearchName objects. A SavedSearchName object contains the Name of a Saved Search. The SavedSavedSearchNamesArray object is used to provide a list of Saved Searches available for a particular user.

public class SavedSearchNameArray {

Properties:

// Collection of SavedSearchName objects
public SavedSearchName[] SearchName;

Associated Methods:

SavedSearchNamesArray GetAvailableSavedSearches(string AIID)

SavedSearchPromptsArray GetSavedSearchPromptsMultiple(string AIID, AcordeWebCS.Acorde2Objects.SavedSearchNamesArray objSavedSearchNameArray)

SavedSearchPromptsArray GetSavedSearchPropertiesMultiple(string AIID, AcordeWebCS.Acorde2Objects.SavedSearchNamesArray objSavedSearchNameArray)


SavedSearchPrompt

A SavedSearchPrompt object is used to provide search criteria when executing a Saved Search via an IBPM Web Service call.

public class SavedSearchPrompt {

Properties:

// The Name of a Saved Search.
public string SearchName;

// Represents the numeric identifier of the FieldDefinition that has been associated with the PromptCriterion.
public string FieldId;

// The type of the field that the prompt row corresponds to.
public int FieldType;

// Represents the text used to identify what field information is needed to be entered.
public string DisplayText;

// Sets the operator for to the Prompt.
public int Operator;

// A string containing a delimited list of available operators for this prompt.
public string Operators;

// Specifies whether or not the prompt information is required in order to execute the profile, as configured within the PromptCriterion.
public bool IsRequired;

// Specifies whether or not the pick list values can be used to enter the prompt information for the profile, as configured within the PromptCriterion.
public bool UsePicklist;

// The name of the associate picklist, if any.
public string PickListName;

// The value of the prompt.
public string Value;

// Boolean property indicating whether or not an error occurred during the Web Service method call.
public bool HasAcordeError;

// Information describing any errors that occurred during the Web Service method call.
public string AcordeErrorMessage;

Associated Methods:

SavedSearchPromptsArray GetSavedSearchPromptsBySearchName(string AIID, string strSearchName)

SavedSearchPromptsArray GetSavedSearchPromptsSingle(string AIID, AcordeWebCS.Acorde2Objects.SavedSearchName objSavedSearchName)

SavedSearchResultsArray BeginSavedSearch(string AIID, string strSearchName, AcordeWebCS.Acorde2Objects.SavedSearchPromptsArray objSSPA, int nPageSize)


SavedSearchPromptsArray

The SavedSearchPromptsArray object contains a collection of SavedSearchPrompt objects. A SavedSearchPrompt object is used to provide search criteria when executing a Saved Search via an IBPM Web Service call.

public class SavedSearchPromptsArray {

Properties:

// Collection of SavedSearchPrompt objects
public SavedSearchPrompt[] Prompts;

Associated Methods:

SavedSearchPromptsArray GetSavedSearchPromptsBySearchName(string AIID, string strSearchName)

SavedSearchPromptsArray GetSavedSearchPromptsSingle(string AIID, AcordeWebCS.Acorde2Objects.SavedSearchName objSavedSearchName)

SavedSearchResultsArray BeginSavedSearch(string AIID, string strSearchName, AcordeWebCS.Acorde2Objects.SavedSearchPromptsArray objSSPA, int nPageSize)


SavedSearchPropertiesArray

The SavedSearchPropertiesArray object contains a collection of SavedSearchProperty objects. A SavedSearchProperty object contains information that describes a specific Imaging Saved Search.

public class SavedSearchPropertiesArray {

Properties:

// Collection of SavedSearchProperty objects
public SavedSearchProperty[] Properties;

Associated Methods:

SavedSearchPropertiesArray GetSavedSearchPropertiesBySearchName(string AIID, string strSearchName)

SavedSearchPropertiesArray GetSavedSearchPropertiesSingle(string AIID, AcordeWebCS.Acorde2Objects.SavedSearchName objSavedSearchName)

SavedSearchPropertiesArray GetSavedSearchPropertiesMultiple(string AIID, AcordeWebCS.Acorde2Objects.SavedSearchNamesArray objSavedSearchNameArray)


SavedSearchProperty

A SavedSearchProperty object contains information which describes a specific Imaging Saved Search.

public class SavedSearchProperty {

Properties:

// The Name of a Saved Search.
public string Name;

// Determines if the Search is offline.
public bool OffLine;

// Future Use.
public bool BatchQuery;

// Future Use.
public bool ColumnsMerged;

// Indicates whether the rows in the result returned by the Saved Search should be distinct rows.
public bool RowsDistinct;

// The maximum duration the named query will be allowed to execute before timing out.
public int MaxExecTime;

// Future Use.
public bool MaxRunTime;

// Indicates the maximum number of rows that the named query will be allowed to return.
public int MaxRows;

// The count of records returned before auto pause is engaged.
public int int AutoPauseCnt;

// Boolean property indicating whether or not an error occurred during the Web Service method call.
public bool HasAcordeError;

// Information describing any errors that occurred during the Web Service method call.
public string AcordeErrorMessage;

Associated Methods:

SavedSearchPropertiesArray GetSavedSearchPropertiesBySearchName(string AIID, string strSearchName)

SavedSearchPropertiesArray GetSavedSearchPropertiesSingle(string AIID, AcordeWebCS.Acorde2Objects.SavedSearchName objSavedSearchName)

SavedSearchPropertiesArray GetSavedSearchPropertiesMultiple(string AIID, AcordeWebCS.Acorde2Objects.SavedSearchNamesArray objSavedSearchNameArray)


SavedSearchResult

A SavedSearchResult object contains information that describes an individual row in the result set returned from executing an Imaging Saved Search. The data in this object provides information regarding the status of the Saved Search, the System Fields object containing data that uniquely identifies an IBPM document, and a UserDefinedFields collection that lists the name and values for each column in the row result.

public class SavedSearchResult {

Properties:

//
public bool IsData;

// This property indicates whether or not the particular row result has been selected. This value equates to the status of the check box that appears in each row result in the IBPM Web Query Results tool. When passing in a SavedSearchResult object as an input parameter for IBPM Web Service methods, such as Exporting, only objects with an IsSelected value equal to true will have the associated operation performed.
public bool IsSelected;

// Enumeration describing the current status of the Search. Processing(1), Complete(2), Error(4), No Connection(8), No Query(16), Query Stopped(32).
public int SearchStatus;

// The Search Connection ID from the original results set obtained from BeginSavedSearch. The SearchConnectionId property can be used to restore a connection with the Search Manager Server without the expense of establishing a completely new connection. The Search Manager Server keeps a query connection open until QueryConnectionManager.DestoryConnection is called or the connection times out. While the Search Manager Server connection is open, the results of any open query is cached.

public string SearchConnectionId;

// Object that contains System Field information used to uniquely identify Imaging documents.
public SystemFields SystemFields;

//
public UserDefinedField[] UserDefinedFieldValues;

Associated Methods:

ExportResultsArray ExportFromSearchResults(string AIID, Acorde2Objects.SavedSearchResultsArray objSSRA)

ExportResultsArray ExportFromSearchResultsEx(string AIID, Acorde2Objects.SavedSearchResultsArray objSSRA, int intDPI, int intType, string strNameSpace, int intScale, bool boolHighestResolution)

SavedSearchResultsArray BeginSavedSearch(string AIID, string strSearchName, AcordeWebCS.Acorde2Objects.SavedSearchPromptsArray objSSPA, int nPageSize) SavedSearchResultsArray ContinueSavedSearchBySearchConnectionID(string AIID, string strSearchConnectionID)


SavedSearchResultsArray

The SavedSearchResultsArray object contains a collection of SavedSearchResult objects. A SavedSearchResult object contains information that describes an individual row in the result set returned from executing an Imaging Saved Search. The data in this object provides information regarding the status of the Saved Search, the System Fields object containing data that uniquely identifies an IBPM document, and a UserDefinedFields collection that lists the name and values for each column in the row result.

public class SavedSearchResultsArray {

Properties:

// Collection of SavedSearchResult objects. Each SavedSearchResult represents a single row in the result set.
public SavedSearchResult[] SearchResults;

// Describes the fields for each row in the result set. This object is for internal use, but the data may still be accessed.
public UserDefinedFieldDefinitionArray FieldDefinitions;}

Associated Methods:

ExportResultsArray ExportFromSearchResults(string AIID, Acorde2Objects.SavedSearchResultsArray objSSRA)

ExportResultsArray ExportFromSearchResultsEx(string AIID, Acorde2Objects.SavedSearchResultsArray objSSRA, int intDPI, int intType, string strNameSpace, int intScale, bool boolHighestResolution)

SavedSearchResultsArray BeginSavedSearch(string AIID, string strSearchName, AcordeWebCS.Acorde2Objects.SavedSearchPromptsArray objSSPA, int nPageSize) SavedSearchResultsArray ContinueSavedSearchBySearchConnectionID(string AIID, string strSearchConnectionID)


SavedSearchStop

A SavedSearchStop object returns information describing whether or not a Saved Search was halted via the a StopSavedSearch IBPM Web Service method.

public class SavedSearchStop {

Properties:

// The Search Connection ID from the original results set obtained from BeginSavedSearch. The SearchConnectionId property can be used to restore a connection with the Search Manager Server without the expense of establishing a completely new connection. The Search Manager Server keeps a query connection open until QueryConnectionManager.DestoryConnection is called or the connection times out. While the Search Manager Server connection is open, the results of any open query is cached.
public string SearchConnectionID;

// Returns whether or not the Search has been stopped.
public bool Succeeded;

// Boolean property indicating whether or not an error occurred during the Web Service method call
public bool HasAcordeError;

// Information describing any errors that occurred during the Web Service method call
public string AcordeErrorMessage;

Associated Methods:

SavedSearchStopArray StopSavedSearchBySearchConnectionID(string AIID, string strSearchConnectionID)

SavedSearchStopArray StopSavedSearchMultiple(string AIID, string[] arrSearchConnectionID)


SavedSearchStopArray

The SavedSearchStopArray object contains a collection of SavedSearchStop objects. A SavedSearchStop object returns information describing whether or not a Saved Search was halted via the a StopSavedSearch IBPM Web Service method.

public class SavedSearchStopArray {

Properties:

// Collection of SavedSearchStop objects
public SavedSearchStop[] StopSearches;

Associated Methods:

SavedSearchStopArray StopSavedSearchBySearchConnectionID(string AIID, string strSearchConnectionID)

SavedSearchStopArray StopSavedSearchMultiple(string AIID, string[] arrSearchConnectionID)


SystemFields

Object which contains System Field information used to uniquely identify Imaging documents. (LUCID, MIMETYPE, SSPROVIDERID, TABLENAME, INDEXPROVIDER, ROWIDENTIFIER, FTSFILTERS) The SystemFields object is contained in a SavedSearchResult object. SystemField objects are used internally in conjunction with the Export, Create Packages, Package Attachment, and Search Results operations.

public class SystemFields {

Properties:

// A string value containing a unique key to the stored item. (Known as the UniqueID or RECID in the Imaging SDK.)
public string LUCID;

// A String value containing an indicator of the document type contained within the entity.
public string MIMETYPE;

// A String value containing a GUID key which identifies the system managing the storage of the entity. Default is {0BF3C340-4C13-11d3-8166-00C04F99E979}.
public string SSPROVIDERID;

// A String value which uniquely identifies the index definition or schema into which the index values are stored. The table name must be fully qualified. (case-sensitive)
public string TABLENAME;

// A String value containing a unique key to the index values. The actual value depends upon the requirements of the system managing the index. It is only necessarily unique within the Index definition identified by the IndexName property.
public string ROWIDENTIFIER;

// A String value containing a GUID key which identifies the system managing the index of the entity.
public string INDEXPROVIDER;

// Future Use.
public string FTSFILTERS;


UserDefinedField

This object contains name/value pairs that represent the columns and columns values for a single row result contained in search results obtained from executing a Saved Search via IBPM Web Service search methods.

public class UserDefinedField {

Properties:

// The name of the field.
public string Name;

// The value of the field.
public string Value;


UserDefinedFieldDefinition

Describes the fields for each row in the result set obtained from executing a Saved Search. This object is for internal use, but the data may still be accessed.

public class UserDefinedFieldDefinition {

Properties:

// The name of the field.
public string Name;

// Internal Use.
public UserDefinedField[] AttributeTypeNode;

// Internal Use.
public UserDefinedField[] DataTypeNode;


UserDefinedFieldDefinitionarray

Describes the fields for each row in the result set obtained from executing a Saved Search. This object is for internal use, but the data may still be accessed.

public class UserDefinedFieldDefinitionArray {

Properties:

// Collection of UserDefinedFieldDefinition objects
public UserDefinedFieldDefinition[] FieldDefinitions;


GetApplicationFieldsForCreateDocument Method

DeleteDocument Method

This web service allows the web service client to delete a single document from the Imaging system. The specified document will be deleted. A return a true will indicate the document has been deleted from the Imaging system. This feature is only available through the Acorde2.asmx interface and uses the Oracle Web Support Server to accomplish the delete of the document. This requires that you connect to WSS during your login to the web services. During the login you must use the "WSSCONNECT" style to connect to WSS.

When using the Interface(s): Acorde2.asmx

Syntax

object.DeleteDocument(xmlAIID As String, LUCID As Integer )

Parameters

Part | Description
xmlAIID | A well formed AIID (IBPM Infrastructure Initialization Document). The information in this XML Document will allow this call to re-connect to the IBPM System.
LUCID | A document identifier for a document in the IBPM system..

Return Type

Boolean - True indicates the document was deleted and false indicates the document could not be deleted..