Workspace User’s Guide, 9.3.1

Copyright © 1989, 2007, Oracle and/or its affiliates. All rights reserved.

Authors: Emilio Esposito, Sigrid Perry, Daniel Montagne, Angela Vermeer, Emily Hamer, Louise Hodgins

The Programs (which include both the software and documentation) contain proprietary information; they are provided under a license agreement containing restrictions on use and disclosure and are also protected by copyright, patent, and other intellectual and industrial property laws. Reverse engineering, disassembly, or decompilation of the Programs, except to the extent required to obtain interoperability with other independently created software or as specified by law, is prohibited.

The information contained in this document is subject to change without notice. If you find any problems in the documentation, please report them to us in writing. This document is not warranted to be error-free. Except as may be expressly permitted in your license agreement for these Programs, no part of these Programs may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose.

If the Programs are delivered to the United States Government or anyone licensing or using the Programs on behalf of the United States Government, the following notice is applicable:

U.S. GOVERNMENT RIGHTS Programs, software, databases, and related documentation and technical data delivered to U.S. Government customers are “commercial computer software” or “commercial technical data” pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As such, use, duplication, disclosure, modification, and adaptation of the Programs, including documentation and technical data, shall be subject to the licensing restrictions set forth in the applicable Oracle license agreement, and, to the extent applicable, the additional rights set forth in FAR 52.227-19, Commercial Computer Software--Restricted Rights (June 1987). Oracle USA, Inc., 500 Oracle Parkway, Redwood City, CA 94065.

The Programs are not intended for use in any nuclear, aviation, mass transit, medical, or other inherently dangerous applications. It shall be the licensee’s responsibility to take all appropriate fail-safe, backup, redundancy and other measures to ensure the safe use of such applications if the Programs are used for such purposes, and we disclaim liability for any damages caused by such use of the Programs.

Oracle is a registered trademark of Oracle Corporation and/or its affiliates. Other names may be trademarks of their respective owners.

The Programs may provide links to Web sites and access to content, products, and services from third parties. Oracle is not responsible for the availability of, or any content provided on, third-party Web sites. You bear all risks associated with the use of such content. If you choose to purchase any products or services from a third party, the relationship is directly between you and the third party. Oracle is not responsible for: (a) the quality of third-party products or services; or (b) fulfilling any of the terms of the agreement with the third party, including delivery of products or services and warranty obligations related to purchased products or services. Oracle is not responsible for any loss or damage of any sort that you may incur from dealing with any third party.
## Chapter 1. Using Workspace

- About Hyperion ........................................... 25
- About Workspace .......................................... 26
- Preparing to Use Workspace ............................ 26
- Workspace Documentation Set ............................ 27
- Deployment Workflow ..................................... 27
- Workspace .................................................. 28
- Workspace Capabilities .................................. 28
  - Modules Used to Perform Tasks ...................... 29
  - Accessing Items from Navigate ....................... 29
  - Using View Pane Buttons ............................... 29
  - User Types and Tasks ................................... 30
- Module Tasks .............................................. 30
- Workspace User Interface ............................... 30
- Reporting and Analysis Repository .................... 31
  - Actions .................................................. 32
  - Locations .............................................. 32
  - File Permissions ....................................... 32
- Logging on to Workspace ................................ 33
- Setting Preferences ..................................... 33
- Using Data Source Elements for Reporting and Analysis .......................... 34
  - Web Analysis Studio .................................. 35
  - Financial Reporting Studio ............................ 35
  - Interactive Reporting Studio .......................... 35
  - Production Reporting Studio .......................... 35
  - Analytic Services Features Available to the Studios ........................................ 36
  - Financial Management Features Available to the Studios ................................. 36
  - Planning Details as a Database Connection ............ 37
- SAP BW Data Sources .................................. 37
  - SAP BW Features ....................................... 37
  - SAP BW Prerequisites .................................. 37
<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>4</td>
<td>Importing Artifacts</td>
<td>107</td>
</tr>
<tr>
<td></td>
<td>Importing</td>
<td>107</td>
</tr>
<tr>
<td></td>
<td>Interactive Reporting Documents and Jobs</td>
<td>108</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
<td></td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
<td></td>
</tr>
<tr>
<td>Pushing Items to Favorites</td>
<td>127</td>
<td></td>
</tr>
<tr>
<td>Managing Favorites</td>
<td>129</td>
<td></td>
</tr>
<tr>
<td>Using Subscriptions</td>
<td>129</td>
<td></td>
</tr>
<tr>
<td>Creating a Subscription</td>
<td>129</td>
<td></td>
</tr>
<tr>
<td>Modifying or Removing Subscriptions</td>
<td>131</td>
<td></td>
</tr>
<tr>
<td>Subscribing to Folders</td>
<td>131</td>
<td></td>
</tr>
<tr>
<td>Receiving and Viewing Subscriptions</td>
<td>132</td>
<td></td>
</tr>
<tr>
<td>Using Personal Pages</td>
<td>132</td>
<td></td>
</tr>
<tr>
<td>Customizing Personal Page Content</td>
<td>135</td>
<td></td>
</tr>
<tr>
<td>Adding or Removing Personal Page Contents</td>
<td>135</td>
<td></td>
</tr>
<tr>
<td>Displaying HTML Content on Personal Pages</td>
<td>135</td>
<td></td>
</tr>
<tr>
<td>Embedding Interactive Reporting Document Sections in Personal Pages</td>
<td>136</td>
<td></td>
</tr>
<tr>
<td>Creating Bookmarks</td>
<td>138</td>
<td></td>
</tr>
<tr>
<td>Adding URL Bookmarks from Personal Pages</td>
<td>139</td>
<td></td>
</tr>
<tr>
<td>Using Exceptions</td>
<td>140</td>
<td></td>
</tr>
<tr>
<td>Modifying the Layout of a Personal Page</td>
<td>143</td>
<td></td>
</tr>
<tr>
<td>Changing the Colors on a Personal Page</td>
<td>144</td>
<td></td>
</tr>
<tr>
<td>Working With Personal Pages</td>
<td>144</td>
<td></td>
</tr>
<tr>
<td>Creating a Personal Page</td>
<td>144</td>
<td></td>
</tr>
<tr>
<td>Copying a Personal Page</td>
<td>146</td>
<td></td>
</tr>
<tr>
<td>Deleting Personal Pages</td>
<td>146</td>
<td></td>
</tr>
<tr>
<td>Publishing and Replacing Personal Pages</td>
<td>146</td>
<td></td>
</tr>
</tbody>
</table>

**Chapter 6. Launching Applications**

- Launching Oracle's Hyperion Applications ........................................ 149

**Chapter 7. Using Performance Scorecard**

- Overview ......................................................................................... 151
- Launching the Scorecard Module .................................................. 152
- Viewing Scorecards ........................................................................ 153
- Viewing Maps in Scorecard ............................................................ 154
- Viewing Accountability Maps .......................................................... 154
- Viewing Strategy Trees ................................................................. 156
- Viewing Strategy Maps ...................................................................... 157
- Exporting Scorecards to Excel ......................................................... 159
- Exporting Strategy Maps ................................................................... 159
- Printing Scorecards and Maps .......................................................... 160
- Setting the Default Workspace Start Page ........................................ 160
Chapter 10. Interactive Reporting ........................................... 197

Using Interactive Reporting Documents in Workspace ................. 197
Using the Toolbars .................................................................. 198
  Standard Toolbar .......................................................... 198
  Standard Interactive Reporting Toolbar .............................. 198
  Navigation Toolbar ....................................................... 200
  Paging Toolbar ............................................................ 200
  Shortcut Menus ................................................................ 200
  Alert Dialog .................................................................... 201

Interacting with Interactive Reporting Documents ...................... 201
Understanding Interactive Reporting Document Files .................. 201
Creating An Interactive Reporting Document File (BQY) From Another Interactive
Reporting Document File (BQY) .................................................. 201
Interactive Reporting Database Connection File (OCE) Selection For Interactive
Reporting Document (BQYs) .................................................... 202
Selecting an Interactive Reporting Data Source ........................ 203
Accessing Interactive Reporting Document Files ......................... 204
Saving Interactive Reporting Document Files ............................ 204
  Saving an Interactive Reporting Document Files .................. 205
  Using the Save Command ............................................... 205
  Using the Save As Command ........................................... 205

Working with Interactive Reporting Document File Sections ........... 206
  Sections Pane .................................................................. 206
  Selecting Interactive Reporting Document File Sections ............ 207
  Adding Sections ............................................................ 207
  Moving Between Sections ............................................... 208
  Duplicating Sections ..................................................... 208
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Renaming Sections</td>
<td>208</td>
</tr>
<tr>
<td>Deleting Sections</td>
<td>209</td>
</tr>
<tr>
<td>Dashboard Home</td>
<td>209</td>
</tr>
<tr>
<td>Refreshing Interactive Reporting Document File Sections</td>
<td>209</td>
</tr>
<tr>
<td>Printing Sections</td>
<td>210</td>
</tr>
<tr>
<td>Exporting Data</td>
<td>210</td>
</tr>
<tr>
<td>Exporting a Section as a PDF</td>
<td>210</td>
</tr>
<tr>
<td>Exporting a Section to MS Excel (.XLS)</td>
<td>211</td>
</tr>
<tr>
<td>Exporting an Interactive Reporting Document File in Native File Format</td>
<td>212</td>
</tr>
<tr>
<td>Query Section</td>
<td>212</td>
</tr>
<tr>
<td>Interactive Reporting Database Connection Files (OCEs)</td>
<td>213</td>
</tr>
<tr>
<td>Data Model</td>
<td>213</td>
</tr>
<tr>
<td>Topics and Topic Items</td>
<td>214</td>
</tr>
<tr>
<td>Query Restrictions</td>
<td>214</td>
</tr>
<tr>
<td>Inserting a New Query</td>
<td>214</td>
</tr>
<tr>
<td>Working with Queries</td>
<td>215</td>
</tr>
<tr>
<td>Building Queries</td>
<td>215</td>
</tr>
<tr>
<td>Working with Items on the Request Pane</td>
<td>216</td>
</tr>
<tr>
<td>Adding Request Items</td>
<td>217</td>
</tr>
<tr>
<td>Removing Request Items</td>
<td>217</td>
</tr>
<tr>
<td>Picture (BLOB Image) Support</td>
<td>217</td>
</tr>
<tr>
<td>Adding Pictures in Query</td>
<td>217</td>
</tr>
<tr>
<td>Working with Pictures in Results and Tables</td>
<td>218</td>
</tr>
<tr>
<td>Adding Pictures in Computed Items</td>
<td>218</td>
</tr>
<tr>
<td>Working with Pictures in Reports</td>
<td>218</td>
</tr>
<tr>
<td>Adding a Computed Item in Query</td>
<td>218</td>
</tr>
<tr>
<td>Adjusting Data Types</td>
<td>219</td>
</tr>
<tr>
<td>Operators</td>
<td>220</td>
</tr>
<tr>
<td>Arithmetic Operators</td>
<td>221</td>
</tr>
<tr>
<td>Comparison Operators</td>
<td>222</td>
</tr>
<tr>
<td>Statements</td>
<td>223</td>
</tr>
<tr>
<td>Logical Operators</td>
<td>223</td>
</tr>
<tr>
<td>Reference</td>
<td>224</td>
</tr>
<tr>
<td>Computed Items and Data Functions</td>
<td>224</td>
</tr>
<tr>
<td>Data Functions</td>
<td>224</td>
</tr>
<tr>
<td>Applying A Query Filter</td>
<td>226</td>
</tr>
<tr>
<td>Variable Filters</td>
<td>227</td>
</tr>
<tr>
<td>Applying Query Sorts</td>
<td>228</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Refreshing a Query</td>
<td>229</td>
</tr>
<tr>
<td>Results and Tables</td>
<td>229</td>
</tr>
<tr>
<td>Adding a Table</td>
<td>230</td>
</tr>
<tr>
<td>Working with Columns and Rows</td>
<td>230</td>
</tr>
<tr>
<td>Adding a Column</td>
<td>230</td>
</tr>
<tr>
<td>Deleting a Column</td>
<td>231</td>
</tr>
<tr>
<td>AutoSizing Columns</td>
<td>231</td>
</tr>
<tr>
<td>Deleting a Row</td>
<td>231</td>
</tr>
<tr>
<td>Sorting Results/Table Items</td>
<td>231</td>
</tr>
<tr>
<td>Number Formatting</td>
<td>232</td>
</tr>
<tr>
<td>Applying a Results and Table Filter</td>
<td>233</td>
</tr>
<tr>
<td>Show Values</td>
<td>234</td>
</tr>
<tr>
<td>Custom Values</td>
<td>235</td>
</tr>
<tr>
<td>Custom SQL</td>
<td>236</td>
</tr>
<tr>
<td>Modifying Filters</td>
<td>236</td>
</tr>
<tr>
<td>Deleting Filters</td>
<td>237</td>
</tr>
<tr>
<td>Results and Table Totals</td>
<td>237</td>
</tr>
<tr>
<td>Calculating a Grand Total for a Column</td>
<td>238</td>
</tr>
<tr>
<td>Calculating a Break Total for a Column</td>
<td>238</td>
</tr>
<tr>
<td>Adding Computed Items in Results and Tables</td>
<td>239</td>
</tr>
<tr>
<td>Adjusting Data Types</td>
<td>240</td>
</tr>
<tr>
<td>Paging Through Results Data</td>
<td>241</td>
</tr>
<tr>
<td>Chart Section</td>
<td>241</td>
</tr>
<tr>
<td>Understanding Chart Dimensions</td>
<td>241</td>
</tr>
<tr>
<td>Chart Data Layout Categories</td>
<td>242</td>
</tr>
<tr>
<td>Legends</td>
<td>243</td>
</tr>
<tr>
<td>Changing Chart Properties</td>
<td>244</td>
</tr>
<tr>
<td>Chart Types</td>
<td>244</td>
</tr>
<tr>
<td>Two-dimensional Chart Types</td>
<td>245</td>
</tr>
<tr>
<td>Pie Charts</td>
<td>245</td>
</tr>
<tr>
<td>Bar Charts</td>
<td>246</td>
</tr>
<tr>
<td>Scatter Charts</td>
<td>247</td>
</tr>
<tr>
<td>Bubble Charts</td>
<td>248</td>
</tr>
<tr>
<td>Multidimensional Chart Types</td>
<td>249</td>
</tr>
<tr>
<td>Viewing Three-dimensional Bar Charts</td>
<td>249</td>
</tr>
<tr>
<td>Clustered Bar Charts</td>
<td>249</td>
</tr>
<tr>
<td>Stacked Bar Charts</td>
<td>250</td>
</tr>
<tr>
<td>Area Charts</td>
<td>251</td>
</tr>
<tr>
<td>Stacked Area Charts</td>
<td>251</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Sorting OLAP Dimensions</td>
<td>269</td>
</tr>
<tr>
<td>Drilling into OLAP</td>
<td>269</td>
</tr>
<tr>
<td>Drilling up</td>
<td>270</td>
</tr>
<tr>
<td>OLAP Data Functions</td>
<td>270</td>
</tr>
<tr>
<td>CubeQuery Section</td>
<td>271</td>
</tr>
<tr>
<td>About Essbase</td>
<td>271</td>
</tr>
<tr>
<td>About Multidimensional Database</td>
<td>272</td>
</tr>
<tr>
<td>Definition of Multidimensional</td>
<td>272</td>
</tr>
<tr>
<td>Dimensions and Members</td>
<td>272</td>
</tr>
<tr>
<td>Non-aggregate Dimensions</td>
<td>273</td>
</tr>
<tr>
<td>Familial Relationships</td>
<td>273</td>
</tr>
<tr>
<td>Generations and Levels</td>
<td>274</td>
</tr>
<tr>
<td>Attributes</td>
<td>275</td>
</tr>
<tr>
<td>Catalog List</td>
<td>275</td>
</tr>
<tr>
<td>OLAPQuery and CubeQuery Data Layout Differences</td>
<td>275</td>
</tr>
<tr>
<td>Building a CubeQuery</td>
<td>276</td>
</tr>
<tr>
<td>DB Logon</td>
<td>277</td>
</tr>
<tr>
<td>Searching Members</td>
<td>277</td>
</tr>
<tr>
<td>Member Selection</td>
<td>278</td>
</tr>
<tr>
<td>Browsing Members</td>
<td>279</td>
</tr>
<tr>
<td>Substitution Variables</td>
<td>280</td>
</tr>
<tr>
<td>Variables</td>
<td>281</td>
</tr>
<tr>
<td>Searching Members</td>
<td>281</td>
</tr>
<tr>
<td>Filter Member Selection</td>
<td>282</td>
</tr>
<tr>
<td>Browsing Filter Members</td>
<td>282</td>
</tr>
<tr>
<td>Searching Filter Members</td>
<td>282</td>
</tr>
<tr>
<td>Navigating CubeQuery</td>
<td>283</td>
</tr>
<tr>
<td>Keep Only</td>
<td>284</td>
</tr>
<tr>
<td>Remove Only</td>
<td>284</td>
</tr>
<tr>
<td>Suppressing Missing and Zero Values</td>
<td>284</td>
</tr>
<tr>
<td>Drilling</td>
<td>285</td>
</tr>
<tr>
<td>Downloading to Results</td>
<td>287</td>
</tr>
<tr>
<td>Separate Columns for Metadata Labels</td>
<td>288</td>
</tr>
<tr>
<td>Measure Behavior in Columns and Rows</td>
<td>289</td>
</tr>
<tr>
<td>Ragged Hierarchies</td>
<td>290</td>
</tr>
<tr>
<td>Shared Members</td>
<td>291</td>
</tr>
<tr>
<td>Formatting CubeQuery Items</td>
<td>296</td>
</tr>
<tr>
<td>Query Options</td>
<td>296</td>
</tr>
<tr>
<td>Global Options</td>
<td>296</td>
</tr>
</tbody>
</table>
Chapter 11. Using SQR Production Reporting Documents

Viewing an SQR Production Reporting Document .......................... 301
Viewing Functionality for HTML Reports ................................. 302
Using the Navigation Bar .................................................. 302
   Exporting Report Information from the Navigation Bar .......... 303
   Using the Navigation Bar to Move Among Pages ................. 303
Navigating with the Table of Contents ................................ 304

Chapter 12. Using Web Analysis ............................................ 305

Presentations ............................................................... 306
   Presentation Access and File Permissions .......................... 306
   User and Group Permissions ........................................ 306
   Document and Folder References .................................. 306
   Benefits and Considerations ....................................... 307
   Reference Reconciliation ............................................ 307
Opening Presentations ..................................................... 307
   Notes on Opening Presentations .................................... 308
Closing Presentations ...................................................... 308
Web Analysis Documents .................................................. 309
Creating Web Analysis Documents ....................................... 309
Creating Documents from Documents .................................... 312
Modifying Queries ......................................................... 313
   Modifying Filter Dimensions ....................................... 314
Selecting Members .......................................................... 314
Advanced Member Selection ............................................... 315
   Advanced Member Selection by Data Source .................... 316
Searching for Members .................................................... 318
Searching for SAP BW Characteristics ................................. 319
Locating Members .......................................................... 320
Selecting Members Using Analytic Services Subsets ................. 320
   Wildcard Characters .................................................. 322
   Expressions ............................................................ 322
   UDAs ................................................................. 322
Selecting Financial Management User-Defined Fields ............... 322
Filtering by SAP BW Member Properties ........................................ 323
Using SAP BW Select Top/Bottom ................................................. 324
Selecting Financial Management Member Lists .......................... 325
Selecting Substitution Variables .................................................. 325
  Multiple Substitution Variables .............................................. 325
  Syntax Tips ........................................................................... 326
Analysis Tools and Substitution Variables ................................. 326
Selecting Personal Variables ....................................................... 326
Applying Point of View (POV) .................................................... 326
Defining Dynamic Time Series Selections ................................. 327
  Time Substitution Variables .................................................. 327
Defining Previous Member Selections ......................................... 328
Navigating Data Objects and Sources ....................................... 328
  Navigation Methods ................................................................ 329
  Repositioning Dimensions ..................................................... 330
Paging ....................................................................................... 330
  Pages .................................................................................... 330
  Multiple-Page and Single-Page List Boxes ............................... 331
Keep Only ................................................................................. 331
Remove Only ............................................................................. 331
Drilling ...................................................................................... 331
Drilling Options ......................................................................... 331
Expand on Drill .......................................................................... 332
Selected Member Data Display Option ...................................... 332
Drilling Variations ...................................................................... 333
Default Drilling Behavior .......................................................... 333
Drill-Linking .............................................................................. 333
Changing Display Types ............................................................ 334
  Data Display Options ............................................................ 334
  Saving Selections to the User POV .......................................... 335
Pinboards .................................................................................... 335
  Pinboards Prerequisites .......................................................... 335
  Pinboard Series ...................................................................... 335
  Pins ....................................................................................... 335
  Traffic-Lighting Control Panel ................................................ 336
SQL Spreadsheets ....................................................................... 336
Freeform Grids ........................................................................... 336
Resizing the Display .................................................................... 336
Managing Analysis Tools ............................................................ 337
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Minimum Value</td>
<td>352</td>
</tr>
<tr>
<td>Multiply</td>
<td>353</td>
</tr>
<tr>
<td>Percent</td>
<td>353</td>
</tr>
<tr>
<td>Percent Difference from Average</td>
<td>353</td>
</tr>
<tr>
<td>Percent of Difference</td>
<td>353</td>
</tr>
<tr>
<td>Percent of Member</td>
<td>354</td>
</tr>
<tr>
<td>Percent of Total</td>
<td>354</td>
</tr>
<tr>
<td>Rank Ascending and Rank Descending</td>
<td>354</td>
</tr>
<tr>
<td>Subtract</td>
<td>354</td>
</tr>
<tr>
<td>Sum</td>
<td>354</td>
</tr>
<tr>
<td>Trend</td>
<td>355</td>
</tr>
<tr>
<td>Variance</td>
<td>355</td>
</tr>
<tr>
<td>Variance Percent</td>
<td>355</td>
</tr>
<tr>
<td>Complex Calculations</td>
<td>355</td>
</tr>
<tr>
<td>Creating Calculations</td>
<td>356</td>
</tr>
<tr>
<td>Modifying Calculations</td>
<td>357</td>
</tr>
<tr>
<td>Analytic Services Attribute Calculations</td>
<td>357</td>
</tr>
<tr>
<td>Print as PDF from Workspace</td>
<td>358</td>
</tr>
<tr>
<td>Database Connections</td>
<td>359</td>
</tr>
<tr>
<td>Database Connection Files</td>
<td>359</td>
</tr>
<tr>
<td>Database Connection Access and Document Permissions</td>
<td>360</td>
</tr>
<tr>
<td>User and Group Permissions</td>
<td>360</td>
</tr>
<tr>
<td>Integrating OLAP and Relational Data</td>
<td>360</td>
</tr>
<tr>
<td>Analytic Services Database Connections</td>
<td>361</td>
</tr>
<tr>
<td>Restrict Data</td>
<td>361</td>
</tr>
<tr>
<td>Retrieve Only Top/Bottom</td>
<td>361</td>
</tr>
<tr>
<td>Edit Data</td>
<td>361</td>
</tr>
<tr>
<td>Suppress Missing Rows, Zeros, and Shared Members</td>
<td>362</td>
</tr>
<tr>
<td>Label Mode and Alias Tables</td>
<td>362</td>
</tr>
<tr>
<td>Analytic Services Drill Settings</td>
<td>362</td>
</tr>
<tr>
<td>Linked Reporting Objects (LROs)</td>
<td>362</td>
</tr>
<tr>
<td>Relational Drill-through</td>
<td>362</td>
</tr>
<tr>
<td>Analytic Integration Services Drill-through</td>
<td>362</td>
</tr>
<tr>
<td>Analytic Services Advanced Member Selection</td>
<td>363</td>
</tr>
<tr>
<td>Attribute Dimensions and Attribute Calculations</td>
<td>363</td>
</tr>
<tr>
<td>Financial Management</td>
<td>363</td>
</tr>
<tr>
<td>Financial Management Features Available in Web Analysis Documents</td>
<td>364</td>
</tr>
<tr>
<td>Related Content</td>
<td>364</td>
</tr>
<tr>
<td>Cell Text</td>
<td>364</td>
</tr>
</tbody>
</table>
Contents

Line-Item Detail ................................................................. 364
Related Content Changes ..................................................... 364
Organization by Period ....................................................... 365
Financial Management Advanced Member Selection .................. 365
User-Defined Fields ............................................................ 366
Display Entity Currency ....................................................... 366
Financial Management Conventions ....................................... 366
  No Drill To Top .................................................................. 366
  No Edit Data ..................................................................... 367
  Adding and Deleting Members ............................................ 367
  New Databases .................................................................. 367
  Deleted Users ................................................................... 367
SAP BW .................................................................................. 367
  SAP BW Prerequisites ....................................................... 367
  SAP BW Conventions ....................................................... 368
  SAP BW Advanced Member Selection .................................. 368
Relational Access .................................................................... 369
  Custom Document SQL Spreadsheet ..................................... 369
  Custom Document Freeform Grid ......................................... 369
  Relational Drill-through .................................................... 369
  Relational Database Connections ........................................ 370
  Analytic Integration Services Drill-through ........................... 370
  Repository ....................................................................... 370
  Controlling Query Result Set Size ...................................... 370
Custom Web Analysis Documents .......................................... 370
  Containers ....................................................................... 371
  Content Panels ............................................................... 371
  Data Objects ..................................................................... 371
  Subscription Controls ....................................................... 372
  SQL Spreadsheet and SQL Subscription ............................... 372
Linking Components by Query ............................................... 372
  Common Data Sources ...................................................... 373
  Unlinking Components ..................................................... 373
Linking Dimensions .............................................................. 373
Edit Data Mode ..................................................................... 373
Editing Data Values ............................................................... 374
Copying, Cutting, and Pasting To and From Excel ..................... 374
Tips for Edit Data Mode ......................................................... 374
In This Chapter

About Hyperion ................................................................................................................. 25
About Workspace ................................................................................................................ 26
Preparing to Use Workspace ............................................................................................... 26
Workspace Documentation Set ............................................................................................ 27
Deployment Workflow .......................................................................................................... 27
Workspace .......................................................................................................................... 28
Workspace Capabilities ....................................................................................................... 28
Module Tasks....................................................................................................................... 30
Workspace User Interface ................................................................................................... 30
Reporting and Analysis Repository ..................................................................................... 31
Logging on to Workspace .................................................................................................... 33
Setting Preferences ............................................................................................................. 33
Using Data Source Elements for Reporting and Analysis ................................................... 34
Using Smart View .............................................................................................................. 48
Personalizing Workspace .................................................................................................... 48
Toolbars .............................................................................................................................. 50
Menus ................................................................................................................................. 54
Shortcut Menu Commands ................................................................................................. 59

About Hyperion

Hyperion is a comprehensive Enterprise Performance Management (EPM) system that consists of these products:

- Oracle’s Hyperion® Workspace—Management reporting including query and analysis in one coordinated environment
- Oracle’s Hyperion® Application Builder.NET—Coordinated planning, consolidation, and scorecarding applications
- System 9 Foundation Services™—Used to ease installation and configuration, provide metadata management, and support a common Microsoft Office interface
About Workspace

Workspace is a DHTML-based, zero-footprint client that provides the user interface for viewing and interacting with content created using Oracle’s Hyperion® Reporting and Analysis – System 9 authoring studios and financial applications:

- Financial reporting for scheduled or on-demand highly formatted financial and operational reporting from most data sources including Oracle’s Hyperion® Planning – System 9 and Oracle’s Hyperion® Financial Management – System 9
- Interactive reporting for ad hoc relational queries, self-service reporting, and dashboards against ODBC data sources
- Production reporting for high volume enterprise-wide reporting
- Web analysis for interactive ad hoc analysis, presentation, and reporting of multidimensional data
- High performance multidimensional modeling, analysis, and reporting with Oracle’s Hyperion® Essbase® – System 9

Reporting and Analysis, which includes Essbase, is part of a comprehensive EPM system that integrates the business intelligence platform with financial applications, Oracle’s Hyperion® Smart View for Office, and Oracle’s Hyperion® Performance Scorecard – System 9.

Preparing to Use Workspace

Prior to using Workspace, familiarize yourself with your documentation set. See the Information Map from the Help menu.

Additional information that you need:

- Browser information—See the Hyperion Reporting and Analysis – System 9 Installation Guide for Windows or Unix.
- Workspace URL and domain
- User account – the user name and password assigned to you. See your system administrator.
- Logon information – “Logging on to Workspace” on page 33
- access permissions – “Toolbars” on page 50
- Preferences – “Setting Preferences” on page 33
- Oracle’s Hyperion® Shared Services User Management Console user name and password
- Database information

For Oracle’s Hyperion® Financial Reporting – System 9, Adobe Acrobat Reader must be installed on your computer. Before you can view reports in PDF, a PDF writer (Adobe Acrobat Distiller, GNU Ghostscript or AFPL Ghostscript) must be installed with your print server. If a PDF viewer is not available, only report names are listed.
To enable the use of Microsoft Internet Explorer (IE) for viewing PDF reports on Workspace:

1. **Open Internet Explorer.**
2. **Select Tools > Internet Options.**
3. **In the Internet Options dialog box, select the General tab, and then in the Temporary Internet Files topic, select Settings.**
4. **In the Settings dialog box, in the Check for newer versions of stored pages topic, select Every visit to the page.**

**Note:**
Hyperion recommends that you add Workspace to the exceptions for your Web pop-up blocker. When you perform some Workspace tasks on the Web such as loading data, a status window pops up showing the task status. If you have a pop-up blocker enabled on your computer, the status window is not displayed.

**Note:**
The first time you access a database connection, you may be prompted to log on. This occurs if the user name and password you use to log on to the Web application differs from the user name and password for the database connection. Your administrator can provide you with the required database connection logon information.

For Internet Explorer, status information is displayed in the browser's status bar while interacting with Workspace. For Firefox, the status bar is disabled by default.

To enable the status bar for Firefox for additional progress information:

1. **Select Tools > Options.**
2. **Select Web Features.**
3. **Select Advanced.**
4. **From the Advanced Javascript Options dialog box, select Change status bar text.**
5. **Click OK.**

### Workspace Documentation Set

For a complete list of Workspace guides, online help, and reference material see the Information Map that is accessible from the Help menu.

### Deployment Workflow

For deployment task information, see *Hyperion Enterprise Performance Management Deployment Guidelines*. 
Workspace

From Workspace access the following from the Navigate menu:

- Explore enables you to list and navigate repository contents; manage and control files and folders; and use elements, like the Open dialog box, that present the repository as a file management system. Documents are displayed in the content area.

- Applications enables you to access Financial Management and Planning applications. Applications is only displayed when a user has rights and applications are available.

- Administer enables you to manage users, groups, user preferences, roles, and authentication methods.

- Schedule enables you to manage jobs and schedule batches and events for automated processing.

- Impact Manager enables you to update Oracle's Hyperion® Interactive Reporting – System 9 documents when database structures, database connections, or links to external data sources change.

For an overview of the Reporting and Analysis reporting solution architecture, see the Hyperion Workspace Administrator's Guide.

Workspace can also be installed with the following Reporting and Analysis thin client products: Financial Reporting, Interactive Reporting, Oracle's Hyperion® SQR® Production Reporting – System 9, Oracle's Hyperion® Web Analysis – System 9, and Performance Scorecard. These products are used to create documents and modify document elements. These installed components determine your available features. For example, Web Analysis must be installed to view Web Analysis documents. For information on tasks performed in these modules, see “Module Tasks” on page 30.

The main function of the repository is to store files. Every repository file features properties that identify the file and control user and group access. Your access permissions, set by your system administrator, determine which repository items you can view, modify, run, and delete. See “Reporting and Analysis Repository” on page 31.

Workspace Capabilities

Workspace tasks:

- Viewing documents, Performance Scorecard documents and maps, and dashboards

- Accessing Financial Management and Planning applications that are available to users that have access and rights. For more information on using Financial Management applications from Workspace, see Hyperion Financial Management – System 9 User’s Guide and for Planning applications from Workspace, see Hyperion Planning – System 9 User’s Guide.

- Scheduling batches, jobs, or events to automatically execute reports or create notifications

- Create Web Analysis and Interactive Reporting documents, books, or batches

- Personalizing Workspace and thus managing information delivery by using a start page, personal pages, and favorites
From Workspace, you use menus, buttons, and items from the Navigate menu to perform tasks. Based on the following criteria, menus and toolbar buttons are updated as you use the system:

- The roles granted you by the administrator. Roles determine which modules are displayed in the View pane and toolbar.
- The Navigate menu items being used and the task being performed. For example, if you use Administer, the menus and toolbar icons contain tasks associated with administration related tasks. If you use Explore, the menu contains file tasks.

**Note:**
Generally, module buttons are displayed in the middle of the toolbar.

### Modules Used to Perform Tasks
You use Workspace to perform user tasks:

- **Navigate Menu** – access Explore, Applications, Administer, Schedule, Impact Manager, and Open Items.
- **Explore** – view documents, scorecards, maps – view, manage, and secure documents or document groups (called *collections*).
- **Applications** – access and view applications such as Financial Management, Planning, and Performance Scorecard.
- **Schedule** – automatically run and manage documents, such as batches, jobs, and events.

**Note:**
The Administer and Impact Manager are used only by administrators. See the *Hyperion Workspace Administrator’s Guide*.

- **Open Items** – view all documents or items you have open in Workspace.

### Accessing Items from Navigate
To access an item, perform an action:

- From Navigate, click the `<item name>`.
- From the toolbar, select the `<item name>` button.

The variable `<item name>` is replaced by Explorer, Applications, Administer, Schedule, Impact Manager, or Open Items.

### Using View Pane Buttons
Features for Navigate items are accessed by the buttons displayed on the top right of the View pane.
Table 1  View Pane Buttons

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Document,</td>
<td>Access current-document information or sections</td>
</tr>
<tr>
<td>Note:</td>
<td>Available only for certain modules; for example, used to display the user</td>
</tr>
<tr>
<td></td>
<td>POV for Financial Reporting documents</td>
</tr>
<tr>
<td>Folder,</td>
<td>Display repository folders from the View pane</td>
</tr>
<tr>
<td>Note:</td>
<td>Available only for Explore</td>
</tr>
<tr>
<td>Search,</td>
<td>Display the Search dialog box, which is used to search for files and folders</td>
</tr>
<tr>
<td></td>
<td>by character string and file type. The search is not case sensitive and</td>
</tr>
<tr>
<td></td>
<td>starts in the folder specified in the Look in: text box and searches all</td>
</tr>
<tr>
<td></td>
<td>sub-folders recursively.</td>
</tr>
<tr>
<td>Note:</td>
<td>Available only for Explore</td>
</tr>
<tr>
<td>Tips,</td>
<td>Access another button:</td>
</tr>
<tr>
<td></td>
<td>● Tasks-Displays a list of tasks relevant to the content pane</td>
</tr>
<tr>
<td></td>
<td>● Tips-Displays a list of Help topics</td>
</tr>
<tr>
<td>Note:</td>
<td>Details-Displays a list of properties and details (available only when in</td>
</tr>
<tr>
<td></td>
<td>Explore, search, or listing)</td>
</tr>
</tbody>
</table>

User Types and Tasks

For a complete listing of the different users available from the Workspace, see the *Hyperion Shared Services User Management Console Guide*.

Module Tasks

The available tasks from Workspace depend on the roles and permissions assigned to you by the system administrator. For information on roles, see the *Hyperion Shared Services User Management Console Guide*.

Workspace User Interface

When you log on, the default Workspace start page is displayed. The default is set from the Preferences dialog. “Setting Preferences” on page 33.
### Reporting and Analysis Repository

The repository is used to store, access, and share documents and files. You can access items such as documents, files, and folders in various ways, including browsing or searching for documents, subscribing to folders, and using dashboards. You make documents, files, and folders available to others by importing documents to the repository.

Documents show information and data in a predefined format. You can use jobs and batches to generate documents automatically. You can run jobs and batches at any time or schedule them to run automatically.
**Note:**

Your file permissions determine which repository items you can view, modify, run, and delete.

**Actions**

- Documents, files, and folders can be opened in four formats:
  - Interactive HTML
  - Portable Document Format (PDF), displayed by Adobe Reader
  - Text files
  - Operation messages, which are generated by applications or services and stored in logs
- Interactive Reporting, SQR Production Reporting, and Financial Reporting users can subscribe to documents. When the documents are changed or updated, the users are informed.
- Interactive Reporting, SQR Production Reporting, and Financial Reporting users must import documents before the documents can be accessed by other users. Importing distributes previously private information for public consumption.

**Locations**

User preferences specify default startup options:

- The Content area can be Explore, documents, repository locations, or applications such as Performance Scorecard, Financial Management, or Planning. Startup options are loaded and displayed when users log on to Workspace.

  **Tip:**

  Set a folder to the directory which contains the most frequently-accessed content.

- A **Favorites** folder contains a users most frequently sought repository content. All user profiles feature Favorites folders, the files of which are accessed through the Favorites menu. Favorites Publisher can push content to users’ Favorites folders, providing one access point for certain content.

**File Permissions**

Workspace file permissions determine who has access to what files or folders and what operations can be performed. You obtain access items as a user, as a group member, or through a role given to you by the system administrator. For information on roles, see the *Hyperion System 9 Security Guide*. The level at which you can access items and perform tasks is called *access privilege*.

Access to specific repository items is controlled by the document owner. Access to operations, such as importing, running jobs, or updating document POV, is controlled through roles. For example, the owner gives you the modify and run access privilege to Job A, but you can run the job only if you have the Job Runner role. The owner gives you the full control access privilege
to Document B, so you can open and update the file. For information on setting file permissions, see Chapter 3, “Exploring and Managing Items.”

When you import a file, you become the file owner, and you specify the access level of other users. You might specify that all users can read the file, your group can modify the file, and only you can delete, change access for, and move the file.

**Logging on to Workspace**

You can access Workspace in two ways: through a URL provided by your administrator or through a Hyperion application link.

**Note:**

Access through Hyperion application links requires that single sign-on be enabled.

➤ To start a Workspace session:

1. In your Web browser, go to Workspace Web page.
2. Enter user name and password.
3. Click Log On.

Your start page is displayed. For more information on setting your start page, see Chapter 2, “Setting Preferences and Personalizing your Workspace”.

**Setting Preferences**

As a designer, you can set defaults for the general appearance of Workspace user interface, Explore, studios, and authentication for changing user passwords. Preferences for Planning are not set from Workspace. For Planning end-user preference settings see the *Hyperion Planning – System 9 User’s Guide* and for administrator and application preferences, see the *Hyperion Planning – System 9 Administrator’s Guide*. Financial Management preferences are set from the Workspace, see the *Hyperion Financial Management System 9 – User’s Guide*. Default startup options can be set for the View pane and content area. Some settings can be overridden through menu options. See Chapter 2, “Setting Preferences and Personalizing your Workspace”.

**Note:**

Your e-mail address, which you cannot update, defaults to the e-mail address registered in your user security settings.
Using Data Source Elements for Reporting and Analysis

Data sources (generic data storage mechanisms) can be multidimensional databases, relational databases, or files. Database connections are portable files stored in the repository. They define the terms, conditions, and methods for connecting to data sources. In Workspace, you cannot create or modify database connections; rather, you must use the applicable studio. You see only database connections that you own and to which you are granted permissions. Multiple permissions are needed to read, write, edit, and change database-connection file properties. For permission descriptions, see the Hyperion Workspace Administrator’s Guide.

Database servers typically use server, application, and database names to create unique identifiers. Such identifiers make database references not readily portable. The studios use database aliases instead of long identifiers. Aliases are easier to remember and more economical to employ and enable a database to be maintained on multiple servers.

Repository documents are dependent on a database-connection file to query data sources for values. A document can use only one database connection but can use any of several data sources.

For a complete list of supported data sources and relational databases by Studio, see Hyperion Reporting and Analysis – System 9 Installation Guide for Windows or UNIX.

- Different data sources have different system requirements. See the Hyperion Reporting and Analysis – System 9 Installation Guide for Windows or UNIX for descriptions of system requirements.
- The View pane Information tab displays the database connection used by the current data object. The tab features two database connection segments for Web Analysis:
- The Database segment displays the database connection name for the current data object.
- The Database User Name segment displays the user name by which access to the database connection was granted.

**Web Analysis Studio**

Oracle's Hyperion® Web Analysis Studio users can construct seamless liaisons between OLAP data and relational data sources. Navigation from OLAP to relational data is typically called relational drill-through.

After relational drill-through is configured, users can navigate to level 0 (the bottom) of the OLAP database and drill down to relational data. Relational drill-through, a client-based integration solution, is comparable to the server-based Analytic Integration Services drill-through.

Relational drill-through supports an array of JDBC relational data sources but does not support queries by level, generation, or previously selected member. Relational drill-through definitions are saved as a property of the database-connection file.

**Financial Reporting Studio**

For Oracle's Hyperion® Financial Reporting Studio, you must be defined as a user, with a user name and password, in the data source that your document uses. For example, if you want to view documents that use Analytic Services, you must logon to the database connections with a user account defined in Analytic Services. Logging on usually occurs automatically. However, if you are not registered in the database, you are prompted for logon credentials.

**Interactive Reporting Studio**

Interactive Reporting documents can contain multiple Query sections, each of which can access a range of data sources (relational databases, OLAP servers, imported data sets, and local joins). Each section can reference zero (if using only local joins) or one database-connection file. The file can reference only one data source. When a query section associated with a relational-database connection or using only local joins is processed, a corresponding Results section is produced. If the database-connection file is associated with a multidimensional database connection, results are shown in the Query section.

**Production Reporting Studio**

With Oracle's Hyperion® SQR® Production Reporting Studio, users can easily develop a range of reports, from small ad hoc reports to mission-critical operational reports. Various data sources can be used; for example, relational databases, OLAP servers, and transactional systems.
After you create a data source connection, you can use the Production Reporting Studio wizard, layout editor, and explorers to design and customize enterprise reports. You can also insert and update database tables to incorporate data transformations into report processing.

Whether you are creating budgets, building exception reports, producing invoices from millions of records, or distributing Web-based reports to help end-users make quick, effective decisions, Production Reporting manages the secure delivery of content across the enterprise.

Analytic Services Features Available to the Studios

Analytic Services integrates data from multiple sources, meets user needs across an enterprise, adds value to previously inaccessible data, and transforms data into actionable information.

Analytic Services features available to studios:

● Data restriction
● Top and bottom only retrieval
● Data edits
● Suppression of rows that contain #MISSING values, zero values, and shared members
● Label mode and alias tables
● Drill settings specific to Analytic Services
● Linked reporting objects
● Relational drill-through
● Analytic Integration Services drill-through
● Advanced member selection
● Attribute dimensions and attribute calculations

For feature details, see the Hyperion Workspace User’s Guide.

Financial Management Features Available to the Studios

Hyperion System 9 Financial Management is a centralized, scalable, financial management and reporting solution. Financial Management features that are extended through Workspace:

● Organization by period
● Advanced member selection specific to Financial Management
● Cell text – related content
● Line item, detail-related content
● Advanced member selection
● User–defined fields
● Entity currency display
For Financial Management convention and feature information, see the *Hyperion Workspace User’s Guide*.

### Planning Details as a Database Connection

After you install the Planning Details ADM driver, you can choose Planning Details as a database connection for Financial Reporting Studio. The Planning Details ADM driver is optimized as a data source to provide Planning features such as supporting details, planning unit annotations, and metadata filtering. If your report grid does not use Planning features, for optimal performance, choose Essbase as the database connection. See the *Hyperion Financial Reporting Studio User’s Guide*.

### SAP BW Data Sources

You can use the studios to access SAP BW data sources. Using the custom-report, free–form grid component, you can present OLAP, relational, and manually entered data on a data object and leverage all data sources in integrated dynamic calculations. The studios offer visually compelling SAP BW reports that satisfy the presentation, reporting and distribution requirements of information consumers.

#### SAP BW Features

SAP BW features:

- BEx Query Variables
- Period-to-date values
- Top and bottom retrieval
- Attributes (member properties)
- Searches for SAP BW characteristic values
- Currency conversion
- Unit of measure conversion
- Unicode

#### SAP BW Prerequisites

To access an SAP BW data source, install the SAP BW client on the server. After installation, define SAP Logon parameters used to communicate with the SAP data source.

**Note:**

For information on accessing SAP JCO data sources and authenticating users against an SAP server, see *Configuring SAP Data Source Access and Authentication* in the *Hyperion Reporting and Analysis – System 9 Installation Guide for Windows or UNIX*.
SAP BW InfoProviders Supported by Reporting and Analysis

- InfoCubes/Remote InfoCubes
- ODS objects
- InfoSets
- BEx query cubes
- Multiproviders

Note:
Using the SAP BW BAPI driver, you cannot issue MDX queries on cubes that have more than 50 characteristics. You can, however, have up to 255 characteristics in an SAP InfoCube.

SAP Variable Support

In this section:

- About SAP Variables
- Variables and Processing Types
- Variable Options

About SAP Variables

SAP variables are query parameters defined in the BEx Query designer. They function as a store for characteristic values, hierarchies, hierarchy nodes, texts, and formula elements.

SAP variables are displayed in a Variable dialog box when creating a new Web Analysis, Production Reporting, or Financial Reporting document, opening a Web Analysis, Production Reporting, or Financial Reporting document, or explicitly selecting to refresh the variables from the shortcut menu in the Content pane. SAP variables are displayed only if the database connection is created against a BEx query with variables defined.

Users are prompted for variable values only if the variable was created in the original BEx query with Ready for Input selected. For variables that do not have Ready for Input selected, the default variable values are applied to the Web Analysis, Production Reporting, or Financial Reporting document upon creation.

Variables and Processing Types

In order to run a variable, it must be associated with a processing type, which identifies the way the variable is processed.

<table>
<thead>
<tr>
<th>Processing Type</th>
<th>Characteristic Values</th>
<th>Hierarchies</th>
<th>Hierarchy Nodes</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>Variable Type</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Table 4 Variable Descriptions

<table>
<thead>
<tr>
<th>Variable/Processing Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Characteristic</strong></td>
<td>Most common type of variable. Most common processing type is manual/default with ready for input setting. Allows characteristic value to be selected at query run time. Authorization processing type—looks to the end-users’ authorization settings as defined with transaction RSMM and uses the value found there as input for the variable.</td>
</tr>
<tr>
<td><strong>Hierarchy</strong></td>
<td>Behaves in same manner as characteristic variables. Represent an entire hierarchy tree for a given characteristic. Allow the query user to select new hierarchies versus simply selecting a different node within the same hierarchy.</td>
</tr>
<tr>
<td><strong>Hierarchy Node</strong></td>
<td>Behaves in same manner as characteristic variables. Represents a given substructure within a hierarchy.</td>
</tr>
<tr>
<td><strong>Formula</strong></td>
<td>Query parameters set in the query definition and not filled with values (processed) until the query is inserted into a workbook. Formula variables function as a store for individual formula elements.</td>
</tr>
</tbody>
</table>

## Table 5 Processing Type Descriptions

<table>
<thead>
<tr>
<th>Variable/Processing Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Manual Entry/Default Value</strong></td>
<td>Variables processed with this processing type allow you to manually enter a value before inserting the query into the workbook. When you create the variables, you determine whether to enter a default value using the default value data.</td>
</tr>
<tr>
<td><strong>Customer Exit</strong></td>
<td>ABAP code that may be written by SAP customer to fill a variable.</td>
</tr>
<tr>
<td><strong>SAP Exit</strong></td>
<td>ABAP code written by SAP to fill a variable value.</td>
</tr>
<tr>
<td><strong>Authorization</strong></td>
<td>Indicates that variable value is stored with user authorization.</td>
</tr>
</tbody>
</table>

## Variable Options

There are five options for each variable type (with the exception of Hierarchies variables with all processing types and any variable type with the Replacement Path processing type) that determine the way values are selected for each variable. In the BEx variable dialog box, they are listed under **Variable Represents**. Values for each of these options are supported in the Variable dialog box.
### Table 6  Variable Options

<table>
<thead>
<tr>
<th>Option Name</th>
<th>Variable Represents</th>
</tr>
</thead>
<tbody>
<tr>
<td>Single Value</td>
<td>One value only.</td>
</tr>
<tr>
<td>Multiple Single Values</td>
<td>Number of single values. Useful in hierarchy nodes, for example, to allow you to enter several single nodes.</td>
</tr>
<tr>
<td>Interval</td>
<td>From and to value, that is, an interval.</td>
</tr>
<tr>
<td>Selection Option</td>
<td>Any combination of single values and intervals.</td>
</tr>
<tr>
<td>Precomputed Value Set</td>
<td>Set of values that are staged persistently in a database table by the Reporting Agent.</td>
</tr>
</tbody>
</table>

There are three additional options for each variable type that determine whether a value is required for the variable. In the BEx Variable dialog box, they are listed under **Variable Value Is**.

### Table 7  Options for Variable Value Is

<table>
<thead>
<tr>
<th>Variable Value Is Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Optional</td>
<td>Variable does not need a value during runtime.</td>
</tr>
<tr>
<td>Mandatory</td>
<td>At least one value must be entered for the variable during runtime:</td>
</tr>
<tr>
<td></td>
<td>● Initial value (#) is permitted explicitly</td>
</tr>
<tr>
<td></td>
<td>● Initial value # means &quot;unassigned&quot;, that is, you cause it to explicitly select all data that has no booked values for this characteristic</td>
</tr>
<tr>
<td>Mandatory, Initial Value Not Allowed</td>
<td>At least one value must be entered for the variable during runtime; Initial value (#) is not permitted (that is, you must enter one or more concrete values in order to execute the query).</td>
</tr>
</tbody>
</table>

**Note:**

**Variable Value Is** can be modified after creating a variable in BEx, but **Variable Represents** can be set only at variable creation time.

### SAP Attribute Support

Supported SAP attributes include:

- **Display attributes**—Users can select, search, filter, and include Display Attributes as part of queries and reports.

- **Navigation Attributes**—Navigation attributes are selected from the field catalog like characteristics, and are used for navigation in Web Analysis, Production Reporting, and Financial Reporting documents. They can also be passed on to Web Analysis, Production Reporting, and Financial Reporting as selection criteria.
SAP Security Integration

SAP BW provides single sign-on login for Web Analysis, Production Reporting, and Financial Reporting users integrating with SAP. For detailed information, see the section titled “Working with an SAP Provider” in the *Hyperion Shared Services Installation Guide*.

Relational Access Methods

Some documents, such as Web Analysis documents, can access OLAP, Hyperion, and supported relational databases.

Methods for accessing relational data from Web Analysis:

- Custom document SQL spreadsheet
- Custom document free-form grid
- Relational drill-through
- Relational database connection
- Analytic Integration Services drill-through
- Repository

Controlling the Size of the Query Result Set

Query governors vary for relational access methods. Custom document SQL spreadsheets and relational drill-through methods enable users to declare query governors as they create SQL queries or relational drill-through definitions.

When you drill from OLAP to relational data, passing only the drilled OLAP dimension member to the relational data source may result in a large query result set. To reduce and simplify the query result set, you can pass the page and filter dimensions specified in the OLAP document.

In Interactive Reporting documents, Query section properties can govern the number of rows returned from relational data sources and impose time limits on queries. Users can cancel queries through the keyboard in some cases.

Starting Tasks

Most tasks in Workspace start the same way.

*Note:*

Some tasks can also be performed using the toolbar, menus, and shortcut menus. For a list of all toolbars, menus, and shortcut menus, see “Toolbars” on page 50.

To begin a task:

1. From the Navigate menu, select an item.
Note:
The View pane displays information such as, depending on the task, a list of folders or document sections. The Content pane displays information that corresponds to the View pane, such as a file list or document content.

2 Perform one of three actions:

- If the content area displays a document, change the POV or view a section.

  In the following example, you can change the POV:

  ![Sample Financial Reporting document](image)

  - If the content area displays a list, locate and double-click the item with which you want to work.
If a dialog box is displayed in the content area, view or modify the information.

Creating Documents

With Workspace, you can use the new document wizard to create Web Analysis or Interactive Reporting document, Financial Reporting book or batch.

To create a Web Analysis or Interactive Reporting document, or a Financial Reporting book or batch:

2. Select an option:
   - Create an Interactive Reporting Document
   - Create a Web Analysis Document
   - Collect reports into a book
   - Batch reports for scheduling

Selecting a Data Source for a Document

To create a document, you must specify a data source. The data source determines the document type.

- To create a Web Analysis document, specify a Web Analysis database connection.
- To create an Interactive Reporting document based on an existing document, specify the existing document.

Note:
In the following procedures, <item name> is Explore, Applications, Administer, Schedule, or Impact Manager.

Accessing Navigate Items

➤ To access an item from the Navigate menu, select Navigate and click the <item name>.

Opening and Printing Documents or URLs

➤ To open a document:
   The Open dialog box is displayed.
2. Select the document.
   The list of open documents can be located from the Open Items option from Navigate menu and in tabs at the bottom of the Workspace. You can toggle between open documents.

➤ To open a URL:
1. Select File > Open > URL.
   The URL dialog is displayed.
2. Enter the URL name.
3. Select OK.

Note:
This procedure applies only to Financial Reporting, Web Analysis, or SQR Production Reporting documents.

➤ To print a document:
1. From Navigate, select Explore.
2 Open a document, for example, a Financial Reporting document.

Note:
You may need to open the document as HTML or PDF.

3 Select File > Print > HTML or File > Print > PDF.

Setting File Properties and Moving Files

➤ To set file properties:
1 From Explore, select a document without opening.
2 Select File > Properties.
   The Properties Dialog is displayed. The General Properties option is selected by default.
   You can modify the file name and description and set user permissions (select Edit Permissions). See Chapter 3, “Exploring and Managing Items.”

➤ To move files or folders in Explore:
1 From Explore, select a document or folder.
2 Select Edit > Cut.
3 Select a repository location, and select Edit > Paste.

Renaming Files

➤ To rename files:
1 From Explore, select a document or folder.
2 Select Edit > Rename.
3 Enter a name.
4 Select Save.

Adding and Removing Documents from Favorites

➤ To add a document or folder to favorites:
1 From Explore, select a document or folder.
2 Select Favorites > Add to Favorites.
3 Select Favorites.
   The document or folder that you added is displayed as a menu option.
To remove a document or folder from Favorites:
1. Select Favorites > Manage Favorites.
2. Clear Show, or select Remove.

To create a shortcut to a SQR Production Reporting document:
1. From Explore, select the document.
2. Right-click the document, and select Create Shortcut.
3. Complete the General Properties dialog box, and select OK.

For instructions, see Chapter 11, “Using SQR Production Reporting Documents.”

Using Explore

In Explore, you organize, search for, or assign access permissions to files. When you select Explore, the View pane shows folders, and the content pane shows files and folders. The following figure shows the Explore page and an example of the options available for Financial Reporting documents.

Note:

To display additional options, the highlighted document was selected along with the right-click option.
Explore features:
- **Folder tree**- Navigate through Workspace folders
- **View File Properties**- View file information, such as type, author, creation date, access permissions, modified date, and description
- Search for files and folders by character string and file type

**Using Schedule**

Use Schedule to manage and schedule batches, jobs, and events and to view status. Schedule is primarily used by Financial Reporting, Interactive Reporting, and SQR Production Reporting. The following Batch Scheduler example is used by Financial Reporting.

Schedule features:
- **Batch Scheduler**
- **Manage Jobs**
- **View Job Status**
- **Manage Events**
- **Consolidated Job Status**

See Chapter 13, “Scheduling Jobs and Batches.”
Using Open Items

Open Items from Navigate displays a list of opened documents, so you can quickly switch between the opened documents.

Using Smart View

Smart View provides a common Microsoft Office interface for Essbase, Financial Management, Planning, and four Workspace components:

- Financial Reporting
- SQR Production Reporting
- Web Analysis
- Interactive Reporting (Smart View export options not enabled)

The centralized interface enables simultaneous use of multiple Hyperion products and improves integration with Microsoft Office (2000, 2002, and 2003). The Smart View implementation provides the following Workspace functionality:

- Exports the current page of the current data object to Excel, Word, or PowerPoint
- Exposes Financial Management and Essbase functions in Excel, Word, and PowerPoint content
- Notifies you when you can upgrade to new releases of Smart View

Smart View enables two export options:

- You can export the current page of the current data object to Word, PowerPoint, or Excel as an image, and later, re-query the Web application to refresh the image.
- You can export documents to Excel as query-ready or formatted HTML.

When you export content as query-ready HTML, the current page of the current data object is converted to HTML, and Hyperion-specific formatting is removed. Thus, Smart View can re-query the data source independent of the Web application.

When you export content as formatted HTML, the current page of the current data object is converted to HTML, and Hyperion formatting definitions and calculated members are retained. Thus, Smart View cannot directly query the data source, but Hyperion content can be leveraged by Microsoft Office applications. Not all export options are supported by all data sources and Web applications. See Chapter 3, “Exploring and Managing Items.”

Personalizing Workspace

You can use Workspace favorites and personal pages to personalize the process of organizing, accessing, and viewing documents. See Chapter 2, “Setting Preferences and Personalizing your Workspace.”
Subscribing to Documents

When documents are changed or updated, subscribing users can be informed:

- By e-mail notifications with attached files
- By bookmarked personal pages
- By images that represent bookmarks

For information on Subscribe, see Chapter 5, “Viewing and Organizing Information.”

Working with Favorites

Favorites provide quick access to frequently used items and documents. With appropriate access permissions, you can add items (push items) to other users’ favorites.

Using Personal Pages

Personal pages provide a way to view frequently used information. You can have multiple personal pages and choose a default personal page, which is displayed when you open Personal Pages from Favorites. You can customize personal page content and layout, create personal pages, and copy and customize imported personal pages.

The following figure shows the types of content that can be displayed on personal pages. A personal page can have some or all of these types.

Personal page features:

- **Broadcast Messages**—A link to a folder, the contents of which are set up and managed by the administrator. Folder contents are displayed as one or more content window, and displayed to every user. The Broadcast Messages folder contains two sub-folders:
  - Personal Page Content—published personal pages
Sample Personal Page—content set up by the administrator and content added by subscription

- My Bookmarks—Links to Web pages or repository items that open as new tabs in Workspace.
- Image bookmarks—Graphic links to Web pages or repository items.
- HTML file or job output displayed as a file content window—Workspace HTML items and URLs
- Exceptions Dashboard—Traffic light indicators. If the traffic light is red, the item is flagged as an exception or the job generated an exception. If the traffic light is green, the job did not generate an exception.
- Displayable Interactive Reporting sections—Sections from Interactive Reporting documents and job output that you can access.

For details on the following tasks, see Chapter 5, “Viewing and Organizing Information”:

- Adding personal page contents
- Modifying personal page layout
- Changing personal page colors
- Displaying HTML content on personal pages
- Creating bookmarks
- Using exception notifications
- Embedding Interactive Reporting document sections in personal pages

**Toolbars**

Toolbars provide quick, context-sensitive access to commonly used features. Button availability is determined by the content-area module.

**Note:**

Your role determines which toolbars, menus, shortcut menus, and modules are displayed on the user interface. For example, if your role enables you to create documents, the toolbar menu item File > New is displayed.

**Standard Toolbar**

The Standard Toolbar is used for common Workspace features. These are displayed prior to opening any item from the Navigate menu.
### Table 8  Standard Toolbar Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="File" /></td>
<td>File &gt; New &gt; Document</td>
<td>Create documents, such as books, batches, analysis documents, and scheduled batch jobs</td>
</tr>
<tr>
<td><img src="image" alt="File" /></td>
<td>File &gt; Open &gt; Document</td>
<td>Use repository documents</td>
</tr>
<tr>
<td><img src="image" alt="Explore" /></td>
<td>NA</td>
<td>Displays the default startup option for content area</td>
</tr>
<tr>
<td><img src="image" alt="Explore" /></td>
<td>Navigate &gt; Explore</td>
<td>Display Explore, to display the repository as a file management system</td>
</tr>
<tr>
<td><img src="image" alt="File" /></td>
<td>File &gt; Logoff</td>
<td>End the current session</td>
</tr>
<tr>
<td><img src="image" alt="Help" /></td>
<td>Help &gt; Help on This Topic</td>
<td>Displays help for the page displayed in the content area</td>
</tr>
</tbody>
</table>

### Web Analysis Toolbar

The Web Analysis toolbar displays standard buttons and buttons specific to it.

### Table 9  Web Analysis Toolbar Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="View" /></td>
<td>View &gt; Data Layout</td>
<td>Display the Data Layout dialog box, used to redefine queries and dimension member selections</td>
</tr>
<tr>
<td><img src="image" alt="File" /></td>
<td>File &gt; Save</td>
<td>Save documents to the repository</td>
</tr>
<tr>
<td><img src="image" alt="File" /></td>
<td>File &gt; Save As</td>
<td>Save documents to the repository under new names or to new locations</td>
</tr>
<tr>
<td><img src="image" alt="NA" /></td>
<td>NA</td>
<td>Display the browser Print dialog box, used to define print parameters and options</td>
</tr>
</tbody>
</table>

### Financial Reporting Toolbar

The Financial Reporting toolbar displays standard buttons and buttons specific to it.

### Table 10  Financial Reporting Toolbar Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="File" /></td>
<td>File &gt; Open in &gt; PDF Preview</td>
<td>Open documents in the browser in PDF</td>
</tr>
</tbody>
</table>
### Book Editor Toolbar

The Book Editor toolbar displays standard buttons and buttons specific to it.

**Table 11  Book Editor Toolbar Buttons**

<table>
<thead>
<tr>
<th>Button</th>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Add Report/Snapshot]</td>
<td>Edit &gt; Add Report/Snapshot</td>
<td>Add reports and snapshots to books</td>
</tr>
<tr>
<td>![Delete]</td>
<td>Edit &gt; Delete</td>
<td>Remove reports and snapshots from books</td>
</tr>
<tr>
<td>![Member Selection]</td>
<td>Edit &gt; Member Selection</td>
<td>Open the member selection dialog box</td>
</tr>
<tr>
<td>![Move Up]</td>
<td>Edit &gt; Move Up</td>
<td>Move reports or snapshots up in the list</td>
</tr>
<tr>
<td>![Move Down]</td>
<td>Edit &gt; Move Down</td>
<td>Move reports or snapshots down in the list</td>
</tr>
</tbody>
</table>

### Batch Editor Toolbar

The Batch Editor toolbar displays standard buttons and buttons specific to it.

**Table 12  Batch Editor Toolbar Buttons**

<table>
<thead>
<tr>
<th>Button</th>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Add Report/Snapshot]</td>
<td>Edit &gt; Add Report/Snapshot</td>
<td>Adds reports or snapshots to batches</td>
</tr>
<tr>
<td>![Delete]</td>
<td>Edit &gt; Delete</td>
<td>Removes reports and snapshots from batches</td>
</tr>
</tbody>
</table>

### Interactive Reporting Toolbar

The Interactive Reporting toolbar displays standard buttons and buttons specific to it. For button descriptions, see Chapter 10, “Interactive Reporting” for details.

### Performance Scorecard Toolbar

The Performance Scorecard toolbar displays standard buttons and buttons specific to it.
### Table 13  Performance Scorecard Toolbar Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>File &gt; Print</td>
<td>Print scorecards or maps to a designated printer</td>
</tr>
<tr>
<td></td>
<td>File &gt; Export to Excel</td>
<td>Export scorecards for employees or measures to an Excel worksheet</td>
</tr>
<tr>
<td></td>
<td>Tools &gt; Links &gt; Performance Scorecard</td>
<td>Launch the Performance Scorecard application to access additional functionality, such as data entry, measure scorecard details, and object creation</td>
</tr>
</tbody>
</table>

### Batch Scheduler Toolbar

The Batch Scheduler toolbar displays standard buttons and buttons specific to it.

### Table 14  Batch Scheduler Toolbar Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>File &gt; New Scheduled Batch</td>
<td>Opens the Schedule Batch dialog box</td>
</tr>
<tr>
<td></td>
<td>Edit &gt; Properties</td>
<td>Displays the details for scheduled batches; for example, the time for which a batch is scheduled</td>
</tr>
<tr>
<td></td>
<td>Edit &gt; Delete</td>
<td>Deletes scheduled batches</td>
</tr>
<tr>
<td></td>
<td>View &gt; Refresh</td>
<td>Updates the Workspace with changes to scheduled batches</td>
</tr>
<tr>
<td></td>
<td>Action &gt; Retrieve Output</td>
<td>Retrieves results for the latest batch job</td>
</tr>
<tr>
<td></td>
<td>Action &gt; Show Details</td>
<td>Displays batch details; for example name, start time, and destination</td>
</tr>
</tbody>
</table>

### Explore Toolbar

The Explore toolbar displays standard buttons and buttons specific to it.

### Table 15  Explore Toolbar Buttons

<table>
<thead>
<tr>
<th>Button</th>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>File &gt; New Folder</td>
<td>Creates folders</td>
</tr>
<tr>
<td>Button</td>
<td>Menu Command</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>--------------</td>
<td>-------------</td>
</tr>
<tr>
<td><img src="image" alt="NA" /></td>
<td>NA</td>
<td>Navigates up to the repository location that contains the current folder</td>
</tr>
<tr>
<td><img src="image" alt="Tools" /></td>
<td>Tools &gt; Search</td>
<td>Displays the Search dialog box, used to search for files and folders by character string and file type</td>
</tr>
<tr>
<td><img src="image" alt="Edit" /></td>
<td>Edit &gt; Cut</td>
<td>Marks repository files to be moved</td>
</tr>
<tr>
<td><img src="image" alt="File" /></td>
<td>File &gt; Properties</td>
<td>Open the Properties dialog box, used to set file properties; for example, file permissions</td>
</tr>
<tr>
<td><img src="image" alt="Edit" /></td>
<td>Edit &gt; Paste</td>
<td>Pastes files to the current repository location</td>
</tr>
<tr>
<td><img src="image" alt="View" /></td>
<td>View &gt; Refresh</td>
<td>Updates Workspace with changes to scheduled batches</td>
</tr>
</tbody>
</table>

**Administer Toolbar**

The Administer toolbarenables you to manage Workspace properties, performance, and user interaction. For button descriptions, see the Hyperion Workspace Administrator’s Guide.

**Production Reporting Toolbar**

When you view SQR Production Reporting documents in Workspace, you see no buttons in the toolbar area. However, you see the navigation bar, which provides options for navigating among HTML-report pages and for viewing reports in multiple output formats. The navigation buttons are dynamic, based on job output. For button descriptions, see Chapter 11, “Using SQR Production Reporting Documents.”

**Menus**

- From Workspace, the standard menus are Navigate, File, View, Favorites, Tools, and Help. These are explained in the following tables.

- Menus and buttons are updated as you use the system, based on the following criteria:
  - The roles granted to you. Role determines which items are displayed from Navigate.
  - The Navigate item being used and the task being performed. For example, if you use Explore, the menus contain file or folder tasks.

**Navigate Menu**

The Navigate menu is available for all Workspace modules. Options displayed for each item depend on your role and rights.
<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Explore</td>
<td>Opens the Explore Module for viewing files in the repository</td>
</tr>
<tr>
<td>Applications</td>
<td>Opens applications that are available based on rights and roles</td>
</tr>
<tr>
<td>&gt; Consolidations (Financial Management Apps)</td>
<td></td>
</tr>
<tr>
<td>&gt; Planning (Planning Applications)</td>
<td></td>
</tr>
<tr>
<td>&gt; Performance Scorecard</td>
<td></td>
</tr>
<tr>
<td>General</td>
<td></td>
</tr>
<tr>
<td>User Management</td>
<td></td>
</tr>
<tr>
<td>Physical Resources</td>
<td></td>
</tr>
<tr>
<td>Mime Types</td>
<td></td>
</tr>
<tr>
<td>Notifications</td>
<td></td>
</tr>
<tr>
<td>Smartcuts</td>
<td></td>
</tr>
<tr>
<td>Row Level Security</td>
<td></td>
</tr>
<tr>
<td>Usage Tracking</td>
<td></td>
</tr>
<tr>
<td>Event Tracking</td>
<td></td>
</tr>
<tr>
<td>Dimension Library</td>
<td></td>
</tr>
<tr>
<td>Application Library</td>
<td></td>
</tr>
<tr>
<td>Data Synchronization</td>
<td></td>
</tr>
<tr>
<td>Application Upgrade</td>
<td></td>
</tr>
<tr>
<td>Job Console</td>
<td></td>
</tr>
<tr>
<td>Classic Application Administration &gt;</td>
<td></td>
</tr>
<tr>
<td>Consolidation Administration or Planning</td>
<td></td>
</tr>
<tr>
<td>Administration</td>
<td></td>
</tr>
<tr>
<td>Consolidation System Messages</td>
<td></td>
</tr>
<tr>
<td>Consolidation Users on System</td>
<td></td>
</tr>
<tr>
<td>Manage Consolidation Servers and Application</td>
<td></td>
</tr>
<tr>
<td>Schedule</td>
<td>Schedule enables you to manage jobs and schedule batches and events for automated processing</td>
</tr>
<tr>
<td>&gt;</td>
<td></td>
</tr>
<tr>
<td>Batch Scheduler</td>
<td></td>
</tr>
<tr>
<td>Manage Jobs</td>
<td></td>
</tr>
<tr>
<td>View Job Status</td>
<td></td>
</tr>
<tr>
<td>Manage Events</td>
<td></td>
</tr>
<tr>
<td>Consolidated Job Status</td>
<td></td>
</tr>
<tr>
<td>Integration Event</td>
<td></td>
</tr>
<tr>
<td>Impact Manager</td>
<td>Impact Manager enables you to update Interactive Reporting documents when database structures,</td>
</tr>
<tr>
<td>&gt;</td>
<td></td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>Synchronize Metadata</td>
<td></td>
</tr>
<tr>
<td>Update Data Models</td>
<td>database connections, or links to external data sources change.</td>
</tr>
<tr>
<td>Javascript Update</td>
<td></td>
</tr>
<tr>
<td>Custom Update</td>
<td></td>
</tr>
<tr>
<td>Manage Task List</td>
<td></td>
</tr>
<tr>
<td>Show Task Status</td>
<td></td>
</tr>
<tr>
<td>Show Impact of Change</td>
<td></td>
</tr>
<tr>
<td>Open Items (List of open modules)</td>
<td>Displays items open in Workspace</td>
</tr>
</tbody>
</table>

*Classic Application Administration is enumerated with both Consolidation Administration and Planning Administration if a user has Dimension Editor and application creator roles for Financial Management and Planning.

## File Menu

The File menu is available for all Workspace modules. Option availability depends on the content of the current window and the module from which the menu is accessed.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File &gt;</td>
<td></td>
</tr>
<tr>
<td>New &gt;</td>
<td></td>
</tr>
<tr>
<td>Document</td>
<td></td>
</tr>
<tr>
<td>Open &gt;</td>
<td></td>
</tr>
<tr>
<td>Document</td>
<td></td>
</tr>
<tr>
<td>Application &gt;</td>
<td></td>
</tr>
<tr>
<td>Performance Scorecard</td>
<td></td>
</tr>
<tr>
<td>Financial Management</td>
<td></td>
</tr>
<tr>
<td>Planning</td>
<td></td>
</tr>
<tr>
<td>URL</td>
<td></td>
</tr>
<tr>
<td>Close &gt;</td>
<td></td>
</tr>
<tr>
<td>Current</td>
<td></td>
</tr>
<tr>
<td>Others</td>
<td></td>
</tr>
<tr>
<td>All</td>
<td></td>
</tr>
<tr>
<td>Save</td>
<td>Save changes, overwriting the current document</td>
</tr>
<tr>
<td>Save As</td>
<td>Saves documents to the repository under new names or to new locations</td>
</tr>
<tr>
<td>Print &gt; PDF or HTML</td>
<td>From Financial Reporting, open reports in PDF or HTML for printing</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Print PDF</td>
<td>For Financial Reporting, Web Analysis, and Interactive Reporting, open reports in PDF for printing</td>
</tr>
<tr>
<td>Print HTML</td>
<td>For Financial Reporting, Web Analysis, and Interactive Reporting, open reports in HTML for printing</td>
</tr>
<tr>
<td>Print</td>
<td>For Performance Scorecard, print scorecards or maps displayed in the Contents pane</td>
</tr>
<tr>
<td>Export to Excel</td>
<td>For Performance Scorecard, export maps or employee scorecards to Excel worksheets</td>
</tr>
<tr>
<td>Export Map</td>
<td>For Performance Scorecard, if a Cause and Effect map is being viewed, export an image of the maps</td>
</tr>
<tr>
<td>Import</td>
<td>Open the Import dialog box, used to import documents, URLs, files, files as jobs, and financial reports to Hyperion System 9</td>
</tr>
<tr>
<td></td>
<td>&gt; File</td>
</tr>
<tr>
<td></td>
<td>&gt; URL</td>
</tr>
<tr>
<td></td>
<td>&gt; File as Job</td>
</tr>
<tr>
<td></td>
<td>&gt; Financial Reports</td>
</tr>
<tr>
<td>Export</td>
<td>Open the Export dialog box, used to export native file formats in XML, Excel as fully formatted or query-ready grid and text, Word, or PowerPoint</td>
</tr>
<tr>
<td>Properties</td>
<td>Open the Properties dialog box, used to set file properties; for example, file permissions</td>
</tr>
<tr>
<td>E-mail Link</td>
<td>Send URL links of objects or folders by e-mail</td>
</tr>
<tr>
<td>Subscribe</td>
<td>Inform subscribing users when documents are changed or updated</td>
</tr>
<tr>
<td>Run Job</td>
<td>For Interactive Reporting jobs, set job parameters and run jobs</td>
</tr>
<tr>
<td>Print</td>
<td>Opens the browser Print dialog box, used to specify printers and print reports</td>
</tr>
<tr>
<td>Page Setup</td>
<td>For Financial Reporting, opens the Page Setup dialog box, used to specify page size, page margins, and workspace size</td>
</tr>
<tr>
<td>Print Preview</td>
<td>For , view reports as they look printed</td>
</tr>
<tr>
<td>Preferences</td>
<td>Opens the Preferences dialog box, used to change your password (using native authentication) and e-mail address and set the default for opening snapshots (PDF Preview or HTML Preview)</td>
</tr>
<tr>
<td></td>
<td>For Financial Reporting, you can also change your language selection and enable XBRL editing</td>
</tr>
<tr>
<td>Logoff</td>
<td>End the session</td>
</tr>
<tr>
<td>Exit</td>
<td>Exit Workspace</td>
</tr>
</tbody>
</table>

**View Menu**

The availability of View menu options depends on the content of the current window and the module from which the menu is accessed.
### Table 18  View Menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>View pane</td>
<td>Show or hide the View pane</td>
</tr>
</tbody>
</table>

### Favorites Menu

Use the Favorites menu to set up personal pages and favorites and to select from a list of favorite documents.

### Table 19  Favorites Menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manage Favorites</td>
<td>Opens the Favorites Manager dialog box</td>
</tr>
<tr>
<td>Show Subscribed Items</td>
<td>Display documents to which you are subscribed and manage personal pages</td>
</tr>
<tr>
<td>Manage Personal Pages</td>
<td>Displays list of available application products, for example Performance Scorecard.</td>
</tr>
<tr>
<td>Displays list of available application products, for example Performance Scorecard.</td>
<td>Displays in alphabetical order a list of favorite documents or folders defined by you or pushed to you</td>
</tr>
<tr>
<td>My Personal Page</td>
<td>Opens your personal page</td>
</tr>
</tbody>
</table>

### Tools Menu

The Tools menu is always available. Command availability is determined by product and roles.

### Table 20  Tools Menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Links &gt; Web Analysis Studio</td>
<td>Connect to Web Analysis Studio documents or launch applications or custom links from the Tools menu</td>
</tr>
<tr>
<td>Install &gt; Oracle’s Hyperion® Interactive Reporting Web Client</td>
<td>Install the Interactive Reporting Web Client, Smart View</td>
</tr>
</tbody>
</table>

### Help Menu

You use the Help menu to access Workspace Help, PDF files and information about Workspace.

### Table 21  Help Menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Help on this Topic</td>
<td>Displays help for the current topic</td>
</tr>
</tbody>
</table>
### Shortcut Menu Commands

To perform tasks, you can use shortcut menu commands, which are displayed when you right-click in Explore for a module document. Option availability depends on the content of the current window and the module from which the menu is accessed.

**Table 22  Shortcut Menu: Explore**

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Go Up A Level</td>
<td>Display the contents of the parent folder</td>
</tr>
<tr>
<td>New Folder</td>
<td>Add folders to the repository</td>
</tr>
<tr>
<td>New Document</td>
<td>From the New Document wizard, create documents, such as books, batches, analysis documents, or scheduled batch jobs</td>
</tr>
<tr>
<td>Open</td>
<td>Select, open, and use repository documents</td>
</tr>
<tr>
<td>Open In &gt; HTML Preview</td>
<td>View documents in browsers as HTML or PDF</td>
</tr>
<tr>
<td>Import &gt; File</td>
<td>Open the Import to Repository dialog box, used to import reports, books, snapshot reports and books, report objects (grid, text, image, and chart) and row and column templates into the repository</td>
</tr>
<tr>
<td>Import &gt; URL</td>
<td></td>
</tr>
<tr>
<td>Import &gt; File as Job</td>
<td></td>
</tr>
<tr>
<td>Import &gt; Financial Reports</td>
<td></td>
</tr>
<tr>
<td>Expand</td>
<td>From the View pane, display sub-folders under selected folder</td>
</tr>
<tr>
<td>Collapse</td>
<td>From the View pane, collapse selected folder</td>
</tr>
</tbody>
</table>
### Explore - Right Click Menu

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export</td>
<td>Open the Export dialog box, used to export saved reports, snapshot reports and books, and report objects (grids, text, image, and chart) from the repository</td>
</tr>
<tr>
<td>E-mail Link</td>
<td>Display the E-mail Editor dialog box, used to indicate recipient names and e-mail message subjects. E-mail Links Editor creates hyperlinks to files so recipients can view the files in Web browsers. Only Financial Reporting users can view hyperlinked files.</td>
</tr>
<tr>
<td>Cut</td>
<td>Remove repository items and place copies on the clipboard</td>
</tr>
<tr>
<td>Paste</td>
<td>Place cut and copied items in reports</td>
</tr>
<tr>
<td>Delete</td>
<td>Remove files from the repository upon confirmation</td>
</tr>
<tr>
<td>Delete with Outputs</td>
<td>For Interactive Reporting documents, delete items with job outputs, if there are outputs</td>
</tr>
<tr>
<td>Rename</td>
<td>Changes name of file or folders</td>
</tr>
<tr>
<td>Properties</td>
<td>Display scheduled batch detail; for example, the time for which a batch is scheduled</td>
</tr>
<tr>
<td>Run Job</td>
<td>For Interactive Reporting jobs, set job parameters and run jobs</td>
</tr>
<tr>
<td>Subscribe</td>
<td>Inform subscribing users of document changes</td>
</tr>
<tr>
<td>Search</td>
<td>Search for repository files</td>
</tr>
<tr>
<td>Create Shortcut</td>
<td>Create document shortcuts, for example, create shortcuts to Interactive Reporting, PDF, and HTML documents</td>
</tr>
<tr>
<td>Retrieve</td>
<td>Download and save an Interactive Reporting document</td>
</tr>
<tr>
<td>Schedule Job</td>
<td>Schedule Interactive Reporting Job</td>
</tr>
<tr>
<td>Add to Favorites</td>
<td>Add files to the favorites list</td>
</tr>
<tr>
<td>Refresh</td>
<td>Refresh the repository to include new folders and files</td>
</tr>
</tbody>
</table>
Setting Preferences and Personalizing your Workspace

In This Chapter

<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting Preferences</td>
<td>61</td>
</tr>
<tr>
<td>Setting Up the User POV for Financial Reporting Documents</td>
<td>73</td>
</tr>
<tr>
<td>Displaying Aliases and Descriptions in the User POV for Financial Reporting</td>
<td>75</td>
</tr>
<tr>
<td>Personalizing Your Workspace</td>
<td>76</td>
</tr>
<tr>
<td>Standard Files</td>
<td>79</td>
</tr>
</tbody>
</table>

Setting Preferences

Set defaults for general appearances of the user interface, Explore, authentication, applications, file types and Studios. For Planning end-user preference settings see the *Hyperion Planning – System 9 User’s Guide* and for administrator and application preferences, see the *Hyperion Planning – System 9 Administrator’s Guide*. For Financial Management end user preference settings see the *Hyperion Financial Management – System 9 User’s Guide*. Use these preferences tabs:

- “Setting General Preferences” on page 61
- “Setting Explore Preferences” on page 63
- “About Module Preferences” on page 65

User interface settings made with the View menu override default settings defined from General Preferences and stay until logging off. When you log on, user interface settings from Preferences are used. See “Personalizing Your Workspace” on page 76.

Setting General Preferences

All users have access to general preferences. For example, a Planning or Financial Management user can set an application as their default startup item at logon. General preferences set defaults for the UI appearance, default start page for the Content area, displaying document paths, displaying Tips tab, and a default e-mail address. Change passwords after logging on to the Workspace. This option is available to users with native authentication parameters specified, not external authentication.

Changes made using Preferences go into effect next time you log on.
➤ General preferences:
1 File > Preferences.

Note:
The e-mail address displayed is your e-mail address registered in your user’s security settings. You cannot update it.

2 Hide document file paths in the progress bar by clearing Show Path For Documents.
3 Workspace prompts you to save unsaved files by checking Prompt to Save Unsaved Files.
4 Hide the Tips Tab by deselecting the Show Tips Tab option.
5 In Default Startup Options for Content, select an option to display by default whenever you log in to Workspace. The default option is Explorer, if users have the Explorer role and None if not.
6 Depending on your selection in step 5, complete the following:
   ● Explore option, click Select. From Select, select a folder and click OK. The path and folder displays in Folder.
   ● Document option, select Select. From Select, select a document and click OK. The path and document name displays in the Document text box.
   ● Favorite option, select one of the following:
     ○ Click Use Current Page to select a page you have open to display in the content area.
     ○ Select a page from Favorite. The page displays in Favorite.
   ● Performance Scorecard option, select one of the following:
     ○ Click Use Current Page to select a page you have open to display in the content area.
     ○ Enter a Scorecard/Map name in the text box.
   ● For Application option, select the drop-down arrow next to the Application field. Select either Consolidation for Financial Management applications or Planning for Planning applications.
7 Perform one of the following tasks:
   ● Save changes, click OK.
   ● Cancel changes, click Cancel.

Setting Authentication Preferences
Set Authentication preferences to change your Workspace login password.

➤ Set Authentication preferences:
1 File > Preferences, click Authentication.
2 In Change Password, enter your current password and a new password.
3 Re-enter your new password to confirm.
4 Click OK.

➤ For Interactive Reporting and SQR Production Reporting authentication:

1 File > Preferences, click Authentication.
2 Repeat step 2 through step 4 above in the In Credentials Used for Pass-Through area.

**Setting Explore Preferences**

Set Explore preferences to define default folders and default permissions for items that you create or import. You can specify default permissions for specific users, groups, or roles. If you do not set these preferences, the Default folder and New Document folder are set to the top-most, or root folder and permissions for items are set to Empty.

You can modify the following Explorer Preferences:

- **Default Folder** - Your default folder is shown when you use Explore. Set it to the folder you access most frequently.

- **New Document Folder** - The New document folder is the default folder where the new document wizard searches for Web Analysis database connection files and Interactive Reporting documents. If you are creating new Interactive Reporting documents and browse for data sources this folder is used.

- **Default Permissions** - Default permissions are applied when you create a folder or import artifacts. Default permissions determine:
  - The ability of a user, group, or role to access the item.
  - Whether to automatically push the item to the user, group, or role favorites.

**Note:**

These default permissions are automatically applied to all artifacts you create or import. You can override these defaults by manually changing the permissions when you create or import the artifact.

➤ Set default folders:

1 File > Preferences, select Explore.
2 Set the Default folder and New Document folder.
3 Click Select, and do one of the following steps:
   - From Look in, select a folder.
   - From the list of names:
     - Select a folder
     - To navigate, double-click a folder

   The folder you select is displayed in the Name text box.
Tip:
Do not type a name in the Name text box.

4 From Default Permissions, select one of the following:
   - Interactive Reporting documents
   - Interactive Reporting jobs
   - SQR Production Reporting jobs
   - Generic jobs
   - All other documents
   - Folders

5 Click OK or Cancel.

6 To continue setting default permissions, repeat step 3.

➤ Set default permissions:
Select Set Permissions to set default permissions for users, groups, and roles. The Permissions dialog is displayed. See “Setting Permissions and Pushing Artifacts” on page 113.

Formatting Preferences
The following preferences can be set for all reports created from Workspace:
   - “Default Formatting Preferences” on page 64
   - “User Preferences and Formatting Options” on page 65

Default Formatting Preferences
Default Formatting preferences specify default data formatting for all subsequently created reports. Options are organized by their ability to amend, format, or replace data returned from the data source.

<table>
<thead>
<tr>
<th>Formatting Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Leading and Trailing Formatting</td>
<td></td>
</tr>
<tr>
<td>Currency Symbol</td>
<td>Inserts the following currency formatting symbols into the Positive Prefix and Negative Prefix text boxes: Dollar ($), Cents (¢), Pound (£), Euro (€), Deutschmark (DM), Franc (F), and Yen (¥).</td>
</tr>
<tr>
<td>Positive Prefix</td>
<td>Enters character to precede positive numeric values.</td>
</tr>
<tr>
<td>Positive Suffix</td>
<td>Enters character to follow positive numeric values.</td>
</tr>
<tr>
<td>Formatting Options</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Negative Prefix</td>
<td>Enters character to precede negative numeric values. <strong>Warning:</strong> The minus sign (-) is the default prefix. Deleting the default prefix without replacing it causes negative values to display positively.</td>
</tr>
<tr>
<td>Negative Suffix</td>
<td>Enters character to follow negative numeric values.</td>
</tr>
<tr>
<td>Numeric Formatting</td>
<td></td>
</tr>
<tr>
<td>Grouped Thousands Check Box</td>
<td>Displays numeric digits as grouped by thousands.</td>
</tr>
<tr>
<td>Minimum Decimals</td>
<td>Indicates the minimum number of decimal places to display.</td>
</tr>
<tr>
<td>Maximum Decimals</td>
<td>Indicates the maximum number of decimal places to display.</td>
</tr>
<tr>
<td>Scale</td>
<td>Enables abbreviated values by tens, hundreds, thousands, ten-thousands, hundred-thousands, millions, and billions.</td>
</tr>
<tr>
<td>Use Negative Color Check Box</td>
<td>Indicates that negative numbers are signified by a selected color.</td>
</tr>
<tr>
<td>Select Negative Color</td>
<td>Enables you to select the color representing negative values.</td>
</tr>
<tr>
<td>Samples</td>
<td></td>
</tr>
<tr>
<td>Update Samples</td>
<td>Updates the samples panel based on the most recent formatting selections.</td>
</tr>
<tr>
<td>Replace Missing With</td>
<td>Replaces missing values with either a text string or zero.</td>
</tr>
<tr>
<td></td>
<td>● Zero</td>
</tr>
<tr>
<td></td>
<td>● Text</td>
</tr>
</tbody>
</table>

**User Preferences and Formatting Options**

There are identical formatting options and user preferences. User preferences are global settings applied to new documents. User Preferences can be overridden by database connection formatting and document-based formatting.

Order of Formatting Precedence:

1. Options saved with documents
2. Options saved with the database connection
3. Options specified in the User Preferences dialog box

Spreadsheet user preferences and chart user preferences are identical to spreadsheet options and chart properties. They are only applied to subsequently created documents.

**About Module Preferences**

Web Analysis, Financial Reporting, SQR Production Reporting, Interactive Reporting, Financial Management, and Planning preferences are accessed from the Preferences dialog box:
Setting Web Analysis Preferences are organized on three tabs. These options specify the active preference file, set default leading and trailing data value formatting, numeric formatting, and database connection parameters for Web Analysis documents.

Setting Preferences for Financial Reporting include options for how you want to preview documents, POV settings, export options, and formatting options, preferences for designing reports, the language to use, units of measure and guidelines document layouts.

Setting Preferences for SQR Production Reporting include scanning folders for SQR Production Reporting Jobs.

Setting Preferences for Interactive Reporting include options for setting locale defaults based upon the country of origin, date and time formatting, and number formatting.

➤ To display the Preferences dialog box, select: File > Preferences

Setting Web Analysis Preferences

Preferences are stored in the repository as preference files. A preferences file is located in every users Profiles folder. Share preference files with other users. Although multiple preference files can be defined, only one preference file can be active at a time.

Note:

Only subsets of Web Analysis preferences are set through Workspace. The Web Analysis Studio offers a comprehensive interface for specifying Web Analysis preferences. Workspace and the Web Analysis Studio modify the same files.

Setting the Active Preferences File

The Preferences dialog box Active Preferences tab specifies the current preferences file.

Selecting Use My Preferences indicates you are using and editing the preferences file located in your Profiles folder. Selecting Use Shared Preferences indicates you are using a shared preferences file at the specified repository location.

Note:

The default location for Shared Preferences files is in the User<Profiles> folder.

Changing the Active Preference does not impact opened documents in the content area. User and shared preferences are only applied to subsequently created documents.

Upon editing shared preferences files, change the default behavior for users referencing that file. To prevent users from changing your preferences, restrict yourself to using your own preferences file.
Default Document Open Mode

- Selecting HTML or Web Analysis Studio, as your default document open mode, opens Web Analysis documents in the default mode selected.
- Selecting HTML opens the document in Workspace.
- Selecting Web Analysis Studio launches a Web Analysis Studio session, automatically logging in and opening the selected document.

**Note:**
This option will open one Web Analysis document per session in the Web Analysis Studio.

Web Analysis Database Preferences

Web Analysis Databases user preferences provide an inventory of available database servers and database connections by listing the database connection name, description, alias table, and repository location.

To review database connection names, click Edit. The Database Preferences dialog box is displayed. It has three tabs:

- Details
- Point of View
- Personal Variable

Click Connect to connect to data sources and retrieve values. If you are unable to connect, you may browse to another database connection file.

About Alias Tables

Alias tables are database tables that store aliases, or alternate description labels, for dimensions or members. Essbase enables you to define multiple alias tables. Web Analysis user preferences enable you to specify which alias table to use. The alias table selection is saved as a Web Analysis Database user preference.

Label mode enables you to select whether dimension members are listed by ID number or description. Label mode options are data source-specific, and are set for database connections, specific documents, and specific dimensions.

Label mode indicates whether the description or ID number is used and the database alias table provides the displayed value. Set the alias table before opening documents using Web Analysis Database user preferences.

Specify which description label to use in specific dimensions, using Dimension Browser and set a default label mode after querying the data source using Data Display options on the data object right-click menu.
Setting Alias Tables

Specify default alias tables for database connections:

1. **File > Preferences.**
2. **Click Web Analysis.**
3. **Click Active Preferences, and select either Use My Preferences, or Use Shared Preferences.** If you select Use Shared Preferences, click Browse and select a shared preferences file from the repository.
4. **Click to make the Databases tab the current tab.**
   The Databases tab lists all available database connections for the active user.
5. **Optional: To edit database preferences for a database connection, select the database connection from the list then click Edit.**
6. **Optional: To add a database connection to the list, click Add.**
   The Database Preferences dialog has three tabs: Details, Point of Views, and Personal Variables. Point of Views and Personal Variable tabs are disabled until a database connection is identified.
7. **Optional: To identify database connection files, perform one:**
   - Click Browse and navigate to a database connection file in the repository. Select the file, click Open then OK.
   - Enter the repository location and filename for existing database connection files in the text area.
     If you do not have access to database connection files, consult your Web Analysis administrator.
8. **Click Connect to retrieve the latest values from the database connection.**
   To log on to the data source, enter log on credentials, click OK.
   When you have connected to the data source, the Database File Location text area is disabled, and the Connect button is converted to a Disconnect button. Data sources supporting Point of View, Personal Variables and Alias Tables have these controls.
9. **Select an alias table from the Alias Table drop down list.**
10. **Click OK.**
    Whenever the specified database connection is used, the selected label mode is also used. Subsequent label mode selections made in the Cube Navigator or the Dimension Browser overwrite these default settings.

Setting the Database Logon Method

Web Analysis enables you to select among several data source log on options, and to save that selection as a Web Analysis Database user preference.

Set default log on methods for specific database connections:

1. **File > Preferences.**
The User Preferences dialog box is displayed.

2 Click Web Analysis.

3 Click Active Preferences, select Use My Preferences or Use Shared Preferences. If you select Use Shared Preferences, click Browse and select shared preferences file from the repository.

4 Click to make the Databases tab the current tab.

The Databases tab lists all available database connections for the Active user.

5 Optional: To edit database preferences for a database connection, select the database connection from the list then click Edit.

6 Optional: To add database connections, click Add.

The Database Preferences dialog box is displayed. It has three tabs: Details, Point of Views and Personal Variables. The Point of View and Personal Variable tabs are disabled until database connections are identified.

7 Optional: To identify database connection files, perform one:
   - Click Browse and navigate to database connection files in the repository. Select the file and click the Open dialog box OK button.
   - Enter the repository location and filename for existing database connection files in the text area.

   If you do not have access to any database connection files, consult your Web Analysis administrator.

8 Click Connect to retrieve the latest values from the database connection.

Enter valid log on credentials, click OK.

When you have connected to the data source, the Database File Location text area is disabled, and the Connect button is converted to a Disconnect button. Data sources supporting Point of View, Personal Variables and Alias Tables, have these controls.

9 Select one option from the Default Logon group:

<table>
<thead>
<tr>
<th>Default Logon Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use User’s name and Password</td>
<td>Connects to the database connection using the Web Analysis user name and password.</td>
</tr>
<tr>
<td>Prompt for User Name and Password</td>
<td>Connects to the database connection by prompting the user for a Web Analysis user name and password.</td>
</tr>
<tr>
<td>Enter User Name and Password</td>
<td>Connects to the database connection using a user name and password for the database connection, if it varies from the Analyzer Login parameters. You must enter the valid values in the corresponding text areas.</td>
</tr>
</tbody>
</table>

10 Click OK.
About Point of View Definitions

Point-of-view database preferences enable you to automatically insert dimensions and members that are of interest to them into the documents of others. Point of View definitions must be defined and activated specifically for a database connection.

When a point of view (POV) is activated, the Use Point of View check box in Cube Navigator and the Document Creation wizard are enabled. All subsequently created and loaded documents use the specified POV until it is deactivated. You can also deactivate use of POV by deselecting the Cube Navigator Use Point of View option as needed.

Point of View definitions consist of both axes and dimension member selections. The entire definition is used when new documents are created with the activated POV.

When you apply a point of view definition to an existing document, only the dimension member selections are applied. This prevents points of view from automatically arranging non-functioning layouts (such as moving all dimensions to a single axis).

If all POV member selections are custom filters, you may not see obvious changes to your document. Check to see which POV is applied on the View pane Information Panel tab, Point of View segment.

Using a point of view definition is a three part process. First, create a point of view definition. Next, activate the point of view definition. Lastly, set an existing document to use the activated point of view definition or create a new document that uses it.

Consider the following benefits:

Generic and Specific Documents

Document designers in large enterprises can create sets of generic documents, knowing that individual users can superimpose diverse and user-specific member selections into documents.

Replacing Member Selection Statements

Apply the complex calculations and analysis tool definitions of others’ documents to the dimensions and members they track, using Point of View. This eliminates the need for the user to investigate and recreate these analyses.

Default Dimension Layout and Member Selections for New Documents

When Point of View is activated, the document-creation process is simplified. Cube Navigator is loaded with the dimension member selections designated by the current Point of View.

Session-based Point of View

Point of View is session-based. Point of View definitions are saved and recalled as part of individual database connections. This enables them to be used on all the documents using the corresponding database connection.

Reloading Documents

You must reload the document for the applied Point of View definition to be displayed.
Point of View and Personal Variables

Point of View definitions replace all existing member selections for corresponding dimensions and database connections. Personal variables augment existing member selections for single dimensions. Leverage personal variables in the creation of Point of View definitions.

About Personal Variables

Define and name complex member selections. Leverage personal variables when they are presented with the corresponding dimension and database connection.

Generic and Specific Documents

Other users create personal variables using the same name, dimension, and database connection that contain the dimensions members that are of interest to them. This technique creates hybrid documents with generic and user-specific content.

Point of View and Personal Variables

Point of View definitions replace existing member selections for corresponding dimensions and database connections. Personal variables augment member selections for single dimensions. Leverage personal variables in the creation of Point of View definitions.

Setting Preferences for Financial Reporting

➤ Set Financial Reporting preferences:

1 File > Preferences

2 Click Financial Reporting.

3 From Financial Reporting, select HTML Preview or PDF Preview to indicate default preference when previewing documents.

4 From User Point of View:
   ● Select On to enable the User Point of View to display prior to running a report or Off to disable. Off is the default.
   ● Select where on the Workspace you want to display the Point of View. In View Pane is the default. You can also select to display above the report or book.
   ● Select Setup Members to select members you want available when using the User POV. The Setup User POV dialog is displayed. See the “Setting Up the User POV for Financial Reporting Documents” on page 73 for more information.

5 Select a character for the Thousands Separator. The options are comma (,), period (.), underscore (_), and Space.

6 Select a character to represent decimal points (for example, 1,000.06) for the Decimal Separator. The options are comma (,), period (.), underscore (_), and Space.

7 From Export to Office Application, select either Office 2000 or Office 2002 or higher as the version of Microsoft Office that you have installed.
Note:
If Office 2000 is selected, Excel is the only Microsoft Office application to which you can export; if Office 2002 or higher is selected, Excel, Word, and PowerPoint are the applications to which you can export.

8 Select Merge Equivalent Prompts to respond only once or deselect to respond consecutively to prompts and variables that are repeated multiple times.

Note:
The setting for Merge Equivalent Prompts takes precedence in the Workspace. However, if the Merge Equivalent Prompt is not set in the Workspace, the default setting in the fr_global.properties file is used.

9 From the Financial Reporting Studio tab, use the drop-down menus to make selections for Language, Units, and Guidelines. You can also select whether you want to enable XBRL editing. See the Hyperion Financial Reporting – System 9 User’s Guide.

10 Select OK.

Setting Preferences for SQR Production Reporting

Use this for SQR Production Reporting files.

➤ Set preferences for SQR Production Reporting:

1 File > Preferences > Production Reporting.

2 Do one of the following:
   ● Select All Folders to scan folders listed in Explore.
   ● Select the Selected Folders option to search folders listed in the Folder window.

3 Use the Add and Remove buttons to add and delete folders from the Folder window. Selecting the Add button opens a Select dialog from which you can select the folders to add to your search. To remove a folder from the Folder window, select the folder and click the Remove button.

4 Select OK.

Setting Preferences for Interactive Reporting

➤ Set preferences for Interactive Reporting:

1 File > Preferences > Interactive Reporting.

2 Select the country from the locale drop-down menu that you are setting the defaults for. The locale selected sets the locale or country associated with the default format that you want to use. The locale that you select determines the available number, date, and currency formats.
3 Select a format for the date, timestamp, time, and month from each of the drop-down menus. Date sets the
default date format, timestamp sets the default time and date format, time sets the default time format,
and month sets the default month format for the month used in Add Date Groups.

4 Select a format for the real number, integer, and null option from each of the drop-down menus. Null sets
the default format for null values. Null values are empty values for which no data exists. Null values are not
equal to zero. Real sets the default format for real values and integer sets the default format for integer
values.

5 Select OK.

Default Open Interactive Reporting Format

The Default Open Format drop-down on the Interactive Reporting Preferences window enables
you to set the default program to open Interactive Reporting documents when you select open
from the menus. The default program can be set to HTML or Interactive Reporting Web Client.
If the Interactive Reporting document is opened as HTML, the document is displayed in HTML
format in the Content pane. In Interactive Reporting Web Client format, the document is opened
in a special application file placed in a Web browser's plug-in directory.

➤ To select the default program:

1 Select File > Preferences > Interactive Reporting.
2 Select the default program to open the document from the Default Open Format drop-down and click OK.

Setting Up the User POV for Financial Reporting Documents

Dimensions often contain members that you may never access. Setting up the user POV enables
you to create a choices list for any dimension in a specified data source. If a choices list is set up
for a dimension, only the members in the choices list are displayed when the dimension is
accessed from the user POV. Any members not included in the choices list are hidden. See
“Displaying Aliases and Descriptions in the User POV for Financial Reporting” on page 75.

➤ Set up user POVs for Financial Reporting in the Workspace:

1 File > Preferences.
2 Click Financial Reporting.
3 From the User Point of View area of the General tab, select the Setup Members button.

Tip:
Select Refresh to update the list of database connections.

4 Select a data source from Database Connection.
5 If prompted, enter log on credentials, select OK.
Note:
Use the Planning Details data source only if your grid will contain Supporting Detail or Planning Unit Annotations. In all other cases, use Essbase as the data source.

6 Click Go to Member Selection: Dimension button, to select the members you want to be available when using the User Point of View. The Setup User POV page is displayed for member selection.

7 Expand the views to select available members, then click the Add to Selected button, . The selected members are displayed in the Selected column and are in the Choices list.

Note:
The Choices list is displayed whenever you are using the specified data base connection in a member selection.

Managing Dimension Members
The procedures for managing members are found here:
- Showing Dimension Properties
- Arranging the Selected Members

Showing Dimension Properties
Determine the properties to display for dimension members by performing the following.

Note:
The changes made apply only to the dimension selected. Each dimension has different display properties. The properties list varies from one dimension to another.

➤ Modify the properties displayed for dimensions:

1 On Select Members of the Setup User POV dialog box, click Show Properties, . The dimension properties list is displayed.

2 Perform one of the following:
   - Select an unchecked property to add the column to the table.
   - Select a checked property to remove the column from the table.

3 Repeat step 2 until only the desired columns are displayed.

4 Click OK to retain the changes.

5 The dimension properties table displays the choices you made.
Arranging the Selected Members

The members in the Setup User POV member selection Dialog box can be arranged in a particular order.

To change the order in which members are displayed in the selected member list:

1. From the Select column of the Setup User POV member dialog box, select a member to move.
2. Perform one of the following:
   - Click \( \text{\(\uparrow\)} \), to move members up.
   - Click \( \text{\(\downarrow\)} \), to move members down.
3. Repeat the first two steps until the member order arrangement is complete.
4. Click OK to save all changes.

Displaying Aliases and Descriptions in the User POV for Financial Reporting

Select how members display in the user POV Financial Reporting documents in Workspace. Members are displayed by name of member, by alias/description, or both member name and alias/description. Specify how to display the member label or whether dimension labels are included.

Display aliases/descriptions in the user POV:

2. From User Point of View, click General, select Setup Members.

   Tip:
   - Select the Refresh button to update the list of database connections.
3. Select data sources from Database Connection.
4. If prompted enter your log on credentials, click OK.

Note:
- Use the Planning Details data source only if your grid will contain Supporting Detail or Planning Unit Annotations. In all other cases, use Essbase as the data source.
5. Select the member label you prefer from Display Member Label. The label selection is based on the data source you are using.
6. From the Dimension Labels are: drop-down list, select whether to include or not include dimension labels.
7. Perform one of the following tasks:
   - Click OK to save your current changes and return to the repository screen.
• Click Cancel to cancel your current changes.
• Click Apply to save the changes and continue manipulating dimensions for other database connections.

Personalizing Your Workspace

When using Workspace, perform customization tasks to change the user interface appearance. Use the View menu or user preferences for customization.

• The user interface settings made with the View menu override the default settings defined in the General Preferences tab and remain in effect until you log-off.
• Each time you log on to Workspace user interface settings from the General Preferences tab are used.

The following table describes the tasks you can perform to customize Workspace user interface.

<table>
<thead>
<tr>
<th>Customization Task</th>
<th>Modules</th>
<th>Menu Bar Command</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show/hide the View pane</td>
<td>All modules</td>
<td>View &gt; View Pane</td>
</tr>
<tr>
<td>Resize the View pane and content area</td>
<td>All modules</td>
<td>See &quot;Resizing the View Pane and Content Area&quot; on page 76</td>
</tr>
<tr>
<td>Which file types are listed in the content area</td>
<td>Explore</td>
<td>View &gt; Display Items of Type. See “Showing Specific File Types” on page 77</td>
</tr>
<tr>
<td>Whether to show hidden files in the content area</td>
<td>Explore</td>
<td>View &gt; Show Hidden</td>
</tr>
<tr>
<td>Which item properties are displayed in the content area</td>
<td>Explore</td>
<td>View &gt; Show Columns. See “Displaying Columns” on page 77</td>
</tr>
<tr>
<td>Sort items in the content area</td>
<td>Explore</td>
<td>See “Sorting Items” on page 77</td>
</tr>
</tbody>
</table>

Resizing the View Pane and Content Area

➤ Resize the View pane and content area:

1. Drag the mouse and point to the column border between the View pane and the content area.

   Tip:
   You must point to the View Pane/Content Area Adjuster which is displayed as a faint double line in the border.

2. When the pointer changes to a horizontal double-headed arrow, drag the border to the right or left.
Displaying Columns

From Explore, items and properties display in the columns within the content area. The setting you make for the columns are retained after you log-off.

➤ Hide or display columns:

1. **View > Show Columns.**
2. Display or hide columns by setting or clearing its check-box. For example, select the check box for Size to display as a column in the content area.
3. To specify the column width, click a column check box, and enter the new column width in pixels.

**Note:**
You cannot specify the column width for exceptions, priority, or versions.

4. **Click Save to save or Cancel to discard your changes.**
   1. To reorder columns, do one of the following steps:
      - Click a column, use ▼ and ▲ arrows.
      - **View > Show Columns.**
      - From the content area, drag and drop the columns.

➤ Resize column widths:

1. **Drag the mouse and point to a column border in the column header.**
2. When the pointer changes into a horizontal double-headed arrow, drag the border to the right or left.

Sorting Items

From Explore, alphabetically sort by items in the columns within the content area. Sort using any column heading. Date columns are sorted chronologically.

➤ To sort a column, click the column heading, then do one of the following:
   - To sort items in ascending order, click the icon next to the column heading to point up.
   - To sort items in descending order, click the icon next to the column heading to point down.

Showing Specific File Types

From Explore, you can specify which file types to display in the content area.

**Note:**
Your role and permissions also determine if an item is displayed.
Display specific file types:

1. Select View > Display Items of Type. You have the following options to choose from:
   - All Files—Displays all files in Explore
   - Select from a list of file type groups—See step 2.
   - Hyperion or Standard—Displays either Hyperion type files or standard files, see “Standard Files” on page 79.
   - Other—select a particular file from the dialog box displayed.

2. Optional: For the list of file type groups, you can select only one file type group from the list.

### Table 26  File Type Groups

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All Jobs (and Output)</td>
<td>Displays all jobs and all job output.</td>
</tr>
<tr>
<td>All Jobs</td>
<td>Displays all jobs. This includes all items imported as a job.</td>
</tr>
<tr>
<td>All Job Output</td>
<td>Displays all job output produced from running a job.</td>
</tr>
<tr>
<td>External Links</td>
<td>Displays all items imported as a URL.</td>
</tr>
<tr>
<td>All Office Files</td>
<td>Displays Microsoft Word, Excel, Power Point, and Project files. It also displays files with the file extensions .mht, .mhtml, or .nws.</td>
</tr>
<tr>
<td>All Reports</td>
<td>Displays:</td>
</tr>
<tr>
<td></td>
<td>- SQR Production Reporting documents</td>
</tr>
<tr>
<td></td>
<td>- Interactive Reporting documents</td>
</tr>
<tr>
<td></td>
<td>- Web Analysis documents</td>
</tr>
<tr>
<td></td>
<td>- Financial Reporting reports, snapshot reports, books, snapshot books and batches</td>
</tr>
<tr>
<td>All Financial Reporting Objects</td>
<td>Displays all Financial Reporting reports, snapshot reports, books, snapshot books and batches</td>
</tr>
<tr>
<td>All Connections</td>
<td>Displays all database connection files:</td>
</tr>
<tr>
<td></td>
<td>- Interactive Reporting database connection</td>
</tr>
<tr>
<td></td>
<td>- Web Analysis Analytic Services (Essbase) database connection</td>
</tr>
<tr>
<td></td>
<td>- Web Analysis Financial Management database connection</td>
</tr>
<tr>
<td></td>
<td>- Web Analysis Relational database connection</td>
</tr>
<tr>
<td></td>
<td>- Web Analysis SAP Info Cube database connection</td>
</tr>
<tr>
<td></td>
<td>- Web Analysis SAP Multiprovider database connection</td>
</tr>
<tr>
<td></td>
<td>- Web Analysis SAP InfoSet database connection</td>
</tr>
<tr>
<td></td>
<td>- Web Analysis SAP ODS database connection</td>
</tr>
<tr>
<td></td>
<td>- Web Analysis SAP Query Cube database connection</td>
</tr>
<tr>
<td>All Images</td>
<td>Displays all image files with the following extensions:</td>
</tr>
<tr>
<td></td>
<td>- .gif</td>
</tr>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td></td>
<td>● .jpeg</td>
</tr>
<tr>
<td></td>
<td>● .png</td>
</tr>
<tr>
<td></td>
<td>● .bmp</td>
</tr>
<tr>
<td></td>
<td>● .tiff</td>
</tr>
<tr>
<td></td>
<td>● .xbm</td>
</tr>
<tr>
<td></td>
<td>● .xwb</td>
</tr>
<tr>
<td>Hyperion</td>
<td>Displays the following:</td>
</tr>
<tr>
<td></td>
<td>● SQR Production Reporting documents</td>
</tr>
<tr>
<td></td>
<td>● Interactive Reporting documents</td>
</tr>
<tr>
<td></td>
<td>● Web Analysis documents, presentations, database-connection files.</td>
</tr>
<tr>
<td></td>
<td>● Financial Reporting reports, snapshot reports, books, snapshot books and batches</td>
</tr>
<tr>
<td></td>
<td>● All jobs</td>
</tr>
<tr>
<td></td>
<td>● All Job output</td>
</tr>
<tr>
<td></td>
<td>● All connections</td>
</tr>
<tr>
<td></td>
<td>● HTML files</td>
</tr>
<tr>
<td></td>
<td>● SPF security files</td>
</tr>
<tr>
<td>Standard</td>
<td>Displays files with the following extensions:</td>
</tr>
<tr>
<td></td>
<td>● .xls</td>
</tr>
<tr>
<td></td>
<td>● .doc</td>
</tr>
<tr>
<td></td>
<td>● .mpp</td>
</tr>
<tr>
<td></td>
<td>● .ppt</td>
</tr>
<tr>
<td></td>
<td>● .pdf</td>
</tr>
<tr>
<td></td>
<td>● .html</td>
</tr>
<tr>
<td></td>
<td>● .txt</td>
</tr>
<tr>
<td></td>
<td>● .xml</td>
</tr>
<tr>
<td></td>
<td>● .zip</td>
</tr>
<tr>
<td></td>
<td>● .rtf</td>
</tr>
<tr>
<td>Other</td>
<td>Select one file type to display from the list of file types.</td>
</tr>
</tbody>
</table>

**Standard Files**

Standard files include text files, log files, HTML files, and Microsoft Office files. The administrator sets up the types of files that the repository supports. See Chapter 3, “Exploring and Managing Items.” Open the following standard file types from Workspace:

- .xls
- .doc
- .mpp
● .ppt
● .pdf
● .html
● .txt
● .xml
● .zip
● .rtf
Exploring and Managing Items

In This Chapter

Using Explore ................................................................. 81
Items .................................................................................... 81
Basics of Explore ................................................................. 86
Viewing Priorities, Exceptions, and Versions ..................... 87
Managing Files ....................................................................... 87
Linking to Other Applications ........................................... 92
Creating E-mail Links to Items ........................................... 92
Using Ambiguous Items .................................................... 94
Registering a File Type ....................................................... 94
Exporting Items ................................................................. 94
Exporting to Smart View for Office .................................... 95
Changing Related Content Servers for Financial Reporting ... 99
Changing Financial Reporting Database Connections ........... 99
Managing Database Connections for Financial Reporting .... 101

Using Explore

Explore enables you to list and navigate repository contents; manage and control files and folders; and use elements, like the Open dialog box, that present the repository as a file management system. User’s roles and the installed Reporting and Analysis modules determine what parts of the user interface are shown — as a result some documents are displayed in the content area and others can also be opened in their own studios. For example, for Interactive Reporting, you can have it set to always open documents in the Interactive Reporting Web Client.

Access privileges or permissions determine which items you can view, modify, run and delete in the repository. See “Setting Permissions and Pushing Artifacts” on page 113.

Items

Items are objects stored in the repository, including files, folders, URLs and shortcuts. Items are HTML files, Interactive Reporting database connections, jobs, batches, documents, reports, and presentations.
All items have properties which store information about files such as attributes and access control information. Properties include: type, a description of the file, and search keywords.

Items are categorized into the following:

- “Documents” on page 82
- “Collections” on page 83
- “Supporting Files” on page 83
- “Other Standard Files” on page 85
- “_folders” on page 85

## Documents

Documents are files created using Oracle's Hyperion applications. Documents include Interactive Reporting documents, Financial Reporting reports, snapshots, Web Analysis documents and SQR Production Reporting documents. Documents are listed and viewed using Explore. Items opened from Explore display as tabs at the bottom of the Workspace. The following table describes viewable documents. Documents can contain and generate the following:

- **Dashboard**—Collection of metrics and indicators provide interactive summaries of your business.
- **Report**—Formatted data values and interactive elements. Reports are displayed in tabular, grid, or chart formats.

**Note:**

Performance Scorecard content is not stored in the repository; however you can view it using Workspace.

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
<th>Created in</th>
<th>File Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>SQR Production Reporting document</td>
<td>Reports querying a relational data source</td>
<td>SQR Production Reporting Studio</td>
<td>.spf</td>
</tr>
<tr>
<td>Interactive Reporting document</td>
<td>Formatted, dynamic, document that generates reports or dashboard typically querying a relational data source.</td>
<td>Oracle's Hyperion® Interactive Reporting Studio, Oracle's Hyperion® Dashboard Development Services, and Workspace</td>
<td>.bqy</td>
</tr>
<tr>
<td>Web Analysis document</td>
<td>Web Analysis document typically querying an OLAP data source.</td>
<td>Web Analysis Studio and Workspace</td>
<td>.ard</td>
</tr>
</tbody>
</table>
### Collections

Collections contain references to groups of documents, such as books, presentations, or job output files. Collections are listed and viewed using Explore. Items opened from Explore display as tabs at the bottom of the Workspace.

**Table 28 Collections in the Repository**

<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
<th>Created in</th>
<th>File Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job Output</td>
<td>Collection of files resulting from running a job.</td>
<td>Workspace</td>
<td>Files are a variety of extensions, such as .pdf, .html, or .txt.</td>
</tr>
<tr>
<td>Snapshot Books</td>
<td>Generated books containing static data.</td>
<td>Workspace</td>
<td>.kbt</td>
</tr>
<tr>
<td>Batches</td>
<td>Collection of executable Financial Reporting Studio documents and books with special properties and are executed to generate reports.</td>
<td>Workspace</td>
<td>.bch</td>
</tr>
<tr>
<td>Presentation</td>
<td>Collections of Web Analysis documents.</td>
<td>Web Analysis Studio</td>
<td>.apt</td>
</tr>
</tbody>
</table>

### Supporting Files

The following tables list Workspace supporting files used when authoring or managing documents or collections.
<table>
<thead>
<tr>
<th>Type</th>
<th>Description</th>
<th>Studio created in</th>
<th>File Extension</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job</td>
<td>Items with special properties that execute to generate output. Jobs contain Interactive Reporting documents, SQR Production Reporting documents or generic documents.</td>
<td>Interactive Reporting - created with Workspace by importing Interactive Reporting documents.</td>
<td>Interactive Reporting jobs do not have file extensions.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>SQR Production Reporting - created with Workspace by importing SQR Production Reporting program files (*.sqr).</td>
<td>SQR Production Reporting jobs have .sqr file extensions.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Generic - created with Workspace by importing Oracle reports or batch files. Generic reports use a command line interface.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>Generic jobs can have a variety of file extensions, such as .sh, .bat.</td>
</tr>
<tr>
<td>Interactive Reporting</td>
<td>Portable files defining terms, conditions, and methods for connecting to data sources.</td>
<td>Interactive Reporting Studio</td>
<td>.oce</td>
</tr>
<tr>
<td>database connection</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>SQR Production Reporting</td>
<td>Files that SQR Production Reporting program references when executed:</td>
<td>SQR Production Reporting Studio</td>
<td>File extensions include .cvs, .img, or .inc.</td>
</tr>
<tr>
<td>Studio files used by a SQR</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Production Reporting</td>
<td>- Include files (#include commands)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>document or SQR Production Reporting job.</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Input data files (Open for-reading commands)</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Image files (print-image and declare-image commands)</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Folder</td>
<td>Containers that contains other folders and files.</td>
<td>not applicable</td>
<td>none</td>
</tr>
<tr>
<td>Shortcut</td>
<td>Pointer to a repository item. Creates shortcuts when you want an item to display in folder A, though it is stored in folder B.</td>
<td>not applicable</td>
<td>none</td>
</tr>
<tr>
<td>URL</td>
<td>Link to Web sites or HTML pages.</td>
<td>not applicable</td>
<td>none</td>
</tr>
</tbody>
</table>
### Other Standard Files

Other standard files include text files, log files, and Microsoft Office files. The administrator sets the types of files that the repository supports. See “Registering a File Type” on page 94.

### Folders

*Folders* exist with the repository and are arranged in a hierarchical structure. Folders are used for organization, they can contain subfolders and items such as jobs, documents, and URLs. The *root* folder contains all files and folders.
Basics of Explore

Use Explore to list, find or view content. Items opened in Explore display as tabs at the bottom of the Workspace. The View pane displays folders. When Explore is active, the following buttons display in the View pane:

- **Document** - View document control panels in the View pane that enables you to view different sections of the document.
- **Tips** - Perform tasks, view tips that are Help topics, or view file or folder details, such as name, type, author and modified date.
- **Folders** - View a list of folders in the View pane.

**Note:**

A search icon, 📚, is displayed in the View pane of Workspace when you select **Tools > Search**. See “Searching for Files or Folders” on page 91.

When items have high priority, multiple versions, or is manually flagged as an exception, an icon is displayed. In order to see these icons the priority, version, or exception column must be displayed.

Folder Contents:

- Sub-folders in the left pane; click the plus button next to the folder name.
- Folders in the left pane and items in the content area; double-click the folder.
- Contents in the content area; click an item.

**Note:**

When entering names for items in the repository such as files and folders, you can use upper and lowercase letters and numbers. Spaces cannot be used at the beginning or end of folder names. Invalid Name characters are as follows: \, /, %, ?, +, <, >, |, ` , * , " . Invalid Path characters are as follows: \, %, ?, +, <, >, |, ` , * , " .

**Note:**

Since importing Financial Reporting objects with invalid characters in their Names/Path is still allowed, those objects once imported in Workspace, should be renamed. Scheduled Batches containing object names with invalid characters will fail when PDF and HTML are selected as output options.
Viewing Priorities, Exceptions, and Versions

When an item is listed in Explore, an icon displays indicating priorities, exceptions, or multiple versions. You can view and set the following conditions:

- **Priority** - High or low priority.

  **Table 30  Priorities**

<table>
<thead>
<tr>
<th>File Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All items that have versions</td>
<td>Use version properties to set an item’s priority to Normal or High. Only available if your administrator activated the priority feature.</td>
</tr>
</tbody>
</table>

  **Note:**

  Priorities for scheduled jobs differ from an item’s priority. Set priorities on schedules you associate with jobs. Priority is a property of schedule. If multiple job are scheduled to run simultaneously, the high priority job is run first. The priority icon is not displayed next to the job. See “Scheduling Jobs” on page 380.

- **Exceptions** - Indicator of conditions or results such as a threshold being reached. Notify subscribing users when an exception has been generated and monitor exceptions on the Exceptions dashboard on your Personal Pages.

  **Table 31  Exceptions**

<table>
<thead>
<tr>
<th>File Type</th>
<th>Exceptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Items with versions</td>
<td>Manually flag an exception on an item. See “Version Properties” on page 122.</td>
</tr>
<tr>
<td>SQR Production Reporting jobs</td>
<td>Programmatically enable jobs to generate exceptions. The exception icon is not displayed next to the job. See “Using Exceptions” on page 140.</td>
</tr>
<tr>
<td>Interactive Reporting jobs</td>
<td></td>
</tr>
<tr>
<td>Generic jobs</td>
<td></td>
</tr>
</tbody>
</table>

- **Versions** - Indicates an item has multiple versions. See “Working with Versions” on page 120.

  To display the priority, versions or exceptions column:

  1. **View > Show Columns.**
  2. **Click Priority, Version, or Exception.**

Managing Files

This section describes the following tasks associated with managing files and folders in the repository.

- “Opening or Selecting Files or Folders” on page 88
Opening or Selecting Files or Folders

After opening files or folders, its contents display in the content area. Items have multiple versions. Imported files are collections containing a single version. You can later save or import additional versions. Versions can be revisions of the same file or completely different files.

➤ Open files using the shortcut menu:

   ● From the content area of Explore, right-click a file, from the shortcut menu select Open In, then select a format. See one of the following:
     ○ For Financial Reporting items, see “Viewing Reports” on page 166.
     ○ For Interactive Reporting items, see “Selecting an Interactive Reporting Data Source” on page 203.
     ○ For Web Analysis items, see “Opening Presentations” on page 307 and “Creating Documents from Documents” on page 312.
     ○ For SQR Production Reporting items, see “Viewing an SQR Production Reporting Document” on page 301.
     ○ For generic files, you can select an option to open the file in a browser window.

➤ Open files using default formats:

1. From Explore, double-click the file or folder.
2. To view or interact with the opened item, see “Using Different File Types” on page 126.

➤ Open or select a file or folder:

2. Navigate to the file or folder, perform the following:
   ● From the Name column, double-click the file or folder to open.
   ● From Look in, select a folder.
   ● To filter the list of items, from the Type list box, click the arrow, select the file type.
Tip:
Click Go Up A Level to move up the folder hierarchy specified in the Look in: text box.

3 Click Open.

4 Optional: To open a file with another application:
   - Click Options.
   - From Open As: select an application to open the file.

Note:
Every file type on your local system maintains information about which application will launch that type of file, and where the application resides. See “Registering a File Type” on page 94.

5 Optional: To open a version of the item, from Versions list, select the version, click Open.

6 To view and interact with the opened item, see “Using Different File Types” on page 126.

Saving Files
Save files to replace them or save files using a new name, which creates a copy of the file. You can save the following files in Workspace:
- Interactive Reporting document
- Web Analysis document
- Snapshot Book
- Book
- Batch

To save
1 Open the file. See “Opening or Selecting Files or Folders” on page 88.
2 File > Save.
3 To save the file with a new name; File > Save As, specify a name and location.

Creating Folders
Create folders to organize files and documents.

To create folders:
1 Select Navigate > Explore, then select the folder in which you want to create a folder.
2 Select File > New > Folder.
3 Type a name for the folder, select Save.
Note:
When entering names for items in the repository such as files and folders, you can use upper and lowercase letters and numbers. Spaces cannot be used at the beginning or end of folder names. Invalid Name characters are as follows: \%/?.+,<,>,|;`. Invalid Path characters are as follows: \%/?,+,<,>,|;`

Creating Documents or Collections
You can create the following documents or collections:
- Interactive Reporting, see “Using the Toolbars” on page 198
- Web Analysis, see “Creating Web Analysis Documents” on page 309
- Book or Snapshot book, see “Creating Books” on page 181
- Batch, see “Designing Batches” on page 192
- Job, see “Importing Files as Jobs” on page 110

Moving Files or Folders
You can move a file or folder to another location.

Note:
You cannot make a copy of a file or folder in the repository. An alternative solution for copying is to export the file and import it with a new name.

To move files or folders:
1. Select Navigate > Explore, then the file or folder you want to or move.
2. Edit > Cut.
3. Click the folder where you want to copy or move the item.
4. Edit > Paste.

Tip:
To select consecutive files or folders to copy or move, select the first item, press and hold down SHIFT, and select the last item. To select files or folders that are not consecutive, hold down CTRL, and select each item.

Renaming Files or Folders
Rename files or folders by changing it’s properties.
Rename files or folders:

1. Select Navigate > Explore.
2. Edit > Rename.

Note:
When entering names for items in the repository such as files and folders, you can use uppercase and lowercase letters and numbers. Spaces cannot be used at the beginning or end of folder names. Invalid Name characters are as follows: \\, /, ?, +, <, >, |, `,*,”. Invalid Path characters are as follows: \\, %, ?, +, <, >, |, `,*,”.
3. Click OK.

Deleting Files or Folders

Delete files or folders:

1. Select Navigate > Explore.
2. Edit > Delete.

Caution!
Deleted files cannot be restored.

Tip:
Delete files or folders by right-clicking then Delete.

Searching for Files or Folders

Search for files or folders with keywords. Keywords are defined for items in order for the search to work. See “Advanced Properties” on page 118.

Narrow your search by specifying the folder or files location, date, file type, or priority. The following rules apply:

- Not case-sensitive.
- The search icon displays on the toolbar when you are in Explore only.
- The search starts in the folder specified in the Look in: text box and searches all sub-folders recursively.

Search for files or folders:

1. Select Navigate > Explore.
2. Select Search from the toolbar.

3. In Keywords, type a keyword for the file. Wild cards are not supported in the Keywords text box.

**Tip:**

Multiple keywords are separated by a space. A keyword containing a space must be double quoted.

4. For additional search criteria, click Options, specify the following options:
   - Use one method to locate the drive, folder or network you want to search:
     - Look in text box.
     - Select button.
   - Select Types to look for files of a type.
   - Select Date, to look for files from a time period.
   - Specify one of the following search methods:
     - Match on any word (or), to match one word specified in the Keywords text box.
     - Match on all words (and), to match words specified in the Keywords text box.
   - Select Find Only High Priority to find items marked as high priority.
   - Select Include Hidden Items to search for files that are normally hidden and not displayed in Explore.

5. Click Search Now.

### Linking to Other Applications

You can open Web Analysis Studio from Workspace.

➤ Link to applications:

- Tools > Links:

<table>
<thead>
<tr>
<th>Link to</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Web Analysis Studio</td>
<td>Oracle’s Hyperion® Web Analysis Studio enables you to access and create documents and presentations.</td>
</tr>
</tbody>
</table>

### Creating E-mail Links to Items

E-mail links to items in the repository. E-mailing link rules:

- Recipients must be defined as a user with a Workspace user name and password to open the linked item in a Web browser.
Recipients need proper access privileges to view the item.

Items in the link can be viewed in Web browsers. A link to the item is sent not the item. When you click on the link, Workspace is opened and the item is displayed.

You cannot send an e-mail link to a folder.

You must select and send e-mail links one item at a time.

You can add text to the e-mail message.

Create e-mail links:

1. From the repository, select the item to e-mail.

Tip:

If the e-mail link option does not display for an item, that item cannot be sent as an e-mail link.

2. File > E-mail Link. The Email Link dialog box, containing the URL links is displayed.

Note:

If your default e-mail address is not specified, you are prompted to select File > Preferences and provide your e-mail address. Your e-mail address is used as the sender for the e-mail link.

3. Perform one of the following tasks:
   - Enter the recipient’s e-mail address.
   - Use the Recipient List, see Using the E-mail Recipient List.

4. Optional: Update the Subject text associated with the e-mail message.

5. Click Send.

Note:

You cannot recall a message after it is sent.

Using the E-mail Recipient List

Use the e-mail recipient list to organize a list of recipients to which you send e-mail links. By entering addresses in this list you do not need to retype e-mail address again. Two e-mail recipient lists are maintained; one for e-mailing links, one for e-mailing batch notifications.

Use the e-mail recipient list:

1. Select File > Email Links.

2. Click Select to display Email Link, and select recipients.

3. Optional: To add a recipient, in New Recipient, type the e-mail address and click .

4. Optional: To remove an e-mail from the selected recipient list, select an e-mail and click .
Using Ambiguous Items

It is possible for different items to have the same name and reside in the same folder. These are ambiguous items. When an ambiguous item is accessed, a list of items with the same name are displayed. Select the item you want to use. This may happen when you perform the following:

- Create e-mail links to an ambiguous item.
- Prompted to select related content links that link to an ambiguous item.

Select ambiguous items:

1. From the list, select the item you want.
2. To determine the differences between the items, do the following:
   - To view the item properties, right-click the item, select Properties.
   - To open and view the item, see “Opening or Selecting Files or Folders” on page 88.

Registering a File Type

The server maintains information about Repository items and which application to launch to open that type of file and where the application resides.

Administrators create file types (technically, new MIME Types) or add file extensions to file types. You may be informed of the new type by your administrator, or you may discover it while browsing or trying to open a file. If there is a file type that your browser cannot open, you are prompted for a program to open it. To avoid that prompt, you need to register the type in your browser or operating system.

The procedure to register new file extensions or MIME types varies with each operating system, its version, your browser, and the browser’s version. Consult the documentation or on-line help of the browser or operating system or ask your system administrator.

Exporting Items

From Explore, only Financial Reporting items have an export option. Export items for the following usages:

- Locations outside of Workspace. You can import items into a Studio or back into Workspace later. Financial Reporting items can export from testing environments to production environments.
- For use in Smart View, see “Exporting to Smart View for Office” on page 95.

Export items:

1. Click Navigate > Explore.
2. File > Export.
3. To navigate to items, preform the following:
From the Look in: list box, select a folder.

To filter the list of items, from the Type list, select the file type.

4 Select the items, click OK.

5 Click Save.

6 Navigate to the location where you want to save the exported file.

7 Click Save.

Exporting to Smart View for Office

This section describes Smart View functionality, concepts and procedures. Smart View provides a common Microsoft Office interface for the following Workspace components:

- Financial Reporting, see “Exporting Financial Reporting Reports and Snapshots to Microsoft Office” on page 97
- Production Reporting, “Exporting Production Reporting Content to Microsoft Excel” on page 98
- Web Analysis, “Exporting Web Analysis Documents to Microsoft Office” on page 98
- Interactive Reporting, Interactive Reporting does not enable Smart View export options

It also provides a common Microsoft Office interface for Essbase, Financial Management and Planning.

The centralized interface enables simultaneous use of multiple Hyperion products and improves integration with Microsoft Office (2000, 2002, and 2003). The Smart View implementation provides the following Workspace functionality:

- Exports the current page of the current data object to Excel, Word, or PowerPoint
- Exposes Financial Management and Essbase functions in Excel, Word, and PowerPoint content
- Notifies you when you can upgrade to new releases of Smart View

About Hyperion System 9 BI+ Smart View Export Options

Smart View enables the following export options:

- You can export the current page of the current data object to Word, PowerPoint or Excel as an image. After insertion, you can re-query the corresponding Web application to refresh the image.

You can export documents to Microsoft Excel as either query-ready HTML or formatted HTML:

- When you export content as query-ready HTML, the current page of the current data object is converted to HTML and Hyperion-specific formatting is removed. This enables Smart View to re-query the data source independent of the Web application.
- When you export content as Formatted HTML, the current page of the current data object is converted to HTML with the Hyperion formatting definitions and calculated members. This specific formatting content prevents Smart View from directly querying the data source, but enables Hyperion content to be leveraged by Office applications.

Not all export options are supported by all data sources and Web applications. The following table indicates export options to Smart View:

Table 33  Smart View Export Options

<table>
<thead>
<tr>
<th>Web Applications</th>
<th>Export Image to Microsoft Word, and PowerPoint</th>
<th>Export Formatted HTML to Excel</th>
<th>Export Query-ready HTML to Excel</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analytic Services</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Financial Management</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Planning</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes *</td>
</tr>
<tr>
<td>Financial Reporting</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Interactive Reporting</td>
<td>N/A</td>
<td>N/A</td>
<td>N/A</td>
</tr>
<tr>
<td>Production Reporting</td>
<td>N/A</td>
<td>Yes</td>
<td>N/A</td>
</tr>
<tr>
<td>Web Analysis</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

**Note:**

To export Hyperion Planning data sources in query ready format, you must use the Hyperion Analytic Services provider.

**Note:**

Exporting charts from SQR Production Reporting is not supported in this release.

Because Excel worksheets prevent users from entering data into read-only cells, some Excel functions such as AutoSum, F9, and some formatting functions are disabled in Smart View. Also note that you must have Microsoft Excel, Word, and PowerPoint installed on the computer running the Hyperion System 9 BI+ client.

**Importing BI+ Content**

Using Smart View, you can import Financial Reporting through Workspace. You can use smart tags to import BI+ content. For information on importing content and using smart tags, see the *Hyperion System 9 Smart View for Office User’s Guide.*
Installing Smart View From Workspace

Smart View is installed with Hyperion System 9 BI+ but to use Smart View you must also separately install a client component. This Office client component is displayed as a Hyperion menu and toolbar within the Microsoft Office suite.

Note:
Before installing Smart View, exit the Interactive Web Client and Microsoft Office applications, and enable pop-ups.

To install the Smart View client from Workspace:

1 Select Tools > Install> Smart View.

The Hyperion Smart View installation wizard is launched.

2 Accept the default installation options.

By default, the installation wizard installs Oracle’s Hyperion® Smart View for Office program files to C:\Hyperion\SmartView. You can specify an alternative installation directory.

3 Reopen the Microsoft Office application.

Note:
If Word fails to display the Hyperion menu, create a data source connection in Excel then restart Word.

Exporting Financial Reporting Reports and Snapshots to Microsoft Office

Note:
To export Financial Reporting report and snapshots to Microsoft Word or PowerPoint as an image, you must install and configure either GNU or AFPL Ghostscript on the Financial Reporting Print server.

To export a report or snapshot to Microsoft Excel, Word, or PowerPoint:

1 Open a report and select File > Export.

2 Select one of the following submenu commands:
   ● To export the current page of the current financial report as query-ready HTML, select Excel > Query-Ready Grid and Text.

      You cannot use this option to export snapshots.

   ● To export the current financial report as formatted HTML, select Excel > Fully-Formatted Grid and Text.
To export the current page of the current financial report to Microsoft Word as a static image, select **Word**.

To export the current page of the current financial report to Microsoft PowerPoint as a static image, select **PowerPoint**.

Snapshots are always exported as static images.

The **File Download** dialog box displays profile information about exported content.

3 **Select an option:**

   - Select **Open** to display exported content in the specified application.
   - Select **Save** to save the content.

**Note:**

When exporting Financial Reporting grid objects to Excel the values are exported as displayed in the report. The desired number of decimal places for precision should be set in the report before exporting.

---

**Exporting Web Analysis Documents to Microsoft Office**

To export the current page of the current data object of the current Web Analysis document to Microsoft Excel, Word, or PowerPoint:

1 **Right-click a data object and select Export.**

2 **Select one of the following submenu commands:**

   - To export the current page of the current data object as query-ready HTML, select **Excel > Query-Ready Grid and Text**.
   - To export the current page of the current data object as formatted HTML, select **Excel > Fully-Formatted Grid and Text**.
   - To export the current page of the current data object to Microsoft Word as a static image, select **Word**.
   - To export the current page of the current data object to Microsoft PowerPoint as a static image, select **PowerPoint**.

Although the image is static, you can re-query the Web application as needed.

Data is exported to the Microsoft Office application and displayed in a worksheet.

---

**Exporting Production Reporting Content to Microsoft Excel**

To export content to Microsoft Excel as Fully-Formatted HTML:

1 **Select Navigate > Explore and choose File > Import > File as job.**

2 **Click Browse and select an SQR job.**
3 Proceed through the pages in the wizard. When you get to the last page, select Excel (.xls) as the output option.

4 Look in the Table of Contents for the Excel output.

**Changing Related Content Servers for Financial Reporting**

You can change the server for selected reports and grids or both in Workspace repository by specifying a new URL or a substitution variable. For example, you may want to change the related content servers when moving reports and grids from a development server to a production server.

➤ To change the related content server in Workspace repository:

1 Select Navigate > Explore, then select Tools > Change Related Content Links.
2 In Select, select a file and click OK.
3 In Change from the Related Content server named, change the URL to that associated with the selected documents, if it is not already displayed.
4 In To Related Content server name, select an option:
   - To specify a server through a URL, select URL, then enter the path and server name in the text box. The URL must start with either http:// or https://.
   - To specify a server using a substitution variable, select Substitution variable, then select a variable from the drop-down list.

   **Note:**
   
   For information on setting up substitution variables in the fr_subvars.properties file, see the Hyperion Financial Reporting Studio User’s Guide.

5 Click OK. The number of occurrences found and replaced is displayed.
6 Click OK.

**Changing Financial Reporting Database Connections**

You can change the database connection for reports and books in Workspace repository. You change the database connection when moving from a development environment server to a production environment server.

When the dimensions in the changed database connections do not match the previous dimensions, an error message similar to the following is displayed:

1012:Report contains an invalid grid. The following dimensions could not be found: Measures

The following actions occur when you open and save a report that has mismatched dimensions:
● Dimensions that existed in the old database connection but not in the new database connection are removed. The dimensions and its members that existed in the rows and or columns are removed from the grid. If, as a result of the removal, no dimension exists in the row or column, you need to add a valid dimension to the cleared row or column in order for the report to run.

● Dimensions that exist in the new database connection but not in the old one, are added to the POV.

If the report contains at least one dimension in both the row and column, it can be run and opened when the error message is received. The report can also be exported from the repository.

If you do not like the modifications that are automatically made for mismatched dimension, you can close the report and change to the original database connection.

When you change the database connection for reports or books, you can also select to validate that the databases have the same dimension. When this option is selected for a report, and dimensions do not match, you are prompted that the action failed. Likewise, if dimensions do not match for a specific report in a book, you are prompted that the action for the entire book failed. If you do not choose to validate, the database connection for the reports and books are changed and you are not prompted for mismatched dimensions. However, errors may occur when you open or run the reports or books.

➤ To change the data source in the repository:

1 From Workspace, select Navigate > Explore to display the Select dialog box, then select Tools > Change Database Connections.

2 In the Type field, select a report type to change, and click OK. Change Database Connection is displayed.

3 Select the item and click OK.

4 In Find all references to the Database Connection, select the database connection to change.

5 In Replace With, select a database connection.

Note:

To create a new database connection, click New Database Connection. See “Adding Database Connections” on page 102.

6 Make changes to all items that you selected.

7 Click OK.

Changing Analytic Services and Planning Details

When changing a report from Analytic Services database connection to a Planning Details database connection or vice versa, there are several restrictions. The data source reference is the only change and there is no conversion.
Changing from Analytic Services to Planning Details

The following is a list of considerations when changing the database connection from Analytic Services to Planning Details for a report:

- The dimensions and functions defined in reports and books must exist in the target data source. The following limitations apply:
  - Attribute dimensions are not supported as dimensions in Planning Details.
  - Hsp_Rates is not available as a dimension.
  - The cell text function cannot be used, because Linked Reporting Objects (LROs) are not supported.
  - Only the member selection using a level 0 is supported.
- Validate that dimensions exist prior to opening the report. If a dimension defined on a grid is not available in the Planning Details data source, no change is made. If an invalid function is used, an error is returned. The report designer has to remove the invalid function or dimension.

Changing from Planning Details to Analytic Services

There are several features that may be defined in a Planning Details report that are irrelevant for Analytic Services report, including PlanningAnnotations, Supporting Detail, and OrderBy. If Supporting Detail is defined in the report, the details are ignored. If PlanningAnnotations or OrderBy are used, they return an error. The report designer must remove the PlanningAnnotation function and OrderBy for the report to run.

Managing Database Connections for Financial Reporting

The Database Connection Manager provides a means to manage reports, books, saved reports objects (row/column templates, grids), batches, and scheduled batches. Reports and report objects can be moved from a development environment to a production environment, or between production servers. The Database Connection Manager provides the following information about each database connection:

- Name—The database connection name
- Type—The data source type (Analytic Services, Financial Management, Planning, SAP BW)
- Value—The connection path

A designer can use Workspace to create, maintain, and assign names to database connections. Users can select an existing database connection when prompted throughout the Financial Reporting Studio; for example, while adding a grid to a report. A database connection consists of a database name, ID, password, and several values that are different for each data source.
## Table 34  Valid Database Values by Database

<table>
<thead>
<tr>
<th>Database</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Essbase</td>
<td>Server</td>
</tr>
<tr>
<td></td>
<td>Application</td>
</tr>
<tr>
<td></td>
<td>Database</td>
</tr>
<tr>
<td></td>
<td>Data Source Type</td>
</tr>
<tr>
<td>Financial Management</td>
<td>Server</td>
</tr>
<tr>
<td></td>
<td>Application</td>
</tr>
<tr>
<td></td>
<td>Data Source Type</td>
</tr>
<tr>
<td>Planning</td>
<td>Application</td>
</tr>
<tr>
<td></td>
<td>Database Connection</td>
</tr>
<tr>
<td></td>
<td>Data Source Type</td>
</tr>
<tr>
<td>SAP BW</td>
<td>Server</td>
</tr>
<tr>
<td></td>
<td>System Number</td>
</tr>
<tr>
<td></td>
<td>Client</td>
</tr>
<tr>
<td></td>
<td>Application</td>
</tr>
<tr>
<td></td>
<td>Database</td>
</tr>
<tr>
<td></td>
<td>Data Source Type</td>
</tr>
<tr>
<td>SSAS</td>
<td>Server</td>
</tr>
<tr>
<td></td>
<td>Application</td>
</tr>
<tr>
<td></td>
<td>Database</td>
</tr>
<tr>
<td></td>
<td>Data Source Type</td>
</tr>
</tbody>
</table>

Related Content:

For more information on managing database connections, see the following topics:

- “Adding Database Connections” on page 102
- “Editing Database Connections” on page 103
- “Deleting Database Connections” on page 104

### Adding Database Connections

When you create a database connection, it is appended to the list in the Database Manager dialog box.

➤ To add a database connection

1. In Workspace, select Navigate > Explore. Then select Tools > Database Connection Manager.
2. Click New.
3 In Database Connection Properties, enter a Database Connection Name.

4 Select a data source Type.

5 The remaining values will differ, based on the data source selected. See Table 34 to view values that display for each data source.

6 To add application and database names, click, and make your selections.

   Note:
   The Application Lookup button displays a tree view of the applications and corresponding databases; the applications are listed as parents and the databases are listed as children. You can search on an application or database. For data sources that are not associated with a database, only applications are listed.

7 Click OK.

8 The database connection profile is appended to the list in Database Connection Manager Dialog.

Selecting an Application and Database Name

The Select Application dialog box displays a tree view of the applications and corresponding databases; the applications are listed as parents and the databases are listed as children. You can search on an application or database.

To Select an Application and Database Name:

1 Scroll through the list to locate your selection, or enter an application or database name in the Application/Database field.

   Note:
   For data sources that are not associated with a database, only applications are listed.

2 For a data source associated with a database, select the database and click OK. For a data source that is not associated with a database, select the application and click OK.

Editing Database Connections

You can edit database connections, when required.

To edit a database connection:

1 In Workspace, select Navigate > Explore. Then select Tools > Database Connection Manager.

2 In Database Connection Manager, select the database connection to edit, then click Edit.

3 Make your changes, then click OK.
Deleting Database Connections

You can delete database connections, when required.

To delete a database connection:

1. In Workspace, select Navigate > Explore. Then select Tools > Database Connection Manager.
2. In Database Connection Manager, select the database connection to remove, then click Delete.
3. An information prompt is displayed. Select Yes to delete.
4. The database connection is removed from Database Connection Manager.

Using the Key Figure Manager for Financial Reporting

Key Figure Manager is used against an SAP BW data source only. A key figure is a dimension contained in every SAP BW cube. Financial Reporting allows the creation of two additional types of key figures: calculated and restricted. Using Key Figure Manager, you can create calculated and restricted key figures. The Calculated and Restricted key figures created in the Key Figure Manager become additional members for the SAP BW key figure dimensions within the Select Members dialog in Financial Reporting Studio; calculated key figures are contained in the Calculated Key Figure folder and restricted key figures are shown in the Restricted Key Figure folder. The report designer can use those key figures in place of or in addition to the SAP BW defined key figure members to return more definitive values in a report.

- Calculated — You can recalculate the key figures for use in Financial Reporting using formulas. Calculated key figures consist of formula definitions containing basic key figures. You can create a calculated key figure based on a key figure or any functions listed in the Key Figure Manager.

- Restricted — Restricted are key figures of the cube that are filtered by one or more dimension member selections, and are needed in order to define a detailed report. By using restricted key figures, you can focus the query result on certain values.

New Calculated and Restricted key figures are stored in Key Figure Manager and are available for use in Member Selection. You can now use the calculated and restricted key figures in your Financial Reporting Studio.

To define a new calculated key figure:

1. Navigate to the Key Figure Manager by selecting Tools > Manage Key Figures.
2. In Key Figure Manager, select a SAP BW data source, then click New Calculated.

Note:
You may be prompted to enter a database connection.

3. In Calculated Key Figure, enter a name for the calculated key figure you are creating.
4. In the Add Function container, select Key Figure and/or function, then click Add.
**Note:**
When you select a function, your calculation is based on a dimension other than Key Figure. For functions, the **Formula** dialog box is displayed where you select the **Dimension** and **Measures** fields.

5. In **Member Selection**, select a Member for your formula and click **OK**. The member is entered into the **Formula** text box in **Calculated Key Figure** dialog box.

6. In **Calculated Key Figure**, define the variable and values for your formula by using the **Add Literals** keypad.

7. Click **OK** to accept the formula. The Calculated Key Figure information is stored in **Key Figure Manager** and is added to Select Members for a SAP BW data source in Financial Reporting Studio.

**Note:**
An error message is displayed for an invalid formula.

➤ To define a new Restricted key figure:

1. Navigate to the **Key Figure Manager** by selecting **Tools > Manage Key Figures**.

2. In **Key Figure Manager**, select a SAP BW data source, then click **New Restricted**.

**Note:**
You may be prompted to enter a database connection.

3. In **Restricted Key Figure**, enter a name for the restricted key figure you are creating.

4. In the **Dimension** container, select **Key Figure**, then select click ![Image](image1.png) to select a key figure member.

5. **Optional.** In the **Dimension** container, select a **Dimension**, then click ![Image](image2.png) to select members for which you want to display members. To select another dimension members, repeat this step.

6. Click **OK** to accept the restricted key figure information. The Restricted Key Figure information is stored in **Key Figure Manager** and is added to Select Members for a SAP BW data source in Financial Reporting Studio.

➤ To edit a calculated or restricted key figure, click **Edit**.

**Note:**
The Key Figure Name cannot be edited.

➤ To delete a calculated or restricted key figure, click **Delete**.
Importing

Importing artifacts to the repository makes them available to others. You might give users the ability to modify one artifact, while limiting others. See “Setting Permissions” on page 113 for detailed information on permissions.

Note:

If you try to import an artifact whose MIME type is not defined, you get an error message. Contact your administrator to create the MIME type.

Table 35 shows the Workspace Studios and artifacts you can import:

<table>
<thead>
<tr>
<th>Studio</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Financial Reporting</td>
<td>● Dynamic report (*.des)</td>
</tr>
<tr>
<td></td>
<td>● Snapshot reports (*.rpt)</td>
</tr>
<tr>
<td></td>
<td>● Books (*.kbk)</td>
</tr>
<tr>
<td></td>
<td>● Snapshot Books (*.kbt)</td>
</tr>
<tr>
<td></td>
<td>● Batch files (*.bch)</td>
</tr>
<tr>
<td></td>
<td>● Supporting files, see “Supporting Files” on page 83</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> To import these files, you must use the Import &gt; Financial Reports menu item.</td>
</tr>
<tr>
<td>SQR Production Reporting</td>
<td>● Documents to view (*.spf)</td>
</tr>
</tbody>
</table>
Interactive Reporting Documents and Jobs

Import an Interactive Reporting document as a file to use it with interactive analysis. Import an Interactive Reporting document as a job for scheduled or on-demand execution and distribution of output. The import essentially creates the job.

Note:

If the Interactive Reporting document you are importing uses row-level security, the row-level security feature is applied when job queries are processed. When users process queries to get more detailed information, their row level security restrictions would be applied at the more detailed levels, such as sales data for their region or department only.

Table 36 The following table describes when to import an Interactive Reporting file or job.

<table>
<thead>
<tr>
<th>Function</th>
<th>File</th>
<th>Job</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interactive with Workspace</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Schedule automatic execution</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Distribute output via E-mail</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Produce multiple-cycle output</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Distribute output to network directories</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Import current results for analysis with Interactive Reporting Web Client</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>FTP output</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>Print output</td>
<td>X</td>
<td></td>
</tr>
</tbody>
</table>
HTML Files

HTML image links and other HTML files are dependent on their folder locations. Ensure the links remain functional after you import them:

- Use relative links in the HTML
- Create folders that mirror the folder structure

Importing Artifacts

Import from Explore using File > Import and these instructions:

- Importing Files
- Importing Multiple Files
- Importing Files as Jobs
- Importing a URL
- Importing Financial Reporting Files

Importing Files

Import files into the repository with the following exceptions:

- For Financial Reporting files, see Importing Financial Reporting Files.
- For importing files as jobs, see “Importing Files as Jobs” on page 110.
- For Interactive Reporting .oce files, see “Setting Processing and Metadata Options” on page 407.
- For importing URLs, see “Importing a URL” on page 111.

To import files:

1. Select Navigate > Explore, navigate to the folder where you want to import the artifact.
2. Select File > Import > File.
3. Browse to the file you want to import.
   Required properties are marked with a red asterisk.
4. Optional: Enter a description, click Next, then click Finish without specifying any Advanced options.
5. Enter properties, see “General Properties” on page 117 and “Advanced Properties” on page 118.
6. Optional: Click Edit Permissions, see “Setting Permissions and Pushing Artifacts” on page 113.
7. Click Finish.

Note:
To return to a previous pages, click Back from the bottom of the page.
Importing Multiple Files

- Files must be imported to the current folder.
- Import different file types together. For example, import text files, HTML files and image files.
- You cannot import multiple Interactive Reporting files (*.bqy, *.oce) or SQR Production Reporting files (*.sqr, *.spf).

To import multiple files:

1. Select Navigate > Explore, navigate to the folder in which you want the files to reside.
2. Select File > Import > File.
3. Click Multiple Files.
4. Select the files you want to import.
   - Browse for the first file. Click >> (right-facing arrows) to add the file to the list. To delete files from the list, select the file and click << (left-facing arrows).
5. Optional: Enter a description, and click Finish to complete the import without specifying any Advanced options.
6. Click Next.
7. Enter properties. See “General Properties” on page 117 and “Advanced Properties” on page 118.
8. Click Finish to import the artifact.

The artifacts are imported into the current folder.

Importing Files as Jobs

Import SQR Production Reporting program files (*.sqr) to create Production Reporting jobs, Interactive Reporting documents (*.bqy) to create Interactive Reporting jobs or generic files to create generic jobs. Schedule, set options on and execute the job using the Schedule module, see “Scheduling Jobs” on page 380.

To import files as jobs:

1. Select Navigate > Explore, navigate to the folder where you want to place the artifact.
2. Select File > Import > File as Job.
3. Browse to the artifact you want to import, and click Next.
4. Do one of the following:
   - For SQR Production Reporting files and generic jobs, see Chapter 15, “Using SQR Production Reporting and Generic Jobs.” This chapter guides you through the steps to complete this wizard.
   - For Interactive Reporting BQY files, see “Setting Data Source and Query Properties” on page 404.
5 To define properties for an Interactive Reporting job:
   ● For Query properties, see “Setting Data Source and Query Properties” on page 404.
   ● For Job properties, see “Setting Interactive Reporting General Properties and Options” on page 405 and “Setting Interactive Reporting Job Properties” on page 402.
   ● For Job defaults, see “Setting Job Defaults” on page 405.
6 Enter properties, see “General Properties” on page 117 and “Advanced Properties” on page 118. Required properties are marked with a red asterisk.
7 Click Next.
8 Optional: For Advanced Properties, click Edit Permissions, see “Setting Permissions and Pushing Artifacts” on page 113.
9 Click Finish.

Importing a URL
Perform these steps to import URLs

➤ To import URLs:
1 Select Navigate > Explore, navigate to the folder where you want to place the artifact.
2 Select File > Import > URL, enter the URL name.
3 Optional: Enter a description, and click Finish to complete the import without specifying any Advanced options.
4 Click Next, then see “General Properties” on page 117 and “Advanced Properties” on page 118. Required properties are marked with a red asterisk.
5 Click Edit Permissions, to specify permissions for the artifact, see step 1.
6 Click Finish.

Using Workspace URLs
Use these steps to open Workspace URLs which point to a repository artifact
   ● Opening a URL
   ● Opening a URL in a New Window
   ● Updating a URL

Opening a URL
Perform the following steps to open a URL.
To open a URL:
1 Select File > Open > URL.
   The URL dialog is displayed.
2 Enter the URL name.
3 Select OK.

Opening a URL in a New Window

To open a URL in a new window:
1 Select Opening a URL.
   The content area displays the Web page.
2 Select New Window.
3 Enter the URL.
4 Select OK.

Updating a URL

Perform the following steps to update the content of an existing URL displayed in the content area.

To update a URL:
1 Select Opening a URL.
   The content area displays the Web page.
2 Select Update URL.
   The Update URL dialog is displayed.
3 Enter the URL.
4 Select OK.

Importing Financial Reporting Files

Use this procedure to import Financial Reporting files.

To import Financial Reporting files:
1 Select Navigate > Explore, navigate to the folder where you want to place the artifact.
2 Select File > Import > Financial Reports.
3 Browse to the files you want to import, then select one or more files.
4 Click Import.
5 Optional: If you import an artifact that uses a data source connection you are prompted to select it.

Setting Permissions

Access permissions define your level of access - view, modify, full control. When you import artifacts, you can:

- Specify who gets access and to what level.
- Have full control over the artifacts you import, and can change the permission level for all roles, groups, and users.
- Efficiently grant permissions through roles or groups rather than to individual users.

To modify permissions, use:

- Setting Permissions and Pushing Artifacts
- Setting Permissions on Interactive Reporting Documents

Setting Permissions and Pushing Artifacts

Set artifact permissions when you import or select it. Push artifacts to be accessible in the repository or Favorites.

Rules for setting permissions and pushing artifacts:

- To push artifacts, you need proper permissions and a role that enables you to push them.
  Push any artifacts, except multiple-cycle jobs and folders.
- Make artifacts accessible in the repository by changing their permissions.
- Make artifacts accessible on Favorites by pushing them to Favorites.
- To apply permissions to artifacts within folders, you need proper permission and role.

➤ To edit permissions for files and folders:

1 Select Navigate > Explore, right-click the file or folder whose permissions you want to modify.
2 Select Edit Permissions.
3 To complete the Permissions dialog, see step 1 on page 114.

➤ To apply permissions to artifacts in a folder:

1 Right-click on a folder in Explore.
2 Select Apply Permissions to Children.
3 To complete Permissions dialog, see step 1 on page 114 through step 3 on page 115.
4 Set permissions for the children of the folder. The columns displayed in the Edit Permissions dialog depend on the artifact type within the folder. Use the description for each of the permissions as a guideline:
<table>
<thead>
<tr>
<th>Permission</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inherit</td>
<td>Same rights as folder.</td>
</tr>
<tr>
<td>No Access</td>
<td>Users cannot see the object.</td>
</tr>
<tr>
<td>View</td>
<td>View document but cannot modify.</td>
</tr>
<tr>
<td>Modify</td>
<td>Make changes but not delete.</td>
</tr>
<tr>
<td>Full Control</td>
<td>Display, change, and delete.</td>
</tr>
<tr>
<td>Run</td>
<td>Ability to run a job.</td>
</tr>
<tr>
<td>Modify and Run</td>
<td>Change, but not delete.</td>
</tr>
<tr>
<td>View and Process</td>
<td>View documents and refresh data, cannot modify.</td>
</tr>
<tr>
<td>Analyze</td>
<td>Create and modify charts, pivots, and reports in the document, but cannot modify the queries or refresh the data.</td>
</tr>
<tr>
<td>Analyze and Process</td>
<td>Create and modify charts, pivots and reports in the document and refresh data. Cannot modify the query.</td>
</tr>
<tr>
<td>Query and Analyze</td>
<td>Create and modify charts, pivots and reports in the document and refresh data. Can build and limit queries before processing.</td>
</tr>
<tr>
<td>Data Model and Analyze</td>
<td>Create and modify charts, pivots and reports in the document and refresh data. Can build and limit queries before processing. Can create and modify data models.</td>
</tr>
</tbody>
</table>

5 Once you are done making your selections for the Edit Permissions dialog, select OK.

**Note:**

Permissions are only applied to artifacts within a folder in which a user has Full Control permission.

6 Select OK.

➤ To change permissions or push artifacts:

1 To specify **Available Users, Groups and Roles** perform the following:
   a. To populate the list with all users, groups or roles leave the text box blank, select Next.
   b. To populate the list with specified users, groups or roles:
      i. To filter the list by name, select begin with, contain, or are in group and enter letters. Do not use the are in group filter for roles.
      ii. To filter the list by user type, select roles, groups, or users, then click Update List. Available Users, Groups, and Roles display artifacts based upon the selections you made in the drop-down lists.
Note:

If all of the artifacts are not listed, filter the list with criteria or contact your administrator. Your administrator determines the maximum number of artifacts to list. Wild cards are not supported and the filter is not case sensitive.

2 Select artifacts from Available Users, Groups and Roles, then click Edit.

3 From Selected Users, Groups and Roles click an artifact then select Edit.

4 Set permissions:
   - Empty - Permissions are empty, this permission defaults to no access if this is the only permission set. If user U1 is contained in group G1 and the following permissions are assigned: modify permissions assigned to G1 and empty permissions assigned to U1, then the empty permission is ignored. If empty permissions are assigned to G1, then the lowest permission is used, which is no access.

   Note:
   This option is not displayed when setting permissions for folders.

   - No access - Cannot access the document.
   - View - Can only display the document.
   - Modify and Run - Change, but not delete.
   - Full control - Display, change, and delete.

   See “Setting Permissions on Interactive Reporting Documents” on page 116.

5 Select PUSHED to push the artifact to the user's Favorites.

6 Click OK.

7 Repeat step 1 on page 114 through step 6 on page 115 to set additional permissions for other users, groups, or roles.

Note:

If all of the users/groups/roles in which you have access to are not listed, filter the list with different criteria or contact your administrator. Your administrator determines the maximum number of users/groups/roles to list.

8 To apply these permissions for an artifact, select Push this item to selected Users, Groups, and Roles.

9 Do the following:
   a. For files, if you want permissions to apply to other imported content by default, click Make these the default permissions for all files I import.
   b. For folders, if you want permissions to apply to other imported content by default, click Make these the default permissions for all folders I create.

   This automatically sets the same permissions for all files and folders you import. You can change permissions for each file or re-set your default access permissions.

10 Click OK.
Note:

To remove a role, group, or user from the selected list, click after highlighting the name to be removed.

**Setting Permissions on Interactive Reporting Documents**

These permissions apply to Interactive Reporting files and jobs:

- Adaptive states specify what functionality is available to users when viewing an Interactive Reporting document.
- **Only user who ran the job has access to the job output** specifies you are the only user who can access the job output.

**Note:**

When importing an Interactive Reporting job, assign an adaptive state on the job output to access it.

<table>
<thead>
<tr>
<th>Adaptive State</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inherit</td>
<td>Not set to anything. This permission defaults to view only if this is the only permission set.</td>
</tr>
<tr>
<td>View Only</td>
<td>View document, but cannot modify.</td>
</tr>
<tr>
<td>View and Process</td>
<td>View documents and refresh data, cannot modify.</td>
</tr>
<tr>
<td>Analyze</td>
<td>Create and modify charts, pivots, and reports in the document, but cannot modify the queries or refresh the data.</td>
</tr>
<tr>
<td>Analyze and Process</td>
<td>Create and modify charts, pivots and reports in the document and refresh data. Cannot modify the query.</td>
</tr>
<tr>
<td>Query and Analyze</td>
<td>Create and modify charts, pivots and reports in the document and refresh data. Can build and limit queries before processing.</td>
</tr>
<tr>
<td>Data model and Analyze</td>
<td>Create and modify charts, pivots and reports in the document and refresh data. Can build and limit queries before processing. Can create and modify data models.</td>
</tr>
</tbody>
</table>

**Creating Shortcuts**

Create a shortcut to a file or document.

- To create shortcuts
  1. **Select Navigate > Explore**, navigate to an artifact.
  2. Right-click the artifact, click **Create a Shortcut**.
3 Enter the name and folder.
4 See “General Properties” on page 117 and “Advanced Properties” on page 118.

Working with Properties

This section describes how to modify properties of repository artifacts. You specify properties when importing and modifying artifacts. See “Importing Artifacts” on page 109 to learn how to access properties pages while importing artifacts.

Properties for artifacts:

- “General Properties” on page 117
- “Advanced Properties” on page 118
- “Output Properties” on page 119
- “Working with Versions” on page 120
- “Interactive Reporting Properties” on page 119
- “Production Reporting Properties and Generic Job Properties” on page 119
- “HTML File Properties” on page 119
- “URL Properties” on page 120
- “Interactive Reporting Database Connection Files” on page 120

➤ To access properties:
1 Select Navigate > Explore, select an artifact.
2 Select File > Properties.

General Properties

Most artifacts have these general properties: Table 39.

Table 39

<table>
<thead>
<tr>
<th>File</th>
<th>The file name and path.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>The name you assign to the file. For example, if the file is c:\Jan03SR set the name to January 2003 Sales Report. Use letters, numbers, a space, and an underscore (_) .</td>
</tr>
<tr>
<td>Description</td>
<td>The description used to generate search keywords. Limit the length to 254 characters.</td>
</tr>
<tr>
<td>Owner</td>
<td>(Read-only) The User Name of the person who imported the artifact.</td>
</tr>
<tr>
<td>Original File Name</td>
<td>(Read-only) The name of the file when it is imported or created.</td>
</tr>
<tr>
<td>Size</td>
<td>(Read-only) file size</td>
</tr>
</tbody>
</table>
A SmartCut is a URL pointing to a file.

Specify the folder and subfolders for shortcuts.

Set this when you import to store the file in WinZip format. This saves disk space, but slows down viewing.

Set rights for users to access files. See “Setting Permissions and Pushing Artifacts” on page 113.

Some artifacts have these advanced options: Table 40.

Table 40

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MIME Type</td>
<td>(Read Only) Multipurpose Internet Mail Extensions. Update this for jobs and documents only, MIME types are MS Word file, HTML file, and Personal Page.</td>
</tr>
<tr>
<td>Security Tags Included</td>
<td>(Read only) Indicates whether the SQR Production Reporting job is secure. Secure jobs are SQR Production Reporting only and always have HTML output.</td>
</tr>
<tr>
<td>Character Encoding</td>
<td>The character-encoding method, such as UTF-8. This encoding must be specified for HTML files so that Workspace can display the file correctly. If the character encoding is not specified in this property or in the HTML file, Workspace uses the character encoding set by your administrator.</td>
</tr>
<tr>
<td>Hidden File</td>
<td>Hides files in Explore. Example: Enable this option for image files needed by an HTML file, so the users select HTML files only.</td>
</tr>
<tr>
<td>Auto-delete file on this date</td>
<td>Enable to automatically delete this artifact. from the repository when these conditions are met: The expiration date passed. Auto-delete is selected. The system performs regular garbage collection (up to an hour after the expiration date). For folders, set auto-delete to occur after all contents have been deleted from the folder.</td>
</tr>
<tr>
<td>If Exceptions are generated, allow users to add to their Exceptions Dashboard</td>
<td>The Exceptions dashboard is displayed on a Personal Page. This field is not used for jobs. When a job exception occurs, subscribed users can be notified by E-mail or with a Exceptions Dashboard indicator.</td>
</tr>
</tbody>
</table>
**Automatically generate keywords**
Generates search keywords based on words contained in the Name and Description. For Interactive Reporting content, the section names are also used as keywords. The search function uses these keywords to find an artifact.

**Keywords**
New keywords used to search for an artifact. Creating keywords for artifacts is highly recommended and used for searching repository artifacts.

**Auto Delete job outputs after**
Used to delete job output after a specified time interval. The job output is deleted when all of these conditions are met:
- The expiration date has passed.
- Auto-delete is checked.
- The system performs its regular garbage collection (up to an hour after the expiration date).

---

**Output Properties**
Output properties option is displayed for Interactive Reporting and SQR Production Reporting jobs. A summary of the job outputs with the respective dates and output formats that the job outputs are available in are displayed when this property is selected for one of the previously mentioned products. You can also delete a selected output from the Output Summary.

**Interactive Reporting Properties**
In addition to General Properties and Advanced Properties, Interactive Reporting files and jobs have unique properties. See “Setting Interactive Reporting Job Properties” on page 402.

**Production Reporting Properties and Generic Job Properties**
In addition to General Properties and Advanced Properties, Production Reporting files and Production Reporting jobs have unique properties. See “Job Properties” on page 418 and “Generic Job Properties” on page 427.

**HTML File Properties**
In addition to General Properties and Advanced Properties, HTML files contain these unique properties also:

<table>
<thead>
<tr>
<th><strong>Table 41</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Character encoding</strong></td>
</tr>
</tbody>
</table>
Make displayable as a file content window | Contents of this artifact can be displayed on Personal Pages. (Default is enabled.)

**URL Properties**

In addition to General Properties and Advanced Properties, URLs have these properties:

<table>
<thead>
<tr>
<th>Table 42</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>URL (in the General Properties group)</strong></td>
</tr>
<tr>
<td><strong>Make displayable as a file content window</strong></td>
</tr>
<tr>
<td><strong>Character encoding</strong></td>
</tr>
<tr>
<td><strong>Icon</strong></td>
</tr>
<tr>
<td><strong>Change Icon</strong></td>
</tr>
</tbody>
</table>

**Interactive Reporting Database Connection Files**

These files are used by Interactive Reporting jobs and Interactive Reporting documents to connect to databases. Separate Interactive Reporting Database Connection file must be specified for each query within a file or job, except for queries that use Local Results. See “Selecting Database-Connection File Options” on page 406.

**Working with Versions**

Repository artifacts have multiple versions, except for jobs, job output, Interactive Reporting database connection files, shortcuts, Web Analysis artifacts and Financial Reporting artifacts.

Typical files are collections of versions, even if you have not imported multiple versions. When a file is imported, the resulting artifact is a collection containing a single version. You can later import additional versions.

Versions can be revisions of the same file or completely different files. If the file is considerably different from the original file, you should import a new file with a unique name.

**Note:**

To change imported versions for Interactive Reporting jobs or Interactive Reporting database connection files, use **Replace** in General Properties. It is important to replace the Interactive Reporting job or Interactive Reporting database connection file with a similar file. If the Interactive Reporting job is considerably different from the original Interactive Reporting job,
import a new job. The system accepts files as replacements for Interactive Reporting jobs or Interactive Reporting database connection files.

Click an artifact’s name for the latest version. When you move or delete an artifact, versions are included in the operation.

Versions have their own properties that are distinct from the properties of their collection artifact.

This section describes how to manipulate versions:

- Opening a Version
- Viewing or Modifying Properties of Versions
- Adding a Version
- Listing Multiple Versions
- Version Properties
- Deleting Versions

**Opening a Version**

Open any artifact version, see “Opening or Selecting Files or Folders” on page 88.

**Adding a Version**

Add another file as a version to an artifact in the repository.

**Note:**

All artifacts in the repository can have multiple versions, except for jobs, job output, Interactive Reporting database connection files, shortcuts, Web Analysis artifacts and Financial Reporting artifacts.

➤ To add versions:

1. Select **Navigate > Explore** then select an artifact.
2. Select **File > Properties**.
   
   The Properties dialog is displayed.
3. Click **Versions**, click **Add New Version** next to **Add another version of this file**.
4. Click **Browse** and select a file to add as a new version.
5. **Optional:** Do one or more of these steps:
   - Enter a Description.
- Enable Flag as an exception, then enter a message. If an exception occurs, the message is displayed on the Exceptions dashboard.
- Set the priority to High or Normal.

6 Click Add Version.

The Modify File page is displayed with the new version listed in the Versions section. The version is not added to the repository yet.

7 Click OK.

The version is added to the repository as the latest version.

**Viewing or Modifying Properties of Versions**

Each version has its own properties.

➤ To view or modify properties of versions:

1. Select Navigate > Explore, click to the artifact whose version you want to edit.
2. Select File > Properties.
3. Select Versions.
4. Select Modify.

The only changeable properties are Description, Priority, Flag as an Exception, and Message, see “Version Properties” on page 122.

5. After modifying properties, click OK.

**Version Properties**

Table 43 shows versions properties:

<table>
<thead>
<tr>
<th><strong>Table 43</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Description</strong></td>
<td>A description that identifies this version. Using preliminary figures as of 2/03 or First draft with Marketing’s comments. The length is limited to 254 characters.</td>
</tr>
<tr>
<td><strong>Creation date</strong></td>
<td>(Read-only) Date the version was created.</td>
</tr>
<tr>
<td><strong>Last modified date</strong></td>
<td>(Read-only) Date the version is changed. Changing versions includes replacing or modifying its properties.</td>
</tr>
<tr>
<td><strong>Modified by</strong></td>
<td>(Read-only) User, who made the last modification to the version.</td>
</tr>
<tr>
<td><strong>Priority</strong></td>
<td>Normal or High priority shows in Explore, the ! indicates high priority. Users can sort on priority, and search for high-priority artifacts.</td>
</tr>
</tbody>
</table>

*Note:* The ! does not display for high-priority scheduled jobs.

This property is available if your administrator activated the priority feature on your system.
## Listing Multiple Versions

From **Navigate > Explore** the latest artifact version is displayed in the content area.

➤ To see all versions:

1. Select **View > Show Columns**.
2. Click **Versions**, then click **Save**.

## Deleting Versions

Delete one or more versions together.

➤ To delete versions:

1. Select **Navigate > Explore**, navigate to the artifact whose version you want to delete.
2. Select **File > Properties**.
   
   The properties of the artifact are displayed.
3. Click **Versions**, then select a version.
4. Click **Delete Selected**.
5. Click **OK**.

<table>
<thead>
<tr>
<th><strong>Size</strong></th>
<th>(Read-only) The file size which is set automatically.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Flag as an exception</strong></td>
<td>An exception indicates a condition or result, such as a threshold being reached. <em>Flag as an exception</em> can be set manually by a user.</td>
</tr>
<tr>
<td></td>
<td>If you set this option on the latest version of an artifact, put the artifact on your Exception Dashboard, its state is displayed on the Exceptions Dashboard. See &quot;Using Exceptions&quot; on page 140.</td>
</tr>
<tr>
<td><strong>Message</strong></td>
<td>Text associated with an exception for this version. When an exception is flagged on the version, this message prints, or it may be visible from a user’s Exception Dashboard.</td>
</tr>
</tbody>
</table>
Viewing and Organizing Information

In This Chapter

Viewing........................................................................................................................ .. 125
Using Different File Types ..................................................................................................... .. 126
Creating a New Book, Batch, or Document....................................................................................126
Selecting a Data Source for a Document......................................................................................126
Using Favorites ................................................................................................................ ...126
Using Subscriptions ............................................................................................................ ..129
Using Personal Pages ........................................................................................................... .132

Viewing

To view, interact, and modify content within documents use Explore, Applications, and Open Items from the Navigate menu. Each displays a list of items to view, and are described below.

Figure 3

- Explore - Navigate through the Repository to locate files and folders.
- Applications – Select Financial Management, Planning, or Performance Scorecard for viewing or launching.
- Open Items - Select the document name to view it in the contents pane. Opened documents display in this list.

Use the buttons at the top of the View pane to interact and view a document.

- Document button , navigate through specific information for the active document. If the active document is a Web Analysis document, the document panel displays filter, page, and row sections.
- Tips button , access tasks, tips and file details relevant to the active document.
Using Different File Types

For information on how to view and use each file type, see:

- “Using Performance Scorecard” on page 151
- “Using Financial Reporting” on page 163
- “Designing Documents for Financial Reporting Batches and Books” on page 179
- “Interactive Reporting” on page 197
- “Using SQR Production Reporting Documents” on page 301
- “Using Web Analysis” on page 305

Creating a New Book, Batch, or Document

The new document wizard creates the following items:

- Web Analysis documents, see “Creating Web Analysis Documents” on page 309
- Interactive Reporting documents see “Interacting with Interactive Reporting Documents” on page 201
- Books, see “Creating Books” on page 181
- Batches, see “Designing Batches” on page 192

Selecting a Data Source for a Document

When creating documents you need to specify the data source. This determines the document type.

- To create a Web Analysis document, specify a Web Analysis database connection. See “Creating Web Analysis Documents” on page 309.
- To create a Interactive Reporting document, based on an existing document, specify a Interactive Reporting document. See “Interacting with Interactive Reporting Documents” on page 201.

Using Favorites

Users can set up their own Favorites and track items you access frequently to view them in the future. Administrators and users can push items to a user’s Favorites.

You need the proper role to push items to Favorites. See the corresponding appendix in the *Hyperion System 9 Shared Services User Management Guide*. If you do not have the proper role to access Explore, you can also see your Favorites list by selecting the Favorites menu.

You can do the following with Favorites:

- “Adding Items to Your Favorites” on page 127
Access Favorites

1 Select Favorites.
2 Select an item from the list of Favorites.

Tip:
You can also access your personal pages or Performance Scorecard.

Adding Items to Your Favorites

Add items to your Favorites or push items to another user’s Favorite using the following:

- You need view access permissions or higher.
- Add any item to Favorites.
- Add folders then use Favorites to access that folder; you cannot access items within the folder directly.

Add items to Favorites:

1 From Navigate, select Explore, navigate to the item.
2 Right-click and select Add to Favorites.

Add folders to Favorites:

1 From Navigate, select Explore, navigate to the folder.
2 Right-click and select Add to Favorites.

Pushing Items to Favorites

Push items to another user’s Favorites by specifying the user name, group, or role.

Push item to Favorites:

1 From Navigate, select Explore, select an item.
2 File >Properties.
3 From Properties, select Edit Permissions.

Note:
You can also select Edit Permissions by right-clicking on the artifact.

4 Populate Available Users, Groups, and Roles in the Properties dialog box with the following:
a. To filter by name, select begin with, contain, or are in group and then enter letters. You cannot use the are in group filter for roles.

b. To filter by user type, select roles, groups, or users, click Update List.

The Available Users, Groups, and Roles column displays items based upon the selections you made in the drop-down lists.

**Note:**

If all of the users/groups/roles are not listed, filter the list with different criteria or contact your administrator. Your administrator determines the maximum number of users/groups/roles to list. Wild cards are not supported and the filter is not case sensitive.

5. Select users from the Available Users, Groups and Roles list, click [ ].
6. From Selected Users, Groups and Roles list click a user, click Edit.
7. Click Pushed from the Edit Permissions dialog box to push the item to the user's Favorites.
8. Click Push this item to selected user, groups, and roles.

**Note:**

If the Access to File option is set to Empty and there are no higher access rights for this item to inherit, then the item is not pushed.

9. Repeat step 1 through step 8 to push other items to Favorites.

10. Click OK or Apply.

11. Optional: To change the appearance of the list of Users, Groups and Roles, drag the mouse over a column border, when the pointer changes to a double headed arrow, drag the borders to the right or left.

12. Optional: If you want permissions to apply to other content you import, make them your default permissions by selecting:
   a. For files, Make these the default permissions for all files I import.
   b. For folders, Make these the default permissions for all folders I import.

Selecting this enables the system to automatically set the same permissions for files you import. You can change the permissions for each file or reset your default permissions at any time.

**Note:**

To remove a role, group, or user from the selected list, click [ ] after highlighting the name to be removed.
Managing Favorites

➤ Manage items in Favorites:

1. From Workspace, select Favorites > Manage Favorites.
2. To remove an item from your Favorites, click Remove next to the item you want to remove.
3. To display an item on your list of Favorites, click Show next to the item you want to show.

Note:
If the favorite was pushed by the administrator or another user you can choose to not show it; however you cannot remove it.

4. Optional: To resize column widths, drag the mouse over a column border, when the pointer changes to a double headed arrow, drag the borders to the right or left.
5. Click OK.

Using Subscriptions

Subscriptions enable you to perform the following:

● Receive e-mail notifications and links to items every time the particular item is modified, a specific job runs, an exception is generated or anything in a folder changes. Subscribe to any item in the repository and you send it to one or more e-mail addresses. See “Creating a Subscription” on page 129.

● If you subscribe to a folder you are notified of any new items imported or created in that folder or any modifications to items within its subfolders. See “Subscribing to Folders” on page 131.

Note:
You cannot subscribe to Personal Pages.

Creating a Subscription

Subscribe to items to be notified when it changes. Receive e-mail notifications that the item changed or with the changed item attached.

Subscribe to be notified when exceptions occur as opposed to receiving notification when an item changes. The item’s owner must enable the item or job to generate exceptions for you to subscribe. Items and jobs generate exceptions when the following steps are setup:

● SQR Production Reporting jobs and generic jobs can be programmatically set up to generate exceptions. See “Supporting Exceptions in SQR Production Reporting or Generic Programs” on page 433.
Interactive Reporting jobs can be programmatically set up to generate exceptions. See “Supporting Exceptions in Interactive Reporting Programs” on page 402.

Manually set exceptions on items by setting the version property Flag as Exception; indicating that the item generated an exception. See “Version Properties” on page 122. The latest version of the item is used to determine if an exception is set.

Create subscriptions:

1. From Navigate, select Explore, navigate to the item you want to subscribe to.
2. Right-click the item, select Subscribe.
3. On the Subscribe page, perform the following steps:
   - Select Subscribe and send e-mail notifications to.
   - In the text box, type one or more e-mail addresses for the recipient of the notification.
   - If you want to send the item as an attachment, select Attach file for “report name” to email message (if possible).

   **Tip:**
   Your administrator determines the maximum size of attachments.

4. **Optional:** To subscribe to an item only when a programmatic exception occurs, select Exception Only. This option is applicable to jobs only.

   **Note:**
   If this option is not displayed, this item or job does not use exceptions.

Add subscriptions to your default personal page:

1. From Navigate, select Explore, navigate to the item you want to subscribe to.
2. Right-click the item, select Subscribe.
3. Click the Personal Pages tab, perform the following:

   **Note:**
   This option is not available for multiple-cycle Interactive Reporting jobs.

   - To add links to the subscription, click Add to My Bookmarks.
   - To add an image that links to the subscription, click Add as Image Bookmark.
     You can use a preconfigured image or browse to an image in the repository.
     - To use a preconfigured icon, click Use pre-configured icon file.
     - To use a custom icon, click Use custom icon file and enter the path and file name or use the Browse button.
To specify the image size, enter pixel values in the width and height text boxes. If you do not enter values the entire image is used.

4 Click OK.

➤ To add Interactive Reporting document sections to your default personal page:

1 From Navigate, select Explore, navigate to the item you want to subscribe to.

   Note:
   The Interactive Reporting document must contain sections.

2 Right-click the item, click Subscribe.

3 From Personal Pages tab, click Add Sections of Interactive Reporting document.

4 From Embed Section, select a section, click Add.

5 Repeat step 2 to add all desired sections.

6 Click OK.

Modifying or Removing Subscriptions

You can modify or remove subscriptions by managing a list of subscribed items.

➤ Modify or remove subscriptions:

1 From the Workspace, select Favorites > Show Subscribed Items.

2 Click a subscription, then click Open Subscriptions.

3 To remove the subscription, clear Subscribe and send e-mail notifications to.

4 To modify the subscription, use the steps described in “Subscribing to Folders” on page 131.

   Note:
   If you remove a subscription, it is removed from all of your Personal Page Bookmark sections also.

5 Click OK.

Subscribing to Folders

When you subscribe to folders, you are notified of items imported to that folder or updates to items within the folder or its subfolders.

If you are interested in the entire contents of a folder or sub folder, you can subscribe to the folder or sub folder.
Subscribe to folders:

1. From Navigate, select Explore, navigate to the folder to which you want to subscribe.
2. Right-click the item, from the shortcut menu select Subscribe.
3. On Subscribe Settings, select Subscribe and send e-mail notification to: to receive notification for this folder and to change or enter your e-mail address.
4. Enter an e-mail address for one or more recipients of the subscription.

Note:
You must enter the e-mail address, you cannot select from a list of recipients.
5. To receive notification when there are changes to the subfolders, select Notify on changes to sub-folders.
6. To receive notification only when items in the folder generate exceptions, select Exception Items.
7. To receive notification only when items in the folder are high priority items, select High Priority Items.

Note:
This option is only available if the administrator has enabled priority ratings.
8. Click OK.

Receiving and Viewing Subscriptions

Using a subscription e-mail notification you can access items directly without browsing the repository.

E-mail notification comes in two formats:

- E-mail with a link to the item or folder - Click the link; if you have access to that item, you can open the document.
- E-mail with the item attached - Follow the directions to either view the file where it is or download the attachment to a file.

Using Personal Pages

Personal Pages are customizable pages enabling you to organize, view, and access Workspace items and other Web content on Web pages. Items on personal pages do not interact with each other. If items change, it cannot propagate changes to items on the Personal Page. To build interactive dashboards, see Hyperion Interactive Reporting – System 9 Object Model and Dashboard Development Services Developer’s Guide Volume 1: Dashboard Design.

You can modify the content and layout of Personal Pages, create additional Personal Pages, copy and customize Personal Pages, add links to repository items or to a Web site.

Content windows and file content windows are the components that make up a Personal Page. Personal Pages open in the maximize mode, automatically hiding the view pane. When publishing personal pages, you can set access permissions during the personal page publish...

- **Content windows** are collections of links to repository items or external sources, image bookmarks, and Broadcast Messages.

- **File content windows** display the contents of an item opposed to a link to the item. You can display the contents of the following items:
  - Embedded Interactive Reporting document sections
  - HTML files
  - HTML job output.

Add or remove content windows or file content windows. Content windows and file content windows are optional except Broadcast Messages. You cannot remove Broadcast Messages, nor delete a Personal Page that displays them, unless you have another Personal Page that displays the Broadcast Messages.

Content on Personal Pages include:

- **Broadcast Messages** - Link to special folders that the administrator populates. The contents of this folder are displayed as one or more content windows and set up and managed by the administrator.

  Broadcast messages contains two sub-folders:
  - Personal Page Content - Published personal pages.
  - Sample Personal Page - Content on personal pages set up by the administrator and content that you add to personal pages by subscribing to items.

- **My Bookmarks** - Collection of links to Web pages or repository items.

- **Image bookmarks** - Graphic links to web pages or repository items.

- **HTML file or job output displayed as a file content window** - Contents of Workspace HTML items displayed on a Personal Page. URLs are also displayable.

- **Exceptions Dashboard** - Add traffic light indicators for jobs enabled for exceptions, or items flagged as exceptions. If the traffic light is red, the item was flagged as an exception or the job generated an exception. If the traffic light is green, the job did not yet generate an exception.

- **Displayable Interactive Reporting sections** - Sections from Interactive Reporting documents and Interactive Reporting job output to which you have access.

The following figure shows a variety of content windows and file content windows.
Note:
If your administrator configured the use of heading bars, each content window’s title is displayed in a colored heading on Personal Pages as shown.

<table>
<thead>
<tr>
<th>Number</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Broadcast Messages Heading Bar - Format the Heading bar for each content window.</td>
</tr>
<tr>
<td>2</td>
<td>Links - links to HTML pages or Web sites.</td>
</tr>
<tr>
<td>3</td>
<td>Content Window - My Bookmarks that are set up using Subscriptions.</td>
</tr>
<tr>
<td>4</td>
<td>Exceptions Dashboard - Lists job exceptions and notification messages or items that are flagged for exceptions.</td>
</tr>
<tr>
<td>5</td>
<td>File Content Window - Displays the contents of an HTML file.</td>
</tr>
</tbody>
</table>

Table 44  Sample Personal Page Illustration

After a highly successful launch of William Shakespeare’s new play, A Midsummer Night’s Dream in January of 1597 (see Units by Month chart) sales increased steadily, building up to the seasonal rush at the end of the year (see Units by Quarter chart).
Customizing Personal Page Content

You can specify information included and the appearance of your Personal Pages. Use the following steps to customize your Personal Pages:

- “Adding or Removing Personal Page Contents” on page 135
- “Displaying HTML Content on Personal Pages” on page 135
- “Embedding Interactive Reporting Document Sections in Personal Pages” on page 136
- “Creating Bookmarks” on page 138
- “Using Exceptions” on page 140
- “Modifying the Layout of a Personal Page” on page 143
- “Changing the Colors on a Personal Page” on page 144

Adding or Removing Personal Page Contents

To add or remove content (content windows) to a Personal Page:

1. **Favorites > Manage Personal Pages.**
2. Select a personal page.
3. Select .
   
   The content of the selected personal page is displayed in the My Personal Page Content area.
4. Select the content you want to add from Select Content, select .
   
   The items listed in the select content area are controlled by your administrator. You can also add content through the subscribe feature. See “Using Subscriptions” on page 129.
5. To remove items, select the content you want to remove from My Personal Page Content and select Remove.
6. Select Save Settings or close the window to Cancel. Changes are automatically displayed in the personal page you updated.

Displaying HTML Content on Personal Pages

Add HTML items as a file content window on a Personal Page, which displays the content of the item as opposed to a link to the item.

**Note:**

HTML job output from SQR Production Reporting jobs and generic jobs must be enabled in order to display the HTML job output as a file content window.
Displaying an HTML File on a Personal Page

Display HTML files on Personal Pages:

1. From Navigate, select Explore, navigate the folders until you find the document you want to add to your Personal Page.
2. Right-click the item, select Subscribe.
3. From the Subscribe window, select the Personal Pages tab.
4. Select Display file/output as a File Content Window.
   If this option is not available, this file/output cannot be displayed as a file content window.
5. Optional: To add the file content window to a personal page, click the desired personal page.
   The HTML displays the embeddable content windows list.

Adding a File Content Window to Personal Pages

Add file content windows to Personal Pages:

1. Favorites > Manage Personal Pages.
2. Tip:
   To define the location of the Broadcast Messages and content windows on your page, select the personal page and right-click. Select Layout.
3. Select the Personal Page you want to add the file content window to and click Content.
4. From Select Content Window, click the desired file content window(s) and add it to the Content list for your Personal Page.
5. Click Save Settings.

Removing a File Content Window from All Personal Pages

Remove file content windows from Personal Pages:

1. From Navigate, select Explore and navigate to the original HTML document/output file.
2. Right-click the item, select Subscribe.
3. On Subscribe, clear Display file/output as a File Content Window.
4. Select OK.

Embedding Interactive Reporting Document Sections in Personal Pages

Embed sections of Interactive Reporting documents or Interactive Reporting job output into Personal Pages.
If the item is an Interactive Reporting job output, it must be HTML from a single-cycle job. The most recent job output is displayed in the embedded section and it is not interactive.

Embedded Interactive Reporting sections are fully interactive, with options available from the pop-up menu.

Specify whether to include the Interactive Reporting Main Menu bar or the Navigation bar as part of the embedded section. Interactive Reporting document sections you can embed are:

- **Results** - Reduced vertically to fit in the container, with horizontal scroll bars. To view more vertical regions, use the page navigation options available on the Main Menu bar.
- **Tables** - Reduced vertically to fit in the container, with horizontal scroll bars. To view more vertical regions, use the page navigation options available on the Main Menu bar.
- **Pivot** - Reduced vertically to fit in the container, with horizontal scroll bars. To view more vertical regions, use the page navigation options available on the Main Menu bar.
- **Chart** - Scaled proportionally to fit in the container.
- **Reports** - Clipped to fit in the container.
- **Dashboard** - Clipped to fit in the container.

**Embedding an Interactive Reporting Section on a Personal Page**

- Embed Interactive Reporting sections on a Personal Page:
  1. From Navigate, select Explore, navigate to the Interactive Reporting document or job output file.
  2. Right-click the item, click Subscribe.
  3. Click Personal Pages tab.
  4. Select Add sections of Interactive Reporting Document.
  5. Select the section you want to add from Embed Section.
  6. Select the Personal Page that you want to update.
  
  **Note:**
  A list is displayed if you have more than one Personal Page.

  7. Click Add.
  The section is displayed in the Embedded BQY Sections list box.

  8. Specify the size you want each section to be on the Personal Page.
  Select the desired section from Embedded BQY Sections and specify its height and width in pixels in the respective field.

  9. Click OK.

**Editing Embedded Interactive Reporting Sections on a Personal Page**

After embedding an Interactive Reporting section, you can edit its properties.
Edit the appearance of embedded sections:

1 Select Favorites > My Personal Page.

2 From the personal page, select  

3 Change the settings from the Edit Results Section window:
   - Replace embedded section - (Read only) Displays the section currently embedded.
   - With section - Select a section to replace the currently embedded section. The name of currently embedded section is displayed by default.
   - Specify section size - Enter the size of the section in pixels.
   - Toolbar display - Select the Interactive Reporting Server toolbar to embed with the section (the default is none).
     - Select Navigation Only, to have the first page, previous page, next page, and last page toolbar buttons only.
     - Select Standard, to have all toolbar buttons except for the Interactive Reporting Server help button.
     - Select None, to have no toolbar displayed.

4 Click Save Settings.

The edited embedded section is displayed on your Personal Page.

Removing Embedded Interactive Reporting Sections from a Personal Page

You can remove any embedded Interactive Reporting section from your Personal Page.

To remove embedded Interactive Reporting sections from Personal Pages, click X in the title of the file content window containing the Interactive Reporting section you want to remove.

To remove an embedded Interactive Reporting section from all Personal Pages:

1 From Navigate, select Explore, navigate the folders until you find the item containing the embedded sections you want to remove from your Personal Page.

2 Right-click the item, click Subscribe.

3 On the Subscribe page, navigate to Add Sections of Interactive Reporting Document.

4 Select the section you want to remove from the list box and click Remove.

5 Click OK.

Creating Bookmarks

Include bookmarks on a Personal Page. A bookmark is a text link or image link to a item or to a URL.
Adding Bookmarks for a Workspace Item from Explore

➤ Add Bookmarks for items:

1 From Navigate, select Explore, navigate to the item.
2 Right-click the item, select Subscribe.
3 On Personal Pages tab, select Add to My Bookmarks.

Note:
The new bookmark is displayed on every Personal Page that includes the My Bookmarks item.

4 Select OK.
5 Go to your Personal Page.
The Bookmark is displayed in the My Bookmarks list.

Note:
When selecting a Oracle’s Hyperion® Web Analysis – System 9, SQR Production Reporting, Financial Reporting, or Interactive Reporting jobs bookmark from the My Bookmarks list of a personal page, it opens as a new tab in Workspace.

Adding Image Bookmarks for a Workspace Item

Bookmarks are added for items you subscribe to, except for folders.

➤ Add image bookmarks for Workspace items:

1 From Navigate, select Explore, navigate to the original item.
2 Right-click the item, select Subscribe.
3 On Subscribe Settings, Add As Image Bookmark. Specify the following information:
   a. Specify graphic files you want to use. Select either:
      ● A pre-configured icon file from the drop-down list
      ● A custom icon file (your administrator needs to add your custom graphic to the Workspace file system and give you the path to it). Using a graphic file from your local file system does not work.
   b. Enter the desired dimensions for displaying the image (in pixels).
4 Select OK.

Adding URL Bookmarks from Personal Pages

Bookmarks can also be added from within Personal Pages.
Adding bookmarks from Personal Pages:

2. Select a personal page from the list. Right-click and select Add bookmark URL.
3. From the Add URL Bookmark to My Bookmarks dialog, enter a bookmark name and URL for bookmark.
4. Select Save.

Note:
The URL must begin with either http:// or https://.

Using Exceptions

Exceptions are conditions or results (such as a threshold being reached) requiring intervention. Exceptions cause corresponding indicators on a subscribing user’s Exceptions Dashboard to change, or a notification to be sent to users who have subscribed.

The exceptions dashboard is an optional content window used to monitor exceptions, it displays on Personal Pages. Each indicator represents one exception-capable job or items with manually flagged as an exception.

Use exceptions with jobs or items:

- Using monitored exceptions with jobs:
  - Programmatically enable monitored exceptions on jobs. The exception is set when certain conditions or thresholds are met. Job exceptions are generated by SQR Production Reporting jobs, Interactive Reporting jobs, or generic jobs. See “Configuring Exceptions” on page 141.
  - Subscribe to jobs and choose to be notified by e-mail when the exception occurs.
  - Place jobs on the Exceptions Dashboard and view its exception status. For each job you add to the Exceptions Dashboard, a green traffic light icon is displayed. If the job generates an exception, the traffic light changes to red. “Using the Exceptions Dashboard” on page 141.

- Using exceptions with items:

  Note:
  An item must have version properties in order to use exceptions.

  - Manually set exception status for items. See “Configuring Exceptions” on page 141.
  - Subscribe to items and choose to be notified by e-mail when the exception occurs.
  - You can place items on the Exceptions Dashboard and view its exception status. For each item you add to the Exceptions Dashboard, a red traffic light icon is displayed. Items cannot be added to the exception dashboard unless the exception status is set. See “Using the Exceptions Dashboard” on page 141.
You have only one Exceptions Dashboard, even if you put it on multiple Personal Pages. If you modify the Exceptions Dashboard on one Personal Page, it changes on all of your Personal Pages that include it.

**Configuring Exceptions**

Configure exceptions for jobs and items with version properties. There are two ways to configure exceptions:

- Programmatically set-up a job to generate exceptions if certain conditions are met. When you run the job if an exception occurs, the exception status of the job is set.
- Manually set exceptions on an item by setting the property to **Flag as an Exception**.

➤ Programmatically enable a job with monitored exceptions capability:

- Design the SQR Production Reporting job (*.sqr) or generic jobs to write exceptions to the `output.properties` file. See “Supporting Exceptions in SQR Production Reporting or Generic Programs” on page 433.
- Design the generic job, to write exceptions to the `output.properties` file. “Supporting Exceptions in SQR Production Reporting or Generic Programs” on page 433.
- Design the Interactive Reporting job to write exceptions. See “Supporting Exceptions in Interactive Reporting Programs” on page 402.

➤ To set exception status for items manually, from Explore, set the property **Flag as an Exception for the latest version of the item**. See “Version Properties” on page 122.

**Using the Exceptions Dashboard**

The exceptions dashboard shows a traffic light indicator for each job or item you place on it. The traffic light indicator changes to indicate if an exception occurred (red) or did not occur (green).

**Note:**

Items have version properties to use exceptions and the exceptions dashboard.

➤ Use Exceptions Dashboard with jobs:

1. From Navigate, select Explore, navigate to the job whose exception you want to monitor, right-click the job, click Properties.
2. From Advanced, select If exceptions are generated, allow users to add to their Exceptions Dashboard, click OK.
3. From Navigate, select Explore, navigate to the job, right-click the job, click Subscribe.
4. On Personal Pages tab, select Add to Exceptions Dashboard.

   If this option is not on the Subscribe Settings page, the file cannot be monitored for exceptions.
5 Click OK.

A traffic light is added to the exceptions dashboard. The traffic light indicator is green. If the job is run and generates an exception, then the traffic light indicator changes to red.

➤ Use Exceptions Dashboard with items:

1 From Navigate, select Explore, navigate to the item that has an exception you want to monitor.
2 Right-click the item, click Properties.
3 From Advanced, select If exceptions are generated, allow users to add to their Exceptions Dashboard.
4 From Versions, set the property Flag as an Exception for the latest version of the item click OK.
5 From Navigate, select Explore, navigate to the item.
6 Right-click the item, from the shortcut menu, select Subscribe.
7 On Subscribe Settings, select Add to Exceptions Dashboard.
   If this option is not on the Subscribe Settings page, this file cannot be monitored for exceptions.
8 Click OK.

A red traffic light is added to the exceptions dashboard, to indicate that an exception is set for this item.

Adding the Exceptions Dashboard to a Personal Page

Add the Exceptions Dashboard to Personal Pages or just one.

➤ Add Exceptions Dashboard to Personal Pages:

1 Go to the Personal Page to which you want to add an Exceptions Dashboard.
2 Click  
3 Click Exceptions Dashboard and click .
4 Click Save Settings.

Customizing the Exceptions Dashboard

Customize the display of the Exceptions Dashboard.

➤ To customize Exceptions Dashboard:

1 Select Favorites, select a Personal Page.
2 On Exceptions Dashboard, select
3 To not show green lights, and have red lights displayed when an exception occurs, enable the Only display monitored exceptions that have exceptions.
Note:
This option is applicable for monitored exceptions used with jobs. Traffic lights display when the exception status is set. You cannot show a green traffic light for items.

4 When exceptions occurs and you want to see its exception text explanatory message next to its red light, select Display exception messages next to graphic indicators.

Note:
There is a smartcut tag called `getException()` that displays exception messages on a Interactive Reporting dashboard. For more information, see the Hyperion Interactive Reporting Studio User’s Guide

5 Click Change Properties.

### Modifying the Layout of a Personal Page

Use the Layout button to select different layout styles for Personal Pages or to rearrange content windows.

#### Specifying Layout Style

The layout style of a Personal Page includes how many columns or sections the page has and where they are displayed on the page.

➤ Specify layout styles:

1 Favorites > Manage Personal Pages.

2 Select a Personal Page, then select 📝.

3 Click Select Layout Style and select a layout style.

4 If you want to put content windows in a section across the top or bottom of the Personal Page, click Show Header Section or Show Footer Section.

5 Click Save Settings.

#### Rearranging Content Windows

➤ Move content windows:

1 Favorites > Manage Personal Pages.

2 Select a Personal Page, then click Layout.

3 Select a content window you want to move.

4 If you want to move the selected content window up or down within the section (column, header or footer) it is currently in, click a vertical arrow. If you want to move the selected content window to another section, click a horizontal arrow.
5 Continue selecting and moving content windows until they are arranged as you want.

6 If you want to move the Broadcast Messages content windows, select Above all Content Windows or Below all Content Windows in the Broadcast Messages section of the Content Layout page.

7 Click Save Settings.

### Changing the Colors on a Personal Page

Select color schemes for Personal Pages, or individually set colors for page elements.

1. Select Favorites > Manage Personal Pages.
2. Select a color scheme.
3. Select a color scheme.
4. If you want to set colors individually, click Customize Colors for Custom. If not, go to step 7.
   - Each colorable Personal Page element displays an array of color samples above a My Own Color option. Select any color in the array by selecting its radio button. Colors shown next to the My Own Color entry box is the current color of the element.
5. Each element whose color you want to change, select the new color you want or enter a hexadecimal color code (for example, #000000 is the hexadecimal color code for black) in the My Own Color entry box.
6. Select Save Settings.
7. Select a color scheme option:
   - Change all my Personal Pages to use this Color Scheme - Applies the specified color scheme to all your existing Personal Pages.
   - Use this as my default Color Scheme for all new Personal Pages - Applies the specified color scheme to the current Personal Page and any future ones.
8. Select Save Settings.

### Working With Personal Pages

Create multiple Personal Pages for different purposes, specify a default Personal Page if you have more than one, and publish a Personal Page so that others can use it as their own.

- “Creating a Personal Page” on page 144
- “Copying a Personal Page” on page 146
- “Deleting Personal Pages” on page 146
- “Publishing and Replacing Personal Pages” on page 146

### Creating a Personal Page

You can create multiple Personal Pages.
To create a Personal Page:

1. Do one of the following:
   - Select File > New > Personal Page.
   - Select .

   Note:
   is not displayed if you exceeded the number of Personal Pages allowed by your administrator. You must remove a Personal Page to enable .

2. Use to add the content windows you want (listed on the left side) to the Personal Page Content list for your new Personal Page (on the right), click Next.

3. Select a layout style and click Next.

   Note:
   Layout styles only show the Personal Page portion of the browser window; the View pane also is displayed on the left. A Header section is a wide area that contains one or more content windows. A Footer section is the same, but located at the bottom of the page.

4. For Layout, arrange the various content windows where you want them on your Personal Page. Select a content window and to move the content window between sections. Select a content window and then to change a content window’s position in a section. When you are done, click Next.

5. On Edit Personal Page, enter a name and description for your Personal Page, select a color scheme, click Finish or Finish & Publish.

   Note:
   Selecting Finish opens the personal page just created for viewing. Finish & Publish enables you to assign permissions during the publishing process of Personal Pages prior to viewing.

You can further customize the colors at a later time, see “Changing the Colors on a Personal Page” on page 144. On the My Personal Pages page, the new Personal Page is listed. Also, from Favorites, select your Personal Page to view.
**Copying a Personal Page**

In addition to publishing new Personal Pages, you can also copy a published Personal Page to a new Personal Page.

**Note:**
You must have a published Personal Page prior to performing the following steps.

➤ To copy published Personal Pages:
1. **Favorites > Manage Personal Pages.**
2. Select 📌.
3. Select **Copy Published Personal Page**, select **Next**.
   The Add Existing Personal Pages page is displayed.
4. Select the personal page(s) you want to copy from the list, select **Finish**.
   Select 📌. The page(s) are displayed in Manage Personal Pages.

**Deleting Personal Pages**

➤ Delete Personal Pages:
1. **Favorites > Manage Personal Pages.**
2. Select the Personal Page you want to delete from **My Personal Pages**.
3. Right-click and select **Remove Page**.

**Note:**
Select **Restore Settings** to restore the deleted Personal Page to the list.

4. Select **Save Settings**.

**Publishing and Replacing Personal Pages**

Publish new Personal Pages or replace published Personal Pages using the content of your Personal Page. Publishing a Personal Page enables other users to copy it.

**Note:**
To publish Personal Pages, you need the proper access permissions to the Personal Page folder.

➤ Publish or replace Personal Pages:
1. **Favorites > Manage Personal Pages.**
On My Personal Pages, select the Personal Page you want to publish, right-click and select **Publish**.

To publish, enter a name and a description in the Publish New Personal Page section, select **Publish**.

The name and description defaults to what you have already assigned to this Personal Page. The name and description should communicate what is distinctive about this page.

**Note:**

When you Publish and run an Interactive Reporting or SQR Production Reporting job to generate the job output, the default naming convention for the job output changes to list the job and job output together.

To replace: In Replace Personal Page, select the page to replace, click **Replace**.

You can replace a published Personal Page with one that has a different name. The contents of the published page are replaced and the published page name remains the same.

To set access permissions on the Personal Page you just published: select **Edit Permissions**.

The default access permissions when publishing Personal Pages are the same as basic documents. To set access permissions, see “Setting Permissions” on page 113.
Launching Oracle's Hyperion Applications

Applications from the Navigate menu contains a list of Performance Scorecard, Planning, or Financial Management applications which you can open. Applications is displayed if both of the following are true:

- A user has rights
- Applications are available

The list of available applications is retrieved from Oracle's Hyperion® Shared Services. When an application is selected, it launches in a new window, passing the single sign on token so you are not prompted again for credentials.

The list of available applications are filtered by the user's provisioned status. For example, if the currently logged on user was not provisioned for a project that included the Planning Real App, it would not be listed. For additional information on using Planning applications, see Hyperion Planning – System 9 User’s Guide and for Financial Management applications, Hyperion Financial Management System 9 User’s Guide.

To launch applications:

1. Select Navigate > Applications.

   A list of available applications you have rights to are displayed.

2. Select the application you want to open.

   The application launches as a tab at the bottom of the Workspace allowing easy switching between screens.

Note:

Preferences can be set when viewing certain applications from Workspace. See Chapter 2, “Setting Preferences and Personalizing your Workspace.”
Performance Scorecard provides a user-oriented subset of Performance Scorecard information for these tasks:

- Viewing all scorecards and maps that you can access
- Printing scorecards and maps
- Exporting employee and measure scorecards to Microsoft Excel worksheets
- Exporting Strategy Maps as image files

From Workspace, you can launch Performance Scorecard in a separate window to modify scorecards or maps, create notes and annotations, modify performance indicators, or generate reports.

To view Performance Scorecard through Workspace, you must have both applications running and single sign-on enabled. Your permissions for accessing data in Performance Scorecard are also used in Workspace. To view a page through Workspace, you need permission to view it in Performance Scorecard.

Performance Scorecard users with User or Designer roles can access all scorecard functionality in Workspace.
Launching the Scorecard Module

Scorecard is launched through Workspace.

➤ To access Performance Scorecard through Workspace:

1 Select Navigate > Applications > Performance Scorecard.

   The expanded list displays scorecards and maps for the Performance Scorecard object types that you are authorized to view:

   ● Employees
   ● Accountability Maps
   ● Strategy Trees
   ● Strategy Maps

2 Expand the Employees or Maps tree.

3 Select an element.

   The scorecard or map is displayed in the Contents pane, and a Scorecard tab is added to the bottom. Each available view type may have a tab: scorecard, scorecard in Excel, and map (up to three tabs). The tab in the Contents pane remains while the Performance Scorecard module is open. When you open a second scorecard, it replaces the existing scorecard.

4 Use these procedures to view and work with the maps and scorecards in the Scorecard module:

Table 45  Scorecard Module Options

<table>
<thead>
<tr>
<th>Element</th>
<th>Purpose</th>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>Employees</td>
<td>Displaying employee names and performance indicators</td>
<td>“Viewing Scorecards” on page 153</td>
</tr>
<tr>
<td>Accountability Map</td>
<td>Displaying available Accountability Maps</td>
<td>“Viewing Accountability Maps” on page 154</td>
</tr>
<tr>
<td></td>
<td>Expanding map names to display associated map elements.</td>
<td></td>
</tr>
<tr>
<td>Strategy Tree</td>
<td>Displaying available Strategy Trees</td>
<td>“Viewing Strategy Trees” on page 156</td>
</tr>
<tr>
<td></td>
<td>Expanding map names to display associated map elements.</td>
<td></td>
</tr>
<tr>
<td>Strategy Map</td>
<td>Displaying available Strategy Maps</td>
<td>“Viewing Strategy Maps” on page 157</td>
</tr>
<tr>
<td>Exporting an image of the selected Strategy Map</td>
<td><em>Exporting Strategy Maps</em> on page 159</td>
<td></td>
</tr>
<tr>
<td>All</td>
<td>Exporting scorecards to Excel</td>
<td>“Exporting Scorecards to Excel” on page 159</td>
</tr>
<tr>
<td>Printing scorecards or maps</td>
<td><em>Printing Scorecards and Maps</em> on page 160</td>
<td></td>
</tr>
<tr>
<td>Element</td>
<td>Purpose</td>
<td>Procedure</td>
</tr>
<tr>
<td>------------------------------------------------------------------------</td>
<td>-------------------------------------------------------------------------</td>
<td>---------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Setting the current page as the default Start Page for the Workspace</td>
<td>“Setting the Default Workspace Start Page” on page 160</td>
<td></td>
</tr>
</tbody>
</table>

For details on working with measures, scorecards and maps in Performance Scorecard, use these documents on the Performance Scorecard information map:

- Hyperion Performance Scorecard — System 9 Application Designer’s Guide
- Hyperion Performance Scorecard — System 9 User’s Guide
- Hyperion Performance Scorecard — System 9 Administrator’s Guide

**Viewing Scorecards**

Scorecards are composed of measures for evaluating the performance of employees, strategy elements, or accountability teams by measuring specific tasks or completion of goals. You can build scorecards that use lower-level, child or descendant scorecards, which means that the performance of scorecards at lower corporate levels can be communicated in the scorecards of the levels above it.

Each item on a scorecard is weighted to reflect its relative importance to the score.

➢ To view an employee scorecard:

1. Launch Scorecard. See “Launching the Scorecard Module” on page 152.
2. Expand Scorecards.

The expanded list displays all Performance Scorecard elements that you are authorized to view.

**Note:**

The Scorecard tab remains while Performance Scorecard is open, but the tab contents change as you select from the Scorecard Browser. One scorecard at a time is displayed on the tab.

3. Expand Employees or the map type to list all scorecards that you are authorized to view. The name and performance indicator for each employee is displayed in the View pane, and a Scorecard tab is added to the bottom of the Contents pane. The performance indicator reflects the status for the employee for the date and the default target.

4. Click a name to display the employee’s scorecard and its associated measures in the Contents pane. Scorecard measures may be grouped by perspective, such as Internal Processes or Learning and Growth. The report provides this information about each scorecard measure:
   - Notes attached to the measure
   - Performance indicator for the current date and default target
   - Trend indicator (whether results are improving or declining)
   - Collected result value
   - Expected target value

Viewing Scorecards 153
5 Select these items on the scorecard to view additional information:

- Measure
- Notes
- Status
- Trend
- Result

Performance Scorecard opens in a separate window, displaying the screen for the selected measure. From Performance Scorecard, you can view or modify information for the selected item. For details on working with scorecards and measures, see the Hyperion Performance Scorecard — System 9 User’s Guide.

6 Save your changes in Performance Scorecard.

Viewing Maps in Scorecard

Scorecard uses three kinds of maps to depict your organization's strategy and accountability structures:

- Accountability maps illustrate the individual business areas, departments, and teams in your organization that are responsible for actions that must be performed to achieve the strategic goals and objectives. See “Viewing Accountability Maps” on page 154.

- Strategy Trees are detailed strategy representations that are used to depict how your organization translates its high-level mission and vision statements into lower-level, constituent strategic goals and objectives. See “Viewing Strategy Trees” on page 156.

- Strategy Maps show the strategic relationships between strategy elements that comprise your organization’s strategic blueprint and the framework used. See “Viewing Strategy Maps” on page 157.

As an end user, you can only view those business objects that you are authorized to view. Only users with Designer permissions can modify a Map. Contact the Application Designer if changes are required.

Viewing Accountability Maps

Accountability maps enable you to view teams, departments, committees, and individuals responsible for tasks that realize key corporate goals. Accountability maps enable accountability elements like departments and committees to understand how their actions are aligned with individual strategic goals.
Accountability maps illustrate individual business areas, departments, and teams that are responsible for actions that must be performed to achieve strategic goals and objectives.

To view an accountability map:

1. **Launch Scorecard.** See “Launching the Scorecard Module” on page 152.
2. **Expand Accountability Maps.**
   
The expanded list displays all Performance Scorecard Accountability maps that you are authorized to view.
3. **Click the Accountability Map name.**
   
The map is displayed in the Contents pane, and a Map tab shows at the bottom of the Contents pane.

   **Note:**
   
The Map tab remains while Performance Scorecard is open, but the tab contents change as you select from the Scorecard Browser. One map at a time is displayed on the Map tab.
4. **Double-click any element on the map, or select the element from Scorecard Viewer.**
   
The associated scorecard is displayed in the Contents pane, replacing the map. A Scorecard tab is added if not present.

   Scorecard measures may be grouped by perspective, such as Internal Processes or Learning and Growth. The report provides this information about each scorecard measure:
   
   - Notes attached to the measure
   - Performance indicator for the date and default target
   - Trend indicator (whether results are improving or declining)
   - Collected result value
   - Expected target value
   - Unit of measure
   - Current score and weight (as percentages)

   **Note:**
   
The contents of this pane and the report columns may vary depending on customized settings made in Performance Scorecard.
5. **Select these items on the scorecard to view additional information:**
   
   - Measure
   - Notes
   - Status
   - Trend
   - Result
Performance Scorecard opens in a separate browser, displaying the screen for the selected measure. From Performance Scorecard, you can view or modify information for the selected item. For details on working with scorecards and measures, see the *Hyperion Performance Scorecard — System 9 Application Designers Guide*.

6 Save your changes in Performance Scorecard.

**Viewing Strategy Trees**

Strategy Trees articulate an organization’s long-term goals in concrete terms, with progress determined by measuring results.

For each strategic objective (SO), you determine a critical success factor (CSF) and create tasks or actions for accomplishing the strategic objective. Each element on the Strategy Tree is associated with measures. For example, a CSF of the SO “Increase Revenue” might be “Repeat Customer Business,” and the actions for meeting the objective might include “Improving Brand Awareness” and “Effective Advertising.”

You can create multiple Strategy Trees to illustrate corporate and business unit or domain-level strategy.

➤ To view a Strategy Tree:

1 **Launch Scorecard.** See “Launching the Scorecard Module” on page 152.
   
   The Viewer displays Scorecard as the available application.

2 **Expand Strategy Trees.**
   
   The expanded list displays all Performance Scorecard Strategy Trees that you are authorized to view.

3 **Click the Strategy Tree name.**
   
   The map is displayed in the Contents pane, and a Map tab shows at the bottom of the Contents pane.

   **Note:**
   
   The Map tab remains while Performance Scorecard is open, but the tab contents change as you select from the Scorecard Browser. One map at a time is displayed on the Map tab.

Depending on the framework type selected for your scorecards, the map may show multiple strategy elements categories. For example, if you select the Balanced Scorecard Collaborative framework, the Strategy Tree contains these element categories:

- SOs
- CSFs
- Actions
4 Double-click any element on the map to display the associated scorecard in the Contents pane, replacing the map.

The Scorecard is displayed in the Scorecard tab. Scorecard measures may be grouped by perspective, such as Internal Processes or Learning and Growth. The report provides this information about each scorecard measure:

- Notes attached to the measure
- Performance indicator for the date and default target
- Trend indicator (whether results are improving or declining)
- Collected result value
- Expected target value
- Unit of measure
- Current score and weight (as percentages)

Note:

The contents of this pane and the report columns may vary depending on customized settings made in Performance Scorecard.

5 Select these items on the scorecard to view additional information:

- Measure
- Notes
- Status
- Trend
- Result

Performance Scorecard opens in a separate browser, displaying the screen for the selected measure. From Performance Scorecard, you can view or modify information for the selected item. For details on working with scorecards and measures, see the Hyperion Performance Scorecard — System 9 Application Designer Guide.

6 Save your changes in Performance Scorecard.

Viewing Strategy Maps

Strategy Maps depict how strategy elements and strategic themes in your application are interrelated, and how they support your corporate strategy. For example, a strategic objective called “Improved Product Quality” probably affects strategic objectives for “Reduce product returns” and “Increase customer satisfaction.” They also present hypotheses about possible causal relationships between strategy elements.

To view a Strategy Map:

1 Launch Scorecard. See “Launching the Scorecard Module” on page 152.
The Viewer displays Scorecard as the available application.

2 **Expand Strategy Maps.**

The expanded list displays all Performance Scorecard Strategy Maps that you are authorized to view.

3 **Click the Strategy Map name.**

The map is displayed in the Contents pane, and a Map tab shows at the bottom of the Contents pane.

**Note:**

The Map tab remains while Performance Scorecard is open, but the tab contents change as you select from the Scorecard Browser. One map at a time is displayed on the Map tab.

Double-click any element on the map to display the associated scorecard in the Contents pane. The Scorecard is displayed in the Scorecard tab.

Scorecard measures may be grouped by perspective, such as Financial or Customer. The report provides this information about each scorecard measure:

- Notes attached to the measure
- Performance indicator for the date and default target
- Trend indicator (whether results are improving or declining)
- Collected result value
- Expected target value
- Unit of measure
- Current score and weight (as percentages)

**Note:**

The contents of this pane and the report columns may vary depending on customized settings made in Performance Scorecard.

4 **Optional: Select items on the scorecard for additional information:**

- Measure
- Notes
- Status
- Trend
- Result

Performance Scorecard opens in a separate browser, displaying the scorecard for the selected measure. From Performance Scorecard, you can view or modify information for the selected item. For details on working with scorecards and measures, see the *Hyperion Performance Scorecard — System 9 Application Designer’s Guide*. 
5 Save your changes in Performance Scorecard.

Exporting Scorecards to Excel

Using Workspace, you can export an employee or measure scorecard to Excel. You can modify the file contents in the Excel format, although this information cannot be saved to Performance Scorecard.

➤ To export an employee or measure scorecard to Excel:
1 Launch Scorecard. See “Launching the Scorecard Module” on page 152.
2 In the Scorecard Viewer, expand the list to locate the scorecard.
3 From the expanded list, select the scorecard.
   The scorecard is displayed in the Contents pane.
4 Use one method to export the file:
   ● Select File > Export to Excel.
   ● Right-click the scorecard, and select View Scorecard in Excel from the shortcut menu.
5 Use one method to view the file:
   ● Click Open to display the file in Workspace on a tab labelled <scorecard name> (Excel).
   ● Click Save, use Save As to save the scorecard as an Excel worksheet, and then open the worksheet.
   The default file name for the worksheet is scorecard.xls where scorecard is the scorecard name.
6 Optional: Modify the data on the Excel worksheet, and click Save. Changes in the Excel worksheet cannot be reimported to Performance Scorecard.

Exporting Strategy Maps

Using Workspace, you can export a Strategy Map as .bmp, .jpg or .png file. Accountability and Strategy Trees cannot be exported.

➤ To export a Strategy Map:
1 Launch Scorecard. See “Launching the Scorecard Module” on page 152.
2 In the Scorecard Viewer, expand Strategy Maps.
   The expanded list displays all Strategy Maps that you are authorized to view.
3 Select the Strategy Map.
   A Map tab shows at the bottom of the Contents pane.
Note:
The Map tab remains while Oracle’s Hyperion® Performance Scorecard – System 9 is open, but the tab contents change as you select from the Scorecard Browser. One map at a time is displayed on the Map tab.

4 From the Workspace main menu, select File > Export Map.
   The Export To dialog box is displayed.
5 Navigate to the location for saving the image file.
6 Enter a file name, and click Save.

Printing Scorecards and Maps

Within Workspace, you can print any scorecard or map.

To print a scorecard or map:
1 Launch Scorecard. See “Launching the Scorecard Module” on page 152.
2 In the Scorecard Viewer, expand the tree to display the scorecard or map.
   The expanded list shows all objects that you are authorized to view.
3 Select the scorecard or map.
4 Select File > Print.
   The Browser Print dialog box is displayed.
5 Specify a printer, properties, number of copies, and page or page range.
6 Click OK.

Setting the Default Workspace Start Page

You can set a specific scorecard or map as your default Workspace Start Page.

To set Scorecard as your default Workspace Start Page:
1 Launch Scorecard. See “Launching the Scorecard Module” on page 152.
2 Select the scorecard or map to use as your Home Page.
3 From the Workspace, select File > Preferences.
   Workspace Preferences is displayed.
4 Select the General tab.
5 From the Content List under Default Startup Options, select the default option you want to use when you sign on to Scorecard:
   • None (Default)
- **Favorite** - If you select Favorite, a list of Available Favorite pages is displayed from which you can select the specific page.

- **Scorecard**

- **Click Use Current Page** button to use the content of the active page, whether it is a map, scorecard or report.

6 From the View Pane Tab list under Default Startup Options, select the default tab you want to display in the View pane when you sign on to Scorecard:

- **Navigate** (Default)
- **Document**
- **Tips**

**Note:**

The Navigate option cannot be changed unless an option other than None is selected from the Content List, as outlined in step 5.

7 **Click OK.**

The next time you open Workspace, the Scorecard page is displayed.
Overview

Workspace enables previewing of Financial Reporting documents, such as reports and books, from the Explore module. You can preview reports and books in HTML or PDF format.

Note:

Text automatically wraps within a grid’s cell. When print previewing PDF reports, text cells with long text are automatically merged into the next cell to the right, if that cell is empty. When previewing HTML reports, text cells are not automatically merged unless the Merge feature was applied at design time. The rows height automatically adjusts to display all text.

Note:

You must have file permissions to view reports or books. See the Hyperion Workspace Administrator’s Guide.

Workspace Tasks

Tasks, other than previewing, performed through Workspace.

- Customize report and book elements. For example, change the POV before or after running the report or book.
- Export reports, snapshot reports, XML (report-definition file), PDF, HTML, Word, Excel, or PowerPoint.
- Use Related Content to link to Financial Reporting reports and Workspace URLs.
- Subscribe to Financial Reporting documents to receive e-mail notifications when reports are modified and add notifications to your favorites. See Chapter 5, “Viewing and Organizing Information.”
- Organize the E-mail Recipient list.

Types of reports and books available from the Explore module:
- Reports—Populated with data from data sources; users can customize by selecting members
- Snapshots—Contain static data for a specific point in time; populated with data when saved.
- Books—Contain sets of dynamic reports and, optionally, tables of contents. Reports are run for all specified member combinations.
- Snapshot books—Contain sets of snapshot reports and, optionally, tables of contents; can be viewed for multiple POVs

Designers incorporate Workspace features into reports and books to enable viewers to perform tasks:

<table>
<thead>
<tr>
<th>Table 46   Workspace Features</th>
<th>Reports</th>
<th>Snapshots</th>
<th>Books</th>
<th>Snapshot Books</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prompt</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>User POV</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>XML, HTML, and PDF</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Page Axis</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>Expansions</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Related Content</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Grid POV</td>
<td>Yes</td>
<td>No</td>
<td>No</td>
<td>No</td>
</tr>
<tr>
<td>Data Security*</td>
<td>Yes</td>
<td>No</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Export to Word, Excel, and PowerPoint</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>E-mail Links</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
<td>Yes</td>
</tr>
</tbody>
</table>

*Data source security is applied.
**Tips Panel**

The Tips panel, located in the Viewer, lists tasks, tips, and details relevant to the current document and to the object selected in the Workspace content area.

For example, if you select a Financial Reporting book:

- Object tasks are listed in the **Tasks** section.
- A list of object-associated help topics is provided in the **Tips** section.
- File properties (for example, object name, MIMEType, author, and most recent modification date) are displayed in the **Details** section.

**Interacting with Documents**

For Financial Reporting, you use the Viewer to change the userPOV for reports and books.

**Note:**

The Document panel is not displayed if you select to display the POV above the report or book. See Chapter 2, “Setting Preferences and Personalizing your Workspace”.

**Enabling Viewing**

Workspace viewing prerequisites:

- For PDF, Acrobat Reader must be installed.
- For reports in PDF, a PDF writer (Acrobat Distiller, GNU Ghostscript, or AFPL Ghostscript) must be installed with the print server. If a PDF viewer is not available, only report names are listed.

➤ To use Internet Explorer for viewing PDF reports in Workspace:

1. Open Internet Explorer.
2. Select **Tools > Internet Options**.
3. In **Internet Options**, select the **General** tab, and, in **Temporary Internet Files**, select **Settings**.
4. In **Settings**, Check for newer versions of stored pages, select Every visit to the page.
5. Click **OK** twice.

**Preview Preferences**

You can set how to view reports and books; PDF Preview or HTML Preview. See Chapter 2, “Setting Preferences and Personalizing your Workspace.”
Logging On to Database Connections

You must be defined as a user, with a user name and password, in the data source that your report is using. For example, if you want to view a report that uses Analytic Services as a data source, you must log on to the database connection with a user account defined in Analytic Services.

Logging on usually occurs automatically. However, if you are not registered in the database, you are prompted to log on through the Database Connection Properties dialog box, which displays the database connection name assigned by the report designer. Ask your administrator for a user name and password. See Chapter 3, “Exploring and Managing Items”.

➤ To log on to a database connection:
1. In Database Connection Properties, enter your user name and password.
2. Click OK.

Changing Expired Passwords for Essbase Users

Essbase administrators can set conditions to control when Essbase users have to change their passwords in Financial Reporting.

➤ To change your expired Essbase password from Workspace, when prompted:
1. Log on with your current user name and password.
2. Click Go.
3. In Change Analytic Services Password, enter your old password and new password.
4. In Confirm Password, reenter the new password.
5. Click OK.

Viewing Reports

If the report contains dimensions on the user POV, they are displayed above the report or book or in the Workspace document panel. Setting dimensions on the user POV enables modification of the dimensions, which results in a modified POV and requires regeneration of the report or book.

Note:

In the repository, you can display the current user POV settings page before reports or books are run. Current user POV settings can be edited after reports or books are run. See Chapter 2, “Setting Preferences and Personalizing your Workspace.”
Reports viewed in PDF are generated using the user POV and output in PDF. Reports with multiple page members are generated for all page members and displayed in Acrobat Reader in Workspace. HTML reports are generated using the user POV.

Viewing and customizing reports tasks:

- “Printing Reports and Books” on page 168
- “Changing User POV” on page 168
- “Responding to Prompts” on page 170
- “Using Expansions” on page 171
- “Using Related Content” on page 171
- “Selecting Members” on page 172
- “Changing Members for Grid POVs” on page 174

To view a report:

1. Select Viewer > Explore, then select a report or book that has prompts.

Note:
The file opens in PDF or HTML, as set Preferences. See Chapter 2, “Setting Preferences and Personalizing your Workspace.”

Tip:
Select the report or book from the repository. Then, right-click the report, and select Open in > HTML Preview or Open in > PDF Preview.

3. Optional: If the Current User POV Settings page is displayed, change the settings and click OK.

   See “Changing User POV” on page 168.

   If the page is displayed, User Point of View is selected in Preferences for Financial Reporting. See Chapter 2, “Setting Preferences and Personalizing your Workspace.”

4. After the report opens, in the View pane, click the database connection right arrow, and review POV settings.
5. Select a dimension to invoke Member Selection, select another member, then click OK.

   Report content changes to reflect the POV change. For information on Member Selection, see “Selecting Members” on page 172.

6. Select View > Preview User Point of View.

7. In Preview User Point of View, change one or more dimension selections by clicking Select.

8. In Member Selection, select another member, click OK.

   The report is refreshed. See “Changing User POV” on page 168.
Printing Reports and Books

You can print any type of report or book. For dynamic reports and books, data is refreshed. For snapshot reports and books data is not refreshed.

➤ To print a report:
1. From Workspace repository, open the report.
   Respond to prompts and modify as needed.
2. Select File > Print HTML or Print PDF.

   Note:
   Print HTML output reflects the report as shown on the screen, while PDF output is fully formatted for end-user use.

➤ To print a book:
1. From Workspace repository, open the book.
   Respond to prompts and modify, as needed.
2. Select File > Open In > Complete Book in PDF to create a PDF of the entire book, including all reports.

➤ To print a report from a book:
1. From Table of Contents view, select a report in the book and select Show Report.
2. Select File > Print.

Changing User POV

User POV, which specifies members for dimensions not defined on report grids, is available for dynamic reports and books, as specified during design-time. You can change user POV members before running reports and books and then run the reports and books to display new-member data. You can also edit user POVs after running reports and books.

When you view a report or book in HTML, the user POV can be displayed in the Document Panel of the View pane or above the report or book table of contents in the Content area.
Each dimension or member is a link. When a link is selected, it displays a Member Selection page from which you can select members for the dimension. The members for a dimension are shown in Tree view, which is a hierarchical view of the members of the dimension. By default, Tree view shows only the top-level member. You can expand a member to see its children.

Note:
Financial Management dimensions often have more than one top-level node.

Member-search methods:
- Expand data-member rows, and search visually. You can use the Expand all Rows button to expand the rows.
- Use the Find text box to search by member or alias and description. Search criteria can include wildcards; for example, * and ?.
  
  See “Selecting Members” on page 172.

To preview user POV settings prior to running a report or book:

1. Select File > Preference > Financial Reporting > General. Select one of the following for Location of Point of View, and a default location for the User Point of View when previewing a report; In View Pane or Above Report/Book.
   - Select In View Pane to display the user POV selections in the Viewer. If you do not select this option, the Viewer displays a Preview User Point of View option that, if selected, displays the Preview User Point of View dialog box.
   - Select Above Report/Book to display the user POV above the report or book.

2. Click OK.

3. From the repository, select the report or book.

4. Select File > Open In > PDF Preview or File > Open In > HTML Preview, or save the book as a snapshot book. The user POV is displayed in the location specified in Preferences.

5. Click a dimension to modify the POV in Member Selection.

See “Selecting Members” on page 172.
Responding to Prompts

Some reports are designed with prompts, which are displayed when you view the reports or books containing the reports. You respond to prompts and provide requested information by selecting members from prompt lists. You can edit prompts manually. If the prompts contain alias names, you convert them to member names.

SAP BW Variable Support in Financial Reporting

SAP BW variables are treated similar to Financial Reporting Member Selection prompts with some key differences: Variables are defined on the Cube, so no action is necessary to put them into a report. When a Cube has one or more variables present and a report/book which references that Cube is executed, the user is prompted to enter a response to any variables present in the Cube. All variables which are marked “ready for input” are shown for any report/book which references the Cube. The Respond to Prompt dialog box, is used to respond to Financial Reporting member selection prompts, as well as Variable responses. There are some differences: a Financial Reporting prompt always allows one or more members to be entered, whereas a variable can be defined to require a single member, numerous members, or a interval or range of members. Variables may be defined to not require a value. Variables can be set to take a numeric value instead of a member name. The Respond to Prompts dialog shows prompts and/or variables within the same dialog. For variables which take a single or numerous members, the user interface behaves the same as a prompt (except that if the variable takes a single member the member selection tree will only allow a single member to be picked). For variables which take an interval or range of members, two member selection/numeric value fields are shown; one for the “from” and one for the “to”. The member selection selector only allow a single member to be selected for either of those member selection fields. For variables which take a numeric value, the no member selection buttons are shown. The following describes the Respond to Prompts columns when a report goes against a cube which is a variable:

- **Variable** — shows the variable description
- **Type** — shows the type of variable which can be: Required Leaf Member Variable, Required Non-Leaf Member Variable, Required Numeric Variable, Optional Leaf Member Variable, or Optional Non-Leaf Member Variable.
- **Selection** — shows the description of the currently selected members with default values.
- **Source** — shows the report or grid which references the datasource which contains the variable.

The Run button validates the prompt members and variable values. Errors display next to the prompt/variable which has the error. The Reset button resets the prompt members and variable values to the initial, default values.

When a report has a member selection prompt in the Report and goes against a Cube which has an “interval” variable, the prompts are separately grouped to clarify the difference.

➤ To respond to a prompt when previewing a report or book:

1. From Workspace repository, navigate to a report or book that has prompts.
2. Select the report or book and select File > Open In > PDF Preview or File > Open In > HTML Preview.
Note:
The file opens in either PDF or HTML. This is set from the Preferences dialog box. For more information, see Chapter 2, “Setting Preferences and Personalizing your Workspace.”

3 Under the Selection column Respond to Prompts, perform an action:

- Enter the member name in the text box for the respective prompt, if known. If the text box is disabled, the prompt contains alias names. To edit the text box, select Edit Member Names. If more than one member is provided for the prompt, members must be separated by commas.

Note:
Selecting Edit Member Names displays the member names in the text box, not the alias names. Edit the member name associated with that alias.

- Click Go to Member Selection. Select Members is displayed. The default member is listed in the right panel - Selected area. See “Selecting Members” on page 172.

4 Click OK.

5 Optional: To undo any changes, click Reset in Respond to Prompts.

6 Click Run. The report or book is displayed.

Using Expansions

Expansions, available only in HTML reports, enable report viewers to see children of members and their corresponding data. Rows and columns for which expansions are enabled are displayed with right-facing triangles, which you click to view associated detail. After expansions are executed, pages are positioned near the rows or columns selected for expansion. Expansions are set up during design-time.

➤ To use expansions, perform an action:

- Click the right-facing triangle for a row or column to view the next level of detail.
  You can click multiple times, to see multiple levels of detail.

- Click the down-facing triangle for an expanded row or column to collapse its members.

Using Related Content

Related Content links to other Financial Reporting documents and to documents on other Hyperion servers. Related Content, set up by report designers, is available in HTML or PDF, as specified by the designers. You view Related Content links by clicking grid values, which are underlined by default.

Members of the cell selected for Related Content are passed to the user POV and used in the related content report. Thus, the context of the Related Content report is the cell selected in the primary report. For example, if you select the Margin row, Boston column cell, Financial...
Reporting sets the user POV for the Account dimension to Margin and for the Entity dimension to Boston and then displays the Related Content report. See the Hyperion Financial Reporting Studio User’s Guide.

Related Content rules:

- If only one action (HTML or PDF) is enabled for the object, actions are not listed on the Related Content page.
- The default action (HTML or PDF) is listed next to the object label.
- Folders open in the Related Content area.
- Object-level security is observed inside folders and when reports are requested to be viewed.

To use Related Content:

1. In a report, click a Related Content link.

   The report opens if a single report is selected in the list of Related Content and only one action is specified. If multiple reports are selected or multiple actions are specified, the Related Content page is displayed in a separate browser window.

2. If Related Content is displayed, click a link.

   If the link you click is not a folder, the document or action combination clicked is displayed.

Selecting Members

For reports, member selection is used to retrieve data and to determine how many members are displayed. You can also search for specific members.

Member selection tasks:

- “Selecting Members for User POVs” on page 173
- “Finding Members” on page 174
- “Changing Page Members” on page 174
Table 47  Items from the Member Selection Web Page

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Cancel</strong></td>
<td>Cancels changes made to the Member Selection dialog box</td>
</tr>
<tr>
<td><strong>Find</strong> button</td>
<td>Used to select the type of search. A member can be searched for and displayed as the name of the member, the description or name in the alias table, and the name of the member and description/alias from a particular table. To search, click Find.</td>
</tr>
<tr>
<td><strong>Find text box</strong></td>
<td>Enter search criteria (not case sensitive)</td>
</tr>
<tr>
<td><strong>Use Wildcards</strong></td>
<td>Enables use of wildcards in the Find text box (selected by default)</td>
</tr>
<tr>
<td>❍ ? for one character</td>
<td></td>
</tr>
<tr>
<td>❍ * for multiple characters</td>
<td></td>
</tr>
<tr>
<td>Note:</td>
<td>If search criteria includes a space, enclose the search phrase in double quotation marks. For example, &quot;IC Offset&quot; is &quot;&quot;IC Offset&quot;&quot;. If the &quot;<em>&quot; wildcard is at the end only, for example, IC Offset</em>, quotation marks are not required.</td>
</tr>
<tr>
<td><strong>Rows Per Page</strong></td>
<td>Specifies a number of rows per page to be displayed on the member list (default 20). If the number of members exceeds the number of rows, use buttons on the Edit Member Selection header to scroll through the rows:</td>
</tr>
<tr>
<td>❯ Next Page</td>
<td></td>
</tr>
<tr>
<td>❏ Previous Page</td>
<td></td>
</tr>
<tr>
<td>Note:</td>
<td>To permanently set the rows per page to a value other than the 20-row default, see your system administrator.</td>
</tr>
<tr>
<td><strong>Displays one or more member properties</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Expands all row members of the hierarchy down to the child level</strong></td>
<td></td>
</tr>
<tr>
<td><strong>Collapses all rows</strong></td>
<td></td>
</tr>
</tbody>
</table>

**Selecting Members for User POVs**

You can use the Member Selection dialog box to select members for reports and books. Using selected dimensions, you can locate members and run reports or books for them.

➤ To select a member for the user POV:

1 Open a report or book that contains a user POV.
2 Click a dimension or member link. **Member Selection** is displayed.
3 Click the plus sign (+) to display children.
4 Select a member, then click OK.

The reports runs for the member. Note that report content reflects the POV change.
Finding Members

From the Member Selection page, for the user POV, you can find and select members.

➤ To find a member:

1 From the Find list, select criteria.
   The search-options list is based on the report data source.

2 In Find, enter complete or partial text. You can use partial text with * or ? wildcard symbols. Use Wildcards is selected by default.

   Tip:
   Use double quotation marks to search for members containing spaces.

3 Click Find to display search results.

4 Select a member, then click OK. The reports runs for the member.

Changing Page Members

You can change a page member only if, during report design, multiple members are assigned to the page axis of a grid. You change a page member to see different report views—HTML reports only. After you change a page member, the report is refreshed and populated with the new page member.

➤ To change a page member:

1 From Workspace, open a report with page-axis members in a grid.

2 From Page, select a member. The report is run, and data is displayed for the selected member.

   Note:
   For PDF, data for page members is displayed on different pages.

Changing Members for Grid POVs

Grids on reports can have dimensions on the grid POV. You can use the default member for each dimension or select a new member to run for a report.

➤ To change a member on the grid POV:

1 Open an HTML report that displays a grid POV.

2 Click a dimension or member link.

3 in Member Selection, select a member, then click OK. The report runs for the selected member.
Viewing Snapshots

Snapshots are similar to reports, except that they contain data for a specific point in time and thus do not retrieve data dynamically. Therefore, data-level security from the data source is not respected.

You can view snapshots in HTML or PDF. However, the print server and a PDF writer must be available to display both HTML and PDF links. If the print server is not available, snapshots are available only as HTML links.

See Table 46 for a list of features available in snapshots.

➤ To view a snapshot:

1. From Workspace repository, select View > Display Items of Type > Hyperion > Snapshot Book or Snapshot Report.
2. Right-click the snapshot and perform an action:
   - To view the snapshot in HTML, and select Open In > HTML Preview.
   - To view the snapshot in PDF, and select Open In > PDF Preview.

Viewing Books

From Workspace, you can view books in HTML or PDF. In PDF, you can view the entire book or individual reports in the book. The print server must be available to display both HTML and PDF links. If the print server is not available, books are available only as HTML links. When you select a report name, the report is generated for all member combinations specified in the book. You can add reports to books and modify members. To create and modify books, see Chapter 9, “Designing Documents for Financial Reporting Batches and Books.” To select and modify members, see “Selecting Members” on page 172.

You can preview user POVs before running books. When you view books, user POVs and tables of contents are displayed. User POVs specify members for dimensions not defined on report grids. You can change user POV members and then run books to display new-member data. See “Changing User POV” on page 168.

You use tables of contents to locate reports that you want to view and to set options.

Note:

The time required to generate and display books in Workspace varies, depending on book size. You can cancel books at any time.

For reports with multiple page members, you can change page members and refresh the reports to show the updated data. Reports are viewed in Acrobat Reader within Workspace.

➤ To view a book:

1. From the list of files in Workspace repository, select View > Display Items of Type > Hyperion > Book.
2 Right-click the book, then perform an action:
   ● To view the book in HTML, and select Open In > HTML Preview.
   ● To view the book in PDF, select Open In > PDF Preview.

3 Optional: If the Current User POV Settings page is displayed, change the settings, then click OK.
   See “Changing User POV” on page 168.
   If the page is displayed, User Point of View is selected in the Preferences dialog box for Financial Reporting. See “Selecting Members” on page 172.

4 Optional: Modify the user POV, from the Book Table of Contents page, and run the report for the new POV.

5 In Book Table of Contents, review the list of reports and locate the report with the preferred members.

6 Perform an action:
   ● For HTML books, click File > Open In > HTML Preview.
   ● For PDF books, click File > Open In > PDF Preview to view individual reports, or click File > Open In > Complete Book in PDF to view the entire book.

7 Optional: Perform one or two actions:
   ● From the book editor, add reports and re-run the book.
     See Chapter 9, “Designing Documents for Financial Reporting Batches and Books.”
   ● From the book editor or from the book POV, modify members.
     See “Selecting Members” on page 172.

**Viewing Snapshot Books**

You can view snapshot books from Workspace in HTML or PDF. When you view snapshot books in PDF, you can view the entire snapshot book or individual snapshot reports. The print server must be available to display both HTML and PDF links. If the print server is not available, snapshot books are available only as HTML links.

When you view snapshot books, tables of contents are displayed. You use tables of contents to locate snapshot reports that you want to view and to set options.

➤ To view a snapshot book:

1 From the repository, select View > Display Items of Type > Hyperion > Snapshot Book.

2 Right-click a snapshot book, then perform an action:
   ● To view the snapshot book in HTML, then select Open In > HTML Preview.
   ● To view the snapshot book in PDF, select Open In > PDF Preview.

3 Optional: From the Table of Contents page, modify the user POV and run the report for the new POV.

4 In Book Table of Contents, review the list of reports and locate the report with the preferred members.

5 Perform an action:
   ● For HTML snapshot books, click File > Open In > HTML Preview.
For PDF snapshot books, click File > Open In > PDF Preview to view individual snapshot reports, or click File > Open In > Complete Book in PDF to view the entire snapshot book.
From Workspace, batches can be created, maintained, and scheduled and books can be created, maintained, and run. Also, advanced member selection provides capabilities such as member functions; for example, Children, Descendants and lists which can be used when editing books.

For Financial Reporting module, you can define and save batches using Workspace new document wizard and copy and delete batches in the repository. Deleting a batch requires file permissions to the batch. By default, only the scheduling user is assigned access rights to snapshots and snapshot books in the repository. If you have file permissions to a batch, you can run every report in the batch when scheduled. The scheduling user can assign file permissions to other users and groups at the time of scheduling. For more information, see “Assigning File Permissions to Snapshots and Snapshot Books” on page 195.
Scheduled batches have a scheduled batch POV (Point of View), which you can modify while scheduling. You can also specify prompt information for the batch. The POV and prompt information, provides values for the POV and prompts specified for each book and report contained in the batch. You can schedule batches to be processed immediately or in the future. For more information on the scheduled batch POV, see Chapter 13, “Scheduling Jobs and Batches.”

Reports or snapshot reports created in Financial Reporting Studio, can be assembled into a book, enabling you to generate their output in one session from Workspace. For example, you can schedule a set of reports to run once a month. You can configure books to generate several versions of a report and different member selections. A book containing those reports can be run at once. The reports contained in the book can be printed or viewed individually in entirety.

Two types of books can be define and saved to the repository:

- Books—Comprises of reports and snapshot reports. When you run a book, the report data is dynamically retrieved from the database; the snapshot data remains static.
- Snapshot books—A book saved as a snapshot book. The data contained in the reports, as well as a table of contents, is created when you save a book. Whenever a snapshot book is viewed, data-level security does not apply; data-level security is applied when the snapshot book is created and is based upon the data level security that is set for the user that saved the snapshot book.

A book contains a book POV, which is a combination of all dimensions in the user POVs for each report in the book. Dimensions that are not defined in a report, default to the user POV member and the dimensions are displayed in the book POV of the Book Editor. You can also select the user POV as a member on the book POV, allowing you to modify the parameters since they are no longer stored in the book definition.

The member selected for a dimension in the book POV is used in each report referencing the book POV for that dimension. The data sources in the POV match the data sources used by the reports in the book.

**Note:**

When a book is scheduled as part of a batch, the dimension referring to the user POV are controlled by the scheduled batch POV.

Tasks that can be performed with books and snapshot books:

- Use batches to group and process sets of books. See Chapter 13, “Scheduling Jobs and Batches.”
- E-mail links to the books or snapshot books. See Chapter 3, “Exploring and Managing Items.”
- Delete books or snapshot books. See Chapter 3, “Exploring and Managing Items.”
- Import books and snapshot books from a file system outside of the repository. See Chapter 4, “Importing Artifacts.”
- Export books and snapshot books. See Chapter 4, “Importing Artifacts.”
- Perform advanced member selection capabilities such as member functions for Children and Descendants, and lists.

**Designing Documents**

From Workspace, you can create a book or batch using the Select a Task wizard. For more information on these topics, see the following:

- “Creating Books” on page 181
- “Designing Batches” on page 192

**Creating Books**

Creating books includes the following:

- “Saving Books and Snapshot Books” on page 189
- “Opening Books or Snapshot Books” on page 190
- “Renaming Books and Snapshot Books” on page 190
- “Previewing and Printing Books and Snapshot Books” on page 190

Books are created, edited and saved in Workspace. You must have administrator or designer rights to create a book. A book can include reports and snapshot reports. The reports can contain prompts for member selection, which are defined when the book is run.

**Note:**

When you save a book as a snapshot book, expansions and related content are removed.

When adding a report to a book, dimensions from the book POV can be set to multiple members. When the book is run, the report iterates over each member. For example, if North, South, East, West, Actual, and Budget are selected, the book contains six versions of this report. You can collate the printed output by member selection if the same member selections are used for all reports in the book. This enables, for example, all the reports for East, Budget to be grouped.

You can copy report member selections between reports if they use the same data source. This eliminates having to select shared members multiple times.

A table of contents is created for the book. You can collate the reports within the printed table of contents by report or by member selection. For example, you can create the following two books:

**Book 1** Balance Sheet (New York, Boston), (Q1, Q2) Cash Flows (New York, Boston), (Q1, Q2)

**Book 2** Balance Sheet (Actual, Budget), (Q1, Q2) Cash Flows (New York, Boston), (Q1, Q2)
If you collate reports in printed books by report, the first report for each set of member selections is run, then the second report for each set of member selections is run. The following book is generated:

Book1 Table of Contents
Balance Sheet
   New York, Q1
   New York, Q2
   Boston, Q1
   Boston, Q2
Cash Flows
   New York, Q1
   New York, Q2
   Boston, Q1
   Boston, Q2

If you collate reports in printed books by member selections, each report for the member selection is run. The following book is created:

Book1 Table of Contents
Balance Sheet
   New York, Q1
   Cash Flows
   New York, Q1
   Balance Sheet
   New York, Q2
   Cash Flows
   New York, Q2
   Balance Sheet
   Boston, Q1
   Cash Flows
   Boston, Q1
   Balance Sheet
   Boston, Q2
   Cash Flows
   Boston, Q2

➤ To create a book:

1 Launch Workspace.
2 Select File > New > Document. The 1. Select a Task wizard is displayed in the Content area.
3 Select Collect reports into a book. and click Next.
4 In Step 2: Select Files, select reports from folders, then click ➜.

Tip:
Press the Shift key to select multiple consecutive reports. Press the Ctrl key to select multiple non-consecutive reports.

5 Optional: To remove a report from the book, select the report, then click ➝. To remove all reports from the book, click ➐.
Note:
If you move, delete, or rename a report in the repository, the report is removed from the book the next time the book is opened. To include the report, add it to the book.

Tip:
To change the order of the selected reports, click and.

6 When completed, click Finish to open the Book Editor.

Note:
To display dimensions in the table of contents, select the dimension name in the Book Editor and select Edit > Display Members in Table of Contents. The Table of Contents column of the Book Editor indicates whether the member name is hidden or displayed.

7 Optional: Add or change members selections for the book POV:
   a. In the Name column, double-click the dimension to display Member Selection.
   b. Select the members. See “Selecting Members” on page 183.
   c. Click OK.

8 Optional: Copying report member selections from one report to another in the Book Editor:

Note:
Member selections are only copied between reports having the same dimensions on the User Point of View.

   a. Highlight the report containing the members to copy.
   b. Select Edit > Copy Member Selection to, then select a report.

9 Select File > Save to save the Book with a file name and description. See “Saving Books and Snapshot Books” on page 189.

Selecting Members

You can select members, create and save member lists, and select functions that dynamically retrieve members from the database connection.

The following figure shows the Member Selection dialog box for the product dimension. The left panel shows the Members, Lists, and Functions tabs. For information on member lists and functions, see the Hyperion Financial Reporting Studio User’s Guide. You can add additional column headings in the Members tab.
To add column headings to the left panel of the Members tab display, select Show Properties, then select the column name.

To view a hierarchy other than the one that is displayed:
1. Click a hierarchical dimension in the Available area of the Members tab.
2. Click the Hierarchy drop-down list, then select the hierarchy.
3. Click OK.

The properties below the Available area are displayed only if you are reporting on Hyperion Financial Management Organization by Period for the Entity dimension. Both the parent and the entities that belong to the parent are displayed.

When you run a report, the entity name is displayed; not the parent name.

**Available Area**

**Member Selection** has three navigational tabs; Members, Lists, and Functions. In the left panel, you can show individual members, member lists, and functions that dynamically select members.
Members Tab

The Members tab shows members that are associated with the selected dimension. By default, the members for a dimension are shown in tree view, which is a hierarchical view of the members of the specified dimension. You can also show the members in a flat list. By default, the tree view shows only the top-level member. You can expand the top-level member to see its descendants.

Lists Tab

The Lists tab shows member lists used to perform a query or to select members for your report. The type of lists are based on the database connection. Member lists can be:

- **System lists** — Predefined in the database when you create user lists; you can include members, member lists, and functions. System lists are available when using Essbase, Oracle’s Hyperion® Planning – System 9, or Financial Management as database connections.

- **User lists** — Lists that are created by you. When you select print preview or Web preview, the members in the user-defined list are displayed in the order that you specified during list creation. User lists can be created when using Essbase as a database connection. See *Hyperion Financial Reporting Studio User’s Guide*.

- **Dynamic lists** — Predefined lists that are used with the DynamicMemberList function. Dynamic lists are available only when using Financial Management as a database connection. See *Hyperion Financial Reporting Studio User’s Guide*.

Functions Tab

You can specify functions to use when selecting members for your report or adding members to member lists. Functions enable you to retrieve members and related members from a database connection. You can specify one or more functions and edit the function parameters. See *Hyperion Financial Reporting Studio User’s Guide*.

Assigning Special Members

Use the Select Members dialog box to select the special members Prompt, Same As, Current Point of View, and User Point of View.

- **Prompt** — Acts like a variable that asks the user to select members. Prompts enable the report writer to filter the dimension members from which the user can select when running the report.

- **Same As** — Creates a column or row member selection with the same member selection setting as another column or row.

- **Current Point of View** — Acts as a variable that employs the POV to specify the member of a particular dimension when the report is run.

- **User Point of View** — Can be selected as a member on the book POV. The parameters can be modified by the end user.
Prompt Details

Prompt Details allows you to limit the members that can be selected for a book. You can also specify an alternate member label; a description (for a Financial Management database connection) or aliases (for Analytic Services or Planning database connections), or both member names and descriptions or aliases. For example, if you want to only provide lines of products, in Member Selection (the previous screen) you would select Prompt as a member of Product, then in Prompt Details select specific lines of product. The user who runs the report selects from those product lines.

➤ To set up a report prompt for members:

1 Optional: To limit the prompt selection to specific default members, or a list of members, or both, take an action:
   - If the member name is known, enter the member name in Default Member or click the Default Member search button. If multiple members are provided for the prompt, members must be separated by commas.

   Note:
   If you leave Default Member blank, the Respond to Prompts dialog box does not display a default member when a user runs the report. The user must specify a member rather than accept a default.
   - If the list of members is known, click the Choices List button to select a list of members. If multiple member lists are provided for the prompt, member lists must be separated by commas.

2 From the Member Labels in Prompt Selection Dialog drop-down list, select the kinds of labels to be displayed in the Respond to Prompts dialog box when the report is run:
   - If the database connection is Analytic Services or Planning, select Member Name, Alias, or Member Name and Alias.
   - If the database connection is Financial Management or SAP BW, select Member Name, Description, or Member Name and Description.

3 Click OK.

Selecting the User Point of View as a Member in the Book Point of View

When a report is added to a book, the dimensions that are on the user POV in the report definitions are applied to the book POV. Members on the book POV default to the user POV in the Book Editor.

Tip:
To filter the repository by books, select View > Display Items of Type > Hyperion > Book.
To select the user POV as a member in the book POV:

1. From Workspace repository, right-click a book, then select Open In > Editor. The Book Editor is displayed.
2. In the book POV View pane, click a dimension for which you want to set up a user POV.
3. In Member Selection, select User Point of View for.
4. Click OK.

Assigning Members Using Functions

You can use functions and edit their parameters to select members dynamically. For information on the use of, and editing function parameters, see the Hyperion Financial Reporting Studio User’s Guide.

Selecting Multiple Members Based on Criteria

You can select members based on criteria. You define criteria by creating expressions of members, Boolean operations, and commands.

Boolean operators enable you to specify precise member combinations for the report, useful with large volumes of data. Use the AND, OR, UNION, and NOT Boolean operators, combined with expression commands, to refine your member selections.

To select multiple members based on criteria:

1. In Member Selection, click Show Advanced Options, located in the right panel Selected area.

   Note:
   At least two members must be displayed in the Selected area before you can create criteria.

2. Build expressions by using one or more of the following operators and symbols:
   - Select the Not Boolean operator to build the expression. Not is the inverse of the selected condition.
   - Type a left parenthesis, ( ( ), to add an opening character to the expression.
   - Type a right parenthesis, ( ) ), to add a closing character to the expression.
   - Click in the Operator column, then select:
     - And — When all conditions must be met.
     - Or — When one condition of several must be met.
     - Union — To combine the data.

   Note:
   You must use double parentheses if you are using three members. For example, if you selected descendants of Market and you want to exclude East, West, and South, your
advanced member selection query should be as follows: Descendants of Market AND NOT (East AND NOT (West AND NOT SOUTH))

3 Click OK.

**Searching for Members**

You can search for members to edit. You can search using a text string or property (that is, name and description). You can use a blank space as a separator to perform simultaneous searches. To search a string for an exact match, including blank spaces, enclose the string in quotation marks.

If you are searching for a list or function, you must activate this function by using the Find Next or Find Previous button.

**Note:**

For Oracle’s Hyperion® Financial Management – System 9, when you search for an entity, you need to search on parent.entity (for example, D62VIELO.D62475LO). When you search just the entity, you need to precede the entity with a wildcard, (for example, *D62475LO).

Find options to locate members:

<table>
<thead>
<tr>
<th>Table 48</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Option</strong></td>
</tr>
<tr>
<td>Find</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Use Wildcards</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td><strong>Note:</strong> If the search criteria has a space in it, enclose the search phrase in quotes. For example, <em>IC Offset</em> should be &quot;*IC Offset&quot;. If the location of the **<em>wildcard is at the end only, for example IC Offset</em>, then you do not need to enclose the phrase in quotes.</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

➤ To search for members:

1 In **Member Selection**, enter text in the Find text box.
Note:
The wildcard option is enabled.

2 Perform an action:

- If you are searching in the Members tab, click the Find button.
- If you are searching in the Lists or Functions tab, click Find Next, or Find Previous.

3 Click OK.

Previewing Selected Members
You can preview the selected members. Members can include a list or function result from evaluated member lists or functions, if applicable.

➤ To preview members, in Member Selection, click Preview Selection, located in the right panel.

Saving Books and Snapshot Books
You can save books to the repository as a compilation of reports, snapshot reports, or reports and snapshot reports. An existing book can be replicated by saving it with the Save As command.

➤ To save a book or snapshot book:

1 From Workspace repository, right-click a book and select Open In > Editor to open it in Book Editor.
2 Select File > Save or File > Save As.
3 Select one of the following options from the Type drop-down list:
   - Book—Reports data will be dynamic when the book is run; snapshot report data will be static, based on when the report was saved as a snapshot.
   - Snapshot Book—Reports data is saved and becomes static; snapshot reports data is static, based on when the report was saved as a snapshot.
4 Enter a name and description, select a folder, then click Save.

Note:
If you are saving as a snapshot book, the Respond to Prompts dialog box is displayed if any prompts exist in the book or any report in the book and the Current User POV Settings dialog box is displayed. See Chapter 8, “Using Financial Reporting.”

5 Navigate to the repository to establish file permissions for the book or snapshot book. See “Assigning File Permissions to Snapshots and Snapshot Books” on page 195.
Opening Books or Snapshot Books

After you save a book, you can open it to maintain, print, or preview the book in HTML or PDF format. When you preview a book, a table of contents is displayed with a list of reports in the book. When you preview a snapshot book, the Table of Contents is displayed in PDF or HTML format, depending on your preference setting. Snapshot books cannot be changed, but they can be previewed, printed, and viewed from the repository. See “Previewing and Printing Books and Snapshot Books” on page 190.

➤ To open a book or snapshot book:

1. From Workspace repository, navigate to a book or snapshot book and select File > Open In.
2. Perform an action:
   - To view a printed version of the book, select PDF Preview.
   - To view the book in HTML format, select HTML Preview.
3. The Content area displays the Book Table of Contents, the tab at the bottom of the browser displays the book name and View (for example, TestBook - View). The report, snapshot or member name is displayed on every row for which it applies in the Book Table of Contents.
4. Select one of the reports or snapshots in the Book Table of Contents, then click Show Report. The report or snapshot is displayed in the Content area in HTML or PDF format, with the Report Name and POV in the tab description.
5. To close the book or snapshot book, select File > Close.

Renaming Books and Snapshot Books

After saving a book or snapshot book or making a duplicate, you may want to rename the file.

➤ To rename a book or snapshot book:

3. Type another name and description into the Name and Description fields.
4. Click OK.

Previewing and Printing Books and Snapshot Books

You can preview books and snapshot books in PDF or HTML prior to printing. From the book table of contents, you can select individual reports within a book to preview as PDF or HTML or view the entire book with all of the reports in PDF.

You can also print an entire book or snapshot book or print individual reports in a book or a snapshot book. When you print a book, the data is retrieved for the reports in the book and the
book is printed. When you print a snapshot book, the data has already been saved in the reports when you save the book as a snapshot book.

Prior to running a book, you can preview the user Point of View and make any necessary changes. This allows users to verify that the members on the user POV are appropriate before running the report or book instead of after the output is displayed.

For more information on previewing and printing, see the following chapters:

- Chapter 8, “Using Financial Reporting”
- Chapter 3, “Exploring and Managing Items”

Note:

Before you print a book, you should set the Book Setup options as described in the following section.

## Changing the Book Setup

Book Setup options enable you to specify whether to include the printed table of contents, set the page orientation, set the numbering of pages to consecutive, and include the table of contents in the consecutive page numbering, collate the table of contents based on reports, collate the table of contents based on the member selection, and select the member label you want used in the table of contents for each data source.

To change the book setup:

1. From Explore repository, right-click a book and select Open In > Editor to open the Book Editor.
2. Select File > Book Setup to display the Book Setup dialog box.
3. In the Page Setup section, select the following:
   - In Paper Size, select Letter, Legal, Ledger, A4 or A3.
   - To continue the page numbering from the previous report in the book, select Consecutive Page Numbers. To begin each report in the book with page 1, deselect Consecutive Page Numbers. To include the table of contents in the consecutive numbering scheme, select Include Table of Contents.

Note:

Page numbering must be specified in the header or footer of each report in the book before you can print the page number.

- In Collate Reports By, select an option for collating the printed table of contents:
  - Select Reports to collate based on the reports.
  - Select Member Selection to collate based on the member selection.

4. In the Table of Contents section of the dialog, select the following:
To include the book table of contents when printing, click **Include Table of Contents in Printed Output**.

**Note:**
For HTML or PDF preview, this option does not apply. The book preview always includes the table of contents for the book.

- Select **Portrait** or **Landscape** for the orientation of the Table of Contents.
- In **Member Labels in Table of Contents**, select the member label to use in the table of contents for the data source that you are currently using. The listed options depend on the data source you are using.

5 Click **OK**.

### Exporting Books and Snapshot Books

You can export books and snapshot books from the repository. See Chapter 3, “Exploring and Managing Items.”

### Designing Batches

Using batches, you can process sets of reports and books simultaneously. Batch creation is comprised of the name, the reports, books, snapshots, snapshot books, and prompts. The prompt information is for the current batch you are running.

Saved batches can be modified, removed, or rescheduled. You can duplicate a batch to use some or all of the same properties as the original batch.

➤ To design a batch:

1 Launch **Workspace**.

2 Select **File > New > Document** to display the **Select a Task** wizard.

3 Select **Batch Reports for Scheduling**, then click **Next**.

4 In **Select Files**, use the **Type** field to filter your selection by **Financial Reporting report, Snapshot report, Book or Snapshot book**.

5 Select your report types and move them to the **Selected Items** panel by clicking **»**.

6 Optional: To remove a report type from **Selected Items**, select the report, then click, **«**. To remove all reports from **Selected Items**, select **«»**.

**Note:**
If you move, delete, or rename a report in the repository, the report is removed from the book the next time the book is opened. To include the report, add it to the book.
Tip:
To change the order of the selected reports, use ✓ and ✓.

7 Click Finish to open the Batch Editor.

Tip:
If you select a report type multiple times, you are prompted to enter a new name for the duplicate report type. The renamed report type is listed in the Batch Editor with its original name followed by the new name in parentheses. To discard the duplicate report, click Cancel.

8 Respond to any prompts that are displayed. See “Defining Prompts for a Batch” on page 194.

9 Select File > Save As.

10 Select a folder, enter a name and description, and click Save.

➢ To duplicate and edit batch properties based on a scheduled batch:
1 From the View panel, select Schedule, then select Batch Scheduler.
2 Select a Scheduled Batch select Edit > Duplicate and Edit Properties.
3 In Schedule Batch, perform an action:
   ● To duplicate properties for a new batch in the repository, search and select the batch and click Next.
   ● To duplicate properties for the selected scheduled batch, click Next.
4 Edit the properties of the batch as needed. For example, you can change the Start Time or Destination settings.
5 Click Finish.

➢ To modify a batch:
1 From the View panel, select Schedule, then select Batch Scheduler.
2 Select Edit > Properties.
3 In Schedule Batch, select a batch and click Next.
4 Make changes, and click Finish.

➢ To delete a batch:
1 From the View panel, select Schedule, then select Batch Scheduler.
2 In Batch Scheduler, select a batch, then select Edit > Delete.
3 Click Yes.
Defining Prompts for a Batch

Prompts are requests for members in the report or book. If reports or books in a batch have prompts, the end user can select the members in the Batch Editor.

When users save the Batch, the Respond to Prompts dialog displays any/all prompts/variables contained in the artifacts within the Batch.

Identical Prompts and Variables

Since SAP BW variables are defined on a datasource and not in a Grid in a Report, the same variable can be used for all Grids in a Report, Book or Batch containing Reports and/or Books, whereas a prompt is explicitly defined on a row/column/page of a Grid. When users are prompted for a member/value to be used for a variable, they can optionally select to use the same member/value for all references to the datasource which contains the Variable. A response to prompts can also be applied with a single response to all references or specified for each member/values for each Grid, Report or Book.

When a variable exists and there is more then one reference to the data source, or when the same prompt exists in more then one grid, the Respond to Prompts dialog box shows a drop-down list where users choose whether they want to respond to prompts at the Grid, Report/Book or Batch level. The selections shown in the dropdown list depend on whether the Respond to Prompts dialog is shown while running a Report, or Book or from within the Batch editor. The drop-down list only appears when a selection is needed. For example, if running a Report with a single grid against a SAP data source with a variable, a drop-down selection is not needed to be shown. Similarly, if a Report, Book or Batch contains only a single Prompt, or the Prompts are different (different dimensions, default members, or choices list), the drop-down selection will not appear.

When running a Report, the drop-down selections are:

- Respond to Prompts at the Report Level (default)
- Respond to Prompts at the Grid Level

When running a Book, the drop-down selections are:

- Respond to Prompts at the Book Level (default)
- Respond to prompts at the Report Level
- Respond to prompts at the Grid Level

When editing a Batch, the drop-down selections is: Respond to Prompts at the Batch Level (Default) Respond to Prompts at the Report/Book Level Respond to Prompts at the Grid Level

- Respond to Prompts at the Batch Level (default)
- Respond to Prompts at the Report/Book Level
- Respond to Prompts at the Grid Level

The selections are only shown when necessary. The selection are not shown if there are multiple references to a variable or prompt.
If the user wants, they can respond to a prompt once, and the same value will be used for both responses, or they can select “Respond to Prompt at Grid Level” in the dropdown, press Apply and enter different values for each prompt listed.

The Source column shows what artifact the prompt is on. When identical prompts are found and only a single prompt response is presented, the Source column will show an asterisk (*) to indicate that the prompt response will apply to all prompts of that type.

The ability to select the level at which to respond to prompts is only available Workspace. In Financial Reporting Studio, the Respond to Prompts dialog box always show all member selection prompts and a single reference to each variable.

➤ To define prompts:

2. Select a batch. The dimensions that are set up with a prompt for the reports are displayed in the Member Selection column Batch Editor.
3. Select a dimension, then select Edit > Member Selection.
4. In Member Selection, select the member you want to use in the report when the batch runs. See “Selecting Members” on page 183.
5. Click OK to return to Batch Editor.
6. Perform an action:
   - Optional. Schedule the batch. See “Designing Batches” on page 192.
   - Save the batch by selecting File > Save, then File > Close.

Opening Batches

You open a batch to edit it or to schedule it.

➤ To open a batch:

2. From the Type drop-down list, select Hyperion > Financial Reporting Batch.
3. Navigate to the folder in which the batch resides.
4. Select the batch file and click Open.

Assigning File Permissions to Snapshots and Snapshot Books

To allow other users and groups to view snapshots and snapshot books in the repository that you create when running a batch, you need to assign access rights to the users and groups.

➤ To assign or remove access to snapshots:

1. Click Navigate > Schedule > Batch Scheduler.
2 Select a batch, then select Edit > Properties.

3 In Schedule Batch, click Next until the Destinations area of the Schedule Batch dialog is displayed.

4 Select Save As Snapshot In Repository.

5 Click File Permissions. For procedures, see step 1.

Note:

If you remove all users, groups, and roles for a batch, then only an administrator can see the snapshot output generated by the batch in the repository.
Using Interactive Reporting Documents in Workspace

Workspace enables users to query relational databases and heterogeneous sources (for example, users of SQL Server, Oracle, flat files, Production Reporting/Web Analysis module content) and perform quick ad-hoc analysis by drilling down and pivoting on the data to see patterns or exceptions. Many features help users to analyze their data to conduct sales and key performance, financial, and forecasting analyses.

Three types of users can relational data source. “Developers” who have the database connectivity software may use a full 32-bit application. “Power users” without this connectivity or when there are more security concerns may be given access to query using a client connected to the database through a server. Users can further given permission to create content completely from scratch, using add-on software installed on their local machine and hosted by the web browser. “Information consumer users” typically use a “thin client” approach; no software is loaded for these users, who instead interact with a DHTML-based series of pages.

The topics in this section explain how use to an Interactive Reporting document (BQY) in Workspace for Information consumer users.
Using the Toolbars

Use the Standard and Interactive Reporting toolbars to navigate through the Workspace and work with common commands.

- “Standard Toolbar” on page 198
- Standard Interactive Reporting Toolbar
- Navigation Toolbar
- Paging Toolbar

Standard Toolbar

The Standard Toolbar is used for common Workspace features:

<table>
<thead>
<tr>
<th>Element Number</th>
<th>Element Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>New Document</td>
<td>Displays the New Document Wizard, which enables you to create an Interactive Reporting document (BQY) for online analysis, collect highly formatted reports into a book, or batch highly formatted reports for scheduling.</td>
</tr>
<tr>
<td>2</td>
<td>Open</td>
<td>Displays the Open dialog box from which you can navigate to a file.</td>
</tr>
<tr>
<td>3</td>
<td>Logoff</td>
<td>Logs off without saving any information.</td>
</tr>
<tr>
<td>4</td>
<td>Viewer</td>
<td>Displays many different types of documents and maintains a list of opened documents, so you can switch quickly between multiple documents.</td>
</tr>
<tr>
<td>5</td>
<td>Schedule</td>
<td>Manage jobs, batches and events for automated processing.</td>
</tr>
<tr>
<td>6</td>
<td>Explore</td>
<td>Lists and the contents of the Repository, so that you can manage and control files and folders.</td>
</tr>
<tr>
<td>7</td>
<td>Administer</td>
<td>Enables you to manage users, user groups, user preferences, roles and authentication methods.</td>
</tr>
<tr>
<td>8</td>
<td>Impact Manager</td>
<td>Updates Interactive Reporting documents when the database structures, database connections or links to external data sources change.</td>
</tr>
<tr>
<td>10</td>
<td>Home</td>
<td>Displays the Start Page for Workspace.</td>
</tr>
<tr>
<td>12</td>
<td>Toggle View pane</td>
<td>Toggles the display of the View pane. The View pane extends down the left side of the interface. At the top of the View pane is a series of buttons that enable you to jump between panels. Each panel has a specific use and corresponding control.</td>
</tr>
<tr>
<td>13</td>
<td>Help</td>
<td>Launches the HTML Help page in a new browser.</td>
</tr>
</tbody>
</table>

Standard Interactive Reporting Toolbar

The Standard Interactive Reporting toolbar is specific to those features used exclusively for Interactive Reporting documents:
<table>
<thead>
<tr>
<th>Element Number</th>
<th>Element Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Data Layout</td>
<td>Enables the Data Layout feature.</td>
</tr>
<tr>
<td>2</td>
<td>Dashboard Home</td>
<td>Displays the Dashboard Home section.</td>
</tr>
<tr>
<td>3</td>
<td>Current Page</td>
<td>Shows the current page of the for table reports. For all charts with the exception of pie, scatter and bubble chart, the current view of data points on the x and y axes is shown.</td>
</tr>
<tr>
<td>4</td>
<td>Page Left</td>
<td>Moves one page in the left direction in the report sections. To move to the first page in the left direction, select [Shift] + Click + left arrow. In the Chart section, this icon enables you to move one view in the left direction.</td>
</tr>
<tr>
<td>5</td>
<td>Page Up</td>
<td>Moves one page in the up direction in the report sections. To move to the top view, select [Shift] + Click + Up arrow. In the Chart section, this icon enables you to move one view up.</td>
</tr>
<tr>
<td>6</td>
<td>Page Down</td>
<td>Moves one page in the down direction in the report sections. To move to the bottom page, select [Shift] + Click + Down arrow. In the Chart section, this icon enables you to move one view down.</td>
</tr>
<tr>
<td>7</td>
<td>Page Right</td>
<td>Moves one page in the right direction in the report sections. To move to the first view in the right direction, select [Shift] + Click + right arrow. In the Chart section, this icon enables you to move one view right.</td>
</tr>
<tr>
<td>8</td>
<td>Refresh</td>
<td>Refreshes only the current section against the database server to dynamically retrieve the most current data set, with the exception of the Dashboard and Report sections. When the Refresh command is selected in the Dashboard and Report sections, all queries in the Interactive Reporting document (BQY) are refreshed. Queries are refreshed in the order in which they are displayed in the section catalog of the full client. For example, in a Interactive Reporting document (BQY) with three queries, Query1, Query2, and Query3, the queries are executed in that order when “Refresh All” is selected.</td>
</tr>
<tr>
<td>9</td>
<td>Export to PDF</td>
<td>Exports a section to Portable Document Format (PDF) and launches it inside your browser if the PDF MIME type is set in your browser. If you have Adobe Acrobat Reader installed, Adobe Acrobat Reader can be downloaded from Adobe’s web site at <a href="http://www.adobe.com/products/acrobat/">http://www.adobe.com/products/acrobat/</a> readstep.html. If the PDF MIME type is not set in the browser, the browser “Save As” dialog box is invoked.</td>
</tr>
<tr>
<td>10</td>
<td>Export to XLS</td>
<td>Exports a section to MS Excel and launches it inside your browser if the mime type has been set to recognize the XLS file extension. Thereafter, saving the file locally or manipulating the file is all done by way of the MS Excel application. If the mime type is not set to recognize the XLS file extension, you are prompted with a Save As Dialog and you must specify a local destination to save the XLS file for future viewing of the data with the MS Excel.</td>
</tr>
<tr>
<td>11</td>
<td>Save</td>
<td>Saves the file locally and launches the Interactive Reporting document (BQY) in the Interactive Reporting Web Client so that you can view and save the Interactive Reporting document (BQY) to your desktop for offline viewing. The Interactive Reporting document (BQY) can only be viewed by the full desktop or web client. If Interactive Reporting Web Client has not been installed, the browser is launched automatically.</td>
</tr>
</tbody>
</table>

**Tip:** If you want to save the Interactive Reporting document (BQY) to the Repository, use the File > Save or File > Save As command.
**Navigation Toolbar**

Section navigation controls on the toolbar are available to end users by using the Navigate Back, Navigate Forward, and Dashboard Home.

If the standard Interactive Reporting toolbar has been enabled, the Navigation toolbar is automatically disabled because it is a subset of the standard toolbar. However, the Navigation and Paging toolbars may be visible and enabled at the same time if the standard toolbar is disabled.

**Paging Toolbar**

Depending on how a report was designed, you may see an abbreviated version of the Interactive Reporting toolbar referred to as the Paging toolbar. This version of Interactive Reporting toolbar contains the paging controls: Page Left, Page Up, Page Down, and Page Right.

If the standard Interactive Reporting toolbar has been enabled, the Paging toolbar is automatically disabled because it is a subset of the standard toolbar. However, the Navigation and Paging toolbars may be visible and enabled at the same time if the standard toolbar is disabled.

**Shortcut Menus**

Use shortcut menus to perform operations on objects that you need to update and maintain. Shortcut menus are context-sensitive menus that pop up.

For Windows users, shortcut menus are enabled by selecting an item and pressing [Shift] + [F10] on the keyboard, or by right clicking the mouse. If the shortcut menu is enabled on the keyboard, the menu opens at the upper, leftmost of the HTML frame.

If the shortcut menu is enabled by right clicking the mouse, the shortcut menu opens next to the cursor pointer where you right-clicked the mouse button within the selected area or on the item. Submenus derived from a shortcut menu are also available which group multiple and related commands. Once you make a selection from a shortcut or submenu, the menu is closed.

The table below lists the keyboard shortcuts:

<table>
<thead>
<tr>
<th>Keyboard Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Arrow Keys</strong></td>
<td>Moves up, down, left and right on the shortcut menu.</td>
</tr>
<tr>
<td><strong>[Enter]</strong></td>
<td>Confirms and accepts an action associated with a shortcut menu item.</td>
</tr>
<tr>
<td><strong>[Esc]</strong></td>
<td>Closes a shortcut menu that is opening. You can also perform this action by selecting or deselecting an item or pressing the [Tab] key.</td>
</tr>
</tbody>
</table>
Alert Dialog

An Alert dialog shows informational messages explaining why the alert opens. You are required to acknowledge the alert before continuing since no other window can be active while it opens. To dismiss the alert, click OK.

Interacting with Interactive Reporting Documents

This section describes how to work with an Interactive Reporting document (BQY):

- Understanding Interactive Reporting Document Files
- Interactive Reporting Database Connection File (OCE) Selection For Interactive Reporting Document (BQYs)
- Accessing Interactive Reporting Document Files
- Working with Interactive Reporting Document File Sections
- Refreshing Interactive Reporting Document File Sections
- Dashboard Home
- Saving Interactive Reporting Document Files

Understanding Interactive Reporting Document Files

An Interactive Reporting document file (BQY) is centered on data from queries (either relational or OLAP) or from imported data. Any number of queries and Data Models can supply the data in an Interactive Reporting document file (BQY). An Interactive Reporting document file (BQY) can contain multiple queries with each query retrieving its data from a different database including: relational databases, imported data files, local files and OLAP servers. The Data Model aspects of the Interactive Reporting document file (BQY) are not visible to the end-user, but the ability to refresh data that come from these sources is. An end-user can duplicate an existing query or create a query based on an existing Data Model.

Once an Interactive Reporting document file (BQY) has been created, it is saved to Workspace Repository located on the server.

When the user selects and retrieves an Interactive Reporting document file (BQY) from the Section pane, the emphasis becomes one of viewing, refreshing, and analyzing of the Interactive Reporting document file (BQY) instead of the query, Data Model, data layout, and report building of the Interactive Reporting document file (BQY).

Creating An Interactive Reporting Document File (BQY) From Another Interactive Reporting Document File (BQY)

You can create an Interactive Reporting document file (BQY) based on an existing Interactive Reporting document file. In this case, the new Interactive Reporting document file inherits the
Interactive Reporting connection file (.oce) and sections associated with the original Interactive Reporting document file.

**Note:**
To create a Interactive Reporting document file that uses another Interactive Reporting database connection file, or a new Interactive Reporting document file not associated with an existing one, see [Interactive Reporting Database Connection File (OCE) Selection For Interactive Reporting Document (BQYs)](#).

To create an Interactive Reporting document file (BQY) based on an existing Interactive Reporting document file (BQY):

1. **Select File > New Document.**
   Select a Task opens.

2. **Select Create an Interactive Reporting Document.**
   Select Data Source opens.

3. **In the Data Source field,** enter the name and path of the data source (Interactive Reporting document file (BQY), or click **Browse** to locate the file.
   For more information about the Browse feature, see [Selecting an Interactive Reporting Data Source](#).

4. **In the Create As field,** select either **Web Client** or **HTML**.
   - **Web Client**—Creates the Interactive Reporting document file in Interactive Reporting Web Client using a connection file using a relational, CubeQuery, or OLAP Query data source.
   - **HTML**—Creates the Interactive Reporting document file in Workspace.

5. **Click Finish.**
A new Interactive Reporting document file (BQY) is created based on the selected Interactive Reporting document.

### Interactive Reporting Database Connection File (OCE) Selection For Interactive Reporting Document (BQYs)

An Interactive Reporting document files (BQY) can be created using an Interactive Reporting database connection file (.oce) selected by the user. See table below for Interactive Reporting connection file (.oce) eligibility:

<table>
<thead>
<tr>
<th>OCE Type</th>
<th>Interactive Reporting Web Client</th>
<th>Workspace</th>
</tr>
</thead>
<tbody>
<tr>
<td>Relational</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>CubeQuery</td>
<td>Yes</td>
<td>Yes</td>
</tr>
<tr>
<td>OLAPQuery</td>
<td>Yes</td>
<td>No</td>
</tr>
</tbody>
</table>
To create an Interactive Reporting document file (BQY) with an Interactive Reporting database connection file (.oce):

   Select a Task opens.

2. Select Create an Interactive Reporting Document and click Next.
   Select Data Source opens.

3. In the Data Source field, enter the name and path of the Interactive Reporting database connection file (.oce), or click Browse to locate the file.
   For more information about using the Browse feature, see Selecting an Interactive Reporting Data Source.

4. In the Create As field, select either Web Client or HTML.
   - Web Client—Creates the Interactive Reporting document in Interactive Reporting Web Client using a connection file using a relational, CubeQuery, or OLAP Query data source.
   - HTML—Creates the Interactive Reporting document file in Workspace. If you select an Interactive Reporting database connection field .oce from a relational, or OLAP Query data source, this option is not available.

5. Click Finish.
   A new Interactive Reporting document file (BQY) is created based on the selected Interactive Reporting database connection file.

Selecting an Interactive Reporting Data Source

Use the Select dialog box to choose an Interactive Reporting document file (BQY) or Interactive Reporting database connection file (.oce) on which to base a new Interactive Reporting document file (BQY).

To select an Interactive Reporting data source:

1. In the Look in field, select the Interactive Reporting document file (BQY) or Interactive Reporting database connection (.oce) from which to build a new Interactive Reporting document file (BQY).
   The folders and files shown on this dialog have been published to the Workspace Repository.
   The Name and Type fields display the file name and type (Interactive Reporting document file or Interactive Reporting database connection file).

2. To specify additional parameters, select Options.
   The Open As and Version fields are displayed.

3. To create the Interactive Reporting document file in Interactive Reporting Web Client, select Interactive Reporting Web Client. To create a new Interactive Reporting document file in Workspace, enter HTML.
   The option(s) available in the Open As field depend on the Interactive Reporting database connection file. Interactive Reporting document files (BQYs) can be created by selecting an Interactive Reporting database connection file (.oce). in Interactive Reporting Studio and...
Interactive Reporting Web Client. In Workspace, only an Interactive Reporting database connection file (.oce) for an Essbase query can be used to create a new Interactive Reporting document file. No Interactive Reporting database connection file (.oce) associated with a relational query can be used to create an Interactive Reporting document file in Workspace.

4 In the Version field, verify the version information.

5 Click OK.

**Accessing Interactive Reporting Document Files**

Use the following procedure to open and close an Interactive Reporting document file.

➤ To open an Interactive Reporting document file

1 Specify the URL of the Workspace in your web browser.

   The login dialog box opens.

2 Enter your user name and password and select Login.

3 Open an Interactive Reporting document file (BQY).

   An Interactive Reporting document can be opened:
   - from Explorer by navigating to an Interactive Reporting document file and double clicking it
   - by selecting the Interactive Reporting document file and clicking Open on the shortcut menu
   - selecting File > Open
   - selecting Favorites and choosing the Interactive Reporting document (if it has been added to Favorites)

   The Interactive Reporting document file opens in Workspace. If a Dashboard section has been included in the Interactive Reporting document file, it opens in creation date order. Typically, a Dashboard section is shown first. If no Dashboard section has been included, the Interactive Reporting document file opens on the last saved section. If the last saved section is a Query or Data Model, or fails for some other reason, the Interactive Reporting document file attempts to open the next section from the Sections pane, working from the top to the bottom of the Sections pane until a section can be displayed.

➤ To close an Interactive Reporting document file (BQY), select File > Close.

If you have modified an Interactive Reporting document file, you are prompted to save any changes.

**Saving Interactive Reporting Document Files**

To ensure that changes made to a Interactive Reporting document file are preserved after you have performed an analysis on it, use the Save features. The Save features in Workspace enable you to save an Interactive Reporting document file to the Workspace Repository (importing).
To save an Interactive Reporting document file locally (offline analysis), see Exporting an Interactive Reporting Document File in Native File Format.

**Saving an Interactive Reporting Document Files**

When you modify an Interactive Reporting document (BQY) or an Interactive Reporting document job, you can save the changed Interactive Reporting document to the Workspace Repository. The Workspace Repository is an efficient way to manage Interactive Reporting document file, and distribute Interactive Reporting document files over a wide network for end-user query and reporting.

Saving the Interactive Reporting document file to the Workspace Repository can be made either by saving it with changes to the original document (Save option), or by saving the Interactive Reporting document file, as a new document (Save As). If you do not have permission to overwrite an Interactive Reporting document file, use the Save As feature.

**Using the Save Command**

Use the Save command to save the changes to the Interactive Reporting document file that you have permission to write to.

➤ To save an Interactive Reporting document file to the Workspace Repository, select File > Save.

Optional: You can also click .

**Using the Save As Command**

Use the Save As command to save the changes you have made to the Interactive Reporting document file when you do not have permission to overwrite the Interactive Reporting document file, or you simply want to save and rename it with your changes.

➤ To save as to the Workspace Repository:

1. **Select File > Save As.**

   The Save As dialog box opens.

2. **Type the name of the Interactive Reporting document file in the Name field.**

3. **Type a description of the Interactive Reporting document file in the Description field.**

4. **Click .**
Working with Interactive Reporting Document File Sections

Interactive Reporting documents are files created and used to retrieve information from a database, analyze the information, and build reports. Since Interactive Reporting document files are integrated query, analysis, and reporting tools, these documents have multiple sections, each of which governs one part of the query and reporting refresh. You create sections progressively as you query a database, retrieve results, and then generate reports.

Interactive Reporting document files are divided into multiple sections, each of which governs one step of the reporting procedure. Interactive Reporting document file sections are created progressively when a database is queried, results are retrieved, and reports are generated.

Each section occupies an independent window and performs distinct operations. You can move back and forth between sections at any time to rebuild your query or alter your result data. You can also position sections side-by-side in a Dashboard section.

The end-user does not need to have a strong technical understanding of databases. Data Model sections are not available, and these sections are not visible in the Sections pane. Each section occupies an independent window in the browser and shows discrete views of data. For example, the Pivot section resembles a spreadsheet or crosstab report that lets you perform drill down analysis of different data relationships. The Chart section graphically depicts summaries, trends, and relationships in your data.

When an Interactive Reporting document file is opened, the default home page is the Dashboard section. If the Dashboard Home section cannot be displayed, then the Interactive Reporting document file opens on the last saved section. If the last saved section is a Query or Data Model (which are not listed in the Section Navigation drop-down menu), or fails for some other reason, then the Interactive Reporting document file attempts to open the next section from the Sections pane, working from the top to the bottom of the Sections pane until a section can be displayed.

For more information on using Interactive Reporting document file sections, see:

- Sections Pane
- Selecting Interactive Reporting Document File Sections
- Adding Sections
- Moving Between Sections
- Duplicating Sections
- Renaming Sections
- Deleting Sections
- Refreshing Interactive Reporting Document File Sections
- Printing Sections
- Dashboard Home

Sections Pane

The Sections pane shows the sections available in the current Interactive Reporting document file:
Dashboard—Upon opening an Interactive Reporting document file, a customized Dashboard section can appear as the Interactive Reporting document file front-end. Each button selection, item selection, or navigation sequence can invoke a script. Behind the scenes, Interactive Reporting refreshes the Dashboard script commands that can perform actions such as retrieve data, populate controls, hide objects, navigate to different sections, and specify report parameters.

Report—Displays high-quality and professionally designed reports. These reports can span anywhere from a complex critical operational report to a results set, a Chart, and a Pivot table. Use the reports to help you evaluate your business, expand communications, and assist in the decision-making process.

Query—Foundation of the Interactive Reporting document, the Query section enables you to connect to a relational database and download a prebuilt query or data model.

Results—Retrieves data to your document and displays it in the Results sections as columns in a table.

Pivot—Interactive table that quickly summarizes, or cross-tabulates, large amounts of data. You can rotate its rows and columns to see different summaries of the source data, or display the details for areas of interest.

Chart—Fully interactive, two- or three-dimensional view of your data that provides powerful ways to visually analyze your data.

Table—Single-dimension report that displays your data in columns. Tables are often used as building blocks in other sections.

OLAPQuery—Query section specifically designed for connecting to multidimensional databases.

CubeQuery—Query section exclusively designed for connecting to and querying Essbase 9.x or greater database.

By default, an Interactive Reporting document file has at least one Query section and one Results section. Each section occupies an independent window and performs distinct operations. You can move back and forth between sections at any time to rebuild your query or alter your result data.

Selecting Interactive Reporting Document File Sections

Sections associated with the Interactive Reporting document file are shown in the Sections pane.

➤ To select a section, click the desired section from the Sections pane.

➤ To scroll up and down through a section, use the scroll bar on the right side of the browser.

Adding Sections

A new section is added based on an existing query and results set.
To insert a new section in an Interactive Reporting document file, select **Actions > Insert > New Section**.

For example, to insert a new Chart, select **Actions > Insert > Chart**.

Interactive Reporting inserts the new section and adds a new section label to the Sections pane. The section label is based on the type of section added. A sequence number is added to the section label if a section with the same name already exists.

**Moving Between Sections**

Although each section occupies an independent window and performs distinct operations, you can move back and forth between sections at any time to rebuild your query or alter your results data. You can also position sections side-by-side in multiple windows.

You can easily navigate between sections to work on queries, results, and reports.

To move between sections, select the desired section from the Sections pane. If necessary, use the up and down scrollbar to vertically through the Sections pane.

**Duplicating Sections**

A section that has been duplicated retains all of the content and formatting of the original section. In addition a new section is added to the Sections pane. The new section label is based on the original section label, but a sequence number is appended to the label. For example, if you duplicate a section named SalesChart three times, the Sections pane shows: SalesChart, SalesChart2, SalesChart3, and SalesChart4.

To duplicate a section, select the section to duplicate in the Sections pane and select **Duplicate** on the shortcut menu.

You can also duplicate a section by selecting a section from the Sections pane and choosing **Edit > Section > Duplicate**.

**Renaming Sections**

The first section that you create is given the default section name, for example, Query or Results. When you insert new sections of the same type as those that already exist, they are numbered sequentially, for example, Query2, Results2, and so on. To assign sections different or unique names based on your application, use the Rename command.

To rename a section:

1. In the Sections pane, select the section name to rename.
2. Select **Rename** on the shortcut menu.

You can also select the section to be renamed and choose **Edit > Section > Rename**.
The Input Section Name dialog box opens.

3 Type the new name for the section and click OK.

Deleting Sections

You can delete a section, but do so with care. Some sections are dependent on other sections. Deleting one section could also delete one or more sections that you did not want to delete. Note that you cannot restore a deleted section.

➤ To delete a section:

1 In the Sections pane, select the section to be deleted.

2 Select Delete on the shortcut menu.

You can also select the section and choose Edit > Section > Delete.

The Confirm Deletion dialog box opens.

3 Click OK.

Dashboard Home

Upon opening a document, a customized Dashboard section can be displayed as the Interactive Reporting document file front-end. Each button selection, item selection, or navigation sequence can invoke a script. Behind the scenes, Interactive Reporting refreshes the Dashboard script commands that can perform actions such as retrieve data, populate controls, hide objects, navigate to different sections, and specify report parameters.

➤ To display Dashboard Home, click 🌐

Refreshing Interactive Reporting Document File Sections

You refresh a section to retrieve the most current data set from the database to Interactive Reporting document file. The Refresh command can be used in any of the query reporting sections. Once the data set has been refreshed in one section, all sections attached to the Interactive Reporting document file are refreshed as well.

By default, the Refresh Current command (refreshes the current object) in all sections except Dashboard and the Report section. In some cases more than one query may be refreshed, if for example, a report references results sets from multiple queries.

In the Dashboard and Report sections, the Refresh All command to refresh all queries in the Interactive Reporting document file is used. Although queries are not visible in to the end-user, they are executed in the order in which they display in the section catalog in the full client version. For example, in an Interactive Reporting document file with three queries, Query1, Query2, and Query3, the queries are executed in that order when the Refresh All command is selected.
If a variable filter has been set for the query by the designer of the <product Interactive Reporting document file, the filter selections must be resolved before the query is refreshed. At that time the user is prompted to select or enter filter values and complete the constraint.

➤ To refresh a section, click 🔄.

### Printing Sections

When you print a section, it is printed to a PDF file and launched inside your browser if the PDF MIME type is set in your browser. The PDF file can be viewed online, or printed if you need a hard copy of a report.

The PDF format is created by Adobe and can be viewed outside of your browser if you have Adobe Acrobat Reader installed. Adobe Acrobat Reader can be downloaded from Adobe’s website at http://www.adobe.com/products/acrobat/readstep.html. If the PDF MIME type is not set in the browser, the browser “Save As” dialog box is invoked.

**Note:**

A Query section cannot be printed.

➤ To export an Interactive Reporting document file to PDF, select File > Print via PDF.

**Optional:** You can also print a section by clicking 🔄.

**Tip:**

Printing a section and Exporting a Section as a PDF are equivalent features.

### Exporting Data

Interactive Reporting document files can be exported in several formats, including:

- Exporting a Section as a PDF
- Exporting a Section to MS Excel (.XLS)
- Exporting an Interactive Reporting Document File in Native File Format

### Exporting a Section as a PDF

Exporting a section to Portable Document Format (.PDF) allows you to preserve the layout and format of the original section and transfer it across multiple platforms (such as Windows, UNIX and the Macintosh). It also enables you to save, print and distribute the file easily and effectively.
To display and print a PDF file you must have Adobe® Acrobat® Reader™ installed. Acrobat Reader is a self-contained application that can behave as an Internet Browser plug-in or as a stand-alone application.

Acrobat Reader enables you to view, print and share a PDF file, but does not enable you to create or modify it. The Acrobat Reader is free and can be downloaded from Adobe’s web site.

When the Acrobat Reader has been installed, you might have to configure your browser to use it. For example you may need to associate Acrobat Reader as the application to read PDF files, or have the PDF display in a separate window instead of the same window. You open a PDF file by double clicking the PDF in the Explore module.

To save a PDF to your desktop for offline viewing, click the Acrobat Reader Save as Copy icon on the Acrobat Reader toolbar. You are prompted to specify the directory in which to save the file.

To print a PDF, click the Acrobat Reader Print icon. You are prompted to specify print parameters and to print the report.

If the Acrobat Reader has not been installed, the File download dialog opens. You can save the file to disk and open it from a location that you specify.

To export an Interactive Reporting document file to PDF, click the .

Optional: You can also print an Interactive Reporting document file to PDF by selecting File > Print via PDF.

Exporting a Section to MS Excel (.XLS)

You can export a section to Microsoft Excel and launch it inside your browser if the mime type has been set to recognize the XLS file extension. From this point, you can save the file locally and work with the data directly in the Microsoft Excel application. If the mime type is not set to recognize the XLS file extension, you are prompted with a Save As Dialog and must specify a local destination to save the XLS file for future viewing of the data with the Microsoft Excel.

To export an Interactive Reporting document file to Excel (XLS):

1 Click Export to XLS.
   If the mime type has been set to recognize the section, it is launched automatically in Microsoft Excel.
   If the XLS file extension in not recognized, the Save As dialog box opens. Complete Step 2.
2 If desired, enter a new name for the section in the File Name field.
3 Select Microsoft Excel Workbook (.XLS) in the Save as Type field.
4 Select Save.
Exporting an Interactive Reporting Document File in Native File Format

When an Interactive Reporting document file is exported in native file format, the Workspace checks if the Interactive Reporting Web Client has been installed and if so, launches the Interactive Reporting document file in a browser. The Interactive Reporting Web Client is a special application file placed in a web browser’s plug-in directory. Plug-ins add seamless functionality to a web browser, enabling the browser to open a plug-in’s particular file type as if it were an HTML file.

Any changes made to the Interactive Reporting document file are not replicated to the original Interactive Reporting document file selected from the document list in the Workspace Repository (which resides on the server and can only be changed by importing the Interactive Reporting document file again).

➤ To export a file in native file format, select File > Export > Native File Format.

If the Interactive Reporting Web Client has been installed, make any desired changes and save the document to the Workspace Repository. If you do not have permission to overwrite the Interactive Reporting document file, use the Save To Repository As command to rename the Interactive Reporting document file and save it to the repository.

If the Oracle’s Hyperion® Interactive Reporting Web Client has not been installed, the File Download dialog box opens. You can either open the Interactive Reporting document file from its current location, or you can export the file to disk and open it from an alternate location.

Query Section

The Query section is the foundation of any Interactive Reporting document file. An Interactive Reporting document file can contain multiple Query sections that can access a wide range of data sources (relational databases, OLAP servers, imported data sets, and local joins). Each Query section has its own Results section and can be associated with the same database or different databases (that is, the connection file or data model used is defined independently in each query).

This section includes the following topics:

- Interactive Reporting Database Connection Files (OCEs)
- Data Model
- Topics and Topic Items
- Query Restrictions
- Working with Queries
- Working with Items on the Request Pane
- Adding a Computed Item in Query
- Computed Items and Data Functions
- Data Functions
Interactive Reporting Database Connection Files (OCEs)

Whenever you use Interactive Reporting to query a relational database and retrieve information, the Interactive Reporting database connection file and data model are used to interact transparently with the database. The Interactive Reporting database connection file and data models are not visible to the end user in the Workspace.

The Interactive Reporting connection file encapsulates and stores connection information used to connect Hyperion applications to a database. Interactive Reporting database connection files specify the database API (ODBC, SQL*Net, etc.), database software, the network address of the database server, and your database user name. An end-user can specify the Interactive Reporting database connection file and database password and logon. It is required for an Interactive Reporting document file (BQY) to reference live information from the database.

Selecting an Interactive Reporting Database Connection File (.OCE)

➤ To select an existing Interactive Reporting database connection file (.oce)

1 Navigate to the folder in which to place the file.

2 Select File > Import > File.

   The first Import dialog box opens.

3 Click Browse, navigate to the folder where the desired Interactive Reporting connection file is located, select the file and click Open.

   The name of the selected Interactive Reporting connection file populates the File field on the Import dialog box.

4 Click Next.

   The second Import dialog box opens.

5 Specify any user name, password, and metadata information and click Finish.

   For more information on these settings, see “Setting Processing and Metadata Options.”

Data Model

You use a data model to interact with a database to create queries that specify which data to fetch from the database.

Data models make the database more accessible because they display database tables graphically as topics. They also:
Substitute descriptive names for arcane database table and column names. Create custom views of the data.

Add computed fields for performing calculations on the retrieved data.

Data Models are not visible in Workspace. If a master copy of a data model has been associated with a query, you can link a query to it. See Inserting a New Query.

**Topics and Topic Items**

Topics are a visual representation of tables in a database. They are logical groupings of related information about a particular facet of your business, such as Customer or Sales. A list of topics is shown in the Catalog list.

A topic item is an individual item in a topic or metatopic.

You build queries by adding topics from the Catalog list to the Request pane. You can also drag and drop any topic item to the Request pane. When you refresh a query, data for all the topic items present on the Request pane are returned.

**Query Restrictions**

These Query features are either unavailable or restricted in scope in Workspace:

- The Query Log and Custom SQL options are not available.
- A subquery is indented in the Section pane, but it is displayed as a regular query in Workspace. A subquery cannot be added in Workspace.
- If an Interactive Reporting document file contains a union query, the first query is displayed. The Request and Filter panes in the Data Layout for the union query are read-only. In addition, there is no Union Controller line. A new Union Query section cannot be created in Workspace.
- Local Results can be displayed, but a new local result table cannot be created in Workspace.
- Derived queries can be displayed, but a new derivable query cannot be created in Workspace.

**Inserting a New Query**

Use the Insert New Query dialog box to select the master data model for a relational query. Additionally if the Interactive Reporting document file (BQY) contains a query associated with an Essbase data source, you can select the Interactive Reporting database connection file (.oce).

**Note:**

If the Interactive Reporting document file (BQY) contains only a relational query and no master data model, the Insert New Query dialog box is not available. In the case where a Interactive Reporting document file (BQY) contains a relational query linked to a master data model, and an Interactive Reporting database connection file (oce) associated with a CubeQuery, all options
on the Insert New Query dialog box are available. Note that master data models are not available for a multidimensional Interactive Reporting database connection file (.oce).

➤ To insert a new query with a master data model:

1 Select Actions > Insert > Query.

The Insert New Query dialog box is displayed.

2 Check Master Datamodel and select the master data model to link to the query.

The master data model is a prebuilt, custom view of a database. The benefit of data models is that any changes to the master data model gets propagated to all dependent queries that are based on the master data model.

3 Click OK.

➤ To select the Interactive Reporting database connection file (.oce) associated with Essbase:

1 Check Existing Essbase Connection and select the database connection file (.oce).

2 Click OK.

Working with Queries

All Query sections in the Interactive Reporting document file are displayed in the Section pane. For each Query section, you can build a query by adding topics to the Request pane. You can also apply filters to the data, or specify columns by which to sort the data that is returned from the database.

Building Queries

You build queries by selecting the data you want to retrieve from a visual representation of the database. Once you have selected the items to include in the query and refresh it, a results set is generated.

Workspace offers three query methods for building queries:

- Duplicate and modify an existing Query section, which has been provided to you in the Section pane
- Link to a predefined data model, known as a Master Data Model (if the appropriate adaptive states have been granted)
- Select an Interactive Reporting database connection file (.oce) used to query an Essbase database

➤ To build a query by linking to a Master Data Model:

1 Select Actions > Insert > Query.

The Insert Query dialog box is displayed.
2 Select a master data model and click OK.
   The Request, Filter and Sort panes are displayed.

3 In the Catalog list, expand the Tables by clicking +.
   A list of topics is displayed.

4 Expand a topic to view topic items by clicking +.

5 Drag a topic item to the Request pane.
   Optional: You can also select the topic item in the Catalog list and click Add to Request on the shortcut menu.

   Tip:
   You can also select a topic item and select Add Selected Items in the Catalog list or select Actions > Add to Request.

   Optional: To add an entire a topic to the Request pane, select the topic and drag it to the Request pane.

6 To apply a sort, drag a topic item from the Request pane to the Sort pane.
   For more information, see Applying Query Sorts.

7 To apply a filter (limit), drag a topic item to the Filters pane.
   For more information, see Applying A Query Filter.

8 Click .
   If you add more items than the Request pane can display, resize the browser.

➤ To duplicate a Query section, select the query to duplicate in the Sections list, and choose Duplicate on the shortcut menu.
   Workspace duplicates the section and adds a new section label to the Sections pane. The new section label is based on the original section label, but a sequence number is appended to the label. For example, if you duplicate a section named SalesChart three times, the Sections pane shows: SalesChart, SalesChart2, SalesChart3, and SalesChart4.

**Working with Items on the Request Pane**

As you build your query, you can add and remove item to and from the Request pane. This allows you to change the way in which the query refreshes and displays.

- Adding Request Items
- Removing Request Items
Adding Request Items

Queries are built by adding topic items from the Catalog list to the Request pane.

➤ To add a topic item to the Request pane, select the topic item in the Catalog list and choose Add to Request on the shortcut menu.

Removing Request Items

You can remove items in the Request pane to exclude the data from your query or results set.

➤ To remove an item from the Request pane, choose the desired item and select Delete on the shortcut menu.

Dependent sections that use the item are not affected by the removal of an item until the query is refreshed.

Note:

Remove items with caution as a computed item or report may draw data from the item that you delete.

Picture (BLOB Image) Support

Pictures can be queried from a relational database if they are image data collected as a BLOB data type and stored as a binary unit in the database management system with ODBC connections. BLOB image files available to include: .JPEG, .BMP, .GIF, and .PNG image formats. Pictures can be dragged and dropped from a query table to the request line, displayed as strings in columns in the Results and Table sections, or shown graphically in the bands of the Report section. Dashboard developers can select images from results sets, not just static images from the file system.

The following restrictions apply to BLOB images in Interactive Reporting:

● The ODBC connection must use a server-defined join
● It is not possible to determine the data type of an image in advance

See also:

● “Adding Pictures in Query” on page 217
● “Working with Pictures in Results and Tables” on page 218
● “Working with Pictures in Reports” on page 218

Adding Pictures in Query

In the Query section, once BLOB images are retrieved as pictures, they are treated like any other table topic item. They can be dragged and dropped from the table directly to the request line. Only pictures in tables that have a primary key defined are included in a query. Pictures cannot
be sorted in the Query section. If you add a non-BLOB image to the request line, a broken link to the image is displayed in the report section.

**Working with Pictures in Results and Tables**

A column is displayed in the Results and Table sections for every picture with a BLOB data type on the request line. Descriptive text is displayed instead of the image in each cell in the format `<Picture:unique id>`. The unique id is tooltip text if any has been specified, otherwise, the unique id is the primary key value.

**Adding Pictures in Computed Items**

A picture function is available in Computed Items so that you can associate an image with a computed column. In the Results and Table section, the picture is shown as descriptive text instead of the image in each cell in the format `<Picture:unique id>`. The unique id is tooltip text if any has been specified, otherwise the unique id is the Resource name. In the Reports section, the computed item containing the picture can be shown graphically, For example you could use an “if else” statement to show an image if a certain set of conditions are met, and another criteria if the condition is not met:

```java
:if (Amount_Sales >= 10000) (Picture ("C:\graphics\smile.gif" ))
else{Picture("C:\graphics\crying.gif" )}
```

**Working with Pictures in Reports**

The Report section can include pictures obtained from the database (BLOB data types) by using an embedded object (Results and Tables) or it can use static images from the Resource Manager. Pictures can be dragged from the Catalog and dropped into the report layout components: report table report body report group header report page header of footer. You cannot drag a picture into a Table Facts column. Once a picture has been added to the report, all images are sized to fit the bounding rectangle defined in the report, and pictures can be resized as needed. Pictures are sorted by the their underlying textual unique id (i.e. the text displayed in a table/result section), which is particularly useful when they are added to the report group headers (via outliner).

**Adding a Computed Item in Query**

In the Query section, a computed item is a set of instructions to the database server. Workspace uses the computing power of the database server to perform calculations as it retrieves data from the database.

For this reason, the Query section allows you to use computed items in a way that is not possible in the other sections. Instead of creating a new data item, the new values simply replace the original values in the data item as they are retrieved from the database.

Additionally, you can compute items using any topic item in the data model and any scalar functions provided by your RDBMS.
To create a computed item in the Query section:

1. Select an item in the Request pane and choose Actions > Add Computed Item.
   
   The Computed Item dialog box is displayed.
   
   Optional: You can also select a request item and choose Add Computed Item on the shortcut menu.

2. Enter a name for the computed item in the Name field.
   
   The default name is Computed, which is numbered sequentially if there is more than one computed item. If you assign a name to a computed item that is identical to an existing scalar function name, Workspace numbers the name starting with the number 2.

3. Select the data type of the computed item to build from the Data Type list box.
   
   See also “Adjusting Data Types” on page 219.

4. Enter the definition of the computed item in the Definition text box.
   
   - See “ Operators” on page 220.
   - Click Reference to display the Reference dialog box, and select items to place in the equation.
     See also “Reference” on page 224.
     
     You can also type any portion of the equation or the entire equation directly into the Definition text box using JavaScript. The names are case sensitive, and you must replace spaces in item names with underscores (‘_’).

5. When the equation is complete, click OK.
   
   In the Query section, the computed item is displayed on the Request pane with its new name. When the query is refreshed, the computed item is listed in the Results Data Layout pane, and it is displayed as a column in the results set.

Adjusting Data Types

Since computed items are new data items, confirm or change the data type of the item to preserve the precision of a mixed-data type computations, or to change the way a data item is handled (for example, interpreting number as strings). This ensures the correct handling of data in server computations.

Attention to data types is most important when computing items in the Query section. Here the computation is performed on the database server, and the computed item may be handled with an unanticipated data type.

Local calculations (Results or Pivot) are handled internally, and adjustment between 16- and 32-bit integers can be handled safely using the automatic or number data type specification.

Since computed items are new data items, confirm or change the data type of the item to preserve the precision of a mixed-data type computations, or to change the way a data item is handled (for example, interpreting number as strings). This ensures the correct handling of data in server computations.
Local calculations (Results or Pivot) are handled internally, and adjustment between 16- and 32-bit integers can be handled safely using the automatic or number data type specification.

### Table 50  Data Type Specifications

<table>
<thead>
<tr>
<th>Data type</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatic</td>
<td>A data type is determined automatically given the data type of the reference items and the computations performed</td>
</tr>
<tr>
<td>BLOB</td>
<td>Binary large object which is truncated at 64,000 bytes. Blob data types can include image formats such as: jpeg, bmp, gif, and png.</td>
</tr>
<tr>
<td>Byte</td>
<td>Variable data type of length determined by a single byte of computer storage. Bytes can store numeric values from 0 to 255, or a single text character</td>
</tr>
<tr>
<td>Date</td>
<td>Calendar date in server default format (typically mm/dd/yy)</td>
</tr>
<tr>
<td>Integer (16–bit)</td>
<td>Retains a 16-bit value (2 bytes). A 16-bit integer stores integer values from 0 to 16,777,216, and signed integers between +8,388,608 and -8,388,608</td>
</tr>
<tr>
<td>Integer (32–bit)</td>
<td>Retains a 32-bit value (4 bytes). A 32-bit integer has a range of 0 to 4,294,967,296 if unsigned. If signed, -2,147,483,648 to 2,147,483,647.</td>
</tr>
<tr>
<td>Long Text</td>
<td>Character data (long text) exceeding 255 bytes (use the string data type for text strings up to 255 characters). The maximum long text retrieved is 4000; characters anything greater than that is silently truncated</td>
</tr>
<tr>
<td>Packed Real</td>
<td>Real numbers packed for use with EDA middleware. The results in Interactive Reporting are the same as real numbers</td>
</tr>
<tr>
<td>Real</td>
<td>Decimal numbers up to 5 positions right of the decimal</td>
</tr>
<tr>
<td>String</td>
<td>Text strings to a maximum length of 256 characters</td>
</tr>
<tr>
<td>Time</td>
<td>Time in format set by user preference</td>
</tr>
<tr>
<td>TimeStamp</td>
<td>Date/time combination in format set by user preference</td>
</tr>
</tbody>
</table>

### Operators

You can add operators in the Computed Item dialog box to add arithmetic or logical operators to a computation in the Definition text box. Operators are added at the insertion point. You can use any of the following types of operators:

- **Arithmetic Operators**
- **Comparison Operators**
- **Statements**
- **Logical Operators**

The following guidelines are applicable when using operators:

- Type the word null (no quotes) into the Expression text box to represent null values.
- Enclose all text string constant values and date constant values entered in expressions in single quotes. (Numbers can be entered without quotes.)
- To join items with a space or other character, reference or type items and strings into the Expression text box and join them with the + operator (for example, City + ‘,’ + State). To join without additional characters, use the Concat function.
- In division operations, the divisor may not be null or equal to zero. If a data item serves as the divisor in an expression (for example, 5000/Units_Sold) and includes null or zero values, first create a computed item using if/else logic to remove null and zero values, and then compute the item containing the division operation.
- Two date items can be subtracted, but not added. The Add Month function adds an integer value to a date.
- You cannot nest functions inside the Sum, Cume, Chr, and Breaksum functions.

**Arithmetic Operators**

Arithmetic operators take numerical values (either logical or variables) as their operands and return a single numerical value.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Name</th>
<th>Used at the:</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Add</td>
<td>Server level and the local metatopic level for all sections</td>
</tr>
<tr>
<td>-</td>
<td>Subtract</td>
<td>Server level and the local metatopic level for all sections</td>
</tr>
<tr>
<td>*</td>
<td>Multiply</td>
<td>Server level and the local metatopic level for all sections</td>
</tr>
<tr>
<td>/</td>
<td>Divide</td>
<td>Server level and the local metatopic level for all sections</td>
</tr>
<tr>
<td>(</td>
<td>Begin suboperations</td>
<td>Server level and the local metatopic level for all sections</td>
</tr>
<tr>
<td>)</td>
<td>End suboperations</td>
<td>Server level and the local metatopic level for all sections</td>
</tr>
<tr>
<td>++</td>
<td>Increment</td>
<td>Server level and the local metatopic level for all sections except the Query section</td>
</tr>
<tr>
<td>--</td>
<td>Decrement</td>
<td>Server level and the local metatopic level for all sections except the Query section</td>
</tr>
<tr>
<td>Mod (%)</td>
<td>Modulus</td>
<td>Local metatopic level only</td>
</tr>
</tbody>
</table>

The modulus operator returns the remainder of dividing var1 by var2.
For example, 5% 4 returns 1.
Tip:
If a computed item is displayed on a Request pane, and the definition of item uses subtraction, such as "Mytable.Column1-5", a SQL error can occur. The exact error depends on the database, but the most common error indicates an undefined name was used. Because databases allow hyphenated names, Interactive Reporting attempts to deal with such names intuitively. Thus, an item definition like "Mytable.Column1-5" is interpreted as a name. In order to ensure it is treated as subtraction, include a space on either side of the hyphen/subtraction operator. For example, entering the computed item definition as Mytable.Column1 - 5" ensures that the correct SQL is generated.

Comparison Operators
A comparison operator compares its operands and returns a logical value based on whether the comparison is true. The operands can be numerical or string values. When used on string values, the comparisons are based on the standard lexicographical ordering.

Note:
The comparison operators in the following table are only available at the local metatopic level. For the examples in the table var1 has been assigned the value 3, and var2 has been assigned the value 4.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Return “true” if the:</th>
</tr>
</thead>
<tbody>
<tr>
<td>==</td>
<td>Operands are equal</td>
</tr>
<tr>
<td></td>
<td>For example, 3 == var1</td>
</tr>
<tr>
<td>!=</td>
<td>Operands are not equal</td>
</tr>
<tr>
<td></td>
<td>For example, var1!= 4</td>
</tr>
<tr>
<td>&lt;</td>
<td>Left operand is less than the right operand</td>
</tr>
<tr>
<td></td>
<td>For example, var1 &lt; var2</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Left operand is less than or equal to the right operand</td>
</tr>
<tr>
<td></td>
<td>For example, var &lt;= var2, var2 &lt;= 5</td>
</tr>
<tr>
<td>&gt;</td>
<td>Left operand is greater than the right operand</td>
</tr>
<tr>
<td></td>
<td>For example, var2 &gt; var1</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Left operand is greater than or equal to the right operand</td>
</tr>
<tr>
<td></td>
<td>For example, var2 &gt;= var1, var1 &gt;= 3</td>
</tr>
</tbody>
</table>
**Statements**

Executes a set of statements if a specified condition is true. If the condition is false, another set of statements can be executed.

<table>
<thead>
<tr>
<th>Table 53</th>
<th>If...else statement</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Statement</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>If...else</td>
<td>if executes a set of statements if a specified condition is true. The specified condition may be another statement and can include other nested if statements. Braces, {}, must enclose multiple statements. If the condition is false, another set of statements can be executed if the optional else statement has been included in the script. A sample if ... else statement looks likes this:</td>
</tr>
<tr>
<td></td>
<td>if (condition) {</td>
</tr>
<tr>
<td></td>
<td>statements1</td>
</tr>
<tr>
<td></td>
<td>}</td>
</tr>
<tr>
<td></td>
<td>else {</td>
</tr>
<tr>
<td></td>
<td>statements2</td>
</tr>
<tr>
<td></td>
<td>}</td>
</tr>
</tbody>
</table>

**Logical Operators**

Logical operators take Boolean (logical) values as operands and return a Boolean value.

<table>
<thead>
<tr>
<th>Table 54</th>
<th>Logical Operators</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Operator</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>AND (&amp;&amp;)</td>
<td>Connects two conditional expressions and retrieves records only if each expression is true. Computed items are not retrieved if any condition belonging to a conditional expression is false. The AND logical operator is usually nested within another conditional expression, for example, expressions which use if and else statements. For example:</td>
</tr>
<tr>
<td></td>
<td>if ((OS == 'Windows') &amp;&amp; (Item type == 'Modem')) {'Windows'} else {'other'}</td>
</tr>
<tr>
<td>OR (</td>
<td></td>
</tr>
<tr>
<td></td>
<td>if ((State == 'Washington')</td>
</tr>
<tr>
<td>NOT (!)</td>
<td>Computes and shows items more accurately stated in a negative way. In effect, all records are retrieved except those that fulfill the conditional expression. You enter the conditional expression with the NOT (!) logical operator preceding the conditional expression. The conditional expression can be a simple value or nested within other conditional expressions, for example, expressions using AND and OR. A combined condition expression that uses NOT is true if the conditional expression following NOT is false. A combined conditional expression is false if the conditional expression following NOT is true.</td>
</tr>
</tbody>
</table>
### Reference

Use the Reference dialog box to select the topics and topic item from which to build the computed item definition.

The Reference dialog box is split between topics in the left pane and topic items in the right pane. The topics displayed in the left pane are derived from the topics in the Request pane. The items displayed in the right pane are the values which make up each topic. Before you can select a topic to use in a computed item expression, you must select it and a topic item.

### Computed Items and Data Functions

Computed items and data functions are fundamentally different, and the functions available in the Computed Item dialog box do not calculate data in the same way as data functions.

- Computed items calculate a fresh value for each original value, based on the computation (for example, Revenue calculated from Price and Units Sold). The new values are part of a new data item or replace the original values. Computed items never reduce the original number of records.

- Data functions, by contrast, summarize groups of database records and replace the original values with new summary data. Because data functions summarize values, the number of records are frequently reduced.

### Data Functions

Data functions compute aggregate values, including averages, maximums, counts and other statistics. These functions summarize groupings of data. You can use data functions to aggregate and compute data from the server before it reaches the Results section, or compute different statistics for aggregated Results totals and report items.

The effects of data functions are most dramatic in the Query section. For example, Dollars is an item of sales transaction records for your stores in London and Madrid. You can apply a data function to this item, consolidate the data, and calculate sum totals, average sale values, number counts of individual sales records, or minimum sale values with respect to each city, once the data is retrieved to Results.

To apply a data function, select the item or column, and choose Data Function on the shortcut menu.

Optional: You can also select the item or column and choose Actions > Data Function, and select the (function).
<table>
<thead>
<tr>
<th>Function</th>
<th>Returns</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Unaggregated values as stored in the database. This is the default in Query.</td>
<td>Query</td>
</tr>
<tr>
<td>Sum</td>
<td>Sum of underlying values. This is the default in Results and report sections.</td>
<td>All</td>
</tr>
<tr>
<td>Average</td>
<td>Average of underlying values</td>
<td>All</td>
</tr>
<tr>
<td>Non-Null Average</td>
<td>Average of underlying values; null values excluded</td>
<td>Pivot, Chart, Report</td>
</tr>
<tr>
<td>Minimum</td>
<td>Lowest of underlying values</td>
<td>All</td>
</tr>
<tr>
<td>Maximum</td>
<td>Highest of underlying values</td>
<td>All</td>
</tr>
<tr>
<td>Count</td>
<td>Number of underlying values</td>
<td>All</td>
</tr>
<tr>
<td>CountDistinct</td>
<td>Number of distinct values in a column. This function is not supported by all database servers.</td>
<td>Query</td>
</tr>
<tr>
<td>Null Count</td>
<td>Number of nulls among underlying values</td>
<td>Pivot, Chart, Report</td>
</tr>
<tr>
<td>Non-Null Count</td>
<td>Number of underlying values; null values excluded</td>
<td>Pivot, Chart, Report</td>
</tr>
<tr>
<td>Standard Deviation</td>
<td>Standard deviation of values. This function is not supported by all database servers.</td>
<td>Query</td>
</tr>
<tr>
<td>Variance</td>
<td>Variance of values. This function is available through Oracle servers only.</td>
<td>Query</td>
</tr>
<tr>
<td>Weight</td>
<td>Use for computing weighted items in Pivot reports.</td>
<td>Query</td>
</tr>
<tr>
<td>% of Column</td>
<td>Sum of all underlying values as a percentage of their respective surface column</td>
<td>Pivot</td>
</tr>
<tr>
<td>% of Row</td>
<td>Sum of underlying values as a percentage of their respective surface row</td>
<td>Pivot</td>
</tr>
<tr>
<td>% of Grand</td>
<td>Sum of underlying values as a percentage of all surface values in the report</td>
<td>Pivot, Chart</td>
</tr>
<tr>
<td>% of Category</td>
<td>Group total percentage of the selected value</td>
<td>Report</td>
</tr>
<tr>
<td>Increase</td>
<td>Calculates the increase between the previous two rows or columns</td>
<td>Pivot</td>
</tr>
<tr>
<td>%Increase</td>
<td>Calculates the percentage increase between the previous two rows or columns</td>
<td>Pivot</td>
</tr>
<tr>
<td>Title</td>
<td>Column names</td>
<td>Report</td>
</tr>
</tbody>
</table>

Null values are empty values for which no data has been specified; null values are not equal to zero.
Applying A Query Filter

When building a query, you usually do not want to see information associated with every product. Instead you want to see information that relates only to a specific product or product line. Similarly, you may not want to see this information for every year the product has been available, but only for recent periods.

When you set a filter in the Query section, data is returned from the database only if it meets the specified conditions. For example, suppose you only want to see your most important customers who spend more than $400,000 per year, or who buy gardening products in the Midwest. By applying a filter you are instructing the database to “give me only the data which satisfies the following conditions” (sales > $400,000; or, state is in Midwest Region and Product Line = Garden).

In another example, a filter placed on Item Type (which includes an “=” (equal) operator and value “Keyboard”) returns only records associated with keyboard sales. Records associated with all other products are excluded from the results set. The data set could be expanded to include modem sales records by adding the value “Modem” to the filter expression.

Similarly, the filter “> 5000” applied to the Amount Sold item filters out all sales transactions less than or equal to $5,000. Alternately, the expression “between 5000, 10000” exclude transactions above $10,000 and eliminates any below or equal to 5,000.

Another advantage of Query filters is that you can apply a filter to any Topic item, even if the item is not on the Request pane. For example, if you request State, Year, and Units Sold, you can filter any of these items.

You can also place a filter on the Operating System if it appears in one of the topics in the Contents pane. For example, if you filter the Operating System to the UNIX only, the server retrieves only sales information related to the UNIX operating system. You do not need to place the Operating System on the Request pane.

Note:
If a query contains an aggregate filter, it is added to the Data Layout. However, this aggregate filter line is read only and a new aggregate filter cannot be created.

➤ To set a query filter:

1 Select a topic item in the Catalog list and select Add to Filter on the shortcut menu.

Optional: You can also drag one or more topics from the Catalog list and drop them into the Filter pane.

The Filter dialog box is displayed.

2 Define a pool of the potential filter values by selecting one of the following options:

- “Show Values” on page 234 — Supplies database values associated with the item.
- “Custom Values” on page 235 — Supplies an empty text box for entering custom values.
- “Custom SQL” on page 236 — Supplies an empty text box for entering a Structured Query Language (SQL) clause to be included in the query statement.
3 If you are working with the Show Values or Custom Values options, select Include Null to include data where the data item has no value.

Retrieves records where the filtered item has no value; for example a field in which no data has been entered. A null value is not equal to zero.

If you are working with the Custom SQL option, skip the remaining steps, enter your Custom SQL and click Set.

4 Select the NOT check box to negate the operator it precedes.

If you select NOT, the results of the equation are reversed.

5 Select a comparison operator to use for filtering values.

For example, if you specify the > Greater Than and specify a value of 10,000, values greater than 10,000 are returned.

For a list of valid comparison operators, see “Comparison Operators” on page 222.

6 Select the values to apply as a filter.

7 Select Set.

To suspend a filter temporarily without deleting it, click Ignore.

Variable Filters

A variable filter is a preset filter that is associated with the Interactive Reporting document file by the designer and resolved only when the query is refreshed. At that time, you are prompted to select or enter filter values and complete the constraint. A variable filter prompt is displayed only if one has been set in the underlying Interactive Reporting document file.

Variable filters work particularly well with custom lists. If a custom list has been created, you can respond to the prompt by simply selecting a value from the custom list. For example, you may have an Interactive Reporting document file you use monthly to monitor inventory levels. Each time you use the Interactive Reporting document file, you run it separately for each product line you carry. You can accelerate the process by making the filter variable on the product line item, and create a custom values list. Each time you refresh the Interactive Reporting document file, you can select a new product line without redefining filters.

You can select from three types of filters from which to apply a variable constraint, including:

- “Show Values” on page 234 – Supplies database values associated with the item.
- “Custom Values” on page 235 – Supplies an empty text box for entering custom values.
- “Custom SQL” on page 236 – Supplies an empty text box for entering a Structured Query Language (SQL) clause to be included in the query statement.

If you do not need to select specific variable filters for the query, choose “Set” to accept the predefined filters and refresh the query. If you want to modify or add other values, complete steps 2 and 3 below.
To specify a variable filter.

1 Click **Refresh** on the Interactive Reporting toolbar.
   The Filter dialog box is displayed.

2 If you are working with the Show Values or Custom Values options, select **Include Nulls** to include data where the data item has no value.
   Retrieves records where the filtered item has no value; for example, a field in which no data has been entered. A null value is not equal to zero.

   If you are working with the Custom SQL option, skip the remaining steps, enter your Custom SQL and click **Set**.

3 **Select the NOT check box to negate the operator it precedes.**
   Selecting NOT reverses the results of the equation.

4 **Select a comparison operator to use for filtering value.**
   For example, if you specify the > Greater Than and then specify a value of 10,000, then values greater than 10,000 are returned.

   For a list of valid comparison operators, see “Comparison Operators” on page 222.

5 **Select the values to apply as a filter.**

6 **Select Set.**
   The filter is applied in the results set.

   To suspend a filter temporarily without deleting it, click **Ignore**.

   To see the result of setting the variable filter, select the Refresh command after the variable has been set.

---

**Applying Query Sorts**

Sorting simplifies the process of data analysis. After data is sorted, the answers to questions are often readily at your fingertips because sorting ranks data to reveal trends and margins. If you apply simple sort conditions in the Query section, the database server sorts the data while refreshing the query before it is retrieved to your document file.

Typically, you can place an ascending or descending order on a sort condition that you place on a column.

To apply a sort to the query, drag one or more items in the Request pane and drop them into the Sort pane.

Optional: A sort can also be applied by selecting an item and choosing **Actions > Add to Sort.**
When the query is refreshed, the request item is sorted in the results set.

To sort in ascending order:

1 Drag one or more items in the Request pane and drop them into the Sort Pane.
2 Select **Sort Ascending** on the shortcut menu.

➤ To sort in descending order:

1 Drag one or more items in the Request pane and drop them into the Sort pane.
2 Select **Sort Descending** on the shortcut menu.

➤ To delete a sort, select the sort value to remove from Sort pane and choose **Delete** on the shortcut menu.

Deleting a sort returns the data to its original display.

### Refreshing a Query

After you build your query and apply filters computations, sorts, and any other adjustments to further refine your request, refresh it to get the results of your query. Refreshing your query may take a few moments if your query is complex or if the data in linked report sections needs to be refreshed.

When you refresh your query, the data is retrieved to the Results section in tabular form. You can refresh your query at any time and in any section to refresh the data. You can also return to the Query section from any other section at any time to alter the query and refresh it.

➤ To refresh a query, click **Refresh**.

Optional: You can also select **View > Refresh**.

### Results and Tables

When you refresh a query or import data, the Interactive Reporting retrieves data to your browser and displays it in the Results section. Although the query may have accessed several different database tables, the results set is displayed as a single table. Each requested item is displayed as a column in the table and each database record is a row.

Use the Results section to:

- Verify that your query returned the correct information.
- Refine and extend the data set by applying filter conditions or create new computed or grouped items.
- Sort or use text and column formatting features to enhance the appearance of data results.
- Add summary totals or subtotals and compute them with data functions.
- Print or export the retrieved data to other applications.

All reports, including tables, pivots, charts, are based on the data that is retrieved to the Results section.
Interactive Reporting provides several ways for you to view the results of a database query for better analysis:

- Adding a Table
- Working with Columns and Rows
- Sorting Results/Table Items
- Number Formatting
- Applying a Results and Table Filter
- Results and Tables
- Show Values
- Results and Table Totals
- Adding Computed Items in Results and Tables
- Paging Through Results Data

**Adding a Table**

➤ To create a table based on data in the Results section:

1. **Select Action > Insert > Table.**
2. **Drag Results items from the Catalog list to the Table Data Layout.**
   The table columns are populated automatically.

**Working with Columns and Rows**

Columns and rows can formatted to your specific needs:

- Adding a Column
- Deleting a Column
- AutoSizing ColumnS
- Deleting a Row

**Adding a Column**

If you have removed a column from the results set, you can easily add it back. However, any data values derived from the re-added column are not automatically update an existing column either in the results/table section or another section, which draws from the results set.

➤ To add a column:

1. **Select any column.**
2. **Select Add Column on the shortcut menu.**
Deleting a Column

You may need to delete a column in order to view the data set in a new way or maybe you want to concentrate on selected columns of interest. This option is available for all columns. Note that column deletion should be approached with caution since other sections draw data values from the results set.

➤ To remove a column, choose the column and select **Delete Column** on the shortcut menu.

The column is deleted. If you need to add the column back to the Results section, select **Add Column** on the shortcut menu.

AutoSizing ColumnS

By default, Interactive Reporting truncates columns evenly and without regard to the length of data values. With the auto-size column width feature, you can automatically size any column to fit the text of the largest value in the column.

➤ To autosize a column:

1. Select a column.
2. Select **Auto-Size Column Width** on the shortcut menu.

Deleting a Row

You can delete a row if it is a grand total or break. Note that the grand total is shown in the last row on the last page of the table.

➤ To delete a row:

1. Select a row.
2. Select **Delete Row** on the shortcut menu.

Sorting Results/Table Items

Data in the Results section is sorted in the order returned by the database. You can change the order in which a column is sorted either in ascending or descending order.

➤ To sort a column:

1. Select the column you want to sort on.
   Selecting multiple columns invokes a “nested sort.”
2. Select **Sort** on the shortcut menu.
   The Sort submenu is displayed.
3. Select either the **Ascending** or **Descending** sort item.
To delete the current sort order:

1. Select any column in the Results or Table section.
2. Select Sort on the shortcut menu.
   The Sort submenu is displayed.
3. Select Delete All.

**Number Formatting**

You can change the way numbers, currency values, and dates are displayed throughout or create new custom formats.

To apply number formatting, select the format from the Format drop down list box.

<table>
<thead>
<tr>
<th>Table 56</th>
<th>Formatting Categories</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Option</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Category</td>
<td>Select a category for which you want to display number formats. When you select a category, the formats for that category are displayed in the Format field. To create a custom format, select Custom and enter the desired format in the Format field. Enter symbols, decimals, commas, and so on to indicate how to display the format. For example, enter 'MM/DD/YY' to display the date as '01/01/99', or enter $$#.###.00 to show two dollar signs before the number and a decimal to mark the thousands' place. When you create a custom format, it appears as a category on the machine on which it was created. If an item already has a custom format applied to it, the custom format is in read-only mode.</td>
</tr>
<tr>
<td>Format</td>
<td>Displays the format for the selected category. If you are creating a custom category, you can enter the desired format directly in the edit field.</td>
</tr>
</tbody>
</table>

The following table lists available numeric categories.

<table>
<thead>
<tr>
<th>Table 57</th>
<th>Numeric Categories</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Option</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Number</td>
<td>Sets the default format for real or integer values.</td>
</tr>
<tr>
<td>Currency</td>
<td>Applies currency formatting to the selected number object(s).</td>
</tr>
<tr>
<td>Percentage</td>
<td>Applied percentage formatting to the selected numeric object.</td>
</tr>
</tbody>
</table>

The following table lists the available formatting options and definitions along with examples for the above categories.

<table>
<thead>
<tr>
<th>Table 58</th>
<th>Formatting Options and Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Option</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>0</td>
<td>Integer placeholder or zero value. If a number has an integer value in this position relative to the decimal point, the inter is displayed. Otherwise a zero is displayed.</td>
</tr>
</tbody>
</table>
### Option Description

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>#</td>
<td>Integer placeholder. If a number has an integer value in this position relative to the decimal point, the integer is displayed. Otherwise, nothing is displayed.</td>
<td>Apply #,##0 to show 1,234.</td>
</tr>
<tr>
<td>()</td>
<td>Formats with parenthesis options display negative values in parentheses. Otherwise, negative values are displayed with a minus sign.</td>
<td>Apply (#,###0) to show (1,234).</td>
</tr>
<tr>
<td>;</td>
<td>A semicolon operates as a separator between two number formats. The semicolon separates a positive integer and a negative integer.</td>
<td>Apply #, ##0;(#,##0) to show 1, 234 or apply (1, 234) for a negative number.</td>
</tr>
<tr>
<td>$ %</td>
<td>Adds the respective character to numeric values in the same position relative to the decimal point.</td>
<td>Apply $#,%0.00 to show $1,234.56.</td>
</tr>
<tr>
<td>$ %</td>
<td>Adds the respective character to numeric values in the same position relative to the decimal point.</td>
<td>Apply 0% to show 3%.</td>
</tr>
<tr>
<td>m d yy</td>
<td>Displays month, day, and year in respective positions for date-coded information.</td>
<td>Apply mm/dd/yy to show 05/07/99</td>
</tr>
<tr>
<td>- /</td>
<td>Adds the respective character to date-coded values in the same position relative to variables.</td>
<td>Apply mm/dd/yy to show 06/23/99</td>
</tr>
</tbody>
</table>

### Applying a Results and Table Filter

Because local filters only hide data from the display, they are a good way to filter the data set to reflect temporary and hypothetical situations. You can always remove the filter to return data to the display and make it available for reporting.

Applying filters to your results/table sets allows you to narrow your request. That way you can work with relevant data, saving time and conserving database and server resources.

You can add, modify and remove filters to columns in the Tables/Results section. The column to which the filter is applied must exist in the table, and a filter cannot be placed on a hidden column.

See also:

- Show Values
- Custom Values
- Custom SQL
- Modifying Filters
- Deleting Filters

➤ To add a results/table filter.

1. Select a column on which to apply the filter.

2. Select Filter on the shortcut menu.

   The Filter submenu is displayed.

3. Select Apply/Modify on the Filter submenu.
The Filter dialog box is displayed.

4 Define a pool of the potential filter values by selecting one of the following options:
   ● “Show Values” on page 234 — Supplies database values associated with the item.
   ● “Custom Values” on page 235 — Supplies an empty text box for entering custom values.

5 If you are working with the Show Values or Custom Values options, select Include Nulls to include data where the data item has no value.
   Retrieves records where the filtered item has no value; for example, a field in which no data has been entered. A null value is not equal to zero.
   If you are working with the Custom SQL option, skip the remaining steps, enter your Custom SQL and click Set.

6 Select the NOT check box to negate the operator it precedes.
   Selecting NOT reverses the results of the equation.

7 Select a comparison operator to use for filtering values.
   For example, if you specify the > Greater Than and then specify a value of 10,000, then values greater than 10,000 are returned.
   For a list of valid comparison operators, see “Comparison Operators” on page 222.

8 Select the values to apply as a filter.

9 Select Set.
   The filter is applied in the results set.

To suspend a filter temporarily without deleting it, click Ignore.

Show Values

The Show Values feature provides a list of values derived from the content of the Results or Table section. Because Show Values retrieve every unique value available, it is best not to use this feature when the data item is large, consists mostly of unique values, or does not change frequently (for example, telephone numbers). In this situation, custom values are recommended when you want to avoid extra calls to the database.

The value list that initially displays was saved with the imported Interactive Reporting document file, and it is not the latest value list from the database.

To show the latest value list, select View > Refresh.

➤ To specify a database filter value:

1 Select the Show Values tab.

2 Select Include Nulls to allow nulls to pass the filter and display in the data set.

3 Expand the Operator drop down and select a comparison operator for the filter expression.
   Check Not to reverse an operator condition.
For example, if you specify the > Greater Than and then specify a value of 10,000, then values greater than 10,000 are returned. Values which pass the comparison test are included. Valid operators include:

Table 59  List of Comparison Operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Retrieves Records Where the Filtered Item:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equal (=)</td>
<td>Equals the specified value(s).</td>
</tr>
<tr>
<td>Not Equal (&lt;&gt; )</td>
<td>Does not equal the specified value(s).</td>
</tr>
<tr>
<td>Less Than (&lt;)</td>
<td>Less than the specified value(s).</td>
</tr>
<tr>
<td>Less or Equal (&lt;=)</td>
<td>Equal to or less than the specified value(s).</td>
</tr>
<tr>
<td>Greater Than (&gt;)</td>
<td>Is greater than the specified value(s).</td>
</tr>
<tr>
<td>Greater or Equal (&gt;=)</td>
<td>Is equal to or greater than the specified value(s)</td>
</tr>
<tr>
<td>Begins With</td>
<td>Begins with the specified value(s) up to and including the end value.</td>
</tr>
<tr>
<td>Contains</td>
<td>Contains the specified value(s) regardless of location.</td>
</tr>
<tr>
<td>Ends With</td>
<td>Ends with the specified value(s).</td>
</tr>
<tr>
<td>Like (with wildcards)</td>
<td>Retrieves records where a text string is displayed and reflects the placement of the specified value(s). For example, a Name Like %ZE_ retrieves records for all employees whose names have the letters Ze followed by a single character at the end</td>
</tr>
<tr>
<td>Is Null</td>
<td>Has no value; for example a field in which no data has been entered.</td>
</tr>
<tr>
<td>Between</td>
<td>Retrieves records where the value of the filtered item lies between (and does not equal) the specified values.</td>
</tr>
<tr>
<td>Not (with operator)</td>
<td>Negates the operator it precedes, reversing the results of the equation</td>
</tr>
</tbody>
</table>

4 Highlight the values to include as filters from the Values list.
To select an individual value, highlight it in the Values pane.
To select multiple and contiguous values in the Values pane, hold the [Shift] and scroll down to or up to the items.
To select multiple, but non-contiguous values in the Values pane, hold the [Ctrl] key and highlight the items.

5 Click Set.
To suspend a filter temporarily without deleting it, click Ignore.

Custom Values

A Custom Values list can be used to set a filter and are created by or supplied to you. One reason to use custom lists with a distributed Interactive Reporting document file is that many data items change very rarely. For example, a Gender item has three consistent values (male, female, and
unknown). A Product line item has many more items, but may only change every year or so. Under these circumstances, it makes sense for you to select from a custom values list.

The initial custom values shown in the values pane originate and are saved with the Interactive Reporting document file.

➤ To apply a custom value as a filter:

1. **Select Include Nulls to include data where the data item has no value.**
   Retrieves records where the filtered item has no value; for example a field in which no data has been entered. A null value is not equal to zero.

2. **Select a comparison operator to use for filtering value.**
   Select the **NOT** check box to negate the operator it precedes.

   For example, if you select the > Greater Than operator and specify a value of 10,000, values greater than 10,000 are returned.

   For a list of valid comparison operators, see “Comparison Operators” on page 222.

3. **In the Values field, enter the values to which you want to set as a filter.**

4. **To add the value, select +(the addition sign).**
   To remove a value from the Values panel, highlight the item in the Values pane and click the - (subtraction sign).

5. **Click Set.**
   To suspend a filter temporarily without deleting it, click Ignore.

### Custom SQL

If you are familiar SQL, select the Custom SQL feature and type a SQL where clause to be included in the query statement.

➤ To add a custom SQL statement:

1. **Select the Custom SQL tab.**

2. **Type your SQL where clause containing the expression to use for the filter in the Values pane.**

3. **Click Set.**
   To suspend a filter temporarily without deleting it, click Ignore.

### Modifying Filters

Once a filter exists for data in your query or results, you can later add or modify filter conditions.

➤ To modify a filter:

1. **Select the column to which the filter has been applied.**

2. **Select Filter on the shortcut menu.**
The Filter submenu is displayed.

3. Select Apply/Modify on the Filter submenu.
   The Filter window is displayed.

4. Select the filter value and click Set.
   The following table provides a quick reference to the Modify Filter option:

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set</td>
<td>Applies the filter value.</td>
</tr>
<tr>
<td>Ignore Filter</td>
<td>Ignores a filter without deleting it.</td>
</tr>
<tr>
<td>Cancel</td>
<td>Cancels any filter applied in the current sessions.</td>
</tr>
</tbody>
</table>

**Deleting Filters**

Deleting filters adds the original values that were filtered back into the data set.

To delete a filter, select the columns that has the filter value to be deleted and select Actions > Filter > Delete on the shortcut menu.

**Results and Table Totals**

Totals and subtotals can help to consolidate a large results set. If you need individual data records and plan to print the Results and Table section as a quick report, add totals and subtotals to break your report into manageable sections.

See also:

- Calculating a Grand Total for a Column
- Calculating a Break Total for a Column
Calculating a Grand Total for a Column

You can calculate a grand total for any numeric data column and specify the original total value with a new type of function. For example, by default the totals for a column are sums of the values in those columns. But you can change the totals to averages instead of sums. These Results/Table section functions include:

<table>
<thead>
<tr>
<th>Data Function</th>
<th>Returns the:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>Sum of all underlying values.</td>
</tr>
<tr>
<td>Average</td>
<td>Average of all underlying values.</td>
</tr>
<tr>
<td>Maximum</td>
<td>Highest of underlying values.</td>
</tr>
<tr>
<td>Minimum</td>
<td>Lowest of underlying values</td>
</tr>
<tr>
<td>Count</td>
<td>Number of underlying values.</td>
</tr>
</tbody>
</table>

To apply a grand total to a column:

1. **Select the column and choose Grand Total on the shortcut menu.**
   A submenu showing all available total functions is displayed.

2. **Select a total function.**
   The grand total is displayed in a new row at the bottom of the last page in the selected column.

To remove all grand totals:

1. **Select a column to which a grand total was applied and choose Grand Total on the shortcut menu.**
   A submenu showing all available total functions is displayed.

2. **Select Delete All.**

To remove a selected grand total:

1. **Select the row to which a grand total was applied and choose Grand Total on the shortcut menu.**
   A submenu showing all available total functions is displayed.

2. **Select Delete.**

Calculating a Break Total for a Column

You can add subtotals to the same column by choosing another column of non-numeric data to serve as a “break column.” The break column is used as a reference point to determine where to break the data in the target column. The data in the subtotal column is subtotaled for each distinct range of identical values in the break column.

Once a break total is placed on one column, the break total is applied to all numeric columns. Like the total functions you can use when adding a grand total, a break total can also consist of different functions. These functions include:
<table>
<thead>
<tr>
<th>Data Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>Sum of all underlying values</td>
</tr>
<tr>
<td>Average</td>
<td>Average of all underlying values</td>
</tr>
<tr>
<td>Maximum</td>
<td>Highest of underlying values</td>
</tr>
<tr>
<td>Minimum</td>
<td>Lowest of underlying values</td>
</tr>
<tr>
<td>Count</td>
<td>Number of underlying values</td>
</tr>
</tbody>
</table>

To apply a break total:

1. **Select the column and choose Break Total on the shortcut menu.**
   A submenu showing all available break total functions is displayed.

2. **Select a total function.**
   The default total function is “Sum”.
   Break totals are displayed in the target column along with the break total function name.

To delete all break totals:

1. **Select the column to which the break total was applied.**
2. **Select Break Total on the shortcut menu.**
3. **Select Delete All.**

To remove a selected break total:

1. **Select the row to which a break total was applied and choose Break Total on the shortcut menu.**
   A submenu showing all available total functions is displayed.
2. **Select Delete.**

### Adding Computed Items in Results and Tables

In the Results and reporting sections, computations are performed in the Interactive Reporting document file. The computations involve only the data in your results set or on the surface of a reporting section.

In these sections you can only create new computed items: you cannot modify original data items retrieved directly from the database.

Computed items in the Results and reporting sections differ in two respects:

- In the Results and Table sections, reference items are limited to the items that is displayed on the Request line.
- In the remaining reporting sections (excluding the Report Designer section), items in any data layout are available in the Reference dialog box. Computations in these sections work
on the aggregated cell values that make up the core of the report. To perform computations on data before it is aggregated, compute the new item in the Results section.

- In the Report Designer section, the break totals of a table can be calculated.

➤ To add a computed item in the Results and Table sections:

1. Select an item in the Request pane and choose Actions > Add Computed Item(s).

   The Computed Item dialog box is displayed.

2. Enter a name for the computed item in the Name field.

   The default name is Computed, which is numbered sequentially if there is more than one. If you assign a name to a computed item that is identical to an existing scalar function name, Interactive Reporting numbers the name starting with the number 2.

3. Select the data type of the computed item from the Data Type list box.

   For information about data types, see “Adjusting Data Types” on page 219.

4. Enter the definition of the computed item in the Definition text box.

   - You can type operators to insert arithmetic and logical operators at the insertion point. See also “Operators” on page 220.
   - Click Reference to display the Reference dialog box, and select items to place in the equation. See also “Reference” on page 224.

   You can also type any portion of the equation or the entire equation directly into the Definition text box using JavaScript. The names are case sensitive, and you must replace spaces in item names with underscores (‘_’).

5. When the equation is complete, click OK.

**Adjusting Data Types**

Since computed items are new data items, confirm or change the data type of the item to preserve the precision of a mixed-data type computations, or to change the way a data item is handled (for example, interpreting number as strings). This ensures the correct handling of data in server computations.

Attention to data types is most important when computing items in the Query section. Here the computation is performed on the database server, and the computed item may be handled with an unanticipated data type.

Local calculations (Results or Pivot) are handled internally, and adjustment between 16- and 32-bit integers can be handled safely using the automatic or number data type specification.

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatic</td>
<td>A data type is determined automatically given the data type of the reference items and the computations performed</td>
</tr>
<tr>
<td>Number</td>
<td>Numeric data type.</td>
</tr>
<tr>
<td>--------</td>
<td>--------------------</td>
</tr>
<tr>
<td>String</td>
<td>Text strings to a maximum length of 256 characters</td>
</tr>
<tr>
<td>Date</td>
<td>Calendar date in server default format (typically mm/dd/yy)</td>
</tr>
<tr>
<td>Picture</td>
<td>Picture (Blob) data types for image formats such as: jpeg, bmp, gif, and png.</td>
</tr>
</tbody>
</table>

**Paging Through Results Data**

By default Interactive Reporting shows a fixed number of rows in a table when a user views a page in a browser. For paging behavior when data extends beyond the vertical and horizontal rows shown on the page, see below.

<table>
<thead>
<tr>
<th>Table 61</th>
<th>Results and Table Paging Options</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Paging Option</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td><strong>Current Page</strong></td>
<td>The tooltip shows the current page in the report.</td>
</tr>
<tr>
<td><strong>Page Up</strong></td>
<td>Moves one page up. To move to the top page, select [Shift] + Click + Up arrow.</td>
</tr>
<tr>
<td><strong>Page Down</strong></td>
<td>Moves one page down. To move to the first page in the down direction, select [Shift] + Click + Down arrow.</td>
</tr>
</tbody>
</table>

**Chart Section**

Charts are fully interactive, three-dimensional views of data. A chart is a graphical representation of a Pivot section. With a varied selection of chart types, and an arsenal of tools like grouping, drill-down and drill to detail, the Chart section is built to support simultaneous graphic reporting and ad-hoc analysis. You can add, move, cluster, focus and drill down into chart objects to gain customized views of the data.

- Understanding Chart Dimensions
- Legends
- Chart Types
- Two-dimensional Chart Types
- Multidimensional Chart Types
- Viewing Three-dimensional Bar Charts

**Understanding Chart Dimensions**

A Chart can be referenced at three points: height, width and depth (x, y and z in Cartesian space). To understand the differences among charts, you have to distinguish between dimensions in space and dimensions of data. The two dimensions are distinct.
Data can either be represented in two or in three dimensional space. In two dimensions, data is represented along the x and y axis. In three dimensions, data is projected back along the z axis.

Two dimensions of data must be represented in two dimensional space. At least three dimensions of data are necessary to use the third spatial dimension.

But three or more dimensions of data can be represented in two dimensional space. For example, cluster and stack represent data categories in the bar chart of two spatial dimensions (x and y axes only).

---

**Chart Data Layout Categories**

The Chart Section opens with an initial plot area for the chart. Because you manage chart construction and manipulation is with the Chart data layout plotting, viewing and reviewing are easy and intuitive.

You construct a chart by dragging items from the Catalog pane to a data layout pane. At least one items must populate the data layout to plot a usable chart.

The data layout consists of the following items:

<table>
<thead>
<tr>
<th>Data Layout Pane</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>X Axis</td>
<td>The X-Axis is used for those items to place on the x axis, which is a straight line on the chart. It is used as a qualitative data label for categorizing information. To place items on the x axis, use the X-Axis pane.</td>
</tr>
<tr>
<td>Slice</td>
<td></td>
</tr>
<tr>
<td>Stack</td>
<td>The Stack Cluster or Depth pane represents the third dimension of data, that is, the z axis that projects out toward you or a location in space. This axis can either be qualitative or quantitative. For a Stack pane, each dimension of data of the charts is represented by only one bar. This bar consists of as many components as the data file has data rows, with the data from each row stacked onto the previous row. For example, a single bar can represent the amount of sales for CD-ROM drives in one year on top of a bar representing sales for other years. You can stack the bar charts vertically or horizontally. By stacking items and assigning a different color to each item, you can display trends among comparable or related items, or emphasize visually a sum of several indicators.</td>
</tr>
<tr>
<td>Cluster</td>
<td></td>
</tr>
<tr>
<td>Depth</td>
<td></td>
</tr>
</tbody>
</table>
### Data Layout Pane

<table>
<thead>
<tr>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>For a <strong>Cluster</strong> pane, data extended in the third dimension is shown as clusters displayed in the foreground. This category creates a vertical column (and only a vertical column) for each data value. If the chart is showing multiple data series, the values are grouped based upon the category value. For example, use clustered bars to compare stores of different types. Alternatively, cluster bars can be used to compare two different values items, such as Amount of Sales and Units Sold. For the <strong>Depth</strong>, data extends the length of the chart along the z axis.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Fact</th>
<th>The <strong>Facts</strong> pane indicates height in the coordinate system. It is used as a quantitative label as a way of categorizing information on the y axis.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Fact (Stack)</td>
<td>For the <strong>Fact (Stack)</strong> pane, each dimension of numeric data is represented by only one bar, and shows the grouping along the y axis. This bar consists of as many components as the data file has numeric rows, with the numeric data from each row stacked onto the previous row. For example, a single bar can represent the amount of sales for CD-ROM drives in one year on top of a bar representing sales for other years. You can stack the bar charts vertically or horizontally. By stacking items and assigning a different color to each item, you can display trends among comparable or related items, or emphasize visually a sum of several indicators. For the <strong>Fact (Depth)</strong> pane, numeric data extends the length of the chart along the z-axis.</td>
</tr>
</tbody>
</table>

### Legends

A chart legend can be set on the x, y or z axis enabling you to shift your focus to data listed on a particular axis. This is a great way to view values on the selected axis without having to view another chart report.

The following three examples shows how to set the legend on different axes to alter the appearance and data shown by the same chart.

In the first example, the legend has been set on the x axis:

In the second example, the legend has been set on the y axis:
In the third example, the legend has been set on the z axis:

To set the chart legend:
1. Select the axis on which to set the legend.
2. Select Set Legend on from the shortcut menu.
   The Axes drop-down list box is displayed.
3. Select either the x, y or z axis.

Changing Chart Properties

You can change the properties of a chart to view it in different perspectives:

- Chart Types
- Two-dimensional Chart Types

Chart Types

Chart types are defined by how they represent data graphically and how they plot values and labels along the x, y or z axes. There are thirteen chart types, each of which may be switched from a two-dimensional to a three-dimensional view (with the exception of the pie chart). Chart types include:

- Pie Charts
To change a chart type:

1 Select an item on the chart.
2 Select Change Chart Type on the shortcut menu.
3 Select another chart type from the submenu.

Two-dimensional Chart Types

Pie and bar charts (of the non-stacked variety) lend themselves to representing two dimensions of data. For example, imagine charting the amount of sales by product type. In pie charts, the two dimensions are represented by slices of a pie. In bar charts, the data is represented by bars along the x and y axes. Two-dimensional chart types include pie and bar charts.

- Pie Charts
- Scatter Charts
- Bubble Charts
- Bar Charts

Pie Charts

Pieces (slices) of the pie are drawn to depict the relative value of a measurable item category to the whole. Pie charts represent additional dimensions of data by further subdividing the pie.
Showing Negative and Positive Values

Pie slices can show both positive values and negative values.

To toggle the display of negative values, select a slice of the pie and select **Show Negative Values** on the shortcut menu.

Showing Pie Percent

Pie slice values can be expressed as a percentage.

To toggle the display of each pie slice value as a percentage, select a slice of the pie and choose **Show Pie Percentages** on the shortcut menu.

Bar Charts

Bar charts are the most common type of business chart and are especially useful for comparative analysis when you want to focus on comparing values and place less emphasis on time. Use a bar chart to illustrate comparisons among individual items.

In a vertical bar chart, items in the y axis form the chart bars. Items in the x axis and z axis itemize the bars.

In a horizontal bar chart, items in the y axis form the chart bars, and items in the x and z axes itemize the bars.
Showing Bar Values

➤ To toggle the display of values, select a bar and choose Show Bar Values on the shortcut menu.

Scatter Charts

A scatter chart is useful for emphasizing scientific or statistical similarities rather than differences in your analysis. Scatter charts illustrate the relationship between pairs of numerical or quantitative values, which are combined into individual data points along the horizontal (y axis) and a vertical (x axis) axis. Data points are plotted in uneven intervals.

A scatter chart represents non-aggregated sources, that is, it retrieves data from the underlying Table/Reports section and does not reflect rolled up values (all other chart types retrieve their data from an aggregated source, and there is a one-to one correspondence between Charts and Pivots). For this reason, the Pivot This Chart feature is not available for a scatter chart.

Scatter charts can only contain a pair of fact or numeric values which are placed in the Y Axis and X Axis in the data layout. If you add only one fact item to the data layout, no scatter chart is rendered. In addition, label values cannot be added to the Y Axis or X Axis of the data layout.

The following feature limitations apply to scatter charts:

● Data functions are not available to scatter charts because this type of chart relies on non-aggregated data.
● The sort feature cannot be used for scatter chart items.
● The Pivot To Chart feature is not available.
● Drilling cannot be performed on a scatter chart.
● The focus feature cannot be used on scatter chart items.
● The Hide feature hides the whole data series in a scatter chart, and an individual item cannot be hidden.
**Bubble Charts**

Bubble charts are typically used to show three dimensions of data in a two dimensional chart. This type of chart often lends itself to the display of financial data because specific values can be visually represented in your chart by different bubble sizes. It is similar to scatter chart allowing you to plot data as a collection of bubbles. Bubble charts plot three values:

- a value set on the x-axis
- a value set on the y-axis
- a value that defines the size or width dimension of a bubble in proportion to the amount of data

Multiple data values can be plotted in the bubble chart.

Bubbles with zero size can rendered using some small bubble size to prevent them from disappearing. Also there is an option can be provided to hide zero-size values if necessary.

Bubbles with negative values can also be displayed. These type of values are derived from their real absolute value, and the real negative value is depicted in the data label (although based on the positive value). You can optionally select not to show negative values.

The following feature limitations apply to bubble charts:

- Data functions are not available to bubble charts because this type of chart relies on non-aggregated data.
- The sort feature cannot be used for bubble chart items.
- The Pivot To Chart feature is not available.
- Drilling cannot be performed on a bubble chart.
- The focus feature cannot be used on bubble chart items.
- The Hide feature hides the whole data series in a bubble chart, and an individual item cannot be hidden.

➤ To create a bubble chart:

1. In the Section pane, select the chart in which to generate the bubble chart.
2. Drag a fact value from the Catalog pane to the Y Axis of the data layout.
3. Drag a fact value from the Catalog pane to the X Axis of the data layout.
4. Drag a fact value from the Catalog pane to the Size pane of the data layout.
To show the real value of a data point, use the tool tip and hover over the data point.

To show grid lines on the scatter chart, click the plot area of the chart and select Show X Axis Grid Lines or Show Y Axis Grid Lines.

**Multidimensional Chart Types**

Frequently you may want to view data represented in more than two dimensions. For example, you may want to see how the sales of product types break down by years or quarter. There are numerous ways to chart three or more dimensions of data. You can project data into the third dimension of space. You can also represent the data in two spatial dimensions.

- Viewing Three-dimensional Bar Charts
- Clustered Bar Charts
- Stacked Bar Charts
- Area Charts
- Stacked Area Charts
- Line Charts
- Time Aware Axis
- Ribbon Charts
- Bar-Line (Combination) Charts

**Viewing Three-dimensional Bar Charts**

You can add more information to your bar chart by adding an additional item or items to the z axis of the chart. Using multidimensional charts, you can show various relationships between three or more items in easy-to-understand bar chart formats.

**Clustered Bar Charts**

Cluster bar charts can be used to juxtapose categories in one label item category. For example, use clustered bars to compare stores of different types. Cluster bars can also be used to compare two different value items, such as Amount of Sales and Unit sold.

You can change your chart perspective so that the z axis data extended in the third dimension is shown as clusters displayed in the foreground. This charting type is useful when z axis bars are hard to distinguish in standard bar formats.

Cluster charts can be used to juxtapose categories in one label item. For example, use clustered bars to compare stores of different types. Alternatively, cluster bars can also be used to compare two different value items, such as Amount of Sales and Unit Sold.

Clustered bar charts are only displayed in a vertical format.
Stacked Bar Charts

One way to represent the third dimension of data is through stacking. In this way, a single bar on the chart can show data for more than one category of data. For example, a single bar can represent amount of sales for CD-ROM drives in one year on top of a bar representing sales for other years. Stacked bar charts can stack vertically or horizontally.

The following is an example of a vertical stacked bar chart.

The following is an example of a horizontal stacked bar chart.
Area Charts

Area charts are essentially bar charts with discontinuous breaks removed along the horizontal axis. Data is not broken into discrete bars, but is displayed in a continuous ebb and flow as defined against the y axis. Consequently, area charts are particularly useful for emphasizing the magnitude of change over time. In addition, area charts can be used for the same purpose as bar charts.

Because area charts do not break data along the horizontal axis, they are most useful for charting three dimensions of data. The z axis should be used to either project data into a third-spatial dimension, or to track two categories of data in a stacked area chart.

In the area chart, items in the y pane determine the height of the line, and items in the x pane itemize the line sections. You can create multiple lines by adding items to the z pane.

Stacked Area Charts

Stacked area charts are essentially bar charts with the discontinuous breaks removed along the horizontal axis, and categories of data are “stacked” on top of each other. Data therefore is not broken into discrete bars, but is displayed in continuous ebb and flow as defined against the y axis. A stacked area chart is an excellent way to display data that shows the relationship of parts.
to the whole. Consequently, stacked area charts can be particularly useful for illustrating changes that are plotted over a period of time.

Line Charts

Line charts show trends in data at equal intervals and are effective for comparing highs and lows in a continuum. Items on the y axis determine the height of the line, and items in the X-Categories itemize the line sections. You can create multiple lines by adding items to the Z-Category.

Line charts have one advantage over bar charts. They do not enable one set of data to obstruct the representation of another. Since lines are thin compared to bars, the data displayed in the front does not block out the data behind.

As a result, data that is not easily represented in bar or area charts work well in line charts. Many more dimensions of data can be superimposed without impairing the effectiveness of the chart.

Time Aware Axis

The Time Aware Axis feature allows you to show dates in chronological order plotted at specific intervals within minimum and maximum bounds. To do this, the Time Aware Axis feature turns a discrete X-Axis into a continuous time interval. The distance between adjacent axis items is
proportional to their time value difference (a non Time Aware Axis shows all items using the same difference between them). The Time Aware feature only implements an alternative visualization of source data and does not affect the way how the data is aggregated and computed items are calculated. That is, the data processing in chart section which includes dividing data into categories and calculating fact data does not depend on whether the Time Aware feature is activated. In particular, the behavior of the “Chart This Pivot”, “Pivot This Chart” and “Add Computed Item” actions do not change.

The Line Charts is the main application area of this feature; however it is available in almost all existing chart types. Scatter/Bubble charts do not include this option because they are already “time aware” (essentially, value aware) by nature. Both have two fact axes which are continuous by definition.

The Time Aware axis can only be used under specific conditions:

- The X axis should have a date/time category to display, which becomes a dedicated Time Scale category.
- Only one category should be on the X-Axis. If you add multiple categories, even if they are date/time categories, the feature is rendered inactive.
- The Time Aware axis is not available for pie, scatter and bubble charts.

The Time Aware Axis is considered active if the conditions in the list above are met, and the Time Aware option on the Label Axis dialog is not explicitly disabled. You can turn on or off the feature. If you turn off the feature, the X axis remains discrete as in previous versions. By default the feature is turned off for Interactive Reporting document files older than Release 9.3. Charts created in Release 9.3 and later have the feature enabled.

**Note:**

Since the Time Aware Axis assumes that all axis labels are in ascending order, the sort order option is disabled.

➤ To create a Time Aware axis:

1. Check the Time Aware option on the Label Axis tab of General properties.
2. Drag a date/time item from the Catalog pane to the X pane in the data layout.
3. Drag a value item from the Catalog pane to the Facts pane in the data layout.

**Ribbon Charts**

A ribbon chart is very similar to a line chart, but with a few visual differences. In ribbon chart, values in the y axis determine the height of the line, and values in the x axis itemize the line sections. You can create multiple lines by adding items to the z axis.
Bar-Line (Combination) Charts

Bar-Line charts (also known as Combination charts) combine some of the strengths of bar charts with the advantages of line charts. Solid bars can be used for the most important data against which other dimensions are represented in lines. In this way, emphasis is given to a portion of data based on its importance. A combination chart is especially useful for comparing two numeric values, such as amount and units of sales.

Note:

A combination chart is most effective when the y axis contains only two value items. It represents one value as bars and the other value as a line. When more than two values are present, the chart alternates between bars and lines in depicting the values (1st, 3rd, 5th items are bars; 2nd, 4th, 6th items are lines).

Working with Charted Data

Interactive Reporting provides several ways for you to dynamically manage your chart data for better analysis. Review the following topics for information on:

- Adding Chart Items
Removing Chart Items

Focusing and Hiding Charted Data

Grouping and Ungrouping Chart Labels

Adding a Chart

➤ To create a Chart based on the Results section data:

1 Select Actions > Insert > Chart.

2 Drag Results items from the Catalog List to the Chart data layout.

   The table columns are populated automatically.

3 Select a Chart type on the shortcut menu.

Adding Chart Items

Interactive charts consist of two layout elements: graphical elements (for example, Chart bars or pie slices) and axis labels. When you add items to a chart, they become values or dimensions in your report.

➤ To add a chart item:

1 Select a Chart item and choose Add item on the shortcut menu.

   The x axis, y axis and z axis submenus are displayed. The z axis submenu does not display for a pie chart.

2 Select a data label from the x axis submenu.

3 Select a fact item from the y axis submenu.

4 Select a data label item from the x axis (or Z-Cluster for a clustered chart, or Z-Stack for a stacked chart) submenu to add a third dimension to the chart.

Removing Chart Items

Removing a plotted items in the Chart sometimes helps to simplify a chart display. However, you do need at least one fact item in order to display a chart accurately.

➤ To remove a chart item:

1 Select the item to be removed in the Chart from the data layout.

2 Select Delete on the shortcut menu.

   The chart is redrawn to reflect the new configuration of items in the chart.
**Refreshing Chart Values Manually**

If a Chart section has been designed so that chart values can be refreshed manually, you can request an immediate refresh to the current section.

➤ To refresh chart values manually, click anywhere on the chart and select **Refresh Chart** on the shortcut menu.

**Focusing and Hiding Charted Data**

A straightforward way to refresh your view of a chart is to single out items for closer focus or to hide some of the charted elements. This allows you to concentrate on particular items of interest.

Focusing redraws the chart report to show only the item you have chosen. This feature is only available for items on the x axis or z axis.

The Show All command updates the chart to include all items removed by focusing. Note that this command is available only when a Chart item has been focused.

Generally, you should only hide items on the x or z axis. Hiding the y axis causes the entire fact to be hidden.

The Show Hidden Items command restores any hidden item.

➤ To focus on a chart item:

1. **Select one or more item on which to focus.**
   The selected items are displayed with a dotted outline.
2. **Select Focus on the shortcut menu.**
   The chart is redrawn to display only the chart item selected.

➤ To show all items in a chart, select a chart item and choose **Show Hidden** on the shortcut menu.

➤ To hide charted data:

1. **In the Chart, select the objects to hide.**
   The selected item(s) are displayed with a dotted outline.
2. **Select Hide Item on the shortcut menu.**
   The chart is redrawn to hide the item.

➤ To show hidden items, select a chart item and choose **Show Hidden** on the shortcut menu.

**Grouping and Ungrouping Chart Labels**

You can merge Chart axis labels using the Group feature. When combined, the data associated with labels is aggregated, creating a new summary label category. With grouping, only your view
of the data is changed. You can easily ungroup grouped categories and return to your original
label values.

For example, your chart report is structured with data item Units (sold) dimensioned by Year
and Quarter. You can group the first and second quarters together to summarize activity for the
first half of the year. The data is aggregated in a new label.

This feature is available only for items on the x axis or z axis.

➤ To toggle the group axis labels feature:

1 Select the individual labels to be grouped.
   (You can group contiguous or discontiguous labels, but the labels must be part of the same
dimension item or axis.)

2 Select (Un)Group Items on the shortcut menu.
   The selected labels, and their associated data values or chart objects, are combined. The resulting
   label is displayed with an asterisk (*) to indicate a grouping.

To ungroup items, reselect the grouped items and choose (Un)Group Items on the shortcut
menu.

### Working with Chart Facts

Data functions in the Chart section are particularly useful if you want your report to display
different types of values. Data functions summarize groups of database records and replace the
original values with new summary data.

For example, in the Pivot section, you can show either the total sale, average sale, or the maximum
sale of each product by quarter. Each of these dimensions is based on the same underlying values.
They differ only in the data function that is applied.

The following table shows the Chart Functions:

<table>
<thead>
<tr>
<th>Data Function</th>
<th>Returns the:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>Sum of all underlying values.</td>
</tr>
<tr>
<td>Average</td>
<td>Average of all underlying values.</td>
</tr>
<tr>
<td>Count</td>
<td>Number of underlying values.</td>
</tr>
<tr>
<td>Count Distinct</td>
<td>Number of distinct values in a column.</td>
</tr>
<tr>
<td>Maximum</td>
<td>Highest of underlying values.</td>
</tr>
<tr>
<td>Minimum</td>
<td>Lowest of underlying values</td>
</tr>
<tr>
<td>Perc of Grand</td>
<td>Sum of underlying values as a percentage of all surface values in the report.</td>
</tr>
<tr>
<td>NonNullCount</td>
<td>Number of underlying values; null values are excluded.</td>
</tr>
</tbody>
</table>
To apply a data function:

1. Select a bar or row of facts (such as Amount).
2. Select Data Function on the shortcut menu.

A shortcut menu of available data functions is displayed.

Optional: You can also select the item or column and choose Actions > Data Function, and select the (function).

3. Select the function.

Each column is recalculated according to the data function applied to the underlying value.

Paging Through the Chart

By default Interactive Reporting shows a fixed number of rows in a table when a user views a page in a browser. Often data extends beyond the vertical and horizontal rows shown on the page. To view your paging options, see the table below.

<table>
<thead>
<tr>
<th>Paging Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current Page</td>
<td>Tooltip shows the current page.</td>
</tr>
<tr>
<td>Page Left</td>
<td>Moves one view in the left direction. To move to the first view in the left direction, select [Shift] + Click + left arrow.</td>
</tr>
<tr>
<td>Page Up</td>
<td>Moves one view up in the Chart sections. To move to the top view, select [Shift] + Click + Up.</td>
</tr>
<tr>
<td>Page Down</td>
<td>Moves one view in the down direction. To move to the first view in the down direction, select [Shift] + Click + Down arrow.</td>
</tr>
<tr>
<td>Page Right</td>
<td>Moves one view in the left direction. To move to the first view in the right direction, select [Shift] + Click + right arrow.</td>
</tr>
</tbody>
</table>

Pivot Section

Pivot tables are analytical tools that resemble spreadsheets or crosstab reports. Data can be sliced and diced for ad-hoc, interactive and multidimensional analysis. You can pivot your data at any time to change the way you view it, or you may drill down, or drill to detail to see how it all adds up or summarizes. Pivot tables also allow you to add, move, focus on and group dimensions to gain customized views of the data.

- Pivot Table Components
- Working with Pivot Data
- Focusing and Hiding Pivot Data
- Working with Row and Column Labels
- Analyzing Pivot Data
Working with Pivot Facts

Paging Through Pivot Data

Pivot Table Components

A pivot table is composed of three components:

- **Facts**—Numeric values broken up in the body of the pivot table. Facts may also be referred to as data values.
- **Data Labels**—Column and row headings on the top and sides of the Pivot and define the categories by which the numeric values are organized
- **Dimensions**—Full row or column of labels

Working with Pivot Data

Interactive Reporting provides several ways for you to dynamically manage your pivot data for better analysis:

- **Adding a Pivot Section**
- **Adding Pivot Items**
- **Deleting Pivot Items**
- **Auto-Sizing a Column**
- **Focusing and Hiding Pivoted Data**
- **Swinging Pivot Dimensions**
- **Grouping and Ungrouping Pivot Labels**

Adding a Pivot Section

➤ To create a table based on the Results section data:

1. Select Actions > Insert > Pivot.
2. Drag items from the Catalog list to the Pivot data layout.

If the data layout is not displayed, select View > Data Layout.

Interactive Reporting populates the cells, rows and columns automatically.

Adding Pivot Items

You can add items from the results set to view and analyze different scenarios in your Pivot.

➤ To add a pivot item:

1. From the Catalog list, select any item and click Add Items on the shortcut menu.
A shortcut showing Row, Column or Facts is displayed.

2 Select the value you want to add.

### Deleting Pivot Items

➤ To delete a pivot item:

1 Select the item to be removed from the Facts, Rows or Columns data layout.

2 Select Delete on the shortcut menu.

The Pivot is redrawn to reflect the new configuration of items.

### Refreshing Pivot Values Manually

If a Pivot section has been designed so that pivot values can be refreshed manually, you can request an immediate refresh to the current section.

➤ To refresh pivot values manually, click anywhere on the pivot and select Refresh Pivot on the shortcut menu.

### Auto-Sizing a Column

By default, Interactive Reporting truncates columns evenly and without regard to the length of data values. With the Auto-Size Column Width feature, you can automatically size any column to fit the text of the largest value in the column.

➤ To autosize a column:

1 Select the column.

2 Select Auto-Size Column Width on the shortcut menu.

### Focusing and Hiding Pivoted Data

A straightforward way to refresh your view of a pivot table is to single out items for closer focus or to hide some of the pivot elements. This allows you to concentrate on particular items of interest.

Focusing redraws the pivot table to show only the item you have chosen to focus on.

The Show All Items command updates the pivot table to include all items removed by focusing. This command is available only when a pivot dimension label has been focused.

Hiding columns is a good way to temporarily suspend the display of a column.

➤ To toggle the focus on a pivot item:

1 Select one or more dimension labels (either side or top).
2 Choose **Focus** on the shortcut menu.

The Pivot is redrawn to display only the chart object selected.

➤ To show all items, select a dimensional label and choose **Show All** on the shortcut menu.

➤ To hide pivoted data:

1. **Select an item.**
2. **Select Hide Items** on the shortcut menu.

The Pivot is redrawn to hide the selected object.

➤ To restore a selected hidden item, select a pivot item and choose **Show Hidden** on the shortcut menu.

---

**Working with Row and Column Labels**

Row and column labels can be grouped and reoriented:

- **Grouping and Ungrouping Pivot Labels**
- **Swinging Pivot Dimensions**

**Grouping and Ungrouping Pivot Labels**

You can merge pivot labels using the Group feature. When combined, the data labels are aggregated, creating a new summary label category. With grouping, only your view of the data is changed. You can easily ungroup grouped categories and redisplay original label values.

For example, your pivot table is structured with data item Units (sold) dimensioned by Year and Quarter. You can group the first and second quarters together to summarize activity for the first half of the year. The data is aggregated in a new label.

➤ To toggle the group dimensional label feature:

1. **Select the individual labels to be grouped.**
   (You can group contiguous or discontiguous labels, but the labels must be part of the same dimension item or axis.)
2. **Select (Un)Group Items** on the shortcut menu.

The selected labels, and their associated data values or chart objects, are combined. The resulting label is displayed with an asterisk (*) to indicate a grouping.

To ungroup items, reselect the grouped items and choose **(Un)Group Items** on the shortcut menu.
Swinging Pivot Dimensions

The swing feature allows you to re-orient the axes of a pivot table and view your data in new ways. When you “swing” a dimension, you can move it up, down or to the opposite axis. This feature is a powerful tool that makes pivot table reporting more powerful than a common spreadsheet.

Note:
You can swing pivot dimensions by moving items within and between data layout panes.

➤ To swing a dimensional label:
1 Select a dimensional label and choose Swing on the shortcut menu.
2 Select a direction.

Valid swing positions are:
● Vertical
● Horizontal
● Up
● Down
● Left
● Right
● Before
● After

If you select the “before” swing positions, you must choose the dimension label before which you wish to place the selected label. This behavior applies to the “after” selection as well.

Working with Pivot Facts

Core numeric data that you slice and dice dimensionally in your analysis are called facts. Facts can be summed to create totals.

You can calculate totals for both columns and rows in a Pivot report. If you layered dimension items along the top or side labels of your report, you can calculate the totals for any level in the hierarchy. When you select an inner dimension for totaling, subtotals are created for each of the categories in the outer dimensions. Totals in the Pivot section include:
● Total Function
● Cumulative Totals
● Surface Values
**Total Function**

You can quickly add totals to your pivot table data. The new total value is created as an additional column. Total functions can be applied to:

- Underlying values from the original results sections
- Surface values displayed in the Pivot

Depending on which set of values you apply the total function, different results are yielded. Consider a simple pivot table with two values of 20 and 30. Each of these is already a total of underlying values (20 = 8 + 12 and 30 = 10 + 20). An average of the underlying value yields the result of 12.5 = (8 + 12 + 10 + 20) / 4). An average of the surface values yields the results 25 = (20 + 30) / 2).

➢ To add totals to a Pivot:

1. **Click a row or column label handle to select it.**
   
   Selecting the outermost label creates a total; selecting an inner label creates a subtotal.

2. **Select Add Total on the shortcut menu.**
   
   A submenu of data functions is displayed.

3. **Select a data function.**

**Cumulative Totals**

By adding cumulative running totals to a pivot table, you can break totals by dimension to restart at each dimensional grouping in the report.

➢ To add a cumulative calculation:

1. **Select a fact item in the data grid of the Pivot.**

2. **Select Add Cume on the shortcut menu.**
   
   The Add Cume shortcut menu is displayed.

3. **Select a scope from the Add Cume shortcut menu.**
   
   A new data values item named “Cume of X” is displayed across each row of the report. The new cume item maintains a cumulative running sum of the original data values item.

   **Note:**

   Cumulative totals are most effective when all dimensions are located on a row or column of the report, and data label column heads are placed orthogonally.

➢ To modify a cumulative calculation:

1. **Select a column in which a cume has already been place in the pivot table’s data grid.**

2. **Select Modify Cume on the shortcut menu.**
The Modify Cume submenu is displayed.

3 Select a scope from the Modify Cume shortcut menu.

**Surface Values**

You can use underlying or surface values when working with totals in Pivot sections. Underlying values refer to values from the original results section. Surface values refers to values in the actual report section. The two approaches yield different results, and produce values that may be displayed incongruous with the values in the report.

To understand this difference between underlying and surface values, consider a simple pivot table with two values of 20 and 30. Each of these is already a total of underlying values (20 = 8 + 12 and 30 = 10 + 20). An average of the underlying value yields the result of $12.5 = (8 + 12 + 10 + 20) / 4)$. An average of the surface values yields the results $25 = (20 + 30) / 2)$. By default, the surface value feature is not active.

➤ To activate surface values, select a pivot item and Surface Values on the shortcut menu.

**Analyzing Pivot Data**

Data functions in the Pivot section are particularly useful if you want your report to display different types of values. Data functions summarize groups of database records and replace the original values with new summary data.

For example, in the Pivot section, you can show either the total sale, average sale, or the maximum sale of each product by quarter. Each of these dimensions is based on the same underlying values. They differ only in the data function that is applied.

<table>
<thead>
<tr>
<th>Data Function</th>
<th>Returns the:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>Sum of all underlying values.</td>
</tr>
<tr>
<td>Average</td>
<td>Average of all underlying values.</td>
</tr>
<tr>
<td>Count</td>
<td>Number of underlying values.</td>
</tr>
<tr>
<td>Count Distinct</td>
<td>Number of distinct values in a column.</td>
</tr>
<tr>
<td>Null Count</td>
<td>Number of nulls among underlying values.</td>
</tr>
<tr>
<td>Non-Null Count</td>
<td>Number of underlying values; null values are excluded.</td>
</tr>
<tr>
<td>Maximum</td>
<td>Highest of underlying values.</td>
</tr>
<tr>
<td>Minimum</td>
<td>Lowest of underlying values</td>
</tr>
<tr>
<td>% of Row</td>
<td>Sum of underlying values as a percentage of their respective surface row.</td>
</tr>
<tr>
<td>% of Column</td>
<td>Sum of underlying values as a percentage of their respective surface column.</td>
</tr>
</tbody>
</table>
Data Function Returns the:
% of Grand Sum of underlying values as a percentage of all surface values in the report.

To apply a data function:

1 Select a row or column of facts (such as Amount).
2 Select Data Function on the shortcut menu.
   A shortcut menu of available data functions is displayed.
   Optional: You can also select the item or column and choose Actions > Data Function, and select the (function).
3 Select a function.
   Each column is recalculated according to the data function applied to the underlying value.

Paging Through Pivot Data

By default, Interactive Reporting shows a fixed number of rows in a table when a user views a page in a browser. Often data extends beyond the vertical and horizontal rows shown on the page. To view your paging options, see the table below.

<table>
<thead>
<tr>
<th>Paging Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current Page</td>
<td>The tooltip shows the current page in the report.</td>
</tr>
<tr>
<td>Page Left</td>
<td>Moves one page in the up direction. To move to the top page, select [Shift] + Click + Up.</td>
</tr>
<tr>
<td>Page Up</td>
<td>Moves one page in the down direction. To move to the first page in the down direction, select [Shift] + Click + Down arrow.</td>
</tr>
<tr>
<td>Page Down</td>
<td>Moves one page in the left direction. To move to the first page in the right direction, select [Shift] + Click + right arrow.</td>
</tr>
<tr>
<td>Page Right</td>
<td>Moves one page in the left direction. To move to the first page in the left direction, select [Shift] + Click + left arrow.</td>
</tr>
</tbody>
</table>

Common Chart/Pivot Features

Interactive Reporting document file management features allow you to easily tailor the look of reports. The features shown below are common in the Chart and Pivot sections:

- Sorting Charts/Pivots
- Drill Anywhere into Charts/Pivots
- DrillDown into Dimensional Data
## Sorting Charts/Pivots

In the Chart and Pivot sections, data is sorted alphabetically. You can override this default and sort dimensional data with reference to other data, rather than alphabetically.

For example, if a chart lists each type of item your company sells and the total amount sold of each, initially the item types are alphabetically ordered. But this data becomes more meaningful when you instead sort the item types with reference to the total sales revenue produced by each. This approach allows you to rank each product type from highest to lowest total sales.

When you want to apply a sort criteria there are three components used to define the sort condition:

- **Sort Items**—Item sorted in ascending or descending order. In the Chart section, sort items refers to the chart axes. In the Pivot section, sort items refers to the pivot dimensions.

- **Referential Items**—Numeric data item included in the Chart or Pivot section, and also the keyword “labels.” These selections provide two ways to sort the selected Chart or Pivot item.
  - **Sorting by labels**—Dimensional data items are sorted alphabetically by name when the chart section is created: this is equivalent to sorting by “labels.” When selected, the “labels” keyword indicates that the item chosen from the submenu are sorted by label or name rather than by reference to corresponding numeric data values in the report.
  - **Sorting by values**—Sorting by a numeric data item orders each value of the target item specified by its corresponding numeric value in the second list. Sorting by values produces an entirely different sort order. For example, your chart may list each state in which your company has made sales revenue and the total cost-of-sales for each. The data items are initially listed in alphabetical order, that is, sorted by “labels.” When you sort instead by cost-of-sales, the states are ranked in order by each corresponding cost-of-sales figure.

- **Functions**—Aggregate statistical functions available when you sort by values. The functions generally duplicate the data functions available in the chart section.

When you sort by values, dimensional data is sorted by the corresponding numeric values of the referenced item. (For example, sorting states by the sum total of the cost of good sold in each state).

To specify a sort:

1. **Select an item to sort in the Chart or Pivot sections.**
2. **Click either Sort Ascending or Sort Descending on the shortcut menu.**
3. **Select Label to sort the item alphabetically, or select the numeric value item as a sort reference.**
4. **If you selected a numeric value, choose an aggregate function on the shortcut menu.**

## Drill Anywhere into Charts/Pivots

The Drill Anywhere feature allows you to drill into and add items in the Chart and Pivot sections that are resident in the Results section, but have not been included in the Chart and Pivot you are viewing. Drill anywhere items are broken out as a new label item(s) automatically. The
advantage of this feature is that it instantly allows you to add items to the data set to reflect temporary and hypothetical situations.

The extent to which you can drill into your data depends on how the original query was built, since Drill Anywhere retrieves data from the Results section.

➢ To drill anywhere into a Chart:

1 Select a pivot dimension or chart item for analysis.

2 Select Drill Anywhere on the shortcut menu.
   A shortcut of drill anywhere items displays.

3 Select an item on which to drill down.
   The report is redisplayed, breaking out the additional data as a new label item.

Note:
If no options are available in the Drill Anywhere drop down list, all available items have been referenced in the chart.

DrillDown into Dimensional Data

The DrillDown feature enables you to use a predefined drill-down path to go directly to the next item in a hierarchy when working with dimensional analysis. For example, you may need to find out if a particular product sells better in different regions of the country. Using a drill-down path, all you have to do is follow the drilldown path to discover which state or even city is a more appropriate market for your product.

➢ To drill down into a Pivot or Chart label:

1 Select any label for drill-down analysis.
   Because the drill-down into feature is not context sensitive, access the drill-down from any label shown.

2 Click DrillDown into on the shortcut menu.
   All available drill-down paths are displayed. Each drill-down path shows the topic which is being drilled into, and the label from which it was drilled.

3 Click the drill-down label.
   After you specify the drill down label, the label is added to the data layout and breaks out the additional data according to the label selected for drill-down.

➢ To drill up from data:

1 Click the label that has been drilled downed.

2 On the Pivot or Chart menu, select Drill Up.
   The report is redisplayed, reversing the drill-down and displaying the original item.
The OLAPQuery section is designed for viewing and analyzing queries based on multidimensional databases (MDD). This section includes the following topics:

- Working with OLAP Data
- OLAP Data Functions

### Working with OLAP Data

Interactive Reporting provides several ways for you to dynamically manage your OLAP data for better viewing analysis:

- OLAP Terminology
- Auto-Sizing a Column
- Sorting OLAP Dimensions
- Drilling into OLAP
- Drilling up

### OLAP Terminology

**Cube**—Data in OLAP databases is stored in cubes. Cubes are made up of dimensions and measures. A cube may have many dimensions.

**Dimensions**—In an OLAP database cube categories of information are called dimensions. Some dimensions could be Location, Products, Stores, and Time.

**MDX**—MDX (Multi Dimensional eXpressions) is the language used to give instructions to OLE DB for OLAP-compliant databases. When an OLAP query section is built, Interactive Reporting is translating those into MDX instructions. When the query is refreshed, MDX is sent to the database server. The data the server returns to the Interactive Reporting document file is the collection of records that answers the query.

**Measures**—Measures are the numeric values in an OLAP database cube that are available for analysis. The measures could be margin, cost of goods sold, unit sales, budget amount, and so on.

**Members**—In a OLAP database cube, members are the content values for a dimension. In the location dimension, they could be San Francisco, Japan, Paris, 35 Main Street, Tokyo, USA, France, Rome, and so on. These are all values for location.

**Multidimensional**—Multidimensional databases create cubes of aggregated data that anticipate how users think about business models. These cubes also deliver this information efficiently and quickly. Cubes consist of dimensions and measures. Dimensions are categories of information. For example, locations, stores and products are typical dimensions. Measures are the content values in a database that are available for analysis.
Auto-Sizing a Column

By default Interactive Reporting truncates columns evenly and without regard to the length of data values. With the Auto-Size Column Width feature, you can automatically size any column to fit the text of the largest value in the column.

➤ To auto-size a column:
1 Select the column.
2 Select Auto-Size Column Width on the shortcut menu.

Sorting OLAP Dimensions

In the OLAP section, data can be sorted in ascending or descending order.

➤ To specify a sort:
1 Select an item to sort in the OLAP sections.
2 Select either Sort Ascending or Sort Descending on the shortcut menu.
3 Select Label to sort the item alphabetically, or select the numeric value item as a sort reference.
4 If you select a numeric value, choose an aggregate function on the Function shortcut menu.

Drilling into OLAP

The Drill Down feature retrieves data from the MDD cube following the hierarchy down to the granular level. When you find a specific item to learn more about, such as a product line, you can drill down into the item label. You can drill down on more than one item and additionally drill down on all items at the same time.

For a member drill down, any row or column label can be drilled into so that you can view the structure of the hierarchies for any particular dimension. Every time you select a specific label in a dimension row or column, you show only the data for that label value. When you select the dimension tab for a level, you show all the members of that dimension level.

For a measure drill down, you can show how different measures consolidate together. A drill down on a measure is done on a progressive basis, one level at a time on a 1 to n path (sequential rather than nested). For example, if Profit is the parent of Tax and Pre-Tax Profit, and Revenue and Expenses are children of Pre-Tax Profit, then the Tax and Pre-Tax columns are drilled down first and you must select the Pre-Tax label to display the Revenue and Expense columns.

Note:
You cannot set filters while in a drilled-down state on a dimension.

➤ To drill down on a label:
1 Select a label.
2 Click **Drill Down** on the shortcut menu.

You can select a label and choose **Action > Drill Down**.

**Note:**

Essbase only: For a measure drill down, you can show how different measures consolidate together. A drill down on a measure is done on a progressive basis, one level at a time on a 1 to n path (sequential rather than nested). For example, if Profit is the parent of Tax and Pre-Tax Profit, and Revenue and Expenses are children of Pre-Tax Profit, then the Tax and Pre-Tax columns are drilled down first and you must double-click the Pre-Tax label to display the Revenue and Expense columns.

**Drilling up**

If you used the drill-down feature, you return to your original view of the data by drilling up one level at a time. To drill up, you simply select the level to drill up.

➤ To drill up on a label:

1 Select the label that has been drilled down.
2 Select **Drill Up** on the shortcut menu.

Optional: You can also select a label and choose **Action > Drill Down**.

**OLAP Data Functions**

Column or row totals added to your OLAPQuery are aggregates (literally, totals of totals), and can be recalculated using data functions. When applied to totals, data functions apply to the calculation to “surface” values.

When applied to surface values, data functions recalculate the values in the visible cells or “surface” of the OLAPQuery. For example, you can show the total sale, average sale, and maximum sale of each product by Quarter. Each of these dimensions is based on the same value. They only differ in the data function that is applied.

<table>
<thead>
<tr>
<th>Data Function</th>
<th>Returns the:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>Sum of all values.</td>
</tr>
<tr>
<td>Average</td>
<td>Average of all values.</td>
</tr>
<tr>
<td>Count</td>
<td>Number of values.</td>
</tr>
<tr>
<td>Maximum</td>
<td>Highest of values.</td>
</tr>
<tr>
<td>Minimum</td>
<td>Lowest of values</td>
</tr>
<tr>
<td>% of Row</td>
<td>Surface values as a percentage of their respective row item.</td>
</tr>
</tbody>
</table>
To apply a data function:

1. **Select a row or column of facts (such as Amount)** on the shortcut menu.
2. **Select Data Function.**
   
   A list of available data functions is displayed.
   
   Optional: You can also select the item or column and choose Actions > Data Function.
3. **Select the function.**

   Each column is recalculated according to the data function applied to the underlying value.

---

**CubeQuery Section**

The CubeQuery section is the Interactive Reporting interface with Essbase 7.x, and 9.x databases. It provides access to the cube in which multidimensional data can be analyzed and complex calculations can be applied before and after the query is processed. The data set from this section can be shown with relational data side-by-side in a dashboard report, or the data can be downloaded to a results set and joined to relational sources.

**About Essbase**

Analytic Services is a multidimensional database application that enables you to analyze multiple aspects of your business continually in comparison to one another. The Essbase database has the following characteristics:

- Works with multidimensional data and roll-up hierarchies in dimensions.
- Retrieves information from other systems.
- Handles some level of summarized data, not transaction.
- Adaptable to multiple reporting and analysis environments.

Additionally, the Essbase database uniquely blends an innovative technical design with an open, client-server architecture. Essbase can be used for a broad range of online analytical processing (OLAP) applications, including:

- Budgeting
- Forecasting and seasonal planning
- Financial consolidations and reporting
- Customer and product profitability analysis
- Price, volume and mix analysis
Executive information systems

About Multidimensional Database
The Essbase multidimensional database stores and organizes data. It is optimized to handle applications that contain large amounts of numeric data and that are consolidation-intensive or computation-intensive. The database organizes data in a way that reflects how users want to view the data.

Definition of Multidimensional
A multidimensional database is an extended form of a two-dimensional data array, such as a spreadsheet, generalized to encompass many dimensions. Dimensions are composed of values called members, which are arranged in a hierarchical structure. A dimension is a perspective or view of a specific dataset. A system that supports simultaneous, alternate views of datasets is multidimensional. Dimensions are categories such as time, accounts, product lines, markets and so on. Each dimension contains additional categories that have various relationships one to another. Members are the names of the elements within a dimension. A dimension can contain an unlimited number of members.

Dimensions and Members
Dimensions and members describe the metadata structure of the database, which is also known as the Essbase outline. The Essbase outline determines how data is stored in Essbase. Following are typical examples of dimensions and their members:

- Time—Hours, Days, Months, Quarters, Years
- Measures—Profit, Inventory, Ratios
- Product—Individual products of the company
- Market—North, South, Central
Non-aggregate Dimensions

Some dimensions are aggregates of their members. For example, 24 hours make a day, 7 days compose a week, 52 weeks make a year, and so on. In these cases, the Time dimension represents the sum of its components. However, some dimensional hierarchies are not the sums of their components. For example, the Measures dimension commonly comprises business measures such as Sales, Profit, and Cost of Goods Sold. When the dimension label cannot represent the sum of contents, a protocol replaces the dimension label with a member set. Essbase uses the first child in the dimension outline as the implied share instead of non-aggregate dimension labels.

Familial Relationships

To simplify the concept of hierarchical order, Essbase uses familial relationships.

- **Parent**—Direct ancestor of an element in a hierarchy; for example, Quarters are the parent of Months.
- **Child**—Direct descendant of any element in a hierarchy; for example, Months are children of Quarters.
- **Descendants**—Elements of greater detail; for example, Days are descendants of Weeks.
- **Ancestors**—Elements of more generality; for example, Weeks are ancestors to Days.
- **Siblings**—Members with the same parent

![Diagram](https://via.placeholder.com/150)
Generations and Levels

Hierarchical structure also can be described in terms of generations and levels. Dimension members on the same layer of the dimensional hierarchy are referred to collectively as generations or levels. The relationships are defined as follows:

- **Generations**—Counted down from the highest ancestor. The root member, or dimension name, is Generation 1. In the following figure, Market is Generation 1.
- **Levels**—Counted from bottom to top: Level 0, Level 1, Level 2, and so on. In the following figure, states are at Level 0.
- **Leaf nodes**—Lowest points in a hierarchy.
**Attributes**

In addition to dimension member names, locations, and relationships, Essbase stores characteristics, called attributes, about members. For example, the Product dimension indicates that in Women’s Apparel, Shirts and Blouses, there is a cotton T-shirt; an attribute indicates that the cotton T-shirt is red, cyan, lime, or pink. Essbase does not store data for attribute dimensions as part of the multidimensional database but instead dynamically calculates it upon request. Attribute dimensions are displayed in dimension hierarchies, in the same manner as other dimensions, despite their data being stored differently.

**Catalog List**

The Catalog List displays one or all dimensions in a tree model. The tree can be expanded to display additional members, but generations are not included in the hierarchy. For cubes with many members in a dimension, paging facilitates navigation. The number of members that can be displayed in the Catalog and Member Selection is defined in the Number of members to display option in Query Options. The default is 50.

- To display the Catalog in single-dimension mode, select a dimension from the Dimension Selection.
  To expand the tree to display additional members in the dimension hierarchy, next to the dimension, click +.

- To display the Catalog in all dimension, click.

**OLAPQuery and CubeQuery Data Layout Differences**

OLAPQuery is the pre release 9.3 section used to query a multidimensional database. The data layout tool in OLAPQuery and CubeQuery have these differences:

<table>
<thead>
<tr>
<th><strong>OLAPQuery Data Layout</strong></th>
<th><strong>CubeQuery Data Layout</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Slicer</td>
<td>Filters</td>
</tr>
<tr>
<td>Side</td>
<td>Rows</td>
</tr>
<tr>
<td>Top</td>
<td>Columns</td>
</tr>
<tr>
<td>Filters from multiple members may be selected and applied from a single hierarchy.</td>
<td>One filter member can be selected per dimension. Filters for multiple members within the same dimension are not supported.</td>
</tr>
<tr>
<td>Measures are treated as distinct dimensions and can be placed only in the Facts pane of the data layout.</td>
<td>Measures can be placed in the Row, Column, and Filter panes of the data layout.</td>
</tr>
<tr>
<td>Member selection in the data layout is unavailable.</td>
<td>Member selections in the Row, Column and Filter panes of the data layout can be edited in the Member Selection dialog box.</td>
</tr>
</tbody>
</table>
Building a CubeQuery

Before you can build a CubeQuery section, you need a published Interactive Reporting database connection file (.oce), and an Interactive Reporting document file (BQY).

To import a published Interactive Reporting database connection file (.oce):
1. **Select File > Import File.**
   The Choose File Import dialog box is displayed.
2. **Click Browse, navigate to the folder where the Interactive Reporting database connection file is located, and click Open.**
   The File field is populated with the Interactive Reporting database connection file name.
3. **Click Next.**
   The OCE Properties Import dialog box is displayed.
4. **Specify a user name and password, and any appropriate data source access settings.**
5. **Click Finish.**

To import an Interactive Reporting document file (BQY):
1. **Select File > Import.**
   The Choose File Import dialog box is displayed.
2. **Click Browse, navigate to the folder where the Interactive Reporting document file (BQY) is located, and click Open.**
   The File field is populated with the Interactive Reporting document file name.
3. **Click Next.**
   The Interactive Reporting Properties Import dialog box is displayed.
4. **Specify a connection option in the Apply Option to All Queries field.**
5. **Select an Interactive Reporting database connection file (.oce) to associate with the Interactive Reporting document file in the Query/DataModel Connection drop-down, and specify an user name and password.**
6. **Click Finish.**

To create a new CubeQuery section based on a previously published Interactive Reporting document file (BQY):
1. **In Explore, select an Interactive Reporting document file (BQY) that contains a CubeQuery section.**
2. **Enter your name in the Host Name field and password in the Host Password field and click OK.**
3. **Select Actions > Insert > Query.**
The Insert Query dialog box opens.

4 **Check Existing Essbase Connection** to select the current Interactive Reporting database connection file (.oce), or select another from the drop-down and click **OK**.

A new Interactive Reporting document file is created.

5 **To populate the Catalog List, select Actions > Retrieve Dimensions.**

The Catalog List shows the dimensions available to add to the query.

6 If prompted, enter your database user name and password in the **DB User Name** and **DB Password** fields and click **OK**.

7 From the Catalog List, select a dimension.

To toggle the Catalog List between single and all dimension modes, click ■.

8 In the Catalog List, select a member dimension and select Query > Add to Rows or Query > Add to Columns.

**Note:**
Members from the same dimension cannot be split across columns, rows and filters.

9 In the Catalog List, select a measure dimension and select Query > Add to Rows or Query > Add to Columns.

10 To filter a member, select a member in the Catalog List and select Query > Add to Filters.

11 Click **Process**.

**Note:**
If missing values are not displayed, it is possible that the Suppress Missing and Suppress Zero options are enabled. These options are enabled by default and can be disabled in the Query Options

**DB Logon**

Use the DB Logon dialog box to specify the database name and password used to logon to the Essbase database.

➢ To specify the database logon, enter the database user name in the **DB User Name** field, and database password in the **DB Password** and click **OK**.

Your database administrator retains a list of all valid logon names and passwords.

**Searching Members**

Member search is available for member names, aliases or both in one or more dimensions from the Catalog List. If the Catalog List shows members in single dimension mode, the Search is
performed on a selected dimension. If all dimensions are displayed, Search is performed on all dimensions.

➤ To search members from the Catalog List:
   1 Select to search by name, alias, or both.
   2 Enter the text on which to search.
      If you use wildcards in searches, only trailing wildcards are accepted (for example, Cola*), and not leading wildcards (for example, *-10).
      The ?? (placement position) is a valid search criteria. The ? substitutes one occurrence of a character; and can be placed anywhere in the string.
   3 Click
      The search results are displayed in the Catalog List, and they can be added to the data layout.

➤ To close Search, select
      The Search results are cleared.

**Member Selection**

An Essbase database may contain hundreds or even thousands of members. Use the Member Selection Browse and Search tabs to refine query member criteria for a selected dimension. The Member Selection dialog box includes dynamic selection functions such as children, descendants, bottom, siblings, or subsets (UDA, Attribute Dimensions, Level and Generation).

The Available pane lists the member hierarchy for the selected dimension. An additional node for substitution variables lists substitution variables for all dimensions; however, if they are selected from another dimension, an error appears when adding the substitution variables to the Selected pane.

The Selected pane lists all member selections. Selections can be a single member or a dynamic selection function (for example, children).

<table>
<thead>
<tr>
<th>Icon</th>
<th>Dynamic Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Member" /></td>
<td>Member</td>
<td>Currently selected member</td>
</tr>
<tr>
<td><img src="image" alt="Children" /></td>
<td>Children</td>
<td>Children of the selected member (one level below)</td>
</tr>
<tr>
<td><img src="image" alt="Descendants" /></td>
<td>Descendants</td>
<td>Descendants of the selected member</td>
</tr>
<tr>
<td><img src="image" alt="Bottom" /></td>
<td>Bottom</td>
<td>Descendants of the selected member on the lowest level of the hierarchy (Level 0)</td>
</tr>
<tr>
<td><img src="image" alt="siblings" /></td>
<td>Siblings</td>
<td>Members on the same level with the same parent as the selected member</td>
</tr>
</tbody>
</table>
### Browsing Members

Use the Member Selection Browse tab to navigate through and select individual members to include in the query.

➤ To browse and select members:

1. **In the data layout, on the shortcut menu, select a dimension member and select Edit.**
   The Member Selection dialog box is displayed.

2. **Select Browse.**

3. **Select a member and click + to the left of the member name to expand it.**

4. **To include an individual member in the query, select the member in the Available pane and click +.**
   The member is added to the Selected pane.

5. **To include a dynamic function, on the shortcut menu, select the member in the Available pane and select the function from the submenu:**
   - Member
   - Children
   - Descendants
   - Bottom
   - Siblings
   - Same Level
   - Same Generation
   - Disable or Enable (selected members only)

6. **Click OK.**

➤ To change the member function in the Selected pane:

1. **Select the member to modify.**
   Use Shift + click to select multiple and consecutive items. Use Ctrl + click to select multiple, but nonconsecutive items.

2. **To include or exclude a member (for example, “Member+Children” versus “Children”), select the check box next to the member name.**

3. **Click OK.**
To clear an item used in the query without removing it from the Selected pane:
1. Select the item and choose Disable from the shortcut menu.
2. Click OK.

To remove a member or member element:
1. Select the member in the Selected pane and click .

   Use Shift + click to select multiple and consecutive items. Use Ctrl + click to select multiple, but nonconsecutive items.

   The member is moved from the Selected pane.
2. Click OK.

To remove all members and member elements, select .

   The Selected pane is depopulated.

To toggle between including or excluding a member:
1. Select a member in the Selected pane.
2. Select Disable to exclude a member, or Enable to include a member.

**Substitution Variables**

Substitution variables define global variables that represent Essbase-specific values. For example, CurMonth can be a substitution variable for displaying the latest time period. Rather than constantly updating queries when a value changes, you change only the value for the substitution variable on the server. Essbase creates substitution variables, but you can specify a substitution variable when selecting members.

To add a substitution variable:
1. Select a member in the data layout and select Edit on the shortcut menu.

   The Member Selection dialog box is displayed.
2. Select Browse.
3. In the Available pane click + to expand the Substitution Variable node.
4. To include a substitution variable, select the member in the Available pane and click .
5. To include a dynamic function on a substitution variable, on the shortcut menu, select the member in the Available pane and select the desired function from the sub-menu:
   - Member
   - Children
   - Descendants
Variables
A variable is a constraint placed on the query when the query is processed.

➤ To use all selected members as a variable (the user is prompted for the values when the query is processed:

1 In the data layout, select a dimension member and select Edit on the shortcut menu.
2 Select Use as variable.
3 Click OK.

Searching Members

➤ To search for members:

1 In the data layout, right click a dimension and select Edit.
2 Select Search.
3 From the Member Type, select the type of member to search:
   ● Name—Member Name
   ● Alias—Alternate Names for database members
   ● Both—Member Name and Alias Name

Note:
To search on alias names, enable the Use Alias Tables option and select an alias table in Query Options.

4 Enter the text string or numeric value to search (a member name or pattern).
   Trailing asterisks and wildcard strings are acceptable. Examples of value text strings: Ja*, M?n, and M??n. Examples of invalid text strings: *-10 and J*n.
5 To locate all member within the selected dimension that matches the text string or numeric value, click.
   The results of the search populate the Available pane.
6 Optional: To add a member to the Selected pane, click ![icon].

7 Click OK.

Filter Member Selection

All data object intersections are relative to filter member selections, which focus intersections and data values, and, consequently, analysis. Filter-axis dimensions are by default represented by the highest aggregate member defined in the data source. To focus analysis on members other than the highest aggregate, you can select one filter member per dimension. Filter member selections do not rearrange dimensions or reorganize pages but focus analysis on intersections. Use Filter Selection tabs to navigate through, search, or select the members to use in a filter definition.

Browsing Filter Members

Use the Filter Selection Browse tab to navigate through and select individual members to use as a filter.

➤ To browse and select members:

1 In the Filter pane of the data layout, select a dimension member and select Edit on the shortcut menu.
   The Filter Selection dialog box opens.
2 Select Browse.
3 Select a member and click + to the left of the member name to expand it.
4 To include a member as a filter in the query, in the Available pane, select the member and click ![icon].
   The member is added to the Selected pane.
5 To include a member as a dynamic function, in the Available pane, select the member and select Member on the shortcut menu.
6 Click OK.

Searching Filter Members

Use the Search tab of Filter Selection dialog to search for members within selected dimensions.

Note:

Only the member names and aliases are displayed and not the fully qualified name (for example, [West].[Salem]) in the Member Selection, Catalog or query results.
To search for members:

1. In the Filter pane of the data layout, right click a member and select Edit.
2. Select Search
3. From the Member Type, select the type of filter member to search:
   - Name—Member Name
   - Alias—Alternate Names for database members
   - Both—Member Name and Alias Name
4. Type the text string or numeric value to search in the text box.
   Trailing asterisks and wildcard strings are acceptable. Examples of value text strings: Ja*, M?n, and M??n. Examples of invalid text strings: *-10 and J*n.
5. Click to locate all members within the selected dimension that match the text string or numeric value.
   Hovering the mouse over an item in the Location column shows a tooltip with the member’s full location path.
   The results of the search populate the Available pane.
6. Optional: To add a member to the Selected pane, click
7. Click OK.

Note:
To add a different member as a filter, first remove the selected member.

Note:
A Search by Alias name searches the currently selected Alias Table in Query Options when the Use Aliases option is enabled.

Navigating CubeQuery
For navigating and maintaining data in the CubeQuery section, see:
- Keep Only
- Remove Only
- Suppressing Missing and Zero Values
- Drilling
- Drilling to Shared Members
Keep Only
Focuses one member by allowing you to clear all other dimension member selections except the selected member from the results set. Non-kept members are not available on the Member Selection dialog box.

➤ To keep specific set members:
1 Select one member or a range of members.
   Use Ctrl + click to keep nonadjacent cells.
2 Select a dimension label and select Keep Only on the shortcut menu.
   Only the selected members are shown.

Remove Only
Clears a dimension member to remove it from the query result set. At least one member must be retained to use this feature. Removed members are not included in the results set, but display on Member Selection dialog box as excluded from the query (flagged with a - or minus sign). To add a member again to the query, the exclusion must be removed from the Selected pane.

➤ To remove a selected member:
1 Select one member or a range of members.
   Use Ctrl + click to remove nonadjacent cells.
2 Select a dimension label and select Remove Only on the shortcut menu.
   The member is removed from the report and the query. To add the member to the query again, add it from the Catalog to the data layout, or select it on the Member Selection dialog box.

Suppressing Missing and Zero Values
Suppressing missing and zero values in rows and columns prevents irrelevant information from being returned, reduces network traffic, and increases query speed. Query options box enables you to customize how CubeQuery handles missing and zero values, including the text label displayed for these values by default.

➤ To suppress missing values in rows, select a row and select Suppress > Missing rows on the shortcut menu.
   By default missing values are blank.
➤ To suppress missing values in columns, select a column and select **Suppress > Missing columns** on the shortcut menu.

➤ To suppress zero values in rows, select a row and select **Suppress > Zero rows** on the shortcut menu.

By default zero values are shown as 0 (zero).

➤ To suppress zero values in columns, select a column and select **Suppress > Zero columns** on the shortcut menu.

**Drilling**

Drilling increases or decreases the display of report detail for dimensions with large amounts of level data. It can consist of drilling down (in many forms) or drilling up. Drilling down retrieves more detailed data within a dimension. You can drill down into more detailed data until the lowest level of a dimension as defined in the database outline is reached.

A before and after drill down example is shown below:

Before drilling:

![Before drilling example](image)

After drilling:

![After drilling example](image)

In this example, for Oct, you can drill down to Audio and Visual. Drilling up is the opposite of drilling down, where you move up the hierarchy within a dimension to less detailed data. Query Options enables you to customize the behavior of the drill level. Shortcut menus also control the drill levels.

**Note:**

You cannot drill down on a Date Time Series member.

➤ To drill down to more detail:

1. **Select the member.**
2. **Double-click the member to drill down using the default Drill Level as defined in Query Options.**
Tip:
You can also select a member, and select Drill > Down to drill down using the default drill level defined in Query Options on the shortcut menu.

Additional drill down options include:

- **Down**—Drills down to more dimension detail using the default drill level defined in Query Options.
- **Up**—Drills up to less dimension detail.
- **Next**—Drills down to the children. This is the default Drill Level. For example, a drill on Year retrieves Qtr1, Qtr2, Qtr3, and Qtr4.
- **Bottom**—Drills down to the lowest level of members in a dimension. For example, a drill on Year retrieves Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, and Dec.
- **All Descendants**—Retrieves data for all descendants. For example, a drill on Year retrieves all quarterly and monthly members.
- **Siblings**—Retrieves data for siblings. For example, a drill on Jan retrieves Jan, Feb, and Mar.
- **Same Level**—Retrieves data for all members at the same level. For example, a drill on Sales might retrieve values for COGS, Marketing, Payroll, Misc, Opening Inventory, Additions, Ending Inventory, Margin %, and Profit %.
- **Same Generation**—Retrieves data for all members of the same generation as the selected member or members. For example, a drill on Sales retrieves COGS, Marketing, Payroll, and Misc.

**Drilling to Shared Members**

You can drill down or drill up on a member that has a shared member defined in the Essbase outline. Essbase determines which members are eligible — the base member or the shared member, and returns drilled or stored members based on the drill path.

This is an Essbase outline:

```
Product
   100
      150 (stored member)
         100-10
         100-20

Brand1
   150 (shared member)
```

The stored member 150 has children; the shared member 150 does not. Drilling up and down on 150 gives different results:

- Drilling down on 150 returns nothing if it is interpreted as the shared member; or, returns 100-10 and 100-20 if it is interpreted as the regular member.
Drilling up on 150 returns Brand1 if it is interpreted as the shared member; or returns 100 if it is interpreted as the regular member.

The proximity of the shared member to the regular member gives different results when drilling down. When drilling up on a member that has a shared member, Analytic Server looks at the members to determine which one is being queried. For example, drilling up on 100-20 sometimes returns Diet and returns 100, depending on whether Diet or 100 is closest to the member 100-20. If 100-20 is alone, then Essbase determines that this is the regular member. If Diet is closer, then 100-20 may be interpreted as the shared member.

**Downloading to Results**

Download to Results is an instrument for rendering a flat table representation of the multidimensional Essbase data cubes in Interactive Reporting. The data is loaded into a Result section of Interactive Reporting document, and can be used for further analysis, report creation and joining with data from other relational data sources. In this case the data processing (e.g. aggregation, totaling, custom calculations, table joins) is performed on Interactive Reporting side.

Downloading to Results populates a Results sections with the results of the processed CubeQuery section. Additionally, the results set can be integrated with the Chart, Table, and reporting sections.

Results are only updated when you select the Download to Results feature, or when you take the downloaded results set and process the results again.

To prevent data values from being counted twice, totals and upper level members are not included in the downloaded results set. In the Pivot section, shared members can be excluded from totals by enabling the Aggregate Shared Members option. In addition, in the Pivot section all results are summed. Some Essbase aggregations may not sum member results due to outline calculations and member unary operators (+, -, *, /, ~). As a result, there may be difference shown between Essbase and Pivot totals depending on the outline structure and calculations of the cube.

**Note:**

Shared members can be excluded from the query by way of Query Options, however there are some cases where customers might want to include Shared Members in the query and result set, but not in the totals. If you want to include shared members in the results set, the parent context needs to exist in the query. In other words, if a shared member’s parent does not exist in the query, Download to Results does not recognize that it is a shared member. When downloading to results a query that has a “ragged” member selection, where some parent members are not expanded to details, the warning message appears: "Note that if the source query results are not fully expanded and/or symmetric, invalid flattened results might be returned.". This is necessary for “parent context” of shared members in a results set – shared member parents need to exist in the query in order to determine that they are shared for the results set:
To download the query to results, select Actions > Download to Results.

The behavior of the Download to Results feature varies for different components in CubeQuery:

- **Separate Columns for Metadata Labels**
- **Measure Behavior in Columns and Rows**
- **Ragged Hierarchies**
- **Shared Members**

### Separate Columns for Metadata Labels

Separate columns for metadata labels are displayed for each Essbase generation in the hierarchy.

#### Table 68  CubeQuery Requested Items (Profit Member Applied In the Filter)

<table>
<thead>
<tr>
<th>Product</th>
<th>Qtr1</th>
<th>Qtr2</th>
<th>Qtr3</th>
<th>Qtr4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cola</td>
<td>5096</td>
<td>5892</td>
<td>6583</td>
<td>5206</td>
</tr>
<tr>
<td>Diet Cola</td>
<td>1359</td>
<td>1534</td>
<td>1528</td>
<td>1287</td>
</tr>
<tr>
<td>Caffeine Free Cola</td>
<td>593</td>
<td>446</td>
<td>400</td>
<td>544</td>
</tr>
<tr>
<td>Cola</td>
<td>7048</td>
<td>7872</td>
<td>8511</td>
<td>7037</td>
</tr>
<tr>
<td>Old Fashioned</td>
<td>1697</td>
<td>1734</td>
<td>1883</td>
<td>1887</td>
</tr>
<tr>
<td>Diet Root Beer</td>
<td>2963</td>
<td>3079</td>
<td>3149</td>
<td>2834</td>
</tr>
<tr>
<td>Sarsaparilla</td>
<td>1153</td>
<td>1231</td>
<td>1159</td>
<td>1093</td>
</tr>
<tr>
<td>Birch Beer</td>
<td>908</td>
<td>986</td>
<td>814</td>
<td>1384</td>
</tr>
<tr>
<td>Root Beer</td>
<td>6721</td>
<td>7030</td>
<td>7005</td>
<td>7198</td>
</tr>
</tbody>
</table>

#### Table 69  Results Set

<table>
<thead>
<tr>
<th>Category</th>
<th>Product SKU</th>
<th>Year</th>
<th>Profit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Colas</td>
<td>Cola</td>
<td>Qtr1</td>
<td>5096</td>
</tr>
<tr>
<td>Colas</td>
<td>Diet Cola</td>
<td>Qtr1</td>
<td>1359</td>
</tr>
<tr>
<td>Colas</td>
<td>Caffeine Free Cola</td>
<td>Qtr1</td>
<td>593</td>
</tr>
<tr>
<td>Root Beer</td>
<td>Old Fashioned</td>
<td>Qtr1</td>
<td>1697</td>
</tr>
<tr>
<td>Root Beer</td>
<td>Diet Root Beer</td>
<td>Qtr1</td>
<td>2963</td>
</tr>
<tr>
<td>Root Beer</td>
<td>Sarsaparilla</td>
<td>Qtr1</td>
<td>1153</td>
</tr>
<tr>
<td>Root Beer</td>
<td>Birch Beer</td>
<td>Qtr1</td>
<td>908</td>
</tr>
</tbody>
</table>

If only one generation of the hierarchy is in the query, additional columns do not show the parent members in the Results section as shown below:
### Table 70  CubeQuery Requested Items (Profit Member is in the Columns)

<table>
<thead>
<tr>
<th>Product</th>
<th>Qtr1</th>
<th>Qtr2</th>
<th>Qtr3</th>
<th>Qtr4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cola</td>
<td>5096</td>
<td>5892</td>
<td>6583</td>
<td>5206</td>
</tr>
<tr>
<td>Diet Cola</td>
<td>1359</td>
<td>1534</td>
<td>1528</td>
<td>1287</td>
</tr>
<tr>
<td>Caffeine Free Cola</td>
<td>593</td>
<td>446</td>
<td>400</td>
<td>544</td>
</tr>
<tr>
<td>Old Fashioned</td>
<td>1697</td>
<td>1734</td>
<td>1883</td>
<td>1887</td>
</tr>
<tr>
<td>Diet Root Beer</td>
<td>2963</td>
<td>3079</td>
<td>3149</td>
<td>2834</td>
</tr>
<tr>
<td>Sarsaparilla</td>
<td>1153</td>
<td>1231</td>
<td>1159</td>
<td>1093</td>
</tr>
<tr>
<td>Birch Beer</td>
<td>908</td>
<td>986</td>
<td>814</td>
<td>1384</td>
</tr>
<tr>
<td>Dark Cream</td>
<td>2544</td>
<td>3231</td>
<td>3355</td>
<td>3065</td>
</tr>
</tbody>
</table>

### Table 71  Results Set

<table>
<thead>
<tr>
<th>Product SKU</th>
<th>Quarter</th>
<th>Profit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cola</td>
<td>Qtr1</td>
<td>5096</td>
</tr>
<tr>
<td>Cola</td>
<td>Qtr2</td>
<td>5892</td>
</tr>
<tr>
<td>Cola</td>
<td>Qtr3</td>
<td>6583</td>
</tr>
<tr>
<td>Cola</td>
<td>Qtr4</td>
<td>5206</td>
</tr>
<tr>
<td>Diet Cola</td>
<td>Qtr1</td>
<td>1359</td>
</tr>
<tr>
<td>Diet Cola</td>
<td>Qtr2</td>
<td>1534</td>
</tr>
<tr>
<td>Diet Cola</td>
<td>Qtr3</td>
<td>1528</td>
</tr>
<tr>
<td>Diet Cola</td>
<td>Qtr4</td>
<td>1287</td>
</tr>
<tr>
<td>Caffeine Free Cola</td>
<td>Qtr1</td>
<td>593</td>
</tr>
<tr>
<td>Caffeine Free Cola</td>
<td>Qtr2</td>
<td>446</td>
</tr>
<tr>
<td>Caffeine Free Cola</td>
<td>Qtr3</td>
<td>400</td>
</tr>
<tr>
<td>Caffeine Free Cola</td>
<td>Qtr4</td>
<td>544</td>
</tr>
</tbody>
</table>

### Measure Behavior in Columns and Rows

In the CubeQuery section, the measure dimension is handled like any other dimension (it can be placed in rows or columns), but a separate results set column is created for each Measure member, whether it is in a row, column, or filter.
### Table 72  Measures in CubeQuery

<table>
<thead>
<tr>
<th></th>
<th>Qtr1</th>
<th>Qtr2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cola</td>
<td>14585</td>
<td>16048</td>
</tr>
<tr>
<td>Diet Cola</td>
<td>7276</td>
<td>7957</td>
</tr>
<tr>
<td>COGS</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cola</td>
<td>5681</td>
<td>6136</td>
</tr>
<tr>
<td>Diet Cola</td>
<td>3496</td>
<td>3871</td>
</tr>
<tr>
<td>Caffeine Free Cola</td>
<td>1493</td>
<td>1606</td>
</tr>
</tbody>
</table>

### Table 73  Measures in Results Set

<table>
<thead>
<tr>
<th>Product SKU</th>
<th>Quarter</th>
<th>Sales</th>
<th>COGS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cola</td>
<td>Qtr1</td>
<td>14585</td>
<td>5681</td>
</tr>
<tr>
<td>Diet Cola</td>
<td>Qtr1</td>
<td>7276</td>
<td>3496</td>
</tr>
<tr>
<td>Caffeine Free Cola</td>
<td>Qtr1</td>
<td>3187</td>
<td>1493</td>
</tr>
</tbody>
</table>

If no Measures are in the row, column or filter, all data values appear in a Value column.

### Table 74  Values Column in Results Set

<table>
<thead>
<tr>
<th>Product SKU</th>
<th>Quarter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cola</td>
<td>Qtr1</td>
<td>14585</td>
</tr>
<tr>
<td>Diet Cola</td>
<td>Qtr1</td>
<td>7276</td>
</tr>
<tr>
<td>Caffeine Free Cola</td>
<td>Qtr1</td>
<td>3187</td>
</tr>
</tbody>
</table>

### Ragged Hierarchies

Typically in Essbase, an individual hierarchy has the same number of members above it as any other member at the same level. In a ragged hierarchy, the logical parent member for one member is not in the level directly above the member. When downloading to results a query that has a ragged member selection, and where some parent members are not expanded to details, a warning message is displayed: "Note that if the source query results are not fully expanded and/or symmetric, invalid flattened results might be returned." This message is necessary to show "parent context" or shared member parents need to exist in the query in order to determine that they are shared for the results set.

In the following example Qtr2 does not have children in the query. Because only the lowest level members are included in the query, the results set includes: Jan, Feb, Mar, and Qtr2. For the “month” value for Qtr2, the label is blank.

### Table 75  Ragged Hierarchy in CubeQuery Section

<table>
<thead>
<tr>
<th>Product</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
</tr>
</tbody>
</table>
Table 76  Ragged Hierarchy in Results Set

<table>
<thead>
<tr>
<th>Quarter</th>
<th>Month</th>
<th>Gen1,Product</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Qtr1</td>
<td>Jan</td>
<td>Product</td>
<td>8024</td>
</tr>
<tr>
<td>Qtr1</td>
<td>Feb</td>
<td>Product</td>
<td>8346</td>
</tr>
<tr>
<td>Qtr1</td>
<td>Mar</td>
<td>Product</td>
<td>8333</td>
</tr>
<tr>
<td>Qtr2</td>
<td>(blank)</td>
<td>Product</td>
<td>27107</td>
</tr>
</tbody>
</table>

If a child member does not have a parent member in the original query, the parent or any other ancestor is included in the Results set:

Table 77  Ragged Hierarchy in CubeQuery Section

<table>
<thead>
<tr>
<th>Product</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan</td>
</tr>
<tr>
<td>Feb</td>
</tr>
<tr>
<td>Mar</td>
</tr>
<tr>
<td>Qtr1</td>
</tr>
<tr>
<td>Dec</td>
</tr>
</tbody>
</table>

Table 78  Ragged Hierarchy in Results Set

<table>
<thead>
<tr>
<th>Quarter</th>
<th>Month</th>
<th>Gen1,Product</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Qtr1</td>
<td>Jan</td>
<td>Product</td>
<td>8024</td>
</tr>
<tr>
<td>Qtr1</td>
<td>Feb</td>
<td>Product</td>
<td>8346</td>
</tr>
<tr>
<td>Qtr1</td>
<td>Mar</td>
<td>Product</td>
<td>8333</td>
</tr>
<tr>
<td>Qtr4</td>
<td>Dec</td>
<td>Product</td>
<td>8780</td>
</tr>
</tbody>
</table>

Shared Members

Shared member data can be included in a query, or their totals can be excluded. Each shared member column in the results set corresponds to an Essbase Generation/Field in the results set.
and query. For Shared Members, the parent context must exist in the query. In other words, if a shared member’s parent is not in the query, the Download to Results feature does not recognize that it is a shared member and determine what its parent is. In this case, a warning message is displayed: "Note that if the source query results are not fully expanded and/or symmetric, invalid flattened results might be returned." This message is necessary to show “parent context” or shared member parents must exist in the query in order to determine that they are shared for the results set. For example, in the Sample Basic Product dimension, for the second instance of “100-20” (shared member) to be properly accounted for in the Download to Results, its parent “Diet” must be included in the OLAP query such as “Diet (Children)”.

**Note:**

Shared members are in bold below.

<table>
<thead>
<tr>
<th>Table 79</th>
<th>Shared Members in CubeQuery Section</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Qtr1</td>
</tr>
<tr>
<td>100-10</td>
<td>5096</td>
</tr>
<tr>
<td>100-20</td>
<td>1359</td>
</tr>
<tr>
<td>100-30</td>
<td>593</td>
</tr>
<tr>
<td>100</td>
<td>7048</td>
</tr>
<tr>
<td>200-10</td>
<td>1697</td>
</tr>
<tr>
<td>200-20</td>
<td>2963</td>
</tr>
<tr>
<td>200-30</td>
<td>1153</td>
</tr>
<tr>
<td>200-40</td>
<td>908</td>
</tr>
<tr>
<td>200</td>
<td>6721</td>
</tr>
<tr>
<td>300-10</td>
<td>2544</td>
</tr>
<tr>
<td>300-20</td>
<td>690</td>
</tr>
<tr>
<td>300-30</td>
<td>2695</td>
</tr>
<tr>
<td>300</td>
<td>5929</td>
</tr>
<tr>
<td>400-10</td>
<td>2838</td>
</tr>
<tr>
<td>400-20</td>
<td>2283</td>
</tr>
<tr>
<td>400-30</td>
<td>-116</td>
</tr>
<tr>
<td>400</td>
<td>5005</td>
</tr>
<tr>
<td><strong>100-20</strong></td>
<td>1359</td>
</tr>
<tr>
<td><strong>200-20</strong></td>
<td>2963</td>
</tr>
</tbody>
</table>
Table 80  Shared Members in Results Set

<table>
<thead>
<tr>
<th>Product SKU, Shared</th>
<th>Gen1, Product</th>
<th>Category</th>
<th>Product SKU</th>
<th>Quarter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product</td>
<td>100</td>
<td>100-10</td>
<td>Qtr1</td>
<td>5096</td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>100</td>
<td>100-20</td>
<td>Qtr1</td>
<td>1359</td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>100</td>
<td>100-30</td>
<td>Qtr1</td>
<td>593</td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>200</td>
<td>200-10</td>
<td>Qtr1</td>
<td>1697</td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>200</td>
<td>200-20</td>
<td>Qtr1</td>
<td>2963</td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>200</td>
<td>200-30</td>
<td>Qtr1</td>
<td>1153</td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>200</td>
<td>200-40</td>
<td>Qtr1</td>
<td>908</td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>300</td>
<td>300-10</td>
<td>Qtr1</td>
<td>2544</td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>300</td>
<td>300-20</td>
<td>Qtr1</td>
<td>690</td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>300</td>
<td>300-30</td>
<td>Qtr1</td>
<td>2695</td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>400</td>
<td>400-10</td>
<td>Qtr1</td>
<td>2838</td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>400</td>
<td>400-20</td>
<td>Qtr1</td>
<td>2283</td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>400</td>
<td>400-30</td>
<td>Qtr1</td>
<td>-116</td>
<td></td>
</tr>
<tr>
<td>100–20</td>
<td>Product</td>
<td>Diet</td>
<td>100-20</td>
<td>Qtr1</td>
<td>1359</td>
</tr>
<tr>
<td>200–20</td>
<td>Product</td>
<td>Diet</td>
<td>200-20</td>
<td>Qtr1</td>
<td>2963</td>
</tr>
<tr>
<td>300–30</td>
<td>Product</td>
<td>Diet</td>
<td>300-30</td>
<td>Qtr1</td>
<td>2695</td>
</tr>
</tbody>
</table>

If multiple generation dimensions have shared members, one “shared” indication per dimension is created:

**Note:**

Shared members are in bold below.

Table 81  Multiple Dimensions with Shared Members in CubeQuery Section

<table>
<thead>
<tr>
<th></th>
<th>Qtr1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actual</td>
<td></td>
</tr>
<tr>
<td></td>
<td>100–10</td>
</tr>
</tbody>
</table>
### Table 82  Multiple Dimension With Shared Members in Results Set

<table>
<thead>
<tr>
<th>Scenario, Gen2, Shared</th>
<th>Scenario, Gen2, Shared</th>
<th>Product SKU, Shared</th>
<th>Category</th>
<th>Product SKU</th>
<th>Quarter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actual</td>
<td>100</td>
<td>Actual</td>
<td>100-10</td>
<td>Qtr1</td>
<td></td>
<td>5096</td>
</tr>
<tr>
<td>Actual</td>
<td>100</td>
<td>Actual</td>
<td>100-20</td>
<td>Qtr1</td>
<td></td>
<td>1359</td>
</tr>
<tr>
<td>Actual</td>
<td>100</td>
<td>Actual</td>
<td>100-20</td>
<td>Diet</td>
<td>Qtr1</td>
<td>1359</td>
</tr>
<tr>
<td>Budget</td>
<td>100</td>
<td>Budget</td>
<td>100-10</td>
<td>Qtr1</td>
<td></td>
<td>6510</td>
</tr>
<tr>
<td>Budget</td>
<td>100</td>
<td>Budget</td>
<td>100-20</td>
<td>Qtr1</td>
<td></td>
<td>2240</td>
</tr>
<tr>
<td>Budget</td>
<td>100</td>
<td>Actual</td>
<td>100-20</td>
<td>Diet</td>
<td>Qtr1</td>
<td>2240</td>
</tr>
<tr>
<td>Actual</td>
<td>Actual</td>
<td>Actual</td>
<td>100-10</td>
<td>Qtr1</td>
<td></td>
<td>5096</td>
</tr>
<tr>
<td>Actual</td>
<td>Actual</td>
<td>Actual</td>
<td>100-20</td>
<td>Qtr1</td>
<td></td>
<td>1359</td>
</tr>
<tr>
<td>Actual</td>
<td>Actual</td>
<td>Actual</td>
<td>100-20</td>
<td>Diet</td>
<td>Qtr1</td>
<td>1359</td>
</tr>
</tbody>
</table>

If a dimension contains shared members at multiple generations, a column is added to the results set for each CubeQuery generation and results set column:
Note:
Shared members are in bold below.

Table 83  Shared Members At Multiple Generation Level in the CubeQuery Section

<table>
<thead>
<tr>
<th>Category, Shared</th>
<th>Product SKU, Shared</th>
<th>Gen1, Product</th>
<th>Category</th>
<th>Product SKU</th>
<th>Quarter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>100–10</td>
<td>100</td>
<td>100–10</td>
<td>Qtr1</td>
<td>5096</td>
<td></td>
<td></td>
</tr>
<tr>
<td>100–20</td>
<td>100</td>
<td>100–20</td>
<td>Qtr1</td>
<td>1359</td>
<td></td>
<td></td>
</tr>
<tr>
<td>100–30</td>
<td>100</td>
<td>100–30</td>
<td>Qtr1</td>
<td>593</td>
<td></td>
<td></td>
</tr>
<tr>
<td>100</td>
<td>100</td>
<td>100</td>
<td>Qtr1</td>
<td>7048</td>
<td></td>
<td></td>
</tr>
<tr>
<td>...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>400–10</td>
<td>400</td>
<td>400–10</td>
<td>Qtr1</td>
<td>2838</td>
<td></td>
<td></td>
</tr>
<tr>
<td>400–20</td>
<td>400</td>
<td>400–20</td>
<td>Qtr1</td>
<td>2283</td>
<td></td>
<td></td>
</tr>
<tr>
<td>400–30</td>
<td>400</td>
<td>400–30</td>
<td>Qtr1</td>
<td>-116</td>
<td></td>
<td></td>
</tr>
<tr>
<td>400</td>
<td>400</td>
<td>400</td>
<td>Qtr1</td>
<td>5005</td>
<td></td>
<td></td>
</tr>
<tr>
<td>100–20</td>
<td>400</td>
<td>100–20</td>
<td>Qtr1</td>
<td>1359</td>
<td></td>
<td></td>
</tr>
<tr>
<td>200–20</td>
<td>400</td>
<td>100–20</td>
<td>Qtr1</td>
<td>2963</td>
<td></td>
<td></td>
</tr>
<tr>
<td>300–30</td>
<td>400</td>
<td>100–20</td>
<td>Qtr1</td>
<td>2695</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Diet</td>
<td>7017</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>400</td>
<td>5005</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>24703</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Table 84  Shared Members at Multiple Generation Level in the Results Set

<table>
<thead>
<tr>
<th>Category, Shared</th>
<th>Product SKU, Shared</th>
<th>Gen1, Product</th>
<th>Category</th>
<th>Product SKU</th>
<th>Quarter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product</td>
<td>100</td>
<td>100–10</td>
<td>Qtr1</td>
<td>5096</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>100</td>
<td>100–20</td>
<td>Qtr1</td>
<td>1359</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>100</td>
<td>100–30</td>
<td>Qtr1</td>
<td>593</td>
<td></td>
<td></td>
</tr>
<tr>
<td>...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>400</td>
<td>400–10</td>
<td>Qtr1</td>
<td>2838</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>400</td>
<td>400–20</td>
<td>Qtr1</td>
<td>2283</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>400</td>
<td>400–30</td>
<td>Qtr1</td>
<td>-116</td>
<td></td>
<td></td>
</tr>
<tr>
<td>100–20</td>
<td>Product</td>
<td>Diet</td>
<td>100–20</td>
<td>Qtr1</td>
<td>1359</td>
<td></td>
</tr>
</tbody>
</table>

CubeQuery Section 295
### Formatting CubeQuery Items

Common formatting options are available for CubeQuery items on the Format and shortcut menus including:

- **Auto-size Width**—By default columns and rows are distributed evenly and without regard to the length of data values, which may be truncated. With the auto-size width feature, you can automatically size any column or rows horizontally to fit the text of the largest value in the column.

- **Auto-size Height**—By default columns and rows are distributed evenly and without regard to the length of data values, which may be truncated. With the auto-size height feature, you can automatically size any column or rows vertically to fit the text of the largest value in the column.

- **Number Format**—Options for changing the way numbers, currency values, and dates are displayed throughout or create new custom formats. See [Number Formatting](#).

➤ To auto-size the width of a row or column, select the row or column label and choose **Auto-Size Width**.

➤ To auto-size the height of a row or column, select the row or column label and choose **Auto-Size Height**.

### Query Options

Use the Query Options to define global and local display behavior and drill options. The Query Options dialog box comprises the Global, Display, and Drill tabs.

➤ To display query options, select **Actions > Query Options**.

### Global Options

Use the Global tab to set global display behavior in the CubeQuery section.

<table>
<thead>
<tr>
<th>Design Options</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Auto-Refresh Query</strong></td>
<td>Queries the database automatically when an item is added to or removed from the data layout, or when the Suppress and Replace options in Query Options are changed. If Auto-Refresh is</td>
</tr>
</tbody>
</table>
disabled, you must click Process to query the database whenever you make a change in the
data layout.

**Catalog Options**

<table>
<thead>
<tr>
<th>Number of members to display</th>
<th>Sets the maximum number of members to display in the Catalog List and Member Selection. The number can be:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>● unlimited</td>
</tr>
<tr>
<td></td>
<td>● 5</td>
</tr>
<tr>
<td></td>
<td>● 10</td>
</tr>
<tr>
<td></td>
<td>● 20</td>
</tr>
<tr>
<td></td>
<td>● 50</td>
</tr>
<tr>
<td></td>
<td>● 100</td>
</tr>
<tr>
<td></td>
<td>● 250</td>
</tr>
<tr>
<td></td>
<td>● 500</td>
</tr>
</tbody>
</table>

The default number of members is 50. In both the Catalog List and Member Selection, the “more...” node expands to the next set of members.

**Display Options**

Use the Display tab to set row and column suppression criteria, alias information, and replacement values.

**Suppress**

<table>
<thead>
<tr>
<th>#Missing Rows</th>
<th>Suppress the return of data rows that contain only missing values. If one value is in the row, the row is not suppressed. By default, this option is disabled.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Zero Rows</td>
<td>Suppress the return of data rows that contain only zeros. By default, this option is disabled.</td>
</tr>
<tr>
<td>Shared Members</td>
<td>Suppress the return of members tagged as shared. By default, this option is disabled.</td>
</tr>
<tr>
<td>#Missing Columns</td>
<td>Suppress the return of data columns that contain only missing data. By default, this option is enabled.</td>
</tr>
<tr>
<td>Zero Columns</td>
<td>Suppress the return of data columns that contain only zeros. By default, this option is disabled.</td>
</tr>
</tbody>
</table>

**Aliases**

<table>
<thead>
<tr>
<th>Use Aliases</th>
<th>Display aliases when performing database retrievals rather than database member names. Aliases are alternate names for database members. You can retrieve data that uses the database name, which is often a stock number or product code, or an alias, which can be more descriptive. When this setting is updated, this message is displayed: “The OLAP Tree will be updated automatically with new Alias information and the OLAP Query will be re-processed.”</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select an Alias Table</td>
<td>Specify the alias table to use for alias names. Each database can contain one or more alias tables.</td>
</tr>
</tbody>
</table>
Replacement

Missing Label  Specify a label for missing values. For example, you might enter: #Missing

By default, the replacement value for a missing label is blank.

Zero Label  Specify a label for zero values. By default the replacement value for a zero label is blank.

Drill Options

Use the Drill tab to define the next level of data displayed when you drill down in a CubeQuery. Additionally, the Member Retention option group contains items that enable you to customize drilling retention characteristics.

Drill Level

(Drill Level drop-down)  Defines the next level of data displayed when you drill down from the Query menu, or when you double click a member. Any drill down selection made from the shortcut menu overrides the selection made here. For example, if you select Bottom Level, data for the lowest level of members in a dimension is retrieved. A drill-down on Year retrieves: Jan, Feb, Mar, Apr, Ma, Ju, Jul, Aug, Sep, Oct, Nov, and Dec.

Valid drill down levels are:

- Next Level
- Bottom Level
- All Descendants
- Sibling
- Same Level
- Same Generation

Member Retention

Include Selection  Retains the selected member along with the other members retrieved as a result of a drill down. For example, if you drill down on Qtr1, the data for Jan, Feb, and Mar, as well as Qtr1, is retrieved. When this option is disabled, the data for only for Jan, Feb, and Mar, is retrieved: Qtr1 is eliminated. By default, this option is enabled.

Within Selected Group  Applies (drilling) to only the group of members in which the selection is made. By default, this setting is disabled. It is meaningful only when the report contains two or more dimensions of data down a report as rows or across a report as columns. This type of report is considered asymmetric, which is characterized by groups of nested members that differ by at least one member.

Remove Unselected Groups  Removes all dimension groups that are not in the selected group.

Dashboards

The Dashboard section is a streamlined, push button approach to querying a database. Dashboards are ideal for users who do not have the time to build a query or design a report.
section. Up to the minute thumbnail views of data allow you to explore what is behind trends and indicators.

On opening the file, you have a customized dashboard, which may show embedded reports and navigational buttons and boxes that allow you to retrieve data, and populate controls.

Each button selection, item selection, or navigation sequence can invoke a script created by a Designer. Behind the scene, Interactive Reporting refreshes the Dashboard script commands that allow you to retrieve data, populate controls, hide objects, navigate to different sections, and specify report parameters.

Report Section

The Report section allows you to view high-quality and professionally designed reports. These reports can span anywhere from a complex critical operational report to a results sets, a chart, and a pivot table. Use the reports in this section to help you evaluate your business, expand communications, and assist in the decision-making process.

The reports found here are dynamic and provide you with an almost unfiltered framework from which to view and analyze data. You can resort and apply data functions, which allow you to display different types of values.

Paging Through the Report

By default Interactive Reporting shows a fixed number of rows in a table when a user views a page in a browser. Often data extends beyond the vertical and horizontal rows shown on the page. To view your paging options, see the table below.

<table>
<thead>
<tr>
<th>Paging Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Current Page</td>
<td>The tooltip shows the current page in the report.</td>
</tr>
<tr>
<td>Page Left</td>
<td>Moves one page in the left direction. To move to the first page in the left direction, select [Shift] + Click + left arrow.</td>
</tr>
<tr>
<td>Page Up</td>
<td>Moves one page up. To move to the top page, select [Shift] + Click + Up.</td>
</tr>
<tr>
<td>Page Down</td>
<td>Moves one view in the down direction. To move to the first page in the down direction, select [Shift] + Click + Down arrow.</td>
</tr>
<tr>
<td>Page Right</td>
<td>Moves one page in the right direction. To move to the first page in the right direction, select [Shift] + Click + right arrow.</td>
</tr>
</tbody>
</table>
In This Chapter

- Viewing an SQR Production Reporting Document: 301
- Viewing Functionality for HTML Reports: 302

Viewing an SQR Production Reporting Document

➤ To view an SQR Production Reporting document in Workspace:

1. Run an SQR Production Reporting job in Workspace.
2. Double-click the job output and view the available output formats.
   Depending on the output formats selected when you ran the job, see “Output Options” on page 425, you can select from some or all of the following output formats:
   - HTML file (HTML)
   - Portable Document Format file (PDF)
   - Comma Separated Value file (CSV)
   - Interactive Reporting Data file (BQD)
   - Microsoft Excel file (XLS)
   - SQR Production Reporting Document (SPF)
   - PostScript file (PS)
   - HP Printer file (HP)
   - Line Printer file (LP)
3. Select the desired output format and click Open.

Figure 7 shows some sample output formats for an SQR Production Reporting job.
Figure 7 Sample Output Formats for an SQR Production Reporting Job

Viewing Functionality for HTML Reports

When you view an SQR Production Reporting document in an HTML format, you can navigate from page to page, move to a specific page, or browse with a table of contents. You can also export report information to different output formats directly from the navigation bar that appears at the top of the report.

Using the Navigation Bar

The navigation bar provides options for navigating to different pages within the HTML report and for viewing the report in multiple output formats. Figure 8 labels each item in the navigation bar.
Exporting Report Information from the Navigation Bar

The navigation bar displays icons for viewing an HTML report in different file formats. The icons that appear on the navigation bar are defined in the Navigation Bar tab in the SQR Production Reporting Studio preferences. (See the Hyperion SQR Production Reporting Studio User’s Guide for more information.) Table 86 describes the export options on the navigation bar.

Table 86  Export Options on the Navigation Bar

<table>
<thead>
<tr>
<th>Icon</th>
<th>Message</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Display Table of Contents</td>
<td>Displays the Table of Contents frame.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Display PDF file</td>
<td>Displays the report in a Portable Document Format (PDF) and launches it in a new browser window.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Download the Data in CSV (comma-delimited) format</td>
<td>Downloads the report data in a Comma Separated Value format (CSV) and displays it in a new browser window.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Download the Data in BQD format</td>
<td>Downloads the report data in a Brio Query Data format (BQD) format and displays it in a new browser window.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Display XML file</td>
<td>Displays the report in an XML format and launches it in a new browser window.</td>
</tr>
</tbody>
</table>

Note:
The HTML navigation bar only displays a subset of all the available output formats. See “Viewing an SQR Production Reporting Document” on page 301.

Using the Navigation Bar to Move Among Pages

You can navigate among the pages of a multi-page HTML report by using the paging options on the navigation bar. Table 87 describes the navigation options on the navigation bar.

Table 87  Navigation Options on the Navigation Bar

<table>
<thead>
<tr>
<th>Icon</th>
<th>Message</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Go to First Page</td>
<td>Displays the first page of the report in the current browser window.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Go to Previous Page</td>
<td>Displays the previous page of the report in the browser window.</td>
</tr>
<tr>
<td><img src="image" alt="Icon" /></td>
<td>Go to Next Page</td>
<td>Displays the next page of the report in the browser window.</td>
</tr>
<tr>
<td>Icon</td>
<td>Message</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>---------------------</td>
<td>-------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>Go to Last Page</td>
<td>Displays the last page of the report in the browser window.</td>
</tr>
</tbody>
</table>

### Navigating with the Table of Contents

The table of contents offers standard functionality for navigating through a document. Figure 9 shows an HTML report with the table of contents displayed.

![Figure 9 Table of Contents Displayed for an HTML Report](image)

### Product Sales for Customer: Sam Johnson

**Average Sale:** $1,013.04

**Product Description** | **Date Ordered** | **Quantity** | **Discount**
--- | --- | --- | ---
Big Wheel Bicycle | 1/01/00 | 6 | 10%
Birford 4000 F | 06/19/02 | 10 | 5%
Birford Chain Saw | 09/19/02 | 6 | 10%
Ginger snaps | 02/19/01 | 10 | 12%
Ginger snaps | 06/19/02 | 12 | 16%
Hookup wire | 02/19/01 | 16 | 8%
Light Bulbs | 1/01/00 | 556 | 2%
Modeling clay | 06/19/02 | 2 | 1%
Shawnee Cross Bow | 06/19/02 | 2 | 1%

**Average Quantity:** 59

**Number of Sales:** 11

**Product Sales Chart**

*Quantity per product*
12

In This Chapter

Presentations .................................................................................................................. 306
Opening Presentations ........................................................................................................ 307
Closing Presentations ........................................................................................................ 308
Web Analysis Documents .................................................................................................... 309
Creating Web Analysis Documents ..................................................................................... 309
Creating Documents from Documents .................................................................................. 312
Modifying Queries ............................................................................................................... 313
Selecting Members ............................................................................................................ 314
Advanced Member Selection ............................................................................................... 315
Searching for SAP BW Characteristics .............................................................................. 319
Navigating Data Objects and Sources .................................................................................. 328
Changing Display Types ..................................................................................................... 334
Pinboards .......................................................................................................................... 335
SQL Spreadsheets .............................................................................................................. 336
Freeform Grids .................................................................................................................. 336
Resizing the Display ........................................................................................................... 336
Managing Analysis Tools ................................................................................................... 337
Show/Hide Only .................................................................................................................. 338
Traffic Lighting .................................................................................................................. 341
Sorting .............................................................................................................................. 343
Restrict Data ....................................................................................................................... 345
Retrieve Only Top/Bottom .................................................................................................. 347
Data Formatting .................................................................................................................. 348
Calculations ....................................................................................................................... 350
Print as PDF from Workspace ............................................................................................. 358
Database Connections ........................................................................................................ 359
Analytic Services Database Connections ............................................................................ 361
Financial Management ....................................................................................................... 363
SAP BW ............................................................................................................................. 367
Relational Access ............................................................................................................... 369
Custom Web Analysis Documents ....................................................................................... 370
Linking Components by Query .......................................................................................... 372
Linking Dimensions ............................................................................................................ 373
Presentations

Presentations, playlists of Web Analysis documents, enable documents to be grouped, organized, ordered, distributed, and reviewed. Presentations are lists of pointers that reference repository documents, not documents copied into sets.

Presentation properties govern display and content; file properties control identification, access, and security.

Presentation Access and File Permissions

Because file permission and presentation access operate independently, presentations may be distributed to users who cannot access the documents within them.

Documents for which users do not have list file permission are not listed; documents for which users do not have read file permission cannot be opened.

File permissions that withhold document access prevent all access, directly or through presentations. Presentation permissions that withhold access do not prevent direct document access.

User and Group Permissions

Users can access presentations assigned to them or the groups to which they belong.

Both presentations and the documents within them must be assigned to groups. Otherwise, group members can access the presentations but not the documents within them (unless granted individual access).

To mitigate the risk of conflicting permissions, store presentations and their documents in the same folder. Whenever possible, distribute documents and presentations to groups. It is easier to set permissions for all files in a folder and all users in a group than to manage permissions for individual files and users.

Document and Folder References

You can add two kinds of references to presentations:

- Document—When you add documents directly to a presentation, a reference to a unique document identifier is created in the presentation. Wherever the document is moved, the presentation can locate and present the document.
- Folders—When you add folders to a presentation, the folder reference is directly added to Presentation Content, but documents in the folder are dynamically referenced. Documents added or removed from the folder are automatically added or removed from presentations referencing that folder.

**Note:**

You cannot dynamically include descendant folders, or presentations in target presentations. When adding a folder to a presentation, only documents immediately in the selected folder are dynamically added to the target presentation.

**Benefits and Considerations**

Folder references simplify presentation maintenance because Web Analysis synchronizes presentation playlists with referenced folder content. You can also change folder content without editing its presentation. You must limit write access to the folder to prevent other users from inadvertently adding content to a folder, and subsequently your presentation.

While document references are less flexible and require more maintenance, presentation content is fixed.

**Reference Reconciliation**

When presentations are opened, Web Analysis first attempts to reconcile document references, and then folder references.

If files are copied and the original file deleted, Web Analysis cannot locate the unique file identifier. In this case, Web Analysis searches for files of the correct name at the same location. When a reference cannot be found by means of identifier or location, the reference displays as red in the Presentation Wizard.

**Opening Presentations**

Options for opening presentations:

- Select File > Open > Document or the open toolbar button, and select a presentation file from the Open dialog box.
- Right click the document and Select Open As
  - Click HTML to open the document in an HTML editor.
  - Click Web Analysis Studio to open the document in Web Analysis Studio.
- Use the view pane Tools menu or Explore toolbar button to access the Explore module, and navigate to and select a presentation from a repository location.

➤ To open a presentation, using the Open dialog box:

1. Perform an action:
Select File > Open > Document.

Select the open button.

The Open dialog box displays. It lists current folder content, as specified by Look in.

Right click the document and Select Open As
  - Click HTML to open the document in an HTML editor.
  - Click Web Analysis Studio to open the document in Web Analysis Studio.

2 Optional: From Type, select All Files or Hyperion > Presentation.

3 Navigate to the presentation:
  - From Look In, select a location from the drop down list.
  - Click the Go Up A Level button to display the contents of the parent folder in the selection frame.

As you navigate, the selection frame lists the files and folders indicated by the Files of Type list.

4 Select the presentation.

5 Click OK.

If the first presentation document uses a database connection requiring log on, the Database Login dialog box is displayed.

6 If prompted by the Database Login dialog, enter a valid user name and password, select Save User ID and Password, and click OK.

The selected presentation (and any other selections) display as content tabs below the content area. The first presentation document is opened and displayed as the current document.

Notes on Opening Presentations

- In the Open dialog box, you can select documents, presentations, or both. Multiple files are opened in the order that the Selection frame lists them. The order of documents inside the presentation is observed in the context of the other files being opened.

- If multiple presentations contain multiple instances of a document, only the first instance is opened. It may seem that the document did not open or that documents opened in the wrong order. Only one instance of a document can be opened (and modified) at a time.

Closing Presentations

Unchanged files close. Changed repository files prompt for changes to be saved. Files not previously saved to the repository trigger the Save As dialog box.
To close all opened documents, select **File > Close All.**

**Web Analysis Documents**

Web Analysis documents display in data objects the data values returned from data sources. A document can have multiple data objects, and data objects have a display type:

- Spreadsheet
- Chart
- Pinboard
- SQL spreadsheet
- Freeform grid

You can review all display types, but you can create spreadsheets and charts only by using the new document wizard.

To create a document you are required to specify:

- Data source—provides data values
- Data object—displays these values
- Query—gets data values from the data source and returns them to the data object.

Properties customize each of these elements.

The database connection wizard specifies the type of data source, logon credentials, database applications, dimension formatting and drill-through properties.

Each data object can be set to a display types that features specific formatting options.

Queries can be explicit, requesting information on particular dimension members, or dynamic, requesting information about any dimension member that satisfies a set of criteria.

You have two document creation options:

- Use the new document wizard
- Modify Web Analysis documents and save them under new names or to new locations

**Creating Web Analysis Documents**

A wizard guides you through creating Web Analysis spreadsheets and charts. The wizard requires a database connection. You must know where this database connection is located, and have permission to use it.

To create a document, using the new document wizard:

1. **Select File > New > Document, or select the toolbar New Document button.**

   Depending on the modules installed, you may be prompted to indicate the kind of document you want to create.
2 **Optional**: To create a Web Analysis document, select **Create a Web Analysis document**, and click **Next**.

If you are not prompted, proceed to the next step.

The content area displays **Select a Data Source**. Because the repository stores document definitions and not document data, you must identify a data source and the parameters for connecting to it.

3 **Perform one**:

   - In the text area, enter the path, including the file name, from the root directory (/) to a database connection.
   - Click **Browse**, select a database-connection file from the **Open** dialog box, and click **OK**.

4 **Optional**: Select **Use my active POV**, to populate the query from a predefined point of view definition, and click **Next**.

Performing this step enables you to load members from predefined point of view definitions and to insert dimensions and members with one click. You can define many point of view definitions, but **Use my active POV** applies only the definition set in user preferences as the current point of view.

5 **Optional**: Select **Automatically select one dimension**, to populate and display a simple spreadsheet, and click **Finish**.

Performing this step skips the remaining steps, and uses the highest aggregate members of the time and measures dimensions to populate spreadsheet row and column axes (the quickest method to use the new document wizard to display a spreadsheet).

Selecting **Automatically select one dimension** and **Use my active POV** and clicking **Finish**, skips the remaining steps and displays a simple spreadsheet using the current point of view definition.

6 **Optional**: Select **Use Cube Navigator instead of Wizard** and click **Next** to view the Select Layout dialog box.

   - Select a layout and click **OK**
   
   The Cube Navigator dialog box is displayed.

   - Select the appropriate dimensions and members and click **OK** to render the report.

7 Click **Next**.

   In **Select Row Dimension**, you must select the dimensions to be used on the Rows axis. You are required to have at least one row axis dimension and one column axis dimension.

8 **To move a dimension name from Filters to Rows**, select the name, and click the right arrow.

The dimension name is displayed in the Rows frame. If no point of view definition was previously applied, the highest aggregate member of the dimension is used. If a point of view definition was applied, its members are used.

9 **Optional**: To select members, in **Rows**, double-click a dimension name.

The Dimension Browser dialog box displays. The dimension is presented as a node tree in the Browse frame. You select members from the Browse frame and move them to the Selections frame, using the following methods:
● To expand or contract the hierarchy, click the plus sign (+) or minus sign (-) nodes, or double-click the dimension name.

● To select members, right-click the dimension name, and select **Select Member**. Member names are displayed in the Selections list.

● To select members dynamically, right-click a member name, and select an advanced member selection method.

● Set the label mode for each dimension to the default label, an ID label, or the alias table description set in database connection properties.

For descriptions of Dimension Browser dialog box options, see “Selecting Members” on page 314.

10 After indicating row-axis dimensions and selecting members, click **Next**.

11 Using the methods used to define the row axis, move a dimension name from **Filters** to **Columns**.

12 Optional: To select members, double-click a dimension name in **Columns**.

13 Using Dimension Browser methods, select members, set options, and click **OK**.

14 Click **Next**. In Step 5, you select page-axis dimensions. Although document intersections are relative to member selections, you can organize row and column intersections by page members.

15 Optional: Using the methods used to define row and column axes, move a dimension name from **Filters** to **Pages**.

16 Optional: Using Dimension Browser methods, select page members.

17 Click **Next**. In Step 6, you select filter-axis members.

All dimensions participate in all spreadsheet intersections, regardless of the axes to which dimensions are assigned. Intersection arrangement is defined by row, column, and page axes. Data values displayed at intersections are determined by member selections.

All data-object intersections are relative to filter member selections, which focus intersections, data values, and, consequently, data-object analysis.

Filter-axis dimensions are by default represented by the highest aggregate member defined in the data source outline. If a point of view definition was applied, its member selections are used. If you select Filter members, all intersections are relative to the selections.

18 Optional: To display the Dimension Browser for Filter axis dimensions, double-click a dimension name.

19 Optional: Using Dimension Browser methods, select Filter axis members, and click **OK**.

20 Click **Next**.

21 Optional: Select a layout option:

  Chart—displays the result set as a chart data object.

  Spreadsheet—displays the result set as a spreadsheet data object.
Vertical Combination—displays the result set as both a chart data object and a spreadsheet data object stacked vertically.

Horizontal Combination—displays the result set as both a chart data object and a spreadsheet data object arranged side-by-side.

You can change the display type of Vertical and Horizontal Combination layouts; for example, you can convert the spreadsheet to another chart type. The objects, however, are linked and maintain a coordinated context.

22 Click Finish to submit the query to the data source.

The data source is queried. The result set returned displays as a data object (or objects) on a Web Analysis document.

Creating Documents from Documents

When you save documents with new names or to new locations, you use data sources, data objects, and queries defined in existing documents, leveraging documents to save time and effort. You can modify documents before you save them to new names or locations.

➢ To create a document from a document:

1 Perform one:
   ● Select File > Open > Document.
   ● Select the open button.
     The Open dialog box displays. A selection frame lists contents of the current folder, specified by Look in.
   ● Right click the document and Select Open As
     ◦ Click HTML to open the document in an HTML editor.
     ◦ Click Web Analysis Studio to open the document in Web Analysis Studio.

2 Optional: From Type, select All Files or Hyperion > Web Analysis Document.

3 Navigate to the document to be copied.

4 Select the document, and click Open.

If the document uses a database connection requiring log on, the Database Login dialog box displays.

5 If prompted by the Database Login dialog, enter a valid user name and password, select Save User ID and Password, and click OK.

The selected document displays.

6 Modify the document.

7 Perform one:
   ● Select File > Save As.
   ● Click the toolbar Save As button.
The Save As dialog box displays. A selection frame lists the contents of the current folder, as specified by Look in.

8 Navigate to the folder into which to save your modified document.

9 Optional: After you navigate to the location to save the file, enter a new filename in Name.

10 Click Save.

The modified document is saved to the specified location with the specified name.

### Modifying Queries

Data Layout is a query editing interface. Data Layout displays dimensions returned by the database connection, arranged on four axes:

- **Rows**
- **Columns**
- **Pages**
- **Filters**

Database connections return three types of dimensions.

<table>
<thead>
<tr>
<th>Table 88 Dimension Type</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Icon</strong></td>
</tr>
<tr>
<td><img src="image" alt="Standard" /></td>
</tr>
<tr>
<td><img src="image" alt="Attribute" /></td>
</tr>
<tr>
<td><img src="image" alt="Attribute Calculations" /></td>
</tr>
</tbody>
</table>

All queries must have at least one dimension assigned to the row axis and one dimension assigned to the column axis; multiple dimensions can be nested on one axis. You can organize row and column dimensions by assigning dimensions to the page axis. Dimensions not assigned to rows, columns, and pages are in the filter axis.

All dimensions, regardless of the axes to which they are assigned, participate in all intersections displayed by a data object. You use Data Layout to arrange dimensions, to specify level of detail, and to set query options.

**Note:**

All data objects start as spreadsheets. Charts and pinboards are organized by the four axes, despite using different metaphors to display data.
To redefine the query and dimension layout of the current data object of the current document, click the toolbar Data Layout button.

To move a dimension between axes, drag the dimension to the other axis.

To select members, double-click the dimension name. Dimension Browser is displayed. See “Selecting Members” on page 314.

Modifying Filter Dimensions

All data-object intersections are relative to filter member selections, which focus intersections and data values, and consequently, analysis.

Filter-axis dimensions are by default represented by the highest aggregate member defined in the data source outline. To focus analysis on members other than the highest aggregate, you can select filter members.

Filter member selections do not rearrange dimensions or reorganize pages, but focus analysis on specific intersections.

Selecting Members

Dimension Browser, an interface for selecting members and refining database queries, is used with the new document wizard, Cube Navigator dialog box, Information panel, or on its own.

The Dimension Browser presents dimensions as a node tree in the Browse frame. You must select dimension members from this Browse frame and move them to the Selections frame.

Members can be selected individually, by familial relationships, by data-source-specific option, or from predefined selection lists.

To access Dimension Browser:

- Right-click a member label on a data object, and select Browse.
- In the view pane Information panel, select a dimension name.
- Click the Data Layout button, and double-click a dimension name.
- In the new document wizard, double-click a dimension name.

To expand or collapse hierarchies in Dimension Browser, click the plus sign (+) or minus sign (-) nodes, or double-click a dimension name.

To select a member, right-click the member, and select Select Member.

The member name is displayed in the Selections list. You cannot select the database connection name at the top of the node tree.
To select a member dynamically in Dimension Browser, right-click the member, and select an advanced member selection method from the list.

See “Advanced Member Selection” on page 315.

To remove a member from the Selections list, perform an action:

- Right-click the member in the Browse or Selections list, and deselect the selected selection method.
- Select the member in the Selections list, and click Remove.

To remove all members from the Selection list, click Remove All.

To preview members returned by advanced member selection, before you quit Dimension Browser, click Preview.

To set dimension label mode, select a Dimension Labels option.

- Use Default
- Descriptions—the current alias table
- IDs—the unique ID label
- Both—ID label and description (used in Financial Management)

The label displayed by description is drawn from the alias table specified by the active user’s database preferences. You can set an alias table for each Active Preferences user ID or group ID.

Users can specify label mode in specific dimensions, using Dimension Browser.

Advanced Member Selection

In dimensions with large member sets, users can define selections by using the Dimension Browser right-click menu. Right-clicking member names enables selection by familial relationship and data-source-specific options.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Select Member</td>
<td>Selects the currently member</td>
</tr>
<tr>
<td><img src="icon" alt="tree" /></td>
<td>Also Select Children</td>
<td>Selects the current member and its children</td>
</tr>
<tr>
<td><img src="icon" alt="tree" /></td>
<td>Also Select Descendants</td>
<td>Selects the current member and its descendants</td>
</tr>
<tr>
<td><img src="icon" alt="tree" /></td>
<td>Select Parent</td>
<td>Selects the parent of the current member</td>
</tr>
<tr>
<td><img src="icon" alt="tree" /></td>
<td>Also Select Ancestors</td>
<td>Selects the current member and its ancestors</td>
</tr>
<tr>
<td>Icon</td>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>--------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>Also Select Siblings</td>
<td>Selects the current member and members on its level and of its parent.</td>
</tr>
<tr>
<td></td>
<td>Select Dim Bottom</td>
<td>Selects lowest-level members</td>
</tr>
<tr>
<td></td>
<td>Select Dim Top</td>
<td>Selects the highest ancestor</td>
</tr>
<tr>
<td></td>
<td>Also Select Level</td>
<td>Selects the current member and all members on its level</td>
</tr>
<tr>
<td></td>
<td>Also Select Generation</td>
<td>Selects the current member and all members of its generation</td>
</tr>
<tr>
<td></td>
<td>Also Select Previous</td>
<td>Displays the Previous Selection dialog box, typically used to select previous members at the current level</td>
</tr>
<tr>
<td></td>
<td>Also Select Subset</td>
<td>Displays the Subset dialog box, used to select an Analytic Services member subset.</td>
</tr>
<tr>
<td>No Icon</td>
<td>Substitution Variables</td>
<td>Displays the Substitution Variables dialog box, used to set a substitution variable as the dimension selection</td>
</tr>
<tr>
<td>No Icon</td>
<td>User Defined Fields</td>
<td>When Financial Management is used as a data source, displays the User Defined Fields dialog box, in which you can specify one of three pre-defined attribute values, select members featuring the specified attribute values, and compose compound selection statements with AND and OR</td>
</tr>
<tr>
<td>No Icon</td>
<td>Dynamic Time Series</td>
<td>Displays the Analytic Services Dynamic Time Series menu (for example: History To Date, Quarter To Date)</td>
</tr>
<tr>
<td>No Icon</td>
<td>Search</td>
<td>Displays the Search dialog box, in which you use search criteria to locate members of large dimensions (adds found members to the Selection list)</td>
</tr>
<tr>
<td>No Icon</td>
<td>Find In Tree</td>
<td>Locates members in large dimensions; expands the dimension hierarchy but does not add found members to the Selection list</td>
</tr>
</tbody>
</table>

### Advanced Member Selection by Data Source

Different data sources support different member selection methods.

#### Table 90: Advanced Member Selection by Data Source

<table>
<thead>
<tr>
<th>Data Source</th>
<th>Advanced Member Selection Methods</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analytic Services</td>
<td>● Also Select Children</td>
</tr>
<tr>
<td></td>
<td>● Also Select Descendants</td>
</tr>
<tr>
<td></td>
<td>● Select Parent</td>
</tr>
<tr>
<td></td>
<td>● Also Select Ancestors</td>
</tr>
<tr>
<td></td>
<td>● Also Select Siblings</td>
</tr>
<tr>
<td></td>
<td>● Select Dim Bottom</td>
</tr>
<tr>
<td></td>
<td>● Select Dim Top</td>
</tr>
<tr>
<td></td>
<td>● Also Select Level</td>
</tr>
<tr>
<td>Data Source</td>
<td>Advanced Member Selection Methods</td>
</tr>
<tr>
<td>---------------------------</td>
<td>------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>● Also Select Generation</td>
</tr>
<tr>
<td></td>
<td>● Also Select Previous</td>
</tr>
<tr>
<td></td>
<td>● Select Subset</td>
</tr>
<tr>
<td></td>
<td>● Substitution Variables</td>
</tr>
<tr>
<td></td>
<td>● Dynamic Time Series</td>
</tr>
<tr>
<td></td>
<td>● Search</td>
</tr>
<tr>
<td></td>
<td>● Find in Tree</td>
</tr>
<tr>
<td>SAP BW</td>
<td>● All Members</td>
</tr>
<tr>
<td></td>
<td>● Select Dim Top</td>
</tr>
<tr>
<td></td>
<td>● Select Dim Bottom</td>
</tr>
<tr>
<td></td>
<td>● Also Select Descendants</td>
</tr>
<tr>
<td></td>
<td>● Select Parent</td>
</tr>
<tr>
<td></td>
<td>● Also Select Ancestors</td>
</tr>
<tr>
<td></td>
<td>● Also Select Children</td>
</tr>
<tr>
<td></td>
<td>● Also Select Siblings</td>
</tr>
<tr>
<td></td>
<td>● Also Select Level</td>
</tr>
<tr>
<td></td>
<td>● Select At Level</td>
</tr>
<tr>
<td></td>
<td>● Also Select Previous</td>
</tr>
<tr>
<td></td>
<td>● Also Select Next</td>
</tr>
<tr>
<td></td>
<td>● Dynamic Time Series</td>
</tr>
<tr>
<td></td>
<td>● Select Top/Bottom</td>
</tr>
<tr>
<td></td>
<td>● Filter on Member Properties</td>
</tr>
<tr>
<td></td>
<td>● Find in Tree</td>
</tr>
<tr>
<td>Financial Management</td>
<td>● All Members</td>
</tr>
<tr>
<td></td>
<td>● Select Dim Top</td>
</tr>
<tr>
<td></td>
<td>● Select Dim Bottom</td>
</tr>
<tr>
<td></td>
<td>● Also Select Descendants</td>
</tr>
<tr>
<td></td>
<td>● Member List</td>
</tr>
<tr>
<td></td>
<td>● Also Select Children</td>
</tr>
<tr>
<td></td>
<td>● User Defined Field</td>
</tr>
<tr>
<td></td>
<td>● Search</td>
</tr>
<tr>
<td></td>
<td>● Find in Tree</td>
</tr>
<tr>
<td>JDBC Relational Data Sources</td>
<td>● Also Select Children</td>
</tr>
<tr>
<td></td>
<td>● Also Select Descendants</td>
</tr>
<tr>
<td></td>
<td>● Select Parent</td>
</tr>
<tr>
<td></td>
<td>● Also Select Ancestors</td>
</tr>
<tr>
<td></td>
<td>● Also Select Siblings</td>
</tr>
<tr>
<td></td>
<td>● Select Dim Bottom</td>
</tr>
<tr>
<td></td>
<td>● Select Dim Top</td>
</tr>
</tbody>
</table>
Consider relational-hierarchy implications in advanced member selections on relational data sources. When highest ancestors are selected, default members, rather than aggregations, may be used. For example, the relational hierarchy may equate Also Select Children and Also Select Descendants.

### Searching for Members

Analytic Services and Financial Management users can locate members in large dimensions by using search criteria. Searches can be conducted inside Dimension Browser (during query creation) or from the data-object right-click menu (during document analysis).

To search for Analytic Services or Financial Management members in Dimension Browser:

1. Right-click a member.
2. Select Search.
3. Enter search criteria in the text boxes.
4. Click OK.

<table>
<thead>
<tr>
<th>Search Criteria</th>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Member</td>
<td></td>
<td>Searches by text string</td>
</tr>
<tr>
<td>Mode</td>
<td>ID</td>
<td>Searches by member name</td>
</tr>
<tr>
<td>Description</td>
<td></td>
<td>Searches by member alias</td>
</tr>
<tr>
<td>Both</td>
<td></td>
<td>Searches by ID and description (Financial Management data sources only)</td>
</tr>
<tr>
<td>Find In Tree</td>
<td></td>
<td>If Expand Tree is selected, adds members to the Selections list and expands the Browse node tree to display the members in the hierarchy (only the first search-criteria instance is selected) If Expand Tree is not selected, adds found members to the Selections list</td>
</tr>
<tr>
<td>Range</td>
<td></td>
<td>Searches the entire dimension or down the hierarchy from the right-clicked member</td>
</tr>
<tr>
<td>Option</td>
<td>Whole</td>
<td>Searches for the whole member name or alias</td>
</tr>
<tr>
<td></td>
<td>Substring</td>
<td>Searches for the first, last, or middle part of the member name, in the order entered in the member text box</td>
</tr>
<tr>
<td></td>
<td>Beginning</td>
<td>Searches for the start of the member string</td>
</tr>
<tr>
<td></td>
<td>Ending</td>
<td>Searches for the end of the member string</td>
</tr>
</tbody>
</table>
To search for Analytic Services members in a Web Analysis data object:

1. Right-click a member, and select Search from the right-click menu.
2. Enter search criteria in the text boxes, and click OK.

**Note:**
Search performance is directly related to size and complexity of the dimension hierarchy.

**Searching for SAP BW Characteristics**

SAP BW users can locate characteristics in large dimension hierarchies by using search criteria. The searches can be conducted only inside Dimension Browser during composition of a query.

To locate SAP BW members in Dimension Browser:

1. Right-click a member.
2. Select Search.
3. Enter search criteria in the text boxes.

### Table 92 SAP BW Search Criteria

<table>
<thead>
<tr>
<th>Search Criteria</th>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Mode</td>
<td>ID</td>
<td>Searches by member technical name</td>
</tr>
<tr>
<td>Description</td>
<td></td>
<td>Searches by member alias</td>
</tr>
<tr>
<td>Search Criteria</td>
<td></td>
<td>Searches using an operand:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>● Equal To</td>
</tr>
<tr>
<td></td>
<td></td>
<td>● &gt;=</td>
</tr>
<tr>
<td></td>
<td></td>
<td>● &lt;=</td>
</tr>
<tr>
<td></td>
<td></td>
<td>● &gt;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>● &lt;</td>
</tr>
<tr>
<td></td>
<td></td>
<td>● Between</td>
</tr>
<tr>
<td></td>
<td></td>
<td>● Contains Pattern</td>
</tr>
<tr>
<td>Execute</td>
<td></td>
<td>Runs the search function</td>
</tr>
<tr>
<td>Filtered Members</td>
<td></td>
<td>Displays the search result set</td>
</tr>
<tr>
<td>Add</td>
<td></td>
<td>Moves the selected member from the Filtered Members list to the Selected Members list.</td>
</tr>
<tr>
<td>Remove</td>
<td></td>
<td>Moves the selected member from the Selected Members list to the Filtered Members list.</td>
</tr>
<tr>
<td>Selected Members</td>
<td></td>
<td>Displays members of the search result set</td>
</tr>
<tr>
<td>Search Criteria</td>
<td>Control</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td>Add All</td>
<td></td>
<td>Moves all filtered members to the Selected Members list</td>
</tr>
<tr>
<td>Remove All</td>
<td></td>
<td>Moves all selected members to the Filtered Members list</td>
</tr>
<tr>
<td>OK</td>
<td></td>
<td>Adds the Search Selected Members list to the Dimension Browser Selections list</td>
</tr>
</tbody>
</table>

4 Click **Execute** to run the search function using the criteria specified in the Mode and Search Criteria group boxes.

The search result set is displayed in the Filtered Members box.

5 **Select members from the Filtered Members list,** and click **Add** to add them to the **Selected Members list**. Only Selected Members list members are added are added to the Dimension Browser Selections list when you click **OK**.

6 **Click OK.**

### Locating Members

In large or complex dimension hierarchies, you can locate known members to select other members, rather than composing search strings for unknown members.

➢ To find a known member in the dimension hierarchy:

1 **In Dimension Browser,** from **Selections,** right-click a member.

2 **Select Find In Tree.**

   In the Browse frame, the dimension hierarchy is expanded, and the first instance of the selected member is highlighted. You can now select members based on their relationship to the selected member.

### Selecting Members Using Analytic Services Subsets

Analytic Services users can define rules that select dimension member subsets by criterion. These rules are composed of the following items:

- UDA—user-defined attributes
- Generation—generation within the dimension hierarchy
- Level—level within the dimensional hierarchy
- Expression—pattern of wildcard characters
- Attribute dimensions—database-defined attributes
- Conditional logic—advanced subset member selection criteria

You can search all selected member descendants using a maximum of 50 subset conditions. Subset criteria are saved by document in the repository. Because the filter panel cannot
To define a member subset selection:

1. In Dimension Browser, right-click a member.
2. Select Select Subset.

The Subset dialog box displays. At the top, it indicates dimension members against which the rule is applied. Use the Individual Selection Rule control to compose a rule by selecting components from drop down lists.

3. Select a type: UDA, Generation, Level, Expression, or Attribute.
4. Select an operand: is (=) or is not (not equal).
5. From the last list, select a value.
6. Click Add.

You must add the rule to Total Subset Definition for it to be used. You can define compound and conditional rules by adding multiple rules to the definition and using the Advanced button to connect them.

<table>
<thead>
<tr>
<th>Option</th>
<th>Submenu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td></td>
<td>Rule added to Total Subset Definition</td>
</tr>
<tr>
<td>Update</td>
<td></td>
<td>Rule replaced by another rule</td>
</tr>
<tr>
<td>Validate</td>
<td></td>
<td>Parenthetical syntax of Total Subset Definition verified</td>
</tr>
<tr>
<td>Remove</td>
<td></td>
<td>Rule deleted from Total Subset Definition</td>
</tr>
<tr>
<td>Remove All</td>
<td></td>
<td>All rules deleted from Total Subset Definition</td>
</tr>
<tr>
<td>Connect</td>
<td>And</td>
<td>AND inserted at end (AND is used by default when multiple rules are added to the definition.)</td>
</tr>
<tr>
<td></td>
<td>Or</td>
<td>OR inserted at end</td>
</tr>
<tr>
<td>Move</td>
<td>Move Up</td>
<td>Rule moved up in Total Subset Definition</td>
</tr>
<tr>
<td></td>
<td>Move Down</td>
<td>Rule moved down in Total Subset Definition</td>
</tr>
<tr>
<td>Parenthesis</td>
<td>Add (</td>
<td>Open parenthesis inserted at beginning</td>
</tr>
<tr>
<td></td>
<td>Add )</td>
<td>Close parenthesis inserted at end</td>
</tr>
<tr>
<td></td>
<td>Remove (</td>
<td>Open parenthesis deleted</td>
</tr>
<tr>
<td></td>
<td>Remove )</td>
<td>Close parenthesis deleted</td>
</tr>
<tr>
<td></td>
<td>Remove All (</td>
<td>All parentheses deleted from Total Subset Definition</td>
</tr>
</tbody>
</table>

Searching for SAP BW Characteristics 321
<table>
<thead>
<tr>
<th>Option</th>
<th>Submenu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Substitution Variable</td>
<td></td>
<td>Substitution Variable dialog box presented, enabling you to select a pre-</td>
</tr>
<tr>
<td></td>
<td></td>
<td>defined substitution variable for the rule value</td>
</tr>
</tbody>
</table>

7. **Optional:** To compose a compound subset definition, repeat steps 3 through 6.

8. Click **OK**.

### Wildcard Characters

Supported wildcard characters include the question mark (?) and the asterisk (*), which can be used only once in an expression and only at the end of a text string.

### Expressions

Subset queries defined by expressions are not dependent upon label mode, returning all strings satisfying the expressions regardless of the alias table. Users must determine whether value sources are ID, description, or from alias tables and refine queries as needed.

### UDAs

Web Analysis enables Analytic Services users to create user-defined attributes (UDAs), words or phrases associated with and defining characteristics of members, for member subsets.

### Selecting Financial Management User-Defined Fields

Financial Management users can select members with specified attribute criteria. User-defined fields define compound selection rules for attributes of a specified value.

- To define a user-defined field selection:

1. In Dimension Browser, right-click a member.

2. Select **User Defined Field**.

   The User Defined Field Selection dialog box is displayed. The controls at the top prompt you to compose a rule.

3. **Select a field:** `UserDefined1`, `UserDefined2`, or `UserDefined3`.

   The equal sign is the sole operand for the rule.

4. **Enter a value**.

5. **Click Add**.

   To be used, the individual rule must be added to the Selection Criteria. Define compound and conditional rules by adding multiple rules to the frame, and using Advanced options to connect them.
Table 94  Advanced User-Defined Field Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Submenu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td></td>
<td>Rule added to Selection Criteria</td>
</tr>
<tr>
<td>Update</td>
<td></td>
<td>Rule replaced by another rule</td>
</tr>
<tr>
<td>Remove</td>
<td></td>
<td>Rule deleted from Selection Criteria</td>
</tr>
<tr>
<td>Remove All</td>
<td></td>
<td>All rules deleted from Selection Criteria</td>
</tr>
<tr>
<td>Connect</td>
<td>And</td>
<td>AND inserted at end (AND is used by default when multiple rules are added to the definition.)</td>
</tr>
<tr>
<td></td>
<td>Or</td>
<td>OR inserted at end</td>
</tr>
<tr>
<td>Move</td>
<td>Move Up</td>
<td>Rule moved up in Selection Criteria</td>
</tr>
<tr>
<td></td>
<td>Move Down</td>
<td>Rule moved down in Selection Criteria</td>
</tr>
<tr>
<td>Parenthesis</td>
<td>Add (</td>
<td>Open parenthesis inserted at beginning</td>
</tr>
<tr>
<td></td>
<td>Add )</td>
<td>Close parenthesis inserted at end</td>
</tr>
<tr>
<td></td>
<td>Remove (</td>
<td>Open parenthesis deleted</td>
</tr>
<tr>
<td></td>
<td>Remove )</td>
<td>Close parenthesis deleted</td>
</tr>
</tbody>
</table>

6 Optional: To compose compound subset definitions, repeat steps 3 through 5.

7 Click OK.

Filtering by SAP BW Member Properties

SAP uses the term member properties to refer to member attributes. You can select SAP BW members and filter them by their member properties. You select the members and then define filtering definitions on the selections.

➢ To select SAP BW members by their member properties:

1 In Dimension Browser, select a member.

   The member is displayed in the Selection frame.

2 Right-click the member, and select Filter on Member Properties.

   The Member Properties dialog box is displayed. The controls at the top prompt you to compose a rule.

3 From the list, select a member property.

4 Select an operand.

5 In the text area, enter a value for the member property.

6 Click Add.
You must add the rule to the filter definition for it to be used. You can use multiple rules to create compound definitions.

<table>
<thead>
<tr>
<th>Option</th>
<th>Submenu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add</td>
<td></td>
<td>Rule added to the filter definition</td>
</tr>
<tr>
<td>Update</td>
<td></td>
<td>Rule replaced by another rule</td>
</tr>
<tr>
<td>Remove</td>
<td></td>
<td>Rule deleted from the filter definition</td>
</tr>
<tr>
<td>Remove All</td>
<td></td>
<td>All rules deleted from the filter definition</td>
</tr>
<tr>
<td>Parenthesis Add (</td>
<td>Add (</td>
<td>Open parenthesis inserted at beginning</td>
</tr>
<tr>
<td></td>
<td>)</td>
<td>Close parenthesis inserted at end</td>
</tr>
<tr>
<td></td>
<td>Remove (</td>
<td>Open parenthesis deleted</td>
</tr>
<tr>
<td></td>
<td>Remove )</td>
<td>Close parenthesis deleted</td>
</tr>
<tr>
<td>Connect</td>
<td>And</td>
<td>AND inserted at end (AND is used by default when multiple rules are added to the definition.)</td>
</tr>
<tr>
<td></td>
<td>Or</td>
<td>OR inserted at end</td>
</tr>
<tr>
<td>Move</td>
<td>Move Up</td>
<td>Rule moved up in the filter definition</td>
</tr>
<tr>
<td></td>
<td>Move Down</td>
<td>Rule moved down in the filter definition</td>
</tr>
</tbody>
</table>

7 Optional: To compose compound definitions, repeat steps 3 through 6.

8 Click OK.

**Using SAP BW Select Top/Bottom**

SAP BW enables you to limit the size of and rank query result sets. You select members and then define filtering definitions on the selections.

To limit and rank SAP BW members as part of the query:

1 In **Dimension Browser**, select a member.
   - The member is displayed in the Selection frame.

2 Right-click the member, and select **Select Top/Bottom**.
   - The Top/Bottom dialog box is displayed.

3 Select **Top or Bottom**.
   - You cannot select both, as you can with Analytic Services.

4 From **Using Function**, select **Percent, Sum, or Count**.
   - You can determine rank by only one method.
5 In the text area, enter a value for the selected method.

For Percent, use a value between one and one hundred. For Sum, enter a threshold. All member values summed up to and including the threshold are returned. For Count, provide an integer, to indicate how many top or bottom members to return.

6 In Order By, select a dimension.

Because all dimensions participate in all intersections, you must identify the intersection by which the selected dimension is ranked.

7 Optional: Click Selection.

Dimension Browser for the Order By dimension is displayed. You can select a member of the Order By dimension by which to rank the selected dimension.

8 Click OK.

Selecting Financial Management Member Lists

Member lists are predefined variables, used for frequently changing information, created using Financial Management, and identified by variable names.

➤ To use a Financial Management member list in a Dimension Browser member selection:

1 In Dimension Browser, right-click a member.

2 Select Member List.

3 From Choose Member List, select a member list.

4 Click OK.

Selecting Substitution Variables

Substitution variables are predefined variables, used for frequently changing information, created using Analytic Services, and identified by variable names.

Substitution variables simplify document maintenance, enabling fluctuating values to be adjusted centrally (in Analytic Services) and to be referenced dynamically (by Web Analysis documents).

➤ To use a substitution variable in a Dimension Browser member selection:

1 In Dimension Browser, right-click a member.

2 Select Substitution Variable.

3 Select a substitution variable.

4 Click OK.
Multiple Substitution Variables

Multiple substitution variables can be used using Subset Member Selections.

Syntax Tips

Substitution variables have specific rules and syntax requirements:
- For substituted values, use dimension or member names.
- Do not use ampersands (&) as the first character of member names.

Analysis Tools and Substitution Variables

When member selections defined by substitution variables are used in analysis tool definitions, the variables are resolved to their current values, ensuring accurate aggregations, comparisons, and calculations, regardless of the substitution-variable definition.

Selecting Personal Variables

Personal variables, containers for ad hoc collections of otherwise unrelated members, enable users to define and name complex member selections. To leverage personal variables, you must be presented with relevant dimensions and database connections.

Defining personal variables does not include them in queries. You select personal variables from Dimension Browser when you define queries.

➤ To use a personal variable in a query, select the personal variable definition from the Dimension Browser Browse panel.

Applying Point of View (POV)

POV database preferences enable users to insert dimensions and members into the documents of others. Definitions must be defined and activated for specific database connections.

When a POV is activated, the Use Point of View check box in the new document wizard is enabled. Documents created when Use Point of View is selected use the active POV.

Workspace users cannot create or activate POV definitions. But, they can select database connections with activated POV definitions and apply the definitions to documents that they are creating. Workspace users cannot apply POV definitions to documents.

POV definitions consist of axes and member selections. Entire definitions are used when documents are created with activated POVs.

If all POV member selections are custom filters, you may not see changes in your document. You can check Point of View, of the view pane Information tab, to see which POV, if any, is applied.
Using POV definitions is a three-part process:

1. Use Web Analysis Studio to create a POV definition.
2. Use Web Analysis Studio to activate the definition.
3. Set a document (existing or newly created) to use the definition.

To apply an activated POV definition to a new document:

1. Perform an action:
   - Select File > New Document.
   - Click the new button.
     The steps for creating documents are displayed.
2. Click Browse.
3. From the Open dialog box, select the file of the database connection that uses the activated POV definition that you want to use, and click OK.

Defining Dynamic Time Series Selections

You can select Dynamic Time Series (DTS) definitions, created in Analytic Services, for query selection statements. To define time periods, users select DTS definitions and time members.

Time Substitution Variables

You can select DTS substitution variables.

Substitution variables are predefined placeholders, used for frequently changing information, identified by variable names, and having temporary values that define data type. When substitution variables are used, temporary values are replaced by current values. Substitution variables are stored at the database level in Analytic Services.

To define a DTS selection:

1. In Dimension Browser, right-click a time member.
2. Select Dynamic Time Series.
   The Dynamic Time Series dialog box is displayed, listing DTS definitions as option buttons and substitution variables in a list.
3. Select a DTS definition option.
4. Perform an action:
   - Select the Substitution Variables tab, and then select a substitution variable.
   - Select the Members tab, and then select a member to represent the date in the X-to-date definition.
5. Click OK.
Defining Previous Member Selections

Selecting Also Select Previous from the Dimension Browser right-click menu displays the Also Select Previous dialog box, used to select previous members at one dimension level.

➤ To define a previous member selection:

1. In Dimension Browser, in Browse, right-click a member.
2. Select Also Select Previous.
   The Also Select Previous dialog box is displayed.
3. Specify how many previous members to retrieve.
4. Click OK.
   Dimension Browser is displayed. The member that you right-clicked is displayed in the Selections list with the Also Select Previous icon.

Navigating Data Objects and Sources

Web Analysis documents can contain a variety of data objects:

- Spreadsheets
- Charts
- Pinboards
- SQL spreadsheets
- Freeform grids

Despite their diversity, data objects are not static. You can rearrange, expand, change, and concentrate dimension intersections. These methods, called navigation methods, enable travel through dimensional hierarchies.

Navigation methods are specific to data object and data source.

<table>
<thead>
<tr>
<th>Table 96</th>
<th>Supported Data Sources</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Type</strong></td>
<td><strong>Data Source</strong></td>
</tr>
<tr>
<td>OLAP</td>
<td>Analytic Services</td>
</tr>
<tr>
<td></td>
<td>IBM DB2 OLAP Server</td>
</tr>
<tr>
<td></td>
<td>SAP BW</td>
</tr>
<tr>
<td>Hyperion</td>
<td>Financial Management</td>
</tr>
<tr>
<td></td>
<td>Planning</td>
</tr>
<tr>
<td>Relational</td>
<td>IBM DB2 Enterprise Server Edition</td>
</tr>
<tr>
<td></td>
<td>Microsoft SQL Server</td>
</tr>
<tr>
<td></td>
<td>Oracle</td>
</tr>
<tr>
<td>Type</td>
<td>Data Source</td>
</tr>
<tr>
<td>----------------------</td>
<td>----------------------</td>
</tr>
<tr>
<td></td>
<td>Teradata</td>
</tr>
<tr>
<td></td>
<td>Other JDBC RDBMS</td>
</tr>
</tbody>
</table>

OLAP data sources support the navigation methods described in this chapter. Other Hyperion data sources and relational data sources support fewer navigation methods.

## Navigation Methods

Hyperion System 9 uses various navigation methods:

### Table 97  Navigation Methods

<table>
<thead>
<tr>
<th>Navigation</th>
<th>Description</th>
<th>Method</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move</td>
<td>Relocates dimensions on data-layout axes</td>
<td>Position dimensions on or between axes, using the Data Layout dialog box, Information panel, or new document wizard</td>
</tr>
<tr>
<td>Paging</td>
<td>Maintains dimensions on their row and column axes, while changing their intersections on the page axis</td>
<td>Click or scroll the Page Control panel. See “Paging” on page 330.</td>
</tr>
<tr>
<td>Keep Only</td>
<td>Retains one member of the selected dimension, while deselecting all other members</td>
<td>Right-click a member and select Keep Only. See “Keep Only” on page 331</td>
</tr>
<tr>
<td>Remove Only</td>
<td>Deselects the selected member, removing it from the query result set</td>
<td>Right-click a member, and select Remove Only. See “Remove Only” on page 331</td>
</tr>
<tr>
<td>Drilling</td>
<td>Increases or decreases dimension detail by displaying or not displaying members in the hierarchy</td>
<td>Double-click members. You can customize drilling behavior. See “Drilling” on page 331</td>
</tr>
<tr>
<td>Drill-Linking</td>
<td>Navigates to other documents or executables</td>
<td>Click a linked cell and pass the cell and the dimension context to another data object or document</td>
</tr>
<tr>
<td>Custom Controls</td>
<td>Define Web Analysis navigation</td>
<td>Use a custom document component to change the query. While Web Analysis users can use custom document components, you can only create these components in the Web Analysis Studio.</td>
</tr>
</tbody>
</table>

Navigation method specifics:

- **Drilling**—Navigates to related members
- **Linking (called drill-linking)**—Passes selected members to other documents
- **Linked reporting objects (LROs)**—Open executables to display cell-notes, Windows executables, or Web page URLs.
Repositioning Dimensions

You can rearrange intersections by repositioning dimensions on or between axes.

➤ To reposition a dimension, using the Data Layout dialog box, click the data layout button, and drag the dimension from its current positions to another position on the current axis or to another axis.

Note:
Document creators use Properties to lock the ability to swap and move dimensions.

➤ To reposition a dimension, using the view pane Information panel:

1. Select View > View Pane.
2. Click the information panel button to make Information the current tab.
3. Scroll to the Filter, Page, Row, and Column trees to review placement of the current data object.
4. Drag the dimension from one axis tree to another axis tree.

Note:
You must have at least one row and one column dimension. If repositioning leaves a row or column axis empty, use Data Layout to rearrange the dimension layout.

Paging

Paging maintains dimensions on row and column axes, while changing their intersections on the Page axis.

You can jump or scroll through pages of intersections by using the Page Control panel.

➤ To display the Page Control panel, select View > Pages.

The Page Control panel displays in the content area above the relevant data object, organizing Page axis intersections so that each page is relevant to one Page member.

➤ To navigate the Page dimension, perform an action:

- Click < and > to move up and down in the page series.
- From the list box, select a page member by name.

Pages

Think of the Page axis as the Z-axis of a three-dimensional graph. Visualize a stack of spreadsheets. You navigate the stack to compare values among pages. The spreadsheets represent Page axis dimensions, and the pages represent Page axis members or member combinations.
**Multiple-Page and Single-Page List Boxes**

When you work with page dimension combinations, the Page Control panel can display multiple-page list boxes, which display all possible page combinations, whether or not data exists. Single-page list boxes omit page combinations that do not contain data. Hyperion recommends using single-page list boxes when working with sparse dimensions.

> To separate or combine Page dimensions into multiple-page list boxes, click **Toggle Multipage**.

**Keep Only**

Keep Only deselects all but one member of the selected dimension.

> To deselect all but one member of a dimension, right-click the member, and select **Keep Only**.

**Remove Only**

Remove Only deselects a member, removing it from the query result set.

> To remove one member from the query result set, right-click a member, and select **Remove Only**.

**Drilling**

Drilling increases or decreases data-object detail by changing the member display. Because drilling is customizable, the term *drilling* refers to almost any hierarchical navigation prompted by clicking a dimension label.

Three types of drilling options:

- Drilling options specify the result set.
- Expand on Drill specifies whether the result set replaces or augments the currently displayed members.
- The Selected Member data-display option specifies whether the drilled member is included in the result set.

Web Analysis users must use the data-object, right-click menu to set drill options. Expand on Drill and Selected Member options are set by user preferences in Web Analysis Studio.

**Drilling Options**

Web Analysis Studio features these default drilling behaviors:

- Drill Down includes a member's children in the display.
Drill Up includes a member's parent in the display.

Drill to Top includes the highest ancestor in the display.

You can customize drilling by setting drilling options. Drilling options are set for the current document through the data object shortcut menu (Drill > Drill Options). Drilling options can also be set for all subsequently created documents through Drilling preferences.

This table describes Web Analysis Studio drilling options:

<table>
<thead>
<tr>
<th>Drilling Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drill to Next Level</td>
<td>Includes the children of the drilled member in the display.</td>
</tr>
<tr>
<td>Drill to Descendants</td>
<td>Includes all descendants of the drilled member in the display.</td>
</tr>
<tr>
<td>Drill to Dim Bottom</td>
<td>Includes the lowest level descendants of the drilled member in the display.</td>
</tr>
<tr>
<td>Drill to Siblings</td>
<td>Includes members at one level who share a parent with the drilled member.</td>
</tr>
<tr>
<td>Drill to Same Level</td>
<td>Includes all members on the drilled member's level.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Hyperion defines levels as hierarchical layers counted up from the</td>
</tr>
<tr>
<td></td>
<td>lowest descendant (Level 0). Other data sources define levels differently.</td>
</tr>
<tr>
<td></td>
<td>Asymmetric hierarchies may also yield unexpected results.</td>
</tr>
<tr>
<td>Drill to Same Generation</td>
<td>Includes all members on the drilled member's generation.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> Hyperion defines generations as hierarchical layers counted down from the highest ancestor (Generation 0). Other data sources define generations differently.</td>
</tr>
</tbody>
</table>

Drilling options are data-source specific. Drilling options that are not supported by the data source default to Drill to Next Level.

**Expand on Drill**

The Expand on Drill drilling option sets the drilling return set to augment or replace currently displayed dimension members. You can set Expand on Drill for the current document through the data object shortcut menu (Drill > Drill Options). Expand on Drill can also be set for all subsequently created documents through Drilling preferences.

When Expand on Drill is selected the drilling return set is added to currently displayed dimension members. When Expand on drill is disabled the drilling return set replaces currently displayed dimension members.

**Selected Member Data Display Option**

The Selected Member data display option specifies that the query result set should include the member from which advanced member selections are defined.

**For example:** If you specify Also Select Children on the Year dimension member and Selected Member is enabled, Year and all of its children are returned by the query. When Selected Member is disabled, only the children of year are returned.
This Selected Member functionality also impacts the drilling result set, by including or excluding the drilled member in the drilling result set.

Additionally, you can enable the Selected Member First data display option, to ensure that the drilled member is listed above the drilling result set.

**Drilling Variations**

These data display and drilling option combinations result in drilling return sets that differ. If you are aware of this dynamic you are better prepared to receive the intended drilling return set.

<table>
<thead>
<tr>
<th>Drilling Variation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Drilling down with Expand Drilling enabled and Data Display &gt; Selected Members disabled</td>
<td>Augments current member selections with the drilled return set and removes the drilled member</td>
</tr>
<tr>
<td>Drilling down with Expand Drilling enabled and Data Display &gt; Selected Members enabled</td>
<td>Augments current member selections with the drilled return set and includes the drilled member.</td>
</tr>
<tr>
<td>Drilling down with Expand Drilling disabled and Data Display &gt; Selected Members disabled</td>
<td>Replaces the current member selections with the drilled return set and removes the drilled member.</td>
</tr>
<tr>
<td>Drilling down with Expand Drilling disabled and Data Display &gt; Selected Members enabled</td>
<td>Replaces the current member selections with the drilled return set and includes the drilled member.</td>
</tr>
</tbody>
</table>

**Default Drilling Behavior**

Default drilling behavior for Web Analysis documents:

- Drill Down displays children.
- Drill Up displays parents.
- Drill to Top displays the highest ancestor.

Drilling options are data-source specific. If, in user preferences, you set drilling options that are not supported by the current data source, drilling defaults to Drill to Next Level.

**Drill-Linking**

Drill-linking enables you to navigate to other documents by clicking cells with preplaced links. Drill-linking differs from both drilling and linked reporting objects. Drilling navigates the dimensional hierarchy. Drill-linking passes the current member selection to other documents and executables. Linked reporting objects are linked to cell notes, file attachments, and URLs.
Changing Display Types

Documents display data values returned from data sources in data objects. Web Analysis documents can have multiple data objects, and each data object can have a different display type:

- Spreadsheet
- Chart
- Pinboard
- SQL spreadsheet
- Freeform grid

Each display type has numerous prerequisites. Because SQL spreadsheets and freeform grids can be created only in Web Analysis Studio, you cannot change them.

Pinboards require traffic lighting definitions, so you can change spreadsheets or charts to pinboards, only if the pinboard definition is defined.

➤ To change the display type of the current document, select Format > Display Type >, and select a display type or chart type.

Note:

Web Analysis Studio users can lock the display type to prevent subsequent users from altering a document.

Data Display Options

Each display type has data display options specifying document behavior. For suppression—suppresses rows with missing data, rows with zeroes, and in the case of Analytic Services, rows with shared members. Suppression can be set from the Cube Navigator dialog box, Data Display shortcut menu or OLAP Server preferences.

<table>
<thead>
<tr>
<th>Data Display Option Submenu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selected Member</td>
<td>Displays the explicit member selection made in the query. This member selection can be previewed in the Information panel, or Dimension Browser. Selected Member provides a method for displaying this information in data objects.</td>
</tr>
<tr>
<td>Selected Member First</td>
<td>When Selected Member is active, enables you to position the explicit member selection made in the query definition first (from left to right, or top to bottom).</td>
</tr>
<tr>
<td>Suppress</td>
<td>Omits data, as specified, from the query result set:</td>
</tr>
<tr>
<td></td>
<td>- Missing Rows</td>
</tr>
<tr>
<td></td>
<td>- Shared Members</td>
</tr>
<tr>
<td></td>
<td>- Zero Rows</td>
</tr>
</tbody>
</table>

Table 100 Data Display Options of Data Object Shortcut Menu
Saving Selections to the User POV

User POV enables users to select members in Filters, Pages, Rows, and Columns (Data layout and/or member selection controls) and applies them to multiple reports.

Note the report needs the following to utilize the User POV:

- “Use User POV” is enabled in the Data Layout dialog in the Web Analysis Studio.
- A dimension member selection needs to include “User POV” as a selection.

This is exposed through the current POV functionality, where UserPOV is the name of another POV that is created and utilized in reports. The UserPOV exist for all database connections and can be set at user level only.

To set a UserPOV, right click a spreadsheet and select Save Selection to save the dimension member selections to the UserPOV.

Pinboards

Pinboards are custom, graphic representations of multiple dimensions. Pinboard dimensions are represented by graphics, pin icons on graphics, and color (or state).

Pinboards Prerequisites

Because pins change image or color dynamically, based on traffic-lighting cues, you must create the spreadsheet and apply traffic lighting before creating the pinboard in Web Analysis Studio.

Pinboard Series

A pinboard series enables drilling from one pinboard to another. You create the first pinboard and then use the Web Analysis Studio Pinboard Designer right-click menu to generate subsequent pinboards, each of which uses the children of the preceding pinboard. The pinboard that represents the dimension bottom is the last in the series.

Pins

You can use the default pins provided by Web Analysis Studio or use Pin Designer to create pins. Pins change their image or color, based on traffic lighting.

Figure 10  Default Pin, Image Pin, and Color Pin
Traffic-Lighting Control Panel

If multiple traffic-lighting definitions are defined on a document, the pinboard display type displays a traffic-lighting control panel, which enables you to scroll through the traffic-lighting definitions.

SQL Spreadsheets

SQL spreadsheet data objects enable users to query relational data sources and display the returned data values on custom documents:

- SQL spreadsheets can be created only on custom documents.
- You must understand how to compose SQL queries to create SQL spreadsheets.
- You must be able to connect to a relational data source using supported JDBC drivers.

Alternatives for accessing relational data:

- In Web Analysis Studio, you can create a relational database connection to be used by spreadsheets, charts, and pinboards.
- You can use freeform grids, which leverage custom document database connections, to combine data values from multiple data sources in one data object.
- In Web Analysis Studio, you can create a relational drill-through connection from an OLAP database connection to a relational data source.
- You use the Related Content dialog box to leverage pre-defined Analytic Integration Services drill-through reports.

Freeform Grids

Freeform grids present OLAP, relational, and manually entered data on a data object, enabling you to leverage multiple data sources in integrated, dynamic calculations.

Freeform grids are comprised of rows and columns; page dimensions are not visually represented. You can use OLAP database connections with members assigned to the page axis, but you cannot navigate through page dimensions unless you create additional subscription controls. In short, only the first page of a multidimensional cube is displayed.

Resizing the Display

You can resize large Web Analysis documents in the content area:

- **Auto-Resize**—attempts to fit the current data object into the current content area
- **Custom Resize**—fits the current data object to a manually specified pixel area
To auto-resize the current data object, select **Format > Auto-Resize**.

To size the current data object to a specified size, select **Format > Custom Resize**, and, when the Custom Resize dialog box is displayed, enter the preferred number of horizontal and vertical pixels.

**Managing Analysis Tools**

You can leverage tools, advanced-analytical-formatting and data-source-specific, from the Workspace. Analysis tools expedite comparisons, visually organize data, and promote structures and conclusions.

Analysis tools are data-source-specific; not all tools are available in all data objects.

Analysis tools are centrally organized and applied by Analysis Tools Manager, accessed using the data-object, right-click menu. Analysis Tools Manager features an Ordered By panel, which shows the number and order of tool definitions activated on the current data object.

You can create analysis tools, using the data-object, right-click menu.

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Traffic Lighting</td>
<td>Displays the Traffic Lighting dialog box, used to color-code member values based on fixed limits or value comparison. Traffic Lighting visually associates member values, whether or not they are sorted or ranked.</td>
</tr>
<tr>
<td>Sorting</td>
<td>Displays the Sorting dialog box, used to order the query result set</td>
</tr>
<tr>
<td>Retrieve Only Top/Bottom</td>
<td>Displays the Retrieve Only Top/Bottom dialog box, used to limit and rank the query result set.</td>
</tr>
<tr>
<td>Restrict Data</td>
<td>Displays the Restrict Data dialog box, used to restrict the query result set based on criteria.</td>
</tr>
<tr>
<td>Calculations</td>
<td>Displays the Calculations dialog box, used to create calculated rows and columns.</td>
</tr>
<tr>
<td>Show/Hide Only</td>
<td>Displays the Show/Hide dialog box, used to filter data by color, value, and member.</td>
</tr>
<tr>
<td>Data Formatting</td>
<td>Displays the Data Formatting dialog box, used to format data values based on member or value criteria.</td>
</tr>
</tbody>
</table>

**Related Content Definitions**

Related Content definitions can be managed from the Related Content dialog box and Analysis Tools Manager. Edits, including remove and remove all, made in the Related Content dialog box change definition content but do not impact definition existence. In Analysis Tools Manager, you can activate, deactivate, reorder, and remove, but not edit, definitions.
Order of Definitions

The order in which Analysis Tools definitions are applied affects data object behavior. Users can edit application order by moving Analysis Tools definitions up and down in the Ordered By panel.

Default Analysis Tools Definitions

Analysis Tools Manager displays default formatting, measures formatting, and spreadsheet option definitions at the top of the Ordered by list panel. Definitions originating from user preferences, database connection properties, and data object properties are applied before Analysis Tools definitions and can be edited, but not removed or disabled.

Activating and Deactivating Analysis Tools Definitions

You can activate and deactivate Analysis Tools definitions without removing them from Analysis Tools Manager; thus, you can use many different Analysis Tools combinations.

➤ To deactivate an Analysis Tools definition, in the Ordered By panel, select the appropriate Active check box.

Show/Hide Only

You use the Show/Hide Only analysis tool to include or exclude members in or from data objects. Using member name, traffic lighting color, or data value criteria, you enabled focused, value-based analysis.

The Information panel displays the Show/Hide Only definitions that restrict or display current-document information.

Asymmetrical Analysis

Asymmetric documents feature nested dimensions that differ (by at least one member) across an axis. You can hide rows, columns, and chart objects and thus enable assymetrical analysis.

Multiple Show/Hide Only Definitions

Multiple Show/Hide Only definitions are applied in order, enabling simultaneous control by member, color, and values.

Differences in Show/Hide Only Definitions

Different types of Show/Hide Only definitions operate differently:

● Calculations displays or hides all calculated members.
Members displays or hides specified members of the dimension right-clicked in the document.

Values displays or hides members on the axis opposite the dimension right-clicked in the document.

Colors displays or hides members on the axis opposite the dimension right-clicked in the document.

Show/Hide Only definitions are created in the Show/Hide Only dialog box.

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Method</td>
<td>Show—Displays items that satisfy definition criteria</td>
</tr>
<tr>
<td></td>
<td>Hide—Hides items that satisfy definition criteria</td>
</tr>
<tr>
<td>Where</td>
<td></td>
</tr>
<tr>
<td>Calculations</td>
<td>Shows or hides all calculated members</td>
</tr>
<tr>
<td>Member</td>
<td>Bases definitions on specified, current-axis members</td>
</tr>
<tr>
<td>Any Values</td>
<td>Tests whether any opposite-axis member contains values that satisfy current-axis criteria</td>
</tr>
<tr>
<td>All Values</td>
<td>Tests whether all opposite-axis members contain values that satisfy current-axis criteria</td>
</tr>
<tr>
<td>Any Colors</td>
<td>Tests whether any opposite-axis member contains colors that satisfy current-axis criteria</td>
</tr>
<tr>
<td>All Colors</td>
<td>Tests whether all opposite-axis members contain colors that satisfy current-axis criteria</td>
</tr>
<tr>
<td>Set Condition</td>
<td></td>
</tr>
<tr>
<td>Operator menu</td>
<td>Enables selection of a criteria operator: Greater than (&gt;), Greater Than or Equal To (&gt;=), Equal to (=), Less Than or Equal To (&lt;), or Less Than (&lt;), Not Equal To (&lt;&gt;)</td>
</tr>
<tr>
<td>Value Text box</td>
<td>Enables users to enter values for conditions</td>
</tr>
<tr>
<td>Color</td>
<td>Opens the Select Color dialog box, used to set condition color</td>
</tr>
<tr>
<td>Members</td>
<td>Lists members and attributes to which the current definition applies</td>
</tr>
<tr>
<td>Advanced</td>
<td>Aggregates or separates member combinations</td>
</tr>
<tr>
<td>Apply</td>
<td>Applies new definitions to documents</td>
</tr>
</tbody>
</table>

### Creating Show/Hide Only Definitions

To create a Show/Hide Only definition:

1. Right-click a member, and select Analysis Tools > Show/Hide Only.
   The Show/Hide Only dialog box is displayed.

2. From Select Method, select Show or Hide.
3 Define a Show/Hide Only definition option:
   - To show or hide calculated members, in Where, select Calculations.
   - To show or hide specific members, in Where, select Members, and, from Members, select members.
   - To show or hide members, if any member satisfies the specified condition.
     a. In Where, select Any Values.
     b. From Members, select members.
     c. Use the operator list and the value text area to define the condition. To show or hide members, if all members satisfy the specified condition:
     d. In Where, select All Values.
     e. From Members, select members.
     f. Use the operator list and the value text area to define the condition.
     g. To show or hide members, if any member satisfies the specified traffic-lighting color condition:
        i. In Where, select Any Colors.
        ii. From Members, select members.
        iii. From the operator list, select Equal To (=) or Not Equal To (<>).
        iv. From Color, select an option. To show or hide members, if all members satisfy the specified traffic-lighting color condition:
   h. In Where, select All Colors.
   i. From Members, select members.
   j. From the operator list, select Equal To (=) or Not Equal To (<>).
   k. From Color, select an option.

Note:
Show/Hide Only Members is applied to the named member, and Show/Hide Only Values and Show/Hide Only Colors are applied to the opposite axis, using the values in the selected axis.

Color options are enabled only for data objects that feature active traffic-lighting definitions. An Advanced check box enables you to specify conditions for member combinations. The Apply button enables you to apply the current definition to the current data object, without exiting the dialog box. You may have to drag the dialog box title bar to see the data object.

4 Click OK.
   The definition is added to Analysis Tools Manager.

5 Click Close.
Editing Show/Hide Only Definitions

To edit a Show/Hide Only definition:

1. Right-click a member, and select Analysis Tools > Analysis Tools Manager.
   Analysis Tools Manager is displayed.

2. Right-click a Show/Hide Only definition, and select Edit.
   The Show/Hide Only dialog box is displayed.

3. Make selections and define parameters.

4. Click OK.

Traffic Lighting

The Traffic Lighting analysis tool color-codes data cells. You can base color-coding on two-member comparisons or single-member fixed limits. Colors graphically associate member values, whether or not they are sorted or ranked. Traffic Lighting definitions are created in the Traffic Lighting dialog box and maintained as the document is pivoted and changed.

The Information panel displays the Traffic Lighting definitions that color-code the current data object.

Table 103  Traffic Lighting Dialog Box

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create Criteria</td>
<td></td>
</tr>
<tr>
<td>Apply Traffic Lighting To</td>
<td>Specifies the dimension to which traffic lighting is applied</td>
</tr>
<tr>
<td>Comparing It To</td>
<td>Specifies the dimension to which the preceding dimension is compared</td>
</tr>
<tr>
<td>Assign Limits</td>
<td>Specifies the interval, set point, and color parameters that compose the traffic lighting definition</td>
</tr>
<tr>
<td>% Differences</td>
<td>Indicates that color-coding is based on the percent difference between compared members. If not enabled, color-coding is based on value difference.</td>
</tr>
<tr>
<td>Enable Financial Intelligence</td>
<td>Enables Hyperion data sources to treat expenses and liabilities as negative values. Works with % Differences to reflect variance and variance percent calculations for the Traffic Lighting dialog box.</td>
</tr>
<tr>
<td>Advanced</td>
<td>Aggregates or separates member combinations</td>
</tr>
<tr>
<td>Apply</td>
<td>Applies the definition to the document</td>
</tr>
</tbody>
</table>

Financial Intelligence Variations

% Differences and Enable Financial Intelligence cooperate to provide four calculations for the Traffic Lighting dialog box:
Neither selected—Traffic Lighting compares members, using a subtraction calculation.

- Only % Differences selected—Traffic Lighting compares members, using a percent difference calculation.

- Enable Financial Intelligence selected—Traffic Lighting compares members, using an advanced variance calculation that recognizes specific expense and liability members as negative values.

- Both selected—Traffic Lighting compares members, using an advanced variance percent calculation that recognizes specific expense and liability members as negative values.

**Assign Limits Box**

In the Assign Limits box, you indicate the number, color, and criteria for color-coding traffic lighting ranges.

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add to End</td>
<td>Inserts set points within ranges</td>
</tr>
<tr>
<td>Remove Last</td>
<td>Removes the last traffic lighting range and set point</td>
</tr>
<tr>
<td>Set Color button</td>
<td>Opens the Select Color dialog box, used to set range colors</td>
</tr>
</tbody>
</table>

**Table 104 Assign Limits Box**

Note:

Setting traffic lighting colors to the colors used by Spreadsheet Options may obscure member color-coding.

**Creating Traffic Lighting Definitions**

To create a traffic lighting definition:

1. **Right-click a member, and select Analysis Tools > Traffic Light.**
   
The Traffic Lighting dialog box is displayed.

2. **From Apply To, select the member to which traffic lighting is to be applied.**

3. **From Comparing It To, select the member to which the previously selected member is to be compared.**

   - Compare to a fixed limit by, in Assign Limits, deselecting % Differences or, from Comparing It To, selecting Fixed Value.

   - Select Advanced twice, first to separate members into combinations and second to select from aggregated members.

   Assign Limits contains three default set points and colors. Set points divide values into ranges identified by color.

4. **For each set point, indicate a set point operand.**
The first list prompts you to specify whether the setpoint value is in the range; you choose greater than (>) or greater than and equal to (>=).

5 In the text box, enter a setpoint value, to specify the threshold that separates ranges.

The second list prompts you to specify the setpoint value; you enter positive or negative decimal values.

6 Optional: To change the range color, click Color, and select a color square.

The Color button displays a color-square palette. Selecting a square assigns it to the current traffic lighting range and displays the hexadecimal value of the color in the neighboring text-entry field.

7 Optional: To change color opacity, enter a value in the last text-entry box for each range.

You can specify a percentage from zero (transparent) to one hundred. Transparency is sometimes used to reveal background graphics.

8 Optional: To add a set point, click Add to End, and repeat steps 4 through 7.

9 Click OK.

**Editing Traffic Lighting Definitions**

➤ To edit a Traffic Lighting definition:

1 Right-click a member, and select Analysis Tools > Analysis Tools Manager.

   Analysis Tools Manager is displayed.

2 Right-click a Traffic Lighting definition, and select Edit.

   The Traffic Lighting dialog box is displayed.

3 Make selections, and define parameters.

4 Click OK.

**Sorting**

The Sorting analysis tool orders dimensions of the query result set in ascending or descending alphanumeric order. Sorting definitions, which are created in the Sorting dialog box and displayed in the Information panel, are dynamic—applied as documents are drilled, pivoted, and changed.

You can use client-side and server-based sorting definitions:

- Client-side sorting—provided by Sorting and executed on local computers
- Server-based sorting—provided by Retrieve Only Top/Bottom and executed on Analytic Server; performed prior to returning the OLAP query result set to the client, thus minimizing the result set and network traffic
Multiple sorting definitions are applied in the order presented by Analysis Tools Manager. Sorting definitions applied to axes with equal values may be rearranged by sorting definitions applied to axes with diverse values. The document display is the result of the cumulative application of all active sorting, client-side and server-side, but it may seem that only the last sorting definition was applied.

**Table 105  Sorting Dialog Box**

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sort On</td>
<td>Specifies the member to which the sorting definition is applied</td>
</tr>
<tr>
<td>Order</td>
<td></td>
</tr>
<tr>
<td>Ascending</td>
<td>Selects ascending alphanumeric order</td>
</tr>
<tr>
<td>Descending</td>
<td>Selects descending alphanumeric order</td>
</tr>
<tr>
<td>Apply</td>
<td>Apply the definition to the document</td>
</tr>
</tbody>
</table>

**Creating Sorting Definitions**

➤ To create a sorting definition:

1. Right-click a member, and select Analysis Tools > Sort.
   
   The Sorting dialog box is displayed.

2. From Members, select the member to which sorting is to be applied.
3. Select Ascending or Descending.
4. Click OK.

**Editing Sorting Definitions**

➤ To edit a sorting definition:

1. Right-click a member, and select Analysis Tools > Analysis Tools Manager.
   
   The Analysis Tools Manager is displayed.

2. Right-click a sorting definition, and select Edit.
   
   The Sorting dialog box is displayed.

3. Make selections and define parameters.
4. Click OK.
Restrict Data

The Restrict Data analysis tool narrows the return set by requiring data values to be relevant to rules and operands. Data can be restricted by two-column comparison or single-column fixed limits.

The Information panel displays Analytic Services Restrict Data definitions for the current document.

Because Restrict Data is executed by Analytic Services, the network server is protected from transmitting and the client is protected from processing large result sets.

Users can apply Restrict Data to result sets of processed queries (using the Analysis Tools right-click menu) and of unsubmitted queries. The last step of the new document wizard enables users to create Restrict Data definitions.

### Table 106  Restrict Data Dialog Box

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Column</td>
<td>Displays the Select Column dialog box, used to select a column from the current document</td>
</tr>
<tr>
<td>Operator menu</td>
<td>Specifies an operator: Greater than (˃), Greater Than or Equal To (≥), Equal to (=), Less Than or Equal To (≤), Less Than (˂), Not Equal To (≠)</td>
</tr>
<tr>
<td>Operand menu</td>
<td>Specifies one of three operands: A value Of—restricts data to a value or range of values, The Data Value of Column—displays a secondary Select Column button, used to compare two columns, A Missing Value—restricts missing values</td>
</tr>
<tr>
<td>Value Text box</td>
<td>Specifies values for Restrict Data conditions</td>
</tr>
</tbody>
</table>

**Note:**

It is advised to use one member per dimension in filters when restrict data or retrieve top/bottom is applied. If multiple members are selected per dimension, the application aggregates results. Because restrict data and retrieve top/bottom are parts of Analytic Services queries, aggregation occurs after queries are returned and may result in unexpected result sets.

### Creating Restrict Data Definitions

➤ To create a Restrict Data definition:

1 **Right-click a member, and select Analysis Tools > Restrict Data.**
   
The Restrict Data dialog box is displayed.

2 **From Select Column, select a column on which to restrict data.**

3 **From Operator, select an operator.**

4 **From Operand, select an operand: A Value Of, The Data Value of Column, or A Missing Value.**
5 Depending on the selected operand, perform an action:
   ● A Value Of—For Value, enter a data value.
   ● The Data Value of Column—From the relevant list, select a column.
   ● A Missing Value—Do nothing.

6 Click Add.

Four buttons are available: Add, Update, Remove, and Remove All.

Restriction criteria is listed in the Restriction Definition frame. You can use the Advanced button to create compound definitions.

<table>
<thead>
<tr>
<th>Table 107</th>
<th>Advanced Options</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Option</strong></td>
<td><strong>Submenu</strong></td>
</tr>
<tr>
<td>Add</td>
<td></td>
</tr>
<tr>
<td>Update</td>
<td></td>
</tr>
<tr>
<td>Validate</td>
<td></td>
</tr>
<tr>
<td>Remove</td>
<td></td>
</tr>
<tr>
<td>Remove All</td>
<td></td>
</tr>
<tr>
<td>Connect</td>
<td>And</td>
</tr>
<tr>
<td></td>
<td>Or</td>
</tr>
<tr>
<td>Move</td>
<td>Move Up</td>
</tr>
<tr>
<td></td>
<td>Move Down</td>
</tr>
</tbody>
</table>

7 Optional: To compose a compound rule, select an advanced connect option, and repeat steps 2 through 7.

8 Click OK.

**Editing Restrict Data Definitions**

To edit a Restrict Data definition:

1 Right-click a member, and select **Analysis Tools > Analysis Tools Manager**.
   Analysis Tools Manager is displayed.

2 Right-click a **Restrict Data** definition, and select **Edit**.
   The Restrict Data dialog box is displayed.

3 Make selections and define parameters.

4 Click **OK**.
Retrieve Only Top/Bottom

The Retrieve Only Top/Bottom analysis tool, central to top/bottom analysis, leverages Analytic Services server-based sorting and ranking to control the size and order of OLAP query result sets. Thus, the network server is protected from transmitting and the client is protected from processing large result sets.

You can apply Retrieve Only Top/Bottom to result sets of processed queries (using the Analysis Tools right-click menu) and to result sets of unsubmitted queries. Prior to sending queries, click the Data Layout Options button and select Retrieve Only Top/Bottom. During query creation, use the last step of the new document wizard.

The Information panel displays all Analytic Services Retrieve Only Top/Bottom definitions for the current document.

Server-Based Sorting

Server-based sorting is provided by Retrieve Only Top/Bottom and executed on Analytic Server. Server-based sorting is performed by the server prior to returning the OLAP query result set to the client, thus minimizing the result set and network traffic.

Multiple, Filter-Axis Members

Multiple, filter-member selections impact Retrieve Only Top/Bottom.

Multiple filter-axis members are aggregated before they are sent queries. Because client-based aggregation does not exist in data source servers, queries are processed using server data values. The discrepancy between client aggregations and server-based sorting and ranking results in irregular result sets.

Note:

Users are strongly advised to use one member per dimension in filters when using Retrieve Only Top/Bottom and Restrict Data.

Table 108 Retrieve Only Top/Bottom Dialog Box

<table>
<thead>
<tr>
<th>Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Column</td>
<td>Specifies the columns to which the Retrieve Only Top/Bottom definition is to be applied</td>
</tr>
<tr>
<td>Show</td>
<td>Limits the result set to the specified criteria</td>
</tr>
<tr>
<td>Top</td>
<td>Selects the highest data value, as indicated by the number in the relevant box</td>
</tr>
<tr>
<td>Bottom</td>
<td>Selects lowest data value, as indicated by the number in the relevant box</td>
</tr>
<tr>
<td>Sorting</td>
<td>Ascending</td>
</tr>
<tr>
<td>Ascending</td>
<td>Displays the result set in ascending alphanumeric order</td>
</tr>
<tr>
<td>Control</td>
<td>Description</td>
</tr>
<tr>
<td>---------</td>
<td>-------------</td>
</tr>
<tr>
<td>Descending</td>
<td>Displays the result set in descending alphanumeric order</td>
</tr>
<tr>
<td>Clear</td>
<td>Deletes all Retrieve Only Top/Bottom definitions</td>
</tr>
</tbody>
</table>

**Creating Retrieve Only Top/Bottom Definitions**

➤ To create a Retrieve Only Top/Bottom definition:

1. **Right-click a member, and select Analysis Tools > Retrieve Only Top/Bottom.**
   The Retrieve Only Top/Bottom dialog box is displayed.

2. **From Column, select the column to which the Retrieve Only Top/Bottom definition.**

3. **Limit the result set by selecting Top or Bottom and, in the relevant box, indicating the number of members.**

4. **Sort the result set by selecting Ascending or Descending.**

5. **Optional: To remove all selections from the current definition and start over, click Clear.**

6. **Click OK.**

**Editing Retrieve Only Top/Bottom Definitions**

➤ To edit a Retrieve Only Top/Bottom definition:

1. **Right-click a member, and select Analysis Tools > Analysis Tools Manager.**
   Analysis Tools Manager is displayed.

2. **Right-click a Retrieve Only Top/Bottom definition, and select Edit.**
   The Retrieve Only Top/Bottom dialog box is displayed.

3. **Make selections and define parameters.**

4. **Click OK.**

5. **Click Close.**

**Data Formatting**

Data Formatting options enable you to format members and data values for members and criteria.

Although formatting options are fixed, formatting scope varies, depending on the formatting source.
To create a Data Formatting definition, right-click a member, and select Analysis Tools > Format.

The Formatting dialog box indicates the member to which the formatting definition is to be applied.

Formatting tasks:
- Format member, font properties
- Format member, data-value, font properties
- Edit member selections
- Restore Default Formatting User Preferences settings

Table 109  Formatting Dialog Box

<table>
<thead>
<tr>
<th>Controls</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Selections</td>
<td>Displays all member selection definitions</td>
</tr>
<tr>
<td>Remove All</td>
<td>Deletes all member selection definitions from Selections</td>
</tr>
<tr>
<td>Remove</td>
<td>Deletes specified member selection definitions from Selections</td>
</tr>
<tr>
<td>Edit</td>
<td>Displays the Edit Formatting Selections dialog box, used to define member selection definitions.</td>
</tr>
<tr>
<td>Header</td>
<td></td>
</tr>
<tr>
<td>Font</td>
<td>Displays the Font Properties dialog box</td>
</tr>
<tr>
<td>Data</td>
<td></td>
</tr>
<tr>
<td>Format Data</td>
<td>Displays the Format Data dialog box, used to specify text and numeric formatting.</td>
</tr>
<tr>
<td>Conditional Formatting</td>
<td>Enables conditional formatting of member selections, based on criteria defined for operand and value</td>
</tr>
<tr>
<td>Operand</td>
<td>Specifies the conditional formatting operand.</td>
</tr>
<tr>
<td>Value</td>
<td>Specifies the conditional formatting value.</td>
</tr>
<tr>
<td>Restore Defaults</td>
<td>Restores the settings specified by default formatting user preferences</td>
</tr>
</tbody>
</table>

Creating Data Formatting Definitions

To create a data formatting definition:

1. Right-click a column or row header, and select Analysis Tools > Format.
   The Formatting dialog box is displayed. The Selections panel displays the member selection.

2. To specify a formatting definition, perform an action:
● From **Header, Font Family**, specify header-cell font properties (point size and font style and color) for the member selection.

● From **Data, Font Family**, specify data-cell font properties (point size and font style and color) for the member selection.

● Click **Data Format** to display the Format Data dialog box, used to specify leading and trailing text, numeric formatting, and missing values.

● Select **Conditional Formatting**, enter a value, and select an operand.

3 Click **OK**.

The formatting definition is listed in Analysis Tools Manager, and the definition is applied to the document.

**Conditional Formatting**

You can refine formatting definitions by using conditional formatting, which requires member selection values to satisfy additional criteria before formatting is applied.

Conditional formatting criteria is defined in the Formatting dialog box by selecting conditional formatting, selecting an operand, and entering a value.

**Editing Data Formatting Definitions**

➢ To edit a data formatting definition:

1 Right-click a member, and select **Analysis Tools > Analysis Tools Manager**.
   Analysis Tools Manager is displayed.

2 Right-click a formatting definition, and select **Edit**.
   The Formatting dialog box is displayed.

3 Make selections and define parameters.

4 Click **OK**.

**Calculations**

You can create members as the products of calculations (client-side calculated members) and edit, delete, and analyze calculations.

Calculation-definition order in Analysis Tools Manager prescribes the order in which compound calculations are executed. To change the order, select definitions and click the up and down arrow.

The **Creating Calculations** procedure describes Calculation analysis tool options in context.
Average

- **Function Performed**: Sum of arguments divided by number of arguments
- **Number of Arguments**: Two or more members or existing calculations
- **Options**: Whether missing values are set to 0 and included in the number of arguments

Example: If Actual is 100 and Budget is 200, the average of Actual and Budget is 150.

Cumulative

- **Function Performed**: A running total
- **Number of Arguments**: One member or existing calculation
- **Options**: Whether missing values are set to 0

Example: Consider a spreadsheet with Actual as a column and Colas, Root Beer, and Cream Soda as rows. If Actual values for the products are 100, 200, 300, Cumulative values are 100, 300, 600.

Difference from Average

- **Function Performed**: Difference between the average value and the occurrence of an argument
- **Number of Arguments**: One member or existing calculation
- **Options**: Whether missing values are set to 0

Example: Consider a spreadsheet with Actual as a column and Colas, Root Beer, and Cream Soda as rows. If Actual values for the products are 100, 200, 300, the average is 200, and Difference from Average values are -100, 0, 100.

Divide

- **Function Performed**: Arithmetic division
- **Number of Arguments**: Two members or existing calculation
- **Options**: Whether missing values are set to 0

Linear Regression

- **Function Performed**: Straight-line linear regression. Looks at all occurrences of the specified argument and uses a linear regression algorithm to calculate a straight line through the occurrences
- **Number of Arguments**: One member or existing calculation
- **Options**: Whether missing values are set to 0 in the calculation

Example: Consider a spreadsheet with Actual as a column and Jan, Feb, Mar as rows. If the Actual values for the time periods are 100, 300, 600, the linear regression values are 83, 333, 58. Notice
that there is a constant difference between values (250). All points in the sequence are adjusted. A chart of the numbers produces a straight line that intersects the original data points.

**Maximum**
- **Function Performed**: Given two or more arguments, the name of the member or existing calculation with the maximum value
- **Number of Arguments**: Two or more members or existing calculations
- **Options**: Whether missing values are set to 0

*Example*: Consider a spreadsheet with East and West as columns and Jan, Feb, Mar as rows. If East values are 100, 300, 600 and West values are 200, 200, 300, Maximum values are West, East, East.

**Maximum Value**
- **Function Performed**: Given two or more arguments, the value of the member or existing calculation with the maximum value
- **Number of Arguments**: Two or more members or existing calculations
- **Options**: Whether missing values should be set to 0

*Example*: Consider a spreadsheet with East and West as columns and Jan, Feb, Mar as rows. If East values are 100, 300, 600 and West values are 200, 200, 300, Maximum Value values are 200, 300, 600.

**Minimum**
- **Function Performed**: Given two or more arguments, the name of the member or existing calculation with the minimum value
- **Number of Arguments**: Two or more members or existing calculations
- **Options**: Whether missing values should be set to 0

*Example*: Consider a spreadsheet with East and West as columns and Jan, Feb, Mar as rows. If East values are 100, 300, 600 and West values are 200, 200, 300, Minimum values are East, West, West.

**Minimum Value**
- **Function Performed**: Given two or more arguments, the value of the member or existing calculation with the minimum value.
- **Number of Arguments**: Two or more members or existing calculations
- **Options**: Whether missing values are be set to 0

*Example*: Consider a spreadsheet with East and West as columns and Jan, Feb, Mar as rows. If East values are 100, 300, 600 and West values are 200, 200, 300, Minimum Value values are 100, 200, 300.
Multiply

- Function Performed: Arithmetic multiplication
- Number of Arguments: Two members or existing calculations or one member or existing calculation and a constant.
- Options: A constant as an argument (if you want to work with one rather than two existing members or calculations) and whether missing values are set to 0

Percent

- Function Performed: Percentage calculation
- Number of Arguments: Two members or existing calculations or one member or existing calculation and a constant.
- Options: A constant as an argument (if you want to work with one rather than two existing members or calculations) and whether missing values are set to 0

Example: Consider a spreadsheet with Actual and Budget as columns and Jan, Feb, Mar as rows. If Actual values are 100, 300, 600 and Budget values are 200, 200, 400, Percentage values (Actual % Budget) are 50, 150, 150.

Percent Difference from Average

- Function Performed: The Difference from Average result displayed as a percentage of the average
- Number of Arguments: One member or existing calculation
- Options: Whether missing values are set to 0

Example: Consider a spreadsheet with Actual as a column and Colas, Root Beer, and Cream Soda as rows. If Actual values for the products are 100, 200, 300, the average is 200, and the Difference from Average (%) column values are -50, 0, 50.

Percent of Difference

- Function Performed: Percentage difference calculation
- Number of Arguments: Two members or existing calculations or one member or existing calculation and a constant.
- Options: A constant as an argument (if you want to work with one rather than two existing members or calculations) and whether missing values are set to 0

Example: Consider a spreadsheet with Actual and Budget as columns and Jan, Feb, Mar as rows. If Actual values are 100, 300, 600 and Budget values are 200, 200, 400, Percentage difference values (Actual % diff Budget), calculated as ((Actual - Budget) / Budget) * 100, are -50, 50, 50.
**Percent of Member**

- **Function Performed**: A member argument as a percentage of another member argument. The second argument is defined by a member intersected on an opposite axis.
- **Number of Arguments**: Two or more members or existing calculations or one member or existing calculation and a constant.
- **Options**: Whether missing values are set to 0
- **Procedure**: Select a Percent of Member calculation from the Function list, select a member argument, and select a member from the opposite axis, using the Opposite Member list.

**Percent of Total**

- **Function Performed**: Percentage of total
- **Number of Arguments**: One member or existing calculation
- **Options**: None

**Example**: Consider a spreadsheet with Actual as a column and Jan, Feb, Mar as rows. If Actual values are 100, 300, 600, Percentage of Total values are 10, 30, and 60.

**Rank Ascending and Rank Descending**

- **Function Performed**: Ranking
- **Number of Arguments**: One member or existing calculation
- **Options**: Ascending or descending (the default). If ascending, the smallest value is ranked as 1. If descending, the largest value is ranked as 1.

**Example**: Consider a spreadsheet with Actual as a column, Jan, Feb, Mar as rows, and Actual values of 100, 300, 600. If descending is selected, Rank values are 3, 2, 1. If ascending is selected, Rank values are 1, 2, 3.

**Subtract**

- **Function Performed**: Arithmetic subtraction
- **Number of Arguments**: Two or more members or existing calculations or one member or existing calculation and a constant.
- **Options**: Whether missing values are set to 0

**Sum**

- **Function Performed**: Arithmetic addition
- **Number of Arguments**: Two or more members or existing calculations or one member or existing calculation and a constant.
- **Options**: Whether missing values are set to 0
**Trend**
- **Function Performed:** Trend based on straight-line linear regression; that is, the slope of the straight line that a linear-regression calculation plots between original, data-series points
- **Number of Arguments:** Two or more members or existing calculations
- **Options:** Whether missing values are set to 0

**Variance**
- **Function Performed:** Arithmetic subtraction that uses Financial Intelligence account metadata to interpret Financial Management expense and liability items as negative values
- **Number of Arguments:** Two or more members or existing calculations or one member or existing calculation and a constant.
- **Options:** Whether missing values are set to 0

**Variance Percent**
- **Function Performed:** Percentage difference calculation that uses Financial Intelligence account metadata to interpret Financial Management expense and liability items as negative values
- **Number of Arguments:** Two members or existing calculations or one member or existing calculation and a constant.
- **Options:** A constant as an argument (if you want to work with one rather than two existing members or calculations) and whether missing values are set to 0

**Complex Calculations**
Hyperion recommends dividing complex calculations into components and combining the components into a compound calculation.

**Example:** To set up a calculation for \( \frac{A + B}{C \times 2} \), where A, B, and C are members, you divide the formula into steps:
- Set up Sum for A + B, and name it Step 1.
- Set up Multiply for C x 2, and name it Step 2.
- Set up Divide for Step 1 result divided by Step 2 result, and name it Step 3.
- Use Show Only Members to hide Step 1 and Step 2. If you want to switch between seeing only members, seeing only calculations, and seeing both, you can use the Hide option in your document right-click menu.
Creating Calculations

➤ To create a calculation:

1 Right-click a member, and select Analysis Tools > Calculation.

   The Calculation Definition dialog box is displayed, providing seven control groups:
   ● Name
   ● Function
   ● Select Position
   ● Select Members
   ● Arguments
   ● Missing Values
   ● Formula

2 For Name, enter a name for the Calculation definition.

3 From Function, select the calculation type.

   The calculation type is displayed in the Function box.

4 From Select Position, select an option.

   ● Front/Top
   ● Back/Bottom
   ● Insert Before
   ● Insert After

   If you select Insert Before or Insert After, select an insertion point from the relevant list box.

   The calculated row or column is inserted before or after the specified dimension.

5 To specify an argument, perform an action:

   ● Select a member, and then click the arrow (>) to replace the undefined argument (?) with the member.
   ● For Constant, enter a value, and click the arrow (>) to replace the undefined argument (?) with a value.
   ● Select Advanced, select a member combination, and click the arrow (>) to replace the undefined argument (?) with the member combination.
   ● Select All Members to select all available members, and, if you want to exclude calculated members from the equation, select Ignore Calculations.

   The calculation definition is displayed in the Formula box.

6 Optional: To indicate how to handle missing values, from Missing Values, select an option:

   ● Include—Calculates missing values as they are stored
   ● Exclude—Removes arguments populated by missing values
- Treat as Number—Populates the argument with the indicated value (default zero)

7 Optional: To evaluate a member argument as a percentage of a member argument located on the opposite axis:
   a. From Function, select Percent of Member.
   b. Select a member argument.
   c. Select a member from the opposite axis, using the Opposite Member box.

8 Click OK.

Modifying Calculations

To modify a calculation:
1 Right-click a member, and select Analysis Tools > Analysis Tools Manager.
   Analysis Tools Manager is displayed.
2 Select a calculation definition, and click Edit.
   The Calculation Definition dialog box displays the arguments for the calculation definition.
3 Optional: To change the calculation definition name, for Name, enter a name.
4 Optional: To move calculation position, select a different position option.
5 Optional: If you selected Insert Before or Insert After, from the relevant list box, select an insertion point.
   The calculated row or column is inserted before or after the dimension.
6 Optional: To change calculation type, from Function, select a calculation type.
   Changing calculation type requires that the user redefine all arguments. For instructions, see “Creating Calculations” on page 356.
7 Optional: To change arguments: perform an action:
   ● Select first an argument and then a member, and then click the arrow.
   ● Select an argument; for Constant, enter a value; and click the arrow.
   ● Select first Advanced, second an argument, and third a member combination, and click the arrow.
   The calculation definition is displayed in the Formula box.
8 Click OK.

Analytic Services Attribute Calculations

You can leverage server-based Analytic Services attribute calculations in the client. Because server-based calculations are performed before OLAP query results are sent to clients, network traffic and the result set are minimized.
To use attribute calculations, you use Data Layout to select the attribute calculations dimensions to participate in the query. Then you use Dimension Browser to select the server-based calculations to be returned by the query result set.

**Note:**

You can reproduce many attribute calculations on the client, but you are responsible for defining the calculations, and the client is responsible for processing the result set.

Reasons to use attributes in calculations:

- To select, aggregate, and report on data that shares attributes
- To select attributes by data type: text, numeric, Boolean, and data type
- To group numeric data types into statistical ranges
- To use sum, count, min, max, and average functions on the attribute calculations dimension automatically generated by Analytic Services
- To use numerical attribute values from calculation scripts and member formulas in calculations
- To create crosstabs of attribute data for a dimension and analyze the dimension in terms of each attribute

**Print as PDF from Workspace**

Web Analysis documents can be printed to Adobe Portable Document Format (PDF) from the Workspace. There are two printing options:

- Print Screen—prints the content area.
- Print Selected Object—prints the specified OLAP pages of the current data object (For Example, Spreadsheet, Chart or Pinboard).

Print Screen prints the current display quickly and easily. Because documents can contain multiple data objects, Print Screen does not specify OLAP pages. If you want to include OLAP pages or object-specific document summaries, you should select Print Selected Object.

To print a report as PDF, perform one:

1. **Open a report and Select File > Print via PDF > Screen** to print the screen or **Select File > Print via PDF > Selected Object** to print the selected reporting object in the report.
2. **Right click a data object and select Print via PDF > Selected.**

**Note:**

If Print via PDF is not available, the System Administrator has configured Web Analysis to only print to HTML in the Workspace and Print via PDF has been disabled.
Database Connections

Database connections are portable files that define terms, conditions, and methods for connecting to data sources. You must use Web Analysis Studio, not Web Analysis, to create and modify database connections.

Documents are dependent on database connection files to query data sources. A document can use multiple database connections to connect to one or more data sources.

To access data sources, you may be prompted to provide logon credentials.

Information provided in the view pane Information tab:

● Database—displays the database connection name for the current data object
● Database User Name—displays the user name by which access to the database connection is granted

Data sources and database connections supported by Web Analysis documents:

● OLAP data sources
  ○ Analytic Services 6.5.6, 7.0.1, 7.1, and 7.1.2
  ○ IBM DB2 OLAP Server 7.1 Service Pack 11, 8.1 Service Pack 3, and 8.2
  ○ SAP BW 3.0, 3.1, and 3.5

● Hyperion data sources
  ○ Financial Management 3.4, 3.5, 3.5.1, and 4.0
  ○ Planning 3.3, 3.5 with Analytic Services 3.5.1, and 4.0

● Relational database connections:
  ○ IBM DB2
  ○ Microsoft SQL Server
  ○ Oracle
  ○ Teradata

System RDBMS requirements vary. See the Hyperion Reporting and Analysis – System 9 Installation Guide for Windows or UNIX for descriptions of relational system requirements.

Database Connection Files

Database connections are stored as repository files and adhere to most file management conventions. You see only database connections that you own or to which you are granted permissions. Various kinds of permission are needed to read, write, edit, and change database connection file properties.
Database Connection Access and Document Permissions

Documents or presentations distributed to users may require database connections that the users cannot access. Document access is independent of database connection access.

Database connection permissions that deny access may prevent access to only one connection. Users can use other connections to the primary data source or to alternate data sources. Users can leverage document definitions independently of database connections.

User and Group Permissions

Users can access database connections assigned to them or to groups to which they belong.

When documents are assigned to groups, the database connections that the document uses must also be assigned to the groups. Otherwise, group members can access the document, but not its data values (unless they are granted individual user access).

To mitigate the risk of conflicting permissions, store documents and their database connections in the same folders. Whenever possible, distribute documents and database connections to groups. It is easier to set permissions for all files in a folder and all users in a group than to manage permissions for individual files and users.

Integrating OLAP and Relational Data

Web Analysis Studio users can construct seamless liaisons between OLAP data and relational data sources. Navigation from OLAP to relational data is called relational drill-through.

After relational drill-through is configured, users can navigate from the dimension bottom (level 0) of the OLAP database and drill down to relational data.

Relational drill-through is a client-based integration solution comparable to the server-based Analytic Integration Services drill-through.

The Relational Drill-Through dialog box is a graphical user interface for creating SQL relational database queries. Users can use complex SQL syntax to specify table joins and to select and order by clauses.

Note:

Relational drill-through supports an array of JDBC relational data sources but does not support queries by levels, generations, or previously selected members.

Relational drill-through definitions are saved as properties of database connection files.
Analytic Services Database Connections

Analytic Services, the analytic solution that integrates data from multiple sources and meets the needs of users across an enterprise, enables the quick and easy implementation of solutions, adds value to previously inaccessible data, and transforms data into actionable information.

Analytic Services integrates with existing business intelligence infrastructure, requiring a minimum of IT overhead and enabling organizations to realize maximum return on their IT investments.

Various Analytic Services features are extended through the Web Analysis graphical user interface:

- “Restrict Data” on page 345
- “Retrieve Only Top/Bottom” on page 347
- “Edit Data” on page 361
- “Suppress Missing Rows, Zeros, and Shared Members” on page 362
- “Label Mode and Alias Tables” on page 362
- “Analytic Services Drill Settings” on page 362
- “Linked Reporting Objects (LROs)” on page 362
- “Relational Drill-through” on page 362
- “Analytic Integration Services Drill-through” on page 362
- “Analytic Services Advanced Member Selection” on page 363
- “Attribute Dimensions and Attribute Calculations” on page 363

Restrict Data

Restrict Data narrows the return set by requiring data values to be relevant to specific rules and operands. Data can be filtered by two-column comparison or by single-column fixed limits.

Retrieve Only Top/Bottom

Retrieve Only Top/Bottom Analysis leverages Analytic Services sorting and ranking to control the size and order of OLAP query result sets, thus protecting the network server from transmitting and the client from processing large result sets.

Edit Data

If you have permission, you can edit data values and write edits back to Analytic Services databases. After edits are applied, users can recalculate the databases and measure the impact of changed values.
Suppress Missing Rows, Zeros, and Shared Members

Web Analysis documents leverage Analytic Services to suppress missing rows, zeroes, and shared members from the query result set, thus preventing return of irrelevant information, reducing network traffic, and increasing query speed.

Label Mode and Alias Tables

Label mode enables you to select whether members are listed by ID number, description, or both. Label mode options are database-specific and can be set for database connections, specific documents, and specific dimensions.

Label mode indicates whether descriptions or ID numbers are used, and Analytic Services alias table definitions provide the displayed values.

Analytic Services Drill Settings

Web Analysis documents use Analytic Services features to provide customized drilling, dependent upon three factors:

- The nature of the hierarchical navigation
- Whether current members are replaced or augmented
- Whether drilled members are replaced or augmented

Linked Reporting Objects (LROs)

Analytic Services LROs, which include the following types, enable users to annotate data values by associating external media with cells.

- Text documents
- File attachments
- URLs

Relational Drill-through

Web Analysis documents enable you to drill through to related relational data from the lowest level of the Analytic Services outline by defining links on Analytic Services database connections. Users can pass pages, filters, and row limits to focus and control the relational query result set.

Analytic Integration Services Drill-through

Analytic Integration Services enables you to organize, format, and present relational data as OLAP cubes in Analytic Services. Web Analysis documents enable you to access Analytic
Integration Services data through Analytic Services linked reporting objects by drilling on cells marked for Analytic Integration Services drill-through.

**Analytic Services Advanced Member Selection**

In dimensions with large member sets, users can define selections with the Dimension Browser right-click menu. Right-clicking member names enables selection by familial relationship and database-specific options.

**Attribute Dimensions and Attribute Calculations**

In addition to member names, locations, and relationships, Analytic Services can store characteristics about members. Analytic Services does not store attribute dimensions as part of OLAP cubes, but dynamically calculates them upon request. Attribute dimensions are displayed in dimension hierarchies and used in calculations, as standard dimensions are displayed and used.

**Financial Management**

Financial Management is a centralized, scalable, financial management and reporting solution. With Financial Management, users can unify their financial information (actuals, budgets, forecasts, statistics) in one Web-based application. Financial Management contains packaged features to support tasks and practices:

- Compliance with global reporting standards, currency management, automation of inter-company activities, and production of auditable results
- Links between legal and management reporting and operating plans to achieve enterprise-wide consistency and visibility
- Multidimensional, line-of-business analysis
- Improved collaboration through the Web
- Key external industry metrics that provide one central point of financial intelligence

Designed for large-scale, centralized Web deployment, Financial Management acts as a shared financial resource for thousands of users across the enterprise, enabling them to collaborate and cooperate in the day-to-day business management. In one application, users can produce auditable documents and forecasts for multiple consumers, such as regulatory bodies, financial analysts, stakeholders, and business partners.

- “Financial Management Features Available in Web Analysis Documents” on page 364
- “Related Content” on page 364
- “Cell Text” on page 364
- “Line-Item Detail” on page 364
- “Related Content Changes” on page 364
Financial Management Features Available in Web Analysis Documents

Financial Management features extended to Web Analysis documents:

- Organization by period
- Advanced member selection
- Cell text, related content
- Line-item detail, related content
- User-defined fields
- Entity currency display

Related Content

The Related Content dialog box links to previously configured, related content and applications. When LRO indicates are enabled, blue triangles are displayed in spreadsheet cells that contain links to related content. Right-clicking linked cells and selecting Related Content displays the Related Content dialog box.

Cell text and line-item detail are accessed as related content.

Cell Text

You can launch cell text notes, read-only text strings stored in the Financial Management data source.

Line-Item Detail

You can launch line-item-detail spreadsheets, read-only relational spreadsheets created from Financial Management data sources.

Related Content Changes

Changes to cell text and line-item detail items are not displayed in Web Analysis documents until Financial Management is recalculated and changes registered.
Organization by Period

Financial Management Organization by Period functionality enables an organization’s latest consolidation structure to coexist with past structures in one application.

Thus, dimension hierarchies can be consolidated differently during different periods. Organizational structures can change for many reasons, including acquisitions, disposals, mergers, and reorganizations.

You can access Org by Period functionality when Org by Period is configured and set on the Financial Management server.

When querying Financial Management database connections configured with Org by Period, the Data Layout Options button displays an Org by Period item. The Org by Period dialog box offers an interface for enabling Org by Period and selecting three members.

Note:
You can review and set this feature only in Web Analysis Studio, but settings are observed by the HTML Web client.


Financial Management Advanced Member Selection

In dimensions with large member sets, users can define selections with the Dimension Browser right-click menu. Right-clicking member names enables selection by familial relationship and database-specific options.

Financial Management offers a smaller set of advanced member selection methods than does Analytic Services.

| Table 110 Financial Management Advanced Member Selection Methods |
|-------------------|---------------|
| **Right-Click Menu Command** | **Description** |
| All Members | Selects all members—a Financial Management member selection method |
| Select Dim Top | Selects the highest ancestor |
| Select Dim Bottom | Selects the lowest descendants |
| Also Select Descendants | Selects the currently member and its descendants |
| Member List | Displays the Member List dialog box, used to select lists of members—a Financial Management member selection method |
| User Defined Fields 1, 2, and 3 | Displays the User Defined Field dialog box, used to select members with specific user-defined field values |
| Search | Displays the Search dialog box, used to locate members |
User-Defined Fields

User-defined fields are typically defined only for Account, Scenario, Entity, and custom dimensions and are limited to 20 characters.

Users can compose compound selection statements by using multiple values for one field (for example, User Defined Field 1 = West AND User Defined Field 1 = East).

To define a user-defined field, users cannot use an empty string as a value.

Display Entity Currency

Financial Management stores currency metrics in the Value dimension and as Entity dimension attributes, thus enabling users to query data sources using selected or default currency values.

When using Financial Management data sources with defined Entity dimension currency information, you can enable the Display Entity Currency option, to append Entity members with their default currency values. Before querying, you use Data Layout options; after querying, you use the Data Display right-click menu; for all subsequently created documents, you use OLAP Server user preferences.

Note:

You can use Web Analysis Studio only to review and set this feature, but settings are observed by the HTML Web client.

Financial Management Conventions

Financial Management outlines have 12 dimensions, eight predefined (Period, View, Entity, Account, ICP, Scenario, Value, and Year) and four custom.

- “No Drill To Top” on page 366
- “No Edit Data” on page 367
- “Adding and Deleting Members” on page 367
- “New Databases” on page 367
- “Deleted Users” on page 367

No Drill To Top

When you query Financial Management, you cannot drill to top as you can when querying Analytic Services. Financial Management and Analytic Services track parent-child relationships differently. The Financial Management hierarchies enable multiple consolidations, thus enabling multiple parents for one child.
No Edit Data

Users cannot write back data to Financial Management data sources, as they can to Analytic Services data sources.

Adding and Deleting Members

Users must click the Reload button to display added or deleted members.

New Databases

Current sessions cannot interact with Financial Management data sources added during the session. Only data sources operating when a session is established can communicate with Web Analysis documents. To connect to new Financial Management databases, log off and then log on again.

Deleted Users

After you establish a Financial Management session, connection is valid until you log off, even if your user name is deleted server-side. Access is not revoked until the current session ends.

SAP BW

You can access SAP BW data sources in Web Analysis documents. Thus, you can extend your SAP BW investment by using advanced analytics and dashboards. Using the custom document freeform grid component, you can present OLAP, relational, and manually entered data on one data object and leverage all data sources in integrated dynamic calculations. Visually compelling SAP BW documents typically surpass the presentation, reporting, and distribution requirements of information consumers.

- “SAP BW Prerequisites” on page 367
- “SAP BW Conventions” on page 368
- “SAP BW Advanced Member Selection” on page 368

SAP BW Prerequisites

After installation, you must download the SAP BW JCo driver 2.1.4 or 2.1.5 from an SAP Web site.

Two Microsoft DLL files, MSvcr71.dll and MSvcp71.dll, are deployed to a common directory during installation. The files are used by Production Reporting, Financial Reporting, and Web Analysis.

You must locate the SAP BW JCo Driver in the DLL files directory.
SAP BW Conventions

SAP data sources differ from other data sources. For example, level 0 is the highest ancestor in SAP and the lowest descendant in Analytic Services. SAP member properties are analogous to Analytic Services attribute dimensions.

SAP BW Advanced Member Selection

In dimensions with large member sets, users can define selections with the Dimension Browser right-click menu. Right-clicking member names enables selection by familial relationship and database-specific options.

SAP BW and Analytic Services offer different sets of advanced member selection methods.

Table 111  SAP BW Advanced Member Selection Methods

<table>
<thead>
<tr>
<th>Right-Click Menu Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>All Members</td>
<td>Selects all members</td>
</tr>
<tr>
<td>Select Dim Top</td>
<td>Selects the highest ancestor, or, in multiple hierarchies, all top level ancestors</td>
</tr>
<tr>
<td>Select Dim Bottom</td>
<td>Selects all lowest level descendants</td>
</tr>
<tr>
<td>Also Select Descendants</td>
<td>Selects the current member and its descendants</td>
</tr>
<tr>
<td>Select Parent</td>
<td>Selects the parent of the current member</td>
</tr>
<tr>
<td>Also Select Ancestors</td>
<td>Selects the current member and its ancestors</td>
</tr>
<tr>
<td>Also Select Children</td>
<td>Selects the current member and its children</td>
</tr>
<tr>
<td>Also Select Siblings</td>
<td>Selects the current member and members on the same level and of the same parent</td>
</tr>
<tr>
<td>Also Select Level</td>
<td>Selects the current member and all members on the same level and of the same dimension</td>
</tr>
<tr>
<td>Select At Level</td>
<td>Selects all members at a level specified by name or number</td>
</tr>
<tr>
<td>Also Select Previous</td>
<td>Selects a variable number of previous members from the level of the current member; uses MDX LAG to indicate the number of previous members to return</td>
</tr>
<tr>
<td>Also Select Next</td>
<td>Selects a variable number of next members from the level of the current member; uses MDX LEAD to indicate the number of subsequent members to return</td>
</tr>
<tr>
<td>Date Time Series</td>
<td>Selects time members based on time definition criteria. SAP BW does not return aggregated values for DTS selections and returns only members that satisfy the criteria.</td>
</tr>
<tr>
<td>Select Top/Bottom</td>
<td>Returns a variable number of members, based on their rank</td>
</tr>
<tr>
<td></td>
<td>You can select top or bottom values, but not both. Rank can be calculated by percentage, sum, or count. Sum uses a threshold value to select members up to and including the value that limits the threshold.</td>
</tr>
<tr>
<td></td>
<td>Result sets may differ from Dimension Browser preview, due to custom filter selections on the query.</td>
</tr>
<tr>
<td>Right-Click Menu Command</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Filter on Member Properties</td>
<td>Displays the Member Properties dialog box, used to select member subsets by member SAP BW property values</td>
</tr>
<tr>
<td>Find in Tree</td>
<td>Locates members in large dimensions; expands the hierarchy but does not add found members to the Selection list</td>
</tr>
</tbody>
</table>

**Relational Access**

Web Analysis documents, using one of five methods, can access OLAP, Hyperion, and supported relational databases.

- “Custom Document SQL Spreadsheet” on page 369
- “Custom Document Freeform Grid” on page 369
- “Relational Drill-through” on page 369
- “Relational Database Connections” on page 370
- “Analytic Integration Services Drill-through” on page 370
- “Repository” on page 370
- “Controlling Query Result Set Size” on page 370

**Custom Document SQL Spreadsheet**

SQL spreadsheet objects represent relational data sources as spreadsheets, using standard SQL syntax queries.

**Custom Document Freeform Grid**

Freeform grids enable users to combine data values from multiple data sources in one data object and thus leverage custom document database connections.

**Relational Drill-through**

You can construct seamless liaisons between OLAP data and relational data sources. Navigation from OLAP to relational data is typically called *relational drill-through*. Users can navigate from the dimension bottom (level 0) of OLAP databases and drill down to relational data.

Web Analysis documents store relational drill-through definitions, which can be defined with Select statements and clauses, as database connection properties of Analytic Services database connections. Query result sets are presented as SQL spreadsheets.

See “Integrating OLAP and Relational Data” on page 360.
Relational Database Connections

Web Analysis Studio provides users with an easy-to-use graphical interface for defining relational database connections. You are prompted to specify relational database type and login credentials, select a relational table, and define database-connection properties.

Web Analysis documents relational data sources, aggregates result sets, and expresses data as OLAP cubes.

Analytic Integration Services Drill-through

Analytic Integration Services Drill-through is a server-based form of relational drill-through. Like conventional relational drill-through, you can construct seamless connections between OLAP and relational data. Unlike conventional relational drill-through, you can drill to relational data sources from all Web Analysis document intersections.

Analytic Services administrators must establish Analytic Integration Services drill-through reports. Relational queries are stored as intersection-specific metadata and flagged with LRO indicators. When users double-click flagged cells, OLAP documents navigate to the specified relational report.

Repository

Repository access is the only mandatory form of relational database access. The repository centrally stores system data, user names, user preferences, and document definitions in relational database tables. Without repository access, you cannot save information. Administrators establish repository access during installation.

Controlling Query Result Set Size

Query governors vary for relational access methods.

Custom document SQL spreadsheets and relational drill-through methods enable users to declare query governors as they create SQL queries or relational drill-through definitions.

When you drill from OLAP to relational data, passing only the drilled OLAP member to the relational data source may result in a large query result set. To focus and diminish query result sets, users can pass page and filter dimensions specified in the OLAP documents.

Other relational access methods rely on the Analysis.properties file to limit query result sets.

Custom Web Analysis Documents

Web Analysis Studio provides twenty-one coding-free components, each of which can be customized and added to custom documents multiple times. Combination options provide almost unlimited creative opportunities for custom-document designers.
Note:
Custom documents cannot be created in Web Analysis Workspace.

- “Containers” on page 371
- “Content Panels” on page 371
- “Data Objects” on page 371
- “Subscription Controls” on page 372
- “SQL Spreadsheet and SQL Subscription” on page 372

Containers
Panel and Split Panel objects enable you to control space and layers on custom documents. It is best to use container panels to design documents and to orient components inside panels. Components placed with absolute alignment in the main document panel maintain position even as other components fluctuate. Thus, components may overlap and shift.

You can size, align, and establish properties for panels. Properties control appearance and behavior.

Content Panels
Panels that provide specialized content:
- Label—Static or dynamic text for use as titles, labels, or captions
- Text Area—Dynamic text used for annotations
- Image—A graphic used to include graphic backgrounds, pictures, illustrations, and graphic controls
- HTML Browser—Static HTML

The panels function without additional coding. Label objects support the dynamic text labels used in printing headers, footers, and SQL spreadsheets.

Data Objects
Data objects representing display types (on the component toolbar):
- Chart—query result sets as charts
- Spreadsheet—query result sets as spreadsheets
- Freeform Grid—content from freeform grids
- Pinboard—query result sets as pinboards

SQL spreadsheet data objects are also available, at the end of the component toolbar.
Subscription Controls

You can add controls to documents to enable users to navigate dimensional hierarchies, browse the documents, or execute commands.

- **Combo Box Subscription**—View a list of members.
- **Radio Button Group Subscription**—Select a member option.
- **Checkbox Group Subscription**—Select multiple members.
- **Tab Group Subscription**—Select a member tab.
- **Multi-level Combo Box Subscription**—Select from interdependent lists (members changing as selections change).
- **Slider Subscription**—Select a member, based on its position on a slider bar.
- **Selection Button Subscription**—Apply member selections to data objects that use the same data source.
- **Alias Controller**—Toggle data objects between alias table labels.
- **Services Button**—Execute pre-set commands and create hotspots.

Subscription buttons can control data objects that share a database connection query.

SQL Spreadsheet and SQL Subscription

Components that present and control SQL query result sets.

- **SQL Spreadsheet**—a data object that displays a SQL query to a relational data source
- **SQL Subscription**—a subscription button designed for SQL spreadsheets

Linking Components by Query

Specifications required for document creation:

- **Data source**—provides data values
- **Data object**—displays data values
- **Query**—Retrieves data values from data sources and returns them to data objects

Properties that customize the specifications:

- Database connection properties indicate data-source type, logon credentials, database applications, dimension formatting, and drill-through properties.
- Data objects can be set to display types that feature specific options.
- Queries can be explicit, requesting information on members, or dynamic, requesting information about all members that satisfy a set of criteria.

In Design Document mode, query definitions are referred to as *data sources*.

- “Common Data Sources” on page 373
Common Data Sources

Design document components using the same data source are coordinated (follow the same navigation lines).

Unlinking Components

If you do not want coordinated document components, you can assign multiple data sources to a data object. Identical data sources with different names are treated as individual sources.

Linking Dimensions

You can use Custom settings to link dimensions within data objects on a document. Dimension linking enables data objects that share dimensions but use different data sources to remain coordinated. Links are unidirectional. Navigation on a data object triggers coordinated navigation on the data objects linked to it. Navigation on the other data objects triggers coordinated navigation only the objects have defined links.

Edit Data Mode

If you have permission, you can edit cell values and write edits back to Analytic Services. You can initiate Edit Data mode only from the spreadsheet display type.

➤ To initiate Edit Data mode in a Web Analysis document, right-click the data object, and select Edit Data.

Edit Data buttons are added to the content area. Editable cells in Analytic Services are converted to data-entry cells.

| Table 112  HTML Web Client Edit Data Controls |
| --- | --- |
| Control | Description |
| Calculation list | Specifies the calculation script to use when the database is recalculated from the HTML Web client |
| Run | Prompts the database server to recalculate the database |
| Exit | Closes Edit Data mode |
| Send Data | Applies edits to the database |
**Editing Data Values**

To edit data values:

1. Right-click the data object, and select Edit Data.
2. To recalculate the database, from Calculation, select a calculation script, and click Run.
3. Click a cell to edit its data value.
4. Enter a data value, and click the column or row heading.
5. Click Send Data.

   Only authorized users can successfully write changes to the database. The Confirmation dialog box is displayed if write-back is successful.

6. Optional: Perform step 2 to recalculate the data.
7. Click Exit.

**Note:**

On long spreadsheets, you may need to scroll down and to the right to locate the Send Data and Exit buttons, on long spreadsheets.

**Copying, Cutting, and Pasting To and From Excel**

While in Edit Data mode, you can cut, copy, and paste ranges of cells from Excel spreadsheets into Web Analysis spreadsheets. The edits can then be posted to Analytic Services. You can also cut, copy, and paste between values.

Keyboard shortcuts:

- To copy, select a range of cells, and press Ctrl + C.
- To cut, select a range of cells, and press Ctrl + X.
- To paste, select a range of cells, and press Ctrl + V.

**Tips for Edit Data Mode**

- You cannot edit calculated members or attribute dimensions, because their values do not reside in the database.
- Dimensions composed of implied shares (or user-defined hierarchies) do not aggregate as conventional dimension hierarchies do. Therefore, implied shares may overwrite data edits made to parents of implied shares as the model is pivoted.

**Example:** Actual and Budget are implied shares of the parent Scenario. Scenario, however, is a categorical label, not an aggregation of Actual and Budget measures.
In This Chapter

Overview ....................................................................................................................... 375
Scheduling and Running Jobs ..................................................................................... 375
Scheduling Batches .................................................................................................... 390
Preparing Batch Files for the Command Line Scheduler ........................................... 399

Overview

In Workspace, you use the Schedule module to perform the following tasks:

- Run and schedule job types:
  - Interactive Reporting job – An Interactive Reporting document imported in Workspace as a job and its associated files.
  - Production Reporting job – A Production Reporting report or program and its associated files. A Production Reporting job can be secure or nonsecure.
  - Generic job – A report or program from another software provider (for example, an Oracle report or a Crystal report), and any associated files.

- Run and schedule batches, which are collections of reports.

Scheduling and Running Jobs

You can manually run jobs from the Explore module. Select the jobs you want to run, enter the job parameters, then view the job output. You can also run jobs automatically by scheduling your jobs to run using events and job parameters.

The scheduler module contains four panels for scheduling jobs:

- Managing Jobs - Use this to list jobs with parameters or schedules.
- Viewing Job Status - Use this to see the status of running jobs and notifications for jobs that are finished.
- Managing Events - Use this to create and manage events.
- Using the Consolidated Job Status List - Use this to view a list of jobs with the option to filter the list and modify the jobs, schedules or events.
If your administrator enabled the pass-through feature, you can configure foreground jobs to run without additional requests for data source login credentials. You can run jobs in the foreground or in the background depending upon how the job was configured by the importer.

Scheduling and Running Jobs includes the following topics:

- “About Job Execution” on page 376
- “Events” on page 377
- “Event Status and Schedule Status” on page 377
- “Job Parameters” on page 378
- “Running Jobs” on page 378
- “Scheduling Jobs” on page 380
- “Using Job Output” on page 382
- “Managing Events” on page 382
- “Managing Jobs” on page 385
- “Viewing Job Status” on page 385
- “Using the Consolidated Job Status List” on page 385
- “Retrieving Jobs” on page 390

### About Job Execution

When a job executes in the foreground, you must wait until the job completes before continuing with other tasks. When a foreground job finishes executing, Workspace displays:

- For Interactive Reporting jobs, a link to the output in the folder where the job resides
- For Production Reporting jobs, the HTML frame file
- For generic jobs:
  - The primary output file, if there is only one
  - A list of primary output files, if there are multiple files
  - A list of all output files, if there is no primary one

When a job is executing in the background, you can perform other tasks in the foreground. When the background job finishes executing, the output files are written to the repository, and a notification message is displayed in the View Job Status panel of the Schedule module.

The Output link is displayed next to the job title. Click the Output link to view the job output.

- “Job Priority” on page 376
- “Scheduling Jobs” on page 377

### Job Priority

When jobs are scheduled to process at the same time, jobs with High priority run first. You can set the priority to High or Normal when you schedule the job.
**Scheduling Jobs**

Scheduling a job enables you to automatically run jobs at a date or time and/or on a recurring basis. To schedule a job, you must associate a time event and a job parameter list with the job. All types of jobs can be scheduled through Workspace.

- Events define the timetable for running a job
- Job Parameters define the run time values necessary to execute a job

**Note:**

For SQR Production Reporting jobs, compile time parameters may also be specified with job parameters.

- Schedules specify the job you want to execute, as well as the event schedule and job parameter list for running the job

**Events**

Events define when the job runs and whether the job runs only once or many times. You can determine whether the job runs every Wednesday, or every fourth Friday, or after an event occurred.

Because events are not associated with a particular job, you can use them to schedule multiple jobs. You can create personal recurring time events that only you can use. You may have access to public recurring time events and externally triggered events your administrator created.

You can create events as you schedule a job or from the Schedule module using the Manage Events panel. You can also view, modify, access, or delete time events.

The types of events that can be used for scheduling jobs are:

- Public recurring time events – Reusable time events created by an administrator and accessible to you with the required access privileges.
- Personal recurring time events – Reusable time events created by you and accessible only to you.
- Externally triggered events – Date based events created by an administrator and accessible to you with the required access privileges. Jobs are scheduled to run when the event is triggered.
- Custom time events – Time events created by you for one time use within a job schedule. Custom events cannot be used by other job schedules.

**Event Status and Schedule Status**

Events and Schedule each maintain their own status, which is displayed by a traffic light indicator. The following table shows how the status enables a job to run. You can set the status when you modify the event or schedule.
Table 113  Event Status and Schedule Status

<table>
<thead>
<tr>
<th>Event Status</th>
<th>Schedule Status</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>active</td>
<td>active</td>
<td>The scheduled job runs</td>
</tr>
<tr>
<td>active</td>
<td>inactive</td>
<td>The scheduled job will not run</td>
</tr>
<tr>
<td>inactive</td>
<td>active</td>
<td>The scheduled job will not run</td>
</tr>
<tr>
<td>inactive</td>
<td>inactive</td>
<td>The scheduled job will not run</td>
</tr>
</tbody>
</table>

**Job Parameters**

Job parameters are run-time values that are necessary to run a job. The run-time values are the job variables or limits you are prompted for by the job. For some Interactive Reporting jobs, job parameters also include processing and job output options. You can save job parameters to:

- Run or schedule jobs without being prompted for the run-time values
- Share Public job parameters with other users
- Run jobs using different parameters on a schedule

Workspace supports the following types of job parameters:

- Public job parameters – Reusable named job parameters created by your administrator and accessible to you with the required access privileges.
- Personal job parameters – Reusable named job parameters created by you and accessible only by you.
- Custom job parameters – Unnamed job parameters created by you and associated with a schedule. Default job parameters are not listed or named and cannot be used with other schedules. They are deleted when the schedule is deleted.

**Note:**

Job parameters can only be created when creating or modifying a job schedule or when running a job. See “Running Jobs” on page 378 or “Scheduling Jobs” on page 380 to see how to get to the job parameters section.

**Running Jobs**

This section provides general instructions for running a job and setting your default job parameters.

➤ To run jobs:

1. In the Explore module, navigate to the job you want to run, then do one of the following:
   - From the menu bar, select File > Run Job.
   - Double click the job.
• Right-click the job, from the shortcut menu, select Run Job.
  The job is opened in the Viewer module.

• Right-click the job, from the shortcut menu, select Run Job in > Foreground.
  When you run jobs in the foreground, a progress bar displays status and you cannot perform
  other tasks until it is complete.

• Right-click the job, from the shortcut menu, select Run Job in > Background.
  When you run jobs in the background, you can continue working in Workspace.

2 If database authentication is required, enter the user name and password for each connection in the Database
  Connectivity section.
  The Database Connectivity section is displayed only if database authentication is required.

3 For SQR Production Reporting and Generic jobs, browse to specify a folder destination for the job output.
  The default folder is the folder where the job is located.

4 In the Job Parameters section, define parameters using an existing job parameters list or create one.
  If the job has no run-time variables, the job parameters section is not displayed.
  To set personal default job parameters, see “Setting Job Parameters” on page 379.

5 If you are using default parameters, click Run Job.

6 Set values, limits, or define or modify cycles depending upon the type of job you are running.
  See “Setting Job Parameters” on page 408 and “Setting SQR Production Reporting and Generic
  Job Parameters” on page 429.

7 Click Run Job.
  Job parameters selected when jobs are imported are called Publisher defaults. You can override
  these Publisher defaults at run time and set your own job parameters. Your jobs run with your
  Publisher defaults until you change them.

Setting Job Parameters

➤ To set your default job parameters:

1 In the Explore module, navigate to the job you want to run, right-click, then select Run Job.

2 Select an existing job parameter list or New Values.

3 Set values, set limits, or define or modify cycles depending upon the type of job you are running.
  See “Setting Job Parameters” on page 408 and “Setting SQR Production Reporting and Generic
  Job Parameters” on page 429.

4 Do one or more of the following steps:
  • Check Save as my default.
  • Check Save, then select Public or Private.

5 Click Run Job.
Your job parameters are not saved until you run the job.

**Scheduling Jobs**

This section provides general instructions for scheduling a job.

➤ To schedule a job:

1. **In the Explore module, navigate to the job you want to run.**
   - From the menu bar, select *File > Schedule Job*.
   - Right-click the job and choose *Schedule Job*.
     The job is opened in the Viewer module.

2. **Right-click the job and select **Add a Schedule**.**

3. **Fill in the properties.**
   - **Name**—(Required) The Name can contain letters, numbers, the space character, and the underscore character “_”.
   - **Description**—A meaningful description of the schedule. For example, *Quarter end for all regions*. The length is limited to 254 characters.
   - **Priority**—When jobs are scheduled to process at the same time, jobs with High priority are run first. Select High or Normal priority.
   - **Active**—This is displayed when you modify a schedule only. A traffic light that indicates if the job is scheduled to run.
     - A green traffic light indicates that the job is scheduled to run.
     - A red traffic light indicates that the job is not scheduled to run.
   - **Run this job**—Infinitely or a specified number of times. The job automatically becomes inactive after it runs the indicated number of times.
   - **Job Output**—Enable to automatically delete job output. Indicate when to delete by entering a number and selecting a time interval (minutes, hours, days, weeks, years) after the job is run. Default is days.
   - **User name and Password**—You are prompted for database authentication if it is required.

4. **Click Next.**

5. **In the Job Parameters section of the Select Job Parameters page, select one of the following options:**
   - To create job parameters from scratch, select *Define job parameters starting with* and select *New Values*.
   - To create job parameters from existing job parameters, select *Define job parameters starting with* and select a job parameter. This enables you to quickly create a job which is similar to an existing job. Make changes to the parameters and save the completed job parameters using a different name.
To use or view job parameters, select Schedule this job with existing job parameters and select the parameters you want to use from the drop-down list. Click View if you want to see the parameters before you move on to the next screen.

If the job has no parameters (no run time variables or limits), the job parameters section is not displayed.

If there are no job parameters, you must create them.

6 Click Next.

7 From the Time Events page, indicate if you want to create an event or use an existing event using one of the following options.

- To create an event from scratch, select A New Recurring Time Event from the drop-down list. See “Creating Personal Recurring Time Events” on page 383.

- To create an event from an existing event, select Define when to run this job starting with and select an event. This enables you to quickly create an event similar to an existing event. Make changes to the event and save it using a different name. See “Creating Personal Recurring Time Events” on page 383.

- To use an existing event, select Schedule this job using an existing event and select the event you want to use.

- To view an event, select Schedule this job using an existing event and click the event you want to view.

If there are no events, you must create one.

Note:

If a schedule is associated with an inactive event, the job is not run. You can check the active status of an event by viewing your events on the Manage Events panel of the Schedule module.

8 Click Next.

9 If desired, configure notification options.

- If you want to view your notifications in the Schedule module using the Manage Jobs panel, select Display notification in Schedule Module.

- If you want to E-mail the notification, enter E-mail addresses. Separate E-mail addresses by semicolons, colons, space characters, commas, or new lines.

- If you want to attach the latest job output to the E-mail, select Attach PDF outputs to E-mail messages.

For Production Reporting jobs, see additional notification options in “Output Options for Scheduling Jobs” on page 429.

10 Specify the Save to Output options.

11 Click Finish to schedule the job.
Using Job Output

When jobs run, the results are placed in job output items. This section describes modifying job output properties and viewing job output. Job output deletion is streamlined. When you delete jobs, you can also delete all associated outputs.

Modifying Job Output Properties

Job output properties determine which users can view the job output. Job output is listed in the same folder as the job. Each run of the job produces job output, which is listed separately. You can modify or view the job output properties depending on your access privileges on the job.

To modify or view job output properties:
1. From the Explore module, navigate to the job output, and click it.
2. Select File > Properties.

Note:
You can also right-click on an artifact and select Edit Permissions.

3. Change the properties or click Edit Permissions to change the access control.

In the Access Control section, when assigning access to additional users, groups, or roles, the adaptive state is limited to View Only. Also, the adaptive state cannot be modified for the existing roles, groups, and users. You can modify the adaptive state for future job output when modifying the access control for the job.

To modify access control, see “Setting Permissions” on page 113.
4. Click OK.

Viewing Job Output

You can open job output and a table of contents is displayed to navigate through the job output.

To view job output:
1. From the Explore module, right-click the job output file, then select Open.
   The table of contents is displayed for items in the job output.
2. Click an item, then click Open.
3. To return to the table of contents and view other items, select the TOC tab in the content tab.

Managing Events

From the Schedule module, use the Manage Events panel to:

- View events which you can access
• Make events accessible to other users using access control
• Modify, delete, or create events

To manage events:
1 Select Navigate > Schedule > Manage Events.
2 To filter the events displayed, from Display Only select an event type, then click Update List.
   All the events you can access are listed with their properties.
3 To modify or delete an event, click Modify or Delete.
4 To create a personal time event, see “Creating Personal Recurring Time Events” on page 383.

Creating Personal Recurring Time Events

To create a personal recurring time event:
1 Select Navigate > Schedule > Manage Events.
2 To filter the events displayed, from Display Only select an event type, then click Update List.
3 From Add Another, select Personal Recurring Time Event, and click Go.

Note:
You must be an Administrator to add a Public Recurring Time Event or Externally Triggered Event.

4 Enter the time event name and description.
5 Click Active to make the Event available for scheduling.

Note:
If a schedule is associated with an inactive event, the job will not run. You can check the event’s active status by using the Manage Events panel in the Scheduler.

6 Select the calendar you want to use for this time event.
   Company calendars are created by your administrator.

7 From the Days to Run list, select the option you want to use and click Go (By Day is the default).
   By Day, By Week, By Period, By Quarter, and By Year let you specify a recurring time pattern. Advanced Days of Week and Advanced Days of Period give you the option to select days with no pattern.

8 From the Time to Run list, select the option you want to use and click Go (Once per hour is the default.)
   The options include Once per Hour, Once Per Day, More Than Once Per Day, or External Event.

9 Update the Starting At and Ending At time to specify a range for the event.
10 Enter a Start Date and select the option to enter an End Date or to accept the default, No End Date.
11 Click Finish.
Viewing Events

You can view all your events from the Manage Events panel in the Schedule module.

➤ To view events:

1 Select Navigate > Schedule > Manage Events.
   A recurring and externally triggered event list is displayed.
2 To filter the events list, select Public or Personal from the Display only list and click Update List.

Modifying Events

You can modify events from the Manage Events panel in the Schedule module.

➤ To modify events:

1 Select Navigate > Schedule > Manage Events.
   A recurring and externally triggered event list is displayed.
2 To filter the events list, select Public or Personal from the Display only list and click Update List.
3 Click Modify next to the event.
4 Change properties.
5 Click OK.
   The modified event is displayed in the events list.

Deleting Events

You can delete events unused by schedules or other events. For example, if an external event is used to trigger a recurring event, the recurring event needs to be deleted or disassociated from the external event before the external event can be deleted.

➤ To delete events from the Manage Events panel in the Schedule module.

1 Select Navigate > Schedule > Manage Events.
   An event list is displayed.
2 To filter the events list, select Public or Personal from the Display only list and click Update List.
3 Click Delete next to the event, and confirm deletion by clicking Yes.
   If schedules are associated with the time event you are deleting, modify those schedules to use another time event.
   Before you delete a time event associated with an external event, disassociate the time event from the external event or delete the external event.
Managing Jobs
From the Schedule module, use the Manage Jobs panel to:

- Display all jobs that have schedules or parameters.
- Modify job parameters.

➤ To manage jobs:
1. Select Navigate > Schedule > Manage Jobs.
   A page is displayed with jobs and their associated schedules.
2. To see a schedule, click the schedule link.
3. To see job parameters, click the job.

Viewing Job Status
From the Schedule module, use the View Job Status panel to:

- Display scheduled job status or jobs running in the background.
- Display notifications for jobs that have completed.

➤ To view job status:
1. Select Navigate > Schedule > View Job Status.
   A page is displayed with two lists: jobs currently running and completed job notifications.
2. To delete job completion notifications:
   - To delete one notification, select the notification check box, right-click, then select Delete.
   - To delete all notifications, select the check box at the top of the column to select all, right-click, then select Delete.
3. From the completed job list:
   - To view the job output, click the link.
   - To view the schedule, click the link.

Using the Consolidated Job Status List
From the Schedule module, use the Consolidated Job Status panel to:

- Filter the job list shown in the Consolidated Job Status List, see “Filtering Consolidated Job Status List” on page 386.
- Modify job properties. See “Modifying Job Parameters” on page 389
- Modify schedule properties. See “Modifying Schedules” on page 388
- Modify event properties. See “Modifying Events” on page 384
To update a scheduled job list:

1. Select the Navigate > Schedule > Consolidated Job Status.

Without default filter criteria, the filter page is displayed before the Consolidated Job Status List page. To filter the Consolidated Job Status List, see “Filtering Consolidated Job Status List” on page 386.

The following table lists the column descriptions on the Consolidated Job Status List page.

<table>
<thead>
<tr>
<th>Table 114</th>
<th>Consolidated Job Status List Columns</th>
</tr>
</thead>
<tbody>
<tr>
<td>Job Name</td>
<td>Displays the job name.</td>
</tr>
<tr>
<td>Job Owner</td>
<td>Displays the job owner’s login id. A non-administrator user must have view access to display jobs.</td>
</tr>
<tr>
<td>Schedule Name</td>
<td>Displays the job schedule name.</td>
</tr>
<tr>
<td>Schedule Owner</td>
<td>Displays the scheduler owner’s login id. Only administrators can see schedules owned by others.</td>
</tr>
<tr>
<td>Event Name</td>
<td>Displays the event name.</td>
</tr>
<tr>
<td>Last Run Date</td>
<td>Displays the date the job last ran. If the schedule or event is inactive, this column displays Schedule Inactive or Event Inactive.</td>
</tr>
<tr>
<td>Last Status</td>
<td>Displays the status from the last time the job ran.</td>
</tr>
<tr>
<td>Next Run Date</td>
<td>Displays the next date the job will run.</td>
</tr>
<tr>
<td>Links</td>
<td>Displays image links. Click a icon link to:</td>
</tr>
<tr>
<td></td>
<td>● modify job properties</td>
</tr>
<tr>
<td></td>
<td>● modify schedule properties</td>
</tr>
<tr>
<td></td>
<td>● modify event properties</td>
</tr>
<tr>
<td></td>
<td>● add schedules.</td>
</tr>
</tbody>
</table>

2. Optional: To display more jobs:
   - Click Prev or Next.
   - Enter a number in Jobs per page, then click Go.

3. Optional: To delete schedules, select the check box for a schedule, then click Delete Checked Schedules.

To select all schedules, click the check box at the top of the column.

**Filtering Consolidated Job Status List**

You can filter your job list using the filter criteria listed in Table 115. A particular filter is not set when it is blank. The Consolidated Job Status List is sorted by the filter you selected in the Default Sort Order field from the filter page.
To set filters and sort criteria for the Consolidated Job Status List:

1. Select Navigate > Schedule > Consolidated Job Status.
2. If default filter settings do not exist, select filter settings. See Table 115 for more details on the filter criteria.
3. Determine the sort order by selecting the Default Sort Order from the drop-down list and the options indicating ascending or descending order.
   The default sort filter is the job name. For descriptions of sorting filters, see Table 115.
4. Click a button:
   - **Apply** - Saves your values for one session.
   - **Save As Default** - Saves your values as your default values.
   - **Restore to Default** - Retrieves the values you last saved as your default values.
   - **Cancel** - Saves no values.

<table>
<thead>
<tr>
<th>Table 115 Job Filters</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Job Name</strong></td>
</tr>
<tr>
<td><strong>Job Owner</strong></td>
</tr>
<tr>
<td><strong>Schedule Name</strong></td>
</tr>
<tr>
<td><strong>Schedule Owner</strong></td>
</tr>
<tr>
<td><strong>Event Name</strong></td>
</tr>
<tr>
<td><strong>Last Status</strong></td>
</tr>
<tr>
<td><strong>Last Run Date</strong></td>
</tr>
<tr>
<td><strong>Next Run Date</strong></td>
</tr>
<tr>
<td><strong>Default Sort Order</strong></td>
</tr>
<tr>
<td><strong>Schedule State</strong></td>
</tr>
</tbody>
</table>

**Managing Individual Job Schedules**

To manage schedules:

1. From Explorer, right-click a job and select Manage Job Schedules.
2. Review Schedules information:
Table 116  Schedules

<table>
<thead>
<tr>
<th>Schedule Name</th>
<th>The name of the schedule</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>A schedule description</td>
</tr>
<tr>
<td>Event</td>
<td>Type of action</td>
</tr>
<tr>
<td>Next Run Date</td>
<td>Next scheduled run</td>
</tr>
<tr>
<td>Job Parameter</td>
<td>Custom parameter settings.</td>
</tr>
<tr>
<td>Modify</td>
<td>Click to modify a schedule. See “Modifying Schedules” on page 388.</td>
</tr>
<tr>
<td>Delete</td>
<td>Click to delete a schedule.</td>
</tr>
</tbody>
</table>

3 Review Job Parameters information:

Table 117  Job Parameters

<table>
<thead>
<tr>
<th>Job Parameter</th>
<th>The name of the parameter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>A parameter description</td>
</tr>
<tr>
<td>Ownership</td>
<td>Owner of parameter</td>
</tr>
</tbody>
</table>

Modifying Schedules

When your schedule needs changes, you can modify it.

➤ To modify a schedule:

1 Select Navigate > Schedule > Consolidated Job Status.
   A list of all jobs that you can access is displayed.

2 Under Job Name, locate the job.

3 Under Links, click Modify Schedule Property in the job row.

4 Change properties.
   See “Scheduling Jobs” on page 380.

5 To deactivate or activate the schedule on the General Properties page toggle Active.

6 To modify more properties click Apply, otherwise click OK.

Deleting Schedules

➤ To delete a schedule:

1 Select Navigate > Schedule > Consolidated Job Status.
   A list of all jobs in the system is displayed.
2 Under Job Name, locate the job and select the check box.
3 Click Delete Checked Schedules.
   The schedule is deleted from all job schedule lists.

Adding Schedules

➤ To add a schedule:
1 Select Navigate > Schedule > Consolidated Job Status.
   A list of all jobs in the system is displayed.
2 Under Job Name, locate the job.
3 Under Links, click Add Schedule in the job row.
4 Follow the instructions in “Scheduling Jobs” on page 380 starting on step 3 on page 380.

Viewing Job Parameters

➤ To view job parameters:
1 Select Navigate > Schedule > Manage Jobs.
   A list of all jobs with schedules and parameters is displayed.
2 Click the job link.
   A schedule and job parameter list for the job is displayed on the Schedule Information page.

Modifying Job Parameters

➤ To modify job parameters:
1 Select Navigate > Schedule > Manage Jobs.
   A list of all jobs with schedules and parameters is displayed.
2 Click the job link.
3 On Schedules, click Modify.
4 In Schedule Properties, change job parameters. See “Modifying Job Parameters” on page 389.
5 Click OK.

Deleting Job Parameters

You can delete job parameters that are not being used by a schedule.
To delete job parameters:

1. Select **Navigate > Schedule > Manage Jobs**.
   
   A list of all jobs with schedules and parameters is listed.

2. Click the scheduled job to which the parameters are associated.

3. Click **Delete** next to the job parameters and confirm deletion by clicking **OK**.

   If no schedules are associated with it, the job parameter is deleted.

   If schedules are associated with it, you must associate the schedule with other job parameters by modifying the schedule.

**Retrieving Jobs**

You can retrieve a SQR Production Reporting job and its associated files.

To retrieve a SQR Production Reporting job:

From the Explore module, right-click the item, from the shortcut menu click **Retrieve**.

**Scheduling Batches**

Batch processing for Financial Reporting topics:

- “Scheduling Batches to Run” on page 391
- “Batch Deletion” on page 397
- “Retrieving the Exported Output” on page 398
- “Viewing the Status of Scheduled Batches” on page 399
- “Preparing Batch Files for the Command Line Scheduler” on page 399

Batches are created, edited, and saved in Workspace using the Batch Editor. You must have a Global Administrator, Report Designer, Scheduler, or Content Publisher role in order to perform these tasks. For role information, see the appendix in the *Hyperion Shared Services User Management Console Guide*. Batches are used to group and process sets of documents such as reports or books. You can send the output of a generated batch to a printer. You can export batches as HTML or PDF files to an external directory. You can e-mail users the exported output in PDF format.

**Note:**

Hyperion recommends that you print long reports or books in a batch. This keeps your computer free while processing.
Scheduling Batches to Run

You schedule batches to run immediately or at a later date. During batch scheduling, you can define the batch POV, set up e-mail notifications, and select the destinations of the generated output when the batch is run. Destination types can include Print to a designated printer, Snapshot to a designated repository folder, PDF to an external directory or attached to an e-mail, and HTML to a designated external directory (Batch Bursting does not support HTML). After selecting scheduled batch options, the batch is added to the batch queue from the Batch Scheduler after a successful run.

The scheduler’s batch bursting feature can run a batch for more than one member of a single dimension on the batch POV for one data source, e-mail the PDFs generated to a recipient list, and save the output to the file system or to the repository. For example, a batch scheduled to run for New York and Houston can have the output for New York going to jones@cd.com and the output for Houston going to smith@cd.com. With batch bursting, you can use predefined text functions for report labels and folder labels. You can create a Bursting Destination File (see About the Bursting Destination File) to override default settings assigned to the batch.

About the Bursting Destination File

The Bursting Destination File contains the default settings for the scheduled batch. You can periodically view the default settings as you navigate through the batch wizard. You can export the Bursting File as a CSV file to specify output and permissions exceptions for a scheduled batch, thus overriding the default settings defined in the Batch Wizard. The member settings in the CSV Bursting Destination file can be appended to the member selections in the Batch Wizard. For example, you may want to specify a different sub-folder for some reports, based on selected members, or make some reports read-only. Only members that are valid for the selected dimension are appended to the bursted file.

To edit the Bursting Destination File for a current batch, the administrator or designer exports the file to a text editor or Excel, enters the members, if not already displayed, and edits any values in the table. The values for each member in the dimension are: Subfolder Name, Financial Reporting Object Name, E-mail Address, Group Name, Role Names, User Names, External Root Folder for PDF.

Upon completion, the file must be imported into the repository (File > Import > File) where it can be applied to a batch in the batch wizard. A sample Bursting Destination File is stored in the Sample folder of your Reporting and Analysis installation.

Batch scheduling tasks:

- “Selecting a Member for the Batch Point of View” on page 392
- “Scheduling Job Bursting” on page 393
- “Specifying the Batch Destination and Bursted Output Labels” on page 393
- “Creating an E-mail List for Batch Bursting Recipients” on page 396

To schedule a batch to run:

1. Click Navigate > Schedule > Batch Scheduler.
3 Enter a name and description for the scheduled batch.

4 **Optional:** To delete the batch from the scheduler after a successful run, select **Delete Scheduled Batch Entry from Scheduler if Completed Successfully.**

5 Click Next to select a batch.

6 Select a batch and click Next. If required, **Logon Credentials** is displayed. Enter a User name and Password and click OK (see “Providing Logon Credentials” on page 400).

7 **For Start Time:**
   - To start the scheduled batch immediately, click **Now.** Go to **step 9.**
   - To start the scheduled batch in the future, select **Later, Start At** Go to **step 8.**

8 **To select the start time and date in the Start Time area:**
   a. In the upper left list boxes, enter the start time and the periodic time interval to run the batch (for example, daily, weekly).
   b. In the upper right drop-down lists, select a start date and end date.

9 **Optional:** If any of the reports and books in the batch have dimensions on the user POV, you can set the member for those dimensions in the **Scheduled Batch Point of View.** For information, see “Selecting a Member for the Batch Point of View” on page 392.

10 **Optional:** If you wish to use job bursting to run a batch for more than one member in a dimension on the Batch POV, see “Scheduling Job Bursting” on page 393.

11 Click Next.

12 Change the default settings for the Destination of the batch file that you are running, and click Next.

13 To save the batch job in the Batch Scheduler with the settings you selected for the destination, click Finish.

**Selecting a Member for the Batch Point of View**

Each scheduled batch has a POV based on all relevant dimensions for the reports in the batch. If no reports or books have a member on the user POV, then there is no batch POV. When the batch is added to the schedule, the user POV is specified as the default batch POV. You can override the user POV settings by specifying a member for each dimension on the batch POV. You must verify that the members selected in the batch POV are appropriate.

➤ To select a member for the batch POV:

1 To arrive at Batch Scheduler, see “Scheduling Batches to Run” on page 391.

2 From the **Scheduled Batch Point of View** area, click the dimension for which you want to select a member. **Member Selection** is displayed.

3 Select the member that you want to use for the POV and click OK. For more information on Member Selection, see Chapter 8, “Using Financial Reporting.”

4 Repeat **step 2** and **step 3** for each POV dimension.
Click Next to complete the batch destination of the batch. See “Specifying the Batch Destination and Bursted Output Labels” on page 393.

**Scheduling Job Bursting**

With each scheduled batch, you can use job bursting to run a report on more than one member in a dimension. When you select only a dimension for job bursting, the setting for that dimension on the batch POV is disabled. The unselected batch POV members remain active and are included with the batch. (If no reports or books have a member on the user POV, then there is no batch POV or job bursting).

To schedule batch bursting:

1. Use the batch scheduler wizard to navigate to the Start Time screen (see “Scheduling Batches to Run” on page 391).
2. In the Bursting Options area, select Run Batch for multiple members in the dimension, then select the dimension for job bursting.
3. Click , then select the members for job bursting. For information on Member Selection, see Chapter 8, “Using Financial Reporting.”
4. In Bursting File, if you have created a CSV Bursting Recipients list for this batch and imported it into the repository, click to select the file.
5. Click Copy Members to add the members defined in the CSV Bursting Recipients list to the Select Members list.

**Note:**

Only members that are valid for the selected dimension are added.

6. Click Next, To continue to batch destination, see “Specifying the Batch Destination and Bursted Output Labels” on page 393.

**Specifying the Batch Destination and Bursted Output Labels**

The Destinations area specifies the type and location of the output for the scheduled batch. Select any combination of the following output options for your batch destination:

**Note:**

Batch Bursting only supports output to Snapshot Reports, Books and PDF files; output to a printer and HTML are not supported for Batch Bursting.

- Snapshot reports or snapshot books—You can save snapshot reports and books within the originating folder (default location) or another folder in the repository. You can assign file permissions for viewing snapshot reports or books to users, groups, and roles.
● Print—You can select a printer and specify printer properties. The Batch Scheduler shows all printers available to the Print Server. Print Server configuration is specified in the fr_repserver.properties file on the Financial Reporting Server computer.

● Export as PDF—PDF files can be saved within a folder on the Scheduler Server or exported to an external directory. PDF files can be attached to an e-mail. Separate e-mail files can be sent for each report or sent once in a zip file.

Note:

To specify a maximum attachment size for e-mail output, use the property, MaxEmailAttachmentSize within fr_scheduler.properties file located in BIPlus/Lib on the scheduler machine. This value, entered in kilobytes, is used to split reports into multiple e-mails to conform to the maximum size attachments allowed per e-mail. The default is set to unlimited (0 (zero) or -ve). When sending an oversized attachment containing a single PDF file or numerous files, the e-mail fails to deliver and the sender is notified. For a single oversized file attachment, the sender can manually deliver the attachment by copying it from the scheduler server or external directories. For numerous files attachments, the sender can rerun the batch from the Batch Scheduler and select the option of sending individual e-mails for each file. This property applies to bursting and non-bursting output.

● Export as HTML—HTML files can be saved within a folder on the Scheduler Server or exported to an external directory. Job bursting is not supported for HTML files.

➢ To select batch destinations:

1 From the Destinations area, select any actions:

   ● Save As Snapshot in Repository: If you select this option, you enable the In Same Folder as Original Object and In Another Folder options. Perform an action:
     ○ Select In Same Folder as Original Object to save snapshots and snapshot books within the same folder as the original report or book in the repository.
     ○ Select In Another Folder to save the output to another location in the repository. Click Folder to select a destination folder in the repository, then click OK.

Note:

Selecting Save As Snapshot in Repository enables File Permissions. File Permissions allows you to assign access to users and groups for snapshot output. For information on assigning access permissions, see Chapter 9, “Designing Documents for Financial Reporting Batches and Books.”

● Print to—the default printer is displayed. Select a different printer and printer settings.

● Export as PDF—Export the batch as a PDF file on the scheduler server. To export to an external directory, select Export to an external directory. To attach the reports as e-mail attachments, select E-mail as PDF Attachment(s). To zip the e-mail attachments, select Zip PDF(s).
- **Export as HTML**—Export the batch as an HTML file on the scheduler server. To export to an external directory, select **Export to an external directory**. This option does not support batch bursting.

**Note:**

When **Export to an external directory** is selected, the enabled drop-down menu is populated by folder locations specified in the `fr_scheduler.properties` file in the `<FinancialReporting>\lib` directory on the Hyperion Financial Reporting Scheduler Server computer. Here is a sample from that file:

```ini
ExportFolderLabel1=ExportFolder1 # ExportFolderPath1=\\{machine name}\{export folder name}
```

A system administrator must determine all the folders where exports are permitted. Contact your system administrator to specify a different folder location.

- **Bursted Output Labels** — The **Object Label** and **SubFolder Label** fields display two default text functions that can optionally be used to identify the report and the report’s subfolder names, respectively. Click to select additional text functions. Click to test the functions. The available functions for bursted reports are:
  - `<<MemberName()>>` — Returns the name of the member being bursted. This function takes no parameters.
  - `<<MemberAlias()>>` — Returns the alias of the member being bursted. This function takes no parameters.
  - `<<MemberDescription()>>` — Returns the description of the member being bursted. This function takes no parameters.
  - `<<BatchPovMember(DataSrcName, DimName)>>` — Returns the name of the POV member being bursted where `DataSrcName` is the name of a data source of the desired POV (a batch can point to two or more POVs) and `DimName` is the name of the dimension under the given POV whose member name is to be extracted.
  - `<<BatchPovAlias(DataSrcName, DimName)>>` — Returns the alias of the POV member of the report being bursted where `DataSrcName` is the name of a data source of the desired POV (a batch can point to two or more POVs), and `DimName` is the name of the dimension under the given POV whose member description is to be extracted.
  - `<<BatchPovDescription(DataSrcName, DimName)>>` — Returns the description of the POV member of the report being bursted, where `DataSrcName` is the name of a data source of the desired POV (a batch can point to two or more POVs), and `DimName` is the name of the dimension under the given POV whose member description is to be extracted.
  - `<<FinancialReportingObjectName()>>` — Returns the name of the Financial Reporting object being bursted. This is typically the report name. This function takes no parameters.
  - `<<Financial ReportingObjectDescription()>>` — Returns the description of the Financial Reporting object being bursted. This is typically the report description. This function takes no parameters.
- `<<Date("format")>>` — Returns the date and time that an online report is populated with data, or the date and time a snapshot report is saved, where `format` is a list of characters enclosed in quotes that define the format of the date and time. See the *Hyperion Financial Reporting Studio User’s Guide*, Using Functions chapter for a list of all the `format` date and time characters.

- **Preview Bursting List** — Select to preview the CSV bursting list. The list shows the default settings selected for members in the job bursting batch. For information, see About the Bursting Destination File.

2 Click Next.

- If your scheduled batch includes e-mail PDF attachments with job bursting, the PDF Attachment Email dialog box is displayed. For instructions, see “Creating an E-mail List for Batch Bursting Recipients” on page 396.

- If your scheduled batch includes e-mail PDF attachments without job bursting, the Scheduled Batch Details dialog box is displayed. For instructions, see “Setting Up E-mail Notifications” on page 396.

### Creating an E-mail List for Batch Bursting Recipients

You can create a recipient list, a subject, and a message for recipients who will receive e-mails with PDF attachments through batch bursting.

➤ To create an e-mail recipient list:

1 Click Select to select and/or add e-mails addresses to the recipient list. For information, see “Selecting E-mail Addresses for Batch Scheduling” on page 397.

2 You can accept the default text, or customize Message Subject and Message Body. Click 📩 to add a text function, and ✅ to test the function.

3 Click Preview Bursting List to view the default settings for the POV members.

4 Click Next to notify recipients on batch job status by e-mail. For information, see “Setting Up E-mail Notifications” on page 396.

### Setting Up E-mail Notifications

You can send a status of Successful and/or Unsuccessful by e-mail when batches scheduled for PDF output are completed. For unburst, the e-mail contains the notification and PDF attachments; for bursted batches, the e-mail contains only the notification.

➤ To set up e-mail notifications:

1 To arrive at Scheduled Batch Details, start the batch wizard. See “Scheduling Batches to Run” on page 391.
2 To notify recipients of a successful batch run, select If Successful, E-mail Details to and click Select to add e-mail recipients (for information, see “Selecting E-mail Addresses for Batch Scheduling” on page 397). Enter a short remark in Message Subject.

To notify recipients of an unsuccessful batch run, select If Unsuccessful, E-mail Details to and click Select to add e-mail recipients (for information see “Selecting E-mail Addresses for Batch Scheduling” on page 397). Enter a short remark in Message Subject.

3 Optional. For job bursting batches, click Preview Bursting List to view and export the Bursting Destination file. This file contains default settings selected for the members in the bursted batch. For information on this file, see About the Bursting Destination File.

Selecting E-mail Addresses for Batch Scheduling

You can set up the scheduler to send an e-mail when a scheduled batch is completed successfully or unsuccessfully. The e-mail includes status details of the batch and optionally the PDF output of the batch. You can select, add, or delete e-mail addresses.

➤ To select recipient e-mails:

1 To arrive at Select E-mail Recipients for Scheduling, start the batch wizard. See “Scheduling Batches to Run” on page 391.

2 In Available Recipients, select an e-mail address and click .

- To add new recipient e-mails, click Add. In Add Address to List of Recipients, add e-mail addresses, separated with a comma and click OK.
- To Remove recipients’ e-mail, select an e-mail address and click Remove

Batch Deletion

You can delete batches in these ways:

- If you have a Global Administrator, Report Designer, Scheduler, or Content Publisher role and proper file permissions, you can delete batches from the repository.
- You can delete scheduled batches from the Batch Scheduler.

Deleting Batches from the Repository

You can delete numerous batches from the repository at once. To delete batches, see Chapter 3, “Exploring and Managing Items ”.

Deleting Batches from the Batch Scheduler

During batch scheduling, you have the option of deleting the scheduled batch from the scheduler if completed successfully. If this option is not selected, the successful batches are saved in the Batch Scheduler. Batches with an “error” status are always saved in the Batch Scheduler. All batches can also be deleted from the Batch Scheduler.
To delete scheduled batches from the Batch Scheduler:

1. Click **Navigate > Schedule > Batch Scheduler**.
2. In **Batch Scheduler**, select the batches for deletion.

   **Tip:**
   To select multiple batches hold down the CTRL key and click each batch in the list.
3. Select **Edit > Delete**.
4. When prompted, click **Yes**.

**Automatic Removal of Batch Scheduler Results**

You can configure the Batch Scheduler to automatically remove batch results that exceed a specified future age. For example, you can remove batch results that are more than a week old and any associated result files that are stored on the scheduler server.

The automatic removal option is turned off by default. You can enable it by editing the `fr_scheduler.properties` file to specify how old the results should be before they are deleted and how often the system checks for them. The `fr_scheduler.properties` file is in the `<Financial Reporting>\lib` directory on the Hyperion Financial Reporting Scheduler Server computer.

**Retrieving the Exported Output**

After a scheduled batch is run, you can retrieve a zipped HTML or PDF output file using the Retrieve Output option to rename and relocate the zipped file to your local drive from the scheduler server’s `\data\SchedulerOutput\Output` directory. You must have access to the batch to retrieve the exported output.

**Note:**
If you delete a batch after scheduling one, you cannot retrieve the output. Retrieval is only valid for non-bursted batch files.

To retrieve output:

1. Click **Navigate > Schedule > Batch Scheduler**.
2. In **Batch Scheduler**, select a completed scheduled batch that produced exported output.
3. Select **Action > Retrieve Output**. The file is presented as a zip file.
4. Select the files to export and click **Extract** to export the files to a directory on your machine.
Viewing the Status of Scheduled Batches

Scheduled batches can be viewed in a list format. Items such as the start time, destination, status, and so on that occurred while running the batch are displayed in a row and column format.

➤ To view the status of a scheduled batch that has run:

Click Navigate > Schedule > Batch Scheduler. The Batch Scheduler displays the list of batches that have run or are scheduled to run. You can click any heading text to sort the batches in the list. Headings include: Name, Description, Start Time, Destination, Status, user ID, and Path.

Tip:

Click any column heading to perform a sort.

Viewing Details of a Scheduled Batch

You can review the details of a particular batch, which includes a summary and server activity in Show Details.

➤ To view the details of a scheduled batch:

1 Click Navigate > Schedule > Batch Scheduler.
2 In Batch Scheduler, select a batch.
3 Select Action > Show Details. Show Details provides the following information:
   ● Summary information:
     ○ Destination of the batch
   ● Server activity:
     ○ Start time of the batch
     ○ Exception messages
     ○ End time and date
     ○ Whether the batch was ran successfully and if e-mail was sent
4 To copy the details to the Clipboard:
   a. Right-click in Show Details and select Select All.
   b. Right-click and select Copy.
5 Click Close.

Preparing Batch Files for the Command Line Scheduler

You can use an external scheduler to schedule batch jobs in Workspace. You automate the process of launching batches using an external scheduler or launching batches after an external
event occurs, such as the completion of a consolidation. For more information, see the Hyperion Workspace Administrator’s Guide.

➤ To export an existing batch file for command line scheduling:

1 Click Navigate > Schedule > Batch Scheduler.
2 In Batch Scheduler, select a completed scheduled batch that was successful and produced exported output.
3 Select Action > Export for Command Line Scheduling.
4 In File Download, save the XML file in the `<FR>`\bin directory as `mybatch.xml` where `mybatch` is the name of your batch input file. For more information, see the Hyperion Workspace Administrator’s Guide.

➤ To create a batch file for command line scheduling:

1 Click Navigate > Schedule > Batch Scheduler.
2 In Batch Scheduler, select Action > Create File for Command Line Scheduling.
3 In Schedule Batch, select a batch file and click Next. To complete the remaining steps of this dialog, see “Scheduling Batches to Run” on page 391.
4 At the end of batch creation, File Download is displayed.
5 Save the XML file in the `<FR>`\bin directory as `mybatch.xml` where `mybatch` is the name of your batch input file. For more information, see the Hyperion Oracle’s Hyperion® Financial Reporting Studio Guide.

Providing Logon Credentials

Logon credentials must be provided in order to run a scheduled batch at a future date.

➤ To enter logon credentials:

1 Enter a user name and Password for the Oracle’s Hyperion® Financial Reporting – System 9 server.
2 Enter a user name and Password for the Database Connection Name you are using.
3 Select OK.
Interactive Reporting Jobs

Interactive Reporting jobs are created with Interactive Reporting Studio and defined by properties and parameters. You can import, run, and schedule Interactive Reporting jobs.

Import Requirements

To import an Interactive Reporting, you need this information:

- Interactive Reporting database connection file names, to connect to the database for processing queries
- Custom calendar name, if not using the default calendar, to resolve dynamic date parameters
- Filter names and values, if running a job with parameters that must be specified. (See “Parameters” on page 402.)
- E-mail addresses if sending results directly to users
- Output directory name if sending results to a directory
- Database create-and-insert privileges if processing results to a database table
- Database grant access if giving additional users access to a database table.

See “Example: Importing and Scheduling a Job” on page 415.

Pass-Through Feature

Pass-through enables users to log on once and access data sources without additional authentication. Pass-through is enabled per authentication system and per Interactive Reporting
database connection file. Pass-through can be used for foreground jobs and all Interactive Reporting documents.

After your administrator enables pass-through for authentication systems, you can enable or disable it for Interactive Reporting database connection files.

**Parameters**

Interactive Reporting job parameters include runtime values, processing options, and job-output options. Processing and job-output options are defined using cycles and actions. A cycle contains job actions and job filters. Actions define how documents are processed and results are distributed. Filters are the values for the run-time variables. Job cycles are named and associated with jobs.

When importing a job, you specify whether users can create cycles (multiple-cycle jobs) or use only the default cycle (single-cycle jobs).

- **Single-cycle jobs**—Limited to one cycle. The default processing and printing actions are used. All single-cycle job results are processed to file as job output. The job output is listed with the job in the Browse item list.
- **Multiple-cycle jobs**—Processed according to how many cycles are defined. Cycles can be created using processing, printing, and exporting actions. You can design jobs to process as many times as necessary at each scheduled run, each process having different parameters (or filters) and job output options.

**Example**

Your document queries sales transactions within a region. The region is specified through a variable filter on the query to make the data available to each sales manager on Monday mornings.

When scheduling the job, you can add a job cycle for each region. You can resolve the variable and filter for each run to retrieve numbers for only one region, and e-mail the numbers from each run directly to the regional manager. All job-run cycles are part of one job, which is easier to track and update.

**Supporting Exceptions in Interactive Reporting Programs**

This section is for Interactive Reporting programmers who support exception notifications to users. (Users can receive e-mail notifications or see a graphic indicator on the Exceptions Dashboard on Personal Pages.)

**Setting Interactive Reporting Job Properties**

These topics describe the properties for Interactive Reporting importing and modifying Interactive Reporting jobs:

- **Setting Advanced Options**
● Setting Data Source and Query Properties
● Setting Interactive Reporting General Properties and Options
● Setting Job Defaults

For details on general properties and advanced options, see “Working with Properties” on page 117.

➤ To access properties:
1. From the Explorer module, select an item.
2. Select File > Properties.

### Setting Advanced Options

In addition to the advanced option detailed in “Working with Properties” on page 117, two options specific to Interactive Reporting jobs are available.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MIME Type</td>
<td>Displays the file type.</td>
</tr>
<tr>
<td>Priority</td>
<td>Job priority when run:</td>
</tr>
<tr>
<td></td>
<td>● High</td>
</tr>
<tr>
<td></td>
<td>● Normal — default</td>
</tr>
<tr>
<td>Run this job in the background</td>
<td>Enable running of your job in the background.</td>
</tr>
<tr>
<td>Hidden File</td>
<td>Set file to hidden.</td>
</tr>
<tr>
<td>Auto-delete job outputs after</td>
<td>Select a time period and enter a number to specify when output is automatically deleted.</td>
</tr>
<tr>
<td>Auto-delete job outputs after</td>
<td>Deleted job output after a specified time. Enter a number, and select a time element:</td>
</tr>
<tr>
<td></td>
<td>● Minutes</td>
</tr>
<tr>
<td></td>
<td>● Hours</td>
</tr>
<tr>
<td></td>
<td>● Days</td>
</tr>
<tr>
<td></td>
<td>● Weeks</td>
</tr>
<tr>
<td>If exceptions, allow users to add to their Exceptions Dashboard</td>
<td>Enables users to report exceptions to Exceptions Dashboards.</td>
</tr>
<tr>
<td>Automatically generate keywords</td>
<td>Automatically generates keywords in &lt;Assigned Keywords&gt;.</td>
</tr>
<tr>
<td></td>
<td>● To add, enter keywords and click।</td>
</tr>
<tr>
<td></td>
<td>● To remove, select from &lt;Assigned Keyword&gt; and click।</td>
</tr>
</tbody>
</table>
Setting Data Source and Query Properties

Interactive Reporting database connection files are used by Interactive Reporting jobs and files to connect to databases. Queries in a document can use different databases. In addition, an Interactive Reporting database connection file can be specified for each query of an file or job.

Before you can import files and jobs, you need access to all Interactive Reporting database connections that your document uses. Otherwise, the required database connection files are not displayed in the connection list. Ask your administrator for access to the required Interactive Reporting database connections.

If you use pass-through, see “Pass-Through Using Multiple, Interactive Reporting, Database-Connection Files” on page 406.

Note:

If no Interactive Reporting database connection file is specified for a query, users accessing the document cannot process the query unless it uses only local results.

To access data source and query properties, from Properties, click Interactive Reporting on the left.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply Option to All Queries</td>
<td>Select a method for obtaining user names and password for queries:</td>
</tr>
<tr>
<td></td>
<td>- Use Default User Name &amp; Password—Uses the defaults for database access.</td>
</tr>
<tr>
<td></td>
<td>- Prompt for User Name &amp; Password—Prompts the user for a user name and</td>
</tr>
<tr>
<td></td>
<td>password per data connection. The word prompt is displayed in the user</td>
</tr>
<tr>
<td></td>
<td>name and password fields.</td>
</tr>
<tr>
<td></td>
<td>- Specify Now—Prompts the importer for a user name and password for all</td>
</tr>
<tr>
<td></td>
<td>queries. The user name is displayed in all user name fields. The password</td>
</tr>
<tr>
<td></td>
<td>is not retractable.</td>
</tr>
<tr>
<td></td>
<td>You can override individual username or password combinations by selecting</td>
</tr>
<tr>
<td></td>
<td>a method for each query connection.</td>
</tr>
</tbody>
</table>

Connection: Select an Interactive Reporting database connection file to use the query. For queries using only local results, select <No Connection>.

If you are using pass-through, see “Pass-Through Using Multiple, Interactive Reporting, Database-Connection Files” on page 406.

User name: Enter a user name, set one globally with the Connecting to Data Sources list; or set a one individually with the options list.

Password: Enter the password to use for this query; or set globally with the Connecting to Data Sources list; or set individually with the options list.

Options: Set the username and password using the selected method (default or prompted)

Query Connections and Processing: Validate all queries that you process at runtime.
Setting Interactive Reporting General Properties and Options

The properties page for an Interactive Reporting job contains general properties and the Interactive Reporting options.

To access general properties, from Properties, click the Properties tab at the top.

<table>
<thead>
<tr>
<th>Table 118</th>
<th>General Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Property</td>
<td>Description</td>
</tr>
<tr>
<td>Calendar</td>
<td>Calendar selected for resolving dynamic date parameters.</td>
</tr>
<tr>
<td>Users running this job can define their own cycles and actions</td>
<td>Allow users to define cycles and parameters for the job, thus creating a multiple-cycle job. The default is not selected (single-cycle jobs). Only single-cycle jobs can be viewed in View Manager.</td>
</tr>
</tbody>
</table>

Note: If you select the option now, you can deselect it later. If you do not select it now, you can never select it.

<table>
<thead>
<tr>
<th>Table 119</th>
<th>Interactive Reporting Options</th>
</tr>
</thead>
<tbody>
<tr>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>Enable ADR</td>
<td>Browser refreshes the document automatically.</td>
</tr>
</tbody>
</table>

Setting Job Defaults

Job Defaults and detailed in Table 120 gives you the option to include HTML as a default, job-output format and to set default, job-parameter values. See “Setting Job Parameters” on page 408.

To access Job Defaults:

From Properties, click the Job Defaults tab at the top.

<table>
<thead>
<tr>
<th>Table 120</th>
<th>Job Defaults</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default</td>
<td>Description</td>
</tr>
<tr>
<td>Include static HTML as a default output format</td>
<td>Select to make HTML and the default output format (the standard Interactive Reporting document) your default output format.</td>
</tr>
<tr>
<td>Set Values</td>
<td>Set default job-parameter values. See For field definitions to set values, see “Setting Job Parameters” on page 408.*Modifying Job Parameters” on page 409.</td>
</tr>
<tr>
<td>Modify Filter</td>
<td>Set default filter options. See “Filter Options” on page 410.</td>
</tr>
<tr>
<td>Set Locale</td>
<td>(Interactive Reporting) Set locale properties:</td>
</tr>
</tbody>
</table>
### Selecting Database-Connection File Options

Interactive Reporting jobs and files use database-connection files to connect to databases. An Interactive Reporting, database-connection file must be specified for each query of an Interactive Reporting file or job, except for queries that use only local results, so users can process the query.

### Pass-Through Using Multiple, Interactive Reporting, Database-Connection Files

If enabled by your administrator, pass-through enables you to access data sources without entering a username and password for each data source. For pass-through to work for Interactive Reporting jobs or files associated with multiple, Interactive Reporting database connections, these conditions are necessary:

- Interactive Reporting database connections is configured for pass-through.
- Credentials required to access each data source are identical.

**Note:**

Hyperion recommends selecting similarly configured Interactive Reporting, database-connection files when importing Interactive Reporting documents. To enable users doing imports to make this selection, Interactive Reporting database connection names should indicate whether the database connection is configured for pass-through.

When Interactive Reporting jobs and files with some but not all Interactive Reporting database connections configured for pass-through are processed:

- Interactive Reporting database connections configured for pass-through—Users are not prompted for logon credentials.
- Interactive Reporting database connections not configured for pass-through—The credential option selected when the job or file was imported (prompt user, specify now, or use the default) is used.

---

<table>
<thead>
<tr>
<th>Default</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Language</strong></td>
<td>Determines the sort order and the job log language.</td>
</tr>
<tr>
<td><strong>Country</strong></td>
<td>Determines the data format (for example, the date/time format).</td>
</tr>
</tbody>
</table>

Click OK to close Properties. You can schedule the job later from the Browse web module. See “Scheduling Jobs and Batches” on page 375.

To complete the Import dialog wizard for Interactive Reporting (.bqy) files, see “Importing Files as Jobs” on page 110.
For pass-through processing of all queries, Interactive Reporting database connections must have identical database credentials.

Setting Processing and Metadata Options

Three options types specific to Interactive Reporting, database-connection file are offered: processing and metadata.

Processing Open Catalog Extension (OCE) options store database connection information.

<p>| Table 121 Processing Database-Connection Options |</p>
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
</table>
| Data source access | Select a method for the Interactive Reporting database-connection file to use a username and password when a job is run or a file is processed.  
- Use the username/password specified below—You enter the database username and password.  
- Prompt for user name/password—You are prompted for the database username and password when the job is run or scheduled or the file is processed. This is the default when pass-through is disabled. |
| User name | If Data source access is set to use this field, enter the database user name. |
| Password | If Data source access is set to use this field, enter the database password. |
| Allow pass-through where end user’s authentication system is enabled for it | Select to allow pass-through credentials for data source access. |

Metadata options store a file that contains extra information about the Interactive Reporting database connection.

<p>| Table 122 Metadata Options |</p>
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>This Interactive Reporting database connection (.oce) uses metadata defined in another connection</td>
<td>Metadata is used and the metadata connection is not specified in the Interactive Reporting, database-connection file. All fields in this group are disabled if this field is not selected.</td>
</tr>
<tr>
<td>Select metadata connection</td>
<td>If metadata is used and the metadata connection is not specified in the Interactive Reporting, database connection file, select the Interactive Reporting database-connection file for the metadata.</td>
</tr>
</tbody>
</table>
| Metadata access | Select one of the following:
<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>* Use processing OCE’s credential for metadata connection – Use that username and password associated with the Interactive Reporting database connection to access the metadata.</td>
</tr>
<tr>
<td></td>
<td>* Use specified user name/password – Use the specified user name and password to access the metadata.</td>
</tr>
</tbody>
</table>

**User name**  
If Data source access is set to use this field, enter the database user name.

**Password**  
If Data source access is set to use this field, enter in the database password.

### Table 123  Interactive Reporting Database Connection

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Connection Software</td>
<td>Connection software name used by this Interactive Reporting database file (.oce) to connect to the database server, for example, ODBC or Essbase.</td>
</tr>
<tr>
<td>Database</td>
<td>Type of the database or database connectivity to which this Interactive Reporting Connection file (.oce) is used to connect, for example ORA8, Essbase, ODBC, OLEDB and so on.</td>
</tr>
<tr>
<td>Host</td>
<td>Identifier or alias for the specific information needed to connect to the client, for example, host name or DSN.</td>
</tr>
</tbody>
</table>

To complete the Import dialog wizard for Interactive Reporting Database Connection (.oce) files, see “Importing Files” on page 109.

### Setting Job Parameters

With single-cycle jobs, job parameters contain job variables filters. With multiple-cycle jobs, job parameters contain job variables or filters and job cycles, which contain processing options and job actions.

**Note:**

You can create job parameters only when creating or modifying a job schedule or running a job.

### Setting Single-Cycle Job Parameters

Only single-cycle jobs with variables filters have job parameters.
To set job parameters for a single-cycle, Interactive Reporting job:

1. From the Explorer module, right-click the Interactive Reporting job, and select Run Job. This job is stored in a folder to which you have Run Job access rights. The Job Parameters window displays the parameter values that are set.

2. Select a job parameter definition.

3. Click Go to use the definition as is or click Edit to modify it.

4. If you clicked Edit, proceed to the following topic.

### Modifying Job Parameters

The following procedure assumes that you clicked edit in the preceding procedure.

To edit a job parameter definition:

1. **Under Job Parameters next to Define Job Parameters starting with** and just to the right of Go, click Edit.

2. Click Modify job parameter to update the job parameter list.

3. **In Name,** enter a name.

4. **In Description,** enter a description.

5. **Optional:** Click Edit Permissions to change access permissions.

6. **Under Set Local,** change the language:
   - **In Language,** select the language.
   - **In Country,** select a country.

7. **Optional:** Modify filters (available only if filters exist in the file). See “Filter Options” on page 410.

8. **Take one action:**
   - Select Save as my default
   - To save your job parameters, select Save, select parameter type, and enter a name.

### Setting Multiple-Cycle Job Parameters

When creating job parameters for multiple-cycle jobs, you can save the cycles and the job parameters associated with the job that you are running or scheduling.

**Note:**

You can create job parameters only when creating or modifying job schedules or running jobs.

To set job parameters for multiple-cycle, Interactive Reporting job:

1. From the Explorer module, right-click the Interactive Reporting job, and select Run Job.
This Interactive Reporting job is stored in a folder to which you have Run Job access rights. The Job Parameters window shows the parameter values that are set.

2 **Under Cycles**, you can perform the following: to add a cycle click Go.
   - To modify cycle, click **Modify**, or to add new cycles, click **Go**.
     - Under Define Cycle, enter cycle information:
       - In Cycle Name, enter a name.
       - Select Save Job Output with the job or Save job output in another folder and enter a file path.
       - Click Edit Cycle Permissions for permissions access.
   - To copy, click **Copy**.
   - If filters exist, see “Filter Options” on page 410.

3 **Select process options.** See “Process Options” on page 412.
   The connection file and database to which you are connected determine whether you can process the results to a database table.

4 **Select action options.**
   For details on action options, see Table 126.

5 **Click OK.**

6 **Select Save Job Parameters, and enter a name.**

### Job Parameter Options

This following topics provide details on Interactive Reporting, job-parameter options:
- **Filter options**—For single-cycle and multiple-cycle jobs
- **Processing options**—For multiple-cycle jobs only
- **Actions options**—For multiple-cycle jobs only

### Filter Options

In Interactive Reporting Studio, filters enable you to control how much data is processed and displayed during relational or OLAP database queries.

Query filters which are created initially in Interactive Reporting Studio, can be static or variable. Static filter values cannot be changed. You can change variable filter values at runtime from Set Values. The Set Values area displays information for relational and OLAP databases.

These topics detail the information displayed in the Set Values area during relational or OLAP database queries:
- **Setting Filter Values for Relational Databases**
- **Setting Filter and Slicer Values for OLAP Queries**
Setting Filter Values for Relational Databases

The Set Values area displays the values for the filters.

To access properties:

1. From the Explore module, select an item.
2. Right-click a job and select Run Job.

Properties is displayed.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Query Name</td>
<td>(Read-only) Query name</td>
</tr>
<tr>
<td>Filter Name</td>
<td>(Read-only) Name of the field that the filter is on from the Interactive Reporting job</td>
</tr>
<tr>
<td>Operator</td>
<td>(Read-only) The operator that the filter uses, such as =, &lt;, or &gt;</td>
</tr>
<tr>
<td>Values</td>
<td>(Read-only) The values that the filter uses (Variable system values such as $USER, are acceptable. The values are from the database that the query is using.)</td>
</tr>
<tr>
<td>Ignore</td>
<td>Disables the filter when the query is processed</td>
</tr>
<tr>
<td>Don’t Prompt</td>
<td>Disables prompting for runtime values. (A dynamic value, such as a system variable can be used for a value(s). This option essentially changes the variable filter to a static filter with fixed values.)</td>
</tr>
<tr>
<td>Modify Filter</td>
<td>Enables modification of a selected filter.</td>
</tr>
<tr>
<td>Include nulls</td>
<td>Enables inclusion of an “is null” condition in the SQL sent to the database when the query is processed.</td>
</tr>
<tr>
<td>Operator</td>
<td>(Read-only) The operator that the filter uses, such as =, &lt;, and &gt;</td>
</tr>
<tr>
<td>Show values</td>
<td>Retrieves from the database all available values associated with the item you can consider and select from the range of values when applying a filter.</td>
</tr>
<tr>
<td>Custom values</td>
<td>Lists available values saved with the filter or read from a file, you can select values from a pre-defined pool. You can create and save a custom list with each filter.</td>
</tr>
</tbody>
</table>

Setting Filter and Slicer Values for OLAP Queries

You can set OLAP variable filters and slicers when importing or scheduling a job with an OLAP query. In the query, you can filter data on cube dimension levels to be displayed in the top or side labels of the query.

Slicers are filters on a dimension that are not in top or side labels but are visible in the data displayed. The filters list on Set Values displays the slicers last.

Note:

When modifying filters, you cannot remove the last filter. You need at least one filter value per filter.
To access filter and slicer values:

1. From the Explore module, select an item.
2. Choose File > Run Job.
3. Click Go to add a schedule.
4. Enter the schedule properties and click Next until you can define the value and filter options.

Table 124

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Set Values (MDD)</strong></td>
<td><strong>OLAP Query Name</strong> — (Read-only) Query name</td>
</tr>
<tr>
<td></td>
<td>Filter On — (Read-only) The dimension level on which the filter is applied</td>
</tr>
<tr>
<td></td>
<td>Operator Type — (Read-only) The type that is set</td>
</tr>
<tr>
<td></td>
<td>Data Operator — (Read-only) The operator that the filter uses, such as =, &lt;, and &gt;. (Slicers have no data operators.)</td>
</tr>
<tr>
<td></td>
<td>Value(s) — (Read-only) The values that the filter uses (Variable system values such as $USER are acceptable. The values are from the database that the query is using.)</td>
</tr>
<tr>
<td></td>
<td>Ignore — Disables the filter when the query is processed</td>
</tr>
<tr>
<td></td>
<td>Don’t Prompt — Disables prompting for runtime values. (A dynamic value such as a system variable can be used for a value. This option essentially changes the variable filter to a static filter with fixed values.)</td>
</tr>
<tr>
<td><strong>Modify Filter</strong></td>
<td>Lists OLAP Query Name/Filter On values. Toggles filter list to filters applied for selected OLAP Query section and filter.</td>
</tr>
<tr>
<td><strong>Operator Type</strong></td>
<td>Availability determined by the database:</td>
</tr>
<tr>
<td></td>
<td>● Select Members From Database</td>
</tr>
<tr>
<td></td>
<td>● Select By Measure</td>
</tr>
<tr>
<td></td>
<td>● Top N</td>
</tr>
<tr>
<td></td>
<td>● Bottom N</td>
</tr>
<tr>
<td></td>
<td>● Top Sum</td>
</tr>
<tr>
<td></td>
<td>● Bottom Sum</td>
</tr>
<tr>
<td></td>
<td>● Top N%</td>
</tr>
<tr>
<td></td>
<td>● Bottom N%</td>
</tr>
<tr>
<td></td>
<td>● Select Members</td>
</tr>
<tr>
<td></td>
<td>● User Defined Attributes</td>
</tr>
<tr>
<td></td>
<td>● Substitution Variables</td>
</tr>
</tbody>
</table>

Available operator types are displayed in the filter list. Slicers have no operator types.

**Process Options**

Process options, are displayed in the section below the Modify Filters options. The connection file and database to which you connect determine whether you can process the results to a database table. You need Create and Insert privileges on the database to process to a database table.
To set process options for a multiple-cycle, Interactive Reporting job:

1. From the Explorer module, right-click the job and select Run Job.
2. Click Go to add another cycle to this job.
3. Click Process Options (+) to display all process options.

### Table 125

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save job output with the job</td>
<td>For storing the job output in the folder containing the job</td>
</tr>
<tr>
<td>Save job output in another folder</td>
<td>For specifying an output folder</td>
</tr>
<tr>
<td>Process results to Interactive Reporting file</td>
<td>For processing queries to the Interactive Reporting file Results section</td>
</tr>
<tr>
<td>Process results to database table</td>
<td>For creating a database table to store the data set. (Items on the Request line become the column headings. You can append columns to the table and query it. You need Create and Insert privileges on the database to process to a database table.)</td>
</tr>
<tr>
<td>Query</td>
<td>For selecting the query to process to a database table.</td>
</tr>
<tr>
<td>Table Name</td>
<td>For entering the name of the table that you are creating or to which you are appending columns (See your database administrator if you want to use a new table.)</td>
</tr>
<tr>
<td>Create a table for each run, appending date to table name</td>
<td>For creating a table for each job run and appending the date to its name</td>
</tr>
<tr>
<td>Delete and recreate table for each job run</td>
<td>For deleting the old table and creates a table for each job run (Runs use the same table name.)</td>
</tr>
<tr>
<td>Create table on initial run, and then append data to existing table</td>
<td>For creating a table on the initial run and adding data to the table</td>
</tr>
<tr>
<td>Grant access to:</td>
<td>For entering additional usernames (separated by commas) (You need Grant privileges to use this field. If Grant Access to is not selected, the table is granted only to your user name.)</td>
</tr>
</tbody>
</table>

### Action Options for Multiple-Cycle Jobs

The action is the output method. The options on the actions page vary depending on the action. Actions and items to which they apply:

- **Export**—Dashboard, Report, Results, Chart, Pivot, OLAPQuery, and an entire document as a web page
- **Save Document**—Entire Interactive Reporting file
- **Print**—Dashboard, Report, Results, Chart, Pivot, and OLAPQuery (Available if the administrator defined a printer for Oracle’s Hyperion® Interactive Reporting Studio)
- Import Document—Dashboard, Report, Results, Chart, Pivot, OLAPQuery, and an entire document as a web page.
- E-mail Section—Dashboard, Report, Results, Chart, Pivot, and OLAPQuery
- E-mail Document—Entire Interactive Reporting file

**Note:**
A cycle can have only one Save As Job Output action. It can have multiple save actions but can be saved as a file on only some output folders.

➢ To set action options for a multiple-cycle, Interactive Reporting job:
1. From the Explorer module, right-click the job, and select Run Job.
2. Click Go to add another cycle to this job.
3. From the actions list, select a value and click Go.

<table>
<thead>
<tr>
<th>Table 126 Export Action Options</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Option</strong></td>
</tr>
<tr>
<td>Section</td>
</tr>
<tr>
<td>Filename</td>
</tr>
<tr>
<td>Format</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>Export as job output</td>
</tr>
<tr>
<td>Save as job output</td>
</tr>
<tr>
<td>Output Directory</td>
</tr>
<tr>
<td>Append Unique Identifier to Filename</td>
</tr>
<tr>
<td>Append Date to Filename</td>
</tr>
<tr>
<td>Option</td>
</tr>
<tr>
<td>----------------------------</td>
</tr>
<tr>
<td>Save Results with Document</td>
</tr>
<tr>
<td>Save Computed Values with Document</td>
</tr>
<tr>
<td>Save in Compressed Format</td>
</tr>
<tr>
<td>Send Files</td>
</tr>
<tr>
<td>Send Results</td>
</tr>
<tr>
<td>Send Computed Values</td>
</tr>
<tr>
<td>Send Compressed</td>
</tr>
<tr>
<td>Additional Message</td>
</tr>
</tbody>
</table>

**Example: Importing and Scheduling a Job**

This example illustrates importing and scheduling of an Oracle's Hyperion® Interactive Reporting – System 9 job. In this example, you import and schedule `sample1.bqy` to run once per quarter.

➤ To import `sample1.bqy`:

1. Navigate to the folder to which to import the job.
2. Select File > Import > File as Job.
3. In File, click Browse to search for the file `sample1.bqy`. Click Next.
4. For Query, on Connecting to Data Sources, under Connection, select Sample for the Query/DataModel name called SalesQuery, and click Next.
5. For Interactive Reporting Job Properties, select Users running this job can define their own cycles and actions, and click Next.
6. For Job Defaults, set General Properties and Locale and click Next.
7. On Advanced Options, click Edit Permissions to open permissions access.
8. Give the World group access to `sample1.bqy`.
   a. Under Available Users, Groups, and Roles, click Update List.
   b. From Available Users, Groups, and Roles, select a user and click ▶.
   c. Under Selected Users, Groups, and Roles, select the user and click Edit.
   d. On Permissions, select the access permissions level for the job and the job output, and set the adaptive state.
      - Access to file—Full Control
      - Adaptive state—View only
e. Click OK.

   Permissions is displayed.

f. Click OK.

9 Click Finish and Schedule.

10 On General Properties, in Name, enter Quarterly, and click Next.

11 On Job Parameters, click Next.

12 On Cycles, by Add another cycle to this job, click Go.

13 Define a cycle:

   ● Under Define Cycle, in Cycle Name, enter Weekly.
   ● Under Add a(n) (blank) Action to this Cycle, select Email Document, and click Go.

14 On Add/Modify Action: Email Document, in To, enter your email address.

15 Select Send File and/or Send Results, and click OK.

16 On Define Cycle, click OK.

17 On Cycles, select Save Job Parameter Name, select Personal from the drop-down list, enter a name in the box, and click Next.

18 On Time Events, select Define when to run this job starting with, and select A New Recurring Time Event, and click Next.

19 On Define Event:

   ● In Name, enter a name.
   ● In Days to Run, select By Quarter.
   ● Click Next.

20 Under Notification, select Display notification in Schedule Module, and click Finish.

The job is now scheduled to run.
Overview

SQR Production Reporting jobs are created with Oracle's Hyperion® SQR® Production Reporting Studio. Generic jobs are created using applications with a command-line SQR Production Reporting interface. You can use the Explore and Schedule modules to import, run, and schedule SQR Production Reporting and generic jobs. You also use properties and parameters to further define SQR Production Reporting and generic job options.

This chapter explains the properties specific to SQR Production Reporting jobs, generic jobs, and SQR Production Reporting documents (SQR Production Reporting job output).

For basic importing procedures, see Chapter 4, “Importing Artifacts.” For basic job execution and scheduling procedures, see Chapter 13, “Scheduling Jobs and Batches.”

Prerequisites for Importing Jobs

Information needed for importing a SQR Production Reporting job:

- Database connectivity, database type, and SQR Production Reporting version needed to run the SQR Production Reporting program that you are adding (select from the list); for example, Marketing SQR Production Reporting v. 9
- Files that the SQR Production Reporting program references:
  - Include files (#INCLUDE commands)
Job Properties

The properties explained in the following topics pertain only to SQR Production Reporting and generic jobs. Properties that do not apply to generic jobs are noted. See “Generic Job Properties” on page 427 for properties unique to generic jobs.

SQR Production Reporting jobs have these properties:

- General properties
- Advanced options
- Connectivity and run options
- Parameters
- Output

SQR Production Reporting and generic jobs and other items, such as BQY jobs share many general properties and advanced options. See “Working with Properties” on page 117.

To access properties:

1. From the Explorer module, select a Production Reporting job.
2. Select File > Properties.

Review properties:

- Click General. See “General Properties” on page 117.
- Click Advanced. See “Advanced Properties” on page 118.
- Click Production Report to review Production Reporting properties:
  - Click Required Files. See “Required Files” on page 420.
  - Click Connect. See “Connection and Run Options” on page 420.
  - Click Parameters. See “Parameters” on page 422.
  - Click Output Options. See “Job Output” on page 425.
  - Click Advanced. See “Advanced SQR Production Reporting Options” on page 422.

Dependency Analysis Commands

When importing SQR Production Reporting job, the system can analyze your SQR Production Reporting program for dependencies. The analysis occurs if you request the system to scan for
required files and INPUT and ASK parameters. Analysis can be time-consuming if your SQR Production Reporting program is large.

The system examines these commands in your SQR Production Reporting program:

- **INCLUDE**—Includes an external source file in the SQR Production Reporting report specification; for example, a SQR Production Reporting code file, `charts.sqi`, required by `stocks.sqr` when it compiles

- **OPEN**—Opens an operating system file for reading or writing; for example, an OPEN statement that opens a file for sequential reading the data in the file, which is identified to the program as 1:

  ```
  open 'stocks.dat' as 1 for-reading record=100
  ```

- **DECLARE-IMAGE**—Declares the type, size, and source of an image to be printed; for example:

  ```
  declare-image control flow
  type = eps-file
  source = 'controlf.eps'
  image-size = (321, 309)
  end-declare
  ```

- **PRINT-IMAGE**—Prints an image in any report section (As with the declare-image command, the print-image command accepts type, size, and source arguments.)

- **ASK**—Retrieves a compile-time substitution variable (Retrieval can be by user input, command-line arguments, or entries in the @file on the command line.)

- **INPUT**—Retrieves a runtime variable (Retrieval can receive by user input, command-line arguments, or entries in the @file on the command line.)

- **PRINT URL="...")**—Prints the file found at the URL location, usually an image file (The file is listed with the required files for the job.)

- **SECURE**—Retrieves the secure tag

---

### Advanced Options

The Security Tags Included property, which is read-only, indicates whether the job is secure. Secure jobs can have only HTML output. All other advanced options are explained in “Working with Properties” on page 117.

---

### Connectivity and Run Options

These topics describe all data source connection properties and run properties for SQR Production Reporting jobs:

- **Connection and Run Options**
- **Required Files**
- **Required-File Addition**
- **Advanced SQR Production Reporting Options**
Connection and Run Options

Use these options, which apply only to SQR Production Reporting jobs, to configure or change the database connections and the SQR Production Reporting engine for the job.

| Data Source and Production Reporting Engine | For selecting a data source and a SQR Production Reporting engine  
If the data source or engine that you need is not available, see your administrator. |
|---------------------------------------------|------------------------------------------------------------------|
| Database Connectivity                       | Use Job Service connectivity for this data source—For using the default username and password  
Prompt for username/password—For prompting users to enter IDs and passwords at runtime  
Use the username/password specified below—For setting the username and password now on import |
| Allow pass-through where end user’s authentication system is enabled for it | For enabling users to access data sources without additional credentials. |

Required Files

When importing a file or job, you can identify and locate required files by scanning the SQR Production Reporting program, or you can manually enter the required files.

Note:

Scanning the SQR Production Reporting program to locate required files is possible only during the import process.

As you identify and locate required files, they are added to the required files screen. For generic jobs, you must manually enter required files.

Files that can be associated with a job or SQR Production Reporting document and required for successful execution:

- For SQR Production Reporting jobs, Include, Data, Image files, and INI file
- For generic jobs, associated files used for running the job
- SQR Production Reporting documents and associated files used in viewing the document

This chapter concentrates on required files managed through a listing interface, namely files for SQR Production Reporting and generic jobs and SQR Production Reporting documents. The INI file and the custom-form required files are managed through another interface.

Note:

Scan for required files before manually entering required files, because the scanned results replace the required files list. If duplicate required files are listed, you must delete the extra files.
Table 127

<table>
<thead>
<tr>
<th>Name</th>
<th>Required-file name</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>The local file icon next to the name indicates that the file is on your local system.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Location</th>
<th>Required-file path</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>If the location is not listed, you must find the file by selecting Modify or delete the file.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Type</th>
<th>The type (INCLUDE, IMAGE, DATA), as determined by the system.</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Manually entered JPEG, GIF, and HTML files are given the IMAGE type. You must select a type for other manually entered files. All files must have a type before you can continue the importing process.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Action</th>
<th>Retrieve—For opening any type of required file</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Replace—for replacing the file with one selected from your local computer or the Workspace repository</td>
</tr>
<tr>
<td></td>
<td>Delete—for deleting the file</td>
</tr>
<tr>
<td></td>
<td>Modify—for browsing your local system for files that the system could not locate</td>
</tr>
</tbody>
</table>

Add Files Manually

Default method to locate required files for a job

Note: Scanning is available only during the import process.

You can enter each required file separately or zip the required files and enter the zip file manually. Workspace extracts the zipped files and adds them to the required files summary list.

Scan Folders Specified in Preferences — The SQR Production Reporting program scans listed folders for required files. Files not located are listed on the summary screen with the File not found message under location. Locate missing files by selecting Modify.

Scan All of Oracle’s Hyperion® Reporting and Analysis – System 9 —

The SQR Production Reporting program is scanned for required files, and files in the Workspace repository are listed on the required files summary list.

If your program uses variables for file names in the OPEN, DECLARE-IMAGE, or PRINT-IMAGE commands, you receive a warning message that the system cannot find the files unless you provide their names. Ignore the message, if you enter the required files manually or if the variables point to files that reside on the Job Service numbers. Otherwise, exit the import process and modify your SQR Production Reporting program.

---

### Required-File Addition

Browse your local system or the repository for required files to add manually.

Table 128  Add Required File Parameters

<table>
<thead>
<tr>
<th>Add File from my PC</th>
<th>Add a file from your local hard drive.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add File from the Repository</td>
<td>Add a file from the database.</td>
</tr>
</tbody>
</table>
Advanced SQR Production Reporting Options


<table>
<thead>
<tr>
<th>Compile</th>
<th>For compiling the program</th>
</tr>
</thead>
<tbody>
<tr>
<td>Benefits:</td>
<td></td>
</tr>
<tr>
<td>● Save time later when running the job</td>
<td></td>
</tr>
<tr>
<td>● Validate SQL ASK parameters</td>
<td></td>
</tr>
<tr>
<td>● Check program validity</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Command-line flags for Job Execution</th>
<th>Optional command-line flags</th>
</tr>
</thead>
<tbody>
<tr>
<td>Some flags can be over-ridden by job-output option formats and demand-paging options, for example, -burst and -printer.\textsuperscript{XX} where \textsuperscript{XX} is a format type.</td>
<td></td>
</tr>
<tr>
<td>This command-line flag option is unavailable: -\textsuperscript{EH_CSVONLY}.</td>
<td></td>
</tr>
<tr>
<td>The system accepts 250 characters on the command line.</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Use SQR.ini from File System on Job Factory Host</th>
<th>For using the SQR.ini file location</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Custom SQR.ini</th>
<th>Path to a custom SQR.ini file</th>
</tr>
</thead>
<tbody>
<tr>
<td>Browse for the file locally or in the repository.</td>
<td></td>
</tr>
<tr>
<td>● Add File from my PC—Select a local file.</td>
<td></td>
</tr>
<tr>
<td>● Add File from the Repository—Select a file from the database.</td>
<td></td>
</tr>
</tbody>
</table>

| Persist foreground job output in repository when running this job | Stores output in the repository. |

| Allow Job Runners the option to change the persistence option | When this is selected, Persist foreground job output when running this job is available to users when running the job in real time. |

Parameters

SQR Production Reporting jobs have two parameter types, ASK and INPUT. ASK parameters (variables) are used at compile time. INPUT parameters (variables) are used when the job is executed and are displayed as prompts when users run the job. You can add ASK and INPUT parameters to the parameter list. Only SQR Production Reporting jobs have ASK parameters. SQR Production Reporting and generic jobs can have INPUT parameters. Further define a parameter by selecting Modify for the parameter. Also select custom forms for user input of parameters.
Parameter Settings

You use Parameters to view scanned parameter or manually enter new ones. Table 129 details the define parameter properties.

<table>
<thead>
<tr>
<th>Table 129</th>
<th>Parameter Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Manually entering parameters</td>
<td>Default method for entering ASK and INPUT parameters. See “Dependency Analysis Commands” on page 418 (Parameters are listed as you add them.)</td>
</tr>
<tr>
<td>Scanning job and reading parameters from the SQR Production Reporting code</td>
<td>Option to enable automatic scenery of the SQR Production Reporting job and the INPUT and ASK parameters list</td>
</tr>
<tr>
<td>Available during the import process.</td>
<td></td>
</tr>
<tr>
<td>Add another parameter to this job</td>
<td>Select INPUT or ASK and click GO. See “INPUT Parameters” on page 424.</td>
</tr>
<tr>
<td>Prompt</td>
<td>The prompt for values for the parameter</td>
</tr>
<tr>
<td>Display</td>
<td>The display format (Text, SQL Choice, Choice Box) for the parameters (Default is Text.)</td>
</tr>
<tr>
<td>Default Value</td>
<td>Default value for the parameter</td>
</tr>
<tr>
<td>Modify</td>
<td>Select to modify these properties for each parameter: prompt, display format, and default value</td>
</tr>
<tr>
<td>Arrow icons</td>
<td>Arrows to reorder the parameter. (The parameters are processed in the order that they are displayed on this list.)</td>
</tr>
<tr>
<td>Garbage can icon</td>
<td>Select to delete the parameter.</td>
</tr>
</tbody>
</table>

ASK Parameters

ASK parameters can be entered as text or as an SQL query.

<table>
<thead>
<tr>
<th>Table 130</th>
<th>ASK Parameter Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display parameter on form as:</td>
<td>Select a parameter display type:</td>
</tr>
<tr>
<td></td>
<td>● Text Entry</td>
</tr>
<tr>
<td></td>
<td>● Choice of Values from SQL Query</td>
</tr>
<tr>
<td>Prompt</td>
<td>The prompt for the parameter</td>
</tr>
<tr>
<td>Default value</td>
<td>For entering a default value or allowing users to change the value (text entry only) The system requires a default value or section of End-user can change value.</td>
</tr>
<tr>
<td>End-user can change value</td>
<td>For allowing users to enter default values during runtime</td>
</tr>
<tr>
<td>SELECT/FROM/WHERE</td>
<td>SQL commands for retrieving the parameter list (SQL query only).</td>
</tr>
</tbody>
</table>
## INPUT Parameters

INPUT parameters can be entered as text, predetermined values, or an SQL query.

### Table 131  INPUT Parameter Properties

<table>
<thead>
<tr>
<th>Display parameter on form as:</th>
<th>Select a parameter display type:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>● Text Entry</td>
</tr>
<tr>
<td></td>
<td>● Choice of Pre-determined Values</td>
</tr>
<tr>
<td></td>
<td>● Choice of Values from SQL Query</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Prompt</th>
<th>The prompt for the parameter</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data Type</td>
<td>The data type (text, numeric, or date; default is text)</td>
</tr>
<tr>
<td>Presentation</td>
<td>The presentation format: drop-down list, option buttons, or list box (Pre-determined and SQL query only)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Default value</th>
<th>For entering a default value or allowing users to change the value (predetermined and text entry)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>If Value optional is unavailable, the system requires a default value or requires that End-user can change value is selected.</td>
</tr>
<tr>
<td></td>
<td>When $FIXED_USERNAME is selected, Value optional and End-user can change value are disabled.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Value optional</th>
<th>For allowing the parameter to have no default value and enabling users to execute jobs with no value for the parameter</th>
</tr>
</thead>
<tbody>
<tr>
<td>End-user can change value</td>
<td>For allowing users to enter default values during runtime</td>
</tr>
<tr>
<td></td>
<td>If no default is specified and this option is selected, users must specify default values.</td>
</tr>
<tr>
<td></td>
<td>When this option is selected, the allow multiple values field is selectable (predetermined and SQL query only).</td>
</tr>
</tbody>
</table>

| Allow multiple values         | For allowing multiple values (list box presentation only) |
|                               | If multiple values selected are used to create dynamic selection criteria within the SQR Production Reporting program, the program must be designed to construct a WHERE clause. |

<table>
<thead>
<tr>
<th>Validation Type</th>
<th>Validation type (text only).</th>
</tr>
</thead>
<tbody>
<tr>
<td>Validation Mask</td>
<td>A standard or custom validation mask (text only)</td>
</tr>
</tbody>
</table>

| List Values                   | For entering values that are moved to the list with the right-facing arrows (predetermined only) |
|                               | Delete values by selecting them in the list and selecting the left-facing arrows. |

| SELECT/FROM/WHERE             | SQL commands for retrieving the parameter list (SQL query only). |

### Custom Forms

You can select a custom JSP parameter form or use the standard form for INPUT parameter intake when the job is run. Parameter forms JSPs with input fields. They can also be more
complex, invoking JavaScript or applets. You can select a customized parameter collection form developed by your company.

The assigned form is stored in the repository. You can assign a custom form from your local system or from the repository.

<table>
<thead>
<tr>
<th>Standard Form</th>
<th>Default HTML parameter form, which is displayed only when properties are being modified</th>
</tr>
</thead>
<tbody>
<tr>
<td>Custom Form</td>
<td>For uploading the custom-form file by clicking ADD (next to Custom Form) and browsing to it</td>
</tr>
<tr>
<td>Required Files</td>
<td>For adding supporting files, such as images, used by the selected form</td>
</tr>
<tr>
<td></td>
<td>Name - Required-file name</td>
</tr>
<tr>
<td></td>
<td>Location - Required-file path (The icon next to the name indicates that the file is on your local system.)</td>
</tr>
<tr>
<td>Action</td>
<td>Replace—For replacing the file with one selected from your local system or the repository</td>
</tr>
<tr>
<td></td>
<td>Delete—For deleting the file</td>
</tr>
<tr>
<td>Add Files Manually</td>
<td>For add required files by clicking Go.</td>
</tr>
</tbody>
</table>

**Parameter List Options**

Table 131 details the INPUT parameter list options.

| Smartform allows user to choose a Parameter list | For allowing users to choose parameter lists at runtime |
| Smartform allows user to save as Job Parameter   | For allowing users to save a parameter for values entered in the input fields |

**Job Output**

HTML format is always selected for an output format. You can add additional output formats by selecting them or listing them in the text box.

**Output Options**

Table 132 details the output options.

<table>
<thead>
<tr>
<th>Choose Output Options for SQR Production Reporting Job</th>
<th>Output formats to be generated from your SQR Production Reporting program:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• HTML</td>
</tr>
<tr>
<td></td>
<td>• Interactive Reporting Data (bqd)</td>
</tr>
<tr>
<td></td>
<td>• Smart View</td>
</tr>
<tr>
<td></td>
<td>• Adobe Acrobat</td>
</tr>
<tr>
<td></td>
<td>• PowerPoint</td>
</tr>
</tbody>
</table>
Demand Paging

Demand paging offers options for splitting, or bursting, the report into separate files for better performance. By bursting a report, you avoid downloading the report in its entirety into the browser.

For secure SQR Production Reporting jobs, you should choose an HTML Demand Paging option according to how the report divides the output among users or groups.

Demand paging is for Web output types which include HTML, BQD, XLC, and CSV. Printed output types include PDF, SPF, PS, LP, and HP.

<table>
<thead>
<tr>
<th>Table 133</th>
<th>Demand Paging Options</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Write the entire report as one file</strong></td>
<td>For writing report output to one HTML file (Not available for a secure SQR Production Reporting job)</td>
</tr>
<tr>
<td><strong>Write a separate file every ___ pages</strong></td>
<td>For creating an HTML file for every N pages</td>
</tr>
<tr>
<td></td>
<td>For example: if you enter 1, an HTML file is created for every report page; if you enter 20, an HTML file is created for every 20 pages.</td>
</tr>
<tr>
<td></td>
<td>Default: An HTML file for every page in the report</td>
</tr>
<tr>
<td><strong>Write a separate file based on table of contents level</strong></td>
<td>For creating HTML files for the table of contents</td>
</tr>
<tr>
<td></td>
<td>If you enter 1, a separate HTML file is created for each level 1 entry in the table of contents. If you enter 2, an HTML file is created for each level 1 and level 2 entry.</td>
</tr>
<tr>
<td></td>
<td>Default: An HTML file for each level 1 entry</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> If no table of contents exists, the report is saved as one HTML file.</td>
</tr>
</tbody>
</table>
Advanced Output Options

Table 134 details the advanced output properties.

<table>
<thead>
<tr>
<th>Allow users to add job output to a Personal Page</th>
<th>For allowing users to embed job output contents (HTML only) in personal pages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command-line flags for Job Output</td>
<td>Command-line flags to be used in output bursting.</td>
</tr>
<tr>
<td>Auto delete job outputs after</td>
<td>For specifying when to delete job output automatically</td>
</tr>
</tbody>
</table>

Compile Properties

You can compile SQR Production Reporting programs before you run them. All precompile programs recompile if INCLUDE file is modified.

<table>
<thead>
<tr>
<th>Compile-Time flags</th>
<th>Command-line flags for use at compile time</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database user name</td>
<td>Username to access the database</td>
</tr>
<tr>
<td>Database password</td>
<td>Password for the username</td>
</tr>
<tr>
<td>ASK parameters</td>
<td>For modifying default values for ASK parameters required by the Production Reporting job</td>
</tr>
</tbody>
</table>

A SQR Production Reporting document is a printer-independent file format that accommodates all SQR Production Reporting graphical features, including fonts, lines, boxes, shaded areas, charts, bar codes, and images. SQR Production Reporting portable files have a default extension of SPF or SNN (for multiple reports). This file format is very useful for saving report output. SQR Production Reporting documents can be distributed electronically and read with the SQR Production Reporting viewer. You can decide later where to print a document.

Generic Job Properties

Most generic job properties and SQR Production Reporting job properties are the same. General properties, advanced options, and parameter properties are the same except where noted in the SQR Production Reporting Job Properties section.

Job input and output properties are unique to generic jobs and are explained in the following topics.

Generic Job Output Options

If the application that you need to run your program is not available, see your administrator to configure a job service with the application that you need.
If the required application is not on the list, a job service must be configured for the application before you proceed with the job setup. Contact your system administrator to configure the application.

### Command-line flags for Job Execution

| Command-line flags for Job Execution | Command-line flags to be passed to the application |

### Required Files for Generic Jobs

Identify and locate required files by manually entering the required files. As you identify and locate required files, they are added to the required files page.

<table>
<thead>
<tr>
<th>Name</th>
<th>Required-file name</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>The icon next to the name indicates that the file is on your local system.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Location</th>
<th>Required-file path</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>If the location is not listed, you must find the file by clicking the modify icon or delete the file.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Action</th>
<th>Retrieve—For downloading the file</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Replace—For replacing the file with one from your local computer or the Workspace repository with the same name</td>
</tr>
<tr>
<td></td>
<td>Delete—For deleting the file</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Add Files Manually</th>
<th>Method for locating required files for a job</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Enter files separately or zip them and enter the zip file name. Workspace extracts the zipped files and adds them to the required file summary list.</td>
</tr>
</tbody>
</table>

### Database Connectivity for Generic Jobs

Enter a database username, password, and connect string.

<table>
<thead>
<tr>
<th>User name</th>
<th>User name for the data source</th>
</tr>
</thead>
<tbody>
<tr>
<td>Password</td>
<td>Password for the data source</td>
</tr>
<tr>
<td>Database Connect String</td>
<td>Database connect string for the data source</td>
</tr>
</tbody>
</table>

| Allow pass-through where end user's authentication system is enabled for it | For allowing users to access data sources without entering credentials |

### Output Options for Generic Jobs

Define the job and output options.

<table>
<thead>
<tr>
<th>Display this primary output file after running the job:</th>
<th>Primary output format</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Separate formats with semicolons; for example, *.html; *.pdf. When a format matches, remaining formats are ignored.</td>
</tr>
</tbody>
</table>
Modifying SQR Production Reporting and Generic Job Properties

The properties of SQR Production Reporting and generic jobs can be modified. See “Working with Properties” on page 117.

The Output Summary section, from which you can delete output, is available when you modify properties.

<table>
<thead>
<tr>
<th>Last Run Date</th>
<th>Lists the date the job was last run.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Formats</td>
<td>Lists the output formats generated.</td>
</tr>
<tr>
<td>Delete Selected</td>
<td>In the first column, select dates, then click <strong>Delete Selected</strong> to delete.</td>
</tr>
<tr>
<td>Page</td>
<td>Navigate through multiple pages of output by entering a page in this text box, or by clicking the arrows.</td>
</tr>
</tbody>
</table>

Setting SQR Production Reporting and Generic Job Parameters

You must set the necessary runtime values for a job before the job is run or scheduled. You can save the values as personal job parameters, so they can be used again.

To set job parameters for SQR Production Reporting and generic jobs:

1. Run or schedule a job.
   See “Running Jobs” on page 378 or “Scheduling Jobs” on page 380.

2. Enter the necessary runtime values in the Set Values section if you are running the job or on Parameters if you are scheduling the job.
   You must specify values for all ASK parameters unless you specified default values when importing the job or unless you have a saved job parameter in the Job Parameter list.

3. Optional: To save the values as personal job parameters, click Save and enter a name for the parameters.

Output Options for Scheduling Jobs

The standard job output options are explained in “Scheduling Jobs” on page 380. SQR Production Reporting jobs offer additional e-mail notification options and output directory options.
E-mail Notification Options

SQR Production Reporting jobs offers e-mail notification options.

<table>
<thead>
<tr>
<th>Email Address(es)</th>
<th>E-mail addresses for sending status reports; separate with semicolons, colons, space characters, commas, or lines.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Attach job outputs to email messages in these formats</strong></td>
<td>Select formats for e-mail attachments:</td>
</tr>
<tr>
<td></td>
<td>Default: HTML</td>
</tr>
<tr>
<td></td>
<td>- HTML—Default</td>
</tr>
<tr>
<td></td>
<td>- Comma Delimited</td>
</tr>
<tr>
<td></td>
<td>- Line Printer</td>
</tr>
<tr>
<td></td>
<td>- Include Dependent Files</td>
</tr>
<tr>
<td></td>
<td>--For including all e-mail attachment files dependent on this job.</td>
</tr>
<tr>
<td></td>
<td>- SPF</td>
</tr>
<tr>
<td></td>
<td>- Interactive Reporting Data</td>
</tr>
<tr>
<td></td>
<td>- Smart View</td>
</tr>
<tr>
<td></td>
<td>- Adobe Acrobat</td>
</tr>
<tr>
<td></td>
<td>- Postscript</td>
</tr>
<tr>
<td></td>
<td>- HP Printer</td>
</tr>
<tr>
<td></td>
<td>- Other—Enter a file type.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Zip Options</th>
<th>Zip file options:</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>- Do not compress attachment files—Zip file not created</td>
</tr>
<tr>
<td></td>
<td>- Combine all attachments into one Zip file—Zip file contains HTML and selected file formats</td>
</tr>
<tr>
<td></td>
<td>- Combine only HTML and Graphics into Zip file—Zip file contains HTML and selected graphic file formats</td>
</tr>
</tbody>
</table>

Output Directory Options

SQR Production Reporting jobs offer output directory options.

**Note:**

The Save to Output Directory section is displayed only if the administrator has configured an output directory.

<table>
<thead>
<tr>
<th>Table 135 Output Directory Options</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Output Directory</strong></td>
</tr>
<tr>
<td><strong>Save output in these formats</strong></td>
</tr>
</tbody>
</table>
Working with Secure SQR Production Reporting Jobs

Secure and insecure SQR Production Reporting jobs are handled differently. For secure jobs, security tags are applied to report sections. The following topics explain what secure jobs are and how their security is accomplished and protected.

If the SQR Production Reporting programmer applies security tags to report sections, thereby restricting access to the sections to specified users, the report is secure. SQR Production Reporting produces only HTML output (with images) for a secure report. For details on programming a secure SQR Production Reporting report, see your SQR Production Reporting documentation.

When a secure SQR Production Reporting job is run, the security tags are written to the SQR Production Reporting. When the document is executed, each resulting HTML file is given a security tag assuring that only users authorized to see all data in the file can see the file.

It is important to set the bursting (or demand paging) options appropriately for a secure report, so the resulting files correspond to the way that the SQR Production Reporting program divided data among users. If you do not burst the SQR Production Reporting document correctly, security is preserved, but some users may not have access to data that they should be able to see.

The SQR Production Reporting document written by running a SQR Production Reporting program can be imported into the repository. Executing a secure document yields the same output with the same access privileges as executing the secure job.

Access Privileges on Secure SQR Production Reporting Jobs

Access privileges on output files are derived, first, from the user’s access when the job is executed or from the job output access privileges, if the privileges are set. Each output file may also have an associated set of security tags. Job owners can change the access privileges on SPF or output files. In a SQR Production Reporting document, which contains all data, broadening access means relaxing security on the report.

Users need all these privileges to see output files:

- View access on the report folder
- View access on the files
Access granted by the SQR Production Reporting security tags of the output files (The access is derived from the security tags in the code.)

Security tags are not checked when job output is deleted. Only normal access privilege checking is performed. Thus, a job output file owner can delete the file, regardless of whether the security tags enable the owner to view the file contents. If a secure report creates data file through a SQR Production Reporting OPEN statement, only the job owner has view access to the file. The owner can relax security for the file.

**Security Mode**

Every item in SQR Production Reporting has a security mode that is on or off.

The security mode for all items derived from a secure SQR Production Reporting file is on. These items include the SQR Production Reporting document, all output files, the SQR Production Reporting ProgramOutput item, and the SPFFileOutputCollection item. If a file is secure, this information is displayed in Properties (on the Advanced tab).

It is possible to create a secure SQR Production Reporting program that produces secure and nonsecure output. The SQR Production Reporting program can be coded so that some pages are output without security, while the rest are secure. In this case, users with access to the output files through normal Workspace access control see the nonsecure output pages and the secure pages that they are authorized to see. The ability to create secure and nonsecure pages within a secure SQR Production Reporting program is governed with the `security` command in SQR Production Reporting.

You can create on replace a version of a secure report, but the security mode for the new version and the original must match.

**Recommendations for Security**

Recommendations for ensuring the security of secure SQR Production Reporting jobs and documents in Workspace:

- Establish dedicated user accounts for secure SQR Production Reporting or SPF jobs.
- Use a dedicated account for one secure report or a group of related secure reports.
- Ensure that secure jobs are run only from dedicated accounts.
- Limit access to the dedicated account to as few people as possible, because everyone with access to it can import secure jobs and access the SQR Production Reporting document, which contains all data.

**Programmer Conventions**

SQR Production Reporting has built-in conventions for designating security tags to Workspace users or groups. A security tag that begins with \texttt{u#} represents a user. A security tag that begins with \texttt{g#} represents a group.
Viewing Security Information

Secure SQR Production Reporting programs tailor their output for multiple users and restrict access accordingly. You can determine whether a file related to the SQR Production Reporting program is secure by viewing its security mode.

For secure SQR Production Reporting file and its related files, the Secure mode property is set to on. The related files include SQR Production Reporting output files, document collections, and SQR Production Reporting documents output collections.

To view the security mode of a file:

1. Select the file, and Modify.
2. Open the Advanced Options section.

If the file is secure, the Security Tags Included box is checked.

Supporting Exceptions in SQR Production Reporting or Generic Programs

The following topics are for SQR Production Reporting and generic report programmers, who support exception notifications to users. (Users can receive e-mail notifications or see a graphic indicator on the Exceptions Dashboard on personal pages.)

SQR Production Reporting Programming

For SQR Production Reporting programs to support exceptions, they must include these lines:

```plaintext
open 'output.properties' as 0 for-append record=32767:vary
write 0 from 'exception.default=on'
write 0 from 'exception.default.text=<exception text>'
close 0
```

Generic Report Programming

For generic jobs or files to support exceptions. Programmers must use the Oracle's Hyperion® Workspace API to configure exception reporting through the job output properties, exception present and exception text.

Setting Priority on Output Programmatically

In SQR Production Reporting programs, you can set the output as high priority. In Explore module listings, users see the high-priority icon next to any high-priority job output or version. Users can also sort by priority (normal or high).
To set priority to high on the output, a program writes the string `rating=high-priority` to the `output.properties` file used by the job service. This code excerpt accomplishes this objective:

```plaintext
open 'output.properties' as 0 for-append record=32767:vary
write 0 from 'rating=high-priority'
close 0
```
Using Custom Parameter Forms for SQR Production Reporting Jobs

In This Chapter

Customizing Parameter Forms ................................................................. 435
Parameter Form Elements ........................................................................ 437
Standard Parameter Form ........................................................................ 441
Standard Parameter Form Example ............................................................ 441
Parameter Forms: Example and Tip ........................................................... 444

Customizing Parameter Forms

An SQR Production Reporting job uses a parameter form to obtain INPUT parameter values at runtime. This section explains how to customize parameter forms.

Note:
The parameter forms are in JSP. Customizing the standard form provided with SQR Production Reporting requires a working knowledge of JSP and Java.

By default, when you run an SQR Production Reporting job or create or modify a parameter list, Workspace generates a standard form to collect parameter information. You can customize the form. For example, some jobs may require a more sophisticated field layout, or your organization may require certain conventions.

You can associate custom parameter forms with jobs at runtime. You run or schedule a job that is associated with a custom form, which is displayed instead of the standard form.

A parameter form is a JSP containing input fields. Forms can also be more complex, invoking JavaScript or an applet.

Parameter Form Process

The parameter form associated with a job or the standard form is displayed when you perform any of these actions:

- Select Run Job from the job shortcut menu
- From an item list, select the job name
Create or modify parameter list while scheduling the job

After you submit a completed form for execution, Workspace performs these actions:

1. Validates parameters for which validation is defined
2. Processes the form
   The form can collect parameter values and database logon information, as required by the job. For scheduling, the form can also collect the parameter list name and description.
3. Creates or modifies the parameter list or runs the job, as applicable
4. If the job was run, retrieves and displays job output

Assigning Parameter Forms Jobs

This procedure applies only to custom parameter forms created for use in SQR Production Reporting.

**Note:**

Custom parameter forms created prior to SQR Production Reporting are in HTML and must be recreated as JSP forms for use with SQR Production Reporting.

➤ To assign a custom parameter form to a SQR Production Reporting job:

1. In the browser, navigate to the job, and right-click the job name.
2. Select Properties from the top menu.
3. Select Custom Form, and browse to the file to use.
4. If your form uses additional files, such as GIFs, select Show Required Files.
5. When you finish changing form properties, click OK.

Assigning the Standard Form

After assigning a custom form to a job, you can reassign the standard form.

➤ To assign the standard form to a job:

1. In the browser, navigate to the desired SQR Production Reporting job and right-click the job name.
2. Choose Properties.
3. Select Parameters from the top menu.
4. Select Standard Form.
5. Choose OK.
Editing Parameter Forms

Edit a custom form before you assign it to a job. To edit a form after it is assigned to a job, download it, change it, and upload it to the repository. An edited standard form is uploaded as a custom form.

SQR Production Reporting parameter forms contain JSP tags or scriptlets that graphical HTML editors cannot display correctly. However, the tags are designed so that you can use some graphical HTML editors to modify layouts. Before using an editor, ensure that it does not alter code.

Using an editor to modify a parameter form requires knowledge of SQR Production Reporting parameter-form API and JSP tags. When editing a parameter form, keep the scriplet code blocks together. Otherwise, it may not work correctly.

To edit a parameter form, use a nongraphical HTML editor, such as Macromedia Homesite. Be careful not to alter the JSP tags.

➤ To edit a parameter form:

1. In the browser, navigate to the SQR Production Reporting job, and right-click the job name.
2. Select Properties.
3. From the top menu, select parameters.
4. Select Custom Form.
5. Select Modify, select Add next to Custom Form.
6. Download the standard form, or browse your PC or the repository for a custom form.
7. If editing the standard form, specify a location for saving an editable copy, and enter a name for the new custom form.
8. Edit the form locally.
   See “Parameter Form Elements” on page 437.
9. Click OK to save changes.

Parameter Form Elements

You create a parameter form as an HTML file that contains special elements. Before displaying a parameter form, Workspace interprets and processes elements that it encounters in the form. Typically, Workspace processes an element by replacing it with the value indicated by the element. For example, it replaces `<%=targetFormParameter.getJobName()%>` with the job name.

Note:

Parameter form elements are case sensitive.
Element Types

The main element types of parameter forms:

- Basic
- Conditional
- Looping

Basic Elements

Basic elements have the form `<%= (bean).getxxx()%>`.

Example: `<%= targetFormParameter.getJobName()%>`.

Conditional Elements

A conditional element has the standard JSP or Java conditional code:

```
if () {}
else {}
```

You can insert HTML or applicable parameter form elements between the start and end tag. SQR Production Reporting evaluates whether the condition indicated by the has Value argument is true or false. If true, the enclosed HTML is included in the displayed form, if false, the HTML between the start and end tags is ignored.

Looping Elements

Looping elements have this form:

```
<getxxxLoop>
  ...
</getxxxLoop>.
```

An example is `getParameterPickListLoop`. You can insert HTML elements between the start and end tags. When Workspace processes the elements, it processes the loop contents until the loop finishes. The loop termination condition depends on the element.

Required Elements

A parameter form provides required elements and elements to use if, for example, you are setting up a parameter pick list or must access information from a database.

Required elements include elements that identify a file as a parameter form file, return parameter information, and return the URL to use when you submit the form for processing. See Table 136.
Table 136  Required Elements

<table>
<thead>
<tr>
<th>Elements</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>setParameterAskCond(String n)</td>
<td>Selects the Nth ASK parameter, where n is from 1 to the total number of ASK parameters.</td>
</tr>
<tr>
<td>getParameterFieldName()</td>
<td>Returns the name of the HTML form field for setting the value of the parameter selected in ParameterInputCond or ParameterAskCond</td>
</tr>
<tr>
<td>setParameterInputCond(String n)</td>
<td>Selects the Nth INPUT parameter, where n is from 1 to the number of INPUT parameters</td>
</tr>
<tr>
<td>getParameterName()</td>
<td>Returns the current parameter name</td>
</tr>
<tr>
<td>getParameterValue()</td>
<td>Returns the value of the current parameter or, for a parameter list, the current value of the parameter</td>
</tr>
</tbody>
</table>

The following topics show code snippets using the required elements.

**Name Specification Elements**

The element that follows specifies the import file name for the parameter form.

```xml
<jsp:include page="jsp/shared/formparameterFormJavaScript.jsp'flush=true"/>
```

**Parameter List Elements**

Scheduling a job requires the creation of a parameter list, which has a name and description and contains a value for each parameter associated with the job. When scheduling a job, you select a parameter list, which provides the set of parameters that Workspace uses when it runs the job.

**Parameter Display Elements**

The following code snippet shows the use of elements for handling parameter values. If your form uses a parameter pick list, see the sample code at the end of this topic.

```xml
<getParameterInputCond hasValue="1"> <!-- 1st parameter -->
<!-- Name of parameter -->
<TD VALIGN="MIDDLE">
<FONT face="Arial, Helvetica, sans-serif" size="-1">
<B><getParameterName/></B>
</FONT>
</TD>
<TD VALIGN="MIDDLE" COLSPAN="2">
<INPUT TYPE="text" NAME="<getParameterFieldName/>" VALUE="<getParameterValue/>" SIZE="30">
</TD>
</getParameterInputCond>
```

The `<getParameterInputCond>` and `<getParameterAskCond>` tags select the INPUT or ASK parameter that is used to resolve the `<getParameterName/>, `<getParameterFieldname/>` and `<getParameterValue>` tags. You must set the `hasValue` argument from 1 to the number of INPUT or ASK parameters.
## Nonrequired Elements

For parameter forms, you can use nonrequired and required elements.

### Table 137  Nonrequired Elements

<table>
<thead>
<tr>
<th>Elements</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>getEmbedParameterValidationRoutines()</code></td>
<td>Adds the JavaScript parameter validation routines to the form</td>
</tr>
<tr>
<td><code>isFormUsesParameterValidationCond()</code></td>
<td>Returns true if the current job requires JavaScript validation routines</td>
</tr>
<tr>
<td><code>isParameterValidationCond()</code></td>
<td>Tests the current parameter for a validation function</td>
</tr>
<tr>
<td><code>isParameterValidationMaskCond()</code></td>
<td>Returns true if a mask is associated with the validation function of the current parameter</td>
</tr>
<tr>
<td><code>resetParameterPickList()</code></td>
<td>Initializes the static or dynamic choice options of the current parameter and prints an error message if initialization fails</td>
</tr>
<tr>
<td><code>isParameterMultiValuesCond()</code></td>
<td>Returns true if the parameter accepts multiple values</td>
</tr>
<tr>
<td><code>see getParameterType()</code></td>
<td>Returns the current parameter type number:</td>
</tr>
<tr>
<td></td>
<td>Text edit = 0</td>
</tr>
<tr>
<td></td>
<td>Drop-down list = 1</td>
</tr>
<tr>
<td></td>
<td>Radio button = 2</td>
</tr>
<tr>
<td></td>
<td>List box = 3</td>
</tr>
<tr>
<td><code>setParameterType()</code></td>
<td>Returns the current parameter type number:</td>
</tr>
<tr>
<td></td>
<td>Text edit = 0</td>
</tr>
<tr>
<td></td>
<td>Drop-down list = 1</td>
</tr>
<tr>
<td></td>
<td>Radio button = 2</td>
</tr>
<tr>
<td></td>
<td>List box = 3</td>
</tr>
<tr>
<td><code>getParameterListPublisherDefaultsFieldName()</code></td>
<td>Returns the name of the HTML form field used for the Publisher Defaults parameter list</td>
</tr>
<tr>
<td><code>processParameterPickListLoop()</code></td>
<td>Iterates through a parameter pick list values.</td>
</tr>
<tr>
<td><code>getPickListParameterValue()</code></td>
<td>Used within a loop construct for <code>processParameterPickListLoop()</code></td>
</tr>
<tr>
<td></td>
<td>Returns the next value in a parameter pick list;</td>
</tr>
<tr>
<td><code>getParameterPickListValueSelected(String presentationType)</code></td>
<td>Must be used within a Java loop construct. Returns &quot;selected&quot; if the next value in the pick list is the current value for the parameter;</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> You can set <code>presentationType</code> to &quot;select&quot; or &quot;check.&quot; For a pick list for a parameter with only a few values, you can use buttons to display the options. In this case, setting the <code>presentationType</code> to &quot;check&quot; returns &quot;checked.&quot; You can use this option to indicate which option is the current value for the parameter</td>
</tr>
<tr>
<td><code>getParameterValidationMask()</code></td>
<td>Returns the mask associated with the current parameter of the validation function</td>
</tr>
</tbody>
</table>
### Standard Parameter Form

The standard parameter form for Oracle’s Hyperion® SQR® Production Reporting – System 9 is in JSP. Notice the required import tags in the standard form example. A `JavaBeanIFormalParameter View` statement is used to access all form APIs to obtain information regarding the form parameter list.

**Note:**

You can create a custom parameter form by modifying the standard form. Java and JSP can be leveraged to enhance the form.

### Standard Parameter Form Example

```jsp
<%@ include file="/jsp/shared/common.inc"%>
<%@ page import="com.brio.one.web.ui.JSPUtility, com.brio.one.web.browser.ui.*, com.brio.one.web.ui.config.*, java.util.*"%>
<jsp:useBean id="targetFormParameter" scope="request" type="com.brio.one.web.ui.IFormParameterView"/>
<!--
This template is used for these purposes:
1) Run a job that requires parameters or database user information
2) Create a parameter list for a job
3) Edit a parameter list for a job
This template is used when there is no custom ONE/SmartForm associated with the job.
-->
<jsp:include page="/jsp/shared/form/parameterFormJavaScript.jsp" flush="true"/>
<TABLE border="0" width="98%" cellpadding="0" cellspacing="0">
    <TR>
        <TD WIDTH="45"><IMG <%=imgLocator.getSrcAltAttribute(request, "space.gif")%> WIDTH="45" HEIGHT="1" ALT=""></TD>
        <!--
        WIDTH="45" HEIGHT="1" ALT=""></TD>
        <TD WIDTH="15"></TD>
    </TR>
</TABLE>
```
Using Custom Parameter Forms for SQR Production Reporting Jobs
if (type == targetFormParameter.LIST_BOX) {
    targetFormParameter.resetParameterPickList();
    if (targetFormParameter.isParameterMultiValuesCond()) {%
        <SELECT class="DataFrameDrop" NAME="<%=targetFormParameter.getParameterFieldName()%>" onchange="onParamChange()" multiple size="5"><%
    } else {%}
        <SELECT class="DataFrameDrop" NAME="<%=targetFormParameter.getParameterFieldName()%>" onchange="onParamChange()" size = "5"><%}
    if (!targetFormParameter.isRequiredParameterCond()) {%
        <OPTION VALUE=""></OPTION><%
    }
    while (targetFormParameter.processParameterPickListLoop()) {%}
        <OPTION VALUE="<%=targetFormParameter.getPickListParameterValue()%>" <% =targetFormParameter.getParameterPickListValueSelected("select")%>><% =targetFormParameter.getHTMLEscapedCurrentPickListParameterValue()%></OPTION><%
    }%>
</SELECT><%
}
if (type == targetFormParameter.RADIO_BUTTONS) {
    targetFormParameter.resetParameterPickList();
    if (!targetFormParameter.isRequiredParameterCond()) { %>
        <input type="Radio" class="RadioButton" onchange="onParamChange()" name="<%=targetFormParameter.getParameterFieldName()%>" value="" checked><span class="RadioButtonText">No Selection Made</span><br><%
    }
    while (targetFormParameter.processParameterPickListLoop()) {%>
        <input type="Radio" class="RadioButton" onchange="onParamChange()" name="<%=targetFormParameter.getParameterFieldName()%>" value="<%=targetFormParameter.getPickListParameterValue()%>" <% =targetFormParameter.getParameterPickListValueSelected("check")%>><span class="RadioButtonText"><%=targetFormParameter.getPickListParameterValue()%></span><br><%
    }
}
%>
</TD VALIGN="TOP" COLSPAN="2"></TR><%
}
if (targetFormParameter.isParameterHiddenCond()) {%
    <INPUT TYPE="hidden" NAME="<%=targetFormParameter.getParameterFieldName()%>" VALUE=" <%=targetFormParameter.getParameterValue()%>"%>
All form parameter APIs are directly accessed through the Java bean; for example:

```
targetFormParameter.getParameterName()
```

Use Java scriptlet tags to run Java code blocks within the tags; for example:

```
<% String start="abc";%>
```

Use a JSP expression embedded in HTML to resolve variables to values at runtime; for example:

```
<HTML>
<BODY>
The start of the alphabet is <%=start%>
</BODY>
</HTML>
```

Parameter form information can also be accessed through the parameter form APIs. This example resolves the current value of the parameter name and display the name in the form:

```
<%=targetFormParameter.getParameterValue()%>
```

### Parameter Forms: Example and Tip

The following code snippet shows tag use for parameter pick lists.

```
<%!-- Parameter Pick List example -->
<%
if (targetForm.setParameterInputCond("1")) {%>
  <SELECT NAME="%=targetFormParameter.getParameterFieldName()%"><%
targetFormParameter.restParameterPickList();
  while(targetFormParameter.processParameterPickListLoop() {%>
    <OPTION VALUE="%=targetFormParameter.getParameterPickListValue()%" <%=targetFormParameter.getParameterPickListValueSelected("select")%>><%=targetFormParameter.getParameterPickListValue()%>
  </OPTION>
%>
</SELECT><%
}%>
```

Custom form can import JSPs and thus become more modular. For example, the standard form example, includes a jsp include tag. The `<jsp:include>` tag is a standard JSP tag:

```
<jsp:includepage="/jsp/shared/form/parameterFormJavaScript.jsp" flush="true"/>
```
The preceding example causes the parameterFormJavaScript.jsp file to be imported and executed with the standard form. Custom forms that include context, such as images, must be defined in the required files section.
! See bang character (!).

#MISSING See missing data (#MISSING).

access permissions A set of operations that a user can perform on a resource.

accessor Input and output data specifications for data mining algorithms.

account A dimension that represents an accounting container that identifies the location and primary nature of the data.

account blocking The process by which accounts accept input data in the consolidated file. Blocked accounts do not receive their value through the additive consolidation process.

account eliminations Accounts which have their values set to zero in the consolidated file during consolidation.

account type How an account’s value flows over time, and its sign behavior. Account type options can include expense, income, asset, liability, and equity.

accountability map A visual, hierarchical representation of the responsibility, reporting, and dependency structure of the accountability teams (also known as critical business areas) in an organization.

accounts dimension A dimension type that makes accounting intelligence available. Only one dimension can be defined as Accounts.

active service A service whose Run Type is set to Start rather than Hold.

active user A user who is entitled to access the system.

active user/user group The user or user group identified as the current user by user preferences. Determines default user preferences, dynamic options, access, and file permissions. You can set the active user to your user name or any user group to which you belong.

activity-level authorization Defines user access to applications and the types of activities they can perform on applications, independent of the data that will be operated on.

ad hoc report An online analytical query created on-the-fly by an end user.

adaptive states Interactive Reporting Web Client level of permission.

adjustment See journal entry (JE).

Advanced Relational Access The integration of a relational database with an Essbase multidimensional database so that all data remains in the relational database and is mapped to summary-level data residing in the Essbase database.

agent An Essbase server process that starts and stops applications and databases, manages connections from users, and handles user-access security. The agent is referred to as ESSBASE.EXE.

aggregate cell A cell comprising several cells. For example, a data cell that uses Children(Year) expands to four cells containing Quarter 1, Quarter 2, Quarter 3, and Quarter 4 data.

aggregate function A type of function, such as sum or calculation of an average, that summarizes or performs analysis on data.

aggregate limit A limit placed on an aggregated request line item or aggregated metatopic item.
**aggregate storage database** The database storage model designed to support large-scale, sparsely distributed data which is categorized into many, potentially large dimensions. Upper level members and formulas are dynamically calculated, and selected data values are aggregated and stored, typically with improvements in overall aggregation time.

**aggregate view** A collection of aggregate cells based on the levels of the members within each dimension. To reduce calculation time, values are pre-aggregated and stored as aggregate views. Retrievals then start from aggregate view totals and add up from there.

**aggregation** The process of rolling up and storing values in an aggregate storage database; the stored result of the aggregation process.

**aggregation script** In aggregate storage databases only, a file that defines a selection of aggregate views to be built into an aggregation.

**alias** An alternative name. For example, for a more easily identifiable column descriptor you can display the alias instead of the member name.

**alias table** A table that contains alternate names for members.

**alternate hierarchy** A hierarchy of shared members. An alternate hierarchy is based upon an existing hierarchy in a database outline, but has alternate levels in the dimension. An alternate hierarchy allows the same data to be seen from different points of view.

**ancestor** A branch member that has members below it. For example, the members Qtr2 and 2006 are ancestors of the member April.

**appender** A Log4j term for destination.

**application** (1) A software program designed to run a specific task or group of tasks such as a spreadsheet program or database management system. (2) A related set of dimensions and dimension members that are used to meet a specific set of analytical and/or reporting requirements.

**application currency** The default reporting currency for the application.

**Application Migration Utility** A command-line utility for migrating applications and artifacts.

**area** A predefined set of members and values that makes up a partition.

**arithmetic data load** A data load that performs operations on values in the database, such as adding 10 to each value.

**artifact** An individual application or repository item; for example, scripts, forms, rules files, Interactive Reporting documents, and financial reports. Also known as an object.

**asset account** An account type that stores values that represent a company’s assets.

**attribute** Characteristics of a dimension member. For example, Employee dimension members may have attributes of Name, Age, or Address. Product dimension members can have several attributes, such as a size and flavor.

**attribute association** A relationship in a database outline whereby a member in an attribute dimension describes a characteristic of a member of its base dimension. For example, if product 100-10 has a grape flavor, the product 100-10 has the Flavor attribute association of grape. Thus, the 100-10 member of the Product dimension is associated with the Grape member of the Flavor attribute dimension.

**Attribute Calculations dimension** A system-defined dimension that performs these calculation operations on groups of members: Sum, Count, Avg, Min, and Max. This dimension is calculated dynamically and is not visible in the database outline. For example, using the Avg member, you can calculate the average sales value for Red products in New York in January.

**attribute dimension** A type of dimension that enables analysis based on the attributes or qualities of dimension members.

**attribute reporting** A reporting process based on the attributes of the base dimension members. See also base dimension.

**attribute type** A text, numeric, Boolean, date, or linked-attribute type that enables different functions for grouping, selecting, or calculating data. For example, because the Ounces attribute dimension has the type numeric, the number of ounces specified as the attribute of each product can be used to calculate the profit per ounce for that product.
**authentication** Verification of identity as a security measure. Authentication is typically based on a user name and password. Passwords and digital signatures are forms of authentication.

**authentication service** A core service that manages one authentication system.

**auto-reversing journal** A journal for entering adjustments that you want to reverse in the next period.

**automated stage** A stage that does not require human intervention, for example, a data load.

**axis** (1) A straight line that passes through a graphic used for measurement and categorization. (2) A report aspect used to arrange and relate multidimensional data, such as filters, pages, rows, and columns. For example, for a data query in Simple Basic, an axis can define columns for values for Qtr1, Qtr2, Qtr3, and Qtr4. Row data would be retrieved with totals in the following hierarchy: Market, Product.

**backup** A duplicate copy of an application instance.

**balance account** An account type that stores unsigned values that relate to a particular point in time.

**balanced journal** A journal in which the total debits equal the total credits.

**bang character (!)** A character that terminates a series of report commands and requests information from the database. A report script must be terminated with a bang character; several bang characters can be used within a report script.

**bar chart** A chart that can consist of one to 50 data sets, with any number of values assigned to each data set. Data sets are displayed as groups of corresponding bars, stacked bars, or individual bars in separate rows.

**base currency** The currency in which daily business transactions are performed.

**base dimension** A standard dimension that is associated with one or more attribute dimensions. For example, assuming products have flavors, the Product dimension is the base dimension for the Flavors attribute dimension.

**base entity** An entity at the bottom of the organization structure that does not own other entities.

**batch calculation** Any calculation on a database that is done in batch; for example, a calculation script or a full database calculation. Dynamic calculations are not considered to be batch calculations.

**batch file** An operating system file that can call multiple ESSCMD scripts and run multiple sessions of ESSCMD. On Windows-based systems, batch files have BAT file extensions. On UNIX, batch files are written as a shell script.

**batch POV** A collection of all dimensions on the user POV of every report and book in the batch. While scheduling the batch, you can set the members selected on the batch POV.

**batch processing mode** A method of using ESSCMD to write a batch or script file that can be used to automate routine server maintenance and diagnostic tasks. ESSCMD script files can execute multiple commands and can be run from the operating system command line or from within operating system batch files. Batch files can be used to call multiple ESSCMD scripts or run multiple instances of ESSCMD.

**block** The primary storage unit which is a multidimensional array representing the cells of all dense dimensions.

**block storage database** The Essbase database storage model categorizing and storing data based on the sparsity of data values defined in sparse dimensions. Data values are stored in blocks, which exist only for sparse dimension members for which there are values.

**Blocked Account** An account that you do not want calculated in the consolidated file because you want to enter it manually.

**book** A container that holds a group of similar Financial Reporting documents. Books may specify dimension sections or dimension changes.

**book POV** The dimension members for which a book is run.

**bookmark** A link to a reporting document or a Web site, displayed on a personal page of a user. The two types of bookmarks are My Bookmarks and image bookmarks.
bounding rectangle  The required perimeter that encapsulates the Interactive Reporting document content when embedding Interactive Reporting document sections in a personal page, specified in pixels for height and width or row per page.

broadcast message  A simple text message sent by an administrator to a user who is logged on to a Planning application. The message displays information to the user such as system availability, notification of application refresh, or application backups.

budget administrator  A person responsible for setting up, configuring, maintaining, and controlling an application. Has all application privileges and data access permissions.

build method  A method used to modify database outlines. Choice of a build method is based on the format of data in data source files.

business process  A set of activities that collectively accomplish a business objective.

business rules  Logical expressions or formulas that are created within an application to produce a desired set of resulting values.

cache  A buffer in memory that holds data temporarily.

calc script  A set of commands that define how a database is consolidated or aggregated. A calculation script may also contain commands that specify allocation and other calculation rules separate from the consolidation process.

Calculated Accounts  You cannot alter the formulas in Calculated Accounts. These formulas are fixed in order to maintain the accounting integrity of the model you are building. For example, the formula for Net Income, a Calculated Account, is modeled into Strategic Finance and can not be changed in either historical or forecast periods.

calculated member in MaxL DML  A member designed for analytical purposes and defined in the optional WITH section of a MaxL DML query.

calculation  The process of aggregating data, or of running a calculation script on a database.

calculation status  A consolidation status that indicates that some values or formula calculations have changed. You must reconsolidate to get the correct values for the affected entity.

calendar  User-defined time periods and their relationship to each other. Q1, Q2, Q3, and Q4 comprise a calendar or fiscal year.

cascade  The process of creating multiple reports for a subset of member values.

Catalog pane  Displays a list of elements available to the active section. If Query is the active section, a list of database tables is displayed. If Pivot is the active section, a list of results columns is displayed. If Dashboard is the active section, a list of embeddable sections, graphic tools, and control tools are displayed.

categories  Groupings by which data is organized. For example, Month

cause and effect map  Depicts how the elements that form your corporate strategy relate and how they work together to meet your organization’s strategic goals. A Cause and Effect map tab is automatically created for each Strategy map.

CDF  See custom-defined function (CDF).

CDM  See custom-defined macro (CDM).

cell  (1) The data value at the intersection of dimensions in a multidimensional database; the intersection of a row and a column in a worksheet. (2) A logical group of nodes belonging to one administrative domain.

cell note  A text annotation for a cell in an Essbase database. Cell notes are a type of LRO.

CHANGED status  Consolidation status that indicates data for an entity has changed.

chart  A graphical representation of spreadsheet data. The visual nature expedites analysis, color-coding, and visual cues that aid comparisons.

chart template  A template that defines the metrics to display in Workspace charts.

child  A member with a parent above it in the database outline.
choice list  A list of members that a report designer can specify for each dimension when defining the report’s point of view. A user who wants to change the point of view for a dimension that uses a choice list can select only the members specified in that defined member list or those members that meet the criteria defined in the function for the dynamic list.

clean block  A data block that where the database is fully calculated, if a calculation script calculates all dimensions at once, or if the SET CLEARUPDATESTATUS command is used in a calculation script.

cluster  An array of servers or databases that behave as a single resource which share task loads and provide failover support; eliminates one server or database as a single point of failure in a system.

clustered bar charts  Charts in which categories are viewed side-by-side; useful for side-by-side category analysis; used only with vertical bar charts.

code page  A mapping of bit combinations to a set of text characters. Different code pages support different sets of characters. Each computer contains a code page setting for the character set requirements of the language of the computer user. In the context of this document, code pages map characters to bit combinations for non-Unicode encodings. See also encoding.

column  A vertical display of information in a grid or table. A column can contain data from one field, derived data from a calculation, or textual information.

committed access  An Essbase Kernel Isolation Level setting that affects how Essbase handles transactions. Under committed access, concurrent transactions hold long-term write locks and yield predictable results.

computed item  A virtual column (as opposed to a column that is physically stored in the database or cube) that can be calculated by the database during a query, or by Interactive Reporting Studio in the Results section. Computed items are calculations of data based on functions, data items, and operators provided in the dialog box and can be included in reports or reused to calculate other data.

configuration file  The security platform relies on XML documents to be configured by the product administrator or software installer. The XML document must be modified to indicate meaningful values for properties, specifying locations and attributes pertaining to the corporate authentication scenario.

connection file  See Interactive Reporting connection file (.oce).

consolidated file (Parent)  A file into which all of the business unit files are consolidated; contains the definition of the consolidation.

consolidation  The process of aggregating data from dependent entities to parent entities. For example, if the dimension Year consists of the members Qtr1, Qtr2, Qtr3, and Qtr4, its consolidation is Year.

consolidation file (*.cns)  The consolidation file is a graphical interface that enables you to add, delete or move Strategic Finance files in the consolidation process using either a Chart or Tree view. It also enables you to define and modify the consolidation.

consolidation rule  Identifies the rule that is executed during the consolidation of the node of the hierarchy. This rule can contain customer specific formulas appropriate for the correct consolidation of parent balances. Elimination processing can be controlled within these rules.

content  Information stored in the repository for any type of file.

context variable  A variable that is defined for a particular task flow to identify the context of the taskflow instance.

contribution  The value added to a parent from a child entity. Each child has a contribution to its parent.

conversion rate  See exchange rate.

cookie  A segment of data placed on your computer by a Web site.

correlated subqueries  Subqueries that are evaluated once for every row in the parent query; created by joining a topic item in the subquery with a topic in the parent query.
Cost of Debt  Value determined by using a weighted average Yield to Maturity (YTM) of a company’s entire debt portfolio. Use is the current YTM rate rather than the nominal cost of debt. The coupon rate determines the interest payment, but it does not always reflect the actual cost of the company’s debt today. As required returns change, the price of a debt issue also changes so that the actual interest payments and anticipated proceeds, at maturity, yield the investors their revised required return. Therefore, the YTM fully reflects the current return demanded by debt holders and the rate at which existing debt would have to be replaced.

Cost of Equity  The return an investor expects to earn on an individual stock. Using the CAPM method, the Cost of Equity is equal to:

Cost of Preferred  Represents the expected return to preferred stockholders. Like debt, you need to enter the yield to maturity on preferred stock, but without the tax shielding.

critical business area (CBA)  An individual or a group organized into a division, region, plant, cost center, profit center, project team, or process; also called accountability team or business area.

critical success factor (CSF)  A capability that must be established and sustained to achieve a strategic objective; owned by a strategic objective or a critical process and is a parent to one or more actions.

crosstab reporting  Categorizes and summarizes data in table format. The table cells contain summaries of the data that fit within the intersecting categories. For example, a crosstab report of product sales information could show size attributes, such as Small and Large, as column headings and color attributes, such as Blue and Yellow, as row headings. The cell in the table where Large and Blue intersect could contain the total sales of all Blue products that are sized Large.

cube  A block of data that contains three or more dimensions. An Essbase database is a cube.

currency conversion  A process that converts currency values in a database from one currency into another. For example, to convert one U. S. dollar into the European euro, the exchange rate (for example, 0.923702) is multiplied with the dollar (1 * 0.923702). After conversion, the European euro amount is .92.

Currency Overrides  In any input period, the selected input method can be overridden to enable input of that period’s value as Default Currency/Items. To override the input method, enter a pound sign (#) either before or after the number.

currency partition  A dimension type that separates local currency members from a base currency, as defined in an application. Identifies currency types, such as Actual, Budget, and Forecast.

custom calendar  Any calendar created by an administrator.

custom dimension  A dimension created and defined by users. Channel, product, department, project, or region could be custom dimensions.

custom property  A property of a dimension or dimension member that is created by a user.

custom report  A complex report from the Design Report module, composed of any combination of components.

custom-defined function (CDF)  Essbase calculation functions developed in Java and added to the standard Essbase calculation scripting language using MaxL. See also custom-defined macro (CDM).

custom-defined macro (CDM)  Essbase macros written with Essbase calculator functions and special macro functions. Custom-defined macros use an internal Essbase macro language that enables the combination of calculation functions and they operate on multiple input parameters. See also custom-defined function (CDF).

cycle through  To perform multiple passes through a database while calculating it.

dashboard  A collection of metrics and indicators that provide an interactive summary of your business. Dashboards enable you to build and deploy analytic applications.

data cache  A buffer in memory that holds uncompressed data blocks.

data cell  See cell.

data file cache  A buffer in memory that holds compressed data (PAG) files.
**Data Form**   A grid display that enables users to enter data into the database from an interface such as a Web browser, and to view and analyze data or related text. Certain dimension member values are fixed, giving users a specific view into the data.

**Data Function**   That computes aggregate values, including averages, maximums, counts, and other statistics, that summarize groupings of data.

**Data Load Rules**   A set of criteria that determines how to load data from a text-based file, a spreadsheet, or a relational data set into a database.

**Data Lock**   Prevents changes to data according to specified criteria, such as period or scenario.

**Data Mining**   The process of searching through an Essbase database for hidden relationships and patterns in a large amount of data.

**Data Model**   A representation of a subset of database tables.

**Data Value**   See cell.

**Database Connection**   File that stores definitions and properties used to connect to data sources and enables database references to be portable and widely used.

**Default Currency Units**   Define the unit scale of data. For example, If you select to define your analysis in Thousands, and enter “10”, this is interpreted as “10,000”.

**Dense Dimension**   In block storage databases, a dimension likely to contain data for every combination of dimension members. For example, time dimensions are often dense because they can contain all combinations of all members. Contrast with sparse dimension.

**Dependent Entity**   An entity that is owned by another entity in the organization.

**Descendant**   Any member below a parent in the database outline. In a dimension that includes years, quarters, and months, the members Qtr2 and April are descendants of the member Year.

**Design Report**   An interface in Web Analysis Studio for designing custom reports, from a library of components.

**Destination Currency**   The currency to which balances are converted. You enter exchange rates and convert from the source currency to the destination currency. For example, when you convert from EUR to USD, the destination currency is USD.

**Detail Chart**   A chart that provides the detailed information that you see in a Summary chart. Detail charts appear in the Investigate Section in columns below the Summary charts. If the Summary chart shows a Pie chart, then the Detail charts below represent each piece of the pie.

**Dimension**   A data category used to organize business data for retrieval and preservation of values. Dimensions usually contain hierarchies of related members grouped within them. For example, a Year dimension often includes members for each time period, such as quarters and months.

**Dimension Build**   The process of adding dimensions and members to an Essbase outline.

**Dimension Build Rules**   Specifications, similar to data load rules, that Essbase uses to modify an outline. The modification is based on data in an external data source file.

**Dimension Tab**   In the Pivot section, the tab that enables you to pivot data between rows and columns.

**Dimension Table**   (1) A table that includes numerous attributes about a specific business process. (2) In Essbase Integration Services, a container in the OLAP model for one or more relational tables that define a potential dimension in Essbase.

**Dimension Type**   A dimension property that enables the use of predefined functionality. Dimensions tagged as time have a predefined calendar functionality.

**Dimensionality**   In MaxL DML, the represented dimensions (and the order in which they are represented) in a set. For example, the following set consists of two tuples of the same dimensionality because they both reflect the dimensions (Region, Year): \{ (West, Feb), (East, Mar) \}

**Direct Rate**   A currency rate that you enter in the exchange rate table. The direct rate is used for currency conversion. For example, to convert balances from JPY to USD, In the exchange rate table, enter a rate for the period/scenario where the source currency is JPY and the destination currency is USD.
dirty block  A data block containing cells that have been changed since the last calculation. Upper level blocks are marked as dirty if their child blocks are dirty (that is, they have been updated).

display type  One of three Web Analysis formats saved to the repository: spreadsheet, chart, and pinboard.

dog-ear  The flipped page corner in the upper right corner of the chart header area.

domain  In data mining, a variable representing a range of navigation within data.

drill-down  Navigation through the query result set using the dimensional hierarchy. Drilling down moves the user perspective from aggregated data to detail. For example, drilling down can reveal hierarchical relationships between years and quarters or quarters and months.

drill-through  The navigation from a value in one data source to corresponding data in another source.

duplicate alias name  A name that occurs more than once in an alias table and that can be associated with more than one member in a database outline. Duplicate alias names can be used with duplicate member outlines only.

duplicate member name  The multiple occurrence of a member name in a database, with each occurrence representing a different member. For example, a database has two members named “New York.” One member represents New York state and the other member represents New York city.

duplicate member outline  A database outline containing duplicate member names.

Dynamic Calc and Store members  A member in a block storage outline that Essbase calculates only upon the first retrieval of the value. Essbase then stores the calculated value in the database. Subsequent retrievals do not require calculating.

Dynamic Calc members  A member in a block storage outline that Essbase calculates only at retrieval time. Essbase discards calculated values after completing the retrieval request.

dynamic calculation  In Essbase, a calculation that occurs only when you retrieve data on a member that is tagged as Dynamic Calc or Dynamic Calc and Store. The member’s values are calculated at retrieval time instead of being precalculated during batch calculation.

dynamic hierarchy  In aggregate storage database outlines only, a hierarchy in which members are calculated at retrieval time.

dynamic member list  A system-created named member set that is based on user-defined criteria. The list is refreshed automatically whenever it is referenced in the application. As dimension members are added and deleted, the list automatically reapplies the criteria to reflect the changes.

dynamic reference  A pointer in the rules file to header records in a data source.

dynamic report  A report containing data that is updated when you run the report.

Dynamic Time Series  A process that performs period-to-date reporting in block storage databases.

dynamic view account  An account type indicating that account values are calculated dynamically from the data that is displayed.

Eliminated Account  An account that does not appear in the consolidated file.

elimination  The process of zeroing out (eliminating) transactions between entities within an organization.

employee  A user responsible for, or associated with, specific business objects. Employees need not work for an organization; for example, they can be consultants. Employees must be associated with user accounts for authorization purposes.

encoding  A method for mapping bit combinations to characters for creating, storing, and displaying text. Each encoding has a name; for example, UTF-8. Within an encoding, each character maps to a specific bit combination; for example, in UTF-8, uppercase A maps to HEX41. See also code page and locale.

ending period  A period enabling you to adjust the date range in a chart. For example, an ending period of “month”, produces a chart showing information through the end of the current month.
Enterprise View  An Administration Services feature that enables management of the Essbase environment from a graphical tree view. From Enterprise View, you can operate directly on Essbase artifacts.

entity  A dimension representing organizational units. Examples: divisions, subsidiaries, plants, regions, products, or other financial reporting units.

Equity Beta  The riskiness of a stock, measured by the variance between its return and the market return, indicated by an index called “beta”. For example, if a stock’s return normally moves up or down 1.2% when the market moves up or down 1%, the stock has a beta of 1.2.

essbase.cfg  An optional configuration file for Essbase. Administrators may edit this file to customize Essbase Server functionality. Some configuration settings may also be used with Essbase clients to override Essbase Server settings.

EssCell  A function entered into an Essbase Spreadsheet Add-in to retrieve a value representing an intersection of specific Essbase database members.

ESSCMD  A command-line interface for performing Essbase operations interactively or through batch script files.

ESSLANG  The Essbase environment variable that defines the encoding used to interpret text characters. See also encoding.

ESSMSH  See MaxL Shell.

exceptions  Values that satisfy predefined conditions. You can define formatting indicators or notify subscribing users when exceptions are generated.

exchange rate  A numeric value for converting one currency to another. For example, to convert 1 USD into EUR, the exchange rate of 0.8936 is multiplied with the U.S. dollar. The European euro equivalent of $1 is 0.8936.

exchange rate type  An identifier for an exchange rate. Different rate types are used because there may be multiple rates for a period and year. Users traditionally define rates at period end for the average rate of the period and for the end of the period. Additional rate types are historical rates, budget rates, forecast rates, and so on. A rate type applies to one point in time.

expense account  An account that stores periodic and year-to-date values that decrease net worth if they are positive.

Extensible Markup Language (XML)  A language comprising a set of tags used to assign attributes to data that can be interpreted between applications according to a schema.

external authentication  Logging on to Oracle’s Hyperion applications with user information stored outside the applications, typically in a corporate directory such as MSAD or NTLM.

externally triggered events  Non-time-based events for scheduling job runs.

Extract, Transform, and Load (ETL)  Data source-specific programs for extracting data and migrating it to applications.

extraction command  An Essbase reporting command that handles the selection, orientation, grouping, and ordering of raw data extracted from a database; begins with the less than (<) character.

fact table  The central table in a star join schema, characterized by a foreign key and elements drawn from a dimension table. This table typically contains numeric data that can be related to all other tables in the schema.

field  An item in a data source file to be loaded into an Essbase database.

file delimiter  Characters, such as commas or tabs, that separate fields in a data source.

filter  A constraint on data sets that restricts values to specific criteria; for example, to exclude certain tables, metadata, or values, or to control access.

flow account  An unsigned account that stores periodic and year-to-date values.

folder  A file containing other files for the purpose of structuring a hierarchy.

footer  Text or images at the bottom of report pages, containing dynamic functions or static text such as page numbers, dates, logos, titles or file names, and author names.

format  Visual characteristics of documents or report objects.
A combination of operators, functions, dimension and member names, and numeric constants calculating database members.

An area on the desktop. There are two main areas: the navigation and workspace frames.

An object for presenting, entering, and integrating data from different sources for dynamic calculations.

Creating reports by entering dimension members or report script commands in worksheets.

A routine that returns values or database members.

A layer in a hierarchical tree structure that defines member relationships in a database. Generations are ordered incrementally from the top member of the dimension (generation 1) down to the child members.

A unique name that describes a generation.

Non-SQR Production Reporting or non-Interactive Reporting jobs.

A command in a running report script that is effective until replaced by another global command or the file ends.

A means for specifying dimension members on a grid without placing dimensions in rows, columns, or page intersections. A report designer can set POV values at the grid level, preventing user POVs from affecting the grid. If a dimension has one grid value, you put the dimension into the grid POV instead of the row, column, or page.

A container for assigning similar access permissions to multiple users.

Graphical user interface

Depending on your configuration, chart cells or ZoomChart details may be highlighted, indicating value status: red (bad), yellow (warning), or green (good).

An average for an account over a number of historical periods.

An entity that is part of a legal entity group, with direct or indirect investments in all entities in the group.

A server on which applications and services are installed.

Properties pertaining to a host, or if the host has multiple Install_Homes, to an Install_Home. The host properties are configured from the LSC.

An analysis mapping low-level data stored in a relational database to summary-level data stored in Essbase, combining the mass scalability of relational systems with multidimensional data.

A link to a file, Web page, or an intranet HTML page.

A programming language specifying how Web browsers display data.

A unique identification for a user or group in external authentication.

Graphic links to Web pages or repository items.

Indicates changes in child entities consolidating into parent entities.

A member with one or more children, but only one is consolidated, so the parent and child share a value.

A group for which an administrator has deactivated system access.

A service suspended from operating.

Indicates entities deactivated from consolidation for the current period.

A user whose account has been deactivated by an administrator.

An account storing periodic and year-to-date values that, if positive, increase net worth.


A buffer containing index pages.
index entry A pointer to an intersection of sparse dimensions. Index entries point to data blocks on disk and use offsets to locate cells.

index file An Essbase file storing block storage data retrieval information, residing on disk, and containing index pages.

index page A subdivision in an index file. Contains pointers to data blocks.

input data Data loaded from a source rather than calculated.

Install_Home A variable for the directory where Oracle's Hyperion applications are installed. Refers to one instance of Oracle's Hyperion application when multiple applications are installed on the same computer.

integration Process that is run to move data between Oracle's Hyperion applications using Shared Services. Data integration definitions specify the data moving between a source application and a destination application, and enable the data movements to be grouped, ordered, and scheduled.

intelligent calculation A calculation method tracking updated data blocks since the last calculation.

Interactive Reporting connection file (.oce) Files encapsulating database connection information, including: the database API (ODBC, SQL*Net, etc.), database software, the database server network address, and database user name. Administrators create and publish Interactive Reporting connection files (.oce).

intercompany elimination See elimination.

intercompany matching The process of comparing balances for pairs of intercompany accounts within an application. Intercompany receivables are compared to intercompany payables for matches. Matching accounts are used to eliminate intercompany transactions from an organization's consolidated totals.

intercompany matching report A report that compares intercompany account balances and indicates if the accounts are in, or out, of balance.

interdimensional irrelevance A situation in which a dimension does not intersect with other dimensions. Because the data in the dimension cannot be accessed from the non-intersecting dimensions, the non-intersecting dimensions are not relevant to that dimension.

intersection A unit of data representing the intersection of dimensions in a multidimensional database; also, a worksheet cell.

Investigation See drill-through.

isolation level An Essbase Kernel setting that determines the lock and commit behavior of database operations. Choices are: committed access and uncommitted access.

iteration A “pass” of the budget or planning cycle in which the same version of data is revised and promoted.

Java Database Connectivity (JDBC) A client-server communication protocol used by Java based clients and relational databases. The JDBC interface provides a call-level API for SQL-based database access.

job output Files or reports produced from running a job.

job parameters Reusable, named job parameters that are accessible only to the user who created them.

jobs Documents with special properties that can be launched to generate output. A job can contain Interactive Reporting, SQR Production Reporting, or generic documents.

join A link between two relational database tables or topics based on common content in a column or row. A join typically occurs between identical or similar items within different tables or topics. For example, a record in the Customer table is joined to a record in the Orders table because the Customer ID value is the same in each table.

journal entry (JE) A set of debit/credit adjustments to account balances for a scenario and period.

JSP Java Server Pages.

latest A Spreadsheet key word used to extract data values from the member defined as the latest time period.

layer (1) The horizontal location of members in a hierarchical structure, specified by generation (top down) or level (bottom up). (2) Position of objects relative to other objects. For example, in the Sample Basic database, Qtr1 and Qtr4 are in the same layer, so they are also in the same generation, but in a database with a ragged hierarchy, Qtr1 and Qtr4 might not be in same layer, though they are in the same generation.
**legend box**  A box containing labels that identify the data categories of a dimension.

**level**  A layer in a hierarchical tree structure that defines database member relationships. Levels are ordered from the bottom dimension member (level 0) up to the parent members.

**level 0 block**  A data block for combinations of sparse, level 0 members.

**level 0 member**  A member that has no children.

**liability account**  An account type that stores “point in time” balances of a company's liabilities. Examples of liability accounts include accrued expenses, accounts payable, and long term debt.

**life cycle management**  The process of managing application information from inception to retirement.

**line chart**  A chart that displays one to 50 data sets, each represented by a line. A line chart can display each line stacked on the preceding ones, as represented by an absolute value or a percent.

**line item detail**  The lowest level of detail in an account.

**link**  (1) A reference to a repository object. Links can reference folders, files, shortcuts, and other links. (2) In a task flow, the point where the activity in one stage ends and another begins.

**link condition**  A logical expression evaluated by the taskflow engine to determine the sequence of launching taskflow stages.

**linked data model**  Documents that are linked to a master copy in a repository.

**linked partition**  A shared partition that enables you to use a data cell to link two databases. When a user clicks a linked cell in a worksheet, Essbase opens a new sheet displaying the dimensions in the linked database. The user can then drill down those dimensions.

**linked reporting object (LRO)**  A cell-based link to an external file such as cell notes, URLs, or files with text, audio, video, or pictures. (Only cell notes are supported for Essbase LROs in Financial Reporting.)

**local currency**  An input currency type. When an input currency type is not specified, the local currency matches the entity’s base currency.

**local report object**  A report object that is not linked to a Financial Reporting report object in Explorer. Contrast with linked reporting object (LRO).

**local results**  A data model's query results. Results can be used in local joins by dragging them into the data model. Local results are displayed in the catalog when requested.

**locale**  A computer setting that specifies a location's language, currency and date formatting, data sort order, and the character set encoding used on the computer. Essbase uses only the encoding portion. See also encoding and ESSLANG.

**locale header record**  A text record at the beginning of some non-Unicode-encoded text files, such as scripts, that identifies the encoding locale.

**location alias**  A descriptor that identifies a data source. The location alias specifies a server, application, database, user name, and password. Location aliases are set by DBAs at the database level using Administration Services Console, ESSCMD, or the API.

**locked**  A user-invoked process that prevents users and processes from modifying data.

**locked data model**  Data models that cannot be modified by a user.

**LOCKED status**  A consolidation status indicating that an entity contains data that cannot be modified.

**Log Analyzer**  An Administration Services feature that enables filtering, searching, and analysis of Essbase logs.

**LRO**  See linked reporting object (LRO).

**LSC services**  Services configured with the Local Service Configurator. They include Global Services Manager (GSM), Local Services Manager (LSM), Session Manager, Authentication Service, Authorization Service, Publisher Service, and sometimes, Data Access Service (DAS) and Interactive Reporting Service.

**managed server**  An application server process running in its own Java Virtual Machine (JVM).
**manual stage**  A stage that requires human intervention to complete.

**Map File**  Used to store the definition for sending data to or retrieving data from an external database. Map files have different extensions (.mps to send data; .mpr to retrieve data).

**Map Navigator**  A feature that displays your current position on a Strategy, Accountability, or Cause and Effect map, indicated by a red outline.

**Marginal Tax Rate**  Used to calculate the after-tax cost of debt. Represents the tax rate applied to the last earned income dollar (the rate from the highest tax bracket into which income falls) and includes federal, state and local taxes. Based on current level of taxable income and tax bracket, you can predict marginal tax rate.

**Market Risk Premium**  The additional rate of return paid over the risk-free rate to persuade investors to hold “riskier” investments than government securities. Calculated by subtracting the risk-free rate from the expected market return. These figures should closely model future market conditions.

**master data model**  An independent data model that is referenced as a source by multiple queries. When used, “Locked Data Model” is displayed in the Query section’s Content pane; the data model is linked to the master data model displayed in the Data Model section, which an administrator may hide.

**mathematical operator**  A symbol that defines how data is calculated in formulas and outlines. Can be any of the standard mathematical or Boolean operators; for example, +, -, *, /, and %.

**MaxL**  The multidimensional database access language for Essbase, consisting of a data definition language (MaxL DDL) and a data manipulation language (MaxL DML). See also MaxL DDL, MaxL DML, and MaxL Shell.

**MaxL DDL**  Data definition language used by Essbase for batch or interactive system-administration tasks.

**MaxL DML**  Data manipulation language used in Essbase for data query and extraction.
merge A data load option that clears values only from the accounts specified in the data load file and replaces them with values in the data load file.

metadata A set of data that defines and describes the properties and attributes of the data stored in a database or used by an application. Examples of metadata are dimension names, member names, properties, time periods, and security.

metadata sampling The process of retrieving a sample of members in a dimension in a drill-down operation.

metadata security Security set at the member level to restrict users from accessing certain outline members.

metaoutline In Essbase Integration Services, a template containing the structure and rules for creating an Essbase outline from an OLAP model.

metric A numeric measurement computed from business data to help assess business performance and analyze company trends.

migration audit report A report generated from the migration log that provides tracking information for an application migration.

migration definition file (.mdf) A file that contains migration parameters for an application migration, enabling batch script processing.

migration log A log file that captures all application migration actions and messages.

migration snapshot A snapshot of an application migration that is captured in the migration log.

MIME Type (Multipurpose Internet Mail Extension) An attribute that describes the data format of an item, so that the system knows which application should open the object. A file's mime type is determined by the file extension or HTTP header. Plug-ins tell browsers what mime types they support and what file extensions correspond to each mime type.

mining attribute In data mining, a class of values used as a factor in analysis of a set of data.

minireport A report component that includes layout, content, hyperlinks, and the query or queries to load the report. Each report can include one or more minireports.

missing data (#MISSING) A marker indicating that data in the labeled location does not exist, contains no value, or was never entered or loaded. For example, missing data exists when an account contains data for a previous or future period but not for the current period.

model (1) In data mining, a collection of an algorithm's findings about examined data. A model can be applied against a wider data set to generate useful information about that data. (2) A file or content string containing an application-specific representation of data. Models are the basic data managed by Shared Services, of two major types: dimensional and non-dimensional application objects. (3) In Business Modeling, a network of boxes connected to represent and calculate the operational and financial flow through the area being examined.

monetary A money-related value.

multidimensional database A method of organizing, storing, and referencing data through three or more dimensions. An individual value is the intersection point for a set of dimensions.

named set In MaxL DML, a set with its logic defined in the optional WITH section of a MaxL DML query. The named set can be referenced multiple times in the query.

native authentication The process of authenticating a user name and password from within the server or application.

nested column headings A report column heading format that displays data from multiple dimensions. For example, a column heading that contains Year and Scenario members is a nested column. The nested column heading shows Q1 (from the Year dimension) in the top line of the heading, qualified by Actual and Budget (from the Scenario dimension) in the bottom line of the heading.

NO DATA status A consolidation status indicating that this entity contains no data for the specified period and account.

non-dimensional model A Shared Services model type that includes application objects such as security files, member lists, calculation scripts, and Web forms.

non-unique member name See duplicate member name.

note Additional information associated with a box, measure, scorecard or map element.
null value A value that is absent of data. Null values are not equal to zero.

numeric attribute range A feature used to associate a base dimension member that has a discrete numeric value with an attribute that represents a value range. For example, to classify customers by age, an Age Group attribute dimension can contain members for the following age ranges: 0-20, 21-40, 41-60, and 61-80. Each Customer dimension member can be associated with an Age Group range. Data can be retrieved based on the age ranges rather than on individual age values.

ODBC Open Database Connectivity. A database access method used from any application regardless of how the database management system (DBMS) processes the information.

OK status A consolidation status indicating that an entity has already been consolidated, and that data has not changed below it in the organization structure.

OLAP Metadata Catalog In Essbase Integration Services, a relational database containing metadata describing the nature, source, location, and type of data that is pulled from the relational data source.

OLAP model In Essbase Integration Services, a logical model (star schema) that is created from tables and columns in a relational database. The OLAP model is then used to generate the structure of a multidimensional database.

online analytical processing (OLAP) A multidimensional, multiuser, client-server computing environment for users who analyze consolidated enterprise data in real time. OLAP systems feature drill-down, data pivoting, complex calculations, trend analysis, and modeling.

Open Database Connectivity (ODBC) Standardized application programming interface (API) technology that allows applications to access multiple third-party databases.

organization An entity hierarchy that defines each entity and their relationship to others in the hierarchy.

origin The intersection of two axes.

outline The database structure of a multidimensional database, including all dimensions, members, tags, types, consolidations, and mathematical relationships. Data is stored in the database according to the structure defined in the outline.

outline synchronization For partitioned databases, the process of propagating outline changes from one database to another database.

P&L accounts (P&L) Profit and loss accounts. Refers to a typical grouping of expense and income accounts that comprise a company’s income statement.

page A display of information in a grid or table often represented by the Z-axis. A page can contain data from one field, derived data from a calculation, or text.

page file Essbase data file.

page heading A report heading type that lists members represented on the current page of the report. All data values on the page have the members in the page heading as a common attribute.

page member A member that determines the page axis.

palette A JASC compliant file with a .PAL extension. Each palette contains 16 colors that complement each other and can be used to set the dashboard color elements.

parallel calculation A calculation option. Essbase divides a calculation into tasks and calculates some tasks simultaneously.

parallel data load In Essbase, the concurrent execution of data load stages by multiple process threads.

parallel export The ability to export Essbase data to multiple files. This may be faster than exporting to a single file, and it may resolve problems caused by a single data file becoming too large for the operating system to handle.

parent adjustments The journal entries that are posted to a child in relation to its parent.

parents The entities that contain one or more dependent entities that report directly to them. Because parents are both entities and associated with at least one node, they have entity, node, and parent information associated with them.

partition area A subcube within a database. A partition is composed of one or more areas of cells from a portion of the database. For replicated and transparent partitions, the number of cells within an area must be the same for the data source and target to ensure that the two partitions have the same shape. If the data source area contains 18 cells, the data target area must also contain 18 cells to accommodate the number of values.
partitioning  The process of defining areas of data that are shared or linked between data models. Partitioning can affect the performance and scalability of Essbase applications.

pattern matching  The ability to match a value with any or all characters of an item entered as a criterion. Missing characters may be represented by wild card values such as a question mark (?) or an asterisk (*). For example, “Find all instances of apple” returns apple, but “Find all instances of apple*” returns apple, applesauce, applecranberry, and so on.

percent consolidation  The portion of a child’s values that is consolidated to its parent.

percent control  Identifies the extent to which an entity is controlled within the context of its group.

percent ownership  Identifies the extent to which an entity is owned by its parent.

performance indicator  An image file used to represent measure and scorecard performance based on a range you specify; also called a status symbol. You can use the default performance indicators or create an unlimited number of your own.

periodic value method (PVA)  A process of currency conversion that applies the periodic exchange rate values over time to derive converted results.

permission  A level of access granted to users and groups for managing data or other users and groups.

perspective  A category used to group measures on a scorecard or strategic objectives within an application. A perspective can represent a key stakeholder (such as a customer, employee, or shareholder/financial) or a key competency area (such as time, cost, or quality).

pie chart  A chart that shows one data set segmented in a pie formation.

pinboard  One of the three data object display types. Pinboards are graphics, composed of backgrounds and interactive icons called pins. Pinboards require traffic lighting definitions.

pins  Interactive icons placed on graphic reports called pinboards. Pins are dynamic. They can change images and traffic lighting color based on the underlying data values and analysis tools criteria.

pivot  The ability to alter the perspective of retrieved data. When Essbase first retrieves a dimension, it expands data into rows. You can then pivot or rearrange the data to obtain a different viewpoint.

planner  Planners, who comprise the majority of users, can input and submit data, use reports that others create, execute business rules, use task lists, enable e-mail notification for themselves, and use Smart View.

planning unit  A data slice at the intersection of a scenario, version, and entity; the basic unit for preparing, reviewing, annotating, and approving plan data.

plot area  The area bounded by X, Y, and Z axes; for pie charts, the rectangular area surrounding the pie.

plug account  An account in which the system stores any out of balance differences between intercompany account pairs during the elimination process.

POV (point of view)  A feature for working with dimension members not assigned to row, column, or page axes. For example, you could assign the Currency dimension to the POV and select the Euro member. Selecting this POV in data forms displays data in Euro values.

precalculation  Calculating the database prior to user retrieval.

precision  Number of decimal places displayed in numbers.

predefined drill paths  Paths used to drill to the next level of detail, as defined in the data model.
**presentation**  A playlist of Web Analysis documents, enabling reports to be grouped, organized, ordered, distributed, and reviewed. Includes pointers referencing reports in the repository.

**preserve formulas**  User-created formulas kept within a worksheet while retrieving data.

**primary measure**  A high-priority measure important to your company and business needs. Displayed in the Contents frame.

**product**  In Shared Services, an application type, such as Planning or Performance Scorecard.

**Production Reporting**  See SQR Production Reporting.

**project**  An instance of Oracle’s Hyperion products grouped together in an implementation. For example, a Planning project may consist of a Planning application, an Essbase cube, and a Financial Reporting Server instance.

**promote**  The action to move a data unit to the next review level, allowing a user having the appropriate access to review the data. For example, an analyst may promote the data unit to the next level for his supervisor’s review.

**promotion**  The process of transferring artifacts from one environment or machine to another; for example, from a testing environment to a production environment.

**property**  A characteristic of an artifact, such as size, type, or processing instructions.

**provisioning**  The process of granting users and groups specific access permissions to resources.

**proxy server**  A server acting as an intermediary between workstation users and the Internet to ensure security.

**public job parameters**  Reusable, named job parameters created by administrators and accessible to users with requisite access privileges.

**public recurring time events**  Reusable time events created by administrators and accessible through the access control system.

**PVA**  See periodic value method (PVA).

**qualified name**  A member name in a qualified format that differentiates duplicate member names in a duplicate member outline. For example, [Market].[East].[State].[New York] or [Market].[East].[City].[New York]

**query**  Information requests from data providers. For example, used to access relational data sources.

**query governor**  An Essbase Integration Server parameter or Essbase Server configuration setting that controls the duration and size of queries made to data sources.

**range**  A set of values including upper and lower limits, and values falling between limits. Can contain numbers, amounts, or dates.

**reconfigure URL**  URL used to reload servlet configuration settings dynamically when users are already logged on to the Workspace.

**record**  In a database, a group of fields making up one complete entry. For example, a customer record may contain fields for name, address, telephone number, and sales data.

**recurring template**  A journal template for making identical adjustments in every period.

**recurring time event**  An event specifying a starting point and the frequency for running a job.

**redundant data**  Duplicate data blocks that Essbase retains during transactions until Essbase commits updated blocks.

**regular journal**  A feature for entering one-time adjustments for a period. Can be balanced, balanced by entity, or unbalanced.

**Related Accounts**  The account structure groups all main and related accounts under the same main account number. The main account is distinguished from related accounts by the first suffix of the account number.

**relational database**  A type of database that stores data in related two-dimensional tables. Contrast with multidimensional database.

**replace**  A data load option that clears existing values from all accounts for periods specified in the data load file, and loads values from the data load file. If an account is not specified in the load file, its values for the specified periods are cleared.

**replicated partition**  A portion of a database, defined through Partition Manager, used to propagate an update to data mastered at one site to a copy of data stored at another site. Users can access the data as though it were part of their local database.
**Report Extractor**  An Essbase component that retrieves report data from the Essbase database when report scripts are run.

**report object**  In report designs, a basic element with properties defining behavior or appearance, such as text boxes, grids, images, and charts.

**report script**  A text file containing Essbase Report Writer commands that generate one or more production reports.

**Report Viewer**  An Essbase component that displays complete reports after report scripts are run.

**reporting currency**  The currency used to prepare financial statements, and converted from local currencies to reporting currencies.

**repository**  Stores metadata, formatting, and annotation information for views and queries.

**resources**  Objects or services managed by the system, such as roles, users, groups, files, and jobs.

**restore**  An operation to reload data and structural information after a database has been damaged or destroyed, typically performed after shutting down and restarting the database.

**restructure**  An operation to regenerate or rebuild the database index and, in some cases, data files.

**result frequency**  The algorithm used to create a set of dates to collect and display results.

**review level**  A Process Management review status indicator representing the process unit level, such as Not Started, First Pass, Submitted, Approved, and Published.

**Risk Free Rate**  The rate of return expected from “safer” investments such as long-term U.S. government securities.

**role**  The means by which access permissions are granted to users and groups for resources.

**roll-up**  See consolidation.

**root member**  The highest member in a dimension branch.

**row heading**  A report heading that lists members down a report page. The members are listed under their respective row names.

**RSC services**  Services that are configured with Remote Service Configurator, including Repository Service, Service Broker, Name Service, Event Service, and Job Service.

**rules**  User-defined formulas.

**runtime prompt**  A variable that users enter or select before a business rule is run.

**sampling**  The process of selecting a representative portion of an entity to determine the entity’s characteristics. See also metadata sampling.

**saved assumptions**  User-defined Planning assumptions that drive key business calculations (for example, the cost per square foot of office floor space).

**scale**  The range of values on the Y axis of a chart.

**scaling**  Scaling determines the display of values in whole numbers, tens, hundreds, thousands, millions, and so on.

**scenario**  A dimension for classifying data (for example, Actuals, Budget, Forecast1, and Forecast2).

**schedule**  Specify the job that you want to run and the time and job parameter list for running the job.

**scope**  The area of data encompassed by any Essbase operation or setting; for example, the area of data affected by a security setting. Most commonly, scope refers to three levels of granularity, where higher levels encompass lower levels. From highest to lowest, these levels are as follows: the entire system (Essbase Server), applications on Essbase Server, or databases within Essbase Server applications. See also persistence.

**score**  The level at which targets are achieved, usually expressed as a percentage of the target.

**scorecard**  Business Object that represents the progress of an employee, strategy element, or accountability element toward goals. Scorecards ascertain this progress based on data collected for each measure and child scorecard added to the scorecard.

**scorecard report**  A report that presents the results and detailed information about scorecards attached to employees, strategy elements, and accountability elements.
secondary measure  A low-priority measure, less important than primary measures. Secondary measures do not have Performance reports but can be used on scorecards and to create dimension measure templates.

Section pane  Lists all sections that are available in the current Interactive Reporting Client document.

security agent  A Web access management provider (for example, Netegrity SiteMinder) that protects corporate Web resources.

security platform  A framework enabling Oracle’s Hyperion applications to use external authentication and single sign-on.

serial calculation  The default calculation setting Essbase divides a calculation pass into tasks and calculates one task at a time.

services  Resources that enable business items to be retrieved, changed, added, or deleted. Examples: Authorization and Authentication.

servlet  A piece of compiled code executable by a Web server.

Servlet Configurator  A utility for configuring all locally installed servlets.

session  The time between login and logout for a user connected to Essbase Server.

set  In MaxL DML, a required syntax convention for referring to a collection of one or more tuples. For example, in the following MaxL DML query, SELECT { [100-10] } ON COLUMNS FROM Sample.Basic { [100-10] } is a set.

shared member  A member that shares storage space with another member of the same name, preventing duplicate calculation of members that occur multiple times in an Essbase outline.

Shared Services  Application enabling users to share data between supported Oracle’s Hyperion products by publishing data to Shared Services and running data integrations.

sibling  A child member at the same generation as another child member and having the same immediate parent. For example, the members Florida and New York are children of East and each other’s siblings.

single sign-on  Ability to access multiple Oracle’s Hyperion products after a single login using external credentials.

slicer  In MaxL DML, the section at the end of a query that begins with and includes the keyword WHERE.

smart tags  Keywords in Microsoft Office applications that are associated with predefined actions available from the Smart Tag menu. In Oracle’s Hyperion applications, smart tags can also be used to import Reporting and Analysis content, and access Financial Management and Essbase functions.

SmartCut  A link to a repository item, in URL form.

snapshot  Read-only data from a specific time.

source currency  The currency from which values originate and are converted through exchange rates to the destination currency.

sparse dimension  In block storage databases, a dimension unlikely to contain data for all member combinations when compared to other dimensions. For example, not all customers have data for all products.

SPF files  Printer-independent files created by a SQR Production Reporting server, containing a representation of the actual formatted report output, including fonts, spacing, headers, footers, and so on.

Spotlighter  A tool that enables color coding based on selected conditions.

SQL spreadsheet  A data object that displays the result set of a SQL query.

SQR Production Reporting  A specialized programming language for data access, data manipulation, and creating SQR Production Reporting documents.

stacked charts  A chart where the categories are viewed on top of one another for visual comparison. This type of chart is useful for subcategorizing within the current category. Stacking can be used from the Y and Z axis in all chart types except pie and line. When stacking charts the Z axis is used as the Fact/Values axis.

stage  A task description that forms one logical step within a taskflow, usually performed by an individual. A stage can be manual or automated.
stage action  For automated stages, the invoked action that executes the stage.

standard dimension  A dimension that is not an attribute dimension.

standard journal template  A journal function used to post adjustments that have common adjustment information for each period. For example, you can create a standard template that contains the common account IDs, entity IDs, or amounts, then use the template as the basis for many regular journals.

Standard Template  The Standard template is the basis for the basic Strategic Finance file. The Standard template contains all default settings. All new files are created from the Standard template unless another template is selected.

Start in Play  The quickest method for creating a Web Analysis document. The Start in Play process requires you to specify a database connection, then assumes the use of a spreadsheet data object. Start in Play uses the highest aggregate members of the time and measures dimensions to automatically populate the rows and columns axes of the spreadsheet.

Status bar  The status bar at the bottom of the screen displays helpful information about commands, accounts, and the current status of your data file.

stored hierarchy  In aggregate storage databases outlines only. A hierarchy in which the members are aggregated according to the outline structure. Stored hierarchy members have certain restrictions, for example, they cannot contain formulas.

strategic objective (SO)  A long-term goal defined by measurable results. Each strategic objective is associated with one perspective in the application, has one parent, the entity, and is a parent to critical success factors or other strategic objectives.

Strategy map  Represents how the organization implements high-level mission and vision statements into lower-level, constituent strategic goals and objectives.

structure view  Displays a topic as a simple list of component data items.

Structured Query Language  A language used to process instructions to relational databases.

Subaccount Numbering  A system for numbering subaccounts using non-sequential, whole numbers.

subscribe  Flags an item or folder to receive automatic notification whenever the item or folder is updated.

Summary chart  In the Investigates Section, rolls up detail charts shown below in the same column, plotting metrics at the summary level at the top of each chart column.

super service  A special service used by the startCommonServices script to start the RSC services.

supervisor  A user with full access to all applications, databases, related files, and security mechanisms for a server.

supporting detail  Calculations and assumptions from which the values of cells are derived.

suppress rows  Excludes rows containing missing values, and underscores characters from spreadsheet reports.

symmetric multiprocessing (SMP)  A server architecture that enables multiprocessing and multithreading. Performance is not significantly degraded when a large number of users connect to a single instance simultaneously.

sync  Synchronizes Shared Services and application models.

synchronized  The condition that exists when the latest version of a model resides in both the application and in Shared Services. See also model.

system extract  Transfers data from an application’s metadata into an ASCII file.

tabs  Navigable views of accounts and reports in Strategic Finance.

target  Expected results of a measure for a specified period of time (day, quarter, etc.)

task list  A detailed status list of tasks for a particular user.

taskflow  The automation of a business process in which tasks are passed from one taskflow participant to another according to procedural rules.
**taskflow definition**  Represents business processes in the taskflow management system. Consists of a network of stages and their relationships; criteria indicating the start and end of the taskflow; and information about individual stages, such as participants, associated applications, associated activities, and so on.

**taskflow instance**  Represents a single instance of a taskflow including its state and associated data.

**taskflow management system**  Defines, creates, and manages the execution of a taskflow including: definitions, user or application interactions, and application executables.

**taskflow participant**  The resource who performs the task associated with the taskflow stage instance for both manual and automated stages.

**Taxes - Initial Balances**  Strategic Finance assumes that the Initial Loss Balance, Initial Gain Balance and the Initial Balance of Taxes Paid entries have taken place in the period before the first Strategic Finance time period.


**template**  A predefined format designed to retrieve particular data consistently.

**time dimension**  Defines the time period that the data represents, such as fiscal or calendar periods.

**time events**  Triggers for execution of jobs.

**time scale**  Displays metrics by a specific period in time, such as monthly or quarterly.

**time series reporting**  A process for reporting data based on a calendar date (for example, year, quarter, month, or week).

**Title bar**  Displays the Strategic Finance name, the file name, and the scenario name Version box.

**token**  An encrypted identification of one valid user or group on an external authentication system.

**top and side labels**  Column and row headings on the top and sides of a Pivot report.

**top-level member**  A dimension member at the top of the tree in a dimension outline hierarchy, or the first member of the dimension in sort order if there is no hierarchical relationship among dimension members. The top-level member name is generally the same as the dimension name if a hierarchical relationship exists.

**trace level**  Defines the level of detail captured in the log file.

**traffic lighting**  Color-coding of report cells, or pins based on a comparison of two dimension members, or on fixed limits.

**transformation**  (1) Transforms artifacts so that they function properly in the destination environment after application migration. (2) In data mining, modifies data (bidirectionally) flowing between the cells in the cube and the algorithm.

**translation**  See currency conversion.

**Transmission Control Protocol/Internet Protocol (TCP/IP)**  A standard set of communication protocols linking computers with different operating systems and internal architectures. TCP/IP utilities are used to exchange files, send mail, and store data to various computers that are connected to local and wide area networks.

**transparent login**  Logs in authenticated users without launching the login screen.

**transparent partition**  A shared partition that enables users to access and change data in a remote database as though it is part of a local database.

**triangulation**  A means of converting balances from one currency to another via a third common currency. In Europe, this is the euro for member countries. For example, to convert from French franc to Italian lira, the common currency is defined as European euro. Therefore, in order to convert balances from French franc to Italian lira, balances are converted from French franc to European euro and from European euro to Italian lira.

**triggers**  An Essbase feature whereby data is monitored according to user-specified criteria which when met cause Essbase to alert the user or system administrator.

**trusted password**  A password that enables users authenticated for one product to access other products without reentering their passwords.
trusted user  Authenticated user

tuple  MDX syntax element that references a cell as an intersection of a member from each dimension. If a dimension is omitted, its top member is implied. Examples: (Jan); (Jan, Sales); (Jan, Sales, [Cola], [Texas], [Actual])

two-pass  An Essbase property that is used to recalculate members that are dependent on the calculated values of other members. Two-pass members are calculated during a second pass through the outline.

unary operator  A mathematical indicator (+, -, *, /, %) associated with an outline member. The unary operator defines how the member is calculated during a database roll-up.

Unicode-mode application  An Essbase application wherein character text is encoded in UTF-8, enabling users with computers set up for different languages to share application data.

unique member name  A non-shared member name that exists only once in a database outline.

unique member outline  A database outline that is not enabled for duplicate member names.

upper-level block  A type of data block wherein at least one of the sparse members is a parent-level member.

user directory  A centralized location for user and group information. Also known as a repository or provider.

user variable  Dynamically renders data forms based on a user’s member selection, displaying only the specified entity. For example, user variable named Department displays specific departments and employees.

user-defined attribute (UDA)  User-defined attribute, associated with members of an outline to describe a characteristic of the members. Users can use UDAs to return lists of members that have the specified UDA associated with them.

user-defined member list  A named, static set of members within a dimension defined by the user.

validation  A process of checking a business rule, report script, or partition definition against the outline to make sure that the object being checked is valid.

value dimension  Used to define input value, translated value, and consolidation detail.

variance  Difference between two values (for example, planned and actual value).

version  Possible outcome used within the context of a scenario of data. For example, Budget - Best Case and Budget - Worst Case where Budget is scenario and Best Case and Worst Case are versions.

view  Representation of either a year-to-date or periodic display of data.

visual cue  A formatted style, such as a font or a color, that highlights specific types of data values. Data values may be dimension members; parent, child, or shared members; dynamic calculations; members containing a formula; read only data cells; read and write data cells; or linked objects.

Web server  Software or hardware hosting intranet or Internet Web pages or Web applications.

weight  Value assigned to an item on a scorecard that indicates the relative importance of that item in the calculation of the overall scorecard score. The weighting of all items on a scorecard accumulates to 100%. For example, to recognize the importance of developing new features for a product, the measure for New Features Coded on a developer’s scorecard would be assigned a higher weighting than a measure for Number of Minor Defect Fixes.

wild card  Character that represents any single character (?) or group of characters (*) in a search string.

WITH section  In MaxL DML, an optional section of the query used for creating re-usable logic to define sets or members. Sets or custom members can be defined once in the WITH section, and then referenced multiple times during a query.

workbook  An entire spreadsheet file with many worksheets.

write-back  The ability for a retrieval client, such as a spreadsheet, to update a database value.

ws.conf  A configuration file for Windows platforms.

wsconf_platform  A configuration file for UNIX platforms.

XML  See Extensible Markup Language (XML).
Y axis scale  Range of values on Y axis of charts displayed in Investigate Section. For example, use a unique Y axis scale for each chart, the same Y axis scale for all Detail charts, or the same Y axis scale for all charts in the column. Often, using a common Y axis improves your ability to compare charts at a glance.

Zero Administration  Software tool that identifies version number of the most up-to-date plug-in on the server.

zoom  Sets the magnification of a report. For example, magnify a report to fit whole page, page width, or percentage of magnification based on 100%.

ZoomChart  Used to view detailed information by enlarging a chart. Enables you to see detailed numeric information on the metric that is displayed in the chart.
Symbols
&Interactive Reporting document (BQY)
working with, 201
=, 235
Interactive Reporting > Data Model, 213
\<, 235
\<=, 235
\<\>, 235
\>, 235
\>=, 235

A
access permissions
BQY documents, setting, 116
defined, 113
descriptions of, 115
setting, 113
accessing navigate items, 44
accessing relational data, 41
actions, multiple-cycle Interactive Reporting jobs, 413
active preference, user interface, 64, 66
active user preference, 66
adaptive states
BQY documents, 116
adding
Exceptions Dashboard to Personal Page, 142
exceptions to Exceptions Dashboard, 118
file content windows on Personal Pages, 136
image bookmarks, Hyperion Foundation items, 139
My Bookmarks, 139
Personal Page content, 135
schedules, 389
sections, 207
versions, 121
adding documents to favorites, 45
Adjusting Data Type, 219
Administer Module toolbar, buttons defined, 54
advanced member selection
defining subset member selections, 320, 323
Hyperion Financial Management, 365
overview, 315
searching for members, 318
Alert dialog, 201
alias, 297
table, 297
using, 297
alias tables
about, 67
setting, 68
aliases, displaying, 75
analysis tools
definitions
default, 338
disabling, 338
enabling, 338
ordering, 338
overview, 337
Restrict Data, 345
Retrieve Only Top/Bottom, 347
Sorting, 343
Traffic Lighting, 341
Analysis Tools Manager toolbar, 337
APIs, exceptions, 433
applets in parameter forms, 435
area charts, 251
Arithmetic Operator, 221
arranging dimensions in the layout, 313
artifacts
setting access permissions, 113
ASK parameters, 439
asymmetrical analysis, 338
attributes, 275
auto-delete
  - Browse web module, 118
  - output for Interactive Reporting jobs, 403
Automatic data type, 220, 240
autosizing columns, 231
Available area, 184
Average calculation, 351

B
background jobs
  - set, 403
bar charts, 246
bar-line charts, 254
basic elements of parameter forms. See parameter forms
basics
  - Browse, 86
basics, Personal Pages, 46
basics, Personal Pages, 46
Batch Editor toolbar, buttons defined, 52
batch jobs
  - defining, 390
  - defining data in selecting
    - POV members for a batch job, 392
details, 399
opening a batch, 195
POV, 392
retrieving output from, 398
scheduling, 195
specifying members for, 392
specifying output format and location, 195
viewing job details of, 399
batch output
  - retrieving, 398
  - specifying format and location, 398
batch POV
  - selecting members, 392
batch processing
  - overview, 390
batches
  - destination and output, 393
  - zipped output file, 398
batches of reports, printing, 168
batches, running books in, 180
BEGIN WITH, 235
BETWEEN, 235
BLOB data type, 220

BLOB Images, 217
Book Editor dialog box, 182
Book Editor toolbar
  - buttons defined, 52
bookmarks
  - creating, 138
  - defined, 50, 133
image
  - items, 139
  - items, 139
My, 50, 133
books
  - changing data source for, 99
  - creating, 181–183
  - importing, 180
  - opening, 180
  - printing, 180
  - renaming, 180
  - saving, 189
BQY, 201
  - document sections, embedding Personal Pages, 136
documents
  - setting access permissions on, 116
  - files, properties of, 119
  - section on a Personal Page, embedding a, 137, 138
break totals, in Results, 238
Broadcast Messages
  - as Personal Page element, 133
Broadcast Messages, Personal Page element, 49
Browse
  - basics of, 86
  - Content pane, 86
browsers
  - Dimension Browser, 314
Building Interactive Reporting > Queries, 215
buttons
  - replacing, 120
Byte data type, 220

calculations
  - Average, 351
  - creating, 356
  - Cumulative, 351
  - Difference from Average, 351
  - Divide, 351
Index

 Linear Regression, 351
 Maximum, 352
 Maximum Value, 352
 Minimum, 352
 Minimum Value, 352
 modifying, 357
 Multiply, 353
 overview, 350
 Percent, 353
 Percent Difference from Average, 353
 Percent of Difference, 353
 Percent of Member, 354
 Percent of Total, 354
 Rank Ascending, 354
 Rank Descending, 354
 Subtract, 354
 Sum, 354
 Trend, 355
 Variance, 355
 Variance Percent, 355
 calendar, selection, 405
 changing
   a page member, 168
 changing member
   grid POV, 174
 changing, colors on Personal Pages, 144
 chart dimensions, 241
 Chart section, 241
 chart types
   multi-dimensional, 249
 charts
   adding items, 255
   focusing and hiding items, 256
   removing items, 255
   types of, 244
 clustered bar charts, 249
 colors
   hiding by color, 338
 columns
   adding in Results section, 230
   autosizing, 231
   deleting in Results section, 231
   sorting, 232
 combination charts, 254
 Comparison Operator, 222
 conditional elements
   in parameter forms, 438
 parameter forms, 438
 connecting to data sources, Interactive Reporting
documents, 404
 CONTAINS, 235
 content
   adding or removing from Personal Pages, 135
   customizing Personal Page, 135
   displaying HTML on Personal Pages, 135
   publishing, 109
   viewing, 87
 Content pane, 86
 content windows
   defined, 132
   rearranging, 143
 Controlling the size of the query result set, 41
 coordinating selected dimensions, 372
 copying
   Personal Pages, 146
 creating
   bookmarks, 138
   calculations, 356
   collection, 90
   document, 90
   folders, 89
   Personal Pages, 144
   personal recurring time events, 383
   personal variables, 326
 Creating an Interactive Reporting document, 202
 creating documents, in Workspace, 41, 43
 Cube Navigator
   overview, 313
 CubeQuery
   Catalog, 275
 CubeQuery section
   alias, 297
   missing label, 298
 Cumulative calculation, 351
 cumulative totals, 263
 Custom Values, 235
 customizing
   Exceptions Dashboard, 142
   Personal Page content, 135
   user interface, 61
 cycle
   defined, 402
 cycles
   actions, defined, 402
limits, 402
user defined, 405

D
Dashboard Home, 199, 209
Dashboard, Exceptions, 140
data
  accessing relational, 41
Data Function, 224
data function
  pivot section, 264
data functions
  compared to computed items, 224
  in OLAP, 270
data labels in pivot tables, 259
data prompts
  defining for a batch of reports, 390
  responding to, 165
data source
  changing, 99
  elements, 34
  old database connections, 100
  overview, 34
  repository, 100
  SAP BW, 37
  selecting for a document, 44
data source, linking components by, 372
data values, hiding by, 338
database connection
  adding, 102
  deleting, 104
  editing, 103
  managing, 101
Interactive Reporting Database Connection Files (.oces), 213
database connections, Planning Details, 37
databases
  web analysis preferences, 66
Date data type, 220
date selections, 327
dedicated accounts, 432
default
  folders, 63
  permissions, 63
  settings, 61
default job output format, 405
default parameter forms, 436
default settings, snapshot, 165
deleting
  events, 384
  files, 91
  folders, 91
  job output, 432
  job parameters, 389
  Personal Pages, 146
  reports from books, 180
  schedules, 388
deleting sections, 209
descriptions, displaying, 75
detail, line item, 364
Difference from Average calculation, 351
Dimension Browser
  labels in, 315
  overview, 314
dimension members
  selecting with Dimension Browser, 314
Dimensions, 268
dimensions
  arranging in the layout, 313
  browsing, 314
  coordinating selected, 372
  moving, 330
  selecting with Cube Navigator, 313
  swapping, 330
  validating that data sources have the same, 99
dimensions and members, 272
displayed HTML files
  on additional Personal Pages, 136
  removing from Personal Pages, 136
displaying
  aliases, 75
  descriptions, 75
  HTML content on Personal Pages, 135
  HTML files on Personal Pages, 136
  secure job information, 433
  user POV, 75
Divide calculation, 351
Interactive Reporting document file (BQY)
  accessing, 204
  processing, 209
Interactive Reporting Document File
  saving, 204
Interactive Reporting document file, saving
Interactive Reporting document files (BQY)
  understanding, 201
documents, BQY, as Personal Page elements, 136
Downloading to Results in CubeQuey section, 287
drill anywhere, 266
drill down
  in OLAP, 269
  drill linking
    overview, 333
drill up
  in OLAP, 270
DrillDown, 267
drilling
  overview, 331
Drilling in CubeQuery section, 285
Dynamic Time Series definitions, 327
substitution variables, 327

E
e-mail
  default, 61
  linking, 92
  recipient list, 93
editing
  Restrict Data definitions, 346
  Retrieve Only Top-Bottom definitions, 348
elements
  parameter forms
    additional elements, 440
    parameter display elements, 439
    parameter list elements, 439
    required elements, 438–439
    types of, 438
  elements, rearranging Personal Page, 143
email notifications, high priority item search, 132
embedding BQY sections on Personal Pages, 137, 138
ENDS WITH, 235
EQUAL, 235
Essbase
  features extended through Hyperion Analyzer, 361
  substitution variables. See substitution variables.
events
  creating a new personal recurring time, 383
  defined, 377
  deleting, 384
modifying, 384
viewing, 384
exceptions
  supporting in generic report programs, 433
  supporting in Production Reporting code, 433
Exceptions Dashboard. See also exceptions
  [Exceptions Dashboard:1], 433. See also exceptions
  [Exceptions Dashboard:1]
  add to Personal Pages, 142
  customizing, 142
  described, 402, 433
  using, 140
Exit command, 57
explore
  preferences, 63
Explore Module toolbar
  buttons defined, 53
export
  exceptions, 96
  Financial Reports, 97
  Production Reporting to Excel, 98
  smart view options, 95
  snapshots, 97
  supported web applications, 96
  Web Analysis, 98
Export to PDF, 199
Export to XLS, 199
exporting
  items, 94
  Smart View, 95
Exporting Data, 210

F
familial relationships, 273
favorites
  adding documents, 45
  overview, 49
  removing documents, 45
Favorites Menu, commands defined, 58
features
  Essbase, 361
  Financial Management, 36
  Hyperion Financial Management, 364
file content windows
  adding to Personal Pages, 136
  removing from Personal Pages, 136
File Menu, commands defined, 56
file properties, 45
files
  deleting, 91
HTML, 109
HTML files as Personal Page elements, 133
options of OCE, 120
owner, 117
properties of BQY, 119
publishing multiple, 109, 110
registering, 93, 94
renaming, 90
searching, 91
security mode, 432
size, 117
filter job list, 386
filtering member selections, 282
  Browsing, 282
filters
  in Results section, 233
  deleting, 237
  modifying, 236
Financial Management
  features extended through Web Analysis, 36
  overview, 36
  studio features, 36
Financial Reporting
  changing the database connection, 99
  changing the related content server, 99
  managing database connections, 101
Financial Reporting preferences, studio, 71
Financial Reporting Studio
  database connections, 37
  overview, 35
Financial Reporting toolbar, buttons defined, 51
Firefox
  status bar, 27
flag exception, 123
folder tree, defined, 47
folders
  creating, 89
  deleting, 91
  moving, 90
Production Reporting preferences, 72
renaming, 90
repository, 85
searching, 90, 91
subscribing to, 131
footer sections, in Personal Pages, 143
formatting
  web analysis preferences, 66
G
generations and levels, 274
generic report programs, support for exceptions, 433
grand total
  in Results section, 238
GREATER OR EQUAL, 235
GREATER THAN, 235
grid POV, changing member, 174
grouping and ungrouping
  chart labels, 256
  in pivot tables, 261
guide, Quick Start, 33
H
header sections, in Personal Pages, 143
Help Menu defined, 58
Help menu, commands defined, 58
hexadecimal color code settings in Personal Pages, 144
hide artifact, when publishing, 118
hiding
  by color, 338
  by data value, 338
  by selected members, 338
high priority.. See priority
HTML
  default job output format, 405
  displaying content on Personal Pages, 135
HTML documents, output of batch jobs, 195
HTML files
  as Personal Page elements, 133
  publishing, 109
  removing from Personal Pages, 136
  security tags in, 431
Hyperion Financial Management
  advanced member selection, 365, 368
  conventions, 366
  features extended through Hyperion Analyzer, 364
  overview, 363
Hyperion System 9 BI+
  smart view export options, 95
icons
   High priority, 433
   modify properties, 433
image bookmark
   item, adding an, 139
   Personal Page elements, 133
image bookmark, Personal Page elements, 50
import
   Interactive Reporting, 96
INPUT parameters, parameter display elements, 439
installing
   smart view from Workspace, 97
Integer (16–bit) data type, 220
Integer (32–bit) data type, 220
Intelligence Client sections. See sections.
Intelligence iServer
   embedded sections, 137
Interactive Reporting
   import, 96
jobs
   action options for multiple-cycle, 413
   properties, 402
   setting job parameters for, 409
Interactive Reporting preferences, 72
Interactive Reporting Studio, overview, 35
Interactive Reporting toolbar, buttons defined, 52
intersections, paging through, 330
IS NULL, 235
item changes, subscribing to, 129
items
   adding, image bookmark, 139
   adding, My Bookmark, 139
   exporting, 94

JavaScript, in parameter forms, 435
job defaults, Interactive Reporting jobs, 405
job output properties, modifying, 382
job parameters
   defined, 377, 378
   deleting, 389
   modifying, 389
   OLAP queries, 411
   personal default, 379
   setting Interactive Reporting, 409
   setting SQR and generic, 383
when running a job, 379
job properties
   generic, 427
   Interactive Reporting, 402
   Production Reporting, 418
jobs
   action options for multiple-cycle Interactive Reporting, 413
   assigning forms to jobs, 436
   deleting output, 432
   filtering job list, 386
   notification options when scheduling, 381
   OLAP job parameters, 411
   output as Personal Page elements, 133
   properties of Interactive Reporting, 402
   running, 378
   scheduling, 380
   secure Production Reporting jobs, 431
   setting default job parameters, 379

K
   Keep Only in CubeQuery section, 284
keywords
   automatically generating, 119

L
   layout of a Personal Page, modifying the, 143
   layout styles, of Personal Pages, 143
   layouts
      arranging dimensions in, 313
      legends, 243
      LESS OR EQUAL, 235
      LESS THAN, 235
      LIKE, 235
      line charts, 252
      line item detail, 364
      Linear Regression calculation, 351
      linking
         applications, 91, 92
         components by data source, 372
         e-mail, 92
         selected dimensions, 373
      links, graphic, 50, 133
      lists
         versions of file, 123
locally saving Interactive Reporting document (BQY).
Logical Operators, 223
LongText, 220
looping elements
  parameter forms elements, 438

M
Maximum calculation, 352
Maximum Value calculation, 352
measures, 270
member lists
  previewing, 189
member prompts, 165
Member Selection, 278
  Browsing, 279
  searching, 281
member selection
  advanced. See advanced member selection.
  defining previous, 328
member selections
  changing for report, 183
  copying between reports, 181
members
  arranging, 75
  dimensions, 74
  previewing, 189
  prompting for in batch processing, 390
  selecting for batch jobs, 392
Microsoft Office
  importing Web Analysis documents, 98
MIME types
  defined, 118
  unknown, 107
Minimum calculation, 352
Minimum Value calculation, 352
missing columns, 297
missing label, 298
missing rows, 297
modifying
  calculations, 357
  events, 384
  job output properties, 382
  job parameters, 389
  layout of Personal Pages, 143
  properties of versions, viewing or, 122
  schedule, 388
monitored exceptions
  as Personal Page elements, 133
  moving between sections, 208
  moving files, 45
MS Excel, 211
multiple files, publishing, 109, 110
multiple-cycle Interactive Reporting jobs, action
  options for, 413
Multiply calculation, 353
My Bookmarks
  adding as Personal Page elements, 139
  defined, 50, 133

N
Native File Format, 212
navigating sections, 206
navigation
  methods, 329
NOT (with operator), 235
NOT EQUAL, 235
notifications
  deleting job, 385
  options for job, 381
  subscribe to items, 129
  viewing an item when you receive, 132
number formatting, 232

O
objects, security mode, 432
OCE files
  defined, 406
  options of, 120
OLAP job parameters, 411
OLAP section, 268
OLAP terminology, 268
open items, using, 48
OPEN statement (Production Reporting), 432
opening
  documents, 32, 44
  files, 32
  folders, 32
Operator, 220
operators, 235
options and properties, when publishing all artifacts,
  116
options, import, 96
output from jobs
  as Personal Page elements, 133
  deleting, 432
  permissions, 431
  security mode, 432
output properties, modifying job, 382

P
Packed Real data type, 220
page members
  changing, 168
  POV, 171
page orientation, 191
Page Setup options, 57
page setup, changing for books, 191
pages
  numbering in books, 191
Paging Icons, 200
paging through intersections, 330
paper size, 191
parameter forms
  additional elements, 440
  assigning default, 436
  assigning to jobs, 436
  basic, conditional, and looping elements, 438
  examples and tips, 444
  importing files, 439
  parameter display elements, 439
  parameter list elements, 439
  required elements, 438–439
  submit for processing code snippet, 439
  switching to default form, 436
  tags, 437
parameter lists
  parameter display elements, 439
  parameter forms elements, 439
parameters
  deleting job, 389
  modifying job, 389
  setting
    Interactive Reporting job, 409
    SQR and generic job, 383
pass-through
  Interactive Reporting jobs, 401
  Production Reporting and generic jobs, 420
  using multiple OCE files, 406
PDF, 210
PDF files, as batch output, 195
Percent calculation, 353
Percent Difference from Average calculation, 353
Percent of Difference calculation, 353
Percent of Member calculation, 354
Percent of Total calculation, 354
Performance Scorecard toolbar, buttons defined, 52
permissions
  default, 63
  permissions, setting access permissions, 113
Personal Pages
  adding a file content window on additional, 136
  adding Exceptions Dashboard, 142
  changing colors, 144
  content, adding or removing, 135
  content, customizing, 135
  creating, 144
  deleting, 146
  displaying HTML files, 136
  elements, rearranging, 143
  embedding BQY sections, 137, 138
  headers and footers, 143
  modifying the layout, 143
  publishing, 146
  removing file content window, 136
  restoring, 146
Personal Pages, basics of, 46
personal pages, overview, 49
personal recurring time events, creating, 383
personal variables
  creating, 326
personalizing
  view pane and content area, 76
  workspace, 76
pie charts
  described, 245
pins
  options for, 335
pivot dimension, 259
Pivot Facts, 262
Pivot Section
  paging, 265
Pivot section, 258
  adding, 259
  adding items, 259
  sorting by labels, 266
pivot tables
components, 259
deleting pivot items, 260
focusing and hiding items, 260
swing feature, 262
working with, 259
Planning Details ADM driver, 37
Point of View
overview, 70, 326
point of view (POV)
defining for batch jobs, 392
displaying members, 75
Financial Reporting, 73
hanging, 168
page member, 171
user POV for the web, 168
preferences
e Explore, 63
Financial Reporting, 71
general, 61
Interactive Reporting, 72
module, 65
Production Reporting, 72
web analysis, 66
prerequisites, SAP BW, 37
 previewing, selected members, 189
printing
 report books and snapshot books, 192
reports, 168
snapshot reports, 168
printing documents, 44
priority, set, 122
privileges, setting access, 113
process options, Interactive Reporting multiple-cycle jobs, 412
Production Reporting jobs
 OPEN statement, 432
 secure and nonsecure output from same job, 432
 secure jobs, 431
 permissions, 431–432
 recommendations, 432
 security mode, 432
 security tags in, 431
 viewing security information, 433
Production Reporting preferences
 folders, 72
Production Reporting programs
 exceptions support, 433
Production Reporting Studio, overview, 35
Production ReportingProgramObject output, 432
Prompts
defining, 194
prompts
defining in a batch of reports, 390
responding to when previewing, 170
properties
 BQY files, 119
generic job, 427
modifying job output, 382
Production Reporting job, 418
security mode, 432
versions, 122
versions, viewing or modifying, 122
Properties dialog box, 436, 437
publishing
about, 107
add to Exceptions Dashboard, 118
auto-delete, 118
content, 109
default job output format, 405
hide artifact, 118
HTML files, 109
jobs
 pass-through, Production Reporting, 420
multiple files, 109, 110
Personal Pages, 146
Q
queries
building OLAP queries with Cube Navigator, 313
defining with Cube Navigator, 313
Dynamic Time Series definitions for, 327
refreshing, 229
Query Options, 296
Quick Start Guide, 33
R
Ragged Hierarchies, 290
Rank Ascending calculation, 354
Rank Descending calculation, 354
Real data type, 220
recurring time events, creating new personal, 383
referential items
  in Chart and Pivot sections, 266
Refreshing a Query, 229
related content
  cell text, 364
  changing the related content server, 99
definitions, 337
  using, 171
relational data
  access, 369
relational data, access, 41
relational drill-through
  overview, 360
Remove Only in CubeQuery section, 284
removing
  embedded BQY sections, 138
  file content windows from Personal Pages, 136
  Personal Page contents, adding or, 135
  subscriptions, 131
removing documents to favorites, 45
removing Request items, 217
removing Request line items, 217
renaming
  files, 90
  folders, 90
renaming sections, 208
replacing
  BQY jobs and OCE files, 120
  buttons, 120
report books, printing, 192
report menu commands, 56
Report section, 299
reports
  adding to book, 182
  assigning to a batch, 390
  changing data source for, 99
  changing display types for, 334
  deleting from books, 182, 192
  drilling to detail, 331
  searching for, 166
  viewing, 166
repository
  folders, 85
  overview, 31
  shortcuts, 84
URLs, 84
  user preferences, 32
repository, changing the data source, 100
Request items, 216
required files
  for generic jobs, 420
  for Production Reporting jobs, 420
Restrict Data analysis tool, 345
  editing definitions, 346
Retrieve Only Top/Bottom analysis tool, 347
retrieving
  batch output, 398
  ribbon charts, 253
role, access permissions, 32
row-level security, 108
rows
  deleting in Results section, 231
running jobs, 378

S
SAP BW
  data source, 37
  InfoProviders, 38
  prerequisites, 37
SAP BW: variables, 38
SAP BW: attributes, 40
SAP BW: features, 37
SAP BW: security integration, 41
saving
  file, 89
  saving an Interactive Reporting document file, 205
saving Interactive Reporting document (BQY), 204
saving files locally, 212
schedule, using the, 47
scheduled batch
  status, 399
scheduler
  external, 399
Scheduler Module toolbar, buttons defined, 53
schedules
  adding, 389
  defined, 377
  deleting, 388
  modifying, 388
scheduling jobs
  general, 380
  searching, 282
files, 91
folders, 91
sections
  adding, 207
deleting, 209
  moving between, 208
renaming, 208
sections, BQY documents, as Personal Page elements, 136
Secure jobs, security tags, 118
Secure mode, 433
secure Production Reporting jobs. See Production Reporting
  security
  Production Reporting job recommendations, 432
  row-level, 108
  viewing security information, 433
security tags
  in secure Production Reporting programs, 432
Select Members dialog box
  Available area, 184
selected members, hiding by, 338
selecting
  dimension members, 314
  member items, 173
  member lists, 185
  member options, 173
  members, 185
  members for the User POV, 173
Selecting Dimension Members, 314
setting
  access permissions, 113
  alias tables, 68
setting file properties, 45
setting preferences, user interface, 33
Shared Members, 286, 291
shared members, 297
Shortcut Menus, 200
shortcuts
  repository, 84
Show Values, 234
show, latest version, 123
Show/Hide Only analysis tool
  creating definitions, 339
  editing definitions, 341
  overview, 338
Show/Hide Only dialog box, 339
Showing Negative and Positive Values, 246
Showing Pie Percent, 246
Smart View
  exporting, 95
smart view
  installing, 97
Smart View, usage with Microsoft Office, 48
SmartCuts
  defined and location, 118
snapshot books
  described, 176
  importing, 180
  opening, 190
  printing, 190, 192
  renaming, 190
  saving, 189
  viewing, 176
snapshot reports
  printing, 168
Snapshot, viewing, 165
snapshots
  printing, 171
  sorting and viewing, 175, 176
snapshots, exporting to Microsoft Office, 97
sorting
  charts and pivot tables, 266
  in OLAP, 269
  in Pivot and Chart sections, 265
  snapshots, 175, 176
Sorting analysis tool, 343
sorting by
  functions, 266
  labels, 266
  values, 266
special members, 185
SPF file format, 427
SPF files
  publishing as jobs, 431
  recommendations for security, 432
  secure Production Reporting jobs, 431
SPFFileOutputCollection object, 432
SQR and generic job parameters, setting, 383
SSL
  configuring for external authentication, 99
stacked area charts, 251
stacked bar charts, 250
Standard toolbar, 50, 198
start page
default, 61
setting, 61
starting tasks, 41
status bar
Firefox, 27
String data type, 220, 241
subscribing
about, 125
items, 129
subscriptions
removing, 131
substitution variables, 280
Dynamic Time Series, 327
syntax, 326
using, 325
Subtract calculation, 354
Sum calculation, 354
Suppressing Missing and Zero Values, 284
surface values, 264
swing feature, in pivot tables, 262
system toolbars, described, 50

T
table of contents, printing, 191
task, starting, 41
termination conditions in parameter forms, 438
three-dimensional charts, viewing, 249
Time Aware Axis, 252
Time data type, 220
time events
creating new personal recurring, 383
defined, 377
time selections, 327
TimeStamp data type, 220
Interactive Reporting toolbar, 198
Interactive Reporting Toolbars, 198
toolbars
buttons defined, 50
buttons, defined, 50
Standard, 50
Tools Menu, commands defined, 58
Topics and topic items, 214
totals
cumulative totals, 263
in Results section, 237
pivot total function, 263

surface values, 264
traffic lighting
Traffic Lighting dialog box, 341
Traffic Lighting analysis tool
overview, 341
Trend calculation, 355

U
unlinking coordinated components, 372
URLs, repository, 84
user interface
active preference, 64, 66
customizing, 61
defined, 30
resizing the view pane and content area, 76
setting preferences, 33
user POV
see POV, 168
user preferences
Databases user preferences, 67
user types and tasks, Workspace, 30
using data source elements, 34

V
Variable Filter, 227
variables in CubeQuery section, 281
Variance calculation, 355
Variance Percent calculation, 355
versions
adding, 121
flag exception, 123
setting priority, 122
showing latest, 123
working with, 120
View Menu, commands defined, 57
view pane, buttons defined, 29
viewing
books, 175
content, 87
details of a batch job, 399
events, 384
items when receiving notification, 132
properties of versions, 122
reports, 166
snapshots, 175, 176
viewing, PDF reports, 27
W
web analysis preferences
databases, 66
formatting, 66
Web Analysis Studio, overview, 35
Web Analysis toolbar, buttons defined, 51
windows, rearranging content, 143
Workspace
accessing items, 29
capabilities, 28
creating documents, 41, 43
deployment tasks, 27
documentation set, 27
file permissions, 32
fundamental tasks, 28
installing smart view, 97
item usage, 29
items, 28
logging on, 33
module tasks, 30
personalizing, 48
setting preferences, 33
starting tasks, 41
user interface, 30
user provisioning, 101
user types and task, 30
viewing PDF reports, 27
workspace
personalizing, 76
workspace library
changing data source in, 99

Z
zero columns, 297
zero rows, 297