<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cancelling Queries</td>
<td>96</td>
</tr>
<tr>
<td>Building Subqueries</td>
<td>96</td>
</tr>
<tr>
<td>Regular Subqueries</td>
<td>96</td>
</tr>
<tr>
<td>Correlated Subqueries</td>
<td>97</td>
</tr>
<tr>
<td>Derived Tables</td>
<td>99</td>
</tr>
<tr>
<td>Derived Tables Rules and Behavior</td>
<td>100</td>
</tr>
<tr>
<td>Derived Tables and SQL</td>
<td>102</td>
</tr>
<tr>
<td>Working with Query Section Data</td>
<td>103</td>
</tr>
<tr>
<td>Processing Results to a Database Table</td>
<td>104</td>
</tr>
<tr>
<td>Estimating Query Size</td>
<td>105</td>
</tr>
<tr>
<td>Displaying Database Remarks</td>
<td>105</td>
</tr>
<tr>
<td>Preaggregating Data Using Functions</td>
<td>105</td>
</tr>
<tr>
<td>Appending Queries</td>
<td>108</td>
</tr>
<tr>
<td>Using Local Results</td>
<td>109</td>
</tr>
<tr>
<td>Using Stored Procedures</td>
<td>110</td>
</tr>
<tr>
<td>Setting Query Options</td>
<td>112</td>
</tr>
<tr>
<td>Editing with SQL</td>
<td>112</td>
</tr>
<tr>
<td>Editing with SQL</td>
<td>112</td>
</tr>
<tr>
<td>Importing SQL Files</td>
<td>114</td>
</tr>
<tr>
<td>Reviewing the SQL Log</td>
<td>115</td>
</tr>
<tr>
<td>Importing Data Files</td>
<td>115</td>
</tr>
<tr>
<td>Setting Data Type Properties</td>
<td>116</td>
</tr>
<tr>
<td>Picture (BLOB Image) Support</td>
<td>117</td>
</tr>
<tr>
<td>Adding Pictures in Query</td>
<td>118</td>
</tr>
<tr>
<td>Adding Tooltips to Pictures</td>
<td>118</td>
</tr>
<tr>
<td>Working with Pictures in Results and Tables</td>
<td>119</td>
</tr>
<tr>
<td>Working with Pictures and Computed Items</td>
<td>119</td>
</tr>
<tr>
<td>Working with Pictures in Reports</td>
<td>119</td>
</tr>
<tr>
<td>Resource Manager</td>
<td>120</td>
</tr>
<tr>
<td>Picture General Properties</td>
<td>123</td>
</tr>
<tr>
<td>Query Menu Command Reference</td>
<td>123</td>
</tr>
<tr>
<td>Insert Query</td>
<td>124</td>
</tr>
<tr>
<td>Chapter 5. Results</td>
<td>127</td>
</tr>
<tr>
<td>Results Section</td>
<td>127</td>
</tr>
<tr>
<td>Understanding Data Types</td>
<td>127</td>
</tr>
<tr>
<td>Results Data Layout</td>
<td>128</td>
</tr>
<tr>
<td>Zooming Results</td>
<td>128</td>
</tr>
<tr>
<td>Formatting Results Columns</td>
<td>128</td>
</tr>
<tr>
<td>Section</td>
<td>Page</td>
</tr>
<tr>
<td>--------------------------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>Defining OLAPQuery Options</td>
<td>154</td>
</tr>
<tr>
<td>General OLAPQuery Options</td>
<td>155</td>
</tr>
<tr>
<td>Database-specific OLAPQuery Options</td>
<td>155</td>
</tr>
<tr>
<td>Building OLAP Queries</td>
<td>157</td>
</tr>
<tr>
<td>OLAPQuery Section Data Layout Rules</td>
<td>158</td>
</tr>
<tr>
<td>OLAPQuery Member and Level Rules</td>
<td>159</td>
</tr>
<tr>
<td>Refining OLAPQuery Data</td>
<td>159</td>
</tr>
<tr>
<td>Specifying a Slicer</td>
<td>160</td>
</tr>
<tr>
<td>Drilling Down</td>
<td>160</td>
</tr>
<tr>
<td>Drilling Up</td>
<td>161</td>
</tr>
<tr>
<td>Hybrid Analysis and Drilling (Essbase and DB2 only)</td>
<td>161</td>
</tr>
<tr>
<td>Adding Computed Items</td>
<td>162</td>
</tr>
<tr>
<td>Using OLAPQuery Functions</td>
<td>163</td>
</tr>
<tr>
<td>Processing OLAP Queries</td>
<td>165</td>
</tr>
<tr>
<td>Processing OLAP Queries Automatically</td>
<td>165</td>
</tr>
<tr>
<td>Working with an OLAPQuery Offline</td>
<td>165</td>
</tr>
<tr>
<td>Creating a OLAPResults Section Automatically</td>
<td>166</td>
</tr>
<tr>
<td>Applying Filters</td>
<td>166</td>
</tr>
<tr>
<td>Applying Member Selection Filters</td>
<td>166</td>
</tr>
<tr>
<td>Applying Measure Filters (Essbase)</td>
<td>167</td>
</tr>
<tr>
<td>Applying Variable Filters</td>
<td>167</td>
</tr>
<tr>
<td>Changing Data Views</td>
<td>171</td>
</tr>
<tr>
<td>Suppressing Rows</td>
<td>172</td>
</tr>
<tr>
<td>Adding Totals</td>
<td>172</td>
</tr>
<tr>
<td>Adding Data Functions</td>
<td>173</td>
</tr>
<tr>
<td>Showing OLAP Results as a Chart</td>
<td>174</td>
</tr>
<tr>
<td>Formatting OLAPQuery Items</td>
<td>174</td>
</tr>
<tr>
<td>Drilling Through from a Multi-Dimensional Database to a Relational Database</td>
<td>174</td>
</tr>
<tr>
<td>Setting Drill-through Options</td>
<td>175</td>
</tr>
<tr>
<td>Drilling Through</td>
<td>176</td>
</tr>
<tr>
<td>OLAP Menu Command Reference</td>
<td>176</td>
</tr>
</tbody>
</table>

Chapter 8. CubeQuery                                                                                   | 179  |

About CubeQuery                                                                                       | 179  |
About Essbase                                                                                                | 179  |
About Multidimensional Databases                                                                       | 180  |
CubeQuery Catalog                                                                                       | 183  |
OLAPQuery and CubeQuery Data Layout Differences                                                        | 184  |
Searching Members from the Catalog                                                                      | 184  |
Building a CubeQuery Section ................................................................. 185
Member Selection ..................................................................................... 186
  Browsing Members .............................................................................. 187
  Searching Members ............................................................................ 190
Member Selection Exclusions ................................................................. 191
Subsets ................................................................................................. 191
Also Select Next/Previous ..................................................................... 194
Filter Member Selection ....................................................................... 194
Data Filters ............................................................................................ 196
Set Condition ....................................................................................... 200
Persisting Data Filters ......................................................................... 201
Query Options ....................................................................................... 202
  Global Options ............................................................................... 202
  Display Options ............................................................................ 203
  Drill Options .............................................................................. 204
Navigating CubeQuery ......................................................................... 204
  Keep Only .................................................................................... 205
  Remove Only ............................................................................... 205
  Suppressing Missing and Zero Values ........................................... 205
Drilling ................................................................................................. 206
Downloading to Results ........................................................................ 208
  Separate Columns for Metadata Labels ........................................... 209
Measure Behavior in Columns ................................................................. 211
Ragged Hierarchies ............................................................................. 211
Shared Members .................................................................................. 213
Including Totals ................................................................................... 217
Showing as Chart ................................................................................ 219
Exporting a CubeQuery ......................................................................... 219
Formatting CubeQuery Items ................................................................. 220
CubeQuery Menu Command Reference .............................................. 222

Chapter 9. Analyzing Data with Pivot Tables ....................................... 225
Pivot Section ......................................................................................... 225
Creating a Pivot Table ......................................................................... 225
Pivoting Data ...................................................................................... 226
Charting a Pivot Table ......................................................................... 226
Working with Pivot Tables ................................................................... 227
  Selecting Pivot Table Elements ..................................................... 227
  Moving Pivot Table Elements ....................................................... 227
Chapter 10. Charting Data ...................................................................................................................... 243
  Chart Section ........................................................................................................................................ 243
  Charting Basics .................................................................................................................................... 243
  Chart Terminology ............................................................................................................................... 244
  Understanding Chart Dimensions ......................................................................................................... 245
    Using the Chart Data Layout .............................................................................................................. 245
  Creating Charts .................................................................................................................................... 246
  Selecting a Chart Type ......................................................................................................................... 247
  Working with Two-dimensional Charts ............................................................................................... 247
    Using Pie Charts to Analyze Data ...................................................................................................... 248
    Scatter Charts .................................................................................................................................... 250
    Bubble Charts .................................................................................................................................... 252
  Using Two-dimensional Bar Charts .................................................................................................... 254
  Working with Multidimensional Charts ............................................................................................. 255
    About the 3-D View ............................................................................................................................ 255
  Creating Three-dimensional Bar Charts .............................................................................................. 256
  Understanding Clustered Bar Charts .................................................................................................... 257
  Understanding Stacked Bar Charts ...................................................................................................... 258
  Understanding Area Charts ................................................................................................................ 258
  Understanding Ribbon Charts ............................................................................................................ 259
  Understanding Line Charts .................................................................................................................. 259
  Time Aware Axis ................................................................................................................................. 260
  Understanding Combination Charts ................................................................................................... 262
  Manipulating Chart Data .................................................................................................................... 263
    Using Different Scales to Compare Related Values ........................................................................... 263
    Using Data Functions in Charts ...................................................................................................... 264
    Adding Computed Items .................................................................................................................. 265
    Sorting Chart Items .......................................................................................................................... 265
<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Working with Interactive Reporting Database Connections</td>
<td>420</td>
</tr>
<tr>
<td>Creating Interactive Reporting Database Connections (.oces)</td>
<td>421</td>
</tr>
<tr>
<td>Setting Connection Preferences</td>
<td>422</td>
</tr>
<tr>
<td>Creating an OLAP Connection File</td>
<td>428</td>
</tr>
<tr>
<td>Connecting to Essbase (CubeQuery only)</td>
<td>429</td>
</tr>
<tr>
<td>Modifying Interactive Reporting Database Connection Files</td>
<td>430</td>
</tr>
<tr>
<td>Connecting to Databases</td>
<td>431</td>
</tr>
<tr>
<td>Monitoring Connections</td>
<td>431</td>
</tr>
<tr>
<td>Connecting with a Data Model</td>
<td>432</td>
</tr>
<tr>
<td>Connecting Without a Data Model</td>
<td>432</td>
</tr>
<tr>
<td>Setting a Default Interactive Reporting Database Connection</td>
<td>433</td>
</tr>
<tr>
<td>Logging On Automatically</td>
<td>433</td>
</tr>
<tr>
<td>Using the Connections Manager</td>
<td>434</td>
</tr>
<tr>
<td>Logging On to a Database</td>
<td>434</td>
</tr>
<tr>
<td>Logging Off of a Database</td>
<td>435</td>
</tr>
<tr>
<td>Modifying an Interactive Reporting Database Connection File Using the Connections Manager</td>
<td>435</td>
</tr>
<tr>
<td>Changing Data Passwords</td>
<td>435</td>
</tr>
<tr>
<td>Changing Database Passwords</td>
<td>436</td>
</tr>
<tr>
<td>Working with an Interactive Reporting Document and Connecting to a Database</td>
<td>436</td>
</tr>
<tr>
<td>Connecting to Interactive Reporting Web Client</td>
<td>438</td>
</tr>
<tr>
<td>Deferring Interactive Reporting Web Client Connections</td>
<td>439</td>
</tr>
<tr>
<td>Connecting to Workspace</td>
<td>440</td>
</tr>
</tbody>
</table>

**Chapter 16. Bidirectional Text** ........................................................................................................... 441

- About Bidirectional Text ............................................................................................................... 441
- Understanding Bidirectional Text .................................................................................................. 441
- Bidirectional Text Configuration Settings .................................................................................. 442

**Chapter 17. Using Metatopics and Metadata** .......................................................................................... 443

- About Metatopics and Metadata ....................................................................................................... 443
- Data Modeling with Metatopics .......................................................................................................... 444
- Creating Metatopics ......................................................................................................................... 444
- Copying Topic Items to a Metatopic ................................................................................................. 444
- Creating Computed Metatopic Items ................................................................................................. 445
- Customizing or Removing Metatopics and Metatopic Items ............................................................ 446
- Viewing Metatopics .......................................................................................................................... 446
- MetaData in Interactive Reporting Studio ...................................................................................... 446
- Using the Open Metadata Interpreter .............................................................................................. 447
- Accessing the Open Metadata Interpreter ........................................................................................ 447
Chapter 18. Data Modeling ........................................................................................................ 457
About Data Models .................................................................................................................. 457
Building a Data Model ........................................................................................................... 458
  Adding Topics to a Data Model .......................................................................................... 458
  Removing Topics from a Data Model ............................................................................... 459
Understanding Joins ............................................................................................................ 459
  Simple Joins ..................................................................................................................... 460
  Cross Joins ........................................................................................................................ 461
  Joining Topics .................................................................................................................. 461
  Specifying an Automatic Join Strategy ............................................................................ 461
  Manually Joining Topics .................................................................................................. 462
  Showing Icon Joins .......................................................................................................... 463
  Specifying Join Types ...................................................................................................... 463
  Removing Joins ................................................................................................................ 464
  Using Defined Join Paths ................................................................................................. 464
  Using Local Joins ............................................................................................................. 465
Working with Topics ............................................................................................................. 469
  Changing Topic Views ...................................................................................................... 469
  Modifying Topic Properties ............................................................................................. 470
  Modifying Topic Item Properties ..................................................................................... 471
  Restricting Topic Views .................................................................................................... 471
Working with Data Models .................................................................................................... 472
  Changing Data Model Views ............................................................................................ 472
  Setting Data Model Options ............................................................................................ 473
  Automatically Processing Queries ................................................................................... 478
  Promoting a Query to a Master Data Model ..................................................................... 478
  Synchronizing a Data Model ............................................................................................ 478
Data Model Menu Command Reference ............................................................................. 479

Chapter 19. Managing the Interactive Reporting Document Repository ........................ 481
About the Document Repository .......................................................................................... 481
Administering a Document Repository .............................................................................. 482
  Creating Repository Tables ............................................................................................. 482
  Confirming Repository Table Creation .......................................................................... 483
  Managing Repository Inventory ...................................................................................... 484
  Managing Repository Groups .......................................................................................... 485
Working with Repository Objects ....................................................................................... 485
  Uploading Interactive Reporting Documents to the Repository .................................. 486
Chapter 20. Auditing with Interactive Reporting ............................................................ 493
  About Auditing ............................................................................................................ 493
  Creating an Audit Table ............................................................................................. 494
  Defining Audit Events .............................................................................................. 494
  Auditing Keyword Variables ..................................................................................... 495
  Sample Audit Events .............................................................................................. 496

Chapter 21. IBM Information Catalog and Interactive Reporting Studio ...................... 499
  About the IBM Information Catalog ......................................................................... 499
  Registering Documents to the IBM Information Catalog .......................................... 499
    Defining Properties .............................................................................................. 500
    Selecting Subject Areas ...................................................................................... 500
  Administering the IBM Information Catalog ........................................................... 501
    Creating Object Type Properties ....................................................................... 501
    Deleting Object Types and Properties .................................................................. 502
  Administering Documents ...................................................................................... 502
    Setting Up Object Types .................................................................................... 503

Chapter 22. Row-Level Security in Interactive Reporting Documents .......................... 505
  About Row-Level Security ....................................................................................... 505
    The Row-Level Security Paradigm ...................................................................... 505
    Reporting and Analysis and Row-Level Security .................................................. 506
  Row-Level Security Tables ..................................................................................... 508
    Creating the Row-Level Security Tables ............................................................. 508
    The BRIOSECG Table ....................................................................................... 509
    The BRIOSECP Table ....................................................................................... 510
    The BRIOSECR Table ....................................................................................... 511
    OR Logic Between Groups .................................................................................. 512
  Row-Level Security Examples ................................................................................ 512
    Defining Users and Groups .................................................................................. 514
    Dealing with “The Rest of the Users” ................................................................... 514
    Overriding Constraints ....................................................................................... 515
Introducing Interactive Reporting

Overview

Oracle’s Hyperion® Interactive Reporting – System 9 connects business users to data and gives them a complete set of tools to support business decisions including ad hoc client/server querying, reporting, and analysis all in one application. Interactive Reporting provides the following capabilities:

- Data extraction and analysis
- Reporting and distribution
- Platform development

Interactive Reporting is an all-in-one query, data analysis, and reporting tool. The interface is highly intuitive and provides an easy-to-navigate environment for data exploration and decision making. With a consistent design paradigm for query, pivot, charting, and reporting, users at any level move fluidly through cascading dashboards—finding answers fast. Trends and anomalies are automatically highlighted, and robust formatting tools enable users to easily build free-form, presentation-quality reports for broad-scale publishing across their organization.

Interactive Reporting Features

Interactive Reporting features include:

- Support for all industry-standard databases.
- A point-and-click interface for intuitive custom query and report building.
- Support for Microsoft Windows and Motif (UNIX), with complete file compatibility between the platforms.
- Easy, nonprocedural navigation between query and reporting sections.
- An extensive online help system that provides assistance for features and document construction.
A drag-and-drop data layout tool for developing reports and analyzing data.

Interactive pivot reporting that lets you perform unrestricted drill-down analysis of different data relationships.

Extensive formatting tools for creating compelling data presentations.

An easy-to-use, interactive charting utility for graphically displaying and drilling-down into data.

How Interactive Reporting Works

Interactive Reporting enables you to access and analyze information stored in different company data sources. It connects you to data and supplies a complete set of tools that enable you to build queries quickly and intuitively—by clicking icons and manipulating objects. Interactive Reporting automatically builds a query to your specifications, sends it to the database, and displays the retrieved data as a table of results.

There are many types of data sources, but the most prevalent are relational databases and multidimensional databases.

Relational Databases

A relational database is a collection of data items organized as a set of formally described tables from which data can be accessed or reassembled in many different ways without having to reorganize the database tables.

The definition of a relational database results in a table of metadata or formal descriptions of the tables, columns, domains, and constraints. Metadata is literally “data about data.”

Multidimensional Databases

A multidimensional database is a data cube that provides multidimensional views of business data. Multidimensional databases are OLAP servers that enable you to easily and selectively extract and view data from different points of view. Multidimensional databases consider each data attribute as a separate dimension and allow you to create hierarchies within a dimension.

OLAP (On-Line Analytical Processing) designates a category of applications and technologies that allow the collection, storage, manipulation, and reproduction of multidimensional data, with the goal of analysis. OLAP provides for the fast analysis of multidimensional shared information.

About Interactive Reporting Documents

Interactive Reporting documents (BQYs) are files you create and use to retrieve information from a database, analyze the information, and build reports. Because Interactive Reporting is an integrated query, analysis, and reporting tool, Interactive Reporting documents have multiple
sections, each of which governs one part of the query and reporting process. You create sections progressively: first you query a database, then retrieve results, and last generate reports.

Interactive Reporting documents can contain data from any number of relational databases queries, multidimensional database queries, and/or from imported data. Documents usually include one or more of the following items:

- A **data model**, which is a visual representation of actual database tables
- A **query** or multiple queries for retrieving a subset of data from the database
- **Join** options, including local joins between different data sets within a single document, local join filters, and optional join path generation
- A **results** set displayed in a table-style format
- **Reports** presenting customized hierarchical views of your data
- Multidimensional **pivot** tables that permit drill-down analysis of data results
- **Charts** that graphically display your query results and allow different angles of vision on the data.

All Interactive Reporting documents usually have at least one Query section and one Results section. From the Results section, you can create multiple Pivot, Chart, Table, and Report sections to analyze and present data. Developers can also create Dashboard sections, which provide an automated push-button interface to a document for use by other users across the enterprise.

### Data Source Connections

For Interactive Reporting users, the process of creating a new document and connecting to a database is simple. You select an Interactive Reporting database connection file (.oce) for the database server and enter your database password. You can select either a new or an existing Interactive Reporting database connection file.

The way you choose an Interactive Reporting database connection file depends on the data model, document, or edition:

- When a data model is available for the Query, Interactive Reporting automatically prompts you for connection information. You connect to a database when you download a data model and process a query to retrieve a data set. In addition, you must be connected to show values for a server filter, to use server functions to create a computed item, or to schedule a document.

- When you open Interactive Reporting to begin a work session (for example, by downloading a data model from an Oracle’s Hyperion® Reporting and Analysis – System 9 repository, or creating a new data model), you must select the correct connection for the targeted database.

Interactive Reporting database connections retain all the information necessary to log onto a specific configuration of database and connection API software. They also retain DBMS-specific connection preferences and specifications for automatic access to metadata. This simplifies the connection process for company personnel by transparently handling host and configuration information. Each user can substitute a database user name when using the Interactive Reporting
database connection, which enforces security measures and privileges that are centralized at the database server.

Interactive Reporting database connections have significant advantages in network environments with many database users. One connection can be created for each Interactive Reporting database connection file in the environment and shared with each end-user. Because passwords are not saved with the Interactive Reporting database connection, distribution does not provide unauthorized access to any user who receives the wrong Interactive Reporting database connection file or acquires it from other sources.

Data Models

After connecting to a database, Interactive Reporting presents subsets of the database contents in the Query section through custom views called data models, which are visual representations of actual database tables. You use a data model to interact with a database to create queries which fetch data from the database.

Data models make the database more accessible by:

- Substituting descriptive names for arcane database table and column names.
- Creating custom views of the data.
- Adding computed fields for performing calculations on the retrieved data.

Standard data models derived from database tables enable you to create metatopics—virtual views independent of the actual database. Metatopics standardize complex calculations and simplify views of the underlying data with intuitive topics customized for business needs.

Users can create their own data models, or use prebuilt data models stored in the centralized Reporting and Analysis repository.

You can also provide a document that contains a master data model from which other users can build one or more queries. This master data model allows your users to concentrate on specific data, not how to set up the data access. Any data model can be promoted to a master data model.

You can offer users a raw look at the table schema, or hide the complexity by first creating one or more metatopics and then promoting the data model. Each time the user adds a new query, Interactive Reporting asks if the query should be linked to the master data model. Any linked queries inherit changes made to the master data model, but the data model is locked and cannot be modified. (Only the master data model can be changed.)

Queries

A query is a request for information from a database. Queries take the form of a command language that lets you select, insert, update, find out the location of data, and so forth.

The standard command language for getting information from and updating a relational database is Structured Query Language (SQL). SQL statements are used both for interactive queries for information from a relational database and for gathering data for reports.
Multidimensional databases also require a language that allows you to express multidimensional queries; however, to date, there is no standard. MDX (Multidimensional Expression Language) is used by Microsoft’s OLE DB for OLAP API and OLAP Services. For Oracle’s Hyperion® Essbase® – System 9, Interactive Reporting uses MaxL (Multidimensional Access Language). MDSQL (Multidimensional Query Language) is yet another query language.

With Interactive Reporting, you do not need to know SQL or any multidimensional query languages to create powerful database queries. You build queries by choosing the data to retrieve from a visual representation of the database.

Interactive Reporting offers two query methods, each of which is displayed as a separate section within an Interactive Reporting document:

- **Query**—Displays the structure of the relational database as tables (or topics), which are used to create a data model—the visual representation of the database tables. An Interactive Reporting document can have more than one data model.

- **OLAPQuery**—Displays the structure of the multidimensional database as a hierarchical tree. OLAP queries are displayed in a form similar to a pivot table, except the data comes straight from the OLAP server.

An Interactive Reporting document can contain one or more relational Query sections, as well as one or more OLAPQuery sections. This allows users access to information in organizations that have both types of databases.

### Analysis and Reporting

Once a query is processed and data results are returned to the desktop, you can use the Interactive Reporting powerful reporting and analysis tools to create custom views, cross-sections, and drill-downs to slice and dice data and view multidimensional relationships.

You can create multiple views of the data or display the information in any form and from any angle possible. At any time, you can reconnect to the server and update your reports and charts with fresh data from the database.

You can also use Interactive Reporting to work autonomously with data after disconnecting from the server. Even without a database connection, you can continue to analyze data and produce reports. You can save results in the desired format for additional refinement in Interactive Reporting, or export the data to other applications for further analysis.

Interactive Reporting enables you to create a wide variety of reports:

- **Tables**—Columnar arrangements of data. Tables are used as building blocks in other reporting sections. You can apply filters to tables, add computed items, include subtotals and grand totals, as well as summary totals such as sum, count or average.

- **Pivot tables**—Interactive tables that quickly summarize or cross-tabulate large amounts of data. You can rotate rows and columns to see different summaries of data or display the details for areas of interest. A pivot table summarized data by using a summary function, such as Sum, Count, or Average. You can include subtotals and grand totals automatically, or use your own formulas by adding computed items.
• **Charts**—Visual display of information; fully interactive, three-dimensional views of data. Interactive Reporting displays data from results sets as bars, lines, columns, pie slices, or other shapes in the chart. When you create a chart, the values from the worksheet are automatically represented in the chart. Charts are linked to the data they are created from and are updated when data is changed.

• **Custom reports**—Creates free-form presentation-quality reports with graphic objects, predefined fields, band-style report data from multiple data sources and computed fields, charts, and pivots; Smart reports enable you to embed charts and pivot tables and show only the data that is relevant to the section in which they are placed.

### Turning Data into Information

Data is meaningless unless it can be analyzed and interpreted. Analysis depends on consolidating and summarizing data through mathematical operations that reveal meaningful relationships, also called aggregation. The result is a summary of the data at a higher level, which summarizes and consolidates data from a lower level.

Aggregation is a critical feature of data analysis. Successful and rapid interpretation of data requires an easy method of aggregating data and representing it for easy interpretation. Aggregation techniques are easy to master. With the simple drag-and-drop of a data item, you can reorganize your data. Remove an item or drill down into your data, and you disaggregate your data.

Interactive Reporting provides a great deal of flexibility in how you choose to aggregate your data. One possibility is to aggregate your data at the time of your query, called server aggregation or preaggregation. In this case, the database server actually performs the aggregation for you.

An advantage of server aggregation is the network traffic is reduced and takes less time because the database server. If you preaggregate data at the server, you might not reach any substantial level of data because detailed data was excluded data by preaggregating. If you do not know your database tables, you could eliminate data that might be important for analysis. Also, preaggregation requires more server processing resources.

Alternatively, you can aggregate data on your desktop without involving the server. Interactive Reporting automatically aggregates your data for you in report sections.
Starting Interactive Reporting

➤ To start Interactive Reporting, select Start > Programs > Hyperion System 9 BI+ > Name.

For example Start > Programs > Hyperion System 9 BI+ > Interactive Reporting Studio.

Whenever you start Interactive Reporting, you must create a new Interactive Reporting document or open an existing Interactive Reporting document.

Opening and Saving a Sample File

During the installation process, Interactive Reporting installs several sample files. This tutorial uses the document named Sample1mod.bqy to familiarize you with many Interactive Reporting features.

➤ To open Sample1mod.bqy:

1 In the Welcome dialog box, select Recent Documents from the Open Existing Documents area.

2 Click Browse and navigate to the Samples folder (for example, C:\Hyperion\BIPlus\docs\samples).

Note:

If you cannot locate the sample files, please contact your administrator.

3 Select Sample1mod.bqy and click Open.

The content area is displayed and shows the sample document with the Dashboard active.
4 Select File > Save Options > Save Query Results with Document.

   The Save Query Results With Document dialog box is displayed.

5 Make sure that all of the items in the Query, Results, and Computed Columns lists are selected, and then click OK.

6 Select File > Save As to open the Save File dialog box.

7 Type a new name for the sample document (for example, practice.bqy) and click Save.

Looking at a Simple Query

The Query section is the foundation of an Interactive Reporting document. It is the space where you build questions for the database.

The Query section in the sample document is labelled SalesQuery. It is a simple query constructed for a fictitious company named Books, Movies, and Video (BMV). BMV distributes books, movies, and videos to a number of retail stores. To predict trends and locate strengths and weaknesses in its distribution techniques, BMV warehouses extensive data.

➤ To view the SalesQuery section, select SalesQuery in the Sections pane.

Viewing Database Tables

In Sample1.bqy, there are four tables, also called topics, in the Content pane. These four topics represent tables in the BMV database. The database tables are listed in the Catalog pane, located to the left of the Content pane.

➤ To view all the database tables:

1 In the Catalog pane, click the + (plus) sign to the left of Tables.

   If you are not connected to the sample database, the Hyperion Sample1.oce dialog box is displayed and prompts you for a user name and password.

   An Interactive Reporting database connection file is a file that enables you to connect to a database. The following icons on the Status bar indicate your connection status:

   ![Connected](image)

   **Connected**—You must be connected to a database to work in the Query section.

   ![Disconnected](image)

   **Disconnected**—You do not need to be connected to a database for many Interactive Reporting tasks.

   For the sample database, you do not need to enter any information in this dialog box.

2 Click OK to connect to the database.

   The Tables tree in the Catalog pane expands to show all of the tables in the database.
Adding Topics to a Query

➤ To include data from a particular table in your query, drag and drop the table from the Catalog pane to the Content pane.

Each topic contains a list of topic items that represent fields or rows of data in the database. In Sample1.bqy, the topics included in the query are Periods, Sales Fact, Products, and Stores.

You build queries by adding topics from the Content pane to the Request line. You can drag and drop any topic item to the Request line. When you process a query, Interactive Reporting returns data for all the topic items present on the Request line. In the sample, several topic items from each table have already been dragged to the Request line (for example, Unit Sales, Amount Sales, Year, Quarter, and so on).

You can also add filters to the data, or specify columns by which to sort the data. You can apply filters and sorts in either the Query section or the Results section.

In the Query section, filters instruct the database server to filter unwanted information from the requested data. Sorts instruct the database server to retrieve data to your desktop in a particular order.

Viewing Results

Data returned from a query is displayed in the Results section. Each column of results corresponds to items on the Request Line in the Query section. Request items are listed in the Catalog pane.

➤ To view the Results section, select SalesResults in the Sections pane.

Use the arrow buttons on the Section title bar to compare the items in the Query and Results sections.

Reordering Columns

➤ To reorder columns in the Results section, drag one column to the left or right of another column.

You can also move column labels in the data layout.

Sorting Columns

➤ To sort columns of data:

1 If the Sort line does not show, click Sort(0) on the Section title bar.

2 Drag Product Line from the Catalog pane to the Sort line.

3 Click Sort Now to group items by Product Line.
Filtering Data

Use the Filter line to limit the data displayed in a column.

➤ To filter data:
1. If the filter line does not show, click filters(0) on the Section title bar.
2. Drag Amount Sales from the Catalog pane to the filter line.
   The Filter dialog box is displayed.
3. Select >=Greater or Equal from the filter drop-down list.
4. Click Custom Values, type 100000 in the field provided, and click OK.
   All entries with sales amounts less than $100,000 dollars are dropped from the Results section.

➤ To remove a data filter, delete Amount Sale from the Filter line.
   The data is redisplayed when you remove the filter.

Calculating Data

You can perform calculations on columns of numeric data.

➤ To sum up numeric data:
1. Select the Amount Sales column.
   The Insert Grand Total dialog displays.
2. Select Results > Grand Total and click OK.
3. Scroll down to the bottom of the table to view the total amount of sales.
   BMV total sales for 1999-2000 are $132,881.
   If the figure does not match $132,881, remove any filters imposed on the results set.
   Delete any filters from the Filter line and view the total again.
   The sum automatically adjusts.
   If you see ########, the number is too large to fit in the designated space.

➤ To resize the column, select Format > Column > Auto-Size Width.

Pivoting Data

In Sample1.bqy, the SalesPivot section is a simple example of a pivot table. Pivot tables provide multiple angles on your data.

➤ To view the Pivot section, select SalesPivot in the Section pane:
   The SalesPivot section is displayed.
Pivot tables allow you to quickly summarize data in the Results section and immediately see the relationships between different dimensions of your data. These reports pivot to provide fresh angles of vision on your data.

➤ To create a pivot table:
1 Select SalesQuery in the Section pane.
2 Select Insert > New Pivot.
3 If the data layout is not already visible, click Data Layout on the Section title bar.

Drag one or more items from the Catalog pane into each of the data layout panes. Remove items from the data layout panes and add new ones. Use the Top Labels pane and Side Labels pane for text. Use the Facts pane for numeric values.

➤ To pivot views:
1 Click the dimension tab at the end of the row labels.
2 Drag the tab down and left to turn your row into a column.

The same data is displayed but with a different angle on the data.
3 Take the tab of the newly formed column and drag it so it becomes a row again.

### Calculating Totals and Subtotals

To make effective use of data, you may need to generate totals or subtotals.

➤ To calculate totals and subtotals (as displayed above):
1 Drag Product Line and Region to the Row pane in data layout.
2 Drag Year to the Column pane in data layout.
3 Drag AmountSales to the Facts pane in data layout.
4 Select the dimension handle for Region (click at the bottom of the Region column).
5 Select Pivot > Add Totals.

A row is added that shows the total number of product line sales for all regions.
6 Select the handle for Product Line and select Pivot > Add Totals.

A row is added showing the subtotals (also know as break totals) for each product line by region.

### Drilling Down

More data is available for analysis than is currently visible in your pivot table.

➤ To drill anywhere, select the Region column and select Pivot > Drill Anywhere > Country.

A column is added to your pivot table that shows countries within region.
To restore the original pivot table without the Unit Sales column, select the Country column and select Pivot > Drillup.

**Hiding Data**

You can temporarily hide data.

➤ To hide an item, select a label such as the Americas label and select Pivot > Hide Items.

➤ To focus on an item, select a label such as the Americas label and select Pivot > Focus On Items.

➤ To restore your excluded items, select Pivot > Show All Items.

**Adding Color**

Use the Format toolbar to add color to emphasize aspects of your pivot table.

**Note:**
If the Format toolbar is not visible, select View > Toolbars > Formatting.

➤ To add a line color:
1. Click a label, dimension handle, or column.
2. On the Format toolbar, open the Line Color list and select a color from the palette.

➤ To add a fill color:
1. Click a label, dimension handle, or column.
2. On the Format toolbar, open the Fill Color list and select a color from the palette.

➤ To add a text color:
1. Click a label, dimension handle, or column.
2. On the Format toolbar, open the Text Color list and select a color from the palette.

**Charting Data**

Charting features make graphic analysis of data and powerful presentations simple. In Sample1.bqy, the AllChart section is a chart based on the data from the original query.
To view the Chart section, select Pivot > Show All Items.
The AllChart section is displayed.

To change the chart type and format, select a chart format from the Chart list.
As you shift from one chart type to another, data may be shifted to different axes.

To create a new chart:
1 In the Section pane, select SalesQuery.
2 Select Insert > New Chart.
   Chart is displayed in the Section pane.
3 In the Section pane, double-click Chart.
   The Section Label dialog box is displayed.
4 Delete Chart and type: Unit Sales Region.
5 Click OK.
6 If the data layout is not already visible, click Data Layout on the Section title bar.
   Numeric values (facts) are placed in the y pane in the data layout. Non-numeric data
   (dimensions) are placed in the x pane and z pane in the data layout.
7 Drag Unit Sales to the x pane in data layout.
8 Drag Region to the z pane in data layout.
9 Drag Product Line to the y pane in data layout.
10 Click a Legend box to change the distribution and patterns of colors.

Sorting Charts
It is often useful to order the bars of a chart sequentially.

To sort your chart:
1 If the Sort line is not visible, click Sort on the Section title bar.
   Sort provides drop-down menus to select sort criteria. Experiment sorting.
2 Click the Ascending or Descending sort icon on the Standard toolbar.
   The data on the chart is rearranged in ascending or descending order.

Inserting Text Labels
You can insert a text label anywhere within the chart to further explain or emphasize a chart component.
To insert a text label:

1. **On the shortcut menu, click Insert Text.**
   The Set Inserted Text dialog box is displayed.
2. **Type the text you want to insert and click OK.**
3. **Drag the text box to any position on the chart.**

**Designing Reports**

The Report Designer is another way to analyze and present data and offers a great deal of formatting flexibility. You can embed either a pivot table or a chart directly in a report.

**To view a Report section, in the Section pane, select RegionReport.**

The RegionReport section is displayed.

**To create a new tabular report:**

1. **Select Insert > New Report.**
   Blank columns are displayed in the Content pane.
2. **Click Groups and Table on the Section title bar to see all panes in the data layout.**
   In the Report section, create reports by dragging items from the Catalog pane to the Groups data layout and the Table data layout.
   The Groups data layout allows you to drag non-quantifiable items and create separate tables for each label in a report group. In other words, when you designate a results column to serve as a report group, Interactive Reporting organizer data in repeating collections of records according to the Report group.
   The Table data layout is divided into the Dimensions and Facts panes. The Facts pane allows you to drag quantifiable items to show quantity. Totals are generated automatically in the report body. The Dimensions pane allows you to drag non-quantifiable items to itemize the facts.
3. **In the Catalog pane, double-click the SalesQuery folder, and click the plus sign to the left of the SalesResults folder.**
4. **Drag Year and Quarter into the Dimensions pane in Table data layout.**
5. **Drag Amount Sales into the Facts pane in Table data layout.**
6. **Drag Territory to the Report Group 1 field of the Groups data layout.**
7. **Drag Country to the Report Group 2 field of the Groups data layout.**
   The new report has visible section boundaries. Results columns added to the Facts pane are automatically summed and the totals are displayed in the tabular report of the report table column.
Creating Smart Reports

Smart reports allow you to embed charts and pivot tables into a report body. These reports show only the data that is relevant to the report section in which they are placed. For example, if the report is grouped by year, and you insert a chart in the report body, the chart replicates automatically so that there is a chart for each year of data in the report. Each year for the chart contains data specific to that year.

➤ To create a Smart report:
1 In the Catalog pane, click the plus sign to the left of the SalesQuery folder.
2 Drag a Chart icon (use either Unit Sales Region or AllChart) and position it just above the table in the report body.
   Allow some white space between the embedded chart and the table.
   In the newly-created Smart report, the chart changes to reflect the data specific to each country within a territory.

Sorting Columns

➤ To sort table columns, select a table column, and drag it to the Sort line.
Multiple table columns can be added to the Sort line to create a nested sort.

Setting Up a Report Page

➤ To set up a report page:
   1 Select Report > Report Setup.
      The Report Page Setup dialog box is displayed.
   2 On the Margin page, set margin sizes (top, bottom, left, and right) and click OK.
   3 On the Column page, specify the number of columns on a page and the default column width and spacing.
   4 Click OK.

➤ To insert a page break, select a Report Group header (be careful not to select the Report Group label) and on the shortcut menu, select Page Break After or Page Break Before.
   Page breaks can be inserted before and after a report body or before and after a Report Group label.

Note:
You can disable automatic totaling.
To remove a page break, select a Report Group header with a page break applied, and on the shortcut menu, select Page Break After or Page Break Before to remove the check mark.
Interactive Reporting Basics

In This Chapter

Maintaining Interactive Reporting Document Files.................................................................35
Exporting to Microsoft Office HTML File Formats...............................................................48
Using Edit Commands..............................................................................................................66
Changing Views......................................................................................................................66
Inserting Sections and Breaks...............................................................................................66
Formatting Text and Other Elements....................................................................................67
Working with the Tools Menu...............................................................................................67
Formatting Numeric Data Types............................................................................................67
Working with Document Sections.........................................................................................69
Setting Interactive Reporting Options..................................................................................72
Export Properties....................................................................................................................84
Export Document as Web Page................................................................................................85
Export to HTML Wizard.........................................................................................................86
Spotlighter..............................................................................................................................87

Maintaining Interactive Reporting Document Files

Interactive Reporting documents are files created by Interactive Reporting that you store on your personal computer. Each Interactive Reporting document file consists of one or more sections. Additionally, the Interactive Reporting document file can be used to retrieve information from a database, analyze the information, and build reports. Maintaining Interactive Reporting document files involves the tasks described in these topics:

● “Creating Interactive Reporting Document Files” on page 36
● “Opening Interactive Reporting Document Files” on page 36
● “Closing Interactive Reporting Document Files” on page 36
● “Saving Documents” on page 37
● “Specifying Save Options” on page 37
● “Save Query Results With Document” on page 37
● “Compressing Interactive Reporting Document Files” on page 37
● “Saving Interactive Reporting Documents to the Reporting and Analysis Repository in Interactive Reporting Web Client” on page 39
Creating Interactive Reporting Document Files

To create an Interactive Reporting document file:

1. Select File > New, or click the New icon on the Standard toolbar.
   The New File dialog box is displayed.

2. Select an Interactive Reporting database connection file.
   For more information about Interactive Reporting database connection files, see “Data Source Connections” on page 21.

3. Enter your user name and password and click OK.

Opening Interactive Reporting Document Files

To open an Interactive Reporting document file:

1. Select File > Open.
   The Open File dialog box is displayed.

2. Select the Interactive Reporting document file and click OK.

Tip:
When opening an Interactive Reporting document file with your browser commands, you may have to adjust the type of field displayed. By default, browsers show files with HTM extensions only. To view Interactive Reporting documents, set the file type to “all files” or “.bqy”.

Closing Interactive Reporting Document Files

Note:
Document shutdown scripts are only executed when an Interactive Reporting document file is closed.

To close an Interactive Reporting document file, select File > Close.
You are prompted to save the changes.
Saving Documents

When you save a document, you save the formatting and layout of all sections it contains. You can also use the Save Query Results With Document option to work offline.

Note:
The Save and Save As commands in Oracle’s Hyperion® Workspace do not execute the document shutdown scripts when saving the Interactive Reporting document file. These scripts only execute when a Interactive Reporting document file is closed.

➤ To save an Interactive Reporting document file, click the Save button on the standard toolbar, or select File > Save.

➤ To save the Interactive Reporting document file under another name:
1 Select File > Save As.
   Save File is displayed.
2 Enter an Interactive Reporting document name in the File Name field and click Save.

Specifying Save Options

➤ To select specific save options, select File > Save Options and choose an option:
  ● Specifying Save Options
  ● Work Offline in Interactive Reporting Web Client
  ● Compressing Interactive Reporting Document Files
  ● Password Protecting Interactive Reporting Document Files
  ● Password Protect Designer Mode

Save Query Results With Document

This option saves the results of a query and any computed columns (from the results) with an Interactive Reporting document file and allows you to analyze and generate reports using the results set without being connected to the database.

See also Saving Results Sets.

Compressing Interactive Reporting Document Files

The Compress Document option condenses the number of bytes in a document, and saves the Interactive Reporting document file in a compressed file format. It enables you to quickly transmit the Interactive Reporting document file and saves valuable storage space. Compression
concentrates the number of bytes by removing empty data fields and unnecessary information. Interactive Reporting automatically decompresses the file when you reopen it.

**Tip:**

To configure Interactive Reporting to compress all Interactive Reporting document files when saving them, select Compress All Documents on the General tab. (See “General Options” on page 75.)

**Password Protecting Interactive Reporting Document Files**

Use the Password Protect Document option to restrict access to an Interactive Reporting document file and ensure the confidentiality of sensitive documents. This option requires users to input a correct password for document access.

To assign a password to an Interactive Reporting document file:

1. **Select File > Save Options > Password Protect Document.**
   
   Password Protect Document is displayed.

2. **In the Password field, type the password to be assigned to the Interactive Reporting document file.**

   Passwords can contain up to 38 alphanumeric characters and are case sensitive.

3. **In the Verify Password field, retype the password and click OK.**

   If the password and the verification do not match, an error message is displayed.

---

**Caution!**

Keep a list of each Interactive Reporting document file and the specific password needed to access it in a secure place.

**Password Protect Designer Mode**

Use the Password Protect Designer Mode option to:

- Restrict access to a document script and the scripting environment. This ensures the integrity and confidentiality of sensitive scripts in a Dashboard section and when you are working with document scripts.

- Enable encryption for startup, shutdown, document, and Dashboard scripts associated with Interactive Reporting document files.

You must supply a valid password to encrypt scripts. (Encrypted scripts are not functional in releases prior to 6.6.3 or 8.1.) You can still password protect an Interactive Reporting document file without encrypting any scripts associated with it.

You can define a default encryption state on the General options of Designer Options. When you create an Interactive Reporting document file, the default encryption state matches the one in
Designer Options. Despite the default setting, scripts are only encrypted if the Interactive Reporting document file has a valid Design mode password.

**Note:**

Password Encryption accommodates user credentials that contain characters from a language other than the Windows machine locale. Password encryption extends to database passwords specified in Interactive Reporting database connection files, Interactive Reporting document files and sections.

➤ To password protect a script:

1. **Select File > Save Options > Password Protect Designer Mode.**
   
   Password Protect Designer Mode is displayed.

2. In the **Password** field, enter the password required to open the document script.
   
   Passwords can contain up to 38 alphanumeric characters and are case sensitive.

3. In the **Verify Password** field, retype the password and click **OK**.
   
   If the password and the verification do not match, an error message is displayed.

➤ To open a password protected script:

1. **Select one action:**
   
   - Select **File > Document Scripts**.
   - Click the Design/Run icon in the Dashboard section run mode.

   Unlock Design Mode is displayed.

2. Enter the password required to open the script and click **OK**.

➤ To encrypt a script:

1. In the **Password** field, enter the design mode password required to open the script.
   
   Passwords can contain up to 38 alphanumeric characters and are case sensitive.

2. In the **Verify Password** field, retype the password and click **OK**.
   
   If the password and the verification do not match, an error message is displayed.

3. Select **Encrypt Dashboard scripts**.

4. Click **OK**.

### Saving Interactive Reporting Documents to the Reporting and Analysis Repository in Interactive Reporting Web Client

When you modify an Interactive Reporting document or job, you can save the changed document to the Reporting and Analysis repository. The Reporting and Analysis repository is
an efficient way to manage documents and distribute documents over a wide network for end-user query and reporting.

Saving the document to the Reporting and Analysis repository can be made either by saving the document with changes to the original document using the Save to Repository option. To save the original document under a new name or when you do not have permission to overwrite a document, use the Save As to the Repository.

➤ To save an document to the Repository, select File > Save to Repository.

**Saving As to the Reporting and Analysis Repository in Interactive Reporting Web Client**

When saving to the Repository, use the Save As to the Repository to save an original Interactive Reporting document under a new name, or when you need to save a document, but do not have permission to overwrite the original.

➤ To save the document under a another name:

1. **Select File > Save to Repository As.**
   
The Save As To Repository File dialog box is displayed.

2. **Navigate to the folder in which to save the Interactive Reporting document file in the Look in field:**
   
   ● To select an existing folder, select a folder from the list show by double clicking the folder. You can drill down into a sub-folders within a folder also by double clicking the selected folder.
   
   ● To move up one level in the Look in field, click Go up.
   
   ● To create a new folder, click New Folder. When the Create New Folder dialog box is displayed, type the name of the folder in which to save the document.
   
   ● To show hidden folders, click Show Hidden.

3. **Type a name for the document in the Name field.**

4. **Optional:** Enter a document description in the Description field.

5. **Select Interactive Reporting document from the Type drop-down list.**

6. **Click Save.**

**Create New Folder**

Use the Create New Folder to add a new folder in which to save Interactive Reporting document files in the repository.

➤ Type the name of new folder in the Please Enter the Name field and click Save.

To nest the new folder within a parent folder, navigate to the parent folder before creating the new folder.
Work Offline in Interactive Reporting Web Client

This option enables you to save an Interactive Reporting document file locally so that you can work with it offline if you have an installed version of Oracle’s Hyperion® Interactive Reporting Web Client. In this case, you are not prompted to connect to the Workspace when opening the document. You set this option in the Oracle’s Hyperion® Interactive Reporting Studio or Interactive Reporting Web Client.

Note:

Once the Interactive Reporting document file is imported to the Workspace, a user with a Viewer/Dynamic Viewer and Explorer role can open the saved locally file without a logon. A user with Explorer Role cannot save the Interactive Reporting document file back to the repository. As a result there is no option to work offline in Interactive Reporting Web Client.

Working with Data Sources

You can use a prebuilt data model or you can import files from other applications and use the data as the source for your document. As you work with data sources, you can use the commands described in these topics:

- “Open From Repository in Interactive Reporting Studio” on page 41
- “Save To Repository in Interactive Reporting Studio” on page 42
- “Import Data File” on page 43
- “Import SQL” on page 44

Open From Repository in Interactive Reporting Studio

Use Open From Repository command to select Interactive Reporting database connection file (.oce) and repository object (data models, standard queries, and standard queries with reports) in Interactive Reporting Studio.

Repository objects ensure that your documents maintain a standard look and feel. If you are not experienced with database access, repository objects also help you get the data you need quickly and easily.

➤ To open a document using a repository object:

1. Select File > Open From Repository > Select.
   
The Select Connection dialog box is displayed.

   Note:
   
   You can also use the Interactive Reporting database connection file currently in use if there is one. Current are listed below the Select menu item.

2. Select the Interactive Reporting database connection file (.oce) to use and click OK.
3 In the Password dialog box, type your user name and password and click OK.

The Open From Repository dialog box is displayed and displays information about the selected object.

- **Unique Name**—Name of repository object
- **Creator**—Creator of the repository object
- **Created**—Date on which the repository object was created
- **Description**—General description of the repository object, its contents, and the type of information that can be queried

4 Navigate through the repository tree to select the repository object to use and click Open.

The repository object is downloaded to the appropriate section.

### Save To Repository in Interactive Reporting Studio

Designers can use the Save To Repository command to upload repository objects (data models, standard queries, and standard queries with reports) for version-controlled distribution to networked Interactive Reporting Studio users, and to describe the object to users browsing the repository.

**Note:**

When you store objects in the Interactive Reporting repository, make the Interactive Reporting database connection file available to users.

Expand

To upload an object to the Interactive Reporting repository:

1 With the repository object to upload open in Interactive Reporting Studio, select File > Save to Repository.

2 Click Select to launch the Select Connection File dialog box.

The Save to Repository dialog box is displayed and the Model Tab defaults.

3 If you have modified a Data Model, built a standard query or a standard query with a report, the Model Type field shows the types of objects that can be saved to the Repository at this time. Select the repository type. Available types are:
   - Data Model
   - Standard Query
   - Standard Query with Reports

4 Enter a descriptive name for the object in the Unique Name field.

5 Type your name as the object creator in the Creator field.

The date on which the object was saved to the Repository defaults in the Created field.

6 Unlock the repository object to allow users to make modifications to it by selecting Locked/Linked Object (Required for ADR) field so that no check mark appears in the field.
If the repository object is subject to Automatic Distributed Refresh, the object must be locked (the Locked/Linked Object field must be checked).

7 Click Prompt for Sync on Download to prompt users to make a copy of an object that has been saved locally if a new version of the object exists in the repository.

8 Enter a description of the object, its attributes, and what it can be used for in the Description field. You can add a description of up to 255 characters in length.

9 Click OK.

10 If you did not enter a unique name for the object in the Unique Name field, Interactive Reporting prompts: “Model name exists in this group. Do you want to enter a Unique Name. In this case, click Yes.”

If you click No, prompts: ”Do you want to replace the existing file?” If you click OK to replace the existing file, the saved object overwrites any existing object with the same name.

11 Click OK.

The Groups tab is displayed. Groups associated with the owned repository appear in the Groups panel. The PUBLIC groups is also included by default.

12 Use the arrow buttons to grant access to Repository groups by adding them from the Available list to the Selected Groups list.

Tip:
You must move the PUBLIC group to the Groups List panel if you want to provide general, unrestricted access to the repository object.

13 Click OK to save the object to the Repository.

14 Distribute the Interactive Reporting database connection file to end-users as need to access both the object source database, and if necessary, the Interactive Reporting hub used to store the object.

**Import Data File**

You can import data from other applications and use the data as the source for your document. Use the Import Data File command to use data stored in Microsoft Excel, tab-delimited, or comma-delimited file formats. The data is displayed in the Results section. You can then use the imported data to build reports and perform data analysis.

➤ To import a data file:

1 Select File > Import Data File > Data File.

   The Import File dialog box is displayed.

2 Navigate to the location of the file to import.

3 Select a file type from the Files of Type drop-down list to make the file easier to find:
   - Tab delimited (*.txt)
   - Comma Delimited (*.csv)
- Excel (*.xls) (the Import feature supports style and font information and Unicode strings [Excel 2000, Excel 2003 file formats]).

**Note:**
Interactive Reporting does not support the import of the Office 2007 format of Excel documents. As a workaround, save the document in an older Excel format and import the document again.

- All Files (*.*)

**Note:**
If an Excel (.xls) file to be imported is not in table format, you receive the following error message: ”Warning: Data you are trying to import is not in a tabular format. Do you still want to import it? You can either reformat the data in Excel to a table format, or continue with the import. If you continue the format, the data does not map in the Interactive Reporting document.

4 **Select the file to import and click OK.**
The data from the imported file is displayed as a table in the Results section.

5 **Select the encoding for the file from the Encoding drop-down.**
The encoding parameter sets the output file encoding. It works for the file formats that allow you to use code page encoding like TXT, CSV and XLS. XLS supports a subset of encodings.

**Import SQL**
The Import SQL command takes a complete SQL statement from a text file, imports it into an existing query, and retrieve the data set from the database server. Use this feature to take advantage of SQL statements you have already written.

Before importing SQL files, make sure that the following conditions are true:
- The SQL file to import begins with a SELECT statement.
- The Query section is active.
- The connection to the database is active.
- The Content pane does not contain any tables.

You also need to know the number of columns to display in the Results section.

After you import the SQL file into the Query section, you cannot:
- edit it
- drag items from the table to the Request line
- use the custom SQL feature
- display its properties

However, you can specify a user-friendly name for the Request item and identify its data type.
To import SQL files:

1 Select File > Import Data File > SQL.
   The Import File dialog box is displayed.
2 Navigate to the location of the file.
3 Select the file to import and click OK.
   Interactive Reporting prompts you for the number of data columns. The number that is by default in the dialog box is an estimate.
4 Type the number of columns and click OK.
   Interactive Reporting inserts the SQL statement directly into the content, nested between the header and footer “Imported SQL Statement.” If the statement is larger than the visible Content pane, use the scroll keys to view it.

Exporting Data

Interactive Reporting enables you to export data to other file formats for use with non-Interactive Reporting applications. Review these topics for information on exporting data:

- “Defining Export Properties for .HTML in the Results and Table Sections” on page 45
- “Defining Export Properties for HTML in the Pivot and OLAP Sections” on page 46
- “Defining Export Properties for HTML in the Report Section” on page 47
- “Exporting a Section” on page 47
- “Exporting to Microsoft Office HTML File Formats” on page 48
- “Exporting a Document as a Web Page” on page 62
- “Browser and HTML Restrictions and Limitations” on page 63
- “Using the Export to HTML Wizard” on page 64
- “Exporting SQL” on page 64
- “Exporting a Query Log” on page 64
- “Exporting Scripts To a Text File” on page 64

Defining Export Properties for .HTML in the Results and Table Sections

Before exporting data to a .HTML file, use the Export Properties dialog box to specify export properties for data in the Results and Table sections.

To specify export properties:

1 Select Format > Export Properties.
   The Export Properties dialog box is displayed.
2 Specify the number of vertical rows to include on an .HTML page before starting a new page (file) by checking the Vertical Page Break checkbox and entering the number of rows.
The default setting is 100 rows per .HTML page. (Select Pixels to specify the number of pixels instead of rows).

To export to one file, or to have no page break, leave the Vertical Page Break checkbox blank.

3 Select the desired export properties.

Check the Export with Style Sheet (CSS) option to create a Cascading Style Sheet file separate from the .HTML file. If this field is unchecked, the style sheet information is embedded in the .HTML file itself.

4 Select the Export MS Excel formulas check box to export Interactive Reporting computed items to Excel. To export a raw table (without formulas), leave the check box blank.

By default the Export MS Excel formulas feature is enabled. For more information about including formulas in a section to be exported to Excel, see “Formula Mappings” on page 55.

5 For data exported to tab-delimited text files, select the Export Without Quotes check box to exclude double quotation marks around real column/cell values in the exported files and click OK.

Defining Export Properties for HTML in the Pivot and OLAP Sections

Before exporting data to HTML, use the Export Properties dialog box to specify export properties for data in the Pivot section.

➤ To specify export properties:

1 Select Format > Export Properties.

The Export Properties dialog box is displayed.

2 Specify the number of vertical rows to include on an HTML page before starting a new page (file) by checking the Vertical Page Break check box and entering the number of row or pixels.

The default setting is 100 rows per HTML page. (Select Pixels to specify the number of pixels instead of rows). To export to one file, or to have no page break, leave the Vertical Page Break check box blank.

3 Specify the number of horizontal columns to include on an HTML page before starting a new page (file) by checking the Horizontal Page Break check box and entering the number of columns or pixels.

The default setting is 100 rows per HTML page. (Select Pixels to specify the number of pixels instead of rows). To export to one file, or to have no page break, leave the Horizontal Page Break check box blank.

4 Select the desired export properties.

Check the Export with Style Sheet (CSS) option to create a Cascading Style Sheet file separate from the HTML file. If this field is unchecked, the style sheet information is embedded in the HTML file itself.

5 For data exported to tab-delimited text files, select the Export Without Quotes check box to exclude double quotation marks around real column/cell values in the exported files.

6 Click OK.
Defining Export Properties for .HTML in the Chart Section

Before exporting a chart section to an HTML file, use the Export Properties dialog box to specify export properties for data.

➤ To specify export properties:

1 Select Format > Export Properties.

The Export Properties dialog box is displayed.

2 To match the maximum number of bars displayed (X and Z directions) for HTML renderings (static or ) with the corresponding values on the Label Axis tab of the Chart Properties dialog (that is, use the Designer settings for the chart), check the Sync with Chart Properties field.

To manually set the maximum number of bars to display per view, uncheck the Sync with Chart Properties field. When the X-Axis Maximum Bars Displayed and Z-Axis Maximum Bars displayed are active, you can set the maximum number of bars to display for both the X axis and the Z axis. The horizontal scrollbar controls scrolling of the X axis, and the Vertical scrollbar controls scrolling of the Z axis.

3 To render chart boundaries, click Chart Boundaries.

The default chart boundaries are 504 pixels in height and 838 pixels in width. To specify other chart boundaries pixel sizes, enter the size in the Height and Width edit boxes. To use the default sizes, click the Reset Size.

4 Click OK.

Defining Export Properties for HTML in the Report Section

Before exporting data to static HTML, use the Export Properties dialog box to specify export properties for data in the Report section.

➤ To specify export properties:

1 Select Format > Export Properties.

The Export Properties dialog box is displayed.

2 Select the desired export properties.

Check the Export with Style Sheet (CSS) option to create a Cascading Style Sheet file separate from the HTML file. If this field is unchecked, the style sheet information is embedded in the HTML file itself.

3 Click OK.

Exporting a Section

After processing a query, you can export the data contents of the Results, Pivot, Chart, Table, or Report sections for use in other applications. If you export from a Results section, the data is raw and unaggregated. If you export from a report section, the data is already aggregated.
In addition, you can export the contents of a Dashboard section to a JPEG file.

To export the current section to a file:
1. **Select File > Export > Section.**
   The Export Section dialog box is displayed.
2. **Specify the location where you want to save the file.**
3. **Type a name for the section to be exported in the File Name field.**
4. **Select a file format from the Save As Type drop-down list.** Select from:
   - Microsoft Office 2000 HTML (*.html)
   - Microsoft Office Web Archive (*.mhtml)
   - Excel (*.xls)
   - Lotus 1-2-3 (*.wks)
   - Text (Tab delimited) (*.txt)
   - Text (Comma Delimited) (*.csv)
   - HTML (*.htm)
   - PDF (*.pdf)

   The available export file formats change depending on which section you export.

   **Note:**
   Select **Format > Export Properties** to set properties for files exported to text or HTML.

**Notes on Exporting a Section to PDF**

By default, headers and footers of the Results, Table, Pivot and Chart sections are mapped to the dialog box font, MS Sans. Because this font is not presented as a single file in the system, but as a series of fonts that may be used to show specific charters, the PDFLib can export only a certain amount of characters using the export mechanism for multiple page PDF export. To avoid the lack of double byte characters in the PDF export, change the header and footer font to Arial Unicode MS or Andale WT.

In a Pivot report exported to PDF using Portrait setting, the total side label width may truncate. To remedy this issue, reduce the number of side labels to decrease the width, or change the page setup to Landscape, and then export the report again.

**Exporting to Microsoft Office HTML File Formats**

You can export and deploy an Interactive Reporting section on an intranet or internet, and work back and forth between the HTML file and Microsoft Office 2000 Excel. This is achieved by using the Microsoft Office 2000 HTML (*.html) or Microsoft Office Web Archive (*.mhtml) file.
formats. These file formats preserve and recognize formatting attributes, formulas, and Visual Basic for Applications macros (VBA) created in the original section.

This feature uses Microsoft Office XML (extended markup language) tags in addition to the HTML. When the exported section is opened in Microsoft Office (specifically Excel), the formatting and formula from the original section are preserved and recognized. You can modify the file again and save it as an HTML file without the loss of any HTML code. If you modify the file and save it in Office Excel file format, the HTML tags are not retained.

A section exported to a Microsoft Office 2000 HTML (.html) file format has the main web page saved in one folder and all the graphics and other related information (such as VBA macros) in another.

Microsoft Office 2000 Web Archive (.mhtml or .mhtml) refers to MS HTML, which is a standard for including objects in the same file as the HTML code (for example .gif or .jpeg files). Objects are encoded using the MIME HTML Internet standard. You might use this file format if you plan to e-mail the HTML as a single file.

**Note:**

Any changes made to the section through the HTML Wizard are not recognized when it is exported to Microsoft Office 2000 HTML.

### Types of HTML File Formats

Interactive Reporting supports three HTML file formats to which a section can be exported:

- Microsoft Office 2000 HTML (*.html)
- Microsoft Office Web Archive (*.mhtml)
- Standard HTML (*.html)

The export features are supported in the following sections:

- Tables and Results
- Chart
- Pivot
- Report

The Dashboard section cannot be exported.

To export a section in Microsoft Office file format:

1. **Select File > Export > Section.**
   - The Export Section dialog box is displayed.

2. **Specify the name of the section in the File name field.**

3. **Select the HTML file format for the section to be exported in the Save as type field.**
   - Valid HTML file formats are:
Comparison of HTML File Format Types

The following table shows which export attributes are supported by the HTML file format.

Table 1  Comparison of HTML File Formats

<table>
<thead>
<tr>
<th>Section</th>
<th>Office HTML Export to Office Excel</th>
<th>Standard HTML Export to Excel</th>
</tr>
</thead>
<tbody>
<tr>
<td>Results/Table</td>
<td>Formatting is preserved.</td>
<td>Formatting is not preserved.</td>
</tr>
<tr>
<td></td>
<td>Formulas are supported. (See Formula Mappings).</td>
<td>Formulas are not supported.</td>
</tr>
<tr>
<td>Pivot</td>
<td>Export preserves formatting.</td>
<td>Export does preserve formatting.</td>
</tr>
<tr>
<td></td>
<td>Cell merging is supported.</td>
<td>Export does not support formulas.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Cell margins are not supported.</td>
</tr>
<tr>
<td>Chart</td>
<td>The Chart section is written to two worksheets: the first worksheet contains the Chart data in a table, and the second worksheet contains the Chart image. Exported Chart data is aggregated in the same way as in the original Chart section.</td>
<td>The Chart data is written to a simple table.</td>
</tr>
<tr>
<td></td>
<td><strong>Tip:</strong> When a Chart section has been exported to Excel, you can use the data in the table as a data source and launch the Excel Chart Wizard to create the actual Chart. The rendered Chart looks the same as the one created in Interactive Reporting Studio.</td>
<td></td>
</tr>
<tr>
<td>Report</td>
<td>The Report data is written to a simple table. If a report has only one table or one pivot (no matter how many pictures and or text labels are in the report), column widths are preserved. Otherwise column widths are not maintained. Column width, in this case, is resized to fit data from any table. Formatting is preserved. Report elements including: text, labels, images, tables, pivots, and charts are placed one after another vertically. A vertical gap of a certain fixed height exists between two elements. If elements overlap vertically by a small value, these elements are shown with no gap between them. This is to accommodate any design that includes stacked elements. The gap is one row high. Report headers/footers are output. Graphical elements such as lines, circles are not supported.</td>
<td>The Report data is written to a simple table.</td>
</tr>
</tbody>
</table>
Exporting a Section to Microsoft Office Excel Worksheets

Each exported section to Microsoft Office HTML creates one worksheet in the Excel workbook even when there are multiple sections. Exported sections of the same Interactive Reporting document do not reference each other in the Excel worksheet. For example if a Table section is created from a Results section, both exported sections are displayed as independent worksheets in Excel.

An Internet Explorer browser can show more than 65,536 rows, and an Excel spreadsheet has 256 columns and a maximum of 65,536 rows. If an exported section has more rows than the Excel row maximum, all rows are exported to the source rows available, but only 65,536 rows are processed for Excel to process any formulas. In this case, Excel truncates the exported data in the section.

Number and Date Formats

Number and date formats in Interactive Reporting sections are exported based on the following predicates:

- Any text within Reporting and Analysis format strings is enclosed double-quotes (""").
- Interactive Reporting fills the number formats for positive, negative, and zero numbers to achieve compatibility with Excel’s construction. Excel number format definition consists of the above number formats, delimited with a semi-colon.
- Date/time formats are exported as is except for the am/pm format, which receives a special format.
- Thousands and decimal separators are converted to Excel special symbols based on the default Reporting and Analysis locale format. When the number format is evaluated, the decimal separator converts to "." (a period) and the thousand separator becomes “,” (a comma) in the target Excel format. Excel treats these special symbols as locale independent separators and replaces them with actual separators from the user’s locale at run-time.
- A value in an Excel cell has two aspects: the value formatted for displaying and the original value. Similarly when a value is placed in a HTML table, a special attribute x:num="<actual value>" is used to preserve the original value. The pre-formatted value is placed in a cell of the HTML table, and it can be shown in the web browser. Formulas operate with the original values. The x:str attribute is used as a global designator in an html <table> in order to tell...
Excel that all the values which do not have x:num attribute specified should be treated as strings. This is useful when there is mixed string and numeric data in a string type column. The third component associated with an HTML table cell is a style class. It is used to specify the custom numeric format for a cell value. Date and time values are represented as numbers. These values are saved in the x:num attribute, and the style class definition specifies the format for date.

**Styles**

Exported sections support styles (CSS) that have been applied to the section including: font name and size, and bold/italic properties.

Overline and double overline properties are not supported in Excel, because Excel has no equivalent styles.

The simple overline style is supported in a browser; the double overline is not. In addition, the overline applies only to the text, not the whole cell as in Interactive Reporting Studio.

The Spotlighter feature is not supported in Excel. The appearance of a cell to which the spotlighter has been applied, retains the same look as in the exported spreadsheet, but without the real auto-formatting. Excel has an equivalent feature called Conditional Formatting. This feature can use a formula returning a Boolean result as a condition.

**Colors**

Excel supports a fifty-six color palette of which sixteen are used exclusively for Charts, and forty for cells in a spreadsheet. Colors can be defined by using RGB notation, and are shared among all worksheets in a workbook.

All colors displayed in the sections being exported are saved as a custom palette and saved in the HTML file (in a hidden xml section). By default Excel uses the color palette as a baseline for creating a custom palette. The colors that match Excel’s colors retain their positions. Unused positions are filled by default Excel colors.

Excel automatically determines which index in the color palette to use for a particular color occurring in CSS.

If the total number of colors is more than forty, Excel determines the color placement.

**Text Wrapping**

If text wrapping is disabled in Interactive Reporting Studio and the section is exported, Excel sizes the column to display all values within a row. Words that do not fit into the cell are wrapped to the next line and are not visible. In the browser, the text is truncated.

**Chart as Image**

A worksheet containing a chart image shows no cell grid.
Charts larger than a single image (chart scrolling is enabled) are placed on a single worksheet, and page breaks are provided. Each image is printed on its own page.

**Headers and Footers**

Headers and footers are converted into appropriate Excel equivalents, and are displayed in a printed document. In addition, the format template is converted to the Excel format. Multiple headers and footers are supported, but they are converted into a single multi-line header or footer.

Headers and footers are not displayed when the exported section is opened in a browser.

**Printing Improvements**

Results, Table, and Pivot sections are exported so that the table headings and pivot top and side labels are marked. These marks allow headings and labels to be duplicated on each page when they are printed from Excel.

**Suppress Duplicates for Results or Table**

The Suppress Duplicate feature hides duplicate values in a selected column but includes them in calculations. Hidden values can be seen and changed only by clicking the cell in Excel. Typing any new value does not change the hidden status of the cell unless the user changes the cell format.

**Formula Generation**

An exported Interactive Reporting document table section can have the following kinds of JavaScript expressions:

- Grand/Break Total calculation (for example, Sum(Units, Breaks) + 10)
- Grand/Break Total labels (for example, "Total " + ToChar(Store))
- Computed Item expressions (for example, Units*2 + 10)

When exporting a table with expressions, the following steps are performed:

- Values that are calculated using formulas are exported to HTML, and available to be shown in a web browser.
- Excel formulas are generated for each cell in the table and written to HTML. This file can be opened in Excel and all values are re-calculated. An end-user can change values in the cells and results are re-calculated again.
JavaScript Expressions

JavaScript expressions used with the Export to HTML feature can refer to columns in the table and invoke computed items. They can also refer to any JavaScript class like Math and String. Those computed items which do not have direct equivalent among the built-in Excel functions are simulated by custom VB functions. See “Formula Mappings” on page 55 for computed item to Excel built-in function mappings.

If the expression refers to a JavaScript class not supported by the Export feature, #NAME? is displayed in the Excel cell (and as a valid value in the web browser) and the Error Office html tag attribute is used. In addition, a comment is added to the cell explaining the error. In Excel, this comment is displayed near the cell where the error occurred. In the browser, the comment is displayed when you hover the mouse pointer over a cell with a small red-colored corner.

Mapping JavaScript to Excel

Interactive Reporting uses a translator to distinguish between the range types used to substitute a column reference in a computed item expression. There are three types of ranges:

- Continuous range corresponding to the whole column (for example, Units)
- Aggregate range – this is a continuous range that is broken by Break Totals (for example Units_Agg). The only purpose of this range is as a data source for aggregate functions. The translator uses Units in all kind of expressions that refer to the column, but it uses Units_Agg range for aggregate functions, for example, SUM(Units_Agg).
- Continuous sub-range used in break total computation.
- Individual cell references (for example, A1, B5)

The table below outlines how the JavaScript expression operations are mapped to Excel.

<table>
<thead>
<tr>
<th>JavaScript</th>
<th>MS Excel</th>
</tr>
</thead>
<tbody>
<tr>
<td>*, / , &lt;=, =&gt;, -, + (arithmetical plus operator)</td>
<td>Uses the same symbols.</td>
</tr>
<tr>
<td>%</td>
<td>MOD() built-in function</td>
</tr>
<tr>
<td>!=</td>
<td>&lt;&gt;</td>
</tr>
<tr>
<td>==</td>
<td>=</td>
</tr>
<tr>
<td>+ (concatenation operator)</td>
<td>&amp;</td>
</tr>
<tr>
<td>Exp1? Exp2: Exp3 (ternary operator)</td>
<td>IF(Exp1, Exp2, Exp3)</td>
</tr>
<tr>
<td>Comma operator (e.g. exp1, exp2, ..., expN)</td>
<td>Replaced with the last expression. For example, (exp1, exp2, ..., expN) -&gt; is replaced with expN in resulting Excel formulas. Expressions should be of the same type (expression or string)</td>
</tr>
<tr>
<td>!</td>
<td>NOT() built-in function</td>
</tr>
</tbody>
</table>
The JavaScript `+` operator can be applied to strings and denotes a string concatenation. Excel’s string concatenation operator is `&`. Interactive Reporting distinguishes between arithmetic `+` and string `+` by tracking the type of arguments in expressions. If one of the arguments is a string literal, a concatenation operator is used. The translator tracks the return type of Object Model functions and columns, so it can infer a final expression type. There are three supported types: numeric, string, and date.

**Formula Mappings**

Most of the computed items that comprise computed item expressions can be mapped directly to Excel functions. Certain functions have different numbers of arguments or argument order and require additional processing.

The following table shows which Interactive Reporting computed items map to Excel formulas.

<table>
<thead>
<tr>
<th>Interactive Reporting Computed Item</th>
<th>Microsoft Excel Function</th>
<th>Implementation</th>
<th>Aggregation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Decode</td>
<td>H_Decode</td>
<td>VBA</td>
<td></td>
</tr>
<tr>
<td>Nvl</td>
<td>Limited support: Nvl(column, expr).</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>AddMonth</td>
<td>H_AddMonth</td>
<td>VBA</td>
<td></td>
</tr>
<tr>
<td>DayOfMonth</td>
<td>DAY</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>LastDay</td>
<td>H_LastDay</td>
<td>VBA</td>
<td></td>
</tr>
<tr>
<td>MonthsBetween</td>
<td>H_MonthsBetween</td>
<td>VBA</td>
<td></td>
</tr>
<tr>
<td>NextDay</td>
<td>H_NextDay</td>
<td>VBA</td>
<td></td>
</tr>
<tr>
<td>Interactive Reporting Computed Item</td>
<td>Microsoft Excel Function</td>
<td>Implementation</td>
<td>Aggregation</td>
</tr>
<tr>
<td>------------------------------------</td>
<td>--------------------------</td>
<td>----------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Sysdate</td>
<td>NOW</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>ToChar(value, format)</td>
<td>Limited Support: Excel’s built-in TEXT(val, format) function is used and the format argument is translated from the Reporting and Analysis format into Excel’s on the formula generation time. Consequently, the format should always be a constant string literal.</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>ToChar(column)</td>
<td>When the argument for ToChar is a column reference, it is converted to TEXT(column, format), where format is one of real, int, or date_format depending on the column type.</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>ToDate(x)</td>
<td>(DATEVALUE(x) + TIMEVALUE(x))</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>ToMonth</td>
<td>H_ToMonth</td>
<td>VBA</td>
<td></td>
</tr>
<tr>
<td>ToQtr</td>
<td>H_ToQtr</td>
<td>VBA</td>
<td></td>
</tr>
<tr>
<td>ToYear</td>
<td>YEAR</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Abs</td>
<td>ABS</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Atn</td>
<td>ATAN</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Ceiling</td>
<td>H_Ceil</td>
<td>VBA</td>
<td></td>
</tr>
<tr>
<td>Cos</td>
<td>COS</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Cosh</td>
<td>COSH</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Exp</td>
<td>EXP</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Floor</td>
<td>H_Floor</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Ln</td>
<td>LN</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Log</td>
<td>LOG</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Log10</td>
<td>LOG10</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Max</td>
<td>MAX</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Min</td>
<td>MIN</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Mod</td>
<td>H_MOD</td>
<td>VBA</td>
<td></td>
</tr>
<tr>
<td>Power</td>
<td>POWER</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Interactive Reporting Computed Item</td>
<td>Microsoft Excel Function</td>
<td>Implementation</td>
<td>Aggregation</td>
</tr>
<tr>
<td>-------------------------------------</td>
<td>--------------------------</td>
<td>----------------</td>
<td>------------</td>
</tr>
<tr>
<td>Round</td>
<td>ROUND</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Sign</td>
<td>SIGN</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Sin</td>
<td>SIN</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Sinh</td>
<td>SINH</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Tan</td>
<td>TAN</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Tanh</td>
<td>TANH</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Trunc</td>
<td>TRUNC</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Avg</td>
<td>H_Avg</td>
<td>VBA</td>
<td>+</td>
</tr>
<tr>
<td>AvgNonNull</td>
<td>AVERAGE</td>
<td>Excel</td>
<td>+</td>
</tr>
<tr>
<td>Chr</td>
<td>H_Chr</td>
<td>VBA</td>
<td></td>
</tr>
<tr>
<td>ColMax</td>
<td>H_ColMax</td>
<td>VBA</td>
<td>+</td>
</tr>
<tr>
<td>ColMin</td>
<td>H_ColMin</td>
<td>VBA</td>
<td>+</td>
</tr>
<tr>
<td>Count</td>
<td>H_Count</td>
<td>VBA</td>
<td>+</td>
</tr>
<tr>
<td>CountDistinct</td>
<td>H_CountDistinct</td>
<td>VBA/Excel</td>
<td>+</td>
</tr>
<tr>
<td>CountNonNull</td>
<td>COUNTA</td>
<td>Excel</td>
<td>+</td>
</tr>
<tr>
<td>CountNull</td>
<td>H_CountNull</td>
<td>VBA</td>
<td>+</td>
</tr>
<tr>
<td>Cume</td>
<td>Computed Items with expressions that have exactly one call to Cume() and nothing else. Example: &quot;Cume(Units)&quot;</td>
<td>Excel/VBA</td>
<td>Aggregation and cross references in rows</td>
</tr>
<tr>
<td>Next</td>
<td>Function call is converted to appropriate cell reference. Limited support: Cannot be used in a Break or Grand Total expression.</td>
<td>Excel/VBA</td>
<td>Cross references in rows</td>
</tr>
<tr>
<td>Prior</td>
<td>Function call is converted to appropriate cell reference. Limited support: Cannot be used in a break or grand total expression.</td>
<td>Excel</td>
<td>Cross references in rows</td>
</tr>
<tr>
<td>Interactive Reporting Computed Item</td>
<td>Microsoft Excel Function</td>
<td>Implementation</td>
<td>Aggregation</td>
</tr>
<tr>
<td>------------------------------------</td>
<td>--------------------------</td>
<td>----------------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| Sum                                | Use Excel’s SUM() for non-string columns.  
String columns exception: H_SumStr() is used. Can be used in break and grand totals only. There may be performance considerations associated with this computed item because it uses heavy computations. | Excel/VBA | * |
<p>| Median                             | MEDIAN                   | Excel          | * |
| Mode                               | H_Mode                   | VBA            | * |
| Percentile                         | H_Percentile             | VBA            | * |
| Rank(column)                       | H-Rank                   | VBA            | * |
| RankAsc(column)                    | H-RankAsc                | VBA            | * |
| StdDev                             | H-StdDev                 | VBAI           | * |
| StdDevp                            | H_StdDevp                | VBA            | * |
| Var                                | Var                      | VBA            | * |
| Varp                               | Varp                     | VBA            | * |
| Ascii                              | CODE                     | Excel          |           |</p>
<table>
<thead>
<tr>
<th>Interactive Reporting Computed Item</th>
<th>Microsoft Excel Function</th>
<th>Implementation</th>
<th>Aggregation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Concat</td>
<td>CONCATENATE</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Initcap</td>
<td>H_Initcap</td>
<td>VBA</td>
<td></td>
</tr>
<tr>
<td>Instr</td>
<td>H_Instr</td>
<td>VBA</td>
<td></td>
</tr>
<tr>
<td>Length</td>
<td>LEN</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Lower</td>
<td>LOWER</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Ltrim</td>
<td>H_Ltrim</td>
<td>VBA</td>
<td></td>
</tr>
<tr>
<td>Replace</td>
<td>H_Replace</td>
<td>VBA</td>
<td></td>
</tr>
<tr>
<td>Rtrim</td>
<td>H_Rtrim</td>
<td>VBA</td>
<td></td>
</tr>
<tr>
<td>Substr</td>
<td>MID</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>Translate</td>
<td>H_Translate</td>
<td>VBA</td>
<td></td>
</tr>
<tr>
<td>Upper</td>
<td>UPPER</td>
<td>Excel</td>
<td></td>
</tr>
<tr>
<td>MovingAvg</td>
<td>H_MovingAvg</td>
<td>VBA</td>
<td>Cross references in rows</td>
</tr>
<tr>
<td>MovingDiff</td>
<td>H_MovingDiff</td>
<td>VBA</td>
<td>Cross references in rows</td>
</tr>
<tr>
<td>MovingMax</td>
<td>H_MovingMax</td>
<td>VBA</td>
<td>Cross references in rows</td>
</tr>
<tr>
<td>MovingMed</td>
<td>H_MovingMed</td>
<td>VBA</td>
<td>Cross references in rows</td>
</tr>
<tr>
<td>MovingMin</td>
<td>H_MovingMin</td>
<td>VBA</td>
<td>Cross references in rows</td>
</tr>
<tr>
<td>MovingSum</td>
<td>H_MovingSum</td>
<td>VBA</td>
<td>Cross references in rows</td>
</tr>
<tr>
<td>All aggregate functions with two and three arguments: Ex. Sum (col, break_col, break_value)</td>
<td>When two argument functions are used in break or grand total expressions and the second argument is ‘Breaks’, most of the functions are converted to their built-in Excel equivalents. Otherwise, the function is substituted with the appropriate H_xxx() VBA function.</td>
<td>Excel/VBA</td>
<td></td>
</tr>
</tbody>
</table>

**Custom Formulas**

Interactive Reporting has a number of computed items that do not map directly to an equivalent Excel function. This section describes the methods the Export feature uses to construct a mapping from the computed item to an Excel function.
Adding VBA functions to the Exported Excel File

Interactive Reporting helper functions implemented in Visual Basic are saved to the exported file. In this instance, the Excel file becomes self-contained. It can be passed to any user as is and does not require installing additional components such as Excel add-ins. All the functions are implemented within this file.

Since VBA functions are treated in Excel as macros, Interactive Reporting signs them digitally in order to prevent a security warning dialog box in Excel if the macro security level is medium or high. When the macros are signed, you can observe certification information and choose to trust the sources. Once the certificate is marked as trusted, all subsequent openings of exported Excel files proceed silently.

Unsupported Formulas

The Excel formula content limit length is 1,024 characters.

Null Values

In Interactive Reporting, a null value is a cell absent of data, but which does not equal zero. Cells that are absent of data are represented by blank cells. Excel does not recognize null values, but has a similar concept. There are also built-in aggregation functions analogs which understand this concept.

Custom Cell Ranges

Named cell ranges are generated to construct Excel formulas for computed items in the spreadsheet. For example, if there is a Table section with Break Totals, then the following types of named ranges are generated:

- A continuous cell range that includes the whole column For example: Units = Results!$C$2:$C$998. This range can be used in all kinds of formula expressions, but cannot be passed to aggregate functions like SUM.

- A compound or broken cell range that includes all the cells with actual data excluding those occupied by Total information For example: Units_Agg = Results!$C$2:$C$4,Results!$C$6:$C$34,Results!$C$36:$C$164. This range can be passed to aggregate functions, which is reflected in its the name.

- A cell range used in break totals calculations For example: Sr_32_2=Results!$C$2:$C$4

Below is a sample spreadsheet generated from the Results section. The column Computed of the section contained Units*2 expression, the column Computed2 contained SUM(Units) expression. The generated Excel formulas are shown in the cells.
For the Excel user, the Auto Outlining feature can be used to create row groups from the Break Totals that Interactive Reporting creates. Excel analyzes the formulas and creates the row groups and outline automatically. The user can then expand or collapse individual groups of rows.

Named cell ranges created in Interactive Reporting can be used for in-sheet formulas and in an external Excel file (worksheet linking). For example, an end user can create a new Excel file and enter a cell formula that refers to a data column of the workbook file exported from Interactive Reporting. For example, an end-user might enter: \( =\text{SUM(BIExport.xls!Results_Units_Agg)} \), where Results_Units_Agg is an auto-generated range that denotes the Units column of the Results table in the BIExport.xls file.

### Worksheet Names and Range Names Generation

Worksheet names are based on the Interactive Reporting document section names. Before exporting a section, consider the following limitations that apply to worksheet names:

- The name of section to be exported should not be longer than thirty-one characters.
- The symbols / \ ? * are not allowed and are removed.
- Duplicate worksheet names are appended with a number to ensure the uniqueness of each worksheet.
- A worksheet name can include space symbols. When such a worksheet name is used in formulas, it should be surrounded with single quotation marks.

Generated range names that correspond to Interactive Reporting document table columns are based on a respective column name. The following restrictions apply to generated range names:

- The worksheet name is added to the beginning of the range name to ensure its uniqueness within the whole workbook.
- Spaces within the name are replaced by underscores.
- The symbols ~!@#$%^&*()_+|{}:"<>?`-=\[];',./ are not allowed and are removed.
- Duplicate range names are appended with a number to ensure the uniqueness of each range name.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Store</td>
<td>Item Name</td>
<td>Units</td>
<td>Computed</td>
</tr>
<tr>
<td>2</td>
<td>Bayshore Electronics</td>
<td>1024 MB Drive</td>
<td>45</td>
<td>=Units*2</td>
</tr>
<tr>
<td>3</td>
<td>Bayshore Electronics</td>
<td>EZ Fax Modern-I</td>
<td>30</td>
<td>60</td>
</tr>
<tr>
<td>4</td>
<td>Bayshore Electronics</td>
<td>EZ Fax Modern-x</td>
<td>45</td>
<td>90</td>
</tr>
<tr>
<td>5</td>
<td>Bayshore Electronics</td>
<td>One Button Mouse-</td>
<td>30</td>
<td>60</td>
</tr>
<tr>
<td>6</td>
<td>Bayshore Electronics</td>
<td>The Quad</td>
<td>35</td>
<td>70</td>
</tr>
<tr>
<td>7</td>
<td>Bayshore Electronics</td>
<td>One Button</td>
<td>30</td>
<td>60</td>
</tr>
<tr>
<td>8</td>
<td>Bayshore Electronics</td>
<td>One Button Mouse-</td>
<td>40</td>
<td>80</td>
</tr>
<tr>
<td>9</td>
<td>Bayshore Electronics</td>
<td>One Button Mouse-</td>
<td>35</td>
<td>70</td>
</tr>
<tr>
<td>10</td>
<td>Total Bayshore Electronics</td>
<td></td>
<td>475</td>
<td>=SUM(SUM_13_2)</td>
</tr>
</tbody>
</table>
Columns must have appropriate identifiers in JavaScript, for instance, an Order Date column can be referred to as Order_Date in a computed item expression. This identifier is used as the main part of a generated range name.

Excel has a limitation on the length of the expression used as a named range. The total length of the references (not including worksheet names) cannot be more than 255 characters. When a named range is generated, its content is broken into smaller chunks, each comprising a smaller named range. The final range is a union of these smaller ranges.

**Exporting a Document as a Web Page**

Use the Export Document As Web Page command to publish the contents of Interactive Reporting documents as web pages. You can select which sections of the current document to include in the export set.

Documents sections are exported in the same order as they are displayed in the Interactive Reporting document. Exportable document sections include: Results, Table, Pivot, Chart, OLAPQuery, and reports created with the Report Designer. Imported sections that have been added to the document, such as text files and Excel files, can also be exported. Data models and the Query, and Dashboard sections are not exportable. Neither are empty or blank sections. After these files are posted to a Web site, you can access the files individually or use the main HTML file to view the frameset, which lists the sections in the report. The exported Web pages include navigation buttons so you can scroll back and forth between pages, or jump to the beginning or end of a document. In addition, the current page number and total number of pages are included in the report.

**Note:**

The Export As HTML and HTML Wizard options in prior versions of Interactive Reporting remain unchanged. However, we recommend that you use the Export As Web Page option.

To export Interactive Reporting documents as Web pages:

1. **Select File > Export > Document As Web Page.**
   The Export Document As Web Page dialog box is displayed.

2. **Select the sections of the document to be exported and click OK.**
   To select all sections, click **Select All**. To clear all selected sections, click **Deselect All**.
   The Save As Type dialog box is displayed.

3. **Navigate to the location where you want to save your Web page.**

   **Tip:**
   Create a separate folder to store the files created by this export option.

4. **Type a name for the exported Web page in the File Name field, or accept the default name, for example Sample1.htm.**
The Save As Type field is set to *.htm by default. All of the HTML files that the export process creates begin with the name specified in the File Name field, for example, Sample1Chart.htm, Sample1Pivot.htm, and so on. The HTML file with the exact same name as the name specified in the File Name field is the main HTML page, and it contains the frameset and links to all of the other pages, for example Sample1.htm.

5 Click Save.

To view the exported selection, open your Web browser, select File > Open, browse to the location of the exported files, and open the main HTML page.

**Saving an Excel file to HTML format**

If you plan to import an HTML file that was created from Excel, note:

- Prior to saving an Excel file to HTML format, turn off Excel’s password protect feature.
- Formulas are saved as sheet references in Excel. When an Excel workbook is saved to HTML workbook, formulas linked to a cell in the HTML workbook do not operate.
- Custom view and scenarios can only be used in Excel.
- Add-ins and templates are only available in Excel.

**Browser and HTML Restrictions and Limitations**

Browser and HTML restrictions may affect how graphics and formatting are displayed on Web pages created by exporting document sections. The known restrictions and limitations are:

- Diagonal lines, ovals, round rectangles, and dotted or dashed lines do not export to the Web page. Overline or double-overline text is displayed as regular text.
- The Netscape browser shows data formatted with bold Arial 8 pt. as regular Arial 8 pt.
- Data formatted with Arial 14 pt. is displayed smaller in Interactive Reporting and Netscape than in Microsoft Word and Internet Explorer.
- Border properties (including color properties) are supported in Microsoft Internet Explorer, but not in Netscape. Consequently, border properties for the Results, Table, and Pivot sections are not displayed on Web pages opened with Netscape. If you embed a Results, Table, or Pivot section in a report, Netscape does recognizes the border properties.
- Raised and sunken borders are displayed as regular borders.
- Lines and rectangles are not displayed in reports in UNIX browsers.
- The right border of a table embedded in a report sometimes is displayed thicker in Netscape.
- The Picture Tile property is not supported by HTML.
- Word-wrapped fields contain hard-coded leading spaces for left padding. HTML permits the browser to implement word-wrap, but eliminates extraneous space. In addition, a browser word-wrap feature does not break a word in the middle of a word regardless of its length.
- When empty table cells are displayed with a certain font, it is because Interactive Reporting inserts a single blank into each empty cell. HTML requires a single value in each empty cell.
HTML does not recognize vertical text.

**Using the Export to HTML Wizard**

The Export to HTML Wizard helps you create Web pages from charts, reports, and pivot tables.

*Note:*

We suggest you use the Export Document As Web Page command (see “Exporting a Document as a Web Page” on page 62) rather than the HTML Wizard.

➤ To use the Export to HTML Wizard, select **File > Export > HTML Wizard**.

**Exporting SQL**

Use the Export SQL command to export the SQL statement for your query. The file is saved in an SQL format.

➤ To export SQL:

1. **Select File > Export > SQL**.
   
The Export SQL File dialog box is displayed.
2. **Specify the file name and location and click Save**.

**Exporting a Query Log**

When you process a query, Interactive Reporting translates your request into SQL or a multidimensional database query statement and forwards it to the database server.

➤ To save the contents of the SQL log to a text file:

1. **Select File > Export > Query Log**.
   
The Export Query Log dialog box is displayed.
2. **Specify the file name and location, and click Save**.

**Exporting Scripts To a Text File**

Use the Export Scripts To Text File command to export JavaScript code and associated events contained in an Interactive Reporting document to a text file (TXT). Interactive Reporting categorizes the text file by object name and events, and includes document and custom menu item scripts.

➤ To export a script to a text file:

1. **Select File > Export > Script To Text File**.
The Export Script dialog box is displayed.

2 Specify the file name and location, and click Save.

### Printing Documents

Printing functions are available for most document sections. You can specify the page setup for your printer, print directly to a printer, or preview a print job on-screen.

#### Page Setup

Use the Page Setup command to specify the default printer for the Interactive Reporting document and to define default page properties.

➤ To define page setup information, select File > Page Setup.

#### Print Preview

Use the Print Preview command to view on-screen a representation of the printed version of a finished report. The Print Preview command is available for all sections except the Dashboard. In the Report Designer section, the page view of the report is a direct representation of the printed report.

➤ To preview a section before sending it to a printer, select File > Print Preview.

A preview of the current section is displayed in the Content pane, and a Print Preview menu is added to the Main menu. Use the commands on the Print Preview menu to navigate through the preview pages and to specify starting page numbers.

#### Print

Use the Print command to print the information displayed in the Content pane of most sections.

➤ To print the information in the document, select File > Print.

### Sending Documents

You can attach documents to your electronic mail (email) if you have a MAPI-compliant email system such as Microsoft Mail or Microsoft Exchange.

➤ To email a document:

1 Select File > Send.

   The Mail Document window is displayed.

2 Select the name of the document recipient.
You can send the document with or without the results. Sending an Interactive Reporting
document with the results enables the recipient to do further analysis.

A document sent without the results contains snapshots of the Chart, Pivot, and other reporting
sections, but not reports created in the Report section. No further analysis is possible.

3 Copy other recipients or include additional remarks and click Send It.

Quitting Interactive Reporting Studio

If documents remain open, you are prompted to save changes to each document before it shuts
down.

➢ To end Interactive Reporting Studio, select File > Exit.

Quitting Interactive Reporting Web Client

If documents remain open, Interactive Reporting Web Client prompts you to save changes to
each document before closing it.

➢ To end your work session in Interactive Reporting Web Client, select File > Close.

Using Edit Commands

The Edit menu contains standard editing commands. It also contains commands that allow you
to work with document sections.

Changing Views

The View menu allows you to toggle the display of interface elements, such as panes, toolbars,
and so on. It also provides commands for working with sections.

Inserting Sections and Breaks

Use the Insert menu to insert new sections in the Interactive Reporting document. You can also
insert page headers and footers for use when printing certain sections.

Note:

See “Formatting Numeric Data Types” on page 67 for detailed information on adding
document sections and customizing the headers and footers in the document sections.
Formatting Text and Other Elements

Use the commands on the Format menu to change the formatting properties of text, numbers, borders, rows, columns, exported documents, and so on. Most of these commands can also be found on the Formatting toolbar.

Note:
See “Formatting Numeric Data Types” on page 67 for detailed information on working with document sections.

Working with the Tools Menu

Use the options on the Tools menu to:
- Process queries
- Specify connection information
- Launch Dashboard Studio or Dashboard Architect
- Define program and default font options
- Customize menus
- Launch the Resource Manager

Formatting Numeric Data Types

Formatting numeric data types include:
- “Changing Numeric Formatting” on page 67
- “Displaying Numbers in Scientific Notation” on page 67

Changing Numeric Formatting

You can change the formatting properties of numeric data types (real and integer) in the following ways:
- Select an object, right-click to access the Number shortcut menu, and select a numeric formatting option from the menu.
- Use the buttons on the right-hand side of the Formatting toolbar.

Displaying Numbers in Scientific Notation

Interactive Reporting enables you to display numbers in scientific notation. The default scientific notation format is:

0.00E+000
The scientific notation format is displayed using the appropriate decimal separator for the current local. (The above example uses a period as the decimal separator.)

The following table describes the acceptable variations on the default scientific notation format:

<table>
<thead>
<tr>
<th>Variation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>The number of decimal positions after the decimal separator.</td>
<td>For example, 0.00000E+000 displays six digits of precision.</td>
</tr>
<tr>
<td>#</td>
<td>Used after the decimal point to suppress zeros. For example, the value .000179 with the format 0.00000E-00 displays as 1.79000E-04. With the format 0.0####E-00, the same value displays as 1.79E-04.</td>
</tr>
<tr>
<td>E or e</td>
<td>Controls the case in which the exponent designator displays.</td>
</tr>
<tr>
<td>0 E+0 E-0 (and the lower case equivalents)</td>
<td>If the plus sign is used, the exponential component always displays with a sign (plus or minus). If the minus sign or no sign is used, the sign displays only when negative.</td>
</tr>
<tr>
<td>E+0 to E+000</td>
<td>The number of zeros following the E or e, with or without a sign character, is the minimum number of digits to display for the exponent. For example, the value 179 displays as 1.79E2 with the format 0.00E0 and as 1.79e002 with the format 0.00e000. If the minimum number of digits is not adequate to represent the magnitude of the number, additional digits are added as required. For example, the value 1,789,000,000,000 with the format 0.00E0 displays as 1.79E12.</td>
</tr>
<tr>
<td>Leading + or – sign</td>
<td>A leading minus sign (or no sign character) displays a sign only if the precision of the number is negative. The appropriate sign always displays if the plus character leads the string.</td>
</tr>
</tbody>
</table>

Note:
You cannot apply scientific notation to non-numeric data types. If you try to do so, the formatting remains the same.

Numeric formatting buttons on the Formatting toolbar are shown in below:

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="#" alt="Currency" /></td>
<td><strong>Currency</strong> - Applies currency formatting to the selected numeric object(s). The currency formatting applied is the first currency type for the selected locale specified in the BQFORMAT.INI file. To display all the available currency types for the current local, click the arrow to the right of the Currency button. <strong>Note</strong>: The Currency button is ignored if the selected object is not of a numeric type (real or integer).</td>
</tr>
<tr>
<td><img src="#" alt="Percentage" /></td>
<td><strong>Percentage</strong> - Applies percentage formatting to the selected numeric object(s). The percentage formatting applied is the first percentage format for the selected locale specified in the BQFORMAT.INI file. To display</td>
</tr>
<tr>
<td>Button</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
|        | all the available percentage formats for the current local, click the arrow to the right of the Percentage button.  
**Note:** The Percentage button is ignored if the selected object is not of a numeric type (real or integer). |
| ![Comma Formatting] | **Comma Formatting** - Toggles the presence of the thousands-separator character on or off. If on, comma formatting inserts the thousands-separator character into the current format string for the selected object. The thousands-separator character is inserted based on current locale settings.  
**Note:** Comma formatting does not affect numbers formatted with scientific notation. |
| ![Decimal Increase] | **Decimal Increase** - Increases the number of displayed digits after the decimal point (or its locale-specific equivalent).  
For example, if the current format for the field specifies three decimal digits, such as $#.000, pressing Decimal Increase modifies the format to $#.0000.  
Pressing Decimal Increase when the number of decimal positions is zero adds the decimal separator character in addition to the one decimal digit. For example, if the format is ##%, pressing Decimal Increase changes the format to ##.0%.  
**Note:** The Decimal Increase button is ignored if the selected object is not of a numeric type (real or integer). |
| ![Decimal Decrease] | **Decimal Decrease** - Decreases the number of displayed digits after the decimal point (or its locale-specific equivalent).  
For example, if the current format for the field specifies three decimal digits, such as $#.000, pressing Decimal Decrease modifies the format to $#.0.  
If the number of decimal positions goes from one to zero when pressing Decimal Decrease, the decimal separator is no longer part of the format. Pressing Decimal Decrease when the number of decimal positions is already at zero results in no action.  
**Note:** The Decimal Decrease button is ignored if the selected object is not of a numeric type (real or integer). |

---

**Working with Document Sections**

Working with document sections involves the tasks described in these topics:

- “Understanding Document Sections” on page 70
- “Adding Sections” on page 70
- “Viewing Sections” on page 70
- “Moving Between Sections” on page 71
- “Duplicating Sections” on page 71
- “Renaming Sections” on page 71
- “Adding Headers and Footers to Sections” on page 72
- “Deleting Sections” on page 72
Understanding Document Sections

Documents are divided into multiple sections, each of which governs one step of the query and reporting procedure. You create sections progressively as you query a database, retrieve results, and generate reports.

A document usually includes Query and Results sections. From the Results section, you can create multiple Pivot, Chart, Table and Report sections to analyze and present data. You can also create Dashboard sections, which provide an automated push-button interface to a document.

Each section occupies an independent window and performs distinct operations. You can move back and forth between sections at any time to rebuild your query or alter your result data. You can also position sections side-by-side in multiple windows.

To see a graphical representation of a document section, click the desired section name in the Section pane.

Adding Sections

➤ To insert a new section in a document, select Insert > New Section.

For example, to insert a new Chart, select Insert > Chart, to insert a new Table, select Insert > Table.

Interactive Reporting inserts the new section and adds a new section label to the Section pane. The section label is based on the type of section added. A sequence number is added to the section label if a section with the same name already exists.

Viewing Sections

You can hide sections to simplify your view of the work area. This allows you to concentrate on specific sections.

➤ To hide a section:

1 In the Section pane, select the section to hide.

2 Select View > Hide Section.

➤ To view a hidden section:

1 Select View > Unhide Section.

The Unhide Sections dialog box is displayed.

2 Select the hidden section to view and click OK.

The section is displayed in the Section pane.
Moving Between Sections

Although each section occupies an independent window and performs distinct operations, you can move back and forth between sections at any time to rebuild your query or alter your results data. You can also position sections side-by-side in multiple windows.

You can easily navigate between sections to work on queries, results, and reports.

To move between sections, use one of the following options:

- Select the desired section in the Section pane.
- Click the arrow keys on the Section title bar.
- Select View > Go To Section > Section.

Duplicating Sections

You can copy Query, OLAPQuery, Chart, Pivot and Dashboard sections if the Duplicatable feature is selected.

➢ To make a section duplicatable, select the section label in the Section pane and select Edit > Duplicatable.

➢ To duplicate a section, select the section label in the Section pane and select Edit > Duplicate Section.

Interactive Reporting duplicates the section and adds a new section label to the Section pane. The new section label is based on the original section label, but a sequence number is appended to the label. For example, if you duplicate a section named SalesChart three times, the Section pane would show: SalesChart, SalesChart2, SalesChart3, and SalesChart4.

Renaming Sections

The first section that you create is given the default section name, for example, Query or Results. When you insert new sections of the same type as those that already exist, they are numbered sequentially, for example, Query2, Results2, and so on. To assign sections different or unique names based on your application, use the Rename command.

➢ To rename a section:

1. In the Section pane, select the section label.
2. Select Edit > Rename.
   
   You can also click Rename Section on the shortcut menu, or double-click the desired section. The Section Label dialog box is displayed.
3. Type a new name in the Label field and click OK.
Adding Headers and Footers to Sections

You can add custom headers and footers and page numbers to your printed section.

➤ To add a header or footer:
  1 Select File > Print Preview.

         A preview of the current section is displayed in the Content pane.
  2 Select Insert > Page Header (or Page Footer).

         The Edit Header (or Edit Footer) dialog box is displayed.
  3 Enter the desired text or use the buttons in the dialog box to add current date, time, file name, page, page total, or limit values and click OK.

         The new header or footer is added to your report.
         You can change the font properties and alignment of headers and footers, but you cannot add color.

Editing a Header or Footer

➤ To edit a header or footer, double-click the header or footer to edit, make any desired changes, and click OK.

Deleting Sections

You can delete a section, but do so with care. Some sections are dependent on other sections. Deleting one section could also delete one or more sections that you did not want to delete. Note that you cannot restore a deleted section.

➤ To delete a section:
  1 In the Section pane, select the section label.
  2 Select Edit > Delete Section.

         You can also select the section and click Delete Section on the shortcut menu.
         The Remove Section dialog box is displayed.
  3 Click Remove.

Setting Interactive Reporting Options

The Tools menu enables you to manage various options, such as job processing options, connections, default formats, and program options.

Review the following topics for information on:
Specifying Default Formats

This section explains how to set up and change the way fonts, styles, numbers, currency values, and dates are displayed. Default formats that you can set include:

- Default Fonts and Styles
- Default Number Formats

Default Fonts and Styles

You can control the way fonts are displayed in every section (except Results and Dashboard) by applying default font and formatting styles to each section element.

➢ To change default fonts and text settings:

1 Select Tools > Options > Default Formats.

   The Default Fonts and Styles dialog box is displayed, with tabs that contain specific font settings for each section.

2 Click the tab for the section to change.

3 Select the font, size, style and alignment settings and click OK.

   To restore the default settings, click Defaults.

Default Number Formats

You can change the way numbers, currency values, and dates are displayed, or you can create new custom formats. Use the Numbers tab of the Default Fonts and Styles dialog box to specify default settings for number formats.

Table 4 Default Number Formats

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select a Formatting Locale</td>
<td>Sets the locale or country associated with the default format to use. The locale determines the available number, date, and currency formats.</td>
</tr>
<tr>
<td>Date</td>
<td>Sets the default date format.</td>
</tr>
<tr>
<td>Timestamp</td>
<td>Sets the default time and date format.</td>
</tr>
<tr>
<td>Time</td>
<td>Sets the default time format.</td>
</tr>
</tbody>
</table>
Field | Description
---|---
**Month (For “Add Date Groups”)** | Sets the default month format for the month used in Add Date Groups.
**Null** | Sets the default format for null values. Null values are empty values for which no data exists. Null values are not equal to zero.
**Real** | Sets the default format for real values.
**Integer** | Sets the default format for integer values.

Table 5 lists the numeric field options and definitions along with examples.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
<th>Examples</th>
</tr>
</thead>
</table>
| 0 | Integer placeholder or zero value. If a number has an integer value in this position relative to the decimal point, the integer is displayed. Otherwise, a zero is displayed. | Apply 0 to show 123  
Apply 0.00 to show 123.45 |
| # | Integer placeholder. If a number has an integer value in this position relative to the decimal point, the integer is displayed. Otherwise, nothing is displayed. | Apply #,##0 to show 1,234 |
| ( ) | Formats with parenthesis options display negative values in parentheses. Otherwise, negative values display with a minus sign. | Apply (#,##0) to show (1,234) |
| ; | A semicolon operates as a separator between two number formats. The semicolon separates a positive integer and a negative integer. | Apply #,##0;(#,##0) to show 1, 234 or apply (1, 234) for a negative number |
| $ % | Adds the respective character to numeric values in the same position relative to the decimal point. | Apply $#,##0.00 to show $1,234.56  
Apply 0% to show 3% |
| m d yy | Displays month, day, and year in respective positions for date-coded information. | Apply mm dd yy to show 05 07 99 |
| - / | Adds the respective character to date-coded values in the same position relative to variables. | Apply mm/dd/yy to show 06/23/99 |
| HH MM SS | Displays hour, minute, and second in respective positions for date-coded information. | Apply HH:MM:SS to show 17:45:10 |
| AM PM | Adds the respective character to time-coded values in the same position relative to variables. | Apply HH:MM:SS AM to show 17:45:10 AM |

➤ To change a default number format:

1. **Select Tools > Options > Default Formats.**
2. **Select the Numbers tab.**
Selecting Program Options

This section describes how to set up default file locations, enable and disable specific operating functions, administer document features, define drill-down paths, and set OLAP options:

- General Options
- File Locations
- OLAP Options

General Options

Use the General tab to globally enable or disable specific operating functions.

➤ To select general options:

1. Select Tools > Options > Program Options.
2. Select the General tab on the Options dialog box.
3. Define the desired options and click OK.

- Auto Logon—Maintains a connection whenever you create a new document. If you are currently logged on, Interactive Reporting prompts you to use the current connection.

- Reset Print Properties—Retains the print settings with each section of the document, instead of inheriting the current default print settings.

- Convert BMP to PNG—Converts a picture automatically in .BMP format is converted to .PNG format (Portable Network Graphic) before it is loaded into the Resource Manager. The converted .PNG image are not backward compatible in pre 9.3 release documents. When an Interactive Reporting document is created and saved using 9.3.x releases, all images are saved in a centralized format (the Resource Manager). As a result, the images cannot be read or displayed in prior releases of Interactive Reporting. This is because the relocation and rationalization of the images is not understood by releases prior to 9.3.x.

The exception is images from a document saved in a pre 9.3 Release, which have been referenced once: not copied, merged or duplicated, e.g. placed in Dashboard or Report workspace as a Picture graphic in traditional fashion.

To retain compatibility with earlier releases, you can run the RevertImageResources script. This script provides a facility to undo the relocation and image merging, and thereby return the Interactive Reporting document to the pre-9.3 pre-Resource Manager format. This script is included with the 9.3. Release of Dashboard Development Services. It can also be downloaded from the Hyperion Developer Network. This script can only be used on the desktop, and not in the Workspace, as it relies on the COM feature of Interactive Reporting Studio.

Certain new features make documents ineligible for conversion to the non-Resource Manager format: for example if the 9.3 Interactive Reporting document has Bubble and
Scatter charts, then these are lost when the Interactive Reporting document is opened in the older version of Interactive Reporting Studio. For information on running the RevertImageResources script, see the 9.3 Readme.

- **Use Microsoft Windows Colors and Styles**—Specifies the colors and styles scheme used in Interactive Reporting. The selection in this field updates a UseSystemColors registry key setting in either the Interactive Reporting Studio or plug in folder of the registry. Enable this field to use legacy colors and styles based on Microsoft Windows. Disable this field to use Workspace colors and styles. Before the setting in this field can take effect, the application must be closed and restarted.

- **Compress All Documents**—Saves all documents in compressed file format. This reverses the default setting, which saves documents without compression. If enabled, you can override this privilege and save documents without compression by choosing File > Save As and changing the Save As type.

- **Create New Documents Compressed**—Compresses new documents.

- **Always Prompt For Owner Name**—Prompts for an owner name of job scheduling repository tables whenever you schedule a document. Enable this feature if you schedule documents to more than one repository.

- **Encrypt Dashboard scripts for new document**—Enables the default encryption state for a new Interactive Reporting document. When an Interactive Reporting document is created, the default encryption state matches the one on the Designer Options dialog. The setting chosen in this field does not affect the encryption state of any other Interactive Reporting document (including the active document.) Note that encrypted scripts are not functional in a release prior to 6.6.3 or 8.1. Despite the default setting you select, scripts are only encrypted if the Interactive Reporting document has a valid Design mode password.

- **When A Two Digit Year Is Entered, Interpret As A Year Between**—By default, if you enter a date and type only two digits for the year, Interactive Reporting handles the dates as follows:
  - Two-digit years entered from 00 up to and including 29 are assigned to the 21st century (2000 to 2029). For example, if you enter 3/12/18, Interactive Reporting accepts the date as March 12, 2018.
  - Two-digit years entered from 30 up to and including 99 are assigned to the 20th century (1930 to 1999). For example, if you enter 3/12/06, Interactive Reporting accepts the date as March 12, 2006.

You can change the default century to which a two-digit year is assigned by using the date-handling boxes. These boxes require a range of dates within a 99-year time period. Changes to a date format are applied globally, but do not affect dates previously formatted.

For example, if you want the two-digit year 25 to be assigned to the twentieth century instead of the twenty-first century use the arrow keys to scroll to the year 1999. The date in the corresponding read-only, date-handling box is automatically changed to 1900.

**Tip:**

Whenever possible, enter the year as four digits; that is, type 2006 instead of 06.
**File Locations**

Use the File Locations tab to specify the default locations for Interactive Reporting documents and other necessary files.

To specify default file locations:

1. **Select Tools > Options > Program Options.**
   The Interactive Reporting Designer Options dialog box is displayed.
2. **Select the File Locations tab.**
3. Enter the desired options and click OK.

- **Documents Directory** — The default directory in which to save Interactive Reporting documents when the Save File dialog box is displayed. Interactive Reporting documents are saved in the default directory with a .bqy extension.
- **Connections Directory** — A directory that contains the Interactive Reporting database connection files used to connect to databases. The default Connections folder is `C:\Hyperion\BIPlus\data\Open Catalog Extensions`.
- **Default Connection** — The Interactive Reporting connection used when no connection is specified, such as when you click the connection icon in a new document. This field is only available in Interactive Reporting Studio.
- **Preferred Repository Connection** — The repository Interactive Reporting database connection file you want the user to see in the Open Repository Connection drop-down list. This field is only available in Interactive Reporting Studio.
- **HTML Template Directory** — The directory of HTML templates used with the HTML Export Wizard. This field is only available in Interactive Reporting Studio.

**OLAP Options**

Program options for pre Release 9.3.1 OLAP and CubeQuery enable you to generate a results section, show the dimension root level.

To select OLAP options:

1. **Select Tools > Options > Program Options.**
   The Interactive Reporting Options dialog box is displayed.
2. **Click the OLAP tab.**
3. **Select the desired options and click OK.**

- **Auto-Generate Results Section When Processing an OLAP Query** — Create a Results section for any future OLAP Query section when that OLAPQuery section is first processed.
- **Show Dimension Root Level (ODBO Level 0/Essbase Generation 1) Data** — Enable the display of level 0 and generation 1 data in the OLAP tree. If you intend to use read or set a full member level hierarchy data in the Dashboards section, this option needs to be enabled. This option does not affect the display of any information in the CubeQuery section.
Use Old OLAP Query section—Enable the display of a new Essbase section in the pre Release 9.3.1 section format. This option also enables pre Release 9.3.1 section functionality. This setting applies only to subsequent OLAP queries, and not an existing OLAP query. By default, new Essbase queries use the CubeQuery Section type. A pre Release 9.3.1 OLAP query and an OLAP query with a CubeQuery section type can co-exist in the same Interactive Reporting document (BQY).

International Options for Interactive Reporting

Use the International tab to specify language options for Interactive Reporting documents supporting the Unicode feature.

➢ To select international language options:

1. Select Tool > Options > Program Options > International.
   The International tab is displayed.
2. Select the desired options and click OK.

Table 6  International Tab Options

<table>
<thead>
<tr>
<th>This is the language of menus and messages.</th>
<th>Select the language to use for Interactive Reporting menus and messages. In the Interactive Reporting Web Client, this setting is available only offline.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Default BQY sort order language</td>
<td>Select the sort order language for the Interactive Reporting document. Languages differ in how data is sorted. See your administrator before selecting a language.</td>
</tr>
<tr>
<td>Default OCE conversion language</td>
<td>Select the default language of the Interactive Reporting connection file when it is converted to Unicode format.</td>
</tr>
</tbody>
</table>

Document Properties

The Document Properties tabs are used to describe information about an Interactive Reporting document including in which application the document was created, the server address associated with a document, and the. Document properties consist of the General tab and the Server tab.

General Document Properties

Use the General Document Properties dialog to display the creation and modification attributes of a document.

The following Created display fields for the document are shown on the General Document Properties dialog:

● Document Path—Displays the path name to which the document has been saved.
● Application Name—Displays the application name in which the document was created. Application names include:
Interactive Reporting Studio
Interactive Reporting Web Client
Workspace
Interactive Reporting Job
Oracle's Hyperion® Smart View for Office

- **Application Version**—Displays the release version in which the document was created.
- **Date**—Displays the date on which the document was created.

The Modified display fields for the document are shown on the General Document Properties dialog:

- **Document Path**—Displays the path name to which the modified document was saved.
- **Application Name**—Displays the application name in which the document was last modified. Application names include:
  - Interactive Reporting Studio
  - Interactive Reporting Web Client
  - Workspace
  - Interactive Reporting Job
  - Oracle's Hyperion® Smart View for Office
- **Application Version**—Displays the release version in which the document was last modified.
- **Date**—Displays the date on which the document was last modified.

### Server Document Properties

Use the Server Document Properties dialog to specify the server address associated with an Interactive Reporting document.

- To specify a server address for a document, enter the URL address in the Server Address field and click **OK**.

  The URL address must be in the format: `http://<server>/workspace/dataaccess`.

### International Properties

When an Interactive Reporting document is opened in Unicode-enabled Interactive Reporting, the Interactive Reporting document file is converted from the old format to the new, and the language is determined based on the document code page. In certain locales (for example, most of the European languages) the language cannot be determined based on the code page from the Interactive Reporting document file. In this case, the user may be prompted to select the correct language for the document. When a new Interactive Reporting document file is created, Interactive Reporting selects the language based on the user locale.language set in Windows unless the user selects another locale/language.
To select the Document Sort Order Language manually:

2. Select the sort order language from the drop-down.
3. Click OK.

The document sort order language property is stored in the configuration file with the settings:

```
[Regional Settings]
DefDocLanguage=English
```

These settings can be copied to the Interactive Reporting server configuration file.

**Customizing Menus**

You can use JavaScript to customize Interactive Reporting menus. Add scripted menu items to the menu bar to:

- Run commonly used scripts
- Launch separate applications
- Export sections to a different file format with a single click

**Note:**

Since version 6.0, JavaScript is used as the script-editing tool instead of the Interactive Reporting scripting language. Script written prior to version 6.0 is still recognized, but is enclosed in a wrapper and called with a JavaScript command.

To add a custom menu:

1. Select Tools > Customize.

The Customize dialog box is displayed.
2 Type the name of your custom menu in the **Menu Name** field.

3 Click **Add** to add a new menu item to the **Menu Items** list.

   The Properties dialog box is displayed and shows the **Text** page.

4 **Type a name** for the menu item.

   Select one or more check boxes to indicate the sections where the menu item should be displayed.

5 **Select the Script tab** to display the **Script** page.

   Enter script commands to be run when the item is chosen from the menu. If you plan to deploy the menu item to a group of users, make sure that commands which reference external applications or files use universal paths.

6 **Click OK to return to the Customize dialog box.**

   Add separator lines and move menu items as needed to complete the final menu.
7 Click OK to close the Customize dialog box.

8 To provide the same functionality for distributed users, copy the preference file which supports this feature to users’ machines.
   - For Windows, the bqtools.ini file is located in the Windows directory.
   - For UNIX, the .bqtools.ini file is located in the user home directory

## Adding Custom Formats

You can specify a custom format in an Interactive Reporting document file by adding a new format locale using delimited characters in the bqformat.ini file, which resides in the \WinNT folder and is read by Interactive Reporting to fill in the format dialog boxes. The bqformat.ini file contains all the sections corresponding to the different countries/regions that you will find in the format dialog window. The file is installed with 38 locales set up with pre-defined formats.

➤ **To add a custom format:**

1 Navigate to the WinNT directory and open the bqformat.ini file using Notepad or Wordpad.

2 Change the second line of the bqformat.ini file to read count=39.

3 Scroll down to the line just below 38=USA and add a line of code that reads 39=BrioSample.

A new locale named BrioSample will be added to the date formatting selection. This locale has the same formats as the USA date formatting selection, but additionally allows users to select a date that reads, "Today is mm/dd/yyyy"; where mm/dd/yyyy is the format for the current date.

4 Highlight all the code for USA, and select Edit > Copy.

5 Place the cursor at the end of the last line of code and select Edit > Paste.

6 In the newly copied code, replace any lines that read USA_ with BrioSample_.

   Be sure to leave the words date, time, number, percentage and currency after BrioSample_.

7 Save the bqformat.ini file and close the editor.

8 Open an Interactive Reporting document file and open up the formatting window (on the shortcut menu, select Number).

9 Use the pull down menu for 'Select a Formatting Locale' and scroll down until you see the BrioSample section that was created in the bqformat.ini file.

➤ **To add a custom format with a delimited character:**

1 Navigate to the WinNT directory and open the bqformat.ini file using Notepad or Wordpad.

   Note that eight BrioSample_date formats are in this section. This procedure show you how to add one custom format with a delimiter character to the BrioSample_date section added above.

2 Change the line that reads count=8 to count=9.

3 Add the code after 8=dd/mm/yyyy HH:MM.
Today is mm/dd/yyyy

This format allows users to print the words "Today is" prior to printing the date.

The code To\day contains a delimiter character before the 'd', the backslash. This backslash must be used in order to print the word 'Today' or the letter 'd' would be replaced with the day number — the slash mark indicates the character is not to be replaced with the date or time element. The characters that should be delimited are; d, m, y, H, M, F.

4 Save the bqformat.ini file and close the editor.

5 Open an Interactive Reporting document file and test the new formatting section you just added on a date field.

6 Right-click a date column, select NUMBER, and select the BrioSample from the Formatting Locale pull-down menu

7 Select Date as the Category.

You should see "To\day is mm/dd/yyyy" in the list of selections.

Notice in the Preview screen that the delimiter character prints the word "Today" correctly without errors

As an additional exercise, try modifying the new date format without using the delimiter character and see how the format is displayed.

**Tools Menu Command Reference**

Table 7 provides a quick reference to the commands available on the Tools menu and list any related shortcuts. The commands listed are those available in the query and results sections.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Keyboard Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Process Query</td>
<td>Processes the current query, all queries in the Interactive Reporting document file, or a customized selection of queries.</td>
<td></td>
</tr>
<tr>
<td>Connection</td>
<td>Allows you to select, log on, log out, modify, or create an Interactive Reporting database connection file.</td>
<td></td>
</tr>
<tr>
<td>Connections Manager</td>
<td>Opens the Connections Manager dialog box.</td>
<td>F11</td>
</tr>
<tr>
<td>Save Connection</td>
<td>Saves an Interactive Reporting database connection file with an Interactive Reporting document file.</td>
<td></td>
</tr>
<tr>
<td>Administer Repository</td>
<td>Opens the Administer Repository dialog box, where you can modify object descriptions or groups.</td>
<td></td>
</tr>
<tr>
<td>Launch Dashboard Studio</td>
<td>Launches Dashboard Studio, which is a wizard-driven dashboard development tool for Interactive Reporting and lets you rapidly build dashboards without writing any code.</td>
<td></td>
</tr>
<tr>
<td>Launch Dashboard Architect</td>
<td>Launches Dashboard Architect, which is an integrated development environment (IDE) for Interactive Reporting and lets you rapidly build, test, debug and integrate Interactive</td>
<td></td>
</tr>
</tbody>
</table>
Reporting applications, dramatically increasing developer efficiency and productivity.

**Options**
Allows you to set default formats or program options.

**Customize**
Opens the Customize dialog box where you can add customized menus or menu items.

**Change Database Password**
Change the password used to log into the database. This feature is database dependent as only the following providers enable users to change the password:
- Teradata
- Red Brick Warehouse
- Oracle
- Essbase
- Sybase System
- Informatica
For all other databases, this feature is greyed out.

**Change Web Client Version**
Interactive Reporting Web Client only for locally saved (offline) documents. Enables users to change the Web Client version in which to open an Interactive Reporting document file. Change the Interactive Reporting Web Client version in which the document file is opened. Available for offline Interactive Reporting document files only.

---

**Export Properties**
Use the Export Properties dialog box to specify export properties for data in the Results, Table, Pivot, and OLAPQuery sections.

**Table 8 Export Properties**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Break HTML Page Every ___ Row</strong></td>
<td>Defines how many rows to include on an HTML page before starting a new page (file). The default setting is 100 rows per HTML page. Either enter the number of rows or click the up and down arrows to increase or decrease the row number by ten. If &quot;No Page Break&quot; is selected, this option is disabled.</td>
</tr>
<tr>
<td><strong>No Page Break</strong></td>
<td>Exports the data to one HTML file.</td>
</tr>
<tr>
<td><strong>Export Without Quotes</strong></td>
<td>Exports a section to a tab-delimited text file with no double quotes (or any other character that is not the raw Results data) around any column data. If you do not select this option, the exported section data contains double quotes surrounding exported column/cell values containing real data.</td>
</tr>
</tbody>
</table>
Export Document as Web Page

Use the Export Document As Web Page dialog box to publish the contents of the Interactive Reporting document file as a Web page. You can select which sections of the current Interactive Reporting document file to include in the export set.

Interactive Reporting documents file sections are exported in the same order as they are displayed in the Interactive Reporting document. Exportable sections include: Results, Table, Pivot, Chart, and reports created with the Report Designer. Imported sections that have been added to the Interactive Reporting document files, such as text files and Excel files, can also be exported. Data models and the Query, OLAPQuery, and Dashboard sections are not exportable. Neither are empty or blank sections.

The files created by this export option include:

- Main (or frameset) HTML (.htm) page
- Document-type icons (.gif)
- Cascading style sheets (.css) that describe the layout primitives
- Individual HTML (.htm) pages for each selected section
- JPEG files (.jpg) with the report content

After these files are posted to a Web site, you can access the files individually or use the main HTML file to view the frameset, which lists the sections in the report. The exported Web pages include navigation buttons so you can scroll back and forth between pages, or jump to the beginning or end of an Interactive Reporting document file. In addition, the current page number and total number of pages are included in the report.

To export an Interactive Reporting document file as a Web page:

1. Select the sections of the Interactive Reporting document file to export and click OK.
   - To select all sections, click Select All. To clear all selected sections, click Deselect All.
   - The Save As Type dialog box is displayed.

2. Navigate to the location in which to save your Web page.
   - Tip: Create a separate folder to store the files created by this export option.

3. Type a name for the exported Web page in the File Name field, or accept the default name, for example Sample1.htm.
   - The Save As Type field is set to *.htm by default. All of the HTML files that the export process creates begin with the name specified in the File Name field, for example, Sample1Chart.htm, Sample1Pivot.htm, and so on. The HTML file with the exact same name as the name specified in the File Name field is the main HTML page, and it contains the frameset and links to all of the other pages, for example Sample1.htm.

4. Click Save.
To view the exported selection, open your Web browser, select File > Open, browse to the location of the exported files, and open the main HTML page.

Export to HTML Wizard

The Export To HTML Wizard helps you create Web pages from charts, reports, and pivot tables. When you use the Export to HTML Wizard, each page of the Chart, Detail, or Designer report is a JPEG file, which is referenced by an HTML file.

Note:

We suggest you use the Export Document As Web Page command (see Exporting a Document as a Web Page) rather than the HTML Wizard.

➤ To export reports using the HTML Wizard:

1 On the first page of the wizard, select an option:
   - Click Create a new export layout if you have never used the Export to HTML Wizard before, or if you want to create a new export layout file instead of using or modifying an existing one.
   - Click Use an existing export layout to use an existing Web layout file from your Style Sheets directory.
     To search for an existing export layout file, click Browse.

2 On the second page of the wizard, specify the style of the home page to create for the exported HTML data, and whether to link it to other existing Web pages. To do this, complete:
   - Enter a name for your home page in the Home Page Name field with an HTM extension.
   - Select an output style.
     Interactive Reporting supports the output styles:
     - Vertical panes
     - Horizontal panes
     - Table of Contents
     - Linked Pages

3 On the third page of the wizard, specify which reports to turn into Web pages.
   All the reports available for potential export to Web page format are listed under Available Reports. Each report that you select will have its own Web page, and links to these pages will appear in the order shown under Selected Reports. You must specify at least one report for export.

4 To export a report into Web page format, click a report name under Available Reports, and click the right arrow to move it to Selected Reports.
5 To rearrange the order in which the Web pages will be linked, select a report name under Selected Reports, click the up arrow to move the report up one line, or click the down arrow to move the report down one line.

6 On the fourth page of the wizard, you can optionally specify another HTML template to be used when creating your Web pages. To select another HTML template, select a report name under Selected Reports, and click the right arrow to move it to HTMLTemplates.

Tip:
An HTML Template controls the size and style of the fonts on a Web page.

7 On the fifth page of the wizard, you can optionally link your Web pages to your source documents. This feature allows you to view the most recent updates on the Web and perform online analysis. To enable online analysis, select Please link my Web pages to their 'source' documents.

Tip:
To use online analysis, you must have Interactive Reporting Web Client installed on your machine.

8 On the sixth page of the wizard, type the full path to the directory where you want to store your new HTML pages, or click Browse to navigate to that location.

9 On the seventh page of the wizard, save your selections as a new HTML Export Layout file. To save your selections and finish building the layout. Specify the name and path of the layout you wish to create and click Finish to exit the wizard.

The Export To HTML Wizard saves your file with the extension "htm" in the specified directory.

**Spotlighter**

Use the Spotlighter to emphasize report elements so that they stand out by applying color and font styles to selected labels. Spotlighter formats are applied conditionally by building an equation and applying the constraint to your report.

**Note:**
In the Report section, the Spotlighter can only be applied to columns of tables in the report.

➤ To spotlight exceptional values:

1 Select a report element to spotlight.

2 Select Format > Spotlighter.

3 Build a conditional format in the Spotlighter:
   ● Select a comparison operator from the Operator list.
   ● Enter a comparison value in the Value field.
   ● Select an exception text format by clicking the font and format color controls.

4 Add formatting or colors to spotlight the data by clicking the format toolbar color controls and font controls.
The sample text in the dialog box previews your spotlighter formatting.

5 Select ✔️ to apply the spotlight format to the selected report element.
   The condition is displayed in the format editor with the spotlighter format applied.
6 Repeat steps 1–5 to specify additional conditions within the same selection.
7 You can apply multiple conditions to a selection.
   For example, you could set values over 5,000 within an item to display red, and those over 10,000
to display bold and green.

➤ To modify Spotlighter formats:
1 Select a spotlighted report element to modify.
2 Select Format > Spotlighter.
3 Double-click the spotlighter format to be modified in the Format editor.
   All conditional formats applied to the selection are captured to the Format editor.
4 Make any desired changes to the condition or format.
5 Select✔️ to reapply the modified spotlighter format.
   The modified format is reapplied to the report element.

➤ To copy Spotlighter formats:
1 Select the spotlighted report element to copy.
2 Select Format > Spotlighter.
   The Spotlighter is displayed with the formats applied to the item displayed in the Format editor.
3 Select Capture.
4 Select the report element to which to apply the spotlighter formats.
   The target area can be in the same report or in a different report.
5 Select Restore.
   The captured formats are applied to the selected report element.

➤ To remove a format from a selected report element:
1 Select a report element.
2 On the Format menu, select Spotlighter.
   The Spotlighter formats applied to the report element are displayed in the Format editor.
3 Select the format to remove in the Format editor.
4 Click Delete.
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Operator</strong></td>
<td>Logical operators including:</td>
</tr>
<tr>
<td></td>
<td>● =—equal to</td>
</tr>
<tr>
<td></td>
<td>● &lt;&gt;—less than, greater than</td>
</tr>
<tr>
<td></td>
<td>● &lt;—less than</td>
</tr>
<tr>
<td></td>
<td>● &lt;=—less than or equal to</td>
</tr>
<tr>
<td></td>
<td>● &gt;—greater than</td>
</tr>
<tr>
<td></td>
<td>● &gt;=—greater than or equal to</td>
</tr>
<tr>
<td><strong>Value</strong></td>
<td>Comparison value to define the condition</td>
</tr>
<tr>
<td></td>
<td>Accepts the equation from the Format editor and applies it to the report element.</td>
</tr>
<tr>
<td></td>
<td>Clears the Format editor and resets the style preference to the previous setting.</td>
</tr>
</tbody>
</table>
| **Formatting Color and Style** | ▪—bold text  
                        | ▪—italicize text  
                        | ▪—underline text  
                        | ▪—change fill color  
                        | ▪—change text color  
|                     | Sample Preview the formatting to be applied.                               |
| **Format Editor**   | Displays the spotlighter format from a row, column or item.                |
| **Capture**         | Captures a spotlighter format from a row, column or item.                  |
| **Restore**         | Copies a spotlighter format to a row, column or item.                      |
| **Apply**           | Applies a spotlighter format to a row, column or item.                     |
Query Section

The Query section is the Interactive Reporting interface with databases. In the Query section, you can examine the overall informational contents of the database, and even look underneath to verify the actual data values.

Each Query section contains a Data Model. Some Data Models are locked, and only allow you to process the query; others allow you to make modifications to the query or build a new one. You can also apply filters (limits), compute and modify items, and process your request for information.

An Interactive Reporting document file can contain multiple Query sections. These query sections can access a wide range of data sources (relational databases, OLAP servers, imported data sets, and local joins). Each Query section has its own Results section and can be associated with the same database or different databases (that is, the Interactive Reporting database connection file or data model used is independently defined in each query).
Using Data Models in the Query Section

Relational queries use data models to view the server database tables and create queries. Depending on your access privileges, you can download a prebuilt data model to the Query section, or build a data model and create your own query.

When you connect to a database, the tables in the database are displayed in the Catalog pane of the Query section. A data model is a visual representation of these tables. You use a data model to create queries that specify which data to fetch from the database and retrieve for analysis.

➤ To view the database tables in the Table catalog, select DataModel > Table Catalog.

The Table catalog in the Catalog pane expands to show all of the tables in the database. If you are not connected to a database, Interactive Reporting prompts you for a user name and password.

➤ To create a data model, in the Catalog pane, select a table from the Table catalog, and select Query > Add Request Item(s).

Building Queries

➤ To build a relational query:

1. Click the Request button on the Section title bar to display the Request line.
2. Complete one of the following actions:
   - Drag an item from the Content pane to the Request line.
   - Select an item in the Content pane and select Query > Add Request Item(s).

To add an entire column from a table to the Request line, select the table header. You also can select more than one of the same item (to create duplicate items).

If you add more items than the Request line can display, use the arrow buttons at the right of the Request line to scroll through the requested items, or resize the Request line to display multiple rows of request columns.

Working with Items on the Request Line

As you build your query, you can reorder, remove, or hide items on the Request line. This allows you to change the way in which the query processes and displays.

Reordering Request Items

You can move Request items to reorder them for viewing results.
To reorder items on the Request line, select the item to be moved and drag it to a new location on the Request line.

Removing Request Items

You can remove items from the Request line to exclude the data from your query or Results set.

To remove an item from the Request line, select the desired item and complete one of the following actions:

- Click the Delete button on the standard toolbar.
- Click Remove on the shortcut menu.
- Press the Delete key.

If you have not yet processed the query, Interactive Reporting removes the item from the Request line. If you have previously processed the query, you are informed that your results no longer match the items requested.

Caution!

Remove items with caution as a computed item or report may draw data from the item you delete.

Hiding Request Items

You can hide items that are displayed on the Request line. This allows you to incorporate data in the results set without displaying it. Hidden request items cannot be referenced for computations.

To hide a request item, complete one of the following actions:

- Select the item and click Hide on the shortcut menu.
- Select the item and choose View > Hide Request Items.

To show a hidden request item:

1. Complete one of the following actions:
   - Click in the Request line and click Unhide on the shortcut menu.
   - Select View > Unhide Request Items.
     The Unhide Columns dialog box is displayed.

2. Select the items to view and click OK.

When you have identified the items to include in the query, you can perform a number of other operations before processing the query. You can add filters or computed items to the Request line, or you can use a Request line item to specify a sort order.
Processing Queries

After you build your query and apply filters, computations, sorts, and any other adjustments to further refine your request, you need to process it. Processing your query may take a few moments if your query is complex or if the data in linked report sections needs to be refreshed. When you process your query, the data is retrieved to the Results section in tabular form. You can reprocess your query at any time and in any section to refresh the data. You can also return to the Query section from any other section at any time to alter the query and reprocess it.

To process a query:

- Click Process on the standard toolbar. (Click the right-arrow to select a process option.)
- Select Tools > Process Query and select the desired process option.

Since an Interactive Reporting document file can contain multiple queries, there are three processing options on the Process drop-down list:

- **Process Current**—Processes the current object. In some cases more than one query may be processed, for example, if a report references results sets from multiple queries. Process Current is the default selection when using the toolbar button.
- **Process All**—Processes all the queries in the document. By default, queries are processed in the order in which they are displayed in the Section catalog. For example, in a document with three queries, Query1, Query2, and Query3, the queries are executed in that order when you select Process All. (See “Query Processing Order” on page 94.)
- **Process Custom**—Opens the Process Custom dialog box so that you can select the order in which queries are processed.

The query is sent to the database and retrieved data is displayed in the Results section. While the data is retrieved, the Status bar displays a dynamic row count indicating rate and progress of server data processing and network transfer.

Query Processing Order

If there are multiple queries in a document, you can determine the order in which they get processed, and select which queries to include or exclude from the processing stream.

This feature is particularly useful when you need to use “fresh” data during a local join operation, or to ensure that your local results are populated with current data from a source query not affected by several earlier tables without duplicating the processing of some queries.
Query Processing Order is available for the Query section, OLAPQuery section and any imported data files sections that can be processed in an Interactive Reporting document when you use the “Process All” feature.

**Note:**

Query processing order settings are saved with the document. For a temporary processing order, do not save the document or set the processing order to what is normal for the given document.

➤ To specify a query processing order:

1. **Select Tools > Process Query > Processing Order.**

   The Query Processing Order dialog box is displayed.

   The first time the Query Processing dialog box is displayed after the new document is created, all query sections belonging to the document are displayed in the order which they are displayed in the Section Catalog (top down). Query sections added after the sections have been arranged, are displayed at the end of the list in the order in which they were added when the dialog box is reopened.

   ![Query Processing Order](image)

   Double-click on an item to add/remove it from the processing order.
   (Only queries with an * are processed during Process All actions.)

2. Select a query section and move it up or down in the processing order using the arrow keys to the right.

3. Double click a query section to remove it from the processing order or add it back and click OK.

   Only queries marked with an asterisk (*) are processed during “Process All”.

4. **Select Tools > Process Query > All.**
Saving Queries

After you process a query, your data is available until you close the Interactive Reporting document file. Saving the Interactive Reporting document file saves the current formatting and layout of all sections.

➤ To save your query, select File > Save.

Related Topics

“Saving Documents” on page 37
“Saving Results Sets” on page 138

Cancelling Queries

To cancel a query, both Interactive Reporting and the database must communicate properly for reasons other than running a query.

➤ To cancel a query, press and hold Alt+End until the query is cancelled.

The Interactive Reporting database connection file used to connect to the database must use an Asynchronous API. This is the default configuration, but it can be turned off on some databases. If the Asynchronous API is disabled, the database cannot detect a new request until the query has finished processing.

The database must pause every so often even when processing a query. As a default configuration, many databases are not set up to pause, which could result in the database being too busy to hear the cancel request until the query has finished processing.

Building Subqueries

You can use subqueries to filter your data. A subquery answers a specific question or provides specific information within the context of a main query, also called a “parent” statement. The database evaluates the entire query by first analyzing the subquery. The parent statement filters its rows based on the rows retrieved by the subquery.

Review these topics for information on subqueries:

“Regular Subqueries” on page 96
“Correlated Subqueries” on page 97

Regular Subqueries

A regular subquery executes the inner and outer queries once and returns the values from the inner query to the outer query. For example, you might need to find out who sold more than the average of all sales representatives in April. You first use a subquery to define what was the
average sales amount in April. This information is supplied to the parent query, which
determines which representatives exceeded the average of all sales in April.

To build a regular subquery:

1. Select or build a parent query.
2. Select an item on which to set a filter by:
   - Double-clicking the topic item
   - Dragging the item from the Content pane to the filter line
   - Right-clicking an item and selecting filter on the shortcut menu.
   The Filter dialog box is displayed.
3. Click Advanced.
   The Advanced button toggles the Create Subquery button.
4. Click Create Subquery.
   A subquery indicator shows that you are working with a subquery and not the parent query,
even though the data models of the parent query are displayed in the Content pane (which now
has a gray background).
   The Subquery section is considered a child of the parent query and is subordinate to the parent
query. It is dependent on the parent query and does not have its own default Query or Results
sections. Subqueries can be nested within other subqueries, in which case the first subquery
becomes the parent query to the subquery nested inside it.
5. Build the query.
   Only one item can be on the Request line, but you can add server and local filters, set a filter
inside a subquery as a variable, and define data functions and computations as needed.
6. In the Section pane, click the parent query for the subquery.
   The parent query section is redisplayed.
7. Click Process to process the parent query and subquery.

Correlated Subqueries

A correlated subquery is related to a regular subquery in that it uses an inner query to feed result
values to the outer query. A correlated subquery executes the outer query multiple times, once
for each row returned by the inner query; it is processed by joining a column in the subquery to
a column in the parent query.

For example, suppose you had to identify which sales representatives had more sales in the
current month than they did in the previous month. The correlated subquery is executed for
each row of sales information in the parent query to first determine what were the sales for each
representative in the previous month. This data, in turn, is compared to sales for each
representative in the current month, and only those representatives whose sales in the current
month were greater that their previous month’s sales are returned.
To build a correlated subquery:

1. **Select or build the parent query.**
2. **Use one of the following options to select an item on which to set a filter:**
   - Double-click the topic item
   - Drag the item from the Content pane to the Filter line
   - Right-click and item and select **Filter** on the shortcut menu.
   The Filter dialog box is displayed.
3. **Click **Advanced**.**
   The Advanced button toggles the Create Subquery button.
4. **Click **Create Subquery**.**
   A subquery indicator shows that you are working with a subquery and not the parent query, even though the parent query’s data models are displayed in the Content pane (which now has a gray background).

   The Subquery section is considered a “child” of the parent query and is subordinate to the parent query. That is, it is dependent on the parent query and does not include its own default query or results section.

   Subqueries can be nested within other subqueries, in which case, the first subquery becomes the parent query to the subquery nested inside it.

   A subquery is correlated based on a join from a column in the subquery to a column in the parent query.
5. **Build the query.**
   Only one item can be on the Request line, but you can add server and local filters, set a filter inside a subquery as a variable, and define data functions and computations as needed.
6. **If the parent query is not displayed in the Catalog pane, select **Show Queries** from the shortcut menu in the Section pane.**
7. **Drag the parent query into the Content pane.**
   The parent query is displayed as a blank topic in the Content pane.
8. **Drag the topic to correlate by into the blank parent query topic.**
   The Select Correlation Column dialog box is displayed and shows the tables of the parent query.
9. **Use the + and – signs to navigate through the structure of the directory tree.**
10. **Select the column in the parent to which to join the subquery topic item and click **OK**.**
    The topic item is added to the Filter line and a join line is drawn.
11. **In the Section pane, click the parent query section.**
    The parent query section is redisplayed.
12. **Click **Process** to process the entire query.**
    The topic item added in the subquery shows the label **sub** next to the topic item name.
Derived Tables

A “derived table” is essentially a statement-local temporary table created by means of a subquery in the FROM clause of a SQL SELECT statement. It exists only in memory and behaves like a standard view or table.

For example, assume an Oracle 9i database table is called “state_table” and has the following row values in the “state” column.

<table>
<thead>
<tr>
<th>State</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>CA</td>
<td></td>
</tr>
<tr>
<td>CA</td>
<td></td>
</tr>
<tr>
<td>CA</td>
<td></td>
</tr>
<tr>
<td>FL</td>
<td></td>
</tr>
</tbody>
</table>

If you used the following inner SELECT statement, which includes a derived table to evaluate the “state_table”, you could return the count and percentage of each state. The SQL has been written for Oracle 9i.

```sql
select state, count(state) as State_Count,
       (count(state)/derived_table.tot_state_count) as State_Percentage
from state_table,
     (select count(state) tot_state_count from state) derived_table
group by state, derived_table.tot_state_count;
```

The results of the query is displayed below:

<table>
<thead>
<tr>
<th>State</th>
<th>State_Count</th>
<th>State_Percentage</th>
</tr>
</thead>
<tbody>
<tr>
<td>CA</td>
<td>3</td>
<td>0.75</td>
</tr>
<tr>
<td>FL</td>
<td>1</td>
<td>0.25</td>
</tr>
</tbody>
</table>

Derived tables are useful when you need to generate aggregates in a table that would otherwise contain dimension type data and join the resulting aggregate with detail level facts in another table.

Additionally, the aggregate values in the derived tables can be used in the outer query’s WHERE clause (i.e., “where salary > average_salary”, average_salary has been derived by the subquery). These tables can also optimize a query’s performance in some circumstances, such as minimizing sorting when some DISTINCT values are needed from some tables but not all. Finally, it might eliminate the need in some cases, to build “local results” queries. This feature enables users to access this type of SQL construct in an easy-to-build manner.
Derived Tables Rules and Behavior

The rules and behavior of a derived table include:

- A Derived Table cannot be “iconized”.
- A Derived Table only has two speed menu options: “Add Selected Items” and “Remove”.
- When you modify a Query section that is used as a Derived Table:
  - Derived tables are available for connections to Teradata, DB2, Oracle, and Microsoft SQL Server. If you use the feature when you build a query, an active connection is required if the server code is ODBC or OLEDB so that the “smart ODBC” can determine the database type.
  - All client versions of Interactive Reporting use derived tables. Scripts in Interactive Reporting document file opened with Workspace can also use this feature.
  - If you remove all items from the Request line, the topic are displayed empty (there are no columns) in the section(s) where they are used as a derived query.
  - If the columns referenced by the “deriving” Query section are removed from the Request line, the effect is the same as if a “sync with database” had found the column removed.
  - If you rename items in a Query section used as a derived table, you must ensure that the new name is a valid name for the database in use. These names are used during the SQL generation, and are quoted if “quoted identifiers” are selected in the database connection.
  - Items from “Local Results” collection cannot be added to the Query.
  - The icon used for a derived table in the Table Catalog tree is shown on the left.
  - Both the referencing query and the derived table query must use the same data source even if one or the other is not connected. For example, assume Query1 is built from DataModel1, and Query2 is a query section not derived from a DataModel section. That is, you must be sure that both Query1 and Query2 can connect to the same data source name (such as an ODBC data source name or an Oracle TNS name), and they share the same API and server codes. The data source name alone may not be sufficient since two names can be identical over two different APIs. However, it is not required that the connections use the same database credentials. You do have to ensure that the referenced tables are accessible from whatever logon is used in all selected Query sections.
  - Interactive Reporting Web Client users need at least a Query role to use derived tables in a data model, or data model role to add or remove them from the data model.

To build a query that uses a derived table:

1. **Build the query which will use the “derived table” and process the query.**
2. **Insert a new query by choosing New Query on the Insert menu.**
   A derivable query can be built for a relational database.
3. **Build the “Derived Table” query by clicking anywhere in the Catalog pane and selecting Derivable Queries on the shortcut menu.**
The “Derivable Queries” option is not displayed if no query sections can be used in the current query.

(The Table Catalog below shows the Derivable Queries tree expanded and the Tables tree contracted. Local Results only are displayed when a user has requested them from the speed menu.)

The only queries that are displayed in this list are those that:

- have the same connection information as the current Query section
- have at least one item on the Request line
- do not use local joins
- do not also contain derived table topics

The topic name, when a derived table is added to the work area, is the same as the Query section name, and the column names are the same as the names of the items on the Request line in the Query section being added with the exception of any (data) function component. In cases where the function is displayed on the Request line, the resulting topic item name would be the same as the name that is displayed in Results after processing the query. The following diagram illustrates how the Request line for Query2 are displayed as a topic in another Query section.

4 Create a manual join by dragging an item from at least one topic to another, including to/from the added derivable query sections.

Once the derived table becomes a topic, items from it can be added to the Request, Filter, or Sort lines of the containing query. It can be referenced in computed item dialogs, and can be used in custom GROUP BY logic.

If you use the Show Values feature when setting a filter on an item in the “derived table”, the SQL that would be used is the same as if you set a filter on the same column in the source Query section.

5 Process the query using the derived table.

You can process the query by way of “Process” command when viewing the query section (or one of its dependent sections) or by checking it in the Process Custom dialog.

The “Process All” command processes the query containing the derived table. It also processes the query section from which the derived table is derived, unless it explicitly removed using the Query Processing Order dialog (which is recommended to avoid duplication of processing at the database.)

Additions to the Request line of the source Query are reflected in the topic item list of the referencing Query section the next time it is displayed.

Once a Query section has been added to another Query or Data Model works area, changes to the source query section will check for dependencies and warn you of any discrepancies that might occur. For example, you might receive a warning if an item was removed from the source query’s Request line which is used someplace else (Request, Filter, Sort, etc.) in a Query that is deriving a table from the source query.
**Derived Tables and SQL**

Review the following sections for information on:

- Custom SQL
- Processing a Query that Contains another Query Section

**Custom SQL**

If you open the Custom SQL window in a query that has a derived table topic, the SQL for the derived table is shown in the custom SQL window as part of the overall query. At this point, the SQL is locked; changes in the source query section for the derived table are not reflected in this SQL until such time as the user presses the Reset button. When you process the query with the Custom SQL window open, it is executed “as is”.

**Processing a Query that Contains another Query Section**

When you process a Query section that contains another Query section, it forms SQL that uses what are called “derived tables”, which are essentially subquery statements in a FROM clause. The SQL generation phase behaves as follows:

- Generates the SQL for the Query section being used as a topic in the current Query section being processed, including resolving any variable filters. Any Sort line items in the source Query section are ignored in generating the SQL. This generation only occurs if the contents of the Query as a topic is referenced by the currently processing Query section, following the rules for join path generation specified for the currently processing section.

- The resulting SQL is added to the currently processing Query section if required, in the FROM clause, surrounded by parentheses, as with any subquery.

- The entire subquery is given a table alias. The alias will follow the pattern for any table involved in a query and will thus be of the form “ALn”. As with subquery filters, any aliases used in the subquery itself will be distinct from the alias names used in the currently processing Query section’s table references. The alias will be used thereafter to refer to columns in the “derived table”, as is normal for SQL generation based on physical tables.

- Following the table alias name, “ALn”, a parenthesized list of column aliases is added. This list is identical to the list of names of the topic items in the Query topic. (For Oracle, the column aliases are displayed in the select list of the subquery instead of in a separate parenthesized list, for example, SELECT AL1.STORE AS store….)

- Before submitting the resulting SQL to the database, a check is performed to ensure that the query is properly joined. If it is not, the standard behavior, as specified by the Interactive Reporting database connection file preference “Allow Non-Joined Queries”, is taken.

- Following submission of the SQL, any references to the column alias names on the Request line of the currently processing Query section are available to build the dependent Results section.

- The minimum requirement is that if the “derived table” is referenced by the currently processing query, its SQL is generated as if that section were processed alone, with the
exceptions noted above. At initial implementation or in a future release, the SQL would include only those columns actually needed by reference in the currently processing Query. This reduces the number of items in the SELECT list of the subquery, with a corresponding reduction in the number of column alias names.

For example, assume the following Query section is to be used as the source for a “derived table” in another Query section:

In this example, the computed item’s definition is “UCASE (Pcw_Customers.Buyer)”. The filter on ‘Store Type’ is set to ‘Discount’.

The Query section using “Query” as a derived table might appear as follows:

In the previous diagram, the filter on City is set to ‘Los Angeles’. The SQL generated when the above query is processed, per the minimum requirements, would be:

```sql
SELECT AL2.STATE, SUM(AL1.UNITS) FROM PCW_SALES AL1,
     (SELECT AL3.STORE_ID, AL3.CITY, AL3.STATE, UCASE(AL3.BUYER)
      FROM PCW_CUSTOMERS AL3
      WHERE AL3.STORE_TYPE = 'Discount') AL2(STORE_ID, CITY, STATE, COMPUTED)
WHERE AL2.STORE_ID = AL1.STORE_ID AND AL2.CITY = 'Los Angeles'
GROUP BY AL2.STATE
```

**Working with Query Section Data**

You can further enhance the data requested in the Query section by working with the data, as described in these topics:

- “Processing Results to a Database Table” on page 104
- “Estimating Query Size” on page 105
- “Displaying Database Remarks” on page 105
- “Preaggregating Data Using Functions” on page 105
- “Appending Queries” on page 108
You can accomplish these tasks by using the commands on the Query menu.

**Processing Results to a Database Table**

Instead of retrieving data to the Results section, you can instruct Interactive Reporting to create a table in the database to store your results set. Items on the Request line become the column headings of the new table, and you can append new columns to the table and query it as needed.

**Note:**

The Interactive Reporting database connection file and database to which you are connected determine whether you can use this feature. You must have *Create* and *Insert* privileges on the database to process results to a database table.

➢ To process results to a database table:

1. **Select Query > Process Results To Table.**
2. **Specify the information requested.**
   - **Table Name**—Name of the new table to be created or the name of an existing table to which you want to append columns. You can create tables under your own owner name or under different databases or owners. If you do not have the correct privileges or do not specify an alternate location, the table is created under your own owner name. Use the format `DATABASE.OWNER.TABLENAME` to specify alternate names.
   - **Create Table**—Creates a new table in which Request items form columns.
   - **Append To Table**—Appends Request items as new columns in a table.
   - **Grant Access To**—Enables either everyone or specific users to access the new tables. Type `PUBLIC` or specific user IDs (separated by commas) for each user who should have access to the table. If not selected, access to the table is filtered to your own user ID.
3. **Click OK.**
   The table is created or modified under the specified database and owner name.

➢ To verify that the query was processed and the results saved as a database table:

1. **Select DataModel > Table Catalog.**
   The Table Catalog expands in the Catalog pane.
2. **Select Refresh on the shortcut menu.**
   The table is displayed in the list of database tables.
Interactive Reporting tracks tables under your database user name and stores a list of these tables in the `bqtbls5.ini` file.

To delete tables you created using the Process To Database Table feature:

1. Select `Query > Process Results To Table.`
   - The Process Results to Database Table dialog box is displayed. Tables created under your user ID are displayed in the Tables Created By list.

2. Select a table from the list and click `Delete`.

**Estimating Query Size**

Queries that sift through and retrieve enormous amounts of data can take a long time to process, and may consume unnecessary system and server resources. If you suspect these factors exist, you may want to size your query before you process it.

The Estimate Size feature queries the database to see how many records your query will retrieve. You can use this feature to test a questionable query or to decide whether to prevent or postpone processing a large results set.

To estimate the size of a query, select `Query > Estimate Query Size`.

Interactive Reporting queries the database and counts the number of records to retrieve if the query is processed. This process may take a while for server-intensive queries.

**Displaying Database Remarks**

Database remarks provide detailed contextual information about a table or column. Remarks may describe the origin, derivation, or details about data model topics and items, which can help you identify and select the information you need. Database remarks often exist as metadata when you map data in a data warehouse project or if you use a CASE tool to manage your database.

To display database remarks, use one of the following options:

- Select `Query > Show Remarks`.
- Click `Show Remarks` on the shortcut menu.

**Preaggregating Data Using Functions**

Depending on how you plan to view your data, you can select to preaggregate data at the database server. Preaggregation (also called server aggregation) is a querying strategy that uses functions to summarize data as it is retrieved from the database. Instead of returning a line-item list of every row that meets the criteria on your Request line, you can order the database to group related information. This results in one row representing the combined (aggregate) value of each distinct group.
You use data functions (provided by your RDBMS) to preaggregate data in a query. When a data function is applied to a Request item, the data related to that item is aggregated when the query is processed. If you need both summary data and increasing levels of detail breakdown in your reporting or analysis, do not preaggregate the data. Report sections will automatically provide an aggregated summary view, and component levels of detail data can be reached using drill-down tools.

If your data set is potentially very large, or incorporates very discrete levels of transactional data that do not apply to your analysis, it may be best to preaggregate the data at the server to return a more manageable data set. Preaggregating data in your query assumes that you have a clear idea of the data to look at and a good conceptual understanding of relational databases. If you are unsure about preaggregation, process the query without applying data functions. If you find that it would be better to preaggregate, return to the Query section and apply data functions to the query.

Use data functions to preaggregate data as it is retrieved from the database. The following table lists the prebuilt data functions that you can apply to items in the Request line.

Tip:
Aggregation is manifested in different ways in the Query and Reporting sections. Before you use data functions in a query, please read ???.

<table>
<thead>
<tr>
<th>Data Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Returns unaggregated values as stored in the database. This is the default option in the Query section.</td>
</tr>
<tr>
<td>Sum</td>
<td>Returns sum of underlying values.</td>
</tr>
<tr>
<td>Average</td>
<td>Returns average of underlying values.</td>
</tr>
<tr>
<td>Minimum</td>
<td>Returns lowest of underlying values.</td>
</tr>
<tr>
<td>Maximum</td>
<td>Returns highest of underlying values.</td>
</tr>
<tr>
<td>Count</td>
<td>Returns number of underlying values.</td>
</tr>
<tr>
<td>Count Distinct</td>
<td>Returns the number of distinct values in a column. This function is not supported by all database servers.</td>
</tr>
<tr>
<td>Standard Deviation</td>
<td>Returns standard deviation of values. This function is not supported by all database servers.</td>
</tr>
<tr>
<td>Variance</td>
<td>Returns variance of values. This function is available through Oracle servers only.</td>
</tr>
<tr>
<td>Weight</td>
<td>Use for computing weighted items in pivot tables.</td>
</tr>
</tbody>
</table>

When using data functions, remember that with the exception of counts, data functions are applied almost entirely to numeric data items and the results are computed with respect to dimensional, nonnumeric items on the Request line, such as name and date items as in the following examples.
Example

Query 1 includes only items for Region and Amount_Sales. The data function Sum is applied and the data returned consists of one row for each region with an aggregate sum for that region in the Amount Sales column.

<table>
<thead>
<tr>
<th>Region</th>
<th>Amount Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>Americas</td>
<td>$80,765,835</td>
</tr>
<tr>
<td>Asia Pacific</td>
<td>$29,556,011</td>
</tr>
<tr>
<td>Europe</td>
<td>$34,569,833</td>
</tr>
</tbody>
</table>

Example

In Query 2, the item Fiscal_Year is added to Query 1, breaking out rows for each state/fiscal year combination with Units totaled on a per state, per year basis.

<table>
<thead>
<tr>
<th>Fiscal Year</th>
<th>Region</th>
<th>Amount Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>1999</td>
<td>Americas</td>
<td>$11,411,978</td>
</tr>
<tr>
<td>1999</td>
<td>Asia Pacific</td>
<td>$4,260,710</td>
</tr>
<tr>
<td>1999</td>
<td>Europe</td>
<td>$5,066,636</td>
</tr>
<tr>
<td>2000</td>
<td>Americas</td>
<td>$57,343,857</td>
</tr>
<tr>
<td>2000</td>
<td>Asia Pacific</td>
<td>$25,305,302</td>
</tr>
<tr>
<td>2000</td>
<td>Europe</td>
<td>$29,503,197</td>
</tr>
</tbody>
</table>

Example

In Query 3, the Product_Line Name has been included and the data function is changed to Average. The number of rows increased, with data summarized as an average per state, per year, per product line.

<table>
<thead>
<tr>
<th>Fiscal Year</th>
<th>Region</th>
<th>Product Line</th>
<th>AVG(Amount Sales)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
To apply a data function in the Query section:

1. Select an item on the Request line.
2. Select Query > Data Function and select the desired function (see Table 12, “Query Section Data Functions,” on page 106).

The item is renamed to reflect the data function you selected. For example, `SUM(Units)` or `AVG(Amount_Sold)`.

When the Query is processed, the data is returned from the server in aggregate form.

To remove a data function in the Query section:

1. Select the item on the Request line.
2. Select Query > Data Function > None.

### Appending Queries

When you need to view and merge multiple queries in a combined Results set, there are four query operators that allow you to merge two or more separate queries. For example, you may need to merge the results of amount from sales by item, plus units from state sales by state. The operators and their functions are:

- **Union**—All distinct rows selected by either query are retrieved. No duplicate rows are retrieved.
- **Union All**—All rows selected by either query, including duplicate rows, are retrieved.
- **Intersection**—All distinct rows selected by both queries are retrieved.
● **Except**—All distinct rows selected by the first query but not the second query, are retrieved. (Oracle database servers refer to the Except operator as “Minus.”)

**Note:**

If your database supports the Intersection and Except operators, but they are not available in the Operator drop-down list, check the Allow SQL-92 Advanced Set Operations connection preference.

The rules governing the use of these operators are:

- The number of columns in the Select clause in both queries must be equal.
- The data type returned in the columns in both queries must match.

For example, if Column 1 in the first query is a date, Column 1 in the second query must also be a date.

**Note:**

Items on the Union line can be repositioned to see the results of different intersections.

To append a query:

1 **Verify data types and associated column(s).**

   This ensures that you know how to merge data in the second query.

2 **Build the Request line.**

   Add server and local filters, data functions, and computations to the query as needed.

3 **Select Query > Append Query.**

   An Operator drop-down list and a second query tab is added below the Request, Filter, and Sort lines. The drop-down list shows whether the queries are linked by way of a union, a union all, an intersection, or an except.

4 **Build the second query.**

5 **To merge multiple queries, select the operator to use from the Operator drop-down list.**

6 **Click Process.**

   You can have Interactive Reporting generate automatically the join path required by the context of the query by using the automatic join path feature. This feature eliminates the need for you to predefine any join paths, because Interactive Reporting determines the paths. When multiple paths are available, you are prompted for which one to use.

**Using Local Results**

Local results are a snapshot of a Results section shown in topic format. They are used to add the results of one query to another in an Interactive Reporting document file.
To use local results, click anywhere in the Catalog pane and select **Local Results** on the shortcut menu.

A Table catalog named Local Results is added to the Catalog pane.

**Limitations of Local Results**

Since local results are maintained on the desktop and not by the database server, there are limitations when using Local Results. The following functions are not available when using Local Results:

- Filters, computed items, data functions, or query properties to further analyze the dataset
- The following Query Options menu governors (disabled if only local results topics make up the Query):
  - Returning unique rows
  - Row filter
  - Time filter
  - Auto-process
  - Custom Group by
- Query filters on Local Results Topic Items
- More than one Filter Local Join
- Filter Local Joins used with Local Joins
- Meta topics
- Access or change properties for Local Results Topic Items
- Append Query features of Unions or Intersections with Local Results Topic Items
- *Process to table* a query

**Note:**

A query based on local result topics will not perform as well as the equivalent database query.

**Processing Order**

When using *process all*, the query producing the results may be processed twice if the query using its results are listed first in the section catalog. It is also possible for the query using the local results to use *stale* data if it was saved with results, and the query that produced them is reprocessed. To prevent this from happening, you can define the order in which queries are processed. For more information, see **Query Processing Order**.

**Using Stored Procedures**

Stored procedures are precompiled, complex queries that are executed on a database server and maintained by a database administrator. Stored procedures execute very quickly and are usually
created to accomplish tasks that SQL cannot do alone. Interactive Reporting treats stored procedures as locked standard queries and does not allow you to modify the procedures.

You can use Interactive Reporting to process stored procedures through Open Client or ODBC, collect the results, and generate reports as you would with a standard query. Stored procedures can be loaded from your desktop and appear as a query object in the Content pane.

**Note:**

**ODBC only.** Interactive Reporting supports stored procedures that return results. This support is contingent on the driver and database. The driver and database must support the required ODBC calls, including SQL Procedures to retrieve a list of available procedures and SQLProcedureColumns which identify the parameters required to execute the procedure. For Oracle, results are recognized in ODBC by specifying reference cursor parameters when the procedure is created. The Interactive Reporting database connection file must specify the database as “ODBC” rather than “Oracle” to work properly.

**Note:**

The ODBC driver must recognize the ODBC syntax for calling procedures: `{call <procedure name> (parameter list)}`. If the procedure has no parameters, the parentheses surrounding the parameter list are optional. Interactive Reporting does not insert empty parentheses in the call to execute the procedure. In addition, the driver must accept literal values for any specified parameter. Drivers that require parameter markers, for which values are provided when the procedure is executed, are not currently supported.

➤ To open a stored procedure:

1. **Select Query > Stored Procedures.**
   The Stored Procedures dialog box appears.

2. **Select the database owner name that contains the stored procedure.**
   Any stored procedure to which you have been granted access is displayed in the Stored Procedures list.

3. **Select a stored procedure from the list and click Load.**
   The stored procedure appears as an icon in the Content pane. No items appear on the Request line until the stored procedure is processed.

➤ To process a stored procedure:

1. **Click Process.**
   If the stored procedure calls for user input, a dialog box appears and prompts you with up to 10 entry fields. If more than 10 arguments are required, successive dialog boxes appear.

2. **If an argument dialog box is displayed, enter appropriate values as arguments to the stored procedure.**
   The arguments supplied are similar to variable filters. If necessary, see your database administrator for clarification on the arguments needed to process a particular stored procedure.
3 If the stored procedure queries the database, the database server returns data to the Results section and
the adds items to the Request line.

**Setting Query Options**

When working with very large or unfamiliar databases, you may occasionally process a query that takes a long time to run or returns more data than is manageable. To prevent problems under these conditions, set query options before processing.

To set query options:

1. **Select Query > Query Options.**
   The Query Properties dialog box is displayed.
2. Select the desired restrictions for the current query and click **OK**.

- **Return Unique Rows**—Eliminates duplicate rows from the data set retrieved by the query. It is not a regression. If the data source for a query is a local results table, even though this feature is enabled, the Unique Rows filter is not enforced.
- **Return First ___ Rows**—Filters the number of database rows retrieved to the number entered.
- **Time Limit ___ Minutes**—Filters the amount of time the query is allowed to run to the number entered. Seconds are entered as a decimal number. Time filters work for asynchronous database connections and cancel at the earliest opportunity for nonasynchronous connections.
- **Auto Process**—Specifies the current query as a Standard Query to be processed automatically on download from the Repository (Designer only).
- **Custom Group By**—Customizes the Group By criteria used to compute aggregate Request items, with selected items not factored into the grouping. This feature is available only when a data function is placed on a Request item.

**Editing with SQL**

You may wish to use SQL to create or edit your query. Working with SQL involves:

- **Editing with SQL**
- **Importing SQL Files**
- **Reviewing the SQL Log**

**Editing with SQL**

If you are familiar with Structured Query Language (SQL) and prefer to edit your own query, activate the Custom SQL window and edit the statement directly. Interactive Reporting sends the contents of the Custom SQL window to the server when you click Process.
You can use the Custom SQL window to edit query syntax, or to troubleshoot a query which is not processing correctly. With this function, you can only edit the FROM and TO clauses of the SQL statement.

**Tip:**
You must leave the Custom SQL window open for Interactive Reporting to use your edited SQL statement when processing the query.

➤ To open the Custom SQL window, select View > Custom SQL.
You can also type edit directly in the Custom SQL window.

Reset restores the SQL statement contained when the Custom SQL dialog box was opened. Use the Window menu to display or hide the Custom SQL window once it is opened.

➤ To save your edits and close the window, you can click Close or click the checked Custom SQL feature on the View menu.

**Determining the Number of Rows from and SQL Statement**

To determine the number of rows retrieved or if data was selected in an SQL statement, use one of the following techniques:

**Technique 1**
begin-report
  do count_rows
  do return_true
end-report

**Technique 2**
begin-procedure count_rows
  move 0 to #count ! This is optional unless main1 is called more than once
  begin-select
    column1
    column2
    column3
  add 1 to #count
  from table1
  end-select
  if #count > 0
    show 'Number of rows selected was ' #count edit 999
  else
    show 'No rows selected'
  end-if
end-procedure main1
begin-procedure return_true
  begin-select
    'true' &true
    column1
    column2
    column3
  from table1
  end-select
if &true = 'true'
show 'Selected at least one row'
else
show 'No rows selected'
end-if
end-procedure

Importing SQL Files

The Import SQL file feature allows you to take a complete SQL statement from a text file, import it into a query, and retrieve the data set from the database server. When the file is imported, it is scanned to determine the number of columns that will be returned by the SQL, with the request line becoming populated with a column indicator for each of the columns. Using this feature, you can take advantage of SQL statements you have already written.

Before importing a SQL file, verify the following:

- You are connected to a database server and are working in the Query section.
- There must be no tables in the Contents pane.
- The SQL file to be imported must begin with a SELECT statement, and you should know the number of columns to be displayed in the Results section.

Once the SQL file is imported into the query, you cannot edit it, drag items from table onto the Request line (however, you can specify a user-friendly name for the Request line item and identify its data type), use the custom SQL feature, or display its properties.

To import an SQL file:

1. Select File > Import Data File > SQL.
   The Import SQL File dialog box is displayed.
2. Select the desired SQL file and click Open.
3. In the Number of Columns dialog box, enter the number of columns that you want the query to run and click OK.
   For extremely complex SQL statements, Interactive Reporting needs to be advised on how many columns to expect from the database. The default number in the dialog box is the "best guess" option.
   Interactive Reporting inserts the SQL statement directly into the content, nested between the header and footer "Imported SQL Statement." If the statement is larger than the entire Contents pane use the scroll keys to view it.
4. Double-click a Request line item.
   You can also click a column on the Request line and click Properties on the shortcut menu.
   The Item Properties dialog box is displayed.
5. Specify a name for the item in the Name field.
6. Associate the item with a data type by selecting a data type from the pull-down list and click OK.
7 Click OK to retrieve the results.

The column data types default to string unless they are manually changed.

➤ To refresh or delete a column name:

1 Edit the SQL in a text editor, such as Windows Notepad or vi in UNIX and save it.
2 In the Query section, right-click on the area labeled ‘--Imported Sql Statement--’.
3 Select either Refresh or Delete as needed.

➤ To edit SQL that has no associated file:

1 Select View > Query Log.
2 Process the query containing the imported SQL text.
3 Copy the SQL statement from the Query Log window and paste it into a new text file using your editor.

When you refresh an imported SQL statement, Interactive Reporting attempts to open the same file used when you first imported the statement. If that file no longer exists, you are prompted to select a new file. Because editing the SQL statement might change the SELECT list (which appears on the Request line) you must redo any edits made to the name and/or data type of those items after refreshing the SQL statement.

### Reviewing the SQL Log

When you process a query, Interactive Reporting translates your graphical request into an SQL or other query statement (MDX – OLEDB and OLAP servers, and Essbase also have their own languages), which in turn is forwarded to the database server. You can view the generated query statement in any section by displaying the Query Log window.

➤ To display the SQL Log, select View > Query Log.

When this feature is active, the Query log is treated as an open window. You can bring it to the front by clicking Windows > Query Log. The Query log closes and drops from the Window menu when it is deactivated on the View menu.

➤ To save the contents of the SQL Log to a file, select File > Export > Query Log.

The Export File dialog box prompts you to enter document and directory names for the new file.

### Importing Data Files

An alternate method of "querying" is to import data from a file. Interactive Reporting can import files in Microsoft Excel (.XLS), and in both comma (.CVS) and tab (.TXT) delimited text formats.
When you import data, the content of a file is delivered to the desktop data cache and displayed in the Results section. You can use imported data as you would the results of a query to build reports and perform data analysis.

To import a data file:

1. Select File > Import Data File > Data File.
   The Import File dialog box is displayed.
2. Navigate to the location of the file.
   On a Windows operating system, select the correct type of the import file type menu to make the file easier to find.
3. Select the file and click OK.
   The data from the imported file is displayed in columnar Results Format.

Setting Data Type Properties

You may want to confirm or change the data type of an item to preserve the precision of a mixed data type computation, or to change the way a data item is handled for example interpreting numbers as strings).

Attention to data types is most important when computing items in the Query section. In this case the database server performs the computation, and the Interactive Reporting may receive the computed item with an unanticipated data type. To ensure that server correctly handles data computations, you should set the data type when performing mixed-data type computations.

Local calculations (Results, Pivot) are handled internally, and adjustment between 16- and 32-bit integers, for example, can be handled safely using the automatic or number data type specification.

To set data type properties for a request item:

1. Select a request item and choose Properties from the shortcut menu.
   The Item Properties dialog box is displayed.
2. Click Options and select a datatype from the Datatype drop-down list.
3. Click OK.
   The following table describes the supported data types:

<table>
<thead>
<tr>
<th>Table 13</th>
<th>Supported Data Types</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Data Type</strong></td>
<td>** Specification**</td>
</tr>
<tr>
<td>Automatic</td>
<td>A data type is determined automatically given the data type of the reference items and the computations performed.</td>
</tr>
<tr>
<td>Blob</td>
<td>Binary large object which is truncated at 64,000 bytes. Blob data types can include image formats such as: JPEG, .BMP, .GIF, and .PNG. See also &quot;Picture (BLOB Image) Support&quot; on page 117.</td>
</tr>
</tbody>
</table>
### Data Type | Specification
--- | ---
**Byte** | Variable data type of length determined by a single byte of computer storage. Bytes can store numeric values from 0 to 255, or a single text character.
**Date** | Calendar date in server default format (typically mm/dd/yy).
**Integer (16-bit)** | Retains a 16-bit value (2 bytes). A 16-bit integer stores integer values from 0 to 16,777,216, and signed integers between +8,388,608 and -8,388,608.
**Integer (32-bit)** | Retains a 32-bit value (4 bytes). A 32-bit integer stores integer values from 0 to 4,294,967,296, and signed integers between +2,147,483,648 and -2,147,483,647.
**Long Text** | Character data (long text) exceeding 25 bytes (use the string data type for text strings up to 255 characters). The maximum long text retrieved is 4000; characters anything greater than that is silently truncated.
**Packed Real** | Real numbers packed for use with EDA middleware. The results in the Interactive Reporting are the same as real numbers.
**Real** | Decimal numbers up to 5 positions right of the decimal.
**String** | Text strings to a maximum length of 256 characters.
Interactive Reporting supports very large character data type column fields, such as Microsoft SQL Server text data type files, and IBM's DB2 Character Large Object (CLOB) data types.
The DB2 CLOB data type is SQL99-compliant and is used to store very large variable-length character strings (up to 10MB). Its length property is displayed with a default value of 4000 characters; however, this may be updated to any value between 1 and 4000 by an Interactive Reporting user. The length property determines the maximum length of the CLOB data string that can be displayed after a database query. CLOB column fields with data that are greater than 4000 bytes in length are truncated after the 4000th character.
**Time** | Time in format set by user preference.
**TimeStamp** | Date/time combination in format set by user preference.

### Picture (BLOB Image) Support
Pictures can be queried from a relational database if they are image data collected as a BLOB data type and stored as a binary unit in the database management system with ODBC connections. BLOB image files available to include: JPEG, .BMP, .GIF, and .PNG image formats. Pictures can be dragged and dropped from a query table to the request line, displayed as strings in columns in the Results and Table sections, or shown graphically in the bands of the Report section. Interactive Reporting dashboard developers can select images from Results sets, not just static images from the file system. Wherever applicable, computed items and some functionality, such as the group by clause in SQL, unions and outer joins, use the primary key column.

The following restrictions apply to BLOB images in Interactive Reporting:
- The ODBC connection must use a server-defined join (see Metadata Definition: Joins).
- BLOB images cannot be retrieved using a stored procedure.
- It is not possible to determine the data type of an image in advance.
BLOB images cannot be used with the Process to Table feature.
BLOB images cannot be used with the Import SQL feature.
In the Workspace if a user attempts to add a BLOB column to the filter, there is no popup message to indicate that the functionality is not supported.
Text Wrap and Suppress Duplicates features cannot be applied to BLOB columns.
If a BLOB column is placed in the Query section and processed in a pre 9.3 release Interactive Reporting document file, images are not backward compatible.

See also:
- Adding Pictures in Query
- Adding Tooltips to Pictures
- Working with Pictures in Results and Tables
- Working with Pictures and Computed Items
- Working with Pictures in Reports

## Adding Pictures in Query

In the Query section, once BLOB images are retrieved as pictures, they are treated like any other table topic item. They can be dragged and dropped from the table directly to the request line. Only pictures in tables that have a primary key defined are included in a query. Pictures cannot be sorted in the Query section. If you add a non-BLOB image to the request line, a broken link to the image is displayed in the report section.

## Adding Tooltips to Pictures

A tooltip can be associated with a picture, which is a tiny box that is displayed next to the picture and identifies it in the Results and Table section. For Dynamic pictures, the tooltip field accepts a column name which represents a non-BLOB column item on the request line used to describe the picture. If no tooltip is selected for a BLOB image, the picture column text shows `<<Picture: unique id>>`. In this case, the unique id is the tooltip text. Otherwise, the corresponding primary key value is shown. For static images, the tooltip is text that you specify on the properties dialog of a picture.

To associate a tooltip with a BLOB image:

1. **Select the BLOB image on the request line.**
2. **Right-click and select Properties.**
   
   The Items Properties dialog box is displayed.
3. **Click Options.**
   
   The Datatype drop-down and Tooltip drop-down are displayed. The Tooltip drop-down contains a list of all non-blob items on request line, and a “None” (default) option.
4 From the Tooltip drop-down, select the non-BLOB image to use as the tool tip.
5 Click OK.

**Working with Pictures in Results and Tables**

A column is displayed in the Results and Table sections for every picture with a BLOB data type on the request line. Descriptive text is displayed instead of the image in each cell in the format <<Picture:unique id>>. The unique id is tooltip text if any has been specified, otherwise, the unique id is the primary key value.

**Working with Pictures and Computed Items**

A picture function is available in Computed Items so that you can associate an image with a computed column. In the Results and Table section, the picture is shown as descriptive text instead of the image in each cell in the format <<Picture:unique id>>. The unique id is tooltip text if any has been specified, otherwise the unique id is the Resource name. In the Reports section, the computed item containing the picture can be shown graphically. For example you could use an “if else” statement to show an image if a certain set of conditions are met, and another criteria if the condition is not met:

```javascript
if (Amount_Sales >= 10000) {Picture ("C:\graphics\smile.gif" )}
else{Picture("C:\graphics\crying.gif" )}
```

**Working with Pictures in Reports**

The Report section can include pictures obtained from the database (BLOB datatypes) by using an embedded object (Results and Tables) or it can use static images from the Resource Manager. Pictures can be dragged from the Catalog and dropped into the report layout components:

- report table
- report body
- report group header
- report page header of footer

**Note:**

You cannot drag a picture into a Table Facts column.

Once a picture has been added to the report, all images are sized to fit the bounding rectangle defined in the report, and pictures can be resized as needed.

Pictures are sorted by the their underlying textual unique id (i.e. the text displayed in a table/result section), which is particularly useful when they are added to the report group headers (by way of the data layout).
Resource Manager

The Resource Manager is a user interface utility used to load, manage and share pictures in the Interactive Reporting document file. By storing one copy of the image and referencing the copy as a resource when used elsewhere, the Resource Manager reduces the size of an Interactive Reporting document file, which in turn reduces the memory footprint required to open some documents.

For example, a company logo might appear several times in an Interactive Reporting document file, in Reporting headings and in Dashboards. With the Resource Manager, only one copy is stored and reused by reference to its resource name.

A picture can be used as a resource only if it is added to the Resource Manager. Users can still import images directly in the Interactive Reporting document file, but in this case, they are considered “dynamic” pictures.

Each Interactive Reporting document file has its own Resource Manager. A new picture is added to the Resource Manager from disk by using an Import feature. Once imported, pictures can be viewed in several formats:

- listed
- in detail
- preview
- thumbnail

Resource Manager pictures can also be merged, renamed and deleted.

In pre 9.3 release Interactive Reporting document file, Resource Manager images are not backward compatible when images are:

- Converted from .BMP format to .PNG format
- Merged using the Resource Manager Merge or Merged All feature.
- Images are dragged from the Resource Node in the Report section or Dashboard section.
- Duplicated from the Report or Dashboard sections.
- Copied from the Report or Dashboard sections.

When an Interactive Reporting document (BQY) is created and saved using 9.3.x releases, all images are saved in a centralized format (the Resource Manager). As a result, the images cannot be read or displayed in prior releases of Interactive Reporting. This is because the relocation and rationalization of the images are not understood by releases prior to 9.3.x.

The exception is images from an Interactive Reporting document file saved in a pre 9.3 Release, which have been referenced once: not copied, merged or duplicated, that is, placed in Dashboard or Report workspace as a Picture graphic in traditional fashion.

To retain compatibility with earlier releases, you can run the RevertImageResources script. This script provides a facility to undo the relocation and image merging, and thereby return the Interactive Reporting document file to the pre-9.3 pre-Resource Manager format. This script is included with the 9.3. Release of Dashboard Development Services. It can also be downloaded.
from the Hyperion Developer Network. This script can only be used on the desktop, and not in Workspace, as it relies on the COM feature of Interactive Reporting Studio.

Certain new features make documents ineligible for conversion to the non-Resource Manager format: for example if the 9.3 Interactive Reporting document file has Bubble and Scatter charts, then these are lost when the Interactive Reporting document file is opened in the older version of Interactive Reporting Studio. For information on running the RevertImageResources script, see the Hyperion System 9 BI+ 9.3. Readme.

➤ To import a picture into the Resource Manager:

1 **Select Tools > Resource Manager.**

   The Resource Manager dialog is displayed.

2 **Click**

   The Select Image dialog is displayed.

3 **Navigate to the graphic and click Open.**

   The image is listed in the Resource Manager.

   If you import a picture that is already in the Resource Manager, a warning message is displayed.

   A picture in .BMP format is converted to .PNG format (Portable Network Graphic) before it is loaded into the Resource Manager.

➤ To change the view of pictures in the Resource Manager:

1 **Click**

   A list of available views is displayed.

2 **Select the view of pictures on the Resource Manager dialog.**

   Available view include:

   - List—Displays picture names only.
   - Details—Displays picture name, size, format type and date imported.
   - Preview—Displays actual picture.
   - Thumbnails—Displays reduced size version of all pictures.

➤ To replace a picture:

1 **Select the picture.**

2 **Right-click and select Replace.**

   The Select Image dialog is displayed.

3 **Navigate to the new picture and click OK.**

   An alert shows all sections in which the old picture is referenced. Picture properties set up for the picture in the Resource Manager are only used for new instances of the picture.
4 Click Replace.

➤ To merge a duplicate picture in the Resource Manager:
1 Select the picture.
2 Right-click and select Merge Duplicates.
   An alert shows all sections in which the duplicate pictures are referenced.
3 Click Merge.
   The first selected duplicate is saved in the Resource Manager and all other duplicates are deleted.
   In this case, any references in the Dashboard and Report sections must be updated.

➤ To merge all duplicate pictures in the Resource Manager:
1 Select the picture.
2 Right-click and select Merge All Duplicates.
   Duplicates must have an identical name, size and type to use this feature.
   An alert shows all sections in which the duplicate pictures are referenced.
   All but the first selected picture is deleted.
3 Click Merge All.

➤ To delete a picture from the Resource Manager:
1 Select the picture.
2 Right-click and select Delete.
3 Click Delete.
   Once a picture is delete, all sections that refer to picture show a broken picture image. That is, the picture is represented by a red-cross icon.
   Deleting a picture from the Dashboard or Report sections, only deletes the reference and not the actual picture.

➤ To rename a picture in the Resource Manager:
1 Select the picture.
2 Right-click and select Rename.
   A picture name must be unique and cannot be empty.
   Avoid using the following characters when renaming a picture: _ \ / * ? “ < > | +
**Picture General Properties**

Use the Picture General Properties to display attributes of a picture resource. Picture attributes are determined when the picture is loaded to the Resource Manager. There are no configurable properties on this dialog.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Displays the file format of the picture.</td>
</tr>
<tr>
<td>Size</td>
<td>Displays the size of the picture.</td>
</tr>
<tr>
<td>Imported</td>
<td>Displays the date and time on which the picture was imported to the Resource Manage.</td>
</tr>
<tr>
<td>Data Source</td>
<td>Displays the file path of the disk where the picture is located.</td>
</tr>
<tr>
<td>Configurable options</td>
<td>Displays the picture percent scale (height and width), and picture effect (none, stretch, clip and title).</td>
</tr>
</tbody>
</table>

**Note:**

The attributes shown on this dialog are informational only, and cannot be changed on this dialog.

**Query Menu Command Reference**

The table below provides a quick reference to the commands available on the Query menu and lists any related shortcuts.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Keyboard Shortcut</th>
<th>Shortcut Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Process Results To Table</td>
<td>Allows you to create a table in the database to store your results set.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Estimate Query Size</td>
<td>Queries the database to see how many records your query will retrieve.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show Remarks</td>
<td>Displays any remarks recorded about a topic or topic item.</td>
<td>Ctrl+I</td>
<td>*</td>
</tr>
<tr>
<td>Add Request Item(s)</td>
<td>Adds the selected topic item to the Request line.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Add Filter(s)</td>
<td>Allows you to create a filter for the selected topic item.</td>
<td>Ctrl+L</td>
<td>*</td>
</tr>
<tr>
<td>Add Sort(s)</td>
<td>Adds the selected topic item to the Sort line.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add Computed Item</td>
<td>Allows you to add a new data item derived from server-side calculations performed on an topic item.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
<td>Keyboard Shortcut</td>
<td>Shortcut Menu</td>
</tr>
<tr>
<td>--------------------</td>
<td>-----------------------------------------------------------------------------------------------</td>
<td>-------------------</td>
<td>---------------</td>
</tr>
<tr>
<td>Data Functions</td>
<td>Applies a prebuilt data function to the selected Request item.</td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>Variable Filter</td>
<td>Designates the selected filter item as variable, which causes Interactive Reporting to prompt the user for the filter values when the query is processed.</td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>Customize Filter</td>
<td>Allows you to control access to the features on the Filter dialog box.</td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>Append Query</td>
<td>Allows you to combine two or more queries in one Results set.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Stored Procedures</td>
<td>Loads a stored procedure and displays it as a query object in the Content pane.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Query Options</td>
<td>Opens the Query Properties dialog box where you can specify options for rows returned, time filters, and so on.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Insert Query**

Use the Insert New Query dialog box to insert a new query. You can insert the query associated with a master data model, or log on using the current Interactive Reporting database connection file. Additionally, Interactive Reporting Studio users can select another Interactive Reporting database connection file.

➤ To insert a new query:

1. Select **Insert > New Query**.

   The Insert Query dialog box is displayed.

2. Select **Master Datamodel** to use the master datamodel associated with the query.

3. Select **Logged on connection** to connect to the database using the current database Interactive Reporting database connection file.

4. Select **No connection** not to connect to any database.

5. Click **Yes**.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Master Datamodel</td>
<td>Each time a new query is inserted into an Interactive Reporting document file that contains a master data model, you are prompted to link the new query to the master data model. The benefit is that any changes to the master data model get propagated to all dependent queries that are based on the master data model.</td>
</tr>
<tr>
<td>Logged on Connection</td>
<td>Uses the current Interactive Reporting database connection file.</td>
</tr>
</tbody>
</table>
To create a new Interactive Reporting database connection file:

1. **Select Insert > New Query**.
   The Insert Query dialog box is displayed.
2. **Do not select any options on the first Insert Query dialog and click No**.
   The second Insert Query dialog is displayed.
3. **Select A New Database Connection File** and click OK.
   The Database Connection Wizard is displayed.
4. **Follow the instructions given in the wizard**.
   For more information, see “Creating Interactive Reporting Database Connections (.oces)” on page 421.

To create a new Interactive Reporting document file using a recent new Interactive Reporting database connection file:

1. **Select Insert > New Query**.
   The Insert Query dialog box is displayed.
2. **Do not select any options on the first Insert Query dialog and click Options**.
   The second Insert Query dialog is displayed.
3. **Select Recent Database Connection Files**.
4. **Select an Interactive Reporting database connection file from the Recent Database Connection Files list**.
5. **If you don’t see the desired Interactive Reporting database connection file, click Browse to display the Select Connection dialog box**.
6. **Navigate to the desired Interactive Reporting database connection file and click Open**.
   The Connection Password dialog box is displayed.
7. **Type your user name in the Host User field and password in the Host Password field, and click OK**.

**Tip:**

If you do not have the right Interactive Reporting database connection file to connect to a particular database, ask your administrator to provide the Interactive Reporting database connection file or to help you create an Interactive Reporting database connection file.
To create a blank Interactive Reporting document file with no Interactive Reporting database connection file, select **No Connection** and click **OK**.
Results

Results Section

When you process a query or import data, Interactive Reporting retrieves data to your desktop and displays it in the Results section. Although the query may have accessed several different database tables, the results set is displayed as a single table. Each requested item is displayed as a column in the table and each database record is a row. The Status bar shows the date and time the results set for a particular Results section was last processed (or imported).

Use the Results section to:

- Verify that your query returned the correct information.
- Refine and extend the data set by applying filter conditions or create new computed or grouped items.
- Sort or use text and column formatting features to enhance the appearance of data results.
- Add summary totals or subtotals and compute them with data functions.
- Print or export the retrieved data to other applications.

All reports, including tables, pivots, charts, and those created using the Report Designer, are based on the data that is retrieved to the Results section.

Understanding Data Types

To effectively work with the data in the Results section, you need to understand how Interactive Reporting handles data. Certain functions can only be used on certain types of data.
The Results section formats data in table format. A table is either a fact table or a dimension table. A table is a fact table if it contains at least one fact column. A dimension table contains only dimension columns.

A fact is a quantifiable entity, such as a value or unit of measure. Facts are the numeric values in a relational database that are available for analysis.

A dimension is a descriptive item, such as a name or label.

**Results Data Layout**

Data queried into the Results section automatically loads into the Results data layout to provide an immediate view of items included in the query. This allows you to plot, view, and manipulate the data set returned with the query.

➤ To toggle the Results data layout, click **Data Layout** on the command line.

**Zooming Results**

You can resize the Results section to fit the Contents pane or the printed page.

➤ To resize the Results section:

1. Select **View > Zoom**.
2. Select a size from the sub-menu.

100% is the default size, which prints to fit 8-1/2 * 11 paper.

**Formatting Results Columns**

Interactive Reporting provides the following formatting options for columns in the Results section:

<table>
<thead>
<tr>
<th>Table 16</th>
<th>Results Column Formatting</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Remove Column</strong></td>
<td>To remove a selected column from the table (and data layout), click <strong>Remove Column</strong> on the shortcut menu.</td>
</tr>
<tr>
<td></td>
<td>If you remove an item from the Contents pane, it is removed from the data layout and the data set entirely. You should approach item removal with caution since computed items may draw data values from the deleted item and the Chart, Pivot and Table sections reference the Results set.</td>
</tr>
<tr>
<td></td>
<td>If a computed item references the column to be deleted, a Report Refresh dialog box is displayed and prompts you to either keep the reference or to remove it.</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> The Remove Column option is available for detail and fact columns.</td>
</tr>
<tr>
<td><strong>Select Column</strong></td>
<td>To select a column, click anywhere inside the column.</td>
</tr>
</tbody>
</table>
**Size Column Width**

By default Interactive Reporting truncates Results columns evenly and without regard to the length of data values. Numeric data that does not fit is replaced with pound signs (#).

To auto-size a column so that all values display, choose Format > Column > Auto-Size Width. For narrow or uniform columns to display values without truncation, wrap the text with each column item.

To apply the standard width to a column, click the column and choose Format > Column > Standard Width.

To resize a column manually, click the column, place the cursor over the right edge of the column, and drag the right border to a new position.

<table>
<thead>
<tr>
<th>Modify Column</th>
<th>To modify a computed column or a grouped column, select the column and choose Results &gt; Modify Column.</th>
</tr>
</thead>
</table>
| Hide/Show a Column | To hide a column, select the column and click Hide Column on either the shortcut menu or the Results menu.  
To unhide a column, click anywhere within the Contents pane and click Unhide Column on either the shortcut menu or the Results menu. When the Unhide Column dialog box is displayed, select the desired column and click OK. |
| Hide/Show Column Titles | To hide or show column titles, choose Format > Column Titles.  
When column titles are hidden, the Column Titles option is unchecked  
When column titles are displayed, the Column Titles option is checked. |
| Size Titles | To apply a custom height to a title, drag the bottom edge of a title row to the new position.  
To apply the standard height to a title row, choose Format > Row > Standard Height. |
| Suppress Duplicates | To suppress the duplicate values for a column, select the column and click Suppress Duplicates on either the shortcut menu or the Format menu.  
Use this option to display the first instance in the column of a duplicate value when individual database records include redundant information. This feature is especially useful if records are associated with the same date, location or customer.  
Note: This option is available for detail and fact columns. |
| Wrap Text | To wrap text within a column, select the column and click Text Wrap on either the shortcut menu or the Format menu.  
Note: This option is available for detail and fact columns. |
| Group Columns | To merge dimension labels into new groupings and aggregate the associated data, click Add Grouping Columns on either the shortcut menu or the Results menu. |
| Sort Ascending | To sort column values in ascending order, click Sort Ascending on the Results menu, shortcut menu, or standard toolbar. |
| Sort Descending | To sort column values in descending order, click Sort Descending on the Results menu, shortcut menu, or standard toolbar. |
| Move Column | To move a column, click the column in the Contents pane and drag it to a new position. The corresponding Outline item shifts to reflect the change. |
Formatting Results Rows

Interactive Reporting offers the following formatting options for Rows in the Results section:

**Table 17  Results Rows Formatting**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Hide/Show Row Numbers</strong></td>
<td>To hide row numbers, choose <strong>Format &gt; Row Numbers</strong>. (The Row Numbers option is unchecked in hidden mode). To show column titles, choose <strong>Format &gt; Column Titles</strong>. (The Row Numbers option is checked in show mode.) You can print row numbers on reports, but you cannot copy them to the clipboard or export them to a file.</td>
</tr>
<tr>
<td><strong>Size Rows</strong></td>
<td>To apply a custom height to a row, drag the bottom edge of the row to the new position. To apply the standard height to a row, choose <strong>Format &gt; Row &gt; Standard Height</strong>. When you resize a row, all rows are repositioned in the report.</td>
</tr>
<tr>
<td><strong>Eliminate Duplicate Rows</strong></td>
<td>To eliminate duplicate rows, choose <strong>Query &gt; Query Options</strong>, and enable the <strong>Return Unique Rows</strong> option in the dialog box. Note: If the data source for a query is a local results table even though the Return Unique Rows feature is enabled, the Unique Rows limit is not enforced.</td>
</tr>
</tbody>
</table>

Formatting Results Items

The following table lists common formatting techniques for Results items.

**Table 18  Results Item Formatting**

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Number</strong></td>
<td>To modify the way numbers, dates, and currency are displayed in the Results section, select the item and click <strong>Number</strong> on the shortcut menu or the Format menu; apply any desired changes on the Number Properties dialog box.</td>
</tr>
<tr>
<td><strong>Alignment/Justify</strong></td>
<td>To modify the way an item is justified within a row or column, use one of the following options: Select an item, choose <strong>Format &gt; Justify</strong>, and select the desired justification. Select an item, click <strong>Alignment</strong> on the shortcut menu, and enter the desired changes in the Alignment Properties dialog box.</td>
</tr>
<tr>
<td><strong>Font</strong></td>
<td>To modify the font of a report item, select the item, click <strong>Font</strong> on the shortcut menu or the Format menu, and enter the desired changes in the Font Properties dialog box.</td>
</tr>
<tr>
<td><strong>Borders and Background</strong></td>
<td>To modify the border of a column, select the column and choose <strong>Format &gt; Borders and Background</strong>. To modify the background of a Results section, click anywhere within the Contents pane, choose <strong>Format &gt; Borders and Background</strong>, and enter the desired information in the Border and Background Properties dialog box.</td>
</tr>
</tbody>
</table>
Enhancing Your Results Set

Before generating reports or exporting the data set, verify that the Results section contains all the information you need. You might want to redesign your query and process it again so that the data set is more manageable.

As you begin to refine your querying technique, you will increasingly use more sophisticated filters and computed items and will understand when to use aggregation in the Query section. Complex queries can be somewhat difficult for new users. When using data aggregation features, check the data set before creating reports.

You can return to the Query section to modify your query and refresh the data set if necessary, but you can also apply many of the same refinements locally in the Results section, including filters, sorts, and computations.

Enhancing your results set involves the tasks in these topics:

- “Filtering Results” on page 131
- “Sorting Results Data” on page 132
- “Adding Computed Items to Results” on page 133
- “Applying Data Functions to Results” on page 133
- “Adding Custom Functions” on page 134
- “Adding Grouping Columns” on page 135
- “Adding Columns Automatically” on page 136
- “Breaking Out Dates” on page 137

Filtering Results

Local filters applied in the Results section enable you to temporarily screen out portions of data for reporting purposes, without eliminating them from the data set.

Local filters are discussed in “Server versus Local Filter Processing” on page 328.

You can apply filters to columns to locally filter the data set retrieved from the query. Since the other reporting sections reference the results set, the local filters are also disseminated to these sections.

Local filters are useful for managing your data set. If you decide you do not need all the information retrieved by your query, you can use a local filter to exclude data from the display. These filters are a good way to filter the data set to reflect temporary and hypothetical situations. You can always suspend or delete the filter to return data to the display and make it available for reporting.
To apply a local filter to a column:

1. **Double-click a column.**
   The Filter dialog box is displayed.

2. **If desired, enter a descriptive name for the filter.**

3. **Select an arithmetic or logical operator from the drop-down list.** See also “Using Operators” on page 332.

4. **Define filter values by clicking one of the following options:**
   - **Show Values**—Shows database values associated with the item.
   - **Custom Values**—Supplies an empty field for inputting custom values. Click the check mark to add a value to the list of values. You can also display values from a custom list previously saved with the Interactive Reporting document file or loaded from a file.

5. **Select the values to include in the filter definition.**
   Select values individually or click **Select all** and deselect the values you do not want to include. Only selected items are applied to the filter definition. To create a snapshot of the values, click **Select All** and click **Transfer** to move the variables to the Custom Values.

6. **When the correct values for the filter expression are highlighted in the values list, click OK.**

   **Tip:**
   You can apply only one filter to a column.

To remove a local filter, select the item and choose **Remove** on the shortcut menu.

**Related Topics**

“Server versus Local Filter Processing” on page 328

**Sorting Results Data**

Use the sort buttons to quickly sort a Results column or report item locally on your desktop. You can apply sequenced, nested sort conditions to Request items in the Results section.

For information about sorts, see Chapter 14, “Applying Sorts.”

To sort column data in the Results section, select the column or item to be sorted and click the ascending or descending button on the standard toolbar.

To apply sort conditions using the Sort line, click **Sort** on the Results section titlebar and drag the items to be sorted to the Sort line.

To reverse the sort order for an item, select the item and click the ascending or descending sort icon on the Standard toolbar. Data is sorted in ascending (alphabetical or numerical) order by default.
Adding Computed Items to Results

You can rank and provide statistics for the values represented as totals or subtotals in your Results section. The Add Computed Item command enables you to build equations to compute totals, or to apply functions to values. Computations are performed on the desktop by Interactive Reporting and involve only the data in your Results set. Therefore, you can only create new computed items – you cannot modify original data items that were retrieved from the database. Computed items are like normal data items, and can be included in reports or reused to compute other data.

For example, you can modify the Amount Sold item by building an equation around it, multiplying by the Unit Price item and renaming the resulting item 'Revenue'. You can also apply a scalar function such as Cume to Amount Sold and return each individual value as a cumulative running total, or simply multiply Amount Sold by the local tax rate to find the tax owed on each sale.

In the Results section, reference items are filtered to the items that is displayed on the Request line of the original query. Also, the scalar functions used to compute items are provided at the desktop level rather than the RDBMS.

For more information about computed items, see Chapter 13, “Computed Items.”

Applying Data Functions to Results

In the Results section, you can only use a data function for totals and subtotals. The other values cannot be recalculated without redoing the query. Data functions return to the underlying values and recalculate the value according to the type of function specified.

You can apply a break (subtotal), grand, or custom total to any column. The following table lists the data functions that you can use with break totals and grand totals.

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>Returns sum of underlying values.</td>
</tr>
<tr>
<td>Average</td>
<td>Returns average of underlying values.</td>
</tr>
<tr>
<td>Minimum</td>
<td>Returns lowest of underlying values.</td>
</tr>
<tr>
<td>Maximum</td>
<td>Returns highest of underlying values.</td>
</tr>
<tr>
<td>Count</td>
<td>Returns number of underlying values.</td>
</tr>
<tr>
<td>Other</td>
<td>Allows you to create a custom function using JavaScript.</td>
</tr>
</tbody>
</table>
Inserting Column Totals
Interactive Reporting adds a row labeled Total to the bottom of the table, and display the total as the last entry in the selected column.

➤ To calculate a column total, select the column to be totaled and click the on the Standard toolbar.

Inserting Grand Totals

➤ To apply a grand total to a column using a data function:
1 Select a column and choose Results > Grand Total.
The Insert Grand Total dialog box is displayed.
2 Select a data function from the Grand Total Function drop-down list.
3 Select one or more columns to be totalled from the Add Grand Total To list and click OK.
The total and any subtotals in the column are computed to reflect the new data function.

Inserting Break Totals

➤ To apply a break total (subtotal):
1 Select a column and choose Results > Break Total.
The Insert Break Total dialog box is displayed.
2 Select a break column from the At Every Break drop-down list.
3 Select a data function from the Break Total Function drop-down list.
4 Select one or more columns on which to display the break total and click OK.

➤ To remove a break total:
1 Highlight a break total row by clicking in the left margin.
The break total row is highlighted
2 On the shortcut menu, click Remove Row.
All break totals associated with the rows are removed from the column.

Adding Custom Functions
You can apply custom functions to data in the Results section. Custom functions in the Results section involve only the data in your Results set. Apply the custom functions that you use to aggregated values. Aggregation means that data is grouped and summarized by subjecting the data to some mathematical operation, such as:
The result is a summary of the data at a higher level.

When you insert a mathematical expression at the total level, the total must be aggregated. For example, write: \( \text{Sum(Units)} \times 5 \) instead of: \( \text{Units} \times 5 \).

To apply a custom function:

1. **Access the Custom dialog box by doing one of the following:**
   - Select a numeric column and choose **Results > Break Total**. In the Insert Break Total dialog box, select **Other** from the Break Total Function drop-down list.
   - Select a numeric column and choose **Results > Grand Total**. In the Insert Grand Total dialog box, select **Other** from the Grand Total Function drop-down list.
   - Select a numeric column and click the Grand Total button on the Standard Toolbar. Interactive Reporting displays the total in a new row at the bottom of the selected column. Double-click either the row cell for the total, or double-click another column of numeric values.

   If you double-clicked a total, the Modify Total Function dialog box is displayed. In the Modify Total Function dialog box, select **Other** from the Grand Total Function drop-down list.

2. **In the Custom Function dialog box, enter the desired expression and click OK.**

   The expression must consist of a mathematical operation (aggregate value), the name of the numeric values column, and if applicable, any JavaScript operators.

---

**Adding Grouping Columns**

Grouping columns, like computed items, create new data in your results set by grouping data from a column. You can use grouping columns to consolidate nonnumeric data values into more general group values and map the group values to a new column in the data set.

Grouping columns are new items added to the Results section and are available for use in report sections.

For example, your company sales database may contain the items: State, Sales Region, and Country, which allow you to aggregate data on different levels in reports. However, suppose you are looking to track sales by subregion, or you want to see data for one state versus an average for all other states combined. You can do this by grouping states together to create a Subregion item or other custom dimension.

To add a grouping column:

1. **Select a column as a base for your grouped column.**
2 Select **Results > Add Grouping Column**, or choose **Add Grouping Column** on the shortcut menu.

The Grouped Column dialog box is displayed. Use the column values to build the grouping categories for the new item.

3 **Type a name for the new column in the Column Name field.**

4 **Create custom group values and link them to values in the base column.**

   - Click **New Groups** to create groups and add them to the Groups list.
   - Select a group in the Grps list; select items from the Available Values list and use the arrows to add them to the Items In Group list for the selected group.
   - Remove selected values from a group by using the arrow to move them back to the Available Items list.
   - Double-click a group name to modify it.
   - Click the **Options** button and specify options for Ungrouped values.

Specify options for ungrouped values:

   - **Null**—Leaves the values ungrouped and unaggregated.
   - **Default**—Allows you to specify a default name to assign to all ungrouped values.
   - **Individual Group**—Assigns each ungrouped values the name originally assigned to it.

5 **When the grouping definitions are complete, click OK.**

The new grouping column is added to the Request line and to the Content pane.

### Modifying Grouped Columns

You can modify a grouping column to change the group structure.

To modify a grouped column, select the grouped column and choose **Results > Modify Column**.

### Adding Columns Automatically

By default, Interactive Reporting retrieves data to your desktop and displays it in the Results section as columns. You can manually add request items by having Interactive Reporting return an empty Results set. This allows you to add columns as you need them.

This feature allows you to display selected rows. You can still sort or create filters using columns not displayed in the Results section.

To toggle AutoAdd columns, select **Results > AutoAdd Columns**.

If the AutoAdd Columns feature is selected, all requested items are displayed in columns.

If the AutoAdd Columns feature is not selected, no columns are returned to the Results section and you have to manually add requested items.
**Breaking Out Dates**

Use date breakout columns to separate date-typed columns into Year, Quarter, and Month items. The new items are automatically derived using date functions available to computed items.

For example, when you add date groups for an item Order Date, the item is broken into constituent date items. A new Year item is created as an integer, Qtr as a string, and Month as a new date.

➤ To break out date items:

1. In the Content pane, select a date-type column.
2. Select Results > Add Date Group.

**Note:**

This feature automatically sets the display format of the new Month item to mmm so that the data sorts correctly. Quarters are based on the calendar year beginning 1/1.

**Working with the Results Table**

Interactive Reporting offers a number of options for working with table components (that is, columns and rows) in the Results section. These commands are found on the Format and Results menus. Many of these commands also have corresponding toolbar icons and are available on the shortcut menu.

- “Selecting Columns and Rows” on page 137
- “Deleting Columns” on page 137

**Selecting Columns and Rows**

➤ To select a column, click anywhere inside the column.

➤ To select a row, click the row header (row number).

**Deleting Columns**

➤ To delete a selected column from the Results table (and data layout), select Results > Remove.

If an item is removed from the Content pane, it is completely removed from the data layout and the data set.
Caution!

Remove items with caution as computed items and other report sections may draw data values from the deleted item.

Formatting Commands

You can use the commands available on the Format menu to change the appearance of fonts, backgrounds, borders, color, row heights, and column widths. For more information on formatting options, see Formatting Text and Other Elements. For detailed information on adding sections and customizing the headers and footers in the sections, see Formatting Numeric Data Types.

Saving Results Sets

After you process a query, your data is available until you close the Interactive Reporting document file. Saving your Interactive Reporting document file saves the current formatting and layout of all Interactive Reporting sections.

You have the option to save the results set with the Interactive Reporting document file. You also have the option to save any computed column expressions as a snapshot. Your decision in this selection depends largely on how use the information, and on what information needs to be recalculated.

Saving results with your query allows you to analyze and generate reports without being connected to the database. Results are saved for an individual query or for multiple queries for which results have been generated. You also can specify whether to save any computed columns in the results set as a snapshot with the Interactive Reporting document file.

Note:

If you are working with a Report Designer section, you must save results with the Interactive Reporting document file. If you do not save results, the Report Designer section is not available.

Saving your results set makes sense if you cannot connect to a database, for example, when traveling or working remotely, or if you are scheduling or forwarding documents for someone else.

To save results with the Interactive Reporting document file:

1. Select File > Save Options > Save Query Results With Document.

   The Save Query With Results Document dialog is displayed showing all of the query sections contained in your document.

2. Select the check box associated with the query results to be saved and decide whether to save computed columns as snapshots, and click OK.
The query results and snapshots for computed columns are automatically saved the next time document is saved.

Computed values saved as snapshots are not recalculated when the document is opened. Not even dynamic expressions (for example, values that reference the `sysdate` function such as `date` or `time`) are recalculated. They are recalculated only when the query is reprocessed. Documents that are saved with computed columns as snapshots tend to be larger in size than documents that do not contain snapshots, but they take less time to open.

To automatically recalculate the values of computed columns when a document is opened, do not select the corresponding results section in the Computed Columns list. The document may take longer to open, especially if the results set contains a large number of computed columns or uses complex formulas in the definitions, since all computed values are recalculated in the Results section and in any other section that references the Results section. On the other hand, documents that do not contain snapshots tend to be smaller in size than documents containing snapshots of computed columns.

The following table lists the selection options and effects for saving query results and snapshots of computed columns with documents.

<table>
<thead>
<tr>
<th>Save Query Results</th>
<th>Save Computed Columns (as Snapshot)</th>
<th>What Happens</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>X</td>
<td>Results are saved with the document and computed columns are saved as a snapshot. Computed columns are not recalculated when the document is opened. Values are recalculated only when the query is reprocessed.</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>Results are saved with the document but computed columns are not saved as a snapshot. Computed columns are recalculated when the document is opened.</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>Neither Results nor computed columns are saved with the document.</td>
</tr>
<tr>
<td>X</td>
<td>X</td>
<td>Neither Results nor computed columns are saved with the document.</td>
</tr>
</tbody>
</table>

**Note:**

You cannot save computed columns as snapshots unless you first save the corresponding query results.

**Exporting Result Sets**

After processing a query, you can export the data contents of the Results section for use in other applications. There are several ways to export, the most common being into file formats such as Excel or Lotus.
Interactive Reporting also exports to HTML format, making it easy to distribute data to many corporate intranets or Web sites. Exported Results section data is raw and unaggregated. If you export from a report section, the data is drawn from the desktop data cube and is preaggregated. Scripts created by the Interactive Reporting JavaScript engine can be saved to a text file.

Export options are discussed in detail in “Exporting Data” on page 45. This section also covers export properties such as whether to use page breaks in HTML files, or whether to include double quotation marks in tab-delimited text files.

## Extended Access for Interactive Reporting

Extended Access for Interactive Reporting enables users to jointly analyze multidimensional and relational sources in one document. It retrieves the flattened OLAP results from a Oracle’s Hyperion® SQR® Production Reporting – System 9, and Oracle’s Hyperion® Financial Reporting – System 9 query in the Reporting and Analysis repository and imports the data into the Interactive Reporting document as a results section. Extended Access for Interactive Reporting also enables:

- An end user can perform quick ad-hoc analysis by drilling down, swapping and pivoting on the data to see patterns or exceptions.
- The results section can be used as a new data source and can be joined with other data sources either from the database or other tables.
- The end user can perform offline analysis for multidimensional data.
- The Interactive Reporting document can be refreshed with multidimensional data.
- The Query/Report (Oracle’s Hyperion® Web Analysis – System 9) can be refreshed.
- The latest job output/snapshot (SQR Production Reporting and Financial Reporting) can be retrieved.

The following steps assume that a Web Analysis query (Web Analysis document), SQR Production Reporting query (SQR Production Reporting job output) or a Financial Reporting query (Batch report) is resident in Workspace. These queries should be formatted so that their data is compatible in a relational query (flattened data), see the WorkspaceUser online help.

**Note:**

Extended Access for Interactive Reporting does not support null values. If a null value is needed for the document, the user must convert the null value to a special value in Oracle’s Hyperion® Financial Reporting – System 9, Oracle’s Hyperion® Web Analysis – System 9 and Oracle’s Hyperion® SQR® Production Reporting – System 9 and use an Interactive Reporting function to convert it back to a null value.

Extended Access for Interactive Reporting can only be done in the Interactive Reporting Web Client application. If the Interactive Reporting Web Client application has not been installed, select **Tools > Install > Interactive Reporting Web Client**. When the Interactive Reporting Web Client Setup dialog is displayed, complete the installation.
To import a multidimensional data source into an Interactive Reporting document:

1 In Workspace, navigate to the Interactive Reporting document to which you want to extend access for a multidimensional report.

2 Select the Interactive Reporting document and select Open as > Interactive Reporting Web Client from the shortcut menu.

   The selected document is displayed in the Interactive Reporting Web Client.

3 Navigate to the section to which you want to add the multidimensional report as a results set.

4 Select File > Import Data > From Repository.

   The Reporting and Analysis Select dialog is displayed.

5 Navigate to the folder which contains the repository document.

6 Double-click the object to select it.

   Make sure that the object name displays in the Name field.

7 Click Select.

   The object is displayed in Sections list as a results set.

Results Menu Command Reference

The following table provides a quick reference to the commands available on the Results menu and lists any related shortcuts.

<table>
<thead>
<tr>
<th>Table 21</th>
<th>Results Menu Commands</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>Filter</td>
<td>Opens the Filter dialog box.</td>
</tr>
<tr>
<td>Sort Ascending</td>
<td>Sorts the selected column values in ascending order (alphabetical or numeric).</td>
</tr>
<tr>
<td>Sort Descending</td>
<td>Sorts the selected column values in descending order (alphabetical or numeric).</td>
</tr>
<tr>
<td>Add Computed Item</td>
<td>Opens the Insert Computed Item dialog box.</td>
</tr>
<tr>
<td>Add Grouping Column</td>
<td>Opens the Grouped Column dialog box. Use to merge dimension labels into new groupings and aggregate the associated data.</td>
</tr>
<tr>
<td>Add Date Groups</td>
<td>Separates date-type items into year, quarter, and month items.</td>
</tr>
<tr>
<td>Modify Column</td>
<td>Use to modify a computed column or a group column.</td>
</tr>
<tr>
<td>Remove</td>
<td>Removes the selected column (or data layout item).</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Break Total</td>
<td>Opens the Insert Break Total dialog box.</td>
</tr>
<tr>
<td>Grand Total</td>
<td>Opens the Insert Grand Total dialog box.</td>
</tr>
<tr>
<td>Hide Column</td>
<td>Hides the selected column from view.</td>
</tr>
<tr>
<td>Unhide Column</td>
<td>Opens the Unhide Column dialog box.</td>
</tr>
<tr>
<td>AutoAdd Columns</td>
<td>Automatically adds columns in the Content pane for all requested items.</td>
</tr>
<tr>
<td></td>
<td>If not selected, no columns are displayed in the Content pane. Turn this option off to manually add columns for requested items.</td>
</tr>
</tbody>
</table>
Working with Tables

In This Chapter

- Table Section...........................................................................................................................................................143
- Creating Tables........................................................................................................................................................143
- Tables as a Data Staging Area.................................................................................................................................144
- Manipulating Table Data..........................................................................................................................................144
- Working with Table Components...............................................................................................................................150
- Table Menu Command Reference.............................................................................................................................150

Table Section

A table is a columnar arrangement of data. Tables are used as building blocks in other reporting sections. A Table section functions is used in much the same way as the Results section. All of the commands that are available on the Results menu are also available on the Table menu. However, you cannot apply complex filters or aggregate data in the Table section.

The data in a Table section is derived from the section that is active when you insert a new table. When you insert a Table section from the Results section, the new Table section is attached to the Results section. This means any changes to the results set are propagated immediately to the Table section.

You can also create additional tables, Pivot tables, Charts, and other reports form a dataset of a Table section just as you would from the Results section. Filters, computed columns, grouping columns, and other actions that modify the dataset of an active section set carry over to all tables and reporting sections built from that section.

Creating Tables

Use the Table data layout to construct, plot, and manage data.

➤ To create a table based on the Results section data:

1 From the Results section, select Insert > New Table.

If the Table data layout is not already displayed, click data layout on the Section title bar.
2 Drag Results items from the Catalog pane to the Table data layout.

Interactive Reporting populates automatically the table columns.

**Tables as a Data Staging Area**

A *computed item* in the Results section becomes a mere data element when added to a Table section. Thus, the Table section can become an intermediate calculation staging area. This ability comes in handy in applications where you wish to place filters on computed items.

For example, suppose you want a report of the top ten producers in your organization. It is easy to add a computed item to your Results section that is based on the Rank function. (This function lets you find out each producer’s rank relative to the others.) However, when you try to filter the results based on that ranking, Interactive Reporting informs you that filters cannot be placed on aggregate items.

To get the results, insert a new Table section based on your Results section. Next, add all the relevant Results items, including the computed Rank field. Once Rank is a column in the table, it is no longer a computed item. It is a regular number on which you can now place a filter. Since the Table section is based on the Results section, your Top 10 report is updated automatically each time you run the query.

**Manipulating Table Data**

The Table menu provides a number of commands that enable you to manipulate the data in the Table section. Review the following sections for information on:

- Filtering Table Data
- Sorting a Table
- Adding Computed Items
- Adding Grouping Columns
- Adding Date Groups
- Applying Data Functions to Tables

**Filtering Table Data**

Filtering data in a table filters the data displayed in the table columns. You can apply filters in the Table section in addition to any filters set in the originating section. Filters set in the Table section are automatically propagated to any other reports that inherit their data set from the table. You can apply only one filter per column.

To return data to the display and make it available for reporting, delete or suspend the filter.

➤ To filter data in a table:

1 Double-click a column, or click the column heading and select Table > Filter.
The Filter dialog box is displayed.

2 Select an arithmetic or logical operator from the drop-down list box.

3 Define the potential filter values by selecting one of the following options:
   - Show Values—Shows column values associated with the item.
   - Custom Values—Supplies an empty field for inputting custom values. Select the check mark to add a value to the list.

4 In the Values list, select the values to include in the filter definition.
   Individually select values or click Select All and deselect the values that you do not want to include.

5 When the values are highlighted in the values pane, click OK.
   The filter is applied to the column and the column name is added to the Filter line.

➤ To remove a filter in a table, select the filter item and choose Table > Remove.

➤ To remove a filter in a table, select the filter and do one of the following:
   - Click the Delete key.
   - Select Table > Remove.
   - Click Remove on the shortcut menu.

➤ To remove all filters in a table, click Filter on the Filter line and select Table > Remove.

➤ To remove all filters in a table, click Filter on the Filter line and do one of the following:
   - Click the Delete key.
   - Select Table > Remove.
   - Click Remove on the shortcut menu.

### Sorting a Table

You can sort the rows in a table by one or more columns in ascending or descending order. You can also apply sequenced, nested sorts to columns in the Table section.

➤ To sort a column, select the column and choose Table > Sort Ascending or Sort Descending.

➤ To apply sort conditions:
   1 Click Sort on the Section Title bar to display the Sort line.
   2 Drag Results items from the Catalog pane to the Sort line.
      You can add items to the Sort line that are not in the data layout.
   3 Establish a final sort sequence by reordering sort items.
Items are sorted left to right on the sort item. To reorder the sequence, drag each item to its new position.

4 **Double-click specific sort items to toggle ascending and descending sort orders.**

Ascending is the default sort order.

5 **Click Sort Now on the Sort line.**

## Adding Computed Items

You can rank and provide statistics for the values represented in the totals or subtotals. The Add Computed Item feature enables you to build equations to compute totals, or to apply functions to values. Computed items are like normal data items and can be included in reports or reused to compute other data. For example, you can modify an *Amount Sold* item by building an equation around it, multiplying by a *Unit Price* item, and renaming the resulting item *Revenue*. You can apply a scalar function such as *Cume* to *Amount Sold* and return each individual value as a cumulative running total, or simply multiply *Amount Sold* by the local tax rate to find the tax owed on each sale.

The Computed Item dialog box is used to build a computed item expression. The computed item expression is a value, variable, logic statement, or equation that instructs Interactive Reporting how to perform a computation.

➤ **To create a computed item:**

1 **Select Table > Add Computed Item.**

   The Computed Item dialog box is displayed.

2 **In the Name field, type a name that describes the computation.**

   The default name is Computed, which is numbered sequentially if there is more than one. If you assign a name to a computed item that is identical to a scalar function name, Interactive Reporting numbers the name starting with the number 2.

3 **Define the new data item by building an expression in the Definition text box.**

   Use the operator buttons to insert arithmetic and logical operators at the insertion point.

   ● Click **Reference** to display the Reference dialog box, and select Request items to place in the equation.

   ● Click **Functions** to apply scalar functions using the Functions dialog box.

   You can also type any portion of the equation or the entire equation directly into the Definition text box using *JavaScript*. The names are case sensitive, and you must replace spaces in item names with underscores ("_").

4 **If necessary, click Options to set a new data type for the item.**

5 **When the equation is complete, click OK.**

   The computed item is added to the data layout and it is displayed as a table column.
Adding Grouping Columns

Grouping columns is a way of creating new data in your results set by grouping data from a column. You can use grouping columns to consolidate non-numeric data values into more general group values and map the group values to a new column in the data set.

Grouping columns are new items added to the Table section and are available for use in report sections.

For example, your company sales database may contain the items: State, Sales Region, and Country, which enable you to aggregate data on different levels in reports. However, suppose you are looking to track sales by subregion, or want to see data for one state versus an average for all other states combined. You can do this by grouping states together to create a subregion item or other custom dimension.

To add a grouping column:

1. Select a column from which to base grouping column.
2. Select Table > Add Grouping Column.

   The Grouped Column dialog box is displayed.

   Use the column values to build the grouping categories for the new item.

3. Type a name for the new column in the Column Name field.
4. Create custom group values and link them to values in the base column.

   ● Click New Groups to create groups and add them to the Groups list.
   ● Select a group items from the Available Values list. Use the arrows to add them to the Items In Group list for the selected group.
   ● Remove selected values from a group by using the arrow to move them back to the Available Items list.
   ● Double-click a group name to modify it.

Specify options for ungrouped values as follows:

   ○ Column Name—Names the new grouping column in the table.
   ○ New Groups—Creates a custom group to be displayed as a value in the new grouping column.
   ○ Options—Indicates how to represent unassigned values within the grouping column, that is, as null values, as members of a default group (named in the adjacent edit field), or as their own individual groups.
   ○ Groups—Selects a custom group to define by adding or removing items.
   ○ Items In Group—Removes an item from a selected custom group.
   ○ Available Values—Adds items to a selected custom group.

Select one of the following options to define the preferences for ungrouped columns:

   ○ Null—Leaves the values ungrouped and disaggregated.
   ○ Default—Enables you to specify a default name to assign to all ungrouped values.
Individual Group—Assigns each ungrouped values the name originally assigned to it.

5 When the grouping definitions are complete, click OK.

The new grouping column is added to the data layout and to the table.

Modifying Grouping Columns

You can modify a grouping column to change the group structure.

➤ To modify a grouping column, select the grouping column and choose Table > Modify Column.

Adding Date Groups

Use date breakout columns to separate date-typed columns into Year, Quarter, and Month items. The new items are automatically derived using date functions available to computed items.

For example, when you add a date group for an item Order Date, the item is broken into constituent date items. A new Year item is created as an integer, Qtr as a string, and Month as a new date.

➤ To break out date items:

1 Select a date-type column in the Content pane.

2 Select Table > Add Date Group.

Note:

This feature automatically sets the display format of the new Month item to mmm so that the data sorts correctly. Quarters are based on the calendar year beginning 1/1.

Applying Data Functions to Tables

In the Tables section, a Dashboard can be used only for totals and subtotals. Data functions return to the underlying values and recalculate the value according to the type of function specified.

You can apply a break (subtotal), grand, or custom total to any column. A grand total on a numeric column applies a default sum function. However, each column can have a number of grand totals, each with a different aggregate function applied to it. The table below lists the data functions that you can use with break totals and grand totals.

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>Returns sum of underlying values.</td>
</tr>
<tr>
<td>Function</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Average</td>
<td>Returns average of underlying values.</td>
</tr>
<tr>
<td>Minimum</td>
<td>Returns lowest of underlying values.</td>
</tr>
<tr>
<td>Maximum</td>
<td>Returns highest of underlying values.</td>
</tr>
<tr>
<td>Count</td>
<td>Returns number of underlying values.</td>
</tr>
<tr>
<td>Other</td>
<td>Enables you to create a custom function using JavaScript.</td>
</tr>
</tbody>
</table>

**Column Totals**

Interactive Reporting adds a row labelled *Total* to the bottom of the table and display the total as the last entry in the selected column.

➢ To calculate a column total, select the column to be totaled and click on the Standard toolbar.

**Grand Totals**

➢ To apply a grand total to a column using a data function:

1. **Select a column and choose Table > Grand Total.**
   The Insert Grand Total dialog box is displayed.

2. **Select a data function from the Grand Total Function drop-down list box.**

3. **Select one or more columns to be totaled from the Add Grand Total To list and click OK.**
   The total and any subtotals in the column are computed to reflect the new data function.

**Break Totals**

➢ To apply a break total (subtotal):

1. **Select a column and select Table > Break Total.**
   The Insert Break Total dialog box is displayed.

2. **Select a break column from the At Every Break in drop-down list box.**

3. **Select a data function.**

4. **Select one or more columns on which to display the break total and click OK.**
Working with Table Components

Interactive Reporting offers a number of options for working with table components (that is columns and rows) in the Table section. These commands are found on the Format and Results menus. Many of these commands also have corresponding toolbar icons and shortcut menu items.

Selecting Columns and Rows

➤ To select a column, click anywhere inside the column.

➤ To select a row, click the row header (row number).

Deleting Columns

➤ To delete a selected column from the Results table (and data layout), select Results > Remove. If an item is removed from the Content pane, it is completely removed from the data layout and the data set.

Caution!

Remove items with caution as computed items and other report sections may draw data values from the deleted item.

Table Menu Command Reference

The table below provides a quick reference to the commands available on the Table menu and lists any related shortcuts.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Keyboard Shortcut</th>
<th>Shortcut Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter</td>
<td>Opens the Filter dialog box.</td>
<td>Ctrl+L</td>
<td>*</td>
</tr>
<tr>
<td>Sort Ascending</td>
<td>Sorts the selected column values in ascending order (alphabetical or numeric).</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Sort Descending</td>
<td>Sorts the selected column values in descending order (alphabetical or numeric).</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Add Computed Item</td>
<td>Opens the Insert Computed Item dialog box.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
<td>Keyboard Shortcut</td>
<td>Shortcut Menu</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-------------------</td>
<td>---------------</td>
</tr>
<tr>
<td>Add Grouping Column</td>
<td>Opens the Grouped Column dialog box. Use to merge dimension labels into new groupings and aggregate the associated data.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Add Date Groups</td>
<td>Separates date-type items into year, quarter, and month items.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Modify Column</td>
<td>Use to modify a computed column or a group column.</td>
<td>Ctrl+M</td>
<td></td>
</tr>
<tr>
<td>Remove</td>
<td>Removes the selected column (or data layout item).</td>
<td>Del</td>
<td>*</td>
</tr>
<tr>
<td>Break Total</td>
<td>Opens the Insert Break Total dialog box.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Grand Total</td>
<td>Opens the Insert Grand Total dialog box.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Hide Column</td>
<td>Hides the selected column from view.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Unhide Column</td>
<td>Opens the Unhide Column dialog box.</td>
<td></td>
<td>*</td>
</tr>
</tbody>
</table>
From the document, the first page begins with a section called "7 Querying Multidimensional Databases," suggesting the chapter focuses on querying multidimensional databases. Below is the continuation of the text:

In This Chapter

OLAPQuery Section..................................................................................................................................................153
Defining OLAPQuery Options.................................................................................................................................154
Building OLAP Queries...............................................................................................................................................157
Refining OLAPQuery Data........................................................................................................................................раж
Processing OLAP Queries...........................................................................................................................................159
Applying Filters............................................................................................................................................................165
Changing Data Views...................................................................................................................................................166
Formatting OLAPQuery Items.......................................................................................................................................171
Drilling Through from a Multi-Dimensional Database to a Relational Database....................................................174
OLAP Menu Command Reference................................................................................................................................176

OLAPQuery Section

Use the OLAPQuery section to query multidimensional) or OLAP databases. When you connect to a multidimensional database, the document opens an OLAPQuery section.

The user interface is similar to the Pivot section, except the OLAPQuery section displays the multidimensional database components as a hierarchical tree in the Catalog pane. These components include:

- **Dimensions**—categories of information, such as Location, Products, Stores, and Time. Dimensions are for informational use only and cannot be used as query items. (If a dimension contains multiple hierarchies, they will be represented under the dimension.)
  - **Levels**—Groups of similar types of members. For example, using the members listed in a Location dimension, Japan, USA, and France belong to the Country level. San Francisco, Paris, Tokyo, and Rome belong to the City level. 35 Main Street belongs to the Address level.
  - **Hybrid (Analysis)**—Further dimensional data is present by way of Hybrid Analysis (the lowest levels of an Essbase or DB2 cube that can reside in a relational database, but are not reflected in the cube structure (metadata) that is resident on the Essbase Server itself). If a dimension has Hybrid Analysis data, the Essbase Server, in conjunction with the Essbase Integration Server automatically retrieves the data from the appropriate relational table source and passes it to Interactive Reporting. If a dimension has available hybrid analysis, it is indicated to the right of the level as shown below.
Members—Content values for a dimension. In the Location dimension, they could be: San Francisco, Japan, Paris, 35 Main Street, Tokyo, USA, France, Rome, and so on. These all are values for location.

Members are shown only under the Values (I) icon and can be dragged only into the Top Labels or Side Labels panes in data layout.

Member Property—A descriptive piece of information about a member that can be retrieved and displayed in the OLAPQuery. This information is metadata and does not in itself constitute a distinct member in the dimensional hierarchy. For example, let’s assume the following hierarchy:

Product
  Category
    Product Name

The Product Name level might have the following properties defined:

Product Description
Product SKU
Color
Size
Weight

You can drag a property into the data layout with its corresponding level, but you cannot drag it into the Slicer or the Measures pane, or apply a filter to it.

Measures—Numeric values in a database cube that are available for analysis. The measures could be margin, cost of goods sold, unit sales, budget amount, and so on.

Individual measures are shown under the Measures icon and can be dragged only to the Measures pane.

Note:

Essbase only. Interactive Reporting supports Essbase Attribute Dimensions. An Attribute Dimension displays in the OLAPQuery section with the word “attribute” to right of the Attribute Dimension’s name. In addition, for each Attribute Dimension, Interactive Reporting creates an Attribute Calculation Dimension. An Attribute Calculation Dimension is displayed at the bottom of the Catalog pane. You can position the members contained within the Attribute Calculation Dimension in the Top or Side Labels of the data layout.

Defining OLAPQuery Options

Interactive Reporting enables you to set options that control various properties in the OLAPQuery section.

- “General OLAPQuery Options” on page 155
- “Database-specific OLAPQuery Options” on page 155
To define OLAPQuery options, select OLAP > OLAP Query Options.

General OLAPQuery Options

General OLAPQuery options can be adjusted regardless of the database. The General tab in the OLAP Query options dialog box is displayed as follows:

Table 24  General OLAPQuery Options

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Design Options</td>
<td>Defines how Interactive Reporting retrieves database totals and re-queries the database.</td>
</tr>
<tr>
<td>● Database Totals—Retrieves database totals when the query is processed.</td>
<td></td>
</tr>
<tr>
<td>● Hardwire Mode—Defines whether to re-query the database when changes are made in the data layout.</td>
<td></td>
</tr>
<tr>
<td>❍ If you select Hardwire mode, Interactive Reporting queries the database automatically when you add an item to or remove an item from the data layout and instantaneously retrieve the data. You do not have to click Process.</td>
<td></td>
</tr>
<tr>
<td>❍ If you do not select Hardwire mode, you must click Process to query the database again whenever you make a change.</td>
<td></td>
</tr>
<tr>
<td>Slicer Display</td>
<td>Defines how to display slicer values.</td>
</tr>
<tr>
<td>● Member List—Selects from a list of all members at the same level as the previously selected member.</td>
<td></td>
</tr>
<tr>
<td>● Tree Control—Displays parent-child slicer value relationships. With Tree Control, you can select multiple values from a dimension as long as your database supports this function. (Databases such as Hyperion Essbase and IBM DB2 OLAP allow this).</td>
<td></td>
</tr>
<tr>
<td>Drill Options</td>
<td>Defines what level of data is the next level displayed when you drill down in an OLAPQuery.</td>
</tr>
<tr>
<td>● Drill to Next Level—Displays data for the next level below the selected member.</td>
<td></td>
</tr>
<tr>
<td>For example, in a dimension with levels of Year, Quarter, Month, and Date, double-clicking on a Year level member name automatically displays all the data for the Quarter level belonging to that year.</td>
<td></td>
</tr>
<tr>
<td>● Drill to All Levels—Displays all possible levels of data below the selected member.</td>
<td></td>
</tr>
<tr>
<td>For example, in a dimension with levels of Year, Quarter, Month, and Date, double-clicking on a Year level member name automatically displays all the data for the Quarter, Month, and Date levels belonging to that year.</td>
<td></td>
</tr>
<tr>
<td>● Drill to Lowest Level—Automatically displays data for only the lowest level belonging to the selected member (intermediate member levels are not shown).</td>
<td></td>
</tr>
<tr>
<td>For example, in a dimension with levels of Year, Quarter, Month, and Date, double-clicking on a Year level member name automatically displays all the data for the Date level belonging to that year.</td>
<td></td>
</tr>
</tbody>
</table>

Database-specific OLAPQuery Options

Database-specific OLAPQuery options depend on the database to which you are connected. As a result, the content on the tab in the dialog box varies according to the type of database connection.
Display Options for Essbase Databases

The tab for Essbase databases is displayed as follows:

Table 25  Display Option for Essbase Database

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Query Options</strong></td>
<td>Defines query options in the following areas:</td>
</tr>
<tr>
<td></td>
<td>• <strong>Suppress Missing Rows</strong>—Suppresses the retrieval of any missing rows where all cells are null.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Suppress Zero Rows</strong>—Suppresses the retrieval of any zero rows where all cells are null.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Specify the number of decimal places to retrieve</strong>—Sets the number of decimal places that the server will return.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Enable Hybrid Analysis Value Retrieval</strong>—This feature allows you to retrieve the lowest levels of an Essbase cube that reside in an external relational database. These levels are not reflected in the cube structure (metadata) that is resident on the Essbase Server itself. Instead, their existence and retrieval is performed by the separate Essbase Integration Server product.</td>
</tr>
<tr>
<td></td>
<td>In order for this functionality to be performed, however, the Essbase server must first receive instructions to enable Hybrid Analysis retrieval. This instruction takes the form of an EssbaseReport Script keyword:</td>
</tr>
<tr>
<td></td>
<td>&lt; HYBRIDANALYSISON&gt;</td>
</tr>
<tr>
<td></td>
<td>Conversely, to disable Hybrid Analysis retrieval, the instruction keyword</td>
</tr>
<tr>
<td></td>
<td>&lt;HYBRIDANALYSISOFF&gt;</td>
</tr>
<tr>
<td></td>
<td>The applicable keyword used sent to the Essbase Server can be viewed on the Query Log.</td>
</tr>
<tr>
<td></td>
<td>This feature is only supported in Hyperion Essbase version 6.5 and IBM DB2 OLAP version 8.1.</td>
</tr>
<tr>
<td><strong>Alias Table</strong></td>
<td>Defines the alias table to use in an OLAPQuery.</td>
</tr>
<tr>
<td></td>
<td>• <strong>Select an Alias Table</strong>—When you use aliases to assign user-friendly names to database physical member and/or generation/level names, Essbase stores the aliases in an Alias Table in the cube. Since a cube can have multiple alias tables, you can select the alias table to use and modify the query based on the value you enter.</td>
</tr>
<tr>
<td></td>
<td>For example, you could define Store Category members as codes, but define an alias for each Store Category to use as a descriptive alias in the Alias Table.</td>
</tr>
<tr>
<td></td>
<td>In the following example, for the member name &quot;0199&quot;, you could see either &quot;January 11999&quot;, &quot;Jan99&quot; or Fiscal Month 1&quot; depending on the selected alias table. By default, uses the default alias table and if another alias table were not selected, you would see &quot;January 1999.&quot;</td>
</tr>
<tr>
<td></td>
<td>Physical Member Name = 0199</td>
</tr>
<tr>
<td></td>
<td>Default Alias Table Value = January11999</td>
</tr>
<tr>
<td></td>
<td>Alias Table 1 Value = Jan99</td>
</tr>
<tr>
<td></td>
<td>Alias Table 2 Value = Fiscal Month 1</td>
</tr>
</tbody>
</table>
Display Options for Microsoft OLE/DB

The tab for Microsoft/OLE DB for OLAP databases is displayed as follows:

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Suppress Empty Rows</td>
<td>Suppresses the retrieval of any empty rows for which there is no measure data.</td>
</tr>
</tbody>
</table>

Building OLAP Queries

Interactive Reporting uses the data layout to manage multidimensional information. The data layout enables you to plot, view, and manipulate dimensions. The three data layout panes are:

- **Side Labels**—Contains non-quantifiable dimensions or members.
- **Top Labels**—Contains non-quantifiable dimensions or members.
- **Measures**—Contains quantifiable dimensions or measures. The Measures pane in data layout holds the values of the cube.

**Note:**

Interactive Reporting treats time and date dimensions as non-quantifiable values.

To build an OLAP query:

1. **Select Tools > Options > Program Options > OLAP.**
   The OLAP tab is displayed.

2. **Select Use Old OLAP Query section and click OK.**
   By default, new Essbase queries use the new Section type (CubeQuery). The Old OLAP query can be used by selecting Tools > Options > Program Options > OLAP > Use Old OLAP Query section.

3. **Select Insert > New Query.**
   The Insert Query dialog box is displayed.

4. **Select an Interactive Reporting connection file in which to connection.**
   See Insert Query for more information.
   The Query section is displayed.

5. **If the data layout is not visible, click Data Layout on the Section title bar.**

6. **In the Catalog pane, select one or more measures (such as units or amounts) and choose OLAP > Add Fact/Measure to add the item(s) to the Measures pane in data layout.**

7. **In the Catalog pane, select one or more levels or members and choose OLAP > Add Side Labels to add the item to the Side Labels pane in data layout.**
In the Catalog pane, select one or more levels or members and choose OLAP > Add Top Label to add the item to the Top Labels pane in data layout.

To refresh the dimension values in the Catalog pane, select OLAP > Retrieve Dimensions.

When you drag items from the Catalog pane to the data layout, only the level names is displayed. For example, if you drag CA into the data layout, the data layout displays State. Level names are displayed in the data layout preceded by an icon, ■.

You can reorient, or pivot, your OLAPQuery by interchanging the items in the top and side dimensions. This feature is useful for juxtaposing data in one dimension with data from other dimensions. By pivoting dimensions from the top to the side, alternate relationships become evident.

**OLAPQuery Section Data Layout Rules**

The following rules apply to the OLAPQuery section data layout:

- A dimension can be represented only on one axis. For example, if the level Year is in the Side Labels pane, you cannot drag the level Quarter to the Top Labels pane.

- If you move the level of one dimension, Interactive Reporting automatically move all levels of the same dimension.

- To pivot data in the OLAPQuery section, move the items in the data layout panes. You cannot use the label handles to pivot data.

- Levels from the same dimension must be grouped together in both the Side Labels and Top Labels panes.

For example, you cannot use the following order for side-label levels, since levels from different dimensions are mixed (Year, Quarter, and Month come from the Time dimension, Store Type comes from the Store dimension, and Product Category comes from the Product dimension).

Instead, the data layout requires that you use this order (Year, Quarter, and Month are all from they same dimension so they are grouped together).

- The hierarchy of a dimension cannot be broken. For example, Year must come before Quarter, which must come before Month.

- “Hybrid Analysis” (Essbase only)—If data is successfully retrieved from the Essbase servers, a “dummy” Level is added to the data layout called "Hybrid1". The new Level of data is shown in the Contents Pane. If data is not retrieved successfully from the Essbase servers (i.e. an error message is returned) the message "No more levels to drill into" message is displayed. If you subsequently drills-down on a returned Hybrid Analysis Level of data, the retrieved Hybrid Analysis Level of data is called "Hybrid2" and so on.

- OLE DB only —If you retrieve dimensional level properties from the database, you can drag each property into the data layout after you add its corresponding level.

For example, if the data layout contains Country, Year and you drag Manager, (a property of Country) into the data layout, the Manager property is kept with Country and not added
after the Year level. A property cannot be dragged into the Slicer pane, the Measures pane in data layout, or have a filter applied to it.

Note that in order to retrieve dimensional level properties, you must enable the Show Member Properties checkbox when creating the Interactive Reporting database connection file.

**OLAPQuery Member and Level Rules**

If you include both members and levels together in a query, a union of the two data sets occurs, and not an intersection. For example, if you select a State level and select San Francisco (which is a city), your query retrieves all states and San Francisco.

The following table shows the results of different queries.

<table>
<thead>
<tr>
<th>Data Layout Item(s)</th>
<th>Component Type</th>
<th>Query returns:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Country (All)</td>
<td>Level</td>
<td>All countries</td>
</tr>
<tr>
<td>State (All)</td>
<td>Level</td>
<td>All states regardless of country</td>
</tr>
<tr>
<td>City (All)</td>
<td>Level</td>
<td>All cities regardless of state or country</td>
</tr>
<tr>
<td>Canada</td>
<td>Member</td>
<td>Canada only</td>
</tr>
<tr>
<td>CA</td>
<td>Member</td>
<td>California only</td>
</tr>
<tr>
<td>San Francisco</td>
<td>Member</td>
<td>San Francisco only</td>
</tr>
<tr>
<td>State (All), San Francisco</td>
<td>Level, Member</td>
<td>All States regardless of country and San Francisco</td>
</tr>
<tr>
<td>Country (All), CA</td>
<td>Level, Member</td>
<td>All Countries and California (not just the USA)</td>
</tr>
<tr>
<td>Country (All), State (All), CA, NV, San Francisco</td>
<td>Level, Level, Member, Member, Member</td>
<td>All Countries, All States</td>
</tr>
</tbody>
</table>

**Refining OLAPQuery Data**

Once you have identified the items to include in your OLAP query, you can perform numerous operations to refine the data such as setting slicer filters, specifying drill data, adding computed items, data functions, and so on. Review the following sections for information on each of these functions.

- Specifying a Slicer
- Drilling Down
- Drilling Up
Specifying a Slicer

A slicer is a sort of third axis in a query that filters data. The other axes are the row axis and the column axis. A slicer defines a logical slice of the server cube by instructing the server to ignore all values not part of your slice. For example if you were running a query for general category stores, you could apply a slicer that slices the category stores into store subsets, such as computer stores, discount stores, and electronic stores.

When working with a slicer, use only an individual member from a dimension. The dimension cannot be used in a Top Label or Side Label (no dimension can be represented on more than one axis at any time).

Tip:

A query can have multiple slicers, each from a different dimension.

To specify a slicer:

1. Click Slicer on the Section title bar to open the Slicer pane.
2. Select a member from a dimension in the Catalog pane and drag it to the Slicer pane.
   Every dimension folder contains a members subfolder named “Values for …” that domain. The subfolder contains the members eligible for selection in the Slicer pane.
3. Click Process.
   If you are running in Hardwire mode (see “Processing OLAP Queries Automatically” on page 165), the slice is applied instantly.

Drilling Down

The Drill Down feature retrieves data from the multidimensional database cube, following the hierarchy down to the granular level. When you want to learn more about an item, such as a product line, drill down into the item label. You can drill down on one or items.

For a member drill down, any Top Label or Side Label can be drilled down so that you can view the structure of the hierarchies for any particular dimension. Every time you select a specific label in a dimension row or column, show only the data for that label value. When you select the dimension tab for a level, show all the members of that dimension level.

Use one of the methods to drill down on a label:

- Double-click the label.
- Select the label and choose Drill Down on the shortcut menu.
Select the label and choose **OLAP > Drill Down**.

**Tip:**
You can specify what level of data is the next level displayed when you drill down in an OLAPQuery. See “**General OLAPQuery Options on page 155**” for information.

**Note:**
You cannot set filters while in a drilled-down state on a dimension.

**Note:**
**Essbase only.** For a measure drill down, you can show how different measures consolidate. A drill down on a measure is done on a progressive basis, one level at a time on a 1 to n path (sequential rather than nested). For example, if Profit is the parent of Tax and Pre-Tax Profit, and Revenue and Expenses are children of Pre-Tax Profit, the Tax and Pre-Tax columns are drilled down first and you must double-click the Pre-Tax label to display the Revenue and Expense columns.

**Drilling Up**
If you used the Drill Down feature, you return to your original view of the data by drilling up one level at a time. To drill up, select the level to drill up to and use one of the following methods:

- Double-click the level.
- Select **Drill Up** on the shortcut menu.
- Select **OLAP > Drill Up**.

**Hybrid Analysis and Drilling (Essbase and DB2 only)**
When you drill down to retrieve Hybrid Analysis data, the drill down retrieves *only* the next level of information, even if there is a selection made for "Drill Through", or the "Drill to all Levels" or "Drill to Lowest Level" options have been enabled on the OLAP Query Options dialog.

If you can drill into data returned by way of hybrid analysis, Interactive Reporting adds a "dummy" level to the data layout called "Hybrid1" and displays the new Level of data accordingly in the Contents Pane. If data is not retrieved successfully from the Essbase servers, you get the message: "No more levels to drill into" message. If you continue to drill down on the Hybrid Analysis level of data, each successful drill down returns the data as "Hybrid2" in the data layout (and "Hybrid3", "Hybrid4"… etc. for any subsequent Hybrid Analysis Level retrievals).

You can use drill up on Hybrid Analysis data to redisplay that level as the lowest level in the Contents pane. All lower level Hybrid Analysis data is removed from the Contents pane and data layout.
Adding Computed Items

Computed items allow you to create a new column by building an expression to compute measures, or by applying functions to measures. Computed items are like normal data measures and can be included in reports or reused to compute other measures.

Computed items are displayed in virtual columns (as opposed to columns that are physically stored in the cube). They are automatically calculated during the query and supplement the information already stored in the database.

For example, you can modify the Amount Sold item by building an expression around it, multiplying by the Unit Price item, and renaming the resulting item Revenue.

Note:
This feature is only available for an MS OLAP database.

To compute or modify a measure:

1 Select OLAP > Add Computed Item.

The Modify Item dialog box is displayed.

2 Specify the information requested in the following fields:

   - Name—Specify a new column name that reflects the computation result.
   - Definition—Build an expression by adding items from the pad or the Functions dialog box.
   - Use the keypad to select and insert arithmetic and logical operators.
   - If you are familiar with MDX (Multi Dimensional eXpressions), type your instruction directly in the Definition field.
   - Measure—Select the MDX equivalent from the list of available measures for the expression.
   - Functions—Apply a numeric function to a selected measure in the Definition field. Depending on the function you select, the Functions dialog box changes to accommodate the selected function. For more information about functions, see “Using OLAPQuery Functions” on page 163.

3 When the expression is complete, click OK.

The new measure name is added to the data layout.

For more information on computed items, see Chapter 13, “Computed Items.”

Note:
You can only add computed items if your database supports them. Examples of databases that support computed items are OLE DB for OLAP-compliant databases such as MS OLAP and SAP BW.
Using OLAPQuery Functions

Use OLAPQuery functions to insert standard numeric functions in computed measure expressions. Numeric functions compute a new measure for each value associated with it. You can use two types of OLAPQuery functions in the OLAPQuery section:

- **Interactive Reporting Functions** — Non-MDX functions that allow you to perform common mathematical computations in MDX. The % of Column, % of Row, and % of Total functions allow you to use only a measure name from the query (not all measures in the cube) as a parameter.

- **MDX functions** — Standard mathematical functions that you apply to computed item expressions. Interactive Reporting supports a number of MDX functions. (For more information on MDX functions, consult your MDX documentation.)

The table below provides a quick reference to the commands available on the Query menu and lists any related shortcuts.

The following table lists the functions available in the OLAPQuery section.

<table>
<thead>
<tr>
<th>Table 28 OLAPQuery Functions</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Function</th>
<th>Type of Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>% of Column</td>
<td>Interactive Reporting</td>
<td>Calculates the value of the specified measure as a percentage of the total for the column.</td>
</tr>
<tr>
<td>% of Row</td>
<td>Interactive Reporting</td>
<td>Calculates the value of the specified measure as a percentage of the total for the row.</td>
</tr>
<tr>
<td>% of Total</td>
<td>Interactive Reporting</td>
<td>Calculates the value of the specified measure as a percentage of the total for all rows and columns.</td>
</tr>
<tr>
<td>% Change</td>
<td>Interactive Reporting</td>
<td>Calculates the percentage change of the specified measure for a particular dimension from the previous member in that dimension. For example, this function could be used to calculate the percentage change from sales from the previous year.</td>
</tr>
<tr>
<td>Absolute Change</td>
<td>Interactive Reporting</td>
<td>Calculates the absolute change of the specified measure for a particular dimension from the previous member in that dimension. For example, this function could be used to calculate the difference in sales from the previous year.</td>
</tr>
<tr>
<td>Avg</td>
<td>MDX</td>
<td>Calculates the average of the selected measure evaluated over the specified dataset.</td>
</tr>
<tr>
<td>Correlation</td>
<td>MDX</td>
<td>Returns the correlation of a dataset against two measures.</td>
</tr>
<tr>
<td>Count</td>
<td>MDX</td>
<td>Calculates the number of members for the specified dimension in the report.</td>
</tr>
<tr>
<td>Covariance</td>
<td>MDX</td>
<td>Measures the tendency of two values to vary together. Variance is the average of the squared deviation of a value from its mean. The covariance is the average of the values of the deviations of feature values from their means.</td>
</tr>
<tr>
<td>Function</td>
<td>Type of Function</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Linregpoint</td>
<td>MDX</td>
<td>Calculates the linear regression of a dataset and returns the value of “b”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>in the regression line y = ax + b.</td>
</tr>
<tr>
<td>Linregr2</td>
<td>MDX</td>
<td>Calculates the linear regression of a dataset and returns r2 (the coefficient of determination).</td>
</tr>
<tr>
<td>Linregslope</td>
<td>MDX</td>
<td>Calculates the linear regression of a dataset and returns the value of “a”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>in the regression line y = ax + b.</td>
</tr>
<tr>
<td>Linregvariance</td>
<td>MDX</td>
<td>Calculates the linear regression of a dataset and returns the variance</td>
</tr>
<tr>
<td></td>
<td></td>
<td>that fits the regression line y = ax + b.</td>
</tr>
<tr>
<td>Max</td>
<td>MDX</td>
<td>Returns the maximum value of the selected measure evaluated over the</td>
</tr>
<tr>
<td></td>
<td></td>
<td>specified dataset.</td>
</tr>
<tr>
<td>Median</td>
<td>MDX</td>
<td>Calculates the median value of the selected measure evaluated over the</td>
</tr>
<tr>
<td></td>
<td></td>
<td>specified dataset.</td>
</tr>
<tr>
<td>Min</td>
<td>MDX</td>
<td>Returns the minimum value of the selected measure evaluated over the</td>
</tr>
<tr>
<td></td>
<td></td>
<td>specified dataset.</td>
</tr>
<tr>
<td>Stdev</td>
<td>MDX</td>
<td>Calculates the standard deviation of the selected measure evaluated over</td>
</tr>
<tr>
<td></td>
<td></td>
<td>the specified dataset.</td>
</tr>
<tr>
<td>Sum</td>
<td>MDX</td>
<td>Calculates the sum of the selected measure evaluated over the specified</td>
</tr>
<tr>
<td></td>
<td></td>
<td>dataset.</td>
</tr>
<tr>
<td>Variance</td>
<td>MDX</td>
<td>Calculates the variance of the selected measure evaluated over the</td>
</tr>
<tr>
<td></td>
<td></td>
<td>specified dataset.</td>
</tr>
</tbody>
</table>

> To apply a data function:

1. **Select OLAP > Add Computed Item** and click **Functions** in the Modify Item dialog box.
   
   The Functions dialog box is displayed.

2. **Select the Interactive Reporting Web Client or MDX function from the Functions list.**
   
   A description of the selected function is displayed below the Functions list and explains the type of calculation the function performs.

3. **Select the measure.**
   
   You can select any measure in the cube, not just a measure in the query. The Cube Hierarchy list shows the organization of the cube including both members and levels.

   Some functions require that you specify a second measure to perform the calculation. See the specific function if you are required to specify a second measure.

   The **Count** function requires no measure.

4. **Define the dataset to evaluate the function and click OK.**
   
   To add a member or level to the dataset from the Cube Hierarchy list, select a member or level, and click **Add**.

   To remove a member or level from the dataset, select a member or level and click **Remove**.
Processing OLAP Queries

After you build your OLAP query and apply filters, computations, sorts, and any other adjustments to further refine your request, you need to process it. Processing your query may take a few moments if your query is complex, or if the data in linked report sections needs to be refreshed.

➤ To process an OLAP query, select Tools > Process Query > Option.

Since a document can contain multiple queries, the Process drop-down list has three processing options:

- **Process Current**—Processes the current object. In some cases more than one query may be processed, for example, if a report references results sets from multiple queries. Process Current is the default selection when using the toolbar button.

- **Process All**—Processes all the queries in the document.

- **Process Custom**—Opens the Process Custom dialog box so that you can indicate which queries to process by selecting a query’s check box.

Interactive Reporting sends the query to the database and retrieve the data to the OLAPQuery section. While the data is being retrieved, the Status bar displays a dynamic count indicating rate and progress of server data processing and network transfer.

Processing OLAP Queries Automatically

If you select to run in Hardwire mode, Interactive Reporting queries the database automatically when you add an item to or remove an item from the data layout and instantaneously retrieves the data. You do not have to click Process.

Note:

You should consider the size of the cube you are querying to determine whether to use Hardwire mode.

➤ To select Hardwire mode, select OLAP > OLAP Query Options and select Hardwire Mode in the Design sectionally the General tab.

Working with an OLAPQuery Offline

To view, plot, and work with an OLAPQuery offline, download the data set to an OLAPResults section within the document. Once downloaded, the data can be integrated with the Chart, Table, and other reporting sections. If you need to modify the query, reconnect to the database and apply any necessary changes.
To download the OLAPQuery data set, select OLAP > Download to Results.

An OLAPResults section is created for the query. You can use the OLAPResults data set to insert a new chart, pivot, or other report.

Creating a OLAPResults Section Automatically

You can have a Results section created automatically when you click Process. This eliminates the need to select OLAP > Download to Results (see “Working with an OLAPQuery Offline” on page 165).

To automatically create a Results section when you click Process:

1. Select Tools > Options > Program Options and choose the OLAP tab.
2. Select Auto-Generate Results Section When Processing an OLAP Query.

When you select this option, Interactive Reporting creates an OLAPResults section automatically for any OLAPQuery section that you create in this session when that OLAPQuery section is first processed.

Applying Filters

Filters enable you to define and apply filters to a query once Top Labels or Side Labels have been added to the query. You set filters by applying comparison operators on the values for a specific member. Review the following sections for information on:

- Applying Member Selection Filters
- Applying Measure Filters (Essbase)
- Applying Variable Filters

Applying Member Selection Filters

Use a member selection filter to filter data retrieved from the server cube. A member selection filter is similar to a slicer except that the member selection filter introduces the member value in your report, and multiple members may be selected from a single hierarchy.

To apply a member selection filter, drag individual member values from the Catalog pane to the data layout:

Another method of member selection uses an expression to dynamically retrieve the list of members that satisfy selected parameters, for example, the Top N or Bottom N. You specify these parameters in the Filter dialog box.
Note:
If you used the Drill down feature to navigate down to a members level, you have to use the drill up feature to return to the original level before you apply Member Selection filters.

➤ To apply a member selection filter using an expression:

1 Drag a level into the data layout and double-click the level name.
   The Filter dialog box is displayed.
2 Specify the information requested in the Filter dialog box and click OK.

Applying Measure Filters (Essbase)

You can filter data retrieved from the server cube with a measure filter, which is similar to a member selection filter. A measure filter uses an expression to dynamically retrieve the list of measures that satisfy selected parameters, for example, the Top N or Bottom N. You specify these parameters in the Filter dialog box. Additional parameters are available based on the selected multidimensional database.

➤ To apply a measure filter:

1 Double-click a measure in Data Layout.
   The Filter dialog box is displayed.
2 Select the data operator from the Data Operator drop-down list.
   The selections shown on this list depend on the database to which you are connected. See “Operator Types and Data Operators” on page 170.
3 Specify any database specific parameter requests, such as a column index (that is, the column on which to apply the measure filter) or value.
4 Move the member(s) to the Applied Filters list and click OK.

Applying Variable Filters

A variable filter is a filter you specify when you process a query. You can use variable filters for standardized documents that you distribute to many users, or to automatically reset filters when you need new conditions every time you run a particular query. A (v) next to an item indicates it has a variable filter.

You place a variable filter on an item using the Filter dialog box, which is accessed in either the Slicer pane or the data layout, depending on your database. The table below specifies how various OLAP databases access the Filter dialog box.
### Table 29  How Databases Access the Filter Dialog Box

<table>
<thead>
<tr>
<th>Database</th>
<th>Access Points</th>
</tr>
</thead>
<tbody>
<tr>
<td>Essbase</td>
<td>Side Labels pane, Top Labels pane, Measures pane, Slicer pane</td>
</tr>
<tr>
<td>OLE DB</td>
<td>Side Labels pane, Top Labels pane, Slicer pane</td>
</tr>
</tbody>
</table>

**Member Variable Filters**

- To set a *member* variable filter:

  1. In the data layout, double-click the item you want to define as a member filter.
     - The Filter dialog box is displayed.
  2. Select the method for retrieving items from the database from the Operator Type list.
     - The selections shown on this list depend on the database to which you are connected. See “Operator Types and Data Operators” on page 170.
  3. Specify any database-specific parameter requests.
  4. Click Show Values to display values in the database.
  5. In the Members field, select a *member(s).*
  6. Move the *member(s)* to the Applied Filters list.
  7. Click Set As Variable and click OK.
     - The OLAPQuery section is redisplayed.
  8. Click Process.
     - The Filter dialog box is redisplayed.
  9. Select the *member(s)* that you want to define as a *variable filter* in the Members field.
 10. Move the *member(s)* as a variable filter to the Applied Filters list and click OK.

**Measure Variable Filters**

- To set a *measure* variable filter:

  1. Double-click the item to define as a *measure filter* in the data layout.
     - The Filter dialog box is displayed.
  2. Select the *data operator* from the Data Operator drop-down list.
     - The selections shown on this list depend on the database to which you are connected. See “Operator Types and Data Operators” on page 170.
  3. Specify any database-specific parameter requests, such as a column index or value.
  4. Move the *measure* to the Applied Filters list.
  5. Click Set As Variable and click OK.
The OLAPQuery Section is redisplayed.

6 Click Process.

The Filter dialog box is redisplayed.

7 Select a measure variable filter by selecting the data operator from the Data Operator drop-down list and specifying any database-specific parameter requests, such as a column index or value.

8 Move the measure variable filter to the Applied Filters list and click OK.

**Slicer Variable Filters**

➤ To set a slicer variable filter:

1 Click Slicer on the Section title bar to open the Slicer pane.

2 Select a member from a dimension in the Catalog pane and drag it to the Slicer pane.

   Every dimension folder contains a members subfolder named Values For Domain, which contains the members that are eligible for selection in the Slicer pane.

3 Double-click the member in the Slicer pane.

   The Slicer dialog box is displayed.

4 Select a member.

5 Click the Set As Variable field and click OK.

   The OLAPQuery section is redisplayed.

6 Click Process.

   The Slicer dialog box is redisplayed.

7 Select the member(s) you want to use as a variable filter and click OK.

**Essbase Substitution Variables**

In Essbase, a substitution variable acts as a dynamic filter. Substitution variables are defined on the server using Essbase Application Manager. Your administrator names the substitution variable and sets its value equal to a user-defined parameter. For example, a variable might be named *Latest Period* and have its value set to equal *November*. When the latest period ends, the variable’s value could be reset to *December*, and so on.

An advantage of this type of variable is that saved queries capture the variable’s name instead of hard coding the actual value. Each time the query is run, different data could be returned if the variable’s value has been changed on the server.

➤ To apply a substitution variable:

1 Double-click an item in the data layout.

   The Filter dialog box is displayed.

2 Click Substitution Variable in the Operator Type drop-down list.
The Filter dialog box retrieves all available variables in the Substitution Variables list.

3 Move the member(s) to the Applied Filters list and click OK.
You can also double-click the member to add it to the Applied Filters list.
The OLAPQuery section is redisplayed.

4 Click Process.
The Filter dialog box is redisplayed.

5 In the Members field, select the member(s) to use as a variable filter.

6 Move the member(s) to the Applied Filters list and click OK.

**Operator Types and Data Operators**

The OLAPQuery section supports the following operator types and data operators:

- OLE DB Operator Types and Data Operators (see Table 30)
- Essbase Operator Types and Data Operators (see Table 31)

**Note:**

Not all providers support all operators.

---

<table>
<thead>
<tr>
<th>Operator Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select Members from DB</td>
<td>Creates a filter based on a member(s) retrieved from the database. (Supported for the Essbase, MSOLAP and SAP/BW databases).</td>
</tr>
<tr>
<td>Select by Measure</td>
<td>Creates a filter based on a measure that you specify.</td>
</tr>
<tr>
<td>Top N</td>
<td>Retrieves only the top N values where each top N value is at least the specified Index value.</td>
</tr>
<tr>
<td>Top N %</td>
<td>Retrieves only the top N % values where each top N % value is at least the specified Index value.</td>
</tr>
<tr>
<td>Top Sum</td>
<td>Retrieves the top N (the smallest number possible) values, such that their sum is at least the specified Index value.</td>
</tr>
<tr>
<td>Bottom N</td>
<td>Retrieves only the bottom N values where each bottom N value is at least the specified Index value.</td>
</tr>
<tr>
<td>Bottom N %</td>
<td>Retrieves the bottom N% where each bottom N % value is at least the specified Index value.</td>
</tr>
<tr>
<td>Bottom Sum</td>
<td>Retrieves the bottom N (the smallest number possible) values such that their sum is at least the specified Index value.</td>
</tr>
</tbody>
</table>

Data Operator | Description |
---            |-------------|
= Equal        | Retrieves only records where the filtered item equals the specified value(s). |
## Operator Type

<table>
<thead>
<tr>
<th>Description</th>
<th>Data Operator</th>
</tr>
</thead>
<tbody>
<tr>
<td>Retrieves only records where the filtered item does not equal the specified value(s).</td>
<td>&lt; &gt; Not Equal</td>
</tr>
<tr>
<td>Retrieves only records where the filtered item is less than the specified value(s).</td>
<td>&lt; Less than</td>
</tr>
<tr>
<td>Retrieves only records where the filtered item is less than or equal to the specified value(s).</td>
<td>&lt; = Less than or Equal to</td>
</tr>
<tr>
<td>Retrieves only records where the filtered item is greater than the specified value(s).</td>
<td>&gt; Greater than</td>
</tr>
<tr>
<td>Retrieves only records where the filtered item is greater than or equal to the specified value(s).</td>
<td>&gt; = Greater than or Equal to</td>
</tr>
</tbody>
</table>

---

## Changing Data Views

In the OLAPQuery section, there are numerous ways to change the way you view the data. Changing data view involves:

### Operator Type/ Data Operator

<table>
<thead>
<tr>
<th>Data Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equal</td>
<td>Retrieves only records where the filtered item equals the specified value(s).</td>
</tr>
<tr>
<td>Match Member</td>
<td>The Match Member performs a trailing-wildcard member search for member names and alias names that match the pattern you specify. It returns the member and alias names it finds. The search uses the Essbase formula: mbrName</td>
</tr>
</tbody>
</table>

---
Suppressing Rows

You can suppress the following types of rows:

- **Missing Rows** (*Essbase only*)—Suppresses the retrieval of any missing rows where all cells are null.
- **Zero Rows** (*Essbase only*)—Suppresses the retrieval of any zero rows where all cells are null.
- **Empty Rows** (*OLE DB only*)—Suppresses the retrieval of any empty rows for which there is no measure data.

To suppress rows in your OLAPQuery data, select **OLAP > OLAP Query Options** and click the **DB Specific** tab.

The options that are displayed on the DB Specific tab depend on the database to which you are connected. See “Database-specific OLAPQuery Options” on page 155 for more information.

Adding Totals

Interactive Reporting enables you to add either database totals or local totals. Database totals are calculated by querying the actual database. Local totals are calculated and applied to surface values.

Adding Database Totals

You can include or exclude database totals to tailor the look of the OLAPResults section and any charts you create using the Show As Chart feature. When you activate the Database Totals feature, totals are retrieved into the OLAPResults section as additional rows or columns. In the Chart section, database totals are plotted.

The OLAPQuery section includes database totals by default. You may wish to turn off this feature if you intend to use the Drill Down feature to navigate the multidimensional cube, or if you plan to export the OLAPQuery section.

To add database totals:

1. Select **OLAP > OLAP Query Options** and click **Database Totals** in the Design section of the General tab.
2. Click **Process** to add the totals to the data.

   Interactive Reporting displays the result as the *first* item at each level of the dimension.
**Note:**

If you enable database totals in the OLAPQuery section, totals are copied as *static values* into any Results section. As a result, they will *not* be treated as dynamically updated totals.

➤ To remove database totals, remove the check mark next to Database Totals on the General tab and click **Process** to reprocess the query.

**Adding Local Totals**

➤ To add local totals, select the desired dimension handle, right-click, and choose **Add Totals**. Interactive Reporting totals the data and displays the result as the *last* item at each level of the dimension.

➤ To remove local totals, click on a total label and press the **Delete** key.

**Adding Data Functions**

Column or row totals added to the OLAPQuery section are aggregates and can be recalculated using data functions. When applied to totals, data functions apply the calculation to *surface* values. When applied to surface values, data functions recalculate the values in the visible cells or surface of the OLAPQuery section. For example, you can show the total sale, average sale, and maximum sale of each product by quarter. Each of these dimensions is based on the same value. They only differ in the data function that is applied.

➤ To apply a total function:

1. Select the dimension handle for a particular measure.
2. Click on the Standard toolbar to calculate the total.
3. Select a column of a particular measure.
4. Choose **OLAP > Data Function** and select a function.

The following table lists the data functions available in the OLAPQuery section.

<table>
<thead>
<tr>
<th>Data Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Sum</strong></td>
<td>Returns sum of all values. This is the default function in all report sections.</td>
</tr>
<tr>
<td><strong>Average</strong></td>
<td>Returns average of all values.</td>
</tr>
<tr>
<td><strong>Count</strong></td>
<td>Returns number of values.</td>
</tr>
<tr>
<td><strong>Maximum</strong></td>
<td>Returns highest value.</td>
</tr>
<tr>
<td>Data Function</td>
<td>Description</td>
</tr>
<tr>
<td>---------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Minimum</td>
<td>Returns lowest value.</td>
</tr>
<tr>
<td>% of Column</td>
<td>Returns surface values as a percentage of their respective column item.</td>
</tr>
<tr>
<td>% of Row</td>
<td>Returns surface values as a percentage of their respective row item.</td>
</tr>
<tr>
<td>% of Grand</td>
<td>Returns surface values as a percentage of all like values in the report.</td>
</tr>
</tbody>
</table>

**Showing OLAP Results as a Chart**

You can perform interactive analysis on the OLAPQuery data by viewing the data as a chart. When you select this option, an OLAPQuery Results section is automatically created, as an OLAP Chart section.

**Note:**

Because the Chart created by the Show As Chart command is stationary, you cannot perform drill-down analysis on it. In addition, it is recommended that you deactivate the Database Totals feature since the chart plots the totals when totals are retrieved from the database.

➢ To show the query as a chart, select OLAP > Show As Chart.

**Formatting OLAPQuery Items**

You can use the commands available on the Format menu to add corner and data labels, and to change the appearance of fonts, backgrounds, borders, color, row heights, and column widths. For more information on formatting options, see Formatting Text and Other Elements

**Drilling Through from a Multi-Dimensional Database to a Relational Database**

In general, OLAP data is aggregated and obtained from a relational database source. As a result, there may be occasions where you want to see the relational data associated with the multi-dimensional data.

For example, assume that you create an OLAP analysis to show your company’s sales aggregated to Country, State, and City levels. Assume further that the sales data for each store within a city is stored in a transactional, relational database. In this case, you could drill down in the OLAPQuery section to sales data for USA > California > San Francisco. To see the data for the stores in San Francisco, however, you would need to drill through to a relational database.

Drilling through from a multi-dimensional database to a relational database involves:

● Setting Drill-through Options
Setting Drill-through Options

Drill-through options define the mapping between a multi-dimensional database and a relational database.

- To set drill-through options:
  1. Select OLAP > Set Drill-Through.
     The Set Drill-Through dialog box is displayed.
  2. Select options in the Set Drill-Through dialog box and click OK.

<table>
<thead>
<tr>
<th>Table 33</th>
<th>Drill Through Options</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Option</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Dimensions</td>
<td>The dimensions in the current OLAP query. Click a dimension to select it.</td>
</tr>
<tr>
<td>Selected Dimension</td>
<td>The dimension selected by the user. This is the dimension to use for mapping.</td>
</tr>
<tr>
<td>Specify Relational Query</td>
<td>The relational query sections that are currently available. To specify a relational query, click the arrow to the right of the drop-down list and select a query from the list that is displayed.</td>
</tr>
<tr>
<td>Relational Topics</td>
<td>The topics contained in the selected relational query. Click a topic to select it.</td>
</tr>
<tr>
<td>Selected Topic</td>
<td>The topic selected by the user. This is the topic to use for mapping. The selected topic should have topic items with names corresponding to the selected dimension levels.</td>
</tr>
<tr>
<td>Map/UnMap Dimension</td>
<td>Maps the selected dimension to a topic (or unmaps the selected dimension from a topic). When you map a dimension to a topic, Interactive Reporting stores an internal link between the dimension and the selected topic.</td>
</tr>
<tr>
<td>Specify Fact Topic</td>
<td>The topic used to map to the OLAP measures. The selected topic should have topic items with names corresponding to the OLAP measures. To specify a topic, click the arrow to the right of the drop-down list and select a topic from the list that is displayed. The topics that appear are the topics available in the selected query.</td>
</tr>
</tbody>
</table>

**Tip:**

To drill-down to any level in the relational data, enable the “Set as Dimension” property for the relational topics that represent the OLAP dimension data. To do this, right-click the topic in the original relational query section Contents pane, select Properties, and click the checkbox next to “Set as Dimension” in the Topic Item Properties dialog box.
Drilling Through

To drill through from a multi-dimensional database to a relational database:

1. Select a dimension and drill-down to the lowest level.
2. Do one of the following:
   - Double-click the dimension.
   - Select OLAP > Drill Through.
     The Drill-Through dialog box is displayed enabling you know that there are no additional OLAP levels to drill into.
3. Click Yes to drill through to the relational data source.
   Interactive Reporting creates a new Pivot section (along with associated Query and Results sections) for the relational data.

Note:
Interactive Reporting ignores slicers when drilling through to a relational database. If a slicer is present, a message is displayed letting you know that the slicer will be ignored.

Tip:
After you drill through on a dimension and create a new Pivot section, you can return to the OLAPQuery section and drill down on additional dimensions if desired. When you drill down on an additional dimension, you can choose whether to create a new Pivot section or update a pivot section with the new dimension data.

Tip:
If you update a pivot section with new data, ensure that the new data to be added to the Pivot section maps to a Fact Topic that is the same as the Fact Topic in the pivot section.

OLAP Menu Command Reference

The following table provides a quick reference to the commands available on the OLAP menu and lists any related shortcuts.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Keyboard Shortcut</th>
<th>Shortcut Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Retrieve Dimensions</td>
<td>Refreshes the dimension values in the Catalog pane.</td>
<td>F9</td>
<td></td>
</tr>
<tr>
<td>Add Side Label</td>
<td>Adds the selected item to the Side Labels pane.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
<td>Keyboard Shortcut</td>
<td>Shortcut Menu</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-------------------</td>
<td>---------------</td>
</tr>
<tr>
<td>Add Top Label</td>
<td>Adds the selected item to the Top Labels pane.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add Fact/Measure</td>
<td>Adds the selected item to the Measures pane.</td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>Add Computed Item</td>
<td>Opens the Computed Items dialog box. (This feature is for MS OLAP only)</td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>Drill Down</td>
<td>Allows you to progressively narrow your focus on a selected item.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Drill Up</td>
<td>Returns the original view of data.</td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>Drill Through</td>
<td>Drills through from a multi-dimensional database to a relational database.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove Total</td>
<td>Removes local totals from selected dimensions.</td>
<td>Del</td>
<td>*</td>
</tr>
<tr>
<td>Hide Items</td>
<td>Removes selected items from the OLAPQuery report.</td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>Show Hidden Items</td>
<td>Retrieves hidden items from the selected row or column to the OLAPQuery report.</td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>Show All Items</td>
<td>Retrieves all hidden items to the OLAPQuery report.</td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>Download To Results</td>
<td>Downloads the OLAPQuery data set to an OLAPResults section for offline work.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show As Chart</td>
<td>Charts the OLAPQuery data set; automatically creates OLAPChart and OLAPResults sections.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>OLAP Query Options</td>
<td>Accesses the OLAPQuery Options dialog box, where you can set options for your OLAPQuery.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Data Functions</td>
<td>Recalculates the surface values in the OLAPQuery data set.</td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>Set Drill-Through</td>
<td>Accesses the Set Drill-Through dialog box, where you can define the options for drilling through from a multi-dimensional database to a relational database.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
In This Chapter

About CubeQuery.....................................................................................................................................................179
CubeQuery Catalog..................................................................................................................................................183
OLAPQuery and CubeQuery Data Layout Differences.................................................................................................184
Building a CubeQuery Section..................................................................................................................................185
Member Selection....................................................................................................................................................186
Query Options..........................................................................................................................................................202
Navigating CubeQuery..............................................................................................................................................204
Downloading to Results............................................................................................................................................208
Showing as Chart.....................................................................................................................................................219
Exporting a CubeQuery.............................................................................................................................................219
Formatting CubeQuery Items....................................................................................................................................220
CubeQuery Menu Command Reference....................................................................................................................222

About CubeQuery

The CubeQuery section is the Interactive Reporting interface with Essbase 7.x, and 9.x databases. It provides access to the cube in which multidimensional data can be analyzed and complex calculations can be applied before and after the queries are processed. The resulting data set can be shown with relational data side-by-side in a dashboard report, or downloaded to a results set and joined to relational sources.

About Essbase

Essbase is a multidimensional database application that enables you to analyze multiple aspects of your business continually in comparison to one another. The Essbase database has the following characteristics:

- Works with multidimensional data and roll-up hierarchies in dimensions.
- Retrieves information from other systems.
- Handles some level of summarized data, not transaction.
- Adapts to multiple reporting and analysis environments.
Additionally, the Essbase database uniquely blends an innovative technical design with an open, client-server architecture. Essbase can be used for a broad range of online analytical processing (OLAP) applications, including:

- Budgeting
- Forecasting and seasonal planning
- Financial consolidations and reporting
- Customer and product profitability analysis
- Price, volume, and mix analysis
- Executive information systems

**About Multidimensional Databases**

The Essbase multidimensional database stores and organizes data. It is optimized to handle applications that contain large amounts of numeric data and that are consolidation or computation-intensive. The database organizes data to reflect how users want to view the data.

**Definition of Multidimensional**

A multidimensional database is an extended form of a two-dimensional data array, such as a spreadsheet, generalized to encompass many dimensions. Dimensions comprise values called members, which are arranged in a hierarchical structure. A *dimension* is a perspective or view of a specific dataset. A system that supports simultaneous, alternate views of datasets is *multidimensional*. Dimensions are categories such as time, accounts, product lines, markets and so on. Each dimension contains additional categories that have various relationships. *Members* exist within a dimension. A dimension can contain an unlimited number of members.

---

### Diagram

[Diagram: Multidimensional Database Diagram]

<table>
<thead>
<tr>
<th>Dimension</th>
<th>Member</th>
</tr>
</thead>
<tbody>
<tr>
<td>Year</td>
<td>Qtr1</td>
</tr>
<tr>
<td>Qtr2</td>
<td>Apr</td>
</tr>
<tr>
<td>Qtr3</td>
<td>Qtr4</td>
</tr>
</tbody>
</table>

---

**CubeQuery**

180
**Dimensions and Members**

Dimensions and members are the metadata of the Essbase database (also known as the Essbase outline). The Essbase outline determines how data is stored in Essbase. Following are typical examples of dimensions and their members:

- **Time**—Hours, Days, Months, Quarters, Years
- **Measures**—Profit, Inventory, Ratios
- **Product**—Individual products
- **Market**—North, South, Central
- **Scenario**—Actual, Budget, Variance, Variance %

**Non-aggregate Dimensions**

Some dimensions are aggregates of their members. For example, 24 hours make a day, 7 days compose a week, 52 weeks form a year, and so on. In these cases, the Time dimension represents the sum of its components. However, some dimensional hierarchies are not the sums of their components. For example, the Measures dimension is commonly composed of business measures such as Sales, Profit, and Cost of Goods Sold. When the dimension label cannot represent the sum of contents, a protocol exists to use one member set in place of the dimension label. Essbase uses the first child in the dimension outline as the implied share instead of non-aggregate dimension labels.

**Familial Relationships**

To simplify the concept of hierarchical order, Essbase uses familial relationships.

- **Parent**—Direct ancestor of an element in a hierarchy; for example, Quarters are the parent of Months.
- **Child**—Direct descendant of any element in a hierarchy; for example, Months are children of Quarters.
- **Descendants**—Elements of greater detail; for example, Days are descendants of Weeks.
- **Ancestors**—Elements of more generality; for example, Weeks are ancestors to Days.
- **Siblings**—Members with the same parent
Generations and Levels

Hierarchical structure also can be described in terms of generations and levels. Dimension members on the same layer of the dimensional hierarchy are referred to collectively as generations or levels. The relationships are defined as follows:

- Generations—Counted down from the highest ancestor. The root member, or dimension name, is Generation 1. In the following figure, Market is Generation 1.
- Levels—Counted from bottom to top: Level 0, Level 1, Level 2, and so on. In the following figure, days are at Level 0.
- Leaf nodes—Lowest points in a hierarchy.
Attributes

In addition to dimension member names, locations, and relationships, Essbase stores characteristics, called attributes, about members. For example, the Product dimension indicates that in Women’s Apparel, Shirts and Blouses, there is a cotton T-shirt; an attribute indicates that the cotton T-shirt is red, cyan, lime, or pink. Essbase does not store data for attribute dimensions as part of the multidimensional database but instead dynamically calculates it upon request. Attribute dimensions are displayed in dimension hierarchies, in the same manner as other dimensions, despite their data being stored differently.

CubeQuery Catalog

The Catalog displays one or all dimensions in a tree model. The tree can be expanded to display additional members, but generations are not included in the hierarchy. For cubes with many members in a dimension, paging facilitates navigation. The number of members that can be displayed in the Catalog and Member Selection is defined in the Number of Members to display option in Query Options. The default is 50.
To display the Catalog in single-dimension mode, select a dimension from the Dimension Selection.

To expand the tree to display additional members in the dimension hierarchy, next to the dimension, click +.

To display the Catalog in all dimensions mode, click 📚.

**OLAPQuery and CubeQuery Data Layout Differences**

OLAPQuery is the pre release 9.3 section used to query a multidimensional database. The data layout tool in OLAPQuery and CubeQuery have these differences:

<table>
<thead>
<tr>
<th>OLAPQuery Data Layout</th>
<th>CubeQuery Data Layout</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slicer</td>
<td>Filters</td>
</tr>
<tr>
<td>Side</td>
<td>Rows</td>
</tr>
<tr>
<td>Top</td>
<td>Columns</td>
</tr>
<tr>
<td>Filters from multiple members may be selected and applied from a single hierarchy.</td>
<td>One filter member can be selected per dimension. Filters for multiple members within the same dimension are not supported.</td>
</tr>
<tr>
<td>Measures are treated as distinct dimensions and can be placed only in the Facts pane of the data layout.</td>
<td>Measures can be placed in the Row, Column, and Filter panes of the data layout.</td>
</tr>
<tr>
<td>Member selection in the data layout is unavailable.</td>
<td>Member selections in the Row, Column and Filter panes of the data layout can be edited in the Member Selection dialog box.</td>
</tr>
<tr>
<td>Shortcut menu enables access to the Filter dialog box and Remove option.</td>
<td>Shortcut menu enables access to Remove option, Member Selection dialog, Data Filter option (rows and columns), Variable option and Filter option</td>
</tr>
</tbody>
</table>

**Searching Members from the Catalog**

Member search is available for member names, aliases or both in one or more dimensions from the Catalog. If the Catalog shows members in single dimension mode, the Search is performed on a selected dimension. If all dimensions are displayed, Search is performed on all dimensions.

**Note:**

Only the member names and aliases are displayed and not the fully qualified name (for example, [West].[Salem] ) in the Member Selection, Catalog or query results.
To search members from the Catalog:

1 Select to search by name, alias, or both.
2 Enter the text on which to search.
   If you use wildcards in searches, only trailing wildcards are accepted (for example, Cola*), and not leading wildcards (for example, *-10).
   The ?? (placement position) is a valid search criteria. The ? substitutes one occurrence of a character; and can be placed anywhere in the string.
3 Click .
   The search results are displayed in the Catalog, and they can be added to the data layout.

To close Search, select 
   The Search results are cleared.

Building a CubeQuery Section

When you query against an Essbase cube, by default the CubeQuery section is created in the Interactive Reporting document. To use this section, you must have access to an Essbase 7.x or 9.x server data source. Interactive Reporting also requires an Essbase 9.3 Runtime or greater client installation.

To create a CubeQuery section:

1 Select Tools > Options > Program Options > OLAP, and clear Use Old OLAP Query section.
   By default, new Essbase queries use the new section type (CubeQuery).
2 Select Insert > New Query.
   The Insert New Query dialog box opens.
3 Select an Interactive Reporting database connection file (.oce) associated with an Essbase 7.x or 9.x server used as a data source.
   For information on connecting to Essbase, see Connecting to Essbase (CubeQuery only).
4 Enter your name in the Host Name field and password in the Host Password field and click OK.
   Interactive Reporting creates a Query section in the Section pane. The Catalog shows the dimensions available to add to the query.
   To toggle the Catalog between single and all dimension modes, click .
5 In the Catalog, select a member dimension and select Query > Add to Rows or Query > Add to Columns.
Note:
Members from the same dimension cannot be split across columns, rows and filters.

6 In the Catalog, select a measure dimension and select Query > Add to Rows or Query > Add to Columns.

7 To filter a member, select a member in the Catalog and select Query > Add to Filters.

8 Click Process.

Note:
If missing values are not displayed, missing rows and columns may be suppressed. This option is enabled in Query options.

Member Selection

An Essbase database may contain hundreds or even thousands of members. Use the Member Selection Browse and Search tabs to refine query member criteria for a selected dimension. The Member Selection dialog box includes dynamic selection functions such as children, descendants, bottom, siblings, or subsets (UDA, Attribute Dimensions, Level and Generation).

The Available pane lists the member hierarchy for the selected dimension. An additional node for substitution variables lists substitution variables for all dimensions; however, if they are selected from another dimension, an error appears when adding the member to the Selected pane.

The Selected pane lists all member selections. Selections can be a single member or a dynamic selection function (for example, children).

<table>
<thead>
<tr>
<th>Icon</th>
<th>Dynamic Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Member]</td>
<td>Member</td>
<td>Currently selected member</td>
</tr>
<tr>
<td>![Children]</td>
<td>Children</td>
<td>Children of the selected member (one level below)</td>
</tr>
<tr>
<td>![Descendants]</td>
<td>Descendants</td>
<td>Descendants of the selected member</td>
</tr>
<tr>
<td>![Bottom]</td>
<td>Bottom</td>
<td>Descendants of the selected member on the lowest level of the hierarchy (Level 0)</td>
</tr>
<tr>
<td>![siblings]</td>
<td>Siblings</td>
<td>Members on the same level with the same parent as the selected member</td>
</tr>
<tr>
<td>![Same Level]</td>
<td>Same Level</td>
<td>Dimension members on the same level as the selected member</td>
</tr>
<tr>
<td>![Same Generation]</td>
<td>Same Generation</td>
<td>Dimension members on the same generation as the selected member</td>
</tr>
<tr>
<td>![Select Next/Previous]</td>
<td>Select Next/Previous</td>
<td>Opens the Select Next/Previous dialog box so that a user can select a number of next or previous members at the same dimension level as the selected member</td>
</tr>
</tbody>
</table>
Subset

Opens the Subset dialog box to further define the member criteria for selections such as level, generation, user defined attributes, and attribute dimensions

Date Time Series

Opens the Date Time Series dialog so that a user can select the latest time period to be reported

Note:

When a Shared Member is individually selected, Essbase treats it as the initial occurrence, and not the shared occurrence of the member. If selection functions such as “Siblings” and “Select Next/Previous” are used with shared members, the returned members reflect the original occurrence of the member. For example in the Sample Basic Product dimension, if the shared member “100-20” (under the Diet member) is selected with the Siblings selection type, the results are (100-10, 100-20 & 100-30) and not (100-20, 200-20, & 300-30). This occurs because the original occurrence of the member, under the parent “100” is used by Essbase

Browsing Members

Use the Member Selection Browse tab to navigate through and select individual members to include in the query.

To browse and select members:

1. In the data layout, right-click a dimension member and select Edit.
   The Member Selection dialog box is displayed.
2. Select Browse.
3. Select a member and click + to the left of the member name to expand it.
4. To include an individual member in the query, select the member in the Available pane and click.
   The member is added to the Selected pane.
5. To include a dynamic function, on the shortcut menu, select the member in the Available pane and select the function from the submenu:
   - Member
   - Children
   - Descendants
   - Bottom
   - Siblings
   - Same Level
   - Same Generation
   - Select Next/Previous
   - Subsets
   - Date Time Series
● Disable or Enable (selected members only)

6 Click OK.

➤ To change the member function in the Selected pane:

1 Select the member to modify.
   Use Shift + click to select multiple and consecutive items. Use Ctrl + click to select multiple, but nonconsecutive items.

2 To include or exclude a member (for example, “Member+Children” versus “Children”), select the check box next to the member name.

3 Click OK.

➤ To clear an item used in the query without removing it from the Selected pane:

1 Select the item and choose Disable from the shortcut menu.

2 Click OK.

➤ To remove a member or member element:

1 Select the member in the Selected pane and click .
   Use Shift + click to select multiple and consecutive items. Use Ctrl + click to select multiple, but nonconsecutive items.
   The member is moved from the Selected pane.

2 Click OK.

➤ To remove all members and member elements, click .
   The Selected pane is depopulated.

➤ To toggle between including or excluding a member:

1 Select a member in the Selected pane.

2 Select Disable to exclude a member, or Enable to include a member.

➤ To preview a list of all members selected for a dimension, click .
   The Preview window is displayed.

**Date Time Series**

Date Time Series members (DTS) are predefined database members used in dynamic, to-date reporting, such as year-to-date or month-to-date values. DTS results are displayed as individual members, summing Level 0 Time dimension members in Essbase based on the current selection.
Use the Date Time Series dialog box to select the latest time period in to-date calculation. The calculated value of the Date Time Series is derived when you define the latest time period to be reported. For example, suppose you need sales data for the quarter up to the current month when the level 0 members of the Year dimension are the months of the year, and the current month is August. In this case, you select a quarter-to-date calculation, which shows sales data for the months of July and August.

**Note:**

Because MDX is used to query Essbase, and MDX does not have an exact equivalent of the Date Time Series (DTS) functions, a combination of xTD (refers to Year-, Quarter-, Month— and Week-to-date periods) and Sum functions are used. As a result, there may be different data output than a traditional DTS for some members; for example, those that use “Time Balance” functionality and “Two Pass Calc” members.

➢ To make a Date Time Series selection:

1. **In the data layout, double-click a Time dimension in the data layout.**
   
   The Member Selection dialog box opens.

2. **In the Selected pane, right-click a Time dimension member, and select Date Time Series.**
   
   The Date Time Series dialog box opens.

3. **Select the definition to use for the to-date calculation and click OK.**

**Substitution Variables**

Substitution variables define global variables that represent Essbase-specific values. For example, CurMonth can be a substitution variable for displaying the latest time period. Rather than constantly updating queries when a value changes, you change only the value for the substitution variable on the server. Essbase creates substitution variables, but you can specify a substitution variable when selecting members.

➢ To add a substitution variable:

1. **Right-click a member in the data layout and select Edit.**
   
   The Member Selection dialog box is displayed.

2. **Select Browse.**

3. **In the Available pane click + to expand the Substitution Variable node.**

4. **To include a substitution variable, select the member in the Available pane and click .**

5. **To include a dynamic function on a substitution variable, right-click the member in the Available pane and select the desired function from the sub-menu:**

   - Member
   - Children
Variables

A variable is a constraint that a user selects when the query is processed.

➤ To use all selected members as a variable (the user is prompted for the values when the query is processed):

1 In the data layout, right-click a dimension member and select Edit.
2 Select Use as variable.
3 Click OK.

You can also a member in the data layout and on the shortcut menu, select Variable.

Searching Members

Use the Member Selection Search tab to find members within a dimension that match a pattern string in Essbase.

Note:
The Search feature is also available in the Catalog.

Note:
Only the member names and aliases are displayed and not the fully qualified name (for example, [West].[Salem] ) in the Member Selection, Catalog or query results.

➤ To search for members:

1 In the data layout, right click a dimension and select Edit.
2 Select Search.
3 From the Member Type, select the type of member to search:
   ● Name—Member Name
• Alias—Alternate Names for database members
• Both—Member Name and Alias Name

**Note:**
To search on alias names, enable the Use Alias Tables option and select an alias table in Query Options.

4 Enter the text string or numeric value to search (a member name or pattern).
Trailing asterisks and wildcard strings are acceptable. Examples of value text strings: Ja*, M?n, and M??n. Examples of invalid text strings: *-10 and J*n.

5 To locate all member within the selected dimension that matches the text string or numeric value, click .
The results of the search populate the Available pane.

6 Optional: To add a member to the Selected pane, click .

7 Click OK.

**Member Selection Exclusions**
To synchronize the Member Selection dialog selections with the results of grid navigation such as Drilling and Keep/Remove Only, additional member selections are sometimes added to the Selected pane to reflect member selections that are excluded from the query. The exclusions appear when dynamic member selections are used (for example, Product (Children)).

To arrive at the proper member selection, exclusions are included in the MDX query to avoid having metadata queries executed. For example, a query has the following member selection in the rows: EntityABC (Member+Children), and the result includes the parent member and 10,000 children. When performing a Remove Only on one of the child members, instead of querying the 10,000 children to update the member selection dialog, an exclusion entry is created for the removed member. Additional examples are as follows, with exclusion entries in bold:

<table>
<thead>
<tr>
<th>Initial Query Selection</th>
<th>Query Operation</th>
<th>Resulting Member Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>Year (Member+Children)</td>
<td>Remove Only: Qtr2</td>
<td>Year (Member+Children)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Qtr2 (-Member)</td>
</tr>
<tr>
<td>Year (Member+Children)</td>
<td>Keep Only: Qtr2</td>
<td>Qtr2 (Member)</td>
</tr>
<tr>
<td>Market (Member - Descendants)</td>
<td>Drill Up: Florida</td>
<td>Market(Member +Descendants) East (- Descendants)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>East (Member)</td>
</tr>
</tbody>
</table>

**Subsets**
Use subsets to define rules that select dimension member subsets, which satisfy specific conditions. These rules can be defined using the following data source constructs:
To define a member subset selection:

1. Select a dimension member in the data layout and select Edit on the shortcut menu.
   The Member Selection dialog box opens.

2. Select a member in the Selected pane and on the shortcut menu, select Subsets.
   The Subset dialog box opens.

3. Select a subset type:
   - Levels
   - Generation
   - UDA
   - Name
   - Alias
   - [Attribute Dimension(s)]

4. Select an operator for the subsetting criteria.
   For example, is (equal to) or is not (not equal to).

5. Enter a value for the subsetting criteria from the third drop-down list.

6. To include criteria to the Conditions text box, click Add.

7. Optional: Repeat steps 3–6 for each subsetting criteria.

8. Click OK.

You must add at least one rule to the Subset definition for it to be used.

<table>
<thead>
<tr>
<th>Select member &quot;and its descendants where (enter or select the values from all three fields)</th>
<th>Returns the subsetting methods available based on the type of item:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Level—Members belonging to a specified level of the dimensional hierarchy</td>
<td>Levels—Members belonging to a selected level of the dimensional hierarchy</td>
</tr>
<tr>
<td>Generation—Members belonging to a specified generation of the dimension hierarchy</td>
<td>Generation—Members belonging to a selected generation of the dimension hierarchy</td>
</tr>
<tr>
<td>UDAs—Members with a specified user-defined attribute</td>
<td>UDA—Members with selected user-defined attributes</td>
</tr>
<tr>
<td>Name/Alias—Specified member name or alias (note: matching a pattern of wildcard characters is not supported at this time)</td>
<td>Name—Members matching a specified name of the dimension hierarchy</td>
</tr>
</tbody>
</table>
| **[second drop-down]** | Displays operand (comparative filtering) criteria. For example, when you select `is`, the filtering criteria must equal the specified value. When you select `is not`, the filtering criteria excludes the members that meet the selected condition. Valid comparative filtering criteria includes:
* is
* is not
* greater than
* greater than or equal to
* less than
* less than or equal to |
| **[third drop-down]** | Displays the corresponding values for the subsetting methods |
| **Add** | Adds the corresponding values to the Conditions text box |
| **Remove** | Removes a selected item from the Conditions text box |
| **Remove All** | Removes all items from the Conditions text box |
| **AND** | Inserts the AND operand at the end of the currently selected rule. The AND operand is used by default when multiple rules are added to the Definition. AND logic requires that the selection(s) meet the current condition and the preceding condition |
| **OR** | Inserts the OR operand at the end of the currently selected rule. OR logic requires that the current condition meet the current condition or the preceding condition. |
| **(** | Adds a left parenthesis to the selected item. Use parentheses to group two or more subsetting values to determine the order priority for conditions. Each item in the Conditions text box can have either the left or right parentheses, but not both. |
| **)** | Adds a right parenthesis to the selected item. Use parentheses to group two or more subsetting values to determine the order priority for conditions. Each item in the Conditions text box can have either the left or right parentheses, but not both. |
| **Remove()** | Removes all left or right parentheses from the selected item in the Conditions text box. |
**Also Select Next/Previous**

Use the Also Select Next/Previous dialog box to select the next or previous members of a selected member. For example, when the results for the Product dimension are:

- Product
  - Colas
  - Root Beer
  - Cream Soda
  - Fruit Soda
  - Diet Drinks

and Cream Soda is selected, the results for the next two members are Fruit Soda and Diet Drinks. If the two previous members are selected, the results are Colas and Root Beer.

To select the next or previous member:

1. In the data layout, right-click a dimension member in the data layout.

   The Member Selection dialog box opens.

2. Right-click a dimension member and choose Select Next/Previous.

   The Also Select Next/Previous dialog box opens.

3. From the first drop-down, select next or previous.

4. From the second drop-down, select how many next or previous members to include.

5. Click OK.

**Filter Member Selection**

All data object intersections are relative to filter member selections, which focus intersections and data values, and, consequently, analysis. Filter-axis dimensions are by default represented by the highest aggregate member defined in the data source. To focus analysis on members other than the highest aggregate, you can select one filter member per dimension. Filter member selections do not rearrange dimensions or reorganize pages but focus analysis on intersections.

Use Filter Selection tabs to navigate through, search, or select the members to use in a filter definition.
Browsing Filter Members

Use the Filter Selection Browse tab to navigate through and select individual members to use as a filter.

➤ To browse and select member:

1 In the Filter pane of the data layout, right-click a dimension member and select Edit.
   The Filter Selection dialog box opens.

2 Select a member and click + to the left of the member name to expand it.

3 To include a member as a filter in the query, in the Available pane, select the member and click.
   The member is added to the Selected pane.

4 Click OK.

Searching Filter Members

Use the Search tab of Filter Selection dialog to search for members within selected dimensions.

Note:
Only the member names and aliases are displayed and not the fully qualified name (for example, [West].[Salem]) in the Member Selection, Catalog or query results.

➤ To search for members:

1 In the Filter pane of the data layout, right click a member and select Edit.

2 Select Search tab.

3 From the Member Type, select the type of filter member to search:
   ● Name—Member Name
   ● Alias—Alternate Names for database members
   ● Both—Member Name and Alias Name

4 Type the text string or numeric value to search in the text box.
   Trailing asterisks and wildcard strings are acceptable. Examples of value text strings: Ja*, M?n, and M??n. Examples of invalid text strings: *-10 and J*n.

5 Click to locate all member within the selected dimension that matches the text string or numeric value.
   Hovering the mouse over an item in the Location column shows a tooltip with the members full location path.
   The results of the search populate the Available pane.

6 Optional: To add a member to the Selected pane, click.
7 **Click OK.**

**Note:**
To add a different member as a filter, first remove the selected member.

**Note:**
A Search by Alias name searches the currently selected Alias Table in Query Options when the Use Aliases option is enabled.

### Data Filters

Data filters limit the data retrieved from the database by specific member selections for one or more dimensions. That is, data is returned from the database only if it meets the specified conditions set up in the filter. Data filters are applied on the server side (at the database), not on the client side.

Use the Data Filter dialog to do the following:

- Filter data based on top \( n \)/bottom \( n \) values
- Apply sorts to data/metadata
- Apply show or hide criteria to display or suppress members from appearing in a query. For queries with multiple dimensions in the rows or column, Show/Hide can be used to create asymmetric reports (queries that include nested dimensions that differ by at least one member across an axis).

The top \( n \) feature retrieves the number of highest data values from the Results set sorted in specified order. The bottom \( n \) option retrieves the lowest number of lowest data values from the Results set sorted by specified order.

The Sorting feature sorts rows or columns of the query result set in ascending or descending numeric order. Sorting definitions are dynamic and are applied as the document is drilled, pivoted, and changed.

The Show/Hide Only feature includes or excludes members by member name, tuples, or data value criteria. It is an effective means of focusing analysis by values.

The Data Filter dialog box is opened by right clicking on a dimension in the data layout and selecting Data Filter. Data Filters are applied by way of MDX queries to the Essbase server, which processes them, not locally by Interactive Reporting.

For example, if the “Product” dimension is in the Rows pane of the data layout and you select the Data Filter option, the heading of the Data Filter dialog box reads: Rows Filter, and the member context appears accordingly. The Member context is the member selection that is required for the Data Filter criteria.

For each of the types of filters, the following is the respective context. Assume a report with “Product” members in the row pane and the “Year” member in the column pane of the data layout. The Data Filter is applied to rows:
Top/Bottom N—Because the “Product” members are filtered to show, for example, the “Top 5”, the criteria for the data values must be defined on a specific column. As a result, the Data Filter dialog box displays a “Selected Columns” section from a “Year” dimension column is selected for the member context (bottom left):

Sort—In a similar manner to Top/Bottom N, Sort requires the definition of the member context on the opposite axis. In the example, with “Product” dimension in the Rows pane of the data layout, the “Selected Columns” section from the “Year” dimension column is selected for the member context:
Show/Hide—when the Data Filter dialog box is opened for a dimension, Show/Hide applies to the dimension selected, where the member context are members from that dimension. For example, with the “Product” dimension in the Rows pane of the data layout, the Data Filter dialog box displays a list of “Product” dimension members from which you can show or hide data:
If two or more dimensions are in the columns or rows pane, the Data Filter dialog box displays all dimension combinations in the Member list pane, applicable. For example if the “Year” and “Scenario” are in the columns pane, a Rows Filter dialog shows all member combinations under Sort On:

**Note:**
Filters for tuples not present in the grid of the Data Filter dialog box are greyed out.

➤ To filter a selected number of top rows or columns or a selected number of bottom rows or columns:

1. **In the data layout, right click on a dimension (either in the Rows or Columns pane) on which to set the filter and select Data Filter.**
   
The Data Filter dialog box is displayed.

2. **Select Filter Type > Top/Bottom N.**

3. **To retrieve the top \(n\) rows or columns of a dimension, select Top and in the text edit box, specify the number of rows or columns to retrieve. Enter a whole number only; decimal points and negative amounts are not accepted.**

4. **To retrieve the bottom \(n\) rows or columns of a dimension, select Bottom and specify the number of rows or columns to retrieve in the text edit box. Enter a whole number only; decimal points and negative amounts are not accepted.**

5. **From the Sort Order drop-down, select to sort rows or columns in Ascending or Descending order.**

6. **From the Sort On pane, select a column or row member from which to run the filter.**

   For Top/Bottom \(n\) and Sort data filters, an alternate axis member selection is required to apply the filter. For example, if you are applying a data filter against a column member, a row member must be selected.

7. **Click to add the column member to the Selected pane.**

8. **Click OK.**

➤ To sort data in ascending or descending order:

1. **In the data layout, right click on a dimension (either in a row or column) on which to set the filter and select Data Filter.**
   
The Data Filter dialog box opens.

2. **Select Filter Type > Sort.**

3. **From Sort Order, select to sort rows or columns in Ascending or Descending order.**

4. **From Sort On, select a column or row member from which to run the filter.**

   For a Top/Bottom \(n\) data filter and Sort data filter, an alternate axis member selection is required to apply the filter. For example, if you are applying a data filter against a column member, a row member must be selected.
5 Click to add the column member to the Selected pane.

6 Click OK.

➤ To show or hide a member or value in an asymmetric report:

1. In the data layout, right-click a dimension (in either the Rows or Columns) which to set the and select Data Filter.

   The Data Filter dialog box opens.

2. Select Show/Hide from the Filter type drop-down.

3. From Select method, choose Hide or Show.

   By default Show is selected.

4. To show or hide a member in the row label, select Member from the Where pane and from the Members pane, choose the members.

5. To show or hide dimension members when all dimension member values satisfy a condition, from the Where pane, select Values from the Where pane, and from the Members pane, choose the values.

6. Set a condition on a value by selecting Condition and indicating a comparative condition on the Set Condition dialog.

7. Click to add the column member to the Selected pane.

   The selected member is displayed in the Selected pane as: Show or Hide (“member_name”).

   The selected value condition is displayed in the Selected pane as Show or Hide (“member_name”): val condition (“value”).

8. Click OK.

**Set Condition**

Use the Set Condition dialog box to specify standardized comparison operators such as greater than, less than or equal to for dimension member values. This function is available for the Show/Hide feature of Data Filters.

➤ To define a value condition for the Show/Hide feature:

1. From the Where pane of the Show/Hide definition, select Value for a dimension member value.

2. Click Condition.

   The Set Condition dialog box is displayed.

3. Select a comparison operator from (Operator), which includes:
   - = (equal to)
   - <> (less than, greater than) or (not equal to)
   - < (less than)
   - <= (less than, equal to)
4 In the edit box, enter the numeric value to use as a condition.

Periods and hyphens (for negative amounts) can be entered in the edit box.

5 Click OK.

The Data Filter dialog box is reopened.

6 Click to add the conditioned value to the Selected pane.

7 Click OK.

Persisting Data Filters

Data filters (Top/BottomN, Sort, or Hide/Show) are persisted even after the members selected for the data filter are no longer in the query. As long as the overall dimension selections in the data layout are not modified, the data filter can still be applied. This behavior enables users to retain the data filter definition even when the query is modified or rebuilt. If the dimension selections in the data layout are changed and the data filter definition is not removed or modified, the results set may not be synchronized with what has been requested.

To alert users to pre-existing data filter definitions when the members selected for the data filter are not in the query, CubeQuery includes the prompt: “A Data Filter definition can no longer be applied. Would you like to Leave the definition, Remove or Update it?”

Valid responses include:

- Leave—Preserves the data filter definition regardless of members that have been added or removed from the query.
- Remove—Removes the entire data filter definition.
- Update—Launches the Data Filter dialog box so that the user can update the data filter definition.

Under certain circumstances, the user may not be prompted:

- the user removes the selected “Member” selection type (via Member selection dialog) from the axis in which the definition is defined
- the user drills on a dimension axis in which the definition is defined and where the “Include selection” option is disabled (selected “Member” selection type is removed)
- the user select to keep only the dimension on the axis in which the definition is defined (selected “Member” selection type is removed)
- Members are added to the same dimensional rows and columns (all methods). For example, if members are added to a row axis where a Top/BottomN is defined for the Market dimension, and additional members are added to the Market dimension, then no prompt is displayed.
● Members are removed from the same dimensional rows and columns (all methods). If a member selection change is made to the opposite axis in which the data filter is defined, there is no prompt as long as the selected member is not removed.

● Member Selection (all methods including variables) changes are made from the same dimensional rows and column. If Member selection changes are made to an opposite axis, the prompt is not invoked unless the member is changed. For example, Year is the selected dimension, and Year is the selected member. In this case, Qtr1 and Qtr4 can be modified without a prompt, but if Year changed, the user is prompted.

● Drilling (all methods) does not invoke the prompt if drilling on the dimension where the Top/BottomN definition is applied, only the members. If the drilling is performed on the dimensional axes with the selected member (for example “Year”) and the member remains, the prompt is not invoked.

● Keep Only (all methods)—same as drilling

● Remove Only (all methods)—same as drilling

Query Options

Use the Query Options to define global and local display behavior and drill options. The Query Options dialog box comprises the Global, Display, and Drill tabs.

➤ To display query options, select Query > Query Options.

Global Options

Use the Global tab to set global display behavior in the CubeQuery section.

<table>
<thead>
<tr>
<th>Design Options</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Auto-Refresh Query</strong></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Catalog Options</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Number of members to display</strong></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>
The default number of members is 50. In both the Catalog List and Member Selection, the “more…” node expands to the next set of members.

---

**Display Options**

Use the Display tab to set row and column suppression criteria, alias information, and replacement values.

### Suppress

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>#Missing Rows</td>
<td>Suppress the return of data rows that contain only missing values. If one value is in the row, the row is not suppressed. By default, this option is enabled.</td>
</tr>
<tr>
<td>Zero Rows</td>
<td>Suppress the return of data rows that contain only zeros. By default, this option is disabled.</td>
</tr>
<tr>
<td>Shared Members</td>
<td>Suppress the return of members tagged as shared. By default this option is disabled. When enabled, shared members are suppressed from the Catalog, query results and the Member Selection dialog. <strong>Note:</strong> When using shared members with non-unique Essbase outlines, the shared members are not recognized for suppression by Essbase. If “Suppress Shared Members” is enabled in a non-unique outline, shared members are not suppressed when they appear in a query. This occurs if the members are selected (for example, Member Selection dialog or Catalog) or navigated to (for example, Drilling, Keep/Remove Only).</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>#Missing Columns</td>
<td>Suppress the return of data columns that contain only missing data. By default, this option is enabled.</td>
</tr>
<tr>
<td>Zero Columns</td>
<td>Suppress the return of data columns that contain only zeros. By default, this option is disabled.</td>
</tr>
</tbody>
</table>

### Aliases

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Aliases</td>
<td>Display aliases when performing database retrievals rather than database member names. Aliases are alternate names for database members. You can retrieve data that uses the database name, which is often a stock number or product code, or an alias, which can be more descriptive. When this setting is updated, this message is displayed: “The OLAP Tree will be updated automatically with new Alias information and the OLAP Query will be re-processed.”</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select an Alias Table</td>
<td>Specify the alias table to use for alias names. Each database can contain one or more alias tables.</td>
</tr>
</tbody>
</table>

### Replacement

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>#Missing Label</td>
<td>Specify a label for missing values. For example, you might enter: #Missing By default, the replacement value for a missing label is blank.</td>
</tr>
</tbody>
</table>
Zero Label

Specify a label for zero values. By default the replacement value for a zero label is blank.

Drill Options

Use the Drill tab to define the next level of data displayed when you drill down in a CubeQuery. Additionally, the Member Retention option group contains items that enable you to customize drilling retention characteristics.

Drill Level

(Stats Level drop-down) Defines the next level of data displayed when you drill down from the Query menu, or when you double click a member. Any drill down selection made from the shortcut menu overrides the selection made here. For example, if you select Bottom Level, data for the lowest level of members in a dimension is retrieved. A drill-down on Year retrieves: Jan, Feb, Mar, Apr, Ma, Ju, Jul, Aug, Sep, Oct, Nov, and Dec.

Valid drill down levels are:
- Next Level
- Bottom Level
- All Descendants
- Sibling
- Same Level
- Same Generation

Member Retention

Include Selection

Retains the selected member along with the other members retrieved as a result of a drill down. For example, if you drill down on Qtr1, the data for Jan, Feb, and Mar, as well as Qtr1, is retrieved. When this option is disabled, the data for only for Jan, Feb, and Mar, is retrieved: Qtr1 is eliminated. By default, this option is enabled.

Within Selected Group

Applies (drilling) to only the group of members in which the selection is made. By default, this setting is disabled. It is meaningful only when the report contains two or more dimensions of data down a report as rows or across a report as columns. This type of report is considered asymmetric, which is characterized by groups of nested members that differ by at least one member.

Remove Unselected Groups

Removes all dimension groups that are not in the selected group.

Navigating CubeQuery

For navigating and maintaining data in the CubeQuery section, see:

- Keep Only
- Remove Only
- Drilling
- Drilling to a Shared Member
Keep Only

The Keep Only feature enables you to focus on one member by allowing you to clear all other dimension member selections except the selected member from the Results set. Non-kept members are not available on the Member Selection dialog box.

➤ To keep specific set members:

1 Select one member or a range of members.
   Ctrl + click to keep nonadjacent cells.

2 Right-click a dimension label and select Keep Only.
   Only the selected members are shown in the report.

Remove Only

Clears a dimension member to remove it from the query result set. At least one member must be retained to use this feature. Removed members are not included in the results set, but display on Member Selection dialog as excluded from the query (flagged with a - or minus sign). To add a member back to the query, the exclusion must be from the Selected pane. See also Member Selection Exclusions.

➤ To remove a selected member:

1 Select one member or a range of members.
   Ctrl + click to remove nonadjacent cells.

2 Right-click a dimension label and select Remove Only.
   The member is removed from the report and the query. To add the member to the query again, add it from the Catalog to the data layout, or select it on the Member Selection dialog box.

Suppressing Missing and Zero Values

Suppressing missing and zero values in rows and columns prevents irrelevant information from being returned, reduces network traffic, and increases query speed. Query options box enables you to customize how CubeQuery handles missing and zero values, including the text label displayed for these values by default. You can suppress the values on the shortcut menu.

➤ To suppress missing values in rows, right-click a row and select Suppress > Missing rows.
   By default, missing values are blank.
To suppress missing values in columns, right-click a column and select Suppress > Missing columns.

To suppress zero values in rows, right-click a row and select Suppress > Zero rows.
By default zero values are shown as 0 (zero).

To suppress zero values in columns, right-click a column and select Suppress > Zero columns.

Drilling
Drilling increases or decreases the display of report detail for dimensions with large amounts of level data. It can consist of drilling down (in many forms) or drilling up. Drilling down retrieves more detailed data within a dimension. You can drill down into more detailed data until the lowest level of a dimension as defined in the database outline is reached.

A before and after drill down example is shown below:

Before drilling:

<table>
<thead>
<tr>
<th>Market</th>
<th>Product</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Oct</td>
<td>12,686</td>
</tr>
</tbody>
</table>

After drilling:

<table>
<thead>
<tr>
<th>Market</th>
<th>Product</th>
</tr>
</thead>
<tbody>
<tr>
<td>Audio</td>
<td>Visual</td>
</tr>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Oct</td>
<td>3,803</td>
</tr>
</tbody>
</table>

In this example for October, you can drill down to Audio and Visual. Drilling up is the opposite of drilling down, where you move up the hierarchy within a dimension to less detailed data. Query Options enables you to customize the behavior of the drill level. Shortcut menus also control the drill levels.

Note:
You cannot drill down on a Date Time Series member.

To drill down to more detail:
1 Select the member.
2 Double-click the member to drill down using the default Drill Level as defined in Query Options.
Tip:
You can also right-click a member, and select Drill > Down to drill down using the default drill level defined in “Query Options” on page 202.

Additional drill down options include:
- Down—Drills down to more dimension detail using the default drill level defined in Query Options.
- Up—Drills up to less dimension detail.
- Next—Drills down to the children. This is the default Drill Level. For example, a drill on Year retrieves Qtr1, Qtr2, Qtr3, and Qtr4.
- Bottom—Drills down to the lowest level of members in a dimension. For example, a drill on Year retrieves Jan, Feb, Mar, Apr, May, Jun, Jul, Aug, Sep, Oct, Nov, and Dec.
- All Descendants—Retrieves data for all descendants. For example, a drill on Year retrieves all quarterly and monthly members.
- Siblings—Retrieves data for siblings. For example, a drill on Jan retrieves Jan, Feb, and Mar.
- Same Level—Retrieves data for all members at the same level. For example, a drill on Sales might retrieve values for COGS, Marketing, Payroll, Misc, Opening Inventory, Additions, Ending Inventory, Margin %, and Profit %.
- Same Generation—Retrieves data for all members of the same generation as the selected member or members. For example, a drill on Sales retrieves COGS, Marketing, Payroll, and Misc.

Drilling to a Shared Member
You can drill down or drill up on a member that has a shared member defined in the Essbase outline. Essbase determines which members are eligible — the base member or the shared member, and returns drilled or stored members based on the drill path.

This is an Essbase outline:

```
Product
  100
    150 (stored member)
      100-10
      100-20
    100-15
  100-20
Brand1
  150 (shared member)
```

The stored member 150 has children; the shared member 150 does not. Drilling up and down on 150 gives different results:
Drilling down on 150 returns nothing if it is interpreted as the shared member; or, returns 100-10 and 100-20 if it is interpreted as the regular member.

Drilling up on 150 returns Brand1 if it is interpreted as the shared member; or returns 100 if it is interpreted as the regular member.

The proximity of the shared member to the regular member gives different results when drilling down. When drilling up on a member that has a shared member, Essbase looks at the members to determine which one is being queried. For example, drilling up on 100-20 sometimes returns Diet and returns 100, depending on whether Diet or 100 is closest to the member 100-20. If 100-20 is alone, then Essbase determines that this is the regular member. If Diet is closer, then 100-20 may be interpreted as the shared member.

**Downloading to Results**

Downloading to Results is an instrument for rendering a flat table representation of the multidimensional Essbase data cubes in Interactive Reporting. The data is loaded into a Result section of Interactive Reporting document, and can be used for further analysis, report creation and joining with data from other relational data sources. In this case the data processing (e.g. aggregation, totaling, custom calculations, table joins) is performed on the Interactive Reporting side.

Downloading to Results populates a Results sections with the results of the processed CubeQuery section. Additionally, the Results set can be integrated with the Chart, Table, and reporting sections.

Results are only updated when you select the Download to Results feature, or when you take the downloaded results set and process the results again.

If you expect the query to retrieve a small to medium sized data set, it is recommended that you enable the automatic download feature from the Query > Tools > Options > Program Options > OLAP > Auto Generate Results When Processing OLAP Query. If you choose this option, the Results set is not created for the current CubeQuery section, but only for new CubeQuery sections. In some circumstances when querying large amounts of data, the automatic creation of a Results section may result in a slight reduction in query performance.

**Note:**

Shared members can be excluded from the query by way of Query Options, however there are some cases where customers might want to include Shared Members in the query and results set, but not in the totals. If you want to include shared members in the results set, the parent context needs to exist in the query. In other words, if a shared member’s parent does not exist in the query, Download to Results does not recognize that it is a shared member. When downloading to results a query that has a “ragged” member selection, where some parent members are not expanded to details, the warning message appears: "Note that if the source query results are not fully expanded and/or symmetric, invalid flattened results might be returned." This is necessary for the “parent context” of shared members in a results set – shared member parents need to exist in the query in order to determine that they are shared for the results set:
To download the query to results, select **Query > Download to Results**.

The behavior of the Download to Results feature varies for different components in CubeQuery:

- **Separate Columns for Metadata Labels**
- **Measure Behavior in Columns**
- **Measure Behavior in Columns**
- **Shared Members**
- **Including Totals**

### Separate Columns for Metadata Labels

Separate columns for metadata labels are displayed for each Essbase generation in the hierarchy.

#### Table 35  CubeQuery Requested Items (Profit Member Applied In the Filter)

<table>
<thead>
<tr>
<th>Product</th>
<th>Qtr1</th>
<th>Qtr2</th>
<th>Qtr3</th>
<th>Qtr4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cola</td>
<td>5096</td>
<td>5892</td>
<td>6583</td>
<td>5206</td>
</tr>
<tr>
<td>Diet Cola</td>
<td>1359</td>
<td>1534</td>
<td>1528</td>
<td>1287</td>
</tr>
<tr>
<td>Caffeine Free Cola</td>
<td>593</td>
<td>446</td>
<td>400</td>
<td>544</td>
</tr>
<tr>
<td>Cola</td>
<td>7048</td>
<td>7872</td>
<td>8511</td>
<td>7037</td>
</tr>
<tr>
<td>Old Fashioned</td>
<td>1697</td>
<td>1734</td>
<td>1883</td>
<td>1887</td>
</tr>
<tr>
<td>Diet Root Beer</td>
<td>2963</td>
<td>3079</td>
<td>3149</td>
<td>2834</td>
</tr>
<tr>
<td>Sarsaparilla</td>
<td>1153</td>
<td>1231</td>
<td>1159</td>
<td>1093</td>
</tr>
<tr>
<td>Birch Beer</td>
<td>908</td>
<td>986</td>
<td>814</td>
<td>1384</td>
</tr>
<tr>
<td>Root Beer</td>
<td>6721</td>
<td>7030</td>
<td>7005</td>
<td>7198</td>
</tr>
</tbody>
</table>

#### Table 36  Results Set

<table>
<thead>
<tr>
<th>Category</th>
<th>Product SKU</th>
<th>Quarter</th>
<th>Profit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Colas</td>
<td>Cola</td>
<td>Qtr1</td>
<td>5096</td>
</tr>
<tr>
<td>Colas</td>
<td>Diet Cola</td>
<td>Qtr1</td>
<td>1359</td>
</tr>
<tr>
<td>Colas</td>
<td>Caffeine Free Cola</td>
<td>Qtr1</td>
<td>593</td>
</tr>
<tr>
<td>Root Beer</td>
<td>Old Fashioned</td>
<td>Qtr1</td>
<td>1697</td>
</tr>
<tr>
<td>Root Beer</td>
<td>Diet Root Beer</td>
<td>Qtr1</td>
<td>2963</td>
</tr>
<tr>
<td>Root Beer</td>
<td>Sarsaparilla</td>
<td>Qtr1</td>
<td>1153</td>
</tr>
<tr>
<td>Root Beer</td>
<td>Birch Beer</td>
<td>Qtr1</td>
<td>908</td>
</tr>
</tbody>
</table>
If only one generation of the hierarchy is in the query, additional columns do not show the parent members in the Results set as shown below:

**Table 37  CubeQuery Requested Items (Profit Member is in the Columns)**

<table>
<thead>
<tr>
<th>Product SKU</th>
<th>Qtr1</th>
<th>Qtr2</th>
<th>Qtr3</th>
<th>Qtr4</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cola</td>
<td>5096</td>
<td>5892</td>
<td>6583</td>
<td>5206</td>
</tr>
<tr>
<td>Diet Cola</td>
<td>1359</td>
<td>1534</td>
<td>1528</td>
<td>1287</td>
</tr>
<tr>
<td>Caffeine Free Cola</td>
<td>593</td>
<td>446</td>
<td>400</td>
<td>544</td>
</tr>
<tr>
<td>Old Fashioned</td>
<td>1697</td>
<td>1734</td>
<td>1883</td>
<td>1887</td>
</tr>
<tr>
<td>Diet Root Beer</td>
<td>2963</td>
<td>3079</td>
<td>3149</td>
<td>2834</td>
</tr>
<tr>
<td>Sarsaparilla</td>
<td>1153</td>
<td>1231</td>
<td>1159</td>
<td>1093</td>
</tr>
<tr>
<td>Birch Beer</td>
<td>908</td>
<td>986</td>
<td>814</td>
<td>1384</td>
</tr>
<tr>
<td>Dark Cream</td>
<td>2544</td>
<td>3231</td>
<td>3355</td>
<td>3065</td>
</tr>
</tbody>
</table>

**Table 38  Results Set**

<table>
<thead>
<tr>
<th>Product SKU</th>
<th>Quarter</th>
<th>Profit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cola</td>
<td>Qtr1</td>
<td>5096</td>
</tr>
<tr>
<td>Cola</td>
<td>Qtr2</td>
<td>5892</td>
</tr>
<tr>
<td>Cola</td>
<td>Qtr3</td>
<td>6583</td>
</tr>
<tr>
<td>Cola</td>
<td>Qtr4</td>
<td>5206</td>
</tr>
<tr>
<td>Diet Cola</td>
<td>Qtr1</td>
<td>1359</td>
</tr>
<tr>
<td>Diet Cola</td>
<td>Qtr2</td>
<td>1534</td>
</tr>
<tr>
<td>Diet Cola</td>
<td>Qtr3</td>
<td>1528</td>
</tr>
<tr>
<td>Diet Cola</td>
<td>Qtr4</td>
<td>1287</td>
</tr>
<tr>
<td>Caffeine Free Cola</td>
<td>Qtr1</td>
<td>593</td>
</tr>
<tr>
<td>Caffeine Free Cola</td>
<td>Qtr2</td>
<td>446</td>
</tr>
<tr>
<td>Caffeine Free Cola</td>
<td>Qtr3</td>
<td>400</td>
</tr>
<tr>
<td>Caffeine Free Cola</td>
<td>Qtr4</td>
<td>544</td>
</tr>
</tbody>
</table>
Measure Behavior in Columns

In the CubeQuery section, the measure dimension is handled like any other dimension (it can be placed in rows or columns), but a separate Results set column is created for each Measure member, whether it is in a row, column, or filter.

Table 39  Measures in CubeQuery

<table>
<thead>
<tr>
<th></th>
<th>Qtr1</th>
<th>Qtr2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales</td>
<td>Cola</td>
<td>14585</td>
</tr>
<tr>
<td></td>
<td>Diet Cola</td>
<td>7276</td>
</tr>
<tr>
<td>COGS</td>
<td>Cola</td>
<td>5681</td>
</tr>
<tr>
<td></td>
<td>Diet Cola</td>
<td>3496</td>
</tr>
<tr>
<td></td>
<td>Caffeine Free Cola</td>
<td>1493</td>
</tr>
</tbody>
</table>

Table 40  Measures in Results Set

<table>
<thead>
<tr>
<th>Product SKU</th>
<th>Quarter</th>
<th>Sales</th>
<th>COGS</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cola</td>
<td>Qtr1</td>
<td>14585</td>
<td>5681</td>
</tr>
<tr>
<td>Diet Cola</td>
<td>Qtr1</td>
<td>7276</td>
<td>3496</td>
</tr>
<tr>
<td>Caffeine Free Cola</td>
<td>Qtr1</td>
<td>3187</td>
<td>1493</td>
</tr>
</tbody>
</table>

If no Measures are in the row, column or filter, all data values appear in a Value column.

Table 41  Values Column in Results Set

<table>
<thead>
<tr>
<th>Product SKU</th>
<th>Quarter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cola</td>
<td>Qtr1</td>
<td>14585</td>
</tr>
<tr>
<td>Diet Cola</td>
<td>Qtr1</td>
<td>7276</td>
</tr>
<tr>
<td>Caffeine Free Cola</td>
<td>Qtr1</td>
<td>3187</td>
</tr>
</tbody>
</table>

Ragged Hierarchies

In Essbase, an individual hierarchy has the same number of members above it as any other member at the same level. In a ragged hierarchy, the logical parent member for one member is not in the level directly above the member. When downloading to results a query that has a ragged member selection, and where some parent members are not expanded to details, a warning message is displayed: "Note that if the source query results are not fully expanded and/or symmetric, invalid flattened results might be returned." This message is necessary to show "parent context" or shared member parents need to exist in the query in order to determine that they are shared for the results set.
In the following example Qtr2 does not have children in the query. Because only the lowest level members are included in the query, the Results set includes: Jan, Feb, Mar, and Qtr2. For the “month” value for Qtr2, the label is blank.

<table>
<thead>
<tr>
<th>Table 42</th>
<th>Ragged Hierarchy in CubeQuery Section</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Product</td>
</tr>
<tr>
<td>Jan</td>
<td>8024</td>
</tr>
<tr>
<td>Feb</td>
<td>8346</td>
</tr>
<tr>
<td>Mar</td>
<td>8333</td>
</tr>
<tr>
<td>Qtr1</td>
<td>24703</td>
</tr>
<tr>
<td>Qtr2</td>
<td>27107</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table 43</th>
<th>Ragged Hierarchy in Results Set</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quarter</td>
<td>Month</td>
</tr>
<tr>
<td>Qtr1</td>
<td>Jan</td>
</tr>
<tr>
<td>Qtr1</td>
<td>Feb</td>
</tr>
<tr>
<td>Qtr1</td>
<td>Mar</td>
</tr>
<tr>
<td>Qtr2</td>
<td>(blank)</td>
</tr>
</tbody>
</table>

If a child member does not have a parent member in the original query, the parent or any other ancestor is included in the Results set:

<table>
<thead>
<tr>
<th>Table 44</th>
<th>Ragged Hierarchy in CubeQuery Section</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Product</td>
</tr>
<tr>
<td>Jan</td>
<td>8024</td>
</tr>
<tr>
<td>Feb</td>
<td>8346</td>
</tr>
<tr>
<td>Mar</td>
<td>8333</td>
</tr>
<tr>
<td>Qtr1</td>
<td>24703</td>
</tr>
<tr>
<td>Dec</td>
<td>8780</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Table 45</th>
<th>Ragged Hierarchy in Results Set</th>
</tr>
</thead>
<tbody>
<tr>
<td>Quarter</td>
<td>Month</td>
</tr>
<tr>
<td>Qtr1</td>
<td>Jan</td>
</tr>
<tr>
<td>Qtr1</td>
<td>Feb</td>
</tr>
<tr>
<td>Qtr1</td>
<td>Mar</td>
</tr>
</tbody>
</table>
Shared Members

Shared member data can be included in a query, or their totals can be excluded. Each shared member column in the Results set corresponds to an Essbase Generation/Field in the Results set and query. For Shared Members, the parent context must exist in the query. In other words, if the parent of a shared member is not in the query, the Download to Results feature does not recognize that it is a shared member and determines the parent. In this case, a warning message is displayed: "Note that if the source query results are not fully expanded and/or symmetric, invalid flattened results might be returned." This message is necessary to show the “parent context”. That is, a the parents of a shared member must exist in the query in order to determine that they are shared for the results set. For example, in the Sample Basic Product dimension, for the second instance of “100-20” (shared member) to be properly accounted for in the Download to Results, its parent “Diet” must be included in the query such as “Diet (Children)”. 

Note:

Shared members are in bold below.

Table 46  Shared Members in CubeQuery Section

<table>
<thead>
<tr>
<th>Qtr1</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>100-10</td>
<td>5096</td>
</tr>
<tr>
<td>100-20</td>
<td>1359</td>
</tr>
<tr>
<td>100-30</td>
<td>593</td>
</tr>
<tr>
<td>100</td>
<td>7048</td>
</tr>
<tr>
<td>200-10</td>
<td>1697</td>
</tr>
<tr>
<td>200-20</td>
<td>2963</td>
</tr>
<tr>
<td>200-30</td>
<td>1153</td>
</tr>
<tr>
<td>200-40</td>
<td>908</td>
</tr>
<tr>
<td>200</td>
<td>6721</td>
</tr>
<tr>
<td>300-10</td>
<td>2544</td>
</tr>
<tr>
<td>300-20</td>
<td>690</td>
</tr>
<tr>
<td>300-30</td>
<td>2695</td>
</tr>
<tr>
<td>300</td>
<td>5929</td>
</tr>
<tr>
<td>400-10</td>
<td>2838</td>
</tr>
</tbody>
</table>
### Table 47  Shared Members in Results Set

<table>
<thead>
<tr>
<th>Product SKU, Shared</th>
<th>Gen1, Product</th>
<th>Category</th>
<th>Product SKU</th>
<th>Quarter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product 100</td>
<td>100–10</td>
<td>Product 100</td>
<td>Qtr1</td>
<td>5096</td>
<td></td>
</tr>
<tr>
<td>Product 100</td>
<td>100–20</td>
<td>Product 100</td>
<td>Qtr1</td>
<td>1359</td>
<td></td>
</tr>
<tr>
<td>Product 100</td>
<td>100–30</td>
<td>Product 100</td>
<td>Qtr1</td>
<td>593</td>
<td></td>
</tr>
<tr>
<td>Product 200</td>
<td>200–10</td>
<td>Product 200</td>
<td>Qtr1</td>
<td>1697</td>
<td></td>
</tr>
<tr>
<td>Product 200</td>
<td>200–20</td>
<td>Product 200</td>
<td>Qtr1</td>
<td>2963</td>
<td></td>
</tr>
<tr>
<td>Product 200</td>
<td>200–30</td>
<td>Product 200</td>
<td>Qtr1</td>
<td>1153</td>
<td></td>
</tr>
<tr>
<td>Product 200</td>
<td>200–40</td>
<td>Product 200</td>
<td>Qtr1</td>
<td>908</td>
<td></td>
</tr>
<tr>
<td>Product 300</td>
<td>300–10</td>
<td>Product 300</td>
<td>Qtr1</td>
<td>2544</td>
<td></td>
</tr>
<tr>
<td>Product 300</td>
<td>300–20</td>
<td>Product 300</td>
<td>Qtr1</td>
<td>690</td>
<td></td>
</tr>
<tr>
<td>Product 300</td>
<td>300–30</td>
<td>Product 300</td>
<td>Qtr1</td>
<td>2695</td>
<td></td>
</tr>
<tr>
<td>Product 400</td>
<td>400–10</td>
<td>Product 400</td>
<td>Qtr1</td>
<td>2838</td>
<td></td>
</tr>
<tr>
<td>Product 400</td>
<td>400–20</td>
<td>Product 400</td>
<td>Qtr1</td>
<td>2283</td>
<td></td>
</tr>
<tr>
<td>Product 400</td>
<td>400–30</td>
<td>Product 400</td>
<td>Qtr1</td>
<td>-116</td>
<td></td>
</tr>
</tbody>
</table>

- **100–20**  
  | Product 100 | Diet | 100–20 | Qtr1 | 1359 |

- **200–20**  
  | Product 200 | Diet | 200–20 | Qtr1 | 2963 |

- **300–30**  
  | Product 300 | Diet | 300–30 | Qtr1 | 2695 |

If multiple generation dimensions have shared members, one “shared” indication per dimension is created:

**Note:**  
Shared members are in bold below.
Table 48  Multiple Dimensions with Shared Members in CubeQuery Section

<table>
<thead>
<tr>
<th>Scenario, Gen2, Shared</th>
<th>Qtr1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actual</td>
<td></td>
</tr>
<tr>
<td>100–10</td>
<td>5096</td>
</tr>
<tr>
<td>100–20</td>
<td>1359</td>
</tr>
<tr>
<td>100</td>
<td>7048</td>
</tr>
<tr>
<td><strong>100–20</strong></td>
<td>1359</td>
</tr>
<tr>
<td>Diet</td>
<td>7017</td>
</tr>
<tr>
<td>Budget</td>
<td></td>
</tr>
<tr>
<td>100–10</td>
<td>6510</td>
</tr>
<tr>
<td>100–20</td>
<td>2240</td>
</tr>
<tr>
<td>100</td>
<td>9790</td>
</tr>
<tr>
<td>100–20</td>
<td>2240</td>
</tr>
<tr>
<td>100</td>
<td>9790</td>
</tr>
<tr>
<td><strong>100–20</strong></td>
<td>2240</td>
</tr>
<tr>
<td>Diet</td>
<td>8910</td>
</tr>
<tr>
<td>Actual</td>
<td></td>
</tr>
<tr>
<td>100–10</td>
<td>5096</td>
</tr>
<tr>
<td>100–20</td>
<td>1359</td>
</tr>
<tr>
<td>100</td>
<td>7048</td>
</tr>
<tr>
<td><strong>100–20</strong></td>
<td>1359</td>
</tr>
<tr>
<td>Diet</td>
<td>7017</td>
</tr>
</tbody>
</table>

Table 49  Multiple Dimension With Shared Members in Results set

<table>
<thead>
<tr>
<th>Scenario, Gen2, Shared</th>
<th>Scenario, Gen2, Shared</th>
<th>Product SKU, Shared</th>
<th>Category</th>
<th>Product SKU</th>
<th>Quarter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actual</td>
<td></td>
<td></td>
<td></td>
<td>100–10</td>
<td>Qtr1</td>
<td>5096</td>
</tr>
<tr>
<td>Actual</td>
<td></td>
<td></td>
<td></td>
<td>100–20</td>
<td>Qtr1</td>
<td>1359</td>
</tr>
<tr>
<td>Actual</td>
<td><strong>100–20</strong></td>
<td>Diet</td>
<td>100–20</td>
<td>Qtr1</td>
<td>1359</td>
<td></td>
</tr>
<tr>
<td>Budget</td>
<td></td>
<td></td>
<td></td>
<td>100–10</td>
<td>Qtr1</td>
<td>6510</td>
</tr>
<tr>
<td>Budget</td>
<td></td>
<td></td>
<td></td>
<td>100–20</td>
<td>Qtr1</td>
<td>2240</td>
</tr>
<tr>
<td><strong>Budget</strong></td>
<td><strong>100–20</strong></td>
<td>Diet</td>
<td>100–20</td>
<td>Qtr1</td>
<td>2240</td>
<td></td>
</tr>
<tr>
<td>Actual</td>
<td><strong>Actual</strong></td>
<td></td>
<td></td>
<td>100–10</td>
<td>Qtr1</td>
<td>5096</td>
</tr>
<tr>
<td>Actual</td>
<td><strong>Actual</strong></td>
<td></td>
<td></td>
<td>100–20</td>
<td>Qtr1</td>
<td>1359</td>
</tr>
</tbody>
</table>
If a dimension contains shared members at multiple generations, a column is added to the Results set for each CubeQuery generation and Results set column:

Note:
Shared members are in bold below.

Table 50  Shared Members At Multiple Generation Level in the CubeQuery Section

<table>
<thead>
<tr>
<th>Gen1, Product</th>
<th>Category</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>100-10</td>
<td>Qtr1</td>
<td>5096</td>
</tr>
<tr>
<td>100-20</td>
<td></td>
<td>1359</td>
</tr>
<tr>
<td>100-30</td>
<td></td>
<td>593</td>
</tr>
<tr>
<td>100</td>
<td></td>
<td>7048</td>
</tr>
<tr>
<td>...</td>
<td></td>
<td></td>
</tr>
<tr>
<td>400-10</td>
<td></td>
<td>2838</td>
</tr>
<tr>
<td>400-20</td>
<td></td>
<td>2283</td>
</tr>
<tr>
<td>400-30</td>
<td></td>
<td>-116</td>
</tr>
<tr>
<td>400</td>
<td></td>
<td>5005</td>
</tr>
<tr>
<td><strong>100-20</strong></td>
<td></td>
<td>1359</td>
</tr>
<tr>
<td><strong>200-20</strong></td>
<td></td>
<td>2963</td>
</tr>
<tr>
<td><strong>300-30</strong></td>
<td></td>
<td>2695</td>
</tr>
<tr>
<td>Diet</td>
<td></td>
<td>7017</td>
</tr>
<tr>
<td><strong>400</strong></td>
<td></td>
<td>5005</td>
</tr>
<tr>
<td>Product</td>
<td></td>
<td>24703</td>
</tr>
</tbody>
</table>

Table 51  Shared Members at Multiple Generation Level in the Results Set

<table>
<thead>
<tr>
<th>Category, Shared</th>
<th>Product SKU, Shared</th>
<th>Gen1, Product</th>
<th>Category</th>
<th>Product SKU</th>
<th>Quarter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Product</td>
<td>100</td>
<td>100-10</td>
<td>Qtr1</td>
<td>5096</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>100</td>
<td>100-20</td>
<td>Qtr1</td>
<td>1359</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Product</td>
<td>100</td>
<td>100-30</td>
<td>Qtr1</td>
<td>593</td>
<td></td>
<td></td>
</tr>
<tr>
<td>...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Including Totals

To prevent data values from being counted twice, totals and upper level members are not included in the downloaded results set.

In the Pivot section, shared members can be excluded from totals by disabling the Aggregate Shared Members option.

In addition, in the Pivot section all results are summed. Some Essbase aggregations may not sum member results due to outline calculations and member unary operators (+, −, *, /, −). As a result, there may be difference shown between Essbase and Pivot totals depending on the outline structure and calculations of the cube.

Note:

Shared members are in bold below.

Table 52  Shared Members Disabled in the CubeQuery Section

<table>
<thead>
<tr>
<th></th>
<th>Qtr1</th>
</tr>
</thead>
<tbody>
<tr>
<td>100–10</td>
<td>5096</td>
</tr>
<tr>
<td>100–20</td>
<td>1359</td>
</tr>
<tr>
<td>100–30</td>
<td>593</td>
</tr>
<tr>
<td>100</td>
<td>7048</td>
</tr>
<tr>
<td></td>
<td>...</td>
</tr>
<tr>
<td>400–10</td>
<td>2838</td>
</tr>
<tr>
<td>400–20</td>
<td>2293</td>
</tr>
<tr>
<td>400–20</td>
<td>−116</td>
</tr>
<tr>
<td>400</td>
<td>5005</td>
</tr>
</tbody>
</table>
Note:
The Product total does not include the “Diet” member total of “7017” because it is configured in the Analytic Service outline to “no consolidate.”

If the same results are inserted into a pivot, the Product total includes the value for the Diet member.

Table 53  Aggregate Shared Members Enabled in the Results Set

<table>
<thead>
<tr>
<th>Qtr1</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>100-10</td>
<td>5096</td>
</tr>
<tr>
<td>100-20</td>
<td>1359</td>
</tr>
<tr>
<td>100-30</td>
<td>593</td>
</tr>
<tr>
<td></td>
<td>Total</td>
</tr>
<tr>
<td>...</td>
<td></td>
</tr>
<tr>
<td>400-10</td>
<td>2838</td>
</tr>
<tr>
<td>400-20</td>
<td>2283</td>
</tr>
<tr>
<td>400-30</td>
<td>-116</td>
</tr>
<tr>
<td></td>
<td>Total</td>
</tr>
<tr>
<td>100-20</td>
<td>1359</td>
</tr>
<tr>
<td>200-20</td>
<td>2963</td>
</tr>
<tr>
<td>300-30</td>
<td>2695</td>
</tr>
<tr>
<td></td>
<td>Total</td>
</tr>
<tr>
<td></td>
<td>Total</td>
</tr>
</tbody>
</table>

If the “Aggregate Shared Members” option is disabled, the total is included for the initial shared member, but not for any parent members above it:
<table>
<thead>
<tr>
<th>Qtr1</th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>100–10</td>
<td>5096</td>
</tr>
<tr>
<td>100–20</td>
<td>1359</td>
</tr>
<tr>
<td>100–30</td>
<td>593</td>
</tr>
<tr>
<td>Total</td>
<td>7048</td>
</tr>
<tr>
<td>...</td>
<td></td>
</tr>
<tr>
<td>400–10</td>
<td>2838</td>
</tr>
<tr>
<td>400–20</td>
<td>2283</td>
</tr>
<tr>
<td>400–30</td>
<td>-116</td>
</tr>
<tr>
<td>Total</td>
<td>5005</td>
</tr>
<tr>
<td>100–20</td>
<td>1359</td>
</tr>
<tr>
<td>200–20</td>
<td>2963</td>
</tr>
<tr>
<td>300–30</td>
<td>2695</td>
</tr>
<tr>
<td>Total</td>
<td>7017</td>
</tr>
<tr>
<td>Total</td>
<td>24703</td>
</tr>
</tbody>
</table>

### Showing as Chart

Use the Show as Chart option to chart the CubeQuery data set and automatically create a Results set. Selecting this feature downloads the CubeQuery to results and create a table section as a parent for the chart section. If a table or chart section already exists for the CubeQuery section, a new section is not created.

➤ To show the CubeQuery as a Chart:

1. **Build and process the CubeQuery.**
   (See Building a CubeQuery Section)
2. **Select Query > Show As Chart.**

### Exporting a CubeQuery

The CubeQuery can be exported to these formats:

- Microsoft Office 2000 HTML—Results can available in Microsoft Excel 2000
Microsoft Office Web Archive (*.mhtml)—Results are available in Microsoft Excel XP and 2003

HTML (*.htm)—Results are available as a web page, complete with include files

PDF (*.pdf)—Adobe Portable Document Format (PDF) that is readable by way of Adobe Reader.

To export a CubeQuery results set:

1 Select File > Export > Section.

The Export Section dialog box is displayed.

2 From Save as type, select the export format type.

3 Click Save.

**Formatting CubeQuery Items**

Common formatting options are available for CubeQuery items on the Format and shortcut menus including:

- Font
- Style
- Number
- Justify
- Border
- Auto-Size Width
- Auto-Size Height
- Corner Labels
- Spotlighter

To modify a font format:

1 Select an item and select Format > Font.

The Font tab of the Properties dialog box opens.

2 Select font, style, size, or effects and click OK.

To modify the style of an item:

1 Select an item and select Format > Style.

A submenu of styles is opens.

2 Select a style:

- Bold
- Italic
- Underline
- Overline
- Double Overline

3 Click Select.

➤ To modify a number format:

1 Select a data cell and select Format > Number.

The Number tab of the Properties dialog box opens.

2 Select a Formatting Locale, Choose a locale.

3 From the Category field, select a date type. Valid options are:
   - All
   - Number
   - Currency
   - Percentage
   - Date
   - Time
   - Custom

The available number formats depends on the formatting locale and category. If you select a custom category, an edit box enables you can enter a custom number format.

4 Select a format.

5 Click OK.

➤ To justify text horizontally and vertically, choose a data cell and on the shortcut menu, and select Justify.

Available justification selections include:
   - left
   - center
   - right
   - top
   - middle
   - bottom

➤ To modify row or column borders, choose a row or column and on the shortcut menu, select Borders.

Available border styles include:
   - none
To auto-size the text in a cell horizontally, choose a row or a column, and select **Format > Auto-Size Width**.

Auto-sizing by width is useful for displaying horizontal values without truncation.

To auto-size the text in a cell vertically, choose a row or a column, and select **Format > Auto-Size Height**.

Auto-sizing by height is useful for displaying vertical values without truncation.

To display the name of the data layout values as corner labels, select **Format > Corner Labels** and on the shortcut menu, specify the position in which to place the corner label.

Valid corner label positions are:

- None
- Column
- Row
- Both

To use the Spotlighter, see **Spotlighter**

---

**CubeQuery Menu Command Reference**

The following table is a quick reference to the commands and shortcuts e on the Query menu.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Keyboard Shortcut</th>
<th>Shortcut Menu</th>
<th>Query Menu</th>
<th>Double-click Enabled</th>
</tr>
</thead>
<tbody>
<tr>
<td>Retrieve Dimensions</td>
<td>Refreshes the dimension values in the Catalog</td>
<td>F9</td>
<td></td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>Add to Rows</td>
<td>Adds selected item to the Rows pane in the data layout</td>
<td></td>
<td>*</td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>Add to Columns</td>
<td>Adds selected item to the Columns</td>
<td></td>
<td>*</td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>-------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add to Filters</td>
<td>Adds the selected item to the Filters pane in the data layout</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Drill Down</td>
<td>Retrieves more detail from the selected member</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Drill Up</td>
<td>Drills up to less dimension detail for the selected member</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Drill Next</td>
<td>Retrieves data for the children of the selected member or members</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Drill Bottom</td>
<td>Retrieves data from the lowest level descendants of the selected member</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Drill All Descendants</td>
<td>Retrieves all descendants of the selected member</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Drill Sibling</td>
<td>Retrieve data for the siblings of the selected member or members</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Drill Same Level</td>
<td>Retrieves data for all members at the same level as the selected member or member</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Drill Same Generation</td>
<td>Retrieves data for all members of the same generation as the selected member or members</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Download to Results</td>
<td>Downloads the CubeQuery data set to an Results section for offline work</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Show as Chart</td>
<td>Charts the CubeQuery data set; automatically creates an Chart</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Section</td>
<td>Description</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Query Options</td>
<td>Accesses the Query Options dialog box, where you can set options for your CubeQuery.</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Keep Only</td>
<td>Clears all other dimension member selections for the selected Dimension, leaving only the selected member.</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove Only</td>
<td>Clears a dimension member, removing it from the query result set.</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Suppress Missing Rows</td>
<td>Suppresses the return of data rows that contain only missing values. If one value is in the row, the row is not suppressed.</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Suppress Missing Columns</td>
<td>Suppresses the return of data columns that contain only missing columns. If one value is in the column, the column is not suppressed.</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Suppress Zero Rows</td>
<td>Suppresses the return of data rows that contain only zeros.</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Suppress Zero Columns</td>
<td>Suppresses the return of data columns that contain only zeros.</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Suppress Shared Members</td>
<td>Suppresses shared members from the query.</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cancel Query</td>
<td>Alt+End</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Pivot Section

The Pivot section enables you to extract meaningful information from your query results. Pivot tables are interactive tools used to slice and dice data for ad-hoc, interactive, and multidimensional analysis. Pivot tables enable you to add, move, rename, focus on, and group dimensions to gain customized views of the data. You can use the Pivot section to rotate or pivot rows and columns to see different summaries of data or display the details for areas of interest. You also can automatically include subtotals and grand totals, or use your own formulas by adding computed items.

Creating a Pivot Table

Pivot tables are made up of:

- **Facts**—Core numeric data that you slice and dice dimensionally in your analysis.
- **Dimensions**—Descriptive items that break aggregate data (facts) into logical categories. In the Pivot section, dimensions are either Column Labels or Row Labels.

For example, if you analyze Unit Sales by region, the numbers are your data values or facts. Region is a dimension. Presented in aggregate, facts are subdivided by your chosen dimension labels.

➤ To create a pivot table:

1. **Select Insert > New Pivot.**
2. If the data layout is not visible, click Data Layout on the Section title bar.
3 Perform one of the following actions:

- Drag each Request item to be included in the table from the Catalog pane to a pane in the data layout (Column Labels, Row Labels, or Facts).
- In the Catalog pane, select one or more Request items and select Pivot > Add Selected Items > Column Labels, Row Labels or Facts.

Tip:
Add Request items such as Unit Sales or Amount Sales to the Facts pane in data layout to create the data grid. Add dimensions such as Product Line or Region to the column and row labels panes in the data layout to create subdivisions.

Tip:
You can select and drag multiple items to the same data layout pane to add multiple values or dimensional levels for analysis. Items are hierarchically ordered in the sequence in which they are displayed in the data layout pane.

Pivoting Data

Use the Pivot feature to reorient the axes of a pivot table and view your data in new ways. Pivoting a table enables you to more easily compare the new data to data in the originating table, which makes pivot tables more powerful than common spreadsheets.

By default, pivot handles are transparent. They only appear when you select a label from a top or side. When the pivot handle appears, it is shown in white with a light grey handle ( ). Once the selection is off, the pivot handle is transparent again.

To pivot data in a table, Select a dimension handle and drag it to any position on the same or opposite dimensional axis.

Charting a Pivot Table

You can automatically generate charts from your current pivot table to view a graphic representation of your data.

To automatically chart your pivot table, select Insert > Chart This Pivot.

Interactive Reporting creates a new Chart section that displays a bar chart based on the data from the pivot table.
Working with Pivot Tables

You can select pivot table elements and perform a wide range of tasks with data elements. Since report sections organize data hierarchically, if you alter a data value item, all instances of the item within the report are affected. Review these topics for information:

- “Selecting Pivot Table Elements” on page 227
- “Moving Pivot Table Elements” on page 227
- “Changing Label Nesting Levels” on page 228
- “Sorting Pivot Tables” on page 228
- “Hiding Pivot Facts” on page 229
- “Formatting Pivot Items” on page 229

Selecting Pivot Table Elements

➤ To select a facts column for formatting, layout or modification, click anywhere on the column of data values. Do not click on the label.

➤ To select a column of Row Labels or a row of Column Labels for formatting, layout, or analysis, click the dimension handle at the end of the column or row of labels.

By default, pivot handles are transparent. They only appear when you select a label from a top or side. When the pivot handle appears, it is shown in white with a light grey handle ( ). Once the selection is off, the pivot handle is transparent again.

➤ To select one complete row or column for formatting or analysis, press the modifier key Alt for Windows or Ctrl+Alt for Motif. Then, select the row or column label.

➤ To select an individual Column Label or Row Label for formatting, select the label itself.

Moving Pivot Table Elements

➤ To move a column to a new location in the Content pane, select the column in the Content pane and drag it to a new position.

➤ To remove Request items from the data layout or columns from the Content pane, select the element and select Pivot > Remove Selected Item.

Note:

When you delete a Request item from the data layout or a column from the Content pane, you cannot use the Undo feature to reinsert the column or Request item.
To move a pivot element item using the data layout, select the item name in the data layout pane, drag the item to a new position or to another data layout pane.

The display updates to reflect the repositioning or reassignment of the item.

Note:

To move items between Column Labels or Row Labels panes and the Fact pane (or vice versa), you must first remove them from the data layout, and then add them again to the chosen pane.

**Changing Label Nesting Levels**

In pivot tables, labels from one dimension frequently are nested within another dimension. Nesting means that one set of labels is displayed as a subdivision of labels at a higher layer of data. You can change the way labels nest to emphasize different relationships.

For example, you can show Year and Quarter as data items in the Column Labels pane in the data layout. The Quarter labels (Q1, Q2, Q3, and Q4) are nested within each year label (1998, 1999). If you move Year after Quarter, each year is displayed as a subset of each quarter. Q1 values are broken down by labels 1998, and 1999.

To change the nested level of labels:

1. With more than one data item in an data layout pane, select a data item.
2. Drag that item to the other side of the second data item in the same pane in the data layout.

The labels in those dimensions switch positions and the data is nested in a different manner.

**Sorting Pivot Tables**

Sorting facts or dimensions enables you to display objects in ascending and descending order according to value.

To sort plotted values and labels:

1. If the Sort line is not visible, click Sort on the Section title bar.
2. In the Sort list, select an item to use as the basis of your sort.
3. In the By drop-down list box, click the sort type (either a label or value).
4. In the Using drop-down list box, select the method of calculation for a data value.

   By default Interactive Reporting plots data in ascending order. To sort in descending order, click the descending icon.
**Hiding Pivot Facts**

You can restrict the data displayed in Pivot fact columns using the Hidden Items feature. When you select this feature, the fact column is removed from the report, but not the data layout. You can restore the hidden data item at any time.

- To hide a fact column, select one or more fact column names in the Facts data layout pane and choose *Hide Items* from the shortcut menu.
  
  The fact column name is dimmed in the data layout.

- To restore a hidden fact column, select the dimmed column in the Facts data layout pane and choose *Show Hidden Items* from the shortcut menu.

**Formatting Pivot Items**

The following table lists common formatting techniques that you can use when working with pivot tables.

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Font</td>
<td>To modify the font of an item in a pivot table, select the item and click <em>Font</em> on the Format menu or shortcut menu. When the Font tab of the Properties dialog box is displayed, apply any desired changes.</td>
</tr>
<tr>
<td>Style</td>
<td>To modify the appearance of an item in a pivot table, select the item and click <em>Style</em> on the Format menu or shortcut menu, and select the style. Styles include: bold, underline, italic formats, and so on.</td>
</tr>
<tr>
<td>Number</td>
<td>To modify the way numbers, dates, and currency are displayed in a pivot table, select the item and click <em>Number</em> on the Format menu or shortcut menu. When the Number tab of the Properties dialog box is displayed, apply any desired changes.</td>
</tr>
<tr>
<td>Justify</td>
<td>To modify the way an item is justified within a row or column in a pivot table, select an item, click <em>Justify</em> on the Format or shortcut menu. Select the type of justification.</td>
</tr>
</tbody>
</table>

**Pivot Section Aggregation and Surface Values**

This section describes how the Pivot section aggregates and displays data from underlying Table or Results sections. It also discusses the influence of the "Surface Values" property on any final displayed results.

There are three key component parts of the Pivot section display including: Detail Fact cells, Break Total cells and Computed Items cells. The behavior of these component parts is discussed in various typical Pivot usage scenarios.
## Fact Detail Cells

A Fact detail cell is the core numeric data that you slice and dice dimensionally in your analysis. A variety of components affect how Fact detail cells behave and what sort of information you see when analyzing them.

Review the following:

- **Results/Table Section and Pivot Section**
- **Aggregation Data Functions**
- **Break Totals**
- **Computed Items**
- **Surface Values**
- **Pivot Section Levels**

### Results/Table Section and Pivot Section

Fact detail cells are derived from the data set that you retrieve from your database and can be analyzed in both the Results and Pivot section. The Results section is a flat representation of raw, un-aggregated data from a database or external data source as shown below. This example shows sample Sales data for several Cities in the USA.

<table>
<thead>
<tr>
<th>City</th>
<th>Units Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Los Angeles</td>
<td>500</td>
</tr>
<tr>
<td>2. Los Angeles</td>
<td>400</td>
</tr>
<tr>
<td>3. Los Angeles</td>
<td>100</td>
</tr>
<tr>
<td>4. Los Angeles</td>
<td>100</td>
</tr>
<tr>
<td>5. Miami</td>
<td>300</td>
</tr>
<tr>
<td>6. Miami</td>
<td>200</td>
</tr>
<tr>
<td>7. Miami</td>
<td>100</td>
</tr>
<tr>
<td>8. Seattle</td>
<td>250</td>
</tr>
<tr>
<td>9. Seattle</td>
<td>50</td>
</tr>
<tr>
<td>10. Tacoma</td>
<td>100</td>
</tr>
</tbody>
</table>

A Pivot section is a flexible tabular display of aggregated data in Interactive Reporting that receives its source of data from either a Results or Table section. As an example, the same Table section City/Units Sold data from above can be converted to a simple Pivot section as shown below.

In the Pivot section, the Units Sold data has been aggregated; that is, there is only one occurrence of each City name shown in the Pivot section Row Labels. The Units Sold data for each City has been summed from the entries in the Table section above to show a single value for each City - these are the Pivot section Detail Facts.
**Aggregation Data Functions**

The method by which the underlying Table section values are aggregated/collection into Pivot section Facts can be varied by a user. As a default, the aggregation method is to sum the data (as shown in the Pivot example above); that is, the underlying Fact values are added together and the sum displayed as the Pivot Detail Fact cell value. There are several other aggregation Data Functions that can be applied to a Pivot Detail cell.

An aggregation Data Function can be applied to all Pivot Fact cells across a row or to the Fact cells down a column.

**Break Totals**

A Break Total is a user-enabled Pivot section row that can display summarized Fact information at the change of a level of Row Label information.

For example, in the above Pivot section, to see the sum of Unit Sales for all Cities, add a "Sum" Break Total line at the end of the City Row Label level as shown below:

<table>
<thead>
<tr>
<th>Units Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Los Angeles, 1,100</td>
</tr>
<tr>
<td>Miami, 600</td>
</tr>
<tr>
<td>Seattle, 300</td>
</tr>
<tr>
<td>Tacoma, 100</td>
</tr>
<tr>
<td>Total, 2,100</td>
</tr>
</tbody>
</table>

If you intend to use Break Totals in your Pivot section, be sure to enable surface values instead of using the underlying table data. In this way, Break Totals reflects the aggregation of displayed detail data.

If you use the “Add Totals” menu option to add a Break Total, the Break Total preserves any data function applied to a Fact Column.

**Computed Items**

A computed item is a user-created column of Fact data in a Pivot section that performs a user-specified calculation using fact data. As an example, below, a Computed Item column has been created to show the "Units Sold" fact amounts multiplied by 2. Each computed item column cell performs its calculations on the data that is used to create the corresponding cells of the fact column on which it is based:
Surface Values

Surface Values enable you to aggregate and calculate Pivot section data based on data displayed in the Pivot section as opposed to data from the underlying Results or Table section.

Pivot Section Levels

Pivot sections can contain multiple levels of Row Label and/or Column Label aggregations. As an example, a State level could be added to the Row Labels of the Pivot section shown above as follows:

Pivot Fact Detail Cell Behavior

See below for information on pivot fact detail cell behavior.

- Simple Pivot Section With Detail Cell Values Only (No Break Totals)—Surface Values Disabled
- Simple Pivot Section With Detail Cell Values Only (No Break Totals)—Surface Values Enabled
- Regular Break Total Line—Surface Values Disabled
- Regular Break Total Line—Surface Values Enabled
- Explicitly Specifying an Aggregation Data Function Across an Entire Break Total Row

Simple Pivot Section With Detail Cell Values Only (No Break Totals)—Surface Values Disabled

The example below shows a simple Pivot section with detail cell values only (no break totals and surface values have been disabled). (Unless otherwise specified, this Table section is used as the source data for Pivot section examples shown throughout this appendix.)
Review the Table section below that shows values of "Units Sold" for some sample cities in the USA. The visible Fact values for each City in the Pivot section are equivalent to the sum of each City's individual constituent "Units Sold" values in the underlying Table section.

In other words the Row Label of Los Angeles and the Pivot-displayed "Units Sold" value of 1,100 have been evaluated by summing each "Units Sold" value for Los Angeles in the underlying Table section (i.e. 500 + 400 + 100 + 100 = 1,100).

In addition to the sum method for aggregation in the Pivot section, you can explicitly specify a number of other aggregation methods, or Data Functions, in which to collect and represent the underlying Table section data as Facts in the Pivot section. These Data Functions include:

- **Average**—The displayed Pivot Fact value is the average (mean) value of the Fact values for this Pivot Row Label in the underlying Table section (i.e. the sum of the corresponding values in the Table section divided by the number of occurrences (rows) of these values).

- **Count**—The displayed Pivot Fact value is the sum of the number of occurrences of Fact values for this Row Label in the underlying Table section.

- **Maximum**—The displayed Pivot Fact value is the maximum value of all Fact occurrences in the underlying Table section for this Row Label.
- **Minimum**—The displayed Pivot Fact value is the minimum value of all Fact occurrences in the underlying Table section for this Row Label.

The effect of applying the above different aggregation Data Functions on Pivot Fact columns can be illustrated in the following Pivot section:

<table>
<thead>
<tr>
<th>Month</th>
<th>Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Jan</td>
</tr>
<tr>
<td>2</td>
<td>Feb</td>
</tr>
<tr>
<td>3</td>
<td>Mar</td>
</tr>
<tr>
<td>4</td>
<td>Apr</td>
</tr>
<tr>
<td>5</td>
<td>May</td>
</tr>
<tr>
<td>6</td>
<td>Jun</td>
</tr>
<tr>
<td>7</td>
<td>Jul</td>
</tr>
<tr>
<td>8</td>
<td>Aug</td>
</tr>
<tr>
<td>9</td>
<td>Sep</td>
</tr>
<tr>
<td>10</td>
<td>Oct</td>
</tr>
<tr>
<td>11</td>
<td>Nov</td>
</tr>
<tr>
<td>12</td>
<td>Dec</td>
</tr>
</tbody>
</table>

The "Units Sold" Fact column is evaluated using a Sum Data Function as above, whereas the "Average Of Units Sold" column uses the Average aggregation Data Function.

That is, the "Average Of Units Sold" Fact value for Los Angeles is evaluated according to the following formula:

The Sum of "Units Sold" values for Los Angeles in the underlying Table section divided by the number of occurrences (rows) of "Units Sold" values for Los Angeles in the underlying Table section

or

\[
(500 + 400 + 100 + 100) / 4 = 1100/4 = 275
\]

The "Count Of Units Sold" value for Los Angeles is 4, which is evaluated by using the Count aggregation Data Function. It is equal to the count or number of individual "Units Sold" row occurrences for Los Angeles in the underlying Table section

The "Max Of Units Sold" for Los Angeles is 500, which is evaluated using the Maximum aggregation Data Function. This function returns the maximum single "Units Sold" value from all "Units Sold" values for Los Angeles in the underlying Table section.

The "Min Of Units Sold" for Los Angeles is 100, which is evaluated using the Minimum aggregation Data Function. This returns the minimum single "Units Sold" value from all "Units Sold" values for Los Angeles in the underlying Table section.
Simple Pivot Section With Detail Cell Values Only (No Break Totals)—Surface Values Enabled

If you enable the "Surface Values" property (by selecting Use Surface Values from the Pivot Option dialog. “Selecting Pivot Table Elements” on page 227) the Pivot section display from above changes to:

<table>
<thead>
<tr>
<th>Month</th>
<th>Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan</td>
<td>10</td>
</tr>
<tr>
<td>Feb</td>
<td>15</td>
</tr>
<tr>
<td>Mar</td>
<td>17</td>
</tr>
<tr>
<td>Apr</td>
<td>20</td>
</tr>
<tr>
<td>May</td>
<td>22</td>
</tr>
<tr>
<td>Jun</td>
<td>20</td>
</tr>
<tr>
<td>Jul</td>
<td>25</td>
</tr>
<tr>
<td>Aug</td>
<td>27</td>
</tr>
<tr>
<td>Sep</td>
<td>30</td>
</tr>
<tr>
<td>Oct</td>
<td>35</td>
</tr>
<tr>
<td>Nov</td>
<td>37</td>
</tr>
<tr>
<td>Dec</td>
<td>40</td>
</tr>
</tbody>
</table>

The Fact columns have now been recalculated to use what would be a displayed (i.e. surface) summed, aggregated value for each City as a source of input data (i.e. the values that are actually displayed in the "Units Sold" column).

As a result, the "Average Of Units Sold" for Seattle references the sum of underlying "Units Sold" values for Seattle (that is, the same value that is displayed for Seattle in the "Units Sold" column). This value is 300 and there is only one value occurrence displayed for Seattle. Consequently, the "Average Of Units Sold for Seattle" is 300 divided by 1 which is 300.

Likewise, the "Count Of Units Sold" column uses the displayed "Units Sold" value for each City as a basis for calculation. Since there is always only one displayed value per City, the "Count Of Units Sold" for each City always has a value of 1.

The "Maximum Of Units Sold" and "Minimum Of Units Sold" column cell values are exactly the same as their equivalent cells in the "Units Sold" column. Since there is only one cell value available per City, by definition that value is always the Maximum or Minimum value available. Since the lowest level of data displayed in a Pivot section is always aggregated from the underlying Table section values, it is recommended that you disable surface values when applying a sum or other data function.

Regular Break Total Line—Surface Values Disabled

At any time, a "regular" Break Total line can be added to a Pivot section by selecting "Add Totals" from the Row Labels right-click speed menu (or the Pivot menu in the Section toolbar).

When a Break Total row is added, it is labeled "Total" as shown below:
Notice that, the regular Break Total row performs aggregation of each Break Total cell value from the underlying Table section data by using the aggregation Data Function that has been specified for that Fact column.

For example, the "Average Of Units Sold" Fact column Break Total cell has a value of 2100. This value has been evaluated by using the Average Data Function (which is the Data Function that has been specified already for that column) on the underlying Table section data. The equation is:

Sum all "Units Sold" values for all Cities in the underlying Table section and divide by the total number of occurrences of those values.

or

\[
\frac{(500 + 400 + 100 + 100 + 300 + 200 + 100 + 250 + 50 + 100)}{10} = \frac{2100}{10} = 210
\]

Likewise, The "Count Of Units Sold" Break Total value refers to the underlying Table section values and returns the total number of occurrences of "Units Sold" values there for all Cities. This amount equals 10.

The "Max Of Units Sold" Break Total value refers to the underlying Table section and returns the single maximum "Units Sold" amount for all Cities. This amount equals 500.

The "Min Of Units Sold" Break Total value refers to the underlying Table section and returns the single minimum "Units Sold" amount for all Cities. This amount equals 50.

### Regular Break Total Line—Surface Values Enabled

If the Surface Value property is enabled, the previous Pivot section, with regular Break Total line, is displayed as:

<table>
<thead>
<tr>
<th></th>
<th>Units Sold</th>
<th>Average Of Units Sold</th>
<th>Count Of Units Sold</th>
<th>Max Of Units Sold</th>
<th>Min Of Units Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Los Angeles</td>
<td>1,100</td>
<td>1,100</td>
<td>1</td>
<td>1,100</td>
<td>1,100</td>
</tr>
<tr>
<td>Miami</td>
<td>600</td>
<td>600</td>
<td>1</td>
<td>600</td>
<td>600</td>
</tr>
<tr>
<td>Seattle</td>
<td>300</td>
<td>300</td>
<td>1</td>
<td>300</td>
<td>300</td>
</tr>
<tr>
<td>Tacoma</td>
<td>100</td>
<td>100</td>
<td>1</td>
<td>100</td>
<td>100</td>
</tr>
<tr>
<td>Total</td>
<td>2,100</td>
<td>525</td>
<td>4</td>
<td>1,100</td>
<td>100</td>
</tr>
</tbody>
</table>

All cell values for each column in the Break Total line have been updated to show the aggregation of all Fact values that are displayed in that column using the aggregation data function specified for that column.
The Break Total value for the “Units Sold” column is shown to be 2100 which is the sum (i.e. the aggregation data function used for that column) of all displayed Fact detail cell values in the column (this value, 2100, happens to be the same as the value shown when surface values were disabled and the underlying Table section values were used, because of the mathematical nature of a sum operation).

For the “Average Of Units Sold” column – the Average aggregation data Function is used for the Fact detail cells. As a result, this same data function is used to evaluate the Break Total cell value. The value of 525 is evaluated to be the sum of the displayed fact detail cells (= 2,100 = 1,100 + 600 + 300 + 100) divided by the number of occurrences of displayed fact detail cell values (4).

The “Count Of Units Sold” column uses the Count data function. As a result the Break Total value uses the Count data function operating against the number of occurrences of displayed Fact detail cells. Since there are four fact detail cell values in this column, the Break Total value is 4.

The “Max Of Units Sold” column uses the Maximum data function. As a result the Break Total value uses the Maximum data function to evaluate the largest number within the displayed Fact detail cells. This number is 1,100 which is the value displayed in the Break Total cell for this column.

The “Min Of Units Sold” column uses the Minimum data function. As a result, the Break Total value uses the Minimum data function to evaluate the largest number within the displayed Fact detail cells. This number is 1,100 which is the value displayed in the Break Total cell for this column.

Explicitly Specifying an Aggregation Data Function Across an Entire Break Total Row

With a regular Break Total line, as described above, the aggregation Data Function that is applied to each Break Total cell is the aggregation Data Function that is already applied to each Fact column.

However, you can explicitly specify an aggregation data function to apply to all cells on a Break Total row. To do this, select the entire Break Total row (by pressing the Alt and mouse left-click buttons simultaneously) and select the appropriate data function from the mouse right-click speed menu or the Pivot menu.

As an example, the row entitled “Total – Average” below, is a regular Break Total line which has had the Average aggregation Data Function explicitly applied to all of its cells (the row entitled “Total” is the regular Break Total row from above):

<table>
<thead>
<tr>
<th>Units Sold</th>
<th>Average Of Units Sold</th>
<th>Count Of Units Sold</th>
<th>Max Of Units Sold</th>
<th>Min Of Units Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Los Angeles</td>
<td>1,100</td>
<td>275</td>
<td>4</td>
<td>500</td>
</tr>
<tr>
<td>Miami</td>
<td>600</td>
<td>200</td>
<td>3</td>
<td>300</td>
</tr>
<tr>
<td>Seattle</td>
<td>300</td>
<td>150</td>
<td>2</td>
<td>250</td>
</tr>
<tr>
<td>Tacoma</td>
<td>100</td>
<td>100</td>
<td>1</td>
<td>100</td>
</tr>
<tr>
<td>Total</td>
<td>2,100</td>
<td>210</td>
<td>10</td>
<td>500</td>
</tr>
<tr>
<td>Total - Average</td>
<td>210</td>
<td>210</td>
<td>210</td>
<td>210</td>
</tr>
</tbody>
</table>
The "Total - Average" calculates the average value of "Units Sold" from the underlying Table section for all cells, that is, the Total - Average is the aggregated sum of all underlying "Units Sold" values divided by the number of occurrences of "Units Sold" values.

You can see how this concept works across all cells on a Break Total row by reviewing the example below. This example Break Total rows named "Total Sum", "Total - Count", "Total - Max", "Total - Min" which have the Sum, Count, Maximum and Minimum Data Functions respectively forced across their rows:

<table>
<thead>
<tr>
<th>Units Sold</th>
<th>Average Of Units Sold</th>
<th>Count Of Units Sold</th>
<th>Max Of Units Sold</th>
<th>Min Of Units Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Los Angeles</td>
<td>1,100</td>
<td>275</td>
<td>4</td>
<td>500</td>
</tr>
<tr>
<td>Miami</td>
<td>800</td>
<td>200</td>
<td>3</td>
<td>300</td>
</tr>
<tr>
<td>Seattle</td>
<td>300</td>
<td>150</td>
<td>2</td>
<td>250</td>
</tr>
<tr>
<td>Tacoma</td>
<td>100</td>
<td>100</td>
<td>1</td>
<td>100</td>
</tr>
<tr>
<td>Total</td>
<td>2,100</td>
<td>210</td>
<td>10</td>
<td>500</td>
</tr>
<tr>
<td>Total - Sum</td>
<td>2,100</td>
<td>2,100</td>
<td>2,100</td>
<td>2,100</td>
</tr>
<tr>
<td>Total - Average</td>
<td>210</td>
<td>210</td>
<td>210</td>
<td>210</td>
</tr>
<tr>
<td>Total - Count</td>
<td>10</td>
<td>10</td>
<td>10</td>
<td></td>
</tr>
<tr>
<td>Total - Max</td>
<td>500</td>
<td>500</td>
<td>500</td>
<td>500</td>
</tr>
<tr>
<td>Total - Min</td>
<td>50</td>
<td>50</td>
<td>50</td>
<td>50</td>
</tr>
</tbody>
</table>

You can override any cell in a Break Total row which has a forced data function. To override the Break Total Data Function, select the Fact cell in that column and the required data function. As an example, the "Count Of Units Sold" column from above has been selected and the Count data function has been explicitly assigned to this column. The resulting Pivot display is nearly identical to the example above except the entire "Count Of Units Sold" column has its Fact Detail and Break Total cells evaluated by the Count data function as described above:

<table>
<thead>
<tr>
<th>Units Sold</th>
<th>Average Of Units Sold</th>
<th>Count Of Units Sold</th>
<th>Max Of Units Sold</th>
<th>Min Of Units Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Los Angeles</td>
<td>1,100</td>
<td>275</td>
<td>4</td>
<td>500</td>
</tr>
<tr>
<td>Miami</td>
<td>800</td>
<td>200</td>
<td>3</td>
<td>300</td>
</tr>
<tr>
<td>Seattle</td>
<td>300</td>
<td>150</td>
<td>2</td>
<td>250</td>
</tr>
<tr>
<td>Tacoma</td>
<td>100</td>
<td>100</td>
<td>1</td>
<td>100</td>
</tr>
<tr>
<td>Total</td>
<td>2,100</td>
<td>210</td>
<td>10</td>
<td>500</td>
</tr>
<tr>
<td>Total - Sum</td>
<td>2,100</td>
<td>2,100</td>
<td>2,100</td>
<td>2,100</td>
</tr>
<tr>
<td>Total - Average</td>
<td>210</td>
<td>210</td>
<td>210</td>
<td>210</td>
</tr>
<tr>
<td>Total - Count</td>
<td>10</td>
<td>10</td>
<td>10</td>
<td></td>
</tr>
<tr>
<td>Total - Max</td>
<td>500</td>
<td>500</td>
<td>500</td>
<td>500</td>
</tr>
<tr>
<td>Total - Min</td>
<td>50</td>
<td>50</td>
<td>50</td>
<td>50</td>
</tr>
</tbody>
</table>

**Pivot Section Computed Items**

Computed items, are Fact columns that are created by the user and which use table data (or displayed Pivot data if Surface Values are enabled) as a basis for calculation. Each Pivot computed item is represented as a new Fact column in the Pivot display and Interactive Reporting provides a multitude of built-in data manipulation and evaluation functions for the user that facilitate the construction of computed item columns.
Here are some key points to remember when working with computed items in the Pivot section:

- To ensure consistency, the source of data for computed items should be governed by the type of computed item function rather than being governed "globally" by the Surface Values property.
- Computed Item functions that operate on aggregated data such as "Avg" and "ColMax" should always receive their input data from the underlying Results or Table data.
- Computed Item functions that expect a single value as input, such as Sqrt, should receive their data from the displayed surface values.
- Computed Items that refer directly to other Pivot section columns without wrapping in a Function reference (such as "Units Sold * 2" above, should receive this data always from displayed surface values.

**Computed Item Detail Cell Values**

A very simple computed item can be created using a Label dimension and the values from the Fact Detail cells. As an example of computed item display, consider the original simple "Units Sold" Pivot display below:

<table>
<thead>
<tr>
<th>Units Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Los Angeles</td>
</tr>
<tr>
<td>Miami</td>
</tr>
<tr>
<td>Seattle</td>
</tr>
<tr>
<td>Tacoma</td>
</tr>
</tbody>
</table>

Several computed item columns can be added to this Pivot using the "Units Sold" Facts as a source of input data. These computed items are shown below as new columns to the right of the "Units Sold" column (surface values have been disabled in this example):

<table>
<thead>
<tr>
<th>Units Sold</th>
<th>Units Sold * 2</th>
<th>Sqrt Units Sold</th>
<th>ColMax Units Sold</th>
<th>Average Units Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Los Angeles</td>
<td>1,100</td>
<td>2,200</td>
<td>33.16625</td>
<td>500</td>
</tr>
<tr>
<td>Miami</td>
<td>600</td>
<td>1,200</td>
<td>24.4949</td>
<td>600</td>
</tr>
<tr>
<td>Seattle</td>
<td>300</td>
<td>600</td>
<td>17.32051</td>
<td>500</td>
</tr>
<tr>
<td>Tacoma</td>
<td>100</td>
<td>200</td>
<td>10</td>
<td>500</td>
</tr>
</tbody>
</table>

These new Computed Item columns are evaluated as follows:

- Units Sold * 2 = Units Sold values multiplied by 2 (i.e. computed item calculation: formula is: Units_Sold * 2)
- Sqrt Units Sold = Square root of Units Sold values (i.e. computed item calculation formula: Sqrt (Units_Sold) )
- ColMax Units Sold = Maximum value of Units Sold in a column (i.e. computed item calculation formula: ColMax (Units_Sold) )
- Average Units Sold = Average value of Units Sold (i.e. computed item calculation formula: Avg (Units_Sold) )
**Computed Item Detail Cell Values—Without Surface Values**

In general, when surface values are disabled, computed item columns receive their source "Units Sold". Fact values from the underlying Table section. However, the specific values from the underlying Table section that the computed item uses depends on the nature of the its calculation.

A calculation or computed item function that expects a single value as input uses the underlying values that correspond to the Pivot computed item column cell to be calculated, aggregated according to the aggregation data function applied to the computed item column.

In the previous example, the "Units Sold * 2" column implicitly requires a single cell value. If it is used in a computed item column with an aggregation data function of Sum, all underlying Table section values corresponding to this Pivot cell are summed and multiplied by 2.

If you review the "Units * 2" value for Los Angeles, you see that it is evaluated by summing the underlying Table occurrences for Los Angeles and multiplying this sum by 2.

The ColMax computed item function operates on a range of data as opposed to a single value. The Avg computed item function operates on the summed, aggregated values corresponding to a Pivot cell. In the case of Los Angeles, this would be the sum of underlying values for Los Angeles divided by the number of occurrences of these values.

This behavior can be most easily seen from the "ColMax Units Sold" column which shows a value of 500 for each cell. The ColMax function interrogates the range of values in an entire column and returns the maximum value found: 500. This is the maximum cell value in the entire "Units Sold" column in the underlying Table section (compared to 1,100 which is the maximum "Units Sold" value shown in the Pivot display).

**Computed Item Detail Values—With Surface Values Enabled**

Compare the above Pivot section display with the following example. In this example, surface values have been enabled.

<table>
<thead>
<tr>
<th></th>
<th>Units Sold</th>
<th>Units Sold * 2</th>
<th>Sum Units Sold</th>
<th>ColMax Units Sold</th>
<th>Average Units Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Los Angeles</td>
<td>1,100</td>
<td>2,200</td>
<td>33,16625</td>
<td>1,100</td>
<td>525</td>
</tr>
<tr>
<td>Miami</td>
<td>600</td>
<td>1,200</td>
<td>24,4949</td>
<td>1,100</td>
<td>525</td>
</tr>
<tr>
<td>Seattle</td>
<td>300</td>
<td>600</td>
<td>17,32061</td>
<td>1,100</td>
<td>525</td>
</tr>
<tr>
<td>Tacoma</td>
<td>100</td>
<td>200</td>
<td>10</td>
<td>1,100</td>
<td>525</td>
</tr>
</tbody>
</table>

As you can see, the "ColMax Units Sold" and "Average Units Sold" Fact columns values have changed. With surface values enabled, the ColMax function refers to the displayed "Units Sold" Fact column for input data and the highest value in this column is 1,100 which is the value that is displayed in the "ColMax Units Sold" column above.

The Avg Computed Item function which is used to evaluate the "Average Units Sold" column takes its input from the sum of the displayed "Units Sold" Fact column values and divides this by the number of displayed occurrences of values in the "Units Sold" column - this is 2100/4 which equals 525 - the value displayed in the "Average Units Sold" column.
In general when you enable surface values for Pivot section computed items, they operate on the summed, aggregated values from the underlying Table section.

**Computed Items With Break Totals—No Surface Values**

If a Break Total row is added to the Pivot by using the "Add Totals" menu item described above, the following Pivot display results:

<table>
<thead>
<tr>
<th></th>
<th>Units Sold</th>
<th>Units Sold * 2</th>
<th>Sqrt Units Sold</th>
<th>ColMax Units Sold</th>
<th>Average Units Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Los Angeles</td>
<td>1,100</td>
<td>2,200</td>
<td>33.16625</td>
<td>500</td>
<td>210</td>
</tr>
<tr>
<td>Miami</td>
<td>600</td>
<td>1,200</td>
<td>24.4949</td>
<td>500</td>
<td>210</td>
</tr>
<tr>
<td>Seattle</td>
<td>300</td>
<td>600</td>
<td>17.32051</td>
<td>500</td>
<td>210</td>
</tr>
<tr>
<td>Tacoma</td>
<td>100</td>
<td>200</td>
<td>10</td>
<td>500</td>
<td>210</td>
</tr>
<tr>
<td>Total</td>
<td>2,100</td>
<td>4,200</td>
<td>45.82576</td>
<td>500</td>
<td>210</td>
</tr>
</tbody>
</table>

Since the surface values have been disabled, the values in the Break Total ("Total") cells for each Computed Item column are evaluated by applying the computed item calculation formula to the underlying aggregated Table section "Units Sold" values summed for all Cities.

**Computed Items With Break Totals—Surface Values Enabled**

If a Break Total row is added to the Pivot by using the "Add Totals" menu and surface values are enabled, the following Pivot display results:

<table>
<thead>
<tr>
<th></th>
<th>Units Sold</th>
<th>Units Sold * 2</th>
<th>Sqrt Units Sold</th>
<th>ColMax Units Sold</th>
<th>Average Units Sold</th>
</tr>
</thead>
<tbody>
<tr>
<td>Los Angeles</td>
<td>1,100</td>
<td>2,200</td>
<td>33.16625</td>
<td>1,100</td>
<td>525</td>
</tr>
<tr>
<td>Miami</td>
<td>600</td>
<td>1,200</td>
<td>24.4949</td>
<td>1,100</td>
<td>525</td>
</tr>
<tr>
<td>Seattle</td>
<td>300</td>
<td>600</td>
<td>17.32051</td>
<td>1,100</td>
<td>525</td>
</tr>
<tr>
<td>Tacoma</td>
<td>100</td>
<td>200</td>
<td>10</td>
<td>1,100</td>
<td>525</td>
</tr>
<tr>
<td>Total</td>
<td>2,100</td>
<td>4,200</td>
<td>45.82576</td>
<td>1,100</td>
<td>525</td>
</tr>
</tbody>
</table>

With surface values enabled, the various Break Total cell values are evaluated using the displayed values of the "Units Sold" Fact column. For example, the "ColMax Units Sold" total line value has changed (from 500) to 1,100 since the maximum value displayed in the "Units Sold" column is 1,100. The "Average Units Sold" total line value has changed (from 210) to 525 since the displayed sum of "Units Sold" is 2,100 and the displayed number of Cities is 4 - leading to an average calculation of 2,100/4 = 525.

In either case, whether surface values are enabled or disabled, the computed item Break Total values are calculated by applying the computed item calculation on the Break Total value for the column on which the computed item calculation is based.

There exists no facility whereby computed item Break Totals are evaluated by summing (or some other aggregate data function) its constituent displayed Detail cell values. If such a facility were to exist, the "Total" cell for the "ColMax Units Sold" column above would be 4,400 (= 1,100 + 1,100 + 1,100 + 1,100) i.e. the sum of all Detail Fact values in this column.
# Pivot Menu Command Reference

The following table provides a quick reference to the commands available on the Pivot menu and lists any related shortcuts.

<table>
<thead>
<tr>
<th>Table 57</th>
<th>Pivot Menu Commands</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Command</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Add Selected Items</td>
<td>Adds the selected item as a Column Label, Row Label, or Fact.</td>
</tr>
<tr>
<td>Remove Selected Items</td>
<td>Removes the selected item.</td>
</tr>
<tr>
<td>Modify</td>
<td>Modifies the selected computed item.</td>
</tr>
<tr>
<td>Sort</td>
<td>Reorders the selected item by labels, by values, ascending, or descending.</td>
</tr>
<tr>
<td>Add Totals</td>
<td>Adds the selected item to the Measures pane.</td>
</tr>
<tr>
<td>Add Computed Item</td>
<td>Adds a new data item derived from calculations performed on an item.</td>
</tr>
<tr>
<td>Add Cume</td>
<td>Adds cumulative totals to break totals by dimension and restarts them at each dimensional grouping.</td>
</tr>
<tr>
<td>Data Function</td>
<td>Applies a prebuilt data function to the selected item.</td>
</tr>
<tr>
<td>Drill Anywhere</td>
<td>Enables you to drill to any item.</td>
</tr>
<tr>
<td>Drillup</td>
<td>Returns the original view of data that you drilled.</td>
</tr>
<tr>
<td>Focus On Items</td>
<td>Updates the pivot table to include only the selected data.</td>
</tr>
<tr>
<td>Hide Items</td>
<td>Hides the selected item.</td>
</tr>
<tr>
<td>Show Hidden Items</td>
<td>Restores the selected hidden item.</td>
</tr>
<tr>
<td>Show All Items</td>
<td>Updates the pivot table to include all items.</td>
</tr>
<tr>
<td>Group Items</td>
<td>Groups the selected dimensions.</td>
</tr>
<tr>
<td>Ungroup Items</td>
<td>Ungroups the selected dimension.</td>
</tr>
<tr>
<td>Restore Name</td>
<td>Restores the original name of a renamed item.</td>
</tr>
<tr>
<td>Refresh Data</td>
<td>Updates the data according to the selected option. Select between After Process, When Section Displayed, Manually, or Refresh Now.</td>
</tr>
<tr>
<td>Pivot Options</td>
<td>Enable surface values, true computed totals, and null facts in computed items.</td>
</tr>
</tbody>
</table>
Charting Data

In This Chapter

Chart Section.................................................................243
Charting Basics.............................................................243
Chart Terminology..........................................................244
Understanding Chart Dimensions........................................245
Creating Charts..............................................................246
Selecting a Chart Type....................................................247
Working with Two-dimensional Charts.................................247
Working with Multidimensional Charts...............................255
Manipulating Chart Data....................................................263
Changing Angle and Elevation (Rotating)............................269
Working with Chart Elements..............................................270
Chart Scrolling and Scaling.................................................273
Customizing Chart Properties..............................................278
Chart Menu Command Reference.........................................288
Vertical Bar Charts.........................................................288
Horizontal Bar Charts......................................................289

Chart Section

The Chart section enables you to see meaningful summaries of your data. Graphic snapshots help you recognize patterns, trends, and other relationships that might not be apparent in columns and rows of tabular data.

The Chart section opens with an initial plot area for the chart. Because chart construction and manipulation is managed with the data layout, plotting, viewing, and reviewing are easy and intuitive. Charts respond dynamically to your commands. When you make a change in a charted item, you see your chart instantly redrawn to reflect the change. Experimenting with different combinations of data can be surprisingly informative.

Charting Basics

A chart is a graphic representation of data. Except for pie charts, all charts plot data with reference to a horizontal x axis and vertical y axis. Multidimensional charts sometimes plot data on an
additional axis. A pie chart uses the metaphor of the pie as a whole to delineate the relative values of the parts or slices.

You construct a chart by dragging Request items from the Catalog pane to one of the data layouts. At least one y axis item must populate an data layout to plot a usable chart.

**Chart Terminology**

The following table defines the chart terminology used in Interactive Reporting:

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Axes</td>
<td>Straight lines on a chart that provide a framework for measurement and reference. Typically, the x axis and z axis are used to display label items, and the y axis shows values or facts (measurable items), such as units and amounts.</td>
</tr>
<tr>
<td>Values</td>
<td>Graphic indicators that represent data. Bar charts display values in either vertical or horizontal bars. Pie charts use wedge-shaped slices to represent values.</td>
</tr>
<tr>
<td>Plot Area</td>
<td>The area bounded by the axes is called the plot area. In the case of the pie chart, the plot area is defined by a circle representing the totality of all data items.</td>
</tr>
<tr>
<td>Planes</td>
<td>In all charts (except pie charts), planes provide background and graphed reference for charted values. Planes define horizontal, vertical, and background fields for a chart.</td>
</tr>
<tr>
<td>Legend</td>
<td>An information box containing color-keyed labels used to identify different data values represented on a chart.</td>
</tr>
<tr>
<td>Grid lines</td>
<td>Straight horizontal and vertical lines arranged in scaled increments that provide calibrated guidelines for value interpretation.</td>
</tr>
<tr>
<td>Bar</td>
<td>A linear measure of a value used in bar charts.</td>
</tr>
<tr>
<td>Slice</td>
<td>A spacial measure of a value used in pie charts.</td>
</tr>
<tr>
<td>Chart top title</td>
<td>Text description related to the entire chart.</td>
</tr>
<tr>
<td>Chart subtitle</td>
<td>Additional text used to describe the chart.</td>
</tr>
<tr>
<td>Y axis label</td>
<td>Text description of the vertical quantity axis.</td>
</tr>
<tr>
<td>Y axis values</td>
<td>Text or numbers which indicate specific values along the y axis.</td>
</tr>
<tr>
<td>X axis label</td>
<td>Text description of the horizontal quantity axis.</td>
</tr>
<tr>
<td>X axis values</td>
<td>Text or numbers which indicate specific values along the x axis.</td>
</tr>
<tr>
<td>Z axis label</td>
<td>Text description of the depth axis.</td>
</tr>
<tr>
<td>Z axis values</td>
<td>Text or number which indicate specific values along the z axis.</td>
</tr>
<tr>
<td>Chart graphic</td>
<td>Central chart picture which contains Chart bars, background and also Chart axes.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>---------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Chart graphic border</td>
<td>Border which controls the position of the Chart’s central bars, background and axes labels. The border can be resized and repositioned.</td>
</tr>
<tr>
<td>Chart border</td>
<td>Border which controls the general position of all other Chart components not controlled by the Chart graphic border. This border can be resized and repositioned.</td>
</tr>
<tr>
<td>Inserted text string</td>
<td>Optional text strings that can be placed anywhere within the Chart border.</td>
</tr>
<tr>
<td>Right y axis label</td>
<td>Optional label that can be placed to the right of the right-hand vertical edge of the Chart graphic.</td>
</tr>
<tr>
<td>Right y axis values</td>
<td>Optional values that can be displayed on the right hand vertical edge of the Chart graphic</td>
</tr>
<tr>
<td>Bar value</td>
<td>Optional text which represents numeric value of the bar.</td>
</tr>
</tbody>
</table>

Table 59  Chart Terminology (Pie Specific)

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pie slice</td>
<td>Individual y axis value representation for current x axis item.</td>
</tr>
<tr>
<td>Pie slice label</td>
<td>Text to identify x axis item.</td>
</tr>
<tr>
<td>Line to label</td>
<td>Line from pie slice label to pie slice to aid in slice identification.</td>
</tr>
</tbody>
</table>

**Understanding Chart Dimensions**

To understand the differences among charts, you have to distinguish between dimensions in space and dimensions of data. The two dimensions are distinct. Space can be represented as three dimensions along the x, y, and z axes. Corresponding to the X, Y and Z axes in the Chart Area. Data can either be represented in a two-dimensional or a three-dimensional (2-D or 3-D) space. In two dimensions, data is represented along the x axis and y-axis only. In three dimensions, data is projected back along the z axis also. Two dimensions of data must be represented in 2-D space. At least three dimensions of data are necessary to use the third spatial dimension Stack, Cluster or Depth (z axis). But three or more dimensions of data can be represented in 2-D space. For example, cluster and stack represent data categories in two spatial dimensions (X axis and Y axis only).

**Using the Chart Data Layout**

The Chart section opens with an initial plot area for the chart. Because you manage chart construction and manipulation is with the Chart data layout plotting, viewing and reviewing are easy and intuitive.

You construct a chart by dragging items from the Catalog pane to a data layout pane. At least one items must populate the data layout to plot a usable chart.

The data layout consists of the following items:
## Table 60  Chart Data Layout

<table>
<thead>
<tr>
<th>Data Layout Pane</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>X Axis Slice</td>
<td>The X-Axis is used for those items to be placed on the x axis, which is a straight line on the chart. It is used as a qualitative data label for categorizing information. To place items on the x axis, use the X-Axis pane.</td>
</tr>
<tr>
<td>Stack Cluster Depth</td>
<td>The Stack Cluster or Depth pane represent the third dimension of data, that is, the z axis that projects out toward you or a location in space. This axis can either be qualitative or quantitative. For a <strong>Stack</strong> each dimension of data of the charts is represented by only one bar. This bar consists of as many components as the data file has data rows, with the data from each row stacked onto the previous row. For example, a single bar can represent the amount of sales for CD-ROM drives in one year on top of a bar representing sales for other years. You can stack the bar charts vertically or horizontally. By stacking items and assigning a different color to each item, you can display trends among comparable or related items, or emphasize visually a sum of several indicators. For a <strong>Cluster</strong>, data extended in the third dimension is shown as clusters displayed in the foreground. This category creates a vertical column (and only a vertical column) for each data value. If the chart is showing multiple data series, the values are grouped based upon the category value. For example, use clustered bars to compare stores of different types. Alternatively, cluster bars can be used to compare two different values items, such as Amount of Sales and Units Sold. For the <strong>Depth</strong>, data extends the length of the chart along the z-axis.</td>
</tr>
<tr>
<td>Fact (Stack) Fact (Depth)</td>
<td>The <strong>Facts</strong> category indicates height in the coordinate system. It is used as a quantitative label as a way of categorizing information on the y axis. For the <strong>Fact (Stack)</strong> pane each dimension of numeric data is represented by only one bar. and shows the grouping along the y axis. This bar consists of as many components as the data file has numeric rows, with the numeric data from each row stacked onto the previous row. For example, a single bar can represent the amount of sales for CD-ROM drives in one year on top of a bar representing sales for other years. You can stack the bar charts vertically or horizontally. By stacking items and assigning a different color to each item, you can display trends among comparable or related items, or emphasize visually a sum of several indicators. For the <strong>Fact (Depth)</strong> pane, numeric data extends the length of the chart along the z-axis.</td>
</tr>
</tbody>
</table>

## Creating Charts

Interactive Reporting charts consists of two layout elements: graphical elements (for example, chart bars or pie slices) and axis labels. When you assign Request items to the data layout, they become values or labels in your chart.

The instructions below are a starting point for building charts. As you use and become familiar with the Chart section, you learn ways to create the exact type of chart that fits your needs.

➤ To create a chart using the Chart data layout:

1. Select Insert > New Chart.
2. If the data layout is not visible, click Data Layout on the Section title bar.
3. Drag each line item from the Catalog pane to the data layout:
Drag values or facts (such as Units or Amount) into the y pane in the data layout to create bar charts, pie charts or ribbon charts.

Drag a label item (such as Name, Product, or State) into the x pane in the data layout to create a 2-D chart.

Drag a label item to the y pane in data layout to add a third dimension to your chart.

Select Format > Chart Type > [chart type].

Note:
You can select and drag multiple items to the same data layout to add multiple values or labels for analysis. Items are hierarchically ordered in the sequence in which they are displayed in the data layout.

Selecting a Chart Type

You can select a different chart type to show data in different views.

To select a chart type, select Format > Chart Type and choose a chart type from the sub-menu. Chart types include:

- Vertical Bar Charts
- Horizontal Bar Charts
- Understanding Stacked Bar Charts
- Understanding Clustered Bar Charts
- Using Pie Charts to Analyze Data
- Understanding Area Charts
- Understanding Line Charts
- Understanding Ribbon Charts
- Understanding Combination Charts
- Scatter Charts
- Bubble Charts

Working with Two-dimensional Charts

Pie and bar charts (of the non-stacked variety) lend themselves well to representing two dimensions of data. For example, imagine charting the amount of sales by product type. In pie charts, the two dimensions are represented by slices of a pie. In bar charts, the data is represented by bars along the x axis and y axis.

- “Using Pie Charts to Analyze Data” on page 248
- “Scatter Charts” on page 250
Using Pie Charts to Analyze Data

Of all charts, the pie chart is the easiest to understand. Pieces (slices) of the pie are drawn to represent the relative value of a measurable item category to the whole. Pie charts represent additional dimensions of data by further subdividing the pie.

In a Pie chart, Request items placed in the x axis represent itemized slices of the pie. Request items placed in the y pane of the data layout define the quantitative whole of the pie.

Creating a Pie Chart

To create a pie chart:

1. From the Chart drop-down list box, select Pie.
2. Drag a value from the Catalog pane to the y pane in the data layout.
   A Pie chart without slices is displayed.
3. Drag one or more label items from the Catalog pane to a data layout pane.
   The Pie chart is differentiated to reflect subcategories. A legend depicting details of the selection is displayed.

Note:
Since pie charts plot data using only two axes, the z pane is disabled in the Data Layout when creating a Pie chart.

Positioning Pie Slices
You can pull individual pie slices out of the pie chart.

To toggle the position of a pie slice, select a slice of the pie and choose Pull Out Slice on the shortcut menu.
A check mark is displayed on the shortcut menu next to Pull Out Slice to indicate that this feature is active. Select this option again to clear the check mark and restore the pie slice to its original position.

Showing Positive and Negative Values
Pie slices show positive values by default.
To toggle the display of negative and positive values, select a slice of the pie and select **Show Negative Values** on the shortcut menu.

A check mark is displayed next to **Show Negative Values** to indicate that negative values are shown. Select this option again to clear the check mark and show positive values.

**Showing Pie Percentages**

To toggle the display of each pie slice value as a percentage, select a slice of the pie and select **Show Pie Percentages** on the shortcut menu.

A check mark is displayed next to **Show Pie Percentages** to indicate that percentages are displayed on the chart (in parentheses next to the pie chart label). Select this option again to clear the check mark and remove the percentages from view.

**Adding Lines to Labels**

To add a pointer line between an individual pie slice and its label, select the pie slice and choose **Format > Line To Label**.

**Note:**

You cannot change a Chart label name when a Pie Chart contains 0 or null values. To add a label name in this case, filter out or hide the 0 or null values in the underlying Results or Pivot section.

**Rotating Pie Charts**

To rotate the perspective angle or elevation of a pie chart:

1. **Click Rotate on the shortcut menu.**
   
The rotate icon is displayed on the pie chart.

2. **Click the rotate icon and move the dotted line to a new location.**
   
When you release the mouse button, the chart is redrawn to reflect the adjusted perspective. If you cannot drag the rotate icon in a certain direction, the chart has reached its farthest possible rotation in that direction.
Showing the Pie Outline

➤ To show a border around the entire border of the pie, select Show Pie Outliner on the shortcut menu.

Scatter Charts

A scatter chart is useful for emphasizing scientific or statistical similarities rather than differences in your analysis. Scatter charts illustrate the relationship between pairs of numerical or quantitative values, which are combined into individual data points along the horizontal (y axis) and a vertical (x axis) axis. Data points are plotted in uneven intervals.

A scatter chart represents non-aggregated sources, that is, it retrieves data from the underlying Table/Reports section and does not reflect rolled up values (all other chart types retrieve their data from an aggregated source, and there is a one-to one correspondence between Charts and Pivots). For this reason, the Pivot This Chart feature is not available for a scatter chart.

To demonstrate how a scatter chart plots data, see the following two figures. If two data series consisting of tons per acre by degree of latitude are shown in an Excel worksheet, the data is displayed as:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>Degree of latitude</td>
<td>Tons per acre 95</td>
<td>Degree of latitude 98</td>
<td>Tons per acre 98</td>
</tr>
<tr>
<td>31</td>
<td>4750</td>
<td>31</td>
<td>5000</td>
</tr>
<tr>
<td>32</td>
<td>4800</td>
<td>32</td>
<td>5200</td>
</tr>
<tr>
<td>33</td>
<td>4900</td>
<td>33</td>
<td>5400</td>
</tr>
<tr>
<td>34</td>
<td>4850</td>
<td>34</td>
<td>5500</td>
</tr>
<tr>
<td>35</td>
<td>4800</td>
<td>35</td>
<td>5150</td>
</tr>
<tr>
<td>36</td>
<td>4900</td>
<td>36</td>
<td>5650</td>
</tr>
<tr>
<td>37</td>
<td>4450</td>
<td>37</td>
<td>5100</td>
</tr>
<tr>
<td>38</td>
<td>4250</td>
<td>38</td>
<td>4950</td>
</tr>
</tbody>
</table>

If the two data series a rendered in chart, the data is shown as:
Scatter charts can only contain a pair of fact or numeric values which are placed in the Y Axis and X Axis in the data layout. If you add only one fact item to the data layout, no scatter chart is rendered. In addition, label values cannot be added to the Y Axis or X Axis of the data layout. The zoom feature is available when you need zoom in a selected area of the plotted scatter chart.

The following feature limitations apply to scatter charts:

- Data functions are not available to scatter charts because this type of chart relies on non-aggregated data.
- The sort feature cannot be used for scatter chart items.
- The Pivot To Chart feature is not available.
- Drilling cannot be performed on a scatter chart.
- The focus feature cannot be used on scatter chart items.
- The Hide feature hides the whole data series in a scatter chart, and an individual item cannot be hidden.

To create a scatter chart:

1. In the Section pane, select the Chart in which to generate the scatter chart.
2. Select Scatter from the Chart Type drop down list.
3. Drag a fact value from the Catalog pane to the Y Axis of the data layout.

A pair of fact values must be added to the data layout to create a scatter chart. Multiple pairs of facts can be added. If only one fact value is added to the data layout, no chart is rendered.
4 Drag a fact value from the Catalog pane to the X Axis of the data layout.

➤ To show the real value of a data point, use the tool tip and hover over the data point.

➤ To show grid lines on the scatter chart, click the plot area of the chart and select Show X Axis Grid Lines or Show Y Axis Grid lines.

➤ To zoom in on data value, click and hold your mouse button and drag to draw a selection rectangle around the data values that you want to zoom in. You can also select View > Zoom > Zoom In.

➤ To zoom out on data values, click View > Zoom > Zoom Out.

Once the view is zoomed out, you can pan areas to the left, top, right, and bottom of the chart. If the view is zoomed out to the maximum, no shortcut menu is available.

**Bubble Charts**

Bubble charts are typically used to show three dimensions of data in a two dimensional chart. This type of chart often lends itself to the display of financial data because specific values can be visually represented in your chart by different bubble sizes. It is similar to scatter chart allowing you to plot data as a collection of bubbles. Bubble charts plot three values:

- a value set on the x-axis
- a value set on the y-axis
- a value that defines the size or width dimension of a bubble in proportion to the amount of data

For example, the worksheet in the following picture contains values for three types of facts: number of products, dollar value of sales, and percentage size of market share.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Number of products</td>
<td>Sales</td>
<td>Market Share %</td>
</tr>
<tr>
<td>2</td>
<td>14</td>
<td>$12,200.00</td>
<td>15%</td>
</tr>
<tr>
<td>3</td>
<td>20</td>
<td>$60,000.00</td>
<td>23%</td>
</tr>
<tr>
<td>4</td>
<td>18</td>
<td>$24,400.00</td>
<td>10%</td>
</tr>
</tbody>
</table>

In the following bubble chart, the size of the bubble corresponds to the values in the third column of the sample data (Market share %).
Multiple data values can be plotted in the bubble chart.

Bubbles with zero size can be rendered using some small bubble size to prevent them from disappearing. Also, there is an option to hide zero-size values if necessary.

Bubbles with negative values can also be displayed. These type of values are derived from their real absolute value, and the real negative value is depicted in the data label (although based on the positive value). You can optionally select not to show negative values.

The following feature limitations apply to bubble charts:

- Data functions are not available to bubble charts because this type of chart relies on non-aggregated data.
- The sort feature cannot be used for bubble chart items.
- The Pivot To Chart feature is not available.
- Drilling cannot be performed on a bubble chart.
- The focus feature cannot be used on bubble chart items.
- The Hide feature hides the whole data series in a bubble chart, and an individual item cannot be hidden.

To create a bubble chart:

1. In the Section pane, select the chart in which to generate the bubble chart.
2. Drag a fact value from the Catalog pane to the Y Axis of the data layout.
3 Drag a fact value from the Catalog pane to the X Axis of the data layout.
4 Drag a fact value from the Catalog pane to the Size pane of the data layout.

➤ To show the real value of a data point, use the tool tip and hover over the data point.

➤ To show grid lines on the scatter chart, click the plot area of the chart and select Show X Axis Grid Lines or Show Y Axis Grid lines.

➤ To zoom in on data value, click and hold your mouse button and drag to draw a selection rectangle around the data values that you want to zoom in
Once zoomed in, the text: “Partial View” is displayed in the upper left of the chart.

➤ To zoom out on data values, click Full or Previous on the shortcut menu.
Once the view is zoomed out, you can pan areas to the left, top, right, and bottom of the chart.
If the view is zoomed out to the maximum, no shortcut menu is available.

### Using Two-dimensional Bar Charts

Bar charts are the most common type of business chart and are especially useful for comparative analysis when you want to focus on comparing values and place less emphasis on time. Use a bar chart to illustrate comparisons among individual items.

Two-dimensional bar charts are plotted using a single item in each of the x pane and y pane in the data layout. The z pane is not populated in 2-D bar charts.

➤ To create a two-dimensional bar chart:

1 **Select a bar chart format from the Chart drop-down list box.**
   The default chart format is Vertical Bar.
2 **Drag a label item from the Catalog pane to the data layout.**
   Data labels are displayed on the horizontal axis in the Chart area.
3 **Drag a value from the Catalog pane to the y pane of the data layout.**
   A chart is plotted that summarizes the selected value on the y axis as it relates to the subcategories of the label item x axis.
   Interactive Reporting automatically scales the data represented on the y axis and adds appropriate labels. The Legend provides an index of label information with a coordinated color scheme.
   To use a different 2-D chart format, select another 2-D chart from the Chart drop-down list box.
To display bar values:

1 Select **Show Bar Values** on the shortcut menu.

2 Select the placement of values on the bar:
   - Inside
   - Over
   - Outside
   - None

To show the gap between bars, click a bar and select **Show Bar Gap** on the shortcut menu.

To show the borders of a bar, click a bar and select **Show Bar Border** on the shortcut menu.

**Working with Multidimensional Charts**

Frequently, you want to represent more than two dimensions of data at a time. For example, you may want to see how the sales of product types break down by years or quarter. There are numerous ways to chart three or more dimensions of data. You can project data into the third dimension of space. You can also represent the data in two spatial dimensions.

- “About the 3-D View” on page 255
- “Creating Three-dimensional Bar Charts” on page 256
- “Understanding Clustered Bar Charts” on page 257
- “Understanding Stacked Bar Charts” on page 258
- “Understanding Area Charts” on page 258
- “Understanding Ribbon Charts” on page 259
- “Understanding Line Charts” on page 259
- “Time Aware Axis” on page 260
- “Understanding Combination Charts” on page 262

**About the 3-D View**

By default, Interactive Reporting imparts a 3-D look to your chart objects. These objects are displayed in the chart space as 3-D objects with depth. That does not mean that you are plotting three dimensions of data or using three dimensions of space to represent data. It is simply a visual effect that can be turned off.

**Note:**

If you turn off 3-D View, you cannot view charts that use a third dimension in space.
To toggle 3-D View, select **Format > 3-D View**.

A check mark is displayed next to the 3-D View option to indicate it is active. Select this option again to clear the check mark and turn off 3-D view.

**Note:**
You can also select to view objects in 3-D using the Properties dialog box. For more information, see “Customizing Chart Properties” on page 278.

---

**Creating Three-dimensional Bar Charts**

You can add more information to your bar chart by adding an additional item or items to the z pane in the data layout. Using multidimensional charts, you can show various relationships between three or more items in easy-to-understand bar chart formats.

Interactive Reporting plots the added data in rows that extend back along the z axis of the chart. Dragging a label item to the Stack, Cluster or Depth category (in this case, Year) plots an extra dimension.

To create a three-dimensional bar chart:

1. Select a bar chart format from the Chart drop-down list box.
   - The default chart format is Vertical Bar.
2. Drag a label item from the Catalog pane to the x pane in the data layout.
3. Drag a label item from the Catalog pane to the z pane in the data layout.
4. Drag a value from the Catalog pane to the y pane in the data layout.
   - A chart is plotted that summarizes the selected value y pane as it relates to the subcategories of the label items (x axis and z axis).

To display line values, select **Show Line Values** on the shortcut menu.

To display bar values:

1. Select **Show Bar Values** on the shortcut menu.
2. Select the placement of values on the bar:
   - Inside
   - Over
   - Outside
   - None
To show the gap between bars, click a bar and select **Show Bar Gap** on the shortcut menu.

To show the borders of a bar, click a bar and select **Show Bar Border** on the shortcut menu.

**Understanding Clustered Bar Charts**

You can change your chart perspective so that the z axis data extended in the third dimension is shown as clusters displayed in the foreground. This charting option is useful when the z axis bars are hard to distinguish in standard bar formats.

You can use clustered bar charts to juxtapose categories in one label item. For example, use clustered bars to compare stores of different types. Alternatively, cluster bars can be used to compare two different value items, such as Amount of Sales and Units Sold.

**Note:**

You can only display clustered bar charts in vertical format.

To cluster bars representing divisions in label items (clustered on the z axis):

1. Select **Vertical Cluster Bar** from the Chart Type drop-down list box.
2. Drag a fact item from the Catalog pane to the y pane and label items to the z axis and x axis panes in the data layout.

To cluster bars representing two different value items (clustered on the y axis):

1. Select **Vertical Cluster Bar** from the Chart drop-down list box.
2. Drag two fact items to the y axis and a label item to the x axis.

To display bar values:

1. Select **Show Bar Values** on the shortcut menu.
2. Select the placement of values on the bar:
   - Inside
   - Over
   - Outside
   - None

Working with Multidimensional Charts
To show the gap between bars, click a bar and select **Show Bar Gap** on the shortcut menu.

To show the borders of a bar, click a bar and select **Show Bar Border** on the shortcut menu.

### Understanding Stacked Bar Charts

Another way to represent the third dimension of data is through stacking. In this way, a single bar on the chart can show data for more than one category of data. For example, a single bar can represent the amount of sales for CD-ROM drives in one year on top of a bar representing sales for other years. You can stack the bar charts vertically or horizontally.

Stacked bar charts show the relationship of parts to the whole. Stacking techniques differ depending on whether you are representing divisions within data label categories or stacking two separate numeric categories.

Stacked bar charts offer similar complexity to clustered bar charts by adding component value items within chart bars or areas. By stacking items and assigning a different color to each item, you can effectively display trends among comparable or related items, or visually emphasize a sum of several indicators.

To create a Stacked bar chart, you need more than one Request item in the Y-Facts in the data layout. Each value item adds a segment to the length of the bar.

To display bar values:

1. Select **Show Bar Values** on the shortcut menu.
2. Select the placement of values on the bar:
   - Inside
   - Over
   - Outside
   - None

To show the gap between bars, click a bar and select **Show Bar Gap** on the shortcut menu.

To show the borders of a bar, click a bar and select **Show Bar Border** on the shortcut menu.

### Understanding Area Charts

Area charts are essentially bar charts with the discontinuous breaks removed along the horizontal axis. Data is not broken into discrete bars but is displayed in a continuous ebb and flow as defined against the Y-axis. Consequently, area charts are particularly useful for emphasizing the magnitude of change over time. In addition, area charts can be used for the same purposes as bar charts.
Because area charts do not break data along the horizontal axis, they are most useful for charting three dimensions of data. The z pane should be used to either project data into a third spatial dimension, or to stack two categories of data in a stacked area chart.

**Creating an Area Chart**

➤ To create an area chart:
1. Select **Area** from the Chart drop-down list box.
2. Drag a value item from the Catalog pane to y pane in the data layout.
3. Drag a label item from the Catalog pane to the z pane in the data layout.
4. Select **Legend On Z** from the Legend drop-down list box.

Setting the legend on the z axis is properly distributes color.

**Creating a Stacked Area Chart**

➤ To create a stacked area chart:
1. Select **Stacked Area** from the Chart drop-down list box.
2. Drag a value from the Catalog pane to the y pane in the data layout.

**Understanding Ribbon Charts**

A ribbon chart is very similar to a line chart but with a few visual differences. In a ribbon chart, items in the y axis determine the height of the line, and items in the x axis itemize the line sections. You can create multiple lines by adding items to the z pane.

➤ To create a ribbon chart:
1. Select **Ribbon** from the Chart drop-down list box.
2. Drag a value item from the Catalog pane to the y pane in the data layout.
3. Drag a label item from the Catalog pane to x pane and one or more label items to the y pane in the data layout.

**Understanding Line Charts**

Line charts show trends in data at equal intervals and are effective for comparing highs and lows in a continuum. In a line chart, items in the y axis determines the height of the line, and items in x axis itemize the line sections. You can create multiple lines by adding items to z axis.

Line charts have one advantage over bar charts. They do not enable one set of data to obstruct the representation of another. Since lines are thin compared to bars, the data displayed in the front does not block out the data behind.
As a result, data that is not easily represented in bar or area charts work well in line charts. Many more dimensions of data can be superimposed without impairing the effectiveness of the chart.

**Note:**

A line chart can have two different looks depending on if the chart was switched from a stacked or non stacked chart. If a line chart was switched from a stacked chart, the z axis items on the chart are stacked. If a line chart was switched from a non stacked chart, the z axis items are not stacked and are displayed as originally created.

➤ To create a standard line charts y axis:

1. Select Line from the Chart drop-down list box.
2. Drag a value item from the Catalog pane to the Facts pane in the data layout.
3. Drag label items from the Catalog pane to the X pane in the data layout.
4. Drag items from the Catalog pane to the Depth pane in the data layout.
5. Select Legend On Facts (Depth) from the Legend drop-down list box to distribute colors along the z axis.

➤ To show line values, click a line and select **Show Line Values** on the shortcut menu.

➤ To show marker border, click a line and select **Show Marker Border** on the shortcut menu.

**Time Aware Axis**

The Time Aware Axis feature allows you to show dates in chronological order plotted at specific intervals within minimum and maximum bounds. To do this, the Time Aware Axis feature turns a discrete X-Axis into a continuous time interval. The distance between adjacent axis items is proportional to their time value difference (a non Time Aware Axis shows all items using the same difference between them). The Time Aware feature only implements an alternative visualization of source data and does not affect the way how the data is aggregated and computed items are calculated. That is, the data processing in chart section which includes dividing data into categories and calculating fact data does not depend on whether the Time Aware feature is activated. In particular, the behavior of the “Chart This Pivot”, “Pivot This Chart” and “Add Computed Item” actions do not change.

For example, the data below represents the total sales per month:

<table>
<thead>
<tr>
<th>Date</th>
<th>Total Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>1/1/2005</td>
<td>$2,583,200</td>
</tr>
<tr>
<td>2/1/2005</td>
<td>$3,551,700</td>
</tr>
<tr>
<td>6/1/2005</td>
<td>$2,011,210</td>
</tr>
<tr>
<td>7/1/2005</td>
<td>$1,149,210</td>
</tr>
</tbody>
</table>

A Line Chart that has no Time Aware axis, shows the data as follows:
The four ticks corresponding to the month are arranged uniformly along the axis (the distance between them is the same). At first glance, it appears that the sales reduction trend becomes slower in the last month. If you look at the graph closer, there is no March to May period.

If you add a Time Aware axis, the same chart looks like this:

This chart shows every month on the present time values; even month for which there is no data. Sales for the last month drop quickly.

The Line Charts is the main application area of this feature; however it is available in almost all existing chart types. Scatter/Bubble charts do not include this option because they are already “time aware” (essentially, value aware) by nature. Both have two fact axes which are continuous by definition.

The Time Aware axis can only be used under specific conditions:

- The X axis should have a date/time category to display, which becomes a dedicated Time Scale category.
- Only one category should be on the X-Axis. If you add multiple categories, even if they are date/time categories, the feature is rendered inactive.
- The Time Aware axis is not available for pie, scatter and bubble charts.
The Time Aware Axis is considered active if the conditions in the list above are met, and the Time Aware option on the Label Axis dialog is not explicitly disabled. You can turn on or off the feature. If you turn off the feature, the X axis remains discrete as in previous versions. By default the feature is turned off for Interactive Reporting documents older than Release 9.3. Charts created in Release 9.3 and later have the feature enabled.

**Note:**

Since the Time Aware Axis assumes that all axis labels are in ascending order, the sort order option is disabled.

To create a Time Aware axis:

1. Check the Time Aware option on the Label Axis tab of General properties.
2. Drag a date/time item from the Catalog pane to the X pane in the data layout.
3. Drag a value item from the Catalog pane to the Facts pane in the data layout.

### Understanding Combination Charts

Combination charts combine some of the strengths of bar charts with the advantages of line charts. Solid bars can be used for the most important data against which other dimensions are represented in lines. In this way, emphasis is given to a portion of data based on its importance. A combination chart is especially useful for comparing two numeric values, such as amount and units of sales.

To create a combination chart that compares values:

1. Select Bar-Line from the Chart drop-down list box.
2. Drag two values from the Catalog pane to the y pane in the data layout.
3. Drag label items from the Catalog pane to x pane and z pane in the data layout.

To create a combination chart that compares categories within a label:

1. Select Bar-Line from the Chart drop-down list box.
2. Drag a value item from the Catalog pane to the z pane in the data layout.
3. Drag one or more value items from the Catalog pane to the y pane in the data layout.
4. Drag a label to the x pane in the data layout.

**Note:**

A combination chart is most effective when the y pane contains only two value items. It represents one value as bars and the other value as a line. When more than two values are present, the chart alternates between bars and lines in depicting the values (1st, 3rd, 5th … items are bars; 2nd, 4th, 6th … items are lines).
To display line values, select **Show Line Values** on the shortcut menu.

To display bar values:
1. Select **Show Bar Values** on the shortcut menu.
2. Select the placement of the values on the bar:
   - Inside
   - Over
   - Outside
   - None

To show the gap between bars, click a bar and select **Show Bar Gap** on the shortcut menu.

To show the borders of a bar, click a bar and select **Show Bar Border**.

To toggle fact values as bar or line, click an item in the Fact pane, and select either **Display as Line** or **Display as Bar**.

---

**Manipulating Chart Data**

Interactive Reporting offers a number of ways to manipulate the data in your chart for better analysis. Review these topics:

- “Using Different Scales to Compare Related Values” on page 263
- “Using Data Functions in Charts” on page 264
- “Adding Computed Items” on page 265
- “Sorting Chart Items” on page 265
- “Creating Pivot Tables from Charts” on page 267
- “Drilling into Charts” on page 267
- “Hiding and Focusing on Charted Data” on page 268
- “Hiding and Focusing on Charted Data” on page 268

---

**Using Different Scales to Compare Related Values**

To chart comparison values or to combine two related indicators on the same chart, you may need to compensate for different numeric scales. For line, clustered bar, and combination charts, you can use a second Y-axis to represent values on a **scalar function** that differs from the scale of the first y-axis.

For example, you might like to chart the sales of your two fastest growing product lines together to get an idea of how business is growing. However, while the growth rates are similar, the two product lines may sell at entirely different volumes. The chart does not provide much
comparative information because each line needs to be charted at a different scale. By using different scales for the two y axes, you can correctly scale each value for the most effective presentation of the data.

➤ To use a different scale for a value on the second y axis, double-click the one of the two values in the y pane in the data layout.

Interactive Reporting changes the scale of the y axis for the value automatically, and italicizes the value name in the data layout. Double-click the item again to return the scale to its default setting.

For information on manually setting scales for left and right y axis values, see “Setting Chart Value Axis Properties” on page 282.

Using Data Functions in Charts

Data functions allow you to calculate values.

➤ To apply a data function:

1 Select a label in the Chart area.

2 Select Chart > Data Function > Function.

Table 61 Chart Data Functions

<table>
<thead>
<tr>
<th>Data Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sum</td>
<td>Returns sum of all values. This is the default setting.</td>
</tr>
<tr>
<td>Average</td>
<td>Returns average of all values.</td>
</tr>
<tr>
<td>Count</td>
<td>Returns number of values.</td>
</tr>
<tr>
<td>Maximum</td>
<td>Returns highest value.</td>
</tr>
<tr>
<td>Minimum</td>
<td>Returns lowest value.</td>
</tr>
<tr>
<td>% of Grand</td>
<td>Returns values as a percentage of all like values in the chart.</td>
</tr>
<tr>
<td>Non-Null Average</td>
<td>Returns average of values; null values excluded.</td>
</tr>
<tr>
<td>Null Count</td>
<td>Returns number of null values.</td>
</tr>
<tr>
<td>Non-Null Count</td>
<td>Returns number of values; null values excluded.</td>
</tr>
</tbody>
</table>

Note:

Null values are empty values for which no data exists. Null values are not equal to zero.
Adding Computed Items

You can create new chart elements by building equations to compute data items, or by applying functions to data items. Computed items are like normal data items, and can be included in charts or used to compute other data.

For example, you can modify the Amount Sold item by building an equation around it, multiplying it by the Unit Price item and renaming the resulting item Revenue. You can also apply a scalar function such as Cume to Amount Sold and return each individual value as a cumulative running total, or simply multiply Amount Sold by the local tax rate to find the tax owed on each sale.

To create a computed item:

1. Select Add Computed Item from a Section menu (for example, Query, Results, and so on).
   - The Computed Item dialog box is displayed.
2. In the Name field, type a name that describes the computation.
   - The default name is Computed, which is numbered sequentially if there is more than one. If you assign a name to a computed item that is identical to a scalar function name, Interactive Reporting numbers the name starting with the number 2.
3. Define the new data item by building an expression in the Definition text box.
   - Use the operator buttons to insert arithmetic and logical operators at the insertion point.
     - Click Reference to display the Reference dialog box, and select Request items to place in the equation.
     - Click Functions to apply scalar functions using the Functions dialog box.
   - You can also type any portion of the equation or the entire equation directly into the Definition text box using JavaScript. The names are case sensitive, and you must replace spaces in item names with underscores (‘_’).
4. If necessary, click the Options button to set a new data type for the item.
5. When the equation is complete, click OK.
   - The computed item is listed in the data layout and is added to your chart.

Sorting Chart Items

Data in charts is sorted alphabetically by default. You can use the sort buttons on the Standard toolbar to perform simple sorts on selected items and reverse the sort order. In charts, however, you generally want to override the default alphabetical setting and sort dimensional data with reference to other data.

For example, if a chart lists each type of widget your company sells and the total amount sold of each, initially the widget types are ordered alphabetically. But this data becomes more meaningful when you instead sort the widget types with reference to the total produced by each. This approach enables you to rank each widget from the highest to lowest total sales.
You can use the Sort line in the Chart section to impose a sort condition for each dimensional data item in your chart. The Sort line includes three drop-down menus used to define the sort conditions. The contents of the menus vary depending on the data items in your chart.

**Note:**

Sorting cannot be used for scatter or bubble chart items.

➤ To specify a sort using the Sort line:

1. **If the Sort line is not already displayed, click Sort on the Section title bar.**
2. **Select an item to sort from the Sort drop-down list box.**
3. **Select a value from the By drop-down list box as a sort reference, or select Label to sort the item alphabetically.**
4. **If desired, select an aggregate function from the Using drop-down list box when sorting by values.**
   The Using drop-down menu is not available when you sort by labels.
5. **If desired, click the ascending or descending Sort button on the Sort line.**
   The Sort line stores a sort condition for each dimensional item included in the chart.

**Sort Items**

The sort drop-down menu lists the data items that can be sorted. Each dimensional item included in the chart (name and date) is listed in this menu. Dimensional items can include Pivot column and row labels.

**Reference Items**

The By drop-down menu lists items used as a basis for a complex sort condition (for example, sorting Cities by the revenue generated in each).

- **Label**—By default, dimensional data items is sorted alphabetically by name when you create your chart: this is equivalent to sorting by label. When selected, labels indicates that the item chosen from the Sort list is sorted by label or name, rather than by reference to corresponding numeric data values in the chart.

- **Value**—Sorting by a numeric data item orders each value of the target item chosen from the Sort list by its corresponding numeric value in the Value list.

Sorting by values produces an entirely different sort order. For example, your chart may list each state in which your company has made sales revenue and the total cost-of-sales for each. The states are initially listed in alphabetical order. When you sort by cost-of-goods, the states are ranked in order by each corresponding cost-of-sales figure.
Functions

The Using drop-down menu contains aggregate statistical functions that are available when you sort by values. The sort aggregate functions are usually the same as the data functions available in a section. When you sort by values, labels are sorted by the corresponding numeric values of the referenced item (for example, sorting states by the sum total of the cost of goods sold in each state).

Note:

Data Functions are not available for the scatter and bubble chart types because these types of charts do no use aggregated data (they retrieve their data from the equivalent of their underlying Table/Results section.)

Creating Pivot Tables from Charts

Once you have a final version of your chart, use the automatic pivot table-generator to create a pivot table based on the layout of your chart.

Note:

The Pivot this Chart feature is not available for scatter and bubble chart types.

To create a pivot table based on your chart, in the Chart section, select Insert > Pivot This Chart.

Drilling into Charts

The drill into feature enables you to drill into items in the Chart section that are resident in the Results section without having to return to reprocess your query or locate the item in the Catalog pane. Drill into items are automatically added as new label items.

The advantage of this feature is that it instantly enables you to add items to the data set to reflect temporary or hypothetical situations. You can always suspend or delete the item to return to the original chart display.

The extent to which you can drill into your data depends on how the original query was built, since Drill Into retrieves data from the Results section based on the table hierarchy of items. This feature does not enables you to interactively query the database.

Note:

You cannot drill into any items in a scatter or bubble chart because these types of charts use non-aggregated data.
To drill anywhere into a chart:

1 Select one or more items for analysis and select Chart > Drill Anywhere > Item.

Interactive Reporting redraws the chart drilled to the selected item. In the data layout, an item selected for drill-down is identified with a drill-bit icon.

2 Select Chart > Drillup to return to the original view of your chart.

Tip:

If no options are available in the Drill Anywhere menu, all Request items have been used in the data layout.

Note:

Drill Anywhere is enabled on the General page of Data Model Options. To display the General tab, select DataModel > Data Model Options.

Hiding and Focusing on Charted Data

A straightforward way to refresh your view of a chart is to single out items for closer focus or remove some of the charted elements. This enables you to concentrate on particular items of interest.

Note:

You cannot use the Focus feature on scatter or bubble chart items. In addition, if you use the Hide feature for scatter or bubble charts, the whole data series is hidden and not an individual item.

Focusing on Items

To focus on a chart item:

1 Select one or more objects on which to focus.

Focused items are displayed with a dotted outline.

2 Select Chart > Focus On Items.

The chart is redrawn to display only the chart object(s) selected. A drillbit icon is displayed in the data layout next to the item(s) on which you focused.
To return to the original chart display, select Chart > Show All Items.

**Hiding Items**

To hide charted data:

1. In the chart, select the object.
   The item is displayed with a dotted outline.
2. Select Chart > Hide Items.
   Interactive Reporting redraws the chart with the selected objects removed. A drillbit icon is displayed in the data layout next to the item(s).

**Restoring Hidden Items**

To restore hidden chart items, select Chart > Show Hidden Items.

**Changing Angle and Elevation (Rotating)**

By default, charts are displayed in a three-dimensional, shortened perspective from above and to the right. You can alter the perspective from which a chart is viewed by rotating it within the Contents pane.

**Tip:**

Before you can rotate a chart, the background plane must be visible. To display the background plane, click the plot area of the chart and click Properties on the shortcut menu. Next click Show Back Plane in the General tab of the Chart Properties dialog box.

To rotate the angle of vision or change the elevation of a bar, line or area chart:

1. Place the cursor at the top right corner of the chart.
   The cursor changes to indicate that you can rotate the chart.
2. Hold down the mouse button and rotate the chart.
   When you release the mouse button, the chart is redrawn to reflect the adjusted perspective. If you cannot rotate further in a certain direction, the chart has reached its farthest possible rotation in that direction.

To rotate the perspective angle or elevation of a pie chart:

1. Click Rotate on the shortcut menu.
   The rotate icon is displayed on the pie chart.
2 Drag the bars on the rotate icon to a new location to rotate the chart.

When you release the mouse button, the chart is redrawn to reflect the adjusted perspective. If you cannot drag the rotate icon in a certain direction, the chart has reached its farthest possible rotation in that direction.

Working with Chart Elements

In the Chart section, you can easily reorganize or reposition data to reconfigure your charts and highlight different relationships between the same items. You can drag items to a different order within an data layout, drag label items between data layout panes designated for labels, or delete items from the data layout your chart is redrawn to reflect your changes.

You can also work directly with elements in the Chart area. Most elements are selected by clicking the element in the chart or the element’s label in the legend. For axis labels, a change to one axis label changes all labels along that axis.

Review the following:

- Selecting Chart Elements
- Displaying Axis Grid Lines
- Inserting Text
- Chart Legends

Selecting Chart Elements

➢ To select chart elements as graphic objects in the Chart area:

1 Place the cursor over the edge of an item in the Chart area.

The cursor changes to a move cursor.

2 Select the object.

A gray outline is displayed around the item. You can move the selected chart item anywhere in the Chart area or resize it using the handles. Also, check the shortcut menu for additional options.

Displaying Axis Grid Lines

Axis grid lines are straight lines on a chart that provide a framework for measurement and reference. By default, grid lines are white, but the color can be customized. Typically, the x axis and Stack, Cluster and Depth (z axis) are used for label items and the Fact, Fact (Stack) and Fact (Depth) (y axis) shows values or facts (measurable items), such as units and amounts.

You can view or hide these axis gridlines depending on the chart you are designing.
To toggle the display of axis grid lines:

1 Click anywhere within the main plot area of the chart.
2 Select Show X Axis Grid Lines (or Show Y Axis Grid Lines) on the shortcut menu.
   A check mark is displayed next to the selected option to indicate that the grid lines are visible. Select this option again to clear the check mark and remove the gridlines from the Chart area display.

Inserting Text

You can insert text anywhere around or within the chart to further explain or emphasize a chart component.

To insert text:

1 Select Insert Text on the shortcut menu.
   The Set Inserted Text dialog box is displayed.
2 Type the text in the text box and click OK.
   The text is displayed in the location where you initially invoked the Insert Text command.

Changing Chart Backplanes

By default the backplane of a chart is light gray

To change the color of the backplane:

1 Select the backplane of the chart.
2 Select the Fill Color icon.
   The Fill Color palette is displayed.
3 Select a color from the Fill Color palette.

Chart Legends

You can select the axis along which to distinguish your data by setting the chart legend on that axis. This is a great way to view values on the selected axis without rearranging the values in the data layout. A chart legend can be set on either the X Axis, Y-, or Z-axis. You can also reposition or resize a legend to take advantage of either the horizontal or vertical space within the chart area.

Note:
Chart legend color settings are preserved when the chart type, chart legend axis, and number of chart axis label values are changed.
The following three examples show how to place the legend on different axes to alter the appearance and data shown by the same chart. In the first example, the legend has been set on the X Axis. In the second example, the legend has been set on the Facts axis. In the third example, the legend has been set on the Z axis:

To set the axis used for a chart legend from the Format menu:

1. Select Format > Set Legend On.
The Set Legend On dialog box is displayed.

2 Select the axis on which to set the legend and click OK.

Colors are redistributed to highlight the data associated with the selected item and color coordinates corresponding labels in the Legend.

➢ To set the axis used for a chart legend from the toolbar, click the axis on which to position the legend.

The selected Legend pull-down menu displays to indicate the new axis position on which the legend has been assigned. Interactive Reporting redistributes colors to highlight the data associated with the selected item and color coordinates corresponding labels in the Legend.

➢ To resize a chart legend:

1 Click a border on the legend.

Sizing handles are displayed on each corner of the selected legend.

2 Drag a sizing handle until the legend is the desired size.

➢ To wrap text in a chart legend, select Wrap Legend Text on the shortcut menu.

Legend text wrapping is only allowed when:

● The longest text of items arranged in one column does not fit the width of the legend.
● Sufficient vertical space is available in the legend.

➢ To show the border around the legend, select Show Legend Outline on the shortcut menu.

By default, the legend outline is not shown.

Chart Scrolling and Scaling

You may want to scroll through data, enlarge your chart to better work with chart details, or change the perspective or angle from which a chart is viewed. Review the following sections for information on:

● Scrolling through Chart Data
● Rotating and Elevating Charts
● Smart Scaling
● Auto Resizing Charts
● Fitting Charts to Screen
Scrolling through Chart Data

When you add a Catalog dimension to the data layout of a Chart, the rendered Chart contains all bars and labels corresponding to the total number of unique items in the dimension. If the number of items added is large and as a result, all items cannot display in one view, you can scroll the entire contents of a chart either vertically or horizontally using the scrollbars. The horizontal scrollbar controls the scrolling of X Axis items, and the vertical scrollbar controls the scrolling of Stack, Cluster and Depth items.

Optionally, you or an administrator can define a specific number of items to show for each view of the chart. If the number of total bars is greater than the view size, a full page of bars displays. For example, assume each bar has three views and you want to display four bars (such as: A-B-C-D). When you first display the chart only bars A-B-C display, then when you scroll to the right bars B-C-D display.

If not all bars of a chart display in one view, the you can display the text “Partial View” as an indicator in the top left corner of the Contents pane. You can show or hide this indicator on a per chart basis by enabling or disabling the “Show partial view indicator” field on the General tab of Chart Properties.

The following rules apply to Chart scrolling:

- The chart legend displays only items visible in the current view.
- Scrollbars are not available for the Pie chart type.
- If all bars can display in one view, the scrollbars are disabled.

Rotating and Elevating Charts

By default, charts are displayed in 3-D foreshortened perspective from above and to the right. You can alter the perspective from which a chart is viewed by rotating it.

Before you can rotate the chart, the background plane must be visible.

➤ To rotate the angle of vision or change the elevation of a bar, line, or area chart:

1 Select Chart > Properties.
   The Chart Properties dialog box is displayed.

2 Click the General tab to view the General properties page.

3 In the Planes area, select the Show Back Plane check box and click OK.

4 Place your cursor at the top right corner of the chart.
   The cursor changes to indicate that you can rotate the chart.

5 Hold down the left mouse button and drag the chart to rotate it.
   When you release the mouse button, the chart is redrawn to reflect the adjusted perspective. If you cannot rotate in a certain direction, the chart has reached its farthest possible rotation in that direction.
Smart Scaling

Smart Scaling describes a method for ensuring that chart text label components are intelligently placed in relation to each other so that there is no overlapping, visual obstructions or clipping. Smart Scaling governs:

- Initial chart displays size
- Chart behavior during resizing
- Ability to move or reposition charts

You apply Smart Scaling to prevent overlapping and clipping of objects. Understanding the initial display, and using the Do Not Remove Text and Minimum Font as modifiers are key to the Smart Scaling algorithm.

Smart Scaling is enabled on the General tab of the Chart Properties. By default, Smart Scaling is enabled.

Initial Display

Smart Scaling relies on a display hierarchy or a draw order when it determines what is displayed. The display hierarchy is based on the number of components and the initial size of the chart boundary. The display hierarchy for the Chart sections is as follows.

Bar, Line and Area charts have this display order:

- Planes
- Bar/Lines/Ribbons
- Stack, Cluster and Depth values
- X axis values
- Fact, Fact (Stack) and Fact (Depth) axis values
- Legend
- Titles
- Axis
- Inserted text

Pie charts have this display order:

- Slices
- Slice Labels
- Legend
- Titles
- Inserted text

The display order of Scatter and Bubble Charts are:

As you add or modify various Chart label components, Smart Scaling uses the hierarchy to determine which components to add or omit when placing items.
For example, in a Pie Chart where several small slices are in the same vicinity of each other, some of the pie slice labels might typically overlap due to simple space allocations. If you have Smart Scaling enabled, some of the slice labels are simply not drawn when crowded conditions are encountered. If a current label overlaps a label, then the label is skipped and the next label is drawn. You can correct this by moving the label slice. If there is enough room for other labels to display unobstructed when the label slices are repositioned, additional labels are displayed. You can also enable the “Line to Label” feature to enhance the slice-label relationship, and identify and place items easier.

Retaining Text

When a chart object is reduced disproportionately to other objects in the bounding area and Smart Scaling is enabled, text may be eliminated based on the display hierarchy. You can prevent text from being removed by enabling the Do not remove text option available on the General tab of Chart properties. In the case where a chart object is reduced too much, text is preserved, but may overlap other object or appear distorted.

Minimum Font Size

When the overall size of a chart is modified, Interactive Reporting attempts to redraw chart components using the object’s font size. If it is not feasible to redraw the component in the space available, the font size is reduced by one point, and another drawing is attempted. This process is repeated until the component can fit within the boundaries defined for it, or until a minimum font size is reached.

You specify the minimum font size on the “General” tab of Chart Properties. The default value for the minimum font size is 8.

The components which are modifiable by the minimum font size are:

- y axis, x axis and z axis
- pie slice values
- legend

When the component is first reduced, it continues to show the original font size and not the user defined font size. If the minimum font size is reached for the supported components and it is still too large to fit with obstructing or being obstructed, then the item is removed from display.

When Smart Scaling is used in conjunction with Auto Resize, changes to the Chart size are limited to all those methods which do not involve the movement of the chart border.

If you select the handles of the chart border and reposition them as the method to resize the Chart when Smart Scaling and Auto Resize are enabled, Auto Resize is automatically disabled. The Smart Scaling property remains enabled.
Moving Chart Components

Almost all chart components can be moved independently of each other within the borders of the chart once is has been drawn. With the exception of bar values and axes values, all other chart components can be moved.

With Smart Scaling, the chart title, subtitle, axes labels and legend cannot be moved over each other and cannot be moved over the axes values text and the chart graphic.

If Smart Scaling is not enabled, a Chart component can be moved anywhere within the border of the chart. If the component is layered on top of a component, it overrides that component in the display.

➤ To enable Smart Scaling:

1. Select Chart > Properties.
2. In the Chart Properties dialog box, click the General tab and select Smart Scaling.
3. To use a minimum font size, add a font size in the Min Font Size box and click OK.

Auto Resizing Charts

You can use the following options to resize a chart:

- Drag the handles of the chart border, which redraws the chart to fit the new border dimensions,
- Enable the “Auto Resize” option on the General tab of Chart Properties. This feature automatically expands the chart border to fit the maximum height or width of the Contents pane.
- Enable the “Auto Resize” property and adjust the size of the entire Interactive Reporting Studio application by dragging the corner the application window. This redraws the chart components automatically.
- Enable the “Auto Resize” property and adjust the size of the Contents pane by adjusting the Section/Catalog pane border. This redraws the chart components automatically.
- Enable the “Auto Resize” property and show or hide the Outline and or Sort line.

Resizing a chart can result in the overlap of chart components, especially when a chart is reduced in size. To prevent this overlap, you can use the Smart Scaling and Minimum Font Size features (both described above). By default Auto Resizing is enabled.

➤ To enable Auto Resize:

1. Select Chart > Properties.
   The Chart Properties dialog box is displayed.
2. Click the General tab to view the General properties.
3. Select the Auto Resize check box and click OK.
Fitting Charts to Screen

When the dimensions of a chart are smaller or larger than the actual size of the Contents pane, and you wish to maintain relative proportions between the chart and the actual size of the pane, use the “Fit to Screen” icon on the Chart toolbar.

➤ To fit a chart to the Contents pane, click 

Customizing Chart Properties

Use the Properties command on the Chart menu to customize how your Chart appears. Review these topics for information:

● “Setting General Chart Properties” on page 278
● “Setting Bubble Chart Properties” on page 283
● “Customizing Chart Patterns and Labels” on page 284
● “Auto-Arranging Chart Pie Labels” on page 285
● “Customizing Chart Colors” on page 285
● “Chart Menu Command Reference” on page 288

Setting General Chart Properties

General chart properties control the display of various objects, such as titles, legends, and borders, in the Chart area. They are also used to specify: scaling, scrolling, sizing, zooming, default plane and rotation settings.

➤ To adjust general chart properties:

1 Select Chart > Properties.
   The Properties dialog box is displayed.
2 Click the General tab to display the General properties page.
3 Change any of the following properties:
   ● Show title—Toggles the display of the chart title as entered in the text field.
   ● Show subtitle—Toggles the display of a subtitle as entered in the text field.
   ● Show legend—Toggles the display of color-coded Chart legends in the Chart area.
   ● Show border—Toggles the display of a border around the chart. The border controls the general position of all other Chart components not controlled by the Chart graphic border. This border can be resized and repositioned.
   ● Show partial view indicator—Toggles the display of the “Partial View” indicator in the top left corner of the Contents pane. The indicator shows when not all bars are displayed in the
current view. The indicator is displayed on all output media, including Interactive Reporting Studio, Workspace, PDF and print).

- **3-D objects**—Toggles the 3-D display of chart objects, including pie slices, chart bars, side planes, and perspective view.
- **Print/PDF all views**—Toggles the print of the entire rendered chart. The setting you specify here is not applied to the Export to PDF option in the Workspace.
- **Auto Resize**—Toggles the automatic resizing of a chart within the Content pane whenever the Chart is resized.
- **Smart Scaling**—Toggles the Smart Scaling feature, which governs how Chart components are initially displayed, how they behave during Chart resizing and how the Chart components can be moved or repositioned.
- **Display all text with smart scaling**—Toggles the do not remove text. When this feature is enabled, Smart Scaling (see above) does not remove any text (it does not clip or overlap text if an object is resized or repositioned to a minimum font size). This feature is checked for new Chart sections, and unchecked for 8.3 releases and earlier that have Smart Scaling enabled. Inserted text and legends are not affected by your selection in this field. Smart Scaling may shrink these objects, but they are never scaled to the point where they are eliminated entirely.
- **Minimum Font Size**—Toggles the minimum font size feature for text labels when the overall Chart size is changed and Smart Scaling (see above) is enabled. If it not possible to fit a component in the available space, the font size is reduced by one point and a redraw is attempted. The font size reduction process repeats until the component can fit within the component’s boundary or until the font size specified here is reached. If the component is still too large to fit without obstructing another object, or it is obstructed, then the component is removed from the display. The default minimum font size is 8.
- **Use legacy colors for data points**—Enables an individual Chart to use legacy colors from the Release 8.3 and earlier Color Palette. When this option is unchecked, the newly added Chart uses the default colors from the 8.4 and later Color Palette. To enable all Charts to use the legacy colors from the Release 8.3 and earlier Color Palette, check the “Use legacy colors for data points” option on the Default Fonts and Styles box. This option is saved with other options at the application level. For more information about this option, see “Customizing Chart Colors” on page 285.
- **% Zoom**—Sets the zoom percentage for the viewable area of a scatter or bubble chart. The standard zoom percentages are: 100%, 150%, 200%, 300%, 400%, 600%, 800%, 1,200%, 1,600%, 2,400%. The zoom percentage either reduces or enlarges the viewable area from its original size. You can also enter a custom zoom percentage in this field.
- **Planes**—Toggles the display of horizontal, vertical, and back planes of a chart.
- **Rotation Auto**—Enables the default rotation for new bar charts to 3° horizontally by 2° vertically when a component is added to the X axis. If a component is added to the Z axis, a rotation of 15° horizontally by 20° vertically is used. If this option is disabled, the rotation specified in the Horizontal/Vertical rotation degrees fields.
- **Horizontal/Vertical rotation degrees**—Shift the perspective angle or elevation (–60 to 60 degrees) for all types except the pie chart, which has its own rotation (see below)
- **Rotation**—For pie charts, rotates the pie the specified number of degrees (between -90 and 90), and changes the pie height the specified number of degrees (0 to 90). For all other charts except line charts, shifts the horizontal and/or vertical angel or elevation a specified number of degrees (between -60 and 60).

- **Auto Layout**—Enables the layout of scatter and bubble chart components automatically. In this case, scatter and bubble chart components cannot be repositioned manually.

- **Legend position**—Sets the position of the legend in scatter and bubble charts. Available positions include: Top, Left, Bottom or Right. This option is especially usefully when the Auto Layout property has been enabled.

4 Select OK.

**Setting Chart Label Axis Properties**

Chart label axis properties control the display of the X Axis and Depth (Z-axis) labels, tickmarks, and values for items in the data layout.

To adjust chart label axis properties:

1 **Select Chart > Properties.**
   The Properties dialog box is displayed.

2 **Click the Labels Axis tab to display the Labels Axis properties.**

3 **Modify the properties shown as desired and click OK to apply your changes.**

<table>
<thead>
<tr>
<th>Table 62</th>
<th>Chart Labels Axis Properties</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Option</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td><strong>Axis dropdown</strong></td>
<td>Enables you to select the axis on which apply options</td>
</tr>
<tr>
<td><strong>Show axis label</strong></td>
<td>(X or Z) Toggles the display of a descriptive axis label as entered in the text field.</td>
</tr>
<tr>
<td><strong>Show drill path in labels</strong></td>
<td>(X or Z) Toggles the display of the drill path in the label and legend. By default, this option is enabled.</td>
</tr>
<tr>
<td><strong>Time Aware</strong></td>
<td>Check to enable the Time Aware Axis feature. When the feature cannot be used at the present time, the label: Time Aware (inactive now) is displayed. To review what conditions must be met to use the Time Aware Axis, see <a href="#">Time Aware Axis</a>.</td>
</tr>
<tr>
<td><strong>Auto range</strong></td>
<td>Check to calculate the time range of a Time Aware axis automatically. The minimum and maximum time range values are searched in the current data set. The time range is recalculated automatically when the data set is processed.</td>
</tr>
<tr>
<td><strong>Min</strong></td>
<td>Enter the maximum time range interval when calculating the time range of a Time Aware axis manually. Enter the</td>
</tr>
</tbody>
</table>
minimum interval in the edit box. The date/time format used to display the values is the same one that you have for X axis labels. The date/time format used to display the values is the same one that you have for x axis labels or default format as in Default formats dialog. When the edit box is focused, it displays date/time in full format "mm/dd/yyyy HH:MM:SS AM". You should enter values in full format, which allows you to enter any values regardless of current label format. This option is disabled if the Auto range option is enabled.

Max
Enter the maximum time range interval when calculating the time range of a Time Aware axis manually. Enter the maximum interval in the edit box. The date/time format used to display the values is the same one that you have for x axis labels or default format as in Default formats dialog. When the edit box is focused, it displays date/time in full format "mm/dd/yyyy HH:MM:SS AM". You should enter values in full format, which allows you to enter any values regardless of current label format. This option is disabled if the Auto range option is enabled.

Auto frequency
Check to calculate tickmarks and labels automatically. If this option is disabled, values are not reset unless changed manually.

Show tickmark
Check to show tickmarks for chart label values. To manually specify recurring intervals at which to display a limited number of tick marks, enter the numeric value in the At every edit box. If you are working with a Time Aware axis, you can specify to place the tickmark on the:

- Value
- Year
- Month
- Week
- Day
- Hour
- Minute
- Second

Show label
Check to show labels. To manually specify recurring intervals at which to display a limited number of tick marks, enter the numeric value in the At every edit box. If you are working with a Time Aware axis, you can specify to place the label on the:

- Value
- Year
- Month
- Week
- Day
- Hour
- Minute
### Setting Chart Value Axis Properties

Chart value axis properties control the display of axis labels, tickmarks, values, and position for items in Y-Facts in the data layout.

To adjust chart value axis properties:

1. **Select Chart > Properties, or select Properties on the shortcut menu.**
   The Properties dialog box is displayed.

2. **Click the Values Axis tab to display the Values Axis properties page.**

3. **Modify the properties shown as desired and click OK to apply your changes.**

You can display labels, tickmarks at intervals, and values at intervals for primary and secondary value axes.

**Allow adjustable scaling for faster performance**—Select this field to calculate the min/max (Y) range based on the first two thousand bars. As you scroll through this range (moving to the right...)

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Expand label box</strong></td>
<td>Increases the label box size for an x axis label (y and z labels are unaffected) in an individual Chart. It is not available for pie charts. This feature is used primarily for sequential labels, for example, time, day or number labels. For regular name-based labels, this feature should be disabled so that the user can view each label name.</td>
</tr>
<tr>
<td><strong>Show values</strong></td>
<td>Check to (X or Z) Toggles the display of individual labels along the axis.</td>
</tr>
<tr>
<td><strong>Auto X Axis frequency and Show... fields (X Axis only)</strong></td>
<td>(X Axis only) Custom-sets the X Axis scale by toggling between auto-spacing, or manually specifying recurring intervals at which to display a limited number of values or tick marks.</td>
</tr>
<tr>
<td><strong>Maximum bars displayed</strong></td>
<td>Check to specify the number of bars to display per page when scrolling on a page. Enter the maximum number of bars in the edit box.</td>
</tr>
</tbody>
</table>
| **Display** | Check to select the number of pages or date/time values when scrolling through a fixed number of intervals for the Time Aware axis. Available values include:  
  - Pages  
  - Year(s) per page  
  - Month(s) per page  
  - Week(s) per page  
  - Day(s) per page  
  - Hour(s) per page  
  - Minute(s) per page  
  - Second(s) per page |
[X] or back [Z]], of if any bar is above the maximum or below the minimum, the Y scale is expanded to all bars.

If this feature is unchecked, the min/max range is calculated based on all bars.

You may also set the left axis and right axis scales using a logarithmic scale, which plots line charts with logarithmic (base 10) values; and whether the values displayed on the scale are automatically set by Interactive Reporting, or set by manually specifying minimum and maximum values. For the left axis scale, you may specify the interval at which to separate axis values or have Interactive Reporting automatically assign the interval.

If all bars are displayed in a view (the chart scrolling is off), the true minimum and maximum are calculated.

If you print a chart when “all views” are active, the minimum/maximum range is calculated based on all bars.

**Note:**

If you plot a line chart with a logarithmic (base 10) value axis, any chart values less than one (1) are represented as zero (0) on the logarithmic scale and an information message is displayed on the Windows status bar.

---

### Setting Bar Chart Properties

Bar chart properties control the general attributes for the various bar chart formats.

To adjust bar chart properties:

1. Select **Chart > Properties**.
   
The Properties dialog box is displayed.

2. Click the **Bar Chart** tab.

3. Modify the properties shown as desired and click **OK** to apply your changes.

   - **Show Values on Bar**—Toggles the display of values on each bar in the chart.
   - **Clustered Bar Charts**—Clusters bars by items on the Fact axis (Y-axis) or Z Axis. For example, if you have *Quarter* on the Y-axis, each cluster consists of four bars, one for each quarter.
   - **Bar-Line Charts**—Toggles the display of values on bars and for lines, and the inclusion of null values (which disrupt the line, area, or ribbon). Zero’ (0) values are included.

     You can also place line chart plot points to the left of or centered on bars, and stack or cluster bars on the Y-axis.

---

### Setting Bubble Chart Properties

Use the Bubble Chart Properties tab to set specific bubble chart options.
To set bubble chart properties:

1 Select Chart > Properties.
   The Properties dialog box is displayed.
2 Select the Bubble tab.
3 Modify any properties and select OK.
   - **Show negative bubbles**—Display bubbles with negative values. These type of values are derived from their real absolute value, and the real negative value is depicted in the data label (although based on the positive value).
   - **Show zero bubbles**—Display bubbles with zero size and render the zero size bubble using a small bubble size to prevent them from disappearing. Also you can disable this feature to hide zero-size values if necessary.
   - **Max bubble size (%)**—Set the maximum size of the bubble in the grid area. This size is measured as a percentage value. The default value is 25%.

**Customizing Chart Patterns and Labels**

In addition to the generic label axis properties that apply to all charts, you can change properties of individual charts items, such as patterns, colors, and data labels. Review the following sections for information:

- **Changing Chart Color Schemes and Fill Patterns**
- **Changing Chart Data Labels**
- **Changing the Color of Chart Elements, Lines, and Text**

**Changing Chart Color Schemes and Fill Patterns**

You can redistribute chart colors to emphasize specific charted items listed in the data layout and change chart focus. Colors are differentiated along a specific axis.

To change the pattern or color scheme of a chart:

1 Double-click a chart element in the legend, or select an element in the chart (such as a bar or a pie slice) and select Chart > Properties.
   A Properties dialog box is displayed that may contain one or more tabs (Patterns, Axis, Data Labels), depending on the format of the active chart.
2 Select the Patterns tab to display the Patterns tab.
3 Select the fill pattern and color for the chart segment, line, or marker and click OK.
   - **Automatic**—Sets the fill pattern and color to the default setting. The default setting for fill pattern is *Solid*. The default setting for color varies between chart formats.
   - **None**—Sets a transparent fill pattern and color for the selected element.
Custom—Enables you to select a foreground color and fill pattern for the chart. Choices include Solid, Hollow, Horizontal, Vertical, Cross, Diagonally Up, Diagonally Down, Diagonally Cross.

For line charts, you can also select the width, style and color of lines, and the size, style, border colors, and fill colors of markers.

**Changing Chart Data Labels**

You can change the type of data used in the labels in your chart. The choices available depend on the chart format.

➢ To change a data label:

1. Double-click a chart element in the legend, or select an element in the chart (such as a bar or a pie slice) and select Chart > Properties.
2. Click the Data Labels tab to display the Data Labels tab.
3. Select the fill pattern and color for the chart segment, line, or marker.
   - **Pie Charts**—Shows pie slice labels, values, percentages, negative values, and lines that connect a data label to its pie slice.
   - **Bar Charts**—Shows individual bar values and the placement of the values inside the bar.
   - **Line Charts**—Shows values and ignore null values, and select the placement of the values relative to the line.

For line charts, use the Axis page to specify whether to plot values on the primary (left) axis or secondary (right) axis.

**Auto-Arranging Chart Pie Labels**

If you reposition a pie label manually and the slices are later rearranged, the position of the label remains unchanged. To reposition the label automatically with the slice, enable the Auto Arrange option on the label context menu.

➢ To auto-arrange chart pie labels, select **AutoArrange** on the shortcut menu.

**Customizing Chart Colors**

This section explains color options available in the Chart section.

**Default Color Palette and Legacy Color Palette**

By default, Interactive Reporting bases the color scheme used in a Charts on the default colors in the Color Palette. This palette consists of a legacy color palette (pre 8.4 color palette) and a default color palette as shown below:
The legacy color palette consists of the first six rows in the color palette. The default color palette consists of the last two rows. There are seventeen chart default colors and the chart background color is the last color on the bottom row. The numbers below are the hexadecimal numbers for the rgb codes in the default Color Palette.

**Using Legacy Chart Colors**

When you open a Chart created in Release 8.3 and earlier, the Chart uses the default colors available in the legacy color palette. This feature is enabled automatically for all 8.3 and earlier charts in the “Use legacy colors for data points” check box on the Default Fonts and Styles dialog box. In addition, when this is checked, all newly added charts use the default colors in the Legacy Color Palette that were used in 8.3 and earlier. When this is unchecked, which is a default value, all newly added charts use the default colors in the Default Color Palette. This value is saved with other application level parameters in this dialog.

For an individual Chart, you can use the default colors available in the Legacy Color Palette by enabling the “Use legacy colors for data points” check box on the General tab of the Chart Properties dialog.

If you modify the Chart (for example, you perform a drill down, or change the chart type), the colors of the Chart use the default color sets depending on the “Use legacy colors for data points” option. For example, if the check box is not checked, the new default colors are used, otherwise, the old default colors (pre 8.4) are used.

In the example below, the bar chart uses the default colors from the Legacy Color Palette:
**Using Default Colors**

By default, Charts created globally in Release 8.4 and later use the default colors available in the Default Color Palette. In this case, the “Use legacy colors for data points” check box is unchecked on the Default Fonts and Styles dialog box.

For an individual Chart, you can use the default colors available in the Default Color Palette by unchecking the “Use legacy colors for data points” check box on the General tab of the Chart Properties dialog.

If you want to use the default colors from the Legacy Color Palette, enable the “Use legacy colors for data points” check box on the General tab of the Chart Properties dialog.

In the next example, the bar chart uses the colors from the Default Color Palette:

![Bar Chart Using Default Colors](chart.png)

**Changing the Color of Chart Elements, Lines, and Text**

Use the Format toolbar to change the line, fill, and text color of a chart element or text and add emphasis to your chart.

**Note:**

If the Format toolbar is not visible, select View > Toolbars > Formatting.

- To change line color:
  1. Select a plot point in the line.
  2. On the Format toolbar, open the Line Color list and select a color from the palette.

- To change the fill color of a chart element:
  1. Select the chart element.
  2. On the Format toolbar, open the Fill Color list and select a color from the palette.

- To change the color of text:
  1. Select a label or other text element.
  2. On the Format toolbar, open the Text Color list and select a color from the palette.
# Chart Menu Command Reference

The following table provides a quick reference to the commands available on the Chart menu and lists any related shortcuts.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Keyboard Shortcut</th>
<th>Shortcut Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sort</td>
<td>Sorts the selected column values in ascending order (alphabetical or numeric).</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Data Function</td>
<td>Applies a prebuilt data function to the selected item.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Add Computed Item</td>
<td>Enables you to add a new data item derived from calculations performed on an item.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Modify Computed Item</td>
<td>Enables you to modify a computed item.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Remove Selected Items</td>
<td>Removes the selected items.</td>
<td>Del</td>
<td>*</td>
</tr>
<tr>
<td>Drill Anywhere</td>
<td>Enables you to drill to any item.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Drillup</td>
<td>Returns the original view of the data you drilled.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Focus On Items</td>
<td>Updates the chart to include only the selected items.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Hide Item</td>
<td>Hides the selected item from view.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Show Hidden Items</td>
<td>Restores the selected hidden item.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Show All Items</td>
<td>Updates the chart to include all items removed by focusing.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Group Items</td>
<td>Groups the selected items.</td>
<td>Ctrl+G</td>
<td>*</td>
</tr>
<tr>
<td>Ungroup Items</td>
<td>Ungroup the selected grouped item.</td>
<td>Ctrl+U</td>
<td>*</td>
</tr>
<tr>
<td>Restore Name</td>
<td>Restores the original name of a renamed item.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Refresh Data</td>
<td>Updates the data according to the selected option. Select between After Process, When Section Displayed, Manually, or Refresh Now.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Properties</td>
<td>Opens the Properties dialog box for the chart or selected chart element.</td>
<td></td>
<td>*</td>
</tr>
</tbody>
</table>

## Vertical Bar Charts

Bar charts compare items within a set. You can create vertical bar charts in two or three dimensions, and you can cluster or stack the bars. In a vertical bar chart, items in the y pane form the chart bars, and items in the x and z panes itemize the bars. Vertical bar charts are the default chart type.
Horizontal Bar Charts

Bar charts compare items within a set. You can create horizontal bar charts in two or three dimensions, and you can cluster or stack the bars. In a horizontal bar chart, items in the x-categories pane form the chart bars, and items in the y pane and z pane itemize the bars.
In This Chapter

Report Section.........................................................................................................................................................291
Creating a Custom Report........................................................................................................................................296
Working with a Report Page.................................................................................................................................309
Setting Up a Report................................................................................................................................................310
Enhancing Report Data............................................................................................................................................312
Using Multiple Data Sources in a Report..................................................................................................................320
Creating Smart Reports............................................................................................................................................321
Formatting Report Items...........................................................................................................................................322
Converting Detail Reports from Versions Earlier than 6.0..........................................................................................322
Report Menu Command Reference...........................................................................................................................324

Report Section

In the Report section, the Report Designer helps you to easily develop a complete range of reports, from small ad-hoc reports to mission-critical operational reports. After you create your database query, you can use this visual layout capabilities of the section to drag and drop columns, expressions, charts, pivot tables, logos, and graphic objects to quickly design and customize your reports.

Report Section Elements

The Report section differs slightly from other sections in order to provide you with as robust a report designer as possible. Key differences include:

- **Expression Line**—Accessed by way of the Expression button on the Section title bar, the Expression line enables you to build common computed expressions using JavaScript.

- **Catalog pane**—Contains all of the of drag-and-drop elements that you use to create a custom report, including:
  - **Query**—Contains all the sections associated with a selected query, including Results, Pivot, and Chart sections. You can drag individual Results columns from the Results and Table sections to a report page, as well as entire Pivot and Chart sections to create Smart Reports.
Graphics—Contains standard vector graphics text labels, and pictures (bitmaps only). Vector graphics include: line, horizontal line, vertical line, rectangles, round rectangles, and ovals. For vector graphics, select Report > Insert Graphics. For a .BMP, .JPEG, .GIF, .JPG or .PNG, select Report > Picture.

When an Interactive Reporting document (BQY) is created and saved using 9.3.x releases, all images are saved in centralized format (the Resource Manager). As a result, the images cannot be read or displayed in prior releases of Interactive Reporting. This is because the relocation and rationalization of the images are not understood by releases prior to 9.3.x.

The exception is images from a document saved in a pre 9.3 Release, which have been referenced once: not copied, merged or duplicated, that is, placed in Dashboard or Report workspace as a Picture graphic in traditional fashion.

To retain compatibility with earlier releases, you can run the RevertImageResources script. This script provides a facility to undo the relocation and image merging, and thereby return the Interactive Reporting document to the pre-9.3 pre-Resource Manager format. This script is included with the 9.3. Release of Dashboard Development Services. It can also be downloaded from the Hyperion Developer Network. This script can only be used on the desktop, and not in the Workspace, as it relies on the COM feature of Interactive Reporting Studio.

Certain new features make documents ineligible for conversion to the non-Resource Manager format: for example if the 9.3 Interactive Reporting document has Bubble and Scatter charts, then these are lost when the Interactive Reporting document is opened in the older version of Interactive Reporting Studio. For information on running the RevertImageResources script, see the Hyperion System 9 BI+ 9.3. Readme.

Fields—Contains predefined fields that can be dragged to various areas of the report to enhance the look and feel of the report. Fields include items such as date and time, the report name, or page number.

To use any of these elements, simply drag them to the desired report component band.

Data Layout—Consists of the Groups data layout and Table data layout. The Table data layout is divided into the Dimension and Fact panes.

Groups Data Layout—Defines the overall or highest levels used to group data in a report. When you designate an item to serve as a group header (also known as a break value), you are instructing Interactive Reporting to organize the rest of the data in repeating collections of records according to the group header.

Dimensions pane in Table Data Layout—Includes descriptive information such as a column in a table that is included in the body of the report.

Facts pane in Table Data Layout—Includes the measurable or quantifiable data as a column in a table included in the body of the report. Interactive Reports calculates and inserts subtotals for each fact column.

Interactive Reporting quantifies values by group header and dimension. If you have a descriptive numeric value that should not be calculated, such as Retail Price or Target Sales, use it as a group header or table dimensions instead of a fact.
Report Section Toolbar

The Report Section toolbar provides icons that enable you to quickly maneuver multiple report objects.

- **Align**—Aligns several objects at the same time. Objects are aligned to the first object you select. Select the first object, then hold down the Control key and select the remaining objects. Click the arrow on the Align icon and select an alignment option: left, center, right, top, middle, or bottom.

- **Make Same Size**—Resizes the selected objects to the same size. Objects are resized to match the first object you select. Select the first object, then hold down the Control key and select the remaining objects. Click the arrow on the Make Same Size icon and select a resizing option: width, height, or both.

- **Layer**—Stacks a single object in relative position to other objects. Layer includes four rearrangement options: Send To Front, Send To Back, Bring Forward, and Send Backward. Use this feature to layer multiple objects so that only the sections of the objects you want visible are shown.

- **Spring Objects**—Maintains relative vertical spacing between dynamic objects. That is, you can spring one object to another so that if the first object is moved, increased or diminished, the second object moves in the same flow. To select an object, select the object, hold down the Control key and select the remaining objects. Click the Spring Objects icon to spring the objects. To remove spring from objects, select the objects, and click Spring Objects again.

- **Zoom**—Sets the magnification level of the report. Options include: whole page, page width, or a percentage of magnification based on 100%.

| Rulers | Horizontal and vertical rulers help you line up items based on precise units of measure. To select the ruler measurement, click the measure indicator at the intersection of the rulers. You can select inches, centimeters, or pixels. To toggle the ruler, select Report > Rulers. A check mark next to the Ruler menu item indicates that the ruler is turned on. |
| Grid | The layout grid automatically snaps all objects to the closest spot on the grid. To toggle the grid, select Report > Grid. A check mark next to the Grid menu item indicates that the grid is turned on. |
| Design Guides | Design guides are similar to grids in that objects automatically snap to line up with the design guides. Design guides are placed at user-specified locations in the work area. You can use both horizontal and vertical design guides. A design guide is displayed as a blue line across the work area, and you can drag the guide to any new location. If rulers are turned on, you can click and drag design guides from both the horizontal and vertical rulers. To toggle a design guide, select Report > Design Guides. A check mark next to the Design Guides menu item indicates that design guides are turned on. |

Report Section Title Bar

The Report Section title bar consists of single-click buttons that enable you to show or hide a specific Report Designer function. These buttons include:
Expression—Toggles the Expression Builder bar, which enables you to build common computed expressions and JavaScript expressions.

Groups—Toggles the Group data layout, which enables you to specify report categories, such as Quarter or Item description.

Sort—Toggles the Sort bar, which enables you to rank data.

Table—Toggles the Table data layout, which enables you to insert facts and dimensions into report bands.

Arrows—The back and forward arrow keys enables you to move back and forward between sections.

Tip:
All data layouts and lines on the section title bar can be detached, dragged, floated and docked from any fixed position.

Expression Line

Use the Expression Line to apply and display aggregate functions and computing fields. For each item in a report, you can display its JavaScript syntax and modify it to fit your own needs.

<table>
<thead>
<tr>
<th>Data Function</th>
<th>Shows available data functions that can be applied to table columns.</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>Cancels and removes a formula. This icon is displayed only when you enter syntax.</td>
</tr>
<tr>
<td>+</td>
<td>Accepts and applies the formula. This icon is displayed only when you enter syntax.</td>
</tr>
</tbody>
</table>

Edit Bar—Used to display, enter, and edit a JavaScript expression.

Expression Syntax

The following table lists the default syntax for Report section items.
Table 64  Report Expression Syntax

<table>
<thead>
<tr>
<th>Report Element</th>
<th>Syntax</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Table Dimension</strong></td>
<td><code>CurrBreak.Value[&quot;Column Name&quot;]</code></td>
</tr>
<tr>
<td></td>
<td>“Column Name” refers to the dimensional column name. The column name can be modified.</td>
</tr>
<tr>
<td><strong>Table Fact</strong></td>
<td><code>Tables[&quot;Section&quot;].Columns[&quot;Column Name&quot;].Sum[currBreak]</code></td>
</tr>
<tr>
<td></td>
<td>“Section Name” refers to either the Results or Table section. Column Name refers to the fact column name. Sum refers to the return of underlying values and can also be an applied Data functions such as Avg, Max, and Min.</td>
</tr>
<tr>
<td><strong>Group Label</strong></td>
<td><code>CurrBreak.Value[&quot;Column Name&quot;]</code></td>
</tr>
<tr>
<td></td>
<td>“Column Name” refers to the dimension or fact column name.</td>
</tr>
<tr>
<td><strong>Group Fact</strong></td>
<td><code>Tables[&quot;Section&quot;].Columns[&quot;Column Name&quot;].Sum[currBreak]</code></td>
</tr>
<tr>
<td></td>
<td>“Section Name” refers to either the Results or Table section. “Column Name” refers to the fact column name.</td>
</tr>
<tr>
<td></td>
<td>To apply a break at the parent level (the highest level), use the following syntax:</td>
</tr>
<tr>
<td></td>
<td><code>Tables[&quot;Section Name&quot;].Columns[&quot;Column&quot;] .Sum[currBreak. Parent]</code></td>
</tr>
</tbody>
</table>

**Snapping Together Expression Syntax**

You can concatenate report expression syntax with other JavaScript expressions to customize the content of labels, facts, and dimensions.

For example, if you wanted a group header to show a union of the Total label and the amount, you could insert a field in the Expression line to concatenate Total with the table fact syntax.

```
"Total " + Format (Tables("Results"),Columns("Amount"),Sum(currBreak), ",.##0")
```

1996

Or, you could insert a field to show the sum (or any other data function) of the column divided by the sum of the parent level expressed as a percentage.

```
Format (Tables("Results"),Columns("Amount"),Sum(currBreak) / Tables("Results"),Columns("Amount"),Sum(currBreak.parent), ",.##0")
```

**Quarter 1** 23%

If you plan to use this feature, add the labels in a computed field. For information on how to add a computed field, see “Adding Computed Items” on page 5-34.
Tip:
In a Report section, you often concatenate some text with a value. For example, you might want to see “Total Sales: $1,234.56” in a group footer instead of just the number. However, since you have concatenated text to the beginning of the number, you cannot set the number format in the traditional way (by using the Properties dialog box). Since you have a concatenated object, you need to set the number format using JavaScript.

To set a number format on a concatenated item, use the following syntax:

`Format(number, mask)`

where `number` is the value to format and `mask` is the number format mask to apply. Using the example above, your completed expression would be displayed as follows:

"Total Sales: " + Format(Tables("Results").Columns("Sales").Sum(currBreak), "$#,##0.00")

Creating a Custom Report

The Report section uses tables as the basic building blocks of custom reports. Tables contain columns of dimensions and facts as determined by the Results items you place in the Dimensions and Facts panes in Table data layout.

To create a basic report:


Interactive Reporting creates a new Report section and inserts a blank table in the Body band of the report in the Content pane.

2. If desired, select Report > Section Boundaries to view the bands for the report components.

If the Table data layout is not visible, click Table on the Section title bar to open the Table data layout.

3. Drag Results items from the Query sections of the Catalog pane to the Table data layout.

Tip:
The Table data layout has two panes – Dimensions and Facts. Use the Dimensions pane to build dimension (label) columns, such as Month, Region, or Product Line. Use the Facts pane to build the facts (numeric values) in the report, such as Amount Sales or Units Sold. Results and Table items added to the Facts pane are totaled automatically.

Report Components

The Report Designer offers a variety of dynamic tools for constructing the report you want to create with all of the components you want it to contain. Understanding how these
components perform and how they integrate with Report section elements is fundamental to building a successful report.

Report pages are structured areas, or bands, of information. Each band contains a different report component and can be customized to include other report elements such as graphic objects, predefined fields, computed fields, charts, and pivot tables.

A components of the report are:

- **Body**—Contains one or more tables whose contents are based on the items listed in the Table Dimensions and Table Facts panes of the data layout. Every report has a body that holds a table of data. Tables can be based on the same or different results sets within the document.
- **Report Group Headers**—Categorize data into repeating collections of records organized according to the header band.
- **Report Header/Footer**—Fully customizable summary bands of information. Report headers print only on the very first page of the report. Report footers print only on the very last page.
- **Page Header/Footer**—Contain data that is repeated on every page, such as page numbers. These bands are also fully customizable.

### Table Column Formatting Options

The following table lists the column formatting options available in Interactive Reporting.

<table>
<thead>
<tr>
<th>Options</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Changing the Column Name Heading (Title)</strong></td>
<td>To modify the column title, click <strong>Expression</strong> on the Section title bar, then select the column title that you want to modify. In the Expression line, type the new title between the quotation marks (“ ”) and click the check mark.</td>
</tr>
<tr>
<td><strong>Hide/Show Column Name Heading (Title)</strong></td>
<td>To toggle the display of column titles, select <strong>Column Titles</strong> on the shortcut menu. A check mark is displayed next to Column Titles to indicate that column titles are visible. Select this option again to clear the check mark and hide column titles from view.</td>
</tr>
<tr>
<td><strong>Remove Column</strong></td>
<td>To remove a selected column from the report (and Table data layout), select <strong>Remove Column</strong> on the shortcut menu. This option is available for dimension and fact columns. Items should be removed with caution as computed items may draw data values from the deleted item.</td>
</tr>
<tr>
<td><strong>Hide/Show Column Total</strong></td>
<td>To toggle the display of column totals, select <strong>Show Column Totals</strong> on the shortcut menu. A check mark is displayed next to Column Totals to indicate that column totals are visible. Select this option again to clear the check mark and hide column totals from view. This option is available only for fact columns.</td>
</tr>
<tr>
<td><strong>Select Column</strong></td>
<td>Click anywhere inside the column.</td>
</tr>
<tr>
<td>Options</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Suppress Duplicates</strong></td>
<td>To suppress the duplicate values for a column, select the column and select Format &gt; Suppress Duplicates. Use this feature if you want to display only the first instance in the column of a duplicate value when individual database records include redundant information. This feature is especially useful if records are associated with the same date, location or customer.</td>
</tr>
<tr>
<td><strong>Text Wrap</strong></td>
<td>To wrap text within a column, select the column and select Format &gt; Text Wrap.</td>
</tr>
<tr>
<td><strong>Sort Ascending/Descending</strong></td>
<td>To sort column values, click Sort Ascending or Sort Descending on the Table menu, shortcut menu, or standard toolbar.</td>
</tr>
<tr>
<td><strong>Reordering Columns</strong></td>
<td>If you want the columns in the table to be displayed in a different order, drag the item in order of how you want it to be displayed in the Table data layout. You can also select the column in the actual report and drag it to a new position in the report.</td>
</tr>
</tbody>
</table>

**Inserting Additional Tables in a Custom Report**

A custom report may contain multiple tables, each originating from the same or different result sets in the document. Multiple tables in one band are a powerful way to compare values.

➤ To add multiple tables to one report:

1. **Select Report > Insert Table.**
   
The cursor changes to a crosshair.

2. **In the Body band, left-click and hold your left mouse button to position your cursor where you want to insert the table, and then drag to create the table.**
   
   A numbered table is inserted.

3. **Drag the Results items from the Query sections of the Catalog pane to the Table2 data layout.**
   
   Each new table that you insert has its own corresponding dimensions and facts pane in the Table data layout.

**Adding Report Group Headers**

A report group is the topmost level at which you can structure data in a report. When you drag an item from the Catalog pane into the Groups data layout, Interactive Reporting supplies a report group header band automatically and adds a label inside the band that identifies the group.

For example to show purchases by state, each state would serve as a report group header in the report. You can place multiple items in one header or add a multiple levels of group headers.

This step is not necessary to create a report, but it may help you to better organize the content of the report. You can show additional headings, graphics, and totals in the report group header band.
To create a report group header:

1. If the Groups data layout is not visible, click **Groups** on the Section title bar to open the Groups data layout.
2. Drag the item on which you want to group data from the Catalog pane to the Report Group1 field in the Groups data layout.
   
The selected item automatically populates the group header.

To modify a report group header:

1. Select **Report > Section Boundaries** to display header/body/footer regions.
2. Drag the an item from the Catalog pane to the group header band.
3. Resize and format the group header as desired.

**Tip:**

Modify a report group when you want to show additional headings, graphics, and totals in the group header band.

To add a text label to report group header:

1. Select **Report > Section Boundaries** to display header/footer regions.
2. Drag the Text Label tool from the Graphics Folder in the Catalog pane to the Group Header.
   
   A Text Label box is displayed.
3. Highlight the text in the Text Label box and type the information that you want to be displayed in the box.
4. Click **Properties** on the shortcut menu to change the border, background or alignment of the text label.
   
   The Properties dialog box is displayed.
5. Select the tab that corresponds to the style you want to change and click **OK**.
6. Move the text label by clicking and dragging it to the desired position.

**Tip:**

Use text labels to identify values shown in a numeric group header.

To repeat report group headers:

1. Select the group header band that you want to repeat.
2. Click **Repeat Header** on the shortcut menu.
   
   The selected group header displays across pages whenever the body band is broken across pages.

**Tip:**

Repeat report groups if the body portion of your report section spills across multiple pages. When you repeat a report group, the group header displays on each body page.
Adding Report Group Footers

In addition to header bands, Report Groups can also have footer bands.

➤ To turn on a footer band for a group:

1 Select the group in the Group data layout.
2 Right-click on the group to display the shortcut menu.
3 Select Footer from the shortcut menu.

There should now be a footer band for each group band. The footer band is displayed after all sub-group and body bands.

Tip:
The footer band for a group is a good place to add group totals.

Inserting Report Headers and Footers

Report headers and footers are treated as normal report areas enabling full customization of the contents, including the introduction of other report elements (Pivots, Charts), text labels and computed fields. Typically Report headers and footers are summarizing bands of information. Report headers print only on the first page of a report. Report footers print only on the last page of a report.

Tip:
Do not confuse report headers and footers with report group headers. Report group headers categorize data into repeating collections of records in a header band, based on the Results columns in the Groups data layout.

➤ To view and create a report header or footer:

1 Select Report > Section Boundaries to view the bands for the report components.
2 Select Report > Headers And Footers > Option.

You can view the report header, the report footer, or both. The Report Header band is displayed on the first page of the report. The Report Footer band is displayed on the last page.

● To insert a report header, select Report Header.
● To insert a report footer, select Report Footer.
● To insert both report headers and report footers, select Show Both.

The Report Header band is displayed on the first page of the report. The Report Footer band is displayed on the last page of the report.

3 Type the information to be displayed in the report header or footer, or drag objects from the Catalog pane to the Report Header or Report Footer band.
The selected item populates the report header or footer automatically.

Review the following table for information on how to insert items into the Report Header or Report Footer band.

<table>
<thead>
<tr>
<th>Item to Insert</th>
<th>Steps to Take</th>
</tr>
</thead>
<tbody>
<tr>
<td>text</td>
<td>Select Text Label from the Graphics folder, and drag the text label to the header/footer area.</td>
</tr>
<tr>
<td>lines, rectangles, or oval graphic</td>
<td>Select the graphic from the Graphics folder and drag it to the report header/footer area, or select Report &gt; Insert Graphic.</td>
</tr>
<tr>
<td>picture graphic</td>
<td>Select the picture from the Graphics Catalog in the Catalog pane and drag it into the report header or footer area. You can also select Report &gt; Picture, use the left mouse button to draw the area in which you want the picture to be displayed, and select an image from the Select Image dialog box. When an Interactive Reporting document (BQY) is created and saved using 9.3.x releases, all images are saved in a centralized format (the Resource Manager). As a result, the images cannot be read or displayed in prior releases of Interactive Reporting. This is because the relocation and rationalization of the images are not understood by releases prior to 9.3.x. The exception is images from a document saved in a pre 9.3 Release, which have been referenced once: not copied, merged or duplicated, that is, placed in Dashboard or Report workspace as a Picture graphic in traditional fashion. To retain compatibility with earlier releases, you can run the RevertImageResources script. This script provides a facility to undo the relocation and image merging, and thereby return the Interactive Reporting document to the pre-9.3 pre-Resource Manager format. This script is included with the 9.3. Release of Dashboard Development Services. It can also be downloaded from the Hyperion Developer Network. This script can only be used on the desktop, and not in the Workspace, as it relies on the COM feature of Interactive Reporting Studio. Certain new features make documents ineligible for conversion to the non-Resource Manager format: for example if the 9.3 Interactive Reporting document has Bubble and Scatter charts, then these are lost when the Interactive Reporting document is opened in the older version of Interactive Reporting Studio. For information on running the RevertImageResources script, see the Hyperion System 9 BI+ 9.3. Readme.</td>
</tr>
<tr>
<td>Smart Chart/Pivot report</td>
<td>Select a prebuilt Pivot report or Chart and drag it into the report header, group header, body, or footer area. Note the following:</td>
</tr>
</tbody>
</table>
## Inserting Page Headers and Footers

Page headers and footers are treated as normal report areas enabling full customizing of the contents, including the introduction of other report elements (Pivots, Charts), text labels and computed fields. Typically, Page headers and footers enable you to specify data that is repeated on every page, such as a page number.

To insert a page header or page footer:

1. **Select Report > Section Boundaries** to view the bands for the report components.
2. **Select Report > Headers And Footers > Option.**
   - You can view a page header, a page footer, or both.
   - To insert a page header, select **Page Header**.
   - To insert a page footer, select **Page Footer**.
   - To insert both page headers and page footers, select **Show Both**.
3. **Type the information to be displayed in the report header or footer, or drag objects from the Catalog pane to the Page Header or Page Footer band.**

The selected item automatically populates the report header or footer. Review the following table for information on how to insert items into the Page Header or Page Footer band.

### Steps to Take

<table>
<thead>
<tr>
<th>Item to Insert</th>
<th>Steps to Take</th>
</tr>
</thead>
<tbody>
<tr>
<td>Any Chart/Pivot dropped into a header/footer that is “owned” by data is focused by that piece of data.</td>
<td>Select a field from the Fields folder and drag it to the report header, group header, body, or footer area, or select <strong>Report &gt; Insert Field</strong>.</td>
</tr>
<tr>
<td>An embedded Chart object retains the Chart size, component placement and property settings (Smart Scaling, Auto Resize, minimum font size) of the original chart in the Chart section. Any changes you make to the size of the embedded chart in the Report section is not transferred to the originating chart.</td>
<td>Select a field from the Fields folder and drag it to the report header or footer area, or select <strong>Report &gt; Insert Predefined Fields</strong> and click a field from the drop-down list box. Normally, fields are used in page headers and footer sections.</td>
</tr>
</tbody>
</table>

### Inserting Page Headers and Footers

Page headers and footers are treated as normal report areas enabling full customizing of the contents, including the introduction of other report elements (Pivots, Charts), text labels and computed fields. Typically, Page headers and footers enable you to specify data that is repeated on every page, such as a page number.

To insert a page header or page footer:

1. **Select Report > Section Boundaries** to view the bands for the report components.
2. **Select Report > Headers And Footers > Option.**
   - You can view a page header, a page footer, or both.
   - To insert a page header, select **Page Header**.
   - To insert a page footer, select **Page Footer**.
   - To insert both page headers and page footers, select **Show Both**.
3. **Type the information to be displayed in the report header or footer, or drag objects from the Catalog pane to the Page Header or Page Footer band.**

The selected item automatically populates the report header or footer. Review the following table for information on how to insert items into the Page Header or Page Footer band.

**Tip:**

You can hide the page header on the first page of a report and show it for the rest of the pages in your report by typing the following code in the “Expression Line” for the page header object:

```java
if (PageNm == 1)
```
{' '}
else
{"Query Processed: "+Format(newDate(), "d-mmm-yyyy")};

**Inserting Page Breaks**

You can insert a page break before or after a report group header.

➤ To toggle page breaks:

1. Select Report > Section Boundaries to view the bands for the report components.
2. Select a report group header.
3. Select Insert > Page Break Before or Page Break After.

A check mark is displayed next to the selected page break option to indicate that it is active. Select this option again to clear the check mark and remove the page break.

<table>
<thead>
<tr>
<th>Item to Insert</th>
<th>Steps to Take</th>
</tr>
</thead>
<tbody>
<tr>
<td>text</td>
<td>Select Text Label from the Graphics folder, and drag the text label to the header/footer area.</td>
</tr>
<tr>
<td>lines, rectangles, or oval graphic</td>
<td>Select the graphic from the Graphics folder and drag it to the report header / footer area, or select Report &gt; Insert Graphic.</td>
</tr>
</tbody>
</table>
| picture graphic             | Select the picture from the Graphics Catalog in the Catalog pane and drag it into the report header or footer area. You can also select Report > Picture, use the left mouse button to draw the area in which you want the picture to be displayed, and select an image from the Select Image dialog box. When an Interactive Reporting document (BQY) is created and saved using 9.3.x releases, all images are saved in a centralized format (the Resource Manager). As a result, the images cannot be read or displayed in prior releases of Interactive Reporting. This is because the relocation and rationalization of the images is not understood by releases prior to 9.3.x. The exception is images from a document saved in a pre 9.3 Release, which have been referenced once: not copied, merged or duplicated, e.g. placed in Dashboard or Report workspace as a Picture graphic in traditional fashion. To retain compatibility with earlier releases, you can run the RevertImageResources script. This script provides a facility to undo the relocation and image merging, and thereby return the Interactive Reporting document to the pre-9.3 pre-Resource Manager format. This script is included with the 9.3. Release of Dashboard Development Services. It can also be downloaded from the Hyperion Developer Network. This script can only be used on the
<table>
<thead>
<tr>
<th>Item to Insert</th>
<th>Steps to Take</th>
</tr>
</thead>
<tbody>
<tr>
<td>desktop, and not in the Workspace, as it relies on the COM feature of Interactive Reporting Studio. Certain new features make documents ineligible for conversion to the non-Resource Manager format: for example if the 9.3 Interactive Reporting document has Bubble and Scatter charts, then these are lost when the Interactive Reporting document is opened in the older version of Interactive Reporting Studio. For information on running the RevertImageResources script, see the Hyperion System 9 BI+ 9.3. Readme.</td>
<td></td>
</tr>
<tr>
<td>Smart Chart/Pivot report</td>
<td>Select a prebuilt Pivot report or Chart and drag it into the report header, group header, body, or footer area. Note that any Chart/Pivot dropped into a header/footer that is “owned” by data is focused by that piece of data.</td>
</tr>
<tr>
<td>empty field (for a computed field)</td>
<td>Select a field from the Fields folder and drag it to the report header, group header, body, or footer area, or select Report &gt; Insert Field.</td>
</tr>
<tr>
<td>common report values (such as page number or page total)</td>
<td>Select a field from the Fields folder and drag it to the report header or footer area, or select Report &gt; Insert Predefined Fields and click a field from the drop-down list box. Normally, fields are used in page headers and footer sections.</td>
</tr>
</tbody>
</table>

### Adding Other Report Elements

You can resize report band items and use the tools available on the Format toolbar to change properties such as number, font, alignment, border, and background.

You can also add graphic items and fields from the Catalog pane to enhance your report. For example, use the Text Label tool to add text labels that identify values for numeric report group headers. Review the following topics for information on:

- “Working with Graphic Elements” on page 304
- “Working with Fields” on page 306
- “Modifying Filter Fields” on page 309

### Working with Graphic Elements

Interactive Reporting provides a complete set of graphic elements to assist you in designing presentation-quality reports (see Table 66, “Report Section Graphic Elements,” on page 305). Lines, rectangles and ovals are considered vector graphics. Vector graphics consist of commands for creating the measures and shape of each line, rectangle, arc, and so on. The resolution of the output device defines the look of the vector graphic, since a vector graphic has no fixed resolution. This property enables you to resize the vector graphic without changing its resolution. Since a vector graphic contains only the instructions for creating an image, it requires less disk space.
Pictures are considered bitmap graphics. A bitmap graphic consists of pixels, which have the appearance of small points. In computer memory, a pixel is shown as one or more bits, containing instructions for color, density and appearance for each pixel shown. As a result, bitmaps use more disk space and have a fixed resolution. If you resize a bitmap image, it may distort the original image.

When an Interactive Reporting document (BQY) is created and saved using 9.3.x releases, all images are saved in a centralized format (the Resource Manager). As a result, the images cannot be read or displayed in prior releases of Interactive Reporting. This is because the relocation and rationalization of the images is not understood by releases prior to 9.3.x.

The exception is images from a document saved in a pre 9.3 Release, which have been referenced once: not copied, merged or duplicated, e.g. placed in Dashboard or Report workspace as a Picture graphic in traditional fashion.

To retain compatibility with earlier releases, you can run the RevertImageResources script. This script provides a facility to undo the relocation and image merging, and thereby return the Interactive Reporting document to the pre-9.3 pre-Resource Manager format. This script is included with the 9.3. Release of Dashboard Development Services. It can also be downloaded from the Hyperion Developer Network. This script can only be used on the desktop, and not in the Workspace, as it relies on the COM feature of Interactive Reporting Studio.

Certain new features make documents ineligible for conversion to the non-Resource Manager format: for example, if the 9.3 Interactive Reporting document has Bubble and Scatter charts, then these are lost when the Interactive Reporting document is opened in the older version of Interactive Reporting Studio. For information on running the RevertImageResources script, see the Hyperion System 9 BI+ 9.3. Readme.

To insert a graphic object from the Catalog pane:
1. Go to the Catalog pane and expand the folder containing the desired graphic object.
2. Click the graphic object; then, drag and drop the object into the Contents pane.

To insert a graphic object from the Report menu:
1. Select Report > Insert Graphic.
2. Select a graphic object from the menu that is displayed.
3. Click the Contents pane to insert the graphic.

<table>
<thead>
<tr>
<th>Table 66</th>
<th>Report Section Graphic Elements</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Element</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>Line</td>
<td>Creates a line that you can rotate.</td>
</tr>
<tr>
<td>Hz Line</td>
<td>Creates a horizontal line.</td>
</tr>
<tr>
<td>Vt Line</td>
<td>Creates a vertical line.</td>
</tr>
<tr>
<td>Rectangle</td>
<td>Creates a rectangle.</td>
</tr>
</tbody>
</table>
To insert a graphic object, use one of the following options:

- Expand the folder in the Catalog pane that contains the desired graphic object; then, drag and drop the object into the Contents pane.
- Select Report > Insert Graphic, select a graphic object from the menu that is displayed, and click the Contents pane to insert the graphic.

### Working with Fields

Interactive Reporting provides a computable field and predefined fields to assist you constructing and producing reports (see Table 67, “Report Section Fields,” on page 306). You can drag and drop these fields anywhere within the report page, body, report group header, report header/footer, and page header and footer. You can also customize how numbers, dates, time, and text fonts are displayed in your report. For numbers, you can use commas, decimals place, dollar signs or percentage symbols. For text items, you can select fonts styles and sizes. For Query and Result filters, you can select specific filters.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Field</td>
<td>Inserts a computed field.</td>
</tr>
<tr>
<td>Query Filter</td>
<td>Inserts a selected query filter.</td>
</tr>
<tr>
<td>Result Filter</td>
<td>Inserts a selected result filter.</td>
</tr>
<tr>
<td>Query SQL</td>
<td>Inserts the last SQL sent to the database when you process a query.</td>
</tr>
<tr>
<td>Page Number</td>
<td>Inserts a page number.</td>
</tr>
<tr>
<td>Number of Pages</td>
<td>Inserts the total number of pages.</td>
</tr>
<tr>
<td>Page X of Y</td>
<td><strong>Note:</strong> All column data types default to string unless they are manually changed.</td>
</tr>
</tbody>
</table>
|                  | Note: The following behavior of this field when the section is deployed in Workspace:
<table>
<thead>
<tr>
<th>Field Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Last Saved</td>
<td>Inserts date on which the report was last saved in MM/DD/YYYY format.</td>
</tr>
<tr>
<td>Last Printed</td>
<td>Inserts date on which the report was last printed in MM/DD/YYYY format.</td>
</tr>
<tr>
<td>Date</td>
<td>Inserts and stamps the current date in MM/DD/YYYY format.</td>
</tr>
<tr>
<td>Time</td>
<td>Inserts and stamps current time in HH:MM:SS format.</td>
</tr>
<tr>
<td>Date &amp; Time</td>
<td>Inserts and stamps date and time in MM/DD/YYYY and HH:MM:SS format.</td>
</tr>
<tr>
<td>Date Now</td>
<td>Inserts the current date in MM/DD/YYYY format.</td>
</tr>
<tr>
<td>Time Now</td>
<td>Inserts the current time in HH:MM:SS format.</td>
</tr>
<tr>
<td>Date &amp; Time Now</td>
<td>Inserts the current date and time in MM/DD/YYYY and HH:MM:SS format.</td>
</tr>
<tr>
<td>File Name</td>
<td>Inserts an Interactive Reporting document (BQY) name.</td>
</tr>
<tr>
<td>Path Name</td>
<td>Inserts the full path name of the document.</td>
</tr>
<tr>
<td>Report Name</td>
<td>Inserts the report name.</td>
</tr>
</tbody>
</table>

**Working with Computed Fields**

A computed field contain a single value based on a calculation. You can create customized JavaScript expressions or modify JavaScript syntax for an existing report element. A computed field is repeated based on the report component in which it is inserted.

➢ To create a computed field:

1. **Select Report > Insert Field.**
   
The cursor changes to a crosshair.

2. **Left-click and hold your left mouse button to position your cursor in the report component where you want to insert the field, and then drag to create the table.**
   
A field labeled Empty Field is inserted.
3 Click the empty field to select it, and then enter JavaScript syntax in the Expression line.

You can copy and paste JavaScript syntax from existing report items into the Expression line to build the expression. To do this, select an existing item and copy the syntax in the Expression line. Then select the new field and paste the syntax into the Expression line.

4 When you have defined the equation, click the check icon.

The field displays the computed value.

A computed field repeats itself based on the band, header, or footer in which you insert it as shown below:

<table>
<thead>
<tr>
<th>Report Element</th>
<th>Repeats</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Group Header</td>
<td>Every Header band</td>
</tr>
<tr>
<td>Report Body</td>
<td>Every Body band</td>
</tr>
<tr>
<td>Report Header</td>
<td>Very first page</td>
</tr>
<tr>
<td>Report Footer</td>
<td>Very last page</td>
</tr>
<tr>
<td>Page Header</td>
<td>Every page</td>
</tr>
<tr>
<td>Page Footer</td>
<td>Every page</td>
</tr>
</tbody>
</table>

**Inserting Filter Values**

You can select and show filters applied in the Query and Results sections to aid in the visual construction and production of the report.

➤ To use a filter value in a report:

1 Select Report > Insert Predefined Field > Query Filter or Result Filter.

The cursor changes to a crosshair.

2 Left-click and hold your left mouse button to position your cursor in the report component where you want to insert the filter field, and then drag to create the field.

The Insert Filter Values dialog box is displayed.

3 In the Query or Result Sections list, select the section that contains the filters that you want to show.

A list of applied filters populates the Filter Names list.

4 Select the Filter Name that you want to use from the Filter Names list.

To show the operator used in the expression, select the Include Filter Operator check box.

5 Click OK.
Modifying Filter Fields

To modify the Filter field name or the values being shown, double-click the Filter field and modify the statement on the Expression line.

The JavaScript expression for the Filter Value field is displayed in the Expression line.

Working with a Report Page

The Report section gives you complete control of your report page setup and provides a number of features that assist you in designing effective, high-quality reports. Review these topics for information:

- “Displaying Rulers” on page 309
- “Using Grids” on page 309
- “Using Design Guides” on page 309

Displaying Rulers

Horizontal and vertical rulers help you line up items based on precise units of measure. Available units of measurement include inches, centimeters, and pixels, which you select by clicking the Measurement icon at the intersection of the top and left rulers.

To toggle the display of a ruler, select Report > Ruler.

A check mark is displayed next to Ruler to indicate the ruler is visible. Select this option again to clear the check mark and remove the ruler from view.

Using Grids

Use the layout grid to snap all objects to the closest grid spot automatically.

To toggle the display of the grid, select Report > Grid.

A check mark is displayed next to Grid to indicate the grid is visible. Select this option again to clear the check mark and remove the grid from view.

Using Design Guides

Design guides are horizontal and vertical lines that you place in your report to help you line up objects. Design guides are similar to grids in that objects automatically snap to align to the design guides.

If rulers are visible, click the ruler and drag one or more design guides from both the horizontal and vertical rulers.
To toggle the display of design guides, select Report > Design Guides.

A check mark is displayed next to Design Guides to indicate they are visible. Select the option again to clear the check mark and remove the design guides.

Setting Up a Report

Use the Report Page Setup command to specify report page parameters including, page size, margins, and columns. Review these topics for information:

- “Specifying Page Size” on page 310
- “Specifying Page Margins” on page 310
- “Setting Up Page Columns” on page 311

Specifying Page Size

When deciding on page size for your report, consider the type of output you want. Do you want to print the report or view it on screen? You can select printer dimensions or specify custom dimensions for your report pages.

➤ To specify page size:


The Report Setup dialog box is displayed.

2. Click the Page Size tab to view the Page Size page.

3. Select the page dimension option you want to use and click OK.

   - Use Printer Dimensions—Determines the printable area based on your printer. If you want to only print the report, select this option.
   - Use Custom Dimensions—Enables you to specify the width and height of your report page.

If you export reports to HTML pages, you can use this setting to control the number of “pages” that are included in each HTML file. Each page is exported to a single HTML file by default. To ensure that all pages in your report are contained in a single HTML file, set the page height to a large number.

Specifying Page Margins

Page margins are the blank space that borders the report area on your page. Since the report area can hold a variety of objects, such as page numbers, text, and lines, change the margin area to accommodate the size of your report area. Margins are set for an entire report.

➤ To specify page margins:

The Report Page Setup dialog box is displayed.

2 Click the **Margins** tab to view the **Margin** page.

3 Enter the Top, Bottom, Left and Right margin sizes and click **OK**.

Margins are measured in units of inches, pixels or centimeters. To change the margin units, click the Measurement icon located above the Content pane until you find the measurement unit that you want to use.

### Margin Measurements

Margins are set either in inches, pixels, or centimeters. Default margins for all four sides are:

<table>
<thead>
<tr>
<th>Type of Measurement</th>
<th>Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inches</td>
<td>.5</td>
</tr>
<tr>
<td>Pixel</td>
<td>.48</td>
</tr>
<tr>
<td>Centimeters</td>
<td>1.28</td>
</tr>
</tbody>
</table>

**Note:**

The default number of pixels depends on your screen resolution.

➤ To change how margins are measured:

Click the Measurement icon above the Contents pane until you find the desired measurement standard.

Measurement standard code definitions are: in=inches, px=pixels, and cm=centimeters.

### Setting Up Page Columns

You can set up a multicolumned report and have data flow from the bottom of one column to the top of the next column. You can specify as many columns as you want.

➤ To create a multi-columned report:

1 **Select Report > Report Setup.**

   The Report Setup dialog box is displayed.

2 **Click the Column tab to view the Column page.**

3 **Select the number of columns that you want to include on the page.**

   If you want to include more than four columns on the page, enter the number of columns in the Other field.
The column width and spacing are determined automatically based on the number of columns specified, the page size, and the page margins. Column width and spacing measurements are set in either inches, pixels, or centimeters.

**Column Measurements**

Column width and spacing measurements are set in either inches, pixels or centimeters. The default width and spacing dimensions for columns are:

<table>
<thead>
<tr>
<th>Type of Column Measurement</th>
<th>Column Number(s)</th>
<th>Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>Inches</td>
<td>1</td>
<td>8&quot;</td>
</tr>
<tr>
<td>Inches</td>
<td>2</td>
<td>3.75&quot;</td>
</tr>
<tr>
<td>Inches</td>
<td>3</td>
<td>2.33&quot;</td>
</tr>
<tr>
<td>Inches</td>
<td>4</td>
<td>1.63&quot;</td>
</tr>
<tr>
<td>Spacing</td>
<td></td>
<td>0.5&quot;</td>
</tr>
<tr>
<td>Pixels</td>
<td>1</td>
<td>768 px</td>
</tr>
<tr>
<td>Pixels</td>
<td>2</td>
<td>360 px</td>
</tr>
<tr>
<td>Pixels</td>
<td>3</td>
<td>224 px</td>
</tr>
<tr>
<td>Pixels</td>
<td>4</td>
<td>156 px</td>
</tr>
<tr>
<td>Spacing</td>
<td></td>
<td>48 px</td>
</tr>
<tr>
<td>Centimeters</td>
<td>1</td>
<td>20.33 cm</td>
</tr>
<tr>
<td>Centimeters</td>
<td>2</td>
<td>9.53 cm</td>
</tr>
<tr>
<td>Centimeters</td>
<td>3</td>
<td>4.13 cm</td>
</tr>
<tr>
<td>Centimeters</td>
<td>4</td>
<td>1.27 cm</td>
</tr>
<tr>
<td>Spacing</td>
<td></td>
<td>1.27 cm</td>
</tr>
</tbody>
</table>

**Enhancing Report Data**

You can apply filters, sorts, computations, and break totals to refine the data in your reports. Review the following:

- Sorting Report Items
- Adding Computed Items
- Creating Computed Columns
- Applying Data Functions
- Adding Totals
Hiding and Focusing on Reported Data

Sorting Report Items

Use the Sort icons to quickly sort a report group header or table column.

➤ To sort items quickly:

1. Drag the table column that you want to sort.
2. Click the Ascending or Descending icons on the standard toolbar.

➤ To apply sort conditions using the Sort line for report group labels:

1. If the Sort line is not already displayed, click Sort on the Section title bar.
   The Sort line is displayed below the Section title bar.
2. Click a report group label in the Content pane.
   The Sort line should read Report Groupx, where x = 1, 2, 3, and so on.
3. Drag a report group label from the content area to the Sort line.
4. Double-click the name of the report group label on the Sort line to toggle between ascending and descending sort order.

➤ To sort table columns:

1. If the Sort line is not displayed, click Sort on the Section title bar.
   The Sort line is displayed below the Section title bar.
2. Click anywhere within the table column (dimension or fact) in the Content pane.
3. Drag table dimensions or table facts from the Content pane to the Sort line.
4. Reorder the Sort items to determine the nested sort order.
5. Double-click the item in the Sort line to toggle between ascending and descending sort orders.

Adding Computed Items

Use the Add Computed Items command to build equations to compute totals, or to apply functions to existing values. Since a report may derive its values from a wide range of data sources (relational database queries, OLAP queries, imported data sets, and local-join queries), you select the Request item that you want to use from the applicable Results section.

➤ To add a computed item:

1. Select a table column and select Report > Add Computed Item.
   The Computed Item dialog box is displayed.
2. In the Column Name field, type a name that describes the computation.
The default name is Computed.

3 In the Tables list, select the results set on which to apply the computed item.

4 In the Columns list, select the column from which to compute the new data item.

Note that the columns available for reference are only the columns that exist in the results set that is the source for the rest of the table.

5 Modify the existing syntax of the table column you selected or define a new computed item by building an expression in the Formula pane.

Interactive Reporting uses JavaScript to compute data items. The JavaScript engine supported in Interactive Reporting does not accept European or non-US number formats for computing data items. More information about JavaScript can be found in *Hyperion System 9 BI+ Interactive Reporting Object Model and Dashboard Development Services Developer’s Guide, Volume 1: Dashboard Design*.

6 Click OK to apply the definition to the computed item column.

A new computed column is added to the Facts pane in the Table data layout for the selected table.

To add a free form computed item:

1 Select a table column and select Report > Add Computed Item, or click Add Computed Item on the shortcut menu.

   The Computed Item dialog box is displayed.

2 In the Column Name field, type a name that describe the free form computation.

3 Click the Formula field.

   The Formula field is activated.

4 Define a new computed item column by building an expression in the Formula field and click OK.

Creating Computed Columns

When looking for answers to basic business questions, raw data cannot always provide the information. For example, while a database might track sales figures, sometimes this information is much more valuable with reference to more complicated calculations such as cost of sales or profit margins.

You can anticipate these requirements, designing the internal database structure so that it makes such calculations as the raw data is collected. But at times you might not find the exact information you need because no one has needed it before. That is where Computed data items are most useful. You use these items to generate new information, usually from data that is already stored in the database. If the database does not offer this information, you can use Interactive Reporting to compute it.
Note:

Equations in the Report section are written in JavaScript syntax. When creating new data item columns, the Computed Item dialog box is not used. Instead, equations are defined in the Expression Line.

To create a computed column:

1 **Build a Tabular report.**

2 **Drag an item from the Catalog pane to the Table Facts pane of the data layout.**

   You cannot modify items added to the Table Dimensions pane of the data layout. Either add an item to the Table Facts pane or modify the item in the Results section.

   When selecting an item from the Catalog, select an item that is part of the equation for the computed item. For example, if Unit Sales is part of the equation, then drag Unit Sales to the Expression bar.

3 **Define the expression in the Expression Line.**

   Undock the Expression Line and resize the window if the equation extends beyond the viewing portion of the window.

   Change the data function applied to the item by selecting another data function from the pull-down list on the Expression Line.

   To apply an arithmetic equation to the expression, enter the applicable operators.

   Drag additional items from the Catalog pane to the Expression Line as needed. The JavaScript syntax for items are generated automatically.

4 **When the equation is complete, click the green check mark on the Expression Line.**

   The equation is calculated and the values are displayed in a column in the table.

   In the following example, the report determines which Store Managers receive $2,000 and $3,000 bonuses. A Level 1 Bonus of $2,000 is granted if the store's revenue exceeds $5,000.00. A Level 2 Bonus is granted if the store's revenue exceeds $10,000.00.
Applying Data Functions

A Dashboard enables you to determine the nature of the values represented in a Table Fact column in the Report section. Data functions retrieve underlying values and recalculate the value according to the type of data function that you specify. For example, the totals for a column are sums (the default data function) of the values in a column. You can use other data functions to change the totals to averages instead of sum.

Interactive Reporting provides a variety of prebuilt data functions that can be accessed from the Expression Line. You can also define your own data functions using JavaScript.

➤ To apply a prebuilt data function in the Report section:
1. Select a table fact.

   The totals in the column are recomputed to reflect the selected data function.

The following table lists the prebuilt data functions available in the Report section.

<table>
<thead>
<tr>
<th>Data Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Column Name</td>
<td>Returns the table column name.</td>
</tr>
<tr>
<td>Sum</td>
<td>Returns sum of underlying values. This is the default data function.</td>
</tr>
<tr>
<td>Average</td>
<td>Returns average of underlying values.</td>
</tr>
<tr>
<td>Count</td>
<td>Returns number of underlying values.</td>
</tr>
<tr>
<td>Maximum</td>
<td>Returns highest of underlying values.</td>
</tr>
<tr>
<td>Data Function</td>
<td>Description</td>
</tr>
<tr>
<td>------------------</td>
<td>--------------------------------------------------</td>
</tr>
<tr>
<td>Minimum</td>
<td>Returns lowest of underlying values.</td>
</tr>
<tr>
<td>% of Category</td>
<td>Returns group total percentage of the value.</td>
</tr>
<tr>
<td>Null Count</td>
<td>Returns number of nulls among underlying values.</td>
</tr>
<tr>
<td>Non-Null Count</td>
<td>Returns number of underlying values; null values are excluded.</td>
</tr>
<tr>
<td>Non-Null Average</td>
<td>Returns average of underlying values; null values are excluded.</td>
</tr>
</tbody>
</table>

➤ To set a data function to the default sum total:

1 Select a column that has been computed with a data function.
A pull-down list of valid data functions displayed.

2 Click on the Standard toolbar.

Adding Totals

By default tables show the total of any column placed in the Table Facts area of the data layout. However, sometimes you want the total to be in different places in the report: in a group header, group footer, or somewhere else in the body. You can do this by dragging a column from the section catalog and dropping it directly into the desired report section. Any column that you drag directly into the report is aggregated using the sum function based on the current break level. Note that you do not need to have the column exist in a table; you can drag any column in your results directly into the report.

Frequently, you may want to display different types of the same underlying values displayed side by side such as the average, maximum, or count values from the original data as shown below. In this case, data functions are particularly useful. By dragging the same column from the section catalog next to the original column and applying a data function, different aspects of the original data are revealed.

Applying Break Totals

➤ To apply a break total to a column in a report table:

1 Select a column and select Report > Break Total.
The Insert Break Total dialog box is displayed.

2 Select a break column from the At Every Break in drop-down list box.

3 Select the data function you want to apply from the Break Total Function drop-down list box.
See “Applying Data Functions” on page 5-35 for a list of data functions that you can use with break totals.
Select one or more columns on which to display the break total and click **OK**.

**Using True Totals for Computed Items**

Both report totals and break totals for tables can be calculated based on the column’s data function applied to surface values, or the underlying formula of the column. This option is controlled by the “True Total Computation” feature.

Underlying values refer to values from the original Results section. Surface values refer to values in the actual report section. The two approaches produce values that may be displayed incongruous with the values in the report.

To understand this difference between underlying and surface values, consider a simple table with two values of 20 and 30. Each of these is already a total of underlying values (20 = 8 + 12 and 30 = 10 + 20). An average of the underlying value yields the result of 12.5 = (8 + 12 + 10 + 20) / 4). An average of the surface value An average of the surface values yields the results 25 = (20 +30) / 2).

The True Total Computation enables you to standardize how total values in a computed column are calculated. When this feature is enabled, all total values are calculated based on the column’s data function applied to the surface values. When this feature is disabled, all totals are calculated based on the underlying formula of the column.

Pre Release 8.3.2 tables (legacy) tables use the calculation method where one total is calculated by the underlying computed item formula for its computation, and the other total applies the column’s data function to the surface values. You can change this behavior by also using the True Total Computation feature.

For legacy computed item columns, the “True Total Computation” feature shows the text “Legacy Total Computation” on the shortcut menu. This indicates that the column is using the inconsistent legacy total/break total computations.

To use true totals for the table total or break total in a computed column:

1. **Select the computed column to which you want to apply the true total.**
2. **On the shortcut menu, select True Total Computation.**

   When the True Total Computation is deselected, totals and break totals are computed using the underlying formula of the column.

To use true totals for the legacy table total or break total in a computed column:

1. **Select the legacy computed column to which you want to apply the true total.**
2. **On the shortcut menu, select Legacy Total Computation.**

   When you select a column, “Legacy Total Computation” is displayed on the shortcut menu. This means that the column is using an inconsistent total/break total computation.

   Selecting the Legacy Total Computation from the shortcut menu disables the feature.
An Alert dialog box indicates that the change cannot be undone: “This action cannot be undone. Are you sure you want to use True Total Computations for Total and Break Totals?”

3 Click Continue.

True Totals are enabled for both Totals and Break Totals of this column.

The next time that you display the shortcut menu, “True Total Computation” is displayed as an option in place of “Legacy Total Computation”. At this point, you can no longer apply the legacy behavior to this column.

Hiding and Focusing on Reported Data

A straightforward way to refresh your view of a report is to single out items for closer focus or remove some of the reported elements. This feature enables you to concentrate on particular items of interest. Hiding a group item removes the item from the report, but not from the data layout. Focusing a group item removes all items except the focused item from the report, but not the data layout.

Focusing on Items

To focus on a report item:

1 Select a group header and select Report > Focus On Item.

Interactive Reporting updates the report to focus on the data. A drill icon is displayed in the data layout next to the column you selected.

2 Select Chart > Focus On Items.

The chart is redrawn to display only the chart object(s) selected. A drill icon is displayed in the data layout next to the item(s) on which you have focused.

Show All Items

Use this feature when you need to return the display to the original view.

To return to the original chart display, select Chart > Show All Items.

Hiding Items

Use this feature when you need to hide a selected item.

To hide a group item, select a group header and select Report > Hide Item.

You can only select one group item to hide at a time.

Interactive Reporting updates the report to hide the data. A drill icon is displayed in the data layout next to the column that you selected to hide.
To restore all hidden groups, select **Report > Show Hidden Items**.
All items listed in the data layout are fully restored to view. The drill icon is displayed.

### Using Multiple Data Sources in a Report

You can create reports that contain data from multiple queries that use a wide range of data sources (relational database queries, OLAP server queries, imported data sets, and local join queries).

In a sense, the data in a single table correlates data across queries in a report, retrieving all rows from the table on the “left” and any rows from the table on the “right” that have matching values. Unlike actual joined topics in the Query section, the tables are not linked in the same sense. In the Report section, data is only in the report.

The rules for using multiple data sources in a single report are:

- Report group headers require a common value that belongs to all results or table sets be included in the report. If you introduce a unique value belonging to one results or table set, nothing is returned for any band below that group header.
- Table Dimensions items can originate from only one data source.
- Values from multiple data sources can be included in Table Facts.
- The Results column that you place as a table determines the Facts used. For example, you have two Results sets:

<table>
<thead>
<tr>
<th>Results 1</th>
<th>Region</th>
<th>Sales</th>
<th>Results 2</th>
<th>Region</th>
<th>Units</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>East</td>
<td>10</td>
<td></td>
<td>East</td>
<td>100</td>
</tr>
<tr>
<td></td>
<td>West</td>
<td>20</td>
<td></td>
<td>West</td>
<td>200</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>South</td>
<td>400</td>
</tr>
</tbody>
</table>

If you place “Region” from Results 1 into the Table Dimension and then drop Results 1: Sales and Results 2: Units into the Table Facts, you get the following table:

<table>
<thead>
<tr>
<th>Region</th>
<th>Sales</th>
<th>Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>East</td>
<td>10</td>
<td>100</td>
</tr>
<tr>
<td>West</td>
<td>20</td>
<td>200</td>
</tr>
</tbody>
</table>

- Note that the data from Results 2: South is not included.
- Smart charts and pivot tables added to a multiple data source report are subject to the same restrictions as described above.

To build a multiple data source report:

1. **Build the queries that you want to include in the report:**
Verify item data types and associated data values in source documents so that you know how to correlate them when creating the reports.

Build the Request line, and add server and local filters, data functions, and computations to the query as needed.

2 Click Process.

3 Select Insert > New Report.

A new report section is displayed.

4 In the Catalog pane, expand the file button of the Results or Table set.

5 If necessary, click Groups on the Section title bar to open the Group data layout.

A group header categorizes data into repeating collections of records in a header band.

6 If necessary, click Table on the Section title bar to open the Table data layout.

The Table data layout shows two panes: Table Dimensions and Table Facts. Use the Table Dimensions pane to build the column dimensions (labels) in the report. Use the Table Facts pane to build the numeric values in the report.

7 Build the group header band by dragging the item(s) from the Results sections of the Catalog pane to the Groups data layout.

8 Build the column dimensions of the report, drag the item(s) from the Query sections of the Catalog pane to the Table Dimensions in data layout pane.

9 Build the column numeric values of the report by dragging the item(s) from the Query sections of the Catalog pane to the Table Facts in data layout pane.

Creating Smart Reports

Smart reports enable you to embed charts and pivot tables into a report body. These reports show only the data that is relevant to the report section in which they are placed. For example, if the report is grouped by year and you insert a chart in the report body, the chart replicates automatically so that there is a chart for each year of data in the report. Each chart contains data specific to that year.

Tip:

Smart reports are refreshed whenever you reprocess the query. Also, if you change a chart or pivot table in its home section, the Smart report is updated and the changes are reflected in the Report section.

To embed a chart or pivot in a report:

1 In the Catalog pane, drag a pivot table or chart to either the report group header, page header, footer, or report body.

2 Size the pivot table or chart by clicking the embedded report until handles are displayed.

The pointer changes to a two-sided arrow.
Formatting Report Items

The following table lists formatting techniques you can use in the Report section.

<table>
<thead>
<tr>
<th>Format</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number</td>
<td>To modify the way numbers, dates and currency are displayed, select the item and select Format &gt; Number. When the Number tab are displayed, apply any desired changes.</td>
</tr>
<tr>
<td>Style</td>
<td>To modify the appearance of a report item, select the item and select Format &gt; Style &gt; Option. Options include bold, underline, italic, and so on.</td>
</tr>
<tr>
<td>Alignment / Justify</td>
<td>To modify the way an item is justified within a row or column, select an item, select Format &gt; Justify &gt; Option. Options include left, center, right, top, middle, and bottom.</td>
</tr>
<tr>
<td>Font</td>
<td>To modify the font of a report item, select the item and select Format &gt; Font. When the Font tab of the is displayed, apply any desired changes.</td>
</tr>
<tr>
<td>Keep Together</td>
<td>Instructs Interactive Reporting not to split a band when a break is encountered. When a break is encountered, the entire band is moved to the next page.</td>
</tr>
<tr>
<td>Keep With Next</td>
<td>Instructs Interactive Reporting to keep bands within a group together when paginating a report. If the lower band cannot fit on the page when the report is paginated, both bands are moved to the following page.</td>
</tr>
</tbody>
</table>

Converting Detail Reports from Versions Earlier than 6.0

You can use the Report Designer to modify Detail reports created in documents prior to version 6.0.

Version 6.0 and later opens Detail reports in read-only mode. To work with the contents of a Detail report, first convert it to the new Report Designer format.

**Note:**

You can convert Detail reports to Report Designer format only if the results set is saved with the document. If your results set is not saved with your document, reprocess the query and then select File > Save Results With Document.

➤ To convert a Detail report to Report Designer format:

1. In the Section catalog, select the Detail report.

   The detail report is displayed in the Content pane and a Detail menu is displayed on the menu bar.

2. Select Detail > Convert To Report.

   The Detail report is converted to the new Report Designer format and inserts a new Report section into the document. The original Detail report is left unchanged.
While every effort has been made to make the converted report as close as possible to the original Detail report design, you may need to clean up some reports, especially those that use computed items, multiple page headers/footers, or complex formatting.

Detail reports can be exported from the current version of the product to all of the previously supported formats, including Excel (.xls), Lotus 1-2-3 (.wks), tab-delimited text (.txt), comma-separated text (.csv), and HTML (.htm).

**Display Differences**

The page margins of a report created by the conversion process may be displayed smaller than in the original Detail report. This is because the new Report section is a WYSIWYG display that includes the unprintable area that exists outside of report margins. In version 5.x, Detail reports did not display or store information about the unprintable area. You can manually adjust the margin sizes in the converted report if needed.

If a Detail report contains multiple page header and footer sections, the current version of the product resolves these to a single page header and footer section during the conversion process. The height of the headers and footers in the converted report is equal to the combined heights of all headers and footers in the original Detail report. This may cause graphic and text objects in the headers and footers to overlap. You should manually adjust the properties, size, and/or position of these objects as necessary.

**Conversion of Detail Report Categories**

Detail Report categories from Detail reports are converted into report groups in the new Report section. The converted report displays Report Group Header and Footer sections if the corresponding category header and footer bands are visible in the original Detail report. The height of these header and footer sections remains the same. Detail report category labels are converted into JavaScript-based computed fields. Display properties remain unchanged.

**Conversion of Data Area**

To preserve as much of the original data and layout as possible, the conversion process translates the Detail report body information to a single table object in the body section of the converted report. This may lead to a loss of fidelity when converting complex or non-tabular style Detail reports.

**Conversion of Facts**

During report conversion, Detail report facts are added to the right of the dimension columns in the body section table. Number formats applied to Detail report facts are migrated to the converted report. If no number format exists, then the default number formats are applied to date, time, and number fields.
Because version 6.x uses JavaScript as the scripting, the conversion process does not automatically convert any computed facts contained in the Detail report. For computed items located in the Detail report body, the expression is omitted from the version 6.x table object. The conversion process may attempt to replace the computed column with another fact. If that occurs, simply delete the extraneous column.

For computed items located in a group header or footer, the code of the old scripting language expression is placed in a text field in the associated header/footer area to aid in manual conversion. Before you correct these placeholder items, Hyperion displays an error message in the field which reads `<string>(1):unterminated string literal`. The Detail report’s `Surface Math` option has no equivalent in the converted report and is ignored.

**Conversion of Smart Reports**

Version 6.x is able to convert Detail reports containing multiple `smart` charts and pivot tables. Some converted smart charts may look different or even invisible once converted and displayed in the 6.x Report section. This is due to some changes in the chart section that affect the way that charts are plotted within a given sized area. As a result, embedded charts may need to be resized manually by the user.

**Conversion of Graphic Objects**

Certain graphic object properties are no longer supported and are ignored during the conversion process. These properties include the shadow, sunken button, and raised button fill effects.

The width of line objects in Detail reports is expressed in whole pixels. When a report is converted, the pixel line widths are converted to the nearest point equivalent.

**Report Menu Command Reference**

The following provides a quick reference to the commands available on the Report menu and lists any related shortcuts.

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Keyboard Shortcut</th>
<th>Shortcut Menu</th>
</tr>
</thead>
<tbody>
<tr>
<td>Design Guides</td>
<td>Toggles the display of design guides.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Grid</td>
<td>Toggles the display of grid lines.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rulers</td>
<td>Toggles the display of rulers.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Section Boundaries</td>
<td>Toggles the display of section boundaries (bands).</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Page Margins</td>
<td>Toggles the display of page margins</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
<td>Keyboard Shortcut</td>
<td>Shortcut Menu</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>-------------------</td>
<td>---------------</td>
</tr>
<tr>
<td>Sort</td>
<td>Sorts the selected column values in ascending order (alphabetical or numeric).</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Data Function</td>
<td>Applies a prebuilt data function to the selected item.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Add Computed Item</td>
<td>Opens the Insert Computed Item dialog box.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Break Total</td>
<td>Opens the Insert Break Total dialog box.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Focus On Items</td>
<td>Updates the report to include only the selected data.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Hide Item</td>
<td>Hides the selected item from view.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Show Hidden Items</td>
<td>Restores the selected hidden item.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Show All Items</td>
<td>Updates the report to include all items removed by focusing.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Insert Table</td>
<td>Inserts a blank table in the report.</td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>Insert Field</td>
<td>Inserts a blank field in the report.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Insert Predefined Field</td>
<td>Inserts a predefined field in the report.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Insert Graphic</td>
<td>Inserts a vector graphic in the report.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Picture</td>
<td>Inserts a picture in the report.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove Selected Items</td>
<td>Removes the selected item from the report.</td>
<td>Del</td>
<td>*</td>
</tr>
<tr>
<td>Headers and Footers</td>
<td>Toggles the display of report and page headers and footers.</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
About Filters

When building a query, you usually do not want to see information on every product you sell. Instead, you want to see information that relates only to a specific product or product line. Similarly, you probably do not want to see this information for every year the product has been available, but only for recent periods.

When you set a filter in the Query section, data is returned from the database only if it meets the specified conditions. For instance, suppose you only want to see customers who spend more than $400,000 per year, or who buy gardening products in the Midwest. By applying a filter you are instructing the database to “give me only the data which satisfies the following conditions” (sales > $400,000; or, state is in Midwest Region and Product Line = Garden).

For example, a filter placed on Item Type (which includes an “=” (equal) operator and value “Keyboard”) returns only records associated with keyboard sales. Records associated with all other products are excluded from the Results set. The data set could be expanded to include modem sales records by adding the value “Modem” to the filter expression.

Similarly, the filter “> 5000” applied to the Amount Sold item filters out all sales transactions less than or equal to $5,000. Alternately, the expression “between 5000, 10000” would exclude transactions above $10,000 and eliminate any below or equal to 5,000.
Server versus Local Filter Processing

You apply filters in the Query or Results sections in basically the same way. The difference is in whether the filter is applied at the server or on your desktop.

- Server Filters in the Query Section
- Local Filters in the Results Section

Server Filters in the Query Section

A filter applied in the Query section instructs the database server to filter unwanted information from your request. Only the filtered data is returned to your desktop.

If your query is potentially large, and you are more or less certain of both the information you need and how to define the correct filters, it is best to apply filters in the Query section. By using the database server to filter the data, you return only the data you need across the network and onto your computer.

Another advantage of applying filters in the Query section is that you can apply a filter to any topic item in the data model, even if the item is not on the Request line. For example, if you request State, Year and Units Sold, you can filter any of these items. But you can also place a filter on Operating System (OS) if it is displayed in one of the topics in the work area. If you filter OS to the UNIX only, the server retrieves only sales information related to the UNIX operating system. You need not place OS on the Request line.

You can also filter computed items.

Local Filters in the Results Section

You can apply filters to columns to locally filter the data set in the Results section. Since the other reporting sections reference the results set, these local filters are disseminated to these sections.

Local filters are useful for managing your data set. If you do not need all information retrieved by your query, you can use a local filter to exclude data from view. Local filters are useful for temporary or hypothetical situations. You can always suspend or delete the filter to view the data and make it available for reporting.

Note:

You can only apply local filters to items on the Request line.

Filter Line

Using filters involves dragging an item from the Content pane to the filter line and then setting filters in Filter.

The Filter line is a drag-and-drop command line similar to the Request and Sort lines. Filtered items are displayed on the Filter line. You can move, size, dock, and hide the Filter line.
Filter indicators on the Filter line and next to the item in the topic. Filter line expressions available in the Query section Filter line:

- ()—Encloses suboperations.
- Var—Indicates a variable.
- AND—Retrieves data that meets both condition.
- OR—Retrieves data that satisfies either of two conditions.

**Filter Line Functionality**

In the Query section, the Filter line includes special functionality:

- The Filter line is an interface for building compound filter, which are multiple filters linked together to form complex filter equations. See Setting Compound Filters.
- The Filter line enables you to convert a filter to a variable filter, which prompts the user of the Interactive Reporting document file to select filters as the query is processed. See Setting Variable Filters.
- When placing a filter on a request item computed with a data function, a divider is displayed on the Filter line, and the Filter icon is placed to the right of the divider. The divider indicates that the filter is applied in the SQL Having clause.
- Subqueries and correlated subqueries which use the result from an inner query as the value of a filter in an outer query.

**Filter Line Syntax**

Syntax rules that apply to all Filter line expressions:

- By default, all equations are solved from left to right, with enclosed sub-operations evaluated first.
- AND is evaluated before OR.
- The AND operator retrieves data that meets both conditions. For example, if you query customers, and filter State to “Florida” AND Item Type to “Modem,” the data retrieved would apply only to customers buying modems in Florida, not to modems bought in Minnesota or keyboards bought in Florida.
- The OR operator retrieves data that satisfies either of two conditions. For example, if you filter State to “Florida” OR Item Type to “Modem,” the data retrieved would include Florida customers and any customers purchasing modems. It would not include customers purchasing keyboards (unless they lived in Florida), or customers in Minnesota (unless they bought modems).
- Suboperations allow you to override the default evaluation order, and may be required for certain operations involving both AND and OR operators.
Filter Controls

When applying a filter, you supply (or select) data values associated with a data item and use mathematical logic to apply the values as constraints.

Name—Descriptive name for the filter.

Include Nulls—Toggles the inclusion/exclusion of null values.

Not—Reverses the effect of an operator (for example, ‘Not >=’ is equivalent to <).

Operators—Comparison operators for the filter expression. Values that pass the comparison test will be included.

Edit field—Enter a value (or multiple values separated by commas), and click the check mark to add them to the custom values list to complete the filter definition. Click the "x" to erase the contents of the Edit field.

Note:
The Edit field is displayed only if you are entering a custom value.

Show Values—Shows all potential values from the database that are associated with the item.

Note:
Show values cannot be used in the Query section for filters on computed or aggregate values.

For more information, see:

- Defining Custom Values
- Multiple Filters and the Meta Topic
- Defining Custom Values

Custom Values—Lists potential values saved with the filter or read from a file. This feature enables you to select values from a predefined pool. You can create and save a custom list with each filter.

Custom SQL—Displays custom SQL for coding Filters directly in SQL.

Note:
The Custom SQL button is displayed only if you apply a filter in the Query section.

Select All—Selects all values displayed in the list of values.

Transfer—Adds selected values to the custom list.

Ignore—Temporarily suspends a filter without deleting it.
**Fractional Digits**—Specify the number of digits that you want to place to the right of the decimal point in an SQL numeric literal statement. The SQL statement uses this setting to determine which values to recognize. For example, if you type the filter value, 0.12345678, the SQL statement writes “where column = 0.12346” (the rounded value), but if you change the spinner to 8, then the SQL writes “where column = 0.12345678”.

**Advanced**—Displays Loaded Values settings and subquery options.

**Loaded Values Settings**—Toggles a custom values list to be read from a file or from the database. Change File allows you to specify the file name. If you read values from a text file, vertical tabs or paragraph markers must defilter each value. Use Show Values to display the file contents.

**Create Subquery**—Creates a subquery.

**Note:** If you access Filter from the Results section, the Advanced button is displayed as Options and the Create Subquery option is not displayed.

---

**Showing Values**

The Show Values command is a powerful option for selecting values to define filters. Show Values provides a list of values actually in the database (or in the data set in Results) and allows you to choose a value based on the data available.

This feature makes it possible to set filters accurately without being familiar with the contents of the database. Show Values is also advantageous when values change frequently and custom lists quickly become outdated.

To show values and define a filter:

1. **Select Show Values** on the Filter dialog box to retrieve the item’s values from the database.
2. Select values in the Values pane and click OK.
3. **Click Select All** or select values individually.

To create a snapshot of the values, click Select All and then click Transfer to move the variables to Custom Values.

**Tip:**

Because Show Values retrieves every value available, it is best not to use it in the Query section when the data item is large, consists mostly of values, or does not change frequently (for example, telephone numbers). In these situations, custom lists are sufficient and help avoid extra calls to the database. You administrator may disable Show Values if database hits are a concern.

**Note:**

Show Values cannot be used for filtering computed or aggregate items.
Defining Custom Values

Custom value lists are created by or supplied to Interactive Reporting. When users open the filter to choose new values, they can choose a filter from a custom list that has been supplied.

One reason to use custom lists with distributed Interactive Reporting document files is that many data items change rarely, if at all. For example, a Gender item has three consistent values (male, female, and unknown). A Product line item has many more values, but may only change every year or so. Data that changes rarely is said to have low cardinality. Under such circumstances, it makes sense for users to select from a custom values list, rather than continuously querying to show database values.

Custom lists are also useful when Setting Variable Filters. When an Interactive Reporting document file creator sets a variable filter, a custom list can be prepared and added to it. The subsequent users who sets the filter can use the custom list or read more custom values in from an external file.

➤ To create a custom values list, use any method:

- Click Show Values in Filter to retrieve the item’s values from the database, then select the values to be included in the custom list and click Transfer.
- Click Custom Values and enter values individually in the edit field, then click the check mark to add each to the custom list.
- Click Advanced and select Load From File to read values from a separate file. Use the Change File button to choose a file from the Select Filter File window. Click Show Values to load the values from the file to the list of values. Click Transfer to add selected values to the custom list.

Values added to the custom list can be selected to determine the filter. If the filter is converted to a variable filter, the custom list is stored in the Interactive Reporting document file and the saved values are available to users who resolve the filter.

Tip:
Imported values must be vertical-tab or paragraph delimited.

Using Operators

Logical operators for defining filters support standard SQL wildcards, including “%” and “_”.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Equal (=)</td>
<td>Retrieves records where the filtered item equals the specified value(s).</td>
</tr>
<tr>
<td>Not Equal (&lt;&gt;)</td>
<td>Retrieves records where the filtered item does not equal the specified value(s).</td>
</tr>
<tr>
<td>Less Than (&lt;)</td>
<td>Retrieves records where the filtered item is less than the specified value(s).</td>
</tr>
<tr>
<td>Less or Equal (&lt;=)</td>
<td>Retrieves records where the filtered item is no greater than the specified value(s).</td>
</tr>
<tr>
<td>Operator</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Greater Than (&gt;)</td>
<td>Retrieves records where the filtered item is greater than the specified value(s).</td>
</tr>
<tr>
<td>Greater or Equal (&gt;=)</td>
<td>Retrieves records where the filtered item is no less than the specified value(s)</td>
</tr>
<tr>
<td>Begins With</td>
<td>Retrieves records where the filtered item begins with the specified value(s) up to and including the end value.</td>
</tr>
<tr>
<td>Contains</td>
<td>Retrieves records where the filtered item contains the specified value(s) regardless of location.</td>
</tr>
<tr>
<td>Ends With</td>
<td>Retrieves records where the filtered item ends with the specified value(s).</td>
</tr>
<tr>
<td>Like (with wildcards)</td>
<td>Retrieves records where a text string is displayed and reflects the placement of the specified value(s). For example, Name Likes_ would retrieve records for all employees whose names have the letters Ze followed by one character at the end.</td>
</tr>
<tr>
<td>Is Null</td>
<td>Retrieves records where the filtered item has no value; for example a field in which no data has been entered.</td>
</tr>
<tr>
<td>Between</td>
<td>Retrieves records where the value of the filtered item lies between (and does not equal) the specified values.</td>
</tr>
<tr>
<td>Not (with operator)</td>
<td>Negates the operator it precedes, reversing the results of the equation.</td>
</tr>
</tbody>
</table>

**Note:**

Text strings are evaluated differently among database systems, and are often case-sensitive (that is, “RED”, “Red” and “red” may not be equivalent in comparison). Text characters are generally valued in ascending order (0 1... 9 A B C... Z a b c... Z.), so that “A” is less than “a” in string comparisons, and strings beginning with numbers are considered “less” than strings beginning with alphabetic characters. See your administrator for specific information.

### Setting Simple Filters

Simple filters are applied in basically the same manner in the Query and Results sections. If you are working with a distributed Interactive Reporting document file, some of the buttons in the Filter dialog box may not be available.

- Filtering Queries
- Filtering Results

### Filtering Queries

The simplest way to filter a query is to apply filters individually to topic items.
To filter a query:

1. Select an item in the data model and choose Query > Add Filter(s).
   The Filter dialog box is displayed.
2. Select an arithmetic or logical operator from the list.
3. Define the potential filter values:
   - Show Values—Shows database values associated with the item.
   - Custom Values—Supplies an empty field for inputting custom values. Click the check mark to add a value to the list of values. You can also display values from a previously saved custom list or values loaded from a file.
   - Custom SQL—Supplies an empty box for typing an SQL clause to be included in the query statement. Choose View > Custom SQL to check the complete statement logic.
4. Select the values to include in the filter definition in the Values list.
   Individually select values or click Select all and deselect the values you do not want to include. Only selected items are applied to the filter definition. To create a snapshot of the values, click Select All and then click Transfer to move the variables to the Custom Values.
5. When the correct values are highlighted in the Values list, click OK.
   The filter is applied to the topic item and an icon is added to the Filter line.
   In the Query section, the filter is applied when you process the Query.

Note:
When placing a filter on an aggregate item (computed with a data function) in the Query section, a filter divider is displayed and the filter icon is placed to the right. The divider indicates the filter is in the SQL Having clause. You must drag the aggregate item from the Request line to the Filter line to create a filter on an aggregate item.

Removing a Query Filter

To remove a filter on a query, select an item on the Filter line and select Remove on the shortcut menu.

Filtering Results

To filter the display of data in the Results section:

1. Select a column (click the column heading) and choose Results > Filter.
   The Filter dialog is displayed.
2. Select an arithmetic or logical operator from the list.
3. Define the potential filter values by clicking one of the following options:
- **Show Values**—Shows database values associated with the item.
- **Custom Values**—Supplies an empty field for inputting custom values. Click the check mark to add them to the list of values. You can also display values from a previously saved custom list or values loaded from a file.

4 **Select the values to include in the filter definition in the Values list.**

Individually select values or click **Select all** and deselect the values you don’t want to include. Only selected items are applied to the filter definition.

5 **When the correct values are highlighted in the Values list, click OK.**

An indicator is added to the Filter line and the filter is immediately applied to the data set.

### Removing a Results Filter

➤ To remove a local filter, choose an item on the Filter line and select **Results > Remove.**

### Setting Compound Filters

In some cases, you may want to set two distinct filters on the same Request item or create compound constraints using more than one item.

Use the Filter line to build compound filter expressions. The Filter line enables you to apply more than one filter to one item, or create compound conditions dependent on more than one constraint.

Drag an item to the Filter line more than once and apply different logical operators to create a complex constraint. For example, to retrieve dollar values greater than $100 or less than or equal to $10, drag the Amount item to the Filter line twice, and set two separate filters. An AND operator is placed between the icons on the Filter line and the data set is constrained by both conditions.

Similar logic can be applied using two filters and substituting the OR operator. For example, to retrieve customers in the Cleveland area and those who have purchased more than $100,000 worth of goods, you can place a filters such that

\[
City = Cleveland \text{ and } SUM(Sale\ Amount) > 100,000
\]

and join them with the OR operator.

**Note:**

The second instance of an item on the Filter line displays a “_2” next to the item name.

➤ To create compound Filter line expressions:

1. **Add two or more items to the Filter line and apply individual filters using the Filter dialog box.**

   An AND operator is displayed between each item on the Filter line.

2. **In the Query section only, click the small arrow at the left edge of the Filter line.”**
The Filter line is adjusted to display the Filter line control buttons.

3 On the Filter line, select filter controls to complete the equation.

- To switch Boolean operators AND and OR, double-click the operator to change.
- To enclose suboperations, select the items you want to enclose and click the parentheses button. To remove parentheses, select a parenthesis and click Remove on the shortcut menu.
- With an item selected on the Filter line, click Var to make the filter variable.

When using compound filters, verify that the expression delivers the correct results.

Tip:
The following syntax rules apply to all Filter line expressions. When creating a compound filter, be sure to verify that the expression is delivering the correct results.

- The AND operator retrieves data that meets both conditions. To retrieve data which satisfies either of two conditions, use the OR operator.
- By default, equations are solved from left to right, with enclosed sub-operations evaluated first. AND is evaluated before OR.
- Sub-operations allow you to override the default evaluation order, and may be required for certain operations involving both AND and OR operators.

Setting Variable Filters

A variable filter is a filter in the Query section that is resolved only when a query is processed. At that time the user is prompted to select or enter filter values and complete the constraint. You can use variable filters in standardized Interactive Reporting document files and distribute them to users to supply different filter values for each process.

Variable filters work particularly well with custom lists. If a custom list has been saved with a variable filter, the user can respond to the prompt by selecting a value from the custom list.

For example, you may use an Interactive Reporting document file monthly to monitor inventory levels. Each time you use the Interactive Reporting document file, you run it separately for each product line you carry. You can accelerate the process by making the filter variable on the product line item, and create a custom values list. Each time you process the Interactive Reporting document file, you can select a new product line without redefining filters.

➤ To set a variable filter:

1 If necessary, add a topic item to the Filter line and define a filter.

If you are providing a custom list, make the values available to the list of values.

Note:
You must select at least one value in the list to save the filter, even if no custom list is provided and the user clicks Show Values to choose from database values. This selection does not influence
the values available to the variable filter, which offers all values in the database or in the custom list.

2 Select a topic item on the Filter line.

3 Choose Query > Variable Filter.
   The Filter item is displayed with a V(1) beside the item name to indicate it is a variable filter.
   If other items are set to variable filters, they are displayed with V(2), V(3), and so on, to indicate the order in which the user is prompted to respond to Variable Filter when the query is processed.

Customizing Filters Options

In some cases, it may be preferable to disable or even remove such features as Include Null or the Custom Values buttons.

**Note:**
Customizing affects one filter. Setting global filter preferences that restrict the options available throughout a distributed data model is an advanced feature not covered in this book.

➤ To customize filter options:

1 Select an item on the Filter line and choose Query > Customize Filter.
   Customize Filter is displayed.

2 Customize the filter as follow and click OK.
   - **Title**—Add a title or text to the filter dialog to instruct users on how to set the filter or on what the values mean.
   - **Prompt**—Supply explanatory comments or instructions.
   - **Values**—Disable Show Values to reduce database hits or remove the Custom SQL or Custom Values option.
   - **Options**—Disable elements and lock in operators.

3 Click OK.

Filtering Table Report Data

You can set filters on columns in a table report to filter the data displayed. Table section filters are applied in addition to the filters set in the Results section. Filters set in the Table section are automatically propagated to the other reports that inherit their data set from the Table. You can always suspend or delete filters to return data to the display and make it available for reporting.

The Status bar displays the total number of rows in the table report. You can apply one filter only per column.
To filter data in a Table report:

1. Double-click the column in which to place a filter.
   The Filter dialog box is displayed.
2. Select a logical operator from the shortcut list.
3. Complete a filter definition by supplying constraining values.
   ● Create a Custom Values list by supplying a value (or values, separated by commas) in the Edit field, and clicking the check mark.
   ● You can also click Show Values to display column values and select one or more values depending on the comparison operator.
4. When the values are highlighted in the values pane, click OK.
   The filter is applied to the column and the column name is added to the Filter line.

To remove a filter in a Table report, select the filter item that you want to remove, and choose Remove on the shortcut menu.

To remove all filters in a Table report, select Filter on the Filter line and choose Remove on the shortcut menu.

**Multiple Filters and the Meta Topic**

Filters are a very important part of the querying process, helping to refine requests, filter unneeded information, and reduce system resource consumption to manageable levels. One way to further increase the reach of filters in a managed query environment is to think of them in terms of both the query and the underlying Data Model, and of ways in which fixed and variable filters may be used together.

Fixed filter values are defined with a query, and remain static until changed manually. Variable filters prompt for new values each time a query is processed. In certain instances you may want to apply both types of filter to one item in order to restrict the available variable filter values and simplify users' choices, or to grant users the latitude of variable filters only within a prescribed range.

For example, consider users of a large data warehouse or legacy system containing sales data going back for many years. For practical or security reasons the administrator might choose to confine some users' access to information dating after 1990. However, it is still important for these users to query the database on-the-fly, and retrieve a variety of data for analysis.

This situation requires two filters, one fixed and one variable, on one topic item. The fixed filter qualifies the values set available to the user in the variable filter. The fixed filter on a date column item instructs the server not to return any values < 1/1/90. The variable filter on the same date column subsequently furnishes a list of server values > 12/31/89 for the user to choose when the Showing Values command is invoked in Filter Controls.
The Two-Tier Strategy

Double-filters can be implemented by dragging an item to the Filter line twice. However, one deficiency to this method is that when applying multiple filters on one item, browse level settings are not effective; that is, the server values retrieved are not constrained by another filter on the same item, because both filters are defined using the same pool of server values. Nevertheless, an elegant solution to this issue is available through the use of the meta topic, which enables the administrator to establish filters at different logical levels.

Meta topics are logical views which overlay the original tables-and-joins model of a database. Items that display in meta topic view inherit any modifications made to the original items in the underlying physical topic view. In this instance, a fixed filter can be applied to the date item in the original database topic. Once a meta topic, which includes the date item, is created to serve as the user view of the Data Model, a variable filter is applied to the date item in the meta topic.

Since the fixed filter is applied to the original date item, the meta topic date item incorporates this filter transparently. The values excluded by the fixed filter are not associated within the new meta topic, and are not returned by the Show Value feature for fixed or variable filters applied to the new meta topic item. Note also that Filter Browse Level settings need not be modified under this scenario because the filters in question are applied to different logical layers.

Filtering Computed Items

In the Query section, you can set a filter on a computed item that resides on the Request Line and invokes an SQL HAVING clause when you process the query.

When you create a computed item, its only reference is through the Request Line. In the same way that you can add an item to Request Line by drag and drop, you can drag and drop a Computed Item onto the Filter Line to prompt for Filter. If the item uses an aggregate function, it displays to the right of all other filters, indicating its use in the HAVING clause of the SQL statement.

➤ To create and set a filter on a computed item in the Query section

1. **Click an item on the Request line and select Query > Add Computed Item.**
   
   Computed Item is displayed.

2. **Enter the information in Computed Item and click OK.**
   
   The computed item displays on the Request line under a new name.

3. **If the Filter line is not already displayed, click the Filter button on the Section Titlebar.**

4. **Drag the computed item from the Request line and drop it in the Filter line.**
   
   Filter is displayed.

5. **Optional: Enter a descriptive name for the filter in the Name field.**
   
   The name is displayed on the filter line icon and can help differentiate multiple filters set on the same item. The name is also used when scheduling an Interactive Reporting document file.

6. **Select an arithmetic or logical operator from the list to begin defining a filter expression.**
7 Define a pool of potential filter values by entering a filter value in the edit field and clicking the check mark to add each to the values list pane.

- The Show Values command is not available because Interactive Reporting cannot retrieve a values list for a computed or aggregated request item from the database.
- Click Custom Values to supply the values in the edit field and click the check mark to add them to the values pane. You can also display values from a custom list previously saved with the Interactive Reporting document file or loaded from a file.
- If you are familiar with SQL, click Custom SQL and type an SQL Where clause to include in the query statement. You can open the Custom SQL dialog box to check the complete statement logic.

8 Select the values to include in the filter definition in the values pane.

Select values individually or click Select all and then deselect those you do not want to include. Only selected items are applied to the filter definition.

9 When the correct values for the filter expression are highlighted in the values pane, click OK.

An indicator is added to the Filter line. In the Results section, the filter is applied to the data set immediately. In the Query section, the filter is applied when you process the Query.

When placing a filter on a Request item computed with a data function in the Query section, a divider is displayed on the Filter line, and the filter icon is placed to the right of the divider. The divider indicates the filter is applied in the SQL Having clause.

10 Click Process to process the final results set.

**Customize Filter**

Use Customize Filter to control access to Filter Controls features. This can be especially useful when you distribute Interactive Reporting document files to end users. For example, if an Interactive Reporting document file is to be distributed to novice users who must set a simple variable filter, it may be preferable to disable or even remove such features as Include Null or the Custom Values buttons.

**Table 72  Customize Filter**

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Add a title or text to the Filter to instruct users on setting the filter, or describe the value.</td>
</tr>
<tr>
<td>Prompt</td>
<td>Supply explanatory comments or instructions.</td>
</tr>
<tr>
<td>Values</td>
<td>Disable the Show Values option to reduce database hits, or remove the Custom SQL or Custom Values options.</td>
</tr>
<tr>
<td>Option</td>
<td>Disable elements and lock in operators.</td>
</tr>
</tbody>
</table>
About Computed Items

When looking for answers to basic business questions, raw data cannot always help. For example, while a database might track dollar sales figures, sometimes this information is much more valuable with reference to more complicated calculations such as cost of sales or profit margin.

Administrators sometimes anticipate these requirements, designing the internal database structure so that it makes such calculations as the raw data is collected. But at times you might need information that no one has yet anticipated.

Computed data items are a means of generating new information, usually from data that is already stored in the database. If your database doesn’t offer particular information, use Interactive Reporting to compute it for yourself.

Computing New Data

Computations can be performed by your database server or by Interactive Reporting on your desktop. A computation does not add data to the database; instead, new data items are added or data items are recalculated in your data set.

Interactive Reporting provides different tools for computing data items. These tools allow you to:

- Build arithmetic expressions {Units * Amount = Revenue}
- Build logical expressions {If Score >=50 Then “Pass” Else “Fail”}
- Build mixed expressions {Tax = Revenue * .35}
- Apply functions {(abs (Amount_Sold))}
Examples of computed items include:

- A `Full_Name` item that concatenates the values in the `First_Name` and `Last_Name` items.
- A `Profit` item derived by subtracting the `Cost of Goods` column from the `Gross Revenues` column.
- A `Grade` item that uses `if...else` logic to assign letter grades derived from test scores.
- A `Sine` item that computes an item for the sine of an angle.
- A `Moving Average` item that smooths a set of data points, i.e., removes irregular fluctuations in the general trend of data.

**Computed Items in Sections**

You can add computed items in the Query, OLAPQuery, Results, Table, Chart, and Pivot sections. This feature works similarly in all sections with a few differences.

In all sections, you can use computed items to create a completely new data item on the Request line from an already existing data item. Each value in the original data item is computed to produce a new value in the newly generated data item. A one-to-one correspondence exists between the original values and the derived computed values.

**Computed Items in the Query Section**

In the Query section, a computed item is a set of instructions to the database server. Interactive Reporting uses the computing power of the database server to perform calculations as it retrieves data from the database.

For this reason, the Query section allows you to use computed items in a way that is not possible in the other sections. Instead of creating a new data item, the new values simply replace the original values in the data item as they are retrieved from the database.

Additionally, you can compute items using any topic item in the data model and any scalar functions provided by your RDBMS.

**Adjusting Data Types**

Since computed items are new data items, you may want to confirm or change the new item’s data type to preserve the precision of a mixed-data type computations, or to change the way a data item is handled (for example, interpreting number as strings). This ensures the correct handling of data in server computations.

Attention to data types is most important when computing items in the Query section. Here the computation is performed on the database server, and the computed item may be handled with an unanticipated data type.

Local calculations (Results, Pivot) are handled internally, and adjustment between 16- and 32-bit integers, for example, can be handled safely using the automatic or number data type specification. For a list of Hyperion-supported data types, see below:
Table 73  Data Types and Specifications

<table>
<thead>
<tr>
<th>Data type</th>
<th>Specification</th>
</tr>
</thead>
<tbody>
<tr>
<td>Automatic</td>
<td>A data type is determined automatically given the data type of the reference items and the computations performed.</td>
</tr>
<tr>
<td>Byte</td>
<td>Variable data type of length determined by a single byte of computer storage. Bytes can store numeric values from 0 to 255, or a single text character.</td>
</tr>
<tr>
<td>Date</td>
<td>Calendar date in server default format (typically mm/dd/yy).</td>
</tr>
<tr>
<td>Integer (16-bit)</td>
<td>Retains a 16-bit value (2 bytes). A 16-bit integer stores integer values from 0 to 16,777,216, and signed integers between +8,388,608 and -8,388,608.</td>
</tr>
<tr>
<td>Integer (32-bit)</td>
<td>Retains a 32-bit value (4 bytes). A 32-bit integer has a range of 0 to 4,294,967,296 if unsigned. If signed, -2,147,483,648 to 2,147,483,647.</td>
</tr>
<tr>
<td>Packed Real</td>
<td>Real numbers packed for use with EDA middleware. The results in Interactive Reporting are the same as real numbers.</td>
</tr>
<tr>
<td>Real</td>
<td>Decimal numbers up to 5 positions right of the decimal.</td>
</tr>
<tr>
<td>String</td>
<td>Text strings to a maximum length of 256 characters.</td>
</tr>
<tr>
<td>Time</td>
<td>Time in format set by user preference.</td>
</tr>
<tr>
<td>TimeStamp</td>
<td>Date/time combination in format set by user preference.</td>
</tr>
</tbody>
</table>

**Computed Items in the Results and Reporting Sections**

In the Results and reporting sections, Interactive Reporting performs computations on the desktop. The computations involve only the data in your Results set or on the surface of a reporting section.

In these sections you can only create new computed items: you cannot modify original data items retrieved directly from the database. For the same reason, scalar functions used to compute items in these sections are provided by the Interactive Reporting, rather than the RDBMS.

Computed items in the Results and reporting sections differ in two respects:

- In the Results and Table sections, reference items are filtered to the items that are displayed on the Request line.
- In the remaining reporting sections (excluding the Report Designer section), reference items are limited to the items placed in the Fact pane in the data layout. Computations in these sections work on the aggregated cell values that make up the core of the report. To perform computations on data before it is aggregated, compute the new item in Results.
- In the Report section, the break totals of a table can be calculated

**Computed Items in the Report Section**

In the Report section, both report totals and break totals can be calculated based on the column’s data function applied to surface values, or the underlying formula of the column.
Underlying values refer to values from the original results section. Surface values refer to values in the actual report section. The two approaches produce values that may be displayed incongruous with the values in the report.

To understand this difference between underlying and surface values, consider a simple table with two values of 20 and 30. Each of these is already a total of underlying values (20 = 8 +12 and 30 = 10 + 20). An average of the underlying value yields the result of 12.5 = (8 + 12 + 10 + 20) /4). An average of the surface values yields the results 25 = (20 +30) / 2).

In the following example, both the Computed and Computed2 columns have the Average data function applied. The Computed column is calculated using the data function applied to the surface values. The Computed2 column is calculated using the underlying values:

<table>
<thead>
<tr>
<th>Store</th>
<th>Amount</th>
<th>Computed</th>
<th>Computed2</th>
</tr>
</thead>
<tbody>
<tr>
<td>Computer Central</td>
<td>1,982.66667</td>
<td>1,982.66667</td>
<td>1,982.66667</td>
</tr>
<tr>
<td>Total Computer Central</td>
<td>1,982.66667</td>
<td>1,982.66667</td>
<td>1,982.66667</td>
</tr>
<tr>
<td>Computer City</td>
<td>1,883.53333</td>
<td>1,883.53333</td>
<td>1,883.53333</td>
</tr>
<tr>
<td>Total Computer City</td>
<td>1,883.53333</td>
<td>1,883.53333</td>
<td>1,883.53333</td>
</tr>
<tr>
<td>Computer Super Bt</td>
<td>1,784.4</td>
<td>1,784.4</td>
<td>1,784.4</td>
</tr>
<tr>
<td>Total Computer Sup</td>
<td>1,784.4</td>
<td>1,784.4</td>
<td>1,784.4</td>
</tr>
<tr>
<td>Computer Town</td>
<td>892.2</td>
<td>892.2</td>
<td>892.2</td>
</tr>
<tr>
<td>Total Computer Town</td>
<td>892.2</td>
<td>892.2</td>
<td>892.2</td>
</tr>
<tr>
<td>Computer World</td>
<td>1,784.4</td>
<td>1,784.4</td>
<td>1,784.4</td>
</tr>
<tr>
<td>Total Computer Wor</td>
<td>1,784.4</td>
<td>1,784.4</td>
<td>1,784.4</td>
</tr>
<tr>
<td>Discount Electronics</td>
<td>892.2</td>
<td>892.2</td>
<td>892.2</td>
</tr>
<tr>
<td>Total Discount Elect</td>
<td>892.2</td>
<td>892.2</td>
<td>892.2</td>
</tr>
<tr>
<td>Grapevine Peripherals</td>
<td>1,189.6</td>
<td>1,189.6</td>
<td>1,189.6</td>
</tr>
<tr>
<td>Total Grapevine Per</td>
<td>1,189.6</td>
<td>1,189.6</td>
<td>1,189.6</td>
</tr>
<tr>
<td>Hi-Tech Mart</td>
<td>1,784.4</td>
<td>1,784.4</td>
<td>1,784.4</td>
</tr>
<tr>
<td>Total Hi-Tech Mart</td>
<td>1,784.4</td>
<td>1,784.4</td>
<td>1,784.4</td>
</tr>
<tr>
<td>Power Computers</td>
<td>1,487</td>
<td>1,487</td>
<td>1,487</td>
</tr>
<tr>
<td>Total Power Comput</td>
<td>1,487</td>
<td>1,487</td>
<td>1,487</td>
</tr>
<tr>
<td>Wolfe’s Disc. Elect</td>
<td>2,200.76</td>
<td>2,200.76</td>
<td>2,200.76</td>
</tr>
<tr>
<td>Total Wolfe’s Disc.</td>
<td>2,200.76</td>
<td>2,200.76</td>
<td>2,200.76</td>
</tr>
<tr>
<td></td>
<td>15,881.16</td>
<td>15,881.16</td>
<td>1,625,78667</td>
</tr>
</tbody>
</table>

If you are calculating totals and break totals for an Interactive Reporting document file (BQY) created in Release 8.3.2 and early (legacy computed items) you can still calculate totals based on the column’s data function applied to surface values, or the underlying formula of the column.

For legacy computed item columns, the “True Total Computation” is changed to “Legacy Total Computation”.

If the user selects “Legacy Total Computation” from the speed menu (essentially trying to turn it off), the user will get an alert dialog indicating that the change cannot be undone (“This action cannot be undone. Are you sure you want to use True Total Computations for Total and Break Totals?” … Continue/Cancel). If the user chooses “Continue”, then “True Totals” will be enabled for both Totals and Break Totals of this column. The next time they display the context menu it will show “True Total Computation” option in place of “Legacy Total Computation”. The user may no longer apply the legacy behavior to this column.
**Computed Items in the Pivot Section**

When you analyze and interpret Pivot section computed item break totals, two methods are available for you to present the data. These methods include:

- Break total cell results derived from the computed item formula applied to the detail cell
- True Computed Item totals

When determining which method to use, look at how the two types of totals differ from each other. The former method is derived from the formula used to calculate the detail cell.

True computed item totals use aggregation according to the specified data function and they never rely on the computed item total formula. Depending on what you are trying to achieve, each method will show different totals.

You can see how the two types of totaling computed items differ in the example below. The first part of the example shows what happens when the totals are derived from the computed item formula used in the detail cells.

Detail cell data is shown at the City level and break totals are shown when the State changes.

<table>
<thead>
<tr>
<th></th>
<th>Units</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>CA</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Burbank</td>
<td>2,395</td>
<td>46</td>
</tr>
<tr>
<td>Glendale</td>
<td>990</td>
<td>41</td>
</tr>
<tr>
<td>Oakland</td>
<td>910</td>
<td>11</td>
</tr>
<tr>
<td>San Diego</td>
<td>7,400</td>
<td>1</td>
</tr>
<tr>
<td>Westwood</td>
<td>695</td>
<td>46</td>
</tr>
<tr>
<td>Total</td>
<td>12,390</td>
<td>41</td>
</tr>
<tr>
<td>NY</td>
<td></td>
<td></td>
</tr>
<tr>
<td>New York</td>
<td>4,640</td>
<td>41</td>
</tr>
<tr>
<td>Rochester</td>
<td>1,615</td>
<td>16</td>
</tr>
<tr>
<td>Total</td>
<td>6,255</td>
<td>6</td>
</tr>
<tr>
<td>Total</td>
<td>18,645</td>
<td>46</td>
</tr>
</tbody>
</table>

In this example, the *Sum* data function has been applied. The “Computed” column is defined by the following formula:

\[(\text{Units} \mod 50) + 1\]

where “\%” represents modulo (remainder) operator. In other words, the formula is defined as:

Integer remainder of \((\text{Unit column cell value} /50) + 1\)

For the Unit column values for each city within a state, the formula works as expected. For example, in the Oakland, CA cell, the formula is:

Units 910
Modulo (remainder) of 910 / 50 = 10
Add 1 to assign a value of 11 (shown above).

For the California “Total” row, the value shown is 41, which is the result of the following formula:

Total “Units” for California = 12390
Modulo of 123900/50 = 40
Add 1 to assign a value of 41
The Modulo of 41 is not the sum of the displayed cell values for all cities in California, instead it is the modulo formula applied only to the cell containing the “Unit” column city total for California.

If you expected to see a break cell total value of 145, you need to use the True Computed Item feature total, which would reference the displayed values in the detail cells (this example assumes a Sum data function):

\[ 46 + 1 + 11 + 1 + 46 \ (= \ 145) \]

**Using Surface Values**

Interactive Reporting enables you to use underlying or surface values when working with totals. Underlying values refer to values from the original results section. Surface values refer to values in the actual report section. The two approaches produce values that may be displayed incongruous with the values in the report.

To understand this difference between underlying and surface values, consider a simple pivot table with two values of 20 and 30. Each of these is already a total of underlying values (20 = 8 + 12 and 30 = 10 + 20). An average of the underlying value yields the result of 12.5 = (8 + 12 + 10 + 20) / 4). An average of the surface values yields the results 25 = (20 + 30) / 2).

**Note:**

Average and Count aggregation Data Functions are not evaluated in True Total mode unless the Use Surface Values property is also enabled (see Use Surface Value above). If Use Surface Values is not enabled, the Average and Count aggregation are calculated using the count of the underlying Table/Result section data values instead of the displayed Pivot values.

**Note:**

By default, the Surface Values feature is deactivated. To activate surface values, choose Pivot > Use Surface Values.

**Computed Items and Data Functions**

Computed items and data functions are fundamentally different, and the functions available in the Computed Item dialog box do not calculate data in the same way as data functions.

- Computed items calculate a fresh value for each original value, based on the computation (for example, Revenue calculated from Price and Units Sold). The new values are part of a new data item or replace the original values. Computed items never reduce the original number of records.

- Data functions, by contrast, summarize groups of database records and replace the original values with new summary data. Because data functions summarize values, the number of records are frequently reduced.
Pivot Options

The Pivot Options tab allows you to enable and disable surface values, how to handle true computed item totals, and how to treat null fact values.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Use Surface Values</strong></td>
<td>Recalculates the values in the visible cells or surface of the pivot rather than the values in the Results section</td>
</tr>
<tr>
<td><strong>True Computed Item Totals</strong></td>
<td>Recalculates break totals so that each total value is equal to the sum of their displayed detail cells. True computed item totals use aggregation according to the specified data function and does not rely on the computed item total formula. If you disable this option, the break total cell values are derived from the computed item formula applied to the detail cell. Average and Count aggregation Data Functions are not evaluated in True Total mode unless you enable Use Surface Values. If you do not enable Use Surface Values, the Average and Count aggregation are calculated using the count of the underlying Table/Result section data values instead of the displayed Pivot values.</td>
</tr>
<tr>
<td><strong>Enable Null Facts In Computed Items</strong></td>
<td>Evaluates a null fact value (an empty cell value) as a zero fact value for non-Moving functions. For Moving Function calculations, where the presence of all displayed Fact cell must be considered in calculations, the following behavior occurs when null fact values are considered as zero. The default option to evaluate and show null values is disabled.</td>
</tr>
</tbody>
</table>

Adding Computed Items

In the Query section, a computed item is a new data item derived from calculations. In the Results, OLAPQuery, Pivot, Chart and Report sections, you add computed items by building equations to compute data items, or by applying functions to existing data items.

Computed items are like normal data items, and can be included in reports or reused to compute other data.

For example, you can modify the Amount Sold item by building an equation around it, multiplying by the Unit Price item and renaming the resulting item 'Revenue'. You can also apply a scalar function such as Cume to Amount Sold and return each individual value as a cumulative running total, or simply multiply Amount Sold by the local tax rate to find the tax owed on each sale.

To create (or modify) a computed item:

1. Select **Add Computed Item** from a Section menu (for example, Query, Results, and so on).
   The Computed Item or Modify Item dialog box is displayed.

2. In the Name field, type a name that describes the computation.
   The default name is Computed, which is numbered sequentially if there is more than one. If you assign a name to a computed item that is identical to an existing scalar function name, the Interactive Reporting numbers the name starting with the number 2.
3 Define the new data item by building an expression in the Definition text box.
   ● Use the operator buttons to insert arithmetic and logical operators at the insertion point.
   ● Click Functions to apply scalar functions using the Functions dialog box.
   ● Click Reference to display the Reference dialog box, and select items to place in the equation.

   You also can type any portion of the equation or the entire equation directly into the
   Definition text box using JavaScript. The names are case sensitive, and you must replace
   spaces in item names with underscores (‘_’).

4 If necessary, click the Options button to set a new data type for the item.

5 When the equation is complete, click OK.

   The computed item is listed in the Results data layout and is displayed as a column in the results
   set.

   In the Query section, the computed item is displayed on the Request line with its new name. In
   the Results section, computed items are displayed in the data layout in blue type.

Operators

The following sections describe the operators available for creating computed items. Use the
following guidelines as you add operators to your computation. Click the Operator buttons in
the Computed Item dialog box to add arithmetic or logical operators to a computation in the
Definition text box. Operators are added at the insertion point. You can use any of the following
types of operators:

   ● Arithmetic Operators
   ● Comparison Operators
   ● Statements
   ● Logical Operators

   Tip:
   Use the following guidelines as you add operators to your computation:

   ● Type the word null (no quotes) into the Expression text box to represent null values.
   ● Enclose all text string constant values and date constant values entered in expressions in
     single quotes. (Numbers can be entered without quotes.)
   ● To join items with a space or other character, reference or type items and strings into the
     Expression text box and join them with the + operator (for example, City + ‘,’ + State).
     To join without additional characters, use the Concat function.
   ● In division operations, the divisor may not be null or equal to zero. If a data item serves as
     the divisor in an expression (for example, 5000 / Units_Sold) and includes null or zero values,
     first create a computed item using if/else logic to remove null and zero values, and then
     compute the item containing the division operation.
Two date items can be subtracted, but not added. The Add Month function adds an integer value to a date.

You cannot nest functions inside the `Sum`, `Cume`, `Chr`, and `Breaksum` functions.

**Note:**
For a detailed description of JavaScript operators, see the Hyperion JavaScript Reference.

**Arithmetic Operators**

Arithmetic operators take numerical values (either logical or variables) as their operands and return a single numerical value.

**Table 74  Arithmetic Operators**

<table>
<thead>
<tr>
<th>Operator</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Add</td>
<td>Used at both the server level and the local metatopic level for all sections.</td>
</tr>
<tr>
<td>-</td>
<td>Subtract</td>
<td>Used at both the server level and the local metatopic level for all sections.</td>
</tr>
<tr>
<td>*</td>
<td>Multiply</td>
<td>Used at both the server level and the local metatopic level for all sections.</td>
</tr>
<tr>
<td>/</td>
<td>Divide</td>
<td>Used at both the server level and the local metatopic level for all sections.</td>
</tr>
<tr>
<td>(</td>
<td>Begin suboperations</td>
<td>Used at both the server level and the local metatopic level for all sections.</td>
</tr>
<tr>
<td>)</td>
<td>End suboperations</td>
<td>Used at both the server level and the local metatopic level for all sections.</td>
</tr>
<tr>
<td>++</td>
<td>Increment</td>
<td>Used at both the server level and the local metatopic level for all sections except the Query section.</td>
</tr>
<tr>
<td>--</td>
<td>Decrement</td>
<td>Used at both the server level and the local metatopic level for all sections except the Query section.</td>
</tr>
<tr>
<td>Mod (%)</td>
<td>Modulus</td>
<td>The modulus operator returns the remainder of dividing var1 by var2. For example, 5% 4 returns 1. Used only at the local metatopic level.</td>
</tr>
</tbody>
</table>

**Tip:**

If a computed item is displayed on a Request Line, and that item’s definition uses subtraction, such as "Mytable.Column1-5", a SQL error can occur. The exact error depends on the database, but the most common error would indicate an undefined name was used. Because databases
allow hyphenated names, Interactive Reporting attempts to deal with such names intuitively. Thus, an item definition like "Mytable.Column1-5" is interpreted as a name. In order to ensure it is treated as subtraction, include a space on either side of the hyphen/subtraction operator. For example, entering the computed item definition as Mytable.Column1 - 5" ensure that correct SQL is generated.

**Comparison Operators**

A comparison operator compares its operands and returns a logical value based on whether the comparison is true. The operands can be numerical or string values. When used on string values, the comparisons are based on the standard lexicographical ordering. The comparison operators in the following table are only available at the local metatopic level.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>==</td>
<td>Returns true if the operands are equal, for example, 3 == var1</td>
</tr>
<tr>
<td>!=</td>
<td>Returns true if the operands are not equal, for example, var1 != 4</td>
</tr>
<tr>
<td>&lt;</td>
<td>Returns true if the left operand is less than the right operand, for example, var1 &lt; var2</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Returns true if the left operand is less than or equal to the right operand, for example, var &lt;= var2, var2 &lt;= 5</td>
</tr>
<tr>
<td>&gt;</td>
<td>Returns true if the left operand is greater than the right operand, for example, var2 &gt; var1</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Returns true if the left operand is greater than or equal to the right operand, for example, var2 &gt;=, var1 &gt;= 2</td>
</tr>
</tbody>
</table>

**Statements**

Executes a set of statements if a specified condition is true. If the condition is false, another set of statements can be executed.

**Note:**

Statements are only available at the local metatopic level.

**Table 76** if...else Statement

<table>
<thead>
<tr>
<th>Statement</th>
<th>Description</th>
</tr>
</thead>
</table>
| if...else | if executes a set of statements if a specified condition is true. The specified condition may be another statement and can include other nested if statements. Braces, {}, must enclose multiple statements. If the condition is false, another set of statements can be executed if the optional else statement has been included in the script. A sample if ... else statement looks like this: if (condition) {
 statements1
Logical Operators

Logical operators take Boolean (logical) values as operands and return a Boolean value. The logical operators below are only available at the local metatopic level.

Table 77 Logical Operators (Local Metatopic Level)

<table>
<thead>
<tr>
<th>Logical Operator</th>
<th>Description</th>
</tr>
</thead>
</table>
| **AND (&&)**     | Connects two conditional expressions and retrieves records only if each expression is true. Computed items will not be retrieved if any condition belonging to a conditional expression is false. The AND logical operator is usually nested within another conditional expression, for example, expressions which use if and else statements. For example:  
  ```java
  if ((OS == 'Windows') && (Item_Type == 'Modem')) {'Windows'} else {'other'}
  ``` |
| **OR (||)**      | Specifies a combination of expressions and retrieves records that include at least one of the expressions. For example, if one of the words is Washington or Oregon, every record with the expression “Washington” and every record with the word “Oregon” is included. Typically the OR (||) is nested within other conditional expressions, for example, expressions which use if and else logical operators. For example to assign Washington and Oregon to the “Northwestern Region” and all other states to “Other Regions”, you would enter:  
  ```java
  if ((State == 'Washington') || (State == 'Oregon'))  
  ('Northwestern Region') else ('Other Regions')
  ``` |
| **NOT (!)**      | Computes and shows items more accurately stated in a negative way. In effect, all records are retrieved except those that fulfill the conditional expression. You enter the conditional expression with the NOT (!) logical operator preceding the conditional expression. The conditional expression can be a simple value or nested within other conditional expressions, for example, expressions using AND and OR. A combined condition expression that uses NOT is true if the conditional expression following NOT is false. A combined conditional expression is false if the conditional expression following NOT is true. For example, suppose you are looking to list all states that are not in the Northwestern region. In this case, you would enter the conditional expression:  
  ```java
  if (! (State == 'Northwestern Region')) {'Other Regions'}
  ``` |

Referencing Topics in Computed Items

Use the Reference dialog box to select Request line items to place in the equation, or use as function arguments.
To show topic items associated with a topic, select the topic in the left pane.
Topic items are displayed in the right pane.

Using Functions

These topics lists the functions available in Interactive Reporting:

- “Scalar Functions” on page 352
- “Data Functions” on page 360
- “Teradata Version 3 OLAP Functions” on page 362
- “Functions for Returning the Day of the Week” on page 367

Scalar Functions

The available scalar functions include:
You can use a variety of scalar functions for adding computed data items in the Pivot, Chart, Tables and Results sections.

“Conditional Scalar Functions” on page 353
“Date Scalar Functions” on page 353
“Math Scalar Functions” on page 354
“Numeric Scalar Functions” on page 356
“Statistical Scalar Functions” on page 358
“String Scalar Functions” on page 359

Note:
In the tables for Conditional, Date, Math, String and Trend functions below, the variables \( n, s, d \), and \( \text{exp} \) (and \( \text{val} \)) represent data items and columns (State, Amount Sold) or actual values (‘NY’, 6000) as arguments to scalar functions, and indicate number, string, date, or variable types, respectively.

Note:
The variable \( c \) indicates that only a data item reference may be used, and not a constant value. If constant values are substituted for data items, dates and text strings must be enclosed in single quotes. Examples in the tables that follow use a mixture of constants and data items, which are generally interchangeable.
### Conditional Scalar Functions

#### Table 78  Conditional Scalar Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Decode</strong> (c,exp,val,exp,val...def)</td>
<td>Compares value of item c to one or more expressions exp, and returns the value matched to each expression, or a default def.</td>
</tr>
<tr>
<td><strong>Example:</strong></td>
<td>decode (region, &quot;South America&quot;,&quot;Priority 1&quot;,&quot;Asia&quot;,&quot;Priority 2&quot;,&quot;Europe&quot;,&quot;Priority 3&quot;,null)</td>
</tr>
<tr>
<td></td>
<td>substitutes priority values for the specified regions and leaves other regions null.</td>
</tr>
<tr>
<td><strong>Nvl</strong> (exp1,exp2)</td>
<td>Returns exp2 if null, and exp1 otherwise.</td>
</tr>
<tr>
<td><strong>Example:</strong></td>
<td>nvl (Phone_No,&quot;Phone_No&quot;,&quot;Not Recorded&quot;)</td>
</tr>
<tr>
<td></td>
<td>returns &quot;Not Recorded&quot; when no telephone number is on record for a customer.</td>
</tr>
<tr>
<td></td>
<td>if the function is included in a computed item expression, only two parameters are allowed: exp1 and exp2.</td>
</tr>
</tbody>
</table>

### Date Scalar Functions

#### Table 79  Date Scalar Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>AddMonths</strong> (d,n)</td>
<td>Adds n months to date d.</td>
</tr>
<tr>
<td><strong>Example:</strong></td>
<td>AddMonths ('5/13/99',4) = 9/13/99</td>
</tr>
<tr>
<td><strong>DayOfMonth</strong> (d)</td>
<td>Returns the day of month for date d.</td>
</tr>
<tr>
<td><strong>Example:</strong></td>
<td>DayOfMonth ('11/02/99') = 2</td>
</tr>
<tr>
<td><strong>LastDay</strong> (d)</td>
<td>Returns date of the last day of the month containing date d.</td>
</tr>
<tr>
<td><strong>Example:</strong></td>
<td>LastDay ('12/6/9') = 12/31/99</td>
</tr>
<tr>
<td><strong>MonthsBetween</strong> (d1,d2)</td>
<td>Returns the number of months between dates d1 and d2 as a real number (fractional value).</td>
</tr>
<tr>
<td><strong>Example:</strong></td>
<td>MonthsBetween ('12/5/99','5/6/99') = 6.9677</td>
</tr>
<tr>
<td><strong>NextDay</strong> (d,s)</td>
<td>Returns the date of the first weekday s after date d. If s is omitted, add one day to d.</td>
</tr>
</tbody>
</table>
### Example:

NextDay ('12/16/99', "Monday") = 12/22/99

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sysdate()</td>
<td>Returns the current system date and time for each record in item c.</td>
</tr>
<tr>
<td>Example:</td>
<td>Sysdate() = 2/11/96 19:54:36</td>
</tr>
<tr>
<td>ToChar (d/n, 'f' or &quot;f&quot;)</td>
<td>Converts the date or number d/n into a string in the specified format. This function does not change the data, but rather the item data type. The results cannot be computed mathematically.</td>
</tr>
<tr>
<td>Example:</td>
<td>ToChar ('05/08/06', &quot;mmmm-yy&quot;) = May-06</td>
</tr>
<tr>
<td></td>
<td>If you are referencing a Date or Number column for the first argument (Date field), single quotes are not required. If you are passing a data value, single quotes are required. A comma must immediately follow the first argument. In the second argument (Format field), single quotes or double quotes must enclose values.</td>
</tr>
<tr>
<td>ToDate (s)</td>
<td>Returns date type in place of date-string s. This function does not change the data, but rather the item data type. The results can be computed mathematically.</td>
</tr>
<tr>
<td>Example:</td>
<td>ToDate ('10/12/96') = 10/12/96</td>
</tr>
<tr>
<td></td>
<td>Note:  See Functions for Returning the Day of the Week for information on how to return the day of the week on which a given date falls.</td>
</tr>
<tr>
<td>ToMonth (d)</td>
<td>Returns a numeric month value for each value of d. You can change the value to display as a month string by adding and applying a mmm date format.</td>
</tr>
<tr>
<td>Example:</td>
<td>ToMonth ('11/2/99' 09:46:00 AM) = 11/2/99 ~ Nov</td>
</tr>
<tr>
<td>ToQtr (d)</td>
<td>Returns a string quarter value for each value of d.</td>
</tr>
<tr>
<td>Example:</td>
<td>ToQtr ('11/02/06' 09:46:00 AM) = Q3</td>
</tr>
<tr>
<td>ToYear (d)</td>
<td>Returns the integer year for each value of d. You can convert the year to display without commas by applying the 0 numeric format.</td>
</tr>
<tr>
<td>Example:</td>
<td>ToYear ('11/02/06' 09:46:00 AM) = 2,006 ~ 2006</td>
</tr>
</tbody>
</table>

### Math Scalar Functions

#### Table 80  Math Scalar Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
<tr>
<td>Function (n, m)</td>
<td>Description</td>
</tr>
<tr>
<td>----------------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| **Abs** (n) | Returns the absolute value of number n. | **Example:**
| | | Abs (-3) = 3 |
| **Atn** (n) | Returns arc tangent of number n radians. | **Example:**
| | | Atan (1) = .7854 |
| **Ceil** (n) | Returns the smallest integer value greater than or equal to number n. | **Example:**
| | | Ceil (5.6) = 6 |
| **Cos** (n) | Returns cosine of number n radians. | **Example:**
| | | Cos (0.5) = .8776 |
| **Cosh** (n) | Returns hyperbolic cosine of number n radians. | **Example:**
| | | Cosh (0.5) = 1.1276 |
| **Count** (c) | Returns the number of row values in c (including nulls). | **Example:**
| | | Count (units) = tally of rows in units |
| **Exp** (n) | Returns e (2.718) raised to exponential power n. | **Example:**
| | | Exp (4) = 54.598 |
| **Max** (a,b) | Returns the larger of items a and b for each new value. | **Example:**
| | | Max (7, 10) = 10 |
| **Min** (a,b) | Returns the smaller of items a and b for each new value. | **Example:**
| | | Min (7, 10) = 7 |
| **Mod** (n,m) | Returns the integer remainder of number n divided by number m. If m is larger, the default value is n. | **Example:**
| | | Mod (6,2) = 0 |
| **Power** (n,m) | Returns number n raised to exponential power m. | **Example:**
|
Power \((10,5) = 100,000\)

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
</table>
| **Round** \((n,m)\) | Returns \(n\) rounded to \(m\) decimal places. If \(m\) is omitted, round to 0 decimal places.  
**Example:**  
Round \((5.6178,2) = 5.62\) |
| **Sign** \((n)\) | Returns indicator of -1, 0, or 1 if number \(n\) is variously negative, 0, or positive.  
**Example:**  
Sign \((-4) = -1\) |
| **Sin** \((n)\) | Returns sine of number \(n\) radians.  
**Example:**  
Sin \((86) = -0.924\) |
| **Sinh** \((n)\) | Returns hyperbolic sine of number \(n\) radians.  
**Example:**  
Sinh \((.5) = .5211\) |
| **Sqrt** \((n)\) | Returns square root of number \(n\).  
**Example:**  
Sqrt \((81) = 9\) |
| **Tan** \((n)\) | Returns tangent of number \(n\) radians.  
**Example:**  
Tan \((30) = -6.405\) |
| **Tanh** \((n)\) | Returns hyperbolic tangent of number \(n\) radians.  
**Example:**  
Tanh \((45) = 1\) |
| **Trunc** \((n,m)\) | Returns number \(n\) truncated to number \(m\) decimal places. The default value for \(m\) is 0.  
**Example:**  
Trunc \((56.0379,2) = 56.03\) |

**Numeric Scalar Functions**

**Table 81**  
<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
</table>

356  
Computed Items
<table>
<thead>
<tr>
<th>Function</th>
<th>Arguments</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Avg</td>
<td>(numbers, break_col, break_value)</td>
<td>Returns the average (arithmetic mean) of values in a number column. The average includes null values when calculating the arithmetic mean.</td>
</tr>
<tr>
<td>AvgNonNull</td>
<td>(numbers, break_col, break_value)</td>
<td>Returns the average (arithmetic mean) of values in a number column, excluding null values.</td>
</tr>
<tr>
<td>chr</td>
<td>(n)</td>
<td>Returns string converted from ASCII numeric code n. Example: Chr (65) = A</td>
</tr>
<tr>
<td>ColMax</td>
<td>(numbers, break_col, break_value)</td>
<td>Returns the largest value in a column of numbers.</td>
</tr>
<tr>
<td>ColMin</td>
<td>(numbers, break_col, break_value)</td>
<td>Returns the smallest value in a column of number.</td>
</tr>
<tr>
<td>Count</td>
<td>(numbers, break_col, break_value)</td>
<td>Counts and returns the number of rows in a column.</td>
</tr>
<tr>
<td>CountDistinct</td>
<td>(numbers, break_col, break_value)</td>
<td>Counts and returns the number of values in a column.</td>
</tr>
<tr>
<td>CountNonNull</td>
<td>(numbers, break_col, break_value)</td>
<td>Counts the number of rows in a column.</td>
</tr>
<tr>
<td>CountNull</td>
<td>(numbers, break_col, break_value)</td>
<td>Counts the number of rows in a column that contains null values.</td>
</tr>
<tr>
<td>Cume</td>
<td>(numbers, break_col)</td>
<td>Returns a cumulative running total for each value in a column of numbers.</td>
</tr>
<tr>
<td>Next</td>
<td>(c)</td>
<td>Returns the next row value of the referenced item c.</td>
</tr>
<tr>
<td>Prior</td>
<td>(c)</td>
<td>Returns the prior row value of the referenced item c.</td>
</tr>
<tr>
<td>Sum</td>
<td>(numbers, break_col, break_value)</td>
<td>Returns the total of a column of numbers.</td>
</tr>
</tbody>
</table>
### Picture Function

**Table 82** Picture Function

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Picture</strong></td>
<td>Returns a BLOB image file (.JPEG, .GIF, .BMP, and .PNG). Image path refers to folder where the image is stored. Tooltip is any descriptive text to associate with the picture image.</td>
</tr>
<tr>
<td></td>
<td><strong>Example:</strong></td>
</tr>
<tr>
<td></td>
<td>if (Amount_Sales &gt;= 10000) {Picture (&quot;C:\graphics\smile.gif&quot;)} else{Picture (&quot;C:\graphics\crying.gif&quot;)}</td>
</tr>
</tbody>
</table>

### Statistical Scalar Functions

**Table 83** Statistical Scalar Functions

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Median</strong></td>
<td>Returns the median of a column of numbers.</td>
</tr>
<tr>
<td><strong>Mode</strong></td>
<td>Returns the most frequently occurring value in a column of numbers.</td>
</tr>
<tr>
<td><strong>Percentile</strong></td>
<td>Returns the n$^{th}$ percentile of values in a column of numbers in ascending order.</td>
</tr>
<tr>
<td><strong>Rank</strong></td>
<td>Returns the rank of a number in a column of numbers.</td>
</tr>
<tr>
<td><strong>RankAsc</strong></td>
<td>Returns the rank of a number in a column of numbers in ascending order.</td>
</tr>
<tr>
<td><strong>StdDev</strong></td>
<td>Estimates standard deviation based on a sample. The standard deviation is a measure of how widely values are dispersed from the average value (the mean). If your data represents the entire population, then compute the standard deviation using the <strong>StdDevp</strong> function.</td>
</tr>
<tr>
<td><strong>StdDevp</strong></td>
<td>Calculates standard deviation based on the entire population given as arguments. The standard deviation is a measure of how widely values are dispersed from the average value (the mean). If your data represents a sample</td>
</tr>
</tbody>
</table>
of the population, then compute the standard deviation using the `StdDev` function.

**StdDevp example**

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>Var</code></td>
<td>Estimates variance based on a sample. The <code>Var</code> function assumes that its</td>
</tr>
<tr>
<td>(numbers, break_col)</td>
<td>arguments are a sample of the population. If your data represents the entire</td>
</tr>
<tr>
<td></td>
<td>population, then compute the variance using the <code>Varp</code> function.</td>
</tr>
<tr>
<td><code>Varp</code></td>
<td>Estimates variance based on the entire population. The <code>Varp</code> function assumes</td>
</tr>
<tr>
<td>(numbers, break_col)</td>
<td>that its arguments are the entire population. If your data represents a sample</td>
</tr>
<tr>
<td></td>
<td>of the population, then compute the variance using the <code>Var</code> function.</td>
</tr>
</tbody>
</table>

### String Scalar Functions

**Table 84 String Scalar Functions**

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>Ascii</code></td>
<td>Returns an ASCII code of the first symbol in the string, s.</td>
</tr>
<tr>
<td>(s)</td>
<td></td>
</tr>
<tr>
<td><strong>Example:</strong></td>
<td>Ascii (&quot;AZ&quot;) = 65</td>
</tr>
<tr>
<td><code>Concat</code></td>
<td>Returns text strings s1 and s2 concatenated.</td>
</tr>
<tr>
<td>(s1, s2)</td>
<td></td>
</tr>
<tr>
<td><strong>Example:</strong></td>
<td>Concat (&quot;interactive&quot;,&quot;reporting&quot;) = interactivereporting</td>
</tr>
<tr>
<td><code>Initcap</code></td>
<td>Returns string s with the first letter of each word capitalized, and remaining</td>
</tr>
<tr>
<td>(s)</td>
<td>characters in lower case.</td>
</tr>
<tr>
<td><strong>Example:</strong></td>
<td>Initcap (&quot;santa fe&quot;) = Santa Fe</td>
</tr>
<tr>
<td><code>Instr</code></td>
<td>Returns position of m(^{th}) occurrence of string s2 in string s1,</td>
</tr>
<tr>
<td>(s1, s2, n, m)</td>
<td>beginning at position number n. If n is negative, the count is made</td>
</tr>
<tr>
<td></td>
<td>backwards from the end of s1. If no values are found, 0 is returned.</td>
</tr>
<tr>
<td><strong>Examples:</strong></td>
<td>Instr (&quot;Mississippi&quot;,'s',5,2) = 7</td>
</tr>
<tr>
<td></td>
<td>Instr ( City, 'a', -2, 1 )</td>
</tr>
<tr>
<td><code>Length</code></td>
<td>Returns character count of string s.</td>
</tr>
<tr>
<td>(s)</td>
<td></td>
</tr>
<tr>
<td><strong>Example:</strong></td>
<td>Length (&quot;Pittsburgh&quot;) = 10</td>
</tr>
<tr>
<td><code>Lower</code></td>
<td>Returns string s in lower case.</td>
</tr>
<tr>
<td>Function</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Lower (s)</td>
<td>Lowercase string</td>
</tr>
<tr>
<td><strong>Ltrim (s1,s2)</strong></td>
<td>Trims string s1 from the left, up to the first character not included in string s2.</td>
</tr>
<tr>
<td><strong>Replace (s1,s2,s3)</strong></td>
<td>Returns string item s1 with all occurrences of string s2 replaced by string s3. The default for s3 deletes each occurrence of s2.</td>
</tr>
<tr>
<td><strong>Rtrim (s1,s2)</strong></td>
<td>Trims column string s1 from the right, up to the first character not included in string s2.</td>
</tr>
<tr>
<td><strong>Substr (s,n,m)</strong></td>
<td>Returns a portion of string s, m characters long, beginning at numeric position n. The default action for m includes all remaining characters.</td>
</tr>
<tr>
<td><strong>Translate (s1,s2,s3)</strong></td>
<td>Returns string s1, with each character contained in string s2 replaced by the corresponding characters in string s3.</td>
</tr>
<tr>
<td><strong>Upper (s)</strong></td>
<td>Returns string s in upper case.</td>
</tr>
</tbody>
</table>

**Data Functions**

Data functions compute aggregate values, including averages, maximums, counts and other statistics. These functions summarize groupings of data. You can use data functions to aggregate and compute data from the server before it reaches the Results section, or compute different statistics for aggregated Results totals and report items.

The effects of data functions are most dramatic in the Query section. For example, Dollars is an item of sales transaction records for your stores in London and Madrid. You can apply a data function to this item, consolidate the data, and calculate sum totals, average sale values, number counts of individual sales records, or minimum sale values with respect to each city, once the data is retrieved to Results.
**Note:**
Although data functions are relatively standard, there may be additional data functions available to you in the Query section, depending on your RDBMS.

To apply a data function, select the item or column, and choose **Data Function** on the Query, Pivot, Chart, Results or Table menu.

You can also select the item or column, activate the shortcut menu, point to Data Function, and select (function).

**Note:**
In report sections, you can apply data functions only if you select a single fact column. You can also change the way data functions are computed.

**Tip:**
You cannot use Data Functions in the Table section.

The following table lists the available data functions.

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>Availability</th>
</tr>
</thead>
<tbody>
<tr>
<td>None</td>
<td>Returns unaggregated values as stored in the database. This is the default in Query.</td>
<td>Query</td>
</tr>
<tr>
<td>Sum</td>
<td>Returns sum of underlying values. This is the default in Results and report sections.</td>
<td>All</td>
</tr>
<tr>
<td>Average</td>
<td>Returns average of underlying values.</td>
<td>All</td>
</tr>
<tr>
<td>Non-Null Average</td>
<td>Returns average of underlying values; null values excluded.</td>
<td>Pivot, Chart, Report</td>
</tr>
<tr>
<td>Minimum</td>
<td>Returns lowest of underlying values.</td>
<td>All</td>
</tr>
<tr>
<td>Maximum</td>
<td>Returns highest of underlying values</td>
<td>All</td>
</tr>
<tr>
<td>Count</td>
<td>Returns number of underlying values.</td>
<td>All</td>
</tr>
<tr>
<td>CountDistinct</td>
<td>Returns the number of distinct values in a column. This function is not supported by all database servers.</td>
<td>Query</td>
</tr>
<tr>
<td>Null Count</td>
<td>Returns number of nulls among underlying values.</td>
<td>Pivot, Chart, Report</td>
</tr>
<tr>
<td>Non-Null Count</td>
<td>Returns number of underlying values; null values excluded.</td>
<td>Pivot, Chart, Report</td>
</tr>
<tr>
<td>Standard Deviation</td>
<td>Returns standard deviation of values. This function is not supported by all database servers.</td>
<td>Query</td>
</tr>
<tr>
<td>Variance</td>
<td>Returns variance of values. This function is available through Oracle servers only.</td>
<td>Query</td>
</tr>
<tr>
<td>Function</td>
<td>Description</td>
<td>Availability</td>
</tr>
<tr>
<td>-----------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>--------------</td>
</tr>
<tr>
<td>Weight</td>
<td>Use for computing weighted items in Pivot reports.</td>
<td>Query</td>
</tr>
<tr>
<td>% of Column</td>
<td>Returns sum of all underlying values as a percentage of their respective</td>
<td>Pivot</td>
</tr>
<tr>
<td></td>
<td>surface column.</td>
<td></td>
</tr>
<tr>
<td>% of Row</td>
<td>Returns sum of underlying values as a percentage of their respective</td>
<td>Pivot</td>
</tr>
<tr>
<td></td>
<td>surface row.</td>
<td></td>
</tr>
<tr>
<td>% of Grand</td>
<td>Returns sum of underlying values as a percentage of all surface values</td>
<td>Pivot, Chart</td>
</tr>
<tr>
<td></td>
<td>in the report.</td>
<td></td>
</tr>
<tr>
<td>% of Category</td>
<td>Returns group total percentage of the selected value.</td>
<td>Report</td>
</tr>
<tr>
<td>Increase</td>
<td>Calculates the increase between the previous two rows or columns.</td>
<td>Pivot</td>
</tr>
<tr>
<td>%Increase</td>
<td>Calculates the percentage increase between the previous two rows or</td>
<td>Pivot</td>
</tr>
<tr>
<td></td>
<td>columns.</td>
<td></td>
</tr>
<tr>
<td>Title</td>
<td>Returns column names</td>
<td>Report</td>
</tr>
</tbody>
</table>

**Tip:**

Null values are empty values for which no data has been specified; null values are not equal to zero.

**Teradata Version 3 OLAP Functions**

Interactive Reporting supports a number of Teradata version 3 OLAP and system functions, which dramatically reduce query time.

- “CSum (Cumulative Sum) Function” on page 363
- “MAvg (Moving Average) Function” on page 363
- “MDiff (Moving Difference) Function” on page 363
- “MSum (Moving Sum) Function” on page 364
- “MLingreg (Multiple Linear Regression) Function” on page 364
- “Quantile Function” on page 365
- “Rank Function” on page 365
- “Current_Timestamp Function” on page 365
- “Qualify Function” on page 366
- “Sample Function” on page 366
- “SampleID Function” on page 367
### CSum (Cumulative Sum) Function

**Table 85  CSum (Cumulative Sum) Function**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Accumulates a sum over an ordered set of rows, providing the current values of the SUM on each row</td>
</tr>
<tr>
<td>Syntax:</td>
<td>CSum(value_expression, sort_expression_list)</td>
</tr>
<tr>
<td>value_expression</td>
<td>A value_expression is a scalar numeric column expression for which a running sum is to be computed.</td>
</tr>
<tr>
<td>sort_expression_list</td>
<td>The sort_expression_list is a list of expressions (with optional sort direction specifications) separated by commas. That is, it specifies the column references used to sort the values. The default sort direction is ascending (ASC).</td>
</tr>
</tbody>
</table>

### MAvg (Moving Average) Function

**Table 86  MAvg (Moving Average) Function**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Computes the moving average of a column using the current row and the preceding width-1 rows.</td>
</tr>
<tr>
<td>Syntax:</td>
<td>MAvg(value_expression, width, sort_expression_list)</td>
</tr>
<tr>
<td>value_expression</td>
<td>The value expression represents a scalar numeric column expression for which a moving average is to be computed.</td>
</tr>
<tr>
<td>width</td>
<td>The width represents the number of previous rows to be used in computing the moving average. The width value is always a positive integer constant. The maximum width is 4096.</td>
</tr>
<tr>
<td>sort_expression_list</td>
<td>The sort_expression_list is a list of expressions (with optional sort direction specifications) separated by commas. That is, it specifies the column references used to sort the values. The default sort direction is ascending (ASC).</td>
</tr>
</tbody>
</table>

### MDiff (Moving Difference) Function

**Table 87  MDiff (Moving Difference) Function**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Returns the moving difference between the current row-column value and the preceding nth value.</td>
</tr>
<tr>
<td>Syntax:</td>
<td>MDiff(value_expression, width, sort_expression_list)</td>
</tr>
<tr>
<td>Description</td>
<td>The moving difference is a common business metric used to compare activity for some variable in a current time period to the activity for the same variable in another time period at a fixed distance in the past.</td>
</tr>
</tbody>
</table>
The value expression represents a scalar numeric column expression for which a moving average is to be computed. The expression cannot contain any OLAP or aggregate functions.

width
The width represents the number of previous rows to be used in computing the moving average. The width value is always a positive integer constant. The maximum width is 4096.

sort_expression_list
The sort_expression_list is a list of expressions (with optional sort direction specifications) separated by commas. That is, it specifies the column references used to sort the values. The default sort direction is ascending (ASC).

### MSum (Moving Sum) Function

#### Table 88  MSum (Moving Sum) Function

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Computes the moving sum of a column using the current row and the preceding n-1 row.</td>
</tr>
<tr>
<td>Syntax:</td>
<td>MSum(value_expression, width, sort_expression_list)</td>
</tr>
<tr>
<td>value_expression</td>
<td>The value expression represents a scalar numeric column expression for which a moving average is to be computed. The expression cannot contain any OLAP or aggregate functions.</td>
</tr>
<tr>
<td>width</td>
<td>The width represents the number of previous rows to be used in computing the moving average. The width value is always a positive integer constant. The maximum width is 4096.</td>
</tr>
<tr>
<td>sort_expression_list</td>
<td>The sort_expression_list is a list of expressions (with optional sort direction specifications) separated by commas. That is, it specifies the column references used to sort the values. The default sort direction is ascending (ASC).</td>
</tr>
</tbody>
</table>

### MLingreg (Multiple Linear Regression) Function

#### Table 89  MLingreg (Multiple Linear Regression) Function

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Returns a predicted value for a column expression based on a least squares multiple linear regression of the previous width-1 based on the sort_expression column values. When there are fewer than width-1 preceding rows, the MLingreg function computes the regression using all the preceding rows.</td>
</tr>
<tr>
<td>Syntax:</td>
<td>MLingreg(value_expression, width, sort_expression_list)</td>
</tr>
<tr>
<td>value_expression</td>
<td>The value expression represents a scalar numeric column expression for which a moving average is to be computed. The expression cannot contain any OLAP or aggregate functions.</td>
</tr>
<tr>
<td>width</td>
<td>The width represents the number of previous rows to be used in computing the moving average. The width-1 previous rows are used to compute the linear regression and the row value itself is used to calculate the predicted value. The width value is always a positive integer constant greater than 1. The maximum width is 4096.</td>
</tr>
<tr>
<td>sort_expression_list</td>
<td>The sort_expression_list is a column reference used to sort the values and to define the dependent variable for calculating the linear regression. The sort_expression_list is an</td>
</tr>
</tbody>
</table>
expression with optional sort direction specification. The default sort direction is ascending (ASC). Only one sort_expression is allowed with this function.

### Quantile Function

**Table 90  Quantile Function**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>quantile_constant</td>
<td>A positive integer constant used to define the number of quantile partitions to be used.</td>
</tr>
<tr>
<td>sort_expression_list</td>
<td>List of expressions (with optional sort direction specifications) separated by commas. That is, it specifies the column references used to sort the values. The default sort direction is ascending (ASC).</td>
</tr>
</tbody>
</table>

**Quantile Value Range**

0 through (Q-1) where Q is the number of quantile partitions specified by the quantile constant.

### Rank Function

**Table 91  Rank Function**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>sort_expression_list</td>
<td>List of expressions (with optional sort direction specifications) separated by commas. That is, it specifies the column references used to sort the values. The default sort direction is ascending (ASC).</td>
</tr>
</tbody>
</table>

### Current_Timestamp Function

**Table 92  Current Timestamp Function**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>fractional_precision</td>
<td>An option precision range for the returned timestamp value. The value range is 0 through 6, inclusive. The default is 6.</td>
</tr>
</tbody>
</table>
### Properties

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Data type: TIMESTAMP WITH TIME ZONE</td>
<td>Length: 12 Not nullable</td>
</tr>
</tbody>
</table>

### Fields

YEAR, MONTH, DAY, HOUR, MINUTE, SECOND, TIMEZONE_HOUR, TIMEZONE_MINUTE

### Qualify Function

**Table 93 Qualify Function**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Filters results of a previously computed OLAP function according to user-specified conditions.</td>
</tr>
<tr>
<td>Syntax:</td>
<td>Qualify search_condition</td>
</tr>
<tr>
<td>search_condition</td>
<td>One or more conditional expressions that must be satisfied by the result rows. Aggregate operators with a Qualify clause can be used.</td>
</tr>
</tbody>
</table>

**Usage Notes**

When you specify a QUALIFY clause in a query, you must also specify a statistical function in one of the following locations within the query.

- select_list of the SELECT clause
- grouping_key of the GROUP BY clause
- search_condition of the QUALIFY clause

When the WHERE, GROUP BY, and QUALIFY clauses are used together in a SELECT statement, the order of evaluation is:

WHERE GROUP BY QUALIFY

### Sample Function

**Table 94 Sample Function**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Reduces the number of rows to be considered for further processing by returning mutually exclusive samples of rows specified either as a list of fractions of the total number of rows or as a list of numbers of rows from the SELECT query.</td>
</tr>
<tr>
<td>Syntax:</td>
<td>Sample(fractional_description [count_description])</td>
</tr>
<tr>
<td>fractional_description</td>
<td>Represents any number of floating point constants in the closed interval (0, 1) and separated by a comma. This is a list of fractions, the sum of which must not exceed 1.</td>
</tr>
<tr>
<td>count_description</td>
<td>Represents a positive integer constant list of row counts. A warning is returned if there are not enough rows in the result to satisfy the sampling request completely.</td>
</tr>
</tbody>
</table>

**Usage Notes**

No more than 16 samples can be requested per SELECT statement.

SAMPLE operates on the evaluated output of the table expression, which can include a WHERE clause and GROUP BY, HAVING, or QUALIFY clauses, sampling the result according to use specification.

A sampling request cannot be repeated. The identical sampling query run twice against the same data will report different rows in the result.
Sampling can be used in a derived table, view, or INSERT-SELECT to reduce the number of rows to be considered for further computation.

You cannot use SAMPLE in a subquery.

If a fraction_description results in no rows being returned, a warning is generated.

If a count_description cannot be completely satisfied, a warning is generated and the sample size is reduced to the number of remaining rows.

### SampleID Function

Table 95  SampleID Function

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Description</td>
<td>Identifies the sample to which a row belongs, distinguishing rows belonging to different samples specified in the SAMPLE clause of a SELECT statement.</td>
</tr>
</tbody>
</table>

**Syntax:**

SAMPLEID

**Definition:**

The sample ID identifies the sample to which a row belongs in the left-to-right order of the SAMPLE clause specification, from 1 through \(n\) (where \(n\) is the number of samples requested in the SAMPLE clause).

**Where to Specify SAMPLEID:**

SAMPLEID can only be specified with a SAMPLE clause and can be displayed either as part of a SELECT clause or in an ORDER BY clause.

### Functions for Returning the Day of the Week

If you need to return the day of the week on which a given date falls, some database systems enable this through functions that can be applied in the SELECT statement. Examples are the `datepart()` function in Microsoft and Sybase SQL Servers (which requests the ‘weekday’ part of the date), and Oracle’s `to_char()` function, which specifies a format of `D` (for day of week number 1 through 7) or `DAY` to get the name of the day.

If your database does not support this function, you can add a computed item to the Results section to derive it.

### Formatting Day of Week Data

If you simply need to format the day of the week for displaying or printing out the date, then no special computation or statement is needed.

➤ To format the day of the week:

1. In the Results section, select the date item and choose Format > Number.

   The Number page of the Properties dialog box is displayed.

2. Select Custom from the Category list.

3. In the Format field, type `ddd` to display a three-letter day abbreviation or `dddd` to display the full name, and click OK.
Analyzing Data Based on Day of Week Data

If you add a format such as dddd mm/dd/yyyy, it displays a date as Tuesday 05/19/2000. This may not be sufficient if you need to perform analysis on data based on the day of the week. Despite the display format, the data in the field is still a date. That is, if you need to compare sales for Mondays versus other days of the week over a given time period, changing the display format does not address your original question. In this case, you need to group all Mondays to do that sort of analysis.

To analyze data based on the day of the week:

1. In the Results section, select the item and choose Results > Add Computed Item.
2. In the Name field, assign a new name to the column.
3. In the Definition field, type: to_char(<MyDate>,’dddd’)

Replace <MyDate> with the name of the column for which you need the day of the week information. This creates a string from the date column with the desired format, as discussed earlier. You can also add the following:

: decode((NEXT_DAY ( <MyDate>, 'Sunday' )) -<MyDate>, 7,'Sunday', 6,'Monday', 5,'Tuesday', 4,'Wednesday', 3,'Thursday', 2,'Friday', 1,'Saturday', 'Error!')

Common Computed Item Examples

The examples that follow show you how to apply some of the mathematical, numerical, and statistical calculations available in the Pivot and Chart sections using computed items.

- Math Functions
- Central Tendency
- Calculated Averages
- Percentile
- Rank

Math Functions

A mathematical equation consists of the argument and a simple or complex arithmetic operator that is applied to the argument. In this example, the sales tax is calculated as a percentage of the revenue (3.5%). The “Net Amount” column is calculated by subtracting the tax dollars from the revenue.

<table>
<thead>
<tr>
<th>Year</th>
<th>Amount Sales</th>
<th>Tax</th>
<th>Net Amount</th>
</tr>
</thead>
<tbody>
<tr>
<td>1999</td>
<td>$114,266,340.20</td>
<td>$3,998,321.81</td>
<td>$110,267,018.295</td>
</tr>
<tr>
<td>2000</td>
<td>$18,615,338.30</td>
<td>$651,536.84</td>
<td>$17,963,801.464</td>
</tr>
</tbody>
</table>
Central Tendency

If you need to distinguish patterns within a given set of data, you can begin looking for the center of distribution where statistics tend to reside. This form of measurement involves finding the “average” in the data set and is typically referred to as the Measure of Central Tendency technique.

Three types of measurements are associated with this technique:

- **Mean**—The value is equal to the sum of the measures divided by the number of measures.
- **Median**—The value is representative of the positional middle measure.
- **Mode**—The value that occurs with the greatest frequency.

In this example, Unit Sales represent the total number of product units purchased. Mean of Unit Sales represents the average purchase size. Median of Unit Sales represent the number of product units that scores exactly in the middle of all purchase quantities. The Mode of Unit Sales presents the number of product units most commonly purchased at one time.

<table>
<thead>
<tr>
<th></th>
<th>Unit Sales</th>
<th>Mean Value</th>
<th>Median Value</th>
<th>Mode Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>1999</td>
<td>5272112</td>
<td>411</td>
<td>276</td>
<td>370</td>
</tr>
<tr>
<td>2000</td>
<td>384533</td>
<td>621</td>
<td>404</td>
<td>441</td>
</tr>
</tbody>
</table>

Calculated Averages

Calculated averages can be applied to break columns and break values. In this example, a variety of columns are created and display different average calculations based on the Amount_Sales column.

The following table shows how averages have been calculated in the figure above.

<table>
<thead>
<tr>
<th>Column</th>
<th>Numeric Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Amount Sales</td>
<td>sum of Amount Sales by quarter and Product Line</td>
</tr>
<tr>
<td></td>
<td>= Sum (Amount_Sales)</td>
</tr>
<tr>
<td>Column</td>
<td>Numeric Function</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Entire Year</td>
<td>average purchase amount (Amount Sales) across all quarters and Product Lines</td>
</tr>
<tr>
<td></td>
<td>= Avg (Amount_Sales)</td>
</tr>
<tr>
<td>By Quarter</td>
<td>average purchase amount (Amount Sales) in a specific quarter</td>
</tr>
<tr>
<td></td>
<td>= Avg (Amount_Sales, Quarter)</td>
</tr>
<tr>
<td>For Quarter and Product Line</td>
<td>average purchase amount (Amount Sales) in a specific quarter for a Product line</td>
</tr>
<tr>
<td></td>
<td>= Avg data function applied to Amount_Sales column</td>
</tr>
<tr>
<td>For Q1</td>
<td>average purchase size (Amount Sales) across all Product Lines for Q1 specifically</td>
</tr>
<tr>
<td></td>
<td>= Avg (Amount_Sales, Quarter, 'Q1')</td>
</tr>
<tr>
<td>For Books</td>
<td>average purchase size (Amount Sales) across all Quarters for Books</td>
</tr>
<tr>
<td></td>
<td>= Avg (Amount_Sales, Product_Line, 'Books')</td>
</tr>
</tbody>
</table>

**Percentile**

Suppose Sales Managers qualify for a special bonus if they are within the 80th percentile (Qualify column). You can define an 80th percentile value for Amount Sales.

<table>
<thead>
<tr>
<th>Amount Sales</th>
<th>Eightieth Percentile</th>
<th>Qualify</th>
</tr>
</thead>
<tbody>
<tr>
<td>Redentor</td>
<td>365,131.171</td>
<td>7,258,107.987</td>
</tr>
<tr>
<td>Robinson</td>
<td>1,982,942</td>
<td>7,258,107.987</td>
</tr>
<tr>
<td>Saint</td>
<td>1,302,044.456</td>
<td>7,258,107.987</td>
</tr>
<tr>
<td>Schmidt</td>
<td>4,067,665.456</td>
<td>7,258,107.987</td>
</tr>
<tr>
<td>Schultz</td>
<td>808,609.729</td>
<td>7,258,107.987</td>
</tr>
<tr>
<td>Shay</td>
<td>3,159,782.897</td>
<td>7,258,107.987</td>
</tr>
<tr>
<td>Shibasaki</td>
<td>9,886,780.173</td>
<td>7,258,107.987</td>
</tr>
<tr>
<td>Stuber</td>
<td>691,660.051</td>
<td>7,258,107.987</td>
</tr>
<tr>
<td>Vilhena</td>
<td>731,076.471</td>
<td>7,258,107.987</td>
</tr>
<tr>
<td>Wah</td>
<td>7,266,360.345</td>
<td>7,258,107.987</td>
</tr>
<tr>
<td>Wayne</td>
<td>32,713,875.41</td>
<td>7,258,107.987</td>
</tr>
<tr>
<td>White</td>
<td>7,245,879.451</td>
<td>7,258,107.987</td>
</tr>
<tr>
<td>Wilson</td>
<td>6,353,554.035</td>
<td>7,258,107.987</td>
</tr>
</tbody>
</table>

The second example identifies countries that make sales transactions under $10,000.
Rank

You can return the rank of a number in a column of numbers. The Rank function works as if you were to sort the list in descending order. In this example, Amount Sales values are ranked for each Country.

Note:

The Rank function assigns duplicate numbers the same rank, which affects the ranks of subsequent numbers.
Project Sales

This example shows a calculation for a 20% increase in sales projections for each quarter, based on Amount Sales for 1999.

Scalar Function Examples

Following are examples of some common scalar functions. Each example shows the syntax used and the result of applying the function. The examples that follow do not include all the scalar functions. The functions described include:

- “Avg” on page 373
- “AvgNonNull” on page 374
- “ColMax” on page 376
- “ColMin” on page 377
- “Count” on page 379
- “CountDistinct” on page 379
- “CountNull” on page 381
- “CountNonNull” on page 382
- “Cume” on page 384
- “Sum” on page 393
- “Median” on page 385
- “Mode” on page 386
- “Percentile” on page 387
- “Rank” on page 389
- “RankAsc” on page 390
- “StdDev” on page 391
Avg

The Avg function returns the average (arithmetic mean) of values in a number column.

\[ \text{Avg}(\text{numbers}, \text{break\_col}, \text{break\_value}) \]

where:

- \textit{numbers} references the column that contains the numbers on which the average is calculated.
- \textit{break\_col} is an optional parameter that references a break column.
- \textit{break\_value} is an optional parameter that returns the average of numbers column where value in \textit{break\_col} equals \textit{break\_value}.

\textbf{Note:}

If constant values in the \textit{break\_value} column are substituted for data items, dates and text strings must be enclosed in single quotes.

The following examples show the results of inserting the \textit{Avg} function in three separate tables.

\textbf{Example 1}

In this example, the \textit{Avg} function is used on the numeric column. The results are shown in the Computed column.

\[ \text{Avg}(\text{Amount}) \]

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>183.67</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>183.67</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>97</td>
<td>183.67</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>183.67</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>183.67</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>183.67</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>183.67</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>183.67</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>183.67</td>
</tr>
</tbody>
</table>
Example 2

In this example, the Avg function is used on the numeric column and break_column. The results are shown in the Computed column.

\[ \text{Avg (Amount, State)} \]

Table 98  Avg Example 2

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>112</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>168.5</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>97</td>
<td>168.5</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>70</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>97</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>208</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>159</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>335</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>335</td>
</tr>
</tbody>
</table>

AvgNonNull

The AvgNonNull function returns the average (arithmetic mean) of values in a number column, excluding null values.

\[ \text{AvgNonNull (numbers, break_col, break_value)} \]

where:

- numbers references the column that contains the numbers on which the average is calculated.
- break_col is an optional parameter that references a break column.
- break_value is an optional parameter that returns the average of non-null numbers column where value in break_col equals break_value.

Note:

If constant values in the break_value column are substituted for data items, dates and text strings must be enclosed in single quotes.

The following examples show the results of inserting the AvgNonNull function in three separate tables.
Example 1

In this example, the `AvgNonNull` function is used on the numeric column. The results are shown in the Computed column.

`AvgNonNull (Amount)`

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>194.5</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>194.5</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>NULL</td>
<td>194.5</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>194.5</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>194.5</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>194.5</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>194.5</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>194.5</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>194.5</td>
</tr>
</tbody>
</table>

Example 2

In this example, the `AvgNonNull` function is used on the numeric column and break_column. The results are shown in the Computed column.

`AvgNonNull (Amount, State)`

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>112</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>240</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>NULL</td>
<td>240</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>70</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>97</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>208</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>159</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>335</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>335</td>
</tr>
</tbody>
</table>
Example 3

In this example, the AvgNonNull function is used on the numeric column, break_column, and break_value. The results are shown in the Computed column.

```
AvgNonNull (Amount, State, 'CA')
```

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>240</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>240</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>NULL</td>
<td>240</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>240</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>240</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>240</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>240</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>240</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>240</td>
</tr>
</tbody>
</table>

**ColMax**

The ColMax function returns the largest value in a column of numbers.

```
ColMax (numbers, break_col, break_value)
```

where:

`numbers` references the column that contains the number on which the maximum column value is calculated.

`break_col` is an optional parameter that references a break column.

`break_value` is an optional parameter that returns the maximum value of numbers column where value in break_col equals break_value.

**Note:**

If constant values in the `break_value` column are substituted for data items, dates and text strings must be enclosed in single quotes.

The following examples show the results of inserting the ColMax function in three separate tables.
Example 1

In this example, the ColMax function is used on the numeric column. The results are shown in the Computed column.

ColMax(Amount)

Table 101  ColMax Example

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>490</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>490</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>NULL</td>
<td>490</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>490</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>490</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>490</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>490</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>490</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>490</td>
</tr>
</tbody>
</table>

ColMin

The ColMin function returns the smallest value in a column of numbers.

ColMin (numbers, break_col, break_value)

where:

*numbers* references the column that contains the numbers on which the count of minimum column value is calculated.

*break_col* is an optional parameter that references a break column.

*break_value* is an optional parameter that returns the minimum value of numbers column where value in break_col equals break_value.

**Note:**

If constant values in the break_value column are substituted for data items, dates and text strings must be enclosed in single quotes.

The following examples show the results of inserting the ColMin function in three separate tables.
Example 1
In this example, the \texttt{ColMin} function is used on the numeric column. The results are shown in the Computed column.

\texttt{ColMin (Amount)}

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>70</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>70</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>NULL</td>
<td>70</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>70</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>70</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>70</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>70</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>70</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>70</td>
</tr>
</tbody>
</table>

Example 2
In this example, the \texttt{ColMin} function is used on the numeric column and break\_column. The results are shown in the Computed column.

\texttt{ColMin (Amount, State)}

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>112</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>240</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>Null</td>
<td>240</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>70</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>97</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>208</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>159</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>180</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>180</td>
</tr>
</tbody>
</table>
**Count**

The Count function counts the number of rows in a column.

\[ \text{Count} (\text{numbers, break\_col, break\_value}) \]

where:

- \textit{numbers} references the column that contains the numbers on which the count is calculated.
- \textit{break\_col} is an optional parameter that references a break column.
- \textit{break\_value} is an optional parameter that returns the count of numbers column where value in \textit{break\_col} equals \textit{break\_value}.

**Note:**

If constant values in the \textit{break\_value} column are substituted for data items, dates and text strings must be enclosed in single quotes.

The following examples show the results of inserting the Count function in three separate tables.

**Example 1**

In this example, the Count function is used on the numeric column. The results are shown in the Computed column.

\[ \text{Count (Amount)} \]

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>9</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>9</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>97</td>
<td>9</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>9</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>9</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>9</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>9</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>9</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>9</td>
</tr>
</tbody>
</table>

**CountDistinct**

The CountDistinct function counts the number of values in a column.
CountDistinct (numbers, break_col, break_values)

where:

- **numbers** references the column that contains the numbers on which the count of distinct (unique) values is calculated.
- **break_col** is an optional parameter that references a break column.
- **break_value** is an optional parameter that returns a distinct (unique) count of numbers column where value in break_col equals break_value.

**Note:**

The `CountDistinct` function differentiates actual values and not the rows. The Count function counts only the actual rows in a column. For example, if a column named “OS Operating Systems” has one hundred rows and shows data by Windows and UNIX systems, the `CountDistinct` function counts only the three operating systems and not the number of rows.

The following examples show the results of inserting the `CountDistinct` function in three separate tables.

**Example 1**

In this example, the `CountDistinct` function is used on the numeric column. The results are shown in the Computed column.

`CountDistinct (Amount)`

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>8</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>8</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>240</td>
<td>8</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>8</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>8</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>8</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>8</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>8</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>8</td>
</tr>
</tbody>
</table>

**Example 2**

In this example, the `CountDistinct` function is used on the numeric column and break_column. The results are shown in the Computed column.
The `CountNull` function counts the number of rows in a column that contains null values.

**CountNull**

\[ \text{CountNull (numbers, break\_col, break\_value)} \]

where:

- `numbers` references the column that contains the numbers on which the count of null values is calculated.
- `break\_col` is an optional parameter that references a break column.
- `break\_value` is an optional parameter that returns the count of null numbers column where value in `break\_col` equals `break\_value`.

**Note:**

If constant values in the `break\_value` column are substituted for data items, dates and text strings must be enclosed in single quotes.

The following examples show the results of inserting the `CountNull` function in three separate tables.

**Example**

In this example, the `CountNull` function is used on the numeric column. The results are shown in the Computed column.

\[ \text{CountNull (Amount)} \]
Table 107  CountNull Example

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>1</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>1</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>NULL</td>
<td>1</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>1</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>1</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>1</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>1</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>1</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>1</td>
</tr>
</tbody>
</table>

CountNonNull

The CountNonNull function counts the number of rows in a column that do not contain null values.

CountNonNull (numbers, break_col, break_value)

where:

`numbers` references the column that contains the numbers on which the count of non-null values is calculated.

`break_col` is an optional parameter that references a break column.

`break_value` is an optional parameter that returns the count of non-null numbers column where value in break_col equals break_value.

Note:

If constant values in the `break_value` column are substituted for data items, dates and text strings must be enclosed in single quotes.

The following examples show the results of inserting the CountNonNull function in three separate tables.

Example 1

In this example, the CountNonNull function is used on the numeric column. The results are shown in the Computed column.

CountNonNull (Amount)
### Table 108  CountNonNull Example 1

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>8</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>8</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>NULL</td>
<td>8</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>8</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>8</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>8</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>8</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>8</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>8</td>
</tr>
</tbody>
</table>

### Example 2

In this example, the `CountNonNull` function is used on the numeric column and `break_column`. The results are shown in the `Computed` column.

\[
\text{CountNonNull (Amount, State)}
\]

### Table 109  CountNonNull Example 2

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>1</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>1</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>NULL</td>
<td>1</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>1</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>1</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>1</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>1</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>2</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>2</td>
</tr>
</tbody>
</table>

### Example 3

In this example, the `CountNonNull` function is used on the numeric column, `break_column`, and `break_value`. The results are shown in the `Computed` column.

\[
\text{CountNonNull (Amount, State, ‘CA’)}
\]
Table 110  CountNonNull Example 3

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>1</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>1</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>97</td>
<td>1</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>1</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>1</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>1</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>1</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>1</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>1</td>
</tr>
</tbody>
</table>

Cume

The Cume function returns a cumulative running total for each value in a column of numbers.

\[ \text{Cume (numbers, break\_col)} \]

where:

- **numbers** references the column that contains the numbers on which the cume is calculated.
- **break\_col** is an optional parameter that references a break column.

**Note:**

If constant values in the break_value column are substituted for data items, dates and text strings must be enclosed in single quotes.

The following examples show the results of inserting the Cume function in two separate tables.

**Example 1**

In this example, the Cume function is used on the numeric column. The results are shown in the Computed column.

\[ \text{Cume (Amount)} \]

Table 111  Cume Example 1

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>112</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>352</td>
</tr>
<tr>
<td>State</td>
<td>City</td>
<td>Amount</td>
<td>Computed</td>
</tr>
<tr>
<td>-------</td>
<td>----------</td>
<td>--------</td>
<td>----------</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>97</td>
<td>449</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>519</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>646</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>824</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>983</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>1473</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>1653</td>
</tr>
</tbody>
</table>

**Example 2**

In this example, the Cume function is used on the numeric column and break_column. The results are shown in the Computed column.

Cume (Amount, State)

**Table 112  Cume Example 2**

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>112</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>240</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>97</td>
<td>337</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>70</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>97</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>208</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>159</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>490</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>670</td>
</tr>
</tbody>
</table>

**Median**

The Median function returns the median of a column of numbers. The median is the middle value or number in the middle of a set of numbers (and not the average).

Median (numbers, break_col)

*numbers* references the column that contains the numbers on which the median is calculated. 
*break_col* is an optional parameter that references a break column.

The following examples show the results of inserting the Median function in two separate tables.
Example 1

In this example, the Median function is used on a numeric column that has an odd number of rows:

\[
\text{Median (Amount)}
\]

The Median function returns the number in the middle, which in this example is 30.

Table 113  Median Example 1

<table>
<thead>
<tr>
<th>State</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>10</td>
<td>30</td>
</tr>
<tr>
<td>CA</td>
<td>20</td>
<td>30</td>
</tr>
<tr>
<td>FL</td>
<td>30</td>
<td>30</td>
</tr>
<tr>
<td>MD</td>
<td>40</td>
<td>30</td>
</tr>
<tr>
<td>MI</td>
<td>50</td>
<td>30</td>
</tr>
</tbody>
</table>

If the numbers column has an even number of rows, the Median function calculates the average of the two numbers in the middle.

Table 114  Median Example 2

<table>
<thead>
<tr>
<th>State</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>10</td>
<td>25</td>
</tr>
<tr>
<td>CA</td>
<td>20</td>
<td>25</td>
</tr>
<tr>
<td>FL</td>
<td>30</td>
<td>25</td>
</tr>
<tr>
<td>MD</td>
<td>40</td>
<td>25</td>
</tr>
</tbody>
</table>

Mode

The Mode function returns the most frequently occurring value in columns of numbers.

\[
\text{Mode (numbers, break\_col)}
\]

where:

- **numbers** references the column that contains the numbers on which the mode is calculated.
- **break\_col** is an optional parameter that references a break column.

Note:

Null values in the numbers column are ignored. Zeroes (0) are included. If the numbers column has no duplicate data values, the Mode function returns the value of the first cell in the numbers column.
The following examples show the results of inserting the Mode function in two separate tables.

**Example**

In this example, the Mode function is used on the numeric column. The results are shown in the Computed column.

```sql
Mode(Amount)
```

<table>
<thead>
<tr>
<th>State</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>10</td>
<td>10</td>
</tr>
<tr>
<td>CA</td>
<td>10</td>
<td>10</td>
</tr>
<tr>
<td>FL</td>
<td>0</td>
<td>10</td>
</tr>
<tr>
<td>MD</td>
<td>40</td>
<td>10</td>
</tr>
<tr>
<td>MI</td>
<td>50</td>
<td>10</td>
</tr>
</tbody>
</table>

**Percentile**

The Percentile function returns the $n$th percentile of values in a column of numbers.

```sql
Percentile(numbers, n, break_col)
```

where:

- `numbers` references the column that contains the numbers on which the percentile is calculated.
- `n` is the percentile value 0 to 1 inclusive.
- `break_col` is an optional parameter that references a break column.

**Note:**

Percentile can also be used to return quartile values by setting the $n$th percentile to the following: 0.25 for first quartile, 0.5 for second quartile, 0.75 for third quartile.

The following examples show the results of inserting the Percentile function in three separate tables.

**Example 1**

In this example, two computed value columns have been calculated. In the first computed column, the Percentile function is used on the numeric column and the $n$th percentile of values (.80 in this case).

```sql
Percentile(Units, .80)
```

In the second computed column, the Percentile function is used on the numeric column, the $n$th percentile of values (.80 in this case), and the break_column.
### Table 116  Percentile Example

<table>
<thead>
<tr>
<th>State</th>
<th>Units</th>
<th>Computed 1</th>
<th>Computed 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>WI</td>
<td>50</td>
<td>191.8</td>
<td>50</td>
</tr>
<tr>
<td>AZ</td>
<td>70</td>
<td>191.8</td>
<td>70</td>
</tr>
<tr>
<td>CA</td>
<td>96</td>
<td>191.8</td>
<td>99.8</td>
</tr>
<tr>
<td>CA</td>
<td>98</td>
<td>191.8</td>
<td>99.8</td>
</tr>
<tr>
<td>CA</td>
<td>101</td>
<td>191.8</td>
<td>99.8</td>
</tr>
<tr>
<td>FL</td>
<td>112</td>
<td>191.8</td>
<td>112</td>
</tr>
<tr>
<td>MD</td>
<td>159</td>
<td>191.8</td>
<td>159</td>
</tr>
<tr>
<td>NY</td>
<td>241</td>
<td>191.8</td>
<td>440.2</td>
</tr>
<tr>
<td>NY</td>
<td>490</td>
<td>191.8</td>
<td>440.2</td>
</tr>
</tbody>
</table>

#### Example 2

In this example, two computed value columns have been calculated. In the first computed column, the `Percentile` function is used on the numeric column and the \( n^{th} \) percentile of values (0 in this case).

#### Table 117  Percentile Example

<table>
<thead>
<tr>
<th>State</th>
<th>Units</th>
<th>Computed 1</th>
<th>Computed 2</th>
</tr>
</thead>
<tbody>
<tr>
<td>WI</td>
<td>50</td>
<td>50</td>
<td>96</td>
</tr>
<tr>
<td>AZ</td>
<td>70</td>
<td>50</td>
<td>96</td>
</tr>
<tr>
<td>CA</td>
<td>96</td>
<td>50</td>
<td>96</td>
</tr>
<tr>
<td>CA</td>
<td>98</td>
<td>50</td>
<td>96</td>
</tr>
<tr>
<td>CA</td>
<td>101</td>
<td>50</td>
<td>96</td>
</tr>
<tr>
<td>FL</td>
<td>112</td>
<td>50</td>
<td>96</td>
</tr>
<tr>
<td>MD</td>
<td>159</td>
<td>50</td>
<td>96</td>
</tr>
<tr>
<td>NY</td>
<td>241</td>
<td>50</td>
<td>96</td>
</tr>
</tbody>
</table>

In the second computed column, the `Percentile` function is used on the numeric column, and the \( n^{th} \) percentile of values (.25 in this case).

**Percentile (Units, .25)**
### Rank

The `Rank` function returns the rank of a number in a column of numbers. It works as if you were to sort the list in descending order.

\[ \text{Rank}(\text{numbers}, \text{break}_\text{col}) \]

where:

- `numbers` references the column that contains the numbers on which the rank is calculated.
- `break_col` is an optional parameter that references a break column.

**Note:**

The `Rank` function assigns duplicate numbers the same rank. The presence of duplicate numbers affects the ranks of subsequent numbers.

The following examples show the results of inserting the `Rank` function in two separate tables.

**Example 1**

In this example, the `Rank` function is used for the numeric column (the column that contains the numbers to rank). The results are shown in the Computed column.

\[ \text{Rank}(\text{Amount}) \]

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>6</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>241</td>
<td>2</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>97</td>
<td>7</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>9</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>7</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>3</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>5</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>1</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>4</td>
</tr>
</tbody>
</table>
**RankAsc**

The *RankAsc* function returns the rank of a number in a column of numbers. It works as if you were to sort the list in ascending order. In this case, the rank of the number would be its position.

*RankAsc* (*numbers*, *break_col*)

where:

*numbers* references the column that contains the numbers on which the rank is calculated.

*break_col* is an optional parameter that references a break column.

**Note:**

The *RankAsc* function assigns duplicate numbers the same rank. The presence of duplicate numbers affects the ranks of subsequent numbers.

The following examples show the results of inserting the *RankAsc* function in two separate tables.

**Example 1**

In this example, the *RankAsc* function is used on the numeric column (the column containing the numbers to rank). The results are shown in the Computed column.

*RankAsc* (*Amount*)

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>4</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>8</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>97</td>
<td>2</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>1</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>2</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>7</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>5</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>9</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>6</td>
</tr>
</tbody>
</table>

**Example 2**

In this example, the *RankAsc* function is used on the numeric column and break_column. The results are shown in the Computed column.

*RankAsc* (*Amount*, *State*)
Table 120  RankAsc Example 2

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>3</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>6</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>97</td>
<td>6</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>1</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>2</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>5</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>4</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>7</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>7</td>
</tr>
</tbody>
</table>

**Note:**
The RankAsc is calculated on the \( \text{SUM(col}_1) \) and grouped by \( \text{col}_2 \).

**StdDev**
The \( \text{StdDev} \) function returns a standard deviation based on a sample. It is a measure of how widely values are dispersed from the average value (the mean).

\[
\text{StdDev} \ (\text{numbers, break_col})
\]

where:

- \( \text{numbers} \) references the column that contains the numbers on which the standard deviation is calculated.
- \( \text{break_col} \) is an optional parameter that references a break column.

**Note:**
\( \text{StdDev} \) assumes that its arguments are a sample of the population. If you data represents the entire population, then compute the standard deviation using \( \text{StdDevp} \).

**Note:**
The standard deviation is calculated using the \( \text{nonbiased} \) or \( n-1 \) method.

**Note:**
If a result set contains one row of data or less, the \( \text{StdDev} \) function should return an error.
The following examples show the results of inserting the \texttt{StdDev} function in two separate tables.

\textbf{Example}

In this example, the \texttt{StdDev} function is used on the numeric column. The results are shown in the Computed column.

\texttt{StdDev (Amount)}

\textbf{StdDevp}

The \texttt{StdDevp} function calculates and returns a standard deviation based on the entire population given as arguments. The standard deviation is a measure of how widely values are dispersed from the average value (the mean).

\texttt{StdDevp (numbers, break\_col)}

where:

- \textit{numbers} refers to the column that contains the numbers on which the standard deviation is calculated.
- \textit{break\_col} is an optional parameter that references a break column.

\textbf{Note:}

\texttt{StdDevp} assumes that its arguments are the entire population. If your data represents a sample of the population, then compute the standard deviation using \texttt{StdDev}.

\textbf{Note:}

The standard deviation is calculated using the \textit{biased or n} method.

The following examples show the results of inserting the \texttt{StdDevp} function in two separate tables.

\textbf{Example}

In this example, the \texttt{StdDevp} function is used for the numeric column. The results are shown in the Computed column.

\texttt{StdDevp (Amount)}

\begin{table}[h]
\centering
\begin{tabular}{|c|c|c|c|}
\hline
\textbf{State} & \textbf{City} & \textbf{Amount} & \textbf{Computed} \\
\hline
AZ & Tucson & 112 & 120.79 \\
\hline
CA & Burbank & 240 & 120.79 \\
\hline
CA & Glendale & 97 & 120.79 \\
\hline
\end{tabular}
\caption{\texttt{StdDevp} Example}
\end{table}
The **Sum** function computes the total for a column of numbers.

\[
\text{Sum (numbers, break\_col, break\_value)}
\]

where:

* **numbers** references the column that contains the numbers on which the sum is calculated.
* **break\_col** is an optional parameter that references a break column.
* **break\_value** is an optional parameter that returns the sum of numbers column where value in break\_col equals break\_value.

**Note:**

If constant values in the break\_value column are substituted for data items, dates and text strings must be enclosed in single quotes.

The following examples show the results of inserting the **Sum** function in two separate tables.

**Example 1**

In this example, the **Sum** function is used on the numeric column. The results are shown in the Computed column.

\[\text{Sum (Amount)}\]

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>1556</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>1556</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>NULL</td>
<td>1556</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>1556</td>
</tr>
</tbody>
</table>
Example 2

In this example, the \textit{Sum} function has been inserted for the numeric column and \textit{break\_column} using the following definition:

\textit{Sum} (\textit{Amount},\textit{State})

The results are shown in the Computed column.

\begin{table}[h]
\centering
\begin{tabular}{|c|c|c|c|}
\hline
\textbf{State} & \textbf{City} & \textbf{Amount} & \textbf{Computed} \\
\hline
AZ & Tuscon & 112 & 112 \\
CA & Burbank & 240 & 240 \\
CA & Glendale & Null & 240 \\
FL & Palmetto & 70 & 70 \\
MD & Laurel & 97 & 97 \\
MI & Detroit & 208 & 208 \\
MN & Eagan & 159 & 159 \\
NY & New York & 490 & 670 \\
NY & Rochester & 180 & 670 \\
\hline
\end{tabular}
\caption{Table 123}
\end{table}

\textbf{Var}

The \textit{Var} function estimates variance based on a sample.

\textit{Var} (\textit{numbers}, \textit{break\_col})

where:

\textit{numbers} references the column that contains the numbers on which the variance is calculated.

\textit{break\_col} is an optional parameter that references a break column.
Note:

Var assumes that its arguments are a sample of the population. If your data represents the entire population, then compute the variance using Varp.

The following examples show the results of inserting the Var function in two separate tables.

Example 1

In this example, the Var function is used on the numeric column. The results are shown in the Computed column.

\[ \text{Var(Amount)} \]

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>16,413.25</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>16,413.25</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>97</td>
<td>16,413.25</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>16,413.25</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>16,413.25</td>
</tr>
<tr>
<td>NY</td>
<td>New York</td>
<td>490</td>
<td>16,413.25</td>
</tr>
<tr>
<td>NY</td>
<td>Rochester</td>
<td>180</td>
<td>16,413.25</td>
</tr>
</tbody>
</table>

Example 2

In this example, the Var function is used on the numeric column and break_column. The results are shown in the Computed column.

\[ \text{Var(Amount, State)} \]

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>0</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>10,224.50</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>97</td>
<td>10,224.50</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>0</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>0</td>
</tr>
</tbody>
</table>
### Varp

The `Varp` function estimates variance based on the entire population.

\[ \text{Varp} \left( \text{numbers, break\_col} \right) \]

where:

- `numbers` references the column that contains the numbers on which the variance is calculated.
- `break\_col` is an optional parameter that references a break column.

**Note:**

`Varp` assumes that its arguments are the entire population. If your data represents a sample of the population, then compute the variance using `Var`.

The following examples show the results of inserting the `Varp` function in two separate tables.

**Example**

In this example, the `Varp` function is used on the numeric column. The results are shown in the `Computed` column.

\[ \text{Varp} \left( \text{Amount} \right) \]

<table>
<thead>
<tr>
<th>State</th>
<th>City</th>
<th>Amount</th>
<th>Computed</th>
</tr>
</thead>
<tbody>
<tr>
<td>AZ</td>
<td>Tucson</td>
<td>112</td>
<td>14,589.56</td>
</tr>
<tr>
<td>CA</td>
<td>Burbank</td>
<td>240</td>
<td>14,589.56</td>
</tr>
<tr>
<td>CA</td>
<td>Glendale</td>
<td>97</td>
<td>14,589.56</td>
</tr>
<tr>
<td>FL</td>
<td>Palmetto</td>
<td>70</td>
<td>14,589.56</td>
</tr>
<tr>
<td>MD</td>
<td>Laurel</td>
<td>97</td>
<td>14,589.56</td>
</tr>
<tr>
<td>MI</td>
<td>Detroit</td>
<td>208</td>
<td>14,589.56</td>
</tr>
<tr>
<td>MN</td>
<td>Eagan</td>
<td>159</td>
<td>14,589.56</td>
</tr>
</tbody>
</table>
Trend Functions

Both the Pivot and Results sections offer trend functions, which allow you to perform statistical analysis within a sample data set of variable size. Trend functions are useful for removing data irregularities/fluctuations, analyzing data trends, and smoothing a set of data points. They are often used to reduce noise that exists when visualizing large data sets by providing aggregation capabilities at configurable window sizes.

Review these topics for information:

- General Moving Average and Moving Function Functionality
- Simple Moving Averages
- Positioning of Moving Average Results—Trailing and Centered Averages
- “Weighted Moving Averages” on page 401
- “Exponential Moving Averages” on page 403
- “Moving Diff” on page 404
- “Moving Maximum” on page 405
- “Moving Median” on page 407
- “Moving Sum” on page 408
- “Moving Minimum” on page 409
- “Direction Of Moving Function Calculation” on page 410

General Moving Average and Moving Function Functionality

The term "Moving" when used with functions such as Moving Averages usually refers to a fixed window or "sub-range" of analysis that moves over a larger range of numeric data values. For each window, a calculation such as an average (mean) is performed. As the window moves over the larger range, one number value is dropped from the window and a new value is added.

To illustrate the effect of Moving Averages as opposed to a simple average (mean) consider the following list of arbitrary "Sales" values over a period of twelve months as shown in a Table or Results section:
The simple mean value of all of the above twelve Sales values is:

\[
\text{Sum of all twelve values divided by 12} = \frac{296}{12} = 24.67
\]

While having some virtue, this simple mean value does not offer any insight into analyzing the variation trend of the original values or to provide a more accurate mean value at varying points of the range. Moving Averages, on the other hand, do offer the ability to understand the trend of data by calculating many average (mean) values over the entire range of original data values.

There are several variations to Moving Average calculation, the most common of these are: Simple Moving Averages, Weighted Moving Averages and Exponential Moving Averages. All of these variations are described in detail in the following sections. Additionally, other "Moving Functions": Moving Maximum, Moving Minimum, Moving Median, Moving Sum and Moving Difference whose functionality closely resembles that of Moving Averages are discussed.

**Simple Moving Averages**

In a Simple Moving Average calculation, the original range of data values is split into smaller "windows" and a simple mean value of each window is calculated. An example of the calculation involved for such Simple Moving Averages is shown below.

<table>
<thead>
<tr>
<th>Month</th>
<th>Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan</td>
<td>10</td>
</tr>
<tr>
<td>Feb</td>
<td>15</td>
</tr>
<tr>
<td>Mar</td>
<td>17</td>
</tr>
<tr>
<td>Apr</td>
<td>20</td>
</tr>
<tr>
<td>May</td>
<td>22</td>
</tr>
<tr>
<td>Jun</td>
<td>20</td>
</tr>
<tr>
<td>Jul</td>
<td>25</td>
</tr>
<tr>
<td>Aug</td>
<td>27</td>
</tr>
<tr>
<td>Sep</td>
<td>30</td>
</tr>
<tr>
<td>Oct</td>
<td>35</td>
</tr>
<tr>
<td>Nov</td>
<td>37</td>
</tr>
<tr>
<td>Dec</td>
<td>40</td>
</tr>
</tbody>
</table>
If the first three Sales values were summed and then this sum was divided by 3 to give a mean value, this value would be:

\[(10 + 15 + 17) / 3 = 42 / 3 = 14\]

Next, consider the mean of the sum of the second, third and fourth original values i.e.:

\[(15 + 17 + 20) / 3 = 52 / 3 = 17.33\]

This pattern could be repeated to reveal the mean values of the third, fourth and fifth values; fifth, sixth and seventh values and so on until all subsequent windows of three numbers are summed and their mean values obtained.

The Simple Moving Averages of the original range of values for a window of 3 (i.e. in this case, a 3-Month Simple Moving Average) could be evaluated to be:

<table>
<thead>
<tr>
<th>Month</th>
<th>Original Sales Values</th>
<th>3-Month Simple Moving Average</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan</td>
<td>10</td>
<td></td>
</tr>
<tr>
<td>Feb</td>
<td>15</td>
<td></td>
</tr>
<tr>
<td>Mar</td>
<td>17</td>
<td>14</td>
</tr>
<tr>
<td>Apr</td>
<td>20</td>
<td>17.33</td>
</tr>
<tr>
<td>May</td>
<td>22</td>
<td>19.66</td>
</tr>
<tr>
<td>Jun</td>
<td>20</td>
<td>20.66</td>
</tr>
<tr>
<td>Jul</td>
<td>25</td>
<td>22.33</td>
</tr>
<tr>
<td>Aug</td>
<td>27</td>
<td>24</td>
</tr>
<tr>
<td>Sep</td>
<td>30</td>
<td>27.33</td>
</tr>
<tr>
<td>Oct</td>
<td>35</td>
<td>30.66</td>
</tr>
</tbody>
</table>
Positioning of Moving Average Results—Trailing and Centered Averages

Note that in Simple Moving Average table, the average of numbers n, n+1 and n+2 in the "Original Values" column (where "n" refers to the row position) is placed in row position n+2 of the "3-Month Simple Moving Average" column. This Moving Average display technique is known as "Trailing Averages". An alternative display technique is known as "Centered Averages" which instead positions the Moving Average in the center row of the window. The table following illustrates the difference in these display techniques using the first three values from above:

<table>
<thead>
<tr>
<th>Month</th>
<th>Centered Averages</th>
<th>Trailing Averages</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan</td>
<td>14</td>
<td></td>
</tr>
<tr>
<td>Feb</td>
<td>14</td>
<td></td>
</tr>
<tr>
<td>Mar</td>
<td></td>
<td>14</td>
</tr>
</tbody>
</table>

"Centered Averages" display requires further calculations when the window is an even number and it is not available for Simple Moving Averages and other Moving Functions at this time.

All "Moving Functions" in this particular implementation will display data according to the "Trailing Averages" principle.

Note also that from the above two tables, "Trailing Averages" display causes the initial n-1 (where n = window size) rows of result data to have no value (rows 1 and 2 are blank in the above examples). This is the generally accepted standard for the initial "n-1" terms and is the standard adopted for the implementation of most Moving Functions.

The following table illustrates the above monthly Sales data Simple Moving Average calculation using "Trailing Averages" display:

The Simple Moving Averages of the original range of values for a window of 3 (i.e. in this case, a 3-Month Simple Moving Average) could be evaluated to be:

<table>
<thead>
<tr>
<th>Month</th>
<th>Original Sales Values</th>
<th>3-Month Simple Moving Average</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan</td>
<td>10</td>
<td></td>
</tr>
<tr>
<td>Feb</td>
<td>15</td>
<td></td>
</tr>
<tr>
<td>Mar</td>
<td>17</td>
<td>14</td>
</tr>
</tbody>
</table>
## 3-Month Simple Moving Average

<table>
<thead>
<tr>
<th>Month</th>
<th>Original Sales Values</th>
<th>3-Month Simple Moving Average</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apr</td>
<td>20</td>
<td>17.33</td>
</tr>
<tr>
<td>May</td>
<td>22</td>
<td>19.66</td>
</tr>
<tr>
<td>Jun</td>
<td>20</td>
<td>20.66</td>
</tr>
<tr>
<td>Jul</td>
<td>25</td>
<td>22.33</td>
</tr>
<tr>
<td>Aug</td>
<td>27</td>
<td>24</td>
</tr>
<tr>
<td>Sep</td>
<td>30</td>
<td>27.33</td>
</tr>
<tr>
<td>Oct</td>
<td>35</td>
<td>30.66</td>
</tr>
<tr>
<td>Nov</td>
<td>37</td>
<td>34</td>
</tr>
<tr>
<td>Dec</td>
<td>40</td>
<td>37.33</td>
</tr>
</tbody>
</table>

## Weighted Moving Averages

With Simple Moving Averages, each data value in the "window" in which the calculation is performed is given an equal significance or weight. It is often the case, especially in financial price data analysis, that more chronologically recent data should carry a greater weight. In these cases, Weighted Moving Average (or Exponential Moving Average - see the following topic) functionality is often preferred.

Consider the same table of Sales data values for twelve months:

<table>
<thead>
<tr>
<th></th>
<th>Month</th>
<th>Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Jan</td>
<td>10</td>
</tr>
<tr>
<td>2</td>
<td>Feb</td>
<td>15</td>
</tr>
<tr>
<td>3</td>
<td>Mar</td>
<td>17</td>
</tr>
<tr>
<td>4</td>
<td>Apr</td>
<td>20</td>
</tr>
<tr>
<td>5</td>
<td>May</td>
<td>22</td>
</tr>
<tr>
<td>6</td>
<td>Jun</td>
<td>20</td>
</tr>
<tr>
<td>7</td>
<td>Jul</td>
<td>25</td>
</tr>
<tr>
<td>8</td>
<td>Aug</td>
<td>27</td>
</tr>
<tr>
<td>9</td>
<td>Sep</td>
<td>30</td>
</tr>
<tr>
<td>10</td>
<td>Oct</td>
<td>35</td>
</tr>
<tr>
<td>11</td>
<td>Nov</td>
<td>37</td>
</tr>
<tr>
<td>12</td>
<td>Dec</td>
<td>40</td>
</tr>
</tbody>
</table>

➢ To calculate a Weighted Moving Average:

1. Calculate how many intervals of data are participating in the Moving Average calculation (i.e. the size of the calculation "window").
If the calculation window is said to be n, then the most recent data value in the window is multiplied by n, the next most recent multiplied by n-1, the value prior to that multiplied by n-2 and so on for all values in the Window.

2 Divide the sum of all of the multiplied values by the sum of the weights to give the Weighted Moving Average over that window.

3 Place the Weighted Moving Average value in a new column according to the trailing averages positioning described above.

To illustrate these steps, consider if a 3-month Weighted Moving Average of Sales in December is required (using the above table of Sales values).

The term "3-month" implies that the calculation "window" is 3, therefore the Weighted Moving Average calculation algorithm for this case should be:

\[
\frac{(\text{Dec Sales value } \times 3) + (\text{Nov Sales value } \times 2) + (\text{Oct Sales value } \times 1)}{3 + 2 + 1}
\]

\[
= \frac{(40 \times 3) + (37 \times 2) + (35 \times 1)}{6}
\]

\[
= \frac{120 + 74 + 35}{6}
\]

\[
= \frac{229}{6}
\]

\[
= 38.17
\]

Or, if a 3-month Weighted Moving Average were evaluated over the entire original range of data, the results would be:

<table>
<thead>
<tr>
<th>Month</th>
<th>Original Sales Values</th>
<th>3-Month Simple Moving Average</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan</td>
<td>10</td>
<td></td>
</tr>
<tr>
<td>Feb</td>
<td>15</td>
<td></td>
</tr>
<tr>
<td>Mar</td>
<td>17</td>
<td>15.12</td>
</tr>
<tr>
<td>Apr</td>
<td>20</td>
<td>18.17</td>
</tr>
<tr>
<td>May</td>
<td>22</td>
<td>20.5</td>
</tr>
<tr>
<td>Jun</td>
<td>20</td>
<td>20.67</td>
</tr>
<tr>
<td>Jul</td>
<td>25</td>
<td>22.83</td>
</tr>
<tr>
<td>Aug</td>
<td>27</td>
<td>25.17</td>
</tr>
<tr>
<td>Sep</td>
<td>30</td>
<td>28.17</td>
</tr>
<tr>
<td>Oct</td>
<td>35</td>
<td>32</td>
</tr>
<tr>
<td>Nov</td>
<td>37</td>
<td>35.17</td>
</tr>
<tr>
<td>Dec</td>
<td>40</td>
<td>38.17</td>
</tr>
</tbody>
</table>
Exponential Moving Averages

Exponential Moving Averages, similar to Weighted Moving Averages, also assign a greater weight to more recent data values. Unlike Weighted Moving Averages, however, they use the previously calculated Exponential Moving Average value as a basis for calculation rather than the original (non-Averaged) data values. In this way, the calculation method used by Exponential Moving Averages is cumulative, meaning that (unlike Simple Moving Averages or Weighted Moving Averages) all previous data values have some effect on the Exponential Moving Average to be calculated, although this effect diminishes greatly with time.

Exponential Moving Averages tend to be more accurate than the other types of Moving Average when the original data values show a more rapid degree of variation over time (or other variable).

The formula for calculating an Exponential Moving Average (EMA) is:

\[ X = (K \times (C - P)) + P \]

Where:

- \( X \) = Current EMA (i.e. EMA to be calculated)
- \( C \) = Current original data value
- \( K \) = Smoothing Constant
- \( P \) = Previous EMA

(The first EMA in the range to be calculated is arbitrary and can be the corresponding original data value or, often, a Simple Moving Average value.

Where:

- \( K \) = Smoothing Constant = \( 2 / (1 + n) \)
- \( n \) = number of periods for EMA i.e. the Window to calculate.

This rather complex calculation is, perhaps, best illustrated by example.

Consider the table of monthly Sales values as shown previously:
If we calculated the Exponential Moving Average in a similar fashion to the 3-Month Simple Moving Average, we would perform the following steps:

➤ To calculate the exponential moving average:
1. **Calculate the Smoothing Constant according to the 2 / (1 + n) formula.**
   
   \[ \text{N} = \text{window of values} = 3, \therefore \text{the Smoothing Constant is:} \]
   
   \[ \frac{2}{1 + 3} = 0.5 \]

2. **For the first Exponential Moving Average, use the first original data value (in this case, that for the Month of "Jan").**

3. **For subsequent values, follow the calculation according to the above formula.**
   
   \[ X = (K \times (C - P)) + P \] as indicated below:

<table>
<thead>
<tr>
<th>Month</th>
<th>Sales</th>
<th>Calculation ((K \times (C - P)) + P)</th>
<th>Exponential Moving Average</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan</td>
<td>10</td>
<td>(\text{Original value})</td>
<td>10</td>
</tr>
<tr>
<td>Feb</td>
<td>15</td>
<td>((0.5 \times (15 - 10)) + 10)</td>
<td>12.5</td>
</tr>
<tr>
<td>Mar</td>
<td>17</td>
<td>((0.5 \times (17 - 12.5)) + 12.5)</td>
<td>14.75</td>
</tr>
<tr>
<td>Apr</td>
<td>20</td>
<td>((0.5 \times (20 - 14.75)) + 14.75)</td>
<td>17.375</td>
</tr>
<tr>
<td>May</td>
<td>22</td>
<td>((0.5 \times (22 - 17.375)) + 17.375)</td>
<td>19.688</td>
</tr>
<tr>
<td>Jun</td>
<td>20</td>
<td>((0.5 \times (20 - 19.6875)) + 19.6875)</td>
<td>19.844</td>
</tr>
<tr>
<td>Jul</td>
<td>25</td>
<td>((0.5 \times (25 - 19.844)) + 19.844)</td>
<td>22.422</td>
</tr>
<tr>
<td>Aug</td>
<td>27</td>
<td>((0.5 \times (27 - 22.422)) + 22.422)</td>
<td>24.711</td>
</tr>
<tr>
<td>Sep</td>
<td>30</td>
<td>((0.5 \times (30 - 24.711)) + 24.711)</td>
<td>27.355</td>
</tr>
<tr>
<td>Oct</td>
<td>35</td>
<td>((0.5 \times (35 - 27.355)) + 27.355)</td>
<td>31.178</td>
</tr>
<tr>
<td>Nov</td>
<td>37</td>
<td>((0.5 \times (37 - 31.178)) + 31.178)</td>
<td>34.089</td>
</tr>
<tr>
<td>Dec</td>
<td>40</td>
<td>((0.5 \times (40 - 34.089)) + 34.089)</td>
<td>37.044</td>
</tr>
</tbody>
</table>

**Moving Diff**

The MovingDiff function operates over a moving window of values, and returns the difference between the current value and the value at the beginning of the window. This function is similar to the MovingMax function. No “Weighted” or “Exponential” can be calculated for this function.

The MovingDiff function takes the following arguments:

MovingDiff (column, window, break_col)
where:

- **column** (required)—Specify the column that contains the numeric fact on which the Moving Function column value is calculated. If you are applying the function from the Pivot section, you can only use a column that has already been added to the Facts pane of the data layout.

- **window** (optional)—Specify a moving “window” of values from the Column on which the Moving Function gets calculated. The window value must be a positive integer of value equal to or less than the total number of rows in the Column (within any Break Column value). If the window value is an integer of greater value than the number of values in the Column, then the window value defaults to the number of rows in the Column (within any Break Column value). If no window value is specified, then the window value defaults to 3.

- **break column** (optional)—Specify the name of the column on which to perform the Moving Function calculation. The break column refers to the rows of similar valued data cell within the Pivot or Results section.

The following results would occur if you used the Moving Diff function with a Window of 3 (MovingDiff(Sales,3)).

<table>
<thead>
<tr>
<th>Month</th>
<th>Original Sales Values</th>
<th>3-Month MovingDiff Average</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan</td>
<td>10</td>
<td></td>
</tr>
<tr>
<td>Feb</td>
<td>15</td>
<td></td>
</tr>
<tr>
<td>Mar</td>
<td>17</td>
<td>7</td>
</tr>
<tr>
<td>Apr</td>
<td>20</td>
<td>5</td>
</tr>
<tr>
<td>May</td>
<td>22</td>
<td>5</td>
</tr>
<tr>
<td>Jun</td>
<td>20</td>
<td>0</td>
</tr>
<tr>
<td>Jul</td>
<td>25</td>
<td>3</td>
</tr>
<tr>
<td>Aug</td>
<td>27</td>
<td>7</td>
</tr>
<tr>
<td>Sep</td>
<td>30</td>
<td>5</td>
</tr>
<tr>
<td>Oct</td>
<td>35</td>
<td>5</td>
</tr>
<tr>
<td>Nov</td>
<td>37</td>
<td>7</td>
</tr>
<tr>
<td>Dec</td>
<td>40</td>
<td>5</td>
</tr>
</tbody>
</table>

**Moving Maximum**

The MovingMax (Moving Maximum) function operates over a moving window of values. For each Window, the MovingMax returns the maximum value found in the Window. This function
is similar to the Simple Moving Average. No “Weighted” or “Exponential” can be calculated for this function.

The MovingMax function takes the following arguments:

\[ \text{MovingMax (column, window, break\_col)} \]

where:

- **column** (required)—Specify the column that contains the numeric fact on which the Moving Function column value is calculated. If you are applying the function from the Pivot section, you can only use a column that has already been added to the Facts pane of the data layout.

- **window** (optional)—Specify a moving “window” of values from the \textit{Column} on which the Moving Function gets calculated. The window value must be a positive integer of value equal to or less than the total number of rows in the \textit{Column} (within any \textit{Break Column} value). If the window value is an integer of greater value than the number of values in the \textit{Column}, then the window value defaults to the number of rows in the \textit{Column} (within any \textit{Break Column} value). If no window value is specified, then the window value defaults to 3.

- **break\_column** (optional)—Specify the name of the column on which to perform the Moving Function calculation. The break column refers to the rows of similar valued data cell within the Pivot or Results section.

The following results would occur if you used the MovingMax function with a Window of 3 (MovingMax(Sales,3)).

<table>
<thead>
<tr>
<th>Month</th>
<th>Original Sales Values</th>
<th>3-Month MovingMax</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan</td>
<td>10</td>
<td></td>
</tr>
<tr>
<td>Feb</td>
<td>15</td>
<td></td>
</tr>
<tr>
<td>Mar</td>
<td>17</td>
<td>17</td>
</tr>
<tr>
<td>Apr</td>
<td>20</td>
<td>20</td>
</tr>
<tr>
<td>May</td>
<td>22</td>
<td>22</td>
</tr>
<tr>
<td>Jun</td>
<td>20</td>
<td>22</td>
</tr>
<tr>
<td>Jul</td>
<td>25</td>
<td>25</td>
</tr>
<tr>
<td>Aug</td>
<td>27</td>
<td>27</td>
</tr>
<tr>
<td>Sep</td>
<td>30</td>
<td>30</td>
</tr>
<tr>
<td>Oct</td>
<td>35</td>
<td>35</td>
</tr>
<tr>
<td>Nov</td>
<td>37</td>
<td>37</td>
</tr>
<tr>
<td>Dec</td>
<td>40</td>
<td>40</td>
</tr>
</tbody>
</table>

Table 133 MovingMax Function Example
Moving Median

The MovingMed function operates over a moving window of values. For each Window, the MovingMed returns the middle value (in terms of rank) found in the Window. If the Window value is an even number, the simple mean value of the two middle ranking values should be used. No “Weighted” or “Exponential” can be calculated for this function.

The MovingMed function takes the following arguments:

\[ \text{MovingMed (column, window, break\_col)} \]

where:

- **column** (required)—Specify the column that contains the numeric fact on which the Moving Function column value is calculated. If you are applying the function from the Pivot section, you can only use a column that has already been added to the Facts pane of the data layout.

- **window** (optional)—Specify a moving “window” of values from the Column on which the Moving Function gets calculated The window value must be a positive integer of value equal to or less than the total number of rows in the Column (within any Break Column value).

  If the window value is an interger of greater value than the number of values in the Column then the window value defaults to the number of rows in the Column (within any Break Column value). If no window value is specified, then the window value defaults to 3.

- **break column** (optional)—Specify the name of the column on which to perform the Moving Function calculation. The break column refers to the rows of similar valued data cell within the Pivot or Results section.

The following results would occur if you used the MovingMed function with a Window of 3 (MovingMed(Sales,3)).

**Table 134** MovingMed Function Example

<table>
<thead>
<tr>
<th>Month</th>
<th>Original Sales Values</th>
<th>3-Month MovingMed Average</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan</td>
<td>10</td>
<td></td>
</tr>
<tr>
<td>Feb</td>
<td>15</td>
<td></td>
</tr>
<tr>
<td>Mar</td>
<td>17</td>
<td>15</td>
</tr>
<tr>
<td>Apr</td>
<td>20</td>
<td>17</td>
</tr>
<tr>
<td>May</td>
<td>22</td>
<td>20</td>
</tr>
<tr>
<td>Jun</td>
<td>20</td>
<td>20</td>
</tr>
<tr>
<td>Jul</td>
<td>25</td>
<td>22</td>
</tr>
<tr>
<td>Aug</td>
<td>27</td>
<td>25</td>
</tr>
<tr>
<td>Sep</td>
<td>30</td>
<td>27</td>
</tr>
<tr>
<td>Oct</td>
<td>35</td>
<td>30</td>
</tr>
<tr>
<td>Nov</td>
<td>37</td>
<td>35</td>
</tr>
</tbody>
</table>
Moving Sum

MovingSum (Moving Sum) function operates over a moving window of values. For each Window, the MovingSum returns the sum of values found in the window. No “Weighted” or “Exponential” can be calculated for this function.

The MovingSum function takes the following arguments:

MovingSum (column, window, break_col)

where:

- **column** (required)—Specify the column that contains the numeric fact on which the Moving Function column value is calculated. If you are applying the function from the Pivot section, you can only use a column that has already been added to the Facts pane of the data layout.

- **window** (optional)—Specify a moving “window” of values from the Column on which the Moving Function gets calculated. The window value must be a positive integer of value equal to or less than the total number of rows in the Column (within any Break Column value). If the window value is an integer of greater value than the number of values in the Column, then the window value defaults to the number of rows in the Column (within any Break Column value). If no window value is specified, then the window value defaults to 3.

- **break column** (optional)—Specify the name of the column on which to perform the Moving Function calculation. The break column refers to the rows of similar valued data cell within the Pivot or Results section.

The following results would occur if you used the Moving Sum function with a Window value of 3.

<table>
<thead>
<tr>
<th>Month</th>
<th>Original Sales Values</th>
<th>3-Month MovingSum Average</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dec</td>
<td>40</td>
<td>37</td>
</tr>
</tbody>
</table>

Table 135  Moving Sum Example

<table>
<thead>
<tr>
<th>Month</th>
<th>Original Sales Values</th>
<th>3-Month MovingSum Average</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan</td>
<td>10</td>
<td></td>
</tr>
<tr>
<td>Feb</td>
<td>15</td>
<td></td>
</tr>
<tr>
<td>Mar</td>
<td>17</td>
<td>42</td>
</tr>
<tr>
<td>Apr</td>
<td>20</td>
<td>52</td>
</tr>
<tr>
<td>May</td>
<td>22</td>
<td>59</td>
</tr>
<tr>
<td>Jun</td>
<td>20</td>
<td>62</td>
</tr>
<tr>
<td>Jul</td>
<td>25</td>
<td>72</td>
</tr>
<tr>
<td>Aug</td>
<td>27</td>
<td>72</td>
</tr>
</tbody>
</table>
### Moving Minimum

The MovingMin function operates over a moving window of values. For each Window, the Moving Minimum returns the minimum value found in the Window. This function is similar to the Simple Moving Average. No “Weighted” or “Exponential” can be calculated for this function.

The MovingMin function takes the following arguments:

\[
\text{MovingMin} (\text{column}, \text{window}, \text{break}_\text{col})
\]

where:

- \text{column} (required)—Specify the column that contains the numeric fact on which the Moving Function column value is calculated. If you are applying the function from the Pivot section, you can only use a column that has already been added to the Facts pane of the data layout.

- \text{window} (optional)—Specify a moving “window” of values from the \text{Column} on which the Moving Function gets calculated. The window value must be a positive integer of value equal to or less than the total number of rows in the \text{Column} (within any \text{Break Column} value).

  If the window value is an integer of greater value than the number of values in the \text{Column}, then the window value defaults to the number of rows in the \text{Column} (within any \text{Break Column} value). If no window value is specified, then the window value defaults to 3.

- \text{break column} (optional)—Specify the name of the column on which to perform the Moving Function calculation. The break column refers to the rows of similar valued data cell within the Pivot or Results section.

The following results would occur if you used the Moving Minimum function with a Window value of 3.

Similar to Simple Moving Averages above, note that the values in the "3-Month Moving Minimum" column are positioned according to the trailing averages.

#### Table 136 Moving Minimum Example

<table>
<thead>
<tr>
<th>Month</th>
<th>Original Sales Values</th>
<th>3-Month Moving Minimum</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan</td>
<td>10</td>
<td></td>
</tr>
<tr>
<td>Feb</td>
<td>15</td>
<td></td>
</tr>
</tbody>
</table>
### Direction Of Moving Function Calculation

In all of the Moving Function calculation examples, it is assumed that the Moving Function calculation proceeds in a downward direction for each Computed Item column. That is to say, the Moving Function calculation window progresses downward, one row at a time, for each subsequent row of displayed fact data. This downward movement is evident in the Table section data (which has been used in the examples shown above) since, in a Table section, each new instance of fact data can only be represented as a new row.

Other sections, however, such as Pivot and Chart allow the possibility for fact data to be represented in more than one directional axis. In the case of Pivot and Chart sections, therefore, you can specify the direction of Moving Function calculation. To illustrate the effect of changing the direction of Moving Function calculation, consider the previously shown Table data:

#### Table 137  Moving Function Example

<table>
<thead>
<tr>
<th>Month</th>
<th>Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan</td>
<td>10</td>
</tr>
<tr>
<td>Feb</td>
<td>15</td>
</tr>
<tr>
<td>Mar</td>
<td>17</td>
</tr>
<tr>
<td>Apr</td>
<td>20</td>
</tr>
<tr>
<td>May</td>
<td>22</td>
</tr>
<tr>
<td>Jun</td>
<td>20</td>
</tr>
<tr>
<td>Jul</td>
<td>25</td>
</tr>
</tbody>
</table>
Adding a new Computed Item column to display a 3-Month Moving Difference would yield:

<table>
<thead>
<tr>
<th>Month</th>
<th>Sales</th>
<th>3-Month Moving Difference</th>
</tr>
</thead>
<tbody>
<tr>
<td>Jan</td>
<td>10</td>
<td></td>
</tr>
<tr>
<td>Feb</td>
<td>15</td>
<td></td>
</tr>
<tr>
<td>Mar</td>
<td>17</td>
<td>7</td>
</tr>
<tr>
<td>Apr</td>
<td>20</td>
<td>5</td>
</tr>
<tr>
<td>May</td>
<td>22</td>
<td>5</td>
</tr>
<tr>
<td>Jun</td>
<td>20</td>
<td>0</td>
</tr>
<tr>
<td>Jul</td>
<td>25</td>
<td>3</td>
</tr>
<tr>
<td>Aug</td>
<td>27</td>
<td>7</td>
</tr>
<tr>
<td>Sep</td>
<td>30</td>
<td>5</td>
</tr>
<tr>
<td>Oct</td>
<td>35</td>
<td>5</td>
</tr>
<tr>
<td>Nov</td>
<td>37</td>
<td>7</td>
</tr>
</tbody>
</table>

Consider, however, if the "Month" and "Sales" data were oriented as follows (as could be done in a Pivot section):

<table>
<thead>
<tr>
<th></th>
<th>Jan</th>
<th>Feb</th>
<th>Mar</th>
<th>Apr</th>
<th>May</th>
<th>Jun</th>
<th>Jul</th>
<th>Aug</th>
<th>Sep</th>
<th>Oct</th>
<th>Nov</th>
<th>Dec</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales</td>
<td>10</td>
<td>15</td>
<td>17</td>
<td>20</td>
<td>22</td>
<td>20</td>
<td>25</td>
<td>27</td>
<td>30</td>
<td>35</td>
<td>37</td>
<td>40</td>
</tr>
</tbody>
</table>

If a new Computed Item were added, to represent a 3-Month Moving Difference, and the Moving Function calculation direction was still down each column, this would result in null values being represented for the Computed Item (as below) since there would only be one fact value per column (this would not be enough fact occurrences to satisfy a 3-term Moving Difference).
If, instead, the Moving Function calculation direction were specified to be along each row (i.e. horizontally from right to left) the Moving Difference Computed Item would yield the "expected" results since the source "Sales" Fact data cells would be examined in their "correct" left-to-right sequence. That is, the following display would result:

<table>
<thead>
<tr>
<th></th>
<th>Jan</th>
<th>Feb</th>
<th>Mar</th>
<th>Apr</th>
<th>May</th>
<th>Jun</th>
<th>Jul</th>
<th>Aug</th>
<th>Sep</th>
<th>Oct</th>
<th>Nov</th>
<th>Dec</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales</td>
<td>10</td>
<td>15</td>
<td>17</td>
<td>20</td>
<td>22</td>
<td>20</td>
<td>25</td>
<td>27</td>
<td>30</td>
<td>35</td>
<td>37</td>
<td>40</td>
</tr>
<tr>
<td>3-Month Moving Difference</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Applying Sorts

In This Chapter

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sorting Data</td>
<td>413</td>
</tr>
<tr>
<td>Simple Sorts</td>
<td>413</td>
</tr>
<tr>
<td>Sort Lines</td>
<td>414</td>
</tr>
<tr>
<td>Complex Sorting</td>
<td>414</td>
</tr>
<tr>
<td>Nested Sorts</td>
<td>417</td>
</tr>
</tbody>
</table>

**Sorting Data**

Sorting simplifies the process of data analysis. After data is sorted, the answers to questions are often readily at your fingertips. Sorting is also very useful for ranking data to reveal business trends and margins.

<table>
<thead>
<tr>
<th>Year</th>
<th>State</th>
<th>Item Type</th>
<th>Amounts</th>
<th>Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>1997</td>
<td>NY</td>
<td>The Standard</td>
<td>0,958.6</td>
<td>70</td>
</tr>
<tr>
<td>1996</td>
<td>NY</td>
<td>EZ Fax Modern-I</td>
<td>7,203.9</td>
<td>55</td>
</tr>
<tr>
<td>1996</td>
<td>MI</td>
<td>The Turbo</td>
<td>7,986.6</td>
<td>45</td>
</tr>
<tr>
<td>1996</td>
<td>MI</td>
<td>1024 ME Drive</td>
<td>10,438</td>
<td>40</td>
</tr>
<tr>
<td>1996</td>
<td>NY</td>
<td>The Turbo</td>
<td>11,536.2</td>
<td>65</td>
</tr>
<tr>
<td>1996</td>
<td>NY</td>
<td>1024 ME Drive</td>
<td>9,133.25</td>
<td>35</td>
</tr>
<tr>
<td>1996</td>
<td>CA</td>
<td>EZ Fax Modern-I</td>
<td>8,513.7</td>
<td>65</td>
</tr>
<tr>
<td>1995</td>
<td>CA</td>
<td>1024 ME Drive</td>
<td>10,438</td>
<td>40</td>
</tr>
</tbody>
</table>

You can perform simple and complex sorts depending on your requirements. You can sort individual data items or use the Sort line to sort items in reference to associated data values. These complex sorts can be nested, so that the sorted data reflects the hierarchical relationships between data items.

**Simple Sorts**

If you only want to sort a single Request item, report row, or column, you can use the Sort buttons on the toolbar to quickly order the data.

If you apply simple sort conditions in the Query section, the database server sorts the data while processing the query before it is retrieved to your desktop. Or you can sort data on your desktop.
in Results or report sections. The data associated with a selected item is sorted in ascending or descending order as you wish.

➤ To select items to sort:

1 **Select the data item to sort.**

   In the Query section, select a topic item on the Request line. In other sections, select a corresponding report element in the Content pane.

2 **On the Standard toolbar, click the ascending or descending Sort icon.**

   The data is sorted in the Content pane.

   If the Sort line is visible, the item appears on the Sort line. The item name is followed by an up or down arrow to indicate the sort order.

### Sort Lines

Interactive Reporting sort lines have two functions:

- To maintain a record of sort conditions that you have applied to the data set.
- To enable you to specify compound and Nested Sorts.

Sort lines take on a different appearance in each section depending on the data presentation and the types of sorts available.

- In the Complex Sorting in the Query, Results, and Table Sections sections, sort lines are drag and drop command lines similar to Request and Filter lines.
- In the Complex Sorting in Chart, Pivot, and OLAPQuery Reports sections, sort lines are list driven and include provisions for sorting by aggregate calculations, such as averages and counts.

**Tip:**

You can move, size, dock, or hide the Sort line. To toggle the Sort line, click the Sort button on the Section title bar.

### Complex Sorting

In addition to performing Simple Sorts, you can use Interactive Reporting to perform complex sorting. Review the following sections for information on:

- Complex Sorting in the Query, Results, and Table Sections
- Complex Sorting in Chart, Pivot, and OLAPQuery Reports
Complex Sorting in the Query, Results, and Table Sections

Note:
The information discussed here also applies to sorting in the Report section.

The appearance and functionality of the Sort line is nearly identical in the Query, Results, and Table sections. In each section, the Sort line uses a drag-and-drop interface similar to the Request and Filter lines.

Using this feature, you can drag items to the sort line and request them to be sorted in sequence to yield Nested Sorts results.

For example, if the first item is State, the second item City, and the third item Store, States are sorted alphabetically by name. Within each state, cities are sorted by name. Within each city, stores are sorted.

Nested effects are based solely on the placement of items on the Sort line. If the item order on the Request line differs from the order in the Content pane, the sort is still nested, but the visual impact is not as pronounced.

The key difference between the sections lies in where the sorting is performed:

- In the Query section, the database server sorts items placed on the Sort line as the query is processed. The data is returned already presorted to the Results section.
- In the Results and Table sections, items placed on the Sort line are sorted on your desktop.

The bottom line effect is the same whether you apply sort conditions locally in the Results or Table section or on the database server in the Query section. Depending on the situation and the needs of your business, one method or the other may be preferable.

Complex Sorting in Chart, Pivot, and OLAPQuery Reports

Note:
The information discussed here does not apply to sorting in the Report Designer section.
In Chart, Pivot, and OLAPQuery reports, you generally want to override the default sort order and sort dimensional data with reference to other data. In these sections, you can use the Sort line to impose a sort condition for each dimensional data item in your report, and to nest your sort conditions at each hierarchical level of the report from the outside in.

The Sort line includes three drop-down menus used to define the sort conditions. The contents of the menus vary depending on the data items in query.

**Tip:**

Data in Chart, Pivot, and OLAPQuery sections is sorted alphabetically by default. You can use the sort buttons on the Standard toolbar to perform simple sorts on selected report items and reverse the sort order. (See “Simple Sorts” on page 413 for more information.)

**Sort Items**

The Sort drop-down menu lists the data items that can be sorted. Each dimensional item included in the report (name and date) is listed in this menu.

**Reference Items**

The By drop-down menu lists items used as a basis for a complex sort condition (for example, sorting Cities by the revenue generated in each). The drop-down menu includes each numerical data item in the report as well as the keyword entry "label." These choices provide two ways to sort the dimensional item specified in the Sort menu:

- **Sorting by Label**—By default Interactive Reporting sorts dimensional data items alphabetically by name when you create your report – this is equivalent to sorting by labels. When selected, *label* indicates that the item chosen from the Sort list is sorted by label or name, rather than by reference to corresponding numeric data values in the report.

- **Sorting by Value**—Sorting by a numeric data item orders each value of the target item chosen from the Sort list by its corresponding numeric value in the Value list.

Sorting by values produces an entirely different sort order. For example, your chart may list each state in which your company has made sales revenue and the total cost-of-sales for each. The states are initially listed in alphabetical order. When you sort by cost-of-goods, the states are ranked in order by each corresponding cost-of-sales figure.

**Functions**

The Using drop-down menu contains aggregate statistical functions that are available when you sort by values. The functions generally duplicate the data functions available in the active section.

The default function for sorting is *Sum*. When you sort by values, Interactive Reporting sorts dimensional data by the corresponding numeric values of the referenced item (for example, sorting states by the sum total of the cost of goods sold in each state).
To specify a sort using the features of the Sort line:

1. If the Sort line is not already displayed, click Sort on the Section title bar.
2. Select an item to sort from the Sort drop-down list.
3. Select a value from the By drop-down list as a sort reference, or select Label to sort the item alphabetically.
4. If desired, select an aggregate function from the Using drop-down list when sorting by values.
   The Using drop-down menu is not available when you sort by labels.
5. If desired, click Sort on the Sort line.

The Sort line stores a sort condition for each dimensional item included in the report.

### Nested Sorts

When you sort more than one data item at a time, the left to right order of data on the Sort line dictates the sort order and creates a nested effect. The item at left on the Sort line is sorted first. Then items to the right are sorted in progression, each within the categories of the preceding item.

For example, if the first item is State, the second item City, and the third item Store, States are sorted alphabetically by name, and then within each state, cities are sorted by name, and then within each city, stores are sorted.

Nested effects are based solely on the placement of items on the Sort line. If the item order on the Request line differs from the order in the Contents pane, the sort is still nested, but the visual impact is not as pronounced.
This section describes how to connect to a relational database and a multidimensional database using Interactive Reporting database connection files, including how to set up these files, define connection preferences, and how to manage connections.

### About Interactive Reporting Database Connection Files

Connectivity is generally one of the most difficult aspects of querying for end users to master. Client/server database applications rely on a complicated web of listeners, network addresses, and preferences that are difficult for anyone but a database administrator to troubleshoot.

Interactive Reporting users can sidestep these potential difficulties by using an Interactive Reporting database connection file (.oce files) to define the terms, conditions, and methods for connecting to data sources.

With a database administrator’s assistance, Interactive Reporting database connection files enable a stable connection to be set up once, and then distributed and reused. End users supply a database user name and password each time they log on to query a database.

Interactive Reporting database connection files retain all the information necessary to log on to a specific configuration of database and connection API software. In addition, Interactive Reporting database connection files retain DBMS-specific connection preferences as well as specifications for automatic access to metadata (see “Using Metatopics and Metadata ” on page 443).

Interactive Reporting database connections store complete sets of connection parameters about:

- Connection software
Interactive Reporting database connections have significant advantages in network environments. One connection can be created for each database in the environment and shared with each end user.

Interactive Reporting database connection files simplify the connection process for company personnel by transparently handling host and configuration information. Each user can substitute their own database user name when using an Interactive Reporting database connection file (oce), which enforces security measures and privileges that are centralized at the database server.

Because passwords are not saved, there is no danger that distribution provides unauthorized access to any user who receives the wrong Interactive Reporting database connection file or acquires it from other sources.

By default, no explicit Interactive Reporting database connection file is required to process Interactive Reporting document files or job outputs using the Workspace or Interactive Reporting Web Client. That is, an user is not required to have specific access privileges to process an Interactive Reporting document file. However, a control setting of an Interactive Reporting document file or job access can be defined to require explicit access. For more information, see the Workspace Administrator’s Guide and the Workspace User’s Guide.

It is to your advantage to create and distribute Interactive Reporting database connection files to facilitate the logon process when storing Interactive Reporting Studio data models.

Working with Interactive Reporting Database Connections

Interactive Reporting Studio provides a Database Connection Wizard to help you create new Interactive Reporting database connections. Before you create a new Interactive Reporting database connection files, collect and verify the following connection information:

- Connection API software and version (for example, Essbase, SQL*Net for Windows NT, and so on)
- Database software and version (for example, MetaCube 4, Oracle 8, and so on)
- IP address, database alias, or ODBC data source name of database server
- Database user name
Creating Interactive Reporting Database Connections (.oces)

The Database Connection Wizard steps you through the Interactive Reporting database connection file creation process and captures the connection parameters in a file that enables you to connect to a data source. Interactive Reporting Studio saves the database connection file in the default Interactive Reporting database connection directory.

With an advanced user’s assistance, an Interactive Reporting database connection file can be set up once, distributed, and reused. You only have to supply a database user name and password each time you log in to query a database.

To create an Interactive Reporting database connection:

1. Select Tools > Connection > Create.
   
The Database Connection Wizard is displayed.

2. Select the connection software used for connecting to the database server from the pull down list in the What connection software do you want to use? field.

3. Select the database server in the What type of database do you want to connect to? field.

4. To configure metadata settings, select Show Meta Connection Wizard.

5. To configure advanced connection preferences, select Show advanced options.

6. Click Next.

7. Depending on the database, enter your user name in the User Name field, password in the Password field, the IP address, ODBC database source or server alias name in the Host field and click Next.

   If you selected to work with meta data settings, the Meta Data Connection Wizard launches. See the “Accessing the Open Metadata Interpreter” on page 447 for more information.

8. The wizard prompts you to save the Interactive Reporting database connection file.

9. To save the Interactive Reporting database connection file, click Yes.

   The Save dialog box is displayed. Interactive Reporting Studio saves the Interactive Reporting database connection file in the default Interactive Reporting connection directory.

10. To save the Interactive Reporting database connection file in a different directory, navigate to the desired directory and click Save.

<table>
<thead>
<tr>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>What connection software do you want</td>
<td>Select the connection software to use when connecting to the database. Depending on the connection software, additional fields may be displayed. These fields enable you to customize the Interactive Reporting database connection file; show metadata settings; and select ODBC logon dialogs.</td>
</tr>
<tr>
<td>to use?</td>
<td></td>
</tr>
<tr>
<td>What type of database do you want to</td>
<td>Select the type of database to which to connect from the pull-down list.</td>
</tr>
<tr>
<td>connect to?</td>
<td></td>
</tr>
<tr>
<td>Show Metadata Connection Wizard?</td>
<td>To view and edit meta data settings, select this field. The Metadata Definitions dialog box is configured with specific SQL statements to read meta data on multiple databases.</td>
</tr>
</tbody>
</table>
Option | Description
--- | ---
**Show advanced options?** | To select advanced preferences for the Interactive Reporting database connection file, select this field. Connection preferences enable you to select what instructions and protocols the Interactive Reporting database connection file should observe. The preferences are saved with the Interactive Reporting database connection file and applied each time you use the connection.

For example, you can use connection preferences to filter extraneous tables from the Table Catalog or specify how the connection software should manage SQL statements.

Connection preferences vary depending on the connection software and database.

**Prompt for database name** | To select the specific database name on the server, select this field.

**Use ODBC Logon Dialogs?** | If you select ODBC connection software, use the ODBC logon dialog boxes instead of the Interactive Reporting Studio dialog boxes, select this field. To use the Interactive Reporting Studio connection dialog boxes, leave this field unchecked.

**User Name** | Enter the sign on name to the database.

**Password** | Enter the password for the database.

**Host** | Enter the IP address, database alias, or ODBC data source name.

**Note:**

In Release 9.3, Hyperion supports connections to Informatica MX2 repositories, specifically connections to the Informatica PowerCenter 7.1 repositories using the Informatica Metadata Exchange SDK 7.1 client software. The Connection Wizard has been changed to prompt for the repository server host name and port number instead of the ODBC connection string, user name and password. The Informatica Metadata Exchange SDK 7.1 client software must be installed on the server or the machine that has DAS running to work in the Workspace and in Interactive Reporting Web Client. Connections to Informatica MX2 repositories are supported on Windows platforms only.

**Setting Connection Preferences**

Connection preferences specify the way certain aspects of the Interactive Reporting database connection file are managed. The preferences are saved with an Interactive Reporting database connection file and are applied each time you use the connection.

For example, use connection preferences to filter extraneous tables from the Table Catalog or change the way the connection software handles SQL transaction statements.

Connection preferences differ depending on the Interactive Reporting Studio edition, connection API, and DBMS.

Connection preferences are accessed by selecting the Show Advanced Options check box in the Database Connection Wizard. Table 140 list all of possible options that are available in the Wizard: the options available to you depend on the connection configuration.
<table>
<thead>
<tr>
<th>Options</th>
<th>Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>ALLOW SQL-92 Advanced Set Operations</td>
<td>Enables support for the Intersection and Difference operators in the Append Query option.</td>
</tr>
<tr>
<td>Apply Filters to restrict the tables that are displayed in the table catalog</td>
<td>Enables specification of table filter conditions for limiting or customizing the list of tables in the table catalog.</td>
</tr>
<tr>
<td>Exclude Hyperion Repository Tables</td>
<td>Excludes all repository tables from the table catalog. “Filter by” and “metadata” definitions override this preference.</td>
</tr>
<tr>
<td>Allow Non-Joined Queries</td>
<td>Prohibits processing when topics are not joined in the Query Contents frame.</td>
</tr>
<tr>
<td>Use SQL to get Table Catalog</td>
<td>Specifies use of SQL to retrieve tables, instead of using SQL Server sp_tables and sp_columns stored procedures. This option enables table filtering, but may be slower than stored procedures. (Sybase and MS SQL Server)</td>
</tr>
<tr>
<td>Choose the Data Retrieval Method</td>
<td>Specifies how the server returns data. In most cases, “Retrieve data as Binary” is the most appropriate, and fastest method.</td>
</tr>
<tr>
<td></td>
<td>Select “Retrieve data as Strings” if the connection API does not support native datatype retrieval, or if queries return incorrect or unreadable data.</td>
</tr>
<tr>
<td>Time Limit ___ Minutes</td>
<td>Establishes an automatic disconnect from the database after the specified period of inactivity.</td>
</tr>
<tr>
<td>Auto Commit After Select</td>
<td>Sends a commit statement to the database server with each Interactive Reporting Studio SQL statement to unlock tables after they have been used. Use this feature if tables are locked after use or users experience long waits for tables.</td>
</tr>
<tr>
<td>Save Interactive Reporting Database connection Without User Name</td>
<td>Enables general distribution of an Interactive Reporting database connection file by saving it generically, without a user name. Instead, any user can log on by typing their own user name.</td>
</tr>
<tr>
<td>Use Quoted Identifiers</td>
<td>Specifies that internal keywords or table and column, or owner names with special characters sent to the server be enclosed in quotation marks. For example, SELECT SUM(“AMOUNT”), “STORE_ID” FROM “HYPERION”.“PCS_SALES”GROUP BY”STORE_ID” The default value for new connections is off.</td>
</tr>
<tr>
<td>Allow Change Database at Logon</td>
<td>Adds Database field to logon dialog box enabling the user to select a specific database when logging on to the DBMS. (Sybase and MS SQL Server)</td>
</tr>
<tr>
<td>Use large buffer query mode</td>
<td>Specifies a binding process to retrieve more records per fetch call. If the ODBC driver supports binding, use this option for faster retrieval. (ODBC only). If this feature is turned on, the ODBC Extended Fetch call requests data at 32k at a time.</td>
</tr>
<tr>
<td>Packet Size Setting.512*</td>
<td>Enables Sybase’s DB-Lib users to set up a large buffer retrieval from the database so that more data can be transferred at one time.</td>
</tr>
<tr>
<td></td>
<td>If this feature is selected, you can specify a multiple of 512 bytes for the number of bytes to transfer at one time.</td>
</tr>
<tr>
<td></td>
<td>Before you specify a multiple of 512 bytes, the server must have enough memory to allocate for the transmission of the selected packet size.</td>
</tr>
<tr>
<td>Options</td>
<td>Descriptions</td>
</tr>
<tr>
<td>---------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>To check which packet size the</td>
<td>To check which packet size the Sybase server supports, run the isql command: sp_configure</td>
</tr>
<tr>
<td>Sybase server supports, run the</td>
<td>and type go.</td>
</tr>
<tr>
<td>isql command:</td>
<td>A list of parameters is returned. Find the parameter showing the “Maximum Network Packet Size.” If the packet size you entered exceeds the maximum</td>
</tr>
<tr>
<td></td>
<td>packet size, you have to enter again a smaller packet size.</td>
</tr>
<tr>
<td></td>
<td>To change the packet size, issue the following command in isql:</td>
</tr>
<tr>
<td></td>
<td>Sp_configure “maximum network packet size”. &lt;new value&gt;</td>
</tr>
<tr>
<td></td>
<td>(where &lt;new value&gt; is the new size).</td>
</tr>
<tr>
<td>Oracle Buffer Size</td>
<td>Determines the default buffer size when retrieving rows of data from an Oracle connection. The default size is 8000 bytes. A user can change this</td>
</tr>
<tr>
<td></td>
<td>value to retrieve more rows per buffer, which may result in a performance improvement, but at the expense of additional memory requirements. The</td>
</tr>
<tr>
<td></td>
<td>minimum size is 8000. If a user specifies a smaller value, nor error is returned, but 8000 bytes is used. There is no hard coded maximum size value for this</td>
</tr>
<tr>
<td></td>
<td>field.</td>
</tr>
<tr>
<td>Disable Asynchronous Processing</td>
<td>Turns off the ability to make simultaneous requests to the database server. This feature is available in Interactive Reporting Studio only.</td>
</tr>
<tr>
<td>Retain Data Formats</td>
<td>Interactive Reporting Studio uses the default formats specified by the database server when handling date, time, and timestamp values. If the</td>
</tr>
<tr>
<td></td>
<td>default formats of the server have been changed, you can retain or preserve these adjusted preferences to ensure Interactive Reporting Studio interprets</td>
</tr>
<tr>
<td></td>
<td>date/time values correctly.</td>
</tr>
<tr>
<td>Server Dates</td>
<td>Enables alteration of internal Interactive Reporting Studio date handling to match server default settings in case of a discrepancy. For more information</td>
</tr>
<tr>
<td></td>
<td>on this feature, see “Modifying Server Date Formats” on page 427.</td>
</tr>
<tr>
<td>Disable Transaction Mode</td>
<td>On upload to the repository, Interactive Reporting Studio brackets SQL Insert statements with transaction statements. Disable Transaction Mode if the</td>
</tr>
<tr>
<td></td>
<td>RDBMS does not support transactions. This feature is only available in Interactive Reporting Studio.</td>
</tr>
<tr>
<td>Do you want to save your OCE</td>
<td>Enables you to save the Interactive Reporting database connection file so that it can be reused at a later time.</td>
</tr>
<tr>
<td>Use outer join operator on limits</td>
<td>Inserts an outer join operator (+) in the SQL on limits applied to the “inner” table for Oracle Net connection software to an Oracle database. By default</td>
</tr>
<tr>
<td></td>
<td>this feature is enabled and is recommended; it is provided to work around Oracle restrictions when using outer joins with certain limit conditions, such as</td>
</tr>
<tr>
<td></td>
<td>when an OR expression is needed. An outer join operator enables Interactive Reporting Studio to retrieve all rows from the “left” or “right” table matching</td>
</tr>
<tr>
<td></td>
<td>joined column values if found or retrieves nulls for non-matching values. If this feature is disabled, then nulls for non-matching values are not retrieved. Use</td>
</tr>
<tr>
<td></td>
<td>the Join Properties dialog box to assist in determining which is the “left” and “right” table. Oracle does not support full (left AND right) outer joins with the</td>
</tr>
<tr>
<td></td>
<td>(+) operator. When an ODBC driver is used, this feature is greyed out.</td>
</tr>
</tbody>
</table>
### Filtering Tables

For databases with many tables, it can help to filter out tables you do not need from the Table catalog. The table filter enables you to specify filter conditions based on table name, owner name, or table type (table or virtual views).

**Note:**

The table filter works with all database server connections except ODBC. If you are working with a Sybase or Microsoft SQL Server database, modify the connection and specify that Interactive Reporting Studio use SQL statements to retrieve the Table catalog before filtering tables.

Typically, you filter tables when creating an Interactive Reporting database connection file, although you can modify an existing Interactive Reporting database connection file later to filter tables.

To filter tables from the Table Catalog when creating an Interactive Reporting database connection file:

1. **Select Tools > Connection > Create.**
   - The Database Connection Wizard is displayed.
2. **Select the connection software used to connect to the database server from the pull down list in the What connection software do you want to use? field.**
3. **Select the database server in the What type of database do you want to connect to? field.**
4. **Select Show Advanced Options and click Next.**
5. **Connect to the data source and click Next.**
   - The dialog box varies according to the connection software you are using. In most cases, you need to specify a user name, password and host name. Click Next.
6. **Click Define next to a table name, table owner, or table type filter check box.**
7. **Select a comparison operator from the drop-down box. The filter constraints determine which tables are included in the Table catalog.**
   - Complete a filter definition by doing one of the following:
     * Enter constraining values in the edit field and select the check mark.
● Click **Show Values** to display a list of potential database values and select values from the list.

● If you are comfortable writing your own SQL statements, click **Custom SQL** to directly code table filters that have greater flexibility and detail.

8 **Click OK.**

Interactive Reporting Studio prompts you to save the filter settings. Once saved, a check mark displays in the appropriate filter check box, which you can use to toggle the filter on and off.

**Note:**

After you complete the Data Connection Wizard, verify that the filter conditions screen out the correct tables. In the Catalog frame, select **Refresh** on the shortcut menu.

➢ To filter tables from the Table Catalog when modifying an Interactive Reporting database connection file:

1 **To filter tables for the current connection, select Tools > Connection > Modify.**

   The Meta Connections Wizard dialog box is displayed.

2 **To filter tables for another connection, select Tools > Connections Manager > Modify.**

   The Connections Manager dialog box is displayed. In the Document Connections frame, select the Interactive Reporting database connection file and click **Modify.**

   The Meta Connections Wizard dialog box is displayed.

3 **Configure the first Wizard as necessary, and then click Next to go to the second Meta Connections Wizard dialog box.**

4 **Configure the second Wizard as necessary, and then click Next to go to the third Meta Connection Wizard dialog box.**

5 **On the third Meta Connection Wizard dialog box, click Define next to a owner, table or type filter check box.**

   A Filter dialog box is displayed. The Filter dialog boxes resemble and operate using the same principles as the Limit dialog box.

6 **Select a comparison operator from the drop-down box. The filter constraints determine which tables are included in the Table Catalog.**

7 **Complete a filter definition by doing one of the following:**

   Enter constraining values in the edit field and select the check mark.

   Click **Show Values** to display a list of potential database values and select values in the frame.

   If you are comfortable writing your own SQL statements, click **Custom SQL** to code table filters directly with greater flexibility and detail. For example, you can write a SQL filter, which enables only tables beginning with “Sales” to be displayed in the table catalog. As new “Sales” tables are added to the database, they automatically are displayed in the Table Catalog.

8 **Select any other customizing options to apply, and click OK.**
You are prompted to save the filter settings. Once saved, a check mark is displayed in the appropriate filter check box, which you can use to toggle the filter on and off.

9 Click Next to continue through each dialog box, selecting any preferences for the Interactive Reporting database connection file.

10 Click Finish.

11 In the Hyperion dialog box, click Yes to save the Interactive Reporting database connection file.

12 In the Save Open Catalog dialog box, browse to a directory, enter the new connection name in the File Name field, and then click Save.

13 In the Table Catalog of the Query section, select Refresh on the shortcut menu to verify that the filter conditions screen out the correct tables.

Modifying Server Date Formats

Interactive Reporting Studio uses the default formats specified by the database server when handling date, time, and timestamp values. If the default formats of the server have been changed, you can adjust preferences to ensure that Interactive Reporting Studio interprets date/time value

➤ To modify server date formats:

1 Select Tools > Connection > Create.

   The Database Connection Wizard is displayed.

2 Select Show Advanced Options and click Next.

3 Click Server Dates.

   The Server Date Formats dialog box is displayed.

   ● To Server Formats—Date and time formats submitted to the server (such as limit values for a date or time field).

   ● From Server Formats—Formats Interactive Reporting Studio expects for date/time values retrieved from the server.

   ● The default values displayed in the To and From areas are usually identical.

4 If the server defaults have changed, select the date, time, and timestamp formats that match the new server defaults from the To and From format drop-down boxes.

   If desired, click Default to restore all values to the server defaults stored in the Interactive Reporting database connection file.

5 If you cannot find a format that matches the database format, click Custom.

   The Custom Format dialog box is displayed.

6 Select a data type from the Type drop-down box.

7 Select a format from the Format drop-down box or type a custom format in the Format field.

8 Click OK.

   The new format is displayed as a menu choice in the Server Date Formats dialog box.
Creating an OLAP Connection File

To create an OLAP connection file:

1 Select Tools > Connection > Create.
   The Database Connection Wizard is displayed.
2 Select the connection software used to connect to the OLAP database server from the drop-down box.
3 Select the OLAP database server from the drop-down box and click Next.
   Depending on the database you select in this field, you may have to specify a password to connect to the database. Enter your name, password, and host address information.
   The sequence of dialog boxes that are displayed depend on the multidimensional database server to which you are connecting. The following sections provide connection information for these multidimensional databases:
   - Connecting to Essbase or DB2 OLAP
   - Connecting to an OLE DB Provider
   - Connecting to Essbase (CubeQuery only)

Connecting to Essbase or DB2 OLAP

To connect to an Essbase or a DB2 OLAP database:

1 Follow the instructions for “Creating an OLAP Connection File” on page 428.
2 Select the application/database to which to connect and click Next.
   This is the cube from which to retrieve values.
3 Select the measures dimension for the cube in the Dimension Name field and click Next.
   This is the specific measure group from which to retrieve values.
4 Click Finish to save the Interactive Reporting database connection file.

Note:
For information on connecting to an Essbase 7.x or 9.x server, see Connecting to Essbase (CubeQuery only)

Connecting to an OLE DB Provider

To connect to an OLE DB provider:

1 Follow the instructions in “Creating an OLAP Connection File” on page 428.
2 Select the database to connect.
NT domain authentication is performed for OLAP cube files (.cub). If the user name and password provided (when attempting to process or retrieve dimensions) are not valid, an access error is returned and the user cannot access the file. To access the file, provide a valid NT domain user name and password. To specify a domain, enter it in the user name field in the form DOMAIN\jdoe.

**Note:**

By default, Interactive Reporting Web Client users are prompted to enter their Windows credentials (user ID, password, and optionally Windows domain, which can be specified in the login user ID prompt field, preceding the user ID text and delimited by a backslash; for example, if domain is HyperionDomain and user ID is user1, HyperionDomain\user1 can be specified in the user ID field when logging on to Microsoft OLAP databases. These changes are enforced to provide more secure access to these databases. If prompted, the user must enter credentials that can be successfully authenticated by the Windows operating system at the database server. Failure to provide credentials that can be successfully authenticated by Windows results in an error message being returned to the user and login to the database being denied. If the user’s credentials are successfully authenticated, the database login proceeds and any role-based security on cube data granted at the database level for the specified user ID is invoked and honored. If no role-based security is implemented at the database level (the database cubes and their data are available to all users), the database administrator can choose to publish an Interactive Reporting database connection file or the database with a pre-assigned system-administrator-level user ID and password. If users access the database using this Interactive Reporting database connection file, they are not prompted to enter any login credentials. They have passed through to the database, where access to all cube data is allowed. Note that these statements also apply to Interactive Reporting Web Client users who access local cube files created from Microsoft OLAP or other OLE DB for OLAP databases (such as the sample cube files that are presented with the sample files provided with the installation).

3. If the OLE DB for OLAP database provides the ability to retrieve dimension properties, select Enable Retrieval Of Dimension Properties and click Next.

4. Select the name of the Provider from the drop-down box and click Next.

For more information about the remaining dialog boxes, consult the database documentation of the provider.

**Connecting to Essbase (CubeQuery only)**

This section shows how to create a new Interactive Reporting connection file. When you query against an Essbase cube, by default, the Interactive Reporting document is created in the CubeQuery section. To use these instructions you must have access to an Essbase 7.x or 9.x server used as a data source. In addition Interactive Reporting requires an Essbase 9.3 Runtime client installation.

**Note:**

Be sure the option to use the pre 9.3.1 OLAPQuery section has been disabled. Select Tools > Options > Program Options > OLAP, and disable the Use Old OLAP Query section option.
To connect to Analytic Server:

1. Select Tools > Connection > Create.
   The first Database Connection Wizard is displayed.
2. From the What connection software do you want to use? drop-down, select Essbase.
3. From the What type of database do you want to connect to? drop-down, select Essbase.
4. Click Next.
   The second Database Connection Wizard is displayed.
5. Enter a user name in the User Name field.
6. Enter a password in the Password field.
7. Enter the host (server) name in the Host field.
8. Click Next.
   The third Database Connection Wizard is displayed.
9. From the Application/Database drop-down, select a cube and click Next.
   The fourth Database Connection Wizard is displayed.
10. From the Dimension Name drop-down, select the measure dimension and click Next.
   Measures are numeric values in a database cube available for analysis. Measures could be margin, cost of goods sold, unit sales, budget amount, and so on.
   The fifth Database Connection Wizard is displayed.
11. Click Finish.
12. When you are prompted to save the OCE (Interactive Reporting database connection file), click yes.
   The Save Open Catalog dialog is displayed.
13. Enter a file name and click OK.
   A new Query section is created in a blank Interactive Reporting document file.

**Modifying Interactive Reporting Database Connection Files**

When you create an Interactive Reporting database connection file, you establish a working database connection file for data modeling and querying. You may need to modify an Interactive Reporting database connection file to reflect changes in the network or hardware configuration, or to manage other connection information.

**Note:**
Changes to basic connection configuration, such as new database or host name, require you to log off and rebuild the Interactive Reporting database connection file.
To modify an Interactive Reporting database connection file:

1 Close any open Interactive Reporting document files.
2 Select Tools > Connection > Modify.
   The Modify Connection dialog box is displayed.
3 Select the connection file to modify and click Open.
   The Database Connection Wizard is displayed showing the information for the Interactive Reporting database connection file you selected.
4 Make any desired changes and then save the Interactive Reporting database connection file when prompted.

Connecting to Databases

In Interactive Reporting Studio, you use an Interactive Reporting database connection file (.oce) to perform tasks that require you to connect to a database, such as:

- Downloading a Data Model
- Processing a query to retrieve a data set
- Showing values for a server limit
- Using server functions to create computed items
- Scheduling an Interactive Reporting document file.

The way you select an Interactive Reporting database connection file depends on which edition of Interactive Reporting Studio you are using and the data model or Interactive Reporting database connection file with which you are working.

If a data model is present in the Query section, Interactive Reporting Studio automatically prompts you with the correct Interactive Reporting database connection file when your actions require a database connection.

When you open Interactive Reporting Studio to begin a work session (for example, by downloading a data model from an Interactive Reporting Studio repository, or creating a data model from scratch) you must select the correct Interactive Reporting database connection file for the targeted database.

Monitoring Connections

Before you attempt to connect to a database, make sure you are not already connected.

You can monitor the current connection status by observing the connection icon, on the lower right side of the Status bar. An X over the icon, indicates there is no current database connection.

To check the connection information, position the cursor over the connection icon. The Interactive Reporting database connection file in use and database name is displayed on the left side of the Status bar.
Connecting with a Data Model

Once a data model is downloaded to or created in the Interactive Reporting document file, the Interactive Reporting document file is associated with the Interactive Reporting database connection file used to create the data model. Interactive Reporting document files store a reference that calls the associated Interactive Reporting database connection file whenever you need to log on to the database to build or process a query.

➤ To log on to a database from an existing Interactive Reporting document file:

1. Select Tools > Connection > Logon or double-click the connection icon on the Status bar.
   The Interactive Reporting database connection dialog box is displayed with the Interactive Reporting database connection file name in the title bar.

2. Enter the user name and password and click OK.

Connecting Without a Data Model

Interactive Reporting Studio users have the option of creating new data models in an empty Interactive Reporting document file. Other users download prebuilt data models from the repository.

In either situation, you select an Interactive Reporting database connection file and connect to a database before you proceed. The database you select contains either the source tables for the data model you plan to create, or the repository that contains the data models you need to download.

➤ To select an Interactive Reporting database connection file when you create a new Interactive Reporting database connection file:

1. Select File > New to display the New File dialog box.

2. Select the Recent Database Connection Files radio button and select an Interactive Reporting connection file from the list, then click OK.
   If the Interactive Reporting database connection file is not displayed, click Browse to display the Select Connection dialog box. Navigate to the Interactive Reporting database connection file and click Open.
   Interactive Reporting Studio prompts you for a user name and password.

3. Enter the user name and password and click OK.
   If you do not have the right Interactive Reporting database connection file for a particular database, ask the database administrator to provide one or help you create an Interactive Reporting database connection file.

Note:
You can create new blank Interactive Reporting document files without connecting to a database. Blank Interactive Reporting document files are useful for importing data files such as
Excel spreadsheets; for creating Dashboard master Interactive Reporting document files and for performing tasks you do not necessarily associate with a database.

**Setting a Default Interactive Reporting Database Connection**

If you log on to one database more frequently than others, you should set the Interactive Reporting database connection file for that particular database as the default connection. Whenever you log on to create a new data model, the default Interactive Reporting database connection file loads automatically.

If you frequently use different databases in the work, you may not want to set a default Interactive Reporting database connection. If you leave the default Interactive Reporting database connection file preference blank, Interactive Reporting Studio prompts you to select an Interactive Reporting database connection file each time you log on.

➤ To set a default Interactive Reporting database connection file:

1. **Select Tools > Options > Program Options.**
   - The Interactive Reporting Studio Options dialog box is displayed.

2. **Select File Locations tab to display the File Locations tab.**

3. **In Connections Direction, enter the default connection directory that contains the Interactive Reporting database connection files you use to connect to different databases and click OK.**

4. **In Default Connection, enter the full path and file name of the Interactive Reporting database connection file used as the default connection.**

   The next time you log on (and create a new Interactive Reporting document file), the default Interactive Reporting database connection file is automatically used.

   Store your default Interactive Reporting database connection file in your connections directory so that Interactive Reporting Studio can find them when you or users of your distributed Interactive Reporting document files attempt to log on.

**Logging On Automatically**

Interactive Reporting provides an Auto Logon feature that maintains the current Interactive Reporting database connection file. Auto Logon is enabled by default.

➤ To toggle Auto Logon:

1. **Select Tools > Options > Program Options.**
   - The Interactive Reporting Studio Options dialog box is displayed.

2. **Click the General tab to display the General tab.**

3. **Select the Auto Logon check box and click OK.**
To use Auto Logon when creating a new Interactive Reporting document file:

1 Select the connection icon on the Status bar to verify that Interactive Reporting Studio is connected to the database.
2 Select File > New.
   The Auto Logon dialog box is displayed.
3 Click Yes to accept the existing connection.
   Interactive Reporting Studio opens the new Interactive Reporting document file. If Auto Logon was accepted, you are connected to the database server automatically. Otherwise, you can select a different Interactive Reporting database connection file.

Using the Connections Manager

The Connections Manager enables you to view the status of all Interactive Reporting database connection files in all open Interactive Reporting document file. Use the Connections Manager to check or change the status of an Interactive Reporting database connection file, to modify connection preferences, or to change database passwords.

The Document Connections frame of the Connections Manager lists each open Interactive Reporting document file and its associated Interactive Reporting database connection file:

- **Connection**—Name of the selected Interactive Reporting database connection file
- **Status**—Connection status (connected or disconnected)
- **Used By**—Name of the Interactive Reporting document section that accesses the database

Use the plus (+) and minus (–) signs to navigate through the tree structure.

Logging On to a Database

To log on to a database:

1 Select Tools > Connections Manager or press F11.
   The Connections Manager dialog box is displayed.
2 Select an Interactive Reporting database connection file and click Logon.
   The Database Password dialog box is displayed.
3 Enter your user name and password and click OK.
   Once connected, the X is removed from the connection icon on the tree.
Logging Off of a Database

➤ To log off of a database:

1 Select Tools > Connections Manager or press F11.
   The Connections Manager dialog box is displayed.
2 Select the Interactive Reporting database connection and click Logoff.

Modifying an Interactive Reporting Database Connection File Using the Connections Manager

You can use the Connections Manager to change your Interactive Reporting database connection file preferences, depending on the database and connection software.

Note:
If you are not familiar with the preferences and their effects, ask the database administrator for assistance before changing the default settings.

➤ To modify an Interactive Reporting database connection file using the Connections Manager:

1 Select Tools > Connections Manager or press F11.
   The Connections Manager dialog box is displayed.
2 Select the Interactive Reporting database connection file and click Modify.
   The Database Connection Wizard is displayed showing the information for the Interactive Reporting database connection file.
3 Make any desired changes and save the Interactive Reporting database connection file when prompted.

Changing Data Passwords

You can change the database password if you are connected to any of these database servers in Interactive Reporting Studio: Essbase, Teradata, Oracle, Red Brick Warehouse, Microsoft SQL Server, or Sybase Server.

➤ To change the password:

1 Select Tools > Connections Manager or press F11.
   The Connections Manager dialog box is displayed.
2 Select the Interactive Reporting database connection file associated with the database to change and click Change Database Password.
   The Change Password dialog is displayed.
3 Enter a user name in the Username field.
4 Enter the current password in the Current Password field.
5 Enter the new password in the New Password field.
6 Enter the new password in the Verify New Password and click OK.

Note:
Some database servers support case-sensitive passwords and/or require a minimum password length. For more information, see the documentation for the database server.

Changing Database Passwords

You can change the database password if you are connected to any of these database servers in Interactive Reporting Web Client: Oracle’s Hyperion® Essbase® – System 9, Oracle, Red Brick Warehouse, Microsoft SQL Server, or Sybase Server.

➤ To change the password:

1 Select Tools > Change Database Password.
   The Change Password dialog box is displayed.
2 Enter the user name in the Username field.
3 Enter the current password in the Current Password field.
4 Enter the new password in the New Password field.
5 Enter the new password again in the Verify New Password field.

Note:
Some database servers support case-sensitive passwords and/or require a minimum password length. For more information, see the documentation for the database server.

Working with an Interactive Reporting Document and Connecting to a Database

Interactive Reporting document files consolidate instructions and specifications for querying, limiting, sorting, and computing data stored on the database server. An Interactive Reporting document file is centered on a Data Model and queries. You can build Data Models and queries yourself using Interactive Reporting Studio, or download shared Data Models from a document repository into an Interactive Reporting document file.

Interactive Reporting document files are associated with a database server by way of a separate Interactive Reporting database connection file. You use a separate Interactive Reporting database connection file for each database server. Each Interactive Reporting database connection file retains routines, instructions, protocols and parameters in a small file, also called an Open Catalog Extension (.oce). The Interactive Reporting database connection file also preserves DBMS-specific connection preferences and specifications for automatic access to metadata.
For Interactive Reporting Studio users, the process of creating a new Interactive Reporting document file and logging onto a database is simple. You select an Interactive Reporting database connection file for the database server to use and enter the database password. You can select either a new or an existing Interactive Reporting database connection file.

➤ To create a new Interactive Reporting document using an existing Interactive Reporting database connection file:

1 Select File > New.
   The New File dialog box is displayed.

2 From Recent Connection Files, select an Interactive Reporting database connection file from the list.

3 If the connection file is not displayed, click Browse to display Select Connection. Navigate to the Interactive Reporting database connection file and click Open.
   The Connection Password dialog box is displayed.

4 Type your user name in the Host User field, password in the Host Password field, and click OK.
   If you do not have the right Interactive Reporting database connection file to connect to a particular database, ask your administrator to provide or help you create a connection file.

➤ To create a new Interactive Reporting document file using a new Interactive Reporting database connection file:

1 Select File > New.
   The New File dialog box is displayed.

2 Select A New Database Connection File field, and click OK.
   The Database Connection Wizard is launched.

3 Follow the instructions provided by the Database Connection Wizard.

➤ To create a blank Interactive Reporting document file with no Interactive Reporting database connection file:

1 Select the Other check box.

2 Select the Blank Document field and click OK.
   Blank Interactive Reporting document files are useful for importing data files such as Excel spreadsheets; for creating a Dashboard master Interactive Reporting document; and performing tasks you don’t normally associate with a database.

➤ To open a Interactive Reporting document file, select Open an Existing Document and select an Interactive Reporting document file from the Recent Connect Documents list.

If the Interactive Reporting document file is not displayed, click Locate File. When the browse box is activated, click the Browse button to display the Open File dialog box. Navigate to the Interactive Reporting document file and click Open. Interactive Reporting document files are saved with a .bqy extension on Windows.
To select an Interactive Reporting database connection file from the document repository:

1. **On the File menu, Open from Repository and click Select.**
   The Select Connection dialog box is displayed.

2. **Navigate to the Interactive Reporting database connection file and click Open.**
   When querying the database, you first select the data items that interest you from a Data Models, Standard Query or Standard Query with Reports. You can find a repository object to start with by selecting one from the Repository Catalog and downloading it to the desktop. When you download the object to the Contents frame, the object becomes the basis of a new Interactive Reporting document file.

3. **If you are not connected, log on to the database containing the document repository by selecting an Interactive Reporting database connection file from the Select Connection dialog box and entering your database user name and password.**
   The Open from Repository dialog box is displayed.
   The Open from Repository dialog box shows the Repository Catalog in the left frame and description information in the right frame. The Repository Catalog is in directory tree format, which enables you to navigate through the repository structure.
   Repositories are organized into subdivisions, which depending on the database may have subdivisions called databases, and most likely have subdivisions called owners. Databases and owners can be departmental headings, people in your organization, or other criteria established by the administrator.
   You cannot access versions 4.0 and older of the repository.

4. **Under each owner name in the repository, there are user groups.**
   User groups are established by an advanced user to categorize and store repository objects by content and access privileges. You have been granted access to only the items you see in the Repository Catalog.

5. **Select the document icons in the directory tree to display profiles in the Model Info and Description Areas to the right.**

6. **When you have navigated to the correct repository owner and user group and found the repository object, select the object in the directory tree and click Open.**
   Interactive Reporting downloads the repository object to the appropriate section.

### Connecting to Interactive Reporting Web Client

Connections made through Interactive Reporting Web Clients and the Workspace can be made immediately to a database, or deferred until a query is actually processed.

**Note:**

A locally saved Interactive Reporting document file does not prompt to connect to the Workspace when opened by dragging the Interactive Reporting document file into a Web browser. A message is displayed stating that the Interactive Reporting document file is opening.
in offline mode. This is part of Windows XP SP2’s new pop-up blocker feature. The workaround is to disable the pop-up blocker. In Microsoft Internet Explorer, select Tools > Pop-Up Blocker > Turn Off Pop-up Blocker.

**Note:**
Firefox does not invoke Interactive Reporting Web Client if: the Interactive Reporting document file name contains double-byte characters or characters from a code page different from the system code page in its file name. In addition, multilingual file names are not recognized by FireFox.

➤ To select a Web client connection method:

1. **Select Tools > Connect or press F11.**
   The Connect drop-down box is displayed.

2. **Select Web Clients.**
   The Web Clients dialog box is displayed.

3. **Select the connection method for the web client:**
   - **Immediately connect to database**—Select this method to immediately connect to a database using genuine database authentication. You are prompted for the logon credentials to the database being accessed. The value set here for the Interactive Reporting document file in Interactive Reporting Studio cannot be changed in Interactive Reporting Web Client. This connection method is the preferred method for Interactive Reporting document files created in Interactive Reporting version 8.2 and later.
   - **Defer connection to database until used to process SQL**—Select this method to defer making a connection to a database until the query is processed. You are prompted for logon credentials to the database without using genuine database authentication. That is, no actual Interactive Reporting database connection file is attempted until the query is processed.

**Deferring Interactive Reporting Web Client Connections**

When an Interactive Reporting document file is opened in Interactive Reporting Web Client, a connection is made to the database immediately using the criteria set in the Interactive Reporting database connection file. This has been the default behavior for the Interactive Reporting Studio and Interactive Reporting Web Client since Release 8.2. Interactive Reporting Web Client optionally enables you to defer the connection to the database until the query is processed. That is, the credentials for the user are obtained following the rules established by the Workspace and by the publishers of the Interactive Reporting document file and document content. For example, if the Interactive Reporting database connection file associated with the query is set to prompt the user when the Interactive Reporting document file was published, the user is prompted; if at publishing time the credentials were supplied (Specify Now), then those credentials are used, and so on. If you defer the connection to the database, the deferment is not
saved with the Interactive Reporting document file. When it is reopened, an immediate attempt to connection to the database is made.

Note:

Deferring the connection to the database in Interactive Reporting Web Client, can only be set in the Interactive Reporting Studio. The setting only affects Interactive Reporting document file opened in Interactive Reporting Web Client, and not in the Interactive Reporting Studio

To defer the connection to the database for an Interactive Reporting document file in Interactive Reporting Web Client:

   The Web Client dialog box is displayed.

2. To defer the connection to the database until the SQL is processed, select Defer connection to database until used to process SQL. This was the default behavior before 8.2 and click OK.

3. Optional. To reset the connection option to the default setting, select Immediately connect to database. (This is the default behavior for version 8.2 and later and is recommended and click OK.

Connecting to Workspace

Use the Connect to Server dialog box to specify the Data Access Servlet URL required to launch the Workspace. The Workspace consists of services, applications, and tools for those users who need to find and view Interactive Reporting document files and for users who need to import files, schedule jobs, and distribute the output.

To connect to the Workspace:

   The Connect to Server dialog box is displayed.

2. Specify the Data Access Servlet URL required to launch the Workspace in the Server Address field.
About Bidirectional Text

Bidirectional text is text containing both right-to-left and left-to-right directional runs. Bidirectional text support is available on all platforms, in the user interface and in all exported document files:

- Export to HTML
- Office HTML
- Export to PDF.

Bidirectional text is rendered equally in all possible output modes, but with the following restrictions:

- Ligatures are not placed between Arabic letters if the text is exported to a PDF file. A ligature is a sequence of characters displayed as a single unit replacing characters that occur next to each other when common components are shared.
- In Office HTML Export, the bidirectional processing is performed by Microsoft Excel after the exported document file is opened. Due to this behavior, text rendering may differ from what is presented in the Interactive Reporting Studio or Workspace.
- The system-defined bidirectional behavior of the following user interface controls is not changed: edit, drop-down, and list-box. This is true both for clients (Interactive Reporting Studio and Interactive Reporting Web Client) and the Workspace.

Understanding Bidirectional Text

Each language has its writing system, or script. Script includes the set of characters which are used for writing. Most languages can be viewed in a left-to-right (LTR) direction of the text, which means that writing begins from left-hand side of page, and concludes at the right-hand side. However there are scripts which have a right-to-left (RTL) direction, for example, Arabic and Hebrew.
Since both RTL and LTR directional text can be displayed within the same paragraph, these paragraphs are referred to as “bidirectional.” For example in the Hebrew text below, the text is written in the RTL direction, and numbers are LTR directional.

You read this sentence starting from the right side beginning with:

יהודיaira ב Furious 1943_next reading number 1943, then reading:

Bear לני זפר.

Complex structures occur when a paragraph of one direction has a citation of different directional text. This citation can contain other citations, which can have original text direction and so on. Consequently text of different directions can be enclosed several times.

The part of the text which has the same direction is called a run.

Bidirectional text can be ordered in visual or logical order. When characters are ordered in the same way in which they are displayed - from left to right, it is a visual order. Entering or reading bidirectional text is done in logical order, which is the sequencing of characters ordered on the way in which characters should be read. Some text scripts require that characters be combined into one ligature when output.

**Bidirectional Text Configuration Settings**

Bidirectional text properties can be set in the application configuration file. On UNIX, processing of bidirectional text is enabled by default. On Windows, bidirectional text support is performed when complex script support is enabled in the system. Additionally, bidirectional support is disabled by using the setting:

```
[Regional Settings]
BidiEnabled=0
```

All paragraphs are left-to-right directional by default, but this setting can be modified by using the setting:

```
[Regional Settings]
TextDirection=LTR|RTL|Context
```

All paragraphs have a left to right reading order if the setting is LTR, or a right to left reading order if the setting is RTL. Context refers to the paragraph direction based on the first letter of paragraph.
About Metatopics and Metadata

Metatopics and metadata enable advanced users to mask the more confusing technical aspects of databases for non-technical users. While data models are already simplified views of the database, they sometimes still present a challenge to novice users. This is especially true when confusing database names and complicated strategies are visible in the data model.

For most end users, the confusing aspects of query building stem from two sources:

- Data model topic and join structures
- Database naming conventions

Interactive Reporting Studio provides two solutions to deal with each of these problems. These complementary solutions can be integrated to shield company personnel from the technical aspects of the query process and make end-user querying completely intuitive:

- **Metatopics**—Topics created from items in other topics. Metatopics are higher level topics, or “virtual topics” that simplify the data model structure and make joins transparent. A metatopic looks and behaves like any other topic and can accept modifications and metadata.

- **Metadata**—Data about data. Typically stored in database tables, and often associated with data warehousing, metadata describes the history, content, and function of database tables, columns, and joins in understandable business terms.

Metadata is useful for overcoming the awkward names or ambiguous abbreviations often used in a database. For example, for a database table named CUST_OLD, metadata can
substitute a description business name for the table, such as “Inactive Customers,” when it is viewed by the end user. Metadata may also include longer comments.

Because most business maintain their metadata on a database server, it is a potentially useful guide to the contents of the database, if it can be synchronized and used in conjunction with the data it describes.

**Data Modeling with Metatopics**

As noted earlier, metatopics allow you to create higher level topics that can greatly simplify the appearance of a data model.

Unlike other topics, metatopics are independent of actual database tables. You can use metatopics to make the column and join structure of an underlying database transparent. You can substitute instead streamlined and intuitive topics adapted to the way users conceptualize information.

For example, you can replace a data model of joined topics with a single metatopics that contains only the items business personnel need in their queries. The joins are completely transparent.

*Tip:*

Metatopics do not support detail view.

**Creating Metatopics**

You can create a new, empty metatopic or copy an existing topic to use as the basis for a metatopic.

➤ To create a new, empty metatopic:

1. *Select DataModel > Add Metatopic.*
2. *Type the name of the new topic in the Topic Properties dialog box and click OK.*

➤ To create a metatopic from an existing topic:

1. *Select a topic in the Content frame.*
2. *Select DataModel > Promote To Metatopic.*

A new metatopic is displayed in the Content frame with the default name: Meta_TopicName. The new topic contains the same items defined in the source topic.

**Copying Topic Items to a Metatopic**

After you create a metatopic, you can rebuild its structure by copying topic items from other topics. Once the topic items are in place, you can view the data model solely at the metatopic level, excluding the original topics in favor of a single metatopic or multiple unjoined metatopics.
To copy items from other topics to a metatopic, select the item that you want to add from an existing topic and drag it to the metatopic.

To select and drag multiple topic items from the same topic, press and hold down the modifier key Alt for Windows, [Option] for MAC or Ctrl+Alt for Motif while using the mouse.

**Note:**
You can select items from only one topic at a time.

---

**Caution!**
If a metatopic contains items copied from an original source topic, do not remove the original topic or use the icon view. Because metatopic items model data through the original source topics, removing the original source topics or using an icon view also removes the copied topic items from the metatopic.

---

**Creating Computed Metatopic Items**

You can customize metatopics by adding *computed items* that do not exist in the database. Computed metatopic items provide end users with access to information they need without storing the data in the database or forcing them to master complicated computations.

Computed Metatopic items can be calculated by either the database server or locally. Locally computed metatopic items are restricted to reference items drawn from the metatopic where the item is placed. Server computed items can reference any items in the original topics or metatopics of the data model.

To create a computed metatopic item:

1. **Select the metatopic for which you want to create a computed metatopic item.**
2. **Select Data Model > Add Metatopic Item > Server or Local.**
   The server or local version of the Modify Item dialog box for computed items is displayed.
3. **Enter a descriptive item name in the Name field.**
4. **Type or use the following buttons to create computed item expression:**
   - Functions button—Applies scalar functions to data items.
   - Reference button—Adds Request Items to the expression.
   - Options button—Specifies a data type.
   - Operator buttons—Adds logical and arithmetic operators to the expression.
Customizing or Removing Metatopics and Metatopic Items

You can apply the same customization options that you use to make original topics and items more intuitive to metatopics and metatopic items.

➤ To remove a metatopic or metatopic item, use one of these options:
  ● Select the metatopic or topic item that you want to remove and select Remove on the shortcut menu.
  ● Press Del.
  ● Press the Delete button.

Caution!
If you remove a metatopic item, it cannot be restored to the metatopic. You must copy the item back to the metatopic or recreate it.

Viewing Metatopics

There are a number of ways to view a data model. By default, database-derived source topics and any metatopics you have created are displayed together in the Content frame in Combined view.

➤ To change the data model view, select DataModel > Data Model View > Option.
Options include:
  ● Combined—Displays both original (database-derived) and metatopics in the Content frame.
  ● Original—Displays only database-derived topics in the Content frame.
  ● Meta—Displays only metatopics in the Content frame.

Caution!
If an original topic contains items that have been copied to a metatopic, do not iconize or remove the original topic from the Content frame in Combined view. Metatopic items are based on original items and remain linked to them. If an original topic is iconized or removed, any metatopic items based on its contents become inaccessible.

MetaData in Interactive Reporting Studio

Interactive Reporting Studio utilizes available metadata to simplify data models. By applying metadata naming conventions and descriptive information, metadata makes the information locked away in database tables and columns more accessible.
Metadata can be applied in several ways in Interactive Reporting Studio. If you have a source of metadata stored on a database server, Interactive Reporting Studio users can use the Open Metadata Interpreter to link it to data models and automatically apply the metadata information. The data modeling features of Interactive Reporting Studio provide ways to add the benefits of metadata if you don’t have a centralized metadata source. Interactive Reporting Studio automatically makes topic and item names more intelligible, and enables you to customize and change the appearance of these entities.

**Using the Open Metadata Interpreter**

The Open Metadata Interpreter is a powerful tool you can use to link Interactive Reporting Studio to metadata, or information about the database. By modifying the SQL that Interactive Reporting Studio sends to the database server, you can dictate where Interactive Reporting Studio finds the information it uses to create a data model from database tables.

The Open Metadata Interpreter enables Interactive Reporting Studio users to draw this information from an enterprise source of business metadata.

The Open Metadata Interpreter reads metadata from tables on a database and applies it to data models through a live database connection. The specifications for reading these tables are stores in Interactive Reporting database connection files. Once configured, metadata definitions are available to anyone who uses the Interactive Reporting database connection files.

**Accessing the Open Metadata Interpreter**

The Open Metadata Interpreter (OMI) is a feature of Interactive Reporting database connection files—files that enables Interactive Reporting Studio to manage database connectivity. OMI is implemented using the Metadata Definition dialog box of the Database Connection Wizard.

To open the Metadata Definition dialog box:

1. If Interactive Reporting Studio is not connected to a database, select the Interactive Reporting database connection files that you want to direct to the metadata source and log on.
2. Select **Tools > Connection > Modify**.
   
   The Database Connection Wizard is launched with the Meta Connection Wizard displayed.
3. Select whether to run the Meta Connection Wizard on the current connection or on a different connection.

   If you select a different connection, the Select Metadata Interactive Reporting database connection field becomes active.
   a. Enter the full path and file name of the Interactive Reporting database connection file that you want to use. You can also click **Browse** to navigate to the location of the Interactive Reporting database connection file.
   b. Click **Next**.

   The Password dialog box is displayed.
c. Enter the database name in the Host Name field and the database password in the Host Password field and click OK.

d. Select the current database name and password to make the metadata connection or to specify an alternate name and password.

If you specify an alternate user name and password, enter the name and password that you want to use for the metadata connection.

4 Click Next.

5 Select the metadata schema where the meta settings are stored from the drop-down box.

Metadata schema are provided by third party vendors and saved in the bqmeta0.ini file. When you select a metadata schema, the predefined schema populates the fields in the Metadata Definition dialog box and is saved to the Interactive Reporting database connection file. If you select another schema, the metadata definitions are overwritten in the Interactive Reporting database connection file.

If you want to customize the metadata settings, select Custom from the drop-down box and click Edit. The Metadata Definition dialog box is displayed, which contains tabs for tables, columns, joins, lookup, and remarks.

For detailed explanations of the metadata definitions, see “Configuring the Open Metadata Interpreter” on page 448.

6 Enter the schema name or owner of the metadata repository table (for custom settings) or click Next to complete the Meta Connection Wizard and return to the Data Connection Wizard.

**Configuring the Open Metadata Interpreter**

The Open Metadata Interpreter is implemented using the Metadata Definitions dialog box. You add metadata definitions in the Metadata Definition dialog box, which contains five tabbed pages.

The pages can be independently configured and are designed to assist you in creating SQL Select statements to extract and apply metadata from predefined source tables or provided by third party vendors.

Radio buttons at the top of the certain pages enable you to specify naming based on actual default table and column names, or a custom metadata source. When the custom option is selected, the SQL entry fields on the tab are activated, and you can enter SQL statements into the separate metadata definition areas.

**Metadata Definition: SQL Entry Fields**

Each Metadata Definition tab has up to three Metadata Table Definition SQL entry fields:

- **Select**—Generates SQL Select statements, and is divided into distinct fields which specify the columns that store the metadata. The columns are located in the database table described in the From field. If necessary, you can use aliases in the Select fields to distinguish between multiple tables.
● **From**—Generates an SQL From clause, and specify the table(s) that contains metadata that applies to the database item described by the tab. You can also enter SQL to access system tables when necessary. If you need to reference more than one table in the From field, you can use table aliases in the SQL.

● **Where**—Generates SQL Where clauses and is used on the Columns and Joins pages to indicate which topic needs to be populated with item names or joined to another topic. It can also be used to establish relationships between multiple tables or filter tables.

**Notes on Entering SQL:**

- Entries are required in all From entry fields, and in all fields marked with an asterisk (*).
- Under default settings, Metadata Definition fields specify the system-managed directory tables (except when using ODBC). You cannot modify field values when the Default radio button is selected.
- :TABLE and :Column should not show quotes in the metadata set up. SQL adds the quotes automatically.
- Clicking Reset at any time when defining a custom source populates the entry fields with the database default values. It may be helpful to start with the defaults when setting up metadata definitions.
- You may sometimes use database variables when entering a Where clause. Interactive Reporting Studio provides :OWNER, :TABLE, :COLUMN, :LOOKUPID, :TABALIAS, and :COLALIAS variables which temporarily store a database owner, table, column, or domain ID number and aliases of the active topic or item. Each variable must be entered in all caps with a leading colon.

**Metadata Definition: Tables**

Extracting and applying metadata to topics is the simplest metadata configuration. When metadata is defined for database tables, they display in the Table catalog with the names supplied in an alternate “table of tables,” and topics drawn from the tables are renamed to reflect the metadata as well.

Once the Table tab is configured, all data models using the connection apply metadata names instead of the default server name to topics in the Content frame.

➤ To apply metadata names to data model topics:

1. **On the Tables tab, select Custom Definition.**

   The SQL entry fields activate and the system-managed information clears. Click Reset if you want to use the database default as a starting point.

2. **In the Select fields, enter the appropriate column names as they are displayed in the alternate table of tables.**

   - **Owner Name**—Name of the owner column in the alternate table of tables
• Physical Table Name—Name of the column of physical table names in the alternate table of tables
• Table Alias—Name of the column of metadata table aliases in the alternate table of tables
• Table Type—Name of the column of physical table descriptions in the alternate table of tables

3 In the From field, enter the physical name of the alternate table of tables.

4 Use the Where fields to filter selected topics (for example, to limit the metadata mapping to include only certain owners).

Note:
If multiple folders exist in the repository, the following modifications are necessary to the Interactive Reporting Studio bgmeta0.ini file in order to filter the list of tables by folder:

➤ To filter Informatica tables:
1 Under the heading labeled [Informatica], change the TableWhere property as follows (do not include brackets):
   TableWhere=SUBJECT_AREA='<folder name>'
2 Change the ColumnWhere property as follows (do not include brackets):
   ColumnWhere=table_name = ':TABLE' and SUBJECT_AREA='<folder name>'

Metadata Definition: Columns
On the Columns tab, you need to specify the topics in which items should display. You may also need to refer to the system-managed table of columns (in addition to the alternate table of columns) for some specific column information. Once you configure the Columns tab, all data models using the connection apply metadata to topic items in the Content frame instead of using default server names.

➤ To apply metadata names to data model topic items:
1 On the Columns tab, select Custom Definition.
   The SQL entry fields activate and the system-managed information clears. Click Reset if you want to use the database defaults as a starting point.
2 In the Select fields, enter the appropriate column names as they are displayed in the alternate table of columns and/or system-managed table of columns.
   • Physical Column Name—Name of the column of physical column names in the alternate table of columns
   • Column Alias—Name of the column of metadata column aliases in the alternate table of columns
   • Column Type—Name of the column of column data types
   • Byte Length—Name of the column of column data lengths
   • Fraction—Name of the column of column data scales
- **Total Digits**—Name of the column of column precision values
- **Null Values**—Name of the column of column null indicators

If you use more than one table in the From field, enter the full column name preceded by a table name in the Select field.

```
<table_name>.<column_name>
```

3. **In the From field, enter the physical names of the alternate table of columns (and system-managed table of tables, if necessary).**

If you are using both tables in the From field, you can simplify SQL entry by using table aliases.

4. **Use the Where field to relate columns in the alternate and system-managed tables of tables to ensure metadata is applied to the correct columns.**

Use the following syntax in the Where field (do not include brackets):

```
<table of columns>.<tables column>=':TABLE' and <table of columns>.<owners column>=':OWNER'.
```

Interactive Reporting Studio automatically populates a topic added to the Content frame with the metadata item names when it finds rows in the alternate table of columns that match the names temporarily stored in :TABLE and :OWNER. Use also the variables :TABALIAS and :COLALIAS to specify table and column aliases in SQL.

**Note:**

The database variables must be entered in upper case and preceded with a colon.

**Metadata Definition: Joins**

You can use the auto-join feature to automatically join topics based not only on the best guess of Interactive Reporting Studio, but also on primary and foreign key information stored in an alternative table of joins. Join strategies include:

- **Best Guess**—Joins columns of similar name and data type.
- **Custom**—Selects joins defined in a custom metadata source.
- **Server-Defined**—Uses joins that have been established on the database server.

The Joins tab uses SQL instructions to employ a custom join strategy stored in metadata. Once Interactive Reporting Studio is directed to the metadata source, all data models using the connection apply specified join logic between topics.

➤ **To automatically join topics using metadata join information:**

1. **On the Joins tab, select Custom.**
   - The SQL entry fields activate. (There are no system defaults for the Joins tab.) Click Clear to clear the entry fields if you make a mistake and want to start over.

2. **In the Select fields, enter the appropriate column names as they are displayed in the alternate table of joins.** Interactive Reporting Studio requires data in the Primary Table and Primary Column fields to find the primary keys.
• **Primary Database Name**—Sets the name of the column of databases for primary key tables in the alternate table of joins.

• **Primary Owner**—Sets the name of the column of owners belonging to primary key tables in the table of joins.

• **Primary Table**—Sets the name of the column of primary key tables in the table of joins.

• **Primary Column**—Sets the name of the column of primary key items in the table of joins.

• **Foreign Database Name**—Sets the name of the column of databases for foreign key tables in the alternate table of joins.

• **Foreign Owner**—Sets the name of the column of owners belonging to foreign key tables in the table of joins.

• **Foreign Table**—Sets the name of the column of foreign key tables in the table of joins.

• **Foreign Column**—Sets the name of the column of foreign key items in the table of joins.

If you use more than one table in the From field, enter the full column name preceded by a table name in the Select fields.

```
table_name.column_name
```

3 In the From field, enter the physical name of the alternate table of joins.

4 Use the Where field to tell Interactive Reporting Studio which topics to auto-join.

Use the following syntax in the Where field (do not include brackets):

```
<owners column>=':OWNER' and <tables column>=':TABLE'
```

If Auto-Join is enabled, Interactive Reporting Studio automatically joins topics added to the Content frame when it finds rows in the alternate table of joins that match the names temporarily stored in :TABLE and :OWNER. You can also use the variables :TABALIAS and :COLALIAS to specify table and column aliases in the SQL.

**Note:**

The database variables must be entered in upper case and preceded with a colon.

**Metadata Definition: Lookup**

Lookups apply metadata to values that are queried by the Show Values command in the limit dialog box. If the database tracks data by codes, abbreviations, or ID numbers, lookup values can help users effectively limit queries.

For example, the product table may track sales by product ID number. When the user attempts to limit the Product ID column in a query, a Show Values call to the database yields only ambiguous product ID numbers. It can be hard to tell where to apply the limit.

Using the Lookup tab, you can map the product ID values to a column of descriptive product names elsewhere in the database. When the user clicks Show Values, he or she selects among descriptive product names to set the limit on the underlying product ID numbers.
Note:
To use this feature, you need a table of descriptive lookup values in the database, and an additional mapping table to verify which items are supported by lookup values and where the corresponding lookup values are stored.

To apply metadata to limit lookup values:

1 On the Lookup tab, select Use SQL Definition.
The SQL entry fields activate. Click Clear to clear the entry fields if you make a mistake and want to start over.

2 In the Select fields, enter the appropriate column names as they displayed in the domain registry table. The Lookup Table, Lookup Value Column, Lookup Description Column, and Lookup Domain ID Column are required for Interactive Reporting Studio to locate lookup values.
   - **Lookup Database**—Name of the column of databases in the domain registry table.
   - **Lookup Owner**—Name of the column of owners in the domain registry table.
   - **Lookup Table**—Name of the column of tables containing lookup domain description values in the domain registry table.
   - **Lookup Description Column**—Name of the column of columns containing descriptive lookup values in the domain registry table.
   - **Lookup Value Column**—Name of the column of columns of original column values in the domain registry table.
   - **Lookup Domain ID Column**—Name of the column of domain IDs in the domain registry table.

3 In the From field, enter the physical name of the domain registry table.
Interactive Reporting Studio first sends SQL to the domain registry table to see if Lookup values are available for a given item.

4 Use the Where field to identify which items have lookup values.
Use the following format (do not include brackets):

\[
<tables column>=':TABLE' \text{ and } <columns column>=':COLUMN'
\]

When you limit an item and show values, Interactive Reporting Studio stores the physical table and column names of the item in the variables, :TABLE and :COLUMN.

Interactive Reporting Studio searches the domain registry table for a row that matches the values temporarily stored in :TABLE and :COLUMN. When it finds a row that matches, it pulls lookup values from the specified columns in the domain descriptions table. You can also use the :LOOKUPID variable to store the lookup domain ID value.

Note:
The database variables must be entered in upper case and preceded with a colon.

5 Use the Lookup Where field to sync the values in the domain registry and domain description tables.
**Metadata Definition: Remarks**

If database remarks already exist for the database, you can configure the Interactive Reporting database connection to retrieve and display them as part of the data model.

Database remarks function like context-sensitive help by providing detailed contextual information about a table or column, and can be very helpful to users when navigating through a large data model.

The Remarks tab uses SQL instructions to direct Interactive Reporting Studio toward the unified server source of remarks for tables and columns. Once the Remarks tab is configured, all data models using the connection have access to remarks (Query > Show Remarks).

To add remarks from stored metadata:

1. On the Remarks tab, select Table Remarks to set up remarks for tables, or select Column Remarks to set up remarks for columns.
   - Click **Clear** to clear the entry fields if you make a mistake and want to start over.
2. In the Tab Name field, type the name of the tab that you want to be displayed in the Show Remarks dialog box.
3. In the Select field, enter the name of the column of table or column remarks.
4. In the From field, enter the physical name of the table containing table or column remarks.
5. Use Where to link the selected topic to its corresponding remark.
   - Use the following syntax in the Where field:
     
     ```
     Name of the Remarks Table=:TABLE
     and
     Name of the Remarks Column=:COLUMN
     ```
   - The dynamic variable automatically inserts the physical name of the object from which the user is requesting data in the application. Interactive Reporting Studio displays remarks when it finds rows in the remarks tables which match the names temporarily stored in :TABLE and :COLUMN. You can also use the variables :TABALIAS (displays name of a table) and :COLALIAS (displays name of a column) to specify table and column aliases in the SQL.

   **Note:**
   - The database variables must be entered in upper case and preceded with a colon.
6. Click Add to add the tab to the Remarks Tabs list.
   - The Remarks Tabs list shows all of the tabs you entered in the order in which you entered them. The first tab in the lists is the default or first tab to be displayed in the Show Remarks dialog box.
   - Use the following buttons to reorder the appearance of Remarks tabs:
     - Up—Moves a tab up one position (toward the front of the Show Remarks dialog box).
     - Down—Moves a tab down one position (toward the back of the Show Remarks dialog box).
To update a Remarks tab:

1. On the Remarks tab, select the tab from the Remarks tabs list.
   The information for the selected tab is displayed in Remarks SQL fields.
2. Enter the desired changes in the Select, From, and Where fields, and then click Update.

To delete a Remarks tab:

On the Remarks tab, select the tab from the Remarks tabs list and click Delete.
About Data Models

When you use Interactive Reporting Studio to query a relational database and retrieve information, you work with a data model: a focused visual representation of the actual database tables.

Interactive Reporting Studio users can create data models, selectively viewing and packaging the contents of a database for querying or distribution. Distributed or shared data models are beneficial for several reasons:

- They substitute descriptive names for arcane database table and column names, enabling users to concentrate on the information, rather than the data retrieval.
- They are customized for users’ needs. Some kinds of data models include prebuilt queries that are ready to process, and may even include reports that are formatted and ready to use. Other data models may automatically deliver data to a user’s computer.
- They are standardized and up-to-date. A data model stored in the document repository can be used throughout the company and is easily updated by the database administrator to reflect changes in the database structure.

**Note:**

You can only add create and modify Data Models if you have the “Data Model, Query, and Analyze” adaptive state.

A Data Model displays database tables as topics in the Contents frame. Topics are visually joined together like database tables and contain related items used to build a query.
Multiple queries can be constructed against a single Data Model in the same Interactive Reporting document file. If you modify the Data Model, any changes are automatically propagated to the corresponding queries.

In addition to standard Data Models derived from database tables, you can create metatopics—virtual views independent of the actual database. You use metatopics to standardize complex calculations and simplify views of the underlying data with intuitive topics customized for business needs.

If you want to preserve a Data Model for future queries, you can promote it to a master data model and lock its basic property design. This feature enables you to generate future queries without having to recreate the Data Model. An Interactive Reporting document file can contain any number of master data models from which any numbers of queries can be generated.

## Building a Data Model

Data models are the building blocks of queries. In a data model, database tables are represented by topics. A *topic* is a list of items, each corresponding to a column in the database tables.

### Adding Topics to a Data Model

You create data models by choosing database tables from the *Table Catalog* and assembling them as topics in the Content frame. The Table catalog is a listing of the tables available in the database. Once connected to a database, you can display the Table catalog and drag the topics that you want to include in the data model to the Content frame.

- **To add a topic to a data model:**
  1. In the Query section, select **DataModel > Table Catalog**, or press F9.
     
     If you are not connected to the database, you are prompted to log on. Once connected, the Table catalog is displayed listing the available database tables.

     **Note:**

     Users can filter tables from the display as part of the database connection.

  2. Drag tables from the Table catalog to the Content frame.
     
     Each database table you place in the Content frame is converted to a topic in a data model.
Removing Topics from a Data Model

➤ To remove a topic from a data model, select the topic and select Remove on the pop-up menu or press Del.

Understanding Joins

Tables in relational databases share information through a conceptual link, or join, between related columns in different tables. These relationships are displayed in the data model through visual join lines between topic items.

Joins enable you to connect or link records in two tables by way of a shared data field. Once a data field is shared, other data contained in the joined tables can be accessed. In this way, each record can share data with another record, but does not store and duplicate the same kind of information.

Joins can be automatically created joins for you, or you can manually join topics.

Suppose you queried only the Customers table to determine the number of customers. You would retrieve 32 records with the names of the stores that purchase products since 32 is the exact amount of stores that have made a purchase.

But suppose you made the same query with the Customers table and Sales table joined. This time you would retrieve 1,000 records, because each store made multiple purchases. Figure 1 shows the intersection of all records in the Sales table that mention stores listed in the Customers table.

![Figure 1 Result of Join Between Two Tables](image)

In other words, a database query returns the records at the intersection of joined tables. If one table mentions stores 1-32 and the other table mentions those same stores repeatedly, each of these records will be returned.

If you join still a third table, such as items, records are returned from the intersection of all three. Figure 2 shows the intersection of all records in the Sales table that have stores in the Customers table and items in the Items table.
The following sections discuss the types of joins available and how to use them:

- “Simple Joins” on page 460
- “Cross Joins” on page 461
- “Joining Topics” on page 461
- “Specifying an Automatic Join Strategy” on page 461
- “Manually Joining Topics” on page 462
- “Showing Icon Joins” on page 463
- “Specifying Join Types” on page 463
- “Removing Joins” on page 464
- “Using Defined Join Paths” on page 464
- “Using Local Joins” on page 465

**Simple Joins**

A simple join between topic items, shown in Figure 3, retrieves rows where the values in joined columns match.

![Figure 3 Simple Join Between Identical Store Key Fields in Two Topics](image)
Joins need to occur between items containing the same data. Often, the item names between two topics are identical, which sometimes indicates which items join. When selecting items to join, recognize that two items may share the same name, but refer to completely different data. For example, an item called “Name” in a Customer table and an item called “Name” in a Product table are probably unrelated.

**Cross Joins**

If topics are not joined, a database cannot correlate the information between the tables in the data mode. This leads to invalid datasets and run-away queries. In this case, a database creates a cross join between non-joined tables, where every row in one table is joined to every row in another table.

**Joining Topics**

The Auto Join Tables option automatically joins database tables as they are added to the Content frame using one of three different join strategies. If Auto Join Tables is not selected, you can manually create joins between topics in the Content frame.

To automatically join topics as they are added to the Content frame:

1. **Select DataModel > Data Model Options.**
   The Data Model Options dialog box is displayed.

2. **Select the General tab.**

3. **Select the Auto Join Tables check box and then click OK.**
   When you add tables from the Table catalog to the Content frame, joins automatically display between topics.
   Clear the Auto Join Tables check box to turn off this feature and manually create joins yourself.

**Note:**

Joins are not added for topics that are in the Content frame before you select the Auto Join Tables option.

**Specifying an Automatic Join Strategy**

You can instruct Interactive Reporting Studio to use one of three different strategies when automatically joining topics. The strategy chosen is employed with a particular connection and saved with the Interactive Reporting database connection file.

To select an automatic join strategy for a database connection:

1. **If you are not currently connected to the database, select an Interactive Reporting database connection file and log on.**
2 Select Tools > Connections > Modify.

The Meta Connection Wizard is displayed with the On The Current Connection option selected.

Note:
For information on metatopics and metadata, see Creating Metatopics.

3 Click Next.

The Meta Connection Wizard displays the repository where the meta settings are stored.

4 Click Edit.

The Metadata Definition dialog box is displayed.

5 Select the Joins tab.

6 Select a join strategy. Join strategy options are:

- **Best Guess**—Joins topics through two items that share the same name and data type
- **Custom**—Joins topics according to specified schema coded in SQL in the Metadata Join Definitions area
- **Server-Defined**—Joins topics based on primary and foreign keys established in the underlying relational database

7 When you have completed the selection, click OK.

**Manually Joining Topics**

You can create relationships between topics by manually joining topic items in the Content frame (see Figure 4).

Figure 4 Manually Created Join Between Two Related Data Items in Two Topics

To manually join two topics, select a topic item, drag it over a topic item in another topic, and release.

A join line is displayed, connecting the items in the different topics.
Showing Icon Joins
When a topic is iconized, you can toggle the display of joins to other topics in the Content frame.

➤ To show icon joins:
1 Select DataModel > Data Model Options.
   The Data Model Options dialog box is displayed.
2 Select the General tab to display the General tab.
3 Select the Show Icon Joins check box and click OK.
   Clear the Show Icon Joins check box to turn off this feature and hide joins of iconized topics.

Specifying Join Types
Join types determine how data is retrieved from a database.

➤ To specify a join type:
1 Select a join line and select View > Properties or click the Properties icon.
   The Join Properties dialog box is displayed.
2 Select a join type and click OK.

Four types of joins are supported:
- **Simple join** (=, >,<, >=, <=+)—A simple (linear) join retrieves the records in both tables that have an identical data in the joined columns.
  You can change the default join setting for simple joins by choosing an operator from the drop-down box. The default setting, Equal, is preferred in most situations.
- **Left outer join** (+=)—A left join retrieves all rows from the topic on the left and any rows from the topic on the right that have matching values in the join column.
- **Right outer join** (=+)—A right join retrieves all rows from the topic on the right and any rows from the topic on the left that have matching values in the join column.
- **Outer or full outer join** (+ = +)—An outer join combines the impact of a left and right join. An outer join retrieves all rows from both tables matching joined column values, if found, or retrieves nulls for non-matching values. Every row represented in both topics is displayed at least once.

**Note:**
A fifth join type, Local Join, is available for use with local Results sets. See “Using Local Joins as Filters” on page 466 for more information.
Caution!

Not all database servers support all join types. If a join type is not available for the database to which you are connected, it is unavailable for selection in the Join Properties dialog box.

Removing Joins

You can remove unwanted joins from the data model. Removing a join has no effect on the underlying database tables or any server-defined joins between them. A deleted join is removed from consideration only within the data model.

➢ To remove a join from a data model, select the join and select Remove on the shortcut menu.

Using Defined Join Paths

Defined Join Paths are customized join preferences that enables you to include or exclude appropriate tables based on the items referenced on the Request and Limit lines. “Bridge tables,” which are not explicitly referenced in the query, are transparently added to the SQL From clause. The net effect limits the query to all referenced tables based on available table groupings, which generate the most efficient SQL for queries off the data model.

➢ To use defined join paths:

1 Select DataModel > Data Model Options.  
The Data Model Options dialog box is displayed.

2 Select the Joins tab to display the Joins tab.

3 Select the Use Defined Join Paths option and click Configure.  
The Define Join Paths dialog box is displayed.

4 In the Define Join Paths dialog box, click New Join Path to name and add a join path.  
The New Join Path dialog box is displayed.

5 In the New Join Path dialog box, enter a descriptive name for the join path and click OK.  
The join path name is highlighted in the Defined Join Paths dialog box.

6 Select a topic in the Available topics list and use the move right (--> ) button to move it to the Topics In Join Path list.

7 To remove join paths from the Topics in Join Path list, select the move left (<--) button, to remove join paths from the Topics In Join Path list.

8 When join paths are completely defined for the data model, click OK.
Tip:
Join paths are not additive; Interactive Reporting Studio cannot determine which tables are common among several paths and link them on that basis. Join paths are not linear, and if selected, the simplest join between all tables in the path is included when processing a query.

Using Local Joins

You can add the results of one query to the results of another query in an Interactive Reporting document file by using *local joins*. Rows from the data sources are joined in the Results section.

Note:
No aggregation can be applied to local result tables and the local results data set cannot be processed to a table.

For example, you might want to see budget figures drawn from MS SQL server and sales figure drawn from an Oracle database combined in one Results set.

Caution!
Local joins are memory and CPU intensive operations. When using this feature, please limit the local joins by using a moderate number of rows.

The following sections explain how to work with local joins:

- “Creating Local Joins” on page 465
- “Using Local Joins as Filters” on page 466
- “Limitations of Local Results and Local Joins” on page 468

Creating Local Joins

To create a local join:

1. Select Insert > Insert New Query to create the first query in the Interactive Reporting document file (BQY):
   The Insert Query dialog is displayed.
2. Complete the steps for inserting a new query (described in the Insert Query topic).
3. In the Query section, verify item data types and associated data values in source documents so that you know how to join them in the Interactive Reporting document file (BQY).
4. Build the Request Line, and add server and local filters, data functions, and computations to the query as needed.
5. Select Process.
Tip:
For consistent results, queries that use local joins should be placed after queries that generate the needed results.

6 Select Insert > Insert New Query to create the second query.
(See step 1 for information on inserting a new query.)
Add topics from the Table catalog to the Content pane, and build the Request line.

7 In the Table catalog, select Local Results on the shortcut menu.

8 In the Table catalog of the second query, select Local Results on the shortcut menu.

A Local Results icon, displays in the Catalog pane.

9 Expand the Local Results icon to display the Results table icon,.

10 Double-click a Results set or drag it to the Content pane.
The Results set from the first query is displayed as a topic in the Content pane.

11 In the Content pane, manually create a join between the Results set and another topic.

12 Build the Request line and select Process.
Local joins are processed on the client machine.
You can use Process All to process the queries, in which case the queries are processed in the order in which they are displayed in the Section catalog.
For example, in an Interactive Reporting document file with three queries, Query1, Query2, and Query3, the queries are executed in the order shown. If Query1 is a local join of the results of Query2 and Query3, it will still be processed first. If Query2 and Query3 have existing Results sets, then the local join in Query1 will occur first, before processing Query2 or Query3. If the Results sets for either Query2 or Query3 are not available, one or both of those queries are processed first in order to get the required results.

Using Local Joins as Filters
A filter local join is a variation of a local join. Instead of independently running two queries then locally joining the data on the desktop, a filter local join runs the first query to retrieve a list of values, then uses those values to filter a column in the second query.

For example, a query may be run from an inventory table in an Oracle database to retrieve a list of part numbers that are out of stock. The resulting part number list may be used as a filter join to define the list of values retrieved from a work_in_process table in another database to determine the status of the stock replenishment.

Note:
The second query could potentially be a very long SQL statement since using filter local joins generates an SQL Having clause for each item.
To use the values retrieved from one query as filter values for another query:

1. Build the first query to include as a filter in the second query by selecting Insert > Insert New Query. The Insert Query dialog is displayed.
2. Complete the steps for inserting a new query (described in the Insert Query topic).
3. Verify item data types and associated data values in source documents so you will know how to join them in the second query.
4. Build the Request line, and add server filter, data functions and computations to the query as needed.
5. Select Process.

7. Select Insert > Insert New Query.
8. Build the second query.
   a. Verify item data types and associated data values in source documents so you will know how to join them to the first query.
   b. Build the Request line, and add server and local limits, data functions, and computations to the query as needed.
9. In the Table catalog of the second query, select Local Results from the shortcut menu.
   A Local Results icon, [icon] is displayed in the Catalog frame.
10. Expand the Local Results icon to display the Results table icon, [icon].
11. Double-click the Results icon or drag it to the Content frame.
   The Results set from the first query that you built is displayed as a topic in the Content pane.

   Note:
   The purpose of embedding the Results is to obtain a list of values. Do not include and Results set topic items on the Request line. Also, do not place any limits on topic items in this Results set. must not include any fields from the embedded Results section. If you do add a topic item from or set a limit on this Results set, you will not be able to set a Limit Local join.
12. In the Content pane, manually join the Results set to a another topic in the second query.
   A join line is displayed, connecting the different topics.
13. Double-click the join line that was created by joining the Results set and other topic, or click the Properties icon.
   The Join Properties dialog box is displayed.
14. Select Filter Local Join and click OK.

   Note:
   If the Filter Local Join option does not display in the Join Properties dialog box, make sure that no Results set topic items are included in the Request line and that no Filter have been placed on any Results set topic item.
15 Click Process to build the query and apply the filter constraint.

Limitations of Local Results and Local Joins

The following limitations apply to local results and local joins:

1. You cannot use any governors with local results topics as part of the query. The following are governors accessed from the Query Options dialog box:
   - Returning Unique Rows
   - Row limit
   - Time limit
   - Auto-Process
   - Custom Group by

2. You cannot have more than one local join per local results topic. When setting up a query using a local results topic, you cannot have more than one local join between the local results topic and another topic/local results topic.

3. You cannot set query limits on local results topic items. Limits must be set in the query/result sections of the query that produces the local results. Attempting to set a query limit on a local results topic item invokes the following error message: “Unable to retrieve value list for a computed or aggregate request item”.

4. You cannot aggregate local results tables.

5. You cannot process local results data to a table.

6. You cannot have more than one limit local join. A limit local join involves two topics, one of which is a local results topic. A local results item is used as a limit to the other topic. Attempting to define more than one limit local join invokes the following error message: “This query contains a local results object involved in a join limit. It is not possible to have other local results objects when you have a local join limit”.

7. You cannot combine limit local joins with local joins. Attempting to combine a limit local join and local join invokes the following error message: “This query contains a local results object involved in a join limit. It is not possible to have other local results objects when you have a local join limit”.

8. You should expect compromised performance when a query is associated with large local results sets. This is expected behavior since Interactive Reporting Studio is not a database.

9. You cannot use metatopics with local results. You cannot promote a local results topic to a metatopic or add a local results topic item as a metatopic item. The Promote To Meta Topic and Add Meta Topic Item DataModel menu options are not available for local results topics and topic items.

10. You cannot access or change properties for local results topic items. Properties include remarks, number formatting, aggregate/date/string functions, data types, and name.

11. You cannot have query request line computed columns from local results topic items. The Add Computed Item menu option is not available for local results topic items.
You cannot use Append Query features of unions or intersections with local results topic items. The Append Query menu option is not available when a local result topic is part of a query.

**Working with Topics**

There are several features that enable you to customize the appearance of topics to make them easier for end users to work with. The following sections describe how to work with topics:

- “Changing Topic Views” on page 469
- “Modifying Topic Properties” on page 470
- “Modifying Topic Item Properties” on page 471
- “Restricting Topic Views” on page 471

**Changing Topic Views**

You can change how you view topics in the Content frame. There are three ways to view topics, as shown in Figure 5:

**Figure 5** Structure (1), Detail (2), and Icon (3) Topic Views

- **Structure view**—Displays a topic as a simple list of component data items. This is the default setting.

  Structure view enables you to view and select individual data items to include in a query. This is the easiest view to use if you are familiar with the information that a data model, topics, and topic items represent.
● **Detail View**—Presents a topic in actual database view with a sample of the underlying data. When you change to Detail view, a small query is executed and a selection of data is loaded from the database server. The topic is displayed as a database table with each topic item displayed as a database column field.

Detail view is useful when you are unfamiliar with a topic. You can browse the first few rows of data to see exactly what is available before adding a topic item to the query.

**Note:**

Detail view is not available for special items such as metatopics or computed data items.

● **Icon View**—Deactivates a topic and reduces it to an icon in the Content frame. When a topic is displayed in Icon View, associated items are removed from the Request and Limit lines. The topic is not recognized as being joined to other topics, and is temporarily removed from the data model and the SQL statement.

If no items from a topic are needed for a particular query and the topic does not link together other topics which are in use, reduce the topic temporarily to Icon view to make large queries run faster and to consume fewer database resources.

➤ To change a topic view:

1. **Select a topic in the Content frame.**
2. **Select DataModel > Topic View > View.**

The topic is displayed in the chosen view.

In Icon view, you can restore the topic view by double-clicking the topic icon.

### Modifying Topic Properties

Use the Topic Properties dialog box to customize the way a topic and associated items are displayed in the data model. By default, items are displayed in the order in which they are defined in the underlying table, or the order in which they are added to a metatopic. You can change the way items are ordered or restrict their display of items within a topic.

➤ To modify topic properties:

1. **In the Catalog frame, select the topic and select View > Properties or click the Properties icon.**
   The Topic Properties dialog box is displayed.
2. **Change the properties to the desired setting and click OK.**

Available options include:

- **Topic Name**—Name of the topic that is shown in the Catalog frame. You can change this field to display a more user-friendly name in the Content frame.
- **Physical Name**—Full name of the underlying database table
- **Items To Display**—Topic items available for the selected topic.
- **Hide/Show All**—Hides or actively displays all topic items.
- **Up/Down**—Moves selected item up or down one space in the topic display.
- **Sort**—Sorts listed items alphabetically.

- **Set As Dimension**—Defines the drill-down path or *hierarchy* for dimensional analysis as shown in the data model. This feature is used in conjunction with the Set As Fact field in the Topic Item Properties dialog box.
- **Allow Icon View**—Enables the *icon view* option for the topic.
- **Allow Detail View**—Enables the *detail view* option for the topic.
- **Cause Reload**— Specifies automatic reloading of server values the next time Detail View is activated.
- **Rows to Load**—Specifies the number of rows to be loaded and displayed in Detail View.

### Modifying Topic Item Properties

Topic items are discrete informational attributes of topics, such as Customer ID, Street Address, or Sales Revenue, and are the basic building blocks of a query. Topic items are organized within topics and represent the columns of data in database tables.

You can modify the names of topic items to make them easier for users to understand and set drill-down path information.

► **To modify a topic item:**

1. **Select the topic item and select View > Properties or click the Properties icon.**

   The Topic Item Properties dialog box is displayed, showing information about the source of the topic column in the database.

2. **Change the topic item properties to the desired setting and click OK.**

   Available options include:

   - **Item Name**—Displays the name of the item.
   - **Set As Fact**—Eliminates items with integer or real values from a drill-down path. This feature is used in conjunction with the Set As Dimension field in the Topic Properties dialog box.
   - **Information**—Additional column information from the database. Information about keys is displayed only when server-defined joins are enabled.
   - **Length**—Enables you to change the string length of columns.

### Restricting Topic Views

Individual topics within a data model can be restricted to control the availability of the Icon view and Detail view, or to limit the number of rows retrieved (which can consume network and server resources) for Detail view.
To set access to Icon or Detail views:

1. **Double-click a topic to be view-restricted.**
   
The Topic Properties dialog box is displayed with the view options shown toward the bottom of the dialog box. The dialog box also contains options for customizing topics.

2. **Select the Allow Icon View or Allow Detail View check boxes to toggle the availability of either view.**

3. **If necessary, Cause Reload to specify loading from the server when Detail View is selected.**
   
   New data is retrieved the next time Detail View is activated for the topic, after which Cause Reload will be toggled off automatically.

4. **If desired in Detail View, enter the number of rows to be returned from the server for Detail View, and click OK.**
   
   By default, the first ten rows of a table are retrieved for preview in Detail View.

---

**Working with Data Models**

You can customize data models in a number of ways. You can change how data models are displayed in the Content frame. You also can define other data model options, such as user access, feature availability, and query governors. Review the following sections for information on:

- “Changing Data Model Views” on page 472
- “Setting Data Model Options” on page 473
- “Automatically Processing Queries” on page 478
- “Promoting a Query to a Master Data Model” on page 478
- “Synchronizing a Data Model” on page 478

---

**Changing Data Model Views**

There are a number of ways to view a data model. By default, database-derived source topics and any metatopics you have created are displayed together in the Content frame in Combined view.

To change the data model view, select **DataModel > Data Model View > Option**.

Options include:

- **Combined**—Displays both original (database-derived) and metatopics in the Content frame.
- **Original**—Displays only database-derived topics in the Content frame.
- **Meta**—Displays only metatopics in the Content frame.
Caution!

If an original topic contains items that have been copied to a metatopic, do not iconize or remove the original topic from the Content frame in Combined view. Metatopic items are based on original items and remain linked to them. If an original topic is iconized or removed, any metatopic items based on its contents become inaccessible.

Setting Data Model Options

To set data model options:

1 Select DataModel > Data Model Options.
   The Data Model Options dialog box is displayed.
2 Set the desired options for the data model and click OK.

Note:

All users have access to the join preferences, but not to the limit, query governor, or auditing features, which are designed to customize data models stored for distribution.

Before applying any new features, be aware that:

- One of the first three limit options (Show Values, Custom Values, or Custom SQL) must be enabled in order for users to apply limits in the Query section.
- Changing join usage usually changes the number of rows retrieved from the database. It also introduces the possibility that novice users may create improperly joined queries.
- If query governors are set as part of a data model, and end users set query governors on a query built from the data model, the more restrictive governor takes precedence.

The following sections provide additional information about data model options:

- “Saving Data Model Options as User Preferences” on page 473
- “Saving Data Model Options as Profiles” on page 474
- “Data Model Options: General” on page 474
- “Data Model Options: Filters” on page 475
- “Data Model Options: Auditing” on page 477

Saving Data Model Options as User Preferences

You can save the data model options you specify as default user preferences by clicking the Save as Defaults button on any of the tabs in the Data Model options dialog box.
To change the defaults without affecting any existing data models (including the current one), click **Save as Defaults** and then click **Cancel**.

To change the defaults and apply them to the current data model, click **Save as Defaults** and then click **OK**.

**Note:**
The following data model options apply to the current data model only and cannot be saved as defaults: Topic Priority information and the Use Defined Join Paths option on the General tab.

### Saving Data Model Options as Profiles

When you save data model options as default user preferences and apply them to a data model, you can save the Interactive Reporting document file for use as a **profile**. Over time, you can build a set of **profile** Interactive Reporting document files. By opening a **profile** Interactive Reporting document file and saving the options from the data model of the **profile** Interactive Reporting document file as defaults, users can switch between proven data model options appropriate to the task at hand.

A first time **profile** Interactive Reporting document file, created from a blank data model before saving any changes to the default settings, can be used to restore the data model options to the default settings. A more complete **profile** Interactive Reporting document file, appropriately populated with topics, can be used to promulgate data model options for the Use Defined Join Path feature.

### Data Model Options: General

Use the General tab to select the following design options for the tables and the governors for the data model:

- **Design Options**
  - **Auto Alias Tables**—Enables the product to replace underscores with spaces and display item names in mixed upper/lower case when a table is added to the Content frame from the Table catalog.
  - **Auto Join Tables**—Instructs the product to automatically **join** database tables based on one of three different join strategies as they are added to the Content frame if their names and data types are identical. If Auto Join Tables is not selected, you must manually create joins between topics in the Content frame.
  - **Show Icon Joins**—Shows topic joins when a topic is in icon view (minimized). It is recommended that you activate this feature.
  - **Allow Drill Anywhere**—Activates the **drill anywhere** menu item on the menus within the Pivot and Chart sections. This option enables users to drill to any field.
  - **Allow Drill To Detail**—Activates the **drill to detail** menu item on the menus within the Pivot and Chart sections. This option enables users to query the database again once
they have reached the lowest level of detail; it only works if the Allow Drill Anywhere option is selected.

- **Governors (Interactive Reporting Studio Only)**
  - **Return First _____ Rows**—Specifies a cap on the number of rows retrieved by a query against the data model, regardless of the size of the potential Results set.

  **Note:**

  All users can also set query governors, but data model options automatically override governors set at the query level. If row limits are also set at the query level, the lower number is enforced.

  - **Time Limit _____ Minutes**—Specifies a cap on the total processing time of a query against the data model. Seconds are entered as a decimal number. Available for asynchronous connection API software (for example, Open Client) that support this feature.

**Data Model Options: Filters**

Use the Filters tab to specify filter browse level preferences and to select global filter options.

When you use Show Values to set filters, you may sometimes need to sift through a lot of data to find the particular values you need. Filter preferences enable you to dictate the way existing filters reduce the values available through the Show Values command.

For example, you want to retrieve customer information only from selected cities in Ohio. However, the database table of customer addresses is very large. Because Interactive Reporting applies a default filter preference, once you place the initial filter on State, the Show Values set returned for City is automatically narrowed to those cities located in Ohio. This saves you from returning thousands of customers, states, and from all sales regions.

You can adjust this preference so that the initial filter selection has no effect on the potential values returned for the second filter (all cities are returned regardless of state).

- **Filter Options**
  - **Show Minimum Value Set**—Displays only values that are applicable given all existing filters. This preference takes into account filters on all tables and related through all joins in the data model (which could be potentially a very large and long running query).
  - **Show Values Within Topic**—Displays values applicable given existing filters in the same topic. This preference does not take into account filters associated by joins in the data model.
  - **Show All Values**—Displays all values associated with an item, regardless of any established filters.

  **Tip:**

  When setting these preferences for metatopics, be sure to display the data model in Original view.

- **Global Filter Options** (Designer only)
Show Values—Globally restricts use of the Show Values command in the Limit dialog box, which is used to retrieve values from the server.

Custom Values—Globally restricts use of the Custom Values command in the Limit dialog box, which is used to access a custom values list saved with the Interactive Reporting document file or in a flat file.

Custom SQL—Enables the user to code a limit directly using SQL.

Note:
The Topic Priority dialog box is displayed only if you first select join in the data model.

Note:
Since most data models do not have the same set of topics, you cannot save changes to the topic priority as default user preferences. (For more information on default user preferences, see “Saving Data Model Options as User Preferences” on page 473.)

Data Model Options: Joins
Use the Joins tab to select join usage preferences.

- Use All Joined Topics—Specifies the use of all joined (non-iconized) topics in the data model.
- Use The Minimum Number Of Topics—Specifies the use only of topics represented by items on the Request Line.
- Use All Referenced Topics—Specifies the use only of topics represented by items on the Request or Limit lines. Changing join usage usually changes the number of rows retrieved from the database. It also introduces the possibility that novice users may create improperly joined queries.
- Use Defined Join Paths—Specifies the use of a user predefined join path that groups the joins necessary to query from the data model. Click Configure to create a custom join path.
- Note that since most data models do not have the same predefined join paths, you cannot save the Use Defined Join Paths option as a default user preference. (For more information on default user preferences, see “Saving Data Model Options as User Preferences” on page 473.)
- Use Automatic Join Path Generation—Instructs Interactive Reporting to dynamically generate joins based on the context of user selections on the Request and Limit lines.

Data Model Options: Topic Priority
Use the Topic Priority tab to define the order that tables are included in the Interactive Reporting SQL statement. Defining a topic priority can significantly speed up large queries.

When defining topic priorities, remember that the centralized fact topic in your data model is the largest and receives the most use during a query. By prioritizing this topic first, followed by
the remaining topics in descending order of magnitude, the database server can more efficiently use the internal join logic between tables.

➤ To set topic priorities in a data model:

1. **Choose Data Model > Data Model Options.**
   The Data Model Option dialog boxes appear.

2. **Click the Topic Priority tab to view the Topic Priority tab.**
   Topics in the data model appear listed in the Tables list in the order they were placed in the Content pane.

3. **Rank the topics in the desired order. Click the arrow to move selected topics up or down in the list.**

4. **Click Auto-Order to automatically detect the magnitude of each topic and rank them accordingly in descending order.**

5. **When the topics appear in the desired order, click OK.**

   **Note:**
   Explorer Users: The Topic Priority dialog box appears only if you first click on a join in the data model.

   **Note:**
   Since most data models do not have the same set of topics, you cannot save changes to the topic priority as default user preferences. (For more information on default user preferences, see “Saving Data Model Options as User Preferences” on page 473.)

---

**Data Model Options: Auditing**

Use the Auditing tab to monitor user events within a managed query environment.

By attaching SQL statements to specific Interactive Reporting document file events, an advanced user can record how Interactive Reporting Studio, a database server, and network resources are being used. When triggered, the SQL statements update an audit log table, which the administrator can query independently to track and analyze usage data. For detailed information about auditing, see “Auditing with Interactive Reporting” on page 493.

   **Note:**
   Although you can save the definitions of specific audit events as default user preferences, you cannot save the enabled/disabled state of the audit events as defaults. (For more information on default user preferences, see “Saving Data Model Options as User Preferences” on page 473.)
Automatically Processing Queries

Use the auto-process feature to have a standard query processed automatically when it is downloaded from the repository.

➤ To set Auto-Process:
1 Display a standard query Interactive Reporting document file open in the Content pane.
2 Select Query > Query Options.
   The Query Properties dialog box is displayed.
3 Select the Auto-Process check box, and then click OK.
4 Select File > Save To Repository to upload the Interactive Reporting document to the repository.
   The query automatically processes when a user opens the Interactive Reporting document file from the repository.

Promoting a Query to a Master Data Model

A query may be promoted to a master data model. This essentially separates the data model from the query, enables multiple queries to be based on a single master data model, and creates a new data model-only section in the Interactive Reporting document file. Master data models do not contain Request lines.

The benefit is that any changes to the master data model get propagated to all dependent queries that are based on the master data model. Each time a new query is inserted into a Interactive Reporting document file that contains a master data model, you are prompted to link the new query to the master data model. When a query is promoted to a master data model, it is added to the Section pane as a new section. Once you promote a query to a master data model, you cannot undo it.

➤ To promote a query to a master data model:
1 In the Query section, select or build a data model.
2 Select DataModel > Promote To Master Data Model.
   Data models in Query sections that are linked to the master data model are locked and cannot be changed. They display with a gray background and the message: “Locked Data Model.”

Synchronizing a Data Model

If data models are distributed to company personnel, it is important to keep them updated to reflect system changes. Data models provide visual understanding of the database; if they are corrupted, users can become lost and frustrated.

For example, consider the situation when a database administrator structurally alters a database table by adding columns, modifying data, or renaming a field. If the changes are not registered
to data models, then Dashboard sections, metatopics, or intranet-distributed reports become obsolete.

Advanced users can ensure data model integrity using the Sync With Database command, a one-step integrity check and update. Sync With Database detects inconsistencies with the database, updates the data model, and provides an itemized list of the changes made. The list can be used to update metatopics and report sections quickly and without interrupting workflow.

➤ To synchronize a data model:

1. Open the data model and log on to the database.
2. Select DataModel > Sync With Database.

Interactive Reporting Studio compares original topics with their corresponding database tables. If the structure of the tables has changed, Interactive Reporting Studio modifies data model topics to reflect the changes. The Data Model Synchronization dialog box is displayed, describing changes to the database. Select the Show Detail Information check box for an itemized list.

Tip:

Because metatopics are a separate logical layer constructed from original topics, they are not automatically updated. The Sync With Database feature removes any altered items from metatopics, but preserves the remaining structure so that repairs are minor. Sync With Database works transparently with most other customized attributes of a data model.

### Data Model Menu Command Reference

The following table provides a quick reference to the commands available on the Data Model menu and lists any related shortcuts.

<table>
<thead>
<tr>
<th>Table 141 Data Model Menu Commands</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Command</strong></td>
</tr>
<tr>
<td>Table Catalog</td>
</tr>
<tr>
<td>Data Model View</td>
</tr>
<tr>
<td>Topic View</td>
</tr>
<tr>
<td>Promote to Metatopic</td>
</tr>
<tr>
<td>Add Metatopic</td>
</tr>
<tr>
<td>Add Metatopic Item</td>
</tr>
<tr>
<td>Command</td>
</tr>
<tr>
<td>----------------------------------</td>
</tr>
<tr>
<td>Sync With Database</td>
</tr>
<tr>
<td>Promote To Master Data Model</td>
</tr>
<tr>
<td>Data Model Options</td>
</tr>
</tbody>
</table>
About the Document Repository

The document repository provides an efficient way to manage and distribute data model objects for end-user querying. By storing standardized objects in a document repository located on the database server, advanced uses can provide version-controlled data models for entire workgroups to access as needed.

Note:

The document repository described in this section is a place for a Interactive Reporting Studio user to store and maintain data models and standard reports.

Objects that can be stored in the document repository are:

- **Data model**—A basic data model that is a group of related topics designed as a starting point for building a query. A basic data model opens in the Content frame of the Query section in which a group of joined topics is displayed.

- **Standard query**—A data model with a query already assembled. After the query is downloaded, you simply process the query to retrieve data. Standard queries are ideal for users who use the same data on a regular basis; for example, to get inventory updates that fluctuate from day to day. A standard query opens in the Results section.

  If a standard query has the *auto-process* feature enabled, the query automatically runs when it is downloaded and populates the Results and report sections with data.

- **Standard query with reports**—A standard query that includes preformed reports which enable you to process the query and view the data using customized report sections. A formatted standard query with reports is displayed in the Pivot, Chart, Dashboard, or Report sections.
Administering a Document Repository

Use the Administer Repository dialog box as an access point to create and maintain repositories and the objects stored inside the repositories. You can use this dialog box to inventory the contents of all repositories on a database server, and update the descriptions of the stored contents.

Note:

Repository administration is the province of the Interactive Reporting Studio advanced user. The data model contents of a document repository are available to end users, but only an advanced user can store and manage shared repository objects.

The following sections describe the tasks associated with administering a document repository:

- “Creating Repository Tables” on page 482
- “Confirming Repository Table Creation” on page 483
- “Managing Repository Inventory” on page 484
- “Managing Repository Groups” on page 485

Creating Repository Tables

A repository is a central place in which an aggregation of data is kept and maintained in an organized way. A document repository is a group of specialized database tables used to store different kinds of data models.

A document repository can be located on any database in the network environment, and can even store data models associated with any other database in the environment.

➤ To create repository tables:


2. Choose Select to open the Select Connection dialog box and select the Interactive Reporting database connection file for the database on which you want to create repository table, or select the Interactive Reporting database connection file for the active Interactive Reporting document file.

   The Administer Repository dialog box is displayed.

3. Click Create to open the Create Repository Tables dialog box.

4. Change the default configuration.
   - Owner Name—Enter the database and owner names (if applicable) under which you want to create the tables. If both database and owner are specified, separate them with a period (for example, Sales.GKL).
   - Grant Tables to Public—Check Grant Tables to Public to grant general access to the repository tables at the database level.
You must grant access to the repository tables in order for users to download data models; otherwise, you will need to manually grant access to all authorized users using a database administration tool.

Do not grant tables to public if you need to maintain tight database security and upload privileges are only permitted for a small group of users.

- **Data Type Fields**—Change default data types for column fields to match data types of the database server. If the DBMS and middleware support a large binary data type, use it for VarData columns. If not, use the largest character data type.

5. **Click Create All** to create the repository tables under the specified user. The All Tables Created dialog box is displayed.

**Note:**

If table creation fails, make sure the database logon ID of the server has been granted Table Create privileges.

6. **Click OK, and then click Close** to close the Create All dialog box.

**Confirming Repository Table Creation**

Repository tables are hidden in the Table Catalog by default. To confirm that the repository tables were created (or if you would prefer to display the tables), you can modify the connection preferences of the Interactive Reporting database connection file, and include the repository tables in the Table catalog.

➤ **To include repository tables in the Table catalog:**

1. **Select Tools > Connection > Modify.**
   The Database Connection Wizard is displayed.

2. **Select the Show Advanced Options check box, and then click Next.**

3. **Enter a user name and password to connect to the data source, and then click Next.**

4. **Clear the Exclude Hyperion Repository Tables check box and click Next.**

5. **Click Next through the rest of the wizard dialog boxes, and then click Finish.**

6. **Save** the Interactive Reporting database connection file.

7. **Select DataModel > Table Catalog or press F9** to view the Table catalog including the document repository tables:
   - The following document repository tables should be displayed:
     - BRIOCAT2
     - BRIOGRP2
     - BRIOBRG2
     - BRIOOBJ2
For detailed information on the document repository tables, see “Document Repository Table Definitions” on page 489.

Managing Repository Inventory

Use the Administer Repository dialog box to create and maintain document repositories and the objects stored inside the repositories. You can use this dialog box to inventory the contents of all repositories on a database server and update the descriptions of the stored contents.

➤ To update a repository object description:

1 Select Tools > Administer Repository, and select the Interactive Reporting database connection file associated with the repository object with which you want to work.

   The Administer Repository dialog box is displayed.

2 Click the Inventory tab.

3 Select a model type from the Model Type drop-down box.

   The Model Type drop-down box shows the model type folders that contain the repository objects. Interactive Reporting Studio supports three types of repository objects: Data Model, Standard Query and Standard Query with Reports. When you select a model type, the description for that model type becomes active.

4 Edit the description in the Description frame of the BRIOCAT2 area.

   The BRIOCAT2 area shows the following catalog details for the selected model:
   - Unique Name—Name of the object as it is displayed in the repository.
   - Creator—Name of the person who created the object.
   - Created—Date on which the object was saved to the repository defaults.
   - Version—Version number of the object.

5 Click Update.

   To modify the attributes of a document object itself, download the object, alter the Interactive Reporting document file and upload it to the repository. For more information, see “Modifying Repository Objects” on page 487.

➤ To delete a repository object:

1 Select Tools > Administer Repository, and select the Interactive Reporting database connection file associated with the repository object with which you want to work.

   The Administer Repository dialog box is displayed.

2 On the Inventory tab, select the model type to be deleted from the Model Type drop-down box.

3 Select a repository object from the Model List and click Delete.

   The object is deleted from the repository.
Managing Repository Groups

The repository group feature enables you to classify stored objects by their availability to distinct workgroups that you define. Users can download repository objects provided that they have access privileges in an authorized workgroup.

This feature complements the open repository by adding a security layer which enables you to consolidate objects into a single repository while selectively restricting access to certain objects as needed.

For example, you are the database administrator at a software firm. Ellen needs access to sales and marketing data models to complete a customer survey presentation. Gavin, a product manager, uses these and product management data models to complete his competitive analyses. Jason, a salesperson, needs access only to the standard query with reports for sales.

The solution is to create groups: Product Management, Marketing, and Sales, and give each group access to the objects that they need. Then assign users to appropriate groups: Ellen would have access to both sales and marketing, Jason to sales, and Gavin to all three.

➤ To set up a repository group:

1. Select Tools > Administer Repository, and select the Interactive Reporting database connection file associated with the repository group with which you want to work.

   The Administer Repository dialog box is displayed.

2. Select the Groups Setup tab to display the Groups Setup tab.

3. Enter the group name that you want to add the repository structure in the Groups field and click Add.

   Tip:

   If you enabled Grant Tables To Public when creating the repository, the default group, Public, is in the Groups list.

4. Select the group for which you want to associate a user name or names.

5. Enter the user name(s) in the Users field, and click Add to add the names to the group.

   Add multiple users by delimiting with commas in the edit field, for example: user1, user2, and user3.

6. All users with access to the repository, regardless of other grouping affiliations, have default access to Interactive Reporting document files placed in the Public group.

➤ To remove a user group or user, select the user name in the Users list and click Remove.

Working with Repository Objects

The following section discusses how to create and modify repository objects, and how to use the automatic distributed refresh (ADR), a sophisticated version control feature, to control document versions:
Uploading Interactive Reporting Documents to the Repository

After you have created a document repository, you can upload repository objects (data models, standard queries, and standard queries with reports) for version-controlled distribution to networked Interactive Reporting users.

Note:
When you store objects in the document repository for user access, make the Interactive Reporting database connection file available to users as well.

To upload an object to the repository:

1. With the repository object you want to upload open in the Content frame, select File > Save To Repository and select the Interactive Reporting database connection file to associate with the object. If necessary, click Select to launch the Select Connection File dialog box, navigate to the Interactive Reporting database connection file, and click OK. The Save To Repository dialog box is displayed showing the Model tab.

2. In the Model Type area, select the type of object you are saving to the repository. Select between Data Model, Standard Query, and Standard Query with Reports.

3. In the Model Info area, enter information about the repository object.
   - **Unique Name**—Name of the object that you want to show for the object in the repository
   - **Creator**—Name of the person who created the object. This information is useful in tracing the document source for updates and so on
   - **Created**—Date on which the object was saved to the repository defaults
   - **Locked/Linked Object (Required For ADR)**—Toggles repository object locking. Previously, repository models were locked to maintain versions (see “Controlling Document Versions in Interactive Reporting Studio” on page 489), and could not be modified by the end user. Unlocked data models can be downloaded as usual and the query modified. However, once saved outside the repository, the unlocked model loses its automatic version-control.
   - **Prompt For Sync On Download**—Prompts users with the request: “A newer version of the object exists in the repository, downloading the changes may overwrite changes you have made to the local file. Would you like to make a copy of the current document before proceeding?”
If the user selects Yes, a copy of the locally saved object is made, Automatic Distributed Refresh is disabled for the copy, and the object is synchronized with the newer version of the object.

- **Description**—Enter a description of the repository object and what it can be used for. The maximum character length that you can add is 255 characters.

4 **Select the Groups tab.**

Groups associated with the owned repository are displayed in the Groups list. The PUBLIC group is included by default.

5 **Use the arrow buttons to grant access to repository groups by adding them from the Available Groups list to the Selected Groups List.**

- **Available Groups**—Available user groups from which access can be granted.
- **Selected Groups**—Groups added to the granted access list for the stored object.

**Tip:**
You must move the PUBLIC group to the Selected Groups list if you want to provide general, unrestricted access to the repository object.

6 **Click OK to save the object to the repository.**

7 **Distribute the Interactive Reporting database connection file to end users as needed to access both the object source database, and if necessary, the document repository used to store the object.**

---

**Modifying Repository Objects**

You can make modifications to document objects stored in the repository by downloading, modifying, and uploading them again. You can save the object under a new name, but if the object is not significantly altered, it is best to retain consistency by reloading the document under the same name. This ensures that linked Interactive Reporting document files are automatically updated.

**Caution!**

Modifications made to repository objects propagate throughout the user environment via Automatic Distributed Refresh (ADR), which track objects by unique ID and version number. Each time the object is uploaded to the repository, it is also assigned a new version number. For ADR to work properly, you must upload a modified repository object with the same name as the original.

To modify a repository object:

1 **Select File > Open From Repository > Select.**

The Select Connection dialog box is displayed.
Note:
You can also select the Interactive Reporting database connection file currently in use if there is one. Current Interactive Reporting database conditions are listed below the Select menu item.

2 Select the Interactive Reporting database connection file, and click OK.

3 In the Password dialog box, type your user name and password and click OK.
The Open From Repository dialog box is displayed.

4 Navigate through the repository tree and select the repository object that you want to use
The Open From Repository dialog box displays information about the selected object.
- **Unique Name**—Name of repository object
- **Creator**—Creator of the repository object
- **Created**—Date on which the repository object was created
- **Description**—General description of the repository object, its contents, and the type of information that can be queried

5 Click Open.
The repository object is downloaded to the appropriate section.

6 Make the desired changes to the object, and then select File > Save To Repository.

7 Select the correct Interactive Reporting database connection for the repository object, and enter the user name and password if prompted.
The Save To Repository dialog box is displayed.

8 Select the Model tab and verify the correct document type in the Model Type field.
If the Model type is grayed out, the object has not been modified and it cannot be saved to the repository at this time.

9 Add any object information in the Model Info area and then click OK.
You are asked if you want to enter a unique name for the object. Click No to replace the current object with the object you just modified. Click Yes to save the modified object under a different name. For Automatic Distributed Refresh to work properly, you must save a modified object with the original object name and model type, and save it in the same user-owned repository.

10 If you assigned another name to the object, you are prompted to associate the modified object with a group. Click OK.
The Group tab is displayed automatically so that you can associate the object with a group.

11 Use the arrow buttons to grant access to repository groups by adding them from the Available Groups list to the Selected Groups List.

12 Click OK.
Controlling Document Versions in Interactive Reporting Studio

Automatic Distributed Refresh (ADR) is a sophisticated version control feature that transparently updates Interactive Reporting when the data model or standard query is changed in the document repository. ADR operates completely in the background without any user interaction.

ADR assumes that:

- Each object in the BRIOOBJ table has a unique ID number.
- Each object is assigned an iterative version number each time it is altered and uploaded.

Data model objects are typically downloaded from the document repository into Interactive Reporting document files that are used to analyze data through pivots, charts, and other reports. When a user saves work to an Interactive Reporting document files on disk (either a local hard disk or file server), Interactive Reporting Studio stores both a link to the source object (which was downloaded from the document repository) and the connection information needed to reconnect to the repository.

Document Repository Table Definitions

When the Interactive Reporting document file is reopened, Interactive Reporting Studio reads the link information, connects to the repository, checks to see if the object exists, and checks if it has the same version number stored in the document. If the object in the repository has been modified, it will have a new version number, which indicates that Interactive Reporting Studio should update the old version saved in the Interactive Reporting document. For ADR to work properly, you must save a modified object with the original object name and model type, and save it in the same user-owned repository. Data models and standard queries (with or without reports) are synchronized using ADR.

The document repository tables are detailed in the following sections:

- “BRIOCAT2 Document Repository Table” on page 489
- “BRIOOBJ2 Document Repository Table” on page 490
- “BRIOBREG2 Document Repository Table” on page 490
- “BRIORPG2 Document Repository Table” on page 491

Note:

The following tables, which were created in Interactive Reporting version 6.6 and prior, are no longer used nor will they be referenced by any aspect of Interactive Reporting Studio: BRIOOCE2, BRIODMQ2, BRIOUSR2, BRIOSVR2, and BRIOUNIQ.

BRIOCAT2 Document Repository Table

Table 142 lists the details of the BRIOCAT2 table, which records a description of the repository objects and local documents loaded in the document repository.
Table 142  BRIOCAT2 Table

<table>
<thead>
<tr>
<th>Column</th>
<th>Datatype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNIQUE_ID</td>
<td>NUM</td>
<td>Unique identifier for a stored Repository object.</td>
</tr>
<tr>
<td>OWNER</td>
<td>CHAR</td>
<td>Creator of the object.</td>
</tr>
<tr>
<td>APP_VERSION</td>
<td>CHAR</td>
<td>Version used to upload the object.</td>
</tr>
<tr>
<td>CREATE_DATE</td>
<td>DATE</td>
<td>Most recent date of upload for the object.</td>
</tr>
<tr>
<td>ROW_SIZE</td>
<td>NUM</td>
<td>Number of rows occupied by the stored object in the BRIOOBJ2 table.</td>
</tr>
<tr>
<td>READY</td>
<td>CHAR</td>
<td>Indicates whether previous upload of the stored object was completed successfully.</td>
</tr>
<tr>
<td>FILE_NAME</td>
<td>CHAR</td>
<td>Descriptive name of the stored object.</td>
</tr>
<tr>
<td>FILE_TYPE</td>
<td>CHAR</td>
<td>File type of the stored object, such as data model, locked query, locked report, LAN-based, folder.</td>
</tr>
<tr>
<td>DESCRIPTION</td>
<td>CHAR</td>
<td>Description of the object.</td>
</tr>
<tr>
<td>VERSION</td>
<td>CHAR</td>
<td>Latest version number of the object, used for ADR.</td>
</tr>
<tr>
<td>TOTAL_SIZE</td>
<td>NUM</td>
<td>Total size of the stored object in bytes.</td>
</tr>
</tbody>
</table>

BRIOOBJ2 Document Repository Table

Table 143 lists the details of the BRIOOBJ2 table, which stores the actual objects loaded in the document repository.

Table 143  BRIOOBJ2 Table

<table>
<thead>
<tr>
<th>Column</th>
<th>Datatype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNIQUE_ID</td>
<td>NUM</td>
<td>Unique identifier for a stored repository object.</td>
</tr>
<tr>
<td>ROW_NUM</td>
<td>NUM</td>
<td>Sequence ID for segment of the object.</td>
</tr>
<tr>
<td>VAR_DATA</td>
<td>BLOB or LONG RAW</td>
<td>Data Model object in binary chunk format.</td>
</tr>
</tbody>
</table>

BRIOBRG2 Document Repository Table

Table 144 lists the details of the BRIOBRG2 table, which stores the associations between registered documents and repository groups.

Table 144  BRIOBRG2 Table

<table>
<thead>
<tr>
<th>Column</th>
<th>Datatype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNIQUE_ID</td>
<td>NUM</td>
<td>Unique identifier for a repository document.</td>
</tr>
</tbody>
</table>
### Column Datatype Description

<table>
<thead>
<tr>
<th>Column</th>
<th>Datatype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GROUP_NAME</td>
<td>CHAR</td>
<td>Name of a repository group.</td>
</tr>
</tbody>
</table>

**BRIOGRP2 Document Repository Table**

Table 145 lists the details of the BRIOGRP2 table, which maintains the list of repository groups and their associated users and privileges.

#### Table 145 BRIOGRP2 Table

<table>
<thead>
<tr>
<th>Column</th>
<th>Datatype</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>GROUP_NAME</td>
<td>CHAR</td>
<td>Name of a repository group.</td>
</tr>
<tr>
<td>USER_NAME</td>
<td>CHAR</td>
<td>Name of a document repository user assigned to the group.</td>
</tr>
</tbody>
</table>

**Controlling Document Versions in Interactive Reporting Web Client**

Automatic Document Refresh (ADR) in Interactive Reporting Web Client enables the end-user to merge and synchronize locally saved Interactive Reporting documents (BQY) as soon as they connect to the repository with the latest version of the repository document. This feature is only for documents opened for the first time.

When a locally saved document is opened, a connection dialog for the Interactive Reporting database connection file (.oce) in the repository prompts the user to connect to the repository. The version information in the Interactive Reporting document is compared with the current version information for the document in the repository. If ADR has been enabled for the document, you are prompted to update to the latest version. The user can proceed with the refresh or not. After the document has been refreshed, the refreshed data cannot be undone. If the flag ADR is disabled for the document, document refresh is not available and the locally saved document is opened as is.

The ADR synchronizing procedure is controlled at the system level and at the document level. Interactive Reporting Web Client ADR always refreshes the whole document. All the documents are published and stored in the repository with some ADR control flags enabled or disabled. Unlike in Interactive Reporting Studio, in Interactive Reporting Web Client there is no concept of Model Type.

**ADR Control Flags**

Control flags determine if an Interactive Reporting document is eligible for ADR. These flags include:

- **ADR Global Flag**—This flag controls the availability of the ADR feature. For a new installation of Interactive Reporting, this flag defaults to enabled. For an upgrade
installation, this flag is disabled. You system administration can enable or disable this feature as needed.

- **ADR BQY Metadata**—This flag is enabled or disabled when an Interactive Reporting document is published to the repository. If the flag is enabled, then only this particular document is allowed for ADR. For simple ADR, this flag is always enabled. ADR for job output defaults to a disabled flag when an Interactive Reporting document is published by a job action. In this case, a user can enable this flag by modifying the properties of the Interactive Reporting document. This flag is always disabled for a job output collection.

**ADR Behavior**

The following table shows how ADR behaves with documents in different scenarios.

<table>
<thead>
<tr>
<th>Interactive Reporting document section in Repository version</th>
<th>Interactive Reporting section in local Interactive Reporting document</th>
<th>Action in Merged Interactive document</th>
</tr>
</thead>
<tbody>
<tr>
<td>Section does not exist.</td>
<td>Section does not exist.</td>
<td>No action</td>
</tr>
<tr>
<td>Section does not exist.</td>
<td>Section exists.</td>
<td>Add from local document.</td>
</tr>
<tr>
<td>Section exists.</td>
<td>Section does not exist.</td>
<td>Add from Repository document.</td>
</tr>
<tr>
<td>Section exists.</td>
<td>Section exists.</td>
<td>Write Repository version.</td>
</tr>
</tbody>
</table>
About Auditing

Auditing enables information to be collected about data models downloaded from the repository. You can use auditing features to track how long queries take to process, which tables and columns are used most often, and even record the full SQL statement that is sent to the database.

Audit information can help the database administrator monitor not only the effectiveness of each distributed data model, but also the weaknesses and stress points within a database. The results are useful for performing impact analysis to better plan changes to the database.

Auditing requires minimal additional setup and can be implemented entirely within the studio version of Interactive Reporting. The steps required for auditing data models are:

● Create a document repository with an inventory of distributed data models.

● Create a database table in which to log audit events.

● Use data model options to define events that you want to audit for each data model.

● Save the audited data models to the document repository.

● Use Interactive Reporting to query the audit table and to analyze the data it contains.

Special Considerations

● The Audit log may fill up. Monitor it regularly and delete any entries that are no longer used.

● Before uploading your audited data model to the document repository, log in as a user and test each auditing event to verify that your SQL statements are not generating any errors.

● Auditing is not supported for the Process Results To Database Table feature, nor for data models. However, scheduled Interactive Reporting documents containing linked data models are audited normally.
Creating an Audit Table

Before you enable auditing of data models, you need to identify the events that you want to track and create a database table to record the information.

Use an SQL editor to create an audit table. Since the query accesses only one database, the audit table needs to reside where the query is processed. Create columns that reflect the types of information that you want to record.

Table 147 provides a sample structure for the table named BQAUDIT. You can customize your audit table and columns to store information related to any events that you can define.

### Table 147  Sample Structure for the BQAUDIT Table

<table>
<thead>
<tr>
<th>Column</th>
<th>Data Source</th>
<th>Explanation/Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>EVENT_TYPE</td>
<td>Text</td>
<td>Events which occur within the context of a query session, such as:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>‘Logon’</td>
</tr>
<tr>
<td></td>
<td></td>
<td>‘Logoff’</td>
</tr>
<tr>
<td></td>
<td></td>
<td>‘Post Process’</td>
</tr>
<tr>
<td>USERNAME</td>
<td>SQL function</td>
<td>Database user information returned by a database SQL function, such as:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>user (Oracle)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>user_name (Sybase)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>CURRENT_USER (Red Brick)</td>
</tr>
<tr>
<td>DAY_EXECUTED</td>
<td>SQL function</td>
<td>Date, time, and duration information returned by a database SQL function, such as:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>sysdate (Oracle)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>getdate (Sybase)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>CURRENT_TIMESTAMP (Red Brick)</td>
</tr>
<tr>
<td>SQL_STMT</td>
<td>Interactive Reporting keyword</td>
<td>SQL statements generated by the user and captured from the Interactive Reporting SQL log, and returned by the keyword variable :QUERYSQL</td>
</tr>
<tr>
<td>DATAMODEL</td>
<td>Interactive Reporting keyword</td>
<td>Data models accessed by the user and returned by the keyword variable :REPOSITORYNAME</td>
</tr>
<tr>
<td>NUM_ROWS</td>
<td>Interactive Reporting keyword</td>
<td>Query information returned by the keyword variable :ROWSRETRIEVED</td>
</tr>
</tbody>
</table>

Defining Audit Events

After you create the audit table on the database, define the events that track each data model.
Note:

To log audit data, provide Interactive Reporting users the database authority to execute each SQL statement you define for auditing events. For example, all users must have insert or update authority to the Audit table that you create.

To define audit events:

1. **Download an existing data model that you want to track from the document repository, or create a new data model in the Content frame using the Table catalog.**
   
   For more information about creating a new data model, see “Building a Data Model” on page 458.

2. **In the Query section, select DataModel > Data Model Options.**
   
   The Data Model Options dialog box is displayed.

3. **Select the Auditing tab to display the Auditing tab.**
   
   The Auditing tab displays the events you can audit.

4. **Click Define to define the way in which an event is audited.**
   
   The SQL For Event dialog box is displayed.

5. **Enter one or more SQL statements to update the audit table when the event occurs, and click OK.**
   
   A check mark is displayed next to the event on the Auditing tab in the Data Model Options dialog box. You can use the check box to enable or disable the event definition without entering the SQL statement again. You can also click Define again at any time to modify the SQL statement.

6. **Select File > Save to Repository to save the audited data model to the document repository.**
   
   The SQL statement is sent to the database whenever a user triggers the event while using the data model.

**Auditing Keyword Variables**

Interactive Reporting Studio provides keyword variables (see Table 148) that can be used to help define audit events. The keywords can be inserted into audit event SQL statements to return specific data each time the event is triggered.

**Tip:**

When entering an auditing keyword variable, always precede it with a colon (:) and enter all keyword text in uppercase. Other items in the SQL statement may also be case sensitive, depending on your database software.
Table 148  Auditing Keyword

<table>
<thead>
<tr>
<th>Keyword Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>:ROWSRETRIEVED</td>
<td>Number of rows retrieved by the most recently executed query.</td>
</tr>
<tr>
<td>:REPOSITORYNAME</td>
<td>Name of the repository object in use (data model or standard query with reports).</td>
</tr>
<tr>
<td>:QUERYSQL</td>
<td>(Pre Process, Limit: Show Values, and Detail View only) Complete SQL text of the most recently executed query statement. <strong>Tip:</strong> Consider the maximum column length when using :QUERYSQL. You may want to use a substring function to limit the length of the SQL being logged. For example: <code>SUBSTR (:QUERYSQL, 200)</code></td>
</tr>
<tr>
<td>:SILENT</td>
<td>Restricts display of the audit-generated SQL statement within the user's SQL Log. When the :SILENT keyword variable is included in the audit statement, the SQL Log output reads “Silent SQL sent to server...” instead of the SQL statement. This keyword variable provides a security feature when the triggered SQL statement is sensitive or should remain undetected.</td>
</tr>
</tbody>
</table>

Sample Audit Events

Table 149 provides examples of audit events. Most examples include ORACLE SQL database functions.

Table 149  Sample Audit Events

<table>
<thead>
<tr>
<th>Audit Event</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Logon</td>
<td>Executed each time a successful logon occurs.</td>
</tr>
<tr>
<td></td>
<td><code>insert into &lt;owner&gt;.bqaudit (username, day_executed, event_type) values (user, sysdate, 'Logon')</code></td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> The logon audit event fires for each action when used with the Data Access Service. Because of connection pooling, it is not possible, at the Data Model level, to determine when an actual logon event is required.</td>
</tr>
<tr>
<td>Logoff</td>
<td>Executed each time a successful logoff occurs.</td>
</tr>
<tr>
<td></td>
<td><code>insert into &lt;owner&gt;.bqaudit (username, day_executed, event_type) values (user, sysdate, 'Logoff')</code></td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> The logoff audit events fires for each action when used with the Data Access Service. A logoff event does not happen until the connection reaches the configured idle time.</td>
</tr>
<tr>
<td>Pre Process</td>
<td>Executed after Process is selected, but before the query is processed. It is useful to track the date and time of both Pre Process and Post Process in order to determine how long a query takes to process.</td>
</tr>
<tr>
<td></td>
<td><code>insert into &lt;owner&gt;.bqaudit (username, day_executed, event_type) values (user, sysdate, 'Pre Process')</code></td>
</tr>
<tr>
<td>Post Process</td>
<td>Executed after the final row in the result set is retrieved at the user's workstation. It is useful to track the date and time of both Pre Process and Post Process in order to determine how long a query takes to process.</td>
</tr>
<tr>
<td></td>
<td><code>insert into &lt;owner&gt;.bqaudit (username, day_executed, event_type, num_rows, sql_stmt) values (user, sysdate, 'Post Process', :ROWSRETRIEVED, SUBSTR (:QUERYSQL, 1, 200))</code></td>
</tr>
<tr>
<td>Audit Event</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>----------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Limit: Show Values</strong></td>
<td>Executed after selecting the Show Values button when setting a Limit.</td>
</tr>
<tr>
<td></td>
<td><code>insert into &lt;owner&gt;.bqaudit (username, day_executed, event_type, datamodel, sql_stmt) values (user, sysdate, 'Show Values', :REPOSITORYNAME, :QUERYSQL)</code></td>
</tr>
<tr>
<td><strong>Detail View</strong></td>
<td>This statement is executed when a user toggles a topic to Detail View and a sampling of data from the database is loaded. Remember that values are only loaded when you first toggle to Detail View, or when Cause Reload is selected in the Topic Properties dialog box.</td>
</tr>
<tr>
<td><strong>New Data Model</strong></td>
<td>This statement is executed when the Data Model is downloaded from the document repository into a Interactive Reporting document.</td>
</tr>
<tr>
<td></td>
<td><code>insert into &lt;owner&gt;.bqaudit (username, day_executed, event_type, datamodel) values (user, sysdate, 'New Data Model', :REPOSITORYNAME)</code></td>
</tr>
<tr>
<td><strong>Data Model Refresh</strong></td>
<td>This statement is executed after a Data Model is refreshed through ADR.</td>
</tr>
<tr>
<td></td>
<td><code>insert into &lt;owner&gt;.bqaudit (username, day_executed, event_type, datamodel) values (user, sysdate, 'Data Model Refresh', :REPOSITORYNAME)</code></td>
</tr>
</tbody>
</table>
About the IBM Information Catalog

IBM’s Visual Warehouse (VW) is a family of products that design, load, manage, and retrieve information from data warehouses. Interactive Reporting Studio is a component for the IBM VW solution, and is resold by IBM as part of VW bundles. To further extend the capabilities of the solution, register, administer, and distribute Interactive Reporting documents (BQY file extension) in the VW Information Catalog. The Information Catalog is a repository of document information with pointers to the physical objects.

Another feature of the Catalog is that it enables you to categorize content stored in documents by specific subject area. A full-search engine in the repository enables you to search for information stored in the documents. For example, you could search on all documents associated with “sales.” In this case, the search results could yield Word files, Excel files, and Interactive Reporting documents. When you find a document that you want to work with, the IBM Information Catalog launches the appropriate application and opens the document.

Registering Documents to the IBM Information Catalog

This section explains how to register documents to the Catalog. It includes the following sections:

- “Defining Properties” on page 500
- “Selecting Subject Areas” on page 500

Visual Warehouse must already be installed before you can register or administer this feature. Also, the client document object types must already exist before completing the following steps. For more information see “Creating Object Type Properties” on page 501.

To register an Interactive Reporting documents:

1. Display the repository object that you want to upload open in the Content pan.
2. Select File > Register To IBM Information Catalog.
The Save File dialog box is displayed.

3 **Type the name of Interactive Reporting document in the File Name field.**

4 **In the Save As Type field, leave the default .bpy file type and click Save.**

   The Connect To Information Catalog Repository dialog box is displayed.

5 **Type your user identification in the User field.**

6 **Type your password in the Password field.**

7 **Type the ODBC data source name in the Database Alias field if it is different than the default database alias value.**

   The Register To Information Catalog dialog box is displayed, showing the Properties and Subject Area tabs. Use these corresponding pages to describe the properties and subject matter of the Interactive Reporting document.

8 **Click the Properties tab to display the Properties tab.**

9 **In the Available Properties list, select a property of the Interactive Reporting document to which you want to add a value.**

10 **In the Enter Value for Selected Property edit box, type a value for the property.**

11 **Repeat Step 8 through Step 9 for all properties.**

12 **Click the Subject Areas tab.**

13 **In the Specify The Subject Area list, use the plus (+) and minus (–) signs to navigate through the Subject area structure (Grouping Category) and select the subject area folder to which you want to add the Interactive Reporting document.**

   The Subject Area displays a tree view of eligible subject area folders in which you can add the Interactive Reporting document.

14 **Click Add to add the Interactive Reporting document or instance to the Subject Area specified in Step 12.**

15 **Click OK.**

**Defining Properties**

You can define the values of selected properties for a document when registering to the catalog. Use the Properties tab to show and edit properties, data types, and lengths:

- **Available Properties**—Displays a list of available properties that you can specify.

- **Enter Value**—Edit any available value by typing the information in this edit box. For a description of eligible values for the properties, see the Description field.

**Selecting Subject Areas**

Use the Subject Area tab to display and select a subject area for the document that you are registering. By including the document in a Subject Area folder, you can later search for the document by topic.
Specify The Subject Area—Displays a tree view of eligible subject area folders in which you can add the document. Use the plus (+) and minus (–) signs to navigate through the folders. To add a document to folder, select the subject area folder and click Add.

Subject Areas Containing—Displays the subject area folder to which the document has been added.

Administering the IBM Information Catalog

This section explains how to administer the IBM information catalog, including:

- “Creating Object Type Properties” on page 501
- “Deleting Object Types and Properties” on page 502
- “Administering Documents” on page 502
- “Setting Up Object Types” on page 503

Creating Object Type Properties

Use the Setup Objects Types under Administer IBM Information Catalog to create an object type and specify its properties. An object type shows a category of business information, for example, a Interactive Reporting document or an image. An object type property describes an attribute of the object type, for example, its name or data type.

Once an object type has been created, you cannot modify its existing properties or add new properties. You can, however, delete the entire object type, but not the individual properties of a selected object type.

To set up the BQY object type and properties:

1. Choose File > Administer IBM Information Catalog.
   The Connect To Information Catalog Repository dialog box is displayed.
2. Type your user identification in the User field.
3. Type your password in the Password field.
4. Type the ODBC data source name in the Database Alias field if it is different than the default database alias value.
5. Click OK.
   The Administer Information Catalog dialog box is displayed.
6. Click the Setup Object Types tab.
7. In the Object Type drop-down box select Interactive Reporting document.
8. In the Name field, type the name of the property that you want to associate with the object type.
9. In the Short Name field, type an abbreviated version of the property name.
10 In the Datatype list, select the data type classification of the property (for example, character-based) from the drop-down list box.

11 In the Length field, type the maximum length character of the property.

12 To require that the property be completed when a user registers a document, click the Entry Required check box.

13 To add the object type property to the Properties for Object Type list box, click Set.

14 Repeat Step 8 through Step 12 for each property that you want to associate with the selected object type.

15 To create the object type, click Create Object Type.

Deleting Object Types and Properties

You can delete the entire object type, but not the individual properties of a selected object type once an object type has been created.

➤ To delete an BQY object type and properties:

1 Choose File > Administer IBM Information Catalog.

The Connect To Information Catalog Repository dialog box is displayed.

2 Type your user identification in the User field.

3 Type your password in the Password field.

4 Type the ODBC data source name in the Database Alias field if it is different than the default database alias value.

5 Click OK.

The Administer Information Catalog dialog box is displayed.

6 Click the Setup Object Types tab.

7 In the Object Type drop-down list box, select Interactive Reporting document.

8 Click Delete Object Type.

Administering Documents

Use the Administer Documents tab to search for a specific document based on an object type, property, and other selected criteria (see Table 150). After the document has been located, you can either delete or edit the associated properties.

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object Type</td>
<td>Interactive Reporting document object type.</td>
</tr>
<tr>
<td>Select Property</td>
<td>Property by which you want to search on the document from the pull-down list. Complete the search condition by selecting a value in the Search Criterion field below. For example,</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Object Type</td>
<td>Interactive Reporting document object types.</td>
</tr>
<tr>
<td>Name</td>
<td>Name of the property that you want to associate with the object type.</td>
</tr>
<tr>
<td>Short Name</td>
<td>Short name of the property that you want to associate with the object type.</td>
</tr>
</tbody>
</table>

**Setting Up Object Types**

Use the Set Up Object Types tab to set up object types and their properties (see Table 151). An object type shows a category of business information, for example, a document or an image. An object type property describes an attribute of the object type, for example, its name or data type.

**Note:**

You can create and delete only the Interactive Reporting document object types and properties through the Interactive Reporting Setup Object Types features. For more information, see “Creating Object Type Properties” on page 501.

**Table 151  Object Types and Properties**

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Object Type</td>
<td>Interactive Reporting document object types.</td>
</tr>
<tr>
<td>Name</td>
<td>Name of the property that you want to associate with the object type.</td>
</tr>
<tr>
<td>Short Name</td>
<td>Short name of the property that you want to associate with the object type.</td>
</tr>
<tr>
<td>Field</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Datatype</td>
<td>Data type of the property.</td>
</tr>
<tr>
<td>Length</td>
<td>Length of the property.</td>
</tr>
<tr>
<td>Entry Required</td>
<td>Requires a user to select a property when registering a document to the DataGuide repository.</td>
</tr>
<tr>
<td>Set</td>
<td>Adds a new object type property to the Properties for Object Type list. If an object type has already been created, this button is unavailable.</td>
</tr>
<tr>
<td>Remove</td>
<td>Removes a new object type property from the Properties For Object Type list. If an object type has already been created, this button is unavailable. Once an object type has been created, you cannot remove its properties; the entire object type must be deleted.</td>
</tr>
<tr>
<td>Properties For Object Type</td>
<td>Properties defined for the object type. To show the entire definition for a property, click a property in the list.</td>
</tr>
<tr>
<td>Create Object Type</td>
<td>Creates an Interactive Reporting document (BQY) object type. Once an object type has been created, you cannot modify its existing properties or add new properties.</td>
</tr>
<tr>
<td>Delete Object Type</td>
<td>Deletes an Interactive Reporting document (BQY) object type. You cannot delete the individual properties of a selected object type.</td>
</tr>
<tr>
<td>Clear</td>
<td>Clears the definition fields of a property.</td>
</tr>
</tbody>
</table>
About Row-Level Security

Properly implemented, row-level security gives individuals in an organization access to only the information they need to make informed decisions. For example, managers need payroll information on their direct reports. Managers do not need to know payroll information for other departments within the organization. Row-level security allows this level of granularity.

The Row-Level Security Paradigm

Most database administrators understand the concept of row-level security. Returning to the payroll data example, all detailed compensation data on the employees of an organization is stored in the same table(s) within the database. Typically, some column within this table can be used as a limit, either directly or by a join to another table with its own set of limits, to restrict access to the data within the table based on the identification of the user accessing the data. Following the payroll example, an employee ID often identifies the sensitive compensation data. A join to a separate employee information table, which contains non-compensation related information such as home address and title, would include a department number. A manager would be limited to details on the employees for her/his particular department.

Row-level security, implemented at the database level, is often done by means of a view. To an application, accessing a view is no different than accessing a table. However, the view is instantiated based on the appropriate limits. Coupled with the GRANT and corresponding REVOKE data definition statements available with the prevalent Relational Database Management Systems (RDBMS), the base tables can be made inaccessible to most users, and the views on that data, filtered based on user identification, made accessible instead. Multiple views may sometimes be required to fully implement a security scheme, depending on how the tables are defined and how the information contained therein must be shared. For instance, a different view for managers versus those in human resources might be required.
Column level security, a companion concept to row-level security, can be similarly enforced. Views can easily hide a piece of information. For example, in the payroll example, the salary column can be left out of the view, but other types of information about an employee can still be accessible to those who need it. This type of security can impart a special problem for standardized reports, available throughout the organization but for audiences with different access permissions. The reporting software might have difficulty dealing with the missing information, consequently requiring different implementations of these otherwise similar reports.

**Reporting and Analysis and Row-Level Security**

The Reporting and Analysis approach to data security is server based. Both the Interactive Reporting Web Client and Workspace are designed to fully implement a secure data access platform. The non-server based clients do not participate in this security mechanism. Users of Interactive Reporting Studio need access beyond that of most users to effectively create the dashboards, and analytic reports required by the majority of the data consumers. In addition, the security information can be placed in a centralized location for the servers (the repository). For the desktop clients, it would in some cases need to be dispersed to multiple databases and maintained separately.

To effectively control access, the servers key off the user’s identification when connecting to it. This is the user’s logon name, used to establish a session with the Reporting and Analysis services.

Beyond this user name, the servers make no assumptions about the user’s place within the organization. A security system can be built entirely independent of any existing grouping of users. New groupings can be defined in lieu of existing ones. This is especially important where groups were not defined with data security as a primary goal. Row-level security can also take full advantage of the existing structures where data security was built into the user and group structure. In many cases, row-level security will work within existing database role definitions and third-party software security systems.

**Column Level Security**

Interactive Reporting servers can easily handle the challenge of column level security. Such hidden information is replaced with an administrator-supplied value (possibly NULL, zero, blanks, or a similar placeholder value), and thus it will not cause existing reports to fail when encountering this type of a security constraint.

**Performance Issues**

The system is designed to not impose any significant performance penalty. The security information is collected at the time the user opens an Interactive Reporting document from the server’s repository, and only then if the server knows the security controls are enabled. When a user opens a locally saved Interactive Reporting document from a previous session with the Reporting and Analysis services, the security information is recollected when reconnecting to the server in case it has changed.
Publishing in a Secure Environment

A powerful feature of Interactive Reporting is the ability to take data “on the road.” Once data has been extracted from the database, which is where the row-level security restrictions are enforced, that data can be saved with the Interactive Reporting document for offline analysis and reporting. Users who publish should be aware of the implications of their audience when publishing data and reports.

If the publication of the data is difficult to control in the current configuration of users and groups known to the server, consider the following options:

- Publish without the detailed results of the queries, leaving only the summary charts and Pivots for the “general” audience. If they need to drill into the summary data, they will need to rerun the queries, at which time their particular security restrictions will be applied. (Even some charts and Pivots can reveal too much, so there is still a need for prudence when publishing these Interactive Reporting documents).

- Create the Interactive Reporting documents with OnStartup scripts to reprocess queries as the Interactive Reporting document is opened. This option provides the user only the data to which they are entitled.

All users should take similar precautions when sharing information generated from Interactive Reporting. This includes exchanging the Interactive Reporting documents (.bqy extensions) themselves by e-mail or shared network directories, exporting the data as HTML files and publishing them to a web site, posting the data on FTP servers as the result of a job action, and creating PDF files from the reports.

Securing the Security Information

The row-level security feature is implemented by means of database tables. The servers read this data and never update it. Hyperion Solutions recommends these tables actually be defined somewhere other than the repository schema, and that read-only access be granted to only the select few that should be able to update the security information.

As additional protection, the actual tables can be hidden via a view, and a WHERE clause can be added to each view definition so that only the server’s user identification, by which it connects to the database to read the row-level security tables, can read the content, if the database supports it. Table 152 shows examples of Where clauses if the repository connection is made as user brioserver.

<table>
<thead>
<tr>
<th>Database</th>
<th>Sample Where Clause on CREATE VIEW</th>
</tr>
</thead>
<tbody>
<tr>
<td>DB2</td>
<td>WHERE USER = ‘BRIOSERVER’</td>
</tr>
<tr>
<td>Oracle</td>
<td>WHERE USER = ‘BRIOSERVER’</td>
</tr>
<tr>
<td>SQL Server</td>
<td>WHERE USER = ‘brioserver’</td>
</tr>
</tbody>
</table>

Table 152  Repository Connection Made as brioserver
Note:
Be aware of case sensitivity with the user name and allow that, for SQL Server, the user might be ‘dbo’.

Each view has the same name as its underlying table, and all available columns from that table would be selected.

Row-Level Security Tables

Three tables implement the row-level security features for Interactive Reporting Web Client and Workspace. Because the tables can be populated in a manner appropriate to the site’s requirements, no predefined user interface to maintain the tables is provided as part of the Interactive Reporting product. However, the row_level_security.bgy can be modified to suit an ad hoc implementation of the row-level security feature, and as a tutorial or test tool when setting up a production system. The only requirement is that the basic set of column definitions be retained. The sample Interactive Reporting document can be used in all cases as a reporting tool for the row-level security data as the servers see it.

Implementing a secure data access environment using row-level security requires an understanding of SQL. First, knowing how the database relationships are defined is critical. Second, specifying the restrictions is directly translated into the SQL ultimately processed at the database.

Creating the Row-Level Security Tables

When the Interactive Reporting components are installed using the custom option, the installer prompts for whether or not to create the row-level security tables and in what database.

If the Interactive Reporting components are installed using the express option, or it is elected not to create the row-level security tables during a custom install, then the tables must be created manually. The Interactive Reporting document mentioned above can create the tables, the necessary SQL DDL can be created based on the table definitions found in this documentation, or the script that creates them during the install can be run. To locate these scripts, look on the install CD under the DATA directory, and then under the appropriate database brand or vendor. The script of interest is named CreateRLS.sql.

When creating the tables post-install, use the web-based Administration module to tell the system where the tables are located. The information required includes the data source name, the database type, the API used to access the database, and the database credentials needed to access the row-level security tables.

There is also a setting to enable or disable the row-level security feature. This setting is intended to enhance performance in systems where the feature is not needed. When disabled, no attempt is made to access these tables. The feature should always be enabled if data security is to be enforced.
The BRIOSECG Table

The BRIOSECG table defines the users and groups that are subject to row-level security restrictions. There are two columns, BUSER and BGROUP, both of varying character length (VARCHAR(n)). The maximum length is not fixed by the server; set it to a practical value.

A user name is defined as the server authentication name (ODSUsername is the property of the ActiveDocument object in the Interactive Reporting Object Model). For jobs, it is the user who scheduled the job.

Group names are arbitrary. The data security administrator is free to define these as required. When both columns of a row are populated with non-null values, the user name defined in the BUSER column is a member of the group name defined in BGROUP.

As maintained by the sample Interactive Reporting document row_level_security.bqy, when a user is added, a row is added to the table with a NULL value in the BGROUP column. When a group is added, a NULL value is stored in the BUSER column. This is a device used by the Interactive Reporting documents to maintain the table and is recommended practice, but it is not a requirement for correct operation of row-level security.

This table is theoretically optional. Without it, however, all users exist as single individuals; they cannot be grouped to apply a single set of restrictions to all members. For example, Vidhya and Chi are members of the PAYROLL group. If this relationship is not defined in BRIOSECG, then any restrictions that apply to Vidhya that should also apply to Chi have to be defined twice. By defining the PAYROLL group and its members, Vidhya and Chi, the restrictions can be defined only once and applied to PAYROLL group.

A group name cannot be used in BUSER; that is, groups cannot be members of other groups. Users, of course, can be members of multiple groups, and this can effectively set up a group/subgroup hierarchy. For example, a PAYROLL group might contain users Sally, Michael, Kathy, David, Bill, Paul, and Dan. Sally, Dan, and Michael are managers, and so they can be made members of a PAYROLL MANAGER group. Certain restrictions on the PAYROLL group can be overridden by the PAYROLL MANAGER group, and Dan, to whom Sally and Michael report, can have specific overrides to those restrictions placed explicitly on the PAYROLL MANAGER group.

Where the database supports it, and if the user’s authentication name in Reporting and Analysis corresponds, this table can be a view created from the roles this user has in the database. For example, in Oracle:

```sql
CREATE VIEW BRIOSECG (BGROUP, BUSER) AS
    SELECT GRANTED_ROLE, GRANTEE FROM DBA_ROLE_PRIVS
```

DBA_ROLE_PRIVS is a restricted table. Since the server reads the view using a configured database logon, it would not be appropriate to use USER_ROLE_PRIVS instead of DBA_ROLE_PRIVS, because that user view will reflect only the server’s roles, not the user on whose behalf the server is operating. Again, this is an Oracle example; other RDBMS may or may not provide a similar mechanism. In some cases, depending on the database, a stored procedure could collect the role information for the users and populate a BRIOSECG table if a simple SELECT is inadequate to collect the information. This would require some means to invoke the procedure each time role definitions were changed.
When using the database’s catalog or some other means to populate BRIOSECG, the sample Interactive Reporting document, row_level_security.bqy, cannot be used to maintain user and group information.

A special group, PUBLIC, exists. It does not need to be explicitly defined in BRIOSECG. All users are members of the PUBLIC group. Any data access restriction defined against the PUBLIC group applies to every user unless explicitly overridden, as described later.

All users can be made part of a group at once by inserting a row where BUSER is ‘PUBLIC’ and BGROUP is that group name. While this may seem redundant, given the existence of the PUBLIC group, it offers some benefits:

- It allows the database catalog technique described above to work. For example, in Oracle, a role can be granted to PUBLIC.
- It allows restrictions for a group other than PUBLIC to quickly be applied to or removed from everyone in an instant.
- It provides more flexibility when using override specifications as described later.

**Note:**

Restrictions are never applied against a user named PUBLIC, but only the group PUBLIC. For this reason, do not use PUBLIC as a user name. Similarly, to avoid problems, do not name a group the same as a user name.

### The BRIOSECP Table

The BRIOSECP (‘P’ for parameter) has one column, named BCONJUNC with a data type of CHAR(3). Its value is either the word AND or the word OR, and the Interactive Reporting document file that administers the RLS creates and populates the table.

### The BRIOSECR Table

The BRIOSECR table is the heart of the row-level security feature. It defines the specific restrictions to be applied to users and the groups (including PUBLIC) to which they belong. These restrictions take the form of join operations (a user cannot access a column in the employee salary table unless it is joined to the employee table), and limits (WHERE clause expressions) to be applied to either the source table (SALARY) or table(s) (EMPLOYEE) to which it is joined. 

Table 153 lists the columns in the BRIOSECR table.

As suggested earlier, existing security definitions can sometimes be translated into the format described here. A view, stored procedure, or programmatic mechanism can be used to translate and/or populate the information needed in BRIOSECR by the Reporting and Analysis servers. When these methods are used, the servers require the column names and data types defined above. And again, do not attempt to use the sample Interactive Reporting document, row_level_security.bqy, to manage this information.

If a join table is specified and it does not already exist in the data model the user accesses, it will still be added to the final SQL generated to ensure the security restrictions are enforced. This
The process is iterative. When a table is added and the present user, either directly or by group membership, has restricted access to that added table, those restrictions will also be applied, which may mean additional tables will be added, and those restrictions will also be checked, and so on. Circular references will result in an error if they are defined.

<table>
<thead>
<tr>
<th>Column Name</th>
<th>Column Type</th>
<th>Functional Use</th>
</tr>
</thead>
<tbody>
<tr>
<td>UNIQUE_ID</td>
<td>INT</td>
<td>This column contains an arbitrary numeric value. It should be unique, and it is useful for maintaining the table by whatever means the customer chooses. The servers do not rely upon this column, and the servers never access this column. To that extent, it is an optional column but recommended. (It is required when using the sample Interactive Reporting document, row_level_security.bql.) When the RDBMS supports it, a unique constraint or unique index should be applied to the table on this column.</td>
</tr>
<tr>
<td>USER_GRP</td>
<td>VARCHAR</td>
<td>The name of the user or the name of a group to which a user belongs. If PUBLIC, the restrictions are applied to all users.</td>
</tr>
<tr>
<td>SRCDB</td>
<td>VARCHAR, can be null</td>
<td>Used to identify a topic in the Data Model. (In Interactive Reporting, a topic typically corresponds to a table in the database, but it could be a view in the database.) If the physical name property of the topic is of the form name1.name2.name3, this represents name1. Most often, this represents the database in which the topic exists. This field is optional unless required by the connection in use. The most likely circumstance in which to encounter this requirement will be with Sybase or Microsoft SQL Servers where the Interactive Reporting database connection file (the connection definition file) is set for access to multiple databases.</td>
</tr>
<tr>
<td>SRCOWNER</td>
<td>VARCHAR, can be null</td>
<td>Used to identify the owner/schema of the topic in the Data Model. This would be name2 in the three-part naming scheme shown above. If the topic property, physical name contains an owner, then it must be used here as well.</td>
</tr>
<tr>
<td>SRCTBL</td>
<td>VARCHAR</td>
<td>Used to identify the table/relation identified by the topic in the Data Model. This is name3 in the three-part naming scheme.</td>
</tr>
<tr>
<td>SRCCOL</td>
<td>VARCHAR</td>
<td>Used to identify a column in SRCTBL. This is a topic item in Data Model terminology, and is an item that might appear on the Request line in a query built from the Data Model. In the context of the security implementation, the item named here is the object of the restrictions being defined by this row of the security table BRIOSER. If this column contains an *, all columns in SRCTBL are restricted.</td>
</tr>
<tr>
<td>JOINDB</td>
<td>VARCHAR, can be null</td>
<td>If present, defines the database name qualifier of a table/relation that must be joined to SRCTBL.</td>
</tr>
<tr>
<td>JOINOWNR</td>
<td>VARCHAR, can be null</td>
<td>If present, defines the schema/owner name qualifier of a table/relation that must be joined to SRCTBL.</td>
</tr>
<tr>
<td>JOINTBL</td>
<td>VARCHAR, can be null</td>
<td>If present, names the table/relation that must be joined to SRCTBL.</td>
</tr>
<tr>
<td>JOINCOLS</td>
<td>VARCHAR, can be null</td>
<td>If present, names the column name from SRCTBL to be joined to a column from JOINTBL.</td>
</tr>
<tr>
<td>JOINCOLJ</td>
<td>VARCHAR, can be null</td>
<td>If present, names the column name in JOINTBL that will be joined (always an equal join) to the column named in JOINCOLS.</td>
</tr>
<tr>
<td>CONSTRTT</td>
<td>CHAR(1), can be null</td>
<td>If present, identifies a table/relation to be used for applying a constraint (limit). This is a coded value. If the value in this column is S, the column to be limited is in SRCTBL. If J, a column in JOINTBL is to be limited. If the value in this column is O, it indicates that for the current user/group, the restriction on the source column for the group/user named in column OVERRIDE is lifted, rendering it ineffective. If this value is NULL, then no additional restriction is defined.</td>
</tr>
<tr>
<td>Column Name</td>
<td>Column Type</td>
<td>Functional Use</td>
</tr>
<tr>
<td>-------------</td>
<td>-------------</td>
<td>----------------</td>
</tr>
<tr>
<td>the JOIN* columns are also all NULL, the column is not accessible at all to the user/group. This implements column level security. See the functional use description of CONSTRTV for more information on column level security.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>CONSTRTC</td>
<td>VARCHAR, can be null</td>
<td>The column in the table/relation identified by CONSTRTT to which a limit is applied.</td>
</tr>
<tr>
<td>CONSTRTO</td>
<td>VARCHAR, can be null</td>
<td>The constraint operator, such as =, &lt;&gt; (not equal), etc. BETWEEN and IN are valid operators. Basically, any valid operator for the database can be supplied.</td>
</tr>
<tr>
<td>CONSTRTV</td>
<td>VARCHAR, can be null</td>
<td>The value(s) to be used as a limit. The value(s) properly form a condition that together with the content of CONSTRCT and CONSTRTO columns create valid SQL syntax for a “condition” in a WHERE clause. Subquery expressions, therefore, are allowed. Literal values should be enclosed in single quotes or whatever delimiter is needed by the database for the type of literal being defined. If the operator is BETWEEN, the AND keyword would separate values. If :USER is used in the value, then the user name is the limit value. If :GROUP is used, all groups of which the user is a member are used as the limiting values. Both :USER and :GROUP can be specified, separated by commas. The public group must be named explicitly; it is not supplied by reference to :GROUP. When applying column level security, CONSTRTV provides the SQL expression that will effectively replace the column on the Request line. For example, the value zero (0) might appear to replace a numeric value that is used in the Interactive Reporting documents but should not be accessible by the specified user/group. While any valid SQL expression that can be used in a SELECT list is permitted, pick a value that is acceptable for the likely use. For example, the word NULL is permitted, but note that in some cases, it might not be the appropriate choice, as it could also end up in a GROUP BY clause.</td>
</tr>
<tr>
<td>OVRRIDEG</td>
<td>VARCHAR, can be null</td>
<td>The name of a group or user. Used when CONSTRTT is set to O. If the group named in OVRRIDEG has a restriction on the source element, then this restriction is effectively ignored for the user/group. SRCDB, SRCOWNER, SRCTBL, and SRCCOL as a collection must be equal between the row specifying the override and the row specifying the conditions to be overridden. (See examples.)</td>
</tr>
</tbody>
</table>

**OR Logic Between Groups**

Each permission/restriction applied to the same group or user is separated by AND logic, but for users who belong to multiple groups, these sets of permissions/restrictions can be separated optionally by OR conditions or by AND conditions. This option makes the logic disjunctive or conjunctive respectively. For example, a user who is in group ‘A’ and is allowed to see sales data in the “truck” category for the Eastern Region, and who also belongs in group ‘B’ and is allowed to see sales data in the ‘minivan’ category for the Eastern Region, can see both ‘truck’ and ‘minivan’ data from one query using OR Logic. If conjunctive logic were used, that user would see no data, since the category could not be ‘truck’ and ‘minivan’ simultaneously.

**Row-Level Security Examples**

The examples are based on the sample Access database provided by option when installing Interactive Reporting on a Windows platform, using the Interactive Reporting database connection file Sample.oce.
For these examples, the users BRIO and VIEW&PROCESS require access to data that is denied to the rest of the users. These two users both belong to the group AMERICAS, which corresponds to a region of the same name. However, the user BRIO is a corporate officer who should be able to see all data.

Only one piece of data will be accessed in the course of these examples: the amount sales column from the sales fact table. The examples are more far-reaching than this might seem.

Screenshots for these examples come from the Interactive Reporting documents to which processing restrictions are applied, and from the sample Interactive Reporting document, row_level_security.bqy, mentioned earlier. For the screen shots from the sample Interactive Reporting document, the columns in the BRIOSECR table follow in a top down, left to right manner for the most part with the fields on the screen. Deviations from this will be noted where possible. In particular, though, note that the UNIQUE_ID column is not shown in this sequence of fields, appropriate to its optional role to the functionality of the software, although it is used behind the scenes by the sample Interactive Reporting document.

Figure 6 shows the layout of the data in the database, to illustrate the possible joins as intended by the database designer.

Figure 6  Database Layout Showing Possible Joins

Figure 7 shows the data model in the published Interactive Reporting documents.
Defining Users and Groups

Based on the above description of the users and groups involved in this example, insert a minimum of two rows into the BRIOSECG table, as shown in Table 154.

Table 154  Rows to Insert in the BRIOSECG Table

<table>
<thead>
<tr>
<th>BGROUP</th>
<th>USER</th>
</tr>
</thead>
<tbody>
<tr>
<td>AMERICAS</td>
<td>BRIO</td>
</tr>
<tr>
<td>AMERICAS</td>
<td>VIEW&amp;PROCESS</td>
</tr>
</tbody>
</table>

In the sample Interactive Reporting document for maintaining row-level security information, once the information has been added, it would look something like Figure 8 when the AMERICAS group is selected.

Dealing with “The Rest of the Users”

The requirement here was that users who were not part of the AMERICAS group should have no access to this information. There are several ways to do this, and in part, what the best way is depends on who the “rest of the users” are.
If they are extranet users, this probably means no access; users outside of the corporate network should not get sales data, even summary data, as this might be considered proprietary and certainly not for any potential competitors. Using the PUBLIC group, restrict the entire SALES_FACT table from accessing this information by using the asterisk to reflect all columns (see Figure 9).

Figure 9  Restriction on SALES_FACT Table

<table>
<thead>
<tr>
<th>Source DB Name</th>
<th>Source Table Name</th>
<th>Source Owner Name</th>
<th>Source Column Name</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>SALES_FACT</td>
<td></td>
<td>*</td>
</tr>
</tbody>
</table>

(This is an example of column level security. All values from this table, if they appear on the Request line, will be substituted with NULL.)

Where there are no extranet concerns, it might be appropriate for all the employees to know how their company is doing overall, such a blanket restriction is not recommended. Instead, restrict the use of the STORE_ID column, the only means by which the sales information can be tied back to any particular store, country, region, etc. This will look identical to the case above except that STORE_ID is specified instead of an asterisk for the Source Column Name.

**Overriding Constraints**

Obviously, members of the AMERICAS group are also members of PUBLIC. So, regardless of the way the PUBLIC group was restricted, those restrictions are not to be applied to the AMERICAS group for the sales information. That group might be restricted in different ways, or not at all, and the same mechanism ensures that happens while PUBLIC restrictions are in place. Figure 10 shows this when using the sample Interactive Reporting document, row _level_security.bqy.
This only overrides PUBLIC constraints for this particular column. Restrictions on PUBLIC against other columns are still enforced against members of the AMERICAS group as well. If the restriction is on all columns of a table, designated by an asterisk, the override must also be specified with an asterisk and then specific column constraints reapplied to groups as needed.

**Cascading Restrictions**

In order to give the members of the AMERICAS group access to sales information only for the appropriate region, the query includes references to columns in other tables which are not necessarily part of the existing data model. The row-level security will function the same whether or not the tables already existed in the data model.

As seen in the table relationships pictured above, the region information is bridged to the sales information by the store table. To implement a constraint that makes only sales information available for a particular region requires two entries in the BRIOSECR table, one to join sales to stores, and one to join stores to regions. This latter case also requires a limit value for the region name. (A limit on REGION_ID could also accomplish the same goal, but is not as readable, especially in an example. See the discussion to follow about subqueries for another perspective on limits on ID type columns.)

The first restriction required for this example is on the STORE_ID column. In order to use that column, a join must be made back to the STORES table. Figure 11 shows how this join would be specified.
Now, the join to the Regions table is added, with the appropriate constraining value, as shown in Figure 12.
The only remaining part of the example is letting user BRIO, also a member of the AMERICAS group, see the data in an unrestricted way. Handling this case is left as an exercise for the reader.

**Other Important Facts**

This section contains miscellaneous information about the implementation of row-level security.

**Custom SQL**

Custom SQL is used to provide special SQL syntax that the software does not generate. In the absence of row-level security, users with proper permissions for the Interactive Reporting document can modify custom SQL to produce ad hoc results.

When row-level security is in place, Custom SQL is affected in two ways:

- If the published Interactive Reporting document contains an open Custom SQL window, it is used as is when the user processes a query. No restrictions are applied to the SQL. However, the user cannot modify the SQL. While this can be a handy feature, care should be taken
when publishing Interactive Reporting documents that require custom SQL that they don’t compromise the security requirements.

- If the user chooses the Reset button on the Custom SQL window, the SQL shown includes the data restrictions, and the original intent of the Custom SQL is lost and the user will not be able to get it back except by requesting the Interactive Reporting document from the server again.

Similar issues apply to the use of imported SQL.

**Limits**

The row-level security feature affects limits three ways:

First, if a user is restricted from accessing the content of certain columns, and the user attempts to show values when setting a limit on the restricted column, the restrictions will be applied to the SQL used to get the show values list. That way, the user cannot see and specify a value they would not otherwise be permitted to access.

Second, setting limits can result in some perhaps unexpected behavior when coupled with row-level security restrictions. This is best explained by example. In order to read the amount of sales, the user is restricted to a join on the STORE_ID column back to the stores table and in addition, the user can only see information for the STORE_ID when the state is Ohio. This user tries to set a limit on the unrestricted column STATE, and chooses something other than Ohio, thinking this a way to subvert the data restrictions. Unfortunately for that user, no sales amount information will be returned at all in this case. The SQL will specify “where state = ‘user selected value’ AND state = ‘OH’”. Obviously, the state cannot be two different values at the same time, so no data will be returned.

Of course, a user may try to set a limit on the CITY column instead of the STATE column, thinking the city name might exist in multiple states. As long as the need exists to access the amount of SALES column in the SALES table with identifying store information, though, the state limit will still be applied, and no data the user should not be able to see will be accessible to that user. It just will not prevent a user from getting a list of stores when sales data is not part of that list. Generally speaking, restricting access to facts based on the foreign key in the fact table (s) works best. If it is necessary to restrict the user’s access to a list of stores, these dimension restrictions work best when applied to all columns in the dimension table with a limit on the source table.

For example, using the requirements described above to restrict the amount of sales information in Ohio only, with the same restriction on the dimension-only queries, do not apply any limit on access of the amount sales information except that it must be joined back to the STORES table on STORE_ID. Then, add a restriction for all columns in the STORES table, limiting it to only stores in Ohio. This limits access to both fact and dimension data.

Third, when setting a limit using Show Values, it has already been noted that any restrictions on the column to be limited are applied to the SQL that generates the show values list. For example, using the restrictions described in the previous paragraph, attempting to show the values list for the CITY column would be constrained to those cities in Ohio. Now, consider the following scenario.
The SALES FACT table also has a TRANSACTION DATE and PRODUCT_ID column. The transaction date column is tied back to a PERIODS table, where dates are broken down into quarters, fiscal years, months, and so on. In this somewhat contrived example, a restriction is placed on the PERIODS table, where values there are joined back to the SALES TRANSACTION table and restricted by PRODUCT_ID values in a certain range. The user sets a limit on fiscal year in the PERIODS table and invokes show values in the Limit dialog box to pick the range. Because of the restrictions in place, only one fiscal year is available, and the user picks it. Now, the user builds a query that does not request the FISCAL YEAR column itself but does reference the PRODUCT_ID field and processes it. This query returns, for the sake of argument, 100 rows. Now the user decides there is a need to see the fiscal year value and adds it to the Request line. Reprocessing the query only returns 50 rows.

Why? In the first case, PRODUCT_ID values outside of the range allowed when querying the FISCAL YEAR column will appear in the results. In the second case, the query will cause the restriction on PRODUCT_ID range to be included. Restrictions are only applied when a user requests to see data. There was no request to see the FISCAL YEAR column in the first case, except while setting the limit. There is no restriction on seeing PRODUCT_ID values. This example is contrived because restricting access to a dimension based on data in a fact table would be extremely unusual. Nevertheless, it illustrates a behavior that should be kept in mind when implementing restrictions.

**Naming**

Another way to set the restrictions described above is by a subquery. Instead of directly setting the limit on the STATE column, limit the values in the STORE_ID column in the STORES table. The constraint operator would be IN, and the constraint values field might look something like this:

\[
(\text{SELECT S.STORE_ID FROM STORES S WHERE S.STATE = 'OH'})
\]

Now, no matter what limit the user sets in the STORES table, they will always be constrained to the set of store IDs that are allowed based on their group memberships and their own user name. Even if a city outside of the allowed state is chosen, such as a city that exists in more than one state, any stores that other city has will not show up in the results.

Using a subquery can be useful when incorporating existing security systems into the row-level security feature of Interactive Reporting. When constructing constraints of this type, it is especially important to know SQL. For example, to specify a subquery, it helps to know that a subquery is always enclosed in parentheses. It is also important to know how Workspace generates SQL and to follow its naming conventions to make sure the syntax generated is appropriate.

**Table and Column Names**

For the most part, simple security constraints reference directly the actual object names in the database. Case sensitivity in names should be observed when and where required. For subqueries and other SQL constructs used to specify the constraint values, it is sometimes useful to refer to objects already used by the software’s SQL generation process. To do this:
● For table references in the FROM clause, use `From.tablename`, where `tablename` is the display name seen in the Interactive Reporting document’s data model as the display name. If the display name contains a space, use the underscore to represent the space.

● For column names, use `tablename.columnname`, following the same rule as above, except that the `From.` should not be used.

**Alias Names**

By default, when processing user queries, table references in the SQL are always given alias names. Alias names are convenient shorthand for long table references, and they are required when trying to build correlated subqueries. These alias names take the form “ALn”, when the ‘n’ is replaced by an arbitrary number. These numbers are usually based on the topic priority properties of the data model and can easily change based on several factors. For example, a user with the proper permissions can rearrange the topics, thus giving them different priorities. Because these numbers are dynamic, constraint specifications should never rely on them. Instead, by using the naming scheme above, the appropriate alias will be added to the constraints. So, if the requirement is a correlated subquery, the appropriate name will be given to the column in the outer query when referenced by the correlated subquery.

In the example above, using a subquery to restrict STORE_ID values to those in a specific state, it was neither necessary nor desirable to use the Hyperion Solutions naming conventions. There, the set of values was to be derived in a subquery that operated independently of the main query. Consequently, the ‘From.’ was not used in the FROM clause of the subquery, and the alias names were given in a way to not conflict with the alias names generated automatically by the software.

To use a correlated subquery, then, consider syntax like the following:

```sql
...FROM STORES S WHERE S.STORE_ID = Stores.Store_Id
```

The reference to the right of the equal sign will pick up the alias name from the outer query and thus provide the correct correlation requirements.
Troubleshooting Interactive Reporting

In This Chapter

Connectivity Troubleshooting with dbgprint...............................................................................................................523
dbgprint and Interactive Reporting Studio......................................................................................................................523
dbgprint and Interactive Reporting Web Client..........................................................................................................525

Connectivity Troubleshooting with dbgprint

If you experience difficulties logging on to or querying a database, you may be able to solve the problem with the help of a dbgprint (debug print) file. The dbgprint file automatically logs detailed status information which can assist you when troubleshooting platform configuration and connectivity problems. A dbgprint file will usually be requested by the Hyperion Solutions Customer Support personnel if they help you to solve a connectivity-related problem.

Although this topic is written with reference to Interactive Reporting, the dbgprint instructions apply to other Hyperion tools as well. If you experience continued connectivity problems with any of these tools, or have difficulty understanding the contents of a dbgprint file, you can forward the contents of the dbgprint file to Hyperion Solutions Customer Support for assistance.

Note:

dbgprint is strictly a diagnostic tool, and the information contained is useful only for troubleshooting. Because Hyperion tools repeatedly log information to the file, dbgprint considerably slows application performance and should only be used if you encounter connectivity problems.

dbgprint and Interactive Reporting Studio

dbgprint is a text file. When placed in a directory containing the Interactive Reporting Studio executable (briqry.exe), Interactive Reporting Studio automatically writes internal status information to the dbgprint file.

➤ To use dbgprint with Interactive Reporting Studio:

1 Exit Interactive Reporting Studio if it is still running.
2 Start a text editor (that is, Notepad, Simple Text, WordPad, and so on).
3 Save an empty file as dbgprint (with no file extension) to the directory which contains the Interactive Reporting Studio executable.

Typically the brioqry.exe is saved to HYPERION_HOME\BIPlus\Client\bin \brioqry.exe.

If you are using Notepad, you first have to type a space or character before you can save the file. Do not save the file with a file extension.

In the UNIX environment you need to create a file named DbgPrint. Please note the capitalization. This file will be placed in the bin directory for Interactive Reporting Studio.

If you are operating in a Windows environment, make sure that no extensions are appended to the end of the file name. If you are using Notepad as the text editor, the .txt extension is automatically appended to the saved file. Make sure you remove any extension before you proceed to the next step.

4 Close the text editor and start Interactive Reporting Studio by opening the actual application file.

In some instances dbgprint does not log information if Interactive Reporting Studio was started through an alias or shortcut. Instead, start Interactive Reporting Studio using the Finder (Macintosh), or Windows Explorer. Clicking a shortcut only works if the Start In field in the Properties dialog box for the shortcut shows the path to the brioqry.exe file.

5 Once Interactive Reporting Studio is running, recreate the steps which resulted in the previous error problem, or follow any instructions given to you by a Hyperion Solution customer support representative.

Typical things you may be asked to do are:
- Connect to the database
- Retrieve a list of tables
- Add tables to the work space
- Create and process a query
- Set a limit

6 Once you have completed the above tasks, quit Interactive Reporting Studio and open the dbgprint file.

7 View the contents of the dbgprint file.

The file should contain status information detailing the Interactive Reporting Studio logon session. You will probably be asked to either fax or email the contents of the dbgprint file to Hyperion Solutions.

If the file is blank, review the previous steps and repeat the process.

**Note:**

If you need to run another dbgprint file, save the contents of the file with a unique name. Each time you run the brioqry.exe file, the existing dbgprint file is overwritten.
DbgPrint files can also be used with Interactive Reporting Web Client.

To use dbgprint with Interactive Reporting Web Client:

1. Shut down the Web browser.
2. Start a text editor (for example, Notepad, Simple Text, MS-WordPad, and so on).
3. Save an empty file as dbgprint to the folder where the browser executable (.exe) resides, for example, C:\Program Files\Internet Explorer directory).

   If you are using Notepad, you first have to type a space or character before you can save the file.

   If you are operating in a Windows environment, make sure that no extensions are appended to the end of the file name. If you are using Notepad as the text editor, the .txt extension is automatically appended to the saved file. Make sure you remove any extension before you proceed to the next step.

4. Start the Web browser.

   The DbgPrint file starts collecting debug information about the processing of the queries.
About Interactive Reporting Studio INI Files

The Interactive Reporting Studio INI files are simple text files that are used to store system and application settings. Table 155 shows each INI used by application and the type of information it contains.

Table 155  INI Files used in Interactive Reporting

<table>
<thead>
<tr>
<th>Application</th>
<th>INI File</th>
<th>Content</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interactive Reporting Studio</td>
<td>BQFORMAT.INI</td>
<td>Stores locale and custom numeric formats.</td>
</tr>
<tr>
<td></td>
<td>BQMETA0.INI</td>
<td>Stores OMI metadata settings for supported Metadata sources.</td>
</tr>
<tr>
<td></td>
<td>BQTOOLS.INI</td>
<td>Stores Custom Menu definitions (only present if custom menus are defined)</td>
</tr>
<tr>
<td>Interactive Reporting Web Client</td>
<td>BRIOQPLG.INI</td>
<td>Stores regional settings for the plug-in</td>
</tr>
<tr>
<td></td>
<td>BQFORMAT.INI</td>
<td>Stores locale and custom numeric formats</td>
</tr>
<tr>
<td></td>
<td>BQTOOLS.INI</td>
<td>Stores Custom Menu definitions (only present if custom menus are defined)</td>
</tr>
<tr>
<td>Workspace</td>
<td>ALL server INI files are stored in sub-directories off of the HYPERION_HOME directory, and NOT in the Windows OS directory. Internationalized versions of the BQFORMAT.INI and BQMETA0.INI files are also present.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>BQFORMAT.INI</td>
<td>Stores locale and custom numeric formats for use with Oracle's Hyperion® Workspace.</td>
</tr>
<tr>
<td></td>
<td>INTELLIGENCE.INI</td>
<td>Stores default configuration settings for the user interface.</td>
</tr>
<tr>
<td></td>
<td>SQR.INI</td>
<td>Stores SQR configuration info for the Job Factory</td>
</tr>
</tbody>
</table>
Interactive Reporting Web Client Co-existence

Interactive Reporting Web Client users can work with different versions of Reporting and Analysis on the same client machine. To enable this feature, new Interactive Reporting Web Client installations include multiple versions of the application. Users can work with all servers older than Release 8.3 + server through Release 8.5. The feature was added because the Reporting and Analysis installation does not have a backward compatibility mechanism and only supports the 8.5 version of the Interactive Reporting Web Client. The correct version that gets used is determined at run-time when the Interactive Reporting document (BQY) is opened. For example, if a user opens an Interactive Reporting document (BQY) in a Release 8.3 server, the 8.3 version of the Interactive Reporting Web Client is launched to serve the request.

Two Interactive Reporting Web Client versions are installed in this release: an 8.3 version and the current 8.5 release. Each Interactive Reporting Web Client plug-in entity is separated on the disk and in the registry. Each version is installed in a separate folder under `<IE Install Directory>\PLUGINS\Hyperion\<Insight Series Version>` or under `<Firefox Install Directory>\Plugins\Hyperion\<Insight Series Version>`. A mechanism has been implemented to find and start a particular Interactive Reporting Web Client executable based on its version. The Interactive Reporting Web Client Launcher that provides 6x/8x co-existence has been enhanced for 8.3/8.5 and future co-existence. There is a single launcher in the system associated with the .bqy mime-type and file.

If an user installs the 8.x version over the Reporting and Analysis installation, then the user needs to installed the Oracle's Hyperion® Reporting and Analysis – System 9 version again in order to have both work correctly.

Locally Saved Interactive Reporting Documents

If a user is working with a locally saved Interactive Reporting document and saves it to disk from the Interactive Reporting Web Client, the file is appended with version information. If the user
opens the file again, the appropriate version of the Interactive Reporting Web Client is launched. After this, the Interactive Reporting Web Client checks the server version to connect to the server. If the server is newer than the current Interactive Reporting Web Client, the user is prompted to upgrade to the current version. In this case, the older version accesses the URL of the server, launches the zero administration page, and performs the upgrade. Interactive Reporting Web Client is opened from the disk using file name in the upgraded version.

If the Interactive Reporting document was created in previous versions of the Interactive Reporting Web Client or in the Oracle's Hyperion® Interactive Reporting Studio, the user is prompted for the version to use. The user can select from a list of versions of Interactive Reporting Web Client, including the 6.x version. If the user selects a 6.x version, no version record is attached to the document because there is no command on the Tools menu to open the document in another version of Interactive Reporting Web Client.

After Interactive Reporting Web Client is launched, the user can change the Interactive Reporting Web Client designated to open the document at any time by selecting the following options from the Tools menu:

- Change the Web Client version to open this file
- Make this Web Client default for locally saved Interactive Reporting document.

### Interactive Reporting Web Client Mismatches

If there is a mismatch between the Interactive Reporting Web Client series required by the server and the user selects a compatible version, a file version record is saved and the document is reloaded.

Required Interactive Reporting Web Client series information is only provided by the 8.5 version servers. If this information is unavailable, it is assumed that the user is connected to either an 8.3 or 6.x server (which is detected by specific cookies and the absence of later version server cookies). Otherwise, it is assumed the user is connected to an 8.3 server. If the user opens a document in Interactive Reporting Web Client in a greater version number than is required by the server (for example, a document from a 6.x server is opened in an 8.3 server), the Save on Exit prompt is suppressed when the document is reloaded to prevent the user from upgrading accidentally to the newer series.

➤ To change the Web Client Version:

1. **Select Tools > Change Web Client Version.**
   A message dialog is displayed stating: Several versions of Interactive Reporting Web Client are detected on your system. Choose the version of Interactive Reporting Web Client to use to open the document.

2. **Select the version to use to open the document from the version drop-down.**

3. **To store the version selection for future documents, select Remember the choice and don’t ask again.**

4. **Click OK.**
   If Interactive Reporting Web Client expects a version other than the version selected, a message dialog is displayed stating: “You are trying to connect to server of different version then this
Interactive Reporting Web Client. Server version x.x is expected. Please try to use the server of this version or choose another Interactive Reporting Web Client from the following list.” At this point, you can either select the expected version or another version.” If you select a version other than expected, some functionality and features in the original document may not be available.

5 Click OK.

**Increasing the Idle Connection Time-outs**

Using a configurable polling time, administrators can control the frequency of messages that keep a connection to Interactive Reporting Web Client active. This feature allows queries of varied lengths to process from when running behind a proxy or firewall with finite idle-connection time-outs. By default there is no polling and this feature needs to be explicitly enabled.

➤ To increase the idle connection time-outs:

1 Open the ws.conf file from the `<SERVLETS DEPLOYMENT>/config` folder in your favorite editor.

2 Add the line:

```
WebClient.Applications.DAServlet.PollingTimeSec=0
```

3 Change the PollingTimeSec parameter value from 0 to the desired value.

- The Default value is 0 for the PollingTimeSec parameter value indicating there is no polling mechanism in place to keep the connection active.
- The PollingTimeSec parameter value is in seconds.
- The PollingTimeSec parameter value is less than the proxy and firewall timeout value (otherwise this configuration change would have no effect).
- Setting the PollingTimeSec parameter value too low increases network traffic. For example: if a firewall is set for a 15 min idle timeout, set the polling time to be 720 sec (== 12 min). There is no need to set the value to 10 seconds in a case like this, as it creates unnecessary network overhead.

Once this entry is added to the ws.conf file, the Servlet Configurator (`<INSTALL_HOME/servlets/bin`, servletconfig.bat for Windows and servletconfig.sh for UNIX can be used to manipulate the value.

4 Save the file.

**Opening Interactive Reporting Web Client in Multiple Browser Windows**

Interactive Reporting Web Client can be launched in a single browser window or multiple browser windows. Use this feature to display either one or several Interactive Reporting documents (BQY) at the same time. When multiple browser windows are opened for the same
Interactive Reporting documents (BQY), the last saved document is the one saved to the repository.

➤ To open Interactive Reporting Web Client in multiple browser windows:
1 Open the ws.conf file from the <SERVLETS DEPLOYMENT>/config folder in your favorite editor.
2 Add the line:
   WebClient.Applications.DAServlet.OpenNewWindow=true
3 Save the file.

➤ To open Interactive Reporting Web Client in a single browser window:
1 Open the ws.conf file from the <SERVLETS DEPLOYMENT>/config folder in your favorite editor.
2 Add the line:
   WebClient.Applications.DAServlet.OpenNewWindow=false
3 Save the file.

Interactive Reporting Web Client Installer Customization

When installing Interactive Reporting Web Client, customization options are available which enable you to optionally install:

● Help files
● Font files
● Translation files

This section also describes how to modify the Configuration file to customize the installation of Interactive Reporting Web Client.

Installing Help and Font Files

➤ To install help and font files:
1 In Explore mode, select an Oracle's Hyperion® Interactive Reporting – System 9 document.
2 Select Open As on the shortcut menu.
   A submenu is displayed.
3 Select Interactive Reporting Web Client from the submenu.
   The Interactive Reporting Web Client Install wizard is displayed.
4 Select to install the help files and font files.
5 Click Next.
   Complete the installation as prompted.
Selecting the Number of Installed Languages

Users do not always need full internationalization support and ability to switch the user interface to different languages. Your administration determines if only one language (which matches the user’s login language) is implemented, or a subset of installed languages is installed.

To allow the user to install additional translations files and custom versions of ini files, the files can be placed in an ad hoc folder (“CustomFiles”) along with the installer package (for example workspace\zeroadmin\component\Insight\CustomFiles), and relative path to which it must be transferred to in the installer. Three methods are available for transferring files to the user machine.

First, the administrator can transfer files into the Interactive Reporting Web Client home directory (for example, c:\program files\internet explorer\plugins\hyperion). In this case, files are placed corresponding to the relative path in which they stored in the “CustomFiles” folder. For example if briottbl.txt file is placed in the :CustomFiles\9.3\Translations\Latin folder on the server, it is transferred to c:\program files\internet explorer\plugins\hyperion\9.0.2\Translations\Latin\briottbl.txt. This reduces the changes to the subfolder name corresponding to Interactive Reporting Web Client version for each new version of the installer (for example, changing the \9.0.2\Translations to \9.1\Translations). To simplify the maintenance of custom installations, a special folder name “PluginFolder” is supported. If briottbl.txt is placed in the CustomFiles \PluginFolder\Translations\Latin folder on the server, it is transferred to the folder corresponding to the version of the installed Interactive Reporting Web Client (for example. \9.0.2\Translations\Latin\briottbl.txt, \9.1\Translations\Latin\briottbl.txt etc.).

In the second case, the files can be transferred into the Windows system directory. This option is supported only for updating existing Interactive Reporting Web Client .ini files (brioqplg_ev.ini etc.) and it is not possible to transfer any other file to the Windows system directory.

The third option enables you to transfer *.ttf font files. These files can be transferred to the Windows Fonts folder and properly registered. The registration requires that font name be made available to the installer (the administrator might write a script to retrieve the font names).

Editing the Configuration File

The easiest way to customize the Interactive Reporting Web Client is by editing the settings.ini file manually. The structure of this file should be as follows.

OneTranslationLanguage=<visible|invisible>,<enabled|disabled>
SilentInstall=<true|false>
<Component>=<visible|invisible>,<installed|skipped>
InstallFile=<path to file>
InstalledTranslationLanguages=<language>,<language>,

<Component>—is any of supported for customized installation components (Insight8.3, Font etc.).
<br>visible|invisible>—defines whether a given option is available to user to change or not.
OneTranslationLanguage—corresponds to “install only one language matching user’s login” option.
SilentInstall—sets the silent install mode. If the option is set to true, neither the component selection dialog or the installation complete notification dialog are shown, and no user interaction is required.

InstallFile and <path to file>—provides information to the installer about additional files that should be installed. There can be an arbitrary number of InstallFiles entries each defining file to install. The path should be relative to the CustomFiles folder.

InstalledTranslationLanguages—defines the subset of installed translations. The <language> parameter is any of the supported translation languages (French, Italian, Japanese etc.). If an option is present in the settings.ini, only translation files for selected languages are installed.

**Configuration File Examples**

Examples of how you might configure the settings.ini are shown below:

In the default configuration, Insight 8.3 is installed as well as all translation languages:

OneTranslationLanguage=invisible,disabled
SilentInstall=false
Insight8.3=invisible,installed
Help=visible,installed
Fonts=visible,installed
Translation=invisible,installed

Instructions are given to install only one translation file matching the language of the installation:

OneTranslationLanguage=invisible,enabled
SilentInstall=false
Insight8.3=invisible,installed
Help=visible,installed
Fonts=visible,installed
Translation=invisible,installed

Instructions are given to install only a selected subset of translation languages:

OneTranslationLanguage=invisible,enabled
SilentInstall=false
Insight8.3=invisible,installed
Help=visible,installed
Fonts=visible,installed
Translation=invisible,installed
InstalledTranslationLanguages=French,Italian,Japanese

Instructions are given not to install Insight 8.3:

OneTranslationLanguage=invisible,disabled
SilentInstall=false
Insight8.3=invisible,skipped
Help=visible,installed
Fonts=visible,installed
Translation=invisible,installed

Instructions are given to allow the user the choice of installing Insight 8.3, install a selected subset of translation languages, but not to install Fonts or Help files:

OneTranslationLanguage=invisible,disabled
SilentInstall=false
Instructions are given not to install anything except the main Oracle's Hyperion® Interactive Reporting Web Client plugin and translations, and to perform silent install (no user interaction). Note that it doesn’t matter that the individual component’s state is set to visible. The SilentInstall switch overrides it:

OneTranslationLanguage=invisible,disabled
SilentInstall=true
Insight8.3=visible,skipped
Help=visible,skipped
Fonts=visible,skipped
Translation=invisible,installed

Instructions are given to install additional custom translation files and the non-default brioqplg_ev.ini:

OneTranslationLanguage=invisible,disabled
SilentInstall=false
Insight8.3=invisible,installed
Help=visible,installed
Fonts=visible,installed
Translation=invisible,installed
InstallFile=PluginFolder\Translations\Latin\briottbl.txt
InstallFile=Translations\Latin\briottbl.txt ; the launcher’s translation
InstallFile=brioqplg_ev.ini
Glossary

See bang character (!).

See missing data (#MISSING).

access permissions A set of operations that a user can perform on a resource.

accessor Input and output data specifications for data mining algorithms.

account A dimension that represents an accounting container that identifies the location and primary nature of the data.

account blocking The process by which accounts accept input data in the consolidated file. Blocked accounts do not receive their value through the additive consolidation process.

account eliminations Accounts which have their values set to zero in the consolidated file during consolidation.

account type How an account’s value flows over time, and its sign behavior. Account type options can include expense, income, asset, liability, and equity.

accountability map A visual, hierarchical representation of the responsibility, reporting, and dependency structure of the accountability teams (also known as critical business areas) in an organization.

accounts dimension A dimension type that makes accounting intelligence available. Only one dimension can be defined as Accounts.

active service A service whose Run Type is set to Start rather than Hold.

active user A user who is entitled to access the system.

active user/user group The user or user group identified as the current user by user preferences. Determines default user preferences, dynamic options, access, and file permissions. You can set the active user to your user name or any user group to which you belong.

activity-level authorization Defines user access to applications and the types of activities they can perform on applications, independent of the data that will be operated on.

ad hoc report An online analytical query created on-the-fly by an end user.

adaptive states Interactive Reporting Web Client level of permission.

adjustment See journal entry (JE).

Advanced Relational Access The integration of a relational database with an Essbase multidimensional database so that all data remains in the relational database and is mapped to summary-level data residing in the Essbase database.

agent An Essbase server process that starts and stops applications and databases, manages connections from users, and handles user-access security. The agent is referred to as ESSBASE.EXE.

aggregate cell A cell comprising several cells. For example, a data cell that uses Children(Year) expands to four cells containing Quarter 1, Quarter 2, Quarter 3, and Quarter 4 data.

aggregate function A type of function, such as sum or calculation of an average, that summarizes or performs analysis on data.

aggregate limit A limit placed on an aggregated request line item or aggregated metatopic item.
aggregate storage database  The database storage model designed to support large-scale, sparsely distributed data which is categorized into many, potentially large dimensions. Upper level members and formulas are dynamically calculated, and selected data values are aggregated and stored, typically with improvements in overall aggregation time.

aggregate view  A collection of aggregate cells based on the levels of the members within each dimension. To reduce calculation time, values are pre-aggregated and stored as aggregate views. Retrievals then start from aggregate view totals and add up from there.

aggregation  The process of rolling up and storing values in an aggregate storage database; the stored result of the aggregation process.

aggregation script  In aggregate storage databases only, a file that defines a selection of aggregate views to be built into an aggregation.

alias  An alternative name. For example, for a more easily identifiable column descriptor you can display the alias instead of the member name.

alias table  A table that contains alternate names for members.

alternate hierarchy  A hierarchy of shared members. An alternate hierarchy is based upon an existing hierarchy in a database outline, but has alternate levels in the dimension. An alternate hierarchy allows the same data to be seen from different points of view.

ancestor  A branch member that has members below it. For example, the members Qtr2 and 2006 are ancestors of the member April.

appender  A Log4j term for destination.

application  (1) A software program designed to run a specific task or group of tasks such as a spreadsheet program or database management system. (2) A related set of dimensions and dimension members that are used to meet a specific set of analytical and/or reporting requirements.

application currency  The default reporting currency for the application.

Application Migration Utility  A command-line utility for migrating applications and artifacts.

area  A predefined set of members and values that makes up a partition.

arithmetic data load  A data load that performs operations on values in the database, such as adding 10 to each value.

artifact  An individual application or repository item; for example, scripts, forms, rules files, Interactive Reporting documents, and financial reports. Also known as an object.

asset account  An account type that stores values that represent a company’s assets.

attribute  Characteristics of a dimension member. For example, Employee dimension members may have attributes of Name, Age, or Address. Product dimension members can have several attributes, such as a size and flavor.

attribute association  A relationship in a database outline whereby a member in an attribute dimension describes a characteristic of a member of its base dimension. For example, if product 100-10 has a grape flavor, the product 100-10 has the Flavor attribute association of grape. Thus, the 100-10 member of the Product dimension is associated with the Grape member of the Flavor attribute dimension.

Attribute Calculations dimension  A system-defined dimension that performs these calculation operations on groups of members: Sum, Count, Avg, Min, and Max. This dimension is calculated dynamically and is not visible in the database outline. For example, using the Avg member, you can calculate the average sales value for Red products in New York in January.

attribute dimension  A type of dimension that enables analysis based on the attributes or qualities of dimension members.

attribute reporting  A reporting process based on the attributes of the base dimension members. See also base dimension.

attribute type  A text, numeric, Boolean, date, or linked-attribute type that enables different functions for grouping, selecting, or calculating data. For example, because the Ounces attribute dimension has the type numeric, the number of ounces specified as the attribute of each product can be used to calculate the profit per ounce for that product.
**authentication** Verification of identity as a security measure. Authentication is typically based on a user name and password. Passwords and digital signatures are forms of authentication.

**authentication service** A core service that manages one authentication system.

**auto-reversing journal** A journal for entering adjustments that you want to reverse in the next period.

**automated stage** A stage that does not require human intervention, for example, a data load.

**axis** (1) A straight line that passes through a graphic used for measurement and categorization. (2) A report aspect used to arrange and relate multidimensional data, such as filters, pages, rows, and columns. For example, for a data query in Simple Basic, an axis can define columns for values for Qtr1, Qtr2, Qtr3, and Qtr4. Row data would be retrieved with totals in the following hierarchy: Market, Product.

**backup** A duplicate copy of an application instance.

**balance account** An account type that stores unsigned values that relate to a particular point in time.

**balanced journal** A journal in which the total debits equal the total credits.

**bang character (!)** A character that terminates a series of report commands and requests information from the database. A report script must be terminated with a bang character; several bang characters can be used within a report script.

**bar chart** A chart that can consist of one to 50 data sets, with any number of values assigned to each data set. Data sets are displayed as groups of corresponding bars, stacked bars, or individual bars in separate rows.

**base currency** The currency in which daily business transactions are performed.

**base dimension** A standard dimension that is associated with one or more attribute dimensions. For example, assuming products have flavors, the Product dimension is the base dimension for the Flavors attribute dimension.

**base entity** An entity at the bottom of the organization structure that does not own other entities.

**batch calculation** Any calculation on a database that is done in batch; for example, a calculation script or a full database calculation. Dynamic calculations are not considered to be batch calculations.

**batch file** An operating system file that can call multiple ESSCMD scripts and run multiple sessions of ESSCMD. On Windows-based systems, batch files have BAT file extensions. On UNIX, batch files are written as a shell script.

**batch POV** A collection of all dimensions on the user POV of every report and book in the batch. While scheduling the batch, you can set the members selected on the batch POV.

**batch processing mode** A method of using ESSCMD to write a batch or script file that can be used to automate routine server maintenance and diagnostic tasks. ESSCMD script files can execute multiple commands and can be run from the operating system command line or from within operating system batch files. Batch files can be used to call multiple ESSCMD scripts or run multiple instances of ESSCMD.

**block** The primary storage unit which is a multidimensional array representing the cells of all dense dimensions.

**block storage database** The Essbase database storage model categorizing and storing data based on the sparsity of data values defined in sparse dimensions. Data values are stored in blocks, which exist only for sparse dimension members for which there are values.

**Blocked Account** An account that you do not want calculated in the consolidated file because you want to enter it manually.

**book** A container that holds a group of similar Financial Reporting documents. Books may specify dimension sections or dimension changes.

**book POV** The dimension members for which a book is run.

**bookmark** A link to a reporting document or a Web site, displayed on a personal page of a user. The two types of bookmarks are My Bookmarks and image bookmarks.
The required perimeter that encapsulates the Interactive Reporting document content when embedding Interactive Reporting document sections in a personal page, specified in pixels for height and width or row per page.

A simple text message sent by an administrator to a user who is logged on to a Planning application. The message displays information to the user such as system availability, notification of application refresh, or application backups.

A person responsible for setting up, configuring, maintaining, and controlling an application. Has all application privileges and data access permissions.

A method used to modify database outlines. Choice of a build method is based on the format of data in data source files.

A set of activities that collectively accomplish a business objective.

Logical expressions or formulas that are created within an application to produce a desired set of resulting values.

A buffer in memory that holds data temporarily.

A set of commands that define how a database is consolidated or aggregated. A calculation script may also contain commands that specify allocation and other calculation rules separate from the consolidation process.

You cannot alter the formulas in Calculated Accounts. These formulas are fixed in order to maintain the accounting integrity of the model you are building. For example, the formula for Net Income, a Calculated Account, is modeled into Strategic Finance and can not be changed in either historical or forecast periods.

A member designed for analytical purposes and defined in the optional WITH section of a MaxL DML query.

The process of aggregating data, or of running a calculation script on a database.

A consolidation status that indicates that some values or formula calculations have changed. You must reconsolidate to get the correct values for the affected entity.

User-defined time periods and their relationship to each other. Q1, Q2, Q3, and Q4 comprise a calendar or fiscal year.

The process of creating multiple reports for a subset of member values.

Displays a list of elements available to the active section. If Query is the active section, a list of database tables is displayed. If Pivot is the active section, a list of results columns is displayed. If Dashboard is the active section, a list of embeddable sections, graphic tools, and control tools are displayed.

Groupings by which data is organized. For example, Month

Depicts how the elements that form your corporate strategy relate and how they work together to meet your organization’s strategic goals. A Cause and Effect map tab is automatically created for each Strategy map.

See custom-defined function (CDF).

See custom-defined macro (CDM).

(1) The data value at the intersection of dimensions in a multidimensional database; the intersection of a row and a column in a worksheet. (2) A logical group of nodes belonging to one administrative domain.

A text annotation for a cell in an Essbase database. Cell notes are a type of LRO.

Consolidation status that indicates data for an entity has changed.

A graphical representation of spreadsheet data. The visual nature expedites analysis, color-coding, and visual cues that aid comparisons.

A template that defines the metrics to display in Workspace charts.

A member with a parent above it in the database outline.
choice list  A list of members that a report designer can specify for each dimension when defining the report’s point of view. A user who wants to change the point of view for a dimension that uses a choice list can select only the members specified in that defined member list or those members that meet the criteria defined in the function for the dynamic list.

clean block  A data block that where the database is fully calculated, if a calculation script calculates all dimensions at once, or if the SET CLEARUPDATESTATUS command is used in a calculation script.

cluster  An array of servers or databases that behave as a single resource which share task loads and provide failover support; eliminates one server or database as a single point of failure in a system.

clustered bar charts  Charts in which categories are viewed side-by-side; useful for side-by-side category analysis; used only with vertical bar charts.

code page  A mapping of bit combinations to a set of text characters. Different code pages support different sets of characters. Each computer contains a code page setting for the character set requirements of the language of the computer user. In the context of this document, code pages map characters to bit combinations for non-Unicode encodings. See also encoding.

column  A vertical display of information in a grid or table. A column can contain data from one field, derived data from a calculation, or textual information.

committed access  An Essbase Kernel Isolation Level setting that affects how Essbase handles transactions. Under committed access, concurrent transactions hold long-term write locks and yield predictable results.

computed item  A virtual column (as opposed to a column that is physically stored in the database or cube) that can be calculated by the database during a query, or by Interactive Reporting Studio in the Results section. Computed items are calculations of data based on functions, data items, and operators provided in the dialog box and can be included in reports or reused to calculate other data.

configuration file  The security platform relies on XML documents to be configured by the product administrator or software installer. The XML document must be modified to indicate meaningful values for properties, specifying locations and attributes pertaining to the corporate authentication scenario.

connection file  See Interactive Reporting connection file (.oce).

consolidated file (Parent)  A file into which all of the business unit files are consolidated; contains the definition of the consolidation.

consolidation  The process of aggregating data from dependent entities to parent entities. For example, if the dimension Year consists of the members Qtr1, Qtr2, Qtr3, and Qtr4, its consolidation is Year.

consolidation file (*.cns)  The consolidation file is a graphical interface that enables you to add, delete or move Strategic Finance files in the consolidation process using either a Chart or Tree view. It also enables you to define and modify the consolidation.

consolidation rule  Identifies the rule that is executed during the consolidation of the node of the hierarchy. This rule can contain customer specific formulas appropriate for the correct consolidation of parent balances. Elimination processing can be controlled within these rules.

content  Information stored in the repository for any type of file.

context variable  A variable that is defined for a particular task flow to identify the context of the taskflow instance.

contribution  The value added to a parent from a child entity. Each child has a contribution to its parent.

conversion rate  See exchange rate.

cookie  A segment of data placed on your computer by a Web site.

correlated subqueries  Subqueries that are evaluated once for every row in the parent query; created by joining a topic item in the subquery with a topic in the parent query.
Cost of Debt  Value determined by using a weighted average Yield to Maturity (YTM) of a company's entire debt portfolio. Use is the current YTM rate rather than the nominal cost of debt. The coupon rate determines the interest payment, but it does not always reflect the actual cost of the company's debt today. As required returns change, the price of a debt issue also changes so that the actual interest payments and anticipated proceeds, at maturity, yield the investors their revised required return. Therefore, the YTM fully reflects the current return demanded by debt holders and the rate at which existing debt would have to be replaced.

Cost of Equity  The return an investor expects to earn on an individual stock. Using the CAPM method, the Cost of Equity is equal to:

Cost of Preferred  Represents the expected return to preferred stockholders. Like debt, you need to enter the yield to maturity on preferred stock, but without the tax shielding.

critical business area (CBA)  An individual or a group organized into a division, region, plant, cost center, profit center, project team, or process; also called accountability team or business area.

critical success factor (CSF)  A capability that must be established and sustained to achieve a strategic objective; owned by a strategic objective or a critical process and is a parent to one or more actions.

crosstab reporting  Categorizes and summarizes data in table format. The table cells contain summaries of the data that fit within the intersecting categories. For example, a crosstab report of product sales information could show size attributes, such as Small and Large, as column headings and color attributes, such as Blue and Yellow, as row headings. The cell in the table where Large and Blue intersect could contain the total sales of all Blue products that are sized Large.

cube  A block of data that contains three or more dimensions. An Essbase database is a cube.

currency conversion  A process that converts currency values in a database from one currency into another. For example, to convert one U.S. dollar into the European euro, the exchange rate (for example, 0.923702) is multiplied with the dollar (1 * 0.923702). After conversion, the European euro amount is .92.

Currency Overrides  In any input period, the selected input method can be overridden to enable input of that period's value as Default Currency/Items. To override the input method, enter a pound sign (#) either before or after the number.

currency partition  A dimension type that separates local currency members from a base currency, as defined in an application. Identifies currency types, such as Actual, Budget, and Forecast.

custom calendar  Any calendar created by an administrator.

custom dimension  A dimension created and defined by users. Channel, product, department, project, or region could be custom dimensions.

custom property  A property of a dimension or dimension member that is created by a user.

custom report  A complex report from the Design Report module, composed of any combination of components.

custom-defined function (CDF)  Essbase calculation functions developed in Java and added to the standard Essbase calculation scripting language using MaxL. See also custom-defined macro (CDM).

custom-defined macro (CDM)  Essbase macros written with Essbase calculator functions and special macro functions. Custom-defined macros use an internal Essbase macro language that enables the combination of calculation functions and they operate on multiple input parameters. See also custom-defined function (CDF).

cycle through  To perform multiple passes through a database while calculating it.

dashboard  A collection of metrics and indicators that provide an interactive summary of your business. Dashboards enable you to build and deploy analytic applications.

data cache  A buffer in memory that holds uncompressed data blocks.

data cell  See cell.

data file cache  A buffer in memory that holds compressed data (PAG) files.
data form A grid display that enables users to enter data into the database from an interface such as a Web browser, and to view and analyze data or related text. Certain dimension member values are fixed, giving users a specific view into the data.

data function That computes aggregate values, including averages, maximums, counts, and other statistics, that summarize groupings of data.

data load rules A set of criteria that determines how to load data from a text-based file, a spreadsheet, or a relational data set into a database.

data lock Prevents changes to data according to specified criteria, such as period or scenario.

data mining The process of searching through an Essbase database for hidden relationships and patterns in a large amount of data.

data model A representation of a subset of database tables.

data value See cell.

database connection File that stores definitions and properties used to connect to data sources and enables database references to be portable and widely used.

Default Currency Units Define the unit scale of data. For example, If you select to define your analysis in Thousands, and enter “10”, this is interpreted as “10,000”.

dense dimension In block storage databases, a dimension likely to contain data for every combination of dimension members. For example, time dimensions are often dense because they can contain all combinations of all members. Contrast with sparse dimension.

dependent entity An entity that is owned by another entity in the organization.

descendant Any member below a parent in the database outline. In a dimension that includes years, quarters, and months, the members Qtr2 and April are descendants of the member Year.

Design Report An interface in Web Analysis Studio for designing custom reports, from a library of components.

destination currency The currency to which balances are converted. You enter exchange rates and convert from the source currency to the destination currency. For example, when you convert from EUR to USD, the destination currency is USD.

detail chart A chart that provides the detailed information that you see in a Summary chart. Detail charts appear in the Investigate Section in columns below the Summary charts. If the Summary chart shows a Pie chart, then the Detail charts below represent each piece of the pie.

dimension A data category used to organize business data for retrieval and preservation of values. Dimensions usually contain hierarchies of related members grouped within them. For example, a Year dimension often includes members for each time period, such as quarters and months.

dimension build The process of adding dimensions and members to an Essbase outline.

dimension build rules Specifications, similar to data load rules, that Essbase uses to modify an outline. The modification is based on data in an external data source file.

dimension tab In the Pivot section, the tab that enables you to pivot data between rows and columns.

dimension table (1) A table that includes numerous attributes about a specific business process. (2) In Essbase Integration Services, a container in the OLAP model for one or more relational tables that define a potential dimension in Essbase.

dimension type A dimension property that enables the use of predefined functionality. Dimensions tagged as time have a predefined calendar functionality.

dimensionality In MaxL DML, the represented dimensions (and the order in which they are represented) in a set. For example, the following set consists of two tuples of the same dimensionality because they both reflect the dimensions (Region, Year): { (West, Feb), (East, Mar) }

direct rate A currency rate that you enter in the exchange rate table. The direct rate is used for currency conversion. For example, to convert balances from JPY to USD, In the exchange rate table, enter a rate for the period/scenario where the source currency is JPY and the destination currency is USD.
**dirty block**  A data block containing cells that have been changed since the last calculation. Upper level blocks are marked as dirty if their child blocks are dirty (that is, they have been updated).

**display type**  One of three Web Analysis formats saved to the repository: spreadsheet, chart, and pinboard.

**dog-ear**  The flipped page corner in the upper right corner of the chart header area.

**domain**  In data mining, a variable representing a range of navigation within data.

**drill-down**  Navigation through the query result set using the dimensional hierarchy. Drilling down moves the user perspective from aggregated data to detail. For example, drilling down can reveal hierarchical relationships between years and quarters or quarters and months.

**drill-through**  The navigation from a value in one data source to corresponding data in another source.

**duplicate alias name**  A name that occurs more than once in an alias table and that can be associated with more than one member in a database outline. Duplicate alias names can be used with duplicate member outlines only.

**duplicate member name**  The multiple occurrence of a member name in a database, with each occurrence representing a different member. For example, a database has two members named “New York.” One member represents New York state and the other member represents New York city.

**duplicate member outline**  A database outline containing duplicate member names.

**Dynamic Calc and Store members**  A member in a block storage outline that Essbase calculates only upon the first retrieval of the value. Essbase then stores the calculated value in the database. Subsequent retrievals do not require recalculating.

**Dynamic Calc members**  A member in a block storage outline that Essbase calculates only at retrieval time. Essbase discards calculated values after completing the retrieval request.

**dynamic calculation**  In Essbase, a calculation that occurs only when you retrieve data on a member that is tagged as Dynamic Calc or Dynamic Calc and Store. The member’s values are calculated at retrieval time instead of being precalculated during batch calculation.

**dynamic hierarchy**  In aggregate storage database outlines only, a hierarchy in which members are calculated at retrieval time.

**dynamic member list**  A system-created named member set that is based on user-defined criteria. The list is refreshed automatically whenever it is referenced in the application. As dimension members are added and deleted, the list automatically reapplies the criteria to reflect the changes.

**dynamic reference**  A pointer in the rules file to header records in a data source.

**dynamic report**  A report containing data that is updated when you run the report.

**Dynamic Time Series**  A process that performs period-to-date reporting in block storage databases.

**dynamic view account**  An account type indicating that account values are calculated dynamically from the data that is displayed.

**Eliminated Account**  An account that does not appear in the consolidated file.

**elimination**  The process of zeroing out (eliminating) transactions between entities within an organization.

**employee**  A user responsible for, or associated with, specific business objects. Employees need not work for an organization; for example, they can be consultants. Employees must be associated with user accounts for authorization purposes.

**encoding**  A method for mapping bit combinations to characters for creating, storing, and displaying text. Each encoding has a name; for example, UTF-8. Within an encoding, each character maps to a specific bit combination; for example, in UTF-8, uppercase A maps to HEX41. See also code page and locale.

**ending period**  A period enabling you to adjust the date range in a chart. For example, an ending period of “month”, produces a chart showing information through the end of the current month.
Enterprise View  An Administration Services feature that enables management of the Essbase environment from a graphical tree view. From Enterprise View, you can operate directly on Essbase artifacts.

entity  A dimension representing organizational units. Examples: divisions, subsidiaries, plants, regions, products, or other financial reporting units.

Equity Beta  The riskiness of a stock, measured by the variance between its return and the market return, indicated by an index called “beta”. For example, if a stock’s return normally moves up or down 1.2% when the market moves up or down 1%, the stock has a beta of 1.2.

essbase.cfg  An optional configuration file for Essbase. Administrators may edit this file to customize Essbase Server functionality. Some configuration settings may also be used with Essbase clients to override Essbase Server settings.

EssCell  A function entered into an Essbase Spreadsheet Add-in to retrieve a value representing an intersection of specific Essbase database members.

ESSCMD  A command-line interface for performing Essbase operations interactively or through batch script files.

ESSLANG  The Essbase environment variable that defines the encoding used to interpret text characters. See also encoding.

ESSMSH  See MaxL Shell.

exceptions  Values that satisfy predefined conditions. You can define formatting indicators or notify subscribing users when exceptions are generated.

exchange rate  A numeric value for converting one currency to another. For example, to convert 1 USD into EUR, the exchange rate of 0.8936 is multiplied with the U.S. dollar. The European euro equivalent of $1 is 0.8936.

exchange rate type  An identifier for an exchange rate. Different rate types are used because there may be multiple rates for a period and year. Users traditionally define rates at period end for the average rate of the period and for the end of the period. Additional rate types are historical rates, budget rates, forecast rates, and so on. A rate type applies to one point in time.

type account  An account that stores periodic and year-to-date values that decrease net worth if they are positive.

Extensible Markup Language (XML)  A language comprising a set of tags used to assign attributes to data that can be interpreted between applications according to a schema.

external authentication  Logging on to Oracle’s Hyperion applications with user information stored outside the applications, typically in a corporate directory such as MSAD or NTLM.

externally triggered events  Non-time-based events for scheduling job runs.

Extract, Transform, and Load (ETL)  Data source-specific programs for extracting data and migrating it to applications.

extraction command  An Essbase reporting command that handles the selection, orientation, grouping, and ordering of raw data extracted from a database; begins with the less than (<) character.

fact table  The central table in a star join schema, characterized by a foreign key and elements drawn from a dimension table. This table typically contains numeric data that can be related to all other tables in the schema.

field  An item in a data source file to be loaded into an Essbase database.

file delimiter  Characters, such as commas or tabs, that separate fields in a data source.

filter  A constraint on data sets that restricts values to specific criteria; for example, to exclude certain tables, metadata, or values, or to control access.

flow account  An unsigned account that stores periodic and year-to-date values.

folder  A file containing other files for the purpose of structuring a hierarchy.

footer  Text or images at the bottom of report pages, containing dynamic functions or static text such as page numbers, dates, logos, titles or file names, and author names.

format  Visual characteristics of documents or report objects.
**formula**  A combination of operators, functions, dimension and member names, and numeric constants calculating database members.

**frame**  An area on the desktop. There are two main areas: the navigation and workspace frames.

**free-form grid**  An object for presenting, entering, and integrating data from different sources for dynamic calculations.

**free-form reporting**  Creating reports by entering dimension members or report script commands in worksheets.

**function**  A routine that returns values or database members.

**generation**  A layer in a hierarchical tree structure that defines member relationships in a database. Generations are ordered incrementally from the top member of the dimension (generation 1) down to the child members.

**generation name**  A unique name that describes a generation.

**generic jobs**  Non-SQR Production Reporting or non-Interactive Reporting jobs.

**global report command**  A command in a running report script that is effective until replaced by another global command or the file ends.

**grid POV**  A means for specifying dimension members on a grid without placing dimensions in rows, columns, or page intersections. A report designer can set POV values at the grid level, preventing user POVs from affecting the grid. If a dimension has one grid value, you put the dimension into the grid POV instead of the row, column, or page.

**group**  A container for assigning similar access permissions to multiple users.

**GUI**  Graphical user interface

**highlighting**  Depending on your configuration, chart cells or ZoomChart details may be highlighted, indicating value status: red (bad), yellow (warning), or green (good).

**Historical Average**  An average for an account over a number of historical periods.

**holding company**  An entity that is part of a legal entity group, with direct or indirect investments in all entities in the group.

**host**  A server on which applications and services are installed.

**host properties**  Properties pertaining to a host, or if the host has multiple Install_Homes, to an Install_Home. The host properties are configured from the LSC.

**Hybrid Analysis**  An analysis mapping low-level data stored in a relational database to summary-level data stored in Essbase, combining the mass scalability of relational systems with multidimensional data.

**hyperlink**  A link to a file, Web page, or an intranet HTML page.

**Hypertext Markup Language (HTML)**  A programming language specifying how Web browsers display data.

**identity**  A unique identification for a user or group in external authentication.

**image bookmarks**  Graphic links to Web pages or repository items.

**IMPACTED status**  Indicates changes in child entities consolidating into parent entities.

**implied share**  A member with one or more children, but only one is consolidated, so the parent and child share a value.

**inactive group**  A group for which an administrator has deactivated system access.

**inactive service**  A service suspended from operating.

**INACTIVE status**  Indicates entities deactivated from consolidation for the current period.

**inactive user**  A user whose account has been deactivated by an administrator.

**income account**  An account storing periodic and year-to-date values that, if positive, increase net worth.

**index**  (1) A method where Essbase uses sparse-data combinations to retrieve data in block storage databases. (2) The index file.

**index cache**  A buffer containing index pages.
index entry A pointer to an intersection of sparse dimensions. Index entries point to data blocks on disk and use offsets to locate cells.

index file An Essbase file storing block storage data retrieval information, residing on disk, and containing index pages.

index page A subdivision in an index file. Contains pointers to data blocks.

input data Data loaded from a source rather than calculated.

Install_Home A variable for the directory where Oracle's Hyperion applications are installed. Refers to one instance of Oracle's Hyperion application when multiple applications are installed on the same computer.

integration Process that is run to move data between Oracle's Hyperion applications using Shared Services. Data integration definitions specify the data moving between a source application and a destination application, and enable the data movements to be grouped, ordered, and scheduled.

intelligent calculation A calculation method tracking updated data blocks since the last calculation.

Interactive Reporting connection file (.oce) Files encapsulating database connection information, including: the database API (ODBC, SQL*Net, etc.), database software, the database server network address, and database user name. Administrators create and publish Interactive Reporting connection files (.oce).

intercompany elimination See elimination.

intercompany matching The process of comparing balances for pairs of intercompany accounts within an application. Intercompany receivables are compared to intercompany payables for matches. Matching accounts are used to eliminate intercompany transactions from an organization's consolidated totals.

intercompany matching report A report that compares intercompany account balances and indicates if the accounts are in, or out, of balance.

interdimensional irrelevance A situation in which a dimension does not intersect with other dimensions. Because the data in the dimension cannot be accessed from the non-intersecting dimensions, the non-intersecting dimensions are not relevant to that dimension.

intersection A unit of data representing the intersection of dimensions in a multidimensional database; also, a worksheet cell.

Investigation See drill-through.

isolation level An Essbase Kernel setting that determines the lock and commit behavior of database operations. Choices are: committed access and uncommitted access.

iteration A “pass” of the budget or planning cycle in which the same version of data is revised and promoted.

Java Database Connectivity (JDBC) A client-server communication protocol used by Java based clients and relational databases. The JDBC interface provides a call-level API for SQL-based database access.

job output Files or reports produced from running a job.

job parameters Reusable, named job parameters that are accessible only to the user who created them.

jobs Documents with special properties that can be launched to generate output. A job can contain Interactive Reporting, SQR Production Reporting, or generic documents.

join A link between two relational database tables or topics based on common content in a column or row. A join typically occurs between identical or similar items within different tables or topics. For example, a record in the Customer table is joined to a record in the Orders table because the Customer ID value is the same in each table.

journal entry (JE) A set of debit/credit adjustments to account balances for a scenario and period.

JSP Java Server Pages.

latest A Spreadsheet key word used to extract data values from the member defined as the latest time period.

layer (1) The horizontal location of members in a hierarchical structure, specified by generation (top down) or level (bottom up). (2) Position of objects relative to other objects. For example, in the Sample Basic database, Qtr1 and Qtr4 are in the same layer, so they are also in the same generation, but in a database with a ragged hierarchy, Qtr1 and Qtr4 might not be in same layer, though they are in the same generation.
**legend box**  A box containing labels that identify the data categories of a dimension.

**level**  A layer in a hierarchical tree structure that defines database member relationships. Levels are ordered from the bottom dimension member (level 0) up to the parent members.

**level 0 block**  A data block for combinations of sparse, level 0 members.

**level 0 member**  A member that has no children.

**liability account**  An account type that stores “point in time” balances of a company's liabilities. Examples of liability accounts include accrued expenses, accounts payable, and long term debt.

**life cycle management**  The process of managing application information from inception to retirement.

**line chart**  A chart that displays one to 50 data sets, each represented by a line. A line chart can display each line stacked on the preceding ones, as represented by an absolute value or a percent.

**line item detail**  The lowest level of detail in an account.

**link**  (1) A reference to a repository object. Links can reference folders, files, shortcuts, and other links. (2) In a task flow, the point where the activity in one stage ends and another begins.

**link condition**  A logical expression evaluated by the taskflow engine to determine the sequence of launching taskflow stages.

**linked data model**  Documents that are linked to a master copy in a repository.

**linked partition**  A shared partition that enables you to use a data cell to link two databases. When a user clicks a linked cell in a worksheet, Essbase opens a new sheet displaying the dimensions in the linked database. The user can then drill down those dimensions.

**linked reporting object (LRO)**  A cell-based link to an external file such as cell notes, URLs, or files with text, audio, video, or pictures. (Only cell notes are supported for Essbase LROs in Financial Reporting.)

**local currency**  An input currency type. When an input currency type is not specified, the local currency matches the entity's base currency.

**local report object**  A report object that is not linked to a Financial Reporting report object in Explorer. *Contrast with linked reporting object (LRO).*

**local results**  A data model's query results. Results can be used in local joins by dragging them into the data model. Local results are displayed in the catalog when requested.

**locale**  A computer setting that specifies a location's language, currency and date formatting, data sort order, and the character set encoding used on the computer. Essbase uses only the encoding portion. *See also encoding and ESSLANG.*

**locale header record**  A text record at the beginning of some non-Unicode-encoded text files, such as scripts, that identifies the encoding locale.

**location alias**  A descriptor that identifies a data source. The location alias specifies a server, application, database, user name, and password. Location aliases are set by DBAs at the database level using Administration Services Console, ESSCMD, or the API.

**locked**  A user-invoked process that prevents users and processes from modifying data.

**locked data model**  Data models that cannot be modified by a user.

**LOCKED status**  A consolidation status indicating that an entity contains data that cannot be modified.

**Log Analyzer**  An Administration Services feature that enables filtering, searching, and analysis of Essbase logs.

**LRO**  *See linked reporting object (LRO).*

**LSC services**  Services configured with the Local Service Configurator. They include Global Services Manager (GSM), Local Services Manager (LSM), Session Manager, Authentication Service, Authorization Service, Publisher Service, and sometimes, Data Access Service (DAS) and Interactive Reporting Service.

**managed server**  An application server process running in its own Java Virtual Machine (JVM).
**Manual Stage**  A stage that requires human intervention to complete.

**Map File**  Used to store the definition for sending data to or retrieving data from an external database. Map files have different extensions (.mps to send data; .mpr to retrieve data).

**Map Navigator**  A feature that displays your current position on a Strategy, Accountability, or Cause and Effect map, indicated by a red outline.

**Marginal Tax Rate**  Used to calculate the after-tax cost of debt. Represents the tax rate applied to the last earned income dollar (the rate from the highest tax bracket into which income falls) and includes federal, state and local taxes. Based on current level of taxable income and tax bracket, you can predict marginal tax rate.

**Market Risk Premium**  The additional rate of return paid over the risk-free rate to persuade investors to hold “riskier” investments than government securities. Calculated by subtracting the risk-free rate from the expected market return. These figures should closely model future market conditions.

**Master Data Model**  An independent data model that is referenced as a source by multiple queries. When used, “Locked Data Model” is displayed in the Query section’s Content pane; the data model is linked to the master data model displayed in the Data Model section, which an administrator may hide.

**Mathematical Operator**  A symbol that defines how data is calculated in formulas and outlines. Can be any of the standard mathematical or Boolean operators; for example, +, -, *, /, and %.

**MaxL**  The multidimensional database access language for Essbase, consisting of a data definition language (MaxL DDL) and a data manipulation language (MaxL DML). See also MaxL DDL, MaxL DML, and MaxL Shell.

**MaxL DDL**  Data definition language used by Essbase for batch or interactive system-administration tasks.

**MaxL DML**  Data manipulation language used in Essbase for data query and extraction.

**MaxL Perl Module**  A Perl module (essbase.pm) that is part of Essbase MaxL DDL. This module can be added to the Perl package to provide access to Essbase databases from Perl programs.

**MaxL Script Editor**  A script-development environment in Administration Services Console. MaxL Script Editor is an alternative to using a text editor and the MaxL Shell for administering Essbase with MaxL scripts.

**MaxL Shell**  An interface for passing MaxL statements to Essbase Server. The MaxL Shell executable file is located in the Essbase bin directory (UNIX: essmsh, Windows: essmsh.exe).

**MDX (Multidimensional Expression)**  The language that gives instructions to OLE DB for OLAP-compliant databases, as SQL is used for relational databases. When you build the OLAPQuery section’s Outliner, Interactive Reporting Clients translate requests into MDX instructions. When you process the query, MDX is sent to the database server, which returns records that answer your query. See also SQL spreadsheet.

**Measures**  Numeric values in an OLAP database cube that are available for analysis. Measures are margin, cost of goods sold, unit sales, budget amount, and so on. See also fact table.

**Member**  A discrete component within a dimension. A member identifies and differentiates the organization of similar units. For example, a time dimension might include such members as Jan, Feb, and Qtr1.

**Member List**  A named group, system- or user-defined, that references members, functions, or member lists within a dimension.

**Member Load**  In Essbase Integration Services, the process of adding dimensions and members (without data) to Essbase outlines.

**Member Selection Report Command**  A type of Report Writer command that selects member ranges based on outline relationships, such as sibling, generation, and level.

**Member-Specific Report Command**  A type of Report Writer formatting command that is executed as it is encountered in a report script. The command affects only its associated member and executes the format command before processing the member.
merge A data load option that clears values only from the accounts specified in the data load file and replaces them with values in the data load file.

metadata A set of data that defines and describes the properties and attributes of the data stored in a database or used by an application. Examples of metadata are dimension names, member names, properties, time periods, and security.

metadata sampling The process of retrieving a sample of members in a dimension in a drill-down operation.

metadata security Security set at the member level to restrict users from accessing certain outline members.

metaoutline In Essbase Integration Services, a template containing the structure and rules for creating an Essbase outline from an OLAP model.

metric A numeric measurement computed from business data to help assess business performance and analyze company trends.

migration audit report A report generated from the migration log that provides tracking information for an application migration.

migration definition file (.mdf) A file that contains migration parameters for an application migration, enabling batch script processing.

migration log A log file that captures all application migration actions and messages.

migration snapshot A snapshot of an application migration that is captured in the migration log.

MIME Type (Multipurpose Internet Mail Extension) An attribute that describes the data format of an item, so that the system knows which application should open the object. A file's mime type is determined by the file extension or HTTP header. Plug-ins tell browsers what mime types they support and what file extensions correspond to each mime type.

mining attribute In data mining, a class of values used as a factor in analysis of a set of data.

minireport A report component that includes layout, content, hyperlinks, and the query or queries to load the report. Each report can include one or more minireports.

missing data (#MISSING) A marker indicating that data in the labeled location does not exist, contains no value, or was never entered or loaded. For example, missing data exists when an account contains data for a previous or future period but not for the current period.

model (1) In data mining, a collection of an algorithm's findings about examined data. A model can be applied against a wider data set to generate useful information about that data. (2) A file or content string containing an application-specific representation of data. Models are the basic data managed by Shared Services, of two major types: dimensional and non-dimensional application objects. (3) In Business Modeling, a network of boxes connected to represent and calculate the operational and financial flow through the area being examined.

monetary A money-related value.

multidimensional database A method of organizing, storing, and referencing data through three or more dimensions. An individual value is the intersection point for a set of dimensions.

named set In MaxL DML, a set with its logic defined in the optional WITH section of a MaxL DML query. The named set can be referenced multiple times in the query.

native authentication The process of authenticating a user name and password from within the server or application.

nested column headings A report column heading format that displays data from multiple dimensions. For example, a column heading that contains Year and Scenario members is a nested column. The nested column heading shows Q1 (from the Year dimension) in the top line of the heading, qualified by Actual and Budget (from the Scenario dimension) in the bottom line of the heading.

NO DATA status A consolidation status indicating that this entity contains no data for the specified period and account.

non-dimensional model A Shared Services model type that includes application objects such as security files, member lists, calculation scripts, and Web forms.

non-unique member name See duplicate member name.

note Additional information associated with a box, measure, scorecard or map element.
null value  A value that is absent of data. Null values are not equal to zero.

numeric attribute range  A feature used to associate a base dimension member that has a discrete numeric value with an attribute that represents a value range. For example, to classify customers by age, an Age Group attribute dimension can contain members for the following age ranges: 0-20, 21-40, 41-60, and 61-80. Each Customer dimension member can be associated with an Age Group range. Data can be retrieved based on the age ranges rather than on individual age values.

ODBC  Open Database Connectivity. A database access method used from any application regardless of how the database management system (DBMS) processes the information.

OK status  A consolidation status indicating that an entity has already been consolidated, and that data has not changed below it in the organization structure.

OLAP Metadata Catalog  In Essbase Integration Services, a relational database containing metadata describing the nature, source, location, and type of data that is pulled from the relational data source.

OLAP model  In Essbase Integration Services, a logical model (star schema) that is created from tables and columns in a relational database. The OLAP model is then used to generate the structure of a multidimensional database.

online analytical processing (OLAP)  A multidimensional, multiuser, client-server computing environment for users who analyze consolidated enterprise data in real time. OLAP systems feature drill-down, data pivoting, complex calculations, trend analysis, and modeling.

Open Database Connectivity (ODBC)  Standardized application programming interface (API) technology that allows applications to access multiple third-party databases.

organization  An entity hierarchy that defines each entity and their relationship to others in the hierarchy.

origin  The intersection of two axes.

outline  The database structure of a multidimensional database, including all dimensions, members, tags, types, consolidations, and mathematical relationships. Data is stored in the database according to the structure defined in the outline.

outline synchronization  For partitioned databases, the process of propagating outline changes from one database to another database.

P&L accounts (P&L)  Profit and loss accounts. Refers to a typical grouping of expense and income accounts that comprise a company’s income statement.

page  A display of information in a grid or table often represented by the Z-axis. A page can contain data from one field, derived data from a calculation, or text.

page file  Essbase data file.

page heading  A report heading type that lists members represented on the current page of the report. All data values on the page have the members in the page heading as a common attribute.

page member  A member that determines the page axis.

palette  A JASC compliant file with a .PAL extension. Each palette contains 16 colors that complement each other and can be used to set the dashboard color elements.

parallel calculation  A calculation option. Essbase divides a calculation into tasks and calculates some tasks simultaneously.

parallel data load  In Essbase, the concurrent execution of data load stages by multiple process threads.

parallel export  The ability to export Essbase data to multiple files. This may be faster than exporting to a single file, and it may resolve problems caused by a single data file becoming too large for the operating system to handle.

parent adjustments  The journal entries that are posted to a child in relation to its parent.

parents  The entities that contain one or more dependent entities that report directly to them. Because parents are both entities and associated with at least one node, they have entity, node, and parent information associated with them.

partition area  A subcube within a database. A partition is composed of one or more areas of cells from a portion of the database. For replicated and transparent partitions, the number of cells within an area must be the same for the data source and target to ensure that the two partitions have the same shape. If the data source area contains 18 cells, the data target area must also contain 18 cells to accommodate the number of values.
partitioning The process of defining areas of data that are shared or linked between data models. Partitioning can affect the performance and scalability of Essbase applications.

pattern matching The ability to match a value with any or all characters of an item entered as a criterion. Missing characters may be represented by wild card values such as a question mark (?) or an asterisk (*). For example, “Find all instances of apple” returns apple, but “Find all instances of apple*” returns apple, applesauce, applecranberry, and so on.

percent consolidation The portion of a child’s values that is consolidated to its parent.

percent control Identifies the extent to which an entity is controlled within the context of its group.

percent ownership Identifies the extent to which an entity is owned by its parent.

performance indicator An image file used to represent measure and scorecard performance based on a range you specify; also called a status symbol. You can use the default performance indicators or create an unlimited number of your own.

periodic value method (PVA) A process of currency conversion that applies the periodic exchange rate values over time to derive converted results.

permission A level of access granted to users and groups for managing data or other users and groups.

perspective A category used to group measures on a scorecard or strategic objectives within an application. A perspective can represent a key stakeholder (such as a customer, employee, or shareholder/financial) or a key competency area (such as time, cost, or quality).

pie chart A chart that shows one data set segmented in a pie formation.

pinboard One of the three data object display types. Pinboards are graphics, composed of backgrounds and interactive icons called pins. Pinboards require traffic lighting definitions.

pins Interactive icons placed on graphic reports called pinboards. Pins are dynamic. They can change images and traffic lighting color based on the underlying data values and analysis tools criteria.

pivot The ability to alter the perspective of retrieved data. When Essbase first retrieves a dimension, it expands data into rows. You can then pivot or rearrange the data to obtain a different viewpoint.

planner Planners, who comprise the majority of users, can input and submit data, use reports that others create, execute business rules, use task lists, enable e-mail notification for themselves, and use Smart View.

planning unit A data slice at the intersection of a scenario, version, and entity; the basic unit for preparing, reviewing, annotating, and approving plan data.

plot area The area bounded by X, Y, and Z axes; for pie charts, the rectangular area surrounding the pie.

plug account An account in which the system stores any out of balance differences between intercompany account pairs during the elimination process.

POV (point of view) A feature for working with dimension members not assigned to row, column, or page axes. For example, you could assign the Currency dimension to the POV and select the Euro member. Selecting this POV in data forms displays data in Euro values.

precalculation Calculating the database prior to user retrieval.

precision Number of decimal places displayed in numbers.

predefined drill paths Paths used to drill to the next level of detail, as defined in the data model.
**presentation**  A playlist of Web Analysis documents, enabling reports to be grouped, organized, ordered, distributed, and reviewed. Includes pointers referencing reports in the repository.

**preserve formulas**  User-created formulas kept within a worksheet while retrieving data.

**primary measure**  A high-priority measure important to your company and business needs. Displayed in the Contents frame.

**product**  In Shared Services, an application type, such as Planning or Performance Scorecard.

**Production Reporting**  See SQR Production Reporting.

**project**  An instance of Oracle’s Hyperion products grouped together in an implementation. For example, a Planning project may consist of a Planning application, an Essbase cube, and a Financial Reporting Server instance.

**promote**  The action to move a data unit to the next review level, allowing a user having the appropriate access to review the data. For example, an analyst may promote the data unit to the next level for his supervisor’s review.

**promotion**  The process of transferring artifacts from one environment or machine to another; for example, from a testing environment to a production environment.

**property**  A characteristic of an artifact, such as size, type, or processing instructions.

**provisioning**  The process of granting users and groups specific access permissions to resources.

**proxy server**  A server acting as an intermediary between workstation users and the Internet to ensure security.

**public job parameters**  Reusable, named job parameters created by administrators and accessible to users with requisite access privileges.

**public recurring time events**  Reusable time events created by administrators and accessible through the access control system.

**PVA**  See periodic value method (PVA).

**qualified name**  A member name in a qualified format that differentiates duplicate member names in a duplicate member outline. For example, [Market].[East].[State]. [New York] or [Market].[East].[City].[New York].

**query**  Information requests from data providers. For example, used to access relational data sources.

**query governor**  An Essbase Integration Server parameter or Essbase Server configuration setting that controls the duration and size of queries made to data sources.

**range**  A set of values including upper and lower limits, and values falling between limits. Can contain numbers, amounts, or dates.

**reconfigure URL**  URL used to reload servlet configuration settings dynamically when users are already logged on to the Workspace.

**record**  In a database, a group of fields making up one complete entry. For example, a customer record may contain fields for name, address, telephone number, and sales data.

**recurring template**  A journal template for making identical adjustments in every period.

**recurring time event**  An event specifying a starting point and the frequency for running a job.

**redundant data**  Duplicate data blocks that Essbase retains during transactions until Essbase commits updated blocks.

**regular journal**  A feature for entering one-time adjustments for a period. Can be balanced, balanced by entity, or unbalanced.

**Related Accounts**  The account structure groups all main and related accounts under the same main account number. The main account is distinguished from related accounts by the first suffix of the account number.

**relational database**  A type of database that stores data in related two-dimensional tables. Contrast with multidimensional database.

**replace**  A data load option that clears existing values from all accounts for periods specified in the data load file, and loads values from the data load file. If an account is not specified in the load file, its values for the specified periods are cleared.

**replicated partition**  A portion of a database, defined through Partition Manager, used to propagate an update to data mastered at one site to a copy of data stored at another site. Users can access the data as though it were part of their local database.
Report Extractor  An Essbase component that retrieves report data from the Essbase database when report scripts are run.

report object  In report designs, a basic element with properties defining behavior or appearance, such as text boxes, grids, images, and charts.

report script  A text file containing Essbase Report Writer commands that generate one or more production reports.

Report Viewer  An Essbase component that displays complete reports after report scripts are run.

reporting currency  The currency used to prepare financial statements, and converted from local currencies to reporting currencies.

repository  Stores metadata, formatting, and annotation information for views and queries.

resources  Objects or services managed by the system, such as roles, users, groups, files, and jobs.

restore  An operation to reload data and structural information after a database has been damaged or destroyed, typically performed after shutting down and restarting the database.

restructure  An operation to regenerate or rebuild the database index and, in some cases, data files.

result frequency  The algorithm used to create a set of dates to collect and display results.

review level  A Process Management review status indicator representing the process unit level, such as Not Started, First Pass, Submitted, Approved, and Published.

Risk Free Rate  The rate of return expected from “safer” investments such as long-term U.S. government securities.

role  The means by which access permissions are granted to users and groups for resources.

roll-up  See consolidation.

root member  The highest member in a dimension branch.

row heading  A report heading that lists members down a report page. The members are listed under their respective row names.

RSC services  Services that are configured with Remote Service Configurator, including Repository Service, Service Broker, Name Service, Event Service, and Job Service.

rules  User-defined formulas.

runtime prompt  A variable that users enter or select before a business rule is run.

sampling  The process of selecting a representative portion of an entity to determine the entity’s characteristics. See also metadata sampling.

saved assumptions  User-defined Planning assumptions that drive key business calculations (for example, the cost per square foot of office floor space).

scale  The range of values on the Y axis of a chart.

scaling  Scaling determines the display of values in whole numbers, tens, hundreds, thousands, millions, and so on.

scenario  A dimension for classifying data (for example, Actuals, Budget, Forecast1, and Forecast2).

schedule  Specify the job that you want to run and the time and job parameter list for running the job.

scope  The area of data encompassed by any Essbase operation or setting; for example, the area of data affected by a security setting. Most commonly, scope refers to three levels of granularity, where higher levels encompass lower levels. From highest to lowest, these levels are as follows: the entire system (Essbase Server), applications on Essbase Server, or databases within Essbase Server applications. See also persistence.

score  The level at which targets are achieved, usually expressed as a percentage of the target.

scorecard  Business Object that represents the progress of an employee, strategy element, or accountability element toward goals. Scorecards ascertain this progress based on data collected for each measure and child scorecard added to the scorecard.

scorecard report  A report that presents the results and detailed information about scorecards attached to employees, strategy elements, and accountability elements.
**secondary measure**  A low-priority measure, less important than primary measures. Secondary measures do not have Performance reports but can be used on scorecards and to create dimension measure templates.

**Section pane**  Lists all sections that are available in the current Interactive Reporting Client document.

**security agent**  A Web access management provider (for example, Netegrity SiteMinder) that protects corporate Web resources.

**security platform**  A framework enabling Oracle's Hyperion applications to use external authentication and single sign-on.

**serial calculation**  The default calculation setting Essbase divides a calculation pass into tasks and calculates one task at a time.

**services**  Resources that enable business items to be retrieved, changed, added, or deleted. Examples: Authorization and Authentication.

**servlet**  A piece of compiled code executable by a Web server.

**Servlet Configurator**  A utility for configuring all locally installed servlets.

**session**  The time between login and logout for a user connected to Essbase Server.

**set**  In MaxL DML, a required syntax convention for referring to a collection of one or more tuples. For example, in the following MaxL DML query, \[ SELECT \{ [100-10] \} ON COLUMNS FROM Sample.Basic \{ [100-10] \} \] is a set.

**shared member**  A member that shares storage space with another member of the same name, preventing duplicate calculation of members that occur multiple times in an Essbase outline.

**Shared Services**  Application enabling users to share data between supported Oracle's Hyperion products by publishing data to Shared Services and running data integrations.

**sibling**  A child member at the same generation as another child member and having the same immediate parent. For example, the members Florida and New York are children of East and each other's siblings.

**single sign-on**  Ability to access multiple Oracle's Hyperion products after a single login using external credentials.

**slicer**  In MaxL DML, the section at the end of a query that begins with and includes the keyword WHERE.

**smart tags**  Keywords in Microsoft Office applications that are associated with predefined actions available from the Smart Tag menu. In Oracle's Hyperion applications, smart tags can also be used to import Reporting and Analysis content, and access Financial Management and Essbase functions.

**SmartCut**  A link to a repository item, in URL form.

**snapshot**  Read-only data from a specific time.

**source currency**  The currency from which values originate and are converted through exchange rates to the destination currency.

**sparse dimension**  In block storage databases, a dimension unlikely to contain data for all member combinations when compared to other dimensions. For example, not all customers have data for all products.

**SPF files**  Printer-independent files created by a SQR Production Reporting server, containing a representation of the actual formatted report output, including fonts, spacing, headers, footers, and so on.

**Spotlighter**  A tool that enables color coding based on selected conditions.

**SQL spreadsheet**  A data object that displays the result set of a SQL query.

**SQR Production Reporting**  A specialized programming language for data access, data manipulation, and creating SQR Production Reporting documents.

**stacked charts**  A chart where the categories are viewed on top of one another for visual comparison. This type of chart is useful for subcategorizing within the current category. Stacking can be used from the Y and Z axis in all chart types except pie and line. When stacking charts the Z axis is used as the Fact/Values axis.

**stage**  A task description that forms one logical step within a taskflow, usually performed by an individual. A stage can be manual or automated.
stage action For automated stages, the invoked action that executes the stage.

standard dimension A dimension that is not an attribute dimension.

standard journal template A journal function used to post adjustments that have common adjustment information for each period. For example, you can create a standard template that contains the common account IDs, entity IDs, or amounts, then use the template as the basis for many regular journals.

Standard Template The Standard template is the basis for the basic Strategic Finance file. The Standard template contains all default settings. All new files are created from the Standard template unless another template is selected.

Start in Play The quickest method for creating a Web Analysis document. The Start in Play process requires you to specify a database connection, then assumes the use of a spreadsheet data object. Start in Play uses the highest aggregate members of the time and measures dimensions to automatically populate the rows and columns axes of the spreadsheet.

Status bar The status bar at the bottom of the screen displays helpful information about commands, accounts, and the current status of your data file.

stored hierarchy In aggregate storage databases outlines only. A hierarchy in which the members are aggregated according to the outline structure. Stored hierarchy members have certain restrictions, for example, they cannot contain formulas.

strategic objective (SO) A long-term goal defined by measurable results. Each strategic objective is associated with one perspective in the application, has one parent, the entity, and is a parent to critical success factors or other strategic objectives.

Strategy map Represents how the organization implements high-level mission and vision statements into lower-level, constituent strategic goals and objectives.

structure view Displays a topic as a simple list of component data items.

Structured Query Language A language used to process instructions to relational databases.

Subaccount Numbering A system for numbering subaccounts using non-sequential, whole numbers.

subscribe Flags an item or folder to receive automatic notification whenever the item or folder is updated.

Summary chart In the Investigates Section, rolls up detail charts shown below in the same column, plotting metrics at the summary level at the top of each chart column.

super service A special service used by the startCommonServices script to start the RSC services.

supervisor A user with full access to all applications, databases, related files, and security mechanisms for a server.

supporting detail Calculations and assumptions from which the values of cells are derived.

suppress rows Excludes rows containing missing values, and underscores characters from spreadsheet reports.

symmetric multiprocessing (SMP) A server architecture that enables multiprocessing and multithreading. Performance is not significantly degraded when a large number of users connect to an single instance simultaneously.

sync Synchronizes Shared Services and application models.

synchronized The condition that exists when the latest version of a model resides in both the application and in Shared Services. See also model.

system extract Transfers data from an application’s metadata into an ASCII file.

tabs Navigable views of accounts and reports in Strategic Finance.

target Expected results of a measure for a specified period of time (day, quarter, etc.,)

task list A detailed status list of tasks for a particular user.

taskflow The automation of a business process in which tasks are passed from one taskflow participant to another according to procedural rules.
taskflow definition  Represents business processes in the taskflow management system. Consists of a network of stages and their relationships; criteria indicating the start and end of the taskflow; and information about individual stages, such as participants, associated applications, associated activities, and so on.

taskflow instance  Represents a single instance of a taskflow including its state and associated data.

taskflow management system  Defines, creates, and manages the execution of a taskflow including: definitions, user or application interactions, and application executables.

taskflow participant  The resource who performs the task associated with the taskflow stage instance for both manual and automated stages.

Taxes - Initial Balances  Strategic Finance assumes that the Initial Loss Balance, Initial Gain Balance and the Initial Balance of Taxes Paid entries have taken place in the period before the first Strategic Finance time period.

TCP/IP  See *Transmission Control Protocol/Internet Protocol (TCP/IP)*.

template  A predefined format designed to retrieve particular data consistently.

time dimension  Defines the time period that the data represents, such as fiscal or calendar periods.

time events  Triggers for execution of jobs.

time scale  Displays metrics by a specific period in time, such as monthly or quarterly.

time series reporting  A process for reporting data based on a calendar date (for example, year, quarter, month, or week).

Title bar  Displays the Strategic Finance name, the file name, and the scenario name Version box.

token  An encrypted identification of one valid user or group on an external authentication system.

top and side labels  Column and row headings on the top and sides of a Pivot report.

top-level member  A dimension member at the top of the tree in a dimension outline hierarchy, or the first member of the dimension in sort order if there is no hierarchical relationship among dimension members. The top-level member name is generally the same as the dimension name if a hierarchical relationship exists.

trace level  Defines the level of detail captured in the log file.

traffic lighting  Color-coding of report cells, or pins based on a comparison of two dimension members, or on fixed limits.

transformation  (1) Transforms artifacts so that they function properly in the destination environment after application migration. (2) In data mining, modifies data (bidirectionally) flowing between the cells in the cube and the algorithm.

translation  See *currency conversion*.

Transmission Control Protocol/Internet Protocol (TCP/IP)  A standard set of communication protocols linking computers with different operating systems and internal architectures. TCP/IP utilities are used to exchange files, send mail, and store data to various computers that are connected to local and wide area networks.

transparent login  Logs in authenticated users without launching the login screen.

transparent partition  A shared partition that enables users to access and change data in a remote database as though it is part of a local database.

triangulation  A means of converting balances from one currency to another via a third common currency. In Europe, this is the euro for member countries. For example, to convert from French franc to Italian lira, the common currency is defined as European euro. Therefore, in order to convert balances from French franc to Italian lira, balances are converted from French franc to European euro and from European euro to Italian lira.

triggers  An Essbase feature whereby data is monitored according to user-specified criteria which when met cause Essbase to alert the user or system administrator.

trusted password  A password that enables users authenticated for one product to access other products without reentering their passwords.
trusted user  Authenticated user

tuple  MDX syntax element that references a cell as an intersection of a member from each dimension. If a dimension is omitted, its top member is implied. Examples: (Jan); (Jan, Sales); (Jan, [Sales], [Cola], [Texas], [Actual])

two-pass  An Essbase property that is used to recalculate members that are dependent on the calculated values of other members. Two-pass members are calculated during a second pass through the outline.

Unary operator  A mathematical indicator (+, -, *, /, %) associated with an outline member. The unary operator defines how the member is calculated during a database rollup.

Unicode-mode application  An Essbase application wherein character text is encoded in UTF-8, enabling users with computers set up for different languages to share application data.

Unique member name  A non-shared member name that exists only once in a database outline.

Unique member outline  A database outline that is not enabled for duplicate member names.

Upper-level block  A type of data block wherein at least one of the sparse members is a parent-level member.

User directory  A centralized location for user and group information. Also known as a repository or provider.

User variable  Dynamically renders data forms based on a user's member selection, displaying only the specified entity. For example, user variable named Department displays specific departments and employees.

User-defined attribute (UDA)  User-defined attribute, associated with members of an outline to describe a characteristic of the members. Users can use UDAs to return lists of members that have the specified UDA associated with them.

User-defined member list  A named, static set of members within a dimension defined by the user.

Validation  A process of checking a business rule, report script, or partition definition against the outline to make sure that the object being checked is valid.

Value dimension  Used to define input value, translated value, and consolidation detail.

Variance  Difference between two values (for example, planned and actual value).

Version  Possible outcome used within the context of a scenario of data. For example, Budget - Best Case and Budget - Worst Case where Budget is scenario and Best Case and Worst Case are versions.

View  Representation of either a year-to-date or periodic display of data.

Visual cue  A formatted style, such as a font or a color, that highlights specific types of data values. Data values may be dimension members; parent, child, or shared members; dynamic calculations; members containing a formula; read only data cells; read and write data cells; or linked objects.

Web server  Software or hardware hosting intranet or Internet Web pages or Web applications.

Weight  Value assigned to an item on a scorecard that indicates the relative importance of that item in the calculation of the overall scorecard score. The weighting of all items on a scorecard accumulates to 100%. For example, to recognize the importance of developing new features for a product, the measure for New Features Coded on a developer’s scorecard would be assigned a higher weighting than a measure for Number of Minor Defect Fixes.

Wild card  Character that represents any single character (?) or group of characters (*) in a search string.

WITH section  In MaxL DML, an optional section of the query used for creating re-usable logic to define sets or members. Sets or custom members can be defined once in the WITH section, and then referenced multiple times during a query.

Workbook  An entire spreadsheet file with many worksheets.

Write-back  The ability for a retrieval client, such as a spreadsheet, to update a database value.

WS.conf  A configuration file for Windows platforms.

wsconf_platform  A configuration file for UNIX platforms.

XML  See Extensible Markup Language (XML)
**Y axis scale**  Range of values on Y axis of charts displayed in Investigate Section. For example, use a unique Y axis scale for each chart, the same Y axis scale for all Detail charts, or the same Y axis scale for all charts in the column. Often, using a common Y axis improves your ability to compare charts at a glance.

**Zero Administration**  Software tool that identifies version number of the most up-to-date plug-in on the server.

**zoom**  Sets the magnification of a report. For example, magnify a report to fit whole page, page width, or percentage of magnification based on 100%.

**ZoomChart**  Used to view detailed information by enlarging a chart. Enables you to see detailed numeric information on the metric that is displayed in the chart.
Index

Essbase, 489
Interactive Reporting Web Client: opening in multiple browser windows, 531
applying measure filters, 167
attribute dimensions, 154
auditing, 493
command language, 23
connecting to, 428
display options, 156
options, 67
query language, 23
quitting, 66
substitution variables, 169

Symbols
% of Category function, 317
% of Grand function, 264
(), 329
Interactive Reporting Web Client, dbgprint and, 525
.bqtools.ini, 82
.css, 85
.csv, 43, 48
.gif, 85
.htm, 85
.jpg, 85
.sql, 64
.txt, 43, 48
.xls, 48
:COLALIAS, 449, 451, 452, 454
:COLUMN, 449
:LOOKUPID, 449, 453
:OWNER, 449, 451, 452, 454
:QUERYSQL, 496
:REPOSITORYNAME, 496
:ROWSRETRIEVED, 496
:SILENT, 496
:TABALIAS, 449, 451, 452, 454

:TABLE, 449, 451, 452, 454
=, 332
\<, 332
\<\=, 332
\<\>, 332
\>, 333
\\>=, 333

Numbers
2-D bar charts, 254
2-D bar charts, using to analyze data, 254
3-D bar charts, 256
3-D View, 255

A
Abs function, 355
access, topic view, setting, 472
accessing
Open Metadata Interpreter, 447
Add Computed Item command, 123, 141, 150, 242, 288, 325
Add Cume command, 242
Add Date Group command, 141, 151
Add Fact/Measure command, 177
Add Filter(s) command, 123
Add Grouping Column command, 141, 151
Add Meta Topic Item command, 479
Add Request Item(s) command, 123
Add Selected Items command, 242
Add Side Label command, 176
Add Sort(s) command, 123
Add to Columns in CubeQuery section, 222
Add to Filters in CubeQuery section, 223
Add to Rows in CubeQuery section, 222
Add Top Label command, 177
Add Totals command, 242
adding
computed items, 347
footers, 72
headers, 72
metadata definitions, 448
remarks from stored metadata, 454
sections, 70
topics to data models, 458
adding computed items, 146, 265, 313
adding date groups, 148
adding grouping columns, 147
adding lines to labels, 249
adding other report elements, 304
adding report groups, 298
AddMonths function, 353
Administer Repository command, 83
Administer Repository dialog box, 482
administering
documents, in IBM Information Catalog, 502
IBM Information Catalog, 501
Interactive Reporting repositories, 482
repository groups, 485
Aggregating Local Results tables, 468
aggregation, 24, 105
alias, 203
table, 203
using, 203
aliases, specifying table and column in SQL, 449, 451, 452, 454
Allow Drill Anywhere option, 474
Allow Drill To Detail option, 474
analyzing data based on day of week data, 368
AND, 329
API software, 420
Append Query command, 124
Append Query command, local results and, 469
applying
metadatato limit values, 452
metadata names to data model topic items, 450
metadata names to data model topics, 449
metadata to limit lookup values, 453
applying data functions to tables, 148
area charts, 258, 259
ascending sorts, 150, 288, 325
Asciifunction, 359
Attn function, 355
audit events
defining, 494, 495
eexamples, 496
samples, 496
testing, 493
audit events, defining, 494
audit log, monitoring, 493
audit table
creating, 494
sample structure, 494
auditing
keyword variables, 495
where not supported, 493
Auto Alias Tables option, 474
Auto Join Tables option, 461, 474
Auto Logon command, 433
Auto-Process command, 478
AutoAdd Columns command, 142
Automatic data type, 343
automatically adding columns command, 136
Average function, 149, 264, 316
Avg function, 373
Avgfunction, 357
AvgNonNull function, 374
AvgNonNullfunction, 357
axes, 244
axis grid lines, showing, 270

B
bar, 244
bar charts
2-D, 254
3-D, 256
clustered, properties, 283
properties, 283
stacked, 258
three-dimensional, 256
two-dimensional, 254
bar-line charts, properties, 283
BEGINSWITH, 333
benefits of data models, 457
Best Guess join strategy, 462
BETWEEN, 333
blank documents, 433
BQAUDIT table, sample structure, 494
bqmeta0.ini, 448, 450
bqtbls5.ini, 105
bqtools.ini, 82
BQY, 499
Break Total command, 142, 151
break total data functions, 148
break totals, 134, 149
bridge tables, 464
brioquery.exe, installation location, 524
BRIOSECP table, 510
browser restrictions and limitations, 63
building queries, confusing aspects, 443
Byte data type, 343
C
cascading style sheets, 85
Ceil function, 355
changing
data model views, 472
database passwords, 435
join types, 463
topic views, 469
changing chart color schemes and fill patterns, 284
changing chart data labels, 285
changing chart legends, 271
changing color of chart elements, lines, and text, 287
changing column names, 297
changing label nesting levels, 228
chart angle and elevation, changing, 274
chart elements, working with, 248
chart label properties, 280
Chart menu commands, 288
chart properties, changing, 278
Chart section, 243
  applying sorts in, 265
  computed items, 265
  Outliner, 246
Chart This Pivot command, 226
charting basics, 243
charts, 31. See also Data Analysis and Reporting with Interactive Reporting
  adding computed items, 265
  adding lines to labels, 249
  area, 258
  building, 246
  combination, 262
  creating, 246
  creating from pivot tables, 226
Data Layout, 246
  inserting text, 271
  line charts, 260
  multidimensional, 255
  pie charts, 248
  pivoting, 267
  ribbon charts, 259
  sorting, 31
  stacked bar, 258
  terminology, 243
  three-dimensional, 255
  three-dimensional bar, 256
tywo-dimensional, 247
two-dimensional bar, 254
chr function, 357
clustered bar charts
  properties, 283
  understanding, 257
COLALIAS, 449, 451, 452, 454
ColMax function, 376
ColMaxfunction, 357
ColMin function, 377
ColMinfunction, 357
color, adding, 30
color, changing in charts, 287
COLUMN, 449
column aliases, specifying in SQL, 449, 451, 452, 454
Column commands
  Add Grouping, 151
  Hide, 151, 288, 325
  Modify, 151
  Unhide, 151, 288, 325
Column Name function, 316
column names
  changing, 297
  hiding, 297
column totals, 149
columns, 27, 137, 150, 297, 298, 311
columns, usage statistics, 493
combination charts, 262, 283
combined view, of data models, 472
combining limit local joins with local joins, 468
comma-delimited files, 43, 48
commands
  Chart menu, 288
  formatting, 138
  Pivot menu, 242, 378
  Report menu, 324
  Results menu, 141
  Table menu, 150
Tools menu, 83
commands, DataModel menu, 479
comparing related values, 263
complex sorting
  in OLAPQuery section, 415
  in Query, Results, and Table sections, 415
components, report, 297
compressing documents, 37
computed fields, 306, 307
Computed Items, 341
computed items
  adding, 150, 288, 325, 347
  Chart section, 265
  compared to data functions, 346
  examples, 368
  in Interactive Reporting document sections, 342
  in OLAP queries, 162
  in Query section, 342
  in Results and report sections, 343
  Report section, 313
  Table section, 146
computed items, and local results, 468
computed metatopic items, creating, 445
computing new data, 341
concatenating report element syntax, 295
Concatfunction, 359
confirming repository table creation, 483
connecting
  databases, 431
  OLE DB Provider, 428
  Essbase or DB2 OLAP, 428
  with data model, 432
  without data model, 432
Connection commands, 83
connection information, 420
connection parameters, 419, 421
connection preferences
  modifying, 430
  setting, 422
connections
  directory, accessing, 433
  monitoring, 431
Connections Manager, 434
Connections Manager command, 83
connectivity-related problems, troubleshooting, 523
CONTAINS, 333
contents, document, 21
controlling document versions, 491
copying
  topic items to metatopics, 444
correlated subqueries, 97
Cosfunction, 355
Coshfunction, 355
Count function, 149, 264, 316
CountDistinctfunction, 357
Countfunction, 355, 357
CountNonNullfunction, 357
CountNullfunction, 357
creating
  charts, 246
  custom reports, 296
Interactive Reporting database connections, 421
log tables, 494
metatopics, 444
object type properties, 501
OLAP connection files, 428
pivot tables, 225
pivot tables from charts, 267
repository objects, 486
repository tables, 482
smart reports, 321
three-dimensional bar charts, 256
creating documents, 65
CSS files, 85
CSV files, 43, 48
CubeQuery, 179
  Catalog, 183
CubeQuery Commands, 222
CubeQuery Drill options
  Drill All Descendants, 223
  Drill Bottom, 223
  Drill Down, 223
  Drill Next, 223
  Drill Same Generation, 223
  Drill Same Level, 223
  Drill Sibling, 223
  Drill Up, 223
CubeQuery section
  alias, 203
  building, 185
data filters, 196
display options, 203
drill options, 204
dynamic time series, 188
global options, 202
member selection, 186
missing label, 203
query options, 202
Select Next/Previous, 194
subsets, 191
Cumefunction
definition, 357
custom formats, server date, 427
custom functions, 149
custom join strategy, 462
custom menu items, 80
custom totals, inserting, 133, 148
custom values, 332
Custom Values limit option, 476
Customize command, 84
Customize Filter command, 124
customizing chart patterns, colors, and labels, 284
customizing chart properties and labels, 278
customizing filter options, 337
customizing metatopics, 446

D
data
calculating, 28
charting, 30
exporting, 47
filtering, 28
hiding, 30
importing, 43
pivoting, 28
refining in OLAPQuery, 159
Data Filters, 196
data filters
persisting in the query, 201
setting conditions for values, 200
show/hide, 196
sort, 196
top n/bottom n, 196
Data Function command, 242, 288, 325
data functions
compared to computed items, 346
in charts, 264
in custom reports, 316
in OLAP queries, 173
in queries, 106
Data Functions command, 124, 177
Data Layout
Chart section, 246, 247
Pivot section, 227
Table section, 143
data layout
differences between OLAPQuery and CubeQuery, 184
Data Model menu commands, 479
data model options
auditing, 477
design, 474
general, 474
joins, 476
limits, 475
topic priority, 476
Data Model Refresh audit event, 497
Data Model Synchronization dialog box, 479
data models, 22
adding topics to, 458
automatically processing, 478
benefits, 457
BRIOCAT2 table, 489
BRIOOBJ2 table, 490
changing topic views, 469
connecting with or without, 432
definition, 481
ensuring integrity, 479
governors, 475
joins, 459
looking up metadata definitions, 452
master, 478
removing topics from, 459
simplifying, 444
synchronizing, 478, 479
topic priority options, 476
uploading to repository, 486
version-controlled, 481
viewing at metatopic level, 444
data source connections, 21
data sources
ODBC, 420
data sources, working with, 41
data types, 127
data, computing, 341
data, pivoting, 226
database
definition, 20
displaying remarks, 105
viewing tables, 26
Interactive Reporting database connection file, 21
creating OLAP, 428
default directory, 421
definition, 419
Database Connection Wizard, 420, 421
Interactive Reporting database connections
choosing, 431
database joins, 459
database tables
in data models, 458
metadata definitions, 449
database tables and columns, usage statistics, 493
database variables, 449, 451, 452, 453, 454
databases
aliases, 420
changing password in Interactive Reporting Web Client, 436
changing passwords in Interactive Reporting Studio, 435
connecting, 431
logging off, 435
logging on, 434
planning changes, 493
user name, 420
using joins in, 459
DATAMODEL column, in sample BQAUDIT table, 494
Date & Time field, 307
Date & Time Now field, 307
Date command, 73
Date data type, 343
Date field, 307
Date Group command, Add, 151
date handling, 76
Date Now field, 307
Date Time Series, 188
dates, breakout columns, 137, 148
day of week, returning, 367
DAY_EXECUTED column, in sample BQAUDIT table, 494
DayOfMonth function, 353
DB2 OLAP, connecting to, 428
dbgprint
Interactive Reporting Web Client and, 525
connectivity troubleshooting with, 523
overwriting files, 524
Decode function, 353
default function, 73
default Interactive Reporting database connections,
setting, 433
default settings, simple joins, 463
deferring Interactive Reporting Web Client
connections, 439
defined join paths, using, 464
defining
audit events, 494
metadata, 448
properties in IBM Information Catalog, 500
deleting
joins, 464
object types and properties in IBM Information Catalog, 502
Remarks tabs, 455
repository objects, 484
deleting columns, 150
deleting sections, 72
descending sorts, 150
design guides, 309
Design Guides command, 324
design options, data model, 474
Detail view
audit event, 497
changing topic views, 469
dimension name, Essbase, 428
dimensions, definition, 128
dimensions, setting topics as, 471
display differences, 323
display options
Essbase, 156
displaying
icon joins, 463
displaying axis grid lines, 270
displaying rulers, 309
Interactive Reporting document
analysis and reporting, 23
Interactive Reporting document (BQY), 66
Interactive Reporting document sections. See sections.
document sections. See sections.
Document Sort Order Language, 79
documents
administering, 502
blank, 433
BRIOBRG2 table, 490
compressing, 37
contents of, 21
exporting as Web pages, 62
password protecting, 38
registering to the IBM information catalog, 499
saving, 37
starting, 25
uploading to repository, 486
Interactive Reporting documents, definition, 20
Download To Results command, 177
Download to Results in CubeQuery section, 223
Drill Anywhere command, 288
drill anywhere, allowing, 474
drill down, 29, 160
Drill Down command, 177, 242
drill to detail, allowing, 474
drill up, 161
Drill Up command, 177, 242, 288
drill-down paths, defining, 471
drilling into charts, 267
drilling through, multi-dimensional to relational, 174
Duplicate Section command, 71
duplicate values, suppressing, 298

E
editing footers, 72
editing headers, 72
elements
  selecting pivot, 227
  working with chart, 248
empty rows, suppressing, 157
enabling users to apply limits, 473
ENDS WITH, 333
ensuring data model integrity, 479
EQUAL, 332
Estimate Query Size command, 123
EVENT_TYPE column, in sample BQAUDIT table, 494
events
  defining audit, 494
Excel files, 48
Expfunction, 355
export
documents as Web pages, 62
HTML Wizard, 86
query logs, 64
script to text file, 64
sections, 47
SQL, 64
Expression line, 294
expression syntax, 294

F
facts, 225
facts, definition, 128
facts, setting topic items as, 471
features, sort line, 266
field definitions, number, 74
file locations, 77
File Name field, 307
files
  creating OLAP connection, 428
  files, exporting, 47
Filter command, 141, 150
filter dialog box, 330
filter line, 328
filter line syntax, 329
filter options, customizing, 337
filter, operators, 332
filtering
  Informatica tables, 450
tables, 425
filtering data in a table, 144
filtering queries, 333
filtering results, 334
filters
  applying
    in OLAPQuery, 166
    member selection, 167
  measure
    applying, 167
    variable, 168
  member variable, 168
  removing, 145
tables, 144
  variable, 167
    in OLAP Query, 167
slicer, 169
filters, applying in OLAPQuery, 166
focus on items, 268, 319
Focus On Items command, 242, 288, 325
font styles, changing, 322
fonts, changing, 322
fonts, default, 73
footers, 72
report, 300
footers, page in custom reports, 302
foreign key tables, in table of joins, 452
formats
default
fonts, 73
number, 74
specifying, 73
formatting commands, 138
formatting day of week data, 367
formatting report items, 322
From Server data formats, 427
functions
data, 173
in sorts, 267, 416
MDX, 163

G
generating automatic join paths, 476
GIF files, 85
governors
data model, 475
in local results, 468
Grand Total command, 142, 151
grand total data functions, 148
grand totals, inserting, 133, 148
Grant Tables To Public option, 482
graphic elements, 304
GREATER OR EQUAL, 333
GREATER THAN, 333
Grid command, 324
grid lines, 244
grids, 309
group fact syntax, 295
group headers, report, 298
Group Items command, 242, 288
group label syntax, 295
grouping columns, 151
groups, administering repository, 485
groups, repository, BRIOBRG2 table, 490
guides, design, 309

H
headers, 72
page, in custom reports, 302
report, 300
report group, 298
Headers and Footers command, 325
Hide and Footer command, 325
hide items, 269, 319
Hide Items command, 242, 288, 325
hiding and focusing on charted data, 268
hiding and focusing on reported data, 319
hiding column names, 297
hiding column totals, 297
hiding icon joins, 463
hiding Request items, 93
hiding sections, 70
horizontal lines, 305
HTML
export wizard, 86
restrictions and limitations, 63
HTML file formats, 49
comparison of, 49

I
IBM Information Catalog
administering documents, 502
creating an object type, 501
definition, 499
registering documents to, 499
setting up object types, 503
icon joins, showing, 463
Icon view
definition, 470
metatopics and, 445, 446
impact analysis, data, 493
import
data files, 43
SQL, 44
Informatica tables, filtering, 450
INI file, 82
Initcap function, 359
Insert Field command, 325
Insert Graphic command, 325
Insert Predefined Field command, 325
Insert Table command, 325
inserting
additional tables in a custom report, 298
limit values, 308
page breaks, 303
page headers and footers, 302
report headers and footers, 300
text, 271
text in charts, 271
inserting sections, 66
Instrfunction, 359
Integer command, 74
Integer data type, 343
Interactive Reporting database connections
creating, 433
default directory, 421
modifying, 430
options, 422
setting default, 433
Interactive Reporting Studio
dbgprint and, 523
troubleshooting connectivity, 523
Interactive Reporting Studio repository
administering, 482
administering groups, 485
uploading documents to, 486
Interactive Reporting Web Client Co-existence, 529
interpreter, open metadata, 452
IP addresses, 420
IS NULL, 333
items
creating computed metatopic, 445
items, sort, 266

J
JavaScript expressions, 54
join paths, using defined, 464
join strategies, 461
join types, specifying, 463
joining topics
automatically, 461
manually, 462
using metadata join information, 451
joins
definition, 459
hiding from users, 444
limit local, 466
limitations of local, 468
local, 465
manual, 462
metadata definitions, 451
removing, 464
showing in icon view, 463
specifying strategies, 461
usage preferences, 476
using defined paths, 464
JPEG/JPG files, 85

K
Keep Only, 224
Keep Together command, 322
Keep With Next command, 322
keys, modifier, 445

L
label properties
chart, 280
charts, 280
label reference, in sorts, 266, 416
labels, nested, 228
Las Saved field, 307
Last Printed field, 307
LastDay function, 353
layout aids, 293
left joins, 463
legacy chart colors, 279, 285
legend, 244
legends, positioning and resizing, 271
Lengthfunction, 359
LESS OR EQUAL, 332
LESS THAN, 332
level rules, OLAPQuery member and, 159
LIKE, 333
limit browse level preferences, 475
limit local joins
combining with local joins, 468
number allowed, 468
limit lookup values, applying metadata to, 453
limit options, 475
Limit Show Values audit event, 497
limit values, in reports, 308
limitations of local results and local joins, 468
limiting values, 475
Limits tab, 475
limits, enabling users to apply, 473
line charts, 259, 260
linear joins, 463
lines, 305
local filters, Results section, 328
local joins, 465, 468
Local Results
  limitations, 110
  processing order, 110
Locked command, 306
log files
  for Interactive Reporting troubleshooting, 523
log tables, 494
logging
  on and off databases, 435
  on to databases, troubleshooting difficulties, 523
logical operators, 332
Logoff audit event, 496
Logon audit event, 496
logon, auto, 75
LOOKUPID, 449, 453
Lowerfunction, 359
Ltrimfunction, 360

M
managing
  Interactive Reporting repositories, 481
manipulating chart data, 263
manipulating table data, 144
manually joining topics, 462
margins, in Report section, 310
master data models, 22
master data models, promoting to, 478
Maxfunction, 355
Maximum function, 149, 264, 316
MaxL (Multidimensional Access Language), 23
MDSQL (Multidimensional Query Language), 23
MDX (Multidimensional Expression Language), 23
MDX functions, 163
measure filters, applying, 167
measure variable filters, 168
measures, 161
Medianfunction, 358
member and level rules, OLAPQuery, 159
Member Search, 184
members, drilling down, 160
menu commands
  Chart, 288
  Pivot, 242, 378
Report, 324
Results, 141
Table, 150
Tools, 83
menu commands, DataModel, 479
menus and menu items, customizing, 80
Meta Connection Wizard, automatic join strategies
  and, 462
meta topics, 22
meta view, of data models, 446, 472
metadata
  adding remarks, 454
  applying, 452
  applying to limit lookup values, 453
  defining, 448
  definition, 443
  in Interactive Reporting, 446
  SQL entry fields, 448
Metadata Definition dialog box, 447
metadata definitions
  adding, 448
  columns, 450
  joins, 452
  limit lookup values, 453
  remarks, 454
  tables, 449
metadata interpreter, open, 452
metadata join information, joining topics using, 451
metadata names
  applying to data model topic items, 450
  applying to data model topics, 449
metadata, definition, 20
metatopics
  copying items to, 445
  creating, 444
  creating items, 445
  definition, 443
  in local results, 468
  viewing, 446
Microsoft Office Excel, 51
Minfunction, 355
Minimum function, 149, 264, 317
missing columns, 203
missing label, 203
missing rows, 203
Modefunction, 358
Modfunction, 355
modifier keys, 445
Modify Column command, 141, 151
Modify command, 242
Modify Computed Item command, 288
modifying
  connection preferences, 430
  Interactive Reporting database connection files, 430
  join types, 463
  metatopics, 444
  repository objects, 487
  request dialog, 478
  server date formats, 427
  topic item properties, 471
  topic properties, 470
modifying Interactive Reporting database connection files
  connection files, 435
modifying pivot tables, 227
monitoring
  connections, 431
Month (for Add Date Groups) command, 74
MonthsBetween function, 353
moving between sections, 71
moving pivot table elements, 227
MovingMax, 405
multicolumned reports, 311
Multidimensional Access Language (MaxL), 23
multidimensional charts, 255
multidimensional databases
  components, 153
  definition, 20
  querying, 153
  supported, 20
Multidimensional Expression Language (MDX), 23
Multidimensional Query Language (MDSQL), 23
multiple data sources, in reports, 320

N
naming topics using stored metadata, 449
nested labels, 228
nested sorts, 415
New Data Model audit event, 497
NextDay function, 353
Nextfunction, 357
NM function, 353
Non-Null Average function, 264, 317
Non-Null Count function, 264, 317
NOT (with operator), 333
NOT EQUAL, 332
Null command, 74
Null Count function, 264, 317
NUM_ROWS column, in sample BQAUDIT table, 494
number field definitions, 74
number formats, changing, 322
number formats, default, 73
Number of Pages field, 306

O
object descriptions, updating repository, 484
object names, 306
object type properties, creating, 501
object types, setting up, 503
objects
  deleting repository, 484
  modifying repository, 487
OCEs, See Interactive Reporting database connections.
ODBC
  data sources, 420
  table filters and, 425
ODBC, stored procedures and, 111
OLAP connection file, creating, 428
OLAP for Essbase, 179
OLAP queries
  adding totals to, 173
  building, 154
OLAPQuery items, formatting, 174
OLAPQuery member and level rules, 159
OLAPQuery section, 23
  accessing offline, 165
  diagram, 153
  showing as a chart, 174
  working offline, 165
OLE DB for OLAP query language, 23
OLE DB provider, connecting, 428
Open Catalog Extension, See Interactive Reporting database connections.
Open From Repository command, 41
Open Metadata Interpreter, 452
operators
  logical, 332
options
data model, 472
Interactive Reporting database connections, 422
program, 75
Options command, 84
OR, 329
OR Logic Between Groups, 512
original view, of data models, 446, 472
outer joins, 463
ovals, 306
OWNER, 449, 451, 452, 454

P
Packed Real data type, 343
page breaks, inserting, 66, 303
Page Margins command, 324
Page Number field, 306
Page Setup command, 65
Page X of Y field, 306
pages, setting up in reports, 33
password protect designer mode, 38
password protect document, 38
passwords
Interactive Reporting database connections and, 420
passwords]
database, changing, 436
Path Name field, 307
paths, using defined join, 464
Percentile function, 358
Picture command, 325
Picture General Properties, 123
pictures, 306
pie charts
analyzing data, 248
rotating, 249
pie slices, positioning, 248
Pivot Data Layout, 227
pivot elements, selecting, 227
Pivot menu commands, 242, 378
Pivot Options, 347
Pivot Section, 225
pivot tables
charting, 226
how to use, 226
modifying, 227
selecting elements, 227
working with pivot items, 227
pivoting data, 226
planes, 244
plot area, 244
positioning pie slices, 248
Post Process audit event, 496
Power function, 355
Pre Process audit event, 496
preferences
connection, setting, 422
join usage, 476
limit browse level, 475
primary key items and tables, in table of joins, 452
Print command, 65
Print Preview command, 65
Prior function, 357
priorities, topics, 476
process
in OLAPQuery, 165
in Query, 94
Process Query command, 83
Process Results To Table command, 123
processing queries, automatically, 478
program options, selecting, 75
Promote To Master Data Model command, 478
Promote To Meta Topic command, 479
promoting
queries to master data models, 478
topics to metatopics, 444
properties
creating object type, 501
defining, 500
topic, 470
Properties command, 288
properties, chart label, 280
publish, 139

Q
queries
adding topics to, 27
appending, 109
automatically processing, 478
building OLAP, 154
cancelling, 96
estimating size, 105
topic, 26
multiple, 91
processing, 94, 165
promoting to master data models, 478
sizing, 105
standard with reports, definition, 481
standard, definition, 481
tracking processing time, 493
troubleshooting, 105
query building, confusing aspects of, 443
Query Limit field, 306
query logs, local results and, 468
query logs, exporting, 64
Query Options command, 124
Query Options in CubeQuery section, 224
query properties, 112
Query section
data functions, 106
types of, 23
Query SQL field, 306
query, definition, 22
query-processing time, tracking, 493
querying databases, troubleshooting difficulties, 523
QUERYSQL, 496

R
RankAsc function, 358
Rank function
scalar, 358
ranking topics, 477
Real command, 74
Real data type, 343
rectangles, 305
reducing available values, 475
Reference dialog, 351
reference items, in sorts, 266, 416
Refresh Data command, 242, 288
registering documents to IBM Information Catalog, 499
relational databases
definition, 20
remarks
adding from stored metadata, 454
showing in Query section, 454
Remarks tabs, reordering, 454
remarks, displaying, 105
Remove command, 141, 151
Remove Only, 224
Remove Selected Items command, 242, 288, 325
Remove Total command, 177
removing
joins, 464
metatopics and metatopic items, 446
topics, 459
removing columns, 297
removing Request items, 93
removing Request line items, 93
renaming sections, 71
reordering columns, 298
reordering Remarks tabs, 454
reordering Request items, 93
reordering Request line items, 93
Replace function, 360
report components, 296, 297
report element syntax, concatenating, 295
report expression syntax, 295
report group headers, 298
report headers and footers, 300
Report menu commands, 324
Report Name field, 307
report pages, 309
Report section
computed fields, 307
computed items, 313
creating smart reports, 321
data functions, 316
diagram, 291
elements, 291
Expression syntax, 294
fields, 306
formatting items, 322
graphic elements, 305
limit values, 308
toolbar, 293
using multiple data sources, 320
Report Setup command, 325
reporting, 23
reports
adding computed items, 313
creating, 33
data functions, 316
designing, 32
inserting page breaks, 303
multicolumned, 311
setting up, 33
smart, 321
repositories
  administering, 482
  definition, 482
  uploading Interactive Reporting document files, 486
repository objects
  creating, 486
  deleting, 484
  modifying, 487
  updating descriptions, 484
repository tables
  confirming creation, 483
  creating, 481
  creation failure, 483
  granting access to, 482
repository, BRIOGRP2 table, 491
repository, saving documents to, 42
REPOSITORYNAME, 496
Request items, hiding, 93
request lines, in master data models, 478
Resource Manager, 120
Restore Name command, 242, 288
restricting topic views, 471
Result Limit field, 306
results
  automatically adding columns, 136
  enhancing, 131
  exporting, 139
  filtering, 131
  save options, 139
  saving, 37, 138
  viewing, 27
  working with, 137
Results menu commands, 141
Results section
  automatically creating, 166
  data functions, 133
  diagram, 127
  exporting, 48
results, limitations of local, 468
Retrieve Dimensions command, 176
Retrieve Dimensions in CubeQuery section, 222
Return First __Rows governor, 475
returning day of week, 367
ribbon charts, 259
right joins, 463
rotating and elevating charts, 274
rotating pie charts, 249
round rectangles, 306
Roundfunction, 356
rows, selecting, 137, 150
ROWSRETRIEVED keyword variable, 496
Rtrimfunction, 360
Rulers command, 324
samples
  audit events, 496
  audit log structure for BQAUDIT table, 494
Save Connection command, 83
Save To Repository command, 42
Save To Repository dialog box, 486
saving documents, 37
scalar functions, 352
  examples, 372
scripts, running from menu items, 80
Searching Members, 184
Section Boundaries command, 324
sections
  adding, 70
  deleting, 72
  duplicating, 70, 71
  exporting, 47
  hiding, 70
  inserting, 66
  moving between, 71
  renaming, 71
  viewing, 70
Select A Formatting Locale command, 73
selecting chart elements, 270
selecting columns, 297
selecting columns and rows, 150
selecting pivot table elements, 227
selecting subject areas, in IBM Information Catalog, 500
server filters in the Query section, 328
server versus local filter processing, 328
Server-Defined join strategy, 462
setting
  bar chart properties, 283
  chart label axis properties, 280
  chart value axis properties, 282
  connection preferences, 422
  data model options, 473
default OCEs, 433
object types up in IBM Information Catalog, 503
setting compound filters, 335
setting simple filters, 333
setting topic priorities, 477
setting up
page columns, 311
reports, 310
setting variable filters, 336
shared members, 203
Show All Items command, 242, 288, 325
Show All Values limit option, 475
Show As Chart command, 177
Show as Chart in CubeQuery, 223
Show Hidden Items command, 242, 288, 325
Show Icon Joins option, 474
Show Minimum Value Set limit option, 475
Show Remarks command, 123
show values, 331
Show Values limit option, 476
Show Values Within Topic limit option, 475
showing
icon joins, 463
remarks in Query section, 454
showing column names, 297
showing column totals, 297
showing pie percentages, 249
showing positive and negative values, 248
Signfunction, 356
SILENT keyword variable, 496
simple joins, 463
simple sorts, 413
Sinfunction, 356
Sinhfunction, 356
slice, 244
slicers
setting, 160
variable filters, 169
smart reports, 321
smart reports, creating, 33
Sort Ascending command, 141, 150, 288, 325
Sort command, 242, 325
Sort Descending command, 141, 150
sort items, 266, 416
sort line features, 266, 416
sort lines, 414
sorting
chart items, 265
charts, 228
pivot tables, 228
report items, 313
reports, 313
tables, 145
sorting data, 413
sorting, in OLAPQuery section, 415
sorting, in Query, Results, and Table sections, 415
sorts, nested, 415
specifying
automatic join strategies, 461
join strategies, 461
join types, 463
join usage preferences, 476
page margins, 310
page size, 310
Spotlighter, 87
SQL
coding limits with Custom SQL limit option, 476
database variables in Where clauses, 449, 451, 452, 453, 454
default values in metadata, 449
definition, 22
entering, 449
exporting, 64
From clauses in metadata, 449
functions in audit log, 494
importing, 44
recording statements, 493
Select statements in metadata, 448
specifying table and column aliases, 449, 451, 452, 454
table filters and, 425
testing for errors in statements, 493
topic priorities and, 476
Where clauses in metadata, 449
SQL files, 64
SQL_STMT column, in sample BQAUDIT table, 494
Sqrtfunction, 356
stacked bar charts, 258
staging data in tables, 144
standard query languages, 22
standard query with reports, definition, 481
standard query, definition, 481
StdDevfunction, 358
StdDevpfunction, 358
stored metadata, 452
stored procedures, 110
  opening, 111
  processing, 111
Stored Procedures command, 124
strategies, join, 461
String data type, 343
Structure view, of topics, 469
structure, BQAUDIT sample audit log, 494
Structured Query Language (SQL), 22
subject areas, selecting, 500
subqueries, building, 96
Subsets, 191
Substitution variables, 189
Substrfunction, 360
subtotals, calculating, 29
Sum function, 148, 264, 316
Sumfunction, 357, 393
Suppress
  Missing Columns, 224
  Missing Rows, 224
  Zero Columns, 224
  Zero Rows, 224
suppressing duplicate values, 298
surface values, 344, 346
Sybase, table filters and, 425
Sync With Database command, 479, 480
synchronizing data models, 478
syntax
  concatenating, 295
  expression, 294
syntax, concatenating, 295
Sysdate function, 354
T
  tab-delimited files, 43, 48
  TABALIAS, 449, 451, 452, 454
  TABLE, 449, 451, 452, 454
table aliases, specifying in SQL, 449, 451, 452, 454
table catalog
  definition, 458
  filtering tables from, 425
  refreshing, 426
  repository tables in, 483
Table Catalog command, 479
table column formatting options, 297
Table Data Layout, 143
table dimension syntax, 295
table fact syntax, 295
Table menu commands, 150
Table section
  computed items, 146
  data functions, 148
diagram, 143
tables
  adding computed items, 146
  bridge, 464
  filtering, 425
  filtering Informatica, 450
  filters, 144
  in bqttbls5.inifile, 105
Interactive Reporting Server tables
  BRIOBRG2 table, 490
  BRIOCAT2 table, 489
  BRIOGRP2 table, 491
  BRIOOBJ2 table, 490
log, 494
metadata definitions, 449
modifying pivot, 227
pivot, 226, 227
usage statistics, 493
working with, 150
tables as a data staging area, 144
Tanfunction, 356
Tanhfunction, 356
Teradata Version 3 OLAP functions, 362
testing auditing events, 493
text in charts, inserting, 271
text labels, 306
text, formatting, 66
text, wrapping, 298
three-dimensional bar charts, 256
Time Aware Axis, 260
Time command, 73
Time datatype, 343
Time field, 307
time formats, 427
time formats, 427
Time Limit ____Minutes governor, 475
Time Now field, 307
Timestamp command, 73
timeStamp data type, 343
timestamp formats, 427
to Server date formats, 427
toCha function, 354
ToDate function, 354
ToMonth function, 354
toolbar, in the Report section, 293
Tools menu commands, 83
topic items
  applying metadata names to, 450
  modifying, 471
topic priorities, 476
topic properties
  in local results, 468
  modifying, 470
Topic View command, 479
topic views
  changing, 469
  restricting, 471
topics
  adding to data models, 458
  applying metadata names to, 449
  joining
    automatically, 461
    manually, 462
  promoting to metatopics, 444
  ranking, 477
  removing from data models, 459
  specifying join strategies for, 461
  topics, adding to query, 27
ToQtr function, 354
Total commands, 151
totals
  adding to OLAPQuery, 173
  break, 134, 149
  calculating, 29
  inserting break totals, 149
  inserting column totals, 149
  inserting in Results section, 133
  inserting in Tables section
    break, 148
    custom, 148
    grand, 148
ToYear function, 354
tracking query-processing time, 493
Translatefunction, 360
Trend Functions, 397
troubleshooting
  Interactive Reporting Studio, 523
Truncfunction, 356
two-dimensional bar charts, 254
TXT files, 43, 48
types, setting up object, 503

U
underlying values, 344, 346
Ungroup Items command, 242, 288
Unhide Column command, 142, 151, 288, 325
updating
  distributed data models, 478
  Remarks tabs, 455
  repository object descriptions, 484
uploading Interactive Reporting document files to the repository, 486
Upperfunction, 360
usage statistics, tables and columns, 493
Use All Joined Topics option, 476
Use All Referenced Topics join option, 476
Use Automatic Join Path Generation option, 476
Use Defined Join Paths option, 476
Use The Minimum Number Of Topics join option, 476
user name, 420
USERNAME column, in sample BQAUDIT table, 494
using
  Connections Manager, 434
  defined join paths, 464
  local joins, 465
  local joins as limits, 466
  metatopics and metadata, 443
  Open Metadata Interpreter, 447
using functions, 352
using surface values, 346

V
value reference, in sorts, 266, 416
values, 244, 263, 298
values limiting, 475
Var limit indicator, 329
Varfunction, 359
Variable Filter command, 124
variable filters, in OLAPQuery, 167
variables in CubeQuery section, 190
variables, database, 449, 451, 452, 453, 454
Varpfunction, 359
VBA functions, 60
version-controlled data models, 481
versions, controlling Interactive Reporting, 489
vertical lines, 305
viewing metatopics, 446
views
  restricting topic, 471
  topic, 469, 470
views, changing, 66
Visible command, 306
Visual Warehouse, IBM, 499

W
Web browser restrictions and limitations, 63
Where clauses, SQL, 449, 451, 452, 453, 454
wrapping text, 298

X
XLS files, 48

Z
zero columns, 203
zero rows, 203