The Programs (which include both the software and documentation) contain proprietary information; they are provided under a license agreement containing restrictions on use and disclosure and are also protected by copyright, patent, and other intellectual and industrial property laws. Reverse engineering, disassembly, or decompilation of the Programs, except to the extent required to obtain interoperability with other independently created software or as specified by law, is prohibited.

The information contained in this document is subject to change without notice. If you find any problems in the documentation, please report them to us in writing. This document is not warranted to be error-free. Except as may be expressly permitted in your license agreement for these Programs, no part of these Programs may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose.

If the Programs are delivered to the United States Government or anyone licensing or using the Programs on behalf of the United States Government, the following notice is applicable:

U.S. GOVERNMENT RIGHTS Programs, software, databases, and related documentation and technical data delivered to U.S. Government customers are "commercial computer software" or "commercial technical data" pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As such, use, duplication, disclosure, modification, and adaptation of the Programs, including documentation and technical data, shall be subject to the licensing restrictions set forth in the applicable Oracle license agreement, and, to the extent applicable, the additional rights set forth in FAR 52.227-19, Commercial Computer Software--Restricted Rights (June 1987). Oracle USA, Inc., 500 Oracle Parkway, Redwood City, CA 94065.

The Programs are not intended for use in any nuclear, aviation, mass transit, medical, or other inherently dangerous applications. It shall be the licensee's responsibility to take all appropriate fail-safe, backup, redundancy and other measures to ensure the safe use of such applications if the Programs are used for such purposes, and we disclaim liability for any damages caused by such use of the Programs.

Oracle is a registered trademark of Oracle Corporation and/or its affiliates. Other names may be trademarks of their respective owners.

The Programs may provide links to Web sites and access to content, products, and services from third parties. Oracle is not responsible for the availability of, or any content provided on, third-party Web sites. You bear all risks associated with the use of such content. If you choose to purchase any products or services from a third party, the relationship is directly between you and the third party. Oracle is not responsible for: (a) the quality of third-party products or services; or (b) fulfilling any of the terms of the agreement with the third party, including delivery of products or services and warranty obligations related to purchased products or services. Oracle is not responsible for any loss or damage of any sort that you may incur from dealing with any third party.
# Contents

## Chapter 1. Getting Started
- Web Publishing Module Overview .......................................................... 5
- System Requirements ................................................................................. 6
  - Web Server Requirements .................................................................. 6
  - Client Computer Requirements ......................................................... 6
- System Components ................................................................................. 7
- Installation Process .................................................................................. 8

## Chapter 2. Installing, Configuring, and Uninstalling
- Preinstallation Tasks ................................................................................. 9
  - System Administrator Tasks ................................................................. 9
  - Network Administrator Tasks .............................................................. 10
  - General Tasks ....................................................................................... 10
- Installing Data Relationship Management Web Publishing ....................... 10
- Manually Configuring Data Relationship Management Web Publishing .......... 12
  - Configuring Data Relationship Management Web Publishing Service .......... 12
  - Configuring Internet Information Services ......................................... 12
  - Verifying System Access ...................................................................... 13
  - Configuring Data Relationship Management Web Publishing Engine .......... 14
  - Configuring Director ........................................................................... 15
  - Configuring Process Manager ............................................................ 15
  - Starting the Data Relationship Management Web Publishing Service .......... 15
- Using the Data Relationship Management Web Publishing Console .......... 16
- Configuring Data Relationship Management Web Client .......................... 18
- System Preferences ................................................................................. 18
  - Embedded Parameters ......................................................................... 20

## Chapter 3. Using Data Relationship Management Web Publishing
- Web Server Commands ........................................................................... 21
- Using Web Client Features ...................................................................... 22
- Main Toolbar and Hierarchy Window ...................................................... 23
- Selecting Versions and Hierarchies ......................................................... 23
Chapter 4. Frequently Asked Questions ................................................... 29

How do I display the home page after I install or update Data Relationship Management Web Publishing? ................................................................. 29
How do I start the Data Relationship Management Web engine? ................. 30
How do I check for error messages? .......................................................... 30
How do I check for connectivity with the Data Relationship Management Application Server? ................................................................. 30
Web Publishing Module Overview

The Oracle's Hyperion® Data Relationship Management Web Publishing module provides an auxiliary means of accessing Data Relationship Management system functionality. This application provides the following capabilities through a Web browser interface:

- Viewing hierarchies and node properties
- Running exports
- Printing hierarchy trees
- Searching for nodes in a given hierarchy

Data Relationship Management Web Publishing connects to the Data Relationship Management application server, but operates in a read-only mode. Various requests can be made using HTTP to either retrieve information or execute a command such as running exports or reloading from the database.

Figure 1 provides a top-level view of Data Relationship Management Web Publishing in relation to the Data Relationship Management architecture.

Web Publishing can be run on its own server or hosted on the Data Relationship Management multi-tier Web Server or the primary application server.
System Requirements

The following topics describe the Data Relationship Management Web Publishing system requirements for the Web server and the client computers.

Web Server Requirements

- Windows 2000 Server or Windows Server 2003
- Internet Information Services (IIS) version 5 or later
- Microsoft Data Access Components (MDAC) 2.7 or later (required only for MS SQL.)

Note:
Currently Web Publishing does not support SSL.

Client Computer Requirements

- Windows 2000 or later (ME, 2000, XP, Server 2003)
- Internet Explorer version 5 or later

Note:
Data Relationship Management Web Publishing uses an ActiveX control which can only run on the Windows operating systems. While Internet Explorer (IE) can be run on a
Macintosh computer, the Mac cannot run ActiveX controls. Though some versions of Netscape (on Windows) claim ActiveX support, using Data Relationship Management Web Publishing in a Netscape configuration is unsupported at this time.

**System Components**

Data Relationship Management Web Publishing consists of the following sets of components.

<table>
<thead>
<tr>
<th>Table 1 System Components</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File Name</strong></td>
</tr>
<tr>
<td>mdm_web_pub_engine.exe</td>
</tr>
<tr>
<td>mdm_web_pub_services_console.exe</td>
</tr>
<tr>
<td>mdm_web_publishing.exe</td>
</tr>
<tr>
<td>web-pub-config.xml</td>
</tr>
</tbody>
</table>

**Note:**

A COM+ application is like an NT service in that it runs behind the scenes with no visible user interface. However, unlike a service, a COM+ application has a public automation interface that allows other applications to communicate with it. There are many configuration options (some of which are outlined later in this document) including the ability to specify a user id/password with which the COM+ application logs in. This provides an extra level of security in that a different set of permissions can be granted to the application id than are available to users who are interactively logged in.

The client components are listed below.

<table>
<thead>
<tr>
<th>Table 2 Web Server Components</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>File Name</strong></td>
</tr>
<tr>
<td>default.asp</td>
</tr>
<tr>
<td>mdm_web_pub_client.ocx</td>
</tr>
<tr>
<td>mdm_web_pub_gateway.dll</td>
</tr>
<tr>
<td>mdm_web_pub_console_test.html</td>
</tr>
</tbody>
</table>
| Graphics Files | ● hyp_sig_hg_rgb_wht.gif  
● logo.gif  
● logo_sep.gif  
● masthead_top.jpg |
### Table 3  Command Components

<table>
<thead>
<tr>
<th>File</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RegisterWebPubEngine.cmd</td>
<td>Command file to register Web Publishing engine</td>
</tr>
<tr>
<td>UnRegisterWebPubEngine.cmd</td>
<td>Command file to unregister Web Publishing engine</td>
</tr>
<tr>
<td>RegisterWebPubService.cmd</td>
<td>Command file to register Web Publishing service</td>
</tr>
<tr>
<td>UnRegisterWebPubService.cmd</td>
<td>Command file to unregister Web Publishing service</td>
</tr>
</tbody>
</table>

### Table 4  Documentation Component

<table>
<thead>
<tr>
<th>Documentation</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>mdm_web_publishing.pdf</td>
<td>This guide</td>
</tr>
</tbody>
</table>

## Installation Process

Installing Data Relationship Management Web Publishing for the first time in a given environment involves the following tasks:

1. Verify prerequisites
2. Run the installation program
3. Configure Data Relationship Management user for Web Publishing
4. Run the Web Publishing Console to configure and start Web Publishing
Preinstallation Tasks

Caution!

You must upgrade your installation of Data Relationship Management Server before upgrading your the Web Publishing installation.

The following topics describe tasks that must be performed before you can install and use Data Relationship Management Web Publishing.

System Administrator Tasks

Your Data Relationship Management system administrator must complete the following tasks before you can install and use Data Relationship Management Web Publishing:

- Ensure that the Data Relationship Management system Release 9.3 is currently installed and operational.
- Create a new Data Relationship Management user name specifically for accessing Data Relationship Management Web Publishing (for example: mdm_Web). Assign the desired access rights to the user.

Note:

All Data Relationship Management Web Publishing users access the system through this one user name.
● Since the engine needs access to all paths that might be used for exports, provide a list of these paths to the network administrator. The system preference WebExDir controls the directory root for file storage location on the Web Publishing server.

● Configure the appropriate Data Relationship Management system preferences related to Data Relationship Management Web Publishing.

**Network Administrator Tasks**

Your network administrator must complete the following tasks before you can install and use Data Relationship Management Web Publishing:

● Create a new network user/application id that the Engine can use to login to the system. This id should have full access rights (including file creation) to any network shares that are designated for Data Relationship Management exports.

● Verify that IE browser policies allow for the use of digitally-signed ActiveX controls. While most Data Relationship Management Web Publishing implementations provide for browser access, some may be used strictly for automating exports. Configuring the browser can be skipped if interactive access is not desired.

**General Tasks**

In addition to system administrator and network administrator tasks described in the preceding topics, the following tasks must be performed before you can install and use Data Relationship Management Web Publishing:


  **Note:**

  Refer to the documentation for the prior version for instructions on uninstalling.

● Ensure that the intended host machine(s) meet or exceed the minimum system requirements defined in this document.

● Ensure that the user performing the installation has administrative rights to the Web server machine.

● Ensure that the Data Relationship Management Web Publishing release package is available.

**Installing Data Relationship Management Web Publishing**

**Caution!**

You must upgrade your installation of Data Relationship Management Server before upgrading your the Web Publishing installation.
To install Data Relationship Management Web Publishing:

1 Do one of these tasks:
   - If you have a Data Relationship Management Web Publishing CD or DVD, insert the CD or DVD into your CD or DVD drive.
   - If you downloaded the Data Relationship Management Web Publishing software from the Download Center:
     a. Navigate to the directory where you downloaded the installation program.
     b. Select File > Run or Start > Run and enter Drive:\Folder \mdm_web_pub_server_setup.exe, where Drive and Folder are the installation program location.

2 Review the Welcome box and click Next.

3 Read the license agreement, select I AGREE and click Next.

4 From Web Publishing Installation Options, do one of the following:
   - Click Next if the computer where you are installing Data Relationship Management Web Publishing is also a Data Relationship Management Web server.
   - Select Ntier Director if Data Relationship Management Web Publishing is being added to a computer that is not a Data Relationship Management Web server or if it is a standalone server, and click Next.

   Note:
   Ntier Director uses COM communication to the primary application server.

5 Click Next to accept the default installation directory, or click Change to select another directory, and click Next.

6 Do one of the following:
   - If you are installing Ntier Director, continue with the next step.
   - If you are not installing Ntier Director, continue with step 8.

7 Enter the machine name or IP address of the Data Relationship Management primary application server and click Next.

8 From Windows COM+ Logon, enter a user name and password for a user who has rights to perform the following actions and click Next:
   - Edit registry settings
   - Read and write to the local file system
   - Launch processes
   - Run as a service

9 Click Install.

10 Optional: After installation completes, you can select Launch Data Relationship Management Web Publishing Console.

11 Click Finish.
Manually Configuring Data Relationship Management Web Publishing

Configuration must be completed for the following:

- Data Relationship Management Web Publishing Service
- IIS Virtual Directory/Pool Configuration
- Data Relationship Management Web Publishing Engine
- When installing on a stand-alone server: COM+ Director and Process Manager Proxy Components

Configuring Data Relationship Management Web Publishing Service

➢ To configure the service:

1. Select Start > Programs > Administrative Tools > Services.
2. Select the Hyperion Data Relationship Management Web Publishing service.
3. Right-click the service and select Properties.
4. On the General tab, ensure that Startup Type is set to Automatic.
5. On the Log On tab, select This Account.
6. Enter a username and password for a Windows administrative user.
7. Click OK.
8. Close the Services dialog box.

Configuring Internet Information Services

Depending on the version of IIS that you are using, follow one of these procedures.

➢ For IIS 5.0:

1. Select Start > Programs > Administrative Tools > Internet Services Manager (or Internet Information Services (IIS) Manager).
2. Expand to the default Web site.
3. Select the mdm_web virtual directory.
4. Right-click and select Properties.
5. On the Virtual Directory tab, verify the following:
   a. The Local Path is pointing to the Data Relationship Management Web directory.
   b. The Read option is selected.
c. Execute Permissions is set to Scripts and Executables.

d. The Application Protection is set to High (Isolated).

Selecting this option enables you to unload the mdm_web application without restarting IIS.

6 On the Directory Security tab, enable and configure anonymous access.

7 Click OK.

8 Click OK.

9 Close the IIS Manager.

➤ For IIS 6.0 or later:

1 Select Start > Programs > Administrative Tools > Internet Services Manager (or Internet Information Services (IIS) Manager).

2 Expand to the default Web site.

3 Select the mdm_web virtual directory.

4 Right-click and select Properties.

5 On the Virtual Directory tab, verify the following:

a. The Local Path is pointing to the Data Relationship Management Web directory.

b. The Read option is selected.

c. Execute Permissions is set to Scripts and Executables.

d. Application Pool is WebPool.

This setting enables you to unload the mdm_web application without restarting IIS.

6 Click OK.

7 Select the Web Service Extensions node and select Active Server Pages from the list of Web Service Extensions on the right.

8 Verify that the Status column displays the status Allowed.

9 Create a new Web service extension named mdm_web_pub_gateway that points to mdm_web_pub_gateway.dll and is set to Allowed.

Note:

The default location for mdm_web_pub_gateway.dll is: C:\Inetpub\wwwroot\mdm_web.

10 Close the IIS Manager.

**Verifying System Access**

➤ To verify system access:

1 Using your Web browser, go to the following URL:
http://webservername/mdm_web

where webservername is the Web server computer name.

2 At the prompt, select to install the mdm_web_client ActiveX control.

Note:
This digitally signed control is safe to install. If you are not prompted to install the component, then it may be necessary to adjust the current browser settings to allow download and installation of ActiveX controls.

3 Click OK.

The Data Relationship Management Web Client page is displayed. No data (versions or hierarchies) is displayed until the service is started at the end of the installation/configuration/startup process.

### Configuring Data Relationship Management Web Publishing Engine

Note:

➢ To configure the Web Publishing Engine:

1 Select Start > Administrative Tools > Component Services.
2 Expand the Component Services node to the DCOM Config folder.
3 In the DCOM Config folder, select the mdm_Web_Pub_Engine object, right-click and select Properties.
4 For Windows 2000 only: From a command line prompt, type: dcomcnfg.
   a. In the list of applications, select the mdm_Web_Pub_Engine object and click Properties.
   b. On the General tab, set Authentication Level to None.
5 On the Identity tab, select This User and enter the same user and password that were configured for the Data Relationship Management Web Publishing Service.
6 On the Security tab, under Launch and Activation Permissions, select Customize and click Edit.
7 Add the user that is configured for IIS anonymous access to the mdm_web virtual directory.

Note:
This is typically IUSR_servername, where servername is the host machine name.

8 Allow Local Activation for this user.

9 Repeat this process for the Access Permissions section, by selecting Customize > Edit, and adding the same user and enabling the Local Access permission.
Click **OK** to close the **Properties** dialog box.

---

**Configuring Director**

If you install on a stand-alone server where Director does not already exist, you must configure the COM+ Director component.

➢ To configure the COM+ Director component:

1. Select **Start > Programs > Administrative Tools > Component Services**.
2. Drill down and select the **Director** component.
3. Right-click and select **Properties**.
4. On the **Security** tab, verify that **Enforce Access Checks for this Application** is not selected.
5. On the **Identity** tab, verify that the appropriate user is setup and then close the **Properties** dialog box.
6. Drill down to the **Components** folder of Director.
7. Select all components by pressing **CTRL-A**, then right-click and select **Properties**.
8. Verify that **Enable Object Pooling** is selected on the **Activation** tab and then close the **Properties** dialog box.
9. Close the **Component Services** window.

---

**Configuring Process Manager**

If you install on a stand-alone server where Process Manager does not already exist, you must configure the COM+ Process Manager Proxy component.

➢ To configure the COM+ Process Manager Proxy component:

1. Select **Start > Programs > Administrative Tools > Component Services**.
2. Drill down and select the **Process Manager** component.
3. Right-click the component and select **Properties**.
4. On the **Activation** tab, verify that the remote server is correct.
5. Close the **Component Services** window.

---

**Starting the Data Relationship Management Web Publishing Service**

➢ To start the Data Relationship Management Web Publishing Service:

1. In the Data Relationship Management Web Publishing Console, click ☰.
2 Verify that the Data Relationship Management Web Publishing Engine component appears in the bottom panel of the console and that the status is Running in the upper right corner.

Note:
For more information, see “Using the Data Relationship Management Web Publishing Console” on page 16.

Using the Data Relationship Management Web Publishing Console

The Data Relationship Management Web Publishing Console is designed to allow configuration, control and monitoring of the Web Publishing system. The Server Monitor Page allows the Web Publishing Service to be controlled (Start, Stop, Restart, Force Shutdown) and displays the current status of the service.

In addition there are three tabs for further information:

- System Status
- Event Log
- Web Server

The System Status tab shows some basic operating system information as well as information on COM+ and DCOM (Out of Process) applications. Currently Web Publishing does not use any COM+ so this section is blank.
The Event Log tab filters the application event log to show events for the Web Publishing module. Clicking on an event in the top panel shows the detail for the event in the lower panel. Events shown are filtered to include only events after the console was started. To see historical events you can check the Show History and click Refresh. Clear resets the filter time to the current date and time.

The Web Server tab provides two browser views to validate access to the Web Server system. The first panel displays the test HTML in the mdm_web virtual directory and validates access to the virtual directory for Web Publishing.

The second view tests the Web Publishing Gateway to perform the List Versions command. If the system is up and running, the list of versions available for Web Publishing is displayed.

Note:

When stopping and starting services such as IIS, you may need to refresh these views. To refresh, right-click on the view and select Refresh.
You can set the Data Relationship Management username and password for the Web Publishing module on the Configuration page. This user is the Data Relationship Management user that the Web Publishing engine uses to retrieve the data for display on the Web client. Limiting access to this user allows the Web Publishing to be restricted.

**Note:**

It is important that the user specified for Web Publishing be exempt from session timeout. Thus, the system preference IdleTimeExcludeUsers should be set to include the name of the user for Web Publishing. If this user is not excluded from session timeout, then the Web Publishing service needs to be restarted each time the user session expires.

### Configuring Data Relationship Management Web Client

Data Relationship Management Web provides a specific set of frequently-used Data Relationship Management functionality in a Web browser. This document assumes that the user is already familiar with the overall Data Relationship Management system, including its terminology and feature set. For more detailed information on any of the features described, please refer to the Data Relationship Management user documentation.

The appearance and behavior of Data Relationship Management Web Publishing can be configured using both System Preferences and embedded parameters.

### System Preferences

The Data Relationship Management system preferences listed below apply to Data Relationship Management Web Publishing usage. These can be configured by a System Administrator within the Data Relationship Management system.
Table 5  System Preferences

<table>
<thead>
<tr>
<th>System Preference</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ExcludeFromWebProp</td>
<td>String</td>
<td>Points to a boolean property [Property Abbrev] used to exclude specific nodes from the Web client. If the boolean property is True, then that node does not appear on the Web client. This property needs to be a local inherited property</td>
</tr>
<tr>
<td>WebBook</td>
<td>String</td>
<td>Book to indicate what exports are available on the Web client. The specified book must be visible to the Web user. For standard books, be sure to include the Std:prefix. If no value is supplied or an invalid book name is entered or a book that is not visible to the Web user is entered, then all exports visible to the Web user are available on the Web client. Note: Do not put a space between Std: and the prefix and book name, otherwise it is considered an invalid book as described above.</td>
</tr>
<tr>
<td>WebExcludeNodeProps</td>
<td>String</td>
<td>Comma-separated list of node properties to exclude from the Web client.</td>
</tr>
<tr>
<td>WebExDir</td>
<td>String</td>
<td>Default export output directory on Web server. Note: To specify a directory, it must already exist. If blank, then exports write to C:.</td>
</tr>
<tr>
<td>WebExportFailure TriggerFile</td>
<td>String</td>
<td>* File name that is created if the Web export fails. File is created in the same directory as the export output.</td>
</tr>
<tr>
<td>WebExportTrigger</td>
<td>String</td>
<td>* File name that is created upon successful completion of the Web export. File is created in the same directory as the export output.</td>
</tr>
<tr>
<td>WebFindFunction</td>
<td>String</td>
<td>Determines the type of Find function to use on the Web client [Basic or Enhanced]. Default is Enhanced.</td>
</tr>
<tr>
<td>WebLoadTrigger</td>
<td>String</td>
<td>* Complete file path to trigger file that is created once the Web server refresh is complete.</td>
</tr>
<tr>
<td>WebVers</td>
<td>Integer</td>
<td>The number of versions to load. Default is 2.</td>
</tr>
<tr>
<td>WebVersionList</td>
<td>String</td>
<td>Comma-delimited list of versions to load. This defaults to Default Current Version and Default Previous Version. If populated, the specified versions are loaded in the order listed. If not populated, then the first N versions are loaded based on the value of WebVers</td>
</tr>
</tbody>
</table>

* Trigger files are used primarily to facilitate automated interaction with the Data Relationship Management Web Server.
Embedded Parameters

The Data Relationship Management Web Publishing user interface can also be configured by parameters embedded within the HTML or ASP page that hosts the interface (for example, Default.asp). The parameters use the following format:

\[<\text{Param Name}="ParamName" \text{ Value}="ParamValue">\]

where ParamName is the parameter name and ParamValue is the desired value.

The following table describes the available parameters:

<table>
<thead>
<tr>
<th>Parameter Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DisableExports</td>
<td>Determines whether the Export tab is available. [True, False]</td>
</tr>
<tr>
<td>DisplayBy</td>
<td>Determines how each node in the hierarchy tree is displayed. [Default, Name, Description, DefaultAndDescription]</td>
</tr>
<tr>
<td>Hierarchy</td>
<td>Determines the default hierarchy to display. The specified hierarchy is displayed if it exists in the default version (the first in the WebVersionList.) The supplied Hierarchy parameter is used whenever a version is selected.</td>
</tr>
</tbody>
</table>
Using Data Relationship Management Web Publishing

In This Chapter

Web Server Commands ...........................................................................................................21
Using Web Client Features ......................................................................................................22
Main Toolbar and Hierarchy Window ..........................................................................................23

Web Server Commands

Interaction with the Data Relationship Management Web Publishing Engine can be done through commands sent by way of a browser. The available commands are listed in the table below. The commands are entered in a URL format:

http://webservenamel/mdm_web/mdm_web_pub_gateway.dll/command[?param=value]

where webservenamel is the actual Web server name and command is the desired command and param is the parameter and value is the parameter value.

Example: http://localhost/mdm_web/mdm_web_pub_gateway.dll/ListHiers?Version=Test%20Import

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
<th>Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>ListVersions</td>
<td>Returns the versions available for Web Publishing. This list is controlled by the WebVers and WebVersionList system preferences.</td>
<td>{None}</td>
</tr>
<tr>
<td>ListHiers</td>
<td>Returns the hierarchies for a specified version.</td>
<td>Version</td>
</tr>
<tr>
<td>ListProperties</td>
<td>Returns the full set of properties available for Web Publishing. Returns abbrev, description, label, data type, Categories tab delimited.</td>
<td>{None}</td>
</tr>
<tr>
<td>ListNodeProps</td>
<td>Returns property values for a specified node.</td>
<td>Version, Hier, Node</td>
</tr>
<tr>
<td>RunExport</td>
<td>Runs a specified export available to Web Publishing.</td>
<td>Export ID, CurrentVersion, PreviousVersion</td>
</tr>
<tr>
<td>TopNode</td>
<td>Returns the top node of a hierarchy.</td>
<td>Version, Hier</td>
</tr>
<tr>
<td>Command</td>
<td>Description</td>
<td>Parameters</td>
</tr>
<tr>
<td>------------------</td>
<td>--------------------------------------------------------------------------------------------------------</td>
<td>-----------------------------</td>
</tr>
<tr>
<td>ListExports</td>
<td>Lists the exports available for Web Publishing. Returns the export type, export abbrev, Export Profiles tab delimited</td>
<td>(None)</td>
</tr>
<tr>
<td>FindNode</td>
<td>Finds a specified Node. Returns Node, Excluded Flag, Inactive Flag</td>
<td>Version, Hier, Node</td>
</tr>
<tr>
<td>ExpandHier</td>
<td>Returns the Descendants of the specified node down to the specified level limit. The Return String contains Level, Node Abbrev, Limb/Leaf Indicator, Child Count, Node Description, Node Display Name, Inactive Flag</td>
<td>Version, Hier, Node, levellimit</td>
</tr>
<tr>
<td>ListExportTypes</td>
<td>Lists the Export Types Available for Web Publishing</td>
<td>(None)</td>
</tr>
<tr>
<td>ShowExport</td>
<td>Returns the Export text for an export that has been run. The Export contents are streamed.</td>
<td>ExportID, CurrentVersion, PreviousVersion</td>
</tr>
<tr>
<td>ListStdExports</td>
<td>Lists the Standard Exports available for Web Publishing. Returns the Export Type, Export Abbrev and Export Profiles Tab Delimited</td>
<td>(None)</td>
</tr>
<tr>
<td>SearchForNode</td>
<td>Returns a set of nodes that matches a search criteria. Returns the Node Abbrev, [Property Value Searched on, If not Abbrev], Excluded Flag, Inactive Flag</td>
<td>Version, Hier, SearchProp, SearchText</td>
</tr>
<tr>
<td>GetSysPrefValue</td>
<td>Returns the Value of the specified system preference</td>
<td>SystemPrefName</td>
</tr>
<tr>
<td>InitEngine</td>
<td>Initializes the Engine (Called by the service on startup)</td>
<td>(None)</td>
</tr>
<tr>
<td>RefreshProps</td>
<td>Refreshes the Property List. Can be used to have Web Publishing see new properties without restarting Web Publishing</td>
<td>(None)</td>
</tr>
</tbody>
</table>

Using Web Client Features

➢ To open a Data Relationship Management Web Client, type the following URL into the address box of your browser:

http://webservername/mdm_web

where webservername is the Web server running the Data Relationship Management Web components.

The Data Relationship Management Web Client home page is displayed.
Main Toolbar and Hierarchy Window

The main toolbar displayed within the client window contains the following items.

- Version list - select one of the available Data Relationship Management versions
- Hierarchy list - select a hierarchy from within the selected version
- Node name buttons (3) - choose how nodes are labeled in the hierarchy tree
- Show Inactive - show or hide inactive nodes in the hierarchy tree

Selecting Versions and Hierarchies

The desired Data Relationship Management Version can be selected from the Versions drop-down list at the top left of the window. A Hierarchy from within the selected version can then be chosen from the Hierarchies list. Once a hierarchy is selected, a tree view is displayed in the left frame of the window.

The displayed hierarchy tree is navigated as follows:

- Clicking the plus sign (+) to the left of a node to expand that node to the next level of the hierarchy
- Clicking the minus sign (-) to the left of an expanded node to remove the display of any nodes at a lower level in the hierarchy

The display of the node names can be adjusted by selecting one of the node name buttons on the toolbar:

- Default—Displays the value determined by the hierarchy property (for example, `DefaultDisplayBy`) if one is set.
- Description—Displays the Description for each node.
- Default and Description—Displays both Default display value and Description for each node.
If none of the three buttons is selected, then the Name for each node is displayed. The Show Inactive option can be used to either include or exclude inactive nodes from the displayed hierarchy tree.

The display on the right side of the Web Client is determined by the feature tab currently selected. These four options are available:

- **Properties**—Display properties for the currently selected node.
- **Export**—Display saved exports available on the Web Client.
- **Print**—Send image of the current hierarchy tree to a printer.
- **Find**—Search for a node in current hierarchy.

## Properties

When the Properties tab is selected on the right-hand pane, a read-only view of the properties for the currently selected node is displayed. Clicking each of the available property category tabs display the properties within that category. Each of the properties to which the Web user has access are displayed with the exception of any excluded by way of the `WebExcludeNodeProps` system preference. Clicking a property in the property viewer causes its Description to be displayed in the status bar below.

## Exports

When the Exports tab is selected on the right-hand pane, a list of each available export type, and any saved exports, are displayed in the tree view.

![Figure 2 Exports](image)

The only exports visible in the Web client are those contained in the export book specified by the `WebBook` system preference. If this system preference is not set or not set correctly, then all exports visible to the Web user are available on the Web client.
To run an export, select it in the tree and click the Request Export Run button. The Version Selector window is displayed. Select a version (or select the check box to use the current default version) and then select a previous version if applicable to the desired export type. Click the OK button to send the request.

A confirmation message is displayed to confirm that the request for the export has been submitted to the Data Relationship Management Web Server.

When the export completes, a new node is displayed in the tree representing the output of the job. This node is labeled with the name of the export and the current and previous versions that were used.

**Note:**

It may be necessary to click the Refresh Export List button to update the tree and display the latest results.

The result files are stored on the Web server in the directory specified by the `WebExDir` system preference. To retrieve the export results, select the output node for the export and click the Download Export button. Specify a filename for saving the results and click Save.

**Note:**

For exports configured to output to a database table, no output is displayed on the Web client nor is anything available for download.

**Print**

When the Print tab is selected on the right-hand pane, options for printing hierarchy trees are displayed.
The hierarchy currently shown in the left frame can be printed with the following options:

- **Full Hierarchy**—Prints the entire hierarchy.
- **From Selected Node**—Prints the hierarchy from the selected node including all descendant nodes.
- **As Shown In Tree**—Prints the hierarchy with the nodes currently selected and expanded in the left frame tree view.
- **Contents of Memo**—Prints the contents of the preview window including annotations.

Click the Preview button to display the results of the selected print option in the preview window in the right-hand pane. Additional text can also be typed into the preview window to annotate the hierarchy. Selecting the Contents of Memo option prints the hierarchy data along with any added text.

Click the Print It button to send the appropriate text to the default printer for the local machine.

**Find**

The Find function can be used to locate a node in the selected version and hierarchy using a search string. The WebFindFunction system preference determines which mode will be available: Basic or Enhanced. In the Enhanced mode, the nodes can be searched by:

- **Name**
- **Description**
- **Other**—Any string property within the hierarchy

The list of properties available for searching can be restricted if desired. Using the Data Relationship Management client tool, the hierarchy level property `WebFindProps` can be set to a list of the properties to be used. Then only the properties in that list is displayed in the
drop-down list for this option. If the WebFindProps property has no value or does not exist, then all string properties is available in the list.

**Tip:**

Creating the hierarchy-level property WebFindProps as data type NodeProps makes it easier for users to enter the desired list of properties.

The search text can also include wildcard characters. If you include an asterisk (*) before or after the search text, all values that contain the specified substring are returned.

Enter the appropriate text in the Search Text box and then click the Find button.

**Figure 4 Enhanced Search**

The list of nodes matching the search criteria is displayed in Search Results box. Selecting a node from the results and clicking the Go To button highlights the given node in the hierarchy tree. The Clear Results button can be used to erase the contents of the Search Results box.

In the Basic mode, nodes can be searched by name only and the search text must exactly match the name.
Figure 5  Basic Search

Using Data Relationship Management Web Publishing
How do I display the home page after I install or update Data Relationship Management Web Publishing?

If the Data Relationship Management Web Publishing home page is not displayed after you install or upgrade the software, follow this sequence of steps to resolve the problem:

1. Verify that the user name and password entered with the Web Publishing Console are correct.

   If the Web Publishing login information is invalid, a “Catastrophic failure” message may be displayed. While this message may sound severe, it simply means that the Engine could not successfully login to the database server.

2. Verify that the URL entered in the browser is correct and has the following format: http://webservername/mdm_web.

3. Verify network connectivity to the Web server computer as follows:
   a. Select Start > Programs > Accessories > Command Prompt.
   b. Enter the following command:

      ```
      ping Host
      ```

      where Host is the name of the Web server.

4. Verify that a reply is received from the application server.

5. If no valid reply is received, then check all network connections between the client and server machines.

6. Verify that the Web server is running and IIS is started.
How do I start the Data Relationship Management Web engine?

The Data Relationship Management Web engine loads automatically when the service is started. You can start and stop the service using the Web Publishing Console or the Microsoft Services screen.

How do I check for error messages?

Any time an unexpected condition arises, an entry is logged into the Windows Event Viewer under Application. The Web Publishing Console can be used to see the filtered set of event log messages pertaining to Web Publishing.

➤ To manually check for error messages:

1. Select Start > Programs > Administrative Tools > Event Viewer.
2. Select the Application Log node or the System Log node.
3. Look for any error messages in the list on the right side of the Event Viewer.
4. If you find errors, double-click the row to view details of which application caused the error and the specific problem encountered.

How do I check for connectivity with the Data Relationship Management Application Server?

The Web Publishing Console provides a Web Server tab that displays the versions accessible from the Data Relationship Management application server. If this screen displays versions then there is connectivity to the Oracle's Hyperion® Data Relationship Management application server. Note you may have to right click and say refresh if you are restarting services so that the cached value shown is refreshed.