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Overview

The term Compliance Template describes a particular family of AqualLogic Enterprise
Repository artifacts. Compliance Templates are only available in some product
configurations. Examples of specific compliance template types include:

Project Profiles

. Architecture Blueprints

Compliance Templates are used to communicate asset requirements or asset solution sets
to internal or outsourced project teams. Project Profiles are usually created for individual
projects, whereas Architecture Blueprints are reusable solution sets that can be leveraged
by multiple projects.

Compliance Templates are typically generated by individuals or teams responsible for
asset and project portfolios:

. Project Planners might generate a Project Profile for each project in the portfolio,
outlining the planning and estimating assumptions.

. Project Architects might generate a Project Profile to identify assets that fulfill a
project's business requirements.

. Enterprise Architects might generate an Architecture Blueprint that specifies the
standard frameworks and servers that are to be used by new projects.

. Those responsible for Service Oriented Architectures might generate an
Architecture Blueprint to identify the services that orchestrate a particular business

function.

. Product Line Architects might generate an Architecture Blueprint that specifies
the assets that are to be used on a specific product line.
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If upgrading from earlier product versions, compliance templates and examples may be
obtained by installing the appropriate datapacks using the Import/Export Tool. Project
Profiles are included in the Compliance Template and Policy Management Datapack.
Architecture Blueprints are included in the Enterprise Architecture Solution Pack.
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Creating a Compliance Template Type

This procedure is performed in the Type Manager, which is only available in some product
configurations.

This example illustrates the creation of a Project Profile compliance template type.

Caution: Adding a compliance template constitutes a permanent change to the
AqualLogic Enterprise Repository system.

In order to preserve database integrity, only Compliance Templates to which no assets are
currently associated may be deleted.

If a Compliance Template Type is available in the Type Manager:

1. Select New in the File menu.

| File  Wiew Help
Mew Crl+M
Save Chl+5
Exit  Cirl

The Create New Type pop-up opens.
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@ Type Mame INE-"-."'.-' Project Profile

Type far Defaults Project Profile ;I

XML Schema =
|: [Compliance Template Types]

E& - Architecture Blueprint [ Zachmar)
E& - Architecture Blueprint «2

[Palicy Types]

POL - Palicy
POL - Regulatory Compliance Policy

2. Enter the appropriate information in the Type Name text box.

3. Inthe Type for Defaults drop-down, select a Compliance Template Type from the
list.

4. Click OK.

The Create New Type pop-up closes and the new Type appears in the tree in the
Type Manager sidebar.

EI—‘&] Compliance Tetrnplate Types
—i E& - Architecture Blueprint (Zachmar)
—i E& - &rchitecture Blueprint «2

—% Mewy Project Profile
L

If no Compliance Template Type is available in the Type Manager:

Compliance templates and examples may be obtained by installing the appropriate
datapacks using the Import/Export Tool. Project Profiles are included in the Compliance

Template and Policy Management Datapack. Architecture Blueprints are included in the
Enterprise Architecture Solution Pack.

If an alternative method is preferred, a new Compliance Template Type may be
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manually generated:

1. Select New in the File menu.

| File  Wiew Help
Mew  ChieM
Save Chl+5
Ewit  Chrl+=

The Create New Type pop-up opens.
2. Enter the appropriate information in the Type Name text box.
3. Inthe Type for Defaults drop-down, select any Type from the list.
4. Click OK.

The Create New Type pop-up closes and the new Type appears in the tree in the
Type Manager sidebar.

5. Open the new compliance template type in the Type Manager.
6. Click the Editor tab of new compliance template type.

7. Select Compliance Template Type in the Archetype drop-down in the General
section of the Editor tab.
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8. Click Save in the File menu.

9. Select one of the of the tabs listed in the Tabs section.

Tabs

Overview

Taxonommy

Technical
Cperational Information
Documentation
Tests

Support

Mekrics

iZhange Management
Management Review
Miscellaneous

The elements assigned to that tab appear in the list in the Elements section.
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10. Click the Add button in the Elements section.

The Select an Element Type to Add pop-up opens.

Select an Hement Type to Add

Project(=]to Which Template iz Applied |_

11. Select Project(s) to Which Template is Applied from the drop-down in the Select
an Element Type to Add pop-up.

12. Click OK.
The Select an Element Type to Add closes.

13. Follow the prompt to enter a label for the new element.
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14.

15.

16.

17.

18.

19.

20.

Edit Projectis) to Which Template is Ap___ |

I

oK _carel |

Click OK.

The new elements appears in the list in the Elements section.
Click Save in the File menu.

Click the Viewer tab of new compliance template type.

Locate the new element in the list of Hidden Elements.

|

|appications Rolup 1
Dezcription (Appliceations Archiecture)

Projeci(s) {o Which Template iz Apphed -

Select (single-click) the new element.
Click the Display in Group button.

The Move Element pop-up opens.

=

Use the drop-down in the Move Element pop-up to select a location for the new
element.
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21. Click OK.

The new element appears in the list in the Elements section of the Viewer tab.

22. Click Save in the File menu.
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Creating a Compliance Template

This procedure is performed in the Asset Editor, and is very similar to Advanced Asset
Submission, as described in the AqualLogic Enterprise Repository User Guide.

1. Select New in the File menu.

Mew Chrl+M

JEVE
Loy Iarate

[ ] =F

The Create a New Asset pop-up opens.

2. Enter the appropriate information in the Name and Version text boxes.
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Create a New Asset X

9 - Mame evamnple Project Profile e

Mewy Project Profile

3. Select the appropriate Type template from the drop-down.
4. Click OK.

The new compliance template appears in the Asset Editor.

5. Click the Relationships tab.
6. Select the assets that are required to be used by the project.

7. Assign the appropriate relationships: Prescribed Assets, Prescibed Processes, and
Prescribed Environments, as appropriate.

8. Click Save in the File menu in the Asset Editor.
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|File View Help

e Ctrl+M

Ctrl+5

Copy/Migrate
Add Mate Ctrl+F2
Exit Chrl+

The asset is submitted for review and registration. (See The Registration Process in
the AqualLogic Enterprise Repository Registrar Guide.)

Follow this procedure to create Project Profiles, Architecture Blueprints, or other
variations of the Compliance Template.
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Apply a Compliance Template to a Project

This procedure begins on the Aqual.ogic Enterprise Repository Assets screen.

1. Use Search or other means to locate the compliance template to be applied to the
project. (Select the desired compliance template in the Type drop-down in the Search
section to filter search results.)

2. Click Apply to Projects _

Fraje Profle: Sesssle Praject Pradile - Purchase Request Traching System (1.9} ﬁg‘lg:}:}ﬂ]

:H_. ':mJ B S Bl il | B e M | B el b | Lt [ Lhis = Demstbiind | | B 08

Samgde Project Predile - Murchase Reques Tracking Sysbem | 1.00

Crawe
THER ASHIT 15 10 D0 UHCD AS AN DLAHELE, §THEASR BLDS POFGEATID Wi TH SAMPLUL HETA AT A, ALL FELES ANDFHITAGATA ARE 706 OE
WL G PRI THLA [N | M EALLR ML R L,

Hegiiralisn Slalus GmZatemd

Peedect Perposs Durtheas Lamsgak Trpckag Sppiemn vl Spre Varder pedaey spened what hes bean dafivpred,
Imarwtiys Spamear Doacdior od Sumippmg

[m-nagmpen Aplhflion) Produgisg repseis sbasd regeetan Merging reguents 1o ora 550 Pertial deliresan, fate dalvarian, rgrg defranan
LE DR ]

2] i F e A il s S S fed | P jifrase pade @7 e spuladn
el abllesi Pobain Rafusil Loita™ ) Tl diiai 6nd Iei] raecli) Wi Sl Tiom Bla it Jueds
R ekl T dpds ™ mill faed &% BTEAddesd, aosd Dy e ol e

The Apply to Projects pop-up opens.

Hpply be Projescis
Fadl g Pagain
b i Riaban
1 ] A fapat sty w [ | isisne v

....,.- o s || g s |

|

(]
(aee]
(8s2]

[Servn | [ Cancei |

Copyright © 1995-2007 BEA Systems, Inc. All Rights Reserved. Page 14 of 23


http://docwiki.flashline.com/index.php/HomePage
http://docwiki.flashline.com/index.php/ALER30_ComplianceTemplates_Apply_to_Project?action=BackLinks
http://docwiki.flashline.com/index.php/ALER30_ComplianceTemplates_Apply_to_Project?action=BackLinks

10.

Click List All Projects or use Search to locate the project to which the profile will be
applied.

A list appears in the Available Projects column.

. Select (highlight) the project to which the profile will be applied.

Click ﬂ to move the project from the Available Projects column to the Projects
Applied to column.

The project moves from Available Projects to Projects Applied to.

. Click Save.

A confirmation pop-up opens.

Apply to Projects

You have applied Sample Project Profile - Purchase Request Tracking System
(1.0) to the following project{s):
Registry

. Click Close.

Click the Projects link in the AqualLogic Enterprise Repository menu bar.
The Projects screen opens.

Use Search or other means to locate the project to which the project profile was
applied.

Click the Compliance Templates tab in the Project Detalil.

The applied compliance template is listed in the Compliance Templates tab.
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Note: If the enterprise repository plugin for Eclipse or .Net is installed, the assets identified
in the compliance templates will also appear in the project's development environment.
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Using Assets Associated with Compliance Templates (Prescribed Assets)

Overview

A Compliance Template may be used to prescribe specific assets for use in any projects to
which the compliance template is applied. This document outlines the process for
consuming prescribed assets.

This procedure begins on the Aqualogic Enterprise Repository Projects screen.

1. Use Search or other means to locate the project.

('] Projects

Create New
List All

Hame

Departmeant

All Departments [V] E]

Status
All Status [+

2. Any compliance templates applied to the project will be listed in the Compliance
Templates section of the project detail.

Frojpeci: Regiskry e A p_-_.; AT}
b |
Termplats Jh porlenied Bi?
! el -2 1N 15 | 1T 2] A.apaamary ddmd... [T
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3. Click ™ Use Assets | {5 the right of the name of the listed compliance template.

o Note: The Use Assets button will appear only to users who are assigned to the
project.

The Use / Download pop-up opens.

Use - Download

Sample Project Profile - Purchase Request Tracking System (1.0)
Registry v

Subscriptions for Sample Project Profile - Purchase Request Tracking System (1.0)
" Sand mae information updates abaut thiz assat.

Assels Related to Sample Project Prefile - Purchase Request Tracking System (1.0}

g cribed
[]| Sample Framewsrk = Strats (3.2

L] Send me infarmaticn updanes absut this pagar,
]| s¥mpla Sarvica - Acceunt Datail (dynamic] (2.0]

I:I Sand ma informatien updates abouc this assart

D Sample XML Schema - MARC [1.0]

D Cend me information updates about thiz asset.

D Sample Environment = Tomcat (4.1}

L] Send me infarmaticn updares absut this paser,

[]| Samele Process - SCRUM (2.0

I:' Send ma infarmatien updaras abouc this assar.

| Next || Cancel |

4. Use the checkboxes in the Use column to select the assets to be downloaded.
5. Click the Next button.

The Use / Download pop-up confirms the asset selections.
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Use - Download

You have selected the following ibems for use in Registry. After you avaluate thase
itams. please ramamber to update thelr usage status in My Stuff.

Listed below are the dovmloadable files associated with your asset usage.

Sample Framewark - Struts [3.2) (=11

Fila
Struts - Struts binaries - UNIX @ -
Struts - Struts Library Distribution @ —
Struts - Struts binaries - WINTEL @ —

Sample Service - Account Detail (dynamic) (2.0)

This assat does not contain any downloadable files.

Sample XML Schema - MARC (1.0)

MARCZ 1slim . x2d - MARCZ1 XML Schema @ —

Sample Environment - Tomcat [(4.1)

jakarta-tomcat-4,1-YYYYMMDD.zip - Tomecat 4.0 Binary @ —
Bistribution for Windows or Unix

Sample Process - SCRUM (2.0)

SCRUM Methodology - describes the SCRUM process

SCRUM Process - Cwverview of the SCRUM process and how to gat @ —
startad

1. Click @ to download the payloads for the selected assets.
2. Click Close when finished.

The downloaded assets are listed on the Consumed Assets section of the project
detail.
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Running a Project Compliance Report

Overview
Project Compliance reports, if enabled in your product configuration, provide the means for

verifying project adherance to the assets prescribed for use in compliance templates.

This procedure is performed on the Aqualogic Enterprise Repository Reports screen.

1. Click the Project Compliance link in the Reports sidebar.

Reports
Project Portfolio Productivity

Project FPortfolio Productivity reports show the overall productivity of
project teams, including their level of compliance vith prescribed
asset usage requirements, and the value they have realized by
leweraging the existing asset portfolio. The reports also spotlight
each project team's contribution to the asset portfolio.

Lz=at Praductian Dataal (B E‘rn1ﬂrt'_||
fAsset Use [ By Project)
Broject Compliance

The Project Compliance report form opens in the main pane.
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Project Compliance

This report shows the Comphance Templates applied to projects
and whether the project is comphant with the Template rules.
*Date Range is based on the date the projects were created.

Date Range” : [ ctom _'I
From ;I
To ;l
Sort Order: [Project Name A

Output Format: |HTML =

Run Report |

2. Use the Date Range, Sort Order, and Output Format drop-downs to set the report
parameters.

NOTE: Date Range is based on the project creation date.
3. Click the Run Report button.
The report appears in the selected format, listing each project, and indicating

compliance templates in use, prescribed assets, usage status of prescibed assets,
and any additional assets consumed by the project.
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