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Preface

Intended Audience
Welcome to Release 7.1.1 of the Oracle Demantra Demand Management User Guide.

See Related Information Sources on page viii for more Oracle Applications product 
information. 

TTY Access to Oracle Support Services
Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services 
within the United States of America 24 hours a day, seven days a week. For TTY 
support, call 800.446.2398. 

Documentation Accessibility
Our goal is to make Oracle products, services, and supporting documentation 
accessible, with good usability, to the disabled community. To that end, our 
documentation includes features that make information available to users of assistive 
technology. This documentation is available in HTML format, and contains markup to 
facilitate access by the disabled community. Accessibility standards will continue to 
evolve over time, and Oracle is actively engaged with other market-leading technology 
vendors to address technical obstacles so that our documentation can be accessible to all
of our customers. For more information, visit the Oracle Accessibility Program Web site 
at http://www.oracle.com/accessibility/ . 

Accessibility of Code Examples in Documentation
Screen readers may not always correctly read the code examples in this document. The 
conventions for writing code require that closing braces should appear on an otherwise 
empty line; however, some screen readers may not always read a line of text that 
consists solely of a bracket or brace. 
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Accessibility of Links to External Web Sites in Documentation
This documentation may contain links to Web sites of other companies or organizations
that Oracle does not own or control. Oracle neither evaluates nor makes any 
representations regarding the accessibility of these Web sites. 

Structure
1  Introduction to Demand Management 
2  Demand Management Overview
3  Demand Management Worksheets
4  Configuring Demand Management
A  Demand Management Levels and Series

Related Information Sources
This is the Release 7.1.1 of the Oracle Demantra Demand Management User's Guide. 
This manual describes the features that are available when you access Oracle Demantra 
Demand Management as a Demand Planner, Demand Plan Manager, or Demand 
Administrator. If this guide refers you to other Oracle Demantra Applications 
documentation, use only the 7.1.1 versions of those guides.

Documentation on OracleMetaLink can be found at http://metalink.oracle.com.

Online Documentation
All Oracle Applications documentation is available online (HTML). Online help is 
available for end users of Oracle Demantra Demand Management. Online help patches 
are available on OracleMetaLink. 

Oracle Demantra User's Guide
This guide explains how to log in to Demantra, use worksheets, and navigate using the 
Graphical User Interface (GUI) available with Oracle Demantra. 

Oracle Demantra Foundations Implementation Guide
This guide provides information for a system administration who sets up the Oracle 
Demantra application. This guide also includes reference information on key database 
tables, client and server expressions, and configuring the various Demantra 
applications. 

Do Not Use Database Tools to Modify Oracle Applications Data
Oracle STRONGLY RECOMMENDS that you never use SQL*Plus, Oracle Data 
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Browser, database triggers, or any other tool to modify Oracle Applications data unless 
otherwise instructed. 

Oracle provides powerful tools you can use to create, store, change, retrieve, and 
maintain information in an Oracle database. But if you use Oracle tools such as 
SQL*Plus to modify Oracle Applications data, you risk destroying the integrity of your 
data and you lose the ability to audit changes to your data. 

Because Oracle Applications tables are interrelated, any change you make using an 
Oracle Applications form can update many tables at once. But when you modify Oracle 
Applications data using anything other than Oracle Applications, you may change a 
row in one table without making corresponding changes in related tables. If your tables 
get out of synchronization with each other, you risk retrieving erroneous information 
and you risk unpredictable results throughout Oracle Applications. 

When you use Oracle Applications to modify your data, Oracle Applications 
automatically checks that your changes are valid. Oracle Applications also keeps track 
of who changes information. If you enter information into database tables using 
database tools, you may store invalid information. You also lose the ability to track who
has changed your information because SQL*Plus and other database tools do not keep a
record of changes. 
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1
Introduction to Demand Management 

Introduction
Oracle Demantra Demand Management provides access to your historical sales data, 
returns, and other reference data organized into multiple hierarchies that reflect the 
needs of your organization. An underlying spreadsheet provides a set of calculated 
(and input) values that you can use at any hierarchy level.

Within Demand Management, you work almost entirely within worksheets. A 
worksheet retrieves a set of data associated with given hierarchy levels, optionally 
filtered; the data generally includes historical sales data, the forecast, and intermediate 
data.

What is Demand Management?
Demand Management is used to enable organizations to produce unconstrained 
forecasts for future demand and generate tactical, operational, and strategic business 
plans. Demand Management captures and processes information from multiple sources
and consolidates demand so that it can be summarized by item, product line, region, 
time, and organization.

There are three key areas of focus in improving Demand Management processes. They 
are: achieving consensus, improving accuracy, and reducing process cycle time. Getting 
an entire organization to one expression of "the forecast" is the most important goal of a 
good Demand Management process. This requires the ability to gather and consolidate 
all the sources of demand information. It also requires providing secure, portal based 
access to receive, analyze, and submit forecast data, and the ability to express the data 
in the right format. For example, see forecast by region in dollars and forecast in units 
by shipping facility and so on.
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Why Manage Demand?
While demand is inherently variable and some inaccuracy is inherent, improving 
accuracy is also critical. Improving accuracy requires improvements in several areas. 
For example, organizations use statistics to better estimate patterns, they consolidate 
quantitative and qualitative judgment, and use performance management to drive 
continuous improvement over time. Perhaps the most important area is reducing the 
cycle time of the demand management process. The longer the process takes, the more 
inaccurate it will be, the further in advance of actual events the prediction will be, and 
the process will also become less frequent. Cutting time out requires powerful analytic 
tools to quickly assess and understand demand and automating processes to allow for 
management by exception.
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2
Demand Management Overview

Oracle Demantra Demand Management Overview
Oracle Demand Management is a configurable web-based product to help your 
organization perform demand planning and forecasting. Demand Management is built 
around collaboration, and takes advantage of workflows to automate the Demand 
Management process.

The process of demand planning generally consists of studying historical sales data and
trying to predict future demand as closely as possible. The goal is to achieve an 
appropriate balance between meeting customer demands as quickly as possible and 
making or buying only as much of each product as required. 

A demand plan is based on a forecast, which in turn is a prediction of tendencies in the 
supply chain over a period of time, influenced by seasonal and other predictable factors.
The result of a forecast is a projected curve that has been smoothed to show tendencies 
and de-emphasize the exceptional variations.

In general, the demand plan and forecast are used in downstream operations such as 
production planning. Depending on how your system has been configured, it either 
exports such data automatically or contains reports that you use for that purpose.

The Demand Management Process
Demand Management is an iterative process, that typically takes place in the weekly, 
biweekly or monthly cycles. This process includes:

1. Collecting the appropriate data from an ERP or other system of record.

2. Downloading the appropriate data to the Demantra database.

3. Generating a forecast and then sending a notification to demand analysts.

4. Demand analysts work with the forecast and making any corrections or 
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adjustments.

5. Demand manager or designated forecast owner approves the forecast. 

6. The approved forecast is uploaded to your ERP system.

Collect and Download Data
Most businesses have a regularly scheduled Demand Management process that can be 
monthly, weekly or, in a few cases, daily. During this period, data from various sources 
are loaded into the Demand Management system for use in forecasting future demand. 
The source systems can be an ERP system, legacy system or another Oracle APS 
(Advanced Planning Suite) module such as Advanced Supply Chain Planning, 
Inventory Optimization, Global Order Promising or Collaborative Planning.

Once loaded, the administrator ensures that planners have access to the data they 
require. For example, each planner may be responsible for planning the demand for a 
particular region or product line. Although planners can view data for all lines of 
business they are given access to, they are only able to modify data for which they have 
permissions.

Generate the Forecast and Send Notifications
After the download is complete, the administrator (or an automated process) runs the 
forecast and resets the approval series. After successful calculation of the forecast, the 
appropriate users are automatically notified that their forecast is available for review. 
The forecast, forecast accuracy measures and Demand Priority information are available
in predefined worksheets for analysis for all users.
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Note: In the event of an unsuccessful download or forecast generation, 
the Administrator can check the batch log for information on problems 
that arose during processing and forecast generation.

Manage and Approve the Forecast
The approval process is built around two user-types: the Demand Administrator and 
Demand Analyst. During implementation, Demand Administrators configure the 
approval process by specifying a reviewer who has final approval of the forecast. Each 
group of Demand Analysts should have one final approver. 

At the start of the approval process, a notification appears in the My Tasks window 
informing Demand Analysts that a forecast is available for the current planning cycle. 
Analysts can review their planning data (including the forecast) using one of the 
pre-seeded worksheets:

• Waterfall Analysis: Product Category and Zone

• Waterfall Analysis: Product Category and Organization

• Demand Analysis: Product Category and Organization

• Demand Analysis: Product Category and Zone

• Demand Analysis: Item and Organization

• Demand Analysis: Item and Zone

Using the graphs and reports found in these worksheets, analysts view and adjust their 
forecast data. They analyze history to understand shipped, booked and customer 
orders, inventory levels and other factors. For example, an analyst may consider any 
upcoming events or promotions that may impact the demand as well as their customer 
and sales forecast. 

Based on this information, analysts modify the forecast and can run a simulation that 
repopulates the worksheet with the changed data. Once their analysis and 
modifications are complete, the analyst saves the changes and selects Done for the 
relevant notification in the Collaborator Workbench's My Tasks view, which notifies the
demand plan manager or administrator.

These changes to the forecast are available for review by an approver. One or more 
people can do the review. For example, if the analysts are responsible for demand by 
region, a regional manager may approve or change the analyst's changes. Or, if an 
analyst's responsibility is broken down into product lines, then the product line 
manager may have final approval. Demand Management's pre-seeded approval process
is setup for one level of review. Additional levels of review require changes to the 
pre-seeded Approval workflow.

The final approver can lock the forecast at any time by checking the Final Approval 
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column. After review, the final approver accepts the forecast by selecting the Done 
button in My Tasks for the forecast notification.

Upload the Forecast
Once approved, the Demand Administrator uploads the consolidated forecast for use in
other systems (for example, Oracle Advanced Supply Chain Planning) where the 
unconstrained demand is used to drive the constrained demand.

Demand Management for Multiple Lines of Business
An organization's data is typically divided into several Lines of Business (LOB). For 
example, a printer manufacturer may have Printers and Copiers lines of business. 
Different lines of business generally have different demand management processes. The
difference in the planning process may be due to the following reasons:

• Each line of business may have different planning cycles (such as weekly or 
monthly) and may use different calendars (such as manufacturing or fiscal).

• Each line of business may have different business requirements, such as 
model-options forecasting, product family level forecasting, service parts 
forecasting, and so on.

• The lines of business may be in different geographical locations or may otherwise 
have varying business practices.

• Each line of business may have its separate group of planners who need to look at 
the demand data pertaining to their respective line of business only.

• A line of business demand plan refers to limiting the scope of a demand plan to 
include only those level values (such as items, organizations, customers' ship to 
locations, sales representatives) that pertain to the line of business. 

When an organization has multiple LOBs, the data is often assigned to specific users 
(for example based on product line or region), and the analyst is responsible for 
determining the demand for that slice of data. When each analyst has reviewed and 
approved his or her forecast, a master approver is notified and approves the forecast as 
a whole.

The following diagram illustrates the demand management process with multiple lines 
of business:
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3
Demand Management Worksheets

Worksheets Overview
To manage or view forecasts and demand, you start in the Collaborator Workbench and
launch any of the relevant Demand Management worksheets. Worksheets with the 
necessary series for analysis and modification of the forecast are available for the 
analyst at the beginning of each cycle.

Worksheet Description
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Waterfall Analysis: Product 
Category and Organization

Compare actual versus forecast demand, aggregated by 
product category and organization, to determine prior 
periods forecast accuracy.

Waterfall Analysis: Product 
Category and Zone

Compare actual versus forecast demand, aggregated by 
product category and zone, to determine prior periods 
forecast accuracy.

Demand Analysis: Product 
Category and Organization

Compare history and demand data in weekly time 
buckets, aggregated by product category and 
organization. Use this worksheet to manage and approve 
the forecast. 

Demand Analysis: Product 
Category and Zone

Compare history and demand data in weekly time 
buckets, aggregated by product category and zone. Use 
this worksheet to manage and approve the forecast.

Demand Analysis: Item and 
Organization

Compare history and demand detailed data in weekly 
time buckets, by item and organization. Use this 
worksheet to manage and approve the forecast.

Demand Analysis: Item and Zone Compare history and demand detailed data in weekly 
time buckets, by item and zone. Use this worksheet to 
manage and approve the forecast.
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Waterfall Analysis Worksheet 

The first step in the Demand Management process is to look at your previous cycle and 
determine how accurate your forecasts were. Using the Waterfall Analysis worksheets 
you can compare actual versus forecast demand for individual product categories, 
organizations, and regions (zones). By comparing actuals to forecast, demand planners 
can identify problem areas, and deduce why forecast demand did better (or worse) than
planned.

For example, a retailer notices that some of their seasonal product categories did not 
perform well during December. Using this data, your demand analyst deduces that an 
unseasonably mild winter was to blame. Since this anomaly was restricted to December,
the demand analyst decides to not make any changes in future demand for those 
products. Based on the results in the Forecast Accuracy worksheet, demand analysts 
can make the required adjustments and take those lessons learned and apply them to 
the next forecast. 

The Waterfall Analysis worksheet is aggregated to the following levels, which allows 
you to view and slice data depending on the details in which you're interested:

• Product Category and Zone

• Product Category and Organization
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The following archived forecasts are used in these worksheets:

• 4 Week Lag Forecast: The forecast series for the four weeks prior to the current 
week. 

• 8 Week Lag Forecast: The forecast series for the eight weeks prior to the current 
week.

• 12 Week Lag Forecast: The forecast series for the 12 weeks prior to the current 
week. 

• 4, 8, and 12-Week Lag Absolute Percentage Error: A measure of forecast accuracy, 
which is calculated as actual demand minus forecast demand, and displayed as a 
percentage.

• 4, 8, and 12-Week Lag Absolute Deviation: A measure of forecast accuracy, and 
represents the average amount that the actual demand varies from forecast 
demand.

About the Forecast and Metrics View
The Forecast and Metrics view displays a table showing demand and forecast values for
individual products, broken down by weekly time buckets. 

About the Absolute Deviation View

The Absolute Deviation view graphically represents the amount of deviation that exists 
in your forecast at the four, eight and 13-week level, represented as total units. Use the 
Absolute Deviation view to determine how much real demand differs from the forecast.
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About the Forecast Percentage Error View
The Forecast Percentage view graphically represents the amount of deviation that exists
in your forecast at the four, eight and 13-week level, represented as a percentage of the 
demand. Use the Forecast Percentage view to determine how much real demand differs 
from the forecast.
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Reference
Basics:

Accessing this Worksheet Do one of the following:

1. In My Worksheets (in Collaborator Workbench), click 
either DM: Waterfall Analysis Product Category and Org 
or DM: Waterfall Analysis Product Category and Zone.

2. If a worksheet is currently open, click either DM: 
Waterfall Analysis Product Category and Org or DM: 
Waterfall Analysis Product Category and Zone and then 
click Open.

Levels you can select Either:

• Product Category and Zone

• Product Category and Organization
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Time Aggregation Weekly

Business Data:

Series Group Series Description

Forecast Accuracy 4 Week Lag 
Forecast

Forecast for the four weeks prior to the current 
time bucket.

8 Week Lag 
Forecast

Forecast for the eight weeks prior to the current 
time bucket.

13 Week Lag 
Forecast

Forecast for the 13 weeks prior to the current time 
bucket.

4 Week Lag 
Absolute Deviation

Absolute Deviation for the four weeks prior to the 
current time bucket.

4 Week Lag 
Absolute % Error

Absolute percentage error for the four weeks prior 
to the current time bucket.

4 Week Lag % 
Error

Percentage error for the four weeks prior to the 
current time bucket.

8 Week Lag % 
Error

Percentage error for the eight weeks prior to the 
current time bucket.

13 Week Lag % 
Error

Percentage error for the 13 weeks prior to the 
current time bucket.

8 Week Lag 
Absolute % Error

Absolute percentage error for the eight weeks prior
to the current time bucket.

8 Week Lag 
Absolute Deviation

Absolute Deviation for the eight weeks prior to the 
current time bucket.

13 Week Lag 
Absolute Deviation

Absolute Deviation for the 13 weeks prior to the 
current time bucket.

13 Week Lag 
Absolute % Error

Absolute percentage error for the 13 weeks prior to
the current time bucket.
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Historical Demand Demand Unconstrained demand. Purple if out of stock.

Sales Demand Unconstrained demand. Purple if out of stock.

Demand Analysis Worksheet 

Once you have reviewed your forecast from previous cycles to determine how accurate 
it was, the next step is to review the forecast for the current planning cycle. The 
Demand Analysis worksheets are available at the start of the planning cycle, and 
display historical data, forecasted demand accuracy statistics and demand priority at 
various levels of aggregation.

You can use the Demand Analysis worksheets to view, edit, and approve the forecast 
for individual weekly time buckets. The Demand Analysis worksheet is aggregated to 
the following levels, which allows you to view and slice data depending on the details 
in which you're interested:

• Product Category and Organization

• Product Category and Zone
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• Item and Organization

• Item and Zone

About the Demand Tracking Table
The Demand Tracking table compares sales and demand figures, at your chosen 
aggregation level, in weekly time buckets. It gives analysts a side-by-side view of their 
actual sales, demand and forecasted sales, along with Absolute Deviation and Absolute 
Percentage Error for comparison. 

This table tracks the following on a weekly basis:

• History

• History Override

• Adjusted History

• Baseline Forecast

• Simulation

• Base Override

• % Chg to Base

• Final Forecast

• Absolute Deviation

• Absolute Percentage Error

• Demand Priority

This table also enables users to track final approval for each line in the forecast. For 
more information, see Approving the Forecast, page 3-11.
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About the Demand Tracking Graph
The Demand Tracking graph displays the Sales, Demand, Sales Forecast, Simulation, 
and Final Forecast values for the chosen product category over time. 

About the Detail Demand Analysis Embedded Worksheet
The Detail Demand Analysis table is an embedded worksheet that compares sales and 
demand figures for your chosen aggregation level, in weekly time buckets. It gives 
analysts a side-by-side view of their historical sales, and forecasted sales, along with 
Absolute Deviation and Absolute Percentage Error for easy comparisons.

Use this worksheet to look at the item level detail for the category. Analysts often look 
at a higher level first and if the data is not what they expect, they drill down to lower 
levels to see the detail. As you click on different categories, the detail level worksheet 
reflects the items for the category, allowing you to review details for that particular 
item.

Modifying Sales Override Values
1. In My Worksheets (in Collaborator Workbench), click Demand Analysis. Or if a 

worksheet is currently open, click File > Open. Click Demand Analysis and then 
click Open.
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2. If the worksheet does not show data immediately, click Data > Rerun. Or click the 
Run button.

This launches the Demand Analysis worksheet.

3. Enters data in the History Override field for history or base override and/or the % 
Chg to Base field for the Forecast. 

The results are shown in the Adjusted History and Final Forecast columns.

Note: You can select and edit multiple cells.

4. From the Data menu, choose Save Data. Or click the Save Data button.

5. From the Data menu, choose Rerun.

The worksheet updates to display the edited values.

Setting the Demand Priority
Note: This setting is only applicable for Demantra integrations with 
EBS.

1. In My Worksheets (in Collaborator Workbench), click Demand Analysis. Or if a 
worksheet is currently open, click File > Open. Click Demand Analysis and then 
click Open.

2. If the worksheet does not show data immediately, click Data > Rerun. Or click the 
Run button.

This launches the DM: Demand Analysis worksheet.

3. In the Demand Priority field, double-click the cell for which you want to set a 
demand priority.

4. Enter the desired (numerical) priority. 

5. From the File menu, choose Save Worksheet.

Approving the Forecast
Approvers are notified in the My Tasks window that a new forecast is available for the 
current planning cycle. 

1. In My Tasks (in Collaborator Workbench), click Demand Analysis. Or if a 
worksheet is currently open, click File > Open. Click Demand Analysis and then 
click Open.
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2. If the worksheet does not show data immediately, click Data > Rerun. Or click the 
Run button.

This launches the Demand Analysis worksheet.

3. Do one of the following:

• To approve a line item in the forecast, click the appropriate check box in the 
Approve column. 

• To final approve a line item in the forecast, click the appropriate check box in 
the Final Approve column. 

4. From the File menu, choose Save Worksheet.

5. In My Tasks (in Collaborator Workbench), select the Demand Analysis worksheet 
and then click Done.

Demand Management notifies the final approver when all analysts have approved 
the current forecast.

Reference
Basics:

Accessing this Worksheet Do one of the following:

1. In My Worksheets (in Collaborator Workbench), click the
relevant worksheet.

2. If a worksheet is currently open, click File >Open. Click 
on the relevant worksheet.

Levels you can select One of:

• Product Category and Zone

• Product Category and Organization

• Item and Organization

• Item and Zone

Time Aggregation Weekly unless Oracle Demantra was implemented with a 
monthly or daily time period.

Business Data:
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Series Group Series Description

EBS Input Demand Priority The allocated demand priority (note that this is 
series is only applicable for EBS integrations).

Forecast % Change to Base Factor override on sales forecast.

Base Override Manual override on sales forecast.

Final Forecast Final forecast (this appears in yellow if the 
difference between final forecast and final partner 
forecast does not meet the requirements of sales 
forecast tolerance).

Baseline Forecast Analytical sales forecast including user simulations.

Simulation Analytical re-forecast triggered by a user simulation.

Forecast Accuracy Abs Deviation Absolute deviation for the fit forecast.

Abs % Error Absolute percentage error for the fit forecast.

Final Approval When checked indicates that the forecast has 
received final approval. 

Final Approved By User who final approved the forecast.

Historical 
Demand

Adjusted History Shipment History – Request Date is the default.

History Historical actual sales/shipments. Shipment History 
– Request Date is the default.

History Override Manual override of historical actual sales/shipments.

Sales Adjusted History Unconstrained demand. Purple if out of stock.

History Historical actual sales/shipments.

History Override Manual override of historical actual sales/shipments.
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4
Configuring Demand Management

Overview of the Configuration Process
Demand Management works with supply chain planning data from external systems. 
Ultimately, those systems own most of the data; and Demand Management is 
responsible only for producing unconstrained forecasts for future demand and for 
generating tactical, operational, and strategic business plans.

Demand Management is designed for minimum amount of configuration, and comes 
with pre-seeded worksheets, users and groups, and workflows. To configure Demand 
Management, the general steps are as follows:
1. Demand Management utilizes users and user groups to facilitate the forecast review

process. Pre-seeded users are provided in the Business Modeler. The Administrator 
should modify these users to reflect the names of the analysts, forecast approver 
and administrator. Forecasts from each analyst require approval from the final 
approver.

In deployments using multiple lines of business, the Administrator should also 
assign product lines, families, and so on to analysts using Demantra User Security 
settings in the Demantra Business Modeler. 

For more information, see Configuring Demand Management Users, page 4-2.

2. Demand Management uses the Archive Forecast, Demand Forecast, and Planning 
Group workflows to facilitate approval process. These workflows must be 
configured to include the user names of your Demand Analysts, Demand Manager, 
and Demand Administrators. 

For more information, see Configuring Approval Workflows, page 4-5.

3. By default, Demand Management uses a weekly base time resolution with a 4-4-5 
weekly fiscal calendar hierarchy. This time resolution is fully configurable and may 
be changed to either days or months. As well, you can configure forecast start day, 
which is set to Monday by default. 
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For more information, see Configuring the Base Time Unit and Time Bucket Start 
Day, page 4-12.

4. You can optionally configure the Demand Management worksheets to display item 
short names and descriptions.

For more information, see Configuring the Item Short Name and Description, page 
4-16.

5. You can configure how Demantra handles future data using the MaxSalesGen 
parameter. This parameter determines how data after the end of history is 
populated. Demand Management uses a configurable MaxSalesGen parameter to 
control how the EP_LOAD process loads future data. 

For more information, see Controlling System and Engine Maximum Sales Dates, 
page 4-17.

6. Demand Management uses automated workflows to import sales and other 
referenced data from external corporate systems. These workflows provide 
integration to external systems such as Oracle EnterpriseOne and EBusiness Suite. 
The actual workflows used depend on your ERP system configuration, and must be
modified. As well, you may be required to make certain changes within your ERP 
environment.

Configuring Demand Management Users
During installation, Demand Management adds pre-seeded users and user groups that 
are required by the application and used for the approval process. During the 
configuration process, administrators should modify these users and groups to reflect 
the analysts and approvers who will be performing approval tasks. The Administrator 
also edits a pre-seeded Planning Group Workflow to specify the ID of the Final 
Approver who will be notified when the Analysts forecasts are ready for review. For 
more information on modifying user details, see Creating or Modifying a User in the 
Demantra User Guide.

Demand Management adds the users Analyst 1-5, to the system; these users belong to 
the new user group Demand Analyst. Admin1 and Manager1 are also added. These 
users are used within the Demand Management workflows. For more information on 
configuring these workflows, see Configuring Approval Workflows, page 4-5.

Filtering User Data
Note: Predefined users come with the ability to see all the data loaded 
into the system. If there is a requirement to limit this, a data filter can be
applied to the users. For more information on filtering user data, see "
Creating or Modifying a User" in the Demantra Implementation Guide. 
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1. Log on to the Business Modeler.

2. From the Security menu, choose Create/Modify User.

The Create/Modify User dialog box appears.

3. Double-click the user icon for which you want to filter user data.

4. The User wizard appears.

5. Click the Next button until the Select User Filters dialog box appears. This dialog 
box lets you filter the data that the user can see; specifically, you control which 
levels and members the user can see.
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6. Filter the data that the user can see, as follows:

• Click a level in the left side of the dialog box and drag it to the box on the right. 
Or double-click a level in the left side.

• Now specify which members of this level the user can see. To do so, click a 
member in the list, and then click the right arrow button. Or double-click the 
member you want to filter out.

The system moves the selected members to the box on the lower right side, as in 
this example:

7. Repeat the preceding steps for each filter you want to add. Each filter automatically 
limits the choices available in subsequent filters.
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8. When you have appropriately filtered data for the user, click Finish.

Configuring Approval Workflows
Oracle Demand Management uses the Archive Forecast, Demand Forecast and 
Planning Group workflows to automate the approval process. These workflows are 
pre-seeded to manage batch forecasting and facilitate the forecast approval process. 

The workflows should be scheduled to run regularly by the Administrator. Specifically, 
the workflows:

• Reset the Final Approval and Final Approve By series to null.

• Run the Analytical Engine to generate a statistical forecast.

• Notifies all users in the Demand Analyst group that the forecast is available.

• Notifies the Manager (the final approver), when all analysts have approved the 
forecast or when the process has exceeded an allotted time.

• Periodically rolls forecast data, based on engine profiles that are configured and 
activated in the Business Modeler.

Although these workflows do not generally require customization, the Administrator 
must ensure the Demand Analyst group contains the user names of the users who 
modify the forecast and the Manager1 and Admin1 users have also been specified.

Note: Before configuring your approval workflows, you should 
configure the users you plan to use for approvals. 

Configuring the Demand Forecast Workflow
The Demand Forecast workflow runs when the EP_LOAD process has completed, and 
resets the forecast approval status, generates a new forecast, and initiates the approval 
process.

1. Log into the Workflow Manager.

2. Locate the Demand Forecast workflow, and click the corresponding Edit button. 

The Edit Schema window opens, showing the Demand Forecast definition.
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3. Double-click the NotifyForecastFinalApproved user step.

The User Step's Properties dialog box appears.
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4. In the User drop-down list box, choose the Demand Management Administrator 
account that you want to notify when the forecast has been approved. The default is
Admin1.

5. Click OK. 

6. In the Workflow Editor, click the Save button.

Configuring the Planning Group Workflow
The Planning Group workflow is responsible for sending notifications to Demand 
Analysts and Demand Managers when forecasts have been approved or a set time-out 
condition is met.

1. Log into the Workflow Manager.

2. Locate the Planning Group workflow, and click the corresponding Edit button. 

The Edit Schema window opens, showing the Planning Group definition.

3. Double-click the NotifyForecastComplete group step.

The User Step's Properties dialog box appears.
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4. Do one of the following:

• From the Users list, select the users that you want to notify when the forecast is 
generated. To select more than one user, press and hold the Ctrl key while 
clicking users.

• From the Groups list, select the user group that you want to notify when the 
forecast is generated. To select more than one user, press and hold the Ctrl key 
while clicking groups.

5. Click the Time tab.

6. The Group Step's Properties dialog box appears.



Configuring Demand Management    4-9

7. In the Manager field, specify the user to notify if analysts' reviews are not 
completed on time. The default user is Manager1.

By default, the workflow's timeout is set to five days and the alert is set to four 
days. Depending on your planning cycle, you may want to increase or decrease this 
value. 

8. In the Timer section, enter a value (in days) at which point the workflow expires. 
When this time is reached, the user specified in the 
NotifyForecastAnalysisNotComplete step is initiated and the manager is notified 
that some of the Analysts have not reviewed their forecasts.

9. In the Alert Time section, enter a value (in days) at which point the workflow 
should send a reminder. 

10. Click OK.
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11. Double-click the NotifyForecastAnalysisComplete User Step.

The User Step's Properties dialog box appears.

12. In the User drop-down list box, choose the user that you want to notify when all 
approvals are completed; the default is Manager1.

13. Click OK.

14. Double-click the NotifyForecastAnalysisNotComplete User step.

The User Step's Properties dialog box appears.

15. In the User drop-down list box, choose the user that is to be notified that the 
Analysts' reviews are complete before the specified timeout. The default value is 
Manager1.

16. Click OK.

17. In the Workflow Editor, click the Save button.
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Configuring the Approve Forecast Workflow
The Approve Forecast workflow rolls forecast data, based on the engine profiles 
configured and activated in the Business Modeler. For more information, see 
Configuring Rolling Data in the Demantra Implementation Guide.

1. Log in to the Workflow Manager.

2. Locate the Approve Forecast workflow, and click the corresponding Edit button. 

The Edit Schema window opens, showing the Approve Forecast definition.

3. Double-click the User step.

4. In the User drop-down list box, enter the user name for the Demand Administrator 
that you want to notify when the forecast is rolled; the default is Admin1.

5. Click OK.

6. In the Workflow Editor, click the Save button.

Configuring Approval Workflows for Multiple User Groups
If there is more than one group of Analysts and Managers (Final Approver) that review 
and modify the forecast, then the Administrator must change the pre-seeded workflows
to handle the additional groups. Specifically, you must:

1. Duplicate Planning Group workflow with the following modifications for each 
additional group:

1. Log in to the Workflow Manager.

2. Edit the Planning Group workflow.

3. In the Planning Group workflow's Group Step dialog box, add the additional 
group and users that are part of the approval process.

4. Click the Time tab.

5. Check the Manager check box and select the Manager's ID from the list of 
values.

6. Modify Timeout settings, if required.

7. Click OK.

2. Modify the Demand Forecast workflow to add additional ApproveForecast steps:

1. Log in the Workflow Manager.
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2. Edit the Demand Forecast workflow.

3. Double click the Custom Step icon to add an additional custom step.

4. In the Class Name field, enter the class name. This should be the same as in the 
original step. (For example, 
com.demantra.workflow.step.WorkflowLauncherStep).

5. In the Parameters section, click Add.

6. Add the schema_id parameter, and assign it the same value as the schema_id 
parameter in the duplicate Planning Group workflow created in step 1.

7. Add the user_id parameter, and assign it the same value as the user_id 
parameter in the duplicate Planning Group workflow created in step 1.

8. Add the sync parameter, and assign it the same value as the sync parameter in 
the duplicate Planning Group workflow created in step 1.

9. Click OK.

Configuring the Base Time Unit and Time Bucket Start Day
The default Demand Management time hierarchy is a 4-4-5 (week) fiscal calendar. You 
can change this configuration to suit your business needs. If you change the base time 
unit from Week to either Day or Month, then all worksheets and integration profiles 
need to be re-configured. The data model must be upgraded for the changes to take 
effect.

The base time bucket start day is Mondays by default, with the week ending Sunday. 
The Demand Administrator may change this base time unit after initial installation 
using the Business Modeler's Data Model wizard. 

Note: This change will affect all users in the system and should be 
coordinated through the Demantra system administrator. In addition, 
changing this setting will clear all time dependant information in the 
system and require a full historical refresh.

If the time bucket is changed from weekly to either daily or monthly, then the 
corresponding series has to be created for the lagged forecast series used in the 
Waterfall Analysis worksheets. For example, it may no longer be appropriate to use the 
last 13 lagged forecast cycles as a base for the worksheet. 

Changing the Base Time Unit and Time Bucket Start Day
1. Log into the Business Modeler. If you do not have access to this, contact your 
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Demantra system administrator.

2. From the Data Model menu, choose Open Data Model. 

The Open Existing Data Model/Template dialog appears

3. Double-click the Demand Management model icon.

The Data Wizard appears.

4. Click the Next button twice.

The Select Time Bucket dialog box appears.
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5. In the Time Bucket field, choose the level at which you want your time buckets.

6. In the First Day of Week field, choose the day of the week on which you want to 
start the time bucket.

7. Click the Next button until you reach the Finish Wizard dialog box.

8. Click the Build Model button.

The Build/Upgrade Model dialog box appears.
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9. Now you can select whether to completely replace the existing data model or just 
modify it:

• If you want to completely replace the existing data model, choose Build New 
Model and select one of the, following options:

• Replace Series: Click this to completely replace the existing series 
definitions.

• Keep Series: Click this if you do not want to make any changes to the 
existing series. This option is suitable if you are in the process of working 
on the data model but do not want to spend the time updating the series 
definitions right now.

Note: This option will delete all worksheets, integrations 
and other aspects of the Demand Management application.

• Alternatively, if you are just modifying an existing data model, select Upgrade 
Existing Model. In this case, if you have made changes to the base time unit, 
select Run Time Bucket.

10. Click OK.

The process of building the data model begins. This may take a few minutes.
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• Demantra highly recommends upgrading an existing model, rather
than building a new model. For more information, see 
Building/Upgrading Models in the Demantra Implementation 
Guide.

• You will need to redefine integration profiles and worksheets if the 
time levels specified therein are now invalid.

Configuring the Item Short Name and Description
Use the following procedure to configure your worksheets to display item short names 
(for example, AS63311) and descriptions (for example, Vision Pad Gold Item 1). 

1. Log on to the Collaborator Workbench.

2. In My Tasks, click the worksheet to which you want to add item short names and 
descriptions.

Or if a worksheet is currently open, click File > Open. Click the worksheet to which 
you want to add item short names and descriptions, and then click Open.

3. From the Worksheets menu, choose Layout Designer.

The Worksheet Designer appears.

4. Click the Aggregation button.
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5. Do one or more of the following to add item short names and descriptions to the 
worksheet:

• To display the item short name, select Item.

• To display the item description, select Item Description.

6. Click the Filters button.

7. Do one or more of the following to add item short names and descriptions to the 
worksheet:

• To display the item short name, select Item.

• To display the item description, select Item Description.

8. Click OK.

9. From the Data menu, choose Rerun.

Controlling System and Engine Maximum Sales Dates
Traditionally, only historical information was loaded into Demantra using the 
EP_LOAD process. All future information (that is, forecast data) is loaded using 
integration profiles or other loading mechanisms. This mechanism controlled the dates 
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marked as end of history for the Forecasting Engine and the Collaborator Workbench.

With the addition of the MaxSalesGen parameter, you can now use the EP_LOAD 
process to load future dates into Demantra. This parameter determines how data after 
the end of history is populated.

Note: When populating the MaxSalesGen parameter, its important to 
enter all dates in the MM-DD-YYYY 00:00:00 format.

Populating the MaxSalesGen Parameter
1. Log into the Demantra Business Modeler.

2. From the Parameters menu, choose System Parameters.

The System Parameters dialog box appears.

3. Click the System tab.

4. In the MaxSalesGen field, enter one of the following values:

• Null: If you leave this parameter blank, Demantra compares the last date 
loaded into the system to the current last system date. The latest of the two 
dates is set to the last date of history.

Use this setting when only historical dates are being loaded.

• Sysdate: Use this value to base the last date of history on the period containing 
today's date. For example, in a weekly system with weeks beginning Monday, if
run on Feb 16th 2007 the last date of history would be set to the previous 
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Monday 2/12/2007. For a monthly system run on the same date the end of 
history would be set to 2/1/2007.

Use this value where the system date should match current date while allowing
future information to be loaded.

• 01-01-1900 00:00:00: Use this date to set the end of history to the last date in the 
sales_data table where the actual_quantity column>0.

Use this value in production environments where future information is being 
loaded but there is a lag in historical information availability. It is critical that 
the data used to drive the engine be stored in the actual_quantity column. Note 
that using this setting can potentially increase loading times for large 
deployments.

• Any date other than 01-01-1900 00:00:00: Any other date will cause the last date
of history to be based on the entered date. In a weekly system with weeks 
beginning Monday, if date entered is Jan 16th 2007 the last date of history 
would be set to the previous Monday 1/15/2007. For a monthly system run with
the same parameter setting the end of history would be set to 1/1/2007.

Use this value to test systems where the desired end of history date does not 
match executed date. Allows users full control on dates assigned as end of 
history and beginning of forecast.

5. Click the Save button.
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A
Demand Management Levels and Series

Demand Management Levels
The following is a list of the available levels in the Demand Management application:

Available EBS Levels
For Item dimensions:

• Demand Class 

• Item

• Product Category 

• Product Description 

• Product Family 

For Location dimensions:

• Organization

• Legal Entity 

• Operation Unit 

• Business Group 

• Sales Channel 

• Site 

• Account 
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• Customer 

• Customer Class 

• Trading Partner Zone 

• Zone 

Available EnterpriseOne Levels
For Item dimensions:

• Item 

• Item Category Code 1

• Item Category Code 2

• Item Category Code 3

• Item Category Code 4

• Item Category Code 5

• Item Category Code 6

• Item Category Code 7

• Product Description 

For Location dimensions:

• Organization

• Item Category Code 1

• Item Category Code 2

• Item Category Code 3

• Item Category Code 4

• Item Category Code 5

• Branch City

• Branch Country 
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• Branch State 

• Site 

• Account 

• Customer Category Code 1

• Customer Category Code 2

• Customer Category Code 3

• Customer Category Code 4

• Customer Category Code 5

• Customer Category Code 6

• Customer Category Code 7

• Customer City 

• Customer Country 

• Customer State 

• Trading Partner Zone 

Demand Management Series
The following is a list of series used by the Demand Management application:

Series Description

% Change to Base Factor Override on Sales Forecast

1 Week Lag Forecast Forecast as of 1 Week ago.

10 Week Lag Forecast Forecast as of 10 Weeks ago.

11 Week Lag Forecast Forecast as of 11 Weeks ago

12 Week Lag Forecast Forecast as of 12 Weeks ago
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13 Week Lag Absolute 
Dev

Absolute Deviation of 13 Week Lagged Forecast

(abs(13 Week Lag Forecast - Adjusted History)) 

13 Week Lag Absolute 
Pct Err

Absolute Pct Error of 13 Week Lagged Forecast 

(abs(13 Week Lag Forecast - Adjusted History)/ Adjusted History) 

13 Week Lag Forecast Forecast as of 13 Weeks ago

13 Week Lag Pct Err Pct Error of 13 Week Lagged Forecast 

((13 Week Lag Forecast - Adjusted History)/Adjusted History) 

2 Week Lag Forecast Forecast as of 2 Weeks ago

3 Week Lag Forecast Forecast as of 3 Weeks ago

4 Week Lag Absolute 
Dev

Absolute Deviation of 4 Week Lagged Forecast 

(abs(4 Week Lag Forecast - Adjusted History)) 

4 Week Lag Absolute 
Pct Err

Absolute Pct Error of 4 Week Lagged Forecast 

(abs(4 Week Lag Forecast - Adjusted History)/ Adjusted History) 

4 Week Lag Forecast Forecast as of 4 Weeks ago

4 Week Lag Pct Err Pct Error of 4 Week Lagged Forecast

((4 Week Lag Forecast - Adjusted History)/Adjusted History) 

5 Week Lag Forecast Forecast as of 5 Weeks ago

6 Week Lag Forecast Forecast as of 6 Weeks ago

7 Week Lag Forecast Forecast as of 7 Weeks ago

8 Week Lag Absolute 
Dev

Absolute Deviation of 8 Week Lagged Forecast 

(abs(8 Week Lag Forecast - Adjusted History)) 

8 Week Lag Absolute 
Pct Err

Absolute Pct Error of 8 Week Lagged Forecast 

(abs(8 Week Lag Forecast - Adjusted History)/ Adjusted History) 
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8 Week Lag Forecast Forecast as of 8 Weeks ago

8 Week Lag Pct Err Pct Error of 8 Week Lagged Forecast 

((8 Week Lag Forecast - Adjusted History)/Adjusted History) 

9 Week Lag Forecast Forecast as of 9 Weeks ago

Abs % Error Absolute % Error for Fit Forecast

Abs Deviation Absolute Deviation for Fit Forecast

Adjusted History Final History data including adjustments

Base Override Manual Override on Sales Forecast

Baseline Forecast Analytical Sales Forecast Including User Simulations

Booking - Req Qty - 
Req Date

Booking History - Requested Quantity - Requested Date

Booking - Book Qty - 
Book Date

Booking History - Booked Quantity - Booked Date

Booking - Book Qty - 
Req Date

Booking History - Booked Quantity - Requested Date

Booking - Req Qty - 
Book Date

Booking History - Requested Quantity - Booked Date

Demand Class 
Destination Key

Demand Class Destination Key

Demand Priority Demand Priority

EBSPRICELIST0 to 
EBSPRICELIST129

Price lists

Final Approval Final Approved if Checked

Final Approved By User who finally approved the forecast

Final Forecast Final Forecast 
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History Historical Actual Sales/Shipment

History Override Historical Manual Override on Sales

Item Destination Key Item Destination Key

Mean Absolute Pct Err Mean Absolute Pct Err

Organization 
Destination Key

Organization Destination Key

Pct Bias Pct Bias

Relative Err Relative Err

Return History Returns History

Return History Site 
Source Key

Returns History Site Source Key

Root Mean Squared 
Err

Root Mean Squared Err

Sales Channel 
Destination Key

Sales Channel Destination Key

Shipping - Req Qty - 
Req Date

Shipping History - Requested Quantity - Requested Date

Shipping - Ship Qty - 
Req Date

Shipping History - Shipped Quantity - Requested Date

Shipping - Ship Qty- 
Ship Date

Shipping History - Shipped Quantity - Shipped Date

Simulation Analytical Re-Forecast Triggered by a User Simulation

Site Destination Key Site Destination Key
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