
Oracle® Demantra Predictive Trade Planning
User's Guide
Release 7.1.1
Part No. E05137-01

March 2007



Oracle Demantra Predictive Trade Planning User's Guide, Release 7.1.1

Part No. E05137-01

Copyright © 2007, Oracle. All rights reserved. 

Primary Author:     Nile Leach, Sunanda Chatterjee

The Programs (which include both the software and documentation) contain proprietary information; they 
are provided under a license agreement containing restrictions on use and disclosure and are also protected 
by copyright, patent, and other intellectual and industrial property laws. Reverse engineering, disassembly, or
decompilation of the Programs, except to the extent required to obtain interoperability with other 
independently created software or as specified by law, is prohibited. 

The information contained in this document is subject to change without notice. If you find any problems in 
the documentation, please report them to us in writing. This document is not warranted to be error-free. 
Except as may be expressly permitted in your license agreement for these Programs, no part of these 
Programs may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any 
purpose. 

If the Programs are delivered to the United States Government or anyone licensing or using the Programs on 
behalf of the United States Government, the following notice is applicable: 

U.S. GOVERNMENT RIGHTS
Programs, software, databases, and related documentation and technical data delivered to U.S. Government 
customers are "commercial computer software" or "commercial technical data" pursuant to the applicable 
Federal Acquisition Regulation and agency-specific supplemental regulations. As such, use, duplication, 
disclosure, modification, and adaptation of the Programs, including documentation and technical data, shall 
be subject to the licensing restrictions set forth in the applicable Oracle license agreement, and, to the extent 
applicable, the additional rights set forth in FAR 52.227-19, Commercial Computer Software--Restricted 
Rights (June 1987). Oracle Corporation, 500 Oracle Parkway, Redwood City, CA 94065. 

The Programs are not intended for use in any nuclear, aviation, mass transit, medical, or other inherently 
dangerous applications. It shall be the licensee's responsibility to take all appropriate fail-safe, backup, 
redundancy and other measures to ensure the safe use of such applications if the Programs are used for such 
purposes, and we disclaim liability for any damages caused by such use of the Programs. 

The Programs may provide links to Web sites and access to content, products, and services from third parties. 
Oracle is not responsible for the availability of, or any content provided on, third-party Web sites. You bear all
risks associated with the use of such content. If you choose to purchase any products or services from a third 
party, the relationship is directly between you and the third party. Oracle is not responsible for: (a) the quality
of third-party products or services; or (b) fulfilling any of the terms of the agreement with the third party, 
including delivery of products or services and warranty obligations related to purchased products or services.
Oracle is not responsible for any loss or damage of any sort that you may incur from dealing with any third 
party. 

Oracle, JD Edwards, PeopleSoft, and Siebel are registered trademarks of Oracle Corporation and/or its 
affiliates. Other names may be trademarks of their respective owners. 



    iii

 
Contents

Send Us Your Comments

Preface

Part 1 Introduction and Basics

1 PTP Introduction
Overview................................................................................................................................... 1-1
Dashboard: Collaborator Workbench....................................................................................... 1-2
Predictive Trade Planning Business Processes and Worksheets............................................. 1-3
Promotion Modeling and Optimization Business Processes and Worksheets........................1-5
Forecasting and Simulation...................................................................................................... 1-7
Optimization............................................................................................................................. 1-7

2 Predictive Trade Planning Concepts
Worksheet Basics....................................................................................................................... 2-1
PTP Data Hierarchy................................................................................................................... 2-2
Promotions................................................................................................................................. 2-6
Retailer Profiles......................................................................................................................... 2-8
Funding...................................................................................................................................... 2-8
Promotion Costs and Spending................................................................................................ 2-9
Volume and Volume Breakdown............................................................................................. 2-9
Data Access.............................................................................................................................. 2-11



iv

3 Logging On and Getting Started
Initial Logon and Download..................................................................................................... 3-1
Logging Onto PTP..................................................................................................................... 3-3
Tutorial: Getting Acquainted with Worksheets....................................................................... 3-3
Controlling Synchronization of Embedded Worksheets......................................................... 3-6
Logging Off PTP........................................................................................................................ 3-7
Ending a Hung Session............................................................................................................. 3-7
Changing Your Password.......................................................................................................... 3-8

4 Working with Data
Editing Data............................................................................................................................... 4-1
Saving and Viewing Changes................................................................................................... 4-3
Sorting Worksheet Data............................................................................................................ 4-4
Copying and Pasting Data.........................................................................................................4-5
Copying and Pasting to and from Microsoft Excel................................................................... 4-6
Exporting Data to Microsoft Excel............................................................................................ 4-6
Linking Data into Third-Party Reporting Tools (via DOL)..................................................... 4-7
Printing.................................................................................................................................... 4-10
Viewing Notes......................................................................................................................... 4-11
Editing Notes........................................................................................................................... 4-13
Viewing and Managing Attachments to Notes...................................................................... 4-14
Specifying Note Permissions.................................................................................................. 4-16
Refreshing the Local Worksheet Cache.................................................................................. 4-17
Viewing the Audit Trail.......................................................................................................... 4-17

5 Managing the Screen
Managing Multiple Worksheets............................................................................................... 5-1
Managing Worksheet Views..................................................................................................... 5-3
Managing View Elements......................................................................................................... 5-4
Changing the Graph Style.........................................................................................................5-4
Managing Empty Rows............................................................................................................. 5-5
Worksheet, Layout, and Data.................................................................................................... 5-6
Worksheet Definition, Layout, and Local Adjustments...........................................................5-7

Part 2 PTP and PMO Business Processes

6 Oracle Demantra Dashboard
Introduction to the Dashboard..................................................................................................6-1



    v

Reviewing Metrics.....................................................................................................................6-3
Reviewing the Planning Hierarchy...........................................................................................6-4
Editing Retailer Information..................................................................................................... 6-5
Opening Worksheets................................................................................................................. 6-8
Managing Tasks........................................................................................................................ 6-9
Creating and Sending a Task.................................................................................................... 6-9
Personalizing the Dashboard.................................................................................................. 6-11

Configuring Your Default Layout......................................................................................6-11
Configuring My Tasks....................................................................................................... 6-13
Configuring My Worksheets..............................................................................................6-14

7 PTP: Managing and Viewing Quotas and Funds
Overview................................................................................................................................... 7-1
Managing Quotas and Funds at the Retailer Level.................................................................. 7-3
Managing Quotas and Funds at the Promotion Group Level.................................................. 7-6
Viewing Quotas and Funds.......................................................................................................7-7
Reference................................................................................................................................... 7-8

8 PTP: Tracking Volume
Overview................................................................................................................................... 8-1
Reference................................................................................................................................... 8-5

9 PMO: Planning Promotions
Introduction to the Planning Environment.............................................................................. 9-1
Creating a Promotion................................................................................................................ 9-6
Marking a Promotion as Planned............................................................................................. 9-8
Approving a Promotion............................................................................................................. 9-9
Committing a Promotion........................................................................................................... 9-9
Marking a Promotion as Partially Paid or Paid...................................................................... 9-10
Closing a Promotion................................................................................................................ 9-10
Making Other Changes to a Promotion.................................................................................. 9-10
Copying and Pasting a Promotion.......................................................................................... 9-13
Deleting a Promotion.............................................................................................................. 9-13
Reference................................................................................................................................. 9-14

10 PMO: Simulation and Optimization
Overview................................................................................................................................. 10-1
Running the Analytical Engine in Simulation Mode.............................................................10-3
Running a Simulation............................................................................................................. 10-3



vi

Optimizing a Promotion......................................................................................................... 10-4
Viewing Optimization Results............................................................................................... 10-7
Accepting an Optimized Promotion....................................................................................... 10-9
Reference............................................................................................................................... 10-10

11 PMO: Examining and Comparing Promotions
Overview................................................................................................................................. 11-1
Examining Promotions from the Manufacturer's Point of View........................................... 11-2
Examining Promotions from a Retailer's Point of View........................................................ 11-6
Comparing Promotions in a Scenario..................................................................................... 11-8
Reference............................................................................................................................... 11-10

12 PMO: Reviewing Past Performance
Overview................................................................................................................................. 12-1
Evaluating Performance from the Manufacturer's Point of View..........................................12-2
Evaluating Performance from a Retailer's Point of View.......................................................12-5
Viewing Actual Averages........................................................................................................ 12-8
Reference................................................................................................................................. 12-9

Part 3 Advanced Topics and Reference

13 Creating Worksheets and Content Panes
Introduction............................................................................................................................. 13-2
Working with Lists.................................................................................................................. 13-3
Creating or Editing a Worksheet or Content Pane................................................................. 13-3
Configuring the Basics............................................................................................................ 13-4
Selecting Series on a Worksheet............................................................................................. 13-6
Managing the Series Lists....................................................................................................... 13-7
Specifying the Time Resolution and Time Span................................................................... 13-9
Specifying Aggregation Levels............................................................................................. 13-11
Using the Advanced Selection Options................................................................................ 13-12
Changing the Overall Scale or Unit of Measure...................................................................13-14
Filtering the Worksheet or Content Pane............................................................................. 13-16
Managing the List of Members............................................................................................. 13-18
Applying Exception Filters................................................................................................... 13-18
Defining the View Layout.....................................................................................................13-20
Adding and Managing Worksheet Views............................................................................ 13-22
Specifying the Worksheet Elements in a View.................................................................... 13-24
Displaying an Embedded Worksheet................................................................................... 13-25



    vii

Filtering a Worksheet View.................................................................................................. 13-26
Sharing Worksheet and Content Panes................................................................................ 13-28
Deleting Worksheet or Content Panes..................................................................................13-28
General Tips on Worksheet Design......................................................................................13-28

14 Administration
Running the Analytical Engine...............................................................................................14-1
Running Required Workflows................................................................................................14-2
Managing the PTP Users......................................................................................................... 14-8

15 PTP Demo Script
Overall Notes........................................................................................................................... 15-1
About World Brands............................................................................................................... 15-2
User IDs and Passwords.......................................................................................................... 15-3
Configuring the PTP Demo for Demand Management......................................................... 15-5
PTP: Setting Quotas and Funds............................................................................................ 15-11
PMO: Creating, Simulating, and Optimizing a Promotion..................................................15-15
PMO: Committing a Promotion............................................................................................ 15-34
PMO: Examining Past Promotions........................................................................................15-35

16 PTP Reference
Series........................................................................................................................................ 16-1
Item Levels.............................................................................................................................16-23
Location Levels...................................................................................................................... 16-23
Retailer................................................................................................................................... 16-24
Promotion Levels................................................................................................................... 16-26
Lookup Tables....................................................................................................................... 16-31
Methods................................................................................................................................. 16-33
Procedures............................................................................................................................. 16-34
Triggers.................................................................................................................................. 16-35
Workflows............................................................................................................................. 16-36
Engine Configuration............................................................................................................ 16-38

Index





    ix

 
Send Us Your Comments

Oracle Demantra Predictive Trade Planning User's Guide, Release 7.1.1
Part No. E05137-01

Oracle welcomes customers' comments and suggestions on the quality and usefulness of this document. 
Your feedback is important, and helps us to best meet your needs as a user of our products. For example: 

• Are the implementation steps correct and complete? 
• Did you understand the context of the procedures? 
• Did you find any errors in the information? 
• Does the structure of the information help you with your tasks? 
• Do you need different information or graphics? If so, where, and in what format? 
• Are the examples correct? Do you need more examples? 

If you find any errors or have any other suggestions for improvement, then please tell us your name, the 
name of the company who has licensed our products, the title and part number of the documentation and
the chapter, section, and page number (if available). 

Note: Before sending us your comments, you might like to check that you have the latest version of the 
document and if any concerns are already addressed. To do this, access the new Applications Release 
Online Documentation CD available on Oracle MetaLink and www.oracle.com. It contains the most 
current Documentation Library plus all documents revised or released recently. 

Send your comments to us using the electronic mail address: appsdoc_us@oracle.com

Please give your name, address, electronic mail address, and telephone number (optional). 

If you need assistance with Oracle software, then please contact your support representative or Oracle 
Support Services. 

If you require training or instruction in using Oracle software, then please contact your Oracle local office
and inquire about our Oracle University offerings. A list of Oracle offices is available on our Web site at 
www.oracle.com. 





    xi

 
Preface

Intended Audience
Welcome to Release 7.1.1 of the Oracle Demantra Predictive Trade Planning User's Guide.

See Related Information Sources on page xii for more Oracle Applications product 
information. 

TTY Access to Oracle Support Services
Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services 
within the United States of America 24 hours a day, seven days a week. For TTY 
support, call 800.446.2398. 

Documentation Accessibility
Our goal is to make Oracle products, services, and supporting documentation 
accessible, with good usability, to the disabled community. To that end, our 
documentation includes features that make information available to users of assistive 
technology. This documentation is available in HTML format, and contains markup to 
facilitate access by the disabled community. Accessibility standards will continue to 
evolve over time, and Oracle is actively engaged with other market-leading technology 
vendors to address technical obstacles so that our documentation can be accessible to all
of our customers. For more information, visit the Oracle Accessibility Program Web site 
at http://www.oracle.com/accessibility/ . 

Accessibility of Code Examples in Documentation
Screen readers may not always correctly read the code examples in this document. The 
conventions for writing code require that closing braces should appear on an otherwise 
empty line; however, some screen readers may not always read a line of text that 
consists solely of a bracket or brace. 



xii

Accessibility of Links to External Web Sites in Documentation
This documentation may contain links to Web sites of other companies or organizations
that Oracle does not own or control. Oracle neither evaluates nor makes any 
representations regarding the accessibility of these Web sites. 

Structure
1  PTP Introduction
2  Predictive Trade Planning Concepts
3  Logging On and Getting Started
4  Working with Data
5  Managing the Screen
6  Oracle Demantra Dashboard
7  PTP: Managing and Viewing Quotas and Funds
8  PTP: Tracking Volume
9  PMO: Planning Promotions
10  PMO: Simulation and Optimization
11  PMO: Examining and Comparing Promotions
12  PMO: Reviewing Past Performance
13  Creating Worksheets and Content Panes
14  Administration
15  PTP Demo Script
16  PTP Reference

Related Information Sources

Do Not Use Database Tools to Modify Oracle Applications Data
Oracle STRONGLY RECOMMENDS that you never use SQL*Plus, Oracle Data 
Browser, database triggers, or any other tool to modify Oracle Applications data unless 
otherwise instructed. 

Oracle provides powerful tools you can use to create, store, change, retrieve, and 
maintain information in an Oracle database. But if you use Oracle tools such as 
SQL*Plus to modify Oracle Applications data, you risk destroying the integrity of your 
data and you lose the ability to audit changes to your data. 

Because Oracle Applications tables are interrelated, any change you make using an 
Oracle Applications form can update many tables at once. But when you modify Oracle 
Applications data using anything other than Oracle Applications, you may change a 
row in one table without making corresponding changes in related tables. If your tables 
get out of synchronization with each other, you risk retrieving erroneous information 
and you risk unpredictable results throughout Oracle Applications. 

When you use Oracle Applications to modify your data, Oracle Applications 
automatically checks that your changes are valid. Oracle Applications also keeps track 



    xiii

of who changes information. If you enter information into database tables using 
database tools, you may store invalid information. You also lose the ability to track who
has changed your information because SQL*Plus and other database tools do not keep a
record of changes. 





Part 1
Introduction and Basics





PTP Introduction    1-1

1
PTP Introduction

This chapter covers the following topics:

• Overview

• Dashboard: Collaborator Workbench

• Predictive Trade Planning Business Processes and Worksheets

• Promotion Modeling and Optimization Business Processes and Worksheets

• Forecasting and Simulation

• Optimization

Overview
Oracle Demantra's Predictive Trade Planning and Trade Promotion Optimization 
applications provide a complete Predictive Trade Planning (PTP) solution, is a powerful
combination of a financial application to manage retailer trade funds coupled with a 
comprehensive promotion analysis tool specifically targeted at manufacturers for the 
purpose of better planning trade funds usage. The application considers sales, point of 
sale (POS), and syndicated data to provide advanced pre and post promotion analysis:

• Historical event evaluation, including detailed analysis of lift components, taking 
into account both direct and indirect effects

• Base volume forecast by item over time based on past history

• Event planning

• Incremental volume forecast based on user-defined promotional variables and 
causals (by product, time, price, vehicle, buydown, and so on) 

• Detailed fund analysis, including quota versus actuals

• Event optimization taking into consideration a variety of constraints (time, budget, 
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spend, number of events, and so on)

While Oracle Demantra's PTP solution provides standard, out-of-the-box configuration 
to achieve this, it also recognizes that every manufacturer manages accounts and trade 
promotions a bit differently. The application is highly configurable, allowing Oracle 
Demantra consultants and trained users to tailor them to the customer's needs, both 
today and as these needs evolve in the future.

Dashboard: Collaborator Workbench
The Collaborator Workbench is the starting point for Oracle Demantra's PTP solution. 
You log into the application and immediately have access to a number of key 
performance indicators (KPIs), displayed inside content panes. PTP provides several 
out-of-the-box content panes, and you can add others. Collaborator Workbench looks 
like this:



PTP Introduction    1-3

From here, you can launch worksheets and review tasks. Each worksheet is a working 
environment designed to support specific business processes. In general, you can open 
worksheets from within Collaborator Workbench or from worksheets that are currently 
open.

For details, see Oracle Demantra Dashboard.

Predictive Trade Planning Business Processes and Worksheets
For PTP business processes, you start in the Collaborator Workbench and launch any of 
the PTP worksheets. The following diagram shows the overall workflow:
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PTP includes the following worksheets:

• PTP: Quota and Fund Entry: Top-Down allows headquarters to manage funds, 
including fund rates and fixed funds as well as sales quotas, at a fairly high level 
(yearly, for retailers and territories). PTP provides the following standard set of 
promotion funds: Brand Development Funds (BDF), Market Development Funds 
(MDF), and slotting funds. In turn, both BDF and MDF include a fixed portion (for 
fixed funds) and a volume-dependent portion, per common practice. 

• PTP: Quota and Fund Entry: Bottom-Up is provided to help you fine-tune quotas 
and funds, by displaying their breakout, weekly, by promotion group. You can edit 
values at this level and they are automatically rolled up to the higher level. At all 
times, upper-level and lower-level numbers are automatically reconciled.

• PTP: Quota and Fund View is a read-only version of the bottom-up entry 
worksheet. It allows you to view authorized funds against your sales quota.

• Volume Tracking is the central location where product, territory, and account 
volumes are forecasted and monitored to ultimately feed volume requirements to 
operations. Fund planning already covered is integrated with volume planning, 
because forecast volumes drive budgets in live accrual environments and drive 
spending for case rate allowances and other variable spending deals.

• Volume Tracking - Detail is similar to Volume Tracking, but allows you to drill 
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down to the retailer level.

For details, see PTP: Managing and Viewing Quotas and Funds, and PTP: Tracking 
Volume.

Promotion Modeling and Optimization Business Processes and 
Worksheets

For PMO business processes, you generally start in the Collaborator Workbench, and 
then open the Planning Environment worksheet. From there, you right-click a 
promotion and launch any of the PMO worksheets to see data for that promotion. Or, to
compare multiple promotions, you right-click a scenario and launch a worksheet to 
view the promotions in that scenario side-by-side. From within an open worksheet, you
can also launch a different worksheet, to look at the same promotion in a different way.

The following diagram shows the overall workflow:
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PMO includes the following worksheets:

• Planning Environment is the entry point to both historical and planned event 
analysis. Event planning consists of creating and managing a calendar of 
promotional events, and understanding their impact on sales, promotion spending, 
and profitability, as well as their correlation with sales quotas. The Planning 
Environment provides all this critical information in one place. See PMO: Planning 
Promotions

• PMO: Promo Effect - Mfg display the effects of future promotions, to show the 
impact on volume and spending, as well as a breakdown of the event with respect 
to the sales dollars and profit generated for the manufacturer. See PMO: Examining 
and Comparing Promotions.

• PMO: Promo Effect - Rtl is similar to the previous worksheet, but shows the 
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breakout of cannibalization effects as a retailer would view them.

• PMO: Promotion Comparison helps you compare and evaluate multiple 
promotions in a scenario, so that you can determine how best to spend trade 
dollars. Typically you create multiple potential promotions in the Sandbox and 
compare them side by side here. See PMO: Examining and Comparing Promotions

• PMO: Optimization Comparison provides the capability to simultaneously view 
and compare the results of a promotion before and after running optimization. 
After comparing, you can accept, reject, or reoptimize the promotion. Once satisfied
with the results of a promotion, you can add it to your current plan. See PMO: 
Simulation and Optimization.

• PMO: Promo-Evaluation: Mfg and PMO: Promo-Evaluation: Rtl provide a detailed 
post-promotional analysis of each individual promotion (by compare forecast to 
actual performance), from the manufacturer's point of view and the retailer's point 
of view, respectively. Here, you can view the breakdown of each event with respect 
to the sales dollars and profit generated for the manufacturer and retailer. See PMO:
Revievieng Past Performance.

• PMO: Promotion History displays the past averages for each promotion type, in a 
number of different contexts. See PMO: Reviewing Past Performance.

Forecasting and Simulation
Typically, the Analytical Engine is run periodically in batch mode, perhaps weekly, to 
generate a forecast for all items and locations in the system. The forecast data includes 
total volume, base volume (volume in the absence of promotions), pre- and 
post-promotional volume, and volume due to cannibalization. This forecast, including 
the detailed breakdown of promotional effects, is available for future dates and for the 
past—so that you can better understand promotions that have already run.

Running the Analytical Engine in batch mode may take hours, depending on the 
volume of data, so PTP also provides the ability to run simulations. You can run a 
simulation quickly, see the results, and accept or reject them.

A simulation generates a forecast for a much smaller set of data, typically a single 
promotion, and provides immediate data for the total volume, base volume (volume in 
the absence of promotions), pre- and post-promotional volume. Depending on where 
you perform a simulation, you may also be able to see cannibalization; this depends on 
whether the worksheet contains all the data that the Analytical Engine needs to find 
cannibalization effects.

Optimization
The effectiveness of a promotion depends on many factors, as noted earlier. To help you
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find the most effective promotion for your needs, PTP provides the ability to optimize a 
promotion.

The Promotion Optimization module uses the previously stored results of the 
Analytical Engine and information about past variations in the promotions. You 
provide a specific goal (optimizing units, revenue, or profit) and constraints (such as 
minimum retailer margin), and the optimizer determines the best set of promotion 
properties.
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2
Predictive Trade Planning Concepts

This chapter covers the following topics:

• Worksheet Basics

• PTP Data Hierarchy

• Promotions

• Retailer Profiles

• Funding

• Promotion Costs and Spending

• Volume and Volume Breakdown

• Data Access

Worksheet Basics
This section provides a closer look at the basic data elements in worksheets, introduced 
previously in "Tutorial: Getting Acquainted with Worksheets."

Levels (Segmentation)
A level lets you aggregate or group data in a worksheet. The following example shows 
part of a worksheet that uses the territory, retailer, and category levels:

Here, you select a territory, then a retailer, and then a product category to display. The 
data in the rest of the worksheet is aggregated across this territory, retailer, and 
category.
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Oracle Demantra uses several different kinds of levels:

• Item levels group and aggregate data according to characteristics of the items you 
sell. For example, PTP item levels include brand, category, and promotion group. 

• Location levels group and aggregate data according to the locations where they are 
sold. For example, PTP location levels include retailer, territory, and so on. 

• Promotion levels correspond to promotional events. 

In generic terminology, the word member refers to a unit within a level. For example, 
Albertson's is a member of the retailer level.

Series (Measures)
A worksheet table or graph displays series data associated with the current selection, 
for example:

PTP provides many kinds of series:

• Some series describe properties of item-location combinations; for example, Sales 
Quota. Others describe properties of promotions; for example, Veh Type.

• Most series have numeric values, but some have string or date values. For some 
series (like Cons Promo and Veh Type), you choose a value from a dropdown list.

• Some series are editable, some are editable only for specific dates, and some are not 
editable at all. 

• Some are based on imported data.

• Some series are shown in different colors, depending on the data values or on other 
local conditions. For example, Incr Mfg Prft is shown in red if profit is negative.

PTP Data Hierarchy
PTP uses specific levels, organized into a flexible set of hierarchies. Some of these levels 
are not used in PTP worksheets, but are available if needed for reporting. Products are 
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organized into several hierarchies, and locations are organized into another set of 
hierarchies. This section provides an overview.

Product Hierarchies

The lowest item level is the Item. PTP organizes items into four hierarchies. 

The Manufacturer Hierarchy
In the manufacturer hierarchy, items belong to brands. Brands, in turn, belong to 
manufacturers.

The Category Hierarchy
In the category hierarchy, items belong to brands, which belong to segments. Segments 
belong to categories.
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The Promotion Group Hierarchy
In the product line hierarchy, items are organized into promotion groups. Promotions 
are usually created at this level, applying to entire sets of items.

The Product Line Hierarchy
In the product line hierarchy, items are organized into product subgroups, which are 
organized into product groups, which are organized into product lines. 

Location Hierarchies
PTP provides two location levels that are both at the same (apparent) lowest level. 
These levels are Ship To and Territory. Internally, PTP has only one lowest location 
level, which is a combination of Ship To and Territory, created automatically by Oracle 
Demantra.

Ship To Hierarchies
Ship To locations are organized by Bill To locations, as follows:
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Ship To locations are also organized by retailer.

Territory Hierarchy
The Territory locations are organized in a single, fairly deep hierarchy. Territories are 
grouped into districts, which are grouped into regions. Regions, in turn, are grouped 
into sales areas, which are grouped into divisions, which are grouped into companies. 
The following figure sketches these relationships without indicating the members of 
each level:
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The Territory-Retailer Level
PTP also uses another level, the combined territory-retailer level, for analytic purposes. 
This level is meant for use only by the Analytical Engine.

Promotions
A promotion is an occurrence that starts at a specific date, has a certain duration, and 
has a certain time-varying effect on sales. PTP models promotions as another kind of 
level, as mentioned earlier, so that they can be used in worksheets in all the same ways 
as item and location levels. 

In PTP, you usually create promotions at the retailer-promotion group level. Multiple 
promotions can be associated with a retailer and promotion group during the same time
bucket.

How PTP Uses Promotion Properties
PTP models a common set of promotion properties that are known to affect the impact 
of promotions. These properties include the following:
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• Vehicle type

• Sale price

• Promotion timing and duration

Each of these properties can have a different effect on the forecast or simulations. When 
the Analytical Engine runs (either in batch mode or simulation mode), it uses 
mathematical models to determine what effect each property had in the past. It uses this
information to predict how each future promotion will behave. 

These properties also affect how the Promotion Optimization behaves. See 
Optimization.

Promotions and Scenarios
Because it is useful to separate tentative promotions from real ones, most PTP 
worksheets organize promotions into two scenarios: Current Year and the Sandbox. 
When you create a new promotion, you place it in the Sandbox as long as it is tentative. 
When the promotion is definite (when mark its status as Planned), then you should 
move the promotion to the Current Year scenario.

A third scenario, actuals, contains promotions from previous years. These promotions 
are excluded from most PTP worksheets because they fall outside the span of time used 
in these worksheets.

Promotion Life Cycle and Status
PTP models a distinct life cycle for every promotion. The Evt Status series shows the 
stage in which a given promotion resides; you can see this series in the Planning 
Environment and other worksheets. Typically a qualified user changes the status when 
appropriate.

1. When a promotion is first created, its status is initialized as Unplanned. Unplanned 
promotions are considered hypothetical and do not have an impact on the 
promotion funds or the forecast.

2. Typically you run a simulation to see the baseline and incremental volume for the 
proposed promotion. In addition, the system will calculate measures to be used for 
the cost benefit review. These include profit for the manufacturer and retailer, 
available fund balances as well as the proposed cost for the promotion.

3. Once you are ready to use the event in forecasting, you change its status event to 
Planned. This causes several things to happen:

• The cost of the promotion is deducted from the available balance of funds.

• The forecast is updated.
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4. The next stage is approved.

5. When you have a firm commitment from the retailer, you move the promotion to 
the committed stage. When a promotion is marked as committed, PTP takes a 
snapshot of details of the promotion, for use in later analysis. With this information,
it will be possible to compare the total projected sales with the total actual sales, for 
example.

Once a promotion has been committed, it is no longer editable.

6. After the promotion runs, the retailer may require payment for the promotion. You 
can advance the status to Partial Paid or to Paid to record the payment status.

7. Finally, the last stage is closed.

Retailer Profiles
Given that different retailers run different types of events differently, PTP stores retailer
profiles that include details such as the following:

• Average everyday selling margin

• Minimum required event margin

• Default vehicle costs for each type of event

When you create a promotion of a given type for a retailer, PTP automatically initializes
the vehicle cost as appropriate for that retailer, saving you the work of making a 
manual adjustment each time. You can override this vehicle cost if necessary.

The other retailer details affect the optimization process, which finds the best possible 
promotion for a given goal, considering the retailer-specific constraints.

PTP provides default settings that you can use for any retailer, so that you can start by 
providing details for just a few key retailers, without needing to enter all of them. You 
can modify these default settings as needed.

Funding
PTP provides the following standard set of promotion funds:

• Brand Development Funds (BDF)

• Market Development Funds (MDF)

• Slotting funds

In turn, both BDF and MDF include a portion for fixed funds and a volume-dependent 
portion, per common practice. For example, the total authorized BDF fund is computed 
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as follows:

rate * volume + fixed funds

This means that when the planned volume increases, you accrue funding. That is, the 
authorized funding also increases.

For specific details on funds, see "About Quotas and Funds".

To set fund amounts, see "PTP: Managing and Viewing Quotas and Funds." In the 
Planning Environment, the Fund Balances window displays a summary of the funds 
and their balances.

Promotion Costs and Spending
Following standard practice, PTP models the promotional spend as a combination of 
fixed spending and per-unit spending. Specifically, apart from slotting costs, the spend 
for a given promotion is computed as follows:

vehicle costs + volume * buydown

For a given retailer, each vehicle type is assumed to have its own default cost. When 
you specify the vehicle type for a promotion for a retailer, PTP looks up and displays 
that cost. You can override this cost if necessary. As part of specifying the promotion 
details, you also specify the buydown, or discount per promoted unit that will be paid 
to the retailer (either as billback from the retailer or as an off-invoice settlement with the
retailer).

In addition to specifying the promotion cost as described here, you also control how 
that promotion is to be funded. Specifically, when you mark a promotion as planned, 
you indicate how to split the cost between MDF and BDF; see "Marking a Promotion as 
Planned."

Volume and Volume Breakdown
In general, PTP volume calculations use actuals for the past and forecasted volume for 
the future. So to compute volume as needed for total MDF or BDF funds for the year, 
PTP combines the actuals to date and the forecast.

In addition to providing the overall volume, PTP shows a breakdown of that volume 
into the following categories:

• Base volume.

• Incremental volume due to a promotion. Part of this incremental volume is due to 
cannibalization effects. The manufacturer and the retailers have different points of 
view about cannibalization, as noted below.

• Pre and post-promotional effects. Sales are usually lower just before and after a 
promotion, as consumers take advantage of the better price during the promotion 



2-10    Oracle Demantra Predictive Trade Planning User's Guide

itself. The Analytical Engine computes the total volume before and after the 
promotion, as a result of the promotion, so that you can include this in your overall 
analysis.

Cannibalization
In addition to computing the incremental volume due to a promotion, the Analytical 
Engine computes specific cannibalization effects. Cannibalization includes multiple 
components, and the manufacturer and the retailer have different points of view. 

• Product switching, as described in Cannibalization Seen by the Manufacturer, 
decreased sales due to sales at another retailer.

• Decreased sales of other products of the same brand at the same retailer. For 
example, sales of Exedra 24 were depressed by the promotion on Exedra 100, at the 
same retailer. 

• Decreased sales of other brands (of the same manufacturer), regardless of retailer. 
For example, sales of Advo 50 were depressed by the promotion on Exedra 100, 
which is made by the same manufacturer.

Cannibalization Seen by the Manufacturer
PTP computes cannibalization that is undesirable to the manufacturer. The following 
shows an example:

This worksheet table shows a promotion group where a promotion was run and all 
promotion groups that were adversely affected, according to the manufacturer.

The row in blue indicates the promotion group (Exedra 100) on which you ran a 
promotion. In this row, you can see the total event dollars, incremental event dollars, 
net incremental event dollars and so on, for the promotion. Note that for Exedra 100, 
there was zero dollars of cannibalization and $2324 of pre- and post-promotional effect. 

On the other hand, examine the other promotion groups here and notice that they were 
all cannibalized. Of course, for these promotion groups, there was zero direct lift, by 
definition, as the promotion did not run on them.
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Cannibalization Seen by the Retailer
PTP also computes cannibalization that is undesirable to the retailer. The following 
shows an example:

This worksheet table shows a promotion group where a promotion was run and all 
promotion groups that were adversely affected, according to the retailer. As before, the 
row in blue indicates the promotion group (Exedra 100) on which you ran a promotion.

Notice two promotion groups are listed here that were not seen in the manufacturer 
version: Notrim 24 and Tyitol 50. These promotion groups represent products that this 
retailer sells, but that are made by a different manufacturer. To the retailer, it is 
undesirable to cannibalize these promotion groups.

Data Access
By default, PTP uses a simple security model. Each sales representative has access only 
to his or her territories. A sales manager has access to all the territories of the 
representatives that he or she supervises.
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3
Logging On and Getting Started

This chapter covers the following topics:

• Initial Logon and Download

• Logging Onto PTP

• Tutorial: Getting Acquainted with Worksheets

• Controlling Synchronization of Embedded Worksheets

• Logging Off PTP

• Ending a Hung Session

• Changing Your Password

Initial Logon and Download
The first time you log onto PTP, Oracle Demantra typically downloads and installs 
software. This operation occurs only once for each machine you use.

1. Open Microsoft Internet Explorer.

2. Enter the web address supplied by your system administrator. This URL probably 
has the following format:

http://server name/virtual directory/portal/partnerLogin.jsp

For example:

http://frodo/demantra/portal/partnerLogin.jsp

Tip: Your Windows Start menu may also include a shortcut to this 
URL.

3. Type your name and password and click Login.
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Oracle Demantra prompts you to install JRE.

4. When you are prompted to install Sun JRE 1.4.2_10, do so. Choose the Typical 
installation and accept all the default values, unless otherwise advised by your 
system administrators.

Note:  Oracle Demantra uses Sun JRE 1.4.2_10. If you are prompted 
to install a later version of JRE, do not do so.

To prevent Java from searching for updates, open the Java control 
panel. On the Update tab, make sure to deselect the check box 
Check for Updates Automatically.

Next, Oracle Demantra displays a dialog box that asks if you want to trust the 
signed application distributed by Oracle. The dialog box is slightly different 
depending on your configuration.

5. Click Yes (or Always) or Start, depending on which dialog box is displayed.

After the initial configuration is completed, Oracle Demantra displays a new 
browser window. The page contains a menu bar, a tool bar, and a work space that is
initially empty.

6. Click File > Open.

7. Click a worksheet in the list and then click Open.

Now the work area displays a worksheet, and the menu bar and tool bar have many
more options.

See also

Creating Worksheets and Content Panes.

Working with Data
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Logging Onto PTP
If you have already performed the initial setup (see "Initial Logon and Download"), 
then log on as follows.

To log onto PTP:
1. Open Microsoft Internet Explorer.

2. Enter the web address supplied by your system administrator. This URL probably 
has the following format:

http://server name/virtual directory/portal/partnerLogin.jsp

For example:

http://frodo/demantra/portal/partnerLogin.jsp

Tip: Your Windows Start menu may also include a shortcut to this 
URL.

3. Type your name and password, and then click Login.

Tutorial: Getting Acquainted with Worksheets
To view and edit data, you work within an environment called a worksheet. Each 
worksheet is a working environment designed to support specific business processes. 
However, all worksheets share certain common characteristics and behavior. This 
exercise is meant to help you get acquainted with any worksheet.

1. In My Worksheets (in Collaborator Workbench), click Planning Environment.

2. If the worksheet does not show data, click Data > Rerun. Or click the Run button.
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3. Scan the windows within the worksheet. 

First, most worksheets contain an area that you use to select the data to display. 
This area usually has the following form (or is sometimes displayed as a treelike 
hierarchy):

When you make a selection here, that changes anything of a lower level that is 
displayed elsewhere in the worksheet. For example, if you change the selection, you
would see different promotions.

Second, worksheets contain two different kinds of tables, and it is important to 
know the difference between them. 

The following is a normal table:
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The other kind of table is an embedded worksheet and appears as a tab within a tile. 
PTP uses embedded worksheets where they are needed for technical reasons.

Both kinds of tables are labeled to indicate what they contain.

For PTP, there is one behavioral difference between these kinds of tables:

• When you select a row in a normal table, that may affect selections elsewhere in
the worksheet. For example, if you click in a promotion row, the worksheet 
focus moves to that same promotion throughout the worksheet, including the 
embedded worksheets. 

Note: If you use the keyboard to move within a table, notice 
that the embedded worksheets are not automatically refreshed, 
for performance reasons. 

• In contrast, when you select a row in an embedded worksheet, that has no 
effect on the focus in the rest of the worksheet. 

A worksheet may also include graphs. Note that even if you click the graphs, it 
would have no effect on them. Note that you can change the graph style; see 
Changing the Graph Style.

4. Right-click a data cell in one of the tables. Notice that you have options to copy and 
paste data, to edit multiple cells, and to display associated notes.

5. Right-click a promotion in the non-scrolling part of a worksheet table like this one:
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Notice that the right-click menu here provides options for working with 
promotions. Depending on your permissions, you may be able to do any of the 
following:

• View promotion attributes in a pop-up dialog box.

• Edit those attributes.

• Create new promotions.

• Copy, paste, or delete promotions.

• Open a promotion in a different worksheet (via the Open or Open With 
options).

Note: When you open a worksheet this way, it is filtered to 
show just the promotion from which you launched it. Notice 
that the name of the promotion is added to the beginning of the
worksheet title.

The right-click menu is also available for scenarios, in worksheets that display 
scenarios.

Controlling Synchronization of Embedded Worksheets
The embedded worksheets worksheet may or may not be synchronized with the rest of 
the worksheet. A worksheet runs faster if synchronization is off. On the other hand, you
might find it less confusing to keep synchronization switched on. Also note that only 
promotion status changes have any effect on the data in embedded worksheets.

To control the synchronization:
Do one of the following:

1. Click one of the following toggle buttons in the tool bar.

• Automatically synchronize the embedded worksheets with the rest of 
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worksheet

• Synchronize on demand

2. Select Options > Synchronize On Demand or Synchronize Automatically.

Logging Off PTP

To exit PTP
Close the browser window. 

Any other open browsers are not affected.

See also

Ending a Hung Session.

Ending a Hung Session
If your session hangs due to network or other problems, you will not be able to log in 
again until the session times out. Alternatively, PTP provides a tool that you can use to 
end that session.

If your permission level is lower than System Manager, your own session is the only 
session you can see.

To end a hung session:
1. Browse to the following case-sensitive URL:

http://server name/virtual directory/portal/userManagement.jsp

For example:

http://frodo/demantra/portal/userManagement.jsp

A login page appears.

2. Type your username and password and then click Log on.

Oracle Demantra displays the following screen:
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3. Click Logout in the row corresponding to your user ID.

A login page appears.

Changing Your Password
Any user can log into the Business Modeler and change his or her own password. If 
your permission level is lower than System Manager, your password is the only 
information you can access.

To change your password:
1. Log into the Business Modeler. If you do not have access to this, contact your Oracle

Demantra system administrator.

2. Click Security > Change Password. Or click the Change Password button.

The Business Modeler displays the Change Password screen:

3. Type your current password in the Old Password field.

4. Type your new password in the New and Confirm New fields.
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5. Click OK.
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4
Working with Data

This chapter covers the following topics:

• Editing Data

• Saving and Viewing Changes

• Sorting Worksheet Data

• Copying and Pasting Data

• Copying and Pasting to and from Microsoft Excel

• Exporting Data to Microsoft Excel

• Linking Data into Third-Party Reporting Tools (via DOL)

• Printing

• Viewing Notes

• Editing Notes

• Viewing and Managing Attachments to Notes

• Specifying Note Permissions

• Refreshing the Local Worksheet Cache

• Viewing the Audit Trail

Editing Data
This chapter describes the basics of working with data: how to edit data, add notes and 
attachments, print, exchange data with outside tools, and so on. It includes the 
following sections:

You can usually edit data in a worksheet, although not all series are editable. Note that 
within a given worksheet, if some of the tabs or windows show data at a higher 
aggregation level, the data is not editable in those tabs or windows.



4-2    Oracle Demantra Predictive Trade Planning User's Guide

Note: Within Oracle Demantra, do not use the following special 
characters:

• Single quote (') 

• Double quote (")

• Ampersand (&)

If you use these characters, unexpected results may occur.

To change a data value manually
1. Select an editable data cell (white).

The cell appears contained in a box.

2. Edit the value as needed.

To update multiple cells
1. In the table, select a range of cells.

2. Right-click the selection and then select Edit Cells.

The Edit Cells dialog box appears.

3. In the dialog box, type a new value and then click OK.

To edit a retailer or a promotion
1. Right-click the retailer or promotion and then select Edit Retailer or Edit Promotion.

2. Edit as needed and then click OK.

Note: Your changes are saved immediately in this case and cannot 
be undone.

To undo
Do one of the following:

• Click Edit > Undo.

• Click Data > Reset Manual Changes. This option restores the worksheet data to the 
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state in which you last saved it.

To redo an action
Click Edit > Redo.

See also

"Copying and Pasting Data"

"Saving and Viewing Changes"

Saving and Viewing Changes
Apart from minor adjustments to the worksheet layout, the changes you make are not 
saved automatically.

Saving Changes
You save changes to data separately from changes to the worksheet definition:

• To save changes that you have made to the data in the worksheet, including 
changes to notes, click Data > Save Data. Or click the Save Data button.

• To save changes that you have made to the worksheet definition, click File > Save 
Worksheet. Or click the Save Worksheet button.

• If you own the worksheet, this option saves the basic worksheet definition and 
its initial layout. For information on changing the worksheet definition, see 
"Creating Worksheets and Content Panes".

• If you do not own the worksheet, this option saves only your own layout of the 
worksheet.

See "Worksheet Definition, Layout, and Local Adjustments".

Controlling the Recalc Option
Usually at least some of the read-only series are computed by means of a local 
expression. By default, Oracle Demantra recalculates all local series expressions 
automatically. In some cases, you may want to switch off this automatic recalculation:

To switch the Recalc option off
Click Data > Set Data Recalc Off. Or click the Recalc Off button.
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To force calculation while Recalc is off
Click Data > Calculate.

To switch the Recalc option on
Click Data > Set Data Recalc On. Or click the Recalc On button.

Viewing Pending Changes to Data

To see pending data changes
1. Click Data > Update to save your data changes.

2. Click Data > Process Monitor. Oracle Demantra displays a screen that shows all 
data saves that are waiting to be processed:

If you are working at a relatively high level, this takes longer to run.

Sorting Worksheet Data
By default, the worksheet table is sorted in ascending order, according to the current 
contents of the x-axis, which is usually time. You can sort the worksheet table in either 
ascending or descending order, according to any series that is displayed in the table.

To sort the worksheet table
Click the header of the column by which you want to sort the worksheet. 
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Oracle Demantra then sorts the entire worksheet table, putting entries in this column in 
descending order. A downward arrow is added to the column header, to indicate that 
the table is sorted by this column.

To resort in ascending order, click the column header again. Oracle Demantra resorts 
the table and changes the direction of the arrow.

To restore the default sorting order of the worksheet table
Click View > Reset Table Sort.

Copying and Pasting Data
You can copy and paste data within the worksheet table.

Note: From a worksheet, you can also paste data to different Windows 
products.

To copy data
1. Within a worksheet, do one of the following:

• In the table, select a cell whose value you want to copy.

• To copy values from more than one cell, click the first cell, and then drag the 
mouse to select all cells you want to include.

2. Right-click and then select Copy. Or click Edit > Copy.

To paste data
1. Do one of the following:

• In the table, select the cell into which you want to paste the data.

• To paste values into more than one cell, select the upper left data cell of the 
block of cells into which you want to paste.

2. Right-click and then select Paste. Or click Edit > Paste.
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See also

"Saving and Viewing Changes"

Copying and Pasting to and from Microsoft Excel
You can copy and paste data from a worksheet to Excel and vice versa.

To copy and paste data to Excel
1. Within a worksheet, copy data as described in "Copying and Pasting Data."

2. Start Microsoft Excel, open a worksheet, and select a cell or block of cells.

3. Right-click and then select Paste.

To copy and paste data from Excel
1. Start Microsoft Excel and open a worksheet.

2. Select one or more cells.

3. Right-click and then select Copy.

4. In Oracle Demantra, select the cell or cells into which you want to paste the data.

5. Right-click and then select Paste. Or click Edit > Paste.

See also

"Exporting Data to Microsoft Excel"

"Linking Data into Third-Party Reporting Tools (via DOL)"

Exporting Data to Microsoft Excel
You can export worksheet data to Excel. Your computer's regional settings can affect the
results; see the note.

To export data to Excel
1. Within a worksheet, click File > Export. Or click the Export to Microsoft Excel 

button.

An export dialog box appears.

2. Select Current Combination to export data currently displayed, or Entire Worksheet
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to export all data from the worksheet.

3. Click OK.

A Save page appears.

4. Define the location where the worksheet data will be saved and enter a name for the
file.

5. Click Save.

Note
When receiving data from an external source, Microsoft Excel uses the Regional Options
in the Windows Control Panel to determine whether a given cell should be formatted as
Currency or General (as is or text). This means that if you export Oracle Demantra data 
that is formatted with a currency symbol, and if the Windows Control Panel uses a 
different currency symbol, those cells will appear in Excel as text values.

If you export to Excel and you receive text values where you wanted currency values, 
do the following:

1. Open the Windows Control Panel.

2. Double-click Regional and Language Options.

3. On the Regional Options tab, make sure that the Currency setting uses the same 
currency symbol as Oracle Demantra.

4. Export again from Oracle Demantra.

Later versions of Excel provide an option for converting problematic cells that it 
recognizes. 

See also

"Copying and Pasting to and from Microsoft Excel"

"Linking Data into Third-Party Reporting Tools (via DOL)"

Linking Data into Third-Party Reporting Tools (via DOL)
When you work within a third-party reporting tool, you can import a Oracle Demantra 
worksheet via Oracle's Dynamic Open Link (DOL) technology. This technology lets you
use any reporting tool that can connect to the Oracle Demantra database (which is 
either Oracle or SQL Server).

Oracle Demantra provides a web page (http://server name/virtual 
directory/portal/DOL_HTML.htm) to which you can link from your reporting tool, such
as Microsoft Excel). Then to access the latest Oracle Demantra data, you can use the 
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refresh functionality within that reporting tool.

The following steps describe how to link Oracle Demantra data into Excel, as an 
example.

Note: The details here may vary depending on the version of Excel. 
Consult the Excel documentation for information about "web queries."

To create a worksheet report in Excel
1. In Microsoft Excel, open the Data menu.

2. Click Get External Data and select New Web Query.

The New Web Query screen appears.

3. Click Browse Web..., which displays a browser.

4. In the address bar, type the following URL and then click Go:

http://server name/virtual directory/portal/DOL_HTML.htm

For example:
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http://frodo/demantra/portal/DOL_HTML.htm

A login page appears.

5. Type your Oracle Demantra user name and password and click Login.

The browser now displays the following list of worksheets:

6. Select a worksheet from the dropdown list and click Confirm.

The worksheet opens in your browser in non-editable HTML format. 

7. Optionally close the browser window.

8. Return to Excel, which is still displaying the same dialog box as before.

9. For step 2, select The entire page.

10. For step 3, select Full HTML formatting.

Note: To save the query for repeat use, click Save Query...

11. Click OK.

Excel asks where to put the data.
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12. Make your choice and click OK.

The Oracle Demantra worksheet opens in Excel.

See also

"Copying and Pasting to and from Microsoft Excel"

"Exporting Data to Microsoft Excel"

Printing

To print the displayed data
1. Click File > Print. Or click the Print button on the toolbar.

The Print Settings dialog box appears.

2. Select the required options.

Content selection Specify whether to print the currently selected item-location 
combination, all combinations in the worksheet, or the 
screen.

Layout Choose portrait or landscape orientation.

Paper Choose a paper size.

Font Choose a font size.

Object selection If this worksheet includes a Gantt chart, this option lets you 
specify whether to include the Gantt chart in the printout.

3. If this worksheet includes a Gantt chart, optionally click the Gantt Settings tab. On 
this tab, specify which promotion attributes to include in the print-out.
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4. Click OK.

5. Oracle Demantra displays the normal system print dialog box, where you choose 
the printer to use, the number of copies to make, and so on.

6. Make selections as you would normally do.

7. Click OK.

Viewing Notes
You can add notes to record comments and reminders. You attach the note to 
combination and date or dates. The worksheet table displays indicator symbols on those
dates, generally in only some of the columns (depending on how your system is 
configured). The following shows an example of the indicator:

The graph displays an indicator as well.

You can see notes in two different areas:

• In the Notes dialog box.
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• In the Notes/Attachments subtab, if this is included in your worksheet. This subtab 
also displays any associated attachments.

To open the Notes page
Do one of the following:

• In the table, right-click a cell and select Notes... The note will be associated with 
only this row.

• In the table, select one or more rows, right-click and then select Notes.... The note 
will be associated with each of the selected rows.

• In the table, double-click the left (non-scrolling) column. (Depending on how Oracle



Working with Data    4-13

Demantra is configured, this action may not bring up the Notes page.)

• In the graph, hold the mouse button over a point, right-click and then select Notes...

To display the Notes/Attachments subtab
See "Specifying the Worksheet Elements in a View."

See also

"Editing Notes"

"Viewing and Managing Attachments to Notes"

"Specifying Note Permissions"

Editing Notes
First display the Notes page or the Notes/Attachments subtab; see "Viewing Notes". In 
the upper part of the worksheet, click the element to which you want to attach this note.

To add a note
1. If the Note box is gray (uneditable), click the Add button.

2. Type a note in the Note box.

3. If you are working in the Notes/Attachments subtab, you can optionally upload an 
attachment See "Viewing and Managing Attachments to Notes."

4. Click the Save button.

To edit a note
1. Select a note and click the Edit button.

2. Type a note in the Note box.

3. If you are working in the Notes/Attachments subtab, you can optionally upload an 
attachment See "Viewing and Managing Attachments to Notes".

4. Click the Save button.

To delete a note
1. Select a note and click the Delete button.
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The Confirm Delete message box appears.

2. Select one of the following:

• Partial Deletion (deletes the note only from the current member and date)

• Total Deletion (deletes the note from all members and dates)

3. Click OK.

4. Click Save.

See also

"Viewing Notes"

"Specifying Note Permissions"

Viewing and Managing Attachments to Notes
You can attach files to the notes, and Oracle Demantra uploads those files into the 
database (in compressed form). To view and manage attachments, you work in the 
Notes/Attachments subtab of your worksheet.

To add an noteattachment to a 
1. Click the note.

2. Click Details.

Oracle Demantra displays the Note Details screen:
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3. Click Add.

4. Find the file that you want to attach and then click Open.

Oracle Demantra uploads a compressed version of the file into the database.

5. Click OK.

To remove an attachment from a note
1. Click the note.

2. Click Details.

Oracle Demantra displays the Note Details screen:

3. Click the row that lists the attachment and then click Remove.

4. Click OK.

To download an attachment
1. Click the note.

2. Click Details.

Oracle Demantra displays the Note Details screen.
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3. Click the row that lists the attachment and then click Download.

4. Specify the directory and filename for the downloaded file and then click Save.

5. Click OK.

See also

"Viewing Notes"

"Specifying the Worksheet elements in a View"

Specifying Note Permissions
In general, notes (and their optional attachments) can be viewed by other users. You can
specify permissions for the notes, to determine who can read the note and what type of 
access they are permitted. You can specify permissions for groups or for specific users.

To specify permissions for a note and its attachments
1. On the Details tab, select the note.

2. Click the Permissions tab.

3. Select the User Permissions or Group Permissions tab.

4. For each user or group that should have non-default settings for this note, move 
that user or group from the left list to the right list (Selected Users or Selected 
Groups). Use any of the techniques in "Working with Lists."

Note: Read-only is the default setting for non-selected users or 
groups.

5. Remove any unwanted users or groups from the right list.

6. Then for each user or group in the right list, do the following:

1. Click the user or group.

2. Select a setting from the Permission dropdown list at the bottom of the page. 
The following options are available:

Read and Write Enables the user or group to read the notes list, edit notes,
and add notes.
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Read Only Enables the user or group to read the notes list.

Not Visible Makes the note list not visible to this user or group.

Full Control Enables the user or group to read the notes list, edit notes,
add notes, and delete notes.

7. Click Save.

8. Click Close.

Group and user permission priorities
• User permissions take precedence over permissions of any groups the user belongs 

to.

• If a user belongs to more than one group, the highest level of permissions from the 
associated groups will be granted.

See also

"Viewing Notes".

Refreshing the Local Worksheet Cache
Depending on the definition of a worksheet, Oracle Demantra may store a local copy of 
the worksheet data on your machine, for faster performance. Also depending on the 
worksheet definition, the cache may be refreshed automatically or may require periodic 
refreshing by you.

To refresh your local worksheet cache
Click Data > Refresh worksheet data cache.

See also

"Saving and Viewing Changes"

"Configuring the Basics"

Viewing the Audit Trail
Oracle Demantra automatically records changes in an audit trail. The audit trail 
includes changes due to edits within worksheets, copy/paste actions, and changes 
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caused by import, and so on.

Note: You can see only changes that were made by you or other users 
who are in the same collaboration groups as you.

Oracle Demantra provides two ways to view the audit trail:

• You can view the changes that have occurred to the item-location combination that 
is currently displayed in the worksheet.

• You can create and then execute a profile that specifies a wider set of data: multiple 
combinations, a wider span of time, and so on.

In either case, the audit trail looks like this:

The top part of the page lists the changes. When you select a row in this table, the 
bottom part of the page lists details corresponding to that row.

• The Series Values tab displays details on the series that were changed.

• The Aggregate Level Population tab displays the specific aggregation levels to 
which this change applies. The change could have occurred at a different 
aggregation level.

• The Filtered Population tab displays the filtering that was used at the time of this 
change.
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Viewing the Audit Trail for a Specific Combination

To view the audit trail for a combination 
1. In a given worksheet, select a combination.

2. Click Data > Audit Trail.

If any changes have occurred to this combination, the Audit Trail screen appears, 
displaying a table with one row for each recorded change. The following 
information is displayed:

Audit Date Date when change was made.

User Name User who made the change

Update Mode Indicates the type of change: Manual, BLE (Business Logic 
Engine) or Integration

Unit Name Unit of measure that was used at the time of the change

Index Name Index that was used at the time of the change

Series List Series affected by the change

Status In Progress, Fail, or Success

3. To see specific details on this change, click a change in this table and then click the 
Series Values tab.

This tab displays the following information:

Series Name Name of the series that was changed.

Series Value New value used in this series.

Original Value Original value in this series.

From Date First date in the series when the change occurs.

To Date Last date in the series when the change occurs.
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4. To see the specific aggregation levels to which this change applies, click the 
Aggregate Level Population tab. The change could have occurred at a different 
aggregation level.

5. To see the filtering that was used at the time of this change, click the Filtered 
Population tab.

Viewing the Audit Trail for Other Data
An audit trail profile enables you to select a specific portion of the audit trail so that you
can view changes that affect more than one combination.

To create or modify an audit trail profile
1. Click File > Audit Trail.

2. Then:

• To create a new profile, click New.

• To modify a profile, click an audit trail profile name and click Modify.

The wizard displays a properties screen.

3. In the Name and Description fields, type a name and optional description.

4. If you want to share this audit trail profile with others, click Public.

5. Click Next.

The wizard prompts you for information about the changes you want to see.

6. For Source Type, select the check box for each type of change you want to see. Here,
BLE represents the Business Logic Engine.

7. For each user whose changes you want to see, move the name from Available Users
to Selected Users.

8. Click Next.

The wizard prompts you for the range of time you are interested in.

9. For Time Filter, select Relative or Fixed, depending on whether you want to define 
a window of time relative to today.

10. For From Date and To Date, specify a range of dates.

11. Click Next.
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The wizard prompts you to specify the aggregation levels you are interested in.

12. For each aggregation level that you are interested in, move that level from Available
Filter Levels to Selected Filter Levels.

13. Click Next.

The wizard prompts you to specify the series you are interested in.

14. For each series that you are interested in, move that series from Available Series to 
Selected Series.

15. Click OK.

16. Click Close to exit the wizard.

To use an audit trail profile
1. Click File > Audit Trail.

2. Click an audit trail profile.

3. Click Execute.

Oracle Demantra displays the specified part of the audit trail. See "Viewing the 
Audit Trail for a Specific Combination".

To delete an audit trail profile
1. Click File > Audit Trail.

2. Click an audit trail profile.

3. Click Delete.

4. Click Yes.
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5
Managing the Screen

This chapter covers the following topics:

• Managing Multiple Worksheets

• Managing Worksheet Views

• Managing View Elements

• Changing the Graph Style

• Managing Empty Rows

• Worksheet, Layout, and Data

• Worksheet Definition, Layout, and Local Adjustments

Managing Multiple Worksheets
This chapter describes how to manage the Oracle Demantra screen in general. It 
includes the following sections:

See also

"Creating Worksheets and Content Panes"

Within Oracle Demantra, you can open multiple worksheets and display them in tab 
mode or window mode. In window mode, you can resize, position, minimize, 
maximize, and tile each window as in other software.

To specify how to display worksheets
Do one of the following:

• Select Options > Tabs View/Windows View.

• Click the Tabs/Windows toggle button.

• display worksheets as windows
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• display worksheets as tabs

A worksheet contains views, and these views can be displayed as windows or tabs 
within the worksheet itself. The Tabs/Windows setting discussed here has no effect on 
the views.

To view a worksheet that has already been opened
1. In windows view, select the worksheet from the Windows menu.

2. In tabs view, click the tab corresponding to the worksheet.

To close a worksheet
Do one of the following:

• In windows view, click close (X) in the top right corner of the worksheet window.

• In tabs view, click the close symbol (X) on the tab.

See also

"Managing Worksheet Views"

"Managing View Elements"

"Adding and Managing Worksheet Views"
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Managing Worksheet Views
A worksheet can include multiple views, which are displayed as tabs or as windows 
within the worksheet window itself.

Each view can have a different set of series and a different layout. Within any given 
worksheet, you can display the views as tabs or as child windows that you can resize 
and reposition.

Depending on the worksheet definition, the views may or may not be synchronized 
with each other. If they are synchronized, when you edit in one view, that change 
automatically appears in the other views.

Note: In a given worksheet, if some of the views show data at a higher 
aggregation level, the data is not editable in those views.

To manage worksheet views
Within any given worksheet, you can display the worksheet views as tabs or as child 
windows that you can resize and reposition.

• To create, modify, or delete worksheet views, see "Adding and Managing 
Worksheet Views".

• To change how views are shown within the current worksheet, click Options > Tabs
Multiview or Options > MDI Multiview, whichever option is displayed. Or click the
corresponding toggle button on the toolbar.

• display views as child windows

• display views as tabs

• If you are currently displaying views as tabs, you can view one tab at a time. Click 
the tab of the view you want to view.

• When you are displaying views as subwindows, you can resize, reposition, 
maximize, and minimize each of these subwindows. Also, the Options menu 
provides options for tiling and cascading the subwindows.

See also

"Managing Multiple Worksheets"

"Managing View Elements"
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Managing View Elements

To hide or re-display elements of a worksheet view
You can hide elements of a worksheet. To do so, use the Options menu. For example, to 
hide the graph, click View > Show/Hide Graph.

Note: This menu includes an option to hide the time axis. You typically 
use this option only if the worksheet also contains time levels. In such a
case, it is desirable to hide the time axis, because it is redundant and 
takes up space on the screen.

Each of these menu items acts as a toggle. To redisplay what you have hidden, click the 
same menu item again.

To re-size an area in a worksheet view
Drag a divider to the required position.

To expand or contract an area in a worksheet view
There are two snap buttons in the upper left of each worksheet area, one with an up 
arrow and one with a down arrow. Click the snap button pointing in the required 
direction.

To re-size a data column
Click the vertical divider between two column headers, and drag it horizontally to the 
required position.

See also

"Managing Multiple Worksheets"

"Managing Worksheet Views"

"Adding and Managing Worksheet Views"

Changing the Graph Style

To change the style of the graph
Click any of the graph style buttons to the left of the graph.
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To display only one pie chart
Click View > Show Multiple Pie Charts. This option is a toggle. If you click it again, you 
redisplay the other pie charts.

Managing Empty Rows

To hide or display empty rows in the worksheet table
Click View >Hide Empty Rows. This option is a toggle. If you click it again, you 
redisplay the empty rows.

Note: This option does not affect any graphs in the worksheet.

Examples
In some cases, some of the rows of a worksheet table might not contain data, for 
example:

Note that the status bar at the bottom of worksheet indicates that empty rows are 
currently being displayed.

When you hide empty rows, the result is as follows:
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Worksheet, Layout, and Data
As you work within Oracle Demantra, it is important to remember that worksheets are 
different from the data in them. For example, the definition of a worksheet specifies 
which series to display and how to aggregate those series for that worksheet. But the 
worksheet definition does not specify the values that the series contain. 

Accordingly, the worksheets and their layouts are saved separately from changes to the 
data. 

• To save changes that you have made to the data in the worksheet, including 
changes to notes, click Data > Save Data. Or click the Save Data button.

• To save changes that you have made to the worksheet definition or to the local 
layout, click File > Save Worksheet. Or click the Save Worksheet button.

• If you own the worksheet, this option saves the basic worksheet definition and 
its initial layout. This affects any users of this worksheet who have not yet 
saved their own layout for it.

• If you do not own the worksheet, this option saves only your own layout of the 
worksheet. This has no effect on any other users.

See also

"Worksheet Definition, Layout, and Local Adjustments"

"Saving and Viewing Changes"
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Worksheet Definition, Layout, and Local Adjustments
As you work with a Oracle Demantra worksheet, you often sort columns, hide or 
display features, and make various other changes. It is useful to understand how these 
settings are saved.

Base Oracle Demantra 
configuration

These settings affect all users 
and all worksheets.

• Display format for each series

• Initial display width of series and levels

• Colors and graph style for each series

• Other display colors (generally dependent on a condition)

Worksheet definition

These settings are saved via 
the File > Save Worksheet 
menu option. Only the 
worksheet owner can make 
these changes.

• Initial number of views within the worksheet and their 
initial names

• Initial elements (Members Browser, table, graph, and so 
on) in worksheet view

• View synchronization setting

• Aggregation levels used in worksheet and initial level 
layout; advanced selection options

• Series used in worksheet and initial series layout

• Time aggregation; time span; time formatting

• Filtering and exception filtering

• Unit of measure used in worksheet; overall scale used in 
worksheet, if any; index or exchange rate, if any
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Layout changes

These settings are saved 
separately for each user if the 
user clicks File > Save 
Worksheet. Any user can 
save these changes, not just 
the worksheet owner.

• Additional views in the worksheet

• New names of worksheet views

• Level layout: order of levels; placement on axes in each 
view; whether level is hidden in each view

• Series layout: order of series; where each series is displayed
(table, graph, both)

• Hide/show time axis

Local adjustments

These settings are saved 
automatically separately for 
each worksheet and each 
user. 

• Use of windows or tabs for views within a worksheet

• Size and position of the Members Browser, table, graph, 
and so on in each view

• Sorting in the worksheet table

• Graph type; legend; grid lines

• Hide/show empty rows setting

• Activity synchronization setting (Options menu)

Not saved • Changes to column widths in the worksheet table

• Initial view focus; focus in each worksheet view

• Expansion state in the Members Browser and Activity 
Browser

• Focus and scroll in all areas

• Zoom setting in Gantt

The autorun option (Options menu) is saved separately for each user, but applies to all 
worksheets that the user sees.



Part 2
PTP and PMO Business Processes
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6
Oracle Demantra Dashboard

This chapter covers the following topics:

• Introduction to the Dashboard

• Reviewing Metrics

• Reviewing the Planning Hierarchy

• Editing Retailer Information

• Opening Worksheets

• Managing Tasks

• Creating and Sending a Task

• Personalizing the Dashboard

Introduction to the Dashboard
This chapter introduces the Oracle dashboard: Collaborator Workbench.

Oracle's Collaborator Workbench is the starting point for PTP. This dashboard is 
designed for use by sales managers. You log into the application and immediately have 
access to a number of key performance indicators (KPIs). You can also jump directly to 
TPMO worksheets, which are working environments that support specific business 
processes; these are described in the following chapters.

To log into the dashboard
1. In Windows, click Start and click Programs.

2. Click Demantra > Demantra Spectrum release > Collaborator Workbench.

3. In the Log On dialog box, enter your user name and password.

4. Click Login.
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5. If the toolbar includes a link labeled Click here to install Java Web Start, click that 
link.

Next Oracle Demantra prompts you to install JRE.

6. When you are prompted to install JRE, do so. Choose the Typical installation and 
accept all the default values, unless otherwise advised by your system 
administrators.

After you install this software, Collaborator Workbench comes up, displaying your 
personal page. Initially, this page looks like this:

At this point, Oracle Demantra might display a dialog box that asks if you want to 
trust the signed application distributed by Oracle.

Note: In some cases, you do not see this dialog box until you click a
worksheet name.
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7. Click Yes (or Always) or Start.

Reviewing Metrics
Collaborator Workbench displays summary panes that display critical information and 
which you can customize to your needs. Initially, it displays the following summary 
panes.

Actuals versus Plan
This summary pane is a graph that shows cumulative actual volume and planned 
volume, as follows:

Sales versus Quota
This summary pane shows current sales compared to the sales quota, as follows:
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Volume Breakdown
This summary pane displays a table that shows the breakdown of volume into base 
volume and incremental volume, as follows:

Reviewing the Planning Hierarchy
The Planning Hierarchy is an expandable, treelike view that you can use to navigate the
planning hierarchy:

Expand the hierarchy as needed.

You can right-click for more options:
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In particular, you can open worksheets that are filtered to the selected retailer (for 
example). In the case of retailers, you can also view or edit properties of the retailer 
such as minimum event margin.

Editing Retailer Information
PTP stores basic retailer details so that when you create a promotion, it is automatically 
specified appropriately for that particular retailer. PTP provides default settings that 
you can use for any retailer.

Setting a Retailer Profile to the Default

To set a retailer profile to the default settings
1. In the Planning Hierarchy, expand the tree display to the retailer level.

2. Right-click the retailer and click Edit Retailer.

PTP displays the following screen:
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3. Change Use Default Profile to Yes.

Caution: Do this only if you are certain that you want to change all 
settings for this retailer.

4. Click OK.

5. Log into the Workflow Manager and run the CopyRetailerDefaults workflow; see 
"Adminiatraion".

This workflow checks for any retailers that have been set to use the default profile, and 
it copies the default details to those retailers.

Editing a Retailer Profile

To edit a retailer profile
1. In the Planning Hierarchy, expand the tree display to the retailer level.
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2. Right-click the retailer and click Edit Retailer.

PTP displays the Edit Retailer screen, as shown in the previous procedure.

3. Set Use Default Profile to No.

Caution: If you do not set Use Default Profile to No, your changes 
will be reset to the default.

4. Enter values for the other attributes as follows:

Name Name of the retailer.

Class_of_Trade Dropdown list with the following choices:

• Food

• Drug

• Mass

• C-Store

• Military

Number of Active Stores Number of active stores that this retailer operates.

Account Classification Dropdown list with the following choices:

• Growth

• Holding

• Declining

Avg Everyday Selling Margin Average selling margin, disregarding promotions.

Min Rtl Event Margin Minimum margin that this retailer must make on an 
event. Promotion Optimization considers only events that
provide at least this much margin.

Veh Costs: Feature & Display Default cost for an event of type F&D for this retailer.

Veh Costs: Feature Only Default cost for an event of type Feature for this retailer.
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Veh Costs: Display Only Default cost for an event of type Display for this retailer.

Veh Costs: TPR Only Default cost for an event of type TPR for this retailer.

Veh Costs: F Shopper Default cost for an event of type F. Shopper for this 
retailer.

Key Competitors A text field where you can list the key competitors of this 
retailer.

5. Click OK.

Opening Worksheets
Each worksheet is a working environment designed for specific PTP and PMO business 
processes. 

To open worksheets, click My Worksheets, or right-click Planning Hierarchy, or right 
click an open worksheet.

To open a worksheet
• To open an unfiltered worksheet, click a worksheet listed in My Worksheets.

• To open a worksheet that is filtered to a specific context, right-click a promotion, 
scenario, retailer, or territory, click Open With, and then click the worksheet name. 
You can do this within the Planning Hierarchy or within an open worksheet.

When you open a worksheet this way, it is filtered to show just the object from 
which you launched it. Notice that the name of the object is added to the beginning 
of the worksheet title.

Note: When you first open a worksheet, Oracle Demantra might 
display a dialog box that asks if you want to trust the signed 
application distributed by Oracle.

Click Yes (or Always) or Start.

See also

"Configuring My Worksheets"

"Creating and sending a Task"
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Managing Tasks
My Tasks lists all tasks that are assigned to you and that you have not yet addressed. 
For example, if you are a manager, you will receive promotions that require approval.

Note: If a due date is shown in red text, that means the response period 
has nearly ended and the task is going to time out fairly soon.

To view all assigned tasks
If you have many open tasks, the My Tasks module does not necessarily display all of 
them. To check for additional tasks:

Click the More link in the bottom right corner of My Tasks.

My Tasks fills the wide pane and shows all current tasks.

To mark a task as done
Before you mark a task as done, make sure that you have reviewed all the relevant 
information and that you have addressed any concerns or issues. Then do the 
following:

1. First:

• Select the appropriate response from the dropdown list in the Select value 
column. The check box next to the task is automatically selected.

• If there is no dropdown list, just select the check box to the left of the task.

2. Click the Save & Refresh link at the bottom of the task list.

The task is removed from My Tasks and the updated task list is shown.

Caution: If you go to another page or log off without clicking Save 
& Refresh, then your changes will be lost.

Creating and Sending a Task

To create and send a task
1. Start by doing one of the following:

• Within My Worksheets, click Send on the worksheet that you want to send.
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• Within My Tasks, click Create Task.

The Send Task to User dialog box appears.

2. Click To..... and select the users or groups to receive the task.

3. In the Message field, type a short text message.

This will be the task message that the recipient sees. The worksheet that you are 
sending will be added automatically as a link from the Message text.

4. In the Description field, type a short description.

This description will be displayed below the task message in the recipient's My 
Tasks module.

5. To link the task subject line to a Web page, enter the full path to the file in URL 
field.

Note: You must enter the full URL, including server name and 
directory hierarchy. The http:// part will be added automatically if 
omitted.

6. To attach a file to the task, enter the path to the file in the File Attachment field or 
use the Browse button to find it.

7. To ensure that this task is completed by a specific time, click Escalate and then 
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provide the following information:

Due Date Date and time by which this task must be completed

Alert Time Date and time at which an alert will be displayed

To Additional email addresses

8. To send an email notification to the recipient of the task, select the Send email list 
check box. (Depending on how your system has been configured, this option may 
not be available.)

9. Click Send Task.

When the recipient next logs in (or refreshes My Tasks), he or she will see the new task.

Personalizing the Dashboard
You can personalize Collaborator Workbench in several different ways:

• "Configuring Your Default Layout"

• "Configuring My Tasks" 

• "Configuring My Worksheets"

To add new summary panes, see "Creating Worksheets and Content Panes".

Configuring Your Default Layout
The Collaborator Workbench page includes a wide pane and a narrow pane, and each 
pane has a possible set of modules that it can display. You choose the modules and their
display order, top to bottom.

To personalize your default layout
1. Click the Personalize link.

The Personalize - Modules page appears. This page contains two lists: one for items 
that can be displayed in the wide pane and one for items that can be displayed in 
the narrow pane.
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These lists include the following:

• My Tasks and My Worksheets, which can be displayed only in the wide pane.

• Who's Online, which can be displayed only in the narrow pane.

• Worksheets that have been defined as content and to which you have access.

2. In each list, use the check boxes to select or clear the modules that you want to see.

3. Click Next.

The Personalize - Order page appears. Like the previous page, this page has one list
for the wide pane and one for the narrow pane.
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4. Select a module and then click the up or down buttons to change its position in the 
list.

The order here is the order in which these modules are shown in Collaborator 
Workbench. 

5. Click Next.

The next page summarizes your choices. You can return to the previous pages to 
make further alterations.

6. Click Finish to save your changes. Or click Back to go back to the previous pages.

Configuring My Tasks

To configure My Tasks
1. If Collaborator Workbench is not currently displaying My Tasks, then display it as 

described in "Configuring Your Default Layout".

2. In My Tasks module, click the personalize button in the upper right corner of the 
pane.

Collaborator Workbench displays a page like the following:
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3. In the Number of Tasks to View field, type the maximum number of tasks that you 
want to see in My Tasks.

4. From the Order Tasks by list, select the field that you want to list the tasks by.

5. From the Sort dropdown menu, select the sorting order that you want for the tasks. 
Task fields can be listed in either ascending or descending order.

6. Click Finish.

My Collaborator Workbench refreshes with My Tasks in the new configuration.

Configuring My Worksheets

To configure My Worksheets
1. If Collaborator Workbench is not currently displaying My Worksheets, then display

it as described in "Configuring Your Default Layout".

2. In My Worksheets module, click the personalize button in the upper right corner.

Collaborator Workbench displays a list of all available worksheets. This includes all
worksheets you own and all public worksheets.
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3. Select the check box next to worksheet that you want to display.

4. Click Next.

Collaborator Workbench displays a new page where you specify how many 
worksheets to display and the display order for the worksheets you have selected.

5. In the Number of Worksheets to View field, type the maximum number of 
worksheets that you want to see in My Worksheets.

6. In the Order list, click a worksheet and then click the up or down arrows to specify 
the display order of that worksheet. Repeat as necessary.

7. Click Finish to save your changes. 
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7
PTP: Managing and Viewing Quotas and 

Funds

This chapter covers the following topics:

• Overview

• Managing Quotas and Funds at the Retailer Level

• Managing Quotas and Funds at the Promotion Group Level

• Viewing Quotas and Funds

• Reference

Overview
This chapter describes how to manage or view quotas and funds in Oracle Demantra, as
part of the PTP business process.

To manage or view quotas and funds, you start in the Collaborator Workbench and 
launch any of the relevant PTP worksheets:
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About Quotas and Funds
Oracle Demantra displays a standard set of promotion funds, which you can view or 
modify at several different levels, as appropriate, along with the quota (Sales Quota) 
that they are intended to support. 

Available Funds
PTP provides the following standard set of promotion funds, broken out as follows:

• Brand Development Funds (BDF): Base rate (BDF Base Rate), development rate 
(BDF Dev Rate), and fixed funds (BDF Fixed Funds). The total of BDF funds is 
shown as BDF Auth.

• Market Development Funds (MDF): Base rate (MDF Base Rate), development rate 
(MDF Dev Rate), and fixed funds (MDF Fixed Funds). The total of MDF funds is 
shown as MDF Auth.

• Slotting funds (Slot Auth)

• In summary, the total authorized funding (BDF, MDF, and slotting) is shown as Ttl 
Fund Auth.

As in standard usage, the rates are per unit so that the authorized funding is the volume
multiplied by the rate. For example, BDF Auth is computed as follows:

(BDF Base Rate + BDF Dev Rate) * volume + BDF Fixed Funds

You can see or edit these funds on several worksheets. One example (PTP: Quota and 
Fund Entry: Top-Down) is shown below:
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Volume
Because volume affects the use of the funds, PTP also displays the following volume 
information:

• Actuals Ttl (the past volume)

• Volume Base (the base volume, in the absence of any promotions)

• Uplift (additional volume due to planned promotions)

In general, PTP volume calculations use actuals for the past and forecasted volume for 
the future. This means that to compute volume as needed for total BDF funds for the 
year, for example, PTP combines the actuals and the forecast.

Unplanned promotions do not affect volume.

Managing Quotas and Funds at the Retailer Level
Typically, you would start by working top-down, setting quotas and funds at the 
retailer-territory level.
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To manage quotas and funds at the retailer-territory level
1. Start in Collaborator Workbench.

2. In My Worksheets, click PTP: Quota and Fund Entry: Top-Down.

Or if a worksheet is currently open, click File > Open. Click PTP: Quota and Fund 
Entry: Top-Down and then click Open.

3. If the worksheet does not show data immediately, click Data > Rerun. Or click the 
Run button.

4. At the top of the screen, select the territory to display.

5. In the Entry Data table, edit the quota and fund values as needed. Here you are 
editing values for the entire year, for a given retailer.

6. Click Data > Save Data. Or click the Save Data button.

Entry Data
Here you enter the funds and quotas. This table shows all the quotas and funds for each
retailer, aggregated over the year.
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Volume Details
This table summarizes the volume information:

Sales Quota
This graph shows the plan, the sales quota, and the projection for each retailer:

Possible Actions
In this worksheet, depending on your authorization, you can do the following:

• Edit fund rates, fixed funds, and quotas.

• Use File > Open to access other PTP worksheets. (It is not recommended to open the
PMO worksheets this way, because they will not be filtered and will be slow.)

See also

"Working with Data"
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Managing Quotas and Funds at the Promotion Group Level
If you have already set quotas and funds at a high level, you might want to fine-tune 
the amounts by adjusting values at the lower levels.

To manage quotas and funds at the promotion group level
In the table, edit the quota and fund values as needed. You can select and edit multiple 
cells. See "Editing Data."

Entry Data
This table shows all the quotas and funds for the selection, by week.

Sales Quota
This graph shows the plan, the sales quota, and the projection for each promotion 
group:

Possible Actions
In this worksheet, depending on your authorization, you can do the following:

• Edit funds and quotas.

• Use File > Open to access other PTP worksheets. (It is not recommended to open the
PMO worksheets this way, because they will not be filtered and will be slow.)

See also

"Working with Data"
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Viewing Quotas and Funds
If you are a sales representative, you can view authorized funds against your sales 
quota. You use the PTP: Quota and Fund View worksheet, which is a view-only 
worksheet. 

To view quotas and funds
1. In My Worksheets (in Collaborator Workbench), click PTP: Quota and Fund View.

Or if a worksheet is currently open, click File > Open. Click PTP: Quota and Fund 
View and then click Open.

2. If the worksheet does not show data immediately, click Data > Rerun. 

3. At the top of the screen, select the territory, retailer, and brand to display.

The table shows all the quotas and funds for each brand, broken down by 
promotion group. For each promotion group, the quotas and funds are displayed 
for the entire year.

The graph below that shows the quota for each promotion group.

Possible Actions
In this worksheet, depending on your authorization, you can do the following:

Use File > Open to access other PTP worksheets.
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Reference

PTP: Quota and Fund Entry: Top-Down
This worksheet lets you set quotas and funds at the retailer level.

Basics

Accessing this worksheet • In My Worksheets (in Collaborator Workbench), click 
PTP: Quota and Fund Entry: Top-Down.

• If a worksheet is currently open, click File > Open. Click 
PTP: Quota and Fund Entry: Top-Down and then click 
Open.

Levels you can select Territory

Levels used in cross tabulation Retailer

Time aggregation Yearly

Business Data

View Series Description

Entry Data Plan $ The manufacturer's planned revenue 

Sales Quota Sales quota (revenue) 

$ Sales Proj Planned sales dollars: actuals plus forecast 

Sales Proj Planned sales volume: actuals plus forecast 

Base Fcst Base volume: actuals plus forecast 

Incr Fcst Incremental volume: actuals and forecast due only 
to planned promotions 

MDF Base Rate Market development fund base rate 
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View Series Description

MDF Dev Rate Market development fund development rate 

MDF Fixed Funds MDF fixed funds 

MDF Auth Authorized market development funds, calculated 
as follows: (base rate + dev rate)*volume + fixed 
MDF funds 

BDF Base Rate Brand development fund base rate 

BDF Dev Rate Brand development fund development rate 

BDF Fixed Funds BDF fixed funds 

BDF Auth Authorized brand development funds, calculated 
as follows: (base rate + dev rate)*volume + fixed 
BDF funds 

Slot Auth Authorized slotting funds 

Ttl Fund Auth Total authorized spending, including MDF, BDF, 
and slotting 

Volume Details Actuals LY Actual demand one year ago 

Plan Vol The manufacturer's planned volume 

Sales Proj Planned sales volume: actuals plus forecast 

Actuals Ttl Total actual quantity (including both base and 
incremental volume) 

Base Fcst Base volume: actuals plus forecast 

Incr Fcst Incremental volume: actuals and forecast due only 
to planned promotions

Sales Quota Plan $ The manufacturer's planned revenue 

Sales Quota Sales quota (revenue) 
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View Series Description

$ Sales Proj Planned sales dollars: actuals plus forecast 

PTP: Quota and Fund Entry: Bottom-Up
This worksheet lets you set quotas and funds at lower levels.

Basics

Accessing this worksheet • In My Worksheets (in Collaborator Workbench), click 
PTP: Quota and Fund Entry: Bottom-Up.

• If a worksheet is currently open, click File > Open. 
Click PTP: Quota and Fund Entry: Bottom-Up and then
click Open.

Levels you can select Territory, Retailer, Brand, Promotion Group

Levels used in cross tabulation None

Time aggregation Weekly

Business Data
Same as for PTP: Quota and Fund Entry: Top-Down, except that this worksheet does 
not include a Volume Details area.

PTP: Quota and Fund View
This read-only worksheet lets you view quotas and funds.

Basics
This read-only worksheet lets you view quotas and funds.
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Accessing this worksheet • In My Worksheets (in Collaborator Workbench), click 
PTP: Quota and Fund View.

• If a worksheet is currently open, click File > Open. 
Click PTP: Quota and Fund View and then click Open.

Levels you can select Territory, Retailer, Brand

Levels used in cross tabulation Promotion Group

Time aggregation Weekly

Business Data
Same as for PTP: Quota and Fund Entry: Top-Down, except that this worksheet does 
not include a Volume Details area.
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8
PTP: Tracking Volume

This chapter covers the following topics:

• Overview

• Reference

Overview
This chapter describes how track sales volume, as part of the PTP business process. It 
includes the following sections.

To track volume, you start in the Collaborator Workbench and launch the Volume 
Tracking worksheet:

The Volume Tracking report is where product, territory, and account volumes are 
forecasted and monitored to ultimately feed volume requirements to operations. Fund 
planning already covered will be integrated with volume planning, because forecast 
volumes drive budgets in live accrual environments and drive spending for case rate 
allowances and other variable spending deals. 

In the Volume Tracking - Detail report, you can drill down to the retailers of a territory 
and see the same data. 
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Tracking Volume for Territories
1. In My Worksheets (in Collaborator Workbench), click Volume Tracking

Or if a worksheet is currently open, click File > Open. Click Volume Tracking and 
then click Open.

2. If the worksheet does not show data immediately, click Data > Rerun. Or click the 
Run button.

3. At the top of the screen, select the territory whose volume you want to see.

The worksheet looks like this:

Volume Tracking Table
The table compares last year's sales to this year's plan, for the selected territory.
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This table tracks the following on a weekly basis:

• Last year's shipments

• This year's shipments

• The current year's base volume projection

• The current year's incremental volume projection

• Cumulative % versus your plan

The information here can be updated weekly to give you an up-to-date tally of how you
are performing versus your plan. Numbers are highlighted in different colors to give 
you a quick and easy way to keep abreast of your performance:

• Green is above plan

• Orange is slightly below plan (95-99.99%)

• Red is more than 5% below plan

Volume Tracking Graph
The Volume Tracking graph gives you a week-by-week look at the plan and the total 
forecast:
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Base and Incremental Graph
The Base and Incremental graph displays the current year's base and incremental sales.

Possible Actions
In this worksheet, depending on your authorization, you can do the following:

Use File > Open to access other PTP worksheets.

Tracking Volume for Retailers
1. In My Worksheets (in Collaborator Workbench), click Volume Tracking - Detail.

Or if a worksheet is currently open, click File > Open. Click Volume Tracking - 
Detail and then click Open.

2. If the worksheet does not show data immediately, click Data > Rerun. Or click the 
Run button.

3. At the top of the screen, select the territory and then retailer whose volume you 
want to see.

The worksheet looks like this:
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This worksheet shows the same data as the Volume Tracking worksheet; see 
"Tracking Volume for Territories".

Reference

Volume Tracking
This worksheet compares last year's sales to this year's plan.

Basics

Accessing this worksheet • In My Worksheets (in Collaborator Workbench), click 
Volume Tracking.

• If a worksheet is currently open, click File > Open. 
Click Volume Tracking and then click Open.

Levels you can select Territory
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Levels used in cross tabulation None

Time aggregation Weekly

Business Data

View Series Description

Forecast vs Actuals Shipments Historical shipment volume from the manufacturer 
to the retailers' locations 

ActualLY Actual demand one year ago 

Actuals Ttl Total actual quantity (including both base and 
incremental volume) 

Ttl Fcst Total volume: base forecast plus incremental 
forecast 

Base Fcst Base volume: actuals plus forecast 

Incr Fcst Incremental volume: actuals and forecast due only 
to planned promotions 

Plan Vol The manufacturer's planned volume 

Cumulative 
Actuals

Total actuals (base plus incremental) cumulative to 
date 

Cumulative Plan Cumulative frozen planned volume 

Cumulative % vs 
Plan

Total cumulative actuals, as a fraction of the plan

Base and 
Incremental

Base Fcst Base volume: actuals plus forecast 

Incr Fcst Incremental volume: actuals and forecast due only 
to planned promotions 
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Volume Tracking - Detail
This worksheet compares last year's sales to this year's plan, at a lower level.

Basics

Accessing this worksheet • In My Worksheets (in Collaborator Workbench), click 
Volume Tracking - Detail.

• If a worksheet is currently open, click File > Open. Click 
Volume Tracking - Detail and then click Open.

Levels you can select Territory, Retailer

Levels used in cross 
tabulation

None

Time aggregation Weekly

Business Data
Same as in the Volume Tracking worksheet.
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9
PMO: Planning Promotions

This chapter covers the following topics:

• Introduction to the Planning Environment

• Creating a Promotion

• Marking a Promotion as Planned

• Approving a Promotion

• Committing a Promotion

• Marking a Promotion as Partially Paid or Paid

• Closing a Promotion

• Making Other Changes to a Promotion

• Copying and Pasting a Promotion

• Deleting a Promotion

• Reference

Introduction to the Planning Environment
This chapter describes how to create promotions and make changes if needed, as part of
the PMO business process. It includes the following sections:

See also

"Promotions"

You plan and manage promotions in the Planning Environment, which is the entry 
point to both historical and planned event analysis. Event planning consists of creating 
and managing a calendar of promotional events, and understanding their impact on 
sales, promotion spending, and profitability, as well as their correlation with sales 
quotas. Demantra's Planning Environment provides all this critical information in one 
place.
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To open and navigate the Planning Environment
1. In My Worksheets (in Collaborator Workbench), click Planning Environment.

2. If the worksheet does not show data immediately, click Data > Rerun. Or click the 
Run button.

PTP displays the following screen:

3. At the top of the screen, select the territory, retailer, category, and promotion group.

4. In the Event Planner window, click a row. Notice the following changes in the rest 
of the worksheet, depending on the scenario and promotion associated with that 
row:

• The graphs below this display graphical information for the promotion.

• The tables below this display side-by-side details for all promotions within the 
currently selected scenario.

5. Click a promotion in the Cost Benefit Review or Fund Allocation window. Notice 
that the same promotion is highlighted throughout the worksheet.
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Color Conventions
The Planning Environment uses the following color conventions:

• White indicates editable fields.

• Gray indicates loaded data such as Start Ship and End Ship.

• Blue indicates data that is calculated by PTP, especially by the Analytical Engine.

• Red indicates negative profit numbers.

Also notice that in the Event Planner window, the Evt Status for a promotion may be 
displayed in different colors, to indicate whether that promotion has been optimized. 
Here:

• White means that the promotion has not been optimized.

• Yellow means that the promotion has been optimized.

• Green means that the promotion has been optimized and accepted, so that the 
promotion is using the optimization results.

Sales % vs. Quota
This window shows an analysis of planned sales to sales quota, for the given retailer. 
This is the total for the retailer. For convenience, the sales projection is also shown.

Fund Balances
This window provides a detailed overview of authorized funds (MDF, BDF, slotting), 
spend and fund balances to date, for the given territory. This is the total for the 
territory.
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Event Planner
This window shows event details such as the start and end ship dates, vehicle type, 
vehicle cost, buydown, base volume and incremental volume. Incremental volume is 
generated by Demantra's comprehensive analytical engine.

Notice that the events are grouped according to the associated scenario. As noted in 
"Promotions and Scenarios", the Sandbox scenario contains all the tentative events 
(unplanned events), and the Current Year scenario contains all the rest. The unplanned 
events have no impact on budget.

This window is the primary area in which you create or modify promotions.

Also notice that when you select a row in this window, the graphs and tables below are 
updated to show details depending on the scenario and promotion associated with that 
row.

Sales Breakdown for Event
This window graphically shows the sales breakdown for the selected event. The 
breakdown shows both base and incremental volume.
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Spend Breakdown for Event
This window graphically shows the spending breakdown for the selected event. The 
breakdown shows both vehicle spending and buydown.

Cost Benefit Review
This window presents a detailed cost benefit analysis for each event in the currently 
selected scenario. Details include profitability metrics from both the manufacturer and 
retailer's perspective, overall event spend, cost per incremental unit (CPIU), and 
payment type. Here you can control the status of the event.

The incremental manufacturing profit is the additional profit that the manufacturer 
earns because of the promotion, in addition to the base profit that would be earned even 
without a promotion. The incremental retailer profit is analogous.

Fund Allocation
This window displays the allocated funding for each event in the currently selected 
scenario. Here you allocate the promotional costs between the MDF and BDF funds.
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Possible Actions
In this worksheet, depending on your authorization, you can do the following:

• Edit a promotion, by changing the sale price and other properties. You can also 
right-click a promotion and select Edit to access other properties.

• Copy and paste promotions. See "Copying and Pasting a Promotion".

• Delete promotions. See "Deleting a Promotion".

• Run simulations. See "Running a Simulation.. Note that this worksheet does not 
contain the data needed to find cannibalization.

• Run optimization. See "Optimizing a Promotion"..

• Right-click on a promotion and open other worksheets filtered to this promotion. 
For example, see "Examining Promotins from a Retailer's Point of View.

• Right-click on a scenario and open the PMO: Promotion Comparison worksheet 
filtered to that scenario. See "Comparing Promotions in a Scenario".

Creating a Promotion

To create a promotion
1. Open the Planning Environment; see "Introduction to the Planning Environment".

2. At the top of the screen, select the territory, retailer, category, and then promotion 
group with which you want to create the promotion.

3. In the Event Planner window, right-click an existing promotion and then select 
New Promotion.

Oracle Demantra displays the following screen.
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4. For Name, specify a name for this promotion.

5. The Population area shows the currently selected combinations with which the new
promotion will be associated. 

The default combinations are taken from the current selection in the worksheet. To 
change them, see "To reassign a promotion to a different item or location".

6. The Start and End dates are controlled by default settings. Edit them as needed.

7. Specify values for the other attributes as appropriate:

Start Ship, End Ship Optionally specify when the product will be shipped for the 
promotion. You might specify this information later, when the
promotion is more certain.

Scenarios Choose Sandbox.

Vehicle Type Choose a type of promotion that affects demand as closely as 
possible to the promotion you are creating.
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Cons Promo Specify the type of consumer overlay, if any. This affects the 
number of Units. For example, if Cons Promo is a two-for-one 
deal, then Units becomes 2.

8. Click Create. The new promotion is created and is displayed in the Event Planner 
window. It has a default cost based on the vehicle type you specified.

9. Specify the Sale Price for use during the promotion.

10. Specify the costs for this promotion:

1. If the Veh Type is incorrect, change it, save the data and rerun the worksheet. 
Then PTP puts the default fixed cost for the new vehicle type into the Veh $ 
series.

2. Optionally edit Veh $, if the fixed cost for this promotion is different from the 
default.

3. For Buydown, specify the discount per promoted unit that will be paid to the 
retailer.

11. Click Data > Save Data.

Because this promotion is unplanned, it is considered hypothetical and does not have 
an impact on the promotion funds or on the forecast.

See also

"Copying and Pasting a Promotion"

Marking a Promotion as Planned
Before you mark a promotion as planned, you may want to run simulation, 
optimization, or both, as described in "PMO: Simulation and Optimization."

Before marking a promotion as planned, you also generally examine the promotion to 
be sure you have chosen the best vehicle type and so on. You may want to create several
tentative promotions (all in the Sandbox scenario) and view them side by side. See 
"PMO: Examining and Comparing Promotions."

To mark a promotion as planned
1. In the Fund Allocation window, change MDF Alloc % as desired. This specifies the 

percentage of the event that is funded by MDF. Enter 50 for 50%, for example.

The remainder is automatically funded by BDF, as PTP automatically computes 
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BDF Alloc % and BDF Alloc.

2. In the Cost Benefit Review window, change the Evt Status of the promotion to 
Planned.

3. Right-click the promotion and then select Edit Promotion.

4. Change Scenarios to Current Year.

5. Click OK.

6. Click another promotion in the worksheet. PTP automatically updates the details 
for the newly planned promotion. Notice that the promotion now consumes funds 
and has an impact on sales projections.

Approving a Promotion

To approve a promotion
1. In the Event Planner window, change the Evt Status to Approved.

2. Click Data > Save Data.

3. Rerun the worksheet.

Committing a Promotion
You commit a promotion when you have a firm commitment from the retailer to run 
the promotion. When you commit a promotion, PTP takes a snapshot of the current 
state of the promotion, for use in later analysis. The committed promotions are included
in all projections. PTP also freezes the promotion at this point, so that you cannot 
change its properties (apart from advancing the status further).

To commit a promotion
1. In the Event Planner window, change the Evt Status to Committed.

2. Click Data > Save Data.

3. Optionally, to see the projections that PTP has just captured, use the PMO: 
Promo-Evaluation: Mfg or PMO: Promo-Evaluation: Rtl worksheet. See "PMO: 
Reviewing Past Performance."
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Marking a Promotion as Partially Paid or Paid

To mark a promotion as paid
1. Open the Planning Environment; see "Introduction to the Planning Envirnoment."

2. In the Event Planner window, change the Evt Status to Partial Paid or Paid.

3. Click Data > Save Data.

4. Rerun the worksheet.

Closing a Promotion

To close a promotion
1. Open the Planning Environment; see "Introduction to the Planning Environment".

2. In the Event Planner window, change the Evt Status to Closed.

3. Click Data > Save Data.

4. Rerun the worksheet.

Making Other Changes to a Promotion
This section describes generally how to make other changes to a promotion. You 
typically make changes in the Planning Environment; see "Introduction to the Planning 
Environment".

Note: Before you change a promotion, you should change its status 
back to Unplanned. After making your change, restore the previous 
status. This procedure ensures that PTP triggers all internal processes 
as needed.

To modify a promotion
1. In the Event Planner window, edit any details in the row corresponding to the 

promotion.

2. Click Data > Save Data.
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3. If you changed the Veh Type, rerun the worksheet to see the new default cost of this
promotion.

To rename a promotion 
1. Right-click it and click Edit.

2. Type a new name and click OK.

To reassign a promotion to a different item or location
You can reassign an unplanned promotion to associate it with a different territory, 
retailer, item, or Ship To, as needed.

1. Right-click a promotion and click Edit.

2. Click Edit below the Population area.

The following dialog box is displayed:
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Usually a promotion is associated with a territory, retailer, category, and promotion
group.

To change the territory, retailer, category, or promotion group, click that level name
in Selected Filter Levels and change the selection displayed in Selected members.

For example, to associate the promotion with a different promotion group:

1. In Selected Filter Levels, click Promotion Group.

2. Then in the Selected members list, double-click the promotion group that you 
no longer want to use for this promotion. For example, double-click ADVO 100 
to remove it from this list.

3. Then in Available members, double-click the promotion group that should be 
used. This promotion group is then moved to the Selected members list. For 
example, double-click ADVO 200 to move it to the Selected members list; now 
the promotion is associated with ADVO 200 instead of ADVO 100.

3. Repeat as necessary.

4. Click Finish to exit this dialog box.

5. Click Finish. The changes are saved.
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6. Rerun the worksheet to see the changes.

Copying and Pasting a Promotion

To copy and paste a promotion
1. You typically start in the Planning Environment; see "Introduction to the Planning 

Environment".

2. In the Event Planner window, right-click a promotion and click Copy.

Tip: You can do the same thing in any area of the worksheet that 
displays promotions.

3. Right-click and then select Paste.

Oracle Demantra displays a dialog box that asks for details about the copy.

4. Specify one of the following:

• To shift the dates of the newly copied promotion, specify a number in the Shift 
By field. The copy will be shifted later in time by the specified amount, but will 
last for the same length of time. You can use any integer, including negative 
number or zero.

• To specify a different start and end date, specify values in the From and To 
fields.

• To make the new promotion span the entire length of time used in the 
worksheet, select Worksheet Derive.

5. Click OK.

6. When prompted for a new promotion name, type the name and click OK.

Deleting a Promotion

To delete a promotion
1. You typically start in the Planning Environment; see "Introduction to the Planning 

Environment."

2. In the Event Planner window, right-click a promotion and click Delete.
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Tip: You can do the same thing in any area of the worksheet that 
displays promotions.

3. Oracle Demantra prompts you to confirm the action. Click Yes or No.

4. Rerun the worksheet to see the change.

Reference

Planning Environment

Basics

Accessing this worksheet • In My Worksheets (in Collaborator Workbench), click 
Planning Environment.

• If a worksheet is currently open, click File > Open. Click
Planning Environment and then click Open.

Levels you can select Territory, Retailer, Category, Promotion Group

Levels used in cross tabulation Scenario, Promotion

Time aggregation Yearly

Business Data

View Series Description

Sales % vs Quota (Base + 
Viewed Events)

Sales Quota Sales quota (revenue)

% Attained Percentage of sales quota attained

$ Sales Proj Planned sales dollars: actuals plus 
forecast
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View Series Description

Fund Balances MDF Auth Authorized market development 
funds, calculated as follows: (base rate 
+ dev rate)*volume + fixed MDF funds

MDF Bal Remaining market development funds, 
calculated as the authorized MDF less 
the spent or committed funds

BDF Auth Authorized brand development 
funds+D75

BDF Bal Remaining brand development funds, 
calculated as the authorized BDF less 
the spent or committed funds

Slot Auth Authorized slotting funds

Slot Bal Remaining slotting budget, accounting 
for the part that has been spent

Unmatched $ Trade spend not yet matched to a 
promotion.

Ttl Fund Auth Total authorized spending, including 
MDF, BDF, and slotting

Ttl Fund Bal Remainder of total authorized 
spending, after accounting for 
spending

Event Planner Start Ship Date when product will start to ship

End Ship Date when shipments will end for the 
event

Start Event Date when promotion starts in stores

# Wks Event length in whole weeks, assuming
that each week starts on Monday.

Veh Type Vehicle type or event type of the 
promotion
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View Series Description

Veh $ Vehicle cost for the promotion

Cons Promo Consumer overlay, the deal type as 
seen by the consumer.

Shelf Price Everyday price to the consumer

Sale Price Sale price per unit at shelf

Units Number of units in the deal to the 
consumer. Usually equal to 1. Use 2 for 
2-for-1 sales, for example.

Buydown Buydown allowance per unit, discount 
offered to retailer for running the event

Lift Lift factor for the promotion

Base Evt Vol Base volume during the promotion

Incr Evt Vol Incremental volume due to the 
promotion

Ttl Evt Vol Total volume for the promotion

Sales Breakdown for Event Base Evt Vol Base volume during the promotion

Incr Evt Vol Incremental volume due to the 
promotion

Cost Benefit Review Ttl Evt $ Total sales during the promotion, for 
the manufacturer

Incr Evt $ Incremental sales to the manufacturer 
due to the event

Mfg Profit Manufacturer's profit from the event

Incr Mfg Prft Incremental profit to the manufacturer 
due to the promotion
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View Series Description

Rtl Prft Retailer's profit from the event

Incr Rtl Prft Incremental profit to the retailer due to 
the promotion

Evt Spend Total planned spending for promotion, 
sum of buydown, vehicle costs, and 
slotting

CPIU Event cost per incremental unit sold as 
a result of the promotion.

% Spend Event spending, as a percentage of 
event sales

Pay Type Indicates the payment terms between 
the manufacturer and the retailer for 
this promotion

Evt Status Current status of the promotion

Spend Breakdown for 
Event

Buydown $ Buydown spend for the promotion

Veh $ Vehicle cost for the promotion

Fund Allocation Evt Spend exS Total planned buydown and vehicle 
costs for promotion

MDF Alloc % Market development funds, as a 
percentage of total plan spending 
(excluding slotting costs). 

MDF Alloc Allocated market development funds, 
based on the percentage set by the 
planner

BDF Alloc % Brand development funds, as a 
percentage of total plan spending 
(excluding slotting costs)
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View Series Description

BDF Alloc Allocated brand development funds, 
based on the percentage set by the 
planner
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10
PMO: Simulation and Optimization

This chapter covers the following topics:

• Overview

• Running the Analytical Engine in Simulation Mode

• Running a Simulation

• Optimizing a Promotion

• Viewing Optimization Results

• Accepting an Optimized Promotion

• Reference

Overview
Before you mark a promotion as planned (or before you commit a promotion), you may 
want to run a simulation on it, or run the optimizer, or both. This chapter describes how
to perform these tasks. It includes the following sections:

You may also want to examine the promotion in detail or create several tentative 
promotions (all in the Sandbox scenario) and view them side by side. See "PMO: 
Examining and Comparing Promotions."

A qualified user or administrator typically runs the Analytical Engine periodically in 
batch mode to generate a forecast for all items and locations in the system. The forecast 
data includes total volume, base volume (volume in the absence of promotions), 
incremental volume, pre- and post-promotional volume, and volume due to 
cannibalization.

To see an immediate forecast for a newly entered promotion, however, you do not have 
to wait for the next batch run, You can simply run a simulation, which considers only 
one promotion. With the forecasted numbers, you can see the effect on quota, accruals, 
spending, and so on. Likewise, if you change the properties of a promotion, you can run
a simulation to see the resulting forecast.
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Also, to help you find the most effective promotion for your needs, PTP provides the 
ability to optimize a promotion. The Promotion Optimization module uses the 
previously stored results of the Analytical Engine. You provide a specific goal and 
constraints, and the optimizer determines the best set of promotion properties. PTP 
provides a worksheet for viewing the optimized results, which you can then accept, if 
these results meet your needs.

In principle, you can run simulation or optimization anywhere PTP displays future 
promotions. Then you can open another worksheet filtered to your promotion to see 
further details. Or you can first open that worksheet and then run simulation or 
optimization. Several worksheets are useful for these purposes: 

The path you choose depends on what meets your needs at any time, but consider the 
following general principles:

• If you run a simulation in the Planning Environment or the PMO: Optimization 
Comparison worksheet, the engine does not have the data needed to see 
cannibalization, which means that you may need to rerun simulation later in a 
different worksheet. If you run simulation in the other worksheets (PMO: 
Promotion Comparison, PMO: Promo Effect - Mfg, and PMO: Promo Effect - Rtl), 
the Analytical Engine can find cannibalization.

• The PMO: Optimization Comparison worksheet is the only place that displays 
optimization results.

Note: Before you can perform either simulation or optimization, it 
is necessary to run the Analytical Engine in batch mode once in 
your application. See "Running Required Workflows."
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Running the Analytical Engine in Simulation Mode
Before you can perform simulations, you must start the Analytical Engine in simulation 
mode. Note that an error will occur if the Analytical Engine has not been run previously
in batch mode.

To run the engine in simulation mode
1. Click Start > Programs.

2. Click Demantra > Demantra Spectrum release > Simulation Engine.

Running a Simulation
You can run a simulation to get a forecast for a promotion, particularly a newly created 
promotion or a promotion that you have just changed.

Note: The promotion must start in the future.

To run a simulation
1. Make sure the Analytical Engine is running in simulation mode; see "Running the 

Analytical Engine in Simulation Mode".

2. Start in the Planning Environment worksheet.

3. Right-click a promotion and launch a worksheet, such as PMO: Promo Effect - Mfg 
or PMO: Promo Effect - Rtl.

Note: In principle, you can run a simulation in any worksheet. Note
that if you run a simulation in the Planning Environment 
worksheet, however, the engine does not have the data needed to 
see cannibalization.

4. Click Data > Run Simulation. Or click the Simulation button.

The Select Simulation Type page appears.
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5. Click Selected Combination.

6. For Select Engine Profile, click Simulation.

7. Click OK.

Depending on the amount of data in your worksheet, simulation may take a few 
minutes.

8. When the simulation is complete, Oracle Demantra displays a message. Click OK.

9. Rerun the worksheet.

10. Examine the results.

11. To accept the results, click Data > Accept Simulation.

Optimizing a Promotion
PTP provides an optimizer that you can use to find the best possible promotion to 
maximize revenue, profit, or units. It considers constraints such as the following:

• Retailer-specific details such as minimum needed retailer event margin. You can 
override the retailer's default event margin if needed.

• Maximum budget and buydown for this promotion.

• Basics such cost of goods, list price, and so on.

To optimize a promotion
1. You typically start in the Planning Environment or the PMO: Optimization 
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Comparison worksheet. See "Introduction to the Planning Environment" or 
"Viewing Optimization Results".

2. In the Event Planner window, right-click any future promotion and click Methods >
Optimize.

PTP displays the following dialog box:

3. Specify values for the following parameters:

Optimization Goal Select one of the following goals for this promotion:

• Maximize Revenue

• Maximize Profit

• Maximize Units
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Max Budget Maximum allowed budget for this promotion. If you 
leave this unspecified, there is no maximum budget.

Optimization Range Start, 
Optimization Range End

If these are blank, Promotion Optimization assumes 
that you want the optimized promotion to fall within 
the span of time of the original promotion. If you want
Promotion Optimization to search for a better time for 
this promotion, use these parameters to specify the 
range of time for optimization to consider.

Buydown Generation Method Specify whether Promotion Optimization should use 
the buydown that you have already entered or 
calculate an optimal buydown for this promotion.

Max Buydown Maximum allowed buydown for this promotion. If 
Promotion Optimization calculates an optimal 
buydown, the buydown will not exceed this value.

Min Rtl Margin Override Minimum margin that the retailer must make on this 
promotion, as specified in this retailer's profile. Use 
this parameter to override that value, if needed.

Use a value greater than 0 and less than or equal to 1.

4. Click Optimize.

Now the system will select the promotion parameters (sale price, vehicle type, and 
so on) that best meet your goal. This is a huge time saver because you do not have 
to go through all the possible permutations of each promotion in order to find the 
best one for your goal.

When optimization is complete, PTP displays a message that indicates the status of 
the optimization and the number of iterations that it ran. (You may not see this 
message, depending on how PTP is configured.)

Then PTP asks if you want to rerun the worksheet.

5. Click OK.

6. If you are not yet in the PMO: Optimization Comparison worksheet, right-click the 
promotion and open that worksheet. See "Viewing Optimization Results."
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Viewing Optimization Results

To view optimization results
If you are not yet in the PMO: Optimization Comparison worksheet, right-click the 
promotion and click Open With > PMO: Optimization Comparison.

The system displays the following:

The PMO: Optimization Comparison worksheet provides the capability to view the 
optimization results (shown in yellow) and compare them to the current state of the 
promotion, to help you decide if you want to accept this optimization. This worksheet 
contains the following information.

Event Planner and Optimized Event Planner
These windows provide details of the events, including start and end ship dates, vehicle
type, vehicle cost, buydown, base volume and incremental volume. Incremental volume
is generated by Oracle Demantra's comprehensive analytical engine.

The Event Planner window shows these details for the actual promotion as it currently 
is. The Optimized - Event Planner window shows the details of the optimized 



10-8    Oracle Demantra Predictive Trade Planning User's Guide

promotion. If you accept the optimization, these details are moved to the actual 
promotion.

Notice that the values are given right below the original values of the promotion to 
facilitate easy comparison. 

If you have not yet optimized this promotion, the Optimized - Event Planner window is
empty.

Cost Benefit Review and Optimized - Cost Benefit Review
These windows display a detailed cost benefit analysis, including profitability metrics 
from both the manufacturer and retailer's perspective, overall event spend, cost per 
incremental unit (CPIU), and so on. The Cost Benefit Review window displays these 
details for the actual promotion as it currently is. The Optimized - Cost Benefit Review 
window shows the details of the optimized promotion. If you accept the optimization, 
these details are moved to the actual promotion.

Here notice that the color of the Evt Status series (upper window only) indicates the 
optimization status of this promotion:

• White means that the promotion has not been optimized.

• Yellow means that the promotion has been optimized.

• Green means that the promotion has been optimized and accepted, so that the 
promotion is using the optimization results.

If you have not yet optimized this promotion, the Optimized - Cost Benefit Review 
window is empty.

Graphs
This worksheet also provides the following graphs:

• Sales Comparison: Compares the total event dollars generated before and after 
optimization.

• Incr Mfg Prft Comparison: Compares the incremental manufacturing profit 
generated before and after optimization. This is the additional profit that the 
manufacturer earns because of the promotion, in addition to the base profit that 
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would be earned even without a promotion.

• Incr Rtl Prft Comparison: Compares the incremental retailer profit generated before 
and after running optimization. This is the additional profit that the retailer earns 
because of the promotion, in addition to the base profit that would be earned even 
without a promotion.

• Spend Comparison: Compares the event spend before and after running 
optimization.

If you have not yet optimized this promotion, each of these graphs includes only one 
bar, corresponding to the promotion in its current state.

Possible Actions
In this worksheet, depending on your authorization, you can do the following:

• Edit a promotion, by changing the sale price and other properties. You can also 
right-click a promotion and select Edit to access other properties.

• Run simulations. See "Running a Simulation".

• Run or rerun optimization. See "Optimizing a Promotion".

• Use the right-click menu to open other worksheets filtered to this promotion.

Accepting an Optimized Promotion
After you optimize a promotion, you can accept it. You can do this in any worksheet 
that displays promotions. For example, you can start in the PMO: Optimization 
Comparison worksheet.

Note: This action has no effect on a promotion that has not been 
optimized.

To accept an optimized promotion
1. Right-click the promotion and select Methods > Accept Optimization.

If you accept the optimization, the attributes of the optimized promotion are copied
into the original promotion. Also notice that the color of the Evt Status series 
changes to green, to indicate that optimization has been accepted.

2. Optionally rerun simulation for a new net-lift analysis; see "Running a Simulation".

3. Optionally right-click the promotion and launch either PMO: Promo Effect - Mfg or 
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PMO: Promo Effect - Rtl. See "PMO: Examining and Comparing Promotions".

Reference

PMO: Optimization Comparison

Basics

Accessing this worksheet Right-click a promotion and click Open With > PMO: 
Optimization Comparison.

Levels you can select Territory, Retailer, Promotion

Levels used in cross tabulation Promotion Group, Scenario

Time aggregation Yearly

Business Data

View Series Description

Event Planner Start Ship Date when product will start to ship 

End Ship Date when shipments will end for the event 

Start Event Date when promotion starts in stores 

# Wks Event length in whole weeks, assuming that 
each week starts on Monday. 

Veh Type Vehicle type or event type of the promotion 

Veh $ Vehicle cost for the promotion 

Cons Promo Consumer overlay, the deal type as seen by 
the consumer. 

Shelf Price Everyday price to the consumer 
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View Series Description

Sale Price Sale price per unit at shelf 

Buydown Buydown allowance per unit, discount 
offered to retailer for running the event 

Lift Lift factor for the promotion 

Base Evt Vol Base volume during the promotion 

Incr Evt Vol Incremental volume due to the promotion 

Ttl Evt Vol Total volume for the promotion 

Optimized - Event 
Planner

Start Ship Date when product will start to ship 

End Ship Date when shipments will end for the event 

Start Event O Date when optimized promotion starts in 
stores 

# Wks O Event length in whole weeks, assuming that 
each week starts on Monday, for optimized 
promotion 

Veh Type O Vehicle type or event type of the optimized 
promotion 

Veh $ O Vehicle cost for the optimized promotion 

Cons Promo Consumer overlay, the deal type as seen by 
the consumer. 

Shelf Price Everyday price to the consumer 

Sale Price O Sale price per unit at shelf, for the optimized 
promotion 

Buydown O Buydown allowance per unit, for optimized 
promotion 

Lift O Lift factor for the optimized promotion 
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View Series Description

Base Evt Vol O Base volume for optimized promotion 

Incr Evt Vol O Incremental volume due to the optimized 
promotion 

Ttl Evt Vol O Total volume for the optimized promotion 

Cost Benefit Review Base Evt $ Base sales for the manufacturer, during the 
promotion 

Incr Evt $ Incremental sales to the manufacturer due to
the event 

Ttl Evt $ Total sales during the promotion, for the 
manufacturer 

Mfg Profit Manufacturer's profit from the event 

Incr Mfg Prft Incremental profit to the manufacturer due 
to the promotion 

Rtl Prft Retailer's profit from the event 

Incr Rtl Prft Incremental profit to the retailer due to the 
promotion 

Evt Spend exS Total planned buydown and vehicle costs 
for promotion 

CPIU Event cost per incremental unit sold as a 
result of the promotion. 

% Spend Event spending, as a percentage of event 
sales 

Evt Status Current status of the promotion 

Optimized - Cost Benefit
Review

Base Evt $ O Base sales for manufacturer, for optimized 
promotion 
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View Series Description

Incr Evt $ O Incremental sales to the manufacturer due to
the event, for the optimized promotion 

Ttl Evt $ O Total sales during the promotion, for the 
manufacturer (for the optimized promotion) 

Mfg Prft O Manufacturer's profit from the optimized 
event 

Incr Mfg Prft O Incremental profit to the manufacturer due 
to the optimized promotion 

Rtl Prft O Retailer's profit from the optimized event 

Incr Rtl Prft O Incremental profit to the retailer due to the 
optimized promotion 

Evt Spend exS O Total planned buydown and vehicle costs 
for optimized promotion 

CPIU O Event cost per incremental unit sold as a 
result of the promotion, for optimized 
promotion 

% Spend O Event spending, as a percentage of event 
sales, for optimized promotion 

Sales Comparison Ttl Evt $ Total sales during the promotion, for the 
manufacturer 

Ttl Evt $ O Total sales during the promotion, for the 
manufacturer (for the optimized promotion) 

Incr Mfg Prft 
Comparison

Incr Mfg Prft Incremental profit to the manufacturer due 
to the promotion 

Incr Mfg Prft O Incremental profit to the manufacturer due 
to the optimized promotion 

Incr Rtl Prft Comparison Incr Rtl Prft Incremental profit to the retailer due to the 
promotion 
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View Series Description

Incr Rtl Prft O Incremental profit to the retailer due to the 
optimized promotion 

Spend Comparison Evt Spend exS Total planned buydown and vehicle costs 
for promotion 

Evt Spend exS O Total planned buydown and vehicle costs 
for optimized promotion
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11
PMO: Examining and Comparing 

Promotions

This chapter covers the following topics:

• Overview

• Examining Promotions from the Manufacturer's Point of View

• Examining Promotions from a Retailer's Point of View

• Comparing Promotions in a Scenario

• Reference

Overview
This chapter describes how to examine and compare promotions, to help you choose 
the best promotion for your needs. It includes the following sections:

Before you mark a promotion as planned (or before you commit a promotion), you 
generally examine the promotion to be sure you have chosen the best vehicle type and 
so on. 

To evaluate promotions, you generally start in the Planning Environment worksheet. 
From there, you right-click a promotion and launch any of the relevant PMO 
worksheets to see data for that promotion.
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Or, to compare multiple promotions, you right-click a scenario and launch a worksheet 
to view the promotions in that scenario side-by-side. As shown here, you can also open 
one worksheet from another, to look at the same promotion in a different way.

You may also want to run simulation, optimization, or both, as described in "PMO: 
Simulation and Optimization."

Examining Promotions from the Manufacturer's Point of View

To evaluate a future promotion from the manufacturer's point of view
1. You typically start in the Planning Environment; see "Introduction to the Planning 

Environment."

2. In the Event Planner window, right-click a promotion and click Open With > PMO: 
Promo Effect - Mfg.

3. If the worksheet does not show data immediately, click Data > Rerun. Or click the 
Run button.

The system displays the PMO: Promo Effect - Mfg worksheet, filtered to display just the
promotion that you right-clicked.
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This worksheet includes the following areas.

Event Planner
This window is the same as the Event Planner window in the Planning Environment 
worksheet. It displays details of all events, including start and end ship dates, vehicle 
type, vehicle cost, buydown, base volume and incremental volume.

Cost Benefit Review
This window is similar to the Cost Benefit Review window in the Planning 
Environment worksheet. It displays a detailed cost benefit analysis, including 
profitability metrics, overall event spend, and cost per incremental unit (CPIU).

Lift Decomposition Graph - Manufacturer
This window shows the effects of the promotion, from the perspective of the 
manufacturer.
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Four series are shown here:

• Base Evt $ is the base money earned by the manufacturer over the course of the 
promotion. This money would have been earned even without the promotion.

• Net Incr Evt $ is the net additional money earned by the manufacturer as a result of 
the promotion; this accounts for both cannibalization and pre- and post-effects.

• Canbl $ is the money lost by the manufacturer due to cannibalistic effects of the 
promotion; see "Cannibalization" on page 19. For display purposes only, this is 
shown as a positive number so that it can be graphed.
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• Pre-Post $ is the money lost by the manufacturer due to decreased sales before and 
after the promotion. For display purposes only, this is shown as a positive number 
so that it can be graphed.

The total height of the bar graph indicates how much money the manufacturer received 
in sales, if cannibalization and pre- and post-effects were ignored.

Lift Decomposition Table - Manufacturer
The Lift Decomposition table displays the same numbers as the preceding graph, but 
displays all promotion groups that were impacted by the selected promotion. Each 
promotion group is shown as a row; the blue row indicates the promotion group on 
which the selected promotion actually ran. This table also summarizes the effects across 
brands, and across companies, for convenient comparison.

For the promoted promotion group (Exedra 100), you can see the total event dollars, 
incremental event dollars, net incremental event dollars and so on, for the selected 
promotion. Note that for Exedra 100, there was zero dollars of cannibalization and 
$2743 of pre- and post-promotional effect. 

On the other hand, examine the other promotion groups and notice that they were all 
cannibalized. Of course, for these promotion groups, there was zero direct lift, by 
definition, as the promotion did not run on them.

Here you can see these useful summaries:

• Total for promotion group where the promotion was run.

• Total effect on the brand.

• Total effect on the manufacturer.

Also notice that this table displays cannibalized and pre- and post-event volume, as 
well.

Lift Decomposition - Retailer
This table summarizes the cannibalization effects as seen by the retailer; see "Examining
Promotions from a Retailer's Point of View" for details.
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Possible Actions
In this worksheet, depending on your authorization, you can do the following:

• Edit a promotion, by changing the sale price and other properties. You can also 
right-click a promotion and select Edit to access other properties.

• Run simulations. See "Running a Simulation."

• Run optimization. See "Optimizing a Promotion."

• Use the right-click menu to open other worksheets filtered to this promotion. For 
example, you can open the PMO: Promo Effect - Rtl worksheet to see the retailer's 
perspective. See "Examining Promotions from a Retailer's Point of View.".

• View aggregate information for the retailer at the bottom of the screen. 

Examining Promotions from a Retailer's Point of View

To evaluate a future promotion from a retailer's point of view
1. You typically start in the Planning Environment; see "Introduction to the Planning 

Environment.

2. In the Event Planner window, right-click a promotion and click Open With > PMO: 
Promo Effect - Rtl.

3. If the worksheet does not show data immediately, click Data > Rerun. Or click the 
Run button.

The system displays the PMO: Promo Effect - Rtl worksheet, filtered to display just the 
promotion that you right-clicked.
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This worksheet includes the same areas as the PMO: Promo Effect - Mfg worksheet, but 
from the retailer's point of view rather than the manufacturer's.

Lift Decomposition Table - Retailer
The Lift Decomposition table displays all promotion groups that were impacted by the 
selected promotion, from the point of view of the retailer. Each promotion group is 
shown as a row; the blue row indicates the promotion group (Exedra 100) on which the 
selected promotion actually ran:

Notice two promotion groups are listed here that were not seen in the manufacturer 
version: Notrim 24 and Tyitol 50. These promotion groups represent products that this 
retailer sells, but that are made by a different manufacturer. To the retailer, it is 
undesirable to cannibalize these promotion groups.

Here you can see these useful summaries:

• Total for promotion group where the promotion was run.

• Total effect on the brand.

• Total effect on each manufacturer.

Also notice that this table displays cannibalized and pre- and post-event volume, as 
well.
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Possible Actions
In this worksheet, depending on your authorization, you can do the following:

• Edit a promotion, by changing the sale price and other properties. You can also 
right-click a promotion and select Edit to access other properties.

• Run simulations. See "Running a Simulation."

• Run optimization. See "Optmizing a Promotion."

• Use the right-click menu to open other worksheets filtered to this promotion. For 
example, you can open the PMO: Promo Effect - Mfg worksheet to see the 
manufacturer's perspective. See "Examining Promotions from the Manufacturer's 
Point of View." .

Comparing Promotions in a Scenario
To determine how best to spend trade dollars, you can compare and evaluate multiple 
promotions in a scenario. Typically you create multiple unplanned promotions in the 
Sandbox scenario and then open the PMO: Promotion Comparison worksheet to view 
them side by side.

When you identify the best promotion, you can mark it as planned; see "Marking a 
Promotion as Planned."

To compare promotions
1. You typically start in the Planning Environment; see "Introduction to the Planning 

Environment."

2. In the Event Planner window, right-click a scenario and click Open.

3. If the worksheet does not show data immediately, click Data > Rerun. Or click the 
Run button.

This launches the PMO: Promotion Comparison worksheet filtered to show the 
promotions of that scenario.
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Now you can easily compare all events in the selected scenario. The screen now 
displays the following areas.

Event Planner
This window is the same as the Event Planner window in the Planning Environment 
worksheet. It displays details of all events, including start and end ship dates, vehicle 
type, vehicle cost, buydown, base volume and incremental volume. Incremental volume
is generated by Oracle's comprehensive Analytical Engine.

Cost Benefit Review
This window is the same as the Cost Benefit Review window in the Planning 
Environment worksheet. It displays a detailed cost benefit analysis, including 
profitability metrics from both the manufacturer and retailer's perspective, overall event
spend, cost per incremental unit (CPIU), payment type and price analysis (average 
retail vs. list).

Graphs
This worksheet displays the following graphs:

• Lift Breakdown: each event is shown as a separate bar.

• Cost Per Incremental Unit: each event is shown as a separate bar.
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Possible Actions
In this worksheet, depending on your authorization, you can do the following:

• Edit a promotion, by changing the sale price and other properties. You can also 
right-click a promotion and select Edit to access other properties.

• Create new promotions; see "Creating a Promotion."

• Delete a promotion; see "Deleting a Promotion."

• Make a copy of a promotion; see "Copying and Pasting a Promotion."

• Run simulations. See "Running a Simulation."

• Run optimization. See "Optimizing a Promotion."

• Right-click a promotion and open another worksheet filtered to that promotion. For
example, you can open the PMO: Promo Effect - Rtl worksheet to see 
cannibalization from the retailer's perspective. See "Examining Promotions from a 
Retailer's Point of View."

• Change the status of a promotion, as described in "PMO: Planning Promotions."

Reference

PMO: Promo Effect - Mfg

Basics

Accessing this worksheet Right-click a promotion and click Open With > PMO: 
Promo Effect - Mfg.

Levels you can select Retailer, Category, Promotion

Levels used in cross tabulation Promotion

Time aggregation Yearly

Business Data
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View Series Description

Event Planner Start Ship Date when product will start to ship

End Ship Date when shipments will end for the 
event

Start Event Date when promotion starts in stores

# Wks Event length in whole weeks, assuming 
that each week starts on Monday.

Veh Type Vehicle type or event type of the 
promotion

Veh $ Vehicle cost for the promotion

Cons Promo Consumer overlay, the deal type as seen 
by the consumer.

Shelf Price Everyday price to the consumer

Sale Price Sale price per unit at shelf

Units Number of units in the deal to the 
consumer. Usually equal to 1. Use 2 for 
2-for-1 sales, for example.

Buydown Buydown allowance per unit, discount 
offered to retailer for running the event

Lift Lift factor for the promotion

Base Evt Vol Base volume during the promotion

Incr Evt Vol Incremental volume due to the promotion

Ttl Evt Vol Total volume for the promotion

Cost Benefit Review Ttl Evt $ Total sales during the promotion, for the 
manufacturer
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View Series Description

Incr Evt $ Incremental sales to the manufacturer due
to the event

Base Evt $ Base sales for the manufacturer, during 
the promotion

Net Incr Evt $ Net revenue to the manufacturer, after 
considering cannibalization and pre- and 
post-effects

Canbl $ Cannibalization dollars for the 
manufacturer

Pre-Post $ Total sales made before and after the 
promotion, as a result of the promotion 
(manufacturer's perspective)

Mfg Profit Manufacturer's profit from the event

Incr Mfg Prft Incremental profit to the manufacturer 
due to the promotion

Net Incr Mfg Prft Net incremental profit for the 
manufacturer, after considering 
cannibalization and pre- and post-effects

Rtl Prft Retailer's profit from the event

Incr Rtl Prft Incremental profit to the retailer due to 
the promotion

Net Incr Rtl Prft Net incremental profit for the retailer, 
after considering cannibalization and pre-
and post-effects

Evt Spend Total planned spending for promotion, 
sum of buydown, vehicle costs, and 
slotting

CPIU Event cost per incremental unit sold as a 
result of the promotion.
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View Series Description

% Spend Event spending, as a percentage of event 
sales

Cost Benefit Review Pay Type Indicates the payment terms between the 
manufacturer and the retailer for this 
promotion

Evt Status Current status of the promotion

Lift Decomposition - Mfg Base Evt $ Base sales for the manufacturer, during 
the promotion

Net Incr Evt $ Net revenue to the manufacturer, after 
considering cannibalization and pre- and 
post-effects

Canbl $ Cannibalization dollars for the 
manufacturer

Pre-Post $ Total sales made before and after the 
promotion, as a result of the promotion 
(manufacturer's perspective)

Lift Decomposition Table 
- Manufacturer

Ttl Evt $ Total sales during the promotion, for the 
manufacturer

Incr Evt $ Incremental sales to the manufacturer due
to the event

Base Evt $ Base sales for the manufacturer, during 
the promotion

Net Incr Evt $ Net revenue to the manufacturer, after 
considering cannibalization and pre- and 
post-effects

Canbl $ Cannibalization dollars for the 
manufacturer

Pre-Post $ Total sales made before and after the 
promotion, as a result of the promotion 
(manufacturer's perspective)
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View Series Description

Canbl Vol Mfg

Pre-Post Vol Total volume before and after the 
promotion, as a result of the promotion

Lift Decomposition - 
Retailer

Ttl Evt $ Rtl Total sales during the promotion, for the 
retailer

Base Evt $ Rtl Base sales for the retailer, during the 
promotion

Incr Evt $ Rtl Incremental sales to the retailer due to the
event

Net Incr Evt $ Rtl Net revenue to the retailer, after 
considering cannibalization and pre- and 
post-effects

Canbl $ Rtl Cannibalization dollars for the retailer

Pre-Post $ Rtl Total sales made before and after the 
promotion, as a result of the promotion 
(retailer's perspective)

PMO: Promo Effect - Rtl

Basics

Accessing this worksheet Right-click a promotion and click Open With > PMO: 
Promo Effect - Rtl.

Levels you can select Retailer, Category, Promotion

Levels used in cross tabulation Promotion

Time aggregation Yearly
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Business Data

View Series Description

Event Planner Start Ship Date when product will start to ship

End Ship Date when shipments will end for the event

Start Event Date when promotion starts in stores

# Wks Event length in whole weeks, assuming that 
each week starts on Monday.

Veh Type Vehicle type or event type of the promotion

Veh $ Vehicle cost for the promotion

Cons Promo Consumer overlay, the deal type as seen by 
the consumer.

Shelf Price Everyday price to the consumer

Sale Price Sale price per unit at shelf

Units Number of units in the deal to the consumer. 
Usually equal to 1. Use 2 for 2-for-1 sales, for 
example.

Buydown Buydown allowance per unit, discount 
offered to retailer for running the event

Lift Lift factor for the promotion

Base Evt Vol Base volume during the promotion

Incr Evt Vol Incremental volume due to the promotion

Ttl Evt Vol Total volume for the promotion

Cost Benefit Review - 
Retailer

Ttl Evt $ Rtl Total sales during the promotion, for the 
retailer
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View Series Description

Incr Evt $ Rtl Incremental sales to the retailer due to the 
event

Base Evt $ Rtl Base sales for the retailer, during the 
promotion

Net Incr Evt $ Rtl Net revenue to the retailer, after considering 
cannibalization and pre- and post-effects

Canbl $ Rtl Cannibalization dollars for the retailer

Pre-Post $ Rtl Total sales made before and after the 
promotion, as a result of the promotion 
(retailer's perspective)

Rtl Prft Retailer's profit from the event

Incr Rtl Prft Incremental profit to the retailer due to the 
promotion

Net Incr Rtl Prft Net incremental profit for the retailer, after 
considering cannibalization and pre- and 
post-effects

Evt Spend Total planned spending for promotion, sum 
of buydown, vehicle costs, and slotting

Pay Type Indicates the payment terms between the 
manufacturer and the retailer for this 
promotion

Evt Status Current status of the promotion

Lift Decomposition - Rtl Base Evt $ Rtl Base sales for the retailer, during the 
promotion

Net Incr Evt $ Rtl Net revenue to the retailer, after considering 
cannibalization and pre- and post-effects

Canbl $ Rtl Cannibalization dollars for the retailer
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View Series Description

Pre-Post $ Rtl Total sales made before and after the 
promotion, as a result of the promotion 
(retailer's perspective)

Lift Decomposition 
Table - Retailer

Ttl Evt $ Rtl Total sales during the promotion, for the 
retailer

Incr Evt $ Rtl Incremental sales to the retailer due to the 
event

Base Evt $ Rtl Base sales for the retailer, during the 
promotion

Net Incr Evt $ Rtl Net revenue to the retailer, after considering 
cannibalization and pre- and post-effects

Net Incr Rtl Prft Net incremental profit for the retailer, after 
considering cannibalization and pre- and 
post-effects

Canbl $ Rtl Cannibalization dollars for the retailer

Pre-Post $ Rtl Total sales made before and after the 
promotion, as a result of the promotion 
(retailer's perspective)

Canbl Vol Rtl

Pre-Post Vol Total volume before and after the promotion,
as a result of the promotion

PMO: Promotion Comparison

Basics

Accessing this worksheet Right-click a scenario and click Open.

Levels you can select Territory, Retailer, Promotion Group
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Levels used in cross tabulation Scenario, Promotion

Time aggregation Yearly

Business Data

View Series Description

Event Planner Start Ship Date when product will start to ship 

End Ship Date when shipments will end for the 
event 

Start Event Date when promotion starts in stores 

# Wks Event length in whole weeks, assuming 
that each week starts on Monday. 

Veh Type Vehicle type or event type of the 
promotion 

Veh $ Vehicle cost for the promotion 

Cons Promo Consumer overlay, the deal type as seen 
by the consumer. 

Shelf Price Everyday price to the consumer 

Sale Price Sale price per unit at shelf 

Units Number of units in the deal to the 
consumer. Usually equal to 1. Use 2 for 
2-for-1 sales, for example. 

Buydown Buydown allowance per unit, discount 
offered to retailer for running the event 

Lift Lift factor for the promotion 

Base Evt Vol Base volume during the promotion 
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View Series Description

Incr Evt Vol Incremental volume due to the 
promotion 

Ttl Evt Vol Total volume for the promotion 

Cost Benefit Review Base Evt $ Base sales for the manufacturer, during 
the promotion 

Incr Evt $ Incremental sales to the manufacturer 
due to the event 

Ttl Evt $ Total sales during the promotion, for the 
manufacturer 

Mfg Profit Manufacturer's profit from the event 

Incr Mfg Prft Incremental profit to the manufacturer 
due to the promotion 

Rtl Prft Retailer's profit from the event 

Incr Rtl Prft Incremental profit to the retailer due to 
the promotion 

Evt Spend exS Total planned buydown and vehicle costs
for promotion 

CPIU Event cost per incremental unit sold as a 
result of the promotion. 

% Spend Event spending, as a percentage of event 
sales 

Pay Type Indicates the payment terms between the 
manufacturer and the retailer for this 
promotion 

Evt Status Current status of the promotion 

Lift Breakdown Base Evt $ Base sales for the manufacturer, during 
the promotion 
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View Series Description

Incr Evt $ Net  

Cost Per Incremental 
Unit

CPIU Event cost per incremental unit sold as a 
result of the promotion. 
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12
PMO: Reviewing Past Performance

This chapter covers the following topics:

• Overview

• Evaluating Performance from the Manufacturer's Point of View

• Evaluating Performance from a Retailer's Point of View

• Viewing Actual Averages

• Reference

Overview
This chapter describes how to review past performance of your promotions. It includes 
the following sections: 

To review the performance of past promotions, you generally start in the Planning 
Environment, page 9-1 worksheet. From there, you right-click a promotion and launch 
any of the relevant PMO worksheets to see data for that promotion.

Once a promotion has been planned and executed, it is useful to evaluate its 
performance against your original plan. The PMO: Promo-Evaluation: Mfg, page 12-9 
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and PMO: Promo-Evaluation: Rtl, page 12-9 worksheets provide a detailed 
post-promotional analysis of each individual promotion (that is, compare forecast to 
actual performance).

You can view the breakdown of each event with respect to the sales dollars and profit 
generated for the manufacturer. Depending on the detail of the historical data, a lift 
decomposition can be provided showing promotional effects such as the following:

• Cannibalization

• Pre and post effects, such as pantry loading

This will enable you to see your true "net lift" and revised financial figures in order to 
properly evaluate the event's performance and uncover its true profitability.

Evaluating Performance from the Manufacturer's Point of View

To evaluate a past promotion from the manufacturer's point of view
1. You typically start in the Planning Environment; see "Introduction to the Planning 

Environment."

2. In the Event Planner window, right-click a promotion and click Open With > PMO: 
Promo-Evaluation: Mfg.

3. If the worksheet does not show data immediately, click Data > Rerun. Or click the 
Run button.

The system displays the PMO: Promo-Evaluation: Mfg worksheet, filtered to 
display just the promotion that you right-clicked.
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The PMO: Promo-Evaluation: Mfg worksheet includes the following windows.

Event Projections and Event Actuals
These windows compare the projections and the actuals, one directly above the other. 
Notice that the actuals are displayed mostly in blue:

The Event Projections window displays planned event details, including event start, 
vehicle type, total planned volume, anticipated manufacturer profit and anticipated 
spend. For the series in this window, PTP uses colors to indicate deviations between the
projections and the actuals:

• If the actual value is more than 20% different from the projection in the undesirable 
sense, the projection is shown in red.

• If the actual value is more than 20% different from the projection in the desirable 
sense, the projection is shown in green. For example, if the actual profit was 130% of
the projected profit, the projection is shown in green.

The Event Actuals window shows the corresponding actuals.

Lift Decomposition Graphs
This worksheet also displays lift decomposition graphs showing the projected 
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breakdown and the actual breakdown:

Net Incremental Graphs
The worksheet includes the following graphs to show the net incremental dollars 
earned for this promotion; each graph compares the projection to the actual. The first 
graph shows the net incremental dollars. The second and third graphs show the net 
incremental profit to the manufacturer and retailer, respectively. The net incremental 
profit is the net additional profit that is earned because of the promotion, in addition to 
the baseline profit.

Lift Decomposition Table Actual (Manufacturer)
The lift decomposition table shows the specific breakdown into base, incremental, 
cannibalization, and pre- and post-effect dollars. This table also shows the net 
incremental volume for the event. This table applies to the manufacturer's point of 
view.
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Possible Actions
In this worksheet, depending on your authorization, you can do the following:

Right-click a promotion and open another worksheet filtered to that promotion. For 
example, you can open the PMO: Promo-Evaluation: Rtl worksheet to see past 
performance from the retailer's perspective. See "Evaluating Performance from a 
Retailer's Point of View."

Evaluating Performance from a Retailer's Point of View

To evaluate a past promotion from a retailer's point of view
1. You typically start in the Planning Environment; see "Introduction to the Plannng 

Environment."

2. In the Event Planner window, right-click a promotion and click Open With > PMO: 
Promo-Evaluation: Rtl

3. If the worksheet does not show data immediately, click Data > Rerun. Or click the 
Run button.

The system displays the PMO: Promo-Evaluation: Rtl worksheet, filtered to display just 
the promotion that you right-clicked.
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This worksheet contains some of the same areas as the PMO: Promo-Evaluation: Mfg 
worksheet, but from the retailer's point of view rather than the manufacturer's.

Event Projections and Event Actuals
These windows compare the projections and the actuals, one directly above the other. 
Notice that the actuals are displayed mostly in blue:

The Event Projections window displays planned event details, including event start, 
vehicle type, total planned volume, anticipated retailer profit and anticipated spend. 
For the series in this window, PTP uses colors to indicate deviations between the 
projections and the actuals:

• If the actual value is more than 20% different from the projection in the undesirable 
sense, the projection is shown in red.

• If the actual value is more than 20% different from the projection in the desirable 
sense, the projection is shown in green. For example, if the actual profit was 130% of
the projected profit, the projection is shown in green.

The Event Actuals window shows the corresponding actuals.
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Lift Decomposition Table - Actual (Retailer)
The lift decomposition table shows the specific breakdown into base, incremental, 
cannibalization, and pre- and post-effect dollars. This table also shows the net 
incremental volume for the event. This table applies to the retailer's point of view.

Here you can see these useful summaries:

• Total for promotion group where the promotion was run.

• Total effect on the brand.

• Total effect on each manufacturer.

Also notice that this table displays cannibalized and pre- and post-event volume, as 
well.

Lift Decomposition Graphs
The worksheet includes two graphs to show the projected lift decomposition and the 
actual lift decomposition. These are displayed vertically in the worksheet for space 
reasons. For convenience here, the documentation displays them side by side:
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Possible Actions
In this worksheet, depending on your authorization, you can do the following:

Right-click a promotion and open another worksheet filtered to that promotion. For 
example, you can open the PMO: Promo-Evaluation: Mfg worksheet to see past 
performance from the manufacturer's perspective. See "Evaluating Performance from 
the Manufacturer's Point of View."

Viewing Actual Averages
It is often useful to review actuals and see average information for different kinds of 
promotions. 

Note: Some of this data is highly aggregated, so some tabs may come 
up slowly.

To view average history
In My Worksheets (in Collaborator Workbench), click PMO: Promotion History.

The worksheet is displayed as follows:

Unlike other worksheets, this worksheet is designed as a series of tabs, each of which 
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displays the same averages, for different contexts. For example, on this tab, you select a 
retailer and category. The table shows averages for that retailer and category. Each row 
in the table corresponds to a type of promotion, so you see these averages broken out by
promotion type.

Each average is computed on a weekly basis. For example, Avg Ttl Evt Vol is the 
average total event volume for a single week.

Reference

PMO: Promo-Evaluation: Mfg
This worksheet compares projections to actuals for a past promotion, from the point of 
view of the manufacturer:

Basics

Accessing this worksheet Right-click a promotion and click Open With > PMO: 
Promo-Evaluation: Mfg.

Levels you can select Retailer, Category, Promotion

Levels used in cross tabulation Promotion

Time aggregation Yearly

Business Data

View Series Description

Event Projections Start Event P Projected date when promotion starts in 
stores

# Wks P Projected event length in whole weeks, 
assuming that each week starts on Monday.

Veh Type P Projected vehicle type or event type of the 
promotion

Cons Promo P Projected consumer overlay.
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View Series Description

Sale Price Sale price per unit at shelf

Ttl Evt Vol P Projected total volume for the promotion

Incr Evt Vol P Projected incremental volume due to the 
promotion

Ttl Evt $ P Projected total sales during the promotion, for
the manufacturer

Incr Evt $ P Projected incremental sales to the 
manufacturer due to the event

Evt Spend exS P Projected total planned buydown and vehicle 
costs for promotion

CPIU P Projected event cost per incremental unit sold 
as a result of the promotion.

% Spend P Projected event spending, as a percentage of 
event sales

Incr Mfg Prft P Projected incremental profit to the 
manufacturer due to the promotion

Net Incr Mfg Prft P Projected net incremental profit for the 
manufacturer

Incr Rtl Prft P Projected incremental profit to the retailer due
to the promotion

Event Projections Net Incr Rtl Prft P Projected net incremental profit for the 
retailer

Event Actuals Start Event Date when promotion starts in stores

# Wks Event length in whole weeks, assuming that 
each week starts on Monday.

Veh Type Vehicle type or event type of the promotion
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View Series Description

Cons Promo Consumer overlay, the deal type as seen by 
the consumer.

Avg Rtl Average unit retail price at shelf

Ttl Evt Vol Total volume for the promotion

Incr Evt Vol Incremental volume due to the promotion

Ttl Evt $ Total sales during the promotion, for the 
manufacturer

Incr Evt $ Incremental sales to the manufacturer due to 
the event

Evt Spend exS Total planned buydown and vehicle costs for 
promotion

CPIU Event cost per incremental unit sold as a 
result of the promotion.

% Spend Event spending, as a percentage of event sales

Incr Mfg Prft Incremental profit to the manufacturer due to 
the promotion

Net Incr Mfg Prft Net incremental profit for the manufacturer, 
after considering cannibalization and pre- and
post-effects

Incr Rtl Prft Incremental profit to the retailer due to the 
promotion

Net Incr Rtl Prft Net incremental profit for the retailer, after 
considering cannibalization and pre- and 
post-effects

Lift Decomposition - 
Projected

Base Evt $ P Projected base sales for the manufacturer, 
during the promotion

Net Incr Evt $ P Projected net revenue to the manufacturer



12-12    Oracle Demantra Predictive Trade Planning User's Guide

View Series Description

Canbl $ P Projected cannibalization dollars for the 
manufacturer

Pre-Post $ P Projected total sales made before and after the
promotion, as a result of the promotion 
(manufacturer's perspective)

Lift Decomposition - 
Actual

Base Evt $ Base sales for the manufacturer, during the 
promotion

Net Incr Evt $ Net revenue to the manufacturer, after 
considering cannibalization and pre- and 
post-effects

Canbl $ Cannibalization dollars for the manufacturer

Pre-Post $ Total sales made before and after the 
promotion, as a result of the promotion 
(manufacturer's perspective)

Net Incremental $ Net Incr Evt $ P Projected net revenue to the manufacturer

Net Incr Evt $ Net revenue to the manufacturer, after 
considering cannibalization and pre- and 
post-effects

Net Incr Mfg Profit Net Incr Mfg Prft P Projected net incremental profit for the 
manufacturer

Net Incr Mfg Prft Net incremental profit for the manufacturer, 
after considering cannibalization and pre- and
post-effects

Net Incr Rtl Profit Net Incr Rtl Prft P Projected net incremental profit for the 
retailer

Net Incr Rtl Prft Net incremental profit for the retailer, after 
considering cannibalization and pre- and 
post-effects

LIft Decompostion 
Table - Actual 

Ttl Evt $ Rtl Total sales during the promotion, for the 
retailer
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View Series Description

(Retailer) Base Evt $ Rtl Base sales for the retailer, during the 
promotion

Incr Evt $ Rtl Incremental sales to the retailer due to the 
event

Net Incr Evt $ Rtl Net revenue to the retailer, after considering 
cannibalization and pre- and post-effects

Canbl $ Rtl Cannibalization dollars for the retailer

Pre-Post $ Rtl Total sales made before and after the 
promotion, as a result of the promotion 
(retailer's perspective)

Lift Decomposition 
Table - Actual (Mfg)

Ttl Evt $ Total sales during the promotion, for the 
manufacturer

Incr Evt $ Incremental sales to the manufacturer due to 
the event

Base Evt $ Base sales for the manufacturer, during the 
promotion

Net Incr Evt $ Net revenue to the manufacturer, after 
considering cannibalization and pre- and 
post-effects

Canbl $ Cannibalization dollars for the manufacturer

Pre-Post $ Total sales made before and after the 
promotion, as a result of the promotion 
(manufacturer's perspective)

Canbl Vol Mfg

Pre-Post Vol Total volume before and after the promotion, 
as a result of the promotion

PMO: Promo-Evaluation: Rtl
This worksheet compares projections to actuals for a past promotion, from the point of 
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view of the retailer:

Basics

Accessing this worksheet Right-click a promotion and click Open With > PMO: 
Promo-Evaluation: Rtl.

Levels you can select Retailer, Category, Promotion

Levels used in cross tabulation Promotion

Time aggregation Yearly

Business Data

View Series Description

Event Projections Start Event P Projected date when promotion starts in 
stores

# Wks P Projected event length in whole weeks, 
assuming that each week starts on 
Monday.

Veh Type P Projected vehicle type or event type of the 
promotion

Cons Promo P Projected consumer overlay.

Sale Price Sale price per unit at shelf

Ttl Evt Vol P Projected total volume for the promotion

Incr Evt Vol P Projected incremental volume due to the 
promotion

Ttl Evt $ Rtl P Projected total sales during the promotion, 
for the retailer

Incr Evt $ Rtl P Projected incremental sales to the retailer 
due to the event



PMO: Reviewing Past Performance    12-15

View Series Description

Evt Spend exS P Projected total planned buydown and 
vehicle costs for promotion

CPIU P Projected event cost per incremental unit 
sold as a result of the promotion.

% Spend P Projected event spending, as a percentage 
of event sales

Rtl Profit P Projected retailer's profit from the event

Incr Rtl Prft P Projected incremental profit to the retailer 
due to the promotion

Net Incr Rtl Prft P Projected net incremental profit for the 
retailer

Event Actuals Start Event Date when promotion starts in stores

# Wks Event length in whole weeks, assuming 
that each week starts on Monday.

Veh Type Vehicle type or event type of the 
promotion

Cons Promo Consumer overlay, the deal type as seen by
the consumer.

Avg Rtl Average unit retail price at shelf

Ttl Evt Vol Total volume for the promotion

Incr Evt Vol Incremental volume due to the promotion

Ttl Evt $ Rtl Total sales during the promotion, for the 
retailer

Incr Evt $ Rtl Incremental sales to the retailer due to the 
event
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View Series Description

Evt Spend exS Total planned buydown and vehicle costs 
for promotion

CPIU Event cost per incremental unit sold as a 
result of the promotion.

% Spend Event spending, as a percentage of event 
sales

Rtl Prft Retailer's profit from the event

Incr Rtl Prft Incremental profit to the retailer due to the 
promotion

Net Incr Rtl Prft Net incremental profit for the retailer, after
considering cannibalization and pre- and 
post-effects

Lift Decomposition 
Table - Actual (Retailer)

Ttl Evt $ Rtl Total sales during the promotion, for the 
retailer

Incr Evt $ Rtl Incremental sales to the retailer due to the 
event

Base Evt $ Rtl Base sales for the retailer, during the 
promotion

Net Incr Evt $ Rtl Net revenue to the retailer, after 
considering cannibalization and pre- and 
post-effects

Net Incr Rtl Prft Net incremental profit for the retailer, after
considering cannibalization and pre- and 
post-effects

Canbl $ Rtl Cannibalization dollars for the retailer

Pre-Post $ Rtl Total sales made before and after the 
promotion, as a result of the promotion 
(retailer's perspective)

Canbl Vol Rtl
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View Series Description

Pre-Post Vol Total volume before and after the 
promotion, as a result of the promotion

Lift Decomposition - 
Projected

Base Evt $ Rtl P Projected base sales for the retailer, during 
the promotion

Net Incr Evt $ Rtl P Projected net revenue to the retailer

Canbl $ Rtl P Projected cannibalization dollars for the 
retailer

Pre-Post $ Rtl P Projected total sales made before and after 
the promotion, as a result of the promotion
(retailer's perspective)

Lift Decomposition - 
Actual

Base Evt $ Rtl Base sales for the retailer, during the 
promotion

Net Incr Evt $ Rtl Net revenue to the retailer, after 
considering cannibalization and pre- and 
post-effects

Canbl $ Rtl Cannibalization dollars for the retailer

Pre-Post $ Rtl Total sales made before and after the 
promotion, as a result of the promotion 
(retailer's perspective)

PMO: Promotion History
This worksheet displays the past averages for each promotion type, in a number of 
different contexts.

Basics

Accessing this worksheet In My Worksheets (in Collaborator Workbench), click 
PMO: Promotion History.

If a worksheet is currently open, click File > Open. Click 
PMO: Promotion History and then click Open.
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Levels you can select Different for each tab of this worksheet.

Levels used in cross tabulation Promotion Type

Time aggregation Yearly

Business Data
Each view in this worksheet contains the same set of series:

Series Description

Avg Rtl Average unit retail price at shelf 

Avg % Disc Average percent discount 

Avg B Dwn Average buydown for the event 

Avg Ttl Evt Vol Average weekly total event volume 

Avg Incr Evt Vol Average weekly incremental event volume 

Avg Lift Average lift factor for promotion 

Avg Ttl Evt $ Average weekly total event dollars for manufacturer 

Avg Incr Evt $ Average weekly incremental event dollars for manufacturer 

Avg Mfg Prft Average weekly manufacturer profit 

Avg Incr Mfg Prft Average weekly incremental manufacturer profit 

Avg Rtl Prft Average weekly retailer profit 

Avg Inc Rtl Prft Average weekly incremental retailer profit 

Avg Rtl Margin Average retailer event margin 

Avg Evt Spend Average weekly event spend 

Avg CPIU Average cost per incremental unit 
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Series Description

Avg % Spend Average percent spend
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13
Creating Worksheets and Content Panes

This chapter covers the following topics:

• Introduction

• Working with Lists

• Creating or Editing a Worksheet or Content Pane

• Configuring the Basics

• Selecting Series on a Worksheet

• Managing the Series Lists

• Specifying the Time Resolution and Time Span

• Specifying Aggregation Levels

• Using the Advanced Selection Options

• Changing the Overall Scale or Unit of Measure

• Filtering the Worksheet or Content Pane

• Managing the List of Members

• Applying Exception Filters

• Defining the View Layout

• Adding and Managing Worksheet Views

• Specifying the Worksheet Elements in a View

• Displaying an Embedded Worksheet

• Filtering a Worksheet View

• Sharing Worksheet and Content Panes

• Deleting Worksheet or Content Panes

• General Tips on Worksheet Design
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Introduction
This chapter describes how to create and redefine worksheets and content panes.

To create or redefine worksheets and content panes, you use the worksheet editor, 
which is divided into multiple screens. This section provides a quick overview:

Area Purpose For details, see

Display Specify basic information. "Configuring the Basics"

Series Select series to include. "Selecting Series on a 
Worksheet" 

Time Specify time resolution of 
worksheet or content pane 
and span of time to consider.

"Specifying the Time 
Resolution and Time Span" 

Aggregation Levels Optionally specify 
aggregation levels to include.

"Specifying Aggregation 
Levels" 

Filters Optionally filter the selected 
combinations.

"Filtering the Worksheet or 
Content Pane" 

Exceptions Optionally apply exception 
filters to further filter the 
combinations.

"Applying Exception Filters" 

Layout Designer Applicable only to 
worksheets. Define the layout 
of the worksheet and its 
views, including the layout of 
the worksheet tables, the 
location of each included 
series, and the graph format.

"Defining the View Layout" 

Within the editor, you have the following options:

• To move to another page, either click a button on the left side of the page or click 
Previous or Next.

• To exit the worksheet editor and keep your changes, click OK. 

• To exit the worksheet editor and discard all changes, click Cancel.
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Working with Lists
As you create or edit worksheets and content panes, you will often use pages that 
present two lists of elements, where you specify your selections. To do so, you move 
elements from the left list to the right list. The left list always presents the available 
elements (such as the available series) and the right list always shows your selections.

You can move elements from one list to the other in many equivalent ways, 
summarized here:

• To move all elements from one list to the other, click one of the double arrow 
buttons, as appropriate.

• To move a single element from one list to the other, click the element and then click 
one of the single arrow buttons, as appropriate. Or double-click the element.

• To move several adjacent elements, click the first element, press Shift and click the 
last element. Then click one of the single arrow buttons, as appropriate.

• To move several elements that are not adjacent, press Ctrl and click each element 
you want. Then click one of the single arrow buttons, as appropriate.

Creating or Editing a Worksheet or Content Pane

To create a new worksheet or content pane
Click File > New. Or click the New button.

To edit an existing worksheet or content pane
1. Click File > Open. Or click the Open button.

2. Click a worksheet or content pane and click Open. 

3. Click the Worksheet menu and select one of the menu items. Or click one of the 
worksheet buttons on the tool bar.

4. Save your changes to the worksheet definition: To save the new definition, click the 
Save button. Or click File > Save 

Note: In contrast, the Data > Update option saves the data and 
notes in the worksheet, not the worksheet definition.

To save the worksheet with a new name, click the Save As button.
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Configuring the Basics

To configure basic information for a worksheet or content pane:
1. Click Worksheet > Display. Or click the Display button.

The system displays a page where you specify the following basic information

Name The title to use in the My Worksheets module and in the window title.

Description Provides optional information to display in My Worksheets. This is 
especially useful in public worksheets for explaining the purpose of the
worksheet to other users.

Access Select Private or Public. Private is for your use only. Public worksheets 
and content panes are available to all users in the group.
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Enable Extra 
Filters

This option adds an extra, user-controlled filter to the worksheet. If you
select the Enable Extra Filters check box, that means that when you 
open the worksheet, you can prefilter the data before seeing the 
worksheet results; this is especially useful for users who use Demantra 
Anywhere.

Normally when you specify aggregation levels to include in the 
worksheet, as described in "Specifying Aggregation Levels", all 
members of those levels are available in the worksheet. 

If you select the Enable Extra Filters check box, that means that when 
you run the worksheet, Demantra first prompts you to select the 
members to display for each level.

This option has no effect on content panes.

Cache 
Worksheet Data

Specifies whether Demantra should cache the data for this worksheet, 
for each user who works with it. If you cache a worksheet, it will run 
more quickly in general, but the cache will need to be refreshed 
periodically. Choose one of the following refresh options:

• Manual—users will have to manually refresh the cache. See "To 
refresh your local worksheet cache".

• Automatic—Demantra will automatically refresh the cache, as 
specified by your implementors.

In either case, Demantra automatically detects when a cache is out of 
date and behaves appropriately. Demantra also automatically refreshes
the cache when you make certain structural changes to the worksheet.

Open With 
Context

Specifies how this worksheet should be filtered when a user opens it 
via the Open or Open With menu options (on the right-click menu).

Choose one of the following options:

• Selected Member (this will filter the worksheet to the object from 
which it was launched, aggregating across all combinations 
associated with that object)

• Selected Combination (this will filter the worksheet to the 
combination from which it was launched)

2. To display the content of this worksheet as a content pane in Collaborator 
Workbench, check Content and then complete the following fields:
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Display Format Specifies the display format to use. Not all display formats may 
be possible, depending on the number of levels and series you 
include.

Currently, Collaborator Workbench chooses the color to use for 
each series, when displaying series in the graph-type content 
panes.

Location Select Wide Pane or Narrow Pane to determine where the content
pane will be displayed in Collaborator Workbench.

Top/Bottom Filter (Only for bar chart content panes.) Specifies how to filter the 
members or combinations for display in the bar chart (to save 
space, not all members are shown). 

• Use the dropdown menu to specify whether the filter should 
apply to the top-ranked or to bottom-ranked members.

• In the input field, specify the number of members to be 
included.

• For Criteria Series, select the series that Demantra should use
to rank the members. (This does not control the order in 
which they are displayed in the chart.)

Note: If multiple items have identical values, all of them are 
displayed, and they collectively count as 1 towards the total. For 
example, suppose top values were 200, 150, 150, 100, and 50. If 
you specified Top/Bottom filter as three, you would see a total of 
four items: both the 150 items, in addition to the 200 and 100 
items.

This option does not affect the worksheet.

3. For worksheets only, to specify how the table should appear, see "Defining the 
View Layout".

Selecting Series on a Worksheet
Every worksheet or content pane must include at least one series.

Note: If you use a settlement level in a worksheet or content pane, all 
series in the worksheet or content pane must refer to tables used by the 
settlement hierarchy.
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To specify the series on a worksheet or content pane:
1. Click Worksheet > Series. Or click the Series button.

The system displays the Available Series and Selected Series lists. Each list is a 
collapsible list of series groups and the series in them.

2. Move all series that you want into the Selected Series list. To do so, either 
double-click each series or drag and drop it. You can also move an entire series 
group from one list to the other in the same way.

3. Remove any series from the Selected Series list that you do not want to include.

Note: You cannot remove a series if it is used as the Criteria Series 
for bar chart content.

To change the order in which the series are displayed, see "Defining the View 
Layout".

See "Series (Measures)"

Managing the Series Lists
You may have a very large number of series, and it can be useful to sort and filter these 
lists so that you can readily find what you need. The system also provides a search 
mechanism.
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Note: This section applies only to the series page of the worksheet 
editor (Worksheet > Series).

To sort a list of series:
1. Click the Sort button.

The Sort dialog box is displayed. 

2. Drag the list name from the Available Columns to the Sort Columns. Or 
double-click the list name in the Available Columns list.

3. Click OK.

To filter a list of series:
1. Click the Filter button.

The Filter page appears.

2. Click Add.

3. Click the arrow to the right of the operator box and select an operator from the 
dropdown list.

4. In the number box, enter the value by which to filter the list.

5. (Optional) You can filter further by using the AND relationship.

6. Click OK.

To find a series:
1. Click the Find button. 

The Find dialog box appears.

2. In the Find where box, select the name of the list to search.

3. In the Find what box, type name of the series.

4. Select Up, Down or All to determine the direction of the search.

5. (Optional) Select one or more of the check boxes:

• Whole Word: Search for the exact match of a word.

• Match Case: Search for the exact match of a word (case sensitive).
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6. Click Find Next to begin (or continue) searching.

Specifying the Time Resolution and Time Span
Each worksheet or content pane selects data for a specified span of time and optionally 
aggregates it in time. You use the Time dialog box to specify the time resolution and 
span of time of the results.

To specify time criteria:
1. Click Worksheet > Time. Or click the Time button.

2. In the Time Scale box, specify the time resolution. The data in the worksheet or 
content pane is aggregated to this time resolution. That is, this option specifies the 
period of time that each data point in the line graph represents.

3. In the Time Filter box, specify the time period to which the worksheet or content 
pane applies:

• Fixed if you always want to show a specific time range, regardless of the 
current date.

• Relative to Today if you always want to show a time range relative to today.

• Relative to Last Sales Date if you always want to show a time range relative to 
the last sales date in the loaded data.

4. In the From Date and To Date boxes, enter values depending on the time filter you 
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have chosen, as follows:

Time Filter Box Action

Relative From Date / To Date Specify periods in both 
From and To with the 
current (computer) date as 
the reference point. 

For example: If the Time 
Scale is Month, and you 
want to see results starting 
from six months before 
today, enter -6 in From Date.

Fixed From Date Enter a specific date as a 
starting point of the results. 
To enter a date, click the 
calendar button and select a 
date.

To Date Specify the number of 
periods you want to include,
starting from the From date. 

5. To control how dates are displayed, click the Advanced button, which brings up the
following dialog box:

6. In the Format dropdown list, select a display format.

For example, to add one month to each displayed date, specify 1 for Month Offset.
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The Preview field shows what the first time bucket would look like with this format
and offset.

7. To offset the displayed dates, optionally specify values for Month Offset or Year 
Offset.

8. Click OK.

Note: If you change the time scale, the worksheet or content pane 
might not show exactly the same aggregate numbers, because the 
cutoff dates would not necessarily be the same. For example, 
suppose your worksheet is weekly and displays 48 weeks of data. 
Then supposed you change the worksheet to display quarterly 
data. A quarter is 13 weeks, and the original span (48 weeks) is not 
an integer multiple of 13. So the worksheet selects a different 
amount of data and shows different overall results. 

Specifying Aggregation Levels
A worksheet or content pane usually includes aggregation levels. When you use the 
worksheet or content pane, you can examine data for the item-location combinations 
associated with those levels.

• If you do not specify any aggregation levels, the data is completely 
aggregated across all items and locations.

• If you use a settlement level, you cannot use levels from any other 
hierarchy.

To specify the aggregation levels in a worksheet or content pane:
1. Click Worksheet > Aggregation Levels. Or click the Levels button.

The system displays the Available Levels and Selected Levels lists.

2. Move all aggregation levels that you want into the Selected Levels list, using any of 
the techniques in "Working with Lists".

3. Remove any unwanted levels from the Selected Levels list.
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For a worksheet, the selected levels will now be used on all views of this worksheet,
unless you configure the views otherwise; see "To specify which levels to use in a 
worksheet view."

The layout of the worksheet view controls the order in which the levels are used; 
see "Defining the View Layout."

See also

"Using the Advanced Selection Options"

"Levels (Segmentation)"

"Changing the Overall Scale or Unit of Measure"

Using the Advanced Selection Options
By default, if a worksheet or content pane includes a promotion level, the worksheet or 
content pane includes all the following types of combinations:

• Combinations that have both sales data and promotions

• Combinations that have sales data, but no promotions

• Combinations that have promotions, but no sales data

The worksheet or content pane displays placeholders for combinations that do not have 
promotions. For example:
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For a worksheet, if you move the promotion level to the worksheet axis (see "Defining 
the View Layout"), the table will display a similar placeholder.

You can exclude some of these combinations. For example, you might want a worksheet
to include only the combinations that have both sales and promotions, as follows:

To exclude combinations with partial data:
1. Click Worksheet > Aggregation Levels. Or click the Levels button.

2. Include at least two levels, one of which should be a promotional level.

When you do so, the screen displays an Advanced button in the lower right.

3. Click Advanced. 

Oracle displays a dialog box with additional options.
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Include combinations that exist only in 
Promotion

This option selects combinations that have 
associated promotions, even if they do not 
have sales data.

Include combinations that exist only in 
SALES_DATA

This option selects combinations that have 
sales data, even if they do not have any 
associated promotions.

4. To exclude the combinations you do not want to see, click the check boxes as 
needed.

See also

"Specifying Aggregation Levels"

Changing the Overall Scale or Unit of Measure
In addition to levels, series, and filtering, a worksheet or content pane has the following 
characteristics:

• A single unit of measure. Typically, most series refer to this unit of measure, but 
there are exceptions such as percentage values. You can switch the unit of measure, 
and the displayed values are changed accordingly. The units in your system 
depend upon your implementation but probably include unit count and dollars.

For monetary units, you can also switch to a different index (such as the Consumer 
Price Index or CPI) or exchange rate, and the worksheet or content pane 
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automatically multiplies all values accordingly.

• An overall scale. The default value is 1. If the displayed values are all large, it can be
useful to re-scale the numbers, for example, to display in amounts of 1000 or 
1000000.

You can change either or both of these. When you make this change, the displayed 
values for most or all of the series in the worksheet or content pane are changed.

Note: This change affects only the series that are scaled. Not all series 
are scaled. For example, a series defined as a percentage is probably not
scaled.

To change the overall scaling factor:
1. Click Worksheet > Aggregation Levels. Or click the Levels button.

The Levels page includes a section where you specify the overall scale of the 
worksheet or content pane, as well as its units of measure.

2. In the Scale Units by box, specify the factor by which all numbers are to be divided 
(for display purposes).

For example, if you specify a factor of 1000, the displayed data will divided by 1000.
So the number 96,000 will be displayed as 96. The vertical axis of the graph is 
updated to show the factor in parentheses. For example, if the vertical axis was 
formerly labeled "units", it will be updated to say "units (1000)" instead.

To change the unit of measure :
1. Click Worksheet > Aggregation Levels. Or click the Levels button on the toolbar.

2. In the Unit Type box, select the unit of measure to display in the worksheet or 
content pane results. 

For example, our items are bottles, and suppose that a case that contains six bottles. 
If you display the worksheet or content pane with cases instead, the system will 
display the number of bottles divided by six.
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3. If the Index box is displayed, choose an index from the dropdown list.

The Index menu lists all the time-dependent indexes and exchange rates that are 
associated with this unit. Each index or exchange rate is a time-varying factor that 
the worksheet or content pane can use. When you select an index, the worksheet or 
content pane will automatically multiply all monetary series by the factor for each 
date. For example, if you choose Consumer Price Index (CPI) as the index, the 
system will calculate all monetary quantities with relation to the CPI.

Note: These indexes and exchange rates are generally imported 
from other systems. The set available to you depends upon your 
implementation.

See also

"Specifying Aggregation Levels"

Filtering the Worksheet or Content Pane
Filters control the combinations that you are able to see. Filtering can have multiple 
sources:

• A given worksheet or content pane may be filtered. For example, worksheet X 
might show only Brand X, which means that the worksheet would show only 
combinations related to Brand X.

• Your user ID may be filtered. For example, if you are an account manager, your 
user ID might give you access only to your accounts. At any level, you would not be
able to see combinations associated with other accounts.

• The data that you share with other users (called the component) might also be 
filtered. Components divide the data for different sets of users.

Demantra automatically combines all the filters. In the preceding example, if the 
component is not filtered, if you use worksheet X, you can see only data for Brand X at 
your accounts.

In contrast to an exception filter ("Applying Exception Filters"), this type of filter is static
and behaves the same no matter how the data changes.
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To apply a filter to a worksheet or content pane:
1. Click Worksheet > Filters. Or click the Filters button.

The system displays the Available Filter Levels and Selected Filter Levels lists.

2. Find the aggregation level at which you want to filter data and move it from the 
Available Filter Levels list into the Selected Filter Levels list, using any of the 
techniques in "Working with Lists".

Note: This level does not have to be the same as any of the 
aggregation levels you display in the worksheet or content pane. In 
fact, typically you filter using a different level than you use to 
display.

3. In the Available Members list, find a member that you want to include and move it 
into the Selected Members list, using any of the techniques in "Working with Lists.".

At this stage, the worksheet or content pane includes only data for this member. 
(Before you applied a filter at this level, the worksheet or content pane could 
theoretically include any member of this level.)

4. Continue to move members from the Available Members list into the Selected 
Members list, until the latter list includes all the members you want.

To filter data further:
Once you have applied a filter as described previously, the worksheet or content pane 
contains only those combinations that are associated with the members you specified. 
You can further filter the data in exactly the same way. 

Also see "Applying Exception Filters."
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Managing the List of Members
Depending on how your system has been configured, it might contain a very large 
number of members. If so, you might want to sort or filter the list or search it. For 
information, see "Managing the Series Lists."

Applying Exception Filters
If you attach an exception filter, Demantra checks the values of the data and displays 
only the combinations that meet the exception criteria. In contrast to an explicit filter, 
Filtering the Worksheet or Content Pane, this type of filter is dynamic and can behave 
differently as the data changes.

Specifically, you define an exception condition that consists of a series, a comparison 
operator, and a value, for example:

When you open the worksheet, Demantra checks each combination in the worksheet. 
For each combination, if the condition is met for any time in the worksheet date range, 
Demantra displays that combination. For example, the worksheet shows combinations 
that have Sales Plan values greater than or equal to 150000, within the time range 
included in the worksheet.

If the condition is not met at any time for any of the worksheet combinations, Demantra
shows the worksheet as empty. That is, if all values in the Sales series are less than 
15000 for all combinations, the worksheet comes up empty.

Note: If the worksheet includes a promotion level or a promotion 
series, the behavior is slightly different. In this case, the Members 
Browser or dropdown list does initially show all combinations. When 
you click display a combination to display it, the worksheet then checks
for exceptions.

You can apply multiple exceptions to a worksheet. When you apply multiple 
exceptions, you can relate them to each other via logical AND or logical OR 
relationships. For example:
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To apply an exception filter:
1. Click Worksheet > Exceptions. Or click the Exceptions button.

The Exceptions Filter page appears.

2. Click Add.

3. In the first box in the new row, select a series from the dropdown list.

Note: Typically only some series are available for exceptions. If you
do not see a series you need, contact your Demantra administrator 
or your implementors.

4. In the second box, select an operator from the dropdown list.

5. In the third box, type or choose a value.

• For a numeric series, type a number.

• For a dropdown series, choose one of the allowed values of this series.

• For a string-type series, type any string. You can use the percent character (%) 
as a wildcard.

• For a date-type series, type a date or use the calendar control to choose a date.

6. (Optional) You can apply additional exceptions. Select the AND or the OR radio 
button to specify the relationship between the exceptions.

To delete an exception filter:
1. Click the exception and then click Delete.

See also

"Filtering the Worksheet or Content Pane"
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"Series (Measures)"

Defining the View Layout
This section applies only to worksheets, not to content panes.

To define the layout of a current view:
1. Click Worksheet > Layout Designer. Or click the Layout Designer button.

The system displays a page where you specify the layout. This page displays the 
following areas:

In addition, this screen displays the following icons:

• An icon for each aggregation level that you have included in the worksheet. By 
default, these levels are included in the Members Browser or selector lists.

• An icon that represents the time axis. By default, time is shown on the x-axis.

• An icon that represents the series data. Series are shown on the y-axis.

2. To change the worksheet layout, drag the level or time axis icons to the appropriate 
areas. You cannot move the series icon.

3. To specify the type of graph to use, select a graph type from the Graph Type 
dropdown list.

4. To specify how to display series in this view:
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1. Click the Sort button.

The Layout Designer displays a page that shows the order in which this view 
currently displays the series.

2. To hide a series in this view, click the None option in the dropdown list to the 
right of the series name.

3. Otherwise, to specify where to display the data for a series, select one of the 
following options: Table, Graph, Table and Graph.

4. To move a series up or down in this list, click the series name and drag it up or 
down.

5. When you are done, click Close.

5. Click Save.

6. Rerun the worksheet to see your changes. To do so, click Data > Rerun.

To specify a cross-tab layout:
1. Drag one or more level icons from the Page Item area to x-axis or y-axis areas.

To specify which levels to use in a worksheet view:
By default, all levels you include in a worksheet are used on all views of the worksheet. 
Within a multi-view worksheet, you often hide some of the levels in some views, so that
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each view is aggregated differently.

1. Right-click within the Page area of the Layout Designer.

The system displays a menu like the following:

2. Click Hide level and then click the name of the level to hide. 

When you hide a level, the worksheet automatically aggregates data across 
members of that level.

Note: Do not use this option to hide the time axis.

To revert to the default layout of a worksheet view:
1. Click Worksheet > Layout Designer. Or click the Layout Designer button.

2. Click the tab corresponding to the worksheet view you want to reset.

3. Click the Reset button.

In the default layout, all selected levels are visible and are on the X axis. Also, all 
series are displayed in the graph and table according to their default definitions.

See also

"Specifying the Worksheet Elements in a View"

"Displaying an Embedded Worksheet"

"Filtering a Worksheet View"

Adding and Managing Worksheet Views
This section applies only to worksheets, not to content panes.

A worksheet can include multiple views, each of which can have a different set of series
and a different layout.
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To add a worksheet view:
1. Within the Layout Designer, click the Add Worksheet View button.

2. In the popup dialog box, type the name of the new view.

3. Click OK.

To control synchronization between the views:
The views of a worksheet may or may not be synchronized with each other. If they are 
synchronized, when you edit in one view, that change automatically appears in the 
other views. Because this can affect performance, sometimes it is best to switch off this 
synchronization.

Within the Layout Designer, click one of the following buttons, whichever is currently 
displayed:

• Do not force synchronization between views

• Synchronize data between views

To rename a worksheet view:
1. Within the Layout Designer, click the Rename Worksheet View button.

2. In the popup dialog box, type the new name of the view.

3. Click OK.

To enable or disable a worksheet view:
1. Within the Layout Designer, click the Hide/Display button.

2. The Layout Designer displays a popup list of all the views associated with this 
worksheet. A check mark is displayed next to each view that can currently be 
displayed.

3. For the view interest, select the check box next to the name of the view.

4. Click elsewhere on the screen to close the list of views.
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To delete a worksheet view:
Within the Layout Designer, do one of the following:

• Click the tab that corresponds to the worksheet view. Then click the Delete 
Worksheet View button.

• Click the Delete All Worksheet View button. Then, at the prompt, click Yes.

See also

"Defining the View Layout" 

"Specifying the Worksheet Elements in a View"

"Displaying an Embedded Worksheet"

"Filtering a Worksheet View"

Specifying the Worksheet Elements in a View
This section applies only to worksheets, not to content panes.

For each worksheet view, you can specify which of the basic worksheet elements are 
included: the table, the graph, and so on. 

To specify the elements to include in a worksheet view:
1. Click Worksheet > Layout Designer. Or click the Layout Designer button.

2. Click the tab corresponding to the worksheet view you want to modify.

3. Click Advanced... in the lower right.

Demantra displays the following screen:
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4. For Combination Selector, click either Tree (to display a Members Browser) or 
Dropdowns (to display dropdown menus instead).

5. Select the check box next to each element you want to include in this view of the 
worksheet. 

6. Click OK.

Displaying an Embedded Worksheet
This section applies only to worksheets, not to content panes.

You can display embedded worksheets on subtabs within a view. An embedded 
worksheet can be at a higher aggregation level than the rest of the worksheet, and the 
worksheet itself remains editable in general. 

Note: The choice of worksheets you see depends on the level-worksheet
associations that are controlled within the Business Modeler.

To display an embedded worksheet as a subtab within a view:
1. Click Worksheet > Layout Designer. Or click the Layout Designer button.

2. Click the tab corresponding to the worksheet view to which you want to add the 
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sub tab.

3. Click Advanced... in the lower right.

• Demantra displays the Advanced screen.

4. Click the Add WS As Subtabs tab.

• Demantra displays a screen like the following:

Depending on the level that you select, the bottom part of the screen shows 
different worksheets that you can add as a subtab to this worksheet view.

5. For Selected Levels, select the level that is associated with the worksheet you want. 
In general, a worksheet is associated with the levels where it makes sense to use it; 
this is controlled by your system configuration. You can choose any of the levels 
that are used in this worksheet.

6. For Selected Worksheets, select the worksheets that you want to display as sub tabs 
within this worksheet view.

7. Click OK.

Filtering a Worksheet View
This section applies only to worksheets, not to content panes.
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For each worksheet view, you can filter the view to show a subset of the data in the 
worksheet.

To filter a worksheet view:
1. Click Worksheet > Layout Designer. Or click the Layout Designer button.

2. Click the tab corresponding to the worksheet view you want to filter.

3. Click Advanced... in the lower right.

• Demantra displays the Advanced screen.

4. Click the Filter By Level Members tab.

• Demantra displays a screen like the following:

5. For Selected Filter Levels, select the level by which you want to filter this worksheet
view. You can choose any of the levels that are used in this worksheet.

6. For Selected Members, select the level members whose data should be displayed in 
this worksheet view.

7. Click OK.



13-28    Oracle Demantra Predictive Trade Planning User's Guide

Sharing Worksheet and Content Panes
In general, any worksheet or content pane is one of the following:

• Private—available only to you

• Public—available to other users as well. (If you are using Collaborator Workbench, 
this means the worksheet or content pane is available to others users within the 
collaborative group.) 

In either case, the original creator owns it and only that person can change it.

When you do share worksheet and content panes, however, you should consider data 
security. Demantra automatically prevents any user from seeing data for which he or 
she does not have permissions. If you build a worksheet or content pane with data that 
other users do not have permissions to view, then those users will see an empty 
worksheet or content pane. Similarly, if a user has partial permissions for the data, then 
the worksheet or content pane will open with only those results that are permitted.

See also

"Configuring the Basics"

Deleting Worksheet or Content Panes
You can delete a worksheet or content pane if you are its owner.

To delete a worksheet or content pane:
1. Open the worksheet or content pane.

2. Click File > Delete. Or click the Delete button.

• Demantra prompts you to confirm the deletion.

3. Click Yes or No.

General Tips on Worksheet Design
This section applies mostly to worksheets, not to content panes.

• For performance reasons, don't select too much data to view, unless there is no 
other choice. 

• If you receive a message saying "out of memory," try the following techniques to 
reduce the amount of memory that your worksheet selects:
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• Remove series if possible

• Reduce the span of time

• Apply filters

• If you do need to select a large amount of data, use the levels to your advantage. 
Specifically, use the levels in the Members Browser or selector lists rather than 
moving them to a worksheet axis. If levels are in the Members Browser or selector 
lists, each combination in the worksheet is relatively smaller and will load more 
quickly.

• If you do not plan on working with the Activity Browser, you can switch off the 
Auto Sync option on the toolbar, and you can also hide the Activity Browser and 
Gantt chart.

• Remember that you can filter the worksheet by any level, including levels that are 
not shown in the worksheet. For example, you might want to see data at the region 
level, but exclude any data that does not apply to the Acme territory. To do this, 
you would filter the worksheet to include only the Acme member of the Territory 
level, but you would select data at the Region level.

• A multi-view worksheet is useful in following cases:

• If you need to edit data at one aggregation level and see easily how that affects 
higher aggregation levels.

• If you need to display a large number of series without having to scroll to see 
each one.





Administration    14-1

14
Administration

This chapter covers the following topics:

• Running the Analytical Engine

• Running Required Workflows

• Managing the PTP Users

Running the Analytical Engine
You should run the Analytical Engine in batch mode probably about once a week. This 
generates a forecast for all the data in the system.

1. Click Demantra > Demantra Spectrum release > Engine Administrator.

2. Click File > Run Engine.
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3. For Username and Password, enter the username and password of the database 
user that stores the Demantra data. (In the installer, this user is referred to as the 
Oracle Database User).

4. For Server, enter the Oracle SID of the database.

5. Click Connect.

6. For Run Mode, click Batch.

7. For Engine Profile, click Batch.

8. Click Run Engine.

After running the Analytical Engine, you should run the Run App Proc After Batch 
Engine workflow.

See also

"Required Workflows"

Running Required Workflows
PTP provides several workflows that perform necessary back-end tasks. An 
administrator will need to run these workflows periodically. To run workflows, you use
the Workflow Manager, a Web-based tool that can be accessed only by users with the 
System Manager permission level.

This section lists these workflows and describes how to run them.
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Required Workflows
You should run the following workflows periodically:

Workflow When to run

CopyRetailerDefaults Run this each time you edit a retailer to use the default 
profile and each time you edit the retailer defaults in the 
Business Modeler.

Run Drop Temps Run this daily.

Run App Proc After Batch Engine Run this after you run the Analytical Engine in batch 
mode.

Logging on to the Workflow Manager
1. Click Demantra > Demantra Spectrum release > Collaborator Workflow.

2. In the Log On dialog box, enter your user name and password.

The Workflow Manager comes up, displaying a list of workflow schemas.

Starting Workflow Instances

To start a workflow instance
Click Start next to the schema that you want to start.

Viewing Workflow Status
You can view all the status of all public workflow schemas and all private workflow 
schemas that you created. This means that you can see how many instances of those 
schemas are running, as well as the status of each instance.

To view overall status of the workflows
The Workflow Manager displays the overall status information for the workflows.
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Each row corresponds to a workflow schema. The Instances column indicates how 
many instances of this workflow schema are currently running, if any. The Status 
column uses the following color codes:

Green The workflow schema is live and you may execute it, creating a workflow 
instance.

Red The workflow schema is archived and cannot be executed. 

Yellow There is a data error or other fault within this schema.

To view the currently running instances of a schema
1. Click the Instances link in the row corresponding to that workflow.

The Workflow Manager lists all the instances of that schema that are currently 
running.

2. When you are done, click Back.

Scheduling Workflow Instances
If you are the owner of a workflow, you can schedule an instance to start at a specific 
time or times. If you are not the owner, you cannot schedule it, although you can start it
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manually, as described in "Starting Workflow Instances".

To schedule a workflow instance
1. If the workflow schema is not visible, use the dropdown menu and select the name 

of a schema group to which it belongs. Or select All.

2. Click Schedule in the row corresponding to that workflow.

The system displays the Schema Scheduler page, which lists all the times when 
Workflow Engine will start an instance of this schema.

3. Click Add.

The system displays the following page.
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4. In the Schedule Schema dropdown list, select the option that specifies how often to 
start an instance of this workflow:

• Daily

• Weekly

• Monthly

• Once

• At Startup (This option launches the workflow whenever the Web server is 
started.)

• Periodic (in this option, you can start a workflow at periodic intervals 
(measured in seconds, minutes, hours, days, weeks, months, or years. Note that 
you cannot choose the starting time.)

Depending on the choice you make here, the system displays additional scheduling 
options in the bottom part of the page.

5. In the rest of the page, finish specifying the schedule.
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6. Click OK.

To unschedule a workflow instance
1. On the Workflow Management page, click Schedule in the row corresponding to 

that workflow.

The system displays the Schema Scheduler page. This page displays one row for 
each scheduling entry for this workflow.

2. Click the row corresponding to the scheduling entry you want to remove.

3. Click Remove.

Stopping Workflow Instances
You can stop any workflow instance that you started. You cannot stop a workflow 
instance started by another user.

To stop a workflow instance
1. If the workflow schema is not visible, use the dropdown menu and select the name 

of a schema group to which it belongs. Or select All.

2. Click the number in the Instances column that corresponds to that workflow.

The system lists all the instances of that schema.

Note: Instances that show in red are instances of Fail-To-Execute 
Step steps. For more information, see the Oracle Demantra 
Foundation Implementation Guide.

3. Click Terminate next to the instance that you want to stop.

4. Click OK.

The instance is stopped and is removed from the list of instances.

Note: Terminate stops only the workflow instance itself. It does not 
cancel any work that the instance may have initiated (such as tasks 
that were sent or requests placed in the Simulation Engine or 
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Business Logic Engine queues). These items must be cancelled 
manually.

See also

Oracle Demantra Implementation Guide

Managing the PTP Users
To manage the PTP users, you use the Business Modeler, a desktop tool that can be 
accessed only by users with the System Manager permission level. (Other users can log 
into the Business Modeler, to change their own passwords, but no other options are 
available to them.)

Logging onto the Business Modeler
Before starting the Business Modeler, make sure that the database is running.

To start the Business Modeler
1. On the Start menu, click Programs.

2. Click Demantra > Demantra Spectrum release > Business Modeler.

A login window appears.

3. Enter your user name and password.

4. Click Login.

Copying a User
The easiest way to create new users is to copy existing users and edit the details as 
needed.

To copy a user
1. In the Business Modeler, click Security > Create/Modify User. 

The Create/Modify User dialog box appears.

2. Click the button of the user you want to copy, and then click Create Copy.

The User Details dialog box appears. Some of the information, such as user name, is
blank. Other details, such as the company name, are copied from the original user.

3. Specify the user name and password for the new user.
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4. Make other changes as needed.

5. Do one of the following:

• Click Next to continue editing information for the new user. Demantra initially 
uses all the same values as for the original user.

• Click Finish.

Creating or Modifying a User

To create or modify a user
1. In the Business Modeler, click Security > Create/Modify User. 

2. Next:

• To create a new user, click the New User button, and then click OK.

• To modify a user, click the button of that user then click OK. Or double-click 
the icon of the user whose details you want to modify.

The User Details dialog box appears.

3. Specify basic user details as follows:

1. Under Enter User Details, type the following information in the appropriate 
boxes (or select from the dropdown lists):

• The user name, password, permission level, and the language in which the 
system will be operated. 
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• The first and last name of the user, the company name, phone and fax 
number, and the email address. 

2. For Permission Level, use System Manager if this user needs access to the 
Business Modeler and the Workflow Manager. Otherwise, use Supervisor.

3. Click Next.

The User Modules dialog box appears. Here you specify which Demantra user 
interfaces this user can access.

4. Click the check box next to each module that the user needs to work with. Then 
click Next.

The New User - Select User Series dialog box appears. This dialog box allows you to
determine what data series will be active for the new user, from the entire set of 
series in this component. Each list is a collapsible list of series groups and the series 
in them.
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If a series is not active for a user, it is not available when the user creates 
worksheets and is not viewable in existing worksheets to which the user has access.

5. Specify the series that a user can see, as follows:

1. Move all series that you want into the Selected Series list. To do so, either 
double-click each series or drag and drop it.

2. Remove any unwanted series from the Selected Series list.

Note: You can also move an entire series group from one list to 
the other in the same way.

3. When you are done specifying series, click Next.

The New User - Select User Filters dialog box appears. This dialog box lets you 
filter the data that the user can see; specifically, you control which levels and 
which members of those levels the user can see.



14-12    Oracle Demantra Predictive Trade Planning User's Guide

6. Filter the data that the user can see, as follows:

1. Click a level in the left side of the dialog box and drag it to the box on the right. 
Or double-click a level in the left side.

2. Now specify which members of this level the user can see. To do so, click a 
member in the list, and then click the right arrow button. Or double-click the 
member you want to filter out.

The system moves the selected members to the box on the lower right side. 
Now the user can see only the selected members of this level. In the preceding 
example, the user can see only data that is associated with the Rainbow brand.

Note: The Selected Members list cannot include more than 200 
members.

3. Repeat the preceding steps for each filter you want to add. Each filter 
automatically limits the choices available in subsequent filters.

4. When you have appropriately filtered data for the user, click Next.

The New User - Select User Groups dialog box appears. This dialog box allows you 
to select the group or groups to which the new user will belong. Members of a 
group can see each other within Who's Online.

7. Specify the collaboration groups to which a user belongs, as follows:

1. Move all groups to which the user should belong into the Selected Groups list. 
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To do so, either double-click each group or drag and drop it.

Note: You can also select and move multiple groups with the 
standard Ctrl+click or Shift+click actions.

2. Remove any unwanted groups from the Selected Groups list.

3. Click Next.

8. Click Finish.

Deleting a User

To delete a user
1. In the Business Modeler, click Security > Create/Modify User.

2. Click the button of the user you want to delete, and then click Delete.

A question box appears, asking if you are sure you want to delete the selected user.

3. To delete the selected user, click Yes.

See also

Oracle Demantra Implementation Guide
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15
PTP Demo Script

This chapter covers the following topics:

• Overall Notes

• About World Brands

• User IDs and Passwords

• Configuring the PTP Demo for Demand Management

• PTP: Setting Quotas and Funds

• PMO: Creating, Simulating, and Optimizing a Promotion

• PMO: Committing a Promotion

• PMO: Examining Past Promotions

Overall Notes
This chapter provides basic background information on the demo and walks you 
through all the elements of Oracle's PTP application, using the demo data as the sample.

To use the demo, you must have already started the following:

• Oracle - Always needed.

• Tomcat - Always needed.

• Simulation Engine - Needed if you are running simulations. See "Running the 
Analytical Engine in Simulation Mode".

In case of problems, see the Troubleshooting chapter in the Oracle Demantra 
Implementation Guide.
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About World Brands
This section introduces the company shown in the demo.

World Brands operates world wide, manufacturing consumer packaged goods and 
providing them to retailers who run more than 2,300 food and drug stores in more than 
31 states coast to coast. The retailers (Albertsons, Safeway, Winn-Dixie, and others) 
operate food stores, drug stores, combination food and drug stores, and fuel centers. 

Competitors to World Brands include Mega Products and Global Corp. World Brands 
has purchased syndicated data for those customers, and this data is loaded into PTP 
and available for analysis.

Products
PTP provides a set of product and location hierarchies intended to suit a variety of 
organizations. Some of these levels are not used in PTP worksheets, but are available if 
needed for reporting. 

For this demo, we focus on the analgesics that World Brands manufactures. World 
Brands produces many items in the analgesic category, and these are organized into 
multiple hierarchies. The demo uses two of these hierarchies.

The Promotion Group Hierarchy
For analgesics, World Brands has about a dozen promotion groups, such as the 
following examples:

• Advo 100

• Advo 200

• Notrim 100

• Notrim 50

Promotions are usually created at this level, applying to entire sets of items.

The Category Hierarchy
The analgesic products constitute one category, the only category shown in the demo. 
The category is subdivided as follows:
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World Brands is often interested in viewing data at the brand level.

Locations
As noted earlier, World Brands sells its products to multiple retailers, and PTP 
correspondingly displays data at the retailer level. PTP also lets you view the specific 
ship-to locations for each retailer, if needed.

In addition to being interested in the retailers, World Brands has an independent 
hierarchy of its own. It is divided into divisions, which consist of sales areas, which 
consist of regions. In turn, regions consist of districts, which consist of territories. For its
own planning purposes, World Brands often likes to view data at the territory level.

PTP models the organization of Mega Products and Global Corp in the same way.

User IDs and Passwords
The demo provides the following user IDs:
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User ID Passwor
d

Data access* Purpose and notes**

ptp ptp all territories superuser

This user has the System Manager permission 
level and therefore can log into administrative 
tools such as the Business Modeler and 
Workflow Manager.

Mgr1 m1 territories T1 + TG +
TM

Manager of Sales1 user

Mgr2 m2 territories T2 + T3 + 
TG + TM

Manager of Sales2 and Sales 3 users

Sales1 s1 territories T1 + TG +
TM

Sales representative for territory T1

Sales2 s2 territories T2 + TG +
TM

Sales representative for territory T2

Sales3 s3 territories T3 + TG +
TM

Sales representative for territory T3

testmgr1 t territories T1 + TG +
TM

Same as Mgr1

testmgr2 t territories T2 + T3 + 
TG + TM

Same as Mgr2

test1 t territories T1 + TG +
TM

Same as Sales1

test2 t territories T2 + TG +
TM

Same as Sales2

test3 t territories T3 + TG +
TM

Same as Sales3

*Territories TG and TM are the territories of the competitor; all users can view this data.

**Apart from the ptp user, all users have the Supervisor permission level.
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Configuring the PTP Demo for Demand Management
This topic explains how to enable the analytics required for the PTP demo in the 
Demand Management application.

To change the Demand Management model to support the PTP engine:
1. From the Business Modeler, navigate Engine > Forecast Tree.

2. Click Next

The Forecast Tree Configuration window appears.

3. Delete all forecast levels. 

4. Click Save, and then click Next.

The Forecast Tree Definition window appears.
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5. Remove all levels from the right panes that are not defined either as the Lowest or 
the Highest levels.

6. Add levels Promotion Group, Brand and Category to Forecast Orders for Items, in 
that order.

7. Add levels Territory Retailer and Retailer to Forecast Order for Location, in that 
order.
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8. Click Next.

The Forecast Tree Configuration window appears.

9. Configure the forecast tree as shown in the following screen capture.

10. Click Save and click Next

The Forecast Tree - Promotion Levels window appears.
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11. Configure promotional levels as shown in the following screen capture. 

12. Click Save, and then click Exit.

13. Navigate to Parameters > System Parameters. 

The System Parameters window appears.

14. Choose the Engine Tab and the Shell sub-tab. 

15. Find Parameter RUNMODE and change the Value to pe from the Default Value dp.
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16. In Data Manipulation sub-tab change parameter CalcOptimizationInput to Yes.

17. In the Validation sub-tab change the parameter UseNonNegRegr from no to yes
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18. Save and Close

19. From the Business Modeler, navigate Engine > Model Library. Ensure that only 
Regression and Modified Ridge Regression (if enabled) are active, and all other 
models are unchecked. 
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20. Click Save, and then click Close.

21. Run the Analytical Batch Engine

PTP: Setting Quotas and Funds
We will start by acting as a sales manager and adjusting some quotas and funds for a 
territory.

1. In Windows, click Start and click Programs. Then click Demantra > Demantra 
Spectrum release > Collaborator Workbench.

2. In the Log On dialog box, enter the user name Mgr1 and the password m1.

3. Click Login.

Now the dashboard, Collaborator Workbench, is displayed:
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We will look at this screen more closely later. For now, we are interested only in the
Planning Hierarchy area:
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This displays all the territories that Mgr1 has access to view, namely Territory T1 of 
World Brands, as well as TG and TM, which represent the competitors of World 
Brands.

4. Right-click T1 and select Open With > PTP: Quota and Fund Entry: Top-Down.

This brings up the following screen:
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This worksheet has been filtered to display only the territory we started from, T1. 
(Notice that the dropdown list includes only this territory. If we had opened the 
worksheet from My Worksheets instead, then we would have a list of all this user's 
territories.)

The Entry Data area shows each retailer in this territory with the yearly quota and 
funds for that retailer. Typically this information is established at the start of a year. 
(We use this worksheet for top-down data entry; another worksheet is available to 
fine-tune details at lower levels.)

5. Make the following changes:

For Albertson's, change Sales Quota to 8,500,000.

In the MDF Base Rate column, select the three cells for the three displayed retailers, 
right-click and select Edit Cells. A small dialog box is displayed. Here, type the 
value 0.20 and click OK.

Notice that as soon as you change the MDF Base Rate, the values for MDF Auth and
Ttl Fund Auth change.

6. Click Data > Save Data. Or click the Save Data button.

7. Optionally log this user out. To do so, go to the Collaborator Workbench and click 
Log Out.
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PMO: Creating, Simulating, and Optimizing a Promotion
In this segment, we will act as the sales representative Sales1, who is responsible for the 
T1 territory.

1. In Windows, click Start and click Programs. Then click Demantra > Demantra 
Spectrum release > Collaborator Workbench.

2. In the Log On dialog box, enter the user name Sales1 and the password s1.

3. Click Login.

Now the Collaborator Workbench is displayed:
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Here, notice the following points:

• This is a personalized page for Sales1. This user can customize it if needed.

• My Worksheets lists worksheets that Sales1 uses often.

• The Planning Hierarchy displays all the territories that Sales1 has access to 
view, namely Territory T1 of World Brands, as well as TG and TM, which 
represent the competitors of World Brands.

• The data displayed here is filtered to display data only for this user's territory.

• The Actuals versus Plan window shows how the forecast is tracking, compared 
to the plan:
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As you can see, the forecasted volume is lower than the plan, so it is necessary to 
create some promotions to increase the volume.

We will focus on Albertson's for this activity.

4. In the Planning Hierarchy area, expand T1 to display Albertson's.

5. Then right-click Albertson's and select Open With > Planning Environment.
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This brings up the Planning Environment, which is the entry point for creating and 
analyzing promotional events.
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Because we opened this worksheet this way, it is filtered to display only data for 
Albertson's.

6. Notice the following points:

• Sales % vs. Quota displays the quota and sales projections for this retailer.

• Fund Balances displays the funds for the territory T1 (aggregated across all 
retailers). 

• Event Planner and the rest of the windows display data for the currently 
selected promotion group.

7. At the of the screen, select the Excedra 100 promotion group.

8. In the Event Planner area, right click in the Promotion column. Then click Create 
Promotion.

A window like the following is displayed:
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The name is initially blank. The Population area indicates where the promotion will 
run, which is by default the same as the currently selected promotion group and 
retailer. The Dates are initialized according to default configurable values.

9. For Name, type April End Special.

10. Click Start and change it to 4/24/2006.

11. Click End and change it to 4/30/2006.

12. Enter the following other details:

• Start Ship: 4/1/2006

• End Ship: 4/30/2006

• Scenarios: Sandbox

• Vehicle Type: Display

13. Click Create.

PTP creates this promotion immediately and reruns the worksheet. The Event 
Planner area displays the new promotion as follows:
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Notice the following points:

• April End Special has an initial vehicle cost. PTP initialized this based on the 
vehicle type and the retailer profile for Albertson's. 

• The shelf price is the normal shelf price for this promoted group.

• The sale price and the buydown are both initialized as 0.

• The Incr Evt Vol is zero, because we do not yet have a forecast for this new 
promotion.

• In Sales % vs. Quota, the sales projections for this retailer have not yet changed, 
for the same reason.

14. Enter the following details for April End Special:

• Sale price: 5.29

• Buydown: 0.10

15. Click Data > Save Data. Or click the Save Data button.

To go further, we need a forecast for this promotion, so we will run a simulation. 
We can do that any worksheet, but we will not see cannibalization effects if we run 
the simulation here, because the Analytical Engine doesn't have access to all the 
data it needs in this worksheet. For now, though, we are interested only in the 
incremental volume, so we will run the simulation here.

Before we can run a simulation that, we must make sure the Simulation Engine is 
running so that it can process our request.

16. In Windows, click Start and click Programs. Then click Demantra > Demantra 
Spectrum release > Simulation Engine.

17. Click Data > Run Simulation. Or click the Simulation button.

The Select Simulation Type page appears.
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18. Click Selected Combination.

19. For Select Engine Profile, click Simulation.

20. Click OK.

Depending on the amount of data in your worksheet, simulation may take a few 
minutes.

21. When the simulation is complete, Demantra displays a message. Click OK.

22. Rerun the worksheet.

Examine the Event Planner area:

Notice the following changes:

• The lift for April End Special is 2.54.

• The incremental event volume is 6,066 units.

On the other hand, notice that Sales % vs. Quota and Fund Balances have not been 
changed. That is because this promotion is still unplanned. We will change its 
status later and see how that impacts the projections and funds.

At this point, we could enter a different sale price, vehicle type, or other details and 
resimulate this promotion, to get a different lift. Rather than doing that repeatedly, 
however, we will run the optimizer. The best place to perform optimization is the 
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PMO: Optimization Comparison worksheet, which displays before and after 
details. So we will drill down to that worksheet.

Note: Leave the Planning Environment open, however, because we 
will return to it.

23. Right-click April End Special and select Open With > PMO: Optimization 
Comparison.

The system displays the following screen:

This worksheet is meant to display the promotion in its current state, side by side 
with the optimized version of the promotion. Notice that the optimized version is 
not present yet.

• The Optimized - Event Planner and Optimized - Cost Benefit Review windows 
are empty.

• Each of the graphs shows only one bar, the bar that corresponds to the 
promotion as it currently is.

24. Right-click the promotion and click Methods > Optimize.

25. The system displays the following screen, asking for details about how to optimize 
this promotion:
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26. For this example, choose the following details:

• Optimization Goal: Maximize Revenue (rather than maximizing units or profit)

• Buydown Generation Method: Fixed Buydown (this will preserve the buydown
that we entered previously, rather than calculating a different buydown for this
promotion)

27. Click Optimize.

Now the system will select the promotion parameters (sale price, vehicle type, and 
so on) that best meet this goal. 

Note: The optimizer considers only variations that are similar to 
promotions that ran in the past for this promotion group. So if this 
promotion group has never run a TPR-type promotion, the 
optimizer will not consider such a variation.

When optimization is complete, PTP displays a message asking if you want to rerun
the worksheet. 
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28. Click OK.

Notice that the optimized promotion is now displayed throughout the worksheet:

• The Optimized - Event Planner and Optimized - Cost Benefit Review windows 
show details for the optimized version.

• Each of the graphs shows two bars.

• Also notice that the Evt Status is displayed in yellow. This indicates that this 
promotion has been optimized but not yet accepted. (This color change, for Evt 
Status, applies in the Planning Environment and all other worksheets, which 
means that you can tell if optimization has been run, even if that worksheet 
does not have all the details seen here.)

The optimized version is different from the original in several ways. For example, 
the sale price and vehicle type are different. The lift for this promotion is much 
higher, as is the revenue.

29. Compare the cost benefit reviews of the original promotion and the optimized 
promotion:
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The incremental profit is higher, and the cost per incremental unit and the % spend 
are both lower.

The optimized version is suitable, so we will accept it.

30. Right-click the promotion and select Methods > Accept Optimization. 

PTP displays a message asking if you want to rerun the worksheet. 

31. Click OK.

Now the attributes of the optimized promotion are copied into the original 
promotion. Notice the following:

• The Event Planner and Optimized Event Planner windows both show the same 
values.

• The Cost Benefit Review and Optimized - Cost Benefit Review windows both 
show the same values.
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• In each graph, both bars are the same height.

• Also notice that the color of the Evt Status series changes to green, to indicate 
that optimization has been accepted.

32. For this example, we would prefer to reduce the price by an even dollar, so we 
change the sale price to 4.89 and save the change.

We now should resimulate the promotion, to see how the sale price affects the 
forecast.

33. Click Data > Run Simulation. Or click the Simulation button.

1. Click Selected Combination.

2. For Select Engine Profile, click Simulation.

3. Click OK.

4. When the simulation is complete, Demantra displays a message. We do not 
need to rerun this worksheet, because now we are interested in seeing the 
retailer's point of view, which we see in another worksheet.

34. Right-click the promotion and click Open With > PMO: Promo Effect - Rtl.

The system displays the following:
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Here we are looking at the same event from the point of view of the retailer. Notice 
the following:

First, the graph decomposes the net lift for the April End Special promotion.
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• Base Evt $ Rtl is the base money earned by the retailer over the course of the 
promotion. This money would have been earned even without the promotion.

• Net Incr Evt $ Rtl is the net additional money earned by the retailer as a result 
of the promotion; this accounts for both cannibalization and pre- and 
post-effects.

• Canbl $ Rtl is the money lost by the retailer due to cannibalistic effects of the 
promotion. For display purposes only, this is shown as a positive number so 
that it can be graphed.

• Pre-Post $ Rtl is the money lost by the retailer due to decreased sales before and
after the promotion. For display purposes only, this is shown as a positive 
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number so that it can be graphed.

• The total height of the bar graph indicates how much money the retailer would 
receive in sales, if cannibalization and pre- and post-effects were ignored.

Next, the Lift Decomposition Table - Retailer area show cannibalization effects, 
as the retailer sees them. The highlighted row shows where our promotion is 
running. Here you can see the effects on other promoted groups, and you can 
see the effects summarized by brand and manufacturer.

• In the Cost Benefit Review window, the red color for Net Incr Rtl Prft alerts us 
to the fact that this promotion currently does not make any money for the 
retailer. Net Incr Rtl Prft considers pre- and post-promotional effects and 
cannibalization, which together make this promotion unprofitable for the 
retailer.

Because this promotion is currently unprofitable for the retailer, we could increase 
the buydown to make it more attractive to the retailer.

35. Change Buydown to 0.60.

Notice that the Net Incr Rtl Prft is now positive:

36. Save the change.

Now we should re-examine the promotion from the manufacturer's point of view.

37. Right-click the promotion and click Open With > PMO: Promo Effect - Mfg.

The system displays the following:
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Notice the following:

• The Cost Benefit Review and Lift Decomposition Table - Manufacturer tables 
show numbers from the point of view of the manufacturer, rather than the 
retailer.

• Because consuming sales of the products of other manufacturers is good in this 
case, that effect is not consider cannibalization and is not shown in the 
manufacturer's breakouts.

• The graph shows a different breakdown than was displayed for the retailer. The
breakdown is different for two reasons. First, the manufacturer has a different 
definition of cannibalization, as just noted. Second, the cost basis is different for 
the manufacturer.

• The bottom of the screen shows a summary of the retailer information, for 
convenience. 

• We could have come directly to this screen, bypassing the PMO: Promo Effect - 
Rtl worksheet. The benefit of the PMO: Promo Effect - Rtl worksheet is that it 
displays only the retailer information, so it is suitable for displaying directly to 
the retailer.

Notice that for the manufacturer, the net incremental profit is still positive, even 
though the event spending has been increased.
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Before we add this promotion to the plan, we might decide to compare it side by 
side with another promotion.

38. Return to the Planning Environment worksheet and rerun this worksheet.

39. Right-click the Sandbox and click Open.

This launches the PMO: Promotion Comparison worksheet filtered to show the 
promotions of that scenario.

Here we have a side-by-side look at the two unplanned promotions in the Sandbox. 
The CPIU is similar in both of these, but April End Special makes more money.

At this point, we may have examined this promotion enough to want to add it to 
the plan. We would also need to specify how to fund it.

40. Return to thePlanning Environment worksheet.

41. In the Fund Allocation window, set MDF Alloc % equal to 85 for April End Special. 
This means that for 85% of the funding for this promotion will be taken from the 
total MDF fund. The remaining 15% will be taken from the BDF fund.

Notice that the Fund Balances window is not yet changed, because this promotion 
is still unplanned.

42. In the Event Planner area, change Evt Status to Planned.

43. Save the change.
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44. Click on another promotion. This causes the embedded worksheets to be refreshed.

Because the promotion is now planned, the cost of the promotion is subtracted from
the funds, as specified, and the promotional volume is added to the plans. The 
Fund Balances window shows the result:

The authorized funding was increased, because the volume was increased, and that 
partly counteracts the cost of the promotion:

• The Ttl Fund Auth increased from $2,931,050 to $2,936,750, an increase of $5700.

• The event itself costs $23,047.

• The fund balance should be decreased by $17347, which is $23,047 less $5700. If 
you compare Ttl Fund Bal before and after, you will see that this is the precise 
difference.

Also, the Sales % vs. Quota window shows the increase in revenue.

45. Optionally, to see the increase in volume, use the Volume Tracking worksheet. To 
do this, return to the Collaborator Workbench. In My Worksheets, click Volume 
Tracking.

46. Click Albertson's at the top of the screen.
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Notice the slight spike in volume at the time we planned for the April End Special 
promotion.

At this point, the Sales1 user might need to send this promotion to the manager for 
approval. To approve the promotion, the manager would simply change the Evt Status 
to Approved.

The next phase would be to meet with the retailer and negotiate an agreement on this 
promotion, before committing the promotion. See the next section.

PMO: Committing a Promotion
At some point, the sales representative would meet with the retailer, finalize the details 
of the promotion, and set the pay type for the promotion. The sales representative could
show the PMO: Promo Effect - Rtl, showing the cost benefit details to the retailer, make 
any last changes, and resimulate to update the forecast. 

When the sales representative receives a firm commitment to run this promotion, he or 
she commits the promotion.

1. In the Planning Environment worksheet, right-click the promotion and click Open 
With > PMO: Promo Effect - Rtl.

2. Change the Pay Type to Off Invoice.
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Note: This change does not affect the forecast. If we had made a 
change t hat affects the forecast, we would need to rerun simulation
to get the most current forecast for the promotion.

3. Change the Evt Status to Committed.

4. Save the changes.

Now PTP takes a snapshot of the planned details of this promotion, creating projections
that can be compared later with the actuals. 

PMO: Examining Past Promotions
To understand how PTP uses projections, we will examine a past promotion and see the
actuals along with those projections.

1. In the Planning Environment worksheet, click the Advo 100 promotion group.

2. Right-click the New Year Blowout promotion and click Open With > PMO: 
Promo-Evaluation: Mfg.

The following screen appears:
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Notice the color coding used here to indicate deviations between the projections 
and the actuals:

• If the actual value is more than 20% different from the projection in the 
undesirable sense, the projection is shown in red.

• If the actual value is more than 20% different from the projection in the 
desirable sense, the projection is shown in green. 

A similar worksheet (PMO: Promo-Evaluation: Rtl) is available if we want to 
examine the actuals from the point of view of the retailer.

It is often useful to review actuals and see average information for different kinds of
promotions. PTP provides a worksheet where you can examine the past averages 
for each promotion type.

3. Click File > Open.

4. Select PMO: Promotion History and then click Open.

The worksheet is displayed as follows:
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Unlike other worksheets, this worksheet is designed as a series of tabs, each of 
which displays the same averages, for different contexts. For example, on this tab, 
you select a retailer and category. The table shows averages for that retailer and 
category. Each row in the table corresponds to a type of promotion, so you see these
averages broken out by promotion type.

Each average is computed on a weekly basis. For example, Avg Ttl Evt Vol is the 
average total event volume for a single week.
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16
PTP Reference

This chapter covers the following topics:

• Series

• Item Levels

• Location Levels

• Retailer

• Promotion Levels

• Lookup Tables

• Methods

• Procedures

• Triggers

• Workflows

• Engine Configuration

Series
This chapter provides reference information for PTP series, levels, methods, and so on.

PTP provides the following series:

Series Table Purpose For details, see...

# Wks promotion Event length in weeks, assuming that 
each week starts on Monday. Always 
rounded up to a whole number of 
weeks.
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Series Table Purpose For details, see...

# Wks O promotion 
level

Event length in weeks, for optimized 
promotion.

"Optimizing a 
Promotion" 

# Wks P promotion 
level

Projected event length in weeks, as 
predicted when the promotion was 
committed.

This series is configured (via a client 
expression) to have three branches, as
follows:

• If the value of this series is not 
null, that means Demantra has 
captured projections for this 
promotion. So use that value.

• If the value is null and if the 
promotion is Committed, use the
value # Wks.

• If the value is null and if the 
promotion is not Committed, use
null.

"Event Projections 
and Event Actuals"

$ Sales sales_data Annual dollar sales.

$ Sales Proj sales_data Planned sales dollars: actuals (for 
past dates) plus forecast (for future 
dates)

% ACV ANY 
PROMO

sales_data Measures the number of stores that 
ran any promotion, weighted by store
size. Loaded from syndicated data.

% ACV DISP sales_data Measures the number of stores that 
ran displays, weighted by store size. 
Loaded from syndicated data.

% ACV FEAT sales_data Measures the number of stores that 
ran features, weighted by store size. 
Loaded from syndicated data.
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Series Table Purpose For details, see...

% ACV 
FEAT&DISPLA
Y

sales_data Measures the number of stores that 
ran combined features and displays, 
weighted by store size. Loaded from 
syndicated data.

% ACV 
FREQSHOPPE
R

sales_data Measures the number of stores that 
ran frequent shopper specials, 
weighted by store size. Loaded from 
syndicated data.

% ACV TPR sales_data Measures the number of stores that 
ran temporary price reductions, 
weighted by store size. Loaded from 
syndicated data.

% Attained sales_data Percentage of sales quota attained. "Sales % vs. Quota"

% Spend promotion Event spending (vehicle and 
buydown), as a percentage of event 
sales. This is a useful metric of the 
effectiveness of a promotion; the 
lower this number, the better.

"Cost Benefit 
Review" 

% Spend O promotion Event spending (vehicle and 
buydown), as a percentage of event 
sales, for the optimized promotion..

"Optimizing a 
Promotion"
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Series Table Purpose For details, see...

% Spend P promotion Projected event spending (vehicle 
and buy down), as a percentage of 
event sales, as predicted when the 
promotion was committed.

PTP uses colors to indicate deviations
between the projections and the 
actuals:

• If the actual value is more than 
20% different from the projection
in the undesirable sense, the 
projection is shown in red.

• If the actual value is more than 
20% different from the projection
in the desirable sense, the 
projection is shown in green. For 
example, if the actual profit was 
130% of the projected profit, the 
projection is shown in green.

This series is configured (via a client 
expression) to have three branches, in
the same way as # Wks P.

"Event Projections 
and Event Actuals"

ActualLY sales_data Actual demand one year ago.

Actuals Base sales_data Base number of units sold in the past,
if there had been no promotions. 
Loaded from syndicated data.

Actuals Incr sales_data Incremental number of units sold in 
the past, due to promotions. Loaded 
from syndicated data.

Actuals LY sales_data Actual demand one year ago.

Actuals Ttl sales_data Total number of units sold in the 
past. This includes both base and 
incremental volume. Loaded from 
syndicated data.

"About Quotas and 
Funds"

Avg % Disc promotion Average percent discount "Viewing Actual 
Averages"
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Series Table Purpose For details, see...

Avg % Spend promotion Average percent spend

Avg B Dwn promotion Average buy down for the event 

Avg CPIU promotion Average cost per incremental unit 

Avg Evt Spend promotion Average weekly event spend "Viewing Actual 
Averages"

Avg Inc Rtl Prft promotion Average weekly incremental retailer 
profit 

Avg Incr Evt $ promotion Average weekly incremental event 
dollars for manufacturer 

Avg Incr Evt 
Vol

promotion Average weekly incremental event 
volume 

Avg Incr Mfg 
Prft

promotion Average weekly incremental 
manufacturer profit 

Avg Lift promotion Average lift factor for promotion 

Avg Mfg Prft promotion Average weekly manufacturer profit 

Avg Rtl promotion Average unit retail price at shelf. 
Loaded from syndicated data.

Avg Rtl Margin promotion Average retailer event margin 

Avg Rtl Prft promotion Average weekly retailer profit 

Avg Rtl sd sales_data Average unit retail price at shelf. 
Loaded from syndicated data.

Avg Ttl Evt Vol sales_data Average weekly total event volume "Viewing Actual 
Averages"

Base Evt $ promotion Base sales for the manufacturer, 
during the promotion.

"Lift Decomposition
Table - 
Manufacturer"
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Series Table Purpose For details, see...

Base Evt $ O promotion Base sales for the manufacturer, 
during the optimized promotion.

"Optimizing a 
Promotion"

Base Evt $ P Projected base sales for the 
manufacturer, during the promotion.

Base Evt $ Rtl promotion Base sales for the retailer, during the 
promotion.

"Lift Decomposition
Table - Retailer"

Base Evt $ Rtl 
Act

promotion Base event dollars from a retailer's 
perspective, as determined by 
syndicated data.

Base Evt $ Rtl P promotion Projected base sales for the retailer, 
during the promotion.

Base Evt $ Rtl 
sd

sales_data Base event dollars earned by the 
retailer, as loaded from external 
systems. By default, this series 
displays loaded syndicated data.

Base Evt Vol promotion Baseline volume during the 
promotion.

Base Evt Vol O promotion Baseline volume during the 
optimized promotion.

"Optimizing a 
Promotion"

Base Fcst sales_data Base volume: actuals (for past dates) 
plus forecast (for future dates).

BDF Auth sales_data Authorized brand development 
funds, calculated as follows: (base 
rate + dev rate) * volume + fixed BDF 
funds

"About Quotas and 
Funds"

BDF Alloc promotion Allocated brand development funds, 
based on the percentage set by the 
planner

"Marking a 
Promotion as 
Planned"
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Series Table Purpose For details, see...

BDF Alloc % promotion Read-only series that indicates how 
much of event spending (apart from 
slotting costs) is to be allocated to 
BDF. 

Note that BDF Alloc % + MDF Alloc 
% = 100%

BDF Auth sales_data Authorized brand development fund,
calculated as follows:

(base rate + dev rate) * volume + fixed
funds

"About Quotas and 
Funds"

BDF Bal sales_data Remaining (unspent) BDF funds, 
computed as follows:

BDF Auth - BDF Alloc

BDF Base Rate sales_data Brand Development Fund Base rate --
displayed to the user in the field.

BDF Dev Rate sales_data Brand Development Fund 
Development rate, entered by 
corporate HQ.

BDF Fixed 
Funds

sales_data BDF fixed funds

Buydown promotion Buydown allowance or discount per 
promoted unit that will be paid to the
retailer. May be used for either 
off-invoice or bill back. 

"Promotion Costs 
and Spending"

Buydown $ promotion Buy down spend for the promotion, 
computed as the buy down 
allowance multiplied by the volume.

Buydown O promotion Buy down spend for the optimized 
promotion.

"Optimizing a 
Promotion"

Can Vol Dir
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Series Table Purpose For details, see...

Canbl $ promotion Cannibalization dollars for the 
manufacturer. This considers volume 
that has been cannibalized from other
products.

"Lift Decomposition
Table - 
Manufacturer"

Canbl $ P promotion Projected cannibalization dollars for 
the manufacturer.

Canbl $ Rtl promotion Cannibalization dollars for the 
retailer. This considers volume that 
has been cannibalized from other 
products and from other stores of this
retailer.

"Lift Decomposition
Table - Retailer"

Canbl $ Rtl P promotion Projected cannibalization dollars for 
the retailer.

Canbl Vol Mfg promotion Cannibalization volume for the 
manufacturer,

Canbl Vol 
Other

promotion Cannibalization of sales at other 
stores, as a result of the promotion. 
This is a negative number that 
indicates how many fewer units were
sold. To the retailer, this is an 
undesirable effect. To the 
manufacturer, this effect is neutral, 
because the manufacturer cares only 
about net volume.

(In Promotion Effectiveness 
terminology, this is the so-called "
store switching" effect.)

Canbl Vol Own promotion Cannibalization of sales of other 
products by the same manufacturer, 
as a result of the promotion. This is a 
negative number that indicates how 
many fewer units were sold. 

(In Promotion Effectiveness 
terminology, this is the so-called "
product switching" effect.)
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Series Table Purpose For details, see...

Canbl Vol Rtl promotion Cannibalization volume for the 
retailer. 

This is the sum of Canbl Vol Other 
and Canbl Vol Own, both of which 
are undesirable to the retailer.

COGS promotion Cost of goods, as paid by the 
manufacturer.

COGS sd sales_data Cost of goods, as paid by the 
manufacturer.

Cons Promo promotion 
level

Consumer overlay, the deal type as 
seen by the consumer. For example, 
buy-1-get-1-free. Controls the 
number of units in the deal and 
affects the volume.

Uses the Cons_type lookup table; see 
"Lookup Tables".

Cons Promo P promotion 
level

Projected consumer overlay, the deal 
type as seen by the consumer, as 
predicted when the promotion was 
committed. 

This is shown in red if the actual deal 
type was different.

This series is configured (via a client 
expression) to have three branches, in
the same way as # Wks P.

Uses the Cons_type lookup table; see 
"Lookup Tables".

"Event Projections 
and Event Actuals"

CPIU promotion Cost per incremental unit sold as a 
result of the promotion.

CPIU O promotion Cost per incremental unit sold as a 
result of the optimized promotion.

"Optimizing a 
Promotion"
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Series Table Purpose For details, see...

CPIU P promotion Projected cost per incremental unit 
sold as a result of the promotion, as 
predicted when the promotion was 
committed.

PTP uses colors to indicate deviations
between the projections and the 
actuals; see "% Spend P".

This series is configured (via a client 
expression) to have three branches, in
the same way as # Wks P.

"Event Projections 
and Event Actuals"

Cumulative % 
vs Plan

sales_data Total cumulative actuals, as a fraction
of the plan.

Cumulative 
Actuals

sales_data The total actuals (base plus 
incremental) cumulative to date. 

Cumulative 
Plan

sales_data Cumulative frozen planned volume.

End Ship promotion 
level

Date when shipments will end for the
event 

"Creating a 
Promotion"

Evt Spend promotion Total plan spend (by the 
manufacturer) for the promotion, 
sum of buy down, vehicle costs, and 
slotting.

Evt Spend exS promotion Total planned buy down and vehicle 
costs for promotion. 

This spend is split between MDF and 
BDF funds. To control the split, you 
set the MDF Alloc % series, which 
controls how much of the spending is
funded by MDF.

Evt Spend exS 
O

promotion Total planned buy down and vehicle 
costs for optimized promotion. 

"Optimizing a 
Promotion"
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Series Table Purpose For details, see...

Evt Spend exS 
P

promotion Projected total planned buy down 
and vehicle costs for promotion, as 
predicted when the promotion was 
committed.

PTP uses colors to indicate deviations
between the projections and the 
actuals; see "% Spend P".

This series is configured (via a client 
expression) to have three branches, in
the same way as # Wks P.

"Event Projections 
and Event Actuals"

Evt Status promotion 
level

Status of the promotion as shown to 
users. For allowed values, see "
Promotion Status".

Also, the color of this series indicates 
the optimization status of this 
promotion:

• Yellow means that the 
promotion has been optimized.

• Green means that the promotion 
has been optimized and 
accepted, so that the promotion 
is using the optimization results.

• White means that the promotion 
has not been optimized.

Incr Evt $ promotion Incremental sales to the manufacturer
due to the promotion.

"Lift Decomposition
Table - 
Manufacturer"

Incr Evt $ Net promotion Net incremental sales due to the 
event.

Incr Evt $ O promotion Incremental sales to the manufacturer
due to the optimized promotion.

"Optimizing a 
Promotion"
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Series Table Purpose For details, see...

Incr Evt $ P promotion Projected incremental sales to the 
manufacturer, due to the event, as 
predicted when the promotion was 
committed.

PTP uses colors to indicate deviations
between the projections and the 
actuals; see "% Spend P".

This series is configured (via a client 
expression) to have three branches, in
the same way as # Wks P.

"Event Projections 
and Event Actuals"

Incr Evt $ Rtl promotion Incremental sales to the retailer due 
to the promotion.

"Lift Decomposition
Table - Retailer"

Incr Evt $ Rtl 
Act

promotion Incremental sales to the retailer due 
to the promotion, as determined by 
syndicated data.

Incr Evt $ Rtl 
sd

sales_data Incremental event dollars earned by 
the retailer, as loaded from external 
systems. By default, this series 
displays loaded syndicated data.

Incr Evt Vol promotion Incremental volume due to the 
promotion.

Incr Evt Vol 
Act

promotion Incremental volume due to the 
promotion, as determined by 
syndicated data.

Incr Evt Vol 
Fut

promotion Incremental volume due to the 
promotion. This series has values for 
all dates (not just future dates).

Incr Evt Vol O promotion Incremental volume due to the 
optimized promotion.

"Optimizing a 
Promotion"
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Series Table Purpose For details, see...

Incr Evt Vol P promotion Projected incremental volume due to 
the promotion, as predicted when the
promotion was committed.

PTP uses colors to indicate deviations
between the projections and the 
actuals; see "% Spend P".

This series is configured (via a client 
expression) to have three branches, in
the same way as # Wks P.

"Event Projections 
and Event Actuals"

Incr Evt Vol sd sales_data Incremental event volume, as loaded 
from syndicated data.

Incr Fcst sales_data Incremental volume: actuals and 
forecast due only to planned 
promotions.

Incr Mfg Prft promotion Incremental profit to the 
manufacturer due to the promotion. 
Event spending and slotting have 
been deducted.

This profit is in addition to the 
manufacturer's usual profit and is 
thus a measure of the value of the 
promotion.

This series is displayed in red if the 
value is negative.

Incr Mfg Prft O promotion Incremental profit to the 
manufacturer due to the optimized 
promotion.

This series is displayed in red if the 
value is negative.

"Optimizing a 
Promotion"
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Series Table Purpose For details, see...

Incr Mfg Prft P promotion Projected incremental profit to the 
manufacturer due to the promotion, 
as predicted when the promotion was
committed.

PTP uses colors to indicate deviations
between the projections and the 
actuals; see "% Spend P".

This series is configured (via a client 
expression) to have three branches, in
the same way as # Wks P.

"Event Projections 
and Event Actuals"

Incr Rtl Prft promotion Incremental retailer profit due to the 
promotion, calculated as the 
incremental volume multiplied by the
retailer's margin.

This profit is in addition to the 
retailer's usual profit and is thus a 
measure of the value of the 
promotion to the retailer.

This series is displayed in red if the 
value is negative.

Incr Rtl Prft O promotion Incremental retailer profit due to the 
optimized promotion.

This series is displayed in red if the 
value is negative.

"Optimizing a 
Promotion"

Incr Rtl Prft P promotion Projected incremental retailer profit 
due to the promotion, as predicted 
when the promotion was committed.

PTP uses colors to indicate deviations
between the projections and the 
actuals; see "% Spend P".

This series is configured (via a client 
expression) to have three branches, in
the same way as # Wks P.

"Event Projections 
and Event Actuals"

incr_vol_no_un
plan

promotion Incremental volume caused only by 
the planned promotions.
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Series Table Purpose For details, see...

Is_self promotion For internal use only. This series 
indicates whether the promotion and 
the item-location combination are 
related:

• 1 means that the promotion 
applies to the item-location 
combination.

• 0 means that the promotion 
applies to some other 
item-location combination.

Lift promotion Lift factor for the promotion. This is 
the event volume divided by the base
volume.

Lift O promotion Lift factor for the optimized 
promotion.

"Optimizing a 
Promotion"

List Price promotion List price, the price charged by the 
manufacturer to the retailer.

List Price sd sales_data List price, the price charged by the 
manufacturer to the retailer.

MDF Auth sales_data Authorized market development 
fund, computed as follows:

(base rate + dev rate)*volume + fixed 
funds 

MDF Alloc promotion MDF spending that is allocated to 
fund this event. This is computed as 
follows:

MDF Alloc % * Evt Spend exS

"Marking a 
Promotion as 
Planned"
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Series Table Purpose For details, see...

MDF Alloc % promotion Editable series that controls how 
much of event spending (apart from 
slotting costs) is to be allocated to 
MDF. 

Note that BDF Alloc % + MDF Alloc 
% = 100%

Enter 50 for 50%, for example.

MDF Auth sales_data Authorized market development 
fund, computed as follows:

(base rate + dev rate) * volume + fixed
funds 

"About Quotas and 
Funds"

MDF Bal sales_data Remaining (unspent) MDF funds, 
computed as follows:

MDF Auth - MDF Alloc

MDF Base Rate sales_data Market development fund base rate. "About Quotas and 
Funds"

MDF Dev Rate sales_data Market development fund 
development rate.

MDF Fixed 
Funds

sales_data MDF fixed funds.

Mfg Prft O promotion Manufacturer's profit from the 
optimized event.

This series is displayed in red if the 
value is negative.

Mfg Profit promotion Manufacturer's profit from the event, 
considering both cost of goods and 
event spending.

This series is displayed in red if the 
value is negative.

Mfg Profit Var promotion
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Series Table Purpose For details, see...

Net Incr Evt $ promotion Net revenue from the manufacturer's 
perspective. This considers the total 
manufacturer's lift dollars and 
subtracts costs due to cannibalization 
and pre- and post-effects.

"Lift Decomposition
Table - 
Manufacturer"

Net Incr Evt $ 
Rtl

promotion Net revenue from a retailer's 
perspective. This considers the total 
retailer's lift dollars and subtracts 
costs due to cannibalization (as seen 
by the retailer) and pre- and 
post-effects.

"Lift Decomposition
Table - Retailer"

Net Incr Rtl 
Prft

promotion Net incremental profit for the retailer,
after considering cannibalization and 
pre- and post-effects.

Optimization 
Status

promotion 
level

Indicates the status of any 
optimization that was run on this 
promotion. Used in the color 
expression of the Evt Status series. 
Not meant for direct use.

Optimized promotion For internal use only. Indicates if 
optimization was run on this 
promotion.
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Series Table Purpose For details, see...

Past End Date promotion 
level

Not displayed. This internal series is 
used to check whether a promotion 
has already occurred. For any 
promotion, this series equals one of 
the following values:

• 1 means that the promotion is 
past; specifically, the 
max_sales_date is equal to or 
after the end date of the 
promotion.

• 0 means that the promotion is in 
the future.

Other series use this series within 
client expressions that have the 
following general logic:

if past end date = 1, use actuals data; 
otherwise, use forecast data.

Pay Type promotion Type of settlement arranged with the 
retailer for this promotion. Indicates 
the payment terms between the 
manufacturer and the retailer for this 
promotion.

Plan Vol sales_data Manufacturer's planned revenue.

Pre-Post $ promotion Total sales made by the manufacturer
before and after the promotion, as a 
result of the promotion. This is 
shown as a positive number for 
graphing purposes. These sales, 
however, are subtracted from the 
total sales.

"Lift Decomposition
Table - 
Manufacturer"

Pre-Post $ Rtl promotion Total sales made by the retailer 
before and after the promotion, as a 
result of the promotion. This is 
shown as a positive number for 
graphing purposes. These sales, 
however, are subtracted from the 
total sales.

"Lift Decomposition
Table - Retailer"
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Series Table Purpose For details, see...

Pre-Post Vol promotion Total volume before and after the 
promotion, as a result of the 
promotion. This is generally a 
negative number.

"Lift Decomposition
Table - 
Manufacturer"

Rtl Prft promotion Retailer's profit from the event.

This series is displayed in red if the 
value is negative.

Rtl Prft O promotion Retailer's profit from the optimized 
event.

This series is displayed in red if the 
value is negative.

"Optimizing a 
Promotion"

Sale Price promotion Sale price per unit at shelf.

Sale Price O promotion 
level

Sale price per unit at shelf, for the 
optimized promotion.

Sales Quota sales_data Sales quota (revenue).

Sales Quota sales_data Sales quota (revenue).

Sales Var promotion

Shelf Price promotion Everyday price to the consumer.

In contrast to the Shelf Price sd series,
this series is stored in 
promotion_data for better 
performance.

Shelf Price sd sales_data The everyday price to the consumer, 
as loaded from external systems. This
series is stored in sales_data and is 
mainly for internal use; see Shelf 
Price.

Shipments sales_data Number of units shipped from the 
manufacturer to the ship-to 
destination of the retailer. 
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Series Table Purpose For details, see...

Slot Auth sales_data Authorized slotting funds. "About Quotas and 
Funds"

Slot Bal sales_data Remaining slotting budget.

Start Event promotion Date when promotion starts in stores. "Creating a 
Promotion"

Start Event O promotion 
level

Date when optimized promotion 
starts in stores.

"Optimizing a 
Promotion"

Start Event P promotion 
level

Projected date when promotion starts
in stores, as predicted when the 
promotion was committed.

This series is configured (via a client 
expression) to have three branches, in
the same way as # Wks P.

"Event Projections 
and Event Actuals"

Start Ship promotion 
level

Date when the product will start to 
be shipped

"Creating a 
Promotion"

Status promotion 
level

For internal use only. 

Ttl Evt $ promotion Total revenue during the event, for 
the manufacturer.

Ttl Evt $ O promotion Total revenue during the optimized 
event, for the manufacturer.

"Optimizing a 
Promotion"

Ttl Evt $ P promotion Projected total revenue during the 
event, for the manufacturer, as 
predicted when the promotion was 
committed.

PTP uses colors to indicate deviations
between the projections and the 
actuals; see "% Spend P".

This series is configured (via a client 
expression) to have three branches, in
the same way as # Wks P.

"Event Projections 
and Event Actuals"
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Series Table Purpose For details, see...

Ttl Evt $ Rtl promotion Total revenue during the event, for 
the retailer.

Ttl Evt Vol promotion Total volume for the promotion.

Ttl Evt Vol O promotion Total volume for the optimized 
promotion.

"Optimizing a 
Promotion"

Ttl Evt Vol P promotion Projected total event volume, as 
predicted when the promotion was 
committed.

PTP uses colors to indicate deviations
between the projections and the 
actuals; see "% Spend P".

This series is configured (via a client 
expression) to have three branches, in
the same way as # Wks P.

"Event Projections 
and Event Actuals"

Ttl Fcst sales_data Total volume: base forecast plus 
incremental forecast.

Ttl Fund Auth promotion Total authorized spending, including 
MDF, BDF, and slotting.

"About Quotas and 
Funds" 

Ttl Fund Bal promotion Remainder of total authorized 
spending, after accounting for 
spending.

Units promotion 
level

Number of units associated with the 
consumer deal (Cons Promo). 
Usually this is 1. This is 2 in the case 
of 2-for-1 deals. 

Unmatched $ sales_data Trade spend not yet matched to an 
event.

Uplift promotion_da
ta

"About Quotas and 
Funds"

Veh $ promotion Vehicle cost for the promotion. "Promotion Costs 
and Spending"
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Series Table Purpose For details, see...

Veh $ O promotion Vehicle cost for the optimized 
promotion.

"Optimizing a 
Promotion" 

Veh Type promotion 
level

The vehicle type or event type of the 
promotion. 

"Promotion Costs 
and Spending"

Veh Type O promotion 
level

The vehicle type or event type of the 
optimized promotion. 

"Optimizing a 
Promotion"

Veh Type P promotion 
level

Projected vehicle type of the 
promotion, as predicted when the 
promotion was committed.

This series is configured (via a client 
expression) to have three branches, in
the same way as # Wks P.

"Event Projections 
and Event Actuals"

Vehicle Cost 
DISPLAY

promotion Vehicle cost for event of type 
DISPLAY.

Vehicle Cost 
F&D

promotion Vehicle cost for event of type F&D.

Vehicle Cost F. 
SHOPPER

promotion Vehicle cost for event of type F. 
SHOPPER.

Vehicle Cost 
FEATURE

promotion Vehicle cost for event of type 
FEATURE.

Vehicle Cost 
NATIONAL 
TV

promotion Vehicle cost for event of type 
NATIONAL TV.

Vehicle Cost 
TPR

promotion Vehicle cost for event of type TPR.

Volume Base sales_data Base volume aggregated over sales 
data.

"About Quotas and 
Funds"
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Series Table Purpose For details, see...

Volume Base 
Ttl

sales_data Base volume series used by many 
other series. This series gives the base
volume, if no promotions were run or
are run. It checks the value of Past 
End Date and uses the following 
logic.

If past end date = 1, use actuals data; 
otherwise, use forecast data.

Volume Incr 
Ttl

promotion_da
ta

Incremental volume series used by 
many other series. This series gives 
the incremental volume due to 
promotions. It checks the value of 
Past End Date and uses the following 
logic.

If past end date = 1, use actuals data; 
otherwise, use forecast data.

Item Levels
PTP uses the following item levels:

The most commonly used item level is Promotion Group. Some PTP worksheets use 
Brand or Segment. The other levels are provided for convenience, so that you can create
worksheets aggregated at those levels.

The Manufacturer level is populated via the APPPROC_MAINTAIN_TERR_RETAILER
procedure. The rest are created by ep_load_main.

Location Levels
PTP uses the following location levels:
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The most commonly used location levels are Territory and Retailer. The Retailer has a 
set of attributes, described in the following subsection. The other levels are provided for
convenience, so that you can create worksheets aggregated at those levels.

The Territory-Retailer level is used by the Analytical Engine. This level is populated via 
the APPPROC_MAINTAIN_TERR_RETAILER procedure. The rest are created by 
ep_load_main.

Internally, the lowest location level is a combination of Ship To and Territory and is 
created automatically by Demantra.

Retailer
This level contains the retailers. It is expected that retailers will be loaded rather than 
created within PTP. However, users can and should modify attributes of these retailers:

Attribute Purpose

Account Classification Dropdown list with the following choices:

• Growth

• Holding

• Declining

Avg Everyday Selling Margin Average selling margin, disregarding promotions.
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Attribute Purpose

Class_of_Trade Dropdown list with the following choices:

• Food

• Drug

• Mass

• C-Store

• Military

Event Threshold: Display Only Minimum number of units that should be sold for an event 
of type Display.

Event Threshold: F Shopper Minimum number of units that should be sold for an event 
of type F. Shopper.

Event Threshold: Feat Display Minimum number of units that should be sold for an event 
of type F&D.

Event Threshold: Feature Only Minimum number of units that should be sold for an event 
of type Feature.

Event Threshold: Natl TV Minimum number of units that should be sold for an event 
of type National TV.

Event Threshold: TPR Only Minimum number of units that should be sold for an event 
of type TPR.

Key Competitors A text field where you can list the key competitors of this 
retailer.

Min Man Event Margin

Min Rtl Event Margin Minimum margin that this retailer must make on an event. 
Promotion Optimization considers only events that provide 
at least this much margin.

Name Name of the retailer.

Number of Active Stores Number of active stores that this retailer operates.
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Attribute Purpose

Ship Timing: Display Stock #Wk Specifies how much earlier this retailer likes to receive any 
items to be placed in display stock. Specify as the number of 
weeks needed before the start of the promotion.

Ship Timing: Displays # Wks Specifies how much earlier this retailer likes to receive any 
displays to be placed in the stores. Specify as the number of 
weeks needed before the start of the promotion.

Ship Timing: Reg Open Stock 
Wks

Specifies how much earlier this retailer likes to receive any 
items to be placed in open stock. Specify as the number of 
weeks needed before the start of the promotion.

Slotting Fees per item Amount that this retailer charges to place the items on the 
shelf, per item.

Use Default Profile Controls whether to update this profile by getting the 
default values for all these attributes.

Veh Costs: Display Only Default cost for an event of type Display for this retailer.

Veh Costs: F Shopper Default cost for an event of type F. Shopper for this retailer.

Veh Costs: Feature & Display Default cost for an event of type F&D for this retailer.

Veh Costs: Feature Only Default cost for an event of type Feature for this retailer.

Veh Costs: Natl TV Default cost for an event of type National TV for this retailer.

Veh Costs: TPR Only Default cost for an event of type TPR for this retailer.

Promotion Levels
PTP uses the following promotion levels:
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The following sections provide details on these levels:

• "Promotion"

• "Promotion Status"

• "Promotion Type"

• "Scenarios"

• "Optimization Goal"

• "Plans"

Promotion
This level contains the promotions. Users can add, modify, or remove promotions as 
needed. The following table lists all the attributes of promotions and indicates when 
these attributes are displayed:

Attribute When Displayed Purpose

Approval

Buydown Buy down allowance for this promotion. May 
be used for Off Invoice or Bill back purposes.

Cons Promo When creating or 
editing

Consumer overlay. Indirectly specifies the 
number of units included in the deal to the 
customer.

Uses the Cons_type lookup table; see "Lookup 
Tables".

End Ship When creating or 
editing

Event Status Not used. Ignore this attribute. It is not used.

Fixed Buydown When optimizing Specifies whether Promotion Optimization 
should use the buydown that you have already
entered or calculate an optimal buydown for 
this promotion.

Uses a lookup table that should not be edited.
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Attribute When Displayed Purpose

Max Budget When optimizing Maximum allowed budget for this promotion.

Max Buydown When optimizing Maximum allowed buydown for this 
promotion. If Promotion Optimization 
calculates an optimal buydown, the buydown 
will not exceed this value.

method_status Uses a lookup table that should not be edited.

Min Rtl Margin 
Override

When optimizing Minimum margin that the retailer must make 
on this promotion. By default, Promotion 
Optimization considers the retailer's default 
required minimum margin. Use this parameter 
to override that value, if needed.

Use a value greater than 0 and less than or 
equal to 1.

Name When creating or 
editing

Name of the promotion. Does not have to be 
unique.

Optimal Budget

Optimal Lift

Optimal Price 
Decrease

Optimal Profit

Optimal Revenue

Optimal Type Indicates the optimal vehicle type for this 
promotion. This attribute is a lookup attribute 
that uses the Promotion Type level.
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Attribute When Displayed Purpose

Optimization Goal When optimizing Select one of the following goals for this 
promotion:

• Maximize Revenue

• Maximize Profit

• Maximize Units

This attribute is a lookup attribute that uses the
Optimization Goal level.

Optimization 
Range End

When optimizing By default, Promotion Optimization assumes 
that you want the optimized promotion to fall 
within the span of time of the original 
promotion. If you want Promotion 
Optimization to search for a better time for this 
promotion, use these attributes to specify the 
range of time for optimization to consider.

Optimization 
Range Start

When optimizing

Optimization 
Status

Never displayed Status of the optimization process on this 
promotion. Uses a lookup table that should not
be edited.

Population When creating or 
editing

Combinations where this promotion will run 
and dates of the promotion.

Promotion Status Not used. Ignore this attribute. It is not used.

Promotion Type1 Never displayed Current vehicle type for this promotion. This 
attribute is a lookup attribute that uses the 
Promotion Type level.

Return on 
Investment (ROI)

Scenarios When creating or 
editing

Scenario to which this promotion belongs. This 
attribute is a lookup attribute that uses the 
Scenarios level.

Start Ship When creating or 
editing
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Attribute When Displayed Purpose

Status Never displayed; not 
used directly

Vehicle Type When creating or 
editing

Type of the promotion. This attribute is a 
lookup attribute that uses the Promotion Type 
level.

Promotion Status
This level contains the PTP promotion statuses.

Promotion Type
This level contains the promotion types, by default, the following set:

Type Details

Display Display Only

F. Shopper F Shopper

F&D Feature and Display

Feature Feature Only

National TV National TV advertising. If this does not 
apply, you can use this type as a placeholder 
for another type, as needed.

TPR Temporary price reduction only.

Consultants can add other types, but changes are needed in multiple places if this is 
done. The documentation for this is currently out of scope.

Scenarios
This level contains the scenarios, which have the following purposes:

• Actuals contains promotions from previous years. These promotions are excluded 
from most PTP worksheets because they fall outside the span of time used in these 
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worksheets.

• Current Year should contain the promotions that are planned for the current fiscal 
year.

• Sandbox should contain all promotions that are not yet planned.

Optimization Goal
This level contains the predefined optimization goals. Do not make changes to this 
level.

Plans
This level is not used in PTP worksheets.

Lookup Tables
This section lists the configurable lookup tables used by promotion levels and series.

Note: You can change the contents of these table, but you should not 
change their structure.

Cons_type
This table lists types of consumer overlays and for each type, indicates the number of 
units included in the deal to the consumer. This lookup table is used by the Cons Promo
attribute, the Cons Promo series, and the Cons Promo P series. This table has the 
following structure:

Field Required? Data type Purpose

CONS_TYPE_ID required NUMBER(10) Unique ID for Oracle 
internal use.

CONS_TYPE_CODE   VARCHAR2(50) Code for the 
consumer overlay.

CONS_TYPE_DESC   VARCHAR2(50) Name of the 
consumer overlay.

IS_FICTIVE   NUMBER(1) Leave these null.
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Field Required? Data type Purpose

SELF_SHAPE_INDIC
ATOR

  NUMBER(5) 

IG_SHAPE_INDICAT
OR

  NUMBER(5) 

OMIT_SEASONAL   NUMBER(5) 

FICTIVE_CHILD   NUMBER(10) 

LAST_UPDATE_DA
TE

  DATE

Pay_Type_lookup
This table controls the drop-down choices in the Pay Type series. This table has the 
following structure:

Field Required? Data type Purpose

PAY_TYPE_ID required NUMBER(10) Unique ID for Oracle 
internal use.

PAY_TYPE_CODE   VARCHAR2(50) Code for the 
consumer overlay.

PAY_TYPE_DESC   VARCHAR2(50) Name of the 
consumer overlay.

IS_FICTIVE   NUMBER(1) Leave these null.

SELF_SHAPE_INDIC
ATOR

  NUMBER(5) 

IG_SHAPE_INDICAT
OR

  NUMBER(5) 

OMIT_SEASONAL   NUMBER(5) 
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Field Required? Data type Purpose

FICTIVE_CHILD   NUMBER(10) 

LAST_UPDATE_DA
TE

  DATE

Methods
PTP uses the following custom methods.

Optimize Promotion
This method uses the Call Promotion Optimizer predefined workflow. The Call 
Promotion Optimizer workflow consists of three steps:

1. The first step initializes the necessary fields in the database. This step collects 
arguments, passes them to the APPPROC_PRE_OPTIMIZATION stored procedure,
and then runs that stored procedure.

Caution: You should not change this step.

2. The second step calls the optimizer. This is a custom step that collects arguments 
and calls the OPL class file, which runs the optimization. 

Note: You must configure this for your specific installation, as 
described in Configuring the Optimization Step. 

3. The final step cleans up the necessary fields in the database, collects arguments, 
passes them to the APPPROC_POST_OPTIMIZATION stored procedure, and then 
runs that stored procedure.

Caution: You should not change this step.

If the user uses this method, Demantra creates a virtual promotion that the user can 
display along with the current promotion (in the PMO: Optimization Comparison 
worksheet). 

Accept Optimization
This method saves the optimized promotion, overwriting the previous details. 
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Specifically, it copies data from the optimized series to the corresponding standard 
series, for the selected promotion. For example, it copies data from # Wks O to # Wks.

This method uses the AcceptOptimization predefined workflow. This workflow 
consists of one step (which calls the APPPROC_ACCEPT_OPTIMIZATION procedure).

Procedures
PTP uses the following custom procedures.

Procedure Purpose

AP
PPROC_ACCEPT_OPTIMIZATION

Used by Promotion Optimization. 

APPPROC_BLE_ACTUALS_LY Updates the ActualLY series.

AP
PPROC_BLE_VOLUME_BASE_FUTU
RE

Updates sales_data. vol_base_ttl, for all dates.

For dates in the future, this procedure sets the field 
equal to the latest base forecast from the engine.

For dates in the past, this procedure sets the field 
equal to the value of sales_data. sdata5, the syndicated
base volume.

AP
PPROC_BLE_VOLUME_BASE_HIST

Updates sales_data .vol_base_ttl, for dates in the past. 
This procedure sets the field equal to the value of 
sales_data. sdata5, the syndicated base volume.

APPPROC_CLEAR_DATA Clears the sales_data, mdp_matrix, promotion, and 
promotion_data tables. Called by the Data Loading 
Wizard.

APPPROC_COPY_DEF_RETAILER Iterates through all retailers, finds any that have been 
marked as using the default profile, and copies the 
default attribute values to each of those retailers.

This procedure is also called by the Data Loading 
Wizard.

APPPROC_DROP_TEMPS Drops the temporary tables.

AP
PPROC_MAINTAIN_TERR_RETAIL
ER

Populates the Manufacturer level and the 
Territory-Retailer level.

This procedure is called by the Data Loading Wizard.
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Procedure Purpose

APPPROC_POST_DATA_LOAD This procedure completes the last steps needed during
data loading:

• Updates the LAST_DATE_BACKUP parameter in 
the INIT_PARAMS_0 table to equal the last sales 
date in the system.

• Runs the APPPROC_COPY_DEF_RETAILER 
procedure.

• Runs the 
APPPROC_MAINTAIN_TERR_RETAILER 
procedure.

• Updates the promotion_data table with values 
loaded into sales_data. 

• Updates sales_data .vol_base_ttl according to the 
sdata5 column that was loaded. This initiates the 
APPTRIG_VOLUME_BASE_UPDATE_SD trigger;
see "Triggers".

This procedure is called by the Data Loading Wizard.

APPPROC_POST_OPTIMIZATION Used by Promotion Optimization. 

APPPROC_PRE_OPTIMIZATION Used by Promotion Optimization. 

Instead of running procedures directly, use the workflows provided by PTP. See "
Administration" and "Workflows".

Triggers
PTP uses the following custom triggers. 

Trigger When activated Action

A
PPTRIG_INSERT_PR
OMOTION

When inserting 
promotion

Gets list price, shelf price, and COGs from 
sales_data and copies them to 
promotion_data.
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Trigger When activated Action

A
PPTRIG_INSERT_PR
OMOTION_PAST

When inserting 
promotion in the past

Updates the following series for this 
promotion:

• Avg Rtl sd

• Incr Evt Vol Act

• Base Evt $ Rtl Act

• Incr Evt $ Rtl Act

AP
PTRIG_SHELF_PRICE
_UDPATE_SD

When updating shelf 
price on sales_data.

Copies that data into promotion_data.

APP
TRIG_VOLUME_BAS
E_UPDATE_PD

When inserting a 
promotion

Gets sales_data.volume_base_ttl and updates
the field by the same name in 
promotion_data.

A
PPTRIG_VOLUME_B
ASE_UPDATE_SD

When updating 
volume_base_ttl in 
sales_data.

Copies that data into promotion_data

Workflows
PTP uses the following workflows:

Workflow When to run Description

AcceptOptimization Do not run directly. Used by the Accept Optimization 
method.

Call Promotion Optimizer Do not run directly. Used by the Optimize Promotion 
method. 

Note: Includes installation-dependent
details and must be configured for 
each installation.
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Workflow When to run Description

CopyRetailerDefaults Run this each time you 
edit a retailer to use the 
default profile and each 
time you edit the retailer 
defaults in the Business 
Modeler.

Executes the 
APPPROC_COPY_DEF_RETAILER 
procedure.

Create Member Do not run directly. Used internally when a user creates a 
member of a level.

Delete Member Do not run directly. Used internally when a user deletes a 
member of a level.

DoNothing Do not use. Do not use.

Edit Member Do not run directly. Used internally when a user edits a 
member of a level.

Import Promo Data Not required. Provided for you to use if you want to
load data manually rather than using 
the Data Loading Wizard.

ImportPromotionLevels Not required. Provided for you to use if you want to
load data manually rather than using 
the Data Loading Wizard.

Paste Member Do not run directly. Used internally when a user pastes a 
member of a level.

Run App Proc After Batch
Engine

Run this after you run the
Analytical Engine.

Runs the following required 
procedures:

• APPPROC_BLE_ACTUALS_LY

• APPPROC_BLE_VOLUME_BAS
E_FUTURE

Run Drop Temps Run this daily. Executes the 
APPPROC_DROP_TEMPS procedure.

Run Engine and BLE   Do not use.
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Workflow When to run Description

runprocsteps Do not run directly. Used by the Optimize Promotion 
method.

Engine Configuration
This section describes the basic engine configuration in PTP. 

Forecast Tree
The PTP forecast tree is as follows:

Forecast level 
number

Levels used in this forecast level Notes

Item level Location level

1 Lowest level Lowest level

2 Promotion Group Territory Retailer This is also the lowest
promotional level 
(LPL).

3 Brand Retailer This is also the 
influence group level 
(IGL).

4 Category Retailer This is also the 
influence range level 
(IRL).

5 Highest fictive level Highest fictive level

Parameter Settings
In PTP, the following parameter values are set for the Analytical Engine:
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Setting Value Notes Needed for

COMPETITION_IT
EM

352 This is the manufacturer level. Analytical Engine

COMPETITION_L
OCATION

237 This setting refers to the 
Competition_Location group table, 
which has only one row. This has 
the same effect as setting 
COMPETITION_LOCATION equal 
to the Retailer level.

CalcOptimizationI
nput

yes Promotion 
Optimization

StartAverage 0

AverageHorizon 52 Specify the length of time, in base 
time units, to use in calculating the 
average baseline forecast. Typically 
one year or half a year is suitable.

BottomCoefficientL
evel

2

TopCoefficientLev
el

3

Engine Models
Only the linear models work with Promotion Optimization. Therefore, in the model 
table in the database, the following models are marked as IS_OPTIMIZATION=1: 
R-REGR, M-MRIDGE, and C-CMREG.
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B
Base Evt Vol, 16-6
Base Evt Vol O, 16-6
Base Fcst, 16-6
batch run, 14-3
BDF

introduction, 2-8
series names, 7-2
setting fund amounts, 7-3, 7-6
using fund, 9-8
viewing fund balances, 9-3
viewing funds, 7-7

BDF Alloc, 16-6
BDF Auth, 16-6, 16-7
BDF Bal, 16-7
BDF Base Rate, 16-7
BDF Dev Rate, 16-7
BDF Fixed Funds, 16-7
bill-to locations, 2-4
BottomCoefficientLevel parameter, 16-39
brand

and other levels, 16-23
introduction, 2-3

budget
consuming, 9-8
establishing, 7-3, 7-6
introduction, 2-8
series names, 7-2
viewing, 7-7
viewing balance, 9-3

Business Modeler, starting, 14-8
Buydown, 16-7
Buydown $, 16-7
Buydown O, 16-7

C
cache, worksheet

enabling for a worksheet, 13-5
refreshing manually, 4-17

CalcOptimizationInput parameter, 16-39
Canbl $, 16-8
Canbl $ Rtl, 16-8
cannibalization

introduction, 2-10

manufacturer
actual, 12-4
actual versus projected, 12-3

retailer
actual, 12-7
actual versus projected, 12-3

categories
introduction, 2-3
in World Brands, 15-2

characters to avoid, 4-2
client expressions and recalculation, 4-3
Collaborator Workbench

adding content panes, 13-5
introduction, 1-2
key metrics, 6-3
logging in, 6-1
opening worksheets, 6-8
personalizing, 6-11

combination
exporting data for, 4-6
including in worksheet, 13-11, 13-12

companies, 2-5
Cons Promo, 16-9
Cons Promo P, 16-9
content

adding pane from existing panes, 6-11
introduction to options, 13-2
options, 13-5
predefined summary panes, 6-3

cost benefit review
for future promotion, 11-3, 11-9
for optimized promotion, 10-8
for promotions in selected scenario, 9-5

CPI (Consumer Price Index), 13-14
CPIU

comparing promotions, 11-9
how computed, 16-9

CPIU O, 16-9
CPIU P, 16-10
Cumulative Actuals, 16-10
Cumulative Plan, 16-10
Current Year scenario, 2-7, 16-31

D
dashboard

adding content panes, 13-5
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introduction, 1-2
key metrics, 6-3
logging in, 6-1
opening worksheets, 6-8
personalizing, 6-11

data
copying and pasting with Excel, 4-6
copying and pasting within worksheet, 4-5
editing, 4-1
exporting to Excel, 4-6
importing into Excel, 4-7
printing, 4-10
saving changes, 5-6

database
connecting to via DOL, 4-7

default
combinations for new promotion, 9-7
combinations in worksheet, 13-12
layout in Collaborator Workbench, 6-11
recalculation, 4-3
table sort, restoring, 4-4
worksheet view layout, 13-20

demo
background of sample company, 15-2
user IDs and passwords, 15-3

districts, 2-5
divisions, 2-5
DOL, using, 4-7
Dynamic Open Link, using, 4-7

E
email

escalating a task, 6-11
sending notification of task, 6-9
specifying for users, 14-9

empty rows
controlling display, 5-5
saving setting, 5-8

End Ship, 16-10
ep_load_main, 16-23, 16-24
event

accepting optimization, 10-9
approving, 9-9
closing, 9-10
committing, 9-9
comparing to other events in scenario, 11-8

copying and pasting, 9-13
costs and spending, 2-9
creating, 9-6
deleting, 9-13
evaluating future event, 11-2
evaluating past event, 12-2, 12-5
introduction, 2-6
life cycle, 2-7
marking as paid, 9-10
marking as planned, 9-8
modifying, 9-10
optimization results, 10-7
optimizing, 10-4
projections and actuals, 12-3, 12-6
reference for attributes, 16-27
specifying how to fund, 9-8

Evt Spend, 16-10
Evt Spend exS, 16-10
Evt Spend exS O, 16-10
Evt Spend exS P, 16-11
Evt Status, 16-11

display color, 9-3
Excel

copying data to, 4-6
exporting data to, 4-6
linking data into via Dynamic Open Link 
(DOL), 4-7
pasting data from, 4-6

exception filter, applying to worksheet, 13-18
exchange rate

introduction, 13-14
used in worksheet, 13-16

exiting, 3-7
extra filters option, 13-5

F
files

attaching to a task, 6-10
attaching to notes, 4-14
downloading from notes, 4-15

filter
adding for when worksheet opens, 13-5
adding to worksheet view, 13-26
and other performance tips, 13-29
at user level, 14-11
filtering series in worksheet editor, 13-8
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for bar charts, 13-6
introduction, 13-16

finding elements, 13-8
fixed funds

introduction, 2-8
series names, 7-2

forecast
affected by promotions, 2-7
and actuals, 7-3
and simulation, 10-1
and unplanned promotions, 2-7
and volume breakdown, 2-9
introduction, 1-7
viewing, 8-3

forecast tree and Promotion Optimization, 16-38
funds

introduction, 2-8
series names, 7-2
setting amounts, 7-3, 7-6
using, 9-8
viewing, 7-7
viewing balances, 9-3

G
graph

adding series to, 13-21
changing style, 5-4
choosing type, 13-20
time resolution of, 13-9
viewing note from within, 4-13

group
adding users to, 14-12

H
Hide Empty Rows, 5-5
hung session, ending, 3-7

I
illegal characters, 4-2
incr_vol_no_unplan, 16-14
Incr Evt $, 16-11
Incr Evt $ Net, 16-11
Incr Evt $ O, 16-11
Incr Evt $ P, 16-12
Incr Evt $ Rtl, 16-12

Incr Evt $ Rtl sd, 16-12
Incr Evt Vol, 16-12
Incr Evt Vol Act, 16-12
Incr Evt Vol Fut, 16-12
Incr Evt Vol O, 16-12
Incr Evt Vol P, 16-13
Incr Fcst, 16-13
Incr Mfg Prft, 16-13
Incr Mfg Prft O, 16-13
Incr Mfg Prft P, 16-14
Incr Rtl Prft, 16-14
Incr Rtl Prft O, 16-14
Incr Rtl Prft P, 16-14
index (financial)

in audit trail, 4-19
introduction, 13-14
used in worksheet, 13-16

Is_self, 16-15
items, 2-3
item-type levels, introduction, 2-2

J
Java

preventing updates, 3-2
Web Start, 6-2

JRE, 6-2
installing, 3-2

L
layout, Collaborator Workbench

configuring by user, 6-11
configuring My Tasks, 6-13
configuring My Worksheets, 6-14

layout, worksheet
defining, 13-20
saving changes, 5-6, 5-7
tips, 13-28

level
adding to worksheet, 13-11
in worksheet, 13-11
item levels in TPMO, 16-23
location levels in TPMO, 16-23
on worksheet tab, 13-21
promotion levels in TPMO, 16-26

Lift, 16-15
lift decomposition, manufacturer
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introduction, 2-10
projected and actual, 12-3

lift decomposition, retailer
actual, 12-7
introduction, 2-11
projected and actual, 12-7

Lift O, 16-15
links in Collaborator Workbench

adding link within a task, 6-10
List Price sd, 16-15
location-type levels, introduction, 2-2
logging off, 3-7

if session hangs, 3-7

M
manufacturer

and other levels, 16-23
incremental profit, 10-8
introduction, 2-3
maintaining level, 16-34

MDF
introduction, 2-8
series names, 7-2
setting fund amounts, 7-3, 7-6
using fund, 9-8
viewing fund balances, 9-3
viewing funds, 7-7

MDF Alloc, 16-15
MDF Auth, 16-15, 16-16
MDF Bal, 16-16
MDF Base Rate, 16-16
MDF Dev Rate, 16-16
MDF Fixed Funds, 16-16
member

and Open With context, 13-5
introduction, 2-2

methods, reference information, 16-33
Mfg Prft O, 16-16
Mfg Profit, 16-16
Mfg Profit Var, 16-16
models for use with Promotion Optimization, 16-
39
My Tasks

configuring, 6-11
configuring and sorting of number of tasks, 6-
13

refreshing, 6-9
My Worksheets, 6-8

configuring, 6-11
configuring list of worksheets, 6-14
sending a worksheet as a task, 6-9
worksheet descriptions in, 13-4

N
Net Incr Evt $, 16-17
Net Incr Evt $ Rtl, 16-17
note

adding, 4-13
adding an attachment, 4-14
deleting, 4-13
editing, 4-13
saving changes, 5-6
setting permissions, 4-16
viewing, 4-13

Notes/Attachments subtab, 4-12, 4-14

O
Open With menu

introduction, 3-6
specifying context for filtering, 13-5

optimization
accepting results, 10-9, 10-9
effect on color of Evt Status, 9-3
introduction, 1-7
performing, 10-4

Optimization Comparison worksheet, 10-7, 10-10
Optimized series, 16-17

P
parameters

for optimization, 10-5
for Promotion Optimization, 16-38

password, changing, 3-8
Past End Date, 16-18
Pay Type, 16-18
Pay Type series, 16-32
performance tips for worksheet design, 13-28
permission level

specifying for user, 14-9, 14-9
permissions in a note, 4-16
personalization
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My Tasks, 6-13
My Worksheets, 6-14
wide and narrow panes, 6-11

Planning Environment worksheet, 9-1, 9-14
Planning Hierarchy summary pane, 6-4, 6-5, 6-6, 
6-8, 6-8
Plan Vol, 16-18
PMO

worksheets of, 1-6
Pre-Post $, 16-18
Pre-Post $ Rtl, 16-18
Pre-Post Vol, 16-19
printing, 4-10
procedures, reference information, 16-34
product groups, 2-4
product lines, 2-4
product subgroups, 2-4
profile for selecting parts of audit trail, 4-20
projections

colors used for deviations, 15-36, 16-4
compared to actuals, 12-3, 12-6

Promo Effect - Mfg worksheet, 11-2, 11-10
Promo Effect - Rtl worksheet, 11-14
Promo-Evaluation Mfg worksheet, 12-2, 12-9
Promo-Evaluation Rtl worksheet, 12-5, 12-13
promotion

accepting optimization, 10-9
approving, 9-9
closing, 9-10
committing, 9-9
comparing to other promotions in scenario, 
11-8
copying and pasting, 9-13
costs and spending, 2-9
creating, 9-6
deleting, 9-13
evaluating future promotion, 11-2
evaluating past promotion, 12-2, 12-5
introduction, 2-6
life cycle, 2-7
marking as paid, 9-10
marking as planned, 9-8
modifying, 9-10
optimization results, 10-7
optimizing, 10-4
projections and actuals, 12-3, 12-6
reference for attributes, 16-27

specifying how to fund, 9-8
Promotion Comparison worksheet, 11-8, 11-17
promotion group

and other levels, 16-23
creating a promotion for, 9-6
introduction, 2-4
in World Brands, 15-2
specifying quotas and funds, 7-6

Promotion History worksheet, 12-17
Promotion Optimization

parameters, 16-38

Q
quota

managing, 7-1
percent attained, 9-3
specifying bottom-up, 7-6
specifying top-down, 7-3
versus sales, 6-3
viewing, 7-7

Quota and Fund Entry Bottom-Up worksheet, 7-
6, 7-10
Quota and Fund Entry Top-Down worksheet, 7-3
, 7-8
Quota and Fund View worksheet, 7-7, 7-10
quote marks, in Oracle Demantra Spectrum, 4-2

R
redo, 4-3
refreshing, 6-9
regions, 2-5
resizing, 5-4
restoring default table sorting, 4-4
retailer

creating promotion for, 9-6
editing profile, 6-5
effect on optimization, 10-4
evaluating past promotion, 12-5
incremental profit, 10-8
introduction, 2-5
introduction to profiles, 2-8
reference for attributes, 16-24
retailers for World Brands, 15-2
running workflow to copy default profile, 14-3
settting quotas and funds for, 7-3

right-click menu
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and copying data, 4-5
and editing data, 4-2
and opening notes, 4-12
as basic navigation tool, 1-5
in Planning Hierarchy, 6-4
introduction, 3-6

Rtl Prft, 16-19
Rtl Prft O, 16-19
Run App Proc After Batch Engine, 16-37
Run Engine and BLE procedure, 14-3

S
Sale Price, 16-19
Sale Price O, 16-19
sales areas, 2-5
Sales Quota, 16-19, 16-19
Sales Var, 16-19
Sales versus Quota, 6-3
Sales versus Quota summary pane, 6-3
Sandbox scenario, 2-7, 16-31

comparing promotions in, 11-8
scenarios

comparing promotions in, 11-8
introduction, 2-7
reference, 16-31

scheduling workflow instances, 14-4
segment

and other levels, 16-23
introduction, 2-3

selection task, marking as done, 6-9
series

available to user, 14-11
editing data, 4-1
for lift decomposition, 11-4
introduction, 2-2
making available for specific user, 14-10
reference information, 16-1
related to funds, 7-2
related to volume, 7-3
selecting, 13-7
specifying display, 13-21

Shelf Price, 16-19
Shelf Price sd, 16-19
Shipments, 16-19
simulation

accepting, 10-4

introduction, 1-7
running, 10-3
starting Simulation Engine, 10-3
useful worksheets, 10-2

Slot Auth, 16-20
Slot Bal, 16-20
slotting funds

introduction, 2-8
series, 7-2
viewing balance, 9-3

sorting
controlling order of series in table, 13-20
restoring default table sort, 4-4
saving sort order, 5-8
series in worksheet editor, 13-8
sort order in My Tasks, 6-14
worksheet table, 4-4

special characters (to avoid), 4-2
StartAverage parameter, 16-39
Start Event, 16-20
Start Event O, 16-20
Start Event P, 16-20
starting

Business Modeler, 14-8
TPMO, 3-1
workflow instance, 14-4

Start Ship, 16-20
subtabs of worksheet

Notes/Attachments, 4-12, 4-14
other worksheet as subtab, 13-25

summary panes
Actuals versus Plan, 6-3
Planning Hierarchy, 6-4, 6-5, 6-6, 6-8, 6-8
Sales versus Quota, 6-3
Volume Breakdown, 6-4

Sun JRE, 6-2
synchronization

between views, 5-3, 5-7, 13-23
syndicated data, 1-1

T
tabs versus windows

for separate worksheets, 5-1
for worksheet views, 5-3

task
configuring My Tasks, 6-13



Index-8

creating and sending, 6-9
marking as done, 6-9

territory
introduction, 2-5
managing funds and quotas, 7-3
tracking volume, 8-2
viewing fund balances, 9-3

Territory-Retailer level
maintaining, 16-34
purpose, 16-24

time level and time axis, 5-4
time resolution, specifying for worksheet, 13-9
Top/Bottom filter, specifying, 13-6
TopCoefficientLevel parameter, 16-39
TPM

worksheets of, 1-3
TPMO, logging on, 3-1
triggers, reference information, 16-35
troubleshooting

cannot see new promotion, 3-6
Ttl Evt $, 16-20
Ttl Evt $ O, 16-20
Ttl Evt $ P, 16-20
Ttl Evt $ Rtl, 16-21
Ttl Evt Vol, 16-21
Ttl Evt Vol O, 16-21
Ttl Evt Vol P, 16-21
Ttl Fcst, 16-21
Ttl Fund Auth, 16-21
Ttl Fund Bal, 16-21

U
undo, 4-2
Units, 16-21
units of measure

introduction, 13-14
in worksheet, 13-14

Unmatched $, 16-21
Uplift, 16-21
user

access to series, 14-11
adding to groups, 14-12
changing password, 3-8
creating, 14-9
deleting, 14-13
filtering data, 14-11

forcing logout, 3-7
IDs and passwords for the demo, 15-3
specifying modules, 14-10

V
Veh $, 16-21
Veh $ O, 16-22
Vehicle Cost DISPLAY, 16-22
Vehicle Cost F. SHOPPER, 16-22
Vehicle Cost FEATURE, 16-22
Vehicle Cost NATIONAL TV, 16-22
Vehicle Cost TPR, 16-22
Veh Type, 16-22
Veh Type O, 16-22
Veh Type P, 16-22
view

adding to worksheet, 13-23
and worksheet, 5-3
defining layout, 13-20, 13-20
deleting from worksheet, 13-24
enabling or disabling, 13-23
hiding worksheet levels, 13-21
introduction, 5-3
managing elements of, 5-4
managing position and size, 5-3
renaming, 13-23
restoring default layout, 13-22
synchronization, 13-23

volume
actual versus plan, 6-3
breakdown, 2-9, 6-4, 7-3
breakdown week by week, 8-4
creating for newly entered promotion, 10-3
for past and future, 2-9
series, 7-3
tracking, 8-1
used in accruing funds, 2-8, 7-2
week by week, 8-3
year on year, 8-2

Volume Base, 16-22
Volume Base Ttl, 16-23
Volume Breakdown summary pane, 6-4
Volume Incr Ttl, 16-23
Volume Tracking worksheet, 8-1, 8-2, 8-5

W
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Web server, launching workflows when starting, 
14-6
Whoxd5 s Online, configuring, 6-11
windows versus tabs

for separate worksheets, 5-1
for worksheet views, 5-3

workflow
email addresses used in, 14-9
reference information, 16-36
schema instances

launching at Web server start, 14-6
scheduling, 14-4
starting, 14-3
stopping, 14-7

Workflow Manager, logging on, 14-3
worksheet

adding notes, 4-13
adding to My Worksheets, 6-14
closing, 5-2
copying to Excel, 4-6
data in, 2-2
deleting, 13-28
deleting notes, 4-13
design

adding a subtab worksheet, 13-25
aggregating and organizing, 13-11
basics, 13-4
caching, 13-5
exception filter, 13-18
filtering individual view, 13-26
index used in, 13-14
selecting series, 13-7
specifying elements to include, 13-24
time criteria, 13-9
tips, 13-28
units of measure, 13-14
views in, 13-20

displaying multiple, 5-1
editing notes, 4-13
exporting to Excel, 4-6
how aggregated and organized, 2-1
layout, 13-20
linking via Dynamic Open Link (DOL), 4-7
notes in, 4-13
ownership and security, 13-28
printing, 4-10
Promotion History, 12-17

saving definition, 5-6, 5-7
sending as task to another user, 6-9
sorting data, 4-4
specifying note permissions, 4-16

worksheets
general introduction, 1-3
Optimization Comparison, 10-7, 10-10
Planning Environment, 9-1, 9-14
Promo Effect - Mfg, 11-2, 11-10
Promo Effect - Rtl, 11-14
Promo-Evaluation Mfg, 12-2, 12-9
Promo-Evaluation Rtl, 12-5, 12-13
Promotion Comparison, 11-8, 11-17
Quota and Fund Entry Bottom-Up, 7-6, 7-10
Quota and Fund Entry Top-Down, 7-3, 7-8
Quota and Fund View, 7-7, 7-10
Volume Tracking, 8-1, 8-5

World Brands
introduction to company, 15-2
users, 15-3

X
x-axis

and default table sorting, 4-4
specifying, 13-20

Y
y-axis

specifying, 13-20
units and scale, 13-14
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