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Preface 
The Oracle|Agile documentation set includes Adobe® Acrobat™ PDF files. The Oracle Technology 
Network (OTN) Web site (http://www.oracle.com/technology/documentation/agile.html) contains the 
latest versions of the Oracle|Agile PLM PDF files. You can view or download these manuals from 
the Web site, or you can ask your Agile administrator if there is an Oracle|Agile Documentation 
folder available on your network from which you can access the Oracle|Agile documentation (PDF) 
files. 

Note To read the PDF files, you must use the free Adobe Acrobat Reader™ version 7.0 or later. 
This program can be downloaded from the Adobe Web site (http://www.adobe.com). 

The Oracle Technology Network (OTN) Web site 
(http://www.oracle.com/technology/documentation/agile.html) can be accessed through Help > 
Manuals in both the Agile Web Client and the Agile Java Client. If you need additional assistance or 
information, please contact support (http://www.oracle.com/agile/support.html) 
(http://www.oracle.com/agile/support.html) for assistance. 

Note Before calling Agile Support about a problem with an Oracle|Agile PLM manual, please 
have ready the full part number, which is located on the title page. 

TTY Access to Oracle Support Services 

Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services within the 
United States of America 24 hours a day, 7 days a week. For TTY support, call 800.446.2398. 
Outside the United States, call +1.407.458.2479. 

Documentation Accessibility  

Our goal is to make Oracle products, services, and supporting documentation accessible, with good 
usability, to the disabled community. To that end, our documentation includes features that make 
information available to users of assistive technology. This documentation is available in HTML 
format, and contains markup to facilitate access by the disabled community. Accessibility standards 
will continue to evolve over time, and Oracle is actively engaged with other market-leading 
technology vendors to address technical obstacles so that our documentation can be accessible to 
all of our customers. For more information, visit the Oracle Accessibility Program Web site at 
http://www.oracle.com/accessibility/ http://www.oracle.com/accessibility/.  

Readme 

Any last-minute information about Oracle|Agile PLM can be found in the Readme file on the Oracle 
Technology Network (OTN) Web site (http://www.oracle.com/technology/documentation/agile.html). 

Agile Training Aids 

Go to the Oracle University Web page 
(http://www.oracle.com/education/chooser/selectcountry_new.html) for more information on Agile 
Training offerings. 

http://www.oracle.com/technology/documentation/agile.html
http://www.adobe.com/
http://www.oracle.com/technology/documentation/agile.html
http://www.oracle.com/agile/support.html
http://www.oracle.com/agile/support.html
http://www.oracle.com/accessibility/
http://www.oracle.com/accessibility/
http://www.oracle.com/technology/documentation/agile.html
http://www.oracle.com/education/chooser/selectcountry_new.html


 

Accessibility of Code Examples in Documentation  

Screen readers may not always correctly read the code examples in this document. The 
conventions for writing code require that closing braces should appear on an otherwise empty line; 
however, some screen readers may not always read a line of text that consists solely of a bracket or 
brace.  

Accessibility of Links to External Web Sites in Documentation  

This documentation may contain links to Web sites of other companies or organizations that Oracle 
does not own or control. Oracle neither evaluates nor makes any representations regarding the 
accessibility of these Web sites.  
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Chapter 1 

Introducing Viewer 

This chapter includes the following: 

 How to Use this Manual....................................................................................................................................... 7 
 Getting Help......................................................................................................................................................... 8 
 About Viewer ....................................................................................................................................................... 8 
 What's New in this Release ................................................................................................................................. 9 
 Viewer Window.................................................................................................................................................... 9 
 Understanding the Viewer ................................................................................................................................... 10 

 
 

How to Use this Manual 
This manual is a supplement to Agile Viewer online Help. It is intended to be used in conjunction 
with the viewer online help and other Oracle|Agile manuals. 

The viewer has been integrated into the Agile system to make use of the Agile’s ability to manage 
attached files by using Agile system features. The integration also streamlines the viewer menus, 
toolbars, and shortcuts. The following table shows where you can find information about Agile 
features and concepts which you may find useful. 

Feature  or  concept  Conta ined  in  th is  document  How to  f ind  the  
document  

Java Client navigation Getting Started with Agile PLM,  
Chapter 2, “Navigation in Java Client” 

Web Client navigation Getting Started with Agile PLM,  
Chapter 3, “Navigation in Web Client” 

Relationships and references between 
objects 

Getting Started with Agile PLM,  
Chapter 5, “Working with Business Objects” 

Attachment files Getting Started with Agile PLM, 

Chapter 9, “Working with Attachments” 

and 
Chapter 10, “Working with Files File Folders” 

Choose Help > Manuals 
in the Java Client or Web 
Client menu bar. On the 
documentation web 
page, click Getting 
Started Guide in the list 
of user manuals. 

 

Working with file folder objects 

File folder mass update 

Routing and reviewing file folders 

File validation (Handle Check Sum) 

Viewing and redlining attachment files 

Product Collaboration User Guide, Chapter 5, 
“Changes” 

Choose Help > Manuals 
in the Java Client or Web 
Client menu bar. On the 
documentation web 
page, click Product 
Collaboration in the list 
of user manuals. 
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Feature  or  concept  Conta ined  in  th is  document  How to  f ind  the  
document  

Viewing and redlining file folder contents 

Redlining through ECOs, MCOs and 
SCOs 

 
 

Getting Help 
To get help at any time, choose Help > Contents in the Agile Viewer menu bar. The viewer online help 
is displayed; it includes detailed information about using viewer features. 

Note See “Agile-specific Features and Functions (on page 15)” for a complete list of features 
and user interface details described in the viewer online Help that have been modified in 
order to integrate the viewer with the Agile system. 

 

About Viewer 
Viewer can display many different file formats without their authoring applications. You can view 
files from many database, graphic, spreadsheet, word-processing, and 2D CAD applications. Even 
archive files can be listed and viewed without the need to decompress them. It isn’t necessary for 
you to identify the file type; Viewer automatically identifies the type of file you are requesting it to 
read. An Agile administrator determines which types of files can be viewed by setting the Supported 
File Types property or, for Advanced Viewer, the Valid Model File Type property.       

Important To view files through the Advanced Viewer, you need Agile Discovery, Read, and 
ViewFile privileges. To redline files through the Advanced Viewer, you need the 
Attachment Redlines privilege. 

The action of attaching your comments, notes, and drawings to a document is known as marking 
up, also commonly known as annotating or redlining. A markup refers to the change being made to 
a document by attaching a markup object. You can use Viewer to mark up files as well as view 
them. 

Note Agile Java Client and Agile Web Client support attachment redlining. Markups for ECOs 
can be made on the Redline Attachments tab in Java Client and Web Client. You access the 
appropriate redline tab on the Affected Items tabs of ECOs. Markups for a file folder object 
can be made on the Files tab of the file folder object in Java Client and Web Client and do 
not require an ECO. 

Some of Viewer’s features are: 

 Flexible user-defined objects — Viewer offers a vast selection of markup objects, including circles, 
clouds, polygons, and arrows. Text can be attached to objects, and lengthier comments can be 
contained in embedded notes. 

Page - 8 Agile Product Lifecycle Management 

 

 



 Chapter 1  
 
 

See Viewer online help for a detailed discussion of markup objects. Choose Help > Contents in 
the Viewer menu bar. 

 Storage of unedited original documents — Original documents are never changed. All your notes 
and drawings are saved in a separate file called a markup file, although when viewed they 
appear to be part of the main document. You do not have to manage the storage and retrieval 
of markup files; Agile does that for you. 

 Support for non-English languages and operating systems — Viewer works with many non-English 
languages, and has been tested on Japanese, Chinese, French, German, Hebrew, and 
Swedish operating systems. 

 

What's New in this Release 
The following new features have been added to this release: 

 Improved usability of the View Compare by Search features, which include the ability to select 
file folder files for comparison by version and to select item attachment files for comparison by 
released item revision. 

 The ability to view the files in a multiple-file file folder as a complete assembly in one viewer 
window.  

 In the Version History window, which is accessed by clicking the Show Versions button on the 
business object Attachments tab, the View menu now includes Compare and Overlay functions. 
This allows you to conveniently compare or overlay different versions of the same file. 

 

Viewer Window 
You can start the Viewer from either the item Attachments tab or the file folder Files tab. 

To start the Viewer in Java Client: 

Double-click the attachment row. 

Or 

1. Select one or more rows. 

2. Click the View File(s) button’s drop-down arrow and select View  from the menu. 

Note If the View  icon is visible on the button, you can simply click the button. 

To start the Viewer in Web Client: 

Click the file name link in the table. 

Or 

1. Select one or more rows. 

2. Click the View File(s) button’s drop-down arrow and select View  from the menu. 

Note If the View  icon is visible on the button, you can simply click the button. 

When you start Viewer, the main Viewer window appears.         
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Note For more information about starting the Viewer, see “Opening Agile Attachment Files in 
the Viewer (on page 15)”. 

 

Viewing an Attachment Tab Row with Multiple Files 

When viewing files from the Attachments tab of an Agile business object, if you view a single row that 
refers to a multiple-file file folder, the Select Files window appears. The Select Files window lists the 
files in that file folder and allows you to select one or more files that you want to view. 

Note For more information about starting the Agile Viewer, see “Opening Agile Attachment 
Files in the Viewer (on page 15)”. 

 

Understanding the Viewer 
The following sections describe the main Viewer window and performance modes, plus other 
information needed to use Viewer. 

Viewer Modes 

Viewer has two performance modes: View and Markup. 

View Mode 

When a document is first opened from business object’s Attachments tab or file folder Files tab, the 
menu bar and toolbars are those of View mode. View mode is Agile Viewer’s default mode. 
Documents can be edited or marked up only from Markup mode, described in the next section.      

Markup Mode 

When Agile Viewer is in Markup mode, the currently displayed document can be marked up. That 
is, you can redline or annotate it. Available markup objects include various shapes, notes, symbols, 
and text. When you open Agile Viewer from the Redline Attachments tab or Files tab in a file folder 
object, Agile Viewer opens either in View or Markup mode, depending on whether the attachment 
has a saved markup and the privileges assigned to the user. If the attachment is checked out, then 
the redlining will not be allowed, however, you can change to Agile Viewer Markup mode to display 
saved markup. For instructions on how to enter Markup mode from View mode, see “Guidelines for 
Marking Up or Redlining Attachments (on page 17)”. When you open a markup file, Markup mode 
starts automatically. 

Note Markup mode is available in the viewer only when the viewer is opened from tabs where 
markups are allowed: from a change order’s Redline Attachments tab and from the Files tab 
of a file folder. In addition, you must have the appropriate Attachment Redlines for Self 
privilege. Contact your Agile administrator if you have questions about your assigned roles 
and privileges. 

 

Viewer Window Components 

There are a few basic components to the Viewer work environment, shown in the following figure. 
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These differ according to whether Viewer is in View mode or Markup mode. 

 
 

Menu Bar 

The menu bar at the top of the window is the main access to all of the menu commands. The 
selection of available commands changes according to the mode the viewer is in and the task that 
you’re performing.      

Toolbars 

The tool buttons under the menu bar offer easy access to the basic commands presented in the 
menu bar. As with menu commands, the selection of available toolbar buttons changes according to 
the mode the viewer is in and the task that you’re performing.       

Status Bar 

In both View mode and Markup mode, there is a status bar located at the bottom of the main 
window. The fields from left to right for each mode’s status bar are as follows:  markers (see the 
following list), current active file name, file type, zoom factor, current page and total number of 
pages, current active file size, date of the file’s creation, and the pointer’s coordinate position. 

The following types of markers can appear on the status bar: 

 A red light bulb marker indicates that the current active file has associated markup files. While in 
View mode, click the markup from the File menu to view the Markup Files dialog box. Then 
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select a markup file or group of markup files to open. When you open a markup file, Markup 
mode starts automatically.       

 A red exclamation mark indicates that some main resources required to properly read the current 
active document are not available (for example, missing fonts or missing CAD files). To quickly 
identify the missing resources, click the red exclamation mark, and the File Properties dialog 
box appears. 

 The Join Session  button, which indicates that you have been invited to join a Collaboration 
session. 

 

Moving Objects 

You can use the left mouse button to click and drag.       

 In View mode — By default, drag to perform an autozoom of all supported file formats (including 
raster and vector files). Select the area you want to enlarge. 

 In Markup mode — If objects are selected, drag to modify and move objects. If no objects are 
selected, drag to perform an autozoom (same as in View mode). 

To select an object, click it. Selected objects are framed by a text box. Modify the size of the 
object by dragging the frame handles. To move an object, move the cursor to the borders (the 
edges) of the markup entity until the cursor turns into a hand pointer. Drag the hand pointer to a 
new location. 

Accessing Commands with Shortcut Menus 

The easiest and quickest way to access most of Agile Viewer’s functions is using the shortcut 
menus. Simply right-click with the pointer over the View window to access appropriate commands. 

In View mode, use these commands: 

 Zoom Fit — to automatically fit the document to the width of the view window. 

 Zoom Previous — to automatically return to your previous zoom level. 

 Zoom Page Width — to automatically fit the document to the width of the view window. 

 a 
new one. The Markup command is available in View mode only when markups are allowed. 

 ct the type of fill to apply to your markup object: Solid Fill, No Fill, or 

 ch layers are visible or active, change layer color, add new layers, 

Markup/Exit Markup — to enter and exit Markup mode and open an existing markup or create 

In Markup mode, use these additional commands: 

 Line Style — to select a style of line to use in your markup. 

 Line Thickness — to select a line thickness for use in your markup. 

Fill Type — to sele
Transparent Fill. 

 Entity Color — to select a color for your markup object. 

 Order — to select the overlay order when several markups are being displayed simultaneously. 

Markup Layers — to select whi
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and rename existing layers. 
 

Canceling an Operation in Progress 

For example, if while drawing a box you realize that you would prefer to draw a cloud, right-click 

 you have already drawn a box, you can either choose Edit > Undo from the menu bar or select the 
ox and press the Delete key on your keyboard. What has already been drawn is erased. 

 

while drawing the box and the box is erased from the display. 

If
b
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Chapter 2 

Agile-specific Features and Functions 

This chapter includes the following: 

 Opening Agile Attachment Files in the Viewer..................................................................................................... 15 
 Marking Up — How It Works ............................................................................................................................... 17 
 Guidelines for Marking Up or Redlining Attachments .......................................................................................... 17 
 Marking Up Documents ....................................................................................................................................... 20 
 2D Features and Functions ................................................................................................................................. 21 
 EDA Features and Functions............................................................................................................................... 21 
 3D Features and Functions ................................................................................................................................. 22 
 Cross Probing ...................................................................................................................................................... 23 
 Comparing Files................................................................................................................................................... 25 
 Overlaying Files ................................................................................................................................................... 27 
 Working with Schematic and PCB Files .............................................................................................................. 29 
 Real-Time Collaboration ...................................................................................................................................... 29 
 Digital Mockup ..................................................................................................................................................... 30 

 
 

Opening Agile Attachment Files in the Viewer 
You can view files from either the Attachments tab of a business object or from the Files tab of a file 
folder object. 

Viewing Files From Java Client 

To view a file from Java Client, Attachments tab: 

1. Go to the Attachments tab of a business object that references the file. 

2. Double-click the attachment row. 
 If the attachment row refers to a file folder with only one file, the Viewer opens and 

displays that file. 
 If the attachment row refers to a multiple-file file folder, the Select Files window appears. 

Select one or more files to view and click OK. The Viewer opens and displays the files you 
selected. 

Or, you can use the Attachment tab View File(s) button: 

1. Go to the Attachments tab of a business object that references the file. 

2. Select one or more attachment rows. 

3. Click the View File(s) button’s drop-down arrow and select View  from the menu.  

Note If the View  icon is visible on the button, you can simply click the button. 
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 nt row that refers to a file folder with only one file, the Viewer 

 s 
more files to view and Click OK. The Viewer opens and 

  the 
 the viewer. The Select Files window does not appear. 

taining the files you want to view. 

2. . 

e file. 

View File(s) button’s drop-down arrow and select View 

If you selected one attachme
opens and displays that file. 
If you selected one attachment row that refers to a multiple-file file folder, the Select File
window appears. Select one or 
displays the files you selected. 
If you selected more than one attachment row, the Viewer opens and all the files in all
selected rows are displayed in

To view a file from Java Client, Files tab: 

1. Go to the Files tab of a file folder object con

Double-click the filename in the file table

The Viewer opens and displays th

3. Or, select one or more file rows. 

4. Click the tab menu  from the menu.  

Note If the View  icon is visible on the button, you can simply click the button. 

The Viewer opens and displays the selected files. 

Viewing Files From Web Client 

t references the file. 

2. 
 

 
ore files to view and click Finish. The Viewer opens and displays the files 

y

ct that references the file. 

To view a file from Web Client, Attachments tab: 

1. Go to the Attachments tab of a business object tha

Click the file name link in the attachments table. 
If the attachment row refers to a file folder with only one file, the Viewer opens and 
displays that file. 
If the attachment row refers to a multiple-file file folder, the Select Files window appears. 
Select one or m
you selected. 

Or, ou can use the Attachment tab View button: 

1. Go to the Attachments tab of a business obje

2. Select one or more attachment rows. 

3. Click the View button’s drop-down arrow and select  View from the menu.  

Note If the View  icon is visible on the button, you can simply click the button. 

 If you selected one attachment row that refers to a file folder with only one file, the Viewer 
opens and displays that file. 
If you selected one attachment r ow that refers to a multiple-file file folder, the Select Files 

 If you selected more than one attachment row, the Viewer opens and all the files in all the 
selected rows are displayed in the viewer. The Select Files window does not appear. 

window appears. Select one or more files to view and click OK. The Viewer opens and 
displays the files you selected. 
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To view a file from Web Client, Files tab: 

1. Go to the Files tab of a file folder object containing the files you want to view. 

2. Click the filename link in the file table. 

3. The Viewer opens and displays the file. 

4. Or, select one or more file rows. 

5. Click the tab menu View button’s drop-down arrow and select  View from the menu. 

Note If the View  icon is visible on the button, you can simply click the button. 

The Viewer opens and displays the selected files. 

Ad Hoc Markups 

Ad hoc 2D, 3D, and EDA/ECAD markup can be done from the Files tab in the file folder object. 
Change order-controlled 2D, 3D, and EDA/ECAD markup can be done from the Redline Attachments 
tab in the ECO. When you view a markup file, the original document, also known as the base file, 
opens too. 

Note Change order-controlled and ad hoc markups are independent from each other. 

To view change order-controlled markups, open the redlined file from the appropriate revision of the 
item Attachments tab or from the change order Redline Attachments tab (see “Viewing ECO Redlines 
from the Attachments Tab of the Item Pending Revision (on page 20)”. 

To view ad hoc markups, open the redlined file from the file folder object Files tab. 

Marking Up — How It Works 
Marking up refers to drawing and writing in an electronic document. With Agile Viewer, your original 
document remains unchanged because your markups are saved in separate markup files. When 
you view a markup file, Agile Viewer loads the markups into memory and lays them over the original 
document.       

There can be as many markup files as you wish for a document because each has its own unique 
filename. This allows several individuals to mark up the same document at the same time because 
a unique markup file is created for each person’s work. With the markup information attached to 
each markup file, you can even tell who created each markup. 

Markup files are divided into uniquely named layers. Create, name, and color the layers to organize 
your work as you like. For example, different colors could indicate time priorities, and each layer 
could contain markups relating to a common purpose. Markup files are stored with other attachment 
files in the file vault, part of Agile File Manager (AFM). Markup files are managed by Agile and are 
automatically retrieved and presented when you view the redlined document. 

Guidelines for Marking Up or Redlining Attachments 
With appropriate privileges, you can redline Microsoft Office documents, 2D, 3D, and EDA files on 
the Files tab of a file folder object and redline 2D, 3D, and EDA files on the Redline Attachments tab, 
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accessible from the Affected Items tab of an ECO.      

Note You can create and edit file markups only through the Affected Items tab of an ECO or the 
Files tab of a file folder object. Your Agile administrator must give you privileges that allow 
you to mark up or redline attachments. For more information about ECOs and file folder 
objects, see Getting Started with Agile PLM. 

 

Java Client 

To mark up or redline an attachment file from an ECO in the Java Client: 

1. If you have not already done so, add an item with an attachment to the Affected Items tab of an 
unreleased ECO. The item now has a pending revision associated with the unreleased ECO. 

Note When redlining an attachment through an ECO, the pending revision 
attachment Folder Version must be set to a specific version number; if the 
Folder Version is set to LATEST-x, you will not be able to create redline 
markups. However, you can edit the Folder Version on the Attachments tab of 
the pending revision so that it refers to a specific Folder Version. 

For example, if the pending revision of the item refers to Folder Version LATEST-7 of the file 
folder, select that row on the Attachments tab, click the Edit  button and use the Folder 
Version drop-down list in the Edit dialog box to select 7. Click OK to complete the edit 
process. You will now be able to create redline markups for that attachment.Select the 
added item on the Affected Items tab of the ECO. 

 On the Redline Attachments tab: 
 Select the row containing the file you want to redline and click the View button. 

Or 
 Double-click the row containing the file you want to redline. 

2. When the Viewer appears, click the Markup button. (This button is available only when markups 
are allowed.) 

3. Use the tools described in the viewer online Help to redline the attachment. To view online 
Help, choose Help > Content in the menu bar. 

Note ECO markups are saved against and associated with the pending revision of 
the item. If the ECO is released without first replacing the file, the markups 
appear against the released revision of the item 

To ad hoc mark up or redline an attachment file from a file folder object in the Java Client: 

1. Double-click the row containing the file you want to redline. 

2. When the Viewer appears, click the Markup button. (This button is available only when markups 
are allowed.) 

3. Use the tools described in the viewer online Help to redline the attachment. To view online 
Help, choose Help > Content in the menu bar. 

Note Ad hoc markups are saved against and associated with the version of the file 
folder object. 
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Web Client 

Note If the item or file has already been redlined, then the Has been redlined icon  will be 
displayed in the place of the Do Redlining icon . Click either   or  to initiate 
redlining. 

To mark up or redline an attachment file from an ECO in the Web Client: 

1. If you have not already done so, add an item with an attachment to the Affected Items tab of an 
unreleased ECO. The item now has a pending revision associated with the unreleased ECO. 

Note When redlining an attachment through an ECO, the pending revision 
attachment Folder Version must be set to a specific version number; if the 
Folder Version is set to LATEST-x, you will not be able to create redline 
markups. However, you can edit the Folder Version on the Attachments tab of 
the pending revision so that it refers to a specific Folder Version. 

For example, if the pending revision of the item refers to Folder Version LATEST-7 of the file 
folder, select that row on the Attachments tab, click the Edit button and use the Folder Version 
drop-down list to select 7. Click Save to complete the edit process. You will now be able to 
create redline markups for that attachment.On the Affected Items tab, click the Do Redlining 
icon for that item to open the Redlines page. 

2. On the Redline Attachments tab, click the Do Redlining button   (or Has been redlined button ) 
on the row of the file you want to redline. (This button is available only when markups are 
allowed. 

3. On the Affected Items tab, click the Do Redlining icon next to the item to open the Redlines 
page. 

4. Use the tools described in the viewer online Help to redline the attachment. To view online 
Help, choose Help > Content in the menu bar. 

Note ECO markups are saved against and associated with the pending revision of 
the item. If the ECO is released without first replacing the file, the markups 
appear against the released revision of the item 

To ad hoc mark up or redline an attachment file from a File Folder object in the Web Client: 

1. On the Files tab of a file folder object, click the Do Redlining button  (or Has been redlined button 
) on the row of the file you want to redline. (This button is available only when markups are 

allowed.) 

2. Use the tools described in the viewer online Help to redline the attachment. To view online 
Help, choose Help > Content in the menu bar. 

Note Ad hoc markups are saved against and associated with the version of the file 
folder object. 

 

Redlining Markups for Change Orders 

The change order redlines of 2D, 3D, and EDA files are based on the pending revision of the item. 
The markup changes are visible from either the change orders’s Redline Attachments tab or from the 
pending revision item Attachments tab. 
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Important 3D features and access to 3D files are available only with Agile Advanced Viewer. 
Features for schematic and PCB files, also referred to as EDA files, are available only with 
the Agile Advanced Viewer. In order to use these features, your company must have the 
View and Mark Up (3D) server license, which provides access to Advanced Viewer 
functions. For more information about server licenses, see the Administrator Guide. 
Contact your Agile Account Executive or reseller to obtain a license. 

 
 

Viewing ECO Redlines from the Attachments Tab of the Item Pending Revision 

You can view the change order markup redlines of the pending revision by displaying the 
Attachments tab of the item pending revision, for example, revision (C) ECO000453. The redlined file is 
indicated by the Has been redlined  icon. 

 In Java Client, select the redlined file you want to view and click the View File(s)  button. 

 In Web Client, click the Has been redlined button in the row of the file you want to view. 

If you have checked out the redlined file and checked in a new version from the Attachments tab, the 
Has been redlined icon does not appear on the Attachments table. 

To view the redlines of previous versions in Java Client: 

1. On the Attachments tab of the pending revision, select the row you want to view. 

2. Click the Show Versions button. The Versions dialog appears. 

3. On the version row for which you want to view redlines, double-click the Has been redlined  
button. 

To view the redlines of previous versions in Web Client: 

1. On the Attachments tab of the pending revision, click the Show Versions button in the row you 
want to view. The Versions dialog appears. 

2. On the version row for which you want to view redlines, double-click the Has been redlined  
button. 

Note If you need to determine which file folder version is associated with the change 
order redlines, refer to the change order History tab. 

However, if the attachment file on the pending revision item is not replaced prior to the change 
order release, the redlines will be accessible from the released revision of the item. The following 
diagram shows an example of the change order attachment redlining process. 

(See also Product Collaboration User Guide and Getting Started with Agile PLM.) 
 

Marking Up Documents 
For information about working with markups, including markup layers and markup objects, refer to 
the viewer online help. Choose Help > Contents in the Agile Viewer menu bar. 
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Tips for Marking Up Documents 

If you exit the Agile viewer without saving, you will lose any redline you have added to the 
attachment. 

Attaching Information to Markup Files 

In Markup mode, the Markup > Information command displays the Markup Information dialog box with 
five information fields attached to the current active markup file.    

Entity Rotate 

Entity Rotate allows you to rotate symbol markup objects. 

To rotate a symbol markup object: 

1. Select the symbol markup object you want. 

2. Click the Rotate Entity button, or choose Markup > Entity Rotate. 

When this feature is activated, the Rotate Entity button appears as a recessed button (light gray) 
on the toolbar. 

3. Place the cursor on one of the corner squares that indicate the selected object. 

4. When you see the crossed-arrows cursor (pointing in four directions), hold down the left mouse 
button and adjust the rotation angle of the object. 

5. Release the mouse button when you are finished adjusting the rotation angle. 

 
 

2D Features and Functions 
For information about working with 2D files, including CAD views and measuring objects, refer to 
the viewer online help. Choose Help > Contents in the Agile Viewer menu bar. 

EDA Features and Functions 
Agile Advanced Viewer EDA features include: 

 Ability to view all relevant EDA formats including artwork formats, PCB/IC layouts, schematics 
and manufacturing formats 

 Cross probe between a PCB layout and related schematics (see “Cross Probing (on page 23)”). 

 Verify design by testing for manufacturability or design violation. 

 Generate and export Bills of Material in a variety of formats. 

For detailed information about all the EDA features, refer to the viewer online help. Choose 
Help > Contents in the Viewer menu bar. 

Important EDA features and access to EDA files are available only with Agile Advanced Viewer. In 
order to use these features, your company must have the View and Mark Up (3D) server 
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license, which provides access to Advanced Viewer functions. For more information about 
server licenses, see the Administrator Guide. Contact your Agile Account Executive or 
reseller to obtain a license. 

 
 

3D Features and Functions 
For information about working with 3D files, including light settings and models, refer to the viewer 
online help. Choose Help > Contents in the Viewer menu bar. 

Important 3D features and access to 3D files are available only with Agile Advanced Viewer. In order 
to use these features, your company must have the View and Mark Up (3D) server 
license, which provides access to Advanced Viewer functions. For more information about 
server licenses, see the Administrator Guide. Contact your Agile Account Executive or 
reseller to obtain a license. 

 
 

Understanding 3D Basics 

3D CAD assemblies are made up of many files dependent one upon another. For example, a 
SolidWorks or Pro/E CAD design consists of at least one assembly file and one or more part files. 
The 3D files are used primarily in manufacturing departments for drawing the blueprint of the new 
instrument. 3D files may be added to the Files tab in one or several file folder objects.  

 One File Folder 

Add all files in one CAD assembly are added to the Files tab of one file folder. When you view 
the assembly, Agile prompts you to identify the top file in the assembly and the complete 
assembly is displayed in the Viewer. 

 Multiple File Folders 

The assembly file is added to the Files tab in one file folder object, and parts files can be 
referenced by adding other file folder objects containing the files as relationships with no rules 
to the Relationships tab of the assembly’s file folder object.  

3D files can be redlined both through a change order (Redline Attachments) and on the Files tab of 
the file folder object. 

Viewing 3D CAD Assemblies in a Multiple-file File Folder from Java Client 

To view a CAD assembly from Java Client, Attachments tab: 

1. Go to the Attachment tab of the business object that references the assembly. 

2. Double-click the multiple-file attachment row that references the CAD assembly. The Select 
Files window appears. 

Note A multiple-file attachment row is indicated by a file folder icon in the Filename 
field, followed by the filenames of all the files in the file folder. 

Or use the Attachment tab View File(s) button: 
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a. On the business object Attachments tab, click to select the multiple-file attachment row. 

b. Click the View File(s) button's  drop-down arrow and select View from the menu. 

3. In the Select Files window, click the radio button to select the option View all files as an assembly, 
starting from the selected file. 

4. Click to select the file row of the assembly file that indicates the top or starting file of the 
assembly. 

5. Click OK. 

To view a CAD assembly from Java Client, Files tab: 

1. Go to the Files tab of a file folder object containing the CAD files for the assembly that you want 
to view. 

2. Click to select the row for the top or starting file of the assembly. 

3. Click the View File(s) button's  drop-down arrow and select View As Assembly from the menu. 

 
 

Viewing 3D CAD Assemblies in a Multiple-file File Folder from Web Client 

To view a CAD assembly from Web Client, Attachments tab: 

1. Go to the Attachment tab of the business object that references the assembly. 

2. Click the multiple-file attachment row that references the CAD assembly. The Select Files 
window appears. 

Note A multiple-file attachment row is indicated by a file folder icon in the Filename 
field, followed by the filenames of all the files in the file folder. 

Or use the Attachment tab View File(s) button: 
a. On the business object Attachments tab, click to select the multiple-file attachment row. 

b. Click the View File(s) button's  drop-down arrow and select View from the menu. 

3. In the Select Files window, click the radio button to select the option View all files as an assembly, 
starting from the selected file. 

4. Click to select the file row of the assembly file that indicates the top or starting file of the 
assembly. 

5. Click Finish. 

To view a CAD assembly from Web Client, Files tab: 

1. Go to the Files tab of a file folder object containing the CAD files for the assembly that you want 
to view. 

2. Click to select the row for the top or starting file of the assembly. 

3. Click the View File(s) button's  drop-down arrow and select View As Assembly from the menu. 
 

Cross Probing 
Cross probing is also described in the viewer online Help. In Agile, this feature is initiated from 
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either the business object Attachments tab or the file folder Files tab rather than from the viewer 
menus. For detailed information about cross probing features, see the Viewer online help. Choose 
Help  > Contents in the viewer menu bar. 

Important Cross probing features are available only with Agile Advanced Viewer. In order to use 
these features, your company must have the View and Mark Up (3D) server license, 
which provides access to Advanced Viewer functions. For more information about server 
licenses, see the Administrator Guide. Contact your Agile Account Executive or reseller to 
obtain a license. 

Use cross probing to interrogate ECAD schematic and layout files in separate viewer windows. 

Note The Agile administrator should specify the ECAD file extension in the Valid Model File Type 
field for you to view the ECAD files. 

You can select both needed files from the same Attachments tab or the same file folder Files tab from 
which you launch the Cross Probe action. Or, you can select one file on the current tab and then 
search for the remaining file from the attachments of any other object. 

The View > By Search > Crossprobe option allows you to find other files in the system, which you may 
want to use to cross probe, without having to select two files from the same Attachments tab or Files 
tab; that is, you can search and select one attached file from Part 234 and another attached file 
from Part 765. 

Alternatively, you can view a single ECAD file then initiate cross probing within the viewer by adding 
another file from your desktop. 

To run Cross Probing: 

1. Display the Attachments tab or the Files tab. 

2. Select both file rows you want to work with and choose:  
 Java Client: View File(s)  > Cross Probe. 
 Web Client: View > Cross Probe. 

Each file is displayed in a separate viewer window. 

3. Begin cross probing. 

See Viewer online help for more information about cross probing. Choose Help > Contents in the 
Viewer menu bar. 

 

Cross Probing in Java Client and Web Client 

To run Cross Probing: 

1. Display the Attachments tab or the Files tab. 

2. Select both file rows you want to work with and choose:  
 Java Client:  View File(s)  > Cross Probe. 
 Web Client: View > Cross Probe. 

Each file is displayed in a separate viewer window. 

3. Begin cross probing. 
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See Viewer online help for more information about cross probing. Choose Help > Contents in the 
Viewer menu bar. 

2. 
 

earch tabs. 
 

3. 
ents of those objects to use to Cross Probe. 

  search or an advanced search. You can check to 

 
run it. Again, returned results may be moved to the Selecte

 
 shortcuts to only those objects that are 

 
y will not appear on the Recently Visited list of the 

4. Results table, and the related 

6.  multiple searches or shortcuts until you are finished selecting the 

7. 

in a separate viewer window. 

8. 

r more information about cross probing. Choose Help > Contents in the 
Viewer menu bar. 

Comparing Files 

 you initiate file compare from either the file folder Files tab or the 

comparison features, see the Viewer online help. Choose Help > 

To run Cross Probing By Search: 

1. Display the Attachments tab or the Files tab. 

Select a file row you want to work with and choose:  
Java Client: View File(s) > By Search > Cross Probe. 

The Select Files dialog appears, with three S
Web Client:  View  > By Search > Cross Probe. 

The View Files by Search dialog appears, with three Search tabs. 

The search dialog allows you to search for any business object (for example, items or 
manufacturer parts) and select the attachm

Use any of the following search methods: 
Search tab lets you create a simple
search attachment contents, too. 
Saved Searches tab opens to your navigation pane where you can browse in search folders, 
select a search, and d Items 
table, and Click OK. 
Shortcuts tab opens to your navigation pane where you can select objects from My 
Bookmarks or Recently Visited. The system displays
appropriate to the operation you are performing. 

Only business objects with attached files appear in the search results table. For example, a
business object that you viewed recentl
Shortcuts tab if it has no attachments. 

When the results of your search are returned, select a row in the 
files for that object appear in the Related Files table. 

5. In the Related Files table, select and move attachments to the Selected Files table. 

You can continue to run
attachments you want. 

 When you are finished, Click OK. 

Each file is displayed 

Begin cross probing. 

See Viewer online help fo

 

Comparing files is also described in the viewer online Help. In Agile, rather than initiating file 
compare from the viewer menus,
business object Attachments tab. 

For detailed information about file 
Contents in the viewer Menu bar. 
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Important 

Administrator Guide. Contact your Agile Account Executive or reseller to 
obtain a license. 

Markups and Comparing Files 

mode. 

Comparing Files in Java Client and Web Client 

nd compare two files from a single file folder Files tab or a single business object 

2.  choose: 
pare 

re information about compare file features and options, choose Help > Contents in the viewer 

e

f an item . 

 h 

e list of 
 file 

 obj

uctory revisions and unreleased pending revisions do 

Compare file features are available only with Agile Advanced Viewer. In order to use 
these features, your company must have the View and Mark Up (3D) server license, 
which provides access to Advanced Viewer functions. For more information about server 
licenses, see the 

 
 

Markups (redlines) are not supported in the Agile viewer compare 

You can select a
Attachments tab. 

To initiate comparing files: 

1. Display the Attachments tab or the Files tab. 

Select both files you want to work with and
 Java Client: View File(s) > Com
 Web Client: View > Compare 

The files and the comparison results are displayed in a single viewer window. 

For mo
menu bar. 
 

Comparing Files By Search 

Th  View > By Search > Compare command allows you to 

 Compare files from different released revisions o

 Compare files from different file folder versions. 

Select any file on any business object  Attachments tab or on any file folder Files tab, then searc
for a file to use for comparison.  

Depending on your search, you can select a business object, then select a file from th
related files for that object. Or, if you have the appropriate privileges, you can search for
folder ects, then select a file from the list of related files for the selected file folder. 

Note For item objects, Introd
not appear in the related files list.  

2. hoose: 
 Java Client: View File(s) > By Search > Compare 

To initiate comparing files by Search : 

1. Display the Attachments tab or Files tab. 

Select a file row you want to work with and c
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 Web Client: View > By Search > Compare 

The Compare Files By Search dialog appears with three search tabs. 

The search dialog allows you to search for any business object (for example item3. s or 
ents of those objects to compare.  

 ens to your navigation pane where you can browse in search folders, 
tems 

 e you can select objects from My 
 

es appear in the search results table. For example, a 

results table, and the related 
. 

5. In th
Related 

 le displays item 
hme
er o

t 

manufacturer parts) and select the attachm

Use any of the following search methods: 
 Search tab lets you create a simple search or an advanced search. You can check to 

search attachment contents, too. 
Saved Searches tab op
select a search, and run it. Again, returned results may be moved to the Selected I
table, and Click OK. 
Shortcuts tab opens to your navigation pane wher
Bookmarks or Recently Visited. The system displays shortcuts to only those objects that are
appropriate to the operation you are performing. 

Only business objects with attached fil
business object that you viewed recently will not appear on the Recently Visited list of the 
Shortcuts tab if it has no attachments. 

4. When the results of your search are returned, select a row in the 
files for that object appear in the Related Files table

e Related Files table, select the file you want. 
 If the selected search object is a file folder, use the Version drop-down list in the 

Files table to select the file folder version you want. 
If the selected search object is an item, in the Related Files tab
attac nts for each released revision of the item (the file name followed by the revision 
numb r letter, for example, widget.dwg - A and widget.dwg - B). 

Note For item objects, Introductory revisions and unreleased pending revisions do no
appear in the related files list.  

If the selected search object is  a business object, check the Show Matching File Types Only 
lated files that are the same file type as the file you with 

6. ck OK. 

 the 

The files and the comparison results are displayed in a single viewer window. Fore more 
 features and options, choose Help > Content in the viewer menu bar.  

ated from the 

Important 

cess to Advanced Viewer functions. For more information about server 

checkbox to display only the re
which you want to compare.  

 When you are finished, Cli

You can continue to run multiple searches or shortcuts until you are finished selecting
attachments you want. 

information about compare file

Overlaying Files 
Overlaying files is also described in the viewer online Help. In Agile, this feature is initi
file folder Files tab rather than from the viewer menus. For detailed information about file overlay 
features, see the Viewer online help. Choose Help  > Contents in the viewer menu bar. 

Overlaying files features are available only with Agile Advanced Viewer. In order to use 
these features, your company must have the View and Mark Up (3D) server license, 
which provides ac
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licenses, see the Administrator Guide. Contact your Agile Account Executive or reseller to 
obtain a license. 

 

Java Client and Web Client 

1. sp b. 

2.  work with and choose 

w, one on top of the other. For more information 
xample, File > Overlays in the menu bar) and options, choose 

1. 

2. Sele
rlay. 

3. 

, too. 
folders, 

re 
e performing. 

ar on the Recently Visited list of the 

ed 

nd move attachments to the Selected Files table. 

6. 

 

Overlaying Files in 

To initiate overlaying files: 

Di lay the Attachments tab or the Files ta

Select both file rows you want to
 Java Client:  View File(s)  > Overlay . 
 Web Client: View > Overlay. 

The files are displayed in a single viewer windo
about overlay file features (for e
Help  > Contents in the viewer menu bar. 

To initiate overlaying files By Search: 

Display the Attachments tab or the Files tab. 

ct a file row you want to work with and choose: 
 Java Client: View File(s) > By Search > Ove

The Select Files dialog appears, with three Search tabs. 
 Web Client:  View  > By Search > Overlay. 

The View Files by Search dialog appears, with three Search tabs. 

The search dialog allows you to search for any business object (for example, items or 
manufacturer parts) and select the attachments of those objects to use to overlay.  

Use any of the following search methods: 
 Search tab lets you create a simple search or an advanced search. You can check to 

search attachment contents
 Saved Searches tab opens to your navigation pane where you can browse in search 

select a search, and run it. Again, returned results may be moved to the Selected Items 
table, and Click OK. 

 Shortcuts tab opens to your navigation pane where you can select objects from My 
Bookmarks or Recently Visited. The system displays shortcuts to only those objects that a
appropriate to the operation you ar

Only business objects with attached files appear in the search results table. For example, a 
business object that you viewed recently will not appe
Shortcuts tab if it has no attachments. 

4. When the results of your search are returned, select a row in the Results table, and the relat
files for that object appear in the Related Files table. 

5. In the Related Files table, select a

You can continue to run multiple searches or shortcuts until you are finished selecting the 
attachments you want. 
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7. 

The files are displayed in a single viewer window, one on top of the other. For more information 
enu bar) and options, 

 

Work
Important y with 

any must have the 

our Agile Account Executive or reseller to obtain a license. 

 the viewer online help. Choose Help > Contents in the 

and Agile

Important 
s, your company must have the View and Mark Up (3D) server license, 

which provides access to Advanced Viewer functions. For more information about server 
licenses, see the Administrator Guide. Contact your Agile Account Executive or reseller to 

 

 users team up and review documents interactively and 
 

session a

Important 
chment Redlines privileges. If they can view and redline a file, 

 

the collaborators must be logged into Agile 
 
 

 When you are finished, Click OK. 

about overlay file features (for example, Analysis > Overlays in the m
choose Help  > Contents in the viewer menu bar. 

ing with Schematic and PCB Files 
Features for schematic and PCB files, also referred to as EDA files, are available onl
the Agile Advanced Viewer.In order to use these features, your comp
View and Mark Up (3D) server license, which provides access to Advanced Viewer 
functions. For more information about server licenses, see the Administrator Guide. 
Contact y

For information about these features, refer to
Viewer menu bar. 

Real-Time Collaboration 
For detailed information about collaboration features, refer to the viewer online help. Choose 
Help > Contents in the Viewer menu bar. The following sections discuss Agile View server information 

 privileges that affect collaboration sessions. 

Real-time collaboration features are available only with Agile Advanced Viewer. In order to 
use these feature

obtain a license. 

 

Overview of Collaboration Sessions 

The Collaboration feature lets multiple
simultaneously, thus shortening an otherwise lengthy review process where documents are passed
back and forth. The Collaboration feature is available to all users who have Agile Discovery, Read, 
and Attachment Redlines privileges. 

From the Collaboration menu, anyone with the required Agile privileges can initiate a Collaboration 
nd act as host, or join a Collaboration session if invited by the host. 

If you plan to host a Collaboration session, ensure that all intended participants have 
Discovery, Read, and Atta
they have the necessary privileges. If they cannot, contact your Agile administrator, who
can grant them the necessary privileges, before you attempt to initiate the Collaboration 
session. 

In order to participate in the collaboration session, all 
and viewing a file in the viewer when you start the collaboration session. They do not need view the
file you are going to review in the collaboration session; they can view any file. For this reason, they
may choose to view a small file that will load quickly. 
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When the host initiates a Collaboration session, a session object is created on the server, which is 
maintained for the duration of the Collaboration session. Session information is available from the 

ated during the Collaboration session to which all participants can add 
p e

only one who can save it. 

nect to the same Agile Viewer server to use the collaboration feature. 

Collaboration menu during a Collaboration session. It displays the session subject (the name 
assigned to the Collaboration session), the session ID (each session subject is assigned a unique 
session ID), the name of the base file viewed, the host, and the list of users participating. 

A session markup file is cre
marku ntities. Participants are assigned different layer colors for the session so that the markup 
entity from each participant is identifiable. The host for the session owns the markup file and is the 

Note All users must con
 

nment and interference of multiple 
assemblies. You can save the mockup as a redline markup entity. 

eb Client 

1. 

2. 

oaded into the same Viewer workspace. 

r 
d Coordinate Systems, Manipulators, Interference Checking, and Part 

Alignment. 

 viewer online help. Choose Help > Contents in the 

1. ab. 

2. 

oaded into the same Viewer workspace. 

r 
d Coordinate Systems, Manipulators, Interference Checking, and Part 

 viewer online help. Choose Help > Contents in the 

Digital Mockup 
In 3D mode, you can use the Mockup feature (DMU) to test alig

 

Digital Mockup in Java Client and W

To initiate Digital Mockup of files: 

Display the Attachments tab or the Files tab. 

Select all the file rows you want to work with and choose: 
 Java Client: View File(s) > Digital Mockup. 
 Web Client:  View  > Digital Mockup. 

The files are l

3. Manipulate the models using the viewer features including the features in the Analysis menu, fo
example User Define

For information about these features, refer to the
Viewer menu bar. 

To initiate Digital Mockup of files: 

Display the Attachments tab or the Files t

Select all the file rows you want to work with and choose: 
 Java Client: View File(s) > Digital Mockup. 
 Web Client:  View  > Digital Mockup. 

The files are l

3. Manipulate the models using the viewer features including the features in the Analysis menu, fo
example User Define
Alignment. 

For information about these features, refer to the
Viewer menu bar. 
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To initiate Digital Mockup of files By Search: 

1. 

2. Sele
kup. 

rs, with three Search tabs. 

3. 
n

 
, too. 

re 
e performing. 

ar on the Recently Visited list of the 

ted 

d move attachments to the Selected Files table. 

6.  until you are finished selecting the 

oaded into the same Viewer workspace. 

8.  
Coordinate Systems, Manipulators, Interference Checking, and Part 

Alignment. 

For information about these features, refer to the viewer online help. Choose Help > Contents in 
the Viewer menu bar. 

 

Display the Attachments tab or the Files tab. 

ct a file row you want to work with and choose: 
 Java Client: View File(s) > By Search > Digital Moc

The Select Files dialog appears, with three Search tabs. 
 Web Client:  View  > By Search > Digital Mockup. 

The View Files by Search dialog appea

The search dialog allows you to search for any business object (for example, items or 
ma ufacturer parts) and select the attachments of those objects to use for the mockup.  

Use any of the following search methods: 
Search tab lets you create a simple search or an advanced search. You can check to 
search attachment contents

 Saved Searches tab opens to your navigation pane where you can browse in search folders, 
select a search, and run it. Again, returned results may be moved to the Selected Items 
table, and Click OK. 

 Shortcuts tab opens to your navigation pane where you can select objects from My 
Bookmarks or Recently Visited. The system displays shortcuts to only those objects that a
appropriate to the operation you ar

Only business objects with attached files appear in the search results table. For example, a 
business object that you viewed recently will not appe
Shortcuts tab if it has no attachments. 

4. When the results of your search are returned, select a row in the Results table, and the rela
files for that object appear in the Related Files table. 

5. In the Related Files table, select an

You can continue to run multiple searches or shortcuts
attachments you want. 

7.  When you are finished, Click OK. 

The files are l

Manipulate the models using the viewer features including the features in the Analysis menu, for
example User Defined 
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Chapter 3 

Modified and Unavailable Viewer Features 

This chapter includes the following: 

 User Interface Modifications ................................................................................................................................ 33 
 File Storage and Management Modifications ...................................................................................................... 33 
 Opening Files Features ....................................................................................................................................... 34 
 Working with Hyperlinks ...................................................................................................................................... 34 
 Viewer Modes ...................................................................................................................................................... 34 

 
 

User Interface Modifications 
The following features described in the viewer online Help have been modified or have been 
suppressed and are not available. 

 Window menu and its options for viewing multiple files (New, Cascade, Tile Horizontally, and Tile 
Vertically) are not available. (See “Viewing Multiple Files in the Agile Viewer”.)  

 The ability to click and drag toolbars to move them is not available.  

 Mnemonic letter shortcuts (ALT+letter) are not available and are not displayed as underlined 
letters in the menus.  

 Tooltips Quick Menu is not available.  

 The Customize > Options menu selection does not include toolbar and tooltip settings.  
 

File Storage and Management Modifications 
Because the Agile system manages and controls access to attached files and markups (redline 
files), the following features described in the viewer online Help may have been modified or are not 
available to you. 

Many of these modifications relate to how files are opened, saved, and where they are stored. 
Instead of using viewer features (for example, File > Open, as described in the viewer online Help) to 
view files, the files are selected via the Agile object Attachments tab and the file folder Files tab, and 
retrieved from the file vault, part of Agile File Manager (AFM). The files are then displayed in the 
viewer window. When you create and save markup files, they are also saved in the file vault. (See 
“Opening Agile Attachment Files in the Viewer (on page 15)”  and “Guidelines for Marking Up or 
Redlining Attachments (on page 17)”.) 

If you need more information about a viewer feature, see the viewer online Help. To view online 
Help, choose Help > Content in the menu bar. 
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Opening Files Features 
These features described in the viewer online Help are not available: 

 Viewer Startup view (empty viewer window).   

 Drag and drop files from Windows Explorer onto the viewer window to open them.  

 The following viewer File menu selections are not available in the Agile Advanced Viewer: Open, 
Browse, Next File, Previous File, Load File, Open URL, and Close. 

 Archive file directory displayed in viewer window. 

 Import and Export Markup files feature is not available. Import and Export 3D Models is not 
available. 

Access to all files, including markup files, is managed by the Agile system. For more 
information about markup files in Agile, see “Marking Up — How It Works (on page 17)” and 
“Guidelines for Marking Up or Redlining Attachments (on page 17)”.  

Working with Hyperlinks 
Refer to the Agile Viewer online help for details about working with and creating hyperlinks. To view 
the online help, choose Help  > Contents in the viewer menu bar. 

Although you can create hyperlink markup entities, you cannot create hyperlinks to other files in the 
Agile file vault. 

The purpose of this viewer feature is to gather or link related information together. This functionality 
is provided by Agile features such as Attachments tabs (which may have multiple attached file folder 
objects) and Relationships tabs. For more information about file folder objects and attachments see 
Getting Started in Agile PLM. 

Viewer Modes 
The viewer modes Startup View and Thumbnails Mode described in the online Help are not 
available. 
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Chapter 4 

Printing 

This chapter includes the following: 

 Printing Documents from within the Viewer ......................................................................................................... 35 
 Headers/Footers Group in Print Properties ......................................................................................................... 35 
 Watermarks and Banners in Print Properties ...................................................................................................... 36 
 Stamps Group In Print Properties........................................................................................................................ 37 
 Printing DGN Files ............................................................................................................................................... 37 

 
 

Printing Documents from within the Viewer 
For detailed information about printing attachments from the file folder object Files tab, see the 
Getting Started with Agile PLM manual, Chapter 9, “Working with Attachments", and Chapter 10, 
"Working with File folders.” 

For detailed information about printing from the viewer, see the viewer online Help. To view online 
Help, choose Help > Content in the viewer menu bar. 

For information about how the Agile administrator can customize the Viewer print options. see 
“Viewer Administration Tasks (on page 39).” 

The following sections describe print features that have been modified to integrate the viewer with 
the Agile system. 

Headers/Footers Group in Print Properties 
This group defines the headers and footers to be included on every printed page of the document.           

Note These settings are maintained and modified by your Agile administrator. 

To view the header and footer settings: 

Select the Headers/Footers tab. 

A literal percentage mark is indicated by %%. Other codes are as follows: 

 %f = full path of document (for example, D:\PICS\TIFF\CTROK.TIF) 

 %v = document drive 

 %d = document directory (for example, D:\PICS\TIFF) 

 %b = document base name (for example, CTROK) 

 %e = document file extension (for example, TIF) 
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 %n = total number document pages 

 pages 

r 

ettings 

eek 

 %U = time: minute 

tor. The Agile 

ents are inserted under the file. Therefore, file types that are in “solid” 
le, PDF, BMP) will not show the watermark. It will show only on “transparent” file 

A faint an

Note For high resolution black and white printing, the transparent watermark is printed on the 

 %p = current page number 

 %N = total number of tiled

 %P = current tile numbe

 %r = newline 

 %F = Excel native print s

 %Y = date: year 

 %M = date: month 

 %D = date: day 

 %W = date: day of w

 %H = time: hour 

 %S = time: second 
 

Watermarks and Banners in Print Properties 
The Print Properties dialog box includes a Watermark tab. This tab cannot be modified in the Agile 
Viewer Print Properties dialog box. 

Watermark and Banner settings are defined and maintained in Agile Administra
Administrator watermark and banner settings determine whether banners and watermarks appear 
on printouts of files attached to Agile objects and the content of those banners and watermarks. 
These banners and watermarks appear on files printed with the Agile Viewer. 

Watermarks on attachm
formats (for examp
types (for example, CAD). 

Watermarks 

d transparent watermark appears on the current document’s contents. 

current document’s contents. For low resolution black and white printing, the wat
printed on the current document’s contents, but it is not transparent. 

ermark is 

r Agile administrator; see the 
istration Tasks

The watermark settings are maintained and modified by you
Administrator Guide. For more information, see “Viewer Admin  (on page 39).” 
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Stamps Group In Print Properties 
Note This feature is not available in this implementation of Agile Viewer. 
 

Printing DGN Files 
Agile Viewer can be configured to print files with a DGN extension in the same manner as 
MicroStation. This option must be configured on the server side; please contact your Agile system 
administrator for assistance.           
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Chapter 5 

Viewer Administration Tasks 

This chapter includes the following: 

 Setting the Print Options...................................................................................................................................... 39 
 Adding Fonts........................................................................................................................................................ 41 
 Viewing Excel Files.............................................................................................................................................. 41 

Note For information about Agile PLM Administrator settings related to the Agile Viewer (for 
example, Supported File and Valid Model File Type settings), see Administrator Guide, “Viewer 
and Files” section of the “General System Settings” chapter. 

For more information about the Agile View Server, including where to find additional Agile View 
Server documentation, see the appropriate Agile installation guide for your Agile PLM system; refer 
the chapter about configuring the Agile View Server. 
 

Setting the Print Options 
Some file formats require configuring specific settings to print properly. In general, you can change 
these settings for all users or for individual users: 

 To change the print settings for all users, you need to modify some of the parameters in the 
AVS\bin\allusers.ini file. 

 To change the print settings for individual users, you need to modify some of the parameters in 
each user's .ini file under AVS\bin\profiles. 

Caution When you modify options in the allusers.ini file, the existing user profiles are not 
automatically modified. Because editing every individual user profile is impractical, in the 
procedures below you are instructed to delete the existing user profiles when you modify 
allusers.ini. The next time a user opens the Agile Viewer, a new user profile is created 
which includes the new allusers.ini options settings. You may want to notify your users in 
advance to let them know that their user profiles will be reset. 

To change the way that the watermark, border, and header (banner) appear when printed, you will 
need to modify the following .ini file parameters: 

 [OPTIONS] – HPBACKGROUND, KEEPORIGINALCOLORS, and 
SWSHOWVIEWPORTBORDER 

 [PRINTWATERMARK] – FONTNAME, FONTSIZE, ORIENTATION, and FONTSTYLE 

 [PRINTHEADERS] – FONTNAME, FONTSIZE, ORIENTATION, and FONTSTYLE 

The following sections describe the procedures for printing watermarks and borders, and for 
modifying the headers and watermarks. 
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Printing Watermarks in .hpg and .plt Files 

To print watermarks correctly in .hpg and .plt files, you must set the background color correctly. 

Note If the watermark image or the color used in the watermark image is not transparent, the 
watermark will not be visible. 

To set the background color: 

1. Shut down the JVue server. 

2. On the drive where the Agile Viewer Server is installed, find the AVS\bin\Profiles folder. 

3. Delete all the user profiles in this folder (Example: John Smith.ini) 

4. Edit the allusers.ini file (AVS\bin\allusers.ini). 

5. In the [OPTIONS] section, add or update the following two lines: 

HPBACKGROUND = 0
KEEPORIGINALCOLORS = 1

Printing Viewport Borders in SolidWorks Files 

To print viewport borders correctly in SolidWorks files, you must enable the viewing/printing of 
viewport borders. 

To enable the option: 

1. Shut down the JVue server. 

2. On the drive where the Agile Viewer Server is installed, find the AVS\bin\Profiles folder. 

3. Delete all the user profiles in this folder (Example: John Smith.ini). 

4. Edit the allusers.ini file (AVS\bin\allusers.ini). 

5. In the [OPTIONS] section, add or update the following line: 

SWSHOWVIEWPORTBORDER = 1

Modifying the Header and Watermark Font Settings 

Note The watermark may be truncated if the font size is too large or if there are too many 
characters in the watermark text. Truncation ensures that the watermark does not distort 
the image. 

To set the watermark font size: 

1. Shut down the JVue server. 

2. On the drive where the Viewer Server is installed, find the AVS\bin\Profiles folder. 

3. Delete all the user profiles in this folder (Example: John Smith.ini). 

4. Edit the allusers.ini file (AVS\bin\allusers.ini). 

5. In the [PRINTHEADERS] section and in the [PRINTWATERMAK] section, update the lines for 
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Fontname, Fontsize, Orientation, and Fontstyle. For example: 

FONTNAME = Serif
FONTSIZE = 24
ORIENTATION = 1
FONTSTYLE = 2 

Note ORIENTATION can be specified as 1 (portrait) or 2 (landscape). 
 

Adding Fonts 
To ensure that specific fonts are recognized by the Agile Viewer, you can add the font path to the 
allusers.ini configuration file. 

To add fonts: 

1. Shut down the JVue server. 

2. On the drive where the Agile Viewer Server is installed, find the AVS\bin\Profiles folder. 

3. Delete all the user profiles in this folder (Example: John Smith.ini). 

4. Edit the allusers.ini file (AVS\bin\allusers.ini). 

5. In the [OPTIONS] section, update the following line: 

XFONTPATHS = {paths}
6. Add the full paths of the font files to the line. Separate the paths with a semicolon. 

7. Save the allusers.ini file. 

8. Clear your web browser’s cache. 

9. Restart the JVue server. 
 

Viewing Excel Files 
When viewing Excel files in the Agile Viewer, all pages may not be displayed. View the file in its 
native application to verify the correct number of pages in the file. 
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