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The Agile documentation set includes Adobe® Acrobat™ PDF files. The Oracle Technology Network (OTN) Web 
site contains the latest versions of the Oracle|Agile PLM PDF files. You can view or download these manuals from 
the Web site, or you can ask your Agile administrator if there is an Oracle|Agile Documentation folder available on 
your network from which you can access the Oracle|Agile documentation (PDF) files.

To read the PDF files, you must use the free Adobe Acrobat Reader™ version 7.0 or later. This program can be 
downloaded from the www.adobe.com.

The Oracle Technology Network (OTN) Web site can be accessed through Help > Manuals in both the Agile Web 
Client and the Agile Java Client. If applicable, earlier versions of Oracle|Agile PLM documentation can be found on 
the www.agile.com/support.

If you need additional assistance or information, please contact support@agile.com or phone (408) 284-3900 for 
assistance.

Before calling Agile Support about a problem with an Oracle|Agile PLM manual, please have ready the full part 
number, which is located on the title page.

Readme

Any last-minute information about Oracle|Agile PLM can be found in the Readme file on the Oracle Technology 
Network (OTN) Web site.

Agile Training Aids

Go to the Agile Training Web page for more information on Agile Training offerings.
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CHAPTER 1
Introducing Agile Viewer

This chapter introduces Agile Viewer and provides basic information about it. Topics discussed include:
❑ How to Use this Manual
❑ Getting Help
❑ About Agile Viewer
❑ What’s New in This Release
❑ Understanding the Agile Viewer

How to Use this Manual
This manual is a supplement to Agile Viewer online Help. It is intended to be used in conjunction with the viewer 
online help and other Agile manuals.

The viewer has been integrated into the Agile system to make use of the Agile’s ability to manage attached files by 
using Agile system features. The integration also streamlines the viewer menus, toolbars, and shortcuts. The 
following table shows where you can find information about Agile features and concepts which you may find useful.

Table 1-1: Where to find related information

Feature or concept Contained in this document How to find the document

Java Client navigation Getting Started with Agile PLM, 
Chapter 2, “Navigation in Java Client”

Choose Help > Manuals in the Java Client 
or Web Client menu bar. On the 
documentation web page, click Getting 
Started Guide in the list of user manuals.

Web Client navigation Getting Started with Agile PLM, 
Chapter 3, “Navigation in Web Client”

Relationships and references between 
objects

Getting Started with Agile PLM, 
Chapter 5, “Working with Business Objects”

Attachment files Getting Started with Agile PLM, 

Chapter 9, “Working with Attachments”

and
Chapter 10, “Working with Files File 
Folders”

Working with file folder objects

File folder mass update

Routing and reviewing file folders

File validation (Handle Check Sum)

Viewing and redlining attachment 
files

Viewing and redlining file folder 
contents

Redlining through ECOs, MCOs and 
SCOs

Product Collaboration User Guide, Chapter 5, 
“Changes”

Choose Help > Manuals in the Java Client 
or Web Client menu bar. On the 
documentation web page, click Product 
Collaboration in the list of user manuals.
1-1
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Getting Help
To get help at any time, choose Help > Contents in the Agile Viewer menu bar. The viewer online help is displayed; it 
includes detailed information about using viewer features.

Note See Chapter 2, “Agile-specific Features and Functions” for a complete list of features and user interface 
details described in the viewer online Help that have been modified in order to integrate the viewer with 
the Agile system.

About Agile Viewer
Agile Viewer can display many different file formats without their authoring applications. You can view files from 
many database, graphic, spreadsheet, word-processing, and 2D CAD applications. Even archive files can be listed 
and viewed without the need to decompress them. It isn’t necessary for you to identify the file type; Agile Viewer 
automatically identifies the type of file you are requesting it to read. An Agile administrator determines which types 
of files can be viewed by setting the Supported Files property or, for Advanced Viewer, the Valid Model File Type 
property.      

Important To view files through the Advanced Viewer, you need Agile Discovery, Read, and ViewFile privileges. To 
redline files through the Advanced Viewer, you need the Attachment Redlines privilege.

The action of attaching your comments, notes, and drawings to a document is known as marking up, also commonly 
known as annotating or redlining. A markup refers to the change being made to a document by attaching a markup 
object. You can use Agile Viewer to mark up files as well as view them.

Note Agile Java Client and Agile Web Client support attachment redlining. Markups for ECOs can be made on 
the Redline Attachments tab in Java Client and Web Client. You access the appropriate redline tab on the 
Affected Items tabs of ECOs. Markups for a file folder object can be made on the Files tab of the file folder 
object in Java Client and Web Client and do not require an ECO.

Some of Agile Viewer’s features are:

❑ Flexible user-defined objects — Agile Viewer offers a vast selection of markup objects, including circles, clouds, 
polygons, and arrows. Text can be attached to objects, and lengthier comments can be contained in embedded 
notes.

See Agile Viewer online help for a detailed discussion of markup objects. Choose Help > Contents in the Agile 
Viewer menu bar.

❑ Storage of unedited original documents — Original documents are never changed. All your notes and drawings 
are saved in a separate file called a markup file, although when viewed they appear to be part of the main 
document. You do not have to manage the storage and retrieval of markup files; Agile does that for you.

❑ Support for non-English languages and operating systems — Agile Viewer works with many non-English 
languages, and has been tested on Japanese, Chinese, French, German, Hebrew, and Swedish operating systems.

What’s New in This Release
The following new features have been added to this release:

❑ Support for AutoVue Professional and AutoVue Solid Model Professional, Version 19.

❑ Ad Hoc redline markups can be saved when performing cross probing, Compare, and Digital Mockup from the 
Files tab of file folder object.
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Understanding the Agile Viewer
The following sections describe the main Agile Viewer window and performance modes, plus other information 
needed to use Agile Viewer.

Agile Viewer Window

You can start the Agile Viewer from either the item Attachments tab or the file folder Files tab. 

To start the Agile Viewer in Java Client:

Double-click the attachment row.

Or

1 Select one or more rows.

2 Click the View Files button’s drop-down arrow and select View  from the menu.

Note If the View  icon is visible on the button, you can simply click the button.

To start the Agile Viewer in Web Client:

Click the file name link in the table. 

Or

1 Select one or more rows.

2 Click the View Files button’s drop-down arrow and select View  from the menu.

Note If the View  icon is visible on the button, you can simply click the button.

When you start Agile Viewer, the main Agile Viewer window appears, as shown in Figure 1-1 on page 1-4.         

Note For more information about starting the Agile Viewer, see “Opening Agile Attachment Files in the Viewer” 
on page 2-1.

Viewing Multiple Files

You can select multiple files to view, and the Agile Viewer opens all the selected files in a single window. In the menu 
bar, choose View > Multicontent to select which file you want to view.

Agile Viewer Modes

Agile Viewer has two performance modes: View and Markup.

View Mode

When a document is first opened from business object’s Attachments tab or file folder Files tab, the menu bar and 
toolbars are those of View mode. View mode is Agile Viewer’s default mode. Documents can be edited or marked 
up only from Markup mode, described in the next section.     
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Markup Mode

When Agile Viewer is in Markup mode, the currently displayed document can be marked up. That is, you can redline 
or annotate it. Available markup objects include various shapes, notes, symbols, and text. When you open Agile 
Viewer from the Redline Attachments tab or Files tab in a file folder object, Agile Viewer opens either in View or Markup 
mode, depending on whether the attachment has a saved markup and the privileges assigned to the user. If the 
attachment is checked out, then the redlining will not be allowed, however, you can change to Agile Viewer Markup 
mode to display saved markup. For instructions on how to enter Markup mode from View mode, see “Guidelines 
for Marking Up or Redlining Attachments” on page 2-2. When you open a markup file, Markup mode starts 
automatically. 

Note Markup mode is available in the viewer only when the viewer is opened from tabs where markups are 
allowed: from a change order’s Redline Attachments tab and from the Files tab of a file folder. In addition, you 
must have the appropriate Attachment Redlines for Self privilege. Contact your Agile administrator if you 
have questions about your assigned roles and privileges.

Agile Viewer Window Components

There are a few basic components to the Agile Viewer work environment, shown in the following figure. These differ 
according to whether Agile Viewer is in View mode or Markup mode.

Menu Bar

The menu bar is the main access to all of the menu commands. The selection of available commands changes 
according to the mode the viewer is in and the task that you’re performing.      

Toolbars

The tool buttons offer easy access to the basic commands presented in the menu bar. As with menu commands, the 
selection of available toolbar buttons changes according to the mode the viewer is in and the task that you’re 
performing.      

Status Bar

In both View mode and Markup mode, there is a status bar located at the bottom of the main window. The fields 
from left to right for each mode’s status bar are as follows: markers (see the following list), current active file name, 
file type, zoom factor, current page and total number of pages, current active file size, date of the file’s creation, and 
the pointer’s coordinate position.

The following types of markers can appear on the status bar: 

❑ A red light bulb marker indicates that the current active file has associated markup files. While in View mode, 
click the markup from the File menu to view the Markup Files dialog box. Then select a markup file or group of 
markup files to open. When you open a markup file, Markup mode starts automatically.      

❑ A red exclamation mark indicates that some main resources required to properly read the current active 
document are not available (for example, missing fonts or missing CAD files). To quickly identify the missing 
resources, click the red exclamation mark, and the File Properties dialog box appears. 

❑ The Join Session  button, which indicates that you have been invited to join a Collaboration session. 

Moving Objects

You can use the left mouse button to click and drag.      
❑ In View mode — By default, drag to perform an autozoom of all supported file formats (including raster and 

vector files). Select the area you want to enlarge.
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❑ In Markup mode — If objects are selected, drag to modify and move objects. If no objects are selected, drag to 
perform an autozoom (same as in View mode).

To select an object, click it. Selected objects are framed by a text box. Modify the size of the object by dragging 
the frame handles. To move an object, move the cursor to the borders (the edges) of the markup entity until the 
cursor turns into a hand pointer. Drag the hand pointer to a new location.

Accessing Commands with Shortcut Menus

The easiest and quickest way to access most of Agile Viewer’s functions is using the shortcut menus. Simply right-
click with the pointer over the View window to access appropriate commands.

In View mode, use these commands: 

❑ Zoom Fit — to automatically fit the document to the width of the view window.

❑ Zoom Previous — to automatically return to your previous zoom level.

❑ Zoom Page Width — to automatically fit the document to the width of the view window.

❑ Markup/Exit Markup — to enter and exit Markup mode and open an existing markup or create a new one. The Markup 
command is available in View mode only when markups are allowed.

In Markup mode, use these additional commands:

❑ Line Style — to select a style of line to use in your markup.

❑ Line Thickness — to select a line thickness for use in your markup.

❑ Fill Type — to select the type of fill to apply to your markup object: Solid Fill, No Fill, or Transparent Fill.

❑ Entity Color — to select a color for your markup object.

❑ Order — to select the overlay order when several markups are being displayed simultaneously.

❑ Markup Layers — to select which layers are visible or active, change layer color, add new layers, and rename existing 
layers.

Canceling an Operation in Progress 

For example, if while drawing a box you realize that you would prefer to draw a cloud, right-click while drawing the 
box and the box is erased from the display. 

If you have already drawn a box, you can either choose Edit > Undo from the menu bar or select the box and press the 
Delete key on your keyboard. What has already been drawn is erased. 
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CHAPTER 2
Agile-specific Features and Functions

This chapter describes Agile-specific viewer features and functions. Topics discussed include:
❑ Opening Agile Attachment Files in the Viewer
❑ Marking Up — How It Works
❑ Guidelines for Marking Up or Redlining Attachments
❑ Marking Up Documents
❑ 2D Features and Functions
❑ EDA Features and Functions
❑ 3D Features and Functions
❑ Cross Probing
❑ Comparing Files
❑ Overlaying Files
❑ Working with Schematic and PCB Files
❑ Real-Time Collaboration
❑ Digital Mockup

Opening Agile Attachment Files in the Viewer
You can view files from either the Attachments tab of a business object or from the Files tab of a file folder object.

To view a file from Java Client:

❑ Go to the Attachments tab of a business object that references the file and:

• Double-click the attachment row.

Or 

• Select one or more attachment rows and click the View Files button’s drop-down arrow and select View  from 
the menu. If the View  icon is visible on the button, you can simply click the button.

❑ Go to the Files tab of a file folder object containing the file, select one or more file rows and 

Click the View Files button’s drop-down arrow and select View  from the menu. If the View  icon is visible 
on the button, you can simply click the button.

To view a file from Web Client:

❑ Go to the Attachments tab of a business object that references the file and click the file name link in the attachments 
table.
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❑ Go to the Files tab of a file folder object containing the file and click the filename link in the file table, or select 
one or more file rows and click the View button in the tab menu.

Ad hoc 2D, 3D, and EDA/ECAD markup can be done from the Files tab in the file folder object. Change order-
controlled 2D, 3D, and EDA/ECAD markup can be done from the Redline Attachments tab in the ECO. When you view 
a markup file, the original document, also known as the base file, opens too.

Note Change order-controlled and ad hoc markups are independent from each other. 

To view change order-controlled markups, open the redlined file from the appropriate revision of the item 
Attachments tab or from the change order Redline Attachments tab (see “Viewing ECO Redlines from the 
Attachments Tab of the Item Pending Revision” on page 2-4). 

To view ad hoc markups, open the redlined file from the file folder object Files tab.

Marking Up — How It Works
Marking up refers to drawing and writing in an electronic document. With Agile Viewer, your original document 
remains unchanged because your markups are saved in separate markup files. When you view a markup file, Agile 
Viewer loads the markups into memory and lays them over the original document.      

There can be as many markup files as you wish for a document because each has its own unique filename. This allows 
several individuals to mark up the same document at the same time because a unique markup file is created for each 
person’s work. With the markup information attached to each markup file, you can even tell who created each 
markup.

Markup files are divided into uniquely named layers. Create, name, and color the layers to organize your work as 
you like. For example, different colors could indicate time priorities, and each layer could contain markups relating 
to a common purpose. Markup files are stored with other attachment files in the file vault, part of Agile File Manager 
(AFM). Markup files are managed by Agile and are automatically retrieved and presented when you view the 
redlined document. 

Guidelines for Marking Up or Redlining Attachments
With appropriate privileges, you can redline Microsoft Office documents, 2D, 3D, and EDA files on the Files tab of 
a file folder object and redline 2D, 3D, and EDA files on the Redline Attachments tab, accessible from the Affected Items 
tab of an ECO. 

Note You can create and edit file markups only through the Affected Items tab of an ECO or the Files tab of a file 
folder object. Your Agile administrator must give you privileges that allow you to mark up or redline 
attachments. For more information about ECOs and file folder objects, see Getting Started with Agile PLM.

Java Client

To mark up or redline an attachment file from an ECO in the Java Client:

1 If you have not already done so, add an item with an attachment to the Affected Items tab of an unreleased ECO. 
The item now has a pending revision associated with the unreleased ECO.

Note When redlining an attachment through an ECO, the pending revision attachment Folder Version must be 
set to a specific version number; if the Folder Version is set to LATEST-x, you will not be able to create 
redline markups. However, you can edit the Folder Version on the Attachments tab of the pending revision 
so that it refers to a specific Folder Version.

For example, if the pending revision of the item refers to Folder Version LATEST-7 of the file folder, select 
that row on the Attachments tab, click the Edit  button and use the Folder Version drop-down list in the Edit 
dialog box to select 7. Click OK to complete the edit process. You will now be able to create redline markups 
for that attachment.Select the added item on the Affected Items tab of the ECO.
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2 On the Redline Attachments tab:

• Select the row containing the file you want to redline and click the View button.

Or

• Double-click the row containing the file you want to redline.

3 When the Agile Viewer appears, click the Markup button. (This button is available only when markups are 
allowed.)

4 Use the tools described in the viewer online Help to redline the attachment. To view online Help, choose 
Help > Content in the menu bar.

Note ECO markups are saved against and associated with the pending revision of the item. If the ECO is released 
without first replacing the file, the markups appear against the released revision of the item.

To ad hoc mark up or redline an attachment file from a file folder object in the Java Client:

1 Double-click the row containing the file you want to redline.

2 When the Agile Viewer appears, click the Markup button. (This button is available only when markups are 
allowed.)

3 Use the tools described in the viewer online Help to redline the attachment. To view online Help, choose 
Help > Content in the menu bar.

Note Ad hoc markups are saved against and associated with the version of the file folder object. 

Web Client

Note If the item or file has already been redlined, then the Has been redlined icon  will be displayed in the place 
of the Do Redlining icon . Click either  or  to initiate redlining.

To mark up or redline an attachment file from an ECO in the Web Client:

1 If you have not already done so, add an item with an attachment to the Affected Items tab of an unreleased ECO. 
The item now has a pending revision associated with the unreleased ECO.

Note When redlining an attachment through an ECO, the pending revision attachment Folder Version must be 
set to a specific version number; if the Folder Version is set to LATEST-x, you will not be able to create 
redline markups. However, you can edit the Folder Version on the Attachments tab of the pending revision 
so that it refers to a specific Folder Version.

For example, if the pending revision of the item refers to Folder Version LATEST-7 of the file folder, select 
that row on the Attachments tab, click the Edit button and use the Folder Version drop-down list to select 7. 
Click Save to complete the edit process. You will now be able to create redline markups for that 
attachment.On the Affected Items tab, click the Do Redlining icon for that item to open the Redlines page.

2 On the Redline Attachments tab, click the Do Redlining button  (or Has been redlined button ) on the row of the 
file you want to redline. (This button is available only when markups are allowed.

3 On the Affected Items tab, click the Do Redlining icon next to the item to open the Redlines page.

4 Use the tools described in the viewer online Help to redline the attachment. To view online Help, choose 
Help > Content in the menu bar.

Note ECO markups are saved against and associated with the pending revision of the item. If the ECO is released 
without first replacing the file, the markups appear against the released revision of the item.
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To ad hoc mark up or redline an attachment file from a File Folder object in the Web Client:

1 On the Files tab of a file folder object, click the Do Redlining button  (or Has been redlined button ) on the row 
of the file you want to redline. (This button is available only when markups are allowed.)

2 Use the tools described in the viewer online Help to redline the attachment. To view online Help, choose 
Help > Content in the menu bar.

Note Ad hoc markups are saved against and associated with the version of the file folder object.

Redlining Markups for Change Orders 

The change order redlines of 2D, 3D, and EDA files are based on the pending revision of the item. The markup 
changes are visible from either the change orders’s Redline Attachments tab or from the pending revision item 
Attachments tab.

Important 3D features and access to 3D files are available only with Agile Advanced Viewer. Features for schematic 
and PCB files, also referred to as EDA files, are available only with the Agile Advanced Viewer. In order to 
use these features, your company must have the View and Mark Up (3D) server license, which provides 
access to Advanced Viewer functions. For more information about server licenses, see the Administrator 
Guide. Contact your Agile Account Executive or reseller to obtain a license.

Viewing ECO Redlines from the Attachments Tab of the Item Pending Revision

You can view the change order markup redlines of the pending revision by displaying the Attachments tab of the item 
pending revision, for example, revision (C) ECO000453. The redlined file is indicated by the Has been redlined  
icon.

❑ In Java Client, select the redlined file you want to view and click the View Files  button.

❑ In Web Client, click the Has been redlined button in the row of the file you want to view.

If you have checked out the redlined file and checked in a new version from the Attachments tab, the Has been redlined 
icon does not appear on the Attachments table. 

To view the redlines of previous versions in Java Client:

1 On the Attachments tab of the pending revision, select the row you want to view.

2 Click the Show Versions button. The Versions dialog appears. 

3 On the version row for which you want to view redlines, double-click the Has been redlined  button.

To view the redlines of previous versions in Web Client:

1 On the Attachments tab of the pending revision, click the Show Versions button in the row you want to view. The 
Versions dialog appears. 

2 On the version row for which you want to view redlines, double-click the Has been redlined  button.

Note If you need to determine which file folder version is associated with the change order redlines, refer to the 
change order History tab.

However, if the attachment file on the pending revision item is not replaced prior to the change order release, the 
redlines will be accessible from the released revision of the item. The following diagram shows an example of the 
change order attachment redlining process.

(See also Product Collaboration User Guide and Getting Started with Agile PLM.) 
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Figure 2-1: Change order redline markup flow chart

Item 333, B ECO_012
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ECO_045
(not released)

Affected Items

Item 333

Item 333, (C) ECO_045
File Folder 087 

Version 3

arches.bmp

1. Put Item 333 on the Affected Items 
tab of ECO_045.

2. ECO_045 creates pending 
Revision C of Item 333.

Markup 1

Markup 2

3. Markups are created through ECO_045 associated with 
pending Revision C of Item 333 (which references File Folder 
087 Version 3). These markups can be viewed only through the 
Affected Items tab of ECO_045 or through the Attachment tab of 
Item 333 pending Revision C.

4. ECO_045 is reviewed, approved, and released.

Item 333, C ECO_045
File Folder 087 

Version 4

arches.bmp

File arches.bmp in File Folder 087 is not yet updated and remains at version 3 with 
markups. Released item 333 Revision C includes attachment markups viewable from 
the released item’s Attachments tab.

5. arches.bmp is check out, modified, and checked in. File Folder 087 is updated to 
version 4. Now released Item 333 Revision C does not include attachment markups.

6.To view the redlined version 3 of arches.bmp, use the Show Versions feature on 
the Attachments tab of Released item 333 Revision C or on the Redline Attachments 
tab of ECO_45. Click (Web Client) or double-click (Java Client) the Has Been Redlined 
icon in the version history dialog table to view arches.bmp, version 3, and its 
markups.
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Marking Up Documents
For information about working with markups, including markup layers and markup objects, refer to the viewer 
online help. Choose Help > Contents in the Agile Viewer menu bar.

Tips for Marking Up Documents

If you exit the Agile viewer without saving, you will lose any redline you have added to the attachment.

Attaching Information to Markup Files

In Markup mode, the Markup > Information command displays the Markup Information dialog box with five 
information fields attached to the current active markup file.   

Entity Rotate

Entity Rotate allows you to rotate symbol markup objects.

To rotate a symbol markup object:

1 Select the symbol markup object you want.

2 Click the Rotate Entity button, or choose Markup > Entity Rotate.

When this feature is activated, the Rotate Entity button appears as a recessed button (light gray) on the toolbar.

3 Place the cursor on one of the corner squares that indicate the selected object.

4 When you see the crossed-arrows cursor (pointing in four directions), hold down the left mouse button and 
adjust the rotation angle of the object.

5 Release the mouse button when you are finished adjusting the rotation angle.

2D Features and Functions
For information about working with 2D files, including CAD views and measuring objects, refer to the viewer online 
help. Choose Help > Contents in the Agile Viewer menu bar.

EDA Features and Functions
Agile Advanced Viewer EDA features include:

❑ Ability to view all relevant EDA formats including artwork formats, PCB/IC layouts, schematics and 
manufacturing formats

❑ Cross probe between a PCB layout and related schematics (see “Cross Probing” on page 2-7).

❑ Verify design by testing for manufacturability or design violation.

❑ Generate and export Bills of Material in a variety of formats.

For detailed information about all the EDA features, refer to the viewer online help. Choose Help > Contents in the 
Agile Viewer menu bar.

Important EDA features and access to EDA files are available only with Agile Advanced Viewer. In order to use these 
features, your company must have the View and Mark Up (3D) server license, which provides access to 
Advanced Viewer functions. For more information about server licenses, see the Administrator Guide. 
Contact your Agile Account Executive or reseller to obtain a license.
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3D Features and Functions
For information about working with 3D files, including light settings and models, refer to the viewer online help. 
Choose Help > Contents in the Agile Viewer menu bar.

Important 3D features and access to 3D files are available only with Agile Advanced Viewer. In order to use these 
features, your company must have the View and Mark Up (3D) server license, which provides access to 
Advanced Viewer functions. For more information about server licenses, see the Administrator Guide. 
Contact your Agile Account Executive or reseller to obtain a license.

Understanding 3D Basics

3D CAD assemblies are made up of many files dependent one upon another. For example, a SolidWorks or Pro/E 
CAD design consists of at least one assembly file and one or more part files. The 3D files are used primarily in 
manufacturing departments for drawing the blueprint of the new instrument. 3D files may be added to the Files tab 
in one or several file folder objects. The assembly file is added to the Files tab in one file folder object, and parts files 
can be referenced by adding other file folder objects containing the files to the References tab of the assembly’s file 
folder object.

3D files can be redlined both through a change order (Redline Attachments) and on the Files tab of the file folder 
object. 

Cross Probing
Cross probing is also described in the viewer online Help. In Agile, this feature is initiated from either the business 
object Attachments tab or the file folder Files tab rather than from the viewer menus. For detailed information about 
cross probing features, see the Agile Viewer online help. Choose Help  > Contents in the viewer menu bar.

Important Cross probing features are available only with Agile Advanced Viewer. In order to use these features, your 
company must have the View and Mark Up (3D) server license, which provides access to Advanced Viewer 
functions. For more information about server licenses, see the Administrator Guide. Contact your Agile 
Account Executive or reseller to obtain a license.

Use cross probing to interrogate ECAD schematic and layout files in separate viewer windows. You can make 
markups in the files as described in “Saving Cross Probing Markups” below.

Note The Agile administrator should specify the ECAD file extension in the Valid Model File Type field for you to 
view the ECAD files.

You can select both needed files from the same Attachments tab or the same file folder Files tab from which you launch 
the Cross Probe action. Or, you can select one file on the current tab and then search for the remaining file from the 
attachments of any other object. 

The View > By Search > Crossprobe option allows you to find other files in the system, which you may want to use to cross 
probe, without having to select two files from the same Attachments tab or Files tab; that is, you can search and select 
one attached file from Part 234 and another attached file from Part 765.

Alternatively, you can view a single ECAD file then initiate cross probing within the viewer by adding another file 
from your desktop.

Saving Cross Probing Markups

When you initiate cross probing from the file folder object Files tab, you can make markups in the files in any of the 
opened windows and save them. The marked up file attachments can be identified in the file folder object Files tab 
by the Has been redlined icon  in its row in the table. This feature can be used only with ECAD files.

The following rules apply to creating cross probing markups:
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❑ You must have the appropriate privilege to create the redline markups:

• Attachment Redlines for Self privilege mask for file folders.

❑ The cross probe viewing operation has been initiated from the Files tab of a checked-in file folder.

❑ For cross probe markups, the markup is associated to the file in the opened viewer window where it is created.

For example, when you cross probe between a PCB file and a schematic file, a viewer window opens for each file. 
You can cross probe from either open viewer window. In addition, you can create a markup in either open viewer 
window. If you create and save a markup on the PCB file, the markup is associated only to the PCB file.

❑ The cross probe session is not saved in the markup file. When you view a file that has associated cross probe 
markups, the Agile viewer does not automatically enter cross probe mode.

Cross Probing in Java Client

To run Cross Probing in Java Client:

1 Display the Attachments tab or the Files tab.

2 Select both file rows you want to work with and choose View Files > Cross Probe.

Each file is displayed in a separate viewer window.

3 Begin cross probing. 

See Agile Viewer online help for more information about cross probing. Choose Help > Contents in the Agile Viewer 
menu bar.

To run Cross Probing By Search in Java Client:

1 Display the Attachments tab or the Files tab.

2 Select a file row you want to work with and choose View Files > By Search > Cross Probe.

The Select Files dialog appears, with three Search tabs. 

3 This dialog allows you to search for any business object (for example, items or manufacturer parts) and select the 
attachments of those objects to use to Cross Probe. Use any of the following search methods:

• Search tab lets you create a simple search or an advanced search. You can check to search attachment contents, 
too. 

• Saved Searches tab opens to your navigation pane where you can browse in search folders, select a search, and 
run it. Again, returned results may be moved to the Selected Items table, and click OK.

• Shortcuts tab opens to your navigation pane where you can select objects from My Bookmarks or Recently Visited. 
The system displays shortcuts to only those objects that are appropriate to the operation you are performing.

Only business objects with attached files appear in the search results table. For example, a business object that 
you viewed recently will not appear on the Recently Visited list of the Shortcuts tab if it has no attachments.

4 When the results of your search are returned, select a row in the Results table, and the related files for that object 
appear in the Related Files table.

5 In the Related Files table, select and move attachments to the Selected Files table. 

You can continue to run multiple searches or shortcuts until you are finished selecting the attachments you want.

6 When you are finished, click OK.

Each file is displayed in a separate viewer window.

7 Begin cross probing. 

See Agile Viewer online help for more information about cross probing. Choose Help > Contents in the Agile Viewer 
menu bar.
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Cross Probing in Web Client

To run Cross Probing in Web Client:

1 Display the Attachments tab or the Files tab.

2 Select both file rows you want to work with and choose View > Cross Probe.

Each file is displayed in a separate viewer window.

3 Begin cross probing. 

See Agile Viewer online help for more information about cross probing. Choose Help > Contents in the Agile Viewer 
menu bar.

To run Cross Probing By Search in Web Client:

1 Display the Attachments tab or the Files tab.

2 Select a file row you want to work with and choose View > By Search > Cross Probe.

The View Files by Search dialog appears, with three Search tabs. 

3 This dialog allows you to search for any business object (for example, items or manufacturer parts) and select the 
attachments of those objects to use to Cross Probe. Use any of the following search methods:

• Search tab lets you create a simple search or an advanced search. You can check to search attachment contents, 
too. 

• Saved Searches tab opens to your navigation pane where you can browse in search folders, select a search, and 
run it. Again, returned results may be moved to the Selected Files table, and click OK.

• Shortcuts tab opens to your navigation pane where you can select objects from My Bookmarks or Recently Visited. 
The system displays shortcuts to only those objects that are appropriate to the operation you are performing.

Only business objects with attached files appear in the search results table. For example, a business object that 
you viewed recently will not appear on the Recently Visited list of the Shortcuts tab if it has no attachments.

4 When the results of your search are returned, select a row in the Results table, and the related files for that object 
appear in the Related Files table.

5 In the Related Files table, select and move attachments to the Selected Files table. 

You can continue to run multiple searches or shortcuts until you are finished selecting the attachments you want.

6 When you are finished, click OK.

Each file is displayed in a separate viewer window.

7 Begin cross probing. 

See Agile Viewer online help for more information about cross probing. Choose Help > Contents in the Agile Viewer 
menu bar.

Comparing Files
Comparing files is also described in the viewer online Help. In Agile, this feature is initiated from the file folder Files 
tab rather than from the viewer menus. For detailed information about file comparison features, see the Agile Viewer 
online help. Choose Help  > Contents in the viewer menu bar.

Important Compare file features are available only with Agile Advanced Viewer. In order to use these features, your 
company must have the View and Mark Up (3D) server license, which provides access to Advanced Viewer 
functions. For more information about server licenses, see the Administrator Guide. Contact your Agile 
Account Executive or reseller to obtain a license.
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Markups and Comparing Files

Markups (redlines) are not supported in the Agile viewer compare mode.

Comparing Files in Java Client

To initiate comparing files in Java Client:

1 Display the Attachments tab or the Files tab.

2 Select both file rows you want to work with and choose View Files > Compare.

The files and the comparison results are displayed in a single viewer window. For more information about 
compare file features and options, choose Help  > Contents in the viewer menu bar.

To initiate comparing files By Search in Java Client:

1 Display the Attachments tab or the Files tab.

2 Select a file row you want to work with and choose View Files > By Search > Compare.

The Select Files dialog appears, with three Search tabs. 

3 This dialog allows you to search for any business object (for example, items or manufacturer parts) and select the 
attachments of those objects to use to compare. Use any of the following search methods:

• Search tab lets you create a simple search or an advanced search. You can check to search attachment contents, 
too. 

• Saved Searches tab opens to your navigation pane where you can browse in search folders, select a search, and 
run it. Again, returned results may be moved to the Selected Items table, and click OK.

• Shortcuts tab opens to your navigation pane where you can select objects from My Bookmarks or Recently Visited. 
The system displays shortcuts to only those objects that are appropriate to the operation you are performing.

Only business objects with attached files appear in the search results table. For example, a business object that 
you viewed recently will not appear on the Recently Visited list of the Shortcuts tab if it has no attachments.

4 When the results of your search are returned, select a row in the Results table, and the related files for that object 
appear in the Related Files table.

5 In the Related Files table, select and move attachments to the Selected Files table. 

You can continue to run multiple searches or shortcuts until you are finished selecting the attachments you want.

6 When you are finished, click OK.

The files and the comparison results are displayed in a single viewer window. For more information about 
compare file features and options, choose Help  > Contents in the viewer menu bar.

Comparing Files in Web Client

To initiate comparing files in Web Client:

1 Display the Attachments tab or the Files tab.

2 Select both file rows you want to work with and choose View > Compare.

The files and the comparison results are displayed in a single viewer window. For more information about 
compare file features and options, choose Help  > Contents in the viewer menu bar.

To initiate comparing files By Search in Web Client:

1 Display the Attachments tab or the Files tab.

2 Select a file row you want to work with and choose View > By Search > Compare.
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The View Files by Search dialog appears, with three Search tabs. 

3 This dialog allows you to search for any business object (for example, items or manufacturer parts) and select the 
attachments of those objects to use to compare. Use any of the following search methods:

• Search tab lets you create a simple search or an advanced search. You can check to search attachment contents, 
too. 

• Saved Searches tab opens to your navigation pane where you can browse in search folders, select a search, and 
run it. Again, returned results may be moved to the Selected Files table, and click OK.

• Shortcuts tab opens to your navigation pane where you can select objects from My Bookmarks or Recently Visited. 
The system displays shortcuts to only those objects that are appropriate to the operation you are performing.

Only business objects with attached files appear in the search results table. For example, a business object that 
you viewed recently will not appear on the Recently Visited list of the Shortcuts tab if it has no attachments.

4 When the results of your search are returned, select a row in the Results table, and the related files for that object 
appear in the Related Files table.

5 In the Related Files table, select and move attachments to the Selected Files table. 

You can continue to run multiple searches or shortcuts until you are finished selecting the attachments you want.

6 When you are finished, click OK.

The files and the comparison results are displayed in a single viewer window. For more information about 
compare file features and options, choose Help  > Contents in the viewer menu bar.

Overlaying Files
Overlaying files is also described in the viewer online Help. In Agile, this feature is initiated from the file folder Files 
tab rather than from the viewer menus. For detailed information about file overlay features, see the Agile Viewer 
online help. Choose Help  > Contents in the viewer menu bar.

Important Overlaying files features are available only with Agile Advanced Viewer. In order to use these features, your 
company must have the View and Mark Up (3D) server license, which provides access to Advanced Viewer 
functions. For more information about server licenses, see the Administrator Guide. Contact your Agile 
Account Executive or reseller to obtain a license.

Saving File Overlay Markups

You can create markups in the file that was opened first when you initiated viewing in overlay mode. The marked 
up file attachments can be identified by the Has been redlined icon  in its table row on the file folder object Files tab. 
This feature can be used only with ECAD files.

The following rules apply to creating overlay markups:

❑ You must have the appropriate privilege to create the redline markups:

• Attachment Redlines for Self privilege mask for file folders.

❑ The overlay viewing operation has been initiated from the Files tab of a checked-in file folder.

❑ For overlay markups, the markup is associated to the file that was opened first. 

For example, when you overlay File A1 and File B2, regardless of which file you selected first, if File B2 was the 
first file that was opened (displayed in the viewer window), then any markups you create and save are associated 
with File BB.

❑ The overlay session is not saved in the markup file. When you view a file that has associated overlay markups, the 
Agile viewer does not automatically enter overlay mode.
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Overlaying Files in Java Client

To initiate overlaying files in Java Client:

1 Display the Attachments tab or the Files tab.

2 Select both file rows you want to work with and choose View Files > Overlay.

The files are displayed in a single viewer window, one on top of the other. For more information about overlay 
file features (for example, File > Overlays in the menu bar) and options, choose Help  > Contents in the viewer menu 
bar.

To initiate overlaying files By Search in Java Client:

1 Display the Attachments tab or the Files tab.

2 Select a file row you want to work with and choose View Files > By Search > Overlay.

The Select Files dialog appears, with three Search tabs. 

3 This dialog allows you to search for any business object (for example, items or manufacturer parts) and select the 
attachments of those objects to use to overlay. Use any of the following search methods:

• Search tab lets you create a simple search or an advanced search. You can check to search attachment contents, 
too. 

• Saved Searches tab opens to your navigation pane where you can browse in search folders, select a search, and 
run it. Again, returned results may be moved to the Selected Items table, and click OK.

• Shortcuts tab opens to your navigation pane where you can select objects from My Bookmarks or Recently Visited. 
The system displays shortcuts to only those objects that are appropriate to the operation you are performing.

Only business objects with attached files appear in the search results table. For example, a business object that 
you viewed recently will not appear on the Recently Visited list of the Shortcuts tab if it has no attachments.

4 When the results of your search are returned, select a row in the Results table, and the related files for that object 
appear in the Related Files table.

5 In the Related Files table, select and move attachments to the Selected Files table. 

You can continue to run multiple searches or shortcuts until you are finished selecting the attachments you want.

6 When you are finished, click OK.

The files are displayed in a single viewer window, one on top of the other. For more information about overlay 
file features (for example, Analysis > Overlays in the menu bar) and options, choose Help  > Contents in the viewer 
menu bar.

Overlaying Files in Web Client

To initiate overlaying files in Web Client:

1 Display the Attachments tab or the Files tab.

2 Select both file rows you want to work with and choose View > Overlay.

The files are displayed in a single viewer window, one on top of the other. For more information about overlay 
file features (for example, File > Overlays in the menu bar) and options, choose Help  > Contents in the viewer menu 
bar.

To initiate overlaying files By Search in Web Client:

1 Display the Attachments tab or the Files tab.

2 Select a file row you want to work with and choose View > By Search > Overlay.

The View Files by Search dialog appears, with three Search tabs. 
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3 This dialog allows you to search for any business object (for example, items or manufacturer parts) and select the 
attachments of those objects to use to compare. Use any of the following search methods:

• Search tab lets you create a simple search or an advanced search. You can check to search attachment contents, 
too. 

• Saved Searches tab opens to your navigation pane where you can browse in search folders, select a search, and 
run it. Again, returned results may be moved to the Selected Files table, and click OK.

• Shortcuts tab opens to your navigation pane where you can select objects from My Bookmarks or Recently Visited. 
The system displays shortcuts to only those objects that are appropriate to the operation you are performing.

Only business objects with attached files appear in the search results table. For example, a business object that 
you viewed recently will not appear on the Recently Visited list of the Shortcuts tab if it has no attachments.

4 When the results of your search are returned, select a row in the Results table, and the related files for that object 
appear in the Related Files table.

5 In the Related Files table, select and move attachments to the Selected Files table. 

You can continue to run multiple searches or shortcuts until you are finished selecting the attachments you want.

6 When you are finished, click OK.

The files are displayed in a single viewer window, one on top of the other. For more information about overlay 
file features (for example, File > Overlays in the menu bar) and options, choose Help  > Contents in the viewer menu 
bar.

Working with Schematic and PCB Files

Important Features for schematic and PCB files, also referred to as EDA files, are available only with the Agile 
Advanced Viewer. In order to use these features, your company must have the View and Mark Up (3D) 
server license, which provides access to Advanced Viewer functions. For more information about server 
licenses, see the Administrator Guide. Contact your Agile Account Executive or reseller to obtain a license.

For information about these features, refer to the viewer online help. Choose Help > Contents in the Agile Viewer menu 
bar.
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Real-Time Collaboration
For detailed information about collaboration features, refer to the viewer online help. Choose Help > Contents in the 
Agile Viewer menu bar. The following sections discuss Agile View server information and Agile privileges that affect 
collaboration sessions.

Important Real-time collaboration features are available only with Agile Advanced Viewer. In order to use these 
features, your company must have the View and Mark Up (3D) server license, which provides access to 
Advanced Viewer functions. For more information about server licenses, see the Administrator Guide. 
Contact your Agile Account Executive or reseller to obtain a license.

Overview of Collaboration Sessions

The Collaboration feature lets multiple users team up and review documents interactively and simultaneously, thus 
shortening an otherwise lengthy review process where documents are passed back and forth. The Collaboration 
feature is available to all users who have Agile Discovery, Read, and Attachment Redlines privileges. 

From the Collaboration menu, anyone with the required Agile privileges can initiate a Collaboration session and act as 
host, or join a Collaboration session if invited by the host. 

Important If you plan to host a Collaboration session, ensure that all intended participants have Discovery, Read, and 
Attachment Redlines privileges. If they can view and redline a file, they have the necessary privileges. If they 
cannot, contact your Agile administrator, who can grant them the necessary privileges, before you attempt 
to initiate the Collaboration session.

In order to participate in the collaboration session, all the collaborators must be logged into Agile and 
viewing a file in the viewer when you start the collaboration session. They do not need view the file you are 
going to review in the collaboration session; they can view any file. For this reason, they may choose to view 
a small file that will load quickly.

When the host initiates a Collaboration session, a session object is created on the server, which is maintained for the 
duration of the Collaboration session. Session information is available from the Collaboration menu during a 
Collaboration session. It displays the session subject (the name assigned to the Collaboration session), the session ID 
(each session subject is assigned a unique session ID), the name of the base file viewed, the host, and the list of users 
participating. 

A session markup file is created during the Collaboration session to which all participants can add markup entities. 
Participants are assigned different layer colors for the session so that the markup entity from each participant is 
identifiable. The host for the session owns the markup file and is the only one who can save it. 

Note All users must connect to the same Agile Viewer server to use the collaboration feature. 
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Digital Mockup
In 3D mode, you can use the Mockup feature (DMU) to test alignment and interference of multiple assemblies. You 
can save the mockup as a redline markup entity.

To initiate Digital Mockup of files in Java Client:

1 Display the Attachments tab or the Files tab.

2 Select all the file rows you want to work with and choose View Files > Digital Mockup.

The files are loaded into the same Agile Viewer workspace.

3 Manipulate the models using the viewer features including the features in the Analysis menu, for example User 
Defined Coordinate Systems, Manipulators, Interference Checking, and Part Alignment. 

For information about these features, refer to the viewer online help. Choose Help > Contents in the Agile Viewer 
menu bar.

Saving Digital Mockup Markups

You can make markups in the file that was opened first when you initiated viewing in Digital Mockup mode. The 
marked up file attachments can be identified by the Has been redlined icon  in its table row on the file folder object 
Files tab. This feature can be used only with ECAD files.

The following rules apply to creating Digital Mockup markups:

❑ You must have the appropriate privilege to create the redline markups:

• Attachment Redlines for Self privilege mask for file folders.

❑ The Digital Mockup viewing operation has been initiated from the Files tab of a checked-in file folder.

❑ For Digital Mockup markups, the markup is associated to the file that was opened first. 

For example, when you mockup File A1, File B2, and File C3, regardless of which file you selected first, if File B2 
was the first file that was opened (displayed in the viewer window), then any markups you create and save are 
associated with File B2.

❑ The Digital Mockup markup file includes information about how to fetch all the files used in the DMU session.

When you view a file that has associated DMU markups, the Agile viewer automatically enters DMU mode when 
the DMU markup is opened. The DMU session is automatically recreated.

Digital Mockup in Java Client

To initiate Digital Mockup of files By Search in Java Client:

1 Display the Attachments tab or the Files tab.

2 Select a file row you want to work with and choose View Files > By Search > Digital Mockup.

The Select Files dialog appears, with three Search tabs. 

3 This dialog allows you to search for any business object (for example, items or manufacturer parts) and select the 
attachments of those objects to use for the mockup. Use any of the following search methods:

• Search tab lets you create a simple search or an advanced search. You can check to search attachment contents, 
too. 

• Saved Searches tab opens to your navigation pane where you can browse in search folders, select a search, and 
run it. Again, returned results may be moved to the Selected Items table, and click OK.

• Shortcuts tab opens to your navigation pane where you can select objects from My Bookmarks or Recently Visited. 
The system displays shortcuts to only those objects that are appropriate to the operation you are performing.
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Only business objects with attached files appear in the search results table. For example, a business object that 
you viewed recently will not appear on the Recently Visited list of the Shortcuts tab if it has no attachments.

4 When the results of your search are returned, select a row in the Results table, and the related files for that object 
appear in the Related Files table.

5 In the Related Files table, select and move attachments to the Selected Files table. 

You can continue to run multiple searches or shortcuts until you are finished selecting the attachments you want.

6 When you are finished, click OK.

The files are loaded into the same Agile Viewer workspace.

7 Manipulate the models using the viewer features including the features in the Analysis menu, for example User 
Defined Coordinate Systems, Manipulators, Interference Checking, and Part Alignment. 

For information about these features, refer to the viewer online help. Choose Help > Contents in the Agile Viewer 
menu bar.

Digital Mockup in Web Client

To initiate Digital Mockup of files in Web Client:

1 Display the Attachments tab or the Files tab.

2 Select all the file rows you want to work with and choose View > Digital Mockup.

The files are loaded into the same Agile Viewer workspace.

3 Manipulate the models using the viewer features including the features in the Analysis menu, for example User 
Defined Coordinate Systems, Manipulators, Interference Checking, and Part Alignment. 

For information about these features, refer to the viewer online help. Choose Help > Contents in the Agile Viewer 
menu bar.

To initiate Digital Mockup of files By Search in Web Client:

1 Display the Attachments tab or the Files tab.

2 Select a file row you want to work with and choose View > By Search > Digital Mockup.

The View Files by Search dialog appears, with three Search tabs. 

3 This dialog allows you to search for any business object (for example, items or manufacturer parts) and select the 
attachments of those objects to use to for the mockup. Use any of the following search methods:

• Search tab lets you create a simple search or an advanced search. You can check to search attachment contents, 
too. 

• Saved Searches tab opens to your navigation pane where you can browse in search folders, select a search, and 
run it. Again, returned results may be moved to the Selected Files table, and click OK.

• Shortcuts tab opens to your navigation pane where you can select objects from My Bookmarks or Recently Visited. 
The system displays shortcuts to only those objects that are appropriate to the operation you are performing.

Only business objects with attached files appear in the search results table. For example, a business object that 
you viewed recently will not appear on the Recently Visited list of the Shortcuts tab if it has no attachments.

4 When the results of your search are returned, select a row in the Results table, and the related files for that object 
appear in the Related Files table.

5 In the Related Files table, select and move attachments to the Selected Files table. 

You can continue to run multiple searches or shortcuts until you are finished selecting the attachments you want.

6 When you are finished, click OK.
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The files are loaded into the same Agile Viewer workspace.

7 Manipulate the models using the viewer features including the features in the Analysis menu, for example User 
Defined Coordinate Systems, Manipulators, Interference Checking, and Part Alignment. 

For information about these features, refer to the viewer online help. Choose Help > Contents in the Agile Viewer 
menu bar.
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CHAPTER 3
Modified and Unavailable Viewer

Features
This chapter describes features and user interface elements described in the viewer online help that have 
been modified in order to seamlessly integrate the viewer with the Agile system. Some features are 
unavailable.Topics discussed include:
❑ User Interface Modifications
❑ File Storage and Management Modifications
❑ Opening Files Features
❑ Working with Hyperlinks
❑ Viewer Modes

User Interface Modifications
The following features described in the viewer online Help have been modified or have been suppressed and are not 
available. 

❑ Window menu and its options for viewing multiple files (New, Cascade, Tile Horizontally, and Tile Vertically) are not 
available. (See “Viewing Multiple Files” on page 1-3.)

❑ The ability to click and drag toolbars to move them is not available.

❑ Mnemonic letter shortcuts (ALT+letter) are not available and are not displayed as underlined letters in the 
menus.

❑ Tooltips Quick Menu is not available.

❑ The Customize > Options menu selection does not include toolbar and tooltip settings.

File Storage and Management Modifications
Because the Agile system manages and controls access to attached files and markups (redline files), the following 
features described in the viewer online Help may have been modified or are not available to you. 

Many of these modifications relate to how files are opened, saved, and where they are stored. Instead of using viewer 
features (for example, File > Open, as described in the viewer online Help) to view files, the files are selected via the 
Agile object Attachments tab and the file folder Files tab, and retrieved from the file vault, part of Agile File Manager 
(AFM). The files are then displayed in the viewer window. When you create and save markup files, they are also saved 
in the file vault. (See “Opening Agile Attachment Files in the Viewer” on page 2-1 and “Guidelines for Marking Up 
or Redlining Attachments” on page 2-2.)
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If you need more information about a viewer feature, see the viewer online Help. To view online Help, choose 
Help > Content in the menu bar.

Opening Files Features
These features described in the viewer online Help are not available:

❑ Viewer Startup view (empty viewer window). 

❑ Drag and drop files from Windows Explorer onto the viewer window to open them.

❑ The following viewer File menu selections are not available in the Agile Advanced Viewer: Open, Browse, Next File, 
Previous File, Load File, Open URL, and Close.

❑ Archive file directory displayed in viewer window.

❑ Import and Export Markup files feature is not available. Import and Export 3D Models is not available. 

Access to all files, including markup files, is managed by the Agile system. For more information about markup 
files in Agile, see“Marking Up — How It Works” on page 2-2 and “Guidelines for Marking Up or Redlining 
Attachments” on page 2-2.

Working with Hyperlinks
Refer to the Agile Viewer online help for details about working with and creating hyperlinks. To view the online help, 
choose Help  > Contents in the viewer menu bar.

Although you can create hyperlink markup entities, you cannot create hyperlinks to other files in the Agile file vault.

The purpose of this viewer feature is to gather or link related information together. This functionality is provided by 
Agile features such as Attachments tabs (which may have multiple attached file folder objects) and Relationships tabs. 
For more information about file folder objects and attachments see Getting Started in Agile PLM.

Viewer Modes
The viewer modes Startup View and Thumbnails Mode described in the online Help are not available.
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CHAPTER 4
Printing

This chapter describes viewer print features that have been modified for use in Agile. Topics discussed 
include:
❑ Printing Documents from within the Agile Viewer
❑ Print Preview
❑ Headers/Footers Group in Print Properties
❑ Watermarks and Banners in Print Properties
❑ Stamps Group In Print Properties
❑ Printing DGN Files

Printing Documents from within the Agile Viewer
For detailed information about printing attachments from the file folder object Files tab, see the Getting Started with 
Agile PLM manual, Chapter 9, “Working with Attachments", and Chapter 10, "Working with File folders.”

For detailed information about printing from the viewer, see the viewer online Help. To view online Help, choose 
Help > Content in the viewer menu bar.

For information about how the Agile administrator can customize the Agile Viewer print options. see Chapter 5, 
“Viewer Administration Tasks.”

The following sections describe print features that have been modified to integrate the viewer with the Agile system.

Print Preview
Note This feature is not available in this implementation of Agile Viewer.

Headers/Footers Group in Print Properties
This group defines the headers and footers to be included on every printed page of the document.        

Note These settings are maintained and modified by your Agile administrator.

To view the header and footer settings:

Select the Headers/Footers tab. 

A literal percentage mark is indicated by %%. Other codes are as follows:

❑ %f = full path of document (for example, D:\PICS\TIFF\CTROK.TIF)

❑ %v = document drive 

❑ %d = document directory (for example, D:\PICS\TIFF)
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❑ %b = document base name (for example, CTROK)

❑ %e = document file extension (for example, TIF)

❑ %n = total number document pages

❑ %p = current page number

❑ %N = total number of tiled pages

❑ %P = current tile number

❑ %r = newline

❑ %F = Excel native print settings

❑ %Y = date: year

❑ %M = date: month

❑ %D = date: day

❑ %W = date: day of week

❑ %H = time: hour

❑ %U = time: minute

❑ %S = time: second

Watermarks and Banners in Print Properties
The Print Properties dialog box includes a Watermark tab. This tab cannot be modified in the Agile Viewer Print 
Properties dialog box.

Watermark and Banner settings are defined and maintained in Agile Administrator. The Agile Administrator 
watermark and banner settings determine whether banners and watermarks appear on printouts of files attached to 
Agile objects and the content of those banners and watermarks. These banners and watermarks appear on files 
printed with the Agile Viewer.

Watermarks on attachments are inserted under the file. Therefore, file types that are in “solid” formats (for example, 
PDF, BMP) will not show the watermark. It will show only on “transparent” file types (for example, CAD).

Watermarks

A faint and transparent watermark appears on the current document’s contents. 

Note For high resolution black and white printing, the transparent watermark is printed on the current 
document’s contents. For low resolution black and white printing, the watermark is printed on the current 
document’s contents, but it is not transparent.

The watermark settings are maintained and modified by your Agile administrator; see the Administrator Guide. For 
more information, see Chapter 5 of this manual, “Viewer Administration Tasks.” 

Stamps Group In Print Properties
Note This feature is not available in this implementation of Agile Viewer. 

Printing DGN Files 
Agile Viewer can be configured to print files with a DGN extension in the same manner as MicroStation. This option 
must be configured on the server side; please contact your Agile system administrator for assistance.         
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CHAPTER 5
Viewer Administration Tasks

This chapter describes how the Agile administrator or the system administrator can customize the Agile 
Viewer print options.
❑ Setting the Print Options
❑ Adding Fonts

Note For information about Agile PLM Administrator settings related to the Agile Viewer (for example, 
Supported File and Valid Model File Type settings), see Administrator Guide, “Viewer and Files” section of the 
“General System Settings” chapter. 

For more information about the Agile View Server, including where to find additional Agile View Server 
documentation, see the appropriate Agile installation guide for your Agile PLM system; refer the chapter 
about configuring the Agile View Server. See also “The Agile documentation set includes Adobe® 
Acrobat™ PDF files. The Oracle Technology Network (OTN) Web site contains the latest versions of the 
Oracle|Agile PLM PDF files. You can view or download these manuals from the Web site, or you can ask 
your Agile administrator if there is an Oracle|Agile Documentation folder available on your network from 
which you can access the Oracle|Agile documentation (PDF) files.” on page -vii of this manual.

Setting the Print Options
Some file formats require configuring specific settings to print properly. In general, you can change these settings for 
all users or for individual users:

❑ To change the print settings for all users, you need to modify some of the parameters in the AVS\bin\allusers.ini 
file.

❑ To change the print settings for individual users, you need to modify some of the parameters in each user's .ini 
file under AVS\bin\profiles.

Caution! When you modify options in the allusers.ini file, the existing user profiles are not automatically modified. 
Because editing every individual user profile is impractical, in the procedures below you are instructed to 
delete the existing user profiles when you modify allusers.ini. The next time a user opens the Agile Viewer, 
a new user profile is created which includes the new allusers.ini options settings. You may want to notify 
your users in advance to let them know that their user profiles will be reset. 

To change the way that the watermark, border, and header (banner) appear when printed, you will need to modify 
the following .ini file parameters: 

❑ [OPTIONS] – HPBACKGROUND, KEEPORIGINALCOLORS, and SWSHOWVIEWPORTBORDER

❑ [PRINTWATERMARK] – FONTNAME, FONTSIZE, ORIENTATION, and FONTSTYLE

❑ [PRINTHEADERS] – FONTNAME, FONTSIZE, ORIENTATION, and FONTSTYLE
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The following sections describe the procedures for printing watermarks and borders, and for modifying the headers 
and watermarks. 

Printing Watermarks in .hpg and .plt Files 

To print watermarks correctly in .hpg and .plt files, you must set the background color correctly. 

Note If the watermark image or the color used in the watermark image is not transparent, the watermark will 
not be visible. 

To set the background color:

1 Shut down the JVue server.

2 On the drive where the Agile Viewer Server is installed, find the AVS\bin\Profiles folder. 

3 Delete all the user profiles in this folder (Example: John Smith.ini)

4 Edit the allusers.ini file (AVS\bin\allusers.ini).

5 In the [OPTIONS] section, add or update the following two lines:

HPBACKGROUND = 0

KEEPORIGINALCOLORS = 1

Printing Viewport Borders in SolidWorks Files 

To print viewport borders correctly in SolidWorks files, you must enable the viewing/printing of viewport borders.

To enable the option:

1 Shut down the JVue server.

2 On the drive where the Agile Viewer Server is installed, find the AVS\bin\Profiles folder. 

3 Delete all the user profiles in this folder (Example: John Smith.ini).

4 Edit the allusers.ini file (AVS\bin\allusers.ini).

5 In the [OPTIONS] section, add or update the following line:

SWSHOWVIEWPORTBORDER = 1

Modifying the Header and Watermark Font Settings 

Note The watermark may be truncated if the font size is too large or if there are too many characters in the 
watermark text. Truncation ensures that the watermark does not distort the image.

To set the watermark font size:

1 Shut down the JVue server.

2 On the drive where the Agile Viewer Server is installed, find the AVS\bin\Profiles folder. 

3 Delete all the user profiles in this folder (Example: John Smith.ini).

4 Edit the allusers.ini file (AVS\bin\allusers.ini).

5 In the [PRINTHEADERS] section and in the [PRINTWATERMAK] section, update the lines for Fontname, Fontsize, 
Orientation, and Fontstyle. For example:

FONTNAME = Serif

FONTSIZE = 24

ORIENTATION = 1

FONTSTYLE = 2
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Note ORIENTATION can be specified as 1 (portrait) or 2 (landscape).

Adding Fonts
To ensure that specific fonts are recognized by the Agile Viewer, you can add the font path to the allusers.ini 
configuration file. 

To add fonts:

1 Shut down the JVue server.

2 On the drive where the Agile Viewer Server is installed, find the AVS\bin\Profiles folder. 

3 Delete all the user profiles in this folder (Example: John Smith.ini).

4 Edit the allusers.ini file (AVS\bin\allusers.ini).

5 In the [OPTIONS] section, update the following line:

XFONTPATHS = {paths}

6 Add the full paths of the font files to the line. Separate the paths with a semicolon.

7 Save the allusers.ini file.

8 Clear your web browser’s cache.

9 Restart the JVue server.

Viewing Excel Files
When viewing Excel files in the Agile Viewer, all pages may not be displayed. View the file in its native application 
to verify the correct number of pages in the file.
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