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Preface
This preface includes the following sections: 

About This Manual ........................................................................vii
Other User Manuals ......................................................................vii
For the System Administrator.......................................................viii
Other Documentation ...................................................................viii
Location of HTML and PDF Manuals ........................................... ix
For Customer Support ..................................................................... x

About This Manual
This manual, the Demand Planner User’s Guide, describes how to use the desktop 
demand-planning product, Demand Planner. It includes the following information:

• Basic introduction

• How-to information on using worksheets to examine your data, including the 
forecast

• An extensive glossary

Other User Manuals
Demantra Spectrum provides the following additional manuals for end users:

• Promotions Effectiveness User’s Guide

• Demand Planner Web User’s Guide

• Demantra Settlement Management User’s Guide

• Collaborator Workbench User’s Guide

• TPMO User’s Guide

• Demand Replenisher User’s Guide
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For the System Administrator

Other Documentation
The Demantra Spectrum documentation includes other manuals, mainly for use by 
people implementing a Demantra Spectrum solution:

Manual Contents

Demantra Spectrum 
Administrator’s 
Guide

• Overview of administrative tasks
• Creating users and groups of users; maintaining security of menu 

items
• Managing workflow instances
• Managing the worksheets
• Maintaining the database and using the Scheduler to schedule 

database procedures; wrapping database procedures
• Using the desktop BLE user interface and defining safety stock 

levels
• Configuring the menus and links in Collaborator Workbench
• Upgrading the Demantra Spectrum license
• Troubleshooting appendix

Manual Contents

Demantra Spectrum 
Release Notes

• New and changed features
• Defects fixed in this release
• Known defects in this release
• Late-breaking information, as needed

Demantra Spectrum 
Installation Guide

• Hardware and software prerequisites
• Running the Demantra Spectrum installer
• Upgrading from a previous release
• Starting the server and logging on
• Initiating the Citrix Metaframe Server, if you use this product
• Uninstalling Demantra Spectrum
• Tips on configuration settings and on Tomcat (used for 

demos)

Demantra Spectrum 
Concepts

• Detailed discussion of basic Demantra Spectrum concepts
• Separate chapters with further conceptual details on 

configuring series, levels, worksheets, and so on
• Overview of the implementation tools and process
• Tips on information needed to hand off the solution to users 

and administrators

TPMO Demo Script Standalone document to get readers acquainted with the TPMO 
application.

Demantra Spectrum 
Consultant’s Guide

Information on configuring everything apart from the Analytical 
Engine.

Analytical Engine Guide 
for Demand Planning

Information on configuring the Analytical Engine, for use with 
Demand Planner Web, Demand Planner, and Demand 
Replenisher.
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Location of HTML and PDF Manuals
All Demantra Spectrum manuals are available in PDF format, within the directory 
Demantra_root\Documents. To read a PDF file, use Adobe Acrobat version 4.0 or 
higher. These files are formatted for double-sided printing and contain color graphics 
(which can be printed in color or in black and white).

Most of the manuals are also available in HTML format, as follows:

Analytical Engine Guide 
for Promotions 
Effectiveness

Applies to Promotions Effectiveness. Same general contents as 
Analytical Engine Guide for Demand Planning.

Demantra Spectrum 
Reference Guide

Provides reference material on the following:
• Demantra Spectrum URLs
• Parameters
• Database procedures
• Base data fields
• Functions and operators used in server and client expressions
• Theoretical forecast models
• Workflow step types
• Glossary

Manual Contents

Help Title Contents

User Help HTML versions of the following:
• Demand Planner Web User’s Guide
• Promotions Effectiveness User’s Guide
• Demantra Settlement Management User’s Guide
• Collaborator Workbench User’s Guide
• Member Management and Chaining Management chapters 

from Demand Planner User’s Guide
• Demantra Spectrum Administrator’s Guide
• Combined glossary and index

Offline Help Condensed version of the preceding, covering only the topics that 
apply to working offline.

Consultant Help HTML versions of the following:
• Demantra Spectrum Concepts
• Demantra Spectrum Installation Guide
• Demantra Spectrum Consultant’s Guide
• Analytical Engine Guide for Demand Planning
• Analytical Engine Guide for Promotions Effectiveness
• Demantra Spectrum Administrator’s Guide
• Demantra Spectrum Reference Guide
• Combined glossary and index

Demand Planner Help HTML version of the Demand Planner User’s Guide.

Demand Replenisher 
Help

HTML version of the Demand Replenisher User’s Guide.
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Each help file is contained in a subdirectory of Demantra_root\Documents. Each of 
these directories contains the file helpset.htm. To open the help, open that file from 
an internet browser.

In this release, there is no HTML version of the TPMO documentation.

For Customer Support
For customer support, call 1-866-Demantra (x501) or send email to 
support@demantra.com.
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1 Getting Started with 

Demand Planner
This chapter provides a quick introduction to Demand Planner. It 
includes the following sections:

About Demand Planning .................................................................1
Getting Started with Demand Planner ............................................1
Typical Use of Demand Planner......................................................2
Saving and Viewing Changes ..........................................................3
Quitting Demand Planner ...............................................................4

About Demand Planning
The process of demand planning generally consists of studying historical sales data 
and trying to predict future demand as closely as possible. The goal is to achieve an 
appropriate balance between meeting customer demands as quickly as possible and 
making or buying only as much of each product as required. Demand Planner Web 
and Demand Planner give you insight into both sides of this trade-off.

A demand plan is based on a forecast, which in turn is a prediction of tendencies in the 
supply chain over a period of time, influenced by seasonal and other predictable 
factors. The result of a forecast is a projected curve that has been smoothed to show 
tendencies and de-emphasize the exceptional variations. 

In general, the demand plan and forecast are used in downstream operations such as 
production planning. Depending on how your system has been configured, it either 
exports such data automatically or contains reports that you use for that purpose.

Getting Started with Demand Planner

To start Demand Planner and open a worksheet

1. On the Start menu, click Programs.

2. Click Demantra > Demantra Spectrum release > Demand Planner.

A login window appears, with the main Demand Planner window behind it. 

3. In the User box, type your user name.

Note If you receive a database error, the Demantra Spectrum database is not 
running. Contact your system administrator.
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4. In the Password box, enter your password.

If you do not know your user ID or password, consult your system administrator. 

5. Click OK.

Demand Planner comes up in a new browser window. The page contains a menu 
bar, a toolbar, and a workspace that is initially empty.

The window title will be different, depending on which data you have access to.

6. Click File > Open.

7. Click a worksheet in the list and then click Open.

Now the work area displays a worksheet, and the menu bar and toolbar have many 
more options.

See also

“Core Concepts” on page 5
“Introduction to Worksheets” on page 14

Typical Use of Demand Planner
At a very high level, you might work with Demand Planner as follows:

1. Log onto Demand Planner.

2. Open a worksheet.

3. View the forecast series and other data and work with it in any of the following 
ways, as needed:

• Edit data manually

• Adjust the forecast itself

• Perform a simulation

Note Not all users can access all functions. 

create new 

open existing 

work area

worksheet

worksheet
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• Perform data approval

• Export data for downstream use

4. Log off.

Saving and Viewing Changes
The changes you make are not saved automatically. Also, in the case of changes to 
data, the changes are not necessarily visible immediately.

Saving Changes
You save changes differently depending on whether you have changed data or the 
worksheet definition:

• To save changes that you have made to the data in the worksheet, including 
changes to notes, click Data > Update. 

• To save changes that you have made to the worksheet definition, click File > 
Save.

For information on changing the worksheet definition, see Chapter 4, “Creating 
and Redefining Worksheets” on page 29.

A Note About Series Definitions
When you edit series data in a worksheet, you might not immediately see changes to 
that series and the series that are related to it.

• Some kinds of series are redisplayed instantly to show any changes, if the Recalc 
option is switched on. (These series use a Demantra client expression, which acts 
as a local spreadsheet expression.)

• For other series, Demantra Spectrum must compute how to store the data in the 
database and how to display it at the worksheet level. (These series use a 
Demantra server expression.) These series are not redisplayed instantly with 
changes. Instead, you must wait briefly and then rerun the worksheet.

Note For these series to be calculated, a database procedure must run in the 
background. By default, the required procedure runs several times a 
minute. For details, see the Demantra Spectrum Administrator’s Guide.
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Controlling the Recalc Option
By default, Demand Planner recalculates all client expressions automatically. In some 
cases, such as the following, you may want to switch off this automatic recalculation:

• While running a worksheet at a level that is different from the replenishment 
planning level.

The replenishment planning level is the level at which safety stock is calculated 
and is defined in the Business Logic Engine.

• In resolving the exceptions before accepting the Supply Constraint.

To switch the Recalc option off 

• Click Data > Set Data Recalc Off. 

To force calculation while Recalc is off

• Click Data > Calculate.

To switch the Recalc option on

• Click Data > Set Data Recalc On. 

Viewing Changes to Data
To make sure that you are seeing all changes, do the following:

To see all changes

1. Click Data > Update to save your data changes.

2. Display the Scheduler window and wait until the MANUALS_INS procedure has 
run again.

If you are working at a relatively high level, the MANUALS_INS procedure 
takes longer to run.

3. Return to the worksheet and click Data > Rerun.

Quitting Demand Planner

To quit Demand Planner
• Click Query > Exit. Or click the Exit button.
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2 Core Concepts

This chapter explains the background concepts and terminology. It 
includes the following sections:

Worksheets .......................................................................................5
The Basic Input Data.......................................................................6
Levels ...............................................................................................6
Combinations...................................................................................8
Filtering ...........................................................................................9
Series .............................................................................................10
User Access.................................................................................... 11

Worksheets
A worksheet (sometimes called as a query) is the primary user interface to Demantra 
Spectrum data. Within a worksheet, you can examine and edit data as needed, view 
and adjust the forecast, and run simulations. When you save changes back to the 
database, they become available to other users and to downstream operations.

A typical worksheet looks like the following:

use these dropdown lists to select
data at some aggregation level

series
selected in
this worksheet
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In a worksheet, you generally select an item (or aggregation of items) and a location 
(or aggregation of locations). Then the worksheet displays a set of data aggregated at 
that level. You also specify the time resolution to use, and the data is aggregated in 
time, as well.

At any given time, a worksheet uses a single unit of measure to express most 
quantities, which you can switch. When you do so change, the displayed values are 
changed accordingly. Note that not all quantities use a unit of measure; a percentage 
value, for example, does not use units. The units in your system depend upon your 
implementation but probably include unit count and dollars. For monetary units, you 
can switch to a different index (such as the Consumer Price Index or CPI) or exchange 
rate, and the worksheet automatically multiplies all values accordingly.

The Basic Input Data
When fully configured, Demantra Spectrum automatically imports the following data, 
at a minimum, from your enterprise systems:

• Item data, which describes each product that you sell.

• Location data, which describes each location to which you sell or ship your 
products.

• Sales history, which describes each sale made at each location. Specifically this 
includes the items sold and the quantity of those items, in each sale.

Demantra Spectrum can import and use other data such as returned amounts, 
inventory data, and orders.

Levels
Levels organize and aggregate the input data so that you can study it to identify 
patterns. The levels are completely configurable and are easily extended. Your 
Demantra Spectrum implementors defined levels as required for your organization, 
and an authorized user can add more. Levels are used in worksheets, in import and 
export, and in forecasting.
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Level Terminology
The easiest way to understand the terminology is to consider an example. The 
following figure shows an example (from the demo) of item-type levels, which 
organize and aggregate sales data by various properties of the items being sold:

In this example, SKU, Product Family, and Division are levels, and you can view 
data aggregated and grouped at any of these levels. (You can also view data 
aggregated for all items.) Here the root level is SKU. (This is the lowest item level in 
most Demantra Spectrum implementations.) The Product Family level is the parent 
of the SKU level, and conversely, SKU is the child of Product Family.

Members

Each level includes a set of members, each with different characteristics. For example, 
the SKU level includes a set of members, each corresponding to a different value of 
SKU. In this example, these members include the following (among many others):

• Private Label LF Chocolate

• Private Label LF Chocolate Chip

• Private Label LF Chocolate Wafer

• Private Label LF Cinnamon

• Private Label LF Oatmeal Raisin

• Private Label LF Shortbread

Within a worksheet, you can view aggregate sales data corresponding to each member. 
(You might not see all the members in a given worksheet, because of your security 
access and because of any additional filtering in the worksheet itself.)

The Product Family and Division levels have fewer members, which are shown in the 
figure.
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Kinds of Levels
Demantra Spectrum supports the following kinds of levels, each of which is indicated 
with a different icon:

Combinations
As you explore your data, you are generally most interested in sales for some item at 
some location, as a function of time. Each possible pairing of item and location is 
known as a combination. 

Combinations are central to Demantra Spectrum. Within a worksheet, you display 
data for a combination at any aggregation level. For example, you could display data 
for any of the following:

• Low fat items in Northeast stores

• SKU PLLF202FCPB at CVS 0051

• Private Label Brand cookies at the account Retailer D

• Ice cream, aggregated at all locations

Selecting Combinations

Apart from completely aggregated worksheets, each worksheet gives you a way to 
select the combination to view, as in the following example.

Here the selected combination is “Low fat products at the BJ account.”

Item levels, which group and aggregate data according to characteristics of the 
items you sell.

Location levels, which group and aggregate data according to characteristics of 
the locations where you sell. For example, location levels could describe a 
hierarchy of geographical places. Another location hierarchy could organize 
the locations in some other manner, such as by type of store.

Combination levels, which group and aggregate data according to 
characteristics of the item-location combinations. Combination levels are also 
known as matrix levels.

Time levels, which group and aggregate data by sales date.

Promotion levels, which group and aggregate data by sales promotions. 
Depending on how your system is implemented, you may have a hierarchy of 
promotional levels (to organize the promotions), and the higher levels might 
use different icons.

Note In theory, some implementations may have more than two chief dimensions. 
For example, you might track sales for items, locations, and demand types. In 
this case, a combination is an item, a location, and a demand type.
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In some cases, you view data that is aggregated across one dimension, as in the 
following example:

Here the selected combination is “Low fat products at all locations.”

Combination Status

Not all items are sold at all locations. By default, Demantra Spectrum stores only 
those combinations that have actual sales, and the Analytical Engine considers only 
those combinations. Depending on your implementation and your user access, you 
might be able to create new combinations, for simulation purposes.

Filtering
Filters control the data that you are able to see. The available data may already be 
filtered, and you can apply additional filters to your worksheets as needed. When you 
apply a filter, you specify the following:

• An aggregation level. You can filter data at any level in any dimension.

• Specific members of that aggregation level that are allowed through the filter; 
other members are not included.

The net result is that a filter allows Demantra Spectrum to display only certain item-
location combinations. In the following example, the filter blocks data for all brands 
except for the Rainbow brand.

As a result, the worksheet will display only those item-location combinations that are 
associated with the Rainbow brand. You can filter data at any level, whether or not it is 
chosen as an aggregation level of the worksheet.

Note The Selected Members list cannot include more than 200 members.
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Series
Each worksheet shows series data associated with the combination that you have 
currently selected in the worksheet. A worksheet displays the series data in a table, or 
in a graph, or both. The following shows an example of a worksheet table:

The example here shows series at the lowest level, but you can view data for any given 
series at any aggregation level. The definition of the series controls how the data is 
aggregated. Data can be aggregated in various ways, for example by totalling it, or by 
taking the maximum or the minimum value.

As you can see from this example, there are many possible variations of series:

• Some series are editable (see Stat Frcst), some are editable only for specific 
dates (see Pseudo), and some are not editable at all. Generally, editable series 
are used as input to other series.

• Some series are shown in different colors, depending on the data values. For 
example, Sales Fcst Bias is displayed in red for any values less than zero.

• Some series are calculated from other series.

• Some are populated directly by the Analytical Engine. These series include 
information about the forecast and related information such as markers that 
indicate regime changes, outliers, and so on.

• Most series have time-varying values for each combination, but there are other 
kinds of series as well (discussed below). For example, the series Stat Frcst 
specifies whether a combination should be used in forecasting or not. As you can 
see, this series has the same value for all time buckets for a given combination.

Your implementors created series for your organization’s needs. For an introduction to 
the most important series, see Chapter 6, “Forecasting and Simulations” on page 45.

Kinds of Series
Demantra Spectrum supports the following kinds of series:

• Sales series contain time-dependent set of data for item-location combinations. 
That is, each data point in the series corresponds to a given item-location 
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combination at a given point in time. This type of series is the most common type 
by far.

• Combination series (also called matrix series) store time-independent data for 
each item-location combination. That is, each data point in the series corresponds 
to a given item-location combination. You use combination series to store and 
maintain information about item-location combinations, such as flags for the 
Analytical Engine to use. 

• Level series store data associated with a specific level. Each data point in the 
series corresponds to a given member of that level. 

User Access
Depending on the implementation and on your access, you might not see the same 
data as other users of the system. Your access can be different from that of another 
user in many ways:

• The data you see might be filtered. For example, if you are an account manager, 
you might not be able to see accounts that are not yours.

• You might not see the same aggregation levels. And you should be able to see 
only those units of measure that make sense for the levels you see.

• You might not see the same series.

• You might not have access to all menus listed in the documentation.

• You can use only worksheets that are public or that you defined. Only the owner 
of a worksheet can edit it.

You should also be aware that an individual worksheet might have additional filters 
applied to it.
Demand Planner User’s Guide 11



Chapter 2: Core Concepts

 
 

12 Demand Planner User’s Guide



 
 
3 Using Worksheets

This chapter provides an overview of worksheets and explains how 
to use them. It includes the following sections:

Opening and Running a Worksheet ...............................................13
Introduction to Worksheets ............................................................14
Closing a Worksheet ......................................................................17
Editing Data in a Worksheet..........................................................17
Working with the Graph.................................................................18
Scrolling.........................................................................................19
Viewing Performance Metrics .......................................................20
Locking Data .................................................................................22
Printing a Worksheet .....................................................................22
Exporting Data ..............................................................................23
Viewing the Lowest Combination Count .......................................23
Opening a Note List .......................................................................23
Adding a Note to a Note List .........................................................25
Editing a Note................................................................................25
Deleting a Note..............................................................................25
Specifying Note Permissions .........................................................25
Changing the Layout of the Summary Report ...............................26

Opening and Running a Worksheet

To open a worksheet

1. Click Query > Open. Or click the Open button.

A Select Query dialog box appears.

2. Click a worksheet name and then click OK. Or double-click a worksheet name.

To run a worksheet

Depending on how Demantra Spectrum was configured, it may or may not run a 
worksheet automatically when you open it.

• Within the worksheet, click Data > Run Query. Or click the Run Query 
button.
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To stop a worksheet from running

• Click Cancel.

Introduction to Worksheets
A worksheet displays data for specific item-location combinations. This data consists 
of all the series that are included in the worksheet, most or all of which vary with time. 
You can display a worksheet in either of the following formats:

• Regular format, which includes dropdown lists you use to select the combination 
to view, and a table and graph, which display the series in the worksheet.

When you use the dropdown lists to select a combination, the table and graph are 
updated automatically to display information for that combination.

• Summary format, which consists of a table that displays the series for all 
combinations in the worksheet. This table has one row for each combination.

The Regular Worksheet Format
When you display a worksheet in regular format, it looks like this:

Note This button may not be available in your implementation, due to 
difficulties in the supporting software.

Combination 
selection lists

Graph of series 
for the selected 
item-location 
combination

Table of series
for the selected

combination
item-location
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Combination-Selection Lists

The upper section of the worksheet contains a dropdown list for each level that is 
included in the worksheet. These dropdown lists might not contain all the items or 
locations, because the worksheet may be filtered to exclude some.

For example, if the worksheet includes the City level, then a list of city names appears 
in the dropdown list. The list of city names depends on how the worksheet is filtered. 
If the worksheet is not filtered, all available city names will appear. 

To relocate the dropdown lists

1. Click the striped area at the far left of the dropdown lists.

The dropdown lists appear contained in a box.

2. Drag the box to a new location, and then release the mouse button.

To restore the original display, click the X button inside the box with the 
dropdown lists.

Worksheet Table

A typical worksheet table looks like this:

The color of cells in the leftmost column indicates the type of data displayed in the 
corresponding rows:

]

Green Historic data

Yellow Forecast data

Orange Data that can be either history or forecast. If this worksheet aggregates 
data in time, it is possible for a single table row to aggregate both 
historical and forecast data. Forecast functions are not available for this 
row.
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Non-editable data cells appear in light gray, while editable cells (only those that can 
actually be edited) appear white. Rows containing Summary Information (at the 
bottom of the screen) appear dark gray.

To resize a data column

• Drag the divider between two columns horizontally to the required position.

Worksheet Graph

The graph displays the series in the worksheet. You can specify the graph format.

To view the graph in other formats

Do one of the following:

• On the Data menu, click the option corresponding to the type of graph, for 
example Bar Graph or Pie Chart.

• On the toolbar, click the button corresponding to the type of graph.

To resize the graph

• Drag the divider between the table and graph to the required position.

Summary Format
When you display a worksheet in summary format, it displays data for all the lowest-
level combinations in the worksheet. The result looks like this: 
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To Change the Worksheet Format

To change the format of the worksheet

1. Open a worksheet.

2. Click Data > Options. Or click the Options button.

The Options dialog box appears.

3. Click Worksheet (for the regular format) or Summary Report.

4. Click OK.

5. Click Data > Run Query. Or click the Run Query button.

See also

“Changing the Layout of the Summary Report” on page 26

Closing a Worksheet

To close an a worksheet

• Click Query > Close. Or click the Close button. 

Editing Data in a Worksheet
Depending on the configuration of the worksheet, you can usually edit some of the 
data in it. 

To edit data within the worksheet table 

Any table cell shown in white is editable. You can edit data in the following ways:

• Type directly into the cell and then press Enter or move to another cell. Note that 
this technique does not work in cells that have a dropdown list of choices.

• Click the cell, type into the editable field in the upper left of the worksheet, and 
click Apply.
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For a cell that has a dropdown list, the list of choices appears in this area:

Make a selection from the list and then click Apply.

• Select multiple editable cells within a single column. Either drag the cursor over 
the cells to be selected or click the column title (series) to select the whole 
column. Then type into the editable field in the upper left of the worksheet and 
click Apply.

To cancel your entries, click Edit > Reset Manual Changes. Or click the 
Reset Manual Changes button.

• Copy and paste data within the worksheet table. To copy a data value, select a 
white data cell, and then click Edit > Copy or press Ctrl+c. To paste the value, 
place the cursor in a white data cell, and then click Edit > Paste or press Ctrl+v.

To edit data in the graph

1. In the graph, click a point in the graph and drag the line to a new position.

As you drag the line, a box appears showing data corresponding to the current 
position.

2. When the required value appears in the box, release the mouse button.

Working with the Graph

To see the table row that corresponds to a graph point

• Click the required point in the graph.

The table scrolls to the correct row, which appears selected.

Note If you have previously checked F. Approve and/or Approve in the Series 
dialog box, an Enter Value for Approve dialog box appears. Click 
Checked or Not Checked, and then click OK.

Note The series to which you point must be defined with a symbol in the 
Business Modeler (Graph tab).
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To position the graph data legend

1. Click Data > Legend.

2. Click the preferred legend position: left, right, top, bottom, or none.

Scrolling

To scroll between views

1. In the vertical scroll bar along the left side of the worksheet table, click the box 
and drag it to the required view.

2. When you have reached the required view, release the mouse button.
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Viewing Performance Metrics
The Performance Metrics window displays quantitative measures for each item-
location combination in the worksheet. It does this by comparing the model fit to the 
historical data. This gives you an impression of how well a certain forecast did in a 
given time period.

To view performance metrics

• Click Analysis > Performance Metrics.

The Performance Metrics window appears.

In this window, you can view the following data:

Parameters (Input)

These parameters are used in calculating the Performance Metrics (=Error Metrics 
and Descriptive Statistics)

History Series The history series for which you want to compute performance 
metrics.

Forecast Series The forecast series for which you want to compute 
performance metrics.

From Date/To 
Date

The historic time period used in comparing the forecast to the 
base.

Error Metrics (Output)
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Performance Metrics: Editing the Parameters
For the system to be able to compute performance metrics, you must specify the 
following parameters. The default values of these parameters are taken from the 
worksheet definition, but they may be changed manually.

MAD Mean Absolute Deviation (MAD), the average absolute error 
over several periods. This measure indicates the magnitude of 
the error, regardless of its direction.

RMSE Root Mean Squared Error (RMSE), root of the average squared 
error over several periods. This measure penalizes a forecast 
much more for extreme deviations than it does for small ones.

MAPE Mean Absolute Percentage Error (MAPE), a relative measure 
to the average absolute percentage error over several periods. 
The measure is an index to the actual series, and is useful in 
comparing forecast accuracy among time buckets.

Descriptive Statistics of History Series (Output)

Mean Mean value of the actual series. This measure indicates the 
mean level of the applicable series.

STD (Standard 
Deviation)

Standard deviation of actual series. A measure of variation of 
the actual series around the mean value.

Min Value Minimum value of the actual series. A descriptive measure to 
the minimum of the series.

Max Value Maximum value of the actual series. A descriptive measure to 
the maximum of the series.

Parameter 
(Input) Description

Default from worksheet 
definition

History Series The history series for which you 
want to compute performance 
metrics.

Sales series

Forecast Series The forecast series for which you 
want to compute performance 
metrics.

Batch Forecast version 0

From Date/To Date The historic time period used in 
comparing the forecast to the base.

History periods chosen in the 
worksheet definition
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To edit the parameters

• In the Performance Metrics window, in the Parameters area, change one or 
more of the default values that were used in calculating Error Metrics and 
Descriptive Statistics.

Locking Data
You can lock your worksheet data and make it read-only to other users.

To lock data

• Click Data > Protect Data. Or click the Lock button.

The button appears red.

To release the lock

1. Make sure the worksheet you want to unlock is open.

2. Click Data > Release Protected Data. Or click the Lock button again.

The button reverts to its original appearance.

Printing a Worksheet

To preview the printed worksheet

1. Click Query > Print Preview.

The active worksheet appears in the default table format.

2. Click the appropriate Print Preview toolbar buttons to achieve the following:

Note To be able to edit parameters, the available series must be part of the 
worksheet definition and the time period should be among the number of 
periods in history in the worksheet definition.

Display the worksheet in graph format

Display the worksheet as a summary report

Print the worksheet

Zoom in

Scroll to the first page

Scroll to the previous page

Scroll to the next page
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To print a worksheet

• Click Query > Print. Or click the Print button.

Exporting Data
You can export worksheet data to different applications.

To export worksheet data

1. Click Query > Export. Or click the Export button.

A Save As dialog box appears.

2. Enter a name for the file and specify the type of file you are saving.

3. Click Save.

Viewing the Lowest Combination Count
The Lowest Combination Count indicates the number of combinations that exist at the 
lowest level in the data window.

To view the lowest combination count

• Click Analysis > Lowest Combination Count.

The number of lowest level combinations is displayed.

Opening a Note List
You can add notes to a worksheet to record comments and reminders.

To open a note list

Do one of the following:

• Hold the mouse button over a point in the chart, right-click and then select Note 
List. An existing note list is indicated by a red circle at the base of the chart.

• Select one or more table rows, right-click and then select Note List. If you select 
more than one row, the note will be associated with each of the selected rows.

Scroll to the final page

Close the Print Preview window
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• Double-click the left column. If a note list is already associated with the row, a 
symbol is displayed in the first column.

The Notes List screen appears.

A Note symbol in worksheet table

B Note symbol in graph

A Beginning of text of the note

B Complete contents of the note

C Last edit - user and date

D Level with which note is associated

E Member with which note is associated
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Adding a Note to a Note List

To add a note

1. In the Notes List screen, click Add.

2. Type a note in the note box, and then click Save.

Editing a Note

To edit a note

1. From the Notes List screen, select a note in the List pane and click Edit.

2. Edit text in the Note box, and then click Save.

Deleting a Note

To delete a note

1. From the Notes List screen, select a note in the List pane.

2. Click Delete.

3. Click one of the following:

• Partial Deletion - deletes the note only from the current member/date.

• Total Deletion - deletes the note from all member/dates with which it is 
associated.

4. Click OK.

Specifying Note Permissions
The notes can be viewed by other users. Security permissions can be specified for the 
notes, to determine who can read the note and what type of access they are permitted.

To specify note permissions for individual users

1. In the Notes List dialog box, select the User’s Permission tab.

2. Double-click a user in the Available Users column.

Repeat for each user to whom you wish to grant access permissions.

3. Click a user in the Selected Users column.

4. Click a setting from the Permission dropdown list.

The following options are available:

• Full Control - read, write, add, delete.
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• Read and Write - read, write, add.

• Invisible - the note list is not visible.

• Read Only - read.

To specify note permissions for groups of users

1. In the Notes List dialog box, select the Group’s Permission tab.

2. Double-click a group in the Available Groups column.

Repeat for each group to which you wish to grant access permissions.

3. Click a group in the Selected Groups column.

4. Click a setting from the Permission dropdown list.

Group and User Permission Priorities
A user can be granted permissions that are different from the permissions granted to 
the groups to which that user belongs. The following rules apply:

• Read-only is the default setting for non-selected users.

• When permissions are specify for a particular user, this takes precedence over the 
group permissions.

• If the user has only default settings, the group permissions will take precedence. 

• If a user belongs to more than one group, the highest level of permissions from 
the associated groups will be granted.

Changing the Layout of the Summary Report
You can change the layout used by a worksheet when it is displayed in the summary 
format. Your changes are not saved permanently, however.

To change the layout of the summary report

1. Open a worksheet and switch to the summary format. See “To Change the 
Worksheet Format” on page 17.

2. Click Data > Design Report. 
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The following dialog box appears.

3. To select a level, drag it from the Unselected Levels list to the Selected 
Levels list.

4. To unselect a level, drag it from the Selected Levels list to the Unselected 
Levels list.

5. To select or unselect a series, click the series in the Selected Series list.

The selected series are marked with a check symbol.

6. Click OK.

Note The order in which the levels are listed controls the layout of the 
worksheet.
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4 Creating and 

Redefining 
Worksheets
This chapter explains how to create and redefine worksheets. It 
includes the following sections:

Starting to Create a New Worksheet ..............................................30
Selecting Series..............................................................................30
Applying Exception Filters ............................................................32
Specifying the Confidence Level....................................................34
Specifying the Time Criteria ..........................................................34
Specifying Aggregation Levels ......................................................36
Changing the Overall Scale or Unit of Measure ...........................37
Filtering the Data in the Worksheet...............................................38
Switching the Filter Mode .............................................................39
Adding a Description to a Worksheet ............................................39
Viewing a Worksheet Definition.....................................................40
Saving a Worksheet Definition.......................................................40
Saving a Worksheet with a Different Name ...................................40
Renaming a Worksheet ..................................................................41
Redefining a Worksheet .................................................................41
Deleting a Worksheet .....................................................................42
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Starting to Create a New Worksheet

To start a new worksheet

• Click Query > New. Or click the New button.

A toolbar appears on the left side of the screen, and a New Query window 
appears with the Select Series dialog box displayed on top.

In general, you follow a sequence of steps. On each screen, save your work and 
continue to the next step by clicking Next on the dialog box. Or, to save the criteria 
and return to the previous step, click Back.

To save the criteria and quit the wizard at any time, click OK.

Selecting Series
A worksheet can select up to 40 series.

The Demantra Spectrum database contains different types of information, such as 
budget data, sales data, and forecasts. In the Select Series dialog box you can select 
the types of data you want to retrieve, from a list that was configured for you. 

Choosing categories of information involves three operations:

1. Selecting the series such as budget data, sales data, and forecasts that you want to 
retrieve from the database. Options include default error series, which enable you 
to view error graphs and identify regions of better or worse fit, as well as 
confidence interval series. You may also select outlier series (data points that do 
not seem to follow the characteristic distribution of the rest of the data) and 
regime change marker series (data points in which a change in the demand pattern 
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occurs). These points will then be visible in the graph of the worksheet 
combination.

2. Defining exceptions. If you attach an exception to a worksheet, Demantra 
Spectrum checks the values of the worksheet data and displays only the 
combinations that meet the exception criteria.

3. Specifying the confidence level. The confidence interval for a forecast line gives 
you a range of values around the forecast line where the ‘true’ demand can be 
expected to be found (with a given level of certainty, that is, the confidence level). 
You can change the confidence level to 90% or 99% or use the default of 95%.

To select a series

• In the Select Series dialog box, click the required series. (Repeat as needed.)

To cancel a selection

• In the Select Series dialog box, click a selected series.

Allowed Types of Series
The desktop product supports only numeric sales or combination series. That is, if a 
worksheet includes any of the following types of series, Demantra Spectrum cannot 
run the worksheet:

• Date series

• String series (other that dropdown series, which are stored with numeric value)

• Series that are related to promotions

Sorting and Finding Series in the Select Series Dialog 
Box

To sort the list

1. In the Select Series dialog box, right-click and then select Sort.

A Sort dialog box appears.

2. To determine how the series will be sorted, do one of the following:

Caution You can select no more than 40 series per worksheet.

Note You can select all series (or the first 40 series listed). To do so, right-click 
and then select Check All. Or cancel the selection of all series by 
choosing Uncheck All.
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• Click one or more required boxes in Columns Available for Sorting, and 
drag them to Sort Columns.

• Double-click the required boxes in Columns Available for Sorting.

3. To specify an ascending sorting order, make sure Ascending is checked. For a 
descending order, clear the box.

4. Click OK.

To find a series in the list

1. In the Find dialog box, right-click and then select Find.

A Find dialog box appears.

2. In the Find where box, select Code or Description to find the series by its 
code or by its description.

3. In the Find what box, type the code or the description of the required series, 
depending on your choice in the Find where box.

4. In the Search box, select Up or Down to specify the direction of the search.

5. (Optional) Click one or more of the following check boxes:

• Whole Word: Search for the exact match of a word.

• Match Case: Search for the exact match of a word (case sensitive).

• On Line Search: For immediate search results (even if only part of a word 
has been entered in the Find what box).

6. Click Find Next to begin (or continue) searching.

Applying Exception Filters
If you attach an exception to a worksheet, Demantra Spectrum checks the values of 
the worksheet data and displays only the combinations that meet the exception 
criteria.

Specifically, you define an exception condition that consists of a series, a comparison 
operator, and a value, for example:

When you open the worksheet, Demantra Spectrum checks each combination in the 
worksheet. For each combination, if the condition is met for any time in the worksheet 
date range, Demantra Spectrum displays that combination. For example, the 
worksheet shows combinations that have Sales Plan values greater than or equal to 
150000, within the time range included in the worksheet.

Note This process can be reversed by dragging a box in the opposite direction, 
or by double-clicking a box in Sort Columns.
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If the condition is not met at any time for any of the worksheet combinations, 
Demantra Spectrum shows the worksheet as empty. That is, if all values in the Sales 
series are less than 15000 for all combinations, the worksheet comes up empty.

You can apply multiple exceptions to a worksheet. When you apply multiple 
exceptions, you can relate them to each other via logical AND or logical OR 
relationships. For example:

To apply an exception filter

1. In the Select Series dialog box, click the Exceptions tab.

2. Click Add.

3. In the new row, click the arrow to the right of the series box and select a series 
from the dropdown list.

4. Click the arrow to the right of the operator box and select an operator from the 
dropdown list.

5. (Optional) In the number box, change the default to the required number.

6. Click Verify to ensure that the new exception is valid.

7. (Optional) You can apply additional exceptions. Click the AND or the OR check 
box to specify that the exceptions will have an AND or an OR relationship.

To delete an exception

• Click the exception and then click Delete.

To save the criteria and quit the Select Series dialog box

Do one of the following:

• Click Next to proceed to the Time dialog box

• Click OK to close the Select Series dialog box and quit the worksheet criteria 
entry path.

Note Not all series are necessarily available for exceptions, depending upon the 
implementation. Contact your implementors.
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Specifying the Confidence Level
You can specify a confidence level for your series. The confidence interval for a 
forecast line gives you a range of values around the forecast line where the ‘true’ 
demand can be expected to be found (with a given level of certainty, that is, the 
confidence level). You can change the confidence level to 90% or 99% or use the 
default of 95%.

To specify a confidence level

1. In the Select Series dialog box, click the Confidence Level tab.

2. In the Confidence Level dropdown, select the required percentage.

Specifying the Time Criteria
You use the Time dialog box to specify the time resolution of the worksheet and to 
specify the range of dates to which the worksheet applies. 

To specify time criteria

1. In the Time Scale box, specify the time resolution of the worksheet results. 

2. In the Time Filter box, specify the time period to which the worksheet applies:

• Relative if you always want the worksheet to show a time range relative to 
today (for example, if you want to see two years of history and a one-year 
forecast each time you open the worksheet).

• Fixed if you always want the worksheet to show a specific time range.

3. In the From Date and To Date boxes, enter values depending on the time filter 
you have chosen, as follows:

Note The confidence level series applies only to future periods.

Time Filter Box Action

Relative From 
Date/
To Date

Specify periods in both From and To with the current 
(computer) date as the reference point. 

For example: If the Time Scale is Month, and you want 
to see results starting from six months before today 
until six months after, enter -6 (negative) in From 
Date, and 6 in To Date.
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You can also enter the date from the calendar window.

To insert a date from the calendar

1. In the From Date or To Date boxes, click the Calendar button. 

A Calendar window appears.

2. Select the required month and year from the relevant dropdown lists.

3. Click the date, and then click OK. 

To save the criteria

Do one of the following:

• Click Next to move to the Level dialog box.

• Click Back to return to the Select Series dialog box.

• Click OK to close the dialog box and quit the criteria entry path.

Fixed From Date Enter a specific date as a starting point of the 
worksheet results. This is enabled only from the 
calendar (see “To insert a date from the calendar” on 
page 35).

To Date Specify the number of periods you want to include, 
starting from the From date. The unit period is what 
you selected in Time Scale.

For example: If the Time Scale is Year, From Date 
is 01/01/96, and you want to see results until 12/31/98, 
enter 3 in To Date.

Time Filter Box Action
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Specifying Aggregation Levels
A worksheet can optionally contain aggregation levels; when you use the worksheet, 
you can examine data associated for any members of those levels. If you do not 
specify any aggregation levels, the data is completely aggregated (but is still time-
dependent).

To specify the aggregation levels in a worksheet

1. Click one or more required levels in Unselected Levels, and drag them to 
Selected Levels. Or double-click a level in Unselected Levels.

The selected levels appear checked in Unselected Levels, and are displayed in 
Selected Levels.

To cancel a level selection

• Drag the level in the opposite direction (that is, to the Unselected Levels list). 
Or, in the Selected Levels list, double-click a level.

To save the criteria and quit the Level dialog box

1. Do one of the following:

• Click Next to move to the Filters dialog box.

• Click Back to return to the Time dialog box.

2. Click OK to quit the criteria entry path.

Note You can select a maximum of four levels per worksheet.
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See also

“Changing the Overall Scale or Unit of Measure” on page 37

Changing the Overall Scale or Unit of Measure
Any given worksheet uses a single overall scaling factor and a single unit of measure. 
You can change either or both of these. When you make this change, the displayed 
values for most or all of the series in the worksheet are changed.

To change the overall scaling factor

1. Click Worksheet > Aggregation Levels. Or click the Levels button on the 
toolbar.

The Levels page includes a section where you specify the overall scale of the 
worksheet, as well as its units of measure.

2. In the Scale Units by box, specify the factor by which all numbers in the 
worksheet are to be divided (for display purposes).

For example, if you specify a factor of 1000, the displayed data will divided by 
1000. So the number 96,000 will be displayed as 96. The vertical axis of the 
graph is updated to show the factor in parentheses. For example, if the vertical 
axis was formerly labeled “units”, it will be updated to say “units (1000)” instead.

To change the unit of measure 

1. Click Worksheet > Aggregation Levels. Or click the Levels button on the 
toolbar.

2. In the Unit Type box, select the unit of measure to display in the worksheet 
results. 

For example, our items are bottles, and suppose that a case that contains six 
bottles. If you display the worksheet with cases instead, the system will display 
the number of bottles divided by six.

Note This change affects only the series that are scaled. Not all series are scaled. 
For example, a series defined as a percentage is probably not scaled.
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3. If the Index box is displayed, choose an index from the dropdown list.

The Index menu lists all the time-dependent indexes and exchange rates that are 
associated with this unit. Each index or exchange rate is a time-varying factor that 
the worksheet can use. When you select an index, the worksheet will 
automatically multiply all monetary series by the factor for each date. For 
example, if you choose Consumer Price Index (CPI) as the index, the system will 
calculate all monetary quantities with relation to the CPI.

See also

“Specifying Aggregation Levels” on page 36

Filtering the Data in the Worksheet
You specify the scope of the worksheet by filtering the data that it displays, so that it 
displays only selected members of specific aggregation levels. These aggregation 
levels do not have to be the same as the aggregation levels you display in the 
worksheet (in fact, they are usually different).

To filter the data used in the worksheet

1. Do one of the following:

• In the Filters dialog box, click a level in Select Filters From (which lists 
the available levels) and drag it to Selected Filters.

• Double-click a level in Select Filters From.

2. Under Select Values to Filter, the Select Values From box now displays 
members for the filter you selected. Do one of the following:

• Double-click the member you want to filter out.

• Click a member in the list, and then click the right arrow button.

3. Repeat for each filter you want to add. 

Note These indexes and exchange rates are generally imported from other 
systems. The set available to you depends upon your implementation.

Note The Selected Members list cannot include more than 200 members.
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To save the criteria and quit this dialog box

Do one of the following:

• Click Back to return to the Level dialog box.

• Click OK to close the dialog box.

To filtering, sorting, or find levels in this dialog box

You can filter, sort, and find the levels that are displayed in the Filter dialog box. To do 
so, use the same general technique described in “Sorting and Finding Series in the 
Select Series Dialog Box” on page 31.

Switching the Filter Mode
By default, the filters operate in cascade mode. In this mode, the filters enable you to 
filter only existing combinations or members for your worksheets. You will see only 
members that have combinations with the previously selected members. Members that 
do not have those combinations will not be available in the list.

Your system administrator may or may not have given you the ability to switch the 
filter mode to non-cascading. In non-cascade mode, you see all the members of the 
selected level regardless of the previously selected members from other levels.

To switch the filter mode

• In the Select Values to Filter pane, right-click and then select Turn Cascade 
Filters Off or Turn Cascade Filters On, as needed.

Adding a Description to a Worksheet
You can add a description to your worksheet, allowing you to explain its purpose and 
uses. A description serves only for documentation purposes and does not affect the 
worksheet itself. It is useful mainly in public worksheets as it clarifies the worksheet 
to other users of the system.

To add a description to a worksheet

1. Open a worksheet.

2. Click Query > Description.

The Query Description dialog box appears.

3. Type the required text and then click OK.
Demand Planner User’s Guide 39



Chapter 4: Creating and Redefining Worksheets

 
 

Viewing a Worksheet Definition

To view all selected worksheet criteria

1. Click Data > Properties. Or click the Info button.

A Query Properties window appears.

2. Click the required tab to view its details.

Saving a Worksheet Definition
The worksheet criteria you have entered have been stored temporarily, until you save 
the worksheet itself. After you save a worksheet, you can use it in the future as many 
times as you want. As new sales data is added to the database, you can select a saved 
worksheet and retrieve forecast data based on the criteria that make up the worksheet.

To save a worksheet definition

1. Click Query > Save. Or click Save.

A Query dialog box appears.

2. In the Query Name box, type a name for the new worksheet. 

This name will appear in the Title box of the worksheet window.

3. From the Access dropdown list, select one of the following:

4. Click OK.

Saving a Worksheet with a Different Name

To save a worksheet with a different name

1. Open a worksheet.

2. Click Query > Save As.

A Query dialog box appears.

Note You cannot edit criteria in this window.

Private For your own use only. Data is retrieved from the database, but the 
worksheet is visible only to its owner (the user who created it) and 
the administrator. 

Public Data is retrieved from the database and the worksheet is visible to all 
users; any user may change its definitions.

Note In contrast, the Data > Update option saves the data and notes in the 
worksheet, not the worksheet definition. See “Saving Changes” on page 3.
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3. In the Query Name box, type a different name for the current worksheet.

4. From the Access dropdown list, select required access type.

5. Click OK.

Renaming a Worksheet
You can rename a worksheet. Each worksheet must have a unique name.

To rename a worksheet

1. Open the worksheet that you want to rename.

2. Click Query > Rename.

A Query dialog box appears.

3. In the Query Name box, replace the name of the worksheet with a new one and 
then click OK.

The new name appears in the title bar of the worksheet window.

Redefining a Worksheet
You can change your worksheet criteria. This process may be preferable to creating a 
new worksheet.

To change worksheet criteria

1. On the Data menu, click Series, Time, Levels or Filter. Or click the Series, 
Time, Levels or Filter button.

The appropriate dialog box appears.

2. Make the required changes, and then click OK.

Note In contrast, the Data > Update option saves the data and notes in the 
worksheet, not the worksheet definition. See “Saving Changes” on page 3.

Series

Time

Levels

Filter
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Deleting a Worksheet

To delete a worksheet

1. Open the worksheet that you want to delete. 

2. Click Query > Delete.

A Verify message appears.

3. Click OK.
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5 Viewing the Audit 

Trail
You can view the audit trail that Demantra Spectrum automatically 
creates when users make changes to data and so on. This chapter 
includes the following sections:

Overview........................................................................................43
Viewing the Audit Trail ..................................................................43

Overview
Demantra Spectrum automatically records changes in an audit trail. The audit trail 
includes changes due to user edits within worksheets, updates via the Business Logic 
Engine, and changes caused by import.

You access the audit trail from within an open worksheet. You can view the changes 
that have occurred to the item-location combination that is currently displayed in the 
worksheet.

Viewing the Audit Trail

To view the audit trail

1. In a given worksheet, select a combination.

2. Click Data > Audit Trail.

The Audit Trail screen appears, displaying a table with one row for each change 
recorded in the audit trail. The following information is displayed:

Note You can see only changes that were made by you or other users who are in the 
same collaboration groups as you.

Audit Date Date when change was made.

User Name User who made the change

Update Mode Indicates the type of change: Manual, BLE (Business Logic 
Engine) or Integration

Unit Name Unit of measure that was used at the time of the change

Index Name Index that was used at the time of the change

Series List Series affected by the change
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The data displayed here is filtered by selected levels (population), the series 

selected in the worksheet (date range) and user security (only updates that were 
made by the user or others in the same collaboration group).

3. To see more details, click Details.

A window is displayed, showing more detail.

4. To see information about changes to series, click the Series Values tab.

This tab displays the following information:

5. To see the specific aggregation levels to which this change applies, click the 
Aggregate Level Population tab. Note that the change could have occurred at 
a different aggregation level.

6. To see the filtering that was used at the time of this change, click the Filtered 
Population tab.

Status In Progress, Fail, or Success

Series Name Name of the series that was changed.

Series Value New value used in this series.

Original Value Original value in this series.

From Date First date in the series when the change occurs.

To Date Last date in the series when the change occurs.
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6 Forecasting and 

Simulations
This chapter includes the following sections:

Overview of Forecasting................................................................45
Fine-Tuning the Forecast ..............................................................46
Selecting Forecasting Models........................................................48
Viewing How Causal Factors Affect Models .................................49
Viewing Forecast Tree Information ...............................................50
Filtering and Sorting Forecast Nodes ...........................................51
Performing a Simulation ...............................................................52
Performing Data Approval ............................................................53

Overview of Forecasting
The process of forecasting depends on the following implementation-specific factors:

• How often the Analytical Engine has been set up to run and generate the forecast 
series

• Which series your organization uses

• Which users have access to those series

However, the general process is roughly as follows:

1. Periodically, after the engine has run, open worksheets that contain the forecast 
series and any related series.

2. View the forecast series and make adjustments as needed.

Note If you examine the forecast through the worksheets, you can view only the 
Final Plan, not each of the individual models involved in generating the 
composite forecast. If you examine the forecast through Microsoft Excel, you 
can view each model and its contribution to Final Plan.
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Fine-Tuning the Forecast
You may want to fine-tune your Final Plan. For example, if you intend to launch a 
sales promotion that is expected to yield an increase that will be well above the 
Demantra Spectrum projection, you can add the expected increase manually. Or if you 
foresee a serious drop in sales (for example, because a production unit is out of order), 
you can enter your prediction manually. Such sharp fluctuations in sales cannot be 
anticipated by the Analytical Engine, which bases its projections on historical analysis 
of sales and other time-based factors that are stored in the database.

To change the Final Plan value manually, you can use the Factor value or the Override 
value. Factor and Override can interact with the Final Plan as follows:

• Factor (%) value alone: Only a Factor value is entered to change a Final 
Plan value. Entering a Factor (%) value will add or subtract a percentage of the 
Sales Forecast to the Final Plan. 

The program will calculate the Final Plan on the fly when the Override column is 
null (empty). It is not necessary to update and rerun the worksheet to see the 
Factor’s effect on the Final Plan. This is because calculations are done locally in 
the worksheet, rather than on the server. However, if you want the results of the 
Factor on Final Plan to be written to the database, you must update the data.

When a Factor value is entered, the Final Plan will be equal to the Sales Forecast 
plus the multiple of the Sales Forecast times the Factor value. In other words, 
when a Factor value is entered:

Final Plan = Sales Forecast + (Factor * Sales Forecast)

For example, if the Sales and Final Plan were 10,000, and a 10% factor was 
entered in the Factor column, then the Final Plan will be 11,000 and Sales 
Forecast will be 10,000: 10,000 + (10,000 * 10%) = 11,000

• Override (absolute) value alone: Only an Override value is entered to change 
a Final Plan value. When an Override value is entered, the Final Plan will be 
equal to Override value. In other words, when a Factor value is entered: Final 
Plan = Override.

Override will calculate the Final Plan on the fly. However, if you want results of 
the Override on Final Plan to be written to the database, you must update the data. 
For example, if the Sales and Final Plan were 10,000 and 12,000 was entered in 
the Override column, then the Final Plan will be 12,000 and Sales Forecast will 
be 10,000:

12,000 = 12,000

• Using both Factor and Override values together: Both Factor and Override 
values are used to change a Final Plan value. When both Factor and Override 
values are entered in a row to change a Final Plan, the data must be updated and 
will be recalculated in the spreadsheet. The Final Plan will be equal to the 
Override plus the multiple of the Factor times the Override value.

The effects of the combination of Factor and Override values on the Final Plan 
can be seen immediately.
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For example: If the Sales and Final Plan were 10,000, and a 10% Factor was 
entered along with a 12000 Override, then the Final Plan would be 13,200:

12,000 + (12,000 * 10%) = 13,200.

Batch, Sales, and Final Forecasts
Sales Forecast and Final Plan values work together with manual changes made to data 
by entering values into the Factor and Override columns. It is important to understand 
how these four columns work together.

In normal operation, and by default, Sales Forecast values are equal to the Batch 
Forecast (specified in the worksheet time definition area as the Forecast Version) 
unless changes have been made by a simulation and the simulation has been accepted.

The Final Plan will also be equal to the Sales Forecast in these two situations, unless 
further manual changes are made to the Factor (%) or Override. For example, you may 
open and run a worksheet (Batch, Sales and Final Plan initially all being equal), and 
then run a simulation. At this point, both the Sales and Final Plan values are updated 
to equal the simulation values. Both Sales and Final now reflect any changes from 
Batch Forecast as a result. Finally, you may make manual changes to the Final Plan 
using Factor or Override, or both, and update the data. In this case, all three forecasts 
(Batch, Sales and Final) will have different values for some part of the forecast period. 
Batch will always have the result of the batch forecast used by the worksheet; Sales 
Forecast will be identical to Batch Forecast unless a simulation has changed its value; 
and Final Plan will be identical to Sales Forecast unless a manual change has been 
made to Factor or Override.

Note The data series were configured for you when Demantra Spectrum was 
implemented. The series described here are default ones.

Note If you are viewing data at a high level of aggregation (for example, forecasts 
of all sales in a certain town) and manual overrides and factor changes were 
made at the store level, then the SUM of these lower (child) level values will 
appear at the parent level of Final Plan and Override. As for the Factor value 
at the town (parent) level, this value will reflect the proportional effect that 
each store historically contributed to the overall sales in the town.
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Selecting Forecasting Models
You can select and configure the forecasting models that will be included in the 
forecast. 

To select the forecasting models to use

1. Click Analysis > Model Library.

The Bayesian Model Manager screen appears.

2. Select the models to use as follows:

• To include a model in the forecast, check the check box in the Active column.

• To exclude a model from the forecast, clear the check box in the Active 
column.

To determine historical time periods per series

1. Enter the minimum length in the Min Len column.

2. Enter the maximum length in the Max Length column.

Note The weight given to each forecasting model will be determined 
automatically by the Analytical Engine.

Note The minimum and maximum historical time periods determine the time 
periods when the model will be used. The time period is the time unit 
configured in the system. The minimum number of time periods must be 
equal to, or greater than, the number of causal factors in the forecast, except in 
the HOLT and FCROST models. These models do not work with causal 
factors.
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To specify the analytical configuration

• Click Regime Change Detection to make the forecast detect the existence of 
regime change points.

• Click Outlier Detection to detect and compensate for unusual points in the data 
that may distort the result of the forecasting process and lead to erroneous 
decisions. 

• Click Spread Forecast to produce a smooth continuous demand pattern when 
forecasting intermittent demand. Unselect to allow peaking.

To return to default settings

• Click Default.

To save changes

• Click Save.

To close the window

• Click Close.

Viewing How Causal Factors Affect Models

To view a causal factor affects a model

• Click Analysis > Forecast Tree Information.

The matrix in the Model Coefficients pane displays all causal factors and models 
loaded in the engine. For more information, see “Viewing Forecast Tree 
Information” on page 50. The matrix in the Model Coefficients pane displays all 
causal factors and models loaded in the engine.
Demand Planner User’s Guide 49



Chapter 6: Forecasting and Simulations

 
 

Viewing Forecast Tree Information
You can view analytics of each forecast node that was included in the aggregation for 
the worksheet combination forecast.

To view forecast tree information

• Click Analysis > Forecast Tree Information.

The Forecast Tree Information window appears.

The following information can be viewed in the tables. First, the Forecast Nodes 
list contains all the nodes that were part of the forecast of the worksheet combination:

Note Only the models that performed a forecast on the selected forecast node 
appear in the Legend list. To view the corresponding graph, select the check 
box in the legend.

Item Description Description of item forecast node.

Location 
Description

Description of location forecast node.

MAPE of Forecast 
Node

Mean Absolute Percentage Error. Will be computed during 
the simulation run.

Weight of Forecast 
Node

Shows the impact of the forecast node on this combination. 
It is computed during the simulation run. The formula uses 
global proportion parameters and computes the relationship 
between the forecast node and this combination.

Outlier Flag If visible, indicates at least one outlier on the forecast node.
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Next, the Model Diagnostics table contains information about the selected 
node:

Last, the Model Coefficients table contains the values of causal factors for each 
model. This table contains the entire model involved in the analysis, along with the 
weight of each causal factor and the final model.

Filtering and Sorting Forecast Nodes
You can filter and sort forecast nodes.

To filter forecast nodes

1. In the Filter dialog box, right-click in the Forecast Nodes List area in one of 
the following columns: MAPE of Forecast Node; Weight of Forecast Node; 
Outlier Flag or Regime Change Flag. A pop-up menu appears.

2. Click Filter.

A Filter dialog box appears.

3. Select the expressions by which levels will be filtered in the respective lists. To 
add multiple expressions, click Add and then repeat the process (or delete one by 
clicking Delete).

4. Click OK.

To sort forecast nodes

1. Right-click in the Forecast Nodes List area in one of the following columns:

• MAPE of Forecast Node
• Weight of Forecast Node.

A pop-up menu appears.

2. Click Sort.

A Sort dialog box appears.

Regime-Change 
Flag

If visible, indicates at least one regime-change point on the 
forecast node.

MAPE Relative measure to the average absolute error over several 
periods.

Model Weight Weight of each model.

Outlier Flag Indicates at least one outlier in the model in one of the time 
buckets.

Regime Change 
Flag

Indicates at least one regime change point in the model in 
one of the time buckets.
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3. Click one or more required boxes in Columns Available for Sorting, and 
drag them to Sort Columns. Or double-click the required boxes in Columns 
Available for Sorting.

4. To specify an ascending sorting order, make sure Ascending is checked. For a 
descending order, clear the box.

5. Click OK.

Performing a Simulation

To perform a simulation

1. Make sure the engine process (in Simulation mode) is running on the server. Also 
note that an error will occur if the Analytical Engine has not been run previously.

2. Run a worksheet.

3. On the toolbar, click the Simulate button.

A question box appears.

4. Do one of the following:

• If you click No, Demantra Spectrum will perform a standard simulation.

• If you click Yes, Demantra Spectrum will perform a simulation with forecast 
analytics. In the Analysis menu, the Forecast Tree Information command 
will be enabled and you can view forecast tree data, and you will be able to 
view details.

5. When the simulation is complete, a message appears. 

6. Examine the results, which Demantra Spectrum writes into the Simulation 
series. Note that the Simulation series is displayed in bright green within the 
graph.

7. Optionally view details on how the simulation was created. To do so, click 
Analysis > Forecast Tree Information. See “Viewing Forecast Tree 
Information” on page 50.

8. Do one of the following:

• To accept the results, click Analysis > Accept Simulation. Demantra 
Spectrum copies the data from the Simulation series into the Sales 
Forecast series, where they are visible to other users.

• To reject the results, click Analysis > Remove Simulation. Demantra 
Spectrum clears the data from the Simulation series.

Note To reverse this process, drag a box in the opposite direction or double-
click a box in Sort Columns.
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Performing Data Approval
Depending on your permission level, you may be able to approve or final approve 
data. 

To (final) approve data

• In the worksheet table, select the check box in the Approved and/or F. 
Approve columns:

Note Depending on how your system was configured, when you approve data, the 
system may automatically apply your approval at a higher level as well.

Approved Approve the forecast for this specific item-location 
combination and date.

F. Approved Higher level of approval, only available to users with the 
Supervisor or System Manager permission levels. It also 
confirms the Approve check box if it has not been selected.

Note If you do not have the required permission level, you will not be able to 
see these columns. See the Demantra Spectrum Administrator’s Guide.
Demand Planner User’s Guide 53



Chapter 6: Forecasting and Simulations

 
 

54 Demand Planner User’s Guide



 
 
7 Member Management

Most members and combinations in Demantra Spectrum are 
imported, but you can create new ones for planning purposes. This 
chapter includes the following sections:

Introduction to Member Management ...........................................55
Starting Member Management ......................................................56
Introduction to the Member Management Tool .............................57
Creating a Member........................................................................60
Creating a Combination ................................................................61
Creating Placeholder Data............................................................63
Filtering the Members ...................................................................58
Managing the Lowest-Level Combinations ...................................63
Moving a Member..........................................................................66
Copying a Member ........................................................................66
Renaming a Member......................................................................67
Deleting a Member ........................................................................68

Introduction to Member Management 
Most members and combinations in Demantra Spectrum are imported and have 
historical data. When you are planning new products or new sales locations, however, 
you do not have any imported data to work with. In this case, you can create members 
and combinations directly in Demantra Spectrum, and you can initialize the new 
combinations with data copied from combinations that you expect to be similar. Then 
the Analytical Engine can include the planned combinations in the forecast.

This overall process consists of the following steps:

1. Create a new member at any aggregation level, if the member you need does not 
yet exist. For example, you can create a new SKU or a new distribution center.

2. Create new combinations that include the new member. For example, if you have 
created a new SKU, then create combinations of that SKU with various stores that 
will sell the SKU. Or if you are introducing an existing product to a store where it 
has not been sold, create a combination of that product and store.
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3. Identify some combination that you believe will have a similar sales pattern to the 
new combinations. Copy data for specified series from those combinations to 
your new combinations, optionally multiplying by an overall factor.

Default Members
Demantra Spectrum provides a default member within each level, as a placeholder, for 
example:

These placeholders may or may not be displayed in the worksheets, depending on how 
those worksheets are filtered.

Member Status
Member Management displays the status of each member, as follows:

In a typical system, most members are real.

Starting Member Management

To start Member Management

Do one of the following:

• Within Demand Planner, click Tools > Member Management.

• Within Collaborator Workbench, click Planning Applications > Member 
Management.

Note This step is known as chaining, and is described in “Chaining 
Management” on page 69.

Real Item member that was created by import and that has sales 
records.

Real Location member that was created by import and that has 
sales records. 

New Item or location member that was created by import but that 
does not yet have sales records. When sales data is loaded 
for this member, it will become real.

User-defined 
(also called 
fictive)

Item or location member that was created within through the 
Member Management or Chaining Management tools. 
When this member is loaded via import, it can become new 
or real, depending on whether it has sales data.
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Introduction to the Member Management Tool
Before you start to use Member Management, it is useful to become familiar with the 
user interface, which looks like this.

Displaying Level Members

To display the members of a level

1. In Active Dimension, click either Items or Locations. 

The left window of Member Management displays all the levels of that 
dimension.

2. In the left window, click the level.

3. Optionally filter the display for performance; see “Filtering the Members” on 
page 58.

4. Click Show Members.

Use this area to select a level 
Use this area to select a memberand filter its members

Use this button to start the process of creating combinations
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5. The Member Selection pane displays the members of that level and all 
submembers.

6. In the Member Selection pane, expand the hierarchy as needed.

For performance reasons, the maximum number of members displayed is 
preconfigured for your system. To display more members, click the More 
Members symbol.

By default, Member Management displays the descriptions of the members. To 
see the codes instead, click the Show Members Code check box.

Filtering the Members
You can filter the members that Member Management displays, which can make the 
Member Selection pane display more quickly, and which can make it easier to find 
a particular member.

To filter the displayed members, method 1

1. Click Filter.

The Filter dialog box appears.

2. In the Select Filters From pane, select a level to be filtered.

The list of members for that level is displayed in the Select Values From pane.

Note If you switch from the item dimension to the location dimension and then 
switch back (or vice versa), Member Management does not remember your 
selections. It does, however, remember any filters you applied in either 
window.

Notes • If the list of members is currently filtered in any way, the Filter button 
is colored red as a reminder.

• If you switch from the item dimension to the location dimension and 
then switch back (or vice versa), Member Management remembers 
any filters you applied in either window.

• You can filter by members of any level of any dimension, no matter 
whether you are view item members or location members. 

For example, suppose you are displaying members of an item level. If 
your filter includes only the Rainbow brand, then at any item level, 
you will see only items that belong to the Rainbow brand. If your filter 
includes only the Northeast region, then you will see only items that 
are sold in that region.
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3. Click the members to be included in the Select Values From pane and click the 
arrow to move them to the Selected Values pane, for example:

4. Click OK to return to Member Management.

5. Click Show Members.

To filter the displayed members, method 2

If you previously applied a filter to the other dimension (which is not currently 
displayed), you can copy that filter to this dimension. To do so:

1. Click Bring filters from Location’s filters or Bring filters from Item’s 
filters, whichever button is currently shown. 

When you do this, Member Management finds the information about the filter 
you had applied in the other window and copies it to this window. Then Member 
Management grays out the Bring filters from Location’s filters or Bring 
filters from Item’s filters button and displays the Filter button in red to 
remind you that a filter has been applied. You can click the Filter button and 
make changes as usual.

2. Click Show Members.
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Creating a Member
You can create a member at any level to which you have access.

To create a member

1. Start Member Management, as described in “Starting Member Management” on 
page 56.

2. Display members of any level that is directly above the level to which you want to 
add a member. See “Displaying Level Members” on page 57. 

3. In the Member Selection pane, right-click a member to which you want to add 
a child member.

4. Click Add Member. This option is not available for members at the lowest level.

The Add Member dialog box appears. This dialog box prompts you for 
information about all parent levels of the new member, as well as any attributes of 
the member. The following example does not include attributes.

The parent member that you chose is shown but is grayed out. Other parent 
members might also be pre-selected and grayed out, depending on the filters you 
applied to the display.

Note At the lowest level, you can also create a member by copying an existing 
member; see “Copying a Member” on page 66.
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5. If you are creating a new SKU, this window also prompts you for unit data, as 
follows:

These numbers tell Demantra Spectrum how to scale worksheet data when you 
switch a worksheet to a different unit of measure. The units displayed depend 
upon your implementation. For each unit of measure, do the following

a. For this new SKU, consider the item count per unit of measure. For example, if 
a case contains eight items, the item count is eight. If a truck contains 2000 
items, the item count is 2000.

b. Divide one by the item count: 1/8 or 1/2000, for example.

c. Enter that number: 0.125 or 0.0005.

Demantra Spectrum uses this information to scale worksheet values when you 
choose to display a worksheet in different units. For example, a worksheet 
displays numbers in terms of item count and you then switch to truckloads, the 
displayed numbers should be smaller.

6. Click OK to continue.

Creating a Combination
Before you create a combination, you should know which item member and which 
location member will be in the combination. These members can be at any 
aggregation level; higher levels generally correspond to a greater number of lowest-
level combinations. You will have a chance to see the corresponding lowest-level 
combinations.

To create a combination

1. Start Member Management, as described in “Starting Member Management” on 
page 56.

2. Display members of the item or location level, as described in “Displaying Level 
Members” on page 57. You can start with either dimension. For example, display 
members of the Brand level.

3. Select the member that you are using as the starting point. For this example, click 
the Rainbow member to select it. 

Note If you are not sure what values to use, find a similar item, note the 
values it uses, and use the same values here.

Note This change is immediate and cannot be canceled.
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4. If there are other hierarchies within this dimension, select a member within each 
of them. For example, suppose that the Member selection list includes two 
hierarchies of locations, as follows (shown collapsed to save space).

In this case, you need to select a member within the ship to hierarchy and a 
member within the source warehouse/plant hierarchy.

You do this so that the new combination can be found within both these 
hierarchies. 

5. Click the Link to Location or Link to Item button, whichever button is 
displayed. For this example, click Link to Location.

Now Member Management displays the levels of the other dimension (in this 
case, the locations).

6. Display members of the desired level. For example, display members of the 
Customer Type level.

7. Click the member that you want to combine with previously selected member. 
For example, click Customer-dc.

8. If there are other hierarchies within this dimension, select a member within each 
of them, as described in Step 4 on page 62. 

9. Do either of the following:

• Click Create Combinations. Demantra Spectrum prompts you to confirm 
the action. Click Yes.

• Click Insert Values. Demantra Spectrum prompts you to confirm the action. 
Click Yes. In this case, Demantra Spectrum creates the combinations (if 
necessary) and inserts placeholder historical data (0 values) into the database. 
You will then be able to see this combination in worksheets.

10. Continue as follows:

• To view the lowest-level combinations, click Combination List. See 
“Managing the Lowest-Level Combinations” on page 63.

• To go directly to Chaining Management, click Chaining Management. See 
“Chaining Management” on page 69.

Note To return to the previous screen, click Back.

Notes • Neither option has any effect on existing combinations.

• In either case, the change is immediate and cannot be canceled.
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Creating Placeholder Data
After you create a combination, you can create placeholder data for it so that the 
combination can be displayed in worksheets (with empty rows). Specifically, the 
demand and the forecast are set equal to zero for all dates.

This option has no effect if the combination already exists.

To create a placeholder (zero) data for a combination

1. Start Member Management, as described in “Starting Member Management” on 
page 56.

2. Select a combination in the same way that you create a combination; see 
“Creating a Combination” on page 61.

3. Click the Insert Values button at the bottom of the screen.

Managing the Lowest-Level Combinations

To manage the lowest-level combinations

1. Start Member Management, as described in “Starting Member Management” on 
page 56.

2. Click the Combination List button at the bottom of the screen. 

This button is activated only when both the item and location members to be 
linked have been selected.

Note This change is immediate and cannot be canceled.
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3. In the Combination List, all possible hierarchy links are displayed in three tab 
windows: New Members; Existing Members, and User Defined 
Members.

4. Do one or more of the following:

• To create combinations, select one or more combinations and click Create 
Combinations.

• To add the combinations to the database and create zero histories for them, 
select one or more combinations and click Insert Values.

• To go directly to Chaining Management, click Chaining Management. 

• To save changes and close Member Management, click OK.

• To close Member Management without saving changes, click Cancel.

Tip To select more than one member combination, press Shift+Click or 
Ctrl+Click.
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To filter the displayed combinations

1. Right-click in the Combination List and then select Filter.

A Filter dialog box appears.

2. From the respective dropdown lists, select the expressions by which members 
will be filtered. To add multiple expressions, click Add and then repeat the 
process.

3. Click OK.

To sort the displayed combinations

1. Right-click in the Combination List and then select Sort.

The Sort dialog box appears.

2. Click the required boxes in Columns Available for Sorting, and drag them to 
Sort Columns. Or double-click the required box in Columns Available for 
Sorting.

To sort in ascending order, make sure Ascending is checked. To sort in 
descending order, clear the box.

3. Click OK.

To delete a user-defined combination

You can delete a combination only if it is user-defined.

1. Click one or more user-defined combinations.

2. Right-click and then select Click Delete.

To search the combination list

1. Right-click in the Combination List and then select Find.

The Find dialog box appears.

2. Click the dimension to search from the Find Where dropdown list.

3. Enter text to search in the Find What field.

4. Select up or down in the Search dropdown box.

5. Click one or more from the following, if required:

• Whole Word

• Match Case

• On Line Search 

6. Click Find Next.

Note This process can be reversed by dragging the boxes in the opposite 
direction. Or double-click in the Sort Columns list.
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Moving a Member
You can move a member within to a different parent member at the same level. 
Remember that the next time data is imported, however, the member may be moved 
back to its original parent. Generally you should move a member only if you 
anticipate a change in the enterprise systems with which Demantra Spectrum is 
integrated.

To move a member

1. Start Member Management, as described in “Starting Member Management” on 
page 56.

2. Display members of the level of interest. See “Displaying Level Members” on 
page 57. 

3. Do either of the following:

• In the Member Selection pane, drag the member to a new parent member. 

• In the Member Selection pane, right-click the member and select Cut 
Member. Then right-click the desired parent and select Paste Member.

4. Demantra Spectrum prompts you to confirm the change. Click OK.

5. Click OK to save the change and close Member Management. Or click Cancel 
to discard the change and exit Member Management.

See also

“Copying a Member” on page 66

Copying a Member
You can copy and paste a member at the lowest level. This creates a user-defined 
member.

To cut or copy and paste a member

1. Start Member Management, as described in “Starting Member Management” on 
page 56.

2. Display members of the level of interest. See “Displaying Level Members” on 
page 57. 

3. In the Member Selection pane, right-click the member of interest and then 
select Copy Member.

4. Right-click the member that should be the parent of the copy and then select 
Paste Member.

A confirmation message appears. 

5. Click Yes to continue.
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Demantra Spectrum prompts you for a unique code and description for the new 
member. If this level has attributes, you can specify values for those as well.

6. Complete the fields and click OK.

See also

“Moving a Member” on page 66

Renaming a Member
You can rename any member. Remember that the next time data is imported, however, 
the member name will be overwritten. Generally you should rename a member only if 
you anticipate a change in the enterprise systems with which Demantra Spectrum is 
integrated.

To rename a member

1. Start Member Management, as described in “Starting Member Management” on 
page 56.

2. Display members of the level of interest. See “Displaying Level Members” on 
page 57. 

3. Do one of the following in the Member Selection pane:

• Right-click the member and then select Rename. Then type a new name for 
the member and click Enter.

• Right-click the member and then select Modify Member. Demantra 
Spectrum displays the dialog box where you can change both the description 
(the name) and the code for this member. Make changes and then click OK. 

Then click OK to save the change and close Member Management. Or click 
Cancel to discard the change and exit Member Management.

Note This change is immediate and cannot be canceled.

Note This change is immediate and cannot be canceled.
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See also

“Moving a Member” on page 66
“Copying a Member” on page 66

Deleting a Member
You can delete a member.

To delete a member

1. Start Member Management, as described in “Starting Member Management” on 
page 56.

2. Display members of the level of interest. See “Displaying Level Members” on 
page 57. 

3. In the Member Selection pane, right-click the member of interest and then 
select Delete. This option is available only for user-defined members, which use 
this icon:

A confirmation dialog box appears.

4. Click Yes.

5. Click OK to save the change and close Member Management. Or click Cancel 
to discard the change and exit Member Management.

See also

“Member Status” on page 56
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8 Chaining 

Management
You use Chaining Management to copy series data, typically 
pasting it into new combinations that you created via Member 
Management. This chapter includes the following sections:

Introduction to Chaining ...............................................................69
Opening Chaining Management....................................................70
Introduction to the Chaining Management Tool............................70
Overview of Chaining Options ......................................................74
Defining a New Chaining Operation.............................................77
Performing a Chaining Operation ................................................82
Scenario 1: Copying at Lowest Level (No Similarity) ...................84
Scenario 2: New Product (Location Similarity) ............................86
Scenario 3: Merging Two Locations..............................................88
Scenario 4: Two New Products......................................................89
Scenario 5: Multiple Sources.........................................................90

Introduction to Chaining
Chaining is the process of copying series data from source combinations to target 
combinations. Typically, you do this after you have created a new member or new 
combinations, so that Demantra Spectrum has data to use when forecasting. While 
you set up a chaining operation, you specify each series data to copy, a range of dates 
to copy from, a date to start pasting to, and an optional multiplicative factor for that 
series. During the chaining operation, Demantra Spectrum aggregates the series data 
and then splits it across the target combinations, according to your choice of split 
mechanism.

Demantra Spectrum saves the details of the chaining operation, which means that you 
can run the same operation later if needed.

Note In order for chaining to occur, the Scheduler must be running and the 
Chaining procedure must be active.
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Opening Chaining Management

To open Chaining Management

1. Do one of the following:

• If Member Management is open, click Chaining Management.

• Within Demand Planner, click Tools > Chaining Management.

• Within Collaborator Workbench, click Planning Applications > Member 
Management.

The Chaining Management window opens.

2. Click Retrieve Targets. Chaining Management is updated to display all saved 
chaining operations.

Introduction to the Chaining Management Tool
Before you start to use Chaining Management, it is useful to become familiar with the 
user interface. After you start it, click Retrieve Targets. The following window is 
displayed.

Each row of the Target area represents a saved chaining operation.

Each row of the Source area represents a source combination for the selected chaining operation.

Each row of the Series area represents a series to copy during the selected chaining operation.
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In this window, you can do the following:

• Define chaining operations.

• View details of each saved chaining operation. When you click a row in the table 
at the top of the screen, the rest of the window is updated to show details for that 
operation.

• Edit a saved chaining operation.

• Send chaining operations to be processed in the background. You can rerun 
chaining operations that were processed earlier.

• View the status of past chaining operations.

Selecting Combinations
As you define chaining operations, you need to select combinations for the target and 
the source(s). To do so, you use a window that looks very much like the Member 
Management tool. The general technique is described here, for reference. In this 
example, we will select the combination Item A at Store 99.

To select a combination

1. Display members of the item or location level, as described in “Displaying Level 
Members” on page 57. You can start with either dimension. For example, display 
members of the SKU level.

2. Click the member that you are using as the starting point. For this example, click 
the Item A member.

3. Click the Link to Location or Link to Item button, whichever button is 
displayed. For this example, click Link to Location.

Now Member Management displays the levels of the other dimension (in this 
case, the locations).

4. Display members of the desired level. For example, display members of the Ship 
To level.

5. Click the member that constitutes the “other part” of the combination. For 
example, click Store 99.

6. Optionally filter the combinations as described below. (In this example, filtering 
does not make sense, because we have selected a single lowest-level 
combination.)

7. Click Chaining Management to select this combination and return to the 
Chaining Management user interface.

Note To return to the previous screen and double-check your selection, click 
Back.
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Filtering the Selected Combinations
You can filter the lowest-level combinations that you select

To filter the combinations

1. Click Filter.

The Filter dialog box appears.

2. In the Select Filters From pane, select a level to be filtered.

The list of members for that level is displayed in the Select Values From pane.

3. Click the members to be included in the Select Values From pane and click the 
arrow to move them to the Selected Values pane.

4. Click OK.

5. Click Show Members.

Double-checking the Combinations
You can view the existing lowest-level source or target combinations for any chaining 
operation. 

To view the existing lowest-level combinations

1. Right-click in the Target area or the Source area and then select All 
Combinations.

Note If the list of members is currently filtered in any way, the Filter button is 
colored red as a reminder.

Note There is another way to filter the combinations. If you had previously 
applied a filter when viewing the other dimension, you can copy that filter 
to this dimension. To do so, click Bring filters from Location’s filters 
or Bring filters from Item’s filters, whichever button is currently 
shown.

Note If this option is not available, save your work, exit Chaining 
Management and then reopen it.
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Chaining Management displays a window like the following:

This window lists all the lowest-level combinations that currently exist. It does 
not show you any combinations that the chaining operation itself would create.

2. To close the window, click OK.

3. If you need to make changes, do the following:

a. Right-click in the Target area or the Source area and then select 
Combination List-Item.

Demantra Spectrum displays a dialog box that lists all the items that you have 
selected. Specify the items to include and click OK.

b. Right-click in the Target area or the Source area and then select 
Combination List-Location.

Demantra Spectrum displays a dialog box that lists all the locations that you 
have selected. Specify the locations to include and click OK.

c. Double-check the combinations as described in Step 1, if needed.
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Overview of Chaining Options
This section provides an overview of the chaining options and explains how they are 
related to one another.

Target and Source
The Target, Population, and Source options are related to each other; when you 
set any of these options, you must consider how you have set the other ones. There are 
essentially three general configurations of these settings that are useful:

• One configuration is for item similarity. Here the source and target combinations 
both contain the same item member(s), at the lowest level. For example, store 99 
sells 1500 items. You have created store 100, which will sell the same 1500 items. 
In this case, Demantra Spectrum automatically creates the implied combinations, 
if they do not yet exist; you do not need to create those combinations first in 
Member Management.

• Another configuration is for location similarity. Here the source and target 
combinations both contain the same location member(s), at the lowest level. For 
example, item A is sold in region 5, which has ten stores. You want to introduce 
item B into this region, where it has not been sold previously. In this case, 
Demantra Spectrum automatically creates the implied combinations, if they do 
not yet exist.

• Another configuration is for dissimilar sources and targets. Here the source and 
target combinations contain different item and location member(s). In these cases, 
Chaining Management does not create any combinations; the target combinations 
must already exist.

The following table summarizes the settings to use for each configuration.

Case

Settings to use

Target Members Population Source**

sku ship to Item Location sku ship to

Item 
similarity

all a specific 
location* 

source target all (in this context, 
this means all SKUs 
associated with the 
source location)

a specific location*, 
different from the 
target

Location 
similarity

a specific 
item* 

all target source a specific item* , 
different from the 
target

all (in this context, 
this means all ship-
to’s associated with 
the source item)

No similarity a specific 
item* 

a specific 
location* 

target target a specific item*, 
different from the 
target

a specific location*, 
different from the 
target

*This member can be at any aggregation level and can be filtered.

**Chaining Management ignores any dead source combinations.
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Aggregation and Splitting
For each series (and for each time period), Demantra Spectrum aggregates the data 
from all the source combinations and then splits the value across the target 
combinations.

Splitting Across Both Items and Locations

You specify how to split data across items and how to split data across locations. The 
resulting split proportions are multiplied for each combination. This is best shown by 
an example.

Suppose that you have four target combinations:

• Item 1 at Store A

• Item 2 at Store A

• Item 1 at Store Z

• Item 2 at Store Z

Now suppose you have specified the following split proportions for the items:

Also suppose that you have specified the following split proportions for the locations:

As a result, the overall proportions for each combination would be as follows:

Note For each series, you also have the option not to split the aggregated value at 
all. Instead, you can paste the aggregated value to each target combination.

Item Proportion

Item 1 0.6

Item 2 0.5

Item Proportion

Store A 0.75

Store Z 0.25

Combination Proportion

Item 1 at Store A 0.6 * 0.75 = 0.45

Item 2 at Store A 0.4 * 0.75 = 0.3

Item 1 at Store Z 0.6 * 0.25 = 0.15

Item 2 at Store Z 0.4 * 0.25 = 0.1
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Available Split Options

Within Chaining Management, you do not actually specify the proportions directly as 
percentages as in the preceding examples. Instead, you have the following options:

• Target proportions: Use the stored proportions of the existing targets. (This 
option applies only when all the specified target combinations already exist.)

• Equal proportions: Split the values equally between all lowest level targets. 
This option is suitable if you have no information about how to split across this 
dimension.

• Source proportions: Match each target combination to a source combination. 
Then for each target, use the proportions of the corresponding source.

• Similar proportions: Choose a third set of combinations to use as a reference, 
and match each target combination to a reference combination. Then for each 
target, use the proportions of the reference source.

Series Manipulation and Other Chaining Options
Within a chaining operation, you can copy data for multiple series. For each series that 
you copy, you can specify the following:

• Series to paste data into (often but not always the same as the copied series)

• Factor to multiply data before pasting

• Option to paste the same aggregated data to each combination rather than splitting 
it.

You also specify a range of dates in the source data; Demantra Spectrum selects series 
data in that span of time. And you specify a starting date in the target, where Demantra 
Spectrum starts pasting the selected series.

Note Stored proportions reflect the relative volume of sales of the different 
combinations. Demantra Spectrum calculates this information 
automatically.

Note If there are no valid combinations in the target, the chaining will not 
work and an error message appears. That is, Demantra Spectrum must 
be able to find a reference combination to use for each target 
combination.
76 Demand Planner User’s Guide



Defining a New Chaining Operation

 
 

Defining a New Chaining Operation

Step 1: Specifying the Target
In this step, you specify the Target Members and Population fields. 

To specify the target

1. Start Chaining Management, as described in “Opening Chaining Management” 
on page 70.

2. In the Name column of the new row, enter a unique name for this chaining 
operation.

3. Double-click in SKU or Ship to column of the new row. 

Demantra Spectrum displays a window where you select a target combination, at 
any aggregation level.

4. Select a combination, as described in “Selecting Combinations” on page 71. As 
you do so, optionally apply a filter, if needed. 

5. If there is a similarity between target and source, choose source for either 
Population/Item column or Population/Location column

The following table summarizes the settings to use here.

See also

“Target and Source” on page 74

Step 2: Specifying the Sources
You must specify at least one source combination for each chaining operation. You 
can choose a source at any aggregation level, and you can choose multiple sources. 
Typically you choose sources that have a demand history that is similar to the target.

To specify a source

1. Right-click in the Source area and then select Insert.

A new row appears in the source area.

2. Double-click in the new row. 

Case

Target Members Population

sku ship to Item Location

Item similarity all a specific location* source target

Location similarity a specific item* all target source

No similarity a specific item* a specific location* target target

*This member can be at any aggregation level and can be filtered.
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Demantra Spectrum displays a window where you select a source combination, at 
any aggregation level.

3. Select a combination, as described in “Selecting Combinations” on page 71. As 
you do so, optionally apply a filter, if needed.

If there is a similarity between target and source, make sure to choose source 
combinations that can be matched to the target combinations. The following table 
summarizes the settings to use here:

See also

“Target and Source” on page 74

Case

Source**

sku ship to

Item similarity all (in this context, this means all 
SKUs associated with the source 
location)

a specific location*, different from 
the target location

Location 
similarity

a specific item* , different from the 
target

all (in this context, this means all 
ship-to’s associated with the source 
item)

No similarity a specific item*, different from the 
target

a specific location*, different from 
the target

*This member can be at any aggregation level and can be filtered.

**Chaining Management ignores any dead source combinations.
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Step 3: Specifying How to Split Across Target 
Combinations

For each series, the data is aggregated across all the source combinations and is then 
split to the target combinations as specified within the chaining operation. In the 
Proportions columns, you determine how the split is performed for the items and for 
the locations. The available split styles are as follows

To specify chaining proportions

1. In the Proportions/Item column, click and select a split style, described above.

If you clicked Similar, then the Similar Location for Item tab is enabled (in 
the Source area). Now Demantra Spectrum needs a set of reference 
combinations that contain the same items as the target combinations. To specify 
these reference combinations, you select another location where the target items 
are sold.

a. Click the Similar Location for Item tab.

b. Double-click the empty field in this tab. Demantra Spectrum displays a 
window where you select a location at any level.

c. Select a location member as usual.

d. Click Chaining Management to accept your selection and return to 
Chaining Management.

2. In the Proportions/Location column, click and select a split style, described 
above.

Setting Meaning

Target Use the stored proportions of the existing targets. (This option applies only when all 
the specified target combinations already exist.)

Equal Split the values equally between all lowest level targets. This option is suitable if you 
have no information about how to split across this dimension.

Source Match each target combination to a source combination. Then for each target, use the 
proportions of the corresponding source.

Similar Choose a third set of combinations to use as a reference, and match each target 
combination to a reference combination. Then for each target, use the proportions of 
the reference source.

Note In this case, you cannot apply a filter when you select the member.
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If you clicked Similar, then the Similar Item for Location tab is enabled. 
Now Demantra Spectrum needs a set of reference combinations that contain the 
same locations as the target combinations. To specify these reference 
combinations, you select another item that is sold at the same locations as the 
target items. The steps are similar to the preceding.

Step 4: Specifying Chaining Dates
For each source, you specify a range of source dates, as well as a date to start pasting. 
For the source dates, you specify a start date and either an end date or a number of 
base time buckets.

To specify the chaining dates

1. For each row in the Source area, specify the following:

Step 5: Specifying the Series to Copy
The Series area of the screen lists the series whose data will be copied during this 
chaining operation. Note that when you copy data from one series, you can paste into 
a different series. You can also specify a scaling factor.

To specify the series to copy

For each series whose data you want to copy during this operation, do the following:

1. Right-click in the Series area and then select Insert.

A new row appears.

2. For Source, select the series from which you want to copy data.

3. For Target, select the series into which you want to paste this data.

4. For Factor, optionally specify a factor to multiply this data by before pasting it.

Note These options are ignored if you click the Same Value for All Members 
check box; see “Step 5: Specifying the Series to Copy” on page 80. 

From Date Starting date for the source data. 
(You can use a calendar by clicking the Calendar button.) 

Length The number of base time buckets for which to copy series data.

To Date Ending date for the source data.

Start At Date at which to start pasting series data from this source.
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5. If you want to paste the same aggregated data to each target combination rather 
than splitting it across the combinations, click the Same Value for All 
Members checkbox.

Step 6: Enabling Partial Chaining Indicators (Optional)
If you have specified item similarity or location similarity, then Demantra Spectrum 
matches up each target combination with one or more corresponding source 
combinations (depending on the number of chaining sources you choose). However, if 
the source combinations do not have sales for some or all dates, the chaining operation 
might be considered incomplete.

To alert yourself of such cases, you might want to enable some or all of the partial 
chaining indicators, which are internal flags that mark the combinations and dates for 
which the last chaining operation was incomplete. These indicators are used in 
different ways depending on the implementation. They are most commonly used as 
levels, which then group the combinations so that you can readily see which ones 
require further work.

There are two general types of partial chaining, with subtypes:

• All sources are missing. This occurs when there are issues with all the source 
combinations. That is, none of the source combinations has data for all the dates. 
For all the source combinations, the data is either completely missing (no data for 
any dates) or just partially missing (data for only some dates).

• Some sources are missing. This occurs when there are issues with some source 
combinations. For some of the source combinations, the data is either completely 
missing (no data for any dates) or just partially missing (data for only some 
dates). Some of the source combinations, however, do have data for all dates.

Check with your implementor or your system administrator to understand whether 
your system is set up to take advantage of the partial chaining indicators. If it is, when 
you define a chaining operation, be sure to enable the indicators for that operation.

To enable partial chaining indicators

1. In the Target area of the chaining manager, scroll to the right, to see the following 
columns:

This area lists four possible indicators; you can enable any or all of them.

2. To enable a partial chaining indicator, select a data column from the dropdown 
list. The chaining operation will write that type of chaining indicator into the 

Note If you choose this option, your choices for item and location 
proportions are ignored.
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internal data column, in the row for a given target combination, if there is a 
mismatch between target and source. 

Demantra Spectrum provides default columns that you can use to store partial 
chaining indicators. Typically, for any given indicator, you specify the data 
column that has the same name as the indicator, as follows:

See also

“Target and Source” on page 74

Final Step: Saving the Chaining Operation

To save a chaining operation

1. Make sure that you have given the chaining operation a good name.

2. Optionally add a description, in the Description column in the far right of the 
target area.

3. Click Save at the bottom of the screen.

See also

“Performing a Chaining Operation” on page 82

Performing a Chaining Operation
You can perform any saved chaining operation. The chaining operation overwrites any 
existing data for the target combinations, for the chained dates 

To perform a chaining operation

1. Click Tools > Chaining Management.

The Chaining Management window opens.

2. Click Retrieve Targets. Chaining Management is updated to display all past 
chaining operations.

3. Click the chaining operation that you want to perform.

4. Click Chain.

Note In order for chaining to occur, the Scheduler must be running and the 
CHAINING procedure must be active.
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Demantra Spectrum displays a dialog box that summarizes your selections. 

5. Click OK.

6. Scroll to the middle of the target area of the screen, to the Process Status 
column. This column shows the status of each chaining operation.

The status is one of the following:

not chained This chaining operation has not been run yet or was run 
recently but was not successful.

ready in 
chain

This chaining operation has been sent to the queue and will be 
performed as soon as possible.

done The chaining operation was completed successfully the last 
time it ran.

failed The chaining operation was not successful.
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Scenario 1: Copying at Lowest Level (No Similarity)
In this scenario, we copy data for one combination at the lowest level and we paste 
into a user-defined combination, also at the lowest level. This is not a common 
scenario but is a useful exercise to try.

Example Data
Suppose that SKU 009 is sold in Wal-Mart 001. This combination has the following 
sales (shown here by quarter):

Suppose that we have already used Member Management to create a new item called 
SKU 999, and then to create a combination for SKU 999 at Wal-Mart 001.

The Chaining Operation
We would like to copy the forecast for SKU 009 and Wal-Mart 011 and use that data 
as Pseudo for SKU 999 at Wal-Mart 011. We would like to shift the dates, however, by 
a year.

To copy this data, we set up the following chaining operation:

Option In Chaining Management Setting Notes

Target

Target 
Members

sku sku 999 We have already created this combination via Member 
Management.ship to walmart store 001

Population
Item target

Location source

Proportions

Item source Because there is no sales data yet for the target 
combination, we cannot use target proportions. 

However, the proportions do not actually matter, 
because we are working at the lowest level. 

Location
source
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Result
After Demantra Spectrum performs the chaining operation, SKU 999 at Wal-Mart 001 
has the following data:

Note that Demantra Spectrum does not paste data into Pseudo after 01/20/03; this is 
because Pseudo is editable only in the history. Also, the value for 01/20/03 is slightly 
different from the corresponding value in the source because we are viewing data by 
quarter. If we viewed data at the lowest level (by week), the numbers would be 
identical.

Source

sku sku 009

ship to walmart store 001

From Date 04/23/01

To Date 01/05/04

Start At
04/22/02 This is the date into which we will start copying the 

requested data. This is approximately a year after the 
chosen starting date.

Series

Target Pseudo These options copy data for the Base Frcst series (for 
the chosen source), multiply that data by a factor of 1, 
and then paste the results into the Pseudo series (for the 
target), shifting the dates as described above.

Source Base Frcst

Factor 100%

Option In Chaining Management Setting Notes
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Scenario 2: New Product (Location Similarity)
We want to introduce a new item to the market. We want this item to be sold in all 
locations where an existing item is sold, with the same sales data, multiplied by one 
half and shifted ahead by one year.

Example Data
The item Chocolate Ice Cream is sold in three stores. For example, the demand for this 
item for the quarter Q1 2003 is as follows:

Suppose we just used Member Management to create a new item called Double 
Chocolate Ice Cream. It will be sold in the same stores as Chocolate Ice Cream, and 
we believe its sales will be the same.

Also, in Member Management, we created the new item (Double Chocolate Ice 
Cream), but we did not create any combinations for it.

The Chaining Operation
We would like Double Chocolate Ice Cream to be in combinations with all the same 
stores as Chocolate Ice Cream. For those combinations, we would like the Demantra 
Spectrum database to contain the same demand data, multiplied by 50% and shifted by 
a year.

To create the combinations and copy this data, we use the following chaining 
operation:

Store Demand

Store A 1000

Store B 2000

Store C 3000

Option In Chaining Management Setting Notes

Target

Target 
Members

sku Double Chocolate Ice Cream

ship to all

Population
Item target

Location source

Proportions
Item source

Location source
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Result
The Demantra Spectrum database now includes the following combinations:

• Double Chocolate Ice Cream at Store A

• Double Chocolate Ice Cream at Store B

• Double Chocolate Ice Cream at Store C

Also, the database contains data for these combinations. For example, the data 
includes these values for Pseudo for the quarter Q1 2004:

Source

sku Chocolate Ice Cream

ship to all

From Date 04/23/01

To Date 01/05/04

Start At
04/22/02 This is the date into which we will start copying 

the requested data. This is approximately a year 
after the chosen starting date.

Series

Target Pseudo These options copy data for the Base Frcst series 
(for the chosen source), multiply that data by a 
factor of 1, and then paste the results into the 
Pseudo series (for the target), shifting the dates 
as described above.

Source Base Frcst

Factor 50%

Option In Chaining Management Setting Notes

Store Pseudo

Store A 500

Store B 1000

Store C 1500
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Scenario 3: Merging Two Locations
We have one store in east Manhattan, and one store on the west side of Manhattan. We 
decided to close down the East location and sell its entire items in the West location 
(merge two locations into one of them). We expect no change in the total sales of each 
product. 

Before Chaining

After Chaining

Population Proportion

Item Location Item Location

Source Target Source Target

Source Target

Store East Store West Store West

Item Loc Quan Item Loc Quan Item Loc Quan

I1 L1 10 I2 L2 20 I2 L2 20

I2 L1 20 I4 L2 40 I4 L2 40

I3 L1 30 I2 L2 20

Target

Store West Item Location

I1 L2 10

I2 L2 40

I3 L2 30

I4 L2 40

Target

Item Location

I2 L1 10

I2 L2 20

I2 L3 30
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Scenario 4: Two New Products
We want to introduce a new item to the market. This item has two versions, ‘Classic’ 
and ‘light’. We want these items to be sold in all locations where an existing item is 
sold, and we expect these two versions to have similar sales (all together) as existing 
product. 

- I1: Existing product, G2: hierarchy level of I21;I22
- I21;I22: New products (‘Classic’ and ‘light’, were never chained. 
- East coast: L1, L2, L3

Before Chaining

After Chaining 
Each of the new products should be sold in all source locations. Sales data of each 
source product-location now needs to be split between two products. 

The split mechanism for ‘non-low level’ member will be ‘equal’. In case of integer 
data type and non-integer results when splitting equally (for example, sales: 15, needs 
to be split between two items), the same mechanism currently being used in ‘Manual 
update’ of aggregated level query, should be applied here.

Population Proportion

Item Location Item Location

Target Source Equal Source

Source Target

I1 G2

Item Location Quantity Item Location Quantity

I1 L1 10 I21  

I1 L2 20 I22   

I1 L3 30

Target

G2 Item Location

I21 L1 5

I21 L2 10

I21 L3 15

I22 L1 5

I22 L2 10

I22 L3 15
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Scenario 5: Multiple Sources
The data from two source items is split with multiple series.

A company is about to introduce Product Z to Saver-Store. Product Z is equivalent to 
3 X Product A and 1 X Product B in a different package, but with a price of just 2 X A 
and 1 X B. Soon after the introduction, the company will execute a campaign with a 
large nation-wide supermarket chain; it will be the same type of campaign as with 
product A.

The user selects Product Z and Saver-Store as the target. For the sources, the user 
selects Product A and Product B with Saver-Store as the location.

Sources
Target

Item Location From Series To Series Factor % Item Location

A Saver-Store Demand Pseudo 300

Z
Saver-
Store

Price  Price 200

Discount Discount 100

Event Event 100

Event Intensity Event 
Intensity

100

B Saver-Store Demand Pseudo 100

Price Price 100

Discount Discount 100
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9 Allocation 

Management
You use Allocation Management to quickly split an amount across 
multiple combinations. This chapter includes the following 
sections:

Starting Allocation Management ...................................................91
Keeping the Same Total but Changing Proportions ......................93
Fixing an Absolute Amount and Changing the Remainder ...........95
Accepting or Rejecting Recalculated Values .................................95
Resetting Values.............................................................................95
Working with the Pie Chart ...........................................................96
Examples of Allocation..................................................................96
Exiting Allocation Management and Saving Changes ..................98

Starting Allocation Management
Before you start working with Allocation Management, you set up by specify the 
combinations to work with and the series among which you want to allocate values.

To start Allocation Management

1. Create a worksheet that includes at least one editable series (the series you will 
edit in Allocation Management) and at least two levels. The editable series must 
be proportional, must not be defined as a percentage, and must not be a dropdown 
series.

The worksheet should use the same time resolution that you want to use in 
Allocation Management. That is, if you want to specify data at the monthly level 
and split that data accordingly, the worksheet should view data at the monthly 
level.

Also, if you want to split data according to the proportions of another series, the 
worksheet should include that series.

2. Run the worksheet and display its results in the worksheet format.

3. In the worksheet, select a member from the second lowest level of the worksheet. 
(Select from the dropdown menu that is second to the furthest right dropdown 
menu.)
Demand Planner User’s Guide 91



Chapter 9: Allocation Management

 
 

4. Select a member from the lowest level of the worksheet (select from the furthest 
right dropdown menu). You will be able to allocate values across all members that 
are siblings of this member.

5. If you make any manual changes to the data in the worksheet, save them before 
starting Allocation Management. To save the changes, click Edit > Update.

6. Click Edit > Allocation Management. Or click the Allocation Management 
button 

The Allocation Management dialog box appears.

7. In the Target Data Series field, select the series for which you want to allocate 
values.

8. In the Target Date field, select the date on which to allocate values.

Note that Allocation Management displays only dates that are relevant to the 
selected series and worksheet.

As soon as you select a date, Allocation Management updates the bottom part of 
the worksheet. This display includes one row for each combination that belongs 
to the level you selected in Step 3 on page 91.

9. Optionally click each series listed in View Series.

Allocation Management updates the bottom part of the worksheet to include data 
for the selected series.

For each series, the bottom part of this worksheet lists a column for that series, as 
well as a column that indicates the relative proportions that correspond to each 
combination. In the following example, the worksheet shows series Final Plan 
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and another column (Final Plan %) that shows how each combination 
contributes to the total:

10. Now you can make different kinds of changes. See the following:

• “Keeping the Same Total but Changing Proportions” on page 93

• “Keeping the Same Proportions but Changing the Total” on page 94

• “Fixing an Absolute Amount and Changing the Remainder” on page 95

Keeping the Same Total but Changing Proportions
First see “Starting Allocation Management” on page 91.

To keep the same total but change the proportions

1. For Override Format, select Absolute Values.

Allocation Management updates the bottom section of the window to include the 
Override column.

2. Click the Fix check box for Total. Now the Total cell is uneditable.

3. Edit the values in the Override column in either or both of the following ways:

• Edit the cells in the Override column manually.
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• Copy the header of one of the columns (except for one of the % columns) 
elsewhere in the worksheet. Then click Edit > Copy. Click the header of the 
Override column and then click Edit > Paste.

4. Click File > Recalc. Or click the Recalc button.

5. If you are done, accept or reject the changes. See “Accepting or Rejecting 
Recalculated Values” on page 95.

Keeping the Same Proportions but Changing the Total
First see “Starting Allocation Management” on page 91.

To keep the same proportions but change the total

1. For Override Format, select Percentage Values.

Allocation Management updates the bottom section of the window to include the 
Override% column.

2. Edit the values in the Override % column in either or both of the following 
ways:

• Edit the cells in the Override % column manually.

• Copy the header of one of the % columns elsewhere in the worksheet. Then 
click Edit > Copy. Click the header of the Override % column and then 
click Edit > Paste.

3. Click File > Recalc. Or click the Recalc button.

4. If you are done, accept or reject the changes. See “Accepting or Rejecting 
Recalculated Values” on page 95.
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Fixing an Absolute Amount and Changing the 
Remainder

First see “Starting Allocation Management” on page 91.

To fix an amount and change the remainder

1. For Override Format, select Absolute Values.

2. For any series data that you want to keep, click the Fix check box to make that 
cell uneditable.

3. Edit the other values in the Override column in either or both of the following 
ways:

• Edit the cells in the Override column manually.

• Copy the header of one of the columns (except for one of the % columns) 
elsewhere in the worksheet. Then click Edit > Copy. Click the header of the 
Override column and then click Edit > Paste.

4. Click File > Recalc. Or click the Recalc button.

5. If you are done, accept or reject the changes. See “Accepting or Rejecting 
Recalculated Values” on page 95.

Accepting or Rejecting Recalculated Values
First see “Starting Allocation Management” on page 91.

To accept recalculated values
• Click Edit > Accept. Or click the Accept button.

To reject recalculated values
• Click Edit > Reject. Or click the Reject button.

See also

“Exiting Allocation Management and Saving Changes” on page 98

Resetting Values
You can reset recalculated values so that the last modification will be displayed.

To reset values
• Click Edit > Reset. Or click the Reset button.
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Working with the Pie Chart
Once mix data has been recalculated, the Allocation Management dialog box 
displays a pie chart that shows the respective series. 

To explode the pie chart
• Click Data > Pie Explode. Or click the Pie Explode button.

To display and position the chart legend

1. Click Data > Legend.

2. Click the required legend position.

Examples of Allocation

Example 1
In this example, we allocate a limited amount based on other data series mix. Suppose 
the total production forecast is 180 (USA: 50, Europe: 60, Asia: 70) for product A. 
Also suppose that the total supply available for product A is 120.

In this example, we allocate the final supply based on the percentage values of the 
production forecast for each of the markets. For example, final supply for the USA 
market is 33 units (= 120 supply * 28% production forecast mix):

Date Market

Prod. Forecast Final Supply

Absolute 
value % value

Absolute 
value % value

1/1/2000 USA 50 28% 33 28%

Europe 60 33% 40 33%

Asia Pacific 70 39% 47 39%

Total 180 100% 120 100%
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Example 2
In this example, we allocate a limited amount by first satisfying firm orders and then 
allocating the rest. In this case, first the firm orders are met at each location, and the 
remaining supply will be split based on the production forecast mix by location.

In order to accomplish this, we would work in several stages as follows:

1. Create a series that computes the supply that is available for allocation:

Available Supply = Final Supply - Firm Orders

2. Allocate the total Available Supply (30) based on percentages in the Production 
Forecast.

3. Make sure that Final Supply is calculated as follows:

Final Supply = Firm Orders + Available Supply

Date Market

Firm Orders Prod. Forecast Final Supply

Absolute 
value % value

Absolute 
value % value

Absolute 
value % value

1/1/2000 USA 20 22%  50 28% 28 24%

Europe 30 33%  60 33% 40 33%

Asia Pacific 40 44%  70 39% 52 43%

Total 90 100%  180 100% 120 100%

Market Firm Orders Final Supply Avail Supply

USA 20 28 8

Europe 30 40 10

Asia Pacific 40 52 12

Total 90 120 30

Market Resulting Avail Supply

USA 28% of 30 is 8

Europe 33% of 30 is 10

Asia Pacific 39% of 30 is 12

Total 100% of 30 is 30

Market Avail Supply Firm Orders Final Supply

USA 8 20 28

Europe 10 30 40

Asia Pacific 12 40 52

Total 30 90 120
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Exiting Allocation Management and Saving Changes

To close the Allocation Management dialog box

1. Click Query > Close. Or click Close.

2. In the regular worksheet, click Data > Update.
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A Desktop System 

Menu
If you have access to the System menu, you can perform assorted 
maintenance tasks. This appendix includes the following sections:

Reloading the Configuration .........................................................99
Monitoring Desktop User Sessions................................................99
Changing Global Settings............................................................100

Reloading the Configuration
After making changes in the Business Modeler, you need to restart the desktop 
products or reload the configuration as follows.

To reload the configuration

• Click System > Reload Configuration.

Monitoring Desktop User Sessions
You can monitor the sessions of all users who are currently logged into the desktop 
products (Demand Planner or Demand Replenisher). This has no effect on users who 
are working in the Web products such as Demand Planner Web or Collaborator 
Workbench.

To monitor the desktop sessions

1. Click System > Sessions Monitor.

The Sessions Monitor dialog box appears.

This dialog box displays the session status of all users who are currently logged in 
to the desktop products. In the Active column, users with active sessions appear 
selected. 

2. Here, do any of the following:

Note In order to access the System menu, you must have the System Manager 
permission level.

Note This does not load the changes into the Web-based products.
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• To send a message to a desktop user who is currently logged in, click that user 
and click Send Message. (If the user is not currently logged in, he or she 
does not receive the message, and the message is not resent later.)

• To terminate a user’s desktop session, click the user and optionally click the 
Send message before killing check box. Enter a message when prompted. 
Then click Kill Session. If you chose to send a message, Demantra Spectrum 
prompts you for that message. Type a message and then click OK.

Changing Global Settings

To change global settings

1. Click System > Maintain > Edit Global Parameters.

2. The system displays the following dialog box, where you can set parameters that 
control how Demantra Spectrum operates:

Parameter If parameter is checked... Note

Use of items 
aggregation

The Analytical Engine will run more 
slowly but will give more accurate 
results. 

Setting is not saved. It is applied 
only to this login session.

Debug 
messages

Demantra Spectrum displays debug 
messages if errors occur.

Setting is not saved. It is applied 
only to this login session.

Autorun mode Demantra Spectrum automatically 
runs worksheets as soon as you open 
them.

Setting is saved in the database 
and is applied to all Demantra 
Spectrum sessions, in the desktop 
and in Web user interfaces.

Receive 
Collaboration 
Messages

Any user of the desktop (Demand 
Planner or Demand Replenisher) will 
receive messages if the currently 
displayed data has been changed by 
another user (who is logged onto 
either the desktop or the Web 
products).

Setting is saved in the database, 
but enables messages only in the 
desktop.
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Advanced Users
This appendix provides additional details for interested users.

How Series Are Calculated and Stored........................................101
The Proport Mechanism ..............................................................102

How Series Are Calculated and Stored
Demantra Spectrum stores data only at the lowest possible level. When you run a 
worksheet that uses a specific aggregation level, the series in it are calculated for that 
level. The definition of a series determines how that calculation is done:

• In some cases, the series retrieves data from the database and aggregates it to the 
level in the worksheet. (In these cases, the series is using a server expression.) 
Here, a background database procedure is responsible for maintaining the data.

• In other cases, the series calculates data based on other data that is available at the 
aggregation level in the worksheet. (In these cases, the series is using a client 
expression.) This data is recalculated immediately whenever you make changes in 
the worksheet.

Similarly, when you edit data at an aggregated level, Demantra Spectrum must 
determine how that affects the lowest level in the database. The definition of a series 
controls what happens:

• If a series is proportional, the parent value is split among the child members 
according to the relative proportions of those members. For example, if one item-
location combination had four times as many sales as another, the former 
combination should receive four times as much of the forecast. If a series is 
calculated by summing from lower levels, that series is usually defined as 
proportional. 

For more information on splitting, see “The Proport Mechanism” on page 102.

• If a series is non-proportional, the value for each child member is set equal to 
value of parent. If a series is defined as averaging lower level data or taking the 
minimum or maximum, that series is usually defined as non-proportional.
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The Proport Mechanism
The Demantra Spectrum proport mechanism is used a wide variety of situations. This 
section describes how the proportions are chosen, how they are used, and when 
proport is called.

How Proportions Are Chosen
Demantra Spectrum provides three general ways to specify the relative proportions of 
different combinations:

For chaining, you have additional options for specifying how to split the data. 

How Proportions Are Used
The following figure shows an upper-level member, ABCD, and its four child 
members. It also shows a reference series (Sales), and it shows the value of that series 
for each child member, all within the same time bucket. 

Kind of 
proportions Details When used

Proportions of a 
reference series

A proportional series uses a reference series, 
usually one of the following:
• Demand (suitable for a historical series)
• Final Plan (suitable for a forecast series)

• Automatically used 
when you edit data at 
an aggregated level

“Actual 
proportions”

Split higher-level data according to the 
proportions of the Demand series.

• Option when 
importing data

“Matrix 
proportions”

Proportions that Demantra Spectrum has 
previously calculated and stored. The 
calculation is based upon the demand, but 
also considers recent average demand, month-
to-month variations, and so on. 

• Option when 
importing data

• Automatically used 
when forecast must 
be created at higher 
level

ABCD

Sales: 10

A B

Sales: 20

C

Sales: 30

D

Sales: 40
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Now suppose that series S is a proportional series that uses Sales as its reference 
series, and suppose that the value of S is changed to 350 for the parent member. In this 
case, the series S is split across the child members as follows:

How the Proport Mechanism Handles Null Values

Now consider a case where the reference series has a null value for one of the child 
member. The proport mechanism ignores that member, as follows:

Series S: 350ABCD

Series S: 35 Series S: 70 Series S: 105 Series: 140

Value of S
is split
across
lower
members

If series S is
changed at this
level...

Sales: 10

A B

Sales: 20

C

Sales: 30

D

Sales: 40

Series S: 350ABCD

Series S: null Series S: 105 Series S: 105 Series: 140

Value of S
is split
across
lower
members

If series S is
changed at this
level...

Sales: null

A B

Sales: 30

C

Sales: 30

D

Sales: 40
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How the Proport Mechanism Handles Zero Values

Now let us consider two cases where child members have zero values. In the first case, 
the reference series is zero for one of the child members, but has non-zero numbers for 
other child members. Any member with 0 sales receives 0% of the split, as follows:

Notice that member A that has a null value for the reference series; for this member, 
the value of series S is null, rather than 0.

In the second case, none of the child members has a non-zero value. In a case like this, 
the parent value is split equally among all members that have zero values for the 
reference series.

As always, if a child member has null for the reference series, the proport mechanism 
ignores that member entirely.

Series S: 350ABCD

Series S: null Series S:  0 Series S: 210 Series: 140

Value of S
is split
across
lower
members

If series S is
changed at this
level...

Sales: null

A B

Sales: 0

C

Sales: 60

D

Sales: 40

Series S: 350ABCD

Series S: null Series S:  175 Series S: 175 Series: null

Value of S
is split
across
lower
members

If series S is
changed at this
level...

Sales: null

A B

Sales: 0

C

Sales: 0

D

Sales: null
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4-4-5 calendar

A calendar that consists of financial quarters, in which each quarter consists of a 
“month” of exactly four weeks, followed by a “month” of exactly four weeks, 
followed by another “month” of exactly five weeks. In practice, 4-4-5 calendars 
vary slightly from company to company.

active combination
Item-location combination that is neither dead nor young; see prediction status.

advanced analytics
The process of specifying engine models and engine parameters for different 
combinations within the forecast tree, rather than using the global settings.

aggregation
The process of adding up or otherwise determining a useful summary of a set of 
related data. For example, you might add up the sales for all the products in a 
product group and arrive at an aggregated number for the entire product group. 
Note that aggregation does not always mean simple addition; you can aggregate 
data in other ways.

allocation
The general process of dividing a limited amount included in a data series on a 
product or location group level, to a product or location item level by using the 
proportions mix of group/items of a different data series.

To perform allocation, you use Allocation Management (within Demand 
Planner). 

batch mode
A mode in which you can run the Analytical Engine. In this mode, the 
Analytical Engine uses the entire forecast tree. See also simulation mode.

base time buckets
The time buckets in which data is stored in Demantra Spectrum. Each base time 
bucket contains data corresponding to one base time unit. Users can view data 
aggregated into larger time buckets as well.

base time unit
The smallest possible time unit in your Demantra Spectrum implementation. 
The base time unit determines the time resolution of your system.
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causal factor
Additional information that can explain historical data so that you can improve 
forecast quality (for example: price, CPI, weather, and so on). Specifically, a 
causal factor is a time-varying quantity (such as a series) that affects demand. 
Demantra Spectrum provides the following general kinds of causal factors:

• A local causal factor depends on the time, location, and item being sold. For 
example, it can be a specific discount in a specific store.

• A global causal factor depends only on the time, for example, a holiday. See 
global factor.

You configure causal factors in the Business Modeler. Demantra Spectrum uses 
this information to better understand the sales history and make more accurate 
predictions.

chaining
The general process of associating historical patterns of existing series with 
other series found in a new product or location, with the goal of predicting for 
the new product or location. To perform chaining, you use Chaining 
Management (within Demand Planner). You specify sources and targets.

client expression
Calculates data at a given level, referring to other data at the same level. You use 
client expressions to calculate numbers that cannot be calculated by aggregation 
from lowest-level data. 

A client expression takes precedence over a server expression.

Normally, you use a server expression to retrieve data for the series at the lowest 
aggregation level. For higher aggregation levels, Demantra Spectrum 
automatically aggregates the results of the server expression. In cases where that 
aggregation is not suitable, you use a client expression that explicitly uses the 
data associated with the higher aggregation level.

combination
The combination of an item member (from any hierarchy level) and an location 
member (from any hierarchy level). Each of the following is a combination:

• Chocolate cookies (at all stores)

• Chocolate cookies at the Fair Haven store

• All cookies at Better Stores, Inc.

The word combination can also refer to the data associated with that 
combination, for example, all sales of chocolate cookies at the Fair Haven store. 

combination level
A level that contains time-independent data for combinations. Sometimes called 
matrix level.

combination series
More often called matrix series.
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combination-selection list
Drop-down list at the top of a worksheet. A worksheet typically has several of 
these, and you use them to specify which item-location combination the 
worksheet should display.

confidence interval
Associated with a forecast, a confidence interval gives a range of values around 
the forecast line where the ‘true’ demand can be expected to be located (with a 
given level of certainty, that is, the confidence level, for example, 95% 
certainty). You specify the desired confidence level for each forecast series 
within Demantra Spectrum.

constraint
A restriction designed to limit data from a series to a specific range. If no 
constraint is set for a certain information category, Demand Planner processes 
all data contained in the series.

crosstab
A worksheet that has been configured with levels on the x-axis and/or y-axis.

dead combination
Combination for which sales are not recent enough to be used for prediction. 
See also prediction status.

dimension
Perspective from which a large volume of complex and interrelated data can be 
viewed and analyzed. Each dimension organizes data in one or more hierarchies 
of levels, allowing you to view the data in different ways. Your Demantra 
Spectrum application can have any number of dimensions, which you define in 
the Business Modeler. See also level hierarchy.

exception

If you attach an exception to a worksheet, Demantra Spectrum checks the values of 
the worksheet data and displays only the combinations that meet the exception 
criteria.

Specifically, you define an exception condition that consists of a series, a comparison 
operator (such as equals or greater than), and a value, for example:

Sales > 150000

When you open the worksheet, Demantra Spectrum checks each combination in the 
worksheet. For each combination, if the condition is met for any time in the worksheet 
date range, Demantra Spectrum displays that combination. For example, the 
worksheet shows combinations that have Sales values greater than 150000, within the 
time range included in the worksheet.

If the condition is not met at any time for any of the worksheet combinations, 
Demantra Spectrum shows the worksheet as empty. That is, if all values in the Sales 
series are less than or equal to 15000, the worksheet comes up empty.
Demand Planner User’s Guide 107



Glossary

 
 

You can attach multiple exceptions to a worksheet. When you do so, you can relate 
them to each other via logical AND or logical OR relationships.

fictive
Placeholder. For example, when you first create a member using Member 
Management, that member is not yet associated with any sales data and is 
therefore a fictive member.

filtering
The process of limiting the scope of data. Demantra Spectrum provides two 
general types of filters, each of which allows only certain data to be displayed or 
otherwise used.

The more common filters are combination filters. For this type of filter, you 
specify the following:

• An aggregation level. You can filter data at any level in any dimension.

• Members of that aggregation level that are allowed through the filter; other 
members are not included.

The net result is that a filter allows Demantra Spectrum to display only certain item-
location combinations.

In a few places, Demantra Spectrum provides a different type of filter, a value-specific 
filter that allows only data that contains certain values.

forecast
Predictions about future sales of items at various locations, as a function of 
time. The forecast is based upon the demand, which in turn is based upon the 
historical data. The length of time that the forecast spans is called the forecast 
horizon.

The Analytical Engine creates the forecast, either as the result of the batch 
forecast, or when a user runs and approves a simulation.

forecast model
Mathematical model used to predict forecast. Demantra Spectrum provides a 
about a dozen forecast models that are in common industry use. To create its 
forecast, the Analytical Engine tests each model, sees how well it fits the 
historical data, and uses a weighted combination of the results from all the 
models.

forecast node
Node within the forecast tree.

forecast tree
A single hierarchy of forecast data, the forecast tree is made up of item-location 
combinations at different aggregate levels. Each node in this tree represents a 
time-based series that is subject to forecast. The forecast tree does not need to 
contain all possible combinations, only those that are relevant to the forecasting 
process.
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global factor
A causal factor that depends only on the date of the sale. A global factor affects 
all items and locations in the system. For example, global oil prices have an 
impact on the sales of automobiles. The effect is widespread but changes with 
time. The effect occurs at all locations where the automobile is sold, and for all 
models being sold.

Another possible global factor is a holiday, if all locations in your solution 
follow the same holidays.

group expressions
An expression that defines a subtotal displayed in the desktop user interfaces 
(Demand Planner and Demand Replenisher).

historical data
In general, this is the record of sales of different items at all locations, for 
months or years in the past. For each sale, you must know the location of the 
sale, the product code, price, and quantity. You also typically know information 
about causal factors (such as holidays and promotions) that may have affected 
the sales volume. Demantra Spectrum also uses information about returns, 
inventory levels, and orders.

index
A financial measure used to normalize prices over time. An example is the 
Consumer Price Index (CPI).

item
One of the dimensions by which you view data. Other typical dimensions are 
location and time. Each dimension consists of one or more hierarchies of data, 
allowing you to view data organized in different ways. For example, if you are 
forecasting demand for muffins, the item dimension could contain a product 
group hierarchy and a flavor hierarchy.

level
An aggregation of data. For example, the Color level might consist of the sales 
data aggregated by the color of the items. Each level consists of members. The 
Color level would have one member for each color. 

Levels allow you to view the data in different ways. Demantra Spectrum 
supports the following types of levels:

• Item levels, which organize data in ways that reflect product properties such as 
product family, color, style, and so on. Each member of an item level represents 
time-dependent data aggregated according to some attribute of the items being 
sold.

• Location levels, which organize data in ways that reflect where sales have 
occurred. Each member of a location-type level represents time-dependent data 
aggregated according to some attribute of the stores or locations where the items 
are being sold.
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• Combination levels, which represent time-independent data aggregated by item 
and location. These are less common.

level hierarchy
Each level can belong within any number of independent hierarchies, each of 
which represents a different way of aggregating data. For example, the SKUs 
could be organized into product families, which in turn could be organized into 
divisions as follows, as follows:

In this example, Division, Product Family, and SKU are all levels in Demantra 
Spectrum.

The SKUs could also be organized into brands as follows:

Note that this hierarchy is independent of the product family hierarchy. That is, there 
is not necessarily any relationship between brands and product families. Nor is there 
any relationship between brands and divisions.
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Given these relationships, a member can have parents. For example, consider the SKU 
member Rainbow LF Chocolate Chip. This SKU might have the following parents:

• Regular (parent of this SKU within the product family level)

• Rainbow (parent of this SKU within the brand level)

live combination
Item-location combination that is neither dead nor young; see prediction status.

local causal factor
See causal factor.

location
A dimension by which you view data. Other typical dimensions are item and 
time. Each dimension consists of one or more hierarchies of data. For example, 
the location dimension could be broken down into country and then into states 
and towns.

matrix level
See combination level.

matrix series
A series that consists of time-independent data for each item-location 
combination. This data is stored in mdp_matrix.

member
An element of a level. Each level contains one or more members. For example, 
at the city level, members may include Paris and London. 

Each member corresponds to a set of sales data. Each member has properties 
that apply to the sales data at that level, such as unit, description, and an 
identifying code.

There are several types of member

member management
The process of creating, editing, and deleting level members.

Real Member that was created by import and that has sales data. Most 
members are real.

New Member that was created by import but that does not yet have sales 
data. When sales data is loaded for this member, it will become real.

User-defined 
or fictive

Member that you have created via one of the following:

• Members Browser in a Web-based worksheet. 

• Member Management in Demand Planner and Demand 
Replenisher.

When this member is loaded via import, it will become new or real, 
depending on whether it has sales data. 
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model
Mathematical model that the Analytical Engine uses when creating a forecast.

outlier
An atypical observation, generally infrequent; a data point that does not appear 
to follow the characteristic distribution of the rest of the data. Outliers may 
reflect genuine properties of the underlying phenomenon (variable), or may be 
caused by measurement errors or other anomalies that should not be modeled.

Some of the Demantra Spectrum forecast models automatically identify and 
exclude outliers, and Demantra Spectrum indicates when that occurs. You can 
manually identify outliers as well.

POS data
Point-of-sale data.

prediction status
When generating forecasts, the engine considers the prediction status of each 
item-location combination. Prediction status is one of the following:

The Analytical Engine ignores any young or dead combinations.

proport
Mechanism that Demantra Spectrum uses for splitting aggregated data across 
the corresponding lowest-level members. Demantra Spectrum splits data on 
many occasions, including the following:

• When the Analytical Engine generates a forecast at an aggregated level

• When data is imported at an aggregated level

• When users edit aggregated data

• When users perform chaining at an aggregated level.

proportions
Split proportions used by the proport mechanism.

query
See worksheet.

Status Description

Young Sales for this combination are too new to be used for prediction.

Dead Sales for this combination are not recent enough to be used for prediction.

Live Neither young nor dead. Also called active.

Create Zero Forecast A user has specified this prediction status manually for this item-location 
combination, and this status means that this combination should have a 
forecast consisting of zero values. 
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regime change
A point in time when a change in the demand pattern occurs. Demantra 
Spectrum can automatically flag when regime changes occur.

sales series
A series that consists of time-dependent data for each item-location 
combination. That is, each data point in the series corresponds to a given item-
location combination at a given point in time. This type of series is the most 
common type by far.

seasonality
If historical data has a regular pattern of observations above and below a trend, 
the data is said to be seasonal. Seasonality is generally observed in data 
compiled on a less than annual basis (for example, quarterly or monthly).

series
Usually, a time-dependent set of data. For example, sales data and the forecast 
are both series. 

A series can be defined by a server expression, a client expression, or both. 

server expression
The SQL expression that calculates the series data at any level by aggregating 
the associated lowest-level data. A very common server expression has the 
following form:

sum (table_name.update_column_name)

Here table_name.update_column_name is the table and column that stores data 
for this series. The server expression often includes the unit of measure in which 
results are expressed. 

A client expression takes precedence over a server expression. 

simulation
A ‘what if’ scenario in which a user may manipulate measure data (such as 
History) and examine the way in which the changes affect related measure data 
(such as Forecasts). 

To perform a simulation, you use the Simulation Engine.

simulation mode
A mode in which you can run the Analytical Engine. In this mode, you perform 
evaluate a scenario, to see what might happen in a given situation. In contrast to 
batch mode, you use only a small part of the forecast tree and a comparatively 
small set of data series.

splitting
In general, splitting refers to the general process of dividing an aggregated 
amount into appropriate parts. See proport.
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spreadsheet
The set of series used in Demantra Spectrum. You can use this set of series in 
the same way as a spreadsheet. Each worksheet generally presents the series 
within a table or spreadsheet format.

summary report
A variant of a worksheet table that displays one row for each combination that 
the worksheet contains. This table can be in crosstab format.

time
A dimension by which you view data. Other typical dimensions are item and 
location.

time bucket
Depending on context, this phrase refers to any of the following:

• The base time buckets.

• A specific period of time corresponding to a time unit (the week of 1/3/05).

• The data associated with that period of time (the data associated with the week of 
1/3/05). If you consider a set of series as a spreadsheet, with time as the horizontal 
axis, then a time bucket is a vertical slice of the data.

• A time unit (a week).

time level
A level that aggregates data across time. Depending on your system, time levels 
are configured to enable you to analyze data by the specific month of the year, 
day of the week, and so on.

time resolution
In general, time resolution specifies the amount of visible detail for time-
dependent data. Specifically, it refers the time unit by which this data is 
grouped, for example, by months or weeks. See also time unit.

time unit
A unit of time in Demantra Spectrum, such as day, week, month, and others, 
including the months of a 4-4-5 calendar.

The base time unit (or minimum time unit) is the smallest length of time that 
your data model represents. This can be either a day, a week, or a month, by 
default; smaller buckets are possible but require custom work. The size of the 
base time unit determines the maximum possible time resolution of your model. 

trend
The long-term behavior of data, over time. 

waterfall chart
A chart that displays both the current version and past versions of the same data.
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worksheet
A set of data retrieved from the Demantra Spectrum database. In a worksheet, 
you specify information such as following:

• At least one series to retrieve from the database

• The levels of aggregation to view in the worksheet

• Optional filtering to set the scope of the worksheet

A worksheet can be public (shared with other Demantra Spectrum users) or 
private. Only the owner of a worksheet can edit it.

A worksheet is also known as a query.

x-axis
The horizontal axis of a worksheet graph and correspondingly, the vertical axis 
of a worksheet table.

y-axis
The vertical axis of a worksheet graph and correspondingly, the horizontal axis 
of a worksheet table.

young combination
Item-location combination for which sales are too new to be used for prediction. 
See also prediction status.

zero history
Historical data consist of zero sales. You usually create zero history for 
combinations you create via Member Management, so that there are placeholder 
records that you can edit.
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