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Other User Manuals ......................................................................vii
For the System Administrator.......................................................viii
Other Documentation ...................................................................viii
Location of HTML and PDF Manuals ........................................... ix
For Customer Support ..................................................................... x

About This Manual
This manual, the Demantra Settlement Management User’s Guide, describes how to 
use Settlement Management. It includes the following information:

• Basic introduction

• How-to information on using worksheets to examine your data, including the 
forecast

• Keyboard shortcuts

• An extensive glossary

Other User Manuals
Demantra Spectrum provides the following additional manuals for end users:

• Collaborator Workbench User’s Guide

• Promotions Effectiveness User’s Guide

• Demand Planner Web User’s Guide

• TPMO User’s Guide

• Demand Planner User’s Guide

• Demand Replenisher User’s Guide
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For the System Administrator

Other Documentation
The Demantra Spectrum documentation includes other manuals, mainly for use by 
people implementing a Demantra Spectrum solution:

Manual Contents

Demantra Spectrum 
Administrator’s 
Guide

• Overview of administrative tasks
• Creating users and groups of users; maintaining security of menu 

items
• Managing workflow instances
• Managing the worksheets
• Maintaining the database and using the Scheduler to schedule 

database procedures; wrapping database procedures
• Using the desktop BLE user interface and defining safety stock 

levels
• Configuring the menus and links in Collaborator Workbench
• Upgrading the Demantra Spectrum license
• Troubleshooting appendix

Manual Contents

Demantra Spectrum 
Release Notes

• New and changed features
• Defects fixed in this release
• Known defects in this release
• Late-breaking information, as needed

Demantra Spectrum 
Installation Guide

• Hardware and software prerequisites
• Running the Demantra Spectrum installer
• Upgrading from a previous release
• Starting the server and logging on
• Initiating the Citrix Metaframe Server, if you use this product
• Uninstalling Demantra Spectrum
• Tips on configuration settings and on Tomcat (used for 

demos)

Demantra Spectrum 
Concepts

• Detailed discussion of basic Demantra Spectrum concepts
• Separate chapters with further conceptual details on 

configuring series, levels, worksheets, and so on
• Overview of the implementation tools and process
• Tips on information needed to hand off the solution to users 

and administrators

TPMO Demo Script Standalone document to get readers acquainted with the TPMO 
application.

Demantra Spectrum 
Consultant’s Guide

Information on configuring everything apart from the Analytical 
Engine.

Analytical Engine Guide 
for Demand Planning

Information on configuring the Analytical Engine, for use with 
Demand Planner Web, Demand Planner, and Demand 
Replenisher.
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Location of HTML and PDF Manuals
All Demantra Spectrum manuals are available in PDF format, within the directory 
Demantra_root/Documents. To read a PDF file, use Adobe Acrobat version 4.0 or 
higher. These files are formatted for double-sided printing and contain color graphics 
(which can be printed in color or in black and white).

Most of the manuals are also available in HTML format, as follows:

Analytical Engine Guide 
for Promotions 
Effectiveness

Applies to Promotions Effectiveness. Same general contents as 
Analytical Engine Guide for Demand Planning.

Demantra Spectrum 
Reference Guide

Provides reference material on the following:
• Demantra Spectrum URLs
• Parameters
• Database procedures
• Base data fields
• Functions and operators used in server and client expressions
• Theoretical forecast models
• Workflow step types
• Glossary

Manual Contents

Help Title Contents

User Help HTML versions of the following:
• Demand Planner Web User’s Guide
• Promotions Effectiveness User’s Guide
• Demantra Settlement Management User’s Guide
• Collaborator Workbench User’s Guide
• Member Management and Chaining Management chapters 

from Demand Planner User’s Guide
• Demantra Spectrum Administrator’s Guide
• Combined glossary and index

Offline Help Condensed version of the preceding, covering only the topics that 
apply to working offline.

Consultant Help HTML versions of the following:
• Demantra Spectrum Concepts
• Demantra Spectrum Installation Guide
• Demantra Spectrum Consultant’s Guide
• Analytical Engine Guide for Demand Planning
• Analytical Engine Guide for Promotions Effectiveness
• Demantra Spectrum Administrator’s Guide
• Demantra Spectrum Reference Guide
• Combined glossary and index

Demand Planner Help HTML version of the Demand Planner User’s Guide.

Demand Replenisher 
Help

HTML version of the Demand Replenisher User’s Guide.
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Each help file is contained in a subdirectory of Demantra_root/Documents. Each of 
these directories contains the file helpset.htm. To open the help, open that file from 
an internet browser.

In this release, there is no HTML version of the TPMO documentation.

For Customer Support
For customer support, call 1-866-Demantra (x501) or send email to 
support@demantra.com.
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1 Introduction to 

Settlement 
Management
This chapter provides a quick introduction to Settlement 
Management and the other Web-based Demantra Spectrum 
products with which it works. It includes the following sections:

Overview to Settlement Management ..............................................1
Getting Started with Settlement Management .................................3
Logging Onto Settlement Management ...........................................7
Typical Tasks in Settlement Management ........................................8
Worksheet Usage Modes..................................................................8
Logging Off Settlement Management ..............................................8
Ending a Hung Session....................................................................9
Changing Your Password ................................................................9
Other Demantra Spectrum Products in Your Solution ..................10

Overview to Settlement Management
Demantra Settlement Management is a Web-based, configurable tool to help you 
resolve settlements with customers (usually retailers) who have run promotions, sold 
your products, and now need reconciliation. You view the promotional events that 
Settlement Management provides as possible matches, and then select one and finalize 
the match. You can then attach proof of performance for the promotion, approve the 
match, and request a check to be sent to the customer (if appropriate). You can also 
mark a settlement as a duplicate, split a settlement (typically to match only part of it), 
or deny a settlement.

Often, a third party (a broker) has negotiated the terms. Your Demantra Spectrum 
system may be set up to enable you to collaborate with the broker, for example, to 
acquire extra information if needed.

Types of Settlements
The specific terms you use may be different, but Settlement Management organizes 
settlements into two groups: trade and non-trade. For trade settlements, Settlement 
Management recognizes three general types of settlements:
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• A claim is a request from a customer for payment. In these cases, the customer 
has run the promotion and is requesting to be reimbursed, based on an agreement 
between you and the customer. If you approve the claim, you request for your A/P 
department to send a check to this customer or to the broker, as applicable.

• A deduction is a short payment on an invoice. In these cases, the customer has run 
the promotion and has made a short payment on an invoice. By permitting this 
short payment, you are reimbursing the customer for running the promotion.

• An off-invoice settlement represents the case where the customer was billed a 
lower amount (that is, “off invoice”) for the products, as compensation for 
running the promotion.

Settlement Stages
Within Settlement Management, a settlement can go through the following stages:

In general, claims come into Settlement Management through your accounts payable 
(A/P) department. Deductions and off-invoice settlements come into Settlement 
Management through in your accounts receivable (A/R) department. In all cases, the 
settlement is loaded into Settlement Management automatically.

Then, in most cases, the processing is as follows:

1. When you receive a new settlement, you take ownership of it so that you can 
process it. At this point, the settlement is In Progress.

2. Then you review the possible promotions to which the settlement may apply. 
Settlement Management displays suitable possible matches.

New In Progress Matched

Duplicate

Denied

Approved

Settlement is sent 
from your A/P or A/R 
department

Settlement is sent 
back to your A/P or 
A/R department
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3. If you find a matching promotion, you match the settlement and validate the proof 
of performance. Usually, you scan in a document that shows that the promotion 
was actually run as required, and then you upload that as an attachment to the 
settlement. 

4. If the settlement is a claim, you then issue a check request to your company’s A/P 
department, to send a check to the customer or to the broker as needed.

5. You (or another person) then approve the settlement. In some organizations, the 
customer service department (CSD) representative has authority to approve a 
settlement. In others, a manager does that job.

In other cases, you may find that the settlement is a duplicate or you may find another 
reason to deny it, per your company’s policies and practices. When you deny a 
settlement, your A/P system may enter a chargeback to the customer.

Also, you can also split the settlement and match only part of it, as appropriate.

See also

“Getting Started with Settlement Management” on page 3
“Demantra Spectrum URLs” on page 139

Getting Started with Settlement Management
This section provides a quick tour of Settlement Management and the basic areas of 
the screen.

Initial Logon
The first time you log onto Settlement Management, Demantra Spectrum typically 
downloads and installs software. This operation is quick and occurs only once for each 
machine you use.

1. Open Microsoft Internet Explorer.

2. Enter the web address supplied by your system administrator. This URL probably 
has the following format:

http://server name/virtual directory/portal/partnerLogin.jsp

For example:

http://frodo/demantra/portal/partnerLogin.jsp

3. Type your name and password and click Login.

Demantra Spectrum prompts you to install JRE.

4. When you are prompted to install JRE, do so. Choose the Typical installation 
and accept all the default values, unless otherwise advised by your system 
administrators. 

Tip Your Windows Start menu may also include a shortcut to this URL.
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Next, Demantra Spectrum displays a dialog box that asks if you want to trust the 
signed application distributed by Demantra. The dialog box is slightly different 
depending on your configuration.

5. Click Yes (or Always) or Start, depending on which dialog box is displayed.

After the initial configuration is completed, Demantra Spectrum displays a new 
browser window. The page contains a menu bar, a toolbar, and a workspace that is 
initially empty.

6. Click File > Open.

7. Click Settlement Details By Account and then click Open.

create new 
worksheet

open existing 
worksheet

work area
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A Quick Tour of Settlement Management
On the Settlement Management screen, notice the following major areas:

• Standard title bar with options to maximize, minimize, and close the screen.

• Menu bar. The most commonly used menu options let you edit and save data, 
print data, export data, change the display in minor ways, and so on.

• Tool bar with shortcuts to perform Demantra Spectrum actions.

• The Settlement Details By Account worksheet, which displays settlements 
in different processing stages, and promotions that you can associate them with.

Settlement Details By Account Worksheet
This worksheet is the main work area. It consists of multiple tabs, and each tab 
displays settlements in a specific processing stage:

• The Unresolved Trade tab displays settlements that have not been resolved. 
These settlements are either new or in progress.

• The Unapproved Trade tab displays settlements that have been matched but 
not yet approved.

• The Approved Trade tab displays settlements that have been matched and 
approved.

• The All tab displays all settlements, for convenience.

General Features
Each tab of the Settlement Details By Account worksheet contains a table at the 
top, which shows details for settlements in your account (or in each account to which 
you have access; only your accounts are shown). 

The rest of the worksheet shows details for the settlement you currently have selected 
in the table. You can select a settlement by clicking or by moving from row to row 
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with the tab and arrow keys. Note that if you use the keyboard to move through the 
worksheet table, the subtabs are not automatically refreshed, for performance reasons.

• The Proposed Event Matches subtab shows promotional events that the 
system has selected as possible matches for this settlement.

• The Notes/Attachments subtab shows notes and files that are attached to the 
selected settlement.

Not all tabs have the same subtabs.

Also, you can right-click to access additional menus that apply to the specific context. 

Settlement Account Summaries Worksheet
Settlement Management provides another worksheet, that summarizes information to 
the account level. 

To access the summary worksheet

1. Click File > Open.

2. Click Settlement Account Summaries and then click Open.

This worksheet looks like the following:

This worksheet contains two tabs: one for trade spending and one for non-trade events 
(such as losses during shipping). Each row summarizes settlement activity for each 
account, by time bucket. The Notes/Attachments subtab shows any notes or 
attachments for the selected account.
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Logging Onto Settlement Management
If you have already performed the one-time setup (see “Initial Logon” on page 3), 
then log on as follows.

To log onto Settlement Management

1. Open Microsoft Internet Explorer.

2. Enter the web address supplied by your system administrator. This URL probably 
has the following format:

http://server name/virtual directory/portal/partnerLogin.jsp

For example:

http://frodo/demantra/portal/partnerLogin.jsp

3. Type your name and password and click Login.

4. Click File > Open.

5. Click Settlement Details By Account and then click Open.

Tip Your Windows Start menu may also include an option for starting 
Settlement Management, which you can use instead.
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Typical Tasks in Settlement Management
The way that you use Settlement Management depends on the worksheets created by 
your Demantra implementors. In general, you can use Settlement Management to do 
tasks like the following:

Worksheet Usage Modes
You can use a worksheet in Settlement Management in three general ways:

• You can use a worksheet in its normal, online mode.

• You can take a worksheet offline, and then edit data and notes without needing 
access to the Demantra Spectrum server. Later you can bring the worksheet back 
online. Demantra Spectrum uploads your changes into the database.

• You can work remotely using a pure HTML user interface, provided that you 
have access to the Demantra Spectrum server. This mode allows you to view and 
edit data when it is not possible or desirable to download the Demantra Spectrum 
applet and Java (as in “Getting Started with Settlement Management” on page 3).

You can do most of the same activities in any of these modes. For details on the 
differences, see Chapter 6, “Working Offline” on page 69 and Chapter 10, “Using 
Worksheets Remotely” on page 133.

Logging Off Settlement Management

To exit Settlement Management

• Close the browser window. 

Any other open browsers are not affected.

Task For information, see 

Open a worksheet “Viewing Data” on page 11

Edit data “Editing Data” on page 13
“Copying and Pasting Data” on page 17

View and manage settlements “Viewing and Resolving Settlements” on 
page 41

Add notes for yourself or for others “Viewing Notes” on page 22
“Specifying Note Permissions” on page 26

View changes made by you or other users “Viewing the Audit Trail” on page 28

Create new worksheets (for advanced 
users)

“Creating and Redefining Worksheets” on 
page 85

Depending on your permissions, you might not have access to all the menus and features 
documented here. If you should have access to a feature, contact your system administrator.

Note To work remotely, you must have a license for Demantra Anywhere.
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Ending a Hung Session
(Added in 7.0) If your session hangs due to network or other problems, you will not 
be able to log in again until the session times out. Alternatively, Demantra Spectrum 
provides a tool that you can use to end that session.

If your permission level is lower than System Manager, your own session is the 
only session you can see.

To end a hung session

1. Browse to the following case-sensitive URL:

http://server name/virtual directory/portal/userManagement.jsp

For example:

http://frodo/demantra/portal/userManagement.jsp

A login page appears.

2. Type your username and password and then click Log on.

Demantra Spectrum displays the following screen:

3. Click Logout in the row corresponding to your user ID.

Changing Your Password
(Added in 7.0) You can log into the Business Modeler and change your own 
password. If your permission level is lower than System Manager, your password is 
the only information you can access.

To change your password

1. Log into the Business Modeler. If you do not have access to this tool, contact your 
Demantra Spectrum system administrator.

2. Click Security > Change Password. Or click the Change Password button.
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The Business Modeler displays the Change Password screen:

3. Type your current password in the Old Password field.

4. Type your new password in the New and Confirm New fields.

5. Click OK.

Other Demantra Spectrum Products in Your Solution
Your Demantra Spectrum solution may include the following additional, separately 
licensed Web-based products:

See also

“Demantra Spectrum URLs” on page 139

Product Description

Collaborator 
Workbench

• Displays summarized data, of your choice
• Provides tools to help you collaborate with others
• Serves as a launch spot for Settlement Management, Promotions 

Effectiveness, or Demand Planner Web.

See “Collaborating with Others” on page 123.

Demantra 
Anywhere

A thin Web client version of Collaborator Workbench. You can use 
Demantra Anywhere to perform most, but not all, of the same tasks as 
Collaborator Workbench

Promotions 
Effectiveness

Displays promotions and shows their effects on sales, both in the past and 
in the forecast.

See “Working with Promotions” on page 55 or see the Promotions 
Effectiveness User’s Guide.

Promotion 
Optimization

Provides additional options on the right-click menu that enable you to 
optimize promotions based on input criteria. See the Promotions 
Effectiveness User’s Guide and the Demantra Spectrum Consultant’s 
Guide.

Demand 
Planner Web

Demantra Spectrum’s demand planning solution.
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2 Working with Data

This chapter describes the basics of working with Demantra 
Spectrum data: how to edit data, add notes and attachments, print, 
exchange data with outside tools, and so on. It includes the 
following sections:

Viewing Data ................................................................................. 11
Editing Data ..................................................................................13
Saving and Viewing Changes ........................................................15
Sorting Worksheet Data.................................................................16
Copying and Pasting Data ............................................................17
Copying and Pasting to and from Microsoft Excel........................17
Exporting Data to Microsoft Excel................................................18
Linking Data into Third-Party Reporting Tools (via DOL)...........19
Printing..........................................................................................22
Viewing Notes ................................................................................22
Editing Notes .................................................................................24
Viewing and Managing Attachments to Notes ...............................25
Specifying Note Permissions .........................................................26
Refreshing the Local Worksheet Cache .........................................27
Viewing the Audit Trail ..................................................................28

Viewing Data

To view your data

1. Click File > Open. Or click the Open button.

2. Click a worksheet in the list and then click Open.

Depending on how Demantra Spectrum was configured, it may or may not 
automatically run the worksheet that you open.

3. If the worksheet does not show data immediately, click Data > Rerun. Or click 
the Run button.

To prefilter a worksheet

Depending on how the worksheet was configured, when you open the worksheet, 
Demantra Spectrum may prompt you to choose how to filter it. 
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In this case, after you click the worksheet and click Open, one or more selection 
pages are displayed when the worksheet, as follows:

1. On each selection page, select one or more choices or click Select All to select 
the whole list. 

2. Click Next or click Finish.

To load all data

When you first run a worksheet, Demantra Spectrum does not load all the data. 
Instead, it loads data for the first item-location combination in the worksheet. When 
you switch to another combination, Demantra Spectrum loads data for that 
combination. Demantra Spectrum does this so that you can see some data without 
having to wait for all the combinations to be loaded. In some cases, you may want to 
load all the combinations immediately; do this only if you are sure it will not slow 
your system down.

To load all the data, click the green arrow in the toolbar.

If the toolbar does not display this arrow, that means all the data has already been 
loaded.
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If worksheet was previously offline

(Added in 7.0) If you previously took this worksheet offline and made changes to the 
data, you will see the following dialog box as soon as you open the worksheet:

For information on these options, see “Reloading Offline Data” on page 76.

Editing Data
You can usually edit data in a worksheet, although not all series are editable. Note that 
within a given worksheet, if some of the tabs or windows show data at a higher 
aggregation level, the data is not editable in those tabs or windows.

Note In Demantra Spectrum, do not use the following special characters:

Single quote (')
Double quote (")
Ampersand (&)

If you use these characters, unexpected results may occur.
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To change a data value manually

1. Select an editable data cell (white).

The cell appears contained in a box.

2. Edit the value as needed. If the cell contains a date, then you can click the arrow 
on the right side of the cell and choose a date:

Or if the cell contains a dropdown list, double-click the cell to display the list and 
then click a list element:

To update multiple cells

1. In the table, select a range of cells.

2. Right-click the selection and then select Edit Cells.

The Edit Cells dialog box appears.

3. In the dialog box, type a new value and then click OK.

To undo

Do one of the following:

• Click Edit > Undo.

• Click Data > Reset Manual Changes. This option restores the worksheet data 
to the state in which you last saved it.

To redo an action

• Click Edit > Redo. 
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See also

“Copying and Pasting Data” on page 17
“Saving and Viewing Changes” on page 15

Saving and Viewing Changes
Apart from minor adjustments to the worksheet layout, the changes you make are not 
saved automatically.

Saving Changes
You save changes to data separately from changes to the worksheet definition:

• To save changes that you have made to the data in the worksheet, including 
changes to notes, click Data > Save Data. Or click the Save Data button.

• To save changes that you have made to the worksheet definition, click File > 
Save Worksheet. Or click the Save Worksheet button.

• If you own the worksheet, this option saves the basic worksheet definition and 
its initial layout. For information on changing the worksheet definition, see 
“Creating and Redefining Worksheets” on page 85.

• If you do not own the worksheet, this option saves only your own layout of the 
worksheet.

See “Worksheet Definition, Layout, and Local Adjustments” on page 39.

Controlling the Recalc Option
Usually at least some of the read-only series are computed by means of a local 
expression. By default, Demantra Spectrum recalculates all local series expressions 
automatically. In some cases, you may want to switch off this automatic recalculation:

To switch the Recalc option off 

• Click Data > Set Data Recalc Off. Or click the Recalc Off button.

To force calculation while Recalc is off

• Click Data > Calculate.

To switch the Recalc option on

• Click Data > Set Data Recalc On. Or click the Recalc On button.
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Viewing Pending Changes to Data

To see pending data changes

1. Click Data > Update to save your data changes.

2. Click Data > Process Monitor. Demantra Spectrum displays a screen that 
shows all data saves that are waiting to be processed:

If you are working at a relatively high level, this takes longer to run.

Sorting Worksheet Data
By default, the worksheet table is sorted in ascending order, according to the current 
contents of the x-axis, which is usually time. You can sort the worksheet table in either 
ascending or descending order, according to any series that is displayed in the table.

To sort the worksheet table

• Double-click the header of the column by which you want to sort the worksheet. 

Demantra Spectrum then sorts the entire worksheet table, putting entries in this 
column in descending order. A downward arrow is added to the column header, to 
indicate that the table is sorted by this column.
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To resort in ascending order, double-click the column header again. Demantra 
Spectrum resorts the table and changes the direction of the arrow.

To restore the default sorting order of the worksheet table

• Click View > Reset Table Sort.

Copying and Pasting Data
You can copy and paste data within the worksheet table.

To copy data

1. Within a worksheet, do one of the following:

• In the table, select a cell whose value you want to copy.

• To copy values from more than one cell, click the first cell, and then drag the 
mouse to select all cells you want to include.

2. Right-click and then select Copy. Or click Edit > Copy.

To paste data

1. Do one of the following:

• In the table, select the cell into which you want to paste the data.

• To paste values into more than one cell, select the upper left data cell of the 
block of cells into which you want to paste.

2. Right-click and then select Paste. Or click Edit > Paste.

See also

“Saving and Viewing Changes” on page 15

Copying and Pasting to and from Microsoft Excel
You can copy and paste data from a worksheet to Excel and vice versa.

To copy and paste data to Excel

1. Within a worksheet, copy data as described in “Copying and Pasting Data” on 
page 17.

2. Start Microsoft Excel, open a worksheet, and select a cell or block of cells.

3. Right-click and then select Paste.

Note From a worksheet, you can also paste data to different Windows products.
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To copy and paste data from Excel

1. Start Microsoft Excel and open a worksheet.

2. Select one or more cells.

3. Right-click and then select Copy.

4. In Demantra Spectrum, select the cell or cells into which you want to paste the 
data.

5. Right-click and then select Paste. Or click Edit > Paste.

See also

“Exporting Data to Microsoft Excel” on page 18
“Linking Data into Third-Party Reporting Tools (via DOL)” on page 19

Exporting Data to Microsoft Excel
You can export worksheet data to Excel. Your computer’s regional settings can affect 
the results; see the note.

To export data to Excel

1. Within a worksheet, click File > Export. Or click the Export to Microsoft 
Excel button.

An export dialog box appears.

2. Select Current Combination to export data currently displayed, or Entire 
Worksheet to export all data from the worksheet.

3. Click OK.

A Save page appears.

4. Define the location where the worksheet data will be saved and enter a name for 
the file.

5. Click Save.

Note

When receiving data from an external source, Microsoft Excel uses the Regional 
Options in the Windows Control Panel to determine whether a given cell should be 
formatted as Currency or General (as is or text). This means that if you export 
Demantra Spectrum data that is formatted with a currency symbol, and if the 
Windows Control Panel uses a different currency symbol, those cells will appear in 
Excel as text values.
18 Demantra Settlement Management User’s Guide



Linking Data into Third-Party Reporting Tools (via DOL)

 
 

If you export to Excel and you receive text values where you wanted currency values, 
do the following:

1. Open the Windows Control Panel.

2. Double-click Regional and Language Options.

3. On the Regional Options tab, make sure that the Currency setting uses the 
same currency symbol as Demantra Spectrum.

4. Export again from Demantra Spectrum.

Later versions of Excel provide an option for converting problematic cells that it 
recognizes. 

See also

“Copying and Pasting to and from Microsoft Excel” on page 17
“Linking Data into Third-Party Reporting Tools (via DOL)” on page 19

Linking Data into Third-Party Reporting Tools 
(via DOL)

When you work within a third-party reporting tool, you can import a Demantra 
Spectrum worksheet via Demantra’s Dynamic Open Link (DOL) technology. This 
technology lets you use any reporting tool that can connect to the Demantra Spectrum 
database (which is either Oracle or SQL Server).

Demantra Spectrum provides a web page (http://server name/virtual directory/
portal/DOL_HTML.htm) to which you can link from your reporting tool, such as 
Microsoft Excel). Then to access the latest Demantra Spectrum data, you can use the 
refresh functionality within that reporting tool.

The following steps describe how to link Demantra Spectrum data into Excel, as an 
example.

To create a worksheet report in Excel

1. In Microsoft Excel, open the Data menu.

2. Click Get External Data and select New Web Query.
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The New Web Query screen appears.

3. Click Browse Web..., which displays a browser.

4. In the address bar, type the following URL and then click Go:

http://server name/virtual directory/portal/DOL_HTML.htm

For example:

http://frodo/demantra/portal/DOL_HTML.htm

A login page appears.

5. Type your Demantra Spectrum user name and password and click Login.

The browser now displays the following list of worksheets:
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6. Select a worksheet from the dropdown list and click Confirm.

The worksheet opens in your browser in non-editable HTML format. 

7. Optionally close the browser window.

8. Return to Excel, which is still displaying the same dialog box as before.

9. For step 2, select The entire page.

10. For step 3, select Full HTML formatting.

11. Click OK.

Excel asks where to put the data.

12. Make your choice and click OK.

The Demantra Spectrum worksheet opens in Excel.

See also

“Copying and Pasting to and from Microsoft Excel” on page 17
“Exporting Data to Microsoft Excel” on page 18

Tip To save the query for repeat use, click Save Query...
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Printing

To print the displayed data

1. Click File > Print. Or click the Print button on the toolbar.

The Print Settings dialog box appears.

2. Select the required options.

3. If this worksheet includes a Gantt chart, optionally click the Gantt Settings tab. 
On this tab, specify which promotion attributes to include in the print-out.

4. Click OK.

5. Demantra Spectrum displays the normal system print dialog box, where you 
choose the printer to use, the number of copies to make, and so on.

6. Make selections as you would normally do.

7. Click OK.

Viewing Notes
You can add notes to record comments and reminders. You attach the note to 
combination and date or dates. The worksheet table displays indicator symbols on 
those dates, generally in only some of the columns (depending on how your system is 
configured). The following shows an example of the indicator:

The graph displays an indicator as well:

Content selection Specify whether to print the currently selected item-
location combination, all combinations in the 
worksheet, or the screen.

Layout Choose portrait or landscape orientation.

Paper Choose a paper size.

Font Choose a font size.

Object selection If this worksheet includes a Gantt chart (which 
requires a license for Promotions Effectiveness), this 
option lets you specify whether to include the Gantt 
chart in the printout.
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You can see notes in two different areas:

• In the Notes dialog box.

• In the Notes/Attachments subtab, if this is included in your worksheet. This 
subtab also displays any associated attachments.

To open the Notes page

Do one of the following:

• In the table, right-click a cell and select Notes... The note will be associated with 
only this row.

• In the table, select one or more rows, right-click and then select Notes.... The 
note will be associated with each of the selected rows.

• In the table, double-click the left (non-scrolling) column. (Depending on how 
Demantra Spectrum is configured, this action may not bring up the Notes page.)

• In the graph, hold the mouse button over a point, right-click and then select 
Notes...
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To display the Notes/Attachments subtab

See “Specifying the Worksheet Elements in a View” on page 117.

See also

“Editing Notes” on page 24
“Viewing and Managing Attachments to Notes” on page 25
“Specifying Note Permissions” on page 26

Editing Notes
First display the Notes page or the Notes/Attachments subtab; see “Viewing 
Notes” on page 22. In the upper part of the worksheet, click the element to which you 
want to attach this note.

To add a note

1. If the Note box is gray (uneditable), click the Add button.

2. Type a note in the Note box.

3. If you are working in the Notes/Attachments subtab, you can optionally 
upload an attachment (see “Viewing and Managing Attachments to Notes” on 
page 25).

4. Click the Save button.

To edit a note

1. Select a note and click the Edit button.

2. Type a note in the Note box.

3. If you are working in the Notes/Attachments subtab, you can optionally 
upload an attachment (see “Viewing and Managing Attachments to Notes” on 
page 25).

4. Click the Save button.

To delete a note

1. Select a note and click the Delete button.

The Confirm Delete message box appears.

2. Select one of the following:

• Partial Deletion (deletes the note only from the current member and date)

• Total Deletion (deletes the note from all members and dates)

3. Click OK.

4. Click Save.
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See also

“Viewing Notes” on page 22
“Specifying Note Permissions” on page 26

Viewing and Managing Attachments to Notes
You can attach files to the notes, and Demantra Spectrum uploads those files into the 
database (in compressed form). To view and manage attachments, you work in the 
Notes/Attachments subtab of your worksheet.

To add an attachment to a note

1. Click the note.

2. Click Details.

Demantra Spectrum displays the Note Details screen:

3. Click Add.

4. Find the file that you want to attach and then click Open.

Demantra Spectrum uploads a compressed version of the file into the database.

5. Click OK.

To remove an attachment from a note

1. Click the note.

2. Click Details.

Demantra Spectrum displays the Note Details screen:
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3. Click the row that lists the attachment and then click Remove.

4. Click OK.

To download an attachment

1. Click the note.

2. Click Details.

Demantra Spectrum displays the Note Details screen:

3. Click the row that lists the attachment and then click Download.

4. Specify the directory and filename for the downloaded file and then click Save.

5. Click OK.

See also

“Viewing Notes” on page 22
“Specifying the Worksheet Elements in a View” on page 117

Specifying Note Permissions
In general, notes (and their optional attachments) can be viewed by other users. You 
can specify permissions for the notes, to determine who can read the note and what 
type of access they are permitted. You can specify permissions for groups or for 
specific users.

To specify permissions for a note and its attachments

1. On the Details tab, select the note.

2. Click the Permissions tab.

3. Select the User Permissions or Group Permissions tab.

4. For each user or group that should have non-default settings for this note, move 
that user or group from the left list to the right list (Selected Users or 
Selected Groups). Use any of the techniques in “Working with Lists” on 
page 96.

5. Remove any unwanted users or groups from the right list.

6. Then for each user or group in the right list, do the following:

a. Click the user or group.

b. Select a setting from the Permission dropdown list at the bottom of the page. 
The following options are available:

Note Read-only is the default setting for non-selected users or groups.

Read and 
Write

Enables the user or group to read the notes list, edit notes, 
and add notes.
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7. Click Save.

8. Click Close.

Group and user permission priorities

• User permissions take precedence over permissions of any groups the user 
belongs to.

• If a user belongs to more than one group, the highest level of permissions from 
the associated groups will be granted.

See also

“Viewing Notes” on page 22

Refreshing the Local Worksheet Cache
Depending on the definition of a worksheet, Demantra Spectrum may store a local 
copy of the worksheet data on your machine, for faster performance. Also depending 
on the worksheet definition, the cache may be refreshed automatically or may require 
periodic refreshing by you.

To refresh your local worksheet cache

• Click Data > Refresh worksheet data cache.

See also

“Visual Elements of Worksheet Views” on page 91
“Saving and Viewing Changes” on page 15
“Configuring the Worksheet Basics” on page 98
“Opening an Item or Location in Another Worksheet” on page 82

Read Only Enables the user or group to read the notes list.

Not Visible Makes the note list not visible to this user or group.

Full Control Enables the user or group to read the notes list, edit notes, 
add notes, and delete notes.
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Viewing the Audit Trail
Demantra Spectrum automatically records changes in an audit trail. The audit trail 
includes all changes due to user edits within worksheets, updates created by the 
Business Logic Engine, copy/paste actions, and changes caused by import.

Demantra Spectrum provides two ways to view the audit trail:

• You can view the changes that have occurred to the item-location combination 
that is currently displayed in the worksheet.

• You can create and then execute a profile that specifies a wider set of data: 
multiple combinations, a wider span of time, and so on.

In either case, the audit trail looks like this:

The top part of the page lists the changes. When you select a row in this table, the 
bottom part of the page lists details corresponding to that row.

• The Series Values tab displays details on the series that were changed.

• The Aggregate Level Population tab displays the specific aggregation levels 
to which this change applies. The change could have occurred at a different 
aggregation level.

• The Filtered Population tab displays the filtering that was used at the time of 
this change.

Note You can see only changes that were made by you or other users who are in the 
same collaboration groups as you.
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Viewing the Audit Trail for a Specific Combination

To view the audit trail for a combination 

1. In a given worksheet, select a combination.

2. Click Data > Audit Trail.

If any changes have occurred to this combination, the Audit Trail screen 
appears, displaying a table with one row for each recorded change. The following 
information is displayed:

3. To see specific details on this change, click a change in this table and then click 
the Series Values tab.

This tab displays the following information:

4. To see the specific aggregation levels to which this change applies, click the 
Aggregate Level Population tab. The change could have occurred at a 
different aggregation level.

5. To see the filtering that was used at the time of this change, click the Filtered 
Population tab.

Audit Date Date when change was made.

User Name User who made the change

Update Mode Indicates the type of change: Manual, BLE (Business 
Logic Engine) or Integration

Unit Name Unit of measure that was used at the time of the change

Index Name Index that was used at the time of the change

Series List Series affected by the change

Status In Progress, Fail, or Success

Series Name Name of the series that was changed.

Series Value New value used in this series.

Original Value Original value in this series.

From Date First date in the series when the change occurs.

To Date Last date in the series when the change occurs.
Demantra Settlement Management User’s Guide 29



Chapter 2: Working with Data

 
 

Viewing the Audit Trail for Other Data
An audit trail profile enables you to select a specific portion of the audit trail so that 
you can view changes that affect more than one combination.

To create or modify an audit trail profile

1. Click File > Audit Trail.

2. Then:

• To create a new profile, click New.

• To modify a profile, click an audit trail profile name and click Modify.

The wizard displays a properties screen.

3. In the Name and Description fields, type a name and optional description.

4. If you want to share this audit trail profile with others, click Public.

5. Click Next.

The wizard prompts you for information about the changes you want to see.

6. For Source Type, click the check box for each type of change you want to see. 
Here, BLE represents the Business Logic Engine.

7. For each user whose changes you want to see, move the name from Available 
Users to Selected Users.

8. Click Next.

The wizard prompts you for the range of time you are interested in.

9. For Time Filter, select Relative or Fixed, depending on whether you want to 
define a window of time relative to today.

10. For From Date and To Date, specify a range of dates.

11. Click Next.

The wizard prompts you to specify the aggregation levels you are interested in.

12. For each aggregation level that you are interested in, move that level from 
Available Filter Levels to Selected Filter Levels.

13. Click Next.

The wizard prompts you to specify the series you are interested in.

14. For each series that you are interested in, move that series from Available 
Series to Selected Series.

15. Click OK.

16. Click Close to exit the wizard.
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To use an audit trail profile

1. Click File > Audit Trail.

2. Click an audit trail profile.

3. Click Execute.

Demantra Spectrum displays the specified part of the audit trail. See “Viewing the 
Audit Trail for a Specific Combination” on page 29.

To delete an audit trail profile

1. Click File > Audit Trail.

2. Click an audit trail profile.

3. Click Delete.

4. Click Yes.
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3 Managing the Screen

This chapter describes how to manage the Demantra Spectrum 
screen in general. It includes the following sections:

Managing Multiple Worksheets .....................................................33
Managing Worksheet Views ...........................................................35
Managing View Elements ..............................................................36
Managing Empty Rows..................................................................37
Worksheet, Layout, and Data.........................................................38
Worksheet Definition, Layout, and Local Adjustments..................39

See Also

“Creating and Redefining Worksheets” on page 85

Managing Multiple Worksheets
Within Demantra Spectrum, you can open multiple worksheets and display them in 
tab mode or window mode. In window mode, you can resize, position, minimize, 
maximize, and tile each window as in other software.

To specify how to display worksheets

Do one of the following:

• Select Options > Tabs View/Windows View.

• Click the Tabs/Windows toggle button.

A worksheet contains views, and these views can be displayed as windows or tabs 
within the worksheet itself. The Tabs/Windows setting discussed here has no effect 
on the views.

display worksheets as windows

display worksheets as tabs
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To view a worksheet that has already been opened

• In windows view, select the worksheet from the Windows menu.

• In tabs view, click the tab corresponding to the worksheet.

To close a worksheet

Do one of the following:

• In windows view, click close (X) in the top right corner of the worksheet window.

• In tabs view, click the close symbol (X) on the tab.

See also

“Managing Worksheet Views” on page 35
“Managing View Elements” on page 36
“Adding and Managing Worksheet Views” on page 115
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Managing Worksheet Views
A worksheet can include multiple views, which are displayed as tabs or as windows 
within the worksheet window itself.

Each view can have a different set of series and a different layout. Within any given 
worksheet, you can display the views as tabs or as child windows that you can resize 
and reposition.

Depending on the worksheet definition, the views may or may not be synchronized 
with each other. If they are synchronized, when you edit in one view, that change 
automatically appears in the other views.

To manage worksheet views

Within any given worksheet, you can display the worksheet views as tabs or as child 
windows that you can resize and reposition.

• To create, modify, or delete worksheet views, see “Adding and Managing 
Worksheet Views” on page 115.

• To change how views are shown within the current worksheet, click Options > 
Tabs Multiview or Options > MDI Multiview, whichever option is displayed. 
Or click the corresponding toggle button on the toolbar.

• If you are currently displaying views as tabs, you can view one tab at a time. 
Click the tab of the view you want to view.

• When you are displaying views as subwindows, you can resize, reposition, 
maximize, and minimize each of these subwindows. Also, the Options menu 
provides options for tiling and cascading the subwindows.

See also

“Managing Multiple Worksheets” on page 33
“Managing View Elements” on page 36

Note In a given worksheet, if some of the views show data at a higher aggregation 
level, the data is not editable in those views.

display views as child windows

display views as tabs
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Managing View Elements

To hide or redisplay elements of a worksheet view

You can hide elements of a worksheet. To do so, use the Options menu. For example, 
to hide the graph, click View > Show/Hide Graph.

Each of these menu items acts as a toggle. To redisplay what you have hidden, click 
the same menu item again.

To resize an area in a worksheet view

• Drag a divider to the required position.

To expand or contract an area in a worksheet view

• There are two snap buttons in the upper left of each worksheet area, one with an 
up arrow and one with a down arrow. Click the snap button pointing in the 
required direction.

To resize a data column

• Click the vertical divider between two column headers, and drag it horizontally to 
the required position.

See also

“Managing Multiple Worksheets” on page 33
“Managing Worksheet Views” on page 35
“Adding and Managing Worksheet Views” on page 115

Note This menu includes an option to hide the time axis. You typically use this 
option only if the worksheet also contains time levels. In such a case, it is 
desirable to hide the time axis, because it is redundant and takes up space on 
the screen.
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Managing Empty Rows

To hide or display empty rows in the worksheet table

• Click View > Hide Empty Rows. This option is a toggle. If you click it again, 
you redisplay the empty rows.

Examples

In some cases, some of the rows of a worksheet table might not contain data, for 
example:

Note that the status bar at the bottom of worksheet indicates that empty rows are 
currently being displayed.

When you hide empty rows, the result is as follows:

Note This option does not affect any graphs in the worksheet.
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Worksheet, Layout, and Data
As you work within Demantra Spectrum, it is important to remember that worksheets 
exist independently from the data that they display. For example, the definition of a 
worksheet specifies which series to display and how to aggregate those series for that 
worksheet. But the worksheet definition does not specify the values that the series 
contain. 

Accordingly, the worksheets and their layouts are saved separately from changes to 
the data. 

• To save changes that you have made to the data in the worksheet, including 
changes to notes, click Data > Save Data. Or click the Save Data button.

• To save changes that you have made to the worksheet definition or to the local 
layout, click File > Save Worksheet. Or click the Save Worksheet button.

• If you own the worksheet, this option saves the basic worksheet definition and 
its initial layout. This affects any users of this worksheet who have not yet 
saved their own layout for it.

• If you do not own the worksheet, this option saves only your own layout of the 
worksheet. This has no effect on any other users.

See also

“Worksheet Definition, Layout, and Local Adjustments” on page 39
“Saving and Viewing Changes” on page 15
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Worksheet Definition, Layout, and Local Adjustments
As you work with a Demantra Spectrum worksheet, you often sort columns, hide or 
display features, and make various other changes. It is useful to understand how these 
settings are saved.

The autorun option (Options menu) is saved separately for each user, but applies to all 
worksheets that the user sees.

Base Demantra Spectrum 
configuration

These settings affect all users and all 
worksheets.

• Display format for each series
• Initial display width of series and levels
• Colors and graph style for each series
• Other display colors (generally dependent on a 

condition)

Worksheet definition

These settings are saved via the File 
> Save Worksheet menu option. 
Only the worksheet owner can make 
these changes.

• Initial number of views within the worksheet and 
their initial names

• Initial elements (Members Browser, table, graph, 
and so on) in worksheet view

• View synchronization setting
• Aggregation levels used in worksheet and initial 

level layout; advanced selection options
• Series used in worksheet and initial series layout
• Time aggregation; time span; time formatting
• Filtering and exception filtering
• Unit of measure used in worksheet; overall scale 

used in worksheet, if any; index or exchange rate, if 
any

Layout changes

These settings are saved separately 
for each user if the user clicks File > 
Save Worksheet. Any user can 
save these changes, not just the 
worksheet owner.

• Additional views in the worksheet
• New names of worksheet views
• Level layout: order of levels; placement on axes in 

each view; whether level is hidden in each view
• Series layout: order of series; where each series is 

displayed (table, graph, both)
• Hide/show time axis

Local adjustments 

These settings are saved 
automatically separately for each 
worksheet and each user. 

• Use of windows or tabs for views within a 
worksheet

• Size and position of the Members Browser, table, 
graph, and so on in each view

• Sorting in the worksheet table
• Graph type; legend; grid lines
• Hide/show empty rows setting
• Activity synchronization setting (Options menu)

Not saved • Changes to column widths in the worksheet table
• Initial view focus; focus in each worksheet view
• Expansion state in the Members Browser and 

Activity Browser
• Focus and scroll in all areas
• Zoom setting in Gantt
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4 Viewing and 

Resolving 
Settlements
This chapter describes how to display and resolve settlements. It 
includes the following sections:

Viewing Unresolved Settlements....................................................41
Assigning an Owner to a Settlement..............................................42
Matching a Settlement to a Promotional Event .............................43
Attaching Documentation to the Settlement ..................................44
Partially Matching a Settlement (Splitting a Settlement) ..............45
Approving a Settlement..................................................................49
Requesting a Check .......................................................................47
Sending a Settlement to Another Person .......................................50
Unlinking a Settlement...................................................................51
Denying a Settlement .....................................................................53

Viewing Unresolved Settlements
1. Open Microsoft Internet Explorer.

2. Enter the web address supplied by your system administrator. This URL probably 
has the following format:

http://server name/virtual directory/portal/partnerLogin.jsp

For example:

http://frodo/demantra/portal/partnerLogin.jsp

3. Type your name and password and click Login.

4. Click File > Open.

5. Click Settlement Details By Account and then click Open.

6. Click the Unresolved Trade tab, where you will do most of the work of 
resolving settlements.

Next steps

“Assigning an Owner to a Settlement” on page 42
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Assigning an Owner to a Settlement

When to do this

Before you can work on a settlement, you should take ownership of it, so that other 
users do not interfere with your work.

To assign an owner

1. Right-click a settlement and then choose Methods > Ownership.

Settlement Management displays a screen like the following:

2. For Settlement Owner, click your user ID from the dropdown list.

3. For Status, click In Progress from the dropdown list.

4. Click OK.

Next steps

The next step is to match this settlement to a promotional event (“Matching a 
Settlement to a Promotional Event” on page 43) or to split this settlement (“Partially 
Matching a Settlement (Splitting a Settlement)” on page 45). In some cases, you might 
need to deny the settlement (“Denying a Settlement” on page 53).
42 Demantra Settlement Management User’s Guide



Matching a Settlement to a Promotional Event

 
 

Matching a Settlement to a Promotional Event

When to do this

Each settlement corresponds to at least one promotional event. You should match a 
settlement to the event or events in order to reconcile your company’s accounting 
books. When you do so, the settlement amount is subtracted from the budget for that 
promotion.

To match a settlement to an event

1. Click the Unresolved Trade tab.

2. Take ownership of the settlement, as in “Assigning an Owner to a Settlement” on 
page 42. The settlement is now highlighted and the subtabs show information that 
is relevant to this settlement.

3. Click the Proposed Event Matches subtab to see possible events that could 
be matched to this settlement. If this is an off-invoice settlement, there will 
probably be only a relatively small number of events.

4. To match the selected settlement to an event, right-click the event and then choose 
Methods > Link.

Settlement Management displays a screen like the following:

5. Make sure that the option Link Settlement to Event is selected.

6. Click OK.

Note If you use the keyboard to move through the worksheet table, the subtabs 
are not automatically refreshed, for performance reasons.
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Demantra Spectrum automatically changes the status of the settlement to 
Unapproved. It also reduces the budget for the selected promotion, using the 
amount of the settlement.

Next steps

At this point, you typically attach proof of performance or other documentation to the 
settlement; see “Attaching Documentation to the Settlement” on page 44. Then the 
settlement can be approved; see “Approving a Settlement” on page 49.

Attaching Documentation to the Settlement

When to do this

Policies vary from company to company, but it is generally necessary for the customer 
to provide documentation that proves that the event was run as specified. This 
documentation may come to you as paper or as computer files. If you receive paper 
documents, scan them so that you can load them into the system.

To attach documentation to a settlement

1. Click the settlement so that it is selected.

2. In the Notes/Attachments subtab, click the Add button.

3. Type a note in the Note box.

4. Click Details.

Note You can attach any kind of file. A PDF file is typical. 
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Demantra Spectrum displays the Note Details screen:

5. Click Add.

6. Find the file that you want to attach and then click Open.

Demantra Spectrum uploads a compressed version of the file into the database.

7. Click OK.

Next steps

If you have attached all the documents needed by your organization, the settlement 
can now be approved; see “Approving a Settlement” on page 49.

Partially Matching a Settlement (Splitting a Settlement)

When to do this

Sometimes it is necessary to split a settlement and match part of it to an event. You 
might do this in the following cases, for example:

• If the customer deducted on more units than permitted by contract

• If the promotion was not run as required by contract

• If the settlement is associated with multiple events
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To partially match a settlement to an event

1. Click the Unresolved Trade tab.

2. Take ownership of the settlement, as in “Assigning an Owner to a Settlement” on 
page 42. The settlement is now highlighted and the subtabs show information that 
is relevant to this settlement.

3. Click the Proposed Event Matches subtab to see possible events that could 
be matched to this settlement.

4. To see the details for a given event, click that event and view the details in the 
right side of the Proposed Event Matches subtab.

5. To partially match the selected settlement to an event, right-click the event and 
then choose Methods > Link.

Settlement Management displays a screen like the following:

6. Click the option Split Settlement: Partial Match.

7. For Amount to Link, enter the monetary amount that should be matched to the 
selected event.

The Open Amount field is updated automatically, showing the remaining, 
unmatched amount of the settlement.

8. For Reason Code, click the reason that best explains why you are performing a 
partial match.

9. If this settlement is a claim, you can request a check to be sent to the customer. To 
do so, click Request Check.

10. Click OK.
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11. If you clicked Request Check, see “Requesting a Check” on page 47.

Demantra Spectrum automatically creates a new settlement that contains the 
remaining, unmatched amount.

Next steps

For the settlement that you just matched, you should approve that settlement; see 
“Approving a Settlement” on page 49.

For the new settlement, you typically do one of the following:

• “Matching a Settlement to a Promotional Event” on page 43

• “Denying a Settlement” on page 53

Requesting a Check

When to do this

If a customer has submitted a claim and if that claim can be matched to a suitable 
event, then you should send a check to the customer (or possibly to the broker, as 
appropriate for the account). This check compensates the customer for running the 
promotional event.

To request a check for a claim

1. On the Link screen, click Request Check. This check box is enabled only for 
claims, not for other kinds of promotions.

2. Click OK.
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Settlement Management displays a screen like the following:

The Existing Requests area lists check requests that have already been issued 
for this promotional event, if any. You use the New Check Request area to 
enter details for a new check request.

3. For Amount, enter the monetary amount of the check request.

4. For Check Requested For, select the item that describes what this check is 
meant to reimburse.

5. For Note, enter an optional note.

6. For Customer Reference, enter optional, additional information to specify 
where to direct the check.

The Customer Info area shows the details about where the request should be 
sent. By default, the request is sent to the customer, to the address shown in this 
area. 
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7. To send the check request to the broker instead, click Mail to Broker. Then for 
Attn, specify the person to include on the Attention line of the address.

Next steps

For the settlement that you just matched, you should approve that settlement; see 
“Approving a Settlement” on page 49.

Approving a Settlement

When to do this

If a settlement has been properly matched to an event, and if the required proof of 
performance (or other documentation) has been provided, you should approve the 
settlement to indicate that it does not need further work.

To approve a settlement

1. Right-click the settlement and click Methods > Approve.

Settlement Management displays a screen like the following:

2. For Status, click Approved from the dropdown list.

3. Click OK.

Next steps

There are no further steps to take for this settlement.
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Sending a Settlement to Another Person

When to do this

If you are not sure how to handle a particular settlement, and want to consult with 
another person, you can send the settlement to that person, if that person is also a user 
of Settlement Management.

To send a settlement to another person

1. Right-click the settlement and click Open.

Settlement Management opens a new worksheet that is filtered only to this 
particular settlement. This allows the other person to focus on the settlement of 
interest.

2. Click File > Send as Task or click the Send as Task button.

The Send Task to User dialog box appears.

3. Click To..... and select the users and/or groups to receive the task.

4. In the Message field, type a short text message explaining what you want the 
recipient to do with this settlement.

This will be the task message that the recipient sees. The worksheet that you are 
sending will be added automatically as a link from the Message text.

5. In the Description field, type a short description.

This description will be displayed below the task message in the recipient’s My 
Tasks module.
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6. To link the task subject line to a Web page, enter the full path to the file in URL 
field.

7. Optionally, to attach a file to the task, enter the path to the file in the File 
Attachment field or use the Browse button to find it.

8. Optionally, to ensure that this task is completed by a specific time, click 
Escalate and then provide the following information:

9. To send an email notification to the recipient of the task, select the Send to 
email list check box. (Depending on how your system has been configured, this 
option may not be available.)

10. Click either Send Worksheet or Send Selected Combination to specify 
whether to filter the worksheet. If you click Send Selected Combination, the 
worksheet is filtered to the combination that you are currently viewing. 
Otherwise, the entire worksheet is sent.

11. Click Send Task.

Unlinking a Settlement

When to do this

If a settlement has been matched to the wrong promotion, for any reason, you should 
unlink it, so that you can rematch it to the correct promotion.

To unlink a settlement that has already been matched

1. Click the Unapproved Trade tab.

2. Take ownership of the settlement, as in “Assigning an Owner to a Settlement” on 
page 42. The settlement is now highlighted and the subtabs show information that 
is relevant to this settlement.

3. Right-click the settlement and click Methods > Unlink.

Note You must enter the full URL, including server name and directory 
hierarchy. The http:// part will be added automatically if omitted.

Due Date Date and time by which this task must be completed

Alert Time Date and time at which an alert will be displayed

To Additional email addresses
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Settlement Management displays a screen like the following:

4. Click OK.

Next steps

The next step is to match this settlement to a different promotional event (“Matching a 
Settlement to a Promotional Event” on page 43) or to split this settlement (“Partially 
Matching a Settlement (Splitting a Settlement)” on page 45). In some cases, you might 
need to deny the settlement (“Denying a Settlement” on page 53).
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Denying a Settlement

When to do this

Sometimes it is necessary to deny a settlement, typically if the promotion was not run 
as required by contract.

To deny a settlement

1. Click the Unresolved Trade tab.

2. Take ownership of the settlement, as in “Assigning an Owner to a Settlement” on 
page 42. The settlement is now highlighted and the subtabs show information that 
is relevant to this settlement.

1. Right-click a settlement and then choose Methods > Deny.

Settlement Management displays a screen like the following:

2. For GL Code, select the entry that best describes the reason to deny this claim. 
This reason is used in your company’s general ledger system.

3. For Status, click Denied from the dropdown list.

4. Click OK.

Next steps

There are no further steps to take.
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5 Working with 

Promotions
This chapter describes how to view, modify, create, delete 
promotions, and so on. It includes the following sections:

About Promotions ..........................................................................55
Displaying the Activity Details Subtab..........................................57
Viewing Promotion Attributes........................................................58
Creating a Promotion ....................................................................60
Modifying a Promotion..................................................................62
Working with the Gantt Chart........................................................63
Sorting Promotions ........................................................................64
Copying and Pasting a Promotion ................................................65
Deleting a Promotion ....................................................................65
Maintaining the Promotion Hierarchy ..........................................66
Opening a Promotion in Another Worksheet .................................67
Using Other Right-Click Menu Options ........................................68

About Promotions
A promotion is an occurrence that starts at a specific date, has a certain duration, and 
has a certain time-varying effect on sales. It is associated with one or more item-
location combinations, which can be either high-level or low-level. Multiple 
promotions can be associated with a combination during the same time bucket.

As with sales data, promotion data can be imported. Typically, your implementors 
imported past promotions as a step in configuring your system. Depending on how 
your system is configured, Promotions Effectiveness may continue to import new 
promotions or you might create promotions within the Promotions Effectiveness user 
interface. Promotions Effectiveness can display promotions in worksheets, where you 
can create, edit, and remove promotions.

Where to Work with Promotions
You can perform operations on promotions such as creating new promotions, editing 
existing promotions, and so on. You can perform most of these actions in different 
areas of a worksheet:
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• In the Activity Details subtab, which displays the promotions within a 
collapsible Gantt chart. See “Displaying the Activity Details Subtab” on page 57. 

• In the Members Browser, if promotions are currently displayed there.

• In the worksheet table, if promotions are currently displayed there.

In your worksheet, notice where the promotions are displayed, right-click a promotion 
in any of those areas, and use the options on the right-click menu, as described in this 
chapter.

Promotion Hierarchies
Promotions can be organized within a hierarchy. The promotions themselves are at the 
lowest levels, and higher levels in this hierarchy provide organizational structure. The 
default Demantra Spectrum demo organizes promotions within a hierarchy of 
scenarios and plans. Within a worksheet, the Activity Browser displays the promotion 
hierarchy, as in the following example:

Attributes
A promotion has attributes, as configured for your implementation. It is important to 
specify appropriate values for the attributes, because the Analytical Engine considers 
them when it creates the forecast.

Depending on how your implementation was configured, these attributes may be 
available as series (and therefore displayed in the worksheet table); consult your 
implementors. In any case, you can see the attributes by right-clicking on a promotion 
and selecting View. Demantra Spectrum then displays a window with the attributes.

Promotion Status
Each promotion has a status, which controls the following:

• Whether the promotion is used in forecasting.

• Whether users can edit the promotion.

• How Settlement Management uses the promotion.
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The default promotion statuses are as follows:

Displaying the Activity Details Subtab
The Activity Details subtab displays promotions within a collapsible Gantt chart.

To display the Activity Details subtab

• Click View > Show Activity Details.

Demantra Spectrum displays the Activity Details subtab:

Status

Meaning

In forecasting
In Promotions 
Effectiveness In Settlement Management

Unplanned The Analytical Engine does not 
consider this promotion. 

Users can edit the promotion. Settlement Management considers 
this promotion to be uncommitted.

Planned The Analytical Engine does 
consider this promotion. 

Committed The user who committed this 
promotion can edit it.

Settlement Management considers 
this promotion to be committed.

Running Nobody can edit the promotion The promotion is currently running.

Unmatched The promotion has ended but has 
not yet been matched to an invoice.

Matched The promotion has ended and has 
been matched to an invoice.

Notes • To display this worksheet element, you must have a license for 
Promotions Effectiveness.

• Depending on your options, this subtab may or may be synchronized 
with the rest of the worksheet.
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This subtab includes two main areas:

• The Activity Browser displays an expandable tree view of the promotions 
associated with the currently selected item-location combination. The hierarchy 
displayed depends on how your system was configured.

• The Gantt chart displays the promotions associated with the currently selected 
item-location combination. You can scroll backwards and forwards in time to see 
the start and end dates of each promotion.

To update the Activity Details subtab

Depending on your current options, the Activity Details subtab does not necessarily 
display data for the currently selected combination. To update the Activity Details 
subtab, right-click in the table and then select Synchronize Activity.

To control whether the subtabs are synchronized with the rest of the 
worksheet

Do one of the following:

• Click one of the following toggle buttons in the toolbar.

• Select Options > Synchronize On Demand or Synchronize 
Automatically.

See also

“Working with the Gantt Chart” on page 63

Viewing Promotion Attributes

To view promotion attributes

1. In your worksheet, find an area that is currently displaying promotions; see 
“Where to Work with Promotions” on page 55.

2. Right-click the promotion and then select View.

Automatically synchronize the subtabs with the rest of 
worksheet

Synchronize on demand

Tip The worksheet runs faster if synchronization is off. On the other hand, if you are 
creating or modifying promotions, you might find it less confusing to keep 
synchronization switched on so that you can immediately see your changes.
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Demantra Spectrum displays the promotion properties. Depending on your 
implementation, this screen may look like the following.

See also

“About Promotions” on page 55
“Creating a Promotion” on page 60
“Working with the Gantt Chart” on page 63
“Displaying the Activity Details Subtab” on page 57

Note Depending on how your implementation was configured, these attributes may 
be available as series (and therefore displayed in the worksheet table).
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Creating a Promotion

To create a promotion

1. In your worksheet, find an area that is currently displaying promotions; see 
“Where to Work with Promotions” on page 55.

1. Right-click an existing promotion and then select New Promotion.

Demantra Spectrum displays a screen where you can create a new promotion. 
Depending on your implementation, this screen may look like the following.

2. For Name, specify a unique name.

3. The Population area shows the currently selected combinations with which the 
new promotion will be associated. The defaults are taken from the current 
selection in the worksheet. To change this selection:

a. Click Edit below the Population area.
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The following dialog box is displayed:

b. Find the aggregation level at which you want to apply the promotion data and 
move it from the Available Filter Levels list into the Selected Filter 
Levels list, using any of the techniques in “Working with Lists” on page 96.

c. In the Available Members list, find a member that you want to include in 
the promotion and move it into the Selected Members list, using any of the 
techniques in “Working with Lists” on page 96. 

d. Continue with all aggregation levels to which the promotion should apply.

e. Click Finish.

4. For Dates, specify the starting and ending date of the promotion.

5. The rest of the fields prompt you for values of attributes associated with this 
promotion; the fields shown in red are required. The specific attributes you see 
depend upon your configuration, but they may include the following:

• For Scenario, choose the upper promotion level to which this promotion 
belongs. (In this example, promotions belong within scenarios.)

• For Promotion Type, choose a type of promotion that affects demand as 
closely as possible to the promotion you are creating. 

• For Promotion Status, choose either unplanned or planned. See “Promotion 
Status” on page 56.

6. Click Create. The new promotion is saved.

Note It is important to specify appropriate values for the attributes, because the 
Analytical Engine considers them when it creates the forecast.
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7. If you do not see your changes, click Options > Synchronize Activity and 
then rerun the worksheet.

Note

Other users can see this promotion, if they can see all item-location combinations with 
which the promotion is associated.

See also

“About Promotions” on page 55
“Deleting a Promotion” on page 65
“Maintaining the Promotion Hierarchy” on page 66

Modifying a Promotion

To modify a promotion

1. In your worksheet, find an area that is currently displaying promotions; see 
“Where to Work with Promotions” on page 55. 

2. Right-click a promotion and click Edit.

3. Make changes as needed; see “Creating a Promotion” on page 60 for details.

4. Click Finish. The changes are saved.

5. If you do not see your changes, right-click in the table and then select 
Synchronize Activity.

Notes

You can also modify promotion dates within the Gantt chart. To do so, in the Gantt 
chart, drag the starting point or end point of the bar to the required date.

If you change the length of time for a promotion, Demantra Spectrum automatically 
adjusts the data associated with that promotion, according to the configuration of that 
series. There are different options. For some series, Promotions Effectiveness 
preserves the net volume, summed over the promotion. If the promotion becomes 
longer, for example, the data values become smaller. In contrast, for other series, 
Demantra Spectrum preserves the approximate level of the data. The behavior you see 
has been configured for your needs and should make sense to you.

See also

“Promotion Status” on page 56
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Working with the Gantt Chart

To scroll the Gantt chart

• Click the left or right arrow buttons that are displayed next to the Activity 
Browser.

To zoom the Gantt chart

• Click either of the magnifying glass buttons that are displayed next to the Activity 
Browser.

• Right-click in the Gantt chart, click Zoom, and then click a zoom option.

For example, if you click Two Years, then the Gantt chart is resized so that two 
years can be viewed within the current display. If you click Fit Query to View, 
the Gantt chart is resized to display the entire span of time specified in the 
worksheet definition.

To sort the Gantt chart

See “Sorting Promotions” on page 64.

To change the promotion dates

In the Gantt chart, drag the starting point or end point of the bar to the required date.
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Sorting Promotions
You can sort the promotions as listed within the Activity Details subtab. These two 
areas are kept in synch with each other, and when you sort promotions in one area, 
Demantra Spectrum automatically sorts them in the other area as well.

To sort promotions

1. In the Activity Browser or the Gantt chart, right-click and select Sort by.

Demantra Spectrum shows a set of sort options for each promotion level in your 
implementation. For each level, you can sort by the promotions by any attribute 
of the level. These attributes include the name of the promotion and its parent 
levels, as well as the promotion start and end dates. The following shows an 
example.

2. Click the option corresponding to the attribute you want to use for sorting.

Demantra Spectrum sorts the promotions in ascending order by this attribute. It 
retains the existing promotion hierarchy; that is, it sorts each promotion relative 
to other promotions that belong to the same parent.
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Copying and Pasting a Promotion
You can copy and paste promotions. When you do so, Demantra Spectrum copies the 
attributes and the series data associated with the promotion.

To copy and paste a promotion

1. In your worksheet, find an area that is currently displaying promotions; see 
“Where to Work with Promotions” on page 55. 

2. Right-click a promotion and click Copy.

3. Right-click and then select Paste.

Demantra Spectrum displays a dialog box that asks for details about the copy.

4. Specify one of the following:

• To shift the dates of the newly copied promotion, specify a number in the Shift 
By field. The copy will be shifted later in time by the specified amount, but 
will last for the same length of time. You can use any integer, including 
negative number or zero.

• To specify a different start and end date, specify values in the From and To 
fields.

• To make the new promotion span the entire length of time used in the 
worksheet, select Worksheet Derive.

5. Click OK.

6. When prompted for a new promotion name, type the name and click OK.

See also

“Modifying a Promotion” on page 62
“Creating a Promotion” on page 60
“Maintaining the Promotion Hierarchy” on page 66

Deleting a Promotion

To delete a promotion

1. In your worksheet, find an area that is currently displaying promotions; see 
“Where to Work with Promotions” on page 55. Note that you cannot delete 
promotions from within the worksheet table.

2. Right-click a promotion and click Delete. 

3. Demantra Spectrum prompts you to confirm the action. Click Yes or No.

Note If the pasted promotion does not span the same length of time as the original, 
the associated series data is adjusted according to the rules given in 
“Modifying a Promotion” on page 62.
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See also

“Maintaining the Promotion Hierarchy” on page 66
“Creating a Promotion” on page 60

Maintaining the Promotion Hierarchy
Promotions typically belong in a hierarchy for management purposes. The specific 
hierarchy that is available to you depends upon your implementation. 

To create a member in the promotion hierarchy

1. In your worksheet, find an area that is currently displaying promotions; see 
“Where to Work with Promotions” on page 55. 

2. Right-click. Demantra Spectrum displays a menu that looks something like this:

The specific choices depend upon your implementation, but in general, you have 
options for creating members at each level in your promotion hierarchy.

In this example (from the standard Demantra Spectrum demo), the highest level 
corresponds to plans, the middle level corresponds to scenarios, and the bottom 
level corresponds to the actual promotions.

3. From this menu, click the option that corresponds to the level at which you want 
to create a new member. For example, to create a new scenario, click New 
Scenarios.

Demantra Spectrum displays a dialog box where you specify properties of the 
new member. 

4. For Name, specify a unique name.

5. Click Finish.

6. Click Data > Update to save your changes.

7. Click Data > Rerun to display the changes.

To copy and paste a member in the promotion hierarchy

1. In the Activity Browser, right-click a member and click Copy.

2. Right-click and then select Paste.

Demantra Spectrum displays a dialog box that asks for details about the copy.
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3. Specify one of the following:

• To shift the dates of the newly copied member, specify a number in the Shift 
By field. The copy will be shifted later in time by the specified amount, but 
will last for the same length of time. You can use any integer, including 
negative number or zero.

• To specify a different start and end date, specify values in the From and To 
fields.

• To make the new member span the entire length of time used in the worksheet, 
select Worksheet Derive.

4. Click OK.

Demantra Spectrum makes a copy of the member and all nodes below it.

To delete a member in the promotion hierarchy

1. Right-click the member and select Delete.

2. Demantra Spectrum prompts you to confirm the action. Click Yes or No.

See also

“Creating a Promotion” on page 60
“Deleting a Promotion” on page 65
“About Promotions” on page 55

Opening a Promotion in Another Worksheet
Depending on how your system has been configured, you may be able to open a 
worksheet that is filtered to show only data relevant to the promotion from which you 
started.

To open a promotion in another worksheet

1. In your worksheet, find an area that is currently displaying promotions; see 
“Where to Work with Promotions” on page 55. 

2. Then do one of the following:

• Right-click the promotion and then select Open. In this case, you are using the 
default worksheet associated with promotions.

• Right-click the promotion and then select Open With and then select a 
worksheet.

The worksheet appears in a new window or tab, depending on how you are currently 
viewing the worksheets.
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Using Other Right-Click Menu Options
Depending on your implementation, the right-click menu may include a Methods 
submenu that includes additional options created by your implementors. When you 
click one of these options, Demantra Spectrum displays a dialog box like the 
following:

Click the Save parameters check box if you want to save the attribute changes to 
the database when the method is run.

For information on any such menu items, please contact your implementors or your 
designated Demantra Spectrum system administrator.
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(Added in 7.0) This chapter describes how to take a worksheet 
offline, edit the data, and bring the worksheet back online. This 
chapter includes the following sections:

About Working Offline ...................................................................69
Setting Up Your Offline Environment ............................................71
Saving Data for Offline Use ..........................................................73
Accessing an Offline Worksheet.....................................................75
Reloading Offline Data..................................................................76

About Working Offline
(Added in 7.0) Normally, when you use a worksheet, Demantra Spectrum connects 
directly to the database and retrieves or saves data in response to your actions. Other 
users also retrieve and save data, and the database always contains the latest changes 
made by any user. In order to do this, the worksheets use an active connection to the 
Demantra Spectrum server.

However, it is useful to be able to work offline, that is, without a connection to the 
Demantra Spectrum server. When you are online, you save a worksheet (or part of it) 
for offline use. Then while you have no connection to the Demantra Spectrum data, 
you can use that worksheet and edit data in it. Later you bring the worksheet back 
online. When you do so, Demantra Spectrum saves the data back to the Demantra 
Spectrum database, just the same way it saves data from any other worksheet. 

In offline mode, you have access to most worksheet features. The following table 
summarizes what is available.

General Area Availability in Offline Mode

Worksheet access Available options:
• Opening and closing any worksheet that you have saved offline on 

this computer.
• Exporting
• Printing

Options that are not available:
• Opening worksheets that you have not saved offline on this 

computer.

Editing Available options: almost all the same as when working online (copy, 
paste, edit cell, and so on)

No option to reset manual changes (to reset manual changes, take the 
worksheet offline again and discard previous changes)
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See also

“Setting Up Your Offline Environment” on page 71

Right-click menus Not available

Screen 
management

Available options: same as when working online (hide/show worksheet 
elements, use of tabs or windows, and so on)

Worksheet design Available options:
• Viewing current worksheet design (Data > Info)

Options that are not available:
• Changing worksheet design or layout
• Creating new worksheets
• Saving worksheet with new name

Audit trail Available only for data within this worksheet

Analytics Not available (cannot tune forecast nodes, run simulations, or see 
forecast details)

Caching Not applicable.

General Area Availability in Offline Mode
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Setting Up Your Offline Environment
(Added in 7.0) The first time you save a worksheet offline, Demantra Spectrum sets 
up your offline environment, so that you can work while you do not have access to the 
Demantra Spectrum server. This is a one-type setup, per user, per machine.

To set up your offline environment

1. Within a normal Demantra Spectrum worksheet, click File > Export for 
Offline Use.

Demantra Spectrum displays the following screen:

Here you specify the directory where Demantra Spectrum will store your offline 
information. By default, this is c:/Documents and Settings/username, but 
you can choose a different location. The offline directory itself is always named 
Demantra.

2. Specify the offline directory location and click OK.

Demantra Spectrum then displays the following screen:

Note When you perform these steps, you must have network access to the 
Demantra Spectrum server, which must be running.
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Here you specify which data to take offline. You might want to work with only a 
single combination, for example.

3. Choose one of the options and click OK.

4. Log off Demantra Spectrum.

5. Enter the web address supplied by your system administrator for offline access. 
This URL probably has the following format:

http://server name/virtual directory/portal/launchDPWeb.jnlp

For example:

http://frodo/demantra/portal/launchDPWeb.jnlp

Depending on what is already installed on this computer, Demantra Spectrum 
then briefly displays a screen titled Java Web Start, which shows its progress in 
scanning and downloading the required JAR file. 

After that, Demantra Spectrum displays a dialog box that asks if you want to trust 
the signed application distributed by Demantra:

6. Click Start or Yes (or Always), depending on which dialog box is displayed.

Note If Demantra Spectrum does not display this screen, that means that you 
have already downloaded the applet to this machine. You do not need to 
download it again.

Depending your system configuration, the screen might be slightly 
different, with the following options instead: Yes, Always, and No.
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Next, Demantra Spectrum displays the following prompt:

7. Click Yes.

Demantra Spectrum creates a shortcut labeled Demantra Offline 
Worksheets, which you use to access your offline worksheets in the future. This 
shortcut is on your desktop and on your Start menu.

You are now configured to use worksheets offline.

See also

“Saving Data for Offline Use” on page 73
“Accessing an Offline Worksheet” on page 75

Saving Data for Offline Use
(Added in 7.0) You can save data from a worksheet (or part of it) in an offline format. 
Then you can work with the data offline and later upload it to Demantra Spectrum.

To take worksheet data offline

1. Within a normal Demantra Spectrum worksheet, click File > Export for 
Offline Use.

Demantra Spectrum then displays the following screen:

Note For details on this shortcut, see the “Troubleshooting User Problems” 
appendix in the Demantra Spectrum Administrator’s Guide.

Note If you have not already taken a worksheet offline on this machine, see 
“Setting Up Your Offline Environment” on page 71.
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Here you specify which data to take offline. You might want to work with only a 
single combination, for example.

2. Choose one of the options and click OK.

3. If you already took this worksheet offline on this machine, Demantra Spectrum 
displays the following screen, which asks how to handle the data changes you 
already made while offline:

4. Click one of the following options:

5. If you clicked Select changes from log, Demantra Spectrum displays a 
screen that shows all the changes to this data.

6. Click OK. 

See also

“Reloading Offline Data” on page 76

Overwrite all values with 
offline values

Treat the data in the offline worksheet as the 
latest data and save it all to the database.

Select changes from log View the audit trail for the data in this 
worksheet and select the changes to keep.

Discard all offline 
changes

Discard all changes made in the offline 
worksheet.
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Accessing an Offline Worksheet
(Added in 7.0) You can save data from a worksheet (or part of it) in an offline format. 
Then you can work with the data offline and later upload it to Demantra Spectrum.

To access an offline worksheet

1. Click the Demantra Offline Worksheets shortcut, which is on your desktop, 
and on your Start menu.

Demantra Spectrum then displays a login dialog box:

2. Enter your user name and password and click OK.

3. Click File > Open.

4. Click the worksheet that you took offline earlier. Note that it is shown with the 
offline icon.

If you currently have network access to the Demantra Spectrum server, Demantra 
Spectrum can open the worksheet in either of two modes, as follows:

Note If you have not already taken a worksheet offline on this machine, see 
“Setting Up Your Offline Environment” on page 71.

Note For details on this shortcut, see the “Troubleshooting User Problems” 
appendix in the Demantra Spectrum Administrator’s Guide.

Note If you are currently have network access to the Demantra Spectrum server, 
this list shows all worksheets. If you are offline, it lists only the offline 
worksheets.

Online Mode Click this option if you want access to the latest data in the 
database, irrespective of your offline changes. 
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See also

“About Working Offline” on page 69
“Reloading Offline Data” on page 76

Reloading Offline Data
(Added in 7.0) If you worked with data offline, you can reload it into Demantra 
Spectrum. When you bring a worksheet back online, Demantra Spectrum saves the 
data back to the database, just the same way it saves data from any other worksheet.

To reload offline data

1. In order to reload offline data, you must have network access to the Demantra 
Spectrum server.

2. Open the offline worksheet as follows:

a. First either click the Demantra Offline Worksheets shortcut or log into 
Demantra Spectrum as usual.

b. Click File > Open.

c. Click the worksheet and click Open.

If you currently have network access to the Demantra Spectrum server, Demantra 
Spectrum gives you a choice as follows:

d. Click Offline Mode and click Select. (You can “push” your changes from 
offline, but you cannot “pull” them from online.)

3. Click Data > Synch Offline Data.

Offline Mode Click this option if you want access to the data you saved 
offline earlier, with any changes you made to it. 

Note When you reload offline data, Demantra Spectrum uses information that it has 
recorded in an audit trail. When it does so, it moves that audit trail information 
into the database. This means that the local record of changes is no longer 
available. In practice, this means that you should delete an offline worksheet 
as soon as you reload all the desired data, and then take the worksheet offline 
again if needed.
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Demantra Spectrum displays the following screen:

4. Click one of the following options:

5. Click Delete offline worksheet when done. You can take the worksheet 
offline again later if needed.

6. Click OK. 

7. If you clicked Select changes from log, Demantra Spectrum then displays the 
a screen like the following:

a. Click the Accept Change check box for each change you want to keep.

b. Click the Accept Changes button on the right.

The selected changes are saved immediately.

Overwrite all values with 
offline values

Treat the data in the offline worksheet as the 
latest data and save it all to the database.

Select changes from log View the audit trail for the data in this 
worksheet and select the changes to keep.

Discard all offline 
changes

Discard all changes made in the offline 
worksheet.

Note You can use similar steps to delete other changes, if you want.
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c. Click Close.

See also

“Saving Data for Offline Use” on page 73
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7 Managing Items and 

Locations
You can use options on the right-click menu to manage items and 
locations.

About Managing Items and Locations...........................................79
Viewing the Attributes of an Item or Location...............................80
Creating an Item or Location ........................................................81
Modifying an Item or Location......................................................81
Deleting an Item or Location.........................................................82
Opening an Item or Location in Another Worksheet .....................82
Using Other Right-Click Menu Options ........................................83

See Also:
“Introduction to Levels” on page 86

About Managing Items and Locations
Depending on your authorization, you have access to options on the right-click menu 
that enable you to do the following:

• To view the attributes of an item, location, or other objects (known generically as 
members)

• To create, edit, and delete items, locations, or other objects

• To perform additional operations on members, as defined within your 
implementation

Permissions are set separately for each level and potentially for each user.

Where to Work with Items and Locations
The right-click menu is available in different areas of a worksheet:

• In the Members Browser

• In the worksheet table, if promotions are currently displayed there
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Interaction with Corporate Systems
If you change or add items or locations, you should be aware of how Demantra 
Spectrum interacts with your corporate systems. Demantra Spectrum periodically 
imports data about sales, items, and locations from your other systems. Each time data 
is imported into your system, the changes you have made to the levels are overwritten, 
depending on the kind of change. 

• You should edit or delete existing members only if you are expecting the same 
change to occur in the imported data, and you need to see the change right away 
within Demantra Spectrum for some reason. 

• If you add members, they will be kept when data is imported.

Viewing the Attributes of an Item or Location

To view the attributes of an item or location

1. In your worksheet, find an area that is currently displaying the type of object you 
want to work with; see “Where to Work with Items and Locations” on page 79.

2. Right-click an object and click View (for example, View Ship to). 

Demantra Spectrum displays a dialog box like the following:

The attributes shown in red are required. These include the Name attribute and all 
immediate parents of this member. Depending on your implementation, not all 
attributes are editable.
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Creating an Item or Location
In the current release, you can create a member, but you cannot display it in your 
worksheet.

To create an item or location

1. In your worksheet, find an area that is currently displaying the type of object you 
want to work with; see “Where to Work with Items and Locations” on page 79.

1. Right-click an object and then select New (for example, New SKU).

Demantra Spectrum displays a window where you specify the name of the new 
member, as well as its parent levels and other attributes.

2. For Name, specify a unique name.

3. The rest of the fields prompt you for values of attributes associated with this 
level; the fields shown in red are required. The specific attributes you see depend 
upon your configuration.

4. Click Create.

5. Click Data > Update to save your changes.

Modifying an Item or Location
You can modify a member by changing its name, the parent members to which it 
belongs, and any visible attributes.

To modify an item or location

1. In your worksheet, find an area that is currently displaying the type of object you 
want to work with; see “Where to Work with Items and Locations” on page 79.

2. Right-click an object and then select Edit (for example, Edit SKU). Then make 
changes as needed; see “Creating an Item or Location” on page 81 for details.

3. Click Finish.

4. Click Data > Update to save your changes.

5. Click Data > Rerun to display the changes.

See also

“About Managing Items and Locations” on page 79

Note You cannot see the new member in the Members Browser, because the 
Members Browser displays only item-location combinations that exist and that 
have sales. 
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Deleting an Item or Location

To delete an item or location

1. In your worksheet, find an area that is currently displaying the type of object you 
want to work with; see “Where to Work with Items and Locations” on page 79. 
Note that you cannot delete objects from within the worksheet table.

2. Right-click an object and click Delete (for example, Delete SKU). 

3. Demantra Spectrum prompts you to confirm the action. Click Yes or No.

See also

“About Managing Items and Locations” on page 79

Opening an Item or Location in Another Worksheet
Depending on how your system has been configured, you may be able to open a 
worksheet that is filtered to show only data relevant to the member from which you 
started.

The specific options are usually different for each aggregation level in your system.

To open an item or location in another worksheet

1. In your worksheet, find an area that is currently displaying the type of object you 
want to work with; see “Where to Work with Items and Locations” on page 79.

2. Then do one of the following:

• Right-click the item or location and then select Open. In this case, you are 
using the default worksheet associated with this item or location.

• Right-click the member and then select Open With and then select a 
worksheet.

The worksheet appears in a new window or tab, depending on how you are currently 
viewing the worksheets.

Note Depending on how this worksheet is defined, it is filtered in one of two ways:

• Filtered by member, that is, filtered to show the item or location from 
which it was launched, aggregating across all combinations

• Filtered by combination, that is filtered to show the specific combination 
from which it was launched
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Using Other Right-Click Menu Options
Depending on your implementation, the right-click menu may include a Methods 
submenu that includes additional options created by your implementors: 

When you click one of these options, Demantra Spectrum displays a dialog box like 
the following:

Click the Save parameters check box if you want to save the attribute changes to 
the database when the method is run.

For information on any such menu items, please contact your implementors or your 
designated Demantra Spectrum system administrator.
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8 Creating and 

Redefining 
Worksheets
This chapter describes how to create and redefine worksheets. The 
first sections introduce the concepts, and the later sections provide 
instructions. This chapter includes the following sections:

Introduction to Worksheets and Views...........................................86
Introduction to Levels ....................................................................86
Introduction to Series ....................................................................89
Visual Elements of Worksheet Views..............................................91
Levels and Layout Variations ........................................................94
Introduction to the Worksheet Editor.............................................96
Creating or Editing a Worksheet ...................................................97
Configuring the Worksheet Basics.................................................98
Selecting Series on a Worksheet ..................................................101
Specifying the Time Resolution and Time Span ...........................103
Specifying Aggregation Levels ....................................................105
Using the Advanced Selection Options........................................106
Changing the Overall Scale or Unit of Measure .........................108
Filtering the Worksheet................................................................109
Applying Exception Filters .......................................................... 111
Defining the View Layout ............................................................ 113
Adding and Managing Worksheet Views ..................................... 115
Specifying the Worksheet Elements in a View.............................. 117
Displaying a Worksheet as a Subtab in a View............................ 118
Filtering a Worksheet View.......................................................... 119
Sharing Worksheets .....................................................................120
Deleting Worksheets ....................................................................120
General Tips on Worksheet Design..............................................120
Viewing the Definition of a Worksheet.........................................121
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Introduction to Worksheets and Views
Within Demantra Spectrum, you work almost entirely within worksheets. A worksheet 
is a customized working environment designed especially for your use. Here you can 
view and edit data. When you save changes back to the database, they become 
available to other users and to downstream operations.

A worksheet consists of one or more views, usually displayed as tabs within the 
worksheet. Each view retrieves a set of data that is aggregated in a specific way and 
that may also be filtered. The following shows an example:

Here, views are shown as tabs within the worksheet. You can also display views as 
child windows of the worksheet.

Introduction to Levels
The first interesting feature of any worksheet view is the aggregation level or levels 
that it uses. For example, you might want to view data at the account level, as follows:

Views in this 
worksheet

Use this tree to select data at some 
aggregation level

The view aggregates series data to the 
specified level
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The worksheet might include a dropdown list instead of this tree control. For example: 

In either case, you can view data for any account. For example, for the quarter that 
started on February 3, 2003, the Demand for the CVS account was 1, 571, 396 units, 
and the unit price was $9.99. You can edit any data that is shown in white, such as the 
price and market plan.

In generic terminology, the word member refers to a unit within a level. For example, 
CVS is a member of the account level.

Level Types
Levels can group and aggregate data in many different ways, and Demantra Spectrum 
uses icons to indicate the type of level:

Item levels group and aggregate data according to characteristics of the items 
you sell.

Location levels group and aggregate data according to characteristics of the 
locations where you sell. For example, location levels could describe 
geography or types of stores.

Combination (or matrix) levels group and aggregate data according to 
characteristics of the item-location combinations. These are less common than 
item and location levels.

Time levels group and aggregate data by sales date. Normally you use a time 
level in place of the time axis.

Promotion levels group and aggregate data by sales promotions. Depending on 
how your system is implemented, you may have a hierarchy of promotional 
levels (to organize the promotions), and the higher levels might use different 
icons. 

Unlike other kinds of levels, promotion levels can be displayed within a Gantt 
chart, if you have a license for Promotions Effectiveness.
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In Demantra Spectrum, the levels are completely configurable and are easily 
extended. The levels that you see should make sense to you. Your Demantra Spectrum 
implementors defined levels as required for your organization, and an authorized user 
can add more. 

Level Attributes
A level can have attributes. For example, a Ship To member might have the following 
attributes:

Apart from the Name attribute, the attributes shown in red are all parents of this 
member. They are shown in red because they are required. 

The other attributes (such as Unit Cost) do not represent levels in the system but 
contain information used for reporting and other purposes. 

Settlement levels, which are used only by Settlement Management. If you use a 
settlement level in a worksheet, you cannot use levels from any other hierarchy 
in that worksheet.

Check request levels, which are used only by Settlement Management.
88 Demantra Settlement Management User’s Guide



Introduction to Series

 
 

Introduction to Series
Each worksheet shows series data associated with the combination that you have 
currently selected in the worksheet. These series were created by your implementors, 
for your organization’s needs. A worksheet displays the series data in a table, or in a 
graph, or both. The following shows an example of a worksheet table:

The example here shows series at the lowest level, but you can view data for any given 
series at any aggregation level. 

As you can see from this example, there are many possible variations of series:

• Some series are editable (see Stat Frcst), some are editable only for specific 
dates (see Pseudo), and some are not editable at all. Generally, editable series 
are used as input to other series.

• Some series are shown in different colors, depending on the data values. For 
example, Sales Fcst Bias is displayed in red for any values less than zero.

• Some series are calculated from other series.

• Some are generated by the Analytical Engine, if that is relevant in your Demantra 
Spectrum solution.

• Most series have time-varying values for each combination, but there are other 
kinds of series as well (discussed below). For example, the series Stat Frcst 
specifies whether a combination should be used in forecasting or not. As you can 
see, this series has the same value for all time buckets for a given combination.

• Most series have numeric values, but some have string or date values. For some 
series, you choose a value from a dropdown list.
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Kinds of Series
Demantra Spectrum supports the following kinds of series:

• Sales series contain time-dependent set of data for item-location combinations. 
That is, each data point in the series corresponds to a given item-location 
combination at a given point in time. This type of series is the most common type 
by far.

• Combination series (also called matrix series) store time-independent data for 
each item-location combination. That is, each data point in the series corresponds 
to a given item-location combination. You use combination series to store and 
maintain information about item-location combinations, mainly flags for the 
Analytical Engine to use. 

• Promotion series store time-dependent data associated with each promotion, at 
each item-location combination.

• Level series store data associated with a specific level. Each data point in the 
series corresponds to a given member of that level. 

Series and Summary Rows
Each series has been configured to be summarized in a specific way, which you can 
see in the summary row of the worksheet table. The table has at least one summary 
row; depending on the layout, it may also include subtotal rows. The following shows 
an example:

As you can see, Demantra Spectrum provides different summarizing options. In this 
example:

• Price and Discount are summarized by averaging.
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• Revenue is summarized by adding all the values.

• The Approved series is summarized by counting the number of approvals.

More complex options are also available. A given series can be summarized in 
different ways within a single worksheet table. Consult your implementors for details 
on how your series are summarized.

Visual Elements of Worksheet Views
In general, a worksheet view can contain the following common visual elements:

Axes of the View
Each worksheet view has an x-axis and a y-axis.

• In the graph, the x-axis is shown horizontally and the y-axis is shown vertically.

• In the table, the x-axis is displayed vertically and the y-axis is displayed 
horizontally. (This way, the x-axis displays the same data in the table and in the 
graph.)

Members Browser or dropdown lists

Subtabs

Current 
view

Table

Graph
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Members Browser or Combination-Selection Lists
As noted earlier, a worksheet view usually includes either a Members Browser or a set 
of dropdown menus, which you use to choose the data to display in the rest of the 
worksheet:

In each case, the selected combination is “Low fat products at the BJ account.” 

In addition to providing a way to select the data to display, the Members Browser 
enables you to create, edit, and delete the level members. See “Managing Items and 
Locations” on page 79. Depending on your implementation, you may also be able to 
perform additional operations on the members; see “Using Other Right-Click Menu 
Options” on page 83.

In some cases, the worksheet does not include either of these controls. This means one 
of following is true:

• The worksheet table is in crosstab format, which displays data for multiple items 
or multiple locations. See “Levels and Layout Variations” on page 94.

• The data in the worksheet is completely aggregated. It may be filtered, however, 
so it is not necessarily aggregated across all items and locations.

Worksheet Table
A worksheet table shows series data for the item-location combination that you have 
currently selected in the view. Depending on how the layout is configured, this may 
appear as an ordinary table or it may appear as a crosstab; see “Levels and Layout 
Variations” on page 94.

By default, each row in the table corresponds to a point in time, and each column 
displays the data for a series. As noted earlier, the table also has a summary row. If the 
worksheet is in crosstab layout, the table also includes subtotal rows.

Members 
Browser

selection 
lists
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The table can show the same series as the graph or a completely different set of series, 
but usually some of the same series are displayed in both places. To specify where 
each series is displayed, see “Defining the View Layout” on page 113. 

You can edit data in the white cells. The gray cells are computed and not editable. For 
details on editing data, see “Editing Data” on page 13. 

For a given combination and date, the table may display symbols that indicate that a 
promotion or a note is associated with that combination and date. These indicator 
symbols are generally displayed for only some of the series, depending on how 
Demantra Spectrum has been configured. See “Viewing Notes” on page 22.

Graph
A worksheet graph displays data for the current selection. By default, the horizontal 
axis shows time, and the vertical axis shows one or more series. 

Subtabs
A worksheet view can contain multiple subtabs.

• The Notes/Attachments subtab displays notes and attachments related to the 
selected combination. See “Viewing Notes” on page 22.

• The Activity Details subtab displays promotions and the promotion hierarchy. 
On the left, the Activity Browser displays an expandable tree view of the 
promotions associated with the currently selected combination. On the right, the 
Gantt chart displays the promotions associated with the currently selected 
combination. You can scroll backwards and forwards in time to see the start and 
end dates of each promotion, and you can zoom in and out in time.

This subtab is available only if you have a license to Promotions Effectiveness.

Here you can create, edit, and delete promotions and higher levels in the 
promotion hierarchy. See “Working with Promotions” on page 55.

• A worksheet can include a subtab that contains a related worksheet. When you 
select a combination in the worksheet table, the related worksheet shows data 
associated with that combination. This related worksheet potentially includes 
different series than the rest of the worksheet and may also be filtered further.

See also

“Defining the View Layout” on page 113

Note In order to include the graph, you must have a license for either Demand 
Planner Web or Promotions Effectiveness.
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Levels and Layout Variations
A worksheet can include multiple different levels or no levels at all (for a completely 
aggregated view). 

When a level is included in a worksheet, that means you can see data associated with 
each member of that level.

Multiple Levels in a Worksheet View
A worksheet view can include multiple levels, for example:

The appearance is slightly different if the worksheet includes dropdown lists instead 
of the Members Browser. For example:

When a view includes multiple levels, you have a more detailed view of the data. In 
the earlier example, data was aggregated across all SKUs for a given account. Here, in 
contrast, you see data aggregated separately for each SKU.
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Level Members Displayed in Crosstab Format
It is also possible to lay out a worksheet so that the members of a level are all 
displayed at the same time. This format is called a crosstab layout, and the table (also 
known as a pivot table) provides a cross tabulation of all the members.

The following figure shows a worksheet table in crosstab layout, with a row for each 
SKU member within each time bucket:

Notice that the Members Browser does not include the SKU level, because all SKUs 
are displayed at the same time.

For another example, the worksheet could instead display the SKU members across 
the top of the table rather than down the side, as in the following example:

Other variations are possible. See “Defining the View Layout” on page 113.
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Introduction to the Worksheet Editor

To create a new worksheet

• Click File > New. Or click the New button.

To edit an existing worksheet

1. Click File > Open. Or click the Open button.

2. Click a worksheet and click Open.

The worksheet editor has a set of buttons on the left, which you use to open different 
pages with different purposes:

Here you have the following options:

• To move to another page, either click a button on the left side of the page or click 
Previous or Next.

• To exit the worksheet editor and keep your changes, click OK. 

• To exit the worksheet editor and discard all changes, click Cancel.

Working with Lists
As you create or edit worksheets, you will often use pages that present two lists of 
elements, where you specify your selections. To do so, you move elements from the 
left list to the right list. The left list always presents the available elements (such as the 
available series) and the right list always shows your selections.

Button Purpose For details, see...

Display Specify basic information about the 
worksheet; specify how to display the 
content of this worksheet in Collaborator 
Workbench.

“Configuring the Worksheet 
Basics” on page 98

Series Select series to include. “Selecting Series on a Worksheet” 
on page 101

Time Specify time resolution of worksheet and 
span of time to consider.

“Specifying the Time Resolution 
and Time Span” on page 103

Aggregation 
Levels

Optionally specify aggregation levels to 
include.

 “Specifying Aggregation Levels” 
on page 105

Filters Optionally filter the data in the 
worksheet.

“Filtering the Worksheet” on 
page 109

Exceptions Optionally apply exception filters to 
further filter the worksheet.

 “Applying Exception Filters” on 
page 111

Layout 
Designer

Define the layout of the worksheet and 
its views, including the layout of the 
worksheet tables, the location of each 
included series, and the graph format.

“Defining the View Layout” on 
page 113
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You can move elements from one list to the other in many equivalent ways, 
summarized here:

• To move all elements from one list to the other, click one of the double arrow 
buttons, as appropriate.

• To move a single element from one list to the other, click the element and then 
click one of the single arrow buttons, as appropriate. Or double-click the element.

• To move several adjacent elements, click the first element, press Shift and click 
the last element. Then click one of the single arrow buttons, as appropriate.

• To move several elements that are not adjacent, press Ctrl and click each element 
you want. Then click one of the single arrow buttons, as appropriate.

Creating or Editing a Worksheet

To create a new worksheet

• Click File > New. Or click the New button.

To edit an existing worksheet

1. Click File > Open. Or click the Open button.

2. Click a worksheet and click Open.

3. Click the Worksheet menu and select one of the menu items. Or click one of the 
worksheet buttons on the toolbar.

4. Save your changes to the worksheet definition:

• To save the new definition, click the Save button. Or click File > Save 

• To save the worksheet with a new name, click the Save As button.

5. Rerun the worksheet to see your changes (unless you have changed only the 
layout, which is refreshed automatically). To do so, click Data > Rerun. Or click 
the Run button.

Note In contrast, the Data > Update option saves the data and notes in the 
worksheet, not the worksheet definition.
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Configuring the Worksheet Basics

To configure basic information for a worksheet

1. Click Worksheet > Display. Or click the Display button.

The system displays a page where you specify the following basic worksheet 
information:

Name The title to use in the My Worksheets module and in the 
worksheet window title.

Description Provides optional information to display in My Worksheets. 
This is especially useful in public worksheets for explaining 
the purpose of the worksheet to other users.

Access Select Private or Public. Private is for your use only. Public 
worksheets are available to all users in the group.
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Enable Extra 
Filters

This option adds an extra, user-controlled filter to the 
worksheet. If you select the Enable Extra Filters check box, 
that means that when you open the worksheet, you can 
prefilter the data before seeing the worksheet results; this is 
especially useful for users who use Demantra Anywhere.

Normally when you specify aggregation levels to include in 
the worksheet (as described in “Specifying Aggregation 
Levels” on page 105), all members of those levels are 
available in the worksheet. 

If you select the Enable Extra Filters check box, that means 
that when you run the worksheet, Demantra Spectrum first 
prompts you to select the members to display for each level. 
For an example, see “Viewing Data” on page 11.

This option has no effect on content panes.

Cache 
Worksheet 
Data

Specifies whether Demantra Spectrum should cache the data 
for this worksheet, for each user who works with it. If you 
cache a worksheet, it will run more quickly in general, but the 
cache will need to be refreshed periodically. Choose one of the 
following refresh options:

• Manual—users will have to manually refresh the cache. 
See “To refresh your local worksheet cache” on page 27.

• Automatic—Demantra Spectrum will automatically 
refresh the cache, as specified by your implementors.

In either case, Demantra Spectrum automatically detects when 
a cache is out of date and behaves appropriately. Demantra 
Spectrum also automatically refreshes the cache when you 
make certain structural changes to the worksheet.

Open With 
Context

Specifies how this worksheet should be filtered when a user 
opens it via the Open or Open With menu options (on the 
right-click menu; see “Opening an Item or Location in 
Another Worksheet” on page 82).

Choose one of the following options:

• Selected Member (this will filter the worksheet to the 
object from which it was launched, aggregating across all 
combinations associated with that object)

• Selected Combination (this will filter the worksheet to 
the combination from which it was launched)
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2. To display the content of this worksheet in Collaborator Workbench, check 
Content and then complete the following fields:

3. To specify how the worksheet table should appear, see “Defining the View 
Layout” on page 113.

Display 
Format

Specifies the display format to use. Not all display formats may 
be possible, depending on the number of levels and series you 
include.

Currently, Collaborator Workbench chooses the color to use for 
each series, when displaying series in the graph-type content 
panes.

Location Select Wide Pane or Narrow Pane to determine where the 
content pane will be displayed in Collaborator Workbench.

Top/Bottom 
Filter

(Only for bar chart content panes.) Specifies how to filter the 
members or combinations for display in the bar chart (to save 
space, not all members are shown). 

• Use the dropdown menu to specify whether the filter 
should apply to the top-ranked or to bottom-ranked 
members.

• In the input field, specify the number of members to be 
included.

• For Criteria Series, select the series that Demantra 
Spectrum should use to rank the members. (This does not 
control the order in which they are displayed in the chart.)

Note: If multiple items have identical values, all of them are 
displayed, and they collectively count as 1 towards the total. 
For example, suppose top values were 200, 150, 150, 100, and 
50. If you specified Top/Bottom filter as three, you would see a 
total of four items: both the 150 items, in addition to the 200 
and 100 items.

This option does not affect the worksheet.
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Selecting Series on a Worksheet
Every worksheet must include at least one series.

To specify the series on a worksheet

1. Click Worksheet > Series. Or click the Series button.

The system displays the Available Series and Selected Series lists. Each list 
is a collapsible list of series groups and the series in them. 

2. Move all series that you want into the Selected Series list. To do so, either 
double-click each series or drag and drop it. You can also move an entire series 
group from one list to the other in the same way.

3. Remove any series from the Selected Series list that you do not want to 
include on the worksheet.

4. To change the order in which the series are displayed, see “Defining the View 
Layout” on page 113.

See also

“Introduction to Series” on page 89

Note If you use a settlement level in a worksheet, all series in the worksheet must 
refer to tables used by the settlement hierarchy.

Note You cannot remove a series from a worksheet if that worksheet uses it as 
the Criteria Series for bar chart content. See Step 2 on page 100.
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Managing the Series Lists
You may have a very large number of series, and it can be useful to sort and filter these 
lists so that you can readily find what you need. The system also provides a search 
mechanism.

To sort a list of series

1. Click the Sort button.

The Sort dialog box is displayed. 

2. Drag the list name from the Available Columns to the Sort Columns. Or 
double-click the list name in the Available Columns list.

3. Click OK.

To filter a list of series

1. Click the Filter button.

The Filter page appears.

2. Click Add.

3. Click the arrow to the right of the operator box and select an operator from the 
dropdown list.

4. In the number box, enter the value by which to filter the list.

5. (Optional) You can filter further by using the AND relationship.

6. Click OK.

To find a series

1. Click the Find button. 

The Find dialog box appears.

2. In the Find where box, select the name of the list to search.

3. In the Find what box, type name of the series.

4. Select Up, Down or All to determine the direction of the search.

5. (Optional) Select one or more of the check boxes:

• Whole Word: Search for the exact match of a word.

• Match Case: Search for the exact match of a word (case sensitive).

6. Click Find Next to begin (or continue) searching.

Note This section applies only to the series page of the worksheet editor 
(Worksheet > Series). To sort the series as displayed in the worksheet, 
see Step 4 on page 113.
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Specifying the Time Resolution and Time Span
Each worksheet selects data for a specified span of time and optionally aggregates it in 
time. You use the Time dialog box to specify the time resolution of the worksheet 
results and to decide the span of time to which the worksheet applies. 

To specify time criteria

1. Click Worksheet > Time. Or click the Time button.

2. In the Time Scale box, specify the time resolution of the worksheet results. The 
data in the worksheet is aggregated to this time resolution. That is, this option 
specifies the period of time that each data point in the line graph represents.

3. In the Time Filter box, specify the time period to which the worksheet applies:

• Fixed if you always want the worksheet to show a specific time range, 
regardless of the current date.

• Relative to Today if you always want the worksheet to show a time range 
relative to today.

• Relative to Last Sales Date if you always want the worksheet to show a 
time range relative to the last sales date in the loaded data.

4. In the From Date and To Date boxes, enter values depending on the time filter 
you have chosen, as follows:

Time Filter Box Action

Relative From Date/
To Date

Specify periods in both From and To with the current 
(computer) date as the reference point. 

For example: If the Time Scale is Month, and you want 
to see results starting from six months before today, 
enter -6 in From Date.
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5. To control how dates are displayed in the worksheet, click the Advanced button, 
which brings up the following dialog box:

a. In the Format dropdown list, select a display format.

b. To offset the displayed dates, optionally specify values for Month Offset or 
Year Offset.

For example, to add one month to each displayed date, specify 1 for Month 
Offset.

The Preview field shows what the first time bucket in the worksheet would 
look like with this format and offset.

c. Click OK.

Note

If you change the time scale, the worksheet might not show exactly the same 
aggregate numbers, because the cutoff points for the worksheet would not necessarily 
be the same. For example, suppose your worksheet is weekly and displays 48 weeks 
of data. Then supposed you change the worksheet to display quarterly data. A quarter 
is 13 weeks, and the original span (48 weeks) is not an integer multiple of 13. So the 
worksheet selects a different amount of data and shows different overall results. 

Fixed From Date Enter a specific date as a starting point of the 
worksheet results. To enter a date, click the calendar 
button and select a date.

To Date Specify the number of periods you want to include, 
starting from the From date. 

Time Filter Box Action
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Specifying Aggregation Levels
A worksheet usually includes aggregation levels. When you use the worksheet, you 
can examine data for the item-location combinations associated with those levels. 

Based on the levels included in a worksheet, Demantra Spectrum automatically 
determines which item-location combinations the worksheet should include. 
Depending on which combination you select, the worksheet displays series data 
associated with that combination. For example, if you select one location level (city) 
and one item level (SKU), the worksheet will contain series data associated with each 
city-SKU combination. On the other hand, if you select one location level (city) and 
you do not specify an item level, the worksheet aggregates data for all items. That is, 
the worksheet will contain series data associated with each city, aggregated for all 
products.

To specify the aggregation levels in a worksheet

1. Click Worksheet > Aggregation Levels. Or click the Levels button.

The system displays the Available Levels and Selected Levels lists.

2. Move all aggregation levels that you want into the Selected Levels list, using 
any of the techniques in “Working with Lists” on page 96.

3. Remove any unwanted levels from the Selected Levels list.

The selected levels will now be used on all views of this worksheet, unless you 
configure the views otherwise; see “To specify which levels to use in a worksheet 
view” on page 114.

The layout of the worksheet view controls the order in which the levels are used; 
see “Defining the View Layout” on page 113.

See also

“Using the Advanced Selection Options” on page 106
“Introduction to Levels” on page 86
“Changing the Overall Scale or Unit of Measure” on page 108

Notes • If you do not specify any aggregation levels in a worksheet, the data is 
completely aggregated across all items and locations.

• If you use a settlement level in a worksheet, you cannot use levels from 
any other hierarchy in that worksheet.
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Using the Advanced Selection Options
By default, if a worksheet includes a promotion level, the worksheet includes all the 
following types of combinations:

• Combinations that have both sales data and promotions

• Combinations that have sales data, but no promotions

• Combinations that have promotions, but no sales data

The worksheet displays placeholders for combinations that do not have promotions. 
For example:

If you move the promotion level to the worksheet axis (see “Defining the View 
Layout” on page 113), the table will display a similar placeholder.

You can exclude some of these combinations. For example, you might want the 
worksheet to include only the combinations that have both sales and promotions, as 
follows:

To exclude combinations with partial data

1. Click Worksheet > Aggregation Levels. Or click the Levels button.

2. Make sure that the worksheet includes at least two levels, one of which should be 
a promotional level.
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When you do so, the screen displays an Advanced button in the lower right.

3. Click Advanced. Demantra displays a dialog box with additional options.

4. To exclude the combinations you do not want to see, click the check boxes as 
needed.

Include combinations 
that exist only in 
Promotion

This option selects combinations that have 
associated promotions, even if they do not have 
sales data.

Include combinations 
that exist only in 
SALES_DATA

This option selects combinations that have sales 
data, even if they do not have any associated 
promotions.
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See also

“Specifying Aggregation Levels” on page 105

Changing the Overall Scale or Unit of Measure
In addition to levels, series, and filtering, a worksheet has the following 
characteristics:

• A single unit of measure. Typically, most series refer to this unit of measure, but 
there are exceptions such as percentage values. You can switch the unit of 
measure, and the displayed values are changed accordingly. The units in your 
system depend upon your implementation but probably include unit count and 
dollars. 

For monetary units, you can also switch to a different index (such as the 
Consumer Price Index or CPI) or exchange rate, and the worksheet automatically 
multiplies all values accordingly.

• An overall scale, which defaults to 1. If the displayed values are all large, it can be 
useful to rescale the worksheet, for example, to display in amounts of 1000 or 
1000000.

You can change either or both of these. When you make this change, the displayed 
values for most or all of the series in the worksheet are changed.

To change the overall scaling factor

1. Click Worksheet > Aggregation Levels. Or click the Levels button.

The Levels page includes a section where you specify the overall scale of the 
worksheet, as well as its units of measure.

2. In the Scale Units by box, specify the factor by which all numbers in the 
worksheet are to be divided (for display purposes).

For example, if you specify a factor of 1000, the displayed data will divided by 
1000. So the number 96,000 will be displayed as 96. The vertical axis of the 
graph is updated to show the factor in parentheses. For example, if the vertical 
axis was formerly labeled “units”, it will be updated to say “units (1000)” instead.

Note This change affects only the series that are scaled. Not all series are scaled. 
For example, a series defined as a percentage is probably not scaled.
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To change the unit of measure 

1. Click Worksheet > Aggregation Levels. Or click the Levels button on the 
toolbar.

2. In the Unit Type box, select the unit of measure to display in the worksheet 
results. 

For example, our items are bottles, and suppose that a case that contains six 
bottles. If you display the worksheet with cases instead, the system will display 
the number of bottles divided by six.

3. If the Index box is displayed, choose an index from the dropdown list.

The Index menu lists all the time-dependent indexes and exchange rates that are 
associated with this unit. Each index or exchange rate is a time-varying factor that 
the worksheet can use. When you select an index, the worksheet will 
automatically multiply all monetary series by the factor for each date. For 
example, if you choose Consumer Price Index (CPI) as the index, the system will 
calculate all monetary quantities with relation to the CPI.

See also

“Specifying Aggregation Levels” on page 105

Filtering the Worksheet
Filters control the combinations that you are able to see. Filtering can have multiple 
sources:

• A given worksheet may be filtered. For example, worksheet X might show only 
Brand X, which means that the worksheet would show only combinations related 
to Brand X.

• Your user ID may be filtered. For example, if you are an account manager, your 
user ID might give you access only to your accounts. At any level, you would not 
be able to see combinations associated with other accounts.

• The data that you share with other users (called the component) might also be 
filtered. Components divide the data for different sets of users.

Demantra Spectrum automatically combines all the filters. In the preceding example, 
if the component is not filtered, if you use worksheet X, you can see only data for 
Brand X at your accounts.

Note These indexes and exchange rates are generally imported from other 
systems. The set available to you depends upon your implementation.
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In contrast to an exception filter (“Applying Exception Filters” on page 111), this type 
of filter is static and behaves the same no matter how the data changes.

To apply a filter to a worksheet

1. Click Worksheet > Filters. Or click the Filters button.

The system displays the Available Filter Levels and Selected Filter Levels 
lists.

2. Find the aggregation level at which you want to filter data and move it from the 
Available Filter Levels list into the Selected Filter Levels list, using any of 
the techniques in “Working with Lists” on page 96.

3. In the Available Members list, find a member that you want to include in the 
worksheet and move it into the Selected Members list, using any of the 
techniques in “Working with Lists” on page 96. 

At this stage, the worksheet includes only data for this member. (Before you 
applied a filter at this level, the worksheet could theoretically include any 
member of this level.)

4. Continue to move members from the Available Members list into the 
Selected Members list, until the latter list includes all the members you want.

To filter data further

Once you have applied a filter as described above, the worksheet contains only those 
combinations that are associated with the members you specified. You can further 
filter the data in exactly the same way. Also see “Applying Exception Filters” on 
page 111.

Managing the List of Members
Depending on how your system has been configured, it might contain a very large 
number of members. If so, you might want to sort or filter the list or search it. For 
information, see “Managing the Series Lists” on page 102.

Note This level does not have to be the same as any of the aggregation levels 
you display in the worksheet. In fact, typically you filter using a different 
level than you use to display.
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Applying Exception Filters
If you attach an exception filter to a worksheet, Demantra Spectrum checks the values 
of the worksheet data and displays only the combinations that meet the exception 
criteria. In contrast to an explicit filter (“Filtering the Worksheet” on page 109), this 
type of filter is dynamic and can behave differently as the data changes.

Specifically, you define an exception condition that consists of a series, a comparison 
operator, and a value, for example:

When you open the worksheet, Demantra Spectrum checks each combination in the 
worksheet. For each combination, if the condition is met for any time in the worksheet 
date range, Demantra Spectrum displays that combination. For example, the 
worksheet shows combinations that have Sales Plan values greater than or equal to 
150000, within the time range included in the worksheet.

If the condition is not met at any time for any of the worksheet combinations, 
Demantra Spectrum shows the worksheet as empty. That is, if all values in the Sales 
series are less than 15000 for all combinations, the worksheet comes up empty.

You can apply multiple exceptions to a worksheet. When you apply multiple 
exceptions, you can relate them to each other via logical AND or logical OR 
relationships. For example:

To apply an exception filter

1. Click Worksheet > Exceptions. Or click the Exceptions button.

The Exceptions Filter page appears.

2. Click Add.

Note Exception filters do not cause filtering in time. If a combination meets the 
exception criteria, Demantra Spectrum displays data for that combination for 
all time buckets within the time range of the worksheet.

Note If the worksheet includes a promotion level or a promotion series, the 
behavior is slightly different. In this case, the Members Browser or dropdown 
list does initially show all combinations. When you click a combination to 
display it, the worksheet then checks for exceptions.
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3. In the first box in the new row, select a series from the dropdown list.

4. In the second box, select an operator from the dropdown list.

5. In the third box, type or choose a value.

• For a numeric series, type a number.

• For a dropdown series, choose one of the allowed values of this series.

• For a string-type series, type any string. You can use the percent character (%) 
as a wildcard.

• For a date-type series, type a date or use the calendar control to choose a date.

6. (Optional) You can apply additional exceptions. Select the AND or the OR radio 
button to specify the relationship between the exceptions.

To delete an exception filter

• Click the exception and then click Delete.

See also

“Filtering the Worksheet” on page 109
“Introduction to Series” on page 89

Note Typically only some series are available for exceptions. If you do not see 
a series you need, contact your Demantra Spectrum administrator or your 
implementors.
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Defining the View Layout

To define the layout of a current view

1. Click Worksheet > Layout Designer. Or click the Layout Designer button.

The system displays a page where you specify the layout. This page displays the 
following areas:

In addition, this screen displays the following icons:

• An icon for each aggregation level that you have included in the worksheet. By 
default, these levels are included in the Members Browser or selector lists.

• An icon that represents the time axis. By default, time is shown on the x-axis.

• An icon that represents the series data. Series are shown on the y-axis.

2. To change the worksheet layout, drag the level or time axis icons to the 
appropriate areas. You cannot move the series icon.

3. To specify the type of graph to use, select a graph type from the Graph Type 
dropdown list.

4. To specify how to display series in this view:

a. Click the Sort button.

this tab represents one 
view of the worksheet 
(the Default view, in 
this example)

this area represents the 
Members Browser or 
the dropdown lists

this area represents the X-axis 
and its contents

this area represents the Y-axis 
and its contents
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The Layout Designer displays a page that shows the order in which this view 
currently displays the series.

b. To hide a series in this view, click the None option in the dropdown list to the 
right of the series name.

c. Otherwise, to specify where to display the data for a series, select one of the 
following options: Table, Graph, Table and Graph.

d. To move a series up or down in this list, click the series name and drag it up or 
down.

e. When you are done, click Close.

5. Click Save.

6. Rerun the worksheet to see your changes. To do so, click Data > Rerun.

To specify a crosstab layout

1. Drag one or more level icons from the Page Item area to x-axis or y-axis areas.

To specify which levels to use in a worksheet view

By default, all levels you include in a worksheet are used on all views of the 
worksheet. Within a multi-view worksheet, you often hide some of the levels in some 
views, so that each view is aggregated differently.

1. Right-click within the Page area of the Layout Designer.

The system displays a menu like the following:.
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2. Click Hide level and then click the name of the level to hide. 

When you hide a level, the worksheet automatically aggregates data across 
members of that level.

To revert to the default layout of a worksheet view

1. Click Worksheet > Layout Designer. Or click the Layout Designer button.

2. Click the tab corresponding to the worksheet view you want to reset.

3. Click the Reset button.

In the default layout, all selected levels are visible and are on the X axis. Also, all 
series are displayed in the graph and/or table according to their default definitions.

See also

“Visual Elements of Worksheet Views” on page 91
“Levels and Layout Variations” on page 94
“Specifying the Worksheet Elements in a View” on page 117
“Displaying a Worksheet as a Subtab in a View” on page 118
“Filtering a Worksheet View” on page 119

Adding and Managing Worksheet Views
A worksheet can include multiple views, each of which can have a different set of 
series and a different layout.

To add a worksheet view

1. Within the Layout Designer, click the Add Worksheet View button.

2. In the popup dialog box, type the name of the new view.

3. Click OK.

Note Do not use this option to hide the time axis.
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To control synchronization between the views

The views of a worksheet may or may not be synchronized with each other. If they are 
synchronized, when you edit in one view, that change automatically appears in the 
other views. Because this can affect performance, sometimes it is best to switch off 
this synchronization.

Within the Layout Designer, click one of the following buttons, whichever is currently 
displayed:

To rename a worksheet view

1. Within the Layout Designer, click the Rename Worksheet View button.

2. In the popup dialog box, type the new name of the view.

3. Click OK.

To enable or disable a worksheet view

1. Within the Layout Designer, click the Hide/Display button.

2. The Layout Designer displays a popup list of all the views associated with this 
worksheet. A check mark is displayed next to each view that can currently be 
displayed.

3. For the view interest, click the check box next to the name of the view.

4. Click elsewhere on the screen to close the list of views.

To delete a worksheet view

Within the Layout Designer, do one of the following:

• Click the tab that corresponds to the worksheet view. Then click the Delete 
Worksheet View button.

• Click the Delete All Worksheet View button. Then, at the prompt, click Yes.

See also

“Defining the View Layout” on page 113
“Specifying the Worksheet Elements in a View” on page 117
“Displaying a Worksheet as a Subtab in a View” on page 118
“Filtering a Worksheet View” on page 119

Do not force synchronization between views

Synchronize data between views
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Specifying the Worksheet Elements in a View
For each worksheet view, you can specify which of the basic worksheet elements are 
included: the table, the graph, and so on. 

To specify the elements to include in a worksheet view

1. Click Worksheet > Layout Designer. Or click the Layout Designer button.

2. Click the tab corresponding to the worksheet view you want to modify.

3. Click Advanced... in the lower right.

Demantra Spectrum displays the following screen:

Depending on your personal license and on the system configuration, you may 
not have all these elements.

4. For Combination Selector, click either Tree (to display a Members Browser) 
or Dropdowns (to display dropdown menus instead).

Notes • In order to include the graph, you must have a license for either 
Demand Planner Web or Promotions Effectiveness.

• The Activity Details option displays the Activity Details subtab; 
this option is available only if you have a license to Promotions 
Effectiveness.

• The Notes/Attachments option displays the Notes/Attachments 
subtab; this option is available only if you have a license to 
Settlement Management. Even if this subtab is not displayed, users 
can still see notes in other ways; see “Viewing Notes” on page 22.
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5. Click the check box next to each element you want to include in this view of the 
worksheet. 

6. Click OK.

Displaying a Worksheet as a Subtab in a View
You can display one or more associated worksheets as a subtab within a view. When 
you select a member in the view, the subtab worksheet is filtered to show just that 
member. You typically use a subtab worksheet to drill into further detail.

To display a worksheet as a subtab within a view

1. Click Worksheet > Layout Designer. Or click the Layout Designer button.

2. Click the tab corresponding to the worksheet view to which you want to add the 
subtab.

3. Click Advanced... in the lower right.

Demantra Spectrum displays the Advanced screen.

4. Click the Add WS As Subtabs tab.

Demantra Spectrum displays a screen like the following:

Depending on the level that you select, the bottom part of the screen shows 
different worksheets that you can add as a subtab to this worksheet view.

Note If you use the keyboard to move through the worksheet table, the subtabs are 
not automatically refreshed, for performance reasons.
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5. For Selected Levels, select the level that is associated with the worksheet you 
want. In general, a worksheet is associated with the levels where it makes sense to 
use it; this is controlled by your system configuration. You can choose any of the 
levels that are used in this worksheet.

6. For Selected Worksheets, select the worksheets that you want to display as 
subtabs within this worksheet view.

7. Click OK.

Filtering a Worksheet View
For each worksheet view, you can filter the view to show a subset of the data in the 
worksheet.

To filter a worksheet view

1. Click Worksheet > Layout Designer. Or click the Layout Designer button.

2. Click the tab corresponding to the worksheet view you want to filter.

3. Click Advanced... in the lower right.

Demantra Spectrum displays the Advanced screen.

4. Click the Filter By Level Members tab.

Demantra Spectrum displays a screen like the following:

5. For Selected Filter Levels, select the level by which you want to filter this 
worksheet view. You can choose any of the levels that are used in this worksheet.
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6. For Selected Members, select the level members whose data should be 
displayed in this worksheet view.

7. Click OK.

Sharing Worksheets
In general, any worksheet is one of the following:

• Private—available only to you

• Public—available to other users as well. (If you are using the separately licensed 
Collaborator Workbench, this means the worksheet is available to other users 
within the collaborative group.) 

In either case, the original creator of a worksheet owns it and only that person can 
change it.

When you do share worksheets, however, you should consider data security. Demantra 
Spectrum automatically prevents any user from seeing data for which he or she does 
not have permissions. If you build a worksheet with data that other users do not have 
permissions to view, then those users will see an empty worksheet. Similarly, if a user 
has partial permissions for the data, then the worksheet will open with only those 
results that are permitted.

See also

“Configuring the Worksheet Basics” on page 98

Deleting Worksheets
You can delete a worksheet if you are its owner.

To delete a worksheet

1. Open the worksheet.

2. Click File > Delete. Or click the Delete button.

Demantra Spectrum prompts you to confirm the deletion.

3. Click Yes or No.

General Tips on Worksheet Design
• For performance reasons, don’t select too much data to view, unless there is no 

other choice. 

• If you receive a message saying “out of memory,” try the following techniques to 
reduce the amount of memory that your worksheet selects:

• Remove series if possible

• Reduce the span of time
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• Apply filters

Also see the Demantra Spectrum Administrator’s Guide.

• If you do need to select a large amount of data, use the levels to your advantage. 
Specifically, use the levels in the Members Browser or selector lists rather than 
moving them to a worksheet axis. If levels are in the Members Browser or 
selector lists, each combination in the worksheet is relatively smaller and will 
load more quickly.

• If you do not plan on working with the Activity Browser, you can switch off the 
Auto Sync option on the toolbar, and you can also hide the Activity Browser and 
Gantt chart.

• Remember that you can filter the worksheet by any level, including levels that are 
not shown in the worksheet. For example, you might want to see data at the 
region level, but exclude any data that does not apply to the Acme territory. To do 
this, you would filter the worksheet to include only the Acme member of the 
Territory level, but you would select data at the Region level.

• A multi-view worksheet is useful in following cases:

• If you need to edit data at one aggregation level and see easily how that affects 
higher aggregation levels.

• If you need to display a large number of series without having to scroll to see 
each one.

Viewing the Definition of a Worksheet

To view the definition of a worksheet

1. Open the worksheet.

2. Click Data > Info. Or click the Info button.

Demantra Spectrum displays a dialog box that summarizes the definition of a 
worksheet, for example:
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9 Collaborating with 

Others
This chapter provides a quick introduction to Collaborator 
Workbench. It includes the following sections:

Collaboration Tools in Demantra Spectrum................................123
Logging into Collaborator Workbench........................................124
Opening a Worksheet from Collaborator Workbench..................126
Managing Tasks in Collaborator Workbench ..............................127
Sending a Task from an Open Worksheet.....................................130
Viewing Other Users....................................................................131

Collaboration Tools in Demantra Spectrum
If you have a license to Collaborator Workbench, you can collaborate with others in 
two general ways:

• You can log into Collaborator Workbench, see other users in your collaboration 
groups, see tasks assigned to you, send tasks to others, and launch worksheets. 

• You can send tasks to other users from within a worksheet (that is, from within 
Demand Planner Web, Promotions Effectiveness, or Settlement Management)

When you launch a worksheet from within Collaborator Workbench, you 
automatically launch Demand Planner Web, Promotions Effectiveness, or Settlement 
Management, whichever product you are licensed to use. Similarly, when you log off 
Collaborator Workbench, you are automatically logged off from Demand Planner 
Web, Promotions Effectiveness, or Settlement Management.

This chapter documents the key features related to collaboration. For further details on 
working with Collaborator Workbench, see the Collaborator Workbench User’s 
Guide.

Note Collaborator Workbench requires another license in addition to Demand 
Planner Web, Promotions Effectiveness, or Settlement Management.
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Logging into Collaborator Workbench

To log into Collaborator Workbench

Your Windows Start menu may include a link to Collaborator Workbench. If so, use 
that. If not:

1. Open Microsoft Internet Explorer.

2. Enter the URL supplied by your system administrator. This URL probably has the 
following format:

http://server name/virtual directory/portal/loginpage.jsp

For example:

http://frodo/demantra/portal/loginpage.jsp

3. In the Log On dialog box, enter your user name and password.

4. Click Login.

5. If you have not logged into any of the Demantra Spectrum Web products before 
on this machine, then Demantra Spectrum installs a small applet on the machine.

6. Optionally click Yes if you want the system to always trust content from this 
source. 

After you install the applet, Collaborator Workbench comes up, displaying your 
personal page.

Note The exception is Demantra Anywhere, which does not use this applet.
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Depending on how Collaborator Workbench is configured, it can include some or all 
of the elements shown in the following figure. You can configure all these elements 
for your own needs. For example, only a single content pane is shown here, but you 
can add as many as you need.

Tasks currently assigned to you Status of other users

Worksheets you often use Summary data (content) for a worksheet
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Opening a Worksheet from Collaborator Workbench
In Collaborator Workbench, My Worksheets lists some or all of the worksheets to 
which you have access, specifically, the following worksheets:

• Private and public worksheets that you own.

• Public worksheets where you and the owner are in the same collaborative group.

To display My Worksheets

If Collaborator Workbench does not currently display My Worksheets, do the 
following:

1. Click the Personalize link in the upper right of Collaborator Workbench.

2. Click the check box next to My Worksheets and then click Next.

3. Click Next again and then click Finish.

To open a worksheet

1. Click a worksheet within My Worksheets. Or click the Open button on the 
upper right of a content pane.

2. Depending on how the worksheet was configured, you may now be prompted to 
filter the data. In this case, one or more selection pages are displayed when the 
worksheet is opened.

a. On each selection page, select one or more choices or click Select All to 
select the whole list. 

b. Click Next or click Finish.

Demantra Spectrum now launches Demand Planner Web, Promotions 
Effectiveness, or Settlement Management, whichever product you are authorized 
to use.

See also

“Working with Data” on page 11
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Managing Tasks in Collaborator Workbench
In Collaborator Workbench, tasks enable you to send work items to other users, to 
share information and to interact with the automated demand chain processes. Tasks 
appear in the My Tasks module. 

A task usually corresponds to a worksheet that you send to another user or receive 
from another user. The task also can include a short message, links to Web sites, and 
attached files.

The Workflow Engine also sends tasks, generally to alert you of exceptions, provide 
forecasts, or communicate messages and information during appropriate 
circumstances.

Viewing Tasks Assigned to You

To display My Tasks

If Collaborator Workbench does not currently display My Tasks, do the following:

1. Click Personalize.

2. Click the check box next to My Tasks and then click Next.

3. Click Next again and then click Finish.

To view all assigned tasks

The My Tasks module does not necessarily display all your tasks. To check for 
additional tasks:

• Click the More link in the bottom right corner of My Tasks.

My Tasks fills the wide pane and shows all current tasks.

Note When you receive a task, you might also receive an email notification in your 
email system, if the sender has selected this as an option.
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To refresh My Tasks

• Click Save & Refresh in the My Tasks module.

Any changes made in My Tasks are communicated to the Collaborator 
Workbench engine.

The date and time of your last My Tasks refresh is shown in the lower right 
corner of the My Tasks display.

Addressing a Task
In general, you address a task in two stages:

1. Examining the associated worksheet and editing or approving data as appropriate. 
How you do this depends upon your organizational needs.

2. Marking the task as done so that the Workflow Engine can continue with the 
workflow.

To mark a task as done

Before you mark a task as done, make sure that you have reviewed all the relevant 
information and that you have addressed any concerns or issues. Then do the 
following:

1. First:

• For a regular task, click the check box to the left of the task.

• For a selection task, select the appropriate response from the dropdown list in 
the Select value column. The check box next to the task is automatically 
checked.

2. Click the Save & Refresh link at the bottom of the task list.

The task is removed from My Tasks and the updated task list is shown.

Note When you receive a task, the Workflow Engine waits until the task status has 
been changed to Done before continuing with the workflow instance. It is 
therefore very important that you mark tasks as done after you have attended 
to the task requirements.

Caution If you go to another page or log off without clicking Save & 
Refresh, then your changes will be lost.
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To cancel the done status

If you have not yet refreshed the My Tasks list, you can cancel your change:

• For a regular task, clear the check box next to the task whose status you want to 
change from done incomplete.

• For a selection task, use the dropdown box to select a response from the list.

To mark all tasks as read

• Click Mark Tasks as Read.

The bold emphasis is removed from the text in the list. This does not occur 
automatically when a task is marked as Done.

Sending a Task from Collaborator Workbench
Depending on how your Collaborator Workbench has been configured, you may be 
able to send tasks to other users.

To create and send a task

1. Start by doing one of the following:

• Within My Worksheets, click Send on the worksheet that you want to 
send.

• Within My Tasks, click Create Task.

The Send Task to User dialog box appears.

2. Click To..... and select the users and/or groups to receive the task.

3. In the Message field, type a short text message.
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This will be the task message that the recipient sees. The worksheet that you are 
sending will be added automatically as a link from the Message text.

4. In the Description field, type a short description.

This description will be displayed below the task message in the recipient’s My 
Tasks module.

5. To link the task subject line to a Web page, enter the full path to the file in URL 
field.

6. Optionally, to attach a file to the task, enter the path to the file in the File 
Attachment field or use the Browse button to find it.

7. Optionally, to ensure that this task is completed by a specific time, click 
Escalate and then provide the following information:

8. To send an email notification to the recipient of the task, select the Send to 
email list check box. (Depending on how your system has been configured, this 
option may not be available.)

9. Click Send Task.

When the recipient next logs in (or refreshes My Tasks), he or she will see the new 
task.

Sending a Task from an Open Worksheet
In addition to sending tasks from Collaborator Workbench, you can send a task 
directly from an open worksheet; that is, you can send a task from within Demand 
Planner Web, Promotions Effectiveness, or Settlement Management, whichever 
product you are currently using.

When you send a task from within an open worksheet, you can filter the task to focus 
on a specific combination.

To send a task from an open worksheet

1. Open a worksheet.

2. Optionally navigate to a combination that you want to focus on.

3. Click File > Send as Task or click the Send as Task button.

Note You must enter the full URL, including server name and directory 
hierarchy. The http:// part will be added automatically if omitted.

Due Date Date and time by which this task must be completed

Alert Time Date and time at which an alert will be displayed

To Additional email addresses
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The Send Task to User dialog box appears.

4. Complete the fields as described in “Sending a Task from Collaborator 
Workbench” on page 129.

5. Click either Send Worksheet or Send Selected Combination to specify 
whether to filter the worksheet. If you click Send Selected Combination, the 
worksheet is filtered to the combination that you are currently viewing. 
Otherwise, the entire worksheet is sent.

6. Click Send Task.

Viewing Other Users
In Collaborator Workbench, the Who’s Online module shows the status of other 
users who belong to the same collaborative groups as you.

To send an email to a contact

• Double-click the name of the contact that you want to send an email to.

The email application opens with a new message to the contact.

Note If you do not have an email application installed, then you will receive an error 
message when you try to send a message to another user.
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10 Using Worksheets 

Remotely
By using Demantra Anywhere, you can access worksheets remotely 
and perform many of the same tasks described earlier in this 
manual. This chapter includes the following sections:

Introduction to Demantra Anywhere ...........................................133
Logging Onto Demantra Anywhere.............................................134
Opening a Worksheet in Demantra Anywhere.............................135
Using Worksheets in Demantra Anywhere ..................................136

Introduction to Demantra Anywhere
In contrast to the other Demantra Spectrum products, Demantra Anywhere is a true 
thin Web client and does not require an applet. You can use it to access Demantra 
Spectrum functionality from remote machines, including handheld devices.

On the other hand, Demantra Anywhere provides less functionality than the other 
products. The following table summarizes the features in Demantra Anywhere that 
relate to worksheets.

Notes • Demantra Anywhere uses a separate license.

• Demantra Anywhere does not enable you to work offline. That is, you 
have access to the data only while you are actually logged on. For 
information on taking a worksheet offline, see “Working Offline” on 
page 69.

Feature Availability in Demantra Anywhere

Worksheet elements • If the worksheet includes subtabs, Demantra Anywhere does 
not display them.

• Worksheet includes dropdown lists instead of a Members 
Browser, no matter how the worksheet is defined.

• You use dropdown menus to access each view of a multi-view 
worksheet.

• The graph is not shown.
• Worksheet table cannot use crosstab layout (no levels on the 

axes).

Menu bar Not available. Instead use the icons in the toolbar.

Right-click menus Browser menu options only.
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Logging Onto Demantra Anywhere

To log onto Demantra Anywhere

1. Open Microsoft Internet Explorer.

2. Enter the URL supplied by your system administrator. This URL probably has the 
following format instead:

http://server name/virtual directory/portal/anywhereLogin.jsp
For example:
http://frodo/demantra/portal/anywhereLogin.jsp

3. In the login dialog box, enter your user name and password.

4. Click Login.

Opening and running 
worksheets

• Can open and close worksheets.
• Can rerun currently open worksheet.
• Cannot view worksheet definition.
• Cannot take worksheets offline or bring back online.

Managing the screen • If you open multiple worksheets, each is opened in a separate 
browser.

• Cannot resize different worksheet areas (for example, the 
table).

• Cannot resize table columns.

Editing data • Can edit one cell at a time.
• Can copy and paste data from cell to cell, one cell at a time.
• Can reset manual changes.
• Can save data.
• Cannot undo.
• Cannot change the automatic recalculation setting.

Printing Can print the data that is currently displayed.

Exporting data Not available.

Notes • Can view notes.
• Cannot edit or create notes.
• Cannot alter note permissions.

Creating and redefining 
worksheets

Not available.

Running simulations Not available.

Feature Availability in Demantra Anywhere
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The Demantra Anywhere page looks like this:

The screen lists all public worksheets and all private worksheets that you own.

See also

“Introduction to Demantra Anywhere” on page 133

Opening a Worksheet in Demantra Anywhere

To open a worksheet

• Click the name of the worksheet. 

To run or rerun a worksheet

Depending on how Demantra Spectrum was configured, it may or may not 
automatically run the worksheet that you open.

• Within the worksheet, click Data > Rerun.
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Using Worksheets in Demantra Anywhere
Within Demantra Anywhere, you can access any public worksheet created in 
Demantra Spectrum, but the worksheets have a simplified appearance, like this:

To select a worksheet view

• Select the view from the Available Views dropdown list.

To select a different combination to display

• Select level members from the level dropdown lists (for example, Brand or Ship 
to).
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To edit worksheet data

1. Click an editable cell.

A small editing page appears.

2. Type in the new value and click OK.

To save data

• Click the Update Data button. 

To reset manual changes since the last time you saved data

• Click the Reset Manual Changes button.

To rerun the worksheet

• Click the Rerun Worksheet button. 

To print the currently displayed data

• Click the Print button. 
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To view a note

1. Click the note icon within the cell.

The Note page appears, displaying a list of all the notes. This list indicates the 
date of each note, as well as who entered it. The Combination field shows the 
item-location combinations to which the currently selected note belongs.

2. To see the note details, click Description.

3. To close the Note page, click the X in the upper right corner.
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A URLs and Shortcuts

Demantra Spectrum URLs

Keyboard Shortcuts

Editing

Item Example URL

Demand Planner Web,
Promotions Effectiveness, or Settlement 
Management (features depend on your 
license)

http://frodo/demantra/portal/partnerLogin.jsp

Dynamic Open Link (DOL) for access 
for third-party reporting tools

http://frodo/demantra/portal/
DOL_HTML.htm

Collaborator Workbench (requires an 
additional license)

http://frodo/demantra/portal/loginpage.jsp

Demantra Anywhere (if you have a license 
for Collaborator Workbench)

http://frodo/demantra/portal/
remoteloginpage.jsp

Demantra Anywhere (if you do not have a 
license for Collaborator Workbench)

http://frodo/demantra/portal/anywhereLogin.jsp

Offline access to Demantra Spectrum 
worksheets (added in 7.0)

http://frodo/demantra/portal/launchDPWeb.jnlp

Notes:
• Here frodo is an example server name. Substitute the name of the server that is running the 

Demantra Spectrum Web software.
• Also, demantra is an example virtual directory. Substitute the name of the virtual directory that is 

the root of the Demantra Spectrum Web software.

Ctrl+c Copy

Ctrl+v Paste

Ctrl+x Cut

Ctrl+z Undo

Ctrl+y Redo
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Menu Access

Display

Worksheets

Alt+f Open File menu

Alt+w Open the Worksheet menu

Alt+e Open Edit menu

Alt+v Open View menu

Alt+o Open Options menu

Alt+d Open Data menu

Alt+Shift+r Reset table sort

Ctrl+Alt+m Show or hide the Members Browser

Ctrl+Alt+r Show or hide the table

Ctrl+Alt+g Show or hide the graph

Ctrl+Alt+a Show or hide the Activity Browser and Gantt chart

Ctrl+Alt+t Show or hide the time axis

F5 Refresh data

Ctrl+s Save worksheet definition

Ctrl+n New worksheet

Ctrl+o Open worksheet

Ctrl+r Run worksheet

Ctrl+u Save data changes

Ctrl+p Print

Ctrl+e Export to Microsoft Excel

Alt+1 Open the general properties of the Worksheet Designer

Alt+2 Open the series part of Worksheet Designer

Alt+3 Open the time criteria part of the Worksheet Designer

Alt+4 Open the levels part of the Worksheet Designer

Alt+5 Open the filters part of the Worksheet Designer

Alt+6 Open the exceptions part of the Worksheet Designer

Alt+7 Open the layout part of the Worksheet Designer
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B Series Reference

The following table lists the series in Settlement Management, including series that 
are not shown in the Settlement Management worksheets by default:

Series name Purpose Applies to...
Used in 
worksheets...

Approved Non Trade Sum of amounts for approved non-trade 
settlements.

Non-trade settlements

Approved Trade Sum of amounts for approved trade 
settlements.

Trade settlements Settlement Details By 
Account, Settlement 
Account Summaries

Customer CHECK # Number of the check from the customer. Uses 
the customer’s check numbering system.

Deductions and off-
invoice settlements

Settlement Details By 
Account

Customer CHECK 
DATE

Date of the check from the customer. Deductions and off-
invoice settlements

Settlement Details By 
Account

Customer Invoice # Number of the invoice from the customer. Uses 
the customer’s invoice numbering system.

Claims Settlement Details By 
Account

Customer Invoice 
DATE

Date of the invoice from the customer. Claims Settlement Details By 
Account

G/L Code General ledger code that best explains why this 
settlement was denied or split.

All settlements Settlement Details By 
Account

Linked Promo ID ID of the promotion with which this settlement 
is linked.

All settlements

Matched Event Name of the promotion with which this 
settlement is linked.

All settlements Settlement Details By 
Account

Owner Settlement Management user who has claimed 
responsibility for this settlement.

All settlements Settlement Details By 
Account

Posted DATE Date on which this settlement entered the 
system.

All settlements Settlement Details By 
Account

Settlement # Unique identifier of this settlement. All settlements

Settlement Account ID Customer with which this settlement is 
associated.

All settlements Settlement Details By 
Account

SETTLEMENT 
STATUS

Current status of this settlement, within 
Settlement Management. One of the following:
• New
• In Progress
• Unapproved
• Approved
• Duplicate
• Denied
• Write Off

These are not customizable. You can also 
display the settlement status as a level.

All settlements Settlement Details By 
Account
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SETTLEMENT TYPE Settlement type, for use by Settlement 

Management. One of the following:
• Claim
• Off-invoice
• Deduction
• Non-Trade
• Claim resulting from an original claim split
• Deduction resulting from an original 

deduction split

These are not customizable. You can also 
display the settlement type as a level.

All settlements Settlement Details By 
Account

Supplier CHECK # Number of the check that reimburses the 
customer for this claim.

Claims Settlement Details By 
Account

Supplier CHECK 
DATE

Date of the check to the customer. Claims Settlement Details By 
Account

Supplier Invoice # Number of the invoice to the customer. Deductions and off-
invoice settlements

Settlement Details By 
Account

Supplier Invoice DATE Date of the invoice to the customer. Deductions and off-
invoice settlements

Settlement Details By 
Account

Total Outstanding Non 
Trade

Sum of amounts for unapproved and 
unresolved non-trade settlements.

Non-trade settlements

Total Outstanding 
Trade

Sum of amounts for unapproved and 
unresolved trade settlements.

Trade settlements Settlement Details By 
Account, Settlement 
Account Summaries

Unapproved Non Trade Sum of amounts for unapproved non-trade 
settlements.

Non-trade settlements

Unapproved Trade Sum of amounts for unapproved trade 
settlements.

Trade settlements Settlement Details By 
Account, Settlement 
Account Summaries

Unresolved Non Trade Sum of amounts for unresolved non-trade 
settlements.

Non-trade settlements

Unresolved Trade Sum of amounts for unresolved trade 
settlements.

Trade settlements Settlement Details By 
Account, Settlement 
Account Summaries

Series name Purpose Applies to...
Used in 
worksheets...
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4-4-5 calendar

A calendar that consists of financial quarters, in which each quarter consists of a 
“month” of exactly four weeks, followed by a “month” of exactly four weeks, 
followed by another “month” of exactly five weeks. In practice, 4-4-5 calendars 
vary slightly from company to company.

active combination
Item-location combination that is neither dead nor young; see prediction status.

advanced analytics
The process of specifying engine models and engine parameters for different 
combinations within the forecast tree, rather than using the global settings.

aggregation
The process of adding up or otherwise determining a useful summary of a set of 
related data. For example, you might add up the sales for all the products in a 
product group and arrive at an aggregated number for the entire product group. 
Aggregation does not always mean simple addition; you can aggregate data in 
other ways.

allocation
The general process of dividing a limited amount included in a data series on a 
product or location group level, to a product or location item level by using the 
proportions mix of group/items of a different data series.

To perform allocation, you use Allocation Management (within Demand 
Planner). 

A/P department
Accounts payable department, the department that receives bills and is 
responsible for paying them.

approved trade
In general, this refers to settlements that have been matched to promotions and 
that have approved by a user with sufficient authority. See also unapproved 
trade.

A/R department
Accounts receivable department, the department that sends bills as needed and 
receives all payments.
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attachment
A file, typically in JPEG or PDF format, that you include within a note, as 
supplemental information. You generally use attachments to provide proof of 
performance.

attribute
A descriptive property associated with the level (and stored internally in the 
table associated with the level). For example, a Ship To member might have the 
following attributes:

Apart from the Name attribute, the attributes shown in red are all parents of this 
member. They are shown in red because they are required. 

You use attributes in several different ways:

• To provide extra information to describe members of the level. You can view and 
edit this information.

• To provide a further subdivision of the level data. To do this, you add an attribute 
to a level and select an option to create it as a child level. For example, suppose 
you create an attribute called ABC. If ABC can have the values A, B, or C, and if 
you create this attribute as a level, then the ABC level would have three members: 
A, B, and C. The member A, for example, would consist of all the data that had 
the A value for this attribute, within the parent level.

• For the purpose of exporting or importing data.

• To describe promotions. Promotion attributes are converted into promotional 
causal factors. Applies only to Promotions Effectiveness.
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batch mode
A mode in which you can run the Analytical Engine. In this mode, the 
Analytical Engine uses the entire forecast tree. See also simulation mode.

base time buckets
The time buckets in which data is stored in Demantra Spectrum. Each base time 
bucket contains data corresponding to one base time unit. Users can view data 
aggregated into larger time buckets as well.

base time unit
The smallest possible time unit in your Demantra Spectrum implementation. 
The base time unit determines the time resolution of your system.

billback
Request for credit on invoice, due to a promotion.

broker
An outside party who negotiates promotional agreements between a 
manufacturer and the retailers. Applies to Settlement Management.

cannibalization
Reduced demand of an existing product caused by a new product introduction 
or by the increased demand of an existing product due to corporate strategies 
like promotions. Although cannibalization typically refers to negative effects 
only, sales interactions like switching of accounts, brands, products, or channel 
could be either positive or negative. Applies to Promotions Effectiveness.

causal factor
Additional information that can explain historical data so that you can improve 
forecast quality (for example: price, CPI, weather, and so on). Specifically, a 
causal factor is a time-varying quantity (such as a series) that affects demand. 
Demantra Spectrum provides the following general kinds of causal factors:

• A local causal factor depends on the time, location, and item being sold. For 
example, it can be a specific discount in a specific store.

• A global causal factor depends only on the time, for example, a holiday. See 
global factor.

• Promotional causal factors, which apply to different items, locations, and 
promotions. These causal factors are available only for Promotions Effectiveness. 

You configure causal factors in the Business Modeler. Demantra Spectrum uses 
this information to better understand the sales history and make more accurate 
predictions.

chaining
The general process of associating historical patterns of existing series with 
other series found in a new product or location, with the goal of predicting for 
the new product or location. To perform chaining, you use Chaining 
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Management (within Demand Planner). You copy data from selected sources to 
the target combinations.

chargeback
A request sent to the customer for payment, typically when a deduction is 
denied.

check request
A request that a CSD representative sends to the company’s A/P department.

claim
A kind of settlement, specifically a request from a customer for payment. In 
these cases, the customer has run the promotion and is requesting to be 
reimbursed, based on an agreement between you and the retailer. If you approve 
the claim, you request for your A/P department to send a check to this customer 
or to the broker, as applicable.

client expression
Calculates data at a given level, referring to other data at the same level. You use 
client expressions to calculate numbers that cannot be calculated by aggregation 
from lowest-level data. 

A client expression takes precedence over a server expression.

Normally, you use a server expression to retrieve data for the series at the lowest 
aggregation level. For higher aggregation levels, Demantra Spectrum 
automatically aggregates the results of the server expression. In cases where that 
aggregation is not suitable, you use a client expression that explicitly uses the 
data associated with the higher aggregation level.

combination
The combination of an item member (from any hierarchy level) and a location 
member (from any hierarchy level). Each of the following is a combination:

• Chocolate cookies (at all stores)

• Chocolate cookies at the Fair Haven store

• All cookies at Better Stores, Inc.

The word combination can also refer to the data associated with that 
combination, for example, all sales of chocolate cookies at the Fair Haven store. 

combination level
A level that contains time-independent data for combinations. Sometimes called 
matrix level.

combination series
More often called matrix series.

competitive item group (CI)
A set of items within an influence range (IR). Typically an influence range 
includes two CIs: “us” and “them.” For example, an influence range could 
consist of two CIs: one for Acme carbonated beverages (“us”) and one for 
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Brand X and Brand Y carbonated beverages (“them”). See also item group. 
Applies only to Promotions Effectiveness.

competitive location group (CL)
A set of locations within an influence range (IR). Each CL typically corresponds 
to a single competitive distribution channel. See also location group. Applies 
only to Promotions Effectiveness.

combination-selection list
Drop-down list at the top of a worksheet, equivalent to the Members Browser. A 
worksheet may have several of these, and you use them to specify which item-
location combination the worksheet should display.

component
A subdivision of the Demantra Spectrum data. Each component includes the 
following items:

• One or more series of data, organized into specific levels.

• Units of measure.

• Optional indexes and exchange rates.

• An owner, who can add additional users.

content pane, content
Pane within Collaborator Workbench that displays a graphical view of data 
associated with a worksheet, to provide you with current, at-a-glance 
information that meets your needs. You can display content in many formats 
such as the following:

• Members Browser, which is a collapsible tree hierarchy of data levels

• Tabular format

• Chart formats including line, bar, and pie charts

• Calendar format

crosstab
A worksheet that has been configured with levels on the x-axis and/or y-axis.

CSD representative
A member of the customer service department. The primary users of Settlement 
Management are CSD representatives.

dead combination
Combination for which sales are not recent enough to be used for prediction. 
See also prediction status.

deduction
A kind of settlement, specifically a short payment on an invoice. In these cases, 
the customer has run the promotion and has made a short payment on an 
invoice. By permitting this short payment, you are reimbursing the customer for 
running the promotion.
Demantra Settlement Management User’s Guide 147



Glossary

 
 

dimension
Perspective from which a large volume of complex and interrelated data can be 
viewed and analyzed. Each dimension organizes data in one or more hierarchies 
of levels, allowing you to view the data in different ways. Your Demantra 
Spectrum application can have any number of dimensions, which you define in 
the Business Modeler. See also level hierarchy.

engine profile
A set of engine parameters with specific values and a profile name. For use only 
with the Promotions Effectiveness engine.

exception
If you attach an exception to a worksheet, Demantra Spectrum checks the values 
of the worksheet data and displays only the combinations that meet the 
exception criteria.

Specifically, you define an exception condition that consists of a series, a comparison 
operator (such as equals or greater than), and a value, for example:

Sales > 150000

When you open the worksheet, Demantra Spectrum checks each combination in the 
worksheet. For each combination, if the condition is met for any time in the worksheet 
date range, Demantra Spectrum displays that combination. For example, the 
worksheet shows combinations that have Sales values greater than 150000, within the 
time range included in the worksheet.

If the condition is not met at any time for any of the worksheet combinations, 
Demantra Spectrum shows the worksheet as empty. That is, if all values in the Sales 
series are less than or equal to 15000, the worksheet comes up empty.

You can attach multiple exceptions to a worksheet. When you do so, you can relate 
them to each other via logical AND or logical OR relationships.

fictive
Placeholder. For example, when you first create a member using Member 
Management, that member is not yet associated with any sales data and is 
therefore a fictive member.

filtering
The process of limiting the scope of data. Demantra Spectrum provides two 
general types of filters, each of which allows only certain data to be displayed or 
otherwise used.

The more common filters are combination filters. For this type of filter, you 
specify the following:

• An aggregation level. You can filter data at any level in any dimension.

• Members of that aggregation level that are allowed through the filter; other 
members are not included.

The net result is that a filter allows Demantra Spectrum to display only certain item-
location combinations.
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In a few places, Demantra Spectrum provides a different type of filter, a value-specific 
filter that allows only data that contains certain values.

forecast
Predictions about future sales of items at various locations, as a function of 
time. The forecast is based upon the demand, which in turn is based upon the 
historical data. The length of time that the forecast spans is called the forecast 
horizon.

The Analytical Engine creates the forecast, either as the result of the batch 
forecast, or when a user runs and approves a simulation.

forecast model
Mathematical model used to predict forecast. Demantra Spectrum provides 
about a dozen forecast models that are in common industry use. To create its 
forecast, the Analytical Engine tests each model, sees how well it fits the 
historical data, and uses a weighted combination of the results from all the 
models.

forecast node
Node within the forecast tree.

forecast tree
A single hierarchy of forecast data, the forecast tree is made up of item-location 
combinations at different aggregate levels. Each node in this tree represents a 
time-based series that is subject to forecast. The forecast tree does not need to 
contain all possible combinations, only those that are relevant to the forecasting 
process.

general attribute
See attribute.

general level
An aggregation level that stores time-dependent data for a combination. For 
example, a promotion is generally associated with one or more items at one or 
more locations, and is associated with specific dates. Demantra Spectrum stores 
the data for this promotion as a general level.

global factor
A causal factor that depends only on the date of the sale. A global factor affects 
all items and locations in the system. For example, global oil prices have an 
impact on the sales of automobiles. The effect is widespread but changes with 
time. The effect occurs at all locations where the automobile is sold, and for all 
models being sold.

Another possible global factor is a holiday, if all locations in your solution 
follow the same holidays.
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group
Set of users who can work together via Collaborator Workbench. A user can 
belong to multiple groups.

Membership in a group also controls access to the Workflow Editor; see Demantra 
Spectrum Administrator’s Guide.

historical data
In general, this is the record of sales of different items at all locations, for 
months or years in the past. For each sale, you must know the location of the 
sale, the product code, price, and quantity. You also typically know information 
about causal factors (such as holidays and promotions) that may have affected 
the sales volume. Demantra Spectrum also uses information about returns, 
inventory levels, and orders.

index
A financial measure used to normalize prices over time. An example is the 
Consumer Price Index (CPI).

influence group (IG)
A set of item-location combinations in which all items belong to the same item 
group and all locations belong to the same location group. Within a given 
influence groups, the influence groups mutually interact. By identifying the 
influence groups, you determine the coarseness or generalization of causality. 
Applies only to Promotions Effectiveness.

influence range (IR)
Level within the forecast tree that controls how far the Analytical Engine looks 
for influence when a promotion is run. The influence ranges control how far the 
Analytical Engine looks for influence when a promotion is run. This determines 
the breadth of the causality. An influence range consists of multiple influence 
groups. Applies only to Promotions Effectiveness.

item
One of the dimensions by which you view data. Other typical dimensions are 
location and time. Each dimension consists of one or more hierarchies of data, 
allowing you to view data organized in different ways. For example, if you are 
forecasting demand for muffins, the item dimension could contain a product 
group hierarchy and a flavor hierarchy.

item group
A set of items within a competitive item group (CI). For example, within the 
Acme CI, the item group I1 might consist of orange-flavored soft drinks. 
Another item group, I2, might consist of colas. Applies only to Promotions 
Effectiveness.

level
An aggregation of data. For example, the Color level might consist of the sales 
data aggregated by the color of the items. Each level consists of members. The 
Color level would have one member for each color. 
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Levels allow you to view the data in different ways. Demantra Spectrum 
supports the following types of levels:

Item and location levels are the most common.

Levels are organized into hierarchies, and each level can have attributes.

level hierarchy
Each level can belong within any number of independent hierarchies, each of 
which represents a different way of aggregating data. For example, the SKUs 

Item levels organize data in ways that reflect product properties such as 
product family, color, style, and so on. Each member of an item level 
represents time-dependent data aggregated according to some attribute of the 
items being sold.

Location levels group and aggregate data according to characteristics of the 
locations where you sell. For example, location levels could describe 
geography or types of stores.

Combination (or matrix) levels group and aggregate data according to 
characteristics of the item-location combinations. These are less common than 
item and location levels.

Time levels group and aggregate data by sales date. Normally you use a time 
level in place of the time axis.

Promotion levels group and aggregate data by sales promotions. Depending on 
how your system is implemented, you may have a hierarchy of promotional 
levels (to organize the promotions), and the higher levels might use different 
icons.

Unlike other kinds of levels, promotion levels can be displayed within a Gantt 
chart. Promotion levels are available only with Promotions Effectiveness.

Settlement levels, which are used only by Settlement Management. In general, 
a settlement is an outstanding sum of money that needs to be resolved, related 
to a promotion. If you use a settlement level in a worksheet, you cannot use 
levels from any other hierarchy in that worksheet.

Check request levels, which are used only by Settlement Management. A 
check request is an instruction to send a check to a customer or designated 
third party. Check requests are exported to the accounting systems that actually 
perform them.
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could be organized into product families, which in turn could be organized into 
divisions as follows, as follows:

In this example, Division, Product Family, and SKU are all levels in Demantra 
Spectrum.

The SKUs could also be organized into brands as follows:

Note that this hierarchy is independent of the product family hierarchy. That is, there 
is not necessarily any relationship between brands and product families. Nor is there 
any relationship between brands and divisions.

Given these relationships, a member can have parents. For example, consider the SKU 
member Rainbow LF Chocolate Chip. This SKU might have the following parents:

• Regular (parent of this SKU within the product family level)

• Rainbow (parent of this SKU within the brand level)
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level series
A series that is associated with a specific level. Each data point in the series 
corresponds to a given member of that level. Data for this series is stored in the 
table associated with the level. 

live combination
Item-location combination that is neither dead nor young; see prediction status.

location
A dimension by which you view data. Other typical dimensions are item and 
time. Each dimension consists of one or more hierarchies of data. For example, 
the location dimension could be broken down into country and then into states 
and towns.

location group
A set of locations within a competitive location group (CL). Applies only to 
Promotions Effectiveness.

matrix level
See combination level.

matrix series
A series that consists of time-independent data for each item-location 
combination. This data is stored in mdp_matrix.

member
An element of a level. Each level contains one or more members. For example, 
at the city level, members may include Paris and London. 

Each member corresponds to a set of sales data. Each member has properties 
that apply to the sales data at that level, such as unit, description, and an 
identifying code.

There are several types of member

member management
The process of creating, editing, and deleting level members.

Real Member that was created by import and that has sales data. Most 
members are real.

New Member that was created by import but that does not yet have sales 
data. When sales data is loaded for this member, it will become real.

User-defined 
or fictive

Member that you have created via one of the following:

• Members Browser in a Web-based worksheet. 

• Member Management in Demand Planner and Demand 
Replenisher.

When this member is loaded via import, it will become new or real, 
depending on whether it has sales data. 
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Members Browser
A collapsible tree hierarchy of item and location levels. Within a Promotions 
Effectiveness worksheet, you use the Members Browser to specify which item-
location combination the worksheet should display.

method
An action that can be performed for a specific member within a worksheet. 
Methods appear as options within the right-click menu. A method is associated 
with a specific level and may be available only within a specific worksheet or 
within all worksheets.

model
Mathematical model that the Analytical Engine uses when creating a forecast.

note
A comment that you attach to data in a worksheet. A note is generally 
associated with specific items and locations, on one or more dates. A note can 
include an attachment.

off-invoice settlement
A kind of settlement that represents the case where the customer was billed a 
lower amount (that is, “off invoice”) for the products, as compensation for 
running the promotion.

outlier
An atypical observation, generally infrequent; a data point that does not appear 
to follow the characteristic distribution of the rest of the data. Outliers may 
reflect genuine properties of the underlying phenomenon (variable), or may be 
caused by measurement errors or other anomalies that should not be modeled.

Some of the Demantra Spectrum forecast models automatically identify and 
exclude outliers, and Demantra Spectrum indicates when that occurs. You can 
manually identify outliers as well.

POS data
Point-of-sale data.

prediction status
When generating forecasts, the engine considers the prediction status of each 
item-location combination. Prediction status is one of the following:

The Analytical Engine ignores any young or dead combinations.

Status Description

Young Sales for this combination are too new to be used for prediction.

Dead Sales for this combination are not recent enough to be used for prediction.

Live Neither young nor dead. Also called active.

Create Zero Forecast A user has specified this prediction status manually for this item-location 
combination, and this status means that this combination should have a 
forecast consisting of zero values. 
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program group
A collection of menu items, typically related to each other in some way. You 
create program groups so that you can easily control access to all the menu 
items in the group. Demantra Spectrum provides several predefined program 
groups, for convenience. 

proof of performance
Also known as POP. A document that shows that the retailer did run the 
promotion as required by agreement. POP is usually required before you can 
approve a settlement. You generally use an attachment to provide proof of 
performance.

promotion
A marketing event associated with specific items at specific locations during a 
specific time. You generally run promotions in order to increase demand. 

promotion series
A series that consists of data for each promotion at each item-location 
combination, at each time bucket.

promotional causal factor
A set of time-varying data associated with specific items at specific locations 
during a specific time. Applies only to Promotions Effectiveness.

proport
Mechanism that Demantra Spectrum uses for splitting aggregated data across 
the corresponding lowest-level members. Demantra Spectrum splits data on 
many occasions, including the following:

• When the Analytical Engine generates a forecast at an aggregated level

• When data is imported at an aggregated level

• When users edit aggregated data

• When users perform chaining at an aggregated level.

proportions
Split proportions used by the proport mechanism.

sales series
A series that consists of time-dependent data for each item-location 
combination. That is, each data point in the series corresponds to a given item-
location combination at a given point in time. This type of series is the most 
common type by far.

seasonality
If historical data has a regular pattern of observations above and below a trend, 
the data is said to be seasonal. Seasonality is generally observed in data 
compiled on a less than annual basis (for example, quarterly or monthly).
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series
Usually, a time-dependent set of data. For example, sales data and the forecast 
are both series. Although most series are time-dependent, Demantra Spectrum 
supports other types of special-purpose series: matrix series and level series.

A series can be defined by a server expression, a client expression, or both. In 
general, the definition of a series describes how data for that series should be 
calculated at any aggregation level. 

• Some series are calculated by aggregated data from the lowest level stored in the 
database. Data can be aggregated in various ways, for example by totalling it, or 
by taking the maximum or the minimum value. To see data changes in this kind of 
series, you must rerun the worksheet.

• Some series are calculated at the level of the worksheet, using data currently 
available at the worksheet level. Data changes are available immediately.

Also, when you edit data for a series, Demantra Spectrum calculates the values for the 
lowest level and writes that to the database. This means that worksheets run more 
quickly at lower levels than at higher levels.

server expression
The SQL expression that calculates the series data at any level by aggregating 
the associated lowest-level data. A very common server expression has the 
following form:

sum (table_name.update_column_name)

Here table_name.update_column_name is the table and column that stores data 
for this series. The server expression often includes the unit of measure in which 
results are expressed. 

A client expression takes precedence over a server expression. 

settlement
An agreement between a manufacturer and a retailer in which the retailer runs a 
specified promotion (to boost sales of a specific product or products) and the 
manufacturer agrees to compensate the retailer for this action. In some cases, 
this agreement is negotiated by a third party, namely, a broker.

See claim, deduction, and off-invoice settlement.

simulation
A ‘what if’ scenario in which a user may manipulate measure data (such as 
History) and examine the way in which the changes affect related measure data 
(such as Forecasts). 

simulation mode
A mode in which you can run the Analytical Engine. In this mode, you perform 
evaluate a scenario, to see what might happen in a given situation. In contrast to 
batch mode, you use only a small part of the forecast tree and a comparatively 
small set of data series.
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splitting
In general, splitting refers to the general process of dividing an aggregated 
amount into appropriate parts. See proport.

switching effect
Generic term for the effect that a sale for a given item-location combination can 
have on sales for another item-location combination. Applies only to 
Promotions Effectiveness.

task
A unit of work shown in the My Tasks module. A task generally consists of a 
request for a specific user or set of users to review a given worksheet; the task 
has a subject line, a description, and a message; it can include a Web link, as 
well as an attached file. Each task has a status and sometimes a timeout period. 
After you address the task, you should mark it as done so that the Workflow 
Engine can continue with the next steps in the workflow.

(The workflow can also send email to a task recipient, via the external email 
system, but that email has no direct effect on the workflow.) 

Depending on how Collaborator Workbench has been configured, users may 
also be able to create tasks and send them to other users.

time
A dimension by which you view data. Other typical dimensions are item and 
location.

time bucket
Depending on context, this phrase refers to any of the following:

• The base time buckets.

• A specific period of time corresponding to a time unit (the week of 1/3/05).

• The data associated with that period of time (the data associated with the week of 
1/3/05). If you consider a set of series as a spreadsheet, with time as the horizontal 
axis, then a time bucket is a vertical slice of the data.

• A time unit (a week).

time level
A level that aggregates data across time. Depending on your system, time levels 
are configured to enable you to analyze data by the specific month of the year, 
day of the week, and so on.

time resolution
In general, time resolution specifies the amount of visible detail for time-
dependent data. Specifically, it refers the time unit by which this data is 
grouped, for example, by months or weeks. See also time unit.
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time unit
A unit of time in Demantra Spectrum, such as day, week, month, and others, 
including the months of a 4-4-5 calendar.

The base time unit (or minimum time unit) is the smallest length of time that 
your data model represents. This can be either a day, a week, or a month, by 
default; smaller buckets are possible but require custom work. The size of the 
base time unit determines the maximum possible time resolution of your model. 

trend
The long-term behavior of data, over time. 

unapproved trade
In general, this refers to settlements that have been matched to promotions and 
that have not yet approved. See also approved trade.

unresolved trade
In general, this refers to settlements that are either new or in progress.

waterfall chart
A chart or table that displays both the current version and past versions of the 
same data.

workflow
An automated sequence of steps, some automatic and some that require user 
input. A typical workflow sends tasks to users (to appear in My Tasks module) 
in response to conditions within the demand chain process. 

worksheet
A set of data retrieved from the Demantra Spectrum database. In a worksheet, 
you specify information such as following:

• At least one series to retrieve from the database

• The levels of aggregation to view in the worksheet

• Optional filtering to set the scope of the worksheet

A worksheet can be public (shared with other Demantra Spectrum users) or 
private. Only the owner of a worksheet can edit it.

A worksheet is also known as a query.

x-axis
The horizontal axis of a worksheet graph and correspondingly, the vertical axis 
of a worksheet table.

y-axis
The vertical axis of a worksheet graph and correspondingly, the horizontal axis 
of a worksheet table.
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young combination
Item-location combination for which sales are too new to be used for prediction. 
See also prediction status.

zero history
Historical data consist of zero sales. You usually create zero history for 
combinations you create via Member Management, so that there are placeholder 
records that you can edit.
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