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 1 TPM and PMO 

Introductions
This chapter introduces the Trade Promotion Management (TPM) 
and Promotion Modeling and Optimization (PMO) applications.

Overview..........................................................................................3
Data Hierarchy ................................................................................4
Dashboard: Collaborator Workbench .............................................5
TPM Worksheets ..............................................................................5
PMO Worksheets .............................................................................6

Overview
Demantra’s Trade Promotion Management & Promotion Modeling & Optimization 
(PMO) applications are a powerful combination of a financial application to manage 
retailer trade funds coupled with a comprehensive promotion analysis tool specifically 
targeted at manufacturers for the purpose of better planning trade funds usage. The 
application considers sales, point of sale (POS), and syndicated data to provide 
advanced pre and post promotion analysis:

• Historical event evaluation, including detailed analysis of lift components, taking 
into account both direct and indirect effects

• Base volume forecast by item over time based on past history

• Incremental volume forecast based on user-defined promotional variables and 
causals (i.e. product, time, price, vehicle, buydown, etc.) 

• Detailed fund analysis, including quota versus actuals

• Event optimization taking into consideration a variety of constraints (time, 
budget, spend, # of events, etc.)

While Demantra’s application provides standard, out-of-the-box configuration to 
achieve this, it also recognizes that every manufacturer manages accounts and trade 
promotions a bit differently. Demantra’s applications are highly configurable, 
allowing Demantra consultants and trained users to tailor them to the customer’s 
needs, both today and as these needs evolve in the future.



Chapter 1: TPM and PMO Introductions

4 Demantra TPMO User Guide

 
 

Data Hierarchy
The TPM and PMO applications assume that the products and locations are organized 
into certain hierarchies, each of which you can navigate within the applications. 
Depending on how your application was configured, you may use other terminology 
for these hierarchies. (For more information on how Demantra Spectrum uses 
hierarchies, see Chapter 3, “TPMO Concepts” on page 17.)

Product Hierarchies
The TPM and PMO applications assume that the products are organized into the 
following hierarchies:

• One hierarchy organizes products into categories, which consist of segments, 
which consist of brands, which consist of SKUs.

• Another hierarchy organizes products into promotion groups, groups of products 
that are promoted together. Each promotion group consists of a set of SKUs.

• Another hierarchy (less often used) organizes products into product lines, which 
consist of product families, which consist of product groups, which consists of 
SKUs.

Location Hierarchies
The TPM and PMO applications assume that the locations are organized into the 
following hierarchies:

• One hierarchy consists of bill-to locations, which consist of specific ship-to 
locations. 

• One hierarchy consists of retailers, which consist of specific ship-to locations. 

• One hierarchy consists of companies, which consists of divisions, which consist 
of sales areas, which consist of regions. In turn, regions consist of districts, which 
consist of territories. 

The lowest location level is a combination of ship-to and territory.
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Dashboard: Collaborator Workbench
Demantra’s Collaborator Workbench is the starting point for Demantra’s TPM and 
PMO applications. You log into the application and immediately have access to a 
number of key performance indicators (KPIs), displayed inside content panes. TPMO 
provides several out-of-the-box content panes, and you can add others. 

From Collaborator Workbench, you can launch worksheets and review tasks. 

Each worksheet is a working environment designed to support specific business 
processes. You can open worksheets from within Collaborator Workbench, the 
Worksheet Viewer, or worksheets that are currently open.

TPM Worksheets
TPM includes the following worksheets:

• Planning Environment—the entry point to both historical and planned event 
analysis. Event planning consists of creating and managing a calendar of 
promotional events, and understanding their impact on sales, promotion 
spending, and profitability, as well as their correlation with sales quotas. The 
Planning Environment provides all this critical information in one place. 

• TPM: Quota and Fund Entry—allows headquarters to manage funds, 
including fund rates and fixed funds as well as sales quotas.

• TPM: Quota and Fund View—a read-only version of the TPM: Quota and 
Fund Entry worksheet. It allows you to view authorized funds against your sales 
quota.

• Volume Tracking—central location where product, territory, and account 
volumes are forecasted and monitored to ultimately feed volume requirements to 
operations. Fund planning already covered is integrated with volume planning, 
because forecast volumes drive budgets in live accrual environments and drive 
spending for case rate allowances and other variable spending deals.

Collaborator Workbench Worksheet Viewer

Planning 
Environment

TPM: Quota and 
Fund Entry

other 
worksheets

My Tasks

My Worksheets

Volume 
Brkdwn

Actuals vs. 
Plan other 

content 
panes
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PMO Worksheets
PMO includes the following worksheets:

• Planning Environment (as above)

• PMO: Optimization Comparison—provides the capability to simultaneously 
view and compare the results of a promotion before and after running 
optimization. After comparing, you can accept, reject, or reoptimize the 
promotion. Once satisfied with the results, you can add them to their current plan 
simply by changing the status to Planned.

• PMO: Promotion Comparison—helps you compare and evaluate multiple 
promotions, so that you can determine how best to spend trade dollars.

• PMO: Promotion Evaluation—provides a detailed post-promotional analysis 
of each individual promotion. (i.e. compare forecast to actual performance). Here, 
you can view the breakdown of each event with respect to the sales dollars and 
profit generated for the manufacturer.

• PMO: Promotion Evaluation - Detail—provides further detail about the 
impact of the promotion. It shows the lift decomposition in much more detail, 
showing the actual cannibalization for the promoted item as well as the impact it 
had on other items within a user’s franchise. 

• PMO: Scenario Evaluation—provides an overview of historical promotions 
by territory, retailer, category and promotion group, allowing for a detailed 
analysis of how all events within a category performed to plan.
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 2 Logging On and 

Getting Started
This chapter provides a quick introduction. It includes the following 
sections:

Initial Logon and Download............................................................7
Logging Onto Demantra Spectrum..................................................9
Tutorial: Getting Acquainted with Worksheets................................9
User Access....................................................................................13
Logging Off Demantra Spectrum ..................................................14
Ending a Hung Session..................................................................14
Changing Your Password ..............................................................15

Initial Logon and Download
The first time you log onto Demantra Spectrum, Demantra Spectrum typically 
downloads and installs software. This operation is quick and occurs only once for each 
machine you use.

1. Open Microsoft Internet Explorer.

2. Enter the web address supplied by your system administrator. This URL probably 
has the following format:

http://server name/virtual directory/portal/partnerLogin.jsp

For example:

http://frodo/demantra/portal/partnerLogin.jsp

3. Type your name and password and click Login.

Demantra Spectrum prompts you to install JRE.

Tip Your Windows Start menu may also include a shortcut to this URL.
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4. When you are prompted to install Sun JRE 1.4.2_10, do so. Choose the Typical 
installation and accept all the default values, unless otherwise advised by your 
system administrators. 

Next, Demantra Spectrum displays a dialog box that asks if you want to trust the 
signed application distributed by Demantra. The dialog box is slightly different 
depending on your configuration.

5. Click Yes (or Always) or Start, depending on which dialog box is displayed.

After the initial configuration is completed, Demantra Spectrum displays a new 
browser window. The page contains a menu bar, a toolbar, and a workspace that is 
initially empty.

6. Click File > Open.

7. Click a worksheet in the list and then click Open.

Now the work area displays a worksheet, and the menu bar and toolbar have many 
more options. 

See also

“Viewing Data” on page 25

Note Demantra Spectrum uses Sun JRE 1.4.2_10. If you are prompted to install 
a later version of JRE, do not do so.

To prevent Java from searching for updates, open the Java control panel. 
On the Update tab, make sure to deselect the check box Check for 
Updates Automatically.

create new 
worksheet

open existing 
worksheet

work area
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Logging Onto Demantra Spectrum
If you have already performed the initial setup (see “Initial Logon and Download” on 
page 7), then log on as follows.

To log onto Demantra Spectrum

1. Open Microsoft Internet Explorer.

2. Enter the web address supplied by your system administrator. This URL probably 
has the following format:

http://server name/virtual directory/portal/partnerLogin.jsp

For example:

http://frodo/demantra/portal/partnerLogin.jsp

3. Type your name and password and click Login.

Tutorial: Getting Acquainted with Worksheets
To view and edit data, you work within an environment called a worksheet. Each 
worksheet is a working environment designed to support specific business processes. 
The worksheets in your solution are unique and are not documented here specifically. 
However, all worksheets share certain common characteristics and behavior. This 
exercise is meant to help you get acquainted with any worksheet.

1. Click File > Open. Or click the Open button.

2. Click a worksheet in the list and then click Open.

Demantra Spectrum now displays the worksheet.

3. Scan the worksheet and identify each element of it, using “Elements of a 
Worksheet” on page 10 as a guide.

4. Then select the data to display:

• If the worksheet uses a Members Browser, click the magnifying glasses to 
expand the hierarchy and then click the leaf node that you want to view.

• If the worksheet has selection lists, select from the left list first, then the next 
list to its right, and so on.

The rest of the worksheet now shows data relevant to this selection. Notice that 
the focus has changed to the current selection in each tab or tile of the worksheet.

Some areas of the worksheet might be at a lower level than your selection. For 
example, you may have selected a Brand, while a graph shows sales for a given 
SKU. Because you have not yet selected a SKU, that graph arbitrarily chose a 
SKU within that brand.

Tip Your Windows Start menu may also include a shortcut to this URL.
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5. If the worksheet includes any table in crosstab format, click a row or column that 
corresponds to the elements that are shown in that breakout. 

For example, if a worksheet tables shows SKUs as rows in the table, choose a 
SKU by selecting a row.

The rest of the worksheet now shows data for this specific selection. This 
includes any embedded worksheets as well as any other subtabs, if the subtabs are 
synchronized; see “Controlling Subtab Synchronization” on page 13. 

6. Still within a worksheet table, use the keyboard to move from element to element. 
Notice that in this case, the subtabs are not automatically refreshed, for 
performance reasons; this is true even if the subtab synchronization is on. 

Elements of a Worksheet
Any worksheet contains some or all of the following possible elements:

Selector

Most worksheets contain an area that you use to select the data to display. This area 
has one of the following forms:

• Members Browser:

• Selection lists:
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Tables

A worksheet table displays data for the current selection. The following shows an 
example:

Some tables display a breakdown by item, location, or other organizational level. The 
following shows an example:

In this example, each SKU in the worksheet is shown side-by-side with the others, 
inside the table. This table is in crosstab format. Many other variations are possible. 
For example, the SKUs could be shown across the top of the table instead.

Graphs

A worksheet graph displays data for the current selection. By default, the horizontal 
axis shows time, and the vertical axis shows one or more series. 

Note In order to include the graph, you must have a license for either Demand 
Planner Web or Promotions Effectiveness.
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Activity Details Subtab

The Activity Details subtab displays promotions and the promotion hierarchy 
related to the current selection.

If this is included in your worksheet, it may appear in the lower right. If your 
worksheet contains multiple tiles, however, it can appear anywhere on the screen.

This subtab is available only if you have a license to Promotions Effectiveness.

Notes/Attachments Subtab

The Notes/Attachments subtab displays notes and attachments related to the 
current selection:

If this is included in your worksheet, it may appear in the lower right. If your 
worksheet contains multiple tiles, however, it can appear anywhere on the screen.
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Embedded Worksheets (Subtab Worksheets)

A worksheet can included embedded worksheets, which can include any of the 
elements listed here. These may appear in the lower right. If your worksheet contains 
multiple tiles, however, these embedded worksheets can appear anywhere on the 
screen. Each embedded worksheet is displayed within a subtab, as follows:

Controlling Subtab Synchronization
The subtabs of a worksheet may or may not be synchronized with the rest of the 
worksheet. A worksheet runs faster if synchronization is off. On the other hand, if you 
are creating or modifying promotions, you might find it less confusing to keep 
synchronization switched on so that you can immediately see your changes.

To control the synchronization, do one of the following:

• Click one of the following toggle buttons in the toolbar.

• Select Options > Synchronize On Demand or Synchronize 
Automatically.

User Access
Depending on the implementation and on your access, you might not see the same 
data as other users of the system. Your access can be different from that of another 
user in many ways:

• The data you see might be filtered. For example, if you are an account manager, 
you might not be able to see accounts that are not yours.

• You might not see the same aggregation levels. And you should be able to see 
only those units of measure that make sense for the levels you see.

• You can see a given promotion only if you have permission to see all item-
location combinations with which the promotion is associated.

• You might not see the same series.

• You could belong to different collaboration groups. See the Collaborator 
Workbench User’s Guide.

Automatically synchronize the subtabs with the rest of 
worksheet

Synchronize on demand
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• You might not have access to all menus listed in the documentation.

• You might have additional menu items, created by your implementors. These 
menu items would be on the right-click menu.

• You can use only worksheets that are public or that you defined. Only the owner 
of a worksheet can change its definition.

You should also be aware that an individual worksheet might have additional filters 
applied to it. You can see those filters at any time.

Logging Off Demantra Spectrum

To exit Demantra Spectrum

• Close the browser window. 

Any other open browsers are not affected.

Ending a Hung Session
If your session hangs due to network or other problems, you will not be able to log in 
again until the session times out. Alternatively, Demantra Spectrum provides a tool 
that you can use to end that session.

If your permission level is lower than System Manager, your own session is the 
only session you can see.

To end a hung session

1. Browse to the following case-sensitive URL:

http://server name/virtual directory/portal/userManagement.jsp

For example:

http://frodo/demantra/portal/userManagement.jsp

A login page appears.

2. Type your username and password and then click Log on.

Demantra Spectrum displays the following screen:
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3. Click Logout in the row corresponding to your user ID.

Changing Your Password
Any user can log into the Business Modeler and change his or her own password. If 
your permission level is lower than System Manager, your password is the only 
information you can access.

To change your password

1. Log into the Business Modeler. If you do not have access to this, contact your 
Demantra Spectrum system administrator.

2. Click Security > Change Password. Or click the Change Password button.

The Business Modeler displays the Change Password screen:

3. Type your current password in the Old Password field.

4. Type your new password in the New and Confirm New fields.

5. Click OK.
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 3 TPMO Concepts

This chapter introduces key concepts in the Demantra Spectrum 
platform and in TPMO.

Getting Acquainted with Worksheets .............................................17
Levels (Segmentation)....................................................................19
Combinations.................................................................................20
Series (Measures) ..........................................................................21
Content Panes................................................................................23

Getting Acquainted with Worksheets
To view and edit data, you work within an environment called a worksheet. Each 
worksheet is a working environment designed to support specific business processes. 
However, all worksheets share certain common characteristics and behavior. This 
exercise is meant to help you get acquainted with any worksheet.

1. Click File > Open. Or click the Open button.

2. Click a worksheet in the list and then click Open.

Demantra Spectrum now displays the worksheet.

3. Scan the worksheet and identify each element of it, using “Elements of a 
Worksheet” on page 18 as a guide. Make sure that you know what each of the 
following elements looks like:

• Members Browser

• Selection lists

• Table

• Graph

• Embedded worksheets (subtab worksheets)

4. Then select the data to display:

• If the worksheet uses a Members Browser, click the magnifying glasses to 
expand the hierarchy and then click the leaf node that you want to view.

• If the worksheet has selection lists, select from the left list first, then the next 
list to its right, and so on.

The rest of the worksheet now shows data relevant to this selection. Notice that 
the focus has changed to the current selection in each tab or tile of the worksheet.

Some areas of the worksheet might be at a lower level than your selection. For 
example, you may have selected a Brand, while a graph shows sales for a given 
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SKU. Because you have not yet selected a SKU, that graph arbitrarily chose a 
SKU within that brand.

5. If the worksheet includes any table in crosstab format, click a row or column that 
corresponds to the elements that are shown in that breakout. 

For example, if a worksheet tables shows SKUs as rows in the table, choose a 
SKU by selecting a row.

The rest of the worksheet now shows data for this specific selection. This 
includes any embedded worksheets as well as any other subtabs, if the subtabs are 
synchronized; see “Controlling Subtab Synchronization” on page 19. 

6. Still within a worksheet table, use the keyboard to move from element to element. 
Notice that in this case, the subtabs are not automatically refreshed, for 
performance reasons; this is true even if the subtab synchronization is on. 

Elements of a Worksheet
Any worksheet contains some or all of the following possible elements:

Selector

Most worksheets contain an area that you use to select the data to display. This area 
usually the following form:

Tables

A worksheet table displays data for the current selection, for example:

In this example, the promotions are shown side-by-side within the table. This table is 
said to be in crosstab format. 

Graphs

A worksheet graph displays data for the current selection. By default, the horizontal 
axis shows time, and the vertical axis shows one or more series. 

Note In order to view the graph, you must have a license for either Demand Planner 
Web or Promotions Effectiveness.
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Embedded Worksheets (Subtab Worksheets)

A worksheet can included embedded worksheets, each of which is displayed within a 
subtab, as follows:

Controlling Subtab Synchronization
The embedded worksheets of a worksheet may or may not be synchronized with the 
rest of the worksheet. A worksheet runs faster if synchronization is off. On the other 
hand, if you are creating or modifying promotions, you might find it less confusing to 
keep synchronization switched on so that you can immediately see your changes.

To control the synchronization, do one of the following:

• Click one of the following toggle buttons in the toolbar.

• Select Options > Synchronize On Demand or Synchronize 
Automatically.

Levels (Segmentation)
A level lets you aggregate or group data in a worksheet. Demantra Spectrum uses 
icons to indicate the type of level:

TPMO includes a flexible set of levels and Demantra consultants can redefine them or 
add others.

Automatically synchronize the subtabs with the rest of 
worksheet

Synchronize on demand

Item levels group and aggregate data according to characteristics of the items 
you sell. For example, TPMO item levels include brand and category.

Location levels group and aggregate data according to the locations where they 
are sold. For example, TPMO location levels include retailer, territory, and so 
on.

Promotion levels group and aggregate data by promotions. 
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Members
In generic terminology, the word member refers to a unit within a level. For example, 
Albertsons is a member of the retailer level.

Level Attributes
A level can have attributes. For example, a Ship To member might have the following 
attributes:

Apart from the Name attribute, the attributes shown in red are all parents of this 
member. They are shown in red because they are required. 

The other attributes (such as Unit Cost) do not represent levels in the system but 
contain information used for reporting and other purposes. 

Combinations
The combination is a central concept in Demantra Spectrum; it is a specific location 
combined with a specific item. Combinations represent real things being sold at real 
places. It is important to understand that Demantra Spectrum contains only the 
combinations that have data. For example, an account might consist of 100 stores, and 
a brand might consist of 100 items. This implies 10,000 possible combinations. 
However, Demantra Spectrum contains information only for those combinations that 
actually have sales data (or that have been manually created by users, for forecasting 
purposes).
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Series (Measures)
Each worksheet or content pane shows series data associated with the members that 
you have currently selected. These series were created by your implementors, for your 
organization’s needs. A worksheet displays the series data in a table, or in a graph, or 
both; a content pane displays either a table or a graph. The following shows an 
example of a worksheet table:

The example here shows series at the lowest level, but you can view data for any given 
series at any aggregation level. 

As you can see from this example, there are many possible variations of series:

• Some series are editable (see Stat Frcst), some are editable only for specific 
dates (see Pseudo), and some are not editable at all. Generally, editable series 
are used as input to other series.

• Some series are shown in different colors, depending on the data values. For 
example, Sales Fcst Bias is displayed in red for any values less than zero.

• Some series are calculated from other series.

• Some are generated by the Analytical Engine, if that is relevant in your Demantra 
Spectrum solution.

• Most series have time-varying values for each combination, but there are other 
kinds of series as well (discussed below). For example, the series Stat Frcst 
specifies whether a combination should be used in forecasting or not. As you can 
see, this series has the same value for all time buckets for a given combination.

• Most series have numeric values, but some have string or date values. For some 
series, you choose a value from a dropdown list.
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Kinds of Series
Demantra Spectrum supports the following kinds of series:

• Sales series contain time-dependent set of data for item-location combinations. 
That is, each data point in the series corresponds to a given item-location 
combination at a given point in time. This type of series is the most common type 
by far.

• Combination series (also called matrix series) store time-independent data for 
each item-location combination. That is, each data point in the series corresponds 
to a given item-location combination. You use combination series to store and 
maintain information about item-location combinations, mainly flags for the 
Analytical Engine to use. 

• Promotion series store time-dependent data associated with each promotion, at 
each item-location combination.

• Level series store data associated with a specific level. Each data point in the 
series corresponds to a given member of that level. 

Series and Summary Rows
Each series has been configured to be summarized in a specific way, which you can 
see in the summary row of the table. The table has at least one summary row; 
depending on the layout, it may also include subtotal rows. The following shows an 
example:

As you can see, Demantra Spectrum provides different summarizing options. In this 
example:

• Price and Discount are summarized by averaging.
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• Revenue is summarized by adding all the values.

• The Approved series is summarized by counting the number of approvals.

More complex options are also available. A given series can be summarized in 
different ways within a single table. Consult your implementors for details on how 
your series are summarized.

Content Panes
You work primarily within the Worksheet Viewer, but you can display read-only, 
summarized data within Collaborator Workbench as well. To do so, you use content 
panes. A content pane displays a graphical view of data associated with a worksheet, 
to provide you with current, at-a-glance information that meets your needs. 

A content pane has many of the same features as a worksheet.
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 4 Working with Data

This chapter describes the basics of working with Demantra 
Spectrum data: how to edit data, add notes and attachments, print, 
exchange data with outside tools, and so on. It includes the 
following sections:

Viewing Data .................................................................................25
Editing Data ..................................................................................26
Saving and Viewing Changes ........................................................27
Sorting Worksheet Data.................................................................28
Copying and Pasting Data ............................................................29
Copying and Pasting to and from Microsoft Excel........................29
Exporting Data to Microsoft Excel................................................30
Linking Data into Third-Party Reporting Tools (via DOL)...........31
Printing..........................................................................................34
Viewing Notes ................................................................................34
Editing Notes .................................................................................36
Viewing and Managing Attachments to Notes ...............................37
Specifying Note Permissions .........................................................38
Refreshing the Local Worksheet Cache .........................................39
Viewing the Audit Trail ..................................................................39

Viewing Data
To view and edit data, you work within an environment called a worksheet, especially 
within the worksheet table. Each worksheet shows specific data, organized in a 
specific way.

To view your data

1. Click File > Open. Or click the Open button.

2. Click a worksheet in the list and then click Open.

Depending on how Demantra Spectrum was configured, it may or may not 
automatically run the worksheet that you open.

3. If the worksheet does not show data immediately, click Data > Rerun. Or click 
the Run button.
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To load all data

When you first run a worksheet, Demantra Spectrum does not load all the data. 
Instead, it loads data for the first item-location combination in the worksheet. When 
you switch to another combination, Demantra Spectrum loads data for that 
combination. Demantra Spectrum does this so that you can see some data without 
having to wait for all the combinations to be loaded. In some cases, you may want to 
load all the combinations immediately; do this only if you are sure it will not slow 
your system down.

To load all the data, click the green arrow in the toolbar.

If the toolbar does not display this arrow, that means all the data has already been 
loaded.

Editing Data
You can usually edit data in a worksheet, although not all series are editable. Note that 
within a given worksheet, if some of the tabs or windows show data at a higher 
aggregation level, the data is not editable in those tabs or windows.

To change a data value manually

1. Select an editable data cell (white).

The cell appears contained in a box.

2. Edit the value as needed.

To update multiple cells

1. In the table, select a range of cells.

2. Right-click the selection and then select Edit Cells.

The Edit Cells dialog box appears.

3. In the dialog box, type a new value and then click OK.

To undo

Do one of the following:

• Click Edit > Undo.

• Click Data > Reset Manual Changes. This option restores the worksheet data 
to the state in which you last saved it.

Note Within Demantra Spectrum, do not use the following special characters:

Single quote (')
Double quote (")
Ampersand (&)

If you use these characters, unexpected results may occur.
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To redo an action

• Click Edit > Redo. 

See also

“Copying and Pasting Data” on page 29
“Saving and Viewing Changes” on page 27

Saving and Viewing Changes
Apart from minor adjustments to the worksheet layout, the changes you make are not 
saved automatically.

Saving Changes
You save changes to data separately from changes to the worksheet definition:

• To save changes that you have made to the data in the worksheet, including 
changes to notes, click Data > Save Data. Or click the Save Data button.

• To save changes that you have made to the worksheet definition, click File > 
Save Worksheet. Or click the Save Worksheet button.

• If you own the worksheet, this option saves the basic worksheet definition and 
its initial layout..

• If you do not own the worksheet, this option saves only your own layout of the 
worksheet.

See “Worksheet Definition, Layout, and Local Adjustments” on page 49.

Controlling the Recalc Option
Usually at least some of the read-only series are computed by means of a local 
expression. By default, Demantra Spectrum recalculates all local series expressions 
automatically. In some cases, you may want to switch off this automatic recalculation:

To switch the Recalc option off 

• Click Data > Set Data Recalc Off. Or click the Recalc Off button.

To force calculation while Recalc is off

• Click Data > Calculate.

To switch the Recalc option on

• Click Data > Set Data Recalc On. Or click the Recalc On button.



Chapter 4: Working with Data

28 Demantra TPMO User Guide

 
 

Viewing Pending Changes to Data

To see pending data changes

1. Click Data > Update to save your data changes.

2. Click Data > Process Monitor. Demantra Spectrum displays a screen that 
shows all data saves that are waiting to be processed:

If you are working at a relatively high level, this takes longer to run.

Sorting Worksheet Data
By default, the worksheet table is sorted in ascending order, according to the current 
contents of the x-axis, which is usually time. You can sort the worksheet table in either 
ascending or descending order, according to any series that is displayed in the table.

To sort the worksheet table

• Double-click the header of the column by which you want to sort the worksheet. 

Demantra Spectrum then sorts the entire worksheet table, putting entries in this 
column in descending order. A downward arrow is added to the column header, to 
indicate that the table is sorted by this column.
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To resort in ascending order, double-click the column header again. Demantra 
Spectrum resorts the table and changes the direction of the arrow.

To restore the default sorting order of the worksheet table

• Click View > Reset Table Sort.

Copying and Pasting Data
You can copy and paste data within the worksheet table.

To copy data

1. Within a worksheet, do one of the following:

• In the table, select a cell whose value you want to copy.

• To copy values from more than one cell, click the first cell, and then drag the 
mouse to select all cells you want to include.

2. Right-click and then select Copy. Or click Edit > Copy.

To paste data

1. Do one of the following:

• In the table, select the cell into which you want to paste the data.

• To paste values into more than one cell, select the upper left data cell of the 
block of cells into which you want to paste.

2. Right-click and then select Paste. Or click Edit > Paste.

See also

“Saving and Viewing Changes” on page 27

Copying and Pasting to and from Microsoft Excel
You can copy and paste data from a worksheet to Excel and vice versa.

To copy and paste data to Excel

1. Within a worksheet, copy data as described in “Copying and Pasting Data” on 
page 29.

2. Start Microsoft Excel, open a worksheet, and select a cell or block of cells.

3. Right-click and then select Paste.

Note From a worksheet, you can also paste data to different Windows products.
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To copy and paste data from Excel

1. Start Microsoft Excel and open a worksheet.

2. Select one or more cells.

3. Right-click and then select Copy.

4. In Demantra Spectrum, select the cell or cells into which you want to paste the 
data.

5. Right-click and then select Paste. Or click Edit > Paste.

See also

“Exporting Data to Microsoft Excel” on page 30
“Linking Data into Third-Party Reporting Tools (via DOL)” on page 31

Exporting Data to Microsoft Excel
You can export worksheet data to Excel. Your computer’s regional settings can affect 
the results; see the note.

To export data to Excel

1. Within a worksheet, click File > Export. Or click the Export to Microsoft 
Excel button.

An export dialog box appears.

2. Select Current Combination to export data currently displayed, or Entire 
Worksheet to export all data from the worksheet.

3. Click OK.

A Save page appears.

4. Define the location where the worksheet data will be saved and enter a name for 
the file.

5. Click Save.

Note

When receiving data from an external source, Microsoft Excel uses the Regional 
Options in the Windows Control Panel to determine whether a given cell should be 
formatted as Currency or General (as is or text). This means that if you export 
Demantra Spectrum data that is formatted with a currency symbol, and if the 
Windows Control Panel uses a different currency symbol, those cells will appear in 
Excel as text values.
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If you export to Excel and you receive text values where you wanted currency values, 
do the following:

1. Open the Windows Control Panel.

2. Double-click Regional and Language Options.

3. On the Regional Options tab, make sure that the Currency setting uses the 
same currency symbol as Demantra Spectrum.

4. Export again from Demantra Spectrum.

Later versions of Excel provide an option for converting problematic cells that it 
recognizes. 

See also

“Copying and Pasting to and from Microsoft Excel” on page 29
“Linking Data into Third-Party Reporting Tools (via DOL)” on page 31

Linking Data into Third-Party Reporting Tools 
(via DOL)

When you work within a third-party reporting tool, you can import a Demantra 
Spectrum worksheet via Demantra’s Dynamic Open Link (DOL) technology. This 
technology lets you use any reporting tool that can connect to the Demantra Spectrum 
database (which is either Oracle or SQL Server).

Demantra Spectrum provides a web page (http://server name/virtual directory/
portal/DOL_HTML.htm) to which you can link from your reporting tool, such as 
Microsoft Excel). Then to access the latest Demantra Spectrum data, you can use the 
refresh functionality within that reporting tool.

The following steps describe how to link Demantra Spectrum data into Excel, as an 
example.

To create a worksheet report in Excel

1. In Microsoft Excel, open the Data menu.

2. Click Get External Data and select New Web Query.
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The New Web Query screen appears.

3. Click Browse Web..., which displays a browser.

4. In the address bar, type the following URL and then click Go:

http://server name/virtual directory/portal/DOL_HTML.htm

For example:

http://frodo/demantra/portal/DOL_HTML.htm

A login page appears.

5. Type your Demantra Spectrum user name and password and click Login.

The browser now displays the following list of worksheets:
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6. Select a worksheet from the dropdown list and click Confirm.

The worksheet opens in your browser in non-editable HTML format. 

7. Optionally close the browser window.

8. Return to Excel, which is still displaying the same dialog box as before.

9. For step 2, select The entire page.

10. For step 3, select Full HTML formatting.

11. Click OK.

Excel asks where to put the data.

12. Make your choice and click OK.

The Demantra Spectrum worksheet opens in Excel.

See also

“Copying and Pasting to and from Microsoft Excel” on page 29
“Exporting Data to Microsoft Excel” on page 30

Tip To save the query for repeat use, click Save Query...
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Printing

To print the displayed data

1. Click File > Print. Or click the Print button on the toolbar.

The Print Settings dialog box appears.

2. Select the required options.

3. If this worksheet includes a Gantt chart, optionally click the Gantt Settings tab. 
On this tab, specify which promotion attributes to include in the print-out.

4. Click OK.

5. Demantra Spectrum displays the normal system print dialog box, where you 
choose the printer to use, the number of copies to make, and so on.

6. Make selections as you would normally do.

7. Click OK.

Viewing Notes
You can add notes to record comments and reminders. You attach the note to 
combination and date or dates. The worksheet table displays indicator symbols on 
those dates, generally in only some of the columns (depending on how your system is 
configured). The following shows an example of the indicator:

The graph displays an indicator as well:

Content selection Specify whether to print the currently selected item-
location combination, all combinations in the 
worksheet, or the screen.

Layout Choose portrait or landscape orientation.

Paper Choose a paper size.

Font Choose a font size.

Object selection If this worksheet includes a Gantt chart (which 
requires a license for Promotions Effectiveness), this 
option lets you specify whether to include the Gantt 
chart in the printout.
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You can see notes in two different areas:

• In the Notes dialog box.

• In the Notes/Attachments subtab, if this is included in your worksheet. This 
subtab also displays any associated attachments.

To open the Notes page

Do one of the following:

• In the table, right-click a cell and select Notes... The note will be associated with 
only this row.

• In the table, select one or more rows, right-click and then select Notes.... The 
note will be associated with each of the selected rows.

• In the table, double-click the left (non-scrolling) column. (Depending on how 
Demantra Spectrum is configured, this action may not bring up the Notes page.)

• In the graph, hold the mouse button over a point, right-click and then select 
Notes...
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See also

“Editing Notes” on page 36
“Viewing and Managing Attachments to Notes” on page 37
“Specifying Note Permissions” on page 38

Editing Notes
First display the Notes page or the Notes/Attachments subtab; see “Viewing 
Notes” on page 34. In the upper part of the worksheet, click the element to which you 
want to attach this note.

To add a note

1. If the Note box is gray (uneditable), click the Add button.

2. Type a note in the Note box.

3. If you are working in the Notes/Attachments subtab, you can optionally 
upload an attachment (see “Viewing and Managing Attachments to Notes” on 
page 37).

4. Click the Save button.

To edit a note

1. Select a note and click the Edit button.

2. Type a note in the Note box.

3. If you are working in the Notes/Attachments subtab, you can optionally 
upload an attachment (see “Viewing and Managing Attachments to Notes” on 
page 37).

4. Click the Save button.

To delete a note

1. Select a note and click the Delete button.

The Confirm Delete message box appears.

2. Select one of the following:

• Partial Deletion (deletes the note only from the current member and date)

• Total Deletion (deletes the note from all members and dates)

3. Click OK.

4. Click Save.

See also

“Viewing Notes” on page 34
“Specifying Note Permissions” on page 38
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Viewing and Managing Attachments to Notes
You can attach files to the notes, and Demantra Spectrum uploads those files into the 
database (in compressed form). To view and manage attachments, you work in the 
Notes/Attachments subtab of your worksheet.

To add an attachment to a note

1. Click the note.

2. Click Details.

Demantra Spectrum displays the Note Details screen:

3. Click Add.

4. Find the file that you want to attach and then click Open.

Demantra Spectrum uploads a compressed version of the file into the database.

5. Click OK.

To remove an attachment from a note

1. Click the note.

2. Click Details.

Demantra Spectrum displays the Note Details screen:

3. Click the row that lists the attachment and then click Remove.

4. Click OK.
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To download an attachment

1. Click the note.

2. Click Details.

Demantra Spectrum displays the Note Details screen:

3. Click the row that lists the attachment and then click Download.

4. Specify the directory and filename for the downloaded file and then click Save.

5. Click OK.

See also

“Viewing Notes” on page 34

Specifying Note Permissions
In general, notes (and their optional attachments) can be viewed by other users. You 
can specify permissions for the notes, to determine who can read the note and what 
type of access they are permitted. You can specify permissions for groups or for 
specific users.

To specify permissions for a note and its attachments

1. On the Details tab, select the note.

2. Click the Permissions tab.

3. Select the User Permissions or Group Permissions tab.

4. For each user or group that should have non-default settings for this note, move 
that user or group from the left list to the right list (Selected Users or 
Selected Groups).

5. Remove any unwanted users or groups from the right list.

6. Then for each user or group in the right list, do the following:

a. Click the user or group.

b. Select a setting from the Permission dropdown list at the bottom of the page. 
The following options are available:

Note Read-only is the default setting for non-selected users or groups.

Read and 
Write

Enables the user or group to read the notes list, edit notes, 
and add notes.

Read Only Enables the user or group to read the notes list.

Not Visible Makes the note list not visible to this user or group.

Full Control Enables the user or group to read the notes list, edit notes, 
add notes, and delete notes.
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7. Click Save.

8. Click Close.

Group and user permission priorities

• User permissions take precedence over permissions of any groups the user 
belongs to.

• If a user belongs to more than one group, the highest level of permissions from 
the associated groups will be granted.

See also

“Viewing Notes” on page 34

Refreshing the Local Worksheet Cache
Depending on the definition of a worksheet, Demantra Spectrum may store a local 
copy of the worksheet data on your machine, for faster performance. Also depending 
on the worksheet definition, the cache may be refreshed automatically or may require 
periodic refreshing by you.

To refresh your local worksheet cache

• Click Data > Refresh worksheet data cache.

See also

“Saving and Viewing Changes” on page 27

Viewing the Audit Trail
Demantra Spectrum automatically records changes in an audit trail. The audit trail 
includes changes due to user edits within worksheets, updates created by the Business 
Logic Engine, copy/paste actions, and changes caused by import.

Demantra Spectrum provides two ways to view the audit trail:

• You can view the changes that have occurred to the item-location combination 
that is currently displayed in the worksheet.

• You can create and then execute a profile that specifies a wider set of data: 
multiple combinations, a wider span of time, and so on.

Note You can see only changes that were made by you or other users who are in the 
same collaboration groups as you.
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In either case, the audit trail looks like this:

The top part of the page lists the changes. When you select a row in this table, the 
bottom part of the page lists details corresponding to that row.

• The Series Values tab displays details on the series that were changed.

• The Aggregate Level Population tab displays the specific aggregation levels 
to which this change applies. The change could have occurred at a different 
aggregation level.

• The Filtered Population tab displays the filtering that was used at the time of 
this change.

Viewing the Audit Trail for a Specific Combination

To view the audit trail for a combination 

1. In a given worksheet, select a combination.

2. Click Data > Audit Trail.

If any changes have occurred to this combination, the Audit Trail screen 
appears, displaying a table with one row for each recorded change. The following 
information is displayed:

Audit Date Date when change was made.

User Name User who made the change
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3. To see specific details on this change, click a change in this table and then click 
the Series Values tab.

This tab displays the following information:

4. To see the specific aggregation levels to which this change applies, click the 
Aggregate Level Population tab. The change could have occurred at a 
different aggregation level.

5. To see the filtering that was used at the time of this change, click the Filtered 
Population tab.

Viewing the Audit Trail for Other Data
An audit trail profile enables you to select a specific portion of the audit trail so that 
you can view changes that affect more than one combination.

To create or modify an audit trail profile

1. Click File > Audit Trail.

2. Then:

• To create a new profile, click New.

• To modify a profile, click an audit trail profile name and click Modify.

The wizard displays a properties screen.

3. In the Name and Description fields, type a name and optional description.

4. If you want to share this audit trail profile with others, click Public.

5. Click Next.

The wizard prompts you for information about the changes you want to see.

6. For Source Type, click the check box for each type of change you want to see. 
Here, BLE represents the Business Logic Engine.

Update Mode Indicates the type of change: Manual, BLE (Business 
Logic Engine) or Integration

Unit Name Unit of measure that was used at the time of the change

Index Name Index that was used at the time of the change

Series List Series affected by the change

Status In Progress, Fail, or Success

Series Name Name of the series that was changed.

Series Value New value used in this series.

Original Value Original value in this series.

From Date First date in the series when the change occurs.

To Date Last date in the series when the change occurs.
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7. For each user whose changes you want to see, move the name from Available 
Users to Selected Users.

8. Click Next.

The wizard prompts you for the range of time you are interested in.

9. For Time Filter, select Relative or Fixed, depending on whether you want to 
define a window of time relative to today.

10. For From Date and To Date, specify a range of dates.

11. Click Next.

The wizard prompts you to specify the aggregation levels you are interested in.

12. For each aggregation level that you are interested in, move that level from 
Available Filter Levels to Selected Filter Levels.

13. Click Next.

The wizard prompts you to specify the series you are interested in.

14. For each series that you are interested in, move that series from Available 
Series to Selected Series.

15. Click OK.

16. Click Close to exit the wizard.

To use an audit trail profile

1. Click File > Audit Trail.

2. Click an audit trail profile.

3. Click Execute.

Demantra Spectrum displays the specified part of the audit trail. See “Viewing the 
Audit Trail for a Specific Combination” on page 40.

To delete an audit trail profile

1. Click File > Audit Trail.

2. Click an audit trail profile.

3. Click Delete.

4. Click Yes.
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 5 Managing the Screen

This chapter describes how to manage the Demantra Spectrum 
screen in general. It includes the following sections:

Managing Multiple Worksheets .....................................................43
Managing Worksheet Views ...........................................................45
Managing View Elements ..............................................................46
Managing Empty Rows..................................................................47
Worksheet, Layout, and Data.........................................................48
Worksheet Definition, Layout, and Local Adjustments..................49

Managing Multiple Worksheets
Within Demantra Spectrum, you can open multiple worksheets and display them in 
tab mode or window mode. In window mode, you can resize, position, minimize, 
maximize, and tile each window as in other software.

To specify how to display worksheets

Do one of the following:

• Select Options > Tabs View/Windows View.

• Click the Tabs/Windows toggle button.

A worksheet contains views, and these views can be displayed as windows or tabs 
within the worksheet itself. The Tabs/Windows setting discussed here has no effect 
on the views.

display worksheets as windows

display worksheets as tabs
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To view a worksheet that has already been opened

• In windows view, select the worksheet from the Windows menu.

• In tabs view, click the tab corresponding to the worksheet.

To close a worksheet

Do one of the following:

• In windows view, click close (X) in the top right corner of the worksheet window.

• In tabs view, click the close symbol (X) on the tab.

See also

“Managing Worksheet Views” on page 45
“Managing View Elements” on page 46
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Managing Worksheet Views
A worksheet can include multiple views, which are displayed as tabs or as windows 
within the worksheet window itself.

Each view can have a different set of series and a different layout. Within any given 
worksheet, you can display the views as tabs or as child windows that you can resize 
and reposition.

Depending on the worksheet definition, the views may or may not be synchronized 
with each other. If they are synchronized, when you edit in one view, that change 
automatically appears in the other views.

To manage worksheet views

Within any given worksheet, you can display the worksheet views as tabs or as child 
windows that you can resize and reposition.

• To change how views are shown within the current worksheet, click Options > 
Tabs Multiview or Options > MDI Multiview, whichever option is displayed. 
Or click the corresponding toggle button on the toolbar.

• If you are currently displaying views as tabs, you can view one tab at a time. 
Click the tab of the view you want to view.

• When you are displaying views as subwindows, you can resize, reposition, 
maximize, and minimize each of these subwindows. Also, the Options menu 
provides options for tiling and cascading the subwindows.

See also

“Managing Multiple Worksheets” on page 43
“Managing View Elements” on page 46

Note In a given worksheet, if some of the views show data at a higher aggregation 
level, the data is not editable in those views.

display views as child windows

display views as tabs
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Managing View Elements

To hide or redisplay elements of a worksheet view

You can hide elements of a worksheet. To do so, use the Options menu. For example, 
to hide the graph, click View > Show/Hide Graph.

Each of these menu items acts as a toggle. To redisplay what you have hidden, click 
the same menu item again.

To resize an area in a worksheet view

• Drag a divider to the required position.

To expand or contract an area in a worksheet view

• There are two snap buttons in the upper left of each worksheet area, one with an 
up arrow and one with a down arrow. Click the snap button pointing in the 
required direction.

To resize a data column

• Click the vertical divider between two column headers, and drag it horizontally to 
the required position.

See also

“Managing Multiple Worksheets” on page 43
“Managing Worksheet Views” on page 45

Note This menu includes an option to hide the time axis. You typically use this 
option only if the worksheet also contains time levels. In such a case, it is 
desirable to hide the time axis, because it is redundant and takes up space on 
the screen.
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Managing Empty Rows

To hide or display empty rows in the worksheet table

• Click View > Hide Empty Rows. This option is a toggle. If you click it again, 
you redisplay the empty rows.

Examples

In some cases, some of the rows of a worksheet table might not contain data, for 
example:

Note that the status bar at the bottom of worksheet indicates that empty rows are 
currently being displayed.

When you hide empty rows, the result is as follows:

Note This option does not affect the worksheet graph.
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Worksheet, Layout, and Data
As you work within Demantra Spectrum, it is important to remember that worksheets 
are different from the data in them. For example, the definition of a worksheet 
specifies which series to display and how to aggregate those series for that worksheet. 
But the worksheet definition does not specify the values that the series contain. 

Accordingly, the worksheets and their layouts are saved separately from changes to 
the data. 

• To save changes that you have made to the data in the worksheet, including 
changes to notes, click Data > Save Data. Or click the Save Data button.

• To save changes that you have made to the worksheet definition or to the local 
layout, click File > Save Worksheet. Or click the Save Worksheet button.

• If you own the worksheet, this option saves the basic worksheet definition and 
its initial layout. This affects any users of this worksheet who have not yet 
saved their own layout for it.

• If you do not own the worksheet, this option saves only your own layout of the 
worksheet. This has no effect on any other users.

See also

“Worksheet Definition, Layout, and Local Adjustments” on page 49
“Saving and Viewing Changes” on page 27
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Worksheet Definition, Layout, and Local Adjustments
As you work with a Demantra Spectrum worksheet, you often sort columns, hide or 
display features, and make various other changes. It is useful to understand how these 
settings are saved.

The autorun option (Options menu) is saved separately for each user, but applies to all 
worksheets that the user sees.

Base Demantra Spectrum 
configuration

These settings affect all users and all 
worksheets.

• Display format for each series
• Initial display width of series and levels
• Colors and graph style for each series
• Other display colors (generally dependent on a 

condition)

Worksheet definition

These settings are saved via the File 
> Save Worksheet menu option. 
Only the worksheet owner can make 
these changes.

• Initial number of views within the worksheet and 
their initial names

• Initial elements (Members Browser, table, graph, 
and so on) in worksheet view

• View synchronization setting
• Aggregation levels used in worksheet and initial 

level layout; advanced selection options
• Series used in worksheet and initial series layout
• Time aggregation; time span; time formatting
• Filtering and exception filtering
• Unit of measure used in worksheet; overall scale 

used in worksheet, if any; index or exchange rate, if 
any

Layout changes

These settings are saved separately 
for each user if the user clicks File > 
Save Worksheet. Any user can 
save these changes, not just the 
worksheet owner.

• Additional views in the worksheet
• New names of worksheet views
• Level layout: order of levels; placement on axes in 

each view; whether level is hidden in each view
• Series layout: order of series; where each series is 

displayed (table, graph, both)
• Hide/show time axis

Local adjustments 

These settings are saved 
automatically separately for each 
worksheet and each user. 

• Use of windows or tabs for views within a 
worksheet

• Size and position of the Members Browser, table, 
graph, and so on in each view

• Sorting in the worksheet table
• Graph type; legend; grid lines
• Hide/show empty rows setting
• Activity synchronization setting (Options menu)

Not saved • Changes to column widths in the worksheet table
• Initial view focus; focus in each worksheet view
• Expansion state in the Members Browser and 

Activity Browser
• Focus and scroll in all areas
• Zoom setting in Gantt
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 6 Demantra Dashboard

This chapter introduces the Demantra dashboard: Collaborator 
Workbench.

Introduction to the Dashboard ......................................................53
Reviewing Metrics .........................................................................55
Reviewing the Planning Hierarchy................................................56
Opening Worksheets ......................................................................57
Managing Tasks .............................................................................57
Creating and Sending a Task .........................................................58
Personalizing the Dashboard ........................................................59

Introduction to the Dashboard
Demantra’s Collaborator Workbench is the starting point for Demantra’s Promotion 
Modeling & Optimization application. This dashboard is designed for use by sales 
managers. You log into the application and immediately have access to a number of 
key performance indicators (KPIs). You can also jump directly to TPMO worksheets, 
which are working environments that support specific business processes; these are 
described in the following chapters.

To log into the dashboard

1. In Windows, click Start and click Programs.

2. Click Demantra > Demantra Spectrum release > Collaborator 
Workbench.

3. In the Log On dialog box, enter your user name and password.Click Login.

4. If the toolbar includes a link labeled Click here to install Java Web Start, 
click that link.

Next Demantra Spectrum prompts you to install JRE.

5. When you are prompted to install JRE, do so. Choose the Typical installation 
and accept all the default values, unless otherwise advised by your system 
administrators.
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After you install this software, Collaborator Workbench comes up, displaying 
your personal page. Initially, this page looks like this:

At this point, Demantra Spectrum might display a dialog box that asks if you 
want to trust the signed application distributed by Demantra.

6. Click Yes (or Always) or Start.

Note In some cases, you do not see this dialog box until you click a worksheet 
name.
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Reviewing Metrics
Collaborator Workbench displays summary panes that display critical information and 
which you can customize to your needs. Initially, it displays the following summary 
panes.

Actuals versus Plan
This summary pane is a graph that shows cumulative actual volume and planned 
volume, as follows:

Sales versus Quota
This summary pane shows current sales compared to the sales quota, as follows:
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Volume Breakdown
This summary pane displays a table that shows the breakdown of volume into base 
volume and incremental volume, as follows:

Reviewing the Planning Hierarchy
The Planning Hierarchy is an expandable, treelike view that you can use to 
navigate the planning hierarchy:

Expand the hierarchy as needed.

You can right-click for more options:
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Opening Worksheets
My Worksheets lists critical worksheets. Each worksheet is a working environment 
designed for specific TPM and PMO business processes. Here, you can do the 
following:

• Click a worksheet to open it. 

• Send a worksheet as a task to another user; see “Creating and Sending a Task” on 
page 58.

To open a worksheet

1. Click a worksheet listed in My Worksheets.

At this point, Demantra Spectrum might display a dialog box that asks if you 
want to trust the signed application distributed by Demantra.

2. Click Yes (or Always) or Start.

See also

“Configuring My Worksheets” on page 61

Managing Tasks
My Tasks lists all tasks that are assigned to you and that you have not yet addressed. 
For example, if you are a manager, you will receive promotions that require approval.

To view all assigned tasks

If you have many open tasks, the My Tasks module does not necessarily display all 
of them. To check for additional tasks:

• Click the More link in the bottom right corner of My Tasks.

My Tasks fills the wide pane and shows all current tasks.

To mark a task as done

Before you mark a task as done, make sure that you have reviewed all the relevant 
information and that you have addressed any concerns or issues. Then do the 
following:

1. First:

• Select the appropriate response from the dropdown list in the Select value 
column. The check box next to the task is automatically checked.

Note If a due date is shown in red text, that means the response period has nearly 
ended and the task is going to time out fairly soon.
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• If there is no dropdown list, just click the check box to the left of the task.

2. Click the Save & Refresh link at the bottom of the task list.

The task is removed from My Tasks and the updated task list is shown.

Creating and Sending a Task

To create and send a task

1. Start by doing one of the following:

• Within My Worksheets, click Send on the worksheet that you want to 
send.

• Within My Tasks, click Create Task.

The Send Task to User dialog box appears.

2. Click To..... and select the users and/or groups to receive the task.

3. In the Message field, type a short text message.

This will be the task message that the recipient sees. The worksheet that you are 
sending will be added automatically as a link from the Message text.

4. In the Description field, type a short description.

This description will be displayed below the task message in the recipient’s My 
Tasks module.

Caution If you go to another page or log off without clicking Save & Refresh, 
then your changes will be lost.
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5. To link the task subject line to a Web page, enter the full path to the file in URL 
field.

6. To attach a file to the task, enter the path to the file in the File Attachment field 
or use the Browse button to find it.

7. To ensure that this task is completed by a specific time, click Escalate and then 
provide the following information:

8. To send an email notification to the recipient of the task, select the Send email 
list check box. (Depending on how your system has been configured, this option 
may not be available.)

9. Click either Send Worksheet or Send Selected Combination to specify 
whether to filter the worksheet. If you click Send Selected Combination, the 
worksheet is filtered to the combination that you are currently viewing; 
otherwise, the entire worksheet is sent.

10. Click Send Task.

When the recipient next logs in (or refreshes My Tasks), he or she will see the new 
task.

Personalizing the Dashboard
You can personalize Collaborator Workbench in several different ways.

Configuring Your Default Layout
The Collaborator Workbench page includes a wide pane and a narrow pane, and each 
pane has a possible set of modules that it can display. You choose the modules and 
their display order, top to bottom.

Note You must enter the full URL, including server name and directory 
hierarchy. The http:// part will be added automatically if omitted.

Due Date Date and time by which this task must be completed

Alert Time Date and time at which an alert will be displayed

To Additional email addresses
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To personalize your default layout

1. Click the Personalize link.

The Personalize - Modules page appears. This page contains two lists: one for 
items that can be displayed in the wide pane and one for items that can be 
displayed in the narrow pane. 

These lists include the following:

• My Tasks and My Worksheets, which can be displayed only in the wide 
pane.

• Who’s Online, which can be displayed only in the narrow pane.

• Worksheets that have been defined as content and to which you have access.

2. In each list, use the check boxes to select or deselect the modules that you want to 
see.

3. Click Next.

The Personalize - Order page appears. Like the previous page, this page has 
one list for the wide pane and one for the narrow pane.

4. Select a module and then click the up or down buttons to change its position in the 
list.

The order here is the order in which these modules are shown in Collaborator 
Workbench. 

5. Click Next.
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The next page summarizes your choices. You can return to the previous pages to 
make further alterations.

6. Click Finish to save your changes. Or click Back to go back to the previous 
pages.

Configuring My Tasks

To configure My Tasks

1. If Collaborator Workbench is not currently displaying My Tasks, then display it 
as described in “Configuring Your Default Layout” on page 59.

2. In My Tasks module, click the personalize button in the upper right corner of the 
pane.

Collaborator Workbench displays a page like the following:

3. In the Number of Tasks to View field, type the maximum number of tasks that 
you want to see in My Tasks.

4. From the Order Tasks by list, select the field that you want to list the tasks 
by.

5. From the Sort dropdown menu, select the sorting order that you want for the 
tasks. Task fields can be listed in either ascending or descending order. 

6. Click Finish.

My Collaborator Workbench refreshes with My Tasks in the new configuration.

Configuring My Worksheets

To configure My Worksheets

1. If Collaborator Workbench is not currently displaying My Worksheets, then 
display it as described in “Configuring Your Default Layout” on page 59.

2. In My Worksheets module, click the personalize button in the upper right 
corner.
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Collaborator Workbench displays a list of all available worksheets. This includes 
all worksheets you own and all public worksheets.

3. Click the check box next to each worksheet that you want to display.

4. Click Next.

Collaborator Workbench displays a new page where you specify how many 
worksheets to display as well as the display order for the worksheets.

5. In the Number of Worksheets to View field, type the maximum number of 
worksheets that you want to see in My Worksheets.

6. In the Order list, click a worksheet and then click the up or down arrows to 
specify the display order of that worksheet. Repeat as necessary.

7. Click Finish to save your changes. Or click Back to go back to the previous 
pages.
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 7 TPM: Managing and 

Viewing Quotas and 
Funds
This chapter describes how to manage or view quotas and funds in 
Demantra Spectrum, as part of the TPM business process. It 
includes the following sections:

About Quotas and Funds ...............................................................63
Managing Quotas and Funds ........................................................63
Viewing Quotas and Funds............................................................65
Reference .......................................................................................66

About Quotas and Funds
Demantra Spectrum displays a standard set of promotion funds, broken out as follows:

• Brand Development Funds (BDF): Base rate, development rate, and fixed funds

• Market Development Funds (MDF): Base rate, development rate, and fixed funds

• Slotting funds

Typically, you view these funds at the same time that you view the sales quotas that 
they are intended to support.

Quotas can be assigned at any level, including down to the SKU level if you want to 
manage at the lowest level of detail.

Managing Quotas and Funds
If you are an administrative user or senior manager, you can set values for quotas and 
funds. You use the TPM: Quota and Fund Entry worksheet, which provides the 
following information:

• Entry point for fund details including base rate, development rate and fixed funds 
for Brand Development Funds (BDF) and Market Development Funds (MDF)

• Summarized total authorized funds for BDF, MDF and slotting, as well as the 
overall total

• For comparative purposes, total forecast and sales quota

• At-a-glance graphical summaries of authorized funds by promotion group

• At-a-glance graphical summary of quotas by promotion group
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To manage quotas and funds

1. In My Worksheets (in Collaborator Workbench), click TPM: Quota and 
Fund Entry.

Or in the Worksheet Viewer, click File > Open. Click TPM: Quota and Fund 
Entry and then click Open.

2. If the worksheet does not show data immediately, click Data > Rerun. Or click 
the Run button.

3. At the top of the screen, select the territory and then the retailer to display.

The table shows all the quotas and funds for each brand, broken down by 
promotion group. For each promotion group, the quotas and funds are displayed 
in weekly buckets. 

As a quick visual aid, when you click a row, the graphs in the rest of the 
worksheet show data for that brand and promotion group.

4. Edit the quota and fund values as needed. 

5. Click Data > Save Data. Or click the Save Data button.
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See also

“Working with Data” on page 25

Viewing Quotas and Funds
If you are a sales representative, you can view authorized funds against your sales 
quota. You use the TPM: Quota and Fund View worksheet, which is a read-only 
version of the TPM: Quota and Fund Entry worksheet. 

To view quotas and funds

1. Click File > Open. Or click the Open button.

2. Click TPM: Quota and Fund View and then click Open.

3. If the worksheet does not show data immediately, click Data > Rerun. Or click 
the Run button.

4. At the top of the screen, select the territory and then the retailer to display.

The table shows all the quotas and funds for each brand, broken down by 
promotion group. For each promotion group, the quotas and funds are displayed 
in weekly buckets. 

As a quick visual aid, when you click a row, the graphs in the rest of the 
worksheet show data for that brand and promotion group.
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Reference

TPM: Quota and Fund Entry

Hierarchy

This worksheet uses the following hierarchy levels:

Business Data

TPM: Quota and Fund View

Hierarchy

Same as the TPM: Quota and Fund Entry worksheet; see “TPM: Quota and 
Fund Entry” on page 66.

Business Data

Same as the TPM: Quota and Fund Entry worksheet; see “TPM: Quota and 
Fund Entry” on page 66.

Levels you can select: Territory, Retailer

Levels used in cross tabulation: Brand, Promotion Group

View Series Purpose

Entry Data BDF Auth Authorized Brand development funds displayed to the user in the 
field

BDF Base Rate Brand development fund base rate -- entered by the corporate 
HQ 

BDF Dev Rate Brand Development Fund Development rate, entered by 
corporate HQ

BDF Fixed Funds BDF Fixed funds -- not dependent on volume, allocated by Corp 
HQ 

MDF  Auth Authorized Market development funds displayed to the user in 
the field

MDF Base Rate Base rate -- entered by the corporate HQ 

MDF Dev Rate Development rate, entered by corporate HQ

MDF Fixed Funds Fixed funds -- not dependent on volume, allocated by Corp HQ 

Sales Quota This series is used by Corporate HQ to enter quota. 

Slot  Auth Slotting budget authorized for the field user

Ttl Fcst The total of the base and incremental values calculated by the 
Demantra engine

Ttl Fund Auth Sum of authorized MDF, BDF and slotting fund 

Sales Quota Sales Quota This series is used by Corporate HQ to enter quota. 
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 8 TPM: Tracking 

Volume
This chapter describes how track sales volume, as part of the TPM 
business process. It includes the following sections.

Tracking Volume ............................................................................67
Reference .......................................................................................69

Tracking Volume
The Volume Tracking report is where product, territory, and account volumes are 
forecast and monitored to ultimately feed volume requirements to operations. Fund 
planning already covered will be integrated with volume planning, because forecast 
volumes drive budgets in live accrual environments and drive spending for case rate 
allowances and other variable spending deals. 

To open the Volume Tracking report

1. In My Worksheets (in Collaborator Workbench), click Volume Tracking.

Or in the Worksheet Viewer, click File > Open. Click Volume Tracking and 
then click Open.

2. If the worksheet does not show data immediately, click Data > Rerun. Or click 
the Run button.
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The screen now displays the following areas:

3. At the top of the screen, select the territory, retailer, category, and then promotion 
group whose volume you want to see.

The Volume Tracking report compares last year’s sales to this year’s plan. On a 
weekly basis, it tracks the following:

• Last year’s shipments

• This year’s shipments

• The current year’s base volume projection

• The current year’s incremental volume projection

• Cumulative % versus your plan

The information here can be updated weekly to give you an up-to-date tally of how 
you are performing versus your plan. Numbers are highlighted in different colors to 
give you a quick and easy way to keep abreast of your performance:

• Green is above plan

• Orange is slightly below plan (95-99.99%)
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• Red is more than 5% below plan

In addition, you see a weekly graphical representation of your current 52 weeks base 
and incremental sales, actuals and projections as well as a week-by-week look at your 
total volume. 

Reference

Volume Tracking

Hierarchy

This worksheet uses the following hierarchy levels:

Business Data

Levels you can select: Territory, Retailer, Category, Promotion Group

Levels used in cross tabulation: None

View Series Purpose

Base and 
Incremental

Base Fcst The base forecast as calculated by the Demantra engine

Incr Fcst The incremental forecast as calculated by the Demantra 
engine.

Forecast vs. 
Actuals

ActualLY Demand for this period one year ago

Actuals Ttl The total actual quantity (base plus incr).

Base Fcst The base forecast as calculated by the Demantra engine

Cumulative % vs Plan Cumulative actuals to date versus forecast cumulative to date.

Cumulative Actuals The total actuals (base plus lift) cumulative to date.

Cumulative Plan The cumulative frozen plan.

Incr Fcst The incremental forecast as calculated by the Demantra 
engine.

Plan Vol Planned volume

Shipments The shipment history from the mfg company to the ship to of 
the retailer.

Ttl Fcst The total of the base and incremental values calculated by the 
Demantra engine
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 9 PMO: Planning 

Promotions
This chapter describes how to create, evaluate, and plan 
promotions, as part of the PMO business process. It includes the 
following sections:

Overview of the Promotion Life Cycle...........................................71
Introduction to the Planning Environment .................................72
Creating a Promotion ....................................................................73
Modifying a Promotion..................................................................75
Reassociating a Promotion with a Different Item or Location......75
Copying and Pasting a Promotion ................................................77
Deleting a Promotion ....................................................................77
Comparing Promotions in a Scenario ...........................................78
Reference .......................................................................................80

Overview of the Promotion Life Cycle
When you first create a promotion, its status is initialized as Unplanned. Unplanned 
promotions are considered hypothetical and do not have an impact on the promotion 
funds or on the forecast.

Once you are ready to use the event in forecasting, you change its status event to 
Planned. This causes several things to happen:

• The cost of the promotion is deducted from the available balance of funds.

• When the Analytical Engine runs next, its forecast includes the proposed 
promotion. The forecast will show both the baseline and incremental volume for 
the proposed promotion. In addition, the system will calculate measures to be 
used for the cost benefit review. These include profit for the manufacturer and 
retailer, available fund balances as well as the proposed cost for the promotion.

Next, either you or your supervisor should approve the promotion by changing its 
status to Approved.

When you have a firm agreement that the retailer will run this event, you change its 
status event to Committed. This has the following effect:

• Overnight, a batch process makes a snapshot of every promotion whose status 
was changed to Committed.

• The committed promotions are included in all projections.
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After the promotion is run and the retailer has been paid, you can change the 
promotion status to Paid and then later to Closed, as appropriate.

Introduction to the Planning Environment
You plan and manage promotions in the Planning Environment, which is the entry 
point to both historical and planned event analysis. Event planning consists of creating 
and managing a calendar of promotional events, and understanding their impact on 
sales, promotion spending, and profitability, as well as their correlation with sales 
quotas. Demantra’s Planning Environment provides all this critical information in 
one place. 

To open the Planning Environment

1. In My Worksheets (in Collaborator Workbench), click Planning 
Environment.

Or in the Worksheet Viewer, click File > Open. Click Planning Environment 
and then click Open.



Creating a Promotion

Demantra TPMO User Guide 73

 
 

2. If the worksheet does not show data immediately, click Data > Rerun. Or click 
the Run button.

3. At the top of the screen, select the territory, retailer, category, and promotion 
group.

The screen now displays the following information for the selection:

• Sales % vs. Quota—Analysis of planned sales to sales quota, including % of 
quota attained and average retail price. This allows you to view your current 
sales versus both budget and forecast.

• Fund Balances—Detailed overview of authorized funds (MDF, BDF, slotting), 
spend and fund balances to date

• Event Planner—Details of all events, including start and end ship dates, 
vehicle type, vehicle cost, buydown, base volume and incremental volume. 
Incremental volume is generated by Demantra’s comprehensive analytical 
engine

• Sales KPIs—Sales Breakdown by Event (includes base and incremental 
volume), Spend Breakdown by Event (vehicle and buydown)

• Cost Benefit Review—Detailed cost benefit analysis, including profitability 
metrics from both the manufacturer and retailer’s perspective, overall event 
spend, cost per incremental unit (CPIU), payment type and price analysis 
(average retail vs. list)

• Fund Allocation—You can allocate the promotional costs across different 
funds.

4. In the Event Planner window, click a promotion to see further details.

The windows below this display graphical information for that promotion. You 
can navigate through the various promotions. As you do so, the corresponding 
graphs are updated to reflect this data.

Creating a Promotion

To create a promotion

1. You typically start in the Planning Environment; see “Introduction to the 
Planning Environment” on page 72.

2. At the top of the screen, select the territory, retailer, category, and then promotion 
group with which you want to create the promotion.

3. In the Event Planner window, right-click an existing promotion and then select 
New Promotion.

Tip You can do the same thing in any area of the worksheet that displays 
promotions.
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Demantra Spectrum displays the following screen.

4. For Name, specify a unique name.

5. The Population area shows the currently selected combinations with which the 
new promotion will be associated. The defaults are taken from the current 
selection in the worksheet. 

6. For Dates, specify the starting and ending date of the promotion.

7. The rest of the fields prompt you for values of attributes associated with this 
promotion; the fields shown in red are required. The specific attributes you see 
depend upon your configuration, but they may include the following:

• For Scenario, choose the upper promotion level to which this promotion 
belongs. (In this example, promotions belong within scenarios.)

• For Promotion Type, choose a type of promotion that affects demand as 
closely as possible to the promotion you are creating.

8. Click Create. The new promotion is created and is displayed in the Event 
Planner area.

9. In the Event Planner area, edit promotion details such as the following.

• Account

• Product

• Vehicle type

• Start ship

• Start event

Note It is important to specify appropriate values for the attributes, because the 
Analytical Engine considers them when it creates the forecast.
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• # of weeks

• Sale Price

• Shelf Price

• Buy Down

10. Click Data > Save Data.

See also

“Copying and Pasting a Promotion” on page 77

Modifying a Promotion

To modify a promotion

1. You typically start in the Planning Environment; see “Introduction to the 
Planning Environment” on page 72.

2. In the Event Planner window, edit any details in the row corresponding to the 
promotion.

3. Click Data > Save Data.

4. To rename the promotion, right-click it, click Edit, type a new name and click 
Finish.

If you need to reassociate this promotion with a different territory, retailer, and so on, 
see “Reassociating a Promotion with a Different Item or Location” on page 75.

Reassociating a Promotion with a Different Item or 
Location

When you create a promotion, it is automatically associated with the items and 
locations where you were working. You can reassociate the promotion with different 
items or locations if needed.

To reassociate a promotion

1. You typically start in the Planning Environment; see “Introduction to the 
Planning Environment” on page 72.

2. In the Event Planner window, right-click a promotion and click Edit.

3. Click Edit below the Population area.

Tip You can do this in any area of the worksheet that displays promotions.

Tip You can do the same thing in any area of the worksheet that displays 
promotions.
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The following dialog box is displayed:

Usually a promotion is associated with a territory, retailer, category, and 
promotion group.

4. To change the territory, retailer, category, or promotion group, click that level 
name in Selected Filter Levels and change the selection displayed in 
Selected members.

For example, to associate the promotion with a different promotion group:

a. In Selected Filter Levels, click Promotion Group.

b. In the Selected members list, double-click the promotion group that you no 
longer want to use for this promotion. For example, double-click ADVO 100 
to remove it from this list.

c. In Available members, double-click the promotion group that should be 
used. This promotion group is then moved to the Selected members list. 
For example, double-click ADVO 200 to move it to the Selected members 
list; now the promotion is associated with ADVO 200 instead of ADVO 100.

5. Repeat as necessary.

6. Click Finish to exit this dialog box.

7. Click Finish. The changes are saved.

8. Rerun the worksheet to see the changes.
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Copying and Pasting a Promotion

To copy and paste a promotion

1. You typically start in the Planning Environment; see “Introduction to the 
Planning Environment” on page 72.

2. In the Event Planner window, right-click a promotion and click Copy.

3. Right-click and then select Paste.

Demantra Spectrum displays a dialog box that asks for details about the copy.

4. Specify one of the following:

• To shift the dates of the newly copied promotion, specify a number in the Shift 
By field. The copy will be shifted later in time by the specified amount, but 
will last for the same length of time. You can use any integer, including 
negative number or zero.

• To specify a different start and end date, specify values in the From and To 
fields.

• To make the new promotion span the entire length of time used in the 
worksheet, select Worksheet Derive.

5. Click OK.

6. Click the newly copied promotion and then select Edit.

7. Enter a new name and click Finish.

See also

“Modifying a Promotion” on page 75
“Creating a Promotion” on page 73

Deleting a Promotion

To delete a promotion

1. You typically start in the Planning Environment; see “Introduction to the 
Planning Environment” on page 72.

2. In the Event Planner window, right-click a promotion and click Delete.

3. Demantra Spectrum prompts you to confirm the action. Click Yes or No.

Tip You can do the same thing in any area of the worksheet that displays 
promotions.

Tip You can do the same thing in any area of the worksheet that displays 
promotions.
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4. Rerun the worksheet to see the change.

See also

“Creating a Promotion” on page 73

Comparing Promotions in a Scenario
To determine how best to spend trade dollars, you can compare and evaluate multiple 
promotions in a scenario. The PMO: Promotion Comparison worksheet provides 
this capability.

You can define several different promotions and compare their results side by side. 
This allows you to quickly spot the best promotion for each opportunity. Once 
completed, you can choose the best promotion(s) and add them to your current plan 
simply by changing the status to Planned. 

To compare promotions in a scenario

1. You typically start in the Planning Environment; see “Introduction to the 
Planning Environment” on page 72.

2. In the Event Planner window, right-click a scenario and click Open With > 
PMO: Promotion Comparison.
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3. If the worksheet does not show data immediately, click Data > Rerun. Or click 
the Run button.

This launches the PMO: Promotion Comparison worksheet filtered to show the 
promotions of that scenario.

Now you can easily compare all events in the selected scenario. The two graphs 
provide the visuals to allow a more in-depth look at the spending levels and true lift of 
each promotion side-by-side.

Note the extensive use of colors to provide indication of key benefits from both the 
manufacturer’s and the retailer’s perspective.

The screen now displays the following areas:

• Event Planner: details of all events, including start and end ship dates, vehicle 
type, vehicle cost, buydown, base volume and incremental volume. Incremental 
volume is generated by Demantra’s comprehensive Analytical Engine.

• Cost Benefit Review: detailed cost benefit analysis, including profitability 
metrics from both the manufacturer and retailer’s perspective, overall event 
spend, cost per incremental unit (CPIU), payment type and price analysis 
(average retail vs. list).

• Net Lift Analytics: detailed volume decomposition by event.

• Total Event Spend: total event spend by event.
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Reference

Planning Environment

Hierarchy

This worksheet uses the following hierarchy levels:

Business Data

Levels you can select: Territory, Retailer, Category, Promotion Group

Levels used in cross tabulation: Scenario, Promotion

View Series Purpose

Cost Benefit 
Review

% Spend Total plan spend for event excluding slotting divided by total 
sales during the event

CPIU Cost per incremental unit

Evt Spend Total Plan Spend for entire promotion

Evt Status Promotion status

Incr Evt $ Incremental $ sales due to the event (gross)

Incr Mfg Prft Incremental profit to the manufacturer due to the promotion 
(gross)

Incr Rtl Prft Incremental retailer profit due to promotion, Incr volume* 
Margin

Mfg Profit Manufacturer's profit from the event (gross)

Pay Type Payment type agreed upon by manufacturer and retailer, for 
example, billback, off invoice, or authorized deduction

Rtl Prft Retailer Margin*Total event volume

Ttl Evt $ Total $ sales during the event
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Event Planner # Wks Number of weeks of the Event based on the event start and 
end date

Base Evt Vol Projected baseline volume for the duration of the promotion 
in actual cases

Buy Dwn Buy down allowance. May be Off Invoice or Bill back. 

Cons Promo Consumer overlay

End Ship Date shipments will end for the event

Incr Evt Vol Incremental event volume based on event base and lift factor 
(gross)

Lift Total volume (including incremental volume from the event), 
divided by base volume

Sale Price The sale price to the consumer.

Shelf Price The everyday price to the consumer

Start Event Date when promotion starts in stores

Start Ship Date product will start to Ship

Ttl Evt Vol Event base volume + Incremental volume after taking 
overrides into account, in actual cases 

Units Number of units to which promotion applies. This is 1, unless 
the promotion is a buy-1-get-1-free promotion; then it is 2.

Veh $ Vehicle costs 

Veh Type The vehicle type or event type of the promotion.

Fund Allocation BDF Alloc Portion of (Total plan spend ex slotting) allotted to BDF

BDF Alloc % % of (Total plan spend ex slotting) allocated to BDF. 

Evt Spend exS Total Plan Spend for entire promotion excluding slotting

MDF Alloc Portion of (Total plan spend ex slotting) allotted to MDF

MDF Alloc % % of (Total plan spend ex slotting) allocated to MDF. This 
value is entered by the planner.  

Fund Balances BDF Auth Authorized Brand development fund = (Base rate + Dev 
Rate)*volume + Fixed funds (Planning Env)

BDF Bal BDF funds remaining = Auth - BDF spent/com

MDF Auth Authorized Market development fund = (Base rate + Dev 
Rate)*volume + Fixed funds (Planning Environment)

MDF Bal MDF funds remaining = Auth - MDF spent/com

Slot Auth Slotting budget authorized by corporate HQ

Slot Bal Slotting authorized - Slotting Spent

Ttl Fund Auth Sum of authorized MDF, BDF and slotting fund 

Ttl Fund Bal MDF bal + BDF bal + Slotting Bal - Unmatched $

Unmatched $ Trade spend not yet matched to an event. It is included in 
Exp/com calculation

View Series Purpose
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Sales Breakdown 
by Event

Base Evt Vol Projected baseline volume for the duration of the promotion 
in actual cases

Incr Vol Incremental volume in actual cases

Sales% vs Quota 
(Base + Viewed 
Events)

# Wks Number of weeks of the Event based on the event start and 
end date

$ Sales Annual Dollar sales 

% Attained Percentage of sales quota attained

% Spend Total plan spend for event excluding slotting divided by total 
sales during the event

BDF Alloc Portion of (Total plan spend ex slotting) allotted to BDF

BDF Alloc % % of (Total plan spend ex slotting) allocated to BDF. 

BDF Auth Authorized Brand development fund = (Base rate + Dev 
Rate)*volume + Fixed funds (Planning Env)

BDF Bal BDF funds remaining = Auth - BDF spent/com

Base Evt Vol Projected baseline volume for the duration of the promotion 
in actual cases

Buy Dwn Buy down allowance. May be Off Invoice or Bill back. 

Buy Dwn $ BuyDown spend for the promotion

CPIU Cost per incremental unit

Cons Promo Consumer overlay

End Ship Date shipments will end for the event

Evt Spend Total Plan Spend for entire promotion

Evt Spend exS Total Plan Spend for entire promotion excluding slotting

Evt Status Promotion status

Incr Evt $ Incremental $ sales due to the event (gross)

Incr Evt Vol Incremental event volume based on event base and lift factor 
(gross)

Incr Mfg Prft Incremental profit to the manufacturer due to the promotion 
(gross)

Incr Rtl Prft Incremental retailer profit due to promotion, Incr volume* 
Margin

Incr Vol Incremental volume in actual cases

Is_self Internal expression

Lift Total volume (including incremental volume from the event), 
divided by base volume

List Price List price paid by the retailer, per unit

MDF Alloc Portion of (Total plan spend ex slotting) allotted to MDF

MDF Alloc % % of (Total plan spend ex slotting) allocated to MDF. This 
value is entered by the planner. 

View Series Purpose
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PMO: Promotion Comparison

Hierarchy

This worksheet uses the following hierarchy levels:

Sales% vs Quota 
(Base + Viewed 
Events)

MDF Auth Authorized Market development fund = (Base rate + Dev 
Rate)*volume + Fixed funds (Planning Environment)

MDF Bal MDF funds remaining = Auth - MDF spent/com

Mfg Profit Manufacturer's profit from the event (gross)

Optimized Indicates whether this promotion is optimized

Pantry Load $ Amount of money that consumers spend on the product 
before and after the event (pantry loading)

Pay Type Payment type agreed upon by manufacturer and retailer, for 
example, billback, off invoice, or authorized deduction

Rtl Prft Retailer Margin*Total event volume

Sale Price The sale price to the consumer.

Sales  Quota This is used to display quota to the user

Shelf Price The everyday price to the consumer

Slot Auth Slotting budget authorized by corporate HQ

Slot Bal Slotting authorized - Slotting Spent

Start Event Date when promotion starts in stores

Start Ship Date product will start to Ship

Ttl Evt $ Total $ sales during the event

Ttl Evt Vol Event base volume + Incremental volume after taking 
overrides into account, in actual cases 

Ttl Fund Auth Sum of authorized MDF, BDF and slotting fund 

Ttl Fund Bal MDF bal + BDF bal + Slotting Bal - Unmatched $

Units Number of units to which promotion applies. This is 1, unless 
the promotion is a buy-1-get-1-free promotion; then it is 2.

Unmatched $ Trade spend not yet matched to an event. It is included in 
Exp/com calculation

Veh $ Vehicle costs 

Veh Type The vehicle type or event type of the promotion.

incr_vol_no_unplan Incremental volume in actual cases

Spend 
Breakdown by 
Event

Buy Dwn $ BuyDown spend for the promotion

Veh $ Vehicle costs 

View Series Purpose

Levels you can select: Territory, Retailer, Promotion Group
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Levels used in cross tabulation: Scenario, Promotion

View Series Purpose

Cost Benefit 
Review

% Spend Total plan spend for event excluding slotting divided by total 
sales during the event

Base Evt $ Base event cost: total event cost less incremental event cost

CPIU Cost per incremental unit

Can $ DIr Direct (internal)

Evt Spend exS Total Plan Spend for entire promotion excluding slotting

Evt Status Promotion status

Incr Evt $ Incremental $ sales due to the event (gross)

Incr Mfg Prft Incremental profit to the manufacturer due to the promotion 
(gross)

Incr Rtl Prft Incremental retailer profit due to promotion, Incr volume* 
Margin

Mfg Profit Manufacturer's profit from the event (gross)

Pantry Load $ Amount of money that consumers spend on the product before 
and after the event (pantry loading)

Pay Type Payment type agreed upon by manufacturer and retailer, for 
example, billback, off invoice, or authorized deduction

Rtl Prft Retailer Margin*Total event volume

Ttl Evt $ Total $ sales during the event
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Event Planner # Wks Number of weeks of the Event based on the event start and end 
date

Avg Rtl Average unit retail price at shelf

Base Evt Vol Projected baseline volume for the duration of the promotion in 
actual cases

Buy Dwn Buy down allowance. May be Off Invoice or Bill back. 

Cons Promo Consumer overlay

End Ship Date shipments will end for the event

Incr Evt Vol Incremental event volume based on event base and lift factor 
(gross)

Lift Total volume (including incremental volume from the event), 
divided by base volume

Sale Price The sale price to the consumer.

Shelf Price The everyday price to the consumer

Start Event Date when promotion starts in stores

Start Ship Date product will start to Ship

Ttl Evt Vol Event base volume + Incremental volume after taking 
overrides into account, in actual cases 

Units Number of units to which promotion applies. This is 1, unless 
the promotion is a buy-1-get-1-free promotion; then it is 2.

Veh $ Vehicle costs 

Veh Type The vehicle type or event type of the promotion.

Net Lift Analytics Base Evt $ Base event cost: total event cost less incremental event cost

Can $ DIr Direct (internal)

Incr Evt $ Net Incremental event profit after accounting for cannibalization 
and pantry loading

Pantry Load $ Amount of money that consumers spend on the product before 
and after the event (pantry loading)

Total Event Spend Evt Spend exS Total Plan Spend for entire promotion excluding slotting

View Series Purpose
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 10 PMO: Simulation and 

Optimization
This chapter describes how to perform simulation and optimization, 
as part of the PMO business process. It includes the following 
sections:

Running the Analytical Engine in Batch Mode .............................87
Running Simulations......................................................................88
Checking the Simulation Queue ....................................................89
Canceling a Simulation .................................................................90
Optimizing a Promotion ................................................................90
Viewing Optimization Results ........................................................92
Accepting an Optimized Promotion...............................................93
Reference .......................................................................................94

Running the Analytical Engine in Batch Mode

Before performing simulation or optimization on a given machine for the first time, 
run the Analytical Engine on that machine so that it has access to the engine’s 
resultsTo run the engine in batch mode

1. Click Demantra > Demantra Spectrum release > Engine Administrator.

2. Click File > Run Engine.

3. For Username and Password, enter the database username and password into 
which you loaded the dump file (the Demantra Database User).

4. For Server, enter the Oracle SID of the database.

5. Click Run Engine.
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Running Simulations
You can run simulations to get an approximate forecast for a promotion. 

To run a simulation

1. Make sure the engine process (in Simulation mode) is running on the server. Also 
note that an error will occur if the Analytical Engine has not been run previously.

2. Run a worksheet. You can run a simulation in any worksheet, but the best 
worksheet to use for this is the PMO: Promotion Evaluation worksheet; see 
“Evaluating a Promotion” on page 97.

3. Optionally make a change that could affect the forecast.

4. Click Data > Run Simulation. Or click the Simulation button.

The Select Simulation Type page appears.

5. Select one of the following simulation types:

6. If you are using Promotions Effectiveness, select the engine profile that includes 
the engine settings to use during this simulation run. For details on the engine 
profiles in your system, contact your Demantra implementor.

7. Do one of the following:

• Click OK to run the simulation.

Note The Select Engine Profile option is used only if you are using the 
Promotions Effectiveness Analytical Engine.

Option Generates a simulation for... Notes

Selected Page 
Item

Combination that you have currently 
selected via the Members Browser or 
selector lists

If a level is on a worksheet 
axis, these two options are 
different. Otherwise they 
are the same.

Selected 
Combination

Combination that you have currently 
selected within the worksheet table

Whole 
Worksheet

All combinations in the worksheet This option takes longer to 
run.
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• Click Cancel to close the page without running the simulation.

8. When the simulation is complete, Demantra Spectrum displays a message. 

9. Examine the results.

10. Do one of the following:

• To accept the results, click Data > Accept Simulation. Demantra Spectrum 
copies the data from the Simulation series into the Sales Forecast series, 
where they are visible to other users.

• To reject the results, click Data > Reject Simulation. Demantra Spectrum 
clears the data from the Simulation series.

(The other series, such as Brand Switching, are left alone; they will be 
overwritten when the Analytical Engine next runs.) 

Checking the Simulation Queue
When you start a simulation, Demantra Spectrum adds it to an internal queue, which 
processes all simulations in the order they are submitted. You can view this queue and 
you can cancel a simulation that you submitted.

To check the simulation queue

1. Click Data > Simulation Queue.

Demantra Spectrum displays the following dialog box:

The Status field indicates the status of each simulation request. The status can be 
one of the following:

Requested A user has submitted this simulation request, which has not yet 
started running.

Running Demantra Spectrum is performing this simulation.

Completed Demantra Spectrum has completed this simulation 
successfully.

Stopping A user asked to cancel this simulation request, which Demantra 
Spectrum has not yet fully canceled.

Stopped A user has canceled this simulation request and Demantra 
Spectrum has fully canceled it.

Failed Demantra tried to run this simulation, but an error occurred.
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Canceling a Simulation

To cancel a simulation

1. Click Data > Simulation Queue.

2. Click simulation and then click Cancel Simulation.

Optimizing a Promotion
You can optimize any future promotion, in any worksheet that displays promotions. 
For example, you can start in the Planning Environment worksheet; see 
“Introduction to the Planning Environment” on page 72.

To optimize a promotion

1. Make sure that you have entered a sale price for the item and location.

2. Right-click a promotion and click Methods > Optimize.

TPMO displays the following dialog box:
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3. Specify values for the following parameters:

4. Click Optimize.

Now the system will select the promotion parameters (sale price, vehicle type, and so 
on) that best meet your goal. This is a huge time saver because you do not have have 
to go through all the possible permutations of each promotion in order to find the best 
one.

In order to view the proposed promotion, you use the PMO: Optimization 
Comparison worksheet; see the next section.

Optimization Goal Select one of the following goals for this 
promotion:

• Maximize Revenue
• Maximize Profit
• Maximize Units

Max Budget Maximum allowed budget for this promotion.

Optimization Range Start, 
Optimization Range End

By default, Promotion Optimization assumes 
that you want the optimized promotion to fall 
within the span of time of the original 
promotion. If you want Promotion 
Optimization to search for a better time for this 
promotion, use these parameters to specify the 
range of time for optimization to consider.

Fixed Buydown Specify whether Promotion Optimization 
should use the buydown that you have already 
entered or calculate an optimal buydown for 
this promotion.

Max Buydown Maximum allowed buydown for this 
promotion. If Promotion Optimization 
calculates an optimal buydown, the buydown 
will not exceed this value.

Min Rtl Margin Override Minimum margin that the retailer must make on 
this promotion. By default, Promotion 
Optimization considers the retailer’s default 
required minimum margin. Use this parameter 
to override that value, if needed.

Use a value greater than 0 and less than or equal 
to 1.
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Viewing Optimization Results
The PMO: Optimization Comparison worksheet provides the capability to 
simultaneously view and compare the results of a promotion before and after running 
optimization.

To view optimization results

1. Right-click a promotion that you have optimized and click Open With > PMO: 
Optimization Comparison.

The system displays the following:

The PMO: Optimization Comparison worksheet contains the following 
information:

• Event Planner: details of the events, including start and end ship dates, vehicle 
type, vehicle cost, buydown, base volume and incremental volume. Incremental 
volume is generated by Demantra’s comprehensive analytical engine.

• Optimized - Event Planner: details of the event as a result of running 
optimization. The values are given right below the original values of the 
promotion to facilitate easy comparison.

• Cost Benefit Review: Detailed cost benefit analysis, including profitability 
metrics from both the manufacturer and retailer’s perspective, overall event 
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spend, cost per incremental unit (CPIU), payment type and price analysis 
(average retail vs. list).

• Optimized - Cost Benefit Review: Detailed cost benefit analysis as a result 
of running optimization.

• Sales Comparison: Graphical comparison of the total event dollars generated 
before and after optimization.

• Incr Mfg Prft Comparison: Graphical comparison of the Incremental 
Manufacturing Profit generated before and after optimization.

• Incr Rtl Prft Comparison: Graphical comparison of the incremental retailer 
profit generated before and after running optimization

• Spend Comparison: Graphical comparison of event spend before and after 
running optimization.

Accepting an Optimized Promotion
After you optimize a promotion, you can accept it. You can do this in any worksheet 
that displays promotions. For example, you can start in the PMO: Optimization 
Comparison worksheet; see “Viewing Optimization Results” on page 92.

To accept an optimized promotion

1. Right-click the promotion and select Methods > Accept Optimization. 

If you accept the optimization, the attributes of the optimized promotion are 
copied into the original promotion. 

2. Once satisfied with the results, you can add this promotion to your current plan 
simply by changing the status to planned.

The system also takes a snapshot of the promotion at this stage for use as a baseline.

Note This action has no effect on a promotion that has not been optimized.
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Reference

PMO: Optimization Comparison

Hierarchy

This worksheet uses the following hierarchy levels:

Business Data

Levels you can select: Territory, Retailer, Promotion

Levels used in cross tabulation: Promotion Group, Scenario

View Series Purpose

Cost Benefit 
Review

% Spend Total plan spend for event excluding slotting divided by total 
sales during the event

Base Evt $ Base event cost: total event cost less incremental event cost

CPIU Cost per incremental unit

Evt Spend exS Total Plan Spend for entire promotion excluding slotting

Evt Status Promotion status

Incr Evt $ Incremental $ sales due to the event (gross)

Incr Mfg Prft Incremental profit to the manufacturer due to the promotion 
(gross)

Incr Rtl Prft Incremental retailer profit due to promotion, Incr volume* 
Margin

Mfg Profit Manufacturer's profit from the event (gross)

Rtl Prft Retailer Margin*Total event volume

Ttl Evt $ Total $ sales during the event
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Event Planner # Wks Number of weeks of the Event based on the event start and end 
date

Base Evt Vol Projected baseline volume for the duration of the promotion in 
actual cases

Buy Dwn Buy down  allowance. May be Off Invoice or Bill back. 

Cons Promo Consumer overlay

End Ship Date shipments will end for the event

Incr Evt Vol Incremental event volume based on event base and lift factor 
(gross)

Lift Total volume (including incremental volume from the event), 
divided by base volume

Sale Price The sale price to the consumer.

Shelf Price The everyday price to the consumer

Start Event Date when promotion starts in stores

Start Ship Date product will start to Ship

Ttl Evt Vol Event base volume + Incremental volume after taking overrides 
into account, in actual cases  

Veh $ Vehicle costs  

Veh Type The vehicle type or event type of the promotion.

Incr Mfg Prft 
Comparison

Incr Mfg Prft Incremental profit to the manufacturer due to the promotion 
(gross)

Incr Mfg Prft O Incremental profit to the manufacturer due to the promotion 
(gross), computed by optimization

Optimized - Cost 
Benefit Review

% Spend O Total plan spend for event excluding slotting divided by total 
sales during the event, calculated as a result of optimization

Base Evt $ O Base event cost computed by Optimization: total event cost less 
incremental event cost 

CPIU O Cost per incremental unit

Evt Spend exS O Total Plan Spend for entire promotion excluding slotting, after 
optimization

Incr Evt $ O Incremental $ sales due to the event (gross), after optimization

Incr Mfg Prft O Incremental profit to the manufacturer due to the promotion 
(gross)

Incr Rtl Prft O Incremental retailer profit due to promotion, Incr volume* 
Margin, after optimization

Mfg Prft O Manufacturer's profit from the event (gross)

Rtl Prft O Retailer Margin*Total event volume

Ttl Evt $ O Total $ sales during the event

View Series Purpose



Chapter 10: PMO: Simulation and Optimization

96 Demantra TPMO User Guide

 
 

Optimized - 
Event Planner

# Wks O Number of weeks of the Event based on the event start and end 
date

Base Evt Vol O Projected baseline volume for the duration of the promotion in 
actual cases

Buy Dwn O Buy down  allowance. May be Off Invoice or Bill back. 

Cons Promo Consumer overlay

End Ship Date shipments will end for the event

Incr Evt Vol O Incremental event volume after Optimization

Lift O Total volume (including incremental volume from the event), 
divided by base volume, computed by Optimization

Sale Price O The sale price to the consumer, as suggested by Optimization

Shelf Price The everyday price to the consumer

Start Event O Date when promotion starts in stores

Start Ship Date product will start to Ship

Ttl Evt Vol O Event base volume + Incremental volume after taking overrides 
into account, in actual cases  

Veh $ O Vehicle costs  

Veh Type O The vehicle type as a result of Optimization

Incr Rtl Prft 
Comparison

Incr Rtl Prft Incremental retailer profit due to promotion, Incr volume* 
Margin

Incr Rtl Prft O Incremental retailer profit due to promotion, Incr volume* 
Margin, after optimization

Sales 
Comparison

Ttl Evt $ Incremental $ sales due to the event (gross)

Ttl Evt $ O Incremental $ sales due to the event (gross), after optimization

Spend 
Comparison

Evt Spend exS Total Plan Spend for entire promotion excluding slotting

Evt Spend exS O Total Plan Spend for entire promotion excluding slotting, after 
optimization

View Series Purpose
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 11 PMO: Reviewing Past 

Performance
Base functionality for promotion evaluation exists in Demantra’s 
TPM application. The difference is a lower level of detail is made 
available (no lift decomposition functionality). The details 
described here are associated with the more advanced PMO 
module. 

Evaluating a Promotion.................................................................97
Reviewing More Details of a Past Promotion .............................100
Evaluating a Scenario .................................................................101
Reference .....................................................................................102

Evaluating a Promotion
Once a promotion has been planned and executed, it is useful to evaluate its 
performance against your original plan. The PMO: Promotion Evaluation 
worksheet provides a detailed post-promotional analysis of each individual 
promotion. (i.e. compare forecast to actual performance).

You can view the breakdown of each event with respect to the sales dollars and profit 
generated for the manufacturer. Depending on the detail of the historical data, a lift 
decomposition can be provided showing promotional effects such as:

• Cannibalization (positive or negative) you have

• Pre and post effects, such as pantry loading

This will enable you to see your true “net lift” and revised financial figures in order to 
properly evaluate the event’s performance and uncover its true profitability.
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To evaluate a past promotion

1. You typically start in the Planning Environment; see “Introduction to the 
Planning Environment” on page 72.

2. In the Event Planner window, right-click a promotion and click Open With > 
PMO: Promotion Evaluation.

3. If the worksheet does not show data immediately, click Data > Rerun. Or click 
the Run button.

The system displays the PMO: Promotion Evaluation worksheet, filtered to 
display just the promotion that you right-clicked.
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The PMO: Promotion Evaluation worksheet includes:

• Event Projections – planned event details, including event start, vehicle type, total 
planned volume, anticipated manufacturer and retailer profit, as well as 
anticipated spend.

• Event Actuals – actual event volume, actual manufacturer and retailer profit, total 
event spend

• Projected Sales vs. Actuals – graph summarizing planned vs. actual sales

• Lift Decomposition – breakdown of event volume into base volume, incremental 
lift (i.e. direct lift) and pantry loading

• Projected Profit vs. Actuals – comparison of anticipated profits vs. actuals
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Reviewing More Details of a Past Promotion
Once in the promotion evaluation screen, you can get further detail about the impact 
of the promotion by moving to the PMO: Promotion Evaluation - Detail 
worksheet. This report will show the lift decomposition in much more detail, showing 
the actual cannibalization for the promoted item as well as the impact it had on other 
items within a user’s franchise. 

To view more details for a past promotion

1. You typically start in the PMO: Promotion Evaluation worksheet; see 
“Evaluating a Promotion” on page 97.

2. Right-click a promotion and click Open With > PMO: Promotion 
Evaluation - Detail.

The PMO: Promotion Evaluation - Detail worksheet includes:

• Event Projections – planned event details, including event start, vehicle type, 
total planned volume, anticipated manufacturer and retailer profit, as well as 
anticipated spend.

• Event Actuals – actual event volume, actual manufacturer and retailer profit, 
total event spend

• Projected Sales vs. Actuals – graph summarizing planned vs. actual sales
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• Lift Decomposition – breakdown of event volume into base volume, 
incremental lift (i.e. direct lift) and pantry loading

• Projected Profit vs. Actuals – comparison of anticipated profits vs. actuals

Evaluating a Scenario
The PMO: Scenario Evaluation worksheet is intended to provide an overview of 
historical promotions by territory, retailer, category and promotion group, allowing for 
a detailed analysis of how all events within a category performed to plan. Demantra’s 
PMO: Scenario Evaluation worksheet provides all this detailed information in one 
place, making it easy to analyze and assess the effectiveness of a promotional 
scenario.

To evaluate the promotions in a scenario

1. You typically start in the Planning Environment; see “Introduction to the 
Planning Environment” on page 72.

2. In the Event Planner window, right-click a scenario and click Open With > 
PMO: Scenario Evaluation.
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The PMO: Scenario Evaluation worksheet displays the following information for 
the promotions in this scenario:

• Event Projections – planned event details, including event start, vehicle type, 
total planned volume, anticipated manufacturer and retailer profit, as well as 
anticipated spend.

• Event Actuals – actual event volume, actual manufacturer and retailer profit, 
total event spend

• Projected Sales vs. Actuals – graph summarizing planned vs. actual sales

• Lift Decomposition – breakdown of event volume into base volume, 
incremental lift (i.e. direct lift) and pantry loading

• Projected Profit vs. Actuals – comparison of anticipated profits vs. actuals

Reference

PMO: Promotion Evaluation

Hierarchy

This worksheet uses the following hierarchy levels:

Levels you can select: Company, Segment, Promotion

Levels used in cross tabulation: None
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Business Data

View Series Purpose

Event Actuals # Wks Number of weeks of the Event based on the event start and 
end date

% Spend Total plan spend for event excluding slotting divided by total 
sales during the event

Avg Rtl Average unit retail price at shelf

CPIU Cost per incremental unit

Cons Promo Consumer overlay

Evt Spend exS Total Plan Spend for entire promotion excluding slotting

Incr Evt $ Incremental $ sales due to the event (gross)

Incr Evt Vol Incremental event volume based on event base and lift factor 
(gross)

Incr Mfg Prft Incremental profit to the manufacturer due to the promotion 
(gross)

Incr Rtl Prft Incremental retailer profit due to promotion, Incr volume* 
Margin

Start Event Date when promotion starts in stores

Ttl Evt $ Total $ sales during the event

Ttl Evt Vol Event base volume + Incremental volume after taking 
overrides into account, in actual cases

Veh Type The vehicle type or event type of the promotion.
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Event Projections # Wks P Projected length of event, in weeks

% Spend P Projected total plan spend for event excluding slotting divided 
by total sales during the event

CPIU P Projected cost per incremental unit

Cons Promo Consumer overlay

Evt Spend exS P Projecte total plan spend for entire promotion excluding 
slotting

Incr Evt $ P Projected incremental $ sales due to the event (gross)

Incr Evt Vol P Projected incremental event volume based on event base and 
lift factor (gross)

Incr Mfg Prft P Projected incremental profit to the manufacturer due to the 
promotion (gross)

Incr Rtl Prft P Projected incremental retailer profit due to promotion, Incr 
volume* Margin

Sale Price The sale price to the consumer.

Start Event P Projected start of the event

Ttl Event $ P Projected total $ sales during the event

Ttl Evt Vol P Projected event base volume + Incremental volume after 
taking overrides into account, in actual cases

Veh Type The vehicle type or event type of the promotion.

Lift 
Decomposition

Base Evt $ Base event cost: total event cost less incremental event cost 

Can $ DIr Direct (internal)

Incr Evt $ Incremental $ sales due to the event (gross)

Pantry Load $ Amount of money that consumers spend on the product 
before and after the event (pantry loading)

Projected Profit vs 
Actuals

Incr Mfg Prft Incremental profit to the manufacturer due to the promotion 
(gross)

Incr Mfg Prft P Projected incremental profit to the manufacturer due to the 
promotion (gross)

Projected Sales vs 
Actuals

Sales Var Variance between Ttl Evt Vol and Ttl Evt Vol P

Ttl Evt Vol Event base volume + Incremental volume after taking 
overrides into account, in actual cases

Ttl Evt Vol P Projected event base volume + Incremental volume after 
taking overrides into account, in actual cases

View Series Purpose
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PMO: Promotion Evaluation - Detail

Hierarchy

This worksheet uses the following hierarchy levels:

Business Data 

Levels you can select: Promotion

Levels used in cross tabulation: Promotion Group

View Series Purpose

Event Actuals # Wks Number of weeks of the Event based on the event start and 
end date

% Spend Total plan spend for event excluding slotting divided by total 
sales during the event

Avg Rtl Average unit retail price at shelf

CPIU Cost per incremental unit

Cons Promo Consumer overlay

Evt Spend exS Total Plan Spend for entire promotion excluding slotting

Incr Evt $ Incremental $ sales due to the event (gross)

Incr Evt Vol Incremental event volume based on event base and lift factor 
(gross)

Incr Mfg Prft Incremental profit to the manufacturer due to the promotion 
(gross)

Incr Rtl Prft Incremental retailer profit due to promotion, Incr volume* 
Margin

Start Event Date when promotion starts in stores

Ttl Evt $ Total $ sales during the event

Ttl Evt Vol Event base volume + Incremental volume after taking 
overrides into account, in actual cases  

Veh Type The vehicle type or event type of the promotion.
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Event Projections # Wks P Projected length of promotion, in weeks

% Spend P Projected total plan spend for event excluding slotting divided 
by total sales during the event

CPIU P Projected cost per incremental unit

Cons Promo Consumer overlay

Evt Spend exS P Projected Total Plan Spend for entire promotion excluding 
slotting

Incr Evt $ P Projected incremental $ sales due to the event (gross)

Incr Evt Vol P

Incr Mfg Prft P Projected incremental profit to the manufacturer due to the 
promotion (gross)

Incr Rtl Prft P Projected incremental retailer profit due to promotion, Incr 
volume* Margin

Sale Price The sale price to the consumer.

Start Event P Projected start of the event

Ttl Event $ P Projected total $ sales during the event

Ttl Evt Vol P Projected event base volume + Incremental volume after 
taking overrides into account, in actual cases 

Veh Type The vehicle type or event type of the promotion.

Lift 
Decomposition

Base Evt $ Base event cost: total event cost less incremental event cost 

Can $ DIr Direct (internal)

Incr Evt $ Incremental $ sales due to the event (gross)

Pantry Load $ Amount of money that consumers spend on the product before 
and after the event (pantry loading)

Projected Profit vs 
Actuals

Incr Mfg Prft Incremental profit to the manufacturer due to the promotion 
(gross)

Incr Mfg Prft P Projected incremental profit to the manufacturer due to the 
promotion (gross)

Projected Sales vs 
Actuals

Sales Var Variance between Ttl Evt Vol and Ttl Evt Vol P

Ttl Evt Vol Event base volume + Incremental volume after taking 
overrides into account, in actual cases  

Ttl Evt Vol P Projected event base volume + Incremental volume after 
taking overrides into account, in actual cases 

View Series Purpose
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PMO: Scenario Evaluation

Hierarchy

This worksheet uses the following hierarchy levels:

Business Data 

Levels you can select: Territory, Retailer, Category, Promotion Group

Levels used in cross tabulation: Promotion

View Series Purpose

Event Actuals # Wks Number of weeks of the Event based on the event start and end 
date

% Spend Total plan spend for event excluding slotting divided by total 
sales during the event

Avg Rtl Average unit retail price at shelf

Base Evt $ Base event cost: total event cost less incremental event cost 

CPIU Cost per incremental unit

Cons Promo Consumer overlay

Evt Spend exS Total Plan Spend for entire promotion excluding slotting

Incr Evt $ Incremental $ sales due to the event (gross)

Incr Evt Vol Incremental event volume based on event base and lift factor 
(gross)

Incr Mfg Prft Incremental profit to the manufacturer due to the promotion 
(gross)

Incr Rtl Prft Incremental retailer profit due to promotion, Incr volume* 
Margin

Pantry Load $ Amount of money that consumers spend on the product before 
and after the event (pantry loading)

Sale Price The sale price to the consumer.

Start Event Date when promotion starts in stores

Ttl Evt $ Total $ sales during the event

Ttl Evt Vol Event base volume + Incremental volume after taking overrides 
into account, in actual cases  

Veh Type The vehicle type or event type of the promotion.
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Event 
Projections

# Wks Number of weeks of the Event based on the event start and end 
date

% Spend Total plan spend for event excluding slotting divided by total 
sales during the event

% Spend P Projected total plan spend for event excluding slotting divided by 
total sales during the event

Avg Rtl Average unit retail price at shelf

Base Evt $ Base event cost: total event cost less incremental event cost 

CPIU Cost per incremental unit

CPIU P Projected cost per incremental unit

Cons Promo Consumer overlay

Evt Spend exS Total Plan Spend for entire promotion excluding slotting

Evt Spend exS P Projected total plan spend for entire promotion excluding slotting

Incr Evt $ Incremental $ sales due to the event (gross)

Incr Evt $ P Projected incremental $ sales due to the event (gross)

Incr Evt Vol IncremIncremental $ sales due to the event (gross)

ental event volume based on event base and lift factor (gross)

Incr Evt Vol P Projected incremental event volume based on event base and lift 
factor (gross)

Incr Mfg Prft Incremental profit to the manufacturer due to the promotion 
(gross)

Incr Mfg Prft P Projected incremental profit to the manufacturer due to the 
promotion (gross)

Incr Rtl Prft Incremental retailer profit due to promotion, Incr volume* 
Margin

Incr Rtl Prft P Projected incremental retailer profit due to promotion, Incr 
volume* Margin

Pantry Load $ Amount of money that consumers spend on the product before 
and after the event (pantry loading)

Sale Price The sale price to the consumer.

Start Event P Projected start of the event

Ttl Event $ P Projected total $ sales during the event

Ttl Evt $ Total $ sales during the event

Ttl Evt Vol Event base volume + Incremental volume after taking overrides 
into account, in actual cases  

Ttl Evt Vol P Projected event base volume + Incremental volume after taking 
overrides into account, in actual cases 

Veh Type The vehicle type or event type of the promotion.

View Series Purpose
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Lift 
Decomposition

Base Evt $ Base event cost: total event cost less incremental event cost 

Incr Evt $ Incremental $ sales due to the event (gross)

Pantry Load $ Amount of money that consumers spend on the product before 
and after the event (pantry loading)

Projected Profit 
vs Actuals

Incr Mfg Prft Incremental profit to the manufacturer due to the promotion 
(gross)

Incr Mfg Prft P Projected incremental profit to the manufacturer due to the 
promotion (gross)

Projected Sales 
vs Actuals

Sales Var Variance between Ttl Evt Vol and Ttl Evt Vol P

Ttl Evt Vol Event base volume + Incremental volume after taking overrides 
into account, in actual cases  

Ttl Evt Vol P Projected event base volume + Incremental volume after taking 
overrides into account, in actual cases 

View Series Purpose
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