## Contents

### Chapter 1. Entering Data in Schedules
- Schedules Overview ................................................... 13
- Data Entry Window ................................................... 13
  - Setting Schedule Options ............................................. 15
  - Data Display ...................................................... 16
  - Schedule Point of View .............................................. 16
  - Finding Accounts or Periods .......................................... 17
  - Viewing Consolidation Detail .......................................... 17
- Schedule Setup ....................................................... 17
  - Defining Schedules ................................................. 18
  - Adding Validated Subaccounts ........................................ 18
  - Entering or Editing Data ............................................. 19
  - Data Entry Operator Keys ............................................ 19
- Schedule Maintenance ................................................. 21
  - Highlighting Data Blocks ............................................. 21
  - Moving Data ..................................................... 21
  - Copying Data ..................................................... 22
  - Removing Data .................................................... 22
  - Calculating Formulas in Schedules ......................................... 22
  - Setting Accounts Without Data to Zero ..................................... 23
  - Decimal Places Option ................................................. 24

### Chapter 2. Loading and Extracting Data
- Database Management Overview .......................................... 25
- Database Window ..................................................... 26
  - Data Status ........................................................ 27
  - Setting Database Options ............................................ 28
  - Database Point of View ................................................ 29
  - Viewing Entity Lists .................................................. 29
  - Viewing Account Groups ............................................. 30
  - Viewing Account Lists ............................................... 30
  - Viewing Consolidation Detail .......................................... 31
<table>
<thead>
<tr>
<th>Finding Accounts in the Database</th>
<th>31</th>
</tr>
</thead>
<tbody>
<tr>
<td>Finding Account Groups or Periods in the Database</td>
<td>31</td>
</tr>
<tr>
<td>Database Maintenance</td>
<td>32</td>
</tr>
<tr>
<td>Highlighting Data Blocks</td>
<td>32</td>
</tr>
<tr>
<td>Moving Data</td>
<td>33</td>
</tr>
<tr>
<td>Copying Data</td>
<td>33</td>
</tr>
<tr>
<td>Pasting Data</td>
<td>34</td>
</tr>
<tr>
<td>Clearing Data Blocks</td>
<td>35</td>
</tr>
<tr>
<td>Filling the Database</td>
<td>35</td>
</tr>
<tr>
<td>Erasing Data</td>
<td>35</td>
</tr>
<tr>
<td>Working with Data Drill-Back to FDM</td>
<td>36</td>
</tr>
<tr>
<td>Managing Visual Cue for FDM Data</td>
<td>36</td>
</tr>
<tr>
<td>Locking or Unlocking Periods in the Database</td>
<td>37</td>
</tr>
<tr>
<td>Journal Posting Lock and Unlock</td>
<td>37</td>
</tr>
<tr>
<td>Calculating Formulas in the Database</td>
<td>39</td>
</tr>
<tr>
<td>Setting Accounts Without Data to Zero</td>
<td>39</td>
</tr>
<tr>
<td>Running Dependent Consolidation Detail Reports</td>
<td>40</td>
</tr>
<tr>
<td>Clearing Invalid Consolidation Detail</td>
<td>41</td>
</tr>
<tr>
<td>Data Formats</td>
<td>42</td>
</tr>
<tr>
<td>Accumulate</td>
<td>42</td>
</tr>
<tr>
<td>Replace</td>
<td>43</td>
</tr>
<tr>
<td>Merge</td>
<td>44</td>
</tr>
<tr>
<td>Calculate Formulas</td>
<td>44</td>
</tr>
<tr>
<td>Report Calculated Accounts</td>
<td>45</td>
</tr>
<tr>
<td>Zero No Data</td>
<td>45</td>
</tr>
<tr>
<td>Load Error File</td>
<td>45</td>
</tr>
<tr>
<td>Defining Data Formats</td>
<td>46</td>
</tr>
<tr>
<td>Loading Data</td>
<td>46</td>
</tr>
<tr>
<td>Extracting Data</td>
<td>48</td>
</tr>
<tr>
<td>Extracting Consolidation Detail</td>
<td>49</td>
</tr>
<tr>
<td>Validation of Records in Data Load and Extract</td>
<td>51</td>
</tr>
<tr>
<td>Running Entity Detail Report</td>
<td>51</td>
</tr>
<tr>
<td>Decimal Places Option</td>
<td>56</td>
</tr>
</tbody>
</table>

**Chapter 3. Hyperion Retrieve**

<table>
<thead>
<tr>
<th>What Hyperion Retrieve Does</th>
<th>57</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hyperion Retrieve Setup</td>
<td>57</td>
</tr>
<tr>
<td>HPAPP.DAT File Format</td>
<td>58</td>
</tr>
<tr>
<td>Setting Up the HPAPP.DAT Environment Variable</td>
<td>58</td>
</tr>
<tr>
<td>Chapter 4. Consolidating Data</td>
<td></td>
</tr>
<tr>
<td>--------------------------------</td>
<td>---</td>
</tr>
<tr>
<td>Consolidation Overview</td>
<td>71</td>
</tr>
<tr>
<td>Consolidation Detail</td>
<td>74</td>
</tr>
<tr>
<td>Consolidation Statuses</td>
<td>74</td>
</tr>
<tr>
<td>Statutory Consolidation Engine</td>
<td>75</td>
</tr>
<tr>
<td>Consolidation Window</td>
<td>76</td>
</tr>
<tr>
<td>Finding Entities</td>
<td>76</td>
</tr>
<tr>
<td>Finding Periods</td>
<td>77</td>
</tr>
<tr>
<td>Consolidation Tasks</td>
<td>77</td>
</tr>
<tr>
<td>Selecting Entities and Periods to Consolidate</td>
<td>78</td>
</tr>
<tr>
<td>Consolidating Data</td>
<td>78</td>
</tr>
<tr>
<td>Consolidating Dynamic Organizations</td>
<td>80</td>
</tr>
<tr>
<td>Running Consolidation Detail Reports</td>
<td>81</td>
</tr>
<tr>
<td>Intercompany Matching Reports</td>
<td>83</td>
</tr>
<tr>
<td>Intercompany Group Selection</td>
<td>83</td>
</tr>
<tr>
<td>Partner Selection</td>
<td>83</td>
</tr>
<tr>
<td>Entity Code Option</td>
<td>86</td>
</tr>
<tr>
<td>Currency Option Selection</td>
<td>86</td>
</tr>
<tr>
<td>Currency Translation</td>
<td>86</td>
</tr>
<tr>
<td>Parent Currency</td>
<td>86</td>
</tr>
<tr>
<td>Report Information to Include</td>
<td>87</td>
</tr>
</tbody>
</table>
Chapter 6. Using Hyperion Enterprise Web ............................................... 121
What Hyperion Enterprise Web Does .................................................. 121
Selecting the Point of View ................................................................... 122
Loading Data ...................................................................................... 122
Viewing Consolidation Status .............................................................. 125
Finding an Entity or Account ................................................................. 125
Consolidating Data ............................................................................. 126
Viewing Task Status ........................................................................... 127
Viewing Data ...................................................................................... 128
Setting Schedule Options ................................................................. 129
Entering and Editing Data ................................................................... 130
Locking and Unlocking Data ................................................................. 131
How Data is Displayed in Hyperion Enterprise Web ......................... 131
Working with Data Drill-Back to FDM .................................................. 132
Viewing the Application Error Log ...................................................... 133
Customizing Web Links ...................................................................... 133
Entering Journals in Web ..................................................................... 134
Journals Module ............................................................................... 134
Viewing Journals and Templates ......................................................... 134
Journals and Templates ...................................................................... 134
Journals and Template Creation .......................................................... 135
Opening Periods ................................................................................. 135
Creating Journal Templates ................................................................. 135
Creating Journals ............................................................................... 136
Entering Adjustment Information ......................................................... 137
Reviewing Journals ............................................................................ 137
Reviewing Individual Journals .............................................................. 137
Chapter 7. Hyperion Allocations .......................................................... 141
  What Hyperion Allocations Does .................................................... 141
  Allocation Types and Methods ...................................................... 142
    Name Allocation Type .................................................................... 142
    Account Allocation Type ............................................................. 143
    Time Allocation Type ................................................................. 143
    Percent Method ........................................................................... 143
    Value Method ............................................................................. 143
    Factor Method ............................................................................ 143
    Total Method .............................................................................. 144
  Hyperion Allocations Desktop .......................................................... 144
  Starting Hyperion Allocations .......................................................... 145
  Setting Hyperion Allocations Preferences ........................................ 146
  Selecting Desktop Color .................................................................. 146
  Changing the Hyperion Enterprise Application ................................... 147
  Allocations Setup ............................................................................ 147
    Defining Allocations ..................................................................... 147
    Previewing Allocation Results ..................................................... 149
    Deleting Allocations .................................................................... 149
  Allocation Sets Setup ...................................................................... 150
    Defining Allocation Sets ............................................................. 150
    Deleting Allocation Sets ............................................................. 151
  Running Allocation Sets .................................................................. 151
  Posting Allocation Sets ................................................................... 152
  Deleting Run Information .................................................................. 152
  Extracting Allocation or Set Information .......................................... 153
  Loading Allocation or Set Information ............................................ 153
  Printing or Previewing Allocation Reports ....................................... 154

Chapter 8. LedgerLink ......................................................................... 157
  LedgerLink Overview ...................................................................... 157
HPCDE - Category Description Function ........................................ 188
HPCONTRIB - Contribution Data Function ...................................... 188
HPCUR - Currency Function .......................................................... 189
HPDCTRL - Direct Control Function ............................................... 189
HPDOWN - Direct Ownership Function .......................................... 190
HPDRV - Derived Sum Function .................................................... 190
HPECODE - Entity Code Function ................................................... 191
HPELIM - Elimination Data Function ........................................... 191
HPFLW - Flow Function ................................................................ 192
HPFNA - First Entity Description Function ..................................... 192
HPFRE - Default Frequency Function ............................................. 192
HPFSN - Subentity Description Function ........................................ 193
HPFUL - Entity Description Function ............................................ 193
HPHEA - Account Description Function ......................................... 193
HPHMJ - Major Account Description Function ................................. 194
HPHS1 - First-level Subaccount Description Function ....................... 194
HPHS2 - Second-level Subaccount Description Function ................. 195
HPINC - Income Account Function ............................................... 195
HPINP - Input Account Function .................................................. 195
HPJAC - Journal Account Function ............................................... 196
HPJCR - Journal Credit Value Function .......................................... 196
HPJDB - Journal Debit Value Function ......................................... 197
HPJDS - Journal Description Function .......................................... 197
HPJEN - Journal Entity Function .................................................. 198
HPJNO - Journal Number Function ............................................... 198
HPJST - Journal Status Function ................................................... 199
HPKEY - Default ID Function ....................................................... 199
HPLNK - Link Data Value Function ............................................... 200
HPNAM - Entity Function .............................................................. 200
HPNNA - First Entity ID Function .................................................. 201
HPNSN - Subentity ID Function ..................................................... 201
HPPARADJ - Parent Adjustment Data Function ................................. 202
HPPCONS - Ultimate Percent Consolidated Function ....................... 202
HPPBE - Percentage Difference Function ........................................ 202
HPPCH - Percentage Change Function .......................................... 203
HPPCONS - Ultimate Percent Consolidated Function ....................... 203
HPPCTRL - Ultimate Percent Control Function ................................ 204
HPPOWN - Ultimate Percent Ownership Function ............................ 204
HPPROP - Proportion Data Function ............................................... 205
HPSCA - Scale Function ................................................................. 205
Chapter 10. Product Documentation at Oracle's Technology Network Site .......................... 211
Hyperion Enterprise Documentation ......................................................... 211

Index ........................................................................................................... 213
In Oracle’s Hyperion® Enterprise®, you can enter data using schedules. You can use Oracle’s Hyperion® Enterprise® Reporting to generate reports.

This chapter provides information and procedures that you need to enter data in schedules.

## Schedules Overview

A schedule is a form you use to enter, view, or edit data in specific accounts. You set up schedules by giving them IDs and descriptions, specifying the account lists to include, and setting options to format and calculate the data.

Each schedule contains data for a specific entity and category, listed by account and period. A schedule can include one or two account lists. This allows you to work with only the accounts that you need instead of the entire chart of accounts. For example, you might have a schedule for Actual data for the Plant 1 entity with a top list of input accounts for Sales Data and a bottom list of calculated accounts for Total Sales. This schedule would allow you to enter data into input accounts and view the results of the data entry on the calculated accounts.

## Data Entry Window

You use the Data Entry window to set up and work with schedules. You perform the following tasks in the Data Entry window:

- Create schedules and edit existing schedules
- Copy and delete schedules
- Enter and edit the schedule data
- Calculate formulas
- Add validated subaccounts

You can open one or more schedules from the Data Entry window to view or change the data in accounts. When you open the Data Entry window, the default schedule appears. You can edit the default schedule or open one or more new schedules. You can also preview and print schedule data. For more information on schedules and how to use them, see *Hyperion Enterprise Getting Started*.

Hyperion Enterprise generates an error message if you try to perform a task for a schedule point of view, when another user has the same point of view already in use, for example in the Data Entry module. This error message is written to the error log. For more information on the error log, see *Hyperion Enterprise Getting Started Guide*.

**Figure 1  Data Entry Window**

1. You can select the expand/collapse box to display all accounts and subaccounts in the schedule. For more information, see *Hyperion Enterprise Getting Started*.

2. A plus sign (+) to the left of an account ID indicates that the account is a major account with hidden subaccounts, or a subaccount with second-level subaccounts. You can select the plus sign to display the subaccounts, or the minus sign (-) to hide the subaccounts.

3. Either one or two account lists, referred to as the top and bottom account lists, can appear in a schedule with a row for each account and a column for each period in the current category.

4. The formulas area shows existing formula statements for the selected account.
5. The information area shows the current frequency, view, scale, and decimal attribute of the selected account. For more information on selecting the point of view, see *Hyperion Enterprise Getting Started*.

6. The account area displays the account type, the account description, and the stored value for the selected period.

Major accounts with subaccounts, as well as subaccounts with second-level subaccounts, are calculated accounts, and you cannot enter data into them. Accounts that are unavailable for input appear in different colors. You can change the following default system colors.

- White cells — Input accounts, available for data entry.
- Green cells — Calculated accounts.
- Yellow cells — Consolidated accounts.

For more information on changing system colors, see *Hyperion Enterprise Getting Started*. For more information on account attributes, see the *Hyperion Enterprise Administrator’s Guide*.

### Setting Schedule Options

The following options determine the appearance of a schedule and how it calculates data:

- Showing account labels or descriptions or account labels and descriptions in the account column
- Showing data for all periods or the current period only
- Automatically or manually recalculating data
- Showing or hiding formulas
- Suppressing rows for accounts with no data
- Changing account and data column widths
- Specifying the font

If several Data Entry windows are open at once, the options you change affect only the active window.

To set schedule options:

1. From **Data Entry**, select **Task > Set Schedule Options**.
2. Specify whether to display the account label or description or account label and description, column widths, periods shown, font, or any other options.

   **Note:** The default setting is to display the account label.

3. Click **OK**.
Data Display

The number of digits that you can see in a period for data values is determined by the column width and font size, which are selected as schedule options. If the number of digits exceeds the column width, the number is rounded and truncated, and a data display character is attached to the number. Table 1 describes the data display characters.

<table>
<thead>
<tr>
<th>Character</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>K</td>
<td>Thousands</td>
</tr>
<tr>
<td>M</td>
<td>Millions</td>
</tr>
<tr>
<td>B</td>
<td>Billions</td>
</tr>
<tr>
<td>T</td>
<td>Trillions</td>
</tr>
<tr>
<td>Q</td>
<td>Quadrillions</td>
</tr>
<tr>
<td>*</td>
<td>The data value is too large to display</td>
</tr>
</tbody>
</table>

Although the system might display a rounded number, the system stores the full value. When you select an account, the stored value appears in the information area.

Table 2 shows how the system displays the value 123456789012 using varying column widths. In the examples, the scale is set to 0 (zero) and the font is set to 8 points.

<table>
<thead>
<tr>
<th>Column Width</th>
<th>Displayed As</th>
</tr>
</thead>
<tbody>
<tr>
<td>10 characters</td>
<td>123.45678B</td>
</tr>
<tr>
<td>8 characters</td>
<td>123.457B</td>
</tr>
<tr>
<td>6 characters</td>
<td>123.4B</td>
</tr>
</tbody>
</table>

Schedule Point of View

The schedule point of view determines which data is displayed in the Data Entry window. When you access the Data Entry module, the Data Entry window contains data for the default schedule. You can change the schedule point of view by changing the category, organization, or entity.

The scale, frequency, and data view options default to the attributes of the current category. By changing any of these options, you can change the view of the data that shows in the current schedule.

Note: Changing the scale, frequency, and data view within the Data Entry window affects the current session only.
You can change the scale, frequency, or data view in the Point of View dialog box. For more information, see *Hyperion Enterprise Getting Started*.

**Finding Accounts or Periods**

A schedule with many accounts or periods might extend beyond your screen. You can find accounts or periods without scrolling through the schedule by typing all or part of its ID. You can also filter the list to include input accounts, calculated accounts, subaccounts, or dynamic view accounts.

> To find an account or period:

1. From the *Data Entry* window, take one of the following actions:
   - To find an account, select *Edit > Find > Account* and use the check boxes to filter the list of accounts.
   - To find a period, select *Edit > Find > Period*.

2. **Type an account or period ID or select one from the list.**

3. **Click OK.**

**Viewing Consolidation Detail**

If you selected the option to store consolidation detail when you created the application, you can view consolidation detail for an entity and its dependents. You can view translation information, proportion detail, elimination detail, parent-level adjustments, and contribution values using the point of view bar.

> To view consolidation detail:

1. From the *Desktop* or a window that uses the point of view, select *Edit > Point of View*.

2. **Select the Consolidation Detail tab, select the consolidation detail that you want to display, and click OK.**

**Schedule Setup**

Schedule setup involves defining the schedules you use to enter data into Hyperion Enterprise. You set up schedules by specifying IDs, descriptions, security classes, account lists, and schedule options. You can create as many schedules as you want, and you can edit the definition of any existing schedule. You can also delete schedules that you no longer use.

Before you set up a schedule, your system administrator must define one or more account lists. If this is the first time the Data Entry window has been accessed in an application, you also need to create or select the default schedule. For information on account lists, see the *Hyperion Enterprise Administrator’s Guide*. For more information on the default schedule, see *Hyperion Enterprise Getting Started*. 
You can delete a schedule if you no longer need it. Deleting a schedule does not delete the data for the entities and categories. You cannot delete a schedule if it is the default schedule.

**Defining Schedules**

You define a schedule or edit an existing schedule when you want to set up a data entry form that consists of one or two account lists. You can edit the attributes of a schedule to change its ID, description, security class, to select new top or bottom account lists, or to change display options, such as the column width, periods shown, and font.

**Note:** Preferences set for schedule attributes by selecting Task > Set Schedule Options or from the Hyperion Enterprise Web will not be available after you close the application.

**Note:** The bottom account list is optional.

➢ To define a schedule:

1. From the **Data Entry** window, perform an action:
   - To create a schedule, select **File > New Schedule**.
   - To edit a schedule, open the schedule and select **File > Schedule Attributes**. For instructions on opening a schedule, see **Hyperion Enterprise Getting Started**.

2. Specify the ID, description, security class, and top and bottom account lists.

3. Select **Options**, set preferences, and click **OK** to change how the data appears in the schedule. For instructions, see “Setting Schedule Options” on page 15.

**Adding Validated Subaccounts**

Validated subaccounts appear in schedules only when data exists for the subaccount. Before you can enter data in these subaccounts, you must manually add them to schedules.

For example, suppose a validated subaccount table contains 50 subaccounts under a major account called Golf Sales. You might need to enter data for only three of these subaccounts. Instead of viewing all 50 subaccounts, you can add the three subaccounts you need under the major account Golf Sales when you enter data.

The validated subaccounts are in the subaccount table assigned to the account or subaccount. The system adds validated subaccounts to the schedule in the order in which they appear in the subaccount table. For information on setting up subaccount tables, see the **Hyperion Enterprise Administrator’s Guide**.

➢ To add validated subaccounts:

1. From the **Data Entry** window, select a major account or subaccount that has validated subaccounts.
2 Select **Edit > Insert Subaccounts** or double-click the on selected account ID or description in the Account column.

3 Enter or select the subaccount ID.

4 Click **OK**.

**Entering or Editing Data**

You enter data into input accounts for base entities. Calculated and consolidated accounts do not accept data entry, because the values they contain come from other sources. For example, if a company called USA East has three dependents, East GF, East TN, and East FB, you enter values into the dependent entities. After you consolidate, the value in USA East is the total of the values in its three dependents.

After you make changes to a schedule, the system prompts you to save the changes when you close the Data Entry window or change the entity or category in the point of view bar in the Data Entry window.

You use the point of view bar to temporarily change the data view to see either periodic or year-to-date data for a category. You can enter data in any data view. For example, if you are entering periodic actual data for June, you can enter year-to-date actual data accumulated from January to June by changing the view to year-to-date. Changing the data view in a schedule does not change the Data View category attribute. For more information on point of view, see *Hyperion Enterprise Getting Started*.

➢ To enter or edit data in a schedule:

1 From the Data Entry window, select the cell in which you want to enter or change data. For instructions, see “Highlighting Data Blocks” on page 21.

2 Type a value and press **Enter**.

**Tip:** You can define the function of the Enter key on your workstation. For instructions, see the Hyperion Enterprise Desktop chapter in *Hyperion Enterprise Getting Started*.

**Data Entry Operator Keys**

Operator keys perform special functions that make data entry faster and easier. You can use the operator keys to enter data in several cells at once, to perform calculations on data already in the schedule, or to fill parts of a schedule with randomly generated test data. *Table 3* describes the operator keys.

<table>
<thead>
<tr>
<th>Key</th>
<th>Operation</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>+</td>
<td>Adds the number you type to the number already in the cell.</td>
<td>30+</td>
</tr>
<tr>
<td>Key</td>
<td>Operation</td>
<td>Example</td>
</tr>
<tr>
<td>-----</td>
<td>-----------</td>
<td>---------</td>
</tr>
<tr>
<td>-</td>
<td>Subtracts the number you type from the number already in the cell.</td>
<td>30-</td>
</tr>
<tr>
<td>% + or % -</td>
<td>Increases or decreases the value in the cell by the percentage you type.</td>
<td>50%+</td>
</tr>
<tr>
<td>+ P or -P</td>
<td>Increases or decreases the value in the cell over the previous period by the amount or percentage you type.</td>
<td>30%+P</td>
</tr>
<tr>
<td>/</td>
<td>Divides the current cell value by the number you type.</td>
<td>10/</td>
</tr>
<tr>
<td>*</td>
<td>Multiplies the current cell value by the number you type.</td>
<td>5*</td>
</tr>
<tr>
<td>A</td>
<td>Allocates the value you type equally among all highlighted cells.</td>
<td>150A</td>
</tr>
<tr>
<td>?</td>
<td>Multiplies the value you type by a random positive number.</td>
<td>30?</td>
</tr>
<tr>
<td>-?</td>
<td>Multiplies the value you type by a random negative number.</td>
<td>-30?</td>
</tr>
</tbody>
</table>

Figure 2 shows an example of how you can use the operator keys to edit data. The operator keys are used to increase the values in the Apparel account by 10 percent across all periods.

**Figure 2 Using Operator Keys**

1. Select the data that you want to change.
2. Enter a value followed by an operator key.
Schedule Maintenance

Once you create schedules, you can maintain them by moving, copying, or removing data. You use a schedule to enter or edit data in input accounts for an entity and category. You perform these tasks to maintain data:

- Highlight Data Blocks
- Move Data
- Copy Data
- Remove Data

Highlighting Data Blocks

You can highlight blocks of accounts and periods in a schedule, then modify or enter data in all the highlighted cells at once. You can highlight a row of data, a column of data, a block of cells, or the entire schedule.

To highlight blocks of data, take one of the following actions:

- To highlight an entire row, select an account ID or description in the left column of a row.
- To highlight an entire column, select a period ID at the top of a column.
- To highlight a block of cells, select a specific cell, then drag the cursor until all desired cells are selected.
- To highlight the entire schedule, select the Account column heading.

Moving Data

You can move data from one cell to another or from a block of cells to another block of cells that is the same size. A gray zero appears in the cleared cells, indicating no data. If the Set No Data to Zero option is selected for the schedule, the no data state is converted to a true zero value, which appears in the same font as other values in the schedule. For more information, see “Setting Accounts Without Data to Zero” on page 23.

You cannot move data to or from locked periods, calculated accounts, or consolidated accounts. Locked periods have a Locked icon in the column heading. Calculated and consolidated accounts are color-coded. You can change the default colors of these account cells. For more information, see Hyperion Enterprise Getting Started.

To move data:

1. From the Data Entry window, select the cell or block of cells that contains the data you want to move.
2. Select Edit > Cut.
Select the cell or block of cells into which you want to paste the data. For instructions, see “Highlighting Data Blocks” on page 21.

Select Edit > Paste.

Copying Data

You can copy data from one cell to another or from a block of cells to another block of cells that is the same size. You can copy data from locked periods, calculated accounts, and consolidated accounts. You cannot paste data to locked periods, calculated accounts, or consolidated accounts. Locked periods have a Locked icon in the column heading. Calculated and consolidated accounts are color-coded. You can change the default colors of these account cells. For more information, see Hyperion Enterprise Getting Started.

To copy data:
1. From the Data Entry window, select the cell or block of cells that contains the data you want to copy.
2. Select Edit > Copy.
3. Select the cell or block of cells into which you want to paste the data. For instructions, see “Highlighting Data Blocks” on page 21.
4. Select Edit > Paste.

Removing Data

You can remove data from one cell or a block of cells. When you remove data, the data is deleted from both the schedule and the data table. A gray zero appears in the cleared cells, indicating no data. If the Set No Data to Zero option is selected for the schedule, the no data state is converted to a true zero value, which appears in the same font as other values in the schedule. For more information, see “Setting Accounts Without Data to Zero” on page 23.

You cannot remove data from locked periods, calculated accounts, or consolidated accounts. Locked periods have a Locked icon in the column heading. Calculated and consolidated accounts are color-coded. You can change the default colors of account cells. For more information, see Hyperion Enterprise Getting Started.

To remove data:
1. From the Data Entry window, select the cell or block of cells that contains the data you want to remove. For instructions, see “Highlighting Data Blocks” on page 21.
2. Select Edit > Remove.

Calculating Formulas in Schedules

You calculate formulas in a schedule to see the results of your data entry. If the Auto Recalculate option is selected in the Schedule Options dialog box, data recalculates each time you enter a
value. For faster data entry, deselect the Auto Recalculate option and then input your data. When you save the schedule, the calculated accounts do not contain the new values, but you can recalculate data manually for an entire schedule or for a specific account or period.

**Note:** All periods impacted by a change in data have a status of IMPACTED for consolidation after you enter new data. The period set in the point of view does not impact the periods that the system impacts.

For example, suppose you enter values for the four subaccounts of the major account Sales, and you want to view the new value for the major account. You can recalculate the data to check the new total of the subaccounts. When you save the schedule with Auto Recalculate deselected, formulas are run, and the status of the file is saved. When you later retrieve the file, a formula status icon appears above the period ID to indicate that you need to calculate formulas.

When you work with several schedules at once, you can recalculate the data for the schedule in the active window only. To recalculate the data for another open schedule, you must switch to that schedule's window.

- **To calculate formulas:**
  1. From the **Data Entry** window, select the periods and accounts that contain the data to calculate.
  2. Select **Task > Calculate Formulas**.

**Setting Accounts Without Data to Zero**

The Set No Data to Zero option converts missing data to zeros. If the Set No Data to Zero option is deselected, missing data appears as zeros. If the Set No Data to Zero is selected, zeros appear in normal text.

A period is missing data when it does not have a data value or a zero but there is data in the prior period. When the system processes data, missing data is always considered zero. The Missing Data as Zero category attribute determines whether zero displays as a periodic or year-to-date value in a particular category. This allows derived data based on the zero values to remain the same in different data views. This setting applies only to flow, income, and expense accounts. Balance, asset, and liability accounts are not affected.

Values for periods missing data appear differently depending on the data view. Zero periodic displays a value of zero for the period missing data. Zero year-to-date displays a year-to-date value of zero for the period missing the data. For example, suppose your default data view is periodic and you select Missing Data as Zero and change your data view to year-to-date. If the value for January is 100 and data is missing for February, the system automatically enters a periodic value of -100 for February to give February a year-to-date value of zero.

- **To convert missing data to zeros:**
  1. From the **Data Entry** window, select the period column heading for the period in which you want to convert no data zeros to true zeros.
Tip: To highlight the entire schedule, select the Account column heading.

2 Select Edit > Set No Data to Zero.

Decimal Places Option

When you create an account in the Accounts module, you specify a default number of decimal places for that account. Whenever you view values for that account, the default number of decimal places appears. For example, if you set the Decimals attribute of an account to 0 (zero), the system shows the account's values as whole numbers. If you set the Decimals attribute of an account to 2, the system shows the account's values with two decimal places, such as 6.75. For more information, see the Hyperion Enterprise Administrator's Guide.

In the Data Entry module, you can use the Decimal Places option to override the account's default number of decimal places that appear. The number of decimal places you specify appears for each data value, even if you exit and re-enter the module. A check mark appears next to the number of decimal places you select on the menu. Selecting Default allows you to view the decimal settings originally specified for the account in the Accounts module.

To override the default number of decimal places:

- From the Data Entry window, select View > Decimal Places.

Select the number of decimal places you want to appear, or select Default to use the number of decimal settings specified in the Accounts module.

This chapter provides information and procedures that you need to load and extract data in Hyperion Enterprise applications.

Database Management Overview

Database management is the process of managing data for different entities, categories, accounts, and periods. For example, you can copy and move data between periods. Data load and extract is the process of loading data from or extracting data to external ASCII files.

You can use the Database module to transfer Hyperion Enterprise data between different locations or applications and between Hyperion Enterprise and other systems. For example, you can extract data from various sites and load it into the application at headquarters, or you can load data into Hyperion Enterprise from a general ledger.

When you load or extract data, you use data formats to indicate how Hyperion Enterprise should interpret data from external systems. For example, a data format can specify entity and account conversion tables that match Hyperion Enterprise entities and accounts with entities and accounts in external systems.
You can calculate formulas in the Database window to enter values in calculated accounts. You can also change accounts that have no data to zero values. The lock and unlock features of the Database window allow you to control the ability to change data. You can lock periods to freeze values, and you can unlock them later if you want to change the values or allow users to change them.

**Database Window**

The Database window shows all accounts in the chart of accounts for the selected entity and category. When you first access the Database module, the Database window lists all account groups and indicates whether accounts in the group contain data.

You can select the plus sign (+) to the left of an account group to display its accounts and subaccounts and view their data values. You can also see the status of each period of data in the Database window.

You can perform these tasks in the Database window:

- Load data from or extract data to ASCII text files
- Calculate formulas
- View accounts in an account list or group
- View data for entities in an entity list
- View translation, proportion, elimination, parent adjustments, or contribution values for the current entity
- Find specific accounts, account groups, or periods in the database
- Print or preview specific accounts and periods or all accounts and periods
- Copy, move, or enter data
- Prevent users from editing data in specific periods by locking them
- Erase entire data files

For more information on printing, see *Hyperion Enterprise Getting Started*.

Hyperion Enterprise generates an error message if you try to perform tasks for a schedule point of view in the Database window when another user has it open for the same schedule point of view. This error message is written to the error log. For more information on the error log, see *Hyperion Enterprise Getting Started Guide*.

Figure 3 shows the Database window.
1. The Entity List drop-down list contains the entity list for which you are currently viewing data and status information. It is not available until you use the View > Entity list menu command to select an entity list.

2. The Periods columns show periods for the current category as column headings.

3. The Period status area shows whether the data for the period is locked, locked for journals, or must be recalculated.

4. The Accounts column shows account groups that you can expand to show account and subaccount detail.

5. Each cell contains a value for an account or subaccount, or the data status for an account group.

6. The Formulas area shows any formula that is defined for the account highlighted in the Database window.

7. The Information area shows the current frequency, view, scale, decimal places, parent entity, and display type, such as translation detail.

8. The account area displays the account type, account description, and stored value for the selected period.

For more information on working with tables, see Hyperion Enterprise Getting Started.

Data Status

The Database window shows the data status for individual account groups in each period. Account groups have a data status of DATA or NO DATA.
A status of DATA indicates that data exists for some or all of the accounts in a group for the period. If you expand the group, the system displays the actual account values. A status of NO DATA indicates that no data exists for any account in a group for the period.

The Database window also shows the status for the entire period in the period status area. Table 4 shows the data status icons.

Table 4 | Data Status Icons
--- | ---
Locked icon | The Locked icon indicates that this period was locked using the Lock option. You can view the account data in the locked period, but you cannot modify it.
Journal Locked icon | The Journal Locked icon indicates that either a journal was posted for the current entity in this period or a Journal Lock was manually placed on the current entity in this period. Once you post a journal for an entity, you can modify the entity’s data only by posting additional journals.
Journal Posting Lock icon | The Journal Posting Lock icon indicates that the current entity and period combination has been locked to avoid the posting of journals. Data can be entered manually or loaded, but no journals can be posted to this entity and period combination.
Calculate Formulas icon | The Calculate Formulas icon indicates that data has changed in the period and you must calculate formulas to recalculate account values. Data can change due to manual data entry in schedules, data fills in Database, or data loads. For more information, see “Calculating Formulas in the Database” on page 39.
Impacted icon | The Impacted icon indicates that the data is impacted. This status applies to either translation, proportion, elimination, or contribution values for an entity or parent data. Data can be impacted due to changes in entity data, such as entering data, modifying data, clearing data, or erasing data.

Setting Database Options

You can set options in the Database window to affect how values show in the window for the current session. You set the following database options in the Set Database Options dialog box:

- Whether the system shows account labels or descriptions and account labels and descriptions in the Account column
- The column widths of the Account column and period columns, and how many columns show in the table
- Whether the system calculates formulas for all displayed accounts each time you enter or edit data
- Whether the system shows the formula for a selected account at the bottom of the Database window
- The size and style of the font in the Database window, which determine how many characters show in each column

Note: If multiple instances of the Database window are open, the preferences you specify affect the active window only.

To set database options:

1. From Database, select Task > Set Database Options.
2 Specify whether to display the account label or description or both, whether to calculate formulas, whether to show formulas in the window, and column widths.

Note: The default setting is to display the account label. The preferences you specify in Set Database options are saved when you exit the application.

3 Select Change Font to specify the font, style, and size for the characters in the Database window, then click OK.

4 Click OK.

Database Point of View

The point of view determines the data you work with in the Database window. When you access the Database module, the Database window contains data for the current category, organization, and entity. You can change the database point of view by changing any of these elements.

The scale, frequency, and data view options default to the attributes of the current category. You can change the view of the data that shows in the Database by changing any of these elements.

Note: Changing the scale, frequency, and data view within the Database window affects the current session only.

You can change the scale, frequency, or data view in the Point of View dialog box. For information about the Point of View dialog box, see Hyperion Enterprise Getting Started.

Viewing Entity Lists

You use an entity list in the Database module to manage data for all entities in the list at once. You can move or copy data, lock and unlock periods, or extract data into a text file for all entities in the list.

For example, suppose you want to copy the Budget sales account figures for all North American subsidiaries from March to April. You can select an entity list called NAmerica that contains the North American companies and copy the sales figures from March to April for all entities in the list in one operation.

The Database window shows data for only one entity at a time, but any operation you perform when an entity list is selected affects all entities in the entity list. When you select an entity list, the data for the first entity in the list appears in the window. You can view the data for a different entity in the list by selecting the entity from the Entity List drop-down list.

For more information on copying lists, see “Copying Data” on page 33. For more information on locking and unlocking the database, see “Locking or Unlocking Periods in the Database” on page 37.
To view an entity list:
1 From the Database window, select View > Entity List.
2 Select an entity list.
3 Click OK.

Tip: The drop-down list at the top of the Database window shows the first entity in the entity list. To display data for another entity, select one from the drop-down list.

Viewing Account Groups
You can view the accounts in an account group when you want to work with accounts in a specific group only. For example, if you want to view only asset accounts, you can select the group that contains those accounts.

To view an account group:
1 From the Database window, select View > Account Group.
2 Enter an account group ID or select one from the list.
3 Click OK.

Tip: To return to the chart of accounts view, select View > Chart of Accounts.

Viewing Account Lists
Account lists are sets of accounts that allow you to use specific accounts together. Account lists usually consist of closely related accounts. You can select an account list to display the data for the accounts in that list only.

For example, if you want to view the data for all intercompany accounts, you can select the Interco account list, which includes only intercompany accounts. When you select an account list, the system does not display rows for account groups.

To view an account list:
1 From the Database window, select View > Account List.
2 Type an account list ID or select one from the list.
3 Optional: Select one or more of the following options: Dynamic Lists, Fixed Lists, Fixed Lists with Dynamic Subaccounts, See All Validated.

Note: If you select the See All Validated option, validated accounts that do not contain data display in your account list. This enables you to include these accounts in your data extract task. You can perform multiple data extracts with the account list that includes validated accounts without data, but once you close the account list the See All Validated option is no longer selected.
Click OK.

Tip: To return to the chart of accounts view, select View > Chart of Accounts.

Viewing Consolidation Detail

If you selected the option to store consolidation detail when you created the application, you can view consolidation detail for an entity and its dependents. You can view translation information, proportion detail, elimination detail, parent-level adjustments, and contribution values using the point of view bar.

To view consolidation detail:

1. From the Desktop or a window that uses the point of view, select Edit > Point of View.
2. Select the Consolidation Detail tab, then select the consolidation detail that you want to display, and click OK.

Finding Accounts in the Database

You can find a specific account in the Database window. This might be faster than using the scroll bars or the arrow keys to scroll through the database. If the selected account is in an account group or account list that is collapsed, the system expands the group or list and highlights the account.

If you are viewing accounts from only one account group or account list, you can find accounts only in the currently selected group or list. To find accounts that are not included in the current group or list, you must return to the full chart of accounts view. For information on viewing account groups or account lists, see “Viewing Account Groups” on page 30 and “Viewing Account Lists” on page 30.

To find an account in the database:

1. From the Database window, select Edit > Find > Account.
2. Use the check boxes to filter the list of accounts.
3. Type an account ID or select one from the list.
4. Click OK.

Finding Account Groups or Periods in the Database

You can locate a specific account group or period in the Database window. Finding an account group in the Database window might be faster than scrolling through the chart of accounts to search for an account group, especially if account detail is shown. Finding a period in the Database window is useful if the period columns extend beyond the Database window and might be faster than using the scroll bars or arrow keys to locate a specific period.
To find an account group or period in the database:

1. From the Database window, take one of the following actions:
   - Select Edit > Find > Account Group and enter an account group ID or select one from the list.
   - Select Edit > Find > Period and enter a period ID or select one from the list.

2. Click OK.

Database Maintenance

You can move, copy, or clear blocks of data in the Database window. You can also fill individual cells or a range of cells with one value or with random values. These editing options allow you to manipulate data across entities, categories, and periods. For example, you can copy data from the Actual category to the Budget category. You can also update multiple accounts, periods, and entities. When you perform database operations, you can specify whether you want to automatically calculate formulas for the values you change.

When you select an entity list in the database, any changes to data affect all entities in the list. For example, suppose you select the Base1 entity list, which contains base entities, and you clear the data from the January period for accounts in the Income account group. The system clears the January values for all Income group accounts for all entities in the Base1 entity list.

Note: Any changes that you make to data in the Database window affect consolidation status, which you can view in the Consolidation window. You might need to calculate formulas or reconsolidate your data. For more information on consolidation statuses, see the Hyperion Enterprise Administrator’s Guide.

Highlighting Data Blocks

Before you can edit data, you must first highlight a block of cells. A data block can include cells in one or more adjacent columns or rows. Once you highlight a block, you can perform these tasks:

- Copy or move the values in the data block to another location
- Fill a selected area with the same value or with random numbers
- Clear all values from the block
- Calculate formulas on a highlighted period only

When you select an entity list in the Database, any change to data affects all entities in the list. For example, suppose you select the entity list BaseA, which contains base entities, and you move the data from the February period for accounts in the Income group. The system moves the February values for all Income group accounts for all entities in the BaseA entity list.

To highlight a data block, from the Database window, take one of the following actions:

- To highlight one cell, select only that cell.
To highlight an entire period, select the period ID.

To highlight a single account across all periods, select the account ID.

To highlight the entire database, select the Account column heading.

To highlight a block of data, select any corner of the data, then drag the pointer to the opposite corner.

**Moving Data**

You can move data from one data block to another. For example, suppose you want to move the first-quarter Marketing Expense account values to the third quarter. You can highlight the first-quarter values and cut them from that column, then paste the values in the third-quarter column. This is faster than entering the values in the third-quarter column and then clearing them from the first-quarter column.

When you cut a block, the system copies the block to the Windows clipboard. You can then paste the block to a different location within the database. Consolidation status might be impacted for the data blocks you move. You can view consolidation status in the Consolidation window. You might also need to calculate formulas. For more information on calculating formulas, see “Calculating Formulas in the Database” on page 39.

**Note:** You cannot move data to calculated accounts or locked periods.

To move data:

1. From the Database window, select the cell or block of cells that contains the data you want to move. For instructions, see “Highlighting Data Blocks” on page 32.
2. Select Edit > Cut.
3. To move the data to a different category, select Edit > Point of View, then select Category and a category from the combo box.
4. Select the cell or block to which you want to move the data. The size of the block you are moving from must match the size of the block you are pasting to.
5. Select Edit > Paste.

**Copying Data**

You can copy data from one data block to another. For example, suppose the tax account values you want to enter for the third quarter are the same as the first-quarter values for those accounts. Instead of entering the same values, you can copy them from the first-quarter column to the third-quarter column.

When you copy a block, the system copies the block to the Windows clipboard. You can then paste the block to a different location within the Database window. Consolidation status might be impacted for the data blocks you copy. You can view consolidation status in the Consolidation
window. You might also need to calculate formulas. For more information on calculating formulas, see “Calculating Formulas in the Database” on page 39.

**Note:** You cannot copy data to calculated accounts or locked periods.

When organizations vary by category and period in an application, if you copy data from one period to another while viewing an entity list, the system might copy data from one entity to a different entity. This occurs because the entities and their position in the list can change from one period to another.

To copy data:

1. From the **Database** window, select the cell or block of cells that contains the data you want to copy. For instructions, see “Highlighting Data Blocks” on page 32.
2. Select **Edit > Copy**.
3. To copy the data to a different category, select **Edit > Point of View**, then select **Category** and a category from the combo box.
4. Select the cell or block to which you want to copy the data. The size of the block you are copying from must match the size of the block to which you are pasting.
5. Select **Edit > Paste**.

**Pasting Data**

You can specify a mode, mathematical operation, or value for pasting values from the Windows clipboard to a specific account or range of accounts. For example, you can cut or copy values from any open window and use the Paste Special option to multiply the values in the Windows clipboard by 100 before they are pasted into the database. You could also specify whether to accumulate or replace the values in the data block to which you are pasting values.

Consolidation status might be impacted for the data blocks to which you paste data. You can view consolidation status in the Consolidation window. You might also need to calculate formulas. For more information on calculating formulas, see “Calculating Formulas in the Database” on page 39.

To paste data:

1. From any open window, select **Edit > Cut** or **Edit > Copy**.
2. From the **Database** window, select the cell or block of cells that contains the data you want to cut or copy. For instructions, see “Highlighting Data Blocks” on page 32.
3. Select **Edit > Paste Special**.
4. Specify the mode, operators, and value for pasting values.
5. Click **OK**.
Clearing Data Blocks

You can clear a block of cells and reset their values to NO DATA. This is faster than replacing the existing values with one zero at a time. Consolidation status might be impacted for the data blocks you clear. You can view consolidation status in the Consolidation window. You might also need to calculate formulas. For more information on calculating formulas, see “Calculating Formulas in the Database” on page 39.

**Note:** You cannot clear data from calculated accounts or from locked periods.

To clear a data block:

1. From the **Database** window, select the cell or block of cells that contains the data you want to remove. For instructions, see “Highlighting Data Blocks” on page 32.
2. Select **Edit > Remove**.

Filling the Database

You can fill accounts, periods, or a block of accounts and periods with a specific value or random values. Filling the database with a specific value saves time when you want to enter the same value in all periods of an account, all accounts for a period, or all of the accounts and periods in a data block. For example, you can fill all periods for the FedTax account with the same value.

You can fill the database with random values to test reports. For example, suppose you are writing a report that includes accounts where no value has been entered. You might want to preview the report to see whether its format needs adjustment. The preview will be more realistic if it includes values for the specified accounts. When you finish writing the report, you can edit the database to clear the random values from the accounts.

**Note:** You cannot fill calculated accounts or locked periods with data.

To fill the database:

1. From the **Database** window, select the cell or block of cells that you want to fill. For instructions, see “Highlighting Data Blocks” on page 32.
2. Select **Edit > Fill** and take one of the following actions:
   - To fill with a fixed value, type a value in the **With** text box.
   - To fill with random values, leave the **With** text box blank.
3. Click **OK**.

Erasing Data

You can erase data from the database. When you erase data, all data for the current category and entity is removed from all periods and all data is removed from a data file regardless of the
currently selected account and entity lists. Erasing data is useful if you no longer need to maintain data for a category and entity. Erasing data can free up disk space.

For example, suppose you have been maintaining historical data for the US west entity in the History category. If you no longer need to maintain the historical data, you can erase it.

In the Database module, remove data does not set values for parent level entities to zero. As a workaround, use Erase Data to clear parent level values.

To erase data:
1. From the Database window, select Task > Erase Data.
2. When the system displays a confirmation message, take one of the following actions:
   - To erase all data for the current category and entity, select Yes.
   - To cancel the erase and return to the Database window, select No.

Working with Data Drill-Back to FDM

To work with data drill-back to FDM, enable visual cue, see “Managing Visual Cue for FDM Data”. Set the required POV to view dimensions that contain FDM data.

To drill-back to FDM data
1. In the Hyperion Enterprise Database module, right-click the database cell and select Audit Intersection. The FDM data drill-back page opens.
2. You can gather the required information on the data.
   For more information on the drill-back options, see the FDM documentation.

Managing Visual Cue for FDM Data

A user preference option is provided to set visual cues for demarcating FDM data in Hyperion Enterprise applications. Based on your requirement, you can disable this option. You can set this option from Hyperion Enterprise Desktop or Hyperion Enterprise Database module. However, you cannot manage this option from Hyperion Enterprise Web.

To disable the visual cue for FDM data from the Hyperion Enterprise Database module:
1. In the Hyperion Enterprise Database module, (If visual cue is enabled) right-click on the data cell and select User. The User Preferences screen opens.
2. Select or clear Enable visual cue based on your requirement.
Locking or Unlocking Periods in the Database

You can lock and unlock periods to restrict or permit data changes. You cannot change data in a locked period, but you can consolidate data in a locked period. You can lock periods to freeze values, and you can unlock them later if you want to allow changes to the values. For example, once all data for the January period is entered, you can lock the period until you are ready to run reports to ensure that the data is not changed accidentally.

When you lock a period, the locked status appears in the period status area for that period. For example, if you lock the January period, the locked status appears in the period status area below January. For more information on period status, see “Database Window” on page 26.

You cannot lock or unlock periods for an elimination company. The system locks or unlocks the elimination company when you lock or unlock its parent. For more information on elimination companies, see the Hyperion Enterprise Administrator’s Guide.

You can lock data for a period only if the following conditions are true:

- The calculate formulas status does not appear in the period status area for the selected period. If it does, you must calculate formulas before locking the period.
- All previous periods are locked.
- For a parent entity, all dependents of the entity are also locked. If a parent has dependents that are not locked, the Lock menu item is disabled, and you cannot lock any periods.
- The value in the locking account equals zero, if the current application uses a locking account. For more information, see the Hyperion Enterprise Administrator’s Guide.

You can unlock data for a period only if these conditions are true:

- All subsequent periods are unlocked.
- For a dependent entity, all parents of the entity are also unlocked. If a dependent has parents that are locked, the Unlock item is disabled, and you cannot unlock any periods.

If organization structures in your application vary by category and period, you may not be able to successfully lock a period. This occurs when the period you are trying to lock contains entities that are inactive for one or more prior periods. You must first manually lock the inactive entities in the prior periods, then lock the current period.

To lock or unlock a period in the database:

1. From the Database window, select the period ID for the period you want to lock or unlock.
2. Take one of the following actions:
   - If the period is not locked, select Task > Lock Data.
   - If the period is locked, select Task > Unlock Data.

Journal Posting Lock and Unlock

You can disable posting of journals to any entity and period by placing a journal posting lock on a data file.
When you apply this lock to a data file, data can only be entered manually or through a data load. Changes cannot be made to the data file by posting journal adjustments for the entity and period combination, but unposted journals can be created for the data file as long as they are not posted. The locked status displays in the period status area in the Database window for that period. For example, if you lock the February period, the locked status appears in the period status area below February.

You can place a journal posting lock only if the following conditions are true:

- No journals have been posted to the entity and period combination.
- The entity has the journal flag on.
- The entity and period combination does not have a data lock or journal lock already placed on it.
- You have security rights to do this.

**Locking Impact**

Table 5 illustrates the available Journal, Journal Posting, and Data locks, and how placing a lock impacts the availability of the other locks.

<table>
<thead>
<tr>
<th>Available</th>
<th>The menu item is available.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Not Available</td>
<td>The menu item is greyed out and you cannot select it.</td>
</tr>
<tr>
<td>X</td>
<td>Action taken by user.</td>
</tr>
<tr>
<td>Explicit</td>
<td>Journal lock is placed manually by a user without posting a journal.</td>
</tr>
<tr>
<td>Implicit</td>
<td>Journal lock is placed by the system when the journal is posted.</td>
</tr>
</tbody>
</table>

**Table 5  Locking Impact Table**

<table>
<thead>
<tr>
<th>Action</th>
<th>Explicit</th>
<th>Implicit</th>
<th>Data Lock</th>
<th>Journal Posting Lock</th>
</tr>
</thead>
<tbody>
<tr>
<td>Post a Journal</td>
<td>Not Available</td>
<td>X</td>
<td>Available</td>
<td>Not Available</td>
</tr>
<tr>
<td>Place manual Journal lock</td>
<td>X</td>
<td>Available</td>
<td>Available</td>
<td>Not Available</td>
</tr>
<tr>
<td>Place a Journal Posting lock</td>
<td>Not Available</td>
<td>Not Available</td>
<td>Available</td>
<td>X</td>
</tr>
<tr>
<td>Place a Data lock</td>
<td>Not Available</td>
<td>Not Available</td>
<td>X</td>
<td>Not Available</td>
</tr>
</tbody>
</table>

**Placing a Journal Posting Lock**

To place a journal posting lock:

1. From the **Database** window, select the period that you want to lock.
2 Select Task > Journal Posting Lock.

**Removing a Journal Posting Lock**

To remove a journal posting lock:

1. From the Database window, select the period that you want to unlock.

**Calculating Formulas in the Database**

You can calculate values for all accounts in a specific period or for all accounts and periods in the Database window. The Auto Recalculate option determines whether the system calculates formulas in the Database window when you modify data. When the Auto Recalculate option is selected, the system calculates formulas when data is changed. When the Auto Recalculate option is deselected, the calculate formulas status appears in the period status area for the affected periods. You must then calculate formulas using the Calculate Formulas option.

For example, suppose you clear data values from accounts in the January period in the Database window. The calculate formulas flag appears in the period status area of the January period, and you can use the Calculate Formulas option to recalculate values for the January period. For information on period status indicators, see “Data Status” on page 27. For more information on the Auto Recalculate option, see “Setting Database Options” on page 28.

If you do not calculate formulas before closing the Database window, the calculate formulas status appears the next time you access the Database window and view the same category and entity.

To calculate formulas in the database:

1. From the Database window, take one of the following actions:
   - To select all periods, select the Account column heading, and ensure that no periods are selected.
   - To select a specific period, select the Period ID column heading.
2. Select Task > Calculate Formulas.

**Setting Accounts Without Data to Zero**

You can convert missing data to zero in individual periods. You can also select the Zero No Data check box in the Load dialog box to convert missing data in the load file to zero values in Hyperion Enterprise.

**Note:** Selecting the Zero No Data check box can significantly increase the size of the data categories. This may impact performance.
To set accounts without data to zero:

1. From the Database window, take one of the following actions:
   - To change values in an individual period, highlight the Period column heading.
   - To change values in the entire database, highlight the Account column heading.

2. Select Edit > Set No Data to Zero.

Running Dependent Consolidation Detail Reports

The dependent consolidation detail report lists all immediate dependents and their consolidation detail components for one account value. Consolidation detail components include contribution, proportion, elimination, translation, and parent adjustment detail. This report allows you to track the consolidated data for the cell you select. For example, suppose the consolidated value is 100, and the entity stores consolidation detail. The report might show values of 30, 30, and 40 from the three immediate dependents along with any available consolidation detail for each dependent. If your application has multiple levels, you can run the report for one level at a time. For more information on storing consolidation detail, see the Hyperion Enterprise Administrator’s Guide.

Note: The dependent consolidation report does not attach formulas to accounts during processing, so if the account you select is a dynamic view account, no values appear.

You define the data to include on the report using the point of view bar and the Database window:

- Your point of view setting determines the category and the entity.
- Your selection in the Database window determines the account and period as well as the frequency, view, scale, and decimal information for the data cell you select.

The report includes one account, one period, and one category. Its rows list all immediate dependents of the entity you select using the point of view. Its columns list all the consolidation detail components you select.

Note: The system saves the options you select in the Dependent Consolidation dialog box and displays them the next time you run the dependent consolidation detail report.

You can also customize your report fonts, colors, and page layout. For more information on customizing the report, see Hyperion Enterprise Getting Started.

To run dependent consolidation detail reports:

1. Set the desired point of view. For instructions, see Hyperion Enterprise Getting Started.

2. From the Database window, select the desired account and period.


4. Select the desired consolidation detail options to include.
Select whether to suppress rows that contain no data or zeros.

Take one of the following actions:

- To print the report, select Print.
- To preview the report, select Preview.

**Clearing Invalid Consolidation Detail**

You can clear any invalid consolidation detail for an application in the Database window. The data to be cleared applies to all accounts and entities in all organizations for the category and periods selected. You can view the date and time that the process starts and ends, the categories and periods being processed, and the detail being cleared in the Hyperion Enterprise error log. If the system is unable to clear the consolidation detail, this information is also recorded in the error log.

You can clear consolidation detail if the following conditions are met:

- The application is set to store translation, proportion, elimination, or contribution values for an entity.
- You have security access to the category selected.
- You select at least one period in the Database window.

When the status of data changes to Impacted, it does not mean that consolidation detail is invalid. You can clear consolidation detail only when the data is invalid.

The following are some of the reasons that consolidation detail can be invalid.

- Changes in the category setting: If the Allow Proportion and Elimination Detail check box in the Categories window is deselected, the proportion and elimination detail that was previously generated for the category is no longer valid and must be cleared.
- Changes in the entity setting: If the Store Contribution Detail check box in the Advanced Option tab in the Entities window is deselected, the consolidation detail that was previously generated is no longer valid and must be cleared.
- Changes in the organizational structure: If the entity is removed from the organizational structure, the generated consolidation detail is no longer valid and must be cleared.
- Changes in the currency: If the currencies of the parent and base entity have changed so that they are now the same, the previously generated consolidation detail is no longer valid and must be cleared.

**Note:** If the Translation Detail option was selected when the application was created, the translation detail is generated regardless of the currency setting for the parent and child combination. This data should not be cleared.

- Changes in parent adjustment detail: The system does not clear the parent adjustment detail because journal entries may be associated with the parent. You must unpost the journals to clear parent adjustment data. If parent adjustment detail is no longer valid due to changes
in the organizational structure and no journals are attached, the system clears this parent adjustment detail. A status of journal lock indicates that there are journals attached.

➢ To clear invalid consolidation detail:

1 From the **Database** window, select **Task > Clear Invalid Consolidation Detail**.

2 Specify the category and periods for which you want consolidation detail to be cleared, then click **OK**.

**Data Formats**

You can use data formats when you load data into Hyperion Enterprise from other systems or extract Hyperion Enterprise data for use with other systems. Data formats indicate how Hyperion Enterprise should process the data in these files.

For example, your general ledger might contain data similar to Hyperion Enterprise but in a different format. You can use a load format for the general ledger to specify entity and account conversion tables that match general ledger accounts and entities with Hyperion Enterprise accounts and entities during data load. Here are the data format options you can specify:

- Characters, including the delimiter to use and the character to indicate negative values
- Conversion tables for converting external entities and accounts to Hyperion Enterprise entities and accounts
- Expression for load or extract, including the mathematical operation to perform, and the value by which to multiply or divide values in the text file
- Suppress zero options
- Number of decimal places for extracting data
- File extension
- Scale
- Data view
- Whether to use the load file name or the user ID of the user performing the data load as the name of the error log file
- Whether to extract derived values
- Whether to validate the records in the load file against the records loaded into Hyperion Enterprise

For information on opening, copying, or deleting data formats, see *Hyperion Enterprise Getting Started*.

**Accumulate**

The Accumulate option adds the values in a load file to the values that are already in the application. For example, suppose the database contains values in the Actual category for the USdiv entity’s payroll accounts for periods 1 through 3, as shown in Table 6.
If you use the Accumulate option to load data for the same category, entity, account, and periods, the system adds the load value for each period to the existing value for that period. The following load file specifies the values to be accumulated to each payroll account:

```
ACTUAL
1
3
USDIV, PAYROLL1, 5, 0, 5
USDIV, PAYROLL2, 25, 0, 25
USDIV, PAYROLL3, 5, 0, 5
```

Table 7 shows the result of the data load using the Accumulate option.

### Table 7  Data Load Using the Accumulate Option

<table>
<thead>
<tr>
<th>PAYROLL1</th>
<th>15</th>
<th>10</th>
<th>15</th>
</tr>
</thead>
<tbody>
<tr>
<td>PAYROLL2</td>
<td>35</td>
<td>10</td>
<td>35</td>
</tr>
<tr>
<td>PAYROLL3</td>
<td>15</td>
<td>10</td>
<td>15</td>
</tr>
</tbody>
</table>

**Replace**

The Replace option clears the existing values from all accounts for the periods specified in the data load file and then loads the values from the data load file. If an account is not specified in the load file, its values for the specified periods are cleared during the load. If an account is specified and its value for any period is left blank in the load file, the result of the data load for that account and period is NO DATA. For example, suppose that the database contains the payroll account values for entity USDIV shown in Table 8.

### Table 8  Payroll Accounts in the Database

<table>
<thead>
<tr>
<th>PAYROLL1</th>
<th>10</th>
<th>10</th>
<th>10</th>
</tr>
</thead>
<tbody>
<tr>
<td>PAYROLL2</td>
<td>10</td>
<td>10</td>
<td>10</td>
</tr>
<tr>
<td>PAYROLL3</td>
<td>10</td>
<td>10</td>
<td>10</td>
</tr>
</tbody>
</table>

If you select the Replace option to load data for the same category, entity, account, and periods, the system uses the load value for each period to replace the existing value for that period. The following load file specifies the values to be loaded and replaced for each payroll account:

```
ACTUAL
1
3
```
Table 9 shows the result of the data load using the Replace option.

<table>
<thead>
<tr>
<th>PAYROLL1</th>
<th>NO DATA</th>
<th>NO DATA</th>
<th>NO DATA</th>
</tr>
</thead>
<tbody>
<tr>
<td>PAYROLL2</td>
<td>25</td>
<td>0</td>
<td>25</td>
</tr>
<tr>
<td>PAYROLL3</td>
<td>5</td>
<td>NO DATA</td>
<td>5</td>
</tr>
</tbody>
</table>

**Merge**

The Merge option clears existing values only from the accounts specified in the data load file and then replaces them with the values in the file. Unlike the Replace option, the Merge option clears only the values from the accounts specified in the load file. For example, suppose the database contains the payroll account values for entity USDIV shown in Table 10.

<table>
<thead>
<tr>
<th>PAYROLL1</th>
<th>10</th>
<th>10</th>
<th>10</th>
</tr>
</thead>
<tbody>
<tr>
<td>PAYROLL2</td>
<td>10</td>
<td>10</td>
<td>10</td>
</tr>
<tr>
<td>PAYROLL3</td>
<td>10</td>
<td>10</td>
<td>10</td>
</tr>
</tbody>
</table>

The following load file specifies the accounts and values to be merged during data load:

```
ACTUAL
1
3
USDIV, PAYROLL2, 25, 0, 25
USDIV, PAYROLL3, 5, 0, 5
```

Table 11 shows the result of the data load using the Merge option:

<table>
<thead>
<tr>
<th>PAYROLL1</th>
<th>10</th>
<th>10</th>
<th>10</th>
</tr>
</thead>
<tbody>
<tr>
<td>PAYROLL2</td>
<td>25</td>
<td>0</td>
<td>25</td>
</tr>
<tr>
<td>PAYROLL3</td>
<td>5</td>
<td>0</td>
<td>5</td>
</tr>
</tbody>
</table>

**Calculate Formulas**

You can select the Calculate Formulas check box to run chart methods when you load data. The system then calculates formulas during the data load, so you do not have to manually calculate formulas after the load. If the Calculate Formulas check box is deselected when you load the data file, you must use the Calculate Formulas option to calculate formulas after you load the file. For more information, see “Calculating Formulas in the Database” on page 39.
Report Calculated Accounts

You use the Report Calculated Accounts option if you want the system to track attempts to load data into calculated accounts, which normally derive their values from other accounts. For example, the value in the Net Sales account might be the result of subtracting the value in the Cost of Sales account from the value in the Gross Sales account. If the Report Calculated Accounts option is selected and you attempt to load data into a calculated account, a message appears in the Hyperion Enterprise error log.

Zero No Data

You can select the Zero No Data check box to convert missing data in load files to zero values in Hyperion Enterprise accounts. Hyperion Enterprise converts no data values to zero values only if you load a no data value into an account that has data in a previous period. For example, suppose the Income account has a value of 25 for January. If a load file has missing data for the Income account in February, and the Zero No Data check box is selected, the system assigns a zero for the Income account for February.

Whether zero values are treated as zero periodic or zero category-to-date depends on the load category's Missing Data as Zero option. If you do not want to convert missing data to zero for the entire load file, you can load the file with the Zero No Data option deselected and then use the Set No Data to Zero option to manually convert missing data to zero in individual periods. For more information on converting missing data to zero in individual periods, see “Setting Accounts Without Data to Zero” on page 39.

Load Error File

If the database cannot accept data you attempt to load, the system writes to two files: an .ERR file that stores data that did not load, and an ERROR.LOG file that describes the errors that occurred during data load. The system stores the ERROR.LOG file in the application directory.

Setting data load and extract defaults in the Format dialog box allows you to specify the file name of your data load .ERR reports. The report name can be either the user ID of the person performing the data load or the name of the original load file, with an .ERR file name extension. For example, if you select the Use load file name (*.ERR) check box and the name of the load file is ACTUAL03.DAT, the name for its .ERR file is ACTUAL03.ERR. If you log on to Hyperion Enterprise with the user ID Admin and you do not select this check box, the name for the .ERR file is ADMIN.ERR. You can specify any file name for the .ERR error file in the Load Error File edit box in the Load dialog box.

The system stores the .ERR file by default in the directory from which you loaded the data. You can view an .ERR file with any text editor, such as the Windows Notepad. After you correct the errors, you can load the rejected data from the load error file without reloading all the data in the original load file. For information on loading data, see “Loading Data” on page 46.

You can view the contents of the ERROR.LOG file in the Hyperion Enterprise Error Log dialog box. For information on the error log, see Hyperion Enterprise Getting Started.
Defining Data Formats

You can define data formats for loading or extracting data. For example, if you need to scale the data you load for the HQ site, you can set up a format that scales the data during data load. When you create a data format, you indicate whether it is for loading only, extracting only, or for both loading and extracting.

To define a data format:

1. From the Database window, take one of the following actions:
   - To create a format, select File > New Format.
   - To edit a format, select File > Open Format, then select a format from the list.

2. Specify the ID, description, security class, and format type, then click OK.

Loading Data

You can load data into a Hyperion Enterprise database from an ASCII file. Many external systems, such as general ledgers and spreadsheets, can create ASCII files that you can load into Hyperion Enterprise. If necessary, you can edit an ASCII file with a text editor before loading it.

You load data to transfer Hyperion Enterprise data between different locations, applications, or software packages. For example, you can load data that has been extracted from other sites into an application at headquarters, or you can load data into Hyperion Enterprise from a general ledger.

A load file must specify a category, the first and last periods that receive the data, the entities and accounts that receive the data, and the account values. A load file can contain data for many entities and accounts but only one category. A file can contain data for a range of periods, but the periods must be consecutive.

Note: If an entity and account combination appears more than once in a load file, those values are added together before they are loaded into the database.

Here is the order of the information that must appear in a load file:

- Category
- First period
- Last period
- Entities, followed by account IDs and data values for a range of periods

Load files affect data only in the periods they specify. For example, if a load file specifies periods 1 through 4 for the Actual category, which contains 12 monthly periods, periods 5 through 12 are not affected by the data load.

Here is a sample ASCII load file that specifies entities and accounts in the Actual category for periods 1 through 4:
ACTUAL
1
4
USCORP, SALES1, 100, 200, 300, 400
USCORP, SALES2, 1001, 2001, 3001, 4001
USCORP, SALES3, 1501, 2501, 3501, 4501
USREG1, SALES1, 20100, 501, 0, 0
USREG1, SALES2, 20100, 521, 1021, 1521
USREG1, SALES3, 20100, 501, 1031, 1531

The first line of the sample file specifies the Actual category.
The second line specifies the category's first period as the first period into which the data will be loaded.
The third line specifies the category's fourth period as the last period into which data will be loaded.
The fourth through ninth lines of the sample file each contain entities followed by account IDs and values for each specified period. For example, the fourth line specifies that the values 100, 200, 300, and 400 are to be loaded into the Sales1 account for the entity UScorp. A comma (,) is the delimiter that separates the data elements on each line of this sample load file.

You can use a load format while loading data. Load formats determine how data is loaded into the application. For example, a load format might contain information about the type of delimiter in your load file or which conversion tables to use during data load. You can use the default load format, or you can select any existing load format. You can use the data load format as it is, or you can edit it for the current load session only.

If you are using server-based processing to load data, a window appears that shows the loading progress. This window is a separate program, so you can perform other tasks in Hyperion Enterprise or exit Hyperion Enterprise while the server is processing. The window closes when the server finishes processing or an error message appears if there is a problem.

To load data:
1. From the Database window, select Task > Load Data.
2. Select Add to add the data files that you want to load.
3. In the Load Error File text box, enter a name for the error log file.
4. Select a format for the load file, or select Default to use the system default.
5. To edit the selected load format for this load session only, select Edit, make your changes, then click OK.
6. Specify the mode to load data and select load options.
7. Click OK.
   The Server Options dialog box is displayed.
8. Select Server if the application is server enabled and you want to execute on the server or select Local if selectable and you want to execute on the local workstation.
Extracting Data

You can copy data from the Hyperion Enterprise database into an ASCII file that you can use with another application or at another location. For example, you can extract data from several company sites and then load the extracted files into the application at the company’s headquarters.

You can also extract data to back up your application's data. An extract file specifies the data category, the first and last periods from which the system extracts the data, the entities and accounts that contain the data, and the account values. An extract file can contain data from many entities and accounts but only one category. It can contain data from a range of periods, but the periods must be consecutive. You can extract data from calculated accounts and global accounts. For a sample extract file, see the *Hyperion Enterprise Administrator’s Guide*.

Here is the order of the information that appears in an extract file:

- Category
- First period
- Last period
- Entities, followed by account IDs and data values for a range of periods

You must specify a data extract format to tell the system how to format the data it extracts. You can use the default extract format, or you can select any existing extract format. You can use the data extract format as it is, or you can edit it for the current extract session only.

You can also extract locked data only. To grant the ability to extract locked data, assign the access right LIMITED, VIEW, or MODIFY to the security class assigned to the Extract Locked Data Only task and assign NONE to the security class assigned to the Extract Data task. In the Database window, the Task > Extract command is enabled only if the selected periods are locked. Any data that is not locked is written to the error log. If you assign both tasks the access right LIMITED, VIEW, or MODIFY, all data is extracted whether it is locked or unlocked. For more information on assigning access rights, see the *Hyperion Enterprise Administrator’s Guide*.

If you are using server-based processing to extract data, a window appears that shows the extracting progress. This window is a separate program, so you can perform other tasks in Hyperion Enterprise or exit Hyperion Enterprise while the server is processing. The window closes when the server finishes processing or an error message appears if there is a problem.

To extract data:

1. From the Database window, highlight the data that you want to extract.
2. Select Task > Extract Data.
3. Type the file name for the extracted data, or click Browse to find the file.
4. From the Format drop-down list, select a format for the extract file or select Default to use the default format.
5. To edit the selected extract format for this extract session only, click Edit, make your changes, then click OK.
6. Select whether to extract calculated, global, or dynamic view accounts.
7. Click OK.
The Server Options dialog box is displayed.

Select **Server** if the application is server enabled and you want to execute on the server or select **Local** if selectable and you want to execute on the local workstation.

**Extracting Consolidation Detail**

You can extract consolidation detail for one or more branches within a branch. The parent selection of the branch is based on the default entity set in the point of view. The account and period selections are based on the accounts and periods highlighted in the Database window. The category of data to extract is based on the default category set in the point of view.

You can select the following consolidation detail to extract: translation, proportion, elimination, parent adjustment, and contribution. The system extracts all the consolidation detail for each parent and child combination. For example, if you extract translation and proportion detail, the system extracts this detail for the current parent and child, then extracts the detail for the next child of the same parent. After the system extracts consolidation detail for all children for the current parent, the system extracts consolidation detail for the next parent and child combination.

The system extracts consolidation detail based on the scale of the parent. If the currency for the parent and the child is the same, the system does not extract translation even if you select to extract it.

After you select the detail that you want to extract, you can specify whether to format your output for an external application or for Hyperion Enterprise. You select the Format for external application option when you want to extract data to be used with another application such as Microsoft Access server. You select the Format for Hyperion Enterprise option when you want to extract data to be used with Hyperion Enterprise. To create a format that is valid for Hyperion Enterprise, the system concatenates the parent, entity, and consolidation detail into one entity ID.

For example, suppose you want to create a file for the organization structure shown in Figure 4.
In the following sample output file, the parent is GROUP1, the dependent entities are A and B and the consolidation detail settings are translation (T) and proportion (P):

**ACTUAL**

```
1 3
GROUP1 | A | T , SALES1, 100, 150, 190
GROUP1 | A | T , SALES2, 110, 200, 300
GROUP1 | A | T , SALES3, 200, 650, 790
GROUP1 | A | P , SALES1, 100, 150, 190
GROUP1 | A | P , SALES2, 110, 200, 300
GROUP1 | A | P , SALES3, 200, 650, 790
GROUP1 | B | T , SALES1, 110, 200, 300
GROUP1 | B | T , SALES2, 200, 650, 790
GROUP1 | B | P , SALES1, 160, 280, 800
GROUP1 | B | P , SALES2, 500, 650, 990
GROUP1 | B | P , SALES3, 310, 260, 370
GROUP2 | C | T , SALES1, 120, 400, 800
GROUP2 | C | T , SALES2, 220, 500, 870
GROUP2 | C | T , SALES3, 320, 600, 890
GROUP2 | C | P , SALES1, 210, 400, 600
GROUP2 | C | P , SALES2, 550, 460, 900
GROUP2 | C | P , SALES3, 230, 430, 800
```

To extract consolidation detail:

1. From the **Database** window, select **Task > Extract Consolidation Detail**.
2. Select an extract consolidation detail option:
   - To extract all entities for all levels of the parent starting from the current parent set in the point of view, select **Current Group** and All Subgroups.
To extract individual entities, select Current Group Only and select individual entities from the list box.

To extract all the entities for the group for the immediate level only, select Current Group Only and select Select All.

3 Select the consolidation detail options you want to extract.

4 Select whether to format for an external application or for Hyperion Enterprise.

5 If you selected to format for Hyperion Enterprise, specify the concatenation character in the Entity Concatenation Character text box.

Note: You must not use the same character for concatenation as for the format delimiter.

Validation of Records in Data Load and Extract

You can validate the records in a load file against the records loaded into Hyperion Enterprise. When you validate records, the system assigns an internal number to each record contained in the load file, then calculates a control total that is entered at the beginning of the file. During data load, the system again calculates the control total for the records in the file, then validates this number against the number originally calculated. If the numbers match, the data load processes.

The internal control number for a record in the load file changes if you manually change the record. Therefore, the original control total does not equal the control total recalculated on data load. When the totals do not match, you receive an error message in the error log to warn you that one or more records has changed since being extracted, and the data does not load.

If you select the Require Checksum option but the load file does not contain the control number, you receive an error in the error log and the load does not process. You must deselect the Require Checksum option to process the data load. If you do not select the Require Checksum option and the load file contains a control total, the system validates this number and warns you if the control numbers do not match.

Running Entity Detail Report

You can run a report of entity detail information for a specific entity. The entity detail is based on the entity selected in the point of view. This detail can include immediate dependents or all dependents of the entity, account balances and related subaccount information for the single account from a single period highlighted on the Database window, related journal entry detail, and consolidation detail information.

If an application that uses Statutory Consolidation Engine (SCE) processing is set up to store consolidation transaction detail, you can view such information on the Entity Detail report. The information you see is described in this topic. For information on setting up an application to store consolidation transaction detail, see the Hyperion Enterprise Statutory Consolidation Engine (SCE) Guide.
After you select the type of detail that you want to view in the report, you can select whether to suppress rows that contain zero or no data and specify a report scale. When you select the default scale, all consolidation detail components use the Parent scale. When you select a specific scale, the report displays each amount in the scale factor selected.

You define the data to include on the report using the point of view bar, Database window, and Entity Detail Report dialog box:

- The category and entity that the system uses is based on the point of view bar settings.
- The account and period that the system uses is based on the account that you highlight in the Database window.
- The report scale value is based on the point of view bar setting. For example, suppose the scale value from the Database module is set to 3. When you access the Entity Detail Report dialog box, the default report scale is 3. You can, however, use the Report Scale drop-down list box to change the scale value.

**Note:** The system saves the options you select in the Entity Detail Report dialog box to your hypent.ini file and uses these settings the next time you access the dialog box or log on to the system. The system does not, however, save the Report Scale or Parent options you select.

You can customize your report fonts, colors, and page layout. For more information on customizing the report, see *Hyperion Enterprise Getting Started*.

*Figure 5* show a sample organization and sample entity detail reports.
Figure 5  Entity Detail Report Structure

Selected options for Sample Report 1, shown in Figure 6:

- Point-of-view entity is Group1
- Account is SALES
- Show only immediate dependents
- Do not expand columns
- Allow rows with zero or no data to appear
- Do not show consolidation detail
Selected options for Sample Report 2, shown in Figure 7:

- Point-of-view entity is Group1
- Account is SALES
- Show all dependents
- Expand columns to show journal entries
- Allow rows with zero or no data
- Show consolidation detail
To run an entity detail report:

1. Set the point of view for the category and entity. For instructions, see *Hyperion Enterprise Getting Started*.
2. From the Database window, select one account from one period.
4. Select whether to include immediate dependents only or all dependents.
5. Select the column expansion options you want to include.
6. Select a report scale from the Report Scale drop-down list or use the default report scale.
7. Select whether to suppress rows if a row does not contain data or contains only zero values.
8. Select whether to show consolidation details for a parent entity.
9. Select the immediate parent for the entity from the Select Parent drop-down list.
10. Take one of the following actions:
    - To print the report, select Print.
    - To preview the report, select Preview.
Decimal Places Option

When you create an account in the Accounts module, you specify a default number of decimal places for that account. Whenever you view values for that account, the default number of decimal places appears. For example, if you set the Decimals attribute of an account to 0 (zero), the system shows the account’s values as whole numbers. If you set the Decimals attribute of an account to 2, the system shows the account's values with two decimal places, such as 6.75. For more information, see the Hyperion Enterprise Administrator’s Guide.

In the Database module, you can use the Decimal Places option to override the account’s default number of decimal places that appear. The number of decimal places that you specify remains in effect until you change it. A check mark appears next to the number of decimal places you select on the menu. Selecting Default allows you to view the decimal settings originally specified for the account in the Accounts module.

To override the default number of decimal places:

1. From the Database window, select View > Decimal Places.
2. Take one of the following actions:
   - Select the number of decimal places to be displayed.
   - Select Default to use the number of decimal settings specified in the Accounts module.
What Hyperion Retrieve Does

Hyperion Retrieve provides the analysis, graphics, and presentation capabilities of spreadsheet software to Hyperion Enterprise. With Hyperion Retrieve, you can access Hyperion Enterprise data from Microsoft Excel worksheets. You can then use the spreadsheet software to analyze and manipulate the data and produce reports and graphs.

Note: In addition to the standard Hyperion Retrieve for Microsoft Excel, you can use Hyperion Retrieve for Microsoft Excel written with Visual Basic for Applications (VBA). For more information, see “VBA Hyperion Retrieve” on page 67.

You can use Hyperion Retrieve with multiple Hyperion Enterprise applications. For example, you can retrieve data from both the Products application and the Tax application for use in the same worksheet.

Hyperion Retrieve Setup

Before you use Hyperion Retrieve with a spreadsheet program, you must perform the following tasks:
• Create an `hpapp.dat` file. The `HPAPP.DAT` file contains information about each Hyperion Enterprise application you want to access with Hyperion Retrieve. For more information, see “HPAPP.DAT File Format” on page 58.

• Set up the HPAPP.DAT environment variable. For more information, see “Setting Up the HPAPP.DAT Environment Variable” on page 58.

• Place the Hyperion Retrieve add-in file in the correct subdirectory. For more information, see “Hyperion Retrieve Add-in File Locations” on page 59.

**HPAPP.DAT File Format**

Before you can run Hyperion Retrieve, you must create a file called `HPAPP.DAT`. The `HPAPP.DAT` file contains the application ID and an optional user ID for each application that you want to access with Hyperion Retrieve and may be stored in any directory.

**Note:** `HPAPP.DAT` must be in all capital letters in system variables.

You can create or edit an `HPAPP.DAT` file with a text editor. Use this format:

\[Application1,User1 \ldots Applicationn,Usern\]

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Application1</td>
<td>The ID of the first application you want to access with Hyperion Retrieve.</td>
</tr>
<tr>
<td>User1</td>
<td>Your user ID for the first application you want to access with Hyperion Retrieve (optional).</td>
</tr>
<tr>
<td>Applicationn</td>
<td>The ID of the last application you want to access with Hyperion Retrieve.</td>
</tr>
<tr>
<td>Usern</td>
<td>Your user ID for the last application you want to access with Hyperion Retrieve (optional).</td>
</tr>
</tbody>
</table>

For example, suppose you want to use Hyperion Retrieve to access data from the Products and Tax applications. If your user ID for both applications is ABC, the `HPAPP.DAT` file in your 1-2-3 or Excel program directory would look like this:

\[PRODUCTS,ABC\]
\[TAX,ABC\]

Hyperion Retrieve will prompt for the user ID if it is not specified in the `HPAPP.DAT` file. Here is an `HPAPP.DAT` file without user IDs:

\[PRODUCTS\]
\[TAX\]

**Setting Up the HPAPP.DAT Environment Variable**

`HPAPP.DAT` files contain the applications to which a user has access when using Hyperion Retrieve with Excel. You can set up `HPAPP.DAT` as an environment variable in the `autoexec.bat` file and use the same `HPAPP.DAT` file for Excel. You do not need to name this file `HPAPP.DAT`. For example, you can create several unique files that contain different Hyperion...
Enterprise applications. You can then name them user1.dat and user2.dat and assign these unique files to the appropriate users by changing their autoexec.bat files. You might also want to restrict or permit access to certain applications by assigning different HPAPP.DAT. files to different users.

You can use the environment variable in a network installation to allow users to share worksheets and have their own HPAPP.DAT. file. For example, you can create an Hyperion Retrieve worksheet and store it on one of your network drives. User1 can use the worksheet with APP1 and APP2, as specified in the user1.dat file. User2 can use the same worksheet with APP3, as specified in the user2.dat file.

Add this line to your AUTOEXEC.BAT file:

SET HPAPP.DAT = Path\Filename

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Path</td>
<td>The path that contains your HPAPP.DAT. file</td>
</tr>
<tr>
<td>Filename</td>
<td>HPAPP.DAT. or the name of the file that contains the Hyperion Enterprise applications you want to use with Hyperion Retrieve.</td>
</tr>
</tbody>
</table>

### Hyperion Retrieve Add-in File Locations

Before you run Hyperion Retrieve, make sure that all add-in files have been installed into the Hyperion Enterprise program directory. Table 12 lists the available spreadsheet programs and the corresponding add-in file names.

<table>
<thead>
<tr>
<th>Product</th>
<th>Add-in File</th>
</tr>
</thead>
<tbody>
<tr>
<td>Excel for Windows version 7.0 (Office 95)</td>
<td>rhxl32.xll</td>
</tr>
<tr>
<td>Excel 97 (Office 97)</td>
<td>rhxl32.xll</td>
</tr>
</tbody>
</table>

### Setting Up Hyperion Retrieve for Microsoft Excel

To set up Hyperion Retrieve for Excel, you must create a shortcut to the RHXLL32.XLL file. When you click on the shortcut icon, Excel 1-2-3 accesses Hyperion Retrieve.

### Starting Hyperion Retrieve for Excel

If you select the Hyperion Retrieve for Excel option when you install Hyperion Enterprise, the system creates a Hyperion Retrieve for Excel icon. Before you start the program, be sure that you have set up Hyperion Retrieve properly. It is recommended that you exit Hyperion Enterprise before you start Hyperion Retrieve. For more information, see "Hyperion Retrieve Setup" on page 57.
The system prompts you for all applications listed in your HPAPP.DAT file. When you have accessed or canceled all the applications listed in your HPAPP.DAT file, the RHXL menu appears on the Excel menu bar.

To start Hyperion Retrieve for Excel, start Excel by clicking on the shortcut icon that you created during Hyperion Retrieve setup. The system prompts you for the user ID and password for each application listed in the HPAPP.DAT file. If your user ID is specified in the HPAPP.DAT file, the system prompts you only for the password.

Displaying No Data as Zero Option

The default setting for displaying no data in Hyperion Retrieve is #NA. You can change this setting to display no data as zero by changing the user preferences in Hyperion Enterprise.

To display no data as zero:

1. From an Hyperion Enterprise application, select File > Preferences > User.
2. Select Display No Data as Zero.
3. Click OK.

Hyperion Retrieve Formulas

When you use Hyperion Retrieve with either Microsoft Excel, you can create formulas for retrieving and manipulating various types of Hyperion Enterprise data. Formulas consist of functions, which specify what types of data you want to retrieve, and arguments, which contain data or identify the data you want to retrieve.

Hyperion Retrieve formulas are like Microsoft Excel formulas except for the following differences:

- Formulas use Hyperion Retrieve functions rather than standard Excel functions.
- Arguments relate specifically to Hyperion Enterprise application elements.

This example shows a formula with the HPVAL function followed by several arguments:

```
HPVAL("USOPS", "ACTUAL", "SALES", "MAR 02", "QYTD", "TAX")
```

In the previous formula, the function HPVAL tells the system to retrieve a value for the US Operations entity, the Actual category, the Sales account, and the March 2002 period with the quarterly year-to-date view, from the Tax application.

Note: If you delete an entity in Hyperion Enterprise, the information for that entity is still retrieved until you purge the entity.
Hyperion Retrieve Arguments

Hyperion Retrieve formulas include arguments that identify Hyperion Enterprise applications and application elements, such as entities and categories. Arguments, which follow functions in a formula, are separated by commas and enclosed in parentheses. An argument can consist of text, such as an account ID, or cell references. You must enclose text in double quotation marks (" ").

Using cell references is usually faster and easier than typing all the information for the argument. For example, suppose a function requires an argument to specify a category, and the ID of the category you want to specify appears in cell D5. You can type either the category ID or the cell reference, D5, as the argument. When you use cell references, you do not enclose them in quotation marks.

Tip: In an Excel worksheet, you do not need to specify an application in an argument to retrieve data from the default application.

Hyperion Retrieve Functions

Every Hyperion Retrieve formula includes a Hyperion Retrieve function followed by an argument, which identifies the data you want to retrieve and the application that contains it. Some functions retrieve the IDs or descriptions of application elements, such as entities and categories. Others retrieve specific values or make calculations based on specific values.

In an Excel worksheet, an equal sign (=) must precede each function. Table 13 describes each Hyperion Retrieve function and its purpose. For detailed information and examples of Hyperion Retrieve functions, see the Hyperion Retrieve Functions chapter.

<table>
<thead>
<tr>
<th>Function</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>HPACC</td>
<td>Retrieves the ID for a specified account.</td>
</tr>
<tr>
<td>HPAMJ</td>
<td>Retrieves the major account ID for a specified account.</td>
</tr>
<tr>
<td>HPAS1</td>
<td>Retrieves the first-level subaccount ID for a specified account.</td>
</tr>
<tr>
<td>HPAS2</td>
<td>Retrieves the second-level subaccount ID for a specified account.</td>
</tr>
<tr>
<td>HPBET</td>
<td>Calculates the difference between two account values and shows the difference as a positive or negative number.</td>
</tr>
<tr>
<td>HPCAL</td>
<td>Returns a 1 if a specified account is a calculated account, or a -1 if it is not.</td>
</tr>
<tr>
<td>HPCDE</td>
<td>Retrieves the description for a specified category.</td>
</tr>
<tr>
<td>HPCONTRIB</td>
<td>Retrieves contribution data.</td>
</tr>
<tr>
<td>HPCUR</td>
<td>Retrieves the currency ID for a specified entity.</td>
</tr>
<tr>
<td>Function</td>
<td>Purpose</td>
</tr>
<tr>
<td>------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>HPDCTRL</td>
<td>Retrieves either the number of voting shares owned or the percentage directly controlled, depending on whether you input shares as units or percentages.</td>
</tr>
<tr>
<td>HPDOWN</td>
<td>Retrieves either the number of shares that the partner directly owns or a direct ownership percentage, depending on whether you input shares as units or percentages.</td>
</tr>
<tr>
<td>HPDRV</td>
<td>Adds the values of a specified income, expense, or flow account for two periods and returns the sum.</td>
</tr>
<tr>
<td>HPECODE</td>
<td>Retrieves the entity code.</td>
</tr>
<tr>
<td>HPELIM</td>
<td>Retrieves elimination data.</td>
</tr>
<tr>
<td>HPFLW</td>
<td>Displays a 1 if a specified account is a flow account, or a -1 if it is a balance account.</td>
</tr>
<tr>
<td>HPFNA</td>
<td>Retrieves the first entity description for a specified entity.</td>
</tr>
<tr>
<td>HPFRE</td>
<td>Retrieves the ID for the default frequency of a specified category.</td>
</tr>
<tr>
<td>HPFSN</td>
<td>Retrieves the subentity description for a specified entity.</td>
</tr>
<tr>
<td>HPFUL</td>
<td>Retrieves the description for a specified entity.</td>
</tr>
<tr>
<td>HPHEA</td>
<td>Retrieves the description for a specified account.</td>
</tr>
<tr>
<td>HPHMJ</td>
<td>Retrieves and shows the major account description for a specified account.</td>
</tr>
<tr>
<td>HPHS1</td>
<td>Retrieves the first-level subaccount description for a specified account.</td>
</tr>
<tr>
<td>HPHS2</td>
<td>Retrieves the second-level subaccount description for a specified account.</td>
</tr>
<tr>
<td>HPINC</td>
<td>Returns a 1 if a specified account is an income or liability account, or a -1 if it is a balance, flow, expense, or asset account.</td>
</tr>
<tr>
<td>HPINP</td>
<td>Returns a 1 if a specified account is an input account, or a -1 if it is not.</td>
</tr>
<tr>
<td>HPJAC</td>
<td>Retrieves the account for a specified journal detail row.</td>
</tr>
<tr>
<td>HPJCR</td>
<td>Retrieves the credit value for a specified journal detail row.</td>
</tr>
<tr>
<td>HPJDB</td>
<td>Retrieves the debit value for a specified journal detail row.</td>
</tr>
<tr>
<td>HPJDS</td>
<td>Retrieves the journal description.</td>
</tr>
<tr>
<td>HPJEN</td>
<td>Retrieves the entity for a specified journal detail row.</td>
</tr>
<tr>
<td>HPINO</td>
<td>Retrieves the number that was assigned to the journal by the system.</td>
</tr>
<tr>
<td>HPJST</td>
<td>Retrieves the journal status.</td>
</tr>
<tr>
<td>HPKEY</td>
<td>Retrieves the ID for the default account, entity, category, or period as specified.</td>
</tr>
<tr>
<td>HPLNK</td>
<td>Retrieves a data value from a spreadsheet to the Hyperion Enterprise database for a specified entity, category, account, period, and frequency.</td>
</tr>
<tr>
<td>HPNAM</td>
<td>Retrieves and shows the ID for a specified entity.</td>
</tr>
<tr>
<td>Function</td>
<td>Purpose</td>
</tr>
<tr>
<td>----------</td>
<td>---------</td>
</tr>
<tr>
<td>HPNNA</td>
<td>Retrieves the first entity ID for a specified entity.</td>
</tr>
<tr>
<td>HPNSN</td>
<td>Retrieves the subentity ID for a specified entity.</td>
</tr>
<tr>
<td>HPPARADJ</td>
<td>Retrieves parent adjustment data.</td>
</tr>
<tr>
<td>HPPBE</td>
<td>Calculates the percentage difference between two account values and shows the difference as a positive or negative number.</td>
</tr>
<tr>
<td>HPPCH</td>
<td>Returns the percentage change between two values without evaluating whether the change is positive or negative.</td>
</tr>
<tr>
<td>HPPCONS</td>
<td>Retrieves the ultimate percent consolidated.</td>
</tr>
<tr>
<td>HPPOWN</td>
<td>Retrieves the ultimate percent ownership.</td>
</tr>
<tr>
<td>HPPROP</td>
<td>Retrieves proportional data.</td>
</tr>
<tr>
<td>HPSCA</td>
<td>Retrieves the scaling factor for a specified entity, category, and account.</td>
</tr>
<tr>
<td>HPSHAROS</td>
<td>Returns the total shares issued.</td>
</tr>
<tr>
<td>HPSHAROW</td>
<td>Returns the total shares owned by other entities.</td>
</tr>
<tr>
<td>HPTRAN</td>
<td>Retrieves translation data.</td>
</tr>
<tr>
<td>HPVAL</td>
<td>Retrieves and shows a data value for a specified entity, category, account, period, frequency, and application.</td>
</tr>
<tr>
<td>HPVSHAROS</td>
<td>Returns the total voting shares issued.</td>
</tr>
<tr>
<td>HPVSHAROW</td>
<td>Returns the total voting shares owned by other entities.</td>
</tr>
</tbody>
</table>

**Pasting Functions in Excel**

Excel includes a Paste Function option that you can use to select Hyperion Retrieve functions and paste them in formulas. When you use this option to paste a function in an Excel worksheet, you can also paste placeholders for the arguments that must follow the function. For more information on the Paste Function option, see the *Microsoft Excel User's Guide.*

Figure 8 shows an Excel worksheet with a formula that uses the HPVAL function and placeholders for the arguments that it requires.
To paste a function in Excel:

1. From the Excel worksheet cell where you want to paste a function, select **Edit > Paste Special**.
2. Select **Formula**, then select **Hyperion Retrieve**.
3. Select a formula, then click **Paste**.

### Hyperion Retrieve Worksheets

You build Hyperion Retrieve worksheets the same way you build Excel worksheets, except that you can use Hyperion Retrieve formulas in addition to Excel formulas. You can also use the RHXL menu in Excel in addition to the Excel menus.

When you use Hyperion Retrieve, you have access to all the functions and features of Excel. You can build templates to create many different worksheets. For example, you can build a template for worksheets that contain periodic account values for a given entity and category.

**Figure 9** show Hyperion Retrieve templates created in Excel.
You can open a template, add account IDs, and specify arguments for the formulas it contains. After you add account IDs and arguments to the template, you can save it under a different name to create a worksheet without changing the template.

Figure 10 shows an Excel worksheet, based on the template in the previous figure, that contains account values for the Actual category and the Spain entity.
When you create a worksheet from a template, you must save the worksheet under a file name that is different from the file name of the template. This leaves the template intact so that you can use it to create other worksheets. For more information on working with templates in Excel, see the *Microsoft Excel User’s Guide*.

**Selecting IDs in Hyperion Retrieve**

You can use the RHXL menu in Excel to select IDs of entities, categories, accounts, periods, and frequencies to use as column or row headings or in formulas. For example, if you want to create a worksheet using Actual data for Israel, you can use the RHP or RHXL menu to select the Israel entity and the Actual category for the worksheet’s title, column headings, or row headings. You can then use references to those cells as arguments in formulas.

To select an ID:

1. From a cell where you want to insert or replace a heading, select the **RHP** or **RHXL** menu option for the type of ID that you want to show:
   - To show an entity ID, select **Change Entity**.
   - To show a category ID, select **Change Category**.
   - To show an account ID, select **Change Account**.
   - To show a period ID, select **Change Period**, then select the category that contains the period you want to show.
   - To show a frequency ID, select **Change Frequency**.
To show a journal ID, select Change Journal.
To show a journal detail ID, select Change Journal Detail.

2 Select the ID that you want to show.

Refreshing Worksheets

You can refresh a worksheet to ensure that it contains the latest values from Hyperion Enterprise. For example, suppose that after you retrieve values from the application for a worksheet, you change some of those values in Hyperion Enterprise. You can refresh the worksheet to retrieve the current values and update the worksheet. You can refresh an entire worksheet at one time, or you can refresh the data in selected rows or columns only.

To refresh a worksheet, take one of the following actions:
- To refresh selected values, select the rows or columns that you want to refresh, then select RHXL > Refresh in Excel.
- To refresh an entire worksheet, select RHXL > Refresh in Excel.

Changing the Default Application

When you start Hyperion Retrieve, the default application is the first one that you open from the Hyperion Enterprise Login dialog box. You can change the default application to any other application that you have opened.

To change the default application:
1 From the worksheet, select the Change Application option.
2 To change the default application from Excel, select RHXL > Change Application.
3 From the Application list box, select the application that you want to use as the default application, then click OK.

VBA Hyperion Retrieve

In addition to the standard Hyperion Retrieve for Microsoft Excel, you can use the VBA version of Hyperion Retrieve for Microsoft Excel written with Visual Basic for Applications (VBA). This version supports applications developed using double-byte systems. The original version of Hyperion Retrieve does not support double-byte systems, such as Japanese or Korean, because Microsoft no longer supports the double-byte extensions of several legacy functions that Hyperion Retrieve uses.

The VBA version of Hyperion Retrieve also gives you all the features and functionality of the traditional Hyperion Retrieve, as well as two new functions:
- Refresh All Linked Cells. For more information, see “Refreshing All Linked Cells” on page 69.
Convert Workbook. For more information, see “Converting Workbook” on page 69.

The following features or functions behave slightly differently in the VBA version of Hyperion Retrieve.

- The argument Application in Hyperion Retrieve functions is now App, and the argument value in the HPLNK function is now Value1.
- In the Function Wizard, optional arguments are displayed in a different font than required arguments.
- When you select the XLAutoRefresh option in the VBA version of Hyperion Retrieve, Microsoft Excel recalculates the HPVAL function whenever anything on the spreadsheet is recalculated. The XLAutoRefresh option is off by default. To set the option, add the following line to the [Default] section of the HypEnt.ini. file:

  XLAutoRefresh=1

- Messages written to the error log at the beginning and completion of a Refresh no longer include the current point of view settings. Instead, the messages indicate the workbook:worksheet[:range] that was refreshed. These messages are also written to the error log when beginning and completing the Refresh All Linked Cells and Convert Workbook tasks.
- The Change Journal Detail... menu item is enabled only when you have used Change Journal... to select a journal for the current application. The Change Journal Detail... menu item is disabled if you have not selected a journal for the current application or if you canceled the Change Journal... dialog box.

  **Note:** Clicking Cancel on the Change Journal Detail... dialog box does not change the contents of the active cell (whereas the RHXLL32.XLL add-in puts -1 in the active cell when this is done).

- If you have Microsoft Excel’s calculation option set for automatic calculation, Microsoft Excel automatically recalculates the whole workbook whenever you open the workbook. If you have Microsoft Excel’s calculator option set for manual calculation, Microsoft Excel displays FALSE in each refreshed cell when you refresh. To avoid this, press F9 to recalculate the spreadsheet.

The following files are installed and used with the VBA version of Hyperion Retrieve

- HERETREV.XLA
- HEEXCEL.DLL
- the appropriate language HERES.DLL

**Setting Up VBA Hyperion Retrieve**

Before running the VBA version of Hyperion Retrieve, you must perform the same setup procedures as you do when setting up the traditional version of Hyperion Retrieve. For instructions for setting up the traditional version of Hyperion Retrieve for Microsoft Excel, see “Hyperion Retrieve Setup” on page 57.
Starting VBA Hyperion Retrieve

After completing the Hyperion Retrieve Setup, create a desktop shortcut to HERETREV.XLA file to run the VBA version of Hyperion Retrieve. Do not start the traditional version of Hyperion Retrieve RHXLL32.XLL file if you want to work with the VBA version of Hyperion Retrieve.

**Note:** Microsoft Excel displays a message when you start the VBA version of Hyperion Retrieve informing you that the spreadsheet contains macros (unless you have suppressed this Microsoft Excel option). You must select Enable Macros to use Hyperion Retrieve.

To start the VBA version of Hyperion Retrieve:

1. Start Excel by clicking on the shortcut icon that you created during Hyperion Retrieve setup.
2. Respond to the system prompts for a user ID and password for each application listed in the HPAPP.DAT file.

**Note:** If your user ID is specified in the HPAPP.DAT file, the system prompts only for the password.

Refreshing All Linked Cells

Microsoft Excel attaches the path of the Hyperion Retrieve program directory at the beginning of any add-in function within a worksheet. If you open a worksheet using a computer that had Hyperion Retrieve stored in a different program directory than the computer last used to save the worksheet, Microsoft Excel prompts you to update the links. When prompted, you must select No and use the Refresh All Linked Cells option to refresh the links. When you select No, #NAME? is displayed in all cells that use Hyperion Retrieve functions and prepends the previous computer’s Hyperion Retrieve program directory in the formula itself. When you use the Refresh All Linked Cells feature, Microsoft Excel finds the current program directory and removes the previous path from the worksheet.

For example, user A has Hyperion Retrieve installed in C:\HYPERION SOLUTIONS and saves a Hyperion Retrieve spreadsheet. User B later opens the same spreadsheet on a different computer, which has Hyperion Retrieve installed in D:\PROGRAM FILES\HYSOL. User B sees #NAME? in a cell of the spreadsheet, with =’C:\HYPERION SOLUTIONS\HERetrev.xla’! HPVAL($B$2,$B$3,$A5,$B$4,$c$3,$B$1) as the contents of the cell. User B must select the Refresh All Linked Cells option, which refreshes the path to the program directory of Hyperion Retrieve currently being used.

To refresh all linked cells, select RHXL > Refresh All Linked Cells.

Converting Workbook

When you open a workbook that was created using the traditional Hyperion Enterprise Retrieve, you must refresh the path to the VBA version of Hyperion Retrieve so that the functions can be
found. The Convert Workbook option helps Microsoft Excel find the Hyperion Retrieve functions in the new add-in.

➢ To convert a workbook, select RHXL > Convert Workbook.
Consolidating Data

In This Chapter

Consolidation Overview ............................................................................................................. 71
Consolidation Window .............................................................................................................. 76
Consolidation Tasks ............................................................................................................... 77
Intercompany Matching Reports ............................................................................................ 83

This chapter provides information and procedures for consolidation, which is the process of gathering data from dependants and rolling it up to parents.

Consolidation Overview

Consolidation is the process of gathering data from dependent entities and rolling it up into a parent entity. During consolidation, the account values for dependent accounts roll up to the parent accounts. Financial data of each parent consists of the values consolidated from its dependents. If you change data of a dependent, data of the parent changes when you consolidate.

As data consolidates, standard and custom methods perform calculations on the data. The system can perform the following operations:

- Intercompany eliminations, which eliminate intercompany transactions between two companies
- Currency conversions, which translate a dependent's local currency values into the parent's currency
- Tax rate calculations and other calculations your system administrator sets up in consolidation methods

When you set up an application, you decide whether you need to store additional detail that can be used to audit consolidated results. You can store the translated, proportion, elimination, and parent adjustment values. The system derives these values as it consolidates data from base entities to parents. For information on consolidation detail, see “Consolidation Detail” on page 74. For information on viewing translation detail in the point of view, see Hyperion Enterprise Getting Started.

Figure 11 shows the consolidation hierarchy of an international corporation with two major divisions: America and Europe. The consolidation hierarchy includes a currency conversion.
Figure 11 includes the following elements:

- Base Entities - West, East, Central, South, USAElim, France, and Israel contain data entered in schedules or journals or loaded from a text file. Entering data in a base entity impacts parent entity data.
- Currency Conversion - The data in France, which is stored in euros, is consolidated to Europe, which is stored in U.S. dollars.
- Store Translation Values - The data in France, which is stored as euros, is translated into U.S. dollars and stored in a translation detail table. You can view these values in the Database or Data Entry module.

- Top Entity - Corp receives consolidated U.S. dollar data from its two divisions, America and Europe.

The system consolidates only one category and one organization at a time. You can consolidate all entities and periods for the current organization and category, or you can consolidate specific entities and specific periods only. This is called a partial consolidation.

For example, suppose that you need to produce a report on a specific entity in an organization. You can run a partial consolidation for that entity only. Figure 12 shows a partial consolidation in the Corp organization.

In the previous figure, data has been loaded into accounts for the entity France. If you want to see the consolidated results for Europe only, you can consolidate only Europe.
Note: Hyperion Enterprise uses the percent consolidation value for consolidation, instead of
the percent ownership value that Hyperion Enterprise SE uses.

Consolidation Detail

You can store details about translation values, ownership percentages, parent adjustments, and
parent calculations that are performed during the consolidation process. You have several
options for storing consolidation detail, including several application and entity settings and a
category setting. You can store values in elimination, proportion, and adjustment tables for an
entity and its dependents. You can also specify whether to store this detail for each parent entity
and category in your application. For more information, see the Creating Applications chapter
in the Hyperion Enterprise Administrator’s Guide.

If you store consolidation detail, you can use the View > Consolidation Detail menu command
in the Database module to view the values in the parent adjustment, proportion, elimination,
or translation tables for a parent entity. For more information, see “Viewing Consolidation
Detail” on page 31.

You can also create reports to view and print consolidation detail, as well as provide an additional
audit trail of the consolidation process. Hyperion Retrieve provides another way to access
consolidation detail. For more information on reports, see Hyperion Reporting User’s Guide.

Consolidation Statuses

The Consolidation window displays a status for each entity for each period in the current
category. The consolidation status indicates which entities and periods have been affected by
data or method changes and need to be consolidated. It also indicates which entities contain no
data in specific periods. Table 14 shows the different consolidation statuses and what they mean.

<table>
<thead>
<tr>
<th>Status</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>CALC</td>
<td>Formulas must be calculated for the entity. Either data was entered for the entity and Formulas were not calculated or a method was edited. When you perform a consolidation, formulas are calculated automatically. You can also calculate formulas manually using the Calculate Formulas option.</td>
</tr>
<tr>
<td>CHANGED</td>
<td>Data has changed for the entity in the specified period. This can be the result of manual data entry in the Data Entry or Database window, a journal entry, or a data load.</td>
</tr>
<tr>
<td>IMPACTED</td>
<td>A data or method change has occurred below this parent entity in the consolidation path. This change impacts the value in the parent entity when you perform a consolidation.</td>
</tr>
<tr>
<td>OK</td>
<td>The entity has already been consolidated and data has not changed. You do not need to consolidate this period, but you can force consolidation.</td>
</tr>
<tr>
<td>DATA</td>
<td>This entity has data. Entities with this status will be consolidated if you select Consolidate All with Data.</td>
</tr>
<tr>
<td>NO DATA</td>
<td>This entity contains no data for the specified period. Entities with this status will not be consolidated if you select Consolidate All with Data. However, the system consolidates entities with no data if there is data in prior periods for that entity.</td>
</tr>
<tr>
<td>Status</td>
<td>Meaning</td>
</tr>
<tr>
<td>----------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>LOCKED</td>
<td>This entity contains data that is locked for the specified period. Entities with this status are not consolidated.</td>
</tr>
<tr>
<td>INACTIVE</td>
<td>This entity does not exist for the current period. This status appears only in applications that vary by category and period.</td>
</tr>
</tbody>
</table>

Here are some of the tasks that can result in an IMPACTED, DATA, or CALC status:

- Changing an organization structure
- Modifying entity attributes
- Adding or deleting accounts
- Modifying account attributes
- Entering data in a schedule or the database
- Loading data
- Modifying methods
- Posting and unposting journals

These actions can cause different status changes for base and parent entities. For more information, see the *Hyperion Enterprise Administrator's Guide*.

**Statutory Consolidation Engine**

The Statutory Consolidation Engine (ACE) is an add-on product that works with Hyperion Enterprise to improve consolidation performance and functionality when the application has a sparse data population and one or more of the following conditions apply:

- The size of the chart of accounts is inflated by an extensive use of intercompany details.
- Conditional rules must be defined for intercompany transactions.
- Complex consolidation methods must be defined to calculate items, such as goodwill or minority interests and consolidation reserves, and to generate a detailed audit trail of the consolidation process.

ACE overrides the Hyperion Enterprise process of writing into the Translation, Proportion, and Elimination data tables of consolidated entities. ACE enhances the performance level of the Hyperion Enterprise translation and consolidation processes in two ways:

- ACE defines logic formulas by source account rather than by destination account.
- ACE performs impacted consolidations by dependent rather than by parent.

ACE consists of the translation and consolidation engine, which is invoked by Hyperion Enterprise, and the Administration module, which the system administrator uses to define the content of ACE methods and to set parameters used by ACE. For more information, see the *Hyperion Enterprise Statutory Consolidation Engine Guide*. 
Consolidation Window

You view the status of entities in different organizations and categories and perform consolidations in the Consolidation window. The Consolidation window contains a table that shows the entities and subentities in the selected organization as well as their status for each period in the selected category. You can change the organization and category using the point of view bar. For more information, see Hyperion Enterprise Getting Started.

Hyperion Enterprise generates an error message when you try to perform consolidation for an entity that is opened by another user. This error message is written to the error log. For more information on the error log, see Hyperion Enterprise Getting Started Guide.

Viewing the Consolidation window can include the following tasks:

- Showing and hiding different levels of dependent entities
- Finding specific entities
- Finding specific periods

For more information, see Hyperion Enterprise Getting Started.

Figure 13 shows the Consolidation window.

Finding Entities

You can use a menu command to quickly move to a specified entity in the Entity column. This might be faster than scrolling through the entities of a large organization.
For example, if you want to consolidate data for Europe only, you can use the Find > Entity command to select Europe. If the entity you want to find is part of a branch that is collapsed, the system expands the branch and highlights the entity.

To find an entity:
1. From the Consolidation window, select Edit > Find > Entity.
2. Use the check boxes to filter the list of entities.
3. Enter an entity ID or select one from the list.
4. Click OK.

Finding Periods
You can use the Find Period option to locate a period in the Consolidation window. This is useful if you are working with a category that has period columns extending beyond the Consolidation window. Using the Find Period option might be faster than using the scroll bars or arrow keys to locate a period.

To find a period:
1. From Consolidation window, select Edit > Find > Period.
2. Enter a period ID or select one from the list.
3. Click OK.

Consolidation Tasks
Consolidation tasks include selecting the entities and periods you want to consolidate, selecting a consolidation option, and running the consolidation. You can select the entities and the periods of data you want to consolidate. You can select one or more entities and periods. You choose one of three options to consolidate data:

- Consolidate impacted entities only
- Consolidate entities with data only
- Consolidate all entities

The way the system consolidates data in dynamic organizations differs from the way it consolidates data in organizations that do not vary by category and period. For more information, see “Consolidating Dynamic Organizations” on page 80. For information on consolidating using the Statutory Consolidation Engine, see the Hyperion EnterpriseStatutory Consolidation Engine Guide.
Selecting Entities and Periods to Consolidate

When you perform consolidations, you can consolidate data for the current category for all entities in an organization or for a specific branch of the organization. Consolidating a specific branch, which is also called a partial consolidation, is useful if you need to report on an entity other than the top entity in an organization. For example, suppose you need to run a report on the Europe entity, which is a dependent entity in the Corp organization. You can consolidate data for Europe only, then run the report on Europe's consolidated data.

Here are some guidelines:

- When you select a parent entity for a partial consolidation, all dependents of the parent entity are selected even if they do not currently appear in the Consolidation window, and all periods are selected.
- You can consolidate data for all periods and entities, specific periods and all entities, or specific periods and specific entities. Consolidating specific periods is useful if only certain periods are affected by a data or method change. For example, suppose you load data for the Actual category and the January period only. You can select the January period for consolidation.
- When you select a period to consolidate, all previous periods with a consolidation status of CALC, DATA, or IMPACTED are selected. This preserves the integrity of data in periods that depend on values from previous periods.
- You cannot select a base entity for consolidation because base entities do not have dependents. You also cannot select entities that have a status of NO DATA for all periods.

To select entities and periods for consolidation, from the Consolidation window, take one of the following actions:

- To consolidate all periods and all entities, select the first entity in the Entity column.
- To consolidate all entities in one period, select the period column heading.
- To consolidate all entities in multiple periods, select the status cell for the top entity in the first period you want to consolidate, then drag to the right until all the periods you want to consolidate are highlighted.
- To consolidate one parent entity in one period, select the status cell for a parent entity in a specific period.
- To consolidate one parent entity in multiple periods, select the status cell for the parent entity in the first period you want to consolidate, then drag to the right until all the periods you want to consolidate are highlighted.

Consolidating Data

After you select the entities and periods you want to consolidate, you select one of three consolidation options:

- Consolidate All Impacted
- Consolidate All
• **Consolidate All with Data**

If you select Consolidate All Impacted, the system consolidates only entities that have been affected by data or method changes. However, the system consolidates entities with no data if there is data in prior periods for that entity.

If you select Consolidate All with Data, the system consolidates only entities with data. This allows you to consolidate entities with data even if the data has not been changed.

If you select Consolidate All, you can force consolidation for all selected entities, even entities with a status of OK. This is useful if you have made changes that are not reflected by the consolidation status indicators. For example, if you change currency translation rates, the statuses do not change but you can force consolidation for all entities to reflect the change. Selecting Consolidate All also calculates formulas for accounts that previously had no data.

When you perform a consolidation, Hyperion Enterprise eliminates values in the translated currency, which is the parent's currency. The system ignores the currency assigned to the elimination company.

If you are on a network and a user is working with an entity you are trying to consolidate, the data for that entity is locked, and the system cannot consolidate it. All consolidations that are not affected by the locked entity are performed.

For example, if you try to consolidate data for the entire Corp organization, and another user is working with the dependent Europe, consolidation is blocked for Europe and the entities above it in the consolidation path. After the consolidation is complete, an error message appears, informing you that the entity Europe could not be accessed. The entity Europe and its parents have the IMPACTED consolidation status, while those entities that successfully consolidated have the OK status.

A message box appears, showing the progress of consolidation for each entity and period. When the consolidation is complete, the status of each successfully consolidated entity and period changes to OK.

If you are using server-based processing to consolidate data, a window appears that shows the progress of the consolidation. This window is a separate program, so you can perform other tasks in Hyperion Enterprise or exit Hyperion Enterprise while consolidating. The window closes when the server finishes consolidating or an error message appears if there is a problem.

---

**To consolidate data:**

1. **From the Consolidation window, select the entities and periods that you want to consolidate.**

2. **Take one of the following actions:**
   - To consolidate all selected entities and periods, regardless of whether they have data, select **Task > Consolidate All**.
   - To consolidate data for entities with a DATA, CALC, or IMPACTED status only, select **Task > Consolidate All Impacted**.
   - To consolidate all selected entities that have data, select **Task > Consolidate All with Data**.

   If the application is a server-based application, you receive a server prompt.
If you receive a prompt, select *Server* to consolidate on the server, or select *Local* to consolidate locally on the client workstation.

**Note:** Select Cancel to stop the consolidation process.

### Consolidating Dynamic Organizations

You use dynamic organizations to track changes to a business organization over time. The organization can vary by category and period. The organization column in the consolidation table shows a composite view of the organization. Each entity appears in the organization in every location that it has ever appeared. The status for each entity appears for those periods in which the entity existed in the organization. For periods where the entity or organization does not exist, the status INACTIVE appears.

You can create dynamic organizations if you select the Vary Organization by Period and Category application setting. For information on setting up applications, see the *Hyperion Enterprise Administrator’s Guide*. For information on organizations that vary by period and category, see the *Hyperion Enterprise Administrator’s Guide*.

Figure 14 shows how a dynamic organization appears in the consolidation table.

#### Figure 14  Dynamic Organization in the Consolidation Table

In the previous figure, Denmark appears under both Eurwest and Nordic in the Entity column. The status of INACTIVE in the period columns indicates that Denmark was owned by Eurwest in January, and was moved to Nordic in February.
When you consolidate a dynamic organization, the structure is consolidated for the periods you select in the consolidation table. If you select more than one period, one period is consolidated at a time for the current category selected in the point of view. Consolidation is performed by period because the organization might be different for each period in a category. Performance might be affected if you consolidate more than one period at a time.

Figure 15 shows how a dynamic organization is consolidated.

In the previous figure, in January, the entity Denmark is a dependent of Eurwest, and does not report to Nordic. In February, Denmark is a dependent of Nordic and is no longer a dependent of Eurwest.

**Running Consolidation Detail Reports**

You can run a report to view and compare all the consolidation detail components for a selected entity and for one account, all accounts, or a range of accounts. Consolidation detail includes entity, translation, proportion, elimination, parent adjustments, and contribution. After you select the type of detail you want to view, you can select whether to suppress rows that contain zero or no data, and then specify a report scale. When you select the default scale, the consolidation detail report uses the parent scale, except for the entity, which uses the entity scale. When you specify a scale, the report displays all report values in the selected scale.

**Note:** The system saves the options that you select in the Consolidation Detail Report dialog box and uses these settings the next time you access this dialog box. The system does not save the report scale or parent options that you select.

You define the data to include on the report using the point of view bar, the Database window, and the Consolidation Detail Report dialog box:
The category and entity the system use are based on your point of view settings.

The range of accounts for one period is from the highlighted accounts on the Database window.

The parent for the entity is selected in the Consolidation Detail Report dialog box.

The default report scale value that the system uses is based on your selection from the point of view bar. For example, suppose the scale value in the Database module is set to Scale 3 (thousands). When you access the Consolidation Detail Report dialog box, the default report scale is 3. You can change the scale value.

Suppose you want to produce a report with the following specifications:

- View entity, translation, and proportion detail for Account1 through Account7.
- Suppress all rows that contain zero or no data.
- Use a report scale value of 3.

Figure 16 shows the resulting report.

### Figure 16  Sample Report

<table>
<thead>
<tr>
<th>Entity</th>
<th>Translation</th>
<th>Proportion</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACCOUNT 1</td>
<td>100</td>
<td>100</td>
</tr>
<tr>
<td>ACCOUNT 2</td>
<td>200</td>
<td>200</td>
</tr>
<tr>
<td>ACCOUNT 3</td>
<td>100</td>
<td>100</td>
</tr>
<tr>
<td>ACCOUNT 5</td>
<td>300</td>
<td>300</td>
</tr>
<tr>
<td>ACCOUNT 7</td>
<td>500</td>
<td>500</td>
</tr>
</tbody>
</table>

You can also customize your report fonts, colors, and page layout. For more information on customizing the report, see *Hyperion Enterprise Getting Started*.

To run a consolidation detail report:

1. From the Database window, highlight one account, all accounts, or a range of accounts for an entity.
2. Select **Task > Run Consolidation Detail Report**.
3. From the drop-down list box, select the parent entity that you want to view.
4. Select the consolidation detail that you want to include.
5. Select whether to suppress rows that contain no data or zeros.
6. From the **Report Scale** drop-down list, select the report scale that you want to use for the report.
7. Take one of the following actions
   - To print the report, select **Print**.
   - To preview the report, select **Preview**.
Intercompany Matching Reports

Intercompany matching reports list the intercompany transactions that are to be eliminated during consolidation for one period. These reports help you to track intercompany transactions for analysis and auditing in the currency that you specify.

You perform the following tasks to produce intercompany matching reports:

- Define intercompany account matching groups.
- Define the partners for which you want to report transactions.
- Specify the currency options.
- Specify the report information to include.
- Specify the report information to suppress.
- Customize your report.

**Note:** You must consolidate before you run intercompany matching reports.

To review an intercompany matching report sample, see “Intercompany Matching Report Case Studies” on page 89 or the “Intercompany Matching Report Sample Report” on page 90.

Intercompany Group Selection

The system produces reports based on the intercompany account matching groups that you define in the Accounts module. You select the entity or entities for which you are processing the report in the Consolidation window, either by single entity or branch, then you select one or more partner entities.

**Note:** If you select more than one period for processing, the system processes only the period that contains the cursor. A parent entity at the top of a branch is usually not an intercompany entity and is excluded from the entities that the system processes.

Partner Selection

After you select the entity or entities for which you are processing the report, you define the partners for which you want to report transactions. You can define partners using the following options:

- Specified partners means either a specific partner entity or all the intercompany entities within a branch
- Within the group means all transactions between entities in the currently selected branch
- Outside the group within the organization means to report all transactions except those that take place between entities in the currently selected branch

You can specify whether to display data in the following ways:
• For either a specific partner entity or all the intercompany entities within a branch; that is, for specified partners
• For all transactions between entities in the currently selected branch; that is, within the group
• For all transactions except those that take place between entities in the currently selected branch; that is, outside the group within the organization
• Outside the group within the application

For example, in the sample organization shown in Figure 17, DIV1 is the entity for which you are processing the report.

Figure 17  Sample Organization

If you choose the partner option as Within the Group, your report includes all transactions that take place between the following entities:
• France and Norway
• France and C1
• France and C2
• Norway and C1
• Norway and C2
• C1 and C2

If you select Outside Group within Organization, your report includes all transactions that take place between the following entities:
• France and C3
• France and C4
If you choose Outside Group within Application, assume that you have the additional organization shown in Figure 18.

Your report then includes all transactions that take place between the following entities:

- France and C3
- France and C4
- France and C5
- France and C6
- Norway and C3
- Norway and C4
- Norway and C5
- Norway and C6
- C1 and C3
- C1 and C4
- C1 and C5
- C1 and C6
- C2 and C3
- C2 and C4
- C2 and C5
- C2 and C6

If you choose the partner option as Specified Partner and select the partner as DIV2, your report includes all transactions that take place between the following entities:

- France and C3
Entity Code Option

You can specify an entity code to filter the list of entities and the list of the matching partners for which you are processing the report. You can select multiple entity codes for a filter.

Currency Option Selection

After you specify the partner transactions to include in your intercompany matching report, you specify one or more types of currency on the report:

- The currency of the entity for which you are processing the report
- The currency of the partner
- The currency of the parent
- Another currency that you select

For each currency you select, the system generates a Difference column. An optional Status column appears on the report.

Currency Translation

Currency translation is performed using the rate specified in the application module for translating balance or flow accounts. You can also specify to translate flow accounts using balance account rates for an intercompany set.

The system does not translate accounts if you specify to use child rates in your application. If your application stores the rate account data in an account group other than GLOBAL, the system uses the rate data of the parent entity.

Parent Currency

In the Consolidation window, if you select only one entity for processing and apply the parent currency, the system uses the currency of the selected entity. If you select a branch or group for processing and apply parent currency, the system translates each dependent using the currency of the parent, which is the top node of the branch.
Report Information to Include

The intercompany matching report includes columns for the entity for which you are processing the report, the partner entity, accounts, entity and matching entity values, the difference between accounts, and the status of the matching transaction.

You use the matching currency as a conversion factor in defining the matching tolerance for the report. The matching currency for the report is the parent currency by default, which is the currency of the top node of the branch selected for processing. You can specify another matching currency.

You use the matching tolerance to specify the range of values for which to report status. The matching tolerance for the report is based on the matching currency you select. The report scale that you select also is the scale for the Matching Tolerance amount.

You can specify whether to display the entity description for entities in the intercompany matching set, whether to display account detail, account totals, and accounts in rows instead of columns. You can select to generate a one report for each entity for which you are processing the report. You can also select the report scale, and the number of decimal places to display on the report.

The system processes and stores values based on account types. When you calculate the difference, the system applies the signs to accounts as shown in Table 15.

Table 15 Account Signs

<table>
<thead>
<tr>
<th>Account Attribute</th>
<th>Sign</th>
</tr>
</thead>
<tbody>
<tr>
<td>Income</td>
<td>Minus</td>
</tr>
<tr>
<td>Expense</td>
<td>Plus</td>
</tr>
<tr>
<td>Asset</td>
<td>Plus</td>
</tr>
<tr>
<td>Liability</td>
<td>Minus</td>
</tr>
<tr>
<td>Balance</td>
<td>Plus</td>
</tr>
<tr>
<td>Flow</td>
<td>Minus</td>
</tr>
</tbody>
</table>

When calculating the Total column, the system considers the sign for the account attribute, then applies the sign of the first account in each column to the result. Therefore, the sign of the total may change, depending upon the sign of the first account that is specified in each column.

Report Information to Suppress

You can suppress the following report information:

- Status, which provides status information based on the matching tolerance that applies to the entire report.
Currency, which provides information on the current and partner entity currencies for each currency you select. For example, if you have different currencies assigned to each partner entity, the currency for each partner is different on each row.

Subtotals, which the system generates after processing each entity for which you are processing the report, and a grand total for the entire report. You might want to suppress totaling and subtotaling if they are not meaningful because of currency differences. For example, if you have a report that shows both current entity and partner currencies, each subtotal might appear in a different currency. In this case, you might want to suppress the grand total.

Matching values, which are transactions that fall within the range of values you specify for matching tolerance.

Report Format
You can customize your report fonts, colors, and page layout. For more information on formatting the report, see Hyperion Enterprise Getting Started.

Running Intercompany Matching Reports
After you define intercompany matching groups, you can use intercompany matching reports to list the intercompany transactions that are eliminated during consolidation and to identify unmatched intercompany transactions. These reports document an organization’s transactions so you can analyze or audit the data in the currency that you specify. The system saves the check box options that you select and displays them the next time you run intercompany matching reports.

You can use Hyperion Reporting to design your own custom intercompany matching reports. For more information on designing custom intercompany matching reports, see the Hyperion Reporting User’s Guide. For more information on running standard intercompany matching reports, see “Running Intercompany Matching Reports” on page 88. For more information about intercompany matching, see the Hyperion Enterprise Administrator’s Guide.

To run intercompany matching reports:

1. From the Consolidation window, select the entity or entities and period for which you want to run the report.
2. Select Task > Run Intercompany Matching Reports.
3. On the Intercompany Group tab, select the intercompany group for which you want to run intercompany matching reports.
4. On the Matching Options tab, select the partner transactions, currency options, and filter options that you want to use.
5. On the Reporting Options tab, select a report and suppression options to include, then take one of the following actions:
   a. To print the report, select Print.
   b. To preview the report, select Preview.
Intercompany Matching Report Case Studies

Evergreen Paper organization has two divisions for which you want to identify unmatched intercompany transactions: DIV1 and DIV2. Figure 19 shows the divisions.

Figure 19  Divisions of Evergreen Paper Organization

Suppose the system administrator at Evergreen Paper wants to produce a report with the following specifications:

- The entity for which you are processing the report is DIV1, which includes France, Norway, C1, and C2.
- The partner entity is DIV2, which includes C3 and C4.
- The currency option is Current Entity Currency.

Table 16 shows the results using the Current Entity Currency option.

Table 16  Results Using Current Entity Currency Option

<table>
<thead>
<tr>
<th>Entity</th>
<th>Matching Entity</th>
<th>Receivables</th>
<th>Payables</th>
</tr>
</thead>
<tbody>
<tr>
<td>France</td>
<td>C3</td>
<td>France, REC.C3 (euros)</td>
<td>C3, PAY.France (yen, converted to euros)</td>
</tr>
<tr>
<td></td>
<td>C4</td>
<td>France, REC.C4 (euros)</td>
<td>C4, PAY.France (HK, converted to euros)</td>
</tr>
<tr>
<td>Norway</td>
<td>C3</td>
<td>Norway, REC.C3 (kroner)</td>
<td>C3, PAY.Norway (yen, converted to kroner)</td>
</tr>
<tr>
<td></td>
<td>C4</td>
<td>Norway, REC.C4 (kroner)</td>
<td>C4, PAY.Norway (HK, converted to kroner)</td>
</tr>
<tr>
<td>Entity</td>
<td>Matching Entity</td>
<td>Receivables</td>
<td>Payables</td>
</tr>
<tr>
<td>--------</td>
<td>-----------------</td>
<td>---------------------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td>C1</td>
<td>C3</td>
<td>C1, REC.C3 (HK)</td>
<td>C3, PAY.C1 (yen, converted to HK)</td>
</tr>
<tr>
<td></td>
<td>C4</td>
<td>C1, REC.C4 (HK)</td>
<td>C4, PAY.C1 (HK, no conversion)</td>
</tr>
<tr>
<td>C2</td>
<td>C3</td>
<td>C2, REC.C3 (USD)</td>
<td>C3, PAY.C2 (yen, converted to USD)</td>
</tr>
<tr>
<td></td>
<td>C4</td>
<td>C2, REC.C4 (USD)</td>
<td>C4, PAY.C2 (HK, converted to USD)</td>
</tr>
</tbody>
</table>

Suppose the system administrator at Evergreen Paper Organization wants to produce a report with the following specifications:

- The entity for which you are processing the report is DIV1, which includes France, Norway, C1 and C2.
- The partner entity is DIV2, which includes C3 and C4.
- The currency option is Partner Currency.

Table 17 shows the results using the Partner Currency option.

### Table 17  Results Using Partner Currency Option

<table>
<thead>
<tr>
<th>Entity</th>
<th>Matching Entity</th>
<th>Receivables</th>
<th>Payables</th>
</tr>
</thead>
<tbody>
<tr>
<td>France</td>
<td>C3</td>
<td>France, REC.C3 (euros, converted to yen)</td>
<td>C3, PAY.France (yen)</td>
</tr>
<tr>
<td></td>
<td>C4</td>
<td>France, REC.C4 (euros, converted to HK)</td>
<td>C4, PAY.France (HK)</td>
</tr>
<tr>
<td>Norway</td>
<td>C3</td>
<td>Norway, REC.C3 (kroner, converted to yen)</td>
<td>C3, PAY.Norway (yen)</td>
</tr>
<tr>
<td></td>
<td>C4</td>
<td>Norway, REC.C4 (kroner, converted to HK)</td>
<td>C4, PAY.Norway (HK)</td>
</tr>
<tr>
<td>C1</td>
<td>C3</td>
<td>C1, REC.C3 (HK, converted to yen)</td>
<td>C3, PAY.C1 (yen)</td>
</tr>
<tr>
<td></td>
<td>C4</td>
<td>C1, REC.C4 (HK, no conversion)</td>
<td>C4, PAY.C1 (HK)</td>
</tr>
<tr>
<td>C2</td>
<td>C3</td>
<td>C2, REC.C3 (USD, converted to yen)</td>
<td>C3, PAY.C2 (yen)</td>
</tr>
<tr>
<td></td>
<td>C4</td>
<td>C2, REC.C4 (USD, converted to HK)</td>
<td>C4, PAY.C2 (HK)</td>
</tr>
</tbody>
</table>

**Intercompany Matching Report Sample Report**

Figure 20 shows a sample intercompany matching report with the following specifications:
- The entity for which you are processing the report is TOP, which includes US100, US100A, US100B, and TopEUR.
- The partner transaction is within group.

Figure 20  Sample Intercompany Matching Report

```
IC - USER
Matching Report: A110 - A1101
Category: Actual  Period: JAN 90
Organization: ORG1  Entity: TOP  Partner: Within Group
Scale: 0  Matching Currency: USD  Tolerance: 0
Entity Code: <NONE>

<table>
<thead>
<tr>
<th>ENTITY</th>
<th>MATCHING ENTITY</th>
<th>ICRECDET1</th>
<th>(CPAYDET1)</th>
<th>DIFF (PAR-USD)</th>
</tr>
</thead>
<tbody>
<tr>
<td>US100</td>
<td>US100A</td>
<td></td>
<td>137</td>
<td>.137</td>
</tr>
<tr>
<td></td>
<td>SUBTOTAL</td>
<td>0</td>
<td>137</td>
<td>.137</td>
</tr>
<tr>
<td>US100B</td>
<td>TopEUR</td>
<td></td>
<td>9968</td>
<td>.9968</td>
</tr>
<tr>
<td></td>
<td>SUBTOTAL</td>
<td>0</td>
<td>9968</td>
<td>.9968</td>
</tr>
</tbody>
</table>
```
This chapter provides information and procedures that you need for entering journals.

**Journals Overview**

A journal is a set of adjustments to account balances for one category and period. You use journals to record changes in account values and maintain an audit trail of those changes. You can use journal templates for common adjustments that you make on a regular basis, to create journals automatically for each period, or as a basis for creating new journals.

You create, edit, and post journals in the Journals module. When you post a journal, the system recalculates the account balances so that the database reflects the adjustments. You can refer to posted journals as records of adjustments, or run reports to check the trail of changes to account values.
Journal Types

You can create three types of journals:

- Regular journals, which adjust values in a single period
- Auto-reversing journals, which adjust values in one period and automatically reverse them in the next period
- Parent journals, which adjust the contribution of an entity to its parent

Regular Journals

You use regular journals to enter one-time adjustments for one period only. Regular journals can be balanced, balanced by entity, or unbalanced. You determine that a journal or template is regular when you create it. For example, suppose you want to enter one-time adjustments to data in the January period of the Actual category for the Cables, Monitors, and Keyboards accounts. You can enter these adjustments in a regular journal, then post the adjustments to different entities or all to the same entity. For information on balanced and unbalanced journals, see “Balanced and Unbalanced Adjustments” on page 96. For information on creating journals and templates, see “Journal and Template Creation” on page 105.

Auto-reversing Journals

You use auto-reversing journals to enter adjustments that you want to reverse in the next period. Auto-reversing journals affect two periods of data. You post an auto-reversing journal to adjust values in one period. When you open the next period, the system automatically creates and posts a journal that reverses those adjustments.

When you open the following period, the journal that the system creates is a regular journal with a status of Auto-reversed. The status of the original journal changes to Locked. When the system creates and posts the auto-reversed journal, it locks the newly-opened period in the database for all entities to which adjustments were posted in the auto-reversed journal.

Note: You cannot edit the data for the entities in the newly-opened period. You also cannot edit, unpost, or delete the auto-reversing journal or the auto-reversed journal.

For example, you can create and post an auto-reversing journal in January called JE1, which adjusts the Cash and Sales accounts for France. When you open the February period, the system creates and posts a second journal called JE1, which reverses the JE1 adjustments made in January. The journal you created in January is an auto-reversing journal with the status Locked. The journal automatically created in February is a regular journal with the status Auto-reversed. For information on creating journals, see “Journal and Template Creation” on page 105. For information on journal statuses, see “Journal Status” on page 97.

When you post auto-reversing adjustments to an entity, you cannot remove that entity until you open the next period in journals. You can delete an entity to which auto-reversing journal adjustments are posted, but you cannot purge it from the application.
Note: You cannot create an auto-reversing template or create an auto-reversing parent journal.

Parent Journals

You can create a parent journal to adjust the value that a dependent contributes to its parent during consolidation. Parent journals adjust the value of the parent only.

For example, suppose your organization contains an entity called France that reports to Europe Consolidated. You can create a parent journal that adjusts the contribution of France to Europe Consolidated. Europe Consolidated is the entity in the Parent drop-down list box, and France is in the rows of the journal. There is no change to France's values. A parent journal can contain adjustments to many entities for the same parent.

You can create a parent journal only if two settings are selected. You must select the Allow Parent Adjustments application setting. You also must select the Allow Parent Adjustments check box in the Entities module for the parent entity. When you first create a journal or template, you determine whether it is a parent journal. For more information on creating journals and templates, see “Journal and Template Creation” on page 105. For more information on the Allow Parent Adjustments parent setting, see the Hyperion Enterprise Administrator’s Guide.

Journal Templates

You can use journal templates to save time when you work with journals. You can create two types of journal templates:

- Standard templates, which contain account IDs, entity IDs, or values for similar adjustments that you enter frequently. You can use a standard template as a starting point for creating many journals.
- Recurring templates, which contain complete adjustments that the system creates automatically when you open a new period.

Standard Templates

You use standard templates when you need to post adjustments that have common adjustment information for each period. Instead of creating a new regular journal every month, you can create a standard template that contains the common account IDs, entity IDs, or amounts. You can use the template as the basis for many regular journals that contain similar adjustment information.

For example, if an entity is in a country with high inflation, you might need to post adjustments to several accounts every month to record changes in the entity's inventory values. The adjustment amounts can change from month to month. You can create a template that contains the account ID and entity, with a line for each adjustment. Each month, you can use the template to create a regular journal that already contains the account and entity IDs for the adjustments, so that you only need to enter the amounts.
You can also use a standard template to make similar adjustments to the amounts that an entity contributes to multiple parents. You enter the adjustment information in the template, and then change the parent each time you create a journal with that template. A standard template can contain balanced or unbalanced adjustments, and can be a regular or parent template. For information on balanced and unbalanced adjustments, see “Balanced and Unbalanced Adjustments” on page 96. For information on regular and parent journals, see “Journal Types” on page 94.

**Recurring Templates**

You can use recurring templates to save time when you need to make identical adjustments in every period. Instead of creating a regular journal for each period to post these adjustments, you can create a recurring template that contains the adjustments. When you open a period, the system creates a regular journal from the template. You can post the journal immediately, or you can edit it before posting it. For information on regular journals, see “Regular Journals” on page 94.

Recurring templates are especially useful for working with a category that has a year-to-date data view. Suppose you are working with the Actual category, which has a year-to-date view. The Other Income account has a value of zero for January through March, but in April, you enter a value of 2,000 because your company sells a truck for $2,000 more than its’ cost. Because the category’s data view is year-to-date, the 2,000 accumulated value appears as part of each month’s cumulative value, so you might want to post an adjustment each month to offset that amount.

Each journal the system creates from a recurring journal template has the same ID and description as the template. For example, if you create a recurring template with the ID CABLEADJ, each journal the system creates from this template also has the ID of CABLEADJ.

A recurring template can contain balanced or unbalanced adjustments. You can create regular recurring templates, but not auto-reversing or parent recurring templates. For information on balanced and unbalanced adjustments, see “Balanced and Unbalanced Adjustments” on page 96.

**Balanced and Unbalanced Adjustments**

Each journal or template that you create is balanced, balanced by entity, or unbalanced. You select the balance attribute when you create or edit the journal or template.

A balanced journal or template is one in which the total debits are equal to the total credits. You must enter equal debits and credits within a balanced journal before you can post the journal. For example, if the total of credits in a journal is 50, the total of debits must also be 50 before you can post the journal.

A journal or template that is balanced by entity is one in which the total debits to each entity are equal to the total credits to that entity. The debits and credits for each entity within a balanced journal must balance before you can post the journal. For example, if the total of credits to an entity in a journal is 50, the total of debits to that entity must also be 50 before you can post the journal.
The adjustments in an unbalanced journal do not need to balance before you can post the journal. For example, you can post an unbalanced journal with a total of 20 debits and 300 credits to different accounts and entities. You can use unbalanced journals to build an audit trail of adjustments when you do not have a complete set of data. For example, several departments might help to develop a company forecast by posting unbalanced journals that contain adjustments based only on their own income and expense data. This provides an audit trail showing how the forecast evolved as each department posted its adjustments.

For more information on creating unbalanced journals, see “Journal and Template Creation” on page 105.

Journal Information

The system maintains information on each journal. You can view this information from the Journals window or include it in reports. Here is the available journal information:

- The journal status shows where the journal is in the adjustment process.
- The optional journal number shows the order of journals.
- The journal ID is a unique identifier for each journal. It appears in selection lists or reports.
- The journal code is a code that you can assign when you create or edit a journal.

Journal Status

The journal status indicates the current state of the journal. The status of a journal changes when you review, post, unpost, edit, reverse, or delete the journal. Standard and recurring templates do not have a status.

Table 18 describes the valid journal statuses.

<table>
<thead>
<tr>
<th>Status</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Unposted</td>
<td>No user has reviewed or posted the journal adjustments to the database.</td>
</tr>
<tr>
<td>Reviewed</td>
<td>A user has reviewed the journal but has not posted its adjustments to the database.*</td>
</tr>
<tr>
<td>Posted</td>
<td>A user has posted the journal adjustments to the database.</td>
</tr>
<tr>
<td>Reversed</td>
<td>A user has posted the journal adjustments to the database, then reversed those adjustments.</td>
</tr>
<tr>
<td>Auto-reversed</td>
<td>The adjustments in this journal were applied to reverse the adjustments made in the auto-reversing journal created and posted in the previous period.</td>
</tr>
<tr>
<td>Locked</td>
<td>A user posted the auto-reversing journal and then opened the next period. It is a valid status for auto-reversing journals only. You cannot modify a locked journal.</td>
</tr>
<tr>
<td>Posted and Edited</td>
<td>A user posted the journal adjustments to the database, edited the adjustments, and posted them again. It appears only in history reports to provide a complete audit trail of the journal. In all other instances, a journal that has been posted and edited has a status of Unposted.</td>
</tr>
</tbody>
</table>
### Status

<table>
<thead>
<tr>
<th>Status</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Deleted</td>
<td>A user deleted the journal from the application. You can review deleted journals when you run the Journals Production report using enhanced filter capabilities.</td>
</tr>
</tbody>
</table>

* - This status is valid only if the Use Reviewed Status option is selected for the application. For more information, see the Hyperion Enterprise Administrator's Guide.

### Journal Number

You can use the journal number as an additional identifier for journals. In an application with journal numbering, the system assigns a sequential number to each journal when you save or load it. The journal number appears above the journal ID in the Journals window.

You can use the journal number as a filter when selecting journals to include in reports. If you delete a journal, the number for that journal remains in the application, and you can include the deleted journal in a report. This ensures a complete audit trail of journals. For example, if you delete the journal with the number 235, and then run a history report on journals numbered between 230 and 240, the ID and description of the journal numbered 235 appear in the report. For information on including journals in reports, see “Journal Production Reports” on page 117.

**Note:** The system does not assign numbers to journal templates. A journal number must be between 1 and 999999.

You specify whether to use journal numbering in the Application window. You set up journal numbering in the Categories window. For information on selecting journal numbering for an application, or on setting up journal numbering, see the *Hyperion Enterprise Administrator's Guide*.

### Journal ID

Each journal that you create has a journal ID assigned to it. The journal ID is a reference that you can use when selecting journals to edit, review, post, unpost, delete, or include in reports. For example, you select the journal ID to view information about a journal in a list box or in a report. The journal ID is the journal ID plus a combination of characters that provide the following information about the journal:

- The first part of the ID identifies journals, standard templates, and recurring templates.
- The journal type indicates whether the journal or template is regular, auto-reversing, or parent.
- The journal status indicates the current state of the journal. For more information on journal statuses, see “Journal Status” on page 97.

Table 19 shows the identifiers that combine to create the journal ID.
### Table 19  Journal ID Identifiers

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Character(s)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Journal</td>
<td>Jrn</td>
</tr>
<tr>
<td>Standard Template</td>
<td>Std</td>
</tr>
<tr>
<td>Recurring Template</td>
<td>Rec</td>
</tr>
<tr>
<td>Regular</td>
<td>R</td>
</tr>
<tr>
<td>Auto-reversing</td>
<td>A</td>
</tr>
<tr>
<td>Parent</td>
<td>T</td>
</tr>
<tr>
<td>Unposted</td>
<td>U</td>
</tr>
<tr>
<td>Reviewed</td>
<td>W</td>
</tr>
<tr>
<td>Posted</td>
<td>P</td>
</tr>
<tr>
<td>Reversed</td>
<td>V</td>
</tr>
<tr>
<td>Locked</td>
<td>L</td>
</tr>
<tr>
<td>Posted and Edited</td>
<td>P&amp;E</td>
</tr>
<tr>
<td>Auto-reversed</td>
<td>O</td>
</tr>
<tr>
<td>Deleted</td>
<td>D</td>
</tr>
<tr>
<td>Posted journal that is extracted as unposted.</td>
<td>T</td>
</tr>
</tbody>
</table>

The characters in the journal ID appear in parentheses and are separated by a underscore ( _ ). For example, the journal labeled France_ADJ is a posted parent journal. Here is how the France_ADJ journal would appear in lists or reports:

```
France_ADJ (Jrn-T-P)
```

As another example, the journal labeled JE7 is a regular journal with the status Reviewed. Here is how the JE7 journal would appear in reports:

```
JE7   (Jrn-R-W)
```

**Note:** The status Posted and Edited appears in history reports only.

### Code

You can assign a 20-character code as an additional identifier for any journal. You define and maintain journal codes in the Codes window, and you assign them to journals in the Journals window.

You can use the code as a filter when selecting journals to open, to extract from one period, or to include in reports. For example, you can assign the code Reclass to any journal that moves
balances from one account to another. You can then run a reclass journal report by including only the posted journals with the code Reclass.

For information on opening journals, see *Hyperion Enterprise Getting Started*. For information on extracting journals, see “Extracting Journals” on page 114. For information on running reports on journals, see “Journal Production Reports” on page 117. For more information on codes, see the *Hyperion Enterprise Administrator’s Guide*.

**Viewing Journal Information**

You can quickly view detailed information about the current journal in the window. The Journal Information message box shows the following details about the journal:

- Number
- Status
- Type
- User who created the journal
- Date and time created
- Date and time posted

➢ To view journal information:

1. From the *Journals* window, click *Info* to open the message box.
2. View the information, then click *Close*.

**Decimal Places Option**

When you create an account in the Accounts module, you specify a default number of decimal places for that account. Whenever you view values for that account, the default number of decimal places appears. For example, if you set the Decimals attribute of an account to 0 (zero), the system shows the account’s values as whole numbers. If you set the Decimals attribute of an account to 2, the system shows the account's values with two decimal places, such as 6.75.

In the Journals module, you can use the Decimal Places option to override the account's default number of decimal places that appear. The number of decimal places that you specify remains in effect until you change it. A check mark appears next to the number of decimal places you select on the menu.

Selecting Default for the Decimal Places option allows you to view the decimal settings originally specified for the account in the Accounts module. The Decimal Places option does not affect the display of data in the Totals, Variance, and Value text boxes. However, the Decimal Places option affects the data display in Journal Production Reports.

**Note:** When you use the Decimal Places option, the system rounds the numbers that display but not the numbers that the system stores.
To override the default number of decimal places:

1. From the **Journals** window, select **View > Decimal Places**.
2. Select the number of decimal places you want to display, or select **Default** to display the number of decimal places specified in the Accounts module.

### Journal Adjustments

Journal adjustments directly affect the values in the database. You must consider this information when preparing to adjust data using journals:

- The data view that you select for the journal determines how the values in the database appear.
- The Missing Data as Zero setting for the category affects journal adjustments to missing data.

### Data View and Journals

When you create a journal, you use the Affects Future Periods setting to determine how the system recalculates future period data if a journal is posted to a period that has data in that future period. When you create a journal, the system sets the default Affect Future Period option as either Periodic or Category-to-Date, based on the setting in the Categories window. If you set Missing Data as Zero for Journal Entities to Category-to-Date, the default setting in Journals for Affects Future Periods is Periodic. Conversely, if you set Missing Data as Zero for Journal Entities to Periodic, the default setting in journals for Affects Future Periods is Category-to-Date. For more information about data view, see the *Hyperion Enterprise Administrator's Guide*.

Table 20 shows the periodic and category-to-date (CTD) values for the Equipment account in the periods January, February, and March before adjustments.

<table>
<thead>
<tr>
<th>Data View</th>
<th>JAN</th>
<th>FEB</th>
<th>MAR</th>
</tr>
</thead>
<tbody>
<tr>
<td>Periodic</td>
<td>100</td>
<td>100</td>
<td>100</td>
</tr>
<tr>
<td>Category-To-Date</td>
<td>100</td>
<td>200</td>
<td>300</td>
</tr>
</tbody>
</table>

Suppose JE5 is a regular journal that contains one credit adjustment of 100 to the Equipment account. If you post JE5 in February with the Affects Future Periods category-to-date option selected, then the values for Equipment appear as shown in Table 21.

<table>
<thead>
<tr>
<th>Data View</th>
<th>JAN</th>
<th>FEB</th>
<th>MAR</th>
</tr>
</thead>
<tbody>
<tr>
<td>Periodic</td>
<td>100</td>
<td>200</td>
<td>100</td>
</tr>
<tr>
<td>Category-To-Date</td>
<td>100</td>
<td>300</td>
<td>400</td>
</tr>
</tbody>
</table>
The previous table shows that value in March is affected in the category-to-date view, but not in the periodic view. If you post JE5 in February with the Affects Future Periods Periodic option selected, then the values for Equipment appear as shown in Table 22.

**Table 22  Values for March Periodic**

<table>
<thead>
<tr>
<th>Data View</th>
<th>JAN</th>
<th>FEB</th>
<th>MAR</th>
</tr>
</thead>
<tbody>
<tr>
<td>Periodic</td>
<td>100</td>
<td>200</td>
<td>0</td>
</tr>
<tr>
<td>Category-To-Date</td>
<td>100</td>
<td>300</td>
<td>300</td>
</tr>
</tbody>
</table>

The previous table shows that value in March is affected in the periodic view, but not in the category-to-date view. The default for the Affects Future Periods setting is periodic for the category. The default for the Missing Data as Zero setting is category-to-date.

**Note:** Journal adjustments to balance accounts always affect future periods in the category-to-date view.

To change the Affect Future Periods settings, you must have access rights to that task. Verify that the Affect Future Periods setting is correct if any of the following situations occur:

- If you change the Missing Data a Zero for Journal Entity setting after journals are created, any new journals created have a different default setting for Affect Future Period.
- If you load the journal entries from an ASCII file, the system loads the affect future period setting from the ASCII file. This setting may not be based on the default setting for the category.

### Adjustments to Missing Data Values

When you post journal adjustments to missing values in the database, the adjustments follow the Missing Data as Zero setting for the category. Table 23 shows how the category-to-date and periodic values for the income account Interest Income appear when you select Missing Data as Zero Category-to-date for the category. For more information about missing data, see the *Hyperion Enterprise Administrator’s Guide*.

**Table 23  Missing Data as Zero Category-to-Date**

<table>
<thead>
<tr>
<th>Data View</th>
<th>JAN</th>
<th>FEB</th>
<th>MAR</th>
</tr>
</thead>
<tbody>
<tr>
<td>Periodic</td>
<td>100</td>
<td>-100</td>
<td>300</td>
</tr>
<tr>
<td>Category-To-Date</td>
<td>100</td>
<td>0</td>
<td>300</td>
</tr>
</tbody>
</table>

**Table 24** shows how the category-to-date and periodic values for the Interest Income account appear when you select Missing Data as Zero Periodic for the category.
Table 24  Missing Data as Zero Periodic

<table>
<thead>
<tr>
<th>Data View</th>
<th>JAN</th>
<th>FEB</th>
<th>MAR</th>
</tr>
</thead>
<tbody>
<tr>
<td>Periodic</td>
<td>100</td>
<td>0</td>
<td>200</td>
</tr>
<tr>
<td>Category-To-Date</td>
<td>100</td>
<td>100</td>
<td>300</td>
</tr>
</tbody>
</table>

If you post a credit adjustment of 50 to Interest Income in the February period, the adjustment depends on the Missing Data setting. Table 25 shows the adjustments to the same account, entity, and periods with the Missing Data as Zero Category-to-date selected for the category and with Affects Future Periods Category-to-date selected for the journal.

Table 25  Missing Data as Zero Category-To-Date, Affects Future Periods Category-To-Date

<table>
<thead>
<tr>
<th>Data View</th>
<th>JAN</th>
<th>FEB</th>
<th>MAR</th>
</tr>
</thead>
<tbody>
<tr>
<td>Periodic</td>
<td>100</td>
<td>-50</td>
<td>300</td>
</tr>
<tr>
<td>Category-To-Date</td>
<td>100</td>
<td>50</td>
<td>350</td>
</tr>
</tbody>
</table>

In the previous table, the category-to-date value for March is affected by the adjustment. Table 26 shows the adjustments to the same account, entity, and periods with the Missing Data as Zero Category-to-date selected for the category and Affects Future Periods Periodic selected for the journal.

Table 26  Missing Data as Zero Category-To-Date, Affects Future Periods Periodic

<table>
<thead>
<tr>
<th>Data View</th>
<th>JAN</th>
<th>FEB</th>
<th>MAR</th>
</tr>
</thead>
<tbody>
<tr>
<td>Periodic</td>
<td>100</td>
<td>-50</td>
<td>250</td>
</tr>
<tr>
<td>Category-To-Date</td>
<td>100</td>
<td>50</td>
<td>300</td>
</tr>
</tbody>
</table>

In the previous table, the periodic value for March is affected by the adjustment. Table 27 shows the adjustments to the same account, entity, and periods with Missing Data as Zero Periodic selected for the category and Affects Future Periods Periodic selected for the journal.

Table 27  Missing Data as Zero Periodic, Affects Future Periods Periodic

<table>
<thead>
<tr>
<th>Data View</th>
<th>JAN</th>
<th>FEB</th>
<th>MAR</th>
</tr>
</thead>
<tbody>
<tr>
<td>Periodic</td>
<td>100</td>
<td>50</td>
<td>150</td>
</tr>
<tr>
<td>Category-To-Date</td>
<td>100</td>
<td>150</td>
<td>300</td>
</tr>
</tbody>
</table>

In the previous table, the periodic value for March is affected by the adjustment. Table 28 shows the adjustments to the same account, entity, and periods with Missing Data as Zero Periodic selected for the category and Affects Future Periods Category-to-date selected for the journal.
Table 28  Missing Data as Zero Periodic, Affects Future Periods Category-To-Date

<table>
<thead>
<tr>
<th>Data View</th>
<th>JAN</th>
<th>FEB</th>
<th>MAR</th>
</tr>
</thead>
<tbody>
<tr>
<td>Periodic</td>
<td>100</td>
<td>50</td>
<td>200</td>
</tr>
<tr>
<td>Category-To-Date</td>
<td>100</td>
<td>150</td>
<td>350</td>
</tr>
</tbody>
</table>

In the previous table, the category-to-date value for March is affected by the adjustment.

**Journals Window**

You perform the following tasks in the Journals window:

- Create and modify journals and journal templates.
- Review journals.
- Post journal adjustments to the database.
- Unpost, edit, and reverse posted journals.
- Load and extract journals.
- Run reports on journal adjustments.
- Delete journals and journals templates.
- Print journals.

For information on opening journals or templates, see *Hyperion Enterprise Getting Started*. Figure 21 shows the Journals window.

Figure 21 Journals Window
The Journals window shows the detail of the current journal, such as the ID, description, and attribute. The buttons at the bottom of the window allow you to quickly perform tasks such as posting or reversing the current journal.

**Journal and Template Creation**

You create journals to make adjustments to the database. You create journal templates to make the journal adjustment process more efficient.

Journal and template creation involves the following tasks:

- Opening periods
- Creating journal templates
- Creating journals
- Entering adjustment information

You can delete unposted journals or journal templates that you no longer need. You can delete unposted or reversed journals from the current category and period.

You can delete a standard or recurring journal template for all periods for the current category. For example, suppose the current category is Actual, and you have a standard journal template for adjustments to Actual data for several accounts for an entity. If your organization divests itself of that entity, you can remove the template from the Actual category.

**Opening Periods**

You make journal adjustments for one category and one period. Before you can enter and post adjustments to the data for a period, the period must be open for journal entry. For example, if you want to post adjustments to the first quarter, you must open the first-quarter period.

You can open a period only if the previous period is open. For example, you can open the second-quarter period only if the first-quarter period is open.

When you open a period, the system uses any recurring journal templates for the current category to create the recurring entries for that period. The system also searches for any posted or unposted auto-reversing journals from the previous period. If any unposted auto-reversing journals exist, you cannot open the period. If any posted auto-reversing journals exist, the system creates and posts a journal that reverses the entries in the posted auto-reversing journal.

You cannot unpost or edit an auto-reversing journal after you open the following period, and you cannot edit or reverse the auto-reversed journal that the system creates. You have the option of canceling and not opening the period. If you do open the period, the data is locked for all entities that are adjusted in the auto-reversed journal. For more information on auto-reversing journals, see “Auto-reversing Journals” on page 94.

To open a period:

1. From the Journals window, select Task > Open Period.
2 Select Yes to open the next unopened period. If there are posted auto-reversing journals in the previous period, a message appears, warning that the journals will be reversed.

3 Select Yes to open the period, or select No to cancel the operation.

Creating Journal Templates

You can create two kinds of journal templates: standard and recurring. Standard templates contain information for similar adjustments that you enter frequently. When you create a standard template, that template is available for all periods in the application.

Recurring templates contain information for identical adjustments that the system makes automatically when you open a new period. After you create a recurring template, you can create journals based on that template in your choice of the periods that are already open. For more information on journal templates, see “Journal Information” on page 97. For information on creating journals from recurring templates, see “Creating Journals Using Recurring Templates” on page 108.

To create a journal template:

1 From the Journals window, select File > New Journal.

2 Select Standard or Recurring, select the type of journal, then click OK.

3 Take one of the following actions:
   - If you are creating a recurring template, enter complete adjustment information. For instructions, see "Entering Adjustment Information" on page 107.
   - If you are creating a standard template, select which adjustment detail to include in a standard template. The only required information is the ID.

4 Select File > Save to save the template.

Creating Journals

Each journal that you create has a ID that is unique within the period. You can create a journal labeled CABLEADJ for each period in the Actual category, and you can create journals with that ID for different categories. You can also create journals and templates with the same ID in the same category. However, you cannot create two journals labeled CABLEADJ in one period for any category. If you have the Autonumbering option selected, you cannot create a journal with the same ID as one that has been previously deleted.

Each template that you create has a ID that is unique within the application. For information on journal templates, see “Journal Information” on page 97.

Before you create a journal, check the point of view to be sure that the current category and period are the ones you want to adjust. You can create journals for the current category and period only. You cannot create auto-reversing journals if the current period is the last period of a category, or if the next period is already open. For information on the point of view, see Hyperion Enterprise Getting Started.
To create a journal:

1. From the Journals window, select File > New Journal.
2. Select Journal and select the type of journal to create.
3. To use a standard template as a basis for a journal, select Use Standard Template and select a template from the list.
4. Click OK.
5. Enter an ID and press Enter.
6. Type a description for the journal or template, and enter the adjustment information. For instructions, see “Entering Adjustment Information” on page 107.

Note: You can enter up to 254 characters in the Journals description field.

7. Select File > Save to save the journal.

Entering Adjustment Information

The adjustment information that you enter in journals and templates includes account IDs, entity IDs, and adjustment amounts. A journal can contain adjustments to one account or multiple accounts. Adjustments cannot be negative numbers, but you can enter a zero for a debit or credit. You can post the adjustments in any journal to one entity or multiple entities. In non-parent journals, you can enter the IDs of only those accounts that accept input, and only those entities that allow journal entries.

You enter adjustment information in the adjustment table in the Journals window. When you enter an account ID in the Account column of a journal, the system enters a default entity in the Entity column in the same row. If you pasted an entity in the current journals session, the system uses the most recent entity you pasted as the default entity. If you have not pasted an entity, the system uses the current entity from the point of view as the default entity.

To enter adjustment information:

1. From the Journals window, create or open the journal or template to which you want to add adjustments. For instructions on creating journals or templates, see “Creating Journal Templates” on page 106. For instructions on opening journals or templates, see Hyperion Enterprise Getting Started.
2. Select the code, security class, and data view for the journal or template.
3. If you are entering adjustments for a parent journal, select the parent whose contribution values you want to adjust.
4. Take one or more of the following actions:
   - To add an adjustment on a blank row, type the ID of the account you want to adjust in the Account column, or select Edit > Paste Account and select an account from the Paste Account dialog box.
To change the entity to which an adjustment will be posted, highlight the existing entity and
type the new entity ID, or select Edit > Paste Entity and select an entity from the Paste Entity
dialog box.

To enter an adjustment amount, type an amount in the Debit or Credit column in the row
for the adjustment and press Enter.

To add a blank row before an existing adjustment, highlight the account ID for the existing
adjustment and select Edit > Insert Row.

Creating Journals Using Recurring Templates

You can use a recurring template to create journals in previously opened periods. You select the
first period in which to create the journal. The system then creates journals in all periods from
the start period to the last opened period in the category. For example, if you create a recurring
template in the April 03 period, you can create journals based on that template in the January,
February, or March periods. The system creates but does not post the journals. You can post the
journals in the appropriate periods. For more information, see “Posting Individual Journals”
on page 111.

To create a journal using a recurring template:

1 From the Journals window, open the recurring template from which you want to create journals. For
instructions, see Hyperion Enterprise Getting Started.

2 Select Task > Apply Recurring Template.

3 Select the start period for the range of periods in which to create the journals.

4 Click OK.

Saving Journals as New Journals

You can save an entire journal or template to a different label. The new journal will be in the
same category and period and will be the same type of journal.

The status of the existing journal will not be used for the newly saved journal. The status of the
newly saved journal will be Unposted.

To save a journal or template as a new journal:

1 From the Journals window, select File > Save As.

   Note:   You cannot use the Save As command for journals that are locked, manually reversed, or
auto-reversed.

2 In the Label text box, enter a unique label for the new journal.

3 Take one of the following actions:
   
   To save and close the new journal, click OK.

   To cancel the changes, click Cancel.
To save and display the new journal, click **Open**.

---

**Reviewing Journals**

You set a status of a journal to Reviewed to indicate that it is ready for posting. You can define security access to specify that only certain users can review journals. For example, if you want to ensure that all journals are reviewed by a manager before any user can post them, you can set security so that only managers can review journals. For information on setting security for journals, see the *Hyperion Enterprise Administrator’s Guide*.

When you create a journal, the journal status is Unposted. In an application that does not use the Reviewed status, you can post the unposted journal. In an application that uses the Reviewed status, you must set the journal’s status to Reviewed before posting it. You can review journals individually or select several journals at once and change their status to Reviewed. For information on the Use Reviewed Status option, see the *Hyperion Enterprise Administrator’s Guide*.

The following requirements must be met before you can review a journal:

- The status of the journal must be Unposted.
- All adjustment information must be complete.
- If the journal is a balanced journal, then the total debits must equal the total credits.
- If the journal is balanced by entity, then the total debits must equal the total credits for each entity.
- You must have security rights to review journals.
- You must have sufficient security rights to all accounts and entities in the journal detail.

---

**Reviewing Individual Journals**

You can change the status of an individual journal to Reviewed in the Journals window. You review a journal to verify that it is correct and indicate that it is ready for posting.

To review an individual journal:

1. Open the journal in the **Journals** window. For instructions, see *Hyperion Enterprise Getting Started*.
2. Click **Review**.

---

**Reviewing Multiple Journals**

You can change the status of multiple journals simultaneously without opening each one in the Journals window. This is faster than reviewing them individually.

To review multiple journals:

1. From the **Journals** window, select **Task > Review Journals**.
To filter the list of available journals, select any of the filter check boxes.

To further filter the list of journals, select **Criteria**, specify the filter criteria, then click **OK**.

Take one or more of the following actions:

- To review all of the available journals, click **Add All**.
- To review selected journals only, select the journals you want to review from the **Unposted journals** list box, then click **Add**.
- To select multiple adjacent journals, select the first journal and either drag to select the remaining journals in the range or hold down **Shift** and select the last journal in the range.
- To select multiple nonadjacent journals, hold down **Ctrl** while selecting journals.
- To deselect any journals that you specified, select the ones that you do not want to review from the **Journals to Review** list box, then click **Remove**.

Click **OK**.

### Journal Lock

When you post adjustments to an entity in a period, the system locks data for that entity and period in the database. You cannot enter or change data in Schedules or load or change data directly in the database for that entity and period. This ensures a complete audit trail of data values.

To unlock data and allow changes from sources other than journals, you must unpost or edit all journals that contain adjustments to that entity and period. When you edit a posted journal, the system unposts the journal. For more information on unposting and editing journals, see “**Reversing Journals**” on page 113.

You can apply a journal lock in the database without posting a journal. You can use this option to ensure that users provide an audit trail when they modify data. For more information on locking data without posting journals, see Chapter 2, “**Loading and Extracting Data**.”

**Note:** Accounts, subaccounts, entities, and subentities to which you have posted journal adjustments are restricted by the system. You cannot delete these elements without unposting or editing all journals that adjust their values.

### Posting Journals

You post a journal to apply the adjustments to the database. Until you post a journal, the adjustments exist in the journal only and do not affect the database, consolidations, or formula calculation results.

You can edit a posted journal if you need to correct an adjustment, and you can reverse a posted journal to back out its value. If you need to make extensive corrections in the database for a period after you have posted journals for that period, you can unpost the journals for that period, make the corrections, and then post the journals again. You can open and close a journal as many times as necessary to enter or change adjustments before you post it.
You can post a journal from the Journals window, or you can select multiple journals to post at once. If the Calculate Formulas option is selected for the application, the system automatically adjusts the balances in the chart of accounts after you post a journal.

The following factors are required before you can post a journal:

- If the Use Reviewed Status option is selected for the application, then a journal must have the status Reviewed before you can post it. For information on reviewing journals, see “Reviewing Journals” on page 109. For information on the Use Reviewed Status and Calculate Formulas options, see the Hyperion Enterprise Administrator’s Guide.

- If the Use Reviewed Status option is deselected for the application, then a journal must have the status of Unposted.

- All entry detail must be complete.

- If the journal is a balanced journal, then the total debits must equal the total credits.

- If the journal is balanced by entity, then the total debits must equal the total credits for each entity.

- You must have security rights to post journals.

- You must have sufficient security rights to all accounts and entities in the journal detail.

**Note:** You cannot post a journal to an entity if a schedule or the database is open for the same entity in another window. Hyperion Enterprise generates an error message if you try to post a journal to an entity that is opened by another user. This error message is written to the error log. For more information on the error log, see Hyperion Enterprise Getting Started Guide.

### Posting Individual Journals

You can post an individual journal in the Journals window. This allows you to check the journal adjustments before you post them.

To post an individual journal:

1. Open the journal that you want to post in the Journals window. For instructions, see Hyperion Enterprise Getting Started.

2. Click Post.

### Posting Multiple Journals

You can post several journals simultaneously without opening them individually in the Journals window. For example, you might want to post several journals after reviewing the adjustments that other users have entered in them. This is faster than posting the journals individually.

If the system encounters an invalid journal while posting multiple journals, the system continues processing the remaining journals. An error message is written to the ERROR.LOG file detailing the problem journal or journals.
To post multiple journals:

1. From the Journals window, select Task > Post Journals.
2. To filter the list of available journals, select any of the filter check boxes.
3. To further filter the list of journals, select Criteria, specify the filter criteria, then click OK.
4. Take one or more of the following actions:
   - To post all of the unposted journals, click Add All.
   - To post selected journals only, select the journals you want to post from the Available Journals list box, then click Add.
   - To select multiple adjacent journals, select the first journal and either drag to select the remaining journals in the range or hold down Shift and select the last journal in the range.
   - To select multiple nonadjacent journals, hold down Ctrl while selecting journals.
   - To deselect any journals that you specified, select the ones you do not want to post from the Journals to Post list box, then click Remove.
5. Click OK.

Unposting Journals

You can unpost journals for a period if you need to make extensive changes to the database for that period. When you unpost journals for a period, the system unlocks the data for that period and the entities to which adjustments were posted. If the Calculate Formulas option is selected for the application, the system automatically adjusts the balances in the chart of accounts after you unpost a journal. For information on the Calculate Formulas option, see the Hyperion Enterprise Administrator's Guide.

If you need to correct adjustments you have reviewed or posted, you can edit the journal. For example, suppose you have posted several journals with adjustments to the Israel entity and you receive new data for Israel. You can unpost the journals, load the new data, and then post the journals again. For information on editing a reviewed or posted journal, see “Editing Templates or Journals” on page 113.

Note: You cannot unpost an auto-reversing journal if you have opened the next period, and you cannot unpost an auto-reversed or reversed journal.

To unpost journals:

1. From the Journals window, select Task > Unpost Journals.
2. To filter the list of available journals, select any of the filter check boxes.
3. To further filter the list of Journals, select Criteria, specify the filter criteria, then click OK.
4. Take one or more of the following actions:
   - To unpost all of the available journals, click Add All.
To unpost selected journals only, select the journals you want to review from the Available Journals list box, then click Add.

To select multiple adjacent journals, select the first journal and either drag to select the remaining journals in the range or hold down Shift and select the last journal in the range.

To select multiple nonadjacent journals, hold down Ctrl while selecting journals.

To deselect any journals you specified, select the ones you do not want to unpost from the Journals to Unpost list box, then click Remove.

5 Click OK.

Note: If the system encounters an invalid journal while posting multiple journals, the system will continue processing the remaining journals. An error message will be written to the error.log file detailing the problem journal or journals.

Hyperion Enterprise generates an error message when you try to unpost a journal to an entity that is opened by another user. This error message is written to the error log. For more information on the error log, see Hyperion Enterprise Getting Started Guide.

Editing Templates or Journals

You can modify any template or journal. For example, you can insert blank rows in a journal to add adjustments, or you can delete adjustments. You can also change the description of an unposted journal or template. You cannot change the ID of a journal or template.

You can modify journals even after you review or post them. The system automatically unposts the journal before you make the corrections. When you finish editing, you must review or post the journal again to apply the corrected adjustments to the database. For information on reviewing journals, see “Reviewing Journals” on page 109. For information on posting journals, see “Posting Journals” on page 110.

After you edit a journal, you can review or post the journal, depending on the application settings for the Reviewed Status option. You cannot edit a posted auto-reversing journal after you open the following period. You cannot edit an auto-reversed or reversed journal.

To edit a template or unposted journal:

1 From the Journals window, open the journal that you want to edit. For instructions, see Hyperion Enterprise Getting Started.

2 To edit a reviewed or posted journal, click Edit.

3 Change the description and adjustment information as needed.

4 Select File > Save to save the changes to the journal.

Reversing Journals

You can back out the values of a posted journal by reversing it. When you reverse a journal, the system creates and posts a copy in which the debits and credits are reversed. The adjustments in
the reversed journal cancel the adjustments in the original journal. The original posted journal and the reversed copy both remain in the application. This provides a complete audit trail.

If the Calculate Formulas option is selected, the system adjusts the balances in the chart of accounts after you reverse a journal. For information on the Calculate Formulas option, see the Hyperion Enterprise Administrator’s Guide.

When you reverse a journal for a period, its ID becomes unavailable for that period. For example, if you reverse a journal for the first quarter, you cannot create another journal with the same ID for the first quarter, but you can create one with that ID for the second quarter.

**Note:** You cannot edit or unpost reversed journals.

To reverse a journal:

1. Open the journal that you want to reverse in the Journals window. For instructions, see Hyperion Enterprise Getting Started.
2. Click Reverse.

### Extracting Journals

You can extract journals and journal templates for the current category to a text file. For example, you might want to extract journals from one application and load them into another application. Here are the options that you can use to extract journals:

- You can use the Extract All Periods option to extract journals that meet specified criteria from all periods in the current category. For example, you can extract all unposted journals.
- You can use the Extract Single Period option to extract only journals that you select in the current period.
- You can also extract journals with Posted status as unposted. For example, suppose a site location enters and posts journals in an application and needs to send the same information as unposted data to Headquarters. You would select the Extract Posted Journals as Unposted option on the Extract Journals dialog box. The posted journals have a status of unposted. In the ASCII file these posted journals have a status of T for transfer of shares and are treated the same as unposted journals when the system loads the journal ASCII file. For more information on posting journals, see “Posting Journals” on page 110.

If you are using server-based processing to extract journals, a window appears that shows the extracting progress. This window is a separate program, so you can perform other tasks in Hyperion Enterprise or exit Hyperion Enterprise while the server is processing. The window closes when the server finishes processing or an error message appears if there is a problem.

To extract journals:

1. From the Journals window, take one of the following actions:
   - To extract journals from all periods, select Task > Extract Journals > All Periods.
To extract journals from the current period, select Task > Extract Journals > Single Period, then open the journal that you want to extract.

2 Type a file name to store the extract journals, or click Browse to find a file.

3 To use a character other than an exclamation point ( ! ) to separate the data items in the extracted journals, type the character in the Delimiter edit box.

4 Select whether to extract posted journals as unposted.

5 Filter the list of journals.

6 Click OK.

The Server Options dialog box is displayed.

7 Select Server if the application is server enabled and you want to execute on the server or select Local if selectable and you want to execute on the local workstation.

### Loading Journals

You can load posted or unposted journals and journal templates for the current category from text files. For example, you can load standard journal templates extracted from one application into another application. You can also load journals created or modified with a text editor.

When you load journals from a text file, you specify the types of journals you want to load. For example, if a text file contains recurring journal templates, you can load the templates, the posted journals, or both. For information on the journal load and extract file format, see “Journal Load and Extract File Format” on page 116.

When loading a journal from an ASCII file, you have the option to overwrite an existing unposted journal with the same label. This information is posted to the error log, and a warning message appears at the end of the load informing you to view the error log. The system loads all journals of the selected types for the current category. If you load a journal for a period that is not open for journals, the system opens the period. If you load posted journals, the system locks the entities to which the adjustments in the journals have been posted, and the data and status are not affected. This prevents double-counting of adjustment amounts.

**Note:** To load posted journals, you must have Modify security rights to the Load Posted Journals securable task.

In an application that uses automatic journal numbering, the system assigns a five-digit number to each journal when you load it. The system follows the sequence of the load file when loading journals. For more information, see ”Journal Number” on page 98.

A journals load file must follow a specific format. You can use the 1.8 Format option to load journals from a file that uses the format from Hyperion Enterprise SE. The system stores any errors that occur while loading journals in the error log. For information on the error log, see Hyperion Enterprise Getting Started.
Note: When you load journals from an ASCII text file, the system does not change any data in the database. For example, if you load a posted journal, the system assumes that the effect of the journal on the data has been written to the database. Therefore, you should load journals only after you perform a database load when you rebuild an application using ASCII text files.

If you are using server-based processing to load journals, a window appears that shows the loading progress. This window is a separate program, so you can perform other tasks in Hyperion Enterprise or exit Hyperion Enterprise while the server is processing. The window closes when the server finishes processing or when an error occurs.

To load journals:

1. From the Journals window, select Task > Load Journals.
2. Type the file name from which to load journals, or click Browse to find the file.
3. If the file you are loading does not use an exclamation point ( ! ) as the delimiter, type the correct character in the Delimiter text box.
4. Use the check boxes to filter the journals that you want to load.
5. Click OK.

The Server Options dialog box is displayed.
6. Select Server if the application is server enabled and you want to execute on the server or select Local if selectable and you want to execute on the local workstation.

Journal Load and Extract File Format

When you load journals into Hyperion Enterprise from a text file, the text file must follow this format:

```
[JOURNAL=ID, Attribute, Template, Type, Status, Category, Period, Class, Parent, Code, Future] DESC=Description <Entity1>, <Account1>, <Debit1>, <Credit1> .. .. <Entityn>, <Accountn>, <Debitn>, <Creditn>
```

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>The ID of the journal.</td>
</tr>
<tr>
<td>Attribute</td>
<td>U for unbalanced adjustments, B for balanced adjustments, or E for adjustments that are balanced by entity.</td>
</tr>
<tr>
<td>Template</td>
<td>J for a journal, R for a recurring template, or S for a standard template.</td>
</tr>
<tr>
<td>Type</td>
<td>R for regular adjustments, A for auto-reversing adjustments, or T for parent adjustments.</td>
</tr>
<tr>
<td>Status</td>
<td>U for an unposted journal, P for a posted journal, W for a reviewed journal, O for an auto-reversed journal, V for a reversed journal, T for a posted journal extracted as unposted, or L for a locked journal.</td>
</tr>
<tr>
<td>Category</td>
<td>The ID of the category to adjust.</td>
</tr>
<tr>
<td>Variable</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Period</td>
<td>The ID of the period to adjust.</td>
</tr>
<tr>
<td>Class</td>
<td>The ID of the security class assigned to the journal or template.</td>
</tr>
<tr>
<td>Parent</td>
<td>The parent for the journal.</td>
</tr>
<tr>
<td>Code</td>
<td>The code for the journal.</td>
</tr>
<tr>
<td>Future</td>
<td>C for adjustments that affect future periods in the category-to-date view, or P for adjustments that affect future periods in the periodic view.</td>
</tr>
<tr>
<td>Description</td>
<td>The description for the journal or template.</td>
</tr>
<tr>
<td>Entity1</td>
<td>The entity in the first row of the adjustment table.</td>
</tr>
<tr>
<td>Account1</td>
<td>The account in the first row of the adjustment table.</td>
</tr>
<tr>
<td>Debit1</td>
<td>The debit in the first row of the adjustment table.</td>
</tr>
<tr>
<td>Credit1</td>
<td>The credit in the first row of the adjustment table.</td>
</tr>
<tr>
<td>Entityn</td>
<td>The entity in the last row of the adjustment table.</td>
</tr>
<tr>
<td>Accountn</td>
<td>The account in the last row of the adjustment table.</td>
</tr>
<tr>
<td>Debitn</td>
<td>The debit in the last row of the adjustment table.</td>
</tr>
<tr>
<td>Creditn</td>
<td>The credit in the last row of the adjustment table.</td>
</tr>
</tbody>
</table>

**Journal Production Reports**

Journal production reports provide information about the journal adjustments made to the database. Here are the types of journal production reports you can run on selected journals or accounts:

- Journals reports
- History reports
- Trial balance reports

You select the content and format of journal production reports, and then preview or print the reports. You can determine the headers, footers, IDs, columns, rows, and data of the journal production reports that you run.

**Running Journals or History Reports**

Journals reports and history reports provide summary information about selected journals. When you create a journals report or a history report, you select the journals to include in the report and then determine the content and format of the report.
A journals report provides information about the status of journals at the time you run the report. You run a journals report to check the current status of one or more journals.

A history report provides a complete audit trail of selected journals. For example, a history report might show that a journal has been posted and reversed and the amounts of its adjustments. History reports provide the most detailed information about the history of a journal. If you post a journal and then edit it, the journal status is Unposted. The history report, however, indicates that the journal has been posted and edited by adding P&E to the journal ID.

You can include deleted journals in a journals report if the autonumbering option has been selected during application setup. The journals report includes a list of deleted journals without any detail. For more information on autonumbering, see the Hyperion Enterprise Administrator’s Guide.

To run a journals or history report:

1. From the Journals window, take one of the following actions:
   - To run a journals report, select Task > Journal Production Reports > Journals Report.
   - To run a history report, select Task > Journal Production Reports > History Report.
2. Filter the list of journals.
3. To further filter the list of Journals, select Criteria, specify the filter criteria, then click OK.
4. Select one or more journals to include in the report and click OK.
5. Select the columns and attributes for the report.
6. Take one or more of the following actions:
   - To print the report, click Print. For instructions on printing and previewing in Hyperion Enterprise, see Hyperion Enterprise Getting Started.
   - To preview the report, click Preview.
   - To save the current settings as defaults, click Set Defaults.
   - To return to the Journals window, click Close.

Running Trial Balance Reports

You can run a trial balance report to verify the balance of a selected account. Trial balance reports provide information about any account to which journal adjustments have been made.

When you run a trial balance report, you first select the entity in the point of view and the account to include in the trial balance and then specify the format of the report.

To run a trial balance report:

1. From the Journals window, select Task > Journal Production Reports > Trial Balance Report.
2. Select an account and click OK.
3. Optional: Change the width in the Width text boxes for any of the columns.
4. Take one or more of the following actions:
● To print the report, click **Print**.
● To preview the report, click **Preview**.
● To save the current settings as defaults, click **Set Defaults**.
● To close the dialog box without printing, previewing, or setting defaults, click **Close**.
# Using Hyperion Enterprise Web

## What Hyperion Enterprise Web Does

Hyperion Enterprise Web enables you to perform Web-based application setup, view data, journals, templates, consolidation status, event log, active Web users, and task status, load data, journals, open periods, and perform Web-based consolidations over the Internet or an intranet. Using Hyperion Enterprise Web you can perform consolidations and data loads from any remote location at which you have an Internet or intranet connection. Your security rights to Hyperion Enterprise Web functionality is set by your system administrator in Hyperion Enterprise. For more information, see your system administrator.
Selecting the Point of View

The point of view (POV) is a set of elements that you define to specify which data Hyperion Enterprise Web accesses when you start an application. The POV bar is made up of links and is located below the navigation menu bar. Each link represents an element in the POV: category, reporting period, organization, entity, and parent. You can also view consolidation detail if this option was selected when the application was created. Items in POV elements sort alphabetically. Therefore, numbers sort numerically by digit. For example, periods may sort 1, 2, 10, 11, 12, 13, 20, 21 and so on. For more information, see *Hyperion Enterprise Getting Started*.

**Note:** When you clear or modify a parent element in the POV, the children elements are automatically adjusted. For example, if you set category to None, the reporting period is set to None, as well.

To select the POV:

1. From the Hyperion Enterprise Web Desktop, click a POV element link. The Select Element page is displayed.
2. Click a POV element in the scrollable list, then click Select Dimension.

**Tip:** You can search for a POV element by entering at least the first characters of its name in the Find text box and then click Select Dimension. The list scrolls to the first POV element that matches what you entered.

Use to view more records, select Next and Previous button .

3. To select an additional POV element, click the link for that element near the top of the Select Element page, then repeat step 2.
4. Click Set POV to set the POV to the selected elements.

Loading Data

You load data to transfer Hyperion Enterprise data between different locations, applications, or software packages. For example, you can load data that has been extracted from other sites into an application at headquarters, or you can load data into Hyperion Enterprise from a general ledger.

You can load data into a Hyperion Enterprise database from an ASCII file. Many external systems, such as general ledgers and spreadsheets, can create ASCII files that you can load into Hyperion Enterprise. If necessary, you can edit an ASCII file with a text editor before loading it.

To load a data file:

1. From the Hyperion Enterprise Web Desktop, in the global selection frame, select Data.

The tasks you can perform in the Data module are displayed in the local selection frame.
2. In the local selection frame, click **Load Data**.

The Load Data page is displayed. This page includes the Load Data box, as shown in Figure 22.

![Figure 22 Load Data Box](image-url)

3. In the **File Properties** text boxes, enter the names of the files that you want to upload, or click **Browse** to navigate to the file names.

4. Optional: To load the specified data files without uploading them to the server, clear the **Upload** check box. If the **Upload** check box is selected, the files are uploaded to the Web.

   **Note:** If you are uploading the data, make sure that the data files are fully accessible to the Web Server.

5. Select one of the following **Mode** options:

   - **Merge** - Clears existing values only from the accounts specified in the data load file and then replaces them with the values in the file. Unlike the Replace option, the Merge option clears only the values from the accounts specified in the load file.
- **Replace** - Clears the existing values from all accounts for the periods specified in the data load file and then loads the values from the data load file. If an account is not specified in the load file, its values for the specified periods are cleared during the load.

- **Accumulate** - Adds the values in a load file to the values that are already in the application.

6. From the **Format** drop-down list, select a format for the data file, or select **Default** to use the system default.

7. **Optional**: To use a different account or entity conversion table than the one that is specified in the format you selected, select the **Override Format Conversion Tables** check box in the **Conversion Tables** area.

8. **Optional**: In the **Conversion Tables** area, select an account conversion table from the **Account** drop-down list, an entity conversion table from the **Entity** drop-down list, or both.

**Note**: You can select an account or entity conversion table only if you selected the **Override Format Conversion Tables** check box.

9. In the **Data Options** area, select one or more of the check boxes to specify how you want Hyperion Enterprise Web to process the data that you are loading:
   - **Calculate Formulas** - Calculates formulas during the data load, so you do not have to manually calculate formulas after the load.
   - **Report Calc Accounts** - Tracks attempts to load data into calculated accounts, which normally derive their values from other accounts.
   - **Zero No Data** - Converts missing data in load files to zero values in Hyperion Enterprise accounts. Hyperion Enterprise Web converts no-data values to zero values only if you load a no-data value into an account that has data in a previous period.

10. **Click** **Submit**.

If you selected the Upload check box, the Upload Progress window is displayed.

**Caution!** Do not perform any other action in the Web browser that is performing the upload until the upload is complete, or the file upload will be cancelled. You can perform only the following actions from the Uploading page while an upload is in progress: Close the Upload Progress window and display it again by clicking **Display Progress**, or cancel the upload by clicking **Cancel Upload**.

When the data load is complete, regardless of whether you uploaded it to the server, the Task Submission Status page is displayed. This page uses one of the following codes to indicate whether the data load was successful:

- **0** - The data load was successful.
- **2** - The data load was unsuccessful.
- **3** - The data load was unsuccessful.

If a code of 2 or 3 is displayed, check the Application error log. For instructions, see “Viewing the Application Error Log” on page 133.
Viewing Consolidation Status

The Consolidation Status page displays a status for each entity and period in the current category. The consolidation status indicates which entities and periods have been impacted by data or method changes and need to be consolidated. It also indicates which entities contain no data for specific periods.

Tip: You can easily navigate within the Consolidation Status page. You can click on an entity name in the Current Path field to navigate within your current path structure or you can click on the down arrow located in the left column of your Consolidation Status page to drill down on a specified entity. If there are more than fifty entities displayed, you can Page Up and Page Down.

To view the consolidation status:
1. From the Hyperion Enterprise Web Desktop, select the POV for which you want to view consolidation status.
2. In the global selection frame, select Consolidation.
   The tasks you can perform in the Consolidation module are displayed in the local selection frame.
3. Select View Consolidation Status.
   The Consolidation Status frame is displayed.
4. Click Refresh Grid.

Note: Other users may be changing or consolidating data, so use the Refresh Grid option at any time to retrieve the most current data.

Finding an Entity or Account

The Find option enables you to search for an entity within your current organization or for an account within your current grid type. The Find option is available only on the Consolidation Status and View Data pages.

To find an entity:
1. From the View Consolidation Status frame, click Find.
2. In the Find text box, enter the full or partial path name separated by pipes ( | ), or enter an entity name.
3. Select Within Current Path to search only within the current path.
4. Click Find Next to start your search.

To find an account:
1. From the View Data frame, click Find.
2. In the Find text box, enter an account name and then click Find.
Consolidating Data

Consolidation is the process of gathering data from dependent entities and rolling it up into a parent entity. During consolidation, the account values for dependent accounts roll up to the parent accounts. Financial data of each parent consists of the values consolidated from its dependents. If you change the data of a dependent, the data of the parent changes when you consolidate.

When you perform consolidations, you can consolidate data for the current category for all entities in an organization or for a specific branch of the organization. Consolidating a specific branch, which is also called a partial consolidation, is useful if you need to report on an entity other than the top entity in an organization. For example, suppose you need to run a report on the Europe entity, which is a dependent entity in the Corp organization. You can consolidate data for Europe only, then run the report on Europe's consolidated data. For more information, see Chapter 4, “Consolidating Data.”

To consolidate data:

1. From the Hyperion Enterprise Web Desktop, in the global selection frame, select Consolidation.

   The tasks you can perform in the Consolidation module are displayed in the local selection frame.

2. In the local selection frame, select Consolidate.

   The Consolidate Data frame is displayed.

3. In the Consolidate Data frame, take one of the following actions:

   - To consolidate only entities with IMPACTED status, select Impacted.
   - To consolidate all selected entities that have data, select All with Data.
   - To consolidate all selected entities and periods regardless of whether they have data, select All.

4. Select a Start Period, an End Period, and a Parent.

5. Click Submit to start consolidating.

   Note: When consolidation begins, the process is off-loaded to the predefined Task Server.

   The Task Submission Status page is displayed.

6. Verify that your consolidation task has been added to the queue successfully.

7. Click Return to the Desktop.
Viewing Task Status

The Task Status page displays the tasks submitted to the task server for Data Loads and Consolidations. The tasks can be filtered by task state, task date, and task time. You can use the task status to see if a data load or consolidation is complete.

To view task status:

1. From the Hyperion Enterprise Web Desktop, in the global selection frame, select Logging.
   The tasks you can perform in the Logging module are displayed in the local selection frame.

2. In the local selection frame, select View Task Status.
   The Task Status frame is displayed. It includes a Display Tasks box (shown in Figure 23) and the column headings for the Task List. You use the Display Tasks box to specify which tasks to include in the Task List.

3. From the Task State drop-down list, select a task state.

4. Optional: In the Start Date text box, enter a date in MM/DD/YYYY format, or click the calendar icon to select a date. If you do not specify a start date, all tasks before the specified end date are listed.

5. From the Start Time drop-down list, select the starting time for the task list. If you do not specify a start time, all tasks before the specified end time are listed.

6. In the End Date text box, enter a date in the MM/DD/YYYY format, or click the calendar icon and select a date. If you do not specify an end date, all tasks after the specified start date are listed.

7. From the End Time drop-down list, select the ending time for the task list. If you do not specify an ending time, all tasks after the specified start time are listed.

8. Click Submit.
   The Task List displays the statuses of tasks that meet the specified criteria.

9. Optional: Take one or more of the following actions:
   - To stop a task while it is in progress, click Cancel and then click Cancel Tasks.
   - To check whether any errors occurred during a task, click the icon in the Log column for that task.
Viewing Data

You can view data in a grid of any of the following types:

- Chart of Accounts
- Dynamic Account List
- Fixed Account List
- Fixed Account List with Dynamic Subaccounts
- Schedule

When you first access View Data, the system lists all account groups in the chart of accounts and indicates whether the accounts in each group contain data.

You can click a plus sign ( + ) to the left of a group name in the Account column to view an account in that group. If more than 50 groups or accounts are listed, you can use the Page Up and Page Down buttons to view additional group or account names. You can also click Find and enter the name of a group or an account to find it in the list that is displayed.

To view data:

1. From the Hyperion Enterprise Web Desktop, in the global selection frame, select Data.
   The tasks you can perform in the Data module are displayed in the local selection frame.

2. In the local selection frame, select View Data.
   If the Warning - Security page is displayed, as shown in Figure 24. You can install an application's digital signature the Warning - Security applet from this page.

3. Do the following to complete the installation:
Click Run to install an application’s digital signature the Warning - Security applet.

If you do not want to install and run an application’s digital signature the Warning - Security applet, click Cancel to end the installation process.

**Note:** If you do not install an application’s digital signature the Warning - Security applet, you cannot manually enter or edit data directly in the View Data grid.

When you select an option for installing and running an application’s digital signature, the View Data page is displayed, showing the entire chart of accounts.

- From the License Agreement window dialog box, then select the Typical setup option and then click Accept.
- From the Java Runtime SE Environment window dialog box, then select Next to continue the installation process.
- Click Finish to exit from the wizard.

4 **Optional:** Change the data view by clicking the current selection.

The data view options are Periodic and CTD (Category to Date). Clicking CTD changes the view to Periodic, and clicking Periodic changes the view to CTD.

5 **Optional:** To view an account list or schedule instead of the entire chart of accounts, from the Grid Type drop-down list select an account list type or select Schedule, then click Select.

The Select Element Web Page Dialog box is displayed.

6 If you selected an account list type or schedule in the preceding step, in the Select Element Web Page Dialog box, click the account list or schedule name and then click Select Dimension.

**Tip:** You can search for an account list or schedule in the list by entering all or part of the account list or schedule name in the Find text box and then clicking Go. The list scrolls to the first account list or schedule name that matches what you entered.

7 Click Refresh Grid.

The data grid is updated to show data for the selected account list or schedule. For information on searching for a specific account on the View Data page, see “Finding an Entity or Account” on page 125.

**Note:** Other users may be changing or consolidating data, so use the refresh grid option at any time to get the most current data.

### Setting Schedule Options

The following options determine the appearance of a schedule and how it calculates data.

- Showing account labels or descriptions or account labels and descriptions in the account column
- Showing data for all periods or the current period
To set schedule options:

1. From the View Data page, open a schedule. See “Viewing Data” on page 128.
2. From the View Data page, select (Schedule Options).
3. Specify whether to display the account label or description or account label and description, periods shown, and formulas.
4. Specify whether to suppress rows for accounts with no data.
5. Click OK.

**Entering and Editing Data**

If the Hyperion Solutions applet is installed, you can enter or edit data directly in the View Data grid.

To enter data:

1. Click within the cell where you want to enter or edit data.
2. Enter the new data in the highlighted cell.
3. Click Save To File to save your data to a specified file and directory.

**Caution!** If you do not save your data to a file, your changes are lost and cannot be uploaded to Hyperion Enterprise.

4. Select one or more of the following options to indicate how you want to save your file:
   - **Extract all Input Accounts** - Extracts all input accounts that are displayed on the page. If you do not select this option, only updated cells are extracted.
   - **Extract Locked Periods** - Extracts locked periods.
   - **Append to Existing File** - Appends the data to an existing data file.
   - **Upload Data File** - Uploads the file to the server and loads the data into Hyperion Enterprise.

   If you select the Upload Data File check box, the Mode and Format drop-down list boxes are displayed.

**Note:** If you do not select the Upload Data File option, a data file is created, but you must later upload the file manually using the Data Load feature.

5. If you selected the Upload Data File check box, select an upload mode from the Mode drop-down list and a format for the uploaded data from the Format drop-down list.
6. Click Save File.
**Locking and Unlocking Data**

You can lock and unlock periods to restrict or permit data changes. You cannot change data or consolidate in a locked period. You can lock periods to freeze values, and you can unlock them later if you want to allow changes to the values. For example, once all data for the January period is entered, you can lock the period until you are ready to run reports to ensure that the data is not changed accidentally. For more information, see Chapter 2, “Loading and Extracting Data.”

To lock or unlock data:

1. **From the View Data frame, click Lock/Unlock Data.**
   
   The Lock/Unlock Data page is displayed.

2. **Take one of the following actions:**
   
   - If the period is not locked, click **Lock**.
   - If the period is locked, click **Unlock**.

3. **Select an entity list to lock or unlock.**

4. **Specify a period for which you want to lock or unlock data.**

5. **Click Submit.**

   The Task Submission Status page is displayed, indicating whether or not your task was added to the queue successfully. For more information on viewing the status on the task, see “Viewing Task Status” on page 127.

**How Data is Displayed in Hyperion Enterprise Web**

You can view or enter data in Hyperion Enterprise Web using a scaled number format. Scaling options determine how the system displays and interprets data. They save you time by enabling you to enter data to the precision required. For example, if you set the scale for the U.S. Region entity to thousands (3), and you enter a value of 6 in the Sales account for the U.S. Region, the system displays the number as 6 but stores the number as 6,000. If you do not scale the Sales account, and you enter a value of 6, the system displays and stores the number as 6.

**Note:** Before you can use scaling, the scale option must be checked for an account. Scaling is set on the category or on the entity. If a category does not have a scale set, then the system uses the scale of the entity selected in the Point of View.

If you specify number formatting in Hyperion Enterprise, the thousands separator is used as the thousands, millions and billions separator in Hyperion Enterprise Web. If you use the System Settings, the number formatting is determined by the client operating system settings.

The Decimals detail displays the number of decimal places for an account value in the View Data page. For example, if you set the Decimals attribute of an account to 0 (zero), the system displays values for that account as whole numbers. If you set the Decimals attribute of an account to 2, the system displays values for that account with two decimal places, such as 8.25.
Note: If you enter a value where the number of decimal places exceeds the number of decimal places displayed for an account, the number is rounded to the specified number of decimal places. For example, if scale = 0, and decimal places = 2 and you enter 1.321, 1.32 is displayed when you leave the field or press Enter.

The Account Detail area of the View Data page displays the scale of a category or entity and the number of decimal places of the selected account as shown in Figure 25.

Figure 25 Hyperion Enterprise Web View Data Page

For more information on scaling, see the Hyperion Enterprise Administrator’s Guide.

Working with Data Drill-Back to FDM

To work with data drill-back to FDM, enable visual cue. Set the required POV to view dimensions that contain FDM data.

To drill-back to FDM data

1. In the Hyperion Enterprise Web module, in the global selection frame click Data, in the local selection frame click View data, in the View Data pane, right-click the database cell and select Audit Intersection.

   The FDM data drill-back page opens.

2. You can gather the required information on the data.

   For more information on the drill-back options, see the FDM documentation.
**Viewing the Application Error Log**

The Application Log is the error log for the Hyperion Enterprise application. Many different types of messages can be written to the Application Log: data load errors, consolidation errors, Hyperion Enterprise system errors, and entity locking errors. You can open the Application Log and view any error or message you encounter while using Hyperion Enterprise Web.

To display the application log, from the Hyperion Enterprise Web Desktop, click View Application Log

---

**Customizing Web Links**

Using the `CustomLinks.js` file you can create links to four Web pages of your choice from the Tools module. The `CustomLinks.js` file contains the following information:

```javascript
var Customlink1_Text = "Oracle";
var CustomLink1_URL = "http://www.oracle.com"
var Customlink2_Text = "";
var CustomLink2_URL = "";
var Customlink3_Text = "";
var CustomLink3_URL = "";
var Customlink4_Text = "";
var CustomLink4_URL = "";
```

CustomLink1_Text is the text that is displayed for the first link and CustomLink1_URL is the page that displays when the first link is selected by a user. CustomLink2_Text and CustomLink2_URL are settings for the second link displayed, and so on, up to four links.

**Note:** The link to the Oracle home page is the default setting for CustomLink1. If you want, you can edit the link text and change the link settings for CustomLink1. For each link, modify only text between the quotation marks.

If either the Text or URL for a link is blank, no text between the quotation marks, the link is not displayed on the Hyperion Enterprise Web Desktop.

Once you create your links, you can edit a link or the text displayed for a link at any time. All links are displayed on the Hyperion Enterprise Web Desktop in the Tools module.

To customize Web links:

1. **Open the `CustomLinks.js` file**, which is located where your Web Server is installed.
2. **Enter text between the quotation marks (“ “) in the CustomLink2_Text line of the `CustomLinks.js` file**.
3. **Enter the URL of the Web page between the quotation marks (“ “) in the CustomLink2_URL line of the `CustomLinks.js` file**.
4. **Repeat steps 2 and 3 for each link that you want to create**.
5. **Save the `CustomLinks.js` file**.
Entering Journals in Web

A journal is a set of adjustments to account balances for one category and period. You use journals to record changes in account values and maintain an audit trail of those changes. You can use journal templates for common adjustments that you make on a regular basis, to create journals automatically for each period, or as a basis for creating new journals.

You create, edit, and post journals in the Journals module. When you post a journal, the system recalculates the account balances so that the database reflects the adjustments. You can refer to posted journals as records of adjustments, or run reports to check the trail of changes to account values.

For more information on Journals, see Chapter 5, “Entering Journals”.

Journals Module

With Journals module in Hyperion Enterprise Web you can view the journals and templates created in the application, create and modify journals and journal templates, review, post, unpost, and load journals, and open periods.

To work on journals:

1. From the Hyperion Enterprise Web page, in the global selection frame select Tasks > Journals.

Links to Journals module are displayed in the local selection frame.

Viewing Journals and Templates.

You can view journals and templates created in the Hyperion Enterprise application on the Web.

To view journals and templates:

1. In the global selection frame, select Journals.

The tasks you can perform in the Journals module are displayed in the local selection frame.

2. In the local selection frame, select Journals and Templates.

The Journals and Templates frame is displayed.

Journals and Templates

You can perform the following tasks in the Journals window:

- Create and modify journals and journals templates.
- Review Journals
- Post Journals
- Load Journals
Journals and Template Creation

Journals and template creation involves the following tasks:

- Opening periods
- Creating journals templates
- Creating journals
- Entering adjustment information

Opening Periods

You make journal adjustments for one category and one period. Before you can enter and post adjustments to the data for a period, the period must be open for journal entry.

For more information on opening periods, see “Opening Periods” on page 105.

To open a period:

1. In the global selection frame, select Journals.
   The tasks you can perform in the Journals module are displayed in the local selection frame.
2. In the local selection frame, select Open Periods.
   The Open Periods frame is displayed.
3. Select the next unopened period. If there are posted auto-reversing journals in the previous period, a message appears, warning that the journals will be reversed.
4. Click Refresh to refresh content area.

Creating Journal Templates

You can create two kinds of journal templates: standard and recurring. Standard templates contain information for similar adjustments that you enter frequently. When you create a standard template, that template is available for all periods in the application.

For more information, see “Creating Journal Templates” on page 106.

To create a journal template:

1. In the global selection frame, select Journals.
   The tasks you can perform in the Journals module are displayed in the local selection frame.
2. In the local selection frame, select Journals and Templates.
   The Journals and Templates frame is displayed.
3. In the Journals and Templates frame, select New.
   The New Journals/Templates frame is displayed.
4 In the New Journals/Templates frame, select Standard or Recurring, select the type of journal, then click OK.

5 Take one of the following actions:
- If you are creating a recurring template, enter complete adjustment information. For instructions, see “Entering Adjustment Information” on page 137.
- If you are creating a standard template, select which adjustment detail to include in a standard template. The only required information is the ID.

6 Click Save.

Creating Journals

Each journal that you create has a ID that is unique within the period. You can create a journal labeled CABLEADJ for each period in the Actual category, and you can create journals with that ID for different categories. You can also create journals and templates with the same ID in the same category. However, you cannot create two journals labeled CABLEADJ in one period for any category. If you have the Autonumbering option selected, you cannot create a journal with the same ID as one that has been previously deleted.

For more information on creating journals, see “Creating Journals” on page 106.

To create a journal:

1 In the global selection frame, select Journals.
   The tasks you can perform in the Journals module are displayed in the local selection frame.

2 In the local selection frame, select Journals and Templates.
   The Journals and Templates frame is displayed.

3 In the Journals and Templates frame, select New.
   The New Journals/Templates frame is displayed.

4 Select Journal and select the type of journal to create.

5 To use a standard template as a basis for a journal, select Use Standard Template and select a template from the list.

6 Click OK.

7 Enter an ID and press Enter.

8 Type a description for the journal or template, and enter the adjustment information. For instructions, see “Entering Adjustment Information” on page 137.

   Note: You can enter up to 254 characters in the journals description field.

9 Click Save.
Entering Adjustment Information

The adjustment information that you enter in journals and templates includes account IDs, entity IDs, and adjustment amounts.

For more information on entering adjustment information see, “Entering Adjustment Information” on page 107.

To enter adjustment information:

1. From the Journals and Templates frame, create or open the journal or template to which you want to add adjustments. For instructions on creating journals or templates, see “Creating Journal Templates” on page 114. For instructions on opening journals or templates, see Hyperion Enterprise Getting Started.
2. Select the code, security class, and data view for the journal or template.
3. If you are entering adjustments for a parent journal, select the parent whose contribution values you want to adjust.
4. Take one or more of the following actions:
   - To add an adjustment on a blank row, type the ID of the account you want to adjust in the Account column, or within the Web data grid double-click in the Account column and select an account from the Select Element - Web Page Dialog box.
   - To change the entity to which an adjustment will be posted, highlight the existing entity and type the new entity ID, or within the Web data grid double-click in the Entity column and select an entity from the Select Element - Web Page Dialog box.
   - To enter an adjustment amount, type an amount in the Debit or Credit column in the row for the adjustment.

   Note: If an entity or an account label is too long to view then hover the mouse over the label to view it in its entirety.

5. Click Save.

Reviewing Journals

You set a status of a journal to Reviewed to indicate that it is ready for posting. You can define security access to specify that only certain users can review journals.

For more information, see “Reviewing Journals” on page 109.

Reviewing Individual Journals

You can change the status of an individual journal to Reviewed in the Journals and Templates frame. You review a journal to verify that it is correct and indicate that it is ready for posting.

To review an individual journal:

1. From the Journal and Template frame, select the journal you want to review, then click Review.
**Note:** If Review is not selectable, in your application.ini file set the APP_JOUR_REVIEW value to 1.

The Task Submission Status frame is displayed.

2 To return to the Journals and Templates frame, Click **Return to Journals List Page**.

**Note:** You cannot review a journal template.

---

**Reviewing Multiple journals**

You can change the status of multiple journals simultaneously without opening each one in the Journals and Templates frame. This is faster than reviewing them individually.

To review multiple journals:

1 In the Journals and Template frame, select the journals you want to review, then click **Review**.

**Note:** If Review is not selectable, in your application.ini file set the APP_JOUR_REVIEW value to 1.

The Task Submission Status frame is displayed.

2 To return to the Journals and Templates frame, Click **Return to Journals List Page**.

---

**Posting Journals**

You post a journal to apply the adjustments to the database. Until you post a journal, the adjustments exist in the journal only and do not affect the database, consolidations, or formula calculation results.

For more information on posting journals, see “Posting Journals” on page 110.

---

**Posting individual journals**

You can post an individual journal in the Journals and Templates frame. This allows you to check the journal adjustments before you post them.

To post an individual journal:

1 In the Journals and Templates frame, select the journal you want to post, then click **Post**.

The Task Submission Status frame is displayed.

2 To return to the Journals and Templates frame, Click **Return to Journals List Page**.
Note: You cannot post a journal template.

Posting Multiple journals
You can post several journals simultaneously without opening them individually in the Journals window.

For more information on posting multiple journals, see “Posting Multiple Journals” on page 111.

➢ To post multiple journals:

1 In the Journals and Templates frame, select the journals you want to post, then click Post. The Task Submission Status frame is displayed.

2 To return to the Journals and Templates frame, Click Return to Journals List Page.

Note: You cannot post journal templates.

Unposting journals
You can unpost journals for a period if you need to make extensive changes to the database for that period.

For more information on unposting journals, see “Unposting Journals” on page 112.

➢ To unpost journals:

1 In the Journals and Templates frame, select the journals you want to unpost, then select Unpost. The Task Submission Status frame is displayed.

2 To return to the Journals and Templates frame, Click Return to Journals List Page.

Note: You cannot unpost a journal template.

Loading Journals
You can load posted or unposted journals and journal templates for the current category from text files. For example, you can load standard journal templates extracted from one application into another application. You can also load journals created or modified with a text editor.

For more information on loading journals, see “Loading Journals” on page 115.

➢ To load journals:

1 With links to journal tasks displayed in the local selection frame, select Load Journals. The Load Journals frame is displayed.
2 In the Load Journals frame, type the file name from which to load journals, or click **Browse** to find the file.

3 If the file you are loading does not use an exclamation point (!) as the delimiter, select the correct character in the **Default Delimeter Character** drop-down list.

4 Use the check boxes to filter the journals that you want to load.

5 Click **Submit**.

**User Preferences**

Select **Enable Visual Cue** preferences for demarcating the FDM data in the Hyperion Enterprise applications.

**Messaging Client**

You can choose to enable messaging option to Hyperion Enterprise Web users.
What Hyperion Allocations Does

Hyperion Allocations enables you to take Hyperion Enterprise data and perform allocations across entities, accounts, or time periods. You can run one or multiple allocations at a time by building allocation sets and placing the allocations in the set.

Hyperion Allocations contains four modules: Allocations, Sets, Allocate, and Reports. You use these modules to perform the following tasks in the order presented in Table 29.

Table 29  Allocation Modules

<table>
<thead>
<tr>
<th>Module</th>
<th>Tasks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allocations</td>
<td>Define allocations by selecting their types and methods.</td>
</tr>
<tr>
<td>Sets</td>
<td>Assign allocations to a set so they can be run and posted.</td>
</tr>
</tbody>
</table>

This chapter presents information and procedures that you need for performing allocations across entities, accounts, and time periods.
<table>
<thead>
<tr>
<th>Module</th>
<th>Tasks</th>
</tr>
</thead>
<tbody>
<tr>
<td>Allocate</td>
<td>Run and post the allocation sets.</td>
</tr>
<tr>
<td>Reports</td>
<td>View and print information about allocations and allocation sets.</td>
</tr>
</tbody>
</table>

When you define an allocation, you specify the category, period, name, and account within the allocation or use variables to specify these elements. If you use variables to define the point of view for an allocation, the system uses the point of view defined for the allocation set that contains the allocation.

For example, if you use a variable for the allocation’s category, Hyperion Allocations uses the category specified in the set's point of view when the allocation is run. You can combine specific and variable points of view to specify an allocation’s performance based on the set in which you run and post it.

You can customize Hyperion Allocations as follows:

- Select a screen font for text in the windows and dialog boxes.
- Select the language in which on-screen information is displayed.
- Select a color for the Hyperion Allocations desktop.

When you finish working with the allocations for one application, you can switch to a different application without exiting Hyperion Allocations.

**Note:** You can only post 260 periods in an Allocations.

### Allocation Types and Methods

Hyperion Allocations provides three allocation types - Name, Account, and Time - and four allocation methods - Percent, Value, Factor, and Total. When you define an allocation, you select one allocation type and one allocation method. Your selections determine the options in the formula the system uses to define the allocation. The allocation types specify where the data is distributed. The allocation methods specify how the data is distributed.

Regardless of the type and method you select, all values referenced in the allocation must be in the Hyperion Enterprise database before you can run the allocation. If you allocate less than 100 percent, the unallocated balance only appears when you preview the allocation.

### Name Allocation Type

Name allocations allow you to distribute a value from one entity, typically a parent entity, to other entities in an entity list. The list you use in the allocations is the same list you use in the Hyperion Enterprise application. You can select either a specific list or use the name expansion variable @NAM. If you use the @NAM variable, the allocation uses the name point of view defined for the allocation set.
Note: A name list in Hyperion Allocations is equivalent to an entity list in Hyperion Enterprise.

**Account Allocation Type**

Account allocations allow you to distribute a value from a major account to its subaccounts. The subaccount tables are the same tables used in the current Hyperion Enterprise application. You can select either a specific subaccount, or use the account expansion variables @ACC and @SUB. If you use a variable, the allocation uses the account point of view defined for the allocation set.

**Time Allocation Type**

Time allocations allow you to distribute a value from a single source time period to many time periods within a range. The source contains one time period. The percentage, value, weight, and destination contain a range based on start and end periods.

**Percent Method**

The percent method distributes a value from the source entity, account, or period into each destination entity, account, or period using specific percentage amounts. The source value is multiplied by the result of a percentage value stored in specific entities, subaccounts, or periods, and then divided by 100. In the formula, the numerator is the percentage value and the denominator is 100. If you want the value to be fully allocated, the combined destination percentage values for the allocation must equal 100.

You must specify all values for this method. Here is the formula for the percent method:

\[
\text{Destination} = \frac{\text{Source} \times \text{Percent}}{100}
\]

**Value Method**

The value method distributes the value in the source entity, account, or period by multiplying the source value by a ratio. The ratio is the value from a specific destination divided by a value representing all the destinations, or a weight.

You must specify all values for this method. Here is the formula for the value method:

\[
\text{Destination} = \frac{\text{Source} \times \text{Value}}{\text{Weight}}
\]

**Factor Method**

The factor method distributes the value in the source entity, account, or period by multiplying it by a specific number for each destination. If you want the value to be fully allocated, the combined destination values must equal 1.00.

You must specify all values for this method. Here is the formula for the factor method:
Destination = Source x Factor

**Total Method**

The total method distributes the entire value in the source entity, account, or period by multiplying the source value by a ratio. The ratio is the value from a specific destination divided by a value representing all the destinations, which Hyperion Allocations calculates.

You can select the total method for the following types of allocations:

- Name allocation
- Account allocation
- Time allocation

In a name allocation, the system totals across all entities in the specified entity list, avoiding the need to consolidate in advance. In an account allocation, the system totals across all subaccounts in the specified subaccount table, avoiding the need to calculate formulas in advance. In a time allocation, the system totals across the time period range specified, which prevents the need to store special total values in advance.

This is the formula for the total method:

\[ \text{Destination} = \frac{\text{Source} \times \text{Value}}{\text{Total(Value)}} \]

**Hyperion Allocations Desktop**

The Hyperion Allocations Desktop is the starting point for all operations within the system. It appears after you enter your user ID and password in the Login dialog box and start the system. You return to the Desktop when you close a module window.

*Figure 26* shows the Hyperion Allocations Desktop.
The Hyperion Allocations Desktop includes the following elements:

- **Title Bar** - Identifies the product Allocations and software version number.
- **Menu Bar** - Presents the following menus that you select to perform tasks:
  - **File** - Enables you to access the modules, view an activity log of Hyperion Enterprise applications, and exit Hyperion Allocations.
  - **Options** - Enables you to switch applications, set preferences, select the desktop color, and extract or load allocation and set information.
  - **Help** - Enables you to view database tables for allocations or sets, view system information, and view version number, free memory, user ID, and application.
- **Icons** - Represent the following Allocation functions: View Log, Change Application, Change Language/Font, About Allocations.
- **Status Bar** - Displays the name of the current Hyperion Enterprise application and the current process, if applicable. When the status bar displays the message Ready, the system is ready to process data.

**Starting Hyperion Allocations**

The first time you access a Hyperion Enterprise application using Hyperion Allocations, the system creates a directory called ALLOC under the application directory and creates the file ALLOCATE.MDB in the ALLOC directory. For example, if you access an application in the C:
\HYPENT\WWCONSOL directory, the system creates the C:\HYPENT\WWCONSOL\ALLOC directory and creates a ALLOCATE.MDB file in that directory. The ALLOCATE.MDB file stores the allocation sets defined for the application.

**Note:** Hyperion Allocations uses Hyperion Enterprise security to determine the access rights you have in an application.

To start Hyperion Allocations:
1. Exit Hyperion Enterprise.
2. From the Start menu, select Programs > Hyperion Solutions > Hyperion Enterprise > Allocations.
3. Select the Hyperion Enterprise application from the Application Name list box.
4. Enter your user ID and password.
5. Click OK.

### Setting Hyperion Allocations Preferences

You can select the language in which Hyperion Allocations runs and the screen font for the dialog boxes and windows. These preferences affect all the applications that your workstation accesses in Hyperion Allocations.

To set Hyperion Allocations preferences:
1. From the Allocations desktop, select Options > Language or select Change Language/Font.
2. Make the appropriate changes:
   - To change the language in which Hyperion Allocations is running, select a language from the Language list box
   - Optional: Select B for bold or I for italic.
   - To change the screen font, select a font from the Font drop-down list.
3. Click OK.

### Selecting Desktop Color

You can select the color for your Hyperion Allocations Desktop.

To select the Hyperion Allocations Desktop color:
1. From the Hyperion Allocations Desktop, select Options > Color.
2. Select a color from the Color palette.
3. Click OK.
Changing the Hyperion Enterprise Application

You can change the Hyperion Enterprise application for which you are creating allocations without exiting Hyperion Allocations. Hyperion Allocations uses Hyperion Enterprise security to determine the access rights you have for an application. Therefore, to access an application from within Allocations you use the same user ID and password that you use to access a Hyperion Enterprise application.

To change the Hyperion Enterprise application:

1. From the Allocations Desktop, select Options > Application or select Change Application.
2. Select the Hyperion Enterprise application from the Application Name list box.
3. Type your user ID and password.
4. Click OK.

Allocations Setup

You set up allocations by defining the allocation and building the allocation formula. You can then preview the results of the allocation. When you no longer need the allocation, you can delete it.

Defining Allocations

Here is the process to define an allocation:

- Select an allocation type and method.
- Assign a name and description to the allocation.
- Specify information for the selected allocation method.
- Build the allocation formula by specifying the point of view elements, including source and a destination category, and the allocation’s name, period, and account.

*Note:* When you specify point of view elements, you can select the category, period, name, and account or use the point of view element defined for the allocation set.

If you change the allocation method or type, the system clears all information from the allocation formula. For more information on allocation set point of view, see “Defining Allocation Sets” on page 150.

Table 30 shows the point of view icons.

<table>
<thead>
<tr>
<th>Selection</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Category Icon]</td>
<td>Specify a category.</td>
</tr>
</tbody>
</table>
Here are the rules for selecting the allocation point of view:

- The name list you select in the Percentage, Value, or Factor edit box must match the name list in the corresponding destination edit box.
- You must select an account with subaccounts for Percentage, Value, or Factor edit box.
- If you use one of the account expansion macros, @ACC-@SUB or Account-SUB, where Account is a specific account, the subaccounts expand when you run the allocation to the subaccount table attached to the current account or the specific account.
- You must specify the period range for Percentage, Value, or Factor edit box and Destination edit box.
- The period you select in the Destination edit box must match the period range specified in the Percentage, Value, or Factor edit box.

To define an allocation:

1. From the Hyperion Allocations Desktop, select Allocations or select File > Desktop > Allocations, then take one of the following actions:
   - To create the first allocation for the application, go to step 2.
   - To create an allocation, select New, then select an allocation type and method.
   - To edit an allocation, select the allocation you want to edit from the Allocation drop-down list.

2. On the Allocation tab, type a name and description for the allocation.

3. To change the allocation type or method, select Type or Method, select an allocation type or method, then click OK.

4. On the Data tab, specify the source and destination category, account, period, and name, then take one of the following actions:
   - For percent allocations, specify the category, period, entity, and account that contain the percentage by which you want to multiply the source value to reach the destination value.
   - For value allocations, specify the category, period, entity, and account that contain the value by which you want to multiply the source value, then specify the account that contains the weight by which the value is multiplied.
   - For factor allocations, specify the category, entity, period, and account that contain the factor by which you want to multiply the source value to reach the destination value.
For total allocations, specify the category, account, period, and entity that contain the value by which you want to multiply the source value, which the system divides by the total for all destinations.

5 To verify that the allocation does not contain errors, click Check.
6 Click Save, then click Close.

Previewing Allocation Results

To view the results of an allocation, you place the allocation in a set, then run and post the allocation. If necessary, you can then change the data in the Hyperion Enterprise application. As an alternative, you can preview the results of an allocation. Previewing allows you to make changes before you run and post the allocation.

**Note:** If you allocate less than 100 percent, the unallocated balance appears only when you preview the allocation.

To preview allocation results:

1 From the Hyperion Allocations Desktop, select Allocations or select File > Desktop > Allocations.
2 From the Allocation drop-down list box, select the allocation that you want to preview.
3 Click Preview.
4 If the allocation has one or more variables for the point of view elements, follow the prompts to select the point of view elements.
5 Verify the allocation results in the Preview window, then select Close twice.

Deleting Allocations

If you no longer need an allocation, you can delete it.

**Note:** You can delete an allocation that is in a allocation set. When the allocation is deleted, it will no longer be included in the allocation set.

To delete an allocation:

1 From the Hyperion Allocations Desktop, select Allocations or select File > Desktop > Allocations.
2 From the Allocation drop-down list box, select the allocation that you want to delete.
3 Click Delete.
4 Click OK, then click Close.
Allocation Sets Setup

Before you can run and post an allocation, you must place the allocation in an allocation set. An allocation set is one or more allocations that you run and post at the same time.

When you set up an allocation set, you define it, add allocations to it, and run and post it. If you no longer need an allocation set, you can delete the set without deleting the allocations within it.

Defining Allocation Sets

When you define an allocation set, you give it an ID and description, decide whether formulas are calculated when you run the set, define its point of view, and select the allocations in the set that you want to run and post at the same time. An allocation set cannot contain more than 1000 allocations.

The point of view for the set provides the organization, category, entity or entity list, account or subaccount table, or period for the allocation. These point of view selections are used only when you define an allocation with one or more point of view variables such as @CAT.

Here are the rules for selecting the allocation set point of view:

- You must first select the organization, and then the name. If you change the organization to one that does not contain the selected entity, you must select a entity in the current organization.
- When you specify an entity list for the point of view and select the Name List check box, the system uses all the entities in this entity list to replace the @NAM variables in the set.
- Specify either an account or an account list in the allocation set point of view, not both.
- You must first select the category, and then the start and end periods.
- The end period must be either the same as or later than the start period.
- When you run the allocation set, the allocations are run in the order that they appear in the Selected Allocations list box in the Allocation Sets dialog box.

**Note:** It is important to define the point of view for the allocation set correctly to ensure data is sent to the proper location in Hyperion Enterprise.

To define an allocation set:

1. From the **Hyperion Allocations Desktop**, select **Sets** or select **File > Desktop > Edit Sets**.
2. Create or edit an allocation set:
   - To create the first allocation set for the application, go to step 3.
   - To create an allocation set, select **New**.
   - To edit an existing allocation set, select the allocation set you want to edit from the **Set** drop-down list.
3. On the **Set** tab, type an ID and description for the allocation set.
To have Hyperion Enterprise calculate formulas after posting the values in the allocation set, select **Execute Logic**.

On the **Point of View** tab, specify the point of view elements for any point of view variable.

Select the data view for the allocation set: **View Year-To-Date** or **View Periodic**.

On the **Allocations** tab, select the allocations to add to or remove from the set:

- To add allocations to the set, highlight one or more allocations in the **Available Allocations** list box and click **Add**.
- To remove allocations from the set, highlight an allocation in the **Selected Allocations** list box and click **Remove**.

To change an allocation’s definition, select the allocation in the **Available Allocations** or **Selected Allocations** list box, then click **Edit**.

To change the order of the allocations in the set, select the allocation that you want to move in the **Selected Allocations** list box and drag it to its new position.

Click **Save**, then click **Close**.

**Deleting Allocation Sets**

If you no longer need an allocation set, you can delete it. If you delete an allocation set, the allocations in the set are not affected.

To delete an allocation set:

1. From the **Hyperion Allocations Desktop**, select **Sets** or select **File > Desktop > Edit Sets**.
2. From the **Set** drop-down list, select the allocation set that you want to delete.
3. Click **Delete**.
4. Click **OK**, then click **Close**.

**Running Allocation Sets**

You can run one or more allocation sets at a time. After you run an allocation set, you post it. When you run an allocation set, Hyperion Allocations creates a run ID, which identifies the data you post to the Hyperion Enterprise application data. Each time you run the allocation set, the system overwrites the data held under this run ID. When you post the allocation run ID, data in the Hyperion Enterprise application is affected. For more information on post allocation sets, see “Posting Allocation Sets” on page 152.

**Note:** You can delete temporary allocation files created after running allocation sets.

To run an allocation set:

1. From the **Hyperion Allocations Desktop**, select **Allocate** or select **File > Desktop > Allocate**.
2 Select the allocation set or sets to run in the Sets list box, then click Run.

3 If the system displays a status of Allocation Error or Set Error, perform one of these steps:
   - Click View Log to view the error, then click OK to close the error log.
   - Click Clear Log to clear and exit the error log. Resolve any errors, then run the allocation again.

4 Repeat steps 2 and 3 until you have run and verified all sets.

5 Click Close.

Posting Allocation Sets

You post allocation sets to apply the changes in the allocation set. To post an allocation set, you must first run it. For more information on run allocation sets, see “Running Allocation Sets” on page 151.

To post an allocation set:
1 From the Hyperion Allocations Desktop, select Allocate or select File > Desktop > Allocate.
2 Select the allocation set or sets to post in the Sets list box.
3 Select one or more run IDs to post in the Run ID list box, then click Post.
4 If the system displays a status of Post Error, perform one of these steps:
   - Click View Log to view the error, then click OK to close the error log.
   - Click Clear Log to clear and exit the error log. Resolve any errors, then post the allocation again.
5 Repeat steps 2 through 4 until you have posted and verified all sets.
6 Select Close.

Deleting Run Information

After you post an allocation set to the Hyperion Enterprise application, you can delete the run ID for the allocation set. If you decide not to post the allocation, you can delete the run ID for an allocation set before you post it.

To delete the run information:
1 From the Allocations desktop, select Allocate or select File > Desktop > Allocate.
2 In the Sets list box, select the allocation set or sets for which you want to delete run IDs.
3 Select one or multiple run IDs to delete in the Run ID list box, then click Delete.
   - The system changes the status of the run ID to Deleted.
4 To remove a run ID from the system, select it in the Run ID list box, then click Delete.
5 Repeat steps 2 through 4 until you have deleted all run IDs.
6 Click Close.

Extracting Allocation or Set Information

You can extract or copy information defining allocations and information defining sets to an ASCII file.

You can use this process to edit your allocation and set information in a text file, then load the information back into the allocations database. For more information on loading, see “Loading Allocation or Set Information” on page 153.

Note: When you extract set information, the corresponding allocation information is not copied to the ASCII file.

To extract allocation or set information:

1 Take one of the following actions from the Hyperion Allocations Desktop:
   • To extract allocations, select Options > Extract > Allocations.
   • To extract allocation sets, select Options > Extract > Sets.

2 Select the allocations or sets to extract:

3 Click Extract to open the Enter Name of Extraction File dialog box.

4 Accept the default directory, which is the Outbox of the open application, or select a different directory.

5 In the File name edit box, type the name and name extension of the ASCII file to which you are copying the allocation or set information.

6 Click Save.

7 To extract additional allocation or set information, repeat steps 2 through 5.

8 When you finish extracting information, click Close.

Loading Allocation or Set Information

You can load information defining allocations or information defining sets from an ASCII text file to your allocations database.

You might do this if you want to edit your allocation and set information in a text file, then load it back into the allocations database. For more information on extracting, see “Extracting Allocation or Set Information” on page 153.

To load allocation or set information:

1 Take one of the following actions from the Hyperion Allocations Desktop:
   • To load allocations, select Options > Load > Allocations.
   • To load allocation set, select Options > Load > Sets.
2 Accept the default directory, which is the Inbox of the open application, or select a different directory.
3 Select the extracted ASCII file with the allocation or set information to load into your allocations database.
4 Click Open to load the information.
5 When the system then prompts you about how to treat existing allocations or sets, take one of the following actions:
   - Click Yes to overwrite the specific allocation or set.
   - Click No to skip the specific allocation or set and leave it as is in the allocations database.
   - Click All to overwrite the specific and all other allocations or sets whose names already exist in the allocations database.
   - Click None to skip the specific and all other allocations or sets whose names already exist in the allocations database.

**Printing or Previewing Allocation Reports**

Hyperion Allocations provides four types of reports you can print or preview:
- An allocation definitions report allows you to view allocation definitions.
- An allocation set definitions report allows you to view set definitions, including the set point of view and which allocations are in the set.
- An allocation run report allows you to view the run status for the allocation sets.
- A post audit report allows you to view the results of an individual allocation set after it has been run. You can run this report regardless of whether the allocation set has been posted.

Table 31 describes the view options.

<table>
<thead>
<tr>
<th>Selection</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>❯</td>
<td>View the first page of the report.</td>
</tr>
<tr>
<td>◀</td>
<td>View the previous page of the report.</td>
</tr>
<tr>
<td>▶</td>
<td>View the next page of the report.</td>
</tr>
<tr>
<td>▼</td>
<td>View the last page of the report.</td>
</tr>
<tr>
<td>🔍</td>
<td>Enlarge or reduce the image of the report on the screen.</td>
</tr>
<tr>
<td>📨</td>
<td>Print the current report.</td>
</tr>
<tr>
<td>Close</td>
<td>Close the preview window.</td>
</tr>
</tbody>
</table>
To print or preview an allocation report:

1. From the Hyperion Allocations Desktop, click Reports or select File > Desktop > Reports.
2. To print or preview an allocation definition report, on the Allocation Definition tab, select one or more allocations, or click Select All to print or preview all the allocations.
3. To print or preview an allocations set definition report, on the Set Definition tab, select one or more allocation sets, or click Select All to print or preview all the allocation sets.
4. To print or preview an allocation run report, on the Run tab:
   a. select one or more allocation sets, or click Select All to print or preview all the allocation sets.
   b. Select the sort option: Run ID, Status, or Set Name.
5. To print or preview a post audit report, on the Post Audit tab:
   a. Select the allocation set from the Select Sets list box.
   b. Select one or more run IDs to print or preview from the Select Run ID list box.
6. Preview or print the report:
   - To preview the information, click Preview. When you are finished previewing the information, select Print to print the information, or Close to close the preview window.
   - To print the information, select Print.
7. Click Close.
This chapter provides information and procedures that you need to use LedgerLink for automating data translations and imports:

**LedgerLink Overview**

LedgerLink automates the process of translating and importing data into Hyperion Enterprise. LedgerLink integrates third-party general ledger and additional feeder system data by using templates applicable to specific vendor applications.

Using LedgerLink, you set up customized templates for each external application from which you want to import data. You can target templates to specific software applications such as Oracle General Ledger. You can then bring in data from different ledger and feeder systems without modifying the files that contain the data.

**Note:** If the external entities are same but the internal entities are different in the LNT file, running the translation files consecutively may output an unexpected result. As a result,
run the files non-consecutively. For example: Loading two profiles consecutively which use Entity translation files where the external name is the same but the internal Enterprise entity is different will result in the wrong LNT file being used for the last profile to run. Load them non-consecutively or close and re-open Ledgerlink between loads for the correct Entity Translation file to be selected.

LedgerLink includes the following modules, which you use to customize and define the data that you want to load:

Set the following access privileges to manage tasks in LedgerLink: You must have modify access rights to the Format Administration task, under the Database tasks in the security module to gain access to create general ledger templates, translation files, and load profiles. Having Limited or View access rights to the Format Administration task is same as having None access rights. You do not require modify access rights to the Format Administration task to launch existing translate or load profiles.

**Note:** File path to load translation file cannot exceed 117 byte in length

**Note:** In Ledgerlink, adding accounts to a mapping table that would exceed 32,000 lines will result in a runtime error.

- **G/L Template Wizard** - Creates templates to describe the format of the general ledger files you load into Hyperion Enterprise.
- **Translation Builder** - Creates translation mapping tables to match external general ledger names and accounts with Hyperion Enterprise entities and accounts. You write translation lists that LedgerLink uses to map data from your general ledger to entities and accounts in Hyperion Enterprise.
- **Translate & Load Profiles** - D settings for translation and load procedures. You select a template created in G/L Template Wizard, then specify where and how to load the general ledger data into Hyperion Enterprise.
- **Load to Hyperion Enterprise** - Loads general ledger data into Hyperion Enterprise.

**LedgerLink Desktop**

The LedgerLink Desktop is the starting point for all operations within the system. The Desktop appears after you enter your user ID and password in the Login dialog box and start the system. You return to the desktop when you close a module window.

**Figure 27** shows the LedgerLink Desktop.
The LedgerLink Desktop includes the following elements:

Title Bar - Identifies the product LedgerLink and the release number.

- **Menu Bar** - Presents the following menus:
  - File - Enables you to access the modules, print reports of the contents of saved G/L Templates and Load Profiles, and exit LedgerLink.
  - Options - Enables you to switch applications and select a language.
  - Help - Gives you access to online help and information about LedgerLink.

- **Icons** - Represent the system modules. You select an icon to access the module it represents.

- **Status Bar** - When the system is not processing data, the status bar displays the ID of the current Hyperion Enterprise application. Otherwise, it displays the current process.

**LedgerLink Sample Files**

To learn to use LedgerLink, you can use sample files to write sample templates, tables, and profiles. The sample files show you how LedgerLink integrates with SAP, Oracle Financials and Hyperion’s accounting solutions - general ledger, Pillar FYPLAN - budgeting, and Hyperion Enterprise - consolidation. If you loaded sample files during installation, they are in the directory where you installed LedgerLink.
Note: Do not load the sample files into Hyperion Enterprise.

Following are descriptions of the sample files:

- **Hyperion Accounting Solutions Sample File** - The Hyperion accounting solutions sample file demonstrates the use of account translation tables in loading data to Hyperion Enterprise. They include examples of Exception, Range, and Global rules in mapping tables.

- **Hyperion Pillar FYPLAN Sample File** - The Hyperion Pillar FYPLAN sample file shows a report consisting of comma delimited fields, a header line, and 12 months of data. The name and account translation tables use a single asterisk ( * ) wildcard opposite one account and the same opposite one name. In the Translate & Load Profiles module, LedgerLink creates a load file without header options in the general ledger source file.

- **Hyperion Enterprise Sample File** - The Hyperion Enterprise sample file demonstrates how to use LedgerLink to feed data from detailed Hyperion Enterprise applications into summary Hyperion Enterprise applications. Because this sample does not use translation files, it bypasses the need to use the Translation Builder module.

- **SAP Sample File** - The SAP sample file shows the error log and reject file, which contains records that were not translated because the accounts in the file are not defined in the translations. This template prompts for a source general ledger output file when loading to Hyperion Enterprise.

- **Oracle Sample File** - The Oracle sample file demonstrates use of the IGNORE feature in translation mapping to disregard the Account / Name, which is not loaded into Hyperion Enterprise and does not generate a report record. The file is a report with fixed-length fields, formatted data, conditional code blocks, and page header lines.

### Defining Templates

You define templates to describe how data is formatted in external general ledgers. The template describes an output file from a source general ledger system, such as Oracle General Ledger. LedgerLink uses these templates to interpret the data while loading it into Hyperion Enterprise. You use the G/L Template Wizard to define templates.

When you define a template, you select a sample from the list of available general ledger templates and then modify the template. Each new template you create is added to the system.

**Note:** When using the G/L Template Wizard, do not use a field delimiter of more than one character.

Defining a template consists of the following basic tasks:

- Select a sample of a general ledger output file, also called a source sample file.
- Select a sample record from the output file.
- Specify a record format.
Configure the template by identifying the separate fields in the record as names, accounts, or data values.

If your general ledger output file is in the form of a report, indicate report format options, you specify the number of lines in the sample file used by the file header, page header, page body, and page footer.

You can also define a template by copying and editing an existing one.

**Note:** Templates are internal LedgerLink files contained in the HPLLINK.MDB file. They do not have file extensions and can be accessed only in G/L Template Wizard.

### Selecting a Source Sample File

**Note:** The sample file is used for formatting only. You do not need to load this file into Hyperion Enterprise. The file that you load must have the same format as the sample file.

The source system file can be either a table extract or a report. A table extract is an ASCII file with individual data fields designated by delimiters or fixed-length formatting. A table extract file does not have page headers, page footers, or page formatting.

A report can contain file headers, page headers, a report body, and page footers. The headers, footers, and body must be the same size on all pages of the output file. The report's data fields must be designated by delimiters or fixed-length formatting.

For both types of source sample files, record delimiters are detected automatically. These can be carriage return line feeds or line feeds. If your file does not use delimiters or fixed-length formatting, the system applies fixed-length formatting. Do not use a field delimiter of more than one character.

To select a source sample file:

1. From the LedgerLink Desktop, select **G/L Template Wizard**.
2. In the **G/L Templates** list box, create or edit a template:
   - To a new template, click **New**.
   - To edit an existing template, highlight the template and click **Edit**.
3. Select file type **Table Extract** or **Report**, based on the form of the general ledger file that you are loading.
4. If the sample file path and name do not appear next to the **Select Sample File** button or if you want to change the sample file, select **Select Sample File**. Select the correct path and file, then click **OK**.
5. Click **Next**.
6. Select a sample record. For instructions, see “Selecting a Sample Record” on page 176.
Translate Data

After you define your template, you translate your external data into their Hyperion Enterprise equivalents using name translation tables and account translation tables. The translation tables match entities or accounts in other systems to entities or accounts in Hyperion Enterprise.

You use the Translation Builder module to create the translation tables from the external data source and the template you set up in the G/L Template Wizard. You can also import and use account and name translation mapping tables that you have previously defined.

Note: If all your codes in an external data source match the entities and accounts in Hyperion Enterprise, you do not need to translate your data.

Translation File Types

The Translation Builder module produces translation files, which you then use to transfer data to Hyperion Enterprise. The type of translation file you create depends on the type of data with which you are working and the method you want to use to import or export data. The translation types are as follows:

- **External Entity Lists (*.nli)** - Describe either external entities in an ASCII file, or lists created by LedgerLink using a General Ledger output file and template. Do not use single or double quotation marks.
- **External Account Lists (*.ali)** - Contain either a list of external account data from a general ledger, or lists created by LedgerLink using a General Ledger output file and template.
- **Import Account Translation (*.tra)** - The import account translation files are ASCII account translation files you create in a text editor. These files must be in the following format: 
  
  _External Account 1, External Account 2, Internal Account._

- **Import Entity Translation (*.trn)** - The import entity translation files are ASCII entity translation files you create in LedgerLink. These files are compiled and cannot be used outside LedgerLink.
- **LedgerLink Entity Translation (*.lnt)** - The LedgerLink entity translation files are internal entity translation files, which cannot be maintained outside LedgerLink.
- **LedgerLink Account Translation (*.lat)** - LedgerLink account translation files are internal account translation files, which cannot be maintained outside LedgerLink.

External Lists

You can use an external list within LedgerLink to create the translation file. This file consists of the valid external names or accounts you use within the translation. You can create or edit the list within a text editor or within LedgerLink. In either case, the file name extension is `.nli` for name lists and `.ali` for account lists.

Note: You can create entity and account lists using the Hyperion Enterprise Entities and Account modules, but LedgerLink external lists display IDs without their descriptions.
**Entity External List**

The entity list has the following format:

*ENTITY*, where *ENTITY* is the entity ID.

**Note:** Additional data can be included after the comma, but will be ignored. Only the entity is visible in the External List box.

**SOURCE.NLI**
LEGAL, MKTG, ADMIN,

In the previous example, only the LEGAL entity would be visible in the External List box.

**Account External List**

The Account list has the following format:

*ACCOUNT*, where *ACCOUNT* is the account ID.

**Note:** Additional data can be included after the comma, but will be ignored. Only the account is visible in the External List box.

**SOURCE.AL**
A001P601, A002P601, A011P602,

In the previous example, only the A001P601 account will be visible in the External list box.

**Translation Builder Window**

You use the Translation Builder Window to create or edit a LedgerLink translation file. You can view both external and Hyperion Enterprise names or accounts. You set up translation rules using the Translation Rules Mapping tabs in the lower portion of the window. You perform tasks in the Translation Builder window by selecting menu commands or toolbar icons.

**Figure 28** shows the Translation Builder window.
The Translation Builder window has the following elements:

- **Title Bar** - Identifies the product, release number, window name, and file name.
- **Menu Bar** - Lists the following menus that you can select to perform different tasks:
  - File - The commands on the File menu allow you to perform the tasks shown in Table 32.

**Table 32  Translation Builder File Menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Task</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Create a translation file.</td>
</tr>
<tr>
<td>Open</td>
<td>Open a translation file.</td>
</tr>
<tr>
<td>Save</td>
<td>Save the current translation file.</td>
</tr>
<tr>
<td>Save As</td>
<td>Provide a new entity for the translation file.</td>
</tr>
<tr>
<td>Open External List</td>
<td>Open an external entity or account list.</td>
</tr>
<tr>
<td>Make External List</td>
<td>Create or update an external entity or account list.</td>
</tr>
<tr>
<td>Import Translation File</td>
<td>Import an ASCII file version of the Exception, Range, and Global rules.</td>
</tr>
<tr>
<td>Export Translation File</td>
<td>Export a version of the Exception, Range, and Global rules as a .TRA file.</td>
</tr>
</tbody>
</table>

**Edit** - Enables you to perform the tasks shown in Table 33.
Table 33  Translation Builder Edit Menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Task</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Row</td>
<td>Add a row within the Exception, Range, or Global tables.</td>
</tr>
<tr>
<td>Delete</td>
<td>Remove a row within the Exception, Range, or Global tables.</td>
</tr>
<tr>
<td>Find</td>
<td>Locate text within the Exception, Range, or Global tables.</td>
</tr>
</tbody>
</table>

Options - Enables you to perform the tasks shown in Table 34

Table 34  Translation Builder Options Menu

<table>
<thead>
<tr>
<th>Command</th>
<th>Task</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity Translation</td>
<td>Switch to name translation mode.</td>
</tr>
<tr>
<td>Account Translation</td>
<td>Switch to account translation mode.</td>
</tr>
<tr>
<td>View Results</td>
<td>View a complete listing of the rules you defined.</td>
</tr>
</tbody>
</table>

Translation Rules

There are three types of rules for defining data within a LedgerLink translation file: Exception, Range, and Global. Entity and account translation files can contain up to three types of rules.

Exception Rules

You use Exception rules for one-to-one mapping of the external entity or account to the Hyperion Enterprise entity or account, or to specify entities or accounts that should not fall into defined Range and Global rules.

Note: Exception rules do not support wildcards.

Figure 29 shows an example of Exception rules that were defined on the Exceptions tab in the Translation Builder.

Figure 29  Exception Rules

<table>
<thead>
<tr>
<th></th>
<th>External</th>
<th>Hyperion</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>CC01C001</td>
<td>BELGIUM</td>
</tr>
<tr>
<td>2</td>
<td>CC01C002</td>
<td>HOLLAND</td>
</tr>
<tr>
<td>3</td>
<td>CC01C004</td>
<td>SWEDEN</td>
</tr>
<tr>
<td>4</td>
<td>CC01C003</td>
<td>NORWAY</td>
</tr>
</tbody>
</table>

- Name CC01C001 translates to entity BELGIUM.
- Name CC01C002 translates to entity HOLLAND.
- Name CC01C003 translates to entity SWEDEN.
- Name CC01C004 translates to entity NORWAY.

**Range Rules**

You use Range rules to group several external entities or accounts and match them to one Hyperion Enterprise account or entity, or to specify entities or accounts that should not fall into defined Global rules.

Figure 30 shows an example of Range rules that were defined on the Range tab in the Translation Builder.

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>CC01C001</td>
<td>CC01C003</td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

In the previous name translation, the accumulation of the account range (accounts CC01C001 through CC01C003) in the external system translates to SPAIN in Hyperion Enterprise.

**Note:** Range rules only support the use of the asterisk ( * ) in the external range.

**Global Rules**

Global rules allow you to use wildcards to translate multiple entities or accounts. You can use Global rules in both the external and Oracle's Enterprise Performance Management software tables. Entities or accounts that you drag to either table are inserted at the drop point. Table 35 shows how wildcards are used in Global rules.

<table>
<thead>
<tr>
<th>Wildcard Character</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>?</td>
<td>Match any specific character within an external entity or account. When used, all characters must match except the wildcard character.</td>
</tr>
<tr>
<td>*</td>
<td>Match characters at the end of an external entity or account or match all characters in an entity or account. When used at the end of specific characters, any characters following the name or account can match. When used by itself, all entities or accounts will be selected.</td>
</tr>
</tbody>
</table>

For example, you might create an account translation file where all external accounts starting with the number 1 are translated to the Hyperion Enterprise Sales account.

You can also use the asterisk ( * ) wildcard in both the External column and the Oracle's Enterprise Performance Management software column instead of listing every entity or account that you want to include in the load file. You could then use the Exception table to list only the entities and accounts that need to be translated.
Note: Using the Global rule might cause a sorted .GLO file to be unsorted after translation. To avoid this, save it under a different name.

For account translation files only, you use the additional column that appears in each table to indicate whether to add the data to or subtract the data from the result. The default setting adds the data.

Evaluation Order

During translation, LedgerLink evaluates rules in the following order:

- Exception
- Range
- Global

If an account is referenced by more than one type of rule, the first occurrence defines the translation. For example, suppose the following rules are defined:

Global:    *,ACC1
Range:        1000>2000,ACC2
Exception:                1010,ACC3
                     1020,ACC4

Here are the results:

1010=ACC3
1020=ACC4
1000.2000 (excluding 1010 and 1020)=ACC2
1999 and 2001>3000 =ACC1

Ignore Feature

You can ignore entities or accounts in a Hyperion Enterprise load profile to avoid having them appear as errors in the error log. For example, suppose you want to ignore the summary or validation accounts extracted from the ledger in a .GLO file. You can instruct LedgerLink to ignore these accounts and not load them into Hyperion Enterprise by typing [IGNORE] in the Oracle's Performance Management software table next to the entity or account. You can use wildcards with the Ignore feature to ignore a range of entities or accounts in the load file.

Note: You can use the Ignore feature in the Exception, Range, and Global mapping tables.

Imported Translation File Rules

You can import and export name and account translation files created in Hyperion Enterprise. These .TRA files are ASCII file versions of the Exception, Range, and Global tables. The format for creating a translation ASCII file differs for Exception, Range, and Global rules.
**Exception Rules for ASCII Files**

You use the Exception rule to match entities and accounts on a one-to-one basis. Exceptions are usually entities or accounts that do not come under Range or Global rules. For example, you might want to translate entity 101L in your general ledger to TEXAS.INP in Hyperion Enterprise.

*Note:* Wildcards are not supported in the Exception rule.

For the each line in the Exception rule, use this format:

External, Internal

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>External</td>
<td>The external entities and accounts</td>
</tr>
<tr>
<td>Hyperion</td>
<td>Hyperion Enterprise entities and accounts</td>
</tr>
</tbody>
</table>

For example:

ACCT10, PEXP.SOCcer.SHOES  
ACCT20, PEXP.SOCcer.BALLS  
ACCT30, PEXP.SOCcer.EQUIP  
ACCT40, PEXP.SOCcer.APPAR

In the previous example, the following rules are defined:

- Account ACCT10 translates to PEXP.SOCcer.SHOES.
- Account ACCT20 translates to PEXP.SOCcer.BALLS.
- Account ACCT30 translates to PEXP.SOCcer.EQUIP.
- Account ACCT40 translates to PEXP.SOCcer.APPAR.

**Range Rules for ASCII Files**

You use Range rules to group several external entities or accounts and match them to one Hyperion Enterprise entity or account. For example, you might want to translate the accumulation of accounts 20100 through 20500 in your general ledger to OTHERINC in Hyperion Enterprise.

*Note:* Range rules support only the asterisk ( * ) wildcard, which you can use in the Oracle’s Performance Management software table but not the external table. The asterisk cannot be combined with any other characters. Using the wildcard maintains the same external name or account as the internal Hyperion entity or account.

For Range rules, use this format:

External1 > Externaln, Hyperion
### Variable Description

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>External</td>
<td>The first entity or account in a series in an external data source</td>
</tr>
<tr>
<td>Externaln</td>
<td>The last entity or account in a series in an external data source</td>
</tr>
<tr>
<td>Hyperion</td>
<td>The Hyperion Enterprise entity or account under which you want to group the accounts.</td>
</tr>
</tbody>
</table>

In the following example, the accumulation of accounts ACCT50 through ACCT70 translates to PEXP.SOCER.NOVELTIES:

ACCT50, ACCT70, PEXP.SOCER.NOVELTIES

### Global Rules for ASCII Files

You use Global rules to translate multiple names or accounts using wildcards.

For Global rules, use this format:

*External*, Hyperion

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>External</td>
<td>The external entity or account to which you want to assign a Global rule</td>
</tr>
<tr>
<td>Hyperion</td>
<td>The Hyperion Enterprise account to which you want the rule to apply</td>
</tr>
</tbody>
</table>

In the following example, the external accounts that start with the number 2 translate to SOCCER.OTHER:

2*, SOCCER.OTHER

You can also use the asterisk ( * ) wildcard in both the External column and the Oracle's Performance Management software column instead of listing every name or account that you want to include in the load file. You could then use the Exception table to list only the entities and accounts that need to be translated.

### Results View Window

You access the Results View Window by selecting Options > View Results from the Translation Builder Window. Table 36 describes the icons that you can use in the Results View window.

**Table 36** Results View Window Icons

<table>
<thead>
<tr>
<th>Icon</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Return to the main Translation Builder window" /></td>
<td>Return to the main Translation Builder window.</td>
</tr>
<tr>
<td><img src="image" alt="Toggle between the Results View window and the LedgerLink desktop" /></td>
<td>Toggle between the Results View window and the LedgerLink desktop.</td>
</tr>
</tbody>
</table>
Icon | Purpose
---|---
![](white) | Recalculate the results of the translation. The table remains blank or contains the results of the previous translation.
![](red) | Show only untranslated items.
| | Change your view from translated to untranslated results.
| | Find text in the Results table.
| | Print your results.

**Toolbar**

When you move the cursor over a toolbar button, its description is displayed in the status bar at the bottom of the window.

Table 37 shows the toolbar buttons and their purposes.

**Table 37  Translation Builder Window Toolbar**

<table>
<thead>
<tr>
<th>Button</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="white" alt="icon" /></td>
<td>Return to the LedgerLink desktop.</td>
</tr>
<tr>
<td><img src="red" alt="icon" /></td>
<td>Create a translation file.</td>
</tr>
<tr>
<td><img src="blue" alt="icon" /></td>
<td>Open a translation file.</td>
</tr>
<tr>
<td><img src="green" alt="icon" /></td>
<td>Save the current translation file.</td>
</tr>
<tr>
<td><img src="yellow" alt="icon" /></td>
<td>Open an external entity or account list.</td>
</tr>
<tr>
<td><img src="purple" alt="icon" /></td>
<td>Create or update an external entity or account list.</td>
</tr>
<tr>
<td><img src="gray" alt="icon" /></td>
<td>Switch to name translation mode.</td>
</tr>
<tr>
<td><img src="orange" alt="icon" /></td>
<td>Switch to account translation mode.</td>
</tr>
<tr>
<td><img src="brown" alt="icon" /></td>
<td>View the results or a complete listing of the rules you defined.</td>
</tr>
<tr>
<td>Button</td>
<td>Purpose</td>
</tr>
<tr>
<td>--------</td>
<td>---------</td>
</tr>
<tr>
<td><img src="image1.jpg" alt="Button" /></td>
<td>Find text within the Exceptions, Ranges, or Global tables.</td>
</tr>
<tr>
<td><img src="image2.jpg" alt="Button" /></td>
<td>Change the current Hyperion Enterprise application.</td>
</tr>
<tr>
<td><img src="image3.jpg" alt="Button" /></td>
<td>Change the current Hyperion Enterprise organization.</td>
</tr>
</tbody>
</table>

### Status Bar

The status bar provides the name of the current Hyperion Enterprise application. The status bar also displays an icon description when you move the cursor over an icon on the toolbar.

### Setting Translate and Load Options

You must set options to control how the system translates and loads data into Hyperion Enterprise. To set these options, you create load profiles in the Translate / Load Profiles module. You specify the settings and then run the profile.

Profiles are internal LedgerLink files contained in the HPLLINK.MDB file. They do not have file extensions and can be accessed only in the Translate / Load Profiles module or using Microsoft Access.

You must identify the following types of files in each profile:

- General ledger output file
- Hyperion Enterprise load file
- Template created in G/L Template Wizard
- Name and account translation tables created in Translation Builder
- Hyperion Enterprise options to attach to the data, such as scale and data view

When you set profiles, you can choose to translate data into the Hyperion Enterprise format without loading it into Hyperion Enterprise.

### Translate / Load Profiles List Box

In the Translate / Load Profiles list box, you open new profiles or edit existing ones. You can also rename, delete, or copy profiles. Figure 31 shows the Translate / Load Profiles List Box.
Table 38 describes the dialog box that contains existing profiles and six buttons.

<table>
<thead>
<tr>
<th>Button</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Rename</td>
<td>Rename the selected profile, overwriting the former name.</td>
</tr>
<tr>
<td>Delete</td>
<td>Delete the selected profile.</td>
</tr>
<tr>
<td>Copy</td>
<td>Create a copy of the selected profile that you can save under a new name.</td>
</tr>
<tr>
<td>New</td>
<td>Create a new profile.</td>
</tr>
<tr>
<td>Edit</td>
<td>Open the selected profile for revisions.</td>
</tr>
<tr>
<td>Close</td>
<td>Close the list box.</td>
</tr>
</tbody>
</table>

Translate / Load Profile Dialog Box

In the Translate / Load Profile dialog box, you set the attributes of load profiles. You specify which files and which Hyperion Enterprise options make up the profile. The Translate / Load Profile dialog box has two tabs. In the Translate tab, you choose the files needed for the data load. In the Load tab, you choose the Hyperion Enterprise options for the load profile, such as scale or start period.

Translate Tab

Figure 32 shows the Translation tab.
Table 39 describes the Translate tab options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prompt at Time of Load</td>
<td>Designate the general ledger source file during the load to Hyperion Enterprise.</td>
</tr>
<tr>
<td>Source G/L Output File</td>
<td>Provide the drive, path, and file name of the general ledger output file.</td>
</tr>
<tr>
<td>Hyperion Enterprise Load File</td>
<td>Provide the drive, path, and file name of the optional Hyperion Enterprise load file.</td>
</tr>
<tr>
<td>G/L Template</td>
<td>Provide the file name of the G/L Template file.</td>
</tr>
<tr>
<td>Entity Translation File</td>
<td>Provide the drive, path, and file name of the Entity Translation file.</td>
</tr>
<tr>
<td>Account Translation File</td>
<td>Provide the drive, path, and file name of the Account Translation file.</td>
</tr>
<tr>
<td>Load Translated G/L file to Hyperion Enterprise Only</td>
<td>Load only a Hyperion Enterprise load file when performing Hyperion-to-Hyperion transfers. Selecting this box removes all other edit boxes from the Translate tab.</td>
</tr>
<tr>
<td>Browse</td>
<td>Select a file from a dialog box. The Browse button appears next to one of four edit boxes, depending on which is the currently or most recently active: Source G/L Output File, Hyperion Load File, Name Translation File, or Account Translation File.</td>
</tr>
<tr>
<td>Edit</td>
<td>Open a file in a text editor. The Edit button appears next to one of two edit boxes, depending on which is the currently or most recently active: Source G/L Output File edit box or Hyperion Load File edit box.</td>
</tr>
</tbody>
</table>

**Load Tab**

Figure 33 shows the Load tab.
Table 40 describes the Load tab options.

<table>
<thead>
<tr>
<th>Option</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Header Options in G/L Source File</td>
<td>Tell LedgerLink to use the headers contained in the general ledger source file. Selecting this box removes the Category, Start Period and End Period edit boxes from the Load tab.</td>
</tr>
<tr>
<td>Category</td>
<td>Specify the category for the data being loaded.</td>
</tr>
<tr>
<td>Start and End Periods</td>
<td>Specify the starting and ending periods for the data being loaded.</td>
</tr>
<tr>
<td>Scale</td>
<td>Specify the scale of the data.</td>
</tr>
<tr>
<td>Mode</td>
<td>Specify whether to accumulate, replace, or merge when loading the data.</td>
</tr>
<tr>
<td>Data View</td>
<td>Specify whether data view is periodic, year-to-date, or by category.</td>
</tr>
<tr>
<td>Options</td>
<td>Specifies whether to have the system perform any of these tasks during the data load: calculate formulas, report a data load to a calculated account as an error, or display accounts with no data as zero.</td>
</tr>
<tr>
<td>Load Translated G/L File to Hyperion Enterprise Only</td>
<td>Loads only a Hyperion Enterprise load file, for use in Hyperion-to-Hyperion transfers. Selecting this box removes the Use Header Options in the G/L Source File check box and the Category, Start Period and End Period edit boxes from the Load tab.</td>
</tr>
</tbody>
</table>
Loading Data into Hyperion Enterprise

The Load to Hyperion Enterprise window displays all available load profiles in the Load Profiles list box. On the right, the window displays the characteristics of the current profile. At the bottom of the window, a status bar lists the current application and organization.

You use the menu commands and toolbar icons to load General Ledger data into Hyperion Enterprise, edit profiles, view logs, and change applications. Table 41 describes the menu items.

Table 41  Load to Hyperion Enterprise Menu Items Commands

<table>
<thead>
<tr>
<th>Command</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Cloud Icon]</td>
<td>Load the selected profile into Hyperion Enterprise.</td>
</tr>
<tr>
<td>![Desktop Icon]</td>
<td>Exit the Load to Hyperion Enterprise module and return to the desktop.</td>
</tr>
<tr>
<td>![Attributes Icon]</td>
<td>Change the attributes of the current profile.</td>
</tr>
<tr>
<td>![Red Icon]</td>
<td>Display the ERROR.LOG file, which contains any errors encountered during the load to Hyperion Enterprise.</td>
</tr>
<tr>
<td>![Gray Icon]</td>
<td>Display the ADMIN.ERR file, which contains any data from the load file that could not be loaded into Hyperion Enterprise because of errors.</td>
</tr>
<tr>
<td>![Application Icon]</td>
<td>Select a new Hyperion Enterprise application to which you can load data.</td>
</tr>
<tr>
<td>![Organization Icon]</td>
<td>Select a new Hyperion Enterprise organization to which you can load data.</td>
</tr>
<tr>
<td>![Category Icon]</td>
<td>Select a new Hyperion Enterprise category to which you can load data.</td>
</tr>
<tr>
<td>![Period Icon]</td>
<td>Select a new Hyperion Enterprise period to which you can load data.</td>
</tr>
</tbody>
</table>

Starting LedgerLink

During initial installation, you select a directory for the HPLL32.EXE file. It should be the same directory that contains HYPENT.EXE. The first time you access a Hyperion Enterprise application using LedgerLink, the system creates a directory called LLINK under the application directory and creates the file HPLLINK.MDB in the LLINK directory. For example, if you access an application in the C:\HYPENT\WWCONSOL directory, the system creates the C:\HYPENT\WWCONSOL\LLINK directory and creates a HPLLINK.MDB file in that directory. The LLINK directory contains any LedgerLink files not specific to a Hyperion Enterprise application. LLINK directories are specified in the HPADDONS.INI file, which resides in your windows directory. The HPLLINK.MDB file stores the templates and load profile defined for the application.

**Note:** LedgerLink uses Hyperion Enterprise security to determine the access rights you have.
To start LedgerLink:

1 Exit Hyperion Enterprise.
2 From the Start menu, select Programs > Hyperion Solutions > Hyperion Enterprise > LedgerLink.
3 Select the Hyperion Enterprise application from the Application Name list box.
4 Enter your user ID and password.
5 Click OK.

Changing the Hyperion Enterprise Application

You can change the Hyperion Enterprise application to which you are loading data without exiting LedgerLink. LedgerLink uses Hyperion Enterprise security to determine the access rights you have for an application. Therefore, to access an application from within LedgerLink, you use the same user ID and password that you use to access a Hyperion Enterprise application.

To change the Hyperion Enterprise application:

1 From the LedgerLink Desktop, select Options > Application.
2 Select the Hyperion Enterprise application from the Application Name list box.
3 Enter your user ID and password.
4 Click OK.

Selecting a Sample Record

After you specify a source sample file and its type, you select the sample record that most accurately represents how the external general ledger assigns and delimits record fields. The source sample file's records are displayed. You can scroll through the file to find the record that best represents the records in your file. You identify the fields in the record that represent the name, account, and data. You also identify the symbol or format that separates fields in the record.

To select a sample record:

1 Select a source sample file. For instructions, see “Selecting a Source Sample File” on page 161.
2 Select a record from the view box.
   - If you select a record that is nondelimited and does not use fixed-length formatting, the Fixed Record Length text box appears.
3 If the Fixed Record Length text box is displayed, place the record's fields in fixed-length columns. To align the fields in columns, either type the field length or click the arrows until the fields are aligned.
4 Click Next.
5 Verify field formats. For instructions, see “Verifying the Field Format” on page 177.
Verifying the Field Format

The source general ledger field format can be fixed length, delimited, or formatted. LedgerLink selects the field format based on the sample record you selected. You then verify the format that LedgerLink selects.

Here are the possible formats of your data file:

- **Fixed-length fields** - Aligned in columns and do not use characters as separators. The columns must be consistent throughout the file.
- **Delimited fields** - Use characters such as commas (,) or semicolons (;) to separate data items.
- **Formatted data** - Data fields that use currency symbols, commas, or parentheses. For example, the data item $123,000 contains currency symbols and commas.

LedgerLink uses the currency format you specify in Windows to determine the thousand and decimal separators. If you want to change options, you can select either a comma or a space as a field delimiter, or enter a different one.

**Note:** When LedgerLink loads data to Hyperion Enterprise, it converts the data format to the standard format for Hyperion Enterprise. For example, if parentheses designate negative numbers in your output file, the parentheses will change to a minus sign (-) in Hyperion Enterprise.

To verify the field format:

1. Select a sample record. For instructions, see “Selecting a Sample Record” on page 176.
2. Select Fixed Length or Delimited, depending on how your general ledger data is formatted.
3. If your data contains currency symbols, commas, or parentheses, select Formatted Data.
4. If your record is delimited and you want to change the field delimiter, select Delimited. Type the delimiter that your external general ledger system uses, or select Space.
5. Click Next.
6. Configure the templates. For instructions, see “Configuring the Template” on page 177.

Configuring the Template

You configure the template to store information from the source record in Hyperion Enterprise name, account, and data fields. You can drag and drop a field or group of fields from the sample record into one of three categories: name, account, or data.

Once you place a field in a category, you can check its position on the record. For example, if the Account field is the second field on the record, it is identified as Field 2.

**Note:** Depending on the task, the cursor has different shapes. It is a four-arrow icon after you select fields, an arrow-with-lines icon while you drag, and a hand-with-lines icon when it is positioned over the edit box.
To configure the template:

1 Verify the field format. For instructions, see “Verifying the Field Format” on page 177.

2 Highlight the field or fields that identify names:
   - For delimited data, click anywhere in the field.
   - For fixed-length data, select the entire field. If your sample file has blank spaces preceding
     the data, select those spaces to ensure enough column width for varying data lengths.

3 Drag the highlighted field or fields to the Name text box.

4 Repeat steps 2 and 3 for the Account and Data text boxes.

5 From the Name, Account, and Data text boxes, take one of the following actions:
   - To remove a single field or adjacent fields, select the field or fields and drag them to the trash
     can icon in the lower right.
   - To remove all fields from all three edit boxes, click Clear All Fields.

6 To place additional text or a period in your Name or Account text box, take one or more of the following
   actions:
   - To add a period, drag the Period button to the text box.
   - To add text, drag the Text button to the text box. Type the text in the dialog box, then click
     OK.

7 For fixed-length fields, type the data column width in the Data Column Width text box.

   Tip: You can highlight the data in the sample record and drag it to the edit box.

8 To display the location of the name, account, and data elements in the sample record, select Show
   Positions.

9 To complete the configuration:
   - If the sample file is in a report format, click Next, then specify report formats. For
     instructions, see “Specifying the Report Format” on page 178.
   - If the sample file is a table extract, click Finish. Type a name for the template and click
     OK.

**Specifying the Report Format**

If your sample file is in the form of a report, you must specify how many File Header, Page
Header, Page Body, and Page Footer lines are in your report.

   Note: Depending on the task, the cursor takes on different shapes. It is an arrow-with-lines icon
   while you drag and a hand-with-lines icon when it is over the edit box.

To specify the report format:

1 Configure the template. For instructions, see “Configuring the Template” on page 177.
2 Type the number of lines for each of the following in its corresponding text boxes: File Header, Page Header, Page Body, and Page Footer.

3 Select Finish.

4 Enter a name for the template, then click OK.

### Defining External Lists

You create external lists based on a general ledger output (.g1o) file and a LedgerLink template. After the external list is created and integrated into a translation file, you can update the list directly in LedgerLink if necessary.

You can also display a previously created name or account translation file in the Make External Account List dialog box. You can then define the relationship between external entities or accounts and Hyperion entities or accounts.

To define an external list or to display a previously created account translation file:

1. From the LedgerLink Desktop, click Translation Builder.
2. To specify whether you want to create or update an external account or entity list, or to open a previously existing one, select Options > Account Translation or Options > Name Translation.

Tip: You can select the name or account translation icon on the toolbar.

3 Take one of the following actions:
   - To create a list, select File > Make External List or select the Make External List icon on the toolbar.
   - To open a list, select File > Open External List or select the appropriate icon on the toolbar.

4 Type the file names.
5 If you opened a previously existing list, select a template from the G/L Template drop-down list.

6 Create or update the list:
   - To create a list, select Create New External List.
   - To update the selected list, select Update External List.

7 Click OK.

### Setting Up Translation Rules

To create a translation file, you must know the entities and accounts in both the external system and the Hyperion Enterprise application. As you create the translation file, you define the rules for translating data.

You can define three types of rules: Exception, Range, or Global. Table 42 provides a brief description of translation rules. For more information on translation rules, see “Translation Rules” on page 165.
Table 42  Translation Rules

<table>
<thead>
<tr>
<th>Rule Type</th>
<th>Purpose</th>
</tr>
</thead>
<tbody>
<tr>
<td>Exception</td>
<td>Match external entities or accounts with Hyperion Enterprise entities or accounts in a one-to-one relationship.</td>
</tr>
<tr>
<td>Range</td>
<td>Group several external entities or accounts with one Hyperion Enterprise entities or account.</td>
</tr>
<tr>
<td>Global</td>
<td>Use a wildcard such as asterisk ( * ) or question mark ( ? ) to translate multiple names or accounts.</td>
</tr>
</tbody>
</table>

To set up translation rules:

1. From the LedgerLink Desktop, click Translation Builder.
2. Take one of the following actions:
   - To create a new translation file, select File > New or click the New button in the toolbar.
   - To open an already existing translation file, select File > Open or click the Open toolbar button, select the file name, then click OK.
3. Select Options > Name Translation or Options > Account Translation.
   
   Tip: To change the Hyperion Enterprise application or organization, select either the Application toolbar icon or the Organization toolbar icon.
4. Define the rules for entities or accounts by selecting the tab for the type of rule you want to create: Exception, Range, or Global.
5. Enter the entities in the appropriate table.

**Viewing Translation Results**

After you define the translation mapping rules, you can view a complete list of the rules in the Results View window. You can also switch between translated and untranslated data views. The Results View window displays a table listing the external entities or accounts, the rule number, the rule, and the result. You can display all the results or only those that are not translated. You can also print the listing.

**Note:** Accounts that did not translate to Hyperion Enterprise appear in red.

To view translation results:

1. From the LedgerLink Desktop, click Translation Builder.
2. To change the data view between names and accounts, select Options > Name Translation or Options > Account Translation.
3. Select Options > View Results.
4. Optional: To refresh the data values, click the Calculate button.
5. To view more specific results criteria:
To display the results of the translation, click the Calculate Data button on the toolbar.

- To display the untranslated results, click the Show Untranslated button on the toolbar.

**Tip:** You can view the Hyperion Enterprise entities and accounts separately from the external source entities and accounts by selecting the Show Only Untranslated button on the toolbar.

6 Select **File > Close** to return to the LedgerLink Desktop.

## Importing Translation Files

You can import and export both entity and account translation files instead of creating them. These .TRA files are ASCII file versions of the Exception, Range, and Global tables. The import method allows you to build translations quickly without using the LedgerLink to specify rules. You use a different format for each type of translation rule. For more information on Exception, Range, and Global Rules for ASCII Files, see “Imported Translation File Rules” on page 167.

**Note:** You must save each file as a translation file (.LNT or .LAT) in LedgerLink after importing it, or you will be able to access the file through the import process only.

1. From the **LedgerLink Desktop**, click **Translation Builder**.
2. Select **File > New**.
3. To select entity or account external translation files, select **Options > Account Translation** or **Options > Name Translation**.
4. Select **File > Import Translation File**.
5. Select the translation file that you want to import.
6. Click **OK**.
7. To save the file, select **File > Save As**.
8. Enter the path and file name in the **Filename** list box.

**Tip:** You must save the file as a translation file (.LAT or .LNT) in LedgerLink, or you will be able to access the file through the import process only.

9 Click **OK**.

## Defining Translation Profiles

Translation profiles specify the data, template, and translation files you use to load data into Hyperion Enterprise.
To define a translation profile:

1. From the LedgerLink Desktop, select Translate > Load Profiles.

2. In the Translate / Load Profiles list box, create or edit a profile:
   - To create a profile, click New.
   - To edit a profile, select the profile, then click Edit.

3. In the Source G/L Output File text box, type the drive, path, and file name of your general ledger output file that you want to import into Hyperion Enterprise.

   Tip: To select the general ledger output file during the load to Hyperion Enterprise, select Prompt at Time of Load.

4. To edit your general ledger output file, click Edit. If you have not defined a file association, a message appears, prompting you to do so.

5. To select or create a Hyperion Enterprise load file:
   - In the Hyperion Enterprise Load File edit box, enter the drive, path, and file name of a Hyperion Enterprise load file.
   - To create a Hyperion Enterprise load file, select Create Hyperion Load File.

6. Select a template from the G/L Template drop-down list.

7. Enter the drive, path, and file name of the entity or account translation file in the Name Translation File text box or the Account Translation File text box.

8. To load only a Hyperion Enterprise load file, select Load Translated G/L File to Enterprise Only.

9. Save your changes or load a file:
   - To save your changes and close the dialog box, select OK. If you are creating a profile, the Enter Load Name dialog box appears. Enter an ID of up to 40 characters, and then click OK.

   Tip: You can also save the changes from the Load tab.

   - To load a file, select the Load tab. For instructions on setting load options, see “Defining Load Profiles” on page 182.

---

Defining Load Profiles

Load profiles specify the Hyperion Enterprise options for the data when it is loaded into Hyperion Enterprise.

To define load profiles:

1. From the LedgerLink Desktop, select Translate > Load Profiles.

2. In the Translate / Load Profile dialog box, select the Load tab.

3. To use the headers in your general ledger source file, select Use Header Options in G/L Source File.
If you have not selected Use Header Options in G/L Source File, select a data category from the **Category** text box, enter a starting period in the **Start Period** edit box, and enter an ending period in the **End Period** edit box.

**5** Select a scale, or select **Default** to use the default scale for the selected category.

**6** Select one of the following modes in the **Mode** text box:
- Select **Accumulate** to add the data values in your general ledger output file to the data values that already exist in Hyperion Enterprise.
- Select **Replace** to delete values in all accounts in Hyperion Enterprise and to insert the values from your general ledger output file.
- Select **Merge** to clear values in Hyperion Enterprise only for accounts for which you are inserting new values from your general ledger output file.

**7** In the **Data View** text box, select the data view that corresponds to your Hyperion Enterprise application.

**8** Specify tasks for the system to perform during data load:
- To calculate formulas automatically, select **Execute Logic**.
- To report an error if you try to load data into a calculated account, select **Report Calc Accts**.
- To display accounts with no data as zero, select **Zero No Data**.

**9** Click **OK** to save the changes.

**10** If you are creating a new profile, enter an ID of up to 40 characters and click **OK**.

---

**Loading Data into Hyperion Enterprise**

You can load source system data to the Hyperion Enterprise database using the templates, translations, and profiles defined in LedgerLink. Load profiles specify the files and settings needed to translate and load data into Hyperion Enterprise. For more information, see "Setting Translate and Load Options" on page 171.

To load data into Hyperion Enterprise:

1. From the **LedgerLink Desktop**, select **Load to Hyperion Enterprise**.

2. In the **Load to Hyperion Enterprise** window, select a load profile from the **Load Profile** list box.

3. To change the profile’s attributes, select **Options > Edit Profile** or click the **Edit Profile** button. For instructions, see “Defining Translation Profiles” on page 181 and the “Defining Load Profiles” on page 182.

4. Select **File > Load**.

   If the load profile was set up to prompt you for a general ledger output file during the load procedure, the Select G/L Output File dialog box is displayed.

5. If the **Select G/L Output File** dialog box is displayed, select an output file, then click **OK**.

6. If an error message appears that states that data could not be loaded into Hyperion Enterprise, select **Options > View Error Log**.
If other error messages appear during the load to Hyperion Enterprise, select **Options > View Load Log.**
This appendix provides the syntax for Hyperion Retrieve functions and examples of their use.

**Function Syntax and Examples**

The following sections provide the syntax and examples for specific Hyperion Retrieve functions.

**HPACC - Account ID Function**

You use the HPACC function to retrieve and show the ID of a specified account. Use this format:

\[ \text{HPACC("Account","Application")} \]

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>The ID for the account</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the account</td>
</tr>
</tbody>
</table>

For example, if the Tax application contains the Cost of Goods Sold account and its ID appears in cell A7, you can use this formula for cell A23 to show the Cost of Goods Sold account ID in cell A23:

\[ \text{HPACC(A7,"TAX")} \]

**HPAMJ - Major Account ID Function**

You use the HPAMJ function to retrieve and show the major account ID for a specified account. Use this format:

\[ \text{HPAMJ("Account","Application")} \]
### Variable Description

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>The ID for the account.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the account.</td>
</tr>
</tbody>
</table>

For example, suppose you type this formula for cell A23:

$$\text{HPAMJ} (A14, "\text{PROD}")$$

If the account ID SALES.GOLF.SHOES appears in cell A14 and the Product application contains that account, the major account ID SALES appears in cell A23.

### HPAS1 - First-level Subaccount ID Function

You use the HPAS1 function to retrieve and show the first-level subaccount ID for a specified account. Use this format:

$$\text{HPAS1} ("\text{Account","Application")}$$

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>The ID for the account.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the account.</td>
</tr>
</tbody>
</table>

For example, suppose you type this formula for cell A28:

$$\text{HPAS1} (A14, "\text{PROD}")$$

If the account ID SALES.GOLF.SHOES appears in cell A14 and the Product application contains that account, the first-level subaccount ID GOLF appears in cell A28.

### HPAS2 - Second-level Subaccount ID Function

You use the HPAS2 function to retrieve and show the second-level subaccount ID for a specified account. Use this format:

$$\text{HPAS2} ("\text{Account","Application")}$$

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>The ID for the account.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the account.</td>
</tr>
</tbody>
</table>

For example, suppose you type this formula for cell A32:

$$\text{HPAS2} (A14, "\text{PROD}")$$

If the account ID SALES.GOLF.SHOES appears in cell A14 and the Product application contains that account, the second-level subaccount ID SHOES appears in cell A32.
HPBET - Difference Function

You use the HPBET function to calculate and return the difference between two data values for a specified account. The difference appears with a minus sign ( - ) if it is negative. Use this format:

\[ \text{HPBET("Account","Value1","Value2","Application")} \]

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>The account ID.</td>
</tr>
<tr>
<td>Value1</td>
<td>A formula, number, or cell reference for the first value.</td>
</tr>
<tr>
<td>Value2</td>
<td>A formula, number, or cell reference for the second value.</td>
</tr>
<tr>
<td>Application</td>
<td>The application ID.</td>
</tr>
</tbody>
</table>

For example, suppose you want to return the difference between the October 2002 and November 2002 values of the Cost of Goods Sold account for the current entity and category in the Tax application. If the account ID appears in cell A5 of the worksheet, the November 2002 value appears in cell D5, and the October 2002 value appears in cell C5, you could use this formula to return the difference between the two values:

\[ \text{HPBET(A5,D5,C5,"TAX")} \]

You can also use the HPBET function to return the difference between an account's values for two different categories in the same period. For example, you might want to show the difference between the Cash account’s February values in the Actual and Last Year categories, or the difference between its values for the Israel and France entities.

**Note:** The system evaluates the difference between the values based on the account type. If you specify an income or a liability account and the second value is greater than the first, the result is negative. If you specify an expense or an asset account and the second value is greater than the first, the result is positive.

HPCAL - Calculated Account Function

You use the HPCAL function to return and show a 1 if a specified account is a calculated account, or a -1 if it is not. Use this format:

\[ \text{HPCAL("Entity","Category","Account","Application")} \]

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The entity ID.</td>
</tr>
<tr>
<td>Category</td>
<td>The category ID.</td>
</tr>
<tr>
<td>Account</td>
<td>The account ID.</td>
</tr>
</tbody>
</table>
**Variable** | **Description**
--- | ---
*Application* | The ID of the application that contains the account.

For example, this formula returns a 1 because for the entity USWEST in the Product application, the Total Sales account is a calculated account:

\[
\text{HPCAL}(*\text{USWEST*}, "\text{ACTUAL*}, "\text{TOTSALES*}, *\text{PROD*})
\]

**HPCDE - Category Description Function**

You use the HPCDE function to retrieve and show the description for a specified category. Use this format:

\[
\text{HPCDE("Category", "Application")}
\]

**Variable** | **Description**
--- | ---
*Category* | The category ID.
*Application* | The application ID.

For example, this formula returns the description for the Forecast category in the Tax application:

\[
\text{HPCDE(*FORCST*, "TAX")}
\]

**HPCONTRIB - Contribution Data Function**

You use the HPCONTRIB function to retrieve contribution data. Use this format:

\[
\]

**Variable** | **Description**
--- | ---
*Entity* | The entity ID.
*Category* | The category ID.
*Account* | The account ID.
*Period* | The period ID.
*Frequency* | The frequency ID.
*Parent* | The parent entity ID.
*Application* | The ID for the application that contains the contribution data.

For example, the following formula returns the Actual category’s contribution data for the Israel entity in the Cables account for the April 2002 period. This formula shows a monthly data view for the parent Europe in the Tax application:
**HPCONTRIB**(*Israel*, "ACTUAL", "CABLES", "APR 02", "MON", "EUROPE", "TAX")

**Note:** The HPCONTRIB function uses the scale of the parent instead of the entity.

**HPCUR - Currency Function**

You use the HPCUR function to retrieve and show the default currency ID for a specified entity. Use this format:

HPCUR("Entity","Application")

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The entity for which you want to retrieve the default currency ID.</td>
</tr>
<tr>
<td>Application</td>
<td>The application ID.</td>
</tr>
</tbody>
</table>

For example, this formula returns the default currency ID for the Israel entity in the Tax application:

HPCUR("Israel","TAX")

**HPDCTRL - Direct Control Function**

You use the HPDCTRL function to retrieve either the amount of voting shares owned or the percentage directly controlled, depending on whether you input shares as units or percentages. Use this format:


<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent</td>
<td>The parent entity ID.</td>
</tr>
<tr>
<td>Child</td>
<td>The child entity ID.</td>
</tr>
<tr>
<td>Category</td>
<td>The category ID.</td>
</tr>
<tr>
<td>Period</td>
<td>The period ID.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the amount of voting shares.</td>
</tr>
</tbody>
</table>

For example, this formula returns the amount of voting shares for the parent Europe with the child Israel in the Actual category for the period April 2002 in the Tax application.

HPDCTRL("EUROPE","Israel","ACTUAL","APR 02","TAX")
**HPDOWN - Direct Ownership Function**

You use the HPDOWN function either to retrieve the number of shares that the partner directly owns or to retrieve a direct ownership percentage, depending on whether you input shares as units or percentages. Use this format:

```
```

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent</td>
<td>The parent entity ID.</td>
</tr>
<tr>
<td>Child</td>
<td>The child entity ID.</td>
</tr>
<tr>
<td>Category</td>
<td>The category ID.</td>
</tr>
<tr>
<td>Period</td>
<td>The period ID.</td>
</tr>
<tr>
<td>Application</td>
<td>The application that contains the number of shares directly owned.</td>
</tr>
</tbody>
</table>

For example, this formula returns the number of shares that the parent Europe owns of the child Israel in the Actual category for the period of April 2002 in the Tax application:

```
HPDOWN("EUROPE","Israel","ACTUAL","APR 02","TAX")
```

**HPDRV - Derived Sum Function**

The results of the HPDRV function depend on the account type of a specified account. If you specify an income, expense, or flow account, the HPDRV function returns the sum of the account's values for two specified periods for the current entity and category. If you specify an asset, liability, or balance account, the HPDRV function returns a value for the later of two periods for the current entity and category without adding that value to the earlier value.

Use this format:

```
HPDRV("Account","Value1","Value2","Application")
```

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>The account ID.</td>
</tr>
<tr>
<td>Value1</td>
<td>A formula, number, or cell reference for the later period's value.</td>
</tr>
<tr>
<td>Value2</td>
<td>A formula, number, or cell reference for the earlier period's value.</td>
</tr>
<tr>
<td>Application</td>
<td>The application ID.</td>
</tr>
</tbody>
</table>

For example, suppose the Cost of Goods Sold account in the Tax application is a flow account, and you want to total its October 2002 and November 2002 values. If the account ID appears in cell A5 of the worksheet, the November 2002 value appears in cell D5, and the October 2002 value appears in cell C5, you could use this formula to return the sum of the values:

```
HPDRV (A5, D5, C5, "TAX")
```
HPECODE - Entity Code Function

You use the HPECODE function to retrieve the entity code, which is a user-assigned code associated with the entity for a particular category and period. Use this format:

HPECODE("Entity", "Category", "Period", "Application")

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The entity ID.</td>
</tr>
<tr>
<td>Category</td>
<td>The category ID.</td>
</tr>
<tr>
<td>Period</td>
<td>The period ID.</td>
</tr>
<tr>
<td>Application</td>
<td>The application that contains the entity.</td>
</tr>
</tbody>
</table>

For example, this formula returns the entity code for the Israel entity in the Actual category for the April 2002 period in the Tax application:

HPECODE("Israel", "ACTUAL", "APR 02", "TAX")

HPELIM - Elimination Data Function

You use the HPELIM function to retrieve elimination data. Use this format:


<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The entity ID.</td>
</tr>
<tr>
<td>Category</td>
<td>The category ID.</td>
</tr>
<tr>
<td>Account</td>
<td>The account ID.</td>
</tr>
<tr>
<td>Period</td>
<td>The period ID.</td>
</tr>
<tr>
<td>Frequency</td>
<td>The frequency ID.</td>
</tr>
<tr>
<td>Parent</td>
<td>The parent entity ID.</td>
</tr>
<tr>
<td>Application</td>
<td>The application that contains the elimination data.</td>
</tr>
</tbody>
</table>

For example, this formula returns elimination data for the Israel entity in the Actual category for the Cables account for the April 2002 period with a monthly data view for the parent Europe in the Tax application:

HPELIM("Israel", "ACTUAL", "CABLES", "APR 02", "MON", "EUROPE", "TAX")

Note: The HPELIM function uses the scale of the parent instead of the entity.
**HPFLW - Flow Function**

You use the HPFLW function to return a 1 if a specified account is an income, expense, or flow account, or a -1 if it is any other type of account. You can use the results returned by the HPFLW function in Excel formulas to differentiate income statement accounts from balance sheet accounts. Use this format:

HPFLW("Account","Application")

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>The account ID.</td>
</tr>
<tr>
<td>Application</td>
<td>The application ID.</td>
</tr>
</tbody>
</table>

For example, this formula returns a 1 because the Pretax Earnings account in the Tax application is a flow account:

HPFLW("PTE","TAX")

**HPFNA - First Entity Description Function**

You use the HPFNA function to retrieve and show the first entity description for a specified entity. Use this format:

HPFNA("Entity","Application")

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The ID for the entity.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the entity.</td>
</tr>
</tbody>
</table>

For example, suppose you type this formula for cell D27:

HPFNA(B14,"TAX")

If the entity USELIM.PADJ in the Tax application appears in cell B14 and the description for USELIM is United States Eliminations, that description appears in the cell D27.

**HPFRE - Default Frequency Function**

You use the HPFRE function to retrieve and show the default frequency ID for a specified category. Use this format:

HPFRE("Category","Application")

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Category</td>
<td>The category ID.</td>
</tr>
<tr>
<td>Variable</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Application</td>
<td>The application ID.</td>
</tr>
</tbody>
</table>

For example, this formula returns the ID of the default frequency for the Forecast category in the Tax application:

\[ \text{HPFRE ("FORCST", "TAX")} \]

**HPFSN - Subentity Description Function**

You can use the HPFSN function to retrieve and show the descriptions of all specified subentities. Use this format:

\[ \text{HPFSN("Entity","Application")} \]

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The ID for the entity or a cell reference.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the name.</td>
</tr>
</tbody>
</table>

For example, suppose you type this formula for cell D27:

\[ \text{HPFSN(B14, "TAX")} \]

If the entity USELIM.PADJ in the Tax application appears in cell B14 and the description for PADJ is Post-Adjustment, that description appears in the cell D27.

**HPFUL - Entity Description Function**

You use the HPFUL function to retrieve and show the description for a specified entity. Use this format:

\[ \text{HPFUL("Entity","Application")} \]

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The entity ID.</td>
</tr>
<tr>
<td>Application</td>
<td>The application ID.</td>
</tr>
</tbody>
</table>

For example, this formula returns the description for the Belgium-Netherlands-Luxembourg entity in the Tax application:

\[ \text{HPFUL ("BENELUX", "TAX")} \]

**HPHEA - Account Description Function**

You use the HPHEA function to retrieve and show the description for a specified account in a specified application. Use this format:
HPHEA("Account","Application")

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>The account ID.</td>
</tr>
<tr>
<td>Application</td>
<td>The application ID.</td>
</tr>
</tbody>
</table>

For example, this formula returns the description for the SALES.FBALL.HLM account ID in the Product application:

\[
\text{HPHEA} \left( \text{"SALES.FBALL.HLM"}, \text{"PROD"} \right)
\]

If the account description is Sales.Football.Helmets, that description appears in the cell that contains the formula.

**HPMJ - Major Account Description Function**

You use the HPMJ function to retrieve and show the major account description for a specified account. Use this format:

\[
\text{HPMJ} \left( \text{"Account"}, \text{"Application"} \right)
\]

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>The ID for the account.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the account.</td>
</tr>
</tbody>
</table>

For example, suppose you type this formula for cell A23:

\[
\text{HPMJ} \left( \text{A14}, \text{"PROD"} \right)
\]

If the account ID SALES.FBALL.HLM in the Product application appears in cell A14 and the SALES account description is Sales by Product, that description appears in cell A23.

**HPHS1 - First-level Subaccount Description Function**

You use the HPHS1 function to retrieve and show the first-level subaccount description for a specified account. Use this format:

\[
\text{HPHS1} \left( \text{"Account"}, \text{"Application"} \right)
\]

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>The ID for the account.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the account.</td>
</tr>
</tbody>
</table>

For example, suppose you type this formula for cell A28:

\[
\text{HPHS1} \left( \text{A14}, \text{"PROD"} \right)
\]
If the account ID SALES.FBALL.HLM in the Product application appears in cell A14 and the FBALL subaccount description is Football, that description appears in cell A28.

**HPHS2 - Second-level Subaccount Description Function**

You use the HPHS2 function to retrieve and show the second-level subaccount description for a specified account. Use this format:

`HPHS2("Account","Application")`

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>The ID for the account.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the account.</td>
</tr>
</tbody>
</table>

For example, suppose you type this formula for cell A32:

`HPHS2(A14,"PROD")`

If the account ID SALES.FBALL.HLM in the Product application appears in cell A14 and the HLM subaccount description is Helmets, that description appears in cell A32.

**HPINC - Income Account Function**

You use the HPINC function to return and show a 1 if a specified account is an income or liability account, or a -1 if it is an asset, balance, expense, or flow account. You can use the results returned by the HPINC function in Excel formulas to show the values of income or liability accounts as positive numbers and the values of asset, balance, expense, and flow accounts as negative numbers. Use this format:

`HPINC("Account","Application")`

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>The account ID.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID of the application that contains the account.</td>
</tr>
</tbody>
</table>

For example, this formula returns a 1 because the Sales.Golf account in the Product application is an income account:

`HPINC("SALES.GOLF","PROD")`

**HPINP - Input Account Function**

You use the HPINP function to return and show a 1 if a specified account is an input account, or a -1 if it is not. Use this format:

`HPINP("Entity","Category","Account","Application")`
<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The entity ID.</td>
</tr>
<tr>
<td>Category</td>
<td>The category ID.</td>
</tr>
<tr>
<td>Account</td>
<td>The account ID.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID of the application that contains the account.</td>
</tr>
</tbody>
</table>

For example, this formula returns a 1 because for the entity USWEST in the Sales category of the Product application, the Sales.Golf account is an input account:

\[ \text{HPINP} \left( \text{"USWEST"}, \text{"ACTUAL"}, \text{"SALES.GOLF"}, \text{"PROD"} \right) \]

### HPJAC - Journal Account Function

You use the HPJAC function to retrieve the account for a specified journal detail row. Use this format:

\[ \text{HPJAC} \left( \text{"Journal"}, \text{"Table"}, \text{"Category"}, \text{"Period"}, \text{"Application"}, \text{"Detail"} \right) \]

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Journal</td>
<td>The journal for which you want to return the account.</td>
</tr>
<tr>
<td>Table</td>
<td>The type of journal: journal or template.</td>
</tr>
<tr>
<td>Category</td>
<td>The category of the journal.</td>
</tr>
<tr>
<td>Period</td>
<td>The period of the journal.</td>
</tr>
<tr>
<td>Application</td>
<td>The application ID.</td>
</tr>
<tr>
<td>Detail</td>
<td>A unique number assigned to each detail row. When you select the detail row using the Change Journal Detail option on the RHXL (in Excel) menu, the system displays the record signature for that detail row.</td>
</tr>
</tbody>
</table>

For example, to display the account IDs for a journal entry, you can use the following formula:

\[ \text{HPJAC} \left( \text{"RECLASS1"}, \text{"JOURNAL"}, \text{"ACTUAL"}, \text{"1"}, \text{"APP1"}, \text{"0"} \right) \]

### HPJCR - Journal Credit Value Function

You use the HPJCR function to retrieve the credit value for a specified journal detail row. Use this format:

\[ \text{HPJCR} \left( \text{"Journal"}, \text{"Table"}, \text{"Category"}, \text{"Period"}, \text{"Application"}, \text{"Detail"} \right) \]

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Journal</td>
<td>The journal for which you want to return the detail row's credit value.</td>
</tr>
<tr>
<td>Table</td>
<td>The type of journal: journal or template.</td>
</tr>
<tr>
<td>Variable</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td><strong>Category</strong></td>
<td>The category for which you want to return a value.</td>
</tr>
<tr>
<td><strong>Period</strong></td>
<td>The period for which you want to return a value.</td>
</tr>
<tr>
<td><strong>Application</strong></td>
<td>The application ID.</td>
</tr>
<tr>
<td><strong>Detail</strong></td>
<td>This is a unique number assigned to each detail row. When you select the detail row using the Change Journal Detail option on the RHXL (in Excel) menu, the system displays the record signature for that detail row.</td>
</tr>
</tbody>
</table>

For example, to display the credit value for a journal entry, you can use the following formula:

`HPJCR("RECLASS1", "JOURNAL", "ACTUAL", "1", "APP1", "1")`

**HPJDB - Journal Debit Value Function**

You use the HPJDB function to retrieve the debit value for a specified journal detail row. Use this format:

`HPJDB("Journal", "Table", "Category", "Period", "Application", "Detail")`

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Journal</strong></td>
<td>The journal for which you want to return the debit value.</td>
</tr>
<tr>
<td><strong>Table</strong></td>
<td>The type of journal: journal or template.</td>
</tr>
<tr>
<td><strong>Category</strong></td>
<td>The category of the journal.</td>
</tr>
<tr>
<td><strong>Period</strong></td>
<td>The period of the journal.</td>
</tr>
<tr>
<td><strong>Application</strong></td>
<td>The application ID.</td>
</tr>
<tr>
<td><strong>Detail</strong></td>
<td>This is a unique number assigned to each detail row. When you select the detail row using the Change Journal Detail option on the RHXL (in Excel) menu, the system displays the record signature for that detail row.</td>
</tr>
</tbody>
</table>

For example, to display the debit value for a journal entry, you can use the following formula:

`HPJDB("RECLASS1", "JOURNAL", "ACTUAL", "1", "APP1", "0")`

**HPJDS - Journal Description Function**

You use the HPJDS function to retrieve the journal description. Use this format:

`HPJDS("Journal", "Table", "Category", "Period", "Application")`

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Journal</strong></td>
<td>The journal for which you want to return the description.</td>
</tr>
<tr>
<td>Variable</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Table</td>
<td>The type of journal: journal or template.</td>
</tr>
<tr>
<td>Category</td>
<td>The category of the journal.</td>
</tr>
<tr>
<td>Period</td>
<td>The period of the journal.</td>
</tr>
<tr>
<td>Application</td>
<td>The application ID.</td>
</tr>
</tbody>
</table>

For example, to display the journal entry description for a journal entry, you would use the following formula:

HPJDS("RECLASS1", "JOURNAL", "ACTUAL", "1", "APP1")

**HPJEN - Journal Entity Function**

You use the HPJEN function to retrieve the entity for a specified journal detail row. Use this format:

HPJEN("Journal", "Table", "Category", "Period", "Application", "Detail")

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Journal</td>
<td>The journal for which you want to return the entity.</td>
</tr>
<tr>
<td>Table</td>
<td>The type of journal: journal or template.</td>
</tr>
<tr>
<td>Category</td>
<td>The category of the journal.</td>
</tr>
<tr>
<td>Period</td>
<td>The period of the journal.</td>
</tr>
<tr>
<td>Application</td>
<td>The application ID.</td>
</tr>
<tr>
<td>Detail</td>
<td>This is a unique number assigned to each detail row. When you select the detail row using the Change Journal Detail option on the RHXL (in Excel) menu, the system displays the record signature for that detail row.</td>
</tr>
</tbody>
</table>

For example, to display the entity for a journal entry, you can use the following formula:

HPJEN("RECLASS1", "JOURNAL", "ACTUAL", "1", "APP1", "0")

**HPJNO - Journal Number Function**

You use the HPJNO function to retrieve the number that was assigned to the journal by the system. Use this format:

HPJNO("Journal", "Table", "Category", "Period", "Application")

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Journal</td>
<td>The journal for which you want to return the number.</td>
</tr>
<tr>
<td>Variable</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Table</td>
<td>The type of journal: journal or template.</td>
</tr>
<tr>
<td>Category</td>
<td>The category of the journal.</td>
</tr>
<tr>
<td>Period</td>
<td>The period of the journal.</td>
</tr>
<tr>
<td>Application</td>
<td>The application ID.</td>
</tr>
</tbody>
</table>

For example, to display the journal number for a journal entry, you would use the following formula:

```
HPJNO("RECLASS1","JOURNAL","ACTUAL","1","APP1")
```

**HPJST - Journal Status Function**

You use the HPJST function to retrieve the journal status. Use this format:

```
HPJST("Journal", "Table", "Category", "Period", "Application")
```

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Journal</td>
<td>The journal for which you want to return the status.</td>
</tr>
<tr>
<td>Table</td>
<td>The type of journal: journal or template.</td>
</tr>
<tr>
<td>Category</td>
<td>The category of the journal.</td>
</tr>
<tr>
<td>Period</td>
<td>The period of the journal.</td>
</tr>
<tr>
<td>Application</td>
<td>The application ID.</td>
</tr>
</tbody>
</table>

For example, to display the journal status for a journal entry, you would use the following formula:

```
HPJST("RECLASS1", "JOURNAL", "ACTUAL", "1", "APP1")
```

**HPKEY - Default ID Function**

You use the HPKEY function to retrieve and show the ID for the default account, entity, category, or period.

Use this format:

```
HPKEY("Element","Application")
```

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Element</td>
<td>ACCOUNT to return the default account ID, ENTITY to return the ID for the default entity, CATEGORY to return the default category ID, or PERIOD to return the ID for the default period.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the account, entity, category, or period.</td>
</tr>
</tbody>
</table>
For example, suppose you type this formula for cell A10:

```
HPKEY("CATEGORY", "PROD")
```

If the default category for the Product application is Last Year and its ID is LASTYR, that ID appears in cell A10.

### HPLNK - Link Data Value Function

You use the HPLNK function to send a data value from a spreadsheet to the Hyperion Enterprise database for a specified entity, category, account, period, frequency, and application.

The name and account to which you are exporting data must be an input name and account. You must select either PER or CTD, rather than YTD, as the frequency view. You cannot export data from a spreadsheet to an open data file. If you are exporting to a journal entity, make sure that it does not have a journal lock applied. Turn off all cell protection in the worksheet when using the HPLNK option. Use this format:

```
HPLNK(Value,"Entity","Category","Account","Period","Frequency", "Application")
```

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Value</td>
<td>The value you want to send to Hyperion Enterprise.</td>
</tr>
<tr>
<td>Entity</td>
<td>The entity for which you want to send a value.</td>
</tr>
<tr>
<td>Category</td>
<td>The category for which you want to send a value.</td>
</tr>
<tr>
<td>Account</td>
<td>The account for which you want to send a value.</td>
</tr>
<tr>
<td>Period</td>
<td>The period for which you want to send a value.</td>
</tr>
<tr>
<td>Frequency</td>
<td>The frequency code for the data you want to send to the database.</td>
</tr>
<tr>
<td>Application</td>
<td>The application ID.</td>
</tr>
</tbody>
</table>

For example, this formula sends the value in cell A20 to the Forecast category's October 2002 value for the Cables account and the Israel entity in the Tax application, with a monthly data view:

```
HPLNK(A20,"Israel","FORCST","CABLES","OCT 02","MON","TAX")
```

For more information, see “Period Values in Hyperion Retrieve Functions” on page 209.

### HPNAM - Entity Function

You use the HPNAM function to retrieve and show the ID for a specified entity. Use this format:

```
HPNAM("Entity","Application")
```
<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The entity you want to show.</td>
</tr>
<tr>
<td>Application</td>
<td>The application ID.</td>
</tr>
</tbody>
</table>

For example, this formula returns the ID for the US100 entity in the Tax application:

```
HPNAM("US100", "TAX")
```

**HPNNA - First Entity ID Function**

You use the HPNNA function to retrieve and show the first entity ID for a specified entity. Use this format:

```
HPNNA("Entity","Application")
```

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The ID for the entity.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the entity.</td>
</tr>
</tbody>
</table>

For example, suppose you type this formula for cell D27:

```
HPNNA(B14, "TAX")
```

If the entity USELIM.PADJ in the Tax application appears in cell B14, the first entity USELIM appears in cell D27.

**HPNSN - Subentity ID Function**

You use the HPNSN function to retrieve and show the subentity ID for a specified entity. Use this format:

```
HPNSN("Entity","Application")
```

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The ID for the entity.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the entity.</td>
</tr>
</tbody>
</table>

For example, suppose you type this formula for cell D27:

```
HPNSN(B14, "TAX")
```

If the entity USELIM.PADJ in the Tax application appears in cell B14, the subentity PADJ appears in cell D27.
**HPPARADJ - Parent Adjustment Data Function**

You use the HPPARADJ function to retrieve parent adjustment data. Use this format:


<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The entity ID.</td>
</tr>
<tr>
<td>Category</td>
<td>The category ID.</td>
</tr>
<tr>
<td>Account</td>
<td>The account ID.</td>
</tr>
<tr>
<td>Period</td>
<td>The period ID.</td>
</tr>
<tr>
<td>Frequency</td>
<td>The frequency ID.</td>
</tr>
<tr>
<td>Parent</td>
<td>The parent entity ID.</td>
</tr>
<tr>
<td>Application</td>
<td>The application that contains the parent adjustment data.</td>
</tr>
</tbody>
</table>

For example, this formula returns the parent adjustment data for the Israel entity in the Actual category for the Cables account for the April 2002 period. The formula shows a monthly data view for the parent Europe in the Tax application:

HPPARADJ("Israel", "ACTUAL", "CABLES", "APR 02", "MON", "EUROPE", "TAX")

**Note:** The HPPARADJ function uses the scale of the parent instead of the entity.

**HPPBE - Percentage Difference Function**

You use the HPPBE function to return the percentage difference between two values for a specified account. The difference appears with a plus sign (+) if it is positive or a minus sign (-) if it is negative. Use this format:

HPPBE("Account","Value1","Value2","Application")

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Account</td>
<td>The account ID.</td>
</tr>
<tr>
<td>Value</td>
<td>A formula, number, or cell reference for the first value.</td>
</tr>
<tr>
<td>Value2</td>
<td>A formula, number, or cell reference for the second value.</td>
</tr>
<tr>
<td>Application</td>
<td>The application ID.</td>
</tr>
</tbody>
</table>

For example, suppose you want to return the percentage difference between the October 2002 and November 2002 values of the Cost of Goods Sold account for the Tax application. If the account ID appears in cell A5 of the worksheet, the November 2002 value appears in cell D5, the October 2002 value appears in cell C5, and the application ID appears in cell A1, you could use this formula to return the percentage difference between the two values:
You could also use the HPPBE function to return the percentage difference between an account's values for two different categories or entities in the same period. For example, you might want to show the percentage difference between the Cash account's February values in the Actual and Last Year categories, or the percentage difference between its values for the Israel and France entities.

**Note:** The system evaluates the difference between the two values based on the account type. If you specify an income or a liability account and the second value is greater than the first, the result is negative. If you specify an expense or an asset account and the second value is greater than the first, the result is positive.

**HPPCH - Percentage Change Function**

You use the HPPCH function to return the percentage change between two values. The system uses this formula:

\[ \frac{(Value 1 - Value 2)}{Value 2} \times 100 \]

You might use the HPPCH function to calculate the percentage change between an account's values for two periods, regardless of account type. You might also use it to calculate the percentage change between an account's values in the same period for two different categories or two different entities. The system does not evaluate whether the percentage change is positive or negative. Use this format:

HPPCH("Value1","Value2","Application")

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Value1</td>
<td>A formula, number, or cell reference for the first value.</td>
</tr>
<tr>
<td>Value2</td>
<td>A formula, number, or cell reference for the second value.</td>
</tr>
<tr>
<td>Application</td>
<td>The application ID.</td>
</tr>
</tbody>
</table>

For example, suppose you want to return the percentage change between the October 2002 and October 2003 values of an account for the Tax application. If the account's October 2003 value appears in cell D5 of the worksheet and the account's October 2002 value appears in cell C5, you could use this formula to return the percentage change between the values:

HPPCH(D5,C5,"TAX")

**HPPCONS - Ultimate Percent Consolidated Function**

You use the HPPCONS function to retrieve the ultimate percent consolidated. Use this format:

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent</td>
<td>The parent entity ID.</td>
</tr>
<tr>
<td>Child</td>
<td>The child entity ID.</td>
</tr>
<tr>
<td>Category</td>
<td>The category ID.</td>
</tr>
<tr>
<td>Period</td>
<td>The period ID.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the ultimate percent consolidated.</td>
</tr>
</tbody>
</table>

For example, this formula returns the ultimate percent consolidated for the parent Europe with the child Israel in the Actual category for the period of April 2002 in the Tax application:

```
HPPCONS("EUROPE", "Israel", "ACTUAL", "APR 02", "TAX")
```

**HPPCTRL - Ultimate Percent Control Function**

You use the HPPCTRL function to retrieve the ultimate percent control. Use this format:

```
```

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent</td>
<td>The parent entity ID.</td>
</tr>
<tr>
<td>Child</td>
<td>The child entity ID.</td>
</tr>
<tr>
<td>Category</td>
<td>The category ID.</td>
</tr>
<tr>
<td>Period</td>
<td>The period ID.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the ultimate percent control.</td>
</tr>
</tbody>
</table>

For example, this formula returns the ultimate percent control for the parent Europe with the child Israel in the Actual category for the April 2002 period in the Tax application.

```
HPPCTRL("EUROPE", "Israel", "ACTUAL", "APR 02", "TAX")
```

**HPPOWN - Ultimate Percent Ownership Function**

You use the HPPOWN function to retrieve the ultimate percent ownership. Use this format:

```
```

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Parent</td>
<td>The parent entity ID.</td>
</tr>
<tr>
<td>Child</td>
<td>The child entity ID.</td>
</tr>
<tr>
<td>Category</td>
<td>The category ID.</td>
</tr>
</tbody>
</table>

### Variable | Description
--- | ---
Period | The period ID.
Application | The ID for the application that contains the ultimate percent ownership.

For example, this formula returns the ultimate percent ownership for the parent Europe with the child Israel in the Actual category in the April 2002 period in the Tax application:

`HPPOWN("EUROPE","Israel","ACTUAL","APR 02","TAX")`

### HPPROP - Proportion Data Function

You use the HPPROP function to retrieve proportion data. Use this format:


<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The entity ID.</td>
</tr>
<tr>
<td>Category</td>
<td>The category ID.</td>
</tr>
<tr>
<td>Account</td>
<td>The account ID.</td>
</tr>
<tr>
<td>Period</td>
<td>The period ID.</td>
</tr>
<tr>
<td>Frequency</td>
<td>The frequency ID.</td>
</tr>
<tr>
<td>Parent</td>
<td>The parent entity ID.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the proportional data.</td>
</tr>
</tbody>
</table>

For example, this formula returns the proportion data for the Israel entity in the Actual category for the Cables account for the April 2002 period with a monthly data view for the parent Europe in the Tax application:

`HPPROP("Israel","ACTUAL","CABLES","APR 02","MON","EUROPE","TAX")`

**Note:** The HPPROP function uses the scale of the parent instead of the entity.

### HPSCA - Scale Function

You use the HPSCA function to retrieve the scaling factor for a specified entity, category, and account. The scaling factor is returned as a power of 10. For example, a scale of 3 in Hyperion Enterprise is returned as 100. If the entity has scaling defined, the scaling for the entity is returned. Otherwise, the scaling for the category is returned. If the Scaling option for the account is turned off in the Chart of Accounts window, the HPSCA function returns a value of 1. Use this format:

`HPSCA("Entity","Category","Account","Application")`
<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The entity for which you want to return the scaling factor.</td>
</tr>
<tr>
<td>Category</td>
<td>The category for which you want to return the scaling factor.</td>
</tr>
<tr>
<td>Account</td>
<td>The account for which you want to return the scaling factor.</td>
</tr>
<tr>
<td>Application</td>
<td>The application ID.</td>
</tr>
</tbody>
</table>

For example, this formula returns the scaling factor for the Cables account and the Israel entity in the Budget category for the Tax application:

\[
HPSCA("Israel","BUDGET","CABLES","TAX")
\]

**HPSHAROS - Shares Outstanding Function**

You use the HPSHAROS function to return the total shares outstanding. Use this format:

\[
HPSHAROS("Entity","Category","Period","Application")
\]

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The entity ID.</td>
</tr>
<tr>
<td>Category</td>
<td>The category ID.</td>
</tr>
<tr>
<td>Period</td>
<td>The period ID.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the total shares outstanding.</td>
</tr>
</tbody>
</table>

For example, this formula returns the total shares outstanding for the entity USWEST in the Actual category in the April 2002 period in the Product application:

\[
HPSHAROS("USWEST","ACTUAL","APR 02","PROD")
\]

**HPSHAROW - Shares Owned by Other Entities Function**

You use the HPSHAROW function to return the total shares owned by other entities. Use this format:

\[
HPSHAROW("Entity","Category","Period","Application")
\]

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The entity ID.</td>
</tr>
<tr>
<td>Category</td>
<td>The category ID.</td>
</tr>
<tr>
<td>Period</td>
<td>The period ID.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the total shares owned by other entities.</td>
</tr>
</tbody>
</table>
For example, this formula returns the total shares owned for the entity USWEST in the Actual category in the April 2002 period in the Product application:

\[
\text{HPSHAROW("USWEST", "ACTUAL", "APR 02", "PROD")}
\]

**HPTRAN - Translation Data Function**

You use the HPTRAN function to retrieve translation data. Use this format:

\[
\]

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The entity ID.</td>
</tr>
<tr>
<td>Category</td>
<td>The category ID.</td>
</tr>
<tr>
<td>Account</td>
<td>The account ID.</td>
</tr>
<tr>
<td>Period</td>
<td>The period ID.</td>
</tr>
<tr>
<td>Frequency</td>
<td>The frequency ID.</td>
</tr>
<tr>
<td>Parent</td>
<td>The parent entity ID.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the translation data.</td>
</tr>
</tbody>
</table>

For example, this formula returns the translation data for the Israel entity in the Actual category for the Cables account in the April 2002 period with a monthly data view for the parent Europe in the Tax application:

\[
\text{HPTRAN("Israel", "ACTUAL", "CABLES", "APR 02", "MON", "EUROPE", "TAX")}
\]

**Note:** The HPTRAN function always returns data values even when the currency of the entity and parent are the same and uses the scale of the parent.

**HPVAL - Data Value Function**

You use the HPVAL function to retrieve and show the data value for a specified entity, category, account, period, frequency, and application. You can view values for a category in the frequency assigned to the category or in larger time increments. For example, if the monthly frequency is assigned to the Actual category, you can view quarterly values but not weekly values. Use this format:

\[
\text{HPVAL("Entity","Category","Account","Period","Frequency", "Application")}
\]

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The entity for which you want to return a value.</td>
</tr>
<tr>
<td>Category</td>
<td>The category for which you want to return a value.</td>
</tr>
<tr>
<td>Variable</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>-------------</td>
</tr>
<tr>
<td>Account</td>
<td>The account for which you want to return a value.</td>
</tr>
<tr>
<td>Period</td>
<td>The period for which you want to return a value.</td>
</tr>
<tr>
<td>Frequency</td>
<td>The frequency code for the data you want to return.</td>
</tr>
<tr>
<td>Application</td>
<td>The application ID.</td>
</tr>
</tbody>
</table>

For example, this formula returns the Forecast category's October 2002 value for the Cables account and the Israel entity in the Tax application, with a monthly data view:

\[
\text{HPVAL("Israel","FORCST","CABLES","OCT 02","MON","TAX")}
\]

For more information, see “Period Values in Hyperion Retrieve Functions” on page 209.

You can now set an option for each application to attach logic when executing HPVAL functions. You must set this option when the following conditions are true:

- You use TOT, DTOT, SUB, or DSUB function for a dynamic view account.
- The range that the account totals includes a TOT, DTOT, SUB, or DSUB function for a non-dynamic view account.

In this scenario, do not split your logic between dynamic view accounts and chart logic when using dynamic view accounts. We recommend that you rewrite your logic to ignore this option.

To set the option for a file-based application, use a text editor to add the following line to the application’s INI file, which is located in the application subdirectory:

\[
\text{APP_ATTACH_LOGIC_DVA=1}
\]

**Note:** When you first create an application, this setting is set to 0 (disabled) by default.

**HPVSHAROS - Voting Shares Outstanding Function**

You use the HPVSHAROS function to return the total voting shares outstanding. Use this format:

\[
\text{HPVSHAROS("Entity","Category","Period","Application")}
\]

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The entity ID.</td>
</tr>
<tr>
<td>Category</td>
<td>The category ID.</td>
</tr>
<tr>
<td>Period</td>
<td>The period ID.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the total voting shares outstanding.</td>
</tr>
</tbody>
</table>

For example, this formula returns the total voting shares outstanding for the entity USWEST for the Actual category for the April 2002 period in the Product application:
**HPVSHAROW - Voting Shares Owned by Other Entities Function**

You use the HPVSHAROW function to return the total voting shares owned by other entities. Use this format:

HPVSHAROW("Entity", "Category", "Period", "Application")

<table>
<thead>
<tr>
<th>Variable</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Entity</td>
<td>The entity ID.</td>
</tr>
<tr>
<td>Category</td>
<td>The category ID.</td>
</tr>
<tr>
<td>Period</td>
<td>The period ID.</td>
</tr>
<tr>
<td>Application</td>
<td>The ID for the application that contains the total voting shares owned by other entities.</td>
</tr>
</tbody>
</table>

For example, this formula returns the total voting shares owned for the entity USWEST in the Actual category for the April 2002 period in the Product application:

HPVSHAROW("USWEST", "ACTUAL", "APR 02", "PROD")

**Period Values in Hyperion Retrieve Functions**

There are two methods for specifying the period when you use the HPLNK and HPVAL functions to share data between Hyperion Enterprise and your spreadsheet program. You can type the period ID or the period number. The following sections show examples of the different methods.

**Period ID**

When you type the period ID, be sure to include quotation marks and type a space before the year. This indicates the April 2002 period:

"APR 02"

This indicates the second quarter period in 2002.

"Q2 02"

**Period Number**

When you type the period number, do not use quotation marks. This indicates the fourth period in the specified category:

4
Hyperion Enterprise Documentation

To access Oracle's Hyperion® Enterprise®, Oracle's Hyperion® Enterprise® Reporting, and Oracle Hyperion Financial Data Quality Management, Fusion Edition documentations, for example: PDF or HTML formats, see Oracle’s Technology Network (OTN) site.
Index

A

Account allocation type, 143
Account Description function (HPHEA), 193
account groups
  finding in database, 31
  in database, 30
Account ID function (HPACC), 185
account lists
  in database, 30
  in schedules, 18
accounts
  allocating values in, 143
  finding in database, 31
  finding in schedules, 17
  highlighting in schedules, 21
  in journals, 196
  retrieving default, 199
  retrieving descriptions of, 193, 194
  retrieving differences between, 202–203
  retrieving IDs of, 185
  retrieving type of, 192–195
  scale of, 205
  status in database, 27
  without data, 39
  without data setting to zero, 23
accounts, finding, in Hyperion Enterprise Web, 125
Accumulate option, 42
add-in
  files, 57
adjustments, 94. See also journals
  balanced, 96
  entering, 107
  reviewing in journals, 109
  unbalanced, 96
Affects Future Periods option, 101
allocation sets
  defining, 150
  deleting, 151
  extracting, 153
  posting, 152
  running, 151
  setting up, 150
Allocations. See Hyperion Allocations
allocations
  defining, 147
  deleting, 149
  deleting run information, 152
  Desktop, 144
  desktop color, 146
  extracting, 153
  loading information, 153
  methods, 142
  previewing results, 149
  setting up, 147
  types, 142
allocations in schedules, 20
application error log, in Hyperion Enterprise Web, 133
applications
  changing, 176
  changing default in Hyperion Retrieve, 67
  changing in Hyperion Allocations, 147
testing, 35
arguments for Hyperion Retrieve, 61
ASCII files
  extracting data to, 48
  extracting journals to, 114
  for allocations, 153
  loading data from, 46
  loading journals from, 115
asterisk (*) in schedules, 16, 20
auto-reversed journals, 94
  identifier, 99
  identifier for, 99
  status of, 97
AutoRecalculate option
in database, 39
in schedules, 22

B
B in schedules, 16
balanced journals, 96

C
CALC status, 74
Calculated Account function (HPCAL), 187
calculated accounts
   editing data in, 22
   loading data into, 45
   moving data in, 21
   reporting on, 45
   whether account is, 187
categories
   retrieving default, 199
   retrieving description of, 188
   scale of, 205
Category Description function (HPCDE), 188
category-to-date data view
   journals and, 101
change the Hyperion Enterprise Application, 176
CHANGED status, 74
codes
   for journals, 99
   retrieving, 191
colors
   allocations desktop, 146
   in Hyperion Allocations, 146
consolidated accounts
   editing data in, 22
   moving data in, 21
consolidating data, 78
consolidating dynamic organizations, 80
consolidation
   process of, 71
   retrieving percentage of, 203
   statuses for, 74
consolidation detail
   extracting, 49
   invalid, 41
   reporting on, 40, 81
   storing, 74
   viewing in schedules, 17
consolidation detail, in Hyperion Enterprise Web, 125
consolidation status
   database changes and, 32
Consolidation window, 76
Contribution Data function (HPCONTRIB), 188
contribution detail
   extracting, 49
   reporting on, 40
   retrieving, 188
   viewing, 17
control
   retrieving percent of, 204
credit values, 196
currencies
   retrieving, 189
Currency function (HPCUR), 189
data
   appearance in schedules, 16
   calculating difference, 187
   calculating in schedules, 15, 129
   clearing blocks of, 35
   consolidating, 78
   consolidating, in Hyperion Enterprise Web, 126
   copying in database, 33
   copying in schedules, 22
   defining formats for, 46
   editing, 19
   entering, 19
   entering using Hyperion Retrieve, 200
   entering with operator keys, 19
   entering, in Hyperion Enterprise Web, 130
   erasing, 35
   error file for, 45
   extracting, 48
   filling database with, 35
   formats for, 42
   highlighting blocks of, 21, 32
   loading, 46
   loading with Accumulate option, 42
   loading with Merge option, 44
   loading with Replace option, 43
   moving in database, 33
   moving in schedules, 21
   pasting in database, 34
removing from schedules, 22
retrieving, 207
status of, 27
validating in data load and extract, 51
viewing, in Hyperion Enterprise Web, 128
Data Entry window, 13
data extract
validating records, 51
data formats
defining, 46
overview, 42
data load
Accumulate option, 42
Merge option, 44
Replace option, 43
validating, 51
DATA status, 27, 74
Data Value function (HPVAL), 207
data view
journals and, 101
database
calculating formulas in, 39, 44
filling with data, 35
finding account groups in, 31
finding accounts in, 31
finding periods in, 31
locking periods in, 37
point of view, 29
setting preferences, 28
unlocking periods in, 37
Database window, 26
debit values, 197
decimal places
for journals, 100
Decimal Places option, 56
decimals
in database, 56
in schedules, 24
Default Frequency function (HPFRE), 192
Default ID function (HPKEY), 199
Defaults, 67
Deleted journal status, 98
deleted journals
identifier for, 99
Dependent Consolidation Detail reports
running, 40
Derived Sum function (HPDRV), 190
desktop
LedgerLink, 158
selecting color, 146
Difference function (HPBET), 187
Direct Control function (HPDCTRL), 189
Direct Ownership function (HPDOWN), 190
dynamic organizations
consolidating, 80
E
elimination
retrieving, 191
Elimination Data function (HPELIM), 191
elimination detail
extracting, 49
reporting on, 40
viewing, 17
eliminations
locked data and, 37
entities
allocating values in, 142
currency for, 189
finding in consolidation, 76
in journals, 198
retrieving default, 199
retrieving descriptions of, 192, 193
retrieving IDs of, 200, 201
scale of, 205
selecting in consolidation, 78
shares owned by, 206, 209
storing consolidation detail for, 74
entities, finding, in Hyperion Enterprise Web, 125
entity code
retrieving, 191
Entity Code function (HPECODE), 191
Entity Code option, 86
Entity Description function (HPFUL), 193
entity detail
reporting on, 51
Entity function (HPNAM), 200
entity lists
allocating to, 142
editing in database, 32
viewing in database, 29
environment variable HPAPP.DAT, 58
error log, in Hyperion Enterprise Web, 133
ERROR.LOG file, 45
Excel
  file locations, 59
  pasting Hyperion Retrieve functions, 63
  setting up Hyperion Retrieve and, 57
  starting Hyperion Retrieve, 59
Exception rule, 165
  exception rule, 165
  exporting data. See extracting data
external list
  create, 179
  creating, 179
  update, 179
extracting
  allocation sets, 153
  allocations, 153
  Consolidation detail, 49
  journals, 114
extracting data
  formats for, 48
F
  factor method for allocations, 143
field formats
  verify, 177
file types
  translation, 162
files
  ERROR.LOG, 45
  for journals, 116
First Entity Description function (HPFNA), 192
First Entity ID function (HPNNA), 201
First-level Subaccount Description function
  (HPHS1), 194
First-level Subaccount ID function (HPAS1), 186
flow accounts
  whether account is, 192
Flow function (HPFLW), 192
fonts
  in database, 28
  in Hyperion Allocations, 146
  in schedules, 15, 129
for LedgerLink, 159
formulas
  calculating in database, 28, 39, 44
  calculating in schedules, 22
  displaying in schedules, 15, 129
  in Hyperion Retrieve, 60
frequencies
  retrieving, 192
G
  G/L Template Wizard, 160
Global rule, 165, 166
H
  history report, 117
  HPACC function, 185
  HPAMJ function, 185
  HPAPP.DAT
    environment variables, 58
    HPAPP.DAT file, 58
    HPAS1 function, 186
    HPAS2 function, 186
    HPBET function, 187
    HPCAL function, 187
    HPCDE function, 188
    HPCONTRIB function, 188
    HPCUR function, 189
    HPDCTRL function, 189
    HPDOWN function, 190
    HPDRV function, 190
    HPECODE function, 191
    HPELIM function, 191
    HPFLW function, 192
    HPFIN function, 192
    HPFSN function, 193
    HPFRE function, 192
    HPFUL function, 193
    HPHEA function, 193
    HPHMJ function, 194
    HPHS1 function, 194
    HPHS2 function, 195
    HPINC function, 195
    HPINP function, 195
    HPJAC function, 196
    HPJCR function, 196
    HPJDB function, 197
    HPJDS function, 197
    HPJEN function, 198
    HPJNO function, 198
    HPJST function, 199
    HPKEY function, 199
    HPLNK function, 200
HPNAM function, 200
HPNNA function, 201
HPNSN function, 201
HPPARADJ function, 202
HPPBE function, 202
HPPCH function, 203
HPPCONS function, 203
HPPCTRL function, 204
HPPOWN function, 204
HPPROP function, 205
HPSCA function, 205
HPSHARES function, 206
HPSHAREW function, 206
HPVAL function, 207
HPTRAN function, 207
HPVSHARES function, 208
HPVSHAREW function, 209
Hyperion Allocations
  desktop, 144
  overview, 141
  starting, 145
Hyperion Retrieve
  arguments, 61
    Display No Data as Zero option, 60
    formulas, 60
    functions, 61
    overview, 57
    pasting functions in Excel, 63
    setting up, 57
    starting for Excel, 59
    worksheets, 64
Hyperion Retrieve add-in file locations, 59
input accounts, 195
intercompany. See elimination
intercompany matching
  reporting on, 83–91
intercompany matching reports
  case studies, 89
  running, 88
journal
  identifier for, 99
Journal Account function (HPJAC), 196
Journal Credit Value function (HPJCR), 196
Journal Debit Value function (HPJDB), 197
Journal Description function (HPJDS), 197
Journal Entity function (HPJEN), 198
journal ID, 98
journal locked status, 27
Journal Number function (HPJNO), 198
journal status
  auto-reversed, 97
Journal Status function (HPJST), 199
journal templates
  creating, 106
  editing, 113
journals, 95. See also parent adjustments
  balanced, 96
  codes for, 99
  creating, 106
  creating templates for, 106
  creating using recurring templates, 108
  credit values in, 196
  data view and, 101
  debit values in, 197
  defined, 93
  deleting, 105
  editing, 113
  entering detail for, 107
  entities in, 198
  extracting, 114
  file formats for, 116
  for parent entities, 95
  future periods, 101
  loading, 115
  locked status, 27
  locking in database, 110
  numbering, 98

I
icons
  for previewing allocations, 154
  in Hyperion Allocations, 147
  in Results View window, 169
  in Translation Builder window, 170
IMPACTED status, 74
imported translation file rules, 167
importing data. See loading data
INACTIVE status, 75
Income Account function (HPINC), 195
income accounts
  whether accounts is, 195
Input Account function (HPINP), 195
posting, 110–112
posting to missing data, 102
process of, 105
repeating, 96
retrieving account in, 196
retrieving descriptions of, 197
retrieving number of, 198
reversing, 113
reviewing, 109
statuses, 97
statuses of, 199
templates for, 95
types of, 94–95
unbalanced, 96
unlocking in database, 110
unposting, 112
viewing information about, 100
journals report, 117
Journals window, 104

K
K in schedules, 16

L
labels
  selecting in Hyperion Retrieve, 66
Language
  of Hyperion Allocations, 146
LedgerLink
  starting, 175
Link Data Value function (HPLNK), 200
load data into Hyperion Enterprise, 183
Load Error File option, 45
Load panel, 173
load profiles, 171
defining, 182
Load to Hyperion Enterprise, 175
loading data, 46
  formats for, 42
loading journals, 115
locked data
  extracting, 48
Locked journal status, 97
locked journals
  identifier for, 99
Locked status, 27, 75
locking data, 37
  effects of, 21, 22
locking journals, 110

M
M in schedules, 16
Major Account Description function (HPHMJ), 194
Major Account ID function (HPAMJ), 185
Merge option, 44
Microsoft Excel, 57
minus sign (-) in schedules, 20

N
Name allocation type, 142
NODATA status, 27, 74
numbering journals, 98
numbers. See data

O
OK status, 74
operator keys, 19
options
  Entity Code, 86
ownership
  retrieving, 190
  retrieving percent of, 204

P
Parent Adjustment Data function (HPPARADJ), 202
parent adjustment detail
  viewing, 17
parent adjustments
  extracting, 49
  reporting on, 40
  retrieving, 202
parent journals, 95
  identifier, 99
parents
  adjustments to, 95
percent control
  retrieving, 189
Percent method for allocations, 143
percent sign (%) in schedules, 20
Percentage Change function (HPPCH), 203
Percentage Difference function (HPPBE), 202
periodic data view
  journals and, 101
periods
  allocations among, 143
  finding in consolidation, 77
  finding in database, 31
  finding in schedules, 17
  highlighting in schedules, 21
  locking in database, 37
  opening in journals, 105
  retrieving default, 199
  retrieving differences between, 203
  selecting in consolidation, 78
  status, 27
  unlocking in database, 37
plus sign (+) in schedules, 19
point of view
  in database, 29
  in Hyperion Allocations, 147
  in the Data Entry window, 16
  retrieving, 199
Posted and Edited journal status, 97
posted and edited journals
  identifier for, 99
Posted journal status, 97
posted journals
  identifier, 99
posting
  allocation sets, 152
  posting journals, 110–112
  data view and, 101
POV, in Hyperion Enterprise Web, 122
previewing
  allocation reports, 154
  previewing of allocation results, 149
  printing allocation reports, 154
profiles
  load, 171
  translate, 171
program files, 57
Proportion Data function (HPPROP), 205
proportion detail
  reporting on, 40
  retrieving, 205
  viewing, 17
Q
  Q in schedules, 16
  question mark (?) in schedules, 20
R
  Range rule, 165, 166
  recurring templates, 96
    creating journals from, 108
    identifier, 99
  regular journals, 94
    identifier, 99
  Replace option, 43
  report format
    specify, 178
  reports
    Consolidation Detail, 81
    for allocations, 154
    Intercompany Matching, 83
    journals, 117
    journals history, 117
    trial balance, 118
  results
    view translation, 180
    retrieving, 206, 209
  Reversed journal status, 97
  reversed journals
    identifier, 99
  reversing journals, 113
  Reviewed journal status, 97
  reviewed journals
    identifier, 99
  rounding
    in schedules, 16
  Rules
    imported translation file, 167
    Rules translation, 165
S
  sample file
    select a source, 161
  sample files, 159
  sample record
    select, 176
  scale
    extracting data and, 49
    retrieving, 205
Index

A B C D E F G H I J K L M N O P Q R S T U V W Y Z

Scale function (HPSCA), 205
schedules
defining, 18
deleting, 17
displaying large values in, 16
operator keys in, 19
point of view, 16
setting preferences for, 15, 129
setting up, 17
truncated data in, 16
Second-level Subaccount Description function (HPHS2), 195
Second-level Subaccount ID function (HPAS2), 186
security classes
extracting data and, 48
Set information
loading, 153
shares, 206, 209
retrieving, 206, 208
Shares Outstanding function (HPSHAROS), 206
Shares Owned by Other Entities function (HPSHAREOW), 206
slash (/) in schedules, 20
source sample file
select, 161
standard templates, 95
identifier, 99
status
for journals, 97
in database, 27
statuses
in consolidation, 74
of journals, 199
subaccounts
allocating to, 143
not displaying, 18
retrieving descriptions of, 194, 195
retrieving IDs for, 186
subaccounts in schedules, 18
subentities
retrieving descriptions of, 193
retrieving IDs of, 201
Subentity Description function (HPFSN), 193
Subentity ID function (HPNSN), 201

T
task status, in Hyperion Enterprise Web, 127
Template Wizard, 160
templates, 106. See also journal templates
balancing, 96
configure, 177
for journals, 95
unbalanced, 96
testing applications, 35
time allocation type, 143
toolbars. See icons
Total method for allocations, 144
Translate / Load Profile Dialog Box, 172
Translate / Load Profiles list box, 171
Translate panel, 172
Translate profiles, 171
Translation builder, 162, 163
Translation Data function (HPTRAN), 207
translation detail
extracting, 49
reporting on, 40
retrieving, 207
viewing, 17
Translation file types, 162
translation files
importing, 181
translation profiles
defining, 181
translation results
viewing, 180
Translation rules, 165
setting up, 179
Trial Balance report, 118
truncating data in schedules, 16

U
Ultimate Percent Consolidated function (HPPCONS), 203
Ultimate Percent Control function (HPPCTRL), 204
Ultimate Percent Ownership function (HPPOWN), 204
unbalanced journals, 96
unlocking data, 37
unlocking journals, 110
unposted journals
identifier, 99
Unposted journals status, 97
unposting journals, 112
Update external list, 179

V
validated subaccounts
adding to schedules, 18
Value method for allocations, 143
values. See data
Verify field formats, 177
voting shares
retrieving, 189, 208, 209
Voting Shares Outstanding function (HPVSHAROS),
208
Voting Shares Owned by Other Entities function
(HPVSHAROW), 209

W
Hyperion Enterprise Web. See Web, Hyperion
Enterprise
Web, Hyperion Enterprise
accounts, finding, 125
consolidation detail, 125
data
consolidation, 126
entering, 130
viewing, 128
entities, finding, 125
error log, 133
POV, 122
task status, 127
using, 121
wildcards
in LedgerLink, 166
windows
Consolidation, 76
Data Entry, 13
Database, 26
Journals, 104
worksheets
Hyperion Retrieve, 64
refreshing in Hyperion Retrieve, 67

Y
year-to-date data view
journals and, 101

Z
Zero No Data Load option, 45
zero values
setting up, 39