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Preface

This guide describes the RPAS user interface. It provides step-by-step instructions to 
complete most tasks that can be performed through the user interface.

Audience
This guide describes the Retail Predictive Application Server Fusion Client user 
interface. It provides step-by-step instructions to complete most tasks that can be 
performed through the user interface.

Documentation Accessibility
Our goal is to make Oracle products, services, and supporting documentation 
accessible to all users, including users that are disabled. To that end, our 
documentation includes features that make information available to users of assistive 
technology. This documentation is available in HTML format, and contains markup to 
facilitate access by the disabled community. Accessibility standards will continue to 
evolve over time, and Oracle is actively engaged with other market-leading 
technology vendors to address technical obstacles so that our documentation can be 
accessible to all of our customers. For more information, visit the Oracle Accessibility 
Program Web site at http://www.oracle.com/accessibility/.

Accessibility of Code Examples in Documentation
Screen readers may not always correctly read the code examples in this document. The 
conventions for writing code require that closing braces should appear on an 
otherwise empty line; however, some screen readers may not always read a line of text 
that consists solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation
This documentation may contain links to Web sites of other companies or 
organizations that Oracle does not own or control. Oracle neither evaluates nor makes 
any representations regarding the accessibility of these Web sites.

Access to Oracle Support
Oracle customers have access to electronic support through My Oracle Support. For 
information, visit http://www.oracle.com/support/contact.html or visit 
http://www.oracle.com/accessibility/support.html if you are hearing 
impaired.
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1
Getting Started 

Welcome to Oracle Retail RPAS Fusion Client. This chapter provides an overview of 
the application and includes information that help you get started with the 
application. It includes the following sections:

■ Overview

■ Basic Concepts of RPAS

■ Terminology Differences Between Clients

■ Setting Up Your Browser

■ Logging on to the Fusion Client

■ Opening a Workbook

■ Creating a New Workbook

■ Deleting a Workbook

■ Renaming a Workbook

■ Understanding the Workbook Wizard Window

■ Accessing Online Help

■ Changing Your Password

■ Logging Out of the Application

Overview
The RPAS Fusion Client is a Web-based rich client for the Retail Predictive Application 
Server (RPAS) platform developed using the latest Oracle Application Development 
Framework (ADF). 

Planning is one of the most important and complex processes in a retail business. It 
typically involves a complex set of activities that need to be followed as part of a 
workflow. Unlike the RPAS Windows-based Classic Client, the Fusion Client includes 
a taskflow feature that provides a robust workflow capability to make each planning 
activity easier to track and maintain.

The Fusion Client uses the same RPAS server as the RPAS Windows-based Classic 
Client. In addition to the enhanced user experience, the Fusion Client provides access 
to a larger number of users and a greater degree of platform independence.
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Where Does the RPAS Fusion Client Fit in an Retail Enterprise
The RPAS platform and Fusion Client form part of the Merchandising Planning and 
Optimization solutions. The illustration below shows an example of a retail enterprise 
with the Fusion Client application implemented with the RPAS server hosting an 
RPAS application. It provides a high level overview of where the Fusion Client 
application fits in a typical retail enterprise.

Figure 1–1 RPAS Fusion Client in a Retail Enterprise

Basic Concepts of RPAS
Retail Predictive Application Server (RPAS) is a configurable platform with a proven 
scalability for developing multidimensional forecasting and planning based solutions. 
This platform provides capabilities such as a multidimensional database structure, 
batch and online processing, a configurable slice-and-dice user interface, a 
sophisticated configurable calculation engine, user security and utility functions such 
as importing and exporting, all on a highly scalable technical environment that can be 
deployed on a variety of hardware. 

This section introduces you to the following RPAS concepts:

■ Multidimensionality

■ Dimensions

■ Measures

■ Domains and Workbooks
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Multidimensionality
In RPAS, information is stored and represented based on the multidimensional 
framework. In a multidimensional database system, data is presented as a 
multidimensional array, where each individual data value is contained within a cell 
accessible by multiple indexes. 

Multidimensional database systems are a complementary technology to entity 
relational systems and achieve performance levels above the relational database 
systems. Applications that run on RPAS identify data through dimensional 
relationships. Dimensions are qualities of an item (such as a product, location, or time) 
or components of a dimension that define the structure and roll up within the 
dimension.

Dimensions
Dimensions describe the top-to-bottom relationship between the levels or positions of 
the dimensions in RPAS. They reflect the dimensions set up at your business and being 
used by the merchandising solutions.

RPAS supports many alternative dimensions that provide different roll ups and help 
analyze the data from a different perspective.

Measures
Measures represent the events or measurements that are recorded, while the positions 
in the dimensions provide a context for the measurement. Measures are defined based 
on the business rules set in the application. The dimensionality of a measure is 
configured through the definition of its base intersection, which is the collection of 
levels (one per appropriate dimension) defining the lowest level at which the 
information is stored for the measure.

Measure names are completely configurable and typically named using a convention 
that identifies each component and the meaning of the measure.

Domains and Workbooks
RPAS stores information in a persistent multidimensional data cache that is optimized 
for large volumes and dimensional or time series data access requirements, typically 
required by multidimensional solutions. This central repository is called a domain. 
The domain also includes central definitions of metadata for the solution and provides 
a single update point.

When you use an RPAS solution, you interact with the solution through a personal 
data repository called a workbook. A workbook contains the subset of the data (and 
metadata) from the domain and its scope is constrained by the access rights available 
to a user. Workbooks are stored on the RPAS server, and can be built using an online 
wizard process or scheduled to be built in a batch process automatically.

Although the data and metadata in the workbook are copied from the domain, the 
data remains independent of the domain. 
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Terminology Differences Between Clients
There are some key terminology differences between the Fusion Client and Classic 
Client. Understanding these differences is useful if you are moving from the Classic 
Client or if you have used the Classic Client before using the Fusion Client. The 
following table describes the differences.

Setting Up Your Browser
The Fusion Client can be accessed using Microsoft Internet Explorer, Google Chrome, 
or Mozilla Firefox. Before you access the application for the first time, you should set 
the following browser settings to allow seamless and error free access:

■ Cache Settings

■ Security Settings for Internet Explorer

Based on the zone where the application is installed, you may configure your browser 
settings for Local intranet or as a Trusted sites zone.

Cache Settings
Before starting the Fusion Client, set up the browser’s cache so that temporary internet 
files are deleted every time you visit a webpage. The cache settings are typically found 
in the browser’s tool menu.

Table 1–1  Terminology in the Fusion Client and Classic Client

Fusion Client Term Term Description
Classic Client 
Term

Dimension Grouping of a particular type of information. 
Typical dimensions are for products, locations, 
time, and measures. For instance, a Product 
dimension could contain information about 
items, item groups, departments, and divisions.

Hierarchy

Level A subdivision of a dimension. Levels group 
information of the same type. For instance, a 
level within the Product dimension could be 
Department. The Department level would 
contain all the departments (men’s shoes, 
women’s shoes, children’s shoes) that exist.

Dimension

View Multidimensional spreadsheets that are used to 
display information from the workbook. 
Workbooks can include one view or multiple 
views, which can present data in the form of 
numbers in a grid. These numeric data values 
can easily be converted to a graphical chart. 
Data can be viewed at a very high level of 
detail, or data values can be quickly aggregated 
and viewed at summary levels.

You can display the information in a view in a 
variety of formats, generally by rotating, 
changing the data rollup, showing and hiding 
measures, and drilling up or down.

Worksheet

Important: Do not select Internet unless you have been instructed to do so 
by the administrator. In most cases, the application is available on your 
company's intranet (Local intranet) or on an Oracle trusted site (Trusted 
sites).
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Security Settings for Internet Explorer
If using Internet Explorer, you should configure the browser security settings to 
improve the user experience. 

To set the security settings, perform the following steps:

1. Start Internet Explorer.

2. From the Tools menu, click Internet Options.

3. On the Security tab, click Local intranet, and then click Sites.

Figure 1–2 Internet Options - Security Tab 

4. On the Local intranet window, click Advanced.

5. In the Add this website to the zone field, enter the application URL, click Add, 
and then click Close.

Figure 1–3 Local Intranet Window - Add Website to the Zone

6. On the Local intranet window, click OK.
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7. In the Security level for this zone area, click Custom level....

Figure 1–4 Security Settings - Local Intranet Zone Window

8. In the Security Settings - Local Intranet Zone window, select the Prompt or 
Enable option for the following parameters:

Table 1–2  Parameters in the Security Settings Window

Category Parameter Name

ActiveX controls and plug-ins

Download signed ActiveX controls

Initialize and script ActiveX controls not marked as safe for 
scripting

Run ActiveX controls and plug-ins

Downloads

File download

For additional security settings for exporting views, see Export. 

Miscellaneous

Allow websites to open without address or status bars

Scripting

Active scripting

Note: For more information on the Prompt and Enable options, see About 
Prompt and Enable Options.
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9. After you set up these parameters, click OK. A message appears that prompts you 
for a confirmation on the changes to the settings for the zone.

10. Click Yes to accept the changes. Based on the settings you changed, you may need 
to restart the Internet Explorer for the changes to take effect.

About Prompt and Enable Options
The Prompt option provides a confirmation message box each time a specific action 
(for example, Download signed ActiveX controls) occurs on the Web browser. The 
browser grants access to the actions, based on your response.

The Enable setting provides a direct access to the specified action without any 
notification.

You may select the Prompt option for the download options because the downloads 
typically occur one time. For the running and scripting actions, since they occur 
frequently, you may select the Enable option. In case you select the Prompt option, 
you may have to respond to a message box several times in an application session.

Logging on to the Fusion Client
Before you log into the Fusion Client, ensure that your system meets the 
recommended configuration. For more information, see the RPAS Installation Guide.

Once you check the configuration, obtain the following information:

■ Uniform Resource Locator, URL – Enter the URL or the Web address of the 
application in the Web browser to access the application. For example:

http://<fullyqualifieddomainname>:<port>/rpas

■ User name, Password, and Profile Name – Based on the tasks you want to 
perform, obtain a user account (that includes user name and password) to log on 
to the application.
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To log in to the Fusion Client:

1. Start Internet Explorer.

2. In the Address bar, enter the Fusion Client URL, and press Enter. The Fusion 
Client Login page appears.

Figure 1–5 Fusion Client Login Page

3. On the Login page, enter the username and password, and select the relevant 
profile in the Profile drop-down list.

Note: Profiles are the RPAS solution domains you want to connect 
to. Profiles can be created during the installation process. After 
installation, you can manually create additional profiles in the 
ProfileList.xml file. For more information, see the RPAS Administration 
Guide for the Fusion Client.
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If you have accessed the RPAS Fusion Client through a single sign-on environment 
such as the Oracle Retail Workspace portal, then only the profile field appears on 
the Fusion Client login page. Select the profile you want to access from the 
drop-down list.

Figure 1–6 Fusion Client Login Page, Accessed Through SSO

4. Click Login. The window refreshes, and the homepage of the RPAS Fusion Client 
is shown.

Figure 1–7 RPAS Fusion Client Homepage

Note: For more information about single sign-on (SSO), see the RPAS 
Administration Guide.
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Concurrent Sessions
If you already have a user session of the Fusion Client running in a domain, you can 
start a second or concurrent session at the same time. When logging into the Fusion 
Client, if you have a concurrent session running, the following message appears:

Figure 1–8 Concurrent Session Message

Select one of the following options:

■ Terminate all existing sessions and create a new session: This option closes any 
existing connections for the user in that domain.

■ Start a concurrent session: This option allows the user to have multiple 
connections within the domain. This does not affect any prior user connections to 
the domain.

Note: For information about the number of allowed concurrent 
sessions, see the "System Administration" chapter of the RPAS 
Administration Guide for the Fusion Client.
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Multiple Sessions
To have multiple sessions means that you have more than one Fusion Client session 
connected to an RPAS domain, whether the connection is to the same domain or the 
same username. 

The supported browsers handle multiple sessions differently. Table 1–3 describes the 
multiple session handling of each browser.

Table 1–3  Browser Multiple Session Handling

Browser Multiple Session Handling

Internet Explorer Use separate windows, rather than separate tabs.

Note: For Internet Explorer 8, special setup is required for multiple 
sessions to function properly:

Option 1: From the Internet Explorer File menu, select the New Session 
option. 

Option 2: Update the Internet Explorer shortcut to include the following 
command line switch :

"C:\Program Files\Internet Explorer\iexplore.exe"
-noframemerging

Use this shortcut every time. 

Option 3: Create a registry string called FrameMerging:

1. From the Start menu, click Run.

2. In the Run dialog box, type regedit in the Open field and click OK.

3. Navigate to 

HKEY_CURRENT_USER\Software\Microsoft\Internet 
Explorer\Main\

4. Right-click the Main key and select New > String Value. 

5. A new string value appears. Name it FrameMerging.

6. Right-click the FrameMerging registry string and select Modify 
from the right-click menu.

7. Enter 0 in the Value data field and click OK. 

Firefox Create a program shortcut with the following target:

"C:\Program Files\Mozilla Firefox\firefox.exe"
-no -remote -p random

Use this shortcut every time. The shortcut launches Firefox with a 
random profile. Since this profile does not exist, the profile manager 
dialog appears. When invoking this shortcut for the first time, create a 
profile for each concurrent session you need. 

After the first use, you can select the desired profile and create the 
Fusion Client session. Each profile has a different session. Ensure that 
you do not create a profile called "random."

Chrome Create a Fusion Client session from one Chrome window. To create 
another session, click the wrench icon and then select the New 
incognito window menu option. This launches a new Chrome window. 
In this new window, create a new Fusion Client session. 

This method has a limitation: you can create only one incognito window 
session. Multiple incognito windows merely share the same session.
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Opening a Workbook
After you log on to the application, a taskflow appears that enables you to navigate 
through the activities and tasks associated with your user account.

To open a workbook:

1. In the taskflow, click the Show List of Workbooks icon next to the task/step you 
want. For more information on the taskflow, see the Taskflow section.

Figure 1–9 Show List of Workbooks Icon

The Open Workbook window appears.

Figure 1–10 Open Workbook Window

2. Select the workbook you want, and click Open Workbook.
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Understanding the Open Workbook Window
The following figure highlights the various components of the Open Workbook dialog:

Figure 1–11 Open Workbook Window User Interface Components

The following table describes the screen components of the Open Workbook window:

Table 1–4  Open Workbook Window User Interface Components

Legend Screen Area Name Position Description

A View menu Top Left The View menu enables you to view all the 
workbooks that you own. It also provides 
you the option to show or hide any column 
in the workbooks grid.

B Rename icon Top Left Enables you to rename a workbook. 

C Delete icon Top Left Enables you to delete a workbook. For more 
information, see Deleting a Workbook.

D Find field, Previous  
and Next arrows

Top Center Enables you to identify the workbooks with 
the keywords you entered in the Find field. 

Use the Previous and Next arrows to 
navigate between the workbooks matching 
the search pattern. The search is not 
case-sensitive.

E Workbooks grid Center Displays the list of workbooks in the current 
profile. By default, only the workbooks that 
you own appear.

To view all the workbooks, under the View 
menu, click All.

F Cancel icon Bottom Right Enables you to cancel an action and exit the 
Open Workbook window.

G Open Workbook 
icon

Bottom Right After you select the workbook you want, 
click this icon to open the workbook. 

Note: you can open only one workbook at a 
time.
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Creating a New Workbook
The new workbook wizard enables you to create workbooks based on the templates 
set up during the implementation as well as RPAS administration templates. These 
templates typically represent a high level business activity in your organization.

Based on the configuration, each template in the RPAS domain may include many 
measures at different intersections. Each workbook template is associated with one of 
the following wizards that help you filter and include the relevant information for the 
workbook:

■ Standard Two Tree Wizard is a set of similar looking two tree pages that help select 
positions in different dimensions.

■ Custom Wizard offers flexibility to the configuration personnel to provide a 
custom set of pages for choosing positions.

The wizards are set up and associated with the workbook template using the RPAS 
Configuration tool.

To create a new workbook:

1. In the taskflow, click the Create New Workbook icon next to the task/step you 
want. For more information on the taskflow, see the Taskflow section.

Figure 1–12 Create New Workbook Icon
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2. Based on the configuration of the workbook template, an associated wizard 
appears. The wizard provides you with positions that help you filter and include 
the relevant information in the workbook.

Figure 1–13 Workbook Wizard

3. In the Available Items area, select the positions you want by holding down the 
Ctrl or Shift keys, and click Add. You can click Add All to select all the positions.

Or, drag and drop the positions to the Selected Items area.

4. Follow the instructions in the wizard, and once you have selected the positions 
you want, click Finish.

Deleting a Workbook
From the list of workbooks, you can delete any workbook you have write access to. To 
delete a workbook:

1. On the Open Workbook window, select the workbook you want. 

To delete more than one workbook, hold the Ctrl key and select the workbooks 
you want to delete. Or, you can hold Shift and select a group of workbooks.

2. Click Delete. A warning message appears.

Figure 1–14 Delete Warning Message

3. Review the warning message, and then click Delete to delete the workbooks or 
click Cancel to cancel this operation.
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Renaming a Workbook
The open workbook dialog box enables you to rename existing workbooks without 
affecting the data within the workbook or the other workbook information such as the 
created date, modified date, formatting information and so on. 

There are a few key points to know about renaming workbooks:

■ You can only rename workbooks that you have write access to.

■ Workbook names can be no more than 32 characters

■ Workbook names cannot contain double or single quotation marks.

■ Workbooks cannot be named "Untitled." This name is reserved.

To rename a workbook in the open workbook dialog box, perform the following steps.

1. Select the workbook you want to rename from the list. When selected, it becomes 
shaded, as shown in Renaming a Workbook.

2. Click Rename.

Figure 1–15 Renaming a Workbook

3. The Rename Workbook dialog box appears. Enter the new name of the workbook 
and click OK.

Figure 1–16 Rename Workbook Dialog Box
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4. The renamed workbook appears in the workbook list.

Figure 1–17 Renamed Workbook

You can also rename a workbook from the File menu. For more information about this 
option, see Renaming Workbooks.
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Understanding the Workbook Wizard Window
The following figure highlights the various components of the workbook wizard:

Figure 1–18 Workbook Wizard

The following table describes the screen components of the workbook wizard window:

Table 1–5  Workbook Wizard Window User Interface Components

Legend
Screen Area 
Name Position Description

A Available Items 
area

Center Left Displays the positions that are available for you 
to select. 

B View menu Center Left, 
within the 
Available Items 
area 

Provides options for viewing the available 
positions. You can adjust the column setting, 
detach the list to view it in a larger window, 
expand or collapse the positions, or scroll to the 
beginning or end of the list. 

C Dimension 
menu

Center Left, 
within the 
Available Items 
area 

Opens the Dimension options window where 
you can select the levels of the dimension you 
want to view in the Available Items list. You 
can also select the attributes that you would 
like to see and sort by in the list.
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D Find field, 
Previous  
and Next 
arrows

Center Left, 
within the 
Available Items 
area 

Enables you to identify the positions with the 
keywords you entered in the Find field. 

Use the Previous and Next arrows to navigate 
between the workbooks matching the search 
pattern. The search is not case-sensitive.

E Detach Left corner of 
the Available 
Items and 
Selected Items 
areas

Enables you to view the list of positions in a 
larger window.

F Wizard 
Taskflow

Top Center Displays the steps in the wizard process and 
shows you where you are within that process.

The wizard taskflow is configured in the RPAS 
Configuration Tools. For more information, see 
the RPAS Configuration Tools User Guide.

G Selected Items 
area

Center Right Displays the positions you selected. It also 
includes a toolbar that enables you to perform 
various functions. 

H Load Favorite 
icon

Center Right, 
within the 
Selected Items 
area

Enables you to select a previously saved group 
of positions to load into the workbook. 

For more information, see Saving and Loading 
Favorites.

I Save Favorite 
icon

Center Right, 
within the 
Selected Items 
area

Enables you to save the positions you have 
selected as group. The next time you build a 
new workbook, you can select and load that 
group rather than choosing the same positions 
individually again. 

For more information, see Saving and Loading 
Favorites.

J Add and Add 
All icons

Center Enables you to add positions that are selected 
in the Available Items area.

To add all positions in the Available Items area, 
click the Add All icon.

K Remove and 
Remove All 
icons

Center Enables you to remove positions in the Selected 
Items area.

To remove all positions in the Selected Items 
area, click the Remove All icon.

L Wizard 
Navigation icon

Bottom Right Enables you to navigate from one wizard page 
to another. Once you have made the selections 
for the workbook and clicked Finish, the 
workbook builds with the selected positions.

M Synchronize 
Hierarchies 
check box

Bottom Left When selected, the shown levels within the 
Selected Items area match the ones in the 
Available Items area. This is selected by default.

Table 1–5 (Cont.) Workbook Wizard Window User Interface Components

Legend
Screen Area 
Name Position Description
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Saving and Loading Favorites
Once you have selected the positions that you want to appear in the workbook you are 
building, you can save that collection of positions for future use by using the Save 
Favorite and Load Favorite features. You can save the collection of positions for each 
dimension presented in the workbook wizard.

Saving Favorites
To save the selected positions as a favorite, perform the following:

1. Once you have moved the positions to the Selected Items area, click the Save 
Favorite icon or select Save Favorites from the View menu. See Figure 1–19.

Figure 1–19 Save and Load Favorites Icons

2. The Save Favorites window appears. Enter the name of the favorite in the Label 
field. In the Access field, choose one of the following: 

■ User: This option makes the favorite available to only the user who created it.

■ World: This option makes the favorite available to all users.

Note that previously saved favorites are listed in the table.

Figure 1–20 Save Favorites Window

3. When finished, click Save. If you would like to abandon the changes, click Cancel.
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Saving Calendar Positions as Favorites
When saving positions in the Calendar dimension, you have the option to use a 
relative calendar rather than the predefined time periods that are shown in the wizard. 
This enables you to use a range of time periods that are relative to the current date. As 
time passes, the calendar favorite updates the range of time to be in relation to the new 
date.

Figure 1–21 Save Favorites – Calendar Dimension

The length of the time periods is determined by the lowest level of the Calendar 
dimension presented in the wizard. For instance, if the lowest level in the wizard is 
Week, then when you select the time range in the relative calendar option, you choose 
the number of weeks to include. 

To use the relative calendar feature, perform the following:

1. In the calendar step of the workbook wizard, click the Save Favorite icon. You do 
not need to move a position to the Selected Items list. 

2. In the Save Favorites window, enter the name in the Label field and select the 
access level in the Access field.

3. At the bottom of the window, select the Use Relative Calendar option.

4. In the Start field, enter the number or use the arrows to choose the number of time 
periods in relation to today’s date for the start period. For instance, if the 
workbook’s lowest calendar level is week and you want the time period to begin 2 
weeks in the past from today’s date, you would enter -2. If you wanted it to begin 
2 weeks in the future, you would enter 2. 

5. In the End field, enter the number of weeks in relation to today’s date that you 
want the time period to end. 

6. When finished, click Save.
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Editing Favorites
To change or update a favorite, perform the following:

1. Move the updated set of positions to the Selected Items area. 

2. Click the Save Favorite icon or select Save Favorites from the View menu.

3. In the Save Favorites window, select the favorite that you want to edit from the 
list.

4. Update the Access level if necessary.

5. Click Save. The favorite now includes the new set of positions.

Loading Favorites
Once you have saved a favorite, you can load it into to the workbook wizard. Loading 
favorites into the wizard rather than selecting individual positions from the wizard 
every time you create a workbook will save you time.

To load a favorite, perform the following:

1. In the workbook wizard, click the Load Favorite icon. 

2. The Load Favorites window appears. Click the favorite you want to load. The 
Load Favorites window automatically closes.

Figure 1–22 Load Favorites Window

3. In the workbook wizard, the positions from the favorite now appear in the 
Selected Items area.

Deleting Favorites
To delete a favorite, perform the following steps:

1. Click the Save Favorite icon or select Save Favorites from the View menu. 

2. Select the favorite you want to delete from the list.

3. Click Delete. The favorite is deleted and no longer appears in the list. 
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Accessing Online Help
To access online help, click Help in the global header.

Figure 1–23 Online Help Link

The online help appears in a new browser window. If more than one help set is 
available, you can choose which one to view by selecting it from the Book drop-down 
field. If there is only one help set, the field is shaded.

Figure 1–24 Online Help Window, Book Field

Contents 
The contents of the online help set are shown in the Contents section of the navigation 
bar on the left. Click the Expand icon next to the folders to drill down to the help 
topics. Click the page you want to view. It appears in the content area. 

Figure 1–25 Help Topic within Online Help
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Figures and Tables
To view a list of figures or tables, click the Figures or Tables bar.

Figure 1–26 Online Help: Figure List

Index
In the Index, you can enter keywords to find topics that contain this keyword. Click 
the topic name to see the page.

Figure 1–27 Online Help: Index
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Search
Use the Search field at the top of the online help window or the Search section within 
the navigation bar to search for words or phrases.

Figure 1–28 Online Help: Search

Changing Your Password
Use the following instructions to change your password. Note that users may be 
prompted to change their password when logging in for the first time.

1. To change your password, click Change password in the global header.

Figure 1–29 Change Password Link
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2. In the Change password window, enter your current password and then enter and 
verify the new password.

Figure 1–30 Change Password Window

3. When finished, click OK.

Locating the Version Number
To find out the version of RPAS Fusion Client and server, click the About link in the 
global header. 

Figure 1–31 About Link

The About Oracle RPAS Fusion Client dialog box appears, displaying client and server 
versions.

Figure 1–32 About Oracle RPAS Fusion Client Dialog Box

Logging Out of the Application
To log out of the application, click Logout in the global toolbar.

Figure 1–33 Logout Link

Note: You may be prompted to save and commit the workbook data 
before logging out of the application.
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2
Understanding the User Interface

This chapter introduces you to the workbook user interface and describes the 
following screen components:

■ Quick Access Toolbar

■ Taskflow

■ Contents Area

Figure 2–1 highlights the various components of the workbook user interface:

Figure 2–1 Workbook User Interface

Table 2–1 describes the user interface components in the workbook user interface:

Table 2–1  Workbook User Interface Screen Components

Screen Component Description

Global Header Displayed at the top of the screen, this area appears across all 
the business applications and custom pages. It includes the 
application branding and links for the Home page, About 
window, Online Help, changing a password, and logging out of 
the application.
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Quick Access Toolbar

Quick Access Toolbar
The following figure highlights the various components on the Quick Access toolbar:

Figure 2–2 Quick Access Toolbar Components

The following table describes the quick access toolbar components highlighted in Figure 2–2:

Quick Access Toolbar Displayed below the global header, the quick access toolbar 
includes the menus and icons that will enable you to perform 
various actions in the workbook. For more information, see 
Quick Access Toolbar.

Taskflow Displayed on the left of the screen, the taskflow provides a 
workflow that helps you navigate through the application. It 
lists the each activity, associated tasks, and steps involved to 
complete an activity. For more information, see Taskflow.

Content Area Displayed on the right of the screen, the content area includes 
views and tabs associated/configured for each task and step in 
the application workflow.

Table 2–2  Quick Access Toolbar Components

Legend Toolbar Component Description

A File menu The File menu provides access to the general options for 
the workbook, such as Save, Commit, and so on. For 
more information on each option available in the File 
menu, see File Menu Options.

B Edit menu The Edit menu provides access to the options associated 
with cell edits, such as Cut, Undo, and so on. For more 
information, see Edit Menu Options.

Table 2–1 (Cont.) Workbook User Interface Screen Components

Screen Component Description
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C View menu The View menu provides options that enable you to 
quickly access one of the workbooks from the taskflow 
using the Go To sub menu. It also contains the 
synchronize page edge option, and tiling options. For 
more information, see View Menu Options.

D Format menu The Format menu provides options that enable you to 
change and save the format of the workbook.

For more information on formatting, see Format Menu 
Options.

E Save Icon The Save icon enables you to save the changes you make 
in the workbook. You can also access this option from the 
File menu.

For more information on saving the workbooks, see 
Saving Workbooks.

F Commit and Commit 
Status Icons

The Commit icon enables you to commit the changes to 
the domain. You can also access this option from the File 
menu. 

The Commit Status icon enables you to view the current 
statuses of the current commit requests in the Commit 
Status dialog box.

For more information on committing the workbooks, see 
Committing Workbooks.

G Print Icon The Print icon enables you to print the view by exporting 
it to an external program. For more information, see 
Print.

H Export Icon The Export icon enables you to export the view to an 
external program. For more information, see Export.

I Refresh Workbook The Refresh Workbook icon allows you to update a 
workbook with the data that is currently stored in the 
domain. This allows you to work with the most current 
data without having to rebuild the workbook. 
Workbooks can be refreshed with a single refresh rule 
group or a multiple ones. For more information, see 
Refreshing Workbooks.

J Undo Icon and 
Drop-down List

The Undo icon enables you to undo actions you 
performed within the entire workbook (not just the 
current view). You can also access this option from the 
Edit menu. When more than one action has been 
performed, a drop-down list of the last performed 
actions is available. From that list you can select the 
actions to undo.

K Calculate Icon After you edit the cells within the workbook, use the 
Calculate icon to calculate and update the associated 
cells within the workbook. You can also access this 
option from the Edit menu. For more information, see 
Calculating Workbooks.

L Previous and Next  
Icons

The Previous and Next icons enable you to navigate to 
the previous or next task/step in the taskflow. You can 
also click the down arrow (next to both the icons) to 
quickly jump to a specific task or step within the 
workflow.

Table 2–2 (Cont.) Quick Access Toolbar Components

Legend Toolbar Component Description



Quick Access Toolbar

2-4 Oracle Retail Predictive Application Server User Guide for the Fusion Client

File Menu Options
The file menu includes the following options:

■ Save – Allows you to save all information in the workbook. This includes 
information on the current layout of views and charts. You can also click the Save 
icon on the toolbar. For more information, see Saving Workbooks.

■ Save As – Allows you to save the workbook with a name and access you want. For 
more information, see Save As Option.

■ Rename – Allows you to rename the workbook. For more information, see 
Renaming Workbooks.

■ Commit – This option allows you to commit the changes to the master domain. 
Once committed, all other users with access to the workbook will notice the 
changes as well. For more information, see Committing Workbooks.

■ Commit Status – This option allows you to view the status of committed 
workbooks. For more information, see Committing Workbooks.

■ Page Setup – Enables you to change the orientation, scaling, margins, header, 
footer, and page breaks for the page when printing.

■ Print – Enables you to print the view by exporting it to Microsoft Excel. For more 
information, see Print.

■ Export – Enables you to export to Microsoft Excel. For more information, see 
Export.

■ Refresh – Allows you to update a workbook with the data that is currently stored 
in the domain. This allows you to work with the most current data without having 
to rebuild the workbook. Workbooks can be refreshed with a single refresh rule 
group or a multiple ones.

■ Revert – Closes an open workbook without saving it and reopens it. This removes 
any changes made to the workbook and resets it to the last saved value.

M View/Manage Images The View/Manage Images icon enables you to associate 
images with specific dimension positions. This feature is 
especially useful for the product and location 
dimensions. For instance, you can associate an item with 
a image of what it should look like displayed on the 
shelf. You can associate stores with images of the store 
front or interior. For more information, see Images. 

N Update Attribute Values 
and Level Splits Icon

After you edit user-defined attributes, you can update 
the attributes and level splits with this icon. Clicking this 
icon recalculates all sort attributes and dimension splits 
displayed in the workbook since the attribute or 
dimension split was applied to the data. This icon is 
enabled only when there are attributes displayed that 
need to be recomputed based on user edits.

For more information, see Updating Attribute Values.

O Workbook Name This area displays the name of the currently open 
workbook.

Note: The Save option does not commit the changes to master domain.

Table 2–2 (Cont.) Quick Access Toolbar Components

Legend Toolbar Component Description
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Edit Menu Options
The Edit menu includes the following options:

■ Undo – Allows you to undo the last action you performed within the workbook 
(not just the current view).

■ Calculate – Allows you to submit the edited data to the server for processing.

■ Cut – Allows you to copy and remove data from the cells of a view in order to 
move the data to cells in the same view, cells in another view, or other 
applications. For more information, see Cut.

■ Copy – Copies selected data to the application clipboard. It keeps data in a 
clipboard which you can use to transfer data within RPAS as well as to an outside 
application such as Excel. For more information, see Copy.

■ Paste – Pastes the data was last placed on the clipboard into the selected cells 
within the RPAS Fusion Client. For more information, see Paste.

■ Cut Special – Cuts data at the base level or higher level intersection across page 
slices. If multiple levels (product group, style, etc.) are represented in the pivot 
table selections, the cut option is performed at the lowest level actually selected. 
For more information, see Cut Special.

■ Copy Special – Copies data at the base level or higher level intersection across 
page slices. You can view data at an aggregate level while copying data at a 
dimensional level not currently displayed or while selecting data from the current 
slice while copying data from all slices. For more information, see Copy Special.

■ Paste Special – Allows you to view data at an aggregate level while pasting it at 
the base level which is not displayed in the current slices. It provides a dialog 
where the user can specify options for specialized paste functions. For more 
information, see Paste Special.

■ Copy to External - Copies data in the Fusion Client to be pasted in external 
applications. This feature is useful when the browser's security restriction prevents 
the Fusion Client from copying to and pasting from the clipboard. For more 
information, see Copy to External.

■ Paste from External - Pastes data into the Fusion Client from external applications. 
This feature is useful when the browser's security restriction prevents the Fusion 
Client from copying to and pasting from the clipboard. For more information, see 
Paste from External. 

■ Fill – Enables you to quickly populate many cells of a writable measure at a time.

■ Clear –Enables you to quickly clear the contents of cells in a view and set them to 
their NA value. You can clear one or more cells, a dimension level, or an entire 
slice. 

■ Lock – Protects cells, measures, and positions from being edited. For more 
information, see Locking and Unlocking.

■ Unlock – Allows you to remove the protection of cells, measures, and positions so 
that they can be edited. For more information, see Locking and Unlocking.

■ Unlock All – Allows you to remove the protection from all cells, measures, or 
positions so that they can be edited. For more information, see Locking and 
Unlocking.
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■ Insert Measures  – Allows you to add measures to an existing workbook that were 
not initially included in the configuration. A measure can be inserted to a single 
view and is available to all the windows for that view. For more information, see 
Insert Measures.

■ Position Maintenance – Enables you to dynamically add, edit, or remove 
positions to a non-calendar position while working in a workbook. These 
user-defined or informal positions are updated in both the domain and workbook 
dimensions. For more information, see Dynamic Position Maintenance.

■ Find – Enables you to search for phrases within the rows, column, and page axis 
of an active view. The search does not include the data within the view. For more 
information, see Find.

View Menu Options
The View menu includes the following options:

■ Go To submenu – In addition to the Previous and Next icons on the Quick Access 
toolbar, the Go To submenu enables you to navigate through the workflow or to a 
specific step. 

■ Synchronize Page Edge – Enables you to simultaneously scroll through the page 
edge of multiple views. It is useful when you want to compare multiple views 
containing the same page or slice dimension. For more information, see 
Synchronized Page Edge Scrolling. 

■ Automatically Evaluate Position Queries  – Allows position queries to 
automatically reevaluate data after a calculate, refresh, or slice move. When 
enabled, the query is updated and the view refreshes with only the positions that 
meet the requirements of the position query. For more information, see Using 
Position Queries with Auto Evaluate.

■ Resort Positions on Pagination  – Reapplies the sort order when paging through 
positions along the page-axis. For more information, see Sorting Across Page 
Edge.

■ Manage Images  – Enables you to associate images with specific dimension 
positions. This feature is especially useful for the product and location dimensions. 
For instance, you can associate an item with a image of what it should look like 
displayed on the shelf. You can associate stores with images of the store front or 
interior. For more information, see Images.

■ Attributes submenu– Enables you to create and manage attributes and level splits 
after you have edited user-defined attributes. The Update Attribute Values option 
recalculates all sort attributes and dimension splits displayed in the workbook 
since the attribute or dimension split was applied to the data. For more 
information, see Updating Attribute Values.

■ Tile Vertically – Allows you to view multiple views by placing them side by side.

■ Tile Horizontally – Allows you to view multiple views by placing them in rows.

■ Tile – Allows you to view multiple views by placing them as tiles.
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Format Menu Options
The Format menu includes the following options:

■ Measure Styles – Opens the Format dialog box. In the Format dialog box, you can 
set and clear formats that apply to measures or dimensions. You can make changes 
to single or multiple measures and dimensions and apply those changes across 
one, many, or all views in the workbook. For more information, see Formatting.

■ Number Formatting – Allows you to modify the number formatting for measures. 
For more information, see Modifying Number Formatting.

■ Exceptions  – Exception formatting is used for numeric measure types. Exception 
formatting defines the styles to be applied to a cell’s value when it falls outside a 
defined range. For more information, see Modifying Exceptions.

■ Dimension Styles – Allows you to specify header styles for dimensions. For more 
information, see Modifying Dimension Styles.

■ Save Format – Enables you to save the workbook format to be used in the future. 
Formats can be saved at one of the following levels: For Just Me, For [My Group], 
or For Everyone. 

■ Delete Format – Enables you to delete a workbook format. It can be deleted at one 
of the following levels: For Just Me, For [My Group], or For Everyone. 

Taskflow
The taskflow appears on the left of your screen and enables you to easily navigate 
through the activities in the application. It provides a pre-configured business 
workflow organized into expandable and collapsible activities, tasks, and steps.

Each activity consists of more than one task and each task may consist of one or more 
steps. In the Fusion Client, each solution (spanning across multiple workbooks) is 
represented as a set of activities, tasks, and steps. 

Note: The taskflow also appears when you log on to the application. 

Note: The taskflow is configured for your domain during 
implementation. For more information on this configuration, see the 
RPAS Configuration Tools User Guide.
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Figure 2–3 shows an example of a solution configured with activities, tasks, and steps:

Figure 2–3 Illustration of Activity, Task, and Step

In the Fusion Client, the workflow illustrated in Figure 2–3 appears in the following 
manner:

Figure 2–4 Taskflow 
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In the taskflow, you can click the Expand icon next to any task to view the associated 
steps. When you are working with a specific step, an arrow icon appears in the 
taskflow indicating the current step and your position in the workflow.

The Create New Workbook, Open Latest Workbook, and Show List of Workbooks 
icons that appear next to each task or step enable you to create new workbooks or 
open existing workbooks. You can find more information on creating new workbooks 
and opening existing workbooks in Chapter 1, "Getting Started".

Figure 2–6 illustrates the icons that appear in the taskflow:

Figure 2–5 Icons in the Taskflow 

The following table describes the icons that appear with all the entries in the taskflow:

Table 2–3  Description of Icons in the Taskflow 

Legend Icon Name Description

A Activities These tabs represent the predefined activities of the 
application.

B Tasks These are individual tasks within an activity. Tasks that 
have a workbook associated with it display a clipboard 
icon. 

C Current Position Icon Indicates the current step and your position in the 
workflow.

D Steps One or more steps make up each task.

E Create a New 
Workbook

Click this icon to create a new workbook. The new 
workbook wizard associated with the relevant task 
appears.
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Access Based Visibility
The activity and tasks that appear in the taskflow are access-based. Depending upon 
the security settings, you may not have access to some tasks or activities. Access to a 
task is defined by whether you have access to the workbook template that the task is 
assigned to. 

The access to the workbook template is maintained in the Security Administration 
step. See the RPAS Administration Guide for the Fusion Client for more information about 
the Administration activity. If you do not have access to a workbook template, then 
you are not able to build the workbooks for the associated tasks and steps.

Hiding specific tasks or activities based on user access is configurable. In the 
configuration, a task can be set to either hidden or disabled. If it is hidden and the user 
does not have access to it, then the task is not displayed. If it is disabled and the user 
does not have access, then the task is displayed but the links to access the workbooks 
are disabled. For more information, refer to the RPAS Configuration Tools User Guide.

F Open the Latest 
Workbook

Click this icon to view the latest workbook (associated 
with the relevant task/step) you worked on.

G Show List of 
Workbooks

Click this icon to view a list of all workbooks 
(associated with the relevant task/step) accessible to 
you. The Open Workbook window appears with a list 
of accessible workbooks. 

If you do not own any workbooks that you own, a 
message appears allowing you to view all workbooks. 

In case there are no workbooks associated with the 
task/step, created by you or by someone else, a 
message appears that allows you to create a new 
workbook.

H Collapse/Restore Icon Click this icon to collapse or restore the taskflow. 
Collapsing the taskflow allows you to view more 
content in the Contents area.

After a user has opened a workbook, the state of the 
taskflow is maintained when navigating between 
workbooks and the homepage. For instance, if you are 
in a workbook and the taskflow is collapsed, when you 
navigate to the homepage and then return to a 
workbook, the taskflow remains collapsed because that 
was its last state.

The state of the taskflow after the first workbook is 
built or opened in a user session is controlled by the 
rpasConfig.properties file. 

For information on changing this setting, see the 
rpasConfig.properties section of the RPAS 
Administration Guide for the Fusion Client.

I Dynamic Task A dynamic task is one that has steps which are 
dynamic, based on the selection the user makes when 
building the associated workbook. The steps are not 
shown unless the user is within a workbook. 

Dynamic tasks display a clipboard with a lightning bolt 
icon.

Table 2–3 (Cont.) Description of Icons in the Taskflow 

Legend Icon Name Description
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Switching Between Multiple Tasks
When working within multiple steps or tasks, all changes you make in a specific step 
are maintained when you move to a step in the same task or a different task associated 
with the same workbook template. In this case, you do not need to save your work 
when you switch between tasks within the same workbook template.

If you switch to a task that is associated with a different workbook template, you are 
prompted to save or discard the changes before opening or building a new workbook. 
To save your changes, use the Save As dialog box. For more information on the Save 
As dialog box, see Save As Option.

Contents Area
The contents area appears on the center of your screen and includes the views 
associated with each step within the business workflow. It provides spreadsheet-like 
views that display multidimensional data. Each view includes a set of measures 
relevant to the step that help you view, analyze information, and take decisions. 

Figure 2–6 shows the various components in the contents area:

Figure 2–6 Content Area Components 

Table 2–4 describes the components highlighted in the figure above:

Table 2–4  Components in the Contents Area

Legend Area Name Description

A View Title Bar Displays the name of the view and also includes view-level features 
such as Minimize, Maximize, Restore, and other View Options. See 
View Title Bar for more information.
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View Title Bar
The View Title bar appears on the top of each view and displays the view name. It 
enables you to perform the following view-level actions:

■ Maximizing or Restoring a View

■ Minimizing a View

■ Moving a View

■ Renaming a View

■ Making a Copy of a View

■ Deleting a View

Maximizing or Restoring a View
To maximize a view:

■ On the View Title bar, click the Maximize icon. This icon is the arrow that points 
towards the top-right, see Figure 2–7.

Figure 2–7 Maximize Icon on the View Title Bar

To restore a maximized view to its original size:

■ On the View Title bar, click the Restore icon. This icon is the arrow with a box that 
points towards the bottom-left, see Figure 2–8.

Figure 2–8 Restore Icon on the View Title Bar

B Page Edge and 
Dimension Tiles 
Area

Enables you to move or swap individual dimensions to view the 
information in a more effective manner. See Page Edge and 
Dimension Tiles Area for more information.

C View Toolbar Provides quick access to view-level formatting, exporting, and 
charting options. SeeView Toolbar for more information.

D View Area Displays a Pivot Table/Grid with the multidimensional data 
organized based on the dimension position set up in the Page Edge 
and Dimension Tiles area. See View Area for more information.

E Views Docking 
Area

Displays the views available in the current step and helps you 
manage any additional copies of the existing views that you may 
create. See Views Docking Area for more information.

Table 2–4 (Cont.) Components in the Contents Area

Legend Area Name Description
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Minimizing a View
To minimize a view:

■ On the View Title bar, click the Minimize icon. This icon is the arrow with an 
underline that point towards the bottom-left, see Figure 2–9.

Figure 2–9 Minimize Icon on the View Title Bar

A minimized view is shown with a restore icon to the left of the view name. To restore 
the view, you must click the view in the Views Docking Area.

Moving a View
To move a view:

1. On the View Title bar, click the Move icon on the view you want to move. This 
icon is the cross hair that appears to the left of the Minimize icon, see Figure 2–10.

Figure 2–10 Move Icon on the View Title Bar

2. Drag and drop the view to the location you want. You can move this view only 
within the Contents area. When you try moving a view to a location out of the 
Contents area, the view auto fits to the nearest valid space.

Renaming a View
To rename a view:

1. On the View Title bar, click the View Options icon. The View Options menu 
appears.

2. In the View Options menu, click Rename view.

Figure 2–11 Rename View Option in the View Options Menu

A Rename View dialog box appears.

3. In the Rename View dialog box, enter the new view name, and click OK.
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Making a Copy of a View
To make a copy of a view:

1. On the View Title bar, click the View Options icon. The View Options menu 
appears.

2. In the View Options menu, click Copy view.

Figure 2–12 Copy View Option in the View Options Menu

A Copy View dialog box appears.

3. In the Copy View dialog box, enter or accept the new view name, and click OK.

Deleting a View
To delete a view:

1. On the View Title bar, click the View Options icon. The View Option menu 
appears.

2. In the View Options menu, click Delete view.

Figure 2–13 Delete View Option in the View Options Menu

A warning message appears.

3. Review the warning message and click Delete to remove the view.

Note: Deleting a view removes the view from the user interface 
permanently.
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Page Edge and Dimension Tiles Area
The Page Edge area appears on top of the View area and displays the dimensions on 
the page edge axis with its current position in the dimension. The Dimension Tiles area 
displays the dimensions, as tiles, that appear in the row and column axes.

On the Page Edge, the current position appears below the dimension name, 
horizontally with the highest visible level on the left to the lowest visible level on the 
right. You can hover the mouse cursor over the position to view the name of the level 
(displayed as a tool tip).

Figure 2–14 Page Edge Displaying the Current Position

When you open the workbook for the first time, the first position in each visible level 
is visible. In an existing workbook, the positions retain the last saved values. 

You can collapse or restore the Page Edge and Dimension Tiles area to fit more view 
content. You can also drag these icons to resize this area. Figure 2–15 shows the 
Collapse Pane icon that enables you resize or collapse the Page Edge and Dimension 
Tiles area:

Figure 2–15 Collapse and Restore Icons in the Page Edge and Dimension Tiles Area
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Understanding Paging/Position Navigation
On the Page Edge area, you can select any position displayed and page through or 
navigate the positions using the navigation icons (First, Previous, Next, Last) available 
next to the dimension tiles. In the view, data relevant to each position is displayed 
when you navigate to a new position in a level.

Figure 2–16 Paging Navigation Icons

The First icon enables you to navigate to the first visible position within the level that 
is selected. When you are at the first position, the First and Previous icons are disabled 
and appear greyed out.

The Last icon enables you to navigate to the last visible position within the level that is 
selected. When you are at the last position, the Next and Last icons are disabled and 
appear greyed out.

The Previous and Next icons enable you to navigate to the previous and next position 
in the level that is selected. The position to which you navigate to depends on the 
current position. When you navigate to a new position, all associated positions at the 
higher and lower visible levels of the same dimension are updated recursively.

Note: You can also pivot or rotate the dimensions between the Page 
Edge, Tiles, and View areas to rearrange the orientation. For more 
information, see Rotating or Pivoting Dimensions.
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View Toolbar
The View Toolbar appears within the View area, above the grid. It displays several 
tools that you can use to manipulate the view.

Figure 2–17 View Toolbar

The following table describes the components highlighted in the figure above:

Table 2–5  Components in the View Toolbar

Legend Area Name Description

A Switch to Pivot Table 
View icon

When in the chart view, this icon enables you to switch to 
the pivot table view. For more information, see Viewing 
Charts.

B Switch to Split View 
icon

Allows you to see the pivot table and chart in two 
vertical panels simultaneously in the same view. For 
more information, see Viewing Charts.

C Switch to Chart View 
icon

When in the pivot table view, this icon enables you to 
switch to the chart view. For more information, see 
Viewing Charts.

D Select Chart Type icon Allows you to select which type of chart you would like 
to view the data in. For more information, see Viewing 
Charts.

E Find field, Find 
Options, Previous and 
Next Arrows

Enable you to search for words, partial words, or phrases 
within the rows, column, and page axis of an active view. 
The search does not include the data within the view. For 
more information, see Find from the View Toolbar. 

F Selection Options icon Allows you to select the data that is shown in the chart. 
You can choose Select All or any other option it presents. 
Select All finds the full extent of the pivot table edges (in 
slices) and sets a new selection range to encompass the 
entire pivot table. This action triggers a refresh of the 
pivot table.

G Measure Profile icon Allows you to select, save, or delete measure profiles. See 
Measure Profiles for more information.

H Level Splitting icon Allows you to group dimension data based on position 
characteristics defined by attribute values. For more 
information, see Level Splitting.

I Attributes icon Allows you to create dynamic attributes that describe a 
particular dimension and level based on a measure’s 
value at specified levels of other dimensions. For more 
information, see Dynamic Attributes.

J Lock icon Protects cells, measures, and positions from being edited. 
For more information, see Locking and Unlocking.

K Sort Ascending and 
Sort Descending icons

Allows you to sort positions in a dimension based on the 
values of a measure's slice for that dimension. For more 
information, see Simple Sort.
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View Area
The view area includes the multidimensional pivot table that displays information for 
the relevant task. Each task may include more than one view, and each view can 
appear in the contents area. The information in the view is organized based on the 
dimension positions set up at the Page Edge, row, and column axes. 

The Fusion Client enables you to work with the data within the view. It also enables 
you to manage the way the information is presented in a view. You can arrange and 
present the information in a layout you want by rotating or pivoting dimensions 
across the axes, changing the data roll ups, or showing or hiding measures. You can 
view the information at a low level of detail or aggregate to view the information at 
summary levels. You can also choose to present the information in many types of 
charts using the charting functionality.

Outline View vs. Block View
You can view the data within the view in one of two ways:

■ Block View enables you to display the data one dimensional level at a time (with 
the lowest level expanded in the grid). Figure 2–18 illustrates the block view:

Figure 2–18 Illustration of the Block View

■ Outline View enables you to view the data at multiple dimensional levels at the 
same time, removing the need for you to collapse lower-level dimensions to see 
aggregate totals for higher levels. Figure 2–19 illustrates the outline view:

Figure 2–19 Illustration of the Outline View

To switch between the outline and block views, right click the header of the axis whose 
view you want to change, and select the relevant view option.
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Rotating or Pivoting Dimensions
In the View area, you can rotate or pivot the dimensions across the axes to display data 
in different orientations. In the Fusion Client, you can pivot the dimensions (in both 
outline and block views) between the view, tiles, and page edge in the two ways:

■ Pivot Move – Moves a dimensional layer to another position on an axis.

■ Pivot Swap – Swaps a dimension with another dimension on the axis.

To perform a pivot move in the page edge:

1. In the page edge, click and hold the dimension tile you want to move.

2. Drag the tile next to the area you want, and release the mouse.

Figure 2–20 Pivot Move in the Page Edge

To perform a pivot move in the pivot table:

1. From the row or column edge, click and hold the dimension you want to move.

2. Drag the dimension to the location you want and release the mouse.

Figure 2–21 Pivot Move in the Pivot Table

Note: When a dimension is swapped or moved to the page edge for 
the first time, the first position within the dimension is displayed in 
the page edge and the data for that position is shown in the view. 
When a dimension that has already been on the page edge during the 
current session is returned to the page edge, the position that was last 
displayed in the page edge during previous time is shown.
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To perform a pivot swap in the page edge:

1. In the page edge, click and hold the dimension tile you want to move.

2. Drag the the dimension tile over the one you want to swap it with. Release the 
mouse.

Figure 2–22 Pivot Swap in the Page Edge

To perform a pivot swap in the pivot table:

1. From the row or column edge, click and hold down the dimension you want to 
swap.

2. Drag the dimension over the other dimension and release the mouse.

Figure 2–23 Example of a Pivot Swap Action

Note: You can also perform these similar actions to switch 
dimensions between the Views, Page Edge, and Dimension Tiles areas.
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Views Docking Area
The Views Docking Area displays all the views configured within the tab. It enables 
you to easily navigate to a view that is not in sight. When a view gets behind other 
views, you can click the specific view name in the Views Docking Area to bring that 
view back to the front. 

When you minimize a view, the view gets minimized to the Views Docking Area. A 
minimized view is shown with a Restore icon to the left of the view name. To restore a 
minimized view, you must click the view in the Views Docking Area.

The following figure shows a Views Docking Area of a tab with three views:

Figure 2–24 Example of a Views Docking Area with Three Views

In the example above, the Item Group Level is the current view that is visible. It is the 
active view that is highlighted in light blue in the Views Docking Area. The Item 
Linkage Override view is hidden behind Item Group Level. The Select Constraint 
Items view is minimized and has a Restore icon next to its name in the Views Docking 
Area.
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3
Workbooks

When you use an RPAS solution, you interact with the solution through a personal 
data repository called a workbook. A workbook contains the subset of the data (and 
metadata) from the domain and its scope is constrained by the access rights available 
to a user. Workbooks are stored on the RPAS server, and can be built using an online 
wizard process or scheduled to be built in a batch process automatically.

This chapter describes the various tasks you can perform with the data in the 
workbooks. It includes the following sections:

■ Saving Workbooks

■ Renaming Workbooks

■ Calculating Workbooks

■ Refreshing Workbooks

■ Committing Workbooks

■ Synchronized Page Edge Scrolling
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Saving Workbooks
On the workbook screen, you can edit the cells in the pivot table, change the layout of 
views, and so on. The Save and Save As options enable you to save such workbook 
changes. 

The Save option is available in the File menu and also as an icon on the toolbar. The 
Save As option is available only in the File menu.

Each time you save the workbook, the workbook is first automatically calculated 
before the changes are saved. If the calculate or save operation fails, an error message 
appears.

To save a workbook:

■ Once you perform the changes you want, click the Save icon on the toolbar.

Figure 3–1 Save Icon on the Toolbar

Or

■ From the File menu, click Save.

Figure 3–2 Save Option in the File Menu
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Save As Option
The File menu also includes a Save As option that enables you to save a copy of the 
workbook. It also enables you to set the access privileges for the workbook.

To save a copy of the workbook:

1. With the workbook open, click Save As in the File menu. The Save As dialog box 
appears.

Figure 3–3 Save As Dialog Box

2. In the Save As dialog box, enter appropriate details in the following fields:

■ Name – The name of the workbook.

■ Access – The access privilege to be set for the workbook. Select one of the 
following options:

– User: This is the default option. Select this option if you want this 
workbook accessible only to you.

– [Group Name]: Select a group if you want to allow access to all users in 
that group, who have access to this workbook template.

– World: Select this option if you want to allow access to all the users set up 
for the application, who have access to this workbook template.

3. Click Save.

By default, the Name and Access fields retain the values set for the workbook that 
were saved previously. You can also select a different workbook from the list and then 
update it to make it a unique name.
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Auto-Save
The RPAS Fusion Client has an Auto-Save workbook feature that saves a copy of an 
open workbook automatically. Auto-saved workbooks contain all the changes up to 
the last Calculate and Custom menu actions.

The auto-save workbook feature enables you to quickly resume your work in case one 
of the following events occur:

■ The Web browser window is closed before logging out from the RPAS Fusion 
Client.

■ The Web browser window stops responding and closes abruptly.

■ The network is disconnected or the Web server stops responding.

When one of these events occurs, an auto-save takes place and a copy of the existing 
workbook is made. This copy has the same name of the workbook with _autosaved 
appended.

After one of these events occurs, you should first notify your administrator. Once the 
issue is fixed and the servers are restored, you can open a new Web browser window, 
log on to your domain again, and start using the auto-saved workbook or your last 
saved revision of the workbook. 

Note: Uncalculated cell edits and formatting changes made in the 
previous session are not saved in the auto-saved workbooks.

Note: In case your implementation uses a clustered configuration 
and the Web server stops responding, you will be re-directed to the 
RPAS Fusion Client login page on another managed server that is 
acting as a fail-over server. You can then log on to your domain and 
resume work using the auto-saved workbook.
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Renaming Workbooks
When you have a workbook open, you can rename it at any time without affecting the 
data within the workbook or the other workbook information such as the created date, 
modified date, formatting information and so on. 

There are a few key points to know about renaming workbooks:

■ You can only rename workbooks to which you have write access.

■ Workbook names can be no more than 32 characters.

■ Workbook names cannot contain double or single quotation marks.

■ Workbooks cannot be named "Untitled." This name is reserved.

To rename a workbook, perform the following steps.

1. With the workbook open that you want to rename, select Rename in the File 
menu.

Figure 3–4 Rename Option in the File Menu

2. The Rename Workbook dialog box appears. Enter the new name and click OK.

Figure 3–5 Rename Workbook Dialog Box

3. The workbook refreshes and the new name appears in the top, right corner.

Figure 3–6 Renamed Workbook

You can also rename a workbook from the Open Workbook window or the Save As 
window. For more information about this option, see Renaming a Workbook.
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Calculating Workbooks
When you edit any cell value within a view, you must calculate the workbook to 
review the cells that are updated based on your action. The Calculate icon on the 
Quick Access toolbar and the Calculate option in the Edit menu enable you to 
calculate the workbook after you edit any cell value in a workbook.

Figure 3–7 Calculate Option on the Quick Access Toolbar and Edit Menu

When you calculate a workbook, the updated cell value is sent to the server and the 
associated cells are recalculated based on the calculation rules already configured.

The formatting for edited cells are removed.

To calculate a workbook:

1. In the workbook, edit the cells you want. You can edit the unprotected cells only. 
There are some protected measures that you may not be able to edit. When you 
edit a cell, the formatting on the edited cell is removed.

Alternately, because of protection processing, there are cells that are protected 
while you are editing other cells.

2. Click the Calculate icon on the Quick Access toolbar.

OR

In the Edit menu, click Calculate.

All associated cells are calculated and the updated workbook appears. As a result of 
the Calculate operation, protected cells may become unprotected if they were 
protected as a result of a previous cell edit. 

Note: The Calculate option is disabled on the Quick Access toolbar 
and Edit menu when there are no changes in the workbook.

Note: You can also calculate the workbook using the keyboard 
shortcut Ctrl + T.
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Refreshing Workbooks
When you are working with a workbook, you have the ability to update it with the 
data that is currently stored in the domain. This allows you to work with the most 
current data without having to rebuild the workbook. 

Workbooks can be configured to have a single refresh rule group or multiple refresh 
rule groups.

■ Single refresh rule group - These contain refresh rules in a single rule group. This 
means that only one rule group is assigned as a refresh rule group in the 
configuration of the workbook.

Figure 3–8 Single Refresh

Note: If a refresh rule group does not exist for a workbook, the 
Refresh option is disabled.



Refreshing Workbooks

3-8 Oracle Retail Predictive Application Server User Guide for the Fusion Client

■ Multiple refresh rule groups - Multiple refresh rule groups are set up and 
assigned to a workbook. When there are multiple refresh rule groups, the refresh 
options in the Edit menu and in the toolbar have a down arrow that shows a list of 
available refresh rule groups. You can choose the specific group to refresh the data 
in the workbook. Only one rule group can be selected or applied at a time.

Figure 3–9 Multiple Refresh 

The refresh rule groups available for use in the Fusion Client are set up in the RPAS 
Configuration Tools. To learn how to create these rule groups, see the RPAS 
Configuration Tools User Guide.

When the refresh option is used, the following occurs:

■ When the refresh option is invoked, the Fusion Client runs the calculation before 
running the refresh operation.

■ The uncommitted data is lost for measures that are refreshed or calculated as a 
result of the refresh. If the measure is not affected by the refresh process, then the 
uncommitted data is not affected.

■ If a locked cell has updated data in the domain, the value in the cell changes to the 
domain value.

■ In general, all locks are ignored and the data is updated with new values from the 
domain.

■ It is possible that elapsed time is updated as part of the refresh. When you refresh, 
the elapsed setting can be updated; therefore, certain periods of data may become 
read-only.
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Committing Workbooks
When you perform a save operation, the changes get saved to the workbook. Unless 
these changes are committed to the master domain, the updated information may be 
lost if the workbook is deleted or corrupted. The Commit option enables you to merge 
the changes you performed in the workbook to the master domain.

You can find the Commit option in the File menu and also as an icon on the toolbar. A 
Commit Status option is also available next to the Commit option. This option enables 
you to review the status of the commit requests.

To commit a workbook:

■ After you perform the changes you want, click the Commit icon on the toolbar.

Figure 3–10 Commit Icon on the Toolbar

OR

■ From the File menu, click Commit.

Figure 3–11 Commit Option in the File Menu

When you commit a workbook, a copy of the workbook is added to the commit queue, 
and the commit status changes to Pending. This status is updated at a set time interval 
(configurable and defaults to 30 seconds) until the status changes to Committed. After 
the system resources are available, the changes are committed to the master domain. 
You can continue working on the workbook while the commit operation is in progress. 
If any changes made subsequent to the last commit operation need to be committed to 
the domain, then another commit operation is required. 

Notes: The Commit operation is similar to the Commit ASAP option 
in the RPAS Classic Client. 
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The following Commit statuses are available:

■ Committed – Indicates that the changes were committed successfully and no 
additional changes have been made.

■ Modified – Indicates that the changes were made (saved or unsaved) since the last 
commit.

■ Pending – Indicates that the changes are submitted to the queue and waiting to be 
processed.

■ In Progress – Indicates that the changes in the workbook are being committed.

■ Failed – Indicates that the changes were not committed. You may need to fix any 
errors in the workbook and try committing again.

An information icon is available next (to the right) to the Commit Status. You must 
hover the mouse cursor over the Commit Status icon to view the current commit 
status.

Viewing Commit Statuses
The Commit Status dialog box enables you to view the commit statuses for all the 
workbooks.

To view the commit statuses:

■ On the Quick Access toolbar, click the information icon placed to the right of the 
current Commit Status.

Figure 3–12 Commit Status Information Icon

■ Or, from the File menu, click Commit Status.

Figure 3–13 Commit Status Icon on the File Menu

Note: If you commit an untitled workbook that has never been 
saved, the data is committed; however, the commit status in the 
toolbar is not updated until the workbook is saved for the first time. 
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The Commit Status dialog box appears.

Figure 3–14 Commit Status Dialog Box

By default, the Commit Status dialog box lists the statuses of the current commit 
operations. It also enables you to filter the list by the users, templates, or status.

To view the commit status based on specific criteria:

1. On the Commit Status dialog box, select the relevant values in the Submitter, 
Task, or Status drop-down lists.

2. Once the specific criteria is selected, click the Refresh icon located on the right of 
the Status drop-down list.

Showing or Hiding Columns
By default, the Commit Status dialog box displays all the columns. To show or hide the 
columns, perform the following steps:

1. On the Commit Status dialog box, click View.

Figure 3–15 View Menu in the Commit Status Dialog Box

2. On the View menu, select the column you want in the Columns sub menu.
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Reordering Columns
The Reorder Columns option in the View menu enables you to reorder the columns 
that appear in the Commit Status dialog box.

To reorder the columns:

1. In the Commit Status dialog box, click View.

2. In the View menu, click Reorder Columns. The Reorder Columns window 
appears.

Figure 3–16 Reorder Columns Window

3. In the Reorder Columns window, select the columns you want, and click the up or 
down arrows to reorder the columns. Click the top (first) and bottom (last) arrows 
to move your selection to the top or bottom of the list.

4. Click OK.

Note:  You can also reorder the columns visible in the dialog box by 
dragging and dropping them to the position you want.
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Synchronized Page Edge Scrolling
Synchronized page edge scrolling enables you to simultaneously scroll through the 
page edge of multiple views. When synchronized page edge scrolling is enabled, all 
views that contain the same slice dimension scroll to the new slice position when one 
of those views is scrolled to a new position. When disabled, scrolling through slice 
positions in one view does not affect the slice position display of other views.

Synchronized page edge scrolling works for all views within a single workbook, and it 
remains enabled as you move through the tasks and steps within that workbook. 
Synchronized page edge scrolling is useful when you want to compare multiple views 
containing the same page or slice dimension.

To enable synchronized page edge scrolling, click Synchronize Page Edge in the View 
menu, as shown in Figure 3–17.

Figure 3–17 Synchronize Page Edge Option in the View Menu

When synchronized page edge scrolling is enabled, a check mark appears by this 
option in the View menu. In addition, workbooks that are set at the same dimension 
levels are refreshed to show the same data within those levels.

Figure 3–18 Synchronized Views

In Figure 3–18, the two views, Item Level and Like Item Level, have been 
synchronized to show the same data: 1 Max Revenue scenario and the Price Zone 1 
location.

Note: The views in Figure 3–18 have been tiled vertically. For more 
about the tiling options, see View Menu Options.
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After you have enabled synchronized page edge scrolling, you can use the navigation 
arrows (Figure 3–19) to view other positions within that level. As you use the 
navigation arrows on one view to move to a different position, the other views that 
have the same level displayed move to the same position.

Figure 3–19 Navigation Arrows

If you save the workbook with the synchronized page edge option turned on, it is 
saved with the workbook. Therefore, when you open the workbook again, the 
synchronized option is still enabled.

Note: When views do not share the same lowest level of a 
dimension, the views do not scroll together.
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4
Cells 

The user's ability to edit multiple workbook cells at once and to move chunks of data 
in and out of the workbook is essential to using RPAS efficiently and effectively. This 
chapter describes how to select and edit cells as well as how to cut, copy, and paste 
information into cells. This chapter describes the various tasks you can perform with 
the data in cells. It includes the following sections:

■ Select and Manipulate Cells

■ Enter or Change Values in a Cell

■ Modify Data with Cell Formulas

■ Clear and Fill Cells in a View

■ Modifying Cell Data

■ Cut, Copy, and Paste

■ Cut, Copy, and Paste Special

■ Copy to External and Paste from External

■ Read-only Measures

■ Locking and Unlocking

Select and Manipulate Cells
Cells or groups of cells must be selected in the pivot table before certain operations can 
be performed on them. Operations such as cutting and copying data, filling or clearing 
data cells, and displaying data in chart form are typically performed on a subset of 
cells that you must select before invoking the menu command.

There are several ways to select cells in the pivot table. Generally, you should make 
your selections in the view axes (where the column and row headers appear) and not 
in the cells themselves.

Select a Single Cell
Click inside the cell. When selected, the cell is shaded.

Note: You cannot select multiple cells for copying or cutting when an 
edit is in progress. While an edit is in progress, only the current edited 
text is copied. To copy multiple selected cells, click Escape to exit and 
then select the multiple cells again. 
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Select all Cells in a Row
Click the row header for that row of cells. 

Select all Cells in a Column
Click the column header for that column of cells.

Select a Group of Contiguous Cells in the Same Row
1. Click the first cell in the row of cells you want to select.

2. Hold the Shift key and click the last cell in the group. The cells become shaded.

Select a Group of Contiguous Cells in the Same Column
1. Click the first cell in the column of cells you want to select.

2. Hold the Shift key and click the last cell in the group. The cells become shaded.

Select a Block of Contiguous Cells
1. Click the top-most, left-most cell in the block you want to select.

2. Hold down the mouse and drag the cursor to the bottom-most, right-most cell in 
the block that you want to select. 

Select a Group of Non-Contiguous Cells
1. Click the first cell you want to select. The selected cell becomes shaded.

2. Hold down the Ctrl key and click the other cells you want to select. All selected 
cells become shaded.

Figure 4–1 Non-Contiguous Cells

See the Paste section for information about copying and pasting non-contiguous cells. 

Enter or Change Values in a Cell
The following are descriptions of actions you can take to change individual values in 
the pivot table. 

Numbers: Enter or overwrite a numeric value.

Alphanumeric Values or Plain Text: Enter or overwrite an alphanumeric value.

Drop-Down List Items: Select the desired option from the drop-down list. Click the 
arrow and select an item from the drop-down list. For information about selecting 
dimension values in drop-down lists, see Single Hierarchy Select.

Date Items: Select the desired date. Click the arrow to display the calendar, and click 
the appropriate arrow keys to change the year, month, or date.

Check Box (Toggle) Items: Click the check box to change the status of the item (yes or 
no, on or off).

Math Operations: To increment the value in a cell using a mathematical formula, see 
Modify Data with Cell Formulas.
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Modify Data with Cell Formulas
Cell formulas allow you to modify the value of a data cell in the pivot table by 
applying an operator (+, -, *, or /) to that value. With this functionality, you can make 
changes to data values without having to manually calculate the result. To perform 
this function, click the data cell and type the operator that you want to add, subtract, 
multiply, or divide by.

For example, suppose that a particular data cell contains the value 10.

■ Add: If you enter +10 in the cell, the value becomes 20.

■ Subtract: If you enter + -10 in the cell, the value becomes 0.

■ Multiply: If you enter *10 in the cell, the value becomes 100.

■ Divide: If you enter /10 in the cell, the value becomes 1.

■ Percentages: If you want to increase the value of a cell by 10%, multiply the value 
by 1.1 (enter *1.1)

There are many applications of cell formulas when modifying data. Cell formulas can 
only be applied to one cell at a time, but changes made to aggregate level cells will be 
spread down to lower-level cells along dimension lines. Similarly, any changes made 
to lower level cells will be reflected in the aggregates of that data.

Using Math Formulas
Apart from the basic math operations, you can also extend the math operations and 
enter formulae in the cells. For example, entering +30/2 in a cell with a value 70 will 
add 30 to the existing value, and then divide the result by 2. Entering 10+30/2 in a cell 
will update the cell with a value 20. 

Overriding Spread Methods
By default, making an edit in the aggregate level cell and calculating spreads the data 
based on the spread method of the measure.

However, you can override the default spread method of a measure and spread the 
aggregate data into individual cells using a different spread method. The override 
spread methods available are Replicate, Evenly, Proportionally, and Delta. Using this 
feature, you can spread data at an aggregate level down to the lower levels in a 
dimension. 

For example, entering 40r in a cell replicates 40 in the child dimension cells when the 
next calculate is performed. The calculation of the spread is done by the RPAS Server.

To override default spread method, add one of the following letters as a suffix to the 
cell value:

Replicate: [value] r   A value entered into a cell at an aggregate level is replicated (copied) 
into every cell at the aggregate cell's base level. This results in a higher aggregate cell 
total (the value entered multiplied by the number of base-level cells).

Evenly:  [value] e     A value entered into a cell at an aggregate level is evenly distributed 
among all cells at the aggregate cell's base level.

Proportionally: [value] p    A value entered into a cell at an aggregate level is distributed 
proportionally among all cells at the aggregate cell's base level (proportional to the 
original values in the base-level cells).
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Delta:  [value] d   The difference between a value entered into a cell at an aggregate level 
and the original value of that cell is distributed evenly among all cells at the aggregate 
cell's base level.

The spread action is performed, once you click Calculate. For more information on 
Calculating, see Calculating Workbooks.

Enter Measure Data Using a Scaling Factor
The scaling factor feature allows you to enter measure data that will be scaled or 
factored to an internal value, which is recognized by the server in data calculations. 
When you enter a value for a measure that has a scaling factor, the value that you enter 
will be multiplied by the scaling factor to arrive at this internal value. The display of 
the data and the ease of data entry can be greatly enhanced by use of a scaling factor.

For example, suppose that you want to enter data in thousands of units. You might 
find it tedious to enter 1000, 2000, 6000, and so on. A more sensible approach would be 
to enter the values 1, 2, and 6, and have the system apply a scaling factor (in this case 
1000) to the entered data. The internal values of the three affected cells would be 1000, 
2000, and 6000, and these internal values would be used in required data calculations. 
Removing the zeros from the display would result in a cleaner, less cumbersome view 
appearance.

Scaling factors can be set in the RPAS Configuration Tools or through the formatting 
options in the RPAS Fusion Client. For more information setting scaling factors in the 
Configuration Tools, see the RPAS Configuration Tools User Guide. 

To set scaling factors in the Fusion Client, perform the following steps:

1. Right-click a measure. The right-click context menu appears.

Figure 4–2 Number Formats Option in the Right-Click Context Menu

2. Select Format, and then select Number Formats. The Format dialog box appears.

3. Select the measure and views for which you want to change the scaling.
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4. Enter a value in the Scale option, as shown in Figure 4–3.

Figure 4–3 Setting the Scale Option in the Number Formatting Tab

For instance, if you enter 1000 as the scale factor, then all values in the view are 
displayed in thousands, meaning that a value of 35 actually represents 35,000. 

5. When finished, click Apply and then Close.

You can use the scale factor for percentages as well. Enter a scale of .01 if you want to 
see values displayed as percentages, meaning that you would see 19% rather than 0.19.

Figure 4–4 Using the Scale Option for Percentages
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Clear and Fill Cells in a View
Your ability to edit multiple workbook cells and to easily move data in and out of the 
workbooks is essential to using RPAS to its fullest extent You can accomplish this by 
using the fill and clear functions. These are found in the Edit menu. 

Figure 4–5 Fill and Clear in the Edit Menu 

Clear
The clear feature enables you to quickly clear the contents of cells in a view and set 
them to their NA value. With the clear function, you can clear one or more cells, a 
dimension level, or an entire slice.

Clear Cells
1. Select the cells you want to clear. In Figure 4–6, the Wp Sales R cells for three 

months have been selected.

Figure 4–6 Cells Selected to be Cleared
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2. Select the Clear option in the Edit menu.

3. The selected cells are returned to their NA value, as shown in Figure 4–7.

Figure 4–7 Cleared Cells

Clear a Dimension Level
The steps for clearing a dimension level vary depending upon which view you are in, 
outline or block. In block view, you can click Clear in the Edit menu just as you do 
when clearing cells. However, clearing a dimension level in outline view works 
differently if more than one level is in the selection. 

To clear a dimension level in outline view, perform the following steps:

1. Select the cells you want to clear. In Figure 4–8, the entire Weekly Sales - Regular 
measure has been selected, and two product dimension levels are selected: Fiscal 
Quarter and Fiscal Month.

Figure 4–8 Clearing Dimension Levels
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2. Select Clear in the Edit menu. The Clear dialog box appears.

Figure 4–9 Clear Dialog Box

3. Select the dimension level you want to clear and click OK. That dimension level 
clears in the background. 

4. If you want to clear another dimension level, select it from the list and click OK. 
When finished clearing, close the Clear dialog box.

Clear a Slice
You can clear an entire slice, all data shown in the view. 

1. When you open the view, do not select any cell. 

If cells are selected, you can deselect them by clicking a dimension tile, opening 
the Dimension dialog box, and then clicking OK to close it. 

2. With no cells selected in the view, click Clear in the Edit menu.

3. A message appears, stating "Entire slice will be cleared because nothing is 
selected." Click OK.

Figure 4–10 Clear Entire Slice Message

The entire slice is cleared. If any read-only cells exist in the slice, a message appears 
informing you that the read-only cells were not cleared.

Figure 4–11 Fill/Clear Message: Ignored Read-only Cells

If all selected cells are read-only, an error message appears, stating that none of the 
selected cells were editable and therefore the clear was not performed.
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Undo Clear
To undo any type of clear, click Undo in either the Edit menu or the quick access 
toolbar. However, once the Calculate function is invoked, the Undo option cannot 
reverse the clear.

Fill
The fill feature enables you to quickly populate many cells of a writable measure at a 
time. Depending on which view you are using, outline or block, one of the following 
dialog boxes appears.

Figure 4–12 Fill Dialog Box in the Block View

Figure 4–13 Fill Dialog Box in the Outline View

As shown in Figure 4–13, the outline view has additional dimension level fields. These 
are available whenever multiple dimensions are displayed in the outline view. You 
must choose which dimension level you want to fill with data. 

Note: The fill feature cannot be used for hyper-dynamic pick lists 
because the list of available selections may vary from cell to cell. 
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To use the fill feature, perform the following steps.

1. Select what you want to fill. In Figure 4–14, the Wp Sales R measure for 100 
Non-food Consumer Goods is selected. Its lower level has four positions within it.

Figure 4–14 Selecting a Cell to Fill

2. With a cell selected, click Fill in the Edit menu.The Fill dialog box appears. 

Figure 4–15 Fill Dialog Box

3. Choose the measure you want to fill in the Measure field. If only one measure was 
selected, as in the example above, only one option appears. 

Note: If no cells were selected before the fill feature was invoked, all 
cells within the measure that is selected in the Fill dialog box are filled. 
The fill applies to the current slice only.

If only a few cells were selected in the grid, only those selected cells 
are filled.



Clear and Fill Cells in a View

Cells 4-11

4. Enter a value in the Fill Value field. The measure you selected determines the type 
of data you can input as the fill value. For instance, if you chose a Boolean type 
measure, only true or false are available options for the fill value.

5. In the next field, select the level of the dimension that you want the fill to apply to. 
The name of this field varies according to the dimension you selected.

6. Select the spread method to use to distribute that fill value among the lower levels 
that belong to the dimension level you selected. For the spread method, choose 
among the following: 

■ Replicate: Any value filled into an aggregate level cell is replicated exactly to 
every base level cell that comprises the aggregate total. 

■ Even: Any value filled into an aggregate level cell is spread evenly among that 
cell's lower level constituents.

■ Proportional: Any value filled into an aggregate level cell is spread 
proportionally among all lower level constituent cells. This is based on the 
content of the cells before the fill.

■ Delta: The difference between the value pasted in the aggregated cell level and 
the original value of the aggregate cell level is spread evenly among all 
lower-level constituent cells.

7. Decide whether you want the fill value to be spread to cells that currently have an 
NA value. If you select Do not spread to NA Value, the fill value data is not 
spread to lower level cells that contain an NA value before the fill. The NA values 
are left intact, and the aggregate data is spread to the remaining lower level cells.

8. Click OK when finished. The Fill dialog box disappears.

In the view, the new fill value appears in the cell. It is shown in italics because it 
has not been calculated or saved yet.

Note: The Spread Method options are disabled when the base or 
lowest level of a dimension is selected. It is disabled because it is not 
possible to spread a fill value to lower levels if the lowest level is 
already selected.

Note: The Do not spread to NA value options is only enabled if the 
spread method option is enabled.

Note: If some of the selected cells were editable and some read-only, 
a message appears stating that the read-only cells were ignored. 
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9. Click Calculate. The view refreshes and the fill value is now distributed 
throughout the lower levels. In Figure 4–16, the fill value is distributed evenly 
among the lower levels.

Figure 4–16 Fill Value Distributed Among Lower Levels

Undo Fill
To undo a fill, click Undo in either the Edit menu or the quick access toolbar. However, 
after the Calculate function is invoked, the Undo option cannot revert the fill.

Modifying Cell Data
In the view, you can make changes to the data cells. You can make the edits by directly 
typing or updating a value in the cell, copying and pasting, or by importing changes 
from a file. You can also lock a cell value by clicking the Lock icon on the View toolbar. 
This ensures that any calculation performed during the cell edits do not affect the 
locked cell values.

In the Fusion Client, you can modify workbook data in the following manner:

1. Click on the cell you want to edit.

2. Once you enter or change the value in the cell, you can navigate to any other cell 
by double-clicking on that cell or using the following keyboard keys to navigate:

■ Enter to scroll Down.

■ Shift + Enter to scroll Up.

■ Tab to scroll Right.

■ Shift + Tab to scroll Left.

To learn how to modify data with math formulas, see Modify Data with Cell Formulas.
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Revert Cell
After an edit action, you can revert the cell to the last calculated value using the Revert 
Cell option in the right-click context menu. The Revert Cell feature is on a cell-by-cell 
basis. When you click Revert Cell, the edited cell reverts to the last saved or calculated 
value. Changes up to the last saved or calculated value are available in the Undo list.

Protection Processing
Protection processing is the process that makes some cells within a workbook 
read-only to ensure that during edits no conflicts occur within the RPAS engine in a 
Calculation Cycle. There are two types of protection processing:

■ Measure Protection Processing - Locks cells in all the displayed views based on the 
measures that have been edited.

■ Dimension Protection Processing - Locks cells based on the dimension 
intersections that have been edited.

Protection processing runs each time when a workbook with any locked cell/measure 
is opened, a cell is edited, a cell or measure is locked, and after each cell revert action. 
It runs only once when a group of cells are updated in one action. Protected cells or 
measures appear highlighted in a different color in the view. This is configurable 
feature.

Measure Protection Processing
In Measure protection processing, cells become read-only when you make changes to 
enough measures. This ensures that there are no more possible changes which may 
cause conflicts.

For example, consider six measures (A, B, C, D, and E) set up with the following two 
rules:

■  Rule 1 - A = B + C

■  Rule 2 - B = D + E

In this scenario, both A and B are read-only before any edits are applied. Although B 
appears to be editable, since there are no reciprocal expressions for B's relation to D 
and E, it is not editable. Measures C, D, and E, however, are editable.

Typically, rule definitions are set up to include all equivalent derivations of any 
expression. This ensures that you can edit all of the measures contained in any 
expression in the rule.

Considering the example above, Rules 1 and 2 will be configured as:

■ Rule 1 A=B+C, B=A-C, C=A-B

■ Rule 2 B=D+E, D=B-E, E=B-D

In this case, all measures are editable before you make any changes and the measures 
remain editable based on the edits you make.

Measure protection processing will lock all instances of a measure when any position 
of the other measures in the rule are edited. 

For example, consider the Rule 1 above in a typical Product, Location, Calendar 
dimension. 

When you edit the measure B for product 1, location 1, and week 1 and measure C for 
product 1, location 1, and week 2, the measure A becomes read-only for all products at 
all locations in every week.
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Dimension Protection Processing
Changes to cells at the aggregated levels occur during a Spread action that changes 
values down to the base intersection of a measure. Dimension protection processing 
protects the intersections (combination of levels) to ensure that all changes made 
during the Spread do not affect such a spreading path. 

Considering the typical retail dimensions, the process applies at 
product:color-location:store-calendar:week and product:style-location:region-calendar:month. 
These two intersections are on the same path from the root to leaf. If the location 
dimension has roots for both region/state and Store Volume, any edit to a cell in the 
Volume Group dimension causes all cells included in an intersection with a 
company/region/state/city to become read-only.

Figure 4–17 Location Dimension Example for Dimension Protection Processing

Dimension protection processing changes to the intersection of dimension and level 
are processed, and edits are allowed to cells as long as the edits are on one path from 
the root to the leaf level.
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Single Hierarchy Select
If a measure has been set up to have dimension values as inputs, the measure cell 
displays a drop-down list of positions, as shown in Figure 4–18.

Figure 4–18 Single Hierarchy Select

For example, a Week Mapping measure can be configured to have the week position of 
the Calendar dimension as an input. The selection of the dimension is configured in 
the domain configuration for a measure.

You can either select a value from the list or click Search at the bottom of the panel as 
shown in Figure 4–19.

Figure 4–19 Single Hierarchy Search
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The Search link launches the Search dialog box where you can search for specific 
values. The search dialog box automatically opens on the Advanced search option 
(Figure 4–20). 

Figure 4–20 Single Hierarchy Search Dialog Box, Advanced

To use the basic search, click Basic. The Search dialog box refreshes with the basic 
search tools (Figure 4–21).

Figure 4–21 Single Hierarchy Search Dialog Box, Basic
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Cut, Copy, and Paste
The cut, copy, and paste features provide flexibility to edit the workbook according to 
the business needs and transfer data from external applications (such as Microsoft 
Excel) to the system as well as from RPAS to those other applications.

To apply the an operation, select data from the view. After selecting the appropriate 
cells, you can cut, copy, and paste. For more information, see the Cut, Copy, and Paste 
sections or Cut, Copy, and Paste Special and Copy to External and Paste from External. 

Browser Settings
To cut, copy, and paste cell data to external applications, the browser must allow 
JavaScript access to the user’s clipboard. For Mozilla Firefox to have access to the 
user’s clipboard, perform the following steps:

1. Open a new window in the Firefox browser.

2. In the address bar, type about:config and hit Enter.

3. A warning message appears. Click I’ll be careful, I promise!.

4. The settings list appears. In the Filter field, enter signed.applets.codebase_
principal_support.

5. Double click the setting to change the value to true.

If access to the user’s clipboard is not enabled in Mozilla Firefox, users cannot use the 
cut, copy, and paste functionality and the following notification appears:

Figure 4–22 Clipboard Notification

Security Implications
By changing this browser configuration in either Firefox or Internet Explorer, all other 
applications that the user accesses through the browser can interact with the user’s 
clipboard. This may pose a security risk.

Notes: 

■ The maximum number of cells that can be copied, cut, or pasted is 
limited by memory. These operations should not be used to export 
entire workbooks. For more information, see Export.

■ You cannot cut or copy multiple cells when an edit is in progress. 
While an edit is in progress, only the current edited text is copied. 
To copy multiple selected cells, click Escape to exit and then select 
the multiple cells again. 
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Cut
Use this procedure to copy and remove data from the cells of a view in order to move 
the data to another view or other applications. Note that data created from deferred 
calculations can be cut. 

To cut data, perform the following steps:

1. Select all data cells in the pivot table that you want to cut. 

2. To cut the data and copy it to the clipboard, use one of these three methods:

■ From the Edit menu, click Cut. 

Figure 4–23 Edit Menu – Cut

■ Right-click and select Cut from the right-click menu. 

Figure 4–24 Right-click Menu – Cut

■ Use the shortcut command Ctrl + X.

3. Data from the selected cells is copied to the clipboard. The selected cells now 
contain NA values. 

4. To paste the data to other cells or to another application, see the Paste section.

Notes: You cannot cut data from non-editable or read-only 
measures.

Note: To remove the last deferred entries after using the cut option, 
right-click and select Revert Cell from the right-click menu. Or, use 
the shortcut option Ctrl + Z. You can also select the Undo option.
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Copy
Use this procedure to copy selected data to the application clipboard. Unlike the cut 
function, the copy function does not clear the data from the view cells. It keeps data in 
a clipboard which you can use to transfer data within RPAS as well as to an outside 
application such as Excel. It also helps you to transfer large amount of data easily. 
Copied cells have just the unformatted textual content transferred over. 

When copying from a cell to the clipboard, the string representation of the cells are 
copied to the clipboard so that it can be pasted into either other cells in the pivot table 
or to outside applications. Data containing deferred calculations can also be copied. 
There is no need to invoke Calculate before copying.

The following table shows what would be actually copied to the clipboard based on 
cell (measure) type.

To copy data, perform the following steps:

1. Select all data cells in the pivot table that you want to copy. 

2. To copy the data to the clipboard, use one of these three methods:

■ From the Edit menu, click Copy. 

Figure 4–25 Edit Menu – Copy

Table 4–1  Copied Data

Cell (Measure) Type Behavior

Boolean True, or checked, values are copied as 1. False, or unchecked, 
values are copied as 0.

Date The formatted date is copied and visible in the cell.

Integer The formatted number as displayed in the cell is copied. 
Prefixes and suffixes, such as $ or %, are copied as well 
separators. 

Picklist The value displayed in the cell is copied.

Real The number as displayed in the cell is copied. The format, such 
as $ and %, is copied as well.

Single dimension The value as displayed in the cell is copied.

String The value as displayed in the cell is copied.
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■ Right-click and select Copy from the right-click menu. 

Figure 4–26 Right-click Menu – Copy

■ Use the shortcut command Ctrl + C.

The selected cells are copied to the clipboard.

Note: If no cells are selected, the Edit menu and right-click options 
are grayed out. If no cells are selected when the Ctrl +C method is 
used, a warning message appears that states, "No positions have been 
selected for this operation." 
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Paste
Once you have copied or cut data from a view, you can paste it to other cells within the 
RPAS Fusion Client or you can paste it to an application such as Excel. The Paste 
option pastes the data that was last placed on the clipboard into the selected cells. 

To paste data, perform the following steps after you have copied or cut data from 
another location:

1. Select the cells in which you want to paste the data.

2. To paste the data into the cells, use one of these three methods:

■ From the Edit menu, click Paste. 

Figure 4–27 Edit Menu – Paste

■ Right-click and select Paste from the right-click menu. 

Figure 4–28 Right-click Menu – Paste

■ Use the shortcut command Ctrl + V.

Note: Although non-contiguous data cells can be copied, they cannot 
be pasted as non-contiguous cells. Data copied from non-contiguous 
cells does not maintain the pattern in which it was copied. For 
information about selecting non-contiguous cells, see Select a Group 
of Non-Contiguous Cells.

Note: If protection processing does not allow data to be pasted into 
the selected cell, the paste operation is aborted.
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Cut, Copy, and Paste Special
The following sections describe the cut, copy, and paste special features.

Cut Special
You can also cut data at the base level or higher level intersection across page slices. If 
multiple levels (product group, style, etc.) are represented in the pivot table selections, 
the cut option is performed at the lowest level actually selected. Once data is cut from 
the selected cells, you can paste data to other selected cells in the pivot table. To cut 
data, perform the following steps:

1. Select all data cells in the pivot table that you want to cut. 

2. From the Edit menu, click Cut Special. 

Figure 4–29 Edit Menu – Cut Special

3. The Cut Special menu appears. 

Figure 4–30 Cut Special Menu

Select from the following options:

■ Cut all Slices: This option is enabled only if the current workbook view 
contains more than one page slice. Otherwise, this options is disabled. When 
this option is selected, the cut operation behaves as if all positions in the slice 
dimension’s levels were selected prior to the cut. If the box is left unchecked, 
only the data from the current slice position is cleared and copied.

■ Cut selected level: This option cuts only the selected level of data.
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■ Cut at base level: This option allows you to cut the data at the measure’s 
lowest intersection.Although the cut function is performed at the base level, it 
seems that the aggregated level data has been cut since the data is rolled up.

Copy Special
You can also copy data at the base level or higher level intersection across page slices. 
Once data is copied from the selected cells, you can paste data to other selected cells in 
the pivot table. This feature allows you to view data at an aggregate level while 
copying data at a dimensional level not currently displayed or while selecting data 
from the current slice while copying data from all slices. You can copy data at the base 
level only or copy from all slices without selecting the base level data or without 
selecting data from entire slices.

To copy data, perform the following steps:

1. Select all data cells in the pivot table that you want to copy. 

2. From the Edit menu, click Copy Special. 

Figure 4–31 Edit Menu – Copy Special

Note: Data copied using the Copy Special option is not copied to the 
clipboard. It is copied to the RPAS server.
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3. The Copy Special menu appears. 

Figure 4–32 Copy Special Menu

Select from the following options:

■ Copy all slices: This option is enabled only if the current workbook view 
contains more than one page slice. Otherwise, this options is disabled. When 
this option is selected, the copy operation behaves as if all positions in the slice 
dimension’s levels were selected prior to the copy. If the box is left unchecked, 
only the data from the current slice position is copied.

■ Copy selected level: This option allows you to copy the level of data shown in 
the pivot table. The base level data from which the displayed data is created is 
not copied. 

■ Copy at base level: This option allows you to copy the base level data, which 
is the measure’s lowest intersection, which may not be displayed in the pivot 
table. If this option is not selected, the data is copied for the selected 
dimension level only.

4. The selected data is copied to the RPAS server. It is not copied to the clipboard. 
You can paste the copied data to other selected cells in the workbook multiple 
times. The copied data is available to the RPAS server until the workbook is 
closed. 
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Paste Special
Paste Special allows you to view data at an aggregate level while pasting it at the base 
level which is not displayed in the current slices. It provides a dialog where user can 
specify options for specialized paste functions.

If the levels of multiple dimensions are represented in the pivot table selections, the 
default paste option is performed at the lowest level. 

To use special paste, perform the following steps:

1. Before using paste, you have placed data in clipboard using Cut, Cut Special, 
Copy, or Copy Special from the Edit menu.

2. Select Paste Special from the Edit menu. 

Figure 4–33 Edit Menu – Paste Special

3. The Paste Special menu appears. 

Figure 4–34 Paste Special Menu
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Select from the following options:

■ Paste all slices: this option pastes data to all slices. If not selected, data is only 
pasted to the currently displayed slice position.

■ Do not paste NA values: If this option is selected, cut or copied NA data 
values are not pasted into the current selection. Whenever the system 
encounters an NA value in the copied data, that value is ignored and the data 
cell being pasted keeps its original value. In other words, when this option is 
selected, the current pivot table data is not overwritten by NA values. 

■ Paste selected level: This option only pastes data at the level of data shown in 
the pivot table.

■ Paste at base level: This option is enabled only if none of the base level 
measures are selected before the paste. This option enables you to paste data 
at the base level, which may not be currently displayed in the workbook. This 
allows you to view data at an aggregate level while pasting it at the base level.

4. Click OK. The selected data is pasted.

Copy to External and Paste from External
The Copy to External and Paste from External options allow data to be copied to and 
pasted from the system clipboard when the browser's security restriction prevents the 
Fusion Client from copying to and pasting from the clipboard. These options are 
needed for Mozilla Firefox and Google Chrome. 

Copy to External
Use the Copy to External feature when data from the pivot table needs to be copied to 
an application other than RPAS Fusion Client, such as Microsoft Excel or Notepad. To 
use the Copy to External feature, perform the following steps:

1. Select the cells to be copied in the pivot table.

Figure 4–35 Selecting Cells for Copy to External
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2. Click the Copy to External option in the Edit menu. 

Figure 4–36 Edit Menu – Copy to External

A dialog box appears, containing the copied data from the pivot table. The data is 
formatted correctly and is selected in a text field. 

Figure 4–37 Copy to External Source Dialog Box

3. To execute the browser's copy command, select the copy option from the browser 
menu or click CTRL+C. This copies the selected text from the text field to the 
system clipboard. Click Close.

The data can then be pasted into another application. It can also be pasted into the 
Fusion Client using the Paste from External option.
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Paste from External
Use the Paste from External feature when you need to paste data into the Fusion Client 
from the system clipboard. 

To use the Paste from External feature, perform the following steps:

1. Copy the data in the correct format from another application. 

2. Select the area to paste in the pivot table by selecting the upper left hand corner of 
the paste area or the exact cells to be pasted into. 

3. Click the Paste from External option in the Edit menu. 

Figure 4–38 Edit Menu – Copy to External

A dialog box appears, containing an empty text field. 

Figure 4–39 Paste from External Source Dialog Box

4. To paste the clipboard data into the text field, use the browser's paste command 
from the browser menu or click CTRL+V. 

5. Click the Paste button in the dialog box to paste the data in the selected pivot 
table.
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Read-only Measures
Read-only measures are defined during the domain configuration process. The 
read-only status can be set at both the base intersection and aggregate levels. 
Read-only measures are indicated as non-editable cells based on measure information 
retrieved when the workbook is opened. 

Read-only cells by default have a gray cell background color. This same default color 
used to indicate protection processing protected cells and elapsed cells. If the visual 
indicator for read only is changed to be different than the visual indicator for protected 
cells and the cell is both read-only and protected, then the cell will display the visual 
indicator for protected cells. These cells are not editable from the RPAS Fusion Client.

Figure 4–40 Read-only and Writable Measures

Locking and Unlocking
In addition to read-only workbooks and measures, the RPAS Fusion Client also 
provides a locking function in order to protect information. The locking function can 
be performed on cells, measures, and positions (a level in a dimension). 

Cell locking is available on any editable cell and invokes protection processing.

Measure locking is available on any measure and invokes protection processing.

Position locking is available on non-calendar dimensions and does not invoke 
protection processing.

Cells
The cell locking feature allows you to lock one or more editable cells in the pivot table. 
When a table cell is locked, calculations performed as a result of data manipulations 
do not affect the locked data values. This functionality allows you examine various 
what-if scenarios to determine the best course of action for planning or forecasting. 
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The RPAS Fusion Client iterates through the selected cells by measure, then by 
column, then by row. Locked cell information is immediately transferred to the RPAS 
Server. The locked cell information is saved with the workbook and locked cells 
continue to be locked upon reopening the workbook.

The locked status of a cell is indicated by the presence of a picture of a lock in the cell's 
left portion. Once an eligible cell is locked, the system determines whether the 
remaining table cells are eligible or ineligible to be locked. For instance, if all the 
children cells of any parent cell are locked, the parent cell cannot be locked. Instead, 
any edits to the parent cell are spread to the children cells based on the ratio of the 
values locked into the cells. If a cell becomes ineligible to be locked, the right-click 
menu associated with that cell does not contain the Lock option. Furthermore, any 
read/write cells that become ineligible for locking are made read-only.

You may choose to lock a data cell at any time to protect that cell from forced 
recalculations due to data manipulations elsewhere in the workbook. For example, 
you may want to see the effect of a change to sales value on inventory levels without 
forcing a change to receipts. Another example would be to change sales value at an 
aggregate level (such as month) and spread the result to only three of the four weeks 
that comprise that month. In this case, you could effectively hold the second week's 
sales value constant while spreading the aggregate-level increase among the remaining 
three weeks.

Protection processing executes against locked cells as if they were edited to their 
current value. Cell locks do not appear in the Undo list, which appears next to the 
Undo icon in the toolbar when more than one edit has been made. In addition, cell 
locks are not affected by the Undo option from the menus. Only cell value edit 
changes appear in the Undo list. Cell lock or unlock actions do not force a calculation 
cycle to execute.

Measures
The measure locking feature enables you to simultaneously lock all of the cells that are 
associated with a given measure in a view. A measure can be locked or unlocked when 
the header cell of the measure dimension is selected. As with individual cell locking, 
the locked status of each cell in the measure is indicated by the lock picture in each 
cell's left portion.

Locked measure information is immediately transferred to the RPAS Server. The 
locked measure information is saved with the workbook, so locking measures enables 
the save features of the workbook. The locked measure information is saved with the 
workbook and locked measures continue to be locked upon reopening the workbook.

Protection processing executes against a locked measure as if the measure has been 
edited to the same value.

If multiple measures are selected, they are locked or unlocked in row or column order. 
A measure may be locked even if it is already protected by protection processing.

Note: You can only make a selection at one level in the headers of a 
multidimensional header. The lock and unlock applies to the selected 
measure only. Locked measures are designated by a lock icon in the 
header text of the measure and in its cells.
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Positions
Position locking allows you to lock all measures in all displayed views along one or 
more positions of non-calendar dimensions. Cells along unlocked positions are still 
editable and can also change as a result of calculations. Locked positions are 
designated by a lock icon in front of the position name. The cells of the locked position 
are shaded as read-only. 

Figure 4–41 Locked Positions

Protection processing does not run against cells locked by a position lock. Unlike cell 
locks, a parent position becomes locked if all its children are locked. They become 
unlocked if any of their children are unlocked. Hidden children are considered when 
deciding if a parent position becomes locked. Unlocking or locking the parent unlocks 
or locks all the children. Hidden children positions are treated the same as visible 
children. Unlike a measure lock, the lock indicators do not show up in each of the cells, 
only in the header cells, even though the cells are displayed as read-only.

Locked position information is immediately transferred to the RPAS Server. The 
locked position information is saved with the workbook, so locking positions enable 
the save features of the workbook. The locked position information is saved with the 
workbook and locked positions continue to be locked upon reopening the workbook.

A position cannot be locked when locking it affects an edited or locked cell. A warning 
modal dialog is displayed and asks you to revert the affected edits and calculate the 
workbook or cancel the position locks. You are warned if a cell lock is affected and 
given the choice of canceling the position lock or unlocking the affected cell locks and 
continuing. If both edits and cell locks are affected, the you see both dialogs with the 
edit dialog appearing first. If you cancel the position lock from either dialog, then no 
action is taken against either locked or edited cells.
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Locking and Unlocking Methods
You can initiate locks by selecting a cell, measure, or position within the pivot table 
and then selecting one of three options to initiate a lock or unlock action. Locking and 
unlocking can be done through the following: 

■ Locking through the Right-click Context Menu

■ Locking through the Edit Menu

■ Locking with the Lock Icon

Locking through the Right-click Context Menu
One way that you can lock or unlock a cell, measure, or position is through the 
right-click context menu. Depending upon what is selected, the context menu 
determines whether the Lock or Unlock option is shown.

Figure 4–42 Locking: Right-click Context Menu

To lock using the context menu, perform the following:

1. Select a cell, measure or position. Once selected, it is shaded. 

2. Right-click the mouse. The context menu appears. If the cell, measure, or position 
is not already locked, the Lock option appears in the menu. 

3. Select the Lock option.

4. The selected item or items show a lock symbol.

Figure 4–43 Lock Symbol Shown in a Locked Measure
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Locking through the Edit Menu
Another way you can lock a cell, measure, or position is through the Edit menu. The 
Edit menu contains several locking options: 

■ Lock

■ Unlock

■ Unlock All Cells

■ Unlock All Measures

■ Unlock All Positions

Figure 4–44 Locking Options in the Edit Menu
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To lock using the Edit menu method, perform the following:

1. Select a cell, measure or position. Once selected, it is shaded. 

2. From the Edit menu, click the Lock option. 

Figure 4–45 Locking through the Edit Menu

The selected item or items show a lock symbol.
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To unlock using the Edit menu method, perform the following:

1. Select the cell, measure or position that is locked. 

2. From the Edit menu, click Unlock. 

Or, if you want to unlock all cells, measures, or positions, select Unlock All and 
choose the type you want to unlock.

Figure 4–46 Locking Options in the Edit Menu

Locking with the Lock Icon
The third way you can lock a cell, measure, or position is with the Lock icon in the 
toolbar. If some selected cells are already locked, they are ignored. If all selected cells 
are already locked, then the selected cells are unlocked instead of locked. If there is an 
error when locking any of the selected cells, measures or positions then an error 
message will be displayed and all of the applied locks will be reset. Cells that were 
already locked when the lock action started will remain locked.

To lock using this method, perform the following:

1. Select a cell, measure or position. Once selected, it is shaded. 

2. Click the Lock icon in the toolbar.

Figure 4–47 Locking with the Lock Icon

The selected item or items show a lock symbol.
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5
Formatting 

RPAS enables you to configure formatting settings of workbooks and save those 
settings for future use. You can configure some formatting within the Fusion Client as 
well as through the RPAS Configuration Tools. For more information configuring 
formatting with the Configuration Tools, see the RPAS Configuration Tools User Guide.

Formatting settings are created in the Format dialog box. In the Format dialog box, 
you can set and clear formats that apply to measures or dimensions. You can make 
changes to single or multiple measures and dimensions and apply those changes 
across one, many, or all views in the workbook.

Default Cell Formats
Some formatting cannot be altered in the Fusion Client. Read-only and protected cells 
as well as edited cells have default formats that are configured in a property file for the 
entire solution. The default formats are shown in Table 5–1.

Read-only cells are those which cannot be edited for any reason. In Figure 5–1, the cells 
of the Ly Sales R measure are read-only since the data is from last year and cannot be 
changed because it occurred in the past.

Protected cells are those which are read-only to ensure there are no more edits which 
may cause conflicts. In Figure 5–1, the cells of the Wp Sales AUR measure are 
protected because that measure is based on the data from Wp Sales U, which has been 
edited. For more information, see Protection Processing.

Table 5–1  Default Formats

Cell State Configurable Style Default Style

Read-only cells Cell Style Light grey background color.

Protected cells Cell Style Light grey background color.

Invalid cells Cell Style Dark grey background color.

Editable Cells Cell Style None (white background color).

Edited Cells Text Style Italic font, white background color.

Note: These default styles can be changed by editing the 
PivotTableStyles.properties file. For instructions on editing this file, 
see the "PivotTableStyles.properties File" section in the RPAS 
Administration Guide for the Fusion Client.
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Invalid cells are those which are at a level in the view below the base intersection of 
the measure. In Figure 5–1, the Wp BOS R measure has a base time level of Half, and 
so it is invalid at the week level. Therefore, the cell in the Sprg Fy2010 is editable, but 
the cells in the week columns are invalid.

Editable cells can be edited. In Figure 5–1, the cells of the Wp Sales R and Wp Sales U 
measures are editable and therefore have white cell backgrounds.

Once a cell has been edited, it retains its white cell background, but its font becomes 
italic. In Figure 5–1, the 2/13/2010 cell in the Wp Sales U measure has been edited.

Figure 5–1 Default Cell Formats

Modify Formatting
To access the Format dialog box, select an option in the Format menu.

Figure 5–2 Format Menu
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Or, right-click a dimension position in the page edge, column axis, or row axis.

Figure 5–3 Format Option in the Right-Click Context Menu

The Format dialog box appears. From the Format dialog box, you can modify measure 
styles, number formatting, exceptions, and dimension styles.

Figure 5–4 Format Dialog Box



Modify Formatting

5-4 Oracle Retail Predictive Application Server User Guide for the Fusion Client

Using the Filter to Find Measures
You can use the filter to find measures that share name commonality, type, or location. 
To use the filter, perform the following steps: 

1. Enter data in at least one of the following fields:

■ Name contains: Enter the word or phrase you want to find. The word or 
phrase is searched for in the entire label string, including any displayed 
attributes. This field is not case sensitive. 

■ Type: Select the type of measure you are searching for. Options are integer, 
real, date, text, Boolean, or all types.

■ Visible in: Select the view that you want to search in. You can select one, 
several, or all. 

In Figure 5–5, the string "Ly" is searched for in all types of measures within the 
Target Setting view.

Figure 5–5 Filtering Measures
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2. After you have entered the search criteria, click the blue arrow to the right of the 
Filter measures area. The measures that fit your search criteria are shown in the 
Measure field within the Apply measure format area.

Figure 5–6 Filter Results

Percent of Parent Measures
Percent of parent measures also appear in the Measure field. Some percent of parent 
measures have the same label as the measure from which it was created. Therefore, 
when displaying measure labels in the Measure field, a series of attributes may be 
used to describe the measure. The attributes are separated by a delimiter character.

The order of attributes is usually displayed as [Label] | [%] | [Aggregation]

For example:

■ Wp Gross Margin | | TOTAL

■ Wp Sales contrb Prod R% | % Product | TOTAL

■ Wp Sales contrb Time R% | % Calendar | TOTAL
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Modifying Measure Styles
From the Measure Styles tab of the Format dialog box, you can locate measures with 
the filter feature and then modify the measure style for those measures. Measures can 
be modified by altering the appearance of the headers cells. 

When the filter feature is not in use, the measures that appear in the Measure field 
within the Apply measure format section shows the measures that are contained in the 
current view.

Figure 5–7 Measure Styles Tab of the Format Dialog Box

Applying Measure Formats
Once you have found the measures you would like to change, you can edit or clear the 
existing formats for those measures and add new ones. To alter the measure format, 
perform the following steps:

1. Use the filter to find the measures you want to alter. See Using the Filter to Find 
Measures.

2. Select the measures from the Measure field. You can select one, several, or all.

Figure 5–8 Select Measures
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3. In the View field, select the views where these measures appear that you would 
like to alter.

4. In the Applies to field, select the part of the measure formatting that you would 
like to alter. 

5. In the Text color, Background color, Cell alignment, and Font style fields, choose 
the settings you want to apply.

6. When finished, click Apply and Close.

Figure 5–9 Applying Measure Formatting

The Format dialog box closes. In the view the new formatting is visible.

Note: The cell background for read-only measures cannot be altered.

Note: "Mixed" appears as a formatting option when two positions 
have different formatting settings. For instance, if a user has selected 
bold as the font style for one measure and italics for another, when the 
user selects both measures at once, the font style drop-down displays 
"mixed." The mixed option occurs only when there are multiple 
selections on the left side, and the properties on the right side contain 
a drop-down list.
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Figure 5–10 Formatted Measures
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Modifying Number Formatting
From the Number Formatting tab of the Format dialog box, you can locate measures 
with the filter feature and then modify the number formatting for those measures. 
When the filter feature is not in use, the measures that appear in the Measure field 
within the Apply measure format section shows the measures that are contained in the 
current view.

Figure 5–11 Number Formatting Tab of the Format Dialog Box

Applying Number Formats
Once you have found the measures you would like to change, you can edit or clear the 
existing number formats for those measures and add new ones. To alter the number 
format, perform the following steps:

1. Use the filter to find the measures you want to alter. See Using the Filter to Find 
Measures.

2. Select the measures you want to alter from the Measure field. You can select one, 
several, or all.

Figure 5–12 Select Measures
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3. In the View field, select the views where these measures appear that you would 
like to alter.

The Quick format field contains four preconfigured number formats: currency, 
percentage, thousands, and millions. If one of these formats suits your needs, 
select it. The values in the Prefix, Suffix, and Scale fields adjust accordingly. If the 
quick formats do not suit your needs, continue to the next steps to adjust the 
remaining fields.

In the Prefix field, enter a string up to seven characters that you want to appear 
before number. Prefixes are often used for a currency symbol. 

In the Suffix field, enter a string up to seven characters that you want to appear 
after the number. Suffixes are often used to denote scaling factors (k, m) or 
percentages (%).

In the Scale field, enter the factor to be applied to displayed values to produce an 
internal value. For instance, you can use this to display a fractional value as a 
percentage with a scale factor of 0.01

Select the Show separator option to use the thousands separator in the view. The 
thousands separator depends upon the regional setting. Often though, it is a 
comma.

In the Precision field, enter the number of places to the right of the decimal to be 
displayed. The precision value for integers is 0.

When finished, click Apply and Close. The number formatting is applied to the 
selected measures in the view.

Table 5–2  Quick Format Options

Quick Format Description

Currency The currency format as a scale factor of 1 and a prefix of $. It has a 
precision of 2. For example, $1223.45.

Percentage The percentage format has a scale factor of 0.01 and a suffix of %. It has a 
precision of 0. For example, 16%.

Thousands The thousands format has a scale factor of 1000 and a suffix of k. It has a 
precision of 0. For example, 1,235k.

Millions The millions format has a scale factor of 1000000 and a suffix of M. It has a 
precision of 0. For example, 1,235M.

Note: Below the Precision field is an example of how the formatted 
number appears.
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Modifying Exceptions
Exception formatting is used for numeric measure types. Exception formatting defines 
the styles to be applied to a cell’s value when it falls outside a defined range.

From the Exceptions tab of the Format dialog box, you can locate measures with the 
filter feature and then modify the exception formatting for those measures. When the 
filter feature is not in use, the measures that appear in the Measure field within the 
Apply measure format section shows the numeric measures that are contained in the 
current view.

Figure 5–13 Exceptions Tab of the Format Dialog Box

Applying Exception Formatting
1. Use the filter to find the measures you want to alter. See Using the Filter to Find 

Measures.

2. Select the measures you want to alter from the Measure field. You can select one, 
several, or all.

Figure 5–14 Select Measures
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3. In the View field, select the views where these measures appear that you would 
like to alter.

4. Use the Condition and Value fields to set the parameters of the exception.

■ In the Condition field, select one of three options:

– < =: Use this to select values that are less than or equal to Value 1.

– > =: Use this to select values that are greater than or equal to Value 1.

– Not between: Use this option to select values that do not fall between 
Value 1 and Value 2. This is a way to set both the <= and >= conditions to 
have the same formatting styles.

■ In the Value fields, enter the following:

– If you chose <= or >= as the Condition, enter the value in Value 1 that the 
exception needs to be greater or less than.

– If you chose Not between as the Condition, enter the values that the 
exception should not fall between in Value 1 and Value 2.

5. In the Text color, Background color, and Font style fields, choose the settings you 
want to apply.

6. When finished, click Apply and Close. The exception formatting is applied to the 
selected measures in the view.

Notes: 

■ If entering a value that has a scale factor, such as a percentage, 
enter the raw value. For example, if you want to enter 10%, you 
should enter .1. 

■ Exceptions applied to integer measures must have integer values 
for Value 1 and Value 2. Otherwise an error occurs. 

Note: Below the Font Style field is an example of how the formatted 
exception appears.
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Modifying Dimension Styles
From the Dimension Styles tab of the Format dialog box, you can specify header styles 
for one, a few, or all dimensions. The filter measure feature is not available on this tab 
because dimension formatting applies only to dimensions, not measures.

Figure 5–15 Dimension Styles Tab of the Format Dialog Box

Applying Dimension Styles
1. In the Dimension field, select which dimension that you would like to alter. You 

can select one, a few, or all.

2. In the View field, select the views where these dimension styles should be used.

3. In the Text color, Background color, and Font style fields, choose the settings you 
want to apply.

Note: Measure appears as an option in the Dimension field. If you 
choose Measure as the dimension, you can set a default header style 
for measures, but not a default cell style. 

Note: Below the Font Style field is an example of how the formatted 
dimension header appears.
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4. In the Header Wrap Length field, define the number of characters for the header 
width. The header text wraps at the first white space after the limit.

5. When finished, click Apply and Close.

The Format dialog box closes. In the view the new dimension styles are visible.

Saving Formats
RPAS allows you to configure formatting settings of workbooks and views and save 
those settings for future use. You can configure the appearance of measures, grids, 
axes, and exceptions; set the type-specific parameters of measures; and enable 
synchronized page scrolling.

The following settings are saved in the formatting database:

■ Dimension and measure tile locations

■ Visible dimension levels (aggregate roll-ups)

■ Measure order and format

■ Format menu settings

■ Slice selection

■ Block view vs. outline view

Note: Even if you select Off in the picklist, headers can still be 
manually wrapped in the pivot table.

Note: Split level/dimension settings and the sort order without 
attributes setting are not saved in the formatting database.
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Format Levels
The formatting settings you create are stored along with the workbook in the domain. 
Because workbook formats are saved just as workbooks are, they can be made 
available to other users. Saved formats are used when being new workbooks.

 There are three availability levels a workbook format can be saved to:

■ For Just Me: The workbook format is available only to the user who created it.

■ For My Group: The workbook format is available to all members of the user’s 
group. Users who belong to more than one group can choose which group to make 
the workbook available to. 

■ For Everyone: The workbook format is available to all users in the organization. 

Figure 5–16 Save Format

When a new workbook is created, the most specific set of workbook formats that 
apply are taken as the new workbook format. When a workbook formatting set exists 
for an availability level (user, group, world), the entire set is taken from that level and 
applied to the new workbook. For example, if there are user settings for the current 
user, all workbook formatting from those user settings are applied.

Note: When a new workbook is created, the user’s default group is 
used for the group availability level check.
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Saving Options
When saving formatting settings, you can save all formatting, Save All, or just save the 
changes you have made, Save Changes Only.

Figure 5–17 Save Format Options

Save Changes Only
The Save Changes Only option allows you to save only what you have changed so that 
a subset of the workbook's formatting is merged into the existing saved format. This 
subset consists of changes made since the workbook was first constructed. You also 
have the option to include changes inherited from any of the saved styles. During the 
merge, any conflicting settings in the existing saved format are overwritten while 
non-conflicting settings are left alone. This allows multiple users to manage group and 
template styles: users can write to the same files without necessarily writing over the 
changes of others. 

Since formatting is saved incrementally, non-conflicting changes to formatting can be 
propagated throughout different levels. When a workbook is created, a superset of all 
changes in the applicable user, group, and template level styles is made with all 
conflicting changes resolved by the lowest level, user. Therefore, if a change is made to 
the group formatting, each group member sees it in every new workbook as long as a 
conflicting formatting setting does not exist at the user level.

Note: The saved formats you inherited may have changed since you 
built your workbook. You should have a strategy in place for 
managing multiple users who save to the group and template formats.
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Save All
The Save All option can be used if you do not want to inherit any changes made to a 
higher level. Selecting Save All writes an entry for each formatting setting whether or 
not you changed it from the group or template format. Essentially, this blocks any 
changes that were made at a higher level from the level to which you are saving. 

Once Save All is applied to the user format, that user is not able to see changes made 
to the group or template level formatting again. Accordingly, if Save All is applied to a 
group format, then no member of the group can see the changes made to the template 
level. However, each group member maintains access to any user level overrides that 
he or she saved. Since Save All overrides all formatting, the only way to revert to Save 
Changes Only is to delete the formatting at that level.

Inheritance Formatting
You can select the check boxes on the Save Format dialog box to inherit the formatting 
information from other levels. 

For example, for any setting at the group level that needs to be propagated to the 
template level, select View and then Save Format for All. The Save Format dialog box 
appears. Click Save Changes Only, and then select Include Inherited Group 
Formatting.

For any setting at the template level that needs to be propagated to the user level, 
select View and then Save Format for User. The Save Format dialog box appears. 
Click Save Changes Only, and then select Include Inherited Template Formatting.

Deleting Formats
You can delete formats that you created. To delete a format, perform the following 
steps.

1. Open the workbook that has the formatting you want to delete.

2. From the View menu, click Delete Format.

3. Choose the level you want to delete it from.

■ For Just Me: The workbook format is deleted only for the user who created it.

■ For My Group: The workbook format is deleted for all members of the user’s 
group. 

■ For Everyone: The workbook format is deleted for all users in the 
organization. Only administrators can save for everyone.

Note: Chart format data is not merged into the existing saved format 
as other data is. It is saved as Save All (overwriting existing 
formatting), even if Save Changes Only is selected.
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6
Dimensions, Levels, and Positions 

Dimensions describe the top-to-bottom relationship between the levels or positions of 
the dimensions in RPAS. They reflect the dimensions set up at your business and being 
used by the merchandising solutions.

RPAS supports many alternative dimensions that provide different roll ups and help 
analyze the data from a different perspective.

Levels are subdivisions of a dimension. Levels group information of the same type. 
For instance, a level within the Product dimension could be Department. The 
Department level would contain all the departments (men’s shoes, women’s shoes, 
children’s shoes) that exist.

Positions are

This chapter describes the various tasks you can perform with dimensions, levels, and 
positions. It includes the following sections:

■ Showing/Hiding Levels

■ Expanding and Collapsing Levels

■ Level Splitting

■ Showing/Hiding Positions
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Showing/Hiding Levels
Dimension levels that appear in the view are based on the configuration. Only levels 
configured for a view are visible in the view. In the Fusion Client, you can show or 
hide the levels in the following ways:

■ Right-click menu

■ Levels tab in the Dimension dialog box

Using the Right-Click Menu
To show or hide levels using the right-click menu:

1. In the view, right-click anywhere in the area that displays the dimension.

2. Select the level you want to show or hide.

Figure 6–1 Right-Click Menu

The view updates to display or hide the relevant level.

Note: You can perform the same action by accessing the right-click 
context menu in the page edge.
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Using the Dimension Dialog Box 
To show or hide levels and select the display type using the Dimension dialog box, 
perform the following steps:

1. In the page edge, click the dimension tile you want. The Dimension dialog box 
appears.

Figure 6–2 Dimensions Dialog Box, Levels Tab

2. Click the Levels tab. The Levels tab shows all the levels and alternate roll-ups and 
enables you to select one or more levels within a single dimension.

3. Select the levels you want to show or hide using the check boxes to the left of the 
level name.

4. Select Block View or Outline View as the display type.

5. Click OK to apply the changes and close the dialog box.

Or, click Apply to apply the changes and continue working on the other tabs.
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Expanding and Collapsing Levels
Although you can click the Expand/Collapse buttons next to each level displayed in 
the view, it can be tedious and time consuming if there are many levels. The Fusion 
Client includes the following options to help you expand/collapse levels easily:

■ Right-click menu

■ Levels Tab in the Dimension pop-up

Using the Right-Click Menu
To expand/collapse levels using the right-click menu:

1. Select the levels you want to expand or collapse, and right-click.

2. On the right-click menu, select Expand Level(s) or Collapse Level(s).

Figure 6–3 Expand Level and Collapse Level Options in the Right-click Menu
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Using the Dimension Dialog Box
To expand or collapse levels using the Dimension dialog box:

1. In the page edge, click the dimension tile of the dimension you want to collapse or 
expand. The Dimension dialog box appears.

Figure 6–4 Dimensions Dialog Box, Levels Tab

2. On the Levels tab, select the relevant check box to expand or collapse all the 
positions at the level. To expand or collapse all positions at all the visible levels, 
click the Expand/Collapse shortcut menu on the top.

Figure 6–5 Expand/Collapse Shortcut Menu

3. Click OK to apply the changes and go back to the view.

You can also click Apply to apply the changes and continue working on the other 
tabs.

Note: The expand/collapse check boxes are enabled only for the 
levels selected.
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Level Splitting
Level splitting allows you to group dimension data based on position characteristics 
defined by attribute values.

For instance, for an attribute that describes the climate of a store location, you could 
group those store locations by climate using a level split.

Figure 6–6 Level Splitting Example
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As shown in Figure 6–6, the attribute values (cold, mild, hot) act as positions within 
the level split. The level split has its own dimension tile. You can move this tile just as 
you would a dimension tile because level splits behave like independent dimensions. 
See Creating a New Split for more information. 

Behind the scenes, a hierarchy is built based on attribute values at the level that is split, 
allowing the aggregations to be correctly calculated and providing a spreading for 
values edited at aggregated levels. Other capabilities, such as locking and protection 
processing, are fully functional on the positions of the split.

Creating a New Split
Before you can create a level split, you must have an attribute, dynamic or static, to 
base the split on. To learn how to create a dynamic attribute, see Creating Dynamic 
Attributes.

1. Click the Level Splitting icon in the toolbar. In the Level Splitting menu, select 
New Split.

Figure 6–7 Level Splitting Icon

Or, right-click a position. The right-click context menu appears. Select Level 
Splitting. In the Level Splitting menu, select New Split.

Figure 6–8 Level Splitting Option in the Right-Click Context Menu



Level Splitting

6-8 Oracle Retail Predictive Application Server User Guide for the Fusion Client

2. The New Split dialog box appears (Figure 6–9). Select the following options:

■ Dimension: Select the dimension that you want to split.

■ Level: Select the level that you want to split into groups.

■ Attributes: Check the attribute that you want to use to group the levels into 
and use the Move icon to move it to the right side. You can move more than 
one attribute to the right side and use the up and down arrows to order them.

If you want to create a new attribute, use the New Attribute icon.

■ Apply To: Select the view that the split should apply to. You can choose one 
view or all views.

■ Split Name: To save the split for later use, enter a name and click Save Split.

Figure 6–9 New Split Dialog Box
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3. When finished, click OK. The dialog box closes, and the levels are split, as shown 
in Figure 6–10.

Figure 6–10 New Level Split
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Clearing a Split
To clear or remove a split from the view, perform the following steps:

■ Click the Level Splitting icon in the toolbar. Then select Clear Split.

Figure 6–11 Clearing a Split with the Level Splitting Icon

■ Or, right-click a position. In the right-click context menu, select Level Splitting. 
Then, select Clear Split. 

Figure 6–12 Clearing a Split with the Right-Click Context Menu

The split is removed from the view.
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Selecting a Split
To apply a saved split to a view, perform the following steps:

1. Click the Level Split icon in the toolbar and then click Select Split.

Figure 6–13 Select Split: Level Splitting Icon

Or, right-click a position. In the right-click context menu, select Level Splitting 
and then Select Split.

Figure 6–14 Select Split: Right-Click Context Menu
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2. The Select Split dialog box appears. Select the split you want to apply to the view.

Figure 6–15 Select Split Dialog Box

3. Click OK. The split is applied to the view.

Editing a Split
To edit an existing split, perform the following steps:

1. Ensure that a split appears in the view. 

2. Right-click the level split or click the Level Split icon.

3. From the Level Split menu, select Edit Split.

Figure 6–16 Editing a Level Split

4. The Edit Split dialog box appears.

5. Edit the split as necessary and click OK.
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Showing/Hiding Positions
Positions that appear in the view are based on the configuration. Only positions 
configured for a view are visible in the view. In the Fusion Client, you can show or 
hide the positions using the Dimension dialog box.

To show or hide positions:

1. In the Page Edge and Tiles area, click the dimension tile you want. The Dimension 
dialog box appears.

2. In the Dimension dialog box, click the Show and Hide tab.

Figure 6–17 Dimension Dialog Box, Show and Hide Tab

3. Select the positions you want by holding down the CTRL or SHIFT key.

4. Click the Add/Remove arrows to move positions between the Visible Positions 
and Hidden Positions areas.

Or

Drag and drop the positions between these areas.

5. Click OK to apply the changes and go back to the view.

You can also click Apply to apply the changes and continue working on the other 
tabs.

Use the Add All and Remove All arrows to move all the positions between the 
Visible Positions and Hidden Positions area.
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7
Measures 

Measures represent the events or measurements that are recorded, while the positions 
in the dimensions provide a context for the measurement. Measures are defined based 
on the business rules set in the application. The dimensionality of a measure is 
configured through the definition of its base intersection, which is the collection of 
levels (one per appropriate dimension) defining the lowest level at which the 
information is stored for the measure.

Measure names are completely configurable and typically named using a convention 
that identifies each component and the meaning of the measure.

This chapter describes the various tasks pertaining to measures. It includes the 
following sections:

■ Showing/Hiding/Reordering Measures

■ Insert Measures
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Showing/Hiding/Reordering Measures
Measures that appear in the view are based on the configuration, and only measures 
configured for a view are visible in the view. In the Fusion Client, you can show, hide, 
or reorder the measures using the dimension dialog box.

To show or hide measures:

1. In the page edge, click the Measure tile. 

Figure 7–1 Measure Tile

The Measure Dimension dialog box appears.

Figure 7–2 Measure Dimension Dialog Box, Show and Hide Tab

2. On the Show and Hide tab, select the measures you want by holding down the 
Ctrl or Shift key.

3. Click the Add/Remove arrows to move measures between the Visible Measures 
and Hidden Measures areas.

Or, drag and drop the measures between these areas.

4. Click OK to apply the changes and go back to the view.

You can also click Apply to apply the changes and continue working on the other 
tabs. Use the Add All and Remove All arrows to move all the measures between 
the Visible Measures and Hidden Measures area.
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To reorder measures:

■ On the Show and Hide tab, select the measures you want to reorder, and click the 
First, Up, Down, or Last arrows until you get the order you want.

Figure 7–3 Measure Dimension Pop-up > Show/Hide Tab

Note: Sorting the measures in the Visible Measures area does not 
reorder the measures in the view. To reorder the measures, use the 
First, Up, Down, and Last arrows.
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Insert Measures
When you want to see a measure that is not part of the current workbook, but you do 
not want to build a new workbook to include that measure, you can use the Insert 
Measures feature. To use this feature, there must be an active view that defines the 
view where the measures will be inserted. You do not have to calculate the workbook 
to insert measures. The measures available for insertion depend upon the following 
criteria:

■ Measure is configured to be insertable (the Insertable attribute is true).

■ Measure security grants read/write or read-only access rights to the user.

■ Measure has a storage database.

■ Measure is not a recalc measure.

■ Its base intersection is compatible with the base intersection of the workbook.

■ Measure is not already present in this workbook.

Insert Measures Dialog Box
The Insert Measures dialog lists the labels of the measures available to be inserted. 
This list is initially sorted in ascending alphabetical order, but you can click the 
heading to change the sorting. You can also use the find option to locate a measure. 
Only measures that can be inserted in the current view appear in the list. 

This dialog launches only if there is at least one insertable measure for the workbook. 
If not, an error dialog appears, stating "There are no measures to insert."

Figure 7–4 Insert Measures Dialog Box Menu

Note: The visibility and editability of the inserted measure and any 
dependent measures will vary based on the permissions granted to 
the user for the inserted or dependent measures.

For more information about measure permissions, see the "Measure 
Rights View" section of the RPAS Administration Guide for the Fusion 
Client.



Insert Measures

Measures 7-5

Accessing the Insert Measures Dialog Box
There are three ways to access the Insert Measure dialog box: the Edit Menu, the 
Context Menu, and the Show and Hide tab in the Measure Dimension dialog box. 

From the Edit Menu
In the Edit menu, click Insert Measures.

Figure 7–5 Insert Measures Option in Edit Menu

From the Right-Click Context Menu
Right-click a measure in the pivot table. The right-click context menu appears. Click 
Insert Measures.

Figure 7–6 Insert Measures Option in Right-Click Context Menu
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From the Show and Hide Tab
Click the Measures tile. 

Figure 7–7 Measure Tile

The Measure Dimension dialog box appears. On the Show and Hide tab, click the 
Insert Measures icon. 

Figure 7–8 Insert Measures Option on Show/Hide Tab 

Inserting a Measure
To insert a measure, perform the following steps:

1. Open the Insert Measures dialog box from the Edit menu, Context menu, or Show 
and Hide tab, as described in Accessing the Insert Measures Dialog Box.

2. In the Insert Measures dialog box, select the measure you want to insert. 

To select more than one measure, hold the Ctrl key and click the measures. As the 
measures are selected, they become shaded.

3. Click OK.

The dialog box closes, and the selected measures are inserted in the workbook for the 
current view.

When inserting measures from the Show and Hide tab, you have the additional option 
of specifying where you want the measures to be inserted.

1. Click the Measure dimension tile. The Measure Dimension dialog box appears.

Figure 7–9 Measure Dimension Tile
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2. On the Show and Hide tab, in the Visible Measures section, select the measure that 
you want the inserted measure to appear under.

Figure 7–10 Selected Measure in the Show and Hide Tab

3. Click the Insert Measures icon. 

Figure 7–11 Insert Measures Option on Show/Hide Tab 

4. The Insert Measure dialog box appears. Select the measures you want to insert and 
click OK. The dialog box closes.

5. The inserted measure appears below the measure selected in Step 2.

Figure 7–12 Inserted Measure
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About Inserted Measures
Here are a few things you should know about inserted measures.

■ After measures are added to a particular view, they cannot be added to other 
views in the workbook. They do not appear in subsequent Insert Measures 
dialogs.

■ After a measure is added to a workbook, it cannot be deleted. The only way to 
revert the workbook is to close it without saving and open a previously saved 
version.

■ Each measure selected for insertion is added to all the views for the view and 
made visible. 

■ If the inserted measure has dependent measures, those are inserted as well. 
Dependent measures are measures configured to act as upper or lower bounds of 
the inserted measure. If the dependent measures have dependent measures 
themselves, those measures are also inserted. 

Dependent measures are inserted in the view but are not automatically made 
visible in the views. You can make them visible by moving them from the Hidden 
Measures section to the Visible Measures section in the Show and Hide tab of the 
Measure Dimension dialog box.

■ Inserted measures have only a load rule. Inserted measures with writable access 
can be edited within the workbook, but because they have no commit rule, the 
edits cannot be committed to the domain.

■ Inserted measures can be formatted, and that formatting can be saved to a 
template. However, the inserted measures are not added to the template and are 
not present when new workbooks are built. If measures are inserted later, they can 
still use the formatting saved in the template.
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8
Measure Profiles 

Measure profiles are customized groups of measures that you can create and use in 
views. Instead of adding or removing measures from the default measure list each 
time you work with a particular view, you can save that customized group of 
measures as a measure profile and load it into the view. By creating a measure profile 
for each set of measures that you frequently use, you reduce the amount of time it 
takes to setup a view. 

Measure profiles are created at the view level and are available in all views and copies 
of that view. Measure profiles are saved as part of the formatting. Depending on how 
you save the formatting, you can make your measure profiles available to other users. 
For more information, see Formatting.

Creating a Measure Profile
To create a measure profile, you first need to select the visible measures for the view. 
Once you have selected the measures that you want to appear in the measure profile, 
you can create the measure profile.

1. Open the view that you want to create a measure profile for.

2. Click the Measure dimension tile.

Figure 8–1 Measure Dimension Tile
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3. The Measure Dimension dialog box appears. On the Show and Hide tab, use the 
arrows to move the measures to and from the Visible Measures box. Place only the 
measures that you want to appear in the measure profile in the Visible Measures 
box.

Figure 8–2 Moving Measures to the Visible Measures Box

4. Adjust the order of the measures in the Visible Measure box by using the First, Up, 
Down, and Last arrows located to the right of the Visible Measure box. This step is 
optional. 

5. Once all of the measures that you want to appear in the measure profile are in the 
Visible Measures box, you can save the measure profile using one of two methods:

Method 1: 

a. In the Profile Name field below to the Visible Measures box, enter the name of 
the measure profile. 

b. Click Save Profile.

Figure 8–3 Measure Profile Name Field
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Method 2: 

a. Click OK. The Measure Dimension dialog box closes and the view is visible 
again. The measures that you selected to be visible are shown in the view. 

b. Click the Measure Profile icon in the View toolbar.

Figure 8–4 Measure Profile Icon

c. The Measure Profile menu appears. Click Save.

Figure 8–5 Measure Profile Menu: Save

6. The Save Profile dialog box appears. Enter the name of the measure profile and 
click Save. 

Figure 8–6 Save Profile Dialog Box

Note: Existing measure profiles are visible in the Save Profile dialog 
box.
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Regardless of the method you use, you cannot create a measure profile that contains 
the same measures and order of an existing profile. If you do create a measure profile 
that is identical to an existing one, a warning message appears and asks if you would 
like to rename the existing measure profile. Click OK to save it with the name you 
entered in the Profile Name field. Click Cancel to leave it as the existing name.

Figure 8–7 Measure Profile Warning Message

Similarly, you cannot save a measure profile with the same name as an existing 
measure profile. 

Applying Measure Profiles
To apply an existing measure profile to a view, perform the following steps:

1. Click the Measure Profile icon in the view tool bar.

Figure 8–8 Measure Profile Icon

2. The Measure Profile menu appears. Click Select.

3. A list of existing measure profiles appears next to the menu. The measure profile 
in use is designated by a blue dot. Select the measure profile you want to apply. 

Figure 8–9 Measure Profile Menu: Select
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The view refreshes and the measures of the measure profile appear.

Updating Measure Profiles
To update an existing measure profile, perform the following steps:

1. Click the Measure tile.

Figure 8–10 Measure Tile

2. The Measure Dimension dialog box appears. On the Show and Hide tab in the 
Visible Measures section, select the profile you want to update from the list.

Figure 8–11 Measure Profile List

The Hidden Measures and Visible Measures lists are updated based on the profile 
selected. 

3. Update the profile by adding or removing measures from the Visible Measures list.

4. When finished updating the profile, click Save Profile.

5. A warning message appears and asks if you want to overwrite the content of the 
measure profile. Click OK.

Figure 8–12 Update Measure Profile Warning Message

6. Click OK at the bottom of the Measure Dimension dialog box to return to the view. 

The measure profile is updated.
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Deleting Measure Profiles
You can delete measure profiles that you have created. However, you cannot delete the 
default profile. To delete an existing measure profile, use one of the following 
methods:

Deleting a Measure Profile: Method 1
1. Click the Measure Profile icon in the View toolbar.

Figure 8–13 Measure Profile Icon

2. The Measure Profile menu appears. Click Delete.

3. A list of existing measure profiles appears next to the menu. Click the measure 
profile you want to delete. 

Figure 8–14 Measure Profile Menu: Delete

4. A warning message appears, asking if you want to delete the profile. Click OK.

Figure 8–15 Measure Profile Warning Message: Deleting Profile

The measure profile is deleted.
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Deleting a Measure Profile: Method 2
You can also delete a measure profile from the Save Profile dialog box:

1. From the Save Profile dialog box, select the measure profile you want to delete.

2. Click Delete.

Figure 8–16 Deleting from the Save Profile Dialog Box

3. A warning message appears, asking if you are sure you want to delete the profile. 
Click OK.

The measure profile is removed from the list.
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9
Dynamic Position Maintenance 

Dynamic Position Maintenance (DPM) enables users to dynamically add, edit, or 
remove positions to a non-calendar position while working in a workbook. These 
user-defined or informal positions are updated in both the domain and workbook 
dimensions. Positions added by the user are referred to as informal positions. 
Positions added during the load process are referred to as formal positions. 

When an informal position is to be made formal, the position's name (label is not 
necessary for the update to occur) must first be updated to reflect the correct position 
name that will be loaded during the load process. Prior to the load, an administrative 
utility is run against the environment to change the status of a position from informal 
to formal (see the RPAS Administration Guide for the Fusion Client for more information 
on the updateDpmPositionStatus utility). This process enables the loading and 
purging of that position through the hierarchy load process and disables further DPM 
activities on the position.

DPM Restrictions 
 The following limitations for DPM exist:

■ You cannot add a dynamic position to the calendar dimension. Due to the rolling 
nature of calculations for measures, were you to add a position to the calendar 
dimension, data for those measures and other measures that depend on them 
would be inconsistent.

■ In a global domain environment, the DPM process cannot be used for maintaining 
positions at or above the partition level. For example, if a global domain is 
partitioned by department that rolls up to division, you cannot use DPM 
functionality to add informal departments or divisions.

■ In a global domain environment, the DPM process cannot be initiated from 
workbooks in the master domain.

■ Positions from alternate dimensions that are not already in the workbook cannot 
be imported into the workbook to be used as parents for new DPM positions.

Note: Access to the DPM menus and dimensions that DPM 
functionality can be applied is determined in the solution and 
workbook configuration (see the RPAS Configuration Tools User Guide 
for more information on enabling DPM functionality). 
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Add a New Position to a Dimension
To add a new position to a dimension, perform the following steps: 

1. From the Edit menu, select Position Maintenance and then the dimension to which 
you want to add a dynamic position.

Figure 9–1 Position Maintenance Option in Edit Menu
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Or, right-click the position level to which you want to add a new position. The 
right-click context menu appears. Select Position Maintenance and then select 
Add Position.

Figure 9–2 Adding a Dynamic Position

2. The Add Dynamic Position window appears. Click the Edit Position link in the 
dimension level to which you want to add a position.

Figure 9–3 Add Dynamic Position Window
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3. The Add [Position] dialog box appears. Enter the name and label of the new 
position. Click OK.

Figure 9–4 Add Position Dialog Box 

4. The Add Dynamic Position window refreshes with the new position shown in the 
selected dimension level.

Figure 9–5 Added Dynamic Position

Note: The aggregate information (district, region, company, and so 
on) is populated only if the Add Dynamic Position window is 
accessed from the right-click menu. If you accessed it from the Edit 
menu, these positions are empty.
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5. Modify the parent levels of the new position. You can select an existing parent 
level or create a new (dynamic) one. To do either, click the link in a level above the 
new position. 

Figure 9–6 Modifying the Parent Level

6. Perform one of the two options:

■ To select an existing position as the parent of the dynamic position, select one 
from the drop down list or search for one using the search link. For more 
information about the search feature, see Using the DPM Search Feature.

Figure 9–7 Selecting an Existing Parent Level
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■ To create a new (dynamic position) parent level, type the name of the new 
parent in the Label field and select the Create New Position option.

Figure 9–8 Creating a New Dynamic Parent

The Name field is enabled. Enter the name of the new parent.

Figure 9–9 Creating a New Dynamic Parent, Name Field

When finished, click OK.

7. Repeat step 6 for other parent levels.

8. When finished, click Save and Close. Or, if you want to add another position, click 
Save and Next.
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The Add Dynamic Position window closes. The view refreshes and the new position is 
shown in blue.

Figure 9–10 New Dynamic Position in View

Note: If the active view has a PQD and the Automatically Evaluate 
Position Queries option is enabled, the newly created position may 
not appear in the view if its default value is set to false.
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Modify an Informal Position
 After dynamic positions are added to the hierarchy, the DPM process allows you to:

■ Change the parent of a dynamic position to a different formal or dynamic parent.

■ Update the position name and position label.

1. Right-click the dynamic position you want to modify.

2. From the right-click menu, select Position Maintenance, then Modify Position.

Figure 9–11 Modifying a Dynamic Position

Note: Only dynamic positions can be modified using the DPM 
feature. The Modify menu is not visible if there are no dynamic 
positions in the workbook.
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3. The Modify Dynamic Position window appears. Select the existing dynamic 
position and modify the position label or position name. Or, select any parent of 
the dynamic position to change the parent assignment.

Figure 9–12 Modify Dynamic Position Window

4. When finished, click Save and Close. 
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Delete an Informal Position
After a dynamic position is added, you can delete it and all child positions to which it 
is a parent. 

1. Right-click the dynamic position you want to delete. 

2. From the right-click menu, select Position Maintenance and then Delete Position.

Figure 9–13 Deleting a Dynamic Position

3. The Delete Dynamic Position dialog box appears to indicate that the dynamic 
position that will be deleted and any child positions associated with it that will be 
deleted as well. Click OK.

Figure 9–14 Delete Dynamic Position Dialog Box

The dialog box closes, and the dynamic position is removed from the view.

Note: Only dynamic positions can be deleted using the DPM feature. 
The delete option is not be visible if there are no dynamic positions in 
the workbook.
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Using the DPM Search Feature
When selecting the parent level that a new dynamic position belongs to, you can use 
the search feature to find the desired level.

1. Click a level above the dynamic position you are creating, as shown in 
Figure 9–15. 

Figure 9–15 Using the DPM Search Feature

2. The Add/Select [Level] dialog box appears. Click the Label field to access the 
Search link. 

3. Click the Search link.

Figure 9–16 Search Link for DPM Search
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4. The Search and Result dialog box appears (Figure 9–17). Use the search features to 
search for a position. You can search with the following options: 

■ Starts With

■ Does Not Contain

■ Not Equals

■ Equals

■ Contains

■ Ends With

Enter a value in the search field and click Search.

Figure 9–17 Search and Result Dialog Box
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5. The dialog box refreshes with the positions that match the search. Select the 
position you want and click OK.

Figure 9–18 DPM Search Results

The Search and Result dialog box closes, and the selected position is filled in the 
Add/Select [Level] dialog box.
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10
Dynamic Attributes 

Dynamic attributes are attributes you can create in the RPAS Fusion Client. Dynamic 
attributes describe a particular dimension and level based on a measure’s value at 
specified levels of other dimensions. The dynamic dimension attributes can be used 
for level splitting, sorting, and displaying in the workbook. For instance, you can 
create an attribute based on the weekly sales that describes stores in terms of their 
weekly sales rate: low, average, or high. 

Once you have created a dynamic attribute, it is saved to the domain. It is added to the 
workbook during workbook build process if the dimension is present and if the 
following conditions are met:

■ The attribute is accessible by the user.

■ The source measure exists in the workbook.

■ The other positions of this attribute fit into the workbook context.

The attribute data is only updated when the attribute is used. 

This chapter describes the various tasks you can perform with dynamic attributes. It 
includes the following sections:

■ Accessing the Define New Attribute Dialog Box

■ Creating Dynamic Attributes

■ Managing Dynamic Attributes

■ Updating Attribute Values
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Accessing the Define New Attribute Dialog Box
Dynamic attributes are created in the Define New Attribute dialog box. You can access 
this dialog box in three ways: with the attributes icon in the toolbar, from the 
right-click context menu, or from the dimension dialog box.

Attributes Icon in the Toolbar

Figure 10–1 Attributes Icon

From the Right-Click Context Menu
1. Right-click a dimension level. The right-click context menu appears.

2. Select Create New Attribute.

Figure 10–2 Create New Attribute: From the Right-Click Context Menu

From the Dimension Dialog Box
1. Click a dimension tile. The dimension dialog box appears.

2. Click the Show Attributes and Sort tab.

3. Click the New Attribute icon in the Available Attributes section.

Figure 10–3 Create New Attribute: From the Dimension Dialog Box



Creating Dynamic Attributes

Dynamic Attributes 10-3

Creating Dynamic Attributes
To create a dynamic attribute, perform the following steps:

1. Access the Define New Attribute dialog box using the icon, right-click context 
menu, or the dimension dialog box as described in the Accessing the Define New 
Attribute Dialog Box section.

Figure 10–4 Define New Attribute Dialog Box

2. Enter the following information:

■ Attribute Name: Enter a name for the attribute. The name must be unique 
across a level for a selected dimension and fewer than 80 characters.

■ Dimension: Select the dimension that the attribute should apply to.

■ Level: Select the level of the dimension chosen in the Dimension field. This is 
the level that the attribute should apply to.

■ [Dimension1] and [Dimension2]: These fields display the dimensions that 
were not chosen in the Dimension field. Select the dimension levels and 
positions that the attribute should be applied to for each.

■ Measure: Select the measure that the attribute should be based on.

■ Is Displayed: Check the check box if you want the created attribute to be 
displayed in the view after it is created. If not selected, the attribute is created 
but not visible. To make the attribute visible at a later time, select it for display 
in the Dimension window as described in Select Attributes for Display.

■ Clustering: Select No Clustering if you want the data from the measure to be 
replicated in the attribute. Select Clustering if you want to group the 
dimension by the values of the measure data. 
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■ Number of clusters: Choose the number of groups that you want the attribute 
to create. This option is visible only if clustering is selected.

■ Group Label: Enter the label of the attribute that you want to apply to that 
cluster of data. Specify how the clusters should be defined by entering a range.

■ Auto Fill: Click this button to automatically create the range for each cluster.

3. Click OK.

The attribute is added to the pivot table.

After you have created the attribute, you can sort the positions by attribute. For more 
about sorting, see Attribute Sorting.

Figure 10–5 Dynamic Attribute: Clustering Example

Another way to use dynamic attributes is to duplicate measure data in the attribute. 
For instance, if you had a Climate measure that describes the climate of a location, you 
could create an attribute based on that measure and select No Clustering, as shown in 
Figure 10–6 and Figure 10–7.

Note: The cluster options are only available for real and integer 
measures.
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Figure 10–6 Define New Attribute: No Clustering 

Figure 10–7 Dynamic Attribute: Non-Clustering Example
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Managing Dynamic Attributes

Managing Dynamic Attributes
After you have created a dynamic dimension attribute, you can edit, copy, rename, or delete it using the Manage 
Dynamic Attributes dialog box.

The Manage Dynamic Attributes dialog box displays all attributes for the selected dimension and level. You can search 
for attributes by using the attribute filter. You can search all dimensions and levels by selecting All in the Dimension 
drop-down list. Or, you can search by a particular dimension, level, and measure.

Figure 10–8 Filtering Attributes

By default, attributes for the innermost layer of the selection on the pivot table are listed. If there are no attributes for 
the selected level, attributes for all visible levels of the selected dimension are displayed. 

If there are no attributes for the selection dimension, all attributes across all dimensions are shown. If there are no 
attributes across any dimension, a message states that there are none. 
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Accessing the Manage Dynamic Attributes Dialog Box
To access the Manage Dynamic Attributes dialog box, perform the following steps:

1. Right-click in the content area.

2. The right-click context menu appears. Select the Manage Dynamic Attributes 
option.

Figure 10–9 Manage Dynamic Attributes

3. The Manage Dynamic Attributes dialog box appears.

Figure 10–10 Manage Dynamic Attributes Dialog Box

From the Manage Dynamic Attributes dialog box, you can edit, copy, rename, delete, 
or create attributes.
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Editing Dynamic Attributes
To edit a dynamic attribute, perform the following steps:

1. Access the Manage Dynamic Attributes dialog box as described in Accessing the 
Manage Dynamic Attributes Dialog Box.

2. Select the attribute you want to edit and click the Edit icon.

Figure 10–11 Editing a Dynamic Attribute

3. The Edit Attribute dialog box appears. Make changes to the attribute information. 
For details about the fields, see Step 2 of the Creating Dynamic Attributes section.

Figure 10–12 Edit Attribute Dialog Box

4. When finished, click OK.
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Copying Dynamic Attributes
To copy a dynamic attribute, perform the following steps:

1. Access the Manage Dynamic Attributes dialog box as described in Accessing the 
Manage Dynamic Attributes Dialog Box.

2. Select the attribute you want to copy and click the Copy icon.

Figure 10–13 Copying a Dynamic Attribute

3. The Copy Attribute dialog box appears. Enter the name of the new attribute. The 
name must be unique across the level for a selected dimension and fewer than 80 
characters.

Figure 10–14 Copy Attribute Dialog Box

4. Click OK.

Renaming Dynamic Attributes
To rename a dynamic attribute, perform the following steps:

1. Access the Manage Dynamic Attributes dialog box as described in Accessing the 
Manage Dynamic Attributes Dialog Box.

2. Select the attribute you want to rename and click the Rename icon.

Figure 10–15 Renaming a Dynamic Attribute
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3. The Rename Attribute dialog box appears. Enter the new name. The name must be 
unique across the level for the selected dimension and fewer than 80 characters.

Figure 10–16 Rename Attribute Dialog Box

4. Click OK.

Deleting Dynamic Attributes
To delete a dynamic attribute, perform the following steps:

1. Access the Manage Dynamic Attributes dialog box as described in Accessing the 
Manage Dynamic Attributes Dialog Box.

2. Select the attribute you want to delete and click the Delete icon.

Figure 10–17 Deleting a Dynamic Attribute

3. A warning message appears. Ensure that you have selected the correct attribute 
and click Delete.

Figure 10–18 Delete Attribute Dialog Box

The attribute is deleted from the list.
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Updating Attribute Values
If data in the base measure of the attribute has changed, you may need to recalculate 
the attributes to see the updated data. To do this, use the Update Attribute Values 
option in the View menu or the Update Attribute Values and Level Splits icon in the 
toolbar.

Figure 10–19 Update Attribute Values Option 

Figure 10–20 Update Attribute Values Icon 

The values of the user defined attributes must be recalculated based on the user edits. 
The update icon and menu are enabled only when there are attributes displayed that 
need to be recomputed based on user edits. Clicking the update option or icon 
recalculates all sort attributes and level splits displayed in the workbook based on user 
edits since the attribute or dimension split was applied to the data.
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11
  Sort, Find, and Position Queries 

Easily sorting and finding data is essential when working with workbooks that contain 
thousands of items, hundreds of locations, and an endless number of dates. Being able 
to put this data in a logical order or find a specific piece of information is what makes 
planning possible.

 This chapter describes the ways you can sort, find, and query data: 

■ Sort

– Simple Sort

– Attribute Based Sort

■ Find

■ Position Query

Sort
There are two kinds of sort: simple and attribute sort. Both allow you to put the data in 
a meaningful order.

Simple Sort
You can sort positions in a level by using the sort icons on the toolbar or the arrows 
that appear on column headers. The positions are sorted based on the values of a 
measure's slice for that level. This sorting can be done without defining additional 
attributes. 

The sort occurs along a single measure, using only a single level in the sort. The 
sorting is limited to the current view, thus providing the user an ability to see the same 
data sorted differently in different views. Sorting is only available in the pivot table or 
split view. It is not available in the graph view. 

Notes: 

■ A slice is valid if it involves only one measure and if it has a 
unique value for each position along the level being sorted 
(meaning that one position along all other dimensions in the 
measure's intersection has been selected).

■ Simple sort cannot be applied to positions in a dimension along 
the page axis. However, you can pivot the desired dimension to 
either row or column axes, execute the sort along the desired slice, 
and then pivot the sorted dimension back to the page axis. 
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Once you have selected the desired valid slice of measure data that you want to sort, 
the sorting arrows are enabled on the toolbar and in the columns, as shown in 
Figure 11–1.

Figure 11–1 Sort Arrows

Once you click one of the sort arrows, the selected positions are sorted according to the 
measure's values in the selected slice. 

The Sort Ascending icons in the toolbar and columns order the data so that the lowest 
number appears at the top of the list and the highest at the bottom. Once the data is 
sorted, the column header is shaded gray and the Sort Ascending arrow is shaded 
dark gray, as shown in Figure 11–2.

Figure 11–2 Sort Ascending

The Sort Descending arrows order the data so that the largest number is at the top. 
Again, after the data is sorted, the column header is shaded gray and the Sort 
Descending arrow is shaded dark gray (Figure 11–3).
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Figure 11–3 Sort Descending

Sorting should reapply after operations that do not change the data. If you show or 
hide positions, change the rollup, or switch the mode from outline to block view or 
vice-versa, you should reapply the sort. Since a pivot operation resets the selected sort 
slice, you must reselect a valid slice and sort again. 

If you use the View Attributes and Sort tab to perform a attribute sort, the simple sort 
is overridden. Previous sorts (either attribute-based or simple sort-based) are not 
maintained after a new simple sort. 

Data editing operations like calculate, update, or refresh do not reapply the sort, and 
the positions remain in the last sorted order.

If you edit a cell and attempt to sort using the toolbar icon, a message appears that 
states the edited cells need to be calculated before the sort operation can take place. 

Figure 11–4 Uncalculated Cells Warning Message

You can choose to calculate, revert, or cancel:

■ Calculate: The positions are sorted after the calculate operation is performed. 

■ Revert: The edits are reverted and the sort is performed. 

■ Cancel: The sort operation is canceled. 

If you have edited the cells and attempt to sort using the column header icon, the page 
refreshes without applying the sort and the header no longer displays the icon to sort. 
If you perform other operations such as show/hide after the edits that have caused the 
page to refresh, the sort icon does not appear in the column header until the edited 
cells are calculated. 
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Sorting By Column Headers
You can sort data by mousing over the pivot table column headers to make the 
ascending and descending sort icon appear. 

Figure 11–5 Sort Icons in Column Header

Click one to sort the positions along the row-edge based on the vales of a measure's 
slice for that dimension. The column is highlighted and the column header displays a 
selected sort icon (ascending or descending) based on the sort direction.

Figure 11–6 Sort Icons in Column Header After Sort

The sort icons do not appear on the column headers if the slice (with the selected 
column) is invalid. For example, when the measures are on the row edge, the sort 
icons do not appear on the column headers. Also, when there is more than one 
dimension on the column axis, the sort icons appear only on the inner layer.

Sorting with the Toolbar Icons
The sort icons in the toolbar are enabled if there is a valid slice involving a single 
measure being selected. Select either a column or row and click the one of the sort 
icons. The toolbar icons are more useful for sorting the rows.

Figure 11–7 Sort Icons in Toolbar

The selected position is sorted according to the measure's values in the selected slice. If 
the rows were sorted, the row just appears selected. If a column was selected, a sort 
icon appears in the column header. 

If you select an invalid slice, for instance, multiple rows or columns are selected, the 
sort icons are enabled but clicking them results in an error message that states the 
selected slice is not a valid slice for sorting.
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Sorting in Outline Mode and Block Mode
You can sort in either the outline or block mode. Sorting in the outline mode sorts all 
the positions as well as the positions within those positions. Sorting in block mode, 
however, only sorts the highest aggregate position. 

Outline Mode  If the pivot table is in outline mode, that is, it is displaying aggregate 
levels of the dimension in separate rows or columns in the same grid, the aggregate 
positions are sorted as well as the positions within the aggregate positions.

In Figure 11–8, note how the 5 Pocket Capri position is listed first because it is larger 
than both the 5 Pocket Frayed Jeans and Bohemian 5 Pocket Jeans groups. Then, 
within the 5 Pocket Capri group, the style/sizes are listed in order of greatest to least, 
the "Antique 10 An" being the largest of all the departments.

Figure 11–8 Sorting in Outline Mode

Block Mode  If the pivot table is in block mode, that is, it is displaying the dimension 
levels in separate rows or columns but not the aggregate levels, the simple sort still 
orders the aggregrate levels as well as the dimension levels within them. 

In Figure 11–9, note how the 5 Pocket Capri, 5 Pocket Frayed Jeans, and Bohemian 5 
Pocket Jeans groups do not have an aggregated number in the column. Nevertheless, 
the groups are still ordered greatest to least as are the style/sizes within those groups.

Figure 11–9 Sorting in Block Mode
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Sorting Across Page Edge
When the positions are sorted on a specific slice, by default the positions stay in the 
previously sorted order as you page through the positions along the page-axis. In 
other words, the positions are not resorted based on the new selections in the 
page-axis. If you want to reapply the sort when paging through positions along the 
page-axis, you must enable the Resort Positions on Pagination option in the View 
menu.

For example, there are two slices that display the sales of five stores: one slice displays 
data for the denim 5 pocket capri, the other displays data for the antique capri. Before 
sorting, the five stores are listed in alphabetical order, as shown in Figure 11–10. When 
the user scrolls from one slice to the other, the stores stay in alphabetical order.

Figure 11–10 Two Unsorted Slices

When a user sorts the denim slice by descending order, the stores are reordered so that 
the store with the highest sales, Berlin, is at the top. If the user scrolls to the antique 
slice, Berlin is still at the top despite the Chicago store having the highest sales. This is 
because the positions stay in the same order by default. They are not resorted 
according to the data. This is shown in Figure 11–11.

Figure 11–11 Sorted Slices, Default Setting
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However, if the Resort Positions on Pagination feature is turned on, the positions are 
resorted according to the data. The Resort Positions on Pagination option is located in 
the View menu. 

  Figure 11–12 Resort Positions on Pagination

When the Resort Positions on Pagination feature is turned on and the first slice is 
sorted by descending order, when the user scrolls to the next slice, it too is sorted, as 
shown in Figure 11–12.

Figure 11–13 Sorted Slices with Resort Pagination

Notes: 

■ Simple sort cannot be applied to positions in a dimension along 
the page axis. However, you can pivot the desired dimension to 
either row or column axes, execute the sort along the desired slice, 
and then pivot the sorted dimension back to the page axis. 

■ The Resort Positions on Pagination option is saved with the 
workbook formatting. For more information about formatting and 
how formatting is saved, see Saving Formats. 
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Undo Sort Using the Context Menu
If you want to undo a sort, right-click and select Undo Sort from the right-click context 
menu. 

Figure 11–14 Undo Sort in Context Menu

You do not need to select the exact slice; any slice on the sorted dimension renders the 
Undo Sort option. Once you select the Undo Sort option, the simple sort is no longer 
applied and the positions appear in the original sort order that was shown when the 
view was first opened. 

Attribute Sorting
An attribute is a piece of information that further describes a position at a given level. 
For example, the SKU level of the product dimension could have three attributes 
associated with it: label, color, and price. This means, any SKU in this product 
dimension could have attribute values of:

■ LABEL: SKU00012 - Cashmere Sweater

■ COLOR: Pale Blue

■ PRICE: $62

Label is the only attribute that is required, but positions in a level can be described 
with any number of attributes. Once established, attributes can be displayed in the 
view if desired. The dimension's attributes can also be used to decide display sort 
order for positions within that level.

But before you can sort by attributes, you need to select the desired attributes to 
appear in the view.
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Select Attributes for Display
To see the available attributes that you can sort by, perform the following steps:

1. In an open view, click the dimension tile of the dimension which you want to sort 
by an attribute. In Figure 11–15, the Location dimension has been selected. 

Figure 11–15 Dimension Tiles

2. The Dimension window appears. Click the Show Attributes and Sort tab. 

3. In the Show Attributes and Sort tab, the available attributes for the dimension are 
listed in both the Available Attributes and Sort Attributes sections on the left. The 
attributes currently shown in the view are listed on the right. Those shown 
attributes have a check mark beside them.

Figure 11–16 Show Attributes and Sort Tab

a. Select the attributes that you want to appear in the view from the  
Available Attributes section at the top. 

b. Either click the right arrow to move the attribute to the Visible Attributes box 
on the right side, or drag the attribute to the right side. 

c. Repeat the same process for the attributes you want to sort by moving them to 
the Sort Attributes section at the bottom.

d. When finished, click OK. This saves your changes and closes the window. 

If you want to make additional changes on other tabs in the Dimension 
window, click Apply instead. This saves your changes but leaves the 
Dimension window open so you can go to other tabs.
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The attributes now appear in the workbook as shown in Figure 11–17.

Figure 11–17 Attributes Shown in a View

Displaying Attributes in Views
In the Fusion Client, you can display attributes in both the outline and block views. 

Outline View
In the outline view, you can view the attributes in either the row edge or the column 
edge. In outline view, for each dimension, the first layer displays attributes with 
display order 1 merged across levels. This layer also features the expand/collapse 
icons. By default, beyond first layer, each displayed attribute is rendered as a separate 
layer.

Views  You can view attributes in two places in the outline view: row edge and column 
edge. 

Figure 11–18 Outline View: Attributes in Row Edge
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Figure 11–19 Outline View: Attributes in Column Edge

When in the outline view, the default ordering of displayed attributes across levels is 
from higher to lower levels. For example, the attribute from higher district level is 
displayed first followed by lower store level.

For each dimension, the first layer always features the expand/collapse icons. In 
addition, the label itself is an attribute, and you can choose to display it in any order or 
hide it altogether (as long as there is at least one attribute displayed for each level). For 
example, you can choose the label attribute for both the store and district levels as 
second in display order, with SKU Label reordered before District Label.

Attribute labels can be combined with levels and shown as Level Label (Attribute 
Label) format. For example, the 'Store (Fmt)' shown in Figure 11–19. The attribute label 
hovers above the layer. However, hovering on first layer, would just display the 
dimension label.
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Merge/Split  You can choose to display multiple attributes as a single layer by using the 
merge option in the right-click context menu. Once you have merged two attributes 
together, you can split them using the split option in the context menu option.

To merge two attributes, perform the following:

1. Right-click one of the attributes you want to merge.

2. In the context menu that appears, select Merge and then select the other attribute 
from within the Merge menu. See Figure 11–20 for an example.

Figure 11–20 Merging Attributes

The attributes merge together and appear in the same row or column. Note how the 
Store Count and Store Format attributes are now in the same column in Figure 11–21. 

Figure 11–21 Merged Attributes

Note: The Merge/Split feature is only available in the outline view, 
not the block view. 
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Only attributes belonging to different levels can be merged. You cannot perform 
Merge/Split actions on the first layer in the outline view because this layer displays 
the first attribute across levels merged.

To split two attributes that have been merged, perform the following:

1. Right-click a merged row or column.

2. In the context menu, select Split, and then select one of the merged attributes from 
within the Split menu.

Figure 11–22 Splitting Attributes

In the outline view, you can merge or split attributes across levels using the right-click 
context menu. However, the first layer would always display attributes with display 
order one merged across levels. In addition, you cannot merge attributes that belong to 
the same level.

Note:  The merge/split feature is session-only and is lost once you 
close the session. 
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Block View
In block view, each layer renders one attribute, and all displayed attributes of a level 
are shown consecutively in user chosen display order as shown in Figure 11–23. The 
first layer in each dimension features the expand/collapse icons.

Figure 11–23 Block View:  Attributes in Row Edge

Figure 11–24 Block View:  Attributes in Column Edge

In block view, the attribute ordering would always follow the User chosen display 
order. The User would be allowed to perform reordering using drag-drop, but that 
would be equivalent to User navigating to View Attributes and Sort tab and changing 
the attribute display order. 

You can also right-click an attribute and hide in block view. This completely removes 
the associated layer from view. 

As in outline view, the expand/collapse icons would be on first layer for each 
dimension and User could choose to display Label attribute it in any order, or even 
hide it altogether (as long as there is at least one attribute displayed for each level).
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Page Edge
You can also see the attributes of a dimension that is in the page edge. The attributes 
are displayed on page edge and are separated by a bar separator as shown. The 
attribute labels would be added to the level display on hover as shown. 

Figure 11–25 Attributes on the Page Edge

Reordering Attributes  In both the outline and block views, you can reorder attributes 
across levels by dragging an attribute row or column to a different location. 

To change the order of attributes, perform the following:

1. Roll over the area above the row until the attribute label appears.

2. Click and drag the attribute label. As you move the attribute row or column, 
available locations where you can drop the attribute are shaded gray. 

Figure 11–26 Reordering Attributes

Note:  The reordering feature is persisted in the session only. Once 
you close the session, the new order is lost. 
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3. When the location where you would like to move the attribute is shaded gray, 
drop the attribute. 

Figure 11–27 Reordered Attributes

Hiding Attributes  You can hide an attribute in a view by right-clicking a cell within that 
attribute’s row or column. In the context menu, select Attributes and then select Hide 
Selected Attribute(s). 

Figure 11–28 Hiding Attributes

Note:  The hiding feature is session-only and is lost once you close 
the session. 
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Attribute Based Sort
You can sort positions in a level using any of the level's attributes. The View Attributes 
and Sort tab enables you to choose attributes used for sorting. There you can also 
define sort direction (ascending/descending) and the order that the chosen attributes 
are to be applied during the sorting process. For example, the SKUs in the product 
dimension can be sorted primarily by price, and then within those prices by label.

The sort is applied dimensionally across multiple levels. For example, if the product 
dimension has the levels company, division, class, style-color, and SKU, the positions 
within the company level are sorted first based on selected sort attributes for company, 
and then positions within each division applying the division’s selected sort attributes, 
and so on.

As with display, if an attribute is defaulted as sort attribute for a level, the default sort 
is always applied if you have no other selection. The attribute-based sort order does 
not over-ride any current simple sort selection, unless you:

■ Navigate to the View Attributes and Sort tab and click OK or Apply. This 
reapplies the attribute-based sort even if you do not make any changes on this tab.

■ Select Undo Sort in the right-click context menu.

For measure dimensions, the User defined Sort Order is applied by default. You can 
choose the Disable User defined Sort Order option on the Show/Hide tab to disable 
the default behavior.

Find
The find feature enables you to search for words, partial words, or phrases within the 
rows, column, and page axis of an active view. The search does not include the data 
within the view.

The find feature locates the phrase you searched for and shades it gray. If the matched 
position is not visible because it’s hidden under a scroll bar, the view is automatically 
scrolled to reveal it. The search is performed through collapsed or hidden positions. 
When a matched position is found, the parent is expanded and the matched position is 
shaded gray.

The find feature can be accessible four ways:

■ The Find option in the right-click context menu

■ The Find option in the Edit menu

■ The shortcut Ctrl + F

■ The Find field in the view toolbar
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Find from the Right-Click Context Menu
To use the find feature from the right-click context menu, perform the following:

1. Right-click a measure, position, or attribute label to see the right-click context 
menu. Note that right-clicking on a data cell does not activate the find feature in 
the right-click context menu. 

2. Click Find.

Figure 11–29 Find in the Right-Click Context Menu

3. The Find window appears. 

Figure 11–30 Find Window
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Enter the following: 

■ Search For:  Enter the phrase you want to find.

■ Match Case: Select this option if you want the search to locate phrases that use 
the same case as the phrase you entered.Leave it unchecked if you want the 
search to find all phrases that match yours, regardless of case.

■ Whole word Only: Select this option if you want the search to find your 
phrase in a whole word rather than a partial one. 

For instance, if you were searching for the letter U and you selected the Whole 
word Only option, then the search would find the Wp BOS U measure, but it 
would not find the letter U within the Wp BOS AUR measure.

■ Only within...: This option enables you to search in a variety of ways:

– Search for your phrase only within one or more measures, positions, or 
attributes that you right-clicked in Step 1. When this option is selected, the 
search ignores all matches outside of those measures, positions, or 
attributes.

– Search within multiple positions by selecting more than one member to 
search through.

– Find a phrase within a specific member and within its own dimension.

– Find a phrase within a specific member and within another dimension.

– In outline mode, use this option to find positions within different levels 
(style, SKU).

– In block mode, use this option to find positions within the same level 
(either style or SKU).

■ Dimension: Specify what dimension you want to search within. This is a 
required step.

■ Levels: Specify which level of the dimension you want to search within. You 
can choose a specific level or you can choose All to search all levels. The 
search is performed level by level, not through parent and child. For example, 
when there are two levels, style and SKU, the search is performed in the style 
level first and then the SKU.

4. When finished, click Find Next. The view refreshes. If a match is found, it is 
shaded gray. 

Figure 11–31 Match Shaded Gray by Find Feature

5. Click Find Next to see the next match. You can click Find Previous at any time to 
see matches you have already seen. 
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If a match is not found, the following message appears:

Figure 11–32 No Matches Found Message

Find from Edit Menu or Ctrl + F
Using the Find feature from the Edit menu or Ctrl + F works similarly to the 
right-click context menu. 

1. Once you have opened a workbook, click Find in the Edit menu or enter Ctrl + F. 
It is not necessary to select anything in the view.

2. The Find window appears. Enter the information as described in Step 2 of the Find 
from the Right-Click Context Menu section.

3. When finished, click Find Next. The view refreshes behind the Find window.

Note: A similar message appears when you reach the end of the 
search and asks if you would like to start the search again. 

Note: If no position was selected in the workbook, the Dimension 
field will not have a dimension automatically selected. You must 
select a dimension from the list to perform the search.
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Find from the View Toolbar
The Find field within the View toolbar is a quick alternative to using the Edit or 
Context menus.

Figure 11–33 Find Field in the View Toolbar

To use the find option in the workbook toolbar, perform the following:

1. Enter a phrase in the Find field.

2. Click the Find Options arrow to manage the search parameters. This is an optional 
step. If you skip this step, the search is performed on all dimensions. 

■ Dimension: Select the dimension you want to search in or select All to search 
all dimensions. 

■ Match Case: Check this option if you want the matches to have the same case 
that you entered.

■ Whole word Only: Check this option if you want to find your phrase in a 
whole word rather than a partial one. 

3. Click either the Previous or Next arrows to begin your search.

Position Query
Position queries are preconfigured rules that filter data so that only positions that 
fulfill the requirements of the query are shown in the view. Position queries are 
configured in RPAS Configuration Tools by an administrator. For instance, if an 
administrator has configured a position query to filter for the stores with sales greater 
than $3500, you can turn on that position query to display only those stores.

The dimension that the query is based on must be in the page edge (Z axis). This is 
known as the driving dimension. The dimensions in the X and Y axes are known as the 
query dimensions. The data in the query dimensions is based on the current position 
of the driving dimension. 

When a position query is applied to a view, the positions in the query dimensions  
(X and Y axes) that fulfill the requirements of the query for the particular position of 
the driving dimension (Z axis) are the only ones shown in the view. All other positions 
are automatically hidden. 



Position Query

11-22 Oracle Retail Predictive Application Server User Guide for the Fusion Client

When more than one driving dimensions are present, all of the driving dimensions 
have to be in Z-axis for the position query to execute. If one or more driving 
dimensions are taken out of the Z-axis and placed in X or Y axes, associated position 
queries are not executed. A given view can have more than one position query, driven 
by one or more dimensions in the Z-axis and driving different dimensions in the X and 
Y axes. 

Figure 11–34 Position Query Icon

When the position query filter is turned off, the icon appears flat. When you mouse 
over the icon, the roll-over text says "Filter [Rule]."

When a position query filter is turned on, the position query icon is depressed. When 
you mouse over the icon, the roll-over text says "Remove filter for [Rule]." 

Figure 11–35 Position Query Rollover Status
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Using Position Queries
If you have a workbook that is configured to have a position query, you can filter to 
view only the positions that fulfill the requirements of that query.

For the purposes of this example, a Sales Total workbook has been configured to 
include a position query to filter locations with the Store measure selected. As shown 
Figure 11–36, the Sales view contains several items; some have Store selected and some 
do not.

Figure 11–36 Position Query Example, Filter Off

When you click the Position Query icon, the view refreshes and only the items with 
the Store measure selected are visible. 

Figure 11–37 Position Query Example, Filter On
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Position Query Filtering Without Calculating
If you edit the measure data and attempt to apply the position query filter without 
calculating first, a warning appears.

Figure 11–38 Position Query Warning for Edited Cells 

To calculate the data and then apply the position query filter, click Yes. To apply the 
filter without considering the edited data, click No. To cancel the action, click Cancel.

Updating Measure Data in Position Queries
After you have applied a position query filter to the data, if you edit the data and 
calculate, the position query filter does not automatically refilter according to the new 
values. When this happens, the filter icon changes to a warning icon. The warning icon 
means that the position query may have stale data in it.

For instance, if you deselect the Store measure for the Still Water product and click 
Calculate while the filter is on, Still Water remains visible in the view and the filter 
icon changes to a warning icon. 

Figure 11–39 Updating Measure Data in a Position Query

If you want the position query to automatically refilter the edited data, use the Auto 
Evaluate feature. For more information about this feature, see Using Position Queries 
with Auto Evaluate.
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Scrolling in Position Queries
After you have filtered the slice, if you scroll to the next position, the position query 
filter is not reapplied to the new position and only the positions that were shown in 
the previous slice are shown in the current slice. 

For example, click the Next icon to scroll to the next location.

Figure 11–40 Scrolling with Position Queries

The view refreshes and the next location, Berlin, is shown (Figure 11–41). Note that the 
position query icon is no longer depressed the same stores in the position query for 
Barcelona (Figure 11–40) are shown, even though two of the stores, Liverpool and 
Oslo, do not have sales greater than $3,500. This is because the position query has been 
turned off. 

Figure 11–41 Position Query Scrolled to New Slice
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If you wanted to reapply the position query, click the Position Query icon. The view 
refreshes, and only the stores that meet the requirements of the position query are 
shown in this slice.

Figure 11–42 Position Query Reapplied to a New Slice

If you want the position query to automatically update when you scroll to a new slice, 
use the Auto Evaluate feature. For more information, see Using Position Queries with 
Auto Evaluate.

Using Position Queries with Auto Evaluate
If you want position queries to automatically reevaluate data after a calculate, refresh, 
or slice move, use the auto evaluate feature. 

The auto evaluate feature is located in the View menu. When enabled, the query is 
updated and the view refreshes with only the positions that meet the requirements of 
the position query. For performance reasons, this option is disabled by default. 

To turn auto evaluate on, click Automatically Evaluate Position Queries option in the 
View menu.

Figure 11–43 Automatically Evaluate Position Queries

Note: The setting of the Automatically Evaluate Position Queries 
option is saved with the workbook formatting. For more information 
on how formatting is saved, see Saving Formats. 
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Updating Measure Data with Auto Evaluate
After you have filtered the data using the position query feature with auto evaluate 
turned on, if you edit the data and calculate, the position query filter automatically 
refilters according to the new values. 

For example, change the Sales total for Luxembourg to zero and click Calculate.

Figure 11–44 Updating Measure Data with Auto Evaluate

The view refreshes and Luxembourg is no longer shown in the filter results.

Figure 11–45 Measure Data Updated with Auto Evaluate



Position Query

11-28 Oracle Retail Predictive Application Server User Guide for the Fusion Client

Scrolling with Auto Evaluate
After the slice is filtered, if auto evaluate is enabled and you scroll to the next position, 
the position query filter is reapplied to the new position. As a result, only the positions 
that meet the requirements of the position query are shown in the current slice. 

For example, click the Next icon to scroll to the next location.

Figure 11–46 Scrolling with Auto Evaluate

The view refreshes and the next location, Berlin, is shown (Figure 11–47). Note how the 
position query icon remains depressed and how different stores are shown compared 
to the previous slice (Figure 11–46). Because auto evaluate is enabled, the position 
query remains on, and only the stores that meet the position query requirements are 
shown. 

Figure 11–47 Position Query Scrolled to New Slice with Auto Evaluate



Position Query

Sort, Find, and Position Queries 11-29

No Position Query Matches
If you scroll to a new slice where no position meets the requirements of the position 
query, all positions in the view are displayed and a warning appears.

Figure 11–48  Scrolling with No Position Query Matches



Position Query

11-30 Oracle Retail Predictive Application Server User Guide for the Fusion Client



Working With Charts 12-1

12
Working With Charts

You can use the charting feature to generate a visual representation of the data in the 
form of charts. This section describes the available chart types and provides 
instructions on the various tasks you can perform with charts. It includes the following 
sections:

■ Viewing Charts

■ Charts View User Interface

■ Available Chart Types

■ Editing a Chart

■ Customizing a Chart

■ Saving a Chart as an Image

Note: Due to some limitations of Flash, chart axes and labels may not 
be visible at times and chart sizes may not adjust as expected.



Viewing Charts

12-2 Oracle Retail Predictive Application Server User Guide for the Fusion Client

Viewing Charts
You can view charts using the following views:

■ Chart View - In this view, the chart displays in the complete view area.

■ Split View - In this view, the chart and data display together in two vertical panels.

To view a chart:

1. Select the data you want for the chart. 

2. From the View toolbar, click the Select Chart Type icon, and then select the chart 
type.

Figure 12–1 Select Chart Type Icon on the View Toolbar

3. Once you select the chart type, click one of the following icons:

■ Switch to Chart View – Select this icon to switch the view to charts.

Figure 12–2 Switch to Chart View Icon on the View Toolbar

■ Switch to Split View – Select this icon to see the pivot table and chart split in 
two vertical panels.

Figure 12–3 Switch to Split View Icon on the View Toolbar
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To switch back to the pivot table, click the Switch to Pivot Table View icon.

Figure 12–4 Switch to Pivot Table View Icon on the View Toolbar

Cell Selection Considerations
When you choose to view a chart, only the cells that you select are represented in a 
chart. Each available graph type requires that a specific amount of data or cells are 
selected for a graph to appear. Although you may select a subset, the cells must 
contain enough data to support the desired graph for the graph to be displayed. For 
more information on the information required for each graph type, see Available Chart 
Types.

Squaring the Selection
When the chart is rendered on screen, the cell selections in the view are automatically 
squared. In this operation, additional cells are added to your selection to represent a 
squared selection area. This ensures that the data is analyzed in a consistent manner. 

If you choose to select some cells before viewing a chart, as shown in Figure 12–5 
below:

Figure 12–5 Example of Cells Selected Before Viewing a Chart
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After the chart appears, your selection in the view is squared, as shown in Figure 12–6:

Figure 12–6 Example of Squared Selection After the Chart Appears

Working with Charts
The following sections describe the charting functions.

Charts View User Interface
When switching to the Chart View or Split View, the View toolbar appears with icons 
relevant to charts.

Figure 12–7 Charting Icons in the View Toolbar

In the Chart View, the following charting icons appear:

Table 12–1  Charting Icons in the View Toolbar

Legend Icon Name Description

A Chart Formatting Enables you to customize the format of the charts. For more 
information, see Customizing a Chart.

B Save Chart to Image Enables you to save the chart as an image (PNG format) file.

C Flip Chart Axis Click to swap the contents represented on the X and Y axes 
without manually performing a pivot operation.
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Editing a Chart
Once the chart appears on screen, you can update the value of a specific series simply 
by clicking the series in the chart. To edit a chart: 

1. In the chart, select the value for the specific series represented in the chart using 
the following steps:

a. Hover the mouse cursor over the series or the legend, the specific series gets 
highlighted automatically and the other series are dimmed. See Figure 12–8.

Figure 12–8 Example of a Series Highlighted in Area Chart.

b. After the series is highlighted, locate the value you want to edit on the chart, 
and select the relevant area based on the following:

Note: This is configurable setting and can be toggled on or off in the 
properties file. For more information, refer to the RPAS Administration 
Guide for the Fusion Client.

Chart Type Area to Select

Area Chart Click the specific point (indicated by tool-tip pop-up).

Bar Chart Click the bar area.

Bubble Chart Click the bubble.

Column Chart Click the column area.

Combination Chart Click the relevant area based on chart type. Refer to the area for Area, 
Column, and Line Charts.
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Figure 12–9 Example of Value to be Selected in the Area Chart

The Chart Editor window appears.

Figure 12–10 Chart Editor Window

2. Enter the new value and click OK. The chart and the view data get updated with 
the new value.

Line Chart Click the specific point on the line (indicated by line marker).

Pareto Chart Click the column or by the pareto line marker.

Pie Chart Click the slice.

Radar Chart Click the line marker point.

Ring Chart Click the slice.

Scatter Chart Click the scatter marker (shape).

Note: Editing chart values also follow the cell editing and protection 
processing rules. Read-only values will not be editable.

Chart Type Area to Select
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Customizing a Chart
In Chart View, the View toolbar includes the Chart Formatting icon that enables you to 
use the formatting options and customize the chart. 

 To customize the chart:

1. In the Chart View, click the Chart Formatting icon in the View toolbar.

Figure 12–11 Chart Formatting Icon in the View Toolbar

The Chart Formatting window appears.

Figure 12–12 Chart Formatting Window

2. In the Chart Formatting window, make the relevant changes. For more 
information on the Chart Formatting window, see Understanding the Chart 
Formatting Window.

3. Click the Apply icon to apply the changes and continue customizing your chart. 
When you click the Apply icon, the changes take effect immediately in the 
background.

4. After all the changes are done, click OK. The changes are applied to the chart and 
the Chart Formatting window closes.
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Understanding the Chart Formatting Window
The Chart Formatting window includes the following tabs:

■ General Tab

■ Axis Tab

■ Series Tab

General Tab
The General tab enables you to customize the general settings for the chart.

Figure 12–13 General Tab on the Chart Formatting Window

The General tab includes the following fields:

Table 12–2  Fields on the General Tab

Field Description

Title Enables you to set a title to the chart.
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Subtype and Layouts Based on the chart, this section enables you to select a subtype 
and layout.

Subtype Selection includes the following options: 

■ Absolute (applies to Area, Bar, and Line Chart)

■ Stacked (applies to Bar and Line Chart)

■ Percentage (applies to Area, Bar, and Line Chart)

■ Is Horizontal (Bar only)

Layout Selection includes the following options

■  Single Y (applies to the Bubble, Scatter, and all 
Absolutes/Stacked types)

■  Dual Y (applies to the Bubble, Scatter, and all 
Absolutes/Stacked types)

■  Split Y (applies to all Absolutes and Stacked types)

Show Legend Select this check box to display a legend on the chart.

3D Effect Select this check box to display the chart in 3-D.

Background Color Enables you to select a background color for the chart.

Table 12–2 (Cont.) Fields on the General Tab

Field Description
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Axis Tab
The Axis tab enables you to customize the axes settings.

Figure 12–14 Axis Tab on the Chart Formatting Window

The Axis tab includes the following fields:

Table 12–3  Fields on the Axis Tab

Field Description

Select Axis Based on the type of chart, displays the axes for the chart. You 
can select each axes and set the parameters in the Axis Settings 
section.

Axis Settings

Title Enables you to set a title for the axis.

Axis Type Enables you to set the data type for the axis. You can choose 
from the following options

■ Number (does not apply for percentage type graphs).

■ Currency (does not apply for percentage type graphs).

■ Percentage (automatic on percentage type graphs).

Axis Tick Enables you to show or hide grid lines within the chart. Select 
from the following options:

■ Auto

■ Grid

■ None

Is Logarithmic Changes the axis to use a logarithmic scale when plotting data.
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Series Tab
The Series tab enables you to set the series color and Y-Axis assignment.

Figure 12–15 Series Tab on the Chart Formatting Window

The Series tab includes the following fields:

Table 12–4  Fields on the Series Tab

Field Description

Select Series Displays the series that appear in the chart.

Series Color Enables you to set a color for the series selected in the Select 
Series section.

Series Y-Axis Assignment Enables you to Move/Move All/Remove/Remove All icons 
and assign series to the Y1 and Y2 axes.
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Saving a Chart as an Image
In Chart View, the View toolbar includes the Save Chart to Image icon that enables 
you to save the chart as an image (in PNG format).

Figure 12–16 Save Chart to Image Icon on the View Toolbar

To save the chart as an image:

1. In the Chart View, click the drop-down arrow on the Save Chart to Image icon, 
and select the image resolution.

Figure 12–17 Drop-down Menu on the Save Chart to Image Icon

2. Click the Save Chart to Image icon to save the image.

3. The File Download dialog box appears. Click Open or Save as shown in 
Figure 12–18.

Clicking Open opens the chart as a PNG file. Clicking Save allows you to select a 
location to save the file.

Figure 12–18 File Download Dialog Box
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Available Chart Types
The following chart types are available with the charting feature:

■ Area Chart

■ Column Chart

■ Bubble Chart

■ Bar Chart

■ Combination Chart

■ Line Chart

■ Pareto Chart

■ Pie Chart

■ Ring Chart

■ Radar Chart

■ Scatter Chart

Area Chart
In a Area chart the data is represented as a filled-in area. They can be used to show 
trends over time, such as sales for the past 12 months. Area charts require at least two 
groups of data along an axis.

Area charts are available in the following types:

■ Absolute Area Chart - Here each area marker connects two data values. This type 
of chart has the following variations:

■ Absolute Area Chart with a Single Y-Axis

Figure 12–19 Absolute Area Chart with a Single Y-Axis
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■ Absolute Area Chart with a Split Dual Y-Axis

Figure 12–20 Absolute Area Chart with a Split Dual Y-Axis

■ Stacked Area Chart - Here area markers are stacked and the values of each set of 
data are added to the values of previous sets. The size of the stack represents a 
cumulative total. This type of chart has the following variations:

■ Stacked Area Chart with a Single Y-Axis

Figure 12–21 Stacked Area Chart with a Single Y-Axis
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■ Stacked Area Chart with a Split Dual Y-Axis

Figure 12–22 Stacked Area Chart with a Split Dual Y-Axis

■ Percentage Area Chart - Here area markers show the percentage of the cumulative 
total of all sets of data.

Figure 12–23 Percentage Area Chart

Bar Chart
A Bar Chart is similar to the Column Chart, except that the data is represented as 
series of horizontal columns.
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Bubble Chart
In a Bubble Chart the data is represented by the location and size of round data 
markers (bubbles). Bubble charts show correlations among three types of values. They 
can be used when there are a number of data items present and you want see the 
general relationships. Bubble Charts require at least three data values.

Bubble Charts are available in the following types:

■ Bubble Chart with a Single Y-Axis

Figure 12–24 Bubble Chart with a Single Y-Axis

■ Bubble Chart with a Dual Y-Axis

Figure 12–25 Bubble Chart with a Dual Y-Axis
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Column Chart
In a Column Chart the data is represented as a series of vertical bars. They can be used 
to examine trends over time or compare items at the same time. For example, sales for 
different product divisions in several groups.

Column Charts are available in the following types:

■ Clustered Column Chart - Here each cluster of columns represent a group of data. 
This type of chart has the following variations:

■ Clustered Column Chart with Single Y-Axis

Figure 12–26 Clustered Column Chart with Single Y-Axis

■ Clustered Column Chart with Dual Y-Axis

Figure 12–27 Clustered Column Chart with Dual Y-Axis
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■ Clustered Column Chart with Split Dual Y-Axis

Figure 12–28 Clustered Column Chart with Split Dual Y-Axis

■ Stacked Column Chart - Here bars of each set of data are appended to the previous 
sets of data. The size of the stack represents a cumulative data total. This type of 
chart has the following variations:

■ Stacked Column Chart with a Single Y-Axis

Figure 12–29 Stacked Column Chart with a Single Y-Axis
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■ Stacked Column Chart with a Dual Y-Axis

Figure 12–30 Stacked Column Chart with a Dual Y-Axis

■ Stacked Column Chart with a Split Y-Axis

Figure 12–31 Stacked Column Chart with a Split Dual Y-Axis
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■ Percentage Column Chart - Here bars are stacked and display the percentage of a 
given set of data relative to the cumulative total of all sets of data. Percentage 
Column Charts are arranged only with a single Y-Axis.

Figure 12–32 Percentage Column Chart

Combination Chart
The Combination Chart uses three different types of data markers to display different 
kinds of data items. They can be used to compare bars and lines, bars and areas, lines 
and areas, or all three combinations. Combination charts require at least two groups of 
data for the chart to render an area marker or a line marker.

Combination Charts are available in the following types:

■ Combination Chart with Single Y-Axis

Figure 12–33 Combination Chart with Single Y-Axis
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■ Combination Chart with Dual Y-Axis

Figure 12–34 Combination Chart with Dual Y-Axis

Line Chart
In a Line Chart the data is represented as a line, series of data points, or data points 
connected by a line. Line Charts require data for at least two points for each member in 
a group.

Line Charts are available in the following types:

■ Absolute Line Chart - Here each line segment connects two data points. This type 
of chart has the following variations:

■ Absolute Line Chart Single Y-Axis

Figure 12–35 Absolute Line Chart Single Y-Axis
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■ Absolute Line Chart Dual Y-Axis

Figure 12–36 Absolute Line Chart Dual Y-Axis

■ Absolute Line Chart Split Y-Axis

Figure 12–37 Absolute Line Chart Split Dual Y-Axis
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■ Stacked Line Chart - Here each set of data is appended to previous sets of data. 
The size of the stack represents a cumulative data total. This type of chart has the 
following variations:

■ Stacked Line Chart Single Y-Axis

Figure 12–38 Stacked Line Chart Single Y-Axis

■ Stacked Line Chart Dual Y-Axis

Figure 12–39 Stacked Line Chart Dual Y-Axis
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■ Stacked Line Chart Split Y-Axis

Figure 12–40 Stacked Line Chart Split Dual Y-Axis

■ Percentage Line Chart - Here the lines are stacked and each line shows the 
percentage of the given set of data relative to the cumulative total of all sets of 
data. Percentage Line Charts are arranged only with a single Y-Axis.

Figure 12–41 Percentage Line Chart
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Pareto Chart
In a Pareto Chart the data is represented by bars and a percentage line that indicates 
the cumulative percentage of bars. Bars are arranged by value from left to right, from 
the largest to the lowest. A Pareto Chart is always a Dual Y-Axis chart. The first Y-Axis 
corresponds to values that the bars represent and the second Y-Axis runs from 0-100% 
and represents the cumulative percentage values.

Figure 12–42 Pareto Chart

Pie Chart
In a Pie Chart the data is represented as sections of a circle. Pie charts can be used to 
show the relationship of parts to a whole.

Figure 12–43 Pie Chart
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Ring Chart
Ring Charts are similar to the Pie Chart, except that the center of each circle displays 
the total pie value.

Figure 12–44 Ring Chart

Radar Chart
In a Radar Chart the data is represented in a polygon layout. They are used to show 
patterns that occur in cycles, such as monthly sales for last three years.

The data structure of a Radar Chart is:

■ Number of sides on the polygon is equal to the number of groups of data. Each 
corner of the polygon represents a group.

■ A series or set of data is represented by a line, markers of the same color, or both 
(labeled by legend text). 

Figure 12–45 Radar Chart
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Scatter Chart
In a Scatter Chart the data is represented by the location of data markers. Scatter 
Charts can be used to show the correlation between two different kinds of data values. 

Scatter Charts are available in the following types:

■ Scatter Chart with a Single Y-Axis

Figure 12–46 Scatter Chart with a Single Y-Axis

■ Scatter Chart with a Dual Y-Axis

Figure 12–47 Scatter Chart with a Dual Y-Axis



Working with Charts

12-28 Oracle Retail Predictive Application Server User Guide for the Fusion Client



Images 13-1

13
Images 

The ability to view images associated with positions on a non-calendar dimension is 
useful in many aspects of the retail world such as assortment planning, item planning, 
story boarding, and so on. 

For instance, you can associate an item with a image of what it should look like 
displayed on the shelf. You can associate stores with images of the store front or 
interior. You can use images to storyboard themes by creating a collection of looks and 
colors for a particular buying period, floor set, or flow. Some retailers choose to 
associate multiple types images with multiple levels of the Product dimension. For 
instance, you could associate images for the following Product levels:

■ Department: Image of a generic sweater

■ Class: Image of a wool sweater

■ Subclass: Image of a L/S V-Neck Solid sweater

■ Style: Image of Chunky Shrunken Style, Washable Wool, L/S V-Neck Solid 
sweater

■ Style/Color: Image of Chunky Shrunken Style, Color Pumpkin, Washable Wool, 
L/S V-Neck Solid sweater

The Fusion Client gives you the ability to associate an image for any dimension other 
than Calendar. These images can be stored on a website or in a repository located in 
the same network as the application server. 

Once images are associated with a position, you can view and compare them within 
the Fusion Client.
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Associating Images with a Position
To associate an image with a position, perform the following steps:

1. Click the Manage Images icon in the toolbar or select Manage Images from the 
View menu.

Figure 13–1 Manage Images Icon 

Figure 13–2 Manage Images Option 

2. The View/Manage Images dialog box appears. Enter the following information: 

■ Dimension and Level: Select the dimension and level into which you want to 
load the image. In Figure 13–3, the Product dimension and Item level were 
chosen.

■ Find image for: Select the position for which you want to load the image. You 
can select the position from the drop-down list or you can scroll through the 
positions in the carousel view. 

■ Image Source: Select either URL or Repository as the location of the image. 
Select URL if the image is located on the internet. Select Repository if the 
image has already been loaded into the repository on a shared network 
location.

Note:  The repository is configured during installation process. 
Contact your administrator for assistance. See the RPAS Installation 
Guide for more information.
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3. File path: Enter the file path for the image. You can type or paste the file path for 
either a Repository or URL image source. For Repository images, you can also use 
the Browse button to locate the file within the repository. After you have entered 
the file path, click Go.

Figure 13–3 Loading Images

The image appears in the image carousel and is now associated with the position.
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Deleting Images
You can disassociate an image with a position by using the Delete button in the 
View/Manage Images dialog box. 

To delete an image, perform the following steps:

1. Click the Manage Images icon in the toolbar or select Mange Images from the 
View menu. 

Or, right-click the position within the view and select View Image from the 
right-click context menu.

Figure 13–4 View Image Option in the Right-Click Context Menu

2. The View/Manage Images dialog box appears. Select the position for which you 
want to delete the image. You can select the position from the Find image for 
drop-down box or from the image carousel. 

Note: Using the Delete function does not delete an image from the 
repository. It only disassociates the image with the position.
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3. After you have selected the position, click the Delete button located to the right of 
the File Path field.

Figure 13–5 Delete Button

The image disappears from the image carousel.

Viewing Image from a View
To view the image associated with a position, use one of the following methods:

Viewing Images - Method 1
1. Right-click the position within the view or page edge. 

2. The right-click context menu appears. Select View Image.

Figure 13–6 View Image Option in the Right-Click Context Menu

The View/Manage Images dialog box appears. The image for the position you selected 
is shown in the center of the image carousel.
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Viewing Images - Method 2
1. Click the Manage Images icon in the toolbar or select Mange Images from the 

View menu. 

2. The View/Manage Images dialog box appears.Use the Find image for drop-down 
box or the image carousel to locate and view the image. 

Comparing Images
You can drag images from the images carousel to the Compare area of the 
View/Manage Images dialog box in order to compare images side by side. 

To compare images, perform the following steps:

1. Click and drag an image from the image carousel to the Compare area. When the 
background of the Compare area changes to blue, release the image. The image 
appears in the Compare area.

Figure 13–7 Dragging an Image to the Compare Area



Comparing Images

Images 13-7

2. Click and drag other images to the Compare area. The images appear as 
thumbnails.

Figure 13–8 Images as Thumbnails in the Compare Area

3. To expand the Compare area in order to view the selected items as larger images, 
click the Expand icon in the top, right corner of the Compare area. To collapse the 
Compare area once expanded, click the Collapse icon in the top, right corner.
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14
Print and Export 

Print and export functionality enables you to export data in the current slice of a view 
to Microsoft Excel or a delimited file and print it.

Additionally, you can adjust the page setup options before printing and exporting the 
data. These print settings are persisted in the Fusion Client for the selected view. 

The page setup, print, and export options are located in the File menu.

Figure 14–1 Page Setup, Print, and Export Options

In addition, print and export icons are located in the toolbar.

Figure 14–2 Print and Export Icons
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Page Setup
The page setup option is available in the File menu, as shown in Figure 14–3.

Figure 14–3 Page Setup Option in the File Menu

The Page Setup dialog box (Figure 14–4) contains five tabs: Page, Margins, 
Header/Footer, Sheet, and Page Breaks.

Figure 14–4 Page Setup Dialog Box

Page settings are applied per view. The View drop-down list contains a list of views of 
the current workbook. By default, the displayed view is selected. Selecting the view in 
the View drop-down sets the view in all tabs of this dialog box.
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The settings created in the Page Setup dialog box are passed to Microsoft Excel and 
used when printing the data. 

The five Page Setup tabs are described in the next sections.

Page Tab
Use the Page tab to specify the page orientation and scaling.

Figure 14–5 Page Setup Dialog Box: Page Tab
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Margin Tab
Use the Margin tab to specify the page margins.

Figure 14–6 Page Setup Dialog Box: Margin Tab
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Header/Footer
Use the Header/Footer tab to apply headers and footers.

Figure 14–7 Page Setup Dialog Box: Header/Footer Tab
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Sheet
Use the Sheet tab to define row and column headers, print gridlines, and page order. 

Figure 14–8 Page Setup Dialog Box: Sheet Tab
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Page Breaks
Use the Page Breaks tab to specify how the rows and columns break across pages.

Figure 14–9 Page Setup Dialog Box: Page Breaks Tab

After you have used the Page Setup dialog box to define how the view appears on a 
page, you can print or export the page.
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Export
You can use the Export functionality to export a slice to a text file or to Microsoft Excel. 
These options are described in the following sections.

Export to a Text File
1. Select the Export option from the File menu.

Figure 14–10 Export Option

If you have edited the view, a warning message appears, asking if you would 
calculate the workbook, revert the cells, or cancel the export.

Figure 14–11 Edited Cells Warning Message

■ Clicking Calculate calculates the workbook and opens the File Download 
dialog box.

■ Clicking Revert reverts the edited cells and opens the File Download dialog 
box.

■ Clicking Cancel cancels the operation.

Note: Before exporting a view, ensure that the Internet Explorer 
"automatic prompting for file downloads" security setting for 
downloads is set to "Disable."
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2. The Export dialog box appears. 

Figure 14–12 Export Dialog Box: Text

Select the following options:

■ View: Choose the view that you want to export.

■ Export To: Select Text.

■ Separator: Choose Comma, Tab, Space, or Other (Please specify). The default 
separator is Comma.

– If you choose Other (Please Specify), you must enter a character in the 
text box. This character will act as the separator. 

Figure 14–13 Separator: Others Option

■ Descriptions: Choose either Labels or Names to be displayed as a header in 
the exported data. The default is Labels.

3. Click Page Setup... to make adjustments to the page setup. This step is optional. 
For more information, see Page Setup.

4. Click OK.

Note: The Apply Page Setup Options and Read-only options are 
not applicable to text file exports.
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5. The File Download dialog box appears. You can choose to either Open the text file 
or Save it to a location on your computer.

Figure 14–14 File Download Dialog Box

6. If you chose Open, the text file opens. If you chose Save, you can open the file 
from the location you saved it. 

Figure 14–15 Data in Text File
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Export to Excel
You can export data to Microsoft Excel through two options. You can use the Export 
option in the File menu to set export options before exporting. Or, you can use the 
Export icon in the toolbar to bypass the export options and export the slice directly to 
Excel.

Option 1: Export Option in the File Menu
To export the slice to Microsoft Excel with the Export option in the File menu, perform 
the following steps:

1. Select the view that you want to export.

2. Select the Export option from the File menu.

Figure 14–16 Export Option

If you have edited the view, a warning message appears, asking if you would 
calculate the workbook, revert the cells, or cancel the operation.

Figure 14–17 Edited Cells Warning

■ Clicking Calculate calculates the workbook and opens the File Download 
dialog box.

■ Clicking Revert reverts the edited cells and opens the File Download dialog 
box.

Note: The export functionality is certified with Microsoft Excel 2003 
and 2007.



Export

14-12 Oracle Retail Predictive Application Server User Guide for the Fusion Client

■ Clicking Cancel cancels the operation.

3. The Export dialog box appears. 

Figure 14–18 Export Dialog Box: Excel

Select the following options:

■ View: choose the view that you want to export.

■ Export To: select Excel.

■ Apply Page Setup Options: select this check box if you want to apply page 
setup options before exporting the data so that you can print the data from the 
exported Excel file. 

■ Read-only: select this check box if you want the exported data to be read-only. 
This prevents the data from being updated when opened in Microsoft Excel.

4. Click Page Setup... if you want to make adjustments to the page setup. This step is 
optional. For more information, see Page Setup.

5. Click OK.

Note: The Separator and Descriptions options are not applicable to 
Microsoft Excel exports.
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6. The File Download dialog box appears. You can choose to either Open the 
Microsoft Excel file or Save it to a location on your computer.

Figure 14–19 Export Dialog Box

7. If you chose Open, Microsoft Excel opens and the slice appears in a spreadsheet. If 
you chose Save, you can open the file from the location you saved it. 

Figure 14–20 Slice in Microsoft Excel
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Option 2: Export Icon in the Toolbar
To export the slice to Microsoft Excel with the Export icon in the toolbar, perform the 
following steps:

1. Select the view that you want to export.

2. Click the Export icon in the toolbar.

Figure 14–21 Export Icon

If you have edited the view, a warning message appears, asking if you would 
calculate the workbook, revert the cells, or cancel the operation.

Figure 14–22 Edited Cells Warning

■ Clicking Calculate calculates the workbook and opens the File Download 
dialog box.

■ Clicking Revert reverts the edited cells and opens the File Download dialog 
box.

■ Clicking Cancel cancels the operation.

3. The File Download dialog box appears. You can choose to either Open the 
Microsoft Excel file or Save it to a location on your computer.

Figure 14–23 File Download Dialog Box
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4. If you chose Open, Microsoft Excel opens and the slice appears in a spreadsheet. If 
you chose Save, you can open the file from the location you saved it. 

Figure 14–24 Slice in Microsoft Excel
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Print
You can print data through two options. You can use the Print option in the File menu 
to set print options before printing. Or, you can use the Print icon in the toolbar to 
bypass the print options.

The print functionality is similar to the export functionality, except that the print 
functionality always applies the page setup options before exporting to Microsoft 
Excel. Print also differs from export because the exported data is always read-only.

Option 1: Print Option in the File Menu
To print the slice with the Print option in the File menu, perform the following steps:

1. Select the view that you want to print.

2. Select the Print option from the File menu.

Figure 14–25 Print Option

If you have edited the view, a warning message appears, asking if you would 
calculate the workbook, revert the cells, or cancel the operation.

Figure 14–26 Edited Cells Warning

■ Clicking Calculate calculates the workbook and opens the File Download 
dialog box.

■ Clicking Revert reverts the edited cells and opens the File Download dialog 
box.

■ Clicking Cancel cancels the operation.
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3. The Print dialog box appears. Select the view you want to print.

Figure 14–27 Print Dialog Box

4. Click Page Setup... if you want to make adjustments to the page setup. This step is 
optional. For more information, see Page Setup.

5. Click OK.

6. The File Download dialog box appears. You can choose to either Open the 
Microsoft Excel file or Save it to a location on your computer.

Figure 14–28 File Download Dialog Box
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7. If you chose Open, Microsoft Excel opens and the slice appears in a spreadsheet. If 
you chose Save, you can open the file from the location you saved it. 

Figure 14–29 Slice in Microsoft Excel

From Microsoft Excel, click the Print option in the main menu.

Figure 14–30 Print Icon in Microsoft Excel
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Option 2: Print Icon in the Toolbar
To print the slice with the Print icon in the toolbar, perform the following steps:

1. Select the view that you want to export.

2. Click the Print icon in the toolbar.

Figure 14–31 Print Icon

If you have edited the view, a warning message appears, asking if you would 
calculate the workbook, revert the cells, or cancel the operation.

Figure 14–32 Edited Cells Warning

■ Clicking Calculate calculates the workbook and opens the File Download 
dialog box.

■ Clicking Revert reverts the edited cells and opens the File Download dialog 
box.

■ Clicking Cancel cancels the operation.

3. The File Download dialog box appears. You can choose to either Open the 
Microsoft Excel file or Save it to a location on your computer.

Figure 14–33 Export Dialog Box
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4. If you chose Open, Microsoft Excel opens and the slice appears in a spreadsheet. If 
you chose Save, you can open the file from the location you saved it. 

Figure 14–34 Slice in Microsoft Excel

From Microsoft Excel, click the Print icon.

Figure 14–35 Print Icon in Microsoft Excel



Special RPAS Fusion Client Features 15-1

15
  Special RPAS Fusion Client Features

This chapter describes special RPAS Fusion Client features that you can use. The 
following features are described:

■ Alert Manager

■ Percent-of-Parent Measures

■ Replicate Selections

Alert Manager
Because of the large volumes of data that needs to be managed by the Oracle Retail 
Predictive Application Server, the server includes an Alert Manager feature that 
highlights data that might otherwise go unnoticed. You can set up business rules to 
alert users about retail events such as open to buy opportunities, stock outages, sales 
performance against plan, margin opportunities, and many others. These alerts go 
beyond exception reporting: Alert Manager links you directly to the area of the plan 
that needs action.

Figure 15–1 Alert Manager on the Home Page
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Alerts are set up by identifying a business measure as the foundation, and then 
creating the alert by using a mathematical rule. A facility behind the scene finds the 
areas of a plan that fall outside the thresholds that is declared within the alert rules. 
This creates an alert that is flagged to the user through the Alert Manager feature.

You can configure Alert Manager to automatically run on a defined schedule using the 
alertmgr utility. Each time that Alert Manager is run, it shows you all the alerts 
conditions that were identified during the last execution. For more information about 
alertmgr, see the RPAS Administration Guide for the Fusion Client.

In the RPAS Fusion Client, Alert Manager provides two methods of viewing the 
measures associated with identified alerts: loading alerts in a new workbook and 
inserting alerts in an existing one. For more information, see Building an Alert 
Manager Workbook and Inserting an Alert in an Existing Workbook.

You may also use the Alert Manager window to keep track of alerts that have been 
resolved. See Resolving Alerts for more information.

Show/Open the Alert Manager Window
You can access the Alert Manager from the Home page (Figure 15–1) or from the View 
menu (Figure 15–2).

Figure 15–2 Alert Manager - View Menu

Note: If there are no alerts in the workbook, neither the Alert 
Manager window on the homepage nor the option in the View menu 
appear.
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Building an Alert Manager Workbook
If no workbooks are currently open, you may pick an alert from the Alert Manager list 
to load and have the system automatically construct a workbook that contains that 
alert's measure and any other measures that you want to display. This workbook 
allows you to examine the actual measure values involved in the generation of the 
alert, so you can make decisions about what needs to be done next. 

To build an alert manager workbook, perform the following steps:

1. In the Alert Manager dialog box, select the alert that you want to see.

2. Click New Workbook.

Figure 15–3 Alert Manager, New Workbook Icon

3. The Workbook Wizard dialog box appears. Select any optional alerts you want to 
include in the workbook and click Next.

Figure 15–4 Alert Manager Workbook Wizard: Additional Alerts
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4. Select the workbook template type and click Next.

Figure 15–5 Alert Manager Workbook Wizard: Workbook Template

5. The hierarchies shown in this step are related to the workbook you selected. In the 
top section, select the hierarchies you want to range. This means that only the 
positions in this hierarchy that trigger the alert are available for selection in the 
workbook wizard. In the bottom section, select the hierarchies that you do not 
want to see in the workbook. Click Next.

Figure 15–6 Alert Manager Workbook Wizard: Range and Hide
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6. The workbook wizard steps from this point on depend on the workbook you 
selected. For each step you are presented, select the positions you want to see in 
each dimension. At the last step, click Finish.

Figure 15–7 Alert Manager Workbook Wizard: Position Selection

7. The Alert Worksheet Selection dialog box appears. Select the view (worksheet) you 
want the alert to appear in. If you do not select a view, Alert Manager 
automatically selects one with the appropriate base intersection.

Figure 15–8 Alert Worksheet Selection

If you select a view that has a base intersection below the base intersection of the 
alert, a message appears that states the base intersections do not match and an 
additional view is created.

The workbook opens.
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Inserting an Alert in an Existing Workbook
If you have an open workbook already displayed, you can use the Alert Manager to 
insert an alert measure into that workbook. This functionality enables you to view 
multiple alert measures simultaneously and address alert-related issues without 
building a new workbook for each.

To insert an alert in an existing workbook, perform the following steps:

1. In the open workbook, select the Manage Alerts option in the View menu.

Figure 15–9 Alert Manager - View Menu

2. The Alert Manager dialog box appears. Select the alert you want to insert in the 
open workbook and click Insert Alert.

Figure 15–10 Alert Manager Dialog Box

The workbook refreshes and the alert measure is inserted. 
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3. Close the dialog box using the Close icon or the Cancel button.

The Alert Manager dialog box closes, and the alert measure is visible in the workbook.

Finding Alerts
In the view, the alert appears and behaves like a read-only boolean measure. Positions 
that have triggered the alert have selected check boxes. 

If you have more than one alert in the workbook, use the Select Alert icon to choose 
the alert that you want to find. Use the Find Next and Find Previous alert icons 
(Figure 15–11) to scroll through all instances of that alert in the workbook. If the next 
or previous alert is not visible in the view, the view refreshes or scrolls to make it 
visible.

Figure 15–11 Select Alert and Find Next and Previous Alerts Icons

Resolving Alerts
Once you have reviewed the alert instances and made any necessary changes to the 
data, you can mark the alert as resolved in the Alert Manager dialog box.

To resolve an alert, check the Resolved check box for that alert (Figure 15–12). 
Checking the resolved check box does not change the data in the workbook or clear 
the instances of that alert. It serves only as a visual cue to users that they have 
addressed the alert.

Figure 15–12 Resolving an Alert
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Percent-of-Parent Measures
A percent-of-parent measure allows you to define, view, and edit a measure as a 
proportion or percentage of another measure for a parent that is up one or more levels. 
These measure relationships are also referred to as participation measures. These 
measures can be defined in the RPAS Fusion Client client in a view or preconfigured in 
the RPAS Configuration Tools. For more information about preconfigured measures, 
see the RPAS Configuration Tools User Guide.

A common use of this functionality is to define measures that are percentage 
participations of sales measures. Typically, these measures are defined as:

■ Absolute: a percentage of a fixed level (such as class) so that the participation of 
each item to the class can be viewed and manipulated. 

■ Relative: a percentage to the next level shown in any dimension (such as Product). 

The following sections describe the absolute and relative percent-of-parent features. 

Notes: 

■ Percent-of-parent measures can be defined only on measures that 
have Total as their default aggregate method.

■ When changing the percentage of the percent-of-parent measure, 
values of the underlying measure will change to reflect the newly 
set percentage.

■ Multiple percent-of-parent measures can be defined for the same 
underlying measure; however, only one percent-of-parent 
measure or the underlying measure can be edited before 
calculation. All other versions will be protected.

■ The use of smart edit is not allowed in the percent-of-parent 
measure.

■ The value of a percent-of-parent measure is a fraction that will be 
between zero and one. If desired, you must format the measure to 
be displayed as a percentage.

■ For percent-of-parent contributions in instances with very small 
values (such as 0.000001) in the cell, those values are considered to 
be 0.0 when determining the percent-of-parent contribution.
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Absolute
The absolute type of percent-of-parent measures allows you to explicitly define the 
parent levels that are used to calculate the percentage at all child levels.

As shown in Figure 15–13, an absolute percent-of-parent measure has been created for 
the Weekly Sales - Regular measure with a defined parent at the Fiscal Half level of the 
Calendar dimension. Therefore, this measure shows what percentage of the Season 4 
half that each week is.

Figure 15–13 Absolute Percent-of-Parent Measure

To create an absolute percent-of-parent measure, perform the following steps:

1. Right-click the measure for which you want to create a percent-of-parent measure.

2. The right-click context menu appears. Select the Create percent-of-parent 
measure... as shown in Figure 15–14.

Figure 15–14 Create Percent-of-Parent Measure Option
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3. The Create Percent-of-Measure dialog box appears (Figure 15–15). If you 
right-clicked a valid measure (one that has Total as its aggregation) in Step 1, then 
that measure appears in the Measure list. If not, then you must select a valid 
measure from the list.

Figure 15–15 Create Percent-of-Parent Measure Dialog Box

4. In the Create Percent-of-Measure dialog box, change the Type to Absolute. The 
dialog box refreshes and displays drop-down lists for all the dimensions 
(Figure 15–16). These lists contain the levels that are available for that dimension. 
These levels are defined by the intersection of the measure.

Select the level at which you want to compare the child levels.

Figure 15–16 Create Percent-of-Parent Measure - Absolute
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5. When finished defining the parent levels, click Create. The view refreshes and the 
new percent-of-parent measure appears (Figure 15–17).

Figure 15–17 Absolute Percent-of-Parent Measure

As shown in Figure 15–17, a new percent-of-parent measure has been created for the 
Weekly Sales - Regular measure with a defined parent at the Fiscal Half level of the 
Calendar dimension.  
The measure shows what percentage of the Season 4 half that each week is. For 
example, the Weekly Sales - Regular for week 10/6/2006 are 8% of the entire Season 4 
half of the 2006 fiscal year.

Note: The % attribute is automatically displayed when creating a 
percent-of-parent measure. This is because the measure label of the 
percent-of-parent is the same as the measure that it was created from, 
and therefore the only way to distinguish them is to show the % 
attribute.
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Relative
The relative type of percent-of-parent measure calculates the value for a given level, 
which is the percentage that level is of the immediate parent level displayed in the 
view. This type can only be set for a single dimension.

To create a relative percent-of-parent measure, perform the following steps:

1. Right-click the measure for which you want to create a percent-of-parent measure.

2. The right-click context menu appears. Select the Create percent-of-parent 
measure... as shown in Figure 15–18.

Figure 15–18 Create Percent-of-Parent Measure Option

3. The Create Percent-of-Measure dialog box appears (Figure 15–19). If you 
right-clicked a valid measure (one that has Total as its aggregation) in Step 1, then 
that measure appears in the Measure list. If not, then you must select a valid 
measure from the list.

Figure 15–19 Create Percent-of-Parent Measure Dialog Box
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4. In the Create Percent-of-Measure dialog box, select the dimension for which you 
want to set the parent level. 

5. Click Create. The view refreshes and the new percent-of-parent measure appears.

Figure 15–20 Relative Percent-of-Parent Measure

As shown in Figure 15–20, a new percent-of-parent measure has been created for the 
Weekly Sales - Regular measure with a defined dimension of Calendar. Because a 
dimension is defined and not a specific level of a dimension, the percent-of-parent 
data shown is relative. This means that the percentage shown is compared to the next 
level shown in the view.

For example, the Weekly Sales - Regular measure for week 10/6/2006 makes up 8% of 
the next level shown, which is Season 4, FY 2006. Accordingly, Season 4 makes up 
100% of all [Calendar]. There is no percentage shown for all [Calendar] because it is 
the highest level in the workbook.
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Comparing Absolute and Relative Percent-of-Parent Measures
The difference between an absolute percent-of-parent measure and a relative one is 
that the parent level for absolute is specified by the user. The parent level for relative is 
not specified—it is the next parent level shown in the view.

Figure 15–21 Comparing Absolute and Relative Percent-of-Parent Measures

As shown in Figure 15–21, the absolute percent-of-parent measure for Weekly Sales - 
Regular has an attribute % Fiscal Half. This means that the child levels are only 
compared to the parent level Fiscal Half.

The relative percent-of-parent measure is also for Weekly Sales - Regular, but its 
attribute is specified as %Calendar. This means that the child levels are compared to 
the parent shown in the view that is immediately above them.

Since the absolute percent-of-parent measure specifies Fiscal Half as the parent level, 
the other level shown in the view, Month, is compared to Half. For instance, week 
10/6/2006 is 8% of the Season 4. October is 31% of the Season 4. Because Fiscal Half is 
the specified parent, it does not show what percentage of FY2010 it is.

However, the relative percent-of-parent measure only specifies the Calendar 
dimension as the parent. This means that any parent level shown in the view can act as 
the parent. Therefore, week 10/6/2006 is 26% of its immediate parent level, which is 
month October. October is 31% of its immediately displayed parent level, which is 
Season 4. Finally, Season 4 is 100% of its immediately displayed parent level, FY2006. 
The relationship of month to quarter (the configured parent of the month level) is not 
displayed since quarter is not displayed in the view.
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If the month level of the Calendar dimension were hidden in this view, then the 
relative percent-of-parent measure would look more like the absolute one since the 
immediately displayed parent level for week would be Fiscal Half, which is the 
specified absolute parent. This is illustrated in Figure 15–22.

Figure 15–22 Comparing Absolute and Relative Percent-of-Parent Measures at Half

Select All
You can select all cells in the current slice by using the Select All option. This is useful 
if you need to select all instances within a large view.

The Select All option is located in the toolbar as well as in the right-click context menu.

Figure 15–23 Select All Option in Toolbar

Figure 15–24 Select All Option in Right-click Context Menu
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To select all cells in the current slice, use one of the following methods:

Select All: Method 1
1. Click the Selection Options icon in the toolbar. 

2. From the drop-down list, click Select All.

All the cells in the current slice are selected.

Select All: Method 2
1. Right-click a cell in the view.

2.  The right-click context menu appears. Click Selection Options. 

3. From the drop-down list, click Select All.

All the cells in the current slice are selected.
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Replicate Selections
In the RPAS Fusion Client, you have the ability to select all instances of a particular 
level at once with the Replicate Selections feature. This is useful if you need to select 
all instances within a large view.

To select instances using the Replicate Selections feature, perform the following steps:

1. Select an instance of the particular level for which you want to select all instances. 
You can select a single cell or an entire row or column.

Figure 15–25 Replicating Selections 
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2. Click the Selection Options icon in the toolbar. Or, right-click the measure and 
from the right-click context menu select Selection Options. Then, click Replicate 
[Row/Column] Selections.

Figure 15–26 Replicate Selections Option

3. The view refreshes and all instances of the chosen level are selected.

Figure 15–27 Replicated Selections in the View
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Using Replicate Selections to Copy and Paste
Perform the following steps to copy an instance of a particular level and paste it to all 
other instances of that level:

1. Right-click an instance of the particular level for which you want to copy and 
paste to all other instances.You can select a single cell or an entire row or column.

2. The right-click context menu appears. Select the Copy option. 

Figure 15–28 Using Replicate Selections to Copy and Paste
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3. Select the same instance again. Either click the Selection Options icon in the 
toolbar, or right-click and select Selection Options from the right-click context 
menu. Then, click Replicate [Row/Column] Selections.

Figure 15–29 Replicate Selections Option

4. The view refreshes and all instances of the chosen level are selected.

Figure 15–30 Replicated Selections in the View
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5. With all the instances of that particular level highlighted, select the Paste option in 
the Edit menu.

The view refreshes, and all the selected instances contain the copied information.

Figure 15–31 Replicated Selections 
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Using Replicate Selections for the Chart View
Perform the following steps to use the replicate selection function to create a particular 
chart view.

1. Select an instance of the particular level for which you want to select all instances 
to show in a chart view. You can select a single cell or an entire row or column.

2. Click the Selection Options icon from the toolbar. Or, right-click and select 
Selection Options from the right-click context menu. Then click Replicate 
[Row/Column] Selections.

Figure 15–32 Replicate Selections Option

3. The view refreshes and all instances of the chosen level are selected.

Figure 15–33 Replicated Selections in the View
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4. With all the instances of that particular level highlighted, click the Switch to Chart 
View icon.

Figure 15–34 Switch to Chart View Icon

The chart view appears. Only the selected instances are shown in the chart. In 
Figure 15–35, the chart only shows data for the Brick & Mortar because those were the 
selected instances.

Figure 15–35 Replicated Selections in Chart View



Replicate Selections

15-24 Oracle Retail Predictive Application Server User Guide for the Fusion Client


	Contents
	Send Us Your Comments
	Preface
	Audience
	Documentation Accessibility
	Related Documents
	Customer Support
	Review Patch Documentation
	Oracle Retail Documentation on the Oracle Technology Network
	Conventions

	1 Getting Started
	Overview
	Where Does the RPAS Fusion Client Fit in an Retail Enterprise

	Basic Concepts of RPAS
	Multidimensionality
	Dimensions
	Measures
	Domains and Workbooks

	Terminology Differences Between Clients
	Setting Up Your Browser
	Cache Settings
	Security Settings for Internet Explorer

	Logging on to the Fusion Client
	Concurrent Sessions
	Multiple Sessions

	Opening a Workbook
	Understanding the Open Workbook Window

	Creating a New Workbook
	Deleting a Workbook
	Renaming a Workbook
	Understanding the Workbook Wizard Window
	Saving and Loading Favorites
	Saving Favorites
	Saving Calendar Positions as Favorites

	Editing Favorites
	Loading Favorites
	Deleting Favorites

	Accessing Online Help
	Contents
	Figures and Tables
	Index
	Search

	Changing Your Password
	Locating the Version Number
	Logging Out of the Application

	2 Understanding the User Interface
	Quick Access Toolbar
	File Menu Options
	Edit Menu Options
	View Menu Options
	Format Menu Options

	Taskflow
	Access Based Visibility
	Switching Between Multiple Tasks

	Contents Area
	View Title Bar
	Maximizing or Restoring a View
	Minimizing a View
	Moving a View
	Renaming a View
	Making a Copy of a View
	Deleting a View

	Page Edge and Dimension Tiles Area
	Understanding Paging/Position Navigation

	View Toolbar
	View Area
	Rotating or Pivoting Dimensions

	Views Docking Area


	3 Workbooks
	Saving Workbooks
	Save As Option
	Auto-Save


	Renaming Workbooks
	Calculating Workbooks
	Refreshing Workbooks
	Committing Workbooks
	Viewing Commit Statuses

	Synchronized Page Edge Scrolling

	4 Cells
	Select and Manipulate Cells
	Enter or Change Values in a Cell
	Modify Data with Cell Formulas
	Using Math Formulas
	Overriding Spread Methods
	Replicate: [value] r
	Evenly: [value] e
	Proportionally: [value] p
	Delta: [value] d


	Enter Measure Data Using a Scaling Factor

	Clear and Fill Cells in a View
	Clear
	Clear Cells
	Clear a Dimension Level
	Clear a Slice
	Undo Clear

	Fill
	Undo Fill


	Modifying Cell Data
	Revert Cell
	Protection Processing
	Measure Protection Processing
	Dimension Protection Processing


	Single Hierarchy Select
	Cut, Copy, and Paste
	Cut
	Copy
	Paste

	Cut, Copy, and Paste Special
	Cut Special
	Copy Special
	Paste Special

	Copy to External and Paste from External
	Copy to External
	Paste from External

	Read-only Measures
	Locking and Unlocking
	Cells
	Measures
	Positions
	Locking and Unlocking Methods
	Locking through the Right-click Context Menu
	Locking through the Edit Menu
	Locking with the Lock Icon



	5 Formatting
	Default Cell Formats
	Modify Formatting
	Using the Filter to Find Measures
	Modifying Measure Styles
	Applying Measure Formats

	Modifying Number Formatting
	Applying Number Formats

	Modifying Exceptions
	Applying Exception Formatting

	Modifying Dimension Styles
	Applying Dimension Styles


	Saving Formats
	Format Levels
	Saving Options
	Save Changes Only
	Save All
	Inheritance Formatting


	Deleting Formats

	6 Dimensions, Levels, and Positions
	Showing/Hiding Levels
	Using the Right-Click Menu
	Using the Dimension Dialog Box

	Expanding and Collapsing Levels
	Using the Right-Click Menu
	Using the Dimension Dialog Box

	Level Splitting
	Creating a New Split
	Clearing a Split
	Selecting a Split
	Editing a Split

	Showing/Hiding Positions

	7 Measures
	Showing/Hiding/Reordering Measures
	Insert Measures
	Insert Measures Dialog Box
	Accessing the Insert Measures Dialog Box

	Inserting a Measure
	About Inserted Measures


	8 Measure Profiles
	Creating a Measure Profile
	Applying Measure Profiles
	Updating Measure Profiles
	Deleting Measure Profiles
	Deleting a Measure Profile: Method 1
	Deleting a Measure Profile: Method 2


	9 Dynamic Position Maintenance
	DPM Restrictions
	Add a New Position to a Dimension
	Modify an Informal Position
	Delete an Informal Position
	Using the DPM Search Feature

	10 Dynamic Attributes
	Accessing the Define New Attribute Dialog Box
	Creating Dynamic Attributes
	Managing Dynamic Attributes
	Accessing the Manage Dynamic Attributes Dialog Box
	Editing Dynamic Attributes
	Copying Dynamic Attributes
	Renaming Dynamic Attributes
	Deleting Dynamic Attributes

	Updating Attribute Values

	11 Sort, Find, and Position Queries
	Sort
	Simple Sort
	Sorting By Column Headers
	Sorting with the Toolbar Icons
	Sorting in Outline Mode and Block Mode
	Outline Mode
	Block Mode

	Sorting Across Page Edge
	Undo Sort Using the Context Menu


	Attribute Sorting
	Select Attributes for Display
	Displaying Attributes in Views
	Outline View
	Views
	Merge/Split

	Block View
	Page Edge
	Reordering Attributes
	Hiding Attributes


	Attribute Based Sort

	Find
	Find from the Right-Click Context Menu
	Find from Edit Menu or Ctrl + F
	Find from the View Toolbar

	Position Query
	Using Position Queries
	Position Query Filtering Without Calculating
	Updating Measure Data in Position Queries
	Scrolling in Position Queries

	Using Position Queries with Auto Evaluate
	Updating Measure Data with Auto Evaluate
	Scrolling with Auto Evaluate

	No Position Query Matches


	12 Working With Charts
	Viewing Charts
	Working with Charts
	Charts View User Interface
	Editing a Chart
	Customizing a Chart
	Understanding the Chart Formatting Window

	Saving a Chart as an Image
	Available Chart Types
	Area Chart
	Bar Chart
	Bubble Chart
	Column Chart
	Combination Chart
	Line Chart
	Pareto Chart
	Pie Chart
	Ring Chart
	Radar Chart
	Scatter Chart



	13 Images
	Associating Images with a Position
	Deleting Images
	Viewing Image from a View
	Viewing Images - Method 1
	Viewing Images - Method 2

	Comparing Images

	14 Print and Export
	Page Setup
	Page Tab
	Margin Tab
	Header/Footer
	Sheet
	Page Breaks

	Export
	Export to a Text File
	Export to Excel
	Option 1: Export Option in the File Menu
	Option 2: Export Icon in the Toolbar


	Print
	Option 1: Print Option in the File Menu
	Option 2: Print Icon in the Toolbar


	15 Special RPAS Fusion Client Features
	Alert Manager
	Show/Open the Alert Manager Window
	Building an Alert Manager Workbook
	Inserting an Alert in an Existing Workbook
	Finding Alerts
	Resolving Alerts

	Percent-of-Parent Measures
	Absolute
	Relative
	Comparing Absolute and Relative Percent-of-Parent Measures

	Select All
	Select All: Method 1
	Select All: Method 2

	Replicate Selections
	Using Replicate Selections to Copy and Paste
	Using Replicate Selections for the Chart View



