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Copyright and Trademarks 
Copyright © 1995, 2008, Oracle. All rights reserved. 

The Programs (which include both the software and documentation) contain proprietary information; 
they are provided under a license agreement containing restrictions on use and disclosure and are 
also protected by copyright, patent, and other intellectual and industrial property laws. Reverse 
engineering, disassembly, or decompilation of the Programs, except to the extent required to obtain 
interoperability with other independently created software or as specified by law, is prohibited. 

The information contained in this document is subject to change without notice. If you find any 
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to be error-free. Except as may be expressly permitted in your license agreement for these 
Programs, no part of these Programs may be reproduced or transmitted in any form or by any 
means, electronic or mechanical, for any purpose. 

If the Programs are delivered to the United States Government or anyone licensing or using the 
Programs on behalf of the United States Government, the following notice is applicable: 

U.S. GOVERNMENT RIGHTS Programs, software, databases, and related documentation and 
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Restricted Rights (June 1987). Oracle USA, Inc., 500 Oracle Parkway, Redwood City, CA 94065. 
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use of the Programs. 

Oracle and Agile are registered trademarks of Oracle Corporation and/or its affiliates. Other names 
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The Programs may provide links to Web sites and access to content, products, and services from 
third parties. Oracle is not responsible for the availability of, or any content provided on, third-party 
Web sites. You bear all risks associated with the use of such content. If you choose to purchase 
any products or services from a third party, the relationship is directly between you and the third 
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Preface 
The Oracle documentation set includes Adobe® Acrobat™ PDF files. The Oracle Technology 
Network (OTN) Web site (http://www.oracle.com/technology/documentation/agile.html) contains the 
latest versions of the Oracle Agile EDM PDF files. You can view or download these manuals from 
the Web site, or you can ask your Agile administrator if there is an Oracle Documentation folder 
available on your network from which you can access the documentation (PDF) files. 

Note To read the PDF files, you must use the free Adobe Acrobat Reader™ version 7.0 or later. 
This program can be downloaded from the Adobe Web site (http://www.adobe.com). 

 

Note Before calling Agile Support about a problem with an Oracle Agile EDM manual, please 
have the full part number, which is located on the title page. 

TTY Access to Oracle Support Services 

Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services within the 
United States of America 24 hours a day, 7 days a week. For TTY support, call 800.446.2398. 
Outside the United States, call +1.407.458.2479. 

Documentation Accessibility  

Our goal is to make Oracle products, services, and supporting documentation accessible, with good 
usability, to the disabled community. To that end, our documentation includes features that make 
information available to users of assistive technology. This documentation is available in HTML 
format, and contains markup to facilitate access by the disabled community. Accessibility standards 
will continue to evolve over time, and Oracle is actively engaged with other market-leading 
technology vendors to address technical obstacles so that our documentation can be accessible to 
all of our customers. For more information, visit the Oracle Accessibility Program Web site at 
http://www.oracle.com/accessibility/ http://www.oracle.com/accessibility/.  

Readme 

Any last-minute information about Oracle Agile EDM can be found in the Release Notes file on the 
Oracle Technology Network (OTN) Web site 
(http://www.oracle.com/technology/documentation/agile.html) 

 

Agile Training Aids 

Go to the Oracle University Web page 
(http://www.oracle.com/education/chooser/selectcountry_new.html) for more information on Agile 
Training offerings. 

Accessibility of Code Examples in Documentation  

Screen readers may not always correctly read the code examples in this document. The 
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conventions for writing code require that closing braces should appear on an otherwise empty line; 
however, some screen readers may not always read a line of text that consists solely of a bracket or 
brace.  

Accessibility of Links to External Web Sites in Documentation  

This documentation may contain links to Web sites of other companies or organizations that Oracle 
does not own or control. Oracle neither evaluates nor makes any representations regarding the 
accessibility of these Web sites.  
 





 

Chapter 1  

Introduction 

Overview 
This manual describes the installation, configuration and customizing options for the Agile e6 
SolidWorks Integration. The information in this document is related to the standard installation so 
that the actual appearance of your installation may vary.  

Note For additional information on Agile e6 e.g. Installation or File Management refer to the 
Agile e6 documentation on the Agile e6 product CD or the Agile Documentation Website 
at https:\docs.agile.com (requires a user/password). 

Note For additional information on SolidWorks refer to SolidWorks documentation on the 
appropriate product DVD.  

Architecture 
The architecture of the integration between Agile e6 and SolidWorks is based on the Object Linking 
and Embedding (OLE) software technology created by Microsoft. Therefore a central component of 
the CCM-integration is the so-called “Cax-OLE-server” (CaxOleSrv.exe).  

The communication between the SolidWorks (as the OLE-client) and the Cax-OLE-server is 
realized by the Remote Procedure Call protocol (rpc).  

So-called ECI functions (ECI = External Communication Interface) are used to realize the 
Interprocess Communication (IPC)-based on Application Programming Interface (API) of Agile e6 to 
link to the CAD systems SolidWorks. 

It enables a close interaction between the CAD system and the database. This is called “CAX”, an 
acronym that simply adds the idea of “eXtensibility” to the familiar acronym “CAD”. 
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Manipulation of the CAD structure and objects (e.g. creation, moving, deleting, copying, etc.) are 
made in the CAD system. It represents the "Engineering Master". 

Agile e6 is the "Organizational Master" for managing CAD objects/structures which are significant 
as independent objects in the construction and release process of a company (e.g. single parts, 
drawings, 3D models) but not as individual CAD base elements (e.g. lines, surfaces, bodies, etc.). 
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Chapter 2  

Installation and Configuration 
This chapter describes the installation of the integration itself and the configuration to start a 
standard integration without customer-specific settings. The integration (CCM) is installed in four 
steps which must be followed for a correct installation:  

1. Checking the Prerequisites 

2. Unpacking the Delivered Archive File 

3. Running the <…>.bat 

4. Defining the Temporary (Transfer) Directory 

5. Testing the Integration with Standard Dump 

6. Deinstallation 

Checking the Prerequisites 
For a complete and most current list of all officially supported platforms and software versions, 
please visit the Platform Support page on our website at: 
http://eignersupport.agilesoft.com/index.asp (you need a password to enter the support website). 

In addition to the required software versions, check the following items before starting the 
installation.  

 A user with administrator privileges is logged into the operating system.  

 Agile e6 is installed and running.  

 The Agile e6 file management service (FMS or DFM) works properly. 

 A user environment is already set up in Agile e6. 

 Two Agile e6 users for logging into the system and for testing (test user with password) are 
created 

 SolidWorks is installed and can be started properly. 

Unpacking the Delivered Archive File 
7. Extract the installation file CCM_2_8_0_0.zip to any folder e.g. the folder location 

C:\AgilePLM\ccm.  

When you unzip, make sure that you retain the folder paths from the zip file. When the files are 
unzipped, you should see the following folder structure in the directory you specified for unzipping:  
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Main Directory Sub-directory Sub-directory Description 

\server  Software concerning the CaxOLE-server 

 \Dll Contains binary library files 

 \Loader 

Contains a loader file (in ASCII format) for 
the LogiView logic model "CAX". One-off 
it has to be added/loaded to the used 
PLM environment of the server if it is not 
present there yet. 

The two containing procedures 
CaxDisplayItem and 
CaxDisplayDocument enable to display 
the metadata set in a "Document form" 
when clicking in the Agile-menu "Display 
Metadata" or to display the related item 
metadata set in a "Item form" when 
clicking in the Agile-menu "Display 
Metadata". 

 MSXML 

Contains the installer package for 
Microsoft XML Parser (MSXML). 

Needed to be launched if this parser is 
not yet installed on the local machine. 

 \Scripts Start scripts (*.bat) and scripts is 
internally (*.tcl) 

  \TclLibrary Required software to run Tcl 

  \Txt Message texts and menu texts (*.txt) 

 \SW2005   
Contains the executable program 
CaxOleSrv.exe to interact with 
"SolidWorks 2005" 

 \SW2006 
Contains the executable program 
CaxOleSrv.exe to interact with 
"SolidWorks 2006" 

 \SW2007 
Contains the executable program 
CaxOleSrv.exe to interact with 
"SolidWorks 2007" 

\SolidWorks    Used binary libraries and executable files.
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Main Directory Sub-directory Sub-directory Description 

 \SW2005   
Contains the runtime library 
agilePLMSW.dll  to interact with 
"SolidWorks 2005" 

  \SW2006 
contains the runtime library 
agilePLMSW.dll  to interact with 
"SolidWorks 2006" 

  \SW2007 
contains the runtime library 
agilePLMSW.dll  to interact with 
"SolidWorks 2007" 

Running Command Procedure RegisterSW200<x>.bat 
There are two executable files in binary format CaxOleSrv.exe and agilePLMSW.dll. Their content is 
specific for the used SolidWorks version. In order to secure that the CCM integration always works 
automatically with the right content of that files they have to be registered. 

The way to accomplish this is to run one-off the command procedure registerSW200<x>.bat (x 
stands for the last cipher of the used SolidWorks version).  

Command line of file registerSW2007.bat Description 

Server\setenv.exe CaxOleLanguage=EN the content of the operating system 
variable CaxOleLanguage will be set 
permanently to "EN"  
(no reboot is necessary). 

Note – If it should be set to German (DE) 
edit the batch script before running the 
integration.  

Replace "=EN" by "=DE". 

Server\setenv.exe 
CaxOleScriptDir=%~dp0%Server\Scripts 

The content of the operating system 
variable CaxOleScriptDir will be set 
permanently to "%~dp0%Server\Scripts" 
(no reboot is necessary). 

copy SolidWorks\SW2007\agilePLMSW.dll 
SolidWorks\agilePLMSW.dll 

The runtime library agilePLMSW.dll which 
is suitable to interact with "SolidWorks 
2007" will be copied into the directory 
…\SolidWorks  . 

copy Server\SW2007\CaxOleSrv.exe 
Server\CaxOleSrv.exe 

The executable program CaxOleSrv.exe 
which is suitable to interact with 
"SolidWorks 2007" will be copied into the 
directory …\Server  . 

regsvr32 SolidWorks\agilePLMSW.dll The runtime library agilePLMSW.dll will 

 Chapter 2- 11

  

 



Oracle Agile Engineering Data Management - MCAD Connector for SolidWorks  
 

be registered in the operating system. 

Server\CaxOleSrv.exe /regserver The executable program CaxOleSrv.exe 
will be registered in the operating system. 

 

When the process CAX-OLE-server is running you can see a small symbol (a globe) in the task bar 
at the lower right corner of the screen.  

 

This process will be closed always automatically at the end of a SolidWorks session. Only after 
running the batch file registerSW200<x>.bat, it has to be closed manually by right-clicking on the 
globe symbol and choosing "Exit". 

Next, a start script needs to be created. 

8. Create the file dtv.bat in …\Server\Scripts\. 

9. To find the correct path for this file, type the following into a command line (e.g. DOS shell) 
set CAXOLEScriptDIR 

Note The system shows the correct path to the directory where dtv.bat needs to be created.  

10. Add the following commands to dtv.bat and customize them accordingly (bold text in example). 

 

rem    ================================================= 

rem    Example Start Script dtv.bat  

rem    ================================================= 

rem 

          set AXA_ROOT="absolute_path/Your_Agile_e6_start_command" 

          pushd %AXA_ROOT% 

          start /b plm.cmd -p ECI-TOPIC:t:1:h:localhost:r:3333 

          popd 

rem    ================================================= 

rem    ================================================= 
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Note This script will then start the Agile e6 integration whenever SolidWorks is started. 

Note Information on how to test the integration with the standard dump can be found under 
“Testing the Integration with Standard Dump”. 

At least the file 3DCADMapping.ini has to be edited. Its content defines essential integration 
settings.  

Note Avoid blank lines in this file! At least a semicolon (used as comment sign) has to be 
placed at the start of line.  

Make sure the lines starting with "-Djava." or "-Dagile." at the beginning of that file should always 
proceeded with a semicolon in order to mark them as comments. They are only used for the 
integration to Agile9. 

The complete path name (i.e. drive + path) of the directory containing the local logfiles is defined in 
section [LogFileDir].  

Defining the Temporary (Transfer) Directory 
When installing the integration, a temporary directory for the file transfer has to be defined in the file 
„3DCADMapping.ini“. The directory D:\axalanttmp\ is the default. The directory name is assembled 
from the content of two sections. In section [CheckOutDisk] the drive character inclusive the colon is 
defined. In section [CheckOutPath] the path is defined. 

; 
[CheckOutDisk] 
; 
D: 
; 
[CheckOutPath] 
; 
\axalanttmp\

If you want to define a different directory, change the respective values in the 3DCADMapping.ini 
file. If the defined directory doesn't exist yet at the specified location than it will be created on first 
checking-out from database if the user has the right to do this.  

Keep in mind that for the check-out of large assemblies enough space should be available 
temporary. 

Testing the Integration with Standard Dump 
The basic installation (“out-of-the-box”) is compatible with an Agile e6 standard environment 
(standard dump). 

Having unzipped the installation file, run the command procedure "registerSW200<x>.bat" and 
edited the file "3DCADMapping.ini " the default integration should now work using an Agile e6 
standard environment (standard dump). In order to realize customer demands additional 
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customizing is necessary. 

Now, if a SolidWorks session is launched simultaneously, a CAX-OLE server process is started in 
the background. You will see a small symbol in the task bar (lower right corner of the screen) 
indicating that the CAX-OLE server is running. If the SolidWorks session will be closed than the 
CAX-OLE server process will be finished too. This ensures registering the binary files mentioned 
above. 

To add the main menu entry Agile to the menu bar, select:  

Tools > Add-Ins > Agile PLM  and click OK. 

Now, if you start SolidWorks, the additional menu is added to your main menu.  

 

A model or drawing can now be loaded from Agile e6 to the CAD software. 

Note Harmonization of the menu structure for all Agile CAD-Integrations: 
 
The integration's menu tree has been reengineered in order to align as well the menu 
structures as the menu names itself. This had been done as unified as possible regarding 
to all the integrations available for Agile e6. 
 
The possible menu tree starts with the entry "Agile" in the top-level menu of SolidWorks. 
This is steered by the content of the file PlmSWAddin.xml to be found in directory  
…\acm\Server\Scripts . 

Deinstallation 
To uninstall the integration software follow the steps below:  

11. Run the batch script unregisterSW<version>.bat 

Command line of file unregisterSW.bat Description 

regsvr32 -u 
SolidWorks\agilePLMSW.dll 

The runtime library agilePLMSW.dll will be 
unregistered in the operating system. 

Server\CaxOleSrv.exe /unregserver The executable program CaxOleSrv.exe will be 
unregistered in the operating system. 

12. Delete the directory tree of the CCM integration completely manually. (The tree is the result of 
unpacking the delivered .zip file at installation time. If a file in such a directory was edited than 
the tree and this file are not deleted automatically.  Delete the temporary Check out directory.  
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Chapter 3  

Special Customizing for Windows XP 64bit 
The 64bit interface is integrated as a macro in SolidWorks. Therefore, the file PlmSWMacro.swp 
exists in the directory ccm\Server\Scripts and contains links to DLLs used by the integration. This 
file needs to be adapted locally. This can be done in the following way: 

13. Start SolidWorks. 

14. Select Tools > Macro > Edit. 

15. A file selection window is opened. 

16. Select the file PlmSWMacro.swp (ccm\server\Scripts) and click Open. 

The VBA development environment for SolidWorks is opened. 

17. Select Tools > References 

The References – PlmSWMacro window is opened. 

Note All registered DLLs are listed. The ones used by the integration are ticked 

18. Select the reference axalantSW 1.0 Typbibliothek. 

19. Click Browse 

20. Select ccm\SolidWorks\agilePLMSW.dll 

21. Click Open. 

Note The reference axalantSW 1.0 SolidWorks is linked to agilePLMSW.dll. 

22. In the References – PLMSWMacro window click OK. 

23. The VBA development environment for SolidWorks is opened again. 

24. Select Debug > Compile PlmSWMacro. 

25. Select File > Close and Return to SolidWorks. 

The Save Changes window is opened in SolidWorks. 

26. Save Changes to …..\ccm\Server\Scripts\PlmSWMacro.swp?. click Yes. 

27. To activate the integration in SolidWorks, select Tools > Add-Ins. 

The Add-Ins window is opened. 

28. Select AgilePLM on both sides and click OK. 

Note This instruction is also available in German as PDF file in the Software distribution. 
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Chapter 4  

Customizing 
The following sections describe some basic customization to adapt the installed software to a non-
standard environment. 

Data Model 
The standard configuration of Agile e6 already contains the tables and fields that are required for 
this integration and displays them in the standard masks.  

Standard Tables and Fields 

To support special customizing the following tables and fields are needed:  

Table Field Type Description 

T_DOC_DAT CAX_TYPE S20 CAX Object type  

  CAX_SUBTYPE S20 CAX Subtype 

  CAX_TIMESTAMP S20 Time stamp 

  CAX_CRE_SYSTEM S40 Creating system 

  CAX_FIL_PATH S255 File path 

  CAX_FIL_NAME S255 File name 

  CAX_FIL_OLD_PATH S255 Old File path 

  CAX_FIL_OLD_NAME S255 Old File name 

T_DOC_STR UG2_IDENT S40 Structure ident 

  CAX_COM S255 Component 

  CAX_REF S255 Reference 

T_MASTER_STR UG2_IDENT S40 Structure ident 

T_MASTER_DOC CAX_CONFIG S20 Configuration 

These fields must be found in the used Agile e6 masks in any sequence and should be “Read only” 
for the user. The virtual width of the mask fields (“Wid/vir”) must be large enough.  

Note Only the fields CAX_TYPE and CAX_CRE_SYTEM have to be visible.  
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Standard Masks  

The Agile e6 standard dump contains the following masks with relevant fields to the SolidWorks-
Integration. 

Mask Field 

T_DOC_DAT.CAX_TYPE 

T_DOC_DAT.CAX_SUBTYPE 

T_DOC_DAT.CAX_CRE_SYSTEM 

T_DOC_DAT.CAX_FIL_PATH 

T_DOC_DAT.CAX_FIL_NAME 

T_DOC_DAT.CAX_TIMESTAMP 

T_DOC_DAT.CAX_FIL_OLD_PATH 

EDB-DOC-DRW-TFR and EDB-DOC-DRW-TLI 

T_DOC_DAT.CAX_FIL_OLD_NAME 

T_DOC_DAT.CAX_TYPE 

T_DOC_DAT.CAX_SUBTYPE 

T_DOC_DAT.CAX_CRE_SYSTEM 

T_DOC_DAT.CAX_FIL_PATH 

T_DOC_DAT.CAX_FIL_NAME 

T_DOC_DAT.CAX_TIMESTAMP 

T_DOC_DAT.CAX_FIL_OLD_PATH 

EDB-DOC-3DM-TFR and EDB-DOC-3DM-TLI 

T_DOC_DAT.CAX_FIL_OLD_NAME 

T_DOC_DAT.CAX_TYPE 

T_DOC_DAT.CAX_SUBTYPE 

T_DOC_DAT.CAX_CRE_SYSTEM 

T_DOC_DAT.CAX_FIL_PATH 

T_DOC_DAT.CAX_FIL_NAME 

EDB-DOC-CFR 

T_DOC_DAT.CAX_TIMESTAMP 

T_DOC_DAT.CAX_FIL_OLD_PATH 
EDB-DOC-CFR 

T_DOC_DAT.CAX_FIL_OLD_NAME 

EDB-DOC-STR-RLI and EDB-DOC-STR-ALI T_DOC_STR.UG2_IDENT 
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Mask Field 

T_DOC_STR.CAX_COM 

T_DOC_STR.CAX_REF 

EDB-ART-STR-RLI T_MASTER_STR.UG2_IDENT 

EDB-ART-DOC-RLI and EDB-ART-DOC-ALI 

T_MASTER_DOC.CAX_CONFIG 

To increase the performance of the data exchange, an additional database index for the field 
T_DOC_DAT.CAX_FIL_NAME can be created with a unique name e.g. „CAX_FIL_IND“. 

Special Standard Menus Used Inside Agile e6 

There are special menus for the integration e.g.  

 EDB-ECX-SEL-SLS 

 EDB-ECX-ART-LOA-SLS 

They contain the selections  

EDB-ECX-CAD "Selection to CAD" A selected object will be sent to the 
SolidWorks session and the control returns to 
the CAD system. 

EDB-ECX-BRK "Return to CAD" The control returns to the CAD system 
immediately. 

For special customizing which involves additional “load masks”, these selections have to be 
integrated into the appropriate select menu of the mask as shown in the following screenshot. 
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Setting a Customer-Specific Vault 
When the objects are saved, the files are automatically checked into an Agile e6 file vault. The 
default name of the vault used in the installation is “CADFILES”. 

If you want to use a different file vault name, create a special vault with a privileged PLM user like 
e.g. “EDBCUSTO” and adapt the 3DCADMapping.ini file.  

29. In Agile e6; select Manager > File Management > Vaults. 
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30. Create a vault with a new name (not “CADFILES”). 

Ensure that the vault name is entered correctly – the name is case-sensitive.  

31. Test if files can be checked into the vault manually.  

32. Open the „3DCADMapping.ini“ file located in the directory:  

Connector\CaxIntegration\Server\Scripts 

33. Enter the name of the Agile e6 vault in the lines that are defined by 

„FDEF:T_FILE_DAT.STORAGE_AREA“.  

FDEF:T_FILE_DAT.STORAGE_AREA    = CADFILES 

...

Note This selection must be updated for each document type used in the integration. This 
means that the vault name must be entered in all „CheckIn<Type>“ sections.  

Note It is also possible to use different vaults for different document types.  

34. Edit the „GetFileData“ section entering the new vault name.  

... 

SEL2:T_STORE_AREA.STORAGE_AREA          = CADFILES 

... 
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Note When using File Management (DFM), special requirements must be observed. Please 
contact your Agile representative. 

Creating the File Name Automatically 

Automatic Creation of File Name at Check-In 

When checking in a SolidWorks object for the first time, the file name is defined by the system 
automatically (Default setting).  

If you want to create your own file names, you need to change the content of the section 
[DefaultSave] in the file 3DCADMapping.ini from “1” to “0”. 

[DefaultSave]  
;  
0  
;  

This will prompt the user to set the file name for the SolidWorks object files manually. The file name 
is stored in the ,,Name" field called (T_DOC_DAT.DOC_NAME) of the meta data set and must be 
unique. 

Changing the Default Name Structure 

The structure of the default file name is defined in the Tcl procedure EDBFileName in the files 
3CADSaveObject.tcl and 3DCADAssign.tcl. This ensures that the SolidWorks objects get a unique 
file name at first check–in as well as when assigning the object to an existing meta data set. 

The default file name has the following structure:  

unique file name: crank-arm_CAX-00001066_0_0.SLDPRT 

Structure part Example 

(Original) file name crank-arm 

separator _ 

document number CAX-00001066 

separator _ 

document version 0 

separator _ 

document revision 0 

.file extension .SLDPRT 

If you want to use another file name structure, you need to modify both tcl files mentioned above. 

Chapter 4 - 22 Oracle Agile Engineering Data Management 

 

 



   

 

Standard Parts and Help Parts  

Standard Parts 

When an assembly is checked in, it often comprises several standard parts (= Norm parts). Thus, 
those parts must be checked-in without renaming the file as described.  

If it would not be distinguished between common parts and standard parts, each standard part in an 
assembly would belong to a separate document. Several Standard part libraries are available for 
usage in SolidWorks, e.g. CADENAS or PowerWorksNorm.   

In order to include such libraries, the path in the section [PowerWorksLibraryPartPath] of the file 
3DCADMapping.ini needs to be adapted.  

0 Common Object  

1 Standard part 
In-house standard parts 

Original filename remains after Check-in  

2 Help part 
Dummy 

Always used if no item should be assigned 

Can be elaborated using the content of section 
[ItemStructureType]: 
1 → always (regardless whether this object has a 
structure) 
2 → no item, but if this object has a structure than it will be 
displayed in the BOM 

6 semi-finished product All configurations refer to the same item. 

8 purchased item / 
assembly 

An item will be assigned. The structure of this object will 
be ignored. 

Help Parts 

Help parts (e.g. weld seams) should be excluded when creating a BOM by selecting Agile > Create 
BOM.  

Set the parameter [ItemStructureType] in the file 3DCADMapping.ini enables to control the 
behavior. Following values are possible: 

1 Help parts are not represented by an item. They are ignored including their complete  
item substructure. 

2 Help parts are not represented by an item. Their item substructure is lifted 1 level. 

CustomerID 
The content of parameter [CustomerID] in the file 3DCADMapping.ini is used to realize customer-
specific configuration settings. For example this enables to use a customer-specific file name 
structure. The content of this parameter for an out-of-the-box installation is “Default”. 
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Generally it is recommended to activate non-standard Tcl-scripts depending on the content of 
CustomerID. 

Note The CustomerID allocation has to be done always by the Agile Project Engineer in order 
to avoid duplications at Agile. 

Loading Referenced Documents (External References) 

Using the integration it is possible to manage parts which have external references to basic parts. 
To manage these parts in Agile e6, too, the basic parts need to be checked into Agile e6 too. To 
check-in, the basic parts need to be stored in the local source directory. A document/meta dataset 
will then be created for the basic part and references concerning structure relation are stored in 
their metadata set.  

To enable the loading of external references/parts, set the “Load referenced documents” option to 
“All” in the system options/External references window in SolidWorks. 
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Chapter 5  

Debugging 
The most profound view into the integration’s functioning enables tracing the ECI-calls which are 
sent from the local Agile client to the connected Agile server including the responds. A file is created 
on the Agile server machine which can be viewed by user using the client.  

It is possible to start and to stop the ECI-trace at any time during the session.  

The trace function is activated in Agile e6: 

35. Click Tools > Trace > Select Module  

36. Select the checkbox for  ECI-Module E 9. 

37. Click OK.  

38. To start the trace log any time during the session, click Tools > Trace > Trace New .  

The name of the new trace file is displayed in the message bar (e.g. Test output on 
D:\AgilePLM\tmp\tst173.trc). 

Note The file location is that on the Agile server machine! 

39. Execute the process you want to test/trace.  

40. To end tracing, click Tools > Trace > Trace Off. 

41. To display the contents of the trace file in a list, click Tools > Trace > Show trace. 

You can copy and paste the trace contents into an Excel file and save it locally. 

Note The information in the trace file can be extended by e.g. adding SQL statements.  
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