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Copyright and Trademarks 
Copyright © 1995, 2008, Oracle. All rights reserved. 

The Programs (which include both the software and documentation) contain proprietary information; 
they are provided under a license agreement containing restrictions on use and disclosure and are 
also protected by copyright, patent, and other intellectual and industrial property laws. Reverse 
engineering, disassembly, or decompilation of the Programs, except to the extent required to obtain 
interoperability with other independently created software or as specified by law, is prohibited. 

The information contained in this document is subject to change without notice. If you find any 
problems in the documentation, please report them to us in writing. This document is not warranted 
to be error-free. Except as may be expressly permitted in your license agreement for these 
Programs, no part of these Programs may be reproduced or transmitted in any form or by any 
means, electronic or mechanical, for any purpose. 

If the Programs are delivered to the United States Government or anyone licensing or using the 
Programs on behalf of the United States Government, the following notice is applicable: 

U.S. GOVERNMENT RIGHTS Programs, software, databases, and related documentation and 
technical data delivered to U.S. Government customers are "commercial computer software" or 
"commercial technical data" pursuant to the applicable Federal Acquisition Regulation and agency-
specific supplemental regulations. As such, use, duplication, disclosure, modification, and 
adaptation of the Programs, including documentation and technical data, shall be subject to the 
licensing restrictions set forth in the applicable Oracle license agreement, and, to the extent 
applicable, the additional rights set forth in FAR 52.227-19, Commercial Computer Software--
Restricted Rights (June 1987). Oracle USA, Inc., 500 Oracle Parkway, Redwood City, CA 94065. 

The Programs are not intended for use in any nuclear, aviation, mass transit, medical, or other 
inherently dangerous applications. It shall be the licensee's responsibility to take all appropriate fail-
safe, backup, redundancy and other measures to ensure the safe use of such applications if the 
Programs are used for such purposes, and we disclaim liability for any damages caused by such 
use of the Programs. 

Oracle and Agile are registered trademarks of Oracle Corporation and/or its affiliates. Other names 
may be trademarks of their respective owners. 

The Programs may provide links to Web sites and access to content, products, and services from 
third parties. Oracle is not responsible for the availability of, or any content provided on, third-party 
Web sites. You bear all risks associated with the use of such content. If you choose to purchase 
any products or services from a third party, the relationship is directly between you and the third 
party. Oracle is not responsible for: (a) the quality of third-party products or services; or (b) fulfilling 
any of the terms of the agreement with the third party, including delivery of products or services and 
warranty obligations related to purchased products or services. Oracle is not responsible for any 
loss or damage of any sort that you may incur from dealing with any third party. 
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Preface 
The Oracle documentation set includes Adobe® Acrobat™ PDF files. The Oracle Technology 
Network (OTN) Web site (http://www.oracle.com/technology/documentation/agile.html) contains the 
latest versions of the Oracle Agile EDM PDF files. You can view or download these manuals from 
the Web site, or you can ask your Agile administrator if there is an Oracle Documentation folder 
available on your network from which you can access the documentation (PDF) files. 

Note To read the PDF files, you must use the free Adobe Acrobat Reader™ version 7.0 or later. 
This program can be downloaded from the Adobe Web site (http://www.adobe.com). 

 

Note Before calling Agile Support about a problem with an Oracle Agile EDM manual, please 
have the full part number, which is located on the title page. 

TTY Access to Oracle Support Services 

Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services within the 
United States of America 24 hours a day, 7 days a week. For TTY support, call 800.446.2398. 
Outside the United States, call +1.407.458.2479. 

Documentation Accessibility  

Our goal is to make Oracle products, services, and supporting documentation accessible, with good 
usability, to the disabled community. To that end, our documentation includes features that make 
information available to users of assistive technology. This documentation is available in HTML 
format, and contains markup to facilitate access by the disabled community. Accessibility standards 
will continue to evolve over time, and Oracle is actively engaged with other market-leading 
technology vendors to address technical obstacles so that our documentation can be accessible to 
all of our customers. For more information, visit the Oracle Accessibility Program Web site at 
http://www.oracle.com/accessibility/ http://www.oracle.com/accessibility/.  

Readme 

Any last-minute information about Oracle Agile EDM can be found in the Release Notes file on the 
Oracle Technology Network (OTN) Web site 
(http://www.oracle.com/technology/documentation/agile.html) 

 

Agile Training Aids 

Go to the Oracle University Web page 
(http://www.oracle.com/education/chooser/selectcountry_new.html) for more information on Agile 
Training offerings. 

Accessibility of Code Examples in Documentation  

Screen readers may not always correctly read the code examples in this document. The 
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conventions for writing code require that closing braces should appear on an otherwise empty line; 
however, some screen readers may not always read a line of text that consists solely of a bracket or 
brace.  

Accessibility of Links to External Web Sites in Documentation  

This documentation may contain links to Web sites of other companies or organizations that Oracle 
does not own or control. Oracle neither evaluates nor makes any representations regarding the 
accessibility of these Web sites.  
 





 

Chapter 1  

Introduction 

Overview 
This manual describes the installation, configuration and customizing options for the Agile e6 
SolidEdge integration (CCH). The information in this document is related to the standard installation 
so the actual appearance of your installation may vary.  

Note For additional information on Agile e6 e.g. Installation or File Management refer to the 
Agile e6 documentation on the Agile e6 product CD or the Agile Documentation Website 
at https:\docs.agile.com (requires a user/password). 

Note For additional information on SolidWorks refer to SolidWorks documentation on the 
appropriate product DVD. 

Architecture 
The architecture of the integration between Agile e6 and SolidEdge is based on the Object Linking 
and Embedding (OLE) software technology created by Microsoft. Therefore, a central component of 
the CCM-integration is the so-called “Cax-OLE-server” (CaxOleSrv.exe).  

The communication between the SolidEdge (as the OLE-client) and the Cax-OLE-server is realized 
by the Remote Procedure Call protocol (rpc).  

So-called ECI functions (ECI = External Communication Interface) are used to realize the 
Interprocess Communication (IPC)-based on Application Programming Interface (API) of Agile e6  to 
link to the CAD systems SolidEdge. 

It enables a close interaction between the CAD system and the database. This is called “CAX”, an 
acronym that simply adds the idea of “eXtensibility” to the familiar acronym “CAD”. 

The following figure shows the simplified architecture of the integration between SolidEdge and 
Agile e6: 
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Manipulations of the CAD structure or of CAD objects (such as creating, interconnecting, deleting, 
copying, etc.) are performed from the CAD system. The CAD system represents the “Engineering 
Master”.  

Agile e6 is the „Organizing Master“ that manages the CAD objects/structures, which are significant 
as independent objects in the construction/design sequence of a company (such as piece parts, 
drawings, 3-D models), but no individual CAD elements (such as lines, areas, bodies, etc.). 
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Chapter 2  

Installation 
Note After a correct installation, a basic structure of the integration is running. The original files, 

especially the text files containing default values should NOT be changed. 

The installation of the Agile e6 SolidEdge integration CCH is divided into several steps. Performing 
the steps in the proper order is important for correct operation. 

The following steps must be carried out: 

1. Prerequisites 

2. Checking the Prerequisites 

3. Unpacking the Archive File 

4. Customizing Vault Options 

5. Deinstallation 

Prerequisites 

The Agile e6-SolidEdge integration is currently available for several hardware platforms and 
operating systems.  

For a complete and most current list of all officially supported platforms, see the Release Notes.  

Checking the Prerequisites 
 Agile e6 is installed and running.  

For running the integration, the following Agile e6 licenses are required as a minimum:  
 Technical Document Management Solution 
  Product Data Management (PDM) solution for managing items and bills of material based 

on the SolidEdge structure 
 DataView development license if you want to customize your integration 

 A license for using the CCH connector is registered and available on the FELICS license 
server.  
You can obtain the required licenses from the Agile Sales Representative.  

 A user with administrator privileges is logged into the operating system.  

) works properly. 

ting (test user with password) are created. 

 dge integration requires a concurrent license for the following module: CCH ... 

 The Agile e6 file management service (FMS or DFM

 A user environment is already set up in Agile e6. 

 Agile e6 users for logging into the system and for tes

 Solid Edge is installed and can be started properly. 

The Solid E
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#003147. 

Unpacking the Archive File 
To install the CCH integration, extract the delivered zip-file to any path, e.g. C:\AgilePLM\cch  

W
u

hen you unzip, make sure that you retain the folder paths from the zip file. When the files are 
nzipped, you should see the following folder structure in the directory you specified for unzipping:  

 

Main Directory Sub-directory Sub-directory Description 

\server   Software concerning the CaxOLE-server 

 \Scripts Start scripts (*.bat) and internally used scripts  (*.tcl) 

  \TclLibrary Required software to run Tcl 

  \Txt ts (*.txt) Message texts and menu tex

 \Dll   Contains binary library files 

 \Loader 

 e 
o be 

dered") to the used PLM 

ument 
 in an Agile 

document form when selecting the menu 

Contains a loader file (in ASCII format) for th
LogiView logic model "CAX". One-off it has t
added ("loa
environment of the server if it is not present 
there yet. 

The containing procedure CaxDisplayDoc
enables to display the metadata set

"Display document metadata set". 

 \MSXML  

L 

Needed to be launched if this parser is not yet 

Contains the installer package for Microsoft XM
Parser (MSXML). 

installed on the local machine. 

\Solid Edge    Required binary libraries and executable files 

Now the integration is installed and works with an Agile e6 standard environment (standard dump).  

 another name, you 

Note How to set up a vault can be found in the Agile e6 documentation. 

Customizing Vault Options 
The default name of the used vault is “PROE” (capitalized). If you want to use
need to change it in Agile e6. 
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Deinstallation 
To uninstall the integration software follow the steps below:  

1. Run the batch script unregisterSE.bat 

Command Line of File 
unregisterSE.bat 

Description 

regsvr32 -u 
SolidEdge\agilePLMSEClient.dll 

The runtime library PLMSEClient.dll will be 
unregistered in the operating system. 

Server\CaxOleSrv.exe /unregserver The executable program CaxOleSrv.exe will be 
unregistered in the operating system. 

2. Delete the complete directory tree of the CCH integration manually.  

The tree is the result of unpacking the delivered .zip file at installation.  

3. Delete the temporary local Check-out directory. 
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Chapter 3  

Configuration 
When the integration is set up correctly, it works in default mode. The behavior of the integration 
can now be configured. 

Running the Command Procedure registerSW200<x>.bat 
There are three executable files in binary format CaxOleSrv.exe, agilePLMSEClient.dll, and 
SExml.dll. To ensure the CCH integration works automatically with those files they have to be 
registered. 

The way to accomplish this is to run the command procedure registerSE.bat once.  

Command Line of File registerSE.bat Description 

.\Server\setenv.exe 
CaxOleLanguage=EN 

The content of the operating system variable 
CaxOleLanguage is set permanently to EN (no reboot 
is necessary). 

Note – If it should be set to German (DE) edit the 
batch script before running the integration.  

Replace EN by DE 

.\Server\setenv.exe 
CaxOleScriptDir=%~dp0%Server\Scripts

The content of the operating system variable 
CaxOleScriptDir is set permanently to 
"%~dp0%Server\Scripts" (no reboot is necessary). 

regsvr32 SolidEdge\PLMSEClient.dll The runtime library PLMSEClient.dll is registered in 
the operating system. 

regsvr32 SolidEdge\SEXml.dll The runtime library SEXml.dll is registered in the 
operating system. 

Server\CaxOleSrv.exe /regserver The executable program CaxOleSrv.exe is registered 
in the operating system. 

When the process CAX-OLE-server is running, a small symbol (a globe) is displayed in the task bar 
at the lower right corner of the screen.  

 

This process will be closed always automatically at the end of a SolidEdge session. Only after 
running the batch file registerSE.bat, it has to be closed manually by right-clicking on the globe 
symbol and choosing "Exit". 

Next, the file …\Server\Scripts\dtv.bat has to be edited to adapt in the first command line the path 
name of the dataview command directory. 
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Finally, the file 3DCADMapping.ini has to be edited. Its content defines essential integration 
settings.  

Note Avoid blank lines in this file! At least a semicolon (used as comment sign) has to be 
placed at the start of the line.  

Make sure the lines starting with "-Djava." or "-Dagile." at the beginning of that file should always 
preceeded with a semicolon to mark them as comments. They are only used for the integration to 
Agile9. 

The complete path name (i.e. drive + path) of the directory containing the local logfiles is defined in 
section [LogFileDir].  

Defining the Temporary (Transfer) Directory 
When installing the integration a temporary directory for the file transfer has to be defined in the file 
„3DCADMapping.ini“. The directory D:\axalanttmp\ is the default. The directory name is assembled 
from the content of two sections. In section [CheckOutDisk] the drive character inclusive the colon is 
defined. In section [CheckOutPath] the path is defined. 

; 
[CheckOutDisk] 
; 
D: 
; 
[CheckOutPath] 
; 
\axalanttmp\ 
; 

Keep in mind that for the check-out of large assemblies enough space should be available 
temporary. 

Creating Own Toolbar 
It is necessary to pass through one-off the following steps in order to create a context-sensitive 
Agile toolbar for every type of CAD object. 

1. Select View > Toolbars > Toolbars  

The Toolbars window is opened.. 
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2. Click New. 

The New Toolbar window is opened.  

3. Type Agile and click OK. 

The Customize window is opened. 

 

The empty Agile toolbar is placed right beside it. 

4. From Categories select Agile. 

Icons assigned to Agile are displayed. 

5. Drag & drop the icons onto the empty Agile toolbar. 

6. Click Close. 

Note This can be repeated for any context. 
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Data Model in Agile e6 
The standard configuration of Agile e6 already contains the tables and fields that are required for 
the integration and corresponding allocations in the standard masks.  

Standard Tables and Fields 

In order to facilitate specific adaptations, the database fields that are required for the integration 
sequence are listed here. 

 

Table Field Type Description 

T_DOC_DAT CAX_TYPE S20 CAX Object type  

 CAX_SUBTYPE S20 CAX subtype  

 CAX_TIMESTAMP S20 Time stamp 

 CAX_CRE_SYSTEM S40 Creator system 

 CAX_FIL_PATH S255 File path 

 CAX_FIL_NAME S255 File name 

 CAX_FIL_OLD_PATH S255 Old file path 

 CAX_FIL_OLD_NAM
E 

S255 Old file name 

T_DOC_STR UG2_IDENT S40 Structure ident 

 CAX_COM S255 Component name 

 CAX_REF S255 Reference 

T_MASTER_STR UG2_IDENT S40 Structure ident 

T_MASTER_DOC CAX_CONFIG S20 Configuration 

The fields can be arranged as required within the masks. It is important that the virtual column width 
of the fields (B/vir) has a sufficient size.  

The fields must exist in the Agile e6 masks. With the exception of CAX_TYPE and 
CAX_CRE_SYSTEM, the fields can be arranged in that way that they are not visible to the user. 
The user does not need any write privileges to these fields.  

Standard Masks 

The following masks are used in the Agile e6 standard:  

 

 

Chapter 3 - 16 Oracle Agile Engineering Data Management 

 

 



   

 

Mask Field 

T_DOC_DAT.CAX_TYPE 

T_DOC_DAT.CAX_SUBTYPE 

T_DOC_DAT.CAX_CRE_SYSTEM 

T_DOC_DAT.CAX_FIL_PATH 

T_DOC_DAT.CAX_FIL_NAME 

T_DOC_DAT.CAX_TIMESTAMP 

T_DOC_DAT.CAX_FIL_OLD_PATH 

EDB-DOC-DRW-TFR and EDB-DOC-DRW-TLI 

T_DOC_DAT.CAX_FIL_OLD_NAME 

T_DOC_DAT.CAX_TYPE 

T_DOC_DAT.CAX_SUBTYPE 

T_DOC_DAT.CAX_CRE_SYSTEM 

T_DOC_DAT.CAX_FIL_PATH 

T_DOC_DAT.CAX_FIL_NAME 

T_DOC_DAT.CAX_TIMESTAMP 

T_DOC_DAT.CAX_FIL_OLD_PATH 

EDB-DOC-3DM-TFR and EDB-DOC-3DM-TLI 

T_DOC_DAT.CAX_FIL_OLD_NAME 

T_DOC_DAT.CAX_TYPE 

T_DOC_DAT.CAX_SUBTYPE 

T_DOC_DAT.CAX_CRE_SYSTEM 

T_DOC_DAT.CAX_FIL_PATH 

T_DOC_DAT.CAX_FIL_NAME 

EDB-DOC-CFR 

T_DOC_DAT.CAX_TIMESTAMP 

T_DOC_DAT.CAX_FIL_OLD_PATH 
EDB-DOC-CFR 

T_DOC_DAT.CAX_FIL_OLD_NAME 

T_DOC_STR.UG2_IDENT 

T_DOC_STR.CAX_COM EDB-DOC-STR-RLI and EDB-DOC-STR-ALI 

T_DOC_STR.CAX_REF 

EDB-ART-STR-RLI T_MASTER_STR.UG2_IDENT 
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EDB-ART-DOC-RLI and EDB-ART-DOC-ALI T_MASTER_DOC.CAX_CONFIG 

 

Note To increase the performance of the integration, an additional database index should be 
applied to the field T_DOC_DAT.CAX_FIL_NAME can be created with a unique name, 
e.g.CAX_FIL_IND. 

Selection to CAD 
The Agile e6 standard configuration already contains the necessary selections in the internal menu 
EDB-ECX-LOA-DOC.  

If, due to specific customizing, another mask must be customized, „Selection by CAD“ should be set 
up accordingly. 

This is used either for loading the selected object to the application or for cancelling the loading 
process and returning to the Solid Edge window.  
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Chapter 4  

Debugging  
The most profound view into the integration’s functioning enables tracing the ECI-calls which are 
sent from the local Agile client to the connected Agile server including the responds. A file is created 
on the Agile server machine which can be viewed by user using the client.  

It is possible to start and to stop the ECI-trace at any time during the session.  

The trace function is activated in Agile e6: 

1. Click Tools > Trace > Select Module  

2. Select the checkbox for  ECI-Module E 9. 

3. Click OK.  

4. To start the trace log any time during the session, click Tools > Trace > Trace New .  

The name of the new trace file is displayed in the message bar (e.g. Test output on 
D:\AgilePLM\tmp\tst173.trc). 

Note The file location is that on the Agile server machine! 

5. Execute the process you want to test/trace.  

6. To end tracing, click Tools > Trace > Trace Off. 

7. To display the contents of the trace file in a list, click Tools > Trace > Show trace. 

You can copy and paste the trace contents into an Excel file and save it locally. 

Note The information in the trace file can be extended by e.g. adding SQL statements.  
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Chapter 5  

Appendix 

Additional Sections of the Mapping File 
3DCADMapping.ini 
The mapping file 3DCADMapping.ini was extended. 

[JNIOPTIONS]  

            ; 

            ; 

For internal use only! 

All lines in this section must start with a semicolon  (made as 
comment). 

[ActiveChangeManagement]  

                        ; 

                        ;1 

                        ; 

For internal use only! 

[BatchJobSleepTime] 

                        ; 

                        1000 

                        ; 

For internal use only! 

[LoadPropertyUpdate]  

                        ; 

                        1 

                        ; 

For internal use only! 

[LoadSaveOption] 

; 

 Save = 0           0/1/2 

 Tif     = 0            0/1 

 Dxf    = 0           0/1 

Enables to predefine the default settings for load and save 
procedures. 

Save: 0 = Standard / 1 = Batch / 2 = Interactive 

Tif, Dxf, Bmp: 0 = Not activated / 1 = Activated 
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 Bmp  = 0           0/1 

 ; 

[PDFAddin] For internal use only! 

[ResetReservation] 

                        ; 

                        1 

                        ; 

Enables to predefine the default setting for the checkbox Unset 
Reservation in the information window Save Preview. 

0 = Nnot activated /1 = Activated 

[SavePreview-AutoPlmInfo] 

                        ; 

                        1 

                        ; 

Triggers the behavior when the information window Save 
Preview is filled. 

0 = The additional information from PLM is displayed after 
clicking PLM Info 

1 = The additional information from PLM is displayed 
immediately for each listed object. 

Note: Performance-loss happens especially for big assemblies. 

[SaveProgress] 

                        ; 

                        0 

                        ; 

Triggers the logging of the Save processes. 

1 = The file Log.txt is written in the check-out path every time when 
the save process runs. 

The following sections must be present in the mapping file 3DCADMapping.ini. This is checked at 
each start of the CaxOleServer.exe. The program exits with an error message if such a section 
cannot be found. 

 [CreateDocument3DModelQuick] 

 [CreateDocumentDrawingQuick] 

 [ChangeDocument3DModelQuick] 

 [ChangeDocumentDrawingQuick] 

 [CheckIn3DModelEPRT] 

 DRW] [CheckInDrawingE

 [ChangeItem] 

 [CreatePartViewFile] 

 [CreateAssemblyViewFile] 

 [CreateDrawingViewFile] 
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 [GetProperties3DModel] 

 [GetPropertiesDrawing] 

Title Box 

ation from the Agile 
t. 

allation, the following Agile e6 objects can be exchanged: 

nt history (for the drawing) 

em

The title box can be filled with metadata information from Agile e6. It requires a drawing template 
that contains the corresponding element details. The integration takes the inform
e6 database text content (reference text) and places it for the respective objec

For a standard inst

 Document 

 Docume

 It  

Note It is also possible to assign SolidEdge properties to Agile e6 fields. 

Information control for SolidEdge data transfer is performed using Tcl scripts (Tcl = Tool Command 

means in 

For example, if the drawing template name is CAX-OLE-A4h, copy all sections with ...Normal... to 
...C you have now 10 new sections in your mapping file, i.e.: 

[FillAttrDocHisCAX-OLE-A4h.dft] 

Language). The customization for this behavior is done in 3DCADMapping.ini which is located in 
your installation directory ..\CaxIntegration\Server\Scripts. 

The bi-directional transfer of values is linked to the name of the drawing template. This 
case of the usage of the standard template, you get "Normal" as name. If custom templates are 
used with special names, you need to add all appropriate sections to the mapping file. 

AX-OLE-A4h... As a result 

FillAttrDocCAX-OLE-A4h.dft] 
... 

...  

If a section is missing, you will get the following message: 

 

Note perties should be initialized by the system. Thus, the following  All user defined pro
properties need to be added to the section [FillAttrInitPropertiesNormal.dft]. 

 Property_1 = NULL 

 Property_2 = NULL 
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 Property_3 = NULL 

Error Handling 

Error Starting Agile e6 from SolidEdge 

If Agile e6 does not start from inside SolidEdge, the problem can be found in most of the cases in 
 more information regarding this file, please 

he message window (see screenshot), the PATH 
e e6 start batch file: 

the file …\Server\Scripts and start the file dtv.bat. For
refer to the Agile e6 documentation. 

Error Message when Starting Agile e6 

If Agile e6 starts with an error message in t
variable needs to be expanded in the Agil

 

8. Go to …\Server\Scripts and open the file dtv.bat. 

9. 

_ROOT=C:\Agile_e6\ext\bin\intel-ms-nt5.0 

Note This is only an example! The correct drive and directory of your system has to be entered 

Extend the first line  

set AXA

by 

set AXA_ROOT=C:\Agile_e6\ext\bin\intel-ms-nt5.0;C:\Agile_e6\axalant\bin\intel-ms-nt5.0 

 
in here. 

Additional Error Handling 
1. 

pened. 

Select the CAX/OLE icon with the right mouse button.  

The context menu is o

 

2. Click 

An Information window is opened. 

Debugging. 
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3. To monitor a log file for error tracking purposes click OK.  

Note This action can also be deactivated. 

Error Message 

When the message ‘Error Creating CaxOleSrv.Application Object” appears, ensure that the paths 
specified in your system environment are set correctly. If necessary, restart the computer. Then 
manually start the CAX/OLE server from …\Server and stop this with the menu function Exit of the 
CAX-OLE server context menu. 
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