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C H A P T E R 1

Using Historical Data

Historical Data is a low overhead way to keep track of and see trends for attributes.

This help is divided into the following topics:

How Does Historical Data Work?

Getting Familiar with the Historical Data Window

Creating and Viewing Historical Data

About Persistence File Preferences

Creating Historical Data Files

Viewing Historical Data from Your JRockit JVM Connection

Displaying Data for a Specific Date and Time Range in the Historical Data Graph

Sharing Historical Data

Customizing the Historical Data Graph

Zooming-in to a Graph

Changing the Y-Axis on a Graph

Enable/Disable Attributes on the Graph
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How Does Historical Data Work?
Historical Data is a low overhead way to keep track of attributes and to see trends for attributes. 
These attributes that you choose to view are not constricted to attributes for the Oracle JRockit 
JVM, which means that you can select attributes from your own applications, or any other 
application that has MBeans registered on the MBean Server.

You select the attributes you want to log to Historical Data on a graph in the Management 
Console by right-clicking the graph and slecting Log to Historical Data from the context menu 
resulting from the right-click action. The attributes you choose to log can be viewed in the 
Historical Data window. You can also share the historical data files with others.

Note: Attribute data is persisted as long as you are connected to a JRockit JVM and have the  
Management Console up and running.

Getting Familiar with the Historical Data Window
The Historical Data window recreates all the graphs for which logging was last enabled in the 
Management Console, including the titles, attribute colors, and attribute value multipliers of the 
attributes in the graphs.
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Figure 1-1 The Historical Data Window

The Historical Data window is divided into the following sections:

1. Graph over attributes that have been recorded.

2. Date selector and time selector—helps you select a specific date and time that you wan to 
view in the historical data file. When you have set the date and time, click the Show button.

3. Set current time button—sets the time to the current time. To view data for the current time, 
click Show.

4. Show data range button—shows the complete data range for the log files.

5. Attribute section—shows which attributes that have been chosen to be monitored. You can 
turn them off/on by clicking the Edit button.
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C H A P T E R 2

Creating and Viewing Historical Data

There are several steps involved to create historical data. This section describes those steps:

About Persistence File Preferences

Creating Historical Data Files

About Naming Conventions for the Persistence Files

Viewing Historical Data from Your JRockit JVM Connection

Displaying Data for a Specific Date and Time Range in the Historical Data Graph

Sharing Historical Data

About Persistence File Preferences
The persistence file is the file where the attributes that you wish to monitor are saved. This file is 
automatically saved in .missioncontrol\persist directory on your computer. You can, of 
course, change the directory for where you save the files (see To change the Persistence 
Directory). 

When you log an attribute to historical data, an additional persistence file is added for that 
connection in the same catalog. As soon as you open one of the persistence files from the same 
directory, Oracle JRockit Mission Control will plot a collective view of all files from that 
directory (see Figure 2-1).
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Figure 2-1 Difference Between One and Many Persistence Files open in JRockit Mission Control

When you enable log rotation, you can set a size on the persisted log. By doing so, you let the 
Management Console create a new log file as soon as the specified limit is reached (see To change 
log rotation).

If you combine log rotation with a setting for the maximum log size (see To set maximum log 
size limit), you will enable full log rotation, i.e. the Management Console will delete the oldest 
log file as soon as the maximum log size limit is reached, and you will always know how much 
space the log files take on your computer. Figure 2-2 shows how the settings can look when full 
log rotation is enabled.

Figure 2-2 Persistence Dialog set with full Log Rotation
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To change the Persistence Directory

1. Click Window > Preferences > JRockit Mission Control > Management Console > 
Persistence.

2. Type in a different directory under Persistence directory, or click Browse to select a 
directory.

3. Click Apply if you want to change other settings or OK to exit the Preferences window.

To change log rotation

1. Click Window > Preferences > JRockit Mission Control > Management Console > 
Persistence.

2. Select Enable log rotation.

3. Enter a value in bytes for when the log should be cleared.

4. Click Apply if you want to change other settings or OK to exit the Preferences window.

To set maximum log size limit

1. Click Window > Preferences > JRockit Mission Control > Management Console > 
Persistence.

2. Select Limit maximum log size.

3. Enter a value in bytes for the maximum log size.

4. Click Apply if you want to change other settings or OK to exit the Preferences window.

Creating Historical Data Files
When you have set up your persistence directory, it is time to create your persistence data log 
files.

To log to Historical Data

1. Open the Management Console for the desired connection.

2. Open the tab that contains the data you want to log (this must be graph data; you cannot log 
data on tabkes or lists).

3. Place your pointer anywhere on the graph and right-click the mouse to open the context menu. 
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4. Select Log to Historical Data.

A new Historical Data file is now created in the persist directory (see Figure 2-3). The file 
will contain all attributes and the chart’s metadata.

Figure 2-3 A Newly Saved Persistence Directory

You can now drag and drop the newly created log file to the JRockit Mission Control window to 
view the result in Historical Data.

Viewing Historical Data from Your JRockit JVM 
Connection

You can view historical data at the same time you are monitoring you connection in the JRockit 
Management Console. As soon as you add another attribute to be persisted, you will get an 
additional log file in your persist directory and the Historical Data can be updated to reflect the 
change.

To view historical data for an active Oracle JRockit JVM connection

1. Select the active Oracle JRockit JVM connection in the JVM Browser.

2. Right click on the connection and select Historical Data.

The Historical Data window opens in the JRockit Mission Control Client window.
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Displaying Data for a Specific Date and Time Range in the 
Historical Data Graph

Sometimes a log file can contain data that has been recorded over a long period of time, but you 
are only interested in viewing data up until a specific date and/or time. Then it is useful to change 
the date and time range that is displayed in the data graph. The data that is displayed spans from 
the beginning of the recording to the date and time you specify.

To change the date range in the Historical Data graph

1. Under Select last time to display, set the date and time.

2. Click Show.

The Historical Data graph now changes to display the data collected up till the date and 
time that you have specified.

To set the date range to show all historical data

Click the Show data range button.

Sharing Historical Data
You can easily share the log files with others. This can be useful when you do not have a 
connection in your JVM Browser for a specific JRockit JVM instance. If you have several log 
files from the same run, you need to make sure that they are together in the same folder when they 
are opened; otherwise, important data will be lost in the viewing process. 

To view data from JRockit JVMs for which you do not have connections

1. Make sure you have the log files in a directory.

If you have many log files within the same catalog and with the same name (different 
index), you will get a compiled view of all log files from that folder.

2. Click File > Open > Open Historical Data.

The log file appears in the JRockit Mission Control window.



Creat ing  and  V iewing  H is to r i ca l  Data

2-10 Viewing Historical Data

About Naming Conventions for the Persistence Files
As soon as you have selected attributes to be logged to Historical Data, JRockit Mission Control 
creates two files:

A log file for that attribute (see Figure 2-4) in your default Persist catalog (or the directory 
of your choice, see To change the Persistence Directory).

Figure 2-4 Persistence Files Saved

A metadata file that contains the layout of the graph from which the data was logged.

The log file for the attribute uses the following naming convention:
internal identification number_connectionname_index.log_gz

For example:
142_localhost_3.log_gz

The example file reads like this:

The 142 identification number (the number that JRockit Mission Control uses to identify all log 
files belonging to the same connection) for the localhost connection and the third (3) log file 
for that connection.

The metadata file uses this naming convention:

internal identification number_metadata.xml

For example:
142_metadata.xml

If the metadata file is not included in the directory of the log_gz files, the JRockit Mission 
Control Client will just show all the attributes in one graph as it previously did before it 
saved the graph layout. 
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Customizing the Historical Data Graph

When you open your Historical Data window the information about the attributes are displayed 
on the Historical Data graph. This section describes how to use the graph so that you can view 
the attributes data in the manner you chose.

This section is divided into the following topics:

Zooming-in to a Graph

Changing the Y-Axis on a Graph

Enable/Disable Attributes on the Graph

Zooming-in to a Graph
You can zoom-in on either a selected portion of the graph or to different time granularities, as 
described in Table 3-1.

Table 3-1  Graph Zoom Levels

This zoom level Shows this information

Selection A specific, user-defined range on the graph.

Seconds Second-by-second.

Minutes Minute-by-minute.

Hours Hour-by-hour.



Customiz ing  the  H is to r i ca l  Data  Graph

3-12 Viewing Historical Data

This section explains the following:

To zoom-in on a selected range on the graph

To zoom-in to a specific time increment

To zoom-in on a selected range on the graph

1. Place the pointer at the far left edge of your selected data range and, holding down the left 
mouse button, drag to the far right edge of the range, as shown in Figure 3-1.

Figure 3-1 Graph with Range Selected

2. Place the pointer over the selection and right-click the mouse.

A context menu for the graph appears (Figure 3-2).

Zoom In Zooms in on the graph.

Zoom Out Zooms out on the graph.

Table 3-1  Graph Zoom Levels

This zoom level Shows this information
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Figure 3-2 Graph Context Menu

3. Select Zoom.

A submenu for Zoom appears (Figure 3-3).

Figure 3-3 Graph Context Menu with Zoom Level Submenu Open

4. Select Selection.

The graph refreshes and now shows a detailed view of the selected data range.

To zoom-in to a specific time increment

1. Place the pointer anywhere on the graph and right-click the mouse.

The graph’s context menu appears (Figure 3-4).
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Figure 3-4 Graph Context Menu

2. Select Zoom.

The zoom level context menu appears (Figure 3-5).

Figure 3-5 Zoom Level Context Menu

3. Select the time increment at which you want to monitor data.

The graph refreshes to show the data within the selected time increment.

Changing the Y-Axis on a Graph
The graph data that is by default expressed in percentages running from 0 to 100%. Use the 
following procedure to change the Y-axis range.

To change the Y-axis range

1. Place the pointer anywhere on the graph and right-click the mouse.

The graph’s context menu appears (Figure 3-6).
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Figure 3-6 Graph Context Menu

2. Select Y-axis range.

The Y-axis range context menu appears (Figure 3-7).

Figure 3-7 Y-axis Range Context Menu

3. Select the range type you want to use.

– Auto sets the range to that which will include all attributes selected for the graph.

– Percent sets the range at 0 to 100%.

– Custom sets any range.

If you select Custom, the Enter y-axis range dialog box appears (Figure 3-8).

Figure 3-8 Enter y-axis range Dialog Box
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4. Enter the range you want to show on the Y-axis and click OK.

The Y-axis reformats to show the new range; for example, if you set the range from 25% to 
75%, the graph would reformat like the example in Figure 3-9.

Figure 3-9 Reformatted Y-Axis with Custom Range Set

Enable/Disable Attributes on the Graph
The attributes on the Historical Data graph can be disabled (hidden). This is a good feature if you, 
for example, only want to view attributes that are expressed in percentages.

To enable or disable attributes

1. Click the Edit button.

The Enable attributes window appears (Figure 3-10).

Figure 3-10 Enable Attributes Window

2. Select (or deselect) the attributes you want to hide.
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3. Click OK.

The attribute is now hidden in the Historical Data graph.
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