Contents

1. Introduction
   Introduction ........................................................................................................... 1-1

2. Setting Up Your Portal Development Environment
   Before You Begin .................................................................................................. 2-1
   Tutorial Steps ........................................................................................................ 2-1
   Create a Portal Domain ......................................................................................... 2-2
   Create a Portal EAR Project .................................................................................. 2-8
   Associate the EAR Project with the Server .......................................................... 2-10
   Create a Portal Web Project .................................................................................. 2-11
   Create a Datasync Project .................................................................................... 2-14
   Summary .................................................................................................................. 2-16

3. Creating a Portal in Your Development Environment
   Before You Begin .................................................................................................. 3-1
   Tutorial Steps ........................................................................................................ 3-1
   Create a Portal ....................................................................................................... 3-2
   Add a Page to Your Portal ..................................................................................... 3-4
   Deploy and View Your New Portal ........................................................................ 3-6
   Create Portlets ....................................................................................................... 3-8
   Add Portlets to the Portal and View the Result .................................................... 3-14
   Summary .................................................................................................................. 3-16
4. Assembling a Desktop in Your Staging Environment

Before You Begin ......................................................... 4-1
Introduction to the Administration Console .............................. 4-1
Tutorial Steps ................................................................. 4-2
  Open the Administration Console ..................................... 4-3
  Log in to the Administration Console ................................. 4-4
  Create a Portal and Desktop ........................................... 4-5
  Update the Desktop Page Contents to Rearrange Portlets ........ 4-9
  Create a New Page on the Desktop ................................. 4-12
Summary ................................................................. 4-15
CHAPTER 1

Introduction

The tutorials presented in this document introduce you to some of the common tasks you perform in developing the pieces of a portal project and organizing those parts into a version that end users see. The tools you use to perform these tasks include Workshop for WebLogic and Oracle WebLogic Portal, including the WebLogic Portal Administration Console.

This document describes the following tasks, organized by chapter:

- Chapter 3, “Creating a Portal in Your Development Environment”
- Chapter 4, “Assembling a Desktop in Your Staging Environment”
Setting Up Your Portal Development Environment

This tutorial helps you prepare your Workshop for WebLogic environment for portal development.

For more detailed information about each dialog of the wizards used in this chapter, refer to the Portal Development Guide.

Before You Begin

Before starting this tutorial, do the following:

- Install Workshop for WebLogic and WebLogic Portal.
- Complete the tutorial “Getting Started with Workshop for WebLogic” located in the Oracle Workshop for WebLogic User’s Guide.

This task is optional, but if you are unfamiliar with the Eclipse development environment on which Workshop for WebLogic is based, the Getting Started tutorial is highly recommended; the tutorial shows you how to start Workshop for WebLogic and navigate the workbench user interface, introduces terminology associated with the workbench, and shows you how to create a simple web application.

Tutorial Steps

Using the tutorial, you will perform tasks that are required to get your Workshop for WebLogic environment ready for portal development.

The tutorial includes instructions on how to perform these tasks:
Setting Up Your Portal Development Environment

- Create a Portal Domain
- Create a Portal EAR Project
- Associate the EAR Project with the Server
- Create a Portal Web Project
- Create a Datasync Project

In your actual development environment you do not need to follow the order of the steps as presented in this tutorial; for example, you can create the portal domain after performing all the other steps. However, we recommend that you follow the steps as presented here so that you can easily see the relationships among the parts of a portal project.

Create a Portal Domain

The portal domain is a group of WebLogic Server resources that contain the application server used by the portal. You must have a server domain that is WebLogic Portal-enabled in order to test the portal that you create. This customized domain is generally called a portal domain.

To create a portal domain, perform these steps:

1. Start Workshop for WebLogic.
2. When asked to select a workspace, click Browse and select (or create) a workspace folder. Follow the dialog prompts as appropriate. For this tutorial, we recommend that you create a new workspace.
   
   If necessary, dismiss the Welcome screen to display the workbench.
3. If the Portal perspective is not already open, select it by choosing Window > Open Perspective > Other > Portal.
   
   The instructions and figures in this tutorial are based on the views that are available in the Portal perspective.
4. Choose File > New > Other.
   
   The New – Select a Wizard dialog displays, as shown in Figure 2-1.
5. Expand **Server** in the tree, click **Server** in the expanded tree, and then click **Next**.

The New Server – Define a New Server dialog displays, as shown in **Figure 2-2**.
6. In the tree, verify that **Oracle** is expanded and that **Oracle WebLogic Server v10.3** is selected. The host name **localhost** is shown in the **Host name** field. For the tutorial, leave this entry unchanged.

7. Click **Next**.

   The New Server – Oracle WebLogic Server v10.3 dialog displays, as shown in Figure 2-3.
8. Click the link that is labeled **Click here to launch Configuration Wizard to create a new domain**.

The Oracle WebLogic Configuration Wizard starts, as shown in **Figure 2-4**.
9. Follow the wizard prompts and enter the values shown in Table 2-1. Click Next as appropriate to continue through the wizard.

**Table 2-1 Configuration Wizard Values**

<table>
<thead>
<tr>
<th>In this Wizard Page...</th>
<th>Select or Enter...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Welcome</td>
<td>Create a new WebLogic domain (the default)</td>
</tr>
<tr>
<td>Select Domain Source</td>
<td>In the Generate a domain configured automatically to support the following Oracle products list, select WebLogic Portal and Workshop for WebLogic 10.3. Notice that a WebLogic Portal Collaboration Repository check box is available on this wizard dialog; portal projects that use GroupSpace or Collaboration Portlets features must have a domain that includes this repository. This tutorial does not use these features, so it can remain unselected.</td>
</tr>
</tbody>
</table>
10. When you are finished with these entries, click **Create** in the Create WebLogic Domain dialog.

   The **Creating Domain** status page appears, indicating the progress of the domain creation.

11. When the domain is created, click **Done**.

   The display returns to the New Server – Oracle WebLogic Server v10.3 dialog.

12. Click **Browse** and navigate to the directory of the domain that you just created. By default, the path is `<BEA_HOME>/user_projects/domains/myPortalDomain`.

13. In the Browse for Folder dialog, select the domain directory and click **OK** to return to the Define a New Server – Oracle WebLogic Server v10.3 dialog.

14. Click **Finish**.

   The new server displays in the Servers view in the Workshop for WebLogic workbench, and a Servers node is added to the tree in the Package Explorer view. Figure 2-5 shows the Servers view and the new server.

   For now, you do not need to start the server. Later in this tutorial, you will create a simple portal application, start the server, and run the portal application on the server.
Create a Portal EAR Project

An EAR project collects the component projects of the application for deployment; you create one EAR project per enterprise application. The EAR project contains JAR files, deployment descriptors, build files, and auto-generated files. For more information about EAR projects and their relationship to the other projects in the workbench, refer to the “Applications and Projects” topic in the Workshop for WebLogic Help.

In this task, you will create an Enterprise Application (EAR) project that is customized to contain WebLogic Portal information. For more information about the Portal EAR Project, refer to the Portal Overview.

To create a Portal EAR project, perform these steps:

1. Be sure you have set up the example environment and domain, as explained previously in “Create a Portal Domain” on page 2-2.

2. From the File menu, select New > Portal EAR Project.

3. In the New Portal EAR Project dialog, enter myPortalEAR in the Project Name field, leave the other entry fields unchanged, and click Next.

   The New Portal EAR Project – Project Facets dialog displays.

4. In the New Portal EAR Project – Project Facets dialog, verify that WebLogic Portal and all features that fall under the WebLogic Portal node are selected, as shown in Figure 2-6.
Figure 2-6  New Portal EAR Project – Select Project Facets Dialog

The selections **WebLogic Portal (Optional)** and **WebLogic Portal Collaboration** are also available here. These selections are not needed for the tutorial; leave them unselected. For more information about what happens when you select these options, refer to the Portal Development Guide.

5. Click **Finish**.

The Portal EAR Project node is added to the Package Explorer view, as shown in Figure 2-7. If you expand the folder you can see the EAR content folder and the required APP-INF and META-INF directories for the project.

Figure 2-7 Package Explorer View including Portal EAR Project
Note: The error icon on the EAR folder appears because the Portal EAR Project references library modules that have not yet been added to the project. Later in this tutorial when you create a Portal Web Project, the library modules will be added and the error icon will disappear when Workshop for WebLogic automatically rebuilds the workspace.

**Associate the EAR Project with the Server**

You need to explicitly associate the EAR project with the server that you created previously, so that later you can test the project on that server.

To associate the Portal EAR Project with the server, perform these steps:

1. In the Servers view (as shown in Figure 2-5), right-click **Oracle WebLogic Server v10.3**, then select **Add and Remove Projects**.

   The Add and Remove Projects dialog displays, as shown in Figure 2-8.

**Figure 2-8 Add and Remove Projects Dialog**

2. Click to select **myPortalEAR** in the **Available projects** column and then click **Add**.
   The project is added to the **Configured projects** column on the right.
3. Click Finish.

The Portal EAR Project is now associated with the server. To verify this, in the Servers view you can expand the server node to view the server’s associated projects. The myPortalEAR project should be shown as a subordinate node.

Create a Portal Web Project

In this task you create the web project that will contain the actual portal.

To create the portal web project, perform these steps:

1. Select File > New > Portal Web Project. The New Portal Web Project dialog displays, as shown in Figure 2-9.

Figure 2-9  New Portal Web Project Dialog

2. In the New Portal Web Project dialog, enter myPortalWebProject in the Project name field.

In the Project contents area of the dialog, leave the default setting unchanged.
3. Select the **Add project to an EAR** check box.

   Because *myPortalEAR* is the only EAR project, it appears in the dropdown menu by default.

   This associates the Portal EAR project that you created previously with this Portal Web Project.

4. Click **Next**.

   The New Portal Web Project – Project Facets dialog displays.

5. In the New Portal Web Project – Select Project Facets dialog, verify that the **WebLogic Portal** node is selected. Also, be sure that all of the features under the WebLogic Portal node are selected, as shown in Figure 2-10.

   **Figure 2-10 New Portal Web Project – Select Project Facets Dialog**

6. Click **Finish**.

   The *myPortalWebProject* folder now appears in the Package Explorer view, as shown in Figure 2-11. If you expand the folder you can see the default library modules and required
directory structure for the project. For more information about the use of Library Modules in WebLogic Portal, refer to the Portal Development Guide.

Figure 2-11 Portal Web Project Added to the Package Explorer
Create a Datasync Project

A datasync project is an optional project that stores general purpose portal services data that is used in the development of personalized applications and portals. These portal services include User Profiles, Session Properties, Campaigns and others. You can share a single datasync project among several EAR projects if you wish.

**Tip:** For more detailed information on the Create New Datasync Project wizard, see Portal Dataysnc Project Wizard in the Portal Development Guide.

To create the datasync project, perform these steps:

1. Select **File > New > Datasync Project**. The Create New Datasync Project – New Datasync Project dialog displays, as shown in Figure 2-12.

**Figure 2-12 Create New Datasync Project Dialog**
2. In the Create New Datasync Project – New Datasync Project dialog, enter myData in the Project name field.
   In the other areas of this dialog, leave the default settings unchanged.

3. Click Next.
   The Create New Datasync Project – EAR Projects dialog displays, as shown in Figure 2-13.

   Figure 2-13 Create New Datasync Project – EAR Projects Dialog

4. Be sure the myPortalEAR check box is selected.
   This associates the Datasync project with the Portal EAR project that you created previously.

   **Tip:** If you create a datasync project without associating it with an EAR, you can do this step later by right-clicking the datasync project in the Package Explorer tree and selecting Properties; then expand the Datasync node in the tree and select EAR Projects to associate the project with the EAR.
5. Click **Finish**.

The myData folder now appears in the Package Explorer window, as shown in Figure 2-14. If you expand the folder you can see the src folder and the data directory structure for the project.

**Figure 2-14 Datasync Project Added to the Package Explorer**

---

**Summary**

With the completion of this tutorial, you have created the basic required elements of a portal development environment. These components are created on your file system in your current workspace.

To learn about some basic portal development tasks using the Workshop for WebLogic workbench, continue to Chapter 3, “Creating a Portal in Your Development Environment.”
Creating a Portal in Your Development Environment

This tutorial helps you learn how to create a portal and portlets using WebLogic Portal in the Workshop for WebLogic workbench. For more detailed information about each dialog of the wizards used in this chapter, refer to the Portal Development Guide.

Before You Begin

The tasks described in this chapter are based on those described in Chapter 2, “Setting Up Your Portal Development Environment”, so it is important that you complete that tutorial before starting the tasks described here.

Tutorial Steps

Using the tutorial, you will create a portal and two portlets, create an additional page for the portal, and then place the portlets onto a page of the portal.

The tutorial includes instructions on how to perform these tasks:

- Create a Portal
- Add a Page to Your Portal
- Deploy and View Your New Portal
- Create Portlets
- Add Portlets to the Portal and View the Result
Create a Portal

In this task you will create a portal for the project that you created in “Create a Portal Web Project” on page 2-11.

To create a portal, perform these steps:

1. If the Portal perspective is not already open, select it by choosing Window > Open Perspective > Portal.

   Using the Portal perspective is optional, but the instructions and figures in this tutorial are based on the views that are available in the Portal perspective.

2. Navigate to the myPortalWebProject/WebContent directory, right-click and then select New > Portal.

   The New Portal dialog displays, as shown in Figure 3-1.

   Because you started this wizard by right-clicking the web content directory, the parent folder field automatically displays that directory name.

**Figure 3-1 New Portal Dialog**
As a best practice, you should locate your portal file in a web content directory that is subordinate to the web project directory. The default web content directory name is WebContent, and is assigned when you use the Portal Web Project Wizard. You can change the name of your web content directory if you wish; for more information, refer to the Portal Development Guide.

3. In the **File name** field, enter myPortal.

   A file type of .portal is required for portals; you can type the .portal extension to the portal’s name if you wish, but WebLogic Portal automatically adds the extension if you don’t enter it.

4. Click **Finish**.

   The wizard adds myPortal.portal to the WebContent folder in the Portal web project and a view of the portal displays in the workbench, as shown in Figure 3-2.

**Figure 3-2  Portal Displayed in Workbench**

The created portal includes a **desktop**, **header**, **footer**, **book**, and **page**. A desktop is a user-specific view of the portal content. A portal can support many desktops. A single portal might support an employee-specific desktop, a customer-specific desktop, and others, where each
desktop exposes different kinds of content to different sets of users. Any part of a portal can be included or excluded from a desktop, including a book, a page, a specific application, or an individual link.

Desktops can also define the look and feel attributes of a Portal. Desktops can be associated with a particular skin that defines the color scheme, fonts, and images used. Desktops also contain a header and footer—you can place images, text, or any web content in these areas to give consistency to the look and feel of a desktop.

You use books to organize your content and navigation in a hierarchical manner. Books can contain other books or pages. In a browser, a book is rendered as a set of tabs or links. Each portal contains a main book called, by default, “Main Page Book.” A page consists of a set of columns and/or windows that organize the actual content of your portal. You navigate to a page by clicking on an individual tab or a link.

**Add a Page to Your Portal**

In this task you will add a second page to the portal’s main book. When the portal is rendered in a browser, the two pages will appear as two clickable tabs. You add a new page by dragging and dropping the new page into the main work area. You will also set properties on the new page using the Properties view.

To add a new portal page, perform these steps:

1. From the **Design Palette** view, drag and drop the Page icon to the area directly to the right of the Page 1 tab. **Figure 3-3** shows the result when you release the mouse button.

   **Tip:** If you do not see the **Design Palette** tab, select **Window > Show View > Design Palette**.
The new page has a default title of “New Page.” To change it, perform these steps:

1. Click the new page tab to select it.

2. In the Properties view, enter “Page 2” as the new title, as shown in Figure 3-4.

   When you enter the new value, the editor shows that the title has changed from New Page to Page 2.
3. Save your changes.

**Deploy and View Your New Portal**

This portal isn’t very interesting yet, but as a quick test, you will deploy your new portal to the server and view it in a browser window that is contained within Workshop for WebLogic.

Follow these steps:

1. Right-click myPortal.portal in the Package Explorer view and select Run As > Run on Server, as shown in Figure 3-5.

**Figure 3-5 Selecting to Run the Portal on the Server**
The Run On Server - Define a New Server dialog displays. Make sure the server that you created during the previous WebLogic Portal tutorial task is highlighted.

**Tip:** When you select Run On Server, the portal web application is automatically published. Publishing involves copying project files, such as resource and configuration files, to the correct location for the server to locate and use them. Workshop for WebLogic detects whenever a file changes that requires republishing. When this happens, the state of the server changes to **Republish**. (You can see this reflected in the Servers view.) To republish the application, you can right-click the server in the Servers view and select **Publish**, select the Publish icon, or select the portal in the Project view and pick **Run As > Run On Server**.

2. Click **Finish** to begin the deployment process.

   Wait while Workshop for WebLogic starts the server, deploys files to the server, and runs the application. While deployment is in process, you can view status messages in the status bar at the bottom of the window.

   The results appear in a new tab in the editor view, as shown in Figure 3-6.

   **Figure 3-6  Portal Display in the Workbench Editor View**

   ![Image of Portal Display in the Workbench Editor View](image)

   Leave this new tab open; after you add portlets you will refresh this display to view them.

**Tip:** You can choose to always use an external web browser to view your portal if you wish. To do so, select **Window > Preferences** and select **General > Web Browser** in the property tree; then select the **Use external Web browser** radio button and pick a browser type from the list. If no browsers appear in the list you can search for available browsers and add them to the list.
Create Portlets

In this task you will create two portlets: a Browser URL portlet and a simple JSP portlet.

Create a Folder to Contain the Portlets

To organize your portlets, it's a good idea to store them in a subfolder in your web content directory.

To create a portlet folder, follow these steps:

1. Right-click the WebContent directory and select New > Folder.

   The New Folder dialog displays, as shown in Figure 3-7.

   **Figure 3-7 New Folder Dialog - Create Folder for Portlets**

   ![New Folder Dialog](image)

   2. Type the folder name `portlets` and click Finish.
Create a Browser URL Portlet

Browser portlets, also called Content URL portlets, are basically HTML portlets that use URLs to retrieve their content. Unlike other portlet types that are limited to displaying data contained within the portal project, browser portlets can display URL content that is outside the portal project.

To create the browser portlet, perform these steps:

1. Right-click the portlets folder and select New > Portlet.

   The New Portlet dialog displays, as shown in Figure 3-8. The folder for the portlet displays automatically in the parent folder field.

   ![Figure 3-8 New Portlet Dialog](image)

   The Finish button is initially disabled; the button enables when you select a valid parent folder and type a portlet name. If you select an invalid portal project in the folder tree on this dialog, an error message appears in the status area near the top of the dialog explaining that the project is not a valid portal project.

2. Type myBrowserPortlet as the file name for the new portlet.
3. Click **Next**.
   The Portlet Wizard displays the Select Portlet Type dialog.

4. Click **Browser (URL) Portlet** and then click **Next**.
   The Portlet Wizard displays the Portlet Details dialog; **Figure 3-9** shows an example.

**Figure 3-9** Creating a Browser URL Portlet - Portlet Details Dialog

5. Specify the values for this portlet, using **Table 3-1** as a guide.
6. Click **Create**.

The Workshop for WebLogic window updates, adding the `myBrowserPortlet.portlet` file to the portlets folder and displaying the new portlet in the editor, as shown in Figure 3-10.

**Figure 3-10 New Browser Portlet Displayed in Editor**
Create a JSP Portlet

JSP portlets reference JSP files. In most cases you can reuse existing JSP files to build portlets from them. JSP portlets are recommended when the portlet is simple and does not require the implementation of complex business logic.

In this task, you will create a simple JSP file and then use that file to generate a portlet.

Follow these steps:

1. Double click the file `index.jsp` in the Package Explorer view.
   
   The `index.jsp` file is located in the `WebContent` directory, and is included with any Portal Web Project that you create.
   
   The source code for the file displays in an editor view. Select the Source tab just below the source code window to display just the source code.

2. Change the default body text to **Simple JSP Portlet** as shown in Figure 3-11.

   Figure 3-11  JSP File Showing Edited Body Text

3. Select **File > Save As** and save this JSP file as `jsp_portlet.jsp`.

4. Drag the `jsp_portlet.jsp` file into the portlets folder.

5. Right-click `jsp_portlet.jsp` and select **Generate Portlet** from the menu.
   
   Because you are generating a portlet from an existing .jsp file, the Portlet Wizard goes directly to the Portlet Details dialog; Figure 3-12 shows an example.
6. Specify the values specified in Table 3-2.

Table 3-2 Portlet Wizard - JSP Portlet Data Entry Fields

<table>
<thead>
<tr>
<th>Field</th>
<th>Value/Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Simple JSP Portlet</td>
</tr>
<tr>
<td>Content Path</td>
<td>/portlets/jsp_portlet.jsp</td>
</tr>
<tr>
<td></td>
<td>Because you are creating this portlet based on an existing JSP file, WebLogic Portal automatically fills in this value.</td>
</tr>
<tr>
<td>Has Titlebar</td>
<td>Leave this box checked.</td>
</tr>
<tr>
<td>State</td>
<td>Select the check boxes Minimizable and Maximizable.</td>
</tr>
</tbody>
</table>

7. Click Create.

The Workshop for WebLogic window updates, adding the jsp_portlet.portlet file to the portlets folder.

Checkpoint: Your WebContent directory should look like the example shown in Figure 3-13.
Add Portlets to the Portal and View the Result

In this task you will add your new portlets to the portal and view your changes.

Follow these steps:

1. In the editor, click the myPortal.portal tab to display it.
2. Click the Page 1 tab in the portal to select it.
3. Drag the JSP portlet (with the file name jsp_portlet.portlet) onto the left column (placeholder) of the portal page.
4. Drag the Browser portlet (with the file name myBrowserPortlet.portlet) onto the right placeholder of the portal page.

Your result should look like the example in Figure 3-14.
5. Save your change.

To view the new portlets in a browser, follow these steps:

1. Click to select the **New Portal Desktop** tab in the editor view.

2. On the toolbar, click **Refresh**.

   Because your change does not require redeploying the change to the server, you do not need to select the **Run on Server** option to see the new portlets.

   Your updated portal should look like the example shown in **Figure 3-15**.
Summary

With the completion of this tutorial, you have created a portal, added a portal page, and created two new portlets that can be displayed in the portal. These components are created on your file system in your current workspace.

To learn about creating desktops using the WebLogic Portal Administration console, continue to Chapter 4, “Assembling a Desktop in Your Staging Environment.”
Assembling a Desktop in Your Staging Environment

This tutorial helps you learn how to use the WebLogic Portal Administration Console for some basic portal configuration tasks.

For more detailed information about each dialog of the wizards used in this chapter, refer to the Portal Development Guide.

Before You Begin

The tasks described in this chapter are based on those described in Chapter 2, “Setting Up Your Portal Development Environment” and Chapter 3, “Creating a Portal in Your Development Environment,” so it is important that you complete those tutorials before starting the tasks described here.

Introduction to the Administration Console

The WebLogic Portal Administration Console is the tool that portal administrators use to not only control the behavior, content, and appearance of portals, but to perform many traditional system administration activities such as user management and security management as well. This tutorial focuses on basic tasks that assemble portals into desktops.

The WebLogic Portal Administration Console is organized according to the following categories of tasks:

- **Portal Management** – Portals, desktops, books, pages, portlets, and other portal resources.
This tutorial describes some of the basic Portal Management tasks. The Portal Development Guide and Portlet Development Guide provide details about Portal Management tasks.

- **User, Groups, & Roles** – User and group management, security provider configuration, Delegated Administration, and Visitor Entitlements.
  The User Management Guide and Security Guide provides detailed information about the tasks in this category.

- **Content Management** – Content and repositories.
  The Content Management Guide provides detailed information about the tasks in this category.

- **Interaction Management** – Campaigns, Placeholders, User Segments, And Content Selectors.
  The Interaction Management Guide provides detailed information about the tasks in this category.

- **Configuration & Monitoring** – Server settings for Cache Management, Server Maintenance Mode, Personalization, Security, Unified User Profiles, and WSRP.

**Tutorial Steps**

Using the tutorial, you will create a portal desktop based on the portal and portlets created previously, make some modifications to your desktop, and then view your results.

The tutorial includes instructions on how to perform these tasks:

- Open the Administration Console
- Log in to the Administration Console
- Create a Portal and Desktop
- Update the Desktop Page Contents to Rearrange Portlets
- Create a New Page on the Desktop
Open the Administration Console

Before you can begin using the WebLogic Portal Administration Console, the server must be running. Depending on the state of your Workshop for WebLogic workbench, you might need to start the server before opening the Administration Console.

If you are continuing from Chapter 3, “Creating a Portal in Your Development Environment,” and you have not closed/opened Workshop for WebLogic, you can skip to Step 4.

If you closed Workshop for WebLogic after finishing the tutorial in Chapter 3, “Creating a Portal in Your Development Environment,” follow these steps:

1. Start Workshop for WebLogic and return to the workspace that you used for the previous tutorials:

2. In the Servers view, click the server to select it.

3. Click Start in the Servers view toolbar.

   Wait while Workshop for WebLogic starts the server. This process might take some time, depending on the speed of your system. When the process completes, the Status column in the Servers view displays Started and the square Stop the Server button becomes active.

4. Click myPortal.portal in the Package Explorer view to select it.

5. From the main menu, select Run > Open Portal Administration Console, as shown in the example in Figure 4-1.

Figure 4-1 Menu Selection for Run > Open Portal Administration Console
The Administration Console login dialog appears.

**Log in to the Administration Console**

The Administration Console login dialog requires a WebLogic Server system administrator or a WebLogic Portal administrator user name and password. WebLogic Server system administrators have full security privileges for the entire domain and can log in to and use the WebLogic Server Administration Console tools. WebLogic Portal administrators have full security privileges for a Portal Web Project, which can include multiple portals.

Table 4-1 shows the default system administrator user names and passwords:

<table>
<thead>
<tr>
<th>User Name</th>
<th>Password</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>portaladmin</td>
<td>portaladmin</td>
<td>Administrator for the portal domain</td>
</tr>
<tr>
<td>weblogic</td>
<td>weblogic</td>
<td>WebLogic Server system administrator with full privileges in the domain</td>
</tr>
</tbody>
</table>

For purposes of this tutorial, you will use the default WebLogic Server login so that you have full privileges.

To log in to the WebLogic Portal Administration Console, follow these steps:

1. Type the user name `weblogic` and password `weblogic` into the dialog and click **Sign In**.
   
The main menu of the Administration Console displays.
Create a Portal and Desktop

To create a desktop, you first create a portal to contain it.

To create a portal and desktop, follow these steps:

1. Click the **Portal Management** menu shortcut on the Administration Console home page.

   The Portal Management page displays; the Portal Resources tree displays in the left pane of the page, as shown in [Figure 4-3](#).

---

Figure 4-2 Administration Console Main Page

![Figure 4-2 Administration Console Main Page](image)

Figure 4-3 Portal Resources Tree in the Administration Console

![Figure 4-3 Portal Resources Tree in the Administration Console](image)
Notice that the display is based on the Portal Web Project that you created in Chapter 3, “Creating a Portal in Your Development Environment.” If you expand the Library > Portlets portion of the tree, you can see the portlets that you created earlier.

2. Click Portals in the tree.
   The Portals page displays, with the Browse Portals tab active. Because no portals exist yet, the table containing portals is empty.

3. Click Create New Portal.
   The Create a New Portal dialog displays, as shown in Figure 4-4.

   Figure 4-4 Create a New Portal Dialog in Administration Console

4. Enter values for the portal, using Table 4-2 as a guide:

   Table 4-2 Create a New Portal Dialog Field Descriptions

<table>
<thead>
<tr>
<th>Field</th>
<th>Value/Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Portal Name</td>
<td>myPortal</td>
</tr>
<tr>
<td>Description</td>
<td></td>
</tr>
<tr>
<td>Partial URL</td>
<td>myPortal</td>
</tr>
<tr>
<td>URI (default resource)</td>
<td></td>
</tr>
</tbody>
</table>

5. Click Create New Portal.
When the Portals page displays again, the Browse Portals table includes the portal you created, and the Portal Resources tree includes the new portal.

6. Click **myPortal** in the Browse Portals table to view the details for this portal.

   The Portals page displays, with the Browse Desktops tab active. Because no desktops exist yet, the table containing desktops is empty.

7. Click **Create New Desktop**.

   The **Create Desktop** wizard displays, as shown in **Figure 4-5**.

**Figure 4-5 Create Desktop Wizard in Administration Console**

8. Enter values for the desktop in the appropriate wizard pages, using **Table 4-3** as your guide:
9. Click **Review Properties** to review the desktop properties, and **Create Desktop** again to create the desktop.

   A confirmation dialog confirms that the desktop has been created and displays related information.

10. Click **Finish** to return to the main Administration Console page.

    The Browse Desktops table includes the desktop you created, and the Portal Resources tree includes the new desktop, as shown in **Figure 4-6**, which shows the expanded tree.
Notice that the portlets that you created for this portal (which was used as the template for this desktop) appear automatically in the new desktop.

**Update the Desktop Page Contents to Rearrange Portlets**

In this task you view the portlets for a desktop page—the portlets that you created using Workshop for WebLogic—and rearrange them on the page. Then you will view your work.

To update your desktop page, follow these steps:

1. In the Portal Resources tree for myPortalWebProject, expand the tree to display the pages for the desktop, as shown in Figure 4-7.
2. Click **Page 1** to select it.

   The Page 1 details display in the right pane of the Administration Console.

3. Select the Edit Contents tab; it appears, as shown in Figure 4-8.

**Figure 4-7  Expanded Portal Resources Tree Showing Desktop Pages**

**Figure 4-8  Page 1 Edit Contents Tab**
4. Drag the Browser Portlet into the same placeholder as the Simple JSP Portlet, as shown in Figure 4-9.

**Figure 4-9 Moving the Browser Portlet by Dragging**

When you release the portlet, it displays above the Simple JSP Portlet, as shown in Figure 4-10.

5. Click **Save Changes**.
6. In the Portal Resources tree, click myDesktop to display the Details page.

7. Click View Desktop.

The desktop displays in a browser, with the portlets in their new positions, as shown in Figure 4-11.

Figure 4-11  Desktop in Browser Showing Moved Portlets

Create a New Page on the Desktop

In this task, you will create a new page for your desktop. Follow these steps:
1. In the Portal Resources tree for myPortalWebProject, expand the Library node in the tree to display the pages, as shown in Figure 4-12.

Figure 4-12 Expanded Portal Resources Tree Showing Desktop Pages

2. Click Pages to display the Browse Pages tab, as shown in Figure 4-13.

Figure 4-13 Browse Pages Tab
3. Click **Create New Page**.

   The **Create New Page** dialog displays, as shown in **Figure 4-14**.

**Figure 4-14 Create New Page Dialog in Administration Console**

![Create New Page Dialog](image)

4. Enter values for the new page, using **Table 4-4** as a guide:

**Table 4-4 Create New Page – Field Descriptions**

<table>
<thead>
<tr>
<th>Field</th>
<th>Value/Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Title</td>
<td>Tutorial Page</td>
</tr>
<tr>
<td>Description</td>
<td>new page for tutorial</td>
</tr>
<tr>
<td>Layout</td>
<td>Three Column Layout</td>
</tr>
<tr>
<td>Theme</td>
<td>(leave as is - None)</td>
</tr>
<tr>
<td>Hidden</td>
<td>(leave as is - unchecked)</td>
</tr>
</tbody>
</table>

5. Click **Create**.

   The new page is added, and is displayed in the Details page for the desktop; the Portal Resources tree updates to include the new page, as shown in **Figure 4-15**.
Summary

With the completion of this tutorial, you have created a basic desktop and performed some additional tasks to become familiar with the staging environment and the WebLogic Portal Administration Console.

To get started with actual portal development and desktop staging, refer to WebLogic Portal document library on e-docs.