WebCenter Portlet API for .NET

WebCenter Portlet API for .NET Library
WebCenter Portlet API for .NET
Send Feedback

Namespaces

Namespace | Description
BEA.ALI.Web | The BEA.ALI.Web namespace contains classes used to build ASP.NET portlets for WebCenter Interaction (WCI).
BEA.ALI.Web.UI | The BEA.ALI.Web.UI namespace contains base pages used to build ASP.NET portlets for WebCenter Interaction (WCI).
BEA.Portlet | The BEA.Portlet namespace contains base classes and objects used for building ASP.NET portlets for either WCI or WSRP aggregators.
BEA.Portlet.WSRP | The BEA.Portlet.WSRP namespace contains classes used when building ASP.NET portlets for WSRP aggregators.


BEA.ALI.Web Namespace

BEA.ALI.Web Namespace
Send Feedback
The BEA.ALI.Web namespace contains classes used to build ASP.NET portlets for WebCenter Interaction (WCI).

Classes

Class | Description
ALIPreferenceAttribute | Place on an WCI page field to mark it as a preference value. The ALIPreferenceAttribute class is abstract, and never used directly. Instead use UserPreference, AdminPreference, etc.
ALIPreferenceCollection | Contains and indexer property for a type of preference.
HttpPortletRequest | Represents an HTTP request within a WCI portlet. This combines ASP.NET's intrinsic Request object with portal-specific information. This is part of the WebCenter Portlet API for .NET.
HttpPortletResponse | Represents an HTTP response within an WCI portlet. This combines ASP.NET's intrinsic Response object with portal-specific information. This is part of the WebCenter Portlet API for .NET.
RemoteSessionAttribute | Place on an ALIPortletPage class to allow RemoteAPISession to establish a connection when debugging the page outside WCI.

Enumerations

Enumeration | Description
AggregationMode | AggregationMode is a flag that tells the portal how the Portlet is currently displayed in the portal, i.e., with other Portlets or alone on the page.
Alignment | An enumeration that identifies the alignment of a portlet.
CommunityAccessLevel | CommunityAccessLevel enumerates the access levels that a user can have for a particular Community.
HostedDisplayMode | HostedDisplayMode is an enumeration of the types of ways a gatewayed page can be displayed by the portal, i.e., with the portal banner or without.
PortletMode | PortletMode is an enumerated type that identifies the mode the portal is using to generate Portlet content.
SettingType | An enumeration of the different types of settings that can be used by a Portlet.
UserInterface | UserInterface is an enumeration that describes the different kinds of user interfaces (e.g., phone, PDA) that can be used in the portal.


AggregationMode Enumeration

AggregationMode Enumeration
See Also Send Feedback
AggregationMode is a flag that tells the portal how the Portlet is currently displayed in the portal, i.e., with other Portlets or alone on the page.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public enum AggregationMode

Members

Member name | Description
Multiple | Multiple Aggregation Mode means that there is more than one Portlet on the portal page in which the Portlet is displayed.
Single | Single Aggregation Mode means that this Portlet is the only Portlet on the portal page.

See Also

BEA.ALI.Web Namespace


Alignment Enumeration

Alignment Enumeration
See Also Send Feedback
An enumeration that identifies the alignment of a portlet.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public enum Alignment

Members

Member name | Description
Footer | Portlet is a footer.
Freeform | Portlet is a content canvas.
Header | Portlet is a header.
Narrow | Portlet can reside in a narrow column.
None | No alignment.
Wide | Portlet can reside in a wide column.

See Also

BEA.ALI.Web Namespace


ALIPreferenceAttribute Class

ALIPreferenceAttribute Class
Members See Also Send Feedback
Place on an WCI page field to mark it as a preference value. The ALIPreferenceAttribute class is abstract, and never used directly. Instead use UserPreference, AdminPreference, etc.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
[AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple = false)]
public abstract class ALIPreferenceAttribute : PreferenceAttribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
BEA.Portlet..::.PortletFieldAttribute
BEA.Portlet..::.PreferenceAttribute
BEA.ALI.Web..::.ALIPreferenceAttribute
BEA.ALI.Web.UI..::.ALIBasePage..::.PortletPreferenceAttribute
BEA.ALI.Web.UI..::.ALIBasePage..::.AdminPreferenceAttribute
BEA.ALI.Web.UI..::.ALIBasePage..::.CommunityPreferenceAttribute
BEA.ALI.Web.UI..::.ALIBasePage..::.CommunityPortletPreferenceAttribute
BEA.ALI.Web.UI..::.ALIBasePage..::.SessionPreferenceAttribute
BEA.ALI.Web.UI..::.ALIBasePage..::.UserPreferenceAttribute

See Also

ALIPreferenceAttribute Members
BEA.ALI.Web Namespace


ALIPreferenceAttribute Members

[image]

WebCenter Portlet API for .NET Library
ALIPreferenceAttribute Members
ALIPreferenceAttribute Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ALIPreferenceAttribute type exposes the following members.

Constructors

Name | Description
ALIPreferenceAttribute | Specifies an WCI preference for the page.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Provides a hashcode unique for the PreferenceAttribute type and key. (Inherited from PreferenceAttribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init | Initializes the preference attribute so that it can handle registration for lifecycle events. (Inherited from PreferenceAttribute.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
LoadValue | Sets the value of the field from the preference values in the IPortletRequest. (Inherited from PreferenceAttribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overrides ToString() to provide a meaningful representation of the PreferenceAttribute type and key. (Inherited from PreferenceAttribute.)
UnloadValue | Writes the value of the field to the preference in the IPortletResponse. (Inherited from PreferenceAttribute.)

Fields

Name | Description
_field | The FieldInfo provided during Init. (Inherited from PortletFieldAttribute.)
_isInitialized | Returns trueTruetruetrue (True in Visual Basic) if Init has has been called. falseFalsefalsefalse (False in Visual Basic) otherwise. (Inherited from PortletFieldAttribute.)
_log | The WCI logger class to trace messages within this class. (Inherited from PortletFieldAttribute.)
_page | The page provided during Init. (Inherited from PortletFieldAttribute.)
_portletContext | The portlet context provided during Init. (Inherited from PortletFieldAttribute.)
_type | The SettingType of the PreferenceAttribute. (Inherited from PreferenceAttribute.)

Properties

Name | Description
Default | Returns a fallback default value base upon the field type if none was provided. (Inherited from PreferenceAttribute.)
DefaultValue | Gets or sets the default value of the preference. This is the value when running outside a portal or when no other value has been assigned. (Inherited from PreferenceAttribute.)
Key | Gets or sets the preference key. (Inherited from PreferenceAttribute.)
PreferenceCollection | Internal PreferenceCollection used to read and write the underlying preference values. (Overrides PreferenceAttribute ..::. PreferenceCollection.)
Type | The type of preference.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

ALIPreferenceAttribute Class
BEA.ALI.Web Namespace


ALIPreferenceAttribute Constructor

ALIPreferenceAttribute Constructor
ALIPreferenceAttribute Class See Also Send Feedback
Specifies an WCI preference for the page.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public ALIPreferenceAttribute(
    SettingType type
)

Parameters

type
Type: BEA.ALI.Web..::.SettingType
The SettingType used by the preference.

See Also

ALIPreferenceAttribute Class
BEA.ALI.Web Namespace


ALIPreferenceAttribute Properties

[image]

WebCenter Portlet API for .NET Library
ALIPreferenceAttribute Properties
ALIPreferenceAttribute Class See Also Send Feedback

The ALIPreferenceAttribute type exposes the following members.

Properties

Name | Description
Default | Returns a fallback default value base upon the field type if none was provided. (Inherited from PreferenceAttribute.)
DefaultValue | Gets or sets the default value of the preference. This is the value when running outside a portal or when no other value has been assigned. (Inherited from PreferenceAttribute.)
Key | Gets or sets the preference key. (Inherited from PreferenceAttribute.)
PreferenceCollection | Internal PreferenceCollection used to read and write the underlying preference values. (Overrides PreferenceAttribute ..::. PreferenceCollection.)
Type | The type of preference.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

ALIPreferenceAttribute Class
BEA.ALI.Web Namespace


PreferenceCollection Property

ALIPreferenceAttribute..::.PreferenceCollection Property
ALIPreferenceAttribute Class See Also Send Feedback
Internal PreferenceCollection used to read and write the underlying preference values.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected override PreferenceCollection PreferenceCollection { get; }

See Also

ALIPreferenceAttribute Class
BEA.ALI.Web Namespace


Type Property

ALIPreferenceAttribute..::.Type Property
ALIPreferenceAttribute Class See Also Send Feedback
The type of preference.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public SettingType Type { get; }

See Also

ALIPreferenceAttribute Class
BEA.ALI.Web Namespace


ALIPreferenceCollection Class

ALIPreferenceCollection Class
Members See Also Send Feedback
Contains and indexer property for a type of preference.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public class ALIPreferenceCollection : PreferenceCollection

Inheritance Hierarchy

System..::.Object
BEA.Portlet..::.PreferenceCollection
BEA.ALI.Web..::.ALIPreferenceCollection

See Also

ALIPreferenceCollection Members
BEA.ALI.Web Namespace


ALIPreferenceCollection Members

[image]

WebCenter Portlet API for .NET Library
ALIPreferenceCollection Members
ALIPreferenceCollection Class Methods Fields Properties See Also Send Feedback

The ALIPreferenceCollection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
_log | The WCI logger class to trace messages within this class. (Inherited from PreferenceCollection.)
_portletContext | The IDK IPortletContext for the current request. (Inherited from PreferenceCollection.)
_type | The SettingType of the PreferenceCollection. (Inherited from PreferenceCollection.)

Properties

Name | Description
Item | Indexer to get or set preferences. Returns null if a preference was not sent to this portlet. (Overrides PreferenceCollection ..::. Item[([(String])]).)
Keys | Gets a ICollection of the preference keys sent in the portlet request. (Inherited from PreferenceCollection.)

See Also

ALIPreferenceCollection Class
BEA.ALI.Web Namespace


ALIPreferenceCollection Properties

[image]

WebCenter Portlet API for .NET Library
ALIPreferenceCollection Properties
ALIPreferenceCollection Class See Also Send Feedback

The ALIPreferenceCollection type exposes the following members.

Properties

Name | Description
Item | Indexer to get or set preferences. Returns null if a preference was not sent to this portlet. (Overrides PreferenceCollection ..::. Item[([(String])]).)
Keys | Gets a ICollection of the preference keys sent in the portlet request. (Inherited from PreferenceCollection.)

See Also

ALIPreferenceCollection Class
BEA.ALI.Web Namespace


Item Property

ALIPreferenceCollection..::.Item Property
ALIPreferenceCollection Class See Also Send Feedback
Indexer to get or set preferences. Returns null if a preference was not sent to this portlet.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public override string this[
    string preference
] { get; }

Parameters

preference
Type: System..::.String

See Also

ALIPreferenceCollection Class
BEA.ALI.Web Namespace


CommunityAccessLevel Enumeration

CommunityAccessLevel Enumeration
See Also Send Feedback
CommunityAccessLevel enumerates the access levels that a user can have for a particular Community.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public enum CommunityAccessLevel

Members

Member name | Description
Admin | The user has full administrative rights to the Community.
Edit | The user has the ability to edit content in the Community (add Portlets, delete Portlets, change layout, etc.).
None | The user does not have access to the Community.
Read | The user can see the Community in the list of Communities, but cannot choose to join the Community.
Select | The user can join the Community.

See Also

BEA.ALI.Web Namespace


HostedDisplayMode Enumeration

HostedDisplayMode Enumeration
See Also Send Feedback
HostedDisplayMode is an enumeration of the types of ways a gatewayed page can be displayed by the portal, i.e., with the portal banner or without.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public enum HostedDisplayMode

Members

Member name | Description
Hosted | Provides the portal banner and footer.
None | Content should be sent without the portal banner or footer.

See Also

BEA.ALI.Web Namespace


HttpPortletRequest Class

HttpPortletRequest Class
Members See Also Send Feedback
Represents an HTTP request within a WCI portlet. This combines ASP.NET's intrinsic Request object with portal-specific information. This is part of the WebCenter Portlet API for .NET.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public class HttpPortletRequest

Inheritance Hierarchy

System..::.Object
BEA.ALI.Web..::.HttpPortletRequest

See Also

HttpPortletRequest Members
BEA.ALI.Web Namespace


HttpPortletRequest Members

[image]

WebCenter Portlet API for .NET Library
HttpPortletRequest Members
HttpPortletRequest Class Methods Properties See Also Send Feedback

The HttpPortletRequest type exposes the following members.

Methods

Name | Description
BinaryRead | Performs a binary read of a specified number of bytes from the current input stream.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance.
MapImageCoordinates | Maps an incoming image-field form parameter to appropriate x-coordinate and y-coordinate values.
MapPath | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object.
SaveAs | Saves an HTTP request to disk.
ToString | Returns a String that represents the current Object.
ValidateInput | Validates data submitted by a client browser and raises an exception if potentially dangerous data is present.

Properties

Name | Description
AcceptTypes | Gets a string array of client-supported MIME accept types.
AnonymousID | Gets the anonymous identifier for the user, if present.
ApplicationPath | Gets the ASP.NET application's virtual application root path on the server.
AppRelativeCurrentExecutionFilePath | Gets the virtual path of the application root and makes it relative by using the tilde (~) notation for the application root (as in "~/page.aspx").
Browser | Gets or sets information about the requesting client's browser capabilities.
ClientCertificate | Gets the current request's client security certificate.
ContentEncoding | Gets or sets the character set of the entity-body.
ContentLength | Specifies the length, in bytes, of content sent by the client.
ContentType | Gets or sets the MIME content type of the incoming request.
Cookies | Gets a collection of cookies sent by the client.
CurrentExecutionFilePath | Gets the virtual path of the current request.
FilePath | Gets the virtual path of the current request.
Files | Gets the collection of files uploaded by the client, in multipart MIME format.
Filter | Gets or sets the filter to use when reading the current input stream.
Form | Gets a collection of form variables.
Headers | Gets a collection of HTTP headers.
HttpMethod | Gets the HTTP data transfer method (such as GET, POST, or HEAD) used by the client.
InputStream | Gets the contents of the incoming HTTP entity body.
IsAuthenticated | Gets a value indicating whether the request has been authenticated.
IsLocal | Gets a value indicating whether the request is from the local computer.
IsSecureConnection | Gets a value indicting whether the HTTP connection uses secure sockets (that is, HTTPS).
Item | Gets the specified object from the Cookies, Form, QueryString or ServerVariables collections.
LogonUserIdentity | Gets the WindowsIdentity type for the current user.
Params | Gets a combined collection of QueryString, Form, ServerVariables, and Cookies items.
Path | Gets the virtual path of the current request.
PathInfo | Gets additional path information for a resource with a URL extension.
PhysicalApplicationPath | Gets the physical file system path of the currently executing server application's root directory.
PhysicalPath | Gets the physical file system path corresponding to the requested URL.
QueryString | Gets the collection of HTTP query string variables.
RawUrl | Gets the raw URL of the current request.
RequestType | Gets or sets the HTTP data transfer method (GET or POST) used by the client.
ServerVariables | Gets a collection of Web server variables.
TimeZone | Returns a TimeZone object representing the end user's time zone.
TotalBytes | Gets the number of bytes in the current input stream.
Url | Gets information about the URL of the current request.
UrlReferrer | Gets information about the URL of the client's previous request that linked to the current URL.
UserAgent | Gets the raw user agent string of the client browser.
UserHostAddress | Gets the IP host address of the remote client.
UserHostName | Gets the DNS name of the remote client.
UserLanguages | Gets a sorted string array of client language preferences.

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


HttpPortletRequest Methods

[image]

WebCenter Portlet API for .NET Library
HttpPortletRequest Methods
HttpPortletRequest Class See Also Send Feedback

The HttpPortletRequest type exposes the following members.

Methods

Name | Description
BinaryRead | Performs a binary read of a specified number of bytes from the current input stream.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance.
MapImageCoordinates | Maps an incoming image-field form parameter to appropriate x-coordinate and y-coordinate values.
MapPath | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object.
SaveAs | Saves an HTTP request to disk.
ToString | Returns a String that represents the current Object.
ValidateInput | Validates data submitted by a client browser and raises an exception if potentially dangerous data is present.

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


BinaryRead Method

HttpPortletRequest..::.BinaryRead Method
HttpPortletRequest Class See Also Send Feedback
Performs a binary read of a specified number of bytes from the current input stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public byte[] BinaryRead(
    int count
)

Parameters

count
Type: System..::.Int32

Remarks

BinaryRead(Int32)

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


Equals Method

[image]

WebCenter Portlet API for .NET Library
HttpPortletRequest..::.Equals Method
HttpPortletRequest Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether two Object instances are equal. (Overrides Object ..::. Equals(Object).)
Equals(Object, Object) | Determines whether two Object instances are equal.

See Also

HttpPortletRequest Class
HttpPortletRequest Members
BEA.ALI.Web Namespace


Equals Method (Object)

HttpPortletRequest..::.Equals Method (Object)
HttpPortletRequest Class See Also Send Feedback
Determines whether two Object instances are equal.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object

Remarks

Equals(Object)

See Also

HttpPortletRequest Class
Equals Overload
BEA.ALI.Web Namespace


Equals Method (Object, Object)

HttpPortletRequest..::.Equals Method (Object, Object)
HttpPortletRequest Class See Also Send Feedback
Determines whether two Object instances are equal.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public static bool Equals(
    Object objA,
    Object objB
)

Parameters

objA
Type: System..::.Object
objB
Type: System..::.Object

Remarks

Equals(Object, Object)

See Also

HttpPortletRequest Class
Equals Overload
BEA.ALI.Web Namespace


GetHashCode Method

HttpPortletRequest..::.GetHashCode Method
HttpPortletRequest Class See Also Send Feedback
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public override int GetHashCode()

Remarks

GetHashCode()()()

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


GetType Method

HttpPortletRequest..::.GetType Method
HttpPortletRequest Class See Also Send Feedback
Gets the Type of the current instance.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Type GetType()

Remarks

GetType()()()

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


MapImageCoordinates Method

HttpPortletRequest..::.MapImageCoordinates Method
HttpPortletRequest Class See Also Send Feedback
Maps an incoming image-field form parameter to appropriate x-coordinate and y-coordinate values.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public int[] MapImageCoordinates(
    string imageFieldName
)

Parameters

imageFieldName
Type: System..::.String

Remarks

MapImageCoordinates(String)

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


MapPath Method

[image]

WebCenter Portlet API for .NET Library
HttpPortletRequest..::.MapPath Method
HttpPortletRequest Class See Also Send Feedback

Overload List

Name | Description
MapPath(String) | Maps the virtual path in the requested URL to a physical path on the server for the current request.
MapPath(String, String, Boolean) | Maps the virtual path in the requested URL to a physical path on the server for the current request.

See Also

HttpPortletRequest Class
HttpPortletRequest Members
BEA.ALI.Web Namespace


MapPath Method (String)

HttpPortletRequest..::.MapPath Method (String)
HttpPortletRequest Class See Also Send Feedback
Maps the virtual path in the requested URL to a physical path on the server for the current request.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string MapPath(
    string virtualPath
)

Parameters

virtualPath
Type: System..::.String

Remarks

MapPath(String)

See Also

HttpPortletRequest Class
MapPath Overload
BEA.ALI.Web Namespace


MapPath Method (String, String, Boolean)

HttpPortletRequest..::.MapPath Method (String, String, Boolean)
HttpPortletRequest Class See Also Send Feedback
Maps the virtual path in the requested URL to a physical path on the server for the current request.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string MapPath(
    string virtualPath,
    string baseVirtualDir,
    bool allowCrossAppMapping
)

Parameters

virtualPath
Type: System..::.String
baseVirtualDir
Type: System..::.String
allowCrossAppMapping
Type: System..::.Boolean

Remarks

MapPath(String, String, Boolean)

See Also

HttpPortletRequest Class
MapPath Overload
BEA.ALI.Web Namespace


MemberwiseClone Method

HttpPortletRequest..::.MemberwiseClone Method
HttpPortletRequest Class See Also Send Feedback
Creates a shallow copy of the current Object.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected Object MemberwiseClone()

Remarks

MemberwiseClone()()()

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


SaveAs Method

HttpPortletRequest..::.SaveAs Method
HttpPortletRequest Class See Also Send Feedback
Saves an HTTP request to disk.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void SaveAs(
    string filename,
    bool includeHeaders
)

Parameters

filename
Type: System..::.String
includeHeaders
Type: System..::.Boolean

Remarks

SaveAs(String, Boolean)

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


ToString Method

HttpPortletRequest..::.ToString Method
HttpPortletRequest Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string ToString()

Remarks

ToString()()()

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


ValidateInput Method

HttpPortletRequest..::.ValidateInput Method
HttpPortletRequest Class See Also Send Feedback
Validates data submitted by a client browser and raises an exception if potentially dangerous data is present.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void ValidateInput()

Remarks

ValidateInput()()()

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


HttpPortletRequest Properties

[image]

WebCenter Portlet API for .NET Library
HttpPortletRequest Properties
HttpPortletRequest Class See Also Send Feedback

The HttpPortletRequest type exposes the following members.

Properties

Name | Description
AcceptTypes | Gets a string array of client-supported MIME accept types.
AnonymousID | Gets the anonymous identifier for the user, if present.
ApplicationPath | Gets the ASP.NET application's virtual application root path on the server.
AppRelativeCurrentExecutionFilePath | Gets the virtual path of the application root and makes it relative by using the tilde (~) notation for the application root (as in "~/page.aspx").
Browser | Gets or sets information about the requesting client's browser capabilities.
ClientCertificate | Gets the current request's client security certificate.
ContentEncoding | Gets or sets the character set of the entity-body.
ContentLength | Specifies the length, in bytes, of content sent by the client.
ContentType | Gets or sets the MIME content type of the incoming request.
Cookies | Gets a collection of cookies sent by the client.
CurrentExecutionFilePath | Gets the virtual path of the current request.
FilePath | Gets the virtual path of the current request.
Files | Gets the collection of files uploaded by the client, in multipart MIME format.
Filter | Gets or sets the filter to use when reading the current input stream.
Form | Gets a collection of form variables.
Headers | Gets a collection of HTTP headers.
HttpMethod | Gets the HTTP data transfer method (such as GET, POST, or HEAD) used by the client.
InputStream | Gets the contents of the incoming HTTP entity body.
IsAuthenticated | Gets a value indicating whether the request has been authenticated.
IsLocal | Gets a value indicating whether the request is from the local computer.
IsSecureConnection | Gets a value indicting whether the HTTP connection uses secure sockets (that is, HTTPS).
Item | Gets the specified object from the Cookies, Form, QueryString or ServerVariables collections.
LogonUserIdentity | Gets the WindowsIdentity type for the current user.
Params | Gets a combined collection of QueryString, Form, ServerVariables, and Cookies items.
Path | Gets the virtual path of the current request.
PathInfo | Gets additional path information for a resource with a URL extension.
PhysicalApplicationPath | Gets the physical file system path of the currently executing server application's root directory.
PhysicalPath | Gets the physical file system path corresponding to the requested URL.
QueryString | Gets the collection of HTTP query string variables.
RawUrl | Gets the raw URL of the current request.
RequestType | Gets or sets the HTTP data transfer method (GET or POST) used by the client.
ServerVariables | Gets a collection of Web server variables.
TimeZone | Returns a TimeZone object representing the end user's time zone.
TotalBytes | Gets the number of bytes in the current input stream.
Url | Gets information about the URL of the current request.
UrlReferrer | Gets information about the URL of the client's previous request that linked to the current URL.
UserAgent | Gets the raw user agent string of the client browser.
UserHostAddress | Gets the IP host address of the remote client.
UserHostName | Gets the DNS name of the remote client.
UserLanguages | Gets a sorted string array of client language preferences.

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


AcceptTypes Property

HttpPortletRequest..::.AcceptTypes Property
HttpPortletRequest Class See Also Send Feedback
Gets a string array of client-supported MIME accept types.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string[] AcceptTypes { get; }

Remarks

AcceptTypes

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


AnonymousID Property

HttpPortletRequest..::.AnonymousID Property
HttpPortletRequest Class See Also Send Feedback
Gets the anonymous identifier for the user, if present.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string AnonymousID { get; }

Remarks

AnonymousID

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


ApplicationPath Property

HttpPortletRequest..::.ApplicationPath Property
HttpPortletRequest Class See Also Send Feedback
Gets the ASP.NET application's virtual application root path on the server.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string ApplicationPath { get; }

Remarks

ApplicationPath

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


AppRelativeCurrentExecutionFilePath Property

HttpPortletRequest..::.AppRelativeCurrentExecutionFilePath Property
HttpPortletRequest Class See Also Send Feedback
Gets the virtual path of the application root and makes it relative by using the tilde (~) notation for the application root (as in "~/page.aspx").

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string AppRelativeCurrentExecutionFilePath { get; }

Remarks

AppRelativeCurrentExecutionFilePath

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


Browser Property

HttpPortletRequest..::.Browser Property
HttpPortletRequest Class See Also Send Feedback
Gets or sets information about the requesting client's browser capabilities.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public HttpBrowserCapabilities Browser { get; set; }

Remarks

Browser

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


ClientCertificate Property

HttpPortletRequest..::.ClientCertificate Property
HttpPortletRequest Class See Also Send Feedback
Gets the current request's client security certificate.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public HttpClientCertificate ClientCertificate { get; }

Remarks

ClientCertificate

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


ContentEncoding Property

HttpPortletRequest..::.ContentEncoding Property
HttpPortletRequest Class See Also Send Feedback
Gets or sets the character set of the entity-body.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Encoding ContentEncoding { get; set; }

Remarks

ContentEncoding

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


ContentLength Property

HttpPortletRequest..::.ContentLength Property
HttpPortletRequest Class See Also Send Feedback
Specifies the length, in bytes, of content sent by the client.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public int ContentLength { get; }

Remarks

ContentLength

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


ContentType Property

HttpPortletRequest..::.ContentType Property
HttpPortletRequest Class See Also Send Feedback
Gets or sets the MIME content type of the incoming request.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string ContentType { get; set; }

Remarks

ContentType

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


Cookies Property

HttpPortletRequest..::.Cookies Property
HttpPortletRequest Class See Also Send Feedback
Gets a collection of cookies sent by the client.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public HttpCookieCollection Cookies { get; }

Remarks

Cookies

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


CurrentExecutionFilePath Property

HttpPortletRequest..::.CurrentExecutionFilePath Property
HttpPortletRequest Class See Also Send Feedback
Gets the virtual path of the current request.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string CurrentExecutionFilePath { get; }

Remarks

CurrentExecutionFilePath

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


FilePath Property

HttpPortletRequest..::.FilePath Property
HttpPortletRequest Class See Also Send Feedback
Gets the virtual path of the current request.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string FilePath { get; }

Remarks

FilePath

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


Files Property

HttpPortletRequest..::.Files Property
HttpPortletRequest Class See Also Send Feedback
Gets the collection of files uploaded by the client, in multipart MIME format.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public HttpFileCollection Files { get; }

Remarks

Files

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


Filter Property

HttpPortletRequest..::.Filter Property
HttpPortletRequest Class See Also Send Feedback
Gets or sets the filter to use when reading the current input stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Stream Filter { get; set; }

Remarks

Filter

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


Form Property

HttpPortletRequest..::.Form Property
HttpPortletRequest Class See Also Send Feedback
Gets a collection of form variables.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public NameValueCollection Form { get; }

Remarks

Form

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


Headers Property

HttpPortletRequest..::.Headers Property
HttpPortletRequest Class See Also Send Feedback
Gets a collection of HTTP headers.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public NameValueCollection Headers { get; }

Remarks

Headers

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


HttpMethod Property

HttpPortletRequest..::.HttpMethod Property
HttpPortletRequest Class See Also Send Feedback
Gets the HTTP data transfer method (such as GET, POST, or HEAD) used by the client.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string HttpMethod { get; }

Remarks

HttpMethod

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


InputStream Property

HttpPortletRequest..::.InputStream Property
HttpPortletRequest Class See Also Send Feedback
Gets the contents of the incoming HTTP entity body.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Stream InputStream { get; }

Remarks

InputStream

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


IsAuthenticated Property

HttpPortletRequest..::.IsAuthenticated Property
HttpPortletRequest Class See Also Send Feedback
Gets a value indicating whether the request has been authenticated.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool IsAuthenticated { get; }

Remarks

IsAuthenticated

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


IsLocal Property

HttpPortletRequest..::.IsLocal Property
HttpPortletRequest Class See Also Send Feedback
Gets a value indicating whether the request is from the local computer.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool IsLocal { get; }

Remarks

IsLocal

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


IsSecureConnection Property

HttpPortletRequest..::.IsSecureConnection Property
HttpPortletRequest Class See Also Send Feedback
Gets a value indicting whether the HTTP connection uses secure sockets (that is, HTTPS).

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool IsSecureConnection { get; }

Remarks

IsSecureConnection

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


Item Property

HttpPortletRequest..::.Item Property
HttpPortletRequest Class See Also Send Feedback
Gets the specified object from the Cookies, Form, QueryString or ServerVariables collections.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string this[
    string key
] { get; }

Parameters

key
Type: System..::.String

Remarks

Item[([(String])])

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


LogonUserIdentity Property

HttpPortletRequest..::.LogonUserIdentity Property
HttpPortletRequest Class See Also Send Feedback
Gets the WindowsIdentity type for the current user.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public WindowsIdentity LogonUserIdentity { get; }

Remarks

LogonUserIdentity

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


Params Property

HttpPortletRequest..::.Params Property
HttpPortletRequest Class See Also Send Feedback
Gets a combined collection of QueryString, Form, ServerVariables, and Cookies items.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public NameValueCollection Params { get; }

Remarks

Params

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


Path Property

HttpPortletRequest..::.Path Property
HttpPortletRequest Class See Also Send Feedback
Gets the virtual path of the current request.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string Path { get; }

Remarks

Path

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


PathInfo Property

HttpPortletRequest..::.PathInfo Property
HttpPortletRequest Class See Also Send Feedback
Gets additional path information for a resource with a URL extension.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string PathInfo { get; }

Remarks

PathInfo

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


PhysicalApplicationPath Property

HttpPortletRequest..::.PhysicalApplicationPath Property
HttpPortletRequest Class See Also Send Feedback
Gets the physical file system path of the currently executing server application's root directory.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string PhysicalApplicationPath { get; }

Remarks

PhysicalApplicationPath

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


PhysicalPath Property

HttpPortletRequest..::.PhysicalPath Property
HttpPortletRequest Class See Also Send Feedback
Gets the physical file system path corresponding to the requested URL.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string PhysicalPath { get; }

Remarks

PhysicalPath

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


QueryString Property

HttpPortletRequest..::.QueryString Property
HttpPortletRequest Class See Also Send Feedback
Gets the collection of HTTP query string variables.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public NameValueCollection QueryString { get; }

Remarks

QueryString

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


RawUrl Property

HttpPortletRequest..::.RawUrl Property
HttpPortletRequest Class See Also Send Feedback
Gets the raw URL of the current request.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string RawUrl { get; }

Remarks

RawUrl

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


RequestType Property

HttpPortletRequest..::.RequestType Property
HttpPortletRequest Class See Also Send Feedback
Gets or sets the HTTP data transfer method (GET or POST) used by the client.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string RequestType { get; set; }

Remarks

RequestType

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


ServerVariables Property

HttpPortletRequest..::.ServerVariables Property
HttpPortletRequest Class See Also Send Feedback
Gets a collection of Web server variables.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public NameValueCollection ServerVariables { get; }

Remarks

ServerVariables

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


TimeZone Property

HttpPortletRequest..::.TimeZone Property
HttpPortletRequest Class See Also Send Feedback
Returns a TimeZone object representing the end user's time zone.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public TimeZone TimeZone { get; }

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


TotalBytes Property

HttpPortletRequest..::.TotalBytes Property
HttpPortletRequest Class See Also Send Feedback
Gets the number of bytes in the current input stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public int TotalBytes { get; }

Remarks

TotalBytes

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


Url Property

HttpPortletRequest..::.Url Property
HttpPortletRequest Class See Also Send Feedback
Gets information about the URL of the current request.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Uri Url { get; }

Remarks

Url

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


UrlReferrer Property

HttpPortletRequest..::.UrlReferrer Property
HttpPortletRequest Class See Also Send Feedback
Gets information about the URL of the client's previous request that linked to the current URL.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Uri UrlReferrer { get; }

Remarks

UrlReferrer

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


UserAgent Property

HttpPortletRequest..::.UserAgent Property
HttpPortletRequest Class See Also Send Feedback
Gets the raw user agent string of the client browser.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string UserAgent { get; }

Remarks

UserAgent

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


UserHostAddress Property

HttpPortletRequest..::.UserHostAddress Property
HttpPortletRequest Class See Also Send Feedback
Gets the IP host address of the remote client.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string UserHostAddress { get; }

Remarks

UserHostAddress

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


UserHostName Property

HttpPortletRequest..::.UserHostName Property
HttpPortletRequest Class See Also Send Feedback
Gets the DNS name of the remote client.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string UserHostName { get; }

Remarks

UserHostName

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


UserLanguages Property

HttpPortletRequest..::.UserLanguages Property
HttpPortletRequest Class See Also Send Feedback
Gets a sorted string array of client language preferences.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string[] UserLanguages { get; }

Remarks

UserLanguages

See Also

HttpPortletRequest Class
BEA.ALI.Web Namespace


HttpPortletResponse Class

HttpPortletResponse Class
Members See Also Send Feedback
Represents an HTTP response within an WCI portlet. This combines ASP.NET's intrinsic Response object with portal-specific information. This is part of the WebCenter Portlet API for .NET.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public class HttpPortletResponse

Inheritance Hierarchy

System..::.Object
BEA.ALI.Web..::.HttpPortletResponse

See Also

HttpPortletResponse Members
BEA.ALI.Web Namespace


HttpPortletResponse Members

[image]

WebCenter Portlet API for .NET Library
HttpPortletResponse Members
HttpPortletResponse Class Methods Properties See Also Send Feedback

The HttpPortletResponse type exposes the following members.

Methods

Name | Description
AddCacheDependency | Associates a set of cache dependencies with the response to facilitate invalidation of the response if it is stored in the output cache and the specified dependencies change.
AddCacheItemDependencies | Overloaded.
AddCacheItemDependency | Makes the validity of a cached response dependent on another item in the cache.
AddFileDependencies | Overloaded.
AddFileDependency | Adds a single file name to the collection of file names on which the current response is dependent.
AddHeader | Adds an HTTP header to the output stream. AddHeader is provided for compatibility with previous versions of ASP.
AppendCookie | This method supports the .NET Framework infrastructure and is not intended to be used directly from your code. Adds an HTTP cookie to the intrinsic cookie collection.
AppendHeader | Adds an HTTP header to the output stream.
AppendToLog | Adds custom log information to the Internet Information Services (IIS) log file.
ApplyAppPathModifier | Adds a session ID to the virtual path if the session is using Cookieless session state and returns the combined path. If Cookieless session state is not used, ApplyAppPathModifier returns the original virtual path.
BinaryWrite | Writes a string of binary characters to the HTTP output stream.
Clear | Clears all content output from the buffer stream.
ClearContent | Clears all content output from the buffer stream.
ClearHeaders | Clears all headers from the buffer stream.
Close | Closes the socket connection to a client.
End | Sends all currently buffered output to the client, stops execution of the page, and raises the EndRequest event.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Flush | Sends all currently buffered output to the client.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance.
MemberwiseClone | Creates a shallow copy of the current Object.
Pics | Appends a PICS-Label HTTP header to the output stream.
Redirect | Overloaded.
RemoveOutputCacheItem | Static method removes from the cache all cached items associated with the specified path.
ReturnToPortal | Redirects the user to the portal page on which they started.
SetCookie | This method supports the .NET Framework infrastructure and is not intended to be used directly from your code. Updates an existing cookie in the cookie collection.
ToString | Returns a String that represents the current Object.
TransmitFile | Writes the specified file directly to an HTTP response output stream without buffering it in memory.
Write | Overloaded.
WriteFile | Overloaded.
WriteSubstitution | Allows insertion of response substitution blocks into the response, which allows dynamic generation of specified response regions for output cached responses.

Properties

Name | Description
Buffer | Gets or sets a value indicating whether to buffer output and send it after the entire response is finished processing.
BufferOutput | Gets or sets a value indicating whether to buffer output and send it after the entire page is finished processing.
Cache | Gets the caching policy (expiration time, privacy, vary clauses) of a web page.
CacheControl | Sets the Cache-Control HTTP header to Public or Private.
Charset | Gets or sets the HTTP character set of the output stream.
ContentEncoding | Gets or sets the HTTP character set of the output stream.
ContentType | Gets or sets the HTTP MIME type of the output stream.
Cookies | Gets the response cookie collection.
Expires | Gets or sets the number of minutes before a page cached on a browser expires. If the user returns to the same page before it expires, the cached version is displayed. Expires is provided for compatibility with previous versions of ASP.
ExpiresAbsolute | Gets or sets the absolute date and time at which to remove cached information from the cache. ExpiresAbsolute is provided for compatibility with previous versions of ASP.
Filter | Gets or sets a wrapping filter object used to modify the HTTP entity body before transmission.
HeaderEncoding | Gets or sets an Encoding object representing the encoding for the current header output stream.
IsClientConnected | Gets a value indicating whether the client is still connected to the server.
IsRequestBeingRedirected | Gets a Boolean value indicating whether the client is being transferred to a new location.
Output | Enables output of text to the outgoing HTTP response stream.
OutputStream | Enables binary output to the outgoing HTTP content body.
RedirectLocation | Gets or sets the value of the HTTP Location header.
Status | Sets the Status line that is returned to the client.
StatusCode | Gets or sets the HTTP status code of the output returned to the client.
StatusDescription | Gets or sets the HTTP status string of the output returned to the client.
SuppressContent | Gets or sets a value indicating whether to send HTTP content to the client.

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


HttpPortletResponse Methods

[image]

WebCenter Portlet API for .NET Library
HttpPortletResponse Methods
HttpPortletResponse Class See Also Send Feedback

The HttpPortletResponse type exposes the following members.

Methods

Name | Description
AddCacheDependency | Associates a set of cache dependencies with the response to facilitate invalidation of the response if it is stored in the output cache and the specified dependencies change.
AddCacheItemDependencies | Overloaded.
AddCacheItemDependency | Makes the validity of a cached response dependent on another item in the cache.
AddFileDependencies | Overloaded.
AddFileDependency | Adds a single file name to the collection of file names on which the current response is dependent.
AddHeader | Adds an HTTP header to the output stream. AddHeader is provided for compatibility with previous versions of ASP.
AppendCookie | This method supports the .NET Framework infrastructure and is not intended to be used directly from your code. Adds an HTTP cookie to the intrinsic cookie collection.
AppendHeader | Adds an HTTP header to the output stream.
AppendToLog | Adds custom log information to the Internet Information Services (IIS) log file.
ApplyAppPathModifier | Adds a session ID to the virtual path if the session is using Cookieless session state and returns the combined path. If Cookieless session state is not used, ApplyAppPathModifier returns the original virtual path.
BinaryWrite | Writes a string of binary characters to the HTTP output stream.
Clear | Clears all content output from the buffer stream.
ClearContent | Clears all content output from the buffer stream.
ClearHeaders | Clears all headers from the buffer stream.
Close | Closes the socket connection to a client.
End | Sends all currently buffered output to the client, stops execution of the page, and raises the EndRequest event.
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Flush | Sends all currently buffered output to the client.
GetHashCode | Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table. (Overrides Object ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance.
MemberwiseClone | Creates a shallow copy of the current Object.
Pics | Appends a PICS-Label HTTP header to the output stream.
Redirect | Overloaded.
RemoveOutputCacheItem | Static method removes from the cache all cached items associated with the specified path.
ReturnToPortal | Redirects the user to the portal page on which they started.
SetCookie | This method supports the .NET Framework infrastructure and is not intended to be used directly from your code. Updates an existing cookie in the cookie collection.
ToString | Returns a String that represents the current Object.
TransmitFile | Writes the specified file directly to an HTTP response output stream without buffering it in memory.
Write | Overloaded.
WriteFile | Overloaded.
WriteSubstitution | Allows insertion of response substitution blocks into the response, which allows dynamic generation of specified response regions for output cached responses.

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


AddCacheDependency Method

HttpPortletResponse..::.AddCacheDependency Method
HttpPortletResponse Class See Also Send Feedback
Associates a set of cache dependencies with the response to facilitate invalidation of the response if it is stored in the output cache and the specified dependencies change.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void AddCacheDependency(
    CacheDependency[] dependencies
)

Parameters

dependencies
Type: array< System.Web.Caching..::.CacheDependency >[]()[]

Remarks

AddCacheDependency(array<CacheDependency>[]()[])

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


AddCacheItemDependencies Method

[image]

WebCenter Portlet API for .NET Library
HttpPortletResponse..::.AddCacheItemDependencies Method
HttpPortletResponse Class See Also Send Feedback

Overload List

Name | Description
AddCacheItemDependencies(ArrayList) | Makes the validity of a cached response dependent on other items in the cache.
AddCacheItemDependencies(array<String>[]()[]) | Makes the validity of a cached response dependent on other items in the cache.

See Also

HttpPortletResponse Class
HttpPortletResponse Members
BEA.ALI.Web Namespace


AddCacheItemDependencies Method (ArrayList)

HttpPortletResponse..::.AddCacheItemDependencies Method (ArrayList)
HttpPortletResponse Class See Also Send Feedback
Makes the validity of a cached response dependent on other items in the cache.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void AddCacheItemDependencies(
    ArrayList cacheKeys
)

Parameters

cacheKeys
Type: System.Collections..::.ArrayList

Remarks

AddCacheItemDependencies(ArrayList)

See Also

HttpPortletResponse Class
AddCacheItemDependencies Overload
BEA.ALI.Web Namespace


AddCacheItemDependencies Method (String[])

HttpPortletResponse..::.AddCacheItemDependencies Method (array<String>[]()[])
HttpPortletResponse Class See Also Send Feedback
Makes the validity of a cached response dependent on other items in the cache.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void AddCacheItemDependencies(
    string[] cacheKeys
)

Parameters

cacheKeys
Type: array< System..::.String >[]()[]

Remarks

AddCacheItemDependencies(array<String>[]()[])

See Also

HttpPortletResponse Class
AddCacheItemDependencies Overload
BEA.ALI.Web Namespace


AddCacheItemDependency Method

HttpPortletResponse..::.AddCacheItemDependency Method
HttpPortletResponse Class See Also Send Feedback
Makes the validity of a cached response dependent on another item in the cache.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void AddCacheItemDependency(
    string cacheKey
)

Parameters

cacheKey
Type: System..::.String

Remarks

AddCacheItemDependency(String)

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


AddFileDependencies Method

[image]

WebCenter Portlet API for .NET Library
HttpPortletResponse..::.AddFileDependencies Method
HttpPortletResponse Class See Also Send Feedback

Overload List

Name | Description
AddFileDependencies(ArrayList) | Adds a group of file names to the collection of file names on which the current response is dependent.
AddFileDependencies(array<String>[]()[]) | Adds a group of file names to the collection of file names on which the current response is dependent.

See Also

HttpPortletResponse Class
HttpPortletResponse Members
BEA.ALI.Web Namespace


AddFileDependencies Method (ArrayList)

HttpPortletResponse..::.AddFileDependencies Method (ArrayList)
HttpPortletResponse Class See Also Send Feedback
Adds a group of file names to the collection of file names on which the current response is dependent.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void AddFileDependencies(
    ArrayList filenames
)

Parameters

filenames
Type: System.Collections..::.ArrayList

Remarks

AddFileDependencies(ArrayList)

See Also

HttpPortletResponse Class
AddFileDependencies Overload
BEA.ALI.Web Namespace


AddFileDependencies Method (String[])

HttpPortletResponse..::.AddFileDependencies Method (array<String>[]()[])
HttpPortletResponse Class See Also Send Feedback
Adds a group of file names to the collection of file names on which the current response is dependent.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void AddFileDependencies(
    string[] filenames
)

Parameters

filenames
Type: array< System..::.String >[]()[]

Remarks

AddFileDependencies(array<String>[]()[])

See Also

HttpPortletResponse Class
AddFileDependencies Overload
BEA.ALI.Web Namespace


AddFileDependency Method

HttpPortletResponse..::.AddFileDependency Method
HttpPortletResponse Class See Also Send Feedback
Adds a single file name to the collection of file names on which the current response is dependent.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void AddFileDependency(
    string filename
)

Parameters

filename
Type: System..::.String

Remarks

AddFileDependency(String)

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


AddHeader Method

HttpPortletResponse..::.AddHeader Method
HttpPortletResponse Class See Also Send Feedback
Adds an HTTP header to the output stream. AddHeader is provided for compatibility with previous versions of ASP.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void AddHeader(
    string name,
    string value
)

Parameters

name
Type: System..::.String
value
Type: System..::.String

Remarks

AddHeader(String, String)

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


AppendCookie Method

HttpPortletResponse..::.AppendCookie Method
HttpPortletResponse Class See Also Send Feedback
This method supports the .NET Framework infrastructure and is not intended to be used directly from your code. Adds an HTTP cookie to the intrinsic cookie collection.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void AppendCookie(
    HttpCookie cookie
)

Parameters

cookie
Type: System.Web..::.HttpCookie

Remarks

AppendCookie(HttpCookie)

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


AppendHeader Method

HttpPortletResponse..::.AppendHeader Method
HttpPortletResponse Class See Also Send Feedback
Adds an HTTP header to the output stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void AppendHeader(
    string name,
    string value
)

Parameters

name
Type: System..::.String
value
Type: System..::.String

Remarks

AppendHeader(String, String)

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


AppendToLog Method

HttpPortletResponse..::.AppendToLog Method
HttpPortletResponse Class See Also Send Feedback
Adds custom log information to the Internet Information Services (IIS) log file.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void AppendToLog(
    string param
)

Parameters

param
Type: System..::.String

Remarks

AppendToLog(String)

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


ApplyAppPathModifier Method

HttpPortletResponse..::.ApplyAppPathModifier Method
HttpPortletResponse Class See Also Send Feedback
Adds a session ID to the virtual path if the session is using Cookieless session state and returns the combined path. If Cookieless session state is not used, ApplyAppPathModifier returns the original virtual path.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string ApplyAppPathModifier(
    string virtualPath
)

Parameters

virtualPath
Type: System..::.String

Remarks

ApplyAppPathModifier(String)

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


BinaryWrite Method

HttpPortletResponse..::.BinaryWrite Method
HttpPortletResponse Class See Also Send Feedback
Writes a string of binary characters to the HTTP output stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void BinaryWrite(
    byte[] buffer
)

Parameters

buffer
Type: array< System..::.Byte >[]()[]

Remarks

BinaryWrite(array<Byte>[]()[])

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


Clear Method

HttpPortletResponse..::.Clear Method
HttpPortletResponse Class See Also Send Feedback
Clears all content output from the buffer stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void Clear()

Remarks

Clear()()()

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


ClearContent Method

HttpPortletResponse..::.ClearContent Method
HttpPortletResponse Class See Also Send Feedback
Clears all content output from the buffer stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void ClearContent()

Remarks

ClearContent()()()

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


ClearHeaders Method

HttpPortletResponse..::.ClearHeaders Method
HttpPortletResponse Class See Also Send Feedback
Clears all headers from the buffer stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void ClearHeaders()

Remarks

ClearHeaders()()()

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


Close Method

HttpPortletResponse..::.Close Method
HttpPortletResponse Class See Also Send Feedback
Closes the socket connection to a client.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void Close()

Remarks

Close()()()

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


End Method

HttpPortletResponse..::.End Method
HttpPortletResponse Class See Also Send Feedback
Sends all currently buffered output to the client, stops execution of the page, and raises the EndRequest event.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void End()

Remarks

End()()()

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


Equals Method

[image]

WebCenter Portlet API for .NET Library
HttpPortletResponse..::.Equals Method
HttpPortletResponse Class See Also Send Feedback

Overload List

Name | Description
Equals(Object) | Determines whether two Object instances are equal. (Overrides Object ..::. Equals(Object).)
Equals(Object, Object) | Determines whether two Object instances are equal.

See Also

HttpPortletResponse Class
HttpPortletResponse Members
BEA.ALI.Web Namespace


Equals Method (Object)

HttpPortletResponse..::.Equals Method (Object)
HttpPortletResponse Class See Also Send Feedback
Determines whether two Object instances are equal.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public override bool Equals(
    Object obj
)

Parameters

obj
Type: System..::.Object

Remarks

Equals(Object)

See Also

HttpPortletResponse Class
Equals Overload
BEA.ALI.Web Namespace


Equals Method (Object, Object)

HttpPortletResponse..::.Equals Method (Object, Object)
HttpPortletResponse Class See Also Send Feedback
Determines whether two Object instances are equal.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public static bool Equals(
    Object objA,
    Object objB
)

Parameters

objA
Type: System..::.Object
objB
Type: System..::.Object

Remarks

Equals(Object, Object)

See Also

HttpPortletResponse Class
Equals Overload
BEA.ALI.Web Namespace


Flush Method

HttpPortletResponse..::.Flush Method
HttpPortletResponse Class See Also Send Feedback
Sends all currently buffered output to the client.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void Flush()

Remarks

Flush()()()

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


GetHashCode Method

HttpPortletResponse..::.GetHashCode Method
HttpPortletResponse Class See Also Send Feedback
Serves as a hash function for a particular type, suitable for use in hashing algorithms and data structures like a hash table.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public override int GetHashCode()

Remarks

GetHashCode()()()

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


GetType Method

HttpPortletResponse..::.GetType Method
HttpPortletResponse Class See Also Send Feedback
Gets the Type of the current instance.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Type GetType()

Remarks

GetType()()()

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


MemberwiseClone Method

HttpPortletResponse..::.MemberwiseClone Method
HttpPortletResponse Class See Also Send Feedback
Creates a shallow copy of the current Object.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected Object MemberwiseClone()

Remarks

MemberwiseClone()()()

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


Pics Method

HttpPortletResponse..::.Pics Method
HttpPortletResponse Class See Also Send Feedback
Appends a PICS-Label HTTP header to the output stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void Pics(
    string value
)

Parameters

value
Type: System..::.String

Remarks

Pics(String)

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


Redirect Method

[image]

WebCenter Portlet API for .NET Library
HttpPortletResponse..::.Redirect Method
HttpPortletResponse Class See Also Send Feedback

Overload List

Name | Description
Redirect(String) | Redirects a client to a new URL.
Redirect(String, Boolean) | Redirects a client to a new URL.

See Also

HttpPortletResponse Class
HttpPortletResponse Members
BEA.ALI.Web Namespace


Redirect Method (String)

HttpPortletResponse..::.Redirect Method (String)
HttpPortletResponse Class See Also Send Feedback
Redirects a client to a new URL.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void Redirect(
    string url
)

Parameters

url
Type: System..::.String

Remarks

Redirect(String)

See Also

HttpPortletResponse Class
Redirect Overload
BEA.ALI.Web Namespace


Redirect Method (String, Boolean)

HttpPortletResponse..::.Redirect Method (String, Boolean)
HttpPortletResponse Class See Also Send Feedback
Redirects a client to a new URL.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void Redirect(
    string url,
    bool endResponse
)

Parameters

url
Type: System..::.String
endResponse
Type: System..::.Boolean

Remarks

Redirect(String, Boolean)

See Also

HttpPortletResponse Class
Redirect Overload
BEA.ALI.Web Namespace


RemoveOutputCacheItem Method

HttpPortletResponse..::.RemoveOutputCacheItem Method
HttpPortletResponse Class See Also Send Feedback
Static method removes from the cache all cached items associated with the specified path.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public static void RemoveOutputCacheItem(
    string path
)

Parameters

path
Type: System..::.String

Remarks

RemoveOutputCacheItem(String)

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


ReturnToPortal Method

HttpPortletResponse..::.ReturnToPortal Method
HttpPortletResponse Class See Also Send Feedback
Redirects the user to the portal page on which they started.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void ReturnToPortal()

Remarks

This method is usually used when a user has clicked through to a Preferences page and clicks "Done" or "Cancel." Note: This method will end the processing of the page and immediately redirect the user back to the portal page.

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


SetCookie Method

HttpPortletResponse..::.SetCookie Method
HttpPortletResponse Class See Also Send Feedback
This method supports the .NET Framework infrastructure and is not intended to be used directly from your code. Updates an existing cookie in the cookie collection.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void SetCookie(
    HttpCookie cookie
)

Parameters

cookie
Type: System.Web..::.HttpCookie

Remarks

SetCookie(HttpCookie)

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


ToString Method

HttpPortletResponse..::.ToString Method
HttpPortletResponse Class See Also Send Feedback
Returns a String that represents the current Object.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string ToString()

Remarks

ToString()()()

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


TransmitFile Method

HttpPortletResponse..::.TransmitFile Method
HttpPortletResponse Class See Also Send Feedback
Writes the specified file directly to an HTTP response output stream without buffering it in memory.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void TransmitFile(
    string filename
)

Parameters

filename
Type: System..::.String

Remarks

TransmitFile(String)

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


Write Method

[image]

WebCenter Portlet API for .NET Library
HttpPortletResponse..::.Write Method
HttpPortletResponse Class See Also Send Feedback

Overload List

Name | Description
Write(Char) | Writes information to an HTTP output content stream.
Write(Object) | Writes information to an HTTP output content stream.
Write(String) | Writes information to an HTTP output content stream.
Write(array<Char>[]()[], Int32, Int32) | Writes information to an HTTP output content stream.

See Also

HttpPortletResponse Class
HttpPortletResponse Members
BEA.ALI.Web Namespace


Write Method (Char)

HttpPortletResponse..::.Write Method (Char)
HttpPortletResponse Class See Also Send Feedback
Writes information to an HTTP output content stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void Write(
    char ch
)

Parameters

ch
Type: System..::.Char

Remarks

Write(Char)

See Also

HttpPortletResponse Class
Write Overload
BEA.ALI.Web Namespace


Write Method (Object)

HttpPortletResponse..::.Write Method (Object)
HttpPortletResponse Class See Also Send Feedback
Writes information to an HTTP output content stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void Write(
    Object obj
)

Parameters

obj
Type: System..::.Object

Remarks

Write(Object)

See Also

HttpPortletResponse Class
Write Overload
BEA.ALI.Web Namespace


Write Method (String)

HttpPortletResponse..::.Write Method (String)
HttpPortletResponse Class See Also Send Feedback
Writes information to an HTTP output content stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void Write(
    string s
)

Parameters

s
Type: System..::.String

Remarks

Write(String)

See Also

HttpPortletResponse Class
Write Overload
BEA.ALI.Web Namespace


Write Method (Char[], Int32, Int32)

HttpPortletResponse..::.Write Method (array<Char>[]()[], Int32, Int32)
HttpPortletResponse Class See Also Send Feedback
Writes information to an HTTP output content stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void Write(
    char[] buffer,
    int index,
    int count
)

Parameters

buffer
Type: array< System..::.Char >[]()[]
index
Type: System..::.Int32
count
Type: System..::.Int32

Remarks

Write(array<Char>[]()[], Int32, Int32)

See Also

HttpPortletResponse Class
Write Overload
BEA.ALI.Web Namespace


WriteFile Method

[image]

WebCenter Portlet API for .NET Library
HttpPortletResponse..::.WriteFile Method
HttpPortletResponse Class See Also Send Feedback

Overload List

Name | Description
WriteFile(String) | Writes the specified file directly to an HTTP response output stream.
WriteFile(String, Boolean) | Writes the specified file directly to an HTTP response output stream.
WriteFile(IntPtr, Int64, Int64) | Writes the specified file directly to an HTTP response output stream.
WriteFile(String, Int64, Int64) | Writes the specified file directly to an HTTP response output stream.

See Also

HttpPortletResponse Class
HttpPortletResponse Members
BEA.ALI.Web Namespace


WriteFile Method (String)

HttpPortletResponse..::.WriteFile Method (String)
HttpPortletResponse Class See Also Send Feedback
Writes the specified file directly to an HTTP response output stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void WriteFile(
    string filename
)

Parameters

filename
Type: System..::.String

Remarks

WriteFile(String)

See Also

HttpPortletResponse Class
WriteFile Overload
BEA.ALI.Web Namespace


WriteFile Method (String, Boolean)

HttpPortletResponse..::.WriteFile Method (String, Boolean)
HttpPortletResponse Class See Also Send Feedback
Writes the specified file directly to an HTTP response output stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void WriteFile(
    string filename,
    bool readIntoMemory
)

Parameters

filename
Type: System..::.String
readIntoMemory
Type: System..::.Boolean

Remarks

WriteFile(String, Boolean)

See Also

HttpPortletResponse Class
WriteFile Overload
BEA.ALI.Web Namespace


WriteFile Method (IntPtr, Int64, Int64)

HttpPortletResponse..::.WriteFile Method (IntPtr, Int64, Int64)
HttpPortletResponse Class See Also Send Feedback
Writes the specified file directly to an HTTP response output stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void WriteFile(
    IntPtr fileHandle,
    long offset,
    long size
)

Parameters

fileHandle
Type: System..::.IntPtr
offset
Type: System..::.Int64
size
Type: System..::.Int64

Remarks

WriteFile(IntPtr, Int64, Int64)

See Also

HttpPortletResponse Class
WriteFile Overload
BEA.ALI.Web Namespace


WriteFile Method (String, Int64, Int64)

HttpPortletResponse..::.WriteFile Method (String, Int64, Int64)
HttpPortletResponse Class See Also Send Feedback
Writes the specified file directly to an HTTP response output stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void WriteFile(
    string filename,
    long offset,
    long size
)

Parameters

filename
Type: System..::.String
offset
Type: System..::.Int64
size
Type: System..::.Int64

Remarks

WriteFile(String, Int64, Int64)

See Also

HttpPortletResponse Class
WriteFile Overload
BEA.ALI.Web Namespace


WriteSubstitution Method

HttpPortletResponse..::.WriteSubstitution Method
HttpPortletResponse Class See Also Send Feedback
Allows insertion of response substitution blocks into the response, which allows dynamic generation of specified response regions for output cached responses.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void WriteSubstitution(
    HttpResponseSubstitutionCallback callback
)

Parameters

callback
Type: System.Web..::.HttpResponseSubstitutionCallback

Remarks

WriteSubstitution(HttpResponseSubstitutionCallback)

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


HttpPortletResponse Properties

[image]

WebCenter Portlet API for .NET Library
HttpPortletResponse Properties
HttpPortletResponse Class See Also Send Feedback

The HttpPortletResponse type exposes the following members.

Properties

Name | Description
Buffer | Gets or sets a value indicating whether to buffer output and send it after the entire response is finished processing.
BufferOutput | Gets or sets a value indicating whether to buffer output and send it after the entire page is finished processing.
Cache | Gets the caching policy (expiration time, privacy, vary clauses) of a web page.
CacheControl | Sets the Cache-Control HTTP header to Public or Private.
Charset | Gets or sets the HTTP character set of the output stream.
ContentEncoding | Gets or sets the HTTP character set of the output stream.
ContentType | Gets or sets the HTTP MIME type of the output stream.
Cookies | Gets the response cookie collection.
Expires | Gets or sets the number of minutes before a page cached on a browser expires. If the user returns to the same page before it expires, the cached version is displayed. Expires is provided for compatibility with previous versions of ASP.
ExpiresAbsolute | Gets or sets the absolute date and time at which to remove cached information from the cache. ExpiresAbsolute is provided for compatibility with previous versions of ASP.
Filter | Gets or sets a wrapping filter object used to modify the HTTP entity body before transmission.
HeaderEncoding | Gets or sets an Encoding object representing the encoding for the current header output stream.
IsClientConnected | Gets a value indicating whether the client is still connected to the server.
IsRequestBeingRedirected | Gets a Boolean value indicating whether the client is being transferred to a new location.
Output | Enables output of text to the outgoing HTTP response stream.
OutputStream | Enables binary output to the outgoing HTTP content body.
RedirectLocation | Gets or sets the value of the HTTP Location header.
Status | Sets the Status line that is returned to the client.
StatusCode | Gets or sets the HTTP status code of the output returned to the client.
StatusDescription | Gets or sets the HTTP status string of the output returned to the client.
SuppressContent | Gets or sets a value indicating whether to send HTTP content to the client.

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


Buffer Property

HttpPortletResponse..::.Buffer Property
HttpPortletResponse Class See Also Send Feedback
Gets or sets a value indicating whether to buffer output and send it after the entire response is finished processing.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool Buffer { get; set; }

Remarks

Buffer

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


BufferOutput Property

HttpPortletResponse..::.BufferOutput Property
HttpPortletResponse Class See Also Send Feedback
Gets or sets a value indicating whether to buffer output and send it after the entire page is finished processing.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool BufferOutput { get; set; }

Remarks

BufferOutput

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


Cache Property

HttpPortletResponse..::.Cache Property
HttpPortletResponse Class See Also Send Feedback
Gets the caching policy (expiration time, privacy, vary clauses) of a web page.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public HttpCachePolicy Cache { get; }

Remarks

Cache

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


CacheControl Property

HttpPortletResponse..::.CacheControl Property
HttpPortletResponse Class See Also Send Feedback
Sets the Cache-Control HTTP header to Public or Private.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string CacheControl { get; set; }

Remarks

CacheControl

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


Charset Property

HttpPortletResponse..::.Charset Property
HttpPortletResponse Class See Also Send Feedback
Gets or sets the HTTP character set of the output stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string Charset { get; set; }

Remarks

Charset

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


ContentEncoding Property

HttpPortletResponse..::.ContentEncoding Property
HttpPortletResponse Class See Also Send Feedback
Gets or sets the HTTP character set of the output stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Encoding ContentEncoding { get; set; }

Remarks

ContentEncoding

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


ContentType Property

HttpPortletResponse..::.ContentType Property
HttpPortletResponse Class See Also Send Feedback
Gets or sets the HTTP MIME type of the output stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string ContentType { get; set; }

Remarks

ContentType

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


Cookies Property

HttpPortletResponse..::.Cookies Property
HttpPortletResponse Class See Also Send Feedback
Gets the response cookie collection.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public HttpCookieCollection Cookies { get; }

Remarks

Cookies

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


Expires Property

HttpPortletResponse..::.Expires Property
HttpPortletResponse Class See Also Send Feedback
Gets or sets the number of minutes before a page cached on a browser expires. If the user returns to the same page before it expires, the cached version is displayed. Expires is provided for compatibility with previous versions of ASP.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public int Expires { get; set; }

Remarks

Expires

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


ExpiresAbsolute Property

HttpPortletResponse..::.ExpiresAbsolute Property
HttpPortletResponse Class See Also Send Feedback
Gets or sets the absolute date and time at which to remove cached information from the cache. ExpiresAbsolute is provided for compatibility with previous versions of ASP.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public DateTime ExpiresAbsolute { get; set; }

Remarks

ExpiresAbsolute

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


Filter Property

HttpPortletResponse..::.Filter Property
HttpPortletResponse Class See Also Send Feedback
Gets or sets a wrapping filter object used to modify the HTTP entity body before transmission.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Stream Filter { get; set; }

Remarks

Filter

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


HeaderEncoding Property

HttpPortletResponse..::.HeaderEncoding Property
HttpPortletResponse Class See Also Send Feedback
Gets or sets an Encoding object representing the encoding for the current header output stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Encoding HeaderEncoding { get; set; }

Remarks

HeaderEncoding

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


IsClientConnected Property

HttpPortletResponse..::.IsClientConnected Property
HttpPortletResponse Class See Also Send Feedback
Gets a value indicating whether the client is still connected to the server.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool IsClientConnected { get; }

Remarks

IsClientConnected

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


IsRequestBeingRedirected Property

HttpPortletResponse..::.IsRequestBeingRedirected Property
HttpPortletResponse Class See Also Send Feedback
Gets a Boolean value indicating whether the client is being transferred to a new location.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool IsRequestBeingRedirected { get; }

Remarks

IsRequestBeingRedirected

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


Output Property

HttpPortletResponse..::.Output Property
HttpPortletResponse Class See Also Send Feedback
Enables output of text to the outgoing HTTP response stream.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public TextWriter Output { get; }

Remarks

Output

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


OutputStream Property

HttpPortletResponse..::.OutputStream Property
HttpPortletResponse Class See Also Send Feedback
Enables binary output to the outgoing HTTP content body.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Stream OutputStream { get; }

Remarks

OutputStream

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


RedirectLocation Property

HttpPortletResponse..::.RedirectLocation Property
HttpPortletResponse Class See Also Send Feedback
Gets or sets the value of the HTTP Location header.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string RedirectLocation { get; set; }

Remarks

RedirectLocation

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


Status Property

HttpPortletResponse..::.Status Property
HttpPortletResponse Class See Also Send Feedback
Sets the Status line that is returned to the client.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string Status { get; set; }

Remarks

Status

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


StatusCode Property

HttpPortletResponse..::.StatusCode Property
HttpPortletResponse Class See Also Send Feedback
Gets or sets the HTTP status code of the output returned to the client.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public int StatusCode { get; set; }

Remarks

StatusCode

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


StatusDescription Property

HttpPortletResponse..::.StatusDescription Property
HttpPortletResponse Class See Also Send Feedback
Gets or sets the HTTP status string of the output returned to the client.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string StatusDescription { get; set; }

Remarks

StatusDescription

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


SuppressContent Property

HttpPortletResponse..::.SuppressContent Property
HttpPortletResponse Class See Also Send Feedback
Gets or sets a value indicating whether to send HTTP content to the client.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool SuppressContent { get; set; }

Remarks

SuppressContent

See Also

HttpPortletResponse Class
BEA.ALI.Web Namespace


PortletMode Enumeration

PortletMode Enumeration
See Also Send Feedback
PortletMode is an enumerated type that identifies the mode the portal is using to generate Portlet content.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public enum PortletMode

Members

Member name | Description
Portlet | Used for the normal Portlet view in a portal page.
Preview | Used when a user selects to preview Portlet content before adding it to a portal page.
Summary | Used for devices with small screens to provide a 10-character summary of Portlet content.
SyndicatedPortlet | Used for Portlets that are being run asynchronously.
SyndicatedPreview | Used for Portlets that are being previewed asynchronously.
SyndicatedSummary | Used for Portlets that are generating a 10-character summary asynchronously.

See Also

BEA.ALI.Web Namespace


RemoteSessionAttribute Class

RemoteSessionAttribute Class
Members Example See Also Send Feedback
Place on an ALIPortletPage class to allow RemoteAPISession to establish a connection when debugging the page outside WCI.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false)]
public class RemoteSessionAttribute : Attribute

Remarks

By default the RemoteAPISession property establishes a session by collecting information from HTTP headers sent by the WCI portal. When debugging that information is not available, but pages will still need the session to be properly debugged.

Examples

CopyC#
[RemoteSession("http://server/ptapi/services/QueryInterfaceAPI", "administrator", "")]
public class MyPortlet : BEA.ALI.Web.UI.ALIPortletPage
{
    ...

Inheritance Hierarchy

System..::.Object
System..::.Attribute
BEA.ALI.Web..::.RemoteSessionAttribute

See Also

RemoteSessionAttribute Members
BEA.ALI.Web Namespace


RemoteSessionAttribute Members

[image]

WebCenter Portlet API for .NET Library
RemoteSessionAttribute Members
RemoteSessionAttribute Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The RemoteSessionAttribute type exposes the following members.

Constructors

Name | Description
RemoteSessionAttribute | Specifies the name of an administrative preference for the page.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name | The user name to log in with.
Password | The user's login password.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
URL | The URL of the WS-Server.

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

RemoteSessionAttribute Class
BEA.ALI.Web Namespace


RemoteSessionAttribute Constructor

RemoteSessionAttribute Constructor
RemoteSessionAttribute Class See Also Send Feedback
Specifies the name of an administrative preference for the page.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public RemoteSessionAttribute(
    string wsserverUrl,
    string loginName,
    string loginPassword
)

Parameters

wsserverUrl
Type: System..::.String
The URL of the WS-Server that the remote session will be established with. Typically the URL takes the form of "http://server:11905/ptapi/services/QueryInterfaceAPI";
loginName
Type: System..::.String
The name of the user that establishes the permissions of the remote session.
loginPassword
Type: System..::.String
The password for the user.

See Also

RemoteSessionAttribute Class
BEA.ALI.Web Namespace


RemoteSessionAttribute Properties

[image]

WebCenter Portlet API for .NET Library
RemoteSessionAttribute Properties
RemoteSessionAttribute Class See Also Send Feedback

The RemoteSessionAttribute type exposes the following members.

Properties

Name | Description
Name | The user name to log in with.
Password | The user's login password.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
URL | The URL of the WS-Server.

See Also

RemoteSessionAttribute Class
BEA.ALI.Web Namespace


Name Property

RemoteSessionAttribute..::.Name Property
RemoteSessionAttribute Class See Also Send Feedback
The user name to log in with.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string Name { get; set; }

See Also

RemoteSessionAttribute Class
BEA.ALI.Web Namespace


Password Property

RemoteSessionAttribute..::.Password Property
RemoteSessionAttribute Class See Also Send Feedback
The user's login password.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string Password { get; set; }

See Also

RemoteSessionAttribute Class
BEA.ALI.Web Namespace


URL Property

RemoteSessionAttribute..::.URL Property
RemoteSessionAttribute Class See Also Send Feedback
The URL of the WS-Server.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string URL { get; set; }

See Also

RemoteSessionAttribute Class
BEA.ALI.Web Namespace


SettingType Enumeration

SettingType Enumeration
See Also Send Feedback
An enumeration of the different types of settings that can be used by a Portlet.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public enum SettingType

Members

Member name | Description
Admin | Apply to one particular Portlet, but to all users and Communities that access the Portlet.
Community | Apply to all Portlets in the current Community, and they are shared for all users of that Community. Generally, Community settings are set by a Community manager.
CommunityPortlet | Apply to a particular Portlet, but are shared by all users of the current Community. Generally, CommunityPortlet settings are set by a Community manager.
Portlet | Apply to the current Portlet and the current user.
Session | Apply to one particular user just as User settings do, but are only persisted for the duration of the user's session.
User | Apply to one particular user, but apply to all Portlets accessed by the user. The administrator must configure the portal to send User settings to a Portlet.
UserInfo | Read-only settings that are generally pulled from third party user repositories. The keys for the default UserInfo settings, such as FullName and EMail, are available in the UserInfo class.

See Also

BEA.ALI.Web Namespace


UserInterface Enumeration

UserInterface Enumeration
See Also Send Feedback
UserInterface is an enumeration that describes the different kinds of user interfaces (e.g., phone, PDA) that can be used in the portal.

Namespace: BEA.ALI.Web
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public enum UserInterface

Members

Member name | Description
Accessible | Indicates that the user request is coming from the WCI Portal for People with Disabilities. The Portlet should comply with guidelines that make HTML markup accessible to people with disabilities.
HDML | Indicates that the user request is using HDML (Handheld Device Markup Language), a user interface markup language for older mobile phones.
PDA | Indicates that the user request is coming from a PDA (Personal Data Assistant), a class of devices that have more functionality than a phone but less than a laptop. These devices have browsers that can accept basic HTML without scripts or DHTML.
Standard | Indicates that the request is coming from a standard web browser that uses the HTML interface that comes with the portal.
WML | Indicates that the user request is using WML (Wireless Markup Language), part of the WAP standard supported by browsers on newer phones.

See Also

BEA.ALI.Web Namespace


BEA.ALI.Web.UI Namespace

BEA.ALI.Web.UI Namespace
Send Feedback
The BEA.ALI.Web.UI namespace contains base pages used to build ASP.NET portlets for WebCenter Interaction (WCI).

Classes

Class | Description
AbstractBasePage | The AbstractBasePage provides the base class for all of the Portlet API Pages. It creates the IDK Context, Request and Response objects, and provides property access to the hybrid Request and Response objects. Developers should never extend this class directly. Instead, extend either WSRPPortletPage or ALIPortletPage.
ALIBasePage | The ALIBasePage provides the base class for all the Portlet API Pages for use with WCI. It creates the IDK User object, and provides property access to the hybrid User. Property access is provided for information sent via headers that was previously avaliable through the IPortletRequest and IPortletContext interfaces in the IDK. It also defines the PortletPreferenceAttribute, AdminPreferenceAttribute, CommunityPreferenceAttribute, CommunityPortletPreferenceAttribute, SessionPreferenceAttribute, and UserPreferenceAttribute which can be used to tag fields whose value comes from a preference sent by the WCI portal. Developers should never extend this class directly. Instead extend ALIPortletPage or ALIPreferencePage.
ALIBasePage..::.AdminPreferenceAttribute | Place on a BEA page field to mark it as an admin preference value.
ALIBasePage..::.CommunityPortletPreferenceAttribute | Place on a BEA page field to mark it as a community portlet preference value.
ALIBasePage..::.CommunityPreferenceAttribute | Place on a BEA page field to mark it as a community preference value.
ALIBasePage..::.PortletPreferenceAttribute | Place on a BEA page field to mark it as a portlet preference value.
ALIBasePage..::.SessionPreferenceAttribute | Place on a BEA page field to mark it as a session preference value.
ALIBasePage..::.UserPreferenceAttribute | Place on a BEA page field to mark it as a user preference value.
ALIPortletPage | ALIPortletPage is the base class to extend for all portlet content pages built for use in an WCI Portal. In addition to all of the property information made available in the ALIBasePage the ALIPortletPage automatically adds portlet <div> tags around the content when it is displayed in a WCI Portal.
ALIPortletUser | ALIPortletUser implements IPrincipal and adds additional User information that comes specifically from WCI.
ALIPreferencePage | ALIPreferencePage is the base class to extend for all portlet preference pages built for use in WCI. In addition to all of the property information made available in the ALIBasePage the ALIPreferencePage automatically adds a title banner to the top of the page, consistent with the WCI look and feel. The banner includes functional Finish and Cancel buttons for updating the preferences on the page.
WSRPBasePage | The WSRPBasePage provides the base class for all of the Portlet API WSRP Pages for use with a WSRP Portal. It creates the IDK User object, and provides property access to the hybrid User. Developers should never extend this class directly. Instead extend WSRPPortletPage.
WSRPBasePage..::.PortletStateValueAttribute | Obsolete. Place on a BEA page field to mark it as a portlet state value.
WSRPPortletPage | Obsolete. WSRPPortletPage is the base class to extend for all portlet content pages built for use in a WLP Portal.
WSRPPortletUser | WSRPPortletUser implements IPrincipal and adds additional User information that comes specifically from a WSRP Consumer. portal.


AbstractBasePage Class

AbstractBasePage Class
Members See Also Send Feedback

The AbstractBasePage provides the base class for all of the Portlet API Pages. It creates the IDK Context, Request and Response objects, and provides property access to the hybrid Request and Response objects.

Developers should never extend this class directly. Instead, extend either WSRPPortletPage or ALIPortletPage.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public abstract class AbstractBasePage : Page

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.Page
BEA.ALI.Web.UI..::.AbstractBasePage
BEA.ALI.Web.UI..::.ALIBasePage
BEA.ALI.Web.UI..::.WSRPBasePage

See Also

AbstractBasePage Members
BEA.ALI.Web.UI Namespace


AbstractBasePage Members

[image]

WebCenter Portlet API for .NET Library
AbstractBasePage Members
AbstractBasePage Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The AbstractBasePage type exposes the following members.

Constructors

Name | Description
AbstractBasePage | Initializes a new instance of the AbstractBasePage class.

Methods

Name | Description
AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddOnPreRenderCompleteAsync | Overloaded.
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Construct | Performs design-time logic. (Inherited from TemplateControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Eval | Overloaded.
ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetGlobalResourceObject | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLocalResourceObject | Overloaded.
GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackEventReference | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
InitOutputCache | Overloaded.
IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
LoadControl | Overloaded.
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnError | Raises the Error event. (Inherited from TemplateControl.)
OnInit | Raises the Init event to initialize the page. (Overrides Page ..::. OnInit(EventArgs).)
OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
OnLoad | Raises the Load event. (Inherited from Control.)
OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
OnPreRender | Raises the PreRender event. (Inherited from Control.)
OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
OnUnload | Raises the Unload event. (Inherited from Control.)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
ParseControl | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
ReadStringResource | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderControl | Overloaded.
RenderErrorPage | Renders an error page when an unhandled exception is encountered.
RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetFocus | Overloaded.
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Validate | Overloaded.
VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
XPath | Overloaded.
XPathSelect | Overloaded.

Fields

Name | Description
m_log | The WCI logger class to trace messages within this class.
m_portletContext | This is the IDK context. We store it to get values from it if the user requests them.
m_portletRequest | The IDK portlet request.
m_portletResponse | The IDK portlet response.
m_portletUser | The IDK portlet user.

Properties

Name | Description
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
EnableEventValidation | (Inherited from Page.)
EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Form | Gets the HTML form for the page. (Inherited from Page.)
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Items | Gets a list of objects stored in the page context. (Inherited from Page.)
LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Title | Gets or sets the title for the page. (Inherited from Page.)
Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
User | Gets information about the user making the page request. (Inherited from Page.)
Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)

Events

Name | Description
AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
PreLoad | Occurs before the page Load event. (Inherited from Page.)
PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
IFilterResolutionService..::.CompareFilters | (Inherited from TemplateControl.)
IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
IFilterResolutionService..::.EvaluateFilter | (Inherited from TemplateControl.)
IExpressionsAccessor..::.Expressions | (Inherited from Control.)
IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)
IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

AbstractBasePage Class
BEA.ALI.Web.UI Namespace


AbstractBasePage Constructor

AbstractBasePage Constructor
AbstractBasePage Class See Also Send Feedback
Initializes a new instance of the AbstractBasePage class.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public AbstractBasePage()

See Also

AbstractBasePage Class
BEA.ALI.Web.UI Namespace


AbstractBasePage Fields

[image]

WebCenter Portlet API for .NET Library
AbstractBasePage Fields
AbstractBasePage Class See Also Send Feedback

The AbstractBasePage type exposes the following members.

Fields

Name | Description
m_log | The WCI logger class to trace messages within this class.
m_portletContext | This is the IDK context. We store it to get values from it if the user requests them.
m_portletRequest | The IDK portlet request.
m_portletResponse | The IDK portlet response.
m_portletUser | The IDK portlet user.

See Also

AbstractBasePage Class
BEA.ALI.Web.UI Namespace


m_log Field

AbstractBasePage..::.m_log Field
AbstractBasePage Class See Also Send Feedback
The WCI logger class to trace messages within this class.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected ILogger m_log

See Also

AbstractBasePage Class
BEA.ALI.Web.UI Namespace


m_portletContext Field

AbstractBasePage..::.m_portletContext Field
AbstractBasePage Class See Also Send Feedback
This is the IDK context. We store it to get values from it if the user requests them.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected IPortletContext m_portletContext

See Also

AbstractBasePage Class
BEA.ALI.Web.UI Namespace


m_portletRequest Field

AbstractBasePage..::.m_portletRequest Field
AbstractBasePage Class See Also Send Feedback
The IDK portlet request.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected IPortletRequest m_portletRequest

See Also

AbstractBasePage Class
BEA.ALI.Web.UI Namespace


m_portletResponse Field

AbstractBasePage..::.m_portletResponse Field
AbstractBasePage Class See Also Send Feedback
The IDK portlet response.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected IPortletResponse m_portletResponse

See Also

AbstractBasePage Class
BEA.ALI.Web.UI Namespace


m_portletUser Field

AbstractBasePage..::.m_portletUser Field
AbstractBasePage Class See Also Send Feedback
The IDK portlet user.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected IPortletUser m_portletUser

See Also

AbstractBasePage Class
BEA.ALI.Web.UI Namespace


AbstractBasePage Methods

[image]

WebCenter Portlet API for .NET Library
AbstractBasePage Methods
AbstractBasePage Class See Also Send Feedback

The AbstractBasePage type exposes the following members.

Methods

Name | Description
AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddOnPreRenderCompleteAsync | Overloaded.
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Construct | Performs design-time logic. (Inherited from TemplateControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Eval | Overloaded.
ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetGlobalResourceObject | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLocalResourceObject | Overloaded.
GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackEventReference | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
InitOutputCache | Overloaded.
IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
LoadControl | Overloaded.
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnError | Raises the Error event. (Inherited from TemplateControl.)
OnInit | Raises the Init event to initialize the page. (Overrides Page ..::. OnInit(EventArgs).)
OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
OnLoad | Raises the Load event. (Inherited from Control.)
OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
OnPreRender | Raises the PreRender event. (Inherited from Control.)
OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
OnUnload | Raises the Unload event. (Inherited from Control.)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
ParseControl | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
ReadStringResource | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderControl | Overloaded.
RenderErrorPage | Renders an error page when an unhandled exception is encountered.
RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetFocus | Overloaded.
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Validate | Overloaded.
VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
XPath | Overloaded.
XPathSelect | Overloaded.

Explicit Interface Implementations

Name | Description
IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
IFilterResolutionService..::.CompareFilters | (Inherited from TemplateControl.)
IFilterResolutionService..::.EvaluateFilter | (Inherited from TemplateControl.)
IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)

See Also

AbstractBasePage Class
BEA.ALI.Web.UI Namespace


AddOnPreRenderCompleteAsync Method

[image]

WebCenter Portlet API for .NET Library
AbstractBasePage..::.AddOnPreRenderCompleteAsync Method
AbstractBasePage Class See Also Send Feedback

Overload List

Name | Description
AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)

See Also

AbstractBasePage Class
AbstractBasePage Members
BEA.ALI.Web.UI Namespace


DataBind Method

[image]

WebCenter Portlet API for .NET Library
AbstractBasePage..::.DataBind Method
AbstractBasePage Class See Also Send Feedback

Overload List

Name | Description
DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

AbstractBasePage Class
AbstractBasePage Members
BEA.ALI.Web.UI Namespace


Eval Method

[image]

WebCenter Portlet API for .NET Library
AbstractBasePage..::.Eval Method
AbstractBasePage Class See Also Send Feedback

Overload List

Name | Description
Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)

See Also

AbstractBasePage Class
AbstractBasePage Members
BEA.ALI.Web.UI Namespace


FindControl Method

[image]

WebCenter Portlet API for .NET Library
AbstractBasePage..::.FindControl Method
AbstractBasePage Class See Also Send Feedback

Overload List

Name | Description
FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)

See Also

AbstractBasePage Class
AbstractBasePage Members
BEA.ALI.Web.UI Namespace


GetGlobalResourceObject Method

[image]

WebCenter Portlet API for .NET Library
AbstractBasePage..::.GetGlobalResourceObject Method
AbstractBasePage Class See Also Send Feedback

Overload List

Name | Description
GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)

See Also

AbstractBasePage Class
AbstractBasePage Members
BEA.ALI.Web.UI Namespace


GetLocalResourceObject Method

[image]

WebCenter Portlet API for .NET Library
AbstractBasePage..::.GetLocalResourceObject Method
AbstractBasePage Class See Also Send Feedback

Overload List

Name | Description
GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)

See Also

AbstractBasePage Class
AbstractBasePage Members
BEA.ALI.Web.UI Namespace


GetPostBackEventReference Method

[image]

WebCenter Portlet API for .NET Library
AbstractBasePage..::.GetPostBackEventReference Method
AbstractBasePage Class See Also Send Feedback

Overload List

Name | Description
GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)

See Also

AbstractBasePage Class
AbstractBasePage Members
BEA.ALI.Web.UI Namespace


InitOutputCache Method

[image]

WebCenter Portlet API for .NET Library
AbstractBasePage..::.InitOutputCache Method
AbstractBasePage Class See Also Send Feedback

Overload List

Name | Description
InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)

See Also

AbstractBasePage Class
AbstractBasePage Members
BEA.ALI.Web.UI Namespace


LoadControl Method

[image]

WebCenter Portlet API for .NET Library
AbstractBasePage..::.LoadControl Method
AbstractBasePage Class See Also Send Feedback

Overload List

Name | Description
LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)

See Also

AbstractBasePage Class
AbstractBasePage Members
BEA.ALI.Web.UI Namespace


OnInit Method

AbstractBasePage..::.OnInit Method
AbstractBasePage Class See Also Send Feedback
Raises the Init event to initialize the page.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected override void OnInit(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs

Remarks

OnInit(EventArgs)

See Also

AbstractBasePage Class
BEA.ALI.Web.UI Namespace


RenderControl Method

[image]

WebCenter Portlet API for .NET Library
AbstractBasePage..::.RenderControl Method
AbstractBasePage Class See Also Send Feedback

Overload List

Name | Description
RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

AbstractBasePage Class
AbstractBasePage Members
BEA.ALI.Web.UI Namespace


RenderErrorPage Method

AbstractBasePage..::.RenderErrorPage Method
AbstractBasePage Class See Also Send Feedback
Renders an error page when an unhandled exception is encountered.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected string RenderErrorPage(
    Exception exception,
    string uniqueIdentifier,
    string additionalInfo
)

Parameters

exception
Type: System..::.Exception
This is the unhandled exception encountered while processing the page.
uniqueIdentifier
Type: System..::.String
A unique identifier for the Portlet to use for individuating form elements in the error page.
additionalInfo
Type: System..::.String
Additional information about the Portlet to display in the error message.

Return Value

The HTML to display for the error.

Remarks

For this to work, set the "customErrors" element in your application's Web.config to "RemoteOnly" (or "On", but this is not advantageous for debugging because you'll lose valuable detailed ASP.NET error information). If you set a custom error page, either through your derived page setting its ErrorPage property or through your Web.config's customErrors element, this method will not get called. Instead the request will be redirected to the custom error page you defined.

See Also

AbstractBasePage Class
BEA.ALI.Web.UI Namespace


SetFocus Method

[image]

WebCenter Portlet API for .NET Library
AbstractBasePage..::.SetFocus Method
AbstractBasePage Class See Also Send Feedback

Overload List

Name | Description
SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)

See Also

AbstractBasePage Class
AbstractBasePage Members
BEA.ALI.Web.UI Namespace


Validate Method

[image]

WebCenter Portlet API for .NET Library
AbstractBasePage..::.Validate Method
AbstractBasePage Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)

See Also

AbstractBasePage Class
AbstractBasePage Members
BEA.ALI.Web.UI Namespace


XPath Method

[image]

WebCenter Portlet API for .NET Library
AbstractBasePage..::.XPath Method
AbstractBasePage Class See Also Send Feedback

Overload List

Name | Description
XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)

See Also

AbstractBasePage Class
AbstractBasePage Members
BEA.ALI.Web.UI Namespace


XPathSelect Method

[image]

WebCenter Portlet API for .NET Library
AbstractBasePage..::.XPathSelect Method
AbstractBasePage Class See Also Send Feedback

Overload List

Name | Description
XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

See Also

AbstractBasePage Class
AbstractBasePage Members
BEA.ALI.Web.UI Namespace


ALIBasePage Class

ALIBasePage Class
Members See Also Send Feedback

The ALIBasePage provides the base class for all the Portlet API Pages for use with WCI. It creates the IDK User object, and provides property access to the hybrid User.

Property access is provided for information sent via headers that was previously avaliable through the IPortletRequest and IPortletContext interfaces in the IDK.

It also defines the PortletPreferenceAttribute, AdminPreferenceAttribute, CommunityPreferenceAttribute, CommunityPortletPreferenceAttribute, SessionPreferenceAttribute, and UserPreferenceAttribute which can be used to tag fields whose value comes from a preference sent by the WCI portal.

Developers should never extend this class directly. Instead extend ALIPortletPage or ALIPreferencePage.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public abstract class ALIBasePage : AbstractBasePage

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.Page
BEA.ALI.Web.UI..::.AbstractBasePage
BEA.ALI.Web.UI..::.ALIBasePage
BEA.ALI.Web.UI..::.ALIPortletPage
BEA.ALI.Web.UI..::.ALIPreferencePage

See Also

ALIBasePage Members
BEA.ALI.Web.UI Namespace


ALIBasePage Members

[image]

WebCenter Portlet API for .NET Library
ALIBasePage Members
ALIBasePage Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The ALIBasePage type exposes the following members.

Constructors

Name | Description
ALIBasePage | Constructs a new ALIBasePage.

Methods

Name | Description
AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddOnPreRenderCompleteAsync | Overloaded.
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Construct | Performs design-time logic. (Inherited from TemplateControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Eval | Overloaded.
ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetGlobalResourceObject | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLocalResourceObject | Overloaded.
GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackEventReference | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
InitOutputCache | Overloaded.
IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
LoadControl | Overloaded.
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnError | Capture ASP.NET page errors and route them through our custom error reporting handler. (Overrides TemplateControl ..::. OnError(EventArgs).)
OnInit | Called each time this page is hit by a user. Initializes the page for use. (Overrides AbstractBasePage ..::. OnInit(EventArgs).)
OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
OnLoad | Raises the Load event. (Inherited from Control.)
OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
OnPreRender | Raises the PreRender event. (Inherited from Control.)
OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
OnUnload | Raises the Unload event. (Inherited from Control.)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
ParseControl | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
ReadStringResource | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderControl | Overloaded.
RenderErrorPage | Renders an error page when an unhandled exception is encountered. (Inherited from AbstractBasePage.)
RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetFocus | Overloaded.
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Validate | Overloaded.
VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
XPath | Overloaded.
XPathSelect | Overloaded.

Fields

Name | Description
AdminPreferences | Indexer of administrative preferences.
CommunityPortletPreferences | Indexer of community portlet preferences.
CommunityPreferences | Indexer of community preferences.
m_httpRequest | ASP.NET's Request object.
m_httpResponse | ASP.NET's Response object.
m_log | The WCI logger class to trace messages within this class. (Inherited from AbstractBasePage.)
m_portletContext | This is the IDK context. We store it to get values from it if the user requests them. (Inherited from AbstractBasePage.)
m_portletRequest | The IDK portlet request. (Inherited from AbstractBasePage.)
m_portletResponse | The IDK portlet response. (Inherited from AbstractBasePage.)
m_portletUser | The IDK portlet user. (Inherited from AbstractBasePage.)
PortletPreferences | Indexer of portlet preferences.
SessionPreferences | Indexer of session preferences.
UserPreferences | Indexer of user preferences.

Properties

Name | Description
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
AggregationMode | Gets the current AggregationMode for the Portlet. The aggregation mode indicates whether the Portlet is alone on the page or displayed with other Portlets.
Alignment | Gets the alignment of the Portlet.
Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClassID | Gets the class ID.
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
CommunityID | Gets the ID of the Community in which the Portlet is currently displayed.
ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
CredentialProvider | Gets the ICredentialProvider, an interface for retrieving the username and password for a backend application that were sent to the Portlet in headers.
CredentialSetter | Gets the ICredentialSetter, an interface for encrypting and setting the username and password for a backend application on a PortletResponse.
Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
EnableEventValidation | (Inherited from Page.)
EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Form | Gets the HTML form for the page. (Inherited from Page.)
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
HostedDisplayMode | Sets the requested display mode. This property cannot be read, as it is not sent to the Portlet in the request. It is set by the Portlet and sent back in the response. This method is used for pages associated with a Portlet (i.e., preference pages).
HostPageURI | Gets the URI for the portal page in which the Portlet is currently displayed.
HostPageURLQueryString | Gets the query string portion of the URL that was used to access this portal's hosting page.
HttpRequest | Gets the .Net HttpRequest for the requested Page.
HttpResponse | Gets the .Net HttpResponse for the requested Page.
ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
ImageServerURI | Gets the URI for the WCI Image Service.
IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Items | Gets a list of objects stored in the page context. (Inherited from Page.)
LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
PageID | Gets the ID of the portal page on which the Portlet is currently displayed.
PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
PortalUUID | Gets the portal UUID.
PortletID | Gets the Portlet ID for the current Portlet.
PortletMode | Gets a PortletMode object to tell the client what mode the Portlet is running in. The Portlet mode indicates whether the Portlet should display standard content or a summary for small-screened mobile devices. The mode also indicates if the Portlet is syndicated (running asynchronously).
PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
ProtocolVersion | Gets the current version of the protocol being used by the portal to communicate with this Portlet. 1.2 indicates a 5.x ALI Portal, 1.3 indicates a 6.x ALI Portal, and 1.4 indicates an Ensemble 1.0 proxy server.
RemoteAPIEndpoint | Gets the remote API endpoint, or null if the Portlet is run as a job. The remote API endpoint can be used to access the portal's remote SOAP API. To instantiate an IRemoteSession object, use RemotePortalSession.
RemotePortalSession | Gets the IRemoteSession initialized with a login token and endpoint URL sent by the portal. Because it is using a login token, the Remote Session will have the same security context in the portal as the user of the Portlet. If you apply a RemoteSessionAttribute to a Portlet that extends ALIBasePage then when running outside of the portal the values specified in the Attribute will be used for creating a RemotePortalSession.
Request | Gets the BEA.ALI.Web.HttpPortletRequest for the requested Page.
Response | Gets the BEA.ALI.Web.HttpPortletResponse object associated with the BEA.ALI.Web.UI.BasePage. This allows you to send HTTP response data to a client and contains information about that response.
ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
ReturnURI | Gets the URI for the portal page to return to when done.
Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
StylesheetURI | Gets the URI for the stylesheet currently being used by the portal user.
SubPortalID | Gets the ID of the subportal that the accessing user belongs to.
SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Title | Sets the title to be displayed for the Portlet. This property cannot be read, as it is not sent to the Portlet in the request. It is set by the Portlet and sent back in the response.
Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
User | Gets the PortletUser object for the user requesting the page.
UserInterface | Gets a UserInterface object to tell the client what type of device is being used to browse the portal (e.g., phone, PDA, standard web browser).
Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)

Events

Name | Description
AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
PreLoad | Occurs before the page Load event. (Inherited from Page.)
PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
IFilterResolutionService..::.CompareFilters | (Inherited from TemplateControl.)
IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
IFilterResolutionService..::.EvaluateFilter | (Inherited from TemplateControl.)
IExpressionsAccessor..::.Expressions | (Inherited from Control.)
IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)
IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


ALIBasePage Constructor

ALIBasePage Constructor
ALIBasePage Class See Also Send Feedback
Constructs a new ALIBasePage.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public ALIBasePage()

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


ALIBasePage Fields

[image]

WebCenter Portlet API for .NET Library
ALIBasePage Fields
ALIBasePage Class See Also Send Feedback

The ALIBasePage type exposes the following members.

Fields

Name | Description
AdminPreferences | Indexer of administrative preferences.
CommunityPortletPreferences | Indexer of community portlet preferences.
CommunityPreferences | Indexer of community preferences.
m_httpRequest | ASP.NET's Request object.
m_httpResponse | ASP.NET's Response object.
m_log | The WCI logger class to trace messages within this class. (Inherited from AbstractBasePage.)
m_portletContext | This is the IDK context. We store it to get values from it if the user requests them. (Inherited from AbstractBasePage.)
m_portletRequest | The IDK portlet request. (Inherited from AbstractBasePage.)
m_portletResponse | The IDK portlet response. (Inherited from AbstractBasePage.)
m_portletUser | The IDK portlet user. (Inherited from AbstractBasePage.)
PortletPreferences | Indexer of portlet preferences.
SessionPreferences | Indexer of session preferences.
UserPreferences | Indexer of user preferences.

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


AdminPreferences Field

ALIBasePage..::.AdminPreferences Field
ALIBasePage Class See Also Send Feedback
Indexer of administrative preferences.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public readonly PreferenceCollection AdminPreferences

Remarks

Administrative preferences are specific to a portlet object. Any user can see them, but they can only be set by the administrator in the Portlet Editor in WCI administration.

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


CommunityPortletPreferences Field

ALIBasePage..::.CommunityPortletPreferences Field
ALIBasePage Class See Also Send Feedback
Indexer of community portlet preferences.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public readonly PreferenceCollection CommunityPortletPreferences

Remarks

Community portlet preferences are specific to a given portlet within a Community. Any user can see them. The same Portlet placed on a different Community would not be able to access these preferences. Community portlet preferences can be adjusted by Community administrators. If you try to use community portlet preferences outside of a Community (i.e. on a My Page) an exception will be thrown. To verify the Portlet is on a Community page, use the IsInCommunity property.

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


CommunityPreferences Field

ALIBasePage..::.CommunityPreferences Field
ALIBasePage Class See Also Send Feedback
Indexer of community preferences.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public readonly PreferenceCollection CommunityPreferences

Remarks

Community preferences are specific to an entire Community. All the portlets and users in the Community have access to these preferences. If you try to use community preferences outside of a community (i.e. on a My Page) an exception will be thrown. To verify the Portlet is on a Community page, use the IsInCommunity property. Community preferences can be adjusted by community administrators. If you only want one portlet in the Community to have access to the preferences, use community portlet preferences.

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


m_httpRequest Field

ALIBasePage..::.m_httpRequest Field
ALIBasePage Class See Also Send Feedback
ASP.NET's Request object.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected HttpRequest m_httpRequest

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


m_httpResponse Field

ALIBasePage..::.m_httpResponse Field
ALIBasePage Class See Also Send Feedback
ASP.NET's Response object.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected HttpResponse m_httpResponse

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


PortletPreferences Field

ALIBasePage..::.PortletPreferences Field
ALIBasePage Class See Also Send Feedback
Indexer of portlet preferences.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public readonly PreferenceCollection PortletPreferences

Remarks

Portlet preferences are specific to a given user and a single Portlet object. Many Portlet objects can be created from the same Portlet Web Service object; each will have unique portlet preferences for a given user. Portlet preferences can be adjusted by anyone.

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


SessionPreferences Field

ALIBasePage..::.SessionPreferences Field
ALIBasePage Class See Also Send Feedback
Indexer of session preferences.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public readonly PreferenceCollection SessionPreferences

Remarks

Session preferences apply to one particular user like User settings, but are only persisted for the duration of the user's browser session. Session preferences can be used by Portlets to communicate with other portlets without making a round trip to the portal database. Session preferences are supported in ALI version 6.0 and above.

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


UserPreferences Field

ALIBasePage..::.UserPreferences Field
ALIBasePage Class See Also Send Feedback
Indexer of user preferences.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public readonly PreferenceCollection UserPreferences

Remarks

User preferences are specific to a given user. User preferences are shared by all portlets that the user accesses. User preferences can be adjusted by the user only.

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


ALIBasePage Methods

[image]

WebCenter Portlet API for .NET Library
ALIBasePage Methods
ALIBasePage Class See Also Send Feedback

The ALIBasePage type exposes the following members.

Methods

Name | Description
AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddOnPreRenderCompleteAsync | Overloaded.
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Construct | Performs design-time logic. (Inherited from TemplateControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Eval | Overloaded.
ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetGlobalResourceObject | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLocalResourceObject | Overloaded.
GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackEventReference | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
InitOutputCache | Overloaded.
IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
LoadControl | Overloaded.
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnError | Capture ASP.NET page errors and route them through our custom error reporting handler. (Overrides TemplateControl ..::. OnError(EventArgs).)
OnInit | Called each time this page is hit by a user. Initializes the page for use. (Overrides AbstractBasePage ..::. OnInit(EventArgs).)
OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
OnLoad | Raises the Load event. (Inherited from Control.)
OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
OnPreRender | Raises the PreRender event. (Inherited from Control.)
OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
OnUnload | Raises the Unload event. (Inherited from Control.)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
ParseControl | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
ReadStringResource | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderControl | Overloaded.
RenderErrorPage | Renders an error page when an unhandled exception is encountered. (Inherited from AbstractBasePage.)
RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetFocus | Overloaded.
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Validate | Overloaded.
VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
XPath | Overloaded.
XPathSelect | Overloaded.

Explicit Interface Implementations

Name | Description
IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
IFilterResolutionService..::.CompareFilters | (Inherited from TemplateControl.)
IFilterResolutionService..::.EvaluateFilter | (Inherited from TemplateControl.)
IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


AddOnPreRenderCompleteAsync Method

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.AddOnPreRenderCompleteAsync Method
ALIBasePage Class See Also Send Feedback

Overload List

Name | Description
AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)

See Also

ALIBasePage Class
ALIBasePage Members
BEA.ALI.Web.UI Namespace


DataBind Method

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.DataBind Method
ALIBasePage Class See Also Send Feedback

Overload List

Name | Description
DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

ALIBasePage Class
ALIBasePage Members
BEA.ALI.Web.UI Namespace


Eval Method

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.Eval Method
ALIBasePage Class See Also Send Feedback

Overload List

Name | Description
Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)

See Also

ALIBasePage Class
ALIBasePage Members
BEA.ALI.Web.UI Namespace


FindControl Method

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.FindControl Method
ALIBasePage Class See Also Send Feedback

Overload List

Name | Description
FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)

See Also

ALIBasePage Class
ALIBasePage Members
BEA.ALI.Web.UI Namespace


GetGlobalResourceObject Method

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.GetGlobalResourceObject Method
ALIBasePage Class See Also Send Feedback

Overload List

Name | Description
GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)

See Also

ALIBasePage Class
ALIBasePage Members
BEA.ALI.Web.UI Namespace


GetLocalResourceObject Method

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.GetLocalResourceObject Method
ALIBasePage Class See Also Send Feedback

Overload List

Name | Description
GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)

See Also

ALIBasePage Class
ALIBasePage Members
BEA.ALI.Web.UI Namespace


GetPostBackEventReference Method

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.GetPostBackEventReference Method
ALIBasePage Class See Also Send Feedback

Overload List

Name | Description
GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)

See Also

ALIBasePage Class
ALIBasePage Members
BEA.ALI.Web.UI Namespace


InitOutputCache Method

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.InitOutputCache Method
ALIBasePage Class See Also Send Feedback

Overload List

Name | Description
InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)

See Also

ALIBasePage Class
ALIBasePage Members
BEA.ALI.Web.UI Namespace


LoadControl Method

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.LoadControl Method
ALIBasePage Class See Also Send Feedback

Overload List

Name | Description
LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)

See Also

ALIBasePage Class
ALIBasePage Members
BEA.ALI.Web.UI Namespace


OnError Method

ALIBasePage..::.OnError Method
ALIBasePage Class See Also Send Feedback
Capture ASP.NET page errors and route them through our custom error reporting handler.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected override void OnError(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs
The EventArgs object that contains the event data.

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


OnInit Method

ALIBasePage..::.OnInit Method
ALIBasePage Class See Also Send Feedback
Called each time this page is hit by a user. Initializes the page for use.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected override void OnInit(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs
The EventArgs object that contains the event data.

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


RenderControl Method

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.RenderControl Method
ALIBasePage Class See Also Send Feedback

Overload List

Name | Description
RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

ALIBasePage Class
ALIBasePage Members
BEA.ALI.Web.UI Namespace


SetFocus Method

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.SetFocus Method
ALIBasePage Class See Also Send Feedback

Overload List

Name | Description
SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)

See Also

ALIBasePage Class
ALIBasePage Members
BEA.ALI.Web.UI Namespace


Validate Method

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.Validate Method
ALIBasePage Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)

See Also

ALIBasePage Class
ALIBasePage Members
BEA.ALI.Web.UI Namespace


XPath Method

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.XPath Method
ALIBasePage Class See Also Send Feedback

Overload List

Name | Description
XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)

See Also

ALIBasePage Class
ALIBasePage Members
BEA.ALI.Web.UI Namespace


XPathSelect Method

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.XPathSelect Method
ALIBasePage Class See Also Send Feedback

Overload List

Name | Description
XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

See Also

ALIBasePage Class
ALIBasePage Members
BEA.ALI.Web.UI Namespace


ALIBasePage Properties

[image]

WebCenter Portlet API for .NET Library
ALIBasePage Properties
ALIBasePage Class See Also Send Feedback

The ALIBasePage type exposes the following members.

Properties

Name | Description
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
AggregationMode | Gets the current AggregationMode for the Portlet. The aggregation mode indicates whether the Portlet is alone on the page or displayed with other Portlets.
Alignment | Gets the alignment of the Portlet.
Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClassID | Gets the class ID.
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
CommunityID | Gets the ID of the Community in which the Portlet is currently displayed.
ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
CredentialProvider | Gets the ICredentialProvider, an interface for retrieving the username and password for a backend application that were sent to the Portlet in headers.
CredentialSetter | Gets the ICredentialSetter, an interface for encrypting and setting the username and password for a backend application on a PortletResponse.
Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
EnableEventValidation | (Inherited from Page.)
EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Form | Gets the HTML form for the page. (Inherited from Page.)
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
HostedDisplayMode | Sets the requested display mode. This property cannot be read, as it is not sent to the Portlet in the request. It is set by the Portlet and sent back in the response. This method is used for pages associated with a Portlet (i.e., preference pages).
HostPageURI | Gets the URI for the portal page in which the Portlet is currently displayed.
HostPageURLQueryString | Gets the query string portion of the URL that was used to access this portal's hosting page.
HttpRequest | Gets the .Net HttpRequest for the requested Page.
HttpResponse | Gets the .Net HttpResponse for the requested Page.
ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
ImageServerURI | Gets the URI for the WCI Image Service.
IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Items | Gets a list of objects stored in the page context. (Inherited from Page.)
LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
PageID | Gets the ID of the portal page on which the Portlet is currently displayed.
PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
PortalUUID | Gets the portal UUID.
PortletID | Gets the Portlet ID for the current Portlet.
PortletMode | Gets a PortletMode object to tell the client what mode the Portlet is running in. The Portlet mode indicates whether the Portlet should display standard content or a summary for small-screened mobile devices. The mode also indicates if the Portlet is syndicated (running asynchronously).
PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
ProtocolVersion | Gets the current version of the protocol being used by the portal to communicate with this Portlet. 1.2 indicates a 5.x ALI Portal, 1.3 indicates a 6.x ALI Portal, and 1.4 indicates an Ensemble 1.0 proxy server.
RemoteAPIEndpoint | Gets the remote API endpoint, or null if the Portlet is run as a job. The remote API endpoint can be used to access the portal's remote SOAP API. To instantiate an IRemoteSession object, use RemotePortalSession.
RemotePortalSession | Gets the IRemoteSession initialized with a login token and endpoint URL sent by the portal. Because it is using a login token, the Remote Session will have the same security context in the portal as the user of the Portlet. If you apply a RemoteSessionAttribute to a Portlet that extends ALIBasePage then when running outside of the portal the values specified in the Attribute will be used for creating a RemotePortalSession.
Request | Gets the BEA.ALI.Web.HttpPortletRequest for the requested Page.
Response | Gets the BEA.ALI.Web.HttpPortletResponse object associated with the BEA.ALI.Web.UI.BasePage. This allows you to send HTTP response data to a client and contains information about that response.
ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
ReturnURI | Gets the URI for the portal page to return to when done.
Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
StylesheetURI | Gets the URI for the stylesheet currently being used by the portal user.
SubPortalID | Gets the ID of the subportal that the accessing user belongs to.
SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Title | Sets the title to be displayed for the Portlet. This property cannot be read, as it is not sent to the Portlet in the request. It is set by the Portlet and sent back in the response.
Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
User | Gets the PortletUser object for the user requesting the page.
UserInterface | Gets a UserInterface object to tell the client what type of device is being used to browse the portal (e.g., phone, PDA, standard web browser).
Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)

Explicit Interface Implementations

Name | Description
IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
IExpressionsAccessor..::.Expressions | (Inherited from Control.)
IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


AggregationMode Property

ALIBasePage..::.AggregationMode Property
ALIBasePage Class See Also Send Feedback
Gets the current AggregationMode for the Portlet. The aggregation mode indicates whether the Portlet is alone on the page or displayed with other Portlets.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public AggregationMode AggregationMode { get; }

Remarks

GetAggregationMode()()()

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


Alignment Property

ALIBasePage..::.Alignment Property
ALIBasePage Class See Also Send Feedback
Gets the alignment of the Portlet.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Alignment Alignment { get; }

Remarks

GetAlignment()()()

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


ClassID Property

ALIBasePage..::.ClassID Property
ALIBasePage Class See Also Send Feedback
Gets the class ID.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public int ClassID { get; }

Remarks

GetClassID()()()

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


CommunityID Property

ALIBasePage..::.CommunityID Property
ALIBasePage Class See Also Send Feedback
Gets the ID of the Community in which the Portlet is currently displayed.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public int CommunityID { get; }

Remarks

GetCommunityID()()()

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


CredentialProvider Property

ALIBasePage..::.CredentialProvider Property
ALIBasePage Class See Also Send Feedback
Gets the ICredentialProvider, an interface for retrieving the username and password for a backend application that were sent to the Portlet in headers.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public ICredentialProvider CredentialProvider { get; }

Remarks

GetCredentialProvider()()()

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


CredentialSetter Property

ALIBasePage..::.CredentialSetter Property
ALIBasePage Class See Also Send Feedback
Gets the ICredentialSetter, an interface for encrypting and setting the username and password for a backend application on a PortletResponse.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public ICredentialSetter CredentialSetter { get; }

Remarks

GetCredentialSetter()()()

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


HostedDisplayMode Property

ALIBasePage..::.HostedDisplayMode Property
ALIBasePage Class See Also Send Feedback
Sets the requested display mode. This property cannot be read, as it is not sent to the Portlet in the request. It is set by the Portlet and sent back in the response. This method is used for pages associated with a Portlet (i.e., preference pages).

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public HostedDisplayMode HostedDisplayMode { set; }

Remarks

SetHostedDisplayMode(HostedDisplayMode)

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


HostPageURI Property

ALIBasePage..::.HostPageURI Property
ALIBasePage Class See Also Send Feedback
Gets the URI for the portal page in which the Portlet is currently displayed.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Uri HostPageURI { get; }

Remarks

GetHostPageURI()()()

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


HostPageURLQueryString Property

ALIBasePage..::.HostPageURLQueryString Property
ALIBasePage Class See Also Send Feedback
Gets the query string portion of the URL that was used to access this portal's hosting page.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string HostPageURLQueryString { get; }

Remarks

GetHostPageURLQueryString()()()

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


HttpRequest Property

ALIBasePage..::.HttpRequest Property
ALIBasePage Class See Also Send Feedback
Gets the .Net HttpRequest for the requested Page.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public HttpRequest HttpRequest { get; }

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


HttpResponse Property

ALIBasePage..::.HttpResponse Property
ALIBasePage Class See Also Send Feedback
Gets the .Net HttpResponse for the requested Page.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public HttpResponse HttpResponse { get; }

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


ImageServerURI Property

ALIBasePage..::.ImageServerURI Property
ALIBasePage Class See Also Send Feedback
Gets the URI for the WCI Image Service.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Uri ImageServerURI { get; }

Remarks

GetImageServerURI()()()

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


PageID Property

ALIBasePage..::.PageID Property
ALIBasePage Class See Also Send Feedback
Gets the ID of the portal page on which the Portlet is currently displayed.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public int PageID { get; }

Remarks

GetPageID()()()

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


PortalUUID Property

ALIBasePage..::.PortalUUID Property
ALIBasePage Class See Also Send Feedback
Gets the portal UUID.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string PortalUUID { get; }

Remarks

GetPortalUUID()()()

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


PortletID Property

ALIBasePage..::.PortletID Property
ALIBasePage Class See Also Send Feedback
Gets the Portlet ID for the current Portlet.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public int PortletID { get; }

Remarks

GetPortletID()()()

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


PortletMode Property

ALIBasePage..::.PortletMode Property
ALIBasePage Class See Also Send Feedback
Gets a PortletMode object to tell the client what mode the Portlet is running in. The Portlet mode indicates whether the Portlet should display standard content or a summary for small-screened mobile devices. The mode also indicates if the Portlet is syndicated (running asynchronously).

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public PortletMode PortletMode { get; }

Remarks

GetPortletMode()()()

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


ProtocolVersion Property

ALIBasePage..::.ProtocolVersion Property
ALIBasePage Class See Also Send Feedback
Gets the current version of the protocol being used by the portal to communicate with this Portlet. 1.2 indicates a 5.x ALI Portal, 1.3 indicates a 6.x ALI Portal, and 1.4 indicates an Ensemble 1.0 proxy server.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string ProtocolVersion { get; }

Remarks

This will be returned in the en-us locale, i.e. '1.2'. GetProtocolVersion()()()

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


RemoteAPIEndpoint Property

ALIBasePage..::.RemoteAPIEndpoint Property
ALIBasePage Class See Also Send Feedback
Gets the remote API endpoint, or null if the Portlet is run as a job. The remote API endpoint can be used to access the portal's remote SOAP API. To instantiate an IRemoteSession object, use RemotePortalSession.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Uri RemoteAPIEndpoint { get; }

Remarks

[!:Plumtree.Remote.Portlet.IPortletRequest.GetRemoteAPIEndpoint]

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


RemotePortalSession Property

ALIBasePage..::.RemotePortalSession Property
ALIBasePage Class See Also Send Feedback
Gets the IRemoteSession initialized with a login token and endpoint URL sent by the portal. Because it is using a login token, the Remote Session will have the same security context in the portal as the user of the Portlet. If you apply a RemoteSessionAttribute to a Portlet that extends ALIBasePage then when running outside of the portal the values specified in the Attribute will be used for creating a RemotePortalSession.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public IRemoteSession RemotePortalSession { get; }

Remarks

GetRemotePortalSession()()()

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


Request Property

ALIBasePage..::.Request Property
ALIBasePage Class See Also Send Feedback
Gets the BEA.ALI.Web.HttpPortletRequest for the requested Page.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public HttpPortletRequest Request { get; }

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


Response Property

ALIBasePage..::.Response Property
ALIBasePage Class See Also Send Feedback
Gets the BEA.ALI.Web.HttpPortletResponse object associated with the BEA.ALI.Web.UI.BasePage. This allows you to send HTTP response data to a client and contains information about that response.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public HttpPortletResponse Response { get; }

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


ReturnURI Property

ALIBasePage..::.ReturnURI Property
ALIBasePage Class See Also Send Feedback
Gets the URI for the portal page to return to when done.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Uri ReturnURI { get; }

Remarks

GetReturnURI()()() You can also use HttpPortletResponse.ReturnToPortal to return the user to the portal page.

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


StylesheetURI Property

ALIBasePage..::.StylesheetURI Property
ALIBasePage Class See Also Send Feedback
Gets the URI for the stylesheet currently being used by the portal user.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Uri StylesheetURI { get; }

Remarks

GetStylesheetURI()()()

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


SubPortalID Property

ALIBasePage..::.SubPortalID Property
ALIBasePage Class See Also Send Feedback
Gets the ID of the subportal that the accessing user belongs to.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public int SubPortalID { get; }

Remarks

GetSubPortalID()()()

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


Title Property

ALIBasePage..::.Title Property
ALIBasePage Class See Also Send Feedback
Sets the title to be displayed for the Portlet. This property cannot be read, as it is not sent to the Portlet in the request. It is set by the Portlet and sent back in the response.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string Title { set; }

Remarks

SetTitle(String)

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


User Property

ALIBasePage..::.User Property
ALIBasePage Class See Also Send Feedback
Gets the PortletUser object for the user requesting the page.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public ALIPortletUser User { get; }

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


UserInterface Property

ALIBasePage..::.UserInterface Property
ALIBasePage Class See Also Send Feedback
Gets a UserInterface object to tell the client what type of device is being used to browse the portal (e.g., phone, PDA, standard web browser).

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public UserInterface UserInterface { get; }

Remarks

GetUserInterface()()()

See Also

ALIBasePage Class
BEA.ALI.Web.UI Namespace


ALIBasePage.AdminPreferenceAttribute Class

ALIBasePage..::.AdminPreferenceAttribute Class
ALIBasePage Class Members Example See Also Send Feedback
Place on a BEA page field to mark it as an admin preference value.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
[AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple = false)]
protected class AdminPreferenceAttribute : ALIPreferenceAttribute

Remarks

Administrative preferences are specific to a Portlet object. Any user can see them, but they can only be set by the administrator on the Portlet Editor in portal administration.

Examples

[AdminPreference()]
[AdminPreference(Key = "MyAdminPref")]
[AdminPreference(Key = "MyAdminPref", DefaultValue = "MyVal")]
private string MyAdminPref;
    ...

Inheritance Hierarchy

System..::.Object
System..::.Attribute
BEA.Portlet..::.PortletFieldAttribute
BEA.Portlet..::.PreferenceAttribute
BEA.ALI.Web..::.ALIPreferenceAttribute
BEA.ALI.Web.UI..::.ALIBasePage..::.AdminPreferenceAttribute

See Also

ALIBasePage..::.AdminPreferenceAttribute Members
BEA.ALI.Web.UI Namespace


ALIBasePage.AdminPreferenceAttribute Members

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.AdminPreferenceAttribute Members
ALIBasePage..::.AdminPreferenceAttribute Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ALIBasePage provides the base class for all the Portlet API Pages for use with WCI. It creates the IDK User object, and provides property access to the hybrid User.

Property access is provided for information sent via headers that was previously avaliable through the IPortletRequest and IPortletContext interfaces in the IDK.

It also defines the PortletPreferenceAttribute, AdminPreferenceAttribute, CommunityPreferenceAttribute, CommunityPortletPreferenceAttribute, SessionPreferenceAttribute, and UserPreferenceAttribute which can be used to tag fields whose value comes from a preference sent by the WCI portal.

Developers should never extend this class directly. Instead extend ALIPortletPage or ALIPreferencePage.

The ALIBasePage..::.AdminPreferenceAttribute type exposes the following members.

Constructors

Name | Description
ALIBasePage..::.AdminPreferenceAttribute | Creates an AdminPreferenceAttribute for a field.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Provides a hashcode unique for the PreferenceAttribute type and key. (Inherited from PreferenceAttribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init | Initializes the preference attribute so that it can handle registration for lifecycle events. (Inherited from PreferenceAttribute.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
LoadValue | Sets the value of the field from the preference values in the IPortletRequest. (Inherited from PreferenceAttribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overrides ToString() to provide a meaningful representation of the PreferenceAttribute type and key. (Inherited from PreferenceAttribute.)
UnloadValue | Writes the value of the field to the preference in the IPortletResponse. (Inherited from PreferenceAttribute.)

Fields

Name | Description
_field | The FieldInfo provided during Init. (Inherited from PortletFieldAttribute.)
_isInitialized | Returns trueTruetruetrue (True in Visual Basic) if Init has has been called. falseFalsefalsefalse (False in Visual Basic) otherwise. (Inherited from PortletFieldAttribute.)
_log | The WCI logger class to trace messages within this class. (Inherited from PortletFieldAttribute.)
_page | The page provided during Init. (Inherited from PortletFieldAttribute.)
_portletContext | The portlet context provided during Init. (Inherited from PortletFieldAttribute.)
_type | The SettingType of the PreferenceAttribute. (Inherited from PreferenceAttribute.)

Properties

Name | Description
Default | Returns a fallback default value base upon the field type if none was provided. (Inherited from PreferenceAttribute.)
DefaultValue | Gets or sets the default value of the preference. This is the value when running outside a portal or when no other value has been assigned. (Inherited from PreferenceAttribute.)
Key | Gets or sets the preference key. (Inherited from PreferenceAttribute.)
PreferenceCollection | Internal PreferenceCollection used to read and write the underlying preference values. (Inherited from ALIPreferenceAttribute.)
Type | The type of preference. (Inherited from ALIPreferenceAttribute.)
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

ALIBasePage..::.AdminPreferenceAttribute Class
BEA.ALI.Web.UI Namespace


ALIBasePage.AdminPreferenceAttribute Constructor

ALIBasePage..::.AdminPreferenceAttribute Constructor
ALIBasePage..::.AdminPreferenceAttribute Class See Also Send Feedback
Creates an AdminPreferenceAttribute for a field.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public AdminPreferenceAttribute()

See Also

ALIBasePage..::.AdminPreferenceAttribute Class
BEA.ALI.Web.UI Namespace


ALIBasePage.CommunityPortletPreferenceAttribute Class

ALIBasePage..::.CommunityPortletPreferenceAttribute Class
ALIBasePage Class Members Example See Also Send Feedback
Place on a BEA page field to mark it as a community portlet preference value.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
[AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple = false)]
protected class CommunityPortletPreferenceAttribute : ALIPreferenceAttribute

Remarks

Community portlet preferences are specific to a given Portlet within a Community. Any user can see them. The same Portlet placed in a different Community would not be able to access these preferences. Community portlet preferences can be adjusted by Community administrators. If you try to use community portlet preferences outside of a Community (i.e. on a My Page) an exception will be thrown. To verify the Portlet is on a Community page, use the IsInCommunity property.

Examples

[CommunityPortletPreference()]
[CommunityPortletPreference(Key = "MyCommPortletPref")]
[CommunityPortletPreference(Key = "MyCommPortletPref", DefaultValue = "MyVal")]
private string MyCommPortletPref;
    ...

Inheritance Hierarchy

System..::.Object
System..::.Attribute
BEA.Portlet..::.PortletFieldAttribute
BEA.Portlet..::.PreferenceAttribute
BEA.ALI.Web..::.ALIPreferenceAttribute
BEA.ALI.Web.UI..::.ALIBasePage..::.CommunityPortletPreferenceAttribute

See Also

ALIBasePage..::.CommunityPortletPreferenceAttribute Members
BEA.ALI.Web.UI Namespace


ALIBasePage.CommunityPortletPreferenceAttribute Members

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.CommunityPortletPreferenceAttribute Members
ALIBasePage..::.CommunityPortletPreferenceAttribute Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ALIBasePage provides the base class for all the Portlet API Pages for use with WCI. It creates the IDK User object, and provides property access to the hybrid User.

Property access is provided for information sent via headers that was previously avaliable through the IPortletRequest and IPortletContext interfaces in the IDK.

It also defines the PortletPreferenceAttribute, AdminPreferenceAttribute, CommunityPreferenceAttribute, CommunityPortletPreferenceAttribute, SessionPreferenceAttribute, and UserPreferenceAttribute which can be used to tag fields whose value comes from a preference sent by the WCI portal.

Developers should never extend this class directly. Instead extend ALIPortletPage or ALIPreferencePage.

The ALIBasePage..::.CommunityPortletPreferenceAttribute type exposes the following members.

Constructors

Name | Description
ALIBasePage..::.CommunityPortletPreferenceAttribute | Creates a CommunityPortletPreferenceAttribute for a field.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Provides a hashcode unique for the PreferenceAttribute type and key. (Inherited from PreferenceAttribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init | Initializes the preference attribute so that it can handle registration for lifecycle events. (Inherited from PreferenceAttribute.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
LoadValue | Sets the value of the field from the preference values in the IPortletRequest. (Inherited from PreferenceAttribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overrides ToString() to provide a meaningful representation of the PreferenceAttribute type and key. (Inherited from PreferenceAttribute.)
UnloadValue | Writes the value of the field to the preference in the IPortletResponse. (Inherited from PreferenceAttribute.)

Fields

Name | Description
_field | The FieldInfo provided during Init. (Inherited from PortletFieldAttribute.)
_isInitialized | Returns trueTruetruetrue (True in Visual Basic) if Init has has been called. falseFalsefalsefalse (False in Visual Basic) otherwise. (Inherited from PortletFieldAttribute.)
_log | The WCI logger class to trace messages within this class. (Inherited from PortletFieldAttribute.)
_page | The page provided during Init. (Inherited from PortletFieldAttribute.)
_portletContext | The portlet context provided during Init. (Inherited from PortletFieldAttribute.)
_type | The SettingType of the PreferenceAttribute. (Inherited from PreferenceAttribute.)

Properties

Name | Description
Default | Returns a fallback default value base upon the field type if none was provided. (Inherited from PreferenceAttribute.)
DefaultValue | Gets or sets the default value of the preference. This is the value when running outside a portal or when no other value has been assigned. (Inherited from PreferenceAttribute.)
Key | Gets or sets the preference key. (Inherited from PreferenceAttribute.)
PreferenceCollection | Internal PreferenceCollection used to read and write the underlying preference values. (Inherited from ALIPreferenceAttribute.)
Type | The type of preference. (Inherited from ALIPreferenceAttribute.)
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

ALIBasePage..::.CommunityPortletPreferenceAttribute Class
BEA.ALI.Web.UI Namespace


ALIBasePage.CommunityPortletPreferenceAttribute Constructor

ALIBasePage..::.CommunityPortletPreferenceAttribute Constructor
ALIBasePage..::.CommunityPortletPreferenceAttribute Class See Also Send Feedback
Creates a CommunityPortletPreferenceAttribute for a field.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public CommunityPortletPreferenceAttribute()

See Also

ALIBasePage..::.CommunityPortletPreferenceAttribute Class
BEA.ALI.Web.UI Namespace


ALIBasePage.CommunityPreferenceAttribute Class

ALIBasePage..::.CommunityPreferenceAttribute Class
ALIBasePage Class Members Example See Also Send Feedback
Place on a BEA page field to mark it as a community preference value.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
[AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple = false)]
protected class CommunityPreferenceAttribute : ALIPreferenceAttribute

Remarks

Community preferences are specific to an entire Community. All the portlets and users in the Community have access to these preferences. If you try to use community preferences outside of a Community (i.e. on a My Page) an exception will be thrown. To verify the Portlet is on a Community page, use the IsInCommunity property. Community preferences can be adjusted by Community administrators. If you only want one Portlet in the Community to have access to the preferences, use community portlet preferences.

Examples

[CommunityPreference()]
[CommunityPreference(Key = "MyCommPref")]
[CommunityPreference(Key = "MyCommPref", DefaultValue = "MyVal")]
private string MyCommPref;
    ...

Inheritance Hierarchy

System..::.Object
System..::.Attribute
BEA.Portlet..::.PortletFieldAttribute
BEA.Portlet..::.PreferenceAttribute
BEA.ALI.Web..::.ALIPreferenceAttribute
BEA.ALI.Web.UI..::.ALIBasePage..::.CommunityPreferenceAttribute

See Also

ALIBasePage..::.CommunityPreferenceAttribute Members
BEA.ALI.Web.UI Namespace


ALIBasePage.CommunityPreferenceAttribute Members

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.CommunityPreferenceAttribute Members
ALIBasePage..::.CommunityPreferenceAttribute Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ALIBasePage provides the base class for all the Portlet API Pages for use with WCI. It creates the IDK User object, and provides property access to the hybrid User.

Property access is provided for information sent via headers that was previously avaliable through the IPortletRequest and IPortletContext interfaces in the IDK.

It also defines the PortletPreferenceAttribute, AdminPreferenceAttribute, CommunityPreferenceAttribute, CommunityPortletPreferenceAttribute, SessionPreferenceAttribute, and UserPreferenceAttribute which can be used to tag fields whose value comes from a preference sent by the WCI portal.

Developers should never extend this class directly. Instead extend ALIPortletPage or ALIPreferencePage.

The ALIBasePage..::.CommunityPreferenceAttribute type exposes the following members.

Constructors

Name | Description
ALIBasePage..::.CommunityPreferenceAttribute | Creates a CommunityPreferenceAttribute for a field.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Provides a hashcode unique for the PreferenceAttribute type and key. (Inherited from PreferenceAttribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init | Initializes the preference attribute so that it can handle registration for lifecycle events. (Inherited from PreferenceAttribute.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
LoadValue | Sets the value of the field from the preference values in the IPortletRequest. (Inherited from PreferenceAttribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overrides ToString() to provide a meaningful representation of the PreferenceAttribute type and key. (Inherited from PreferenceAttribute.)
UnloadValue | Writes the value of the field to the preference in the IPortletResponse. (Inherited from PreferenceAttribute.)

Fields

Name | Description
_field | The FieldInfo provided during Init. (Inherited from PortletFieldAttribute.)
_isInitialized | Returns trueTruetruetrue (True in Visual Basic) if Init has has been called. falseFalsefalsefalse (False in Visual Basic) otherwise. (Inherited from PortletFieldAttribute.)
_log | The WCI logger class to trace messages within this class. (Inherited from PortletFieldAttribute.)
_page | The page provided during Init. (Inherited from PortletFieldAttribute.)
_portletContext | The portlet context provided during Init. (Inherited from PortletFieldAttribute.)
_type | The SettingType of the PreferenceAttribute. (Inherited from PreferenceAttribute.)

Properties

Name | Description
Default | Returns a fallback default value base upon the field type if none was provided. (Inherited from PreferenceAttribute.)
DefaultValue | Gets or sets the default value of the preference. This is the value when running outside a portal or when no other value has been assigned. (Inherited from PreferenceAttribute.)
Key | Gets or sets the preference key. (Inherited from PreferenceAttribute.)
PreferenceCollection | Internal PreferenceCollection used to read and write the underlying preference values. (Inherited from ALIPreferenceAttribute.)
Type | The type of preference. (Inherited from ALIPreferenceAttribute.)
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

ALIBasePage..::.CommunityPreferenceAttribute Class
BEA.ALI.Web.UI Namespace


ALIBasePage.CommunityPreferenceAttribute Constructor

ALIBasePage..::.CommunityPreferenceAttribute Constructor
ALIBasePage..::.CommunityPreferenceAttribute Class See Also Send Feedback
Creates a CommunityPreferenceAttribute for a field.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public CommunityPreferenceAttribute()

See Also

ALIBasePage..::.CommunityPreferenceAttribute Class
BEA.ALI.Web.UI Namespace


ALIBasePage.PortletPreferenceAttribute Class

ALIBasePage..::.PortletPreferenceAttribute Class
ALIBasePage Class Members Example See Also Send Feedback
Place on a BEA page field to mark it as a portlet preference value.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
[AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple = false)]
public class PortletPreferenceAttribute : ALIPreferenceAttribute

Remarks

Portlet preferences are specific to a given user and a single Portlet object. Many Portlet objects can be created from the same Portlet Web Service object; each will have unique portlet preferences for a given user. Portlet preferences can be adjusted by anyone.

Examples

[PortletPreference()]
[PortletPreference(Key = "MyPortletPref")]
[PortletPreference(Key = "MyPortletPref", DefaultValue = "MyVal")]
private string MyPortletPref;
    ...

Inheritance Hierarchy

System..::.Object
System..::.Attribute
BEA.Portlet..::.PortletFieldAttribute
BEA.Portlet..::.PreferenceAttribute
BEA.ALI.Web..::.ALIPreferenceAttribute
BEA.ALI.Web.UI..::.ALIBasePage..::.PortletPreferenceAttribute

See Also

ALIBasePage..::.PortletPreferenceAttribute Members
BEA.ALI.Web.UI Namespace


ALIBasePage.PortletPreferenceAttribute Members

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.PortletPreferenceAttribute Members
ALIBasePage..::.PortletPreferenceAttribute Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ALIBasePage provides the base class for all the Portlet API Pages for use with WCI. It creates the IDK User object, and provides property access to the hybrid User.

Property access is provided for information sent via headers that was previously avaliable through the IPortletRequest and IPortletContext interfaces in the IDK.

It also defines the PortletPreferenceAttribute, AdminPreferenceAttribute, CommunityPreferenceAttribute, CommunityPortletPreferenceAttribute, SessionPreferenceAttribute, and UserPreferenceAttribute which can be used to tag fields whose value comes from a preference sent by the WCI portal.

Developers should never extend this class directly. Instead extend ALIPortletPage or ALIPreferencePage.

The ALIBasePage..::.PortletPreferenceAttribute type exposes the following members.

Constructors

Name | Description
ALIBasePage..::.PortletPreferenceAttribute | Creates a PortletPreferenceAttribute for a field.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Provides a hashcode unique for the PreferenceAttribute type and key. (Inherited from PreferenceAttribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init | Initializes the preference attribute so that it can handle registration for lifecycle events. (Inherited from PreferenceAttribute.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
LoadValue | Sets the value of the field from the preference values in the IPortletRequest. (Inherited from PreferenceAttribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overrides ToString() to provide a meaningful representation of the PreferenceAttribute type and key. (Inherited from PreferenceAttribute.)
UnloadValue | Writes the value of the field to the preference in the IPortletResponse. (Inherited from PreferenceAttribute.)

Fields

Name | Description
_field | The FieldInfo provided during Init. (Inherited from PortletFieldAttribute.)
_isInitialized | Returns trueTruetruetrue (True in Visual Basic) if Init has has been called. falseFalsefalsefalse (False in Visual Basic) otherwise. (Inherited from PortletFieldAttribute.)
_log | The WCI logger class to trace messages within this class. (Inherited from PortletFieldAttribute.)
_page | The page provided during Init. (Inherited from PortletFieldAttribute.)
_portletContext | The portlet context provided during Init. (Inherited from PortletFieldAttribute.)
_type | The SettingType of the PreferenceAttribute. (Inherited from PreferenceAttribute.)

Properties

Name | Description
Default | Returns a fallback default value base upon the field type if none was provided. (Inherited from PreferenceAttribute.)
DefaultValue | Gets or sets the default value of the preference. This is the value when running outside a portal or when no other value has been assigned. (Inherited from PreferenceAttribute.)
Key | Gets or sets the preference key. (Inherited from PreferenceAttribute.)
PreferenceCollection | Internal PreferenceCollection used to read and write the underlying preference values. (Inherited from ALIPreferenceAttribute.)
Type | The type of preference. (Inherited from ALIPreferenceAttribute.)
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

ALIBasePage..::.PortletPreferenceAttribute Class
BEA.ALI.Web.UI Namespace


ALIBasePage.PortletPreferenceAttribute Constructor

ALIBasePage..::.PortletPreferenceAttribute Constructor
ALIBasePage..::.PortletPreferenceAttribute Class See Also Send Feedback
Creates a PortletPreferenceAttribute for a field.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public PortletPreferenceAttribute()

See Also

ALIBasePage..::.PortletPreferenceAttribute Class
BEA.ALI.Web.UI Namespace


ALIBasePage.SessionPreferenceAttribute Class

ALIBasePage..::.SessionPreferenceAttribute Class
ALIBasePage Class Members Example See Also Send Feedback
Place on a BEA page field to mark it as a session preference value.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
[AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple = false)]
protected class SessionPreferenceAttribute : ALIPreferenceAttribute

Remarks

Session preferences apply to one particular user like user settings, but are only persisted for the duration of the user's browser session. Session preferences can be used by portlets to communicate with other Portlets without making a round trip to the portal database. Session preferences are supported in ALI version 6.0 and above.

Examples

[SessionPreference()]
[SessionPreference(Key = "MySessionPref")]
[SessionPreference(Key = "MySessionPref", DefaultValue = "MyVal")]
private string MySessionPref;
    ...

Inheritance Hierarchy

System..::.Object
System..::.Attribute
BEA.Portlet..::.PortletFieldAttribute
BEA.Portlet..::.PreferenceAttribute
BEA.ALI.Web..::.ALIPreferenceAttribute
BEA.ALI.Web.UI..::.ALIBasePage..::.SessionPreferenceAttribute

See Also

ALIBasePage..::.SessionPreferenceAttribute Members
BEA.ALI.Web.UI Namespace


ALIBasePage.SessionPreferenceAttribute Members

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.SessionPreferenceAttribute Members
ALIBasePage..::.SessionPreferenceAttribute Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ALIBasePage provides the base class for all the Portlet API Pages for use with WCI. It creates the IDK User object, and provides property access to the hybrid User.

Property access is provided for information sent via headers that was previously avaliable through the IPortletRequest and IPortletContext interfaces in the IDK.

It also defines the PortletPreferenceAttribute, AdminPreferenceAttribute, CommunityPreferenceAttribute, CommunityPortletPreferenceAttribute, SessionPreferenceAttribute, and UserPreferenceAttribute which can be used to tag fields whose value comes from a preference sent by the WCI portal.

Developers should never extend this class directly. Instead extend ALIPortletPage or ALIPreferencePage.

The ALIBasePage..::.SessionPreferenceAttribute type exposes the following members.

Constructors

Name | Description
ALIBasePage..::.SessionPreferenceAttribute | Creates a SessionPreferenceAttribute for a field.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Provides a hashcode unique for the PreferenceAttribute type and key. (Inherited from PreferenceAttribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init | Initializes the preference attribute so that it can handle registration for lifecycle events. (Inherited from PreferenceAttribute.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
LoadValue | Sets the value of the field from the preference values in the IPortletRequest. (Inherited from PreferenceAttribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overrides ToString() to provide a meaningful representation of the PreferenceAttribute type and key. (Inherited from PreferenceAttribute.)
UnloadValue | Writes the value of the field to the preference in the IPortletResponse. (Inherited from PreferenceAttribute.)

Fields

Name | Description
_field | The FieldInfo provided during Init. (Inherited from PortletFieldAttribute.)
_isInitialized | Returns trueTruetruetrue (True in Visual Basic) if Init has has been called. falseFalsefalsefalse (False in Visual Basic) otherwise. (Inherited from PortletFieldAttribute.)
_log | The WCI logger class to trace messages within this class. (Inherited from PortletFieldAttribute.)
_page | The page provided during Init. (Inherited from PortletFieldAttribute.)
_portletContext | The portlet context provided during Init. (Inherited from PortletFieldAttribute.)
_type | The SettingType of the PreferenceAttribute. (Inherited from PreferenceAttribute.)

Properties

Name | Description
Default | Returns a fallback default value base upon the field type if none was provided. (Inherited from PreferenceAttribute.)
DefaultValue | Gets or sets the default value of the preference. This is the value when running outside a portal or when no other value has been assigned. (Inherited from PreferenceAttribute.)
Key | Gets or sets the preference key. (Inherited from PreferenceAttribute.)
PreferenceCollection | Internal PreferenceCollection used to read and write the underlying preference values. (Inherited from ALIPreferenceAttribute.)
Type | The type of preference. (Inherited from ALIPreferenceAttribute.)
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

ALIBasePage..::.SessionPreferenceAttribute Class
BEA.ALI.Web.UI Namespace


ALIBasePage.SessionPreferenceAttribute Constructor

ALIBasePage..::.SessionPreferenceAttribute Constructor
ALIBasePage..::.SessionPreferenceAttribute Class See Also Send Feedback
Creates a SessionPreferenceAttribute for a field.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public SessionPreferenceAttribute()

See Also

ALIBasePage..::.SessionPreferenceAttribute Class
BEA.ALI.Web.UI Namespace


ALIBasePage.UserPreferenceAttribute Class

ALIBasePage..::.UserPreferenceAttribute Class
ALIBasePage Class Members Example See Also Send Feedback
Place on a BEA page field to mark it as a user preference value.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
[AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple = false)]
protected class UserPreferenceAttribute : ALIPreferenceAttribute

Remarks

User preferences are specific to a given user. User preferences are shared by all Portlets that the user accesses. User preferences can be adjusted by the user only.

Examples

[UserPreference()]
[UserPreference(Key = "MyUserPref")]
[UserPreference(Key = "MyUserPref", DefaultValue = "MyVal")]
private string MyUserPref;
    ...

Inheritance Hierarchy

System..::.Object
System..::.Attribute
BEA.Portlet..::.PortletFieldAttribute
BEA.Portlet..::.PreferenceAttribute
BEA.ALI.Web..::.ALIPreferenceAttribute
BEA.ALI.Web.UI..::.ALIBasePage..::.UserPreferenceAttribute

See Also

ALIBasePage..::.UserPreferenceAttribute Members
BEA.ALI.Web.UI Namespace


ALIBasePage.UserPreferenceAttribute Members

[image]

WebCenter Portlet API for .NET Library
ALIBasePage..::.UserPreferenceAttribute Members
ALIBasePage..::.UserPreferenceAttribute Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The ALIBasePage provides the base class for all the Portlet API Pages for use with WCI. It creates the IDK User object, and provides property access to the hybrid User.

Property access is provided for information sent via headers that was previously avaliable through the IPortletRequest and IPortletContext interfaces in the IDK.

It also defines the PortletPreferenceAttribute, AdminPreferenceAttribute, CommunityPreferenceAttribute, CommunityPortletPreferenceAttribute, SessionPreferenceAttribute, and UserPreferenceAttribute which can be used to tag fields whose value comes from a preference sent by the WCI portal.

Developers should never extend this class directly. Instead extend ALIPortletPage or ALIPreferencePage.

The ALIBasePage..::.UserPreferenceAttribute type exposes the following members.

Constructors

Name | Description
ALIBasePage..::.UserPreferenceAttribute | Creates a UserPreferenceAttribute for a field.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Provides a hashcode unique for the PreferenceAttribute type and key. (Inherited from PreferenceAttribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init | Initializes the preference attribute so that it can handle registration for lifecycle events. (Inherited from PreferenceAttribute.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
LoadValue | Sets the value of the field from the preference values in the IPortletRequest. (Inherited from PreferenceAttribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overrides ToString() to provide a meaningful representation of the PreferenceAttribute type and key. (Inherited from PreferenceAttribute.)
UnloadValue | Writes the value of the field to the preference in the IPortletResponse. (Inherited from PreferenceAttribute.)

Fields

Name | Description
_field | The FieldInfo provided during Init. (Inherited from PortletFieldAttribute.)
_isInitialized | Returns trueTruetruetrue (True in Visual Basic) if Init has has been called. falseFalsefalsefalse (False in Visual Basic) otherwise. (Inherited from PortletFieldAttribute.)
_log | The WCI logger class to trace messages within this class. (Inherited from PortletFieldAttribute.)
_page | The page provided during Init. (Inherited from PortletFieldAttribute.)
_portletContext | The portlet context provided during Init. (Inherited from PortletFieldAttribute.)
_type | The SettingType of the PreferenceAttribute. (Inherited from PreferenceAttribute.)

Properties

Name | Description
Default | Returns a fallback default value base upon the field type if none was provided. (Inherited from PreferenceAttribute.)
DefaultValue | Gets or sets the default value of the preference. This is the value when running outside a portal or when no other value has been assigned. (Inherited from PreferenceAttribute.)
Key | Gets or sets the preference key. (Inherited from PreferenceAttribute.)
PreferenceCollection | Internal PreferenceCollection used to read and write the underlying preference values. (Inherited from ALIPreferenceAttribute.)
Type | The type of preference. (Inherited from ALIPreferenceAttribute.)
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

ALIBasePage..::.UserPreferenceAttribute Class
BEA.ALI.Web.UI Namespace


ALIBasePage.UserPreferenceAttribute Constructor

ALIBasePage..::.UserPreferenceAttribute Constructor
ALIBasePage..::.UserPreferenceAttribute Class See Also Send Feedback
Creates a UserPreferenceAttribute for a field.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public UserPreferenceAttribute()

See Also

ALIBasePage..::.UserPreferenceAttribute Class
BEA.ALI.Web.UI Namespace


ALIPortletPage Class

ALIPortletPage Class
Members See Also Send Feedback
ALIPortletPage is the base class to extend for all portlet content pages built for use in an WCI Portal. In addition to all of the property information made available in the ALIBasePage the ALIPortletPage automatically adds portlet <div> tags around the content when it is displayed in a WCI Portal.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public abstract class ALIPortletPage : ALIBasePage

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.Page
BEA.ALI.Web.UI..::.AbstractBasePage
BEA.ALI.Web.UI..::.ALIBasePage
BEA.ALI.Web.UI..::.ALIPortletPage

See Also

ALIPortletPage Members
BEA.ALI.Web.UI Namespace


ALIPortletPage Members

[image]

WebCenter Portlet API for .NET Library
ALIPortletPage Members
ALIPortletPage Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The ALIPortletPage type exposes the following members.

Constructors

Name | Description
ALIPortletPage | Constructs a new ALIPortletPage.

Methods

Name | Description
AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddOnPreRenderCompleteAsync | Overloaded.
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Construct | Performs design-time logic. (Inherited from TemplateControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Eval | Overloaded.
ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetGlobalResourceObject | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLocalResourceObject | Overloaded.
GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackEventReference | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
InitOutputCache | Overloaded.
IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
LoadControl | Overloaded.
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnError | Capture ASP.NET page errors and route them through our custom error reporting handler. (Inherited from ALIBasePage.)
OnInit | Called each time this page is hit by a user. Initializes the page for use. (Inherited from ALIBasePage.)
OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
OnLoad | Raises the Load event. (Inherited from Control.)
OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
OnPreRender | This method adds a portlet <div> tag around the content of the page before rendering. The tag is used in WCI Portals to identify portlet content. (Overrides Control ..::. OnPreRender(EventArgs).)
OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
OnUnload | Raises the Unload event. (Inherited from Control.)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
ParseControl | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
ReadStringResource | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderControl | Overloaded.
RenderErrorPage | Renders an error page when an unhandled exception is encountered. (Inherited from AbstractBasePage.)
RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetFocus | Overloaded.
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Validate | Overloaded.
VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
XPath | Overloaded.
XPathSelect | Overloaded.

Fields

Name | Description
AdminPreferences | Indexer of administrative preferences. (Inherited from ALIBasePage.)
CommunityPortletPreferences | Indexer of community portlet preferences. (Inherited from ALIBasePage.)
CommunityPreferences | Indexer of community preferences. (Inherited from ALIBasePage.)
m_httpRequest | ASP.NET's Request object. (Inherited from ALIBasePage.)
m_httpResponse | ASP.NET's Response object. (Inherited from ALIBasePage.)
m_log | The WCI logger class to trace messages within this class. (Inherited from AbstractBasePage.)
m_portletContext | This is the IDK context. We store it to get values from it if the user requests them. (Inherited from AbstractBasePage.)
m_portletRequest | The IDK portlet request. (Inherited from AbstractBasePage.)
m_portletResponse | The IDK portlet response. (Inherited from AbstractBasePage.)
m_portletUser | The IDK portlet user. (Inherited from AbstractBasePage.)
PortletPreferences | Indexer of portlet preferences. (Inherited from ALIBasePage.)
SessionPreferences | Indexer of session preferences. (Inherited from ALIBasePage.)
UserPreferences | Indexer of user preferences. (Inherited from ALIBasePage.)

Properties

Name | Description
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
AggregationMode | Gets the current AggregationMode for the Portlet. The aggregation mode indicates whether the Portlet is alone on the page or displayed with other Portlets. (Inherited from ALIBasePage.)
Alignment | Gets the alignment of the Portlet. (Inherited from ALIBasePage.)
Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClassID | Gets the class ID. (Inherited from ALIBasePage.)
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
CommunityID | Gets the ID of the Community in which the Portlet is currently displayed. (Inherited from ALIBasePage.)
ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
CredentialProvider | Gets the ICredentialProvider, an interface for retrieving the username and password for a backend application that were sent to the Portlet in headers. (Inherited from ALIBasePage.)
CredentialSetter | Gets the ICredentialSetter, an interface for encrypting and setting the username and password for a backend application on a PortletResponse. (Inherited from ALIBasePage.)
Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
EnableEventValidation | (Inherited from Page.)
EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Form | Gets the HTML form for the page. (Inherited from Page.)
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
HostedDisplayMode | Sets the requested display mode. This property cannot be read, as it is not sent to the Portlet in the request. It is set by the Portlet and sent back in the response. This method is used for pages associated with a Portlet (i.e., preference pages). (Inherited from ALIBasePage.)
HostPageURI | Gets the URI for the portal page in which the Portlet is currently displayed. (Inherited from ALIBasePage.)
HostPageURLQueryString | Gets the query string portion of the URL that was used to access this portal's hosting page. (Inherited from ALIBasePage.)
HttpRequest | Gets the .Net HttpRequest for the requested Page. (Inherited from ALIBasePage.)
HttpResponse | Gets the .Net HttpResponse for the requested Page. (Inherited from ALIBasePage.)
ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
ImageServerURI | Gets the URI for the WCI Image Service. (Inherited from ALIBasePage.)
IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Items | Gets a list of objects stored in the page context. (Inherited from Page.)
LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
PageID | Gets the ID of the portal page on which the Portlet is currently displayed. (Inherited from ALIBasePage.)
PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
PortalUUID | Gets the portal UUID. (Inherited from ALIBasePage.)
PortletID | Gets the Portlet ID for the current Portlet. (Inherited from ALIBasePage.)
PortletMode | Gets a PortletMode object to tell the client what mode the Portlet is running in. The Portlet mode indicates whether the Portlet should display standard content or a summary for small-screened mobile devices. The mode also indicates if the Portlet is syndicated (running asynchronously). (Inherited from ALIBasePage.)
PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
ProtocolVersion | Gets the current version of the protocol being used by the portal to communicate with this Portlet. 1.2 indicates a 5.x ALI Portal, 1.3 indicates a 6.x ALI Portal, and 1.4 indicates an Ensemble 1.0 proxy server. (Inherited from ALIBasePage.)
RemoteAPIEndpoint | Gets the remote API endpoint, or null if the Portlet is run as a job. The remote API endpoint can be used to access the portal's remote SOAP API. To instantiate an IRemoteSession object, use RemotePortalSession. (Inherited from ALIBasePage.)
RemotePortalSession | Gets the IRemoteSession initialized with a login token and endpoint URL sent by the portal. Because it is using a login token, the Remote Session will have the same security context in the portal as the user of the Portlet. If you apply a RemoteSessionAttribute to a Portlet that extends ALIBasePage then when running outside of the portal the values specified in the Attribute will be used for creating a RemotePortalSession. (Inherited from ALIBasePage.)
Request | Gets the BEA.ALI.Web.HttpPortletRequest for the requested Page. (Inherited from ALIBasePage.)
Response | Gets the BEA.ALI.Web.HttpPortletResponse object associated with the BEA.ALI.Web.UI.BasePage. This allows you to send HTTP response data to a client and contains information about that response. (Inherited from ALIBasePage.)
ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
ReturnURI | Gets the URI for the portal page to return to when done. (Inherited from ALIBasePage.)
Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
StylesheetURI | Gets the URI for the stylesheet currently being used by the portal user. (Inherited from ALIBasePage.)
SubPortalID | Gets the ID of the subportal that the accessing user belongs to. (Inherited from ALIBasePage.)
SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Title | Sets the title to be displayed for the Portlet. This property cannot be read, as it is not sent to the Portlet in the request. It is set by the Portlet and sent back in the response. (Inherited from ALIBasePage.)
Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
User | Gets the PortletUser object for the user requesting the page. (Inherited from ALIBasePage.)
UserInterface | Gets a UserInterface object to tell the client what type of device is being used to browse the portal (e.g., phone, PDA, standard web browser). (Inherited from ALIBasePage.)
Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)

Events

Name | Description
AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
PreLoad | Occurs before the page Load event. (Inherited from Page.)
PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
IFilterResolutionService..::.CompareFilters | (Inherited from TemplateControl.)
IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
IFilterResolutionService..::.EvaluateFilter | (Inherited from TemplateControl.)
IExpressionsAccessor..::.Expressions | (Inherited from Control.)
IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)
IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

ALIPortletPage Class
BEA.ALI.Web.UI Namespace


ALIPortletPage Constructor

ALIPortletPage Constructor
ALIPortletPage Class See Also Send Feedback
Constructs a new ALIPortletPage.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public ALIPortletPage()

See Also

ALIPortletPage Class
BEA.ALI.Web.UI Namespace


ALIPortletPage Methods

[image]

WebCenter Portlet API for .NET Library
ALIPortletPage Methods
ALIPortletPage Class See Also Send Feedback

The ALIPortletPage type exposes the following members.

Methods

Name | Description
AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddOnPreRenderCompleteAsync | Overloaded.
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Construct | Performs design-time logic. (Inherited from TemplateControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Eval | Overloaded.
ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetGlobalResourceObject | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLocalResourceObject | Overloaded.
GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackEventReference | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
InitOutputCache | Overloaded.
IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
LoadControl | Overloaded.
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnError | Capture ASP.NET page errors and route them through our custom error reporting handler. (Inherited from ALIBasePage.)
OnInit | Called each time this page is hit by a user. Initializes the page for use. (Inherited from ALIBasePage.)
OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
OnLoad | Raises the Load event. (Inherited from Control.)
OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
OnPreRender | This method adds a portlet <div> tag around the content of the page before rendering. The tag is used in WCI Portals to identify portlet content. (Overrides Control ..::. OnPreRender(EventArgs).)
OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
OnUnload | Raises the Unload event. (Inherited from Control.)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
ParseControl | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
ReadStringResource | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderControl | Overloaded.
RenderErrorPage | Renders an error page when an unhandled exception is encountered. (Inherited from AbstractBasePage.)
RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetFocus | Overloaded.
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Validate | Overloaded.
VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
XPath | Overloaded.
XPathSelect | Overloaded.

Explicit Interface Implementations

Name | Description
IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
IFilterResolutionService..::.CompareFilters | (Inherited from TemplateControl.)
IFilterResolutionService..::.EvaluateFilter | (Inherited from TemplateControl.)
IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)

See Also

ALIPortletPage Class
BEA.ALI.Web.UI Namespace


AddOnPreRenderCompleteAsync Method

[image]

WebCenter Portlet API for .NET Library
ALIPortletPage..::.AddOnPreRenderCompleteAsync Method
ALIPortletPage Class See Also Send Feedback

Overload List

Name | Description
AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)

See Also

ALIPortletPage Class
ALIPortletPage Members
BEA.ALI.Web.UI Namespace


DataBind Method

[image]

WebCenter Portlet API for .NET Library
ALIPortletPage..::.DataBind Method
ALIPortletPage Class See Also Send Feedback

Overload List

Name | Description
DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

ALIPortletPage Class
ALIPortletPage Members
BEA.ALI.Web.UI Namespace


Eval Method

[image]

WebCenter Portlet API for .NET Library
ALIPortletPage..::.Eval Method
ALIPortletPage Class See Also Send Feedback

Overload List

Name | Description
Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)

See Also

ALIPortletPage Class
ALIPortletPage Members
BEA.ALI.Web.UI Namespace


FindControl Method

[image]

WebCenter Portlet API for .NET Library
ALIPortletPage..::.FindControl Method
ALIPortletPage Class See Also Send Feedback

Overload List

Name | Description
FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)

See Also

ALIPortletPage Class
ALIPortletPage Members
BEA.ALI.Web.UI Namespace


GetGlobalResourceObject Method

[image]

WebCenter Portlet API for .NET Library
ALIPortletPage..::.GetGlobalResourceObject Method
ALIPortletPage Class See Also Send Feedback

Overload List

Name | Description
GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)

See Also

ALIPortletPage Class
ALIPortletPage Members
BEA.ALI.Web.UI Namespace


GetLocalResourceObject Method

[image]

WebCenter Portlet API for .NET Library
ALIPortletPage..::.GetLocalResourceObject Method
ALIPortletPage Class See Also Send Feedback

Overload List

Name | Description
GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)

See Also

ALIPortletPage Class
ALIPortletPage Members
BEA.ALI.Web.UI Namespace


GetPostBackEventReference Method

[image]

WebCenter Portlet API for .NET Library
ALIPortletPage..::.GetPostBackEventReference Method
ALIPortletPage Class See Also Send Feedback

Overload List

Name | Description
GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)

See Also

ALIPortletPage Class
ALIPortletPage Members
BEA.ALI.Web.UI Namespace


InitOutputCache Method

[image]

WebCenter Portlet API for .NET Library
ALIPortletPage..::.InitOutputCache Method
ALIPortletPage Class See Also Send Feedback

Overload List

Name | Description
InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)

See Also

ALIPortletPage Class
ALIPortletPage Members
BEA.ALI.Web.UI Namespace


LoadControl Method

[image]

WebCenter Portlet API for .NET Library
ALIPortletPage..::.LoadControl Method
ALIPortletPage Class See Also Send Feedback

Overload List

Name | Description
LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)

See Also

ALIPortletPage Class
ALIPortletPage Members
BEA.ALI.Web.UI Namespace


OnPreRender Method

ALIPortletPage..::.OnPreRender Method
ALIPortletPage Class See Also Send Feedback
This method adds a portlet <div> tag around the content of the page before rendering. The tag is used in WCI Portals to identify portlet content.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected override void OnPreRender(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs
An EventArgs object that contains the event data.

Remarks

OnPreRender(EventArgs)

See Also

ALIPortletPage Class
BEA.ALI.Web.UI Namespace


RenderControl Method

[image]

WebCenter Portlet API for .NET Library
ALIPortletPage..::.RenderControl Method
ALIPortletPage Class See Also Send Feedback

Overload List

Name | Description
RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

ALIPortletPage Class
ALIPortletPage Members
BEA.ALI.Web.UI Namespace


SetFocus Method

[image]

WebCenter Portlet API for .NET Library
ALIPortletPage..::.SetFocus Method
ALIPortletPage Class See Also Send Feedback

Overload List

Name | Description
SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)

See Also

ALIPortletPage Class
ALIPortletPage Members
BEA.ALI.Web.UI Namespace


Validate Method

[image]

WebCenter Portlet API for .NET Library
ALIPortletPage..::.Validate Method
ALIPortletPage Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)

See Also

ALIPortletPage Class
ALIPortletPage Members
BEA.ALI.Web.UI Namespace


XPath Method

[image]

WebCenter Portlet API for .NET Library
ALIPortletPage..::.XPath Method
ALIPortletPage Class See Also Send Feedback

Overload List

Name | Description
XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)

See Also

ALIPortletPage Class
ALIPortletPage Members
BEA.ALI.Web.UI Namespace


XPathSelect Method

[image]

WebCenter Portlet API for .NET Library
ALIPortletPage..::.XPathSelect Method
ALIPortletPage Class See Also Send Feedback

Overload List

Name | Description
XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

See Also

ALIPortletPage Class
ALIPortletPage Members
BEA.ALI.Web.UI Namespace


ALIPortletUser Class

ALIPortletUser Class
Members See Also Send Feedback
ALIPortletUser implements IPrincipal and adds additional User information that comes specifically from WCI.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public class ALIPortletUser : IPrincipal

Inheritance Hierarchy

System..::.Object
BEA.ALI.Web.UI..::.ALIPortletUser

See Also

ALIPortletUser Members
BEA.ALI.Web.UI Namespace


ALIPortletUser Members

[image]

WebCenter Portlet API for .NET Library
ALIPortletUser Members
ALIPortletUser Class Methods Fields Properties See Also Send Feedback

The ALIPortletUser type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasActivityRight | Returns a flag that indicates whether or not the user has the specified Activity Right.
HasSettingsRight | Returns a flag that indicates whether or not the user has the right to change the specified setting type.
IsGuestUser | Returns whether the user is a portal guest user.
IsInRole | Determines whether the current principal belongs to the specified role.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_aspUser | Standard ASP .Net User.
m_page | WCI's Request object for the given page visit.
m_portletUser | WCI's User object for the given HTTP User to a Portlet.

Properties

Name | Description
ActivityRights | Gets an enumeration of the Activity Rights for the user. Only Activity Rights that the administrator has configured the portal to send to the Portlet will appear in this enumeration.
BasicAuthPassword | Gets the user's basic auth password from the HTTP Authorization header in the web request.
BasicAuthUsername | Gets the user's basic auth username from the HTTP Authorization header in the web request.
CharacterSet | Gets the user's character set. This setting is configured by the user in the portal and used for localization.
CurrentCommunityAccessLevel | Gets the Community access level. The administrator must configure the portal to send the Community ACL to the Portlet.
ID | Gets the User object ID for the current user.
Identity | Gets the identity of the current principal.
LoginToken | Gets the user’s login token from the request. The login token can be used to access the portal as the current user.
Name | Gets the portal user name for the current user.
SettingsRights | Gets an enumeration of SettingTypes indicating what preference types the current user can edit.

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


ALIPortletUser Fields

[image]

WebCenter Portlet API for .NET Library
ALIPortletUser Fields
ALIPortletUser Class See Also Send Feedback

The ALIPortletUser type exposes the following members.

Fields

Name | Description
m_aspUser | Standard ASP .Net User.
m_page | WCI's Request object for the given page visit.
m_portletUser | WCI's User object for the given HTTP User to a Portlet.

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


m_aspUser Field

ALIPortletUser..::.m_aspUser Field
ALIPortletUser Class See Also Send Feedback
Standard ASP .Net User.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected IPrincipal m_aspUser

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


m_page Field

ALIPortletUser..::.m_page Field
ALIPortletUser Class See Also Send Feedback
WCI's Request object for the given page visit.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected AbstractBasePage m_page

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


m_portletUser Field

ALIPortletUser..::.m_portletUser Field
ALIPortletUser Class See Also Send Feedback
WCI's User object for the given HTTP User to a Portlet.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected IPortletUser m_portletUser

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


ALIPortletUser Methods

[image]

WebCenter Portlet API for .NET Library
ALIPortletUser Methods
ALIPortletUser Class See Also Send Feedback

The ALIPortletUser type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HasActivityRight | Returns a flag that indicates whether or not the user has the specified Activity Right.
HasSettingsRight | Returns a flag that indicates whether or not the user has the right to change the specified setting type.
IsGuestUser | Returns whether the user is a portal guest user.
IsInRole | Determines whether the current principal belongs to the specified role.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


HasActivityRight Method

ALIPortletUser..::.HasActivityRight Method
ALIPortletUser Class See Also Send Feedback
Returns a flag that indicates whether or not the user has the specified Activity Right.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool HasActivityRight(
    string activityRight
)

Parameters

activityRight
Type: System..::.String
the name of the Activity Right

Return Value

true if the user has the Activity Right and false otherwise

Remarks

HasActivityRight(String)

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


HasSettingsRight Method

ALIPortletUser..::.HasSettingsRight Method
ALIPortletUser Class See Also Send Feedback
Returns a flag that indicates whether or not the user has the right to change the specified setting type.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool HasSettingsRight(
    SettingType settingType
)

Parameters

settingType
Type: BEA.ALI.Web..::.SettingType
the setting type (e.g., Admin, Portlet, User)

Return Value

true if the user has the right to change the specified setting type and false otherwise

Remarks

HasSettingsRight(SettingType)

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


IsGuestUser Method

ALIPortletUser..::.IsGuestUser Method
ALIPortletUser Class See Also Send Feedback
Returns whether the user is a portal guest user.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool IsGuestUser()

Return Value

true if and only if the user is a Portal guest

Remarks

IsGuestUser()()()

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


IsInRole Method

ALIPortletUser..::.IsInRole Method
ALIPortletUser Class See Also Send Feedback
Determines whether the current principal belongs to the specified role.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool IsInRole(
    string role
)

Parameters

role
Type: System..::.String

Implements

IPrincipal..::.IsInRole(String)

Remarks

IsInRole(String)

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


ALIPortletUser Properties

[image]

WebCenter Portlet API for .NET Library
ALIPortletUser Properties
ALIPortletUser Class See Also Send Feedback

The ALIPortletUser type exposes the following members.

Properties

Name | Description
ActivityRights | Gets an enumeration of the Activity Rights for the user. Only Activity Rights that the administrator has configured the portal to send to the Portlet will appear in this enumeration.
BasicAuthPassword | Gets the user's basic auth password from the HTTP Authorization header in the web request.
BasicAuthUsername | Gets the user's basic auth username from the HTTP Authorization header in the web request.
CharacterSet | Gets the user's character set. This setting is configured by the user in the portal and used for localization.
CurrentCommunityAccessLevel | Gets the Community access level. The administrator must configure the portal to send the Community ACL to the Portlet.
ID | Gets the User object ID for the current user.
Identity | Gets the identity of the current principal.
LoginToken | Gets the user’s login token from the request. The login token can be used to access the portal as the current user.
Name | Gets the portal user name for the current user.
SettingsRights | Gets an enumeration of SettingTypes indicating what preference types the current user can edit.

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


ActivityRights Property

ALIPortletUser..::.ActivityRights Property
ALIPortletUser Class See Also Send Feedback
Gets an enumeration of the Activity Rights for the user. Only Activity Rights that the administrator has configured the portal to send to the Portlet will appear in this enumeration.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public IEnumerator ActivityRights { get; }

Remarks

GetActivityRights()()()

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


BasicAuthPassword Property

ALIPortletUser..::.BasicAuthPassword Property
ALIPortletUser Class See Also Send Feedback
Gets the user's basic auth password from the HTTP Authorization header in the web request.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string BasicAuthPassword { get; }

Remarks

GetBasicAuthPassword()()()

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


BasicAuthUsername Property

ALIPortletUser..::.BasicAuthUsername Property
ALIPortletUser Class See Also Send Feedback
Gets the user's basic auth username from the HTTP Authorization header in the web request.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string BasicAuthUsername { get; }

Remarks

GetBasicAuthUsername()()()

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


CharacterSet Property

ALIPortletUser..::.CharacterSet Property
ALIPortletUser Class See Also Send Feedback
Gets the user's character set. This setting is configured by the user in the portal and used for localization.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string CharacterSet { get; }

Remarks

GetUserCharacterSet()()()

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


CurrentCommunityAccessLevel Property

ALIPortletUser..::.CurrentCommunityAccessLevel Property
ALIPortletUser Class See Also Send Feedback
Gets the Community access level. The administrator must configure the portal to send the Community ACL to the Portlet.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public CommunityAccessLevel CurrentCommunityAccessLevel { get; }

Remarks

GetCurrentCommunityAccessLevel()()()

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


ID Property

ALIPortletUser..::.ID Property
ALIPortletUser Class See Also Send Feedback
Gets the User object ID for the current user.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public int ID { get; }

Remarks

GetUserID()()()

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


Identity Property

ALIPortletUser..::.Identity Property
ALIPortletUser Class See Also Send Feedback
Gets the identity of the current principal.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public IIdentity Identity { get; }

Implements

IPrincipal..::.Identity

Remarks

Identity

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


LoginToken Property

ALIPortletUser..::.LoginToken Property
ALIPortletUser Class See Also Send Feedback
Gets the user’s login token from the request. The login token can be used to access the portal as the current user.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string LoginToken { get; }

Remarks

[!:Plumtree.Remote.Portlet.IPortletRequest.GetLoginToken]

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


Name Property

ALIPortletUser..::.Name Property
ALIPortletUser Class See Also Send Feedback
Gets the portal user name for the current user.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string Name { get; }

Remarks

GetUserName()()()

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


SettingsRights Property

ALIPortletUser..::.SettingsRights Property
ALIPortletUser Class See Also Send Feedback
Gets an enumeration of SettingTypes indicating what preference types the current user can edit.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public IEnumerator SettingsRights { get; }

Remarks

GetSettingsRights()()()

See Also

ALIPortletUser Class
BEA.ALI.Web.UI Namespace


ALIPreferencePage Class

ALIPreferencePage Class
Members See Also Send Feedback

ALIPreferencePage is the base class to extend for all portlet preference pages built for use in WCI.

In addition to all of the property information made available in the ALIBasePage the ALIPreferencePage automatically adds a title banner to the top of the page, consistent with the WCI look and feel. The banner includes functional Finish and Cancel buttons for updating the preferences on the page.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public abstract class ALIPreferencePage : ALIBasePage

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.Page
BEA.ALI.Web.UI..::.AbstractBasePage
BEA.ALI.Web.UI..::.ALIBasePage
BEA.ALI.Web.UI..::.ALIPreferencePage

See Also

ALIPreferencePage Members
BEA.ALI.Web.UI Namespace


ALIPreferencePage Members

[image]

WebCenter Portlet API for .NET Library
ALIPreferencePage Members
ALIPreferencePage Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The ALIPreferencePage type exposes the following members.

Constructors

Name | Description
ALIPreferencePage | Constructs a new ALIPreferencePage.

Methods

Name | Description
AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddOnPreRenderCompleteAsync | Overloaded.
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Construct | Performs design-time logic. (Inherited from TemplateControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
DrawTitleBar | Draws the preference page title bar. This gives a text title to the page in a bar that spans the page. The bar also includes "Finish" and "Cancel" buttons. This method can be overwritten to supply a different look or style to the top of a preference page.
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Eval | Overloaded.
ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
GetBannerText | Gets the title string to use in the banner at the top of the preference page.
GetCancelButtonText | Gets the string to use on the Cancel button. Implementing this method allows a developer to use a localized string.
GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetFinishButtonText | Gets the string to use on the Finish button. Implementing this method allows a developer to use a localized string.
GetGlobalResourceObject | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLocalResourceObject | Overloaded.
GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackEventReference | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
InitOutputCache | Overloaded.
IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
LoadControl | Overloaded.
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnError | Capture ASP.NET page errors and route them through our custom error reporting handler. (Inherited from ALIBasePage.)
OnInit | Overridden to place the template controls that exist on all preference pages. These controls are placed at the top of the page, and include a banner and Finish and Cancel buttons. We must add the template controls in this stage of the page's lifecycle. Other stages, such as the Load, PreRender, Render, or even SaveViewState will cause view state corruption or naming problems. (Overrides ALIBasePage ..::. OnInit(EventArgs).)
OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
OnLoad | Raises the Load event. (Inherited from Control.)
OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
OnPreRender | Overridden to set the text values in the controls added to the top of the page. These value are not set in OnInit when the controls are added because a developer may have actions in their Page_Load method to set these text values based on localization. (Overrides Control ..::. OnPreRender(EventArgs).)
OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
OnUnload | Raises the Unload event. (Inherited from Control.)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
ParseControl | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
ReadStringResource | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderControl | Overloaded.
RenderErrorPage | Renders an error page when an unhandled exception is encountered. (Inherited from AbstractBasePage.)
RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
SavePreferences | Called when a user clicks the Finish button. This method is responsible for any final actions to be performed by the page, and setting any preference values that should be sent back to the portal.
SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetFocus | Overloaded.
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Validate | Overloaded.
VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
XPath | Overloaded.
XPathSelect | Overloaded.

Fields

Name | Description
AdminPreferences | Indexer of administrative preferences. (Inherited from ALIBasePage.)
CommunityPortletPreferences | Indexer of community portlet preferences. (Inherited from ALIBasePage.)
CommunityPreferences | Indexer of community preferences. (Inherited from ALIBasePage.)
m_httpRequest | ASP.NET's Request object. (Inherited from ALIBasePage.)
m_httpResponse | ASP.NET's Response object. (Inherited from ALIBasePage.)
m_log | The WCI logger class to trace messages within this class. (Inherited from AbstractBasePage.)
m_portletContext | This is the IDK context. We store it to get values from it if the user requests them. (Inherited from AbstractBasePage.)
m_portletRequest | The IDK portlet request. (Inherited from AbstractBasePage.)
m_portletResponse | The IDK portlet response. (Inherited from AbstractBasePage.)
m_portletUser | The IDK portlet user. (Inherited from AbstractBasePage.)
PortletPreferences | Indexer of portlet preferences. (Inherited from ALIBasePage.)
SessionPreferences | Indexer of session preferences. (Inherited from ALIBasePage.)
UserPreferences | Indexer of user preferences. (Inherited from ALIBasePage.)

Properties

Name | Description
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
AggregationMode | Gets the current AggregationMode for the Portlet. The aggregation mode indicates whether the Portlet is alone on the page or displayed with other Portlets. (Inherited from ALIBasePage.)
Alignment | Gets the alignment of the Portlet. (Inherited from ALIBasePage.)
Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClassID | Gets the class ID. (Inherited from ALIBasePage.)
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
CommunityID | Gets the ID of the Community in which the Portlet is currently displayed. (Inherited from ALIBasePage.)
ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
CredentialProvider | Gets the ICredentialProvider, an interface for retrieving the username and password for a backend application that were sent to the Portlet in headers. (Inherited from ALIBasePage.)
CredentialSetter | Gets the ICredentialSetter, an interface for encrypting and setting the username and password for a backend application on a PortletResponse. (Inherited from ALIBasePage.)
Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
EnableEventValidation | (Inherited from Page.)
EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Form | Gets the HTML form for the page. (Inherited from Page.)
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
HostedDisplayMode | Sets the requested display mode. This property cannot be read, as it is not sent to the Portlet in the request. It is set by the Portlet and sent back in the response. This method is used for pages associated with a Portlet (i.e., preference pages). (Inherited from ALIBasePage.)
HostPageURI | Gets the URI for the portal page in which the Portlet is currently displayed. (Inherited from ALIBasePage.)
HostPageURLQueryString | Gets the query string portion of the URL that was used to access this portal's hosting page. (Inherited from ALIBasePage.)
HttpRequest | Gets the .Net HttpRequest for the requested Page. (Inherited from ALIBasePage.)
HttpResponse | Gets the .Net HttpResponse for the requested Page. (Inherited from ALIBasePage.)
ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
ImageServerURI | Gets the URI for the WCI Image Service. (Inherited from ALIBasePage.)
IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Items | Gets a list of objects stored in the page context. (Inherited from Page.)
LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
PageID | Gets the ID of the portal page on which the Portlet is currently displayed. (Inherited from ALIBasePage.)
PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
PortalUUID | Gets the portal UUID. (Inherited from ALIBasePage.)
PortletID | Gets the Portlet ID for the current Portlet. (Inherited from ALIBasePage.)
PortletMode | Gets a PortletMode object to tell the client what mode the Portlet is running in. The Portlet mode indicates whether the Portlet should display standard content or a summary for small-screened mobile devices. The mode also indicates if the Portlet is syndicated (running asynchronously). (Inherited from ALIBasePage.)
PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
ProtocolVersion | Gets the current version of the protocol being used by the portal to communicate with this Portlet. 1.2 indicates a 5.x ALI Portal, 1.3 indicates a 6.x ALI Portal, and 1.4 indicates an Ensemble 1.0 proxy server. (Inherited from ALIBasePage.)
RemoteAPIEndpoint | Gets the remote API endpoint, or null if the Portlet is run as a job. The remote API endpoint can be used to access the portal's remote SOAP API. To instantiate an IRemoteSession object, use RemotePortalSession. (Inherited from ALIBasePage.)
RemotePortalSession | Gets the IRemoteSession initialized with a login token and endpoint URL sent by the portal. Because it is using a login token, the Remote Session will have the same security context in the portal as the user of the Portlet. If you apply a RemoteSessionAttribute to a Portlet that extends ALIBasePage then when running outside of the portal the values specified in the Attribute will be used for creating a RemotePortalSession. (Inherited from ALIBasePage.)
Request | Gets the BEA.ALI.Web.HttpPortletRequest for the requested Page. (Inherited from ALIBasePage.)
Response | Gets the BEA.ALI.Web.HttpPortletResponse object associated with the BEA.ALI.Web.UI.BasePage. This allows you to send HTTP response data to a client and contains information about that response. (Inherited from ALIBasePage.)
ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
ReturnURI | Gets the URI for the portal page to return to when done. (Inherited from ALIBasePage.)
Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
StylesheetURI | Gets the URI for the stylesheet currently being used by the portal user. (Inherited from ALIBasePage.)
SubPortalID | Gets the ID of the subportal that the accessing user belongs to. (Inherited from ALIBasePage.)
SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Title | Sets the title to be displayed for the Portlet. This property cannot be read, as it is not sent to the Portlet in the request. It is set by the Portlet and sent back in the response. (Inherited from ALIBasePage.)
Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
User | Gets the PortletUser object for the user requesting the page. (Inherited from ALIBasePage.)
UserInterface | Gets a UserInterface object to tell the client what type of device is being used to browse the portal (e.g., phone, PDA, standard web browser). (Inherited from ALIBasePage.)
Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)

Events

Name | Description
AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
PreLoad | Occurs before the page Load event. (Inherited from Page.)
PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
IFilterResolutionService..::.CompareFilters | (Inherited from TemplateControl.)
IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
IFilterResolutionService..::.EvaluateFilter | (Inherited from TemplateControl.)
IExpressionsAccessor..::.Expressions | (Inherited from Control.)
IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)
IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

ALIPreferencePage Class
BEA.ALI.Web.UI Namespace


ALIPreferencePage Constructor

ALIPreferencePage Constructor
ALIPreferencePage Class See Also Send Feedback
Constructs a new ALIPreferencePage.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public ALIPreferencePage()

See Also

ALIPreferencePage Class
BEA.ALI.Web.UI Namespace


ALIPreferencePage Methods

[image]

WebCenter Portlet API for .NET Library
ALIPreferencePage Methods
ALIPreferencePage Class See Also Send Feedback

The ALIPreferencePage type exposes the following members.

Methods

Name | Description
AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddOnPreRenderCompleteAsync | Overloaded.
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Construct | Performs design-time logic. (Inherited from TemplateControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
DrawTitleBar | Draws the preference page title bar. This gives a text title to the page in a bar that spans the page. The bar also includes "Finish" and "Cancel" buttons. This method can be overwritten to supply a different look or style to the top of a preference page.
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Eval | Overloaded.
ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
GetBannerText | Gets the title string to use in the banner at the top of the preference page.
GetCancelButtonText | Gets the string to use on the Cancel button. Implementing this method allows a developer to use a localized string.
GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetFinishButtonText | Gets the string to use on the Finish button. Implementing this method allows a developer to use a localized string.
GetGlobalResourceObject | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLocalResourceObject | Overloaded.
GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackEventReference | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
InitOutputCache | Overloaded.
IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
LoadControl | Overloaded.
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnError | Capture ASP.NET page errors and route them through our custom error reporting handler. (Inherited from ALIBasePage.)
OnInit | Overridden to place the template controls that exist on all preference pages. These controls are placed at the top of the page, and include a banner and Finish and Cancel buttons. We must add the template controls in this stage of the page's lifecycle. Other stages, such as the Load, PreRender, Render, or even SaveViewState will cause view state corruption or naming problems. (Overrides ALIBasePage ..::. OnInit(EventArgs).)
OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
OnLoad | Raises the Load event. (Inherited from Control.)
OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
OnPreRender | Overridden to set the text values in the controls added to the top of the page. These value are not set in OnInit when the controls are added because a developer may have actions in their Page_Load method to set these text values based on localization. (Overrides Control ..::. OnPreRender(EventArgs).)
OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
OnUnload | Raises the Unload event. (Inherited from Control.)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
ParseControl | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
ReadStringResource | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderControl | Overloaded.
RenderErrorPage | Renders an error page when an unhandled exception is encountered. (Inherited from AbstractBasePage.)
RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
SavePreferences | Called when a user clicks the Finish button. This method is responsible for any final actions to be performed by the page, and setting any preference values that should be sent back to the portal.
SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetFocus | Overloaded.
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Validate | Overloaded.
VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
XPath | Overloaded.
XPathSelect | Overloaded.

Explicit Interface Implementations

Name | Description
IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
IFilterResolutionService..::.CompareFilters | (Inherited from TemplateControl.)
IFilterResolutionService..::.EvaluateFilter | (Inherited from TemplateControl.)
IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)

See Also

ALIPreferencePage Class
BEA.ALI.Web.UI Namespace


AddOnPreRenderCompleteAsync Method

[image]

WebCenter Portlet API for .NET Library
ALIPreferencePage..::.AddOnPreRenderCompleteAsync Method
ALIPreferencePage Class See Also Send Feedback

Overload List

Name | Description
AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)

See Also

ALIPreferencePage Class
ALIPreferencePage Members
BEA.ALI.Web.UI Namespace


DataBind Method

[image]

WebCenter Portlet API for .NET Library
ALIPreferencePage..::.DataBind Method
ALIPreferencePage Class See Also Send Feedback

Overload List

Name | Description
DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

ALIPreferencePage Class
ALIPreferencePage Members
BEA.ALI.Web.UI Namespace


DrawTitleBar Method

ALIPreferencePage..::.DrawTitleBar Method
ALIPreferencePage Class See Also Send Feedback
Draws the preference page title bar. This gives a text title to the page in a bar that spans the page. The bar also includes "Finish" and "Cancel" buttons. This method can be overwritten to supply a different look or style to the top of a preference page.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected virtual WebControl DrawTitleBar()

Return Value

The title bar for the preference page.

See Also

ALIPreferencePage Class
BEA.ALI.Web.UI Namespace


Eval Method

[image]

WebCenter Portlet API for .NET Library
ALIPreferencePage..::.Eval Method
ALIPreferencePage Class See Also Send Feedback

Overload List

Name | Description
Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)

See Also

ALIPreferencePage Class
ALIPreferencePage Members
BEA.ALI.Web.UI Namespace


FindControl Method

[image]

WebCenter Portlet API for .NET Library
ALIPreferencePage..::.FindControl Method
ALIPreferencePage Class See Also Send Feedback

Overload List

Name | Description
FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)

See Also

ALIPreferencePage Class
ALIPreferencePage Members
BEA.ALI.Web.UI Namespace


GetBannerText Method

ALIPreferencePage..::.GetBannerText Method
ALIPreferencePage Class See Also Send Feedback
Gets the title string to use in the banner at the top of the preference page.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected abstract string GetBannerText()

Return Value

The string to use in the title banner

See Also

ALIPreferencePage Class
BEA.ALI.Web.UI Namespace


GetCancelButtonText Method

ALIPreferencePage..::.GetCancelButtonText Method
ALIPreferencePage Class See Also Send Feedback
Gets the string to use on the Cancel button. Implementing this method allows a developer to use a localized string.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected abstract string GetCancelButtonText()

Return Value

The string to use on the Cancel button

See Also

ALIPreferencePage Class
BEA.ALI.Web.UI Namespace


GetFinishButtonText Method

ALIPreferencePage..::.GetFinishButtonText Method
ALIPreferencePage Class See Also Send Feedback
Gets the string to use on the Finish button. Implementing this method allows a developer to use a localized string.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected abstract string GetFinishButtonText()

Return Value

The string to use on the Finish button

See Also

ALIPreferencePage Class
BEA.ALI.Web.UI Namespace


GetGlobalResourceObject Method

[image]

WebCenter Portlet API for .NET Library
ALIPreferencePage..::.GetGlobalResourceObject Method
ALIPreferencePage Class See Also Send Feedback

Overload List

Name | Description
GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)

See Also

ALIPreferencePage Class
ALIPreferencePage Members
BEA.ALI.Web.UI Namespace


GetLocalResourceObject Method

[image]

WebCenter Portlet API for .NET Library
ALIPreferencePage..::.GetLocalResourceObject Method
ALIPreferencePage Class See Also Send Feedback

Overload List

Name | Description
GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)

See Also

ALIPreferencePage Class
ALIPreferencePage Members
BEA.ALI.Web.UI Namespace


GetPostBackEventReference Method

[image]

WebCenter Portlet API for .NET Library
ALIPreferencePage..::.GetPostBackEventReference Method
ALIPreferencePage Class See Also Send Feedback

Overload List

Name | Description
GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)

See Also

ALIPreferencePage Class
ALIPreferencePage Members
BEA.ALI.Web.UI Namespace


InitOutputCache Method

[image]

WebCenter Portlet API for .NET Library
ALIPreferencePage..::.InitOutputCache Method
ALIPreferencePage Class See Also Send Feedback

Overload List

Name | Description
InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)

See Also

ALIPreferencePage Class
ALIPreferencePage Members
BEA.ALI.Web.UI Namespace


LoadControl Method

[image]

WebCenter Portlet API for .NET Library
ALIPreferencePage..::.LoadControl Method
ALIPreferencePage Class See Also Send Feedback

Overload List

Name | Description
LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)

See Also

ALIPreferencePage Class
ALIPreferencePage Members
BEA.ALI.Web.UI Namespace


OnInit Method

ALIPreferencePage..::.OnInit Method
ALIPreferencePage Class See Also Send Feedback
Overridden to place the template controls that exist on all preference pages. These controls are placed at the top of the page, and include a banner and Finish and Cancel buttons. We must add the template controls in this stage of the page's lifecycle. Other stages, such as the Load, PreRender, Render, or even SaveViewState will cause view state corruption or naming problems.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected override void OnInit(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs
An EventArgs object that contains the event data.

Remarks

OnInit(EventArgs)

See Also

ALIPreferencePage Class
BEA.ALI.Web.UI Namespace


OnPreRender Method

ALIPreferencePage..::.OnPreRender Method
ALIPreferencePage Class See Also Send Feedback
Overridden to set the text values in the controls added to the top of the page. These value are not set in OnInit when the controls are added because a developer may have actions in their Page_Load method to set these text values based on localization.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected override void OnPreRender(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs
An EventArgs object that contains the event data.

Remarks

OnPreRender(EventArgs)

See Also

ALIPreferencePage Class
BEA.ALI.Web.UI Namespace


RenderControl Method

[image]

WebCenter Portlet API for .NET Library
ALIPreferencePage..::.RenderControl Method
ALIPreferencePage Class See Also Send Feedback

Overload List

Name | Description
RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

ALIPreferencePage Class
ALIPreferencePage Members
BEA.ALI.Web.UI Namespace


SavePreferences Method

ALIPreferencePage..::.SavePreferences Method
ALIPreferencePage Class See Also Send Feedback
Called when a user clicks the Finish button. This method is responsible for any final actions to be performed by the page, and setting any preference values that should be sent back to the portal.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected abstract void SavePreferences()

See Also

ALIPreferencePage Class
BEA.ALI.Web.UI Namespace


SetFocus Method

[image]

WebCenter Portlet API for .NET Library
ALIPreferencePage..::.SetFocus Method
ALIPreferencePage Class See Also Send Feedback

Overload List

Name | Description
SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)

See Also

ALIPreferencePage Class
ALIPreferencePage Members
BEA.ALI.Web.UI Namespace


Validate Method

[image]

WebCenter Portlet API for .NET Library
ALIPreferencePage..::.Validate Method
ALIPreferencePage Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)

See Also

ALIPreferencePage Class
ALIPreferencePage Members
BEA.ALI.Web.UI Namespace


XPath Method

[image]

WebCenter Portlet API for .NET Library
ALIPreferencePage..::.XPath Method
ALIPreferencePage Class See Also Send Feedback

Overload List

Name | Description
XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)

See Also

ALIPreferencePage Class
ALIPreferencePage Members
BEA.ALI.Web.UI Namespace


XPathSelect Method

[image]

WebCenter Portlet API for .NET Library
ALIPreferencePage..::.XPathSelect Method
ALIPreferencePage Class See Also Send Feedback

Overload List

Name | Description
XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

See Also

ALIPreferencePage Class
ALIPreferencePage Members
BEA.ALI.Web.UI Namespace


WSRPBasePage Class

WSRPBasePage Class
Members See Also Send Feedback

The WSRPBasePage provides the base class for all of the Portlet API WSRP Pages for use with a WSRP Portal. It creates the IDK User object, and provides property access to the hybrid User.

Developers should never extend this class directly. Instead extend WSRPPortletPage.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public abstract class WSRPBasePage : AbstractBasePage

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.Page
BEA.ALI.Web.UI..::.AbstractBasePage
BEA.ALI.Web.UI..::.WSRPBasePage
BEA.ALI.Web.UI..::.WSRPPortletPage

See Also

WSRPBasePage Members
BEA.ALI.Web.UI Namespace


WSRPBasePage Members

[image]

WebCenter Portlet API for .NET Library
WSRPBasePage Members
WSRPBasePage Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The WSRPBasePage type exposes the following members.

Constructors

Name | Description
WSRPBasePage | Constructs a new WSRPBasePage.

Methods

Name | Description
AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddOnPreRenderCompleteAsync | Overloaded.
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Construct | Performs design-time logic. (Inherited from TemplateControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Eval | Overloaded.
ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetGlobalResourceObject | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLocalResourceObject | Overloaded.
GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackEventReference | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
InitOutputCache | Overloaded.
IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
LoadControl | Overloaded.
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnError | Capture ASP.NET page errors and route them through our custom error reporting handler. (Overrides TemplateControl ..::. OnError(EventArgs).)
OnInit | Called each time this page is hit by a user. Initializes the page for use. (Overrides AbstractBasePage ..::. OnInit(EventArgs).)
OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
OnLoad | Raises the Load event. (Inherited from Control.)
OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
OnPreRender | Raises the PreRender event. (Inherited from Control.)
OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
OnUnload | Raises the Unload event. See Page.OnUnload (Overrides Control ..::. OnUnload(EventArgs).)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
ParseControl | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
ReadStringResource | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderControl | Overloaded.
RenderErrorPage | Renders an error page when an unhandled exception is encountered. (Inherited from AbstractBasePage.)
RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetFocus | Overloaded.
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Validate | Overloaded.
VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
XPath | Overloaded.
XPathSelect | Overloaded.

Fields

Name | Description
m_log | The WCI logger class to trace messages within this class. (Inherited from AbstractBasePage.)
m_portletContext | This is the IDK context. We store it to get values from it if the user requests them. (Inherited from AbstractBasePage.)
m_portletRequest | The IDK portlet request. (Inherited from AbstractBasePage.)
m_portletResponse | The IDK portlet response. (Inherited from AbstractBasePage.)
m_portletUser | The IDK portlet user. (Inherited from AbstractBasePage.)
PortletStateValues | Indexer of portlet properties.

Properties

Name | Description
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
EnableEventValidation | (Inherited from Page.)
EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Form | Gets the HTML form for the page. (Inherited from Page.)
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Items | Gets a list of objects stored in the page context. (Inherited from Page.)
LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Title | Gets or sets the title for the page. (Inherited from Page.)
Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
User | Gets the PortletUser object for who is requesting the page.
Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)

Events

Name | Description
AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
PreLoad | Occurs before the page Load event. (Inherited from Page.)
PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
IFilterResolutionService..::.CompareFilters | (Inherited from TemplateControl.)
IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
IFilterResolutionService..::.EvaluateFilter | (Inherited from TemplateControl.)
IExpressionsAccessor..::.Expressions | (Inherited from Control.)
IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)
IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

WSRPBasePage Class
BEA.ALI.Web.UI Namespace


WSRPBasePage Constructor

WSRPBasePage Constructor
WSRPBasePage Class See Also Send Feedback
Constructs a new WSRPBasePage.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public WSRPBasePage()

See Also

WSRPBasePage Class
BEA.ALI.Web.UI Namespace


WSRPBasePage Fields

[image]

WebCenter Portlet API for .NET Library
WSRPBasePage Fields
WSRPBasePage Class See Also Send Feedback

The WSRPBasePage type exposes the following members.

Fields

Name | Description
m_log | The WCI logger class to trace messages within this class. (Inherited from AbstractBasePage.)
m_portletContext | This is the IDK context. We store it to get values from it if the user requests them. (Inherited from AbstractBasePage.)
m_portletRequest | The IDK portlet request. (Inherited from AbstractBasePage.)
m_portletResponse | The IDK portlet response. (Inherited from AbstractBasePage.)
m_portletUser | The IDK portlet user. (Inherited from AbstractBasePage.)
PortletStateValues | Indexer of portlet properties.

See Also

WSRPBasePage Class
BEA.ALI.Web.UI Namespace


PortletStateValues Field

WSRPBasePage..::.PortletStateValues Field
WSRPBasePage Class See Also Send Feedback
Indexer of portlet properties.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public readonly PreferenceCollection PortletStateValues

Remarks

Portlet properties are specific to a given user and a single Portlet object. Portlet properties can be adjusted by anyone.

See Also

WSRPBasePage Class
BEA.ALI.Web.UI Namespace


WSRPBasePage Methods

[image]

WebCenter Portlet API for .NET Library
WSRPBasePage Methods
WSRPBasePage Class See Also Send Feedback

The WSRPBasePage type exposes the following members.

Methods

Name | Description
AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddOnPreRenderCompleteAsync | Overloaded.
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Construct | Performs design-time logic. (Inherited from TemplateControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Eval | Overloaded.
ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetGlobalResourceObject | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLocalResourceObject | Overloaded.
GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackEventReference | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
InitOutputCache | Overloaded.
IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
LoadControl | Overloaded.
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnError | Capture ASP.NET page errors and route them through our custom error reporting handler. (Overrides TemplateControl ..::. OnError(EventArgs).)
OnInit | Called each time this page is hit by a user. Initializes the page for use. (Overrides AbstractBasePage ..::. OnInit(EventArgs).)
OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
OnLoad | Raises the Load event. (Inherited from Control.)
OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
OnPreRender | Raises the PreRender event. (Inherited from Control.)
OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
OnUnload | Raises the Unload event. See Page.OnUnload (Overrides Control ..::. OnUnload(EventArgs).)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
ParseControl | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
ReadStringResource | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderControl | Overloaded.
RenderErrorPage | Renders an error page when an unhandled exception is encountered. (Inherited from AbstractBasePage.)
RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetFocus | Overloaded.
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Validate | Overloaded.
VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
XPath | Overloaded.
XPathSelect | Overloaded.

Explicit Interface Implementations

Name | Description
IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
IFilterResolutionService..::.CompareFilters | (Inherited from TemplateControl.)
IFilterResolutionService..::.EvaluateFilter | (Inherited from TemplateControl.)
IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)

See Also

WSRPBasePage Class
BEA.ALI.Web.UI Namespace


AddOnPreRenderCompleteAsync Method

[image]

WebCenter Portlet API for .NET Library
WSRPBasePage..::.AddOnPreRenderCompleteAsync Method
WSRPBasePage Class See Also Send Feedback

Overload List

Name | Description
AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)

See Also

WSRPBasePage Class
WSRPBasePage Members
BEA.ALI.Web.UI Namespace


DataBind Method

[image]

WebCenter Portlet API for .NET Library
WSRPBasePage..::.DataBind Method
WSRPBasePage Class See Also Send Feedback

Overload List

Name | Description
DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

WSRPBasePage Class
WSRPBasePage Members
BEA.ALI.Web.UI Namespace


Eval Method

[image]

WebCenter Portlet API for .NET Library
WSRPBasePage..::.Eval Method
WSRPBasePage Class See Also Send Feedback

Overload List

Name | Description
Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)

See Also

WSRPBasePage Class
WSRPBasePage Members
BEA.ALI.Web.UI Namespace


FindControl Method

[image]

WebCenter Portlet API for .NET Library
WSRPBasePage..::.FindControl Method
WSRPBasePage Class See Also Send Feedback

Overload List

Name | Description
FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)

See Also

WSRPBasePage Class
WSRPBasePage Members
BEA.ALI.Web.UI Namespace


GetGlobalResourceObject Method

[image]

WebCenter Portlet API for .NET Library
WSRPBasePage..::.GetGlobalResourceObject Method
WSRPBasePage Class See Also Send Feedback

Overload List

Name | Description
GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)

See Also

WSRPBasePage Class
WSRPBasePage Members
BEA.ALI.Web.UI Namespace


GetLocalResourceObject Method

[image]

WebCenter Portlet API for .NET Library
WSRPBasePage..::.GetLocalResourceObject Method
WSRPBasePage Class See Also Send Feedback

Overload List

Name | Description
GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)

See Also

WSRPBasePage Class
WSRPBasePage Members
BEA.ALI.Web.UI Namespace


GetPostBackEventReference Method

[image]

WebCenter Portlet API for .NET Library
WSRPBasePage..::.GetPostBackEventReference Method
WSRPBasePage Class See Also Send Feedback

Overload List

Name | Description
GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)

See Also

WSRPBasePage Class
WSRPBasePage Members
BEA.ALI.Web.UI Namespace


InitOutputCache Method

[image]

WebCenter Portlet API for .NET Library
WSRPBasePage..::.InitOutputCache Method
WSRPBasePage Class See Also Send Feedback

Overload List

Name | Description
InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)

See Also

WSRPBasePage Class
WSRPBasePage Members
BEA.ALI.Web.UI Namespace


LoadControl Method

[image]

WebCenter Portlet API for .NET Library
WSRPBasePage..::.LoadControl Method
WSRPBasePage Class See Also Send Feedback

Overload List

Name | Description
LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)

See Also

WSRPBasePage Class
WSRPBasePage Members
BEA.ALI.Web.UI Namespace


OnError Method

WSRPBasePage..::.OnError Method
WSRPBasePage Class See Also Send Feedback
Capture ASP.NET page errors and route them through our custom error reporting handler.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected override void OnError(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs
The EventArgs object that contains the event data.

See Also

WSRPBasePage Class
BEA.ALI.Web.UI Namespace


OnInit Method

WSRPBasePage..::.OnInit Method
WSRPBasePage Class See Also Send Feedback
Called each time this page is hit by a user. Initializes the page for use.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected override void OnInit(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs
The EventArgs object that contains the event data.

See Also

WSRPBasePage Class
BEA.ALI.Web.UI Namespace


OnUnload Method

WSRPBasePage..::.OnUnload Method
WSRPBasePage Class See Also Send Feedback
Raises the Unload event. See Page.OnUnload

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected override void OnUnload(
    EventArgs e
)

Parameters

e
Type: System..::.EventArgs
An EventArgs object that contains event data.

See Also

WSRPBasePage Class
BEA.ALI.Web.UI Namespace


RenderControl Method

[image]

WebCenter Portlet API for .NET Library
WSRPBasePage..::.RenderControl Method
WSRPBasePage Class See Also Send Feedback

Overload List

Name | Description
RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

WSRPBasePage Class
WSRPBasePage Members
BEA.ALI.Web.UI Namespace


SetFocus Method

[image]

WebCenter Portlet API for .NET Library
WSRPBasePage..::.SetFocus Method
WSRPBasePage Class See Also Send Feedback

Overload List

Name | Description
SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)

See Also

WSRPBasePage Class
WSRPBasePage Members
BEA.ALI.Web.UI Namespace


Validate Method

[image]

WebCenter Portlet API for .NET Library
WSRPBasePage..::.Validate Method
WSRPBasePage Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)

See Also

WSRPBasePage Class
WSRPBasePage Members
BEA.ALI.Web.UI Namespace


XPath Method

[image]

WebCenter Portlet API for .NET Library
WSRPBasePage..::.XPath Method
WSRPBasePage Class See Also Send Feedback

Overload List

Name | Description
XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)

See Also

WSRPBasePage Class
WSRPBasePage Members
BEA.ALI.Web.UI Namespace


XPathSelect Method

[image]

WebCenter Portlet API for .NET Library
WSRPBasePage..::.XPathSelect Method
WSRPBasePage Class See Also Send Feedback

Overload List

Name | Description
XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

See Also

WSRPBasePage Class
WSRPBasePage Members
BEA.ALI.Web.UI Namespace


WSRPBasePage Properties

[image]

WebCenter Portlet API for .NET Library
WSRPBasePage Properties
WSRPBasePage Class See Also Send Feedback

The WSRPBasePage type exposes the following members.

Properties

Name | Description
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
EnableEventValidation | (Inherited from Page.)
EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Form | Gets the HTML form for the page. (Inherited from Page.)
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Items | Gets a list of objects stored in the page context. (Inherited from Page.)
LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Title | Gets or sets the title for the page. (Inherited from Page.)
Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
User | Gets the PortletUser object for who is requesting the page.
Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)

Explicit Interface Implementations

Name | Description
IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
IExpressionsAccessor..::.Expressions | (Inherited from Control.)
IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

WSRPBasePage Class
BEA.ALI.Web.UI Namespace


User Property

WSRPBasePage..::.User Property
WSRPBasePage Class See Also Send Feedback
Gets the PortletUser object for who is requesting the page.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public WSRPPortletUser User { get; }

See Also

WSRPBasePage Class
BEA.ALI.Web.UI Namespace


WSRPBasePage.PortletStateValueAttribute Class

WSRPBasePage..::.PortletStateValueAttribute Class
WSRPBasePage Class Members Example See Also Send Feedback
Place on a BEA page field to mark it as a portlet state value.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
[AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple = false)]
[ObsoleteAttribute("Use PortletPropertyAtttribute instead.")]
public class PortletStateValueAttribute : PortletPropertyAttribute

Remarks

Portlet state is specific to a portlet object. Portlet state can be adjusted by anyone.

Examples

[PortletStateValue()]
[PortletStateValue(Key = "MyPortletPref")]
[PortletStateValue(Key = "MyPortletPref", DefaultValue = "MyVal")]
private string MyPortletProp;
    ...

Inheritance Hierarchy

System..::.Object
System..::.Attribute
BEA.Portlet..::.PortletFieldAttribute
BEA.Portlet..::.PreferenceAttribute
BEA.Portlet.WSRP..::.PortletPropertyAttribute
BEA.ALI.Web.UI..::.WSRPBasePage..::.PortletStateValueAttribute

See Also

WSRPBasePage..::.PortletStateValueAttribute Members
BEA.ALI.Web.UI Namespace


WSRPBasePage.PortletStateValueAttribute Members

[image]

WebCenter Portlet API for .NET Library
WSRPBasePage..::.PortletStateValueAttribute Members
WSRPBasePage..::.PortletStateValueAttribute Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The WSRPBasePage provides the base class for all of the Portlet API WSRP Pages for use with a WSRP Portal. It creates the IDK User object, and provides property access to the hybrid User.

Developers should never extend this class directly. Instead extend WSRPPortletPage.

The WSRPBasePage..::.PortletStateValueAttribute type exposes the following members.

Constructors

Name | Description
WSRPBasePage..::.PortletStateValueAttribute | Creates a PortletStateValueAttribute for a field.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Provides a hashcode unique for the PreferenceAttribute type and key. (Inherited from PreferenceAttribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init | Initializes the preference attribute so that it can handle registration for lifecycle events. (Inherited from PreferenceAttribute.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
LoadValue | Sets the value of the field from the preference values in the IPortletRequest. (Inherited from PreferenceAttribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overrides ToString() to provide a meaningful representation of the PreferenceAttribute type and key. (Inherited from PreferenceAttribute.)
UnloadValue | Writes the value of the field to the preference in the IPortletResponse. (Inherited from PreferenceAttribute.)

Fields

Name | Description
_field | The FieldInfo provided during Init. (Inherited from PortletFieldAttribute.)
_isInitialized | Returns trueTruetruetrue (True in Visual Basic) if Init has has been called. falseFalsefalsefalse (False in Visual Basic) otherwise. (Inherited from PortletFieldAttribute.)
_log | The WCI logger class to trace messages within this class. (Inherited from PortletFieldAttribute.)
_page | The page provided during Init. (Inherited from PortletFieldAttribute.)
_portletContext | The portlet context provided during Init. (Inherited from PortletFieldAttribute.)
_type | The SettingType of the PreferenceAttribute. (Inherited from PreferenceAttribute.)

Properties

Name | Description
Default | Returns a fallback default value base upon the field type if none was provided. (Inherited from PreferenceAttribute.)
DefaultValue | Gets or sets the default value of the preference. This is the value when running outside a portal or when no other value has been assigned. (Inherited from PreferenceAttribute.)
Key | Gets or sets the preference key. (Inherited from PreferenceAttribute.)
PreferenceCollection | Internal PreferenceCollection used to read and write the underlying preference values. (Inherited from PortletPropertyAttribute.)
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

WSRPBasePage..::.PortletStateValueAttribute Class
BEA.ALI.Web.UI Namespace


WSRPBasePage.PortletStateValueAttribute Constructor

WSRPBasePage..::.PortletStateValueAttribute Constructor
WSRPBasePage..::.PortletStateValueAttribute Class See Also Send Feedback
Creates a PortletStateValueAttribute for a field.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public PortletStateValueAttribute()

See Also

WSRPBasePage..::.PortletStateValueAttribute Class
BEA.ALI.Web.UI Namespace


WSRPPortletPage Class

WSRPPortletPage Class
Members See Also Send Feedback
WSRPPortletPage is the base class to extend for all portlet content pages built for use in a WLP Portal.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
[ObsoleteAttribute("Use the WSRPPortletContext object to access portlet information instead of extending the WSRPortletPage.")]
public abstract class WSRPPortletPage : WSRPBasePage

Inheritance Hierarchy

System..::.Object
System.Web.UI..::.Control
System.Web.UI..::.TemplateControl
System.Web.UI..::.Page
BEA.ALI.Web.UI..::.AbstractBasePage
BEA.ALI.Web.UI..::.WSRPBasePage
BEA.ALI.Web.UI..::.WSRPPortletPage

See Also

WSRPPortletPage Members
BEA.ALI.Web.UI Namespace


WSRPPortletPage Members

[image]

WebCenter Portlet API for .NET Library
WSRPPortletPage Members
WSRPPortletPage Class Constructors Methods Fields Properties Events Explicit Interface Implementations See Also Send Feedback

The WSRPPortletPage type exposes the following members.

Constructors

Name | Description
WSRPPortletPage | Constructs a new WSRPPortletPage.

Methods

Name | Description
AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
AddOnPreRenderCompleteAsync | Overloaded.
AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Construct | Performs design-time logic. (Inherited from TemplateControl.)
CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
DataBind | Overloaded.
DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Eval | Overloaded.
ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindControl | Overloaded.
Focus | Sets input focus to a control. (Inherited from Control.)
FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
GetGlobalResourceObject | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLocalResourceObject | Overloaded.
GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
GetPostBackEventReference | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
InitOutputCache | Overloaded.
IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
LoadControl | Overloaded.
LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState()()() method. (Inherited from Control.)
LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState()()() method. (Inherited from Control.)
MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
OnError | Capture ASP.NET page errors and route them through our custom error reporting handler. (Inherited from WSRPBasePage.)
OnInit | Called each time this page is hit by a user. Initializes the page for use. (Inherited from WSRPBasePage.)
OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
OnLoad | Raises the Load event. (Inherited from Control.)
OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
OnPreRender | Raises the PreRender event. (Inherited from Control.)
OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
OnUnload | Raises the Unload event. See Page.OnUnload (Inherited from WSRPBasePage.)
OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
ParseControl | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
ProcessRequest | Sets the intrinsics of the Page, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
ReadStringResource | Reads a string resource. The ReadStringResource()()() method is not intended for use from within your code. (Inherited from TemplateControl.)
RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
RemovedControl | Called after a control is removed from the Controls collection of another control. (Inherited from Control.)
Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
RenderControl | Overloaded.
RenderErrorPage | Renders an error page when an unhandled exception is encountered. (Inherited from AbstractBasePage.)
RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
SetFocus | Overloaded.
SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Validate | Overloaded.
VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
XPath | Overloaded.
XPathSelect | Overloaded.

Fields

Name | Description
m_log | The WCI logger class to trace messages within this class. (Inherited from AbstractBasePage.)
m_portletContext | This is the IDK context. We store it to get values from it if the user requests them. (Inherited from AbstractBasePage.)
m_portletRequest | The IDK portlet request. (Inherited from AbstractBasePage.)
m_portletResponse | The IDK portlet response. (Inherited from AbstractBasePage.)
m_portletUser | The IDK portlet user. (Inherited from AbstractBasePage.)
PortletStateValues | Indexer of portlet properties. (Inherited from WSRPBasePage.)

Properties

Name | Description
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
EnableEventValidation | (Inherited from Page.)
EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Form | Gets the HTML form for the page. (Inherited from Page.)
Handle | Gets the WSRP portlet handle.
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Items | Gets a list of objects stored in the page context. (Inherited from Page.)
LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Title | Gets or sets the title for the page. (Inherited from Page.)
Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
User | Gets the PortletUser object for who is requesting the page. (Inherited from WSRPBasePage.)
Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)

Events

Name | Description
AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
PreLoad | Occurs before the page Load event. (Inherited from Page.)
PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)

Explicit Interface Implementations

Name | Description
IParserAccessor..::.AddParsedSubObject | (Inherited from Control.)
IFilterResolutionService..::.CompareFilters | (Inherited from TemplateControl.)
IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
IFilterResolutionService..::.EvaluateFilter | (Inherited from TemplateControl.)
IExpressionsAccessor..::.Expressions | (Inherited from Control.)
IControlDesignerAccessor..::.GetDesignModeState | (Inherited from Control.)
IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
IControlDesignerAccessor..::.SetDesignModeState | (Inherited from Control.)
IControlDesignerAccessor..::.SetOwnerControl | (Inherited from Control.)
IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

WSRPPortletPage Class
BEA.ALI.Web.UI Namespace


WSRPPortletPage Constructor

WSRPPortletPage Constructor
WSRPPortletPage Class See Also Send Feedback
Constructs a new WSRPPortletPage.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public WSRPPortletPage()

See Also

WSRPPortletPage Class
BEA.ALI.Web.UI Namespace


WSRPPortletPage Properties

[image]

WebCenter Portlet API for .NET Library
WSRPPortletPage Properties
WSRPPortletPage Class See Also Send Feedback

The WSRPPortletPage type exposes the following members.

Properties

Name | Description
Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
ClientID | Gets the server control identifier generated by ASP.NET. (Inherited from Control.)
ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
EnableEventValidation | (Inherited from Page.)
EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should run a message authentication check (MAC) on the page's view state when the page is posted back from the client. (Inherited from Page.)
ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Form | Gets the HTML form for the page. (Inherited from Page.)
Handle | Gets the WSRP portlet handle.
HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
IsCallback | Gets a value indicating whether the page request is the result of a call back. (Inherited from Page.)
IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
IsPostBack | Gets a value indicating whether the page is being loaded in response to a client postback, or if it is being loaded and accessed for the first time. (Inherited from Page.)
IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Items | Gets a list of objects stored in the page context. (Inherited from Page.)
LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. (Inherited from Page.)
Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
MasterPageFile | Gets or sets the file name of the master page. (Inherited from Page.)
MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. (Inherited from Page.)
StyleSheetTheme | Gets or sets the name of the style sheet applied to this page. (Inherited from Page.)
SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Title | Gets or sets the title for the page. (Inherited from Page.)
Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
User | Gets the PortletUser object for who is requesting the page. (Inherited from WSRPBasePage.)
Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)

Explicit Interface Implementations

Name | Description
IControlBuilderAccessor..::.ControlBuilder | (Inherited from Control.)
IDataBindingsAccessor..::.DataBindings | (Inherited from Control.)
IExpressionsAccessor..::.Expressions | (Inherited from Control.)
IDataBindingsAccessor..::.HasDataBindings | (Inherited from Control.)
IExpressionsAccessor..::.HasExpressions | (Inherited from Control.)
IControlDesignerAccessor..::.UserData | (Inherited from Control.)

See Also

WSRPPortletPage Class
BEA.ALI.Web.UI Namespace


Handle Property

WSRPPortletPage..::.Handle Property
WSRPPortletPage Class See Also Send Feedback
Gets the WSRP portlet handle.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string Handle { get; }

See Also

WSRPPortletPage Class
BEA.ALI.Web.UI Namespace


WSRPPortletUser Class

WSRPPortletUser Class
Members See Also Send Feedback
WSRPPortletUser implements IPrincipal and adds additional User information that comes specifically from a WSRP Consumer. portal.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public class WSRPPortletUser : IPrincipal

Inheritance Hierarchy

System..::.Object
BEA.ALI.Web.UI..::.WSRPPortletUser

See Also

WSRPPortletUser Members
BEA.ALI.Web.UI Namespace


WSRPPortletUser Members

[image]

WebCenter Portlet API for .NET Library
WSRPPortletUser Members
WSRPPortletUser Class Methods Fields Properties See Also Send Feedback

The WSRPPortletUser type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsInRole | Determines whether the current principal belongs to the specified role.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
m_aspUser | Standard ASP .Net User.
m_page | WLP's Request object for the given page visit.
m_portletUser | BEA's User object for the given HTTP User to a Portlet.

Properties

Name | Description
Identity | Gets the identity of the current principal.
SAMLToken | Gets an XmlElement representing a SAML token for the user. If not used in a WSRP Consumer, or a SAML token was not sent by the Consumer, then nullNothingnullptra null reference (Nothing in Visual Basic) is returned.

See Also

WSRPPortletUser Class
BEA.ALI.Web.UI Namespace


WSRPPortletUser Fields

[image]

WebCenter Portlet API for .NET Library
WSRPPortletUser Fields
WSRPPortletUser Class See Also Send Feedback

The WSRPPortletUser type exposes the following members.

Fields

Name | Description
m_aspUser | Standard ASP .Net User.
m_page | WLP's Request object for the given page visit.
m_portletUser | BEA's User object for the given HTTP User to a Portlet.

See Also

WSRPPortletUser Class
BEA.ALI.Web.UI Namespace


m_aspUser Field

WSRPPortletUser..::.m_aspUser Field
WSRPPortletUser Class See Also Send Feedback
Standard ASP .Net User.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected IPrincipal m_aspUser

See Also

WSRPPortletUser Class
BEA.ALI.Web.UI Namespace


m_page Field

WSRPPortletUser..::.m_page Field
WSRPPortletUser Class See Also Send Feedback
WLP's Request object for the given page visit.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected AbstractBasePage m_page

See Also

WSRPPortletUser Class
BEA.ALI.Web.UI Namespace


m_portletUser Field

WSRPPortletUser..::.m_portletUser Field
WSRPPortletUser Class See Also Send Feedback
BEA's User object for the given HTTP User to a Portlet.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected IPortletUser m_portletUser

See Also

WSRPPortletUser Class
BEA.ALI.Web.UI Namespace


WSRPPortletUser Methods

[image]

WebCenter Portlet API for .NET Library
WSRPPortletUser Methods
WSRPPortletUser Class See Also Send Feedback

The WSRPPortletUser type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsInRole | Determines whether the current principal belongs to the specified role.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WSRPPortletUser Class
BEA.ALI.Web.UI Namespace


IsInRole Method

WSRPPortletUser..::.IsInRole Method
WSRPPortletUser Class See Also Send Feedback
Determines whether the current principal belongs to the specified role.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool IsInRole(
    string role
)

Parameters

role
Type: System..::.String

Implements

IPrincipal..::.IsInRole(String)

Remarks

IsInRole(String)

See Also

WSRPPortletUser Class
BEA.ALI.Web.UI Namespace


WSRPPortletUser Properties

[image]

WebCenter Portlet API for .NET Library
WSRPPortletUser Properties
WSRPPortletUser Class See Also Send Feedback

The WSRPPortletUser type exposes the following members.

Properties

Name | Description
Identity | Gets the identity of the current principal.
SAMLToken | Gets an XmlElement representing a SAML token for the user. If not used in a WSRP Consumer, or a SAML token was not sent by the Consumer, then nullNothingnullptra null reference (Nothing in Visual Basic) is returned.

See Also

WSRPPortletUser Class
BEA.ALI.Web.UI Namespace


Identity Property

WSRPPortletUser..::.Identity Property
WSRPPortletUser Class See Also Send Feedback
Gets the identity of the current principal.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public IIdentity Identity { get; }

Implements

IPrincipal..::.Identity

Remarks

Identity

See Also

WSRPPortletUser Class
BEA.ALI.Web.UI Namespace


SAMLToken Property

WSRPPortletUser..::.SAMLToken Property
WSRPPortletUser Class See Also Send Feedback
Gets an XmlElement representing a SAML token for the user. If not used in a WSRP Consumer, or a SAML token was not sent by the Consumer, then nullNothingnullptra null reference (Nothing in Visual Basic) is returned.

Namespace: BEA.ALI.Web.UI
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public XmlElement SAMLToken { get; }

See Also

WSRPPortletUser Class
BEA.ALI.Web.UI Namespace


BEA.Portlet Namespace

BEA.Portlet Namespace
Send Feedback
The BEA.Portlet namespace contains base classes and objects used for building ASP.NET portlets for either WCI or WSRP aggregators.

Classes

Class | Description
FieldAttributeTypeAttribute | Indicates the allowed type of a member to which a portlet field attribute may be applied. This class supports the .NET Portlet API and is not intended for external use.
PortletFieldAttribute | Base class used for attributes applied to portlet fields. This class supports the .NET Portlet API and is not intended for external use.
PreferenceAttribute | Binds a non-private page field to a preference value. The PreferenceAttribute class is abstract, and not intended for use by external consumers. Instead use one of the classes derived from PreferenceAttribute.
PreferenceCollection | Represents a pseudo collection of preferences of a specific type. Exposes an indexer property for easy access to the underlying IDK settings collections.


FieldAttributeTypeAttribute Class

FieldAttributeTypeAttribute Class
Members See Also Send Feedback
Indicates the allowed type of a member to which a portlet field attribute may be applied. This class supports the .NET Portlet API and is not intended for external use.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = true)]
public class FieldAttributeTypeAttribute : Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
BEA.Portlet..::.FieldAttributeTypeAttribute

See Also

FieldAttributeTypeAttribute Members
BEA.Portlet Namespace


FieldAttributeTypeAttribute Members

[image]

WebCenter Portlet API for .NET Library
FieldAttributeTypeAttribute Members
FieldAttributeTypeAttribute Class Constructors Methods Properties Explicit Interface Implementations See Also Send Feedback

The FieldAttributeTypeAttribute type exposes the following members.

Constructors

Name | Description
FieldAttributeTypeAttribute | Creates a FieldAttributeTypeAttribute that indicates support for a specific type.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Type | Gets the supported type.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

FieldAttributeTypeAttribute Class
BEA.Portlet Namespace


FieldAttributeTypeAttribute Constructor

FieldAttributeTypeAttribute Constructor
FieldAttributeTypeAttribute Class See Also Send Feedback
Creates a FieldAttributeTypeAttribute that indicates support for a specific type.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public FieldAttributeTypeAttribute(
    Type type
)

Parameters

type
Type: System..::.Type
The type the FieldAttributeTypeAttribute for which the FieldAttributeTypeAttribute indicates support.

See Also

FieldAttributeTypeAttribute Class
BEA.Portlet Namespace


FieldAttributeTypeAttribute Properties

[image]

WebCenter Portlet API for .NET Library
FieldAttributeTypeAttribute Properties
FieldAttributeTypeAttribute Class See Also Send Feedback

The FieldAttributeTypeAttribute type exposes the following members.

Properties

Name | Description
Type | Gets the supported type.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

FieldAttributeTypeAttribute Class
BEA.Portlet Namespace


Type Property

FieldAttributeTypeAttribute..::.Type Property
FieldAttributeTypeAttribute Class See Also Send Feedback
Gets the supported type.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Type Type { get; }

Field Value

The supported Type.

See Also

FieldAttributeTypeAttribute Class
BEA.Portlet Namespace


PortletFieldAttribute Class

PortletFieldAttribute Class
Members See Also Send Feedback
Base class used for attributes applied to portlet fields. This class supports the .NET Portlet API and is not intended for external use.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
[AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple = false)]
public abstract class PortletFieldAttribute : Attribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
BEA.Portlet..::.PortletFieldAttribute
BEA.Portlet..::.PreferenceAttribute
BEA.Portlet.WSRP..::.RegistrationPropertyAttribute

See Also

PortletFieldAttribute Members
BEA.Portlet Namespace


PortletFieldAttribute Members

[image]

WebCenter Portlet API for .NET Library
PortletFieldAttribute Members
PortletFieldAttribute Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The PortletFieldAttribute type exposes the following members.

Constructors

Name | Description
PortletFieldAttribute |

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init | Initializes the field attribute so that it can handle registration for lifecycle events.
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
LoadValue | Called when the page is loading to load the value into the portlet field.
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnloadValue | Called to unload the value from the portlet field.

Fields

Name | Description
_field | The FieldInfo provided during Init.
_isInitialized | Returns trueTruetruetrue (True in Visual Basic) if Init has has been called. falseFalsefalsefalse (False in Visual Basic) otherwise.
_log | The WCI logger class to trace messages within this class.
_page | The page provided during Init.
_portletContext | The portlet context provided during Init.

Properties

Name | Description
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

PortletFieldAttribute Class
BEA.Portlet Namespace


PortletFieldAttribute Constructor

PortletFieldAttribute Constructor
PortletFieldAttribute Class See Also Send Feedback
Initializes a new instance of the PortletFieldAttribute class.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected PortletFieldAttribute()

See Also

PortletFieldAttribute Class
BEA.Portlet Namespace


PortletFieldAttribute Fields

[image]

WebCenter Portlet API for .NET Library
PortletFieldAttribute Fields
PortletFieldAttribute Class See Also Send Feedback

The PortletFieldAttribute type exposes the following members.

Fields

Name | Description
_field | The FieldInfo provided during Init.
_isInitialized | Returns trueTruetruetrue (True in Visual Basic) if Init has has been called. falseFalsefalsefalse (False in Visual Basic) otherwise.
_log | The WCI logger class to trace messages within this class.
_page | The page provided during Init.
_portletContext | The portlet context provided during Init.

See Also

PortletFieldAttribute Class
BEA.Portlet Namespace


_field Field

PortletFieldAttribute..::._field Field
PortletFieldAttribute Class See Also Send Feedback
The FieldInfo provided during Init.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected FieldInfo _field

See Also

PortletFieldAttribute Class
BEA.Portlet Namespace


_isInitialized Field

PortletFieldAttribute..::._isInitialized Field
PortletFieldAttribute Class See Also Send Feedback
Returns trueTruetruetrue (True in Visual Basic) if Init has has been called. falseFalsefalsefalse (False in Visual Basic) otherwise.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected bool _isInitialized

See Also

PortletFieldAttribute Class
BEA.Portlet Namespace


_log Field

PortletFieldAttribute..::._log Field
PortletFieldAttribute Class See Also Send Feedback
The WCI logger class to trace messages within this class.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected ILogger _log

See Also

PortletFieldAttribute Class
BEA.Portlet Namespace


_page Field

PortletFieldAttribute..::._page Field
PortletFieldAttribute Class See Also Send Feedback
The page provided during Init.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected Page _page

See Also

PortletFieldAttribute Class
BEA.Portlet Namespace


_portletContext Field

PortletFieldAttribute..::._portletContext Field
PortletFieldAttribute Class See Also Send Feedback
The portlet context provided during Init.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected IPortletContext _portletContext

See Also

PortletFieldAttribute Class
BEA.Portlet Namespace


PortletFieldAttribute Methods

[image]

WebCenter Portlet API for .NET Library
PortletFieldAttribute Methods
PortletFieldAttribute Class See Also Send Feedback

The PortletFieldAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init | Initializes the field attribute so that it can handle registration for lifecycle events.
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
LoadValue | Called when the page is loading to load the value into the portlet field.
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UnloadValue | Called to unload the value from the portlet field.

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

PortletFieldAttribute Class
BEA.Portlet Namespace


Init Method

PortletFieldAttribute..::.Init Method
PortletFieldAttribute Class See Also Send Feedback
Initializes the field attribute so that it can handle registration for lifecycle events.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public virtual void Init(
    FieldInfo Field,
    Page Page,
    IPortletContext PortletContext
)

Parameters

Field
Type: System.Reflection..::.FieldInfo
The FieldInfo for the field to which the attribute is applied.
Page
Type: System.Web.UI..::.Page
The Page on which the field is declared.
PortletContext
Type: IPortletContext
The IDK PortletContext for the request.

Exceptions

Exception | Condition
System..::.ArgumentException | The attribute has been applied to field with a type that is not supported.

See Also

PortletFieldAttribute Class
BEA.Portlet Namespace


LoadValue Method

PortletFieldAttribute..::.LoadValue Method
PortletFieldAttribute Class See Also Send Feedback
Called when the page is loading to load the value into the portlet field.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected virtual void LoadValue(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: System..::.EventArgs
An EventArgs that contains no event data.

See Also

PortletFieldAttribute Class
BEA.Portlet Namespace


UnloadValue Method

PortletFieldAttribute..::.UnloadValue Method
PortletFieldAttribute Class See Also Send Feedback
Called to unload the value from the portlet field.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected virtual void UnloadValue(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: System..::.EventArgs
An EventArgs that contains no event data.

See Also

PortletFieldAttribute Class
BEA.Portlet Namespace


PreferenceAttribute Class

PreferenceAttribute Class
Members See Also Send Feedback
Binds a non-private page field to a preference value. The PreferenceAttribute class is abstract, and not intended for use by external consumers. Instead use one of the classes derived from PreferenceAttribute.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
[FieldAttributeTypeAttribute(typeof(long))]
[FieldAttributeTypeAttribute(typeof(int))]
[FieldAttributeTypeAttribute(typeof(bool))]
[FieldAttributeTypeAttribute(typeof(DateTime))]
[FieldAttributeTypeAttribute(typeof(double))]
[FieldAttributeTypeAttribute(typeof(float))]
[FieldAttributeTypeAttribute(typeof(string))]
public abstract class PreferenceAttribute : PortletFieldAttribute

Inheritance Hierarchy

System..::.Object
System..::.Attribute
BEA.Portlet..::.PortletFieldAttribute
BEA.Portlet..::.PreferenceAttribute
BEA.ALI.Web..::.ALIPreferenceAttribute
BEA.Portlet.WSRP..::.PortletPropertyAttribute

See Also

PreferenceAttribute Members
BEA.Portlet Namespace


PreferenceAttribute Members

[image]

WebCenter Portlet API for .NET Library
PreferenceAttribute Members
PreferenceAttribute Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The PreferenceAttribute type exposes the following members.

Constructors

Name | Description
PreferenceAttribute | Specifies a preference for the page.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Provides a hashcode unique for the PreferenceAttribute type and key. (Overrides Attribute ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init | Initializes the preference attribute so that it can handle registration for lifecycle events. (Overrides PortletFieldAttribute ..::. Init(FieldInfo, Page, IPortletContext).)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
LoadValue | Sets the value of the field from the preference values in the IPortletRequest. (Overrides PortletFieldAttribute ..::. LoadValue(Object, EventArgs).)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overrides ToString() to provide a meaningful representation of the PreferenceAttribute type and key. (Overrides Object ..::. ToString()()().)
UnloadValue | Writes the value of the field to the preference in the IPortletResponse. (Overrides PortletFieldAttribute ..::. UnloadValue(Object, EventArgs).)

Fields

Name | Description
_field | The FieldInfo provided during Init. (Inherited from PortletFieldAttribute.)
_isInitialized | Returns trueTruetruetrue (True in Visual Basic) if Init has has been called. falseFalsefalsefalse (False in Visual Basic) otherwise. (Inherited from PortletFieldAttribute.)
_log | The WCI logger class to trace messages within this class. (Inherited from PortletFieldAttribute.)
_page | The page provided during Init. (Inherited from PortletFieldAttribute.)
_portletContext | The portlet context provided during Init. (Inherited from PortletFieldAttribute.)
_type | The SettingType of the PreferenceAttribute.

Properties

Name | Description
Default | Returns a fallback default value base upon the field type if none was provided.
DefaultValue | Gets or sets the default value of the preference. This is the value when running outside a portal or when no other value has been assigned.
Key | Gets or sets the preference key.
PreferenceCollection | Abstract factory method that provides the preference collection used to get and set preference values.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

PreferenceAttribute Class
BEA.Portlet Namespace


PreferenceAttribute Constructor

PreferenceAttribute Constructor
PreferenceAttribute Class See Also Send Feedback
Specifies a preference for the page.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public PreferenceAttribute()

See Also

PreferenceAttribute Class
BEA.Portlet Namespace


PreferenceAttribute Fields

[image]

WebCenter Portlet API for .NET Library
PreferenceAttribute Fields
PreferenceAttribute Class See Also Send Feedback

The PreferenceAttribute type exposes the following members.

Fields

Name | Description
_field | The FieldInfo provided during Init. (Inherited from PortletFieldAttribute.)
_isInitialized | Returns trueTruetruetrue (True in Visual Basic) if Init has has been called. falseFalsefalsefalse (False in Visual Basic) otherwise. (Inherited from PortletFieldAttribute.)
_log | The WCI logger class to trace messages within this class. (Inherited from PortletFieldAttribute.)
_page | The page provided during Init. (Inherited from PortletFieldAttribute.)
_portletContext | The portlet context provided during Init. (Inherited from PortletFieldAttribute.)
_type | The SettingType of the PreferenceAttribute.

See Also

PreferenceAttribute Class
BEA.Portlet Namespace


_type Field

PreferenceAttribute..::._type Field
PreferenceAttribute Class See Also Send Feedback
The SettingType of the PreferenceAttribute.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected SettingType _type

See Also

PreferenceAttribute Class
BEA.Portlet Namespace


PreferenceAttribute Methods

[image]

WebCenter Portlet API for .NET Library
PreferenceAttribute Methods
PreferenceAttribute Class See Also Send Feedback

The PreferenceAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Provides a hashcode unique for the PreferenceAttribute type and key. (Overrides Attribute ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init | Initializes the preference attribute so that it can handle registration for lifecycle events. (Overrides PortletFieldAttribute ..::. Init(FieldInfo, Page, IPortletContext).)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
LoadValue | Sets the value of the field from the preference values in the IPortletRequest. (Overrides PortletFieldAttribute ..::. LoadValue(Object, EventArgs).)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overrides ToString() to provide a meaningful representation of the PreferenceAttribute type and key. (Overrides Object ..::. ToString()()().)
UnloadValue | Writes the value of the field to the preference in the IPortletResponse. (Overrides PortletFieldAttribute ..::. UnloadValue(Object, EventArgs).)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

PreferenceAttribute Class
BEA.Portlet Namespace


GetHashCode Method

PreferenceAttribute..::.GetHashCode Method
PreferenceAttribute Class See Also Send Feedback
Provides a hashcode unique for the PreferenceAttribute type and key.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public override int GetHashCode()

Return Value

A hashcode unique for the preference type and key.

See Also

PreferenceAttribute Class
BEA.Portlet Namespace


Init Method

PreferenceAttribute..::.Init Method
PreferenceAttribute Class See Also Send Feedback
Initializes the preference attribute so that it can handle registration for lifecycle events.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public override void Init(
    FieldInfo Field,
    Page Page,
    IPortletContext PortletContext
)

Parameters

Field
Type: System.Reflection..::.FieldInfo
The FieldInfo for the field to which the attribute is applied.
Page
Type: System.Web.UI..::.Page
The Page on which the field is declared.
PortletContext
Type: IPortletContext
The IDK PortletContext for the request.

Exceptions

Exception | Condition
System..::.ArgumentException | The attribute has been applied to field with a type that is not supported.

See Also

PreferenceAttribute Class
BEA.Portlet Namespace


LoadValue Method

PreferenceAttribute..::.LoadValue Method
PreferenceAttribute Class See Also Send Feedback
Sets the value of the field from the preference values in the IPortletRequest.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected override void LoadValue(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

PreferenceAttribute Class
BEA.Portlet Namespace


ToString Method

PreferenceAttribute..::.ToString Method
PreferenceAttribute Class See Also Send Feedback
Overrides ToString() to provide a meaningful representation of the PreferenceAttribute type and key.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public override string ToString()

Return Value

String representing the PreferenceAttribute type and key.

See Also

PreferenceAttribute Class
BEA.Portlet Namespace


UnloadValue Method

PreferenceAttribute..::.UnloadValue Method
PreferenceAttribute Class See Also Send Feedback
Writes the value of the field to the preference in the IPortletResponse.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected override void UnloadValue(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

PreferenceAttribute Class
BEA.Portlet Namespace


PreferenceAttribute Properties

[image]

WebCenter Portlet API for .NET Library
PreferenceAttribute Properties
PreferenceAttribute Class See Also Send Feedback

The PreferenceAttribute type exposes the following members.

Properties

Name | Description
Default | Returns a fallback default value base upon the field type if none was provided.
DefaultValue | Gets or sets the default value of the preference. This is the value when running outside a portal or when no other value has been assigned.
Key | Gets or sets the preference key.
PreferenceCollection | Abstract factory method that provides the preference collection used to get and set preference values.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

PreferenceAttribute Class
BEA.Portlet Namespace


Default Property

PreferenceAttribute..::.Default Property
PreferenceAttribute Class See Also Send Feedback
Returns a fallback default value base upon the field type if none was provided.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected virtual string Default { get; }

See Also

PreferenceAttribute Class
BEA.Portlet Namespace


DefaultValue Property

PreferenceAttribute..::.DefaultValue Property
PreferenceAttribute Class See Also Send Feedback
Gets or sets the default value of the preference. This is the value when running outside a portal or when no other value has been assigned.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Object DefaultValue { get; set; }

Field Value

The default value of the preference. The value of a preference when running outside of a portal or when no other value has been assigned.

See Also

PreferenceAttribute Class
BEA.Portlet Namespace


Key Property

PreferenceAttribute..::.Key Property
PreferenceAttribute Class See Also Send Feedback
Gets or sets the preference key.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string Key { get; set; }

Field Value

The key used for the preference.

See Also

PreferenceAttribute Class
BEA.Portlet Namespace


PreferenceCollection Property

PreferenceAttribute..::.PreferenceCollection Property
PreferenceAttribute Class See Also Send Feedback
Abstract factory method that provides the preference collection used to get and set preference values.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected abstract PreferenceCollection PreferenceCollection { get; }

See Also

PreferenceAttribute Class
BEA.Portlet Namespace


PreferenceCollection Class

PreferenceCollection Class
Members See Also Send Feedback
Represents a pseudo collection of preferences of a specific type. Exposes an indexer property for easy access to the underlying IDK settings collections.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public abstract class PreferenceCollection

Inheritance Hierarchy

System..::.Object
BEA.Portlet..::.PreferenceCollection
BEA.ALI.Web..::.ALIPreferenceCollection
BEA.Portlet.WSRP..::.PortletPropertyCollection

See Also

PreferenceCollection Members
BEA.Portlet Namespace


PreferenceCollection Members

[image]

WebCenter Portlet API for .NET Library
PreferenceCollection Members
PreferenceCollection Class Methods Fields Properties See Also Send Feedback

The PreferenceCollection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
_log | The WCI logger class to trace messages within this class.
_portletContext | The IDK IPortletContext for the current request.
_type | The SettingType of the PreferenceCollection.

Properties

Name | Description
Item | Indexer to get or set preferences. Returns null if a preference was not sent to this portlet.
Keys | Gets a ICollection of the preference keys sent in the portlet request.

See Also

PreferenceCollection Class
BEA.Portlet Namespace


PreferenceCollection Fields

[image]

WebCenter Portlet API for .NET Library
PreferenceCollection Fields
PreferenceCollection Class See Also Send Feedback

The PreferenceCollection type exposes the following members.

Fields

Name | Description
_log | The WCI logger class to trace messages within this class.
_portletContext | The IDK IPortletContext for the current request.
_type | The SettingType of the PreferenceCollection.

See Also

PreferenceCollection Class
BEA.Portlet Namespace


_log Field

PreferenceCollection..::._log Field
PreferenceCollection Class See Also Send Feedback
The WCI logger class to trace messages within this class.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected ILogger _log

See Also

PreferenceCollection Class
BEA.Portlet Namespace


_portletContext Field

PreferenceCollection..::._portletContext Field
PreferenceCollection Class See Also Send Feedback
The IDK IPortletContext for the current request.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected readonly IPortletContext _portletContext

See Also

PreferenceCollection Class
BEA.Portlet Namespace


_type Field

PreferenceCollection..::._type Field
PreferenceCollection Class See Also Send Feedback
The SettingType of the PreferenceCollection.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected SettingType _type

See Also

PreferenceCollection Class
BEA.Portlet Namespace


PreferenceCollection Properties

[image]

WebCenter Portlet API for .NET Library
PreferenceCollection Properties
PreferenceCollection Class See Also Send Feedback

The PreferenceCollection type exposes the following members.

Properties

Name | Description
Item | Indexer to get or set preferences. Returns null if a preference was not sent to this portlet.
Keys | Gets a ICollection of the preference keys sent in the portlet request.

See Also

PreferenceCollection Class
BEA.Portlet Namespace


Item Property

PreferenceCollection..::.Item Property
PreferenceCollection Class See Also Send Feedback
Indexer to get or set preferences. Returns null if a preference was not sent to this portlet.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public virtual string this[
    string preference
] { get; set; }

Parameters

preference
Type: System..::.String

Remarks

The indexer of the base PreferenceCollection reads directly from the portlet request and writes directly to the portlet response. Therefore, unless over-ridden in a derived class, values set are not available to get until a subsequent request.

If the current user does not have permission to change the property value or changes are not allowed due to the state of the portlet, the change is discarded and a warning message is logged to the WCI logging utility (Logging Spy), but no exception is thrown.

See Also

PreferenceCollection Class
BEA.Portlet Namespace


Keys Property

PreferenceCollection..::.Keys Property
PreferenceCollection Class See Also Send Feedback
Gets a ICollection of the preference keys sent in the portlet request.

Namespace: BEA.Portlet
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public virtual ICollection Keys { get; }

Remarks

This method is a wrapper around IPortletRequest.GetSettingCollection().Keys.

See Also

PreferenceCollection Class
BEA.Portlet Namespace


BEA.Portlet.WSRP Namespace

BEA.Portlet.WSRP Namespace
Send Feedback
The BEA.Portlet.WSRP namespace contains classes used when building ASP.NET portlets for WSRP aggregators.

Classes

Class | Description
PortletInfo | Runtime information and metadata about the requested portlet.
PortletPropertyAttribute | Binds a non-private page field to a portlet property.
PortletPropertyCollection | A dictionary of WSRP portlet preferences.
RegistrationInfo | Provides access to information provided by the wsrp consumer making the current request when it registered with the producer.
RegistrationPropertyAttribute | Binds a non-private page field to a registration property.
WSRPPortletContext | Provides contextual information about the current WSRP portlet request.


PortletInfo Class

PortletInfo Class
Members See Also Send Feedback
Runtime information and metadata about the requested portlet.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public class PortletInfo

Remarks

The PortletInfo object is accessed from the Portlet property of the current WSRPPortletContext.

Inheritance Hierarchy

System..::.Object
BEA.Portlet.WSRP..::.PortletInfo

See Also

PortletInfo Members
BEA.Portlet.WSRP Namespace


PortletInfo Members

[image]

WebCenter Portlet API for .NET Library
PortletInfo Members
PortletInfo Class Methods Properties See Also Send Feedback

The PortletInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Handle | Gets the WSRP Portlet handle value.
HasNewMode | Gets a value indicating if the portlet mode has been changed to a new value.
HasNewWindowState | Gets a value indicating if the window state had been changed to a new value.
Key | Gets the WSRP RuntimeContext portletInstanceKey value.
Mode | Gets the current portlet mode of the Portlet or sets a new mode. The portlet mode may only be changed during a WSRP performBlockingInteraction operation.
NamespacePrefix | Gets the WSRP RuntimeContext namespacePrefix value.
Properties | Gets the WSRP portlet properties.
WindowState | Gets the current window state of the Portlet or sets a new window state. The window state may only be changed duing a WSRP performBlockingInteraction operation.

See Also

PortletInfo Class
BEA.Portlet.WSRP Namespace


PortletInfo Properties

[image]

WebCenter Portlet API for .NET Library
PortletInfo Properties
PortletInfo Class See Also Send Feedback

The PortletInfo type exposes the following members.

Properties

Name | Description
Handle | Gets the WSRP Portlet handle value.
HasNewMode | Gets a value indicating if the portlet mode has been changed to a new value.
HasNewWindowState | Gets a value indicating if the window state had been changed to a new value.
Key | Gets the WSRP RuntimeContext portletInstanceKey value.
Mode | Gets the current portlet mode of the Portlet or sets a new mode. The portlet mode may only be changed during a WSRP performBlockingInteraction operation.
NamespacePrefix | Gets the WSRP RuntimeContext namespacePrefix value.
Properties | Gets the WSRP portlet properties.
WindowState | Gets the current window state of the Portlet or sets a new window state. The window state may only be changed duing a WSRP performBlockingInteraction operation.

See Also

PortletInfo Class
BEA.Portlet.WSRP Namespace


Handle Property

PortletInfo..::.Handle Property
PortletInfo Class See Also Send Feedback
Gets the WSRP Portlet handle value.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string Handle { get; }

Field Value

The WSRP Portlet handle value.

See Also

PortletInfo Class
BEA.Portlet.WSRP Namespace


HasNewMode Property

PortletInfo..::.HasNewMode Property
PortletInfo Class See Also Send Feedback
Gets a value indicating if the portlet mode has been changed to a new value.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool HasNewMode { get; }

Field Value

trueTruetruetrue (True in Visual Basic) if the Mode is different from the value passed to the portlet by the WSRP producer. falseFalsefalsefalse (False in Visual Basic) otherwise.

See Also

PortletInfo Class
BEA.Portlet.WSRP Namespace


HasNewWindowState Property

PortletInfo..::.HasNewWindowState Property
PortletInfo Class See Also Send Feedback
Gets a value indicating if the window state had been changed to a new value.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool HasNewWindowState { get; }

Field Value

trueTruetruetrue (True in Visual Basic) if the WindowState is different from the value passed to the portlet by the WSRP producer. falseFalsefalsefalse (False in Visual Basic) otherwise.

See Also

PortletInfo Class
BEA.Portlet.WSRP Namespace


Key Property

PortletInfo..::.Key Property
PortletInfo Class See Also Send Feedback
Gets the WSRP RuntimeContext portletInstanceKey value.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string Key { get; }

Field Value

The WSRP RuntimeContext portletInstanceKey value.

See Also

PortletInfo Class
BEA.Portlet.WSRP Namespace


Mode Property

PortletInfo..::.Mode Property
PortletInfo Class See Also Send Feedback
Gets the current portlet mode of the Portlet or sets a new mode. The portlet mode may only be changed during a WSRP performBlockingInteraction operation.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string Mode { get; set; }

Field Value

The current mode of the portlet.

Exceptions

Exception | Condition
System..::.InvalidOperationException | An attempt was made to change the portlet mode but the current request is not a WSRP performBlockingInteraction.

See Also

PortletInfo Class
BEA.Portlet.WSRP Namespace


NamespacePrefix Property

PortletInfo..::.NamespacePrefix Property
PortletInfo Class See Also Send Feedback
Gets the WSRP RuntimeContext namespacePrefix value.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string NamespacePrefix { get; }

Field Value

The WSRP RuntimeContext namespacePrefix value.

Remarks

The NamespacePrefix value is used to namespace client script function names and control id values to ensure they are unique within an aggregated page. If you use the special wsrp_rewrite_token in your client side scripts, you can use this property to construct the actual runtime name of the function or control on the server.

See Also

PortletInfo Class
BEA.Portlet.WSRP Namespace


Properties Property

PortletInfo..::.Properties Property
PortletInfo Class See Also Send Feedback
Gets the WSRP portlet properties.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public PortletPropertyCollection Properties { get; }

Field Value

The collection of properties for this portlet.

Remarks

The returned collection is live and read-write. Changes made to the collection including addition of new properties are immediately available in the ASP.NET page and are persisted to the WSRP consumer when the page request ends.

Change to the collection are avaiable to the target of Server.Transfer.

See Also

PortletInfo Class
BEA.Portlet.WSRP Namespace


WindowState Property

PortletInfo..::.WindowState Property
PortletInfo Class See Also Send Feedback
Gets the current window state of the Portlet or sets a new window state. The window state may only be changed duing a WSRP performBlockingInteraction operation.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string WindowState { get; set; }

Field Value

The WSRP window state of the portlet.

Exceptions

Exception | Condition
System..::.InvalidOperationException | An attempt was made to change the WindowState but the current request is not a WSRP performBlockingInteraction.

See Also

PortletInfo Class
BEA.Portlet.WSRP Namespace


PortletPropertyAttribute Class

PortletPropertyAttribute Class
Members Example See Also Send Feedback
Binds a non-private page field to a portlet property.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
[AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple = false)]
public class PortletPropertyAttribute : PreferenceAttribute

Remarks

Portlet properties are specific to a portlet instance.

PortletPropertyAttribute binds a local, non-private page field to a portlet property by loading the value of the property into the local field at the start of the page request andand updating the property as necessary just before the request ends. Values assigned to a local field bound with the PortletPropertyAttribute are not be updated in the PortletInfo.Properties collection until the page unloads. In general, you should not set the value of a propety using both the PortletPropertyCollection and a bound field as one the values may overwrite the other.

PortletPropertyAttribute binding does not function for pages that are the target of a Server.Transfer invocation as Server.Transfer bypasses the normal page event lifecycle. If you are using Server.Transfer, use the PortletPropertyCollection to access portlet properties instead.

Similarly, you can not use PortletPropertyAttribute binding to transfer state between pages using Server.Transfer. Instead, either use the PortletPropertyCollection or use Response.Redirect.

Examples

CopyC#
[PortletProperty()]
protected string MyPortletProp;

[PortletProperty(Key="LastAccessed")]
public DateTime lastAccessedDateTime;

[PortletProperty(Key="QuerySize", DefaultValue="20")]
internal long itemsToView;

Inheritance Hierarchy

System..::.Object
System..::.Attribute
BEA.Portlet..::.PortletFieldAttribute
BEA.Portlet..::.PreferenceAttribute
BEA.Portlet.WSRP..::.PortletPropertyAttribute
BEA.ALI.Web.UI..::.WSRPBasePage..::.PortletStateValueAttribute

See Also

PortletPropertyAttribute Members
BEA.Portlet.WSRP Namespace


PortletPropertyAttribute Members

[image]

WebCenter Portlet API for .NET Library
PortletPropertyAttribute Members
PortletPropertyAttribute Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The PortletPropertyAttribute type exposes the following members.

Constructors

Name | Description
PortletPropertyAttribute | Creates a PortletPropertyAttribute for a field.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Provides a hashcode unique for the PreferenceAttribute type and key. (Inherited from PreferenceAttribute.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init | Initializes the preference attribute so that it can handle registration for lifecycle events. (Inherited from PreferenceAttribute.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
LoadValue | Sets the value of the field from the preference values in the IPortletRequest. (Inherited from PreferenceAttribute.)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overrides ToString() to provide a meaningful representation of the PreferenceAttribute type and key. (Inherited from PreferenceAttribute.)
UnloadValue | Writes the value of the field to the preference in the IPortletResponse. (Inherited from PreferenceAttribute.)

Fields

Name | Description
_field | The FieldInfo provided during Init. (Inherited from PortletFieldAttribute.)
_isInitialized | Returns trueTruetruetrue (True in Visual Basic) if Init has has been called. falseFalsefalsefalse (False in Visual Basic) otherwise. (Inherited from PortletFieldAttribute.)
_log | The WCI logger class to trace messages within this class. (Inherited from PortletFieldAttribute.)
_page | The page provided during Init. (Inherited from PortletFieldAttribute.)
_portletContext | The portlet context provided during Init. (Inherited from PortletFieldAttribute.)
_type | The SettingType of the PreferenceAttribute. (Inherited from PreferenceAttribute.)

Properties

Name | Description
Default | Returns a fallback default value base upon the field type if none was provided. (Inherited from PreferenceAttribute.)
DefaultValue | Gets or sets the default value of the preference. This is the value when running outside a portal or when no other value has been assigned. (Inherited from PreferenceAttribute.)
Key | Gets or sets the preference key. (Inherited from PreferenceAttribute.)
PreferenceCollection | Internal PreferenceCollection used to read and write the underlying preference values. (Overrides PreferenceAttribute ..::. PreferenceCollection.)
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

PortletPropertyAttribute Class
BEA.Portlet.WSRP Namespace


PortletPropertyAttribute Constructor

PortletPropertyAttribute Constructor
PortletPropertyAttribute Class See Also Send Feedback
Creates a PortletPropertyAttribute for a field.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public PortletPropertyAttribute()

See Also

PortletPropertyAttribute Class
BEA.Portlet.WSRP Namespace


PortletPropertyAttribute Properties

[image]

WebCenter Portlet API for .NET Library
PortletPropertyAttribute Properties
PortletPropertyAttribute Class See Also Send Feedback

The PortletPropertyAttribute type exposes the following members.

Properties

Name | Description
Default | Returns a fallback default value base upon the field type if none was provided. (Inherited from PreferenceAttribute.)
DefaultValue | Gets or sets the default value of the preference. This is the value when running outside a portal or when no other value has been assigned. (Inherited from PreferenceAttribute.)
Key | Gets or sets the preference key. (Inherited from PreferenceAttribute.)
PreferenceCollection | Internal PreferenceCollection used to read and write the underlying preference values. (Overrides PreferenceAttribute ..::. PreferenceCollection.)
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

PortletPropertyAttribute Class
BEA.Portlet.WSRP Namespace


PreferenceCollection Property

PortletPropertyAttribute..::.PreferenceCollection Property
PortletPropertyAttribute Class See Also Send Feedback
Internal PreferenceCollection used to read and write the underlying preference values.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected override PreferenceCollection PreferenceCollection { get; }

See Also

PortletPropertyAttribute Class
BEA.Portlet.WSRP Namespace


PortletPropertyCollection Class

PortletPropertyCollection Class
Members See Also Send Feedback
A dictionary of WSRP portlet preferences.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public class PortletPropertyCollection : PreferenceCollection, IDictionary<string, string>,
    ICollection<KeyValuePair<string, string>>, IEnumerable<KeyValuePair<string, string>>,
    IEnumerable

Remarks

PortletPropertyCollection extends PreferenceCollection to provides a true IDictonary implementation for accessing WSRP portlet properties. Changes made to the PortletPropertyCollection are immediately reflected in future read operations.

Changes to the PortletPropertyCollection are only persisted during a performBlockingInteraction operation (generally, an ASP.NET postback) and when the WSRP consumer sends a portletStateChange value of readWrite or cloneBeforeWrite. Under any other condition, changes made to the collection are thrown away and warning message are sent to the WCI logging utility (Logging Spy).

Inheritance Hierarchy

System..::.Object
BEA.Portlet..::.PreferenceCollection
BEA.Portlet.WSRP..::.PortletPropertyCollection

See Also

PortletPropertyCollection Members
BEA.Portlet.WSRP Namespace


PortletPropertyCollection Members

[image]

WebCenter Portlet API for .NET Library
PortletPropertyCollection Members
PortletPropertyCollection Class Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The PortletPropertyCollection type exposes the following members.

Methods

Name | Description
Add | Adds a portlet property with the provided key and value to the PortletPropertyCollection.
Clear | Removes all the properties from the PortletPropertyCollection.
ContainsKey | Determines whether the PortletPropertyCollection contains an element with the specified key.
ContainsValue | Determins whether the PortletPropertyCollection contains a property with a specific value.
CopyTo | Copies the elements of the PortletPropertyCollection to an Array of KeyValuePair<string, string>, starting at a particular Array index.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Gets an IEnumerator<KeyValuePair<string, string>> suitable for enumerating the items in the collection.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the property with the specified key from the PortletPropertyCollection.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetValue | Gets the property value associated with the specified property key.
Unload |

Fields

Name | Description
_log | The WCI logger class to trace messages within this class. (Inherited from PreferenceCollection.)
_portletContext | The IDK IPortletContext for the current request. (Inherited from PreferenceCollection.)
_type | The SettingType of the PreferenceCollection. (Inherited from PreferenceCollection.)

Properties

Name | Description
Count | Gets the number of properties contained in the PortletPropertyCollection.
IsReadOnly | Returns falseFalsefalsefalse (False in Visual Basic).
Item | Indexer to get or set portlet properties. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if a property is not present in the collection. (Overrides PreferenceCollection ..::. Item[([(String])]).)
Keys | Gets an ICollection containing the keys of the properties in the PortletPropertyCollection. (Overrides PreferenceCollection ..::. Keys.)
Values | Gets an ICollection<string> containing the values in the PortletPropertyCollection.

Explicit Interface Implementations

Name | Description
ICollection<(Of <(KeyValuePair<(Of <(String, String>)>)>)>)..::.Add |
ICollection<(Of <(KeyValuePair<(Of <(String, String>)>)>)>)..::.Contains |
IEnumerable..::.GetEnumerator |
IDictionary<(Of <(String, String>)>)..::.Item |
IDictionary<(Of <(String, String>)>)..::.Keys |
ICollection<(Of <(KeyValuePair<(Of <(String, String>)>)>)>)..::.Remove |

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


PortletPropertyCollection Methods

[image]

WebCenter Portlet API for .NET Library
PortletPropertyCollection Methods
PortletPropertyCollection Class See Also Send Feedback

The PortletPropertyCollection type exposes the following members.

Methods

Name | Description
Add | Adds a portlet property with the provided key and value to the PortletPropertyCollection.
Clear | Removes all the properties from the PortletPropertyCollection.
ContainsKey | Determines whether the PortletPropertyCollection contains an element with the specified key.
ContainsValue | Determins whether the PortletPropertyCollection contains a property with a specific value.
CopyTo | Copies the elements of the PortletPropertyCollection to an Array of KeyValuePair<string, string>, starting at a particular Array index.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Gets an IEnumerator<KeyValuePair<string, string>> suitable for enumerating the items in the collection.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the property with the specified key from the PortletPropertyCollection.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TryGetValue | Gets the property value associated with the specified property key.
Unload |

Explicit Interface Implementations

Name | Description
ICollection<(Of <(KeyValuePair<(Of <(String, String>)>)>)>)..::.Add |
ICollection<(Of <(KeyValuePair<(Of <(String, String>)>)>)>)..::.Contains |
IEnumerable..::.GetEnumerator |
ICollection<(Of <(KeyValuePair<(Of <(String, String>)>)>)>)..::.Remove |

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


Add Method

PortletPropertyCollection..::.Add Method
PortletPropertyCollection Class See Also Send Feedback
Adds a portlet property with the provided key and value to the PortletPropertyCollection.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void Add(
    string key,
    string value
)

Parameters

key
Type: System..::.String
The string key for the property to add.
value
Type: System..::.String
The string value for the property to add.

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Add(TKey, TValue)

Exceptions

Exception | Condition
System..::.ArgumentNullException | key is a null reference.
System..::.ArgumentException | A property with the same key already exists in the colleciton.

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


ICollection(KeyValuePair(String, String)).Add Method

PortletPropertyCollection..::.ICollection<(Of <(KeyValuePair<(Of <(String, String>)>)>)>)..::.Add Method
PortletPropertyCollection Class See Also Send Feedback

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
void ICollection<KeyValuePair<string, string>>.Add(
    KeyValuePair<string, string> item
)

Parameters

item
Type: System.Collections.Generic..::.KeyValuePair <(Of <( String, String >)>)

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


Clear Method

PortletPropertyCollection..::.Clear Method
PortletPropertyCollection Class See Also Send Feedback
Removes all the properties from the PortletPropertyCollection.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void Clear()

Implements

ICollection<(Of <(T>)>)..::.Clear()()()

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


ICollection(KeyValuePair(String, String)).Contains Method

PortletPropertyCollection..::.ICollection<(Of <(KeyValuePair<(Of <(String, String>)>)>)>)..::.Contains Method
PortletPropertyCollection Class See Also Send Feedback

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
bool ICollection<KeyValuePair<string, string>>.Contains(
    KeyValuePair<string, string> item
)

Parameters

item
Type: System.Collections.Generic..::.KeyValuePair <(Of <( String, String >)>)

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


ContainsKey Method

PortletPropertyCollection..::.ContainsKey Method
PortletPropertyCollection Class See Also Send Feedback
Determines whether the PortletPropertyCollection contains an element with the specified key.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool ContainsKey(
    string key
)

Parameters

key
Type: System..::.String
The key of the property to locate in the PortletPropertyCollection.

Return Value

trueTruetruetrue (True in Visual Basic) if the PortletPropertyCollection contains an element with the key; otherwise, falseFalsefalsefalse (False in Visual Basic).

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.ContainsKey(TKey)

Exceptions

Exception | Condition
System..::.ArgumentNullException | key is a null reference.

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


ContainsValue Method

PortletPropertyCollection..::.ContainsValue Method
PortletPropertyCollection Class See Also Send Feedback
Determins whether the PortletPropertyCollection contains a property with a specific value.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool ContainsValue(
    string value
)

Parameters

value
Type: System..::.String
The value to locate in the PortletPropertyCollection.

Return Value

trueTruetruetrue (True in Visual Basic) if the PortletPropertyCollection contains an element with the specified value; otherwise, falseFalsefalsefalse (False in Visual Basic).

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


CopyTo Method

PortletPropertyCollection..::.CopyTo Method
PortletPropertyCollection Class See Also Send Feedback
Copies the elements of the PortletPropertyCollection to an Array of KeyValuePair<string, string>, starting at a particular Array index.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public void CopyTo(
    KeyValuePair<string, string>[] array,
    int arrayIndex
)

Parameters

array
Type: array< System.Collections.Generic..::.KeyValuePair <(Of <( String, String >)>) >[]()[]
The one-dimensional Array that is the destination of the elements copied from the PortletPropertyCollection.The Array must have zero-based indexing.
arrayIndex
Type: System..::.Int32
The zero-based index in array at which copying begins.

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


GetEnumerator Method

PortletPropertyCollection..::.GetEnumerator Method
PortletPropertyCollection Class See Also Send Feedback
Gets an IEnumerator<KeyValuePair<string, string>> suitable for enumerating the items in the collection.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public IEnumerator<KeyValuePair<string, string>> GetEnumerator()

Return Value

An IEnumerator<KeyValuePair<string, string>> suitable for enumerating the items in the collection.

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


IEnumerable.GetEnumerator Method

PortletPropertyCollection..::.IEnumerable..::.GetEnumerator Method
PortletPropertyCollection Class See Also Send Feedback

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()

Implements

IEnumerable..::.GetEnumerator()()()

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


Remove Method

PortletPropertyCollection..::.Remove Method
PortletPropertyCollection Class See Also Send Feedback
Removes the property with the specified key from the PortletPropertyCollection.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool Remove(
    string key
)

Parameters

key
Type: System..::.String
The key of the property to remove.

Return Value

trueTruetruetrue (True in Visual Basic) if the element is successfully removed; otherwise, falseFalsefalsefalse (False in Visual Basic). This method also returns falseFalsefalsefalse (False in Visual Basic) if key was not found in the original PortletPropertyCollection.

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Remove(TKey)

Exceptions

Exception | Condition
System..::.ArgumentNullException | key is a null reference.

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


ICollection(KeyValuePair(String, String)).Remove Method

PortletPropertyCollection..::.ICollection<(Of <(KeyValuePair<(Of <(String, String>)>)>)>)..::.Remove Method
PortletPropertyCollection Class See Also Send Feedback

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
bool ICollection<KeyValuePair<string, string>>.Remove(
    KeyValuePair<string, string> item
)

Parameters

item
Type: System.Collections.Generic..::.KeyValuePair <(Of <( String, String >)>)

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


TryGetValue Method

PortletPropertyCollection..::.TryGetValue Method
PortletPropertyCollection Class See Also Send Feedback
Gets the property value associated with the specified property key.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool TryGetValue(
    string key,
    out string value
)

Parameters

key
Type: System..::.String
The key of the property value to get.
value
Type: System..::.String %
When this method returns, the value associated with the specified key, if the key is found; otherwise, the default value for the type of the value parameter. This parameter is passed uninitialized.

Return Value

trueTruetruetrue (True in Visual Basic) if the PortletPropertyCollection contains an element with the specified key; otherwise, falseFalsefalsefalse (False in Visual Basic).

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.TryGetValue(TKey, TValue%)

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


Unload Method

PortletPropertyCollection..::.Unload Method
PortletPropertyCollection Class See Also Send Feedback

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected internal void Unload(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


PortletPropertyCollection Properties

[image]

WebCenter Portlet API for .NET Library
PortletPropertyCollection Properties
PortletPropertyCollection Class See Also Send Feedback

The PortletPropertyCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of properties contained in the PortletPropertyCollection.
IsReadOnly | Returns falseFalsefalsefalse (False in Visual Basic).
Item | Indexer to get or set portlet properties. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if a property is not present in the collection. (Overrides PreferenceCollection ..::. Item[([(String])]).)
Keys | Gets an ICollection containing the keys of the properties in the PortletPropertyCollection. (Overrides PreferenceCollection ..::. Keys.)
Values | Gets an ICollection<string> containing the values in the PortletPropertyCollection.

Explicit Interface Implementations

Name | Description
IDictionary<(Of <(String, String>)>)..::.Item |
IDictionary<(Of <(String, String>)>)..::.Keys |

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


Count Property

PortletPropertyCollection..::.Count Property
PortletPropertyCollection Class See Also Send Feedback
Gets the number of properties contained in the PortletPropertyCollection.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public int Count { get; }

Field Value

The number of properties contained in the PortletPropertyCollection.

Implements

ICollection<(Of <(T>)>)..::.Count

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


IsReadOnly Property

PortletPropertyCollection..::.IsReadOnly Property
PortletPropertyCollection Class See Also Send Feedback
Returns falseFalsefalsefalse (False in Visual Basic).

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public bool IsReadOnly { get; }

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly

Remarks

The PortletPropertyCollection is always read/write. However, changes made to the collection are persisted to the WSRP consumer only during a WSRP performBlockingInteraction or when the consumer sends a portletStateChnage value or readWrite or cloneBeforeWrite.

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


Item Property

PortletPropertyCollection..::.Item Property
PortletPropertyCollection Class See Also Send Feedback
Indexer to get or set portlet properties. Returns nullNothingnullptra null reference (Nothing in Visual Basic) if a property is not present in the collection.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public override string this[
    string key
] { get; set; }

Parameters

key
Type: System..::.String

Remarks

Attempting to get a value that does exist returns nullNothingnullptra null reference (Nothing in Visual Basic) instead of throwing an exception. Cast to IDictionary<string, string> if you wish an exception to be raised when the key is not present in the collection.

Exceptions

Exception | Condition
System..::.ArgumentNullException | key is a null reference.

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


IDictionary(String, String).Item Property

PortletPropertyCollection..::.IDictionary<(Of <(String, String>)>)..::.Item Property
PortletPropertyCollection Class See Also Send Feedback

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
string IDictionary<string, string>.Item[
    string preference
] { get; set; }

Parameters

preference
Type: System..::.String

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Item[([(TKey])])

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


Keys Property

PortletPropertyCollection..::.Keys Property
PortletPropertyCollection Class See Also Send Feedback
Gets an ICollection containing the keys of the properties in the PortletPropertyCollection.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public override ICollection Keys { get; }

Field Value

An ICollection containing the keys of the portlet properties.

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


IDictionary(String, String).Keys Property

PortletPropertyCollection..::.IDictionary<(Of <(String, String>)>)..::.Keys Property
PortletPropertyCollection Class See Also Send Feedback

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
ICollection<string> IDictionary<string, string>.Keys { get; }

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Keys

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


Values Property

PortletPropertyCollection..::.Values Property
PortletPropertyCollection Class See Also Send Feedback
Gets an ICollection<string> containing the values in the PortletPropertyCollection.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public ICollection<string> Values { get; }

Implements

IDictionary<(Of <(TKey, TValue>)>)..::.Values

See Also

PortletPropertyCollection Class
BEA.Portlet.WSRP Namespace


RegistrationInfo Class

RegistrationInfo Class
Members See Also Send Feedback
Provides access to information provided by the wsrp consumer making the current request when it registered with the producer.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public class RegistrationInfo

Inheritance Hierarchy

System..::.Object
BEA.Portlet.WSRP..::.RegistrationInfo

See Also

RegistrationInfo Members
BEA.Portlet.WSRP Namespace


RegistrationInfo Members

[image]

WebCenter Portlet API for .NET Library
RegistrationInfo Members
RegistrationInfo Class Methods Fields See Also Send Feedback

The RegistrationInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ConsumerAgent | The WSRP Registration consumer agent value.
ConsumerName | The WSRP Registration consumer name value.
Handle | The WSRP Registration handle value.
Properties | A read-only dictionary of registration properties provided by the consumer when it registered with the producer.

See Also

RegistrationInfo Class
BEA.Portlet.WSRP Namespace


RegistrationInfo Fields

[image]

WebCenter Portlet API for .NET Library
RegistrationInfo Fields
RegistrationInfo Class See Also Send Feedback

The RegistrationInfo type exposes the following members.

Fields

Name | Description
ConsumerAgent | The WSRP Registration consumer agent value.
ConsumerName | The WSRP Registration consumer name value.
Handle | The WSRP Registration handle value.
Properties | A read-only dictionary of registration properties provided by the consumer when it registered with the producer.

See Also

RegistrationInfo Class
BEA.Portlet.WSRP Namespace


ConsumerAgent Field

RegistrationInfo..::.ConsumerAgent Field
RegistrationInfo Class See Also Send Feedback
The WSRP Registration consumer agent value.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public readonly string ConsumerAgent

See Also

RegistrationInfo Class
BEA.Portlet.WSRP Namespace


ConsumerName Field

RegistrationInfo..::.ConsumerName Field
RegistrationInfo Class See Also Send Feedback
The WSRP Registration consumer name value.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public readonly string ConsumerName

See Also

RegistrationInfo Class
BEA.Portlet.WSRP Namespace


Handle Field

RegistrationInfo..::.Handle Field
RegistrationInfo Class See Also Send Feedback
The WSRP Registration handle value.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public readonly string Handle

See Also

RegistrationInfo Class
BEA.Portlet.WSRP Namespace


Properties Field

RegistrationInfo..::.Properties Field
RegistrationInfo Class See Also Send Feedback
A read-only dictionary of registration properties provided by the consumer when it registered with the producer.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public readonly IDictionary<string, string> Properties

See Also

RegistrationInfo Class
BEA.Portlet.WSRP Namespace


RegistrationPropertyAttribute Class

RegistrationPropertyAttribute Class
Members Example See Also Send Feedback
Binds a non-private page field to a registration property.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
[FieldAttributeTypeAttribute(typeof(long))]
[FieldAttributeTypeAttribute(typeof(float))]
[FieldAttributeTypeAttribute(typeof(int))]
[FieldAttributeTypeAttribute(typeof(DateTime))]
[AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple = false)]
[FieldAttributeTypeAttribute(typeof(bool))]
[FieldAttributeTypeAttribute(typeof(double))]
[FieldAttributeTypeAttribute(typeof(string))]
public class RegistrationPropertyAttribute : PortletFieldAttribute

Examples

CopyC#
[RegistrationProperty()]
protected string myRegProp;

[RegistrationProperty(Key = "RegDate")]
public DateTime registrationDate;

[RegistrationProperty(Key = "ConsumerBuildNo", DefaultValue = "0")]
internal string consumerBuildNo;

Inheritance Hierarchy

System..::.Object
System..::.Attribute
BEA.Portlet..::.PortletFieldAttribute
BEA.Portlet.WSRP..::.RegistrationPropertyAttribute

See Also

RegistrationPropertyAttribute Members
BEA.Portlet.WSRP Namespace


RegistrationPropertyAttribute Members

[image]

WebCenter Portlet API for .NET Library
RegistrationPropertyAttribute Members
RegistrationPropertyAttribute Class Constructors Methods Fields Properties Explicit Interface Implementations See Also Send Feedback

The RegistrationPropertyAttribute type exposes the following members.

Constructors

Name | Description
RegistrationPropertyAttribute |

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Provides a hashcode unique for the RegistrationPropertyAttribute and key. (Overrides Attribute ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init | Initializes the field attribute so that it can handle registration for lifecycle events. (Inherited from PortletFieldAttribute.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
LoadValue | (Overrides PortletFieldAttribute ..::. LoadValue(Object, EventArgs).)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overrides ToString() to provide a meaningful representation of the RegistrationPropertyAttribute and key. (Overrides Object ..::. ToString()()().)
UnloadValue | Called to unload the value from the portlet field. (Inherited from PortletFieldAttribute.)

Fields

Name | Description
_field | The FieldInfo provided during Init. (Inherited from PortletFieldAttribute.)
_isInitialized | Returns trueTruetruetrue (True in Visual Basic) if Init has has been called. falseFalsefalsefalse (False in Visual Basic) otherwise. (Inherited from PortletFieldAttribute.)
_log | The WCI logger class to trace messages within this class. (Inherited from PortletFieldAttribute.)
_page | The page provided during Init. (Inherited from PortletFieldAttribute.)
_portletContext | The portlet context provided during Init. (Inherited from PortletFieldAttribute.)

Properties

Name | Description
DefaultValue | Gets or sets the default value assigned to the field when no registation property value is provided in the request or when the page is running outside the portal environment.
Key | Gets or sets the key value used to look up the registration property. If not provided this defaults to the name of the field to which this attribute is applied.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

RegistrationPropertyAttribute Class
BEA.Portlet.WSRP Namespace


RegistrationPropertyAttribute Constructor

RegistrationPropertyAttribute Constructor
RegistrationPropertyAttribute Class See Also Send Feedback
Initializes a new instance of the RegistrationPropertyAttribute class.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public RegistrationPropertyAttribute()

See Also

RegistrationPropertyAttribute Class
BEA.Portlet.WSRP Namespace


RegistrationPropertyAttribute Methods

[image]

WebCenter Portlet API for .NET Library
RegistrationPropertyAttribute Methods
RegistrationPropertyAttribute Class See Also Send Feedback

The RegistrationPropertyAttribute type exposes the following members.

Methods

Name | Description
Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Provides a hashcode unique for the RegistrationPropertyAttribute and key. (Overrides Attribute ..::. GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Init | Initializes the field attribute so that it can handle registration for lifecycle events. (Inherited from PortletFieldAttribute.)
IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
LoadValue | (Overrides PortletFieldAttribute ..::. LoadValue(Object, EventArgs).)
Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Overrides ToString() to provide a meaningful representation of the RegistrationPropertyAttribute and key. (Overrides Object ..::. ToString()()().)
UnloadValue | Called to unload the value from the portlet field. (Inherited from PortletFieldAttribute.)

Explicit Interface Implementations

Name | Description
_Attribute..::.GetIDsOfNames | (Inherited from Attribute.)
_Attribute..::.GetTypeInfo | (Inherited from Attribute.)
_Attribute..::.GetTypeInfoCount | (Inherited from Attribute.)
_Attribute..::.Invoke | (Inherited from Attribute.)

See Also

RegistrationPropertyAttribute Class
BEA.Portlet.WSRP Namespace


GetHashCode Method

RegistrationPropertyAttribute..::.GetHashCode Method
RegistrationPropertyAttribute Class See Also Send Feedback
Provides a hashcode unique for the RegistrationPropertyAttribute and key.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public override int GetHashCode()

Return Value

A hashcode unique for the RegistrationPropertyAttribute and key.

See Also

RegistrationPropertyAttribute Class
BEA.Portlet.WSRP Namespace


LoadValue Method

RegistrationPropertyAttribute..::.LoadValue Method
RegistrationPropertyAttribute Class See Also Send Feedback

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
protected override void LoadValue(
    Object sender,
    EventArgs e
)

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

RegistrationPropertyAttribute Class
BEA.Portlet.WSRP Namespace


ToString Method

RegistrationPropertyAttribute..::.ToString Method
RegistrationPropertyAttribute Class See Also Send Feedback
Overrides ToString() to provide a meaningful representation of the RegistrationPropertyAttribute and key.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public override string ToString()

Return Value

String representing the RegistrationPropertyAttribute and key.

See Also

RegistrationPropertyAttribute Class
BEA.Portlet.WSRP Namespace


RegistrationPropertyAttribute Properties

[image]

WebCenter Portlet API for .NET Library
RegistrationPropertyAttribute Properties
RegistrationPropertyAttribute Class See Also Send Feedback

The RegistrationPropertyAttribute type exposes the following members.

Properties

Name | Description
DefaultValue | Gets or sets the default value assigned to the field when no registation property value is provided in the request or when the page is running outside the portal environment.
Key | Gets or sets the key value used to look up the registration property. If not provided this defaults to the name of the field to which this attribute is applied.
TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)

See Also

RegistrationPropertyAttribute Class
BEA.Portlet.WSRP Namespace


DefaultValue Property

RegistrationPropertyAttribute..::.DefaultValue Property
RegistrationPropertyAttribute Class See Also Send Feedback
Gets or sets the default value assigned to the field when no registation property value is provided in the request or when the page is running outside the portal environment.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public Object DefaultValue { get; set; }

Field Value

The default value assigned to the field when no registration property value is provided.

See Also

RegistrationPropertyAttribute Class
BEA.Portlet.WSRP Namespace


Key Property

RegistrationPropertyAttribute..::.Key Property
RegistrationPropertyAttribute Class See Also Send Feedback
Gets or sets the key value used to look up the registration property. If not provided this defaults to the name of the field to which this attribute is applied.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string Key { get; set; }

Field Value

The registration property key

Remarks

This value must match the value of the name attribute for the registration property declared in the wsrp-producer.xml configuration file.

See Also

RegistrationPropertyAttribute Class
BEA.Portlet.WSRP Namespace


WSRPPortletContext Class

WSRPPortletContext Class
Members See Also Send Feedback
Provides contextual information about the current WSRP portlet request.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public class WSRPPortletContext

Remarks

Use the Current property to obtains the current WSRPPortletContext information.

Inheritance Hierarchy

System..::.Object
BEA.Portlet.WSRP..::.WSRPPortletContext

See Also

WSRPPortletContext Members
BEA.Portlet.WSRP Namespace


WSRPPortletContext Members

[image]

WebCenter Portlet API for .NET Library
WSRPPortletContext Members
WSRPPortletContext Class Methods Properties See Also Send Feedback

The WSRPPortletContext type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ConsumerAgent | Gets the User-Agent that made the portlet request to the WSRP Producer.
ConsumerRegistration | Gets the RegistrationInfo for the WSRP Consumer that made the portlet request.
Current | Gets the WSRPPortletContext for the current request.
Portlet | Gets the PortletInfo for the requested Portlet.
ProducerName | Gets the name of the WSRP Producer application.
ProducerVersion | Gets the version of the WSRP Producer application.

See Also

WSRPPortletContext Class
BEA.Portlet.WSRP Namespace


WSRPPortletContext Properties

[image]

WebCenter Portlet API for .NET Library
WSRPPortletContext Properties
WSRPPortletContext Class See Also Send Feedback

The WSRPPortletContext type exposes the following members.

Properties

Name | Description
ConsumerAgent | Gets the User-Agent that made the portlet request to the WSRP Producer.
ConsumerRegistration | Gets the RegistrationInfo for the WSRP Consumer that made the portlet request.
Current | Gets the WSRPPortletContext for the current request.
Portlet | Gets the PortletInfo for the requested Portlet.
ProducerName | Gets the name of the WSRP Producer application.
ProducerVersion | Gets the version of the WSRP Producer application.

See Also

WSRPPortletContext Class
BEA.Portlet.WSRP Namespace


ConsumerAgent Property

WSRPPortletContext..::.ConsumerAgent Property
WSRPPortletContext Class See Also Send Feedback
Gets the User-Agent that made the portlet request to the WSRP Producer.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string ConsumerAgent { get; }

See Also

WSRPPortletContext Class
BEA.Portlet.WSRP Namespace


ConsumerRegistration Property

WSRPPortletContext..::.ConsumerRegistration Property
WSRPPortletContext Class See Also Send Feedback
Gets the RegistrationInfo for the WSRP Consumer that made the portlet request.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public RegistrationInfo ConsumerRegistration { get; }

See Also

WSRPPortletContext Class
BEA.Portlet.WSRP Namespace


Current Property

WSRPPortletContext..::.Current Property
WSRPPortletContext Class See Also Send Feedback
Gets the WSRPPortletContext for the current request.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public static WSRPPortletContext Current { get; }

Field Value

The WSRPPortletContext for the current request.

See Also

WSRPPortletContext Class
BEA.Portlet.WSRP Namespace


Portlet Property

WSRPPortletContext..::.Portlet Property
WSRPPortletContext Class See Also Send Feedback
Gets the PortletInfo for the requested Portlet.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public PortletInfo Portlet { get; }

See Also

WSRPPortletContext Class
BEA.Portlet.WSRP Namespace


ProducerName Property

WSRPPortletContext..::.ProducerName Property
WSRPPortletContext Class See Also Send Feedback
Gets the name of the WSRP Producer application.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string ProducerName { get; }

See Also

WSRPPortletContext Class
BEA.Portlet.WSRP Namespace


ProducerVersion Property

WSRPPortletContext..::.ProducerVersion Property
WSRPPortletContext Class See Also Send Feedback
Gets the version of the WSRP Producer application.

Namespace: BEA.Portlet.WSRP
Assembly: PortletAPI (in PortletAPI.dll)
Version: 1.1.2.0 (1.1.233.4964)

Syntax

C#
public string ProducerVersion { get; }

See Also

WSRPPortletContext Class
BEA.Portlet.WSRP Namespace


AddOnPreRenderCompleteAsync Method

[image]

WebCenter Portlet API for .NET Library
WSRPPortletPage..::.AddOnPreRenderCompleteAsync Method
WSRPPortletPage Class See Also Send Feedback

Overload List

Name | Description
AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)

See Also

WSRPPortletPage Class
WSRPPortletPage Members
BEA.ALI.Web.UI Namespace


XPathSelect Method

[image]

WebCenter Portlet API for .NET Library
WSRPPortletPage..::.XPathSelect Method
WSRPPortletPage Class See Also Send Feedback

Overload List

Name | Description
XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)

See Also

WSRPPortletPage Class
WSRPPortletPage Members
BEA.ALI.Web.UI Namespace


RenderControl Method

[image]

WebCenter Portlet API for .NET Library
WSRPPortletPage..::.RenderControl Method
WSRPPortletPage Class See Also Send Feedback

Overload List

Name | Description
RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)

See Also

WSRPPortletPage Class
WSRPPortletPage Members
BEA.ALI.Web.UI Namespace


InitOutputCache Method

[image]

WebCenter Portlet API for .NET Library
WSRPPortletPage..::.InitOutputCache Method
WSRPPortletPage Class See Also Send Feedback

Overload List

Name | Description
InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)

See Also

WSRPPortletPage Class
WSRPPortletPage Members
BEA.ALI.Web.UI Namespace


FindControl Method

[image]

WebCenter Portlet API for .NET Library
WSRPPortletPage..::.FindControl Method
WSRPPortletPage Class See Also Send Feedback

Overload List

Name | Description
FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl()()() method. (Inherited from Control.)

See Also

WSRPPortletPage Class
WSRPPortletPage Members
BEA.ALI.Web.UI Namespace


DataBind Method

[image]

WebCenter Portlet API for .NET Library
WSRPPortletPage..::.DataBind Method
WSRPPortletPage Class See Also Send Feedback

Overload List

Name | Description
DataBind()()() | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)

See Also

WSRPPortletPage Class
WSRPPortletPage Members
BEA.ALI.Web.UI Namespace


SetFocus Method

[image]

WebCenter Portlet API for .NET Library
WSRPPortletPage..::.SetFocus Method
WSRPPortletPage Class See Also Send Feedback

Overload List

Name | Description
SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)

See Also

WSRPPortletPage Class
WSRPPortletPage Members
BEA.ALI.Web.UI Namespace


Eval Method

[image]

WebCenter Portlet API for .NET Library
WSRPPortletPage..::.Eval Method
WSRPPortletPage Class See Also Send Feedback

Overload List

Name | Description
Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)

See Also

WSRPPortletPage Class
WSRPPortletPage Members
BEA.ALI.Web.UI Namespace


GetGlobalResourceObject Method

[image]

WebCenter Portlet API for .NET Library
WSRPPortletPage..::.GetGlobalResourceObject Method
WSRPPortletPage Class See Also Send Feedback

Overload List

Name | Description
GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)

See Also

WSRPPortletPage Class
WSRPPortletPage Members
BEA.ALI.Web.UI Namespace


Validate Method

[image]

WebCenter Portlet API for .NET Library
WSRPPortletPage..::.Validate Method
WSRPPortletPage Class See Also Send Feedback

Overload List

Name | Description
Validate()()() | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)

See Also

WSRPPortletPage Class
WSRPPortletPage Members
BEA.ALI.Web.UI Namespace


LoadControl Method

[image]

WebCenter Portlet API for .NET Library
WSRPPortletPage..::.LoadControl Method
WSRPPortletPage Class See Also Send Feedback

Overload List

Name | Description
LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
LoadControl(Type, array<Object>[]()[]) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)

See Also

WSRPPortletPage Class
WSRPPortletPage Members
BEA.ALI.Web.UI Namespace


GetPostBackEventReference Method

[image]

WebCenter Portlet API for .NET Library
WSRPPortletPage..::.GetPostBackEventReference Method
WSRPPortletPage Class See Also Send Feedback

Overload List

Name | Description
GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)

See Also

WSRPPortletPage Class
WSRPPortletPage Members
BEA.ALI.Web.UI Namespace


GetLocalResourceObject Method

[image]

WebCenter Portlet API for .NET Library
WSRPPortletPage..::.GetLocalResourceObject Method
WSRPPortletPage Class See Also Send Feedback

Overload List

Name | Description
GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)

See Also

WSRPPortletPage Class
WSRPPortletPage Members
BEA.ALI.Web.UI Namespace


XPath Method

[image]

WebCenter Portlet API for .NET Library
WSRPPortletPage..::.XPath Method
WSRPPortletPage Class See Also Send Feedback

Overload List

Name | Description
XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)

See Also

WSRPPortletPage Class
WSRPPortletPage Members
BEA.ALI.Web.UI Namespace