Contents

Preface

Topics ................................................................................................................. vii
Prerequisite Skills .......................................................................................... viii
Prerequisite Software ....................................................................................... viii
Documentation ................................................................................................. ix
  TUXEDO Documentation ........................................................................... ix
  Other Publications ......................................................................................... ix
Contact Information ......................................................................................... ix
  Documentation Support ............................................................................... x
  Customer Support ......................................................................................... x

1. Preinstallation Requirements

  Deciding the Environment for eLink Adapter for PeopleSoft ......................... 1-1
  Testing the PeopleSoft Application ............................................................ 1-2
  Defining PeopleSoft Message Definition .................................................... 1-2

2. Creating a BEA_CPS Message Definition

  Start the PeopleTools Application Designer .............................................. 2-1
  Create a New Record Definition ................................................................. 2-2
  Add Fields To The Record Definition ......................................................... 2-3
  Define Record Properties ............................................................................ 2-4
    General Properties .................................................................................. 2-4
    Set the Type of Record ......................................................................... 2-5
  Define the Field Properties ......................................................................... 2-6
    Save the Record Definition .................................................................. 2-7
  Create a Panel to Acces the BEA_CPS Message Definition (Optional) .... 2-8
  Define a New Panel Group ....................................................................... 2-14
Create The New Business Process................................................................. 2-19
Create a New Activity .................................................................................. 2-20
Define the Activity ...................................................................................... 2-21
Create New Message Agent Message Definition ....................................... 2-23
Define the Message Definition .................................................................... 2-24
Configuration Validation ............................................................................. 2-31
Launching the Security Administrator .......................................................... 2-33

3. Installing eLink Adapter for PeopleSoft
Pre-Installation Considerations................................................................... 3-1
Configuring the Environment to Install eLink for PeopleSoft ..................... 3-2
Installing BEA eLink Adapter for PeopleSoft............................................. 3-2
Installing on UNIX-based Platforms ........................................................... 3-2
Installing on a Windows NT Platform......................................................... 3-5
Distribution Libraries and Executables ....................................................... 3-9
Uninstalling eLink Adapter for PeopleSoft on Windows NT ....................... 3-10

4. Configuring PeopleSoft Application Server Domain
Configuring to Run Multiple Domains....................................................... 4-2
Configuring the PeopleSoft Domain ........................................................... 4-2
Configuring eLink Adapter for PeopleSoft Domain .................................... 4-3

5. Configuring FML32
Create the FML Definition File(s)............................................................... 5-1

6. Running eLink Adapter for PeopleSoft
FML32 Buffer............................................................................................. 6-3

7. Exposing PeopleSoft Panels to TUXEDO Applications
Determining PeopleSoft Internal GUI Component Names ..................... 7-2
Displaying the Disciplinary Action Dialog Box ........................................ 7-2
Obtaining the Internal Menu Name ............................................................ 7-4
Obtaining the Internal Panel Name and Group .......................................... 7-6
Obtaining the Search Record ..................................................................... 7-7
Obtaining the Record and Field Names...................................................... 7-8
Creating the Activity and Message Definition ......................................... 7-10
Defining FML32 Fields ................................................................. 7-17
Testing the New Message Definition ........................................ 7-19
Message Definition Worksheets ............................................... 7-21
Preface

This document provides instructions for installing and configuring BEA eLink Adapter for PeopleSoft. It is intended for system managers with the responsibility of installing products in the UNIX or Windows NT environment and configuration of layered products. While this guide attempts to provide step-by-step details of the configuration of eLink Adapter for PeopleSoft, it is intended for the experienced eLink Adapter for PeopleSoft consultant.

Topics

Preinstallation Requirements
Creating a BEA_CPS Message Definition
Installing eLink Adapter for PeopleSoft
Configuring PeopleSoft Application Server Domain
Configuring FML32
Running eLink Adapter for PeopleSoft
Exposing PeopleSoft Panels to TUXEDO Applications
Prerequisite Skills

Users of this guide are expected to have the following skill set in order to understand the context of the information:

♦ PeopleTools use, including the creation and definition of records, panels, panel groups, menus, menu items, business processes, activities, and message definitions.
♦ TUXEDO FML buffer definition.
♦ System management knowledge of BEA TUXEDO.
♦ A general understanding of the Windows NT operating system and DOS shell commands.
♦ A general understanding of the UNIX operating system and UNIX commands.
♦ A familiarity with BEA TUXEDO and PeopleSoft programming.

Prerequisite Software

Before starting the eLink adapter for PeopleSoft installation be sure that the following software is properly installed:

♦ PeopleSoft 7.5 or greater (three-tier mode.)
♦ PeopleTools 7.56 or later
♦ TUXEDO 6.4 or greater.
Documentation

This document, the *BEA eLink Adapter for PeopleSoft User Guide*, is designed primarily as an online document. If you are reading this as a paper publication, note that to get full use from this document you should install and access it as an online HTML document.

**TUXEDO Documentation**

The following BEA publications may be helpful:

* TUXEDO System 6 Programmer’s Guide, Volumes 1 and 2

**Other Publications**

For more information about TUXEDO technology, refer to the following books:

* The *TUXEDO System* (Andrade, Carges, Dywer, Felts)
* *TUXEDO: An Open Approach to OLTP* (Primatesta)
* *Building Client/Server Applications Using TUXEDO* (Hall)

For more information about PeopleSoft technology, refer to the following books:

* *PeopleSoft 7.5 People Books*

**Contact Information**

The following sections provide information about how to obtain support for the documentation and software.
Documentation Support

If you have questions or comments on the documentation, you can contact the BEA Information Engineering Group by e-mail at docsupport@beasys.com.

Customer Support

If you have any questions about this version of BEA eLink Adapter for PeopleSoft, or if you have problems installing and running BEA eLink Adapter for PeopleSoft, contact BEA Customer Support through BEA WebSupport at www.beasys.com. You can also contact Customer Support by using the contact information provided on the Customer Support Card, which is included in the product package.

When contacting Customer Support, be prepared to provide the following information:

♦ Your name, e-mail address, phone number, and fax number
♦ Your company name and company address
♦ Your machine type and authorization codes
♦ The name and version of the product you are using
♦ A description of the problem and the content of pertinent error messages
1 Preinstallation Requirements

This section provides information about preparing to install the eLink Adapter for PeopleSoft component.

Deciding the Environment for eLink Adapter for PeopleSoft

The eLink Adapter for PeopleSoft software must be installed in its own TUXEDO domain. This allows configuration and management to occur without disruption to the PeopleSoft services. This domain must be separately licensed, as the TUXEDO license provided with PeopleSoft only covers the PeopleSoft applications.

Depending on system load and use, eLink Adapter for PeopleSoft may be installed either on the same computer that runs PeopleSoft or a separate computer. This choice is left to the system manager.

If the computer where the eLink Adapter for PeopleSoft software resides is not the same computer as the one being used to run PeopleSoft, then you must install and configure the PeopleTools 7.56 client software on the eLink Adapter for PeopleSoft machine.
1 Preinstallation Requirements

Testing the PeopleSoft Application

Before installation of the eLink Adapter for PeopleSoft can begin, PeopleSoft must be started. Verify PeopleSoft is up by connecting in 2-tier mode. To do this, start the `pstools.exe` in the `%PS_HOME%\bin\client\winx86\` directory path. Enter the database name `PTDMO` and a valid login ID and password, such as `PTDMO/PTDMO`.

Defining PeopleSoft Message Definition

After verifying the PeopleSoft application is connecting in 2-tier mode, you must set up Message Definitions for updating and retrieving data from the PeopleSoft database. These definitions must be in place prior to installing the eLink Adapter for PeopleSoft component. For information on how to configure these Message Definitions in PeopleSoft, refer to “Creating a BEA_CPS Message Definition.”
2 Creating a BEA_CPS Message Definition

When the eLink Adapter for PeopleSoft software starts up, it must determine which PeopleSoft Message Definitions are available via ATMI services. To do this, the eLink Adapter component requires a definition, BEA_CPS, which queries all the available definitions. You create this definition within the PeopleSoft configuration using the PeopleTools Application Designer. This section explains how to create the BEA_CPS Message Definition within PeopleSoft.

**Start the PeopleTools Application Designer**

These are the steps used to create the BEA_CPS message Definition in PeopleTools:

<table>
<thead>
<tr>
<th>Creating a BEA_CPS Message Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Create a New Record Definition</td>
</tr>
<tr>
<td>Add Fields To The Record Definition</td>
</tr>
<tr>
<td>Define Record Properties</td>
</tr>
<tr>
<td>Define the Field Properties</td>
</tr>
<tr>
<td>Create a Panel to Access the BEA_CPS Message Definition (Optional)</td>
</tr>
<tr>
<td>Create The New Business Process</td>
</tr>
</tbody>
</table>
Create a New Record Definition

Select File -> New. This brings up a dialog that allows the selection of a new PeopleSoft object. Highlight Record from the available choices (Figure 2-1) and click OK.

Figure 2-1   Add a new record definition in PeopleTools.
Add Fields To The Record Definition

The record will contain two fields: ACTIVITYNAME, and INPUTNAME.

1. Begin by adding the ACTIVITYNAME field:
   a. Select Insert -> Field from the menu. The Insert Field dialog box displays (Figure 2-2).
   b. Type ACTIVITYNAME in the Name field and click the Insert button.

   Figure 2-2   Add the ACTIVITYNAME field to the record.

2. Add the INPUTNAME field:
   Change the Name field from ACTIVITYNAME to INPUTNAME and click Insert. Figure 2-3 shows how the Record Definition displays with both fields.
Define Record Properties

After you have defined the record, you must define its properties. Select File -> Object Properties from the menu to bring up the Record Properties dialog.

General Properties

On the General tab add the general information about the record. In Figure 2-4, the Description and Comment fields are filled in as follows:

Description: BEA CPS Record

Comment: This record is used by eLink Adapter for PeopleSoft to determine the Message Agent Activities and Message Definitions.
Set the Type of Record

1. Select the **Type** tab.
2. Select the **Dynamic View** radio button in the **Record Type** section.
3. Type the following in the **SQL View Select Statement** text box:
   
   ```sql
   select A.ACTIVITYNAME, A.INPUTNAME from PSMSGAGTDEFN A, PSBUSPROCXREF B where B.COMPONENTNAME = A.ACTIVITYNAME
   ```
4. Verify the information (Figure 2-5.)
5. Press the **OK** button.
Define the Field Properties

1. Double-click on the ACTIVITYNAME field in the Record window to bring up the Record Field Properties dialog.

2. Under the Use tab check (click) the Key, Search Key, and List Box Item check boxes. Ensure that no other check boxes are selected (Figure 2-6).

3. Select OK.
Define the Field Properties

Figure 2-6 Define the properties of the ACTIVITYNAME field.

4. The INPUTNAME field properties must also be set. Double-click on the INPUTNAME field in the Record window to bring up the Record Field Properties dialog for the INPUTNAME field. Select the Key and List Box Item checkboxes. Ensure that no other checkboxes are selected. Select OK.

Save the Record Definition

1. Select File -> Save As from the menu.
2. In the Save As dialog type BEA_CPS in the Save Name As field (Figure 2-7).
3. Select OK.
2 Creating a BEA_CPS Message Definition

Figure 2-7  The last step in creating the record definition

Insert the record into the project by selecting Insert -> Current Object into Project from the menu (or by pressing <F7>). The Record window may now be closed: select File->Close from the menu.

Create a Panel to Access the BEA_CPS Message Definition (Optional)

The tasks in this section are optional and define the PeopleSoft Panel and Menu items that allow the eLink Adapter for PeopleSoft Message Definition to be graphically executed from within PeopleTools.

Note:  The eLink Adapter for PeopleSoft component will function without these items being created.

When using PeopleTools, a panel must be defined to allow access to the ACTIVITYNAME and INPUTNAME fields defined in the BEA_CPS record. Select File->New and highlight Panel in the New dialog to create a new panel. Select OK (Figure 2-8).

Figure 2-8  Create a new panel definition.

Adding fields consists of adding two edit boxes and defining the properties of each.

1. Begin by inserting an Edit box.
2. Select Insert -> Edit Box from the menu.
3. The cursor will change from a pointer to a crosshair.

4. Move the crosshair over the panel window (near the center of the upper half of the window) and click on the window.

5. This will place a new entry field in the panel (Figure 2-9).

6. The crosshair will revert back to a pointer.

Figure 2-9 Add the first text entry field to the panel.

7. Double-click on the entry field in the panel window (the white box).

8. This will bring up the Panel Field Properties dialog.

9. Under the Record tab, specify BEA_CPS as the Record Name (you may either type it in or select it from the drop-down list).

10. For the Field Name specify ACTIVITYNAME (again, you may either type it in or select it from the drop-down list) (Figure 2-10).

11. Under the Use tab check Display Only in the Field Use Options section (Figure 2-11).

12. Select OK.
Figure 2-10  Set the panel field properties for the ACTIVITYNAME field.
Figure 2-11  Set the panel field properties for ACTIVITYNAME to display only.

Following the same method used for the ACTIVITYNAME, add a second entry field for INPUTNAME. Place this entry field in the center of the bottom half of the panel window. Select Insert -> Edit Box from the menu (pointer changes to crosshair), position the crosshair in the center of the lower half of the panel window and click on the panel window, double click on the new entry field to bring up the Panel Field Properties dialog. For the Record Name specify BEA_CPS. For the Field Name specify INPUTNAME (Figure 2-12). Under the Use tab check Display Only in the Field Use Options section (Figure 2-13). Select OK.
Figure 2-12  Define the panel field properties for the INPUTNAME field.
Figure 2-13  Set the panel field properties for INPUTNAME to display only.

Save the panel definition by selecting File -> Save As from the menu and typing BEA_PANEL as the Save Name as (Figure 2-14). Select OK. The panel has been created. Add the Panel to the Project, <F7>. Select File -> Close from the menu to close the panel definition window.

Figure 2-14  Save the newly created panel as BEA_PANEL.
Define a New Panel Group

A panel group must be defined to contain the panel that was just defined. From the menu select **File -> New**, and choose **Panel Group** in the **New** dialog (Figure 2-15). Select **OK**.

**Figure 2-15** Create a new panel group.

From the menu select **Insert -> Panel into Group** to bring up the Insert Panel dialog. Specify **BEA_PANEL** in the **Name** field and press the **Insert** button (Figure 2-16). Select **Close** to close the Insert Panel dialog (Figure 2-17).

**Figure 2-16** Insert the BEA_PANEL into the panel group.
Figure 2-17  The panel group with BEA_PANEL inserted.

A search record must be added to the panel group. This is the method by which eLink for PeopleSoft determines the names of available Message Agent Activities and Message Definitions:

1. From the menu select **File -> Object Properties** to bring up the Panel Group Properties dialog.
2. In the dialog select the **Use** tab.
3. Under Actions select the **Add, Update/Display, Update/Display All** checkboxes.
4. Ensure that the **Correction** and **Data Entry** checkboxes are not selected.
5. In the **Search Record** field specify BEA_CPS (by either typing it in or selecting it from the drop-down list) (Figure 2-18).
6. Select **OK** to return to the Panel Group Definition window.
2 Creating a BEA_CPS Message Definition

Figure 2-18 Define the properties of the panel group.

![Panel Group Properties]

Save the panel group by selecting File -> Save As from the menu. Type BEA_PNLGROUP as the Save Name As (Figure 2-19). Select OK to save and return to the Panel Group definition window. Add the panel group to the project by pressing <F7>. Close the Panel Group Definition window by selecting File -> Close from the menu.

Figure 2-19 Save the newly created panel group as BEA_PNLGROUP.

![Save As]

The panel group must now be associated with a menu.

To create the menu select File -> New from the menu and select Menu from the New dialog. Select OK.

Choose Standard as the Menu type and select OK (Figure 2-20).
Define the Field Properties

This will display a menu window with the new menu in it. In the menu, between Favorites and Language, is an empty space outlined with a dashed rectangle (Figure 2-21). Double click within this rectangle to bring up the Bar Item Properties dialog.

Type BEA in the Name field and eLink for PeopleSoft in the Label field (Figure 2-22).

Select OK.

Figure 2-20  Create a new standard menu.

Figure 2-21  The newly created menu.
Figure 2-22  Add a new bar item, CPS, to the menu.

The menu now needs a menu item. Double click in the new dashed rectangle that is below the heading “CPS” to bring up the Menu Item Properties dialog. Enter CPS1 in the Name field and Definitions in the Label field (Figure 2-23).

Figure 2-23  Add a menu item, “Definitions,” to the bar item “CPS.”

The panel group created previously is added to the menu by pressing the Select button on the Menu Item Properties dialog. Press the Select button to bring up the Open Object dialog. Specify BEA_PNLGROUP as the Name (Figure 2-24). Press the Select button in the Open Object dialog to return to the Menu Item Properties dialog. Select OK in the Menu Item Properties dialog.
Create The New Business Process

Figure 2-24  Add BEA_PNLGROUP to eLink for PeopleSoft.

![Image of BEA_PNLGROUP window]

Save the Menu by selecting **File -> Save As** from the menu. Specify BEA_MENU as the **Save Name** as (Figure 2-25). Select **OK**. Add the panel group to the project by pressing <F7>. Close the **Menu Definition** window by selecting **File -> Close** from the menu.

Figure 2-25  Save the newly created menu as BEA_MENU.

![Image of Save As dialog]

Create The New Business Process

A business process must be created to contain the Activity and Message Definition that eLink for PeopleSoft uses.
2 Creating a BEA_CPS Message Definition

Create a new business process by selecting File -> New from the menu and selecting Business Process from the New dialog (Figure 2-26). Select OK. This will bring up the Business Process window and a small, detached activity window.

Figure 2-26  Create a business process with the Activity and Message Definition.

Create a New Activity

Click on the button with three footprints. Move the pointer over the Business Process window (pointer will change to a box) and press the mouse button. The Activity Choices dialog will be displayed. Select Create New Activity (Figure 2-27). Select OK. This will place an icon of the three footprints in the Business Process window (Figure 2-28).

Figure 2-27  Create a new activity within the business process.
Define the Activity

Right click on the three footprint icon in the Business Process window. This will display the Activity Definition dialog. In the Name field type BEA_CPSActivity and then press <Tab>.

Note: The Icon Description will be filled in automatically with the data from the Name field when focus is shifted from the Name field.

In the description field type “This activity is used by BEA eLink for PeopleSoft during initialization.” (Figure 2-29). Select OK. Be sure to use the same capitalization as documented.
2 Creating a BEA_CPS Message Definition

Figure 2-29 Define the activity as BEA_CPSActivity.

Figure 2-30 The business process now contains the BEA_CPSActivity definition.
Double click on the BEA_CPSActivity icon in the Business Process window (Figure 2-30). The Business Process window will be blank and the small floating window will now contain several more, different icons (Figure 2-31). Click on the icon that appears to be a door and move the pointer into the Business Process window (the pointer will change to a small box) and click in the Business Process window. This will place the door icon in the window (Figure 2-32).

Figure 2-31  Add a Message Agent Message Definition.
Define the Message Definition

Right click on the door icon in the Business Process window to bring up the Message Agent Definition dialog. Specify BEA_CPSNames in the Name field and press <Tab> (the Icon Description field will be filled in automatically after focus changes from the Name field). For the Description field type: “This definition is used by BEA eLink for PeopleSoft during initialization.” Be sure to use the specified capitalization.
Figure 2-33 Name the new Message Agent Message Definition BEA_CPSNames.

Select the Attributes button to bring up the Message Attributes dialog. Specify the following for each of the fields (either by typing in the values or selecting them from the drop-down lists) (Figure 2-34):

If the optional steps were performed as described in “Create a Panel to Acces the BEA_CPS Message Definition (Optional),” specify the following values:

- Menu Name-BEA_MENU
- Bar Name-BEA
- Item Name-CPS1
- Action Name-Update/Display All
- Search Record-BEA_CPS
2 Creating a BEA_CPS Message Definition

Figure 2-34 Attributes for BEA_CPSNames when not for use within PeopleTools.

Select OK to return to the Message Agent Definition dialog.

Select the Level Mapping button on the Message Agent Definition dialog. In the If Row Found section select the Update radio button. In the If Row Not Found section select the Insert radio button (Figure 2-35). Select OK to return to the Message Agent Definitions dialog.

Figure 2-35 Define the Level Mapping attributes.

Select the Field Mapping button to bring up the Message Agent Field Map dialog (Figure 2-36). Select the Add button to bring up the Map Field dialog.
Figure 2-36  Add field mapping to the BEA_CPSNames Message Definition.

In the **Value** section highlight (Search Record) in the **Record** box and then ACTIVITYNAME in the **Field** box. In the **Field Name** specify ACTIVITYNAME (Figure 2-37). Select **OK** to return to the **Message Agent Field Map** dialog. Select the **Add** button again to bring back the **Map Field** dialog.

Figure 2-37  Field mapping without ACTIVITYNAME Message Definition.
In the Value section highlight (Search Record) in the Record box and then INPUTNAME in the Field box. In the Field Name specify INPUTNAME (Figure 2-38). Select OK to return to the Message Agent Field Map dialog.

Figure 2-38  Field mapping without INPUTNAME Message Definition.

Select OK from the Message Agent Field Map dialog (Figure 2-39) to return to the Message Agent Definition dialog. Select OK in the Message Agent Definition dialog to return to the Business Process window.
Define the Message Definition

Figure 2-39  Message Definition BEA_CPSNames with required field mappings.

Save the Business Process by selecting File -> Save As from the menu. Type BEA_CPSBUSPROC in the Save Name As field (Figure 2-40). Select OK. Add the Business Process to the Project by pressing <F7>. Close the Business Process by selecting File -> Close from the menu.

Figure 2-40  Save the newly created Business Process as BEA_CPSBUSPROC.

Save the Project by selecting File -> Save Project from the menu. Enter BEA_CPS as the name to save as (Figure 2-41).

Figure 2-41  Save the eLink for PeopleSoft project as BEA_CPS.

Figure 2-42 shows the BEA_CPS project with all the components visible.
Figure 2-42 All items defined in the eLink for PeopleSoft project.

Select File -> Exit from the menu to exit the application designer. The PeopleSoft definitions required by eLink Adapter for PeopleSoft have now been created.
To make the eLink for PeopleSoft menu visible within the PeopleSoft GUI, permissions must be granted to authorized users. Launch the PeopleTools Object Security application.

Open the PeopleTools group by selecting **File -> Open -> Group**, highlighting PeopleTools, and pressing **OK**.

From the menu select **View -> Menus**.
In the Excluded Menus list, on the right side of the window, the BEA_MENU will be listed. Highlight BEA_MENU by clicking on it.

Add it to the usable list by clicking on the single left arrow in the middle of the window.
Save the changes by selecting **File -> Save** from the menu.

Exit PeopleSoft Object Security by selecting **File -> Exit**.

**Launching the Security Administrator**

To launch the Security Administrator, select **File -> Open**. Press the arrow to the right of the **Operator/Class Name** input field. ALLPANLS will be inserted into the **Operator/Class Name** field.
Select OK and the ALLPANLS Class displays.

Click on the Menu icon on the left side of the window. Insert the BEA_MENU by selecting Insert -> Menu Name from the menu. This brings up the Insert Menu Name dialog.
Highlight BEA_MENU from the list and select OK to bring up the Select Menu Items dialog.

Press the Select All button and then press the OK button to return to the Security Administrator main window, which now should include BEA_MENU in the menu list.
Save the changes by selecting **File -> Save** from the menu and then exit the Security Administrator selecting **File -> Exit**. The BEA Menu will now be available from within the PeopleTools GUI. In order for the menu item to appear, any running PeopleTools Applications must be restarted (e.g. If Security Administrator was launched from within the Application Designer, the Application Designer must be exited and re-started). The BEA Menu will appear under the Go menu item.
3 Installing eLink Adapter for PeopleSoft

This chapter contains information for installing and uninstalling the eLink Adapter for PeopleSoft product.

Pre-Installation Considerations

The eLink Adapter for PeopleSoft software runs on Digital UNIX, HP-UX, AIX, Solaris, and Windows NT platforms. Complete the following tasks prior to installing eLink Adapter for PeopleSoft:

♦ Read the BEA eLink Adapter for PeopleSoft Release Notes.
♦ Install and verify the operation of the BEA TUXEDO product.
♦ The following server platforms are supported for eLink for PeopleSoft:
  ♦ HP-UX
  ♦ AIX Version
  ♦ Solaris
  ♦ Windows NT (Intel)
3 Installing eLink Adapter for PeopleSoft

Configuring the Environment to Install eLink for PeopleSoft

Before installing eLink Adapter for PeopleSoft, you must configure the environment properly. Ensure that BEA TUXEDO is configured properly.

Installing BEA eLink Adapter for PeopleSoft

The eLink Adapter for PeopleSoft software will run on Unix-based platforms and Windows NT. Refer to the appropriate platform sections that follow for installation instructions.

Installing on UNIX-based Platforms

To install the eLink Adapter for PeopleSoft software, you run the install.sh script. This script installs all the necessary software components.

Perform the following steps to install the eLink Adapter for PeopleSoft software on a supported UNIX platform.

1. Log on as root to install eLink for PeopleSoft.
   
   $ su -
   Password:

2. Access the CD-ROM device.
   
   # ls -l /dev/cdrom
   total 0
   brw-rw-rw- 1 root sys 27, 0 September 27 10:55 c1b0t010

3. Mount the CD-ROM.
   
   # mount -r -F cdfs /dev/cdrom/c1b0t010 /mnt

4. Change the directory to your CD-ROM device.
   
   # cd /mnt
5. List the CD-ROM contents.

```
# ls
install.sh hp sun5x ibm alpha winnt
```

6. Execute the installation script.

```
# sh ./install.sh
```

7. The installation script runs and prompts you for responses. Listing 3-1 is an example of the installation script. The entries in bold represent user responses.

**Listing 3-1  Install.sh Example**

```
01 alpha.dux40 02) hp/hpux1020 03) hp/hpux11
04) ibm/aix43 05) sun5x/sol26 06) sun5x/sol17

Install which platform’s files? [01-6, q to quit, l for list]: 3

** You have chosen to install from hp/hpux11 **

Is this correct? [y,n,q]: y

To terminate the installation at any time press the interrupt key, typically <del>, <break>, or <ctrl+c>.

The following packages are available:

```
1     eps        BEA eLink Adapter for PeopleSoft
```

Select the package(s) you wish to install (or ‘all’ to install all packages) (default: all) [?,??,q]: all

BEA eLink Adapter for PeopleSoft
(9000) Release 1.1
Copyright (c) 1999 BEA Systems, Inc.
All Rights Reserved.
Distributed under license by BEA Systems, Inc.
BEA eLink is a trademark of BEA Systems, Inc.

Directory where PeopleSoft Adapter files are to be installed (Enter your TUXEDO directory path) [?,q]: /work/cmadm/tux64
3 Installing eLink Adapter for PeopleSoft

Using /work/cmadm/tux64 as the PeopleSoft Adapter base directory

Determining if sufficient space is available ... 
200 blocks are required
493566 blocks are available to /work/cmadm/tux64

Unloading /cmhome/dist/eps-2/hp/hpux11/eps/EPST64.Z...
bin/cps
bin/lic.sh
eLink/peoplesoft/psappserv/psappsrv.dc
eLink/peoplesoft/psappserv/psappsrv.ubx
eLink/peoplesoft/psappserv/readme.txt
eLink/peoplesoft/psappserv/setenv.bat
eLink/peoplesoft/psappserv/setenv.sh
eLink/peoplesoft/simpeps/MsgAgtEx.fml
eLink/peoplesoft/simpeps/ePS.dc
eLink/peoplesoft/simpeps/ePS.env
eLink/peoplesoft/simpeps/ePS.ubb
eLink/peoplesoft/simpeps/in.ud
eLink/peoplesoft/simpeps/readme.txt
eLink/peoplesoft/simpeps/setenv.bat
eLink/peoplesoft/simpeps/setenv.sh
locale/C/CPSMSG_CAT
udataobj/CPSDef.fml
180 blocks
...finished

Changing file permissions...
...finished

If your license file is accessible, you may install it now.
Install license file? [y/n]:n

Please don’t forget to use lic.sh located in your product bin
directory to install the license file from the enclosed floppy.
Refer to your product Installation Guide for details on how to do
this.

Installation of BEA eLink Adapter for PeopleSoft was successful

Please don’t forget to fill out and send in your registration card

8. Change the directory to your root directory.

# cd /
9. Unmount the CD-ROM device.

Installing on a Windows NT Platform

The following steps will install the eLink for peopleSoft software on a Windows NT system.

1. Insert the product CD-ROM and click the Run option from the Start menu. The Run window displays. Click Browse to select the CD-ROM drive. Change directories to the \winnt directory and select Setup.exe program. Click OK to run the executable and begin the installation. The following Welcome screen displays. Click Next to continue with the installation.

![Figure 3-1 Welcome Screen](image)

2. The BEA Software License Agreement displays. Click Yes to accept the terms of the agreement and continue with the product installation. Click No to exit the installation process.
3 Installing eLink Adapter for PeopleSoft

Figure 3-2  BEA Software License Agreement

3. The User Information screen displays after the Software License Agreement screen. Enter the user name in the Name field. Enter the name of your company in the Company field. Click Next to continue with the installation.

Figure 3-3  User Information Screen
4. The **Install License File?** option screen displays next. You may select **Yes** to install your BEA Software License File, or you may select **No** to bypass this step and continue installing the eLink Adapter for PeopleSoft software. If you select **Yes**, continue with step 5. If you select **No**, continue with Step 7.

**Figure 3-4  Install License File? Screen**

![License File? Screen](image)

5. The **Select License File Source Directory** screen displays. Enter the directory path where your license file resides in the field. You can browse and click directories by clicking the **Browse** button. Typically, the license file is installed in the `tuxedo/udataobj` directory.

   If you entered a valid directory path, click **Next** to continue with the installation. Go to Step 7. If you entered an invalid directory path, go to Step 6.

**Figure 3-5  Select License File Source Directory Screen**

![License File Source Directory](image)

6. If you do not enter a valid directory path for your license file, the installation software generates an error message dialog box. You can select **Yes** to enter a valid directory path, or you can select **No** to continue with the installation. If you
select No, the installation software automatically searches for either the TUXEDO or WebLogic Enterprise software. If it finds either, the installation software completes the process. If neither is found, the installation software aborts the process.

Once you have entered a valid directory path, click Next to continue with the installation. Go to Step 7.

**Figure 3-6 Invalid License File Directory Dialog Box**

7. A progress bar displays showing the status of the installation.

8. The Setup Complete screen displays notifying you that the BEA eLink Adapter for PeopleSoft product is installed on your system. Click Finish to complete the Setup process.

**Figure 3-7 Setup Complete Screen**
The eLink Adapter for PeopleSoft CD-ROM contains the following libraries and executable programs. After installing the eLink Adapter for PeopleSoft software, verify that these libraries and programs are installed on your system.

Verify that the following files are installed by the eLink Adapter for PeopleSoft software.

Table 3-1 Distribution Libraries and Executables

<table>
<thead>
<tr>
<th>Directory</th>
<th>Files</th>
</tr>
</thead>
<tbody>
<tr>
<td>/bin</td>
<td>cps</td>
</tr>
<tr>
<td></td>
<td>CPSMSG_CAT</td>
</tr>
<tr>
<td>/udataobj</td>
<td>CPSDef.fml</td>
</tr>
<tr>
<td>elink/peoplesoft/simpeps</td>
<td>ePS.dc</td>
</tr>
<tr>
<td></td>
<td>ePS.env</td>
</tr>
<tr>
<td></td>
<td>ePS.ubb</td>
</tr>
<tr>
<td></td>
<td>in.ud</td>
</tr>
<tr>
<td></td>
<td>MsgAgtEx.fml</td>
</tr>
<tr>
<td></td>
<td>readme.txt</td>
</tr>
<tr>
<td></td>
<td>setenv.bat</td>
</tr>
<tr>
<td></td>
<td>setenv.sh</td>
</tr>
<tr>
<td>elink/peoplesoft/psappsv</td>
<td>psappsrv.dc</td>
</tr>
<tr>
<td></td>
<td>psappsrv.ubx</td>
</tr>
<tr>
<td></td>
<td>readme.txt</td>
</tr>
<tr>
<td></td>
<td>setenv.bat</td>
</tr>
<tr>
<td></td>
<td>setenv.sh</td>
</tr>
</tbody>
</table>
Perform the following steps to uninstall the eLink Adapter for PeopleSoft on a Windows NT system.

1. Click the **Start** button, and then point to **Settings**. Point to the folder that contains **Control Panel**, and then click **Control Panel**.

2. Double click on the **Add/Remove Programs** option from the **Control Panel** listings to access the **Add/Remove Programs** properties window.

3. In the **Add/Remove Programs Properties** window, select eLink Adapter for PeopleSoft from the program list and click the **Add/Remove** button.

4. The uninstall process for eLink for PeopleSoft begins. The **Remove Programs From Your Computer** screen displays. Click **OK** to complete the uninstall process.

**Figure 3-8   Remove Programs From Your Computer Screen**
4 Configuring PeopleSoft Application Server Domain

It is possible to configure eLink Adapter for PeopleSoft differently from the configuration detailed here. For example, eLink Adapter for PeopleSoft can run on the same computer as PeopleSoft. These variations are simply a matter of configuring TUXEDO via the UBBCONFIG file, the scope of which is outside this document.

The configuration detailed in this document is an example. It should be a simple exercise to modify the configuration to meet any specific site needs. Refer to the TUXEDO documentation for details concerning TUXEDO configuration.

Note: This example assumes that PeopleSoft has been installed and properly configured for three-tier mode. When configuring PeopleSoft in three-tier mode, you must stop and restart the PeopleSoft application server domain. Therefore, this configuration example requires that the PeopleSoft services be stopped and restarted.
Configuring to Run Multiple Domains

This section details configuration of TUXEDO so that PeopleSoft and eLink Adapter for PeopleSoft run in separate domains.

Configuring the PeopleSoft Domain

1. Modify the domain’s `psappsrv.ubx` file (usually located in the `PS_HOME\appserv\domain` directory) on the computer running PeopleSoft. Add the following entries to the end of the specified sections:

   Listing 4-1   psappsrv.ubx Changes

   *GROUPS
   PSDGRP GRPNO = 2 OPENINFO = NONE

   *SERVERS
   DMADM
     SRVGRP = PSDGRP SRVID = 30
   GWADM
     SRVGRP = PSDGRP SRVID = 31
   GWTDOMAIN
     SRVGRP = PSDGRP SRVID = 32

2. Copy the `psappsrv.dc` file from the `samples\psappsrv` directory to the `PS_HOME\appserv\domain` directory. It must be modified to reflect the site-specific information. The default `psappsrv.dc` provided is shown in Listing 4-2.

   Listing 4-2   Default psappsrv4v.dc

   #
   DM_LOCAL_DOMAINS
   TESTSERV GWGRP=PSDGRP
     TYPE=TDOMAIN
Configuring to Run Multiple Domains

```
DOMAINID="TESTSERV"
DMTLOGDEV="<PS_HOME>appserv\<domain>\DMTLOG"

*DM_REMOTE_DOMAINS

eLink   TYPE=TDOMAIN
      DOMAINID="eLink"

*DM_TDOMAIN

eLink   NWADDR="<IP:port of eLink Adapter for PeopleSoft machine>"
TESTSERV NWADDR="<IP:port of PS machine>"

*DM_REMOTE_SERVICES
```

3. Run `psadmin` to reconfigure the domain; no modifications to any of the configurations settings should be necessary. Do not boot the domain yet.

4. Set the following environment variables at the command prompt:

   ```
   SET TUXCONFIG=<PSHOME>\appserv\<domain>\pstuxcfg
   SET BDMCONFIG=<PSHOME>\appserv\<domain>\BDMCONFIG.
   ```

5. After modifying the `psappsrv.dc` file for your site, run `dmloadcf` to create the binary domain configuration file:

   ```
dmloadcf -y psappsrv.dc
   ```

6. Boot the PeopleSoft domain via `psadmin`.

   **Note:** The DMADM server will log an informational message (CMDGW_CAT:3149) upon startup. This message indicates that the default domain gateway configuration file is being used. This is normal in this configuration.

### Configuring eLink Adapter for PeopleSoft Domain

1. Create a UBBCONFIG file for eLink Adapter for PeopleSoft on the computer running the software. A sample `ePS.ubb` is shown in Listing 4-3.
4 Configuring PeopleSoft Application Server Domain

Listing 4-3  Sample ePS.ubb file

```
# This is a skeletal TUXEDO configuration file - "ePS.ubb"
# designed to be used for eLink Adapter for PeopleSoft.

*RESOURCES
IPCKEY          33247        # ( 32768 < IPCKEY < 262143 )
MASTER          eLink
DOMAINID        eLink
MODEL           SHM
MAXSERVERS       20
SECURITY        NONE

*MACHINES
"<Name of computer running eLink>" LMID="eLink"
 TUXDIR="C:\TUXEDO"
 APPDIR="C:\BEA_eLink\PeopleSoft\samples"
 TUXCONFIG="C:\BEA_eLink\PeopleSoft\samples\ePS.tux"
 ULOGPFX="C:\BEA_eLink\PeopleSoft\samples\ULOG"
 ENVFILE="C:\BEA_eLink\PeopleSoft\samples\ePS.env"
 TYPE="i386NT"
 MAXACCESSERS=80

*GROUPS
 CPSDGRP LMID=eLink
 GRPNO=1
 DGRP LMID=eLink
 GRPNO=2
 OPENINFO=NONE

*SERVERS
 DEFAULT:
 CLOPT="-A"       # Advertise all services.
 REPLIQ=N         # Reply queue not needed for our simple setup.
 MAXGEN=3         # Max number of restarts in the grace period.
 GRACE=60         # Ten minutes grace period.
 RESTART=Y
 SYSTEM_ACCESS=FASTPATH

 DMADM
 SRVGRP = DGRPSRVID = 30

 GWADM
 SRVGRP = DGRPSRVID = 31

 GWTDOMAIN
```
SRVGRP = DGRPSRVID = 32

CPS
SRVGRP=CPSDGRP
SRVID=155
RQADDR="MSGAPIQ"
REPLYQ=Y
CLOPT="-A -- -l7 -p2,L -s2,R"

*SERVICES

2. Modify the machine name to reflect the name of the computer on which eLink Adapter for PeopleSoft is running.

3. Modify the paths to point to the correct locations.

4. Run tmloadcf to create the binary configuration file.

    tmloadcf -y ePS.ubb

    Note: The TUXCONFIG environment variable must match the one specified in ePS.ubb, in this case ePS.tux.

The FML Definition Files must be placed in a directory accessible by eLink Adapter for PeopleSoft. The ePS.env file provided as shown in Listing 4-4.

Listing 4-4   ePS.env File

    FIELDTBLS32=CPSDef.fml,MsgAgtEx.fml
    FLDTBLDIR32=C:\BEA_eLink\PeopleSoft\winx86\bin;
                 C:\BEA_eLink\PeopleSoft\samples
    CPSOprId=<PTADMIN>
    CPSOprPswd=<PTADMIN>
5. Modify the settings as follows:

- The eLink Adapter for PeopleSoft path must point to the appropriate location.
- CPSOprId and CPSOprPswd must be the Operator ID and password of a valid PeopleSoft user with the privileges necessary to run the CPSNames Message Definition.

It may be desirable to add \( \text{Usysfl32} \) to FIELDTBLS32 and \( \text{TUXDIR\udataobj} \) (where \( \text{TUXDIR} \) is the full path to the TUXEDO home directory) to FLDTBLDIR32 to allow the use of \( \text{ud32} \) with eLink Adapter for PeopleSoft.

6. Create the domain configuration file for the eLink domain. A sample configuration file is shown in Listing 4-5.

**Listing 4-5  Sample Configuration File**

```plaintext
*DM_LOCAL_DOMAINS
# Domain in which BEA eLink Adapter for PeopleSoft is running
eLink  GWGRP=DGRP
       TYPE=TDOMAIN
       DOMAINID="eLink"
       DMTLOGDEV="c:\BEA_eLink\PeopleSoft\samples\DMTLOG"

# Domain in which PeopleSoft is running
*DM_REMOTE_DOMAINS
TESTSERV  TYPE=TDOMAIN
       DOMAINID="TESTSERV"

*DM_TDOMAIN
eLink       NWADDR="<IP:Port of eLink machine>"
TESTSERV    NWADDR="<IP:port of PS machine>"

*DM_REMOTE_SERVICES
MsgAPI
GetCertificate
```

7. Modify the machine name to reflect the name of the computer on which eLink Adapter for PeopleSoft is running.
8. Modify the paths to point to the correct locations.

9. Ensure that the BDMCONFIG environment variables are set before running `dmloadcf`.

10. Run `dmloadcf` to create the binary configuration file.
    
    `dmloadcf -y ePS.dc`
4 Configuring PeopleSoft Application Server Domain
Configuring FML32

Communication with eLink Adapter for PeopleSoft is achieved through the use of FML32 buffers. This section details the creation of the FML Definition Files and configuration of the environment to allow eLink Adapter for PeopleSoft to find the FML definition files. For a complete overview of FML buffers see the TUXEDO FML Programmer’s Guide provided with TUXEDO.

Create the FML Definition File(s)

The eLink Adapter for PeopleSoft component maintains a one-to-one relationship between the FML field names and the field names used in the PeopleSoft Message Definitions (note this is not the record field’s name, it is the name entered for the Message Definition field mapping). In order for eLink Adapter for PeopleSoft to use the FML fields there must be one or more FML Field Definition Files which must be included in the environment variable FIELDTBLS32 and located in a directory included in the environment variable FLDTBLDIR32, both of which are in the ePS.env file.

The eLink Adapter for PeopleSoft component treats all fields as being of type string. Therefore, only unique Message Definition fields names need defining – eLink Adapter for PeopleSoft does not differentiate between multiple occurrences of the same field name in different Message Definitions when passing data between one another. It is up to the system manager to determine how to maintain the FML definition files. They may be stored in one file or broken into sets of files that may, for example, correspond to the fields used for each individual Activity.

There are several ways to determine the Message Definition field names. Two of the easier ways are:
To determine the field names that must be defined in an FML definition file using the PeopleTools Application Designer, open each Message Agent Message Definition that will be used with eLink Adapter for PeopleSoft. Inside each Message Definition in the Field Mapping section, obtain the list of field names used by that Message Definition. For example: in the PeopleSoft demonstration database the Business Process MSGAGT_EXAMPLES contains one Activity, MsgAgtExamples, which contains four Message Definitions: AddL0, AddUpdRow, ReadRow, and ReadRows. Examining the Field Mapping for the ReadRows Message Definition shows four defined fields: EMPLID, NAME_TYPE, NAME_PART, and PREFERRED_NAME. These are the fields that must be defined in an FML Definition File.

Figure 5-1 shows the list of message definition fields that must be defined in an FML definition file in order to use eLink Adapter for PeopleSoft with the message agent message definition.

**Figure 5-1 List of necessary message definition fields.**
Create the FML Definition File(s)

The FML Definition File must contain lines similar to the following:

<table>
<thead>
<tr>
<th>Field</th>
<th>Value</th>
<th>Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>EMPLID</td>
<td>900</td>
<td>string</td>
<td>EmployID</td>
</tr>
<tr>
<td>NAME_TYPE</td>
<td>901</td>
<td>string</td>
<td>Type of name for employee</td>
</tr>
<tr>
<td>NAME_PART</td>
<td>902</td>
<td>string</td>
<td>ID of portion of name of employee</td>
</tr>
<tr>
<td>PREFERRED_NAME</td>
<td>903</td>
<td>string</td>
<td>Preferred name of employee</td>
</tr>
</tbody>
</table>

To obtain the list of fields by querying the database directly, use the following SQL query:

```sql
select distinct C.FIELDNAME
from PSMSGAGTDEFN A, PSBUSPROCXREF B, PSMAPRECFIELD C
where B.COMPONENTNAME=A.ACTIVITYNAME
and C.ACTIVITYNAME=A.ACTIVITYNAME
order by C.FIELDNAME
```

The selection may be modified to obtain the fields for one or a set of Activities by adding additional constraints to the “where” clause.

For example, to obtain the fields used only by the MsgAgtExamples Activity, use the following query:

```sql
select distinct C.FIELDNAME
from PSMSGAGTDEFN A, PSBUSPROCXREF B, PSMAPRECFIELD C
where B.COMPONENTNAME=A.ACTIVITYNAME
and C.ACTIVITYNAME=A.ACTIVITYNAME
and C.ACTIVITYNAME='MsgAgtExamples'
order by C.FIELDNAME
```
5 Configuring FML32
This section discusses starting the TUXEDO domain(s) to allow eLink Adapter for PeopleSoft to function.

First, boot the PeopleSoft domain via `psadmin`. This domain must be running in order for the eLink for PeopleSoft server (CPS.EXE) to successfully initialize.

The eLink for PeopleSoft domain environment has to be set before it can be booted up. The environment variables that need to be set are: TUXCONFIG, BDMCONFIG, FIELDTBLS32 and FLDTBLDIR32. A sample environment batch file to do this has been provided in `elink\peoplesoft\simpeps\setenv.bat`.

The eLink for PeopleSoft domain can now be booted up by using the command:

```
tmboot -y
```

Based on the command line options given to eLink for PeopleSoft, it will look for all or specific Activities and create the TUXEDO services to execute those message definitions. The command line options for eLink for PeopleSoft are summarized below.

The eLink for PeopleSoft component maintains a one-to-one correspondence between each advertised service and each Message Agent Business Process–Activity pair. Four (optional) command line parameters control the way in which eLink for PeopleSoft service names are created from the PeopleSoft Activity and Message Definition names. The parameters are:

- `l<length>` (lowercase “L”)
  specifies the length of the service prefix constructed from the Activity name.
  Where `<length>` is replaced by one of the following numbers:
Service name derived solely from the Message Definition Name (uses none of the Activity Names).

Service name consists of characters from both the Activity and Message Definition names. The name uses a total of 14 characters from the two names: a prefix derived from the Activity name, a dot (".") , and a suffix derived from the Message Definition name. The number represents the maximum number of characters to use for the prefix.

An optional conversion level may be specified to control the algorithm used for creating the service name prefix and suffix. This conversion will be applied before concatenation, so that truncation occurs based on the setting of the "-l" parameter.

- `p<level>`
  specifies the conversion level to use for creating the service name prefix from the Activity name.

- `s<level>`
  specifies the conversion level to use for creating the service name suffix from the Message Definition name.

Where `<level>` is replaced by one of the following numbers:

- **0**
  At a conversion level of zero, no changes are made to the original name before the concatenation is performed. This is the default if the -p or -s is not specified.

- **1**
  Remove spaces, keeping up to 15 characters (note that further truncation may occur during the concatenation step)
  For example:
  “This Is A Long Name In PeopleSoft” becomes:
  “ThisIsALongName”
  “Administer Workforce” becomes “AdministerWorkf”

- **2**
  Remove spaces, and all vowels (y is considered a consonant) except capitals and letters preceded immediately by a space, up to 15
characters (again, further truncation may occur during concatenation).
For example: “This Is A Long Name In PeopleSoft” becomes:
“ThsIsALngNmInPp”
“Administer Workforce” becomes “AdmnstrWrkfrc”

-a<ActivityName>[,<ActivityName>...]  
Where: <ActivityName> is the (unmodified) name of a PeopleSoft Activity.

For each Activity specified, the Adapter will advertise services for every Message Definition in that Activity. The Adapter will advertise services for all Message Agent Message Definitions in all Activities if this option is not specified.

Command line options are processed from right to left, thus making it possible to use different lengths and mangling schemes (both prefix and suffix) for one, some, or all of the Activity – Message Definition pairs. If the –a option is encountered, the service names for that Activity are created using the previously set length (-l), prefix scheme (-p), and suffix scheme (-s). If any or all of these options are omitted the defaults are used.

FML32 Buffer

Communication with eLink for PeopleSoft is performed using FML32 buffers. The application making the PeopleSoft request must populate an FML32 buffer with the fields required by the PeopleSoft Message Definition.

In addition, two eLink for PeopleSoft defined fields must be populated: BEA_CPSOprId and BEA_CPSOprPswd. These fields correspond to the PeopleSoft Operator ID and password, respectively, that eLink for PeopleSoft will use to log in to PeopleSoft and perform the requested action.

All FML32 fields must be defined as type string. This applies to both the data being passed to eLink for PeopleSoft as well as the data returned from eLink for PeopleSoft.

Field names in the FML32 buffer are identical to the names used in the PeopleSoft Message.
If the Message Definition is expecting input of EmployeeID, HireDate, and Salary there must be FML32 fields of these names defined.

Multiple rows of data are represented as occurrences in the FML32 buffer. All fields with the same occurrence are treated as a single row of data to PeopleSoft. This provides the application with the ability to add or update multiple non-level 0 rows in PeopleSoft as well as receive multiple rows of data from PeopleSoft.

The FML32 buffer returned by eLink for PeopleSoft reserves one field, BEA_CPSError, for return status. This field will contain the return code and, if available, a string description of the error returned from PeopleSoft.

For example, the demonstration database that ships with PeopleSoft contains several Message Agent Message Definitions.
This chapter provides instructions for determining internal names for a PeopleSoft GUI dialog box components. This information is then used to create a Message Definition for TUXEDO applications to access the PeopleSoft database in the same manner as the PeopleSoft dialog box.

Throughout this chapter you will need to record dialog box information on the two worksheets located at the end of this chapter.

You must determine the following dialog box internal information in order to create the Message Definition:

- Menu name
- Dialog box name
- Dialog box group
- Record and field names associated with the dialog box
- Search record
Determining PeopleSoft Internal GUI Component Names

Perform the following steps to gather internal names for PeopleSoft GUI dialog box components.

The PeopleSoft dialog box used in this integration example is the “Disciplinary Action” panel. This panel is created as part of PeopleSoft’s demonstration application, PTDMO.

Displaying the Disciplinary Action Dialog Box

Perform the following steps to display the Disciplinary Action dialog box.

1. Select Start -> PeopleSoft7.5 -> PeopleTools. You will see the following dialog box; however, the title bar may display a different title.

2. Select Go -> Administer Workforce -> Administer Workforce (GBL) from the menu.
3. From the Administer Workforce dialog box, select **Use -> Disciplinary Action**. You will see the following dialog box.

**Figure 7-2 Employee ID Dialog Box**

4. Type the employee number G000 in the EmpID box and click OK. The Administer Workforce (GBL) - Use - Disciplinary Action dialog box displays.
For the purposes of this example, the Disciplinary Action dialog box is the object from which PeopleSoft internal information will be gathered.

Using the Message Definition Attributes worksheet in the back of this chapter, record the following information in the GUI name column.

- Menu Name - Administer Workforce (GBL)
- Menu Bar - Use
- Menu Item - Disciplinary Action
- Action - Update/Display
- Panel Name - Disciplinary Action

**Obtaining the Internal Menu Name**

Perform the following steps to obtain the internal menu name.

1. Select **Start -> PeopleSoft7.5 -> Application Designer**. You will see the Application Designer dialog box.

2. Select **File -> Open**. You will see the following Open Object dialog box.
3. In the Object Type drop-down list, select Menu.

4. Type % in the Name box and click Select. The “Objects matching selection criteria” field populates with a list of items.

5. Select the menu name that is similar to the GUI menu name. In this case, you select ADMINISTER_WORKFORCE_(GBL).

6. Click Select. The Application Designer development environment opens with the ADMINISTER_WORKFORCE_(GBL) dialog box displayed in the right pane. This serves as verification that you selected the correct object.
7. Using the Message Definition Attributes worksheet in the back of this chapter, record the following Menu Name information in the PeopleSoft Internal Name column.

- Menu Name - ADMINISTER_WORKFORCE (GBL)

### Obtaining the Internal Panel Name and Group

To obtain the panel name and panel group, you must open and examine the panel within the PeopleTools Application Designer.

Perform the following steps to obtain the internal panel name and group.

1. From within Application Designer, select **File -> Open**. You will see the Open Object dialog box.

2. In the Object Type drop-down list, select Menu.

3. Type ADMINISTER_WORKFORCE(GBL) in the name box and click Select. The “Objects matching selection criteria” field populates with a list of items.

4. Select the menu name that is similar to the GUI menu name. In this case, you select ADMINISTER_WORKFORCE_(GBL).
5. Click Select. The Application Designer development environment opens with the ADMINISTER_WORKFORCE_(GBL) dialog box displayed in the right pane. This serves as verification that you selected the correct object.

6. From within the ADMINISTER_WORKFORCE_(GBL) dialog box displayed in the right pane, select Use -> Disciplinary Action.

7. Right-click on Disciplinary Action and select View Definition from the menu. The following DISCIPLINARY_ACTN.GBL panel displays in the Application Designer dialog box.

Figure 7-6  Panel Group Dialog Box

8. Using the Message Definition Attributes worksheet in the back of this chapter, record the following Panel Name and Panel Group information in the PeopleSoft Internal Name column.
   - Panel Name - DISCIPLINARY_ACTN
   - Panel Group - DISCIPLINARY_ACTN.GBL

Obtaining the Search Record

Perform the following steps to obtain the Search Record.
7 Exposing PeopleSoft Panels to TUXEDO Applications

1. From within the Application Designer with the DISCIPLINARY_ACTN.GBL panel displayed, select File -> Object Properties. The Panel Group Properties dialog box displays.

2. Select the Use tab.

3. Using the Message Definition Attributes worksheet in the back of this chapter, record the following Search Record information in the PeopleSoft Internal Name column.

4. Click Cancel to close the Panel Group Properties dialog box.

5. Click Cancel to close the Panel Group dialog box.

6. Close the ADMINISTER_WORKFORCE_(GBL) Menu. If prompted to save changes, click No.

Obtaining the Record and Field Names

Perform the following steps to obtain Record and Field names.

1. Select Start -> PeopleSoft7.5 -> Application Designer. The Application Designer dialog box displays.

2. Select File -> Open. The Open Object dialog box displays.
3. In the Object Type drop-down list, select Panel.

4. In the Name box, type DISCIPLINARY_ACTN.

5. Click Select. The DISCIPLINARY_ACTN.ENG panel displays as shown.

Figure 7-8  DISCIPLINARY_ACTN.ENG Panel

6. To obtain the Record and Field information associated with the GUI object, double-click on the field of interest. The Panel Field Properties dialog box displays with the Record and Field information.
7. Select the Use tab to determine if the field is used for Display Only. If the field is Display Only, then TUXEDO applications are only able to retrieve the information, not update it.

8. Using the Message Definition Fields worksheet in the back of this chapter, record the Record Name, Field Name, and Display Only information.

9. Repeat steps 6 through 8 for every dialog box component of interest.

10. Select File -> Close to close the DISCIPLINARY_ACTN.ENG when you are finished. If prompted to save changes, click No.

Creating the Activity and Message Definition

Once you have obtained the Message Definition attributes and the field names associated with the GUI controls, you can create a Message Definition to access the panel’s information from a TUXEDO application.

Perform the following steps to create the activity and message definition.

1. Select Start -> PeopleSoft7.5 -> Application Designer. The Application Designer dialog box displays.
2. Select **File -> New -> Business Process.** The following panel displays within the Application Designer main window.

*Figure 7-10  Business Process Panel*

3. Click the “Three Footprints” icon to begin adding a new activity.

4. Click anywhere on the grid to display the Activity Choices window.

*Figure 7-11  Activity Choices Window*

5. Click the Create New Activity button.

6. Click OK. The “Three Footprints” icon displays on the grid window.

7. Place your cursor over the “Three Footprints” icon and right-click. The Activity Definition dialog box displays.
8. Use the dialog box to describe the new activity using the Name, Icon Descr, and Description fields.

9. Click OK. The icon for the new activity displays on the Business process grid.

10. Double-click the new activity icon to open the activity.

11. Click the Door icon to select it and then click somewhere on the grid to add a Message Definition.

12. Right-click the Message Definition to open the Message Agent Definition dialog box.
13. Type the appropriate descriptive information.

14. Click Attributes to open the Message Attributes dialog box.

15. From the Menu Name drop-down list, select ADMINISTER_WORKFORCE-(GBL).
16. Using the Message Definition Attributes worksheet in the back of this chapter, select the corresponding values from the Message Attributes drop-down lists.

17. Click OK to return to the Message Agent Definition dialog box.

18. Click Level Mapping to open the Map Level Options dialog box.

**Figure 7-15 Map Level Options Dialog Box**

![Map Level Options Dialog Box](image)

19. Accept all the defaults and click OK to return to the Message Agent Definition dialog box.

20. Click Field Mapping to open the Message Agent Field Map dialog box.
21. Click Add to open the Map Field dialog box.

Using the information recorded in the Message Definition Fields worksheet at the back of this chapter, map each field in the Message Agent Field Map so that this information can be retrieved by TUXEDO applications.

22. To add the field EMPLID, select Search Record in the Record pane.

23. Select EMPLID in the Field pane.
24. Type EMPLID in the Field Name box.

25. Accept the map Mode default.

26. Select Input from the Map When drop-down list.

27. Click OK to return to the Message Agent Field Map. The EMPLID field should be added to the Message Agent Field Map as shown below.

**Figure 7-18  Message Agent Field Map**

28. Add the remaining fields to the Message Agent Map definition. Since this message definition is for a query request, all other fields should be of type “Output”. These fields will not be sent in the query request, but will only be received in the query response.

**Note:** Notice that the Field Name defined in the Message Agent map does not have to match the field name of the record.

29. Continue adding output fields as necessary. A sample Message Definition follows.
Defining FML32 Fields

In order to use the new message definition, you must create the associated FML field identifiers.

For more information on defining FML32 fields, refer to the BEA TUXEDO FML Programmer’s Guide.

Perform the following steps to define the FML32 fields.

1. Edit the MsgAgtEx.fml.

30. Click OK to close the Message Agent Field Map dialog box.

31. Click OK to close the Message Agent Definition dialog box.

32. Select File -> Save to save the new business process, activity, and message definition.
2. Add each field from the Message Agent Field Map to the FML file. Each field should be of type string. The following table is the FML used for this example.

**Table 7-1 FML Example**

<table>
<thead>
<tr>
<th>#name</th>
<th>rel-number</th>
<th>type</th>
<th>flags</th>
<th>comment</th>
</tr>
</thead>
<tbody>
<tr>
<td>EMPLOYEE_ID</td>
<td>18</td>
<td>string</td>
<td>-</td>
<td>Employee ID</td>
</tr>
<tr>
<td>DISCIP_INCIDENTS</td>
<td>19</td>
<td>string</td>
<td>-</td>
<td>Number of incidents</td>
</tr>
<tr>
<td>DISCIP_INCIDENT_DATE</td>
<td>20</td>
<td>string</td>
<td>-</td>
<td>Date of incident</td>
</tr>
<tr>
<td>DISCIP_INCIDENT_TYPE</td>
<td>21</td>
<td>string</td>
<td>-</td>
<td>Incident type</td>
</tr>
<tr>
<td>DISCIP_INCID_TYPE_DESCR</td>
<td>22</td>
<td>string</td>
<td>-</td>
<td>Incident type description</td>
</tr>
<tr>
<td>DISCIP_INCIDENT_DESCR</td>
<td>23</td>
<td>string</td>
<td>-</td>
<td>Incident description</td>
</tr>
<tr>
<td>DISCIP_SUPERVISOR_ID</td>
<td>24</td>
<td>string</td>
<td>-</td>
<td>Employee ID of supervisor</td>
</tr>
<tr>
<td>DISCIP_SUPERVISOR</td>
<td>25</td>
<td>string</td>
<td>-</td>
<td>Supervisor name</td>
</tr>
<tr>
<td>DISCIP_INCID_PURGE_DT</td>
<td>26</td>
<td>string</td>
<td>-</td>
<td>Date that incident is forgotten</td>
</tr>
<tr>
<td>DISCIP_STEP_TYPE</td>
<td>27</td>
<td>string</td>
<td>-</td>
<td>Type of discipline taken</td>
</tr>
<tr>
<td>DISCIP_STEP_TYPE_DESCR</td>
<td>28</td>
<td>string</td>
<td>-</td>
<td>Descrip of discipline step type</td>
</tr>
<tr>
<td>DISCIP_STEP_DT</td>
<td>29</td>
<td>string</td>
<td>-</td>
<td>Date of discipline action</td>
</tr>
<tr>
<td>DISCIP_STEP_ADVISOR</td>
<td>30</td>
<td>string</td>
<td>-</td>
<td>Discipline advisor</td>
</tr>
<tr>
<td>DISCIP_STEP_COMMENTS</td>
<td>31</td>
<td>string</td>
<td>-</td>
<td>Comments on discipline action</td>
</tr>
</tbody>
</table>
Testing the New Message Definition

Perform the following steps to test the new Message Definition.

1. Reboot the eLink for PeopleSoft adapter to take advantage of the new FML fields and the new Message Definition.
   tmshutdown -s cps
   tmboot -s cps

2. Create a script for the ud32 utility. The ud32 utility can read tab-delimited text and create a FML32 buffer request. Use the following ud32 script to test this example.
   SRVCNM  QryDscp.DscActn
   BEA_CPSOprID   PTDMO
   BEA_CPSOprPswd PTDMO
  EMPLID   G000

3. Send the script to the indicated service and print out the FML32 response.
   This script will invoke service “QryDscp.DscActn”, sending an operator ID. ad operator password, and an employee id to return Disciplinary information on. The following is the output for the example.
   $ud32 < disp.ud
   SENT pkt(1) is:
   SRVCNM QryDscp.DscActn
   BEA_CPSOprId   PTDMO
   BEA_CPSOprPswd PTDMO
   EMPLID   G000

   RTN pkt(1) is:
   BEA_CPSRows     1
   DISCIP_INCIDENTS     1
   DISCIP_INCIDENTS_DATE 02/11/1994
Exposing PeopleSoft Panels to TUXEDO Applications

DISCIP_INCIDENT_TYPE LRF
DISCIP_INCID_TYPE_DESCR Late return from lunch
DISCIP_INCIDENT_DESCR Greg returned 30 minutes late from lunch
Tardiness has been a recurring problem with Greg.
DISCIP_SUPERVISOR_ID 8154
DISCIP_SUPERVISOR Peck, Jan
DISCIP_INCID_PURGE_DT 08/11/1994
DISCIP_STEP_TYPE 1
DISCIP_STEP_TYPE_DESCR Discuss with dept. Supervisor
DISCIP_STEP_DT 02/11/1994
DISCIP_STEP_ADVISOR Richardson, Dion
DISCIP_STEP_COMMENTS Greg has been verbally reprimanded. Further tardiness will result in dock in pay.
Message Definition Worksheets

Use the following worksheets to record the information needed to create a Message Definition.

Table 7-2  Message Definition Attributes

<table>
<thead>
<tr>
<th>GUI Name</th>
<th>PeopleSoft Internal Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td></td>
</tr>
<tr>
<td>Men Bar</td>
<td></td>
</tr>
<tr>
<td>Menu Item</td>
<td></td>
</tr>
<tr>
<td>Action</td>
<td></td>
</tr>
<tr>
<td>Panel</td>
<td></td>
</tr>
<tr>
<td>Name</td>
<td></td>
</tr>
<tr>
<td>Panel</td>
<td></td>
</tr>
<tr>
<td>Group</td>
<td></td>
</tr>
<tr>
<td>Search</td>
<td></td>
</tr>
<tr>
<td>Record</td>
<td></td>
</tr>
</tbody>
</table>

Table 7-3  Message Definition Fields

<table>
<thead>
<tr>
<th>Record Name</th>
<th>Field Name</th>
<th>Display Only</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
## Exposing PeopleSoft Panels to TUXEDO Applications

<table>
<thead>
<tr>
<th>Record Name</th>
<th>Field Name</th>
<th>Display Only</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>