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Preface

This document provides detailed instructions for installing the BEA Business Pro
Option Servers.

Who Should Read This Document

This document is intended for system administrators responsible for installing an
configuring the BEA Business Process Option system.

How This Document Is Organized

The BEA eLink Business Process Option Configuration Guide is organized as follows:

� Chapter 1, “Business Process Option Architectural Overview,” provides a brief 
description and graphical representation of the primary Business Process Op
components that you will be configuring.

� Chapter 2, “Business Process Option Configuration Overview,” describes the 
files and procedures involved in configuring the eLink Business Process Opti
application for eLink Platform 1.2.

� Chapter 3, “Configuring the Server Platform Environment,” provides 
instructions for configuring your UNIX shell environment for the Business 
Process Option application running under BEA eLink Platform 1.2. 

� Chapter 4, “Configuring the Business Process Engine,” provides instructions for 
modifying the eLink_BPO.env  file to configure your Business Process Option 
Client environment.
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� Chapter 5, “Configuring the Business Process Option Servers,” provides 
instructions for modifying the eLink_BPO.cfg  file to configure your Business 
Process Option Server environment.

� Chapter 6, “Creating the eLink Platform Configuration Files,” provides 
instructions for creating the eLink Platform configuration files for the Busines
Process Option application. This includes specific instructions for using the 
eLink Platform Configuration utilities to generate these files.

� Appendix A, “Configuration Information Checklist,” provides checklists you can
use to gather the information you will need to complete the Business Process
Option configuration process.

� Appendix B, “Configuration Expert Quick Reference Guide,” provides a 
description of the main windows and navigation procedures for the 
Configuration Expert and Configuration Data Editor utilities.

� Appendix C, “Sample Configuration Files,” provides samples of files the BEA 
eLink Business Process Option uses to configure the platform environment a
the various client and server components.

How to Use This Document

This document, the BEA eLink Business Process Option Server Configuration Gui, 
is provided as a virtual print document in Adobe Acrobat PDF format.

Documentation Conventions

The following documentation conventions are used throughout this document.

Convention Item

boldface text Indicates terms defined in the glossary.

Ctrl+Tab Indicates that you must press two or more keys simultaneously.
vi BEA eLink Business Process Option Configuration Guide
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italics Indicates emphasis or book titles.

monospace 
text

Indicates code samples, commands and their options, data structures a
their members, data types, directories, and file names and their extensio
Monospace text also indicates text that you must enter from the keyboa

Examples:

#include <iostream.h> void main ( ) the pointer psz

chmod u+w *

\tux\data\ap

.doc

tux.doc

BITMAP

float

monospace 
boldface 
text

Identifies significant words in code.

Example:

void commit  ( )

monospace 
italic 
text

Identifies variables in code.

Example:

String expr

UPPERCASE 
TEXT

Indicates device names, environment variables, and logical operators.

Examples:

LPT1

SIGNON

OR

{ } Indicates a set of choices in a syntax line. The braces themselves shoul
never be typed.

[ ] Indicates optional items in a syntax line. The brackets themselves shou
never be typed.

Example:

buildobjclient [-v] [-o name ] [-f file-list ]... 
[-l file-list ]...

Convention Item
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n

e. 
| Separates mutually exclusive choices in a syntax line. The symbol itself
should never be typed.

... Indicates one of the following in a command line: 

� That an argument can be repeated several times in a command line

� That the statement omits additional optional arguments

� That you can enter additional parameters, values, or other informatio

The ellipsis itself should never be typed.

Example:

buildobjclient [-v] [-o name ] [-f file-list ]... 
[-l file-list ]...

.

.

.

Indicates the omission of items from a code example or from a syntax lin
The vertical ellipsis itself should never be typed.

Convention Item
viii BEA eLink Business Process Option Configuration Guide
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Related Documentation

The following sections list the documentation provided with the eLink software, a
other publications related to its technology.

eLink Business Process Option Documentation

The eLink Business Process Option information set consists of the following 
documents:

BEA eLink Business Process Option User’s Guide 

BEA eLink Business Process Option Release Notes 

BEA eLink Business Process Option Server Installation Guide

BEA eLink Business Process Option Client Installation Guide

BEA eLink Business Process Option Operation and Maintenance Guide

BEA eLink Business Process Option Configuration Guide

Note: The BEA eLink Business Process Option CD set also includes Adobe Acro
PDF files of all of the online documents. You can use the Adobe Acrobat
Reader to print all or a portion of each document.

BEA TUXEDO and eLink Platform Publications

The following BEA publications describe the eLink Platform technology in depth:

TUXEDO System 6 Administration Guide

TUXEDO System 6 Administration Guide to the Web-Based GUI

TUXEDO System 6 Reference Manual

BEA eLink Platform Release and Installation Notes
BEA eLink Business Process Option Configuration Guide ix
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Configuration Expert Documentation

The BEA eLink Platform 1.2 release provides the following documentation for 
Configuration Expert utility:

BEA Builder Configuration Expert Online Help 

This is an online manual in PDF format, which you can access using the standar
Adobe Acrobat Reader. This manual provides additional details and instructions
using Configuration Expert to create and generate the application configuration f
for BEA eLink Platform 1.2.

Other Publications

For more information about TUXEDO and eLink Platform technology, refer to the
following books:

3-Tier Client/Server at Work (Edwards)

The TUXEDO System (Andrade, Carges, Dywer, Felts) 

The BEA eLink Business Process Option incorporates third-party process engin
technology. The relevant documentation is directly incorporated within the eLink
Business Process Option documentation set. The BEA eLink Business Process E
CD contains the third-party documentation as an additional reference. Please not
neither the third-party documentation nor the usage it describes are directly supp
by BEA Systems, Inc.

Customer Support

If you have any questions about this version of the BEA eLink Business Process
Option, or if you have problems installing and running the BEA eLink Business 
Process Option, contact BEA Customer Support through BEA WebSupport at 
www.beasys.com . You can also contact Customer Support by using the contact 
information provided on the Customer Support Card, which is included in the prod
package.
x BEA eLink Business Process Option Configuration Guide



Customer Support

tion:
When contacting Customer Support, be prepared to provide the following informa

� Your name, e-mail address, phone number, and fax number

� Your company name and company address

� Your machine type and authorization codes

� The name and version of the product you are using

� A description of the problem and the content of pertinent error messages
BEA eLink Business Process Option Configuration Guide xi
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1 Business Process 
Option Architectural 
Overview

This section provides a brief description and graphical overview of the basic Busi
Process Option components you will be configuring. Topics include:

� Overview

� Business Process Engine Components

� Business Process Option Components

� eLink Platform and Foundation Servers

� Server Groups and Services
BEA eLink Business Process Option Configuration Guide 1-1
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Overview

The primary Business Process Option components can be categorized as follow

Note: The term Business Process Option is used in two different contexts — one 
general and one specific — in this manual. The general term refers to the
product as a whole, which includes the entire set of Business Process En
components and non-Business Process Engine components, such as the
Business Process Option Servers. The specific term refers to the subset 
non-Business Process Engine components, which are the Business Proc
Option Servers and Business Process Option Contract Repository.

� Business Process Engine Components

� Business Process Engine Client Components:

� Process Design Assistant (PDA)
Business Interface Window
Process Design Window

� Business Process Repository

� Business Process Engine Servers:

� IcWorker  (IcGen  services)

� IcWorker  (IcJob  services)

� IcEvtAct

� IcCliMgr  (Client Manager) Server

� Business Process Option Components

� Business Process Option Servers

� eProcRunner

� eProcStarter

� eTaskAgent

� Business Process Option Contract Repository
1-2 BEA eLink Business Process Option Configuration Guide
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� eLink Platform/TUXEDO Servers

� WSL

� eLinkJSL

� IREPSVR

Figure 1-1 provides a graphical overview of the Business Process Option compon

Figure 1-1   Business Process Option Architectural Overview

The sections below provide descriptions of primary Business Process Engine an
Business Process Option components.

UNIX Operating System

eLink Platform

BPO Agents

BPO Contract Repository

BP Engine

Oracle DatabaseBusiness 
BEA Servers

Jolt /WS
Process Repository

Business Process Option
BEA eLink Business Process Option Configuration Guide 1-3
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Business Process Engine Components

The Business Process Engine does the following:

� Provides workflow storage and management facilities

� Maintains object and state information in the database

� Provides decision-making services for controlling process flows (task 
sequencing)

The Business Process Engine consists of four eLink Platform servers, a number
applications, a database, and a repository of documents. Important runtime 
configration information is stored in the <$IC_HOME>/config  directory. Additional 
platform configuration information is stored in the platform environment file (by 
default eLink_BPO.env ). The Business Process Engine eLink Platform servers ar
located in the directory <$IC_HOME>/tuxapp .

Business Process Engine Client Components

The Business Process Engine Client components consist of the following:

� Process Design Assistant (PDA)

� The Business Interface Window

� The Process Design Window

� Business Process Repository Database

� Oracle Database

� Oracle Transaction Manager (TMS)

These components are described in the following sections.
1-4 BEA eLink Business Process Option Configuration Guide
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Process Design Assistant

The main Business Process Engine Client component is the Process Design Ass
(PDA). This component, in turn, comprises the following subcomponents:

� Business Interface Window — The Business Interface Window of the Process 
Design Assistant is the primary interface to the Business Repository database.
The contents of the database are displayed in an object tree structure that lis
the available modules, the interfaces contained in each module, and so on. Y
can use the Interface Window to add, modify, or delete the objects in the 
database. You can also populate the Business Repository database by impor
existing Field Manipulation Language (FML) files, or by loading interfaces fro
text files.

� Process Design Window—You use the Process Design Window to form proces
flows. You create process flows by using palettes and templates in the Desig
Pad (subwindow).  The process flows you create are displayed as flow diagra
in the Design Pad. The process boxes in the diagrams represent tasks, and t
arrows in the diagrams represent dependencies between tasks.

Figure 1-2 illustrates the structure of the Process Design Assistant.

Figure 1-2   Business Process Engine Client Components

Windows NT Platform

Business Process Engine
Process Design Assistant

Process Design Wi ndowBusiness Interface Window
BEA eLink Business Process Option Configuration Guide 1-5
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Document Repository

Process flows may have external documents “attached” to them. The Document Repository is wh
information regarding these attachments is maintained. The data is stored in a directory or set of
directories and maintained by the Business Process Engine by way of the IcRepDaemon Server a

Engine applications.

Oracle Database

The Business Process Engine Business Repository requires the presence of the 
database. The Business Repository uses the database to store process-related 
information.

Note: As part of the eLink Business Process Option Server installation, you sho
have already created your Business Process Engine tablespace and user.
have not, please refer to the BEA eLink Business Process Option Server 
Installation Guide. Data should only be accessed via the tools provided, ne
directly.

Oracle Transaction Manager (TMS)

The Oracle transaction manager, or TMS, is included with the Business Process
Engine installation, and is located in the directory <$IC_HOME>/tuxapp . The 
executable is IcTMS .

Business Process Engine Servers

The Business Process Engine Servers are as follows:

� IcWorker   — IcGen_eLink  services

� IcWorker  — IcJob_eLink  services

� IcEvtAct  — Event/Action Daemon Server

� IcCliMgr  — Business Process Engine Client Manager

The Business Process Engine Servers are located in the directory $IC_HOME/tuxapp . 
A descriptions of the servers are provided in the following sections.
1-6 BEA eLink Business Process Option Configuration Guide
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IcWorker Servers

The Business Process Option IcWorker  Servers provide two kinds of services for 
balancing the system processing load created by client calls to the API:

� IcGen  service — The IcGen  service is intended for processing API calls that 
require relatively little time and system resources. 

� IcJob  service — The IcJob  service is intended for processing API calls that 
consume more time and system resources. 

There are two IcWorker  Servers, one for each service. Routing Business Process
Option API calls to the appropriate service enables calls to be processed in a tim
fashion. The corresponding IcWorker  server then handles the request and returns d
to the client as appropriate.

IcEvtAct (Event/Action Daemon) Server

IcEvtAct  is the Business Process Engine Event/Action Daemon Server. This se
handles processing of Business Process Option events (which are distinct from A
events). In general, it is not necessary to modify or configure this server.

IcCliMgr (Client Manager) Server

IcCliMgr  is the Business Process Engine Client Manager Server. The Client Man
handles starting and restarting of long-running daemons. One of these is the 
IcEvtSched  daemon which drives the IcEvtAct  server. As part of the installation, the
Business Process Engine Document Repository server is put under Client Mana
control. The configuration information for the IcCliMgr  server is maintained in 
<$IC_HOME>/config/IcCliMgr.cfg .
BEA eLink Business Process Option Configuration Guide 1-7
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Business Process Option Components

This section describes the basic Business Process Option (non-Engine) compon
These are:

� Business Process Option Servers:

� Business Process Option Contract Repository

� ATMI and Business Process Databases

The components are described in the following sections.

Business Process Option Servers

The Business Process Option Servers start processes, execute tasks, and pass
information to the processes and tasks via calls to eLink Platform services. They
provide access by other applications to the Business Process Engine via the eLi
Platform.

The Business Process Option Servers are as follows:

� eProcRunner

� eProcStarter

� eTaskAgent

The servers are located in the directory <$TUXDIR>/bin . The following sections 
describe each of the servers.

eProcRunner

The eProcRunner  is the Business Process Option Server that starts a Business Pr
Engine job or process, and waits for the process to complete before returning. T
eProcRunner  will pass data to a process when it starts the process, and return d
based upon the outcome of the process.
1-8 BEA eLink Business Process Option Configuration Guide
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eProcStarter

The eProcStarter  is the Business Process Option Server that starts a Business
Process Engine job (request) or process, and returns as soon as the process has
The eProcStarter  will pass data to a process when it starts the process, but will
return to the calling client as soon as the process has been successfully activate

eTaskAgent

The eTaskAgent  is the Business Process Option Server that processes Business
Process Engine tasks. The eTaskAgent  obtains tasks ready for processing and calls a
eLink Platform service. The service name called is the same as the task name. T
eTaskAgent  passes data to the service as specified by the task attributes, which
defined by parameter expressions. The data received from the service call is then
available to the process, again as stated in the parameter expressions.

eLink Platform and Foundation Servers

The eLink Platform and Foundation Servers provide access for clients to eLink 
Platform services. A client can be any other eLink Platform application. Clients c
request the services of the eLink Platform itself, or the services of any other applic
server managed by the eLink Platform. These servers are provided as part of yo
eLink Platform and Foundation installation. The eLink Platform Servers are as 
follows:

� WSL

� eLinkJSL

� IREPSVR

The eLink Platform Servers are located in the directory <$TUXDIR>/bin . The 
following sections describe each of these servers. For more detailed information,
to your TUXEDO, eLink Platform, and Foundation documentation.
BEA eLink Business Process Option Configuration Guide 1-9
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WSL Server

The WSL is the eLink Platform Workstation Listener, and is provided as part of you
eLink Platform installation. The WSL provides access for clients, known as 
Workstation Clients, to the services of other eLink Platform application servers. 
Essentially, WSL handles all communication between Workstation Clients and the 
eLink Platform application servers. In the context of the Business Process OptionWSL 
provides these services for the Business Process Engine Process Design Assista
various of the Business Process Engine applications.

eLinkJSL Server

The eLinkJSL  is the eLink Platform JOLT Listener, and is provided as part of you
eLink Platform installation. The eLinkJSL  provides access for clients to the service
of other eLink Platform application servers. Essentially, eLinkJSL  handles all 
communication between Jolt Clients and the eLink Platform application servers. In
context of the Business Process Option application, eLinkJSL  provides these services
primarily for the Business Process Engine Process Design Assistant.

IREPSVR Server

This is the Business Repository Server. This is provided as part of your eLink 
Platform/Business Process Option installation. IREPSVR provides services for 
accessing and maintaining the Business Repository. In the context of the Busine
Process Option application, IREPSVR provides these services primarily for the 
Business Process Engine Process Design Assistant.

Server Groups and Services

The base eLink Platform configuration consists of two server groups: one is the 
Transactional Group,  and the other the Non-transactional Group. Non-transactional 
servers do not support the ability to participate in transactions, while transaction
servers do provide this function, and are managed by the Oracle XA. A transaction is 
one or more actions, steps, tasks, or other procedures that must occur as an atom
If one step of a transaction fails, all other tasks must be undone (if already comple
such that there is no trace of the tasks ever having occurred. This is referred to a
1-10 BEA eLink Business Process Option Configuration Guide
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rollback. If all tasks for a transaction have been completed successfully, the transa
is committed (finalized) and is considered complete. Non-transactional servers do
support the rollback function, and therefore do not support transactions.

The collection of all Business Process Option eLink Platform Servers, their grou
association, and services are defined in the following sections.

Non-Transactional Group

Table 1-1 summarizes the servers in the Non-Transactional Group.

 .

Table 1-1  Business Process Option eLink Platform Servers: Non-Transactional Group

Server Service Description

WSL None. Standard ATMI Workstation Listener

eLinkJSL None Standard ATMI Jolt Listener

IcCliMgr IcCliMgr Administrative interface to the Daemon 
Manager, which manages long-running ATMI 
client applications

IcCliMgr IcCmChildError Error reporting interface to the Daemon 
Manager, which manages long-running ATMI 
client applications

IREPSVR hidden system Contract Repository Server
BEA eLink Business Process Option Configuration Guide1-11
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Oracle Transactional Group

Table 1-2 summarizes the servers in Oracle Transactional Group. This group con
the Business Process Engine transactional servers. These servers are grouped t
to enable them to be managed simultaneously through the eLink Platform 
administration tools tmstart  and tmadmin .

Table 1-2  Business Process Option eLink Platform Servers: Oracle Transactional Group 1

Server Service Description

IcEvtAct IcEA_eLink Event/Action Daemon processing service

IcWorker IcGen_eLink IcGen Worker service

IcWorker IcJob_eLink IcJob Worker service

eProcStarter User defined Return from service call after creating an 
active job (job runs asynchronously)

eProcRunner User defined Return from service call after job 
completes

eTaskAgent IcTaskAgentLoop Task processing daemon service
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2 Business Process 
Option Configuration 
Overview

This section provides an overview of  the Business Process Option configuration
process. Topics include:

� Overview

� Business Process Option Configuration Files

� eLink Platform Configuration Utilities

Overview

Your Business Process Option installation documentation provides instructions f
installing the product and testing the Business Process Engine installation. This 
manual provides instructions for configuring and finetuning your installation for a
production environment. This primarily involves creating and/or modifying a set o
Business Process Option and eLink Platform configuration files. The following sec
provides an overview of these files and their context within the configuration.
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Business Process Option Configuration Files

To configure your installation for a production environment, you must modify and
create a number of configuration files. These files are categorized as follows:

� Server platform (UNIX operating system) environment:

� env.sh  file — Defines and sets environment variables to configure your 
UNIX shell environment for the Business Process Option Servers running
under eLink Platform.

� Business Process Engine:

� eLink_BPO.env  — Defines and sets environment variables specific to the 
Business Process Engine.

� IcCliMgr.cfg  — This is the Business Process Engine Client Manager 
configuration file.

� IcRepDaemon.config  — This is the Business Process Engine Repository 
Daemon configuration file.

� Business Process Option Server configuration:

� eLink_BPO.cfg  — This file contains various parameters for defining and 
configuring the Business Process Option Servers. Parameters in this file 
control the interactions between the Business Process Option Servers and
Business Process Engine. 

� eLink Platform configuration:

� <application_name >.ubb  — This is the TUXEDO/eLink Platform 
configuration file (UBB file). This is the UBB file specific to the Business 
Process option, and configures the eLink Platform for running the 
application. You can create and generate this file by using the eLink Platfo
Configuration Expert utility.

Figure 2-1 illustrates the context of the Business Process Option  configuration fil
2-2 BEA eLink Business Process Option Configuration Guide
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Figure 2-1   Context of Business Process Option Configuration Files

To modify your configuration, you must manually modify the appropriate 
configuration files. However, to create, generate, and/or modify the eLink Platfor
UBB (and related) configuration files, you can use the eLink Platform Configurat
Expert and Data Editor utilities. These utilities provide a series of screens for ente

eLink_BPO.cfg

eLink_BPO.env IcRepDaemon.configIcCliMgr.cfg

  <app>.ubb

env.sh

eLink Platform

Business Process Engine Environment

Business Process Option
Server Configuration

Operating System Shell
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your configuration information. You can then use the Configuration Expert Gene
Files feature to generate the required TUXEDO/eLink Platform UBB configuratio
files. 

The following section provides a description of the Configuration Expert and Dat
Editor utilities.

eLink Platform Configuration Utilities

BEA eLink Platform provides two utilities to assist you in configuring the eLink 
Platform for eLink applications. These are:

� Configuration Expert  — This utility automates the process of creating and 
modifying eLink Platform application configuration files. The Configuration 
Expert presents a series of screen forms for entering your configuration 
information. After you have completed the forms, you can use Configuration 
Expert to generate the required files and place them in the appropriate locatio

You can also use Configuration Expert to run a system startup test, to ensure
your configuration is correct and functional. During startup, Configuration 
Expert displays a series of status messages that indicate whether the startup
successful. The status messages may also provide some debugging informa
for determining the source of any problem.

� Configuration Data Editor  — This utility enables you to quickly create and/or 
modify the Data Configuration file for your Business Process Option Server 
machine. The Configuration Expert uses this file to create the configuration 
setup file for generating the BEA eLink Platform configuration files. 

Chapter 6, “Creating the eLink Platform Configuration Files,” provides detailed 
instructions for using these utilities to configure the eLink Platform specifically for 
Business Process Engine. Appendix B, “Configuration Expert Quick Reference 
Guide,” provides general instructions for starting up and using these utilities.

Note: For additional information on using the Configuration Expert and 
Configuration Data Editor, refer to the online document BEA Builder 
Configuration Expert Online Help  provided in PDF (Acrobat Reader) forma
with the BEA eLink Platform 1.2 release.
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3 Configuring the Server 
Platform Environment

This section provides instructions for configuring your UNIX shell environment fo
the Business Process Option Servers running under BEA eLink Platform. This en
editing the variable assignments in the Business Process Option UNIX environm
script env.sh . This section describes the env.sh  script in detail and provides 
instructions for modifying its contents to suit your particular configuration. Topics
include:

� The env.sh File

� The env.sh Environment Variables

� Modifying the env.sh File

The env.sh File

In order to function properly, the various Business Process Option components re
certain information concerning the operating system environment in which the ser
reside. When you installed the Business Process Engine, a script was created th
the environment variables required for operation of that component. This script fi
env.sh  and is located in the directory $IC_HOME/config .  As part of the Business 
Process Option Server installation, this file was additionally enhanced to include
environment variables required for the eLink Platform. The updated env.sh  is placed 
in the directory <$TUXDIR>/eLink/BusProc .
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3 Configuring the Server Platform Environment

 or  
o 
Note:  If you modify the configuration for your Business Process Option system
the supporting software (for example, the Oracle database), you must als
update the env.sh  file to reflect those changes. 

A sample env.sh  file is provided in Appendix C, “Sample Configuration Files.”
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The env.sh Environment Variables

The following table describes each of the variables contained in the env.sh  file.

Note: You must manually add or edit the following variables and their assignme
in the env.sh  file:

� TUXCONFIG

� FIELDTBLS32

� FLDTBLDIR32

Warning: The TUXCONFIG environment variable is not provided as part of the 
installation, because the TUXCONFIG file location is not known or required 
as part of the installation process. This environment variable  must be set, 
however, for the eLink Platform to compile the UBB configuration file and 
boot the eLink Business Process Option application. The values of the
FML environment variables FIELDTBL32  and FLDTBLDIR32 contain only 
the data necessary for the Business Process Option Servers to run. T
must be updated for any other FML definitions that you will use.

env.sh Variable Description

IC_HOME This is the eLink Business Process Engine home directory.

IC_CLIENT This is the eLink Business Process Engine client login string. This string specifies
the eLink Business Process Engine user, server, and optionally the user’s 
password, in the format <username> [ /<password> ] @<servername> .    
IcTuxInstall  generates the IC_CLIENT  string icdba @<servername>  ; 
icdba  is the default user ID for the eLink Business Process Engine 
administrative user, and <servername>  is replaced by your specification for 
the variable IC_SERVER_NAME. For security reasons, the administrator 
password is not specified in the generated IC_CLIENT  string.

TUXDIR This is the eLink Platform home directory.
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TUXCONFIG This is the explicit location of the binary configuration file for the eLink Platform. 

Note: This environment variable is not provided as part of the 
installation, because the TUXCONFIG file location is not known or 
required as part of the installation process. This environment 
variable must be set, however, for the eLink Platform to compile 
the UBB configuration file and boot the eLink application.

PATH Contains a list of the directories to be searched to locate executables. The 
following directories are appended to the setting for this variable:
$IC_HOME/bin
$TUXDIR/bin
$ORACLE_HOME/bin

LANG This is the NLS language. If it has not already been set, it will be set to C.

NLSPATH This specifies the directories to be searched for locating message catalogs. The
following directory specifications are appended to the setting for this variable:
$IC_HOME/data/%L/messages/%N
$IC_HOME/data/messages/%N
$IC_HOME/data/C/messages/%N

LD_LIBRARY_PATH Solaris only. This is the search path for shared libraries. The following directory 
specifications are appended to the setting for this variable:

$IC_HOME/lib — Path for the Business Process Engine shared libraries

$TUXDIR/lib — Directories in which the platform shared libraries reside

$ORACLE_HOME/lib — Path for the database shared libraries

SHLIB_PATH HP-UX only. This is the search path for shared libraries. The following directory 
specifications are appended to the setting for this variable:

$IC_HOME/lib — Path for the Business Process Engine shared libraries

$TUXDIR/lib — Directories in which the platform shared libraries reside

$ORACLE_HOME/lib — Path for the database shared libraries. 

ORACLE_HOME This is the Oracle home directory.

TWO_TASK Identifies the Oracle instance for SQL*Net. If you have chosen to bypass 
SQL*Net, TWO_TASK is replaced by ORACLE_SID.

env.sh Variable Description
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Modifying the env.sh File

To alter the env.sh  environment variable settings after the installation, do the 
following:

1. Shut down the Business Process Option system.

2. Edit the env.sh  script file, using any plain text editor such as UNIX vi  or 
emacs. 

3. Save the newly modified env.sh  file.

4. Execute the env.sh  script at the UNIX shell prompt, as follows:

. ./env.sh

You can also add this command to the icadmin  .profile  file, and then source 
the .profile  file. The .profile  file is also sourced upon login.

5. Restart the eLink Business Process Option system.

FIELDTBLS32 Contains the list of table files required by FML data-dependent routing.

Note: This variable is provided with only the settings required by the 
Business Process Option. You must update these to include any
other FML definitions that you will be using.

FLDTBLDIR32 This contains the list of table files required by FML.

Note: This variable is provided with only the settings required by the 
Business Process Option. You must update these to include any
other FML definitions that you will be using.

WSNADDR Identifies the host machine and port number used by the eLink Platform 
Workstation Listener (WSL). 

env.sh Variable Description
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4 Configuring the 
Business Process 
Engine

This section provides instructions for configuring your eLink Platform environme
for the Business Process Engine Client and Business Process Engine Server. T
process entails editing the variable assignments in the Business Process Engine
environment script eLink_BPO.env . This section describes this script in detail and
provides instructions for modifying its contents to suit your particular configuratio
Topics include:

� Overview

� The eLink_BPO.env File

� Configuring the Process Design Assistant (PDA)

� Configuring the Business Repository Server

� Configuring the Client Manager
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Overview

In order for the Business Process Engine to function properly within the eLink 
Platform environment, certain application-specific environment variables must be
defined and set. When you installed the Business Process Engine, a script file w
created which defines and sets these environment variables. This file is 
eLink_BPO.env , and resides in the directory <$TUXDIR>/eLink/BusProc . 
However, you may have to modify some of the variable assignments in this file. 
following section, “The eLink_BPO.env File,” describes the contents of this file and
how to modify it to suit your particular configuration. A sample of this file is provide
in Appendix C, “Sample Configuration Files.” 

In addition to modifying the eLink_BPO.env  file, you may have to perform some 
additional coniguration procedures to finetune your installation. These procedure
described in the following sections:

� Configuring the Process Design Assistant (PDA)

� Configuring the Business Repository Server

� Configuring the Client Manager

The next section describes the eLink_BPO.env  file.

The eLink_BPO.env File

The configuration file eLink_BPO.env  contains runtime configuration parameters 
used internally by the eLink Business Process Engine server processes. The 
eLink_BPO.env  file is located in the directory <$TUXDIR>/eLink/BusProc . This file 
is used as the default Business Process Engine environment file, and is specified 
ENVFILE parameter setting in the UBB configuration file for your eLink Platform. To 
use a different file, you must specify the new file name in the ENVFILE parameter 
setting in the UBB file.
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Most of the parameter assignments in the eLink_BPO.env  file should not be changed.
Table 4-1 indicates which settings should not be changed. It is recommended that
make a working copy of the file in the location specified by the APPDIR setting in the 
UBB configuration file. If you do modify this file, you must update the FIELDTBLS32  
and FLDTBLDIR32 variables in any FML field table files required by other servers 
running as part of the eLink Platform application.

If you are using an ENVFILE that already exists, you must add the Business Proce
Engine variables (see all variables with the IC_  prefix in Table 4-1) to this file. You 
must also add the required FML Field Table files and directories specified in the 
FIELDTBLS32  and FLDTBLDIR32 variable assignments in the eLink_BPO.env  file to 
those listed in the existing ENVFILE.

Table 4-1 provides a description of the eLink_BPO.env  file parameters, and indicates
which of these should not be modified.

.

Table 4-1  eLink_BPO.env File Environment Variables

Variable Description

IC_SERVER_NAME This is the name of this eLink Business Process Engine server.

IC_HOST_MACHINE This is the master host machine for this server.

IC_STATUS_LOG This is the filename for the eLink Business Process Engine status log
By default, this is $IC_HOME/logs/status.log .

IC_AUDIT_MODE This is the type of audit logging used by this eLink Business Process
Engine server. The audit log tracks most user actions, such as acquiri
or completing a task. The possible values for this parameter:

IC_EVENT_AUDIT_DATABASE — Specifies that audit records should 
be written only to the database. This is the default.

IC_EVENT_AUDIT_DATABASE_AND_FILE — Specifies that audit 
records should be written to both the database audit log and the file 
specified by IC_AUDIT_LOG. Although this option slightly decreases 
the performance of eLink Business Process Engine, it provides an eas
accessible form of the audit log while still maintaining 
database-enforced integrity.
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Configuring the Process Design Assistant 
(PDA)

To configure the Process Design Assistant, you must define the following param
in the Process Design Assistant Logon window. You can access this window in t
PDA by selecting Settings->Logon.

� User name

� User password

� Port number on which the eLinkJSL  is listening

� Port number on which the WSL is listening

IC_AUDIT_LOG This is the name of the audit log file. Use this only if  IC_AUDIT_MODE 
is set to IC_EVENT_AUDIT_DATABASE_AND_FILE. 

If it is set to IC_EVENT_AUDIT_DATABASE, you should set 
IC_AUDIT_LOG to NOT_USED (the default).

IC_RDBMS Identifies the database system. This must always be ORACLE.

IC_EVENT_POLL_INTERVAL This is the polling interval, in seconds, for temporal events (for 
example, overdue tasks). The default of 3600 (one hour) is sufficient fo
most installations. Because the operations controlled by this paramet
perform full-table scans of large tables, decreasing this value is likely t
significantly degrade overall performance.

IC_ACTION_POLL_INTERVAL This is the polling interval, in seconds, for general event processing. 
This parameter determines how frequently events are processed by t
Event-Action Daemon. The default value is 60; you should decrease 
this value if your system makes extensive use of eLink Business 
Process Engine actions.

Table 4-1  eLink_BPO.env File Environment Variables

Variable Description
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Warning: Do not transpose the WSL port number and the eLinkJSL port 
number. There is a known problem that will cause the system to beco
unstable should the two ports be swapped for one another. Be very ca
when specifying the port numbers.

� Application password (optional)

Note: Required only if you are using an Authentication Server.

� Business Process Engine service name suffix

Note: The default installation specifies eLink as the suffix. If you specify a 
different suffix during the Business Process Engine installation, then y
must update the appropriate lines in the IcTuxConfig  file to reflect the 
proper suffix. The lines to be updated are as follows:

IcGen_eLink
IcEA_eLink
IcJob_eLink

You must update  IcTuxConfig  files on both the clients and server to 
reflect this change. These files are in the following locations:

Client: <PDA_Base_Install_Dir >/Txm/config

Server: <$IC_HOME>/config

In addition, you must change the eLink  argument for the -s  option in the 
Command Line Options  specification for the following servers:

IcEvt
IcWorker (IcGen)
IcWorker (IcJob)
BEA eLink Business Process Option Configuration Guide 4-5
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Configuring the Business Repository Server

The configuration file IcRepDaemon.config  located in the directory 
<$IC_HOME>/config  contains the information relating to logging levels, access, a
repository location. To finetune your configuration, you must modify this file 
accordingly. The file itself contains instructional comments concerning its conten
and how to modify the parameter settings; please refer directly to the file for this
information. A listing of this file is provided in Appendix C, “Sample Configuration 
Files.” 

Modifying the Business Repository Server Port Number

The default port on which the Business Process Engine Repository server listen
9001. This information is stored in the database. If you must modify the port num
after you have installed the Business Process Engine, you must update the data
using the following command:

update REPOSITORIES set LOCATION = '< host >:< port >'

where <host > is the hostname of the computer running the Business Process En
and <port > is the new port number.

Setting the Time Zone Environment Variable

Ensure that the system-specific time zone environment variable is correctly set b
running the Repository Daemon. In the US,  the settings are PST8PDT, MST7MDT, 
CST6CDT, and EST5EDT. If you do not set the time zone, the default is system-speci

Warning: The time setting on the client machine(s) must be within 10 minutes of
setting on the server machine — including the time zone differential o
the client machine. If this is not the case, the client cannot connect to
server. If this occurs, you can correct it by modifying the time of the clie
machine to match that of the Repository Daemon host.
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The Repository Daemon uses the high-order bits of the current time as part of th
encryption key for tokens. Therefore, the time setting  for the client machine(s) m
be within 10 minutes of the setting on the server machine — including the client’s 
zone differential. If this is not the case, the Business Repository Server returns a
Invalid/Expired Keys  error and the Process Design Interface fails to start. This 
be a particular problem when communicating across time zones, because the tim
differential will exceed the acceptable range of 10 minutes, and the client will no
able to connect. 

For example, a client running the Process Design Assistant in the Eastern Time 
could have a local time of 13:05:15 EST,while the server residing in the Pacific T
Zone could have a time of 10:05:15 PST. Under these conditions, the Business 
Repository Server would run successfully. If both times were set to 10:05:15 and
time zones remained the same, the Business Repository Server would return an
Invalid/Expired Keys  error and the Process Design Interface would fail to start
this occurs, you can correct it by modifying the time of the client workstation to ma
that of the Repository Daemon host.

Configuring the Client Manager

The Business Process Engine Client Manager (IcCliMgr ) is responsible for starting 
and restarting long-running daemons that are ATMI clients. One such daemon is
IcEvtSched , which drives the IcEvtAct  server. As part of the installation, the 
Business Repository Server is placed under the control of the Client Manager. 

The configuration information for the IcCliMgr  server is maintained in the 
configuration file <$IC_HOME>/config/IcCliMgr.cfg . A listing of this file is 
included in Appendix C, “Sample Configuration Files.” 
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5 Configuring the 
Business Process 
Option Servers

This section provides instructions for configuring the Business Process Option 
Servers. This entails editing the variable assignments in the Business Process O
configuration file eLink_BPO.cfg . This section describes this file in detail and 
provides instructions for modifying its contents to suit your particular configuratio
Topics include:

� Overview

� The eLink_BPO.cfg File

� SERVER Sections

� eLink_BPO.cfg Configuration Parameters

Overview

The Business Process Option Servers — also sometimes referred to as the Bus
Process Option eLink Platform application servers — are responsible for execut
and controlling the eLink Platform ATMI services. ATMI services send input and
output data to the applications that are connected and controlled by the eLink Plat
BEA eLink Business Process Option Configuration Guide 5-1
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The Business Process Option Server uses the following eLink Agent Server prog
to execute and control ATMI services:

� eProcStarter

� eProcRunner

� eTaskAgent . 

Essentially, when you configure the Business Process Option Server, you are in e
configuring these eLink Platform Agent Servers. Therefore, the set of these eLin
Agent Server programs, along with the Business Process Server itself, are collec
referred to as the Business Process Option Servers.  To configure the servers, yo
modify the contents of the configuration file eLink_BPO.cfg . The following sections 
provide a detailed description of this file, and instructions for modifying it to suit yo
configuration.

The eLink_BPO.cfg File

The Business Process Option Servers are configured and administered through 
mechanisms of the following configuration files:

� eLink_BPO.cfg — This is the default Business Process Option configuration 
file. During initialization, each server reads the configuration file specified in t
CLOPT (Command Line Options) line in the UBB configuration file. (Refer to 
Chapter 6, “Creating the eLink Platform Configuration Files,” for instructions on 
specifying configuration files.) If no file is specified, the server will fail to boot.

� The eLink Platform UBB configuration file — This is the primary 
TUXEDO/eLink Platform configuration file. A relationship exists between the 
eLink_BPO.cfg  file and the UBB configuration file, as illustrated in Figure 5-1
Please refer to your TUXEDO and eLink Platform documentation for a 
description of and instructions on modifying the UBB configuration file.

The eLink_BPO.cfg  file is installed in the following location:

<$TUXDIR>/eLink/BusProc/

You should place a working copy of this file in the eLink Platform APPDIR .
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Note: Any changes to a configuration file section require that the server(s) using
section be shut down and restarted for the changes to take effect. A listin
the default eLink_BPO.cfg  file is provided in Appendix C. 

SERVER Sections

The eLink_BPO.cfg  file contains at least one section for each server, and may 
contain a separate section for each instance of the servers. The particular section
server is read when the server is started, as part of the server initialization proce

Sections are demarked by the following headers:

[SERVER=<servername >]

where <servername > is one of eProcRunner , eProcStarter , or eTaskAgent . 

By default, the servers search for a SERVER section equal to the name of the server 
executable, minus the path information. You can instruct the server to use a secti
another name by using the -i < section > option in the CLOPT line. 

Note: <section > must consist only of the section name; do not include the entire 
UBB file section line (for example, use only the <section > portion of the line  
[SERVER=<section >] .

Figure 5-1 illustrates the relationship between the server CLOPT arguments and the 
server configuration file, for two instances of the eProcRunner  server, each using its 
respective configuration section.
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Figure 5-1   Relationship between the UBB and eLink_BPO.cfg Files
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eLink_BPO.cfg Configuration Parameters

The relevant section configuration parameters are categorized as follows:

� Business Process Engine Server Login Parameters

� Business Process Option Server Parameters

Business Process Engine Server Login Parameters

The following three parameters are common to each eLink_BPO.cfg  file section. 
These specify the login information to be used by the Business Process Option S
for connections to the appropriate Business Process Engine. 

� SERVER — This is the name of the Business Process Engine Server to which 
connect. If you used the default installation, this will be the installation machin
name.

� USER — This is the Business Process Engine user ID. This must be a user 
created with the BpoAddUser  command during the Business Process Option 
installation procedure.

� PASSWORD — This is the password assigned to the Business Process Engine 
specified for USER, above.

The settings for these parameters are fairly static. These three settings must be p
for each server. Specify the Business Process Engine Server machine and login
information by replacing the installed defaults with the correct information. These
initially set as follows:

SERVER=<systemname >
USER=<icdba >
PASSWORD=<icdba >

You must modify the assignments for these parameters to the correct settings for 
Business Process Engine Server machine; otherwise, attempts by the Business P
Option Server to connect with the Business Process Engine Server will fail.
BEA eLink Business Process Option Configuration Guide 5-5
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Business Process Option Server Parameters

The Business Process Option Server parameters are grouped as follows:

� eProcStarter  parameter:

� SERVICE_LIST

� eProcRunner  parameters:

� SERVICE_LIST

� POLL_INTERVAL

� eTaskAgent  parameters:

� POLL_INTERVAL

� POLL_COUNT

� COMPLETE_FAILED_TASK

These are described in the following sections.

eProcStarter Parameters

� SERVICE_LIST  — This is a comma-separated list of service names to be 
advertised. Each of the listed service names must have a corresponding tem
defined. Each of the names in this list must be unique and meet the 
TUXEDO/eLink Platform service name requirements. Also, because these ar
advertised services, each name must be unique when compared to the 
SERVICE_LIST  for the eProcRunner  and any other services running in the 
eLink Platform application.

eProcRunner Parameters

� SERVICE_LIST  — This is a comma-separated list of service names to be 
advertised. Each listed service name must have a corresponding template 
defined. Each name in this list must be unique and meet the TUXEDO/eLink 
Platform service name requirements. Also, since these are advertised service
each these names must be unique when compared to the SERVICE_LIST  for the 
eProcStarter  and any other services running in the eLink Platform applicatio

� POLL_INTERVAL — The eProcRunner  server waits for a process to complete 
before returning to the caller. POLL_INTERVAL specifies how often, in tenths of 
5-6 BEA eLink Business Process Option Configuration Guide
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seconds, the server should sleep between process status queries. Longer tim
result in less CPU use, but potentially more time between completion of the 
process and notification to the client. Shorter durations result in more CPU us
and possibly earlier notification to the client of process completion.

eTaskAgent Parameters

The following parameters control how often the eTaskAgent  looks for ready tasks, the
number of ready tasks processed in succession, and what to do should  process
a task fail.

Note: The Business Process Engine controls access to tasks and jobs through
logins. Users must belong to at least one pool, which is a group of users. Tasks
also must have an assigned pool. Only users in the pool assigned to a part
task may acquire and process the task. The BPO provides the utility 
BpoAddUser  for creating users for the eTaskAgent . BpoAddUser  is located in 
<$TUXDIR>/eLink/BusProc . It creates the specified user and places the u
in a pool with the same name as the user (after creating the pool). This is
important because the eTaskAgent  only processes Tasks with a pool name 
identical to the USER parameter or the "Owner" pool. This allows tasks to b
assigned to certain instances of the eTaskAgent .

� POLL_INTERVAL — This specifies the amount of time the server should wait 
between queries to the Business Process Engine for ready tasks. The time is
specified in tenths of seconds. The longer the delay, the less CPU usage 
consumed by the eTaskAgent  when there are no ready tasks; however, it may 
take proportionately longer for a ready task to be acquired. Conversely, a sho
interval may allow the server to acquire tasks sooner as they become availab
but will consume more processing time when no tasks are ready.

� POLL_COUNT — This is the maximum number of ready tasks that should be 
processed before forcing the daemon to process another ATMI loop. This 
ensures that the server responds to TUXEDO/eLink Platform commands suc
shutdown , etc. If no ready tasks are available, the server will sleep for the 
POLL_INTERVAL and process another ATMI loop.

� COMPLETE_FAILED_TASK — This specifies that failed tasks should be marked 
completed. If this is set to YES, when a service request fails, the eTaskAgent  
will mark the task as complete  and continue, setting error information on the 
process level attributes. If this is set to NO, then the eTaskAgent  will leave the 
task as acquired  and stop any further processing on this path of execution 
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within the process. Completing failed tasks allows the engine to make decisio
regarding error processing, while leaving the task in the acquired state allows
human intervention. The default, should this parameter be unspecified or con
an invalid value, is to complete failed tasks and allow the Business Process 
Engine to continue processing the job.
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This section provides instructions for creating the eLink Platform configuration fil
for the Business Process Option application. This includes specific instructions f
using the eLink Platform Configuration utilities to generate these files. Topics incl

� Overview

� Step 1: Gather Your Configuration Information

� Step 2: Create a New Data Configuration File

� Step 3: Create a New Configuration Setup File

� Step 4: Configure the Application Properties

� Step 5: Add the Machine to the Configuration Tree

� Step 6: Configure the Machine Properties

� Step 7: Add and Configure the Server Groups

� Step 8: Configure the Servers

� Step 9: Configure the Optional Components

� Step 10: Generate the Configuration Files and Scripts

� Step 11: Testing the Configuration
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Overview

BEA eLink Platform provides two utilities to assist you in the configuration proce
These are:

� Configuration Data Editor — This utility enables you to quickly create and/or 
modify the Data Configuration file for your Business Process Option Server 
machine. The Configuration Expert uses this file to create the configuration 
setup file for generating the BEA eLink Platform configuration files.

� Configuration Expert — This utility enables you to create and modify the BEA 
eLink Platform Business Process Option configuration files without having to 
manually create and edit these files. You can also use Configuration Expert t
perform a test startup of the new configuration.

Appendix B, “Configuration Expert Quick Reference Guide,” provides an overview of 
the main windows and navigation procedures for these utilities. 

Note: For more detailed information and instructions on using Configuration Exp
refer to the online document BEA TUXEDO Builder Configuration Expert 
provided in PDF form with the BEA eLink Platform 1.2 release. This 
document provides instructions for using Configuration Expert to specifica
configure the Business Process Option application.

Note: The examples in this section are taken from a UNIX platform installation.
you are running the Configuration Expert under Windows NT, any local pa
such as the output directory, must be specified following the standard DO
convention of < drive_letter >:\< path >. Any pathnames you specify for 
the servers must follow the naming convention of the operating system un
which the Business Process Servers are to be running.

The eLink Platform Business Process Option 
Configuration Files

The Configuration Expert uses the information you specify in the configuration 
screens to generate the following configuration files:
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� <application_name >.ubb  — This is the eLink Platform UBB file for your 
new Business Process Option configuration. This file is located in the outp
directory you specify in the Location field of the Configuration Expert New
Configuration screen (see Figure 6-1 in “Step 3: Create a New Configuration 
Setup File”).

� <application_name >.checklist  — This specifies the tasks to be 
completed (on each machine) to set up the application.

� tux_start.sh  — This is the generated startup script for your new eLink 
Platform and Business Process Option configuration. This file is located in
the output directory you specify in the Location field of the Configuration 
Expert New Configuration screen (see Figure 6-1).

� tux_stop.sh  — This is the generated shutdown script for your new eLink 
Platform and Business Process Option configuration.  This file is located i
the output directory you specify in the Location field of the Configuration 
Expert New Configuration screen (see Figure 6-1).

� crtlog.sh  — This is a UNIX script file that creates the device list file for 
the BEA eLink Platform.  This file is located in the output directory you 
specify in the Location field of the Configuration Expert New Configuration
screen (see Figure 6-1).
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Overview of Configuration Procedures

The steps involved in creating the BEA eLink Platform configuration files for the 
Business Process Option are as follows:

Step 1: Gather Your Configuration Information

Step 2: Create a New Data Configuration File

Step 3: Create a New Configuration Setup File

Step 4: Configure the Application Properties

Step 5: Add the Machine to the Configuration Tree

Step 6: Configure the Machine Properties

Step 7: Add and Configure the Server Groups

Step 8: Configure the Servers

Step 9: Configure the Optional Components

Step 10: Generate the Configuration Files and Scripts

Step 11: Testing the Configuration

Detailed instructions for each of these steps are provided in the following section
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Step 1: Gather Your Configuration 
Information

Before you begin the configuration process, you can gather the information you 
need to complete the configuration. Appendix A, “Configuration Information 
Checklist,” in this manual provides a checklist you can use to complete this step.

Step 2: Create a New Data Configuration File

Before you can create a new configuration, you must create a new Data Configur
file for the server machine(s) you intend to add to the new eLink Platform 
configuration. This file contains some basic information about the machine(s) an
informs the Configuration Expert of the existence of the machine(s). 

To create a new Data Configuration file:

1. Start the Configuration Data Editor utility.

On a UNIX platform:

Enter the following commands at the operating system prompt:

cd < $TUXDIR>/eLink/ConfigExpert/bin

./ConfigEditor &  

On a Windows NT platform:

Click Start->Programs->BEA eLink->Configuration Expert Setup.

This displays the Configuration Data Editor startup screen.

Note: Refer to the section entitled, “Starting the Configuration Data Editor,” in 
Appendix B, “Configuration Expert Quick Reference Guide,”  for an 
illustration of the Configuration Data Editor startup screen.

2. Go to the Configuration Data Editor main window.
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Choose File->New to display the Configuration Data Editor main window. 

Note: Refer to “Starting the Configuration Data Editor,” in Appendix B, 
“Configuration Expert Quick Reference Guide,”  for an illustration of the 
Configuration Data Editor main window.

3. Enter your machine information.

Enter the following information in the fields:

� Name — This is the name of the machine you are configuring with 
Configuration Expert. This should be the hostname as it appears on the 
network. This is an identifier for Configuration Expert only, and should 
match the name you specify in the hostname  field.

� Hostname  — This is the name of the machine on which the Business Proc
Option Servers will run.

� Description  — Enter a brief description of the application for which you 
are configuring this platform (in this case, the Business Process Option).

� Operating System  — Select the appropriate operating system from the 
pulldown menu to the right of this field.

� TUXEDO Directory (TUXDIR)  —  Enter the full absolute pathname for the
location of your eLink Platform installation.

� Tuxedo version  — Select Tuxedo 6.5 from the pulldown menu to the righ
of this field. 

4. Add the machine to the Machines list.

After entering all of your machine specification information, click Add. The 
name of the newly defined machine is added to the Machines list on the left. 

Note: Repeat steps 3 and 4 for any other machines that are part of the Busi
Process Option and eLink Platform installation.

5. Choose File->Save to save your machine specifications.

6. Choose File->Exit to quit the Configuration Data Editor.
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Step 3: Create a New Configuration Setup 
File

After creating a new machine specification with the Data Editor, the next step is 
create a new application configuration setup file. This file is not the eLink Platfor
configuration file you will generate in the final steps of the configuration process. T
file simply provides a framework for collecting the information you enter into the 
Configuration Expert screen forms. When you have completed the configuration
initiate the file generation process, Configuration Expert reads this file and gene
the actual eLink Platform configuration files.

To create a new configuration setup file:

1. Start the Configuration Expert utility.

On a UNIX platform:

Enter the following commands at the operating system prompt:

cd < $TUXDIR>/eLink/ConfigExpert/bin

./ConfigExpert &

On a Windows NT platform:

Click Start->Programs->BEA eLink->Configuration Expert.

This displays the Configuration Expert startup screen.  

2.  Choose File->New.

This displays the Create New Configuration window, as illustrated in Figure 6-1.
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Figure 6-1   Configuration Expert Create New Configuration Window

3. Enter the name of your application (in this case, BPO) in the Name field in th
Create New Configuration window. 

The Configuration Expert creates a file of this name, with the suffix .ce . For 
example: BPO.ce .

4. Enter the location in which you want the new configuration file to reside.

In the Location field, enter the full absolute pathname for the location in which
the new configuration file should be written. Do not include the filename — th
specifies the location of the file, only.  It is recommended that you select the 
default. To do this, click on the elipsis button (...) to the right of the location 
field. Select the default. Click OK to submit your selection and go back to the
Create New Configuration window. 

5. Click OK to submit your specifications and go to the Application Properties 
(General) window.

After you click OK to start a new setup file, the Application Properties window
displays, with the General tab selected. The next step in creating a new setup
is to configure the Application Properties. The following section provides 
instructions for this procedure.
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Step 4: Configure the Application Properties

The next step is to configure the Application Properties. The Application Propert
define such information as the application name, the IPC Key, level of system ac
number of services, and location of the server environment files.

To configure the Application Properties:

1. Go to the Application Properties window and select the General tab.

There are several ways to go to the Application Properties window:

� If you have just created a new application configuration file using the New
Configuration window, click OK in the New Configuration window. This 
leads directly to the Application Properties window with the General tab 
selected.

� From the Configuration Expert main window, select the application in the 
Current Application panel, then click the Props button to display the 
Application Properties window with the General tab selected.

� From the Configuration Expert main window, select the application in the 
Current Application panel, then choose Edit->Properties  to display the 
Application Properties window with the General tab selected.

Figure 6-2 illustrates the Application Properties window with the General tab 
selected.
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Figure 6-2   Configuration Expert Application Properties General Window

2. Enter your Application Properties General information.

The Application Properties (General) window contains the following fields:

� Application Name  — This is the eLink Platform application name (in this 
case, the BEA Business Process Option). This corresponds to the UBB fil
parameter DOMAINID.

� IPC Key  — This is the Interprocess Communication Key. This is a unique 
application identification key that all eLink Platform servers and clients us
to identify and communicate with the application. Each eLink Platform 
application must have a unique IPC Key. The corresponding UBB file 
parameter is IPCKEY. The value must be between 32768 and 262143.

� Master Machine  — This is the controlling machine for the eLink Platform 
application. For single-server configurations, this tab is disabled. (See “Step 
6: Configure the Machine Properties.”) The corresponding UBB file 
parameter is MASTER.

� System Access  — This specifies the access mode to the BEA eLink 
Platform bulletin board. The corresponding UBB file parameter is 
SYSTEM_ACCESS. Select FASTPATH from the drop down menu to the right of 
this field. The corresponding UBB file parameter is SYSTEM_ACCESS.
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� Maximum # of Services  — This is the size of the Services table in the 
BEA eLink Platform bulletin board, and is the maximum number of service
that may be advertised by all servers running in the application. The 
corresponding UBB file parameter is MAXSERVICES. The default is 500; the 
range is 1 to 32768.

3. Enter your Application Properties Environment information.

Click on the Environment tab to display the Application Properties 
(Environment) window, as illustrated in Figure 6-3.

Figure 6-3   Configuration Expert Application Properties Environment Window

� Available Servers File  — This is the location in which the 
iservers.lst  file resides. This is the list of available servers; this list is 
updated whenever you use the Create button to add new servers. There i
corresponding UBB file parameter.

� Generated Servers File  — This is the location in which the 
gservers.lst  file resides. By default, this file, which is provided as part o
this release, resides in the <TUXDIR>/eLink/ConfigExpert/Config  
directory. Enter the full absolute pathname for this location. There is no 
corresponding UBB file parameter.
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� Output Directory  — This is the directory to which the Configuration 
Expert output files should be written. The default is 
$TUXDIR/ConfigExpert/config . There is no corresponding UBB file 
parameter.

4. Submit your Application Properties information and go to the main window.

Click OK to submit your Application Properties information and go to the 
Configuration Expert main window, as illustrated in Figure 6-4.

Figure 6-4   Configuration Expert Main Window

5. Save your new configuration setup file.

Although you have created a new configuration setup file, it does not yet exis
on disk. Choose File->Save to save the new configuration setup file. Each tim
you choose File->Save at any step in the configuration process, the current 
configuration information is written to this file.

To save your new configuration specifications, click Save, or choose File->Sa
or File->Save As. If you choose File->Save As, this displays the Save 
Application Configuration window, as illustrated in Figure 6-5.
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Figure 6-5   Configuration Expert Save Application Configuration Window

Select the directory to which the configuration should be saved, specify a 
filename, and click OK. 
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Step 5: Add the Machine to the 
Configuration Tree

In “Step 2: Create a New Data Configuration File,” you defined your server machine
and application, and made their existence known to the Configuration Expert. Th
added the machine to the Available Machines list, but did not add it to the 
configuration itself. In this step, you add the Business Process Option Server ma
to the new configuration by adding it to the configuration tree (left panel in the m
window) and thereby make it available for configuration. 

To add a machine to the configuration tree:

1. Go to the Configuration Expert main window.

After completing “Step 4: Configure the Application Properties,” click OK in the 
Application Properties window to go to the Configuration Expert main window
The main window displays the machine and application information you 
specified in the previous steps.

2. Select the machine from the Available Machines list.

The Configuration Expert main window contains two panels:

� The Available Machines list (on the right hand side)

� The Current Application configuration tree (on the left hand side)

Select a machine from the Available Machines list in the left panel.

3. Click Add to display the Machine Properties (General) window.

Click Add to add the selected machine to the Current Application panel on th
left. This action also brings up the Machine Properties (General) window for 
configuring the properties of the machine you just added. You can proceed to
next step to configure the machine you just added, or click OK in the Machine
Properties (General) window to configure the machine at another time. You c
then repeat the process for “Step 5: Add the Machine to the Configuration Tree” 
and continue adding as many machines as you want to configure. Each mach
must be configured individually, however. Generally, it is easier to proceed to
“Step 6: Configure the Machine Properties” and configure each machine as you 
add it, before adding another machine. However, this is not mandatory. 
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Step 6: Configure the Machine Properties

When you clicked Add in “Step 5: Add the Machine to the Configuration Tree,” the 
Machine Properties window automatically displayed, with the General tab alread
selected. At this point, you can elect to click OK in this window to add the machin
the configuration tree, and then add additional machines before proceding to “Step 6: 
Configure the Machine Properties.” Generally, it is more convenient to configure eac
machine as you add it, before adding additional machines to the configuration tre
do so, you must repeat “Step 5: Add the Machine to the Configuration Tree” and “Step 
6: Configure the Machine Properties” for each machine you want to add and configu

Note:  You can also go to the Machine Properties (General) window by selecting
machine you want to configure from the configuration tree (left panel of th
main window) and then either clicking the Props button or by selecting 
Edit->Properties. If you elected to add multiple machines in “Step 5: Add the 
Machine to the Configuration Tree,”you will need to use one of these method
to get to the appropriate Machine Properties 

To configure the machine properties for the selected machine, click on the tab for
category of properties in the Machine Properties window, and enter your informa
into the appropriate fields. There are three categories of machine properties:

� General  — This contains some information concerning the machine name, 
application directory, environment setup file, and the prefix to be used in nam
ULOG files. This is the first Machine Properties window

� Limits  — This specifies the maximum number of Native and WS clients 
allowed for this machine.

� Network  — This defines the listener ports, user ID, and group ID.

To configure the machine properties:

1. Go to the Machine Properties (General) window.

When you click Add in “Step 5: Add the Machine to the Configuration Tree,” 
the Machine Properties (General) window automatically displays. You can als
go to this window by selecting a machine in the configuration tree (left panel)
and then either clicking the Props button, or choosing Edit->Properties. 
Figure 6-6 illustrates the Machine Properties window with the General tab 
selected.
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Figure 6-6   Configuration Expert Machine Properties General Window

2. Enter your general properties information for the selected machine. 

The Machine Properties (General) window contains the following fields:

� Logical Machine ID  — This is the name of the machine you specified 
using the Data Editor in “Step 2: Create a New Data Configuration File,” 
above. The corresponding UBB file parameter is LMID .

� Application Directory  — This is the directory to be used as the 
application working directory by the eLink Platform. Enter the full absolute
pathname for the location in which the application servers are located. Th
corresponding UBB file parameter is APPDIR.

� Environment File  — This is the environment file containing the 
environment variable assignments for all BEA eLink Platform applications
on this machine. Enter the full absolute pathname and filename for the 
eLink_BPO.env  file.There is no default for this field. The corresponding 
UBB file parameter is ENVFILE.

� ULOG File Prefix  — This is the location and filename for the user log file
generated by the eLink Platform. This file is typically referred to as the 

ULOG file. The final portion of this entry should be a filename, typically 
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ULOG. The eLink Platform will append the suffix .< current_date > to the 
filename. If you do not specify a pathname, the file is placed in the directo
<APPDIR>. The corresponding UBB file parameter is ULOGPFX. 

3. Enter your Machine Properties Limits information.

Click on the Limits tab to display the Machine Properties (Limits) window, as 
illustrated in Figure 6-7.

Figure 6-7   Configuration Expert Machine Properties Limits Window

This window contains the following fields:

� Maximum Number of Native Clients  — This is the maximum number of 
Native Clients that you can assign to this machine. The range is 1 to 3276
You can accept the default, which is 50. The corresponding UBB file 
parameter is MAXACCESSERS.

� Maximum Number of WS Clients  — This is the maximum number of 
Workstation clients you can assign to this machine. The range is 0 to 3276
You can accept the default, which is 50. The corresponding UBB file 
parameter is MAXWSCLIENTS.
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4. Enter your Machine Properties Network information (optional).

Click on the Network tab to display the Machine Properties (Network) window
as illustrated in Figure 6-8.

Figure 6-8   Configuration Expert Machine Properties Network Window

Note: For the standard Business Process Option configuration,which uses only
single machine, it is not necessary to define any Machine Properties Netw
parameters. Accept the defaults for these parameters.

This window contains the following fields:

� BRIDGE Listener Port  — This is the TCP/IP port number to be used by the 
BRIDGE process. The corresponding UBB file parameter is BRIDGE.

� TListen Listener Port  — This is the TCP/IP port number to be used by the
tlisten  process. The corresponding UBB file parameter is NLSADDR.

� USER ID  — This is the specific USER ID of the BEA eLink Platform 
administrator on that machine. The corresponding UBB file parameter is UID.
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� GROUP ID — This is the specific GROUP ID of the BEA eLink Platform 
administrator on that machine. The corresponding UBB file parameter is GID.

5. Submit your Machine Properties information.

After you enter all of the appropriate information, click OK to submit your 
specifications.

Note: It is recommended that you save your configuration setup file after comple
each step, as the information will not be saved automatically. Choose 
File->Save to save the current file.
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Step 7: Add and Configure the Server 
Groups

The next step is to add the server groups to the configuration and configure each g
You can add and configure one group at a time, or add all of the groups at once
then configure each group. Each group must be configured individually. 

A group is a collection of eLink Platform Servers. Grouping servers facilitates ser
management by enabling eLink Platform operations (for example, boot or shutdo
to be executed unilaterally across a group.

To add and configure the server groups:

1. Go to the Configure Groups window.

Choose Go->Groups. You can also click the Right Arrow key next to the Step
status message to go to the next configuration step (in this case, Configure 
Groups). Figure 6-9 illustrates the Configure Groups window.
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Figure 6-9   Configuration Expert Configure Groups Window

2. Add the required groups to the configuration.

Select the group in the Available Groups list, and then click Add. The group 
name should now appear in the Current Application configuration tree in the 
frame.

Add the following groups to the Current Application configuration tree:

� Default  Group

� BusProcOption  Group

Note: You can customize the list of available server groups by editing the Reso
Manager template file. For more information on this procedure, refer to th
BEA TUXEDO Builder Configuration Expert online document which is 
provided on your BEA eLink Platform installation CD-ROM. This docume
is in PDF form and is readable with Adobe Acrobat Reader. 

3. Change the name of the Default  group to SYSGRP.
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Select the Default  Group in the Current Application configuration tree, and 
click the Props button (or choose Edit->Properties). This displays the Group 
Properties (General) window, as illustrated in Figure 6-10.

Figure 6-10   Configuration Expert Group Properties General Window

Change the contents of the Group Name field to SYSGRP.

Note: The Transactions tab is greyed out for this group; you need not enter any
transaction information for the group SYSGRP.

4. Click OK to submit the new group name.

5. Change the name of the BusProcOption  group to BPOGRP.

Follow the same procedure as you did to change the name of the Default  
group.

6. Click OK to submit the new group name.

Note: It is recommended that you save your configuration setup file after comple
each step, as the information will not be saved automatically. Choose 
File->Save to save the current file.
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Step 8: Configure the Servers

The next step is to add and configure the servers. The gservers.lst  file defines all 
servers required by the application. However, if you want to use additional  serve
for example, the server mathserv  for the MATHAPP sample application — you will 
need to add those in addition to the servers defined in this procedure. The serve
add are  appended to the iservers.lst  file.

To configure the servers:

1. Go to the Configure Servers window.

Choose Go->Servers to display the Configure Servers window. You can also 
click the Right Arrow key next to the Step # status message to go to the next
configuration step (in this case, Configure Servers). Figure 6-11 illustrates the 
Configure Servers window.

Figure 6-11   Configuration Expert Configure Servers Window

2. Add the IcCliMgr  server to the group SYSGRP.
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To add the server, do the following:

a. Select the group SYSGRP from the Current Application configuration tree on th
left. This displays the servers available to that group.

b. Select the IcCliMgr  server from the Available Servers list, and click ADD.

The IcCliMgr  server should now be listed in the Current Applications frame, 
under the group SYSGRP.

3. Configure the General Properties for the IcCliMgr  server.

The IcCliMgr  server manages the startup and shutdown of certain Business 
Process Engine services, such as the Repository Daemon.

To configure the general properties for the IcCliMgr  server, do the following:

a. Select IcCliMgr  from the Current Applications list, and click Props. (You ca
also choose Edit->Properties, or simply double-click on the server name in
Current Applications list). This displays the Server Properties window with t
General tab selected, as illustrated in Figure 6-12.
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Figure 6-12   Configuration Expert Server Properties General Window

This window contains the following fields:

� Server Name  — This is the fully qualified path to the eLink Platform Serve
executable. If you do not specify the path, it is assumed that the file reside
in the <APPDIR>.

� Command Line Options  — These are the default server command line 
options that are to be used for automatic startup of the server. The 
corresponding UBB file parameter is CLOPT.

b. Modify the server name field so that it is quoted and contains the fully qual
path to the executable. For example: 

"/work1/ic/tuxapp/IcCliMgr"

c. Change the location of the logs (optional).

You can optionally change the location of the log files generated by the 
server. To do so, add the full pathname before both of the .err and .out   
entries in the Command Line Options  field. For example:
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Note: A backslash indicates that the command should be written in one 
continuous line; the backslash is not part of the actual command line.

Before:

-A -e IcCliMgr.err -o IcCliMgr.out --\
-b IcCliMgr.cfg -I IcCliMgr.log

After:

-A -e /bpo/logs/IcCliMgr.err -o /bpo/logs/IcCliMgr.out --\
-b IcCliMgr.cfg -I /bpo/logs/IcCliMgr.log

Warning: This entry consists of two parts: the eLink Platform/TUXEDO-specific
options, and the server-specific options. These two portions are separ
by two minus sign characters ( --  ). The minus signs must be included in
your specification. For information on the platform-specific options, ref
to your eLink Platform and TUXEDO UBB file documentation.

4. Configure the Process Properties for the IcCliMgr  server.

Click on the Process tab in the Server Properties window. This displays the 
Server Properties (Processes) window, as illustrated in Figure 6-13.
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Figure 6-13   Configuration Expert Server Properties Process Window

This window contains the following fields:

� Minimum # of Processes  — This specifies the minimum number of 
server instances to be automatically started when the server is booted. A 
blank field defaults to 1. The corresponding UBB file parameter is MIN.

� Maximum # of Processes  — This specifies the maximum number of 
server instances that can be booted at any given time. A blank field defau
to 1. The corresponding UBB file parameter is MAX.

� Restartable  — This specifies whether the server is restartable. The defa
is No (checkbox unchecked).  Select Yes (checkbox checked) for all servers. 
The corresponding UBB file parameter is RESTART.

Note: The following four parameters support the automatic spawning/decay
of servers through the mechanism of the -p  eLink Platform/TUXEDO 
CLOPT parameter. Given the following:

Grow pool when queue depth over = A
Seconds to wait before growth parameter = B
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Shrink pool when queue depth under = C
Seconds to wait before shrinking = D

Then the CLOPT line should contain the following:

-p A,B: C,D

� Grow pool when queue depth over  — Specifies the maximum number 
of messages before spawning a new server. During runtime, if the numbe
messages is met or exceeded for a time set by the Seconds to wait 

before growth parameter , a new server is spawned.

� Seconds to wait before growth parameter  — Specifies the time in 
seconds allowed to elapse before the server pool is expanded. 

� Shrink pool when queue depth under  — Specifies the minimum 
number of messages before deactivating a server. During runtime, if the 
number of messages is below this value by the time specified by the 
Seconds to wait before shrinking  parameter, a server is deactivated. 

� Seconds to wait before shrinking  — Specifies the time in seconds 
allowed to elapse before the server pool is reduced. 

5. Enter 1 as the Minimum # of Processes .

6. Enter 1 as the Maximum # of Processes .

7. Submit the modified IcCliMgr  server configuration information.

Click OK to submit your modifications and return to the Server Configuration 
window.

8. Add the BPOGRP servers.

Add each of the following servers to the BPOGRP group, in the oder listed. 

� IcEvtAct  — This advertises the Business Process Engine Event/Action 
Daemon processing services.

� IcWorker  — (First of two IcWorker  servers) This advertises the 
IcGen_eLink services. 

� IcWorker  — (Second of two IcWorker  servers)This advertises the 
IcJob_eLink services. 

Note: Add two instances of the IcWorker  server.
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� eProcRunner  — This is the Business Process Option Server that starts a 
Business Process Engine job or process, and waits for the process to 
complete before returning.

� eProcStarter  —  This is the Business Process Option Server that starts a
Business Process Engine job or process, and returns as soon as the proc
has started.

� eTaskAgent  — This is the Business Process Option Server that processes
Business Process Engine tasks.

� Define the BPOGRP server properties.

For each of the BPOGRP servers, do the following:

a. Select the server from the Current Applications list, and click Props. (You 
also choose Edit->Properties, or simply double-click on the server name in
Current Applications list). This displays the Server Properties (General) 
window, as illustrated in Figure 6-12.

b. Modify the server name field so that it is quoted and contains the fully qual
path to the executable. For example: 

"/work1/ic/tuxapp/IcCliMgr"

Note: You need not specify an explicit pathname for the eProcRunner , 
eProcStarter  and eTaskAgent  servers. However, you must specify the
full path to the eLink_BPO.cfg file  for each in the Command Line 

Options  field.

c. Change the location of the IcWorker  server log files.

To change the log file locations, add the full pathname before each of  the
.err and .out   entries in the Command Line Options  field. For example:

Note: A backslash indicates that the command should be written in one 
continuous line; the backslash is not part of the actual command line.

For the first IcWorker  server entry:

-A -e /bpo/logs/IcWorker.err -o /bpo/logs/IcWorker.out --\
-b IcWorker.cfg -I /bpo/logs/GenWorker.log

For the second IcWorker  server entry:

-A -e /bpo/logs/IcWorker.err -o /bpo/logs/IcWorker.out --\
-b IcWorker.cfg -I /bpo/logs/IcJobWorker.log
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9. Configure the Process Properties for each server.

Click on the Process tab in the Server Properties window. This displays th
Server Properties (Processes) window, as illustrated in Figure 6-13. The 
following table provides the Process settings for each server. You can acc
the default settings for all fields except those indicated in the table.

Note: For all servers, check the Restartable  checkbox.

Warning: The default installation uses eLink  as the Business Process Engine 
service name suffix. If you change this for any reason during the 
installation of the Business Process Engine, you must update  
IcTuxConfig  files on both the client machine(s) and server machine(
to reflect this change. These files are in the following locations:

Client: <PDA_Base_Install_Dir >/Txm/config

Server: <$IC_HOME>/config

In addition, you must change the eLink  argument for the -s  option in 
the Command Line Options  specification for the following servers:

IcEvt
IcWorker (IcGen)

IcWorker (IcJob)

Note: It is recommended that you save your configuration setup file after comple
each step, as the information will not be saved automatically. Choose 
File->Save to save the current file.

Server Name Min. # Processes Max. # Processes

IcEvtAct 1 1

IcWorker (IcGen) 3 3

IcWorker (IcJob) 1 1

eProcRunner 1 1

eProcStarter 1 1

eTaskAgent 1 1
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Step 9: Configure the Optional Components

The next step is to add and configure the optional components. The optional 
components are eLink Platform utility servers or add-ons, such as communicatio
gateways. For the Business Process Option, you must add and configure the follo
components:

� WSL

� eLinkJSL

� IREPSVR

To add and configure these components:

1. Go to the Configure Optional Components window.

Choose Go->Options to go to the Configure Optional Components window. Y
can also click the Right Arrow key next to the Step # status message to go to
next configuration step (in this case, Configure Optional Components). 
Figure 6-14 illustrates the Configure Optional Components window, which 
comes up with the WS tab selected.
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Figure 6-14   Configuration Expert Configuring Optional Components Window

2. Add the WSL component.

The Configuring Optional Components (WSL) window contains the following 
fields:

� WSL Port Number  — This specifies the port number for the Workstation 
Listener. Enter a port number of 11417. The contents of this field are adde
to the UBB file CLOPT parameter contents for the WSL Server.

� Minimum Number of Handlers  — This specifies the minimum number of 
Workstation handlers, or WSH, that are started when the application is 
booted You can accept the default for this configuration.  The contents of 
field are added to the UBB file CLOPT parameter contents for the WSL 
Server.

� Maximum Number of Handlers  — This specifies the maximum number of 
Workstation handlers that can be started. You can accept the default for th
configuration. The contents of this field are added to the UBB file CLOPT 
parameter contents for the WSL Server.
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� Multiplexing Factor  — This specifies the maximum number of clients 

per WSH.  You can accept the default for this configuration. The contents 
this field are added to the UBB file CLOPT parameter contents for the WSL 
Server.

Enter your WSL component specifications and click Add.

3. Add the eLinkJSL  component.

To add the eLinkJSL  component, do the following:

a. Click the Jolt tab to display the Configuring Optional Components (Jolt) 
window, as illustrated in Figure 6-15.

Figure 6-15   Configuration Expert Configure Optional Components Jolt 
Window

b. Select eLinkJSL .

 This displays the Configure Optional Components (Jolt JSL) window, as 
illustrated in Figure 6-16.
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Figure 6-16    Configure Optional Components Jolt JSL Window

This window contains the following fields:

� eLinkJSL Port Number  — This is the port number assigned to the 
eLinkJSL . Enter a port number of  11400. The contents of this field are 
added to the UBB file CLOPT parameter contents for the eLinkJSL Server.

� Minimum Number of Handlers  — This specifies the minimum number of 
Jolt handlers, or JSH, that are started when the application is booted. You
accept the default for this configuration. The contents of this field are adde
to the UBB file CLOPT parameter contents for the eLinkJSL Server.

� Maximum Number of Handlers  — This specifies the maximum number of 
JSH that can be started. You can accept the default for this configuration. 
The contents of this field are added to the UBB file CLOPT parameter 
contents for the eLinkJSL Server.

� Multiplexing Factor  — This specifies the maximum number of clients 
per JSH. You can accept the default for this configuration. The contents o
this field are added to the UBB file CLOPT parameter contents for the 
eLinkJSL Server.
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c. Enter your eLinkJSL  component specifications and click Add.

4. Add the IREPSVR component.

To add the IREPSVR component, do the following:

a. Click the Repository tab to display the Configuring Optional Components 
(Repository) window, as illustrated in Figure 6-17.

Figure 6-17   Configuration Expert Configure Optional Components Repository 
Window

b. Select IREPSVR.

 This displays the Configure Optional Components (Repository IREPSVR
window, as illustrated in Figure 6-18.
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Figure 6-18    Configure Optional Components Repository IREPSVR Window

This window contains the following fields:

� Read-Only Access to Repository Checkbox  — If selected, this 
specifies read only access to the repository file. Make sure this is 
UNSELECTED so that there is write access to the file. The contents of this fie
are added to the UBB file CLOPT parameter contents for the IREPSVR.

� Repository File  — This specifies the location of the BEA eLink Platform
Repository file. This is the file in which the Business Process Option Proc
Design Assistant stores information. This file must be accessible by the 
IREPSVR, which usually means it must be local to the IREPSVR machine. 
When you installed the Business Process Option, an empty repository file
was created and stored in the directory <$TUXDIR>/udataobj.  

c. Enter your IREPSVR component specifications and click Add.

5. Save the entire configuration file.

Choose File->Save to save the current file. 

The configuration process is now complete. The next step is to generate the 
configuration files and scripts, as described in the next section.
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Step 10: Generate the Configuration Files 
and Scripts

After entering all of your configuration information and saving your configuration
setup file, you can generate the configuration files and scripts. The Configuration
Expert reads the contents of your setup file to generate these files. If you modify
contents of your setup file at any time, you must consequently regenerate the 
configuration files and scripts for these changes to occur in the configuration.

To generate the configuration files and scripts:

1. Choose Go->Startup.

This displays the Generate & Startup window, as illustrated in Figure 6-19.

Figure 6-19   Configuration Expert Generate & Startup Window

2. Click the Gen Files button.
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This will produce an output listing in the Command Output frame on the left o
the Generate & Startup window, as illustrated in Figure 6-20.

Figure 6-20   Configuration Expert Generate Files Output

The following files should be generated:

� <application_name >.ubb

� <application_name >.checklist

� tux_start.sh

� tux_stop.sh

� crtlog.sh

For a description of each of these files, refer to “The eLink Platform Business 
Process Option Configuration Files,” in the “Overview” section of this chapter.

Note: You can move or copy the generated files into the working eLink Platfo
application directory ($APPDIR, which in this case is the Business Proce
Option installation directory). 

3. Save your settings. 
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The Business Process Option configuration process is now complete. The next s
to test the new configuration. Instructions for this step are provided in the next se

Step 11: Testing the Configuration

To test your new configuration, you can use the Configuration Expert Activate fea
to perform a preliminary startup of the system. Use one of the following methods

� Use the Activate button in the Configuration Expert Step 5: Generate a 

Startup  window:

a. Go to the Configuration Expert main window.

b. Use the Right Arrow button to the left of the Step status line. Click the Rig
Arrow until the Step status message Step 5: Generate a Startup  displays, 
as illustrated in Figure 6-21.
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Figure 6-21   Configuration Expert Step 5: Generate a Startup Window

c. Click the Activate button to initiate a startup.

� Choose Go->Startup->Activate.

When the system is started, a series of status and/or error messages are dis
in the Command Output panel in the right half of the main window. You can u
the output in this panel to assist in finetuning or debugging your new 
configuration.
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A Configuration  
Information Checklist

This section provides checklists you can use to gather the information you will nee
complete the Business Process Option configuration process. Topics include:

� Overview

� eLink Platform Environment Configuration (env.sh File)

� Client Environment Configuration (eLink_BPO.env File)

� Server Environment Configuration

� Data Configuration File

� Configuration Setup File

� Application Properties Configuration

� Machine Properties

� Server Properties Configuration

� Optional Components Configuration
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Overview

This appendix contains the following checklists for gathering your configuration 
information:

� eLink Platform Environment Configuration (env.sh File)

� Client Environment Configuration (eLink_BPO.env File)

� Server Environment Configuration

� Data Configuration File

� Configuration Setup File

� Application Properties Configuration

� Application Properties (General)

� Application Properties (Environment)

� Machine Properties

� Machine Properties (General)

� Machine Properties (Limits)

� Machine Properties — (Network)

� Server Properties Configuration

� Server Properties (General)

� Server Properties (Process)

� Optional Components Configuration

� WSL Component Configuration

� eLinkJSL Component Configuration

� IREPSVR Component Configuration
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Note: Groups configuration does not require any additional information, so no 
checklist has been provided. For more information on configuring Groups
please refer to the online document BEA TUXEDO Builder Configuration 
Expert provided in PDF form with the BEA eLink Platform 1.2 release.

These checklists are provided in the following sections.

eLink Platform Environment Configuration 
(env.sh File)

This section provides a checklist for the information you will need to complete th
configuration procedures outlined in Chapter 3, “Configuring the Server Platform 
Environment.” 

Note: You must manually add the following variables and their assignments to 
env.sh  file:

� TUXCONFIG

� FIELDTBLS32

� FLDTBLDIR32

Warning: The TUXCONFIG environment variable is not provided as part of the 
installation, because the TUXCONFIG file location is not known or required 
as part of the installation process. This environment variable must be set, 
however, for the eLink Platform to compile the UBB configuration file and 
boot the eLink Business Process Option application.
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Table A-1  eLink Platform Environment Configuration Checklist

Environment 
Variable

Description Assigned Value

IC_HOME This is the eLink Business Process Engine 
home directory.

IC_CLIENT This is the eLink Business Process Engine 
client login string. This string specifies the 
eLink Business Process Engine user, 
server, and optionally the user’s 
password, in the format 
username [ /password ] @serverna
me. 

TUXDIR This is the eLink Platform home directory.

TUXCONFIG This is the explicit location of the binary 
configuration file for the eLink Platform.

Note: You must manually add this 
variable to the env.sh  file.

PATH Contains a list of the directories to be 
searched to locate executables.

LANG This is the NLS language. 
The default is C.

NLSPATH Directories to be searched for locating 
message catalogs.

LD_LIBRARY_PATH Solaris only. This is the search path for 
shared libraries.

SHLIB_PATH HP-UX only. This is the search path for 
shared libraries.

ORACLE_HOME This is the Oracle home directory.
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TWO_TASK

or
ORACLE_SID

Identifies the Oracle instance for 
SQL*Net. 

FIELDTBLS32 Contains the list of table files required by 
FML data-dependent routing.

Note: You must manually add this 
variable and its assignment to the 
env.sh  file.

Note: Add eLink_BPO.f32  or the 
equivalent if you added these 
fields to an existing field table 
file.

FLDTBLDIR32 This contains the list of table files required 
by FML.

Note: You must manually add this 
variable and its assignment to the 
env.sh  file.

Note: Add the directory containing the 
modified eLink_BPO.f32  file 
for site-specific FML field 
numbers. 

WSNADDR This identifies the host machine and port 
number used by the eLink Platform 
workstation listener (WSL). 

Table A-1  eLink Platform Environment Configuration Checklist

Environment 
Variable

Description Assigned Value
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Client Environment Configuration 
(eLink_BPO.env File)

Table A-2  Client Environment Configuration Checklist

Variable Description Assigned 
Value

IC_SERVER_NAME This is the name of this eLink Business Process 
Engine server.

IC_HOST_MACHINE This is the master host machine for this server.

IC_STATUS_LOG This is the filename for the eLink Business 
Process Engine status log. 

Default: $IC_HOME/logs/status.log .

IC_AUDIT_MODE This is the type of audit logging used by this 
eLink Business Process Engine server. The 
possible values for this parameter:

IC_EVENT_AUDIT_DATABASE 

IC_EVENT_AUDIT_DATABASE_AND_FILE 

IC_AUDIT_LOG This is the name of the audit log file. Use this 
only if  IC_AUDIT_MODE is set to 
IC_EVENT_AUDIT_DATABASE_AND_FILE. 

If it is set to IC_EVENT_AUDIT_DATABASE, 
set IC_AUDIT_LOGS to NOT_USED (the 
default).

IC_RDBMS This identifies the database system. This must 
always be ORACLE.

Oracle

IC_EVENT_POLL_INTERVAL This is the polling interval, in seconds, for 
temporal events (e.g., overdue tasks). 

Default: 3600 (one hour) 
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IC_ACTION_POLL_INTERVAL This is the polling interval, in seconds, for 
general event processing. 

Default: 60

FIELDTBLS32 This contains a list of the FML field definition 
files available to the eLink Platform.

FLDTBLDIR32 This specifies the location of the FML field 
definition files specified in FIELDTBLS32 .

Variable Description Assigned 
Value
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Server Environment Configuration

This section provides checklists for configuring the Business Process Engine an
Business Process Option Servers.

 eLink_BPO.cfg File

This section contains a set of checklists for configuring the eLink_BPO.cfg  file 
parameters for each server.

Business Process Engine Server Login Parameters

The following three parameters are common to each eLink_BPO.cfg  file section. 
These specify the login information to be used by the Business Process Option S
for connections to the appropriate instance of the Business Process Engine. 

Table A-3  Business Process Engine Server Login Parameters Checklist

Variable Description Assigned Value

SERVER This is the name of the Business Process 
Engine Server to which to connect. 

USER Business Process Engine userid . This must 
be a user created with the BpoAddUser  
command during installation.

PASSWORD This is the password assigned to the Business 
Process Engine user specified for USER, 
above.
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Server Environment Configuration
eProcStarter Parameters

eProcRunner

Table A-4  eProcStarter Parameters Checklist

Variable Description

SERVICE_LIST This is a comma-separated list of service 
names to be advertised. Each must have a 
corresponding template defined. Each  must 
be unique and meet eLink Platform service 
name requirements. Each must be unique 
when compared to the SERVICE_LIST  for 
eProcRunner  and any other services 
running in the eLink Platform application.

Table A-5  eProcRunner Parameters Checklist

Variable Description Assigned Value

SERVICE_LIST This is a comma-separated list of service 
names to be advertised. Each must have a 
corresponding template defined. Each 
must be unique and meet eLink Platform 
service name requirements. Each must be 
unique when compared to the 
SERVICE_LIST  for eProcStarter  and 
any other services running in the eLink 
Platform application.

POLL_INTERVAL Specifies how often, in tenths of seconds, 
the server should sleep between process 
status queries.
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eTaskAgent

Table A-6  eTaskAgent Parameters Checklist

Variable Description Assigned Value

POLL_INTERVAL This specifies the amount of time in 
tenths of seconds the server should 
wait between queries to the 
Business Process Engine for ready 
tasks. 

POLL_COUNT This is the maximum number of 
ready tasks that should be processed 
before forcing the daemon to 
process another ATMI loop. 

COMPLETE_FAILED_TASK If the service request fails, marks 
the task as complete  and continue 
(setting error information on the 
process level attributes).
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Data Configuration File

This section provides a checklist for the information you will need to complete
“Step 2: Create a New Data Configuration File,” in Chapter 6, “Creating the eLink 
Platform Configuration Files.”

Table A-7  Data Configuration File Checklist

Field Description Default Assigned Value

Name Name of the machine you are configuring with 
Configuration Expert. This should be the 
hostname as it appears on the network. This is 
an identifier for Configuration Expert only, 
and should match the name you specify in the 
hostname  field.

None.

Hostname Name of the machine on which the Business 
Process Option Servers will run.

None.

Description Description of the application for which you 
are configuring this platform.

None.

Operating 
System

Select the appropriate operating system from 
the pulldown menu to the right of this field.

None.

TUXEDO 
Directory 
( $TUXDIR)

Full absolute pathname for the location of 
your eLink Platform installation.

None.

Tuxedo 
version

The eLink Platform/Tuxedo version on this 
installation. 

TUXEDO 6.3 TUXEDO 6.5
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Configuration Setup File

This section provides a checklist for the information you need to complete
“Step 3: Create a New Configuration Setup File,” in Chapter 6, “Creating the eLink 
Platform Configuration Files.”

Table A-8  Configuration Setup File Configuration Checklist

Field Description Assigned Value

Name Name of the application you are configuring.

Location Full absolute pathname for the location in which 
the new Configuration Setup file is to reside. 

Default:

TUXDIR/eLink/ConfigExpert/config

Select the default.
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Application Properties Configuration

This section provides a set of checklists for the information you need to complet
“Step 4: Configure the Application Properties,” in Chapter 6, “Creating the eLink 
Platform Configuration Files.”  The checklists are as follows:

� Application Properties (General) Configuration Checklist

� Application Properties (Environment) Configuration Checklist

These are provided in the following subsections.

Application Properties (General)

This section provides a checklist for the information you will need to configure th
General Application Properties for “Step 4: Configure the Application Properties,” in 
Chapter 6, “Creating the eLink Platform Configuration Files.”   

Table A-9  Application Properties (General) Checklist

Field Description Default Assigned Value

Application 
Name

eLink Platform application name. 
This corresponds to the UBB file 
parameter DOMAINID.

None.

IPC Key Interprocess Communication Key. 
Each eLink Platform application 
must have a unique IPC Key. The 
corresponding UBB file parameter is 
IPCKEY. The value must be 
between 32768 and 262143.

None.
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Master Machine This is the controlling machine for 
the eLink Platform  application. For 
single-server configurations, this 
should be the same as that specified 
for the Logical Machine Name  
and Hostname  in the Machine 
Properties General window. The 
corresponding UBB file parameter 
is MASTER.

None.

System Access Specifies the access mode to the 
BEA eLink Platform bulletin board. 
The corresponding UBB file 
parameter is SYSTEM_ACCESS.  
The corresponding UBB file 
parameter is SYSTEM_ACCESS.

FASTPATH FASTPATH

Maximum # of 
Services

Size of the Services table in the 
BEA eLink Platform bulletin board, 
and is the maximum number of 
services that may be advertised by 
all servers running in the 
application. The corresponding 
UBB file parameter is 
MAXSERVICES.  Range is 1 to 
32768.

500

Table A-9  Application Properties (General) Checklist

Field Description Default Assigned Value
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Application Properties (Environment)

This section provides a checklist for the information you will need to configure th
Environment Application Properties for “Step 4: Configure the Application 
Properties,” in Chapter 6, “Creating the eLink Platform Configuration Files.”  

Note: A backslash denotes continuation of the current line. The backslash is not
of the field entry.

able A-10  Application Properties (Environment) Checklist

Field Description Default Assigned Value

Available 
Servers 
File

This is the location in which 
the iservers.lst  file 
resides. There is no 
corresponding UBB file 
parameter.

<$TUXDIR>/eLink/\

ConfigExpert/Config/\

iservers.lst

Generated 
Servers 
File

This is the location in which 
the gservers.lst  file 
resides.

Enter the full absolute 
pathname for this location. 
There is no corresponding 
UBB file parameter.

<$TUXDIR>/eLink/\

ConfigExpert/Config.

Output 
Directory

Directory to which the 
Configuration Expert output 
files should be written. There 
is no corresponding UBB file 
parameter.

<$TUXDIR>/eLink/\

ConfigExpert/Config.
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Machine Properties

This section provides a checklist for the information you need to complete
“Step 6: Configure the Machine Properties,” in Chapter 6, “Creating the eLink 
Platform Configuration Files.”

There are three categories of machine properties:

� General  — This contains some information concerning the machine name, 
application directory, environment setup file, and the prefix to be used in nam
ULOG files.

� Limits  — This specifies the maximum number of native and WS clients 
allowed for this machine.

� Network  — This defines the listener ports, user ID, and group ID.
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Machine Properties (General)

This section provides a checklist for the information you need to configure the Gen
Machine Properties for “Step 6: Configure the Machine Properties,” in Chapter 6, 
“Creating the eLink Platform Configuration Files.”  

Table A-11  Machine Properties (General) Checklist

Field Description Default Assigned Value

Logical 
Machine ID

Name of the machine you specified 
using the Data Editor. The 
corresponding UBB file parameter is 
LMID.

None.

Applicatio
n Directory

Directory to be used as the 
application working directory by 
the eLink Platform. Enter the full 
absolute pathname for the location 
in which the application servers are 
located. The corresponding UBB 
file parameter is APPDIR.

None.

Environmen
t File

This is the environment file 
containing the environment variable 
assignments for all BEA eLink 
Platform applications on this 
machine. Enter the full absolute 
pathname and filename for the 
eLink_BPO.cfg  file. The 
corresponding UBB file parameter 
is ENVFILE.

None.

ULOG File 
Prefix

Location and filename for the user 
log file generated by the eLink 
Platform. The final portion of this 
entry should be a filename, typically 
ULOG. The corresponding UBB file 
parameter is ULOGPFX. 

<$APPDIR>
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Machine Properties (Limits)

This section provides a checklist for the information you will need to configure th
Limits Machine Properties for “Step 6: Configure the Machine Properties,”  in 
Chapter 6, “Creating the eLink Platform Configuration Files.”  

Table A-12  Machine Properties (Limits) Checklist

Field Description Default Assigned Value

Maximum Number of 
Native Clients

Maximum number of native clients 
that you can assign to this machine. 
The range is 1 to 32767. You can 
accept the default, which is 50. The 
corresponding UBB file parameter 
is MAXACCESSERS.

50

Maximum Number of 
WS Clients

This is the maximum number of 
Workstation Clients you can assign 
to this machine. The range is 0 to 
32767. You can accept the default, 
which is 50. The corresponding 
UBB file parameter is 
MAXWSCLIENTS.

50
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Machine Properties — (Network)

This section provides a checklist for the information you need to configure the 
Network Machine Properties for “Step 6: Configure the Machine Properties,”  in 
Chapter 6, “Creating the eLink Platform Configuration Files.”  

Table A-13  Machine Properties (Network) Checklist

Field Description Default Assigned Value

BRIDGE 
Listener 
Port

TCP/IP port number to be used by 
the BRIDGE process. The 
corresponding UBB file parameter 
is BRIDGE.

50001

TListen 
Listener 
Port

TCP/IP port number to be used by 
the tlisten  process. The 
corresponding UBB file parameter 
is NLSADDR.

5000

USER ID Specific USER ID of the BEA 
eLink Platform administrator on 
that machine. The corresponding 
UBB file parameter is UID .

None.

GROUP ID Specific GROUP ID of the BEA 
eLink Platform administrator on 
that machine. The corresponding 
UBB file parameter is GID.

None.
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Server Properties Configuration

This section provides the checklists for the information you need to complete
“Step 8: Configure the Servers,” in Chapter 6, “Creating the eLink Platform 
Configuration Files.”

Note: The gservers.lst  file defines all of the servers required by the applicatio
However, if you want to use additional  servers — for example, the serve
mathserv  for the MATHAPP sample application — you need to add those to t
configuration. The servers you add are  appended to the iservers.lst  file.
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Server Properties (General)

This section provides a checklist for the information you need to configure the Gen
Server Properties for “Step 8: Configure the Servers,”  in Chapter 6, “Creating the 
eLink Platform Configuration Files.”  

The General Server Properties consist of the following fields for each server bein
configured:

� Server Name — This is the fully qualified path to the eLink Platform Server 
executable. If you do not specify the path, it is assumed that the file resides in
the <APPDIR>. Please refer to Chapter 6, “Creating the eLink Platform 
Configuration Files,” for detailed instructions on completing this field.

� Command Line Options — These are the default server command line option
that are to be used for automatic startup of the server. The corresponding UB
file parameter is CLOPT.

In the following table, you can note the Command Line Option entry you want to
assign for each server. Please refer to Chapter 6, “Creating the eLink Platform 
Configuration Files,” for detailed instructions on completing this field.

Table A-14  Server Properties (General) Checklist

Server Name Command Line Option Assignment

IcCliMgr

IcEvtAct

IcWorker (IcGen)

IcWorker (IcJob)

eProcRunner

eProcStarter

eTaskAgent
BEA eLink Business Process Option Configuration GuideA-21



A Configuration Information Checklist

rver 

s 
Server Properties (Process)

This section provides checklists for the information you need to configure the Se
Process Properties for “Step 8: Configure the Servers,” in Chapter 6, “Creating the 
eLink Platform Configuration Files.”  

Note: For all servers, select the Restartable  checkbox.

Minimum/Maximum Number of Server Processes

The following table lists the assignments you should enter for the Minimum # of 

Processes  and Maximum # of Processes  fields in the Server Properties — Proces
screen for each server.

Table A-15  Minimum/Maximum Server Processes Checklist

Server Name Min. # 
Processes

Max. # 
Processes

IcCliMgr 1 1

IcEvtAct 1 1

IcWorker (IcGen) 3 3

IcWorker (IcJob) 1 1

eProcRunner 1 1

eProcStarter 1 1

eTaskAgent 1 1
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Server Processes Configuration Checklist

The following is a checklist for the information you need to configure the Server 
Process Properties for each server in “Step 8: Configure the Servers,”  in Chapter 6, 
“Creating the eLink Platform Configuration Files.”  You must configure the Processe
Properties for each server separately. You can make copies of this checklist to g
the information you will need for each specific server.

Table A-16  Server Processes Configuration Checklist

Field Description Default Assigned Value

Minimum # 
of 
Processes

This specifies the minimum number 
of server instances to be 
automatically started when the 
server is booted. The corresponding 
UBB file parameter is MIN.

See Table A-15 See Table A-15

Maximum # 
of 
Processes

This specifies the maximum 
number of server instances that can 
be booted at any given time. The 
corresponding UBB file parameter 
is MAX.

See Table A-15 See Table A-15

Restartable This specifies whether the server is 
restartable. The default is No 
(checkbox unchecked). The 
corresponding UBB file parameter 
is RESTART.

No
(unchecked)

Yes
(checked)

Grow pool 
when queue 
depth over

During runtime, if the number of 
messages is met or exceeded for a 
time set by the Seconds to wait 
before growth parameter , a 
new server is spawned. This is also 
an argument for the -p  option in the 
CLOPT line of the UBB file.

None.
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Seconds to 
wait before 
growth 
parameter

Specifies the time in seconds 
allowed to elapse before the server 
pool is expanded.  This is also an 
argument for the -p  option in the 
CLOPT line of the UBB file.

None.

Shrink pool 
when queue 
depth under

During runtime, if the number of 
messages is below this value by the 
time specified by the Seconds to 
wait before shrinking  
parameter, a server is deactivated.    
This is also an argument for the -p  
option in the CLOPT line of the UBB 
file.

None.

Seconds to 
wait before 
shrinking

Specifies the time in seconds 
allowed to elapse before the server 
pool is reduced. This is also an 
argument for the -p  option in the 
CLOPT line of the UBB file.

None.

Table A-16  Server Processes Configuration Checklist

Field Description Default Assigned Value
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Optional Components Configuration

This section provides a checklist for the information you need to complete
“Step 9: Configure the Optional Components,” in Chapter 6, “Creating the eLink 
Platform Configuration Files.”  

For the Business Process Option, you must add and configure the following 
components:

� WSL

� eLinkJSL

� IREPSVR

WSL Component Configuration

This section provides a checklist for the information you need to configure the W
component for “Step 9: Configure the Optional Components,” in Chapter 6, “Creating 
the eLink Platform Configuration Files.”  

Table A-17  WSL Component Configuration Checklist

Field Description Default Assigned Value

WSL Port 
Number

This specifies the port number for 
the Workstation Listener. Enter a 
port number of 11417. The contents 
of this field are added to the UBB 
file CLOPT parameter contents for 
the WSL server.

6001 11417
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Minimum 
Number of 
Handlers

This specifies the minimum number 
of Workstation handlers, or WSH, 
that are started when the application 
is booted You can accept the default 
for this configuration.  The contents 
of this field are added to the UBB 
file CLOPT parameter contents for 
the WSL Server.

1

Maximum 
Number of 
Handlers

This specifies the maximum 
number of Workstation handlers 
that can be started. You can accept 
the default for this configuration. 
The contents of this field are added 
to the UBB file CLOPT parameter 
contents for the WSL Server.

1

Multiplexi
ng Factor

This specifies the maximum 
number of clients per WSH.  You 
can accept the default for this 
configuration. The contents of this 
field are added to the UBB file 
CLOPT parameter contents for the 
WSL Server.

5

Table A-17  WSL Component Configuration Checklist

Field Description Default Assigned Value
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eLinkJSL Component Configuration

This section provides a checklist for the information you will need to configure th
eLinkJSL component for “Step 9: Configure the Optional Components,” in Chapter 6, 
“Creating the eLink Platform Configuration Files.”  

Table A-18  eLinkJSL Component Configuration Checklist

Field Description Default Assigned Value

eLinkJSL 
Port Number

This is the port number assigned to 
the eLinkJSL . Enter a port number 
of  11400. The contents of this field 
are added to the UBB file CLOPT 
parameter contents for the 
eLinkJSL Server.

7001 11400

Minimum 
Number of 
Handlers

This specifies the minimum number 
of Jolt handlers, or JSH, that are 
started when the application is 
booted. You can accept the default 
for this configuration. The contents 
of this field are added to the UBB 
file CLOPT parameter contents for 
the eLinkJSL Server.

1

Maximum 
Number of 
Handlers

This specifies the maximum 
number of JSH that can be started. 
You can accept the default for this 
configuration. The contents of this 
field are added to the UBB file 
CLOPT parameter contents for the 
eLinkJSL Server.

1
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Multiplexi
ng Factor

This specifies the maximum 
number of clients per JSH. You can 
accept the default for this 
configuration. The contents of this 
field are added to the UBB file 
CLOPT parameter contents for the 
eLinkJSL Server.

5

Table A-18  eLinkJSL Component Configuration Checklist

Field Description Default Assigned Value
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IREPSVR Component Configuration

This section provides a checklist for the information you will need to configure th
IREPSVR component for “Step 9: Configure the Optional Components,” in Chapter 6, 
“Creating the eLink Platform Configuration Files.”  

Table A-19  IREPSVR Component Configuration Checklist

Field Description Default Assigned Value

Read-Only 
Access to 
Repository 
Checkbox

If selected, this specifies read only 
access to the repository file. Make 
sure this is unselected so that there 
is write access to the file. The 
contents of this field are added to 
the UBB file CLOPT parameter 
contents for the IREPSVR.

Read-Only Unselected

Repository 
File

This specifies the location of the 
BEA eLink Platform Repository 
file. An empty repository file exists 
in <$TUXDIR>/udataobj.  

<$TUXDIR>/udataobj
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B Configuration Expert 
Quick Reference Guide

This section provides a quick reference guide to the main windows and navigatio
procedures for the Configuration Expert and Configuration Data Editor utilities. 
Topics include:

� Overview

� Starting the Configuration Data Editor

� Configuration Data Editor Navigation Guide

� Starting the Configuration Expert

� Configuration Expert Navigation Guide

Overview

BEA eLink Platform provides two utilities to assist you in the configuration proce
These are:

� Configuration Expert  — This utility automates the process of creating and 
modifying eLink Platform application configuration files. This utility enables 
you to build and generate Business Process Option configuration files withou
having to manually write and edit these complex files. The Configuration Exp
presents you with a series of screen forms for entering your configuration 
information. After you complete the forms, Configuration Expert generates th
required files and places them in the appropriate locations. 
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You can also use Configuration Expert to run a system startup test, to ensure
your configuration is correct and functional. During the startup process, 
Configuration Expert displays a series of status messages which enable you 
determine whether the startup has been successful, and if unsuccessful, to a
you in determining the source of the problem.

� Configuration Data Editor  — This utility enables you to quickly create and/or 
modify the Data Configuration file for your Business Process Option Server 
machine. The Configuration Expert uses this file to create the configuration 
setup file for generating the BEA eLink Platform configuration files. 

Note: For additional information on using the Configuration Expert and 
Configuration Data Editor, refer to the online document BEA Builder 
Configuration Expert Online Help provided in PDF (Acrobat Reader) forma
with the BEA eLink Platform 1.2 release.

Starting the Configuration Data Editor

The Configuration Data Editor provides a quick and simple method for “creating”
new machine — that is, creating a new data configuration file for a machine, thu
making it accessible and configurable by the Configuration Expert. 

To start the Configuration Data Editor utility, use one of the following commands
depending on the operating system on which the utility is running:

� On a UNIX platform:

cd <TUXDIR>/Config

./ConfigEditor & 

� On a Windows NT platform:

Click Start->Programs->BEA eLink->Configuration Expert Setup.

This displays the Configuration Data Editor startup screen, as illustrated in 

Figure B-1.
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Configuration Data Editor Navigation Guide
Figure B-1   Configuration Data Editor Startup Screen

Configuration Data Editor Navigation Guide

To go to the Configuration Data Editor main window, select File->New. Figure B-2 
illustrates the Configuration Data Editor main window.
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Figure B-2   Configuration Data Editor Main Window (adding a machine)

This window contains the following elements:

� Main Window Menu bar — This contains the following standard elements:

� File — Open, Close, and Save a Data Configuration file.

� Edit — Edit a Data Configuration file.

� Quick Access Buttons — 

� Add — This corresponds to Edit->Add. This adds the current machine 
configuration information to the Machines panel on the left.

� Delete — This corresponds to Edit->Delete. This deletes the selected item
from the Machines panel on the left.

� Modify — This corresponds to Edit->Modify. This updates the configuratio
to reflect any changes made to the machine data.

� Revert — This corresponds to Edit->Revert. This undoes the changes mad
by the last Edit->Modify command.
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� Machines — (panel on left) This displays the list of machines current included
in the Configuration Data file.

� Machine Attributes — (panel on right) This provides several fields for defining 
the machine you want to add to the current Configuration Data file.

For additional information on using the Configuration Data Editor, refer to the onl
document BEA Builder Configuration Expert Online Help provided in PDF (Acrobat 
Reader) format with the BEA eLink Platform 1.2 release.

Starting the Configuration Expert

The executable for starting Configuration Expert resides in the following location

<TUXDIR>/eLink/ConfigExpert/bin

To start Configuration Expert, use on of the following commands, depending on 
operating system on which the utility is running:

� On a UNIX platform:

cd <TUXDIR>/Config

./ConfigExpert &

� On a Windows NT platform:

Click Start->Programs->BEA eLink->Configuration Expert.

This displays the Configuration Expert startup screen as illustrated in Figure B-3.
BEA eLink Business Process Option Configuration GuideB-5



B Configuration Expert Quick Reference Guide

 

ns 
hild 
Figure B-3   Configuration Expert Startup Screen

To go to the Configuration Expert main window, you must either create a new 
configuration setup file or open an existing one. To open an existing file, choose
File->Open and then choose the file from the Open Configuration File window. 

Configuration Expert Navigation Guide

To navigate through the configuration process, you can use the menus and butto
provided in the Configuration Expert main window. All other screens appear as c
windows, leaving the main window available on your screen. Figure B-4 illustrates the 
Configuration Expert Main window.
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Figure B-4   Configuration Expert Main Window

The Configuration Expert main window contains the following elements:

� Main Window Menubar — The main window menubar contains the following 
items:

� File — This menu contains the standard elements, as follows:

New — Create a new configuration file.

Open — Open an existing file.

Close — Close the current file.

Save — Save the current file.

Save As — Save and rename the current file.

Exit — Exit Configuration Expert.

� Edit — This menu contains the following elements:

Properties — Select the item you want to configure, and then select 
Edit->Properties to go to the appropriate configuration screen.
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� Go — This is the main navigation menu, which leads to most of the top-le
configuration screens. This menu contains the following elements:

Next — Go to the next configuration step. This corresponds to the Right 
Arrow button next to the Step status message line.

Machines — Go to the Configure Machines screen, with the General tab 
selected.

Groups — Go to the Configure Groups screen.

Servers — Go to the Configure Servers screen.

Options — Go to the Configure Optional Components screen.

Startup — This provides a submenu, containing the elements Activate 
(perform a system startup for the current application) and Deactivate 
(perform a shutdown for the current application).

� Settings — This provides access to the Configuration Expert settings scree
These screens enable you to specify settings for the Configuration Expert
itself, in terms of how it handles and displays the screens and input 
information.

General — This enables you to specify a Configuration Data file to be used
by the Configuration Expert to create the new configuration.

Objects — This enables you to specify how Configuration Expert should 
handle and configure specific types of objects.

Output — This enables you to specify whether the Configuration Expert 
should generate the scripts for tlisten  and TLOG.

� Quick Access Buttons — The following buttons are provided for quick access to
Menubar commands:

� New — This corresponds to the menubar selection File->New.

� Open — This corresponds to the menubar selection File->Open.

� Close — This corresponds to the menubar selection File->Close.

� Save — This corresponds to the menubar selection File->Save.

� Settings — This corresponds to the menubar selection Settings->General.

� Add — This corresponds to the menubar selection Edit->Add.

� Delete — This corresponds to the menubar selection Edit->Delete.
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� Props — This corresponds to the menubar selection Edit->Properties.

� Available Machines — This panel (on the right side of the main window) 
contains a list of the machines currently available for adding to the current 
configuration. For a machine to be included in this list, you must have created
Data Configuration file for the machine, using the Configuration Expert Data 
Editor.

� Steps to Follow status line and access arrows — This status line indicates which 
configuration step you are currently performing, which in turn indicates which
element contents are currently displayed in the main window. The Step statu
line resides just above the Available Machines panel. To the left of the status
are left and right arrow keys, for navigating forward and backward through th
steps, respectively.

� The Current Application configuration tree — This is a topological map or list 
of the  configuration for the current application. The topology includes the 
application name, the machines, servers and optional components included i
configuration.

Note: For more detailed information on Configuration Expert, refer to the online
document BEA Builder Configuration Expert Online Help provided in PDF 
(Acrobat Reader) format with the BEA eLink Platform 1.2 release.
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C Sample Configuration 
Files

This section provides provides listings of each of the sample Business Process O
configuration files included with this release. Topics in this section include:

� Overview

� eLink_BPO.env

� eLink_BPO.cfg

� env.sh

� IcCliMgr.cfg

� IcRepDaemon.config

Overview

The BEA eLink Business Process Option uses a number of files to configure the
platform environment, and the various client and server components. These files a
follows:

� eLink_BPO.env — This contains the eLink Platform environment variable 
settings. 

� eLink_BPO.cfg — This contains the parameters for configuring the Business 
Process Option servers.
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� env.sh — This is a UNIX shell script that sets the environment variables used
the eLink Platform environment. 

� IcCliMgr.cfg — This contains the parameters for configuring the Business 
Process Engine Client Manager. 

� IcRepDaemon.config — This contains the parameters for configuring the 
Business Process Engine Daemons.

The following configuration files are samples from an installation on an HP-UX 1
machine (supmac1 ) prior to any configuration. The BEA eLink Platform was installe
in the $TUXDIR directory, which on this machine is set to /work1/test/platform . 
The Business Process Engine was installed in the $IC_HOME directory, which is set to 
/work1/test/bpe  on this machine.

eLink_BPO.env

The file eLink_BPO.env  contains the parameters for configuring the Business Proc
Engine. The following listing is a sample eLink_BPO.env  file.

FIELDTBLS32=tuxfield.tbl,eafield.tbl,cmfields.tbl,tuxqfield.tbl,t
padm,irep.f32,jrep.f16,jwsladmin.f32
FLDTBLDIR32=/work1/test/bpe/config:/work1/platform/udataobj
IC_SERVER_NAME=supmac1
IC_HOST_MACHINE=supmac1.beasys.com
IC_STATUS_LOG=/work1/test/bpe/logs/status.log
IC_AUDIT_MODE=IC_EVENT_AUDIT_DATABASE
IC_AUDIT_LOG=NOT_USED
IC_RDBMS=ORACLE
IC_EVENT_POLL_INTERVAL=3600
IC_ACTION_POLL_INTERVAL=60
IC_ACTION_RPC_RETRY_INTERVAL=10800
IC_ACTION_RPC_TIMEOUT=60
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eLink_BPO.cfg

The file eLink_BPO.cfg  file contains the parameters for configuring the Business
Process Option servers. The following listing is a sample eLink_BPO.cfg  file.

# Sample eLink Platform Option configuration file.
# Modify to suit your site's requirements.
# NOTE: the following SERVER key (enclosed in square brackets)
# identifies a particular eLink Agent server program for which
# the following parameters will apply.

[SERVER=eProcStarter]

# NOTE: unlike the above key, the following SERVER parameter
# tells that eLink Agent to which host's Business Process Engine
# it will connect. 

SERVER=systemname
USER=icdba
PASSWORD=icdba

# Comma separated list of ATMI service names used to control which
# process flows will be advertised as services.
# NOTE: ensure that the eProcStarter and eProcRunner
# service lists do not contain any of the same services.

SERVICE_LIST=svcname1,svcname2

# NOTE: the following SERVER key (enclosed in square brackets)
# identifies a particular eLink Agent server program for which
# the following parameters will apply.

[SERVER=eProcRunner]

# NOTE: unlike the above key, the following SERVER parameter
# tells that eLink Agent to which host's Business Process Engine
# it will connect. 

SERVER=systemname
USER=icdba
PASSWORD=icdba

# Comma separated list of ATMI service names used to control which
# process flows will be advertised as services.
# NOTE: ensure that the eProcStarter and eProcRunner
# service lists do not contain any of the same services.
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SERVICE_LIST=svcname3,svcname4

# Specifies, in tenths of seconds, the poll interval
# for checking job completion

POLL_INTERVAL=5

# NOTE: the following SERVER key (enclosed in square brackets)
# identifies a particular eLink Agent server program for which
# the following parameters will apply.

[SERVER=eTaskAgent]

# NOTE: unlike the above key, the following SERVER parameter
# tells that eLink Agent to which host's Business Process Engine
# it will connect. 

SERVER=systemname
USER=icdba
PASSWORD=icdba

# Specifies, in tenths of seconds, the poll interval when scanning
# for ready tasks. 

POLL_INTERVAL=50

# The maximum number of ready tasks to process before forcing the
# server to repeat the ATMI service loop (default is 5).

POLL_COUNT=5
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The env.sh file is a UNIX shell script that sets the environment variables used by
eLink Platform environment. The following listing is a sample env.sh file.

#  E N V . S H
#  InConcert Administrator Environment for SH/KSH/BASH
#  Fri Dec  3 11:55:07 PST 1999
#  Include this file into an sh/ksh/bash environment using
#  the "." command.

LANG="${LANG-C}"
IC_HOME="/work1/test/bpe"
TUXDIR="/work1/test/platform"
PATH="${PATH:+$PATH:}$IC_HOME/bin:$TUXDIR/bin"
NLSPATH="${NLSPATH:+$NLSPATH:}$IC_HOME/data/%L/messages/%N:$IC_HO
ME/data/messages/%N:$IC_HOME/data/C/messages/%N"
SHLIB_PATH="${SHLIB_PATH:+$SHLIB_PATH:}$IC_HOME/lib:$TUXDIR/lib"
IC_CLIENT="${IC_CLIENT-icdba@supmac1}"
FIELDTBLS32="tuxfield.tbl,eafield.tbl,cmfields.tbl,tuxqfield.tbl,
tpadm"
FLDTBLDIR32="$IC_HOME/config:$TUXDIR/udataobj"
WSNADDR="//supmac1.beasys.com:11420"
ORACLE_HOME="/work1/oracle/app/oracle/product/8.0.4"
ORACLE_SID="jose"
PATH="${PATH:+$PATH:}$ORACLE_HOME/bin"
SHLIB_PATH="${SHLIB_PATH:+$SHLIB_PATH:}$ORACLE_HOME/lib"
export LANG IC_HOME TUXDIR PATH NLSPATH SHLIB_PATH IC_CLIENT 
TUXCONFIG FIELDTBLS32 FLDTBLDIR32 WSNADDR ORACLE_HOME ORACLE_SID 
PATH SHLIB_PATH
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IcCliMgr.cfg

The IcCliMgr.cfg  file contains the parameters for configuring the Business Proc
Engine Client Manager. The following listing is a sample IcCliMgr.cfg  file.

#  IcCliMgr.cfg (from template IcCliMgr.cfg.tpl)
#  Each entry is separated by a line consisting of at least two 
#  dashes. Note about secure environments: The programs managed by 
#  the IcCliMgr are TUXEDO clients.  As a result, they have to do 
#  tpinit authentication using the standard authentication 
#  callback.  Since these applications are not interactive, the 
#  IC_TUXEDO_APPLICATION_PASSWORD, IC_TUXEDO_USER_NAME, and 
#  IC_TUXEDO_USER_PASSWORD environment variables will have to be 
#  specified, either in the envfile or directory in the envs 
#  parameter.

#  An entry for the IcEvtSched daemon is mandatory.

NAME=IcEvtSched
DIR=/work1/test/bpe
PROGRAM=tuxapp/IcEvtSched
ENVFILE=/work1/test/bpe/config/IcEnvFile
ARGS: IcEA_eLink

#  The entry for the IcRepDaemon is only required when running 
#  authenticated- mode repositories.  Warning: if run from IcCliMgr 
# it will run as icadmin.
#NAME=IcRepDaemon
#DIR=/work1/test/bpe
#PROGRAM=bin/IcRepDaemon
#ARGS: -climgr
#ENVS: IC_HOME=/work1/test/bpe

#  Complete list of possible keywords, defaults in [].

#ID=number To use a fixed client id (must be unique) [next in 
#seq] NAME=identifierName of client (must be unique). [tail of 
#PROGRAM]

#GROUP=identifierName of client group (non-unique).  [same as NAME]

#DIR=path Directory in which to run the program. [.]

#PROGRAM=path The program to run (REQUIRED).

#ARGS: arglistWhitespace-separated, can be continued by indenting
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# subsequent lines.  Can use '', "", or 
# {} for quoting.  Braces nest. [empty 
# list]

#INPUT=path Standard input to program. [/dev/null]

#OUTPUT=path Standard out of program. [/dev/null]

#ERROR=path Standard error of program. [dup of OUTPUT]

#ENVFILE=path Environment file.  Uses standard IcCliMgr env syntax.

# [none]

#ENVS: envlistWhitespace-separated, can be continued by indenting
# subsequent lines.  Can use '', "", or 
# {} for quoting the value part.  Braces 
# nest. [empty]

#

# The following syntax applies equally to the 
# envlist and the envfile contents.

# VAR=valueset var to value

# VAR:=valueprepend value to var, separated by : if necessary

# VAR=:valueappend value to var, separated by : if necessary

# VAR=-valueset var to value only if not already set

# VAR@ unset var

#  The following are the restart parameters.  They are per-client.  
#  Each client can run multiple concurrent copies if the boot 
#  parameter is greater than one.  Whenever a process dies or the 
#  system is booted, the client manager attempts to start as many
#  copies as necessary until the number running matches the boot 
#  count.  Whenever the system is booted for the first time or a 
#  process dies after a period of successful operation, a grace 
#  period begins.  If a process dies during the grace period, a 
#  retry is attempted up the maximum number of retries and/or the 
#  flux limit is exceeded.  When the flux limit is exceeded, the 
#  client manager will try again when the grace period expires.  If 
#  the process dies outside of the grace period, it is considered
#  a restart rather than a retry.

#NCONC=number Maximum number of concurrent processes. [unlimited]

#MAXST=number Total maximum that can be started. [unlimited]
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#RSTRT=number Total maximum number of restarts. [unlimited]

#RETRY=number Total maximum number of retries. [unlimited]

#GRACE=number Retry grace period, in seconds. [3600]

#BOOT=number Number of processes to boot. [1]

#HIST=number Number of process history entries to keep. [20]

#FLUX=number Number of retries permitted with same grace period. 
[3]
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ss 
IcRepDaemon.config

The IcRepDaemon.config  file contains the parameters for configuring the Busine
Process Engine Daemons. The following listing is a sample  IcRepDaemon.config  
file.

#  IcRepDaemon.config

#  SAMPLE SAMPLE SAMPLE SAMPLE SAMPLE SAMPLE SAMPLE SAMPLE SAMPLE

#  This file must be edited and the various sections uncommented as 

#  needed. Anything in <angle-brackets> should be replaced!

#  Section 1.  REPOSITORY SERVER CONFIGURATION

#  Recommended Items

#  SERVER-PATH

#  PORT

#  The SERVER-PATH should point to the IcRepServer executable, which 

#  usually resides in $IC_HOME/bin.  Defaults to 
#  $IC_HOME/bin/IcRepServer.

#  The PORT line should specify the TCP port number associated with 
#  the repository in the database, as specified in the second half 
#  of the repository 'LOCATION' property.  This item, or the -port 
#  command line switch, must be specified.

SERVER-PATH=/work1/test/bpe/bin/IcRepServer
PORT=9010

#  Optional Items

#  USER-ID

#  The USER-ID line specifies what user IcRepDaemon runs as.  If it 
#  is not running as this user or cannot change to this user, 
#  IcRepDaemon will exit.

USER-ID=inst

#  LOG-FILE
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#  The LOG-FILE entry can be set to a file or the keyword 'SYSLOG'.
#  If 'SYSLOG' is used, then accesses are logged using the syslog 
#  systemlogging facility.  Note that log records of varying 
#  priority are generated, with different verbosity.  If a file is 
#  used, the LOG-LEVEL configuration entry controls how much is 
#  logged.  If SYSLOG is used, then syslog's standard configuration 
#  file (usually /etc/syslog.conf) is used to control how records 
#  are processed.

#  Uncomment only one in each group

LOG-FILE=/work1/test/logs/repserver.log

#LOG-FILE=SYSLOG
#LOG-LEVEL=warng
#LOG-LEVEL=emerg
#LOG-LEVEL=alert
#LOG-LEVEL=critc
#LOG-LEVEL=error
#LOG-LEVEL=warng
#LOG-LEVEL=note
#LOG-LEVEL=info
#LOG-LEVEL=debug

#  Section 2.  REPOSITORY ACCESS PERMISSIONS

#  Optional Repeating Items

#  VALID-DIR

#  Uncomment and repeat for each directory you wish to access.  If 
#  not specified, the IcRepServer can potentially access all files 
#  accessible on the server host.

VALID-DIR=/work1/test/repository

#VALID-DIR=<path-to-rep2>

#  VALID-HOST

#  Uncomment and repeat for each host name, domain name, or host 
#  group. If not specified, any host can request repository server 
#  transfers.

#  Currently, the following forms are supported:

# VALID-HOST=hostnameA specific host name
# VALID-HOST=domain-nameA specific DNS domain name
# VALID-HOST=IP-addressA specific IP address (dotted-quad 
# notation) VALID-HOST=IP-wildcardA group of IP addressed with 
# some quads
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# replaced by '*'

# VALID-HOST=ALLAll hosts on the internet

#VALID-HOST=myhost
#VALID-HOST=MyCompany.COM
#VALID-HOST=10.0.0.51
#VALID-HOST=192.5.105.*
#VALID-HOST=ALL
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