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Introduction and Roadmap

The following sections describe the contents, audience for, and organization of this guide— 
Using the WebLogic RFID Edge Server Administration Console.

“Document Scope and Audience” on page 1-1

“Guide to This Document” on page 1-1

“Related Documentation” on page 1-2

Document Scope and Audience
This document describes how to use the RFID Administration Console to configure ECSpecs, 
ECSpec reports and subscribers, RFID devices, filters, and workflows.

The intended audience is developers, system administrators, operations staff, support engineers, 
and other personnel with an interest in WebLogic RFID Edge Server.

Guide to This Document
This document is organized as follows:

This chapter, “Introduction and Roadmap,” describes the scope of this guide, summarizes 
new features, and lists related documentation.

“Using the Administration Console,” describes how to use the RFID Administration 
Console, monitor Edge Servers, and export and import Edge Server configuration.
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“Working with ECSpecs,” describes how to create, edit, test, and deploy ECSpecs and 
ECSpec subscribers, and how to use the ECSpec Editor.

“Working With ECSpec Reports,” describes how to create ECSpec reports, report filters, 
and report groups.

“Configuring and Monitoring Readers,” describes how to add, remove, and configure 
readers, filters, and composite readers, and how to monitor readers.

Related Documentation
The following BEA documents contain information that is relevant to Using the WebLogic RFID 
Edge Server Administration Console:

Product Overview provides descriptive information about WebLogic RFID Edge Server, 
including use cases, key benefits, component architecture, functional overview, RFID 
concepts and terminology, and developer and RFID resources.

Installing WebLogic RFID Edge Server describes how to install and configure WebLogic 
RFID Edge Server.

Programming with the ALE and ALEPC APIs describes the Application Level Events 
(ALE) and Application Level Events Programming Cycle (ALEPC) programming 
interfaces (APIs) that you use to create applications that interact with WebLogic RFID 
Edge Server by reading and writing electronic product code (EPC) tags.

Using the Reader Simulator describes how to use the reader simulator software included 
with RFID Edge Server. The Reader Simulator minimally simulates a ThingMagic 
Mercury4 RFID reader.

RFID Reader Reference describes how to configure the RFID devices supported by the 
RFID Edge Server.

Workflow Reference describes how to configure and use the workflow modules included 
with the WebLogic RFID Edge Server.

http://e-docs.bea.com/rfid/edge_server/docs23/overview/index.html
http://e-docs.bea.com/rfid/edge_server/docs23/install/index.html
http://e-docs.bea.com/rfid/edge_server/docs23/prog/index.html
http://e-docs.bea.com/rfid/edge_server/docs23/simulator/index.html
http://e-docs.bea.com/rfid/edge_server/docs23/reader_reference/index.html
http://e-docs.bea.com/rfid/edge_server/docs23/workflow_reference/index.html
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Using the Administration Console

The following sections describe how to use the RFID Edge Server Administration Console.

“Administration Console Overview” on page 2-1

“Starting and Stopping the Administration Console” on page 2-2

“Administration Console Menus” on page 2-2

“Exporting and Importing an Edge Server Configuration” on page 2-5

“Monitoring Edge Servers” on page 2-6

Administration Console Overview 
The RFID Edge Server Administration Console is a graphical Java application that you use to:

Monitor the activities of multiple Edge Servers and readers.

See “Monitoring Edge Servers” on page 2-6 and “Monitoring Readers” on page 5-7.

Add, remove, and configure readers and composite readers.

See “Editing Readers” on page 5-3 and “Working with Composite Readers” on page 5-3.

Create, view, and edit ECSpec data objects and their subscribers.

See “Working with ECSpecs” on page 3-1 and “Using the ECSpec Editor” on page 3-8.

View real-time Edge Server and RFID device telemetry data.
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See “Monitoring Edge Servers” on page 2-6 and “Monitoring Readers” on page 5-7.

Dynamically configure RFID devices, filters, and workflows.

See “Editing Readers” on page 5-3, “Working with Transient Filters” on page 5-5, and 
“Configuring Workflow Modules” on page 6-1.

Export and import RFID Edge Server configuration objects.

See “Exporting and Importing an Edge Server Configuration” on page 2-5.

Starting and Stopping the Administration Console
Prerequisite: WebLogic RFID Edge Server must be installed on your system. See Installing 
WebLogic RFID Edge Server.

Starting the Console
Start the RFID Edge Server and the Administration Console with individual scripts in the 
RFID_EDGE_HOME/bin directory, where RFID_EDGE_HOME is the directory where you installed 
the WebLogic RFID Edge Server software. See Starting and Stopping WebLogic RFID Edge 
Server in Installing WebLogic RFID Edge Server.

Stopping the Console
In the Administration Console, select File > Exit.

Administration Console Menus
The Administration Console has the following main menus:

“File Menu” on page 2-2

“View Menu” on page 2-4

“Test Menu” on page 2-4

“Help Menu” on page 2-4

File Menu
Table 2-1 describes the File menu options.

http://e-docs.bea.com/rfid/edge_server/docs23/install/index.html
http://e-docs.bea.com/rfid/edge_server/docs23/install/index.html
http://e-docs.bea.com/rfid/edge_server/docs23/install/postinstall.html#start_stop
http://e-docs.bea.com/rfid/edge_server/docs23/install/postinstall.html#start_stop
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Table 2-1  File Menu Options

Name Description

Configure Edge Servers Adds an Edge Server instance to the Administration Console. For each Edge 
Server, you need to specify:

Edge Server URL: The location of the Edge Server instance. Use the format:

http://host_name:port

where host_name is the host name of the machine where the Edge Server is 
running, and port is the port the Edge Server is listening on (configured when you 
installed the Edge Server).

If you cannot remember the port you configured, you can find it in 
RFID_EDGE_HOME/etc/edge.props:
# The TCP port on which the ALE service listens.

com.connecterra.ale.servicePort = 6060

Preferences AutoRefresh Interval

Specifies how often to contact the Edge Server to update the ECSpec information 
displayed in the Administration Console (in milliseconds).

Default: 2000 (every 2 seconds).

Alert History Length

Specifies how many alerts to store for each device.

Default: 2000

Import Imports a valid XML Edge Server configuration file. See “Importing an Edge 
Server Configuration” on page 2-5.

Export Exports the following Edge Server objects to an XML file:
• RFID Devices
• Composite Readers
• ECSpecs
• ECSpec Subscribers
• PCSpecs
• PCSpec Subscribers
• Workflow Modules

See “Exporting an Edge Server Configuration” on page 2-5.

Exit Quits the application.



Using  the  Admin is t ra t ion  Conso le

2-4 Using the Administration Console

View Menu
Table 2-2 describes the View menu options.

Test Menu
Table 2-3 describes the Help menu options.

Help Menu
Table 2-4 describes the Help menu options.

Table 2-2  View Menu Options

Name Description

Refresh ECSpecs Contacts the Edge Server and retrieves the list of all active ECSpec instances and 
additional information for each. This operation may take some time if there are 
many ECSpec instances with data to be retrieved.

Typically the ECSpec information is automatically refreshed according to the value 
you set for the Auto Refresh Interval in File > Preferences. This option is useful if 
the auto-refresh interval is particularly long, or if you have made a change you want 
to see immediately.

Refresh Device Browser Rebuilds the nodes shown in the left pane of the Console (Device Browser). 

Contacts each of the Edge Servers defined. If a particular Edge Server cannot be 
contacted, then the Device Browser shows the host name and port number (for 
example, localhost:6060) and an error indicator. This operation may take 
some time if there are many Edge Servers to scan, and if some Edge Servers are not 
responding. 

Table 2-3  Test Menu Options

Name Description

Read Tags Displays real-time tag data from the selected Edge Server and any configured 
reader. See “Reading Real-Time Tag Data” on page 5-11.



Expor t ing  and Impor t ing  an  Edge  Se rve r  Conf igurat ion

Using the Administration Console 2-5

Exporting and Importing an Edge Server Configuration
Configuration exporting and importing lets you duplicate RFID Edge Server configurations on 
other Edge Servers. You select Edge Server objects to export to an XML file, and duplicate the 
configuration on another RFID Edge Server by importing that file.

Exporting an Edge Server Configuration
To export an RFID Edge Server configuration:

1. Select File > Export.

2. On the Export Configuration page, from the Server drop-down list, select the Edge Server 
from which to export configuration objects.

3. In the Types section, select the object types to export.

4. To select objects by name, enter the object name in the Names section.

Note: Names are case-sensitive and must match the object name exactly. If there is no 
match, an empty XML file is created.

Note: If you export ECSpec Subscribers and not the ECSpec they reference, you will get an 
error upon importing the ECSpec Subscribers file if the ECSpec does not exist on the 
target Edge Server to which you import the file.

5. Click Export.

6. In the Open dialog window, specify a file name with an XML extension and click Open.

The XML file is saved with the name and location you specified.

Importing an Edge Server Configuration
To import RFID Edge Server configuration:

Table 2-4  Help Menu Options

Name Description

Help Displays a link to the Administration Console Help.

About Displays version and copyright information.
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1. Select File > Import.

2. In the Open dialog window, select a configuration XML file to import and click Open.

3. On the Import Configuration page, from the Server drop-down list, select the target Edge 
Server to which to import configuration objects and click Import.

The configuration file is imported and the configuration objects appear in the Console 
under the selected Edge Server node.

Note: If you import configuration objects with the same name as objects that already exist 
on the Edge Server, the Resolve Import Conflicts page appears. Select which objects 
to replace with imported ones.

Note: When you export all ECSpec Subscribers to an ECSpec, they appear in one XML file 
with the same name as the ECSpec. When you import an ECSpec and its ECSpec 
Subscribers objects, they appear with the same name in the Resolve Import 
Conflicts page. The first one listed is the ECSpec object and the second one is the 
ECSpec Subscribers object.

Monitoring Edge Servers 
Using the Administration Console, you can examine configuration information for and messages 
generated by an Edge Server. Also, you can monitor how many event and programming cycles 
have completed since you started an Edge Server. 

The following sections describe Edge Server monitoring data:

“Displaying Edge Server Telemetry” on page 2-6

“Displaying Edge Server Alerts” on page 2-7

“Displaying Edge Server Attributes” on page 2-8

Displaying Edge Server Telemetry
The Edge Server Telemetry page displays information about the number of event and 
programming cycles that have completed since you started the Edge Server. To display RFID 
Edge Server telemetry: 

1. In the left pane of the Console, select an Edge Server.

2. In the right pane, select Telemetry at the bottom of the page to display the Edge Server 
Telemetry page.
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Note: Collapse telemetry graphs to improve presentation and performance; only the 
expanded (non-collapsed) views are updated.

For more information about event cycles and programming cycles, see Reading and 
Writing Tags in Programming with the ALE and ALEPC APIs.

– Table 2-5 shows when event cycles occurred.

– Table 2-6 shows when programming cycles occurred.

Displaying Edge Server Alerts
To display RFID Edge Server alerts: 

1. In the left pane of the Console, select an Edge Server.

2. In the right pane, select Alerts at the bottom of the page.

The Edge Server Alerts page shows messages and alerts from the Edge Server.

When you select an alert in the top pane, a preview pane opens at the bottom of the page 
that displays the complete text of the alert.

Table 2-5  eventCyclesCompleted

total Total number of event cycles completed since the Edge Server was started.

horizontal axis Time stamps for event cycles, in 24-hour time.

vertical axis Number of event cycles completed within the telemetry interval configured in the Edge 
Server. When the telemetry interval is very short, this value is likely to be either zero 
(no event cycles) or one (one event cycle). If the telemetry interval is longer, larger 
values are displayed when many event cycles are completed within one telemetry 
interval.

Table 2-6  programmingCyclesCompleted

total Total number of programming cycles completed since the Edge Server was started.

horizontal axis Time stamps for programming cycles, in 24-hour time.

vertical axis Number of programming cycles completed within the telemetry interval configured in 
the Edge Server. 

http://e-docs.bea.com/rfid/edge_server/docs23/prog/read_write_tags.html
http://e-docs.bea.com/rfid/edge_server/docs23/prog/read_write_tags.html
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Displaying Edge Server Attributes
To display RFID Edge Server attributes: 

1. In the left pane of the Console, select an Edge Server.

2. In the right pane, select Attributes at the bottom of the page.

The Edge Server Attributes page shows configuration information for this Edge Server.

Table 2-7  Edge Server Alerts

Column Description

Importance • INFO (green)
• WARNING (yellow)
• SEVERE (red)

Date Date and time the log entry was written.

Message Text of the message.

Table 2-8  Edge Server Attributes

Column Description

manufacturer ConnecTerra

version Version of the Edge Server.
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Working with ECSpecs

You use ECSpec data objects to tell the Edge Server what information you want from readers, 
and how you want that reader information reported. 

The following sections describe what you can do with ECSpecs:

“Working with ECSpecs in the Administration Console” on page 3-2

“Displaying ECSpecs” on page 3-2

“Testing ECSpecs Using Activate Once” on page 3-3

“Suspending ECSpecs” on page 3-4

“Unsuspending ECSpecs” on page 3-4

“Deleting ECSpecs” on page 3-4

“Viewing ECSpec Subscribers” on page 3-5

“Creating and Removing Subscribers” on page 3-5

“Editing Subscribers” on page 3-8

“Using the ECSpec Editor” on page 3-8
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Working with ECSpecs in the Administration Console
Although ECSpec objects can be quite complex, the Administration Console provides an easy 
way to create and activate ECSpec objects, view the resulting reports, and modify your ECSpec 
design to meet the needs of the application you are developing.

Using the Administration Console, you can:

Specify what data you want in a given report.

Specify where to deliver the report; for example, an HTTP post to a Web address, to a file 
on your system, or to the Edge Server Console.

Activate an ECSpec once and view the results.

Examine the report to determine whether you are getting the information you want.

Repeat these steps until you are satisfied with the results, then export your ECSpec 
information for programmatic integration into a production system.

The details of ECSpec objects are covered in Programming with the ALE and ALEPC APIs. 

Displaying ECSpecs
To display ECSpecs: 

1. In the left pane of the Console, expand an Edge Server node.

2. Under that Edge Server, select ECSpecs. 

The ECSpecs currently defined for this Edge Server are listed in the ECSpecs pane on the 
upper right. 

Table 3-1 describes the ECSpec status information.

Table 3-1  ECSpec Status Information

Column Description

Name The name of an ECSpec. You assign this name when you create the ECSpec.

Activation Count An ECSpec is “activated” each time the start condition is met. 

This field shows how many times this ECSpec has been activated since its 
creation.

http://e-docs.bea.com/rfid/edge_server/docs23/prog/index.html
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The data for the Name field is taken from the ECSpec object, while the other field data are 
taken from the ECSpecInfo object. For more information on these objects, see Reading 
Tags Using the ALE API in Programming with the ALE and ALEPC APIs.

Using the ECSpecs page, you can:

Add, edit, and view ECSpecs. See “Using the ECSpec Editor” on page 3-8.

Work with ECSpecs, including suspending, unsuspending, testing (via “Activate Once”), 
deleting, and showing subscribers.

Add, remove, and edit subscribers associated with ECSpecs.

Testing ECSpecs Using Activate Once
To generate a test report for an ECSpec:

1. In the left pane of the Console, expand an Edge Server node and select ECSpecs.

2. In the ECSpecs pane, select the ECSpec.

3. Click Activate Once.

A Report window displays the XML ECSpec report data from the Edge Server.

A report appears after the ECSpec has completed one activation (for example, the Start and 
Stop conditions have been met). If the report does not appear quickly, a progress dialog 
appears. You can cancel the report from this dialog, if desired.

Note: Activating an ECSpec turns on any readers used by that ECSpec.

The Report window contains menu options to export the report to a file (File > Export), 
close the window (File > Close), and access Help (Help > EC Report Help).

Last Activated Last time this ECSpec was activated.

Last Reported Last time this ECSpec generated a report. Not every ECSpec activation produces 
a report.

Subscriber Count Number of subscribers associated with this ECSpec. If the ECSpec has been 
suspended, a (Suspended) notation appears next to the number of subscribers.

Table 3-1  ECSpec Status Information (Continued)

Column Description

http://e-docs.bea.com/rfid/edge_server/docs23/prog/read_tags_api.html
http://e-docs.bea.com/rfid/edge_server/docs23/prog/read_tags_api.html
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Suspending ECSpecs
To suspend an ECSpec:

1. In the left pane of the Console, expand an Edge Server node and select ECSpecs.

2. In the ECSpecs pane, select the ECSpec.

3. Click Suspend.

While the ECSpec is suspended, no information is sent to any of the subscribers associated 
with that ECSpec. The Subscriber Count column in the ECSpecs pane displays a 
parenthetical notation if the ECSpec is suspended. 

Note: Suspending an ECSpec may turn off any readers used only by that ECSpec.

Unsuspending ECSpecs
To unsuspend an ECSpec:

1. In the left pane of the Console, expand an Edge Server node and select ECSpecs.

2. In the ECSpecs pane, select the ECSpec.

3. Click Unsuspend. 

The ECSpec resumes sending information to subscribers, and the notation is removed from 
the Subscriber Count column in the ECSpecs pane.

Note: Unsuspending an ECSpec turns on any readers used by that ECSpec when the Start 
condition is met.

Deleting ECSpecs
To delete an ECSpec:

1. In the left pane of the Console, expand an Edge Server node and select ECSpecs.

2. In the ECSpecs pane, select the ECSpec.

3. Click Delete. 

The ECSpec, all its reports, and all subscribers associated with that ECSpec are removed.
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Viewing ECSpec Subscribers
To show subscribers for a given ECSpec:

1. In the left pane of the Console, expand an Edge Server node and select ECSpecs. 

2. In the ECSpecs pane, select the ECSpec.

A list of subscribers (destinations for ECSpec report information) and associated status 
information appears in the bottom Subscribers pane. 

Table 3-2 describes the ECSpec subscriber status information.

The URI field is taken from the ECSubscription object, while the other fields are taken 
from the ECSubscriptionInfo object. For more information on these objects, see Reading 
Tags Using the ALE API in Programming with the ALE and ALEPC APIs.

Creating and Removing Subscribers
To create a new subscriber and associate it with the selected ECSpec:

1. In the left pane of the Console, expand an Edge Server node and select ECSpecs.

2. In the ECSpecs pane, select an ECSpec.

3. In the Subscribers pane, click New. 

4. On the Subscriber page, select a subscriber type from the drop-down list. 

The subscriber type determines what other fields appear on the page. 

5. Fill in a destination for the report information to be sent to this subscriber. 

Table 3-3 describes the report destinations for the various subscriber types.

Table 3-2  ECSpec Subscriber Status Information

Column Description

URI URI for this subscriber.

Last Succeeded Last time the Edge Server succeeded in sending a report to this subscriber.

Consecutive Failures Number of consecutive times the Edge Server failed in its attempts to send 
a report to this subscriber.

http://e-docs.bea.com/rfid/edge_server/docs23/prog/read_tags_api.html
http://e-docs.bea.com/rfid/edge_server/docs23/prog/read_tags_api.html
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6. (JMS only) Fill in values for the JMS subscriber-specific properties shown in Table 3-4.

Note: To configure SAF JMS notifications, see Configuring the Edge Server To Use 
Client-side SAF.

Table 3-3  Subscriber Type Report Destinations

Subscriber Type Destination Prompt Description

XML on Edge 
Server Console

“Heading” Enter a text comment to write the report to the Console in 
XML, preceded by the comment entered in the Heading 
field.

XML via HTTP 
POST

“http://” Enter a URL to which to deliver the report using HTTP 
POST.

Format:
host:port/remainder-of-URL

(The colon and port number may be omitted; the port 
number defaults to 80.)

XML via JMS 
Message

“TOPIC” or “QUEUE” Enter the name of the topic that the JMS notification driver 
will publish to, or the name of the queue that the JMS 
notification driver will add to. The topic or queue entered 
must exist in the JMS server. See Table 3-4 for JMS 
subscriber properties.

XML File on Edge 
Server

“Directory or File” Enter a directory path or file name to which to deliver the 
report by writing to the specified file.

TCP/IP “Host” and “Port” Enter a host name and port number to which to deliver the 
report using a client TCP socket.

Workflow Module “Module” Enter a destination workflow module name to which to 
deliver the report.

Other “URI” Enter a URI to which to deliver the report.

http://e-docs.bea.com/rfid/edge_server/docs23/install/configure.html#config_saf
http://e-docs.bea.com/rfid/edge_server/docs23/install/configure.html#config_saf
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7. Fill in values for the Failure Action section. 

Table 3-4  Subscriber Page (JMS Options)

Name Description

Connection Factory JNDI name of the connection factory (from the JMS server) for obtaining a topic 
connection or a queue connection. 

Use a topic connection factory name when you publish to a topic. Use a queue 
connection factory name when you add to a queue.

Provider URL Optional. URL for the JNDI Naming service.

User Optional. User name used to create a JMS topic or queue connection.

Password Optional. Password used to create a JMS topic or queue connection.

Security Principal Optional. Security principal associated with the JNDI Naming Service.

Authentication Optional. Authentication string associated with the security principal.

Credential Optional. Security credential associated with the security principal.

Naming Service Message 
Properties

Optional. These are added to the javax.naming.Context environment when 
one is constructed, in order to access a naming service to perform the necessary 
JNDI lookups.

Name is the naming service message property name. Names are prefixed with 
jndi:

Value is the string value.

Note: In general, the properties in a naming properties file are considered default 
values, and can be overridden by a notification subscription URI (by 
adding the equivalent property to the notification URI as a query 
parameter). However, when configuring a SAF client, you cannot override 
naming properties by using a notification subscription URI. SAF only 
uses the properties in the naming properties file.

JMS Message Properties Optional. These are added to the javax.jms.TextMessage as String 
properties.

Name is the text message property name.

Value is the string value.
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If the delivery of a report to a subscriber fails on consecutive tries, the Edge Server can 
automatically unsubscribe that subscriber. The Failure Action section defines the 
conditions under which that can occur. You can use the default failure action (Use 
defaults) or override it (Override defaults).

If you chose to override the defaults, specify one or both failure actions by clicking the 
check box next to the action – unsubscribe after N consecutive failures, or unsubscribe 
after N milliseconds of consecutive failures. You also need to enter a reasonable number 
for each action selected.

8. Click Subscribe to save your changes and associate the new subscription with the ECSpec.

To remove a subscriber from an ECSpec:

1. In the ECSpecs pane, select an ECSpec.

2. In the Subscribers pane, select a subscriber. 

3. Click Delete.

Editing Subscribers
To edit a subscriber:

1. In the left pane of the Console, expand an Edge Server node and select ECSpecs. 

2. In the ECSpecs pane, select an ECSpec.

3. In the Subscribers pane, select a subscriber. 

4. Click Edit. 

5. On the Subscriber page, make any desired changes and click Save.

Note: When the new subscriber is saved, the original subscriber is unsubscribed and the 
changed subscriber is saved. If the save fails, the original subscriber remains 
unsubscribed (removed).

Using the ECSpec Editor
Use the ECSpec Editor to:

Add, edit, view, and deploy ECSpecs.

Add and edit ECSpec reports, report filters, report groups, and user memory regions.
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Test an ECSpec.

Import an ECSpec.

Export an ECSpec to an XML file.

Displaying the ECSpec Editor
To display the ECSpec Editor:

1. In the left pane of the Console, expand an Edge Server node and select ECSpecs. 

2. In the ECSpecs pane, select an ECSpec and click Edit.

The ECSpec Editor is displayed with four main menus:

– “File Menu” on page 3-9

– “Tools Menu” on page 3-10

– “View Menu” on page 3-10

– “Help Menu” on page 3-10

File Menu
Table 3-5 describes the ECSpec Editor File menu options.

Table 3-5  File Menu Options

Name Description

Deploy Deploys this ECSpec using the current name (equivalent to redefine in the ALE 
API). This menu item is enabled if you have unsaved changes to a previously 
defined ECSpec.

Deploy As... Deploys this ECSpec using another name. You are prompted for the name. This 
item is equivalent to define in the ALE API.

Revert Resets the ECSpec being edited to the last deployed version, and discards any 
recent changes made using the ECSpec Editor. If you have imported an ECSpec 
and have not yet deployed it, reset the ECSpec being edited to the version you 
imported.

Export Exports this ECSpec to an XML file.

Close Closes the ECSpec Editor.
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Tools Menu
Table 3-6 describes the ECSpec Editor Tools menu options.

View Menu
Table 3-7 describes the ECSpec Editor View menu options.

Help Menu
Table 3-8 describes the ECSpec Editor Help menu options.

Creating and Deploying ECSpecs
Note: You must create at least one ECSpec Report before deploying an ECSpec. See “Creating 

ECSpec Reports” on page 4-1.

To create and deploy an ECSpec:

Table 3-6  Tools Menu Options

Name Description

Test Tests this ECSpec. See “Testing ECSpecs” on page 3-13.

Table 3-7  View Menu Options

Name Description

ECSpec Editor View the ECSpec in the ECSpec Editor. Use the ECSpec Editor to modify and deploy your 
ECSpecs.

As XML View the ECSpec in XML format. Use the ECSpec Editor to make further changes.

As Text View the ECSpec in text format. Use the ECSpec Editor to make further changes.

Table 3-8  Help Menu Options

Name Description

ECSpec Help... Displays a link to the Administration Console Help.
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1. In the left pane of the Console, expand an Edge Server node and select ECSpecs. 

2. In the ECSpecs pane, click New. 

3. In the ECSpec Editor, move one or more logical readers from the Available list to the 
Selected list using the arrows between the lists.

4. Add a Start condition and one or more Stop conditions to the ECSpec, using the controls in 
the Start and Stop sections in the ECSpec Editor. 

When the ECSpec has an active subscriber, the readers specified in the ECSpec start 
reading tags when the start condition is satisfied, and stop reading tags when any of the 
stop conditions are satisfied.

Table 3-9 describes ECSpec start conditions and Table 3-10 describes ECSpec stop 
conditions.

Table 3-9  ECSpec Start Conditions

Start Condition Description

Continuous Start the next event cycle as soon as the previous event cycle ends.

Repeat Period 
(Milliseconds)

Start the next event cycle after a specified amount of time has elapsed from the 
start of the previous event cycle.

Trigger URI Start the event cycle when a trigger is received.

Table 3-10  ECSpec Stop Conditions

Stop Condition Description

Duration (Milliseconds) Stop reading tags after the stated number of milliseconds.

Duration (Read Cycles) Stop reading tags after the stated number of read cycles.

Stable Set Interval 
(Milliseconds)

Stop reading tags after the stated number of milliseconds have elapsed with no 
new tags seen.

Stable Set Interval (Read 
Cycles)

Stop reading tags after the stated number of read cycles have elapsed with no new 
tags seen.
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5. Enter application-specific data in the Application Data field, if any. 

Data entered here is copied to every report generated from this ECSpec.

6. Add at least one report to the ECSpec: select the Reports node in the left pane and click the 
New Report button in the right pane.

See “Creating ECSpec Reports” on page 4-1 for more information.

7. Deploy the finished ECSpec by clicking the Deploy As button on the ECSpec Editor toolbar, 
filling in a name for the ECSpec when prompted, and clicking OK to save your changes. 

You may want to test the ECSpec before deploying. See “Testing ECSpecs” on page 3-13.

Importing ECSpecs
To import an ECSpec:

1. In the left pane of the Console, expand an Edge Server node and select ECSpecs. 

2. In the ECSpecs pane, click Import.

3. Select the ECSpec file to import and click Open.

The ECSpec Editor displays the imported ECSpec. 

4. Edit the ECSpec, if desired, and add, remove, or edit its report information.

5. Deploy the ECSpec by clicking the Deploy As button on the ECSpec Editor toolbar (or by 
selecting File > Deploy As), filling in a name for the ECSpec when prompted, and clicking 
OK. 

You may want to test the ECSpec before deploying. See “Testing ECSpecs” on page 3-13.

Editing ECSpecs
To edit an existing ECSpec:

Minimum Stable Count Stop reading tags after the stated number of tags have been seen and, for each 
report, the stated number of tags are included in that report.

Trigger URI Stop reading tags when a trigger condition is received.

Table 3-10  ECSpec Stop Conditions (Continued)

Stop Condition Description
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1. In the left pane of the Console, expand an Edge Server node and select ECSpecs. 

2. In the ECSpecs pane, select an ECSpec.

3. Click Edit.

The ECSpec Editor displays the ECSpec.

4. Edit the ECSpec, and add, remove or edit reports and filter information.

5. Deploy the finished ECSpec by clicking the Deploy button on the ECSpec Editor toolbar (or 
by selecting File > Deploy) and clicking OK. 

You may want to test the ECSpec before deploying. See “Testing ECSpecs” on page 3-13.

Testing ECSpecs
To test an ECSpec:

1. In the left pane of the Console, expand an Edge Server node and select ECSpecs. 

2. In the ECSpecs pane, select an ECSpec. 

3. Click Edit.

4. Click the Test button on the ECSpec Editor toolbar (or select Tools > Test) to generate a test 
report. 

If the test is successful, a Report window displays XML report data from the Edge Server 
after the ECSpec completes one activation (for example, the Start and Stop conditions are 
met).

If the report does not appear quickly, a progress dialog appears. You can cancel the report 
from this dialog, if desired.

Note: Testing an ECSpec turns on any readers used by that ECSpec.

The Report window contains menu options to export the report to a file (File > Export), 
close the window (File > Close), and access Help (Help > EC Report Help).

Viewing ECSpecs as XML or Text
To view an ECSpec as XML or text:

1. In the left pane of the Console, expand an Edge Server node and select ECSpecs. 

2. In the ECSpecs pane, select an ECSpec.



Work ing  wi th  ECSpecs

3-14 Using the Administration Console

3. Click Edit.

The ECSpec Editor displays the ECSpec.

4. Select View > As XML or View > As Text.

The ECSpec Editor displays the ECSpec in text or XML format.

Exporting ECSpecs
To export an ECSpec to an XML file:

1. In the left pane of the Console, expand an Edge Server node and select ECSpecs. 

1. In the ECSpecs pane, select an ECSpec. 

2. Click Edit. 

The ECSpec Editor displays the ECSpec.

3. Click the Export button on the toolbar (or select File > Export) to export the ECSpec to an 
XML file.

4. Specify a file name and location, and click Save.
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Working With ECSpec Reports

The following sections describe working with ECSpec Reports:

“Creating ECSpec Reports” on page 4-1

“Creating Report Filters” on page 4-4

“Creating Report Groups” on page 4-6

“Specifying User Memory Regions” on page 4-9

Creating ECSpec Reports
Every ECSpec contains specifications for one or more reports. A report is based on the tags that 
were detected by the specified readers during the event cycle. It may have more or less 
information, based on the conditions of the report specification and any report filters or groups 
that have been defined. 

When an event cycle completes, a set of reports for an ECSpec (for example, an ECReports 
object) is generated and can be sent to subscribers or other clients. For more information on 
subscribers, see “Creating and Removing Subscribers” on page 3-5.

Note: An ECSpec must contain at least one report before being deployed.

To create an ECSpec report:

1. In the left pane of the Console, expand an Edge Server node and select ECSpecs. 

2. In the ECSpecs pane, select an ECSpec to which you will add a report.
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3. Click Edit to display the ECSpec Editor.

4. In the ECSpec Editor, expand the Reports node in the left pane. 

The right pane displays a list of report specifications for the current ECSpec.

5. Click New Report. 

The new report is added to the left pane, and the right pane displays the report properties.

Each report you add corresponds to an ECReportSpec object. For more information on this 
object, see Reading Tags Using the ALE API in Programming with the ALE and ALEPC 
APIs.

6. Enter a unique report name.

7. Use the check boxes in the Report Contents section to specify the report contents. 

8. Choose the report set (the set of tags to include in the report) by selecting radio buttons in the 
Report Set section.

Table 4-1  Report Contents

Name Description

EPC List EPCs represented as pure identity URIs according to the EPCglobal Tag Data 
Standards (urn:epc:id:…). A pure identity URI contains just the EPC, with no 
additional information such as tag type, filter bits, and so on. 

Tag List The tag field contains EPCs represented as tag URIs according to the EPCglobal 
Tag Data Standards (urn:epc:tag:…). A tag URI contains all information on the 
tag, including the EPC, tag type, and filter bits (when applicable).

Raw Hexadecimal List Raw tag values represented as raw hexadecimal URIs.

Raw Decimal List Raw tag values represented as raw decimal URIs (urn:epc:raw:…).

Count Total number of EPCs.

http://www.epcglobalinc.org/standards/
http://www.epcglobalinc.org/standards/
http://www.epcglobalinc.org/standards/
http://www.epcglobalinc.org/standards/
http://e-docs.bea.com/rfid/edge_server/docs23/prog/read_tags_api.html
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9. Use the check boxes in the Omit Report section to define the behavior when the report is 
empty. 

If you select the check box labeled If omitted, suppress all ECReports this cycle, the 
existence of this particular report will control whether any reports are sent to subscribers. 
Specifically, if this report is omitted based on one of the other conditions (empty, or 
unchanged from last cycle), no reports will be sent for the current cycle.

10. Enter application-specific data in the Application Data field, if any. 

Data entered here is copied to every report generated from this ECSpec.

11. Add one or more filters to the report, if desired. See “Creating Report Filters” on page 4-4.

The report remains visible in the ECSpec Editor. Changes are saved when you deploy the 
ECSpec. 

12. One ECSpec can contain many reports. To add more reports to the current ECSpec, repeat 
steps 4-11.

13. When you finish adding reports to the ECSpec, deploy it as described in “Creating and 
Deploying ECSpecs” on page 3-10 or “Editing ECSpecs” on page 3-12.

Editing ECSpec Reports
To edit an ECSpec report:

1. Open the ECSpec Editor and select an ECSpec as described in steps 1-3 of “Creating ECSpec 
Reports” on page 4-1.

2. In the left pane of the ECSpec Editor, expand the Reports node to display the reports for the 
selected ECSpec.

3. Select a report. 

Table 4-2  Report Set

Name Description

Current All EPCs read in the current event cycle.

Additions EPC additions from the previous event cycle.

Deletions EPC deletions from the previous event cycle.
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The right pane displays a set of properties for the current report. 

4. Make any desired changes here.

The report remains visible in the ECSpec Editor. Changes are saved when you deploy the 
ECSpec. 

5. To edit more reports, repeat the steps 2 - 4. 

6. Deploy the ECSpec by clicking the Deploy button on the ECSpec Editor toolbar (or selecting 
File > Deploy).

Removing ECSpec Reports
To remove an ECSpec report:

1. Open the ECSpec Editor and select an ECSpec as described in steps 1 - 3 of “Creating ECSpec 
Reports” on page 4-1.

2. In the left pane of the ECSpec Editor, expand the Reports node to display the reports for the 
selected ECSpec.

3. Select a report.

4. Click Delete Report. 

Changes are saved when you deploy the ECSpec.

If you delete all the reports, the ECSpec becomes invalid and cannot be deployed; at least 
one report specification must be given.

Creating Report Filters
Report filters allow you to specify which tags will be included in and excluded from the report. 
You can filter tags based on any fields for the chosen tag format.

If there are any Include filters, tags that match at least one include filter pattern will be included 
in the report (unless they also match an Exclude filter). If there are no Include filters, then tags 
will be included unless they match any Exclude filters.

The Include and Exclude filters together make up an ECFilterSpec object. See Reading Tags 
Using the ALE API in Programming with the ALE and ALEPC APIs.

To add a report filter to an ECSpec report:

http://e-docs.bea.com/rfid/edge_server/docs23/prog/read_tags_api.html#ecfilter_spec
http://e-docs.bea.com/rfid/edge_server/docs23/prog/read_tags_api.html#ecfilter_spec
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1. Open the ECSpec Editor and select an ECSpec as described in steps 1-3 of “Creating ECSpec 
Reports” on page 4-1.

2. In the left pane of the ECSpec Editor, expand the Reports node to display the reports for the 
selected ECSpec.

3. Expand an individual report node. 

Each report node has two filter nodes beneath it (Include and Exclude).

4. Select Include Filters or Exclude Filters to display a list of filters of that type in the right 
pane.

5. Click New Filter. 

The new filter is added to the left pane, and the right pane displays the filter properties.

6. Choose a Tag Format from the drop-down list. For more information on tag formats, see the 
EPCGlobal Tag Data Standards.

7. Fill in the fields for that tag format (the fields shown depend on the format chosen). 

For detailed information, see ECFilterSpec in Programming with the ALE and ALEPC 
APIs.

The filter remains visible in the ECSpec Editor until you choose a different node in the left 
pane. 

8. To add more report filters to the current ECSpec, repeat steps 4 - 7. 

Changes are saved when you deploy the ECSpec.

9. When you finish editing the ECSpec, click the Deploy button on the ECSpec Editor toolbar 
(or select File > Deploy).

Editing Report Filters
To edit a report filter:

1. Open the ECSpec Editor and select an ECSpec as described in steps 1-3 of “Creating ECSpec 
Reports” on page 4-1.

2. In the ECSpec Editor, expand the Reports node in the left pane. 

Each report for this ECSpec is listed beneath the Reports node.

3. Expand an individual report node. 

http://www.epcglobalinc.org/standards/
http://e-docs.bea.com/rfid/edge_server/docs23/prog/read_tags_api.html#ecfilter_spec
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Each report node has two filter nodes beneath it (Include and Exclude).

4. Expand a filter node and select a filter to display the filter properties in the right pane.

5. Edit the fields as desired.

The filter remains visible in the ECSpec Editor until you choose a different node in the left 
pane. 

6. To edit more report filters in the current ECSpec, repeat steps 3 - 5. 

Changes are saved when you deploy the ECSpec. 

Removing Report Filters
To remove a report filter:

1. Open the ECSpec Editor and select an ECSpec as described in steps 1-3 of “Creating ECSpec 
Reports” on page 4-1.

2. In the left pane of the ECSpec Editor, expand the Reports node to display the reports for the 
selected ECSpec.

3. Expand an individual report node. 

Each report node has two filter nodes beneath it (Include and Exclude).

4. Expand a filter node and select a filter to display the filter properties in the right pane.

5. Click Delete Filter. 

Changes are saved when you deploy the ECSpec. 

Creating Report Groups
Report grouping enables you to specify how a set of tag data will be separated into subdivisions 
within a report. You can create a group based on any of the fields for the tag format chosen, and 
define a series of rules that will generate groups within a report. Both list and count data included 
in the report are grouped.

When you create report groups, every tag reported in an event cycle will be part of exactly one 
group. If a tag does not match any pattern URIs in the pattern list, it is included in a special 
"default group." As a special case of the preceding rule, if the pattern list is empty (or if no groups 
are defined), all tags will be part of the default group. See EPC Patterns in Programming with the 
ALE and ALEPC APIs.

http://e-docs.bea.com/rfid/edge_server/docs23/prog/read_tags_api.html#EPC_Patterns
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The report group information (all the groups specified under a Grouping node in the left pane of 
the ECSpec Editor) constitutes an ECGroupSpec object. See Reading Tags Using the ALE API 
in Programming with the ALE and ALEPC APIs.

To add a report group to an ECSpec report:

1. Open the ECSpec Editor and select an ECSpec as described in steps 1-3 of “Creating ECSpec 
Reports” on page 4-1.

2. In the left pane of the ECSpec Editor, expand the Reports node to display the reports for the 
selected ECSpec.

3. Expand an individual report node. 

Each report node has a Grouping node beneath it. 

4. Select the Grouping node to display a list of report groups in the right pane.

5. Click New Group. 

The new group is added to the browser tree, and the right pane displays the group 
properties.

6. Choose a Tag Format from the drop-down list.

7. Fill in the fields for the sections that are displayed beneath the tag format (the sections shown 
depend on the chosen format). For more information on tag formats, see the EPCGlobal Tag 
Data Standards.

Table 4-3 describes grouping behavior you can specify. Fields are inactive when a grouping 
behavior is disallowed for a particular section. 

Table 4-3  Grouping Options

Name Description

Any All values belong to a single group (will appear on a single report).

Group By Create a different group for each distinct value (generate a separate report for each 
value).

Specific Create a group for the value specified (and a default group for all other values). 

Range Create a group for the range of values specified (and a default group for all other 
values).

http://e-docs.bea.com/rfid/edge_server/docs23/prog/read_tags_api.html
http://www.epcglobalinc.org/standards/
http://www.epcglobalinc.org/standards/
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The group remains visible in the ECSpec Editor until you choose a different node in the 
left pane. 

8. To add more report groups to the current ECSpec, repeat the steps 5-7. 

Changes are saved when you deploy the ECSpec. 

Editing Report Groups
To edit a report group:

1. Open the ECSpec Editor and select an ECSpec as described in steps 1-3 of “Creating ECSpec 
Reports” on page 4-1.

2. In the left pane of the ECSpec Editor, expand the Reports node to display the reports for the 
selected ECSpec.

3. Expand an individual report node. 

Each report node has a Grouping node beneath it.

4. Expand the Grouping node and select a group to display the group properties in the right 
pane.

5. Edit the fields as desired.

The group remains visible in the ECSpec Editor until you choose a different node in the 
left pane. 

6. To edit more report groups in the current ECSpec, repeat the steps 4 and 5. 

Changes are saved when you deploy the ECSpec. 

Removing Report Groups
To remove a report group:

1. Open the ECSpec Editor and select an ECSpec as described in steps 1-3 of “Creating ECSpec 
Reports” on page 4-1.

2. In the left pane of the ECSpec Editor, expand the Reports node to display the reports for the 
selected ECSpec.

3. Expand an individual report node. 

Each report node has a Grouping node beneath it.
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4. Expand the Grouping node and select a group.

5. Click Delete Group. 

Changes are saved when you deploy the ECSpec. 

Specifying User Memory Regions
In your report specifications, you can specify a memory location on Gen 2 EPCglobal tags. 

For detailed information on writing and reading Gen 2 tags, see Programming with the ALE and 
ALEPC APIs.

To specify a user memory location:

1. Open the ECSpec Editor and select an ECSpec as described in steps 1-3 of “Creating ECSpec 
Reports” on page 4-1.

2. In the left pane of the ECSpec Editor, expand the Reports node to display the reports for the 
selected ECSpec.

3. Expand an individual report node. 

Each report node has a User Memory Region node beneath it.

4. Select User Memory Region and click New User Memory Region.

5. Specify a user memory region as described in Table 4-4.

Changes are saved when you deploy the ECSpec.

Table 4-4  User Memory Regions

Name Description

URI URI-formatted string representing the contents of the requested memory 
segment. The URI includes a selection for memory bank, an offset within 
the memory bank, and a length of the memory extent, in bits.
urn:connecterra:tagmem:@bankid.length[.offset]

Where bankid is one of three values: epc, tid, or user. Length 
and offset are decimal values in bits. The default value for offset is 
0.

http://e-docs.bea.com/rfid/edge_server/docs23/prog/index.html
http://e-docs.bea.com/rfid/edge_server/docs23/prog/index.html
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EPC Tag EPC value.

Memory Bank Valid values are: epc, tid, or user. 
Length and offset are decimal values in bits. The default value for length 
is 32 and offset (optional) is 0.

Table 4-4  User Memory Regions (Continued)

Name Description
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C H A P T E R 5

Configuring and Monitoring Readers

A reader is a generic term for a hardware device, also referred to as a physical reader, which reads 
EPC values from or writes EPC values to RFID labels (tags). The reader has one or more antennas 
which emit radio waves and receive signals back from the tag.

You configure the RFID Edge Server to communicate with all supported readers as follows: 

Edit the reader configuration information on the RFID Devices page in the Administration 
Console. See “Editing Readers” on page 5-3.

OR

Edit the RFID_EDGE_HOME/etc/edge.props file directly to configure these devices, 
where RFID_EDGE_HOME is the directory in which you installed the RFID Edge Server 
software. For more information about the edge.props file, see Configuring WebLogic 
RFID Edge Server.

Note: These two methods of configuring supported readers are mutually exclusive. You define 
all readers either through the Administration Console or by editing the edge.props file. 
See Two Approaches to Configuring Readers: edge.props or Administration Console in 
Installing WebLogic RFID Edge Server.

The following sections describe how to configure and monitor readers:

“Displaying Readers” on page 5-2

“Creating, Copying, and Removing Readers” on page 5-2

“Editing Readers” on page 5-3

http://e-docs.bea.com/rfid/edge_server/docs23/install/configure.html
http://e-docs.bea.com/rfid/edge_server/docs23/install/configure.html
http://e-docs.bea.com/rfid/edge_server/docs23/install/configure.html#two_config_approaches
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“Working with Composite Readers” on page 5-3

“Working with Transient Filters” on page 5-5

“Monitoring Readers” on page 5-7

“Reading Real-Time Tag Data” on page 5-11

Displaying Readers
To display readers: 

1. In the left pane of the Console, expand an Edge Server node.

2. Select RFID Devices under that Edge Server.

Using the RFID Devices page on the right, you can create, remove, and configure readers 
for the Edge Server you selected. 

Creating, Copying, and Removing Readers
To add a new physical reader to the selected Edge Server:

1. In the left pane of the Console, expand an Edge Server node and select RFID Devices to 
display the RFID Devices page.

2. Click New to display the Create Reader page.

3. Enter a device name (which will appear in the left pane of the Console) and select a Reader 
Type to display reader-specific properties. 

4. Fill in values for the reader-specific properties shown. 

Properties with an asterisk (*) to the right of the field label must be filled in. Refer to the 
RFID Reader Reference and the manufacturer’s manual for your reader for more 
information on these properties and their allowable values.

5. Click OK to save your changes and add the new reader to the Edge Server.

To make a copy of an existing reader:

1. In the left pane of the Console, expand an Edge Server node and select RFID Devices to 
display the RFID Devices page.

http://e-docs.bea.com/rfid/edge_server/docs23/reader_reference/index.html


Edi t ing  Readers

Using the Administration Console 5-3

2. Select a reader from the list on the RFID Devices page.

3. Click Clone. 

The Create Reader page displays the device definition and properties of the reader you 
selected. 

4. Edit the existing device name, and change the values of the device-specific properties as 
needed.

5. Click OK to save your changes and add the reader to the Edge Server.

To delete a reader from the selected Edge Server:

1. In the left pane of the Console, expand an Edge Server node and select RFID Devices to 
display the RFID Devices page.

2. Select a reader from the list on the RFID Devices page.

3. Click Delete. 

4. Confirm that you want to delete this device from the Edge Server.

Editing Readers
To reconfigure an existing reader:

1. In the left pane of the Console, expand an Edge Server node and select RFID Devices to 
display the RFID Devices page.

2. Select a reader from the list on the RFID Devices page.

3. Click Configure. 

The Edit Reader page displays the device name, device type, and properties.

4. Make configuration changes as necessary, and click OK to save the changed reader 
configuration to the Edge Server.

Working with Composite Readers
You create composite readers by combining existing logical readers. Logical readers refer to one 
or more physical readers or antennas that have a single logical purpose; for example, readers 
positioned around a door might be called DockDoor42. Logical readers can be considered 
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equivalent to “locations.” See Comparing Physical Readers and Logical Readers in Installing 
WebLogic RFID Edge Server.

Composite readers provide an easy way to add or remove logical readers when one or more 
ECSpecs have already been defined. For more information on composite readers, see Using 
Composite Readers in Installing WebLogic RFID Edge Server.

Displaying Composite Readers
To display composite readers: 

1. In the left pane of the Console, expand an Edge Server node. 

2. Select Composite Readers.

Use the Composite Readers page to add, remove, and configure Composite Readers.

Creating a Composite Reader
To create a new composite reader for the selected Edge Server:

1. In the left pane of the Console, expand an Edge Server node and select Composite Readers 
to display the Composite Readers page.

2. Click New.

3. On the Create Composite Reader page, enter a reader name (which will appear in the list in 
the readers shown in the Composite Readers page and in the ECSpec Editor), and move one 
or more logical readers from the Available Readers list to the Included Readers list using 
the arrow controls between the lists.

4. Click OK to save your changes and add the new composite reader to the Edge Server.

Copying a Composite Reader
To make a copy of an existing composite reader:

1. In the left pane of the Console, expand an Edge Server node and select Composite Readers 
to display the Composite Readers page.

2. Select a composite reader from the list.

3. Click Clone. 

The Create Composite Reader page displays the reader information.

http://e-docs.bea.com/rfid/edge_server/docs23/install/configure.html#compare_physical_logical
http://e-docs.bea.com/rfid/edge_server/docs23/install/configure.html#using_composite_readers
http://e-docs.bea.com/rfid/edge_server/docs23/install/configure.html#using_composite_readers
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4. Fill in a new composite reader name, and change the included readers as needed.

5. Click OK to save your changes and add the cloned composite reader to the Edge Server.

Deleting a Composite Reader
To delete a composite reader from the selected Edge Server:

1. In the left pane of the Console, expand an Edge Server node and select Composite Readers 
to display the Composite Readers page.

2. Select a composite reader from the list.

3. Click Delete. 

4. Confirm that you want to delete this composite reader from the Edge Server.

Editing a Composite Reader
To reconfigure an existing composite reader:

1. In the left pane of the Console, expand an Edge Server node and select Composite Readers 
to display the Composite Readers page.

2. Select a composite reader from the list.

3. Click Configure. 

The Composite Reader Configuration page displays the reader name and list of included 
readers.

4. Make configuration changes as necessary, and click OK to save the changed composite reader 
configuration to the Edge Server.

Working with Transient Filters
Transient filters allow you to “smooth out” the stream of raw data coming from the reader—filter 
out tags that appear only briefly, keeping those tags that are read several times within a specified 
interval of time. See Smoothing Read Cycles with Transient Filtering in Programming with the 
ALE and ALEPC APIs.

You can apply a transient filter to any reader antenna (for example, a logical reader). Different 
logical readers may share the same filter settings, or have different settings. For more information 
about transient filters, see Adding a Transient Filter in Installing WebLogic RFID Edge Server.

http://e-docs.bea.com/rfid/edge_server/docs23/prog/read_write_tags.html#smoothing_trans_filtering
http://e-docs.bea.com/rfid/edge_server/docs23/install/configure.html#transient_filter
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Creating a Transient Filter
To add a transient filter:

1. In the left pane of the Console, expand an Edge Server node and select Filters.

The Filters page displays the transient filters configured for the selected Edge Server.

2. On the Filters page, click New to display the Create Filters page.

3. Enter a filter name and select Transient Filter from the drop-down list.

For each transient filter you add, define the following required parameters.

4. Click OK.

5. To apply the filter to a logical reader, specify the filter name in the reader configuration 
properties. See “Editing Readers” on page 5-3.

To apply the same filter to more than one logical reader, specify the same filter name for 
more than one reader. Even though more than one logical reader refers to the same filter 
name, each logical reader is processed by a different filter instance.

Copying a Transient Filter
To make a copy of an existing filter:

1. In the left pane of the Console, expand an Edge Server node, and select Filters to display the 
Filters page.

2. Select a filter.

Table 5-1  Transient Filter Properties

Name Description

Minimum Tag Reads The number of times a tag must be read before being included in the filter (visible 
to the event cycle).

Firm Interval The maximum time (in milliseconds) allowed between reads that increase the 
Minimum Tag Reads count.

Expired Interval The maximum duration (in milliseconds) for a tag not to be read before expiring 
from the filter.
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3. Click Clone. 

The Create Filter page displays the filter definition and properties of the filter you 
selected. 

4. Edit the existing filter name, and change the values of the filter properties as needed.

5. Click OK.

Deleting a Transient Filter
To delete a filter:

1. In the left pane of the Console, expand an Edge Server node, and select Filters to display the 
Filters page.

2. Select a filter.

3. Click Delete. 

4. Confirm that you want to delete this filter from the Edge Server.

Editing a Transient Filter
To reconfigure an existing transient filter:

1. In the left pane of the Console, expand an Edge Server node, and select Filters to display the 
Filters page.

2. Select a filter.

3. Click Configure. 

The Edit Filter page displays the device name, device type, and properties.

4. Make configuration changes as necessary. See “Transient Filter Properties” on page 5-6.

5. Click OK to save the changed filter configuration to the Edge Server.

Monitoring Readers
Using the Administration Console, you can monitor how long read cycles are taking, and keep 
track of how many read cycles have occurred since you started the Edge Server. You can see how 
many tags each reader is reading. 
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Also, you can examine configuration information for each reader, and examine the messages and 
warnings that the reader generated. 

“Displaying Reader Telemetry” on page 5-8

“Displaying Reader Alerts” on page 5-10

“Displaying Reader Attributes” on page 5-10

Displaying Reader Telemetry
To display reader telemetry: 

1. In the left pane of the Console, select an Edge Server. 

2. Expand the Edge Server node and the RFID Devices node associated with that Edge Server.

3. In the left pane, select the name of a physical reader.

4. In the right pane, select Telemetry at the bottom of the page.

Telemetry information for each logical reader (antenna) appears. 

Note: Collapse telemetry graphs to improve presentation and performance; only the 
expanded (non-collapsed) views are updated.

– Table 5-2 shows when read cycles occurred.

– Table 5-3 shows how much time each reader is taking for a read cycle (read cycle 
time).

– Table 5-4 shows how many tags this reader read in the field (tags in field).

– Table 5-5 shows when write cycles (programming cycles) occurred.

– Table 5-6 shows how much time each reader or printer is taking for a write cycle (write 
cycle time).

Table 5-2  readCycles

total Total number of read cycles completed since the Edge Server was started.
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horizontal axis Time stamps, in 24-hour time.

vertical axis Shows how many read cycles were completed within the telemetry interval configured 
for the Edge Server. When the telemetry interval is very short (as the default 250ms is), 
this value is likely to be either zero (no read cycles) or one (one read cycle). If the 
telemetry interval is longer, larger values will be displayed when many read cycles are 
completed within one telemetry interval.

Table 5-2  readCycles (Continued)

Table 5-3  readCycleTime

current Value from the most recent read cycle.

horizontal axis Time stamps, in 24-hour time.

vertical axis Minimum and maximum read cycle times, in milliseconds.

Table 5-4  tagsIn Field

current Value from the most recent read cycle.

horizontal axis Time stamps, in 24-hour time.

vertical axis Shows how many tags this reader read during each read cycle.

Table 5-5  writeCycles

total Total number of write cycles (programming cycles) completed since the 
Edge Server was started. A programming cycle is an interval of time during 
which a single tag is written and verified.

horizontal axis Time stamps, in 24-hour time.

vertical axis Shows how many programming cycles were completed within the 
telemetry interval configured in the Edge Server. 
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Displaying Reader Alerts
To display reader alerts: 

1. In the left pane of the Console, select an Edge Server. 

2. Expand the Edge Server node and the RFID Devices node associated with that Edge Server.

3. In the left pane, select the name of a physical reader.

4. In the right pane, select Alerts at the bottom of the page.

The Reader Alerts page shows messages and warnings generated by the reader.

When you select an alert in the top pane, a preview pane opens at the bottom of the page 
displaying the complete text of the alert.

Displaying Reader Attributes
To display reader attributes: 

1. In the left pane of the Console, select an Edge Server. 

Table 5-6  writeCycleTime

current The value from the most recent write cycle.

horizontal axis Time stamps, in 24-hour time.

vertical axis Minimum and maximum write cycle times, in milliseconds.

Table 5-7  Reader Alerts

Column Description

Importance • INFO (green)
• WARNING (yellow)
• SEVERE (red)

Date Date and time the reader generated the message.

Message Text of the message.



Read ing  Rea l -T ime  Tag  Data

Using the Administration Console 5-11

2. Expand the Edge Server node and the RFID Devices node associated with that Edge Server.

3. In the left pane, select the name of a physical reader.

4. In the right pane, select Attributes at the bottom of the page.

The Reader Attributes page shows configuration information for this reader. The reader 
sends this configuration information to the Edge Server.

Reading Real-Time Tag Data
This testing feature reads real-time tag data from any configured logical reader for a selected 
Edge Server and displays the results in the Administration Console.

To read tag data:

1. In the Console, select Test > Read Tags to display the Read Tags page.

2. From the Server drop-down list, select an Edge Server.

3. From the Reader Name drop-down list, select a logical reader name.

Tag data polling on the selected reader starts immediately, displaying the results in the 
Read Tags data table. Table 5-9 describes the Read Tags data.

Table 5-8  Reader Attributes

Column Description

antennaCount Number of antennas this reader has.

hostname Hostname or IP address that the Edge Server is using to communicate with this 
reader.

manufacturer Reader manufacturer.

model Reader model.

tcpPort TCP port that the Edge Server is using to communicate with this reader.
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4. Click Stop to suspend reading tag data.

The values in the Read Tags data table do not update while reads are suspended, and tags 
do not expire from the list. If a read returns an error, reading tag data is suspended.

5. Click Start to continue reading tag data, Clear to reset tag data to zero, or Close.

Table 5-9  Read Tags Data

Column Description

Tag Value Tag format and numerical value of the EPC.

Note: A red X appears to the left of the Tag Value column when a tag has left 
the reader’s field. After five minutes have passed without the reader’s 
detecting a tag, that tag is deleted from the list.

Read Count Number of times the tag has been read (seen by the reader) since the test started.

% Seen Calculated as a percentage of read cycles in which the tag has been detected since 
the tag was first seen. Thus, a tag starts out at 100%, and if the tag is removed from 
the field, its percentage will decrease until the tag entry expires from the list in five 
minutes.

This data is most valuable for measuring intermittent tags.

Last Seen Number of seconds, minutes, and hours since the tag was last seen.

User memory When reading a Gen 2 tag, the first snippet of user memory (32 bits).
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C H A P T E R 6

Configuring Workflow Modules

The following sections describe workflow modules and describe how to configure them through 
the RFID Edge Server Administration Console.

“Overview of RFID Workflow Modules” on page 6-1

“Configuring Workflow Modules” on page 6-2

Overview of RFID Workflow Modules
Workflows coordinate the receipt of RFID data with other kinds of device input and output, and 
use the Electronic Product Code Information Service (EPCIS) interface to communicate to 
enterprise applications. Often, workflow applications interact with users through stack lights, 
LEDs, and Console UIs. A workflow provides business context—it integrates raw RFID data into 
one step of an operational business process.

Workflows are constructed from workflow modules, user-configurable building blocks used to 
create workflows in the WebLogic RFID Edge Server. A module takes input messages (event 
cycle reports or output from other modules), and emits workflow messages according to 
embedded business logic.

To configure workflows, you configure the ECSpec whose reports provide input to the workflow, 
then configure each module used in the workflow. See Configuring and Using Workflows and 
Workflow Module Reference in Workflow Reference.

http://e-docs.bea.com/rfid/edge_server/docs23/workflow_reference/config_use.html
http://e-docs.bea.com/rfid/edge_server/docs23/workflow_reference/reference.html
http://e-docs.bea.com/rfid/edge_server/docs23/workflow_reference/index.html
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Configuring Workflow Modules
This section describes using the Administration Console to configure workflow modules:

1. In the left pane of the Console, expand an Edge Server node.

2. Under that Edge Server, select Workflow Modules.

3. Choose the type of operation to perform:

a. To define a new module, click New.

b. To create a copy of an existing module, select the module and click Clone.

c. To edit an existing module, select the module and click Edit.

d. To delete an existing module, select the module and click Delete.

4. Give the module you are creating a unique Module Name.

5. Choose the Module Type from the drop-down list.

6. Configure the workflow module by filling in values for the fields according to the information 
provided in Workflow Module Reference in Workflow Reference. 

7. Click OK.

http://e-docs.bea.com/rfid/edge_server/docs23/workflow_reference/reference.html
http://e-docs.bea.com/rfid/edge_server/docs23/workflow_reference/index.html
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