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C H A P T E R 1

Tutorial: Building Your First Data 
Transformation

Data transformation is the mapping and conversion of data from one format to another. For 
example, XML data can be transformed from XML data valid to one XML Schema to another 
XML document valid to a different XML Schema. Other examples include the data 
transformation from non-XML data to XML data. This tutorial introduces the basics of building 
a data transformation by describing how to create and test a XML-to-XML data transformation 
using WebLogic Workshop.

In WebLogic Integration business processes, a data transformation transforms data using queries 
(written in the XQuery language). This tutorial describes the steps for building a query in the 
XQuery language—a language defined by the World Wide Web Consortium (W3C) that provides 
a vendor independent language for the query and retrieval of XML data.

To learn about the XQuery language, see the XQuery 1.0: An XML Query Language 
Specification - W3C Working Draft 16 August 2002 at the W3C web site at the following URL:
http://www.w3.org/TR/2002/WD-xquery-20020816

The WebLogic XQuery engine invoked by a business process conforms to the August 16, 2002 
draft of the XQuery Specification.

To learn more about XML and XML Schemas, see Java and XML Basics.

The data transformation created in this tutorial is invoked in the RequestQuote business process. 
This business process is created to meet the business needs of an enterprise. The enterprise starts 
the business process as a result of receiving a Request for Quote from clients, checks the 
enterprise’s inventory and pricing systems to determine whether the order can be filled, and sends 
a quote for the requested items to the client. To learn more about creating business processes and 
the RequestQuote business process, see Tutorial: Building Your First Business Process.

http://www.w3.org/TR/2002/WD-xquery-20020816
http://edocs.bea.com/workshop/docs81/doc/en/workshop/guide/getstarted/navJavaXMLBasics.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/tutorial/tutWLIProcessIntro.html
http://www.w3.org/TR/2002/WD-xquery-20020816
http://www.w3.org/TR/2002/WD-xquery-20020816
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The following figure shows the flow of data in the RequestQuote business process of the Tutorial 
Process application.

The purpose of the RequestQuote business process is to provide price and availability 
information for a set of widgets. The flow of the data through the RequestQuote business process 
is represented by the following steps:

1. The business process receives the set of widget IDs.

2. The business process determines the tax rate for the shipment and puts the result in the 
taxRate float business process variable.

3. The business process gets the price of each of the requested widgets from a source and 
places the resulting XML data into the priceQuote business process variable. (This XML 
data is valid to the XML Schema in the PriceQuote.xsd file.)

4. The business process gets information about availability for the widgets from another 
source and places the resulting XML data into the availQuote business process variable. 
(This XML data is valid to the XML Schema in the AvailQuote.xsd file.)
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5. The business process invokes the Combine Price and Avail Quotes node. The Combine 
Price and Avail Quotes node calls the myJoin Transformation method stored in the 
Transformation file called MyTutorialJoin.dtf file. The business process passes the 
values of the priceQuote, availQuote, and taxRate business process variables to the 
myJoin method. The myJoin method invokes the query written in the XQuery language 
and stored in the myJoin.xq file. The query merges all the price, availability, and tax rate 
information into a single set of XML data and returns the result as the return value of the 
myJoin method. The data returned from this myJoin method is valid to the XML Schema 
in the Quote.xsd file. After the myJoin method is invoked, the Combine Price and Avail 
Quotes node assigns the resulting XML data to the Quote business process variable.

Tutorial Goals
The tutorial provides steps to create and test a transformation using the graphical environment 
provided in WebLogic Workshop. Specifically, in this tutorial you will create the following:

The MyTutorialJoin Transformation file. 

The myJoin Transformation method in the MyTutorialJoin Transformation file.

The query invoked by the myJoin Transformation method. This query is stored in the XQ 
file called myJoin.xq.

Steps in This Tutorial
Follow the steps in this tutorial to create and test a data transformation. Specifically, the steps 
include:

Chapter 2, “Step 1: Getting Started”
Describes how to load the prepackaged Tutorial Process Application.

Chapter 3, “Step 2: Building the Transformation”
Provides a step-by-step procedure to create and select source and target types for a 
Transformation method.

Chapter 4, “Step 3: Mapping Elements and Attributes”
Provides a step-by-step procedure to create mappings between source and target elements 
and attributes in a Transformation method.

Chapter 5, “Step 4: Mapping Repeating Elements—Creating a Join”
Provides a step-by-step procedure to add a join between repeating elements to the 
Transformation method.
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C H A P T E R 2

Step 1: Getting Started

The Business Process and Data Transformation Tutorials both use a prepackaged Tutorial 
Process application. The prepackaged Tutorial: Process Application contains all the business 
process, XML, XML Schema, DTF, and XQ files, required to run the tutorial business processes 
and transformations.

The RequestQuote business process in the Tutorial Process application invokes a transformation 
stored in the TutorialJoin.dtf and join.xq files. The steps in this Tutorial tell you how to 
create the same transformation that is prepackaged in the TutorialJoin.dtf and join.xq files 
of the Tutorial: Process Application. (You can use the transformation in the 
TutorialJoin.dtf and join.xq files as a reference.) You name the Transformation file that 
you build in this tutorial: MyTutorialJoin.dtf and the XQ file that contains the query: 
myJoin.xq.

After completing the steps in this Tutorial, you will change the RequestQuote business process 
to invoke the transformation you created in this tutorial. In addition, you will run the 
RequestQuote business process which will invoke the transformation, as described in Step 12: 
Run the Request Quote Business Process of the Business Process Tutorial.

Note: If you followed the steps described in the Business Process Tutorial, you have already 
created an application and can skip the “To Load The Tutorial Process Application” on 
page 2-2 task. However, you must open the application. To open the application, from 
the WebLogic Workshop menu bar, select File→Open→Application. The Open 
Workshop Application is displayed. Browse for the existing 
Tutorial_Process_Application and click Open.

The tasks in this step include:

http://e-docs.bea.com/workshop/docs81/doc/en/integration/tutorial/tutlogic/tutWLIProcessTest.html
http://e-docs.bea.com/workshop/docs81/doc/en/integration/tutorial/tutlogic/tutWLIProcessTest.html
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To Load The Tutorial Process Application

To Explore the Contents of the Application

To Load The Tutorial Process Application
In this task, you load the prepackaged Tutorial: Process Application.

1. From the BEA WebLogic Workshop menu bar, choose File→New→Application....

The New Application dialog box is displayed.

2. In the left pane, select the Tutorial folder, as shown in the following figure.

3. In the right pane, select Tutorial: Process Application, as shown in the following figure.

4. In the Name field, enter Tutorial_Process_Application.

5. From the Server drop-down menu, select the integration server. For example, if you 
installed WebLogic Platform in the c:\bea directory on Windows, the integration server is 
located at the following path:

c:\bea\weblogic81\samples\domains\integration

6. Click Create.
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Your Tutorial Process application is created and displayed in the Application tab. (If the 
Application tab is not visible in WebLogic Workshop, from the menu bar, choose 
View→Application.)

To Explore the Contents of the Application

1. In the Application tab, expand the Schemas folder. (If the Application tab is not visible, 
from the WebLogic Workshop menu bar, choose View→Application.)

The XML Schema files for this application are displayed.

2. In the Application tab, expand the Tutorial_Process_ApplicationWeb folder.

The directories and files that make up the Tutorial project are displayed.

3. In the Application tab, expand the Tutorial_Process_ApplicationWeb/requestquote 
folder.

The DTF, XQ, and JPD files used in the tutorial are displayed. These files are part of the 
Tutorial project.

The Application tab represents the files and resources available in your business process 
application. It includes the following components:

Tutorial_Process_Application—The application folder.

Schemas—Contains the XML Schemas used in the business process.

Tutorial_Process_ApplicationWeb—The project folder. Every business process 
application contains one or more projects. (Projects represent WebLogic Server Web 
applications. That is, when you create a project, you are creating a Web application. The 
name of your project will be included in the URL your clients use to access your 
application.) 

requestquote—Contains your project files and folders: 

– services folder contains Web services with which your business process interacts.

– testxml folder contains XML files which you can use to test the completed business 
process. 

– RequestQuote.jpd—The completed business process. The Business Process Tutorial 
walks you through rebuilding this business process. In this tutorial, the prebuilt 
RequestQuote business process is used to exercise the transformation stored in the 
TutorialJoin.dtf file.

– DTF files (PriceAvailTransformations.dtf, RequestQuoteTransformations.dtf, 
TutorialJoin.dtf)—Contains the Transformation files used in RequestQuote.jpd.



2-4 Tutorial: Building Your First Data Transformation 

– XQ files—Contains queries (written in the XQuery language) called by the DTF files 
used in RequestQuote.jpd. A Transformation file can have one or more methods, 
each of which is associated to a query in an XQ file.

– FileQuote.jcx—A File control used by your Request for Quote business process to 
write a file to the file system.
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C H A P T E R 3

Step 2: Building the Transformation

In this step, you create a transformation that contains the mapping of different source (input) 
types to a single target (output) type. Specifically, this tutorial provides the steps for transforming 
a Java primitive and two sets of XML data (valid to two different schemas) to a single set of XML 
data valid to a third schema, as shown in the following figure.
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The RequestQuote business process takes as input a set of widget IDs and returns the price and 
availability of these widget IDs.

The source parameters to the myJoin Transformation method include the following:

XML data valid to the PriceQuote.xsd file. The RequestQuote business process of the 
Tutorial Process application builds a piece of XML data that is valid to the 
PriceQuote.xsd XML Schema and stores it in a business process variable called 
priceQuote. This piece of XML data contains a set of widget IDs and their price.

XML data valid to the AvailQuote.xsd file. The RequestQuote business process of the 
Tutorial Process application builds a piece of XML data that is valid to the 
AvailQuote.xsd XML Schema and stores it in a business process variable called 
availQuote. This piece of XML data contains a set of widget IDs, a boolean that 
represents if the widget is available, and the ship date.

A Java primitive of type float called taxRate.
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The myJoin Transformation method takes these source parameters and invokes a query which 
merges the price, availability, and tax rate information into one piece of XML data valid to the 
XML Schema in the Quote.xsd file.

The tasks in this step include:

To Create MyTutorialJoin.dtf

To Add a Transformation method to MyTutorialJoin

To Select the Source Types

To Select the Target Type

To Create MyTutorialJoin.dtf
In this task, you create a Transformation file called MyTutorialJoin.dtf. In addition, you 
create a Transformation method in the Transformation file. During run time, the business process 
will call this method to invoke the transformation.

1. In the Application tab, right-click the requestquote folder and from the drop-down menu, 
select New→Transformation File.

2. The New File dialog box is displayed.

3. In the File name field, enter MyTutorialJoin.dtf.

4. In the New File dialog box, click Create.

In the Design View, a graphical representation of the MyTutorialJoin Transformation file 
appears, as shown in the following figure.

To Add a Transformation method to MyTutorialJoin

1. In the Design View, right-click in the box representing the MyTutorialJoin Transformation 
file. (The box shown in the preceding figure.)

2. From the drop-down menu, select Add Transformation method.
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A Transformation method is created in the MyTutorialJoin Transformation file.

3. Enter myJoin as the method name.

4. Right-click the arrow representing the myJoin method, as shown in the following figure.

5. From the drop-down menu, select Configure XQuery Transformation Method.

The Configure XQuery Transformation Method - myJoin dialog box is displayed. 

The Configure XQuery Transformation Method - myJoin dialog box contains the 
following two panes:

– Available Source Types—From this pane you select the source (input) types for the 
transformation. 

– Available Target Types—From this pane you select a target (output) type for the 
transformation. 

To Select the Source Types
In this task, you select the source types for the transformation in the Configure XQuery 
Transformation Method - myJoin dialog box. Source types are the input data types for the 
transformation—the data types that are transformed to the target data type.

1. In the Available Source Types pane of the Configure XQuery Transformation Method - 
myJoin dialog box, the application XSD files: PriceQuote.xsd, AvailQuote.xsd, 
Quote.xsd, and QuoteRequest.xsd are displayed, as shown in following figure.
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Note: If these files are not listed, you probably have not loaded the Tutorial: Process 
Application. For instructions on loading this application, see “To Load The Tutorial 
Process Application” on page 2-2.

2. In the Available Source Types pane, expand PriceQuote.xsd folder, then select the 
priceQuote element, as shown in the following figure.

3. Click Add.

The elements and attributes that make up the priceQuote element are displayed in the 
Selected Source Types pane.
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4. In the Available Source Types pane, expand AvailQuote.xsd folder, then select the 
availQuote element.

5. Click Add.

The elements and attributes that make up the availQuote element are displayed in the 
Selected Source Types pane.

6. In the Available Source Types pane, select the Java option. 

The available Java Types are displayed in the Available Source Types pane.

7. In the Available Source Types pane, select the float node, as shown in the following 
figure.

8. In the Name field of the Available Source Types pane, change the name of the Java source 
variable from floatVar to taxRate as shown in the following figure.
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Note: The taxRate mapper variable created in the presiding step is different from the 
taxRate business process variable of the RequestQuote business process. The 
variables created in the mapper are used in transformations and not in business 
processes.

9. Click Add.

To Select the Target Type
In this task, you select a target type for the transformation in the Configure XQuery 
Transformation Method -myJoin dialog box.

1. In the Available Target Types pane of the Configure XQuery Transformation Method - 
myJoin dialog box, the PriceQuote.xsd, AvailQuote.xsd, Quote.xsd, and 
QuoteRequest.xsd files are listed.

2. In the Available Target Types pane, expand Quote.xsd folder, then select the quote 
element, as shown in the following figure.
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3. Click Add.

The elements and attributes that make up the quote element are displayed in the Selected 
Target Types pane.

4. Click Create Transformation.

The file: myJoin.xq is created and displayed in the Design View.

The myJoin Transformation method is added to the MyTutorialJoin Transformation file. 
The myJoin method contains the three source parameters selected in the previous steps.

In the Application tab, representations of the MyTutorialJoin.dtf and myJoin.xq files are 
displayed as shown in the following figure.

Note: In the Application tab, the myJoin.xq appears indented under the 
MyTutorialJoin.dtf. These files are associated and contain references to each other. 
To learn more, see The Association Between XQ and DTF Files.

http://edocs.bea.com/workshop/docs81/doc/en/integration/dtguide/dtguidemapperxqanddtf.html
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5. Save the MyTutorialJoin.dtf file. Right-click the MyTutorialJoin.dtf file, then in the 
drop-down menu, select Save.
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C H A P T E R 4

Step 3: Mapping Elements and 
Attributes

In this step, you map source nodes to target nodes. The following figure shows the mapping of 
example XML data. 

Figure 4-1  Mapping Example

In the preceding figure, the source XML data has a different format than the target XML data. 
When building a query invoked by a Transformation method, you map the source nodes to target 
nodes as represented by the arrows. During run time, the transformation uses the mappings to 
convert the data from the source format to the target format. For example, the arrow labeled 1 
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represents the transformation of the priceQuote/customerName element to the quote/name 
element.

The mapping of the address data, is a more complex transformation, as represented by the arrow 
labeled 2 in the preceding figure. To transform the address information, all the attributes of the 
shipAddress element (street, city, state, and zip) must be converted to a single string 
XML element called address.

The source XML data is valid to a different XML Schema than the target XML data. As shown 
in the preceding figure, the example source XML document called PriceQuote.xml is valid to 
the XML Schema in the PriceQuote.xsd file. Additionally, the example source XML document 
called Quote.xml is valid to the XML Schema in the Quote.xsd file.

The PriceQuote.xml, AvailQuote.xml, QuoteRequest.xml, QuoteRequest_a.xml, and 
Quote.xml files are located in the 
Tutorial_Process_ApplicationWeb/requestquote/testxml directory of the application.

Note: The preceding figure shows just one source data type (priceQuote). This is just one of 
the three sources to the myJoin method as described in “Step 2: Building the 
Transformation” on page 3-1. In this step, the mappings between the XML Schema in the 
PriceQuote.xsd file to the XML Schema in the Quote.xsd file are discussed. In the 
“Step 4: Mapping Repeating Elements—Creating a Join” on page 5-1, mappings 
between the other source types (AvailQuote.xsd and taxRate) are discussed.

Note: The PriceQuote.xml, AvailQuote.xml, QuoteRequest_a.xml, 
QuoteRequest.xml, and Quote.xml files are provided as examples and are not used by 
the business process during run time. During run time, the business process constructs 
the source XML data, and passes it to the transformation as described in the Introduction 
of this tutorial.

Complete the following tasks to create, alter, and test mappings between the source and target 
data:

To Map a Node From a Source to a Target

To Map Attributes of an Element to Single Element

To View and Save the Generated Simple Query

To Test the Simple Query

To Edit and Retest the Simple Query

To Add an XQuery Function Call to the Query
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To Map a Node From a Source to a Target
In this step, you map the XML string element called customerName from the source 
(PriceQuote.xsd) to the XML string element called name in target (Quote.xsd).

1. View myJoin.xq in the Design View:

a. If the Application tab is not visible in WebLogic Workshop, from the menu bar choose 
View→Application. 

b. In the Application tab, double-click 
Tutorial_Process_Application\Tutorial_Process_ApplicationWeb\

requestquote\MyTutorialJoin.dtf\myJoin.xq, then, if necessary, select the 
Design View tab.

The Design View displays the a graphical representation of the selected sources in the 
Source pane, as shown in the following figure.

Note: If the priceQuoteDoc, availQuoteDoc, and taxRate nodes are not displayed in your 
Source pane, follow the instructions in “To Select the Source Types” on page 3-4.

The nodes displayed in the Source pane correspond to source parameters of the myJoin 
method of the MyTutorialJoin Transformation file. The signature of the myJoin method 
from the MyTutorialJoin.dtf file is shown in the following Java code segment:
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/**
 * @dtf:transform xquery-ref="myJoin.xq"
 * @dtf:schema-validate return-value="false" parameters="false"
 */
public abstract org.example.quote.QuoteDocument 
myJoin(org.example.price.PriceQuoteDocument priceQuoteDoc, 
org.example.avail.AvailQuoteDocument availQuoteDoc, float taxRate);

For example, the priceQuoteDoc node displayed in the Source pane, corresponds to the 
org.example.price.PriceQuoteDocument priceQuoteDoc parameter in the myJoin 
method.

Note: You can view the full source code listing of the MyTutorialJoin Transformation file 
by double-clicking MyTutorialJoin.dtf in the Application tab, then selecting the 
Source View tab.

2. From the Source pane of the myJoin XQ file, drag-and-drop the 
priceQuoteDoc/customerName node onto the quote/name node in the Target pane.

A solid line appears between the two elements. This solid line represents a data link 
between the two nodes—a link that converts the value of the source node directly to the 
value of the target node. This link is shown in the following figure.

This link corresponds to the mapping represented with an arrow (labeled with the number 
1) in Figure 4-1.

To Map Attributes of an Element to Single Element
In this step, you will map multiple attributes of one element to another single element. 

The XML priceQuoteDoc/shipAddress element contains the following attributes:

street

city

state

zip

All these attributes will be mapped to the single XML quote/address element of type string. This 
mapping is represented by the arrow labeled 2 in Figure 4-1. 
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Link the multiple shipAddress attributes from the Source pane to the Target pane with a single 
drag-and-drop operation, as described in the following procedure:

1. In the Source pane, select the street attribute of priceQuoteDoc/shipAddress node.

2. In the Source pane, press Shift while selecting the zip attribute of the 
priceQuoteDoc/shipAddress node.

The street, city, state, and zip attributes are selected. The street, city, and state attributes 
are shaded in gray and the zip attribute is shaded in blue as shown in the following figure.

Note: You can also use the Ctrl key to select groups of nodes. 

3. Drag-and-drop the attributes from the Source pane to the quote/address node in the Target 
pane.

Four new links are displayed, as shown in the following figure.

Figure 4-2  Create Links

The links labeled with numbers in the preceding figure, correspond to the mappings 
represented as arrows (labeled with numbers) in Figure 4-1.

To View and Save the Generated Simple Query
A query (in the XQuery language) is generated when you create mapping links from source 
elements and attributes to target elements and attributes.

1. Select the Source View tab of the myJoin.xq file.
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The generated query is displayed as shown in the following figure.

Note: The XQuery code labeled with numbers in the preceding figure correspond to the 
numbered mappings and links in Figure 4-1 and Figure 4-2, respectively.

2. Save all the files in this application. From the WebLogic Workshop menu bar, choose 
File→Save All. You can also save all the files by entering Ctrl+S. 

Note: Pressing Ctrl+S saves all the files in the application, not just the current file.

To Test the Simple Query
This section describes the steps necessary to test the query generated in the preceding section. In 
this section, you will enter source XML data, run that data against the query, and view the 
resulting target XML data.

1. Select the Test View tab of myJoin.xq file.

2. Import PriceQuote.xml as source data for the transformation:

a. From the drop-down menu in the Source Data pane, select $priceQuoteDoc.

b. Click Import... .

The Open File to Test dialog box is displayed.

c. Double-click the requestquote folder.

d. Double-click the testxml folder.

e. Click the PriceQuote.xml file.

f. Click Open.

A graphical representation of the PriceQuote.xml file appears in the Source Data pane.

3. In the Result Data pane, click Test.
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Note: In order for a query to run, the WebLogic Server for the current application must be 
running. If not currently running, the WebLogic Server for the current application will 
be started.

The source XML data in one format is transformed by the query to XML in the target 
format and graphically displayed in the Result Data pane, as shown in the following 
figure.

The preceding figure shows a graphical representation of the resulting XML data.

To learn more about the transformation occurring in the query including a walk through of 
the generated XQuery code, see Understanding the Transformation.

4. To view the resulting data as an XML document, in the Result Data pane, select the XML 
Source View tab.

The following XML data is displayed:

<?xml version="1.0" encoding="UTF-8"?>
<quot:quote xmlns:quot="http://www.example.org/quote">

<name>Acme Inc</name>
<address>12 Springs RdMorris Plainsnj07960</address>

</quot:quote>

Note: In the preceding XML document, the string: quot is the namespace prefix for the 
following namespace URI: xmlns:quot="http://www.example.org/quote". To 
learn more about namespace declarations and how this XML data was generated, see   
Understanding the Transformation.

To Edit and Retest the Simple Query
This section provides the steps for editing the generated query to add a delimiter between the 
street, city, state, and zip code fields of the address element.

1. Select the Design View tab of myJoin.xq file.

http://edocs.bea.com/workshop/docs81/doc/en/integration/dttutorial/tutWLIDataTransExtraTrans.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/dttutorial/tutWLIDataTransExtraTrans.html
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2. Select the link between the zip attribute of the priceQuoteDoc/shipAddress node and the 
quote/address node.

In the General Expression pane of the Target Expression tab, the XQuery code between 
the nodes is displayed. (If the Target Expression tab is not visible, from the WebLogic 
Workshop menu bar, choose View→Windows→Target Expression tab.)

3. In the General Expression pane of the Target Expression tab, add the argument: ",", 
between the address attribute parameters of the concat function to delineate between the 
different address fields, as shown in the following listing:

concat($priceQuoteDoc/ns0:shipAddress/@street,",",
$priceQuoteDoc/ns0:shipAddress/@city,",",
$priceQuoteDoc/ns0:shipAddress/@state,",",
$priceQuoteDoc/ns0:shipAddress/@zip)

4. Click Apply.

The updated map is displayed as shown in the following figure.

In the proceeding step, you modified the links between shipAddress attributes and the 
address element in the query, which causes these links to change from direct data links 
(represented as blue lines) to implied links (represented as light gray lines) as show in the 
following figure. The mapper parses the XQuery code and determines that there are 
implied links between the target and source elements. 

5. Select the Test View tab of myJoin.xq file and in the Result Data pane click Test.

In the Result Data pane, the resulting XML data is displayed.

The street, city, state, and zip code fields of the address element will be delineated by a 
commas, as shown in the following listing:

<address>12 Springs Rd,Morris Plains,nj,07960</address>
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To Add an XQuery Function Call to the Query
This section provides steps for converting the state field to uppercase by calling a standard W3C 
XQuery function from the query.

1. Select the Design View tab of myJoin.xq file.

2. Select the link between the state attribute of the shipAddress element and the 
quote/address element. 

In the Source pane, the state attribute becomes shaded in green. 

In the General Expression pane of the Target Expression tab, the call to the concat 
function is selected, as shown in the following figure.

3. In the General Expression pane, find the following text:

$priceQuoteDoc/ns0:shipAddress/@state

4. In the Palette, expand the String Functions folder. (If the Palette is not visible, from the 
WebLogic Workshop menu bar, choose View→Windows→Palette.)

5. In the Palette, select the upper-case function, and drag-and-drop it over the 
$priceQuoteDoc/ns0:shipAddress/@state attribute in the General Expression pane.

The following is displayed in the General Expression pane, as shown in the following 
figure.

Leave $string-var selected in the General Expression pane as shown in the preceding 
figure. 
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6. In the Source pane, select the priceQuoteDoc/shipAddress/state node and drag-and-drop 
it over the $string-var parameter of the General Expression pane.

In General Expression pane the following is displayed, as shown in the following figure.

7. Click Apply.

8. Select the Test View tab.

9. Click Test.

In the XML Source View tab of the Result Data pane, the state is displayed in uppercase 
characters, as shown in the following listing:

<address>12 Springs Rd,Morris Plains,NJ,07960</address>
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C H A P T E R 5

Step 4: Mapping Repeating 
Elements—Creating a Join

In this step, you will add additional mappings to the existing query. In the previous sections, you 
mapped some data from the source type defined by the PriceQuote.xsd XML Schema to the 
target type defined by the Quote.xsd XML Schema. In this section, you will map additional data 
from the source types (defined by the PriceQuote.xsd XML Schema, the AvailQuote.xsd 
XML Schema, and the Java float primitive: taxRate) to the target type (defined by the 
Quote.xsd XML Schema) as shown in the following figure.

Mappings created in this section will create a join between repeating elements in the source and 
target XML Schemas. Complete the following tasks to create, test, and alter the join:
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Create a User-Defined Java Method to Invoke From the Join Query

To Join Two Sets of Repeating Elements

Add Links to Populate the quoteResponse Element

Call the calculateTotalPrice User Method From the Query

To View the Generated Query

To Test the Query

Create an Instance of the MyTutorialJoin Control

Edit the Node That Invokes the Transformation

To Run the Business Process

Create a User-Defined Java Method to Invoke From the Join Query
In this task, you will create a user-defined Java method in the MyTutorialJoin Transformation 
file that calculates the total price of the widgets requested including tax. In “Call the 
calculateTotalPrice User Method From the Query” on page 5-9, you will change the query to 
invoke this method.

1. View MyTutorialJoin.dtf in the Design View:

a. If the Application tab is not visible in WebLogic Workshop, from the menu bar, choose 
View→Application. 

b. In the Application tab, double-click 
Tutorial_Process_Application\Tutorial_Process_ApplicationWeb\request

quote\MyTutorialJoin.dtf and select the Design View tab.

The graphical representation of the MyTutorialJoin Transformation file is displayed, 
as shown in the following figure:
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2. Right-click in the box representing the MyTutorialJoin Transformation file. (The box 
shown in the preceding figure.)

3. From the drop-down menu, select Add User Method.

A User method is created in the MyTutorialJoin Transformation file.

4. Enter calculateTotalPrice as the method name.

The methods that make up the MyTutorialJoin Transformation file are displayed, as 
shown in the following figure.

5. Right-click the arrow representing the calculateTotalPrice method.

6. From the drop-down menu, select Edit in source view.

7. In Source View, edit the MyTutorialJoin Transformation file and replace the following 
generated calculateTotalPrice Java method:

public String calculateTotalPrice()
{

return ““;
}

With the following calculateTotalPrice Java method:

public float calculateTotalPrice(float taxRate, int quantity, float 
price, boolean fillOrder)
{

float totalTax, costNoTax, totalCost;
if (fillOrder)
{

// Calculate the total tax
totalTax = taxRate * quantity * price;
// Calculate the total cost without tax
costNoTax = quantity * price;
// Add the tax and the cost to get the total cost
totalCost = totalTax + costNoTax;

}
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else
{

totalCost = 0;
}
return totalCost;

}

Warning:Make sure you change the return type of the calculateTotalPrice function 
from String to float.

8. Save all the files in this application. From the WebLogic Workshop menu bar, choose 
File→Save All.

To Join Two Sets of Repeating Elements

1. View myJoin.xq in the Design View:

a. If the Application tab is not visible in WebLogic Workshop, from the menu bar, choose 
View→Application. 

b. In the Application tab, double-click 
Tutorial_Process_Application\Tutorial_Process_ApplicationWeb\request

quote\MyTutorialJoin.dtf\myJoin.xq and select the Design View tab.

2. In the Source pane, collapse the shipAddress node.

3. From the Source pane, drag-and-drop the priceQuoteDoc\priceRequests\priceRequest 
node onto the quote\quoteResponse node in the Target pane.

These nodes are both repeating nodes. A repeating node means more than one instance of 
this node can be specified. The + symbol to the right of the node indicates these nodes are 
repeating nodes.

Warning: You must select the priceRequest node and not the priceRequests node. 

A dashed line linking the two repeating nodes is displayed, as shown in the following 
figure. 

The dashed line with short dashes represents a structural link—a link between two parent 
structures that does not map data directly.

To learn more about XML repeating nodes, see “Understanding XML Repeating Nodes” 
on page 6-4.

4. From the Source pane, drag-and-drop the availQuoteDoc\availRequest node onto the 
quote\quoteResponse node in the Target pane.
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A dashed line linking the two repeating elements is displayed, as shown in the following 
figure.

5. Select the Source View tab to view the changes to the query.

6. Expand prolog.

The following query is displayed in the Source View:

{-- requestquote/MyTutorialJoin.dtf#myJoin --}
declare namespace ns0 = "http://www.example.org/price"
declare namespace ns1 = "http://www.example.org/avail"
declare namespace ns2 = "http://www.example.org/quote"
<ns2:quote>

<name>{ data($priceQuoteDoc/ns0:customerName) }</name>
<address>{ concat($priceQuoteDoc/ns0:shipAddress/@street , ",",

$priceQuoteDoc/ns0:shipAddress/@city ,",",
xf:upper-case($priceQuoteDoc/ns0:shipAddress/@state) , ",",
$priceQuoteDoc/ns0:shipAddress/@zip) }</address>

{
for $priceRequest in 

$priceQuoteDoc/ns0:priceRequests/ns0:priceRequest,
$availRequest in $availQuoteDoc/ns1:availRequest

return
<quoteResponse/>

}
</ns2:quote>
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In the preceding query, there are no data links between the children of the repeating nodes, 
so the quoteResponse element is empty. (The string: <quoteResponse/> is an empty 
node.)

The structural links between the repeating nodes generates the for loop which is shown in 
bold in the preceding query listing. This XQuery for loop iterates through the set of 
priceRequest and availReqest repeating elements. For example, if the source XML 
data to this query contains three instances of the priceRequest element and three 
instances of the availRequest element, the for loop would execute a total of nine times 
with the following combinations:

– The first instance of the priceRequest element with the first instance of 
availRequest element.

– The first instance of the priceRequest element with the second instance of 
availRequest element.

– The first instance of the priceRequest element with the third instance of 
availRequest element.

– The second instance of the priceRequest element with the first instance of 
availRequest element.

– The second instance of the priceRequest element with the second instance of 
availRequest element.

– The second instance of the priceRequest element with the third instance of 
availRequest element.

– The third instance of the priceRequest element with the first instance of 
availRequest element.

– The third instance of the priceRequest element with the second instance of 
availRequest element.

– The third instance of the priceRequest element with the third instance of 
availRequest element.

For some transformations, you may want the query to generate all the possible 
combinations but for others, you may want to constrain the combinations as described in 
the following steps.

7. Select the Design View tab.

8. In the Source pane, drag-and-drop the 
priceQuoteDoc/priceRequests/priceRequest/widgetId node onto the target 
availQuote/availRequest/widgetId node.
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Note: Both of these elements are in the Source pane.

A line between the two widgetId nodes is displayed, as shown in the following figure.

9. View the changes to the query by clicking the Source View tab.

The following query is displayed in the Source View:

{-- requestquote/MyTutorialJoin.dtf#myJoin --}
declare namespace ns0 = "http://www.example.org/price"
declare namespace ns1 = "http://www.example.org/avail"
declare namespace ns2 = "http://www.example.org/quote"
<ns2:quote>

<name>{ data($priceQuoteDoc/ns0:customerName) }</name>
<address>{ concat($priceQuoteDoc/ns0:shipAddress/@street , ",",

$priceQuoteDoc/ns0:shipAddress/@city , ",",
xf:upper-case($priceQuoteDoc/ns0:shipAddress/@state) , ",",
$priceQuoteDoc/ns0:shipAddress/@zip) }</address>

{
for $priceRequest in 

$priceQuoteDoc/ns0:priceRequests/ns0:priceRequest,
$availRequest in $availQuoteDoc/ns1:availRequest

where data($priceRequest/ns0:widgetId) = 
data($availRequest/ns1:widgetId)

return
<quoteResponse/>

}
</ns2:quote>
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The link between the widgetId nodes generates the where clause in the for loop, as 
shown in bold in the preceding query listing. This where clause constrains or limits the 
output of the for loop. Specifically, the where clause specifies that if the expression in the 
where clause is true, the for loop will output the contents of the return. For this 
example, if the widgetId of the availRequest element is equal to the widgetId of the 
priceQuest element, the following XML data is returned: 

<quoteResponse/>

An empty quoteReponse element isn’t very useful. In the following task: “Add Links to 
Populate the quoteResponse Element” on page 5-8, you will add data links that will 
populate the quoteResponse element.

Add Links to Populate the quoteResponse Element

1. Select the Design View tab.

2. From the Source pane, drag-and-drop the 
priceQuoteDoc/priceRequests/priceRequest/widgetId node onto the 
quote/quoteResponse/widgetId node in the Target pane.

3. From the Source pane, drag-and-drop the 
priceQuoteDoc/priceRequests/priceRequest/price node onto the 
quote/quoteResponse/unitPrice node in the Target pane.

4. From the Source pane, drag-and-drop the 
availQuoteDoc/availRequest/requestedQuantity node onto the 
quote/quoteResponse/requestedQuantity node in the Target pane.

5. From the Source pane, drag-and-drop the availQuoteDoc/availRequest/quantityAvail 
node onto the quote/quoteResponse/fillOrder node in the Target pane.

6. From the Source pane, drag-and-drop the availQuoteDoc/availRequest/shipDate node 
onto the quote/quoteResponse/shipDate node in the Target pane.

7. From the Source pane, drag-and-drop the taxRate Java primitive onto the 
quote/quoteResponse/taxRate node in the Target pane.

8. From the Source pane, drag-and-drop the taxRate Java primitive onto the 
quote/quoteRespons/totalCost node in the Target pane.

Note: In the next section, to calculate the total cost of the order, you will edit the link 
between the taxRate Java primitive and the quote/quoteResponse/totalCost node.

In the Design View, the following links are displayed, as shown in the following figure.
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9. Save all the files in this application. From the WebLogic Workshop menu bar, choose 
File→Save All.

Call the calculateTotalPrice User Method From the Query

1. Select the Design View tab.

2. Select the link between the taxRate Java primitive and the quote/quoteResponse/totalCost 
node.

3. In the Palette, find the User Functions section. (If the Palette is not visible, from the 
WebLogic Workshop menu bar, choose View→Windows→Palette.)

4. In the User Functions section of the Palette, select the calculateTotalPrice function, and 
drag-and-drop it into the General Expression pane.

Leave $float-var selected in the General Expression pane.

5. In the Source pane, select the taxRate node and drag-and-drop it onto the $float-var 
parameter of the General Expression pane.

In the General Expression pane, the default argument: $float_var is replaced with the 
$taxRate argument and the next argument becomes selected, as shown in the following 
figure.
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Leave $int-var selected in the General Expression pane.

6. In the Source pane, select availQuoteDoc/availRequest/requestedQuantity and 
drag-and-drop it onto the selected $int-var argument in the General pane.

In the General Expression pane, the default argument: $int_var is replaced with the 
$availRequest/ns1:requestedQuantity argument and the next argument becomes selected, 
as shown in the following figure.

Leave $float-var selected in the General Expression pane.

7. In the Source pane, select priceQuoteDoc/priceRequests/priceRequest/price and 
drag-and-drop it onto the selected $float-var argument in the General Expression pane.

In the General Expression pane, the default argument: $float_var is replaced with the 
$priceRequest/ns0:price argument and the next argument becomes selected, as shown in 
the following figure.
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Leave $boolean-var selected in the General Expression pane.

8. In the Source pane, select availQuoteDoc/availRequest/quantityAvail and drag-and-drop 
it onto the selected $boolean-var argument in the General Expression pane.

In the General Expression pane, the default argument: $boolean_var is replaced with the 
$availRequest/ns1:quantityAvail argument, as shown in the following figure.

9. Click Apply.

In the Design View, the following is displayed, as shown in the following figure.



5-12 Tutorial: Building Your First Data Transformation

10. Save all the files in this application. From the WebLogic Workshop menu bar, choose 
File→Save All.

To View the Generated Query

1. Select the Source View tab.

2. Expand prolog.

The following query is displayed in Source View:

{-- requestquote/MyTutorialJoin.dtf#myJoin --}
declare namespace ns0 = "http://www.example.org/price"
declare namespace ns1 = "http://www.example.org/avail"
declare namespace ns2 = "http://www.example.org/quote"
<ns2:quote>

<name>{ data($priceQuoteDoc/ns0:customerName) }</name>
<address>{ concat($priceQuoteDoc/ns0:shipAddress/@street , ",",

$priceQuoteDoc/ns0:shipAddress/@city , ",",
xf:upper-case($priceQuoteDoc/ns0:shipAddress/@state) , ",",
$priceQuoteDoc/ns0:shipAddress/@zip) }</address>

{
for $priceRequest in 

$priceQuoteDoc/ns0:priceRequests/ns0:priceRequest,
$availRequest in $availQuoteDoc/ns1:availRequest

where data($priceRequest/ns0:widgetId) = 
data($availRequest/ns1:widgetId)

return
<quoteResponse>

<widgetId>{ data($priceRequest/ns0:widgetId) }</widgetId>
<unitPrice>{ data($priceRequest/ns0:price) }</unitPrice>
<requestedQuantity>{ 

data($availRequest/ns1:requestedQuantity) }</requestedQuantity>
<fillOrder>{ data($availRequest/ns1:quantityAvail) 

}</fillOrder>
{

for $shipDate in $availRequest/ns1:shipDate
return

<shipDate>{ data($shipDate) }</shipDate>
}
<taxRate>{ $taxRate }</taxRate>
<totalCost>{ calculateTotalPrice($taxRate,

$availRequest/ns1:requestedQuantity,
$priceRequest/ns0:price,
$availRequest/ns1:quantityAvail) }</totalCost>

</quoteResponse>
}
</ns2:quote>
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The links added in the preceding task generate the additional XQuery source code listed between 
the <quoteResponse> and </quoteResponse> tags highlighted in bold in the preceding query 
listing.

To Test the Query

1. Select the Test View tab.

2. There are three import parameters to the myJoin Transformation method: 
$priceQuoteDoc, $availQuoteDoc, and $taxRate. In the task: “To Test the Simple 
Query” on page 4-6, you imported PriceQuote.xml as source data for the 
$priceQuoteDoc parameter. In this step, you import AvailQuote.xml for the source 
parameter: $availQuoteDoc:

a. From the drop-down menu in the Source Data pane, select $availQuoteDoc.

b. Click Import... .

The Open XML File to Test dialog box is displayed.

c. Double-click the requestquote folder.

d. Double-click the testxml folder.

e. Double-click the AvailQuote.xml file.

A graphical representation of the AvailQuote.xml file appears in the Source Data pane.

3. From the drop-down menu in the Source Data pane, select $taxRate .

4. In the Node Value field of the $taxRate node, double-click the existing value, enter 
“0.08”, and then press Enter on your keyboard

5. In the Result Data, pane click Test.

The query is run with the test XML data. A graphical representation of the resulting XML 
data is shown in the XML Design View of the Result Data pane, as shown in the 
following figure.
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This query joins the two sets of source repeating elements (availRequest and 
priceRequest) to a single repeating element (quoteResponse).

6. To view resulting data as XML, in the Result Data pane, select the XML Source View tab.

7. To check that the resulting XML data from the query is valid against the associated XML 
Schema, in the Result Data pane click Validate. 

The Output tab will show whether the XML data is valid to the target XML Schema. In 
this example, the resulting XML data is checked against the XML Schema in the 
Quote.xsd file. To learn more, see Validating.

http://edocs.bea.com/workshop/docs81/doc/en/integration/dtguide/dtguidemappervalidating.html
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Create an Instance of the MyTutorialJoin Control 
In this task, you create an instance of the MyTutorialJoin.dtf control. 

1. View the RequestQuote business process in the Design View:

a. If the Application tab is not visible in WebLogic Workshop, from the menu bar choose 
View→Application.

b. In the Application tab, double-click 
Tutorial_Process_Application\Tutorial_Process_ApplicationWeb\request

quote\RequestQuote.jpd and select the Design View tab.

2. Click Add on the Controls tab, then choose Integration Controls→Transformation from 
the drop-down menu. (If the Controls pane is not visible in WebLogic Workshop, from the 
menu bar, choose View→Windows→Data Palette. The Controls pane is at the bottom of 
the Data Palette.) 

Note: The Data Palette associated with business processes is different than the Data 
Palette associated with the mapper. 

The Insert - Transformation dialog box is displayed.

3. In the Insert - Transformation dialog box, complete the following steps: 

a. In Step 1, enter myTutorialJoin as the variable name for the control.

b. In Step 2, ensure that the following option is selected: Use a Transformation already 
defined by a DTF file.

c. Click Browse beside the DTF file field, expand the requestquote folder, select 
MyTutorialJoin.dtf, and then click Select to close the file browser.

The following in displayed in the Insert - Transformation dialog box:
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4. Click Create to close the Insert - Transformation dialog box. 

An instance called myTutorialJoin is created in your project and displayed in the 
Controls pane as shown by the following figure:

Edit the Node That Invokes the Transformation
In this task, you edit the Combine Price and Avail Quotes node in the RequestQuote business 
process and change the instance that gets invoked by this node from an instance of the 
TutorialJoin.dtf to an instance of the MyTutorialJoin.dtf. Additionally, you change the 
design of the Combine Price and Avail Quotes node to call the myJoin() method on the 
MyTutorialJoin control. The myJoin() method combines the data returned to your business 
process from different systems creating a single XML response document (quote) that is 
subsequently returned to the business process’s client. 

1. In the RequestQuote business process, double-click the Combine Price and Avail Quotes 
node to open its node builder. 
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The node builder opens on the General Settings pane.

2. From the drop-down menu in the Control field select myTutorialJoin.

3. Select QuoteDocument myJoin() from the Method field.

4. Click Send Data to open the second pane of the node builder.

The Select variables to assign fields are populated with default variables. The data types 
match the data type expected in the source parameters to the myJoin() method as shown in 
the following list:

priceQuote holds the price quote data, which is returned from the PriceProcessor 
service in the For Each loop in your business process.

availQuote holds the availability quote data, which is returned from the AvailProcessor 
service in the For Each loop in your business process.

taxRate holds the rate of sales tax applied to the quote, based on the shipping address, 
which is returned to your business process from the taxCalculation service.

The Control Expects fields are populated with the data type expected by the myJoin() 
method on the MyTutorialJoin control, as shown in the following figure.

5. Click Receive Data to open the third pane of the node builder.

On the Receive Data tab, the Select variables to assign field is populated with the default 
variable: Quote. The data type matches the data type expected in the target parameter to 
the myJoin() method. The Control Expects field is populated with the data type returned 
by the myJoin() method: QuoteDocument, as shown in the following figure.
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6. In the node builder, click X in the top right-hand corner to save your specifications and 
close the node builder.

7. Save all the files in this application, including the RequestQuote business process. From the 
WebLogic Workshop menu bar, choose File→Save All.

To Run the Business Process
Earlier in this tutorial, you entered the XML data that is run against the query. During run time, 
the business process builds the XML data and passes it to the query that was built in this tutorial. 
To run the business process and invoke the query, follow the instructions in Step 12: Run the 
RequestQuote Business Process in the Tutorial: Building Your First Business Process.

http://edocs.bea.com/workshop/docs81/doc/en/integration/tutorial/tutlogic/tutWLIProcessTest.html
http://edocs.bea.com/workshop/docs81/doc/en/integration/tutorial/tutlogic/tutWLIProcessTest.html
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C H A P T E R 6

Understanding the Concepts

This section is optional and provides detailed conceptual information about the following topics:

Understanding the Transformation

Understanding XML Repeating Nodes

Understanding the Transformation
The transformation occurring in the query built in “Step 3: Mapping Elements and Attributes” on 
page 4-1 is shown in the following figure:
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The query generated in “To Map Attributes of an Element to Single Element” on page 4-4 is 
shown in the following listing:

{-- requestquote/MyTutorialJoin.dtf#myJoin --}

declare namespace ns0 = "http://www.example.org/price"

declare namespace ns1 = "http://www.example.org/avail"

declare namespace ns2 = "http://www.example.org/quote"

<ns2:quote>

<name>{ data($priceQuoteDoc/ns0:customerName) }</name>

<address>{ concat($priceQuoteDoc/ns0:shipAddress/@street ,

$priceQuoteDoc/ns0:shipAddress/@city ,

$priceQuoteDoc/ns0:shipAddress/@state ,

$priceQuoteDoc/ns0:shipAddress/@zip) }</address>

</ns2:quote>

The first three lines of this query are namespace declarations. These namespace declarations are 
part of the query prolog. For each namespace in the source and target XML Schema, the mapper 
generates a namespace declaration. For example, the mapper generates the namespace 
declaration: ns0 for the namespace URI (http://www.example.org/price) defined in the 
XML Schema of the PriceQuote.xsd file. Namespaces are used to uniquely distinguish 
elements in XML Schema from elements in another XML Schema.

The following steps describe the transformation that occurs when the source XML data is run 
against the preceding query:

1.  The fifth line of the query is shown in the following listing:

<ns2:quote>

This line of the query becomes the first line of the XML output, as shown in the following 
listing:

<quot:quote xmlns:quot="http://www.example.org/quote">

During the transformation, the namespace prefix for the quote element changes. In the 
query, the namespace prefix associated with http://www.example.org/quote 
namespace URI is ns2. However, in the resulting XML data, the namespace prefix 
generated for the http://www.example.org/quote namespace URI is quot. This 
namespace declaration is highlighted in bold in the preceding listing.

2.  The sixth line of the query is shown in the following listing:

<name>{data($priceQuoteDoc/ns0:customerName)}</name>
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This line of the query transforms the customerName element of the priceQuote element 
to the name element of the quote element.

The following steps describe the transformation that occurs on this line of XQuery code:

a. The <name> and </name> tags transform directly to XML output. 

b. Characters between curly braces {} are interpreted in a special way by the XQuery engine. 
That is, characters surrounded by curly braces are not transformed directly into XML. 
Specifically, in this example, the curly braces surrounding the data method specify that 
the data function of the XQuery language should be executed.

The data function returns the value of the passed in XML node. For this example, the 
argument to the data function is the following XPath expression: 
$priceQuoteDoc/ns0:customerName. The $priceQuoteDoc variable contains the 
contents of the priceQuote element, including its subelements. This XPath expression 
returns the customerName node of the priceQuote element. (The / XPath operator 
delineates parent nodes from child nodes.) 

The XQuery data function takes customerName node and returns the value of the 
node, the string: Acme Inc. This string is placed between the <name> and </name> 
tags resulting in the following line of output XML data, as shown in the following 
listing:

<name>Acme Inc</name>

3. The seventh line in the query is shown in the following listing:

<address>{ concat($priceQuoteDoc/ns0:shipAddress/@street,
$priceQuoteDoc/ns0:shipAddress/@city,
$priceQuoteDoc/ns0:shipAddress/@state,
$priceQuoteDoc/ns0:shipAddress/@zip) }</address>

The following steps describe the transformation that occurs on this line of XQuery code.

a. The <address> and </address> tags transform directly to XML output.

b. Characters between curly braces {} are interpreted in a special way by the XQuery engine. 
That is, characters surrounded by curly braces are not transformed directly into XML. 
Specifically, in this example, the curly braces surrounding the data method specify that 
the data function of the XQuery language should be executed.

c. The concat function takes the values of all its arguments, concatenates these values 
together, and returns them as a string. For this example, the concat function takes the 
values of the all the XPath expressions and concatenates them together in one address 
string. Additionally, all the arguments in this concat function are XPath expressions that 
return the value of specified attribute, as shown in the following table.
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The return string of the concat function is placed between the <address> and 
<address> tags resulting in the following line of XML data, as shown in the following 
listing:

<address>12 Springs RdMorris Plainsnj07960</address>

4. The last line of the query is shown in the following listing:

</ns2:quote>

The last line of the query becomes the last line of the XML output, as shown in the 
following listing:

</quot:quote>

The resulting address element has no delimiter between the street, city, state, and zip code 
fields, making the address difficult to read and parse. For instructions on adding delimiters to this 
query, return to “To Edit and Retest the Simple Query” on page 4-7 in the main section of this 
tutorial.

Understanding XML Repeating Nodes
A repeating node means that more than one instance of this node can be specified. For example, 
in the following XML data there are three instances of the priceRequest node, as shown in the 
following listing:

<?xml version="1.0"?>
<priceQuote xmlns="http://www.example.org/price">

<customerName>Acme Inc</customerName>

The Following XPath 
Expression

Returns The String

$priceQuoteDoc/ns0:sh
ipAddress/@ns0:street

The value of the street attribute 
of the shipAddress element.

12 Springs Rd

$priceQuoteDoc/ns0:sh
ipAddress/@ns0:city

The value of the city attribute of 
the shipAddress element.

Morris Plains

$priceQuoteDoc/ns0:sh
ipAddress/@ns0:state

The value of the state attribute 
of the shipAddress element.

nj

$priceQuoteDoc/ns0:sh
ipAddress/@ns0:zip

The value of the zip attribute of 
the shipAddress element.

07960
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<shipAddress street="12 Springs Rd" city="Morris Plains" state="nj" 
zip="07960"/>

<priceRequests>
<priceRequest>

<widgetId>12</widgetId>
<price>1.00</price>

</priceRequest>
<priceRequest>

<widgetId>134</widgetId>
<price>34.10</price>

</priceRequest>
<priceRequest>

<widgetId>211</widgetId>
<price>10.00</price>

</priceRequest>
</priceRequests>

</priceQuote>

A segment of the XML Schema for the preceding XML data is shown in the following listing:

<?xml version="1.0"?>
<xsd:schema . . . >
. . .

<xsd:element name="widgetId" type="xsd:integer"/>
<xsd:element name="price" type="xsd:float"/>
<xsd:element name="priceRequest">

<xsd:complexType>
<xsd:sequence>

<xsd:element ref="pri:widgetId"/>
<xsd:element ref="pri:price"/>

</xsd:sequence>
</xsd:complexType>

</xsd:element>
<xsd:element name="priceRequests">

<xsd:complexType>
<xsd:sequence>

<xsd:element ref="pri:priceRequest" minOccurs="1" 
maxOccurs="10"/>

</xsd:sequence>
</xsd:complexType>

</xsd:element>
. . .

<xsd:element name="priceQuote">
<xsd:complexType>

<xsd:sequence>
<xsd:element ref="pri:customerName" minOccurs="1" maxOccurs="1"/>
<xsd:element ref="pri:shipAddress" minOccurs="1" maxOccurs="1"/>
<xsd:element ref="pri:priceRequests"/>

</xsd:sequence>
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</xsd:complexType>
</xsd:element>

</xsd:schema>

The minOccurs="1" and maxOccurs="10" settings, in the definition of the priceRequest 
element (highlighted in bold in the preceding listing), specify that there can be one to ten 
instances of the priceRequest element. This defines priceQuote as a repeating element.

To View the Full listing of the XML Schema, Open the PriceQuote.xsd file

1. In the Application tab, expand Schemas folder. (If the Application tab is not visible in 
WebLogic Workshop, from the menu bar choose View→Application.)

2. Double-click the PriceQuote.xsd icon.

The PriceQuote.xsd file is displayed.

3. Return to the Design View of the myJoin.xq file:

a. In the Application tab, double-click 
Tutorial_Process_Application\Tutorial_Process_ApplicationWeb\
requestquote\MyTutorialJoin.dtf\myJoin.xq

b. Select the Design View tab.
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