BEA WebLogic Process Integrator
A Component of BEA WebLogic Integration

Using the BEA WebLogic Process Integrator Worklist
Contents

About This Document

What You Need to Know .............................................................................................. v
e-docs Web Site ........................................................................................................... vi
How to Print the Document ....................................................................................... vi
Related Information .................................................................................................... vi
Contact Us! ................................................................................................................ vii
Documentation Conventions ..................................................................................... vii

1. Starting and Exiting the Worklist

Starting the Worklist .................................................................................................. 1-1
Exiting the Worklist .................................................................................................... 1-3
Logging Off from the WebLogic Process Integrator Server .................................. 1-4
Logging On to the WebLogic Process Integrator Server ........................................ 1-4

2. Working with Tasks

Understanding Worklist Tasks ................................................................................ 2-1
Changing Task Properties ....................................................................................... 2-2
Executing a Task ........................................................................................................ 2-4
Changing Task Status ................................................................................................ 2-4
  Changing Task Status to Done .............................................................................. 2-4
  Changing Task Status to Pending ........................................................................ 2-5
Reassigning a Task ..................................................................................................... 2-5

3. Working with Workflows

Starting a Workflow .................................................................................................. 3-1
Viewing Workflow Status ......................................................................................... 3-3
4. Customizing the Worklist
   Working with Task Status ................................................................. 4-1
   Updating Task Status ....................................................................... 4-1
   Selecting Task Status Categories to Display .................................. 4-2
   Selecting Column Headings to Displays ....... ............................... 4-2
   Selecting Task Sort Order ......................................................... 4-3
   Selecting a Display Option ......................................................... 4-4

5. Working with Tools
   Displaying Logon Task Status ...................................................... 5-1
   Specifying Task Options .............................................................. 5-2

Index
About This Document

This document explains how to use the BEA WebLogic Process Integrator™ Worklist console. The document is organized as follows:

- Chapter 1, “Starting and Exiting the Worklist,” provides instructions for starting and exiting Worklist and disconnecting/reconnecting to the BEA WebLogic Process Integrator Server.
- Chapter 2, “Working with Tasks,” describes the task functions in Worklist.
- Chapter 4, “Customizing the Worklist,” explains how to customize the Worklist display and behavior.

What You Need to Know

This document is intended for users who complete workflow tasks.
e-docs Web Site

BEA product documentation is available on the BEA corporate Web site. From the BEA Home page, click on Product Documentation or go directly to the “e-docs” Product Documentation page at http://e-docs.beasys.com.

How to Print the Document

You can print a copy of this document from a Web browser, one file at a time, by using the File→Print option on your Web browser.

A PDF version of this document is available on the BEA WebLogic Process Integrator documentation Home page on the e-docs Web site (and also on the documentation CD). You can open the PDF in Adobe Acrobat Reader and print the entire document (or a portion of it) in book format. To access the PDFs, open the BEA WebLogic Process Integrator documentation Home page, click the PDF files button, and select the document you want to print.

If you do not have the Adobe Acrobat Reader, you can get it for free from the Adobe Web site at http://www.adobe.com/.

Related Information

The following BEA WebLogic Process Integrator documents contain information that is relevant to using this product.

- Learning to Use BEA WebLogic Process Integrator
- Using the BEA WebLogic Process Integrator Studio
- Installing and Configuring BEA WebLogic Process Integrator
- BEA WebLogic Process Integrator Release Notes
Contact Us!

Your feedback on the BEA WebLogic Process Integrator documentation is important to us. Send us e-mail at docsupport@beasys.com if you have questions or comments. Your comments will be reviewed directly by the BEA professionals who create and update the BEA WebLogic Process Integrator documentation.

In your e-mail message, please indicate which release of the BEA WebLogic Process Integrator documentation you are using.

If you have any questions about this version of BEA WebLogic Process Integrator Worklist, or if you have problems installing and running the product, contact BEA Customer Support through BEA WebSupport at www.beasys.com. You can also contact Customer Support by using the contact information provided on the Customer Support Card, which is included in the product package.

When contacting Customer Support, be prepared to provide the following information:

- Your name, e-mail address, phone number, and fax number
- Your company name and company address
- Your machine type and authorization codes
- The name and version of the product you are using
- A description of the problem and the content of pertinent error messages

Documentation Conventions

The following documentation conventions are used throughout this document.

<table>
<thead>
<tr>
<th>Convention</th>
<th>Item</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Tab</td>
<td>Indicates that you must press two or more keys simultaneously.</td>
</tr>
<tr>
<td><em>italics</em></td>
<td>Indicates emphasis or book titles.</td>
</tr>
<tr>
<td><strong>Convention</strong></td>
<td><strong>Item</strong></td>
</tr>
<tr>
<td>---------------</td>
<td>----------</td>
</tr>
</tbody>
</table>
| monospace text | Indicates code samples, commands and their options, data structures and their members, data types, directories, and filenames and their extensions. Monospace text also indicates text that you must enter from the keyboard. *Examples:*  
`#include <iostream.h>` `void main ( ) the pointer psz`  
`chmod u+w *`  
`\tux\data\ap\.
doc\`  
`tux.doc\`  
`BITMAP\`  
`float\` |
| monospace italic text | Identifies variables in code. *Example:*  
`String expr\` |
| UPPERCASE TEXT | Indicates device names, environment variables, and logical operators. *Examples:*  
`LPT1\`  
`SIGNON\`  
`OR\` |
| () | Indicates a set of choices in a syntax line. The braces themselves should never be typed. |
| [] | Indicates optional items in a syntax line. The brackets themselves should never be typed. *Example:*  
`buildobjclient [-v] [-o name] [-f file-list]...`  
`[-l file-list]...` |
| | Separates mutually exclusive choices in a syntax line. The symbol itself should never be typed. |
### Documentation Conventions

<table>
<thead>
<tr>
<th>Convention</th>
<th>Item</th>
</tr>
</thead>
<tbody>
<tr>
<td>...</td>
<td>Indicates one of the following in a command line:</td>
</tr>
<tr>
<td></td>
<td>▪ That an argument can be repeated several times in a command line.</td>
</tr>
<tr>
<td></td>
<td>▪ That the statement omits additional optional arguments.</td>
</tr>
<tr>
<td></td>
<td>▪ That you can enter additional parameters, values, or other information.</td>
</tr>
<tr>
<td></td>
<td>The ellipsis itself should never be typed.</td>
</tr>
<tr>
<td></td>
<td><em>Example:</em></td>
</tr>
<tr>
<td></td>
<td><code>buildobjclient [-v] [-o name] [-f file-list]... [-l file-list]...</code></td>
</tr>
<tr>
<td>.</td>
<td>Indicates the omission of items from a code example or from a syntax line.</td>
</tr>
<tr>
<td>.</td>
<td>The vertical ellipsis itself should never be typed.</td>
</tr>
</tbody>
</table>
Using the BEA WebLogic Process Integrator Worklist
CHAPTER 1

Starting and Exiting the Worklist

The following sections describe how to start and exit from the WebLogic Process Integrator Worklist console and disconnect/reconnect to the WebLogic Process Integrator server:

- Starting the Worklist
- Exiting the Worklist
- Logging Off from the WebLogic Process Integrator Server
- Logging On to the WebLogic Process Integrator Server

Starting the Worklist

To start the WebLogic Process Integrator Worklist:

1. Do one of the following:
   - On a UNIX system, go to the bin subdirectory of the WebLogic Process Integrator installation, and run the Worklist start-up script, by entering the following at the command prompt:

```
sh worklist.sh
```
The Logon to WebLogic Process Integrator dialog box is displayed.

**Figure 1-1   Logon to WebLogic Process Integrator Dialog Box**

2. Enter your user name in the User Name field.

3. Enter your password in the Password field.

4. In the Server [:port] field, specify the system that is running the WebLogic Process Integrator Server application as follows:

   ```
t3://host:7001
   
   where host is the computer name or IP address of the system that is running the WebLogic Process Integrator server. Specify localhost if the Server is running on the same computer as the Worklist application.
   ```

5. Click the OK button. The Worklist application window is displayed.
Exiting the Worklist

The information displayed on the User ID and Role tabs depends on the selected organization. An organization can represent different business entities or geographical locations. Use the drop-down list to the right of the toolbar to view task information for all organizations to which you belong.

Exiting the Worklist

Select File→Exit from the menu bar to close the Worklist console. Unsaved changes are automatically saved.
1 Starting and Exiting the Worklist

Logging Off from the WebLogic Process Integrator Server

Select File→Logoff from the menu bar to log off the WebLogic Process Integrator server. The toolbar icons on the main window and all menus except Tasks and Help are disabled. The Worklist console is disconnected from the WebLogic Process Integrator Server.

Logging On to the WebLogic Process Integrator Server

To reconnect to the WebLogic Process Integrator server after you have logged off:

1. Select File→Logon from the menu bar. The Logon to WebLogic Process Integrator dialog box displays.
2. Enter your user name in the User Name field.
3. Enter your password in the Password field.
4. In the Server [:port] field, specify the system that is running the WebLogic Process Integrator Server application as follows:

   t3://host:7001

   where host is the computer name or IP address of the system that is running the WebLogic Process Integrator Server. Specify localhost if the Server is running on the same computer as the Worklist application.
5. Click the OK button. The Worklist application window displays.
The following sections explain how to work with BEA WebLogic Process Integrator Worklist tasks:

- Understanding Worklist Tasks
- Changing Task Properties
- Executing a Task
- Changing Task Status
- Reassigning a Task

Understanding Worklist Tasks

When a task in a workflow is first defined in WebLogic Process Integrator Studio, certain permissions are set for that task. These permissions determine what actions you can do with a particular task in the Worklist console. See Using the BEA WebLogic Process Integrator Studio for more information.

There are three types of task permissions in Worklist:

- User—a task is assigned to a particular user ID. Only the assigned user can perform the task unless the user reassigns the task to another user (reassignment can only occur if the user has reassign permission).

  **Note:** The first tab on the main window is the User ID tab, which contains tasks assigned to your user ID.
2  Working with Tasks

- User who belongs to a role to which the task is assigned—a task is assigned to a role. A role is a common area of responsibility, ability, or authorization level that is shared by a group of individuals (such as a buyer or supervisor).

Users can belong to one or more roles. In this case, each role is represented by a tab to the right of the User ID tab on the main window. Tasks contained within a role can only be done by users who are members of that role. Any user who is a member of that role can take a task assigned to the role and execute it.

- User in a role—a task is assigned to a user in a role. The system automatically assigns the task to the user in the selected role who has the least number of tasks to do.

Changing Task Properties

To change task properties:

1. Select the task whose properties you want to change on the User ID tab or the appropriate Role tab.

2. Select Task→Properties from the menu bar. The Task Properties dialog box is displayed.
3. Select the task priority from the Priority drop-down list.

4. Select one or more of the following task-permission checkboxes:
   - Modify at execution—specifies whether users can change task permissions. If this permission is not set, users cannot select other permissions on the Task Properties dialog box.
   - Mark done without executing—denotes whether users can change task status to done.
   - Re-execute if marked done—specifies whether users can execute tasks even if the task has already been completed.
   - Unmark if marked done—denotes whether users can change task status to pending.
   - Reassign at execution—specifies whether users can reassign tasks.

5. Click the OK button to save any property changes and close the dialog box.
Executing a Task

You can only execute tasks that are pending and have been assigned to you individually as a user, to a role of which you are a member, or to a user in a role.

To execute a task:
1. Select the task you want to execute on the User ID tab or the appropriate Role tab.
2. Select Task→Execute from the menu bar.

The actual behavior during task execution is determined by the definition of the task at workflow design time. See Using the BEA WebLogic Process Integrator Studio for more information.

Changing Task Status

You can change task status from pending to done or done to pending.

Changing Task Status to Done

To change task status from pending to done:
1. Select the task you want to change on the User ID tab or the appropriate Role tab.
2. Select Task→Mark as Done from the menu bar.

Changing task status to done sets the task completion date to the current date and executes the actions defined for the marked done event of the task. The ability to change task status to done is determined by the permissions set on the Task Properties dialog box. See “Changing Task Properties” for more information.
Changing Task Status to Pending

To change task status from done to pending:

1. Select the task you want to change on the User ID tab or the appropriate Role tab.
2. Select Task → Unmark Done from the menu bar.

Changing task status to pending clears the task completion date. This action does not affect a task that is not complete. The ability to change task status to pending is determined by the permissions set on the Task Properties dialog box. See “Changing Task Properties” for more information.

Reassigning a Task

You can only reassign a task if:

- The task is currently assigned to you individually as a user, to a role of which you are a member, or to a user in a role.
- The task reassign permission is set on the Task Properties dialog box. See “Changing Task Properties” for more information.

To reassign a task:

1. Select the task you want to reassign on the User ID tab or the appropriate Role tab.
2. Select Task → Reassign from the menu bar. The Reassign Task dialog box displays.
3. Select one of the following sets of steps depending on your reassignment target:

   Reassignment to another user:
   a. Click the User radio button.
   b. Select another user in the Assignee drop-down list in the same organization associated with the workflow containing the task.

   Reassignment to a user in a role to which the task is assigned:
   a. Click the Role radio button.
   b. Select a role in the Assignee drop-down list in the same organization associated with the workflow containing the task.

   Reassignment to a user in a role:
   a. Click the User in role radio button.
   b. Select a role in the Assignee drop-down list. At execution time, the system performs workload balancing by automatically assigning the task to the user in that role who is assigned the least number of current tasks.

4. Click the OK button to save any reassignment changes and close the dialog box.
CHAPTER

3 Working with Workflows

The following sections explain how to work with BEA WebLogic Process Integrator Worklist workflows:

- Starting a Workflow
- Viewing Workflow Status

Starting a Workflow

To start a workflow:

1. Select Workflow → Start a Workflow from the menu bar. The Start Workflow dialog box displays.
2. Select the organization that contains the workflow you want to start in the Select the organization drop-down list. This list displays all the organizations to which you belong.

3. Select the workflow to start from the Select a workflow to start scroll list. The workflows that appear in this list represent all available workflow template definitions that you can start manually. Such workflows are defined as active and with a manual start at workflow design time.

4. Click the OK button to start the workflow. The processing that occurs during startup depends on the definition of the workflow created at design time. See *Using the BEA WebLogic Process Integrator Studio* for more information.
After the workflow starts successfully, the BEA WebLogic Process Integrator dialog box displays.

**Figure 3-2 BEA WebLogic Process Integrator Dialog Box**

![BEA Weblogic Process Integrator Dialog Box](image)

5. Click the OK button to close the dialog box.

**Viewing Workflow Status**

To view the status of all tasks associated with the workflow of the selected task:

1. Select the task whose workflow status you want to view on the User ID tab or the appropriate Role tab.

2. Select Workflow→Workflow Status from the menu bar. The Workflow Status dialog box displays.

**Figure 3-3 Workflow Status Dialog Box**

![Workflow Status Dialog Box](image)

Optionally, right click on any task listed in the Task column. A pop-up menu displays showing all the actions you can do with tasks.
3 Working with Workflows
The following sections explain how to customize the display and behavior of the WebLogic Process Integrator Worklist:

- Working with Task Status
- Selecting Column Headings to Displays
- Selecting Task Sort Order
- Selecting a Display Option

**Working with Task Status**

You can update task status and select task status categories to display on the User ID and Role tabs.

**Updating Task Status**

Select View→Refresh from the menu bar to update the status of all tasks shown on the User ID and Role tabs.
Customizing the Worklist

Selecting Task Status Categories to Display

To select task status categories to display on the User ID and Role tabs:

1. Select View from the menu bar. A list of checkboxes corresponding to the Pending, Done, and Inactive task statuses displays.

2. Select one or more of the checkboxes for the task status categories you want to display using Table 4-1. The User ID and Role tabs display or hide tasks based on the status categories you select.

Table 4-1  Task Status Categories to Display

<table>
<thead>
<tr>
<th>Status Category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pending</td>
<td>Pending tasks have not been executed yet.</td>
</tr>
<tr>
<td>Done</td>
<td>Done tasks have been completed</td>
</tr>
<tr>
<td>Inactive</td>
<td>Inactive tasks have not been started in the workflow.</td>
</tr>
</tbody>
</table>

Selecting Column Headings to Displays

To select column headings to display on the User ID and Role tabs:

1. Select View→Columns from the menu bar. The Columns dialog box displays.
Selecting Task Sort Order

To select task sort order on the User ID and Role tabs:

1. Select View→Sort By from the menu bar. A list of radio buttons displays corresponding to column headings shown on the User ID and Role tabs.

2. Select the radio button for the column heading you want to use to sort tasks.
Customizing the Worklist

Note: Select the Ascending checkbox to sort tasks in ascending order by the selected column heading. Otherwise, the tasks on the User ID and Role tabs are sorted in descending order.

Selecting a Display Option

To select a display option for the Worklist console:

1. Select View→Look & Feel from the menu bar. A list of radio buttons displays corresponding to the different user environments you can use.

2. Select the radio button for the user environment you want to use to display the Worklist console.
The following sections explain how to use the BEA WebLogic Process Integrator Worklist tools:

- Displaying Logon Task Status
- Specifying Task Options

**Displaying Logon Task Status**

To display logon task status:

1. Select Tools from the menu bar. A checkbox for Display Logon Status appears.

2. Select the checkbox to display logon task status. When this feature is enabled, the Workflow Status dialog box displayed during logon shows the number of pending and overdue tasks you have.

**Note:** The ability to enable/disable the display of logon task status is set on the Task Properties dialog box. See “Changing Task Properties” for more information.
Specifying Task Options

To specify task options:

1. Select Tools→Options from the menu bar. The Worklist Options dialog box displays.

![Worklist Options Dialog Box]

2. Configure Worklist options as follows:
   - Select the Enable task notification checkbox to automatically notify you when you are assigned new tasks. In this case, when you receive a new task, the notification dialog box is displayed:

![New Task Notification Dialog Box]

   - Specify the name of a WAV or AU file in the Play audio file field that will play when you receive a task notification.

   To browse audio files in your system, click the button to the right of the Play audio file field and select the audio file you want to use.
Specify the frequency between successive task notifications in the Seconds between successive notifications field. For example, you may not want task notification more frequent than every five minutes to reduce work interruptions.

3. Click the OK button to save any option changes and close the dialog.
Using the BEA WebLogic Process Integrator Worklist
Index

C
changing task properties 2-2
changing task status 2-4
changing task status to done 2-4
changing task status to pending 2-5
customer support contact information vii

D
displaying logon task status 5-1
documentation conventions vii

E
e-docs web site vi
executing a task 2-4

L
logging on Worklist 1-1

P
printing product documentation vi

R
reassigning a task 2-5
related information vi

S
specifying task options 5-2
starting a workflow 3-1
starting Worklist 1-1
status, viewing workflow 3-3
support, technical vii

T
tasks
change properties 2-2
change status 2-4
changing status to pending 2-5
changing task status to done 2-4
displaying logon status 5-1
execute 2-4
specifying options 5-2
understand 2-1

U
understanding Worklist tasks 2-1

V
viewing workflow status 3-3

W
what you need to know v
workflow, starting 3-1
workflow, viewing status 3-3
Worklist, starting 1-1