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C H A P T E R 1

WebLogic Builder

This document contains the following sections.

“How WebLogic Builder Works” on page 1-1

“Recommended Uses for WebLogic Builder” on page 1-2

“Limitations of WebLogic Builder” on page 1-2

“Starting WebLogic Builder” on page 1-3

“Migrating a J2EE Module to WebLogic Server” on page 1-6

“Working with Web Applications” on page 1-7

“Working with EJBs” on page 1-12

“Working with the J2EE Container” on page 1-17

“WebLogic Builder User Interface” on page 1-18

“Porting and Deploying Applications with WebLogic Builder” on page 2-1

How WebLogic Builder Works
WebLogic Builder is a visual environment for editing a J2EE application’s deployment 
descriptor XML files. You can view descriptor files while you visually edit them in WebLogic 
Builder, and you won’t need to make textual edits to the XML files. 
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Open WebLogic Builder and use the file menu to open an application’s compiled J2EE 
components (*.class files or modules that contain *.class files). If any of the application’s 
deployment descriptor files needed for deployment on WebLogic Server are missing or defective, 
WebLogic Builder will offer to generate new or repaired descriptor files. 

Once deployment descriptor files exist, use WebLogic Builder to edit their elements and 
attributes. For example, add a tag library to a web application, or add a finder method to an EJB. 

Test your application by using WebLogic Builder to deploy applications to a server. 

Recommended Uses for WebLogic Builder
Use WebLogic Builder for the following tasks:

Generate deployment descriptor files for a J2EE module

Edit a module’s deployment descriptor files

View deployment descriptor files

Compile and validate deployment descriptor files

Deploy a module to a server

Limitations of WebLogic Builder
Cannot add new modules to an application’s descriptor files 

Will notice changes to *.class files only if you close and reopen the module

Support for generating descriptors for EJB 1.1 beans is not guaranteed; focus is on EJB 2.0

Validates EJBs only

Cannot automatically display the differences between a changed but unsaved descriptor file 
and original file

Cannot perform batch descriptor update of XML element values

Cannot remove components from a module’s descriptor files

If you make changes to descriptor files while they are opened in WebLogic Builder, 
Builder will not be aware of the changes

No file management capabilities
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Generated XML representations of relations among entity beans are only accurate for 
one-to-one relations. For entity beans that already have descriptors, Builder does not 
refresh relations that have a “many” side. 

Starting WebLogic Builder
Start Builder from the Start menu or from the command line. 

From the Start menu, choose BEA WebLogic Platform-->Development Tools-->WebLogic 
Builder. 

In the command-line, use the following command: 

for Windows: 

startWLBuilder.cmd

for Unix: 

startWLBuilder.sh

This command sets your environment and starts WebLogic Builder. 

Open a module (a JAR or an EAR or a WAR or a J2EE module in exploded format) using the 
File menu’s Open options. 
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When you open a module in WebLogic Builder, you see on the left a navigational tree view of 
the module’s descriptor files, which you use to explore and select the components of the 
application. 
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On the right, you see tabbed panels with fields and other controls for editing the deployment 
descriptor elements of the module. 



WebLogic  Bu i lde r

1-6 WebLogic Builder Online Help

Use the navigational tree view on the left to select application components, and edit them in the 
corresponding tabs in the right-hand panel. 

For more information about the interface, see WebLogic Builder User Interface.

Migrating a J2EE Module to WebLogic Server
Migrate a module with no WebLogic Server deployment descriptors to WebLogic Server by 
opening the module using the File menu Open Archive or Open Directory. 

WebLogic Builder checks that the module has all the deployment descriptor files required for 
successful deployment on WebLogic Server. If needed deployment descriptor files are missing, 
WebLogic Builder will offer to generate them for you. If you accept, WebLogic Builder will 
introspect the class files in your module and create appropriate deployment descriptor files. 

To generate the descriptors, WebLogic Builder matches beans with their interfaces using method 
signatures and naming conventions. WebLogic Builder expects that bean class file names will 
end in either “Bean” or “EJB.” If possible, Builder will match up both methods and bean names. 
If bean names do not match, Builder looks for beans and interfaces that contain the same methods. 
If there are duplicate methods, or if it is not possible to use both method signatures and bean 
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names, Builder displays a warning in the error pane that it has made a guess based on available 
information. You can click on this error message to be taken to the class panel of the suspect bean 
to check and edit the class selection. 

WebLogic Builder does not overwrite existing deployment descriptor files. 

For more information about using WebLogic Builder to port applications to WebLogic Server, 
see Porting and Deploying Applications with WebLogic Builder.

Working with Web Applications
The following sections provide information about Web Applications. 

Adding a Servlet with Servlet Mapping and Security Constraints

Adding an ejb-ref/ejb-local-ref

Adding a Resource Reference

Adding a Listener Class

Adding a Filter with Filter Mapping

Defining a Match Map Class

Setting Welcome and Error Pages

Adding an Existing Tag Library

Adding a Virtual Directory

Adding a Servlet with Servlet Mapping and Security 
Constraints
This section describes how to add servlets to your Web Application’s deployment descriptor files 
and configure them with security roles, constraints, and assignments. 

Adding a Servlet with URL Mapping
Use the following procedure to add a new servlet to the deployment descriptor file. 

1. Under your Web Application’s name in the navigational tree, select Servlets. 

2. In the Servlets panel, select the servlet and click Add. 
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3. In the General tab, enter the Servlet Name and servlet class or JSP file. 

4. Optionally, add URL mappings to the servlet in the URL mappings list by entering the URL 
pattern and clicking Add. 

5. Click OK. 

The servlet’s name appears in the Servlet node in the navigational tree. 

Adding Security Roles, Constraints, and Assignments
Use the following procedures to define security roles and add security constraints and 
assignments to them. 

1. Under the Web Application node in the navigational tree, select Security Roles. 

2. In the editing panel, click Add, enter security role names and descriptions, and click OK. 

3. Under the Web Application node in the navigational tree, select Security Roles. 

4. In the editing panel, select a Role and click Edit. 

5. In the Edit dialog, add the names of members of the Role. 

6. Expand the Security Constraints node, and select a Constraint. 

7. In the Resources/Pages tab, set the following: 

– Web Resource Name

– URL patterns for Web Resources 

See virtual-directory-mapping in weblogic.xml Deployment Descriptor Elements, and 
filter-mapping in web.xml Deployment Descriptor Elements.

– HTTP methods 

– allowed and disallowed roles

8. In the Roles tab, set the Roles for which the Resources/Pages settings are allowed. 

9. In the SSL/Misc tab, set: 

– Transport Guarantee

See security-constraint in web.xml Deployment Descriptor Elements.

– Display Name

http://e-docs.bea.com/wls/docs81/webapp/weblogic_xml.html#1039396
http://e-docs.bea.com/wls/docs81/webapp/web_xml.html#1039330
http://e-docs.bea.com/wls/docs81/webapp/web_xml.html#1017885
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Adding an ejb-ref/ejb-local-ref 
Use an ejb-ref in the web application to define a reference to an EJB resource. See ejb-ref in 
web.xml Deployment Descriptor Elements.

Use an ejb-local-ref to declare a reference to the home interface of a local EJB. See 
ejb-local-ref in web.xml Deployment Descriptor Elements.

1. In the navigational tree, under the Web Tier, select J2EE References. 

2. In the J2EE References editing panel, select the EJB Refs tab for an ejb-ref, or the EJB 
Local Refs tab for an ejb-local-ref, and click Add. 

3. In the Edit dialog, specify the following properties of the reference and then click OK: 

– Reference Name

– Link Name (optional)

– EJB Type (Session or Entity)

– Remote Interface

– Home Interface

– Description (optional)

WebLogic Builder writes the reference to web.xml and displays it in the EJB Refs tab of 
the J2EE References editing panel. 

Adding a Resource Reference
Declare a reference to an external resource for your web application using the following 
procedure. The resource-ref element written using this procedure is located in web.xml. See 
resource-ref. 

1. In the navigational tree, under the name of your Web Application, select J2EE References. 

2. In the J2EE References editing panel, select the Resource Refs tab and click Add. 

3. In the Add dialog, select or enter the following parameters for the resource reference: 

– Reference name 

– Reference type

– JNDI name

http://e-docs.bea.com/wls/docs81/webapp/web_xml.html#1020090
http://e-docs.bea.com/wls/docs81/webapp/web_xml.html#1013984
http://e-docs.bea.com/wls/docs81/webapp/web_xml.html#1045815
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– Resource Sharing

– Resource Authentication

– Description

Click OK. 

4. In the navigational tree, expand the WebLogic Settings node under Web Applications, select 
J2EE Links and click Add. 

5. Select the Resource Reference that you added in step 3, enter its JNDI name for WebLogic 
Server, and click OK. 

Adding a Listener Class
Add an event listener class to a Web Application using the following procedure. See Application 
Events and Event Listener Classes. 

1. In the navigational tree, under the name of your Web Application, select Listeners. 

2. In the Listener editing panel, click Add. 

3. Enter the classname of the event and click OK. 

Adding a Filter with Filter Mapping
Declare a filter and filter mapping for your Web application using the following procedure. The 
filter element and filter-mapping element written using this procedure are located in 
web.xml. See filter and filter-mapping.

1. Under the name of your Web Application in the navigational tree, select Filters. 

2. In the Filters edit panel, click Add. 

3. In the edit dialog, enter the display settings for the filter: 

– In the General tab, enter the filter name and class and click OK. 

– In the Init Params tab, add the name, value and, optionally, a description of the 
parameters, and click OK. 

– In the Display tab, enter the Display Name, Small Icon (must reside within the Web 
Application), Large Icon (also must reside within the Web .Application), and 
Description (optional), and click OK

http://e-docs.bea.com/wls/docs81/webapp/app_events.html
http://e-docs.bea.com/wls/docs81/webapp/app_events.html
http://e-docs.bea.com/wls/docs81/webapp/web_xml.html#1015950
http://e-docs.bea.com/wls/docs81/webapp/web_xml.html#1039330
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Defining a Match Map Class
Define a match map to specify a class for URL pattern matching for your web application using 
the following procedure. The url-match-map element written using this procedure is located in 
weblogic.xml. See url-match-map.

1. Under the name of your Web Application in the navigational tree, select the Miscellaneous 
node and then the Container Settings tab. 

2. The Redirect content (determines the value for user-readable data used in a redirect) and 
Redirect content type (the servlet container uses this value to set the type on the response 
for internal redirects) fields do not persist values entered in them. Set these values in the 
text of weblogic.xml. 

3. Check to specify whether redirects will use absolute URLs. If unchecked, the servlet 
container will not convert the relative url to the absolute URL in the location header in a 
redirect.

4. Specify whether to check authentication on forward. If checked, the request dispatcher will 
check authorization on forwarded requests. 

5. Enter the name of a URL match-map class name for this Web Application. 

Setting Welcome and Error Pages
Specify a welcome page and error using the following procedure. The welcome-file-list 
element and error-page element written using this procedure are located in web.xml. See 
welcome-file-list and error-page.

1. Select your Web Application’s name in the navigational tree. 

2. In the edit panel for the Web Application, select Welcome Files. 

3. Set the order for existing welcome files using the Move up, Move down buttons, or add new 
files by entering the filenames and clicking Add. 

4. Select the Error Pages tab and click Add. 

5. Enter the filename or browse to the file. Set HTTP Error Code or Exception Type, and click 
OK. 

http://e-docs.bea.com/wls/docs81/webapp/weblogic_xml.html#1039479
http://e-docs.bea.com/wls/docs81/webapp/web_xml.html#1026980
http://e-docs.bea.com/wls/docs81/webapp/web_xml.html#1017571
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Adding an Existing Tag Library
Add tag libraries to your web application using the following procedure. The taglib element 
written using this procedure is located in web.xml. For information about tag libraries, see 
Overview of Programming JSP Tag Extensions. Also see taglib.

1. Under your Web Application name in the navigational tree, select Tag Libraries. 

2. In the Tag Libraries editing panel, click Add. 

3. Enter the URI for the tag library. 

4. Enter the location of the TLD or JAR file, or browse to it and select it. 

5. Click OK. 

Adding a Virtual Directory
Add a virtual directory to your Web Application using the following procedures. See 
virtual-directory-mapping in weblogic.xml Deployment Descriptor Elements. 

1. In the navigational tree, under Web Application, Miscellaneous, select 
VirtualDirectoryMappings and click Add. 

2. Set a local directory path by entering it, and add its URL patterns by entering them in the 
bottom text field and clicking Add. Then click OK. 

Working with EJBs
WebLogic Builder generates descriptors and interfaces for a bean class only if the bean class 
follows the naming convention of ending in either “Bean” or “EJB.” 

See the following sections for information about EJBs. 

http://e-docs.bea.com/wls/docs81/taglib/overview.html
http://e-docs.bea.com/wls/docs81/webapp/web_xml.html#1017621
http://e-docs.bea.com/wls/docs81/webapp/weblogic_xml.html#1039396
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Creating a Relationship Between 2.0 CMP Beans

Adding a CMP Field to an Entity Bean

Adding a Finder Method to an EJB

Specifying Optimistic Concurrency

Adding an ejb-reference or an ejb-local-reference Between Two Beans

Creating a Relationship Between 2.0 CMP Beans
Create a relationship between two 2.0 CMP beans using the following procedure. 

1. In the navigational tree under the EJB node, right-click the Relations node and select Add a 
relation... Note that if your module does not have CMP 2.0 beans, WebLogic Builder will not 
display the Relations node.

2. In the Relations dialog, enter a name for the relation. 

3. Set the Between option to One or Many for the first bean, and select the bean. 

4. Set the And option for the second bean to the desired match with the first bean’s Between 
option, and select the second bean and click Next. 

5. In the second Relations dialog, set a Role name, a CMR (Container Managed Relationship) 
field for the second bean, and a primary key Field for the first bean and a column for the 
second bean.
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6. Click Next. 

7. In the third Relations dialog, select the role name and optionally set bidirectional relations 
(CMR field and field type).

8. Click Finish. 
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WebLogic Builder writes the relation to ejb-jar.xml, and an entry for the relation 
appears in the Relations node. 

Adding a CMP Field to an Entity Bean
1. , In the navigational tree under EJB, expand an entity bean node, select the CMP Fields node 

and cllick Add.

2. In the CMP Fields dialog, set the field’s name. For example, if you have 
getFirstName() on your Bean class, the name of the CMP field will be firstName.

3. Use the browse button to browse to a table name. If you are not connected to a server, the 
browse button will activate the Connect to a Server dialog. 

4. To select the column name, click the browse button and browse the table. Select a column 
and click OK.

5. Set the column type. 

6. Click OK. 

The new CMP field will appear in the navigational tree under the CMP node of the bean. 

Adding a Finder Method to an EJB
1. In the navigational tree, under the name of your entity bean, expand the bean and select 

Finders. 

2. In the bean’s Finder editing panel, click Add. 
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3. Select the method name, enter its properties, and click OK. 

Specifying Optimistic Concurrency
You may want to set optimistic concurrency for your CMP entity beans when parallel 
transactions seem unlikely to conflict or when speed of response times is more important than 
certainty that transactions have not conflicted. WebLogic Builder’s default setting is pessimistic 
concurrency. See Choosing a Concurrency Strategy.

To set optimistic concurrency, do the following.

1. With an entity bean selected in the left navigational panel, select Tuning -> Cache. In the 
Concurrency strategy selection field, select Optimistic. 

2. Click Configure concurrency and select the Verify column and the Optimistic column to 
map the entity bean to a table. 

3. Select Version or Timestamp in the Verify column to enable the Optimistic column field. 

http://e-docs.bea.com/wls/docs81/ejb/entity.html#ChoosingaConcurrencyStrategy
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4. You can use the Browse button to connect to a server, browse a database, and select a 
column, or you can type the column name directly. 

Adding an ejb-reference or an ejb-local-reference Between 
Two Beans
See http://java.sun.com/dtd/ejb-jar_2_0.dtd and weblogic-ejb-jar.xml Deployment Descriptor 
Reference. 

1. In the navigation tree, expand an EJB and select Resources. 

2. In the Resources editing panel, select the EJB Refs or the EJB Local Refs tab and click 
Add. 

In the Add dialog, enter or select the following parameters: 

– EJB name

– EJB reference (or local reference) name

– Type of bean

– Home class

– Remote class

– JNDI name

Working with the J2EE Container
Ordering a Module

Setting Up EJB Caching

Choosing a Security Realm

Ordering a Module
To set the deployment order of a module, use the following procedure. See Deployment Order in 
Deploying WebLogic Server Applications. 

1. In the navigational tree, select the root node of the application. 

2. In the editing panel, select Deployment Order. 

http://e-docs.bea.com/wls/docs81/ejb/DDreference-ejb-jar.html
http://e-docs.bea.com/wls/docs81/ejb/DDreference-ejb-jar.html
http://e-docs.bea.com/wls/docs81/deployment/concepts.html#1001981
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3. In the field that lists the module’s components, select components and use the Move up and 
Move down buttons to reset their deployment order. 

Setting Up EJB Caching
Set up EJB caching using the following procedure. See Tuning WebLogic Server EJBs and 
http://www.bea.com/servers/wls810/dtd/weblogic-ejb-jar.dtd.

1. In the navigational tree, under the EJB node, expand a bean and select Tuning. 

2. In the Tuning panel, set the following caching conditions.

– Enter a the name of a concurrency strategy. 

– Check or leave unchecked the option to cache between transactions.

– For a cache, set maximum number of beans in cache, idle time-out, and read time-out. 

– For cache reference, select the entity cache name and set the estimated bean size. 

Choosing a Security Realm
Set a security realm for a module using the following procedure. 

1. In the navigational tree, select the WebLogic Application Settings node. 

2. In the WebLogic Application Settings editing panel, select the Security Realm tab. 

3. In the Security Realm tab, enter the realm name. 

WebLogic Builder User Interface
This section describes menu tasks and provides a key for locating deployment descriptor 
elements in the Builder interface. 

Menu Tasks

Deployment Descriptor Elements in WebLogic Builder

Menu Tasks
Opening an Application

Connecting to a Server

Deploying

http://e-docs.bea.com/wls/docs81/perform/EJBTuning.html
http://www.bea.com/servers/wls810/dtd/weblogic-ejb-jar.dtd
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Selecting a Compiler

Closing an Application

Saving an Application

Validating an Application

Generating Descriptors

Removing a Component Descriptor

Adding a New Descriptor Element

Removing a Deployment Descriptor Element

Viewing Deployment Descriptor XML Files

Opening an Application
To open an archived or an exploded module, from the File menu, select Open. Browse to the 
archived module or to the directory that contains the exploded module, select it, and click Open. 

Troubleshooting
If you try to load a module that is not well formed, for example an EAR that has a nested JAR 
which is not referenced in the accompanying MANIFEST.MF file, WebLogic Builder may have 
trouble opening your module. 

Connecting to a Server
Connect to a server to deploy your module for testing, or to connect your module to a data source. 

From the tools menu, select Connect to Server..

Enter the connect information in the dialog, and click Connect. 
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Deploying
From the Tools menu, select Deploy Module. If you are not connected to a server, WebLogic 
Builder offers the Connect dialog. 

Selecting a Compiler
1. From the Tools menu, select Options. 

2. In the Options dialog, select EJBC Compiler. 

3. Click Browse, and browse to the compiler. Select it and click Open.

Closing an Application
From the File menu, select Close. 

Saving an Application
From the File menu, select Save. 



WebLog ic  Bu i lde r  User  In te r face

WebLogic Builder Online Help 1-21

All changes that you have made to deployment descriptor files in WebLogic Builder will be saved 
to your module. 

Validating an Application
Validating does not save new changes to a module. 

Select Validate from the Tools menu to validate your module. 

Generating Descriptors
On opening a new module, WebLogic Builder asks you for permission to generate deployment 
descriptors for your opened module. When you accept, J2EE Application Builder creates the new 
descriptors and writes them to the appropriate location in the module. 

Removing a Component Descriptor
Remove a component from the module by removing its associated descriptor element from the 
module, outside of WebLogic Builder. 

Adding a New Descriptor Element
Add a new descriptor element to the module outside of WebLogic Builder. 

Removing a Deployment Descriptor Element
Remove files from module outside of WebLogic Builder.

Viewing Deployment Descriptor XML Files
View the XML files for the actively selected component using the following procedure. Note that 
these XML views are read-only. 

1. From the View menu, select XML Source. 

A tabbed XML viewer appears. 

2. Use the tabs to select the XML file you wish to view. 
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Deployment Descriptor Elements in WebLogic Builder
The sections listed below show the locations of deployment descriptor elements in WebLogic 
Builder. 

weblogic.xml Elements in WebLogic Builder

web.xml Elements in WebLogic Builder

weblogic-application.xml Elements in WebLogic Builder

ejb-jar.xml Elements in WebLogic Builder

weblogic-ejb-jar.xml Elements in WebLogic Builder

Tag Lib Elements in WebLogic Builder

weblogic-cmp20-rdbms-jar.xml Elements in WebLogic Builder

The file tree in the left panel contains nodes that group various deployment descriptor elements 
together in an intuitive manner. Click these nodes to navigate among the editing panels on the 
right, where you can make changes to the deployment descriptor elements. 
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weblogic.xml Elements in WebLogic Builder
The table below maps elements found in weblogic.xml to locations in WebLogic Builder’s 
interface. See weblogic.xml Deployment Descriptor Elements.

XML Element WebLogic Builder Node −−> Tab

description Web Application Node−−>Display 

weblogic-version

http://e-docs.bea.com/wls/docs81/webapp/weblogic_xml.html
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security-role-assignment: 

role-name, 
principal-name

Web Application Node−−>Security Roles

reference-descriptor:

resource-description, 
res-ref-name, jndi-name, 
ejb-reference-description, 
ejb-ref-name, 
resource-env-description, 
res-env-ref-name

Web Application Node−−>J2EE References

session-descriptor:

session-param, 
param-name: (CacheSize, 
ConsoleMainAttribute, 
CookieComment, 
CookieDomain, 
CookieMaxAgeSecs, 
CookieName, 
CookiePath, 
CookiesEnabled, 
IDLength, 
InvalidationIntervalSecs, 
JDBCConnectionTimeou
tSecs, 
PersistentStoreCookieNa
me, PersistentStoreDir, 
PersistentStorePool, 
PersistentStoreType, 
SwapIntervalSecs, 
TimeoutSecs, 
TrackingEnabled, 
URLRewritingEnabled)

Web Application Node−−>Session Settings

XML Element WebLogic Builder Node −−> Tab
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web.xml Elements in WebLogic Builder
The table below maps elements found in web.xml to locations in WebLogic Builder’s interface. 
See web.xml Deployment Descriptor Elements.

jsp-descriptor:

jsp-param, param-name 
(compileCommand, 
compileFlags, 
compilerClass, 
compilerSupportsEncodi
ng, defaultFilename, 
encoding, keepgenerated, 
noTryBlocks, 
packagePrefix, 
pageCheckSeconds, 
precompile, verbose, 
workingDir, debug)

Web Application Node−−>JSP Settings

container-descriptor Web Application, Miscellaneous Node−−>Container Settings

charset-params Web Application, Miscellaneous Node−−>IANA-Java Charset 
Mappings, and −−>Path-Charset Mappings

virtual-directory-mapping
:

(local-path, url-pattern

Web Application, Miscellaneous Node−−>Virtual Directories

url-match-map Web Application, Miscellaneous Node−−>Container Settings

security-permission Web Application, Security Constraints

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab

icon Web Application Node−−>Display

display-name Web Application Node−−>Display

XML Element WebLogic Builder Node −−> Tab

http://e-docs.bea.com/wls/docs81/webapp/web_xml.html
http://e-docs.bea.com/wls/docs81/programming/app_xml.html
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description Web Application Node−−>Display

distributable not supported

context-param Web Application Node−−>Context Params

filter:

icon, filter-name, 
display-name, 
description, filter-class, 
init-param

Web Application, Filter Node−−>Filter 

filter-mapping Web Application, Servlet/Filter Mappings Node−−>Filter 
Mappings

listener Web Application, Listeners−−>Listener Class

servlet:

icon, servlet-name, 
display-name, 
description, 
(servlet-class|jsp-file), 
init-param, 
load-on-startup, 
security-role-ref

Web Application, Servlets−−>Servlets

servlet-mapping:

servlet-name, url-pattern
Web Application, Servlet/Filter Mappings Node−−>Servlet 
Mappings

session-config:

session-timeout
Web Application, Session Settings−−>General

mime-mapping:

extension, mime-type
Web Application−−>Mime Types

welcome-file-list Web Application−−>Welcome Files

error-page:

(error-code|exception-typ
e), location

Web Application−−>Error Pages

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab
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taglib:

taglib-uri, taglib-location
Web Application, Tag Libraries−−>Tag Libraries

resource-env-ref:

description, 
resource-env-ref-name, 
resource-env-ref-type

Web Application, J2EE References−−>Resource Env Refs

resource-ref:

description, res-ref-name, 
res-type, res-auth, 
res-sharing-scope

Web Application, J2EE References−−>Resource Refs

security-constraint:

display-name, 
web-resource-collection, 
auth-constraint, 
user-data-constraint

Web Application, Security Constraints−−>Resource Pages, 
Roles, SSL/Misc

login-config:

auth-method, 
realm-name, 
form-login-config

Web Application−−>Login

security-role:

description, role-name
Web Application, Security Roles−−>Role name, Description, 
Principal Names

security-role-ref: 
description, role-name, 
role-link

Web Application, Servlets, Servlet−−>Security Role Refs

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab
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weblogic-application.xml Elements in WebLogic Builder
The table below maps elements found in weblogic-application.xml to locations in WebLogic 
Builder’s interface. See weblogic-application.xml Deployment Descriptor Elements. 

env-entry: 

description, 
env-entry-name, 
env-entry-value, 
env-entry-type

Web Application, J2EE References−−>Env Entries

ejb-ref

description, ejb-ref-name, 
ejb-ref-type, home, 
remote, ejb-link, run-as

Web Application, J2EE References−−>EJB Refs

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab

weblogic-application WebLogic Application Settings

ejb:

entity-cache 
(entity-cache-name, 
(max-beans-in-cache | 
max-cache-size), 
caching-strategy, 
start-mdbs-with-applicati
on

WebLogic Application Settings, EJB Settings−−>EJB Settings

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab

http://e-docs.bea.com/wls/docs81/programming/app_xml.html


WebLog ic  Bu i lde r  User  In te r face

WebLogic Builder Online Help 1-29

xml:

parser-factory 
(saxparser-factory, 
document-builder-factory
, transformer-factory), 
entity-mapping 
(entity-mapping-name, 
public-id, system-id, 
entity-uri, when-to-cache, 
cache-timeout-interval)

WebLogic Application Settings−−>XML Parser Factory, XML 
Entity Mappings

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab
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security:

realm-name
WebLogic Application Settings−−>Security Realm

jdbc-connection-pool:

data-source-name, 
connection-factory 
(factory-name, 
connection-properties), 
pool-params 
(size-params, xa-params, 
login-delay-seconds, 
leak-profiling-enabled, 
connection-check-params
), driver-params 
(statement, 
prepared-statement, 
row-prefetch-enabled, 
row-prefetch-size, 
stream-chunk-size), 
xa-params (debug-level, 
keep-conn-until-tx-compl
ete-enabled, 
end-only-once-enabled, 
recover-only-once-enable
d, 
tx-context-on-close-need
ed, 
new-conn-for-commit-en
abled, 
prepared-statement-cache
-size, 
keep-logical-conn-open-o
n-release, 
local-transaction-support
ed, 
resource-health-monitori
ng-enabled) acl-name

WebLogic Application Settings, JDBC Data Sources−−>General, 
Connection, Pool, XA Settings, Driver

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab
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ejb-jar.xml Elements in WebLogic Builder
The table below maps elements found in ejb-jar.xml to locations in WebLogic Builder’s 
interface. See WebLogic Server EJB Deployment Files.

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab

abstract-schema-name EJB−−>Advanced

acknowledge-mode Message Driven Bean−−>Advanced

security-role EJB−−>Security

method-permission, EJB, Methods−−>Permissions

container-transaction EJB, Methods −−>Transactions

cascade-delete not supported

cmp-field:

description, field-name
EJB, CMP Fields−−>CMP Fields

cmp-version EJB −−>Persistence

cmr-field:

description, 
cmr-field-name, 
cmr-field-type

EJB, Relations−−>Relation Wizard (right-click Relations)

destination-type Message Driven Bean−−> General

ejb-class EJB−−>Classes

ejb-client-jar not supported

ejb-link EJB−−>Resources

ejb-local-ref:

description, ejb-ref-name, 
ejb-ref-type, local-home, 
local, ejb-link

EJB, Resources−−>EJB Local Refs

http://e-docs.bea.com/wls/docs81/ejb/DDreference-cmp-jar.html
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ejb-name EJB−−>General

ejb-ql EJB Application, Finders−−>Finders

ejb-ref:

description, home, 
remote, ejb-link

EJB, Resources−−>EJB Refs

ejb-relation:

description, 
ejb-relation-name, 
ejb-relationship-role

Relations−−>Relations Wizard (right-click on Relations)

ejb-relationship-role: 
description, 
ejb-relationship-role-nam
e, multiplicity, 
relationship-role-source, 
cmr-field

Relations−−>Relations Wizard (right-click on Relations)

ejb-relationship-role-nam
e

Relations−−>Relations Wizard (right-click on Relations)

ejb-class:

home, remote, 
local-home, local

EJB−−>Classes

primkey-field Entity Bean−−>Persistence

resource-env-ref:

env-entry (description, 
env-entry-name, 
env-entry-type, 
env-entry-value)

EJB−−>Resources

field-name Entity Bean, CMP Fields−−>CMP Fields

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab
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message-driven:

ejb-name, ejb-class, 
message-driven-destinati
on

Message Driven Bean−−>General, Classes

message-selector:

acknowledge-mode, 
transaction-type

Message Driven Bean−−>Advanced

subscription-durability Message Driven Bean−−>General

persistence-type Entity Bean−−>Persistence

prim-key-class Entity Bean−−>Persistence

primkey-field Entity Bean−−>Persistence

query: 

description, 
query-method, 
result-type-mapping, 
ejb-ql

EJB, Finders−−>Finders

reentrant EJB−−>Advanced

relationships: 

description, ejb-relation
EJB Application, Relations−−>Relations Wizard (right-click on 
Relations)

resource-env-ref:

description, 
resource-env-ref-name, 
resource-env-ref-type 

EJB, Resources−−>Environment

resource-ref: 

description, res-ref-name, 
res-type, res-auth, 
res-sharing-scope

EJB, Resources−−>Resource References

role-name Enterprise Application−−>Security

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab
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weblogic-ejb-jar.xml Elements in WebLogic Builder
The table below maps elements found in weblogic-ejb-jar.xml to locations in WebLogic 
Builder’s interface. See weblogic-ejb-jar.xml Deployment Descriptor Reference. 

session-type Session Bean−−>General

session:

ejb-name, home, remote, 
local-home, local, 
ejb-class, session-type, 
transaction-type, 

Session Bean−−>General, Classes

session:

env-entry, ejb-ref, 
ejb-local-ref, 
security-role-ref, 
security-identity, 
resource-ref, 
resource-env-ref

Session Bean, Resources−−>Environment, Resource References, 
EJB Refs, EJB Local Refs

subscription-durability Message-Driven Bean−−>General

transaction-type EJB, Methods−−>Transactions

trans-attribute EJB, Methods−−>Transactions

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab

cache-between-transactio
ns 

EJB, Tuning−−>Cache

concurrency-strategy EJB, Tuning−−>Cache

connection-factory-jndi-n
ame 

Message-Driven Bean−−>Foreign JMS Provider

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab

http://e-docs.bea.com/wls/docs81/ejb/DDreference-ejb-jar.html
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jms-polling-interval-seco
nds 

Message-Driven Bean−−>Advanced

jms-client-id Message-Driven Bean−−>Advanced

delay-updates-until-end-o
f-tx 

EJB−−>Persistence

destination-jndi-name Message-Driven Bean−−>General

ejb-reference-description:

ejb-ref-name, jndi-name
EJB, Resources−−>EJB Refs

ejb-local-reference-descri
ption:

ejb-ref-name, jndi-name

EJB, Resources−−>EJB Local Refs

enable-call-by-reference For Session Bean: EJB−−>Advanced

For Entity Bean: EJB−−>Persistence

enable-dynamic-queries not supported

entity-cache:

max-beans-in-cache, 
idle-timeout-seconds, 
read-timeout-seconds, 
concurrency-strategy, 
cache-between-transactio
ns

EJB, Tuning−−>Cache

Not supported for Entity EJB. 

entity-cache-ref: 

entity-cache-name, 
concurrency-strategy, 
cache-between-transactio
ns, estimated-bean-size

EJB, Tuning−−>Pool

entity-cache-name not supported

estimated-bean-size not supported

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab
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entity-clustering:

home-is-clusterable, 
home-load-algorithm, 
home-call-router-class-na
me

EJB, Tuning−−>Cluster

enable-dynamic-queries not suported

finders-load-bean EJB−−>Advanced

home-call-router-class-na
me 

Session and Entity Beans, Tuning−−>Cluster

home-is-clusterable Session and Entity Beans, Tuning−−>Cluster

home-load-algorithm Session and Entity Beans, Tuning−−>Cluster

idempotent-methods EJB, Tuning−−>Cluster

idle-timeout-seconds EJB, Tuning−−>Cache

not supported for Stateful Session Bean

cache-type not supported

initial-beans-in-free-pool EJB, Tuning−−>Cluster

initial-context-factory Message Driven Bean−−>Foreign JMS Provider

is-modified-method-nam
e 

not supported

isolation-level Entity Bean, Methods−−>Transactions

jndi-name Entity Bean−−>General

clients-on-same-server not supported

local-jndi-name EJB−−>General

max-beans-in-cache EJB, Tuning−−>Cache

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab
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max-beans-in-free-pool EJB, Tuning−−>Pool

message-driven-descripto
r 

not supported

persistence-use not supported

pool:

max-beans-in-free-pool, 
initial-beans-in-free-pool

EJB, Tuning−−>Pool

read-timeout-seconds EJB, Tuning−−>Cache

replication-type EJB, Tuning−−>Cluster

security-role-assignment:

role-name, 
principal-name

EJB Application

stateful-session-clusterin
g:

home-is-clusterable, 
home-load-algorithm, 
home-call-router-class-na
me, replication-type

EJB, Tuning−−>Cluster

stateful-session-cache:

max-beans-in-cache, 
idle-timeout-seconds

EJB, Tuning−−>Cache

stateless-bean-call-router-
class-name 

not supported

stateless-bean-is-clustera
ble 

not supported

stateless-bean-load-algori
thm 

not supported

stateless-bean-methods-ar
e-idempotent 

not supported

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab
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Tag Lib Elements in WebLogic Builder
The table below maps tag library elements to locations in WebLogic Builder’s interface. See 
Creating a Tag Library Descriptor. 

stateless-clustering:

home-is-clusterable, 
home-load-algorithm, 
home-call-router-class-na
me, 
stateless-bean-is-clustera
ble, 
stateless-bean-load-algori
thm, 
stateless-bean-call-router-
class-name, 
stateless-bean-methods-ar
e-idempotent

not supported

stateless-session-descript
or:

pool, stateless-clustering

not supported

transaction-isolation:

isolation-level

not supported

trans-timeout-seconds Entity Bean−−>Persistence

type-identifier not supported

provider-url Message Driven Bean−−>Foreign JMS Provider

invalidation-target:

ejb-name
Entity Bean−−>Advanced

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab

http://e-docs.bea.com/wls/docs81/taglib/tld.html
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weblogic-cmp20-rdbms-jar.xml Elements in WebLogic Builder
The table below maps elements found in weblogic-cmp20-rdbms-jar.xml to locations in the 
WebLogic Builder interface. See Programming WebLogic Server Enterprise JavaBeans.

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab

taglib: 

tlib-version, jsp-version, 
short-name, uri, 
display-name, small-icon, 
large-icon, description, 
validator, listener

Web Application, Tag Libraries−−>Location, URI

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab

create-default-dbms-table EJB−−>Application

delay-database-insert-unti
l

Entity Bean−−>Advanced

automatic-key-generation Entity Bean−−>Automatic Key Generation

field-group not supported

table-map:

table-name, field-map
EJB Application, Relations−−>Relation wizard (right-click 
Relations)

verify-columns, 
optimistic-column

not supported

 check-exists-on-method Entity Bean−−>Advanced

ejb-name EJB−−>General

data-source-name EJB−−>Persistence

table-name EJB Application, Relations−−>Relation wizard (right-click 
Relations)

http://e-docs.bea.com/wls/docs81/ejb/index.html
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field-map:

cmp-field, dbms-column, 
dbms-column-type

not supported

cmp-field EJB Application, Relations−−>Relation wizard (right-click 
Relations)

dbms-column EJB Application, Relations−−>Relation wizard (right-click 
Relations)

optimistic-column not supported

dbms-column-type EJB Application, CMP Fields, CMP−−>CMP

column-map:

foreign-key-column, 
key-column

EJB Application, Relations−−>Relation wizard (right-click 
Relations)

weblogic-rdbms-relation:

relation-name, 
table-name, 
weblogic-relationship-rol
e, relationship-role-name 

EJB Application, Relations−−>Relation wizard (right-click 
Relations)

relationship-role-map: 

foreign-key-table, 
primary-key-table, 
column-map

EJB Application, Relations−−>Relation wizard (right-click 
Relations)

 group-name EJB Application, Finders, Finder−−>Query Settings

cmr-field EJB Application, Relations−−>Relation wizard (right-click 
Relations)

relationship-caching:

caching-name, 
caching-element

not supported

caching-name not supported

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab
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caching-element:

cmr-field, group-name, 
caching-element

not supported

weblogic-query:

query-method, 
weblogic-ql, group-name, 
max-elements, 
include-updates 

EJB Application, Finders, Finder

sql-select-distinct not supported

weblogic-ql EJB Application, Finders, Finder

method-name EJB Application, Finders, Finder

query-method EJB Application, Finders, Finder

max-elements EJB Application, Finders, Finder

include-updates EJB Application, Finders, Finder

sql-select-distinct EJB Application, Finders, Finder

automatic-key-generation
:

generator-type, 
generator-name, 
key-cache-size

EJB−−>Automatic Key Generation

generator-type EJB−−>Automatic Key Generation

generator-name EJB−−>Automatic Key Generation

key-cache-size EJB−−>Automatic Key Generation

delay-database-insert-unti
l 

EJB−−>Advanced

validate-db-schema-with not supported

database-type not supported

XML Elements and 
Attributes

WebLogic Builder Node −−> Tab
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C H A P T E R 2

Porting and Deploying Applications 
with WebLogic Builder

This tutorial shows you how to rapidly deploy Sun’s BluePrint wireless application Smart Ticket 
to WebLogic Server using the WebLogic Builder utility. WebLogic Builder is a visual 
environment that enables you to generate and edit deployment descriptor files. Smart Ticket is a 
J2EE application that lets you browse and purchase movie tickets using a wireless device such as 
a cell phone. Smart Ticket has both web application and EJB components.

In particular, the tutorial shows how to:

Generate and edit Smart Ticket’s deployment descriptor files using WebLogic Builder

Configure Smart Ticket’s data sources using the WebLogic Server Administration Console

Run Smart Ticket on WebLogic Server using a device emulator in the J2ME Wireless 
Toolkit

This tutorial contains the following sections:

“Prerequisites” on page 2-2

“Procedures” on page 2-2

“Big Picture” on page 2-7

“Best Practices” on page 2-7

“Related Reading” on page 2-8
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Prerequisites
Before starting this tutorial:

Read about Java Smart Ticket 1.1.1 at http://java.sun.com/blueprints/wireless/ .

Read about WebLogic Builder at WebLogic Builder Online Help.

Install Java 2 Platform, Micro Edition 1.0.4_01 at http://java.sun.com/j2me/docs/.

Install and start WebLogic Server. See http://www.bea.com.

Procedures
Follow these steps to deploy Smart Ticket on WebLogic Server. 

Step 1: Set up your applications and environment.

Step 2: Generate deployment descriptors for Smart Ticket.

Step 3: Specify <context-root> for the web application.

Step 4: Specify JNDI names.

Step 5: Define Smart Ticket’s data sources.

Step 6: Deploy Smart Ticket on WebLogic Server.

Step 7: Run Smart Ticket.

Step 1: Set up your applications and environment.
In this step you install Smart Ticket and J2ME, Sun’s Wireless Toolkit. You also set up your 
environment so you can build the application. 

1. If you have not already done so, install and start WebLogic Server 8.1. 

Download WebLogic Server 8.1 from http://www.bea.com and install it. The WebLogic Server 
installation directory, c:\bea\weblogic810 unless you specify another location, is called 
WL_HOME. 

2. Download and install Smart Ticket 1.1.1. 

Download the Smart Ticket demo application source code at 
http://developer.java.sun.com/developer/releases/smarticket/. Extract it into a new directory 

http://java.sun.com/blueprints/wireless/
{DOCROOT}/wlbuilder/index.html
http://java.sun.com/j2me/docs/
http://www.bea.com
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on the same machine or accessible from WL_HOME. We will call this directory 
SMARTICKET_HOME. 

3. Download and install J2ME to a location we will call J2MEWTK_HOME (say, C:\J2mewtk).

Download the Sun Wireless toolkit at: 
http://java.sun.com/products/j2mewtoolkit/download.html. Install the toolkit. During 
installation you will be prompted to select a JDK. You can select the JDK included in your 
BEA_HOME/jdk141 directory. 

4. Set J2MEWTK_HOME=C:\J2mewtk, assuming C:\J2mewtk is where you installed J2ME. 
Note: if you do not set J2MEWTK_HOME, you will not be able to build the application. 

5. Set your environment by running the setExamplesEnv script located in 
WL_HOME\samples\domains\examples. 

6. Open SMARTICKET_HOME \smarticket\localant.bat and add “%CLASSPATH%” to the 
end of the ANT_CLASSPATH line.

7. In the SMARTICKET_HOME\smarticket directory, build Smart Ticket by running 
localant.bat. . WebLogic Builder requires compiled .class files and cannot use .java 
files. 

Step 2: Generate deployment descriptors for Smart Ticket.
In this sequence, WebLogic Builder reads the deployment descriptor files that are included with 
the Smart Ticket application and introspects the application’s .class files to create the 
deployment descriptor files that help an application to run on WebLogic Server. 

WebLogic Builder will not overwrite the application’s existing deployment descriptor files. 

1. Open WebLogic Builder. In Windows select Start->Programs->BEA WebLogic 
Platform->WebLogic Server 8.1 | WebLogic Builder. In UNIX use the following command: 
startBuilder.sh

2. In WebLogic Builder’s File->Open menu, select the folder SMARTICKET_HOME 
\build\server and click Open. A dialog asks: “Unable to locate deployment descriptors. 
Would you like deployment descriptors created for you?” Click Yes to have WebLogic 
Builder introspect the Smart Ticket class files and generate weblogic.xml and 
weblogic-ejb-jar.xml. 

3. Select File->Save. 
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4. In WebLogic Builder, create smarticket.ear by selecting File->Archive and specifying 
SMARTICKET_HOME\bin\smarticket.ear. 

smarticket.ear is the application archive that you will configure and then deploy on 
WebLogic Server. 

Step 3: Specify <context-root> for the web application.
In this step, you set the Smart Ticket web application’s context path using the <context-root> 
element.

1. In WebLogic Builder, select the \web node’s Context Path tab. 

2. In the Context Path text field, enter SmarTicketApp. 

Now the application’s <context-root> element is specified. 

Step 4: Specify JNDI names.
In this sequence, you assign JNDI names to references in the web application and in EJBs so that 
the data in the entity beans is accessible from the web application. 

to the web application’s EJB references and resource references, and

to the EJB resource references 

1. Select Builder’s EJB Refs panel in the J2EE Refs node, and specify the JNDI names for the 
EJB Refs as follows:

 

2. In the Resource Refs panel in Builder’s J2EE Refs node, set the Ref Name, EJB Type, and 
JNDI Name according to the following table. Set the Resource Authentication Type to 
Container.

Reference Name EJB Type JNDI Name

ejb/MovieInfo Session MovieInfo

ejb/TicketSales Entity TicketSales

ejb/Customer Entity Customer

ejb/LocaleInfo Session LocaleInfo
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3. In the Resource References panel from Builder’s EJB Resources node, set JNDI names for 
EJB Resources according to the following table.

 

4. In Builder, select File->Save to save changes to the archive. 

Step 5: Define Smart Ticket’s data sources.
In this step, start the Examples server and use the WebLogic Server Administration Console to 
configure the Data Sources for each of the four EJBs the Smart Ticket application uses. Also in 
this step, replace Smart Ticket’s Cloudscape database with the Pointbase RDBMS included with 
WebLogic Server. 

Reference Name Reference Type JNDI Name

jdbc/MovieInfoDataSou
rce

java.sql.DataSource MovieInfoDataSource

jdbc/TicketSalesDataS
ource

java.sql.DataSource TicketSalesDataSource

jdbc/CustomerDataSour
ce

java.sql.DataSource CustomerDataSource

jdbc/LocaleInfoDataSo
urce

java.sql.DataSource LocaleInfoDataSource

Resource Reference Name Resource Reference Type JNDI Name

jdbc/MovieInfoDataSou
rce

java.sql.DataSource MovieInfoDataSource

jdbc/TicketSalesDataS
ource

java.sql.DataSource TicketSalesDataSource

jdbc/CustomerDataSour
ce

java.sql.DataSource CustomerDataSource

jdbc/LocaleInfoDataSo
urce

java.sql.DataSource LocaleInfoDataSource
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The JNDI names for the data sources must match the JNDI names for the web application 
resource references and the EJB resources you set in Step 4. 

1. Start the Examples server from: Start->Programs->BEA WebLogic Platform-> WebLogic 
Server 8.1->Server Tour and Examples->Launch Examples Server. 

The Examples Server launches the WebLogic Server Examples page. 

2. Open the WebLogic Server Administration Console by navigating to 
http://localhost:7001/console (or by following the link from the WebLogic Server 
Examples page), and sign in using username weblogic and password weblogic. 

3. Select the JDBC node and click Tx Data Sources. 

4. Select Configure a new JDBC Tx Data Source. 

5. Enter a name for the data source. The first one is MyCustomerDataSource. Enter 
CustomerDataSource in the JNDI field. Enter demoPool as your Pool Name; this is the default 
connection pool that WebLogic Server examples use. Click Create. 

6. Click the Targets Tab, then select the examplesServer in the Available column and click on the right 
arrow to target it. Click Apply. 

7. Repeat steps 4 and 5 for the other three data sources (MyMovieInfoDataSource, 
MyLocaleInfoDataSource, and MyTicketSalesDataSource). 

8. To replace Smart Ticket’s Cloudscape database with Pointbase, the evaluation RDBMS 
included with WebLogic Server 8.1, add the following to 
SMARTICKET_HOME\smarticket\populate.bat: 

set POINTBASEHOME=%SAMPLES_HOME%\server\eval\pointbase 

java utils.Schema 
jdbc:pointbase:server://localhost/demo,database.home=%POINTBASEHOME% 
com.pointbase.jdbc.jdbcUniversalDriver -u examples -p examples -verbose 
./src/smarticketPointBase.sql

9. We are also making the smarticket.sql Pointbase friendly by replacing it with a script 
that substitutes “int” data types with “integer.” Extract smarticketPointBase.sql from 
http://edocs.bea.com/wls/docs81/quickstart/smarticket-patch.zip and copy it into 
SMARTICKET_HOME\smarticket\src.

10. Set up the database by running SMARTICKET_HOME\smarticket\populate.bat.

Step 6: Deploy Smart Ticket on WebLogic Server.
Now you are ready to deploy and run Smart Ticket on the WebLogic Server 8.1 Examples Server. 

http://localhost:7001/console
{DOCROOT}/quickstart/smarticket-patch.zip
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1. Specify the server for the application using the Connect to Server dialog in WebLogic 
Builder’s Tools menu. 

2. Deploy Smart Ticket by selecting Deploy Module from the WebLogic Builder tools menu. 

3. Set the port in Smart Ticket’s executable, SMARTICKET_HOME\bin\smarticket.jad, by 
replacing the given port number (8000) with the port number of the Examples server, which by default 
is 7001. 

4. Optionally, open the J2ME Wireless Toolkit and select the default device and specify 
preferences. There are several options available for using the emulator. 

5. Start SMARTICKET_HOME\bin\smarticket.jad by double-clicking it or by selecting 
Start->J2ME Wireless Application->Run MIDP Application and selecting it.

A J2ME wireless emulator, either the one you selected in step 4 or the default emulator, 
DefaultGrayPhone, appears. The Smart Ticket asks you to create a user account and log 
in. 

Step 7: Run Smart Ticket.
When creating a user account for the Smart Ticket Application, enter 95130 or 95054 for your 
zip code. Your password must be six characters long. 

Try selecting the 'Poster' mode when you create an account; this will enable your phone or other 
wireless emulator to display a preview poster for the movies as you browse them. 

Big Picture
WebLogic Builder is a visual environment for generating and editing an application’s 
deployment descriptor files. You can view descriptor files while you visually edit them in 
WebLogic Builder, and you won’t need to make textual edits to the XML. See WebLogic Builder 
at http://edocs.bea.com/wls/docs81/wlbuilder/index.html. 

The sample application Smart Ticket illustrates how the J2EE platform interoperates with the 
J2ME platform to create enterprise applications that serve mobile client devices, such as cell 
phones, two-way pagers, and palmtops.

Best Practices
View the progress and status of the Smart Ticket application on WebLogic Server by monitoring 
the Launch Examples Server command window that appeared when you started the server. 

http://edocs.bea.com/wls/docs70/wlbuilder/index.html
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When selecting a device emulator from the J2ME Wireless Toolkit’s Default Device menu, the 
DefaultGreyPhone is the easiest to work with. 

If you are redeploying the Smart Ticket application, clear the database of the previous user’s 
information. To do so:

1. Run the J2ME Wireless Ticket Utility (available from the Windows start menu, or as an 
executable in J2ME_HOME/bin. 

2. Click Clean Database. 

3. Restart Smart Ticket by double-clicking SMARTICKET_HOME\bin\smarticket.jad or 
from Start->J2ME Wireless Application->Run MIDP Application.

Related Reading
See the procedure for porting Smart Ticket to WebLogic Server 8.1 without using WebLogic 
Builder: Java Smart Ticket Demo 1.1 at 
http://edocs.bea.com/wls/docs81/quickstart/smarticket.html.

{DOCROOT}/quickstart/smarticket.html
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