
Web Applications

Web Applications
Workshop for WebLogic provides support for building web applications using the Beehive NetUI 
framework.

These topics introduce you to the basic concepts behind Beehive NetUI-based web applications.

 Current Release Information:

●     What's New

●     Upgrading to 10.0 

Useful Links:

●     Tutorials

●     Tips and Tricks

Other Resources:

●     Online Docs

●     Dev2Dev

●     Discussion Forums

●     Development Blogs

 
Topics Included in This 
Section
 
Tutorial: Accessing a Database from 
a Web Application
This tutorial shows you how to build a web 
application that communicates with a 
backend database.

Tutorial: Beehive NetUI / Java 
Server Faces Integration
This tutorial shows you how to add Java 
Server Faces pages to your web 
application and how to integrate Java 
Server Faces and Beehive NetUI 
technologies in one application.

Introduction to Beehive NetUI
This topic introduces you to the basic 
concepts behind Beehive NetUI, the web 
application framework used by Workshop 
for WebLogic.

The Page Flow Perspective
This topic sets out the tooling provided by 
Workshop for WebLogic for building web 
applications.

Integrating Java Server Faces into a 
Beehive NetUI Web Application
This topic explains how to integrate JSF 
and Beehive NetUI technologies in one 
application.

Beehive Implementation Details
This topic lists the different web 
applications used by Workshop for 
WebLogic.

Authoring Beehive NetUI JSPs
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Web Applications

These topics introduce you to the basic 
techniques for creating JSP pages with 
Workshop for WebLogic.

Web Application Dialogs
These topics explain the web application 
related UI dialogs and wizards. 
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Tutorial: Accessing Controls from a Web Application

Tutorial: Accessing a Database from a Web Application

What This Tutorial Teaches

This tutorial teaches you how to build a web application capable of accessing a database using 
BEA Workshop for WebLogic Platform. It also provides a general introduction to the web 
application and control technologies that are part of Workshop for WebLogic.

Note: This tutorial requests that you create a new workspace; if you already have a 
workspace open, this will restart the IDE. Before beginning, you might want to launch 
help in standalone mode to avoid an interruption the restart could cause, then locate 
this topic in the new browser. See Using Help in a Standalone Mode for more 
information.

The tutorial contains step-by-step instructions for building a simple web application for managing 
a customer database. As you progress through the tutorial you will learn:

●     how Workshop for WebLogic leverages Beehive technologies to simplify web application 
development

●     how to use Java Controls to encapsulate access to data resources

●     how to make web applications and controls work together

●     how controls can be used to access data stored in a database

●     how to display complex Java objects as simple HTML tables

Tutorial Synopsis

Step 1: Create an EAR Project and a Web Application Project

The first step of this tutorial you will create two projects: an EAR project and a Web Application 
Project which contains a default minimal page flow. You will define a server which connects to the 
sample database and has library modules deployed on it. 

By the end of the first step, your application consists of the following components: 
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Tutorial: Accessing Controls from a Web Application

 

Step 2: Add a Page Flow and a Control

In the second step, you will add a Page Flow, and two controls to the web application project.

Page Flows are user-facing components of a web application. A Page Flow consists of any number 
of JSP pages and a single Java class, called a Controller class, that handles user actions and 
events inside the application.

The two controls used in this tutorial allow your application to interact with a database. The first 
control (CustomerControl.java) is a custom Java control. The second control (CustomerDB.java) is 
a database control that queries the database directly. Strictly speaking, a web application needs 
only one control, a database control, to access a database; but two controls are used here (a 
database control with a wrapper custom control) to increase the modularity of the application. 
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Tutorial: Accessing Controls from a Web Application

Details about this modularity are provided in step 2 of this tutorial.

At the end of step 2, your application will consists of the following components: 
 

Step 3: Create a Data Grid

In the third step you add a data grid to a JSP page that will display the data in the database.
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Tutorial: Accessing Controls from a Web Application

The components work together as follows: a method in the Page Flow Controller class will call the 
custom control, which will call the database control, which finally will query the database. The 
results returned by the query will then be displayed by the data grid on the JSP page.

Step 4: Create a Page to Edit Customer Data

In the last step you add an edit page to the Page Flow allowing you to edit the data in the 
database.

When the application is complete, it appears as follows: 
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Tutorial: Accessing Controls from a Web Application

 

Click the arrow below to navigate through the tutorial:
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Tutorial: Accessing Controls from a Web Application: Step 1: Create an EAR Project and a Web Application Project

Step 1: Create an EAR Project and a Web Application Project

In this step you will create two projects: an EAR project and a Web Application project. These are 
the basic building blocks required for designing and testing a new Workshop for WebLogic web 
application.

An EAR project configures and stores resources of other components that are part of it, 
components such as web applications, EJBs, databases, etc. An EAR project has two main roles: 
(1) It is a composite project made up of other projects, such as web projects, EJB projects, and 
others. (2) It is a resource project containing library modules and JARs which other projects 
utilize. 

The web application project you create belongs to the EAR project. 

The tasks in this step are: 

●     To Start Workshop for WebLogic Platform 

●     To Create a New Web Project and a New EAR Project

●     To Import Files into the Web Project 

●     To Add a WebLogic Server Domain

To Start Workshop for WebLogic and Create a New Workspace

If you haven't started Workshop for WebLogic yet, use these steps to do so.

... on Microsoft Windows

If you are using a Windows operating system, follow these instructions.

●     From the Start menu, click All Programs > BEA Products > Workshop for 
WebLogic Platform 10.0 

...on Linux

If you are using a Linux operating system, follow these instructions.

●     Run BEA_HOME/workshop100/workshop4WP/workshop4WP.sh

(If you have already started Workshop for WebLogic, select File > Switch Workspace.)

1.  In the Workspace Launcher dialog, click the Browse button.
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Tutorial: Accessing Controls from a Web Application: Step 1: Create an EAR Project and a Web Application Project

2.  In the Select Workspace Directory dialog, navigate to a directory of your choice 
and click Make New Folder.

3.  Name the new folder WebAppTutorial, press the Enter key and Click OK.

4.  In the Workspace Launcher dialog, click OK.

5.  Close the Welcome view. 

To Create a New Web Project and a New EAR Project

1.  Right-click anywhere within the Project Explorer view and select New > Dynamic 
Web Project.  
Click Next. 

2.  In the Project Name field, enter CustomerCare 
Place a check mark next to Add project to an EAR. 
Confirm that the EAR Project Name is CustomerCareEAR.

3.  Click Finish. 

When your web project is first created, it is displayed 
in the Project Explorer view by default. The Project 
Explorer view shows a logical view of your workspace 
and its resources. 

The image to the right shows your workspace in the 
Navigator view. To switch to the Navigator view select 
Window > Show View > Navigator. The Navigator 
view shows your workspace as it is saved on disk.

There are now two projects in your workspace: the 
web project CustomerCare and the EAR project 
CustomerCareEAR. The two projects appear as 
sibling projects, since they are on the same level of 
the directory tree. But when the projects are compiled 
and deployed, the EAR project CustomerCareEAR is 
really a container project for the web project 
customerCare.

The CustomerCare Web Project

●     The .settings folder: Any directory that begins 
with a "." contains metadata generated by 
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Workshop for WebLogic. You should not edit the 
files in this directory. The .settings folder contains 
the preferences selected for each project.

●     The build folder contains .class files and other 
compiled code. You should not edit the files in this 
directory.

●     The src folder contains the web project's JAVA 
files. These files are user editable.

●     The WebContent folder contains the web project's JSP files and other web-related resources, 
such as configuration files (in the WEB-INF folder).

The CustomerCareEAR EAR Project

●     The .settings and build folders are described above. 

●     The EarContent folder contains configuration files for the EAR project. 
 
EarContent/APP-INF/lib: Any JARs in this directory are available to any project referenced 
by the EAR project. 
 
EarContent/META-INF/application.xml: Lists the modules referenced by the EAR, for 
example, the web application customerCare. 
 
EarContent/META-INF/weblogic-application.xml: List the library modules referenced by 
the EAR project. These resources can be used by any module referenced by the EAR.

To Import Files into Your Web Project

In this step you will import control files into your web project, control files that provide access to a 
customer database. An alternative design would locate these controls in a utility project (File > 
New > Project > J2EE > Utilty Project), which would make the controls available to all projects in 
the EAR. But for the sake of simplicity and expediency we have placed the controls directly in the 
web project.

1.  On the Project Explorer view, open the nodes CustomerCare > Java Resources. 

2.  Open Windows Explorer (or your operating system's equivalent) and navigate to the 
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directory BEA_HOME/workshop100/workshop4WP/eclipse/plugins/com.bea.
workshop.product.wl.samples_1.0.0/tutorials/resources/webApp/ and locate 
the controls and model folder. 

Watch Out! Don't open the webService folder by mistake!

3.  Drag the folders controls and model into the Project Explorer tab and drop them 
directly onto the folder customerCare/Java Resources/src.

4.  Before proceeding, confirm that the following directory and file structure exists. 
 

To Add a WebLogic Server Domain 

In this step you will point to a server where you can deploy your application. 

Note: if you have executed this tutorial before your server may already contain previous 
deployments of the tutorial-related projects. Before proceeding, it is recommended that you either 
(1) remove previous tutorial code from your server or (2) create a new server domain. 

1.  Confirm that you are in the J2EE perspective (Window > Show Perspective > 
J2EE ).

2.  Click the Servers tab. 

3.  Right-click anywhere within the Servers tab, and select New > Server.

4.  In the New Server dialog, select BEA Systems > BEA WebLogic v10.0 Server. 
Click Next. 
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5.  In the Domain home dropdown, select the location BEA_HOME/weblogic100/
samples/domains/workshop. (Note: if you are using a newly created server 
domain for this tutorial, then use the Browse button to navigate to that server 
domain, for example, BEA_HOME/user_projects/domains/base_domain.) 
Click Next.

6.  In the Available projects column, select CustomerCareEAR. Click the Add button 
to move the select project to the Configured projects column.

7.  Click Finish. 
 
A new server is added to the Servers tab.

You can use the Servers tab to manage your servers and project deployments as you develop 
your applications. 

To deploy or undeploy a project from a server, right-click the server and select Add and Remove 
Projects.

For more properties, double-click a server.

Click one of the following arrows to navigate through the tutorial: 
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Step 2: Add a Page Flow and a Control

The tasks in this step are:

●     Create a New Page Flow 

●     To Add a Control to the Page Flow 

●     To Create an Action to Forward Data to a JSP Page

Create a New Page Flow

1.  In the Project Explorer, right-click on the CustomerCare project and select New > Page Flow. 

2.  In the New Page Flow dialog, in the field Page Flow folder name enter customerManagement and click Finish. 
 

 

file:///F|/depot/dev/src/workshop/product/plugins/com.bea.workshop.product.wl.doc/html/webapplications/tutorial/tutWebAppStep2.html (1 of 10)1/26/2007 3:40:24 PM



Tutorial: Accessing Controls from a Web Application: Step 2: Add a Page Flow and an Action

3.  When asked to open the Page Flow perspective, click Yes. 
 

 

When you add a new Page Flow, it is displayed in the Page Flow Perspective by default. The Page Flow Perspective gives you four different views on a particular Page 
Flow:

1.  Page Flow Explorer

2.  Page Flow Editor

3.  Source Editor

4.  Page Flow Overview 

Page Flow Explorer

The Page Flow Explorer shows a logical view of the current Page Flow, listing all of the Actions, JSP Pages, Form Beans, etc. contained in the Page Flow. The Page Flow 
Explorer depicts the properties in a way similar to a file tree. But it is important to note that this tree is not the way that the Page Flow is written to disk. (To see the actual 
file tree of a Page Flow as it is written to disk, switch to the Navigator view.)

The top-level node gives the package of the current Page Flow. In this case the package is customerManagement.
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The first child node gives the Page Flow Controller class being viewed, in this case, CustomerManagementController.java.  
 
The next node lists the Actions. In this case there is only one action: begin. This action is created by default with each new Page Flow.

Next the JSP pages are listed. There is only one JSP page at this time: index.jsp.

At this time, all of the other nodes are empty, because our Page Flow is relatively undeveloped. As we proceed we'll add items to the nodes.

Page Flow Editor

The Page Flow Editor gives a graphical view of the current Page Flow.

The graphical view depicts the Page Flow's actions, JSP pages, and the connections between the actions and pages. In the picture below, the begin action is shown in the 
center pane. An arrow extending from the begin action to the index.jsp page depicts the Forward that navigates users to index.jsp, whenever the begin action is called.

The left side of the pane is called the upstream pane and the right side is called the downstream pane. Note that the Page Flow Editor always depicts the direction of 
flow as starting from the left and progressing to the right.

To change the current Page Flow depicted, click the dropdown list marked by the green triangle, as shown below. 

As you can see from the dropdown list shown below, there are two Page Flows in the web application: (1) Controller (a default Page Flow created with each web application) 
and (2) CustomerManagementController (which you will be developing for the remainder of this tutorial).
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You can also access a list of available Page Flows by clicking the icon on the Page Flow Explorer tab. In the image below the icon is circled in red. (The icon directly to the 
right will pop up the new Page Flow wizard.)

Page Flow Overview

The Page Flow Overview gives a graphical summary of a page flow. It shows all of the actions, pages, and the relationships between them.

Double-clicking on an icon in the Page Flow Overview shows the associated source code in Source View.

Source Editor

The source editor, appearing directly underneath the Page Flow Editor view, shows the Java source for the Page Flow Controller class.
file:///F|/depot/dev/src/workshop/product/plugins/com.bea.workshop.product.wl.doc/html/webapplications/tutorial/tutWebAppStep2.html (4 of 10)1/26/2007 3:40:24 PM



Tutorial: Accessing Controls from a Web Application: Step 2: Add a Page Flow and an Action

To Add a Control to the Page Flow

In this step, you will add a control, CustomerControl.java, to the Page Flow. The methods of this control (addCustomer, editCustomer, etc.) allow the Page Flow client 
to interact with customer data in a database. The interaction between the Page Flow client and the database consists of three classes: 

1.  CustomerManagementController.java: the client Page Flow class 

2.  CustomerControl.java: a wrapper intermediary Control class 

3.  CustomerDB.java: the Database Control class, queries the database directly

The control CustomerControl.java acts as a wrapper intermediary class between the client, CustomerManagementController.java, and the Database Control CustomerDB.
java. This wrapper intermediary increases the modularity of the application, allowing the user (1) to switch to a different Database Control if necessary in the future and (2) 
to execute any data type recasting within the wrapper class. 

In this tutorial no actual recasting occurs, but it is easy to imagine a case where recasting is necessary. For example, suppose your Page Flow expects a Customer[] object 
but your Database Control returns an ArrayList of Customer objects. In such a situation you could use the intermediary wrapper class to load the ArrayList into a Customer
[] before passing the data to the Page Flow.

1.  On the Page Flow Explorer tab, right-click on the Referenced Controls node and select Add Control.  
 

file:///F|/depot/dev/src/workshop/product/plugins/com.bea.workshop.product.wl.doc/html/webapplications/tutorial/tutWebAppStep2.html (5 of 10)1/26/2007 3:40:24 PM
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2.  In the Select Control dialog, select Existing Project Controls > CustomerControl - controls. 
Click OK. 
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You have just added four lines of code to the Page Flow Controller class CustomerManagementController.java:

    import org.apache.beehive.controls.api.bean.Control;
    import controls.CustomerControl;
    
        ...
    
    @Control
    private CustomerControl customerControl;

These lines declare the Customer control on the Page Flow, allowing you to call control methods.

When you declare a control on a Page Flow class, it appears in the Referenced Controls node, along with a list of its available methods:

 

To Create an Action to Forward Data to a JSP Page

In this task you will edit the Page Flow class so that it retrieves customer data from the CustomerControl. In particular, you will add an Action ( i.e., an annotated method 
called getCustomers() ) to the the Page Flow class that calls the CustomerControl method getCustomers(), a method which returns an array of Customer objects. (In the 
next step you will create a JSP page that displays this array of Customer objects, rendering it as an HTML table.)

1.  On the Page Flow Explorer tab, open the node Referenced Controls > customerControl and locate the getCustomers method. 

2.  Drag the getCustomers method directly on top of the index.jsp page displayed on the right-hand side of the Page Flow Editor tab.  
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Note: Make sure that the Page Flow CustomerManagementController is displayed in the Page Flow Editor. If any other Page Flow is displayed, select 
CustomerManagementController from the dropdown list (click the green triangle to show the dropdown list). 
 

3.  In the New Action dialog, accept the defaults and click Finish. 
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When the dialog closes, the Page Flow Editor should appear as follows: 
 

  
 
You have now created a new Page Flow Action getCustomers() that calls the Control method getCustomers(). The source code of the Action looks like this: 
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Tutorial: Accessing Controls from a Web Application: Step 2: Add a Page Flow and an Action

    @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "", actionOutputs = { @Jpf.ActionOutput(name = "getCustomersResult", 
type = model.Customer[].class) }) })
    public Forward getCustomers() {
        Forward forward = new Forward("success");
        model.Customer[] getCustomersResult = customerControl.getCustomers();
        forward.addActionOutput("getCustomersResult", getCustomersResult);
        return forward;
    }

4.  Press Ctrl-Shift-S to save your work. 

Click one of the following arrows to navigate through the tutorial: 
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Step 3: Create a Data Grid

In this step you will add a data grid to your application. A data grid is a set of JSP tags that are designed to render data as an HTML table. This is 
especially useful for rendering database data: the data grid renders the database fields as columns of the table and it renders the database records 
as rows of the table.

The tasks in this step are:

●     Create a JSP Page to Display the Customer List 

●     To Create a Grid to Display the Customer List 

●     To Run the Page Flow

Create a JSP Page to Display the Customer List

In this step you will create a new JSP page and place it within the navigation scheme of your Page Flow: when the getCustomers() action is called, 
the user is navigated to this JSP page.

1.  On the Page Flow Editor tab, click on the getCustomers action icon to center the node.

2.  Right-click on the unspecified node and select New JSP Page. 
 
The unspecified node means that the action getCustomers does not forward to any specified JSP page or other action. Your page flow 
will compile if it contains unspecified nodes, but, at runtime, if the getCustomers action is ever called, an exception will be thrown. (In 
terms of the source code, an unspecified node depicts an empty string in the path attribute of a Forward object: @Jpf.Forward(name = 
"success", path = "" ). 
 

 
 
Note: Data is passed from an Action to a JSP page through the pageInput implicit object. An implicit object is a location within a Page 
Flow where you can read and (oftentimes) write data for the purpose of passing the data around within the Page Flow. 

file:///F|/depot/dev/src/workshop/product/plugins/com.bea.workshop.product.wl.doc/html/webapplications/tutorial/tutWebAppStep3.html (1 of 19)1/26/2007 3:40:26 PM



Tutorial: Accessing Controls from a Web Application: Step 3: Create a Data Grid

 
The pageInput implicit object is the standard location for passing data from an Action to a JSP page. 
 
An Action writes data to the pageInput implicit object by declaring an action output. The following action is declaring that it writes 
Customer[] data to the pageInput.getCustomerResult implicit object. 

    @Jpf.Action(
                ...
                actionOutputs = { @Jpf.ActionOutput(  name="getCustomersResult", type = model.Customer[].class) }
                ...
                )
    public Forward getCustomers() {

A page input declares the data type that a JSP page expects to receive. The following JSP tag is declaring that it expects Customer[] 
data from the pageInput.getCustomerResult implicit object. 

    <netui-data:declarePageInput name="getCustomersResult" type="model.Customer[]" required="true" />

Note that if the Action passes something other than the expected data type, then a runtime exception will be thrown. 
 
If you ever need to edit the properties of an action output/page input, right-click the arrow that passes between the Action and the JSP 
page and select Edit Action Output.

3.  Right-click on the new JSP and select Rename (if necessary), rename the JSP to customers.jsp, and press the Enter key. 
 

To Create a Grid to Display the Customer List

In this task, you will add a set of JSP tags (<netui-data:dataGrid>, <netui-data:rows>, etc.) that are specially designed to render Java objects as 
an HTML table.
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1.  On the Page Flow Editor tab, right-click customers.jsp and select Open to open its source code.

2.  On the JSP Data Palette, in the Page Inputs section, locate the getCustomersResult icon.  
Drag the getCustomersResult icon onto the source code for customers.jsp, dropping it directly before the </netui:body> tag. 

3.  From the Choose a wizard dialog, select Data Grid and press OK. 
 

 

4.  On the Data Grid dialog, click the Columns tab. 
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5.  Reorder the columns listed to match the following sequence:  
    
   Id 
   First Name 
   Last Name 
   Company Name 
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   City 
   State 
   Zip 
   Phone 
   Email  
 

6.  Click the New button and position the new column (named Newcolumn0 by default) at the top of the list. 
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The next few tasks define an "Edit" link for each row of the table. These links take you to a editing page, where you can update the 
fields for a given row. 

7.  Change the Header Text of the new column from Newcolumn0 to Edit. (You can change the text by clicking inside the cell you wish to 
edit.)  
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8.  Set the Render As column to Text Anchor. (This makes the text into linking text instead of plain text.) 
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9.  Set the Content Source column to Static. 
 
By setting this dropdown to Static you are signaling your intent to display the same content in the column for each row, for example, a 
static image. When you set it to Data you are signaling your intent to display dynamic content in the column, typically some display text 
based on the data in the row, for example, the ID of the row. 
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Notice that when you set the dropdown to Data, fields appear in the lower part of the wizard to help you format the dynamic display 
text. If you set the dropdown to Static, those fields disappear. 
 

 

10.  In the Display Text field, enter Edit. 
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11.  Click the New button (next to the Anchor Action field).  
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12.  On the New Action dialog, from the Action Template dropdown list, choose Get Item for Edit Via Control. 
 
This New Action wizard helps construct different actions for typical scenarios. Note the different options available for creating new 
actions. Choosing 'Simple' helps you set up a simple navigational action. Choosing 'Control Method Call' helps you set up a control-
calling action. 
 
From the Control Method dropdown list, confirm that the method getCustomerById(Integer) is selected. 
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Click Next.  
 

 

13.  On the New Action dialog, on the Input Mapping page, click the Finish button. 
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A new action called getCustomerById is created in the Page Flow controller file.

14.  On the Data Grid dialog, click the Parameters tab. 
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15.  Click the Select button (on the Parameters tab, not the Columns tab). 
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16.  Select the id property and click OK. 
 

file:///F|/depot/dev/src/workshop/product/plugins/com.bea.workshop.product.wl.doc/html/webapplications/tutorial/tutWebAppStep3.html (15 of 19)1/26/2007 3:40:26 PM



Tutorial: Accessing Controls from a Web Application: Step 3: Create a Data Grid

 

17.  On the Data Grid dialog, click OK. 
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18.  Press Ctrl-Shift-S to save your work. 

You have just added the following data grid to the customers.jsp page.

file:///F|/depot/dev/src/workshop/product/plugins/com.bea.workshop.product.wl.doc/html/webapplications/tutorial/tutWebAppStep3.html (17 of 19)1/26/2007 3:40:26 PM



Tutorial: Accessing Controls from a Web Application: Step 3: Create a Data Grid

        <netui-data:dataGrid name="getCustomersResultGrid"
                dataSource="pageInput.getCustomersResult">
                <netui-data:configurePager disableDefaultPager="true" />
                <netui-data:header>
                        <netui-data:headerCell headerText="Edit" />
                        <netui-data:headerCell headerText="Id" />
                        <netui-data:headerCell headerText="First Name" />
                        <netui-data:headerCell headerText="Last Name" />
                        <netui-data:headerCell headerText="Company Name" />
                        <netui-data:headerCell headerText="City" />
                        <netui-data:headerCell headerText="State" />
                        <netui-data:headerCell headerText="Zip" />
                        <netui-data:headerCell headerText="Phone" />
                        <netui-data:headerCell headerText="Email" />
                </netui-data:header>
                <netui-data:rows>
                        <netui-data:anchorCell value="Edit" action="getCustomerById">
                                <netui:parameter name="id" value="${container.item.id}" />
                        </netui-data:anchorCell>
                        <netui-data:spanCell value="${container.item.id}">
                        </netui-data:spanCell>
                        <netui-data:spanCell value="${container.item.firstName}">
                        </netui-data:spanCell>
                        <netui-data:spanCell value="${container.item.lastName}">
                        </netui-data:spanCell>
                        <netui-data:spanCell value="${container.item.companyName}">
                        </netui-data:spanCell>
                        <netui-data:spanCell value="${container.item.city}">
                        </netui-data:spanCell>
                        <netui-data:spanCell value="${container.item.state}">
                        </netui-data:spanCell>
                        <netui-data:spanCell value="${container.item.zip}">
                        </netui-data:spanCell>
                        <netui-data:spanCell value="${container.item.phone}">
                        </netui-data:spanCell>
                        <netui-data:spanCell value="${container.item.email}">
                        </netui-data:spanCell>
                </netui-data:rows>
        </netui-data:dataGrid>

To Run the Page Flow

1.  On the Page Flow Explorer tab, click the server icon to deploy and run the Page Flow. 
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2.  In the Run on Server dialog, confirm that BEA WebLogic v10.0 Server is selected, and click Finish. 
 
Wait a minute for the server to start and the EAR to deploy.  
You will see a browser tab appear, displaying a grid of customer data.

3.  Close the browser tab for http://localhost:7001/customerCare/customerManagement/CustomerManagementController.jpf.

Click one of the following arrows to navigate through the tutorial: 
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Step 4: Create a Page to Edit Customer Data

In this step you will add a JSP page for editing individual customer records.

The tasks in this step are:

●     To Create a Record Editing Page 

●     To Make a Form for Updating the Customer Data

●     To Set Up Navigation Back to the Customer List 

●     To Run the Page Flow

To Create a Record Editing Page

1.  On the Page Flow Explorer tab, right-click on the Pages node and select New JSP Page.

2.  Rename the page to editCustomer.jsp. Press Enter. 

3.  On the Page Flow Editor tab, place the cursor in the Quick Jump field, enter getCustomerById, and press the Enter key. This will display the getCustomerById node in the 
center pane. (Alternatively, you can click the getCustomerById node on the Page Flow Overview tab.)

4.  Drag editCustomer.jsp icon (located on the Page Flow Explorer tab), onto the unspecified node (located on the Page Flow Editor tab).  
 
Note: make sure to drop directly on the unspecified node as shown below. 
 

To Make a Form for Updating the Customer Data

1.  On the Page Flow Explorer tab, double-click editCustomer.jsp to open its source code.

2.  On the JSP Design Palette, in the NetUI Wizards section, drag the Update Form pattern onto the JSP source editor and drop it directly before the </netui:body> tag. 
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3.  On the Update Form dialog, next to the Action field, click the New button. 
 

 

4.  On the New Action dialog,  
from the Control Method dropdown list, choose the updateCustomer(Customer) method, 
from the Form Bean dropdown list, select customerManagement.CustomerManagementController.GetCustomerByIdFormBean. 
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Click the Next button. 
 

5.  In the New Action dialog, on the Input Mapping page, click Finish. 
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6.  Click the Select button next to the Item Identifier field. 
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7.  Select the id property and click OK. 
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8.  On the Update Form dialog, on the Select Action page, click the Next button. 
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9.  On the Update Form dialog, on the Select Properties page, click the Next button. 
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10.  Arrange the fields so that they have the following order:  
 
   Id 
   First Name 
   Last Name 
   Company Name 
   City 
   State 
   Zip 
   Phone 
   Email  
 
Click the Finish button. 
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By clicking Finish, you have added the following form to editCustomer.jsp. 

<netui:form action="updateCustomer">
                <netui:hidden dataSource="actionForm.customer.id"></netui:hidden>
                <table>
                        <tr valign="top">
                                <td>Customer:</td>
                                <td>
                                <table>
                                        <tr valign="top">
                                                <td>FirstName:</td>
                                                <td><netui:textBox dataSource="actionForm.customer.firstName"></netui:textBox>
                                                </td>
                                        </tr>
                                        <tr valign="top">
                                                <td>LastName:</td>
                                                <td><netui:textBox dataSource="actionForm.customer.lastName"></netui:textBox>
                                                </td>
                                        </tr>
                                        <tr valign="top">
                                                <td>CompanyName:</td>
                                                <td><netui:textBox dataSource="actionForm.customer.companyName"></netui:textBox>
                                                </td>
                                        </tr>
                                        <tr valign="top">
                                                <td>City:</td>
                                                <td><netui:textBox dataSource="actionForm.customer.city"></netui:textBox>
                                                </td>
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                                        </tr>
                                        <tr valign="top">
                                                <td>State:</td>
                                                <td><netui:textBox dataSource="actionForm.customer.state"></netui:textBox>
                                                </td>
                                        </tr>
                                        <tr valign="top">
                                                <td>Zip:</td>
                                                <td><netui:textBox dataSource="actionForm.customer.zip"></netui:textBox>
                                                </td>
                                        </tr>
                                        <tr valign="top">
                                                <td>Phone:</td>
                                                <td><netui:textBox dataSource="actionForm.customer.phone"></netui:textBox>
                                                </td>
                                        </tr>
                                        <tr valign="top">
                                                <td>Email:</td>
                                                <td><netui:textBox dataSource="actionForm.customer.email"></netui:textBox>
                                                </td>
                                        </tr>
                                </table>
                                </td>
                        </tr>
                </table>
                <br /> 
        <netui:button value="updateCustomer" type="submit" />
        </netui:form>

 
To Set Up Navigation Back to the Customer List

1.  On the Page Flow Editor tab, place the cursor in the Quick Jump field, enter updateCustomer, and press the Enter key. This will display the updateCustomer node in the 
center pane. (Alternatively, click the updateCustomer node on the Page Flow Overview tab .)

2.  Drag the getCustomers action (located on the Page Flow Explorer tab) onto the right-hand side of the Page Flow Editor tab . 
 

3.  Press Ctrl-Shift-S to save your work.

4.  The Page Flow Overview should appear as follows: 
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5.  Close the source file for editCustomer.jsp.

To Run the Page Flow

1.  On the Page Flow Explorer tab, click the server icon to deploy and run the Page Flow. 

2.  In the Run on Server dialog, confirm that BEA WebLogic v10.0 Server is selected, and click Finish.  
 
Wait a minute for the EAR and web application projects to deploy. 
You will see a browser tab appear, displaying a grid of customer data 

3.  Click the Edit link for "David Owen".

4.  Update the information for David Owen and click updateCustomer.

5.  Note that the information is updated on the grid page.

Click one of the following arrows to navigate through the tutorial: 
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Tutorial: Accessing a Database from a Web Application 

In this tutorial you learned:

●     how Page Flow Controller files work

●     how to provide user access to a database through a web application

●     how a database control queries a database

●     how databinding is used to pass data around a Page Flow

●     how a data grid renders complex data as an HTML table

Click the arrow below to navigate through the tutorial:
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Tutorial: Java Server Faces Integration

What This Tutorial Teaches

This tutorial teaches you how to enable and use Java Server Faces in a Workshop for WebLogic 
web application. 

The application you build here is a hybrid application that uses both JSF and Beehive NetUI 
technology. JSF supplies the user interface portion of the application, while Beehive NetUI 
supplies centralized backend data processing.

Note: This tutorial requests that you create a new workspace; if you already have a 
workspace open, this will restart the IDE. Before beginning, you might want to launch 
help in standalone mode to avoid an interruption the restart could cause, then locate 
this topic in the new browser. See Using Help in a Standalone Mode for more 
information.

The tutorial contains step-by-step instructions for building a simple web application for querying 
and viewing customer data. As you progress through the tutorial you will learn:

●     how Workshop for WebLogic uses JSF and Beehive NetUI technologies to simplify web 
application development

●     how to enable JSF in a Workshop for WebLogic web application

●     how to use JSF tags to create user data submission forms

●     how to use JSF tags to display complex Java objects as simple HTML tables

●     how to call a Beehive NetUI action from a JSF page

Note: this JSF tutorial assumes that you have a basic knowledge of Beehive NetUI web 
application technology, including the roles of controller classes, JSP pages, form beans and action 
methods. If you are unfamiliar with these concepts you may want to complete Tutorial: Accessing 
a Database from a Web Application before continuing.

Tutorial Synopsis

Step 1: Create a JSF-Enabled Web Project

In the first step of this tutorial you will create the foundation for your application by creating two 
projects: an EAR project and a Web Application Project. 

The EAR project has two main purposes: (1) it is a composite application that acts as a container 
for other applications and (2) it contains resources, in the form of library modules and JARs, for 
the applications contained in it. 
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For the purposes of this tutorial, the most important JARs contained in the EAR project are (1) the 
Beehive NetUI JARs and (2) the JSF JARs.

The Web Application Project accesses these JAR resources in the EAR simply by referencing them, 
not by copying them directly. This allows multiple web projects to point to the same resources in 
an EAR, without unnecessary duplication of resources.

Step 2: Create a JSF Web Application

In step you will create a simple web application that uses JSF tags to define the user interface. 

The web app contains a page where users can submit queries and another page for viewing the 
results.

 

Click the arrow below to navigate through the tutorial: 
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Step 1: Create a JSF Enabled Web Project 

In this step you will set up a JSF-enabled web project.

The tasks in this step are:

●     To Create a New Workspace 

●     To Create a New Web Project and a New EAR Project

●     To Import Files into the Web Project 

●     To Add a WebLogic Server

To Create a New Workspace

If you haven't started Workshop for WebLogic yet, follow these steps to do so.

... on Microsoft Windows

If you are using a Windows operating system, follow these instructions.

●     From the Start menu, click All Programs > BEA Products > Workshop for WebLogic Platform 10.0 

...on Linux

If you are using a Linux operating system, follow these instructions.

●     Run BEA_HOME/workshop100/workshop4WP/workshop4WP.sh

1.  In the Workspace Launcher dialog, click the Browse button. (If Workshop for WebLogic is already running, 
select File > Switch Workspace. ) 

2.  In the Select Workspace Directory dialog, navigate to a directory of your choice and click Make New 
Folder.

3.  Name the new folder JSFTutorial, press the Enter key and click OK.

4.  In the Workspace Launcher dialog, click OK.

5.  Close the Welcome view. 

To Create a New Web Project and a New EAR Project

1.  Right-click anywhere within the Project Explorer view and select New > Dynamic Web Project.  
Click Next. 

2.  In the Project Name field, enter JSFWeb. 
Place a checkmark next to Add project to an EAR. 
Confirm that the field EAR Project Name shows the value: JSFWebEAR. 
Click Next. 
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3.  Place a check mark next to the facet JSF (circled in red in the image below).  
Click Finish.  
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4.  When you are asked to switch to the J2EE perspective, in the Open Associated Perspective dialog, click Yes.

To Import Files into the Web Project

In this step you will import control files into your web project, control files that provide access to customer data.

1.  On the Project Explorer tab, open the nodes JSFWeb > Java Resources.

2.  Open Windows Explorer (or your operating system's equivalent) and navigate to the directory BEA_HOME/
workshop100/workshop4WP/eclipse/plugins/com.bea.workshop.product.wl.samples_1.0.0/
tutorials/resources/jsf/ and locate the folders businessObjects and controls.

3.  Drag the folders businessObjects and controls into the Project Explorer tab directly onto the folder 
JSFWeb/Java Resources/src.

4.  Confirm that the following directory and file structure exists before proceeding. 
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To Add a WebLogic Server

In this step you will point to a server where you can deploy your application.

Note: If you have executed the JSF tutorial before, it is recommended that you either (1) remove previous JSF tutorial 
code from your server or (2) create a new server domain. 

1.  Click the Servers tab.

2.  Right-click anywhere within the Servers tab, and select New > Server.

3.  In the New Server dialog, select BEA Systems > BEA WebLogic Server v10.0.  
Click Next. 

4.  In the Domain home field, use the pulldown to set the domain to BEA_HOME/weblogic100/samples/
domains/workshop. (Note: if you are using a newly created server domain for the JSF tutorial, then use the 
Browse button to navigate to that new server domain, e.g., BEA_HOME/user_projects/domains/base_domain.) 
Click Next.

5.  In the Available projects column, select JSFWebEAR. Click the Add button to move the selected project to 
the Configured projects column.

6.  Click Finish. 
 
A new server is added to the Servers tab.

You can use the Servers tab to manage your servers and project deployments as you develop your applications. 

To deploy or undeploy a project from a server, right-click the server and select Add and Remove Projects.

For more properties, double-click a server.

Related Topics 

Integrating Java Server Faces into a Web Application

Click one of the following arrows to navigate through the tutorial: 
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Step 2: Create a JSF Web Application

The tasks in this step are:

●     To Add a Control to the Page Flow 

●     Add a JSF Form for Submitting Search Queries

●     Add a JSF Page that Displays Query Results

●     Add a Link Back to the Search Form Page

●     Run the Web Application

To Add a Control to the Page Flow

In this step you will add a control to the web application. The control is designed to return customer data in the form of an ArrayList of 
Customer objects. In a more real world scenario this control might call out to a database or a web service to retrieve the customer data. 
But for the sake of testing the JSF components, the control in this scenario simply returns a fixed ArrayList of Customer objects.

1.  Select Window > Open Perspective > Page Flow. (For a description of the Page Flow perspective, see Page Flow 
Perspective.)

2.  On the Page Flow Explorer tab, right-click on the Referenced Controls node and select Add Control.

3.  In the Select Control dialog, select Existing Project Controls > CustomerControl - controls and click OK.

4.  Click Ctrl-S to save your work.

You have just added four lines of code to the Page Flow controller class:

    import org.apache.beehive.controls.api.bean.Control;
    import controls.CustomerControl;
    
        ...
    
    @Control
    private CustomerControl customerControl;

These lines declare the Customer control on the Page Flow, allowing you to call control methods.

Add a JSF Form and a NetUI Action for Submitting Search Queries

In this step you will add a JSF form (<h:form>) for submitting search queries on the customer data.

You will also add a new NetUI action (getCustomers) to the controller class. The JSF form will call this action through the form's attribute 
action. This action has a form bean parameter of type Customer: form beans are Java representations of HTML form data. 

When a user submits data though the form, the following events occur:

●     A Customer object (= a form bean) is created based on the submitted data. (This is the responsibility of the JSF backing class.)

●     The Customer object form bean is passed to the action getCustomers action. (The <h:form> tag passes the Customer object.) 

●     The getCustomers action performs a search based on the properties of the Customer object.

1.  On the Page Flow Explorer tab, double-click the node Pages > index.jsp to open the JSP's source code.

2.  From the JSP Design Palette, drag Create Form into index.jsp's source code. Drop it directly before the </f:view> element . 
 
Note: You can accomplish the same thing (creating a new form) by dragging the getCustomers method (on the Page Flow 
Explorer view and dropping it directly on top of the index.jsp page (in the Page Flow Editor).

3.  In the Create Form wizard, to create a new action, click New.

4.  In the New Action wizard, in the Action Template dropdown field, select Update Item Via Control. 
Next to the Form Bean field, click Add. 
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5.  In the Select a FormBean dialog, type Customer. 
Under Matching Types, select Customer - businessObjects. 
Click OK. 

6.  In the New Action dialog, click Next. 
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7.  In the New Action dialog click Finish. 
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8.  In the Create Form dialog click Next. 

9.  Confirm that all fields are checked.  
Click Next. 
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10.  In the Create Form dialog, order the fields in the following sequence: 
 
id 
first 
last 
address 
    city 
    state 
    zip 
 
Click Finish.

11.  Press Ctrl-Shift-S to save your work. 

You have just added the following form to the page index.jsp.

The form works by constructing a Customer object from the search data entered by the user. The Customer object is constructed by 
loading the entered data into the the backing bean's form bean: <h:inputText value="#{backing.formBean1.last}" id="field2" />. 
Note that backing.formBean1 refers to a Customer object field on the backing bean. 

The form, with the Customer object attached as an attribute, is then submitted to the NetUI action getCustomers.

<%@ page language="java" contentType="text/html;charset=UTF-8"%>
<%@ taglib prefix="f" uri="http://java.sun.com/jsf/core"%>
<%@ taglib prefix="h" uri="http://java.sun.com/jsf/html"%>

    <h:form>
        ....
        <h:outputLabel value="Last:" for="field2" />
        <h:inputText value="#{backing.formBean1.last}" id="field2" />
        ...
        <h:commandButton action="getCustomers" value="getCustomers">
            <f:attribute name="submitFormBean" value="backing.formBean1" />
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        </h:commandButton>
    </h:form>

The attached form bean is submitted as the action's method parameter:

    getCustomers(businessObjects.Customer form)

You have also added the following action to the controller file Controller.java.

Notice that the action takes a Customer object parameter: this parameter is the form bean submitted by the form. 

        @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "", actionOutputs = { @Jpf.ActionOutput(name 
= "getCustomersResult", type = java.util.ArrayList.class, typeHint = "java.util.ArrayList<businessObjects.
Customer>") }) })
    public Forward getCustomers(businessObjects.Customer form) {
        Forward forward = new Forward("success");
        businessObjects.Customer criteria = form;
        java.util.ArrayList<businessObjects.Customer> getCustomersResult = customerControl.getCustomers(criteria);
        forward.addActionOutput("getCustomersResult", getCustomersResult);
        return forward;
    }

Add a JSF Page that Displays Query Results

In this step you will create a new JSF page and add JSF tags for displaying query results. 

You will add a <h:dataTable> tag that renders an HTML table when appropriate data is passed to it. In this case, a java.util.ArrayList of 
Customer objects is passed to the <h:dataTable> tag. The tag iterates over the Customer objects rendering each object as a row in a 
standard HTML table.

Note that when you create a new JSF page, Workshop for WebLogic automatically creates the page's backing Java bean.

1.  On the Page Flow Editor view, place the cursor in the field labeled Quick Jump. 

 

Press Ctrl-Space to bring up the content assistant dropdown.

Double-click getCustomers.

The getCustomers action will be given focus in the Page Flow Editor.
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2.  In the Page Flow Explorer tab, right-click the Pages node and select New JSF Page.

3.  Name the page customers.jsp and press Enter.

4.  In the Rename Compilation Unit dialog, click Continue.  
 
At this point Workshop for WebLogic creates both (1) the page customers.jsp and (2) the backing Java class customers.java. 
(To examine the backing class, right-click the page and select Open Backing File.)

5.  Drag customers.jsp from the Page Flow Explorer view to the Page Flow Editor tab. Drop it directly on the unspecified 
node.

6.  On the Page Flow Explorer view (don't confuse this with the Page Flow Editor), double-click customers.jsp to open its 
source code. 

7.  From the JSP Data Palette drag getCustomersResult into the source view for customers.jsp. Drop it directly before the 
</f:view> tag.

8.  In the Data Display Wizard, confirm that all fields are checked and click Finish.

9.  Click Ctrl-Shift-S to save your work.

You have just added the following code to the customers.jsp file.

Notice that the data table gets it's input data through the NetUI implicit object pageInput. This is one of the most common ways to 
integrate Beehive NetUI and JSF technologies. For information about integrating these technologies, see Integrating Java Server Faces 
into a Web Application.

<%@ page language="java" contentType="text/html;charset=UTF-8"%>
<%@ taglib prefix="f" uri="http://java.sun.com/jsf/core"%>
<%@ taglib prefix="h" uri="http://java.sun.com/jsf/html"%>
<%@taglib uri="http://beehive.apache.org/netui/tags-databinding-1.0" prefix="netui-data"%>
<netui-data:declarePageInput required="true" type="java.util.ArrayList<businessObjects.Customer>" 
name="getCustomersResult" />

<html>
    <head>
    </head>
    <body>
        <f:view>
           <f:verbatim><p>Beehive NetUI-JavaServer Faces Page - ${pageContext.request.requestURI}</p></f:verbatim>

    <h:dataTable value="#{pageInput.getCustomersResult}" var="item0" border="1">
        <h:column>
            <f:facet name="header">
                <h:outputLabel value="Last" />
            </f:facet>
            <h:outputText value="#{item0.last}" />
        </h:column>
        <h:column>
            <f:facet name="header">
                <h:outputLabel value="Address" />
            </f:facet>
            <h:panelGrid columns="2">
                <h:outputLabel value="State: " />
                <h:outputText value="#{item0.address.state}" />
                <h:outputLabel value="Zip: " />
                <h:outputText value="#{item0.address.zip}" />
                <h:outputLabel value="City: " />
                <h:outputText value="#{item0.address.city}" />
            </h:panelGrid>
        </h:column>
        <h:column>
            <f:facet name="header">
                <h:outputLabel value="First" />
            </f:facet>
            <h:outputText value="#{item0.first}" />
        </h:column>
        <h:column>
            <f:facet name="header">
                <h:outputLabel value="Id" />
            </f:facet>
            <h:outputText value="#{item0.id}" />
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        </h:column>
    </h:dataTable>
</f:view>
    </body>
</html>

You have also specified the navigational target of the getCustomers action:

        @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "customers.faces", actionOutputs = { @Jpf.
ActionOutput(name = "getCustomersResult", type = java.util.ArrayList.class, typeHint = "java.util.ArrayList") }) })
    public Forward getCustomers(businessObjects.Customer form) {
        Forward forward = new Forward("success");
        businessObjects.Customer criteria = form;
        java.util.ArrayList<businessObjects.Customer> getCustomersResult = customerControl.getCustomers(criteria);
        forward.addActionOutput("getCustomersResult", getCustomersResult);
        return forward;
    }

Notice that the action forwards to the customers.jsp page using the .faces file extension: path = "customers.faces". 

Add a Link Back to the Search Form Page

In this step you will add a link on the results page that will navigate the user back to the search form page. The link you add will be a JSF 
link that directly raises a NetUI action.

1.  On the Page Flow Editor view, click the customers.jsp node so that customers.jsp is displayed in the center pane of the 
view. 

2.  On the Page Flow Editor view, right-click in the right-hand side of the view (also called the "downstream" pane) and select 
New Action. 
 

 

3.  In the New Action dialog, in the Action Name field, enter showIndex. 
In the Form Bean field, confirm that <none> is selected. 
In the Forward To field, select index.jsp.  
Click Finish. 
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4.  Press Ctrl-Shift-S to save your work.

Run the Web Application

1.  On the Page Flow Explorer view, click the server icon to deploy and run the Page Flow. 

2.  In the Run On Server view, click Finish. 
 
Wait while the application compiles, the server starts, and the application is deployed.

3.  Enter search criteria in the fields provided and click the Call showIndex button.  
 
Note: you can use partial First or Last names only as search criteria on the input form. Submit a blank form to retrieve all 
customers.

Related Topics 

Integrating Java Server Faces into a Web Application

Click one of the following arrows to navigate through the tutorial: 
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Summary: Java Server Faces Integration

In this tutorial you learned:

●     how to use JSF to create user interfaces for web applications

●     how Beehive NetUI provides backend event handling for a web application

●     how JSF and Beehive NetUI can work together in a web application

Further Information

Sun Site: JavaServer Faces Technology

Beehive Documentation: Java Server Faces

dev2dev Site: Integrating JavaServer Faces with Beehive Page Flow

Related Topics 

None.

Click the arrow below to navigate through the tutorial: 
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Building Web Applications: Introduction

BEA Workshop for WebLogic Platform provides tooling support for NetUI: the Apache Beehive 
framework for web applications. This topic explains the basic concepts behind Beehive NetUI.

Why Use Beehive NetUI?

By using Beehive NetUI, you can avoid making the typical mistakes that often happen during web 
application development, by separating presentation, business logic implementation, and 
navigational control. In many web applications, web developers using JSP (or any of the other 
dynamic web languages such as ASP or CFM) combine presentation and business logic in their 
web pages. 

As these applications grow in complexity and are subject to continual change, this practice leads 
to expensive, time-consuming maintenance problems, caused by:

●     

Limited reuse of business logic 

●     

Cluttered JSP source code 

●     Unintended exposure of business-logic code to team members who focus on other aspects of 
web development, such as content writers and visual designers

NetUI allows you to separate the user interface code from navigational control and other business 
logic. User interface code can be placed where it belongs, in the JSP files. Navigational control, 
business logic, and the core functionality of the web application can be implemented in Java 
controller classes, which form the nerve center of your web application. 

The basic division of labor between JSP files and controller classes can be summarized as follows: 
Java controller classes implement the functionality of the web application; JSP files surface that 
functionality to the user.

The presentation and processing aspects of a Beehive NetUI web app are highly modular: it's easy 
to change one without impacting the other. For example, its easy to change the look and feel of 
the web app by updating the JSP pages with little or no changes required to the underlying 
controller classes. Similarly, you can re-implement the controller classes without changing the JSP 
pages, because the core functionality of the web app is encapsulated in the controller classes 
instead of spread throughout the JSP pages.

The separation of presentation and business logic offers a big advantage to development teams. 
For example, you can make site navigation updates in a single Java class, instead of having to 
search through many JSP files and make multiple updates. You can also encapsulate similar web 
application functions in single Java classes, creating functionally modular web components. This 
approach to organizing the entities that comprise web applications makes it much easier to 
maintain and enhance web applications by minimizing the number of files that have to be updated 
to implement changes, and lowers the cost of maintaining and enhancing applications.
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Components of the Beehive NetUI Programming Model

This section gives an overview of the basic parts of the Beehive NetUI implementation. 

JSP Files

JSPs form the user interface of a NetUI web application, without the need to include Java code 
snippets on those pages. In a Beehive NetUI web app, the JSP pages contain JSP tags and 
references to JSP implicit objects, but no Java code. This makes the application behavior more 
predictable, testable, and it allows for stricter separation of labor between Java code developers 
and JSP developers. 

Beehive NetUI provides the JSP developer special libraries of JSP tags, the <netui> tag libraries, 
that supplement the functionality of the standard JSP tag libraries.

The <netui> tag library contains JSP tags specifically designed to work with controller classes (see 
below). Tags in the library all begin with the prefixes "netui", "netui-databinding", and "netui-
template". Some of these tags perform much like familiar HTML tags, while others perform 
function particular to page flow web applications. The most important feature of the tag library is 
its ability to refer to data in the controller class. The <netui> tags allow the JSP pages to both 
read from and write to Java code in the controller class. This is accomplished without placing any 
Java code on the JSP pages, greatly enhancing the separation of data presentation and data 
processing.

Java Server Faces (JSF) files can also be added to your web application, either as a replacement 
or complement to the JSPs.

Controller Classes

Data processing code is contained in Java classes called controller classes. Controller classes 
handle user navigation through the JSPs in the web application, handle user data submissions, call 
external resources such as web services and backend databases, and generally implement the 
core functionality of the web application.

For more infomation on the syntax of Controller classes, see the Apache Beehive documentation: 
Page Flow Controllers

Actions

Actions are methods in the Controller class that has been decorated with specially designed set 
of metadata annotations, or "annotations" for short. Annotations, a new feature in Java 5, are 
property setters for methods or classes. Beehive NetUI defines its own set of annotations that 
allow the controller class to easily communicate with the JSP pages, control navigation with the 
web application and manage application state.

For more infomation about actions, see the Apache Beehive documentation: Fleshing out the 
Controller and Actions in NetUI.
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Page Flows

JSPs and Controller classes are arranged in modular units called page flows. A page flow consists 
of a single controller class and any number of JSP files. Typically, a single page flow reflects some 
unit of functionality within a web application. For example, a company's web application might 
contain many different page flows, one for browsing the company's catalogue of products, another 
for collecting the products in a shopping cart, and another for managing customer accounts.

For more information on Page Flow modules, see the Apache Beehive documentation: Nested 
Page Flows, Page Flow Inheritance, and Shared Flow.

Implicit Objects

Beehive NetUI provides two types of implicit objects that can be used to move data around the 
application and save application state. 

1.  
JSP implicit objects: these are the standard set of JSP objects provided by the JSP 
implementation, such as session, pageContext, etc.

2.  
NetUI implicit objects: these objects are provided by the Beehive NetUI framework allowing 
access to objects in the Controller class, etc. 
 
For a list of the available objects see: Data binding to NetUI Implicit Objects in the Apache 
Beehive documentation.

Form Beans

Form Beans are a Java representation of a HTML form. When a user submits an HTML form, the 
submitted data is captured as a Form Bean and (typically) is passed to an action for further 
processing. 

For more information on Form Beans and their role in a NetUI web application, see NetUI Form 
Control Tags in the Apache Beehive documentation.

Validation and Exception Handling

Validation and exception handling are defined using a declarative programming model using 
annotations. For more information see Validation and Exception Handling in the Apache Beehive 
documentation.

Related Topics

NetUI: Getting Started
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The Page Flow Perspective

This topic describes Workshop for WebLogic's tooling features for building Beehive NetUI web applications.

Workshop for WebLogic provides a variety of views and graphical user interface tools to help you design, conceptualize and implement NetUI web applications.

Individual icons used in the Page Flow Perspective are described in the Page Flow Perspective Visual Glossary.

Page Flow Perspective

The Page Flow Perspective gives a graphical summary of an individual page flow.

Open the Page Flow Perspective by selecting Window > Open Perspective > Page Flow.

Note: If you already have a page flow-related file open, the Page Flow Perspective will display that file's page flow. If you don’t have a page flow-related file open, the Page Flow Perspective 
opens to the first page flow in the first page flow-enabled project that it finds. To switch the page flow displayed, you must explicitly switch to another page flow through one of the views, or 
make a page flow-related file from a different page flow the active document in the Source Editor View.

The Page Flow Perspective consists of these views:

●     

Page Flow Explorer View: shows a view of the functional parts of the current page flow

●     

Page Flow Editor View: shows a graphical view of a specific page flow node (action or page) and its neighboring nodes

●     Page Flow Overview: shows a diagram of the navigational structure between actions and pages 

●     

Source Editor View: shows the Java source of a page flow artifact

●     

Annotations View: shows the annotation currently selected in one of the above views

●     JSP Design Palette: shows available design elements that can be added to the current JSP page

●     JSP Data Palette: shows available data elements that can be added to the current JSP page

The following diagram shows the default locations for these views when the Page Flow Perspective is first opened. Only those views that are page flow-specific are described below. Other views, such as the 
Servers and Problems views are displayed by default, but they are not specifically designed to show page flow-related information.

Each of these views is described in detail below.
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Page Flow Explorer View
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For more information see Page Flow Explorer View.

Page Flow Editor View

For more information see Page Flow Editor View.

Page Flow Overview

For more information see Page Flow Overview.

Source Editor View

For more information see Source Editor View.

Annotations View

For more information see Annotations View.

JSP Design Palette

For more information see JSP Design Palette.

JSP Data Palette

For more information see JSP Data Palette View.

Related Topics

The following tutorials use many of the views and wizards described above:

Tutorial: Accessing a Database from a Web Application

Tutorial: Java Server Faces Integration

Also see the following topic:

Page Flow Perspective Visual Glossary
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Integrating Java Server Faces into a Web Application

Java Server Faces (JSF) is a web user interface technology that can be used to supplement the user interface 
technology native to Beehive NetUI (the <netui> tag library).

Enabling JSF in a Web Project

To install the default JSF implementation, add the JSF facet to your web project. (Project > Properties > Project 
Facets > Add/Remove Project Facets > place check next to JSF).

Adding the JSF facet will install JSF Reference Implementation 1.1.

Integrating JSF and Beehive NetUI

Beehive NetUI and JSF can be fully integrated in a web application. Below are described the most typical ways to 
make the two frameworks communicate.

Forwarding from a NetUI Action to a JSF Page

To forward from a NetUI action to a JSF page, refer to the JSF page with the .faces file extension, even though 
Workshop for WebLogic creates JSF pages on disk with the .jsp file extension.

Suppose you have a JSF page named myJSFPage.jsp. To forward to this page from an action, use the following 
syntax:

        @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "myJSFPage.faces") } )
        public Forward navigate() {
                return new Forward("success");
        }

Raising NetUI Actions from JSF Pages

JSF pages can raise NetUI actions through the action attribute.

For example, assume you have the following action in a NetUI controller file.

        @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "myJSFPage.faces") } )
        public Forward navigate() {
                return new Forward("success");
        }

You can invoke this action from a JSF by referencing navigate in an action attribute: 

    <h:form>
    ...
        <h:commandButton action="navigate" value="Go"/>
    </h:form>

Raising NetUI Actions from JSF Backing Beans

Suppose you have an action navigate in a Controller class. To invoke navigate from within a JSF backing bean, 
use a command handler decorated with the annotation set @Jpf.CommandHandler/@Jpf.RaiseAction:
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    @Jpf.CommandHandler(
        raiseActions={
            @Jpf.RaiseAction(action="navigate")
        }
    )
    public String invokeNavigate()
    {
        return "navigate";
    }

You bind to the command handler from the JSF page in the usual way:

    <h:commandButton action="#{backing.invokeNavigate}" value="Go"/>

Calling Controls from JSF Backing Beans

You call a control from a backing bean just as you would call a control from any Java class.

First you declare the control on the client Java class.

    import org.apache.beehive.controls.api.bean.Control;
    
        ...
    
    @Control
    private CustomerControl customerControl;

Then you invoke methods on that control.

    public Customer[] getCustomers() {
                return customerControl.someMethod();
        }

Passing Data Between JSF Pages and NetUI Actions

JSF pages can reference NetUI implicit objects using JSF expressions. For example, the following JSF page receives 
a page input from the NetUI controller class:

<%@ page language="java" contentType="text/html;charset=UTF-8"%>
<%@ taglib prefix="h" uri="http://java.sun.com/jsf/html"%>
<%@taglib uri="http://beehive.apache.org/netui/tags-databinding-1.0" prefix="netui-data"%>

<netui-data:declarePageInput required="true" type="java.util.ArrayList<businessObjects.Customer>" 
name="getCustomersResult" />

...

    <h:dataTable value="#{pageInput.getCustomersResult}" var="item0" border="1">

        ...

    </h:dataTable>

References are not limited to the pageInput implicit object; you can reference any implicit object using JSF-style 
expressions. For example, the following expression references the foo field on the controller class:

    <h:outputText value="#{pageInput.foo}"/>
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You can also submit data (as a form bean) from a JSF page to a NetUI Controller class.

Suppose you have an action that has a form bean parameter:

        @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "confirm.faces") } )
        public Forward getCustomers(Customer form) {
            
                // do something with the submitted form data...
                
                return new Forward("success");
        }

A form bean is a Java representation of an HTML form, where the bean properties correspond to the fields in the 
HTML form.

public class Customer implements Serializable
{
    private String first = "";
    private String last = "";
   
    public Customer()
    {
    }
    
    public Customer(String first, String last)
    {
        this.first = first;
        this.last = last;
    }

    public void setFirst(String value)
    {
        first = value;
    }

    public String getFirst()
    {
        return first;
    }

    public String getLast()
    {
        return last;
    }

    public void setLast(String value)
    {
        last = value;
    }
} 

To submit this form bean to the action from a JSF page, reference the bean with a JSF style expression:

    <h:form>
        <h:outputLabel value="First:" for="field1" />
        <h:inputText value="#{backing.custFormBean.first}" id="field1" />
        <h:outputLabel value="Last:" for="field2" />
        <h:inputText value="#{backing.custFormBean.last}" id="field2" />
        <h:commandButton action="getCustomers" value="Submit">
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            <f:attribute name="submitFormBean" value="backing.custFormBean" />
        </h:commandButton>
    </h:form>

Note that the form bean is referenced via the backing bean. See the italic expressions above: #{backing.
custFormBean.first}, #{backing.custFormBean.last}, and backing.custFormBean.

For these expressions to work, the backing bean must include the form bean as a field, with appropriate setters 
and getters on that field:

@Jpf.FacesBacking()
public class index extends FacesBackingBean {
 
    private Customer custFormBean = new Customer();
 
    public Customer getCustFormBean() {
        return custFormBean;
    }
 
    public void setCustFormBean(Customer bean) {
        this.custFormBean = bean;
    }
}

Other Integration Scenarios

Other integration scenarios are described in the document Integrating JavaServer Faces with Beehive Page Flow.

Mixing JSF and NetUI Tags

Mixing Beehive NetUI tags, or any JSP tags, with JSF tags can lead to surprising results. You should have a good 
understanding of the particular tags you are using before you mix the different tag libraries.  
 
An exception you do not need to worry about is the use of the Beehive NetUI <netui-data:declarePageInput> tag. 
This tag can be used freely with JSF tags because it only sets up a contract with the NetUI controller class but not 
affect the view in any other way.

Workshop for WebLogic JSF Tooling Features 

Workshop for WebLogic offers development support for may common JSF coding tasks, including:

1.  automatic generation of backing beans

2.  JSF-specific code generation for forms and data grids

3.  support for authoring command handlers

To activate JSF development support you must be in the Page Flow perspective (Window > Open Perspective > 
Page Flow).

JSF-Specific Code Generation Through the JSP Data Palette

In the Page Flow perspective, the Data Palette supports JSF tags and JSF style expressions when composing JSF 
pages.

Note: the Data Palette recognizes JSF pages by the presence of the JSF tag <f:view> on the page. If the following 
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tag (and its associated library declaration) is present on the page, then the Data Palette will generate code in JSF 
mode:

    <%@ taglib prefix="f" uri="http://java.sun.com/jsf/core"%>
    ...
    <f:view>

Note that any prefix value is acceptable; the prefix value 'f' is shown only because it is the default value.

For example, suppose you have a JSF page with a page input declaration:

<netui-data:declarePageInput
        type="java.util.ArrayList<businessObjects.Customer>"
        name="getCustomersResult" />

The presence of a page input declaration will activate the Data Palette with a corresponding node:

When this node is dragged and dropped onto the JSF page, JSF tags are used to construct the data display 
structures. For example:

<h:dataTable value="#{pageInput.getCustomersResult}" var="item0"
                border="1">
                <h:column>
                        <f:facet name="header">
                                <h:outputLabel value="Name" />
                        </f:facet>
                        <h:outputText value="#{item0.name}" />
                </h:column>
        </h:dataTable>

Workshop for WebLogic will create outputText fields for simple properties and launch the Data Display Wizard for 
complex and/or repeating type properties. 
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JSF-Specific Code Generation Through the JSP Design Palette

Similar support is provided for composing JSF forms through the Design Palette.

When a page contains a declaration for the core JSF core library (<%@ taglib prefix="f" uri="http://java.
sun.com/jsf/core"%>), the the Design Palette will be in 'JSF mode'. Forms and data grids created from the Design 
Palette will use JSF tags and JSF expressions.

JSF Command Handler Support

You can easily add command handlers to a JSF backing bean by right-clicking the Command Handler node and 
selecting New Command Handler. (You must be in the Page Flow perspective to see the Command Handler 
node.)
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The wizard allows you to setup command handler method that can raise actions in the controller class. The wizard 
also lets you specify a form bean that can be passed along to the raised action. For details on passing form bean 
data from a JSF page to a controller action, see Passing Data Between JSF Pages and NetUI Actions above.

You can also add control references to a backing bean in a similar manner:

Related Topics

dev2dev documentation: Integrating JavaServer Faces with Beehive Page Flow
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Tutorial: Java Server Faces Integration
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Web Application Technologies

This topic lists the versions and locations of the web application technologies used by BEA 
Workshop for WebLogic Platform.

Web Application Technologies Versions

The following table lists the versions of standard web technologies used by Workshop for 
WebLogic.

The JAR resources listed below are made available to a web application through library modules, 
essentially JARs packaged as WARs and EARs. You add these library modules to your web 
application by adding the corresponding facet to your web application. For instance to add the JSF 
library module, right-click your project and select Properties > Project Facets > Add/Remove 
Project Facets > [Place a check next to JSF].

Technology Version
Library Module 
Location JARs

Struts 1.2 BEA_HOME/
weblogic100/
common/
deployable-
libraries/struts-1.2.
war

struts.jar

Beehive NetUI 1.0.1 
(see Beehive 
Version note below)

BEA_HOME/
weblogic100/
common/
deployable-
libraries/beehive-
netui-1.0.war

beehive-netui-core.jar, 
beehive-netui-tags.jar 

Beehive Controls 1.0.1 
(see Beehive 
Version note below)

BEA_HOME/
weblogic100/
common/
deployable-
libraries/beehive-
controls-1.0.war

beehive-controls.jar, beehive-
ejb-controls.jar, beehive-jdbc-
controls.jar, beehive-jms-
controls.jar

JSTL (JSP 
Standard Tag 
Library)

1.1 BEA_HOME/
weblogic100/
common/
deployable-
libraries/beehive-
jstl-1.1.war

jstl.jar, standard.jar

JSF (Java 
Server Faces)

1.1.01  
(see JSF 
Implementations 
note below)

BEA_HOME/
weblogic100/
common/
deployable-
libraries/jsf-1.1.
war

jsf-api.jar, jsf-impl.jar
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JSF Implementations

WebLogic Platform ships two JSF implementations: (1) Sun's reference implementation 1.1.01 and 
(2) MyFaces 1.1.1. Workshop for WebLogic uses Sun's reference implementation 1.1.01 by default 
when the JSF facet is added to a web project.

Beehive Version

The version of Beehive is 1.0.1 with some minor local fixes made by BEA. These fixes will be 
rolled back into the Apache Beehive code base at a later date.

Related Topics

none
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Authoring Web-based User Interfaces

The following topics explain how to author web-based user interfaces using Workshop for 
WebLogic. 

Workshop for WebLogic provides support for the following user interface technologies: (1) the 
JavaServer Pages Standard Tag Library and (2) the Beehive NetUI tag libraries (3) Java Server 
Faces and (4) Tiles.

Overview: NetUI Tag Libraries
Explains the contents of the three NetUI tag libraries. 

Creating Forms for Collecting User Data
Explains how to create forms for user input.

Displaying Data with NetUI Data Grids
Explains how to display tabular data using data grids.

Using JavaScript in NetUI and Portal Applications
Explains how to use JavaScript on a JSP page.

Validating User Input Data
Explains how to use Workshop for WebLogic's validation tools.

Using Tiles
Explains how to use Tiles technology in a Beehive NetUI web application. 

Rendering Trees
Explains how to render HTML trees.

Controlling Web Application Look and Feel with JSP Templates
Explains how to use JSP templates in a web application.

Authoring JSP Template Projects and Populating the Default Template List
Explains how to author JSP template projects.

Related Topics

NetUI Tag Library Overview
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Overview: Beehive NetUI Tag Library 

Beehive NetUI provides three tag libraries:

1.  
core HTML library: renders basic HTML elements

2.  
data grid library: renders tables and filterable/sortable data grids

3.  
JSP template library: renders reusable page elements such as headers, footers, etc.

These three libraries are described in more detail below.

The Core HTML Tag Library

To use the core HTML library, enter the following declaration on your JSP page: 

    <%@taglib uri="http://beehive.apache.org/netui/tags-html-1.0" prefix="netui"%>
  

For a list of the tags available see:

netui Library

The Data Grid Tag Library

To use the data grid library, enter the following declaration on your JSP page: 

    <%@taglib uri="http://beehive.apache.org/netui/tags-databinding-1.0" prefix="netui-data"%>
  

For a list of the tags available see:

netui-data Library

The Template Tag Library

To use the template library, enter the following declaration on your JSP page: 

    <%@taglib uri="http://beehive.apache.org/netui/tags-template-1.0" prefix="netui-template"%>
  

For a list of the tags available see:

netui-template Library

Related Topics
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NetUI Tag Library Overview
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Creating Forms for Collecting User Data

The following topic describes how Beehive NetUI supports the submission of user data. 

HTML Forms and Form Beans

Suppose you want your web application to collect data from users, such as the user's name, email, etc. Beehive NetUI 
supports user data submission through a three step process: (1) First the user enters data into an ordinary HTML form. 
(2) Upon submission that data is loaded into a Java object called a form bean. (3) Once the submitted data has been 
packaged as a form bean, the Controller class is free to operate on the data: typically the form bean is passed to one of 
the Controller class's action methods for further processing.

Form beans are Java representations of the user-facing HTML form. In particular they are standard JavaBean 
representations of HTML forms: for each data field in the HTML form, the form bean has a corresponding member field 
and getter/setter methods. For example, the following HTML form has two data fields: firstname and lastname. 

  <netui:form action="updateCustomer">
                <netui:textBox dataSource="actionForm.customer.firstName" id="field2"></netui:textBox>
                <netui:textBox dataSource="actionForm.customer.lastName" id="field3"></netui:textBox>
  </netui:form>

Its corresponding form bean has two member fields, the Strings firstname and lastname, each with setter/getter fields:

public class Customer implements Serializable {
 
        private static final long serialVersionUID = 1L;
   
        private String firstName = "";

        private String lastName = "";

        public Customer(String firstName, String lastName) {

                this.firstName = firstName;
                this.lastName = lastName;
        }

        public String getFirstName() {
                return firstName;
        }

        public void setFirstName(String firstName) {
                this.firstName = firstName;
        }
        
        public String getLastName() {
                return lastName;
        }

        public void setLastName(String lastName) {
                this.lastName = lastName;
        }
}

An instance of this form bean gets passed to the action method for further processing by the Controller class.

public Forward updateCustomer(Customer form)
{
    ...
}
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For more infomation about form beans, HTML forms and action methods see the Apache Beehive documentation 
Handling Forms.

Repeating Form Elements

The Beehive NetUI tag libraries supports advanced form element repeater tags. These tags allow you to render forms 
dynamically. For more information on dynamically rendered repeating forms, see the Apache Beehive documentation 
NetUI Repeating Form Control Tags. 

Using the Create Form Wizard

Workshop for Weblogic Platform provides powerful tools for building Beehive NetUI forms. For more information see 
Tutorial: Accessing Controls from a Web Application: Step 4: Create a Page to Edit Customer Data.

Related Topics

NetUI Form Control Tags

NetUI Repeating Form Control Tags
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Displaying Data with NetUI Data Grids

BEA Workshop for WebLogic Platform provides tools for creating Beehive NetUI data grids. Data 
grids provide a powerful way for users to interact with tabular data, such as a record set from a 
database. For example, a data grid can render a record set as a sortable and filterable HTML table.

Data grids are rendered using the Beehive NetUI tag <netui-data:dataGrid> and its associated 
children tags. To render a record set as an HTML table, pass a data set (for example, an Array of 
objects) to the <netui-data:dataGrid> tag's dataSource attribute:

<netui-data:dataGrid dataSource="pageInput.employeeArray" name="employeeGrid">

For more information about the <netui-data:dataGrid> syntax see Beehive NetUI Data Grids and 
netui-data:dataGrid Tag

Using the Data Display Wizard

Workshop for WebLogic provides a wizard that can define data grid properties. For more 
information using the data grid wizard see Tutorial: Accessing Controls from a Web Application: 
Step 3: Create a Data Grid

Using the <netui-data:repeater> and Related Tags

Related Topics

Beehive NetUI Data Grids

Sorting and Filtering in a Data Grid
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Using JavaScript in NetUI and Portal Applications

The following topic explains how to access page elements, such as forms and user input elements, 
with JavaScript and how to ensure that each occurrence of the id attribute on a page is unique.

Beehive documentation: Tags Support for JavaScript

Related Topics

Validating User Input Data

Beehive documentation: <netui:scriptContainer>
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Validating User Input Data

The Beehive NetUI tag libraries provide annotations for validating form data submitted by users.

You can develop validation processes by working with the validation annotations directly in source 
code or you can use Workshop for WebLogic's validation tools. Workshop for WebLogic's validation 
tools provide a graphical user interface for developing validation processes.

Related Topics 

Validation Rules Dialog

Set Message Bundle Dialog

Apache Beehive documentation: Validation 
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Using Tiles

Apache Beehive supports Struts Tiles technology. Struts Tiles allows to you reuse common web 
application components such as menu bars, headers, and footers. 

For more information about support for Struts Tiles see Tiles Support.

Related Topics

Tiles Support
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Rendering Trees

The Beehive NetUI tag libraries provide tags for rendering tree structures, allowing you to display 
a list of links arranged as expandable/collapsible tree nodes.

For more infomation on rendering trees, see the Apache Beehive documentation Tree Tags. 

Related Topics

Tree Tag 
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Controlling Web Application Look and Feel with JSP/JSF Templates

BEA Workshop for WebLogic Platform allows you to set a default JSP template to use for all new JSP pages created 
with a given project or workspace.

Setting the Default Template for a Workspace

To set the default JSP template for all of the projects with a given workspace, select Windows > Preferences > File 
Templates > Default JSP/JSF Template:

The list of available templates is populated from any template projects in the workspace or any installed template plug-
ins.

Clicking the checkbox next to a template designates it as the default template. But selecting a template label (not the 
checkbox) will show the template description and a preview of which files will be created. Note that the locations and 
names are shown in the abstract here since the actual location and file names are not known until the time of creation.

Setting the Default Template for a Project
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To override the workspace default template setting for a given individual project, right-click the project folder and 
select Properties > File Templates > Default JSP Template.

If the checkbox Use Project Settings is unchecked the workspace default settings are used. If checked then the 
project settings will override the workspace settings.

Note: In the Page Flow perspective, if you right-click the Pages node, and select Set Default Page Template the 
same project-level dialog will open.

Specifying a Template for a New JSP 

In the Page Flow perspective, JSP template selection is part of the new JSP wizard.

To enter the new JSP wizard, select File > New > Workshop JSP. 
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Related Topics

Authoring JSP Template Projects
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Authoring JSP Template Projects 

This topic explains how to create a JSP template project. A JSP template project contains one or more JSP templates and 
adds those templates to the list of possible default JSP templates. For more information on setting the default JSP template 
see Controlling Web Application Look and Feel with JSP Templates.

Creating a JSP Template Project

Any project can be converted into a JSP template project, provided it has the appropriate the project nature. To define a 
project as a JSP template project, add the template project nature to the project's .project file:

    <natures>
        ...
        <nature>com.bea.workshop.common.filetemplate.core.templateProjectNature</nature>
        ...
    </natures>

The .project file resides in the root of a project directory. To view the .project file, switch to the Navigator view: Window > 
Show View > Navigator.

The template project nature will cause Workshop for WebLogic to recognize the project as a template project.

JSP Template Project Structure

A JSP template project consists of the following elements: 

●     

the .project file is configured appropriately (see Creating a JSP Template Project above)

●     

a templateProject.xml file at the root of the template project directory

●     

any number of template resource files: JSP page templates, CSS files, image files, etc. 

The set of files contained in a give template is defined by the templateProject.xml file. The following sample 
templateProject.xml file defines one template called "BEA Branded NetUI JSP". Multiple templates can be defined in a given 
templateProject.xml file.

<?xml version="1.0" encoding="UTF-8"?>
<template-project xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
  <template id="com.bea.demo.filetemplate.NetUIJSP"
            name="BEA Branded NetUI JSP"
            typeClass="com.bea.workshop.web.jsp.core.beans.JSPBaseBean">
    <description>A NetUI-enabled JSP with BEA Branding</description>
    <source-ref context="JSPBaseBean" source="com.bea.demo.filetemplate.NetUIJSP.source" />
    <source-ref context="FileTemplateBean" source="com.bea.demo.filetemplate.dataGrid.css.source" />
    <resource-ref resource="com.bea.demo.filetemplate.logo_bea_tl.gif.source" outputpath="WebContent/
resources/images/logo_bea_tl.gif" />
    <resource-ref resource="com.bea.demo.filetemplate.rt_blue_bkgnd.jpg.source" outputpath="WebContent/
resources/images/rt_blue_bkgnd.jpg" />
    <resource-ref resource="com.bea.demo.filetemplate.sp.gif.source" outputpath="WebContent/resources/
images/sp.gif" />
  </template>
  <source id="com.bea.demo.filetemplate.NetUIJSP.source" file="WebContent/index.jsp" type="jsp"></source>
  <source id="com.bea.demo.filetemplate.dataGrid.css.source" file="WebContent/resources/datagrid.css" 
type="css"></source>
  <resource id="com.bea.demo.filetemplate.logo_bea_tl.gif.source" path="images/logo_bea_tl.gif" />
  <resource id="com.bea.demo.filetemplate.rt_blue_bkgnd.jpg.source" path="images/rt_blue_bkgnd.jpg" />
  <resource id="com.bea.demo.filetemplate.sp.gif.source" path="images/sp.gif" />
</template-project>
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For information on creating a templateProject.xml file, see templateProject.xml Configuration File.

For an example JSP template project open the SamplesWorkspace. Instructions on opening the SamplesWorkspace are 
available at Opening a Sample Workspace.

Supported Character Encodings

Because of the way templates are processed, the files included in a template must to be encoded in UTF-8. Any other 
character encoding will result in an error. 

JSP Template Plugins

A JSP template project can also be packaged as a plugin. Template plugins are nothing more than template projects that 
have the templateProject plugin point defined.

For an example of a template plugin see BEA_HOME/tools/workshop/com.bea.workshop.netui.core_1.0.0

Upgrading JSP Template Projects from Workshop for WebLogic Version 9.2 to 10.0

You must make the following changes to your JSP template projects after upgrading from version 9.2 to 10.0.

1.  In the templateProject.xml file, occurrences of com.bea.wlw.jsp.core.beans.JSPBaseBean should be changed to 
com.bea.workshop.web.jsp.core.beans.JSPBaseBean.

2.  In the templateProject.xml file, occurrences of com.bea.wlw.jsf.core.beans.JSFBaseBean should be changed to 
com.bea.workshop.web.jsf.core.beans.JSFBaseBean.

3.  In the .project file, the project nature should be changed from com.bea.wlw.filetemplate.core.
templateProjectNature to com.bea.workshop.common.filetemplate.core.templateProjectNature.

Note that the .project file is editable from the Navigator view (Window > Show View > Other > General > 
Navigator). 

Related Topics

Controlling Web Application Look and Feel with JSP Templates

templateProject.xml Configuration File
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Web Application Dialogs

These dialogs and wizard are designed to help you create web applications.

Topics Included in This Section

Associated Files for Page Flow Controllers Dialog
Set the locations for page flow files.

Conditional Forward Dialog 
Create a forward that is conditional on a JSP 2.0 expression.

Create Form Wizard
Create a new form for user data submission.

Data Display Wizard
Create a table or list for display of complex data sets.

Data Grid Wizard
Create a data grid table for display of a data set.

Default JSF Template Preferences Dialog
Set the default JSF template at the workspace-level.

Default JSP Template Preferences Dialog
Set the default JSP template at the workspace-level.

Default JSP Template Properties Dialog
Set the default JSP template at the project-level.

Edit Action Output Dialog
Edit action output and page inputs.

JSF Backing Files Dialog
Set the location for Java backing files for new JSF pages.

JSP Data Palette View
Drag and drop data objects onto a JSP page.

JSP Design Palette View
Drag and drop common design elements and tags onto a JSP page.

JSP Design Palette Preferences
Populate the JSP Design Palette with JSP tag libraries. Population settings apply to all 
projects in a workspace.

JSP Design Palette Properties
Populate the JSP Design Palette with JSP tag libraries. Population settings apply at the 
individual project-level.
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New Action Wizard
Create a new action in a controller class.

New Anchor Dialog
Create a new HTML anchor.

New Command Handler Dialog
Create a new JSF command handler.

New Image Anchor Dialog
Create a new image anchor tag.

New JSF Page Dialog
Create a new JSF page based on a JSF template.

New JSP Page Dialog
Create a new JSP page based on a JSP template.

New Page Flow Dialog
Create a new page flow.

New Shared Flow Dialog
Create a new shared flow controller class.

New Dynamic Web Project Wizard
Create a new web project.

Page Flow Editor View
Graphically edit a page flow.

Page Flow Source Editor View
Edit page flow source directly.

Page Flow Explorer View
Provides a logical/structural view of a page flow.

Page Flow Overview
Provides a logical/structural view of a complete page flow.

Page Flow Visual Glossary
Describes icons used in the Page Flow Perspective.

Select Properties Dialog
Select fields to be displayed in a data grid, form, etc.

Suppressible Dialogs Preferences
Suppression settings for selected web application-related dialogs.

Update Form Wizard
Create a new form for updating an individual record in a data set.
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Set Message Bundle Dialog
Select or create a message bundle file.

Validation Rule Dialog
Create and edit validation rules for data submission.

Related Topics

none.
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Associated Files for Page Flow Controllers Dialog

Use this dialog to set the Java source folder where new controller files are created by default.

Note: This dialog is specifically designed for cases where (1) a web project has more than one 
source folder defined and (2) when the user creates a new page flow under the web content 
folder rather than one of the source folders. Upon creation of a new page flow, the controller 
file will be saved to the default source directory specified by this dialog.

How To Open this Dialog

To open this dialog, select Project > Properties > Associated Files Model > Page Flow Controllers.

How To Use This Dialog

The source files for a give page flow reside in two different, but parallel, directories: 

●     

JSP files reside in the web content folder. The default location is /<ProjectRoot>/WebContent/. 

●     

controller files (and other JAVA source files) reside in the source folder. The default value is /
<ProjectRoot>/src. (It is possible to have multiple source folders in a project. In such cases, 
controller files for new page flows are created in the source folder specified by this dialog.)

For example, a typical web project will be structured as follows:

     <ProjectRoot>
        src
            pageFlow1
                Controller1.java
            pageFlow2
                Controller2.java
        WebContent
            pageFlow1
                index.jsp
            pageFlow2
                index.jsp          
 

The JAVA and JSP files of a page flow are associated because the contents of the source folder(s) and 
web content folder have parallel directory structures. For differences with earlier versions of Workshop 
for WebLogic, see Upgrade Changes for Co-Location in Page Flows.

The default locations of the JSP and controller files can be set at project creation. For details see New 
Dynamic Web Project Wizard.

This dialog controls the default location for controller files for new page flows, previous created controller 
files will not be moved.
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Associated Files for Page Flow Controllers Dialog

Related Topics

New Dynamic Web Project Wizard

New Page Flow Dialog

Upgrade Changes for Co-Location in Page Flows
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Conditional Forward Dialog

Use this dialog to specify the condition for a conditional forward. 

A conditional forward is executed only if its condition is true. For example, in an online store, the 
shopping cart page is shown to users on the condition that they are logged in.

The condition should resolve to a boolean value and be expressed in the JSP 2.0 expression 
language.

How To Open this Dialog

In the Page Flow Editor view, right-click downstream of any simple action and select New JSP. If 
the simple action already has a forward associated with it, then the Conditional Forward Dialog 
will appear. 

How To Use This Dialog

Enter any JSP 2.0 expression into the Expression field.

A new @Jpf.ConditionalForward annotation will be added to the action.

Related Topics

Sun JSP documentation: JSP 2.0 expression language

Beehive documentation: @Jpf.ConditionalForward
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Create Form Wizard

Use this wizard to create new Beehive HTML forms and select/create an associated action. 

How To Open This Wizard

To open the Create Form wizard:

1.  
View a JSP or JSF page in the Page Flow perspective: Window > Open Perspective > 
Page Flow.

2.  
Open the Create Form wizard: From the JSP Design Palette, drag and drop the Create 
Form icon unto the JSP page.

How to Use this Wizard

Select Action Page

The Select Action page allows you to select an existing action or create a new action to handle 
submission of the Beehive HTML input form. (The submitted data will be used to construct a form 
bean instance, and this form bean instance will be passed to the action you select/create here.)
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Create Form Wizard

Select Properties Page

Select the input form fields that you want to expose on the JSP page. The list of available fields is 
taken from the form bean fields.
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Create Form Wizard

Arrange Fields Page

Select the order in which the input fields will appear on the JSP page.
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Create Form Wizard

Related Topics

JSP Design Palette

Creating Forms for Collecting User Data
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Data Display Wizard

Use this wizard to display a repeating data set as a list or table.

How To Open This Wizard

To open the Data Display wizard:

1.  
View a JSP or JSF page in the Page Flow perspective: Window > Open Perspective > 
Page Flow.

2.  
Open the Create Form wizard: From the JSP Design Palette, drag and drop the Data 
Display icon unto the JSP page.

How to Use this Wizard

Specify Data Page

This page specifies the data set to be rendered as an HTML list or table.
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Data Display Wizard

Select Properties Page

This page specifies the fields of the data set to be rendered in the HTML list or table.
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Data Display Wizard

Arrange Fields Page

This page specifies the order in which the fields are rendered.
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Data Display Wizard

Select Format Page

This page specifies how the data set is rendered: as an HTML table, list, or as plain text.
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Data Display Wizard

Related Topics

JSP Design Palette

Data Grid Wizard
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Data Grid Wizard

Data Grid Dialog

Use this wizard to render a data set as a filterable/sortable HTML table. The HTML table is 
rendered using a Beehive NetUI data grid.

How To Open this Dialog

To open the Data Grid wizard:

1.  
View a JSP page in the Page Flow perspective: Window > Open Perspective > Page Flow.

2.  
Open the Create Form wizard: From the JSP Design Palette, drag and drop the Data Grid 
icon unto the JSP page.

How to Use this Dialog

General Tab

The Data source area specifies the data set and the data type of the object to be rendered.

The Grid name specifies a unique name for the grid.

The Style prefix specifies a string prefix that prepends (or replaces) the values for the class 
attribute in the rendered HTML tags. For detailed description of this behavior see CSS Attributes in 
the Apache Beehive documentation.
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Data Grid Wizard

 

Columns Tab

The Grid columns area specifies the properties for a given column in the rendered HTML table.

Header Text specifies the label displayed at the top of the column.

Render As specifies how the content of the column is rendered. Possible values are:
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●     

Text: content rendered as plain text

●     

Text Anchor: content rendered as a text link

●     Image: content rendered as an image

●     Image Anchor: content rendered as an image link

●     Custom Markup: content rendered as a user specified HTML markup

Further properties are specified in the Column Properties.

Content Source specifies the source of the column. 

1.  
Data: specifies a data binding expression

2.  
Static: specifies literal text

The Column properties area specifies detailed properties for the column content. 
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Data Grid Wizard

Pager Tab

The Pager tab specifies properties for links that navigate through the HTML table.
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Data Grid Wizard

Related Topics

Apache Beehive documentation: <netui-data:grid>

Tutorial: Accessing Controls from a Web Application: Step 3: Create a Data Grid
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Default JSF Template: Workspace Preferences Dialog

Use this dialog to set the JSF template preferences for all projects in a workspace. 

How To Open this Dialog

To open this dialog, select Windows > Preferences > File Templates > Default JSF Template

How To Use this Dialog

For details on using this dialog see Controlling Web Application Look and Feel with JSP/JSF Templates.

Related Topics

Controlling Web Application Look and Feel with JSP/JSF Templates

Authoring JSP Template Projects 
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Default JSP Template: Workspace Preferences Dialog

Use this dialog to set the JSP template preferences for all projects in a workspace. 

How To Open this Dialog

To open this dialog, select Windows > Preferences > File Templates > Default JSP Template

How To Use this Dialog

For details on using this dialog see Controlling Web Application Look and Feel with JSP/JSF Templates.

Related Topics

Controlling Web Application Look and Feel with JSP/JSF Templates

Authoring JSP Template Projects 
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Default JSP Template: Project Properties Dialog

Use this dialog to set the default JSP template for a given project. The default set here overrides any workspace-level 
preferences.

How To Open this Dialog

In the Page Flow Explorer view, right-click the Pages node, and select Set Default Page Template.

In Project Explorer view, select the target project, and select File > Properties > File Templates > Default JSP 
Template

How To Use this Dialog

For details on using this dialog see Controlling Web Application Look and Feel with JSP/JSF Templates.

Related Topics
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Controlling Web Application Look and Feel with JSP/JSF Templates

Authoring JSP Template Projects 
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Edit Action Output Annotations Dialog

Use this dialog to specify the contract between action outputs and page inputs. Action outputs 
document the data objects passed along a given forward; page inputs document the data objects 
expected by a given JSP. For more information see Page Inputs and @Jpf.ActionOutput in the 
Apache Beehive documentation.

How To Open This Dialog

To open this dialog, from the Page Flow Editor right-click on any arrow that points from a 
method Action icon (colored blue) and select Edit Action Outputs. 

Note that simple Action icons (colored green) must first be converted to method Actions before 
the Edit Action Outputs option is available. To convert a simple Action to a method Action, right 
click the simple Action icon and select Convert to a Method.

Note that this dialog does not, all by itself, ensure that a data will be send from an action method 
to a JSP page. To actually transport data the user must programatically attach data to the 
pageInput context. For details, see Page Inputs and @Jpf.ActionOutput in the Apache Beehive 
documentation. 

How To Use This Dialog

To create a new action output click the New button. This will place a new @Jpf.ActionOutput 
annotation on the method Action's @Forward annotation.

To create a new page input on a JSP page, click the Copy button.
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Edit Action Output Annotations Dialog

 

Related Topics

Apache Beehive documentation: Page Inputs 

Apache Beehive documentation: @Jpf.ActionOutput

Tutorial: Accessing Controls from a Web Application: Step 3: Create a Data Grid 
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JSP Data Palette View

Use this view to to drag and drop data objects onto a JSP page in order to create data displays.

How To Open This View

To open this view, select Window > Open Perspective > Page Flow. The view appears in the 
lower right by default.

How to Use this View

This view displays the data objects that are available to a JSP page based on the contents of the 
JSP page's <netui-data:declarePageInput> tag.

For example, assume that the following <netui-data:declarePageInput> tag appears on a JSP page.

    <netui-data:declarePageInput name="getCustomersResult" type="model.Customer[]" />

The above tag will cause the JSP Data Palette to be populated with the getCustomersResult data 
object, as shown below.

The JSP Data Palette also shows:

1.  
public JavaBean properties belonging to the page flow controller class.

2.  
public JavaBean properties from any shared flows referenced by the page flow controller.
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3.  
public JavaBean properrties from the backing file of a netui-enabled JSF page. 

Related Topics

The Page Flow Perspective

Page Flow Perspective Visual Glossary

Tutorial: Accessing Controls from a Web Application: Step 3: Create a Data Grid
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JSP Design Palette View

Use this view to drag and drop JSP tags onto a JSP page. 

You can also use this view initiate common wizards:

●     

Create Form Wizard

●     

Data Display Wizard

●     

Data Grid Dialog

How To Open This View

To open this view, select Window > Open Perspective > Page Flow. The view appears in the 
lower left by default.

How to Use this View

This view lists the JSP tags available for drag and drop onto a JSP page. To control the population 
of the list, use the JSP Design Palette Preferences Dialog and the JSP Design Palette Project 
Properties Dialog.

The view also lists common wizards to help design JSP pages, such as the form creation wizard. 
To initiate a wizard, drag and drop it onto a JSP page.
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Related Topics

The Page Flow Perspective

Page Flow Perspective Visual Glossary

JSP Design Palette Preferences Dialog 

JSP Design Palette Project Properties Dialog

Create Form Wizard

Data Display Wizard

Data Grid Dialog
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JSP Design Palette Preferences Dialog

Use this dialog to populate the JSP Design Palette with tag libraries. 

Settings made in this dialog apply to all projects in a workspace. To override these settings at the project-level, use the 
JSP Design Palette Project Properties Dialog.

How To Open This Dialog

To open this dialog, select Window > Preferences > Web and XML > JSP Design Palette.

How To Use This Dialog

Move tag libraries from the right-hand list to the left-and list to display the library on the JSP Design Palette.

Note: when a tag library's TLD files are placed in a valid location according to its JSP specification (JSP 1.1, 1.2 
and 2.0 are supported), it will be displayed in the JSP Design Palette. It will also be listed in the left-hand 
column (Visible tab libraries) of this dialog.
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Related Topics

JSP Design Palette
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JSP Design Palette Project Properties Dialog

Use this dialog to populate the JSP Design Palette with tag libraries. 

Settings made here apply only to an individual project and can override workspace-level settings. To create workspace-
level settings use the JSP Design Palette Preferences Dialog.

How To Open this Dialog

To open this dialog, open the Project Explorer and select Project > Properties > JSP Design Palette.

How To Use This Dialog

Move tag libraries from the right-hand list to the left-and list to display the library on the JSP Design Palette.

To override workspace-level settings, place a checkmark next to Use Project Settings.

Related Topics
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JSP Design Palette 

JSP Design Palette Preferences Dialog
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New Action Wizard

Use this wizard to create new actions in a NetUI controller class.

How To Open This Wizard

There are three ways to open this wizard:

●     

Inside the Page Flow perspective, right-click anywhere inside the Page Flow Editor and select New Action.

●     

Inside the Page Flow perspective, right-click the Actions node in the Page Flow Explorer.

●     Inside the Page Flow perspective, right-click anywhere within JSP source and select Insert > Action.

How To Use This Wizard

This wizard provides different templates for creating different kinds of actions. The template is selected from the dropdown list named Action 
Templates.

The following table describes each available template shows typical action code created by the template.

Action Template Descriptions

Template Description
Simple 
Declarative 
Action

Adds a @Jpf.SimpleAction annotation to the controller class.

    @Jpf.Controller(simpleActions = {
        @Jpf.SimpleAction(name = "simpleDeclarativeAction", ...) }
    public class CustomerManagementController extends PageFlowController

Basic Method 
Action

Adds a minimal action method to the controller class.

    @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "customers.jsp") })
    public Forward basicMethodAction(FormBean form) {
        Forward forward = new Forward("success");
        return forward;
    }
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Control 
Method Call

Adds an action method that (1) takes a Form Bean parameter (provided the control method takes input), (2) calls a control 
method, and (3) forwards the result of the control method to a page input (provided the control method returns something other 
than void).

    @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "customers.jsp", actionOutputs = { @Jpf.
ActionOutput(name = "returnValueName", type = model.Customer.class) }) })
    public Forward controlMethodCall(FormBean form) {
        Forward forward = new Forward("success");
        java.lang.Integer id = form.getCustomer().getId();
        model.Customer returnValueName = customerControl.getCustomerById(id);
        forward.addActionOutput("returnValueName", returnValueName);
        return forward;
    }

Get Item For 
Display Via 
Control

Adds an action that takes an item off the user request and forwards the item as an action output to a JSP page input.

    @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "customers.jsp", actionOutputs = { @Jpf.
ActionOutput(name = "returnValueName", type = model.Customer.class) }) })
    public Forward getItemForDisplay() {
        Forward forward = new Forward("success");
        String param1 = getRequest().getParameter("id");
        java.lang.Integer id = TypeUtils.convertToIntegerObject(param1);
        model.Customer returnValueName = customerControl.getCustomerById(id);
        forward.addActionOutput("returnValueName", returnValueName);
        return forward;
    }

Get Item For 
Edit Via 
Control

Adds an action that takes an item off the user request and forwards the item as an output form.

    @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "customers.jsp") })
    public Forward getItemForEdit() {
        Forward forward = new Forward("success");
        String param1 = getRequest().getParameter("id");
        java.lang.Integer id = TypeUtils.convertToIntegerObject(param1);
        model.Customer returnValueName = customerControl.getCustomerById(id);
        GetItemForEditFormBean outputForm = new GetItemForEditFormBean();
        outputForm.setReturnValueName(returnValueName);
        forward.addOutputForm(outputForm);
        return forward;
    }
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Delete Item 
Via Control

Adds an action that takes an item off the user request and invokes a delete method on the control.

    @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "customers.jsp", actionOutputs = { @Jpf.
ActionOutput(name = "returnValueName", type = model.Customer.class) }) })
    public Forward deleteItem() {
        Forward forward = new Forward("success");
        String param1 = getRequest().getParameter("id");
        java.lang.Integer id = TypeUtils.convertToIntegerObject(param1);
        model.Customer returnValueName = customerControl.deleteCustomerById(id);
        forward.addActionOutput("returnValueName", returnValueName);
        return forward;
    }

Add Item Via 
Control

Add an action that takes data from the posted form and invokes an add method on the control.

    @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "customers.jsp", actionOutputs = { @Jpf.
ActionOutput(name = "returnValueName", type = model.Customer.class) }) })
    public Forward addItem(FormBean form) {
        Forward forward = new Forward("success");
        java.lang.Integer id = form.getCustomer().getId();
        model.Customer returnValueName = customerControl.getCustomerById(id);
        forward.addActionOutput("returnValueName", returnValueName);
        return forward;
    }

Update Item 
Via Control

Takes data from the posted form and invokes an update method on the control.

    @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "customers.jsp", actionOutputs = { @Jpf.
ActionOutput(name = "returnValueName", type = model.Customer.class) }) })
    public Forward updateItem(FormBean form) {
        Forward forward = new Forward("success");
        java.lang.Integer id = form.getCustomer().getId();
        model.Customer returnValueName = customerControl.getCustomerById(id);
        forward.addActionOutput("returnValueName", returnValueName);
        return forward;
    }

The table below explains the role of each field in the action templates.

Field Descriptions
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Field Description
Action 
Name

Specifies the action name. For method actions this is the method name:

    public Forward actionName()

For simple actions, this is the name attribute on the @Jpf.SimpleAction annotation.

    @Jpf.Controller(simpleActions = { @Jpf.SimpleAction(name = "actionName", ...) 

Control Specifies the control class that is called by the action, shown in bold type below.

        @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "customers.jsp", actionOutputs = 
{ @Jpf.ActionOutput(name = "returnValueName", type = model.Customer.class) }) })
        public Forward actionName(FormBean form) {
                Forward forward = new Forward("success");
                java.lang.Integer id = form.getCustomer().getId();
                model.Customer returnValueName = customerControl.getCustomerById(id);
                forward.addActionOutput("returnValueName", returnValueName);
                return forward;
        }

Control 
Method 

Specifies the control method that is called by the action, shown in bold type below.

        @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "customers.jsp", actionOutputs = 
{ @Jpf.ActionOutput(name = "returnValueName", type = model.Customer.class) }) })
        public Forward actionName(FormBean form) {
                Forward forward = new Forward("success");
                java.lang.Integer id = form.getCustomer().getId();
                model.Customer returnValueName = customerControl.getCustomerById(id);
                forward.addActionOutput("returnValueName", returnValueName);
                return forward;
        }

Form Bean Specifies the parameter (= a form bean) of the action method.

        @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "customers.jsp", actionOutputs = 
{ @Jpf.ActionOutput(name = "returnValueName", type = model.Customer.class) }) })
        public Forward actionName(FormBean form) {
                Forward forward = new Forward("success");
                java.lang.Integer id = form.getCustomer().getId();
                model.Customer returnValueName = customerControl.getCustomerById(id);
                forward.addActionOutput("returnValueName", returnValueName);
                return forward;
        }

file:///F|/depot/dev/src/workshop/product/plugins/com.bea.workshop.product.wl.doc/html/webapplications/ui/uiNewActionWizard.html (4 of 5)1/26/2007 3:40:36 PM



New Action Wizard

Forward To Specifies the JSP page or action that is the target of this action. 

        @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "customers.jsp", actionOutputs = 
{ @Jpf.ActionOutput(name = "returnValueName", type = model.Customer.class) }) })
        public Forward actionName(FormBean form) {
                Forward forward = new Forward("success");
                java.lang.Integer id = form.getCustomer().getId();
                model.Customer returnValueName = customerControl.getCustomerById(id);
                forward.addActionOutput("returnValueName", returnValueName);
                return forward;
        }

Return 
Value Name

Specifies the variable name of the data returned by the control method invocation, shown in bold below.

        @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "customers.jsp", actionOutputs = 
{ @Jpf.ActionOutput(name = "returnValueName", type = model.Customer.class) }) })
        public Forward actionName(FormBean form) {
                Forward forward = new Forward("success");
                java.lang.Integer id = form.getCustomer().getId();
                model.Customer returnValueName = customerControl.getCustomerById(id);
                forward.addActionOutput("returnValueName", returnValueName);
                return forward;
        }

Related Topics

Tutorial: Accessing Controls from a Web Application: Step 3: Create a Data Grid

Tutorial: Accessing Controls from a Web Application: Step 4: Create a Page to Edit Customer Data

Apache Beehive documentation: Actions
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New Anchor Wizard

New Anchor Dialog

Use this wizard to add a new anchor to a JSP page.

How To Open This Dialog

In the Page Flow perspective, from the JSP Design Palette drag and drop the anchor icon into the source view of a JSP 
page. The anchor icon is in the section labeled NetUI.

How To Use This Dialog

There are four different modes to this dialog, controlled from the Anchor Type dropdown field. Each mode presents a different 
set of available fields. These modes are: 

●     Action: Creates an anchor that invokes an action method in the page flow Controller class. 

The following fields are presented in Action mode:

Text: clickable text to display. 
Action: the action method to be invoked. 
Parameters: parameters/value pairs will be passed to the action method as Java parameters.

If the following values are entered into the dialog:

The following NetUI tag will be created:

    <netui:anchor action="getCustomers">Invoke the 'getCustomers' action</netui:anchor>

The final HTML will be rendered as follows: 

    <a href="/CustomerCare/customerManagement/getCustomers.do?param1=value1">Invoke the 'getCustomers' 
action</a>

Clicking the link will invoke the following action:

    @Jpf.Action(...)
    public Forward getCustomers(String param1) {
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        ...
    } 

●     Hyperlink: Creates an anchor that links to an URL. 

The following fields are presented in Hyperlink mode:

Text: clickable text to display. 
URL: the URL (relative or absolute) to link to. 
Parameters: parameters/value pairs will added to the URL's query string (the portion of the URL appended after the '?').

If the following values are entered into the dialog:

The following NetUI tag will be created:

    <netui:anchor href="page2.jsp">Link to Page2</netui:anchor>

The following HTML will be rendered (where "CustomerCare" is the project name and "customerManagement" is the path to 
the page flow):

    <a href="/CustomerCare/customerManagement/page2.jsp?param1=value1">Link to Page2</a>

●     

Named Anchor: Creates a link to a named anchor on the same page. 

If the following values are entered into the dialog:
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The following NetUI tag set will be created:

    <netui:anchor linkName="subsection2">Link to Sub-Section 2</netui:anchor>

The following HTML will be rendered (where "CustomerCare" is the project name and "customerManagement" is the path to 
the page flow):

<a href="#subsection2">Link to Sub-Section 2</a>

●     

Basic Anchor: Creates an incomplete <netui:anchor> tag. Only the src attribute on the tag is specified in this mode. The 
user must manually edit the source to complete the tag. At least one of the following attributes must be specified for HTML 
to be rendered: action, href, linkName, clientAction, tagId, or formSubmit.

 

Related Topics

New Image Anchor Dialog

file:///F|/depot/dev/src/workshop/product/plugins/com.bea....duct.wl.doc/html/webapplications/ui/uiNewAnchorWizard.html (3 of 3)1/26/2007 3:40:37 PM



New Command Handler Dialog

New Command Handler Dialog

This dialog creates a method in a JSF backing file for handling a given command event. If the 
command event causes navigation to another page, destinations may be entered via the dialog. 
An annotation on the command handler will be created for each specified destination, similar to 
@Forward annotations on NetUI action methods. If a page is selected as a destination, an 
intervening @SimpleAction will be generated in the NetUI controller class.

How To Open This Dialog

In the Page Flow perspective, on the Page Flow Explorer tab, open the Pages node and a JSF-
enabled JSP page. Right-click Command Handlers folder and select New Command Handler. 
See the diagram below for the location of the Command Handlers folder.

How To Use this Dialog

Click the New button to view a dropdown of common navigation targets for the new command 
handler.
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Related Topics

Integrating Java Server Faces into a Web Application
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New Image Anchor Dialog

Use this dialog to create a new image anchor. An image anchor is like an anchor, except that a clickable image replaces clickable 
text. The <netui:imageAnchor> tag supplies the source code for an image anchor.

How To Open This Dialog

In the Page Flow perspective, from the JSP Design Palette drag and drop the image anchor icon into the source view of a 
JSP page. The image anchor icon is in the section labeled NetUI.

How To Use This Dialog

There are four different modes to this dialog, controlled from the Anchor Type dropdown field. Each mode presents a different 
set of available fields. These modes are: 

●     Action: Creates an image anchor that invokes an action method in the page flow Controller class. 

The following fields are presented in Action mode:

Image Path: the path to the clickable image. 
Action: the action method to be invoked. 
Parameters: parameters/value pairs will be passed to the action method as Java parameters.

If the following values are entered into the dialog:

The following NetUI tag set will be created:

    <netui:imageAnchor action="getCustomers" src="images/myImages.gif">
        <netui:parameter name="param1" value="value1" />
    </netui:imageAnchor>

The final HTML will be rendered as follows: 

    <a href="/CustomerCare/customerManagement/getCustomers.do?param1=value1"><img src="/images/myImages.
gif"></a>
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Clicking the link will invoke the following action:

    @Jpf.Action(...)
    public Forward getCustomers(String param1) {
        ...
    } 

●     Hyperlink: Creates an image anchor that links to an URL. 

The following fields are presented in Hyperlink mode:

Image Path: the path to the clickable image. 
URL: the URL (relative or absolute) to link to. 
Parameters: parameters/value pairs will added to the URL's query string (the portion of the URL appended after the '?').

If the following values are entered into the dialog:

The following NetUI tag set will be created:

     <netui:imageAnchor href="somePage.jsp" src="images/myImage.gif">
         <netui:parameter name="param1" value="value1" />
    </netui:imageAnchor>

The following HTML will be rendered (where "CustomerCare" is the project name and "customerManagement" is the path to 
the page flow):

<a href="/CustomerCare/customerManagement/somePage.jsp?param1=value1"><img src="/CustomerCare/
customerManagement/images/myImage.gif"></a>

●     

Named Anchor: Creates a link to a named anchor on the same page. 

If the following values are entered into the dialog:
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The following NetUI tag set will be created:

    <netui:imageAnchor linkName="subsection1" src="images/myImage.gif"></netui:imageAnchor>

The following HTML will be rendered (where "CustomerCare" is the project name and "customerManagement" is the path to 
the page flow):

    <a href="#subsection1"><img src="/CustomerCare/customerManagement/images/myImage.gif"></a>

●     

Basic Anchor: Creates an incomplete <netui:imageAnchor> tag. Only the src attribute on the tag is specified in this mode. 
The user must manually edit the source to complete the tag. At least one of the following attributes must be specified for 
HTML to be rendered: action, href, linkName, clientAction, tagId, or formSubmit.

Related Topics

New Anchor Dialog
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New JSF Page Dialog

Use this wizard to create a new JSF page and to specify the template JSF on which it is based.

How To Open This Dialog

To open this dialog:

1.  
JSF-enable your web project (= a web project that includes the JSF facet). For instructions 
on creating a JSF-enabled web project, see Enabling JSF in a Web Project. 

2.  Select File > New > Other > Web > Workshop JSF Page.

How To Use This Dialog

Java Server Faces Page

This page lets you select the name and location of the new JSF page.

Note that JSF pages are not defined by their file extension; instead it is defined by the presence of 
JSF tags. A file with the JSP file extension can still be a JSF page, provided that it contains JSF 
tags.

Upon creation of a JSF page, a backing class, often called the "backing bean", is created (provided 
that the JSF with NetUI Backing File template is selected).
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Select a template for this JSF Page

This page lets you select from the available JSF templates, if desired. For more information on JSF 
templates, see Controlling Web Application Look and Feel with JSP/JSF Templates.
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Related Topics

Controlling Web Application Look and Feel with JSP/JSF Templates

Enabling JSF in a Web Project
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New JSP Dialog

Use this wizard to create a new JSP page and to specify the template JSP on which it is based.

How To Open This Dialog

To open this dialog:

●     

Select File > New > Workshop JSP

How To Use This Dialog

New JSP

This page lets you select the name and location of the new JSP page.
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Select a template for this JSP

This page lets you select from the available JSP templates, if desired. For more information on JSP 
templates, see Controlling Web Application Look and Feel with JSP/JSF Templates.
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Related Topics

Controlling Web Application Look and Feel with JSP/JSF Templates
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New Page Flow Dialog

Use this dialog to create a new page flow.

How To Open This Dialog

To open this dialog:

●     

Select File > New > Other > Web > Page Flow

●     In the Page Flow perspective, on the Page Flow Explorer tab, click the New Page Flow/
Select Page Flow button.

How To Use This Dialog

Page Flow

Use this page to specify the name and location of the page flow.

A default page flow is created, including:

●     

Two new folders. Each is named after the Page flow folder name field. 
 
One folder is located under the web content folder. (The default location of the web content 
folder is /<ProjectRoot>/WebContent.) 
 
One folder is located under the source content folder. (The default location of the source 
content folder is /<ProjectRoot>/src.)  
 
Note: in cases where there are multiple source content folders, and the parent folder field 
points to a location within the web content folder, then the source folder selected in the 
Associated Files for Page Flow Controllers dialog is used.

●     

An index.jsp page located in the web content folder.

●     

A controller class located in the source content folder. The controller class name is based on 
the name you specify here. If you specify myPageFlow, then the controller class is named 
MyPageFlowController.java. You can override the controller class name by specifying a 
different value in the Controller name field.
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Related Topics

New Dynamic Web Project Wizard

New Page Flow Dialog
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Upgrade Changes for Co-Location in Page Flows

Associated Files for Page Flow Controllers Dialog
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New Shared Flow Dialog

Use this this dialog to create a new shared flow page flow. A shared page flow is a page flow that 
can be used by other page flows.

How To Open This Dialog

To open this dialog:

●     

Select File > New > Other > Web > Shared Flow

How To Use This Dialog

Shared Flow

Use this page to specify the name and location of the shared flow.

A single controller class is created. The controller class extends the class org.apache.beehive.
netui.pageflow.SharedFlowController. The controller class name is based on the name you 
specify here. If you specify myPageFlow, then the controller class is named 
MyPageFlowController.java.
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New Page Flow Dialog

Related Topics

Apache Beehive documentation: Shared Flow
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New Dynamic Web Project Wizard

New Dynamic Web Project Wizard

Use this wizard to create and configure a new dynamic web project.

How To Open This Dialog

To open this dialog:

●     

Select File > New > Project > Web > Dynamic Web Project

How To Use This Dialog

Dynamic Web Project

The Project Name field specifies the deployment name of the project.

In the Project contents area, if Use default is checked, then the project will be created in the current 
workspace, inside a directory matching the specified Project Name.

If you uncheck Use default, you can specify a project directory outside of the current workspace. The 
selected directory does not need to be empty, but it cannot already be a project directory (it cannot contain 
a .project file).

The Target runtime field defines the sorts of runtime resources available to your web project.

For more infomation about EAR projects see Applications and Projects.
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New Dynamic Web Project Wizard

Select Project Facets

A Workshop for WebLogic dynamic web project has the following project facets specified by default. For 
more information on these facets see Facets.
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New Dynamic Web Project Wizard

Web Module

The Context Root specifies the part of the project identifier. The project root is also part of the URL used 
to access the web application.

The Content Directory specifies the name of the directory where common web resources are located. For 
example, the WEB-INF dir, JSP pages, etc.

The Java Source Directory specifies that name of the directory where Java source files are located. For 
example, all page flow controller class will be created in this directory.
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New Dynamic Web Project Wizard

Related Topics

Applications and Projects

Facets
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Page Flow Editor View

Page Flow Editor View

The Page Flow Editor view shows a graphical view of a specific page flow node (action or page) and its neighboring nodes.

The following diagram points out the main areas, icons, and buttons available on the Page Flow Editor View.

You select the current page flow from a dropdown by clicking the green arrow at the top of the view.

Related Topics

The Page Flow Perspective

Page Flow Perspective Visual Glossary
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Page Flow Source Editor View

Page Flow Source Editor View

The Source Editor view shows the source for a Java file, JSP file, etc. All of the views in the Page Flow perspective are synchronized 
with the Source View for two-way editing.

Related Topics

The Page Flow Perspective

Page Flow Perspective Visual Glossary
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Page Flow Explorer View

Page Flow Explorer View

The Page Flow Explorer View gives you an overview of the functional parts of a page flow, including 
actions, JSPs, controls, exception handlers, etc. 

The image below points out some of the main nodes of the Page Flow Explorer view. 

Adding Nodes to the Page Flow Explorer

You can add elements to the current page flow by right-clicking on a node and selecting New....
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Page Flow Explorer View

For example, to add a new exception handling method to the page flow, right click the Exception 
Handlers node and select New Exception Handler. 

A wizard will pop up, where you can select the method name and the type of exception to be 
handled. The light bulb icon indicates that a code completion is available for this field. Press Ctrl
+Space Bar to activate the code completion dialog.

The following exception handler method will be added to the controller class.
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Page Flow Explorer View

        @Jpf.ExceptionHandler()
        protected Forward myExceptionHandler(Exception ex, String actionName,
                        String message, Object form) {
                return new Forward("success");
        }

Drag and Drop from the Page Flow Explorer

You can also drag and drop elements from the Page Flow Explorer into the Page Flow Editor. 

If you drag a node onto the center pane of the Page Flow Editor, then that node will be given focus.

If you drag a node onto the downstream pane of the Page Flow Editor, then a forward or link will be 
made joining the center pane node and whever node has been dropped in the downstream pane.

Related Topics

The Page Flow Perspective

Page Flow Perspective Visual Glossary
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Page Flow Overview View

Page Flow Overview View

The Page Flow Overview gives a complete view of a page flow, including all of its pages, actions, and forwards. 

The Page Flow Overview is not an editable view (although you can delete some page flow elements through this view, see below 
for details). It is primarily used to give an overarching picture of page flow elements and the relationships between them.

The green triangle selects the page flow to display when there is more than one page flow in the project.

The focal node in the Page Flow Editor syncs with the selected node in the Page Flow Overview.
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Page Flow Overview View

Double-clicking a node will display it corresponding source code in Source View.

When graph tracing is turned on, the selected node and its direct connections are displayed; the remaining nodes are grayed 
out. Incoming links are shown in green, outgoing links in blue.
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Page Flow Overview View

Link labels can be turned on or off with the link label toggle.
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Page Flow Overview View

Editing through the Page Flow Overview is limited to the deletion of a selected element. The red X button will delete the selected 
page, action, or forward.

You can also print or save an image of the view.

Keyboard Shortcuts

The following table gives the keyboard navigation shortcuts for the Page Flow Overview.
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Page Flow Overview View

Keyboard Shortcuts
Key Stroke Event
Shift+F10 Shows the context menu on the selected item
Ctrl+F10 Shows the context menu for the canvas
Arrow keys Cycles through the actions and pages nodes, generally following the direction of the 

arrow key.
"/" and "\" keys Cycles through the forwards connected to the currently selected node. This is 

especially useful for elements that may be difficult to select with the mouse.
Enter key Same as doubling clicking on the currently selected node.

Tips and Tricks

●     

To quickly Maximize/Restore the Page Flow Overview, double-click the Page Flow Overview tab.

●     

To see all of a truncated forward label, select the link. You may also hover over the link to see the full label in the tooltip.

●     

To easily select links in a highly connected graph, select the node of interest and use the “/” key to cycle through the links. 

●     

To keep the Page Flow Overview maximized when switching page flows, right-click the Page Flow Overview tab and 
select Detached. 

●     

To highlight a specific path through the graph, turn on Graph Tracing mode and Ctrl+click each of the links in the path. 
When link label mode is turned on, clicking or Ctrl+clicking on a link label selects/deselects the associated links.

●     

To quickly see all off-screen connections of a given node, select the node and look at the Page Flow Editor. 

●     

To scroll the canvas in any direction, press the Spacebar and drag the canvas in the desired direction. You only have to 
press the Spacebar to initiate the gesture, not while panning the canvas. 

Related Topics

The Page Flow Perspective

Page Flow Perspective Visual Glossary
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Page Flow Perspective Visual Glossary

Page Flow Perspective Visual Glossary

The table describes the icons and graphical elements used in the Page Flow Perspective, especially those icons used in the Page Flow Editor and Page Flow 
Overview views.

Page Flow Perspective Visual Glossary
Element Icon Description
Action Represents an action method, a method annotated with @Jpf.Action.

Action with 
form bean 
parameter

Represents an action method with a form bean parameter, for example: 

@Jpf.Action(...)
public Forward updateCustomer(MyFormBean form) {
    ....
}

Global Action Represents a global action.

Shared Action Represents a shared action.

Simple action Represents an instance of the annotation @Jpf.SimpleAction.

When the begin action is a simple action, it is colored green.
Exception 
Handler

Represents an exception handler.

Exit Node Represents an exit node.

Forward Represents an action forward: @Jpf.Forward.

Forward with 
action output

Represents an action forward with an associated action output, for example: 

@Jpf.Forward(
    name = "success", 
    path = "customers.jsp", 
    actionOutputs = { @Jpf.ActionOutput(name = "getCustomersResult", type = model.Customer[].class) }
)

JSP Page Represents a JSP page.

JSP Page with 
page input

Represents a JSP page with a page input declaration: <netui-data:declarePageInput/> 

HTML Page Represents an HTML page.
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Page Flow Perspective Visual Glossary

JSF Page (no 
backing class)

Represents a JSF page without a backing class.

JSF Page 
(with backing 
class)

Represents a JSF page with a backing class.

Tiles 
Definition

Represents a Tiles definition.

Page Flow Represents a page flow.

Shared Flow Represents a shared page flow.

Nested Page 
Flow

Represents a nested page flow.

Return to 
Previous 
Action

Represents Jpf.NavigateTo.previousAction.

Return to 
Previous Page

Represents Jpf.NavigateTo.previousPage.

Return to 
Current Page

Represents Jpf.NavigateTo.currentPage.

Inherited 
action, page, 
shared, flow, 
etc.

 

  

 

The yellow triangle represents an element inherited from another page flow.

Overriding 
action, 
shared flow, 
etc.

 

 

The green square represents an overriding element.

External 
action, page, 
page flow

 

  

 

The orange arrow represents an external element.

Sync Page 
Flow Editor 
with Source 
View

Syncs the Page Flow Editor with the current cursor location in Source Editor view. For example, if, in the Source Editor, the 
cursor is in the method body of an action, clicking this button will make the action become the focal node in the Page Flow 
Editor. Similarly if a member JSP page is open in the Source Editor, clicking this button will make that JSP the focal node. 
This button is only enabled when the cursor is in the Source Editor of some node.

Related Topics

The Page Flow Perspective
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Select Properties Dialog

Select Properties Dialog

Use this dialog to select properties (=fields) to be displayed in a data grid or form.

How To Open This Dialog

This dialog is invoked whenever properties for a data grid or form need to be specified: 

●     

Click Select on the Columns tab of the Data Grid dialog (assuming that a repeating data 
type is entered on the General tab)

●     

The second screen of the Create Form wizard

●     

The second screen of the Data Display wizard

●     

Click Select in the Item Identifier section of the Update Form wizard
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Select Properties Dialog

Related Topics

Data Grid 

Create Form 

Data Display

Update Form
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Suppressible Dialogs Preferences

Suppressible Dialogs Preferences

Use this dialog to set preferences for these message dialogs:

●     

Resolve Page Inputs

●     

Add Page Inputs

●     

Warn on Duplicate JSP Name

How To Open This Dialog

To open this dialog, select Window > Preferences > NetUI Page Flow > Suppressible Dialogs.
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Suppressible Dialogs Preferences

Related Topics

none
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Update Form Wizard

Update Form Wizard

Use this dialog to create a form for updating a data set.

How To Open This Dialog

To open this wizard, open a JSP file in the Page Flow perspective. Then drag and drop the Update 
Form entry from the NetUI Patterns section of the JSP Data Palette onto the source view of the 
JSP.

How To Use This Dialog

Select Action Page

The select action page specifies the action that the form will invoke when the form is submitted. 
You may also create a new action for the form to invoke.

You must also select a primary key field for the submitted item that uniquely identifies it in the 
data set. The value of this field identifies which item in the data set is to be updated.
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Update Form Wizard

Select Properties Page

This page specifies which items are to appear in the update form.
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Update Form Wizard

Arrange Fields

This page specifies the order in which the fields appear in the form.
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Update Form Wizard

Related Topics

The Page Flow Perspective

JSP Data Palette 
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Set Message Bundle Dialog

Set Message Bundle Dialog

Use this dialog to set the message bundle file for validation errors. Message bundle files consist of 
message-key/message-value pairs. When a validation error occurs, an error message can be 
retrieved by pointing at the message's key. 

How To Open This Dialog

From the Validation Rule Editor, select the top-level node in the Properties area. In the Page 
Flow Default Message Bundle area, click the ellipses button (...).

How To Use This Dialog

Create a new message bundle file by selecting Create a new message bundle and specifying 
the file name and location.

Point to an existing message bundle by clicking the Browse button.

Related Topics

Validation Rules Dialog
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Validation Rules Dialog

Validation Rules Dialog

Use this dialog to set validation rules for input forms. Validation is applied to the form bean that is constructed form submitted data. 
This dialog lets you specify:

●     

the form bean to validate

●     

the particular form bean fields that require validation 

●     

the specific validation rules to be applied 

●     

the error messaging mechanisms to be used when errors arise

●     

locale-specific validation rules

How To Open This Dialog

1.  
In the Page Flow Editor, right-click any action that has a form bean parameter, indicated by the form bean icon. The form bean 
icon appears as a box in the lower right-hand corner of an action icon: 
 

           

2.  
Select Validation Rules.

3.  
Select one the scopes: Action Scope, Form Bean Scope, or Page Flow Scope. 

The action/form bean you right-click determines which form bean will be validated.

The scope you chose determines the location and type of the validation annotation. 

●     

Action scope decorates the action method with a @Jpf.ValidatableProperty annotation

●     

Form Bean scope decorates the form bean's getter fields with the @Jpf.ValidatableProperty annotation.

●     

Page Flow scope decorates the controller class with a nested set of @Jpf.ValidatableBean / @Jpf.ValidatableProperty annotations. 

How To Use This Dialog

Top-Level Node
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Validation Rules Dialog

The top level node in the Properties area shows the form bean to which validation applies. In the image above validation is applied to 
the form bean customerManagement.CustomerManagementController.GetCustomerByIdFormBean.

Page Flow Default Message Bundle field lets you specify the set of error messages that are used when validation errors arise. The 
bundle specified here will be the default bundle for all validation errors in the page flow class, this bundle will be used unless otherwise 
specified at the action or form bean scope. See Validation: Set Message Bundle for details.

Field-Level Nodes
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Validation Rules Dialog

The field-level nodes in the Properties area shows all of the fields of a particular form bean. Field-level nodes are indicated by a green 
ball icon (see the image above) for simple types; a larget green ball with a "C" for complex types. The form bean below has one field: 
Customer.

The fields in the Display Name (optional) section allow the user to use a different name for the validated property when validation 
error messages arise. This name can be provided either as literal text or a message key from the associated bundle. Using a substitute 
name, an error message can be "The last name field is required", instead of "lastName is required"

There are three basic options for validation error message: 

1.  
Framework-based. For example, Struts validation error messaging might be used.

2.  
Annotation-based. On this option error message are stored in the validation annotation directly

3.  
Message bundle-based. On this option, error message are stored in a separate message bundle file. Messages are retrieved by the 
use of message keys.

The Source dropdown list has three corresponding values:

(1) Framework Default: on this setting, any framework-based error messages will be used, provided that your framework is 
configured for these messages. For example, if your application were already configured to use Struts validation, select this option.

(2) Annotation in this File: on this setting, the value of the Display Name field (directly below the Key field) sets the displayName 
attribute on the validation annotation. For example, assuming that "The Customer field" is entered in the Display Name field, then the 
following validation annotation will be created: 

      @Jpf.ValidatableProperty(
          ...
          displayName="The Customer field",
          ...
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Validation Rules Dialog

      )
      ...

(3) Page Flow Default Message Bundle: on this setting, the value of Display Name specifies the message key used to retrieve the 
error message from the default message bundle. (To set the message bundle file, see Validation: Set Message Bundle.)

For example, suppose that 

●     

the Page Flow Default Message Bundle field (see above) is set to "validationError.properties",

●     

the the Key field is set to "custKey", and 

●     

the Display Name field is set to "The Customer field"

then the following validation annotations are created:

    ...messageBundles = { @Jpf.MessageBundle(bundlePath = "validationError.properties")
    ...@Jpf.ValidatableProperty(displayNameKey = "custKey", propertyName = "customer")

and the following key is written in the bundle file:

    custKey=The Customer field

The Key field shows a list of all the keys available in the default bundle (if any). Selecting a key from the list displays the associated 
message in the Display Name field. Any edits made to the message are saved in the bundle. Also new keys can be entered directly into 
the Key field.

Locale Nodes
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Validation Rules Dialog

The locale nodes in the Properties area specifies the locales to which the validation rules apply. Locale nodes are indicated by globe 
icons (see the image above). 

To create a new locale-specific rule, right-click a property-level node, and select New Validation Locale. 

The All locale is provided by default for each property. Place specific validation rules here that should be applied to every locale.

Rule Nodes

Rule nodes specify particular validation rules. Rule nodes are indicated by a key icon (see the image above).

To create a new validation rule, right-click a locale icon, and select the desired rule type. Properties and error messaging for the rule are 
specified on the right-hand side of the dialog.

Related Topics

Validation: Set Message Bundle
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Tasks: Web Applications

Tasks: Web Applications

This section contains instructions for common web application development tasks. 

Topics included in this section:

How To Define an Action that Forwards Users to Another Page

This topic explains how to setup navigation between two JSP pages using an action method.

How to Submit User Data from a JSP

This topic explains how to setup user data submission from a JSP page to an action.

How to Change the Default Encoding for a New HTML Page 

This topic explains how to change the default encoding for a new HTML page to UTF-8.

Related Topics

Tutorial: Accessing a Database from a Web Application

Tutorial: Java Server Faces Integration
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How To Define an Action that Forwards Users to Another Page

How to Define an Action that Forwards Users to Another Page

This topic explains how to setup navigation between two JSP pages using a navigational action in a page flow 
Controller class.

These instructions assume that you have a dynamic web project (New > Project > Other > Web > Dynamic 
Web Project) that contains a page flow with at least two JSP pages. 

To Create the Navigational Action

1.  
Open the Page Flow perspective (Window > Open Perspective > Page Flow).

2.  
Right-click in the center pane of the Page Flow Editor and select New Action.

3.  
In the New Action dialog, in the Action Template field, confirm that Basic Method Action is selected. 
In the Action Name field, enter an appropriate name for the action. This will be the name of the action 
method. 
In the Forward To field, select the destination JSP page. (This is the page that users will navigate to.) 
Click Finish. 

To Create a Link that Invokes the Navigational Action

1.  
Open the JSP page that will invoke the action. This is the starting page that users will navigate from.

2.  
On the JSP Design Palette, expand the NetUI category by clicking the heading or the + sign. Under the 
NetUI heading, drag and drop the anchor icon onto the starting JSP page.

3.  
In the New Anchor dialog, in the Anchor Type dropdown, confirm that Action is selected. 
In the Text field, enter some appropriate text. This is the display text for the hyperlink. 
In the Action dropdown, select the action method you created above. 
Click Ok.

In the Page Flow Editor there should be two arrows: (1) an arrow pointing from the starting JSP page to the 
action method and (2) another arrow pointing from the action method to the destination JSP page.

The source code you have created should look something like the following:
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index.jsp 

    <netui:anchor action="navAction">Navigate to destination.jsp!</netui:anchor>

Controller.java

    @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "destination.jsp") })
    public Forward navAction() {
        Forward forward = new Forward("success");
        return forward;
    }

Related Topics

Page Flow Editor 

New Action

JSP Design Palette
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How to Submit User Data from a JSP

This topic explains how to set up user data submission using an HTML form, a form bean (a Java representation of the 
HTML form), and an action. 

The purpose of these instructions is to make you familiar with some of the main dialogs and wizards to help you 
accomplish this coding goal. These instructions are not intended to apply to every case where a form is required for 
user submitted data. For example, these instruction may not apply directly if you already have a pre-existing form 
beans. In that case, the instruction below can modified to utilize your pre-existing resources: where the instructions tell 
you to create a form bean, simply select the pre-existing item from the dropdown list.

These instructions assume that you have a dynamic web project (New > Project > Other > Web > Dynamic Web 
Project) that contains a page flow. 

To Create a Form Bean to Model Submitted Data

(If you already have a form bean, you can skip this step.)

1.  
Open the Page Flow perspective (Window > Open Perspective > Page Flow).

2.  
On the Page Flow Explorer tab, right-click the Form Bean node and select New Inner Class Form Bean.

3.  
On the Page Flow Explorer tab, right-click the new form bean (named NewFormBean by default) and select 
Rename. Rename the form bean appropriately (e.g., Customer, Order, etc.).

4.  
On the Page Flow Explorer tab, double-click the form bean to view its source. Add private fields to the form bean 
class, for example:

    @Jpf.FormBean
        public static class Customer implements java.io.Serializable {
  
        private String firstName;
        private String lastName;
  
    }

5.  
Right-click within the body of the Controller class and select Source > Generate Getters and Setters. This will 
create public getter and setter methods for the form bean's private fields.

To Create an Action and a User Input Form Based on a Form Bean

1.  Open the JSP page where you want the form to appear.

2.  
From the JSP Design Palette drag and drop the node Create Form onto the JSP page.

3.  
In the Create Form wizard, in the Action section, click New. (If you already have an action you want to use, do 
not click New. Instead select that action from the dropdown list and skip the next step.)

4.  
In the New Action wizard, in the Action Template field, select Basic Method Action. 
In the Action Name field, enter an appropriate name. 
In the Form Bean field, select the form bean created above. 
In the Forward To field, select an appropriate destination to forward the user to after data has been submitted. 
Click Finish.
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5.  
In the Create Form wizard, click Next. 
On the Select Properties page, select the form bean fields that will appear in the user input form. 
Click Next. 
On the Arrange Fields page, select the order that the fields should appear on the JSP page. 
Click Finish.

The code created should look like something like the following:

form.jsp page

<netui:form action="nameAction">
    <table>
         <tr valign="top">
             <td><label for="field1"> FirstName: </label></td>
             <td><netui:textBox dataSource="actionForm.firstName" tagId="field1"></netui:textBox></td>
         </tr>
         <tr valign="top">
             <td><label for="field2"> LastName: </label></td>
             <td><netui:textBox dataSource="actionForm.lastName" tagId="field2"></netui:textBox></td>
         </tr>
    </table>
    <netui:button value="nameAction" type="submit" />
</netui:form>

Controller.java

    @Jpf.Action(forwards = { @Jpf.Forward(name = "success", path = "confirm.jsp") })
    public Forward nameAction(Controller.NameForm form) {
        Forward forward = new Forward("success");
        return forward;
    }

        ...

    @Jpf.FormBean
    public static class NameForm implements java.io.Serializable {
        private static final long serialVersionUID = 1815159769L;
          
        private String firstName;
        private String lastName;
  
        public String getFirstName() {
            return firstName;
        }
        public void setFirstName(String firstName) {
            this.firstName = firstName;
        }
        public String getLastName() {
            return lastName;
        }
        public void setLastName(String lastName) {
            this.lastName = lastName;
        }
    }

Related Topics

Create Form Wizard

JSP Design Palette View
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JSF Tutorial: Step 2: Create a JSF Web Application
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How to Change the Default Encoding for a New HTML Page 

Upon installation of Workshop for WebLogic, the default encoding for a new HTML page (File > 
New > Other > Web > HTML) is the same as the Java VM encoding. The Java VM encoding 
value will differ depending on the operating system configuration. 

To change the default value to charset=UTF-8 open the HTML Files dialog (Window > 
Preferences > Web and XML > HTML Files). In the section labeled Creating files, in the 
Encoding dropdown, select the value ISO 10646/Unicode(UTF-8). 

The default HTML encoding is a workspace level setting. This means that each new workspace will 
be initiated with a default encoding of ISO-8859-1. If another default encoding is desired, it must 
be reset upon the creation of each new workspace.

Note: the preferences dialog Window > Preferences > Web and XML > JSP Files > 
Encoding has no effect on the default encoding for JSP files. To change the default 
encoding for new JSP pages, create a JSP template project and reset the default JSP 
template.

Related Topics

Controlling Web Application Look and Feel with JSP/JSF Templates

Authoring JSP Template Projects
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