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CHAPTER
1 Running the Purchase 
Order Sample

The BEA WebLogic XML/Non-XML Translator (hereafter referred to as XML 
Translator) software includes a Purchase Order sample designed to illustrate the basic 
techniques of creating message format definitions for binary data using Format 
Builder. The Purchase Order sample consists of DTD, MFL, and DATA files. These 
samples can be used to test your installation of the XML Translator.

The following topics are discussed in this section:

n What is Included in the Purchase Order Sample

n Prerequisite Considerations

n Understanding the Data Formats Used with XML Translator

n Performing Binary to XML Translation

n Performing XML to Binary Translation
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1 Running the Purchase Order Sample
What is Included in the Purchase Order 
Sample

The following table provides a listing and description of the files included in the 
Purchase Order sample application.

Prerequisite Considerations

There are certain software applications that must be installed and tasks that must be 
performed prior to running the Purchase Order sample. Please refer to the BEA 
WebLogic XML/Non-XML Translator Release Notes for more information.

Understanding the Data Formats Used with 
XML Translator

To understand how the Format Builder is used, it helps to understand the data formats 
used by XML Translator: binary data, XML, and MFL.

Table 1-1  List of Purchase Order Sample Application Files

Directory File Description

samples\po po_01.data Purchase order data in binary format.

po_02.data Additional purchase order data in binary format.

po.dtd Purchase order document type definition.

po.mfl Pre-built message format description of purchase order 
data.
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About Binary Data (Non-XML Data)

Because computers are based on the binary numbering system, applications often use 
a binary format to represent data. A file stored in binary format is computer-readable 
but not necessarily human-readable. Binary formats are used for executable programs 
and numeric data, and text formats are used for textual data. many files contain a 
combination of binary and text formats. Such files are usually considered to be binary 
files even though they contain some data in text format.

Unlike XML data, binary data is not self-describing. In other words, binary data does 
not provide a description of how the data is grouped, divided into fields, or arranged 
in a layout. Binary data is a sequence of bytes that can be interpreted as an integer, a 
string, or a picture, depending on the intent of the application that generates the 
sequence of bytes. For example, the following binary data string can be interpreted 
many different ways:

2231987

This could be a date (2/23/1987) or a phone number (223-1987) or any number of other 
interpretations. Without a clear understanding of the purpose of this data string, the 
application has no idea how to interpret the string.

In order for binary data to be understood by an application, the format must be 
embedded  within each application that accesses the binary data.

The Format Builder is used to create a Message Format Language (MFL) file that 
describes the layout of the binary data. MFL is an XML language that includes 
elements to describe each field of data, as well as groupings of fields (groups), 
repetition, and aggregation. The hierarchy of a binary record, the layout of the fields, 
and the groupings of fields and groups are expressed in an MFL document. The MFL 
document is used by XML Translator at run-time to translate binary data to and from 
an XML document.

About XML Documents

Extended Markup Language, or XML, is a text format for exchanging data between 
different systems. It allows data to be described in a simple, standard, text-only format. 
In contrast to binary data, XML data embeds a description of the data within the data 
stream. Applications can share data more easily, since they are not dependent on the 
BEA WebLogic XML/Non-XML Translator Samples Guide 1-3



1 Running the Purchase Order Sample
layout of the data being embedded within each application. Since the data is presented 
in a standard form, applications on disparate systems can interpret data in proprietary 
binary formats.

Instances of XML documents contain character data and markup. The character data 
is referred to as content, while the markup provides hierarchy for that content. Markup 
is distinguished from content by angle brackets. Information in the space between the 
“<“ and the “>” is referred to as the tags that markup the content. Tags provide an 
indication of what the content is for, and a mechanism to describe Parent-child 
relationships.

An XML document can conform to a content model. A content model allows Metadata 
(data that is used to describe other data) about XML documents to be communicated 
to an XML parser. XML documents are said to be “valid” if they conform to a content 
model. A content model describes the data that can exist in an instance of an XML 
document. A content model also describes a top-level entity, which is a sequence of 
subordinate entities. These subordinate entities are further described by their tag names 
and data content. The two standard formats for XML content models are XML 
Document Type Definition (DTD) and XML Schema. A Schema is an XML document 
that defines what can be in an XML document. A DTD also defines what content can 
exist in an XML document, but the Schema definition is more specific than the DTD, 
and provides much finer-grained control over the content that can exist in an XML 
document.

About MFL Documents

Message Format Language (MFL) is an XML language that describes the layout of 
binary data. This language includes elements to describe each field of data, as well as 
groupings of fields (groups), repetition, and aggregation. The hierarchy of a binary 
record, the layout of fields, and the grouping of fields and groups is expressed in an 
MFL document. MFL documents are created using Format Builder. The Format 
Builder application allows you to define the structure of binary data and save that 
information in an MFL document. These MFL documents are then used to perform 
run-time translation.

The MFL documents you create using Format Builder can contain the following 
elements:

n Message Format — The top level element. Defines the message name and MFL 
version.
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Understanding the Data Formats Used with XML Translator
n Field — Sequence of bytes that have some meaning to an application. (For 
example, the field EMPNAME contains an employee name.) Defines the formatting 
for the field. The formatting parameters you can define include:

l Tagged — Indicates that a literal precedes the data field, denoting the 
beginning of the field.

l Length Field — Indicates that a length value precedes the data field, 
denoting the length of this field.

l Repeating — Repeating fields appear more than once in the message format. 
You can set a specific number of times the field is to repeat, or define a 
delimiter to indicate the end of the repeating field.

l Optional — The field may or may not be present in the named message 
format.

n Groups — Collections of fields, comments, and other groups or references that 
are related in some way (for example, the fields PAYDATE, HOURS, and RATE 
could be part of the PAYINFO group). Defines the formatting for all items 
contained in the group. The formatting parameters you can define include:

l Repeating — Repeating groups appear more than once in the message 
format: You can set a specific number of times the group is to repeat, or 
define a delimiter to indicate the end of the repeating group.

l Choice of Children — Defining a group as “Choice of Children” means that 
only one item in the group will appear in the message format.

l Optional— The group of data within this structure may or may not be 
present in the named message format.

n References — Indicates that another instance of the field or group format exists 
in the data. Reference fields or groups have the same format as the original field 
or group, but you can change the optional setting and the occurrence setting for 
the reference field or group. For example, if you have a “bill to” address and a 
“ship to” address in your data, you only need to define the address format once. 
You can create the “bill to” address definition and create a reference for the 
“ship to” address.

n Comments — Notes or additional information about the message format.
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Performing Binary to XML Translation

The following sections provide information on building sample purchase order format 
definitions using the Format Builder utility to test the translation of binary data into 
XML format.

n Analyzing the Data to be Translated

n Using the Format Builder To Test the Translation

The Format Builder included with XML Translator allows you to build format 
definitions for binary data that will be translated to or from XML. Format definitions 
are the metadata used to parse binary data.

Analyzing the Data to be Translated

The key to translating binary data to and from XML is to create an accurate description 
of the binary data. For binary data (data that is not self-describing), you must identify 
the following elements:

n Hierarchical groups

n Group attributes, such as name, optional, repeating, delimited

n Data fields

n Data field attributes, such as name, data type, length/termination, optional, 
repeating

Listing 1-1 shows sample binary data that is included on the XML Translator 
CD-ROM and is called \sample\po\po_01.data. In this sample, the example data 
is taken from a ficticious purchase order on a proprietary system that the XYZ 
Corporation uses. They would like to interchange this information with another system 
that accepts XML data.
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Listing 1-1   Sample Binary Purchase Order Data

1234;88844321;SUP:21Sprockley’s Sprockets01/15/2000123 Main St.; 
Austin;TX;75222;555 State St.; Austin;TX;75222; 
PO12345678;666123;150;Red Sprocket;

Perform the following steps to analyze the purchase order data:

1. Get the definition of the data. This may involve using printed specifications or 
internal documentation. For this sample, we have described the purchase order 
format in Table 1-2.

Table 1-2  Purchase Order Master Record

Field Name Data Type Length Description

Purchase Request 
Number

Numeric Delimited by semicolon The Purchase Request number assigned by 
the Purchasing department. This number is 
used to track the status of an order from 
requisition through delivery and payment.

Supplier ID Numeric Delimited by semicolon The identification of the assigned supplier 
as defined in the corporate Supplier Data 
Base. Assignment of an approved supplier 
is made by the buyer when creating a 
Purchase Request from a requisition.

Supplier Name Character Prefixed by a literal 
"SUP:". Following this 
literal is a two digit 
numeric length field.

The name of the assigned supplier as 
defined in the corporate Supplier Data 
Base. This field is prefixed with a literal to 
indicate that it is present.

Requested Delivery 
Date

Date 
MM/DD/YYYY

10 characters The delivery date specified by the 
requisitioner.

Shipping Street Character Delimited by semicolon The street address to be used in shipping 
the requested items.

Shipping City Character Delimited by semicolon The city to be used in shipping the 
requested items.
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Shipping State Character Delimited by semicolon The state to be used in shipping the 
requested items.

Shipping Zip Numeric Delimited by semicolon The zip code to be used in shipping the 
requested items.

Billing Street Character Delimited by semicolon The street address to be used for billing.

Billing City Character Delimited by semicolon The city to be used for billing.

Billing State Character Delimited by semicolon The state to be used for billing.

Billing Zip Numeric Delimited by semicolon The zip code to be used for billing.

Payment Terms Supported payment terms may be either 
Purchase Order or Company Credit Card. 
A literal preceding the payment 
information identifies the type.

PO Type Character Literal “PO” Indicates PO payment terms.

PO Number Numeric Delimited by semicolon Purchase Order number.

Credit Card Type Character Literal “CC” Indicates Credit Card payment terms.

Credit Card Number Numeric Delimited by semicolon Credit card number.

Credit Card 
Expiration Month

Numeric Delimited by semicolon Expiration month for credit card.

Credit Card 
Expiration Year

Numeric Delimited by semicolon Expiration year for credit card.

Purchase Items The following fields identify the items to 
be purchased. This information may be 
repeated for each item that is part of this 
Purchase Request. At least one item must 
be present.

Part Number Numeric Delimited by semicolon The supplier's part number of the requested 
item.

Quantity Numeric Delimited by semicolon The quantity requested. Must be greater 
then zero.

Field Name Data Type Length Description
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2. Identify hierarchical groups.

Groups are collections of fields, comments, and other groups or references that 
are related in some way. In Table 1-2, notice that the sample data defines two 
distinct groups: Payment Terms and Purchase Items. In addition to these groups, 
notice that there are several fields related to shipping and billing addresses. You 
can define a group for Shipping Address and a group for Billing Address.

3. Identify group attributes.

You must define the attributes of the hierarchical groups. Group attributes 
include the name of the group, whether the group is optional, repeating, or 
delimited, or whether it is defined as a reference to another group. For example, 
look at the Address group within the Shipping Address and Billing Address 
groups. These two groups contain the same fields with the same attributes. 
Therefore, you can define the Address group within the Shipping Address group 
and set up the Address group within the Billing Address group as a reference. 
For more information on references, refer to the BEA WebLogic XML/Non-XML 
Translator User Guide.

4. Identify data fields.

Fields are a sequence of bytes that have some meaning to an application. In 
Table 1-2, some of the sample data fields are Purchase Request Number, 
Supplier ID, Supplier Name, etc.

5. Identify data field attributes.

You need to define the attributes of the data fields. Field attributes include the 
name of the field, the type of data contained in the field, the length of the field, 
or the delimiter that denotes the end of the field. For example, the Supplier ID 
field is delimited by a semicolon (;) indicating the end of the field data, but the 
Requested Delivery Date has an implied length of 10 characters.

Once you have completed the steps above, it might be helpful to put the data into a 
spreadsheet form as shown in Table 1-3. This will assist you in entering the data in 
Format Builder to create your message definitions.

Description Character Delimited by semicolon Description of the requested item.

Field Name Data Type Length Description
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Table 1-3  Analysis of Purchase Order Data

Using the Format Builder To Test the Translation

This section walks you through the Format Builder steps required to create the message 
definition file for translating the binary Purchase Order data to XML.

Notes: For details on entering data in the detail windows of Format Builder, refer to 
the BEA WebLogic XML/Non-XML User Guide.

The file \sample\po\po.mfl included on the CD-ROM contains the message 
definition created by the steps below. You can use this file for reference to make sure 
you create the definition correctly.

Description G
ro

up

F
ie

ld

R
ef

er
en

ce

O
pt

io
na

l

Name / Refers To Data Type Occurrence Delimited by

Purchase Request Number X PR_Number Numeric 1 Semicolon

Supplier ID X Supplier_ID Numeric 1 Semicolon

Supplier Name X X Supplier_Name String 1 Numeric field length 2

Requested Delivery Date X Requested_Delivery_Date Date  MM/DD/YYYY 1 Semicolon

 Shipping Address X Shipping_Address 1

Street X Street String 1 Semicolon

City X City String 1 Semicolon

State X State String 1 Semicolon

Zip X Zip Numeric 1 Semicolon

Billing Address X Address 1 Semicolon

Street X Street String 1 Semicolon

City X City String 1 Semicolon

State X State String 1 Semicolon

Zip X Zip Numeric 1 Semicolon

Payment Terms X Payment Terms 1

Purchase Order X 0 or 1

Purchase Order Tag X Payment_Type_PO Literal "PO" 1 Semicolon

Purchase Order Number X PO_Number Numeric 1 Semicolon

Credit Card X 0 or 1

Payment Type X Payment_Type_CC Literal "CC" 1 Semicolon

Credit Card Number X CC_Number Numeric 1 Semicolon

Credit Card Expire Month X CC_Expire_Month Numeric 1 Semicolon

Credit Card Expire Year X CC_Expire_Year Numeric 1 Semicolon

Purchase Items X Purchase_Items 1- n Semicolon

Part Number X Part_Number Numeric 1 Semicolon

Quantity X Quantity Numeric 1 Semicolon

Description X Description String 1 Semicolon
1-10 BEA WebLogic XML/Non-XML Translator Samples Guide
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Step 1. Starting Format Builder and Creating the Message Format

To start Format Builder and create the message format:

1. Choose Start→Programs→BEA WebLogic XML/Non-XML Translator→Format 
Builder. The Format Builder main window displays.

2. Choose File→New. A new message definition opens.

3. Enter PurchaseRequest as the message format name and click Apply. The tree 
pane changes to reflect the new message format name.

Step 2. Creating Fields

To create fields:

1. Select PurchaseRequest in the tree pane and choose Insert→Field→As Child. The 
Field Description detail window opens.

2. Enter the field details as follows:

These values were determined by our analysis of the raw purchase order data, as 
you can see in Table 1-3.

3. Click Apply. The PR_Number field is saved to the message format file.

Note: Since the only difference between the PR_Number field and the 
Supplier_ID field is the name, we will use the Format Builder Duplicate 
feature to create the Supplier_ID field.

4. Select the PR_Number field you just created in the tree pane and click Duplicate. 
A new field description is displayed in the detail pane.

Field Value

Name PR_Number

Type Numeric

Field Occurrence Once

Delimiter ; (semi-colon)
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5. Enter Supplier_ID as the name and click Apply. The Supplier_ID field is created 
and stored in the message format file.

6. Select the Supplier_ID field you just created in the tree pane and choose 
Insert→Field→As Sibling.

7. Enter the Supplier_Name field details as follows:

8. Click Apply. The Supplier_Name field is created and added to the tree pane.

Note: The dashed box around the field icon in the tree pane indicates this is an 
optional field.

9. Select the Supplier_Name field you just created in the tree pane and choose 
Insert→Field→As Sibling.

10. Enter the Requested_Delivery_Date field details as follows:

Note: The Field detail pane changes based on the Type selected. Because this 
field is a Date type, it has an implied length and does not require you to 
specify the termination.

Field Value

Name Supplier_Name

Optional Select this option

Tagged Select this option and choose “String” from the drop down 
list

Tag SUP:

Type String

Field Occurrence Once

Termination (Length Field Tab)

Type Numeric

Length Select this option and enter “2” in the text box
1-12 BEA WebLogic XML/Non-XML Translator Samples Guide
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11. Click Apply. The Requested_Delivery_Date field is created and added to the tree 
pane.

Step 3. Creating Groups

To create groups:

1. Select the Requested_Delivery_Date field in the tree pane and choose 
Insert→Group→As Sibling. The Group Detail window opens.

2. Enter the group details as follows:

These values were determined by our analysis of the raw purchase order data 
presented in Table 1-3.

3. Click Apply. The Shipping_Address group is created and added to the tree pane.

We know from our initial data analysis that the Shipping Address and Billing 
Address groups contain the same fields with the same attributes. Therefore, we 
can define the Address group within the Shipping Address group and set up the 
Address group within the Billing Address group as a reference. For more 
information on references, refer to the BEA WebLogic XML/Non-XML Translator 
User Guide.

Field Value

Name Requested_Delivery_Date

Type Date: MM/DD/YYYY

Field Occurrence Once

Data Base Type String

Field Value

Name Shipping_Address

Field Occurrence Once
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4. Select the Shipping_Address group in the tree pane and choose 
Insert→Group→As Child.

5. Use the data in Table 1-3 to create the Address group and click Apply to save the 
data.

6. Follow the steps outlined in Step 2. Creating Fields, to create the Street, City, 
State, and Zip fields as children of the Address group.

Note: Once the Street field is created, you can use the Duplicate button to create 
the City and State fields.

Step 4. Creating a Group Reference

Now we are going to create the Billing Address group and fields. Since this is a 
duplicate of the Shipping Address group, we can create a group reference. A reference 
group has the same format as the original group, but you can change the optional 
setting and the occurrence setting for the reference group.

1. Select the Shipping_Address group in the tree pane and choose 
Insert→Group→As Sibling. The Group Detail window opens.

2. Enter the group details as follows:

These values were determined by our analysis of the raw purchase order data 
presented in Table 1-3.

3. Select the Address group under Shipping_Address in the tree pane and choose 
Edit→Copy. This copies the Address group details (including child objects) and 
places them on the clipboard.

4. Select the Billing_Address group you created in step 2 in the tree pane and 
choose Edit→Paste→As Reference. This pastes the copy of the Address group 
into the message definition as a sibling of the Billing Address group.

Note: You can identify this Address group as a reference by the icon located to 
the left of it in the tree pane.

Field Value

Name Billing_Address

Field Occurrence Once
1-14 BEA WebLogic XML/Non-XML Translator Samples Guide
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5. Change the Address reference group to be a child of the Billing_Address group 
by  selecting the Address reference group in the tree pane and choose 
Edit→Demote. The Address reference group moves under the Billing_Address 
group.

Step 5. Creating the Remaining Items

Follow Steps 1 through 4 above to create the remaining items necessary to complete 
the message definition for the Purchase Order sample. Use the analysis of the raw 
purchase order data presented in Table 1-3 to determine the values you need to enter 
for each item. You can use the file \sample\po\po.mfl for reference if you need 
assistance.

When you finish entering the items, your tree pane should looks similar to Figure 1-1.
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Figure 1-1   Completed Tree Pane for Purchase Order Sample

Step 6. Saving the Message Format

To save a message format file:

1. Choose File→Save As. The Save As dialog displays.

2. Navigate to the directory where you want to save the file.

3. In the File Name text box, type the name you want to assign to the file.
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Note: Format Builder automatically assigns the .MFL extension to message 
format files by default if no extension is given.

4. Click Save As to save the file in the specified location with the specified name 
and extension.

Once you have generated the Message Format definition, you can create a DTD or 
XML Schema document that describes the XML to be converted. You can set up 
Format Builder to automatically generate a DTD and/or Schema for your message 
definitions as follows:

1. From the Format Builder main window, choose Tools→Options. The Format 
Builder Options dialog opens.

2. Select Auto-generate DTD and/or Auto-generate Schema to have Format Builder 
automatically create these documents during the translation process.

3. Click OK to activate your selections.

Now, whenever you save message format documents, Format Builder will generate a 
DTD and/or a Schema for your message format. Refer to the BEA WebLogic 
XML/Non-XML User Guide for more information on DTDs and Schemas.

Step 7. Testing the Message Format

Now, you must test the message format to identify any errors that exist before using it 
to translate actual data.

1. Choose Test→Message Format. The Tester opens. This allows you to test the 
translation of the binary purchase order data into XML.

2. Click Load and navigate to the SAMPLES\PO directory. 

3. Choose the file PO_01.DATA and click Open. The left side of the Format Tester 
dialog displays the binary data.

4. Click To XML >. The binary data is translated and the right side of the dialog 
displays the purchase order data in XML format.

Note: You can see the messages output during the translation by selecting Debug.
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5. If the translated data appears correct, click Save on the right side of the dialog 
(under XML).

6. Navigate to the SAMPLES\PO directory and enter PO.XML as a name for the XML 
data.

Performing XML to Binary Translation

You can also use Format Builder to create message definitions and test the translation 
of XML data to binary. The steps required to do this are essentially the same as 
translating binary data to XML. To translate XML data to binary, first create an MFL 
description of the binary format. The Purchase Order Record sample provides an MFL 
document that can be loaded by performing the following steps:

1. Choose File→Open in Format Builder.

2. Navigate to the directory containing the desired file and select the file name.

3. Click open. The file is loaded into Format Builder.

4. Choose Tester→Message Format.

5. Under the XML panel, click Load, and navigate to the SAMPLES\PO directory. 

6. Choose the file po.xml and click Open. The right side of the Format Tester 
dialog displays the XML data.

7. Click <To Binary. The XML data is translated, and the right side of the dialog 
displays the purchase order data in Binary format.

Note: You can see the messages output during the translation by selecting Debug.
1-18 BEA WebLogic XML/Non-XML Translator Samples Guide



CHAPTER
2 Running the WebLogic 
Process Integrator 
Sample Applications

The BEA WebLogic XML/Non-XML Translator software includes two sample 
applications designed to illustrate the integration of XML Translator with BEA 
WebLogic Process Integrator. This section describes these samples and gives you 
step-by-step instructions for running the samples. The following topics are discussed:

n Prerequisite Considerations

n Running the WebLogic Process Integrator Servlet Sample

n Running the WebLogic Process Integrator EJB Sample

Prerequisite Considerations

There are certain software applications that must be installed and tasks that must be 
performed prior to running the Purchase Order sample. Please refer to the BEA 
WebLogic XML/Non-XML Translator Release Notes for more information.

Note: The instructions presented in this section assume that you have a good working 
knowledge of BEA WebLogic Process Integrator and BEA WebLogic Server. 
You should have successfully installed WebLogic Process Integrator and run 
a sample workflow prior to running the Purchase Order sample.
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Running the WebLogic Process Integrator 
Servlet Sample

This sample application implements a Web Archive (WLPI_Sample.war) that installs 
a servlet to accept requests for conversion of binary data to XML. The servlet is 
accessed via a browser and responds by displaying the generated XML data. In 
addition, a generated XML file may be posted to a JMS topic to act as a starting event 
for a WebLogic Process Integrator workflow.

Note: This sample does not require the interface to WebLogic Process Integrator; 
however, in order to start the workflow, WebLogic Process Integrator is 
required.

What is Included in the Servlet Sample

The following table provides a listing and description of the files included in the 
WebLogic Process Integrator Servlet sample application. This sample application can 
be found in the samples\wpli\servlet directory.

Table 2-1  List of Servlet Sample Application Files

Directory File Description

\servlet\source WLPI_sample.java The source code for the servlet used to present the HTML 
screen and process binary data to XML. This XML may 
be placed, optionally, onto the WebLogic Process 
Integrator JMS topic.

\servlet SampleData.mfl The Message Format Language description of the sample 
binary data file used to start the sample WebLogic Process 
Integrator workflow.

\servlet SampleData.data The sample data file used as input to start the sample 
WebLogic Process Integrator workflow.
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How to Run the Servlet Sample

This section describes the steps required to run the Servlet Sample. Follow the 
instructions appropriate for your WebLogic Server version (5.1 or 6.0). For 
instructions on the tasks specific to WebLogic Server and WebLogic Process 
Integrator, refer to the documentation that accompanies those applications.

Using WebLogic 5.1

To run the servlet sample stand-alone (without WebLogic Process Integrator):

1. Copy the license-group section from the XML Translator license file 
(license.bea) to the WebLogic Process Integrator license file. For details on this 
procedure, refer to the BEA WebLogic XML/Non-XML Translator Release Notes 
and the WebLogic Process Integrator documentation.

\servlet SampleWorkflow.xml The exported WebLogic Process Integrator workflow 
used in the sample. This workflow should be imported via 
the WebLogic Process Integrator Studio GUI to setup the 
workflow tasks involved in the sample.

\servlet WLPI_sample.war A Web Archive file containing all executable sample code 
and configuration files.

\servlet\images bealogo.jpg The BEA logo image displayed on the HTML page 
rendered by the sample servlet.

\servlet\WEB-INF hello.html The HTML page used by the sample servlet to obtain 
input data from the user.

\servlet\WEB-INF web.xml The J2EE configuration file defining deployment 
information for the sample servlet.

\servlet\WEB-INF weblogic.xml The BEA configuration file defining WebLogic-specific 
information for the sample servlet.

\servlet\WEB-INF
\lib

*.jar Utility libraries, including XML Translator, that are used 
in the execution of the sample code.

Table 2-1  List of Servlet Sample Application Files

Directory File Description
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2. Using a text editor, add the following line to the end of your 
weblogic.properties file:

weblogic.httpd.webApp.WLXT=<path to war file>/WLPI_sample.war

Note: If you have both WebLogic Server and WebLogic Process Integrator 
installed, you may have two instances of the weblogic.properties file. 
Make sure you edit the file in the WebLogic Process Integrator directory 
for this sample exercise.

3. Start WebLogic.

4. Start a web browser and enter the following URL:

http://<weblogic server>:<weblogic port>/WLXT/WLXTTest

5. Select an MFL file and a data file from your local machine.

6. Click Submit. The server response displays the generated XML data.

The following additional steps can be run to start the workflow if you are integrating 
with WebLogic Process Integrator:

1. Using a text editor, open the weblogic.properties file in the wlpi\Server 
directory.

2. Modify the mail.host parameter to contain the address of your SMTP server.

3. Start WebLogic Process Integrator.

4. Start the WebLogic Process Integrator Studio and log on.

5. Select Templates in the left pane, click the right mouse button, and choose Create 
to create a new template.

6. Select the newly created template, click the right mouse button, and choose 
Import Template Definition.

7. Select the file \samples\wlpi\SampleWorkFlow.xml.

8. Select the newly imported workflow, click the right mouse button, and choose 
Properties. The Properties dialog displays.

9. Select Active and click OK.

10. Select the workflow, click the right mouse button, and choose Save.
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11. Using a text editor, open the file \samples\wlpi\SampleData.data. Replace 
the text user@bea.com with a valid email address. This is the address the 
workflow uses to deliver the email message.

12. Open a browser and go to the following URL:

http://<weblogic server/port>/WLXT/WLXTTest

13. Enter the following path to the MFL file:

samples\wlpi\SampleData.xml

14. Enter the following path to the data file:

samples\wlpi\SampleData.data

15. Select the option to invoke WebLogic Process Integrator and click Submit. A 
short email message is sent to the address you supplied in the data file.

Using WebLogic 6.0

To run the servlet sample stand-alone (without WebLogic Process Integrator):

1. Copy the license-group section from the XML Translator license file 
(license.bea) to the WebLogic Process Integrator license file. For details on this 
procedure, refer to the BEA WebLogic XML/Non-XML Translator Release Notes 
and the WebLogic Process Integrator documentation.

2. Start WebLogic.

3. Copy the WLPI_sample.war file to the default web application directory.  By 
default, these directories are:

C:\bea\wlserver6.0\config\mydomain\applications (for Windows NT 
or Windows 2000) 

$BEA_HOME/wlserver6.0/config/mydomain/applications (for Unix)

4. If your WebLogic Server has auto-deployment enabled, the sample web 
application is deployed within several seconds. Verify the deployment setting 
using the WebLogic Server Console, as shown in Figure 2-1.
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Figure 2-1   WebLogic Server Console

5. If you have disabled auto-deployment on your WebLogic Server, you must 
statically deploy the web application using the WebLogic Server Console. To do 
this, follow the steps below:

a. From the tree in the left pane, choose Web Applications.

b. In the right pane, click Install a New Web Appolication.

c. Enter the path and file name of the WLPI_sample.war file and press Upload.

Note:Do not select the file you copied to the applications directory in step 3.
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After the WLPI_sample.war file is successfully uploaded, WLPI_sample 
appears in the tree under Web Applications. 

d. Select the new WLPI_sample node from the tree.

e. Click the Deployed checkbox in the right pane and click Apply.

f. Select the Targets tab.

g. Move your server name from the Available column to the Chosen column, as 
shown in Figure 2-2.
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Figure 2-2   WebLogic Server Console Targets Tab

6. Start a web browser and enter the following URL:

http://<host>:<port>/WLPI_sample/WLXTTest

7. Select an MFL file and a data file from your local machine.

8. Click Submit. The server response displays the generated XML data.
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The following additional steps can be run to start the workflow if you are integrating 
with WebLogic Process Integrator:

1. Start WebLogic Process Integrator.

2. Start the WebLogic Process Integrator Studio and log on.

3. From the tree in the left pane, choose Mail.

4. Enter the appropriate information to configure your mail host. Figure 2-3 shows 
an example of the Mail Session Configuration screen.

Figure 2-3   WebLogic Server Console Mail Session Configuration Tab
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5. Select the Targets tab.

6. Move your mail server name from the Available column to the Chosen column, 
as shown in Figure 2-4.

Figure 2-4   WebLogic Server Console Mail Session Targets Tab

7. Select Templates in the left pane, click the right mouse button, and choose Create 
to create a new template.
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8. Select the newly created template, click the right mouse button, and choose 
Import Template Definition.

9. Select the file \samples\wlpi\SampleWorkFlow.xml.

10. Select the newly imported workflow, click the right mouse button, and choose 
Properties. The Properties dialog displays.

11. Select Active and click OK.

12. Select the workflow, click the right mouse button, and choose Save.

13. Using a text editor, open the file \samples\wlpi\SampleData.data. Replace 
the text user@bea.com with a valid email address. This is the address the 
workflow uses to deliver the email message.

14. Open a browser and go to the following URL:

http://<weblogic server/port>/WLXT/WLXTTest

15. Enter the following path to the MFL file:

samples\wlpi\SampleData.xml

16. Enter the following path to the data file:

samples\wlpi\SampleData.data

17. Select the option to invoke WebLogic Process Integrator and click Submit. A 
short email message is sent to the address you supplied in the data file.

Running the WebLogic Process Integrator 
EJB Sample

This sample simulates a dataflow from an HR system to a payroll system, initiated by 
the entry of payroll data. The employee data is obtained from a legacy payroll system 
that uses binary data. The data is translated to XML in order to perform a calculation 
to determine the employee’s pay information. The result of the calculation is translated 
back to binary and sent on to the payroll system.
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What is Included in the EJB Sample

The following table provides a listing and description of the files included in the 
WebLogic Process Integrator EJB sample application. This sample application can be 
found in the samples\wpli\ejb directory.

Table 2-2  List of EJB Sample Application Files

Directory File Description

\ejb Makefile Make file for building the sample source to a .jar file.

\ejb WLXTExample.xml Exported sample workflow from WebLogic Process 
Integrator.

\ejb HR.mfl MFL file for binary data returned from the Sample HR 
Bean.

\ejb Payroll.mfl MFL file for binary data passed to the Sample Payroll 
Bean.

\ejb Autopay.cmd Windows NT command script to initiate the workflow 
from the command line.

\ejb Autopay.sh Unix shell script to initiate the workflow from a 
command prompt.

\ejb\lib WLXTEJB51.jar or
WLXTEJB60.jar

Executables for the sample application. The file 
WLXTEJB51.jar is used if you have WebLogic 
Server version 5.1 installed. The file WLXTEJB60.jar 
is used if you have WebLogic Server 6.0 installed.

\ejb\source XMLnonXML 
Translator.java

EJB wrapper class for WLXT.

\ejb\source XMLnonXML 
TranslatorHome.java

EJB wrapper class for WLXT.

\ejb\source XMLnonXML 
TranslatorBean.java

EJB wrapper class for WLXT.

\ejb\source Payroll.java Sample EJB to represent legacy payroll system.

\ejb\source PayrollHome.java Sample EJB to represent legacy payroll system.
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How to Run the EJB Sample

Follow the steps below to run the EJB sample. For specific instructions on performing 
the tasks in WebLogic Process Integrator and WebLogic Server, please refer to the 
documentation that accompanies those applications.

Step 1. Configure and Run WebLogic Process Integrator using WebLogic Server 
5.1

Note: If you are running WebLogic Process Integrator under WebLogic Server 5.1, 
follow the steps below.

If you are running WebLogic Process Integrator under WebLogic Server 6.0, 
proceed to Step 2. Configure and Run WebLogic Process Integrator using 
WebLogic Server 6.0.

1. Copy the license-group section from the XML Translator license file 
(license.bea) to the WebLogic Process Integrator license file. For details on this 
procedure, refer to the BEA WebLogic XML/Non-XML Translator Release Notes 
and the WebLogic Process Integrator documentation.

\ejb\source PayrollBean.java Sample EJB to represent legacy payroll system.

\ejb\source HR.java Sample EJB to represent legacy HR system.

\ejb\source HRHome.java Sample EJB to represent legacy HR system.

\ejb\source HRBean.java Sample EJB to represent legacy HR system.

\ejb\source AutoPay.java Program to place a pre-formatted message on the WLPI 
Event Topic to start the sample workflow.

\ejb\source HexDump.java Utility class used by the sample EJBs.

\ejb\source EmployeeRecord.java Employee data class used by the sample HR EJB.

Table 2-2  List of EJB Sample Application Files

Directory File Description
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2. Deploy the sample beans by adding an entry to the WebLogic Properties file. For 
example:

weblogic.ejb.deploy=d:/beahome/wlxt1.0/samples/ejb/lib/WLXTEJB51.jar

3. Add the full path and file name of the following .jar files to the server.cmd 
file used to start the WebLogic Process Integrator Server.

xmlx.jar
dom2.jar
sax2.jar
ebase.jar
wlxt.jar

4. In the WebLogic Process Integrator home directory, create a subdirectory called 
mflrepos.

5. Copy the two sample .mfl files included with this sample (Payroll.mfl and 
HR.mfl) to the new subdirectory.

6. Start the WebLogic Process Integrator Server.

7. Run WebLogic Process Integrator Studio.

Step 2. Configure and Run WebLogic Process Integrator using WebLogic Server 
6.0

1. Copy the license-group section from the XML Translator license file 
(license.bea) to the WebLogic Process Integrator license file. For details on this 
procedure, refer to the BEA WebLogic XML/Non-XML Translator Release Notes 
and the WebLogic Process Integrator documentation.

2. Copy the file WLXTEJB60.jar from the \samples\wlpi\ejb\lib directory 
where you have XML Translator installed to the \lib directory where you have 
WebLogic Process Integrator installed.

3. Open the file config.xml in a text editor. This file can be found in the directory 
<BEA_Home>\wlserver6.0\config\<domain_name>.

4. Add the following lines to the end of the WebLogic Process Integrator 
Application section of the file:

<EJBComponent
Name=”wlxt-sample”
Targets=”<your_machine_name>”
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URI=”WLXTEJB60.jar”
/>

Figure 2-5 shows an example of the Application section of the config.xml file 
with the above lines added.

Figure 2-5   Sample config.xml file

5. Add the full path and file name of the following .jar files to the server.cmd 
file used to start the WebLogic Process Integrator Server.

xmlx.jar
dom2.jar
sax2.jar
ebase.jar
wlxt.jar

6. In the WebLogic Domain home directory, create a subdirectory called mflrepos. 
By default, this directory is:

$BEA_Home/wlserver60
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7. Copy the two sample .mfl files included with this sample (Payroll.mfl and 
HR.mfl) to the new subdirectory.

8. Start the WebLogic Process Integrator Server.

9. Run WebLogic Process Integrator Studio.

Step 2. Create the Business Operations for the Workflow

You need to create seven business operations for the sample. These business 
operations are referenced by the sample workflow; therefore, their names must exactly 
match the list below.

n Create XML/nonXML Translation Bean

n Create Example HR Bean

n Get Employee Info

n Translate Binary to XML

n Create Example Payroll Bean

n Post Payroll Data

n Translate XML to Binary

Notes: The names of these operations must exactly match the above list. Business 
operation names are case-sensitive.

To create the business operations:

1. Choose Configure→Business Operations and click Add.

2. Enter the information for each business operation as shown in each of the seven 
dialog illustrations that follow.

3. After you enter the information in the dialog, click OK.

4. Repeat steps 1 through 3 for each business operation.
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Figure 2-6   Create XML/nonXML Translation Bean Business Operation
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Figure 2-7   Create Example HR Bean Business Operation
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Figure 2-8   Get Employee Info Business Operation
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Figure 2-9   Translate Binary to XML Business Operation
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Figure 2-10   Create Example Payroll Bean Business Operation
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Figure 2-11   Post Payroll Data Business Operation
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Figure 2-12   Translate XML to Binary Business Operation

The following dialog shows a list of the completed business operations.
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Figure 2-13   List of Completed Business Operations

5. Click Done when you have finished creating the Business Operations.

Step 3. Create the Template and Import the Template Definition

To create the template and import the template definition:

1. Create a new template called WLXT Example.

2. Select the template from the tree view in the left pane and click the right mouse 
button.

3. Choose Import Template Definition.

4. Select the definition file WLXTExample.xml. A message box opens informing 
you that the business operations you just created will be executed during this 
workflow.
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Figure 2-14   Import Message

5. Click OK to close the message box. A confirmation message displays.

Figure 2-15   Import Confirmation Message

6. Click OK to close the message box.

Step 4. Open and Activate the Template

To open and activate the template:

1. Select the WLXT Example template definition imported in the previous step from 
the tree view and click the right mouse button.
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2. Choose Open. The workflow created for this sample application displays.

Figure 2-16   Workflow for WLXT Example

3. Select the WLXTExample template definition again from the tree view and click 
the right mouse button.

4. Choose Properties. The Template Definition properties dialog displays.
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Figure 2-17   Template Definition

5. Click Active to activate the template and click OK.

6. Select the WLXTExample template definition a third time from the tree view and 
click the right mouse button again.

7. Choose Save to save the template definition with the changes you made.
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Step 5. Start the Workflow

There are two ways to start the workflow created in the sample:

n From the WebLogic Process Integrator Worklist

n From the Command Line

From the WebLogic Process Integrator Worklist

To start the sample workflow from the Weblogic Process Integrator Worklist:

1. Start WebLogic Process Integrator Worklist and choose Workflow→Start a 
Workflow.

2. Select WLXT Example. The template opens and the tasks are displayed.

Figure 2-18   WLXT Example Worklist

3. Select the Enter Payroll Data task and click the right mouse button.

4. Choose Execute. The Enter Payroll Data dialog displays.
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Figure 2-19   Enter Payroll Data

5. Enter the payroll data and click OK. The task is started and the workflow runs.

Note: For this example, the employee numbers 1 through 4 are valid. You can 
enter any period ending date and any number of hours worked.

From the Command Line

To start the sample workflow from a command line prompt:

1. Open the script file (Autopay.cmd on Windows NT systems; Autopay.sh on 
Unix systems) in a text editor and check the location of the WebLogic Process 
Integrator Server. By default, the location is localhost and port:7001.

2. Change the location information to match the host and port for your system.

3. Run the command scripts for your system (Windows NT or Unix), passing the 
same parameters shown in Figure 2-19. For example:

Autopay 1 2000-11-30 60

Figure 2-20 shows the WebLogic Process Integrator output from executing the 
workflow.
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Figure 2-20   WebLogic Process Integrator Server Console
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