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Guide to Data Transformation

NOTE TO REVIEWERS:

It's hard to architect a document that works both as a "Guide" to be read from end to end and works as
context sensitive help. | view the Context Sensitive Help as being a very important addition for SP3, so you
may notice changes to the documentation that makes it less readable as a guide but more usable as contex
sensitive help. For example, | have moved more topics up a level, so | can link directly from the panes of the
product to the sections.

In WebLogic Workshop business processes, data can be transformed using either a query or a eXtensible
Stylesheet Language Transformation (XSLT). This guide describes how to use the mapper functionality of
WebLogic Workshop to create a data transformation graphically. From this graphical representation of a dat
transformation, WebLogic Workshop generates a query. The generated query is invoked during run time by
the business process to transform data. The query is written in the XQuery language a language defined by
the World Wide Web Consortium (W3C) that provides a vendor independent language for the query and
retrieval of XML data.

This guide also describes how to import an existing eXtensible Stylesheet Language Transformation (XSLT)
into WebLogic Workshop for data transformation. An XSLT is written in the eXtensible Stylesheet Language
(XSL) an older language defined by the W3C that supports the use of stylesheets for the conversion of XML
data. In WebLogic Workshop, the preferred method for data transformations is to use queries in the XQuery
language. Data transformations using XSL Transformations is supported primarily for legacy applications.

This guide also describes the design—time and run—time considerations for transforming non—XML data to
other types of data.

Topics Included in This Section

Transforming Data Using XQuery

Describes how to use the mapper functionality of WebLogic Workshop to create a query (written in the
XQuery language) for transforming data between XML, non—-XML, Java classes, and Java primitive data
sources.

Examples: Manipulating and Constraining Data Using XQuery

This section provides information and examples on how to use the mapper functionality of WebLogic
Workshop to constraint or manipulate data in a transformation.

Transforming Non—-XML Data

Describes the design—-time and run—time steps required for the transformation of data between a non—-XML
format and an XML format in WebLogic Integration.

Transforming Data Using XSLTs

Describes how to import a XSLT (eXtensible Stylesheet Language Transformation) into WebLogic workshoy
for transforming XML data (valid to one XML Schema) to XML data (valid to a different schema.)

Guide to Data Transformation 1



Guide to Data Transformation

Programming Transformations

Describes programming considerations for transformations outside the mapper functionality of WebLogic
Workshop.

Guide to Data Transformation 2



Transforming Data Using XQuery

Data transformation is the mapping and conversion of data from one format to another. This section describ
how to build a data transformation using the mapper functionality of WebLogic Workshop. To transform date
using an existing eXtensible Stylesheet Language Transformation (XSLT), see Transforming Data Using
XSLTs.

The mapper functionality of WebLogic Workshop enables the conversion of data of different types. For
example, XML data can be transformed from XML data valid to one XML Schema to another XML
document valid to a different XML Schema.

The source types and target type of a data transformation can be any of the following data types:

* XML Data

* Non—-XML Data

* Java Primitives

« Java Classes To learn more, see Using Java Classes in Transformations.

A data transformation can have multiple source inputs but only one output target. For example you can
transform data from three input data sources to one target source, as shown in the following figure.

Source XML Data
4|I"1 o
" Source XML Schema Flle -
: : WebLogic
"""""""""""" Workshop
Source Non-XML Data \
Data : Target XML Data
‘ Transformation il
......... "h‘"“ f valid to
. schema in the MFL
: (msam meﬂ .......................

Language) file

Source Java primitive

This section describes how to use the mapper functionality of WebLogic Workshop to create a data
transformation graphically. From this graphical representation of a data transformation, WebLogic Workshoy
generates a query. The query is written in the XQuery language a language defined by the W3C that provide
a vendor independent language for the query and retrieval of XML data.

This section contains the following topics:

 Creating Schemas Projects

* Importing Schemas

 Creating a Transformation File and a Transformation Method
 Selecting Source and Target Types

 Creating Maps

* General Steps to Open or Create a Query in the Mapper

Transforming Data Using XQuery 3
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« Viewing and Editing the Generated Code of Maps
 Testing Maps in the Test View

* Link Representations

» Modifying Links Using the Target Expression Tab
* Using the Constraints Tab

» Using Java Classes in Transformations

» The Association Between XQ and DTF Files
 Using the Data Palette of the Mapper

« Validating

« Using the Property Editor of the Mapper

« XML Global Element, Global Type, and Local Element Components

Related Topics

To learn more about data transformations and for a step—by-step walk through of the mapping functionality,
see Tutorial: Building Your First Data Transformation.

For more information and examples on how to use the mapper functionality to constraint or manipulate data
see Examples: Manipulating and Constraining Data Using XQuery.

To learn about the XQuery language, see the XQuery 1.0: An XML Query Language Specification — W3C
Working Draft 16 August 2002 available from the W3C web site at the following URL:

http://iwww.w3.0rg/TR/2002/WD-xquery—20020816/

The WebLogic XQuery engine which is invoked by the Transformation method conforms to the August 16,
2002 draft of the XQuery Specification.

To learn more about XML and XML Schemas, see Java and XML Basics.

Transforming Data Using XQuery 4



Creating Schemas Projects

When you create a new Process application, by default a project folder named Schemas is created in the
business process application folder of the Application tab of WebLogic Workshop. Additional project folders
of either Schema Project or WLI System Schemas type can be created in your application folder.

In this document, the phrases a Schemas project folder or the current Schemas project folder refers to any
project folder of either Schema Project or WLI System Schemas type in the current application. It can have
the default name: Schemas or any other legal project name.

MFL and XSD files can be imported into project folders or subfolders of either Schema Project or WLI
System Schemas type. You can have one or more project folders of either Schema Project or WLI System
Schemas type in an application folder. For example, you might want to place schemas that do not change v
often into the default project folder named Schemas and create another Schema Project folder called
MySchemas which contain schemas that change more often. (If a schema file changes in the project folder:
the schemas in that project folder are built again.) Partitioning your schemas in this way can reduce the
schema build time. For example, if a schema keeps changing in the MySchemas project folder, the schema:
the Schemas project folder will not be built.

Project folders of either Schema Project or WLI System Schemas type are same except Project folders of
the type WLI System Schemas also contain WebLogic Integration system XSD files. Importing MFL and
XSD schema files into project folders of either type will make these schemas available in the current
application. In addition, the default project folder named Schemas also contains the WebLogic Integration
system XSD files. (This default project folder named Schemas is created when a new business process
application is created in WebLogic Workshop.)

For example, you may want to create a Project folder of the WLI System Schemas type, if you deleted a
WebLogic Integration system XSD file in the default project folder named Schemas, and you now want
access to that system XSD file in your application.

This section contains the following tasks:

» To Create Business Process Application (Required)
» To Create Additional Schema Project or WLI System Schemas Project Folders (Optional)

To Create Business Process Application (Required)
Open or create a business process project and application. For instructions, see Creating a Business Proce
Application. When you create a new business process application, by default a project folder named Schem
is created. You can use the project folder named Schemas to import your MFL and XSD files into your
business process application or you can create additional Schema Project or WLI System Schemas project
folders and import your MFL and XSD files into those project folders as described in the following task.
To Create Additional Schema Project or WLI System Schemas Project Folders (Optional)

1. In the Application tab, right—click on the top-level application folder. (If the Application tab is not

visible in WebLogic Workshop, choose View > Application from the menu bar.)
2. From the drop—down menu, select New > Project....

The New Project dialog box is displayed.
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3. In the left-most pane of the New Project dialog box, select the Schema folder.

4. In the right-most pane of the New Project dialog box, select either Schema Project or WLI System
Schemas.

5. In the Project name field, enter a name (for example: MySchemas) and click Create.

6. A new schema project folder is created in the Application tab.

Creating Schemas Projects 6



Importing Schemas

In this task, you import your schemas into your application. The following schema types are supported:

* XML Schema W3C XML Schema files describe and constrain the content of XML documents. (The
XSD files that contain XML Schemas end in the .xsd extension.) You can create XSD and XML files
and validate XML files against XML Schemas using XML Spy which is bundled with WebLogic
Platform. For instructions on starting XML Spy see How Do I: Start XMLSPY?.)

Note: Multiple namespaces in XML and XSD files are supported in WebLogic Workshop. For
example, you can transform two source XML files valid to different namespace to another XML file
which is valid to a third namespace. To learn more, see Understanding the Transformation of the
Tutorial: Building Your First Data Transformation.

 MFL MFL (Message Format Language) documents describe and constrain the content of non—-XML
data. For example, data coming from COBOL copybooks and C structure definitions. (MFL files are
created using the Format Builder and end in the .mfl extension. For instructions on using Format
Builder, see Using Format Builder to Create Format Schemas (MFL Files).)

Note: The file name of the MFL document becomes the namespace of the MFL elements.

When a schema (described in an XSD or MFL file) is imported into your application, representations of thes
schemas are available in some of the panes of WebLogic Workshop. In addition, Java interfaces for accessi
the data represented in the schemas are generated. To learn more about these Java classes see Java Clas
Created From Importing Schemas.

Note: Due to a Windows operating system limitation on file path lengths (256 characters), you might have
trouble compiling schemas in which the generated types are nested in a very deep package hierarchy. This
may result in an error message stating that a particular class couldn't be found. To work around this limitatio
try using an xsdconfig file to guide the naming of generated packages so that the hierarchy is less deep,
package names are shorter, etc. For more information, see How Do |: Guide XMLBeans Type Naming Durir
Schema Compilation?.

QUESTION FOR REVIEWERS: | updated the following section. Could you please read it carefully?

Importing an XML Schema (XSD file)

When an XSD file (which contains an XML Schema) is imported into a Schema project folder of a
WebLogic Workshop application, a build of the application is triggered which generates XMLBeans based o
the imported XML Schema. The XML Beans provides Java classes for accessing the XML data that conforn
to the imported XML Schema. These Java classes are available as XML types in the type system of the
application. To learn more, see Getting Started with XMLBeans.

After XML Beans are generated for an XML Schema, the following options are enabled in WebLogic
Workshop:

» The ability to create XML business process variable of the XML Schema type from the Data Palette
of a business process. The Data Palette of a business process is available when a JPD file is active
WebLogic Workshop. (If the Data Palette is not visible with a JPD file active, choose View >
Windows > Data Palette from the menu bar.) To learn more about business process variables, see
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Creating Variables.
» The ability to select the XML types as a source or target type for a transformation. To learn more, se
To Select the Source and Target Types and To Change the Selected Source or Target Parameters.
» The ability to select a displayed XML type from Data Palette of the mapper. (The XML Schema
type must be selected as a source or target type in order for it visible in the Data Palette of the
mapper.) The Data Palette of the mapper is available when an XQ file is active is WebLogic
Workshop. An XQ file contains a query which is written in the XQuery language. (If the Data Palette
is not visible, with a XQ file active, choose View > Windows > Data Palette from the menu bar.)
To learn more about mapper variables, see Using the Data Palette of the Mapper.

Note: The Data Palette of the mapper displays a different set of variables than the variables
displayed in the Data Palette for business processes (JPDs). The variables displayed in the Data
Palette of the mapper are used only in transformations and are distinct from the variables used in
business processes.

Importing an MFL File

When an MFL file (which contains a schema describing non—-XML data) is imported into a Schema project
folder of a WebLogic Workshop application, a build of the application is triggered which generates XML

Beans based on the schema in the imported MFL file. From the definitions in the MFL file, Non—-XML types
as well as XML types (from the schema in the MFL file) are available in the type system of the application.

These generated XML Bean classes provide methods for access the data that conforms to an MFL file. (The
Java class contains get and set methods for accessing the MFL data, similar to the XMLBean Java interface
that is generated when a XML Schema is imported and built.) To learn more about the XML Schema
representations generated from an MFL file see Java Classes Created From Importing Schemas. To learn n
about XMLBeans, see Getting Started with XMLBeans.

In addition, an MflObject Java class is also generated for the MFL file. This Java class provides methods for
the conversion between non—-XML and XML data, programmatically outside the mapper functionality of
WebLogic Workshop. To learn more, see Java Classes Created From Importing Schemas.

After XML Beans are generated for the schema defined in the MFL file, the following options are enabled in
WebLogic Workshop:

» The ability to create a Non—XML business process variable (that conforms to the schema in the MFL
file) from the Data Palette of a business process. (If the Data Palette is not visible with a JPD file
active, choose View > Windows > Data Palette from the menu bar.) For example, if a
StockQuotes.mfl is imported into a Schemas project a StockQuotes.mfl node is visible from the
Create Variable pane for the NonXML variable type. To launch the Create Variable pane, choose
Add > Variables in the top right—hand corner of the Data Palette pane when a JPD is active. This
is an internal representation of the XML Schema not available outside of WebLogic Workshop. To
learn more about business process variables, see Creating Variables.

» The ability to create an XML business process variable derived from the schema in the MFL file
from the Data Palette of a business process. (If the Data Palette is not visible, with a JPD file active,
choose View > Windows > Data Palette from the menu bar.) For example, if a StockQuotes.mfl
is imported into a Schemas project a StockQuotes.xsd.mfl node is visible from the Create Variable
pane for the XML variable type. To launch the Create Variable pane, choose Add > Variables in
the top right—hand corner of the Data Palette pane when a JPD is active. This is an internal
representation of the XML Schema not available outside of WebLogic Workshop. To learn more
about business process variables, see Creating Variables.

Importing Schemas 8
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» The ability to select the Non—-XML type or the XML type (derived from definitions in the MFL file)

as a source or target type for a transformation in the Configure XQuery Transformation Method
pane. When you select the Non—-XML or XML type as a source type for a transformation, a variable
of the source type is displayed in the Data Palette of the mapper.

Note: The Raw Data type represents unstructured Non—-XML data. This type is not available in data
transformation.

The ability to select a displayed schema type (derived from the MFL file) in the Data Palette of the
mapper. (The XML Schema type must be selected as a source or target type in order for it visible in
the Data Palette of the mapper.) The Data Palette of the mapper is available when an XQ file is
active is WebLogic Workshop. An XQ file contains a query which is written in the XQuery language.
(If the Data Palette is not visible, with a XQ file active, choose View > Windows > Data Palette
from the menu bar.) To learn more see Using the Data Palette of the Mapper.

Note: The Data Palette of the mapper displays a different set of variables than the variables
displayed in the Data Palette for business processes (JPDs). The variables displayed in the Data
Palette of the mapper are used only in transformations and are distinct from the variables used in
business processes.

To make the schemas in XSD and MFL files available in your process application, you must import them int
a Schemas project folder. (To learn more, see a Creating Schemas Projects.) You can import XSD and MFL
files into a Schemas project folder, by following the steps described in one of the following tasks:

e To Import an XSD or MFL file Into Your Application Using the Import Option of the Schemas

Folder Drop—Down Menu

e To Import an XSD or MFL file Into Your Application Using Drag—And-Drop

To Import an XSD or MFL file Into Your Application Using the Import Option of the Schemas Folder
Drop—Down Menu

In this task, you import XSD or MFL files using the Import option of the drop—down menu of a Schemas
project folder.

1.

2.

In the Application tab, right—click on a Schemas project folder. (If the Application tab is not visible
in WebLogic Workshop, choose View > Application from the menu bar.)
From the drop—down menu, select Import... .

The Import Files dialog box is displayed.

. Browse the file system, and select your XSD file (ends in the.xsd extension) or MFL file (ends in

the.mfl extension), and click Import.

The schema in the XSD or MFL file is imported. This triggers a build of the current Schemas project
folder. (The build verifies that the schema file is well formed. For XSD files, it also verifies that the
element and attribute names in the XML Schema do not conflict with the XSD files that have already
been imported into the current Schemas project folder.)

Any errors that occur when compiling your XSD and MFL files will be displayed in the WebLogic
Workshop Build tab. For all of the XSD and MFL files imported into a Schema project, you must fix
any reported errors before you will be able to use these schemas in business processes or
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transformations.
To Import an XSD or MFL file Into Your Application Using Drag—And-Drop
In this task, you import XSD or MFL files by dragging—and—dropping them into a Schemas project folder.

In a Windows Explorer pane, select the XSD or MFL file and drag it into a Schemas folder. (If the
Application tab is not visible in WebLogic Workshop, choose View > Application from the menu bar.)

The schema in the XSD or MFL file is imported. This triggers a build of the current Schemas project folder.
(The build verifies that the schema file is well formed. For XSD files, it also verifies that the element and
attribute names in the XML Schema do not conflict with the XSD files that have already been imported into
the current Schemas project folder.)

Any errors that occur when compiling your XSD and MFL files will be displayed in the WebLogic Workshop
Build pane. For all of the XSD and MFL files imported into a Schema project, you must fix any reported
errors before you will be able to use these schemas in business processes or transformations.

Note: Outside of WebLogic Workshop, you can also copy XSD or MFL files directly into a Schemas project
folder in the file system. For example, if your application saved in the C:\user_projects\applications\myApp
directory contains the default Schemas project, you can save the MFL file directly into this
C:\user_projects\applications\myApp\Schemas directory in the file system. This will trigger a build of the
current Schemas project folder in WebLogic Workshop.

Importing Schemas 10



Creating a Transformation File and a Transformation
Method

This section describes how to create a Transformation file (also know as a DTF file because it ends in the .c
extension). In addition, this section describes how to add a Transformation method to the DTF file. Each
Transformation method contains a single data transformation the mapping and conversion of data from one
format to another.

Data Transformations in business processes can be created in the following ways:

» While creating a Client Request, Client Response, Control Send, Control Send with Return, or
Control Receive nodes in a specific business process For instructions on creating a transformation
from a Client or Control node, see Interacting With Clients and Interacting With Resources Using
Controls, respectively.

» While building a data transformation independent of a specific business process, from the WebLogic
Workshop menu bar This section describes how to create a standalone data transformation from the
menu bar and store it in a DTF file. Creating a transformation stored in a standalone DTF allows for
the reuse of the transformation in different nodes of a business process.

This section contains the following tasks:

* To Create a Transformation File From the Menu Bar
* To Add a Transformation Method to Transformation File

To Create a Transformation File From the Menu Bar

1. Open business process project and application.
Note: You must be active in a business process project, in order for Transformation File option to
be available from the New File dialog box. (If the Application tab is not visible in WebLogic
Workshop, choose View > Application from the menu bar.)

2. In the Application tab, select a subfolder of a project folder. (Project folder names end with the
string: Web.)

3. From the WebLogic Workshop menu bar, choose File > New > Transformation File.
The New File dialog box appears.

4.In the File name field, enter file.dtf, where file represents the file name in which the Transformation
file is stored. In this example, the file name is dataTrans is entered.

5. Click Create.

In the Design View, a graphical representation of the dataTrans Transformation file appears, as
shown in the following figure.

Creating a Transformation File and a Transformation Method 11



Guide to Data Transformation

_|; dataTrans Transformation

Member Variables

In addition, a Transformation file (ending in the .dtf extension) is created. For this example, the
Transformation file called dataTrans.dtf is created and is visible in the Application tab.

To Add a Transformation Method to Transformation File

1. In the Design View, right—click in the box representing the dataTrans Transformation file. The box
shown in the preceding figure. (Where dataTrans is the name of the Transformation file.)
2. From the drop—down menu, select Add Transformation Method.

A transformation method is created in the Transformation file.
3. Enter myTransMethod, where myTransMethod represents the method name.
The Transformation method in the Transformation file is created. This task does not however, create
the XQ file to store the query. The XQ file is created in the following section. XQ files contain
queries written in the XQuery language which end in the .xq extension.
In addition to transformation methods, user—defined Java methods can added to a Transformation file. (Use
methods are user—defined Java methods that can be called from XQuery code.) For instructions on adding :

User method, see To Add a User Method to a Transformation File.

Note: You can also create transformation methods and user methods in the Design View of a DTF file, by
dragging—and-dropping the Transformation Method and User Method icons, respectively from the Palette

to the Design View.

Creating a Transformation File and a Transformation Method 12



Selecting Source and Target Types

In the following tasks, you select the source and target types from the Source or Target panes of the
Configure XQuery Transformation Method — methodName dialog box. (Where methodName represents

the current Transformation method.) Source types are the input data types for the data transformation the d:
types that are transformed to the target data type.

This section contains the following tasks:

» To Select the Source and Target Types

» To Change the Selected Source or Target Parameters

» Updating the Graphical Representation Displayed in the Source View of a XQ File
To Select the Source and Target Types

1. Select or create a Transformation file.

For instructions on creating a Transformation file see To Create a Transformation File From the
Menu Bar.

To select an existing Transformation file:

a.In the Application tab, expand the folders that contain the Transformation file. (If the
Application tab is not visible in WebLogic Workshop, choose View > Application from
the menu bar.)
b. In the Application tab, double—click the Transformation file (ends in the .dtf extension).
2. Select or create a method from a Transformation file.

For instructions on creating a method in a Transformation file, see To Add a Transformation Method
to Transformation File.

To select an existing method, in the Design View of the Transformation file (ends in the .dtf
extension), right—click the arrow representing the method, as shown in the following figure:

CUJ Vdatal’rans Transformation

}_ . —w—t] myTranshethod

Rig ht-click 'Member Variables
here

3. From the drop—down menu, select Configure XQuery Transformation Method.
The Configure XQuery Transformation Method dialog box is displayed. In the Available Source

Types pane of Configure XQuery Transformation Method dialog box, the list of available source
types are displayed.

Selecting Source and Target Types 13
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Note: In order for schema representations to be available in the Available Source Types and
Available Target Types pane, the XSD and MFL files which contain these schemas must be
imported into a Schemas project folder and the current application must have completed building. Tc
learn more, see Selecting Source and Target Types.

4. Select the desired source type from the XML, NonXML, and Java options.
5. Specify an source type, by doing one of the following:

To specify an XML, NonXML, or Java primitives source type:

a.In the Available Source Types pane, expand the schema and element folders, until you find
the desired element.
b. Select an source element.
c. If desired, change the default name provided in the Name field. This field specifies the name
the mapper uses to refer to this element.
d. Click Add.
To specify a Java class source type:

a. The Java class for conversion must be available in the current project. To learn more about
including a Java class in your project, see Using Existing Applications.
b. In the Type field, of the Available Source Types pane, enter the full package name of the
Java class. For example, for a class named Book in the package named org.library, enter:
org.library.Book in the Type field.
QUESTION FOR REVIEWERS: This the way | had it but | think it was wrong:

In the Type field, of the Available Source Types pane, enter the full package name of the Java class. For
example, for a class named Book in the package named library.org, enter: org.library.Book in the Type field.

a.If desired, change the default name provided in the Name field. This field specifies the name
the mapper uses to refer to this element.
b. Click Add.

To learn more, see Using Java Classes in Transformations.

The elements and attributes that make up the selected element are displayed in the Selected Source
Types pane.

Note: Non—-XML Types/Untyped/RawData is not supported as a source or target type for a
Transformation method. RawData has no associated structure and therefore can not be transformed
using the mapper. To learn more, see Create a New Instance of an MflObject From Untyped Raw
Data Example.

6. Repeat step 5 for an additional source types.
Note: Multiple source types can be specified.

7. Specify an source type, by doing one of the following:

To specify an XML, NonXML, or Java primitives source type:

Selecting Source and Target Types 14
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a.In the Available Target Types pane, expand the schema and element folders, until you find
the desired element.
b. Select an target element.
c. Click Add.
To specify a Java class source type:

a. The Java class for conversion must be available in the current project. To learn more about
including a Java class in your project, see Using Existing Applications.

b. In the Type field, of the Available Target Types pane, enter the full package name of the
Java class. For example, for a class named Book in the package named org.library, enter:
org.library.Book in the Type field.

c. Click Add.

To learn more, see Using Java Classes in Transformations.

The elements and attributes that make up the selected element are displayed in the Selected Target
Types pane.

Note: Only one target type can be specified.
8. If desired, select the Schema Validate Parameters check box.

If this check box is selected, during run time the source parameters are validated against their schen
types before the transformation is executed. To learn more, see Schema Validating During Run Time

Note: The Schema Validate Parameters check box will only be enabled if all the parameters and
the return type are typed XML or typed MFL types.

9. If desired, select the Schema Validate Return check box.

If selected, during run time the target parameter is validated against its schema type after the
transformation is executed. To learn more, see Schema Validating During Run Time.

Note: The Schema Validate Return check box will only be enabled if all the parameters and the
return type are typed XML or typed MFL types.

10.Click Create Transformation.
Note: You do not have to select an source type but you must select an target type.
An XQ file (ending in the .xq extension) is created to store the query and displayed in the
Application tab. The query is written in the XQuery language. XQ files are associated with a
particular DTF file and appear indented under the associated DTF file in the Application tab. To
learn more, see The Association Between XQ and DTF Files.

To Change the Selected Source or Target Parameters

If links have been created between source and target types in the Design View of an XQ file, then XQuery
code has been generated which refers to the source and target types.
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If you change the source and target types of the query, the existing XQuery code remains unchanged and n
be referencing the original source or target types which may be no longer valid for this query. The XQuery
code in the query may now be invalid and may require some manual XQuery code clean up as described in
last step in the following task.

Note: You may be able to minimize the amount of clean—up required by using the same name for the source
variable in both the original and new query. Instead of having different names for the original and new sourc
variables, for example: oldOrderDoc/po—number and newOrderDoc/po—number, respectively, use the same
name: orderDoc/po—number for both.

To change or add source parameters or change the target parameter:

1. Select the Transformation file (ends in the .dtf extension) that contains that Transformation method:
a.In the Application tab, expand the folders that contain the Transformation file. (If the
Application tab is not visible in WebLogic Workshop, choose View > Application from
the menu bar.)
b. In the Application tab, double—click the Transformation file (ends in the .dtf extension) that
contains the Transformation method.
2. Select the method from the Transformation file. In the Design View of the Transformation file,
right—click the arrow representing the method.
3. From the drop—down menu, select Reconfigure XQuery Transformation Method.

The Configure XQuery Transformation Method dialog box is displayed.

4. Remove and add elements in the Available Source Types and Available Target Types pane as
desired.
5. If desired, select the Schema Validate Parameters check box.

If this check box is selected, during run time the source parameters are validated against their schen
types before the transformation is executed. To learn more, see Schema Validating During Run Time

Note: The Schema Validate Parameters check box will only be enabled if all the parameters and
the return type are typed XML or typed MFL types.

6. If desired, select the Schema Validate Return check box.

If selected, during run time the target parameter is validated against its schema type after the
transformation is executed. To learn more, see Schema Validating During Run Time.

Note: The Schema Validate Return check box will only be enabled if all the parameters and the
return type are typed XML or typed MFL types.

7. Click Edit Transformation.

8. Clean up the XQuery code if required. If you changed the source and target types of the query, the
existing XQuery code remains unchanged the XQuery code is not regenerated and therefore any
references in the XQuery code to the original source or target types remain in the query. These
references may be invalid for this query depending on what source and target types were changed a
described in the following guidelines:

9. If you added an additional source type, no XQuery code clean up is required.

10.1f you remove an existing source type, the XQuery code that references the removed source type wil
be invalid and may need to be removed.
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11.1f you change the existing source or target types, the XQuery code that references the changed sour
or target type may be invalid depending on differences between the old and new schemas and may
need to be removed.

To view the XQuery source code including any errors:

a.In the Application tab, expand the folders that contain the XQ file. (If the Application tab is
not visible in WebLogic Workshop, choose View > Application from the menu bar.)

b. In the Application tab, double—click the XQ file that contains XQuery code.

c. Select the Source View tab.

The XQuery code is displayed and the invalid XQuery code is underlined in red.

9. Fix the errors reported in the Source View. To view a detailed description of an error, move the
mouse over the error in the Source View.

If desired, you can delete all the XQuery code in the Source View of the XQ file by removing all the
XQuery source code after the namespace declaration(s) and recreating your links in the Design Viev

Updating the Graphical Representation Displayed in the Source View of a XQ File

QUESTION FOR REVIEWERS: Does this still apply? Do | need to include this section? Sandip says it is no
required. He says "changes to the transformation method in the DTF source view will force a rebuild of the
mapper design view when the XQ document is activated" Frank, do you agree?

The following procedure describes how to force the mapper to display an updated graphical representation
an XQ file in the Design View, if you have manually changed the source or target parameters of a
Transformation method in the Source View of the Transformation file. To update the graphical representatio
of the XQ file, complete the following steps:

1. View the Transformation file that contains the query (stored in the XQ file) in the Design View:
a.In the Application tab, expand the folders that contain the Transformation file. (If the
Application tab is not visible in WebLogic Workshop, choose View > Application from
the menu bar.)
b. In the Application tab, double—click the Transformation file (ends in the .xsd extension).
c. Select the Design View tab.
2. Select the desired Transformation method from a Transformation file:
a.Right—click the arrow representing the method.
b. From the drop—down menu, select Reconfigure XQuery Transformation Method.
The Configure XQuery Transformation Method dialog box is displayed.

3. Click Edit Transformation.

The graphical representation of the object is displayed in the Design View of the XQ file.
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Creating Maps

To create maps between elements, you must have selected at least one input source schema and the outpt
target schema. For instructions, see To Select the Source and Target Types and To Change the Selected
Source or Target Parameters.

1. Select a Transformation file.

For instructions on creating a Transformation file see To Create a Transformation File From the
Menu Bar.

To select an existing Transformation file:

a.In the Application tab, expand the folders that contain the Transformation file. (If the
Application tab is not visible in WebLogic Workshop, choose View > Application from
the menu bar.)
b. In the Application tab, double—click the Transformation file (ends in the .dtf extension).
2. Select a Transformation method from a Transformation file.

For instructions on creating a method in a Transformation file, see To Add a Transformation Method
to Transformation File.

To select an existing method, in the Design View of the Transformation file:
a.Right—click the arrow representing the method.
b. From the drop—down menu, select Goto XQuery Document.

The mapper pane is displayed.

3. Select the Design View tab.

The selected input source documents are listed in the Source pane and the selected output target
document is listed in the Target pane.

Warning: If a schema is not listed in the Source or Target panes, you will not be able to create links.
For instructions to import the schema, see To Select the Source and Target Types and To Change tl
Selected Source or Target Parameters.

Note: A schema may not be listed in the Source or Target panes while an application is building.
Wait until the build has completed before selecting the schema.

The Design View displays the a graphical representation of the selected source schemas in the
Source pane.

4. Drag a node from the Source pane to a node in the Target pane.
While dragging a node from the Source pane over nodes in the Target pane, a temporary link (a

dashed line) appears between the two nodes. The color of the dotted line changes depending on the
compatibility between the source and target node, as shown in the following table:
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The Color of
the Dashed Means . ..
Lineis. ..

No link can be created between the source node and the target node. The datd type of
the target node cannot be converted to the data type of the source node. (The [ink

Red represents a illegal mapping.) For example, a node of data type XML string can not be
converted to an XML repeating node. A red error dialog box will be displayed when

you drag the source node over the target node.
A link can be created between the source node and the target node but the data types
Orange are not completely compatible. An orange warning dialog box describing the
incompatibility will be displayed when you drag the source node over the target node.
A link can be created between the source node and the target node. The data type of
the target node is compatible with the data type of the target node.

Green

Warning: Be careful when creating links between a Java Strings and a typed XML parameters. Whet
the XQuery code, which is generated when you create a map between these two types, is run in the
XQuery engine the result is an empty typed XML target document. The XQuery engine does not
parse the String into a typed XML document.

QUESTION FOR REVIEWERS: Are there other warnings | should list here? Should | have a table?

After the target node has been dropped on the source node, a line representing a link will be displayed.
Depending on the target and source nodes, a dashed line or a solid line will be displayed. To learn more, se
Link Representations.

5. Repeat the preceding step until all the desired nodes are mapped.

Note: To learn more about the menu options available for links including information on how to delete links,
see Link Menu Options.

Note: Instead of mapping nodes, you can create a constant for a node in Target pane. During run-time, the
node will return the value of the constant. This functionality may be useful during the development of your
application. For example, you might have the transformation return constants, so you can test the actions th
occur after the transformation, before mapping source to target nodes. To create a constant, right—click a nc
in the Target pane and from the drop—down menu, select Create Constant. In the Constant Value field,
enter the value of the constant, and click OK.
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General Steps to Open or Create a Query in the
Mapper

The following procedure provides the steps for creating or opening a Business Process Application,
Transformation file, and XQ file.

1. Create or open an existing business process project and application that contains the query stored a
method in the Transformation file.

For instructions on creating a new business process project and application, see Creating a Busines
Process Application.

To open an existing application:

a.From the WebLogic Workshop menu bar, choose File > Open > Application.
b. In the Open Workshop Application dialog box, browse for the desired application and click
Open.
2. Import your schemas into your application. For instructions, see Importing Schemas.
3. Create or open the Transformation file.

For instructions on creating a new Transformation file, see Creating a Transformation File and a
Transformation Method.

To open an existing Transformation file:

a.In the Application tab, browse and select a Transformation file. (If the Application tab is
not visible in WebLogic Workshop, choose View > Application from the menu bar.)
b. Double—click the Transformation file (ends in the .dtf extension).
4. Select input source schema(s) and the output target schema. For instructions, see To Select the
Source and Target Types and To Change the Selected Source or Target Parameters
5. Create or select a Transformation method from a Transformation file.

For instructions on creating a method in a Transformation file, see To Add a Transformation Method
to Transformation File.

To select an existing method, in the Design View of the Transformation file:
a.Right—click the arrow representing the method.

b. From the drop—down menu, select Goto XQuery Document.
The mapper pane is displayed.
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Viewing and Editing the Generated Code of Maps

A query (in the XQuery language) is generated when you create mapping links from Source elements and
attributes to Target elements and attributes.

1. Open a query in the mapper pane. For instructions see General Steps to Open or Create a Query in
the Mapper.
2. Select the Source View tab.

The generated query is displayed.

For a description of a generated query, see Understanding the Transformation of the Tutorial:
Building Your First Data Transformation.

3. Edit the generated query (the XQuery code). (Optional)
The query is written in the XQuery language. To learn about the XQuery language supported with
WebLogic Integration, see the XQuery 1.0: An XML Query Language Specification — W3C Working
Draft 16 August 2002 available from the W3C web site at the following URL.:
http://iwww.w3.0rg/TR/2002/WD-xquery—20020816/

The WebLogic XQuery engine which is invoked by the Transformation method conforms to the
August 16, 2002 draft of the XQuery Specification.

Note: You can also edit the XQuery code for a link from the General Expression pane of the Target
Expression tab. To learn more see Modifying Links Using the Target Expression Tab.
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Testing Maps in the Test View

The following functionality is available from the Test View of the mapper:

« Test Clicking Test runs the query (transformation) to converting the data displayed in the Source
Data pane against the mappings in the query displaying the result in the Result Data pane.

Note: Java interfaces and abstract Java classes are supported as source or target types for a transformatiot
a transformation with Java interfaces and/or Java classes as source or target types cannot be executed in T
View. However, a transformation with a Java interfaces and/or abstract Java classes as source or target typ
can be invoked from a business process (JPD) without error.

 Select Another Source (Input) Type Using the Pull-Down Menu in the Source Data Pane The
variables listed in drop—down menu of the Source Data pane are the source (input) types selected fc
the transformation in the Configure XQuery Transformation Method pane. To edit another source
type in the Source Data pane, you can change the displayed source type by selecting another sourci
type from the pull-down menu as shown here.

Source Data
$priceQuoteDoc B ’ Generate Data l \ Import... ] { Yalidate l
IpriceQuoteDoc
$availQuoteDoc Node Value
ibtaxRate E]
() customerName customerMame_1
=@ shipaddress
@7 street street_1
@7 city city_1
@7 state state_1
Q)? zip zip_1
ﬂ %ML Design View [ %ML Source View |

Import... Clicking Import... displays the Open File To Test pane. From the Open File To Test

pane, you can browse for source XML and non—-XML data files to load into the Source Data pane to
use as input to the query. After importing, you can click Test to run the transformation using the
imported source data or Validate to validate the displayed source data against the associated schern

Note: When you import source data the source data is validated against the associated schema and
any warnings and errors are displayed in the Output pane. You can import XML data for Global
Types and Local Elements but since Global Types and Local elements are not validated, no errors o
warnings will be reported for invalid data. To learn more, including which types can be validated, see
Validating During Design Time.

NOTE FOR REVIEWERS: This section was added for the following bug:
http://radar/netui/showecr.jsp?bugid=173139 Is it correct?

» Generate Data Clicking Generate Data regenerates the source data used as input to the
transformation. When you initially bring up the Test View, WebLogic Workshop generates an initial
set of source data and displays it in the Source Data pane. If you make changes to the data and ther
decide that you want to regenerate the data, click Generate Data. For example, you might want to
regenerate the XML test data, if you edited the original XML data resulting in XML data not valid to
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the associated schema and now want to regenerate the input XML data, again.
« Validate Clicking Validate, validates the displayed source data against the associated schema and
any errors are reported during design time.

Note: Not all types can be validated in the Test View. To learn more, including which types can be
validated, see Validating During Design Time.

« Editing the Data in the Source Data Pane When you initially bring up the Test View, WebLogic
Workshop generates an initial set of source data and displays it in the Source Data pane. You can
also optionally import data from source XML and nhon—-XML data files by clicking Import.... You
can edit and alter the data in the Source Data pane of the Test View using any of the following
methods:

¢ You can change the generated source data by selecting the desired the Node Value field of
the Source Data pane and entering your data.

¢ You can change the generated source data by right—clicking on a node in the Node Name
field of the Source Data pane and from the drop—down menu, selecting Edit Value.

» Adding, Removing, and Moving Data in the XML Design View by Right—Clicking on a
Node You can alter the data in the XML Design View tab of the Source Data pane of the Test
View, by right—clicking on a node (element) in the Node Name field of the Source Data pane. Only
valid menu items for the selected element as defined by the XML Schema will be displayed.

In the Node Name field of the Source Data pane, right—click on a node (element) and from the
drop—down menu selecting (if active) one of the following menu options:

¢ Duplicate node Right—clicking on an instance of a complexType node and selecting the
Duplicate node option generates another instance of the selected node. The Duplicate menu
option will only be available if the minOccurs setting in the XML Schema element definition
for the selected element is greater than 1.

QUESTION FOR REVIEWERS: Did | get the preceding section correct? Is it complexType or repeating
element?

¢ Insert Child node Right—clicking on a node and selecting the Insert Child node > child
option, insert a child node under the selected node. This option will only be active if child
nodes are allowed by the XML Schema for the selected node.

NOTE FOR REVIEWERS: The following note is for http://radar/netui/showcr.jsp?bugid=176201.

Note: In the Test View, the option for inserting a child node to the test data for a recursive schema is
disabled in the XML Design View tab of the Source Data pane. If you wish to add child nodes to the test
data for a recursive schema, switch to the XML Source View and add the child node to the test data directly
as XML.

¢ Remove node Right-clicking on a node and selecting the Remove node option, deletes the
node. The Remove menu option will only be available if the XML Schema element definition
for the selected element is optional (minOccurs=0).

¢+ Move Up Right-clicking on an instance of a complexType node and selecting the Move Up
option, moves the current instance of the node up a level in the list.

¢ Move Down Right—clicking on an instance of a complexType node and selecting the Move
Down option, moves the current instance of the node up a level in the list.

Testing Maps in the Test View 23



Guide to Data Transformation

QUESTION FOR REVIEWERS: Did | get the preceding section correct?

Note: You can also alter the data by directly editing the XML data in the XML Source View tab of the
Source Data pane.

« Viewing and Editing XML Data The following two views are available for displaying XML data
from the Source Data and Result Data panes:
¢ XML Design View Clicking the XML Design View tab allows you to view and edit a
graphical representation of the XML data.
¢ XML Source View Clicking the XML Source View tab allows you to view and edit the
data as an XML document.
« Viewing and Editing Non—-XML Data The following two views are available for displaying
non-XML data from the Source Data and Result Data panes:
¢ Hex Clicking the Hex tab allows you to the edit the data using both hexadecimal numbers
and as text (Unicode characters). The data is displayed on the left side of the pane as
hexadecimal numbers and on the right side as text.
¢ Text Clicking the Text tab allows you to the edit the data as text (Unicode characters). The
Text tab displays the printable characters (usually in the form of words and numbers) and
certain control characters (carriage return, tab, and so on). For example, carriage returns are
shown as line breaks. Non—printable characters, are displayed as small squares.

QUESTION FOR REVIEWERS: Is it Unicode? Was | correct in the preceding paragraphs?
To View and Test an XQ file in the Test View of the Mapper
1. Open a query in the mapper pane. For instructions see General Steps to Open or Create a Query in
the Mapper.
2. Select the Test View tab.
A graphical display of the generated source data is displayed in the Source Data pane.
3. If desired, change the generated source data.
For details see the preceding sections.
4.If desired, validate the source data against the associated schema. In the Source Data pane of the
Test View, click Validate. To learn more, see Validating During Design Time.

5. In the Result Data pane, click Test.

If not currently running, the WebLogic Server for the current application will be started. In order for
a query to run, the WebLogic Server for the current application must be running.

In the Result Data pane, after the query is run a graphical representation of the target data is
displayed.

6. To view the resulting data as an XML document, in the Result Data pane select the XML Source
View tab.

7.1f desired, you can validate the result data against the associated schema. In the Result Data pane c
the Test View, click Validate. To learn more, see Validating During Design Time.

Testing Maps in the Test View 24



Testing Maps in the Test View

Guide to Data Transformation

25



Link Representations

A data link directly transforms data from a source node to a target node. For example the following figure
shows a data link between the priceQuote/customerName element and the quote/name element.

Input XML Data (Source Schema) Output XML Data (Target Schema)
<?xml varsion="1.0' 7> <7xml version="1.0"7>
- - ) ) N Transform <quote xmins="http://lexample.org/quote">
<priceQuote xmins="http:/fexample.org/price"> -ation <nama>Acme Inc.</name>
<customerName>Acme Inc.</customerName> —+— v -
</quote>

</priceQuote>

Both priceQuote/customerName and quote/name are XML String elements. During run—time, the data from
the priceQuote/customerName element is converted to the quote/name element as shown in the preceding
figure.

The data link between these two elements is represented by a blue line in the mapper functionality of
WebLogic Workshop as shown in the following figure:

| Source H || Target |
=-fe ? priceQuoteDoc == ? quote
() customerhame [~] ) 5 name [~]

If you modify the XQuery code linking these two elements, the link between these elements changes from a
data link (represented as a blue line) to an implied link (represented as a light gray line) as show in the
following figure.

| Source ” || Target |
== ? priceQuoteDoc E] == ? quote E]
) customerhame [*] () g name [*]

Note: To learn more about the menu options available for links including information on how to delete links,
see Link Menu Options.

For an example of modifying the XQuery code between elements, see the task: To Edit and Retest the Simj
Query in the Step 3: Mapping Elements and Attributes in the Tutorial: Building Your First Data
Transformation.

The following table summaries the different link representations.

Is the Link
. Currently
, Is the Link a Mapper - . . .
Link Type Generated Link? Description Seliﬁ;ed in| Representation of Link
Mapper?
A link that converts the |Not
. Link is generated by value of the source nodgSelected
Data Link . . .
dragging—and-dropping. |directly to the value of the
eSS
target node. Selected
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Structural
Link

Link is generated by
dragging—and-dropping.

A link between two
parent structures that dg

Not
8glected

not map data directly.

Selected

| I E R RN NN _

Data
Structural
Link

Link is generated by
dragging—and—dropping.

A data structural link is
the combination of the

Not
Selected

5]
1]

following two links:

* A data link
between two
nodes a link that
converts the valu
of the source
node directly to
the value of the
target node.

A structural
link a link
between two
structures.

Example: The link
between the child nodeg
of a repeating element.

e

Selected

e p— —

Constraint
Link

Link is generated by
dragging—and-dropping.

Link Representations

A link that constrains or
limits the resulting data
a join between source
parent structures. The

Niot

Selected

constraint link is create
with one or more source|
elements.

Example: You could add
a constraint link to a join
of two source repeating
elements to only return
the data when the value
of a particular source
element are equal to ea
other. To learn more, se
Creating a Conditional
Constraint Using the
Constraints Tab.

QUESTION FOR
REVIEWERS: Is my
definition OK?

Is the name OK? In the
spec this was called a
Source—to—Source Join

Selected

192}

th
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link.

Copy Link

Link is generated by
dragging—and—dropping

A link between two
identical schema
substructures. During ru
time, the source data is
directly copied as a bloc
to the target data.

A copy link is also
generated when mappin
between a untyped XML
node and a typed XML
complex-type node.

QUESTION FOR
REVIEWERS: Is my
definition OK?

Not
r$e|ected

K

0
Selected

=== moom == roow oo o =D

Implied
Link

Link between the nodes i
created by writing new
XQuery or modifying
existing XQuery code.

A link whose XQuery
code can not be

Not
Selected

interpreted by the mapp

Examples:

» A data link that
was modified
using the
General
Expression
section of the
Target
Expression tab o
the Source View
of the mapper.
(For example,
adding the
xf:upper—case
function to a link
To learn more sd
Invoking
Functions or
Operators in a
Query.)

The data links
generated
between a secon
set of child node
when a union
constraint has

Link Representations

to be another type of link.

Belected

e

been applied a s
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the sam

REVIEWERS: |
this up. Is the d
and example O

of two structural
links. The child
nodes must be of

subschema. To
learn more see
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Link Menu Options

This section describes the menu options available with links in the Design View of the mapper, as shown in

the following table.

Menu Option Invoke by . .. Result . . .
In the Design View of the mapper,
right—click on an empty section betwegn
the Source and Target panes and from
the drop—down menu select Delete Al|in the Design View, the graphical representatigns
Delete All Links. of all the links are deleted and in the Source View
Links the generated XQuery code linking the source
Note: Right—clicking on an empty nodes to the target nodes is deleted.
section between the Source and Target
panes causes all the nodes to be
unselected.
I_n the D_e5|gn View of the Mappet, Data links or data structural links will be created
right—click on a structural link and fron )
etween the child nodes of the selected structyral
the drop—down menu select Induce |. . . .
link if source and target child elements of the link
Map.
are the same subschema type. The target and
Induce Map -
. L source child elements must have the same naine,
Note: This menu option is only ;
) S must be the data types, and must be in the same
available when a structural link is . :
. . . order for the Induce Map option to create child
selected in the Design View of the links
mapper. '
In the Design View of the mapper, The view _changes from the Design View to the)
: : : . Source View and generated XQuery code between
View Code right—click on a link and from the . o
: the links is displayed. The XQuery code for the
drop—down menu select View Code. S e .
selected link is highlighted in yellow.
Disable In the Design View of the mapper, Blocking XQuery code is added around the

Link Representations
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right—click on a link and from the
drop—down menu select Disable Targs
Node.

XQuery code of the selected link that prevents
XQuery code for the link from being executed
during run time (either from the Test View or
invoked from a JPD.)

Enable Target
Node

In the Design View of the mapper,
right—click on a disabled link and from
the drop—down menu select Enable
Target Node.

The blocking XQuery code is removed around
selected link. During run time, the XQuery codj
for the link is executed.

the

the

1”4

Delete Link

In the Design View of the mapper,
right—click on a selected link and from

In the Design View, the graphical representatid
of the selected link is deleted and in the Sourcs
Miew the generated XQuery code linking the

ns

\1%

the drop—down menu select Delete Lij

source node to the target node is deleted.
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Modifying Links Using the Target Expression Tab

You can view and modify the link between a source and target element using the Target Expression tab.
You can use the Target Expression tab to build a more complex expression between a source and target
element as shown in the following sections:

« Editing Links Using the Target Expression Tab

» Adding If-Then-Else Constructs to a Link
« Invoking Functions or Operators in a Query

Editing Links Using the Target Expression Tab
This section describes how to edit the XQuery code of a link using the Target Expression tab.
To Edit the XQuery Code of a Link
1. Open a query in the mapper pane. For instructions see General Steps to Open or Create a Query in
the Mapper.
2.In the Design View, select or create a link between a source and target node.

Keep the link selected for the next step.

3. Select the Target Expression tab. (If the Target Expression tab is not visible in WebLogic
Workshop, choose View > Windows > Target Expression from the menu bar.)

By default the General option is selected and the XQuery code for the link is displayed in the
General Expression pane.

4. Select the Target Expression tab. (If the Target Expression tab is not visible in WebLogic
Workshop, choose View > Windows > Target Expression from the menu bar.)
5. Edit the generated query (the XQuery code). (Optional)

The query is written in the XQuery language. To learn about the XQuery language supported with
WebLogic Integration, see the XQuery 1.0: An XML Query Language Specification — W3C Working
Draft 16 August 2002 available from the W3C web site at the following URL.:
http://www.w3.0rg/TR/2002/WD-xquery—20020816/

The WebLogic XQuery engine which is invoked by the Transformation method conforms to the
August 16, 2002 draft of the XQuery Specification.

Adding If-Then-Else Constructs to a Link

QUESTION FOR REVIEWERS: Should | use if-then—else construct like Liquid Data or if-then—else
expression or just if-then—else as a noun. | don't want to use if-then—else expression because the mapper |
if expression so it could be confusing.

This section describes how to add if-then—else constructs to a link using the Target Expression tab. When &
guery is invoked with an if-then—else, the conditions that make up the if expression are evaluated and
depending on the result, different values are returned for a target node. For example, if the value of quantity
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source node is greater than 500 then 4554 is returned as the value of the id target node but if the value of
guantity source node is less than 500, then 5894 is returned as the value of the id target node as shown in t
example in the following figure.

Figure : If-Then-Else

Input XML Data Query Output XML [
(example data: (XQuery Code) <7xml version="1.0" encoding
<Supplier>
PurchaseOrder.xml) ot s
<7xmi version="1.0" encoding="UTF-8"?> <id>{ </Supplier>
xml version= encoding= - . ) i
<PurchaseOrder> g dgs(gata(Sl‘-‘urt:haseOrderDoc'quanuty) > 500) then
<partld>345</partld> —
<quantity>678</quantity> — EIS_::B ——
<maxVolumeForSupplier>1000</ <"Supplier>a bl

maxVolumeForSupplier>
<countryCode>UK</countryCode>
</PurchaseOrder>

QUESTION FOR REVIEWERS: | know that it's sort of unorthodox to show the XQuery code when we want
them to use the mapper functionality and not look at the code but it just seemed like the user needs why the
would use the if-then—else and showing the XQuery code with the if-then—else is in the middle of the target
node seemed to be the easiest way to do this. Is this OK or can you think of another way to represent it?

In addition to the following procedure for adding a simple if-then—else expression to a link, a more complex
example is available. To learn more see Adding Nested If-Then-Else Expressions with Complex Conditions
to a Link.

To Add an If-Then-Else Expression to a Link

1. Open a query in the mapper pane. For instructions see General Steps to Open or Create a Query in
the Mapper.

For this example, import the files: PurchaseOrder.xsd and Supplier.xsd files (step 2 in General Steps
to Open or Create a Query in the Mapper.) If you installed WebLogic Platform in the c:\bea directory,
import these files from the
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\ifThenElse directory.

For this example, select and add the PurchaseOrder.xsd/PurchaseOrder node as an source type (st
in General Steps to Open or Create a Query in the Mapper.)

For this example, select and add the Supplier.xsd/Supplier node as an target type (step 4 in General
Steps to Open or Create a Query in the Mapper.)

QUESTION FOR REVIEWERS: In the past, | put longer set of instructions here for opening an application,
importing schemas, creating a DTF, and XQ file etc. | have changed this for SP3, because | envision people
using the context sensitive help to get to this section, so they already have a XQ file open. Now, | point the
general section "General Steps to Open or Create a Query in the Mapper". Do you think that's a good thing
do?

2.In the Design View, select or create a link between a target and source element to add the
if-then—else.
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For this example, select the PurchaseOrderDoc/quantity source element and drag it to the Supplier/i
target node.

Keep the link selected for the next step.

3. Select the Target Expression tab. (If the Target Expression tab is not visible in WebLogic
Workshop, choose View > Windows > Target Expression from the menu bar.)
4. Select the If Then Else option.

The XQuery if-then—else construct is added to the link. For example, the following XQuery source
code segment for the link is replaced:

data($PurchaseOrderDoc/quantity)
By the following XQuery source code segment for the link:

if (xf:boolean("true™)) then
data($PurchaseOrderDoc/quantity)
else

0

5. Click If Condition.
The If Condition pane appears.
6. In this step, you add condition(s) to the if section of the if-then—else.

During run time, when the condition(s) in the if are evaluated and if the if evaluates to true, the then
part of the if-then—else is invoked but if the if evaluates to false, the else part of the if-then—else is
invoked.

The if section of an if-then—else can be a simple condition that compares a source element and a
simple value. The if section of an if-then—else can also be complex involving multiple conditions.

To create a condition, first populate the left and right side expressions:

¢ Drag and drop elements from Source pane or the Data Palette into the Left Hand
Expression or Right Hand Expression section of the If Condition pane.
¢ Enter values directly into the Right Hand Expression section of the If Condition pane.
¢ Drag and drop functions or operators from the Palette into the Left Hand Expression or
Right Hand Expression section of the If Condition pane.
After the Left Hand Expression or Right Hand Expression sections for a simple expression are
specified, select an operator from the Operator drop—down list and click Add.

For this example, complete the following steps to create a simple condition:
a.From the Source pane, drag the PurchaseOrderDoc/quantity element into the Left Hand
Expression section of the If Condition pane.
b. Select the operator: >.
c. In the Right Hand Expression section of the If Condition pane, enter: 500 and click Add.

The condition is added to the if section of the if-then—else.
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To create an if section with multiple conditions:

a.Create a simple condition as described previously.
b. Add additional conditions:

Populate the Left Hand Expression and the Right Hand Expression. Select the appropriate
operator.

Select the appropriate Join Type.
Click Add.

For an example, see Adding Nested If-Then—-Else Expressions with Complex Conditions to
a Link.

7. Click Then Expression.

8. In the Then Expression section, enter a value or an expression. If you specify an expression, during
run time if the If Condition evaluates to true, the expression in the Then Expression section will be
evaluated and the resulting value will become the value of the target node. You can build an
expression by dragging functions or operators from the Palette and elements from the Source pane ¢
Data Palette into the Edit Then Expression section as shown in Adding Nested If-Then—Else
Expressions with Complex Conditions to a Link.)

For this example, replace the following text:

data($PurchaseOrderDoc/quantity)
With the supplier id value of 4554.

Note: In addition, nested if-then—else constructs can be added to the else expression. To learn more
see Adding Nested If-Then-Else Expressions with Complex Conditions to a Link.

9. Click Apply.

10.Click Else Expression.

11.In the Else Expression section, enter a value or an expression. If you specify an expression, during
run—time if the If Condition evaluates to false, the expression in the Else Expression section will be
evaluated and the resulting value will become the value of the target node. You can build an
expression by dragging functions or operators from the Palette and elements from the Source pane
Data Palette into the Edit Then Expression section as shown in Adding Nested If-Then-Else
Expressions with Complex Conditions to a Link.)

For this example, enter 5894 and click Apply.

Note: In addition, nested if-then—else constructs can be added to the else expression. To learn more
see Adding Nested If-Then-Else Expressions with Complex Conditions to a Link.

12.Select the General option, to view the generated if-then—else XQuery source code.

13.To run the query, select the Test View of the XQ file.

14.In the Source Data pane of the Test View, enter or import the desired source XML. To learn more
see Testing Maps in the Test View.
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For this example, in the Source Data pane of the Test View, select the quantity Node Value field
and enter 678.

15.1n the Result Data pane, click Test.

If not currently running, the WebLogic Server for the current application will be started. In order for
a query to run, the WebLogic Server for the current application must be running.

In the Result Data pane, after the query is run a graphical representation of the target data is
displayed.

For this example, in the Result Data pane, the resulting value of Supplier/id element is 4554 because
the source quantity was over 500 as shown in the preceding figure.

16. Save the DTF and the XQ file. From the menu bar, choose File > Save All.

Invoking Functions or Operators in a Query

This section describes how to insert calls to functions or operators into a query using the Target Expression
tab.

This section contains the following topics:

« Invoking XQuery Functions or Operators in a Query
« Invoking User Defined Methods in a Query
« Invoking Control Methods in a Query

Invoking XQuery Functions or Operators in a Query

A set of standard W3C XQuery functions and operators are provided in the mapper functionality of
WebLogic Integration. When you use the mapper functionality to design a transformation, a query (written ir
the XQuery language) is generated that does actual data conversion. In the generated query, you can add
function calls to this set of standard XQuery functions. For example, as part of your transformation you migh
want to convert the XML String to uppercase characters.

The procedure below describes how to add a function call to a simple link between a XML String source
node and an XML String target node. Adding a function to a more complicated query is described in the Ste
3: Mapping Elements and Attributes in the Tutorial: Building Your First Data Transformation.

For listings and detailed descriptions of the XQuery functions and operators available in the mapper
functionality of WebLogic Workshop, see XQuery Reference.

In addition to the XQuery functions available in the mapper functionality, a larger set functions is provided.
You can manually add invocations to these functions to queries in the Source View of the mapper
functionality. For a list of these additional functions, see the XQuery 1.0 and XPath 2.0 Functions and
Operators — W3C Working Draft 16 August 2002 available from the W3C web site at the following URL.:.
http://lwww.w3.0rg/TR/2002/WD-xquery—operators—20020816/

To Add a XQuery Function or Operator Call to a Query
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1. Open a query in the mapper pane. For instructions see General Steps to Open or Create a Query in
the Mapper.
2.In the Design View of the XQ file, select or create the link to add the function or operator call.

The link between these two nodes becomes green.

Adding a function or an operator to a link means that during run time, as part of the transformation of
the data between the source node and the target node, the function will be invoked.

3. In the bottom pane of the Design View, choose the Target Expression tab. (If the Target
Expression tab is not visible in WebLogic Workshop, choose View > Windows > Target
Expression from the menu bar.)

In the General Expression pane, the XQuery code linking the selected target and source node is
displayed.

4. View function and operator folders of the Palette. (If the Palette is not visible in WebLogic
Workshop, from the menu bar choose View > Windows > Palette.)
5. In the Palette, collapse and expand the folders to find the desired function or operator.

For this example, from the String Functions folder select the upper—case function.

6. In the XQuery Functions pane, select the desired function, and drag it into the General Expression
pane.

For this example, the following text is displayed in the General Expression pane, as shown in the
following figure.

Constraints | Target Expression X
Expression Type: (® General (O If Then Else
-| General Expression (4]
data(xf:upper-case| 1 D
[=]

For the following step, leave the parameter selected (in this example: $string—var) in the General
Expression pane as shown in the preceding figure.

7.Select a source parameter using one of the following options:
¢ From the Source pane of the Design View select a source node and drag—and-drop it over
the parameter in the General Expression pane.
¢ From the Data Palette pane select a source variable and drag—and-drop it over the
parameter in the General Expression pane. (If the Data Palette is not visible in WebLogic
Workshop, from the menu bar choose View > Windows > Palette.)
For this example, the following text is displayed in the General Expression pane, as shown in the
following figure.
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Constraints | Target Expression 5%

Expression Type: (® General (O If Then Else

- | General Expression Apply

data(xf:upper-case(§quoteDoc/nane)) D

i

8. Repeat step 8 until all the parameters in the function or operator are assigned.
9. Click Apply.

During run time for this example, the upper—case function will convert all the characters of the
$quoteDoc/name element to upper case.

10. Save the DTF and the XQ file. From the menu bar, choose File > Save All.
Invoking User Defined Methods in a Query
This section describes the following tasks:

* To Add a User Method to a Transformation File
» To Add a User Defined Method Call to a Query

To Add a User Method to a Transformation File

A User method is a user—defined Java method that can be called from a query (written in the XQuery
language). You can add User Methods to a Transformation file and then add invocations to these User
methods in queries. Adding a User method to a Transformation file is described in Create a User Defined
Java Method to Invoke From the Join Query in Step 4: Mapping Repeating Elements Creating a Join in the
Tutorial: Building Your First Data Transformation.

To Add a User Defined Method Call to a Query

Before you can add a user defined method call to a query, the method must already have been created in tf
Transformation file. For instructions, see To Add a User Method to a Transformation File.

Calling a User method from a query is described in Call the calculateTotalPrice User Method From the
Query task in Step 4: Mapping Repeating Elements Creating a Join in the Tutorial: Building Your First Data
Transformation.

You may want to add an exception path to the node in the business process which calls the Transformation
file. To learn more, see Getting the TransformException Fault Code Programmatically.

Warning: The User method you call from the query should contain only stateless functionality.
Note: You cannot call a User method which returns a void from a query.
Invoking Control Methods in a Query

To Add a Control Function Call to a Query

Modifying Links Using the Target Expression Tab 37



Guide to Data Transformation

1. Create or open an existing business process project and application that contains the query stored a
method in the Transformation file.

For instructions on creating a new business process project and application, see Creating a Busines
Process Application.

To open an existing application:

a.From the WebLogic Workshop menu bar, choose File > Open > Application.
b. In the Open Workshop Application dialog box, browse for the desired application and click
Open.
2. Import your schemas into your application. For instructions, see Importing Schemas.
3. Create or open the Transformation file.

For instructions on creating a new Transformation file, see Creating a Transformation File and a
Transformation Method.

To open an existing Transformation file:

a.In the Application tab, browse and select a Transformation file. (If the Application tab is
not visible in WebLogic Workshop, choose View > Application from the menu bar.)

b. Double—click the Transformation file (ends in the .dtf extension).

4. Add an instance of a control to the Transformation file:

a.In the Controls section of the Data Palette, select Add > Control_Name, where
Control_Name represents the hame of the control to add.

b. Follow the steps in the Insert Control dialog box and click Create.

To learn more, see Working with Java Controls.

An instance of the control is created and a representation of the controls appears in the graphical
representation of the Transformation file.

5. Select input source schema(s) and the output target schema. For instructions, see To Select the
Source and Target Types and To Change the Selected Source or Target Parameters
6. Create or select a Transformation method from a Transformation file.

For instructions on creating a method in a Transformation file, see To Add a Transformation Method
to Transformation File.

To select an existing method, in the Design View of the Transformation file:
a.Right—click the arrow representing the method.
b. From the drop—down menu, select Goto XQuery Document.

The mapper pane is displayed.

7. Open the XQ file that contains the transformation in the Design View.
8. In the Design View, select the link to add the function call.

The link between these two nodes becomes green.

Adding a function to a link means that during run time, as part of the transformation of the data
between the source node and the target node, the function will be invoked.
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9. In the bottom pane of the Design View, choose the Target Expression tab. (If the Target
Expression tab is not visible in WebLogic Workshop, choose View > Windows > Target
Expression from the menu bar.)

In the General Expression pane, the XQuery code linking the selected target and source node is
displayed.

10.In the Palette, expand the Controls Functions folder. (If the Palette is not visible in WebLogic
Workshop, from the menu bar choose View > Windows > Palette.)

11.In the Palette, collapse and expand the folders to find the desired function.

12.1In the Palette, select the desired function, and drag it into the General Expression pane.

Warning: When you select a Control in Palette all the functions in a Control are listed. You should
however, only use the Control functions in queries with look—up, read-only stateless functionality.
For example, a query could call a read-only function, which accepts as a parameter a record id and
returns the string associated with the record id. This read-only function does not change or add any
values in the database. It just reads a values from the database. Control functions that are stateful
should not be called from queries. For example, a Database control function that adds a record to th
database should not be called from a query. Functions that are stateful or modify the database shoul
be called from the business process directly.

QUESTION FOR REVIEWERS: Is this still true? Are all the functions still listed or only the stateless ones?

13.Select a source parameter using one of the following options:
¢ From the Source pane of the Design View select a source node and drag—and-drop it over
the parameter in the General Expression pane.
¢ From the Data Palette pane select a source variable and drag—and-drop it over the
parameter in the General Expression pane. (If the Data Palette is not visible in WebLogic
Workshop, from the menu bar choose View > Windows > Palette.)
14.Click Apply.

During run time, the query will invoke the selected function from the control.

15. Save the DTF and the XQ file. From the menu bar, choose File > Save All.
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Using the Constraints Tab

The Constraints tab of the mapper allows you to constrain or manipulate the relationship between source ar
target repeating elements.

The following Constraint Type options are available from the Constraints tab:

» Repeatability/Join To learn more, see Merging the Contents of Repeating Elements and Creating a
Conditional Constraint Using the Constraints Tab.

» Union To learn more, see Using the Union Option of the Constraints Tab.

» Group By Key Fields To learn more, see Using the Group by Key Fields Option of the Constraints
Tab.

When you create structural links between repeating elements in the Design View, XQuery for loops are
generated to iterate through the repeating elements. You can use the Where Clause Expression pane of the
Constraints tab to limit or constrain the target repeating elements by adding where clauses to the XQuery fo
loops. In the Where Clause Expression pane of the Constraints tab, you can build complex conditions for
the where clause of the XQuery for loop. A complex condition is made up of conditions that are OR or AND
together, for example:

((data($PurchaseOrderDoc/partld) > 200 and data($PurchaseOrderDoc/partld) <= 400))

The complex condition that makes up the where clause are evaluated for each iteration of the for loop. For &
example see Adding a Constraint With Multiple Conditions.
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Using Java Classes in Transformations

This section describes how to use Java classes as source or target types in transformations.
To Use a Java Class in Transformations
1. Create or open a business process project and application.

For instructions on creating a new business process project and application, see Creating a Busines
Process Application.

To open an existing application that contains the query:

a.From the WebLogic Workshop menu bar, choose File > Open > Application.
b. In the Open Workshop Application dialog box, browse for the desired application and click
Open.
2. The Java class for conversion must be available in the current project. To learn more about including
a Java class in your project, see Using Existing Applications.

Note: Java interfaces and abstract Java classes are supported as source or target types for transformations
cannot be executed in Test View. However, a transformation with a Java interfaces and/or abstract Java
classes as source or target types can be invoked from a business process (JPD) without error.

For the example shown in this procedure, create a Java file called Book.java in a subfolder named processe
in the project folder:

a.Right—click the project folder or a subfolder in the project folder.
b. From the drop—down menu, select New > Java Class.

The New File dialog box appears.

c. In the Field Name field, enter Book.java.

d. Click Create.

e.Paste the following code segment in between the starting and ending curly brackets of the Book
class:

public String title; /I Will convert to xsd type
public Author[] authors; // Will convert to xsd type
private int copiesPrinted; // Private member with no get/set methods; will not convert to xsd type
private int copiesSold; // Private member with get/set methods will convert to xsd
public int getCopiesSold(){
return copiesSold;

public void setCopiesSold(int in){
copiesSold = in;
}
public HashMap stores; /I Will not convert to xsd type, HashMap not supported

Errors will be reported in the Source View. You will fix those errors in the preceding steps.

To learn more about which fields are supported in Java classes, see Java Class Conversion.
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f. Add the following import definition in the third line of the Book.java file (after the line: package
processes;):

import java.util.HashMap;
g. Save the Book.java file.

In Application tab, expand the your application folder. (If the Application tab is not visible in
WebLogic Workshop, from the menu bar choose View > Application.)

Expand the myprojectWeb project folder, where myproject represents the name of your project
folder.

If required, expand the folder(s) that contain the Book.java file.

Right—click the Book.java file and in the drop—down menu select Save.

You also need to create a Java file called Author.java in the processes subfolder:

a.Right—click the project folder or a subfolder in the project folder.
b. From the drop—down menu, select New > Java Class.

The New File dialog box appears.

c. In the Field Name field, enter Author.java.

d. Click Create.

e.Paste the following code segment in between the starting and ending curly brackets of the Author
class:

public String lastname; /' Will convert to xsd type
public String firstname;  // Will convert to xsd type

f. Save the Author.java file.

In Application tab, expand the your application folder. (If the Application tab is not visible in
WebLogic Workshop, from the menu bar choose View > Application.)

Expand the myprojectWeb project folder, where myproject represents the name of your project
folder.

If required, expand the folder(s) that contain the Author.java file.
Right—click the Author.java file and in the drop—down menu select Save.

3. Import the necessary XSD and MFL files for the other source or target parameters of the
Transformation method into a Schemas project folder. To learn more, see Selecting Source and Tart
Types.

For the example in this procedure, import the Book.xsd file. For example, if you installed WebLogic

Platform in the c:\bea directory, import the Book.xsd file from the
C:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\javaClass directory.
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The XML Schema in the Book.xsd file is the target type for this example transformation.
Importing schemas files triggers a build of the current Schemas project folder. Wait until the
Schemas project folder is built before proceeding to the next step. (The representations of the schen
will not be available in Available Source Types and Available Target Type panes until build is
complete.)

4. Create a Transformation file and Transformation method.

For instructions on creating a new Transformation file, see Creating a Transformation File and a
Transformation Method.

5. Open the Transformation method which contains the query.

For instructions on creating a new method in a Transformation file, see To Add a Transformation
Method to Transformation File.

To open an existing method which contains the query:

a.Right-click the arrow representing the method that contains the query.
b. From the drop—down menu, select Configure Transformation Method.

The Configure XQuery Transformation Method dialog box is displayed.

6. Select the source and target parameters for the Transformation method. For detailed instructions, se
Selecting Source and Target Types.

For this example, in the Available Source Types pane, select the XML option, select
Typed/Book.xsd/Book element as the target parameter, and click Add.

For this example, in the Available Target Types pane, select the Java option, enter: processes.Book
in the Type field, and click Add.

Click Create Transformation.
A graphical representation of the Java class and XML Schema is displayed in the Design View.
Note: Not all the fields in the Book.java class are displayed. Only supported public members or
private members with JavaBean style get and set methods are displayed. In this example, the privat:
member: copiesSold is displayed because the associated JavaBeans set and get methods for this
member are provided. However, the class member stores is not displayed because it is of type:
java.util.HashMap which is not a supported type. To learn more about which fields of a Java class ar
supported in transformations, see Java Class Conversion.

7.1n the Source pane select a node and drag it into the Target pane.

A link represented by a line between the two nodes is displayed.

Repeat this step as necessary to create additional links.
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For this example, in the Source pane select the $BookDoc/Title node and drag it to the Book/title
node in the Target pane.

For this example, in the Source pane select the $BookDoc/Author node and drag it to the
Book/authors node in the Target pane. These nodes are both repeating nodes. A repeating node
means more than one instances of this node can be specified. In the Source pane, repeating nodes
represented with a + symbol to the right of the node. A dashed line linking the two repeating nodes i
displayed.

For this example, in the Source pane select the $BookDoc/Author/LastName node and drag it to the
Book/authors/Author/lasthame node in the Target pane. A solid line linking the two nodes is
displayed.

In the Source pane select the $BookDoc/Author/FirstName node and drag it to the
Book/authors/firstname node in the Target pane. A solid line linking the two nodes is displayed.

In the Source pane select the $BookDoc/CopiesSold node and drag it to the Book/copiesSold node
in the Target pane. A solid line linking the two nodes is displayed.

8. Save the DTF and the XQ file. From the menu bar, choose File > Save All.
9. Test the query:
a.Select the Test View tab.
b. In the Result Data pane, click Test.
c. The query is run with the default test data. A graphical representation of the resulting XML
data is shown in the Result Data pane.
d. To view resulting data as XML, in the Result Data pane, select the XML Source View tab.
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The Association Between XQ and DTF Files

Associated Transformation (DTF) and XQ files have references to each other in their source code. For
example, if you create a Transformation file named union which contains a Transformation method called
convert and you create maps between the source and target nodes of the Transformation method the follow
files are generated:

» A DTF file called union.dtf
* A XQ file called convert.xq

In the Application tab, the following is displayed:

3 test
G 5 union.dtf
|<7] convert.xq

These two files are associated with each other, the union.dtf refers to the convert.xq file and the convert.xq
refers to the union.dtf file. If you change the name of either of these files or the transformation method name
you must update the reference to it in the other file.

For the preceding example, the following transform annotation is displayed in the Source View of the
union.dtf file, as shown in the following figure.

Package name

e
ckage test;
impoy n xml,Xml e
import m.oea.xml.X¥mlObjectLlist
10li iestract | 11 1 lmplemrent I 1. transform. TransformSource
static final ong serialvVersionUID = 1L;
Name of associated XQ file
* @def:cransform xquery-ref="convert.xq"
* Adtf:schema-validate return=-value="false" parameters="false"
;;g;ic abstract org.book.BookDocument convert (org.book.BookDocument _BookDoc);

} W_J

Transformation method name

The following comment is displayed in the Source View of the convert.xq file, as shown in the following
figure:

Transform-
Name of ation
Package associated method
name DTE file name

{=- test/union.dtf#convert --}
This section contains the following topics:

* Rename the DTF File and References in Associated XQ Files
* Rename the XQ File and References In the Associated DTF File
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Rename the DTF File and References in Associated XQ Files

1. Save the DTF and the associated XQ file(s). From the menu bar, choose File > Save All.
2. In the Application tab, right—click the DTF file and from the drop—down menu, select Rename.

For this example, select the union.dtf file.
3. Enter the new name and enter the return key.
For this example, replace union with myunion.

In the Application tab, the DTF file is renamed to myunion.dtf and the associated XQ file
(convert.xq) no longer appears under the myunion.dtf file as shown in the following figure:

(Y test
[¢?] convert.xq

¢ myunion.dtf

4., For each of the XQ files associated with a DTF file:
a.In the Application tab, double—click a XQ file associated with the renamed DTF file.

For this example, in the Application tab double—click convert.xq.

b. Select the Source View tab of the XQ file.
For this example, select the Source View tab of the convert.xq file.

c. In the first line of the XQ file, change the listed DTF file to the new name.
The red underline in the first line of the XQ file disappears.

For this example, change the first line from the following code:
{—- test/union.dtf#convert —}
To this code:
{—- test/myunion.dtf#convert ——}
5. Save the DTF and the associated XQ file(s). From the menu bar, choose File > Save All.
Rename the XQ File and References In the Associated DTF File

1. Save the DTF and the associated XQ file(s). From the menu bar, choose File > Save All.
2.In the Application tab, right—click the XQ file and from the drop—down menu, select Rename.

For this example, select the convert.xq file.
3. Enter the new name and enter the return key.

For this example, replace convert with myconvert.
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4. In the Application tab, double—click the DTF file associated with the renamed XQ file.
For this example, in the Application tab double—click union.dtf.

5. Select the Source View tab of the DTF file.
For this example, select the Source View tab of the union.dtf file.

6. In the DTF file, change the listed XQ file in the transform annotation to the new name.
The red underline under the XQ name disappears.

For this example, change the annotation from the following code:

/**

* @dtf:transform xquery-ref="convert.xq"

* @dtf:schema-validate return-value="false" parameters="false"
*/

To the following annotation:

/**

* @dtf:transform xquery-ref="myconvert.xq"
* @dtf:schema-validate return-value="false" parameters="false"
*/

7. Save the DTF and the associated XQ file(s). From the menu bar, choose File > Save All.
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Using the Data Palette of the Mapper

The Data Palette of the mapper provides a location to access the variables and their subelements. You can
drag—and-drop variables or their subelements from the Data Palette of the mapper into the Constraints and
Target Expression tabs of the mapper.

Note: You can also drag—and—drop elements from the Source pane of the mapper directly into the
Constraints and Target Expression tabs of the mapper.

The following types of variables are displayed in the Data Palette of the mapper:

» Source The variables listed in Source section of the Data Palette are the source (input) types
selected for the transformation in the Configure XQuery Transformation Method pane. To learn
more, see Selecting Source and Target Types.

« Structural Link When a structural link is selected in the Design View of an XQ file, the Structural
Link section of the Data Palette lists the loop iteration variable associated with the XQuery for loop
generated by the structural link. This variable is in scope for all subelements of the node with the
structural link.

QUESTION FOR REVIEWERS: Frank this is what Sandip suggested. Do you like it?

When you create link(s) between a source repeating element and a target repeating element, a structural lir
between the two elements is created and a XQuery for loop is generated. When you use the Constraints tak
limit or constrain repeating element(s), a where clause is added to the XQuery for loop. To learn more abou
which features of the mapper functionality to use to manipulate and constrain data, see Examples:
Manipulating and Constraining Data Using XQuery.

Caution: The Data Palette of the mapper displays a different set of variables than the variables displayed in
the Data Palette for business processes (JPDs). The variables displayed in the Data Palette of the mapper «
used only in transformations and are distinct from the variables used in business processes.
To View the Variables Associated with Transformation in the Data Palette
1. For the Data Palette of the mapper to be visible, the Design View of an XQ file must be selected.
To view an XQ file in the Design View:
a.If the Application tab is not visible in WebLogic Workshop, from the menu bar choose
View > Application.
b. In the Application tab, double—click XQ file and select the Design View tab.
2. (Optional) Select a structural link to view the repeating element(s) associated with the current link
that can be constrained using Constraints tab.
3. If the Data Palette is not visible in WebLogic Workshop, from the menu bar choose View >
Windows > Application.
Related Topics
Modifying Links Using the Target Expression Tab

Examples: Manipulating and Constraining Data Using XQuery
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Adding If-Then-Else Constructs to a Link

Business Process Variables and Data Types

Using the Data Palette of the Mapper
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Validating

The schema validating done during run time is different than the validate done when you click Validate in
the Test View tab of the XQ file during design time. The Schema validating done on XML and non-XML
typed data during run time can actually modify the resulting data while the validating during design time doe
not modify the resulting data but it does report if any required elements or attributes defined in the schema &
not present.

This section provides the following topics:

« Validating During Design Time
» Schema Validating During Run Time

Validating During Design Time
During design time, Validate in the Source Data and Result Data panes in the Test View tab of an XQ file
will be active if the selected source parameter or resulting data is a typed global XML element. To learn mor

see XML Global Element, Global Type, and Local Element Components.

For example, if a typed global XML parameter is selected in the Source Data pane, Validate will be active
as shown in the following figure.

Source Data
#tBookDoc ‘ v ] l Generate Data ] l Import... ] [ Validate ]
Mode Name Mode Yalue
[2)7 Book
© Title Title_1
= @ author
() FirstMame FirstName_11
() LastMame LastMame_11
@ CopiesSold 70
| %ML Design Yiew [HML Source View |

Validate will not be active if the selected source parameter or resulting data is one of the following types:
* Typed Non—-XML
Note: Untyped Non-XML (RawData) data cannot be used in transformations.

« XmlObject (untyped XML object)

« XmlObjectList (untyped XML object list)

« Java Types (both Java primitive types and Java classes)

* XML global type To learn more see XML Global Element, Global Type, and Local Element
Components.

« XML local element To learn more see XML Global Element, Global Type, and Local Element
Components.

For these types, Validate will not be active as shown in the following figure.
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Source Data

#Xm|0bjectDoc |+ } { Generate Data ] ’ Import... ] { ‘

Mode Name Mode Yalue
? *mlObject %¥mlObject_1

|| ¥ML Design View XML Source View |

If you click Validate in either the Source Data and Result Data panes in the Test View tab of an XQ file,
the displayed XML is checked against it schema and any errors are reported during design time. The
validating done during design time in the Test View is not the same as the schema validating that occurs
during run time. The validating during design time does not modify the resulting XML document but it does
check if any required elements or attributes defined in the schema are not present.

QUESTION FOR REVIEWERS: Do | have the list of Validate active types correct?

Schema Validating During Run Time

In the Selected Source Types pane of the Configure XQuery Transformation Method pane, if the Schema
Validate Parameters check box is selected, during run time, the source parameters that support schema
validation will be schema validated against their associated schema before the transformation is executed.
XML parameters will be schema validated against their XML Schema while the typed non—-XML parameters
will be validated against the schema in the MFL file. The Schema Validate Parameters check box will be
ignored for the parameters that do not support schema validation.

Note: In the Selected Source Types pane of the Configure XQuery Transformation Method pane, the
Schema Validate Parameters check box is not active if any of selected source parameters cannot be schem
validated.

The following table shows which types will and will not be schema validated during run time.

Type Schema Validated” To Learn More See.. ..
XML Global Element Yes XML Global Element, Global Type,
and Local Element Components
Typed Non XML Yes
XML Global Element, Global Type,
XML Global Type No and Local Element Components
XML Local Element NoO XML Global Element, Global Type,
and Local Element Components
XmlObject (untyped XML object) No

XmlObjectList (untyped XML object list) [No

Java Types (both Java primitive types and
Java classes)

No

In the Selected Source Types pane of the Configure XQuery Transformation Method pane, if you select
the Schema Validate Parameters check box, the parameter attribute of the @dtf:schema-validate annotatio
will be set to true. To learn more see @dtf:schema-validate Annotation.
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In the Selected Source Types pane of the Configure XQuery Transformation pane, if you select the
Schema Validate Return check box and the target parameter is a type that can be schema validated, during
run time the target parameter is schema validated against its schema type after the transformation is execut
To learn more see @dtf:schema-validate Annotation.

The Schema validating done on typed XML or non—XML data during run time can actually modify the
resulting data. For XML data, if default attributes and elements are specified in the XML Schema and these
attributes and elements do not have values in the source document, the resulting XML will have these defal
specified. To learn more about XML schema validating, see Occurrence Constraints.

If schema validating fails during run time, the com.bea.transform.TransformException exception is thrown.
How the exception is handled depends on the node that invokes the transformation. If there is an exception
path associated with node at the node level, group level or globally for the business process, the exception
path is invoked. If there is no exception path associated with the node, the exception will force the business
process to fail. To learn about exception paths in business processes, see Handling Exceptions.
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Using the Property Editor of the Mapper

This section provides the following topics:

 Using the Property Editor When Editing an DTF File
« Using the Property Editor When Editing an XQ file

Using the Property Editor When Editing an DTF File

While editing an DTF file in the Design View or the Source View, you can use the Property Editor to view
or edit the properties of the selected method.

For example, if you select a XQuery transformation method in the Design View of a DTF file, you can
change the name of the method by editing the name property in the Property Editor. You can also edit the
annotations and attributes of the selected method in the Property Editor.

Note: Context Sensitive Help is available for the dtf annotations by selecting the annotation property or
attribute in the Property Editor and clicking F1.

To learn more see Data Transformation Annotations.

Using the Property Editor When Editing an XQ file

While editing an XQ file in the Design View, the Property Editor allows you to view schema properties
about the nodes in the current map without opening the source and target XSD or MFL files. The Property
Editor of the mapper displays a read—only view of the schema properties for the selected element(s). To
change XML Schema properties you must edit the XSD file that contains the XML Schema. To change the
schema properties for non—XML data, you must edit the corresponding MFL file.

Note: Selecting a link will select the target and source elements of the link. To deselect a link and the target
and source nodes of the link, click an empty section of the middle pane (a section with no links) between the
Source and Target panes of the mapper.

A selected target or source node is displayed with a gray or blue box around the node as shown in the
following figure.

Source H H Target ’
= [#)? _priceQuoteDoc = 27 quote
() customerhlame ) 5 name
=) shipAddress () 5 address
Q')? street = C)+ quoteResponse

In the preceding figure, both customerName and name are selected elements, so the schema properties for
both these elements will be displayed in the Property Editor.
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XML Global Element, Global Type, and Local Element
Components

QUESTION FOR REVIEWERS: Please read this carefully. It is a new section.

A XML component is considered global if it is a direct child of the schema element while an XML
component is considered local if it is not a direct child of the schema element (is nested to another element)
shown in the following XML Schema:

<?xml version="1.0"?>
<xs:schema xmlns:xs="http://www.w3.0rg/2001/XMLSchema" targetNamespace="http://www.acme.org/globalExample"
xmIns="http://www.acme.org/globalExample" elementFormDefault="qualified" attributeFormDefault="unqualified">
<xs:element name=jlobalElement">
<xs:complexType>
<xs:sequence>
<xs:HealEl@mantéminOccurs="1" maxOccurs="1" type="xs:string" />
</xs:sequence>
</xs:complexType>
</xs:element>
<xs:complexType name="globalType">
<xs:sequence>
<xs:element name="anotherLocalElement" minOccurs="0" maxOccurs="unbounded" type="xs:string" />
</xs:sequence>
</xs:complexType>
</xs:schema>

In the preceding example XML Schema, the globalElement is global because it is a direct child of the schen
element while localElement is local because it is child of globalElement.

You can also declare a global type definition as shown by the globalType element at the bottom of the
preceding XML Schema. While you can only have one global element in an XML Schema, you can create
many instances (with different names) of a global type in a single XML Schema.

The following table shows the graphical representations of these different XML components in the mapper.

Name Representation in the MappgName in Preceding Example XML Schema
Local Element | @ localElement globalElement
Global Element| # [2] globalElement localElement and anotherLocalElement
= &g Global Types
Global Type globalType globalType

Related Topics

Global Versus Local
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Examples: Manipulating and Constraining Data Using

XQuery

This section provides information and examples on how to use the mapper functionality of WebLogic
Workshop to constraint or manipulate data in a transformation, as summarized in the following table.

If You Want to Manipulate Your Datato . . .

As Shown in . ..

To Learn More,
See the Following
Example . ..

Combine the contents of two different schemg
Subelements of the repeating elements are nq
merged.

I%'lgure: Combining Data From
)lsifferent Schemas

Combining Data
From Different
Schemas

Merge the contents of repeating elements.
Subelements of repeating elements are mergs

Figure: Merging the Contents of
Hlepeating Elements

Merging the
Contents of
Repeating Elements

Combine sets of data of the same type (same
schema) into larger sets of data. Subelements
the repeating elements are not merged.

Figure: Combining Sets of the
ame Data

Using the Union
Option of the
Constraints Tab

Combine data and repeating elements based
passed in key value.

dingare: Merging Data Using a Key
Value

Using the Group by
Key Fields Option o
the Constraints Tab

Add a condition constraint which limits the
repeating elements that are returned.

Figure: Using a Conditional
Constraint to Merge Data

Creating a
Conditional
Constraint Using the
Constraints Tab

Add a complex condition constraint which limi
the repeating elements that are returned. A

[S

Adding a Constraint

simple condition.

complex conditional constraint contains two ofFigure: Complex Constraint With Multiple
more conditions joined together one of the Conditions
following join type: and, or.

Return a different value for target node based|on Adding

the outcome a simple if-then—else containing|&igure: If-Then-Else If-Then-Else

Constructs to a Link

Return a different value for target node based
the outcome of nested if—then—else(s) with
complex conditions.

on
Figure: Complex If-Then-Else

Adding Nested
If-Then-Else
Expressions with
Complex Conditions
to a Link

Convert data from a XML Schema simple typd
to a complex type.

tFigure: Non—Repeating Target
Element to Repeating Source Grg

Creating a
Transformation
Between a
Non—-Repeating
SBurce Element and
Repeating Target
Group

Examples: Manipulating and Constraining Data Using XQuery
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Convert data from a XML Schema complex tyﬁgure: Repeating Source Group {Greating a

to a simple type. Non—-Repeating Target Element |Transformation
Between a Repeating
Source Group and
Non—-Repeating
Target Element
Figure: Non—-Recursive Source |Using Recursive
Elements to a Recursive Target [Schemas in
Element Transformations

Create mappings with schemas that have
recursive elements.

Related Topics

To learn more about how to use the mapper functionality of WebLogic Workshop to create a data
transformation graphically, see Transforming Data Using XQuery.

For a step—by-step walk through of the mapping functionality, see Tutorial: Building Your First Data
Transformation.

To learn about the XQuery language, see the XQuery 1.0: An XML Query Language Specification — W3C
Working Draft 16 August 2002 available from the W3C web site at the following URL:

http://www.w3.0rg/TR/2002/WD-xquery—-20020816/

The WebLogic XQuery engine which is invoked by the Transformation method conforms to the August 16,
2002 draft of the XQuery Specification.

To learn more about XML and XML Schemas, see Java and XML Basics.
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Combining Data From Different Schemas

You can use the mapper functionality to combine the contents of two different schemas, as shown in the
following figure:

Figure : Combining Data From Different Schemas

Source XML Data

(valid to XML Schema in Custinfo.xsd) Result XML Data
<?xml version="1.0" encoding="UTF-8"7?> (valid to the XML Schema in POCustInfo.xsd)
<customer xmins="http:/Awww.creditpo.org/Custinfo"> <?xml version="1.0" encoding="UTF-8"?>
<customer-id>123456789</customer-id> <poc:purchase-order xmins:poc="http://www.creditpo.org/
<customer-name>CustomerX</customer-name=> POCustinfo">
<customer-address>AddressX</customer-address> J <poc:customer>
</customer> (" <cus:customer-id xmins:cus="http:/\www.creditpo.org/
Custinfo">123456789</cus:customer-id>
Source XML Data <cus:customer-name xmins:cus="http:/fwww.creditpo.org/

Custinfo">CustomerX</cus:customer-name>
<cus:customer-address xmins:cus="http:/iwww.creditpo.org/
ustinfo">AddressX</cus:customer-address>

(valid to the XML Schema in PO.xsd)
<?xml version="1.0" encoding="UTF-8"?>

<purchase-order xmins="http://www.creditpo.org/PO"> </poc:customer>
<line-items> ) (<pociline-items>
<line-item=> <poc:line-item=>
<part-no>1</part-no> <poc:part-no>1</poc:part-no>
<quantity>10</quantity> <poc:quantity>10</poc:quantity>
<fline-item> </poc:line-item>
<line-item> <poc:line-item>
<part-no>2</part-no> o <poc:part-no>2</poc:pan-no>
<quantity=>20</quantity> i <poc:quantity>20</poc:quantity>
</line-item> </poc:line-item>
<line-item> <poc:line-item>
<part-no>3</part-no> <poc:part-no>3</poc:part-no>
<quantity>30</quantity> <poc:quantity>30</poc:quantity>
</line-item> </poc:line-item>
<fline-items> — </poc:line-items>
</purchase-order> @:purchaseorder>

In this case, the customer information is merged with the line—items repeating element to form one combine
XML document.

This example describes how to create a transformation which combines the data from two different XML
Schemas. This example shows how to combine the XML sample data shown in the preceding figure. In this
example, the source data is not constrained or limited to produce the target data a where clause was not ad
to the for loop iterating over the purchase—order/line—-items/line—items using the Constraints tab.

To Combine Data From Different Schemas

1. Import the two XSD files that contain the XML Schemas for the source types of the transformation.
For instructions, see Selecting Source and Target Types.

For this example, import the files: Custinfo.xsd and PO.xsd files. If you installed WebLogic Platform
in the c:\bea directory, import these files from the
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\dataDiffSchemas directory.

Note: The PO.xsd file used in this example is identical to the PO.xsd file used in Using the Union

Option of the Constraints Tab. If you have already imported the PO.xsd file for the Using the Union
Option of the Constraints Tab example, you do not need to import it again.
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2. Import the XSD file that contains the XML Schema for the target type of the transformation. For
instructions, see Selecting Source and Target Types.

For this example, import the file: POCustinfo.xsd. If you installed WebLogic Platform in the c:\bea

directory, import this file from the
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\dataDiffSchemas directory.

Importing schemas files triggers a build of the current Schemas project folder. Wait until the current
Schemas project folder is built before proceeding to the next step. (The representations of the schen
will not be available in Available Source Types and Available Target Type panes until build is
complete.)

3. Create a Transformation file and a method in the Transformation file. For instructions, see Creating e
Transformation File and a Transformation Method.
4, Select the Transformation method from a Transformation file.

To select an existing method, in the Design View of the Transformation file:
a.Right—click the arrow representing the method.
b. From the drop—down menu, select Configure XQuery Transformation Method.

5. Select the source types for the transformation:
a.In the Available Source Types pane, expand the schema and element folders, until you find
the desired element.
b. In the Available Source Types pane, select the desired element.
c. Click Add.
The elements and attributes that make up the selected element are displayed in the Selected Source
Types pane.

For this example, select and add the Custinfo.xsd/customer and PO.xsd/purchase-order nodes.
6. Select the target type for the transformation:
a.In the Available Target Types pane, expand the schema and element folders, until you find
the desired element.
For this example, expand the POCustInfo.xsd schema folder.
b. In the Available Source Types pane, select the desired element.
For this example, select the POCustInfo.xsd/purchase-order element.

c. Click Add.

The elements and attributes that make up the selected element are displayed in the Selectec
Target Types pane.

7. Click Create Transformation.
The Design View of the XQ file is displayed.

8. Create links between repeating element nodes:
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a.In the Source pane, select the repeating element and drag it to the repeating element in the
Target pane.

For this example, link the $purchase_orderDaoc/line-items/line—item repeating element to the
purchase-order/line-items/line-item repeating element.

A dashed line linking the two repeating elements is displayed. The dashed line with short
dashes represents a structural link a link between two parent structures that does not map
data directly. The dashed-line representation for a structural link is shown in the following
figure:

[

To learn more about links, see Link Representations.

b. In the Source pane, select each of the subelements of the repeating element and drag them 1
the analogous subelement of the repeating element in the Target pane.

For this example, link the $purchase_orderDoc/line—items/line—item/part-no element to the
purchase-order/line-items/line-item/part—no element. In addition, link the
$purchase_orderDoc/line-items/line—item/quantity element to the
purchase-order/line—items/line—item/quantity element.

Two solid lines linking the two subelements is displayed. These solid lines represents a data
link a link that converts the value of the source node directly to the value of the target node
The solid line representation for a data link is shown in the following figure.

To learn more about links, see Link Representations.

9. Create links between the second set of nodes:
a.In the Source pane, select the $customerDoc node and drag it to the
$purchase—-order/customer node in the Target pane. A structural link between the two nodes
is created.
b. Right—click the structural link between the $customerDoc node and the
$purchase-order/customer node and from the pull-down menu select Induce Map.

A data link between the $customerDoc/customer—id node and the
$purchase—order/customer/customer—id node is created.

A data link between the $customerDoc/customer—-name node and the
$purchase—order/customer/customer—name node is created.

A data link between the $customerDoc/customer—address node and the
$purchase—order/customer/customer—address node is created.

The map between the source and target elements is shown in the following figure.
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Source | Target
= {27 customerDoc T S = [2)? purchase-order
O customer-id Tt caaay g = O‘? customer
© customer-name @ 5 customer-id
) customer-address @ 5 customer-name
= {27 purchase_orderDoc @ 5 customer-address
B @ line-items B @ line-items
= @ line-item Ml = == - - - --—-——————- = = @3 line-item
@ part-no @ 5 part-no
) quantity @ 5 quantity

10. Select the Test View tab.
11.Import XML or non—XML files as source data for the transformation. For more information, see
Creating Maps.

For this example, in the Source Data pane, select the $purchase_orderDoc node and import the file:
InputPO.xml. In the Source Data pane, select the $customerDoc node and import the file:
InputCust.xml. If you installed WebLogic Platform in the c:\bea directory, import these files from the
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\dataDiffSchemas\XML
directory.

Note: You can cut and past directory paths into the Name field of the Open File to Test pane to
jump to directory locations. If you installed WebLogic Platform in the c:\bea directory, you can jump
to the directory that contains the XML files for this example, by pasting the following directory path
into the Name field:
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\dataDiffSchemas\XML and
then pressing enter.

12.1n the Result Data pane, click Test.

If not currently running, the WebLogic Server for the current application will be started. In order for
a query to run, the WebLogic Server for the current application must be running.

In the Result Data pane, after the query is run a graphical representation of the target data is
displayed.

13.1f the target data is XML data, in the Result Data pane, you can view the resulting data as an XML
document by selecting the XML Source View tab. The XML result for this example is also displayed
in Figure: Combining Data From Different Schemas.

14.1f desired, you can validate the result data against the associated schema. In the Result Data pane c
the Test View, click Validate. To learn more, see Validating During Design Time.

15. Save the DTF and the XQ file. From the menu bar, choose File > Save All.
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You can use mapper functionality to merge the contents of repeating elements, as shown in the following
figure:

Figure : Merging the Contents of Repeating Elements

Source XML Data Result XML Data
(example data: PriceQuote.xml) (example data: Quote.xml)
<?xml version="1.0" 7> <?xml version="1.0"7>
<priceQuote xmins="http:/fexample.org/price™ <quote xmins="http:/fexample org/quote">
;briceRequestp <quoteResponse>
<priceRequest> » <widgetld>12</widgetld>
<widgetld>12</widgetld> ——] » <requestedQuanity>10</requestedQuanity>
<price>1.00</price> <fillOrder>true</fillOrder>
</priceRequest> <shipDate>2002-03-22</shipDate>
<priceRequest> » <unitPrice>1.00</unitPrice>
<widgetld>134</widgetld>
<price>34,10</price> <Iquotte§esponse>
</priceRequest> <quoteResponse>
</priceRequests> <widgetld>12</widgetld>
</priceQuote> <requestedQuanity>10</requestedQuanity>
<fillOrder>true</fillOrder>

<shipDate>2002-03-22</shipDate>

Source XML Data <unitPrice>34.10</unitPrice>
(example data: AvailQuote.xml)
</quoteResponse>
<7xml version="1,0"?> <quoteResponse>
<availQuote xmins="http://www.example.org/avail"> <widgetld>134</widgetld>
<availRequest> <requestedQuanity>345</requestedQuanity>
<widgetld>12</widgetld> <fillOrder>false</fillOrder>
<requestedQuanity>10</requestedQuanity=> <shipDate>BackOrder</shipDate>
<quanityAvail>true</quanityAvail> <unitPrice>1.00</unitPrice>
<shipDate>2003-03-22</shipDate> .
</availRequest> </quoteResponse=>
<availRequest> <quoteResponse>
<widgetld>134</widgetld> <widgetld>134</widgetld>
<requestedQuanity>345</requestedQuanity> <requestedQuanity>345</requestedQuanity>
<quanityAvail>false</quanityAvail> <fillOrder>false</fillOrder>
<shipDate>BackOrder</shipDate> <shipDate>BackOrder</shipDate>
</availRequest> <unitPrice>34.10</unitPrice>
</availQuote>
</quoteResponse>
</quote>

The join, shown in the preceding figure, merges the price and availability from the two source documents to
one output (target) document called Quote.xml. Specifically, the price (element: price) and widget Id
(element: widgetld) for the widgets is supplied by the PriceQuote.xml document and the number of widgets
available (element: requestedQuanity) is supplied by the AvailQuote.xml document. The widgetld and
requestedQuanity elements are part of the availRequest repeating element and price element is part of the
priceRequest repeating element. These subelements to repeating elements are merged into subelements o
guoteResponse repeating element.

For this example, a complete merge of the two sets of elements resulting in four elements as shown in
Figure: Merging the Contents of Repeating Elements is not desired. Instead a conditional constraint is need:
that will return the merged element only if the condition is true. To learn more, see Creating a Conditional
Constraint Using the Constraints Tab.
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For a step—by-step walk through of using the mapping functionality to create a join with a conditional
constraint, see Tutorial: Building Your First Data Transformation. Specifically, the join is created in Step 4:
Mapping Repeating Elements Creating a Join in the Tutorial: Building Your First Data Transformation.
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Using the Union Option of the Constraints Tab

You can use the Union option of the Constraints tab to combine sets of data of the same type into larger set
of data, as shown in the following figure.

Figure : Combining Sets of the Same Data

Source XML Data
(valid to the XML Schema in PO.xsd)

<?xml version="1.0" encoding="UTF-8"7>
<purchase-order xmins="http:/fwww.creditpo.org/PO">

<line-items> Result XML Data
<line-item> (valid to the XML Schema in Order.xsd)
<part-no>1</part-no>
< ity=10< ity>
<qine.iter::antlty 10<iquantity <?xml version="1.0" encoding="UTF-8"?>
<'Ilne-item> <ord:order xmins:ord="http:/iwww.creditpo.org/Order">
<part-no>2</part-no> L <ord;tims>
- ity>20</ - rd:item>
</Iine—izen?:amlty 2=y <ord:part-number>1</ord:part-number>
. v <ord:quantity-number>10</ord:quantity-number>
<fline-items=> :
</ord:item>
</purchase-order>
rd:item>
<ord:part-number>2</ord;part-number>
. Souce XML Data_ ’ <ord:quantity-number>20</ord:quantity-number>
(valid to the XML Schema in PO.xsd) <jord:item>
ord:item=>
<?xml version="1.0" encoding="UTF-8"7> N <ord:part-number>3</ord:part-number>
<purchase-order xmins="http:/fwww.creditpo.org/PO"> g <ord:quantity-number>30</ord.quantity-number>
<line-items> </ord:item=>
<line-item> <ord:item>
<part-no>3</part-no> <ord:part-number>4</ord:part-number>
<quantity>30</quantity> ( v <ord:quantity-number>40</ord:quantity-number>
<fline-item> </ord:item>
<line-item> X <jord:items>
<part-no>4</part-no> <ford:order>
<quantity>40</quantity> |
</line-item>

</line-items>
</purchase-order>

In this union, repeating elements of the same type are combined into a larger set but in the preceding join
example in Merging the Contents of Repeating Elements, the contents of repeating elements are merged.

SP3+ idea from Frank: While it has made for interesting test cases, having both line-items+ and line—-item+
repeatable doesn't really make sense. All you would need to do is lop off the outer maxOccurs="unbounded
in PO.xsd:

<xs:choice maxOccurs="unbounded">

<xs:choice>

LIZ COMMENT: | made this change to the PO.xsd schema.

This section describes how to create a transformation which combines two sets of repeating elements using
the Union option. This section shows how to combine the example XML data shown in the preceding figure.

To Combine Sets of Data of the Same Type
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1. Create a Transformation file and a method in the Transformation file. For instructions, see Creating ¢
Transformation File and a Transformation Method.

2. Import the XSD file that contains the XML Schema for the source type of the transformation. For
instructions, see Selecting Source and Target Types.

For this example, import the file: PO.xsd. If you installed WebLogic Platform in the c:\bea directory,
import this file from the c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\union

Note: The PO.xsd file used in this example is identical to the PO.xsd file used in Combining Data
From Different Schemas. If you have already imported the PO.xsd file for the Combining Data From
Different Schemas example, you do not need to import it again.

3. Import the XSD file that contains the XML Schema for the target type of the transformation. For
instructions, see Selecting Source and Target Types.

For this example, import the file: Order.xsd. If you installed WebLogic Platform in the c:\bea
directory, import this file from the
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\union directory.

Importing schemas files triggers a build of the current Schemas project folder. Wait until the current
Schemas folder is built before proceeding to the next step. (The representations of the schemas will
not be available in Available Source Types and Available Target Type panes until build is
complete.)

4. Select the Transformation method from a Transformation file.
To select an existing method, in the Design View of the Transformation file:

a.Right—click the arrow representing the method.
b. From the drop—down menu, select Configure XQuery Transformation Method.
5. Select the source types for the transformation:
a.In the Available Source Types pane, expand the schema and element folders, until you find
the desired element.
b. In the Available Source Types pane, select the desired element.
c. Click Add.
The elements and attributes that make up the selected element are displayed in the Selected Source
Types pane.

For this example, add the PO.xsd/purchase-order element twice.
6. Select the target type for the transformation:
a.In the Available Target Type pane, expand the Order.xsd schema folder.
b. In the Available Source Types pane, select the Order.xsd/order element.
c. Click Add.

The elements and attributes that make up the selected element are displayed in the Selectec
Target Type pane.

7. Click Create Transformation.
The Design View of the XQ file is displayed.
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8. In the Source pane, select the first repeating element and drag it to the repeating element in the
Target pane.

For this example, link the $purchase_orderDoc/line-items/line—item repeating element in the Source
pane to the order/items/item repeating element in the Target pane.

A dashed line linking the two repeating elements is displayed. The dashed line with short dashes

represents a structural link a link between two parent structures that does not map data directly. The
dashed-line representation for a structural link is shown in the following figure:

To learn more about links, see Link Representations.

9. In the Source pane, select the second repeating element and drag it to the repeating element in the
Target pane.

For this example, link the $purchase_orderDoc1l/line-items/line—item repeating element in the
Source pane to the order/items/item repeating element in the Target pane.

A dashed line linking the two repeating elements is displayed. The dashed line with short dashes

represents a structural link a link between two parent structures that does not map data directly. The
dashed-line representation for a structural link is shown in the following figure:

At this point, in the Constraint Type pane of the Constraints tab, the Repeatability/Join option is
selected.

Keep the last link selected for the next step.

10.In the Constraint Type pane of the Constraints tab, select the Union option.
11.Create data links from the first set of repeating element nodes.

In the Source pane, select each of the subelements of the repeating element and drag them to the
analogous subelement of the repeating element in the Target pane.

For this example, link the nodes shown in the following table:

Drag This Element From the Source Pane . . .| To This Element in the Target Pane . . .
$purchase_orderDoc/line-items/line—item/part—ooder/items/item/line—number
$purchase_orderDoc/line-items/line—item/quantitsder/items/item/quantity—number

Solid blue lines linking the two subelements are displayed. These solid lines represents a data link a
link that converts the value of the source node directly to the value of the target node The solid line
representation for a data link is shown in the following figure.

Since the two structural links have the union constraint applied to them, a set of implied data links
between the second set of subelements are generated as shown in the following figure.
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unionhlew, xq - {processWeb}\dtguide), X

Source Target
= (27 purchase_orderDoc = (27 order
B @  line-items E@© items
= @ line-item e == == === 3 = @3 item
O part-no — Ofpart-number
) quantity el @ 5 quantity-number
= (27 purchase_orderDoct A
B @ line-items L
5] O*Iine-item -- -
© part-no
) quantity

'| Design Yiew [Source View | Test View |

The solid gray lines represents implied links.

12.Select the Test View tab.
13.Import XML or non—-XML files as source data for the transformation. For more information, see
Creating Maps.

For this example, in the Source Data pane, select the $purchase_orderDoc node and import the file:
InputPO1.xml. In the Source Data pane, select the $purchase_orderDocl node and import the file:
InputPO2.xml. If you installed WebLogic Platform in the c:\bea directory, import these files from the
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\union\XML directory.

Note: You can cut and past directory paths into the Name field of the Open File to Test pane to
jump to directory locations. If you installed WebLogic Platform in the c:\bea directory, you can jump
to the directory that contains the XML files for this example, by pasting the following directory path
into the Name field:
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\union\XML and then pressing
enter.

14.1n the Result Data pane, click Test.

If not currently running, the WebLogic Server for the current application will be started. In order for
a query to run, the WebLogic Server for the current application must be running.

In the Result Data pane, a graphical representation of the target data is displayed.

15.1f the resulting data is XML data, in the Result Data pane you can view the resulting data as an XML
document by selecting the XML Source View tab. The XML result for this example is also displayed
in Figure: Combining Sets of the Same Data.

16.1f desired, you can validate the result data against the associated schema. In the the Result Data pa
of the Test View, click Validate.

17.Save the DTF and the XQ file. From the menu bar, choose File > Save All.

Note: The nodes are being joined in the union and not the data in the nodes. For example, if you are mergin

repeating elements in which the value of the part-no element is equal to 1, both part—-no elements appear ir
the target data as shown in the following figure.
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Source XML Data
(valid to the XML Schema in PO.xsd)

<?xml version="1.0" encoding="UTF-8"7>
<purchase-order xmins="http://www.creditpo.org/PO">

<line-items>

<line-item> Result XML Data
<par-no>1<jpart-no> (valid to the XML Schema in Order.xsd)
<quantity>10</quantity>

</line-item> <?xml version="1.0" encoding="UTF-8"?>

<line-item> 1 <ord:order xmins:ord="http://www.creditpo.org/Order">
<part-no>2</part-no> <ord:items>
<quantity>20</quantity> <ord:item>

<fline-item> <ord:part-number=>1<jord:part-number>

<fline-items>
</purchase-order>

<ord:quantity-number>10<jord.quantity-number>

Source XML Data <ord:part-number>2</ord:part-number>
(valid to the XML Schema in PO.xsd) <ord:quantity-number>20</ord:quantity-number>
</ord:item>
d:item>
<ord:part-number>1</ord:part-number>
<ord:quantity-number>10</ord:quantity-number>

<?xml version="1.0" encoding="UTF-8"7>
<purchase-order xmins="http://www.creditpo.org/PO">

<line-items> <lord-item>
<line-item> = d'item>
<part-no>1</part-no> \ )
<zuanrt‘it >1(;E /c:ugr?ﬁtw <ord:part-number>3</ord:part-number>
</line-item> ¥ l <ord:quantity-number>30</ord:quantity-number>
<line-item> :";ﬁ;"em:
<part-no>3</part-no> < Od_ l:mr:
<quantity>30</quantity> ord-orde
</line-item>
</line-items>

</purchase-order>

The query returns both repeating elements because it determines the repeating nodes are unique, even if tr
values of the part—no element are both equal to 1.

(] [=]
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Using the Group by Key Fields Option of the

Constraints Tab

You can use the Group by Key Fields option of the mapper functionality to group data based on a key value

as shown in the following figure:

Figure : Merging Data Using a Key Value

Source XML Data
(example data: GroupKeyFldIn.xml)

Kay Fields define how the
the output is grouped. In
this example, all
Warehousel line items are
grouped togeather.

Result XML Data
example data: GroupKeyFldOut.xml)

<7xml version="1.0"7>
<in-warehousa-inventory xmins="http2//www.credilpo.org/repkeyin™
<in-line-item>
<in-warehouse-id>Warehouse1</in-warehouse-id> 4
<in-location-desc>Location1</in-location-desc>
<in-part-no>1</in-part-no>

<in-quanmy>10<u‘in-quantity>:} I
<flin-line-item>

TT
i
I
=

<?xml version="1.0" encoding="UTF-8"7>
<rep:out-inventory xmins:rep="http:/fwww.cradilpo.org/repkeyout">
<rap.out-warehouse-inventory>
'! <rep.out-warehouse-id>Warehouse1</rep.out-warehouse-id>

<rep.out-location-desc/>
<rep:out-line-item>
<rep:out-part-no>1</rep.out-par-no>

<in-line-item>
<in-warehouse-id>Warehousa2</in-warehouse-id>
<in-location-desc>Location2</in-location-desc>
<in-part-no>2</in-part-no>
<in-guantity>20</in-quantity>

<lin-line-item>

<in-line-item>
<in-warehouse-id>Warehouse1</in-warehouse-id>
<in-location-dasc>Location1</in-location-desc>
<in-part-no>3</in-part-no>

<|n~quanl:ly>30<u'|rvquanl|!y;}
</in-line-item>

</in-warehouse-inventory> Cutar-most

repeating
element

Inner-most
repeating
elemant

%

<rep:out-quantity>10</rep:out-quantity>
</rap-out-line-item>
<rep:out-line-item>
<rgp:out-part-no>3<frap:out-parn-no>
<rep:out-quantity>30</rep:out-quantity>
</rep:oul-line-item>

......

<rep:out-warehouse-id>Warehouse2</rep:out-warehouse-id>
<rep:out-location-desc/>

Lemaa.

f<tep out-ine-item>
i <rep:out-part-no>2<jrep.out-pan-no>

% <rapiout-quantity>20</rep:out-quantity>
i</rap:out-line-item>

</rep:out-inventory>

In the example shown in the preceding figure, the in—warehouse—id element is the key field that is used to
group the output. Both the first and third instances of the in—line—item repeating element in the source
document contain the same value of the in—warehouse—id element (Warehousel), so these elements are

grouped together in the target (output) docume

nt.

This section describes how to group data by a key field using the Group by Key Fields option. This section
shows how to group the example XML data shown in the preceding figure.

To Group Sets of Data Based on a Key Field

1. Create a Transformation file and a method in the Transformation file. For instructions, see Creating ¢
Transformation File and a Transformation Method.

2. Import the XSD file that contains the XML Schema for the source and target types of the

transformation. For instructions, see Selecting Source and Target Types.

For this example, import the files: GroupKeyFldIn.xsd and GroupKeyFIldOut.xsd. If you installed
WebLogic Platform in the c:\bea directory, import these files from the
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\groupKeyFields directory.

Using the Group by Key Fields Option of the Constraints Tab
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Importing schemas files triggers a build of the current Schemas project folder. Wait until the current
Schemas folder is built before proceeding to the next step. (The representations of the schemas will
not be available in Available Source Types and Available Target Type panes until build is
complete.)

3. Select the source type(s) for the transformation:
a.In the Available Source Types pane, expand the schema and element folders, until you find
the desired element.
b. In the Available Source Types pane, select the desired element.
c. Click Add.
The elements and attributes that make up the selected element are displayed in the Selected Source

Types pane.
For this example, complete this step for the GroupKeyFIdIn.xsd/in—warehouse-inventory element.

4. Select the target type for the transformation:
a.In the Available Target Type pane, expand the schema and element folders, until you find
the desired element.

For this example, expand the GroupKeyFldOut.xsd schema folder.
b. In the Available Source Types pane, select the desired element.
For this example, select the GroupKeyFldOut.xsd/out-inventory element.

c. Click Add.

The elements and attributes that make up the selected element are displayed in the Selectec
Target Type pane.

5. Click Create Transformation.

The Design View of the XQ file is displayed.
6. Create all the data links.

For this example, make the following links:

¢ From the Source pane, drag the
$in_warehouse_inventoryDoc/in—line—item/in—warehouse—id element to the
out-inventory/out-warehouse—-inventory/out-warehouse—id repeating element in the Target
pane.

¢ From the Source pane, drag the
$in_warehouse_inventoryDoc/in-line—item/in—location—desc element to the
out-inventory/out-warehouse—-inventory/out—location—desc element in the Target pane.

¢ From the Source pane, drag the $in_warehouse_inventoryDoc/in—line—item/in—part-no
element to the out-inventory/out-warehouse-inventory/out-line—item/out—part—-no element
in the Target pane.

¢ From the Source pane, drag the $in_warehouse_inventoryDoc/in-line—item/in—quality
element to the out-inventory/out-warehouse-inventory/out-line—item/out—quantity element
in the Target pane.
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7. Create a link between source repeating element and the inner-most target repeating element. (See
Figure: Merging Data Using a Key Value for an example of an inner-most and outer—-most repeating
elements.) In the Source pane, drag the source repeating element to the inner-most target repeating
element in the Target pane.

For this example, link the $in_warehouse_inventoryDoc/in-line-item repeating element to the
out-inventory/out-line-item repeating element.

A dashed line linking the two repeating elements is displayed. The dashed line with short dashes

represents a structural link a link between two parent structures that does not map data directly. The
dashed-line representation for a structural link is shown in the following figure:

To learn more about links, see Link Representations.

8. In the Source pane, drag the source repeating element that contains the key field(s) to the outer-mo
target repeating element that will contain the key field(s) in the Target pane.

For this example, link the $in_warehouse_inventoryDoc/in-line—item repeating element to the
out—inventory/out-warehouse—-inventory repeating element.

A dashed line linking the two repeating elements is displayed. The dashed line with short dashes

represents a structural link a link between two parent structures that does not map data directly. The
dashed-line representation for a structural link is shown in the following figure:

To learn more about links, see Link Representations.

At this point, in the Constraint tab, the Constraint Type is Repeatability/Join but in a preceding
step, the Constraint Type will be set to Group by Key Fields)

Keep this link selected for the next step.
9. In the bottom half of the Design View for the XQ file, in the Constraints tab select the Group by
Key Fields option.

10.In the Select Group Key pane, select the in-warehouse—-id node and click Add.

The following is displayed in the Design View as shown in the following figure:
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groupByKeyFields.xq* - {processWeb}\dtguide’, X
Source Target
= 27 in_warehouse_inventoryDoc = (27 out-inventory
= @ in-line-item iescggecccccccna= > B (@ out-warehouse-inventory

@ ? in-warehouse-id @ 5 out-warehouse-id
@ ? in-location-desc @ 5 out-location-desc
@ ? in-part-no S - - = @3 out-line-item

& 7 in-quantity @ 5 out-part-no
O § out-quantity

| Design View [Source View | Test View |

| Build ™ Constraints “{ Target Expression
Constraint Type: (O RepeatabilityJoin (® Group by Key Fields

X

-| Group Keys

[4]
Select Group Key Key Field:
= (&% in-line-item | I I
[+]

N A
@) , in-warehouse-id Key Field List Remove
@ . in-location-desc ns0:in-warehouse-id
© 7 in-part-no
@ 7 in-quantity

11.Select the Test View tab.
12.Import XML or non—XML files as source data for the transformation. For more information, see
Creating Maps.

For this example, in the Source Data pane, select the $in_warehouse_inventoryDoc node and impor
the file: GroupKeyFIdin.xml. If you installed WebLogic Platform in the c:\bea directory, import this
file from the
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\groupKeyFields\XML
directory.

13.1n the Result Data pane, click Test.

If not currently running, the WebLogic Server for the current application will be started. In order for
a query to run, the WebLogic Server for the current application must be running.

In the Result Data pane, a graphical representation of the target data is displayed. The XML result
for this example is also displayed in Figure: Merging Data Using a Key Value.

14.1f the resulting data is XML data, in the Result Data pane you can view the resulting data as an XML
document by selecting the XML Source View tab.

15.1f desired, you can validate the result data against the associated schema. In the the Result Data pa
of the Test View, click Validate.

16. Save the DTF and the XQ file. From the menu bar, choose File > Save All.

] (=]
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Creating a Conditional Constraint Using the
Constraints Tab

In Merging the Contents of Repeating Elements, both of the source documents (PriceQuote.xml and
AvailQuote.xml) share the common element widgetld. A constraint (as a condition) can be added to the join
that specifies if the widgetld of the availRequest element is equal to the widgetld of the priceRequest eleme
the merged repeating element quoteResponse be returned.

When you create a structural link between a repeating element in the Design View, an XQuery for loop is
generated to iterate through the repeating elements. Creating a constraint using the Where Clause Expressi
pane of the Constraints tab adds a where clause to the XQuery for loops which limits the target repeating
elements which are returned during run time. The condition that makes up the where clause are evaluated f
each iteration of the for loop.

Adding this constraint would change the resulting data as shown in Figure: Merging the Contents of
Repeating Elements to the data shown in Figure: Using a Conditional Constraint to Merge Data.

Figure : Using a Conditional Constraint to Merge Data

Source XML Data
(example data: AvailQuote.xml)

<?xml version="1.0"7>
<availQuote xmins="http://www.example.org/avail">
<availRequest>

Result XML Data

+— ———— <widgetld>12</widgetld>
<requestedQuanity>10</requestedQuanity>
<quanityAvail>true</quanityAvail>
<shipDate>2003-03-22</shipDate>

</availRequest>

<availRequest>
<widgetld>134</widgetld>

<quanityAvail>false</quanityAvail>
<shipDate>BackOrder</shipDate>
</availRequest>
</availQuote>

(example data: Quote.xml)

<?xml version="1.0"7>
<quote xmins="http:/fexample.org/quote*>

;(;(.uoteResponse>
» <widgetld>12</widgetld>

<requestedQuanity>345</requestedQuanity>

» <requestedQuanity>10</requestedQuanity>
<fillOrder>true</fillOrder>
<shipDate>2002-03-22</shipDate>

» <unitPrice>1.00</unitPrice>

(example data: PriceQuote.xml)

<?xml version='1.0' 7>
<priceQuote xmins="http://example.org/price">

<priceRequests>

|
|
‘ Source XML Data
|
| <priceRequest>

Le—— — c—

<taxRate>.0800</taxRate>
<totalCost>10.8</totalCost>

</quoteResponse>

<quoteResponse>
<widgetld>134</widgetld>
<requestedQuanity>345</requestedQuanity>
<fillOrder>false</fillOrder>
<unitPrice>34.10</unitPrice>

</quoteResponse>

</quote>

<widgetld>12</widgetld>
<price>1.00</price>
</priceRequest>
<priceRequest>
<widgetld>134</widgetld>
<price>34.10</price>
</priceRequest>
</priceRequests>

</priceQuote>
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For a step—by-step walk through of using the mapping functionality to create a join with a constraint, see
Tutorial: Building Your First Data Transformation. Specifically, the join is created in Step 4: Mapping
Repeating Elements Creating a Join in the Tutorial: Building Your First Data Transformation.

In the next section an additional condition is added to the where clause. To learn more see Adding a
Constraint With Multiple Conditions.
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Adding a Constraint With Multiple Conditions

In Creating a Conditional Constraint Using the Constraints Tab, a constraint was added to the join that
specifies if the widgetld of the availRequest element is equal to the widgetld of the priceRequest element th
merged repeating element quoteResponse be returned. Creating a constraint using the Where Clause
Expression pane of the Constraints tab adds a where clause to the XQuery for loops which limits the target
repeating elements which are returned during run time. The condition that makes up the where clause is
evaluated for each iteration of the for loop. In this section you add another condition (resulting in a complex
condition) to the where of the for loop to further limit what is returned by the for loop as shown in the figure.

Figure : Complex Constraint
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element is returned.

Source XML Data
(example data: AvailQuote.xml)

<availQuote xmins="http://www.example.org/avail">

<availRequest>
<widgetld>12</widgetld>
<requestedQuantity>10</requestedQuantity>
<quantityAvail>true</quantityAvail>
<shipDate>2003-03-22</shipDate>

<favailRequest>

<availRequest>
<widgetld>134</widgetld>
<requestedQuantity>345</requestedQuantity>
<quantityAvail>false</quantityAvail>
<shipDate>BackOrder</shipDate>

</availRequest>

<availRequest>
<widgetld>211</widgetld>
<requestedQuantity>100</requestedQuantity>
<quantityAvail>true</quantityAvail>
<shipDate>2003-04-21</shipDate>

</availRequest>

</availQuote>

The constraint (the where clause of the for loop) contains the following complex condition:

where (data($priceRequest/ns{:widgetId)
and data($availRequest/nsl:requestedQuantity)

The where clause limits what is returned from the for loop during run time.

If the two widgetIds are equal and the requestedCuanity is less than 50, the cuoteResponse

data ($availRequest/nsl:widgetId)
< 50)

Result XML Data

N

A

<?xml version="1.0"?>
<quote xmins="http://fexample.org/quote">

<totalCost>10.8</totalCost>

</quoteResponse>
</quote>

<quoteResponse>
<widgetld>12</widget|d>
<unitPrice>1.00</unitPrice>
<requestedQuantity>10</requestedQuanti
<fillOrder>true</fillOrder>
<shipDate>2003-03-22</shipDate>
<taxRate>0.08</taxRate>

Source XML Data
(example data: PriceQuote.xml)

<?xml version="1.0' 7>
<priceQuote xmins="http:/fexample.org/price">

<priceRequests>
<priceRequest>
<widgetld>12</widgetld>
<price>1.00</price>
</priceRequest>
<priceRequest>
<widgetld>134</widgetld>
<price>34.10</price>
</priceRequest>
<priceRequest>
<widgetld>211</widgetld>
<price>10.00</price>
</priceRequest>
</priceRequests>
</priceQuote>

To Add a Condition to the Join in the Data Transformation Tutorial

1. From the BEA WebLogic Workshop menu bar, choose File > New > Application....

Adding a Constraint With Multiple Conditions
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The New Application dialog box is displayed.

N

.In the left pane, select the Tutorial folder.
3. In the right pane, select Tutorial: Process Application.

.In the Name field, enter Tutorial Add_Condition.
. From the Server drop—down menu, select the integration server. For example, if you installed
WebLogic Platform in the c:\bea directory on Windows, the path to the integration server is:

o1 b~

c:\bea\weblogic81\samples\domains\integration
6. Click Create.
Your Tutorial Process application is created and displayed in the Application tab.
7. 1In the Application tab, expand the Tutorial_Add_ConditionWeb folder.
The directories and files that make up the Tutorial project are displayed.
8. In the Application tab, expand the Tutorial_Add_ConditionWeb/requestquote folder.

The DTF, XQ, and JPD files used in the tutorial are displayed. These files are part of the Tutorial
project.

9. View Join.xq in the Design View. In the Application tab, double—-click
Tutorial_Process_Application\Tutorial_Add_ConditionWeb\requestquote\TutorialJoin.dtf\Join.xq and
select the Design View tab.

10. Select the link between the availQuoteDoc\availRequest node and the quote\quoteResponse node
in the Target pane.

The single condition that makes up the where clause is displayed in Where Clause Expression pane
of the Constraints tab.

11.Create the second condition in the where clause:

a.In the Source pane select the availQuoteDoc/availRequest/requestedQuanity node and
drag—and-drop it into the Left Hand Expression section of the Where Clause Expression
pane.

b. Select the < operator.

c. Remove the text in the Right Hand Expression section of the Where Clause Expression
pane.

d. In the Right Hand Expression section of the Where Clause Expression pane enter 50.

e.From the Join Type field select the AND option.

The Join Type determines how the conditions that make up where clause are evaluated
during run time.

f. Click Add.

The second condition is added to the where clause of the for loop.
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12.To run the query, select the Test View of the XQ file.

13.1n this step, you import AvailQuote.xml for the source parameter: $availQuoteDoc:
a.From the drop—down menu in the Source Data pane, select $availQuoteDoc.
b. Click Import... .

The Open XML File to Test dialog box is displayed.

c. Double—click the requestquote folder.
d. Double—click the testxml folder.
e.Double—-click the AvailQuote.xml file.

14.1n this step, you import PriceQuote.xml for the source parameter: $priceQuoteDoc:
a.From the drop—down menu in the Source Data pane, select $priceQuoteDoc.
b. Click Import... .

The Open XML File to Test dialog box is displayed.

c. Double—click the requestquote folder.
d. Double—click the testxml folder.
e.Double-click the PriceQuote.xml file.
15. Enter the taxRate value:
a.From the drop—down menu in the Source Data pane, select $taxRate.
b. In the Node Value field of the $taxRate node, double—click on the existing value, and enter:
0.08 and click Enter.
16.In the Result Data pane, click Test.

If not currently running, the WebLogic Server for the current application will be started. In order for
a query to run, the WebLogic Server for the current application must be running.

In the Result Data pane, a graphical representation of the target data is displayed. The XML result
for this example is also displayed in Figure: Complex Constraint.

During run time, the where clause limits what is returned by the for loop. If the two widgetlds are
equal and the requestedQuanity is less than 50, the quoteResponse element is returned.
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Adding Nested If-Then—Else Expressions with
Complex Conditions to a Link

The following example shows adding nested if-then—else expressions to a link to supply the appropriate
supplier id for an incoming purchase order. In addition this section shows how you can use functions in
if-then—else expressions.

In this example, if partld is between 0 and 200, use the Supplier with the id of 12453. If the partld is betweer
201 and 400, the Supplier id is dependant on the quantity requested. If the quantity requested is over the
maximum volume for one Supplier (id: 20045) use the high volume Supplier (id: 35667.) In addition, this
example appends the source countryCode to the supplier id code using the concat function call as shown in
following figure.

Figure : Complex If-Then—-Else

Input XML Data Query
(example data: (XQuery Code)
PurchaseOrder.xml) )
<Supplier>
<id>{

<?xml version="1.0" encoding="UTF-8"?> if ((data($PurchaseOrderDoc/partld) > 0 and data($PurchaseOrderDoc/partld) <= 200)) then
<PurchaseOrder> || xf-concat($PurchaseOrderDoc/countryCode,
<partld>345</partld> — ".12353")
<quantity>678</quantity> 1/ else
<maxVolumeForSupplier>1000</ if ((data(SPurchaseOrderDoc/partld) > 200 and data($PurchaseOrderDoc/partld) <= 400)) the
maxVolumeForSupplier> if (data($PurchaseOrderDoc/quantity) > xs:decimal(data(SPurchaseOrderDoc/
<countryCode>UK</countryCode> max\VolumeForSupplier))) then
</PurchaseOrder> xf:concat($PurchaseOrderDoc/countryCode,
*.20045%)
else
xf:concat{$PurchaseOrderDoc/countryCode,
"-35667")

else
xf-concat($PurchaseOrderDoc/countryCode,
*.56898") }</id>
</Supplier>

=

Output XML Data

<?xml version="1.0" encoding="UTF-8"7>
<Supplier>

<id>UK-35667</id>
</Supplier=>

To Create the If-Then-Else Example with Complex Conditions

1. Open a query in the mapper pane. For instructions see General Steps to Open or Create a Query in
the Mapper.

For this example, import the files: PurchaseOrder.xsd and Supplier.xsd files (step 2 in General Steps
to Open or Create a Query in the Mapper.) If you installed WebLogic Platform in the c:\bea directory,
import these files from the

c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\ifThenElse directory.

Adding Nested If-Then—-Else Expressions with Complex Conditions to a Link 78



Guide to Data Transformation

For this example, select and add the PurchaseOrder.xsd/PurchaseOrder node as an source type (st
in General Steps to Open or Create a Query in the Mapper.)

For this example, select and add the Supplier.xsd/Supplier node as an target type (step 4 in General
Steps to Open or Create a Query in the Mapper.)

2.In the Design View, create a link by dragging—and—-dropping the PurchaseOrderDoc/countryCode
Source element over the Supplier/id Target node.

Keep the link selected for the next step.

3. Select the Target Expression tab. (If the Target Expression tab is not visible in WebLogic
Workshop, choose View > Windows > Target Expression from the menu bar.)
4. Select the If Then Else option.

An XQuery if-then—else construct is added to the link.
5. Click If Condition.
The If Condition pane appears.

6. Add the first condition to the if section of the if-then—else:
a.From the Source pane, drag the PurchaseOrderDoc/partld element into the Left Hand
Expression section of the If Condition pane.
b. Select the operator: >.
c. In the Right Hand Expression section of the If Condition pane, enter: 0 and click Add.
The first condition is added to the if section of the if-then—else.

7. Construct the second condition to the if section of the if-then—else:
a.From the Source pane, drag—and-drop the PurchaseOrderDoc/partld element into the Left
Hand Expression section of the If Condition pane.
b. Select the operator: <=.
c. In the Right Hand Expression section of the If Condition pane enter: 200.
8. From the Join Type field select the AND option.

The Join Type determines how the conditions that make up if section of the if-then—else are
evaluated during run time.

9. Click Add.
The second condition is added to the if section of the if-then—else.
During run time, for example if partld is equal to 100, the if condition is evaluated as described here:

¢ The first condition (partld>0) evaluates to true.
¢ The second condition (partld<=200) evaluates to true resulting in the if condition: (true and
true).
¢ The if condition: (true and true) evaluates to true resulting in execution of the then
expression.
10.Click Then Expression.
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The contents of the Then Expression are selected.
Keep the contents selected for the next step.

11.Create the then expression:

a. Select the Palette. (If the Palette is not visible in WebLogic Workshop, choose View >
Windows > Palette from the menu bar.)

b. In the Palette, expand String Functions.

c. Select the concat function and drag it into the Then Expression pane. Leave the first
$string—var argument selected for the next step.

d. From the Source pane, drag—and-drop the PurchaseOrderDoc/countryCode element over th
first $string—var argument of the concat function in the Then Expression pane.

e. Select the text: $string—var and click the Delete key. Leave the cursor in the current location.

f. Enter: "-12453".

The $string—var argument is replaced by the string: "-12453".

g. Click Apply.
The following XQuery code of the then expression is saved:

xf:concat($PurchaseOrderDoc/countryCode,
"-12453")

During run time, when the if condition evaluates to true, the then expression is evaluated. When the
then expression created in this step is evaluated, it concatenates the countryCode with supplier id of
12453 and returns this value as the Target Supplier/id.

12.1n this step, you add a nested if-then—else to the else.
The nested if-then—else added in this step, tests if the supplied source partld is between 201 and 4C
For partlds in this range, the returned Supplier id is dependant on the quantity requested. If the
quantity requested is over the maximum volume for one Supplier (id: 20045) the high volume
Supplier (id: 35667) is returned.
To add the nested if-then—else to the else expression:

a. Select the down arrow to the right of Else Expression, and from the drop—down menu select
Insert Nested If-Then—Else.

A nested if-then—else is added to the else and Else becomes Else If Condtion.
b. Add the first condition to the if section of the second level if-then—else:

From the Source pane, drag—and—drop the PurchaseOrderDoc/partld element into the Left
Hand Expression section of the If Condition pane.

Select the operator: >.

In the Right Hand Expression section of the Else If Condition pane, enter: 200 and click
Add.
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The first condition is added to the if section of the second level if-then—else.
c. Construct the second condition to the if section of the second level if-then—else:

From the Source pane, drag the PurchaseOrderDoc/partld element into the Left Hand
Expression section of the Else If Condition pane.

Select the operator: <=.
In the Right Hand Expression section of the Else If Condition pane, enter: 400.
d. From the Join Type field, select the AND option.

The selected Join Type determines how the conditions that make up if section of the
if-then—else are evaluated during run time.

13.Click Add.
The second condition is added to the if section of the second level if-then—else.
14.Select Else If Condition of the second level if-then—else to collapse the Else If Condition pane.

In the Target Expression tab the following is displayed as shown in the following figure.

| [ Constraints | Target Expression . -

Expression Type: (O General (@ If Then Else

+| If Condition ~ ({data($PurchaseOrderDoc/partld) > 0 and data($PurchaseOrderDoc/partld) <=200))

+| Then Expression ~ xf:concat{$PurchaseOrderDoc/countryCode,”"-12453")

+| Else If Condition -~ ({{data($PurchaseOrderDoc/partld) > 200 and data($PurchaseOrderDocfpartld) <=400))
+| Then Expression ~ ()
+| Else Expression ~ ()

15.1n this step, you add another nested if-then—else to the then of the second level if-then—else. This
if—-then—else determines if the quantity requested is over the maximum volume for one Supplier (id:
20045) return the high volume Supplier (id: 35667).

To add the third if-then—else to the then expression:
a. Select the down arrow to the right of the second Then Expression at the bottom of the pane,

and from the drop—down menu select Insert Nested If-Then—-Else as shown in the following
figure.
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| Constraints j Target Expression X

Expression Type: (O General (@ If Then Else

+| If Condition ~ ({(data($PurchaseOrderDoc/partld) > 0 and data{$PurchaseOrderDoc/partld) <=200))

+| Then Expression -~ xf:concat{$PurchaseOrderDocfcountryCode,”-12453")

+| Else If Condition -~ ({data{$PurchaseOrderDoc/partld) = 200 and data($PurchaseOrderDocfpartld) <=400))
+| Then Expression ~ ()
+| Else Expression Edit Then Expression

| [BUId Y Output Insert Nested If-Then-Else %

A nested third level if-then—else is added to the then and Then Expression becomes Then
If Condition.

b. Add a condition to the if section of the third level if-then—else:

From the Source pane, drag the PurchaseOrderDoc/quantity element into the Left Hand
Expression section of the Then If Condition pane as in the following figure.

| Constraints j Target Expression X

Expression Type: () General (@ If Then Else

+| If Condition ~ ({(data($PurchaseOrderDocfpartld) > 0 and data{$PurchaseOrderDoc/partld) <=200))

+| Then Expression -~ xf:concat{$PurchaseOrderDocfcountryCode,”-12453™)

+| Else If Condition -~ ({data{$PurchaseOrderDoc/partld) = 200 and data($PurchaseOrderDocfpartld) <=400))
-| Then If Condition ~

Left Hand Expression |0perator ] ' Right Hand Expression -

al§PurchaselrderDoc/quantity) E] E}l % Join Type:
[

i
[J | | [*]

~

DEI

+| Then Expression ~ ()
+| Else Expression ~ ()
+| Else Expression ~ ()

Select the operator: >.

Select the Palette. (If the Palette is not visible in WebLogic Workshop, choose View >
Windows > Palette from the menu bar.)

In the Palette, expand Type Functions.

Select the decimal function and drag—and—drop it into the Right Hand Expression section
of the Then If Condition pane. Leave the first $string—var argument selected for the next
step.

From the Source pane, drag the PurchaseOrderDoc/maxVolumeForSupplier element over
the first $string—var argument of the decimal function in the Right Hand Expression section

of the Then If Condition pane and click Add.
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A condition is added to the if section of the third level if-then—else.

Note: You must explicitly cast the PurchaseOrderDoc/maxVolumeForSupplier element as a
decimal to force the comparison between the Left Hand Expression and the Right Hand
Expression to be a numerical comparison and not a lexicographical one.

QUESTION FOR REVIEWERS: Is the above note clear enough?

16. Create the then expression of the third level if-then—else:
a. Select the Then Expression of the third level if-then—else.
The following is displayed in the Target Expression tab.

Constraints | Target Expression X

Expression Type: (O General (@ If Then Else

+| If Condition ~ ({data($PurchaseOrderDoc/partld) > 0 and data($PurchaseOrderDoc/partld) <=200))
+| Then Expression ~ xficoncat{$PurchaseOrderDoc/countryCode,”"-12453™)
+| Else If Condition -~ ({data($PurchaseOrderDoc/partld) > 200 and data($PurchaseOrderDocfpartld) <=400))

+| Then If Condition ~ data({$PurchaseOrderDoc/quantity) = xs:decimal{data{$PurchaseOrderDoc/maxVolumeForsi...
-| Then Expression ~ Apply

+| Else Expression ~ ()
+| Else Expression ~ ()

a. Select the Palette. (If the Palette is not visible in WebLogic Workshop, choose View >
Windows > Palette from the menu bar.)

b. In the Palette, expand String Functions.

c. Select the concat function and drag it into the Then Expression pane. Leave the first
$string—var argument selected for the next step.

d. From the Source pane, drag—and—drop the PurchaseOrderDoc/countryCode element over th
first $string—var argument of the concat function in the Then Expression pane.

e.Select the text: $string—var and click the Delete key. Leave the cursor in the current location.
f. Enter: "-20045".

The $string—var argument is replaced by "-20045".

g. Click Apply.
The XQuery code of the then expression of the third level if-then—else is saved.

During run time, when the if condition evaluates to true, the then expression is evaluated. If the then

expression created in this step is evaluated, it concatenates the countryCode with supplier id of 2004
and returns this value as the Target Supplier/id.
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17.Create the else expression of the third level ifF-then—else:
a. Select the Else Expression of the third level if-then—else.

The following is displayed in the Target Expression tab.

Constraints | Target Expression X

Expression Type: (O General (@ If Then Else

+| If Condition ~ ({data($PurchaseOrderDoc/partld) > 0 and data($PurchaseOrderDoc/partld) <=200))
+| Then Expression ~ xficoncat{$PurchaseOrderDoc/countryCode,”"-12453™)
+| Else If Condition -~ ({data($PurchaseOrderDoc/partld) > 200 and data($PurchaseOrderDocfpartld) <=400))
+| Then If Condition ~ data{$PurchaseOrderDoc/quantity) = xs:decimal{data{$PurchaseOrderDoc/maxYolumeForsi...
+| Then Expression ~ xf:concat{$PurchaseOrderDoc/countryCode,”-20045™)
- | Else Expression ~

+| Else Expression ~ ()

b. Select the Palette. (If the Palette is not visible in WebLogic Workshop, choose View >
Windows > Palette from the menu bar.)

c. In the Palette, expand String Functions.

d. Select the concat function and drag it into the Then Expression pane. Leave the first
$string—var argument selected for the next step.

e.From the Source pane, drag—and-drop the PurchaseOrderDoc/countryCode element over th
first $string—var argument of the concat function in the Then Expression pane.

f. Select the text: $string—var and click the Delete key. Leave the cursor in the current location.

g. Enter: "-35667".

The $string—var argument is replaced by "-35667".

h. Click Apply.
The XQuery code of the else expression of the third level if-then—else is saved.

During run time, when the if condition evaluates to false, the else expression is evaluated. If the else
expression created in this step is evaluated, it concatenates the countryCode with supplier id of 356¢
and returns this value as the Target Supplier/id.

18. Create the else expression of the second level if-then—else:
a. Select the Else Expression of the second level if-then—else.

The following is displayed in the Target Expression tab.
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Constraints Y Target Expression X

Expression Type: () General (@ If Then Else

+| If Condition ~ ({data($PurchaseOrderDoc/partld) > 0 and data($PurchaseOrderDoc/partld) <=200))
+| Then Expression ~ xficoncat{$PurchaseOrderDoc/countryCode,”"-12453™)
+| Else If Condition -~ ({data($PurchaseOrderDocfpartld) > 200 and data($PurchaseOrderDocfpartld) <=400))
+| Then If Condition ~ xf:boolean("true™)
+| Then Expression ~ xf:concat{$PurchaseOrderDoc/countryCode,-20045™)
+| Else Expression ~ xf:concat{$PurchaseOrderDoc/countryCode,"-35667")
-| Else Expression ~

b. In the Palette, expand String Functions.

c. Select the concat function and drag it into the Then Expression pane. Leave the first
$string—var argument selected for the next step.

d. From the Source pane, drag—and—drop the Purchase Order Doc/contracted element over the
first $string—var argument of the concat function in the Then Expression pane.

e.Select the text: $string—var and click the Delete key. Leave the cursor in the current location.
f. Enter: "-56898".

The $string—var argument is replaced by "-56898".

g. Click Apply.
19. Select the General option, to view the generated XQuery source code. The following XQuery code is
displayed:

if ((data($PurchaseOrderDoc/partld) > 0 and data($PurchaseOrderDoc/partld) <= 200)) then
xf:concat($PurchaseOrderDoc/countryCode,
"-12353")
else
if ((data($PurchaseOrderDoc/partld) > 200 and data($PurchaseOrderDoc/partld) <= 400)) then
if (data($PurchaseOrderDoc/quantity) > xs:decimal(data($PurchaseOrderDoc/maxVolumeForSupplier))) then
xf:concat($PurchaseOrderDoc/countryCode,
"-20045")
else
xf:concat($PurchaseOrderDoc/countryCode,
"-35667")
else
xf:concat($PurchaseOrderDoc/countryCode,
"-56898")

20.To run the query, select the Test View of the XQ file.

21.Import the file: PurchaseOrder.xml. If you installed WebLogic Platform in the c:\bea directory,
import this file from the

c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\ifThenElse\XML directory.
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Note: You can cut and past directory paths into the Name field of the Open File to Test pane to
jump to directory locations. If you installed WebLogic Platform in the c:\bea directory, you can jump
to the directory that contains the XML files for this example, by pasting the following directory path
into the Name field:
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\ifThenElse\XML and then
pressing enter.

22.1n the Result Data pane, click Test.

If not currently running, the WebLogic Server for the current application will be started. In order for
a query to run, the WebLogic Server for the current application must be running.

In the Result Data pane, a graphical representation of the target data is displayed.

In the Result Data pane, the resulting value of Supplier/id element is UK-35667. The specified
source partld (345) is between 200 and 400 and the specified source quantity (678) is less than the
specified source maxVolumeForSupplier (1000), so the else expression:
xf:concat($PurchaseOrderDoc/countryCode, "-", xf:string(35667)) is evaluated (shown in bold in the
preceeding XQuery code listing), resulting in the string: UK-35667 being returned as the value of the
Supplier/id element as shown in the following resulting XML data:

<?xml version="1.0" encoding="UTF-8"?>
<Supplier>

<id>UK-35667</id>
</Supplier>

23.Save the DTF and the XQ file. From the menu bar, choose File > Save All.
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Creating a Transformation Between a Non—Repeating
Source Element and Repeating Target Group

This example shows how to map a XML Schema simple type (for example: a non—repeating single element)
to a XML Schema complex type (for example: a repeating element) as shown in the following figure. In this
example, you will create a transformation that during run time will take a single source element and maps it
repeating target element as shown in the following figure.

Figure : Non—Repeating Target Element to Repeating Source Group

During run time, the query executes the following actions:

1) If the name of the source input element is equal to "pilling-date”,
then the string: EILLING is retumned as the data for the value node.

AN
2) The value of the source XML element 0i11ing-date becomes the
value of the target t yoe XML element.
\\\ Result XML Data
(valid to the XML Schema in Dates.xsd)
Source XML Data
(valid to the XML Schema in PODate.xs\ <?xml version="1.0" encoding="UTF-8"7>
<dat:dates xmins:dat="http://www.acme.org/Dates™
<?xml version="1.0" encoding="UTF-8"7> <dat:date>
<pod:PODate xmlns:pod="hnp:.’Mww.acme.Ofg.'PODate">\ [ » <dat:type>BILLING</dat:type>
<pod:billing-date>3/30/2004 </pod:billing-date> p <datvalue>3/30/2004</dat:value>
<pod:delivery-date>4/04/2004</pod:delivery-date> 3= </dat:date>
</pod:PODate> <dat:date>
» <dat:itype>DELIVERY</dat:type>
» <dat:value>4/04/2004</dat:value>
</dat:date>
</dat:dates>
3) If the name of the source input element is equal to “delivery-date”,
then the string: DELIVEEY is returned as the data for the vz1ue node.

//

4) The value of the source XML element delivery-date becomes the
value of the target tvoe XML element.

To Create and Run a Transformation Between a Non—Repeating Source Element and a Repeating Target
Group

1. Create a Transformation file and a method in the Transformation file. For instructions, see Creating ¢
Transformation File and a Transformation Method.

2. Import the XSD file that contains the XML Schema for the source type of the transformation. For
instructions, see Selecting Source and Target Types.

For this example, import the file: PODate.xsd. If you installed WebLogic Platform in the c:\bea
directory, import this file from the
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\singleToRepeat directory.

Note: The PODate.xsd file used in this example is identical to the PODate.xsd file used in Creating a

Transformation Between a Repeating Source Group and Non—Repeating Target Element. If you hav
already imported the PODate.xsd file for the Creating a Transformation Between a Repeating Sourct
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Group and Non-Repeating Target Element example, you do not need to import it again.

3. Import the XSD file that contains the XML Schema for the target type of the transformation. For
instructions, see Selecting Source and Target Types.

For this example, import the file: Dates.xsd. If you installed WebLogic Platform in the c:\bea
directory, import this file from the
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\singleToRepeat directory.

Note: The Dates.xsd file used in this example is identical to the Dates.xsd file used in Creating a
Transformation Between a Repeating Source Group and Non—-Repeating Target Element. If you hav
already imported the Dates.xsd file for the Creating a Transformation Between a Repeating Source
Group and Non-Repeating Target Element example, you do not need to import it again.

Importing schemas files triggers a build of the current Schemas project folder. Wait until the current
Schemas folder is built before proceeding to the next step. (The representations of the schemas will
not be available in Available Source Types and Available Target Type panes until build is
complete.)

4. Select the Transformation method from a Transformation file.
To select an existing method, in the Design View of the Transformation file:
a.Right—click the arrow representing the method.
b. From the drop—down menu, select Configure XQuery Transformation Method.
5. Select the source type for the transformation:
a.In the Available Source Types pane, expand the PODate.xsd folder.
b. In the Available Source Types pane, select the PODate.xsd/PODate element.
c. Click Add.
The elements and attributes that make up the PODate.xsd/PODate element are displayed in the
Selected Source Types pane.
6. Select the target type for the transformation:
a.In the Available Target Types pane, expand the Dates.xsd folder.
b. In the Available Target Types pane, select the desired element.
For this example, select the Dates.xsd/date element.
c. Click Add.

The elements and attributes that make up the Dates.xsd/date element are displayed in the
Selected Target Types pane.

7. Click Create Transformation.
The Design View of the XQ file is displayed.

8. In the Source pane, select the element (PODateDoc/billing—date) and drag it the repeating element
(dates/date) in the Target pane.
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A dashed line linking the two elements is displayed. The dashed line with short dashes represents a
structural link a link that does not map data directly. The dashed-line representation for a structural
link is shown in the following figure.

To learn more about links, see Link Representations.

9. In the Source pane, select the element (PODateDoc/delivery—date) and drag it the repeating elemen
(dates/date) in the Target pane.

A dashed line (representing a structural link) between two elements is displayed and the two dates
(PODateDoc/delivery—date and PODateDoc/billing—date) are automatically unioned together. In
addition, the Structural Link variable PODate is automatically created and displayed in the Data
Palette.

The following XQuery is code is generated:

<nsl:.dates>

for $PODate in $PODateDoc/ns0:billing—date union $PODateDoc/ns0:delivery—date
return
<nsl:date/>

</nsl:.dates>

$PODateDoc is the source or input variable to the transformation, while $PODate is the iteration
variable for union of the elements: $PODateDoc/ns0:billing—date and
$PODateDoc/ns0:delivery—date.

During run time, the for loop in the preceding XQuery code is executed twice. The first time the for
loop is run, the iteration variable $PODate is equal to the first element in the union:
$PODateDoc/ns0:billing—date and the second time the for loop is run the iteration variable $PODate
is equal to the second element in the union: $PODateDoc/ns0:delivery—date. The XML data returnec
by the preceding query returns two empty elements: <nsl:date/>. The following steps will add the
XQuery code to return the billing and delivery dates to the query.

10.In the Source pane, select the PODateDoc/billing—date element and drag it the dates/value element
the Target pane.

Two data links are created as shown in the following figure.

Source Target
= [£)? PODateDac = [&)? dates
() biling-date = @F date
) delivery-date © type
) 5 value

Since the structural links (PODateDoc/billing—date to dates/date) and (PODateDoc/delivery—date
dates/date) are unioned together, when you created the link from the PODateDoc/billing—date eleme
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to the dates/value element (dates/value), a second data link between the PODateDoc/deilivery—date
element and dates/value element is automatically created.

11.In the Source pane, select the PODateDoc/billing—date element and drag it the dates/type element ir
the Target pane.

Two data links are created.
Keep the PODateDoc/billing—date to dates/type link selected for the next step.

12.Select the Target Expression tab. (If the Target Expression tab is not visible in WebLogic
Workshop, choose View > Windows > Target Expression from the menu bar.)
13.Select the If Then Else option.

The XQuery if-then—else construct is added to the link. For example, the following XQuery source
code segment for the link is replaced:

data($PODate)

By the following XQuery source code segment for the link:

if (xf:boolean("true™)) then
data($PODate)
else

0

14.Click If Condition.
The If Condition pane appears.

15.1n this step, you add a condition to the if section of the if-then—else:

a.Select the Palette. (If the Palette is not visible in WebLogic Workshop, choose View >
Windows > Palette from the menu bar.)

b. In the Palette, expand Node Functions.

c. Select the local-name function and drag it into the Left Hand Expression pane of the If
Condition pane. Leave the $node-var argument selected.

d. Select the Data Palette. (If the Data Palette is not visible in WebLogic Workshop, choose
View > Windows > Data Palette from the menu bar.)

e.From the Data Palette pane, drag—and—drop the PODate Structural Link variable over the
$node-var argument of the local-name function in the If Condition pane.

f. Select the operator: =.

g. In the Right Hand Expression section of the If Condition pane, enter: "billing—date" and
click Add.

Note: You must enter double quotes around the "billing—date" string.
The condition is added to the if section of the if-then—else.

16.Click Then Expression.
17.1n the Then Expression section, replace the existing text with the string: "BILLING".

Replace the following text:

Creating a Transformation Between a Non—Repeating Source Element and Repeating Target Gro@g



Guide to Data Transformation

data($PODate)
With the following string:

"BILLING"
Note: You must enter double quotes around the "BILLING" string.

18.Click Apply.
19.Click Else Expression.
20.In the Else Expression section, enter the string: "DELIVERY".

Note: You must enter double quotes around the "DELIVERY" string.

21.Click Apply.
22.Select the General option, to view the generated if-then—else XQuery source code.

The following XQuery code is displayed:

if (xf:local-name($PODate) = "billing—date") then
"BILLING"

else
"DELIVERY"

During run time, this if-then—else statement is executed twice by the XQuery for loop. The if part of
the if-then—else executes the following condition:

xf:local-name($PODate) = "billing—date"

In the left—-hand expression of the if condition, the iteration variable $PODate is passed into the
local-name function as a parameter. The local-name function returns the name of the XML element
For example: if the $PODate iteration variable contains the XML element named billing—date, the
string: billing—date is returned by the local-name function and therefore, the left—-hand expression of
the if condition evaluates to the string: billing—date.

The right—-hand expression of the if condition is equal to the string: "billing—date".

In the if condition, the left—hand expression is compared with the right-hand expression, and if the
two strings are equal, the if condition evaluates to true and the string: "BILLING" is returned as the
value of the target node: dates/date/type.

Note: For simplicity, in this example it is assumed that if $PODate does not equal "billing—date", it
must equal "delivery—date".

23.Select the Test View tab.
24.Import XML files as source data for the transformation.

For this example, in the Source Data pane, select the $datesDoc node and import the file:
PODatelnput.xml. If you installed WebLogic Platform in the c:\bea directory, import this file from the
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\single ToRepeat\XML
directory.
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Note: You can cut and past directory paths into the Name field of the Open File to Test pane to
jump to directory locations. If you installed WebLogic Platform in the c:\bea directory, you can jump
to the directory that contains the XML files for this example, by pasting the following directory path
into the Name field:

c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\singleToRepeat\XML and
then pressing enter.

25.1n the Result Data pane, click Test.

If not currently running, the WebLogic Server for the current application will be started. In order for
a query to run, the WebLogic Server for the current application must be running.

In the Result Data pane, a graphical representation of the target data is displayed.

26.If the resulting data is XML data, in the Result Data pane you can view the resulting data as an XML
document by selecting the XML Source View tab. The XML result for this example is also displayed
in Figure: Non—Repeating Target Element to Repeating Source Group.

27.1f desired, you can validate the result data against the associated schema. In the Result Data pane ¢
the Test View, click Validate.

28.Save the DTF and the XQ file. From the menu bar, choose File > Save All.
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Creating a Transformation Between a Repeating
Source Group and Non—Repeating Target Element

This example shows how to map a XML Schema complex type (for example: a repeating element) to a XML
Schema simple type (for example: a non-repeating single element). In this example, you will create a
transformation that during run time will take a source repeating element and maps it to single target field
using constraints as shown in the following figure.

Figure : Repeating Source Group to Non—Repeating Target Element

During run time, the first generated XQuery for loop iterates
through the list of source repeating elements of type date.

If the constraint (date/tyoe = “BILLINGY) s true, then the
contents of the date 1ae element is returned as the contents
of the target PODate/billing-date element.

Source XML Data
(valid to the XML Schema in
Dates.xsd) Result XML Data
(valid to the XML Schema in PODate.xsd)

<?xml version="1.0" encoding="UTF-8"7>
<dates xmins="http://www.acme.org/Dates™>

<?xml version="1.0" encoding="UTF-8"?>

<date> <pod:PODate xmins:pod="http:/fwww.acme.org/PODate">
:%ﬁﬁ;f’%'s\ﬁ%:gfj:@ 1 » <pod:billing-date>03/29/2004</pod billing-date>
</date> ! ! I——> <pod:delivery-date>03/31/2004</pod:delivery-date>
! </pod:PODate>
<date>
<type>BILLING</type>
<value>03/29/2004</value>
</date>
</dates> During run time, the second generated XQuery £oxr loop iterates through the list
of source repeating elements of type date,
If the constraint (date/type = DELIVERY)Iis true, then the contents of the
date/wvalue element is returned as the contents of the target Pobate/
delivery-date element,

To Create and Run a Transformation Between a Repeating Source Group and a Non—Repeating Target
Element

1. Create a Transformation file and a method in the Transformation file. For instructions, see Creating ¢
Transformation File and a Transformation Method.

2. Import the XSD file that contains the XML Schema for the source type of the transformation. For
instructions, see Selecting Source and Target Types.

For this example, import the file: Dates.xsd. If you installed WebLogic Platform in the c:\bea
directory, import this file from the
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\repeatToSingle directory.

Note: The Dates.xsd file used in this example is identical to the Dates.xsd file used in Creating a
Transformation Between a Non—Repeating Source Element and Repeating Target Group. If you hav
already imported the Dates.xsd file for the Creating a Transformation Between a Non—-Repeating
Source Element and Repeating Target Group example, you do not need to import it again.

3. Import the XSD file that contains the XML Schema for the target type of the transformation. For
instructions, see Selecting Source and Target Types.
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For this example, import the file: PODate.xsd. If you installed WebLogic Platform in the c:\bea
directory, import this file from the
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\repeatToSingle directory.

Note: The PODate.xsd file used in this example is identical to the PODate.xsd file used in Creating a
Transformation Between a Non—Repeating Source Element and Repeating Target Group. If you hav
already imported the PODate.xsd file for the Creating a Transformation Between a Non—Repeating
Source Element and Repeating Target Group example, you do not need to import it again.

Importing schemas files triggers a build of the current Schemas project folder. Wait until the current
Schemas folder is built before proceeding to the next step. (The representations of the schemas will
not be available in Available Source Types and Available Target Type panes until build is
complete.)

4. Select the Transformation method from a Transformation file.
To select an existing method, in the Design View of the Transformation file:
a.Right—click the arrow representing the method.
b. From the drop—down menu, select Configure XQuery Transformation Method.
5. Select the source type for the transformation:
a.In the Available Source Types pane, expand the Dates.xsd folder.
b. In the Available Source Types pane, select the Dates.xsd/dates element.
c. Click Add.
The elements and attributes that make up the Dates.xsd/dates element are displayed in the Selectec
Source Types pane.
6. Select the target type for the transformation:
a.In the Available Target Types pane, expand the PODate.xsd folder.
b. In the Available Target Types pane, select the desired element.
For this example, select the PoDate.xsd/PODate element.
c. Click Add.

The elements and attributes that make up the PoDate.xsd/PODate element are displayed in
the Selected Target Type pane.

7. Click Create Transformation.
The Design View of the XQ file is displayed.

8. In the Source pane, select the repeating element (datesDoc/date) and drag it the first single element
(PODate/billing—date) in the Target pane.

Keep this link selected for the next step.
A dashed line linking the two elements is displayed. The dashed line with short dashes represents a

structural link a link that does not map data directly. The dashed-line representation for a structural
link is shown in the following figure.
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[ R
To learn more about links, see Link Representations.

9. In this step, you add a constraint to the structural link created in the preceding step:
a.From the Source pane select the datesDoc/date/type node and drop it into the Left Hand
Expression pane of the Where Clause Expression in the Constraints tab.
b. Select the operator: =.
c. In the Right Hand Expression pane of the Where Clause Expression in the Constraints
tab, enter the following string: "BILLING".

Warning: You must enter the quotes around the string.

d. Clicking Add.
During run time, the constraint created in this step, just tests if constraint: datesDoc/date/type is equi
to the string: "BILLING". The next step will add the XQuery code to the for loop to return data if
during run time the constraint is equal to true.

10.In the Source pane, select the datesDoc/date/value element and drag it the PODate/billing—date
element in the Target pane.

A data link is created.

During run time, this data link will return the value of datesDoc/date/value as the value of
billing—date if the constraint: data($date/ns0:type) = "BILLING" evaluates to true.

11.In the Source pane, select the repeating element (datesDoc/date) and drag it the second single
element (PODate/delivery—date) in the Target pane.

A dashed line linking the two elements is displayed.
Keep this link selected for the next step.

12.1n this step, you add a constraint to the structural link created in the preceding step:
a.From the Source pane select the datesDoc/date/type node and drop it into the Left Hand
Expression pane of the Where Clause Expression in the Constraints tab.
b. Select the operator: =.
c. In the Right Hand Expression pane of the Where Clause Expression in the Constraints
tab, enter the following string: "DELIVERY". The next step will add the XQuery code to
return data if during run time the constraint is equal to true.

Warning: You must enter the quotes around the string.
d. Clicking Add.
During run time, the constraint created in step, tests if datesDoc/date/type is equal to the string:

"DELIVERY™".

13.1In the Source pane, select the datesDoc/date/value element and drag it the PODate/delivery—date
element in the Target pane.

A data link is created.
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During run time, this data link will return the value of datesDoc/date/value as the delivery—date if the
constraint: data($date/ns0O:type) = "DELIVERY" evaluates to true.

14.Select the Test View tab.
15.Import XML files as source data for the transformation.

For this example, in the Source Data pane, select the $datesDoc node and import the file:
InputDates.xml. If you installed WebLogic Platform in the c:\bea directory, import this file from the
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\repeatToSingle\XML
directory.

Note: You can cut and past directory paths into the Name field of the Open File to Test pane to
jump to directory locations. If you installed WebLogic Platform in the c:\bea directory, you can jump
to the directory that contains the XML files for this example, by pasting the following directory path
into the Name field:
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\repeatToSingle\XML and then
pressing enter.

16.In the Result Data pane, click Test.

If not currently running, the WebLogic Server for the current application will be started. In order for
a query to run, the WebLogic Server for the current application must be running.

In the Result Data pane, a graphical representation of the target data is displayed.

17.1f the resulting data is XML data, in the Result Data pane you can view the resulting data as an XML
document by selecting the XML Source View tab. The XML result for this example is also displayed
in Figure: Repeating Source Group to Non—Repeating Target Element.

18.1f desired, you can validate the result data against the associated schema. In the Result Data pane c
the Test View, click Validate.

19. Save the DTF and the XQ file. From the menu bar, choose File > Save All.
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Using Recursive Schemas in Transformations

This example shows how to create mappings with schemas that have recursive elements. A recursive elem
contains a child element of the same type as the parent as shown in the following example XML Schema
listing:

<?xml version="1.0"?>

<xs:schema xmIns:xs="http://www.w3.0rg/2001/XMLSchema" targetNamespace="http://www.acme.org/Product"
xmlns="http://www.acme.org/Product" elementFormDefault="qualified" attributeFormDefault="unqualified">
<xs:complexType name="productType">
<xs:sequence>
<xs:element name="part—description" minOccurs="0" maxOccurs="unbounded" type="xs:string" />
<xs:element nahilg="product" minOccurs="0" maxOccurs="unbounded" type="productType" />
</xs:sequence>
</xs:complexType>
<xs:element name="product" type="productType">
</xs:element>
</xs:schema>

In this example, the product element is a recursive element because it is of type: productType and
productType contains a child—product element which is also of type productType (productType refers to
itself) as shown in bold in the preceding code listing.

Figure : Non—Recursive Source Elements to a Recursive Target Element

Source XML Data
(valid to the XML Schema in SupplierAcme.xsd)

<?xml version="1.0" encoding="UTF-8"7>

<supplier-acme xmins="http:/\www.acme.org/Partsinput"> /
<part-description-00100>Set of Honda Car Repair Manuals</part-description-00100> 1
<part-description-00101>Honda Accord 1992 Car Repair Manual</part-description-00101>
<part-description-00102>Fixing the Transmission of the Honda Accord 1992</part-description-00102>1

</supplier-acme>

Result XML Data
(valid to the XML Schema in Product.xsd)

<?xml version="1.0" encoding="UTF-8"?>
<prod:product xmins:;prod="http://www.acme.org/Product">
<prod:pari-description>Set of Honda Car Repair Manuals</prod:part-description=>

<prod:child-product>
<prod:part-description>Honda Accord 1992 Car Repair Manual</prod:part-description>
<prod:child-product>
<prod:part-description>Fixing the Transmission of the Honda Accord 1992</prod:part-description>
</prod:child-product>
</prod:child-product>
</prod:product>

To Create and Run a Transformation Between a Non—Recursive Source Elements and a Recursive Target
Element

1. Open a query in the mapper pane. For instructions see General Steps to Open or Create a Query in
the Mapper.
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For this example, import the files: SupplierAcme.xsd and Product.xsd files (step 2 in General Steps
to Open or Create a Query in the Mapper.) If you installed WebLogic Platform in the c:\bea directory,
import these files from the
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\recursive directory.

For this example, select and add the SupplierAcme.xsd/supplier—-acme node as an source type (stef
in General Steps to Open or Create a Query in the Mapper.)

For this example, select and add the Product.xsd/product node as an target type (step 4 in General
Steps to Open or Create a Query in the Mapper.)

2. Select the Design View.

The product node is displayed with one level of the recursive child—product node expanded as show
in the following figure.

Target
= [2)? product
O* part-description
= @* child-product
(* part-description
& child-product

3. In the Target pane of the Design View, expand the second level child—product node by
right—clicking the second-level or bottom child—product node and from the drop—down menu
selecting Expand Recursive Node.

Another child node appears under the second-level child—product node as shown in the following
figure.

Target
== ? product
(* part-description
= @* child-product
(9 * part-description

= ()™ child-product
(9 * part-description
(% child-product

4.1n the Design View, create a link by dragging—and—dropping the
supplier_acmeDoc/part—description—00100 Source element over the top-level
product/part—description Target node as shown in the following figure.

5.In the Design View, create a link by dragging—and—dropping the
supplier_acmeDoc/part—-description—00102 Source element over the second level
product/part—description Target node as shown in the following figure.

6. In the Design View, create a link by dragging—and—dropping the
supplier_acmeDoc/part—description—00103 Source element over the third level
product/part—description Target node as shown in the following figure.
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Source Target
=-fe ? supplier_acmeDoc =2 ? product
Q part-description-00100 - Q"} part-description
() part-description-00101 - - B (_)* child-product

() part-description-00102 - C)’fk part-description
= @ child-product
()% part-description

& * child-product

7.Select the Test View tab.
8. Import XML files as source data for the transformation.

For this example, in the Source Data pane, select the $supplier_acmeDoc node and import the file:
InputRecursive.xml. If you installed WebLogic Platform in the c:\bea directory, import this file from
the c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\recursive\XML directory.

Note: You can cut and past directory paths into the Name field of the Open File to Test pane to
jump to directory locations. If you installed WebLogic Platform in the c:\bea directory, you can jump
to the directory that contains the XML files for this example, by pasting the following directory path
into the Name field:
c:\bea\weblogic81\workshop\help\doc\en\integration\reffiles\transform\recursive\XML and then
pressing enter.

9. In the Result Data pane, click Test.

If not currently running, the WebLogic Server for the current application will be started. In order for
a query to run, the WebLogic Server for the current application must be running.

In the Result Data pane, a graphical representation of the target data is displayed.
10.If the resulting data is XML data, in the Result Data pane you can view the resulting data as an XML
document by selecting the XML Source View tab. The XML result for this example is also displayed

in Figure: Non—Recursive Source Elements to a Recursive Target Element.
11.Save the DTF and the XQ file. From the menu bar, choose File > Save All.
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Transforming Non—-XML Data

This section describes design—time and run—time steps required for creating and executing transformations
involving non—XML data sources. It also describes how to create schemas (MFL files) for non—XML data
using an included WebLogic Integration utility called Format Builder.

This section covers the following topics:

» Using Non—XML Data in Business Processes

» Using Format Builder to Create Format Schemas (MFL Files)

« Importing Existing Metadata to Create Format Schemas (MFL Files)
« Testing the Format Schemas (MFL Files)

Using Non—XML Data in Business Processes

Non—-XML data that is sent to or received from legacy applications is often platform—specific information
organized in a format unique to the machine on which the information originated. Non—XML data is not
self-describing, so to be understood by an application, information about the format (metadata) of this data
must be embedded within each application that uses non—XML data from a legacy application.

This section covers the following topics:

» Understanding Transformations That Use Non—-XML Data
» Using WebLogic Integration for Transforming Non—-XML Data

Understanding Transformations That Use Non—-XML Data

Data transformation is the mapping and conversion of data from one format to another. For example, data ir
non—XML format can be transformed to an XML format and the converse is also true, data in an XML forma
can be transformed to an non—-XML format. In order to transform data, you must create a schema which
contains a description (metadata) for each of the data fields in the non—XML data. During the transformatior
of data from a non—XML format to an XML format, each field of non—XML data is transformed to XML
according to the metadata defined for that field. The metadata you specify must include the name of the fielc
the data type, the size, and an indication of whether the field is always present or optional. This description
the non—-XML data is used to transform the data to XML, as shown in the following figure:

Non-XML Data XML Data

<?XML version="1.0"7>

Tom;Jones;1345;19; <Employee>

Transformation <FName>Tom</FName>

<LName>Jones</LName>
<EmpNum>1345</

Schema EmpNum>

(contains metadata <JobGrade>19</JobGrade>

for each of the non- </Employee>

XML data fields)

WebLogic Integration can also transform data from XML to non—-XML format, as shown in the following
figure:
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XML Data

<?XML version="1.0"7>
<Employee>
<FName>Tom</FName>
<LName>Jones</LName>
<EmpNum>1345</
EmpNum>
<JobGrade>19</JobGrade>
</Employee>

schema in MFL File /

(contains metadata
for each of the non-
XML data fields)

Non-XML Data

Transformetion Tom;Jones;1345;19;

WebLogic Integration can also transform data from one non—XML format to another non—-XML format, as
shown in the following figure:

Non-XML Data

Tom;Jones;1345;19;
Non-XML Data

e > Jones;Tom;19;1345;
schema in MFL File /
(contains metadata

for each of the non-
XML data fields)

Using WebLogic Integration for Transforming Non—-XML Data

WebLogic Integration facilitates the integration of data from diverse enterprise applications by supporting the
transformation of non—-XML legacy system data to other data types (XML and Java primitives). Once legacy
data is available as XML or a Java primitive, it can be used directly by WebLogic Integration business
processes. WebLogic Integration supports transformations with non—XML data using the following data

integration tools:
» Design—Time Component
¢ Format Builder

¢ WebLogic Workshop
* Run-Time Component

Steps 1-8 occur at design—time and step 9 occurs during run time, as shown in the following two figures.

The steps for an example non—XML to XML data transformation is shown in the following figure:
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WebLogic Integration Design Time Phase

Format Builder

® ® ®

WebLogic Integration
Run-Time Phase

Analyze non-XML Based on the analysis,

I
! I
| I
! I
' I
! I
| I
: I
. . | I
| data to determine the Format Builder |
create the schema usin | |
: schema (the metadata [ ™ Focrmat Builder. ;(," 9 creates an MFL | : |
I descnblfng each field appropriate, create the document. : | :
I of data.) schema using utilities that | MFL I.| Whenthe |
| create MFL from non-XML 1" | Document | ! business |
| sources, like COBOL [ | | processis |1
I copybooks.) lf/ i | runand the
| - - " | | method in the :
| T TTTT T T e T T | I Trans- |
I | I | formation file | |
1 @ ® || ©® @ | | NonXML | 1 oftre nodeis | |
| . 1| Daa | " invoked, the | !
|| Create an Import Create a Associate : | | data trans- :
I| application, [ the MFL [”| Adda [®] Transformation file, [ the method | | I | formation |,
Il project, and file into Client ... or | | a method in the file, with a Client | I oceurs. I
: workflow in the Control ... and a data ... or 1 : I
1| WebLogic project. node to the transformation in Control ... | | | |
L Workshop. workflow. the method. node. : I :
J [  _ |
: Y I
I Weblogic Workshop :
|
|

The steps for an example XML to non—XML transformation is shown in the following figure:
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WebLogic Integration Design Time Phase

Analyze non-XML
data to determine the
schema (the metadata
describing each field
of data.)

®

Based on the analysis,

create the schema using

Format Builder. (If
appropriate, create the

schema using utilities that
create MFL from non-XML
sources, like COBOL
copybooks.)

Format Builder
creates an MFL
document.

Format Builder

A

N

MFL
Document

WebLogic Integration
Run-Time Phase

XML
Document

Create an Import Create a Associate
application, [ the MFL Adda [®] Transformation file, [ the method
project, and file into Client ... or | | a method in the file, with a Client
workflow in the Control ... and a data ... 0r
WebLogic project. node to the transformation in Control ...

l\ Workshop. workflow. the method. node. J
' Y

: Weblogic Workshop

[

\
——————— o ————————— - —— o ——————————— —

When the
business
process is
run and the
method in the
Trans-
formation
control of the
node is
invoked, the
data trans-
formation

Steps 2-3 are done in the Format Builder tool and steps 4-8 are done in WebLogic Workshop.

Design—Time Component

Format Builder

A design—-time component of WebLogic Integration is a Java application called Format Builder. In the first
design—-time phase (steps 2-3 in preceding figures), you use the Format Builder to create descriptions of
non-XML data records. Specifically, you describe the layout and hierarchy of the non—XML data (the
schema) in the Format Builder so it can be transformed to or from other data sources, like XML.

You can describe sequences of bytes as fields and specify, for each field, the type of data (floating point,
string, and so on), the size of the data, and the name of the field. You can further define sets of fields (grour
multiple instances of fields and groups, and aggregation.

The description you create is saved in an XML grammar called Message Format Language (MFL). MFL
documents contain metadata that describes the structure of the non—-XML document. Once the non—-XML
document has been described via an MFL document, it can be used in XQuery data transformations just like
XML documents that have been described by XML Schema (XSD) files.

You can also use Format Builder to retrieve, validate, and edit stored MFL documents and to test message
format definitions with your own data. MFL documents are stored in the file system.

The test feature allows you to verify the MFL documents created in Format Builder by transforming a sample
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XML file to non—-XML format, or transforming a sample non—-XML file to XML format. You can save the
transformed data in a file for future testing.

Note: To learn more about using Format Builder, see Using Format Builder to Create Format Schemas (MF
Files).

WebLogic Workshop

In this second design-time phase, you use WebLogic Workshop to create an application, project, and
business process. For instructions on creating applications, projects, and business processes, see Creating
Business Process Application.

In order to map non—-XML data in a transformation, you must first import an MFL file which describes the
non-XML data into WebLogic Workshop. For instructions, see Selecting Source and Target Types.

You also use WebLogic Workshop to create a Transformation file, a method in the Transformation file, and :
Client or Control node in a business process. The method contains a transformation, which when invoked b
the business process during run time, maps data types. You design Control or Client nodes in your busines:
process to call a method in a Transformation file, as shown in steps 6—8 in the preceding figures.

The following table lists the Client or Control nodes that can be added to a business process:

* Client Request

* Client Response

» Control Send

» Control Send with Return
» Control Receive

For instructions on add Client and Control nodes to a business process with Transformations, see Interactin
With Clients and Interacting With Resources Using Controls, respectively.

Run-Time Component

If you design a Client and Control node to call a method in a Transformation file, during run time, the
business process invokes the node and then that node invokes the method that contains the transformation
example, a Client Receive node could receive non—XML data and pass that data to the transformation meth
which transforms the non—XML data to XML data, as shown in the following figure:

Client
non-XML data
__________________________________________ -
Business Proces I
# |
: Client Request Node SFensiomation e |
I non-XMU data |
| |
I ¢ '
1 method \ ! MFL
| (contains transformation) <+ — file
1 XML J |
| data |
| ) '
I |
|
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Using Format Builder to Create Format Schemas (MFL Files)

WebLogic Integration uses MFL files to represent the schemas of non—XML documents, just as XSD files
are used to represent the schemas of XML documents. At run—time WebLogic Integration uses these MFL
files to carry out transformation operations involving non—XML data. This section provides information about
creating these MFL files using Format Builder.

It includes the following topics:

» Understanding Data Formats
» Analyzing the Data to Be Transformed
» Using Format Builder

Understanding Data Formats

To understand how to use the Format Builder, it helps to understand the following format and document
types:

* Non—XML Data
* XML Documents
* MFL Documents

Non—-XML Data

Because computers are based on the binary numbering system, a binary format is often used in application:
represent data. A file stored in binary format can be read by a computer, but not necessarily by a human.
Binary formats are used for executable programs and numeric data; text formats are used for pure text. Mar
files contain a combination of binary and text formats. Non—XML data refers to both binary and text
formatted data.

Note: The term non—-XML data replaces the term Binary data that was used in previous versions of
WebLogic Integration. (WebLogic Integration 7.0 or earlier.)

Unlike XML data, non—XML data is not self-describing. In other words, non—XML data does not include a
description of how the data is grouped, divided into fields, or otherwise arranged. Non—-XML data is a
sequence of bytes that can be interpreted as an integer, a string, or a picture, depending on the intent of the
application that generates that sequence.

For example, consider the following non—XML data string:

2231987

You can interpreted it in many different ways. For example:

* As a date: 2/23/1987
» As a phone number (223-1987)

Without a clear understanding of the purpose of this data string, the application cannot interpret the string
appropriately.
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In order for non—XML data to be understood by an application, the layout of the data must be embedded in
the application itself. The character set used to encode the character data included in a non—XML file may
also vary. For example, character data on an IBM mainframe is usually encoded using the EBCDIC charact:
set, while data from a desktop computer is either ASCII or unicode.

You can use Format Builder to create a Message Format Language (MFL) file that describes the layout or
schema of your non—-XML data. MFL is an XML language that includes elements for describing each field of
data, as well as groupings of fields (groups), repetition, and aggregation. The hierarchy of a non—XML recor
the layout of fields, and the grouping of fields and groups are expressed in an MFL document. This MFL
document is used at run time to transform non—-XML data to and from an XML document.

Listing : Example of Non—XML Data

1234;88844321;SUP:21Sprockley's Sprockets01/15/2000123 Main St.;
Austin; TX;75222;555 State St.;Austin;TX;75222;P012345678;666123;150;
Red Sprocket;

XML Documents

The eXtensible Markup Language (XML) is the universal format for structured documents and data. Unlike
non-XML data, XML data is self-describing; it makes use of tags (words bracketed by '<' and '>') that signha
the start and end of each block of data. These tags define the hierarchy of related data components that
constitute the elements in a structured document.

The properties of XML make it suitable for representing and structuring data in a platform—neutral manner.
By making the structure explicit, XML can simplify the task of exchanging data between applications.
Because the data is presented in a standard form, applications on disparate systems can interpret it using X
parsing tools, instead of having to interpret data in proprietary binary formats.

The following listing shows an example XML document:

<?xml version="1.0"?>
<PurchaseRequest>
<PR_Number>1234</PR_Number>
<Supplier_ID>88844321</Supplier_ID>
<Supplier_Name>Sprockley&apos;s Sprockets</Supplier_Name>
<Requested_Delivery_Date>2000-01-15T00:00:00:000</Requested_Delivery_Date>
<Shipping_Address>
<Address>
<Street>123 Main St.</Street>
<City>Austin</City>
<State>TX</State>
<Zip>75222</Zip>
</Address>
</Shipping_Address>
</PurchaseRequest>

MFL Documents

A Message Format Language (MFL) document (also known simply as a message format document) is a
specialized XML document used to describe the layout of non—-XML data. When you use Format Builder to
define the hierarchy of a non—XML record, the layout of fields, and the grouping of fields and groups, the
information is saved as an MFL document that can then be used to perform run—time transformations. The
information captured in the MFL document can also be used to generate a DTD that describes the content
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model for the output generated by the MFL document.

The top-level element of a message format document is the MessageFormat element, which defines the
message format name and version. For example, the following is the root element of the sample po.mfl
document installed with WebLogic Integration:

<MessageFormat name='"PurchaseRequest' version="2.01">

WebLogic Integration supports Message Format Language Version 2.02. This version supports new feature
related to padding, truncation, and trimming. Message Format Language Version 2.01 is still supported.

The name assigned to the message format document becomes the root element in the XML instances that
generated based on the MFL document. For example, The following is the root element of any XML
document generated based on the sample po.mfl document:

<PurchaseRequest>
The other elements and attributes available in an MFL document are used to define the following:

« Fields and Field Formats — A field is a sequence of bytes that is meaningful in the context of an
application and that defines the format of a field. (For example, the field EMPNAME contains an
employee name.) You can define the following formatting parameters:

¢ Tagged - Indicates that a literal precedes the data field, denoting the beginning of the field.

¢ Length — Indicates that a numeric value precedes the data field, denoting the length of this
field.

¢ Occurrence - Indicates the number of times the field is shown in the message format. You
can specify the number of times the field is to be shown, or define a delimiter that indicates
the end of the repeating field.

¢ Optional - Indicates that the field may or may not be included in the format of the named
message.

¢ Code Page - Identifies the type of character encoding used for the data in the field.

Note: You must specify unique field names in a single MFL document. To learn more, see A
Note of Caution Must Specify Unique Field and Group Names in the Same MFL File.

» Groups and Group Formats — A group is a collection of fields, comments, and other groups or
references that are related in some way (for example, the fields PAYDATE, HOURS, and RATE
belong to the PAYINFO group). The parameters you can define for a group include:

¢ Tagged — Means that a literal precedes the other content of the group, which may be other
groups or fields.

¢ Occurrence - Indicates either the number of times the group is to be repeated in the messag
format, or a delimiter that marks the end of the repeated group. For more information about
delimiters, see Specifying Delimiters.

¢ Choice of Children — Indicates that only one item in the group will appear in the message
format.

¢ Optional - Indicates that the data in this structure may or may not be included in the named
message format.

Note: You must specify unique group names in a single MFL document. To learn more, see
A Note of Caution Must Specify Unique Field and Group Names in the Same MFL File.

Transforming Non—-XML Data 107



Guide to Data Transformation

» References and Reference Formats — A reference indicates that another instance of the field or grou
format exists in the data. The format of a reference field or group is the same as the format original
field or group, but you can change the optional setting and the occurrence setting for the reference
field or group. For example, if your data includes a bill to address and a ship to address and the sam
format is used for both addresses, you can create the address format once, and then reference it. Tf
is, you can create the an address definition for the bill to address and reference it for the ship to
address.

« Comments — Notes containing additional information about the message format.

Analyzing the Data to Be Transformed

Before a message format can be created, the layout of the non—XML data must be understood. Sample dat:
for a legacy purchase order, with corresponding MFL and XML documents for a purchase order record, are
installed with WebLogic Integration. The sample purchase order illustrates how WebLogic Integration
transforms data from one format to another.

For more information about this sample data, see Non—-XML Data Mapping Sample.

The key to transforming non—XML data to and from XML is to create an accurate description of it. For
non-XML data (data that is not self-describing), you must identify the following elements:

« Hierarchical groups

« Group attributes, such as name, optional, repeating, delimited

* Data fields

« Data field attributes, such as name, data type, length/termination, optional, repeating

Use Format Builder to incorporate these elements into the format definitions used for data transformations.

Using Format Builder
Format Builder helps you create format descriptions for non—-XML data and store them in MFL documents.
Your description should include hierarchical and structural information derived from a detailed analysis of
your data. These format descriptions are stored in an MFL document. You can also use Format Builder to te
your format descriptions before applying them to your data.
WebLogic Integration also provides utilities that allow you to import COBOL copybooks, import XML
Schemas, and convert C structure definitions into MFL files. To learn more about these utilities, see Importir
Existing Metadata to Create Format Schemas (MFL Files).
Starting Format Builder
You can launch Format Builder using one of the following options:

» To Start Format Builder From WebLogic Workshop

» To Start Format Builder on Windows Without Launching WebLogic Workshop

» To Start Format Builder on Linux Without Launching WebLogic Workshop
To Start Format Builder From WebLogic Workshop

1. Start WebLogic Workshop: choose Start > Programs > BEA WebLogic Platform 8.1 >
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WebLogic Workshop 8.1.
2. The main WebLogic Workshop window is displayed.

3. From the WebLogic Workshop menu bar, choose Tools > WebLogic Integration > Format
Builder.

The Format Builder main window is displayed.
To Start Format Builder on Windows Without Launching WebLogic Workshop

Choose Start > Programs > BEA WebLogic Platform 8.1 > Other Development Tools > Format
Builder.

The Format Builder main window is displayed.
To Start Format Builder on Linux Without Launching WebLogic Workshop

1. In command line shell, go to the WebLogic Integration bin directory. For example, if WebLogic

Platform is installed in the /usr2/bea directory, go to the /usr2/bea/weblogic81/integration/bin
directory as shown here:

cd /usr2/bea/weblogic81/integration/bin

2. Run the Format Builder start script, as shown here:

Jfb.sh
The Format Builder main window is displayed.

Using the Format Builder Window

The Format Builder window is split into two vertical panes. The left pane contains the navigation tree which

shows the structural relationship of the groups and fields defined in the active MFL document. The right pan
displays the properties that define the item.

Information about the file you are editing is displayed in the title bar of the Format Builder window.

T Format Builder - File[C:\schemas'StockQuotes.mfl] B : =10l x|
File Edit Insert View Tools Help
Bla|R|x|@|e|e] o|~] e|e|=z] t]|8]e|=]%]|=] &
Message Description
B2 PriceQuate ‘

] '-] StackSymbol NamelXML Root |StockPrices

- [_] StockPrice ||

ARl I fieset | Help |

The structure of the non—XML data is defined in the navigation tree through a combination of fields and
groups that match the target data.
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The following topics explain how to use the various tools provided in the Format Builder window to navigate
and execute commands:

 Using the Navigation Tree

 Using the Format Builder Menu Bar
* Using the Toolbar

 Using Drag and Drop

 Using the Shortcut Menus

Note: For additional information about Format Builder, see the help included with the Format Builder
executable. (To access the Format Builder help, start the Format Builder as described in Starting Format
Builder and then from the Format Builder menu bar, choose Help > Help Topics.)

Using the Navigation Tree

The navigation tree represents the structure of the non—XML data in a hierarchical layout. The root node of
the navigation tree, the Message node, corresponds to the MFL document being created or edited. Child no
are labeled with the names of groups or fields. Fields are represented by leaf nodes in the navigation tree.
Groups contain fields or other groups and are represented by non-leaf nodes in the navigation tree.

The icon for each node encapsulates the following information about the node: whether the node represents
message, a group, a field, a comment, or a reference; whether a group or field is repeating; whether a grouy
a Choice of Children; and whether a group or field is optional or mandatory.

You can add, delete, move, copy, or rename nodes in the navigation tree though menus or the toolbar. (For
details, see Using the Format Builder Menu Bar and Using the Toolbar.)

The following table describes the icons displayed in the navigation tree.

Tree

Icon Name Description
Icon
Message The top—level element.
Format

) Collections of fields, comments, and other groups or references that are related in
- Group some way. (For example, the fields PAYDATE, HOURS, and RATE belong tq the
PAYINFO group.) Defines the formatting for all items in the group.

! 8rp(';t)|;\a| A group that may or may not be included in the message format.
=] Repeating A group that is included one or more times.
Group
Optional : -
= : A group that may or may not be included, but if included, may occur more than
=i Repeating
once.
Group
Indicates the existence of another instance of the group in the data. The formgat of a
= Group . .
2] reference group is the same as that of the original group, but you can change| the
Reference . ) .
optional setting and the occurrence setting for the reference group.
=] Group Choice |Indicates that only one of the items in the group is included in the message fdrmat.
g  |Field
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Sequence of bytes that is meaningful in the context of the application and that
defines the formatting for the field. (For example, the field EMPNAME contains an
employee name.)

i Optional Field |A field that may or may not be included in the message format.
Y E;?;atmg A field is included one or more times.
i Optional A field that may or may not be included, but, if included, may occur more thar once
“““ Repeating Fiel@in the message format.
_ Field Indicates the existence of another instance of the field in the data. The formaf of a
L] reference field is the same as that of the original field, but you can change the
Reference ; . ; .
optional setting and the occurrence setting for the reference field.
Comment Contains notes about the message format or the data transformed by the message
format.
= Collapse A minus sign next to an item indicates that the specified item can be collapsef.
Expand ?hﬁlcﬁ ;rlrgljg next an item indicates that the specified item can be expanded to [show

Using the Format Builder Menu Bar
The menu bar provides quick access to Format Builder functions.

File Edit Insert View Tools Help

The items available in a menu depend on the actions you have taken and the node currently selected in the
navigation tree. If a menu item is not available, it is shown in gray in the menu.

You can display a menu in either of two ways:
* Click the name of the menu in the menu bar.
« On your keyboard, press Alt + key, where key is the first letter in the menu name. For example, pres

Alt + F to select the File menu option.

To execute a command, select it from the menu. Some commands can also be executed via the keyboard
shortcut indicated on the menu (For example, a Ctrl + key sequence.) The commands available on each me
are described in Format Builder Menus.

Using the Toolbar

The toolbar is a menu of icons that provide alternative ways to access frequently used commands.

El= EHEIDIDIRR R @@E Y @<: = @@

To execute a command, click the appropriate icon in the toolbar. If a command is unavailable, the icon for it
appears grayed-out.

The following table describes the icons in the Format Builder tool bar.

Toolbar Icon Name Description
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ects,

on

n be

field

field

tree.

[ee.

e. For

nd

B New Creates a new message format.
= Open Opens an existing message format.
= Save Saves the current message format.
Removes the item currently selected in the left pane, and its child obj
from the navigation tree. The item can be pasted elsewhere in the
% Cut navigation tree.
Note: This action is not available if the message format (root) item is
selected.
Makes a copy of the item currently selected in the left pane for insert
elsewhere in the navigation tree.
P Copy
Note: This action is not available if the message format (root) item is
selected.
B Paste as Sibling|Iinserts the cut or copied item as a sibling object of the selected item.
0 Paste as Inserts a reference to the cut or copied item as a sibling object of the
Reference selected item.
Reverses the previous action. The tool tip indicates the action that cg
undone. For example, if you change the name of a field to Address and
A Undo click Apply, the tool tip displays the following message: Undo Apply H
Address.
Format Builder supports multiple undoing of previous actions.
Reverses the effects of an Undo command. The tool tip indicates the
action that can be redone. For example, if you change the name of a
. Redo to Adglress and then Undo that chgnge, the Redo tool tip displays the
following message: Redo Apply Field Address.
Format Builder supports multiple redoing of previous actions.
¢ Insert Field Inserts a field as a sibling of the item selected in the navigation tree.
2 Insert Group Inserts a group as a sibling of the item selected in the navigation treg.
> Insert Comment|Inserts a comment as a sibling of the item selected in the navigation
T Move Up Moves the selected item up one position under its parent.
& Move Down Moves the selected item down one position under its parent.
Assigns the selected item to the next highest level in the navigation t
o Promote item |For example, suppose Fieldl is a child object of Groupl. If you selec
Field1l and click the Promote tool, you make Fieldl a sibling of Groug
Assigns the selected item to the next lower level in the navigation tre
= Demote item _examp!e, suppose Groupl_ is the siblling. of Fieldl and itis Iisteql
immediately after Groupl in the navigation tree. If you select Fieldl 3
click the Demote tool, you make Field11 a child of Groupl.
K Expand All Expands all the items in the navigation tree to show child items.
"= Collapse All Collapses the navigation tree to show first—level items only.
Format Tester |Opens the Format Tester window.
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Using the Shortcut Menus

When you right—click an item in the navigation tree, a menu of the most frequently used commands for that
item is displayed. The following table describes the commands that are available from the shortcut menus.

Note: The availability of a command depends on the item you select and the previous actions you have take

Command Description

Removes the item currently selected in the left pane, and its child objects, from the navigation
tree.

Makes a copy of the item currently selected in the left pane for insertion elsewhere in the

Cut

Copy navigation tree.

Inserts the cut or copied item. An additional menu is displayed when you select Paste. You can
Paste paste the item as either a child or a sibling of the selected item. In addition, you can paste a

reference to the cut or copied item as a sibling of the selected item.
Insert Inserts a new group as either a child or a sibling of the selected item, depending on your
Group specification.

. Inserts a new field as either a child or a sibling of the selected item, depending on your

Insert Field

specification.

Insert Inserts a comment as either a child or a sibling of the selected item, depending on your
Comment [specification.

Makes a copy of the currently selected item and pastes it as a sibling. The duplicate item
contains the same values and child objects as the original. The name of the duplicate ig the
same as that of the original, with the addition of a prefix: New. Thus, for example, if the hame
of the original item is MyGroup1, then the name of the duplicate is NewMyGroupl.

Delete Deletes the selected item.

Duplicate

Using Drag and Drop
You can drag and drop to copy and paste, or move items in the navigation tree.

Note: The node being copied or moved is always inserted as a sibling of the selected node during the
drag—and—-drop process. If you drag and drop the node onto the Message Format node, it is inserted as the
child.

To move an item:

1. Select the item you want to move.

2. Press and hold the left mouse button while you drag the item to the desired node.

3. When the item is in the desired location, release the left mouse button. The item is moved to the new
location.

To copy and paste an item:
1. Select the item you want to copy.
2. Press and hold the Ctrl key.

3. Keeping the Ctrl key depressed, press and hold the left mouse button while you drag the item to the
desired node.
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4. With the sibling object selected, release the left mouse button. A copy of the item is pasted the new
location.

Creating Message Formats

The first step in creating a message format definition file is to create a message format (the root node of a
message format file).

To create a message format:

1. Choose File > New. The detail window for the message format is displayed the right pane.

T Format Builder =)
File Edit Insert View Tools Help

Bla|R| x|e|e]e

Comment
NevwMessageFormat

| |

rMessage Descripton————

| NamefML Root | QERENESSET T

Anply I Reset I Help I

2. Enter the name of the message format in the Name/XML root field.

Note: The entry in the Name/XML Root field becomes the name of the root element of each XML
instance generated based on this message format document. Therefore, the entry must comply with
the conventions described in the following section, XML Element Naming Conventions.

3. Click one of the following:
¢ Apply updates the message format properties.

¢ Reset discards your changes to the detail window and resets all fields to the values that were
last applied.

¢ Help displays online help information for the message format detail window.

Note: The Apply and Reset options are enabled only after changes are made in the detail
window.

XML Element Naming Conventions

The names you assign to the root node, fields, groups, and references in a message format document are
transformed to XML element names in the XML instances generated based on the message format docume
Therefore, the names must comply with the following XML naming rules:

« A name must start with a letter or underscore.
« A name can contain letters, digits, periods, hyphens, or underscores.

The following strings are examples of valid names:

* MyField
* MyFieldl
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* MyField_again
* MyField—again

The following strings are examples of invalid names:

» 1MyField (starts with a digit)

» My>Field (includes a greater—than sign (>), which is an illegal character)
* My Field (includes a space, which is not permitted)

» My/Field (includes the back slash (/), which is an illegal character)

* My\Field (includes the forward slash (\), which is an illegal character)

» My:Field (includes a colon (:), which is an illegal character)

» My:Field (includes a semi—colon (;), which is an illegal character)

QUESTION FOR REVIEWERS: Added the preceding three bullets for doc impact of
http://radar.bea.com/netui/showcr.jsp?bugid=CR138600 Is it enough? Should | list more?

Creating Groups

A group is a collection of fields, comments, references, and other groups that are related in some way. For
example, the fields PAYDATE, HOURS, and RATE might all belong to the PAYINFO group. You can create
a group as a child of the message format item, as a child of another group, or as a sibling of a group or field

Note: You must specify unique field names in a single MFL document. To learn more, see A Note of
Caution Must Specify Unique Field and Group Names in the Same MFL File.

To create a group:

1. Select the an item in the navigation tree.
2. Choose one of the following:
¢ If the selected item is the root node, or another group, and you want to create the group as tr
child of the selected item, choose Insert > Group > As Child.
¢ If you want to create the group as a sibling the selected item, choose Insert > Group > As
Sibling.
The detail window for the group is displayed the right pane.
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Group Description

Name |Shipping_§\ddress

| [_] Optional

(® Dnce

[_] Choice Of Children

Group Occurrence

{_) Repeat Delimiter
() Repeat Field
{_) Repeat Number
) Unlimited

Group Attributes

[_] Group is Tagged

Group Delimiter

@ None Attributes
) Delimited
) Delimiter Field
Delimiter Is Shared
Apphy Duplicate Reset Help

3. Define the properties for the group as described in the following table:

Category

Property

Description

Name

The name of the group. The entry must
comply with the conventions described in
XML Element Naming Conventions.

Group Description |optional

Select Optional if the group is optional.

Choice of Children

Select Choice of Children if only one of th
items in the group will be included in the
message format.

D

Optional in the

Group Occurrence
(Unless defined as

Group Description,
all groups occur at

Once

Select this option to indicate that the grou
appears only once.

Repeat Delimiter

Select this option to indicate that the grou
will repeat until the specified delimiter is
encountered.

Select this option to indicate that the grou

=

will repeat an unlimited number of times.

Transforming Non—-XML Data

least once.) Repeat Field will rgpeat the number of times s_pecified i
the field selected as the repeat field.
Select this option to indicate that the grou
Repeat Number ) o .
will repeat the specified number of times.
Unlimited Select this option to indicate that the group
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Group Attributes

Group is Tagged

Select this option if the group is tagged, th
is, if a literal precedes the other content o
the group, which may be other groups or
fields.

The termination point of a group can be
specified by a delimiter: a string of
characters that marks the end of a group
fields. The group continues until delimiter
characters are encountered.

Note: Normally, groups are not delimited.
They are usually parsed by content; the
group ends when all child objects have bqg
parsed. For more information about
delimiters, see Specifying Delimiters.

Select from among the following options t
specify the group delimiter attributes:

None Select this option if there is no
delimiter for the group.

Group Delimiter

Select this option if the
termination point of the group i
marked with a delimiter
character string, then enter the
delimiter characters in the Valu
field.

Delimited

at

en

|=)

172

e

Select this option if the
termination point of the group i
marked by a field that contains
delimiter character string. Whe
you select this option, you are
prompted to provide the
following:

Delimiter

: Field select the field that
Field

contains the delimiter characte
string. A list of valid fields is
presented in a drop—down list.

Default enter the default
delimiter character used if the
selected field is not included in

172

=]

the data. This value is required.

Delimiter is Shared

Select this option to indicate th
the delimiter marks both the en
of the group of data, and the er
of the last field of the group. Th
delimiter is shared by the group

and the last field of the group, 110
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indicate the end of the data.

4. Click one of the following:
¢ Apply updates the group properties.
¢ Duplicate makes a copy of the group currently displayed and pastes it as a sibling.

The duplicate group contains the same values and child objects as the original. The name of
the duplicate is the same as that of the original, with the addition of a prefix: New. Thus, for
example, if the name of the original group is MyGroupl, then the name of the duplicate is
NewMyGroupl.

¢ Reset discards your changes to the detail window and resets all fields to the values that were
last applied.
¢ Help displays online help information for the detail window.

Note: The Apply and Reset options are enabled only after changes are made in the detail
window.

Specifying Delimiters

You can specify delimiters in Format Builder by entering the correct syntax. For example, if you want to
specify a tab character as a delimiter (\u009'), you must enter the construct \t to match it.

The following tables maps characters you can use as delimiters to the constructs you must use to designate
these characters as delimiters.

Use this construct . . .| To designate the following character as a delimiter . . .
X X
\\ \ (backlash)
\On Character with octal value On (<=n<=7)
\Onn Character with octal value Onn (0 <=n<=7)
\Omnn Character with octal value Omnn (0 <=m<=3,0<=n<=7
\xhh Character with hexadecimal value Oxhh
\uhhhh Character with hexadecimal value Oxhhhh
\t Tab character ("\u0009")
\n Newline (line feed) character (\uOOOA")
\r Carriage-return character (\u0O00D")
\f Form—feed character (\u000C")
\a Alert (bell) character (\u0007")
\e Escape character (\u0O01B")
\CX Control character corresponding to x

To learn more, see the java.util.regex.Pattern class decription.
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Creating Fields

A field is a sequence of bytes that is meaningful to an application. (For example, the field EMPNAME
contains an employee name.) You can create a field as a child of the message format node, as a child of a
group, or as a sibling of a group or another field. Field names are used as element names in the XML outpu
they must comply with the conventions described in XML Element Naming Conventions.

To create a field:

1. Select an item in the navigation tree.
2. Choose one of the following:

¢ If you want to create the field as the child of the selected item, choose Insert > Field > As
Child.

¢ If you want to create the field as the sibling of the selected item choose Insert > Field >
As Sibling.
The detail window for the field is displayed the right pane.

Field Description

Name |PR_Number | [C] Optional

Type | String v |

Field Occurrence
{®) Once
{_) Repeat Delimiter
{_) Repeat Field
{_) Repeat Number
) Unlimited

Field Attributes

[_] Field is Tagged [_] Field Default Yalue
Termination

(@) Length Attributes

() Imbedded Length [ Length | Trim [Pad | Truncate

) Delimiter Value I

() Delimiter Field

Code Page | windows-1252 - Windows Latin-1 v

Apphy Duplicate Reset Help

3. Define the properties for the field as described in the following table:

Category Property Description
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Field Description

Name

The name of the field. The entry must comply w
the conventions described in XML Element
Naming Conventions and A Note of Caution Mu
Specify Unique Field and Group Names in the
Same MFL File.

ith

Optional

Select this option if this is an optional field.
Optional means that the data for the field may oj
may not be present.

If the Optional option is selected for a file, then
you must also set the Field is Tagged option fro
the Field Attributes pane. In addition, in the Fiel
Is Tagged text box enter a unique value for eac
optional field in a group. Multiple groups can us
the same tag value but the tag value for each
optional field in a group must be unique.

Added for CR126076

—

m

1Y " I =

Type

Select the data type of the field from the
drop—down list. The default is String.

Note: Which field type you select dictates which
field data options are displayed.

For a list of data types supported by WebLogic

Integration, see the online help of Format Builder.

Field Occurrence

(Unless defined as
Optional in the Field

at least once.)

Once

Select this option to indicate that the field appes
only once.

irs

Repeat Delimiter

Select this option to indicate that the field will
repeat until the specified delimiter is encountere

d.

Description, all fields occy

r
Repeat Field

Select this option to indicate that the field will
repeat the number of times specified in the field
selected as the repeat field.

Repeat Number

Select this option to indicate that the field will
repeat the specified number of times.

Unlimited

Select this option to indicate that thg¢
field will repeat an unlimited numbef

of times.

1%

Field Attributes

(The Field Attributes
properties that are

6%he

Field is Tagged

Transfoﬁﬁl%llg‘il/)(\‘:r\éjnalr)(?l\?ftllf3 é][dent on

pe specified in
Field Description)

Select this option if the field is tagged, that is, if
literal proceeds the data, indicating that the data
present. You must also choose the data type of
tag field from the drop—down list. For example if
the following:

SUP:ACME INC

SUP: is a tag and ACME INC is the field data.

a
1S

the
I
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If you select the Field is Tagged option, enter th
tag in the field to the right of the check box.

Field Default
Value

Select this option to specify a value for the data
field that is inserted into the non—XML data if thg
field is not included in the XML.

If the field is not included in the non—-XML data
and it is not optional, then the non—XML data fa
to parse, even if a default value is given.

Data Base Type

If the field is a date or time field, the base type

or Numeric) used to represent the data.

Year Cutoff

If the field is a date field with a 2-digit year, the
year cutoff attribute allows the 2—digit year to be
converted to a 4-digit year. If the 2-digit year is|
greater than or equal to the year cutoff value, a
prefix of 19 is added to the year value. Otherwis
prefix of 20 is used.

Code Page

The character encoding of the field data. The
default code page is set by choosing Tools >
Options and selecting the default encoding from
Default Field Code Page drop down list.

Value

The value displayed in a literal field.

Field Attributes
(Continued)

Transforming Non—-XML Data

Termination

Select from among the following options to sped
the group delimiter attributes:

Length Select this option to set the
length of variable-sized data

select this option, you are
prompted to provide the
following:

Length enter the number of
bytes in the field.

Trim Leading/Trailing removes
the specified data from the
leading or trailing edge of the
data.

Pad if the XML data is shorter
than the specified length,

appends the specified data to
correct its length. Select one o
the following padding options:

¢ Select the Trailing
option to append
padding at the end of a

1%

indicates the type of characters (ASCIl, EBCDIC

D

n

S

€ea

types to a fixed value. When you
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field.
¢ Select the Leading
option to append
padding at the beginnin
of a field.
Truncate remove a specified
number of characters from a
field. Select any combination o

the following truncation options:

¢ Select the Truncate Fir
option to remove the
specified number of
characters from the
beginning of the field.
¢ Select the Truncate
After option to remove
the specified number of
characters from the end
of the field.
If you select both truncation
options, the Truncate First opti
is implemented initially, and thg
Truncate After option is invoke
on the remaining characters.

f

O P

Field Attributes
(Continued)

Transforming Non—-XML Data

Embedded
Length

Termination
(Continued)

Select this option to indicate th
the termination point of a
variable-sized data type is
specified by an embedded leng
An embedded length precedeg
the data field and indicates the
number of bytes in the data.
When you select this option, yq
are prompted to provide the
following:

+ Type specifies the data]
type and, if necessary,
the length or delimiter
for termination.

¢ Tag/Length
Order specifies the
order of the tag and
length fields when both
are included. The defay
order is: tag, length.

¢ Trim
Leading/Trailing remov
the specified data from
the leading or trailing

at

jth.
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edge of the data.

¢ Truncate remove a
specified number of
characters from a field.
For more information,
see the description of tk
Truncate option for the
Length option.

Delimiter

Select this option to indicate th
the termination point of a
variable-sized data type is
specified by a delimiter: a valug
that marks the end of the field.
The field data continues until tk
delimiter is encountered. Wher
you select this option, you are
prompted to provide the
following:

¢ Value enter the
delimiter that marks the
end of the field data.

¢ Trim
Leading/Trailing remov
the specified data from
the leading or trailing
edge of the data.

¢ Truncate remove a
specified number of
characters from a field.
For more information,
see the description of tf
Truncate option for the
Length option.

ne

at

1%

e

ne

Field Attributes
(Continued)

Transforming Non—-XML Data

Termination
(Continued)

Delimiter Field

Select this option if the
termination point of a
variable-sized data type is
specified by a field that contain
a delimiter value. When you
select this option, you are
prompted to provide the
following:

+ Field select the field
that contains the
delimiter.

+ Default enter a default
delimiter that can be
used when the delimite
field is not present. You
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must enter a value in this
field.
¢ Trim
Leading/Trailing removes
the specified data from
the leading or trailing
edge of the data.
¢ Truncate remove a

specified number of
characters from a field.
For more information,
see the description of the
Truncate option for the
Length option.

For more information about

delimiters, see Specifying

Delimiters.

Specifies the number of digits

Decimal Position(0-16) to the left of the decimal

point.

4. Click one of the following:
¢ Apply updates the field properties.
¢ Duplicate makes a copy of the field currently displayed and pastes it as a sibling.

The duplicate field contains the same values as the original. The name of the duplicate is the
same as that of the original, with the addition of a prefix: New. Thus, for example, if the name
of the original field is MyField1, then the name of the duplicate is NewMyField1.

¢ Reset discards your changes to the detail window and resets all fields to the values that were
last applied.
¢ Help displays online help information for the field detail window.

Note: The Apply and Reset options are enabled only after changes are made in the detail
window.

Padding Mandatory Fields

Prior to the WebLogic Integration 7.0 release, no padding was performed on mandatory fields when data for
the field did not exist at run time. For the WebLogic Integration 7.0 release and all subsequent releases, dur
an XML to non—XML transformation, a mandatory field that does not contain data is padded with the default
value, if a default value has been specified. If no default value is specified and a field does not contain data
transformation time, an error occurs.

Note: Padding of mandatory fields is not supported for non—XML to XML transformations.
This feature is useful when a group is specified multiple times, but data is provided for only one occurrence.

When padding of mandatory fields is invoked, all occurrences of a group for which data are not provided are
padded with default values, if specified.
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A Note of Caution Must Specify Unique Field and Group Names in the Same MFL File
| added in this section for the bug:

http://radar.beasys.com/netui/showbug.jsp?bugid=40197 | Format Builder does not enforce unique field
names; duplicates can result in WLW compilation failure

Xiaomin said this note should remain in.

You must specify unique field (FieldFormat) and group (StructFormat) format names in a single MFL file.
Format Builder allows the creation of duplicate field and group format names in the same MFL file but when
an MFL file with duplicate names is imported into WebLogic Workshop causing the schemas project is built,
errors will be reported, as shown in the following examples.

If the following example MFL file is imported into WebLogic Workshop, the build of the schema project
fails because the field name: StockSymbol is used in two different groups:

<?xml version='1.0" encoding="windows-1252'?>
<IDOCTYPE MessageFormat SYSTEM 'mfl.dtd'>
<MessageFormat name='StockPrices' version="2.01'>
<StructFormat name='PriceQuoteOne' repeat="*'>
<FieldFormat n&@teskSymbol' type='String' delim="" codepage='windows—-1252'/>
<FieldFormat name='StockPrice' type='String' delim='|' codepage='windows-1252'/>
</StructFormat>
<StructFormat name="'PriceQuoteTwo' repeat="*">
<FieldFormat n&teskSymbol' type='String' delim="" codepage='windows—1252'/>
<FieldFormat name='StockPrice' type='String' delim='|' codepage="windows-1252'/>
</StructFormat>
</MessageFormat>

The following schema build error is reported:

ERROR: Error compiling MFL file —C:\bea\weblogic81\DTGuide\Schemas\StockQuotesSameStructFormat.mfl:
FieldFormat already defined: StockSymbol

If the following example MFL file is imported into WebLogic Workshop, the build of the schema project
fails because the group name: PriceQuote is used twice, even though the first PriceQuote is nested in the
group: Level:

<?xml version="1.0" encoding="windows-1252'?>
<IDOCTYPE MessageFormat SYSTEM 'mfl.dtd">
<MessageFormat name='StockPrices' version="2.01'>
<StructFormat name=Level' repeat="*">
<StructFormat naPnieeQuote' repeat="*">
<FieldFormat name='StockSymbol' type='String' delim="" codepage="windows-1252'/>
<FieldFormat name='StockPrice' type='String' delim='|' codepage="windows—-1252'/>
</StructFormat>
</StructFormat>
<StructFormat name='PriceQuote' repeat="">
<FieldFormat name='StockSymbol' type='String' delim="" codepage="'windows-1252'/>
<FieldFormat name='StockPrice' type='String' delim='|' codepage='windows-1252'/>
</StructFormat>
</MessageFormat>

The following schema build error is reported:
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ERROR: Error compiling MFL file — C:\bea\weblogic81\DTGuide\Schemas\StockQuotesSameNamelnDiffGroup.mfl:
StructFormat already defined: PriceQuote

Note: You can, however, use the same field and group names in different MFL files because the file name o
the MFL document becomes the namespace for the field or group format names in WebLogic Workshop,
making the field and group format names unique from file to file. For example, the StockPrice field in the
Stock.mfl file is prefixed with the namespace:Stocks making it unique from the StockPrice field in the
Price.mfl file which is prefixed with the namespace: Price.

Creating Comments

Comments are notes about the message format or the data transformed by the message format. Comments
included in the message format definition for documentation and informational purposes only; they are
unnumbered and are not transformed to XML or non—XML data. You can create a comment as a child or
sibling of any message format, group, or field.

Note: Conventionally, a comment precedes the node it annotates.
To create a comment:

1. Select an item in the navigation tree.
2.Choose one of the following:
¢ If you want to create the comment as the child of the selected item, choose Insert >
Comment > As Child.
¢ If you want to create the comment as the sibling of the selected item, choose Insert >
Comment > As Sibling.
3. Enter the comment text in the Comment Details field.

Comment Details

KYZ Corporation legacy Purchase Request Form

Apply Reset Help

4. Click one of the following:
¢ Apply updates the comment text.
¢ Reset discards your changes to the detail window and resets all fields to the values that were
last applied.
¢ Help displays online help information for the comment detail window.

Note: The Apply and Reset options are enabled only after changes are made in the detail
window.
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Creating References

References allow you to reuse an existing field or group format in a new context. When you create a
reference to an existing field or group, the same format is used, but you can modify the optional and
occurrence properties for the reference field or group.

For example, if your data includes a bill to address and a ship to address and the same format is used for b
addresses, you can create the address format once, and then reference it. That is, you can create the an ad
definition for the bill to address and reference it for the ship to address.

Note: A reference item is given exactly the same name as the original item, therefore, you should use a
generic name, such as address, when you create a field or group that is be referenced. For instance, in the
previous example, you can create an address group as a child of the bill_to group and then reference the
address group from within the ship_to group.

To create a reference:

1. Select the item to be referenced in the navigation tree.

2.Choose Edit > Copy.

3. Select an item at the desired location for the reference. When you paste the item as a reference in tt
next step, the reference is pasted as a sibling of the selected item.

4.Choose Edit > Paste > As Reference.

The detail window for the reference is displayed. For example, the following figure shows the detalil
window for a Field Reference:

Field Reference Description
Name [_] Optional
Field Reference Occurence
® Once
_) Repeat Delimiter
_) Repeat Field
) Repeat Number

) Unlimited

Edit Reference Help

5. Define the properties for the reference as described in the following table:

Category Property Description

Name The name off
the field or
Field or Group Reference Description group for
which you
created this
reference.
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This value
cannot be
changed.

Optional

Select this
option if the
reference is
optional.

Field or Group Reference Occurrence

(Unless defined as Optional all referenced items occur at least
once.)

Once

Select this
option to
indicate that
the
referenced
item appears
only once.

Repeat Delimite

Select this
option to
indicate that
the
referenced
item will
repeat until
the specified
delimiter is
encountered

Repeat Field

Select this
option to
indicate that
the
referenced
item will
repeat the
number of
times
specified in
the field
selected as
the repeat
field.

Repeat Number

Select this
option to
indicate that
the
referenced
item will
repeat the
specified
number of

times.

Unlimited
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Select this option to
indicate that the
referenced item will
repeat an unlimited
number of times.

6. Click one of the following:
¢ Apply updates the reference properties.

¢ Reset discards your changes to the detail window and resets all fields to the values that were
last applied.

¢ Edit Reference displays the detail window for the original item to allow you to edit the item.
¢ Help displays online help information for the reference detail window.

Note: The Apply and Reset options are enabled only after changes are made in the detail
window.

Working with the Palette

The Format Builder palette allows you to store commonly used message format components so they are
available whenever you need to insert them into your message format definitions.

The default palette, palette.xml, is an MFL document which is stored in the WebLogic Integration installatior
directory. The default palette contains common date formats, literals, and strings. You can use these items i
the message formats you create, as well as add your own items to the default palette. You can also create
own MFL documents for use in the palette, or open and use items from any existing MFL document.

The following topics provide the information you need to use the palette:
* Opening the Palette
 Using the Palette File Menu
 Using the Palette Shortcut Menu
» Copying Items From the Active Message Format to the Palette

* Deleting Items From the Palette
« Copying Palette Items from the Palette to the Active Message Format

Opening the Palette
To open the palette:

1. Start Format Builder.
2.Choose View > Show Palette.

The Palette window displays the default palette.
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File
PredefinedNodes
L'_I Dates

] Literals

] strings

You can copy items from the navigation tree to the palette, and vice versa. You can use drag and drop, or tt
commands available on the shortcut menu, to organize items in the palette. The contents of the palette are
automatically saved when you exit Format Builder.

Note: Only copying items, whether from the navigation tree to the palette or vice versa, is allowed. You
cannot move items between the windows.

Using the Palette File Menu

The commands described in the following table are available from the Palette File menu.

Command Description

Displays the Open dialog box to allow you to select and open an existing MFL document in the
palette.

Save Saves any changes you have made to the MFL document currently open in the palette.
Hide Palette|Closes the Palette window.

Open

Using the Palette Shortcut Menu

A shortcut menu is displayed when you right—click an item or folder in the palette. The following table
describes the commands available from the shortcut menu.

Note: Some commands may be unavailable, depending on the item you select.

Command Description

Inserts a new folder. When you select this command, you are prompted to supply the name of
the folder.

Rename |Renames a folder. When you select this command, you are prompted to supply the new|name.
Delete Deletes the selected item.
Move Up |Moves the selected item up one position under its parent.

Move
Down

Insert

Moves the selected item down one position under its parent.

Assigns the selected item to the next level up in the hierarchy. For example, suppose Fi¢ld1 is
Promote |child of Groupl. If you select Field1 and click the Promote tool, then Field1l becomes a sjbling
of Group1.

Demote  |Assigns the selected item to the next lower level in the hierarchy. When you demote an item, it
becomes a child of the sibling that immediately precedes it. For example, suppose Fieldl is a
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sibling of Groupl, and that it and immediately follows Groupl. If you select Field1 and click the
Demote tool, Fieldl becomes a child of Groupl.

Copying Items From the Active Message Format to the Palette

To copy an item from the document currently open in Format Builder to the palette:
1.If it is not already displayed, choose View > Show Palette.
2. In the navigation tree, select the item you want to add to the palette.
3. Drag the item to palette window, then drop it in the desired location in the hierarchy.
The item is copied to the selected location.
Note: You cannot add an item that depends on the existence of another item to the palette. For
example, you cannot add a field or group reference, and you cannot add an item for which a Repeat

Field is specified.

Adding comments is possible, but not recommended because comments do not have unique names and
therefore are indistinguishable on the palette.

Deleting Items From the Palette
To delete an item from the palette:

1. Right—click the item to be deleted to display the shortcut menu.
2. Select Delete.

You are prompted to confirm the deletion.
3. Click OK to delete the item.
Copying Palette Items from the Palette to the Active Message Format
To copy an item from the palette to a message format document currently open in Format Builder:
1.If it is not already displayed, choose View > Show Palette to display the palette.
2.In the palette window, select the item you want to add to your message format.
3. Drag the item to navigation tree, then drop it in the desired location in the hierarchy.
The item is copied to the selected location in the message format.
Saving a Message Format
You can either save your MFL files directly into a Schemas folder in the file system or you can save the MFI
file to the file system and later import the MFL file into a Schemas folder as described in the preceding
bullets:
* You can save MFL files directly into a Schemas project folder in the file system. For example, if
your application saved in the c:\bea\weblogic81\apps\myApp directory contains the default Schemas

project, you can save the MFL file directly into this c:\bea\weblogic81\apps\myApp\Schemas
directory in the file system.
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* You can save a message format document to your file system as described in this section and later
when creating a transformation, you import this MFL file into a Schemas folder of a business proces:
application. To learn more, see Importing Schemas.

To save a message format file for the first time:

1.In the Format builder menu bar, choose File > Save As.

The Save As dialog box is displayed as shown in the following figure:

Look in: Ipo v @ @ @ oo .

File name: | | Save As

Files of tyne: | MFL Files (*.mfl) v| | cancel

2. Navigate to the folder in which you want to save the file.
3. Enter the name you want to assign to the file in the File Name field.

Note: If you do not include an extension in your filename, Format Builder automatically assigns the
default extension:.mfl.

4. Click Save As to save the file in the specified location with the specified name and extension.
To save changes to an existing file, choose File > Save.

To save an existing file to a new name, choose File > Save As and follow steps 2 through 4 in the precedin
procedure.

Opening an Existing Message Format File
You can open a message format document on your file system as described in the this section.
To open an existing message format file:

1. In the Format Builder menu bar, choose File > Open.

The Open dialog box is displayed as shown in the following figure:
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Look in: ] wixft1.0

v

= (@] (o] s

UninstallerData
1 apidoc

I doc

help

1 samples

File name: |

| | Open

Files of type:

MFL Files (*.mfl)

v | Cancel

2. Locate and select the desired file.

3. Click Open.

Using Internationalizatio

n Features

You can use the internationalization features in Format Builder by changing the options for an individual
message file or by setting the default Format Builder options to include internationalization. For details, see:

» Changing Options for a Message Format
* Setting Format Builder Options

Changing Options for a Message Format

To change options for a message format file:

1. Select the root node of the message format in the navigation tree.
2.Choose File > Properties.

The File Properties dialog box displays the Message Format Version and the Default Message
Format (MFL) Encoding.

T File Properties

Message Format Yersion I2.01 v I

i~ Character Encoding Options

This dialog allowws you to set options for the current MFL document.
Use the Tools -= Options menu to set defaults for the application.

X

iDefault Message Format (MFL) Encoding

OK I Cancel |
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3. Select a type of character encoding for the MFL document from the list of encoding names and
descriptions for this file. (To change the default settings for all new message format documents,

choose Tools > Options.)
4. Click OK.

Your changes are reflected in the MFL document when you test it using Format Tester.

Setting Format Builder Options

You can set several options to control the overall operation of Format Builder.

To set Format Builder options:

1. Choose Tools > Options.

The Options dialog box is displayed.

T Format Builder Options x|
Default Message Format Version | 2.01 v
Character Encoding Options
Default Message Format (MFL) Encoding
| v
Default Field Code Page
| v
XML Formatting Options

Initial Indent
New Line Indent

XML Content Model Options

[_] Auto-generate DTD

o

EoN

| OK || Cancel

2. Enter data in the fields as described in the following table:

Category Option

Description

Default Message

N/A Format Version

Select the version to be associated with new MFL docume

own message format version. The version specified for a
message format can be changed from the default from the
Properties dialog box described in the preceding section
Changing Options for a Message Format..

Note: Each message format document is associated with its

nts.

File

Character Default Message
Encoding Format (MFL)
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Options Encoding document specifies the encoding used for the MFL documeént
itself, and the XML output it generates.
Default Field Code[Select the code page, from the list of non—-XML formats, to|be
Page used as the default code page for each field created in your
MFL documents. A code page specifies the character encqding
of the non—XML data in the field.

Enter the number of spaces by which to indent the root element

XML . Initial Indent when generating the XML output.
rormatting h ber of by which to ind hild
Options New Line Indent Enter the number of spaces by which to indent a new chi

element when generating the XML output.

Generates a DTD document which captures the content mpdel
XML Content |Auto—generate defined in the MFL document. If you specify Auto—generate
Model OptiongDTD DTD, when you save an MFL document to the file system, [the
DTD is saved in the same directory.

3. Click one of the following:
¢ OK saves your changes and dismisses the dialog box.
¢ Cancel discards your changes and dismisses the dialog box.
Format Builder Menus
The following menus are available in Format Builder: File, Edit, Insert, View, Tools, and Help.

The commands available on each menu are described in the following sections.

Note: Some commands may be unavailable, depending on which actions you have taken and what is select
in the navigation tree.

File Menu

The following commands are available from the File menu.

Command Description
New Creates a new message format document.

Open Opens an existing message format document.
Close Closes the current message format document.
Save Saves the current message format document.

Save As [Saves the current message format under a different name.

Opens the File Properties dialog box for the active message format document. This dialdg
allows you to set options for the active MFL document (see Changing Options for a Message

Properties Format). Choose Tools > Option to set defaults for the application (see Setting Format Builder
Options).
Exit Exits the Format Builder.
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The following commands are available from the Edit menu.

Command

Description

Reverses the previous action. The Undo command on the Edit menu is constantly refreshed to
indicate the action most recently performed that can be nullified. For example, if you change the

Undo name of a field to Field1 and click Apply, the listing for the Undo command contains the
action following text: Undo Apply Field Fieldl.
Format Builder supports multiple undoing of previous actions.
Reverses the effects of the Undo command. The Redo command in the Edit menu is copstantly
refreshed to indicate the action that can be redone. For example, if you change the name of a
Redo field to Field1 and then click Undo, the listing for the Redo command contains the following
action text: Redo Apply Field Fieldl.
Format Builder supports multiple redoing of actions previously undone.
Removes the selected item along with its child objects. The item is placed in the clipboard and
can be pasted in a new location.
Cut
Note: This action is not available if the Message Format (root) item is selected.
Makes a copy of the selected item along with its child objects. The copy is placed in the
clipboard and can be pasted in a new location.
Copy
Note: This action is not available if the Message Format (root) item is selected.
Inserts the current contents of the clipboard. When you select Paste, the following Paste menu
options are displayed:
Paste « As Child
 As Sibling
* As Reference
Makes a copy of the currently selected item and pastes it as a sibling. The duplicate item
Dublicate contains the same values and child objects as the original. The name of the duplicate is the san
P as that of the original, with the addition of a prefix: New. Thus, for example, if the name of the
original item is MyField1, then the name of the duplicate is NewMyFieldl.
Delete Deletes the item selected in the navigation tree, as well as all child objects of that item.
Move Up |Moves the selected item up one position under its parent.
II\DA(CJ)\\//V?] Moves the selected item down one position under its parent.
Assigns the selected item to the next level up in the hierarchy. For example, suppose Fi¢ld1 is
Promote [child of Groupl. If you select Field1l and select Promote, then Fieldl becomes a sibling of
Groupl and is inserted immediately after Groupl.
Assigns the selected item to the next lower level in the hierarchy. When you demote an item, it
Demote becomes a child of the group that immediately precedes it. For example, suppose Field] is a

sibling of Groupl and immediately follows Groupl. If you select Field1l and select Demote,
Fieldl becomes a child of Groupl.
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in the

Insert Menu
The following commands are available from the Insert menu.
Command Description
Field Inserts a new field. You can insert the field as either a child or sibling of the item selected
navigation tree.
Grou Inserts a new group. You can insert the group as either a child or sibling of the item sele¢ted in
P the navigation tree.
Inserts a comment. You can insert the comment as either a child or sibling of the item sejected
Comment |. L
in the navigation tree.
View Menu

The following commands are available from the View menu.

Command

Description

Show PalettgDisplays the Palette window.

Expand All

Tools Menu

The following commands are available from the Tools menu.

Command

Description

Import

Displays a list of the installed importers. Choose the importer from which you want to imf
message.

Test

Opens the Format Tester.

Options

Displays the Format Builder Options dialog box.

Help Menu

The following commands are available from the Help menu.

Command Description

Help Topics Displays the online help in your default browser.

How Do |

Displays a list of common Format Builder tasks. Click a task to view the step—by-
instructions.

About

Displays version and copyright information for the Format Builder and the JDK ydg

running.
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Importing Existing Metadata to Create Format Schemas (MFL
Files)

WebLogic Integration provides utilities that allow you to import COBOL copybooks, import XML Schemas,
and convert C structure definitions into MFL files. The following topics explain how to perform these import
operations:

* Importing a COBOL Copybook
 Importing C Structures

Importing a COBOL Copybook
WebLogic Integration includes a feature that allows you to import a COBOL copybook into Format Builder
by creating a message definition to transform the COBOL data. When importing a copybook, you can use
comments to document the imported copybook and the Groups and Fields it contains.
To import a COBOL copybook:

1.Choose Tools > Import > COBOL Copybook Importer.

The COBOL Copybook Importer dialog box is displayed.

File Name: | | Browse ...
Data Properties
Byte Order Character Set
(@ Big Endian ) EBCDIC
() Little Endian (@ US-ascCH
) Other
Cancel About

2. Designate the properties, as described in the following table:

Property Value Description
Type the full pathname of the file you want to
File Name text string |import or use the Browse button to navigate to the

location of the file.
Select this option for IBM 370, Motorola, and mogt
Big Endian [RISC designs (IBM mainframes and most UNIX
platforms).

Byte Order : ; :
Little Select this option for Intel, VAX, and Unisys
Endian processors (Windows, VMS, Digital, UNIX, and
Unisys)
Character Set EBCDIC
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Note: The character set is an Select this option to set the character set to
attribute of the originating host EBCDIC.
machine. Select this option to set the character set to
US=ASCIl 15s-ascil.
Other Select character encoding of the field data by us|ng
a list of code pages.

3. Click one of the following:
¢ OK imports the COBOL Copybook using the settings you defined.
¢ Cancel closes the dialog box and returns you to Format Builder without importing.
¢ About displays information about the COBOL Copybook importer, including the version
being used and copybook features that are supported.

After you import a copybook, you can work in the same way you work with any message format definition. If
you find an error or unsupported data type in the copybook, a message is displayed, informing you of the
error. You can choose to have the error displayed or saved in a log file for future reference.

The following table provides a listing and descriptions of the sample files installed for the COBOL copybook
importer. All directory names are relative; the specified directories are under the
WL_HOME\integration\samples\di directory where WL_HOME is the top-level directory of your WebLogic
Platform installation. (For example, if you installed WebLogic Platform in the c:\bea directory, the di
directory is located at the following location: c:\bea\weblogic81\integration\samples\di.)

Directory File Description
COBOL\ |emprec5.cpy|Sample copybook file
COBOL\ |emprec5.datalest data corresponding to emprec5.cpy

Importing C Structures

WebLogic Integration includes a C struct importer utility that converts a C struct definition into an MFL
message definition by generating the following types of output data:

* MFL document
* C code

Whichever type of output you want, you must first specify a .c or .h input file, which must be parsed, and
then select the desired structure. Then you can choose between MFL (default) or C code for your output.

All input to the parser must be valid C code. In addition, all external references, such as #include, #define,
and typedef statements, must be resolved before you can use them. You can resolve them by editing them
manually or by using the compiler's preprocessor.

Various platform—-specific parameters may affect the description of data for C code. For example, the length
of a long on a particular platform affects the non—XML data that conforms to a particular structure definition.

Two methods are available for dealing with these platform dependencies, depending on whether or not MFL

is generated directly into Format Builder. If you want to generate MFL and have that MFL displayed
immediately in Format Builder, you must supply the platform—dependent parameters in a configuration file.
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Alternately, if you choose to generate your source in C, you may compile the C code on the desired machin
The compiler on that machine accounts for the necessary platform—-dependent information. This approach
allows you to produce an executable file that, when run, produces two files: an MFL document and non—-XM
data that conforms to that MFL. The MFL document can be opened in Format Builder and the non—-XML dat
file can be opened in Format Tester.

Generating MFL directly into Format Builder requires platform configuration parameters found in an existing
configuration file or a new configuration file created with the hardware profile editor. The hardware profile
editor allows you to specify an existing profile that can be loaded, updated, and saved.

The source code for a utility that generates hardware profiles according to your needs is provided in the
WL_HOME\integration\samples\di\CFG directory where WL_HOME is the top—level directory of your
WebLogic Platform installation. (For example, if you installed WebLogic Platform in the c:\bea directory, the
cfg directory is located at the following location: c:\bea\weblogic81\integration\samples\di\CFG.)

Sample C Struct Importer Files

The following table provides a listing and descriptions of the sample files installed for the C struct importer.
All directory names are relative; the specified directories are under WL_HOME\integration\samples\di
directory where WL_HOME is the top—-level directory of your WebLogic Platform installation. (For example,
if you installed WebLogic Platform in the c:\bea directory, the di directory is located at the following location:
c:\bea\weblogic81\integration\samples\di.)

Directory File Description

C emprec5.h |C version of the emprec5.cpy sample Copybook file, with some typedefs.
Variant of the emprec5.h file in which a nested struct definition, but no typedef is

C emprec5n.h
used.

C emprec5s.h [Simple version of the emprec5.h file.

C ntfsez.h Small sample, extracted from the ntfs.h file, designed to test recursive typedefs.

Cfg cprofile.c Source code for the cprofile.c utility; designed to generate profiles on various
platforms.

The following .cfg files were generated by the cprofile program on various platforms. Each .cfg file contains
a value for DESCRIPTION.

Cfg dec8cc.cfg |DEC Alpha 1091, Digital UNIX 4.0e, cc compiler

Cfg hp5cc.cfg |HP-UX B.11.00, cc compiler

Cfg ntdbccb.cfg (Windows NT 4.0, Borland 5.x compiler, default switches
Cfg ntdvc6.cfg [Windows NT 4.0, Visual C++ 6.x compiler, default switches
Cfg sun7cc.cfg |SunOS 5.8, cc compiler

Cfg w95bcc5.cfg|Windows 95, Borland 5.x compiler, default alignment

Cfg w95vch.cfg |Windows 95, Visual C++ 5.x compiler, default alignment

Starting the C Struct Importer
To start the C Struct Importer:

1. Start Format Builder. For instructions, see Starting Format Builder.
2.Choose Tools > Import > C Struct Importer.
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The C Struct Importer dialog box is displayed.

T C Struct Importer E3
Input
Input File: " | Browse...
Structure | v |
Output
(® MFL Hardware Profile
() C Code Name | | Browse..

New ...

The C Struct Importer dialog box allows you to specify import properties, as described in the

following table:

Note: Initially, MFL is specified as the default output type.

Category Property

Description

Input File

Type the full pathname of the file you want to import or use the
Browse button to navigate to the location of the file.

Input Structure

Drop—down list of structures found in the input file after parsing

successful.

S

Parse

Select this option to parse the input file. If successful, the Strugture

list box is populated with the list of structures found in the input file.

Output

MFL

If you select this option, you can generate MFL from a structure
definition and a hardware configuration file. The Hardware Profil
dialog box is displayed with the following options.

+ Name Specify an existing profile either by entering the fjle

name or using the Browse option. The prebuilt hardwar
profiles may be found in the samples\di\cfg directory.
¢ Save saves the current hardware profile.

+ Save As allows you to save the current hardware profile

under another name.
+ Edit allows you to edit the current hardware profile.
+ New allows you to create a new hardware profile.

U

C Code

Transforming Non—-XML Data

If you select this option, you can generate C source code to co
on the target machine and execute to produce MFL. The C Co

141

mpile
e File




Guide to Data Transformation

Names dialog box is displayed with the following options.

¢+ MFL Gen specifies the C source code file name that muyst
be compiled on the target machine to generate MFL. Use the
Browse option to navigate to the directory where you want
the file to reside.

¢ Data Gen specifies the C source code file name that muyst
be compiled on the target machine for generating test data.
Use the Browse option to navigate to the directory whelfe
you want the file to reside.

3. Click one of the following:
¢ OK saves your hardware profile changes.
¢ Cancel dismisses your hardware profile changes.
¢ About displays information about the C Struct Importer, including the version number and
the release date.

Understanding Hardware Profiles

The hardware profiles used by the C Struct Importer contain data size and alignment information for specific
hardware and compiler combinations and are used to generate MFL for C structures. They are stored in
configuration files that can be created, loaded, updated, and saved.

The cprofile.c source file in the WL_HOME\integration\samples\di\CFG directory is used to generate these
profiles for any platform. This code is designed to be compiled and executed on the target platform with the
compiler normally used. You should be able to compile and execute it on any platform with an ANSI standar
C compiler in order to generate a profile configuration file that can be imported into the C Struct Importer.
(Where WL_HOME is the top—level directory of your WebLogic Platform installation. For example, if you
installed WebLogic Platform in the c:\bea directory, the CFG directory is located at the following location:
c:\bea\weblogic81\integration\samples\di\CFG.)

Building the Hardware Profile Utility
To produce acceptable parser input, execute the appropriate commands for your platform:
* On Windows NT, use the VC++ preprocessor:

VC++ Compiler
cl /P cprofile.c (output in cprofile.i)

GNU Compiler
gcc —P —E cprofile.c>cprofile.i

¢ On UNIX
cc —P cprofile.c (output in cprofile.i)
Running the Hardware Profile Utility

To execute the cprofile program and specify a hardware profile name, enter the following text at a commanc
prompt:
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cprofile configfilename [DESCRIPTION]

A description is optional. If you decide to provide one, put it in the configuration file as the value of
DESCRIPTION. If the description contains embedded blanks, enclose it in quotes.

Generating MFL
To generate MFL:

1. Enter a filename in the Input File field, or click Browse and select a file from the list that is
displayed.
2. Click Parse to parse the file.

Upon completion, the Structure list is populated with the structures found in the input file.
Note: If your file does not parse correctly, we recommend that you proceed in one of two ways:

3. Run your .h or .c source code through the compiler, preprocessor, and then run the processor outpu
through the parser.

4. Comment out the character creating the parsing failure and attempt to parse again. Please note that
the parser fails at the first instance of incompatible data it encounters. Therefore, repetition of this ste
may be required.

3. Select the desired structure from the Structure drop—down list.

At this point, you must provide some profile configuration data to generate the MFL directly. You
can do this by either creating a new hardware profile or specifying an existing profile.

4. Specify an existing profile or create a new one by performing one of the following procedures:
¢ Specify an existing profile in one of the following ways: enter the filename in the Hardware
Profile Name field, or click Browse to select a file from the list that is displayed.

Click Edit to open the hardware profile editor if you need to view or edit the profile
parameters.

Note: Hardware profiles for common configurations are prebuilt and may be found in the
WL_HOME\integration\samples\di\CFG directory. (Where WL_HOME is the top-level
directory of your WebLogic Platform installation. For example, if you installed WebLogic
Platform in the c:\bea directory, the CFG directory is located at the following location:
c:\bea\weblogic81\integration\samples\di\CFG.)

¢ Click New to create a new hardware profile. The Hardware Profile editor is displayed with

the default parameters loaded. Specify a name and description for the new profile, and modif
the primitive data types and byte order as required.
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@C Struct Importer Hardware Profile [ X]

Profile Name: [defaulti |

Description: WMVIN32 - VC++ B, NT 4.%

Primitive Data Types

Size Alighment Size Alighment
short 2 v| |2 v| longlong  |undef ¥/ [undef |
short int |2 v | |2 v | __int 64 |8 v | |8 v |
int 4 v| |4 v|  double '8 v| |8 v |
long int |4 v| |4 'l long double |8 'l |8 v|
float 4 v |a |  woid 4 > |4 v|
long 4 v| |4 v|  unsigned |4 v| |4 v |
Byte Order

{®) Little Endian {_) Big Endian

5. Click OK to save your hardware profile changes and return to the C Struct Importer dialog box.

6. Click OK to generate your MFL. If the generation is successful, you are returned to Format Builder
with an MFL object listed in the navigation tree. The MFL object reflects the same name as the input
file used in the parse operation.

If errors are detected during the generation process, the MFL Generation Errors dialog box is
displayed providing you with an opportunity to view or file the error log.

T MFL Generation Errors [ X|

MFL generation errors
Errors occured in the MFL generation for struct NTFS_RECORD_HEADER
using configuration file D:'heawlxt2.0'samples\CFGhp5cc.cfg

Display Error Log Save Error Log Cancel
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7. Click one of the following:
¢ Display Error Log to view any errors encountered,
¢ Save Error Log to save the error log to the location of your choice, or
¢ Cancel to dismiss the MFL Generation Errors dialog box.

After you determine which errors were generated, you can return to the C Struct Importer and repeat the
applicable steps.

Generating C Code
To generate C code:

1. Enter a filename in the Input File field, or click Browse and select a file from the list that is
displayed.

2. Click Parse to parse the file.

Upon completion, the Structure list is populated with the structures found in the input file.
Note: If your file does not parse correctly, we recommend that you proceed in one of two ways:

3. Run your .h or .c source code through the compiler, preprocessor, and then run the processor outpu
through the parser.

4. Comment out the character creating the parsing failure and attempt to parse again. Please note that
the parser fails at the first instance of incompatible data it encounters. Therefore, repetition of this ste
may be required.

3. Select the desired structure from the Structure drop—down list.

4. Select the C Code option.

5. Enter a filename in either the MFL Gen or Data Gen field, or click Browse and select a file from the
list that is displayed.

6. Click OK.

Messages are displayed if you are about to overwrite an existing file or if the code generation has
succeeded or failed.

7. Copy the generated source code to the target platform, compile and execute it.

Note: You must copy the input file containing the struct declarations, as well. When compiled, both
programs accept the name of the output file as an argument.

8. Copy the generated MFL or data back to the platform on which Format Builder is running.
Importing an XML Schema
WebLogic Integration includes a feature that allows you to import an XML Schema into Format Builder. The
imported XML Schema provides a starting point for creating the MFL message definitions used for
transforming data between XML and non—-XML formats.

To import a XML Schema from an XSD file:

1. Choose Tools > Import > XML Schema Importer.
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The Select XSD File & Root Element dialog box is displayed.
2.In the XML Schema Definition field, select an XSD file (ends in the .xsd extension.)
3. In the Root Element drop—down menu, select a root element.
4. Enter a value in the MFL Field Delimiter Default field.
A delimiter is a character that marks the end of the data field.

5. Click OK.

Note: Imported Element attributes are not converted.

Testing the Format Schemas (MFL Files)

After you build a format schema, you can test it using the Format Tester. The Format Tester parses and
reformats data as a validation test and then generates sample non—XML or XML data. This sample data car
be edited, searched, and debugged to produce the expected results. Format Tester uses the data transform
run—time engine to perform the test transformation.
This section discusses the following topics:

« Starting the Format Tester

» Using the Format Tester Dialog Box

 Testing Format Definitions
» Debugging Format Definitions

Starting the Format Tester
To start Format Tester:

1. Start Format Builder is not already running. For instructions, see Starting Format Builder.
2.Choose Tools > Test.

The Format Tester dialog box is displayed as shown in the following figure:
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The Format Tester dialog box is divided into three windows: the Non—-XML window, the XML
window, and the Debug window. Resize bars divide the windows. You can drag the resize bar to
adjust window size, or click an arrow on the bar to show or hide a window. For example, you can
click the left arrow on the bar dividing the Non—-XML and XML windows to hide the Non—-XML
window. If a window is hidden, you can drag the bar or click the appropriate arrow to restore the
window.

Note: When you open the Format Tester for the first time in a session, only the Non—-XML and
XML windows are visible. To open the Debug window, use the resize bar at the bottom of the
Format Test dialog box, or choose Display > Debug to toggle the Debug window on and off.

Using the Format Tester Dialog Box

The following topics explain how to use various tools provided in the Format Tester dialog box to navigate
and execute commands:

 Using the Non—-XML Window
* Using the XML Window

* Using the Debug Window

* Using the Resize Bars
 Using the Menu Bar

 Using the Shortcut Menus

The following topics explain how to use each of these features to help you accomplish your task.
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Using the Non—XML Window

The Non—-XML window can contain sample data that has been:
* Generated based on the active MFL document.
* Transformed from the contents of the XML window.

« Specifically designed to test the active MFL document.

You can open an existing non—XML data file, edit or save the contents of the window, or clear the window a
required for your test situation. For details, see Using the Menu Bar and Using the Shortcut Menus.

The Non—-XML window of the Format Tester dialog box serves as a non—XML file editor. The window
contains the following tabs:

» Hex displays data offsets, the hex value of individual bytes, and the corresponding text, which can
be displayed in either ASCII or EBCDIC format.
» Text Text only display.

The editor allows you to edit a hex byte or a text value. If a hex data value is modified, the corresponding te
value is updated, and vice versa.

Using the Data Offset Feature

The data offset feature of the Hex tab allows you to display the data offsets as hexadecimal or decimal
addresses.

To change the format of the data offsets:
1. Choose Display > Hex.
The following two data offset options are displayed:
¢ Offsets as Hexadecimal
¢ Offsets as Decimal
2. Select an option that best suits your needs. The data offset portion of the Non—XML window
changes dynamically to reflect your choice.
Using the Text Feature
The Text tab of the Non—-XML window displays the printable characters (usually in the form of words and
numbers) and certain control characters (carriage return, tab, and so on). For example, carriage returns are
shown as line breaks. Non—printable characters, are displayed as small squares.
Using the XML Window
The XML window can contain sample XML that has been:
» Generated based on the active MFL document.

 Transformed from the contents of the Non—-XML window.
« Specifically designed to test the active MFL document.
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You can open an existing XML file, edit or save the contents of the window, or clear the window as required
for your test situation. For details, see Using the Menu Bar and Using the Shortcut Menus.

When XML is generated, the XML Formatting Options specified in the Format Builder options dialog box
are used. For additional information, see Setting Format Builder Options.

Using the Debug Window

The Debug window displays the actions that occur during a transformation, any errors that are encountered,
and field and group values, along with delimiters. To determine the cause of an error, identify the last field
that parsed successfully and examine the properties of the field listed after it in the navigation tree.

When you open the Format Tester for the first time in a session, only the Non—XML and XML windows are
visible. To open the Debug window, choose Display > Debug to toggle the Debug window on and off. The

Debug window opens below the Non—-XML and XML windows.

Debug output is restricted to the most recent 64 KB of messages. This restriction prevents large debug outp
from causing a JVM out of memory event.

The debug log feature allows you to save all debugging information in a file. For details, see Using the DebL
Log.

Note: Use of the Debug window or log file increases the time required to transform from XML to non—-XML.
Using the Resize Bars

You can change the dimensions of any window in the Format Tester by using the resize bars located betwe
the Non—-XML, XML, and Debug windows. To change the size of a window, select a resize bar and drag in
the appropriate direction (up or down or to the left or right) to enlarge one of the windows and reduce the

other.

Each resize bar also contains two directional buttons. Click the appropriate button to show or hide any of the
three windows.

Using the Menu Bar

Format Tester functions can be accessed from the five menus listed in the menu bar at the top of the main
window.

File Edit Display Generate Transform
You can expand a Format Tester menu in either of two ways:

* Click the name of the menu in the menu bar.
* On your keyboard, press Alt + key, where key is the underlined letter in the menu name.

To execute a command, select it from the menu. Some commands can also be executed via the keyboard

shortcut indicated on the menu (For example, a Ctrl + key sequence.) The commands available on each me
are described in the following sections.
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The following commands are available from the File menu.

Command Description
Displays the Open dialog box to allow you to select and open a file in the Non—XML
Open window.
Non—-XML
Note: The default file extension for non—XML files is .DATA.
Displays the Open dialog box to allow you to select and open a file in the XML wind
Open XML

Note: The default file extension for XML files is .XML.

Save Non—XML |Displays the Save dialog box to allow you to save the contents of the Non—XML window.
Save XML Displays the Save dialog box to allow you to save the contents of the XML window.
Debug Log Displays the Save dialog box to allow you to save the debugging information in a tejt file.
Close Closes the Format Tester window.
Edit Menu
The following commands are available from the Edit menu.
Command Description
Cut Removes the currently selected text and places it on the clipboard for pasting in another
location.
Copies the currently selected text and places it on the clipboard for pasting in another
Copy )
location.
Paste Inserts the cut or copied text at the cursor location.
Allows you to search for a hex or text value. This command applies to the content of the
: Non-XML window only.
Find
Note: The text search is case sensitive.
: Repeats the last Find from the current cursor position. This command applies to the
Find Next .
content of the Non—XML window only.
GoTo Allows you to move the cursor to a specified byte offset in the Non—-XML window.
Display Menu
The following commands are available from the Display menu.
Command Description
Check to display the XML window, uncheck to hide the window. When
XML check box unchecked, the Non—-XML window expands to fill the Format Tester dialog

box.

Debug check box

Check to display the Debug window, uncheck to hide the window.
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Clear > Non—-XML Clears the contents of the Non—-XML window.

Clear > XML Clears the contents of the XML window.

Clear > Debug Clears the contents of the Debug window.

Hex > Offsets as Displays the offset values as hexadecimal. Mutually exclusive with the Hex >

Hexadecimal option button|Offsets as Decimal option.

Hex > Offsets as Decimal [Displays the offset values as decimal. Mutually exclusive with the Hex >
option button Offsets as Hexadecimal option.

Generate Menu

The following commands are available from the Generate menu.

Command Description
Non—-XML Generates non—-XML data to match the MFL document specification.
XML Generates XML data to match the MFL document specification.

If checked, you are prompted to specify the following during the
generation process:

Prompt while generating data » Whether or not to include optional fields or groups in the

check box output.

» Which choice of children to include in the output.

» The number of times to include repeating fields or groups in the
output.

Transform Menu

The following commands are available from the Transform menu.

Command Description
Non-XML to [Based on the MFL document specification, converts the contents of the Non—-XML
XML window to XML. The XML output is displayed in the XML window.
XML to Based on the MFL document specification, converts the contents of the XML window to
Non-XML non—-XML data. The non—XML output is displayed in the Non—-XML window.

Using the Shortcut Menus

When you right—click in the Non—-XML, XML, or Debug window, a menu of the most frequently used
commands for that window is displayed. The following table describes the commands that are available fron
the shortcut menus.

Command Description
Cut Rem_oves the currently selected text and places it on the clipboard for pasting in another
location.
Copy g(;giieosnthe currently selected text and places it in the clipboard for pasting in another
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Paste Inserts the cut or copied text at the cursor location.
Clear Clears the contents of the Non—XML, XML, or Debug window.
Generate Generates non—-XML or XML data to match the MFL document specification. This
command is only available on the Non—-XML and XML shortcut menus.
Converts the contents of the Non—XML window to XML. This command is only available
To XML
on the Non—-XML shortcut menu.
Converts the contents of the XML window to non—XML. This command is only availaljle on
To Non—-XML
the XML shortcut menu.
Text in ASCII Changes the character set used for the text displayed in the text portion of the Hex tab to
ASCII.
Text in Changes the character set used for the text displayed in the text portion of the Hex tab to
EBCDIC EBCDIC.

Testing Format Definitions
To test a message format definition:

1. Start Format Builder.

2.0pen a Message Format file.

3. Start Format Tester.

4.Choose File > Open Non—-XML, or File > Open XML to load the file you want to transform and

view, or enter your own data in one of the two data windows.

5. Choose Display > Debug if you want to view the actions that take place during the transformation
operation. This step is optional. If you want to be able to view debugging information later, you must
open the Debug window before starting the transformation operation.

6. Choose Transform > Non—-XML to XML, or Transform > XML to Non—XML to transform

your data to the appropriate format.

The transformed data is displayed in the Non—-XML or XML window as shown in the following
figure:
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/3 Format Tester B =10/

File Edit Display Generate Transform

~ Mon-xXML :—XML

00000[31 32 33 34 35 36 37 38 123456'.i| ?xml version="1.0" encoding="UTF-8"2> 4
0000839 3b 31 32 33 34 35 36 9;1234% < PurchaseRedquest>

00010[37 38 39 3b 30 38 2f 31 | [789;08, <PR_Number>123456789</PR_Number>
0001830 2f 32 30 30 31 53 74 | |0/2001¢ <Supplier ID>123456789</Supplier I
00020[72 65 65 74 3b 43 69 74 | |reet;Ci <Requested_Delivery Date>03/08/200
000Z8|79 3b 53 74 61 74 65 3b | [y;State <Shipping Address>

00030[31 32 33 34 35 36 37 38 | |123456% <hddresss

00038[39 3b 53 74 72 65 65 74 | |9;8trec™ <Street>Street</Streets

g | B e Atres
<City>City</City>

Current Offset: 0 (0x0) <State>State</State> -
Hex | Text] Rl| | L|J

P

— Debug

Processing xml and mfl nodes PurchaseRequest
Processing xml node PR_Number

L« 12

7. Correct any errors and test the transformation again.
8. Repeat steps 6 and 7 until the transformation is successful.

Note: You can leave Format Tester open while you modify the message format document in Format Builder
Changes to the document are detected automatically by Format Tester.

Debugging Format Definitions
The following topics explain how to use three Format Tester features to debug and correct your data:
» Searching for Values
* Positioning to an Offset
* Using the Debug Log
Searching for Values
The Find command allows you to search for hex or text values in the non—XML data.
To search for a hex or text value:
1.In the Format Tester dialog box, choose File > Non—-XML to open the non—XML data file you

want to search.
2.Choose Edit > Find to open the Find dialog box.
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Find What: Direction: From:
e || * Forwards ¢ Beginning of File
" Backwards || { Current Position
" Text ( Hex )
" End of File
OK Cancel |

3. Enter the target of the search in the Value field.

4. Select the Text or Hex option button to specify the value type.

5. Select the Forwards or Backwards option button to specify the search direction.

6. Select the Beginning of File, Current Position, or End of File option button to specify the search
starting position.

7. Click OK to dismiss the Find dialog box and execute the specified search.

If the value is found, the cursor moves the location of the value. If the value is not found, the
following message is displayed: The specified search string was not found.

8. To repeat the search from the current cursor position, choose Edit > Find Next.
Positioning to an Offset
The Go To command allows you to move the cursor to a specified hexidecimal or decimal address (offset).

To move to a specified offset:

1.In the Format Tester dialog box, choose Edit > Go To to display the Go To dialog box.

. Bytes to Move: | Direction: 1 From:
Offset: | ® Forwards (@ Beginning of File
) Backwards | (_ Current Position

® Dec (' Hex I
i) End of File

OK Cancel

2. Enter the target offset in the Offset field.

3. Select the Dec or Hex option button to specify the type of offset.

4. Select the Forwards or Backwards option button to specify the direction.

5. Select the Beginning of File, Current Position, or End of File option button to specify the starting
position.

6. Click OK to dismiss the dialog box and move the cursor to the specified offset.

Using the Debug Log

Although debugging information is not saved by default, the Format Tester dialog box allows you to specify
a debug log file. When you specify a debug log file, all debugging information generated during your testing
session is appended to the specified file.
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To specify a debug log file:
1.In the Format Tester dialog box, choose the File > Debug Log to display the Save dialog box.

Note: The Debug Log check box on the File menu is toggled upon selection. If the check box is
checked, choosing File > Debug Log turns off logging to the file.

2. Select the desired directory, and then do one of the following:
¢ To create a new log file, enter the name in the File name field and then click Save.

¢ To use an existing log file, select the file and then click Save.
If you select an existing file, the new debug information is appended to the end of the existing file.
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In WebLogic Workshop business processes, XML data can be transformed using either XQuery expression:
or eXtensible Stylesheet Language Transformations (XSLTs). An XQuery expression or query, is written in
the XQuery language a language defined by the World Wide Web Consortium (W3C) that provides a vendol
independent language for the query and retrieval of XML data. An XSLT is written in the eXtensible
Stylesheet Language (XSL) an older language defined by the W3C that supports the use of stylesheets for t
conversion of XML data.

To learn about XSLT, see the XSL Transformations (XLST) Version 1.0-W3C Recommendation 16
November 1999 at the web site of the W3C at the following URL:

http://www.w3.org/TR/xslt

The XSLT processor which is invoked by the transformation conforms to the November 16, 2002
Recommendation of the XSLT Specification.

WebLogic Workshop provides functionality for executing existing XSLTs in business processes. However, ir
WebLogic Workshop, the preferred method for data transformations is to use queries in the XQuery languac
To learn more about adding queries to your business process, see Transforming Data Using XQuery. Data
transformation using XSLT is supported primarily for customers who have upgraded from prior versions of
WebLogic Integration and wish to continue using their XSLT-based maps without modification.

This section contains the following tasks:

e To Import an Existing XSLT file
» To Add a Data Transformation to a Business Process Using an XSLT

To Import an Existing XSLT file
This task describes how to import an XSLT file into your project.
1. In the Application tab, right—click any project folder (project folder names end with the string: Web)
or product subfolder. (If the Application tab is not visible in WebLogic Workshop, choose View >

Application from the menu bar.)

Warning: Do not import the XSLT file into a Schemas project folder. (To learn more, see a Creating
Schemas Projects.)

2. From the drop—down menu, select Import... .
The Import Files dialog box is displayed.

3. Browse the file system, select your XLST file (files that end with the .xsl extension), and click
Import.

The XSLT file is imported into the project.

To Add a Data Transformation to a Business Process Using an XSLT
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1. Select or create a Transformation file (also know as a DTF file because it ends in the .dtf extension).
(For instructions on creating a Transformation file see Creating a Transformation File and a
Transformation Method.

In the Application tab, expand the folders that contain the Transformation file. (If the Application
tab is not visible in WebLogic Workshop, choose View > Application from the menu bar.)

2. Select or create a Transformation method in a Transformation file. (For instructions on creating a
method in a Transformation file, see Creating a Transformation File and a Transformation Method.)

In the Design View, right—click the arrow representing the method.
3. From the drop—down menu, select Configure XSLT Transformation Method.
The Configure XSLT Transformation Method dialog box is displayed.

4. From the XSLT Transformation File drop—down menu, select the appropriate XSLT file.
5. 1f your XSLT accepts parameters, add parameters to the Transformation method.

Repeat the following steps for each parameter of the XSLT:

a.In the Parameter Name field, enter the name of the XSLT parameter as it appears in the
XSLT file.

b. From the Parameter Type drop—down menu, select the appropriate Parameter Type.

c. Click Add.

Note: The parameter name entered in the Parameter Name field, must match the parameter
name specified in the XSLT file. For example, if taxrate is specified as a parameter in the
XSLT source file, the same name (taxrate) must be specified in the Parameter Name field.
The following segment of an example XSLT file shows the declaration of the variable taxrate:

<?xml version="1.0" encoding="utf-8"?>

<xsl:stylesheet xmins:xsl="http://www.acme.com/trans" version="1.0">
<xsl:output method="update" indent="yes" />
<xsl:param name="taxrate"/>

Note: In the Configure XSLT Transformation Method dialog box, the order of the
parameters specified is not significant. The parameters of the XSLT are matched to the
parameters of the Transformation method by name.

6. Click OK.

This links the XSLT file with the selected method in the Transformation file. During run time, if the
business process invokes this method, this XSLT is invoked.
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This section describes programming considerations for transformations outside the mapper functionality of
WebLogic Workshop.

This section contains the following topics:

» Java Classes Created From Importing Schemas

« Java Class Conversion
» Using the MflObject Interface to Transform Non—-XML Data Programmatically

 Getting the TransformException Fault Code Programmatically
» Using the com.bea.WLXT Package (Deprecated)
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Java Classes Created From Importing Schemas

When a schema is imported into your application, representations of these schemas are available in some c
the panes of WebLogic Workshop. To learn more, see Selecting Source and Target Types.

In addition, Java classes for accessing the data represented in the schemas are generated, as shown in the
following figure.

XML Spy Format Builder
MFL File
XSD File
Contains the
Contains the schema which
XML Schema describes a non-
XML document
A Schemas
Project
x XMLBeans
XMLBeans instance
instance derived from a | MFLObject
derived from a schemain a *| Java class
XML Schema MFL
A
Variables
Application

The generated Java classes are described in the following table:

Importing ... Generates . . . Example
An XML Bean class it generated for th i an XML Schema file with the document or roqt
. XML Schema when the XML Schema R o S X
An XSD file |. . level elements: price and widgitld is imported into
. imported and built. The XML Bean class . :
(contains an . . Schemas project folder with a namespace of
provides methods for accessing the XI i ,
XML data that conforms to the imported XM p:/lwww.example.org/quote, the classes:
Schema) P riceDocument and WidgetldDocument are

Schema. To learn more, see Getting
Started with XMLBeans.

An MFL file |A top—level MflObject container class igf the MFL file: StockQuotes.mfl, that specifies
(contains a |generated for the MFL file. This Java [the MessageFormat name of StockPrices, is
schema whichclass provides methods for the imported into a Schemas project folder, the
describes conversion between non-XML and XM&tockPricesMflObject Java class is generated ip the
non-XML data, programmatically outside the  [Schemas/MFL Classes/stockquotes folder. To learn
data) mapper functionality of WebLogic more, see Using the MflObject Interface to
Workshop. Transform Non—-XML Data Programmatically

generated into the org/example/quote folder.
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A top—level XML Bean class based on
the main MessageFormat name is
generated from the MFL file when the
MFL is imported. The XML Bean class
contains get and set methods for
accessing the data, similar to the XML
Bean class that is generated when a X
Schema is imported and built. To learn
more about XML Beans, see Getting
Started with XMLBeans.

Before using the get and set methods
the XML Bean class, the non—XML da
must first be converted to XML data. T
learn more, see Transforming Non—XN
Data to Typed XML.

The file name of the MFL document
becomes the namespace of the MFL
elements in the XML Bean class.

If the MFL file: StockQuotes.mfl which specifieg
MessageFormat name of StockPrices is import
into a Schemas project folder, the class
StockPricesDocument is generated under the f
named stockquotes.

ML

One or more XML Bean classes that
correspond to the StructFormat
element(s) that are children of the mai
MessageFormat element in the MFL fi

StructFormat elements are equivalent
root or document level elements in XM
Schemas.

The file name of the MFL document
becomes the namespace of the MFL
elements in the XML Bean class. In
addition, if the MFL is stored in a
subfolder of the Schemas folder, the
subfolders pathname becomes the
package name of the namespace. For
example, if the StockQuotes.mfl file is
stored in the Schemas/trading folder, t
full namespace for the generated XML
Beans class is trading/stockquotes.

n
#.the MFL file: StockQuotes.mfl contains a sing
StructFormat element named PriceQuote, whic
[@ child of the MessageFormat element named
BtockPrices the following XML Beans classes g
generated in the Schemas/XML Bean
Classes/stockquotes folder:

PriceQuoteDocument
PriceQuoteDocument.PriceQuote
StockPricesDocument

StockPricesDocument.StockPrices
he

le
nis

For example if the following StockQuotes.mfl file is imported into a Schemas folder:

<?xml version='1.0" encoding="UTF-8'?>

<IDOCTYPE MessageFormat SYSTEM 'mfl.dtd'>

<MessageFormat name='StockPrices' version="'2.01'>
<StructFormat name='PriceQuote' repeat="*">

<FieldFormat name="StockSymbol' type="String' delim="' codepage="windows-1252'/>
<FieldFormat name='StockPrice' type='String' delim='|' codepage='windows-1252'/>

</StructFormat>
</MessageFormat>
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The following is displayed in the current Schemas folder as shown in the following figure:

|| Application X

29 testDTGuide
= ‘23 Schemas
=} {3 MFL Classes
= ¢ stockquotes
StockPricesMflObject
=} {3 ¥ML Bean Classes
= {¢] stockquotes
@ PriceQuoteDocument
@ PriceQuoteDocument.PriceQuote
StockPricesDocument
f] stockPricesDocument. StockPrices
E;] StockQuotes.mfl
(2] testDTGuidewWeb
() Modules
() Libraries
(3] Security Roles

When schemas are imported into your application, representations of these schemas are available in some
panes of the WebLogic Workshop. To learn more, see Selecting Source and Target Types.
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Java classes can be used as source and target types for transformations. Also, business process variables
be created from Java classes.

However, not all the fields that can make up a Java class are supported. This section describes which fields
a Java class are supported.

When you use a Java class or primitive in a transformation, WebLogic Integration converts it into an internal
representation of XML Schema data types. Java fields that are not supported are ignored. WebLogic
Integration then uses this internal representation to transform your Java classes to and from XML and
non-XML (MFL) documents

Note: This internal representation of the XML Schema is not exposed in WebLogic Workshop.

Note: The mapper functionality of WebLogic Workshop will only display the fields of a Java class that are
supported.

For a Java class to be used in WebLogic Integration, it must first be available in the WebLogic Workshop
project. To learn more about including Java class in your project, see Using Existing Applications.

Note: Java interfaces and abstract Java classes are supported as source or target types for a transformatiot
a transformation with a Java interface and/or abstract Java classes as source or target types cannot be exe
in Test View. However, a transformation with a Java interfaces and/or abstract Java classes as source or ta
types can be invoked from a business process (JPD) without error.

QUESTION FOR REVIEWERS: Does the above paragraph sound right?
Java classes are converted using the following procedure:

1.If the Java class is selected as an input type for a DTF, by default the name of the class becomes th
name of the variable. (For example, if the class Book is selected as an input type, by default, the
BookDoc variable is created by the mapper.) If the Java class is selected as the output type of a DTF
the name of the class becomes the name of the XML document's root element.

All the Java fields that can be mapped are converted to the appropriate XML Schema elements in th
new XML Schema. If a field cannot be mapped it is ignored. To learn more, see the following table.

2. For each field of the Java class, this conversion procedure is applied recursively to determine the tyy
of each subelement. Fields that are themselves Java classes will be subelements in the internal XMl
Schema. These subelements will have the same name in the XML schema as their name in the Jave
class. For an example, see Using Java Classes in Transformations.

3. Java fields of the class are converted according to the following rules:

¢ Public instance member variables of supported Java types are converted.

The following table describes the supported fields of Java classes and how these fields are

converted to the internal XML Schema representation of the Java class. Also, the XML
Schema data type can be converted back to the Java field unless otherwise noted.
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Java Field or Class

Converts to this XML Schema Data Type . . .

Java primitive types

equivalent XML data types

For example, Java primitive float type is converte
to a XML Schema float type.

java.lang.String

xsd:string

java.util.Date xsd:dateTime
java.util.Calendar xsd:dateTime
java.util.Date xsd:dateTime
java.sql.Date xsd:date
java.sgl.Time xsd:time
org.w3c.dom.Document xsd:any
org.w3c.dom.DocumenFragment |xsd:any
org.w3c.dom.Element xsd:any
org.w3c.dom.Node xsd:any

XML Bean classes

To learn more see XMLBeans Support for Built-I
Schema Types.

MflObject classes

The type of the corresponding XML Schema.

Java arrays

xsd:sequence of specified data type

For example, an array of Java integers is convert
to a XML sequence of integers.

ed

javax.sql.RowSet

xsd:anyType

Note: You cannot convert from XML back to a
RowSet.

java.util.Collection and classes that
implement the interface

xsd:anySimpleType*

Note: You cannot convert from XML back to a
Collection because java.util.Collection is only an
interface. You can, however, convert back to a cl
that implements the Collection interface.

ASS

Note: Static member variables are not converted.

Note: Final instance member variables (constants) are not converted.

Private fields are converted if JavaBean style get and set property methods for that field are

available in the class. For example, the following private member field: testBool is converted
to an XML schema type because the class that contains testBool has set and get methods fo
this private field as show in the following code segment:

public class TestSimpleTypes
{

private boolean testBool;

public boolean getTestBool(){
return testBool;

}
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public void setTestBool(boolean b){
testBool = b;
}
}

¢ Interface type fields will be converted if JavaBean style get and set property methods for the
interface are available in the class. You cannot convert from XML back to an interface. You

can, however, convert back to a class that implements a interface.
Related Topics
To learn more about creating Java class variables in business processes, see Creating Variables.

To lean more about using Java classes as input or output parameters in transformations, see Using Java
Classes in Transformations.
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Using the MflObject Interface to Transform Non—-XML
Data Programmatically

When an MFL is imported into a Schema project folder, a corresponding MflObject Java class is generated.
The name of the generated Java class file is derived from the MessageFormat name specified in the MFL fil
as shown in the following example StockQuotes.mfl file:

<?xml version='1.0" encoding="UTF-8'?>
<IDOCTYPE MessageFormat SYSTEM 'mfl.dtd'>
<MessageFormat name='StockPrices' version="2.01'>
<StructFormat name='PriceQuote’' repeat="*">
<FieldFormat name="'StockSymbol' type='String' delim=":" codepage="windows-1252'/>
<FieldFormat name="StockPrice' type='String' delim='"|' codepage="windows-1252'/>
</StructFormat>
</MessageFormat>

For example, if the preceding StockQuotes.mfl file, which specifies the MessageFormat name of StockPrice
is imported into the Schemas project folder, a StockPricesMflObject.class file is generated with following
methods:

public final class StockPricesMflObject extends MflObject {
public StockPricesDocument convertToXml() {}
public static StockPricesMflObject newlnstance(StockPricesDocument xml) {}
public static StockPricesMflObject newlInstance(byte[] bytes) {}
public static StockPricesMflObject newlInstance(InputStream in) {}
public static StockPricesMflObject newlInstance(String in) {}
public static StockPricesMflObject newlInstance(RawData in) {}

}

You can use these methods to programmatically convert non—-XML data to and from XML data outside the
mapper functionality of WebLogic Workshop. The following table lists the available MflObject methods and
describes functionality provided with each method. In the following table, MFName represents the specified
MessageFormat name. (In the preceding example, the specified MessageFormat name was StockPrices.)

Method Name and Signature Functionality

Transforms the non—XML data, valid to the schema in the MFL
file, to an instance of the associated XMLBeans Java interfgce.
The XMLBeans Java interface can then be used to access this
public MFNameDocument data in the XML document. To learn more about XMLBeans|, see
convertToXml() Getting Started with XMLBeans.

For an example of using this interface see Transforming
Non-XML Data to Typed XML.

Transforms an instance of the associated XMLBeans (XML
data) to non—XML data that is valid to the schema in the MHL
file.

public static MFNameMflObject
newlnstance(MFNameDocument xml)

public static MFNameMflObject
newlnstance(byte[] bytes)

public static MFNameMflObject Transforms the non—XML input stream to an instance of the
newlnstance(InputStream in) MflObject.

Transforms byte non—-XML data to an instance of the MflObject
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public static MFNameMflObject Transforms non—-XML data as a string to an instance of the
newlnstance(String in) MflObject.

public static MFNameMflObject Transforms non—-XML data as raw data to an instance of the
newlnstance(RawData in) MflObject.

The following section shows three different examples of using the StockPricesMflObject class:

» Transforming Non—-XML Data to Typed XML
» Create a New Instance of an MflObject From Typed XML Example
» Create a New Instance of an MflObject From Untyped Raw Data Example

Transforming Non—-XML Data to Typed XML

The example in this section shows a business process programmatically converting an incoming typed
non-XML message to an typed XML representation of that data.

This example assumes the StockPrice.mfl file is imported into a Schemas project folder and the following
XML Bean classes were generated:

* PriceQuoteDocument

* PriceQuoteDocument.PriceQuote
» StockPricesDocument

» StockPricesDocument.StockPrices

To learn more about the Java classes that are generated when MFL files are imported, see Java Classes
Created From Importing Schemas. For a listing of the StockPrice.mfl, see Java Classes Created From
Importing Schemas.

The business process executes the following steps:

1. A Client Request start node receives an non—XML message of type:
stockquotes.StockPricesMflObject and stores in a typed non—XML variable called stockPriceln.

2.1n a Perform node of the business process following the Client Request start node, the typed
non-XML data is transformed to the XML Beans representation of the data by calling the
convertToXml function as shown in the first line of the perform method of the following Process
Definition for Java (JPD) code listing:

package processes;
public class convertToXMLExample implements com.bea.jpd.ProcessDefinition
{
public stockquotes.StockPricesDocument stockPriceXML;
public stockquotes.PriceQuoteDocument.PriceQuote priceQuoteXML;
public stockquotes.StockPricesMflObject stockPriceln;

public void perform() throws Exception

{

stockPriceXML = stockPriceln.convertToXml();
priceQuoteXML = stockPriceXML.getStockPrices().addNewPriceQuote();
priceQuoteXML.setStockPrice("10.99");

3. The second line in the perform function executes the following steps:
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a.From the XML representation of the non—XML data, the stockquotes.StockPricesDocument
XML Beans class gets the current instance, as shown in the following section of code:

stockPricesXML.getStockPrices()

b. Adds a new instance of PriceQuote using the addNewPriceQuote method of the
stockquotes.StockPricesDocument XML Beans class, as shown in the following section of
code:

stockPricesXML.getStockPrices().addNewPriceQuote()

4. The last line in the perform function sets the StockPrice element to the string: 10.99 using the
setStockPrice method of the stockquotes.StockPricesDocument XML Beans class, as shown in the
following section of code:

priceQuoteXML.setStockPrice("10.99");

Create a New Instance of an MflObject From Typed XML Example

The example in this section shows a business process creating a new instance of an MflObject from incomir
typed XML data.

This example assumes the StockPrice.mfl file is imported into a Schemas project folder and the following
XML Bean classes were generated:

* PriceQuoteDocument

* PriceQuoteDocument.PriceQuote
» StockPricesDocument

» StockPricesDocument.StockPrices

To learn more about the Java classes that are generated when MFL files are imported, see Java Classes
Created From Importing Schemas. For a listing of the StockPrice.mfl, see Java Classes Created From
Importing Schemas.

The business process executes the following steps:

1. The Client Request start node receives an XML message of type: StockPricesDocument and stores
in a typed XML variable called stockPriceXML.

2.1n the perform node, an instance of the stockquotes.StockPricesMflObject is created from the typed
XML data by calling the static newlnstance function which accepts a parameter of type:
StockPricesDocument as shown in the following Process Definition for Java (JPD) code listing:

package processes;
public class newInstanceFromXMLExample implements com.bea.jpd.ProcessDefinition

{

public stockquotes.StockPricesDocument stockPriceXML;

public void perform() throws Exception

{
}

stockquotes.StockPricesMflObject stockPriceMFLObj = stockquotes.StockPricesMflObject.newlnstance(stockPrice XMl
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Create a New Instance of an MflObject From Untyped Raw Data Example

The example in this section shows a business process creating a new instance of an MflObject from incomir
raw data (a stream of non—XML data that is untyped and has no known structure).

This example assumes the StockPrice.mfl file is imported into a Schemas project folder and the following
XML Bean classes were generated:

* PriceQuoteDocument

» PriceQuoteDocument.PriceQuote
» StockPricesDocument

» StockPricesDocument.StockPrices

To learn more about the Java classes that are generated when MFL files are imported, see Java Classes
Created From Importing Schemas. For a listing of the StockPrice.mfl, see Java Classes Created From
Importing Schemas.

The business process executes the following steps:

1. The Client Request start node receives an untyped non—-XML data message and stores in a
RawData variable called stockPriceRaw.

2.In the perform node, an instance of the stockquotes.StockPricesMflObject is created from the
untyped non—-XML data by calling the static newlnstance function which accepts a parameter of type
RawData as shown in the following Process Definition for Java (JPD) code listing:

package processes;
public class newlnstanceFromXMLExample implements com.bea.jpd.ProcessDefinition

{

public com.bea.data.RawData stockPriceRaw;

public void perform() throws Exception

{
}

stockquotes.StockPricesMflObject stockPriceMFLODbj = stockquotes.StockPricesMflObject.newlnstance(stockPriceRav
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Getting the TransformException Fault Code
Programmatically

In the mapper functionality of WebLogic Workshop, you create transformations that transform data from one
format to another. From these transformations, queries (written in the XQuery) language are generated. Yol
can use the mapper functionality to edit these queries to add invocations to standard XQuery functions and
operators, User functions, or Controls functions. To learn more, see Invoking Functions or Operators in a

Query.

During run time, these queries may throw a TransformException exception with an associated fault code.
(For example, your query might call one of the provided standard XQuery functions, which may throw an
exception.) The fault code provides information about why the TransformException was thrown. You may
want to add Java code to business process to get the fault code of the TranformException and do some acti
in the code based on the fault code. You may also display the description string associated with the fault cor
in the console using a System.out.printin function. You add this code to the Process Definition for Java (JPC
file which contains the Java code for the business process.

Note: If you are only interested in the fault code string, use the Exception pane of the Workshop Test
Browser or the Test View pane of the mapper functionality of WebLogic Workshop to display the error
string associated with the fault code.

For example, a business process whose Start node is a Client Receive node invokes a Transformation
method of a Transformation file. The Client Receive node has an exception path with a Perform node to
catch exception, as shown in the following figure:

Ok
TransformExceptionExample

O

OnException

!
="

Perform

e 2

Client Request

Finish

The Transformation method invokes a query, which invokes the standard XQuery function xf:date. During
run time when the query is executed, the date function is invoked with the string: 2003—-8-16. This string is
not a legal date format because the month is not specified with two digits. This causes the date function to
thrown a TransformException exception with the TransformFaultCodes.RT_ILLEGAL_CAST fault code.
The Perform node retrieves the information about the exception that invoked it, checks that the exception is
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TransformException, and then prints out fault code number and sting that describes the fault code, as show
in the following JPD code segment:

import com.bea.jpd.JpdContext;

import com.bea.data.RawData;

import com.bea.xml.XmlObject;

import com.bea.transform.TransformException;
import com.bea.transform.TransformFaultCodes;

public class TransformExceptionExample implements com.bea.jpd.ProcessDefinition

{
public void perform() throws Exception
{
Exception e;
com.bea.transform.TransformException te;
e = this.context.getExceptioninfo().getException();
System.out.printin("Caught exception in transformation: " + e.toString());
if (e instanceof TransformException)
{
te = (TransformException) €;
System.out.printin(“Fault Code Number=" + te.getFaultCode());
System.out.printin("Fault Code String=" + te.getCause());
switch (te.getFaultCode()) {
case TransformFaultCodes.RT_ILLEGAL_CAST:
// Add code here to do some action based on the error code.
break;
default:
break;
}
}
}
}

For example, if some corrective action should occur if the returned fault code is equal to the
TransformFaultCodes.RT_ILLEGAL_CAST fault code, replace the comment that starts with the string: //Add
code here with the corrective Java code.

For a list of the supported fault codes, see the JavaDoc for the TransformFaultCodes class.

Note: The following two import lines must be added manually in the Source View of the JPD file:

import com.bea.transform.TransformException;
import com.bea.transform.TransformFaultCodes;
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Using the com.bea.WLXT Package (Deprecated)

The public methods provided in the com.bea.WLXT package are deprecated. This deprecated package will
removed from the product in a future release. You should migrate your application away from using this
package to using the functionality provided in WebLogic Integration 8.1 for transforming data between
non-XML and XML formats. To learn more, see Transforming Non—-XML Data.
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