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1 Release

What’'s New in Oracle’s Siebel Events Management Guide, Version
8.1/8.2

No new features have been added to this guide for this release. This guide has been updated to
reflect only product name changes.
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This chapter lists the applications administration tasks that are specific to Siebel Events
Management. Use this chapter in combination with Siebel Applications Administration Guide.

This chapter contains the following topic:
“Administrative Setup Tasks” on page 9

You can use this manual and the Events Management software interface as a general guide to
accomplishing your business tasks; however, be aware that you may need to make some
adjustments to the order in which you enter data and the ways in which you use Events Management
software capabilities.

Siebel Applications Administration Guide covers the setup tasks that are common to all Siebel
Business Applications, such as using license keys, defining employees, and defining your company’s
structure. It also provides the information you need to implement, configure, and monitor the Siebel
sales, service, and marketing products and to perform data administration and document
administration tasks.

NOTE: Some tasks discussed in this chapter replace the corresponding ones in the Siebel
Applications Administration Guide, whereas others are additional tasks. It is recommended that you
review Table 1 before following the procedures in the Siebel Applications Administration Guide.

This guide assumes that you have already installed or completed the upgrade of Siebel Events
Management. If you have not, go to the Installation/Upgrade section of the Siebel Bookshelf CD-ROM
and click the links to the guides that are relevant to your company’s implementation.

The Siebel Database Server installation script creates a Siebel administrator account that can be
used to perform the tasks described in this guide. For more information, see Siebel System
Administration Guide and the Siebel Installation Guide for the operating system you are using.

CAUTION: Do not perform system administration functions on your local database. Although there
is nothing to prevent you from doing this, it can have serious results, such as data conflicts, an overly
large local database, or a large number of additional transactions to route.

Administrative Setup Tasks

Table 1 lists and describes the administrative setup tasks that are specific to Siebel Events
Management and tasks that might differ from those of the other Siebel Business Applications. Table 1
also directs you to documentation that provides information about each task.

Siebel Events Management Guide Version 8.1/8.2 9



Getting Started B Administrative Setup Tasks

When setting up your application, use Table 1 in combination with Siebel Applications Administration

Guide.

Table 1.
Administrative Task

Configuring the Shopping
Cart

Administrative Setup Tasks

Description

Set up Web access for Siebel
Events for Finance.

For More Information

Siebel eSales Administration
Guide

Configuring Email
Notification

Configure automatic email
notifications for events.

Siebel Email Response
Administration Guide

Reviewing and Modifying
Lists of Values (LOVs)

Customize values in picklists.

Siebel Applications Administration
Guide

“Reviewing and Modifying Lists of
Values (LOVs)”

Updating Lookup Tables

Populate values for region
administration, product lines, and
session templates.

“Updating Lookup Tables”

Using Pricing Models

Set up pricing models.

Siebel Pricing Administration
Guide

Managing the Events
Calendar

Enable a browser for high-
interactivity applications and
configure the calendar display.

Siebel System Administration
Guide

Using Reports

Set up report parameters.

Siebel Reports Guide
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agement

Application administrators can use this chapter to understand concepts related to Siebel Events
Management installation and configuration. The chapter provides an overview of server and client
installation requirements, browser requirements, and Shopping Cart requirements. It also includes
a discussion of how to configure automatic email notification.

This chapter includes the following topics:
B “Installation Overview” on page 11
B “Shopping Cart Requirements” on page 12

B “Configuring Automatic Email Notification” on page 12

Installation Overview

Server software for Siebel Events Management is automatically installed along with your other Siebel
Server software and when the license key for Siebel Events Management is activated. To use Siebel
Events Management, you must enter the Siebel Server component group Marketing. For more
information about installing Siebel Servers and about enabling Siebel Server component groups, see
Siebel Installation Guide for the operating system you are using.

Client software is not required to use administrative or customer-facing functionality, provided that
the client computer has a supported Web browser installed and is connected to a network that
communicates with the necessary servers.

Browser Requirements for Financial Services Customers

Financial Services customers need a browser for high-interactivity applications to support real-time
updates to the user interface. For example, when you drag a column divider to change column width,
a browser for high-interactivity applications displays your changes in real time. This functionality is
particularly important in the events calendar and persistent filters, and use of a low-interactivity
browser results in an incomplete screen display. For information on setting up browser capabilities
for the events calendar in your Siebel application, see Chapter 7, “Managing the Events Calendar.”

Siebel Events Management Guide Version 8.1/8.2 11
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Shopping Cart Requirements

Siebel Events Management is designed to work with the Siebel eSales Shopping Cart, which allows
users to pay for goods and services over the Web. For Siebel Events Management to work properly
with the Shopping Cart, Siebel Business Process Designer must be present, and all Siebel eSales
workflow processes must be activated. For more information about the Shopping Cart, see Siebel
eSales Administration Guide.

NOTE: Siebel Events implementations running DB2 Universal Database for AS/400 require RSA
encryption for Events Management to work properly with the Shopping Cart. For all other database
servers, use of RSA is strongly encouraged, but not mandatory. You must run separate scripts to
enable RSA encryption.

For more information, see the Siebel Database Upgrade Guide. For information on running the scripts
to change the encryption method to RSA, see Using Siebel Tools.

Configuring Automatic Email
Notification

Siebel Events Management is designed to send the following kinds of email messages:
B Invitations to events
B Confirmation messages when registrations for events are completed successfully

B Notification messages that events have no remaining seats open, but that the email recipients
have been placed on waiting lists for any cancellations

B Notification of cancellations

For these messages to be sent automatically, Siebel Events Management must be configured to work
with Siebel Workflow Designer and Siebel Communications Server. The general process for setting

up automatic email notification for Events Management is described in this section. For more detailed
information about creating communications profiles, restarting servers, and working with workflow
policies and processes, see Siebel Communications Server Administration Guide and Siebel Business
Process Framework: Workflow Guide.

This process depends upon a correct email address being included in the Contact information for each
person registered.

NOTE: The following procedure assumes that you have already activated the Siebel eSales workflow
processes needed for proper operation of the Shopping Cart.

To set up automatic email notification

1 Navigate to the Site Map > Administration - Business Process > Policies view and set an
Activation Date and Expiration Date for each of the following policies:

m eEvents Event Confirmation Email

m eEvents Event Invitation Email
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ring Events Management ® Configuring Automatic Email
Notification

m eEvents Event Waitlisted Email

NOTE: For each Activation Date value, use a date that is earlier than the current date. Use an
Expiration Date that is later than the current date.

From the link bar, choose Workflow Processes and activate the following processes:
Event Confirmation Email (eEvents)

Event Waitlisted Email (eEvents)

Event Invitation Email (eEvents)

Event Cancellation Email (eEvents)

Send Order Accepted Email (eSales)
Restart your Siebel Server and Siebel Gateway Name Server.

Navigate to the Site Map > Administration - Communications > Communications Drivers
and Profiles view, and then set up a profile for a supported email server, including appropriate
specifications for Profile Parameter Overrides.

For an Internet SMTP/POP3 mail server parameter, overrides should include entries for any or all
of the following parameters:

From Address

POP3 Account Name
POP3 Account Password
POP3 Server

SMTP Server

POP3 Server Port

SMTP Server Port
Navigate to the Administration - Communications screen > All Templates view.
In the Templates list, select the Event Confirmation Email Package (eEvents) template.

Then, click the Advanced view tab, and use the Delivery Profile field to specify the profile you
created in Step 4.

Repeat Step 5 and Step 6 for each of the following templates:
m Event Waitlisted Email Package (eEvents)

m Event Invitation Email Package (eEvents)

m Order Accepted Email Package (eSales)

For each of the templates in Step 6, specify any needed changes to the text that will appear in
your email notifications:

m  For the Events templates, make any needed text changes in the Template Text field on the
Advanced form.

Siebel Events Management Guide Version 8.1/8.2 13
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Notification

m  For the eSales template, click the Template Items view tab, and make the changes in the list
that appears.

8 Make sure the Outbound Communications Manager component has been started.
9 Start the Generate Triggers server task.
10 Start the Workflow Monitor Agent server task for Events Group.

After email notification is properly configured, your Siebel application generates automatic email
messages when event registration records have a registration status of Invited, Confirmed, or
Waitlisted. Automatic email messages are not generated for session registration records. Workflows
can be created to send automatic email messages for session registration records if desired. For more
information about registration, including procedures for inviting and registering event attendees, see
Chapter 6, “Registering for an Event.”
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4 Event

Siebel Events Management helps you create and enter information that defines the scope, activities,
and budget of an event. Defining an event is the first of four phases in the event management
process. Because requirements and task sequences can differ from event to event, the organization
of Events Management screens may not exactly match the sequence or organization of tasks for your
particular event.

This chapter includes the following topics:

B “Event Management Process Phases” on page 15

B “Business Scenarios for Defining an Event” on page 17

B “Example Process Flow for Defining an Event” on page 19

B “Administrator Setup Procedures for Defining an Event” on page 19
|

“End-User Setup Procedures for Defining an Event” on page 29

Event Management Process Phases

The event management process has four primary phases:

B Definition

B Preparation

B Implementation

B Evaluation

Siebel Events Management can help you define, prepare, implement, and evaluate events.

Depending on the size and complexity of your event, you may be tracking large amounts of
information, including the status of many tasks. To simplify the process of learning to use Events
Management, this manual discusses the four phases in the order listed above and provides
instructions for business tasks that are typical of each phase. However, if your event is large and
complex, you may find that the phases actually overlap, or you may find that changing circumstances
occasionally require you to redo a previously completed task.

Event Plan Definition
The definition phase typically includes the following business tasks:
B Defining the purpose of the event. Decide what do you want the event to accomplish.

B Defining the type of event. Decide if the event will be a seminar, a conference, a roadshow,
or another type of event.
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B Defining the scope of the event. Estimate approximately how many people will attend and for
how long. Identify what types of people will attend.

B Determining the nature and the logistics of the event. Determine if the event will require
specific timing, a specific location, or a venue.

Creating an action plan. Identify what activities are required to conduct a successful event.

Creating a budget for the event. Identify the budget categories and the anticipated costs
associated are with each category.

Event Preparation

When you know the approximate nature and purpose of your event, your intended audience, and any
constraints on timing and location, you are ready to begin preparing for the event. This phase
typically includes the following business tasks:

B Activity management tasks. These tasks include:

m  Assigning event preparation and implementation tasks to employees, vendors, or other event
staff

m  Tracking progress of event preparation activities
m Designating the event staff and speakers
B Information preparation tasks. These tasks include:
Refining and organizing the information that will be presented at the event
Researching and choosing one or more speakers for the event
Tracking and managing speaker availability for the event

Preparing information for Web site publication

Preparing collateral to be distributed at the event
B Site preparation tasks. These tasks include:
m Researching and choosing a venue for the event
®  Arranging for any needed facilities and equipment within the venue
m  Doing the required physical setup of the event site prior to beginning the event
B Financial tasks. These tasks include:
®  Forming partner relationships to improve event quality or defray expenses
m  Tracking expenditures and revenues in relation to the event budget
B Other tasks. These tasks include:
m Researching and choosing vendors for the event
® Inviting prospective event attendees

B Registering attendees in advance
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B Preparing status reports concerning preparations for the event

Event Implementation

When you open the event to the first registrant, you have moved from the preparation phase into
the implementation phase of the event. This phase typically includes the following business tasks:

B Registering walk-in attendees at the event site. Register walk-in attendees using
administration screens, or let attendees self-register using the Web site (recommended).

B Completing last-minute preparation tasks. Complete last-minute tasks, such as recording
the billing parameters the vendor will use, recording any discounts or special rates you negotiate,
and storing file attachments for the event.

B Coordinating with venue personnel. Coordinate with venue personnel to address any facilities
issues that arise during the event.

B Coordinating with vendor personnel. Coordinate with vendor personnel to make sure that
they deliver contracted goods and services on time, in good condition, and at the correct
locations within the venue.

B Coordinating with partner organizations. Coordinate with partner organizations to make
sure that they meet their obligations for the event.

Event Evaluation

After the event has taken place, you will want to evaluate the event. This phase typically includes
the following business tasks:

B Preparing reports. Create reports on attendance, opportunities generated, and so on for senior
management.

B Preparing reviews of the venues and vendors. Review the venues and vendors used for the
event to determine if they should be considered for future events and the reasons why or why
not.

B Following up on new business opportunities. Follow up with the contacts that were
generated during the event.

NOTE: You can analyze a contact’s attendance frequency to target future events and determine
areas of interest by navigating to the Contacts screen and choosing the Consumer list link, then
review the Consumers Activities. For more information, see Siebel Applications Administration
Guide.

Business Scenarios for Defining an Event

These scenarios provide examples of process flows performed by Siebel application administrators
and event planners. Your company may follow different process flows according to its business
requirements.
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Administrator Event Definition Scenario

This scenario provides an example of a process flow performed by application administrators. In this
scenario, an administrator works for a company holding a user week conference for a software
product used by astronomers. In order for event planners and team members to efficiently manage
the event, the administrator needs to set up Siebel Events Management for the particular
informational needs of the event. Also, because Siebel Pricer has been purchased along with Siebel
Events Management, the administrator needs to set up Events Management and Siebel Pricer to work
together.

Using lists of values (LOVs), the administrator determines the available fields and selections that
allow the event planner and team members to enter and manage the specific information required
for this event. For example, the event planner may need to add a planetarium—which is not typically
an available selection—as a room type for a session on a college campus. To make this possible, the
administrator reviews and modifies the LOVs that populates the static picklist for the room type.

NOTE: Finance customers, some fields and selections, such as regions, product lines, and sessions,
require the administrator to create them using tables instead of LOVs.

Finally, the administrator performs other procedures that speed data entry by event planners and
team members. These procedures include adding and updating account data, entering contact data,
and adding venues.

End-User Event Definition Scenario

This scenario provides an example of a process flow performed by end users. In this scenario, the
end user is an event planner who, like the administrator described in “Administrator Event Definition
Scenario,”, works for a company holding a user week conference for a software product used by
astronomers.

The event planner uses Siebel Events Management to define the event by entering information about
the event, such as its name, whether it is a conference or seminar, timing, location, and so on.
Typically, the event planner waits until the administrator has defined all of the fields and selections
necessary before entering this information. In such cases, the event planner provides the
administrator with enough information to define the event fields. However, due to the unusual topic
of this event, the event planner decides to work in tandem with the administrator to define the fields
and enter the event information.

Events often involve featured topics or themes, such as climate change, water pollution, and the
ozone layer. In Siebel Events Management, these are called tracks. Therefore, as part of event
definition, the event planner can add any such event tracks as necessary. To add additional continuity
to the event plan, the event planner can also associate related events.

Next, the event planner creates a budget for the event by entering estimated revenues and
expenses, such as advertising revenues and catering expenses.

Lastly, the event planner creates several activity templates, each of which can be used to associate
a set activities, or action items, with the event.

18 Siebel Events Management Guide Version 8.1/8.2




Example Process Flow for

Defining an Event

Figure 1 is based on recommended event definition tasks to be performed by administrators and end
users in Siebel Events Management. Administrator procedures include the following: reviewing and
modifying LOVs, updating Lookup Tables, creating contacts, accounts, venues, using Price Models,
and so on. End-User procedures are as follows: defining Events Plans, Events, and Sessions, creating
tracks, adding Event Plan details, creating events, adding budget details and event activities, and so

on.

Administrator Procedures

Ernd-User Procedures

Fevieming and hModifying
Lists of Walues (LOWS)

Lefining Event Plans,
Ewents, and Sessians

v

!

Updating Lookup Tables

Creating Tracks

!

.

Creating Contacts

Adding Event Plan Details

v

!

Creating Accounts

Creating Events

¥

i

Creating Wenues

Adding Budget Details

-

B}

Using Pricing hodels

Adding Event Activities

Defining an Event i Example Process Flow for Defining an Event

Figure 1. Process Flow for Event Definition Administrator and End-User Procedures

Administrator Setup Procedures for
Defining an Event

This section discusses the following topics and procedures:
B Reviewing and Modifying Lists of Values (LOVS)

B Updating Lookup Tables

B Creating Accounts
|

Creating Contacts
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B Creating Venues
B Using Pricing Models

Siebel Events Management contains fields that depend upon LOVs, existing Accounts, existing Tables
or Contacts data. As an administrator, you can use procedures described in this section to set up and
autopopulate many LOVs and tables before the first event is added to the database. By first defining
and autopopulating LOVs and tables, entering event information proceeds more efficiently. Also, you
may want to verify that businesses and people with whom you interact when planning and hosting
events are added as Accounts and Contacts before you set up events. The sections that follow contain
information about reviewing and modifying these items.

Reviewing and Modifying Lists of Values (LOVS)

Before you enter information about an event, you may want to review the existing LOVs to determine
whether the values meet the needs of your company and then add or modify LOVs to adapt them to
your business processes.

NOTE: Certain registration status values, such as Confirmed, Pending, and Waitlisted, are used by
the application to update event seat counts. Developers should excercise caution when changing the
EVENT_REG_STATUS LOV values, and test the application to make sure that it works as expected
after any changes.

To review and modify LOVs for event management
1 Navigate to the Site Map > Administration - Data > Lists of Values view.

2 Refer to Table 2 or Table 3, and review the LOVs for event management.
3 Update the values as required.
For specific instructions on modifying LOVs, see Siebel Applications Administration Guide.

4 If you add values to the EVENT_FORMAT list of values, also add those values in the List of Values
Explorer view:

a2 Navigate to the Site Map > Administration - Data > Lists of Values Explorer view.
b  Select the type of SOURCE TYPE (internal).
c In explorer, navigate to SOURCE TYPE (internal) > Values > EVENT > Child List of Values.

d In the Child List of Values list, add the values.
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Siebel Events Management screens contain fields that display available values from LOVs such as
those listed in Table 2 and Table 3.

Table 2. List of Values (LOVS)

List of Values Comments

EVENT_BILLING_BASIS Indicates whether a venue or vendor rate is calculated hourly,
daily, weekly, monthly, or on a per-item or per-person basis.

EVENT_COMMITMENT_TYPE Displays a selection of contribution types a partner organization
can make for an event, such as monetary, promotional, material,
and so on.

EVT_FREQUENCY Frequency with which the events occur within an event plan. For
example, daily, monthly, or quarterly.

EVENT_FEE_TYPE Indicates if a fee is required for the event. Values available by
default include Registration, Voluntary, Donation, and None.

EVENT_FORMAT Displays the format of the session featured, such as Keynote,
Roundtable, Workshop, and so on.

EVENT_COMMITMENT_TYPE Displays a selection of sponsorship commitment types, such as
promotion or resources.

EVENT_ORG_TYPE Displays a selection of vendor or partner for an organization type.

EVENT_PARTNER_ROLE Identifies the role of a partner organization in an event, such as
Exhibitor, Sponsor, Contributor, and so on.

EVENT_PARTNER_STATUS Indicates the status of arrangements with a partner organization,
such as Requested, Shipped, Fulfilled, and so on.

EVENT_REG_STATUS Displays the registration status of a potential attendee, speaker,
or staff member for an event or an individual session.

EVENT_REVENUE_TYPE Displays a selection of revenue sources related to an event, such
as Partners, Sponsors, Advertisers, and so on.

EVENT_ROOM_TYPE Displays a selection of room types available at event venues, such
as conference rooms, classrooms, auditoriums, and so on.

EVENT_STAFF_ROLE Displays a selection of staff member roles or areas of
responsibility, such as Set-Up, Moderator, Clean-Up, and so on.

EVENT_STATUS Displays the registration status, such as in Planning, Launched,
Scheduled, and so on.

EVENT_STATUS_CODE Displays the status of an event or session, such as Planned, In
Progress, Completed, and so on.

EVENT_TYPE Displays the type of parent event plan or event featured, such as
Seminar, Deal Roadshow, Non-Deal Roadshow, and so on.

EVENT_VENDOR_ROLE Displays a selection of vendor roles or areas of responsibility, such
as Caterer, Audio/Video, Security, and so on.
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Table 2. List of Values (LOVS)

List of Values Comments

EVENT_VENUE_ROLE

Displays a selection of venues, such as Convention Center, Hotel,
Office, and so on.

MKTG_PLAN_APPR_TYPE

Displays a list of approval status values, such as Rejected,
Approved, and Submitted.

OFFER_MATERIAL_TYPE

Displays a selection of collateral and literature types, such as
Brochure, Map, Hand-out, and so on. This LOV is used in other
areas of your Siebel application.

PARTICIPANT_STATUS

Displays a selection of participant status types such as VIP and
Guest.

SALES_TOOLS_STATUS

Indicates whether a collateral or literature item has reached
Draft, Final, Approved, and so on. This LOV is used in other areas
of your Siebel application.

SRC_ITEM_CATEGORY

Displays a list of expense categories, such as Creative,
Furnishing, Vendors, Materials, and Venues.

SESSION_LOCATION_TYPE

Displays a list of session location types, such as Station or Table.

TRAVEL_TYPE_CODE

Displays a selection of travel types such as Air, Ground, and Hotel.
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Table 3. Financial Services Customer-Specific List of Values (LOVs)

List of Values Comments

EVENT_COM_REG_STATUS Displays the registration status of an account for an event or an
individual session. Values include Pending, Confirmed, Waitlisted,
Restricted Invite, Invited, Cancelled, and so on.

EVENT_RECUR_FREQ_TYPE Indicates the frequency of the auto-generated event of an event
plan, such as Daily, Weekly, Quarterly, and so on.

EVENT_VENDOR_FUNCTION Defines the service the vendor is providing. Values include Ads,
Music, Lunch, Breakfast, Booths, Limo, Lodging, Publications,
Sound, Table Set-up, Video, and so on.

EVT_PARTICIPANT_TYPE Displays values for participant type, such as Analyst, Internal
Participant, Competitor, and so on.

EVT_SIGNUP_STATUS Displays the event registration status values, such as Open or
Closed.

FINS_EVENTS_PROD_CAP_SI | Displays values for the market capitalization size to describe the
ZE featured financial product, such as Large Cap, Mid Cap, Small
Cap, or Micro Cap.

NOTE: You use the S_REGION table to define the regions associated with the featured financial
product, such as Asia, North America, Europe, and so on.

Updating Lookup Tables

You can enter and maintain some values through LOVs, but you must create other values through
tables. The advantage of using tables to enter values is that each company can establish a unique
hierarchy and define appropriate values for its business processes.

Populating tables in your Siebel application is a consistent process when setting up Regions, Product
Lines, and Session templates, which are described in this section. You can update event-related
tables from the Administration - Application screen.

Region Administration
Because Siebel Events Management is only one of many parts of your Siebel application that uses
the concept of region, you need to define a regional hierarchy appropriate for your overall business.

There are two region-related fields in Siebel Events Management:
B The Region field indicates the region in which the Event takes place.

B The Region Origin field indicates the Region from which the Event's featured investment comes.
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Other parts of the Siebel application use region to indicate the investment focus of your salesmen
and their coverage regarding your client companies. Therefore, it is important that you select a
region hierarchy that is generic enough to describe event regions, coverage regions, and investment
product regions in a single table.

For global or multinational companies, you need to define regional hierarchies that relate to the
geographical areas your business serves and in which you conduct events. Application Administrators
can manage region hierarchies by performing the following procedure.

To define regional hierarchies
1 Navigate to the Administration - Locations > Regions view.

2 In the Parent Region list, define the region, for example, North America, Asia, and so on.

3 In the Child Region list, you can then define subsets of the Parent Regions. For example, your
Child Regions could be the individual countries that are associated with the highlighted record in
the Parent Region list.

Alternatively, you many choose to use individual cities that are associated with the highlighted
Parent Region. If two levels of region hierarchies are not sufficient for your company's business
requirements, the Siebel data model allows a database administrator to create additional levels.
You will however, have to configure the user interface to allow users to define this hierarchy.

The following list illustrates how multiple regions and areas within regions can be set up in the Region
table. For example, your financial institution may define geographies in the following major regions
and then areas within a region:

B Asia-Pacific
Japan
China
Singapore
Malaysia

Indonesia

Australia
B Europe

®  United Kingdom

m  France
m  Spain
m  ltaly

B Middle East
B North America
B South America

For more information on working with regions, see Siebel Finance Guide.
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Period Administration

While some organizations use standard calendar reporting periods, other organizations use fiscal
reporting periods. Siebel Business Applications provide flexibility in this area, so organizations can
set up periods that make sense for them. For information about period administration, see Siebel
Forecasting Guide.

Product Lines for Financial Services Customers

If you are a financial services customer, Siebel Events Management uses the Product Line table to
store Asset Classes. You will want to add a row to the table for each relevant asset class associated
with a product line from the Product Line Fee view of the Administration - Application screen.

For example, your financial institution may define the following four types of Asset Classes within a
Product Line:

B Derivative

B Equity

B Fixed Income
B Mutual Fund

For information on Product Administration, see Siebel Product Administration Guide.

Adding Session Templates

Siebel Events Management uses Session Templates to store templates for groups of sessions that
are similar. For example, all events that take place in London may follow the same sequence of
sessions, including the same start times and end times. In this case, you may want to save a London
template that contains the same sequence of sessions, which you can reuse each time you host a
London event.

Session templates may be used in more than one region, area, or location. You can manage session
templates by navigating to the Marketing Templates screen and choosing Session Templates. For
more information, see “Event Management Process Phases” on page 15.

The following steps describe a recommended workflow for setting up session templates and the
events and sessions that define them.

1 Create the template. An Administrator creates a Session Template and adds session details
including City, Country, and Start Time.

2 Add sessions to the template. The administrator then adds sessions to the template,
specifying name, start date, end date, and format.

3 Save the template. Siebel Events Management saves the session template, which allows you
to add, change, or delete sessions associated with it.

Siebel Events Management Guide Version 8.1/8.2 25



Defining an Event & Administrator Setup Procedures for Defini

Table 4 displays sample line items in a session template. For example, your company may define the
following one-day event in London as part of a session template.

Table 4. Sample Session Template Line Items
City London
Country United Kingdom
Start Time 9:00 A.M.

After you have created an outline for a London session template, you can add typical sessions that
occur during your London-based events. Table 5 displays sample sessions within the London session
template.

Table 5. Sample London Sessions

Registration/Breakfast 8:00 A.M.-8:30 A.M.
Introductions 8:30 A.M.-9:00 A.M.
Opening Presentation 9:00 A.M.-10:00 A.M.
Featured Presentation 10:00 A.M.-11:30 A.M.
Breakout Session 11:30 A.M.-12:30 P.M.
Lunch 12:30 P.M.-2:00 P.M.
One-on-One Analysis 2:00 P.M.-3:30 P.M.
Roundtable 2 3:30 P.M.-5:00 P.M.
Group Report Out 5:00 P.M.-5:45 P.M.
Concluding Remarks 5:45 P.M.-6:00 P.M.

Creating Contacts

A few Events Management forms and lists contain fields that depend upon existing contact data
entered in the Contacts screen. A contact is an individual with whom your company conducts
business or expects to conduct business with in the future. A contact can be an employee of another
company, a vendor, or professional consultant and may have relationships with a number of
companies. Data entry in Events Management can proceed more smoothly if you have already
entered contact data for:

B Your organization’s employees

B Potential staff (other than vendors)
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B Potential venue personnel
B Potential individual invitees

For more information about entering Contacts, see Siebel Applications Administration Guide.

Creating Accounts

Administrators create the supporting data for the events (that is, account information, venues,
setting up rooms, and so on) before creating the event itself. Therefore, many Events Management
forms and lists contain fields that depend on existing account data entered in the Accounts screen.
An account represents the relationship between your company and the companies or individuals with
whom you conduct business. To make data entry in Events Management less time consuming, you
can enter account data for event vendors, partners, supporting organizations, and employing
organizations of potential event invitees earlier.

Before adding account data, identify the relationships for which you need to create accounts. Then,
use the following procedure to enter account data for each relationship.

To enter account data
1 Navigate to the Site Map > Accounts view.

2 Before adding a new account, search the accounts list to make sure the account does not already
exist.

3 If the account does not exist, in the Add Section complete the fields for the new account, and
click Add.

4 In the Recent Records section, drill down on the account name.

5 Click the More Info view tab, click the show more button and complete additional fields as
needed.

As you gain additional information, or as account details evolve or change, you can update the
account information. For more information, including details about adding an account, specifying
account details including addresses, and handling company name changes, see Siebel Applications
Administration Guide.

Creating Venues

A venue is a physical facility where an event may be held, such as a conference center or hotel. In
Siebel Events Management, you can store information about possible venues ahead of time, including
their rental rates, and later choose which venue or venues to associate with an event. These and
other end-user tasks are described further in Chapter 5, “Preparing for an Event.”

In preparation for working with venue data, you should add possible venues using the Administration
- Location screen as described in the following procedure.
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To add a venue
1 Navigate to the Site Map > Administration - Location view.

2 In the Locations list, create a new record, and complete the necessary fields.

The following procedure describes how to enter information about rooms that you may want to use
for event venues, such as conference rooms, meeting rooms, or classrooms.

To enter room information for a potential event venue
1 Navigate to the Site Map > Administration - Location view.

2 In the Locations list, select the location that you are considering as a possible event venue.
3 Click the Rooms view tab.
4 In the Rooms list, create a new record.

The following table describes some fields in the Room list.

Field Comments

Drops Information describing the network access ports.

Name Name of the room you are considering as a possible event or session venue.
Room Expense of renting the room, per time unit or other unit identified in the Basis
Rate field.

Type Type of the room.

The following procedure lets you record information about the equipment that is available in a
potential room for an event.

To add the equipment available in a potential event venue room
1 Navigate to the Site Map > Administration - Location view.

In the Locations list, select the location that you are considering as a possible event venue.
Click the Rooms view tab.

In the Rooms list, select the room for which you want to add equipment.
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In the Equipment list, create a new record.

Using Pricing Models

If you have purchased Siebel Pricer along with Siebel Events Management and will be using the Siebel
Shopping Cart view to charge customers event or session registration fees, you can use pricing
models to adjust the registration fee a customer must pay to attend an event or session. The
adjusted fee may be based on customer location, customer account agreements, or other factors.
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For more detailed information about setting up and using Siebel Pricer, see Siebel Pricing
Administration Guide.

End-User Setup Procedures for
Defining an Event

This section discusses the following topics and procedures:
Defining Event Plans, Events, and Sessions

Creating Tracks

Adding Event Plan Details

Creating Events

Adding Budget Details

Adding Event Activities

Defining Event Plans, Events, and Sessions

Siebel Events Management allows you to define event plans, events, and sessions. For the purposes
of defining and organizing information for an event, you should note that Siebel Events Management
uses a three-level hierarchy of events:

B Event Plans. Event plans are used to define the high-level information about an event, including
overall date span, approvals, and summarized financial metrics. Information from child events,
such as expenses and attendees roll up to the event plan.

B Events. The propagated events, or children of the parent event, which comprise the individual
days within the parent event timeline. An event is usually one day long.

B Sessions. The components of an event. Usually, many sessions make up an event. Sessions are
typically measured in hours.

Event plans include defining the purpose, nature, and scope of the event, and making at least
tentative decisions about when and where the event will be held. In Siebel Events Management, you
can record these decisions in an event.

Later in the definition process, you can update the event plan, events, and sessions with detailed
information. Also, prospective event attendees will be able to view information from the listing on
your Siebel Events Web site.

NOTE: In this release, information that is entered for a specific session is stored separately from
information that is entered for the event that includes the session. For example, to view all
information about event vendors, you would need to review the vendor information under the
Participants view tab and the Sessions screen.
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Creating Tracks

A track in Siebel Events Management is a featured topic or theme at an event. For example, a biotech
investment conference may establish three tracks: Genomics, Computers, and Pharmaceutical.

After tracks are created, they can be associated to events and sessions. For example, using the
biotech example, you could relate several sessions on using computers in biotech with the computers
track. As a result, attendees who are interested in this subject can select from a subset of sessions
that are related to the subject.

The following procedure describes how to add an event track. For information on relating a track to
events and sessions, see Chapter 5, “Preparing for an Event.”

To add an event track
1 Navigate to the Site Map > Events > Tracks view.

2 In the Tracks list, create a new record, and enter a status for the track.
Some status values are In Planning, Scheduled, Launched, Completed, and Cancelled.

NOTE: These status values are for descriptive purposes only and do not limit registration to
associated sessions.

Adding Event Plan Details

This section describes how to create an event plan, which generates events. Creating an event plan
also generates an activity in the Activities screen.

The lists and forms for event plans and events use much of the same information. Many of the fields
you enter for the event plan are inherited by its events. Each event inherits the values in the parent
event fields when it is initially saved. After the initial save, the Status field and the Display on Website
field inherit changes made to the parent event.

An event plan’s Status field can be used to hide the event, and its events and sessions, from all users
who are not using an Events Administrator Log In ID. This is accomplished by choosing the value
Restricted in the Status field of an event. The Restricted status is then copied to that event’s events
and sessions. This also works in reverse—if a session’s status is changed to Restricted, the change
affects, or gets copied to, the status of the event or event plan.

NOTE: For Finance customers, to hide the event, choose the value of Hidden in the Status field of
an event. This hides the event from sales people and other employees who do not have
administrative log in.

When creating an event plan, you can specify a value in the Event Frequency field. This field, along
with the event plan start and end date, determines how many event records will automatically be
generated under the event plan. For example, if the event plan spans 10 days, and the event plan
frequency is daily, then 10 events will be generated. When creating a new event plan, events are
automatically generated upon saving the event plan record. To generate events for existing event
plans, use the Create Events button on the event plan form applet. You can use only the Create
Events button to generate events if no events exist for the event plan.
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The following procedure describes how to create an event plan.

NOTE: To avoid manually updating the events that the event plan generates, enter as much
information as possible in the event plan record before you save it for the first time.

To create an event plan
1 Navigate to the Site Map > Events > Event Plans view.

2 From the visibility filter, select All Event Plans.
3 In the Event Plans list, create a new record, and complete the necessary fields.
NOTE: As the event plan creator, you will automatically be selected as the primary team member.

Siebel Events Management automatically generates events for each day, including the start and
end dates for the parent event. To change the event frequency, in the More Info form, select an
event Frequency.

Setting Goals and Assumptions for an Event Plan

Each event plan can be associated with a set of goals and assumptions. Each goal is a metric against
which the performance of the plan will be measured, given certain quantitative assumptions.

To create a goal for an event plan
1 Navigate to the Site Map > Events > Event Plans view.

In the Event Plans list, select and drill down on the event plan.
Click the Plan view tab and then click Goals.

In the Goals list, create a new record.
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In the Metric field, select the appropriate value and complete the following steps based on that
choice.

m If the goal is a financial metric, in the Target Amount field, complete the target value for the
goal.

m  If the goal is s non-financial metric, in the Target Quality field, complete the target value for
the goal.

6 If known, in the Forecast Amount column, type the forecast value.

If you do not know the expected forecast value, leave the field empty and complete the field after
you have developed a forecast.

NOTE: If the goal has a number format of percentage be sure to type whole number values, not
decimal values. For example, an ROI goal of 15% should be completed at 15, not .15.

To create an assumption for an event plan
1 Navigate to the Site Map > Events > Event Plans view.
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In the Event Plans list, select and drill down on the event plan.
Click the Plan view tab and then click Goals.

In the Assumptions list, create a new record.
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In the Metric field, select the appropriate value and complete the following steps based on that
choice.

m If the goal is a financial metric, in the Target Amount field, complete the target value for the
goal.

m If the goal is s nonfinancial metric, in the Target Quality field, complete the target value for
the goal.

6 If known, in the Forecast Amount column, type the forecast value.

NOTE: If you do not know the expected forecast value, leave the field empty and complete the
field after you have developed a forecast.

Deal Roadshow Event Type (Financial Services Customers Only)

If you are a financial services customer, you can create an event with a Type = Deal Roadshow, you
can also select the specific deal with which the event is associated and make sure that the deal and
the event are not visible to others outside of your deal team. When you associate the event with the
deal, the security for the deal is inherited by that event. Users added to the employee list as
members of the event team will not be able to view the event unless they are first added to the deal
team.

Deal visibility is associated with an individual’s position and not with the individual user. Because
Siebel applications typically associate only one position with an employee, this association may affect
an employee who leaves a position as a member of the deal team to work in another department
within the company. A new employee would be assigned to that position, which may result in the
possibility that users could lose track of the old employee’s knowledge of the deal. This functionality
is required to comply with the securities laws in most countries.

NOTE: In order to limit visibility of a deal to designated deal team members, you must first select
the Secure Flag in the More Info form on the Opportunities Screen. You can designate deal team
members in the Sales Team field in your Siebel application. The primary deal team member is the
only one who can change the Secure Flag.

Associating a Deal Roadshow with a Specific Deal (Finance Services
Customers Only)
The following procedure describes how to associate a specific deal with an event.

To associate a deal roadshow with a specific deal
1 Navigate to the Site Map > Events view.

2 In the Events list, select and drill down on the event for which you want to associate the deal.

3 In the Event Details form, in the Deal Name field, click the select button.
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4 In the Opportunity dialog box, select Add, and then click OK.

Updating Event Plans

The following procedure describes how to make changes to an event plan.

To modify an event plan
1 Navigate to the Site Map > Events > Event Plans view.

2 In the All Event Plans list, modify the event by changing the necessary fields.

Changes made to the parent event will not automatically update in the events’ fields. You can
manually change event data from the Events view.

To delete an event plan
1 Navigate to the Site Map > Event Plans view.

In the All Event Plans list, select the event and click Delete.

CAUTION: If you delete an event plan, all events, sessions, and activities associated with it are
also deleted. Therefore, it is recommended that the only time events should be deleted is when
they are erroneously created. Otherwise, the status of the event should be set to Canceled to
indicate that it did not take place, and no more work needs to be done.

Creating Events

Events can be manually created or updated with an event plan. Events Management allows you to
manage and track the entire event process.

To create an event
1 Navigate to the Site Map > Events > Event Plans view.

From the visibility filter, select All Event Plans.
In the All Event Plans list, select and drill down on the Event Plan Name.

Click the Schedule view tab, and then click Events.
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In the Events list, create a new record, and complete the necessary fields.

NOTE: You can automatically generate events on the Event Plans form, using the Create Events
button.
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Table 6 and Table 7 describe some fields in the Events form.

Table 6. Selected Financial Customer-Specific Fields in the Events Form

Field Comments

# of Attendees

Allows you to maintain approximate attendance information.

Additional Product
Interest

A free-form text field to describe additional sectors, regions, additional
capitalization sizes, and other items of interest about the featured
investment security.

Asset Class

The asset class of the investment security featured by the event. For
example, if the event is called Global Bond Investing, then the featured
asset class would be Fixed Income (or Bonds).

Capitalization Size

Describes the relative size of the market capitalization of the featured
investment.

Deal Name

Name of the deal (IPO or other investment banking-related opportunity)
featured by the event.

External

A check box to indicate whether you an event to be visible to external

contacts through the Siebel Events Web site. If External is not checked
(value = FALSE), then no external contacts are able to see information
about the event through the Web site.

Fee Type

The fee is required for the event. Default values include Registration,
Voluntary, Donation, and None.

Industry

Describes the sector or industry group of the featured investment. For
example, if the event features an automobile company, then the Industry
value is Automobiles.

Preferences

Free-form field that allows you track any attendee preferences on an
aggregated basis. For example, in this field you might enter “Order 20
vegetarian meals.”

Project Code

Your company’s internal Project Code for the event.

Region Origin Describes the region in which the featured investment originates. For
example, if the event features an automobile company based in Japan,
then the Region Origin value is Asia.

Symbol The stock ticker or CUSIP of the featured investment.

Team The employees responsible for accomplishing event-related tasks,

including planning, hosting, and evaluating the event. By default, the
user who creates the event is automatically listed as the primary team
member. The primary team member or the system administrator can
designate a different employee as the primary team member. For more
information, see the procedure titled To create an event plan in the
“Updating Event Plans” on page 33 section.
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Table 7.

Field Comments

Selected Fields in the Event Form

Capacity

Approximate audience range projected for the event. This value is used
during registration to help determine whether or not maximum enrollment
for the event has been reached.

Display on Website

Specifies whether the event should be displayed on the Events Web site.

Description

A free-form text field to describe the event. Information entered here is
visible to prospective attendees as part of the Upcoming Events
information on the Home Page.

Current Registration
Fee

Fee to register for the event at the current date and time.

End

(Required) Date and time that the event ends. The end value cannot be
set to a date and time earlier than the Start value. Also, the end value
cannot conflict with parent (events, in the case of sessions or event plans,
in the case of events) start and end values.

Event Name

(Required) Name for the event that will be visible to internal and external
users.

Event Type (Required) Nature of the event. Typical values include Meeting,
Conference, Trade Show, Seminar, and so on. The list of values that
determines the available choices is EVENT_TYPE.

Fee Type The fee is required for the event. Default values include Registration,
Voluntary, Donation, and None.

Frequency The number of times the event takes place.

Host Employee

The employee responsible for the event.

Invitation Deadline

Date by which invitations for the event should be sent to prospective
attendees. Defaults to 60 days before the event Start.

Lead Partner

The partner company affiliated with the event.

Organization

Specifies which organizations have access to view the event. By default,
the event creator’s organization is added to this list as the primary
organization. For more information about organizations, the Siebel
Applications Administration Guide.

Promotional Fee

Discounted fee for registering before the promotion and date.

Promotion End

The date until which the promotional registration fee applies.

Standard Fee

Regular fee for registering into the event.

Session Template

Specifies the session template used to generate sessions.

Siebel Events Management Guide Version 8.1/8.2 35



Defining an Event B End-User Setup Procedures for Defining an Eve

Table 7. Selected Fields in the Event Form
Field Comments
Start (Required) Date and time that the event starts. The start value cannot be

set to a date and time later than the end value. For a new event, both
fields default to current date and time. The event automatically appears
on the Events Calendar for each date from the start through and the end.

Also, the start value cannot conflict with parent (events in the case of
sessions, event plans in the case of events) start and end values.

Status Status of the event. Values available by default are as follows:

B Planned. Visible only in administrative screens. Registration not
allowed.

B Launched. Visible in administrative screens and end-user screens.
Registration allowed.

B In Progress. Visible in administrative screens and end-user screens.
Registration allowed.

B Completed. Visible only in administrative screens.

B Cancelled. Visible only in administrative screens.

Team The employees responsible for accomplishing event-related tasks,
including planning, hosting, and evaluating the event. By default, the user
who creates the event is automatically listed as the primary team
member. The primary team member or the system administrator can
designate a different employee as the primary team member. For more
information, see the procedure titled To create an event plan in the
“Updating Event Plans” on page 33 section.

URL Location of a Web site providing more information about the event.

Venues Main location where the event is held, such as a hotel, conference center,
or office building. You associate venues with Companies.

After you create an event, you can associate one or more tracks with an event.

Updating an Event
Sometimes in the event planning process it is necessary to add or update information previously
recorded based on changes to the events.

To update an event
1 Navigate to the Site Map > Events > Event view.

2 In the Events list, select the event, and make the necessary changes.
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Adding Budget Details

As part of defining an event, you can create a budget for the event. The budget includes estimated
revenues and expenses. Then, as part of preparing for and hosting the event, you can enter actual
revenues and expenses. With this information, Siebel Events Management calculates budget
variances (estimated versus actual amounts) so you can analyze an event’s financial performance at
each level of the event—event plan, event, and session. This capability allows your company to
maintain a history of line item variances and budget accuracy over time.

NOTE: Expenses and revenues for events and sessions can be entered at any level in the hierarchy.

To enter estimated expenses or revenues for an event
1 Navigate to the Site Map > Events > Event view.

2 From the visibility filter, select All Events.
3 In the All Events list, select and drill down on the event for which you want to enter expenses.
4 Click the Plan view tab, and select the appropriate subview.
m  For estimated expenses, click the Expenses subview tab.
m  For estimated revenues, click the Revenue subview tab.
5 In the Expenses list, create a new record, and complete the necessary fields.

When you save the record, the Variance amount and running totals for Forecast Expenses and
Actual Expenses are updated at the bottom of the Expense List.

6 (Optional) To add invoice details to an expense record, create a new invoice record in the Invoices
screen, and make note of the invoice number for use in the remaining steps.

Some invoice record fields are described in the following table.

Field Comments

Type Select Payable. Invoices of type Receivable cannot be selected for cost
line items.
Invoice # This automatically generated number appears in the Invoice # field of

the Invoice Items list when you return to the event’s Cost view in
Step 7 on page 37.

7 Navigate back to the Invoice Line Items list for the event.
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Click Add in the Invoice # field to copy in the invoice information from the Invoices screen.

The following table describes some fields in the Invoice Line Items list.

Quantity The number of items associated with the cost line item.

Invoice A Yes or No value, based on whether or not a vendor will generate an
Expected? invoice.

Invoice Date The date the Invoice # is entered.

Invoice Status The status of the invoice. Typical values are Open, On Hold, Cancelled,

Consolidated, and Closed.

Vendor Invoice # The invoice number entered.

Vendor Name The account name of the vendor.

Cost Code An internal cost code associated with the line item.

Estimating Revenues
You can use Siebel Events Management to track revenue sources for an event. Revenue may come
from sources such as sponsorships, registration fees, advertising, and exhibitors.

To

a A 0w N PR

enter estimated revenues for an event
Navigate to the Site Map > Events > Event view.

In the Events list, select and drill down on the Event Name.
Click the Plan view tab, and then click Revenue.
In the Revenue list, create a new record, and complete the necessary fields.

(Optional) Associate the revenue with a session.

You can track expenses at the venue and vendor levels. Expenses created at the venue level, roll up
to the event and have a Cost Type = Venue. Expenses created at the vendor level, roll up to the event
and have a Cost Type = Vendor. For more information on creating expenses for a venue, see
“Researching and Choosing a Venue” on page 61. For more information on creating expenses for a
vendor, see “Researching and Hiring Vendors” on page 66.
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Financial Information for Events

Siebel Events Management provides summarized financial information at all three levels in the
hierarchy: Event Plans, Events, and Sessions. This information includes planning period, budget,
expenses, and revenues. Several of these fields are automatically calculated based on detailed
records that are created. See Table 8, Table 9, and Table 10 for more information about these fields.

Table 8. Fields Found on the Event Plans, Events, and Sessions Detail Applet.
Planning Period User entered
Execution Period User entered
Requested Budget User entered
Assigned Budget User entered
Forecast Expenses An autopopulated field that provides the sum of

expense records and forecast expense field

Actual Expenses An autopopulated field that provides the sum of
expense records and actual expense field

Forecast Revenue An autopopulated field and provides the sum of
revenue records and forecast revenue field

Actual Revenue An autopopulated field that provides actual
revenue. For more information see Siebel
Marketing User Guide.

Planning Period User entered

Table 9. Fields Found on the Event Plans and Events Detail Applet.

Field Comment

MDF Requested An autopopulated field that provides the sum of
MDF request

Net Expense (forecast) An autopopulated field that provides the Forecast
Expenses-MDF Requested

Table 10. Fields Found on the Event Plans Detail Applet.

Budget Request Assigned from the Budget Request in a marketing
plan; for more information, see Siebel Marketing
User Guide
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Approving Event Plans

During the event planning phase, marketing administrators may be required to submit high-level
event plans for approvals, as a part of the overall planning and budgeting process. Siebel Events
Management contains functionality for getting approvals, whereby users can collaborate on an event
plan by submitting the record to different individuals using the approval field. You can define further
control over the approval process through state models, see Siebel Assignment Manager
Administration Guide for further information.

To use the event plan approval field
1 Navigate to the Site Map > Events > Event Plans view.

2 In the Event Plans list, select the event.

3 In the Event Plan form, from the Approval Status field, click the drop-down list and select
Submitted.

4 In the Pick Employee dialog box, select the individual to whom you want to submit the plan.
5 Enter any additional comments, and then click Send.

The person to whom you have submitted the plan must log in to the Siebel application to approve
or reject the plan.

NOTE: You have the ability to track the history of approvals in the Event Plan > Plan > Approvals
view.

Adding Event Activities

An activity in Events Management is an action item, such as creating collaterals, that needs to be
assigned and completed prior to the start of an event. You enter these action items using the
Activities view tab in Siebel Events Management.

CAUTION: Some view tabs have names that closely resemble typical event action items, but which
are, in fact, reserved for the products of action items. For example, the Collateral view tab is where
collateral, a product, is stored after an individual creates collateral, an action. Use the Activities view
to list action items such as creating collateral and to assign them to specific individuals.

During this phase of event management, you enter activities for the event. Then, during the next
phase of event management, event preparation, you assign the activities to specific staff members,
and track activity progress.

When entering activities, you can enter records individually for each event, or you can create a
reusable activity template, which automatically associates a set of activities with any event you
choose.

You can also combine individual activities with activities from an activity template. If some activities
in an activity template do not apply to an individual event, you can remove them from the event
without affecting the template.

The following procedure describes how to create a reusable activity template for an event.
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To create an Activity Template for an event

1
2

To
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Navigate to the Site Map > Administration - Data > Activity Templates view.
In the Activity Templates list, create a new record.

a In the Name field, provide a name for the activity.

b In the Type field, select Event Management.

C Leave the Sales Stage and Sale Method fields blank, because they do not apply to Siebel Events
Management activities.

NOTE: Finance customers, be sure to select the Automatic Trigger check box to automatically
generate an activity list when the template is associated with an event.

Click the Activity Templates Details view tab.
In the Activity Template Details list, create a new record.
NOTE: Create a new activity for each activity associated with the activity template.

For information on creating activity templates, see Siebel Applications Administration Guide.

associate an Activity Template with an event
Navigate to the Site Map > Events > Event view.

From the visibility filter, select All Events.

In the Events list, select and drill down on the Event Plan Name.

Click the Schedule view tab, and then click Events.

Click the Plan view tab, and then click Activity Plans.

In the Activity Plans list, create a new record.

In the Template field, choose a predefined template from the drop-down list.
Complete other fields as needed.

Click the Activities link.

In the Activities list, drill down on the Type field to edit details of that activity.

The display changes from the Events screen to the Activities screen, and an Activity form and an
Attachments list are displayed.

The following procedure describes how to add an individual activity to an event.

To add an activity to an event

1
2
3

Navigate to the Site Map > Events >Event view.
In the Events list, select and drill down on the Event Name.

Click the Plan view tab and then click Activities.
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4 In the Activities list, create a new record, and complete the necessary fields.
A modified list of activities appears.

For more information on working with activities, see Siebel Applications Administration Guide.
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This chapter discusses how to organize, schedule, and assign the many tasks required to produce a
successful event. Specifically, the chapter provides procedures for organizing and staffing sessions,
and associating each session with a track. In addition, you can add detailed activities and assign
them to event staff. The chapter also describes other preparation tasks for physical aspects of the
event site and provides procedures for involving external parties, such as vendors and speakers.

This chapter includes the following topics:

B “Event Preparation Tasks” on page 43

B “Business Scenario for Preparing for an Event” on page 44

B “Example Process Flow for Preparing for an Event” on page 45
|

“End-User Procedures for Preparing for an Event” on page 45

Event Preparation Tasks

A large number of interdependent tasks must be carried out during preparation for an event. In this
chapter, these tasks are grouped into the following categories:

Track management tasks
Activity management tasks
Information preparation tasks

Site preparation tasks

Other tasks

The grouping and sequence of tasks presented in this chapter are arbitrary. The order in which end
users and event managers choose venues, vendors, partners, and speakers may vary by company
and by event. You may be able to confirm session information, locations, and schedules early in the
event management process, or you may need to adjust session characteristics shortly before and
even during the event.

NOTE: Because the order of event preparation tasks varies, it is recommended that you read this
entire chapter at the beginning of your event planning and preparation process. This information
allows you to approach event preparation with an appropriate sequence and schedule for an event.
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Business Scenario for Preparing for an
Event

This scenario provides an example of a process flow performed by an event planner. Your company
may follow a different process flow according to its business requirements.

NOTE: This scenario continues the example from “Business Scenarios for Defining an Event” on
page 17,

At this stage, the event planner has defined several tracks for the event. Now, the event planner
completes the following track management tasks:

B Identifying the sessions that make up each of these tracks and associates the sessions with their
respective track

B Associating related tracks with one another
Next, the event planner completes the following activity management tasks:
B Adding staff to events and sessions

B Assigning event staff members to various activities, and then monitoring the progress of those
activities

Concurrent with the activity management tasks, the event planner completes the following
information preparation tasks:

B Adding sessions to events

B Confirming that there are no unintentional gaps or overlaps in the timing of sessions, by viewing
session schedules

B Adding speakers to sessions

B Publishing event information to a Web site

B Preparing event collaterals and adds specific collateral to the appropriate events and sessions
Next, the event planner completes the following site preparation tasks:

B Choosing a venue and enters room information

B Adding information about the equipment available in an event venue room

B Entering a location for a event venue.

E Because the location is a hotel where special rates are available for event attendees, the
event planner also associates the venue rate codes with the event.

m After entering the venue and its rate codes, she can enter venue billing information.

m After entering locations as event venues and having entered rooms associated with those
locations, she assigns specific rooms to individual sessions within the event.

These are just some of the many tasks that the event planner performs to prepare for an event.
Other preparation tasks include associating partner organizations and vendors with events or
sessions, recording billing parameters for event vendors, entering vendor discounts and other special
rate codes, and attaching files to events.
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Example Process Flow for Preparing for

an Event

Figure 2 is based on recommended end-user procedures for event preparation in Siebel Events
Management.

Track Wlanagement Tashs

Activity Management Tashs

Freparing Sessions

“Wenue Preparation Tasks

Third-FParty T ashs

Inwiting Contacts and
Frospects

Freparing Event Status
Feports

Figure 2. Process Flow for Event Preparation End-User Procedures

End-User Procedures for Preparing for
an Event

This section discusses following tasks shown in Figure 2:
B Track Management Tasks

B Activity and Staff Management Tasks

B Preparing Sessions
|

Venue Preparation Tasks
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B Third-Party Tasks
B Inviting Contacts and Prospects to an Event

B Preparing Event Status Reports

Track Management Tasks

As described in Chapter 4, “Defining an Event,” a track in Siebel Events Management is a featured
topic or theme at an event. For example, a biotech investment conference may establish three
tracks: Genomics, Computers, and Pharmaceutical.

In Chapter 4, “Defining an Event,” you created tracks and associated them with events. In this
chapter, you complete the following additional track-related tasks:

B Associating tracks with events and sessions. Identify a track that needs to have one or more
sessions associated with it, and then select those sessions from a list.

B Associating related tracks. Select a track, identify other tracks that are related to the selected
track, and then associate those related tracks with the selected track.

B Using the Tracks Calendar. Select an event and view all of the event’s tracks, and all of the
sessions that make up those tracks, side by side in a day-planner format.

B Associating contacts with a track. Create a list of the members in a given track by selecting
contacts and associating them with the track.

B Viewing track members. View a list of the contacts associated with a track.

Associating Tracks with Events and Sessions
A track is typically comprised of one or more sessions. Therefore, after creating tracks and
associating them with events, you need to add one or more sessions to each track of the event.

NOTE: Tracks can be related to one another.

The following procedure describes how to associate one or more sessions with a track.

To associate one or more sessions with a track
Navigate to the Site Map > Events > Tracks view.

In the Tracks list, select the track with which you want to associate the session or sessions.
Drill down on the Track Name.
Click the Related Events view tab.

In the Related Events list, create a new record.
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To associate the track with a session within the event, in the Sessions list, create a new record.
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Associating Related Tracks
After creating tracks, you may find it helpful to associate one or more related tracks to a given track.

The following procedure describes how to associate related tracks to events.

To associate related tracks
1 Navigate to the Site Map > Events > Tracks view.

2 In the Tracks list, select the track with which you want to associate.
3 In the Track form, click the select button in the Related Tracks field.

After you have associated related tracks, the Related Tracks field in the More Info form shows the
name of one of the related tracks.

To view all related tracks
B To view all of the related tracks, click the select button in the Related Tracks field.

Using the Track Calendar

Using the Track Calendar, you can view the scheduled sessions for several tracks side by side in a
day-planner format.

The following procedure describes how to use the Track Calendar.

To use the Track Calendar

1 Navigate to the Site Map > Events > Event Plans view.

2 From the visibility filter, select All Events.

3 In the All Events list, select and drill down on the Event Plan Name.
4 Click the Schedule view tab and then click Events.

5 In the Events list, drill down on the Event Name.

Click the Schedule view tab, and then click Track Calendar.

Alternatively, you can view track-related events, sessions, and members in the standard list and form
views by choosing the corresponding view tabs on the Tracks screen.

Associating Contacts with a Track
The following procedure describes how to associate contacts with a track.

To associate contacts with a track
1 Navigate to the Site Map > Events > Tracks view.

2 In the Tracks list, select and drill down on the track with which you want to associate the contact.
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3 Click the Members view tab.

4 In the Members list, create a new record, and complete the necessary fields.

Viewing Track Members

The following procedure describes how to view the contact that are associated with a track, or track
members.

To view track members
1 Navigate to the Site Map > Events > Tracks view.

2 In the Tracks list, select and drill down on the Track Name.

3  Click the Members view tab.

Activity and Staff Management Tasks

An activity in Events Management is an action item, such as create collateral, that needs to be
assigned and completed prior to or during the event.

In Chapter 4, “Defining an Event,” you created activity templates (optional) and added activities to
events. In this chapter, you can follow-up by adding staff, which includes speakers, and assigning
them to sessions and specific activities. After activities are assigned, you can use your Siebel
application to monitor the progress of activities.

Adding Staff to an Event or a Session

The Staff view in the Events and Sessions screens provides a quick way to add information about
individuals with event responsibilities, including both employees and nonemployees, such as
speakers, contractors, and vendors. While you are adding staff, you can reference the Staff Calendar
to view the availability of staff members and speakers.

It is a good business practice to add staff members as contacts and their organizations as accounts
before you define the event staff. See Chapter 4, “Defining an Event,” for more information.

The following procedure describes how to add an existing employee or contact to an event.

To add a staff member to an event
Navigate to the Site Map > Events > Event Plans view.

In the Events list, select and drill down on the Event Plan Name.
Click the Schedule view tab, and then click Events.
In the Events list, select and drill down on the event to which you want to add a staff member.

Click the Resources view tab, and then click Staff.
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In the Staff list for the event, create a new record, and complete the fields.
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The following procedure describes how to add a staff member to an individual session. After a staff
member is added, the session appears on the staff member’s calendar.

To add a staff member to a session
Navigate to the Site Map > Events > Event Plans view.

In the Events list, select and drill down on the Event Name.
Click the Schedule view tab, and then click Sessions.
In the Sessions list, select and drill down on the session name.

Click the Resources view tab, and then click Staff.
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In the Staff list, create a new record, and complete the fields.

The following procedure describes how to view staff member and speaker availability.

To view staff availability
1 Navigate to the Site Map > Events > Event Plans view.

2 From the visibility filter, select All Events.

3 In the Events list, select and drill down on the event name for which you want to check staff
availability.

4 Click the Schedule view tab, and then click Staff Calendar.
The Staff Calendar appears. All staff members, speakers, and contacts associated with an event

or session appear in the top row of the calendar, and the time slots they are currently assigned
are highlighted in yellow on the calendar.

To view speaker availability
Navigate to the Site Map > Events > Event Plans view.

From the visibility filter, select All Events.

In the Events list, select and drill down on the event name for which you want to check staff
availability.

4 Click the Schedule view tab, and then click Speaker Availability.

Working with Event Activities

Event activities are assigned to event team members—employees from the event-hosting
organization who have operational responsibilities for event planning, preparation, and
implementation. Some activities may be more appropriately assigned to people outside the event-
hosting organization, such as vendor or venue representatives, or organizational employees who are
not on the event team. Together, event team members and other people with event responsibilities
are called event staff.
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In order to assign an event to an event staff member using Siebel Events Management, the individual
must be listed in the Siebel System Person table.

NOTE: An activity related to an event is assigned in the Events list, not in the Sessions list, even if
it is for a particular session within the event.

To assign an event activity
Navigate to the Site Map > Events > Event view.

In the Events list, select and drill down on the Event Name.

Click the Schedule view tab, and then click Events.

In the Events list, select and drill down on the event for which you want to assign an activity.
Click the Plan view tab, and then click Activities.

In the Activities list, select and drill down on the Type field.
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Do one of the following:

m If you are assigning this activity to an employee of your organization, in the Employees field
of the Activity form, click the select button and select an employee.

m If you are assigning this activity to a contact outside your organization, in the Contacts field
of the Activity form, click the select button and select a contact.

Monitoring Progress on Event Activities

You can use Siebel Events Management to update and monitor the progress of event activities. The
view tab you use to enter and view activity information depends on whether a given activity is part
of an Activity Plan or a stand-alone activity. The following procedure describes how to track activities.

To monitor progress of event activities
1 Navigate to the Site Map > Events > Event Plans view.

2 In the Events list, select and drill down on the Event Plan Name.
3 Click the Schedule view tab.
4

In the Events list, select and drill down on the event for which you want to monitor activity
progress.

al

Click the Plan view tab, and then click Activities.
Use one of the following methods to display activity details:

m  For individual activities that may or may not belong to any Activity Plan, click the Activities
link.

m  For activities that you want to view in the context of an Activity Plan, click the Activity Plans
link.

In each case, the display changes to include an Activities list that displays status information.
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7 Select an activity to update and complete the necessary fields.

Preparing Sessions

Most business events involve the presentation of information. The amount and type of information
presented varies across events, as do the means of presentation. This section describes the
processes for organizing the information for presentation, choosing speakers for the event, and
preparing collateral for distribution during the event.

This section provides material on how to prepare information for an event. Later sections of this
chapter provide information about venues, equipment, budgets, vendors, and other aspects of event
preparation and implementation.

Basic Questions for Event Organizing
In the course of organizing the information for an event, you may find it useful to consider the
following questions:

B What kind of audience do you hope to reach?

B What professional challenges do members of your audience face?

B How will the information help the audience meet its challenges?

B What is the size of the audience you intend to reach?

B What kind of presentation will your audience find most useful and appealing?
For example, is your information appropriate for a lecture format, a hands-on workshop, a
demonstration, and so on?

B How long will it take to present the information?

What equipment, such as computers, projectors, projection screens, slides, sound systems, and
telephone or network wiring, will you need for your presentation?

B What collateral item do you want audience members to take with them from the event?
B  What resources (human and monetary) do you have for the event?

Having at least tentative answers to these questions helps you decide on the basic structure of an
event, including session type and length, speakers, and collateral.

Creating and Using Sessions

During event preparation, you need to establish sessions within events, allowing attendees to choose
which presentations to attend. It is not mandatory to create sessions for an event with only one
presentation, but creating sessions allows an attendee to synchronize to their personal calendar.
Additionally, you can associate a speaker with one or more sessions, but not with events. You can
also record feedback received on a session using the session’s Feedback Form, as described in
“Adding a Session to an Event” on page 52.
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Adding a Session to an Event
After you create an event plan, your Siebel application generates the events. You can add one or
more sessions to an event.

To add a session to an event
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Navigate to the Site Map > Events > Event Plans view.

In the Event Plans list, select and drill down on the event to which you want to add a session.
Click the Schedule view tab, and then click Events.

In the Events list, select and drill down on the Event Name.

Click the Schedule view tab and then click Sessions.

In the Sessions list, create a new record.

The session record inherits the start date and end date from the event. Modify the Start and End
fields as necessary.

NOTE: A session’s start and end times cannot be outside the range of its Event Plans start and
end times.

Drill down on the Session Name.

In the Session form, complete the necessary fields.

To associate a venue with the session, click the select button in the Venue field.

To associate a room with the session, click the select button in the Room field.

NOTE: Repeat this procedure for each additional session you want to add to the event.

The following table describes some of the fields in the session form.

Field Comments

Session Fee Any fee specific to the individual session, in addition to the event
Registration Fee. This field may not be displayed in the Sessions list by
default, but can be made visible by using the Columns Displayed command.

Comments A text field for notes related to the session. Visible to administrators only.
This field may not be displayed in the Sessions list by default, but it can be
made visible by using the Columns Displayed command.

Description A description of the session. Information stored in this field is visible to
potential event attendees who request detailed information about the
session.

Dress Code The recommended session attire. Values available by default include

Business Casual, Business Professional, Black Tie, Sport, and Casual. This
field may not be displayed in the Sessions list by default, but it can be made
visible by using the Columns Displayed command.

LOV Type: EVENT_DRESS_CODE
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Field Comments

End (Required) The date and time when the session ends. This field defaults to
the value of the End field for the event.

Fee Type A description of the kind of fee noted for the session in the Additional Fee
field, if any. Typical values include Donation, None, Registration, and
Voluntary. This field may not be displayed in the Sessions list by default, but
it can be made visible by using the Columns Displayed command.

Feedback Form An optional field for entering feedback received about the session.

Format The type of session. Values available by default include Keynote, Lecture,
Panel, and so on.

LOV Type: EVENT_FORMAT

Session The maximum number of people who can attend the session. This field may

Capacity not be displayed in the Sessions list by default, but can be made visible by
using the Columns Displayed command. If a value is specified for Room, this
field defaults to the capacity of the room. If no value is specified for Room,
this field defaults to the Event Capacity value for the event. For more
information about entering room characteristics, see the procedure titled To
enter room information for a potential event venue in the “Creating Venues”
on page 27 section.

Session Name (Required) A name to identify the session.

Related One or more other sessions that cover related information. Available values

Sessions are all sessions for all events. This field may not be displayed in the
Sessions list by default, but can be made visible by using the Columns
Displayed command.

Room The specific room in the venue where the session is held. This field may not
be displayed in the Sessions list by default, but can be made visible by using
the Columns Displayed command. Available values depend upon
information entered under the Rooms view tab of the Accounts screen. For
more information about completing this field, see Step 10 on page 52. For
more information about entering room characteristics, see the procedure
titled To enter room information for a potential event venue in the “Creating
Venues” on page 27 section.

Start (Required) Date and time when the session starts.

Status The status of the session. Values available by default include Planned,
Launched, Completed, and Cancelled.

LOV Type: EVENT_STATUS_CODE

Venue The location or facility where the session is held, which may or may not be
related to primary venue for the event. For more information about
specifying a venue, see Step 9 on page 52.
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Creating and Using Session Templates
Sessions can also be generated automatically using Session Templates. This feature reduces the
amount of data entry required when setting up multiple events with similar session schedules.

To create a session template
1 Navigate to the Site Map > Marketing Templates > Session Templates view.

2 In the Session Templates list, create a new record, and complete the necessary fields.
3 In the lower list, create a new record, and complete the necessary fields.

Repeat the above step for each session template created.

To use a session template
1 Navigate to the Site Map > Events > Event view.

2 In the Events list, select and drill down on the event.

3 In the Details form, from the Session Template field, click the select button.

4 In the Sessions dialog box, select the session, and click OK.

NOTE: You can only apply a Session Template to an event if no sessions already exist for that event.

You can add a group of sessions to an event using a session template. As application administrator,
you must set up a session template before you can associate it with an event, see Chapter 4,
“Defining an Event.”

NOTE: You cannot apply a template to an event that already has existing sessions. If you want to
change the template or reapply it, you must delete all existing sessions, delete the template from
the event, save the record, and the reselect the template.

To associate a session template with an event
1 Navigate to the Site Map > Events > Event view.

2 In the Event list, select and drill down on the event.
3 Click the Schedule view tab, and then click Sessions.
4 In the Sessions list, create a new record.
5

In the Sessions list, click the select button in the Session Template field to select a session
template.

To see the session associated with the event
B Click the Schedule view tab, and then click Sessions.

NOTE: The Validate Session button in the Sessions view can be used to check for schedule conflicts
across all sessions in a single event. If one or more sessions have time values that overlap, an error
message appears. This button is particularly useful when managing large events with many
sequential sessions.
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Viewing Session Schedules and Attendees

This section describes procedures for viewing session schedules and attendees. You can view session
schedules using the Session Time Line. This method is helpful for confirming that there are no
unintentional gaps or overlaps in the timing of sessions. You may also view a session’s list of
attendees to determine the session’s popularity or for informational purposes.

The following procedure describes how to view the Session Time Line.

To view the Session Time Line
1 Navigate to the Site Map > Events > Event Plans view.

Z In the Event Plan list, select and drill down on the event.
3 Click the Schedule view tab, and then click Events.
4

In the Events list, select and drill down on the event for which you want to check session
scheduling.

5 Click the Schedule view tab, and click Session Time Line.

The following procedure describes how to view only the available sessions for an overall event.

To view only the available sessions for an event
1 Navigate to the Site Map > Events > All Events view.

2 In the Events list, select and drill down on an event.
3 Click the Schedule view tab, and then click Sessions.
4 In the Sessions list, confirm that Status is set to Open.

The following procedure describes how to view a list of session attendees.

To view session attendees
1 Navigate to the Site Map > Events > Sessions view.

2 In the Sessions list, select and drill down on the session name for the session for which you want
to view attendees.

3 Click the Participants view tab, and then click Attendees.
To see a list of all companies registered for a session, click the Company Attendees link.

NOTE: Registering a contact automatically registers that contact’s company.

Assigning Rooms to Sessions

After you have designated one or more locations as event venues and have entered rooms associated
with those locations, you can assign specific rooms to individual sessions within the event. The
following procedure describes how to assign a room to a session.
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To assign a room to a session
1 Navigate to the Site Map > Events > Sessions view.

2 In the Sessions list, select the session to which you want to assign a room.
3 In the Session form, review the current value in the Venue field.
If necessary, select another venue that is associated with the selected event.

4 In the Room field, select a room.

Researching and Organizing Speakers

Siebel Events Management provides you with the ability to designate one or more speakers per
session. Speakers must be members of the event staff, with speaker as their selected role. They can
be employees of the event-hosting organization, or they can be persons from outside organizations.
They may or may not be registered as event attendees, according to your preference. Speaker
information is always stored in relation to a specific session, rather than to an event plan or event.

Adding Speakers to Sessions
The following procedure describes how to add one or more speakers to a session within an event.

When adding a new session staff member with a role of speaker, or changing the role of an existing
session staff member to speaker, Siebel Events checks for overlapping speaking engagements for the
staff member based on the session start and end date. If the speaker is booked for more than one
session at the same time, it displays an error message and prevents the record from being saved.

To add speakers to a session
1 Navigate to the Site Map > Events > Sessions view.

2 In the Sessions list, select and drill down on the session for which you want to specify one or
more speakers.

3 Click the Resources view tab, and then click Staff.
In the Staff list, create a new record, and complete the necessary fields.

E Be sure to select Speaker from the Session Role drop-down list to designate this person is a
speaker for the event.

m The Status field indicates whether or not the speaker has been confirmed to speak at the
event. It does not indicate the speaker’s registration status as an event attendee.

B You can only select session staff members who were previously created in the parent event.

Viewing Session Tracks
You can use the Session Track view to associate tracks to sessions. The following procedure describes
how to view tracks that are associated with a specific session.
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To view tracks associated with a specific session
1 Navigate to the Session Tracks view.

The Tracks list displays all the tracks that the session belongs to.

2 Click the Tracks Name to sort the list.

Publishing Event Information to a Web Site

If your company has purchased the optional Siebel Events for Finance module, you can prepare your
event information for Web site publication.

The combination of Siebel Events Management settings affect whether or not information in the
Events and Sessions screens is visible to prospective event attendees on the Web site. These settings
are as follows:

The status of the event

The start date of the event

The type of event

The Registration Status of the prospective attendee

The Registration status of the company of the prospective attendee

The External flag setting

Both the Event and Session Details forms have check boxes labeled Display on Website. These
check boxes default to true. You can use Display on Website check boxes to designate internal
events and sessions that should not be published to the Web site or events or sessions for which
only an administrator can register attendees:

m If you clear an event’s Display on Website check box, the event and its sessions are not
displayed on the Web site, regardless of the status, date, or type.

m If you clear a session’s Display on Website check box, the session is not displayed on the Web
site.

The following procedures describe how to choose settings for the visibility you want.

To make event information visible to all
Navigate to the Site Map > Events > Event view.

In the Events list, select an event.
Set the Status field to Launched.
Set the Start field to a date in the future or to today’s date.

Verify that Type is not set to Restricted.
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Verify that the Display on Website check box is selected.
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To make event information visible to invitees and administrators
1 Navigate to the Site Map > Events > Event view.

In the Events list, select an event.
Set the Status field to Launched.

Set the Start field to a date in the future or to today’s date.
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Set Type to Restricted.

NOTE: Events of type Restricted are not displayed in the customer site except to attendees who
have been explicitly invited to the event. The attendee can view open invitations from the home
page by clicking the View My Open Invitations link and can then accept an invitation by
registering for the event.

To make event information visible to invited company employees (for Finance
customers only)

1 Navigate to the Site Map > Events > All Events view.
In the Events list, make sure the External column check box is selected.
In the Event form, set the Status field to Launched.

Set the Start Date field to a date in the future or to today’s date.
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Make sure the Event Type field is not set to Restricted.

To make event information visible to internal employees
Navigate to the Site Map = Events > All Events view.

In the Events list, make sure the External column check box is not selected.

In the Event form, set the Status field to Launched or Planned.
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Set the Start Date field to a date in the future or to today’s date.

To make event information visible to administrators only
B Set Status to any value except Launched, or set Start to a date earlier than today’s date.

If an event is visible, then the sessions related to it can be visible or not based on the value in
the Status field in the session itself. As with events, a status of Launched allows all users to see
the session information.

Creating and Using Web Banners

Event managers can use the Web banner functionality to publish rich HTML content describing a
particular event on the Events Web site. HTML templates can be created in Web tools such as Adobe
GolLive or Microsoft Front Page, and then stored in the Siebel file system for use as an event Web
banner. The Web banner can also be edited in Siebel Events Management within a WYSIWYG
environment, without requiring knowledge of HTML tags. This capability allows added control over
the look and design of the event detail view by business users.
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To create a Web banner

1 Develop your Web banner in an external editor or notepad to create a blank HTML file.
2 Navigate to the Site Map > Events > Web Banner Templates view.

3 In the Web Banner Templates list, create a new record, and complete the necessary fields.

To use a Web banner
Navigate to the Site Map > Events > Event view.

In the Events list, select and drill down on the event.

Click the Resources view tab and then click Web Banner.
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In the Web Banner form, create a new record, and in the Template Name field, click the select
button.

5 From the Pick Event Template dialog box, select the template, and click OK.
6 In the Web Banner form, click Save Template.

NOTE: Graphics and other files referenced by the HTML must be accessible for the Web server that
is hosting the Siebel Events Web site.

Using Siebel Microsites

Similar to Event Web Banners, Microsites can be used to control the look and feel of the event detail
view in the registration Web portal. Microsites, however, offer more capabilities in the area of content
management. Event managers can use Microsites instead of Web banners if they require these
capabilities.

Many companies have multiple content managers whose responsibilities include adding and
modifying data on Web pages. The layout and maintenance of data and hypertext links needs to be
done as efficiently as possible, without requiring IT resources. The Microsite Management module is
designed to simplify creation and maintenance of Web pages. Everything from site organization and
creation of new pages through to editing text and graphics is carried out from the Microsite
Management screen.

To use a Microsite with an event
1 Navigate to the Site Map > Events > Event > Details view.

2 In the Events form, copy the name in the Event Name field.

You will use this information when creating a Microsite page.
3 Navigate to the Site Map > Administration - Microsite > Page Administration view.
4 In the Page Administration, click Create New Page.

The Create New Page dialog box appears.

5 In the Parent Page field, click the multiple select button to select the Siebel Events Information.
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6 In the Default View field, click the multiple select button to select the eEvents Event Detail
Microsite View.

7 In the Title field, enter or paste the name of the Event that you want the Microsite to be
associated with.

NOTE: The text in this field has to match the name of the event exactly.
8 Click OK.
9 Click the Page Title link of the new page.

10 In the Page Administration form, add the HTML-based content to the Microsite page to be
displayed in the event registration Web portal.

NOTE: You can also have a single Microsite page for all Events within an Event Plan. When creating
the Microsite page, use the Event Plan name. Do not create a Microsite for the Events within the
Event Plan. The events Web portal first checks for event-level microsite pages to display, then checks
for Event Plan-level Microsite pages to display, and finally checks for Web banners to display.

Preparing Collateral

Another aspect of organizing information for an event is preparing literature such as brochures, white
papers, presentation handouts, trade show exhibit maps, and so on. Collectively, such literature is
known as collateral. Collateral can be a Web page URL or a file.

You can manage collateral preparation using activities in Siebel Events Management. After collateral
is prepared, those electronic files, as well as vendor and venue contracts, can be stored in the Siebel
Events Management.

Adding Collateral to an Event or a Session
You can use Siebel Events Management to store collateral for an event or for a specific session.

To add a collateral item to an event or a session
1 Navigate to the Site Map > Events > Events or Sessions view.

2 In the Events or Sessions list, select the event or session with which you want to associate
collateral.

Click the Resources view tab, and then click Collateral.
In the Collateral list, create a new record.

Complete the necessary fields.
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To attach a file to the record, click the select button in the File field to display the Add Attachment
dialog box, and then follow these instructions:

a  Click Browse to display a Choose File dialog box.
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b  Use standard Windows techniques to select the file you want to designate as collateral, and then
click Open.

The Choose File dialog box closes, and the name of the selected file appears in the File Name
field of the Add Attachment dialog box.

c  Click Add.

The Add Attachment dialog box closes, and the name of the selected file appears in the File
field of the Collateral form in the main window.

Venue Preparation Tasks

Event management requires site preparation. This section provides information about preparing the
event site. Preparing the event site requires several tasks, including researching and choosing a
venue, assigning rooms within a venue to individual sessions, arranging for needed materials, and
setting up the site just before the event begins.

Researching and Choosing a Venue

A venue is a physical facility where an event may be held, such as a conference center or hotel. In
Siebel Events Management, you can store information about possible venues ahead of time, including
their rental rates, and later choose which venue or venues to associate with an event. An event can
be associated with multiple venues. A session within an event can be associated with only one venue.

During or after an event, you can enter review comments about how well each selected venue
functioned for your event. These comments can be useful for planning future events.

The following procedure lets you record information about the equipment that is available in a
potential room for an event.

To enter a location for an event venue
Navigate to the Site Map > Events > Event Plans view.

In the Event Plans list, select and drill down on the event for which you want to enter a venue.
Click the Schedule view tab, and then click Events.
In the Events list, select and drill down on the event.

Click the Resources view tab, and then click Venues.
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In the Venues list, create a new record.

NOTE: You can also select a venue on the Details form’s Venue field on both Events and Sessions
lists.

After you enter a location as an event venue, you can specify venue rate codes for an event. If the
venue is a hotel where event attendees stay, or—if you do business with the venue regularly—you
may have negotiated special rates for hotel rooms, conference rooms, and so on. Special rates may
be associated with codes that attendees or event managers mention to the venue representative.
The following procedure describes how to store information about venue rate codes.
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To associate venue rate codes with an event
1 Navigate to the Site Map > Events > Event Plans view.

2 In the Event Plans list, select and drill down on the event for which you want to record venue
rate codes.

Click the Schedule view tab and then click Events.

In the Event list, select and drill down on the event.

Click the Resources view tab and then click Venues.

In the Venues list, select the venue for which you want to enter information.

Scroll down to the Billings list and select Rate Codes from the drop-down list.
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In the Rate Code list, create a new record.

The following table describes some fields in the Rate Code list.

Field Comments

Code The code to mention to the venue representative in order to receive the special
rate, such as SEBL123.

Comments A text field to record other information, such as Customer must mention rate
code at time of check-in.

Name A name of your own choosing, to identify the rate code, such as Marriott
Siebel User Week Promotion.

Type A description of the special rate, such as 20% discount off lodging rates.

At any time during the event management process, you can enter review comments regarding the
venues you are working with. For example, you might want to note the name of a particularly helpful
venue representative, or mention that a particular work crew might need closer supervision if the
venue is reused for a future event. For more information about entering reviews, see “Entering Venue
and Vendor Performance Reviews” on page 109.

Entering Venue Expense and Billing Information

After you have entered a location as an event venue and optionally specified venue rate codes for an
event, you can enter venue expense and billing information. Expense records created at the venue
level roll up to the event, with a Cost Type = Venue. Venue billing records are a detailed breakdown
of a single venue expense record, indicating room and room rate information.

To enter venue expense information
1 Navigate to the Site Map > Events > Event Plans view.

2 In the Event Plans list, select and drill down on the event plan for which you want to enter venue
expense information.

3 Click the Schedule view tab, and then click Events.
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To enter venue billing information
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In the Events list, select and drill down on the event.

Click the Resources view tab, and then click Venues.

In the Venues list, select the venue for which you want to enter expense information.
Scroll down to the Expense list, and create a new record.

In the Expense list, complete the necessary fields.

Navigate to the Site Map > Events > Event Plans view.

In the Event Plans list, select and drill down on the event for which you want to enter billing
information.

Click the Schedule view tab, and then click Events.

In the Events list, select and drill down on the event.

Click the Resources view tab, and then click Venues.

In the Venues list, select the venue for which you want to enter billing information.

Scroll down to the Expense list and select the expense for which you want to enter billing
information.

NOTE: An event must have a venue before you can add a venue to its session. Rooms can only
be selected after a venue for the session is selected.

Scroll down to the Billing subview, and create a new record.

The following table describes some fields in the Billing list.

Field Comments

Room A required field that displays the rooms available within the venue. You can
select a room from the dialog box.

Billing Basis A value for the interval at which the room use is charged. The drop-down list
displays typical values of Per Person, Per Item, Hourly, Daily, Weekly, and so
forth.

Billing Rate The negotiated rate from the account screen for the venue. You can edit the
billing rate amount.

Quantity A value for the number of rooms within the venue.

Flat Fee The flat charge for the room. For example, there may be a setup or booking
charge that is not reflected in the Billing Basis or Billing Rate fields.

Total Cost The actual room cost calculated by multiplying the billing rate times the
quantity plus the flat fee. {(Rate*Quantity)+Flat Fee}

Comments A text field for other information associated with the billing record.
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After you create one or more billing records, you can update the actual cost of the parent expense
record to reflect the total cost of the billing records.

To update the actual cost of the expense record
1 Navigate to the Site Map > Events > Event Plans view.

2 Inthe Event Plans list, select and drill down on the event plan for which you want to update venue
expense information.

Click the Schedule view tab, and then click Events.
In the Events list, select and drill down on the event.
Click the Resources view tab, and then click Venues.

In the Venues list, select the venue for which you want to update expense information.
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Scroll down to the Expense list, and click Update Actual Cost.

Setting Up at the Venue

When you have chosen a venue, assigned rooms to sessions, and arranged for materials, most of
the remaining preparation activities take place onsite, within a few hours of the start of the event.
Onsite activities may vary across events, but the following list includes some typical setup activities:

Setting up chairs
Setting up and testing computers
Setting up and testing audiovisual equipment

Setting up collateral displays

Setting up a check-in area for registered attendees
Setting up a registration area for walk-in attendees

Siebel Events Management does not provide special screens, lists, or forms for onsite setup tasks.
Use the Activities list to plan and track these actions, as described in “Activity and Staff Management
Tasks” on page 48.

Third-Party Tasks

This section describes how to use Siebel Events Management to collaborate with partner
organizations, work with event vendors, attach files to an event, invite potential attendees, and
generate event status reports.
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Collaborating with Partner Organizations

When your organization prepares for an event, you may find it useful to collaborate with a partner
organization that may benefit from sponsoring an aspect of the event. A partner may sponsor the

event through financial support, or may provide services, equipment, speakers, and so on. A partner
organization may be associated with an event or an individual session. Siebel Events Management
provides lists and forms to help you keep track of partner commitments.

The following procedure describes how to associate a partner organization with an event. This
procedure assumes that the partner organization has already been added through the Partners
screen in your Siebel application.

To associate a partner organization with an event
1 Navigate to the Site Map > Events > Event Plans view.

2 In the Event Plans list, select and drill down on the event for which you wish to associate a
partner organization.

Click the Schedule view tab, and then click Events.
In the Events list, drill down on the event name.

Click the Participants view tab, and then click Partners.
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In the Partners list, create a new record, and complete the fields.

To associate a partner organization with a session
Navigate to the Site Map > Sessions view.

In the Sessions list, select and drill down on the session for which you wish to associate a partner
organization.

3 Click the Participants view tab, and then click Partners.
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4 In the Partners list, create a new record, and complete the fields.

For sessions, by default, the Role, Value, and Partner Status fields display the values for the
corresponding partner record for the event. You can change these values at the session level
without affecting the partnership data at the event level.

The following table describes some fields in the Partners list.

Field Comments

Role The role of the partner organization. Typical values include Exhibitor, Sponsor,
Co-Host, Advertiser, Partner, Strategic Partner, Premier Partner, Base Partner,
Gold Sponsor, Silver Sponsor, and Bronze Sponsor.

LOV Type: EVENT_PARTNER_ROLE

Partner The status of arrangements with the partner organization. Typical values

Status include Offered, Requested, Paid, Fulfilled, and Pending. Offered means that
the partner organization has offered to be a partner. Requested means that
the event-hosting organization has asked the partner organization for a
partnership.

Value The monetary value of the partner organization’s commitment.

Researching and Hiring Vendors

Previous sections describe event-related goods and services that are provided either by your own
organization or by the venue or venues where the event is held. One additional category of providers
remains to be discussed—good and services vendors who are neither in your own organization nor
affiliated with an event venue.

In Siebel Events Management, the procedures for working with vendors are quite similar to those for
venues, except that the goods or services vendors provide are not as closely related to specific
physical locations.

As with venues, a vendor can be associated with an event or a session. To associate a vendor with
one or more sessions, you must first associate it with the event.

In preparation for working with vendor data, you should enter possible vendors as accounts. The
Accounts screen allows you to enter vendors, vendor addresses, and vendor contacts before you set
up an event. When entering vendors as accounts, choose Vendor in the Account Type field of the
Vendor form. For more information, see Chapter 4, “Defining an Event.”

The following procedure describes how to associate a vendor with an event or session. Prior to
associating a vendor with a session, you should have already associated the vendor with the event.

To associate a vendor with an event
1 Navigate to the Site Map > Events > Event Plans view.

2 In the Event Plans list, select and drill down on the event for which you want to associate a
vendor.

3 Click the Schedule view tab, and then click Events.
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4 In the Events list, drill down on the events name.
5 Click the Participants view tab, and then click Vendors.

6 In the Vendors list, create a new record.

To associate a vendor with a session
1 Navigate to the Site Map > Sessions view.

2 In the Session list, select and drill down on the session for which you want to associate a vendor.
3 Click the Participants view tab, and then click Vendors.
4 In the Vendors list, create a new record.

After you have associated a vendor with an event, you can record the billing parameters the vendor
uses, any discounts or special rates you negotiate, and optional reviews of the vendor’s performance
for the event.

The following procedure describes how to record the billing parameters for an event vendor.

To record billing expense information for a vendor
1 Navigate to the Site Map > Events > Event Plans view.

2 In the Event Plans list, select and drill down on the event for which you wish to record the billing
parameters.

Click the Schedule view tab, and then click Events.
In the Events list, select and drill down on the event.

Click the Participants view tab, and then lick Vendors.
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In the Vendors list, select the vendor for which you want to enter billing parameters.
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7 Scroll down to the Billings subview and in the Billing list, create a new record.

The following table describes some fields in the Billing list.

Field Comments

Flat Fee The currency field for any flat fee to be charged instead of or in addition to the
billing rate.

Qty The actual quantity of basis units used by the event.

Rate The currency field for vendor’s rate per basis unit.

Service Type  The type of responsibility the vendor has for the event.

Total Cost A result of the automatic calculation based on Rate, Qty, and Flat Fee, when
you save the record.

Units The basis of the vendor’s rate. Typical values include Per Person, Per Item,
Hourly, Daily, Weekly, Monthly.

NOTE: Billing records created at the Vendor level roll up to the event as expense records, with
a Cost Type = Vendor.

The following procedure describes how to enter any discounts or special rates you have negotiated
with the vendor.

To enter vendor discounts or other special rate codes
1 Navigate to the Site Map > Events > Event Plans view.

2 In the Event Plans list, select and drill down on the event for which you wish to enter vendor
discount information.

3 Click the Schedule view tab, and then click Events.

In the Events list, select and drill down on the event.
5 Click the Participants view tab, and then click Vendors.

Billing, Rate Code, and Reviews subviews appear below the Vendors list.
6 Select the vendor for which you want to specify rate code information.

7 In the Billing subview select, Rate Code from the drop-down list.
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8 In the Rate Codes list, create a new record.

The following table describes some fields in the Rate Codes list.

Field Comments

Name A name to designate the discount or special rate.

Type A description of the discount amount or special rate.

Adjacent to the Billing and Rate Code subviews, there is a subview for review information about the
selected vendor. For information about entering a vendor review, see “Entering Venue and Vendor
Performance Reviews” on page 109.

Attaching Files

In the process of preparing for your event, you may want to store certain file attachments for an
event, such as contracts with vendors or floor plans of exhibit halls.

NOTE: In this release, event attachments can be stored and retrieved only by users who have access
to the administration screens in Siebel Events Management.

The following procedure describes how to attach a file to event information. This procedure is meant
for event attachments only. Documents that are used for multiple events should be stored as
collateral. For more information about storing collateral items, see “Preparing Collateral” on page 60.

To attach a file to an event
Navigate to the Site Map > Events > Event Plans view.

In the Event Plans list, select and drill down on the event for which you wish to attach a file.
Click the Schedule view tab, and then click Events.
In the Events list, select the event.

Click the Plan view tab, and then click Documents.
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In the Documents list, create a new record.

For URL attachments, a link appears in the Attachment Name field to take you to the Web site.
For file attachments, information about the selected file is now displayed in the Attachment
Name, Size, Type, and Modified fields.

Inviting Contacts and Prospects to an Event

This section provides an introduction to inviting prospective attendees. However, prior to inviting
attendees, it is recommended that you read “Self-Registering to Attend an Event” on page 89.
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You can invite prospective attendees to an event by adding an individual attendee or a list of
attendees for the event and setting the Registration Status to Invited, which triggers an automatic
email to the invitee or invitees. If the registration status is set to Invited when an invitee logs in to
your Siebel Events Web site, then the invitee sees the event listed when he or she clicks the View
My Open Invitations link on the home page.

You can also register prospective attendees directly for events and sessions. For information about
registration, including important descriptions of registration workflow rules, see “Self-Registering to
Attend an Event” on page 89.

For financial services customer, if an attendee is registered at the event or session level, an
autoregistration process is triggered that registers the attendee’s employing company for the event
with a registration status of Restricted Invite.

An attendee’s registration status effects whether the attendee can:
B See the event listed on the Events home page

B View the event details

B See nothing at all

If the registration status is set to Invited when an invitee logs in to your Siebel Events Web site, then
the invitee sees the event listed on the Events home page. If an account’s registration status is set
to Invited, all employees of that company see that event listed, and all employees can view the event
details.

Inviting a Contact to an Event
The following procedures describes how to invite a contact to an event.

Inviting a contact
1 Navigate to the Site Map > Events > Event view.

In the Events list, select and drill down on the event for which you want to invite the contact.
Click the Participants view tab, and then click Registration.

In the Registration list, click Add Attendee.
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In the Registration list, click Invite.

NOTE: After the attendee is invited, you can view the attendee by clicking the Participants view
tab.

Inviting a List of Contacts to an Event
The following procedures describes how to invite a group of people to an event.

To invite a list of contacts
1 Navigate to the Site Map > Events > Event view.
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In the Events list, select and drill down on the Event.
Click the Participants view tab, and then click Registration.
In the Registration list, click Add List.

In the Add Attendee List dialog box, select a list or create a new record, and then click OK.

2
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In the Registration list, click Invite all.

NOTE: After the list is invited, you can view the invited attendees by clicking the Participants
view tab.

Inviting Contacts and Prospects to an Event Using Siebel Marketing
Customers who have purchased the required license options for Siebel Marketing, can invite contacts
or prospects to an event through an email marketing campaign. This involves creating a target
segment or list of invitees, associating a related event to a campaign and email offer, and executing
the campaign to send out email invitations with an embedded Event Web site URL. During execution,
campaigns that have a related event automatically add the campaign contacts or prospects to the
event as attendees, with a Registration Status of Invited.

Unlike contacts, prospects are not required to log in to the Events Web site in order to register for
an event. This method for inviting prospects may be particularly useful in the case where third-party
prospect lists are imported and not promoted to contacts. Invited prospects are shown in the Events
screen, Attendees subview. For more information on Email Offers and Campaigns, see Siebel
Marketing User Guide.

After you invite the attendees, you can register them using the Events screen, Participants view. For
more information on how to register invited attendees, see Chapter 6, “Registering for an Event.”

Entering and Tracking Travel Arrangements

As attendees, speakers, and staff are confirmed, travel arrangements for each can be entered using
the Participants view tab. Also, multiple travelers, such as the speakers and staff for a multicity
event, can be added to a single travel arrangement.

Travel arrangements can be associated with all three levels of events—event plans, events, and
sessions. For example, a staff member may involved in a one-day event, in another city, of a week-
long event. In this case, you can enter the travel arrangements using the Events screen.

The following procedures involve travel arrangements for an event using the Events screen. You may
find it helpful to reference the Calendar screen when scheduling event travel arrangements.

To enter travel arrangements
1 Navigate to the Site Map > Events > Event view.

2 In the Events list, select and drill down on the event for which you wish to enter travel
arrangements.

3 Click the Participants view tab, and then click Travel.

4 In the Travel list, create a new record.
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5 In the Travel Type field, select a travel type from the drop-down list.

After you enter the travel type and move to another field, the Travel Detail form refreshes and
show fields specific to the travel type you selected.

6  Fill in the remaining fields as needed.
7 Scroll down to the Air Travel Detail form, and fill in the fields as needed.
8 In the Attendees list, create a new record to add attendees to this travel arrangement.

NOTE: For Finance customers, you can only add people registered for the event, not staff or
employees.

9 In the Attendees list, select the event attendees (press CTRL to select multiple attendees), and
then click OK.

The Company Name field is autopopulated. The Confirmation Number and Comments fields are
optional.

You can track travel arrangements using the All Travel list in the Travel view. The All Travel list is a
read-only list and is for informational viewing purposes only.

To track travel arrangements
1 Navigate to the Site Map > Events > Event Plans view.

2 In the Event Plans list, select and drill down on the event you wish to track.
3 Click the Participants view tab, and then click All Travel.

A summary of all travel arrangements for the event, including travel arrangements associated
with events and sessions, is displayed.

Preparing Event Status Reports

Throughout the event preparations, you may want to use the preconfigured event status report to
summarize current information about registrations, budget, and revenue. The following procedure
describes how to produce an event status report.

The event status report uses the Registration Status field to summarize response rate and interest
levels among the invitees.

NOTE: Report parameters must be configured before you can select the Reports view. For
information about setting report parameters, see Siebel Reports Guide.

To prepare an event status (snapshot) report
1 Navigate to the Site Map > Events > Event view.

2 In the Event Plans list, select and drill down on the event for which you wish to prepare a report.

3 Click the Reports button.
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4 In the Select a Report field, select Event Snapshot.

The event snapshot report appears in a new window.

NOTE: Reports are currently not available at the Session or Event Plan level.
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This chapter describes the different approaches to registration, such as registering an individual
contact, an individual account, a list of contacts, or inviting prospected through Siebel Marketing.

This chapter includes the following topics:

“Example Process Flow for Registering for an Event” on page 76
“Registering One or More Attendees” on page 76

“Tracking Guests of Attendees” on page 80

“Registering a Group of Attendees for a Session” on page 81
“Registering an Account for Financial-Services Customers” on page 81
“End-User Procedures for Self-Registering for an Event” on page 87
“Configuring the Register Button” on page 93

“Configuring Quantity Selection in Registration” on page 94

“Customizing Siebel Events Home Page Applets” on page 94
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Example Process Flow for Registering
for an Event

Figure 3 is based on recommended administrator and end-user procedures for registering for an
event in Siebel Events Management. Some recommended administrator procedures are registering
an account (for Finance customers), registering attendees, attendee session registration, account
session registration (for Finance customers), and managing registration status.

Administrator Procedures End-User Procedures
Registering an Account Registering to Use
(Finance customers) the reb Site

! B

N Self-Registaring to
Registering Attandeea(s) Attend an Event

h

Attendee Session
Registration

I

Account Session
Registration (Finance
customers)

¥

Managing Registration
Status

Figure 3. Process Flow for Event Registration Administrator and End-User Procedures

Registering One or More Attendees

In Siebel Events Management, you can build lists of attendees and register all of the contacts on the
list. This feature is available for event plans and events, but not for sessions. This capability is
particularly useful when the same group of attendees needs to be registered for multiple events of
an event plan.

Registering a List of Attendees for an Event
The list of attendees that you register is built from within the Event Plans or Events screen, as a part
of the attendee registration process.

The following procedure describes how to register a list of attendees.
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To register an attendee list for an event
Navigate to the Site Map > Events > Event view.

In the Events list, select and drill down on the Event Name.
Click the Participants view tab, and then click Registration.
In the Registration list, click Add List.

In the Add Attendee List dialog box, select a list or create a new record, and then click OK.
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Click Register All to invite the attendees.

After the list is registered, you can view the registered attendees using the Participants view tab.

Creating Attendee Lists

You can send out invitations to attendees who came to a specific event or session, or invite specific
types of attendees to an event. For example, you might want to invite registered C-level executives
to a special private event. You can create lists of attendees for this purpose, to be used for
registration in other events. Creating an attendee list is different from creating a list of contacts,
because you are working with a subset of attendees within a specific event or session.

When the list is created, note that the default format for the list name is “[Event or Session Name]-
[Date][Time]”. The name of the list can be changed.

To create a list of attendees
1 Navigate to the appropriate view:

m  For events, navigate to the Site Map > Events > Event > Attendees view.
m  For sessions, navigate to the Site Map > Events > Sessions > Attendees view.

2 (Optional) Query for the attendees by the criteria you want to search on, that is
Status=Confirmed or Job Title=C.

3 In the Attendees list, select one or more attendees.
4 Click Create New List.
A message confirms that the list has been saved.

5 Specify the name of the list.

Registering an Attendee
There are two ways a potential attendee can be registered to attend an event:

B Self-registration. The potential attendee can use a standard Web browser to visit the Siebel
Events Web site and register for an event listed there. For more information on registering for
an event, see “End-User Procedures for Self-Registering for an Event” on page 87.

B Registration by an administrator. A member of your own company can use administrative
screens to register the potential attendee for an event. For more information on registering an
attendee for an event or session, see “Registering an Attendee for an Event” on page 78.
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Although self-registration through the Events Web site home page is recommended over registration
by an administrator, there may be times when it is convenient for an employee of the presenting
organization to register an attendee for an event or a session, rather than requiring the attendee to
self-register. This option is particularly useful for registration at events that allow registration at the
door, because employees with access to administration screens can register walk-in attendees upon
their arrival.

Self-registration is preferred because it uses LDAP security systems and authenticates a user’s
username and password. Registration from administrative screens may require site-specific steps to
create matching user accounts for both your Siebel application and the security system.

NOTE: Not all event attendees must be customers or clients of your company. If you wish to track
the attendance of event staff, speakers, personnel from partner organizations, and so on, you may
do so by registering them as attendees.

Registering an Attendee for an Event

The following procedure describes how you can register an attendee for an event or session directly
from the administrative screens. Attendees who are registered for events and sessions are
automatically registered for their parent events.

NOTE: Attendees must be registered for an event before they can register for a session.

If an attendee registers for an event prior to the attendee’s account being registered for the event,
the account is automatically registered for the event plan and for the event. The event registration
status is set to Restricted Invite.

Siebel Events automatically adds attendees who are not in the system as contacts to the contacts
table after the you complete the following registration procedure.

To register an attendee for an event
1 Navigate to the Site Map > Events > Event view.

2 In the Event Name list, select and drill down on the event for which you want to register an
attendee.

3 Click the Participants view tab, and then click Registration.
4 In the Registration list, create a new attendee record.

®m When a contact record is added in the registration list, its status is blank. The administrator
can decide whether to invite the contact.

m If the event does not have a registration fee, and if there is space available, the value of the
Registration Status should be Confirmed.

m If the registration status is automatically set to Waitlisted, then all seats are taken for the
event or session. If you want, you can continue registering additional attendees, but they are
placed on the waiting list.

m If there is a fee for attending the event or session, and if there are seats available, the
registration status is Pending until the fee payment is submitted in Step 5.
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m After an account or contact is registered, it disappears from the Registration tab. The record
is transferred to the Attendees or All Attendees view, as appropriate. There is no data loss.

If this is a fee-based event, to step through the Shopping Cart and complete the purchase
transaction with a credit card, click Finish.

NOTE: The Finish button is available only if there is a fee.

For Financial-services customers, the following table describes some fields in the Registration
list.

Field Comments

Attendee Type A general category representing the type of attendee. Typical values
include Standard, Attendee, Premium, VIP, Guest, Staff-Internal,
Staff-External, Staff-VIP, Speaker, and Speaker-VIP.

LOV Type: PARTICIPANT _STATUS

Group A text field for noting how this attendee is grouped with others. For
example, one could group attendees by table number for a mealtime
event with fixed seating.

Registered The autogenerated date and time when the registration record is
created. This field is not displayed by default in the Registration list,
but can be added using the Columns Displayed menu command.

Registration # A unique, read-only, alphanumeric code that is autogenerated for the
current registration.

Registration Status The status of the potential attendee’s registration. By default,
available values include Invited, Pending, Confirmed, and so on. When
this setting has a value of Invited, the event appears in the invitee’s
My Invitations list on the Web site.

LOV Type: EVENT_REG_STATUS

The following table describes some typical Registration Status values.

Value Comments

Attended Indicates that the potential attendee actually attended the event plan,
event, or session. Enter this value only after attendance has occurred.

Cancelled Indicates that the potential attendee reversed their previous acceptance
before the cancellation deadline.

Confirmed Indicates the participant completed the registration process.

Invited Causes the event to appear in the invitee’s My Invitations list on the Web
site.

No-show Indicates the potential attendee was confirmed for the event, but did not

attend the event.
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Value Comments

Pending Indicates the potential attendee has been invited but has not yet
responded to the invitation.

Walk-1n Indicates the attendee was not confirmed prior to the event, but did attend
the event.

Registering Previously Invited Attendees to an Event

An event may have one or more previously invited attendees, that need to be either confirmed or
canceled as part of the registration process. Attendees can self-register for an event that they are
invited to, or an administrator can manually confirm their registration.

To confirm or cancel the registration of a previously invited attendee

1
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Navigate to the Site Map > Events > Event view.

In the Events list, select and drill down on the event.

Click the Participant view tab, and then click Attendees.

In the Attendees list, click Query.

In the Registration Status field, selected Invited, and click Go.

NOTE: This field shows Attendees who were previously invited.

Select the desired Attendee.

Click Confirm Registration or Cancel Registration to confirm or cancel this attendee’s registration.

NOTE: The Attendee’s registration status changes accordingly. If this is a fee-based event, the
Shopping Cart appears when you select Confirm Registration.

Tracking Guests of Attendees

Certain types of events permit attendees to bring guests. You can track guests for each registered
attendee.

To specify that an attendee is a guest of another attendee

1
2
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Navigate to the Site Map > Events > Event > Attendees view.

In the Attendees list, select the attendee record for the guest you want to specify as a guest of
another attendee.

In the Guest Of field, click the multiple select button to select the primary attendee.
Select the primary attendee, and then click OK.

NOTE: Only registered attendees appear for selection in the Guest Of field.

Siebel Events Management Guide Version 8.1/8.2



g for an Event " Registering a Group of Attendees for a Session

Registering a Group of Attendees for a
Session

Sometimes, you may want to select a group of attendees to register for a session. Instead of
registering each attendee for the session individually, you can select multiple attendees to register
for the session simultaneously.

To register a group of attendees for a session
1 Navigate to the Site Map > Events > Sessions > Registration view.

2 In the Registration list, click Add Attendees.
3 Select multiple attendees by pressing the CTRL or SHIFT key.
4

When you have selected all the attendees you want, click OK to add the attendees to the
Registration list.

5 Click Register All.

Registering an Account for Financial-
Services Customers

You can control which contacts can register for an event by registering an account and issuing
invitations to specific contacts associated with that account. Control of which contacts can register
is determined by the registration status value you select for the account.

The status value that affects account contacts’ (namely, company employees) ability to register is
Invited. If the account is registered for the event with a status of Invited, all contacts associated with
the account can view the event listing on the Events Web site home page and register for the event.

After an account is registered, the contacts themselves are not registered until action is taken to
register individual attendees or attendee lists. An individual attendee can be registered by yourself,
the administrator, as described in “Registering an Attendee” on page 77, or by the contact, as
described in “End-User Procedures for Self-Registering for an Event” on page 87. A contact list can only
be registered by an administrator, as described in “Registering One or More Attendees” on page 76.

NOTE: An individual attendee can still be invited directly to an event, whether or not that attendee’s
account is registered for the event. If an attendee registers for an event prior to the attendee’s
account being registered for the event, Siebel Events automatically registers the account for the
event with a status of Restricted Invite.

Additional considerations for registering accounts are as follows:

B An account can be registered for an event, which automatically registers the account for the
event.

B An account can be registered directly at the session level.

The following procedure describes how to register an account for an event.
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To register an account for an event

1

2
3
4

Navigate to the Site Map > Events > Event view.

In the Events list, select and drill down on the event.

Click the Participants view tab, and then click Registration.

To register an account, click the Add Attendee button in the Account Registration list.
The button appears as available when you set the event Status to Launched.

Choose a registration status according to the visibility and registration options you want to make
available to account contacts.

If you want contacts associated with the account to be able to view and register for the event,
choose Invited in the Registration Status field.

The following table describes typical Registration Status values.

Field Comments

Attended Indicates the potential attendee actually attended the event plan, event,
or session. Enter this value only after attendance has occurred.

Cancelled Indicates the potential attendee reversed their previous acceptance
before the cancellation deadline.

Confirmed Indicates the participant completed the registration process.

Invited Causes the event to appear in the invitee’s My Invitations list on the Web
site.

No-show Indicates the potential attendee was confirmed for the event, but did not

attend the event.

Pending Indicates the potential attendee has been invited, but has not responded.

Walk-1n Indicates the attendee was not confirmed prior to the event, but did
attend the event.

Registration Workflow

Siebel Events Management uses workflow rules to eliminate redundant data entry during the
registration process.
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Registering an attendee for the event will automatically register the account for the event if the
attendee is associated to an account.

If an account has been manually registered for an event then a new contact registration with the
same associated account will not impact the existing account registration.
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Figure 4 illustrates the process for attendee event registration.

Attendee Account
(Finance users only)
Roll-up - Faoll-up -
s | |
Register for Event L Register for Event L
Step 2
Fegister for Session f-=------= » Auto Registerad

Figure 4. Attendee Event Registration

NOTE: The term Pre-Registered in the preceding workflow indicates that the attendee has already
been registered.

Attendees cannot register for a session until they have first registered for an event. Attendee records
are rolled up to the Event Plan level for reporting purposes only.

Session Registration and Activity Records
As part of session management, the workflow performs the following tasks:

B When a session is first created, the workflow creates an Activity record to track that session, and
sets the Activity Type = Session.

B When an event manager registers a person for the session, the workflow adds the person’s name
to the list associated with the Activity record.

These workflow activities are generated so that all internal employees who are registered for a
session can see that session displayed on their personal calendar within the Siebel application
(shown in the Calendar screen). In addition, for all external contacts who are registered for a session,

an Activity of Type = Session shows on the contact-centric calendar, which is found in the Contacts
screen, Calendar view.
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Figure 5 illustrates the workflow triggered during session registration. First, the Event Manager
registers attendee for a session. Second, the workflow adds the person’s name to the list associated
with the activity record, and then an activity displays on the attendee’s personal calendar. In
addition, the activity displays on the Contacts > Calendar view.

3a) Activity displays on
A attendee's personal
calendar

21Workflovy adds the

11 Event Manager ,
] : _| person's name tothe
Session redisters aﬁgndee for *| izt q=snciated with the =
& Session

activity recard

3k Activity displays on
-  Contacts Screen =
Calendat vieww

Figure 5. Session Registration Workflow

Removing a Session Activity

If you register an attendee for a session in error, you need to remove the session activity from the
attendee’s personal calendar. Removing a session activity requires deleting the individual from the
Attendee’s list for the session, then removing the attendee’s name from the Contacts field in the
Activities form.

The following procedure describes how to remove a session activity from an attendee’s personal
calendar.

To remove a session activity from an attendee’s personal calendar
Navigate to the Site Map > Events > Sessions view.

In the Sessions list, and select and drill down on the session.

Click the Participants view tab, and then click Attendees.

In the Attendees list, select and the attendee from the list and click Cancel Registration.
Navigate to the Site Map > Activities > All Activities view.

In the Activities list, select the activity.

In the Activity form, from the Contact’s field, click the select button.
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In the Contacts dialog box, select the attendee, and click Remove.
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Troubleshooting Registration

If you are experiencing difficulty submitting credit card information using the Shopping Cart, make
sure that Siebel Events Management is properly configured for the database software in use. For
more information, see Chapter 3, “Installing and Configuring Events Management.”

Canceling Registrations and Using the Waiting List

In Siebel Events Management, you can cancel registrations only from administrative screens. End
users who want to cancel their event or session registration must contact the organization holding
the event and ask that an administrator cancel the registration.

When an event registration is canceled, all registrations for specific events and sessions associated
with the event are canceled as well. Likewise, if an event registration is canceled, so are all
registrations for specific sessions of the event. However, if a session registration is canceled, the
event registrations are not canceled.

When the administrator cancels a registration for an event or session that is full, a seat becomes
available. However, in some cases, it may be desirable to prevent a seat from becoming available.
To prevent a seat from becoming available, the administrator should reduce the capacity immediately
prior to canceling the registration.

If the capacity is not reduced, and a seat becomes available, it is allocated to the next user whose
registration is added by the administrator or whose registration status is changed from Waitlisted to
Confirmed, whichever comes first. In other words, after a seat becomes available, it is recommended
that administrators immediately change the registration status of the next wait listed person to
Confirmed. Otherwise, a new registrant may accidentally be given the seat designated for the wait-
listed person.

The following procedure describes how to cancel an event registration from an administrative screen.

To cancel a potential attendee’s registration for an event
1 Navigate to the Site Map > Events > Event view.

2 In the Events list, select and drill down on the event name for which you want to cancel a
registration.

3 In the Details form, note whether the potential attendee is due any refund of fees, and, if so, the
amount to be refunded.

4 In the Events form, if you want to prevent a seat from becoming available because of the
cancellation, reduce the Event Capacity by one. For example, if the Event Capacity is 100,
manually change the field to 99.

5 Click the Participants view tab, and then click Attendees.

6 In the Attendees list, select the person to be canceled, and click Cancel Registration.
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7 Use your organization’s standard procedure to provide any refund due to the person whose
registration was canceled.

NOTE: It is possible to delete the registration record, rather than set the registration status to
Cancelled, but this is not recommended. Deleting the record completely removes information
about the registration that can be used to track the number of cancellations, to perform refunds,
and so on.

After canceling a registration, the Event form shows that Openings increased by one and Seats Taken
decreased by one.

You can give the new seat to the first person on the waiting list, as described in the following
procedure. To do this, you first identify the person on the waiting list who has the oldest claim to an
open seat. Next, you confirm their interest and availability for the event, and then, you change that
person’s registration status from Waitlisted to Confirmed. The following procedure is specific to an
event; however, the concept can also be applied to an event or a session registration.

To enable the waitlist for an event or session, make sure that the Allow Waitlist check box is selected.
By default, all events and sessions have the waitlist function enabled.

To allocate an open seat to a person on the waiting list
Navigate to the Site Map > Events > Event view.

In the Events list, select and drill down on the event for which a seat has become available.
Click the Participants view tab, and then click Attendees.
In the Attendees list, click the menu button and choose Columns Displayed.

In the Columns Displayed list, make sure the Registered column is displayed.
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In the Attendees list, click Query.
a In the Registration Status field, select Waitlisted.
b Run the query to display all currently wait-listed attendees.

7 In the Registered column header, click the up arrow to sort the listings by registration date and
time.

The person with the oldest listing on the waiting list is displayed in the first row of the list.
8 Confirm the potential attendee’s interest and availability for the event.
9 In that person’s record, change the Registration Status from Waitlisted to Confirmed.

In certain cases you might want to disable the waitlist function for an event or session. For example,
when the capacity is reached, attendees will no longer be able to register for the event or session.
An error message is displayed to users who attempt to register for an event that is full, and whose
waitlist function is disabled.

To disable the waitlist
1 Navigate to the appropriate view:

m For an event, navigate to the Site Map > Events > Event > Details view.
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m For a session, navigate to the Site Map > Events > Sessions > Details view.

2 In the Details form, clear the Allow Waitlist check box.

End-User Procedures for Self-
Registering for an Event

End users can self-register through the Events Web site. However, prior to a potential attendee self-
registering for an event, the hosting organization should complete several tasks. These tasks are as
follows:

B Establish the invitee’s User ID
B Register the invitee to attend the event with a status of Invited

B Send an email to the invitee, which includes the address of the Web site and information about
the username and password to be used at the site

After being invited, the potential attendee performs the following tasks:

B Visits the Web site and logs in using the specified username and password
B Views his current event invitations

B Self-registers to attend the event

NOTE: If the invitee registers to attend the event, that self-registration replaces the tentative
registration record created by the administrator.

If the potential attendee wants to cancel his or her registration at any point in the process, that
person must contact an administrator who can cancel the registration.

Registering to Use the Web Site
In order to self-register using a Web browser, a potential attendee must first be a registered user of
the Siebel Events Web site.

NOTE: For Finance customers, Siebel Events is an optional module that allows customers to use a
Web site to register for events. Your company must purchase this module in order to use Web
registration and follow the procedures described in this section.

End-User Events Visibility (for Finance Customers)
The following visibility rules and information are applied and displayed on the Web site according to
the below criteria:

B Upcoming Events. Displays the next five events that have a Status Launched, a Start date after
today, an Event Type that is not Restricted, and Display on Website = V.

B View My Open Invitations. Displays events to which a contact has been personally invited. If
the contact’s account is invited, but not the individual, the event does not appear here.
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Events Web Site Registration Process
The first step in becoming a Siebel Events Web site user is to obtain the address for the site’s home
page. This address may be obtained through one of the following:

B A personal contact within the hosting organization
B A link on the company’s corporate Web site

B An email message sent by the hosting organization
B An advertisement

After obtaining the home page address, and if the event is not restricted, any potential attendee can
become a registered Web site user by clicking the New User link on the home page. After registration
on the Web site, the potential attendee can view event information and self-register for the event.
However, if the event is restricted, the company hosting the event must establish the potential
attendee as a registered Web site user and then invite the Web site user to the event. This invitation
allows enable the potential attendee to self-register over the Web site.

NOTE: As described in Chapter 5, “Preparing for an Event,” if the External check box is not selected
in the Event form, the event is not visible to Web site users under any circumstances.

The following procedure describes how to self-register as an Events Web site user. You may want to
adapt and distribute these instructions to your event-hosting employees and Web site users who
have limited access to documented procedures.

To self-register as an Events Web site user
1 Use standard Web browser to navigate to the Events home page.

2 Click the New User link in the User Login form.
A Personal Information form appears.

3 Complete the fields on the Personal Information form, noting the username and password values
you enter for future reference, and then click Next.

4 In the Contact Information form, complete the fields, and then click Next.
A Usage Terms dialog box appears, showing a license agreement.

5 Read the terms of the agreement, and then click | Agree to proceed.
A Registration Confirmation message appears.

6 Click Finish.

The Siebel Events Web site reappears, but the User Login form is no longer displayed, as you are
now logged in.

NOTE: Siebel Events Management administration screens are accessed through Siebel
applications such as Siebel Sales, Siebel Marketing, or Siebel Call Center. Depending on your
Siebel application configuration, Siebel Events end-user screens may or may not be accessible
through these Siebel applications, as well.
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Self-Registering to Attend an Event
An end user can self-register to attend an event when all of the following are true:

B The end user is a registered Events Web site user.
B The event’s Event Type is not set to Restricted.

When these conditions are met, an end user can view the event and register to attend the event.
However, if the Event Type is Restricted, the end user cannot register to attend the event, and he or
she can only view the event if they are an invited attendee.

The following procedures describe how a registered user of the Events Web site can register to attend
an event and any particular sessions within an event that may require separate registration. Note,
however, in this release of Siebel Events Management, attendee registration is no longer required at
the Event Plan level. Attendees must first register for an event, and then register for the sessions

within an event.

NOTE: Confirmed registration for the event is required before registration for sessions is possible.

To self-register to attend an event
1 Navigate to the home page of the Events Web site.

2 Log in as a registered user of the site. For more information about new user registration, see
“Events Web Site Registration Process” on page 88.

The Siebel Events home page reappears without the User Login form.
3 Click one of the following links to view event information:

m  Events link in Browse Events list. Displays the Available Events list, which shows all
events that are open to the general public.

m Register for an Event. Also displays the Available Events list, which shows all events that
are open to the general public.

®m  View My Open Invitations. Displays the My Invitations list, which shows all events to which
you have been invited, including restricted events.

m  Any event listed in the Upcoming Events area of the home page. Displays an Event
form and a Sessions list for the selected event.

4 If you clicked one of the first three links in Step 3 on page 89, click the name of an event that
interests you. Otherwise, proceed to Step 5 on page 90.
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In the Event form, click Register.

If there is no charge for the event, and if there is still space available, the My Events list appears.
The list includes the event you selected, with the Status field set to Confirmed, showing that you
are registered for the event. Also, an email message is automatically sent to you, reporting that
your registration is confirmed for the event.

If there is no charge for the event, but the maximum enrollment has been reached, the My Events
list appears, but the event listing shows a status of Waitlisted. An email message is automatically
sent to you, reporting that you are on the waiting list and will be informed if space becomes
available.

If there is a registration fee for the event, and if there is still space available, the Shopping Cart
appears, containing information about the charge for the event.

(Optional) To continue registering for additional events before paying, return to the Events home
page and repeat Step 3 on page 89 and Step 4 on page 89.

To pay for all of the events you for which are registering, click Check Out.

a In the Payment Method form, enter your credit card and billing information. If you have used the
Shopping Cart before, your previously entered information displays for you to edit or confirm.

b Click Continue to display the Order Summary, and verify that all information is correct.
Cc  Click Confirm Order.
An Order Confirmation message appears.

d Click Return to Home Page, and then click View Your Registrations to display the My Registered
Events list.

1 The list includes the event or events that you selected, with the Status field set to
Confirmed, indicating you are registered for the event. Also, two email messages are
automatically sent to you, one reporting that your registration is confirmed, the other
reporting your Shopping Cart transaction.

2 If there is a registration fee for the event, but maximum enrollment has been reached,
the My Events list appears, but the event listing shows a status of Waitlisted. An email
message is automatically sent to you, reporting that you are on the waiting list and will
be informed if space becomes available.

2 If you do not complete the check-out process for the Shopping Cart, your registration
status is set to Pending, by default. This status reserves a seat for you, if a seat is
available, but only for a finite time period. The default length of time that a registration
remains pending is four hours. After this period, Siebel Events automatically deletes
pending registrations when you register another user for the same event.

The following procedure describes how to complete an unconfirmed registration for an event, either
to convert a status of Pending to a status of Confirmed or to convert a status of Waitlisted to a status

of Confirmed.

1

90

To complete a pending or wait listed registration to attend an event

On the Home Page in the My Events list, click the View Your Registrations link.
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Locate the listing for the registration that you want to complete, and click the link in the Event
Name column of that listing.

An Event form, a Sessions list, and a My Sessions form appears.
In the Event form, click Register.

m If there is no charge for the event, and if there is still space available, the My Events list
appears. The list includes the event you selected, with the Status field set to Confirmed,
showing that you are registered for the event. Also, an email message is automatically sent
to you, reporting that your registration is confirmed for the event.

m If there is no charge for the event, but the maximum enrollment has been reached, the My
Events list appears, but the event listing shows a status of Waitlisted. An email message is
automatically sent to you, reporting that you are on the waiting list and will be informed if
space becomes available.

m If there is a registration fee for the event, and if there is still space available, the Shopping
Cart appears, containing information about the charge for the event.

(Optional) To continue registering for additional events before paying, return to the Events home
page and repeat Step 3 on page 89.

To pay for all of the events you for which are registering, click Check Out.

a In the Payment Method form, enter your credit card and billing information. If you have used the
Shopping Cart before, your previously entered information displays for you to edit or confirm.

b Click Continue to display the Order Summary, and verify that all information is correct.
C  Click Confirm Order.
An Order Confirmation message appears.

d Click Return to Home Page, and then click View Your Registrations to display the My Registered
Events list.

4 The list includes the event or events you selected, with the Status field set to Confirmed,
indicating you are registered for the event. Also, two email messages are automatically
sent to you, one reporting that your registration is confirmed, the other reporting your
Shopping Cart transaction.

2 If there is a registration fee for the event, but maximum enrollment has been reached,
the My Events list appears, but the event listing shows a status of Waitlisted. An email
message is automatically sent to you, reporting that you are on the waiting list and will
be informed if space becomes available.

The following procedure describes how to register for sessions within an event.

To register to attend sessions within an event

1

If you have not already done so, register for the sessions’ event, and make sure that your
registration status is Confirmed.

For instructions on how to register, see “Events Web Site Registration Process” on page 88.

From the home page, click the link View your Registration.
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3 In the My Registered Events list, click the Events Name.
An Event form, a Sessions list, and a My Confirmed Sessions list appear.

4 In the Sessions list, select the session or sessions you want to register for, and then click Register
Session.

m If there is no additional fee for the session, and if there is still space available, the Event
form, Sessions list, and My Confirmed Sessions list reappear. The selected session is listed
in the My Confirmed Sessions list with a value of Confirmed in the Status field.

m If there is no additional fee for the session, but maximum enrollment has been reached, the
Event form, Sessions list, and My Confirmed Sessions list reappear. The selected session is
listed in the My Confirmed Sessions list with a value of Waitlisted in the Status field.

m If there is an additional fee for the session, and if there is still space available, the Shopping
Cart appears, containing information about the charge for the session.

5 (Optional) To continue registering for additional sessions before paying, return to the Events
home page and repeat Step 3 on page 92 and Step 4 on page 92.

6 To pay for all of the sessions you for which are registering, click Check Out.

a In the Payment Method form, enter your credit card and billing information. If you have used the
Shopping Cart before, your previously entered information displays for you to edit or confirm.

b Click Continue to display the Order Summary, and verify that all information is correct.
Click Confirm Order. An Order Confirmation message appears.

Click Return to Home Page, and then click View Your Registrations to display the My Registered
Events list.

e Click the name of the event that includes the session you selected.

21 An Events form, Sessions list, and My Confirmed Sessions list reappear. The selected
session is listed in the My Confirmed Sessions list with a value of Confirmed in the Status
field.

2 If there is an additional fee for the session, but maximum enrollment has been reached,
the Event form, Sessions list, and My Confirmed Sessions list reappear. The selected
session is listed in the My Confirmed Sessions list with a value of Waitlisted in the Status
field. To register for additional sessions, repeat Step 4 on page 92.

2 If there is an additional fee for the session, and the user is already registered for one or
more selected session, the Shopping Cart appears, but does not include the sessions that
the user is already registered for.

2 If there is a time-conflict between two or more overlapping sessions, an error message
is displayed.
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Registering for Sessions Within a Track

Users have the choice of browsing and registering for sessions that appear within a specific track.
This allows users to match their interested sessions with the available sessions in large events. For
more information on Associating Events and Sessions with a track, see “Associating Tracks with Events
and Sessions” on page 46.

NOTE: Before proceeding with the procedure that follows, if you have not already done so, you must
register for the session’s event and make sure that your registration status is Confirmed. If you are
not registered for the event, then you won’t be allowed to register for the session. For instructions
on how to self-register to attend an event, see “Self-Registering to Attend an Event” on page 89.

To register for sessions within a track
1 From the home page, click the link Register for an Event.

2 In the All Available Events list, click the Event Name.

NOTE: An event form, a session list, and a track list appear.

Prospect Registration

Prospects who received an email invitation to the event by way of a marketing campaign, may
register for an event without logging in to the Event Web site. A prospect must click the URL within
the email invitation to be able to register for an event this way. Information about the prospect is
embedded within the URL and passed onto the Event Web site.

If invited through a marketing campaign, any change in an attendee’s registration status results in
a registration history (campaign response) record being created. Registration history records can be
viewed in the Events screen, Attendees subview. For more information, see “Inviting Contacts and
Prospects to an Event Using Siebel Marketing” on page 71.

Troubleshooting Registration

If you are experiencing difficulty submitting credit card information using the Shopping Cart, make
sure that Events is properly configured for the database software in use. For more information, see
Chapter 3, “Installing and Configuring Events Management.”

Configuring the Register Button

The Register button in eEvents Event Register Form Applet does not invoke a workflow. Instead, this
button invokes a method that calls the EnrollUser method in the Event Registration business service.
The EnrollUser method then calls additional child methods to perform the following steps:

B Checks if the user is a prospect.

B Checks if the user is eligible for registration based on the event attributes and the user attributes.
Also, checks if space is available for the event.

B Checks if a prior registration record exists for the user. Also, checks if that registration record
needs updating or is confirmed.
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B If no prior registration record exists, creates a new registration record to register the user.
B If the registration record is confirmed, updates the space capacity.
B If a quote is needed, calls the Quote method to create a quote and line item.

If you want the Register button to invoke a workflow, you can call the Register Events business
service in a workflow step to complete these steps. If you do not call the Register Events business
service, your workflow must complete these steps.

The code in the eEvents Event Register Form Applet invokes a business component that populates
the input properties that the EnrollUser method and its child methods use. This applet code also
invokes the Event Registration business service. You can create a script to accomplish these applet
code tasks. In this script, you can call only the EnrollUser method because this method calls the child
methods. However, if you want to change the child methods, you can change all methods using
escript.

For more information about the EnrollUser method and its child methods, see Appendix A,
“Registration Business Service Methods.”

Configuring Quantity Selection in
Registration

If you use the Shopping Cart to charge attendees event or session registration fees, the Quantity
field in the Shopping Cart automatically defaults to a value of 1. If you want to configure Siebel
Events Management so that an attendee can purchase a quantity greater than 1, you can add a script
to the write record method in the Quote Item business service.

The AddToShoppingCart method in the Event Registration Service business service calls the following
methods:

B IsltemInShoppingCart in the Shopping Service business service. This method checks to see if the
item is already present in the Shopping Car.

B AddToCart in the Shopping Service business service. This method adds the item to the cart and
prices the item.

Customizing Siebel Events Home Page
Applets

The Events Web portal contains navigational applets on the home page that are designed to simplify
user navigation. Some of these navigational applets are not based on business component data,
instead Siebel administrators or developers use Siebel Tools to customize the applets. The applets
are as follows:

B “Customizing the My Events Applet” on page 95
B “Customizing the Browse Events Applet” on page 96

B “Customizing the Upcoming Events Applet” on page 96
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Customizing the My Events Applet

The My Events Applet, as shown in Figure 6, provides links to views where users can register for
events, view event invitations, or view events they have already registered for.

My Events

—., Regizter for an Event
* Select an event far which you weould like to register

Wiesy My Open Invitations
i “iewy open invitations for selected events

!
L

P

Yiewy Your Registrations
- Wiew events wwhere you have slresdy registered

--'—‘_'_'_'-r-

g

Figure 6. My Events Applet Example

Each link and corresponding bitmap is represented by a control object on the applet. To create or
modify a new control, Siebel administrators or developers should perform the following procedure.

To create or modify new controls on an applet

1 Using Siebel Tools create a link by setting the HTML Type property of the control to “Link” and
then set the Method Invoked property to “GotoView”.

2 To specify the destination view, create a Control User Property with Name = “View” and Value =
“Destination View Name”.

Each image is specified in the Control’s HTML Bitmap property, which refers to a Bitmap Category
Item. The layout of the applet is defined by the Applet Web Template.

For more information about working with applets, views, drilldowns, bitmaps, and Web templates,
see Configuring Siebel Business Applications, Using Siebel Tools, and Siebel Object Interfaces
Reference.
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Customizing the Browse Events Applet
The Browse Events Applet, as shown in Figure 7, provides links to views where end-users can browse
a list of events or session or query for a specific event or session.

Browse Events

Events

Browse a list of
vents or guery for &
“Fapecific event

Seszions

- Brovwwsze alist of

| Sessions or guety for
—— zpecific Session

Figure 7. Browse Events Applet Example

The Browse Events Applet is built on the same structure, that is with link and image controls, as the
My Events Applet. For more information, see the to create or modify new controls on an applet
procedure in the “Customizing the My Events Applet” on page 95 section.

Customizing the Upcoming Events Applet
The Upcoming Events Applet, as shown in Figure 8, is based on the eEvents Event business
component. This applet displays links to the event detail view.

Upcoming Events
o Denefit Concert - Atlants

. Benefit Concert - Mew *ork

Figure 8. Upcoming Events Applet Example

The applet displays a link for each of the next five events where Status = “Launched,” Start Date >
current date, Event Type is not Restricted, and Display on Website= “Y”. The applet is a special type
of a list applet, whose Web template displays a bulleted list for each record. A drilldown object on

the applet specifies that the Name field should have a context-sensitive link to an event detail view.

For more information about working with applets, views, drilldowns, bitmaps, and Web templates,
see Configuring Siebel Business Applications, Using Siebel Tools, and Siebel Object Interfaces
Reference.
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This chapter discusses the requirements for displaying the events calendar. The chapter also
describes how to configure the events calendar user interface for your company. For end users,
procedures are provided for managing the events calendar and viewing sessions in the personal
calendar.

This chapter includes the following topics:
B “Events Calendar Overview” on page 97

B “End-User Procedures for Managing an Events Calendar” on page 98

Events Calendar Overview

Siebel Events Management allows individuals to manage an events calendar and synchronize
sessions with their personal calendars, where the sessions appear as activities. This section provides
an overview of the relationships between the events calendar and personal calendar, as well as
providing information about events calendar browser requirements and icons.

In addition to the personal calendar, there is also the Track Calendar and the Session Timeline or
speaker calendar. For more information on the Track Calendar, see “Using the Track Calendar” on
page 47. For more information on the speaker calendar, see “Adding Speakers to Sessions” on
page 56.

Events Calendar and Personal Calendar Relationships
The following list provides information about the differences and relationships that exist between the
events calendar and the personal calendar:

B The events calendar only displays events, and not sessions or event plans.

B The personal calendar only displays activities corresponding to events or sessions and not event
plans. When an employee registers for a session, an activity appears on the employee’s personal
calendar. For more information on the differences between event plans, events, and sessions,
see Chapter 4, “Defining an Event.”

B Personal calendar synchronization is a one-way communication from the sessions of an event to
the personal calendar. Changes to the session item that display on the personal calendar are not
saved to the session itself. If a user cannot attend a planned session listed on his or her personal
calendar, only you—as the event’s administrator—can remove that person from any speaker,
staff, or attendee lists.

B Personal calendar items do not appear on the events calendar.
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Events Calendar Browser Requirements

The person viewing the events calendar needs to use a browser for high-interactivity applications. A
browser for high-interactivity applications supports real time updates to the user interface. For
example, when you drag a column divider to change column width, a browser for high-interactivity
applications displays your changes in real time. This functionality is particularly important in the
events calendar. Using a browser for low-interactivity applications results in an incomplete screen
display.

For more information about configuring browsers for high-interactivity applications, see Siebel
System Administration Guide. For information about the supported browsers for high-interactivity
applications, see Siebel System Requirements and Supported Platforms on Oracle Technology
Network.

End-User Procedures for Managing an
Events Calendar

End users can see a list of upcoming events at any time by viewing the events calendar. The first
part of this section describes how you can use the events calendar to learn about new events and
sessions for which you may want to register.

After you register for a session within an event, your Siebel application also displays the session on
your personal calendar. The second part of this section describes how you can view session details
from your personal calendar and set an alarm to receive online session reminders.

Viewing Event Details from the Events Calendar

You can use the events calendar to view all events that are scheduled for the day, week, or month
in a calendar format. Each event listing displays a link that takes you to details about the event and
associated sessions.

In the Events Calendar view, you can find out details about an event, for example the type, status,
and description, by placing your mouse pointer over the Event Name link. In addition, you can view
all the events planned for the day by placing your mouse pointer over the date in the Events Calendar
view.

The following procedure describes how to view event details and associated sessions from the events
calendar.

To view event details from the events calendar
1 Navigate to the Site Map > Events > Calendar view.

2 Click the Daily, Weekly, or Monthly view tab.
B Clicking the Daily view tab, sorts the calendar by hours in a day.

B Clicking the Weekly view tab, sorts the calendar by days in a week.
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m  Clicking the Monthly view tab, sorts the calendar by days of the month, as shown in the
following figure.

A ronthy |
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7 28 29 30 i 1
Test Event - 1 Test Event- 1 Test Event -1 Test Event - 1
2
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24 25 26 7 28 29
30
3 1 2 3 4 5
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3 Place your mouse pointer over the name link to view details about the event.

Place your mouse pointer over the date to view events that are planned for that day.
5 Click the name link for the event you want to view.

The Events form and Sessions list appear, showing more details about the event.
6 Click the Session Time Line link.

The Event Session Timeline appears, showing an hourly breakdown for each session associated
with the event, as shown in the following figure.

| Resources || Participants

Sessions Track Calendar Speaker Availability Session Time Line

Session Timeline | [Menu~] | [Query| [Refresh | [Print ]
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Viewing Session Details from the Personal Calendar
The following procedure describes how to view session details on your personal calendar.

To view session details from the personal calendar
1 Navigate to the Site Map > Calendar view.
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2 Click the Daily, Weekly, or Monthly view tab.
Your planned sessions appear in your personal calendar.
3 In the Calendar, click the name link for the session you want to view.
The Calendar Detail form appears, showing activity-style details about the session.

NOTE: The personal calendar displays an activity for each session. A session activity in the
calendar is a copy of the session information. You may not reschedule or modify sessions from
the personal calendar.

4 In the Calendar Detail form, select the Alarm check box to receive an online reminder for the
session.
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This chapter discusses topics and procedures that help end users manage events onsite at the venue,
using a direct connection to Siebel Events Management. The topics and procedures discussed include
system requirements for hosting an event, managing activities onsite at the event, hosting onsite
registration, and viewing venue, vendor, and partner information.

This chapter includes the following topics:

B “System Requirements for Hosting an Event” on page 101
“Example Process Flow for Hosting an Event” on page 102
“End-User Procedures for Hosting an Event” on page 102

“Event Leads and Opportunities” on page 105

“Correspondence Integration” on page 106

System Requirements for Hosting an
Event

Using Siebel Events Management at an event site requires that you have a dedicated connection to
your Siebel database. If an event takes place at a venue that allows you to connect directly to Siebel
Events Management onsite, you can establish an event operations center where you can review and
update event activities, add or change registrations, and quickly locate information about event
vendors and partners.
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Example Process Flow for Hosting an
Event

Figure 9 is based on recommended end-user procedures for hosting an event in Siebel Events
Management.

End-User Procedures

Activity Management
at the Event Venue

-

Onsite Registration

'

Entering Actual Revenues
and Cosls

'

Viewing Venue, Vendor,
and Partrer Information

Figure 9. Process Flow for Event Hosting End-User Procedures

End-User
Procedures for Hosting an Event

This section discusses the following topics and procedures:
B Activity Management at the Event Venue

B Onsite Registration

B Entering Actual Revenues and Expenses

|

Viewing Venue, Vendor, and Partner Information

Activity Management at the Event Venue

When you plan the activities that must be completed for your event, as described in Chapter 5,
“Preparing for an Event,” some of the activities may take place before, during, or after the event. To
make sure that the event goes smoothly, review the status of event activities frequently during the
preparation process.

If your event takes place at a venue that allows you to use Siebel Events Management onsite, you
may want to review, update, add, and assign activities during the event.
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Onsite Registration
If an event allows attendees to register onsite at the event, you may want to set up a registration
area where event staff can use Siebel Events Management to register last-minute attendees.

For more information about how to perform this kind of registration, see Chapter 6, “Registering for
an Event.”

Entering Actual Revenues and Expenses

An important aspect of event management is determining whether an event produces a good return
on investment. In order to determine this, you must record actual event income and expenses. In

Siebel Events Management, you can record these amounts using the Revenue and Expenses views.
These views are also useful for analyzing budget variances, if you have established a budget for your
event. For information on setting up a budget for an event, see “Adding Budget Details” on page 37.

Actual revenues and expenses can be entered using the Revenue and Expenses views at the event
plan, event, and session level. Each revenue and expense record is optionally related to an event
and session. Records entered in the child, roll up to the parent. For example, a revenue record
entered at the session level also appears at the event and event plan level.

Actual expenses can also be recorded at the venue and vendor level. For more information about
creating expense for a venue, see “Researching and Choosing a Venue” on page 61. For more
information about creating expenses for a vendor, see “Researching and Hiring Vendors” on page 66.

The following procedure describes how to record actual revenues for an event or session.

To record actual revenues for an event or session
Navigate to the Site Map > Events > Event view.

In the Events list, select and drill down on the event for which you want to record revenue.
Click the Plan view tab, and then click Revenue.

In the Revenue list, create a new record.

a A W N P

To associate the revenue with a session, in the Session field, click the select button.

The following procedure describes how to record actual expenses.

To create an invoice for an expense
1 From the application-level menu, select Navigate > Site Map > Invoices.

2 In the Invoices list, create a new record.
NOTE: Write down the Invoice # for reference.
3 In the Status field, select Approved.

In the Bill To Account field, click the select button to select an account for billing identification
purposes.

5 From the Pick Account dialog box, select the account, and click OK.
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6 Complete the remaining fields.

To record an expense
Navigate to the Site Map > Events > Event view.

In the Events list, select and drill down on the event for which you want to record an expense.
Click the Plan view tab, and then click Expenses.

In the Expense list, create a new record.

a A W N P

To associate the expense with an event or session, in the Event or Session field, click the drop-
down list, and select the event or session.

(@)

To associate the invoice information, in the Invoice # field, click the select button.

7 In the FS Invoice dialog box, select the Invoice number, and then click OK.

Viewing Venue, Vendor, and Partner Information

During an event, you may need to contact venue, vendor, and partner personnel, either to make sure
that planned activities are carried out, or to address unforeseen needs that arise during the event.
If you can access Siebel Events Management onsite, you can look up contact information for venue,
vendor, and partner personnel.

The following procedures briefly describe how to look up this type of information. For information
about entering new venue, vendor, and partner information, see Chapter 5, “Preparing for an Event.”

To view venue information
Navigate to the Site Map > Events > Event Plans view.

In the Event Plans list, select and drill down on the event for which you need information.
Click the Schedule view tab, and then click Events.

In the Events list, select and drill down on the event for which you wish to view information.
Click the Resources view tab, and then click Venues.

Select the venue for which you need information.
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Review the following areas for the information that you need:

®  Venues record

m  Billing subview

m  Expenses subview

m  Reviews subview (accessed from the Billings view drop-down list)

8 To view additional information about the venue, including location and account information, click
the name link for the selected record in the Venues list.

9 To display venue room information, drill down on the venue record, and click the Rooms view tab.
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To view vendor information

1
2
3
a4
5
6
7

Navigate to the Site Map > Events > Event Plans view.

In the Event Plans list, select and drill down on the event for which you need information.
Click the Schedule view tab, and then click Events.

In the Events list, drill down on the event.

Click the Participants view tab and then click Vendors.

In the Vendors list, select the vendor for which you need information.

Review the following areas for the information you need:

® The Vendors list

®  The Billing subview

m  The Reviews subview (In the Billings subview drop-down list)

8 To view account or contact information, click the selected record’s name link in the Name or
Primary Contact column of the Vendors list.

To view partner information
Navigate to the Site Map > Events > Event Plans view.

In the Events list, select and drill down on the event for which you need information.
Click the Schedule view tab, and then click Events.

In the Events list, select and drill down on the Event Name.

Click the Participants view tab, and then click Partners.

In the Partners list, select the partner for which you need information.
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To view account or contact information about the selected partner, click the name link in either
the Name or Primary Contact column of the Partners list.

Event Leads and Opportunities

During an event, or after an event has occurred, leads or opportunities are often captured for
distribution to the sales team. Using Siebel Events Management, you can capture opportunities
associated with a particular event.

To create a new opportunity, see Siebel Applications Administration Guide.

To associate an opportunity to an event
1 Navigate to the Site Map > Events > Event view.

2 In the Events list, select and drill down on the event.

3 Click the Results view tab, and then click Opportunity.
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In the Opportunity list, create a new record.
In the Name field, click the select button.

In the Pick Opportunity dialog box, select the opportunity, and click OK.

VI ©2 B 1 BN

Complete the rest of the fields as necessary.

Correspondence Integration

Siebel Correspondence allows users to generate template-based correspondence to a group of
contacts. You can leverage this functionality from within Siebel Events to send any type of
correspondence to event attendees, for example, a registration package before the event or session
or follow-up literature.

You can only send correspondence to attendees. You cannot send correspondence to prospects.

For information on setting up and administering Correspondence templates, see the Siebel
Correspondence, Proposals, and Presentations Guide.

To send correspondence to attendees
1 Navigate to the appropriate view:

®  For an event, navigate to the Site Map > Events > Event > Attendees view.

m For a session, navigate to the Site Map > Events > Sessions > Attendees view.
In the Participants list, select one or more attendees.

From the File menu, choose Send Letter.

In the Correspondence list, select an enclosure to send.

o b W N

Click Submit.
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When an event is over, your company can evaluate the effectiveness of the event using Siebel Events
Management. This chapter discusses features that help end users evaluate events, for example event
summary reports, performance reviews of vendors and venues, and attendee registration records.

This chapter includes the following topics:
B “Example Process Flow for Evaluating an Event” on page 107
B “Administrator Procedures for Evaluating an Event” on page 108

B “End-User Procedures for Evaluating an Event” on page 108

Example Process Flow for Evaluating an
Event

Figure 10 shows the on recommended flow for end-user procedures to evaluate an event in Siebel
Events Management—viewing budget variances, preparing reports for an event, entering venue and
vendor performance reviews, and event followup.

Viewing Budget Variances

Preparing Reports
for an Event

Entering Yenus and Vendor
Pesformance Reviews

Figure 10. Process Flow for Event Evaluation End-User Procedures

See “End-User Procedures for Evaluating an Event” on page 108 for a discussion of these procedures.
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Administrator Procedures for Evaluating
an Event

There are no specific administrator procedures related to evaluating an event. However, as an
administrator, you need to set up reporting parameters during the initial configuration of your Siebel
application.

For information on setting report parameters, see Siebel Reports Guide.

End-User Procedures for Evaluating an
Event

This section discusses the following topics and procedures:
B Viewing Budget Variances

B Preparing Reports for an Event

B Entering Venue and Vendor Performance Reviews
B Event Followup

B Viewing a Contact’s Events

B Viewing a Contact’s Sessions

Viewing Budget Variances

After recording actual revenues and expenses, as described in Chapter 8, “Hosting an Event,” you can
view budget variances at the event plans, event, or session level. The following procedure describes
how to view budget variances for an event.

To view budget variances for an event
1 Navigate to the Site Map > Events > Event view.

2 In the Events list, select and drill down on the event for which you want to view budget variances.
3 Click the Plan view tab.
4 Click the Expenses link to view the expense variance.

NOTE: Aggregated budget variances can also be viewed within the Event screen, Details view
within the financial information fields.
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Preparing Reports for an Event

Siebel Events Management includes a preconfigured event summary report to assist you in
evaluating events. This report contains information on attendance, budget, revenues, and vendor
and venue performance ratings.

To produce an event summary report
1 Navigate to the Site Map > Events > Event Plans view.

2 In the Event Plans list, select and drill down on the event plan for which you want to produce a
summary report.

Click the Schedule view tab, and then click Events.
In the Events list, select the event for which you want to produce a summary report.

Click the Reports button.

o 00 A~ W

From the Select a Report field, select Event Summary.

Entering Venue and Vendor Performance Reviews

During or after an event, you can enter performance reviews of the venues and vendors with which
you are working. To make sure the information is available when venues and vendors are considered
for future events, enter comments soon after an event is complete.

The following procedure describes how to enter a venue performance review for an event.

To enter a venue performance review
1 Navigate to the Site Map > Events > Event Plans view.

2 In the Event Plans list, select and drill down on the event for which you want to enter a venue
performance review.

Click the Schedule view tab, and then click Events.
In the Events list, select and drill down on the event.

Click the Resources tab, and then click Venues.

o 00~ W

In the Venues list, select the venue that you want to review, and scroll down to the Billings
subview.

\]

In the Billings subview, from the drop-down list, select Reviews.

In the Reviews list, create a new record, and complete the necessary fields. See Table 11 on
page 110 for more information.

The following procedure describes how to enter a vendor performance review for an event.
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To enter a vendor performance review
Navigate to the Site Map > Events > Event Plans view.

In the Event Plans list, select the event for which you want to enter a vendor performance review.
Click the Schedule view tab, and then click Events.
In the Events list, select and drill down on the event.

Click the Participants view tab, and then click Vendors.

o 00 A W N P

In the Vendors list, select the venue that you want to review, and scroll down to the Billings
subview.

\‘

In the Billings subview, from the drop-down list, select Reviews.

8 Inthe Reviews list, create a new record, and complete the necessary fields. See Table 11 for more
information.

Table 11 displays some fields in the Reviews list.

Table 11. Selected Fields in the Reviews List

Field Comments

Reviewer Automatically populates with the username of the user who creates the review.

Posted Automatically populates with the date and time when the record is created.

Rating (1-10) Allows you specify a numerical rating for the venue. Valid values are 1 through
10, where 10 is the best rating.

Comments Provides space for any comments you have about the venue or vendor.

Event Followup

Siebel Events Management provides information that can be used to follow-up with invitees and
attendees based on their levels and areas of interest. For an event plan with a single event, you can
identify those with a strong interest by comparing the lists of those who were invited with those who
attended. For a larger, multievent event, you can identify areas of interest by reviewing which events
and sessions particular contacts attended. You can also gauge event success based on the
percentage of invited accounts that attended.

Viewing a Contact’s Events

Siebel Events Management provide information that allows you to view events that your contacts
have registered to attend.

To view a contact’s events
1 Navigate to the Site Map > Contacts > Contacts List view.
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From the Contact List drop-down list, select All Contacts Across Organizations.
In the Contacts List, drill down on the Contact’s last name.
Click the Events view tab.

NOTE: This view must be added to the current user’s responsibility.

Viewing a Contact’s Sessions

Siebel Events Management provides information that allows you to view sessions that your contacts
are attending.

To view a contact’s sessions

1

2
3
4

Navigate to the Site Map > Contacts > Contacts List view.

From the Contact List drop-down list, select All Contacts Across Organizations.
In the Contacts list, drill down on the Contact’s last name.

Click the Sessions view tab.

NOTE: This view must be added to the current user’s responsibility.
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A iIness Service

There are two event business services used for event and session registration respectively:
EventRegistrationService and SessionRegistrationService. These business services contain several
methods, which are outlined in Figure 11 and Figure 12 that follow. The primary method used to
register an individual into an event or session is EnrollAdmin. The other functions are mostly
subroutines called by this primary method. They are documented here for the benefit of technical
developers who may wish to override specific methods, to add custom functionality. For more
information on business services, see Using Siebel Tools.

This chapter includes the following topics:
B “Example Methods of Business Services” on page 114

B “Descriptions of Business Services Methods” on page 115
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Example Methods of Business Services

EnrallAdrmin Enrallser

LIpdateRegistration

CheckPreviousRegn

¥

CheckSpace

I 3

CreateRenistration

F Y

CleanSpace

LpdateSpace »  Checkuote » AddToShoppingCart
Figure 11. EventRegistrationService Flow
EnrallAdmmin b  EnrollUser b CheckPreviousRedn M CheckBpace
EnrollEndUser —— UndateRenistration | CreateRegistration CleanSpace
Checkverlaps UpdateSpace » Checkiluote » AddToShoppingCart

Figure 12. SessionRegistrationService Flow
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Descriptions of Business Services
Methods

Siebel Events Management uses business services to perform registration management tasks behind
the scenes. If desired, developers can employ these business services and methods to register
individuals into events and sessions through scripting, workflow, or other configuration designs.

This topic includes the following business services:
B EventRegistrationService Business Service Methods

B SessionRegistrationService Business Service Methods on page 124

EventRegistrationService Business Service Methods

This topic describes the EventRegistrationService business services methods.

EnrollAdmin Method

This method is used to register one or more individuals. Input Property set is a nested property set
where each row is an input contact or prospect. This method is invoked from RegisterAll button,
where all dummy records in the current context are registered. See Table 12 for a description of
EnrollAdmin Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 12. EnrollAdmin Method Properties

Properties Description

Eventld* Input Property - Row Id of the Event.

Prospect ID Input Property - Row Id of the prospect being registered. This
property is used by the Siebel Marketing Server during campaign
execution.

Type (‘EVENT’) Input Property - Always set to “EVENT”

List Id Input Property - List Id that contains the contact, if applicable.

List Owner Id Input Property - The list creator Id that contains the contact, if
applicable.

Dummy Id (Dummy regn Id) | Input Property - Dummy registration record Id.

Contact Id Input Property - The row Id of the contact being registered.

User Type* Input Property - type of individual being registered. “Contact” or
“Prospect.”

Return Val* Output Property - “Success” or “Failure.”

Output Type* Output Property - Further information on the result.
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Table 12.

EnrollAdmin Method Properties

Properties Description

Shopping Flag

Output Property - Determines whether the Shopping Cart process
is required. “YES” or Null.

Error Regn

Output Property - Cumulative error message with additional
information.

EnrollUser Method

This method is used to register a single contact or prospect. See Table 13 for a description of

EnrollUser Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 13.

Properties

EnrollUser Method Properties

Description

Event Id*

Input Property - Row Id of the Event.

Prospect Id

Input Property - Row Id of the prospect being registered. This
property is used by the Siebel Marketing Server during campaign
execution.

Type (‘EVENT’)

Input Property - Always set to “EVENT.”

List Id

Input Property - List Id that contains the contact, if applicable.

List Owner Id

Input Property - List creator Id that contains the contact, if
applicable.

Registration Date

Input Property - Date of registration.

Contact Id

Input Property - Row Id of the contact being registered.

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure.”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String

Output Property - Event Id.

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)

Output Property - Contact or Prospect Id.

Reg Id (Registration Id)

Output Property - Attendee Id.
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Error Code (Contains Error
Identifier)

ess Service Methods ™ Descriptions of Business Services Methods

EnrollUser Method Properties

Output Property - Siebel Error Id.

Shopping Flag (YES or “*)

Output Property - Determines whether the event is fee based and
needs to go through the Shopping Cart process. “YES” or Null.

CheckPreviousRegn Method
This method determines if a previous registration or attendee record exists. See Table 14 for a
description of CheckPreviousRegn Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 14.

Properties

CheckPreviousRegn Method Properties

Description

Event Id* Input Property - Row Id of the Event.

Prospect Id Input Property - Row Id of the prospect being registered. This
property is used by the Siebel Marketing Server during campaign
execution.

Contact Id Input Property - Row Id of the contact being registered.

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure.”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String (Contains Event
1d)

Output Property - Event Id.

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)

Output Property - Contact or Prospect Id.

Error Code (Contains Error
Identifier)

Output Property - Siebel Error Id.

Reg Id (Old regn if it exists)

Output Property - Attendee Id.

Regn Status (Status of the
old regn)

Output Property - Status of previous attendee record.
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CheckSpace Method

This method checks if there is capacity for registration. See Table 15 for a description of CheckSpace

Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 15.

CheckSpace Method Properties

Properties Description

Event Id* Input Property - Row Id of the Event.

Prospect Id Input Property - Row Id of the prospect being registered. This
property is used by the Siebel Marketing Server during campaign
execution.

Contact Id Input Property - Row Id of the contact being registered.

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure.”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String (Contains Event
1d)

Output Property - Event Id.

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)

Output Property - Contact or Prospect Id.

Error Code (Contains Error
Identifier)

Output Property - Siebel Error Id.
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CleanSpace Method
This method removes any old pending registration or attendee records that do not belong to the
current user, to free up capacity. The Business Component User Property “Reservation Time Out
Hour” determines how long these records exist before being deleted. See Table 16 for a description
of CleanSpace Method properties.

Service Methods " Descriptions of Business Services Methods

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 16.

CleanSpace Method Properties

Properties Description

Event Id* Input Property - Row Id of the Event.

Prospect Id Input Property - Row Id of the prospect being registered. This
property is used by the Siebel Marketing Server during campaign
execution.

Contact Id Input Property - Row Id of the contact being registered.

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String (Contains Event
1d)

Output Property - Event Id.

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)

Output Property - Contact or Prospect Id.

Error Code (Contains Error
Identifier)

Output Property - Siebel Error Id.
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CreateRegistration Method

This method calls the UpdateSpace method to create a registration and seat counts. Then calls
CheckQuote to determine if a quote needs to be created. See Table 17 for a description of
CreateRegistration Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 17.

CreateRegistration Method Properties

Properties Description

Event Id* Input Property - Row Id of the Event.

Prospect Id Input Property - Row Id of the prospect being registered. This
property is used by the Siebel Marketing Server during campaign
execution.

Contact Id Input Property - Row Id of the contact being registered.

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

List Id

ListOwnerld

Dummylid

Input Property - Dummy registration record Id.

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure.”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String (Contains Event
1d)

Output Property - Event Id.

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)

Output Property - Contact or Prospect Id.

Error Code (Contains Error
Identifier)

Output Property - Siebel Error Id.

Quote Item Id

Output Property - Quote Item Row Id.

Reg Id

Output Property - Attendee Id.

Shopping Flag (“Y” or “*)

Output Property - Determines whether the Shopping Cart process
is required. “YES” or Null.
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UpdateRegistration Method

This method is called when a pending registration or attendee already exists. Completes the
registration by calling other methods as necessary. See Table 18 for a description of
UpdateRegistration Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 18.

UpdateRegistration Method Properties

Properties Description

Event Id* Input Property - Row Id of the Event.

Prospect Id Input Property - Row Id of the prospect being registered. This
property is used by the Siebel Marketing Server during campaign
execution.

List Id Input Property - List Id that contains the contact, if applicable.

List Owner Id

Input Property - List creator Id that contains the contact, if
applicable.

Registration Date

Input Property - Date of registration.

Contact Id

Input Property - Row Id of the contact being registered.

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

Reg Id*

Output Property - Attendee Id.

Status™

Input Property - Status of the registration.

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure.”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String (Contains Event
1d)

Output Property - Event Id.

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)

Output Property - Contact or Prospect Id.

Error Code (Contains Error
Identifier)

Output Property - Siebel Error Id.

Quote Item Id

Output Property - Quote Item Row Id.

Reg Id

Output Property - Attendee Id.

Shopping Flag (“Y” or “*)

Output Property - Determines whether the Shopping Cart process
is required. “YES” or Null.

Siebel Events Management Guide Version 8.1/8.2 121



Registration Business Service Methods = Descriptions of Business S

UpdateSpace Method
This method creates or updates a regn and updates event counts within a Lock to ensure transaction
integrity. See Table 19 for a description of UpdateSpace Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 19. UpdateSpace Method Properties

Properties Description

Event Id* Input Property - Row Id of the Event.

Prospect Id Input Property - Row Id of the prospect being registered. This
property is used by the Siebel Marketing Server during campaign
execution.

Contact Id Input Property - Row Id of the contact being registered.

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

Action* (Mode of Operation
to be performed - create
regn, update regn)

Input Property - Operation can be performed.
Increase count: Enroll an attendee

Drop from enroll: Drop an attendee (no functionality present for
this currently)

Drop from waiting: Drop an WL attendee (no functionality present
for this currently)

Drop from invited: Drop an invitee (no functionality present for this
currently)

Waiting to enroll: Enroll an existing attendee (called from Update
Regn)

Invitee to enroll: Enroll an invitee (called from Update Regn)

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure.”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String (Contains Event
1d)

Output Property - Event Id.

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)

Output Property - Contact or Prospect Id.

Error Code (Contains Error
Identifier)

Output Property - Siebel Error Id.

Reg Id

Output Property - Attendee Id.
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This method determines whether the current user needs to be charged. See Table 20 for a description
of CheckQuote Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 20.

CheckQuote Method Properties

Properties Description

Prospect Id Input Property - Row Id of the prospect being registered. This
property is used by the Siebel Marketing Server during campaign
execution.

Contact Id Input Property - Row Id of the contact being registered.

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

Reg Id*

Input Property - Registration or attendee row Id.

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure.”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String (Contains Event
1d)

Output Property - Event Id.

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)

Output Property - Contact or Prospect Id.

Error Code (Contains Error
Identifier)

Output Property - Siebel Error Id.

AddToShoppingCart Method

This method invokes the shopping service to create a quote item. See Table 21 for a description of
AddToShoppingCart Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 21.

Properties

AddToShoppingCart Method Properties

Description

Prospect Id Input Property - Row Id of the prospect being registered. This
property is used by the Siebel Marketing Server during campaign
execution.

Contact Id Input Property - Row Id of the contact being registered.
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Table 21.

Properties

AddToShoppingCart Method Properties

Description

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

Reg Id*

Input Property - Registration or attendee row Id.

Event Id*

Input Property - Event row Id.

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure.”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String (Contains Event
1d)

Output Property - Event Id.

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)

Output Property - Contact or Prospect Id.

Error Code (Contains Error
Identifier)

Output Property - Siebel Error Id.

Quote Id

Output Property - Quote Row Id (Returns a quote id if a new quote
is created).

Quote Item Id

Output Property - Quote Item Row Id (Returns a quote item Id if
the quote item already exists in the same Web session).

Shopping Flag (“Y” or “*)

Output Property - Determines whether the Shopping Cart process
is required. “YES” or Null.

SessionRegistrationService Business Service Methods

This topic describes the SessionRegistrationService business services methods.
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EnrollAdmin Method

This method is used to register one or more individuals. Input property set is a nested property set
where each row is an input contact or prospect. This method is invoked from the RegisterAll button,
where all dummy records in the current context are registered. See Table 22 for a description of
EnrollAdmin Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 22. EnrollAdmin Method Properties

Properties Description

Eventld* Input Property - Event Row Id.

Session Id Input Property - Session Row Id.

Prospect Id Input Property - Row Id of the prospect being registered. This
property is used by the Siebel Marketing Server during campaign
execution.

Type(‘SESSION’) Input Property - Always set to “SESSION.”

Dummy Id (Dummy regn Id) | Input Property - Dummy registration record Id.

Contact Id Input Property - Row Id of the contact being registered.

User Type* (Contact or Input Property - Type of individual being registered. “Contact” or
Prospect) “Prospect.”

Return Val* (Success or Output Property - Further information on the result.

Failure)

Output Type* (Info on the Output Property - Further information on the result.

return value)

Shopping Flag (YES or “*) Output Property - Determines whether the Shopping Cart process
is required. “YES” or Null.

Error Regn (A grouped error | Output Property - Cumulative error message with additional
message if applicable) information.
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EnrollEndUser Method

This method is used for multi-session registration for a contact or a prospect. Check for time overlaps
between selected sessions and existing session registrations. Uses a nested property set. See
Table 23 for a description of EnrollEndUser Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 23. EnrollEndUser Method Properties

Properties Description

Event Id* Input Property - Event Row Id.

Session Id Input Property - Session Row Id.

Prospect Id Input Property - Row Id of the prospect being registered. This
property is used by Siebel Marketing Server during campaign
executions.

Type (‘SESSION’) Input Property - Always set to “SESSION.”

Contact Id Input Property - Row Id of the contact being registered.

User Type* (Contact or Input Property - Type of individual being registered. “Contact” or

Prospect) “Prospect.”

Reg Id (Empty) Input Property - Registration or attendee row Id. Not used.

Status (Empty) Input Property - Registration or attendee status. Not used.

Registration Date (Empty) Input Property - Registration date. Not used.

Parent Registration Id Input Property - Registration or attendee row Id for the session’s

(Empty) parent event. Not used.

Start Date™* Input Property - Start Date and Time of the session.

End Date* Input Property - End Date and Time of the session.

Name* Input Property - Name of the session (used for error messaging).

Return Val* (Success or Output Property - “Success” or “Failure.”

Failure)

Output Type* (Info on the Output Property - Further information on the result.

return value)

Error Regn (A grouped error | Output Property - Cumulative error message with additional

message if applicable) information.

Shopping Flag (“YES” or ““) Output Property - Determines whether the Shopping Cart process
is required. “YES” or Null.

Parent Reg Id Output Property - Registration or attendee row Id for the session’s
parent event.
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CheckOverlaps Method

This method is used to determine if any of the sessions selected for registration within the event
have time overlaps or conflict with prior registered sessions for the attendee. Uses a nested property
set. See Table 24 for a description of CheckOverlaps Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 24. CheckOverlaps Method Properties

Properties Description

Event Id* Input Property - Event Row Id.
Session Id Input Property - Session Row Id.
Prospect Id Input Property - Row Id of the prospect being registered. This

property is used by Siebel Marketing Server during campaign
executions.

Type (‘SESSION’)

Input Property - Always set to “SESSION.”

Contact Id

Input Property - Row Id of the contact being registered.

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

Reg Id (Empty)

Input Property - Registration or attendee row Id. Not used.

Status (Empty)

Input Property - Registration or attendee status. Not used.

Registration Date (Empty)

Input Property - Registration date. Note used.

Parent Registration Id
(Empty)

Input Property - Registration or attendee row Id for the session’s
parent event. Not used.

Start Date*

Input Property - Start Date and Time of the session.

End Date*

Input Property - End Date and Time of the session.

Name*

Input Property - Name of the session (used for error messaging).

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure.”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String (Contains
Session Id)

Output Property - Event Id

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)

Output Property - Contact or Prospect Id.

Error Code (Contains Error
Identifier)

Output Property - Siebel Error Id.
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Table 24.

CheckOverlaps Method Properties

Properties Description

Reg Id

Output Property - Attendee Id.

Shopping Flag (“Y” or “*)

Output Property - Determines whether the Shopping Cart process
is required. “YES” or Null.

EnrollUser Method

This method is used to register a single contact or prospect. See Table 25 for a description of

EnrollUser Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 25.

EnrollUser Method Properties

Properties

Description

Event Id* Input Property - Event Row Id.
Session Id Input Property - Session Row Id.
Prospect Id Input Property - Row Id of the prospect being registered. This

property is used by Siebel Marketing Server during campaign
executions.

Type (‘SESSION’)

Input Property - Always set to “SESSION.”

Status

Input Property - Registration or attendee status. Not used.

Reg Id (Empty)

Input Property - Registration or attendee row Id. Not used.

Parent Registration Id*

Input Property - Registration or attendee row Id for the sessions’
parent event.

Registration Date

Input Property - Registration date. (Only required if multiple
registration records exist for the same contact.)

Contact Id

Input Property - Row Id of the contact being registered.

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure.”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String (Contains Event
1d)

Output Property - Event Id.

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)
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Table 25.

Properties Description

Reg Id (Registrationld)

ss Service Methods ! Descriptions of Business Services Methods

EnrollUser Method Properties

Output Property - Attendee Id.

Error Code (Contains Error
Identifier)

Output Property - Siebel Error Id.

Shopping Flag (YES or “*)

Output Property - Determines whether the Shopping Cart process
is required. “YES” or Null.

CheckPreviousRegn Method
This method is used to determine if a previous registration or attendee record exists. See Table 26
for a description of CheckPreviousRegn Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 26.

CheckPreviousRegn Method Properties

Properties

Session Id*

Description

Input Property - Session Row Id.

Prospect Id Input Property - Row Id of the prospect being registered. This
property is used by Siebel Marketing Server during campaign
execution.

Contact Id Input Property - Row Id of the contact being registered.

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure.”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String (Contains Event
1d)

Output Property - Event Id.

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)

Output Property - Contact or Prospect Id.

Error Code (Contains Error
Identifier)

Output Property - Siebel Error Id.

Reg Id (Old regn if it it exists)

Output Property - Attendee Id.
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Table 26.

CheckPreviousRegn Method Properties

Properties Description

Regn Status (Status of the
old regn)

Output Property - Status of previous attendees record.

Parent Reg Id

Output Property - Registration or attendee row Id for the session’s
parent event.

CheckParentRegn Method
This method determines if the attendee is registered for the session’s parent event. See Table 27 for
a description of CheckParentRegn Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 27.

Properties

CheckParentRegn Method Properties

Description

Session Id*

Input Property - Session Row Id.

Prospect Id Input Property - Row Id of the prospect being registered. This
property is used by Siebel Marketing Server during campaign
execution.

Contact Id Input Property - Row Id of the contact being registered.

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

Event Id*

Input Property - Event Row Id.

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure.”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String (Contains Event
1d)

Output Property - Event Id.

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)

Output Property - Contact or Prospect Id.

Error Code (Contains Error
Identifier)

Output Property - Siebel Error Id.

Parent Reg Id

Output Property - Registration or attendee row Id for the session’s
parent event.

Parent Status

Output Property - Status of the session’s parent event.
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CheckSpace Method
This method checks if there is capacity for registration. See Table 28 for a description of CheckSpace
Method properties.

Service Methods " Descriptions of Business Services Methods

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 28.

CheckSpace Method Properties

Properties Description

Session Id*

Input Property - Session Row Id.

Prospect Id Input Property - Row Id of the prospect being registered. This
property is used by Siebel Marketing Server during campaign
execution.

Contact Id Input Property - Row Id of the contact being registered.

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure.”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String (Contains Event
1d)

Output Property - Event Id.

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)

Output Property - Contact or Prospect Id.

Error Code (Contains Error
Identifier)

Output Property - Siebel Error Id.
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CleanSpace Method

This method removes any old pending registration or attendee records that do not belong to the
current user, to free up capacity. The Business Component User Property “Reservation Time Out
Hour” determines how long these records exist before being deleted. See Table 29 for a description
of CleanSpace Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 29.

CleanSpace Method Properties

Properties Description

Session Id*

Input Property - Session Row Id.

Prospect Id Input Property - Row Id of the prospect being registered. This
property is used by Siebel Marketing Server during campaign
execution.

Contact Id Input Property - Row Id of the contact being registered.

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure.”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String (Contains Event
1d)

Output Property - Event Id.

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)

Output Property - Contact or Prospect Id.

Error Code (Contains Error
Identifier)

Output Property - Siebel Error Id.
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CreateRegistration Method

This method calls the UpdateSpace method to create a registration and seat count. Then it calls
CheckQuote to determine if a quote needs to be created. See Table 30 for a description of
CreateRegistration Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 30.

Properties

CreateRegistration Method Properties

Description

Event Id

Input Property - Event Row Id.

Session Id*

Input Property - Session Row Id.

Prospect Id Input Property - Row Id of the prospect being registered. This
property is used by Siebel Marketing Server during campaign
execution.

Contact Id Input Property - Row Id of the contact being registered.

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

Parent Registration Id

Input Property - Registration or attendee Id of the parent event.

Dummylid

Input Property - Dummy Registration Id.

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure.”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String (Contains Event
1d)

Output Property - Event Id.

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)

Output Property - Contact or Prospect Id.

Error Code (Contains Error
Identifier)

Output Property - Siebel Error Id.

Quote Item Id

Output Property - Quote Item Row Id.

Reg Id

Output Property - Attendee Id.

Shopping Flag (‘Y” or “*)

Output Property - Determines whether the Shopping Cart process
is required. “YES” or Null.
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UpdateRegistration Method

This method is called when a pending registration or attendee already exists. Completes the
registration by calling other methods as necessary. See Table 31 for a description of
UpdateRegistration Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 31.

Properties

UpdateRegistration Method Properties

Description

Event Id

Input Property - Event Row Id.

Session Id*

Input Property - Session Row Id.

Prospect Id Input Property - Row Id of the prospect being registered. This
property is used by Siebel Marketing Server during campaign
execution.

Status Input Property - Status for the registration.

Registration Date

Input Property - Date of the registration.

Contact Id

Input Property - Row Id of the contact being registered.

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

Reg Id*

Input Property

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure.”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String (Contains Event
1d)

Output Property - Event Id.

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)

Output Property - Contact or Prospect Id.

Error Code (Contains Error
Identifier)

Output Property - Siebel Error Id.

Quote Item Id

Output Property - Quote Item Row Id.

Shopping Flag (‘Y” or “*)

Output Property - Determines whether the Shopping Cart process
is required. “YES” or Null.

Reg Id

Output Property - Registration or attendee Id.
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UpdateSpace Method
This method creates or updates a regn and updates event counts within a Lock to ensure transaction
integrity. See Table 32 for a description of UpdateSpace Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 32. UpdateSpace Method Properties

Properties Description

Session Id*

Input Property - Session Row Id.

Prospect Id Input Property - Row Id of the prospect being registered. This
property is used by Siebel Marketing Server during campaign
execution.

Contact Id Input Property - Row Id of the contact being registered.

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

Parent Registration Id

Input Property - Registration/attendee Id of the parent event.

Action* (Mode of operation
to be performed - create
regn, update regn)

Input Property - Operation can be performed.
Increase count: Enroll an attendee

Drop from enroll: Drop an attendee (no functionality present for
this currently)

Drop from waiting: Drop an WL attendee (no functionality present
for this currently)

Drop from invited: Drop an invitee (no functionality present for this
currently)

Waiting to enroll: Enroll an existing attendee (called from Update
Regn)

Invitee to enroll: Enroll an invitee (called from Update Regn)

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure.”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String (Contains Event
1d)

Output Property - Event Id.

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)

Output Property - Contact or Prospect Id.
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Table 32.

UpdateSpace Method Properties

Properties Description

Error Code (Contains Error
Identifier)

Output Property - Siebel Error Id.

Reg Id

Output Property - Registration or attendee Id.

CheckQuote Method

This method determines whether the current user needs to be charged. See Table 33 for a description
of CheckQuote Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 33.

CheckQuote Method Properties

Properties

Description

Prospect Id Input Property - Row Id of the prospect being registered. This
property is used by Siebel Marketing Server during campaign
execution.

Contact Id Input Property - Row Id of the contact being registered.

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

Reg Id*

Input Property - Registration or attendee row Id.

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure.”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String (Contains Event
1d)

Output Property - Event Id.

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)

Output Property - Contact or Prospect Id.

Error Code (Contains Error
Identifier)

Output Property - Siebel Error Id.
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AddToShoppingCart Method

This method invokes the shopping service to create a quote item. See Table 34 for a description of
AddToShoppingCart Method properties.

NOTE: Input Properties marked by an asterisk(*) indicate a required field.

Table 34.

AddToShoppingCart Method Properties

Properties Description

Prospect Id Input Property - Row Id of the prospect being registered. This
property is used by Siebel Marketing Server during campaign
execution.

Contact Id Input Property - Row Id of the contact being registered.

User Type* (Contact or
Prospect)

Input Property - Type of individual being registered. “Contact” or
“Prospect.”

Reg Id*

Input Property - Registration/attendee row Id.

Session Id*

Input Property - Session Row Id.

Return Val* (Success or
Failure)

Output Property - “Success” or “Failure.”

Output Type* (Info on the
return value)

Output Property - Further information on the result.

Error String (Contains Event
1d)

Output Property - Event Id.

Error Message (Error
encountered)

Output Property - Description of any error encountered.

Error Param (User Id)

Output Property - Contact or Prospect Id.

Error Code (Contains Error
Identifier)

Output Property - Siebel Error Id.

Quote Id

Output Property - Quote Row Id. (Returns a quote Id if a new quote
is created)

Quote Item Id

Output Property - Quote Item Row Id. (Returns a quote item Id if
the quote item already exists in the same Web session.)

Shopping Flag (‘Y” or “*)

Output Property - Determines whether the Shopping Cart process
is required. “YES” or Null.
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Table 35 outlines some commonly-used business component user properties, and describes how they
can be used to modify the behavior of the Siebel Events Management application. User properties
are changed using Oracle’s Siebel Tools, and should only be modified by experienced developers.
Please test the application thoroughly to ensure expected results after modifying user properties.

Table 35. User Properties Table

Business Default
Component User Property Description Value
eEvents Event | Cancel Attendees Y = Canceling Event cancels attendees for | Y

the event. N = Attendee status remains.

Internal Charge Flag | Y = Employees are not charged for the fee- | N
based events. N = Employees are charged.

On Field Update Set | To dynamically change the invitation Start Date,
deadline date. Specify days in value using “Invitation
specified format. Deadline”,

“[Start
Date] - 60~
Relate Activity Determine if activity needs to be created, Y

when event is created. Y = activity created.
N = no activity.

When an event is created, an error results if
the TODO_TYPE list of values does not
include an active value that has eEvent as
language independent code.

CustomFieldX

where X is a number

Used to copy a single-value field value from
a parent event to child events. A user
property with the same number for X must
exist on the parent and child business
component. The CustomFieldX user
properties that you use must all be active
and in logical order.

CustomMVFEX

where X is a number

Used to copy a multi-value field value from
a parent event to child events. A user
property with the same number for X must
exist on the parent and child business
component.
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Table 35. User Properties Table

Business Default
Component User Property Description Value
eEvents Event | Reservation Time Time (in hours) after which pending records | 4
Attendee Out Hour can be deleted if there is a necessity to free
up space.
Auto Register Y = Automatically register the individual’s Y
Company company when the individual registers. N =
Do not automatically register the company.
eEvent Event Cancel Attendees Propagate of cancellation status for Y
Session attendee from event to session. Y =
Propagate status. N = Do not propagate.
Inherit Event Date If event date changes out of scope, this N
property determine whether the session will
inherit either the Start or End Date of the
event. Y = Inherit date from event. N = Do
not change date.
Internal Charge Flag | Y = Employees will not be charged for fee- | N
based sessions. N = Employees are
charged.
Relate Activity Determine if activity needs to be created, Y

when session is created. Y = Activity
created. N = No activity.

When a session is created, an error results
if the TODO_TYPE list of values does not
include an active value that has Session as
language independent code.
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Table 35. User Properties Table

Event Business Component User Properties B

Business Default
Component User Property Description Value
eEvents Parent | Event Schedule View | Determine which view is displayed after the | eEvent
Event Create Event button is selected. Parent
Event
Events
View
CustomFieldX Used to copy a single-value field value from
. a parent event to child events. A user
BRI 213 & LD property with the same number for X must
exist on the parent and child business
component. The CustomFieldX user
properties that you use must all be active
and in logical order.
CustomMVFX Used to copy a multi-value field value from
. a parent event to child events. A user
BRI 213 & LD property with the same number for X must
exist on the parent and child business
component.
eEvent Session | Reservation Time Time (in hours) after which pending records | 4

Attendee

Out Hour

can be deleted if there is a necessity to free
up space.
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A

account data, entering 27
account, registering
about 81
registering (procedure) 82
activities
activity template for an event, creating 41
activity, adding to an event 41
event management activities, about
creating 40
session activity, removing 84
activity template, creating 41
administrators
event information, making visible to
administrators only 58
registering an attendee, about 77
attachments, attaching to a event 69
attendee list
registering for an event 77
attendees
calendar, removing session activity from 84
event or session, registering for 78
prospective attendee, about inviting 69
registering, ways to 77
registration for an event, canceling 85
automatic email notification
See email notification, configuring automatic

B
billing
billing parameters, recording for an event
vendor 67
venue billing information, entering 63
browser requirements 11
budget
budget variances, viewing for an event 108
estimated cost for an event, entering 37

C

calendar
events calendar, relationship with personal
calendar 97
session activity, removing from attendee’s
calendar 84
session calendar, viewing 55
session details, viewing from personal
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calendar 99
collateral, adding to an event or session 60
contact data, entering 26
content
See speaker and content, preparing for
Correspondence Integration
sending correspondence to attendees 106
costs
estimated costs for an event, entering 37
recording a cost 103, 104
Customizing Siebel Events Home Page
Applets 94
Customizing Siebel Events Homepage
Applets
Browse Events Applet 96
My Events Applet 95
Upcoming Events Applet 96

D

Deal Roadshow event type
about and visibility 32
specific deal, associating with 32

E
email notification, configuring automatic
about 12
setting up (procedure) 12
employees
event information, making visible to internal
employees 58
event information, making visible to invited
company employees 58
equipment, specifying for rooms 28
evaluating an event
See also individual event entries
administrator procedures, about 108
budget variances for an event, viewing 108
event follow-up, about 110
event summary report, producing 109
process flow example, about and
diagram 107
reports for an event, about preparing 109
vendor performance review, entering 110
venue performance review, entering 109
event activity
See also individual event entries
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assigning (procedure) 50
assigning to team members, about 49
progress, monitoring 50
event definition business tasks, list of 15
event implementation, list of tasks 17
event management process
See also individual event entries
about 15
event definition business tasks, list of 15
event evaluation, list of tasks 17
event implementation, list of tasks 17
event preparation, list of tasks 16
event materials
See also individual event entries
event plans
about events calendar and personal
calendar 97
adding event plan details 30
adding session 52
approving 40
creating an assumption 31
creating attendee lists 77
defining 29
deleting an event plan 33
entering travel arrangements 71
modifying an event plan 33
registering attendees 76
setting goals 31
summarized financial information 39
tracking guests of attendees 80
viewing budget variances 108
event status report
preparing a report 72
event summary report, producing 109
event track, adding 30
event, defining
See also individual event entries
account data, entering 27
activity template for an event, creating 41
activity, adding to an event 41
administrator event definition business
scenario 17
contact data, entering 26
end-user event definition scenario 18
estimated costs for an event, entering 37
event management activities, about
creating 40
event plans, event, and session data,
about 29
event tracks, adding 30
event venue, adding 28
event venue, entering room information for
potential venue 28
event venues, defined 27

event, about adding and updating 30

event, adding (procedure) 31

event, deleting 33

event, modifying 33

LOVs for event management, reviewing and
modifying 20

pricing models, about and setting up
process 28

process flow example, about and diagram 19

tables, about updating 23

event, registering for

See also self-registering for an event and
individual event entries

account, about registering 81

account, registering (procedure) 82

attendee list, registering for an event 77

attendee, ways to register 77

canceling registrations and using the waiting
list, about 85

event or session, registering an attendee
for 78

open seat, allocating to person on waiting
list 86

potential attendee’s registration,
canceling 85

process flow example (diagram) 76

registration workflow 82

session activity, removing 84

session registration and activity records,
workflow (diagram) 83

troubleshooting, about 85

events

See also individual event entries

activity, adding to event 41

actual revenues, recording 103

adding (procedure) 31

attendee list, registering for 77

attendee, registering for 78

collateral, adding to 60

evaluation phase, about 17

event data, about 29

event information, making visible to all 57

event venue, about activity
management 102

file, attaching to 69

onsite registration, about 103

pending or waitlisted registration, completing
to attend an event 90

potential attendee’s registration,
canceling 85

self-registering to attend (procedure) 89

self-registering to attend, conditions to
meet 89

session template, associating with 54
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session, adding to 52
sessions attendees, viewing 55
sessions, viewing only available 55
staff member, adding to 48
storage of information, about 29
updating and adding, about 30
vendor, associating with 66
events calendar
See also individual event entries
browser requirements 98
event details, viewing 98
personal calendar, relationships with 97
Events Web site, self-registering as a
user 88
events, preparing for
See also individual event entries
billing parameters, recording for an event
vendor 67
business scenario 44
contacts, associating with a track 47
event activities, monitoring progress of 50
event activity, about assigning to team
members 49
event activity, assigning (procedure) 50
event status report, preparing 72
event, adding staff member to 48
event, attaching file to 69
partner organization, associating with an
event or session 65
process flow example (diagram) 45
prospective attendees, about inviting 69
related track, associating 47
session, adding a staff member to 49
session, associating one or more with a
track 46
site preparation tasks, about 61
speaker preparation tasks, basic
questions 51
staff and speaker availability, viewing 49
tasks, list of 43
track calendar, using 47
track management tasks, list of tasks 46
track members, viewing 48
travel arrangements, entering 71
travel arrangements, tracking 72
vendor discounts or special rate codes,
entering 68
vendors, about researching and hiring 66
vendors, associating with an event or
session 66

F

files, attaching to event 69

Index m F

H

hosting an event

actual revenue and costs, about determining
good return 103

actual revenues for event plans, events, or
sessions, recording 103

cost, recording 103, 104

event venue, about activity
management 102

onsite registration, about 103

partner information, viewing 105

process flow example, about and
diagram 102

system requirements 101

vendor information, viewing 105

venue information, viewing 104

1
IBM DB2 UDB, about Shopping Cart
requirements 12
installation
automatic email notification, configuring 12
browser requirements 11
Shopping Cart requirements 12

L
List of Values (LOVSs), reviewing and
modifying 20

M

Microsites
events 59

@)

onsite registration, about 103

P

partner organizations, associating with an
event or session 65
partners, viewing partner information 105
pending registration, completing to attend
an event 90
personal calendar
events calendar, relationship with 97
session detail, viewing from 99
pricing models, about and setting up
process 28
Product Line table, about using 25
prospective attendees
See attendees
publishing information
See Web site
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R

regional hierarchy, about defining 23
registering for an event
See event, registering for; self-registering for
an event
reports
event status report, preparing 72
event summary report, producing 109
event, about preparing reports for 109
Restricted event type, about 58
revenues
actual revenue and costs, about determining
good return 103
event, recording actual revenue for an event
plan, event, or session 103
rooms
equipment, adding in potential room 28
session, assigning a room to 56
RSA encryption, Shopping Cart Requirement
for DB2 UDB 12

S

self-registering for an event
See also event, registering for
about 87
attendee, about registering 77
attending an event (procedure) 89
attending an event, condition to meet 89
Events Web site user, self-registering as 88
pending or waitlisted registration, completing
to attend event 90
sessions within an event, registering to
attend 91
troubleshooting, about 93
Web site registration process 88
Web site visibility rules 87
Web site, registering to use 87
session registration
registering group of attendees
81
session registration, workflow tasks
performed (diagram) 83
session templates
about and setting up 25
event, associating with 54
sessions
actual revenues, recording 103
attendee, registering for 78
collateral, adding to 60
event, adding to 51
event, viewing only available sessions 55
room, assigning to a session 56
session activity, removing 84

session attendees, viewing 55
session calendar, viewing 55
session time line, viewing 55
session, adding speaker to 56
sessions data, about 29
staff member, adding to 49
storage of information, about 29
vendor, associating with 66
within an event, registering to attend 91
setup, administrative tasks
table of 10
Shopping Cart requirements 12
site preparation tasks
event, entering a location for 61
room, assigning to a session 56
venue billing information, entering 63
venue rate codes, associating with an
event 62
venue, about researching and choosing 61
venue, list of setup activities 64
speaker and content, preparing for
collateral, adding to an event or session 60
event, viewing only available sessions 55
information, organizing 51
presentation content, organizing into
sessions 51
session attendees, viewing 55
session calendar, viewing 55
session template, associating with a
event 54
session time line, viewing 55
session, adding speakers to 56
Web site, about publishing information to 57
Web site, making event information
visible 57
Web site, making event information visible to
administrators only 58
Web site, making event information visible to
internal employees 58
Web site, making event information visible to
invited company employees 58
Web site, making event information visible to
invitees and administrators 58
speakers, adding to session 56

T
tables, updating

about 23

Product Line table, about using 25

regional hierarchy, about defining 23

session templates, about and setting up 25
templates

activity template, creating for an event 41
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session templates, about and setting up 25

session templates, associating event with 54
tracks

calendar, using 47

contacts, associating with a track 47

event tracks, adding 30

related tracks, associating 47

session, associating one or more with a
track 46

track management tasks, list of tasks 46

track members, viewing 48

travel arrangements

entering 71
tracking 72

troubleshooting

registration, about 85
self-registering for an event 93

\Y

vendors

billing parameters, recording for an event
vendor 67

event or session, associating with 66

researching and hiring, about 66

vendor discounts or special rate codes,
entering 68

vendor information, viewing 105

vendor performance reviews, entering 110

venues

adding (procedure) 28

defined 27

event venue, entering a location for 61

event venue, entering room information for
potential venue 28
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researching and choosing, about 61

room equipment, specifying 28

room, assigning to a session 56

setup activities, list of 64

venue billing information, entering 63

venue information, viewing 104

venue performance review, entering 109

venue rate codes, associating with an
event 62

viewing session tracks

associating tracks with sessions 56

w

waiting list

canceling registration and using, about 85

open seat, allocating to person on list 86

waitlisted registration, completing to attend
an event 90

Web site

event information, making visible to
administrators only 58

event information, making visible to all 57

event information, making visible to internal
employees 58

event information, making visible to invited
company employees 58

event information, making visible to invitees
and administrators 58

Events Web site user, self-registering as 88

publishing information to, about 57

registering to use 87

registration process 88

visibility rules 87
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