Siebel Performance Tuning Guide > Tuning the Web Server Computer for All UNIX and Linux Platforms > Tuning Siebel Business Applications for AIX >

Tuning Kernel Settings for AIX


This topic is part of Tuning Siebel Business Applications for AIX.

There are several AIX kernel settings you can tune for optimal Siebel Server or Web server performance under AIX. These include the Virtual Memory Management and TCP settings. You must have root privileges to modify these settings. Use the vmo, ioo, and no commands to tune the AIX kernel. For more information about AIX kernel settings, see your operating system vendor's documentation.

To change the kernel settings

  1. Using a text editor such as vi, open the /etc/rc.net file for editing.
  2. Modify settings using vmo, as follows:

    if [ -f /usr/sbin/vmo ] ; then

    /usr/sbin/vmo -o minperm%=5 -o maxperm%=30 -o minfree=720 -o maxfree=768

    In providing values for minfree and maxfree, use the following formulas:

    • minfree = number_of_CPUs times 120 = 6 times 120 = 720
    • maxfree = number_of_CPUs times (120 plus maxpgahead) = 6 times (120 plus 8) = 768

      where:

    • number_of_CPUs is the number of CPUs on the AIX server you are tuning (for example, 6)
    • maxpgahead is the value of the maxpgahead (-o maxpgahead=number) parameter (for example, 8)

      NOTE:  Although the default value for maxperm is 80, for a Siebel Business Applications deployment it must be set to a value between 30 and 50.

  3. Modify settings using ioo, as follows:

    if [ -f /usr/sbin/ioo ] ; then

    /usr/sbin/ioo -o numfsbuf=200 -o sync_release_ilock=1

  4. Modify the network options, as follows:

    if [ -f /usr/sbin/no ] ; then

    /usr/sbin/no -a rfc1323=1

    /usr/sbin/no -a tcp_sendspace=24576

    /usr/sbin/no -a tcp_recvspace=24576

    /usr/sbin/no -a rfc2414=1

    /usr/sbin/no -a tcp_init_window=3

    /usr/sbin/no -a use_isno=0

    /usr/sbin/no -a tcp_nagle_limit=0

  5. Check the settings for all User Limits (ulimit) and make sure that they are set to -1 (unlimited), as follows:

    ulimit -a

    NOTE:  To change the set limits, update the /etc/security/limits file by changing all ulimit parameter values to -1 (unlimited).

  6. Save your changes and exit the editor.
  7. Make sure that the rpc.statd and rpc.lockd daemons run on the Siebel Server computer and on the server computer where the Siebel File System is located. Then set the number of threads for the rpc.lockd daemon on each applicable server computer.

    It is recommended to increase the number of rpc.lockd daemon threads from the default. If possible, use the maximum number of threads, which is 511. System degradation can occur and logins might be blocked if the rpc.lockd daemon is not configured to handle a large number of lock requests. For example, you might execute commands like this:

    chssys -s rpc.lockd -a 511
    stopsrc -s rpc.lockd; startsrc -s rpc.lockd

  8. Restart the server computer to have the new settings take effect.
Siebel Performance Tuning Guide Copyright © 2013, Oracle and/or its affiliates. All rights reserved. Legal Notices.