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Chapter 1
Overview

Welcome to the IStream Document Manager DMS Guide for IStream and Model 
Documents.

This guide is for users who will be working with IStream documents and model 
documents in the DMS.

This chapter describes:

• Document Conventions on page 6

• IStream Document Manager on page 7

• Logging in to IStream Document Manager on page 8

• Configuring Internet Explorer on page 9

• Icons in IStream Document Manager on page 10

• IStream Document Manager Documentation on page 11

• Using the Online Help on page 13

• Contacting Skywire Software for Help on page 16
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Document Conventions

Tips, Notes, Important Notes and Warnings

Tip: A Tip provides a better way to use the software.

Note: A Note contains special information and reminders.

Important: An Important note contains significant information about the use and 
understanding of the software.

Warning: A Warning contains critical information that if ignored, may cause errors or result 
in the loss of information.

Other Document Conventions
• Window names, buttons, tabs and other screen entities are in bold, for 

example: Click Next.

• Paths, URLs and code samples use the Courier font, for example:  
C:\Windows

• Some sections contain links to other Related Topics.
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IStream Document Manager

 IStream Document Manager is a suite of integrated document capabilities, 
including document assembly, document management, search, workflow, 
collaboration and customization that support the entire document life cycle, across 
the enterprise. It enables organizations to better create, manage and distribute 
highly personalized, complex, error-free documents such as contracts, booklets 
and correspondence.

The IStream Document Manager DMS, IStream Author, IStream InfoConnector, 
IStream Assembler, IStream Visualizer, IStream Assembler Add-in for Microsoft 
Word, and IStream Author Add-in for Microsoft Word are all available to use with 
IStream Document Manager, as specified in your license agreement. IStream 
Publisher, Tracker, IStream Product Developer, IStream Communicator and 
IStream Writer are all complimentary products within the product suite.

The IStream Document Manager DMS includes document management 
capabilities such as:

• version control 

• check in and check out of files

• index and searching 

• folder structuring 

• document viewing and retrieval 

• reserving 

• user and group Security 

It also includes:

• document workflow 

• collaboration 

• project creation 

• message boards 

• Interactive IStream document assembly 

• model document management 

The IStream Document Manager DMS provides an easy to use, highly flexible, 
web-based user interface.

The main types of documents you can work with in the IStream Document 
Manager DMS are:

• IStream Documents on page 19

• Model Documents on page 41: this includes sections, and model documents 
in the outline format
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Logging in to IStream Document Manager

IStream Document Manager runs in Internet Explorer.

Method: Log in to IStream Document Manager

1. In Internet Explorer, select the IStream Document Manager Address your 
administrator has set up for you (if it is not already selected).

2. Enter your Username and Password, then click Log-in.

You are now logged in to IStream Document Manager.

Note: When you first log in to Windows, an IStream cleanup utility briefly appears in a 
DOS window.

                          Also note that the screens may appear slightly different than those in this guide.
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Configuring Internet Explorer

Complete the following procedure in Internet Explorer to ensure proper access to 
the IStream Document Manager DMS.

1. Click Tools > Internet options.
2. On the General tab, in the Temporary Internet Files section, click 

Settings.
3. Select the Every visit to the page option, then click OK.
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Icons in IStream Document Manager

IStream Document Manager displays an icon next to each item in the DMS. The 
following table describes the icons that refer to IStream items:

Icon Description

IStream section (.CDS file)

IStream model document (.CMS file)

IStream document (.CLG file)

IStream PDF document (regeneratable .PDF file)

IStream Assembly server

Icons of Older IStream Documents

Old IStream model document format: a .CMS file created with 
Calligo 5.x and earlier

Old IStream section: a .CDS file created with Calligo 5.x and 
earlier

Old IStream document: a customizable .CLG file created with 
Calligo 5.x and earlier

Old IStream document: a non-customizable .CLG file created with 
Calligo 5.x and earlier
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IStream Document Manager Documentation

IStream Document Manager includes the following documents and online help 
files. If you need a copy of any of these documents, please contact your system or 
product administrator.

General Documentation
• The IStream Document Manager Release Notes include general product 

information, product enhancements and new features, supported platforms 
and third-party software, assorted considerations, and known issues and 
limitations.

• The IStream Document Manager ReadMe file describes the contents of the 
installation CD.

• IStream Document ManagerThe IStream Document Manager Glossary 
contains definitions of commonly used IStream terms.

User Guides and Online Help
• The IStream Assembler Online Help describes how to generate documents 

from sections and model documents.

• The IStream Assembler Add-in for Microsoft Word Online Help describes 
how to perform certain IStream Assembler functions directly within 
Microsoft Word.

• The IStream Author User Guide describes how to create, edit, and test 
sections or model documents.

• The IStream Author Add-in for Microsoft Word Online Help describes how 
to perform certain IStream Author functions directly within Microsoft Word.

• The IStream Customizer User Guide describes how to modify the content of 
generated documents so that the changes will be applied during subsequent 
document generations. 

• The IStream Document Manager DMS Guide for IStream and Model 
Documents describes how to edit and work with IStream sections and model 
documents using the DMS user interface.

• The DMS Plug-in for Author Online Help describes how to access DMS 
functionality in IStream Author.

• The IStream InfoConnector Online Help describes how to set up and 
configure IStream InfoSources.

Advanced Guides
• The IStream Document Manager Guide for New Installations explains how 

to complete a new installation of IStream Document Manager. It includes 
system requirements and detailed installation and configuration information.
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• The IStream Document Manager Upgrade Installation Guide explains how 
to upgrade an existing installation of IStream Document Manager. It 
includes system requirements and detailed installation and configuration 
information.

• The IStream Document Manager Message Reference Guide contains lists of 
error, log and SDK messages from the various IStream components. It is for 
technical users who need additional information about the various IStream 
messages they receive.

• The IStream Document Manager Technical Guide is for system 
administrators and technical support staff who configure IStream Document 
Manager and set up links between it and their company’s database. This 
guide is also for those who set up and maintain security groups and 
operators in the system, and who install, optimize, maintain and 
troubleshoot IStream Document Manager. It also describes installing and 
configuring IStream XML InfoSources for interactive and batch generation.

• If you have purchased the IStream Toolkit, the IStream Assembler and 
Extensibility Toolkit Guides are installed onto your system. (You can view 
these guides from the Start > All Programs > IStream menu.)

These guides contain detailed descriptions of the components in the IStream 
Toolkit, or SDK. They are for technical users who need to integrate IStream 
components with their own or other third party applications.

In addition to the toolkit guides, the IStream Toolkit SDK Samples Guide 
gives an overview of the toolkit samples. The samples are working 
examples that can help you develop custom applications.

For more information about the toolkit, see the IStream Document Manager 
Toolkit ReadMe.
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Using the Online Help

This section describes how to use the Online Help and includes information about:

• The Contents of the Online Help on page 13

• Searching the Help on page 13

• Using the Help Index on page 14

• Using the Help Table of Contents on page 14

• Navigating the Help on page 14

• Printing a Help Topic on page 15

The Contents of the Online Help
The Online Help contains the same contents as the related PDF document, but in 
an online Help format.

To open the Online Help, click the Help menu.

The Help is divided into two frames:

• the left frame displays the navigation tools: Contents, Index and Search

• the right frame contains the contents of each Help topic

There are different ways to find a Help topic:

• Searching the Help on page 13

• Using the Help Index on page 14

• Using the Help Table of Contents on page 14

• Navigating the Help on page 14

Searching the Help
You can search the entire Help contents to find a specific topic.

Method: Search the Help

1. In the left pane of the Help, click the Search tab.
2. Enter the word(s) you want to search for, then click Go! or press Enter.
3. A list of Help topics is displayed in descending order by Rank. The Rank 

indicates how many times the word(s) you searched for appears in a Help 
topic. It can help indicate how relevant the topic may be in your search.

Tip: Use specific words in your search, for example: model document. Avoid using 
plurals, for example, “sections,” because this may limit your search results.
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Using the Help Index
The Help Index contains a listing of all the Help topics in alphabetical order.

Method: Use the Help Index

1. In the left pane of the Help, click the Index tab.
2. Click the letter that corresponds to the topic you are searching for. You 

cannot select a letter that is greyed out, because it contains no index entries.
3. A list of all index entries beginning with the letter you selected is displayed.
4. Scroll to the index entry of the topic you are searching for.
5. Click the topic to view its contents in the main body of the Help.

Using the Help Table of Contents
When you open the Help, the Contents are displayed. The Contents contain main 
topics and their subtopics.

Each main topic appears as a book icon:

Each subtopic appears as a page icon:

Subtopics can also appear as book icons. In other words, books can appear within 
other books.

You can open a book by clicking a book icon or the text next to the book icon. 
This will expand the book and display the topics within that book. 

To close an open book, click the book icon. The book “collapses”, hiding the 
topics within the book.

Tip: When a Help topic is displayed, you can click the “Show in Contents” button to 
open the corresponding book that contains the displayed Help topic:

Navigating the Help
To go to the next or previous Help topic in the Contents, use the Next and 
Previous buttons in the right pane of the Help:

To go to the next or previous topic that you have viewed, use the Forward and 
Back buttons in your Web Browser.
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Printing a Help Topic
You can print a Help topic in case you want to refer to it later.

Method: Print a Help topic

1. Click the Print icon in the upper-right corner of the Help:

2. The Print dialog box is displayed.
3. Click Print to print the Help topic. 
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Contacting Skywire Software for Help

Customer Support hours are 8:00 A.M. to 8:00 P.M. (Eastern Time), Monday 
through Friday. Outside of these hours, send us a detailed e-mail message and you 
will be contacted during regular business hours. Please provide detailed 
information, as described in the Support Checklist.

Contact Information

Support Checklist
When contacting Skywire Software Customer Support, please provide the 
following information:

• Your name, company name, e-mail address, and phone number

• Version numbers of all your Skywire Software products

• Name and version of the network software

• Windows version, including any installed Service Packs

• Microsoft .NET Framework version

• DMS version, including any installed Service Packs (if applicable)

• Microsoft Word version (if applicable)

• Database vendor and version (if applicable)

• Error messages and the circumstances of their occurrence

• A full description of the problem:

• What happened? What were the sequence of events that preceded the 
problem?

• In which screen or window did the problem occur?

• Was the problem the result of pressing a key?

• Did the screen freeze? What functions of the software are affected?

• How many people are affected?

Mail: Customer Support
Skywire Software
19 Allstate Parkway, Suite 400
Markham, Ontario, L3R 5A4

Phone: 1-905-513-7466

Fax: 1-905-513-1684

Email: directsupport@skywiresoftware.com

Web: www.skywiresoftware.com
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Chapter 2
IStream Documents

This chapter describes:

• IStream Documents on page 20

• Giving Permission to Generate from a Model Document on page 21

• Adding an IStream Document to the DMS on page 23

• Working with Existing IStream Documents on page 26

• Regenerating an IStream Document on page 30

• Editing an IStream Document on page 32

• Customizing IStream Documents on page 35

• Printing Documents on page 36

• Reserving or Downloading IStream Documents and Sections on page 37

• Categories and Attributes on page 38

• Using Categories and Attributes with IStream Documents on page 39
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IStream Documents

IStream documents are the assembled documents that are created based on a 
model document: see Model Documents on page 41. These files have a.CLG file 
extension. In the Document Management System (or DMS), their MIME 
(Multipurpose Internet Mail Extensions) type is Microsoft Word. 

You can produce IStream documents from: 

• the Document Management System (DMS)

• IStream Author at an Author client workstation

• Assembler at an Author client workstation (this could be local or remote 
generation)

• IStream Publisher

• Microsoft Word, at a client workstation with the IStream Assembler Add-in 
for Microsoft Word installed
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Giving Permission to Generate from a Model 
Document

Before you can create an IStream document, the model document must have the 
appropriate permission, named Generate from Model, assigned to it.

Important: You must have Edit Permissions assigned to the model document to be able to 
assign permissions. If you do not, please contact your system administrator for 
help.

Method: Assign permissions to a model document for generation

1. Navigate to the folder that the model document (the .CMS file) is located in.
2. Click the model document Functions drop-down arrow and select 

Permissions.

The Permissions page opens.

3. Click a link in the Default Access or Assigned Access sections. (For 
information about the fields in these sections, click Help > For this Page.)

An Edit Permissions pane opens.



ISTREAM DOCUMENTS

22 ISTREAM DOCUMENT MANAGER VERSION 6.2 DMS GUIDE FOR ISTREAM AND MODEL DOCUMENTS

4. Select the Generate from Model check box.
5. Click Update on the Edit Permissions pane.
6. Repeat steps 3 to 5 to give Generate from Model permission to other users 

or groups.
7. Click Done.

Please note:
• If this permission is applied to the Public Access group, all users will have 

permission to generate from this model document.

• If you remove Public Access for a user in the DMS, documentation 
generation will fail for this user unless you also manually give permission 
for the Assembly Server object.
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Adding an IStream Document to the DMS

You can add an IStream document to the DMS through remote generation from a 
model document stored on the DMS, or by adding an existing IStream document 
stored on the file system.

Using remote generation allows you to create IStream documents that you can 
regenerate later if database information changes, or if the model document 
changes. Remote generation uses either Assembler or Publisher to generate 
IStream documents.

If you add an IStream document stored on the file system to the DMS, you can 
regenerate the document from the DMS user interface once you have added it.

You can add a traditional IStream document (.CLG) to the DMS, or you can add 
an IStream PDF. Both types of files can be regenerated, but documents saved in 
.CLG format can also be modified in other IStream Document Manager 
applications, such as IStream Customizer.

You can also add a Word document generated from a model document to the 
DMS, but Word documents cannot be regenerated later.

Note: Remote generation is different from the Make Generation command on a model 
document’s function drop-down menu. Make Generation creates a frozen 
version of the generated document that you cannot edit or regenerate.

Method: Add an IStream document

1. Navigate to the folder where you want to add your IStream document.
2. Click Add IStream Document. Alternatively, from the Add Item drop-

down list, select IStream Document.

The Add:IStream Document page opens.
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3. If you want to add the IStream document by generating it from a model 
document on the DMS (remote generation), do one of the following steps:

• From the Model Document drop-down list, select the name of a 
model document on the DMS.

-OR-

• Click Select Model to browse the DMS for the model document.
4. If you want to add an IStream document saved to the file system, enter the 

file’s path in the File field, or click Browse to locate the IStream document.

When browsing for a document on the file system, remember that you can 
add an IStream document (.CLG file), or an IStream PDF. An IStream PDF 
is a regeneratable PDF document that was created by exporting a .CLG to 
.PDF format using the Assembler Add-in for Microsoft Word.

5. Select the Edit check box if you want to open the IStream document for 
editing after you have created it. See Editing an IStream Document on page 
32 for more information.

If you select the Edit check box, the Destination Format drop-down list 
will be hidden. Do not select the Edit check box if the document being 
added is to be a Word document or PDF file. You can only use the Edit 
feature if the destination format is an IStream document.

6. Click the Destination Format drop-down list arrow (which is visible only if 
the Edit check box is cleared) and select the format you want the added item 
to be saved in: .CLG, a .PDF, or .DOC.

Note: If you choose to create the document as a .DOC file, the document will be 
generated and converted to a standard Word document. It will not be able to be 
regenerated.
7. If you chose to create the document as a .PDF file, the PDF Password and 

Verify PDF Password fields are available. Completing these fields will 
require users to enter the password that you specify to open the PDF.

If you do not want to add a password to the PDF, leave the PDF Password 
and Verify PDF Password fields blank.

8. Enter a Name for the IStream document.
9. If you want to change the currently selected storage location for the IStream 

document, click Browse IStream DM to locate the area in the DMS where 
you want the IStream document created.

The Select Container to Create In page opens.

a. Navigate to the folder you want to add the IStream document to.

b. In the Action column, click Select.

The storage location appears in the Create In field.
10. Click Add.

If you have key data variables defined in the model document, you may be 
prompted to enter key data.
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Assembly Server (or Publisher) generates an IStream document. You can 
view the generation log as the document is being generated.

Important: If the folder you specified in Create In has a category attached to it, any required 
attributes assigned to that category must have a value or generation will fail. An 
error message will display and no document will be added to the DMS. Therefore, 
ensure that all required attributes have a value when you assign them to a 
category.
11. When the generation is complete, click OK.

You are returned to the page where you added the IStream document, or, if 
applicable, the IStream document is opened in Microsoft Word for editing. 

12. Click the Refresh button in the browser if your IStream document has not 
been added.
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Working with Existing IStream Documents

You view (View as Web Page), Open, or Download an IStream document in the 
same way as any other document in the DMS.

When you select View as Web Page for an IStream document (see Viewing an 
IStream Document as a Web Page on page 26), it is displayed in HTML format. 
The document appears as read-only and cannot be changed.

When you download an IStream document (see Downloading an IStream 
Document on page 26), a copy of the document is created locally in Microsoft 
Word format.

When you open an IStream document (see Opening an IStream Document on 
page 27), it is displayed in Microsoft Word format.

Note: The IStream document is a Microsoft Word document with additional IStream 
functions available to it.

Viewing an IStream Document as a Web Page
You can view an IStream document as a web page if you have the Livelink Filter 
Pack installed on your system.

Method: View an IStream document

1. Navigate to the document you want to view.
2. Click the Functions drop-down arrow and select View as Web Page.

The document opens in the View as Web Page page in HTML format.

Downloading an IStream Document
You can download an IStream document, and create a copy locally in Microsoft 
Word format.

Method: Download an IStream document

1. Navigate to the document you want to download.
2. Do one of the following steps:

• Click the IStream document name link. The Document Overview page 
opens. Click Download.

- OR -

• Click the Functions drop-down arrow and select Download. A File 
Download dialog box opens.
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3. Click Open to open Microsoft Word within the browser window, displaying 
the IStream document contents, or click Save to save a copy of the 
Microsoft Word document to your local workstation.

Please note:
• When saving a document, if you chose to create a copy of it on your local 

workstation, the link between the IStream document on the DMS and the 
document you have copied and modified is no longer active. Modifications 
will only be reflected in the copy on your workstation, not in the copy in the 
DMS.

• Files that do not have a file extension in their Name will be downloaded as 
Microsoft Word files.

Opening an IStream Document
You can use the Open command to view your IStream document. Open displays 
the document in an embedded version of Microsoft Word. If you make any 
changes to the document, changes must be saved in a separate copy of the IStream 
document stored on your local file system, and are not retained in the copy saved 
on the DMS.

Method: Open an IStream document

1. Navigate to the document you want to open.
2. Click the Open link.

The document is opened in read-only mode in Microsoft Word.

Viewing a Document’s Overview Page
The behavior of a document’s name link can be configured by the administrator so 
that it does one of the following actions when clicked:

• open the document in the browser

- OR -

• open the document’s overview page

If it has been configured, you can view a document’s Document Overview page, 
which provides information about the document. You can also perform various 
functions from the Document Overview page, such as:

• opening, downloading or editing the document

• emailing a link to the document

• accessing previous versions of the document or the document’s properties

• adding a rating to the document
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Method: View an IStream document’s Overview page

1. Navigate to the document that you want to view the Document Overview 
page of.

2. Click the IStream document name link.

The Document Overview page opens.

Viewing the Generation Log for an IStream Document
You can view the generation log for an IStream document stored on the DMS 
using DMS functionality. Viewing the generation log can be useful if you want to 
review generation errors, or if you want to save or print a copy of the log for your 
records.

Note: The View Generation Log feature is only available on IStream documents (.CLG 
files), and not on IStream PDFs.

Method: View the generation log

1. Click the Function arrow next to the name of the IStream document that has 
the log you want to view.

2. Click View Generation Log.
3. The log for the most recent generation of the IStream document opens in the 

current web page.

You can do the following steps:

• select the contents of the log and copy them for pasting into a word 
processing program

• save a .txt copy of the log on your local file system by choosing File 
> Save As.

• print a copy of the log by choosing File > Print.
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4. When you are finished working with the generation log, click the Back 
button in your browser to return to the area in the DMS where the source 
IStream document is stored.
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Regenerating an IStream Document

You might regenerate an IStream document when: 

• database entries have changed (for example, street addresses)

• model document changes have been made

• you need to verify the original generation

You can regenerate a traditional IStream document (.CLG file) or an IStream 
PDF. Not all PDF files are regeneratable IStream PDFs. IStream PDFs are created 
through remote generation in the DMS, or by exporting a .CLG file to .PDF 
format using the IStream Assembler Add-in for Word.

You can only regenerate documents that are unreserved in the DMS. For more 
information on reserved documents, see Reserving or Downloading IStream 
Documents and Sections on page 37.

Method: Regenerate an IStream document

1. Navigate to the document you want to regenerate.
2. Click the Generate link next to the file name. Alternatively, click the 

Functions drop-down arrow and select Generate.

If you are regenerating an IStream PDF, you will be prompted to add a 
password to the PDF. Users will need to enter the password that you specify 
to open the PDF document. If you do not want to add a password, leave the 
PDF Password and Verify PDF password fields empty, and click OK.

Document assembly begins, and you can view the generation log while the 
document is being generated. 

3. A Key Data prompt will appear when you generate if you have key data 
defined and it is not persisted in the model. Enter the key data and click 
Continue.

4. When generation is complete, click OK.

You are returned to the page where you generated the IStream document. 

Please note:
• Regenerating an IStream document automatically creates a new version of 

the .CLG or .PDF file. 

• When you use Edit or Open on a model document, the model document is 
saved as a temporary file. You can edit the file, but the Generate function 
from the IStream Author Plug-in will not be available. Please complete the 
edits to the model document and save the modified document back to the 
DMS. Once your edits are complete, you can create an IStream Document 
by:

• selecting the Add:IStream Document function from the DMS
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-OR-

• using the New IStream Document button available in either IStream 
Assembler or IStream Author Add-in for Microsoft Word.

Method: View changes from a previous version

1. Click the Functions drop-down arrow next to the IStream document with 
the versions that you want to view. 

2. Select Properties > Versions. 

The Versions Tab opens.
3. Do one of the following steps:

• Click the File Name link. The Version Overview page opens. Click 
Open version.

- OR -

• Click the Functions drop-down arrow beside any of the versions, then 
select View as Web Page. The document displays inside the browser.

Note: View as Web Page is only available if you have the Livelink Filter Pack installed 
on your system. If View as Web Page is not available, you can use the Open 
command to view your IStream document.
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Editing an IStream Document

You can edit an IStream document before printing or sending it. The Edit 
function allows you to edit IStream documents using Microsoft Word. The .CLG 
properties of a document are maintained when you modify it.

Note: If the Edit function is not available in the DMS, contact your system 
administrator.

Updating File Formats
The first time you edit a specific IStream document created in a version earlier 
than IStream Document Manager 6.1, the format of the document will 
automatically be updated to reflect the new format introduced with IStream 
Document Manager 6.1.

The file is converted to the new format and saved back to the DMS before it is 
opened in Microsoft Word. All versions of this IStream document will now be in 
the new format. The converted version that is saved to the DMS is saved with a 
temporary file name (for example, 23719.tng).

If you save the IStream document after viewing or editing it in Microsoft Word, a 
new version is added to the DMS with the appropriate file name (for example, 
PolicyABC1234.clg). If you do not save the file, the most recent file will be in 
the new IStream document format with a temporary name (for example, 
23719.tng).

We therefore recommend that you always save the document in Word the first 
time it is opened with IStream Document Manager 6.2.

Method: Edit an IStream Document

1. Navigate to the IStream document to be edited.
2. Do one of the following steps:

• Click the Edit link.

- OR -

• Click the Functions drop-down arrow and select Edit.

Note: If you have never used the Edit function before, you may be prompted to install 
the Edit control.
3. The document opens in Microsoft Word, ready to edit. You can make 

changes to the document, and to the document’s key data and PDF security 
options by choosing Author > Document Properties in Microsoft Word. 
For more information, see the IStream Assembler Add-in for Microsoft 
Word documentation.

4. When you are finished modifying the document, Close it.
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5. You are prompted to save the changes made to your IStream document. You 
can choose from the following three options:

• Save the changes to IStream DM saves the changes to the IStream 
document stored on the DMS, and creates a new version of it.

• Save as a copy on your desktop allows you to save the document as a 
separate copy on your file system, independent from the copy saved on 
the DMS. Your changes will not be reflected in the copy of the IStream 
document stored in IStream Document Manager.

• Discard the changes ends the edit session without saving the changes 
that you made to any location.

Choose an option then click OK. Microsoft Word closes, and you are 
returned to the page in the DMS where you selected the Edit command.

6. To view the additional versions of the document on the DMS, click the 
Functions drop-down arrow and select Properties > Versions. 

The Versions Tab opens, displaying all versions of the document. See also 
Reserving or Downloading IStream Documents and Sections on page 37.

7. To view the file, click the Functions drop-down arrow beside any of the 
versions, and select View as Web Page.

Please note the following information about the Edit function:
• Edits made using the Edit command are not retained if you regenerate. Use 

IStream Customizer if you want to retain changes made to your IStream 
document when you regenerate. See Customizing IStream Documents on 
page 35.

• You must have Microsoft Word installed. We recommend that the version 
of Word be the same as that used to author your model documents.

• You can only use the Edit function to modify a document if you have 
RESERVE permission on it, otherwise you cannot edit the document. For 
more information on reserved documents, see Reserving or Downloading 
IStream Documents and Sections on page 37.

• When you use the Add IStream Document function, you can select the 
Edit check box. If you do, the Destination Format drop-down list will be 
hidden. 

• Do not select the Edit check box if the document being added is to be a 
Word document or a PDF file. Note that you can only use the Edit feature if 
the destination format is an IStream document. 

• After the document is generated, the IStream document (.CLG) is saved in 
the DMS. If the Edit check box was selected on the Add IStream 
Document page, the Edit feature is automatically invoked, allowing you to 
make changes after generation.

• If you have Livelink Explorer installed, some of these sections may vary.
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Note: To re-generate an IStream document after editing it in Word, you must save it to 
the DMS, and use the Generate link in the DMS.

• When clicking a hyperlink in an IStream generated document from IStream 
Document Manager, a prompt will appear asking if you want to save the 
document. Click No to ignore the prompt and continue to the hyperlink 
destination.
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Customizing IStream Documents

You can use IStream Customizer to edit IStream documents. It is only when you 
edit an IStream document in Customizer that the document retains the edits when 
the document is regenerated.

To customize documents using IStream Customizer:

• you must have IStream Customizer installed on your computer

• you must have the proper security permissions to use IStream Customizer

• the document you want to customize must be set up to be customized: see 
Setting Document Permissions on page 35 in the IStream Customizer User 
Guide

• the document must have tagged text

See the IStream Customizer User Guide for an explanation of all IStream 
Customizer functions.

Method: Customize an IStream document

1. Navigate to the IStream document to be edited.
2. Click the Customize link. Alternatively, click the Functions drop-down 

arrow and select Customize.

Note: If you are using Windows Vista, an Internet Explorer warning may 
appear stating: A website wants to open web content using this program 
on your computer. Click Do not show me the warning for this program 
again, then click Allow.

IStream Customizer opens.
3. If the User Information dialog box opens, enter the default User name and 

Password for InfoSources.
4. Add custom wordings to the tagged text blocks as necessary.
5. When you are done editing, QuickGen or regenerate the document to update 

it and apply the wordings.
6. Click Save and Close.

Another version of the document is added to the DMS.
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Printing Documents

Once you have generated your document, you can print it. IStream Document 
Manager can process a single generated document or a batch of many documents. 
You may direct documents to a specific printer, or print on a specific schedule.

Note: This section applies to any IStream documents, Word documents or PDFs that are 
generated.

Method: Print one or more documents

1. Select the check box next to the documents you want to print. 

2. Click the Print button .

The Items to be Printed page opens.

3. Click Print Documents.

Printing in Batch Mode
IStream Document Manager supports printing of documents in batch mode with 
IStream Publisher. For details, see the IStream Publisher documentation.
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Reserving or Downloading IStream Documents 
and Sections

When you reserve an IStream document (.CLG) in the DMS, you can download it.

When you reserve a model document (.CMS) or section (.CDS), you do not have 
the download function available from the Reserve screen, but you can download 
it after it has been reserved. 

If the document in the DMS does not have a file extension, then a .DOC file 
extension is added to the file name when you download it.

If the document in the DMS already has a file extension, it is saved with its 
existing file extension (.CLG, .CMS, or .CDS). You will be able to open the 
document in the corresponding application (like IStream Author or IStream 
Assembler), or you can open it in Word. 

Reserving a document prevents other users from editing it. Reserved documents 
are shown in the DMS with a checkmark next to them.

Use the Unreserve command to allow other users access to the document for 
editing. Use the Download command to make and use a local copy of a document.



ISTREAM DOCUMENTS

38 ISTREAM DOCUMENT MANAGER VERSION 6.2 DMS GUIDE FOR ISTREAM AND MODEL DOCUMENTS

Categories and Attributes

Categories and attributes are useful tools when searching for a specific document 
or object within the DMS. For more information about how to use categories and 
attributes, see Using Categories and Attributes with IStream Documents on page 
39.

Using categories and attributes eliminates having to perform full text searches on 
documents in the DMS.

Categories
A category is a classification or type of group of documents and other items.

For example, car insurance can be a category. This is a line of business within an 
insurance company. Users would typically want to search within that category in 
the DMS.

Attributes
An attribute is a field or data value that describes a document or other item that is 
stored as metadata to use in searches in the DMS. 

For example, the policy number 12345 is an attribute value of the policy.

Attributes allows users to search for very specific documents by using attribute 
values in their searches.

Using Categories and Attributes in Searches
Categories and attributes work together during the search process. One or more 
attributes can belong to a category.

For example, instead of doing a full text search for a document with the text 
12345, you can search for a car insurance (category) document with a policy 
number of 12345 (attribute).

Categories and attributes work directly with key data and the DMS search engine. 
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Using Categories and Attributes with IStream 
Documents

This section describes how categories and attributes are used with IStream 
documents.

Categories and Key Data
When coding a model document in IStream Author, you can apply a category to 
the master section of the model document by using the Key Data tab of the 
Properties dialog box. You can view the Properties of the master section by 
clicking File > Section Properties in IStream Author.

For more information, see the IStream Author Online Help or IStream Author 
User Guide. 

Creating Categories
Users with administrator privileges create categories using the Open the 
Categories Volume page in the DMS. You cannot add categories to IStream 
documents by using the Add Item > Category function in the DMS.

Attributes need to be manually added to the category in the DMS that is assigned 
to the model document. The names of the attributes must match the names of the 
persistent variables in the model documents. Persistent variables do not need to be 
in key data.

Required Attributes
If a category has a required attribute, a value must be specified for both 
documents and folders. If required attributes are left blank, unexpected problems 
may occur. Attribute information from model documents override attribute 
information in the DMS.

Example
You create a model document in Author that has a matching category name in the 
DMS. The model document does not have any persistent variables defined that 
match any attributes assigned to the category for the folder on the DMS. When 
you add the generated document to the DMS folder, the category is assigned to the 
document, but the attribute value from the folder category is not assigned.

Using Decimal Values
If decimal values are used in number-type persistent variables or in the key data of 
an IStream document that is stored on the DMS, you will not be able to update the 
Category Information page for this document. If you try to use decimals, a DMS 
error will occur.
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Generating IStream Documents
When you generate an IStream document from the model document, IStream 
Assembler takes the category assigned to the model document and checks it 
against the category assigned to the folder where it is being stored. One of the 
following actions will occur:

• if the folder does not have a category, Assembler will assign the model 
document’s category to the IStream document

• if the folder does have a category, the IStream document will inherit the 
category of the folder, while also maintaining the model document category

• if both the folder and the model document have a category, the IStream 
document will have both categories assigned to it
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Chapter 3
Model Documents

This chapter describes:

• Model Documents on page 42

• Adding a New Model Document Master Section on page 44

• Adding a New Section on page 47

• Adding an Existing Section on page 49

• Promoting Model Documents on page 50

• Editing Model Documents on page 51
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Model Documents

A model document is like a template. The way a model document is structured 
determines how the output (the IStream document) appears.

A model document consists of a mandatory master section and other, optional 
sections that, when assembled, determine how a model document is generated.

A model document is constructed with references, rules, and sections. 

A model document is like the root and trunk of a tree. The document’s other 
sections are like the branches.

To produce a generated document from a model document, the document 
generator examines all of the required branches of the tree, locating the data called 
for in each rule and expression. It then assembles this information into a generated 
document that can be viewed (see Viewing an IStream Document as a Web Page 
on page 26) and eventually distributed by a variety of methods, such as print, 
email, regular mail and fax.

In the IStream Document Manager, you can perform the following functions with 
model documents:

• Adding a New Model Document Master Section on page 44

DOCUMENT
SECTION
(optional)

ISTREAM
DOCUMENT

(*.clg)

DOCUMENT
SECTION
(optional)

text

MASTER
SECTION

(mandatory)

DOCUMENT
SECTION
(optional)

Model
Document

ASSEMBLY
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• Adding a New Section on page 47 

• Promoting Model Documents on page 50

• Editing Model Documents on page 51

Model Document Characteristics
A model document stored on a DMS has the following characteristics:

• When you create a new model document master section, it is stored within 
the folder that you specify.

• File extensions are not automatically entered. If you want to add the .CMS 
or .CDS extension, you must do so manually. Adding extensions is essential 
when dealing with files going to and from a DMS repository to a file system 
repository.
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Adding a New Model Document Master Section

This section describes how to add a new model document master section to the 
DMS using IStream Author. For more information about model documents and 
sections, see Model Documents on page 41, and the Author Online Help or Author 
User Guide.

Storing model document sections on the DMS allows many authors to edit the 
sections that make up a model document. It also ensures that the resources of the 
Assembly Server are available to all users.

You can add a new master section to the DMS in the traditional format, or in the 
new model document outline format.

Method: Add a new master section and create a new model 
document in the traditional format

Note: Following the steps below will only create a traditional master section, not a 
model document outline. If you want to create a model document outline and store 
it in the DMS, see Add a new model document outline on page 45.

1. Navigate to the folder in the DMS where you want to store the new master 
section.

2. From the Add Item drop-down list, select IStream Section. 

The Add: IStream Section page opens.

3. Select the Create New Model check box. Choosing this check box will 
create the new section in the master section (.CMS) format, setting the 
section as the basis of a new model document. If you do not select the check 
box, the section is created in the .CDS format.

4. Enter a name for the new master section in the Name field. 
5. Confirm that the folder in the Create In field is the one where you want the 

new master section to be saved on the DMS. Click Browse IStream DM to 
select a different location.
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6. Click Add.

Author opens on your local workstation. The New Master Section dialog 
box opens.

7. Click OK.

The master section for the new model document is opened in Author. 
8. Click Save on the Author toolbar. 

The document is saved and compiled. You can continue working with the 
model document in Author, or you can close the model document. For 
information on authoring model documents, see the Author Online Help or 
the Author User Guide.

When you return to the DMS, navigate to the folder that you previously 
selected in the Create In field on the Add: Model Document page (in step 
4). The master section has been saved to that location.

Method: Add a new model document outline

1. In Author, choose File > New Model Document Outline.

The New Master Section dialog box displays.
2. Enter a Name for the new outline.
3. If necessary, enter a Description.
4. If necessary, modify the Effective and Termination dates.
5. To apply the attached template to all sections that you include in the outline 

later, select the Attach Template check box. Then, navigate to the 
Microsoft Word template that you want to attach to the outline.
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6. Click OK. 

A new model document outline is created.
7. Click File > Save As.

The outline is compiled, and the Save As dialog opens.
8. Verify that the DMS repository that you want to save the outline to is 

selected. You can see the name of the currently selected repository at the top 
of the Save As dialog.

To choose a different repository:

a. Click Repository

b. Select one of the repositories available in the list, and click OK.

Note: You can use InfoConnector to establish a new repository if necessary. See the 
InfoConnector Help for more information.
9. Enter a Name for the model document outline. This name will be the one 

given to the model document outline in the DMS.
10. Click Save.

The model document outline is saved to the DMS in the location that you 
specified. You can continue working with the model document in Author, or 
you can close the model document. For information on authoring model 
documents, see the Author Online Help or the Author User Guide.
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Adding a New Section

This section describes how to add a new section to the DMS using IStream 
Author. For more information on model documents and sections, see Model 
Documents on page 41 and the Author Online Help or the Author User Guide.

Method: Add a new section

1. Navigate to the folder in the DMS where you want to store the new model 
document section.

2. From the Add Item drop-down list, select IStream Section. 

The Add: IStream Section page opens.

3. Enter the new section name in the Name field. 
4. Confirm that the folder entered in the Create In field is where you want the 

new section saved on the DMS. Click Browse IStream DM to select a 
different location.

5. Click Add.

IStream Author opens on your local workstation. The New Sub Section 
dialog box opens.
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6. Click OK.

The new section is opened in Author.
7. Click Save on the Author toolbar. 

The new section is saved and compiled.

You can edit the section in Author, or you can close the section. For 
information on authoring model documents and sections, see the Author 
Online Help or the Author User Guide.

When you return to the DMS, navigate to the folder that you selected in the 
Create In field on the Add: IStream Section page. The new section has 
been saved to that location.

Note: The Specific tab within the Properties of a section contains values (such as the 
Section Name, Effective Date and Termination Date) that you cannot edit in 
IStream Document Manager. You can use IStream Author to edit these values.
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Adding an Existing Section

If a section was previously stored on the file system, you can add it to the DMS.

Method: Add an existing section

1. Navigate to the folder in the DMS where you want to store the model 
document section.

2. From the Add Item drop-down list, select IStream Section. 

The Add: IStream Section page opens.

3. Enter the section name in the Name field. 
4. Next to the File field, click Browse, and select the section (.CMS or .CDS 

file) file stored on a file system that you want to add to the DMS.
5. Confirm that the folder entered in the Create In field is where you want the 

section saved on the DMS. Click Browse IStream DM to select a different 
location.

6. Click Add.

When a master section is added to the DMS, you cannot generate documents from 
it until Generate from Model permission is given. See Giving Permission to 
Generate from a Model Document on page 21.
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Promoting Model Documents

A model document cycles through various stages of development, quality 
assurance testing, and production. Often, a model document is stored on a 
different repository for each phase of its creation and use. When a different 
repository is used for each of the development, quality assurance, and production 
stages, you need to move your model documents from one location to another so 
that a new group of users can test, modify, or generate from the model documents 
as necessary.

The process of moving model documents from one repository to another is called 
promotion. To promote model documents from one repository to another, you 
should use the IStream Promoter utility. For more information and instructions, 
see IStream Promoter on page 113 of the IStream Document Manager Technical 
Guide.
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Editing Model Documents 

Before being used in a production environment, model documents may need to be 
edited to ensure that they work properly when they are generated using Assembly 
Server or IStream Publisher.

When sections are stored on the DMS, you can edit them directly from the DMS 
instead of needing to open them in Author first.

There are two main ways of editing model documents:

• Editing Model Documents Using IStream Author on page 51

• Editing Model Documents in Word on page 52

Editing Model Documents Using IStream Author
You can use IStream Author to edit model documents.

Method: Edit model documents using IStream Author

1. Navigate to the model document.
2. Click the Author link.

Note: If you are using Windows Vista, an Internet Explorer warning may 
appear stating: A website wants to open web content using this program 
on your computer. Click Do not show me the warning for this program 
again, then click Allow.

Author opens, and the model document is opened for editing.
3. Make the necessary changes within Author.
4. Click Save, then Close the model document. For more information about 

authoring model documents, see the Author Online Help or Author User 
Guide.

Model Document Editing Considerations
Please note the following considerations when editing model documents using 
IStream Author:

• Each time a model document is edited and saved again in the DMS, a 
version is added to each section. For more information on versioning, and 
how to view previous versions of a document, see View changes from a 
previous version on page 31.

• If an individual section is opened for editing outside of a model document, it 
cannot be generated; it can only be compiled. Only a whole model document 
can be generated.
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• When you are editing a model document or an individual section, the 
sections become reserved. They are not available to be edited by other users 
until they are unreserved. For more information on reserved documents, see 
Reserving or Downloading IStream Documents and Sections on page 37.

Editing Model Documents in Word
You can edit sections in Microsoft Word using the Edit command in the DMS. 

Method: Edit the section in Word

1. Navigate to the section on the DMS that you want to modify.
2. Click Edit next to the section. (If you have never used the Edit feature 

before, you may be prompted to install the Edit control.)
3. The section opens in Microsoft Word, ready to edit. You can modify any 

code as necessary.

If you opened a master section created in model document outline format, 
you will be able to see the model document code, but you will not be able to 
modify it. If you want to change the rules in a model document outline, you 
need to open the outline in Author and use model document outline 
functionality to adjust the rules as appropriate. For more information, see 
The Model Document Outline on page 189 of the Author User Guide.

4. When you are finished working with the section, click Close.

You are prompted to save the changes made to the section. You can choose 
from the following options:

• Save the changes to IStream DM saves the changes to the section 
stored on the DMS, and creates a new version of it.

• Save as a copy on your Desktop allows you to save the section as a 
separate copy on your file system, independent from the copy saved on 
the DMS. Your changes will not be reflected in the copy stored on the 
IStream Document Manager.

• Discard the changes ends the edit session without saving the changes.
5. Choose an option then click OK.

Microsoft Word closes, and you are returned to the page in the DMS where 
you selected the Edit command.

Note: Your section has been saved, but it may not have been compiled. To compile it, 
click the Compile link beside the document.
6. To view the additional version of the section on the DMS, click the 

Functions drop-down arrow for the section, scroll to Properties and click 
Versions.
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Please note the following information about the Edit command:
• You must have Microsoft Word installed, and its version must be the same 

as that used to author your model documents.

• To compile model document sections, the IStreamDM Proxy needs to be 
running on the Assembly Server. 

• You can only Edit a document on which you have Reserve permission. For 
more information on reserved documents, see Reserving or Downloading 
IStream Documents and Sections on page 37.

• When clicking a hyperlink in an IStream generated document from IStream 
Document Manager, a prompt will appear asking if you want to save the 
document. Click No to ignore the prompt and continue to the hyperlink 
destination.

• Edit does not include all of Author’s wizards. It is a Microsoft Word edit of 
the model.
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