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This document provides information on:

= Section 1, "ADF Skin Editor System Requirements"

= Section 2, "Installing the ADF Skin Editor"

= Section 3, "Using the ADF Skin Editor on Windows"

= Section 4, "Using the ADF Skin Editor on Linux and UNIX Systems"
= Section 5, "Using the ADF Skin Editor on Mac OS X Platforms"

= Section 6, "Enabling ADF Skin Editor Extensions"

= Section 7, "Setting the User Home Directory"

= Section 8, "Documentation Accessibility"

1 ADF Skin Editor System Requirements

This release of the ADF Skin Editor is tested and supported on the specific versions
Windows, Linux, and Mac OS X, as listed in Section 1.1, "Recommended CPU,
Memory, Display, and Hard Drive Configurations". In addition, it is supported on any
operating system that supports Sun Java SE Development Kit (JDK) 6 Update 20 or
later.

1.1 Recommended CPU, Memory, Display, and Hard Drive Configurations

The following tables list the recommended CPU, memory, display, and hard drive
requirements for the different operating systems:

s Table 1, " Recommended CPU, Memory, Display, and Hard Drive Requirements
for Windows"

s Table 2, " Recommended CPU, Memory, Display, and Hard Drive Requirements
for Linux"

s Table 3, " Recommended CPU, Memory, Display, and Hard Drive Requirements
for MAC OS X"

The following table lists the recommended CPU, memory, display, and hard drive
requirements for the Windows operating system:
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Table 1 Recommended CPU, Memory, Display, and Hard Drive Requirements for

Windows
Resource Recommended
Operating System Windows Vista
Windows 7
Windows Server 2003 R2
Windows Server 2008
Windows XP-Service Pack 2
CPU Type and Speed Pentium IV 2 GHz or faster
Memory 2 GBRAM
Display 65536 colors, set to at least 1024 X 768 resolution
Hard Drive Space 500 MB
JDK JDK 6.0 Update 20 for Windows, available at:

http://www.oracle.com/technetwork/java/jav-
ase/downloads/index.html

The following table lists the recommended CPU, memory, display, and hard drive
requirements for the Linux operating system:

Table2 Recommended CPU, Memory, Display, and Hard Drive Requirements for Linux

Resource Recommended
Distribution Red Hat Enterprise Linux 5.0
Red Hat Enterprise Linux 4.0
Oracle Enterprise Linux 5.0
Oracle Enterprise Linux 4.0
SUSE Linux Enterprise Server 10
SUSE Linux Enterprise Server 11
CPU Type and Speed Pentium IV 2 GHz or faster
Memory 2 GBRAM
Display 65536 colors, set to at least 1024 X 768 resolution
Hard Drive Space 500 MB
JDK JDK 6.0 Update 20 for Linux, available at:

http://www.oracle.com/technetwork/java/jav-
ase/downloads/index.html

The following table lists the recommended CPU, memory, display, and hard drive
requirements for the Mac OS X operating system:

Table 3 Recommended CPU, Memory, Display, and Hard Drive Requirements for MAC

oS X

Resource Recommended

Operating System Apple Mac OS X Version 10.5.2 or later
CPU Type and Speed 64-bit Intel processors

Memory 2 GBRAM

Display "Thousands" of colors

Hard Drive Space

500 MB




Table 3 (Cont.) Recommended CPU, Memory, Display, and Hard Drive Requirements for
MAC OS X

Resource Recommended

JDK Sun Java SE 6 for Mac OS X 10.5, available at:
http://www.apple.com/support/down-
loads/javaformacosxl05update2.html.

2 Installing the ADF Skin Editor

The ADF Skin Editor does not require an installer. To install the ADF Skin Editor, you
will need an unzip tool. You can download a free, cross-platform unzip tool, Info-Zip,
available at: http: //www.info-zip.org/.

Caution: Make sure that you install the ADF Skin Editor into a
directory that does not contain spaces. For example, do not use
C:\Program Files as the installation directory.

To install the ADF Skin Editor from skineditor. zip:

1. If you don't have JDK 6.0 Update 20 or later installed, you can obtain it from:
http://www.oracle.com/technetwork/java/javase/downloads/index
.html.

2. Unzip skineditor.zip to the target directory.

Caution: After you unzip skineditor. zip to the target directory,
do not rename the skineditor directory that contains the ADF Skin
Editor executable. For example, if you unzipped skineditor. zip to
C:\installdir, do not rename the skineditor directory at the
following location: C: \installdir\skineditor. This directory is
part of the ADF Skin Editor installation.

Note: For the remainder of this document, in the context of the ADF
Skin Editor, Mw_HOME is used to represent the directory of the
installation. For example, if you unzipped skineditor.zip into
C:\installdir, then MW _HOME refers to
C:\installdir\skineditor.

3 Using the ADF Skin Editor on Windows

Once the installation is complete, you can begin using the ADF Skin Editor on
Windows systems.

3.1 Starting the ADF Skin Editor

To start the ADF Skin Editor on Windows, run the following command from the
command line:

s MW_HOME\skineditor.exe




3.2 Specifying the JDK location

Specify the location of your JDK installation in the dialog that appears when you start
the ADF Skin Editor for the first time. You will need to enter the path to the Java
executable, for example D:\jdk1.6.0_20\bin.

3.3 Changing the JDK location

To change a JDK location that you have previously specified, set the variable
SetJavaHome in the file Mw_HOME\ skineditor\bin\skineditor.conf to the
location of your JDK installation. Use an editor that recognizes UNIX end-of-line
characters, such as WordPad. When you save the file, WordPad will warn you that it is
about to save the file in text-only format. You can ignore this warning.

For example, in a Windows environment, if the location of your JDK is in a directory
called jdk1.6.0_20 on your D: drive, your entry in skineditor.conf would look like:

SetJavaHome d:\jdkl.6.0_20

3.4 User Directories

The following list describes the default directory structure within the ADF Skin Editor
on Windows:

»  The default location for the system subdirectory is
$APPDATA%\skineditor\systemll.1.2.0.XX.XX.XX, where XX .XX.XX is
the unique number of the product build.

»  The default location for user-generated content is:

- C:\Users\user\Documents\skineditor\mywork on Windows Vista
systems.

- C:\skineditor\mywork on all other Windows platforms.

For more information on user directories and how to set the value for the home
environment variable, see Section 7, "Setting the User Home Directory".

4 Using the ADF Skin Editor on Linux and UNIX Systems

Once the installation is complete, you can begin working with the ADF Skin Editor on
Linux and UNIX systems.

4.1 Changing System Cursors

On UNIX or Linux platforms, the Java cursors may display large and opaque, creating
difficulties when used for drag and drop operations. To address this problem the ADF
Skin Editor provides a set of cursors to replace the default set. You must have write
access to the JDK in order to replace the cursors.

To replace the cursors:

1. Make a backup copy of the default cursors located in the JDK directory at:
<jdk_install>/jre/lib/images/cursors

2. Extract the replacement cursors from the tar file at:

MW_HOME/skineditor/jdev/bin/clear_cursors.tar




4.2 Setting the System Resource Limit

The minimum recommended system resource limit for the ADF Skin Editor on Linux
systems is 4096.

To determine the resource limit configuration for your system, enter:

= /bin/sh -c 'ulimit -n

If the value returned is less than 4096, you set the system resource limit:

1. Openthe 1imits.conf file, which is located in the /etc/security/ directory.
2. Look for the following lines:

* soft nofile <value>
* hard nofile <value>
3. In the lines, change the value to 4096. The lines will then read:

* soft nofile 4096
* hard nofile 4096

Note: In case the lines listed in Step 2 do not exist, add the lines
listed in Step 3 to the 1imits. conf file.

4.3 Starting the ADF Skin Editor
To start the ADF Skin Editor on Linux and UNIX, run the following file:

MW_HOME/skineditor/bin/skineditor

4.4 Specifying the JDK location

When you start the ADF Skin Editor for the first time, the skineditor script prompts
you to provide the location of your JDK installation if it cannot locate it. You will need
to enter the path to the Java executable, for example /usr/local/java/bin/java.

4.5 Changing the JDK location

To change a JDK location that you have previously specified, set the variable
SetJavaHome in the file MW _HOME/skineditor/bin/skineditor.conf to the
location of your Java installation.

For example, in a UNIX environment, if the location of your JDK is in a directory
called /usr/local/java, your entry in skineditor.conf would look like:

SetJavaHome /usr/local/java

5 Using the ADF Skin Editor on Mac OS X Platforms

Once the installation is complete, you can begin using the ADF Skin Editor on Mac OS
X platforms.

5.1 Starting the ADF Skin Editor
To start the ADF Skin Editor, run the following file:

MW_HOME/skineditor/bin/skineditor.




5.2 Specifying the JDK location

When you start the ADF Skin Editor for the first time, the skineditor script prompts
you to provide the location of your JDK installation if it cannot locate it. You will need
to enter the path to the Java executable, for example /usr/local/java/bin/java.

5.3 Changing the JDK location

To change a JDK location that you have previously specified, set the variable
SetJavaHome in the file MWw_HOME/skineditor/bin/skineditor.conf to the
location of your Java installation.

For example, in a Mac OS X environment, if the location of your JDK is in a directory
called /usr/local/java, your entry in skineditor.conf would look like:

SetJavaHome /usr/local/java

6 Enabling ADF Skin Editor Extensions

You can use the ADF Skin Editor to create ADF skins for Fusion web applications built
on different releases of Oracle ADF. Before you create an ADF skin that targets a
different release, you may need to download an extension from OTN that provides
support for the release you want to target.

To automatically download and install an ADF Skin Editor extension:
»  From the Help menu, select Check for Updates.

On the Source page of the Check for Updates wizard, you can specify the update
center to download the extension from, or specify a local file to install the
extension from.

Search the Official Oracle Extensions and Updates update center to download
extensions for the ADF Skin Editor.

To manually download an ADF Skin Editor extension:

1. Goto
http://www.oracle.com/ocom/groups/public/@Qotn/documents/webco
ntent/131167.xml.

2. Select an extension for the ADF Skin Editor.

3. Follow the instructions to download the zip file.

To manually install an extension for the ADF Skin Editor:

1. Verify if there are additional installation instructions in the extension archive.
2. From the Help menu, select Check for Updates.

3. On Step 1 of the wizard, select Install from a Local File and navigate to the zip
file.

4. Finish the wizard and restart ADF Skin Editor. After you restart ADF Skin Editor,
you will be able to use the extension.

For more information, click Help in the dialogs that the Check for Updates wizard
displays.




7 Setting the User Home Directory

This section provides instructions on how to define a user home environment variable
and set its value for each user in order for the ADF Skin Editor to identify user home
directories correctly.

The user home directory contains the user's preferences for the ADF Skin Editor (in the
system subdirectory). It is also the default location for new projects (in the
\skineditor\mywork\ directory) as well as other configuration files that are
specific to a given user.

Caution: Make sure that you choose a Home directory that does not
contain spaces. For example, do not use C: \My Home as your home
directory.

To define the name of the user home environment variable:

1. Open the file Mii_HOME/skineditor/bin/skineditor.boot in a text editor.
Use an editor that recognizes UNIX end-of-line characters, such as WordPad.

2. Find the entry:
ide.user.dir.var = JDEV_USER_HOME, JDEV_USER_DIR

This is the default variable that the ADF Skin Editor will look for at startup. You
can define or add any environment variable that the ADF Skin Editor should use.
As the terminal server administrator, you may change the name of this variable to
follow your system's naming conventions.

Note: You can explicitly set the home environment variable by
adding the following line in the skineditor.boot file:
ide.user.dir = <Path to preferred user directory>

The output should look something like this:

ide.user.dir = D:\users\jdoe (on Windows)
ide.user.dir = /home/users/jdoe (on Linux and UNIX)

3. Save the file. If you are using WordPad, it will warn you that it is about to save the
file in text-only format. You can ignore this warning.

The user home directory can also be specified from the command line using this
command:

skineditor.exe -J-Dide.user.dir=<Path>
Examples:
s skineditor.exe -J-Dide.user.dir=D:\users\jdoe (on Windows).

s skineditor -J-Dide.user.dir=/home/users/jdoe (on Linux and UNIX).

7.1 Setting the Home Environment Variable on Windows

To set the home environment variable on a Windows systems, including individual
users of the ADF Skin Editor on a multiuser system, use the following steps:
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Caution: Do not set the home environment variable to a directory
that contains spaces. For example, do not specify C: \My Projects
as the home directory.

From the Windows Start menu, select Control Panel, and then select System.
Select the Advanced tab, then click Environment Variables.
In the User Variables section, click New.

Add JDEV_USER_DIR, or the name you chose for ide.user.dir.var, as a user
variable.

Set the value of this variable to your home directory (for example,
N:\users\jdoe), and click OK.

To check your variable setting, open a command shell and enter:
set

You should see output similar to the following;:
JDEV_USER_DIR=N:\users\jdoe

Launch the ADF Skin Editor.

From the Help menu, select About to verify that the value of ide.user.diris
set to your user home directory.

7.2 Setting the Home Environment Variable on Linux and UNIX

Use the following steps to set the environment variable on Linux and UNIX systems.
The examples and syntax provided refer to the C Shell.

Caution: Do not set the home environment variable to a directory
that contains spaces. For example, do not specify home/jdoe/my
projects as the home directory.

In your startup configuration file (for example, . cshrc), set the environment
variable to your preferred directory. For example, use the following command to
set the home environment variable to mydocs/skinfiles under the $HOME
directory:

setenv JDEV_USER_DIR S$HOME/mydocs/skinfiles
Source the file to make your changes take effect:

source .cshrc

Display the environment variable to confirm the change:
echo $JDEV_USER_DTR

You should see output similar to the following;:
/home/jdoe/mydocs/skinfiles

Launch the ADF Skin Editor.

From the Help menu, select About to verify that the value of ide.user.diris
set to your user home directory.




By default, the user home directory on Linux and UNIX is $HOME/ jdevhome.

7.3 Setting the Home Environment Variable on Mac OS X

Use the following steps to set the environment variable on Mac OS X systems. The
examples and syntax provided refer to the BASH shell.

Caution: Do not set the home environment variable to a directory
that contains spaces. For example, do not specify home/jdoe/my
projects as the home directory.

1. In your startup configuration file (for example, .bashrc), set the environment
variable to your preferred directory:

JDEV_USER_DIR=$SHOME/mydocs/skinfiles

2. Export the new value of the environment variable:
export JDEV_USER_DIR

3. Source the file to make your changes take effect:

.profile

4. Display the environment variable to confirm the change:
echo $JDEV_USER_DIR
You should see output similar to the following;:
/Users/jdoe/mydocs/skinfiles

5. Launch the ADF Skin Editor.

6. From the Help menu, select About to verify that the value of ide.user.diris
set to your user home directory.

By default, the user home directory on Mac OS X is $SHOME/jdeveloper.

8 Documentation Accessibility

Our goal is to make Oracle products, services, and supporting documentation
accessible to all users, including users that are disabled. To that end, our
documentation includes features that make information available to users of assistive
technology. This documentation is available in HTML format, and contains markup to
facilitate access by the disabled community. Accessibility standards will continue to
evolve over time, and Oracle is actively engaged with other market-leading
technology vendors to address technical obstacles so that our documentation can be
accessible to all of our customers. For more information, visit the Oracle Accessibility
Program Web site at http: //www.oracle.com/accessibility/.

Accessibility of Code Examples in Documentation

Screen readers may not always correctly read the code examples in this document. The
conventions for writing code require that closing braces should appear on an
otherwise empty line; however, some screen readers may not always read a line of text
that consists solely of a bracket or brace.




Accessibility of Links to External Web Sites in Documentation

This documentation may contain links to Web sites of other companies or
organizations that Oracle does not own or control. Oracle neither evaluates nor makes
any representations regarding the accessibility of these Web sites.

Access to Oracle Support

Oracle customers have access to electronic support through My Oracle Support. For
information, visit http://www.oracle.com/support/contact.html or visit
http://www.oracle.com/accessibility/support.html if you are hearing
impaired.
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