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Preface

The tutorials presented in this document introduce you to some of the common tasks 
you perform in developing the pieces of a portal project and organizing those parts 
into a version that end users see.

Audience
This document is intended for new WebLogic Portal developers and administrators. 

Documentation Accessibility
Our goal is to make Oracle products, services, and supporting documentation 
accessible to all users, including users that are disabled. To that end, our 
documentation includes features that make information available to users of assistive 
technology. This documentation is available in HTML format, and contains markup to 
facilitate access by the disabled community. Accessibility standards will continue to 
evolve over time, and Oracle is actively engaged with other market-leading 
technology vendors to address technical obstacles so that our documentation can be 
accessible to all of our customers. For more information, visit the Oracle Accessibility 
Program Web site at http://www.oracle.com/accessibility/.

Accessibility of Code Examples in Documentation
Screen readers may not always correctly read the code examples in this document. The 
conventions for writing code require that closing braces should appear on an 
otherwise empty line; however, some screen readers may not always read a line of text 
that consists solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation
This documentation may contain links to Web sites of other companies or 
organizations that Oracle does not own or control. Oracle neither evaluates nor makes 
any representations regarding the accessibility of these Web sites.

Deaf/Hard of Hearing Access to Oracle Support Services
To reach Oracle Support Services, use a telecommunications relay service (TRS) to call 
Oracle Support at 1.800.223.1711. An Oracle Support Services engineer will handle 
technical issues and provide customer support according to the Oracle service request 
process. Information about TRS is available at 
http://www.fcc.gov/cgb/consumerfacts/trs.html, and a list of phone 
numbers is available at http://www.fcc.gov/cgb/dro/trsphonebk.html.



x

Related Documents
For more information, see the following documents in the WebLogic Portal 
documentation set:

■ Oracle Fusion Middleware Overview for Oracle WebLogic Portal

■ Oracle Fusion Middleware Getting Started with WebLogic Portal for Oracle WebLogic 
Portal

■ Oracle Fusion Middleware Quick Start Guide for Oracle WebLogic Portal

■ Oracle Fusion Middleware Portal Development Guide for Oracle WebLogic Portal

Conventions
The following text conventions are used in this document:

Convention Meaning

boldface Boldface type indicates graphical user interface elements associated 
with an action, or terms defined in text or the glossary.

italic Italic type indicates book titles, emphasis, or placeholder variables for 
which you supply particular values.

monospace Monospace type indicates commands within a paragraph, URLs, code 
in examples, text that appears on the screen, or text that you enter.
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1Introduction

The tutorials presented in this document introduce you to some of the common tasks 
you perform in developing the pieces of a portal project and organizing those parts 
into a version that end users see. The tools you use to perform these tasks include 
Oracle Enterprise Pack for Eclipse and Oracle WebLogic Portal, including the 
WebLogic Portal Administration Console. 

This document describes the following tasks, organized by chapter:

■ Chapter 2, "Setting Up Your Portal Development Environment"

■ Chapter 3, "Creating a Portal in Your Development Environment"

■ Chapter 4, "Assembling a Desktop in Your Staging Environment"
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2Setting Up Your Portal Development
Environment

This tutorial helps you prepare your Oracle Enterprise Pack for Eclipse environment 
for portal development. 

For more detailed information about each dialog of the wizards used in this chapter, 
see the Oracle Fusion Middleware Portal Development Guide for Oracle WebLogic Portal.

2.1 Before You Begin
Before starting this tutorial, do the following:

■ Install Oracle Enterprise Pack for Eclipse and WebLogic Portal. 

■ Review "Introduction to the Oracle Enterprise Pack for Eclipse (OEPE) IDE" at 
http://www.oracle.com/technology/obe/obe11jdev/11/eclipse_int
ro/eclipse_intro.html. 

This task is optional, but if you are unfamiliar with the Eclipse development 
environment on which Oracle Enterprise Pack for Eclipse is based, the Getting 
Started tutorial is highly recommended; the tutorial shows you how to start Oracle 
Enterprise Pack for Eclipse and navigate the workbench user interface, introduces 
terminology associated with the workbench, and shows you how to create a 
simple web application. 

2.2 Tutorial Steps
Using the tutorial, you will perform tasks that are required to get your Oracle 
Enterprise Pack for Eclipse environment ready for portal development.

The tutorial includes instructions on how to perform these tasks:

■ Section 2.2.1, "Create a Portal Domain"

■ Section 2.2.2, "Create a Portal EAR Project"

■ Section 2.2.3, "Associate the EAR Project with the Server"

■ Section 2.2.4, "Create a Portal Web Project"

■ Section 2.2.5, "Create a Datasync Project"

In your actual development environment, you do not need to follow the order of the 
steps as presented in this tutorial; for example, you can create the portal domain after 
performing all the other steps. However, we recommend that you follow the steps as 
presented here so that you can easily see the relationships among the parts of a portal 
project. 
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2.2.1 Create a Portal Domain 
The portal domain is a group of WebLogic Server resources that contain the 
application server used by the portal. You must have a server domain that is WebLogic 
Portal-enabled in order to test the portal that you create. This customized domain is 
generally called a portal domain. 

To create a portal domain, perform these steps:

1. Start Oracle Enterprise Pack for Eclipse (the IDE). You can run the executable file 
<MW_HOME>/oepe_11gR1PS1/eclipse/eclipse.exe. On Windows, you can 
also  start the IDE from the Start menu by selecting Start > My Programs > Oracle 
WebLogic > Eclipse for WebLogic 10.3.2. 

2. When asked to select a workspace, click Browse and select (or create) a workspace 
folder. Follow the dialog prompts as appropriate. For this tutorial, we recommend 
that you create a new workspace.

If necessary, dismiss the Welcome screen to display the workbench. 

3. If the Portal perspective is not already open, select it by choosing Window > Open 
Perspective > Other > Portal. 

The instructions and figures in this tutorial are based on the views that are 
available in the Portal perspective. 

4. From the menu bar, select File > New > Other. 

5. In the New dialog, expand Server in the Wizards tree and then click Server, if not 
already selected. (Figure 2–1)

Figure 2–1 The New Dialog for Selecting a Wizard

6. Click Next.

7. In the New Server dialog, in the Select the server type list, verify that Oracle is 
expanded and Oracle WebLogic Server 11gR1 PatchSet 1 is selected. (Figure 2–2)

In the Server's host name field, localhost is shown. For the tutorial, leave this entry 
unchanged.



Tutorial Steps

Setting Up Your Portal Development Environment 2-3

Figure 2–2 New Server Dialog

8. Click Next. 

9. On the Oracle WebLogic Server 11gR1 page, click the link labeled Click here to 
launch Configuration Wizard to create a new domain. (Figure 2–3)

Figure 2–3 Launching the Configuration Wizard
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The Fusion Middleware Configuration Wizard displays, as shown in Figure 2–4. 

Figure 2–4 Fusion Middleware Configuration Wizard

10. Follow the wizard prompts and enter the values shown in Table 2–1. Click Next as 
appropriate to continue through the wizard. 

Table 2–1 Configuration Wizard Values 

In this Wizard Page... Select or Enter...

Welcome Create a new WebLogic domain (the default)

Select Domain Source In the Generate a domain configured automatically to support the 
following products list, select WebLogic Portal.

Notice that a WebLogic Portal Collaboration Repository checkbox is 
available on this wizard dialog; portal projects that use Collaboration 
Portlets features must have a domain that includes this repository. 
This tutorial does not use these features, so it can remain unselected. 
For information about Collaboration Portlets, see the Oracle Fusion 
Middleware Portlet Development Guide for Oracle WebLogic Portal.

Specify Domain Name and Location Domain name: myPortalDomain

Domain location: Accept the default, or specify another directory on 
your system.

Configure Administrator Username and 
Password

User name: weblogic

User password: webl0gic

Confirm user password: webl0gic 

Note: A valid password must contain at least one non-alphabetic 
character. In this case, the "0" in webl0gic is a zero character. Please 
remember the login and password you use for this step; you will 
need to use it again later in the tutorial. 
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11. When you are finished with these entries, click Create on the Configuration 
Summary page. 

The Creating Domain status page appears, indicating the progress of the domain 
creation. 

12. When the domain is created, click Done.

The display returns to the New Server – Oracle WebLogic Server 11gR1 PatchSet 1 
dialog. 

13. Click the Browse button next to the Domain Directory field and navigate to the 
directory of the domain that you just created. By default, the path is 
MW_HOME/user_projects/domains/myPortalDomain. 

14. In the Browse for Folder dialog, select the domain directory and click OK. 

15. In the New Server dialog, click Finish. 

The new server displays in the Servers view in the Oracle Enterprise Pack for 
Eclipse workbench, and a Servers node is added to the tree in the Package 
Explorer view. Figure 2–5 shows the Servers view and the new server. If you don't 
see this view, select Window > Show View > Servers > Server. 

For now, you do not need to start the server. Later in this tutorial, you will create a 
simple portal application, start the server, and run the portal application on the 
server. 

Figure 2–5 New Server Displayed in Oracle Enterprise Pack for Eclipse

Configure Server Start Mode and JDK ■ Development Mode

■ JRockit SDK (recommended) 

Configure JDBC Data Sources Use the defaults.

Note: When you click Next, the Configuration Wizard attempts to 
run a series of connection tests against the default PointBase 
database. Because the database is not running at this point, these tests 
will always fail. After the tests run, just click Next again. A warning 
dialog appears asking if you want to bypass testing. You can safely 
ignore this warning. Click OK to continue.

Run Database Scripts Click Run Scripts, then click Next. 

Note: This step is new as of WebLogic Portal 10.3.2. For past releases, 
these scripts were run automatically for the default PointBase 
database. You must click the Run Scripts button before continuing. 

Select Optional Configuration Use the defaults. Just click Next. 

Table 2–1 (Cont.) Configuration Wizard Values 

In this Wizard Page... Select or Enter...
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2.2.2 Create a Portal EAR Project
An Enterprise Archive (EAR) project collects the component projects of the application 
for deployment; you create one EAR project per enterprise application. The EAR 
project contains JAR files, deployment descriptors, build files, and auto-generated 
files. For more information about EAR projects and their relationship to the other 
projects in the workbench, see the "Applications and Projects" topic in the Oracle 
Enterprise Pack for Eclipse Help. 

In this task, you will create an EAR project that is customized to contain WebLogic 
Portal information. For more information about the Portal EAR project, see the Oracle 
Fusion Middleware Overview for Oracle WebLogic Portal. 

To create a Portal EAR project:

1. Select Window > Open Perspective > Portal to switch to the Portal perspective. 

2. Be sure you have set up the example environment and domain, as explained in 
Section 2.2.1, "Create a Portal Domain."

3. In Oracle Enterprise Pack for Eclipse, Select File > New > Portal EAR Project.

4. In the New Portal EAR Project dialog, enter myPortalEAR in the Project name 
field.

5. In the Configuration section, click Modify.

6. In the Project Facets dialog, verify that the WebLogic Portal node is selected in the 
Project Facets dialog, as shown in Figure 2–6. 

Figure 2–6 Project Facets Dialog

The selections WebLogic Portal (Optional) and WebLogic Portal Collaboration 
are also available here. These selections are not needed for the tutorial; leave them 
unselected. For more information about what happens when you select these 
options, see the Oracle Fusion Middleware Overview for Oracle WebLogic Portal. For 
information about the Collaboration Portlets, see the Oracle Fusion Middleware 
Portlet Development Guide for Oracle WebLogic Portal.

7. Click OK to exit the Project Facets dialog. 

8. Click Finish. 
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The Portal EAR Project node is added to the Package Explorer view, as shown in 
Figure 2–7. If you expand the folder you can see the EARcontent folder and the 
required APP-INF and META-INF directories for the project.

Figure 2–7 Portal EAR Project in the Package Explorer View

2.2.3 Associate the EAR Project with the Server
You need to explicitly associate the EAR project with the server that you created 
previously, so that later you can test the project on that server. 

To associate the Portal EAR project with the server:

1. In Oracle Enterprise Pack for Eclipse, in the Servers view (as shown in Figure 2–5), 
right-click Oracle WebLogic Server 11gR1 PatchSet 1, and then select Add and 
Remove. 

2. In the Add and Remove Projects dialog, in the Available column, select 
myPortalEAR and then click Add. (Figure 2–8)

Figure 2–8 Add and Remove Projects Dialog
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The project is added to the Configured projects column on the right. 

3. Click Finish. 

The Portal EAR project is now associated with the server. To verify this, in the 
Servers view you can expand the server node to view the server's associated 
projects. The myPortalEAR project should be shown as a subordinate node. 

2.2.4 Create a Portal Web Project
In this task, you create the web project that will contain the actual portal.

To create the portal web project:

1. In Oracle Enterprise Pack for Eclipse, select File > New > Portal Web Project.

2. In the New Portal Web Project dialog, enter myPortalWebProject in the Project 
name field. (Figure 2–9)

Figure 2–9 New Portal Web Project Dialog

3. Select the Add project to an EAR checkbox, if not selected by default. 

Because myPortalEAR is the only EAR project, it appears in the EAR Project 
Name list by default.

This associates the Portal EAR project that you created previously with this Portal 
Web project. 

4. In the Configuration section of the dialog, click Modify.

5. In the Project Facets dialog, verify that the WebLogic Portal node is selected. Click 
OK to exit the Project Facets dialog. 
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Figure 2–10 Project Facets Dialog for Portal Web Project

6. Click Finish. 

The myPortalWebProject folder now appears in the Package Explorer view, as 
shown in Figure 2–11. If you expand the folder you can see the default library modules 
and the required directory structure for the project. For more information about the 
use of Library Modules in WebLogic Portal, see the Oracle Fusion Middleware Portal 
Development Guide for Oracle WebLogic Portal.

Figure 2–11 Portal Web Project Added to the Package Explorer

2.2.5 Create a Datasync Project
A datasync project is an optional project that stores general purpose portal services 
data that is used in the development of personalized applications and portals. These 
portal services include User Profiles, Session Properties, Campaigns, and others. You 
can share a single datasync project among several EAR projects if you wish. 

To create a datasync project:

1. In Oracle Enterprise Pack for Eclipse, select File > New > Datasync Project. 

2. In the Create New Datasync Project dialog, enter myData in the Project name 
field. (Figure 2–12)

In the other areas of this dialog, leave the default settings unchanged. 
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Figure 2–12 Create New Datasync Project Dialog

3. Click Next. 

4. On the EAR Projects page, ensure the myPortalEAR checkbox is selected, as 
shown in Figure 2–13.

This associates the Datasync project with the Portal EAR project that you created 
previously. 

Tip: For more information about the Create New Datasync Project 
dialog, see "Portal Dataysnc Project Wizard" in the Oracle Fusion 
Middleware Portal Development Guide for Oracle WebLogic Portal.
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Figure 2–13 Create New Datasync Project – EAR Projects Page

5. Click Finish. 

The myData folder now appears in the Package Explorer window, as shown in 
Figure 2–14. If you expand the folder you can see the src folder and the data 
directory structure for the project.

Figure 2–14 Datasync Project Added to the Package Explorer

2.3 Summary
With the completion of this chapter, you have created the basic required elements of a 
portal development environment. These components are created on your file system in 
your current workspace. 

Tip: If you create a datasync project without associating it with an 
EAR, then you can associate it later by right-clicking the datasync 
project in the Package Explorer tree and selecting Properties; then you 
can expand the Datasync node in the tree and select EAR Projects to 
associate the project with the EAR. 
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To learn about some basic portal development tasks that can be performed by using 
the Oracle Enterprise Pack for Eclipse workbench, continue to Chapter 3.
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3Creating a Portal in Your Development
Environment

This tutorial helps you learn how to create a portal and portlets using WebLogic Portal 
in the Oracle Enterprise Pack for Eclipse workbench. 

For more information about each dialog of the wizards used in this chapter, see the 
Oracle Fusion Middleware Portal Development Guide for Oracle WebLogic Portal. 

3.1 Before You Begin
The tasks described in this chapter are based on those described in Chapter 2, so it is 
important that you complete that tutorial before starting the tasks described here. 

3.2 Tutorial Steps
Using the tutorial, you will create a portal and two portlets, create an additional page 
for the portal, and then place the portlets onto a page of the portal. 

The tutorial includes instructions on how to perform these tasks:

■ Section 3.2.1, "Create a Portal"

■ Section 3.2.2, "Add a Page to Your Portal"

■ Section 3.2.3, "Deploy and View Your New Portal"

■ Section 3.2.4, "Create Portlets"

■ Section 3.2.5, "Add Portlets to the Portal and View the Result"

3.2.1 Create a Portal
In this task, you will create a portal for the project that you created in Section 2.2.4, 
"Create a Portal Web Project."

To create a portal:

1. Start Oracle Enterprise Pack for Eclipse (the IDE). You can run the executable file 
<MW_HOME>/oepe_11gR1PS1/eclipse/eclipse.exe. On Windows, you can 
also  start the IDE from the Start menu by selecting Start > My Programs > Oracle 
WebLogic > Eclipse for WebLogic 10.3.2. 

2. In Oracle Enterprise Pack for Eclipse, if the Portal perspective is not already open, 
select Window > Open Perspective > Portal. 

Using the Portal perspective is optional, but the instructions and figures in this 
tutorial are based on the views that are available in the Portal perspective. 
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3. Navigate to the myPortalWebProject/WebContent directory, right-click 
WebContent, and then select New > Portal.

4. In the New Portal dialog, in the File name field, enter myPortal. (Figure 3–1)

A file type of .portal is required for portals; you can type the .portal 
extension to the portal's name if you wish, but WebLogic Portal automatically 
adds the extension if you don't enter it. 

Figure 3–1 New Portal Dialog 

5. Click Finish. 

The wizard adds myPortal.portal to the WebContent folder in the Portal web 
project and a view of the portal displays in the Portal editor, as shown in 
Figure 3–2. 

Note: Because you opened the New Portal dialog by right-clicking 
the WebContent directory, the parent folder field automatically 
displays that directory name. 

As a best practice, you should locate your portal file in a web content 
directory that is subordinate to the web project directory. The default 
web content directory name is WebContent, and is assigned when 
you use the Portal Web Project Wizard. You can change the name of 
your web content directory if you wish. For more information, see the 
Oracle Fusion Middleware Portal Development Guide for Oracle WebLogic 
Portal.
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Figure 3–2 Portal Displayed in the Portal Editor

The created portal includes a desktop, header, footer, book, and page. A desktop is a 
user-specific view of the portal content. A portal can support many desktops. A single 
portal might support an employee-specific desktop, a customer-specific desktop, and 
others, where each desktop exposes different kinds of content to different sets of users. 
Any part of a portal can be included or excluded from a desktop, including a book, a 
page, a specific application, or an individual link.

Desktops can also define the look and feel attributes of a portal. Desktops can be 
associated with a particular skin that defines the color scheme, fonts, and images used. 
Desktops also contain a header and footer—you can place images, text, or any web 
content in these areas to give consistency to the look and feel of a desktop.

You use books to organize your content and navigation in a hierarchical manner. Books 
can contain other books or pages. In a browser, a book is rendered as a set of tabs or 
links. Each portal contains a main book called, by default, "Main Page Book." A page 
consists of a set of columns and/or windows that organize the actual content of your 
portal. You navigate to a page by clicking an individual tab or a link.

3.2.2 Add a Page to Your Portal
In this task, you will add a second page to the portal's main book. When the portal is 
rendered in a browser, the two pages will appear as two clickable tabs. You add a new 
page by dragging and dropping the new page into the main work area. You will also 
set properties on the new page using the Properties view.

To add a new portal page:

1. In the Design Palette view, from the Portal Editor Controls, drag the Page icon to 
the area directly to the right of the Page 1 tab. Figure 3–3 shows the result when 
you release the mouse button. 

Tip: If you do not see the Design Palette tab, select Window > Show 
View > Design Palette. 
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Figure 3–3 Adding a Page to a Portal in the Workbench

2. The new page has a default title of New Page. To change the title, click the New 
Page tab to select it. 

3. In the Properties view, for the Title property, enter Page 2, as shown in 
Figure 3–4. 

The editor shows that the title has changed from New Page to Page 2. 

Figure 3–4 Changing a Page Title in the Portal Properties View

4. Save your changes. 

3.2.3 Deploy and View Your New Portal 
This portal isn't very interesting yet, but as a quick test, you will deploy your new 
portal to the server and view it in a browser window that is contained within Oracle 
Enterprise Pack for Eclipse. 
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To deploy a portal:

1. Right-click myPortal.portal in the Package Explorer view and select Run As > 
Run on Server, as shown in Figure 3–5. 

Figure 3–5 Selecting to Run the Portal on the Server

2. In the Run On Server dialog, make sure the server that you created during the 
previous WebLogic Portal tutorial task is highlighted. 

3. Click Finish to begin the deployment process. 

Wait while Oracle Enterprise Pack for Eclipse starts the server, deploys files to the 
server, and runs the application. While deployment is in process, you can view 
status messages in the status bar at the bottom of the window. 

The results appear in a new tab in the editor view, as shown in Figure 3–6. 

Figure 3–6 Portal Display in the Workbench Editor View

Leave this new tab open; after you add portlets you will refresh this display to 
view them.

Tip: When you select Run On Server, the portal web application is 
automatically published. Publishing involves copying project files, 
such as resource and configuration files, to the correct location for the 
server to locate and use them. Oracle Enterprise Pack for Eclipse 
detects whenever a file changes that requires republishing. When this 
happens, the state of the server changes to Republish. (You can see 
this reflected in the Servers view.) To republish the application, you 
can right-click the server in the Servers view and select Publish, select 
the Publish icon, or select the portal in the Project view and pick Run 
As > Run On Server. 
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3.2.4 Create Portlets
In this task, you will create two portlets: a Browser URL portlet and a simple JSP 
portlet. 

3.2.4.1 Create a Folder to Organize Portlets
To organize your portlets, it's a good idea to store them in a subfolder in your web 
content directory. 

To create a portlet folder:

1. Under your portal web project directory, right-click the WebContent directory 
and select New > Folder. 

2. In the New Folder dialog, enter the folder name portlets, as shown in 
Figure 3–7. 

Figure 3–7 New Folder Dialog

3. Click Finish.

3.2.4.2 Create a Browser URL Portlet
Browser portlets, also called Content URL portlets, are basically HTML portlets that 
use URLs to retrieve their content. Unlike other portlet types that are limited to 
displaying data contained within the portal project, browser portlets can display URL 
content that is outside the portal project. 

Tip: You can choose to always use an external web browser to view 
your portal if you wish. To do so, select Window > Preferences and 
select General > Web Browser in the property tree; then select the Use 
external Web browser radio button and select a browser type from the 
list. If no browsers appear in the list, you can search for available 
browsers and add them to the list.
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To create a browser portlet:

1. In Package Explorer, under the WebContent directory of your portal web project 
directory, right-click the newly created portlets folder and select New > Portlet. 

2. In the New Portlet dialog, enter myBrowserPortlet as the name of the portlet. 
(Figure 3–8)

Figure 3–8 New Portlet Dialog

In the New Portlet dialog, note that the portlets folder is automatically 
displayed as selected in the parent folder list. The Finish button is initially 
disabled; the button gets enabled when you select a valid parent folder and type a 
portlet name. If you select an invalid portal project in the folder tree on this dialog, 
an error message appears in the status area near the top of the dialog explaining 
that the project is not a valid portal project. 

3. Click Next. 

4. In the Portlet Wizard, on the Select Portlet Type page, click Browser (URL) Portlet 
and then click Next. 

5. On the Portlet Details page (Figure 3–9), specify the details for your portlet, using 
Table 3–1 as a guide. 

Table 3–1 Portlet Wizard - Browser Portlet Data Entry Fields

Field Value/Description

Title Browser Portlet

This value appears in the title bar of the portlet in the editor view of the 
Oracle Enterprise Pack for Eclipse workbench. 

Content URL http://www.oracle.com

This is the value for the Content URL (external URL) that the portlet 
should use to retrieve its information. 



Tutorial Steps

3-8 Oracle Fusion Middleware Tutorials for Oracle WebLogic Portal

Figure 3–9 Creating a Browser URL Portlet - Portlet Details Dialog

6. Click Create. 

The Oracle Enterprise Pack for Eclipse window updates, adding the 
myBrowserPortlet.portlet file to the portlets folder and displaying the new 
portlet in the editor, as shown in Figure 3–10. 

Figure 3–10 New Browser Portlet Displayed in Editor

Has TitleBar Leave the box checked. 

In order for a portlet to have changeable states or modes, the portlet 
must have a title bar. 

State Select all four checkboxes: Minimizable, Maximizable, Floatable, and 
Deleteable. 

Available Modes Leave these fields blank. 

Table 3–1 (Cont.) Portlet Wizard - Browser Portlet Data Entry Fields

Field Value/Description
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3.2.4.3 Create a JSP Portlet
JSP portlets reference JSP files. In most cases you can reuse existing JSP files to build 
portlets from them. JSP portlets are recommended when the portlet is simple and does 
not require the implementation of complex business logic. 

In this task, you will create a simple JSP file and then use that file to generate a portlet. 

To create a JSP portlet:

1. In Package Explorer, under the WebContent directory of your portal web project 
directory, right-click the portlets folder and select New > Portlet.

2. In the New Portlet dialog, ensure the WebContent/portlets folder is selected.

3. In the File name field, enter jsp_portlet.

4. Click Next. 

5. In the Portlet Wizard, on the Select Portlet Type page, select JSP/HTML Portlet, 
and click Next. (Figure 3–11)

Figure 3–11 Select Portlet Type

6. On the Portlet Details page (Figure 3–12), enter the values described in Table 3–2.

Table 3–2 Portlet Wizard - JSP Portlet Data Entry Fields

Field Value/Description

Title Simple JSP Portlet 

Content Path /portlets/jsp_portlet/jsp_portlet.jsp

 WebLogic Portal automatically fills in this value. 

Has Titlebar Leave this box checked. 

State Select the Minimizable and Maximizable checkboxes.



Tutorial Steps

3-10 Oracle Fusion Middleware Tutorials for Oracle WebLogic Portal

Figure 3–12 JSP Portlet Details

7. Click Create. 

8. Locate the jsp_portlet.jsp file. It will be in the 
WebContent/portlets/jsp_portlet folder. Double-click the file to open it in 
the editor. 

9. Replace the default text in the file with Simple JSP File, as shown in 
Figure 3–13. 

Figure 3–13 JSP File Showing Edited Body Text 

10. Save the JSP file. 

Checkpoint: Your WebContent directory should look like the example shown in 
Figure 3–14. 
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Figure 3–14 WebContent Directory Including Portal, Browser Portlet, and JSP Portlet

3.2.5 Add Portlets to the Portal and View the Result 
In this task, you will add your new portlets to the portal and view your changes. 

To add portlets to a portal:

1. In the editor view, click the myPortal.portal tab. 

If the tab is not open, double-click myPortal.portal under the WebContent 
directory of your portal web project directory in the Package Explorer view. 

2. Click the Page 1 tab in the portal to open it. 

3. Drag the JSP portlet (with the file name jsp_portlet.portlet) onto the left 
column (placeholder) of the portal page. The jsp_portlet.portlet file is available in 
the WebContent/portlets directory. 

4. Drag the Browser URL portlet (with the file name 
myBrowserPortlet.portlet) onto the right placeholder of the portal page. 
This portlet file is available in the WebContent/portlets directory. 

Your result should look like the example in Figure 3–15.
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Figure 3–15 Portal in Editor View with Portlets Added

5. Save your changes. 

To view the new portlets in a browser:

1. Click the New Portal Desktop tab in the editor view. (This is the tab in which the 
live portal was displayed according to the instructions in Section 3.2.3, "Deploy 
and View Your New Portal.") 

If the tab is hidden, click the >> button on the toolbar.

2. Click the Refresh icon on the browser toolbar to reload the page. 

Because your change does not require redeploying the change to the server, you 
do not need to select the Run on Server option to see the new portlets.

Your updated portal should look like the example shown in Figure 3–16. 

Figure 3–16 Running Portal with Browser Portlet and JSP Portlet Added
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3.3 Summary
With the completion of this tutorial, you have created a portal, added a portal page, 
and created two new portlets that can be displayed in the portal. These components 
are created on your file system in your current workspace. 

To learn about creating desktops using the WebLogic Portal Administration console, 
continue to Chapter 4.
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4Assembling a Desktop in Your Staging
Environment

This tutorial helps you learn how to use the WebLogic Portal Administration Console 
for some basic portal configuration tasks. 

For more information about each page of the wizards used in this chapter, see the 
Oracle Fusion Middleware Portal Development Guide for Oracle WebLogic Portal. 

4.1 Before You Begin
The tasks described in this chapter are based on those described in Chapter 2 and 
Chapter 3; so it is important that you complete those tutorials before starting the tasks 
described here. 

4.2 Introduction to the WebLogic Portal Administration Console
The WebLogic Portal Administration Console is the tool that portal administrators use 
to not only control the behavior, content, and appearance of portals, but also to 
perform many traditional system administration activities such as user and security 
management. This tutorial focuses on basic tasks that assemble portals into desktops. 

The WebLogic Portal Administration Console is organized according to the following 
categories of tasks (Figure 4–2):

■ Portal – Provides tools for managing portals, desktops, books, pages, portlets, and 
other portal resources. 

This tutorial describes some of the basic Portal Management tasks. For detailed 
information about Portal Management tasks, see the Oracle Fusion Middleware 
Portal Development Guide for Oracle WebLogic Portal. 

■ User, Groups, & Roles – Provides tools for user and group management, security 
provider configuration, delegated administration, and visitor entitlements. 

For detailed information about the tasks in this category, see the Oracle Fusion 
Middleware User Management Guide for Oracle WebLogic Portal and the Oracle Fusion 
Middleware Security Guide for Oracle WebLogic Portal. 

■ Content – Provides tools for managing content and repositories. 

For detailed information about the tasks in this category, see the Oracle Fusion 
Middleware Content Management SPI Development Guide for Oracle WebLogic Portal. 

■ Interaction – Provides tools for managing campaigns, placeholders, user 
segments, and content selectors.
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For detailed information about the tasks in this category, see the Oracle Fusion 
Middleware Interaction Management Guide for Oracle WebLogic Portal. 

■ Configuration & Monitoring – Provides tools for managing server settings for 
cache, server maintenance mode, personalization, security, unified user profiles, 
and WSRP. 

For detailed information about the tasks in this category, see the:

– Oracle Fusion Middleware Security Guide for Oracle WebLogic Portal 

– Oracle Fusion Middleware Portal Development Guide for Oracle WebLogic Portal

– Oracle Fusion Middleware Federated Portals Guide for Oracle WebLogic Portal

– Oracle Fusion Middleware Interaction Management Guide for Oracle WebLogic 
Portal

– Oracle Fusion Middleware User Management Guide for Oracle WebLogic Portal 

4.3 Tutorial Steps
Using the tutorial, you will create a portal desktop based on the portal and portlets 
created previously, make some modifications to your desktop, and then view your 
results. 

The tutorial includes instructions on how to perform these tasks:

■ Section 4.3.1, "Open the Administration Console"

■ Section 4.3.2, "Log in to the Administration Console"

■ Section 4.3.3, "Create a Portal and Desktop"

■ Section 4.3.4, "Update the Desktop Page Contents to Rearrange Portlets"

■ Section 4.3.5, "Create a New Page on the Desktop"

4.3.1 Open the Administration Console
Before you can begin using the WebLogic Portal Administration Console, the server 
must be running. Depending on the state of your Oracle Enterprise Pack for Eclipse 
workbench, you might need to start the server before opening the Administration 
Console. 

If you are continuing from Chapter 3 and you have not closed/opened Oracle 
Enterprise Pack for Eclipse, you can skip to Step 4. 

If you closed Oracle Enterprise Pack for Eclipse after finishing the tutorial in 
Chapter 3, follow these steps:

1. Start Oracle Enterprise Pack for Eclipse and return to the workspace that you used 
for the previous tutorials. You can run the executable file 
<MW_HOME>/oepe_11gR1PS1/eclipse/eclipse.exe. On Windows, you can 
also  start the IDE from the Start menu by selecting Start > My Programs > Oracle 
WebLogic > Eclipse for WebLogic 10.3.2. 

2. In the Servers view, click the server to select it. 

3. On the Servers view toolbar, click the Start the server icon.

Wait while Oracle Enterprise Pack for Eclipse starts the server. This process might 
take some time, depending on the speed of your system. When the process 
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completes, the Status column in the Servers view displays Started and the Stop 
the server square icon becomes active. 

4. From the menu bar, select Run > Open Portal Administration Console, as shown 
in Figure 4–1. 

Figure 4–1 Menu Selection for Run > Open Portal Administration Console

The Administration Console login dialog appears. 

4.3.2 Log in to the Administration Console
The Administration Console login dialog requires a WebLogic Server system 
administrator or a WebLogic Portal administrator user name and password. WebLogic 
Server system administrators have full security privileges for the entire domain and 
can log in to and use the WebLogic Server Administration Console tools. WebLogic 
Portal administrators have full security privileges for a Portal web project, which can 
include multiple portals.

Table 4–1 shows the default system administrator user names and passwords.

For purposes of this tutorial, you will use the default WebLogic Server login so that 
you have full privileges. 

To log in to the WebLogic Portal Administration Console:

1. In the Administration Console login dialog, enter the user name weblogic and 
password webl0gic, and then click Sign In. This username and password must 

Table 4–1 Default User Names and Passwords for the WebLogic Portal Administration 
Console

User Name Password Description

weblogic webl0gic WebLogic Server system administrator with full 
privileges in the domain.

Note: This username and password must match the 
values you provided when you created the domain in 
Section 2.2.1, "Create a Portal Domain." In this case, 
remember that the "0" in the password is a zero.
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match the values you provided when you created the domain in Section 2.2.1, 
"Create a Portal Domain."

The main menu of the Administration Console displays. 

Figure 4–2 Administration Console Main Page

4.3.3 Create a Portal and Desktop 
To create a desktop, you first create a portal to contain it.

To create a portal and desktop, follow these steps:

1. Click the Portal Management menu shortcut on the Administration Console home 
page.

The Portal Management page displays; the Portal Resources tree displays on the 
left on the page, as shown in Figure 4–3.

Figure 4–3 Portal Resources Tree in the Administration Console

Notice that the display is based on the Portal Web Project you created in Chapter 3. 
If you expand the Library > Portlets portion of the tree, you can see the portlets 
that you created earlier. 
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2. Click Portals in the tree. 

3. In the Browse Portals tab on the Portals page, click Create New Portal.

Because no portals exist yet, the table containing portals is empty. 

4. In the Create a New Portal dialog, enter values for the portal, using Table 4–2 as a 
guide.

5. Click Create New Portal. 

When the Portals page displays again, the Browse Portals table includes the portal 
you created, and the Portal Resources tree lists the new portal. 

6. Click myPortal in the Browse Portals table to view the details for this portal. 

7. In the Browse Desktops tab of the portal page, click Create New Desktop.

8. In the Create Desktop wizard, enter values for the desktop in the appropriate 
wizard pages, using Table 4–3 as your guide:

9. On the Enter Desktop Properties page, click Review Properties to review the 
desktop properties. 

10.  On the Review Properties page, click Create Desktop to create the desktop.

A confirmation dialog confirms that the desktop has been created and displays 
related information. 

11. Click Finish to return to the main Administration Console page. 

The newly created desktop is listed in the Browse Desktops table and the Portal 
Resources tree. Figure 4–4 shows the expanded tree.

Table 4–2 Create a New Portal Dialog Field Values

Field Value

Portal Name myPortal

Partial URL myPortal

URI (default resource) (leave blank)

Table 4–3 Create Desktop Wizard Page Values

Wizard Page Value/Selection

Step 1: Select Create Method 1. Select the Select a .portal file radio button. 

2. Click Next. 

Step 2: Select Source 1. Click Show All. 

The portal you created using Oracle Enterprise Pack 
for Eclipse displays in the list. 

2. Select myPortal.portal.

3. Click Next. 

Step 3: Enter Desktop Properties ■ Title – myDesktop

■ Description – general desktop

■ Partial URL – myDesktop

■ Default Shell – (leave as is)

■ Look and Feel – (leave as is)
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Figure 4–4 New Desktop in Portal Resources Tree

Notice that the portlets that you created for this portal (which was used as the 
template for this desktop) appear automatically in the new desktop. 

4.3.4 Update the Desktop Page Contents to Rearrange Portlets
In this task, you view the portlets for a desktop page—the portlets that you created 
using Oracle Enterprise Pack for Eclipse—and rearrange them on the page. Then you 
will view your work. 

To update your desktop page:

1. In the Portal Resources tree for myPortalWebProject, expand the tree to 
display the pages for the desktop, as shown in Figure 4–4.

2. Click Page 1 to select it.

3. In the Page 1 page on the right, select the Edit Contents tab.

The Edit Contents tab of Page 1 displays the JSP portlet and the browser portlet. 
(Figure 4–5)

Figure 4–5 Page 1 Edit Contents Tab

4. Drag the browser portlet onto the same placeholder as the Simple JSP Portlet, as 
shown in Figure 4–6.
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Figure 4–6 Moving the Browser Portlet by Dragging

When you release the mouse button, the browser portlet appears below the Simple 
JSP Portlet, as shown in Figure 4–7. 

Figure 4–7 Result After Moving the Browser Portlet in the Administration Console

5. Click Save Changes.

6. In the Portal Resources tree, click myDesktop. 

7. In the Details tab, click View Desktop. 

The desktop displays in a browser, with the portlets in their new positions, as 
shown in Figure 4–8. 
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Figure 4–8 Desktop in Browser Showing Portlets Rearranged

4.3.5 Create a New Page on the Desktop
In this task, you will create a new page for your desktop. 

To create a page on a desktop:

1. In the Portal Resources tree for myPortalWebProject, expand the Library node. 

2. Click Pages, as shown in Figure 4–9.

Figure 4–9 Expanded Portal Resources Tree Showing Desktop Pages

3. In the Browse Pages tab of the Pages page, click Create New Page.

4. In the Create New Page dialog (Figure 4–10), enter values for the new page, using 
Table 4–4 as a guide.

Table 4–4 Create New Page – Field Descriptions

Field Value/Description

Title Tutorial Page

Description new page for tutorial

Layout Three Column Flow Layout

Theme (leave as is - None)

Hidden (leave as is - unchecked)
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Figure 4–10 Create New Page Dialog in Administration Console

5. Click Create. 

The new page is added, and is displayed in the Details page for the desktop; the 
Portal Resources tree updates to include the new page, as shown in Figure 4–11. 

Figure 4–11 New Page Added to the Portal Resources Tree

4.4 Summary
With the completion of this tutorial, you have created a basic desktop and performed 
some additional tasks to become familiar with the staging environment and the 
WebLogic Portal Administration Console. 

To get started with actual portal development and desktop staging, see the Oracle 
Fusion Middleware Portal Development Guide for Oracle WebLogic Portal. 
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