リリース・ノート
リリース10.1.3.2
部品番号: E05035-04
原典情報: B31773-07 Oracle Business Intelligence Suite Enterprise Edition Release Notes, Version 10.1.3.2
2008年1月
Oracle Business Intelligence Suite Enterprise Editionは、これまでSiebel Systems社のSiebel Business Analyticsプラットフォームとして提供されていたコンポーネントで構成されており、その機能が大幅に向上しています。
このリリース・ノートでは、リリース10.1.3.2とリリース10.1.3.2.1に関する既知の問題と対処方法について説明します。
このリリース・ノートでは、Oracle Business Intelligence Suite Enterprise EditionのCDに含まれる製品の既知の問題と対処方法について説明します。これらの製品をインストールするには、『Oracle Business Intelligence Infrastructureインストレーションおよび構成ガイド』を参照してください。このマニュアルは、Oracle Business Intelligence Suite Enterprise EditionのCD-ROM、および次のOracle Business Intelligence Suite Enterprise EditionドキュメントのWebサイトから入手できます。
http://www.oracle.com/technology/documentation/bi_ee.html
このリリース・ノートは、次の各項で構成されています。
このリリース・ノートは、新しい情報が入手可能になった時点で定期的に更新されます。最新バージョンのリリース・ノートを参照できるように、Oracle Business Intelligence Suite Enterprise EditionのWebサイトをチェックしてください。
リリース・ノートのドキュメントを検索する手順は次のとおりです。
次のリンクをクリックします。
最新リリースのセクションで、「View Library」をクリックします。
「Documentation Library」ページで、「Getting Started」タブをクリックします。
「Getting Started」タブの「Release Notes」セクションで、「PDF」または「HTML」をクリックします。
|
注意: ドキュメント内に記載されているURLや参照ドキュメントには、Oracle Corporationが提供する英語の情報も含まれています。 |
この項では、Oracle Business Intelligence Suite Enterprise Edition製品に関する一般的な問題とその対処方法について説明します。この項の内容は次のとおりです。
動作要件の詳細は、『Oracle Business Intelligence Suite Enterprise Editionシステム要件およびサポートされるプラットフォーム』を参照してください。このマニュアルは、Oracle Business Intelligence Suite Enterprise Editionのドキュメント・セットにあります。次の場所にあるOracle Metalinkの「Certify」タブからも入手できます。
この項では、Oracle Business Intelligence Suite Enterprise Editionのインストールおよびアップグレードに関するリリース・ノートについて説明します。この項の内容は次のとおりです。
第2.2.2項「Siebel Marketing Serverユーザーはリリース10.1.3.2にアップグレードしてはいけない」
第2.2.9項「マルチユーザー開発機能を使用する前にOracle Business Intelligence Enterprise EditionのQuickFixを適用する」
第2.2.10項「すべてのカスタム・インストールでOracle BI Presentation Servicesプラグインがデプロイされる」
第2.2.11項「Windowsへのインストール後、Oracle BI Presentation Servicesが起動されない」
第2.2.14項「インストール後にSystems ManagementおよびOracle BI Publisherが起動しない」
この問題はリリース10.1.3.2に適用されます。この問題は、リリース10.1.3.2.1の『Oracle Business Intelligence Infrastructureインストレーションおよび構成ガイド』に記載されています。
「Advanced」インストールを実行する場合は、Oracle Application Serverをインストールして、Oracle Business Intelligenceインストーラでアプリケーションが正常にデプロイされるようにする必要があります。次のOracle Application Serverコンポーネントが必要です。
Oracle HTTP Server
Oracle Containers for J2EE(OC4J)
Oracle Process Manager and Notification Server
Oracle Business Intelligence Suite Enterprise Editionのインストール後、Oracle HTTP Serverを使用しない場合は、インストール後にOracle Application ServerでOracle HTTP Serverを無効にできます。
この問題はリリース10.1.3.2に適用されます。この問題はリリース10.1.3.2.1で修正されています。
Oracle Siebel Marketing製品のキャンペーン管理機能をご利用のお客様が、Siebel Marketing Serverをセグメント分析に使用している場合は、Oracle Business Intelligence Suite Enterprise Editionリリース10.1.3.2にアップグレードしないでください。そのかわりに、リリース10.1.3.2.1以上にのみアップグレードしてください。
Oracle Siebel 7.7またはOracle Siebel 7.8をご利用のお客様は、ご利用のOracle Siebelプラットフォームにパッチを適用する必要があります。このパッチによって、Oracle Business Intelligence Suite Enterprise Editionリリース10.1.3.2.1とのSOAP相互運用性が可能になります。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
アップグレード処理の実行時には、様々なメッセージが表示されます。その際、アップグレードの正常終了を示す警告メッセージが表示されることがあります。警告というメッセージ・カテゴリは、必ずしもアップグレード操作の失敗を示すわけではありません。この問題への対処方法はありません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
Oracle Business Intelligenceインストーラを実行し、たとえば処理が4%終了した時点でインストーラがハングする場合は、_JAVA_OPTIONS環境変数が設定されているかどうかを確認します。次の例では、_JAVA_OPTIONS環境変数が設定されています。
_JAVA_OPTIONS -Xrunjvmhook -Xbootclasspath/a:C:\PROGRA~1\COMMON~1\MERCUR~1\FUNCTI~1\Java\classes;C:\PROGRA~1\COMMON~1\MERCUR~1\FUNCTI~1\Java\classes\jasmine.jar
この問題を回避するには、_JAVA_OPTIONS変数が設定されている行をコメント・アウトして、通常のインストールを実行します。行をコメント・アウトするには、次のような構文を使用します。
%_JAVA_OPTIONS %
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
WindowsシステムでOracle Business Intelligenceインストーラを実行すると、Microsoft .NETのインストール・ダイアログが表示されることがあります。このダイアログが表示されたら、その画面で「キャンセル」または「OK」をクリックします。いずれの場合も、Oracle Business Intelligence Suite Enterprise Editionのインストールは正常に実行されます。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
インストール時、次の表示に関する問題は無視してもかまいません。
WindowsまたはLinuxシステムでOracle Business Intelligenceインストーラを実行すると、完全インストールの開始時、説明が表示される場所に$Lcom.siebel.analyticsなどのテキストが表示されることがあります。このテキストは、より意味のある説明が表示されるまで約30秒間表示されます。
このテキストはインストールのエラーともとれますが、単にリフレッシュに関する問題であり、表示されなくなれば無視してもかまいません。その後、インストールを続行できます。
進行状況を示すウィンドウにファイルがインストール中であると示されていても、「Installing Oracle Business Intelligence 10.1.3.2.0」進行状況ページのプログレス・バーにすばやく100%が表示されます。さらに、この100%のテキストは、判読しにくい反転映像(薄い灰色)で表示されます。
この問題への対処方法はなく、これによって正常なインストールが妨げられることはありません。
この問題はリリース10.1.3.2.1に適用されます。
UNIXプラットフォームへのインストール後に、次のようなエラーが発生する場合があります。
Oracle BI Answersのページで「BI Publisher」タブをクリックすると、ページがハング状態になりレスポンスがなくなります。
Oracle BI Dashboardのページで「BI Publisher」タブをクリックすると、次のようなエラー・メッセージが表示されます。
The following error occurred: [code=DNS_HOST_NOT_FOUND] The host name was not found during the DNS lookup.
インストーラで有効な完全ホスト名を特定できないために、これらのエラーが発生します。インストーラではnslookupコマンドを使用して完全ホスト名の取得を試みます。nslookupユーティリティがインストールされていて正常に動作していれば、インストーラでは完全ホスト名を検索して使用することができます。nslookupユーティリティがインストールされていない場合や正常に動作していない場合は、インストーラでは完全ホスト名を検索することができません。そのかわりに、インストーラでは元のマシン名をドメイン名なしで使用しようとします。
この問題を回避するには、nslookupユーティリティがUNIXマシンにインストールされていて正常に動作することを確認します。ユーティリティが正常に動作していれば、インストーラでは完全ホスト名を検索して構成ファイルで使用することができます。そうでない場合は、インストーラでは元のマシン名のみが使用されます。これによってエラーが発生する場合があります。
この問題はリリース10.1.3.2.1に適用されます。
Oracle Business Intelligence Suite Enterprise EditionをSolarisプラットフォームにインストールした後、次のようなエラー・メッセージが表示されることがあります。
Javahost service is unable to start, exiting with the following error: "...SEVERE: Unexpected Exception. Listener will be shutdown. java.io.IOException: Invalid argument..."
このエラーはSolarisのバグ(6433853)によって発生した可能性があります。この問題を解決する手順は次のとおりです。
最新バージョンのSolaris用Java(1.5.0_08以上)にアップグレードします。
次の手順に従って、Javahostサービスで最新バージョンのJavaが使用されていることを確認します。
SADATADIR/web/configディレクトリにあるinstanceconfig.xmlファイルを開いて編集します。
JavaHome要素が1.5.0_08以上を指し示すように修正します。
instanceconfig.xmlファイルの編集方法の詳細は、『Oracle Business Intelligence Presentation Services管理ガイド』を参照してください。
この問題はリリース10.1.3.2に適用されます。この問題はリリース10.1.3.2.1で修正されています。
Oracle Business Intelligence Enterprise Editionのマルチユーザー開発機能を使用する場合は、事前にOracle Business Intelligence Enterprise Edition 10gリリース3(10.1.3.2)用のQuickFixがインストールされていることを確認してください。QuickFixには、次の場所にあるSupportWebのAlert 1280からアクセスできます。
このQuickFixでは、チェックアウトされたプロジェクトからディメンション列が失われる可能性のあるバグが解決されます。この問題は、次の状況下でプロジェクトが抽出される場合に、Oracle BI Enterprise Editionの不具合によって発生します。
元になる論理列がファクト列でない。
デフォルトで読取り権限が許可されていない。すべてのユーザーが可視性を持たないように明示的に設定されている。
プロジェクト抽出シーケンスでは、プロジェクト・ユーザーに基づいて、追加するプレゼンテーション列が決定されます。しかし、プロジェクト・ユーザーおよびグループは、プロジェクトのファクト表が追加されるまで追加されません。したがって、ファクト表(および以降の論理列)が追加された時点では、まだプレゼンテーション列は追加されていません。プレゼンテーション列は、プロジェクト抽出シーケンスの次の段階でユーザーおよびグループが追加される際に追加されます。ただし、ユーザーおよびグループを追加するプロジェクト抽出シーケンスでは、ファクト列に基づくプレゼンテーション列の追加のみが行われます。ディメンション列に基づく列は、デフォルトでそれらの読取り権限が許可されないかぎり追加されません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
HTTPサーバーがインストールされているマシンでカスタム・インストールを実行する場合、Oracle Business Intelligence Presentation Servicesをインストールするように選択すると、選択の有無にかかわらず、Oracle BI Presentation Servicesプラグインがデプロイされます。このプラグインの使用を回避するには、インストール後にプラグインを手動で停止するか、Oracle Enterprise Managerを使用してアンデプロイします。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
Windowsシステムへのインストール後、コンピュータを再起動しても、Oracle BI Presentation Servicesが起動されない場合があります。これは同時に起動される、他の多くの大きなプロセスまたはサービスが原因で発生します。これにより、Oracle BI Presentation Servicesがタイムアウトします。
この問題を回避するには、コンピュータの再起動後、Oracle BI Presentation Servicesを手動で再起動します。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
Windowsシステムで「Advanced」インストールを実行してコンピュータを再起動すると、サービスの起動に失敗したというエラー・メッセージが表示されることがあります。次のようなログ情報がイベント・ビューアに表示されます。
Invalid repository file: Drive:\OracleBI\server\Repository\paint.rpd.
このメッセージは、Paintデモが「Basic」インストールでのみ使用可能であり、「Advanced」インストールでは使用できないために生成されます。このエラー・メッセージは無視してかまいません。この問題への対処方法はありません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
paintリポジトリのインストール後、Oracle BI Schedulerは事前構成されません。事前構成を行わずにOracle BI Schedulerを起動しようとすると、次のようなエラー・メッセージが表示されることがあります。
Error 1064: An exception occurred in the service when handling the control request
インストール後、このエラー・メッセージが表示されないようにするには、『Oracle Business Intelligence Infrastructureインストレーションおよび構成ガイド』の説明に従ってOracle BI Schedulerを構成します。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
インストール後は、それぞれのインターネット・ショートカットまたは次のリンクを使用して、Systems ManagementまたはOracle BI Publisherを起動します。
http://host.domain.com:port/xmlpserverhttp://host.domain.com:port/emOracle Business Intelligence Suite Enterprise Editionをインストールしてコンピュータを再起動した後、OC4Jが起動していなければ、これらのコンポーネントも起動しません。この問題を回避するには、これらのコンポーネントを起動する前に、OC4Jを手動で起動します。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
SuSeプラットフォームへのインストールが正常に終了したら、次のURLを使用してXMLPサーバーにログインできます。
http://host.domain:port/xmlpserver
ユーザー名とパスワードを入力した後、「500 server not found.」などのエラー・メッセージが表示されることがあります。
この問題を解決するには、OC4Jを再起動します。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
このリリースでは、Oracle BIのMicrosoft Excelアドイン変換が可能です。ただし、予測される有効期間の制限のために、このアドイン機能がこのリリースではローカライズされていません。言語サポートを提供するために、ローカライズされたリソース・ファイルが作成されることがあります。このアドイン機能はMicrosoft Office用のより堅牢なOracle BIプラグインに置き換えられる予定であるため、そのようなファイルの有用性は短期的なものになります。
この問題はリリース10.1.3.2.1に適用されます。
FirefoxブラウザをSolarisプラットフォームで使用している場合に、ポップアップ表示される説明に関して既知の問題が発生することがあります。説明をポップアップ表示する項目にマウス・ポインタを移動したときに、項目の説明が複数行に表示される場合でも1行に切り捨てられることがあります。Internet ExplorerなどのブラウザをWindowsプラットフォームで使用している場合は、この問題は発生しません。Windowsのブラウザでは説明全体が表示されます。
この問題への対処方法はありません。
この項では、Oracle Business Intelligence Suite Enterprise Editionのドキュメントの修正事項について説明します。この項の内容は次のとおりです。
第2.5.1項「『Oracle Business Intelligence Infrastructureインストレーションおよび構成ガイド』の修正事項」
第2.5.2項「『Oracle Business Intelligence Presentation Services管理ガイド』の修正事項」
第2.5.4項「『Oracle Business Intelligence Enterprise Editionデプロイメント・ガイド』の修正事項」
この項では、『Oracle Business Intelligence Infrastructureインストレーションおよび構成ガイド』に関する次の修正事項について説明します。
この問題はリリース10.1.3.2に適用されます。この問題は、リリース10.1.3.2.1の『Oracle Business Intelligence Infrastructureインストレーションおよび構成ガイド』に記載されています。
第4章「Oracle Business Intelligenceのインストールの準備」に「インストール計画のプロセス」という項があります。この項の最後に次のテキストを追加する必要があります。
Oracle Business Intelligence Suite Enterprise EditionおよびOracleクライアント・ソフトウェアを同じマシンにインストールするには、最初にOracleクライアント・ソフトウェアをインストールする必要があります。Oracle Business Intelligence Suite Enterprise EditionをインストールしてからOracleクライアント・ソフトウェアをインストールすると、Oracle Business Intelligence Suite Enterprise EditionのJava SDKバージョンが変更され、ランタイム・エラーが発生することがあります。
この問題はリリース10.1.3.2.1に適用されます。
第4章「Oracle Business Intelligenceのインストールの準備」に「IBM AIX用のOracle BI Serverの環境変数」という項があります。その項にある2つの項で、「LDR_CNTRL = IGNOREUNLOAD@LOADPUBLIC@PREREAD_SHLIB@MAXDATA」の値が誤って記載されています。それらの項と、各項における正しい値を次に示します。
「IBM AIXでの32ビット版Oracle BIのデプロイ」:
export LDR_CNTRL = IGNOREUNLOAD@LOADPUBLIC@PREREAD_SHLIB@MAXDATA=0X80000000
「IBM AIXでの64ビット版Oracle BIのデプロイ」:
export LDR_CNTRL=IGNOREUNLOAD@LOADPUBLIC@PREREAD_SHLIB@MAXDATA=0x6000000000000000
「IBM AIXでの32ビット版Oracle BIのデプロイ」において、次の文は正しくありません。
AIXで32ビット版Oracle BIのデプロイメントを設定するには、次のコマンドを実行します。
この文は次のように読み替えてください。
次のAIX用32ビット環境変数は、.variant.shにより自動的に設定されます。
この問題はリリース10.1.3.2.1に適用されます。
第9章「Oracle BI Presentation Servicesの構成」の「Oracle BI Presentation Services用のWARファイルの作成」で、手順の前に記載されている表に誤りがあります。この表は、次のように読み替えてください。
この手順では、次のディレクトリにあるWARファイルを使用します。
Windowsの場合: OracleBI_HOME\web
UNIXの場合: /usr/local/OracleBI/web
同じ項内の手順を次のように読み替えてください。
WARファイルを作成または再作成するには
前のリストに示したOracle Business Intelligenceインストール・ディレクトリに移動します。
WARファイルを作成するには、次のjarコマンドを実行します。
jar -cf Analytics.war -C app.
|
注意: コマンドの最後にピリオドを含める必要があります。 |
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
『Oracle Business Intelligence Presentation Services管理ガイド』で、プロキシ機能用カスタム・メッセージ・テンプレートを作成する手順において、適切なDBや接続プールに接続してターゲット・ユーザーの抽出を行うSQL文などが欠落しています。
この問題を回避するには、『Oracle Business Intelligence Presentation Services管理ガイド』の「プロキシ機能用カスタム・メッセージ・テンプレートの作成」においてカスタム・メッセージ・テンプレートを作成する手順の手順4に記載されているコードを次のコードで置換します。
<XML>
<logonParam name="RUNAS">
<getValues>EXECUTE PHYSICAL CONNECTION POOL physical_dbname.conn_pool_name
select targetId from Proxies where proxyId='@{USERID}'</getValues>
<verifyValue>EXECUTE PHYSICAL CONNECTION POOL physical_dbname.conn_pool_name
select targetId from Proxies where proxyId='@{USERID}' and
targetId='@{VALUE}'</verifyValue>
<getDelegateUsers>EXECUTE PHYSICAL CONNECTION POOL physical_dbname.conn_pool_name select proxyId, proxyLevel from Proxies where
targetId='@{USERID}'</getDelegateUsers>
</logonParam>
</XML>
次のカスタム・メッセージ・テンプレート例も手順の末尾に追加します。
カスタム・メッセージ・テンプレート例
<?xml version="1.0" encoding="utf-8" ?>
<WebMessageTables xmlns:sawm="com.siebel.analytics.web.messageSystem">
<WebMessageTable system="SecurityTemplates" table="Messages">
<WebMessage name="LogonParamSQLTemplate">
<XML>
<logonParam name="RUNAS">
<!-- for EXECUTE PHYSICAL CONNECTION POOL, SQL_Paint.SQL_Paint = -->
<!-- SAS Repository physical_dbname.conn_pool_name -->
<getValues>EXECUTE PHYSICAL CONNECTION POOL SQL_Paint.SQL_Paint
select targetId from Proxies where proxyId='@{USERID}'\</getValues>
<verifyValue> EXECUTE PHYSICAL CONNECTION POOL SQL_Paint.SQL_Paint
select targetId from Proxies where proxyId='@{USERID}' and targetId='@{VALUE}'\</verifyValue>
<getDelegateUsers>EXECUTE PHYSICAL CONNECTION POOL SQL_Paint.SQL_Paint
select proxyId, proxylevel from Proxies where targetId='@{USERID}'
</getDelegateUsers>
</logonParam>
</XML>
</WebMessage>
</WebMessageTable>
</WebMessageTables>
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
『Oracle Business Intelligence Server管理ガイド』の「Oracle BIリポジトリ・ファイルの設定完了と管理」の章で、「Deliversで操作するためのリポジトリの設定」に記載されているSA Systemサブジェクト領域の設定手順が不完全です。Oracle Business Intelligence Deliversが機能するには、SA Systemサブジェクト領域をOracle Business Intelligenceリポジトリの「Presentation」レイヤーに正しく設定する必要があります。
SA Systemサブジェクト領域を設定するための完全な手順は、『Analytics Server Administration Guide Version 7.8.2, Revision A』を参照してください。第7章「Completing Setup and Managing Oracle BI Repository Files」の「Setting Up the Repository to Work with Delivers」に移動します。この項に記載されている次の情報は、Oracle Business Intelligenceリリース10.1.3.2に適用されます。
図15に示すように、「Presentation」レイヤーのメタデータには、SA Systemフォルダ、Userテーブル、および列を含める必要があります。
SA Systemサブジェクト領域フォルダのUserテーブルの列の詳細は、このマニュアルの表26に説明されています。
『Analytics Server Administration Guide Version 7.8.2, Revision A』は、次の場所にあるOracle Technology Networkの「Oracle Business Intelligence Enterprise Edition Documentation」ページで入手できます。
http://www.oracle.com/technology/documentation/bi_ee.html
また、次の場所にあるSupportWebの「Documentation Updates」ページでも入手できます。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
『Oracle Business Intelligence Enterprise Editionデプロイメント・ガイド』の「BI Presentation Servicesのリスナー・ポートの変更」で、手順3に記載されているPresentation Servicesのデフォルトのリスナー・ポートを変更する例が正しくありません。<RPC>ノードの参照は削除する必要があります。手順3は次のように読み替えてください。
3. 次の例で示すように、<WebConfig>タグの中でBI Presentation ServicesインスタンスのRPCリスナー・ポートの値を割り当てます。
<WebConfig>
<ServerInstance>
...
<Listener port="9715" />
...
</ServerInstance>
</WebConfig>
注意: 前述の例では、BI Presentation ServicesインスタンスのRPCリスナー・ポートは、デフォルトの9710からポート9715に変更されています。
この項では、Oracle Business Intelligence Server(Oracle BI Server)に関するリリース・ノートについて説明します。この項の内容は次のとおりです。
第3.3項「Ago()列とレベルベースのメジャー列との組合せによってはOracle Databaseエラーが生成される」
第3.6項「「Consistency Check」ウィンドウのチェック・ボックスに「Options」タブの設定が反映されない」
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
Windowsシステムでは、XMLAデータソース(SAP/BWおよびMicrosoft Analysis Server)に対して、Administration Toolのドラッグ・アンド・ドロップ機能を使用できます。
この機能を使用すると、キューブなどの物理メタデータ・オブジェクトを、メトリック、属性およびディメンションを保持したまま、完全構成されたビジネス・モデル・メタデータとしてAdministration Toolにドラッグ・アンド・ドロップできます。これにより、論理ディメンション・モデルを、各種ディメンションを持つメタデータ構成が含まれるデータソースから手動で再定義する必要が減少します。
この機能を有効にするには、次の手順を実行します。
WindowsシステムにOracle Business Intelligence Suite Enterprise Editionをインストールします。
OBIAT_XMLA_DDというWindowsシステム変数を作成して、その値をYesに設定します。
Administration Toolを再起動します。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
10.2.0.3より前のバージョンのOracle Database 10gリリース2を使用すると、データベースのパフォーマンスに重大な問題を引き起こす完全外部結合の問題が発生することがあります。またこの問題により、Oracle BI ServerからデータベースにWITH句を含むSQLクエリーを送信すると、データベースがハングすることがあります。
この問題を回避するには、Oracle Database 10gリリース1または2を使用している場合は、Oracle Database 10gリリース2パッチ・セット2(10.2.0.3)にアップグレードします。パフォーマンスの面からは、この対処方法が適切です。
パッチ・セット2をインストールせずに問題を回避するには、Administration Toolを使用してデータベース機能のテーブルを変更します。この構成により、Oracle BI Serverでは、パッチの適用されていないOracle Database 10gで問題を発生させるSQL構成が送信されなくなります。
データベース機能のテーブルを変更するには、次の手順を実行します。
Administration Toolで、物理データベースのメタデータ・オブジェクトのプロパティを開きます。
「Features」タブにナビゲートします。
PERF_PREFER_MINIMAL_WITH_USAGEおよびPERF_PREFER_INTERNAL_STITCH_JOINの各エントリの値を選択し、Trueに設定します。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
Ago()列をレベルベースのメジャー列と組み合せて使用すると、その組合せによっては「ORA-00942: table or view does not exist at OCI call OCIStmtExecute.」などのOracle Databaseエラーが表示されることがあります。
この問題を回避するには、Oracle Database 10gリリース2を使用している場合はパッチ・セット2(10.2.0.3)をインストールし、ネイティブの完全外部結合のサポートを有効にします。パフォーマンスの面からは、この対処方法が適切です。
パッチ・セット2をインストールせずに問題を回避するには、第3.2項「Oracle Database 10gでの完全外部結合およびWITH句に関する問題」で説明しているように、データベース機能のテーブルでPERF_PREFER_INTERNAL_STITCH_JOINをTrueに設定します。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
別のレポートの結果を制約するレポートを使用する場合、その子レポートがメジャーに対するフィルタを持っていると、オプティマイザによって最終的な結果からメジャー列が削除されることがあります。この問題を回避するには、親レポートに対して、次のような不要なメジャーのフィルタを追加します。
'measure'<>0
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
INTERVAL型のデータの列を含むデータベース・オブジェクトをインポートすると、インポートされたデータがLONGVARBINARY型になります。Oracle Business Intelligence Suite Enterprise Editionでは、INTERVALデータ型は直接サポートされません。このデータは、UNKNOWNデータ型でインポートする必要があります。
この問題を回避するには、ビジネス・マッピングからINTERVAL型のデータを削除し、そのデータをクエリー・リクエストの一部として含めないようにします。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
「Consistency Check」ウィンドウの「Options」タブでハイレベル・オプションの「Warnings」、「Errors」または「Best Practices」を無効にしても、「Messages」タブの対応するチェック・ボックスは自動的に選択解除されません。システムでは、「Messages」タブではなく「Consistency Check」ウィンドウの設定が適用され、適切なハイレベル・オプションが無効になります。
この問題への対処方法はありません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
集計メジャーがレベル・キーとしてリポジトリに含まれると、Administration Toolにアサーションの内部エラー・メッセージが表示されます。集計メジャーはレベル・キーとして定義できないため、このメッセージが表示されます。
この問題を回避するには、集計メジャーをレベル・キーから削除して、正しいキーに置き換えます。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
XMLAデータソースからのインポート処理の実行時、次のいずれかのエラー・メッセージが表示されることがありますが、これらのメッセージは適切でないか、誤解される可能性があります。
[nQSError : 46100] Sax Parser failed with error
ユーザーが誤ったアドレスをURLボックスに入力すると、このメッセージが不適切に表示されることがあります。適切なエラー・メッセージは次のようなものです。
[nQSError: 46121] is not a correct URL
この問題を回避するには、正しいURLを入力します。
[nQSError: 64001] The file not found
インポート・ファイルが存在するけれども適切に構成されていない場合、このメッセージが不適切に表示されることがあります。この問題を回避するには、対象ファイルが存在すること、そのファイルが正しく構成されていること、およびファイル内のすべてのタグが正しい順番および構文で記述されていることを確認します。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
オンライン・モードでAdministration Toolを操作している際に、Oracle BI ServerがリポジトリまたはAdministration Toolを閉じずに再起動され、ユーザーが再度リポジトリをオンライン・モードで開こうとすると、Oracle BI Serverが稼動していないというエラー・メッセージが表示されることがあります。
この問題を回避するには、Administration Toolを閉じて、再度リポジトリをオンライン・モードで開きます。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
SAP/BW(Business Information Warehouse)のデータに対してクエリーを実行すると、エラー・メッセージが表示されることがあります。その際、接続がタイムアウトしていると、このエラーが結果として表示されるエラー・メッセージに反映されません。
この問題への対処方法はありません。
この問題はリリース10.1.3.2に適用されます。この問題はリリース10.1.3.2.1で修正されています。
リポジトリ内に定義されたユーザーについて、次の問題が発生する場合があります。初期化ブロックでUSERシステム変数を変更しようとすると、その初期化ブロックが実行されません。また、同じ初期化ブロック内にある他のセッション変数も設定されません。ユーザーがリポジトリ内に格納されていない場合、この問題は発生しません。
この問題を回避するには、初期化ブロックを2つの個別の初期化ブロックに分割して、一方のブロックでUSERシステム変数を取得または設定し、もう一方のブロックで他のセッション変数を取得または設定するようにします。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
次の手順を実行すると、Oracle BI Serverがクラッシュする可能性があります。
新しい物理スキーマをリポジトリにインポートします。
既存の物理オブジェクト、ビジネス・モデル・オブジェクトおよびプレゼンテーション・オブジェクトをすべて削除します。
変更を保存します。
この問題への対処方法はありません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
IBM OS/390およびAS/400オペレーティング・システムでIBM DB2データベースを使用している場合、TIMESTAMPDIFF関数は、その関数で処理される値を概算するSQLに変換されて実行されます。この概算により、正しくない値が返されることがあります。この問題への対処方法はありません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
『Oracle Business Intelligence Server管理ガイド』の第11章に「クエリー・キャッシュの構成」があります。この項の最初の2段落は、次のように読み替えてください。
クエリー・キャッシュはデフォルトで有効になっています。古くなったエントリのフラッシュ方法を決定したら、NQSConfig.INIファイルでキャッシュ記憶域のパラメータを構成する必要があります。この項では、Oracle BI Serverでクエリー・キャッシュを構成するために必要なタスクについて説明します。クエリー・キャッシュの制御に使用するパラメータの詳細は、『Oracle Business Intelligence Infrastructureインストレーションおよび構成ガイド』を参照してください。
この項では、Oracle Business Intelligence Presentation Services(Oracle BI Presentation Services)に関するリリース・ノートについて説明します。この項の内容は次のとおりです。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
Catalog Managerでは、他のユーザーのフォルダの所有権を取得できます。所有権を取得した後も、そのフォルダのプロパティに所有者としてシステム・アカウントが継続して表示されることがあります。この問題を回避するには、親フォルダを選択し、「View」メニューで「Refresh」オプションを選択します。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
Catalog Managerでプレゼンテーション・カタログを開くと、カタログが開いていることを示すようにカーソルが変更されない場合があります。カタログを開くために必要な時間は、カタログのサイズなど、様々な要因によって異なります。
カタログのパスを誤って入力した場合、パスが正しくないことを示すエラー・メッセージが表示されるまでしばらく時間がかかります。
これらの問題への対処方法はありません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
Catalog Managerの「Advanced Search」領域にフィールドが表示されないことがあります。このエラーは、「Advanced Search」領域を開いた後、内容表示モードと検索モードを切り替えると発生します。フィールドが表示されない場合は、「Advanced Search」テキストの横にある「Expand」アイコン(右向きの三角)をクリックして、すべてのオプションを表示します。
この問題への対処方法はありません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
Catalog Managerツリーでは複数のオブジェクトを選択できます。複数のオブジェクトを選択し、それらの権限を編集しようとすると、Catalog Managerではツリー内の最初のオブジェクトの権限のみが編集されます。複数のオブジェクトの権限を同時に編集することはできません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
「Edit Catalog Group」ダイアログに、「The table below contains a list of the current members of this group. Users can join the group by entering the group's password from the 'Join Catalog Group' screen, or you can manually add them by clicking Add New Member below.」という記述があります。
アカウントをグループに関連付ける機能は削除されました。「Edit Catalog Group」ダイアログのこの記述は無視してください。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
プレゼンテーション・カタログ間でコンテンツをコピーする際、コピー先のカタログに、コピー元のカタログ内のフォルダと同じフォルダがある場合は、既存ファイルを置換するかどうかを選択できます。既存ファイルを置換しないように選択すると、そのコンテンツが新規であるか既存であるかにかかわらず、コピー先のカタログには何もコピーされません。
この問題を回避するには、コピー先のカタログに、新しいフォルダとファイルを個別にコピーします。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
ポータル・クライアントのポートレットを設定する場合は、表示コンテンツのレポート・パスを指定する必要があります。このレポート・パスを後から変更しようとすると、以前に保存したポートレットに対する変更がシステムで拒否されることがあります。この問題を解決するには、既存のポートレットをすべて削除し、新しいポートレットを作成して正しいレポート・パスを指定します。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
iBotではシステム・アラートの送信先デバイスを選択できます。電話、ポケットベルまたは携帯情報端末などのデバイスの番号を入力する際、数字以外の文字を入力すると、エラー・メッセージが表示されることがあります。この問題を回避するには、数字のみを含み、その他の文字(ピリオド、ハイフンおよびカッコなど)を含まない番号を入力します。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
レポートおよびダッシュボードのマークアップにHTMLを使用している場合、そのHTMLタグがアプリケーションに表示されることがあります。これらのタグの表示は、多くの場合、HardenXSS要素の設定に関連しています。よりセキュアなWebアプリケーションを提供するための大幅な機能向上の一部として、今回のリリースでは、HardenXSS要素のデフォルト設定が変更されています。HardenXSS要素はクロスサイト・スクリプティング攻撃の防止を目的としており、現在はデフォルトで有効化されています。
この問題を回避するには、『Oracle Business Intelligence Presentation Services管理ガイド』の説明に従ってHardenXSS要素を無効にします。
この問題はリリース10.1.3.2に適用されます。この問題はリリース10.1.3.2.1で修正されています。
Windows XPマシンでの特定のテスト構成では、Oracle BI Presentation Servicesの仮想メモリーが安定せず、増大し続けることが確認されています。そのような場合は、XPLowFragmentationHeap設定を有効にすることにより、この状況を解決して仮想メモリーを安定させます。instanceconfig.xmlファイルのServerInstance要素でXPLowFragmentationHeap要素をTrueに設定します。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
非ASCII名を持つレポートをダウンロードして「Save」ダイアログから直接開くと、Windows 2000マシンでは空のレポートが表示されることがあります。Windows 2000では、インライン・ファイルの名前変換が原因でファイルを開けないことがあります。
この問題を回避するには、ASCII文字を含む名前にファイル名を変更するか、あるいは名前をローカル・マシンに保存してからファイルを開くようにします。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
ポータルに格納するOracle BI ポートレットには、実際的な制限があります。レポートの複雑さ、サーバーのメモリーおよびCPU、構成など、様々な要因がパフォーマンスに影響します。一般的な規則として、Oracle Business Intelligence Suite Enterprise Editionで処理する個別ポートレットの数は5以下にします。大きなコンテンツのブロックを含める場合は、Interactive Dashboards全体または個々のダッシュボード・ページを単一のユニットとしてポータルに組み込みます。
この項では、Oracle Business Intelligence Answers(Oracle BI Answers)に関するリリース・ノートについて説明します。この項の内容は次のとおりです。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
複合的なレイアウト・ビューで作業する場合は、各種ビューを変更することによって出力を変更できます。ページ下部にある「Download」リンクを選択する場合は、まず「Refresh Results」アイコンを選択します。最初にリフレッシュを実行することで、ダウンロード・ビューに最新の変更が反映されるようになります。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
集合演算を使用する場合は、集計ルールを定義する必要があります。デフォルトの集計を使用すると、その式が集合演算で機能しません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
「Formula Editor」ダイアログで行を操作する場合は、式の既存の行を選択(強調表示)して、コラム・ピッカーの別の行で置換できます。ただし、使用するブラウザのバージョンによっては、強調表示された行を新しい行で置換できません。この問題を回避するには、現在の行を削除してから新しい行を追加します。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
ピボット・テーブルの行に集計を追加すると、合計に対する「Format Labels」オプション・ページの一部のフォーマット機能が動作しないことがあります。この問題への対処方法はありません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
「Report-Based Total」オプションが選択されていない場合、ネストされた集計に対してフィルタ処理を実行すると、「Report-Based Total」オプションが選択されている場合と同じ結果が返されることがあります。この問題への対処方法はありません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
OracleAS Portalを使用してOracle BIコンテンツを公開する場合、ポートレット・セッションが期限切れになることがあります。この問題を回避するには、instanceconfig.xmlファイルのClientSessionExpireMinutes要素を使用して、セッション期間を長く設定します。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
Oracle BI PublisherレポートをOracle BI Dashboardに公開しようとすると、「Resource Not Found」エラー・メッセージが表示されることがあります。このエラーは、多くの場合、参照するレポートが28文字以上の長い名前を持つことが原因で発生します。そのような場合は、名前の短いレポートを再度公開することで問題を回避できます。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
MHTMLとしてダウンロードしたレポートに、エラー・メッセージが表示されるか、グラフのかわりにXを含む図が表示される場合、その原因はブラウザでのMHTMLフォーマットの解析方法にあります。多くの場合、この問題はMHTMLレポートを直接開くことによって発生します。
この問題を回避するには、MHTML出力をファイルとして保存してから、その保存したファイルを開きます。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
『Oracle Business Intelligence Answers, Delivers, and Interactive Dashboardsユーザーズ・ガイド』には、構文での変数の使用についての説明で、フォーマット・マスクの位置が誤って記述されています。次の各項の構文を変更する必要があります。
「リポジトリ変数およびプレゼンテーション変数の参照構文」で、箇条書き項目は次のように読み替えてください。
@{<variableName>}[format]: リポジトリ変数を参照します。たとえば、@{dashboard.path}と指定すると、現在のダッシュボードのパスが挿入されます。
- @{variables.<variableName>}[format]{<value>}: プレゼンテーション変数を参照します。たとえば、@{variables.myFavoriteRegion}{Central}と指定すると、プレゼンテーション変数myFavoriteRegionの値が挿入されます。
variables: リクエスト内のプレゼンテーション変数の参照に必要な接頭辞です。
variableName: 現在の評価コンテキストで参照可能なオブジェクトへの参照です。たとえば、@{variables.myFavoriteRegion}のように指定します。
format(オプション): {<variableName>}に適用されるフォーマット・マスクです。変数のデータ型によって異なります。たとえば、#,##0、MM/DD/YY hh:mm:ssなどのように指定します。
value(オプション): variableNameによって参照する変数が移入されない(つまり、定義されない)場合に使用する値を示す、定数参照または変数参照です。
「Oracle BIの説明ビューの追加または変更」で、「Prefix」、「Narrative」および「Postfix」という行の構文の説明は、それぞれ次のように読み替えてください。
変数を含めるには、@{variableName}[format]{<value>}構文を使用します。
「Oracle BIの静的テキスト・ビューを追加または変更するには」で、表の「変数」行の最初の1文は次のように読み替えてください。
次のHTML例には、@{variableName}[format]{<value>}構文を使用した変数式が含まれています。
Oracle Business Intelligence Interactive Dashboards(Oracle BI Dashboards)についての既知の問題はありません。
この項では、Oracle Business Intelligence Delivers(Oracle BI Delivers)に関するリリース・ノートについて説明します。この項の内容は次のとおりです。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
iBotのヘッドラインを作成する場合は、ヘッドラインにバックスラッシュ文字(\)を含めないでください。ヘッドラインにバックスラッシュ文字が含まれると、ジョブ・マネージャにOracle BI Presentation Servicesの致命的なエラーが表示されることがあります。
この問題への対処方法はありません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
特定の状況下では、iBotでデータベースに接続してコンテンツのクエリーを実行できない場合、iBot受信者がODBCエラー・メッセージを含む電子メールを受信することがあります。
この問題への対処方法はありません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
ダッシュボード・ページでプロンプトを含むiBotを作成する場合、プロンプトの値を設定するにはiBotを実行する必要があります。
この問題への対処方法はありません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
条件付きiBotは、結合クエリーとフィルタの両方を含むリクエストに基づいて作成できないことに注意してください。そのようなiBotを作成すると、スケジューラ・ログにエラー・メッセージが表示されますが、その他の場所には表示されません。この問題への対処方法はありません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
クラスタ環境では、個々のユーザーにパーソナライズされたレポートの複数のインスタンスを実行するiBotは、単一のサーバー上で実行されます。iBotの実行時にサーバーが停止すると、そのiBotは自動的に再起動するようにスケジュールされます。サーバーの停止状態が続き、iBotの再起動の試行回数が「Number of Request Tries」パラメータの値を超えると、ログ・ファイル・エントリが生成されます。
この問題への対処方法はありません。
この項では、Oracle Business Intelligence Disconnected Analytics(Oracle BI Disconnected Analytics)に関するリリース・ノートについて説明します。この項の内容は次のとおりです。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
Mozillaブラウザを使用してOracle BI Disconnected Analyticsページにアクセスすると、「Add/Edit Filter」オプションの選択時に「Path Not Found」エラーが表示されることがあります。この問題を回避するには、Mozilla以外のブラウザを使用します。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
Red Hat LinuxマシンでOracle BI Presentation Servicesを実行すると、事前処理された増分同期化を実行する場合に問題が発生することがあります。この問題への対処方法はありません。
この項では、Oracle Business Intelligence Publisher(Oracle BI Publisher)に関するリリース・ノートについて説明します。この項の内容は次のとおりです。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
Java SE Development Kit(JDK)5.0バージョン1_5_0_7にはバグがあり、このバグによってOracle BI Publisherのパフォーマンスが悪影響を受けます。パフォーマンスを向上させるには、JDK 5.0 update 11(1_5_0_11)にアップグレードしてください。この更新版を次の場所からダウンロードしてインストールしてください。
http://java.sun.com/javase/downloads/index_jdk5.jsp
JDKの更新版をインストールしたら、新しいJDKの場所を指すようにOC4J起動スクリプトまたはバッチ・ファイルを変更する必要があります。
OC4J起動スクリプトを変更する手順は次のとおりです。
Windowsの場合は、<OracleBI>\oc4j_bi\bin\oc4j.cmdを開いて編集します。LinuxまたはUNIXマシンの場合は、$OracleBI/setup/oc4j.shを開いて編集します。
新しいJDKの場所を指すようにJAVA_HOME変数を設定します。たとえば、JAVA_HOME=D:\Program Files\Java\jdk1.5.0_11のように設定します。
JDKを更新したマシンに「Basic」インストール・オプションを使用してOracle Business Intelligence Presentation Servicesがインストールされている場合は、新しいJDKの場所を指すようにinstanceconfig.xmlファイルを変更する必要があります。
instanceconfig.xmlファイルを変更する手順は次のとおりです。
<OracleBIData>/web/config/instanceconfig.xmlファイルを開いて編集します。
新しいJDKの場所を指すようにJavaHomeパラメータを設定します。たとえば、<JavaHome>D:\Program Files\Java\jdk1.5.0_11</JavaHome>のように設定します。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
ダッシュボードに埋め込まれているOracle BI Publisherレポートでスクロール・バーまたはレポートがクリップされて表示される場合は、ダッシュボード・ページでオブジェクトの高さのプロパティ値を増やす必要があります。ダッシュボード・ページでOracle BI Publisherオブジェクトのプロパティを編集して、レポート全体およびスクロール・バー・コントロールが正しく表示されるまで、高さを550ピクセルよりも大きく設定します。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
<?sort:element_name?>構文を使用すると、データ値のグループをソートできます。この構文はfor-each-group構文の直後に配置します。このソート構文は、ネストされたfor-each-groupの下に配置すると機能しません。このソート構文をネストされたfor-each-groupの下に配置すると、EmptyStackExceptionエラーが表示され、レポート出力が表示されません。
この問題への対処方法はありません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
繰返し可能フィールドを持つPDF出力を縦モードで作成すると、レポート出力は正しくフォーマットされます。ただし、同じレポートを横モードで作成すると、表のヘッダーは正しく表示されますが、次の問題が発生します。
繰り返される行の情報(つまり、反復内の各データ・フィールド)が90度回転して表示される。
繰り返される行が、垂直方向に上から下へではなく、水平方向に右から左へ表示される。
この問題への対処方法はありません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
RC4アルゴリズムは、AESなどのより新しいアルゴリズムに比べて安全性が低いため、新しいアプリケーションでの使用は推奨されていません。ただし、Adobe Acrobat 6.0でサポートされる暗号化アルゴリズムは、RC4アルゴリズムのみです。Oracle BI Publisherの今後のリリースでは、Adobe Acrobat 7.0以上のバージョンに対するAES暗号化のサポートも計画されています。
この問題への対処方法はありません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
ユーザーズ・ガイドの「行の書式設定」というトピックでは、表レポートの背景色を1行おきに設定する方法が説明されています。この説明は、PDF出力に対してのみ有効です。HTML、RTFおよびExcelの出力フォーマットでは、1行おきに背景色が表示されません。これらの出力フォーマットでは、すべての行が白い背景色で表示されます。
この問題への対処方法はありません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
Microsoft Wordには、ヘッダーおよびフッターについて、ページの端からの距離を指定するページ設定オプションがあります。このオプションは、「ファイル」メニューから「ページ設定」→「余白」タブを選択し、「用紙の端からの距離」ボックスで設定します。出力フォーマットがRTFである場合、この余白設定は保持されません。かわりに、デフォルトの余白設定を使用して出力が作成されます。HTML、PDFおよびExcelなどのその他の出力フォーマットでは、この余白設定は正しく機能します。
この問題への対処方法はありません。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
Oracle XDKはIEEE 754規格に対応したXSL標準に準拠しているため、小数点を含む数字を加算する場合に丸めの問題が発生することがあります。たとえば、Oracle BI Publisherで、次の構文を使用して13683.80および516.39を加算するとします。
<?13683.80 + 516.39?>
この構文では、バイナリ浮動小数点演算用のIEEE 754規格に基づく制限によって値14200.189999999999が返されます。
この問題を回避するには、次に示すformat-number関数またはround構文を使用して、14200.19が戻り値として返されるようにします。
<?format-number:(13683.80 + 516.39);'D99'?>
または
<?(round((13683.80 + 516.39)*100) div 100)?>
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
クラスタ化された環境を使用している状況において、CUPSサーバーを配信オプションとして実装しているが他に定義済プリンタがない場合、CUPSサーバーが配信オプションとして表示されないことがあります。
この問題を回避するには、「管理」インタフェース→「配信」→「プリンタ」でエントリを作成して、実際に存在する配信先プリンタかダミーの配信先プリンタを追加します。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
チャートを含むレポート・レイアウトをExcel出力に表示すると、チャートが表示されずにチャートの位置に小さいアイコンのみが表示されることがあります。
この問題を回避するには、次に示す手順に従ってイメージURLにおけるセキュリティのブロックを解除する必要があります。
WEB-INF/web.xmlファイルを開きます。
次のブロックを探します。
<filter-mapping> <filter-name>SecurityFilter</filter-name> <url-pattern>/xdo/tmp/*</url-pattern> </filter-mapping>
<url-pattern>要素を次のように変更します。
<filter-mapping> <filter-name>SecurityFilter</filter-name> <url-pattern>/xdo/tmp/*.tmp</url-pattern> </filter-mapping>
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
データソースが複数のSQLクエリーから連結されたXMLである場合、BI Publisherサーバーに直接接続するとXMLデータがTemplate Builderに正しくロードされません。
この問題を回避するには、データ・モデル構築後にサンプル・データを生成してからアクセス可能なディレクトリに保存します。Template Builderのデータ・ロード機能(Oracle BI Publisherの「データ」→「サンプルXMLデータのロード」を選択)を使用して、レポート・データをTemplate Builderにロードします。Template Builderを切断モードで使用する方法の詳細は、『Oracle Business Intelligence Publisherユーザーズ・ガイド』を参照してください。
この問題はリリース10.1.3.2.1に適用されます。
リリース10.1.3.2.1以上において、管理者がBI Publisherのスケジューラを適切に構成していないと、ユーザーにXMLP_SCHEDULERロールが付与されていても「スケジュール」タブと「スケジュール」ボタンは無効になります。「スケジュール」タブと「スケジュール」ボタンを有効にするには、スケジューラ表をインストールして構成する必要があります。
Oracle Business Intelligence Scheduler(Oracle BI Scheduler)についての既知の問題はありません。
この項では、Oracle Business Intelligence Administration Tool(Oracle BI Administration Tool)に関するリリース・ノートについて説明します。この項の内容は次のとおりです。
この問題はリリース10.1.3.2とリリース10.1.3.2.1に適用されます。
Oracle BI Administration ToolでXMLファイルを物理データソースとして使用する場合は、指定するURLのファイル名にXML接尾辞が必要です。たとえば、データソースがD:\datasources\xml\Categories.xmlである場合、「Physical Table - <name of data source>」ダイアログの「XML」タブにある「URL」フィールドには「D:\datasources\xml\Categories.xml」と指定する必要があります。また、「Database」ダイアログの「General」タブにある「Database」フィールドの値にXMLを選択する必要があります。
オラクル社は、障害のあるお客様にもオラクル社の製品、サービスおよびサポート・ドキュメントを簡単にご利用いただけることを目標としています。オラクル社のドキュメントには、ユーザーが障害支援技術を使用して情報を利用できる機能が組み込まれています。HTML形式のドキュメントで用意されており、障害のあるお客様が簡単にアクセスできるようにマークアップされています。標準規格は改善されつつあります。オラクル社はドキュメントをすべてのお客様がご利用できるように、市場をリードする他の技術ベンダーと積極的に連携して技術的な問題に対応しています。オラクル社のアクセシビリティについての詳細情報は、Oracle Accessibility ProgramのWebサイトhttp://www.oracle.com/accessibility/を参照してください。
ドキュメント内のサンプル・コードのアクセシビリティについて
スクリーン・リーダーは、ドキュメント内のサンプル・コードを正確に読めない場合があります。コード表記規則では閉じ括弧だけを行に記述する必要があります。しかしJAWSは括弧だけの行を読まない場合があります。
外部Webサイトのドキュメントのアクセシビリティについて
このドキュメントにはオラクル社およびその関連会社が所有または管理しないWebサイトへのリンクが含まれている場合があります。オラクル社およびその関連会社は、それらのWebサイトのアクセシビリティに関しての評価や言及は行っておりません。
Oracleサポート・サービスへのTTYアクセス
アメリカ国内では、Oracleサポート・サービスへ24時間年中無休でテキスト電話(TTY)アクセスが提供されています。TTYサポートについては、(800)446-2398にお電話ください。
Oracle Business Intelligence Suite Enterprise Editionリリース・ノート, リリース10.1.3.2
部品番号: E05035-04
原本名: Oracle Business Intelligence Suite Enterprise Edition Release Notes, Version 10.1.3.2
原本部品番号: B31773-07
Copyright © 2007, Oracle. All rights reserved.
制限付権利の説明
このプログラム(ソフトウェアおよびドキュメントを含む)には、オラクル社およびその関連会社に所有権のある情報が含まれています。このプログラムの使用または開示は、オラクル社およびその関連会社との契約に記された制約条件に従うものとします。著作権、特許権およびその他の知的財産権と工業所有権に関する法律により保護されています。
独立して作成された他のソフトウェアとの互換性を得るために必要な場合、もしくは法律によって規定される場合を除き、このプログラムのリバース・エンジニアリング、逆アセンブル、逆コンパイル等は禁止されています。
このドキュメントの情報は、予告なしに変更される場合があります。オラクル社およびその関連会社は、このドキュメントに誤りが無いことの保証は致し兼ねます。これらのプログラムのライセンス契約で許諾されている場合を除き、プログラムを形式、手段(電子的または機械的)、目的に関係なく、複製または転用することはできません。
このプログラムが米国政府機関、もしくは米国政府機関に代わってこのプログラムをライセンスまたは使用する者に提供される場合は、次の注意が適用されます。
U.S. GOVERNMENT RIGHTS
Programs, software, databases, and related documentation and technical data delivered to U.S. Government customers are "commercial computer software" or "commercial technical data" pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As such, use, duplication, disclosure, modification, and adaptation of the Programs, including documentation and technical data, shall be subject to the licensing restrictions set forth in the applicable Oracle license agreement, and, to the extent applicable, the additional rights set forth in FAR 52.227-19, Commercial Computer Software--Restricted Rights (June 1987). Oracle USA, Inc., 500 Oracle Parkway, Redwood City, CA 94065.
このプログラムは、核、航空産業、大量輸送、医療あるいはその他の危険が伴うアプリケーションへの用途を目的としておりません。このプログラムをかかる目的で使用する際、上述のアプリケーションを安全に使用するために、適切な安全装置、バックアップ、冗長性(redundancy)、その他の対策を講じることは使用者の責任となります。万一かかるプログラムの使用に起因して損害が発生いたしましても、オラクル社およびその関連会社は一切責任を負いかねます。
Oracle、JD Edwards、PeopleSoft、Siebelは米国Oracle Corporationおよびその子会社、関連会社の登録商標です。その他の名称は、他社の商標の可能性があります。
このプログラムは、第三者のWebサイトへリンクし、第三者のコンテンツ、製品、サービスへアクセスすることがあります。オラクル社およびその関連会社は第三者のWebサイトで提供されるコンテンツについては、一切の責任を負いかねます。当該コンテンツの利用は、お客様の責任になります。第三者の製品またはサービスを購入する場合は、第三者と直接の取引となります。オラクル社およびその関連会社は、第三者の製品およびサービスの品質、契約の履行(製品またはサービスの提供、保証義務を含む)に関しては責任を負いかねます。また、第三者との取引により損失や損害が発生いたしましても、オラクル社およびその関連会社は一切の責任を負いかねます。