Agile Product Lifecycle Management

Product Portfolio Management User Guide

v9.3.0.2

Part No. E17302-01
June 2010
Oracle Copyright

Copyright © 1995, 2010, Oracle and/or its affiliates. All rights reserved.

This software and related documentation are provided under a license agreement containing restrictions on use and disclosure and are protected by intellectual property laws. Except as expressly permitted in your license agreement or allowed by law, you may not use, copy, reproduce, translate, broadcast, modify, license, transmit, distribute, exhibit, perform, publish or display any part, in any form, or by any means. Reverse engineering, disassembly, or decompilation of this software, unless required by law for interoperability, is prohibited.

The information contained herein is subject to change without notice and is not warranted to be error-free. If you find any errors, please report them to us in writing.

If this software or related documentation is delivered to the U.S. Government or anyone licensing it on behalf of the U.S. Government, the following notice is applicable:

U.S. GOVERNMENT RIGHTS
Programs, software, databases, and related documentation and technical data delivered to U.S. Government customers are "commercial computer software" or "commercial technical data" pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As such, the use, duplication, disclosure, modification, and adaptation shall be subject to the restrictions and license terms set forth in the applicable Government contract, and, to the extent applicable by the terms of the Government contract, the additional rights set forth in FAR 52.227-19, Commercial Computer Software License (December 2007). Oracle USA, Inc., 500 Oracle Parkway, Redwood City, CA 94065.

This software is developed for general use in a variety of information management applications. It is not developed or intended for use in any inherently dangerous applications, including applications which may create a risk of personal injury. If you use this software in dangerous applications, then you shall be responsible to take all appropriate fail-safe, backup, redundancy and other measures to ensure the safe use of this software. Oracle Corporation and its affiliates disclaim any liability for any damages caused by use of this software in dangerous applications.

Oracle is a registered trademark of Oracle Corporation and/or its affiliates. Other names may be trademarks of their respective owners.

This software and documentation may provide access to or information on content, products and services from third parties. Oracle Corporation and its affiliates are not responsible for and expressly disclaim all warranties of any kind with respect to third party content, products and services. Oracle Corporation and its affiliates will not be responsible for any loss, costs, or damages incurred due to your access to or use of third party content, products or services.
CONTENTS

Oracle Copyright ........................................................................................................... ii

Introduction ..................................................................................................................... 1

About this Document ...................................................................................................... 1

Related Documentation ................................................................................................. 1

Agile Product Portfolio Management Overview .......................................................... 1

What’s New in PPM 9.3 ................................................................................................. 2

Upgrade Considerations ................................................................................................. 3

Configuration Notes ....................................................................................................... 3

Features Summary ......................................................................................................... 3

When to Use Web Client ................................................................................................. 4

When to Use Gantt Chart ............................................................................................... 4

Project Management Objects ......................................................................................... 5

Project Tree Structure .................................................................................................. 7

PPM Process Flow .......................................................................................................... 10

Where to Find Information ............................................................................................. 10

Understanding the Interface .......................................................................................... 13

Home Page ...................................................................................................................... 13

Quick Links .................................................................................................................... 13

Home Page Inbox Tabs .................................................................................................. 14

Dashboard ...................................................................................................................... 14

Notifications .................................................................................................................. 21

Workflow Routings Tab .................................................................................................. 28

My Assignments ............................................................................................................. 29

Printing the Assignment Table ...................................................................................... 34

Using the Quick View Dialog ....................................................................................... 34

Timesheet ....................................................................................................................... 35

Project Page .................................................................................................................... 36

Viewing Project Details ................................................................................................. 36

Viewing Project Summary ............................................................................................. 37

Summary Page Actions .................................................................................................. 38

Viewing General Information ....................................................................................... 40

Dates .............................................................................................................................. 43

Duration ......................................................................................................................... 43

Audit Values ................................................................................................................... 44

Working with Attachments ......................................................................................... 44

Collaborating on Project Activities .............................................................................. 45
**Managing Content**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting up a Project Structure</td>
<td>45</td>
</tr>
<tr>
<td>Actions Menu</td>
<td>45</td>
</tr>
<tr>
<td>Address Book Palette</td>
<td>46</td>
</tr>
<tr>
<td>Gantt Chart</td>
<td>47</td>
</tr>
<tr>
<td>Overview</td>
<td>48</td>
</tr>
<tr>
<td>Prerequisites</td>
<td>48</td>
</tr>
<tr>
<td>Modes of Operation</td>
<td>49</td>
</tr>
<tr>
<td>Launching Gantt</td>
<td>49</td>
</tr>
<tr>
<td>Launching Gantt Using Shortcuts</td>
<td>49</td>
</tr>
<tr>
<td>Gantt Toolbar Icons</td>
<td>49</td>
</tr>
<tr>
<td>Views in Gantt</td>
<td>51</td>
</tr>
<tr>
<td>Gantt</td>
<td>51</td>
</tr>
<tr>
<td>Task Assignment</td>
<td>51</td>
</tr>
<tr>
<td>Calendar</td>
<td>52</td>
</tr>
<tr>
<td>Critical Path</td>
<td>52</td>
</tr>
<tr>
<td>Comparative Gantt</td>
<td>52</td>
</tr>
<tr>
<td>Resource</td>
<td>52</td>
</tr>
<tr>
<td>Resource Sheet</td>
<td>53</td>
</tr>
<tr>
<td>Resource Utilization</td>
<td>53</td>
</tr>
<tr>
<td>Customizing the Gantt Chart</td>
<td>53</td>
</tr>
<tr>
<td>Setting Preferences</td>
<td>54</td>
</tr>
<tr>
<td>Appearance and Style</td>
<td>55</td>
</tr>
<tr>
<td>Bar Labels</td>
<td>55</td>
</tr>
<tr>
<td>Grids</td>
<td>55</td>
</tr>
<tr>
<td>View Bar</td>
<td>56</td>
</tr>
<tr>
<td>Gantt File Menu Options</td>
<td>56</td>
</tr>
<tr>
<td>Working Offline on Gantt</td>
<td>57</td>
</tr>
<tr>
<td>Unlocking Projects before Exiting</td>
<td>57</td>
</tr>
<tr>
<td>Toggling the View Between Gantt and Web Client</td>
<td>57</td>
</tr>
<tr>
<td>Printing a Gantt Chart</td>
<td>58</td>
</tr>
</tbody>
</table>

**Setting Up Project Management Processes** ........................................... **59**

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Setting up a Project Structure</td>
<td>59</td>
</tr>
<tr>
<td>Creating a Project Template</td>
<td>60</td>
</tr>
<tr>
<td>Identifying the Template Used to Create a Project</td>
<td>61</td>
</tr>
<tr>
<td>Adding Activities</td>
<td>61</td>
</tr>
<tr>
<td>Adding Gates</td>
<td>62</td>
</tr>
<tr>
<td>Adding Milestones</td>
<td>63</td>
</tr>
<tr>
<td>Editing Data</td>
<td>63</td>
</tr>
<tr>
<td>Deleting Project Elements</td>
<td>64</td>
</tr>
<tr>
<td>Setting Ownership to Resource Pools</td>
<td>65</td>
</tr>
<tr>
<td>Managing Content</td>
<td>65</td>
</tr>
</tbody>
</table>
Adding Content ..............................................................................................................................65
Setting Mandatory Content .......................................................................................................67
Setting Up AutoNumbering ........................................................................................................68
Personalizing Views for Content ................................................................................................68
Defining Rules for Content ..........................................................................................................69
Duplicating Deliverables from a Project Template .......................................................................70
Content Objects ........................................................................................................................70
AutoNumbers ................................................................................................................................70
Required Fields ............................................................................................................................71
Tabs .............................................................................................................................................71
Activities and Gates .....................................................................................................................71
Root Projects ................................................................................................................................71
Templates ......................................................................................................................................72

Creating and Managing Projects ...............................................................................................73
Creating a Project ..........................................................................................................................73
Using Gantt Chart ........................................................................................................................73
Using Web Client ..........................................................................................................................74
Editing a Project ............................................................................................................................76
Editing Project Objects Concurrency .......... 76
  Editing Multiple Tasks in the Same Project Tree ................................................................. 76
  Editing Tasks with a Predecessor and Successor Relationship ......................................... 76
Examples ......................................................................................................................................77
Multiple Users Editing the Same Task .......................................................................................77
Reviewing Changes .......................................................................................................................78
Undoing Changes ..........................................................................................................................79
Activating a Project .......................................................................................................................79
Working with Project Content ......................................................................................................80
  Viewing Content ......................................................................................................................80
  Updating Content ....................................................................................................................81
Managing Resources .....................................................................................................................82
  Adding Resources ..................................................................................................................82
    Adding Resources using Web Client .................................................................................. 82
    Adding Resources using Gantt .............................................................................................82
  Viewing Resource Utilization .................................................................................................85
    Viewing Project Resource Utilization Chart .....................................................................85
    Viewing Resource Utilization Reports .......................................................... 86
  Editing Team Member Attributes ......................................................................................... 86
  Assigning Tasks to Resources ............................................................................................... 88
Bulk Assigning Tasks to a Resource ......................................................... 88
Splitting a Task Among Several Resources ........................................... 88
Changing Ownership of Tasks in Projects Created from Templates .......... 89
Removing Resources ............................................................................. 89
Delegating Ownership .......................................................................... 90
Substituting Resources .......................................................................... 92
Searching for Timesheets ....................................................................... 93
Managing Schedules ............................................................................. 93
Creating and Editing Dependencies ...................................................... 93
Creating and Editing Dependencies in Web Client ................................. 94
Creating and Editing Dependencies in Gantt ............................................ 94
Types of Dependencies .......................................................................... 95
Dependency Time Buffer ........................................................................ 96
Editing Display Order ........................................................................... 96
Rescheduling a Program ......................................................................... 96
Creating a Baseline ................................................................................ 97
Comparing Baselines ............................................................................. 98
Managing Discussions ......................................................................... 99
Discussions Table ................................................................................ 99
Adding Discussions ............................................................................... 99
Replying to Discussions ....................................................................... 100
Viewing Discussion Replies .................................................................. 101
Removing Discussions ......................................................................... 101
Viewing Action Items ........................................................................... 102
Archiving Projects ................................................................................ 102

Participating in Projects ..................................................................... 105
Accepting Assignments ........................................................................ 105
Declining Assignments ......................................................................... 105
Editing Assignments ............................................................................ 106
Mark Assignments Complete ................................................................. 106
Flagging Assignments .......................................................................... 107
Reporting Time ..................................................................................... 107
Subscribing to Events .......................................................................... 108
Changing Workflow Status ................................................................... 108

Tracking Projects ................................................................................ 111
Status Tracking .................................................................................... 111
Default Health Statuses ....................................................................... 111
How Status Roll-Up works .................................................................... 112
### Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Workflow Status</td>
<td>113</td>
</tr>
<tr>
<td>Rules for Parent Status</td>
<td>113</td>
</tr>
<tr>
<td>Cost Status</td>
<td>114</td>
</tr>
<tr>
<td>How Total Cost is Determined</td>
<td>114</td>
</tr>
<tr>
<td>Costs Included in Baselines</td>
<td>115</td>
</tr>
<tr>
<td>Reports</td>
<td>115</td>
</tr>
<tr>
<td>About Agile Standard Reports</td>
<td>115</td>
</tr>
<tr>
<td>Agile Standard Reports for PPM</td>
<td>116</td>
</tr>
<tr>
<td><strong>Working with Microsoft Project</strong></td>
<td><strong>119</strong></td>
</tr>
<tr>
<td>Before You Begin</td>
<td>119</td>
</tr>
<tr>
<td>Working with Imported Microsoft Project Files</td>
<td>119</td>
</tr>
<tr>
<td>Setting Up Microsoft Project Synchronization</td>
<td>119</td>
</tr>
<tr>
<td>Creating a PPM Project from an Existing Microsoft Project File</td>
<td>120</td>
</tr>
<tr>
<td>Mapping Resources</td>
<td>120</td>
</tr>
<tr>
<td>Launching a PPM Project in Microsoft Project</td>
<td>121</td>
</tr>
<tr>
<td>Read Only and Edit Modes</td>
<td>121</td>
</tr>
<tr>
<td>Working Offline on a PPM Project</td>
<td>122</td>
</tr>
<tr>
<td>Microsoft Project Troubleshooting Tips</td>
<td>122</td>
</tr>
<tr>
<td>Deleting Objects in Microsoft Project</td>
<td>123</td>
</tr>
<tr>
<td>Transferring Microsoft Project Work Values to PPM</td>
<td>123</td>
</tr>
<tr>
<td><strong>Import and Export</strong></td>
<td><strong>125</strong></td>
</tr>
<tr>
<td>Importing Data</td>
<td>125</td>
</tr>
<tr>
<td>Before You Begin</td>
<td>125</td>
</tr>
<tr>
<td>Persistence of Import Settings</td>
<td>126</td>
</tr>
<tr>
<td>Importing Large Data Files</td>
<td>126</td>
</tr>
<tr>
<td>Supported File Formats</td>
<td>126</td>
</tr>
<tr>
<td>Data Transformation</td>
<td>127</td>
</tr>
<tr>
<td>Importing Projects and Project Content</td>
<td>127</td>
</tr>
<tr>
<td>Define Import Preferences</td>
<td>127</td>
</tr>
<tr>
<td>File Selection</td>
<td>127</td>
</tr>
<tr>
<td>Specify File Content</td>
<td>127</td>
</tr>
<tr>
<td>Specify Attribute Mapping</td>
<td>130</td>
</tr>
<tr>
<td>Review Import Settings and Begin Import</td>
<td>130</td>
</tr>
<tr>
<td>Exporting Data</td>
<td>130</td>
</tr>
<tr>
<td><strong>Configuring Product Portfolio Management</strong></td>
<td><strong>133</strong></td>
</tr>
<tr>
<td>Administration in Agile Java Client</td>
<td>133</td>
</tr>
</tbody>
</table>

v9.3.0.2
Preface

The Agile PLM documentation set includes Adobe® Acrobat PDF files. The Oracle Technology Network (OTN) Web site http://www.oracle.com/technology/documentation/agile.html contains the latest versions of the Agile PLM PDF files. You can view or download these manuals from the Web site, or you can ask your Agile administrator if there is an Agile PLM Documentation folder available on your network from which you can access the Agile PLM documentation (PDF) files.

**Note** To read the PDF files, you must use the free Adobe Acrobat Reader version 7.0 or later. This program can be downloaded from the Adobe Web site http://www.adobe.com.

The Oracle Technology Network (OTN) Web site http://www.oracle.com/technology/documentation/agile.html can be accessed through Help > Manuals in both Agile Web Client and Agile JavaClient. If you need additional assistance or information, please contact My Oracle Support (https://support.oracle.com) for assistance.

**Note** Before calling Oracle Support about a problem with an Agile PLM manual, please have the full part number, which is located on the title page.

TTY Access to Oracle Support Services

Oracle provides dedicated Text Telephone (TTY) access to Oracle Support Services within the United States of America 24 hours a day, 7 days a week. For TTY support, call 800.446.2398. Outside the United States, call +1.407.458.2479.

Readme

Any last-minute information about Agile PLM can be found in the Readme file on the Oracle Technology Network (OTN) Web site http://www.oracle.com/technology/documentation/agile.html

Agile Training Aids

Go to the Oracle University Web page http://www.oracle.com/education/chooser/selectcountry_new.html for more information on Agile Training offerings.

Accessibility of Code Examples in Documentation

Screen readers may not always correctly read the code examples in this document. The conventions for writing code require that closing braces should appear on an otherwise empty line; however, some screen readers may not always read a line of text that consists solely of a bracket or brace.

This documentation may contain links to Web sites of other companies or organizations that Oracle does not own or control. Oracle neither evaluates nor makes any representations regarding the accessibility of these Web sites.
Chapter 1

Introduction

This chapter includes the following:

- About this Document ........................................................................................................................................... 1
- Agile Product Portfolio Management Overview ..................................................................................................... 1
- Features Summary ...................................................................................................................................................... 3
- When to Use Web Client ........................................................................................................................................... 4
- When to Use Gantt Chart .......................................................................................................................................... 4
- Project Management Objects .................................................................................................................................... 5
- PPM Process Flow ..................................................................................................................................................... 10
- Where to Find Information ...................................................................................................................................... 10

About this Document

The Agile Product Portfolio Management (PPM) user guide describes the features and functions of Agile PPM. It addresses managers and executives who use Agile PPM to record, monitor, and track progress of projects and programs.

Related Documentation

We recommend the following references to understand some aspects common to all Agile PLM solutions:

- Agile PLM Getting Started Guide
- Agile PLM Administration Guide

Agile Product Portfolio Management Overview

Agile Product Portfolio Management (PPM) is a web-based application that enables users to manage all aspects of a project or program. PPM is fully integrated with the complete Agile PLM suite of products to maintain a centralized view of project records and associated product information within the organization.

Executives use the PPM Dashboards to view portfolio data pertaining to all projects or programs. This includes risks such as schedule slips, lack of resources, and project cost that directly contribute to the overall status of the project.

Project or program managers use PPM to:

- Create and manage project tasks, resources, and schedules
- Assign projects, phases, tasks, and deliverables
- Conduct project discussions
Generate action items
View and distribute project content
Oversee project status
Manage project budgets

Resource pool managers use PPM to:

- Manage resource pools
- Assign resources to tasks

Project participants use PPM to:

- Manage daily task assignments
- Report the completion of tasks
- Upload documents
- Participate in project discussions

What’s New in PPM 9.3

The Agile PLM UI has been dramatically enhanced in release 9.3, and there have been congruent changes in PPM as well. Commonly used features that have been enhanced are listed below. Click on each link to view the corresponding section where these changes are documented.

- **Viewing Project Summary** on page 37 - Enhanced widget configuration and personalization options.
- **Managing project content** on page 65 - Faster project content addition, directly from the search results table or the left pane, using drag and drop or copy and paste. Preview pane and View Details icon replaced by a Quick View dialog that appears when you position your mouse cursor upon any Agile object. Edit Rule button moved to table header. Enhanced View creation and personalization.
- **Working on assignments** on page 29- Icon/button changes. Enhanced View creation and personalization. View Details dialog replaced by Quick View.
- **Project scheduling** on page 93 using Gantt Chart - Only icon changes.
- **Assigning resources** on page 82 using Gantt Chart - Only icon changes.
- **Delegating ownership** on page 90 using Gantt and Web Client - Only icon changes.
- **Launching a project in Microsoft Project** on page 119 - No changes in functionality. This action was earlier available under the Tools > Administration menu in the right pane of the Web Client. This menu has now moved to the left pane, and is now called Tools and Settings.
- **Viewing Dashboard** on page 14 - The Dashboard was earlier accessible from the drop-down list next to the Home icon. This is now a separate tab on the Home page along with Notifications, Workflow, and My Assignments. Default tabs and widgets have been renamed. The Programs tab has been renamed to Projects and My Activities to My Stuff. Column and widget display have been optimized.
Managing Discussions and Action Items on page 45 - Now grouped under a new tab called Collaboration.

Creating and Comparing Baselines on page 97 - All baseline-related actions are now grouped together in the Schedule tab.

Upgrade Considerations

During an upgrade from a previous version of PPM, data migration is necessary, so the existing data complies with new or changed business rules.

To facilitate the data migration, a post upgrade utility is available. For information on using this utility, see the guide Installing Agile PLM with BEA WebLogic.

Note The PPM post upgrade utility is not supported on WebSphere Application Server.

Configuration Notes

For Japanese and Chinese OS, an Agile PPM database instance can only be configured to use UTF-8 language encoding. Agile PPM sets the browser’s character encoding to UTF-8, and it is not recommended to change the character encoding setting in the browser.

If the Agile PLM server is running on JRE 1.4, the Gantt application requires JRE 1.5.x. The higher versions such as JRE 1.6 are supported, if the Agile PLM server is running on JRE 1.5.

Features Summary

The PPM objects provide detailed control over all aspects of project management, from high-level overview to individual employee activities.

PPM has features that enable you to plan, manage, and execute projects. You can classify the features of PPM into the following categories:

Project Planning
- Create a project from scratch
- Create projects based on existing project templates
- Create baselines for projects
- Convert your Microsoft Project to a PPM project to avail the benefits of Agile PLM
- Import and export root-level information about the projects
- Import project details from file formats such as .xls and .csv into PPM
- Manage project schedules
- Manage project milestones and gates

Resource Management
- Assign projects and tasks to resources
- Manage resource pools
- Track time and effort spent on projects
- **Project Collaboration**
  - Initiate and respond to project-related discussions
  - Post news and action items related to the project
  - View notifications on assignments and action items
  - Maintain a project dashboard

- **Project Tracking**
  - View project summary to track overall status of a project
  - Track project costs
  - Monitor overall status of the project
  - Generate project reports for analysis
  - View notifications on assignments and action items

### When to Use Web Client

Web Client is recommended for the project team members who need to view information and input data specific to the activities they own.

Use Web Client to:

- View notifications and assignments
- Manage assignments
- Use timesheets
- View a personalized dashboard
- View project summary and status
- Change workflow status
- View reports
- Manage subscriptions
- Manage content
- Participate in discussions

**Note** Project participants use Web Client for all their activities.

### When to Use Gantt Chart

Gantt chart is recommended for program and project managers, whose primary responsibility is to monitor and manage programs and projects.

Use Gantt chart to:

- Assign and manage tasks and resources
- Monitor resource utilization
- Add and manage activities, gates, and dependencies
- View progress and modify project schedule

## Project Management Objects

Project Management process involves management of schedules, tasks, statuses, discussions, documents, phases, gates, and resources.

At a minimum, a typical Agile PPM project consists of:

- A root-level project
- A series of child objects such as phases, programs, tasks, gates, or other projects.

The following table describes the various objects in the Agile PPM solution:

<table>
<thead>
<tr>
<th>Icon</th>
<th>Object</th>
<th>Description</th>
</tr>
</thead>
</table>
| ![Folder] | Project | A Project is a unique set of related projects, phases, tasks, sub-programs, milestones, and gates that is driven by a time schedule with target start and end dates, and dependencies. A Project is the top-level object, but can also be a child of another project.  
**Note** If the organizational practice uses Programs as the top-level object, to enable program creation in PPM, contact your site’s Agile Administrator. |
| ![Folder] | Program | A Program is a unique set of related programs, phases, tasks, sub-programs, milestones and gates. Programs are driven by a time schedule. A Program can be the top-level object or a child object of another project or program. |
| ![Folder] | Phase | A Phase, sometimes called a stage, is a segment of a project.  
Phases define the activities required to create a set of deliverables. When phases end, Project Managers may hold a phase exit or gate review to examine the completion status of each phase.  
A Phase comprises activities such as tasks and gates. It derives the date and status information from the project elements. |
| ![Folder] | Task | A Task is a segment of work that one or more resources can complete over a period of time. Progress or status of a task rolls up to higher levels of the program. Phases, projects, programs, or other tasks can contain tasks. |
| ![Folder] | Gate | A gate marks a point in the project timeline that typically requires a review of a group of project tasks, activities, and/or deliverables.  
A gate status is "Closed" by default. Gates can be set in review or set to open based on work performed in the project. The work performed is typically defined as deliverables. If a gate is set into review, the project can be held until it is opened. When a gate is opened, directly or after a review, project progress can resume.  
A decision gate is a special gate type used in phase-gate project methodologies. Decision gates mark a point in the project timeline when tactical and strategic
## Icon | Object | Description
--- | --- | ---
 | Milestone | Milestones are points in the project timeline that indicate the need for additional or secondary activities. Milestones can mark billing cycles, sub-project launch points, project metrics, or project team notifications. Milestones may or may not be dependent on deliverables.
 | Deliverable | A Deliverable represents a unit of work required for a project's success, usually fulfilled by generating a digital file. (Word processing documents, spreadsheet documents, PDFs, presentation documents, etc.) Deliverables can also be Agile PLM objects and processes. Deliverables are managed in the Content tab of a project and often used to control the status of tasks and gates.
 | Discussion | Discussions are informal conversations specific to a project or program, found in the Discussions tab within the Collaboration tab of the project object. Discussions are frequently sub-classed into Risks and Issues sub-classes to capture and store all risks and issues related to projects.
 | News | News is the information or announcements that need to be communicated to everyone who has access to the project object. News is a tab within the Collaboration tab of the project object.
 | Action Item | Action items are created in the Collaboration tab of a project and are used to track non-essential activities that do not impact the project timeline. Action items can be assigned at any level of the project hierarchy. Action items are tracked and available to users in the project's Summary page and the My Assignments page.

**Note** Programs, projects, phases, tasks and gates are fully customizable. For further information, see your site’s Agile administrator.
Project Tree Structure

The following figure illustrates the various PPM Objects in a project.
Projects, programs, phases, tasks and gates are fully customizable. A 'Program' with multiple projects is 'Complete' only if all the projects within it are 'Complete'. Each of these projects has its own set of phases and gates. The following figure illustrates 'Projects' within a 'Program':

Note: If your organization uses 'Programs' instead of 'Projects', contact your site's Agile Administrator to modify settings in Java Client.
Chapter 1: Introduction

An example of a project tree structure as seen in the navigation pane:

- 2.0 Product Development
  - Phase One - Feasibility Assessment
  - Evaluate Market and Revenue Expectations
    - Create Preliminary Market and Revenue Forecast
    - Define Market Expectations
  - DP1 - Release to Development
  - Phase Two - Product Development
  - DP2 - Release to Prototype
  - Phase Three - Prototype Development
  - DP3 - Release to Pilot
  - Phase Four - Pilot Production
  - DP4 - Release for Volume Ramp
  - Phase Five - Ramp to Volume and Release
  - DP5 - Release for Manufacture
  - Phase Six - Project Brief
  - DP6 - Project Complete
PPM Process Flow

Where to Find Information

<table>
<thead>
<tr>
<th>Your role...</th>
<th>Where to find information...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project or Program Management Office</td>
<td>Setting up Project Management Processes on page 59</td>
</tr>
<tr>
<td>Project Manager</td>
<td>Creating and Managing Projects on page 73</td>
</tr>
<tr>
<td></td>
<td>Working with Microsoft Project on page 119</td>
</tr>
<tr>
<td></td>
<td>Import and Export on page 125</td>
</tr>
<tr>
<td></td>
<td>Tracking Projects on page 111</td>
</tr>
<tr>
<td>Resource Pool Owner</td>
<td>Creating and Managing Projects on page 73</td>
</tr>
<tr>
<td>Task Owner, Resource</td>
<td>Participating in Projects on page 105</td>
</tr>
<tr>
<td>Role</td>
<td>Section</td>
</tr>
<tr>
<td>-----------------------</td>
<td>--------------------------------</td>
</tr>
<tr>
<td>Administrator</td>
<td>Configuring Product Portfolio Management</td>
</tr>
<tr>
<td>Any PPM User</td>
<td>Understanding the Interface</td>
</tr>
</tbody>
</table>
Chapter 2

Understanding the Interface

This chapter includes the following:

- Home Page ................................................................. 13
- Project Page ..................................................................... 36
- Gantt Chart ...................................................................... 47

As a PPM user, you need to be familiar with the following:

- Using PPM-specific tabs in the Dashboard
- Working with PPM Notifications
- Working with My Assignments
- Working with Timesheets
- Accessing project information
- Using the Navigator
- Working with Gantt Chart

Home Page

The Agile Home page provides access to Dashboard, Notifications, Workflow Routings, and My Assignments. You can configure the application to view timesheets. You can set the Home page to display one of these tab pages as your preferred start page. For more information, refer the Getting Started with Agile PLM guide.

If you choose one of the dashboard tabs as your preferred start page, that dashboard tab page displays when you click the icon in the top pane.

If you want to view the Home page while you are working on a project page, click the icon.

Quick Links

Quick Links, at the top of the Home page, is a list of up to ten links that you use frequently. You can define and edit your own Quick Links list. Your Quick Links list can include predefined Agile PLM system links, saved searches in your Personal Searches folder, or bookmarks in your My Bookmarks folder.

To edit your Quick Links list:

1. Click the Edit icon next to the Quick Links: heading at the top of the Home page. The Edit Quick Links dialog appears.
2. From the drop-down list choose the type of link you want to use.
The three types of available links are:

- **Links** – predefined Agile PLM system links including My User Profile and Change Password.
- **Bookmarks** – available values are all the bookmarks in your Bookmarks folders, listed individually.
- **Searches** – available values are all the searches in your Personal Searches folders, listed individually.

3. Use the ▶ display button and ▼ hide button to move links from the Hidden Links list to the Quick Links list.
   Or, double-click to move links from one list to the other list.

4. You may include more than ten links in the Quick Links list, but only the first ten links are displayed in your **Quick Links** list.

5. Reorder the list by selecting one or more links and using the ▲ move up and ▼ move down arrow buttons to move them up or down in the list.

6. When you are finished, click the **Save** button.

**Home Page Inbox Tabs**

As information passes through the Agile system, users receive news of status changes, requests, and other notifications through email. Users with different roles and privileges receive different notifications. As soon as you log in to the Web Client, it is a good practice to view the information available for your perusal on the Home Page Inbox tabs.

- **Dashboard Tab**—Enables you to view and manage information across all your projects. For more details on dashboard features, see **Dashboard** on page 14.

- **Notifications Tab**—Lists notifications that inform you of some action or process that has taken place, or requests that you can accept from the My Assignments tab. In addition, this tab lists the action items or activities for which you can accept or decline ownership from the My Assignments tab. It is a recommended practice to delete the notifications after you have read them.

- **Workflow Routings Tab**—Lists the routable objects that require your review or action. Click the object number in the table to open a routable object.

- **My Assignments Tab**—My Assignments Tab lists project leaf node objects or action items assigned to you which are not yet complete. You can accept or decline a request or ownership. Click the Quick View callout that appears when you position your mouse cursor over an object, to view the details of the object.

- **Timesheet Tab**—Allows timesheet entry by assigned resources on a project. It enables you to track reported time data to ascertain resource utilization and related costs. This tab is visible only if enabled by your Agile administrator.

**Dashboard**

The Dashboard is a highly configurable set of views that enables users to track and manage the information available in the Agile PLM system.

You can create an unlimited number of dashboard tabs to categorize and display the content you
want. Access to these tabs can be restricted through roles and privileges. The data that you wish to view can be retrieved from different sources, and rendered in charts, tables, and other forms.

Dashboard tabs must be created and configured in Agile Java Client by an administrator. You can view and personalize the tabs that are made visible in Agile PLM Web Client for your use.

For details on configuring Dashboard views, see the *Agile PLM Administrator Guide*.

The dashboard enables PPM users to view and manage information across all projects. You can use the dashboard to obtain:

- Executive-level view of key information for all your projects based on your roles and privileges
- User-level information about your own activities and tasks
- Resource utilization reports

All users can use the dashboard to access reports and view consolidated information. See also *Reports* on page 115.

**Viewing the Dashboard**

The Dashboard tab appears on the Home page along with *Notifications*, *Workflow Routings*, and *My Assignments* tabs.

**To view the Dashboard:**

1. In the top pane of the Welcome page, click *Home* 
2. Click the *Dashboard* tab.

**To make the Dashboard tab page your default start page when you log into Web Client:**

1. In the top pane of the Welcome page, click *My Settings* . The User Profile page appears.
2. Click the *Preferences* tab.
3. Click *Edit*.
4. Select the *Dashboard* list item in the *Preferred Start Page* drop-down list.
5. Click *Save*.

**Manipulating the Dashboard Widgets**

The Dashboard widgets can be manipulated by the icons and menu entries described in the table below.

<table>
<thead>
<tr>
<th>Button</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Export</td>
<td>Exports data in comma-separated value (.CSV) format for use in a spreadsheet (available in all tables).</td>
</tr>
<tr>
<td>Maximize/Restore Original Size</td>
<td>Expands the window to full size or reduces it to the size it was previously.</td>
</tr>
<tr>
<td>Refresh</td>
<td>Refreshes the table view to show latest changes to content.</td>
</tr>
<tr>
<td>Button</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Remove Content From View</td>
<td>Closes the window. To reopen the window, refresh your browser view. Or select the content object from the <strong>Add Content</strong> drop-down list at the bottom of the page and click Add.</td>
</tr>
<tr>
<td>✉️ Dashboard Filter</td>
<td>Displays the dashboard category fields on the basis of which you can filter the widget results. Edit these fields and click Save to obtain the narrowed down search results.</td>
</tr>
</tbody>
</table>

In the windows which display a widget, you can click column headings of most tables to change the sort order. If you have the necessary privileges, you can click on data in most widgets to ‘drill down’ to a view of the individual object.

**Dashboard Tabs**

The dashboard comprises:

- **Default Tabs** that enable you to select the view: Executive, Projects, Resources, Financial, My Stuff, Optional Tab 1, and Optional Tab 2.
- **User-configured tabs** that display customized information in tabular or chart formats, based on preferences set up by an administrator.

**Note** To view user-configured tabs, you must have the Dashboard Tab View privilege assigned to you, and this privilege must be applied to these tabs within the Agile Java Client.

- **Widgets** within each tab that present information relevant to that view. For example, in the My Stuff tab, the widgets represent the current user’s project activities: My Discussions, My Documents, My Action Items.

The **Dashboard Filter icon in every table enables you to filter data within the widgets to create customized views.**

The information you can view in the Executive, Projects, and Financial tabs is from root projects for which you have the Read and Discover privilege.

If you are an Executive, you have global privileges. You can view all root-level projects that contain matching values for the dashboard category fields. By default, these fields are labeled Project Type, Region, Division, Customer, Launch Year, Product Line, Category 7, Category 8, Category 9, and Category 10. These are multi-select list fields that can be relabeled and configured within the **Administration > General Info** tab in the Agile Java Client.

**Note** For information on how to configure optional dashboard tabs, see the Agile Administrator Guide.
**Configuring Dashboard Tab Widgets**

The Dashboard Filter icon at the top of each widget enables you to filter the data in the widget to show only the information that is most relevant to you.

**To filter the table display within a dashboard tab widget:**

1. Click the Dashboard Filter icon in the table. The default filter values for the dashboard category fields appear.
2. Click **Edit**.
3. The default selection for all the dashboard categories is **All**. Choose the **Selected** option to enable the search palette next to each field.
4. Launch the search palette next to the dashboard category field which you want to filter, and search for defined attributes.
5. Select attributes for each category field, one by one.
6. Click **Save**.

The selected fields display in the widget.

You can filter the dashboard category fields that display within each tab widget according to your business requirement.

For example, a functional manager who owns a number of resource pools might want to view only off-track tasks assigned to people in certain pools. An executive might set the dashboard to show all the projects, programs, issues, gates, financial summaries, and resources that apply to a division and region, or view a specified subset. Once the dashboard settings are entered, you only see information that satisfies the specified settings.

You can use the dashboard category fields to rapidly classify tasks and to slice data for reporting purposes. The default Dashboard category fields are Project Type, Region, Product Line, Division, Region, Launch year, Category 7, Category 8, Category 9, and Category 10.

The values that you set at the root project level are applied down the hierarchy. For example, if you set a particular value for **Division** at the root project level, all the tasks within the hierarchy are also set to the same value. These fields are ideally used for Customer, Market and other attributes that are relevant at the top level of the project.

---

**Note**

If a root project has a value set to "All," then, by design, it will show up in all views no matter what value is selected in the configuration view for that field.

---

**Executive Tab**

The **Executive** tab provides portfolio data for the executive who needs to monitor projects and see information rollups by type of project. It provides a cross-section of information on projects where you can see the major risks in terms of schedule, resources, and cost.

**Note**

The Executive tab contains data only if you have Executive role, or have Read privilege for root-level projects.
The widgets in the Executive tab are:

- **Project Status** - Provides a graph of all active projects the user has configured to view, showing the overall status of each (i.e., On Track, Needs Attention, Off Track). For each type of status displayed, the widget shows the percentage of projects with the specific status.

To display the number of projects that comprise a segment, place the mouse cursor over that segment of the chart.

To display the Projects tab with a particular segment of projects selected in all windows, click on that segment.

The data in this window does not include projects that are in the Completed or Canceled states, projects with a Project State field setting of Proposed or Template, or projects that are archived or soft-deleted.

- **Resource Pool Allocation** - Displays a table showing the names of available resource pools and associated data, filtered by the settings in the dashboard filter.

The table displays the following information for each resource pool:

- **Pool Name** – The name of the resource pool.
- **Overdue** – The number of Off Track projects which have a resource pool or pool members assigned.
- **Allocation** – Displays □ if the pool or any of its members are over-allocated for a project.

Pool members who do not have current assignments are not counted. Resources who are not assigned to any resource pool do not appear on the dashboard.


The data in this window does not include projects that are in the Completed or Canceled states, projects with a Project State field setting of Proposed or Template, or projects that are archived or soft-deleted.

- **Financial** - Displays a table showing cost rollups for the root projects that you have access to view. The Financial tab in the Executive view also shows the same table that is presented in the Financial View. See Financial Tab on page 20.

**Projects Tab**

The Projects tab displays gate progress, status, and discussions specific to the projects for which you have access as the owner, resource, or team member. The various widgets in the Projects tab are:

- **Project Status** - Displays all projects to which you have access (subject to the table filters). It includes the root project name, status, start date and end date.

To change the sort order, click a column heading.

To open a Project object, click its name. The icon adjacent to the project name indicates the status of the project, such as On Track or Needs Attention.

- **Gate Status** - Displays the gates for each active project, their status and scheduled due date. (The number required is derived from the number of deliverables listed on the Content tab plus
the number of dependencies to the gate.)

To open a project or gate, click its name.

- **Project Discussions** - Lists the open discussions, specific to the projects for which you have access rights. The Open Date denotes the date on which the discussion was initiated. Use the Priority drop-down list to filter the discussions on the basis of priority.

**Resources Tab**

The **Resources** tab provides resource pool owners and executives with the information about the resources they manage. Pool managers can see the status of activities assigned to their resources, the priority issues related to their resources and the list of off-track activities assigned to their pools as well as the current resource loads across the enterprise.

The various widgets in the **Resources** tab are:

- **Resource Allocation** - Shows each resource pool’s projects and status, noting items that are in Pending, Assigned, or Overdue statuses. It also notes resources that are over-allocated.

  A pending activity or gate is one that has been delegated to a resource pool, but has not yet been assigned to a user in that pool.

  The number of overdue items is a count of all activities or gates that are past the due date, whether or not they are assigned to users.

  To edit status for a resource pool (add or remove resources, or create a report), click its name.

  The data in this window does not include projects that are in the Completed or Canceled states, projects with a Project State field setting of Proposed or Template, or projects that are archived or soft-deleted.

- **Open Discussions by Resource Pool** - Shows the discussions for each resource pool. You can select priorities to display from the Priority list. Click the name of a project to open it. Once the project object is open you can go to its Discussions tab, and view associated issues. (For further information on the Discussions tab, see **Discussion Table** on page 99.)

  If there is a discussion thread, only the top level issue is displayed.

  The data in this window does not include projects that are in the Completed or Canceled states, projects with a Project State field setting of Proposed or Template, or projects that are archived or soft-deleted.

- **Resource Pool Activity Status** - Shows Off-Track items assigned to pool members of pools that you own, noting Scheduled due date, Project name, and Scheduled End date. To view and update off-track resource pool activities, click the Resource pool name.

  The data in this window does not include projects that are in the Completed or Canceled states, projects with a Project State field setting of Proposed or Template, or projects that are archived or soft-deleted.

- **Resource Pool Utilization** - Shows a graph of resource pool utilization by project, enabling a pool manager to see where resources are allocated or over-allocated.

  To view project name and percent utilization of resources, place the mouse pointer over each chart segment.

  To view team data, click the chart segment of interest. This opens the corresponding project
object in the Team tab.

The data in this window does not include projects that are in the Completed or Canceled states, projects with a Project State field setting of Proposed, or projects that are archived or soft-deleted.

Financial Tab

The Financial tab shows charts of capital expense, labor cost, and fixed cost for each root project available. The Financial tab also shows the same table that is presented in the 'Financial' widget in the Executive tab.

To configure which reports appear in the Financial tab, use Tools and Settings > Administration > Dashboard Configuration.

To select the projects to be considered for each chart, use the Dashboard filter in the chart.

You can minimize, maximize, or close charts in the tab view. When a chart is closed, the Add Content list appears. Use this list to re-open any chart that you have closed.

My Stuff Tab

The My Stuff tab displays the Documents, Discussions, and Action Items assigned to the logged in user. The widgets in this tab are:

- My Action Items - Displays all your Action Items by Status, Creator, and Due Date. The name of the project or discussion to which the Action Item is associated appears as a link in the Belongs To column. Click the link to view the associated object. To view the Action Item, click the corresponding link in the Subject column.

- My Documents - Lists all the project-related documents that you own with the name of the Root Project, Project Name, Folder Number, and the File Name. To open a file, click the folder number and then click the Files tab. Alternatively, you can click the file name to view the document.

- My Discussions - Lists all the discussions you have created for the selected set of projects, showing the Subject, Most Recent Message, and the Date for each. You can click on the Subject link to view and reply to a discussion.

Optional Tabs

You can configure Optional Tab1 and Optional Tab2 to display reports based on your customized queries in each table. If you have the privilege to configure these tabs, a Configure button appears in the middle of each table in the Optional Tabs page.

To configure a dashboard widget table:

1. Click Configure.
2. In the Table Name field, type a name relevant for the data you want to show in the table.
3. In the Chart Type field, select an option.
4. Click Next.
5. Select one of the following search options:
   - Saved Search - Use the search palette to select a saved search.
   - Advanced Search - Click Define Query to use the Agile PLM Advanced Search feature to
6. Click **Next**.

7. Select the fields you want to display from the **Available Fields** column and move them to the **Selected Fields** column using the left and right arrows. You can also reorder the fields using the up and down arrows.

8. Specify sort order and click **Finish**.

The fields that are available for display are configured in Java Client by an administrator. For more information on configuring Optional tabs in Java Client, see the *Agile PLM Administrator Guide*.

**Dashboard Management Administration Tasks**

If your Agile administrator has given you Administrator privilege applied to Dashboard Management, you can use the Tools and Settings menu (**Tools and Settings > Administration > Dashboard Configuration**) to modify system-wide settings that determine which available tables to display on each tab, and the order in which they are displayed. For instructions, see Configuring the Dashboard on page 155.

| Caution | Any Dashboard Management modification you make affects every Agile PLM user. If you display a particular table, then every user can see that table in their dashboard. If you hide a particular table, then no one can see that table in their dashboard. |

**Notifications**

The Home page **Notifications** tab lists notifications that have been sent to you through the PLM notification system. Notifications inform you of some action or process that has taken place, such as the trigger of a field subscription and the generation of RFQs. A notification can also let you know that you have a request that requires your attention. Requests ask you to accept or decline ownership of an action item or activity.

| Note | To accept or decline a request, use the **My Assignments** tab. |

**To view a notification:**

Click the **Subject** link.

The notification details and links to associated data are displayed in the notification palette. The palette controls include:

- Back – read the previous notification in the table.
- Forward – read the next notification in the table.
- Delete – delete the displayed notification.
- Close – close the palette.

**To delete notifications from the table:**

1. Select the table rows you want to delete.
2. Click the **Delete** button or Press the **Delete** key.

The Notifications table displays the following information about each notification.
**Note**  You can sort the Notifications table by clicking any of the table column headers described below.

<table>
<thead>
<tr>
<th>Notification table columns</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Notification icons</td>
<td>Displays icons representing the type of notification and whether or not you have read the notification:</td>
</tr>
<tr>
<td></td>
<td>▪ Unread notifications:</td>
</tr>
<tr>
<td></td>
<td>– Unread notification</td>
</tr>
<tr>
<td></td>
<td>– High importance unread notification</td>
</tr>
<tr>
<td></td>
<td>– Low importance unread notification.</td>
</tr>
<tr>
<td></td>
<td>▪ Read notifications:</td>
</tr>
<tr>
<td></td>
<td>– Read notification</td>
</tr>
<tr>
<td></td>
<td>– High importance read notification</td>
</tr>
<tr>
<td></td>
<td>– Low importance read notification</td>
</tr>
<tr>
<td>Subject</td>
<td>A link that you can click.</td>
</tr>
<tr>
<td></td>
<td>The title of the notification.</td>
</tr>
<tr>
<td></td>
<td>Click this link to view and read the notification in the notification palette.</td>
</tr>
<tr>
<td>object icon</td>
<td>Icon for the object type related to the notification.</td>
</tr>
<tr>
<td></td>
<td>Place your cursor over the icon to see the object name in the tool tip, for example, ECR or Audit.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Click this column header to sort the notification table by object type.</td>
</tr>
<tr>
<td>Regarding</td>
<td>A link that you can click.</td>
</tr>
<tr>
<td></td>
<td>The object for which the notification was sent, for example, a specific Discussion or ECR.</td>
</tr>
<tr>
<td></td>
<td>Click this link to open the object in the content pane.</td>
</tr>
<tr>
<td></td>
<td>Or, use the Quick View feature to view the object:</td>
</tr>
<tr>
<td></td>
<td>▪ Place your cursor over the link.</td>
</tr>
<tr>
<td></td>
<td>▪ When the <strong>Quick View</strong> bubble appears, click <strong>Quick View</strong> to open the object in the Quick View palette, a separate pop-up window.</td>
</tr>
<tr>
<td></td>
<td>The Notifications table remains visible and accessible behind the Quick View palette.</td>
</tr>
<tr>
<td>Received</td>
<td>The date the notification was received.</td>
</tr>
<tr>
<td></td>
<td><strong>Note</strong> Click this column header to sort the notification table by date.</td>
</tr>
</tbody>
</table>
**PPM Notifications**

Within Product Portfolio Management, default notifications are triggered and sent to appropriate recipients when you perform various actions on a project object. For example, a notification can inform you of schedule or status changes, an activity assigned to you, or a project that needs your approval, based on your role.

Event-based notifications can also be configured in Java Client as per your requirement. Such notifications can be triggered by event-based subscriptions.

For detailed information on event-based notifications, configuring notifications, and creating custom notifications, see the *Agile PLM Administrator Guide*.

**Note**  Notifications are generated only when enabled in Java Client.

Default PPM notifications are related to any of the following:
- Ownership, Assignment or Delegation
- Schedule Change
- Cost
- Workflow
- Discussions
- Subscriptions
- Setup

**Cost Impact Notifications**

<table>
<thead>
<tr>
<th>Project Object</th>
<th>Notification</th>
<th>Received By</th>
<th>When...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td>Task Overbudget Notification</td>
<td>Task Owner</td>
<td>The cost of executing a task exceeds the budget allocation for it.</td>
</tr>
<tr>
<td></td>
<td>Actual Time exceeds Budgeted time to Object Owner Notification</td>
<td>Project owner</td>
<td>Resource(s) allocated to a task have exceeded the budgeted time to complete the task.</td>
</tr>
<tr>
<td>Resource Pool</td>
<td>Actual Time exceeds Budgeted time to Pool Owner Notification</td>
<td>Resource Pool Owner</td>
<td>Resource(s) from the recipient's resource pool have exceeded the budgeted time to complete the allocated task.</td>
</tr>
</tbody>
</table>

**Discussion-related Notifications**

<table>
<thead>
<tr>
<th>Notification</th>
<th>Received By</th>
<th>When...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Discussion Action Item Assignment Notification</td>
<td>Discussion participant/program</td>
<td>An action item associated with a discussion is assigned to the recipient.</td>
</tr>
</tbody>
</table>
### Discussion Create Notification

Any user added to the Notify list during discussion creation.

A new discussion object is created successfully.

---

### Discussion Send

Discussion participant/program resource

A discussion is sent to the recipient.

---

### Reply Create Notification

Discussion participants

A user replies to a message within a discussion thread.

---

### Reply Update Notification

Discussion participants

A user updates a reply message within a discussion thread.

---

### Other Notifications

#### Relationship Promotion Failure Notification

Program Owner

Automatic promotion of a project status fails for any reason, for example, the non-completion of a required field.

---

#### Relationship Notifications > Subscription Notification

Notification subscriber

Field tags within a subscription notification is changed or updated.

---

### Ownership, Assignment, or Delegation Notifications

The following notifications are related to ownership, assignment, or delegation of a project object.

<table>
<thead>
<tr>
<th>Project Object</th>
<th>Notification</th>
<th>Received By</th>
<th>When...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td>Project Object Delegation Notification</td>
<td>Delegated user.</td>
<td>A Project activity is delegated to the recipient.</td>
</tr>
<tr>
<td></td>
<td>Action Item Assignment Notification</td>
<td>Assigned user.</td>
<td>An action item is assigned to the recipient.</td>
</tr>
<tr>
<td></td>
<td>Project Owner Assignment Notification</td>
<td>Project owner.</td>
<td>The recipient creates a project from a template or is assigned ownership of a project during project creation from a template.</td>
</tr>
<tr>
<td></td>
<td>Assignment of an activity to a resource.</td>
<td>Assigned user.</td>
<td>An activity is assigned to the recipient.</td>
</tr>
<tr>
<td></td>
<td>Accept activity assignment</td>
<td>Project Owner</td>
<td>The assigned resource accepts the activity assignment.</td>
</tr>
</tbody>
</table>
## Chapter 2: Understanding the Interface

<table>
<thead>
<tr>
<th>Project Object</th>
<th>Notification</th>
<th>Received By</th>
<th>When...</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Reject activity assignment</td>
<td>Project Owner</td>
<td>The assigned resource rejects the activity assignment</td>
</tr>
<tr>
<td></td>
<td>Project Object Delegation Accept Notification</td>
<td>Project Owner</td>
<td>A resource accepts an activity delegation.</td>
</tr>
<tr>
<td></td>
<td>Project Object Delegation Reject Notification</td>
<td>Project Owner</td>
<td>A resource declines an activity delegation.</td>
</tr>
<tr>
<td></td>
<td>Notification for Project Object Delegation</td>
<td>Delegated user.</td>
<td>A project activity is delegated to the recipient and needs to be accepted or rejected from the My Assignments tab.</td>
</tr>
<tr>
<td>Resource Pool</td>
<td>Pool Owner Project Delegation Notification</td>
<td>Resource Pool Owner</td>
<td>An activity (with or without child activities) is delegated to a resource pool.</td>
</tr>
<tr>
<td></td>
<td>Notification for Activity Assignment to a Resource</td>
<td>Resource Pool Member</td>
<td>An activity is assigned to the recipient.</td>
</tr>
<tr>
<td></td>
<td>Pool Owner Project Delegation Request</td>
<td>Resource Pool Owner</td>
<td>A child activity of a template project is delegated to the recipient's resource pool and needs to be accepted or rejected from the My Assignments tab.</td>
</tr>
<tr>
<td></td>
<td>Pool Owner Project Delegation Accept Notification</td>
<td>Project Owner</td>
<td>A resource pool owner accepts an activity assignment.</td>
</tr>
<tr>
<td></td>
<td>Pool Owner Project Delegation Reject Notification</td>
<td>Project Owner</td>
<td>A resource pool owner rejects an activity assignment.</td>
</tr>
<tr>
<td></td>
<td>Notification to Resource pool owner- Assignment of Activity</td>
<td>Resource Pool Owner</td>
<td>An activity is assigned to a resource in the recipient's resource pool. For proposed projects, this can be controlled using a SmartRule.</td>
</tr>
<tr>
<td>Gate</td>
<td>Gate Action Item Assignment Notification</td>
<td>Assigned user</td>
<td>An action item associated with a project gate is assigned to the recipient.</td>
</tr>
</tbody>
</table>
### Project Object Notification

<table>
<thead>
<tr>
<th>Project Object</th>
<th>Notification</th>
<th>Received By</th>
<th>When...</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Gate Object Delegation</td>
<td>Delegated user</td>
<td>A project gate is delegated to the recipient.</td>
</tr>
<tr>
<td></td>
<td>Gate Object Delegation Accept Notification</td>
<td>Gate Owner</td>
<td>A user accepts a gate object delegation.</td>
</tr>
<tr>
<td></td>
<td>Gate Object Delegation Reject Notification</td>
<td>Gate Owner</td>
<td>A user rejects a gate object delegation.</td>
</tr>
<tr>
<td></td>
<td>Notification for Gate Object Delegation</td>
<td>Delegated user</td>
<td>A program gate is delegated to the recipient and needs to be accepted or rejected from the My Assignments tab.</td>
</tr>
</tbody>
</table>

### Schedule Change Notifications

<table>
<thead>
<tr>
<th>Project Object</th>
<th>Notification</th>
<th>Received By</th>
<th>When...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td>Parent Project Schedule Change Notification</td>
<td>Parent Program Owner</td>
<td>The scheduled date of a parent activity is changed. Applies only when one or more baselines are created for the tree.</td>
</tr>
<tr>
<td></td>
<td>Predecessor Project Schedule Change Notification</td>
<td>Successor Program Owner</td>
<td>The scheduled dates of a predecessor activity are changed, resulting in changes to the scheduled dates of the successor activity.</td>
</tr>
<tr>
<td></td>
<td>Microsoft Project Sync Change Notification</td>
<td>Program Owner</td>
<td>Changes made to a PPM project from Microsoft Project are synchronized, resulting in schedule date changes. Applies only when one or more baselines are created for the tree.</td>
</tr>
<tr>
<td></td>
<td>Child Activity Reschedule Notification</td>
<td>Activity Owner</td>
<td>The scheduled date of a child activity is changed as a result of changes to the scheduled date of the parent activity. Applies only when one or more baselines are created for the tree.</td>
</tr>
<tr>
<td></td>
<td>Notification to Activity Owner for Project Schedule Date Change due to addition of Predecessor</td>
<td>Activity Owner</td>
<td>The Schedule Date of an activity has changed because it is now dependent upon a preceding activity.</td>
</tr>
</tbody>
</table>
### Setup-related Notifications

<table>
<thead>
<tr>
<th>Notification</th>
<th>Received By</th>
<th>When…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Project Creation Notification</td>
<td>Project Creator</td>
<td>Project creation is run as a background process and a new project is created successfully.</td>
</tr>
<tr>
<td>Activity Send</td>
<td>Any user.</td>
<td>An activity is sent to the recipient.</td>
</tr>
<tr>
<td>User Disabled Notification</td>
<td>Resource Pool Owner</td>
<td>A user who was assigned as a resource to an activity from the recipient’s resource pool has been disabled by the system.</td>
</tr>
</tbody>
</table>

### Workflow-related Notifications

<table>
<thead>
<tr>
<th>Project Object</th>
<th>Notification</th>
<th>Received By</th>
<th>When…</th>
</tr>
</thead>
<tbody>
<tr>
<td>Activity</td>
<td>Project Status Promotion, Observers/Notifiers</td>
<td>Designated observers or users on the Notify list.</td>
<td>There is a change in activity status.</td>
</tr>
<tr>
<td></td>
<td>Project Status Promotion, Approvers</td>
<td>Designated approvers.</td>
<td>There is a change in activity status that requires approval.</td>
</tr>
<tr>
<td></td>
<td>Approve Project, Notifiers</td>
<td>All users on the Notify list for the activity.</td>
<td>The activity has been approved to move forward in the workflow.</td>
</tr>
<tr>
<td></td>
<td>Project Approve Activity, Add Approver</td>
<td>Designated approver.</td>
<td>The recipient is added as an approver for a project or activity.</td>
</tr>
<tr>
<td></td>
<td>Project Approve Activity, Add Observer</td>
<td>Designated observer.</td>
<td>The recipient is added as an observer for a project or activity.</td>
</tr>
<tr>
<td></td>
<td>Project Approve Activity, Remove Approver</td>
<td>Designated Project Approver</td>
<td>The recipient is removed from the list of approvers for a project or activity.</td>
</tr>
<tr>
<td></td>
<td>Project Activity Comment</td>
<td>Program Owner</td>
<td>A user has added a comment to an activity.</td>
</tr>
<tr>
<td>Project Object</td>
<td>Notification</td>
<td>Received By</td>
<td>When...</td>
</tr>
<tr>
<td>----------------</td>
<td>--------------</td>
<td>-------------</td>
<td>---------</td>
</tr>
<tr>
<td></td>
<td>Project Activity Promotion Failure, Reject</td>
<td>Program Owner</td>
<td>A required approver rejects a project status promotion request.</td>
</tr>
<tr>
<td></td>
<td>Project Activity Promotion, Approve</td>
<td>Program Owner</td>
<td>A required approver approves a project status promotion request.</td>
</tr>
<tr>
<td>Gate</td>
<td>Gate Status Promotion Observers/Notifiers</td>
<td>Designated Gate Observers</td>
<td>There is a change in gate status.</td>
</tr>
<tr>
<td></td>
<td>Gate Status Promotion; Approvers</td>
<td>Project/Gate Approvers</td>
<td>There is a change in gate status that requires approval.</td>
</tr>
<tr>
<td></td>
<td>Project Approve Gate; Add Approver</td>
<td>Designated Gate Approver</td>
<td>The recipient is added as an approver for a gate.</td>
</tr>
<tr>
<td></td>
<td>Project Approve Gate; Add Observer</td>
<td>Designated Gate Observer</td>
<td>The recipient is added as an observer for a gate.</td>
</tr>
<tr>
<td></td>
<td>Project Approver Gate; Remove Approver</td>
<td>Designated Gate Approver</td>
<td>The recipient is removed from the list of approvers for a gate.</td>
</tr>
<tr>
<td></td>
<td>Project Gate Comment</td>
<td>Program Owner</td>
<td>A user adds a comment to a project gate.</td>
</tr>
<tr>
<td></td>
<td>Project Gate Promotion Failure, Reject</td>
<td>Program Owner</td>
<td>A required approver rejects a gate status promotion request.</td>
</tr>
<tr>
<td></td>
<td>Project Gate Promotion, Approve</td>
<td>Program Owner</td>
<td>A required approver approves a gate status promotion request.</td>
</tr>
</tbody>
</table>

**Workflow Routings Tab**

The Home page Workflow Routings tab lists routable objects that require your attention. For example, your Workflow Routings table may contain tasks that you can choose to accept.

The workflow routings are a combination of base classes and actions that define the kind of attention on the routed object. In PPM, the routable objects are Activities or Gates in the Project Class.

The workflow routings tab consists of routable objects that require your:

- Approval
Acceptance or Rejection

Review

Action

This tab includes features that allow you to review your routing objects quickly and efficiently. For detailed information on Workflow Routing tab, see the Getting Started with Agile PLM guide.

My Assignments

The Home page My Assignments tab lists Activities and Action Items for which you are responsible. The My Assignments tab provides a set of tools that allow you to efficiently work with your assignments. You can sort the assignments table rows, or select one or more assignment rows in the table, and then perform an action on the selected assignments. For example, you can accept or decline a project activity assignment, or flag an assignment for easier tracking.

The Home page My Assignments tab table includes:

- Activity objects where:
  - The activity is In Process. The workflow status type is not Complete or Canceled.
  - The activity’s Project State attribute is set to Active. Proposed or Template activities are not included.
  - You are the owner of the activity and the Delegated Owner field is blank. If you have delegated ownership, the Delegated Owner field contains the name of the delegated owner until the activity is accepted or declined.
  - You are the delegated owner of the activity.
  - You are a resource on the Team tab of the activity and your allocation is greater than 0%.

- Action Items where:
  - The action item is assigned to you and it is not Complete or Cancelled.
  - The action item is assigned to you and it has been accepted.
  - The action item is assigned to you and it has not been declined.
  - You are the creator of the action item and it has been declined by the assignee.

Project Assignments

Projects that display in your My Assignments tab are:

- Active root-level projects that have no child objects, for which you are the owner.
- Leaf-level projects for which you are the owner.
- Projects that you have delegated to a resource from the Actions > Delegate menu.

Note The project is displayed till the assigned resource accepts the action item. Once the resource accepts the action item, it disappears from your My Assignments list and you receive a notification in the Notifications tab.
**My Assignments Table**

Your Agile administrator determines which columns appear in the My Assignments table. You can, however, rearrange or filter the defined columns as you wish, using the Personalize option. If you have questions about the My Assignments tab, contact your Agile administrator.

By default, the My Assignments tab includes the following columns:

<table>
<thead>
<tr>
<th>Column name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flag</td>
<td>Flag icon which you can set to manage your assignments. For more information, see <a href="#">Flagging Assignments</a> on page 107.</td>
</tr>
<tr>
<td>Activity Status</td>
<td>The current status of the activity. For example, if you have not yet accepted the assignment, a Pending Acceptance icon is displayed here.</td>
</tr>
<tr>
<td>Name</td>
<td>The name of the activity or action item. Click this link to open the activity or action item.</td>
</tr>
<tr>
<td>Status</td>
<td>Workflow status of the activity or action item. For example, an activity can be Not Started or In Process and an action item can be Not Accepted, Accepted, or In Progress. If you have the appropriate privileges, you can edit the Status column. For more information, see Editing Assignments on page 106.</td>
</tr>
<tr>
<td>Due Date</td>
<td>The date the activity or action item is due. You can sort the assignment list by due dates. For more information, see Using the View Options to Sort your Assignment List on page 32. If you have the appropriate privileges, you can edit the Due Date column. For more information, see Editing Assignments on page 106.</td>
</tr>
<tr>
<td>% Complete</td>
<td>For activities, the percentage of the task that has been completed. If you have the appropriate privileges, you can edit the % Complete column. For more information, see Editing Assignments on page 106.</td>
</tr>
<tr>
<td>Related To</td>
<td>For activities, the Related To column lists the parent activity and root parent activity. For action items, the Related To column lists the activity or discussion object to which the action item is associated. Click the links in this column to open the related activities or discussions.</td>
</tr>
<tr>
<td>Actual Hours</td>
<td>For activities, the number of hours expended on the activity. If you have the appropriate privileges, you can edit the Actual Hours column. For more information, see Editing Assignments on page 106.</td>
</tr>
</tbody>
</table>
## My Assignments Tab Tools

The *My Assignments* tab tools include:

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Views</td>
<td>Select a view from the drop-down list. Use the list to sort your assignments by pre-defined views, for example, pending requests, flagged assignments, due dates, action items, or activities where you are a resource. For more information, see <a href="#">Using the View Options to Sort your Assignment List</a> on page 32.</td>
</tr>
<tr>
<td>Print</td>
<td>Prints the table. Allows you to print the assignment table in the currently displayed sort order. For more information, see <a href="#">Printing the Assignment Table</a> on page 34.</td>
</tr>
<tr>
<td>Accept</td>
<td>Accept the selected activities, project activity assignments, or action items. For activities, accept the ownership when you are the designated owner. For project activity assignments, accept the assignment as a resource for the activity. For action items, accept the action item when you are the assignee and the action item has not yet been accepted. For more information, see <a href="#">Accepting Assignments</a> on page 105.</td>
</tr>
<tr>
<td>Decline</td>
<td>Decline the selected activities, project activity assignments, or action items. For activities, decline the ownership when you are the designated owner. For project activity assignments, decline the assignment as a resource for the activity. For action items, decline the action item when you are the assignee and the action item has not yet been accepted. For more information, see <a href="#">Declining Assignments</a> on page 105.</td>
</tr>
<tr>
<td>Mark Complete</td>
<td>Mark as complete the selected activities or action items. For activities, sets the Complete field to 100% and changes the workflow status to Complete. For action items, changes their status to complete and removes them from your assignment list. For more information, see <a href="#">Mark Assignments Complete</a> on page 106.</td>
</tr>
<tr>
<td>More &gt; Add to Flagged View</td>
<td>Sets the flag for all the selected table rows. Allows you to flag multiple rows at one time. To display flagged rows, in the View drop-down list, choose <em>Flagged</em>. For more information, see <a href="#">Flagging Assignments</a> on page 107.</td>
</tr>
<tr>
<td>Tool</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>More &gt; Add to Hidden Assignments View</td>
<td>Allows you to hide assignments. Hidden assignments do not appear in the assignments table. For more information, see <em>Hiding and Unhiding Assignments</em> on page 33.</td>
</tr>
<tr>
<td>More &gt; Remove From View</td>
<td>Remove assignments from the Hidden view. When displaying the hidden assignment view, this menu allows you to remove (unhide) the selected assignment rows. See also <em>Hiding and Unhiding Assignments</em> on page 33 and <em>Flagging Assignments</em> on page 107.</td>
</tr>
<tr>
<td>More &gt; Fill-down</td>
<td>Copy the value from a cell to the corresponding cells in all rows following the selection.</td>
</tr>
<tr>
<td>More &gt; Fill-down(selected cells)</td>
<td>Copy the value from a cell to all the selected cells. The value of the first cell in the selection is copied into all the selected cells.</td>
</tr>
<tr>
<td>More &gt; Fill-up</td>
<td>Copy the value from a cell to the corresponding cells in all rows preceding the selection.</td>
</tr>
<tr>
<td>More &gt; Fill-up(selected cells)</td>
<td>Copy the value from a cell to all the selected cells. The value of the last cell in the selection is copied into all the selected cells.</td>
</tr>
<tr>
<td>🔄 Flag not set</td>
<td>Flag icon appears in each row of the assignment table. Set or unset the flag by clicking it. The flag helps you to organize your assignments and mark the ones you want to track. For more information, see <em>Flagging Assignments</em> on page 107.</td>
</tr>
<tr>
<td>🔄 Flag set</td>
<td></td>
</tr>
<tr>
<td>Quick View</td>
<td>The Quick View callout appears when you place the mouse cursor over the name of the activity. Click on this callout to open a pop-up window that displays important details about the object and allows you to edit, accept, or decline the object. The content of this window can be configured in Java Client Administrator. For more information, see <em>Using the Quick View Dialog</em> on page 34.</td>
</tr>
</tbody>
</table>

**Using the View Options to Sort your Assignment List**

Use the Home page *My Assignments* tab *Views* drop-down list to sort your assignments and quickly find the assignments with which you want to work. For example, you can sort for pending requests or for overdue assignments.

Agile PLM provides the following pre-defined view categories.

<table>
<thead>
<tr>
<th>View</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Base View*</td>
<td>Displays all assignments, except hidden assignments.</td>
</tr>
</tbody>
</table>
### Creating Personalized Views

The **Personalize** button allows you to create customized views of the content that is displayed in page tables. Once you create views, these are listed as options for your selection in the **Views** drop-down list. For details on using the Personalize options, see the *Getting Started with Agile PLM* guide.

### Hiding and Unhiding Assignments

On the **My Assignments** tab of the Home page, the **More > Add to Hidden Assignments View** command allows you to hide assignment rows that you do not want to see. The assignments are still part of your assignment list, but they are displayed only when you choose **Hidden Assignments** in the **Views** drop-down list.

Hiding assignments can be a useful assignment management tool. For example, suppose you are assigned as a resource for an activity, but you are not the activity owner. You have completed your portion of the task, but other resources have not yet completed their portions of the task. Therefore, the assignment still appears on your **My Assignments** tab because it has not been marked as Complete. You can hide this assignment so it no longer appears on your assignments list. However, it will still appear on the assignment lists of other resources.

Hiding an assignment removes it from all your **My Assignments** tab views except your **Hidden Assignments** view. Your **Hidden Assignments** view has no effect on the assignment lists of other users. You can hide assignments (add them to your hidden view), display your hidden assignments, and
unhide hidden assignments (remove them from your hidden view).

**To add assignment rows to your Hidden View:**
1. Click the **Home** button 🏡 to display the Home page.
2. Click the **My Assignments** tab to display your list of assignments.
   - If desired, use the **Views** drop-down list or the filter to sort which assignment rows are displayed.
3. Select one or more rows in the table.
4. Choose **More > Add to Hidden Assignments View**.

**To view your hidden assignments:**
1. Click the **My Assignments** tab to display your list of assignments.
2. In the **Views** drop-down list, choose **Hidden Assignments**.

**To remove assignment rows from your Hidden View:**
1. Click the **My Assignments** tab to display your list of assignments.
2. In the **Views** drop-down list, choose **Hidden Assignments**.
3. In the hidden assignments view, select the rows you want.
4. Choose **More > Remove from View**.

**Printing the Assignment Table**

You can use the **Print** function in the **My Assignments** tab of the Home page to print the currently displayed assignments table. Use the **View** drop-down list or the Filter to sort the table; then print the displayed table rows.

**To print the My Assignment table:**
1. Click the **Home** button 🏡 to display the Home page.
2. Click the **My Assignments** tab to display your list of assignments.
3. Use the **Views** drop-down list to sort the table to display the assignments you want.
4. Click the **Print** button.
   - A printable version of the table is displayed in a new browser window and the Print dialog appears.
5. Click **Print** in the Print dialog.
6. Close the new browser window when you are finished.

**Using the Quick View Dialog**

On the Home page **My Assignments** tab, the **Quick View** tool tip (appears when you place the mouse cursor over the name of activity objects) opens a details dialog that displays additional information about the object and allows you to perform actions on that object, for example, edit and bookmark. Your Agile administrator determines which attributes and actions are available in the details dialog of each object type.
Chapter 2: Understanding the Interface

Note To configure Quick View dialog in PPM, refer the section, UI Configuration Data.

Timesheet

The Timesheet feature helps Agile PPM customers address critical business needs, such as the accurate calculation of resource time and associated labor costs for a project. This feature helps authorized users to do the following:

- Record the number of hours worked against each assigned task, on a daily or weekly basis.
- View and administer all timesheets recorded in the system.
- Derive resource time data for reports and analysis.

Note Timesheet entry and management is restricted by certain role, privilege, and SmartRule settings in Java Client. For details, see the Agile PLM Administrator Guide.

Timesheet Tab Tools

<table>
<thead>
<tr>
<th>Tool</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>More &gt; Print</td>
<td>Prints the selected timesheets. Click More &gt; Print to print the timesheet.</td>
</tr>
<tr>
<td>More &gt; Timesheet Search</td>
<td>Allows users with appropriate privileges to search and view all timesheets recorded in the system. Click More &gt; Timesheet Search to search for timesheets. For more information, see Searching for Timesheets on page 93</td>
</tr>
<tr>
<td>More &gt; Fill-down</td>
<td>Copy the value from a cell to the corresponding cells in all rows following the selection.</td>
</tr>
<tr>
<td>More &gt; Fill-down(selected cells)</td>
<td>Copy the value from a cell to all the selected cells. The value of the first cell in the selection is copied into all the selected cells.</td>
</tr>
<tr>
<td>More &gt; Fill-up</td>
<td>Copy the value from a cell to the corresponding cells in all rows preceding the selection.</td>
</tr>
<tr>
<td>More &gt; Fill-up(selected cells)</td>
<td>Copy the value from a cell to all the selected cells. The value of the last cell in the selection is copied into all the selected cells.</td>
</tr>
<tr>
<td>Views</td>
<td>Allows you to select from a list of defined timesheet views. You can create views using the Personalize options.</td>
</tr>
<tr>
<td>Personalize</td>
<td>Click Personalize to set the Table filters. You can configure the timesheet display to show selected attributes such as the associated activity's Name, Number (manually created or auto-generated activity number), Description, Parent, Parent Number, or Root Parent. If you have privilege to view timesheets of other users, you can create a View to configure and view other users' time sheets. This filter works the same as in My Assignments. For detailed information about using the filter, see the Getting Started with Agile PLM guide.</td>
</tr>
</tbody>
</table>
Project Page

The project page opens when you click on any project object. From this page, you can record and update information such as schedule, cost, status, resources, content, and discussions about the project.

From the project page, you can:

- View details of a project—see Viewing Project Details on page 36
- View project summary—see Viewing Project Summary on page 37
- View the project as a Gantt Chart—see Launching Gantt on page 49
- Lock or unlock projects—see Multiple Users Editing the Same Task on page 77
- Change the status of a project—see Changing Workflow Status on page 108
- View the project tree—Click the Navigator button to show the project tree instead of the folder structure, in the left pane.
- Perform various actions on a project—see Actions Menu on page 45
- Personalize table views—see Creating Personalized Views on page 33 and Personalizing Views for Content on page 68

Viewing Project Details

The Details View is displayed by default if you click on a project object that is at the lowest level in the hierarchy (no sub-activities). If you click on an object that has sub-activities, it opens in the Summary view. The Summary view is not available for objects without sub-activities. While viewing a project, you can click the Details View or Summary buttons to toggle between the two views.

You can view and manage project-related objects from the following tabs or pages within the Details View.

<table>
<thead>
<tr>
<th>Tab</th>
<th>Tasks</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Info</td>
<td>View and edit general information about the project, including activities, status, and other attributes configured in Administration. See Viewing General Information on page 40.</td>
</tr>
<tr>
<td>Schedule</td>
<td>Manage the schedule of individual activities within the project, create baselines, and analyze the impact of changes. See Managing Schedules on page 93.</td>
</tr>
<tr>
<td>Dependencies</td>
<td>Create and manage dependencies between various project-related activities. See Creating and Editing Dependencies on page 94.</td>
</tr>
<tr>
<td>Team</td>
<td>Manage resources for a project. See Managing Resources on page 82.</td>
</tr>
<tr>
<td>Content</td>
<td>View and manage all project-related content, including deliverables. See Managing Content on page 65.</td>
</tr>
<tr>
<td>Workflow</td>
<td>View workflows and sign-offs, and assign approvers, observers, and notifiers as necessary. See Managing Workflows.</td>
</tr>
<tr>
<td>Tab</td>
<td>Tasks</td>
</tr>
<tr>
<td>------------</td>
<td>----------------------------------------------------------------------</td>
</tr>
<tr>
<td>Collaboration</td>
<td>Create or join project-related discussions, view action items, share news and information. See Managing Discussions on page 99.</td>
</tr>
<tr>
<td>Attachments</td>
<td>View, edit, and manage attachments that are required for project execution. See Working with Attachments on page 44.</td>
</tr>
<tr>
<td>History</td>
<td>View project history. See Viewing Project History on page 45.</td>
</tr>
</tbody>
</table>

**Viewing Project Summary**

When you first open a project which has sub-activities the **Summary** view displays. (If the project you open does not have sub-activities, then the **Details** view appears.) The **Summary** view is a consolidated view of project information. Executives, task owners and project managers can use this page to quickly review current information, status, and health of a project. This view can comprise all parent-level objects (projects, phases, and tasks) that have child activities. This view is not available on leaf-level activities and gates.

The **Summary** page contains several ‘widgets’. Each widget provides users with customized information and action buttons for a specific aspect of the project, as configured by an administrator. For example, a **Project Gates** widget may provide users visibility into the status of the project gates (milestones) for that project and deliverables associated with those gates. An **Upcoming Activities and Action Items** widget may list upcoming activities and provide an **Add** button that you can use to add an action item to be performed for an activity.
To configure the **Summary** view, you need appropriate privileges. For details on privileges and summary page configuration steps, see the *Agile PLM Administrator Guide*.

### Summary Page Actions

You can perform the primary actions required on the project directly from the **Summary** view.

Most widgets contain links to the listed objects. You can use these links to navigate to the appropriate tab of the object and perform necessary actions. For example, in the Project Gates widget, you can click on the name of the Gate to modify the details.

The contents of each widget and the actions that you can perform within each are explained in the table below.
<table>
<thead>
<tr>
<th>Widget</th>
<th>Description</th>
<th>Actions Available</th>
</tr>
</thead>
</table>
| Project Summary                | A quick overview of the project. Displays data for attributes associated to project activities, as configured by an administrator. Examples of the attributes are Name, Description, Status, Scheduled Start date, and Scheduled End date | ▪ **Add image** - Insert an image file from your local drive. Click **Add** Image to browse and select an image file from your local drive. The image file is automatically resized if it exceeds the allotted space and resolution.  
▪ **Replace Image** - Replace the current image file with another.  
**Note** Image editing options are available only to root project managers, and only on the root project.  
▪ **Edit** - Edit the attribute values displayed within the widget. You must have Modify privilege to edit these values. For details, see the *Agile PLM Administrator Guide*. |
| Upcoming Activities and Action Items | Helps you keep track of immediate requirements. Lists project activities and action items that are either overdue, or will be due within a specified time frame. You can view leaf-level project objects (including gate sub-classes) that are in Not Started or In Progress states, and Open Action Items associated to the Activity being viewed and its child activities. Table columns are sortable; by default these are sorted by Due Date. | ▪ **Add Action Item** - Create a new Action Item for the activity being viewed currently. Click **Add Action Item** to open a dialog where you can create the new action item.  
▪ **Show** - Filter the list using the options within the **Show** drop-down list to display upcoming action items and activities, or items that need your immediate attention. For example, you can use the My Activities and Action Items list item to filter the list by items for which you are the assigned owner. After selecting an option, you can additionally narrow down the results by entering a number in the **due in — days** field. The default value in this field is 7 (days). |
| Recent Discussions             | Displays a list of recent, open discussions that occurred within a specified time frame. When you click on a row to select a discussion, the discussion thread displays in the bottom pane of the window as a preview. | ▪ **Add** - Create a new discussion to be associated with the current Activity. Click **Add** to open the Add Discussion wizard and enter discussion details. You can select the list of users you wish to include in the discussion and notify them.  
▪ **Join** - Join an existing discussion. Select the row of the discussion you wish to join and click **Join** to join the discussion.  
▪ **Reply** - Reply to a discussion message. Click **Reply** on the right-hand side of the selected discussion row to open a dialog where you can enter your response. You can edit the subject of the message if you want. By default, the response will be sent to all users currently included in the discussion. You can edit the **Notify List** field in the dialog to change the list of users who will receive the response. |
## Viewing General Information

The **General Info** tab contains Activity and Status information, and displays information for the fields listed in the table. Fields which contain information that is compiled or rolled up from other fields are not editable. To edit fields, click the **Edit** button. You can make changes in the editable fields, and click **Save** to save the changes, or click **Cancel** to exit without saving.

<table>
<thead>
<tr>
<th>Field</th>
<th>Contains...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Schedule</td>
<td>Information that enables you to quickly track program progress. Displays the targeted start and finish dates as well as the total duration between the targeted start and finish dates.</td>
</tr>
</tbody>
</table>
### Estimated
Information that enables you to track when overdue items will be delivered.

### Actual
Actual varies from schedule if you are ahead of or behind targeted project dates.

### Variance in Work Days
Start Variance, Finish Variance, and Duration Variance are displayed for Estimated, and Actual dates, compared with Scheduled dates. Variances can be displayed in either Work Days or Calendar Days, or both Work and Calendar days.

**Note:** Your Agile administrator determines which information is displayed in the summary table on the General Info tab.

### Number
The AutoNumber assigned to the project object.

### Activities Type
Displays whether the activity is a project, program, phase, or task.

### Owner
The project owner.

### Name
The name of the activity.

### Description
Text that describes the project. The maximum length is set by the Agile administrator.

### Root Parent
A link to the root parent object.

### Parent
A link to the parent object.

### Project State
Indicates the type: **Active**, **Proposed**, **Template**. Only an active project can undergo changes in workflow status.

### Audit Score
The audit score for the activity. See **Audit Values** on page 44.

### Weight
Weight assigned to the activity. See **Audit Values** on page 44.

### Weighted Score
A calculated score based on the audit score times the weight. See **Audit Values** on page 44.

### Status
Indicates the workflow status of the project.

### Rollup Health Status
Indicates whether the health status rollup is selected or not.

### Cost Status
Denotes the cost status for the activity. This value is a selected value for the leaf object and a rolled-up value for a parent object.

### Resource Status
Denotes the resource status for the activity. This value is a selected value for the leaf object and a rolled-up value for a parent object.

### Quality Status
Denotes the quality status for the activity. This value is a selected value for the leaf object and a rolled-up value for a parent object.

### Lock User
Name of the user who is currently using Gantt Chart or Microsoft Project to modify the project. When a user launches either Gantt Chart or Microsoft Project, the activity is automatically locked to prevent any other user from editing the project in PPM.

### Workflow
Identifies the object's assigned workflow.

### Schedule Status
The schedule status of the activity.
| **Overall Status** | An overall status of the activity. This value is calculated based on either selected or rolled up values for cost, resource, quality, and schedule. It denotes the worst of these status values (cost, resource, quality, and schedule). |
| **Project Type** | Dashboard field. May be renamed during implementation. |
| **Region** | Dashboard field. May be renamed during implementation. |
| **Division** | Dashboard field. May be renamed during implementation. |
| **Product Line** | Dashboard field. May be renamed during implementation. |
| **Customer** | Dashboard field. May be renamed during implementation. |
| **Launch Year** | Dashboard field. May be renamed during implementation. |
| **Global** | Controls whether the project is available to all executives or not. |
| **Actual Labor Cost** | The Labor cost incurred on the project as on date, based on the actual work done on the project. |
| **Budgeted Labor Cost** | The intended Labor cost for the project. |
| **Estimated Labor Cost to Completion** | The cost of Labor for the entire project which is calculated based on the change in Project cost or plan, as the project progresses. |
| **Actual Fixed Cost** | The Fixed Cost incurred on the project as on date, based on the actual work done on the project. |
| **Budgeted Fixed Cost** | The intended Fixed cost for the project. |
| **Estimated Fixed Cost to Completion** | The fixed cost for the project which is calculated based on the change in the project costing or plan as the project progresses. |
| **Actual Capital Expenses** | The capital expenses incurred on the project as on date. |
| **Budgeted Capital Expenses** | The intended capital expense limit on the project. |
| **Estimated Capital Expenses to Completion** | The estimated capital expenses for the project which varies based on any change in the fixed assets of the project. |
| **Actual Time (In Days)** | Days Effort is calculated at the rate of 8 hours per day and displayed as Actual Time (In Days). Each day is calculated as a bucket of 8 hours. For example, if actual hours worked is 24, Actual Time (In Days) is calculated as 3 days. If actual hours worked is 25, it is calculated as 4 days. |
| **Budgeted Time (In Days)** | The pre-allocated time in days for a project to reach completion. |
| **Estimated Time to Completion** | The approximate time that is required for the project to reach completion, on the basis of the progress in project. |
| **Category fields** | Fields that can be configured by the administrator. |
| **Schedule Editor** | Indicates the source of schedule editing for this project: PPM or MSP (Microsoft Project). This is automatically set to MSP when you launch a project into Microsoft Project. When set to MSP, the PPM project does not roll up dates, durations and % complete values. This ensures that when the project is published in PPM from Microsoft Project, the project dates are correct in PPM. |
| **Actual Flex Cost** | A cost field that can be configured by the administrator. Actual cost reflects the cost incurred on the project as on date. |
Budgeted Flex Cost | A cost field that can be configured by the administrator. Budgeted cost reflects the intended cost for the project.
---|---
Estimated Flex Cost to Completion | A cost field that can be configured by the administrator. Estimated cost reflects the cost that keeps varying based on any change in the project cost or plan as the project progresses.
Critical | Indicates whether the activity is on the critical path.
Total Actual Cost | Sum of all the actual costs.
Total Budgeted Cost | Sum of all the budgeted costs.
Total Estimated Cost to Completion | Sum of all the estimated costs to completion.
Created from Template | Name of the template on the basis of which this project is created.
PLM Reference | Any object that you want to add as a reference to the project. This object also appears in the Content tab of the project.
Project Keywords | Keywords that are associated to the project. You can configure the project summary page to display important content on the basis of these project keywords.

**To edit the information in the General Info tab:**
1. Click **Edit** on the General Info tab of a project object.
2. Modify the editable fields.
3. Click **Save**.

### Dates

Within Agile PPM, dates are displayed in your preferred date format, but there is no time zone conversion applied for dates such as Schedule Start Date, Schedule End Date, Actual Start Date, Actual End Date, Estimated Start Date and Estimated End Date.

Date values that you enter are stored in Greenwich Mean Time (GMT) and displayed without the time zone. For example, if you enter a date value of 10/10/2009, the system stores the date in the database as 10/10/2009 00:00:00 GMT.

**Note** Page Two, Page Three, Workflow, and History dates are displayed in user-preferred time zones.

### Duration

Objects within a project can have different duration types such as:

- **Fixed duration** — The object takes a defined period of time, for example, five days. For Fixed duration, the Days Effort is calculated as the Scheduled Duration times the sum of the % Allocation of all resources. You can also create a zero duration activity by selecting Fixed Duration and setting Zero as the Days Effort.

- **Effort driven** — The Days Effort of the object is fixed, but the number of resources assigned affects the Scheduled Duration. For Effort Driven Duration Type, the Scheduled Duration is
calculated as the Days Effort divided by the sum of % Allocation of all resources.

**Note** If a parent changes to a leaf node object (an activity with no children) then the Duration type changes from 'Calculated' to 'Fixed'. The Duration remains the same as it was when it was the parent. If the parent object had resources, Days Effort is calculated based on the percentage allocation of the Resource/Groups assigned to the Team tab. If there are no resources, the Days Effort is the same as the Scheduled Duration.

### Audit Values

The General Info tab of activities contains the following audit values:

- **Audit Score** - The value assigned to each object in a project by an auditor during an audit, based on performance indicators.
- **Weight** - A value that reflects the importance of the individual object compared to other objects, in the context of the entire project.
- **Weighted Score** - A value calculated by multiplying the values in the Weight and Audit Score fields.

### Working with Attachments

Attachments to Agile business objects contain pertinent information about the object in addition to the information recorded on the object tabs. Examples of attachment files are:

- Drawing files such as CAD drawings or scanned image files in viewable formats
- Web-based information in the form of URLs
- Project specifications and other documents
- Non-viewable files, compressed files, and so on

**Important** As a best practice, it is recommended that the attachments tab in Agile PPM activities and gates be disabled. Agile PPM provides a unique tab, the Content Tab that should be used for all project content, including attachments, for projects.

For more information on working with attachments, refer the *Getting Started with Agile PLM* guide.
Collaborating on Project Activities

The Collaboration tab enables you to manage project-related discussions, action items that result from the discussions, and news items. You can also add and view these objects in the Project Summary page.

The Collaboration tab has the following views:

- **Discussions** - Enables you to initiate, join, reply to, or remove a discussion. The Notifications tab in your Home page displays all the discussions notified to you. For further information on managing discussions, see [Managing Discussions](#) on page 99.

- **Action Items** - Enables you to manage the action items. You can add, remove, accept, or decline an action item. In addition, you can mark the action item 'Complete'. The Action Items which you add in this tab appear in the My Assignments tab of the assignee’s Home page. You can view these action items in the Upcoming Activities and Action Items widget of the Project Summary page.
  
  For further information on working with Action items, see [Viewing Action Items](#) on page 102.

- **News** - Enables you to add and remove news or announcements specific to the project. You can also add and remove news items on the Project Summary page.

Viewing History

The History tab records all actions taken, such as editing the General Info tab or changing activities or team members.

**Note**

If you do not have the appropriate read privileges, you cannot view the fields on the History tab. If you have questions about your privileges, see your Agile administrator.

Actions Menu

The Actions Menu consists of the following options in addition to the standard PLM menu commands such as Bookmark, Subscribe, Save As and Delete.

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Gantt Chart</td>
<td><a href="#">Click Gantt Chart</a> to view the Gantt Chart view of the project. For more information on working with Gantt, see <a href="#">Gantt Chart</a>.</td>
</tr>
<tr>
<td>Menu</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Delegate</td>
<td>Click <em>Delegate</em> to delegate the project to a different owner. For more information on delegating ownership, see <a href="#">Delegating Ownership</a> on page 90.</td>
</tr>
<tr>
<td>Substitute Resource</td>
<td>Click <em>Substitute Resource</em> to replace a resource in the project team. For more information on substituting resources, see <a href="#">Substituting Resources</a> on page 92.</td>
</tr>
<tr>
<td>Change Parent</td>
<td>Click <em>Change Parent</em> to modify the root parent of the project.</td>
</tr>
<tr>
<td>Make This a Root Activity</td>
<td>In the project or phase within a project, select <em>Make this a root activity</em> to start a new project. This change modifies the existing dependencies.</td>
</tr>
<tr>
<td>Compare Baselines</td>
<td>Click <em>Compare Baselines</em> to view a comparison between two project baselines. For more information, see <a href="#">Comparing Baselines</a> on page 98.</td>
</tr>
<tr>
<td>Microsoft Project</td>
<td>The entries in this menu enable you to launch the existing PPM project in Microsoft Project. In addition, you can save the existing PPM project as an XML file. For more information, see <a href="#">Working with Microsoft Project</a> on page 119.</td>
</tr>
<tr>
<td>Complete</td>
<td>Click <em>Complete</em> to modify the status of the project to 'Complete'.</td>
</tr>
<tr>
<td>Change to Canceled</td>
<td>Click <em>Change to Canceled</em> to modify the status of the Project to 'Canceled'.</td>
</tr>
<tr>
<td>Reports and Analytics</td>
<td>The entries in this menu enable you to obtain reports on <em>Project Resource Utilization</em> and <em>Schedule</em>. For more information, see <a href="#">Reports</a>.</td>
</tr>
</tbody>
</table>

**Address Book Palette**

**To search for a user group:**

1. Click ![Address Book](#) to open the address book palette.
2. Choose *User Groups* in the address book palette drop-down list.
3. Type the user group object search criteria that you want to use.
4. Click the ![Execute a Quick Search](#) button.
5. In the palette search results table, select the user group row or rows you want:
   - Double-click a row.
   - Select one or more rows and drag them to the field that you are modifying.
6. Press the Escape key to close the address book palette.

**To search for a user within a user group:**

1. Click ![Address Book](#) to open the address book palette.
2. Choose *Search within a user group* in the address book palette drop-down list.
3. In the *Select a user group to search within* popup, type the name of the user group you want or
4. When you have selected a user group, click **OK** in the popup.

**Note** Agile PLM adds the group name to the address book palette drop-down list. Agile PLM continues to add group names to the palette drop-down list until the number of groups equals twenty. As additional groups are added to the list, Agile PLM removes the oldest entries from the drop-down list. A maximum of twenty groups that you recently selected for the **Search within a user group** option remain on the drop-down list.

Alternately, you can use the address book palette drop-down list to select one of the user groups that you have selected recently.

5. Type the user object search criteria that you want to use.

6. Click the **Execute a Quick Search** button. The search is restricted to the members of the selected group.

7. In the palette search results table, select the user row or rows you want:
   - Double-click a row.
   - Select one or more rows and drag them to the field that you are modifying.

8. Press the Escape key to close the address book palette.

**Note** The **Search within a User Group** option appears in the drop down menu within the ‘New Member’ palette, only if more than two hundred user groups are available.

---

**Gantt Chart**

The Gantt Chart feature is a powerful project management tool that helps project managers plan, administer, and track projects from start to finish. With Gantt, you can create a new project and then plan the work breakdown structure for this project, which includes defining activities and tasks, creating dependencies between tasks, and performing resource management.
Overview

The Gantt Chart offers rich user-friendly features (such as Excel-like data editing) to manipulate and view data in graphical or tabular formats. Multiple view options enable you to focus on discrete project aspects, and right-click menus help you to quickly take actions on selected project objects.

The default Gantt view consists of a menu bar, standard toolbar, a tabular activity pane and a graphical activity pane. The tabular activity pane provides a hierarchical tree structure representation of all activities and the graphical pane provides a graphical representation of activities with color and iconic indicators.

Prerequisites

Make sure you have the appropriate privileges to perform project management activities within the Gantt Chart. If you have questions about your assigned roles and privileges, contact your Agile administrator.

The Gantt chart uses Java Web Start technology and requires Java Runtime Environment (JRE) to
be installed on your computer. If the recommended JRE does not exist on your system or if you have a lower version installed, you are prompted to install the latest JRE version. For information on recommended JRE, see Agile PLM 9.3 Release Notes.

**Note** If certain firewalls prevent this automatic download, you can download and install the appropriate JRE version from the URL: [http://www.sun.com](http://www.sun.com).

### Modes of Operation

The Gantt chart operates in three modes:

- **Connected** – Requested data is obtained directly from the server.
- **Disconnected** – Requested data is obtained from the installation folder. If the server is not available, Gantt switches to this mode. Once the server becomes available, it switches back to Connected mode.
- **Offline** – Requested data is retrieved from the installation folder. The server is assumed to be unavailable.

**Note** The Gantt chart opens in the mode it was set to when you last worked on it. If the Gantt Chart was set to Offline mode in your last session, it opens in Offline mode when you next try to launch a project from Web Client. This means the requested project cannot be opened as the system assumes server unavailability. Instead, a new default project is launched. To open the project you wanted, change the mode from Offline to Connected, and then launch the project again from Web Client.

### Launching Gantt

To launch the Gantt Chart for a project, open the project and select **Details View > Gantt Chart**.

If your project has sub-activities, you can also select **Actions > Gantt Chart** from the **Summary** view.

When you start the Gantt Chart, Java JAR files are downloaded into your computer's temporary files folder. Once these have been loaded, the Gantt Chart appears.

### Launching Gantt Using Shortcuts

During Gantt download, you are prompted to confirm whether you want shortcuts to the Gantt application to be installed on your Desktop and Start menu. Click **Yes** to confirm. These shortcuts are especially useful when you want to work on Gantt offline.

To launch Gantt from the Desktop, double-click the icon. To launch Gantt from the **Start** menu, choose **Programs > Oracle | Agile PLM** and select the Gantt application. Once you have saved a Gantt Chart Exchange (.gcx) file on your system, you can simply double-click on the file to launch the Gantt Chart.

### Gantt Toolbar Icons

Most actions on the Gantt chart can be performed using the icons on the toolbar or corresponding shortcut keys. When you place your mouse pointer over an icon, the shortcut key appears next to the name of the icon.
<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Shortcut Keys</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>📏</td>
<td>Cut</td>
<td>Ctrl+X</td>
<td>Cuts a selected cell value, activity or gate.</td>
</tr>
<tr>
<td>📝</td>
<td>Copy</td>
<td>Ctrl+C</td>
<td>Copies a selected cell value, activity or gate.</td>
</tr>
<tr>
<td>🧵</td>
<td>Paste</td>
<td>Ctrl+V</td>
<td>Pastes the cut or copied cell value, activity or gate.</td>
</tr>
<tr>
<td>🗂</td>
<td>Open</td>
<td>Ctrl+O</td>
<td>Open Activities or Gates.</td>
</tr>
<tr>
<td>📁</td>
<td>Save</td>
<td>Ctrl+S</td>
<td>Saves changed information in the Gantt.</td>
</tr>
<tr>
<td>📘</td>
<td>Activity</td>
<td>Insert</td>
<td>Inserts an activity below the selected activity, at the same indent level.</td>
</tr>
<tr>
<td>🍀</td>
<td>Gate</td>
<td>Alt+G</td>
<td>Inserts a gate below the selected activity, at the same indent level.</td>
</tr>
<tr>
<td>❌</td>
<td>Delete</td>
<td>Delete</td>
<td>Deletes the selected item from the Gantt Chart.</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td>To select an activity for deletion, highlight or select the whole row.</td>
</tr>
<tr>
<td>📄</td>
<td>Create Dependency</td>
<td>Alt+C</td>
<td>Adds a dependency.</td>
</tr>
<tr>
<td>📂</td>
<td>Edit Dependency</td>
<td>Alt+D</td>
<td>Opens the Edit Dependency dialog for the selected dependency.</td>
</tr>
<tr>
<td>📇</td>
<td>Go To Selected Task</td>
<td>Ctrl+G</td>
<td>Brings the corresponding graphic into view.</td>
</tr>
<tr>
<td>🔖</td>
<td>Outdent or Move Left</td>
<td>Alt+Shift+Left</td>
<td>Outdents an item, so that a project element no longer reports to the higher-level element. Moves the selected item or items to the left.</td>
</tr>
<tr>
<td>📆</td>
<td>Indent or Move Right</td>
<td>Alt+Shift+Right</td>
<td>Indents an item, making a project element report to another item. Moves the selected item or items to the right.</td>
</tr>
<tr>
<td>🔧</td>
<td>Move Up</td>
<td>Alt+Shift+Up</td>
<td>Moves an item up to change the order of the listed items at the same level. If project elements report to that item, these move along with it.</td>
</tr>
<tr>
<td>🔧</td>
<td>Move Down</td>
<td>Alt+Shift+Down</td>
<td>Moves an item down to change the order of the listed items at the same level. If project elements report to the item, these move along with it.</td>
</tr>
<tr>
<td>📃</td>
<td>Expand All</td>
<td>Ctrl+E</td>
<td>Expands the Project tree structure to view all</td>
</tr>
</tbody>
</table>
Chapter 2: Understanding the Interface

<table>
<thead>
<tr>
<th>Icon</th>
<th>Name</th>
<th>Shortcut Keys</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![Icon]</td>
<td>Collapse All</td>
<td>Ctrl+Q</td>
<td>Collapses the Project tree structure to hide all activities in the tree.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Zoom In</td>
<td>Ctrl+Plus (NumPad)</td>
<td>Enlarges the graphical pane view.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Zoom Out</td>
<td>Ctrl+Minus</td>
<td>Reduces the graphical pane view.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Zoom To Fit</td>
<td>Ctrl+0</td>
<td>Changes the size of the graphical pane to show the entire project within the visible area.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Manage Resources</td>
<td>Alt+F10</td>
<td>Allows you to select and manage resources for the selected activities.</td>
</tr>
<tr>
<td>![Icon]</td>
<td>Delegate Owner</td>
<td>Alt+F12</td>
<td>Allows you to delegate the ownership of the selected activities.</td>
</tr>
</tbody>
</table>

**Views in Gantt**

Gantt supports the following views:

- Gantt
- Task Assignment
- Calendar
- Critical Path
- Comparative Gantt
- Resource
- Resource Sheet
- Resource Utilization

**Gantt**

The Gantt view is the default view. This view displays the project activities and schedules in a combination pane. One pane displays a tabular view of activities in a hierarchical tree structure. The other displays a graphical view of activities in a bar graph format.

**Task Assignment**

The Task Assignment view is a combination view of the Gantt Chart in the top pane and the Manage Resources sheet and Resource Utilization chart in the bottom pane. When you select an activity in the Gantt view, resource information about the task appears in the Manage Resource view. You can simultaneously view the resource utilization of each resource in a graph format in the Resource Utilization pane.
Calendar

The Calendar view allows you to create, edit, and review your project tasks in a calendar format. The Calendar view consists of two tabs, Month and Day. The Month tab displays a monthly view with all the days in the month. The Day tab displays a day view with all the hours in the day.

The Calendar view is helpful to view tasks that are scheduled on a particular day, week or month. It shows tasks schedules for a specific week or range of weeks. You can create a project by entering a task and the duration of a project using the calendar format.

Critical Path

Critical path view helps you plan all activities that directly affect the completion date of a project. Critical Path is determined by identifying all the activities that have slack, below a pre-determined number of days.

Critical path activities act as the basis for creating a schedule and planning resource allocation. It helps you analyze where a remedial action is required to get a project back on track. Critical path can be viewed at activity and sub-activity level. The critical task is the current activity on the critical path.

Note If a schedule is on a critical path, the schedule bar on the graphical pane appears red.

Comparative Gantt

The Comparative Gantt view helps you compare the current project schedule against estimated or actual schedules, or against a saved baseline. To view a comparison, select an option from the drop-down list in the main toolbar. The default comparison value is Estimated. All saved baselines display in this list for selection.

In the graphical view:

- The Current schedule of a parent displays in orange.
- The Current schedule of a child activity displays in pink.
- The Estimated, Actual, or Baseline schedule of the parent activity displays in white.
- The Estimated, Actual, or Baseline schedule of selected child activities displays in gray.

In the tabular view, you can view baseline schedule information (start and end dates) in columns alongside current schedule information.

Resource

The Resource view displays a list of all users for a particular project and their task allocation as per the schedule, in a calendar format. If you assign an allocation to a user, you will be able to view a bar graph in the pane below displaying the percentage of allocation. You can also select the topmost row - All Users - to view a bar graph of all resources simultaneously.
Resource Sheet

The Resource Sheet allows you to view available resources and add selected resources to your project. The Resource Sheet contains a set of users who are associated with the activities within a project. Adding resources to a Resource Sheet reduces duplication and maintenance of resources. You can access the Resource Sheet from View > Resource Sheet.

The Resource Sheet view contains fields with relevant user information such as Title, Business Phone, Email, Status, Assigned from Pool, and so on. You can review, add, or edit information on each resource. You can quickly create a resource list for your project by adding the name of each resource and their related information. A resource can be an individual, a company or department, a piece of equipment, a room, or any other resource that you are using for your project.

Note
Simultaneous updates to the Resource Sheet by different users are not supported. Updates to the resource sheet are saved independently of Gantt chart updates.

Resource Utilization

The Resource Utilization view displays all the resources and the tasks assigned to each resource. It displays the tasks and task allocations from other projects in PPM as well. You can view the following information for each resource or resource group in this table:
- Name
- Pool Name
- % Allocation
- Schedule Start
- Schedule End

To format columns in the report:
1. Choose Format > Preferences.
2. Within the Preferences dialog that opens, in the Columns tab, select the columns you want to display.
3. Use the arrow buttons to move selected column names from the Available Columns list to the Selected Columns list.
4. To rearrange the order in which the columns display, move them up or down in the list using the up and down arrows.
5. To hide or show gridlines, select the appropriate check boxes for Horizontal and Vertical.
6. Click OK to apply your changes.

Customizing the Gantt Chart

The graphical and tabular display of data within the Gantt Chart can be customized based on your preferences. You can configure the display of columns, grids, bar labels, appearance, and styles using the options in the Format menu.
The columns can be configured to display Page One attributes - the options that are made available in these fields are configured in the Java Client General Info attribute settings.

**Setting Preferences**

You can customize column display and set other preferences such as preferred file download location, as described further.

**To customize column display:**
1. Choose Format > Preferences.
2. Within the Preferences dialog that opens, in the **Columns** tab, select the columns you want to display.
3. Use the arrow buttons to move selected column names from the **Available** columns list to the **Frozen** or **Non-Frozen** columns list as desired. The Non-Frozen column displays all the visible columns in the tabular activity pane.
4. Click **OK**.

**To freeze, unfreeze, or hide one or more columns:**
1. Within the tabular view pane, select the column or columns.
2. In the right-click menu, select **Freeze Column**, **Unfreeze Column** or **Hide** as appropriate.
   - Within the **Columns** tab of the Preferences dialog, you can use the ◀ and ▶ arrow buttons to sort the order of the displayed columns. Alternatively, you can click and drag a column in the tabular view pane to change its location.

**To set preferences for offline mode:**
1. Choose Format > Preferences.
2. Within the Preferences dialog, select the **Advanced** tab.
3. In the **File Location** field, browse and select the folder to which you want your files downloaded for offline access. The default location for file downloads is your My Documents folder.
4. In the **Project Name** field, you can enter a default value for activity names. For example, if several of your projects start with the same name, say 'ABC Project V.1', 'ABC Project V.2', 'ABC Project V.3' etc., you can enter 'ABC Project' in this field so that you only need to change the rest of the name.
5. Select other options as appropriate:
   - If you select **Yes** for the **Download Page Two and Page Three** field, this information gets downloaded when you are in Online mode, and can be saved for offline activity. If you select **No**, this information is loaded only if you choose to view the properties of a selected activity.
   - If you select **Yes** in the **Display Locked Projects on Exit** field, a dialog appears when you exit Gantt, where you can view the list of projects that are locked by you. You can then choose to unlock activities that other users may need to access.
6. Click **OK** to exit the Preferences dialog.
7. In the **Format** menu, click **Save Settings** to save your preferences. The next time you log in, these settings are maintained.
Appearance and Style

To customize the appearance of your Gantt Chart, choose Format > Appearance and choose from the following themes:

- Metal
- CDE Motif
- Windows
- Windows Classic
- Kunststoff
- Office

To change the graphical view style, choose Format > Styles and choose any of the following styles:

- Agile
- Activity Completion
- Critical Path
- Custom Time Scale
- Level Coloring
- Standard

Bar Labels

You can select the text to be displayed on the bar graphs on the graphical view pane. The information is displayed in relation to the task, project or phase corresponding to the bar graph. Choose Format > Bar Labels and select an option from the following labels:

- Name
- Start Date
- End Date
- Status
- % Completed
- None

Grids

You can select from the following options to customize the display of grids and rows in your graphical view:

- Show Vertical Grid
- Vertical Grid Color
- Show Weekends
- Weekends Color
- Show Horizontal Grid
- Horizontal Grid Color
- Color Rows
- Even Row Color
- Odd Row Color

Once you have made changes to any of the format settings, select **Format > Save Settings** from the menu bar to save changes.

**Note**  The Save Settings command does not save changes to the Grid.

**View Bar**

The View Bar is a pane that is displayed on the left of the Gantt Chart and allows you easy access to view the different type of Gantt views. The Gantt view types are displayed as icons and you can click on the icon to display the view. The View Bar is enabled by default. To disable it for a particular session select **View > View Bar**.

**Note**  A check mark next to the View Bar option indicates that the view bar is enabled.

**Gantt File Menu Options**

The **File** menu in the Gantt Chart offers the following options:

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>New</strong></td>
<td>Creates a new root project with default project data.</td>
</tr>
<tr>
<td><strong>Open</strong></td>
<td>Opens a search window where you can locate and open projects from the server. You can search by Root Project, Root Template, Activities, Gates, or All Project. Available only in online mode. The search criteria you last used appears by default in the <strong>Find From</strong> field. When you search by Activities or Gates, parametric search options become available if corresponding attributes have been enabled in Java Client. Click <strong>Options</strong> to view parametric search fields and specify criteria.</td>
</tr>
<tr>
<td><strong>Open File</strong></td>
<td>Helps you search and locate a saved .gcx (Gantt Chart Exchange) file on your hard drive. If you saved a folder location as a preference in the Advanced tab of the Format &gt; Preferences dialog, this folder is opened. If the current project was opened using a .gcx file stored in a particular folder, that folder is opened.</td>
</tr>
<tr>
<td><strong>Save</strong></td>
<td>Saves the project to the server. Saved data includes: Page One, Page Two, Page Three, Schedule, Dependencies, Team, and Resources.</td>
</tr>
<tr>
<td><strong>Save File</strong></td>
<td>Saves the project to your hard drive. Saved data includes all activities, dependencies, resource sheet, activity states, and any modifications made after you last saved the project.</td>
</tr>
</tbody>
</table>
| **Save As**  | Saves the project to the server under a different name. Saved data includes: Page One, Page Two, Page Three, Schedule, Team, and Resource Sheet. Content (from the Content tab) is not saved. If you save a Completed or
Chapter 2: Understanding the Interface

<table>
<thead>
<tr>
<th>Menu Command</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Canceled project, the new project's status is set to 'Not Started'.</td>
<td></td>
</tr>
<tr>
<td>Save As File</td>
<td>Saves the project to your hard drive under a different name. Make sure you change the name of the root project so that you do not update an existing project on the server inadvertently.</td>
</tr>
<tr>
<td>Recent Files</td>
<td>Displays a list of up to 10 files that were recently opened from the hard drive.</td>
</tr>
<tr>
<td>Work Offline</td>
<td>When selected, switches the Gantt to offline mode, regardless of server availability. To return to online mode, select this option again. Connection status is displayed at the bottom right corner of the window.</td>
</tr>
</tbody>
</table>

Working Offline on Gantt

You can continue working on the Gantt chart even when you are not logged into Agile PLM. The Gantt client can be used as a standalone application on your computer. This feature enables you to do the following:

- Continue working on a project while traveling or during server downtime.
- Create a preliminary draft of a project and make it available online only when you want other users to see it.
- Email a saved project to others for opinions and updates.

The first time you launch a Gantt chart from <Web Client>, you are provided the option to save a shortcut to the Gantt chart on your desktop. Once you save the shortcut, you can use it to launch Gantt and work on it offline.

Unlocking Projects before Exiting

When you close the Gantt Chart after working on it in Offline or Disconnected mode, the projects that you opened from Gantt remain locked. To ensure that projects used by others are unlocked for their use, you are prompted to unlock projects before you exit. Within the Unlock Projects dialog that appears, select the projects that you wish to unlock for the use of others and click OK.

Toggling the View Between Gantt and Web Client

While you are working on the Gantt Chart, you can switch to the <Web Client> view if required. This option is available in all modes of the Gantt Chart and is highlighted only when at least one row from the project Tree is selected.

**To switch to the <Web Client> view of the current project:**

1. Select one or more activity rows in the Gantt chart.
2. In the Tools menu, or in the right-click menu, select Show In Browser. If you are not connected to the server, the Agile PLM login screen appears.
3. Log in to Agile. A new browser window opens for each activity row that you selected.
Printing a Gantt Chart

You can print any view of the Gantt Chart using the Print option in the File menu.

Within the Print window, or the Print Preview window, you can manually change Page Setup options if necessary. By default, the page margins are set to 0.5 inches, and the page orientation is set to Landscape.
Chapter 3

Setting Up Project Management Processes

This chapter includes the following:

- Setting up a Project Structure ................................................................. 59
- Managing Content ................................................................................. 65

Project Management process in PPM involves the following primary activities:

- Creating a Project Template
- Adding Activities and Gates
- Setting ownership to Resource Pools
- Managing Content

Setting up a Project Structure

When creating a new project, the easiest way to build the structure is to start at the top and work down. Typically, for a structured project, you need:

- Parent project object
- Child activity objects
- Designated project “gates”
- Pool of resources (project team members)

You can store project specifications and requirements documents with the parent project object, to make it easy for project members to locate them.

The general procedure is to create the root-level project first and then create the child objects.

The table below shows the general workflow to create a project structure:

<table>
<thead>
<tr>
<th>Starting “from scratch” in Agile PPM</th>
<th>Porting an Existing project from Microsoft Project</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Create the root-level project object using the method described in Creating a Project on page 73. Be sure to specify Project as the object type.</td>
<td>1. Publish the project's Microsoft Project file into Agile PPM, as described in Creating a PPM Program from an Existing Microsoft Project file on page 120.</td>
</tr>
</tbody>
</table>
## Starting “from scratch” in Agile PPM

<table>
<thead>
<tr>
<th>2. Create the first child object. Go to the <strong>Schedule</strong> tab of the new Project object, and click <strong>Add</strong>. Create the first child object. All objects created from the <strong>Schedule</strong> tab are children of the current object.</th>
</tr>
</thead>
<tbody>
<tr>
<td>3. Repeat the process to create additional child objects, as needed.</td>
</tr>
<tr>
<td>4. Open each child object and create its child objects, as needed.</td>
</tr>
<tr>
<td>5. Set Gates to delineate the completion of key project goals.</td>
</tr>
<tr>
<td>6. Set Milestones to define a target or trigger point for project metrics or communications.</td>
</tr>
<tr>
<td>6. Map existing dependencies between project objects.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Porting an Existing project from Microsoft Project</th>
</tr>
</thead>
<tbody>
<tr>
<td>2. Re-set any dependencies that were not originally entered as ‘Finish to Start’ dates.</td>
</tr>
</tbody>
</table>

Once you have the structure in place, you can use **Actions > Save As** to save it as a template for future projects.

### Note
You can also create project objects using the project Gantt Chart. For further information, see the [Gantt Chart](#).

## Creating a Project Template

Project templates provide a framework to create projects with similar components. These components include tasks, resources, and deliverables that can be similar in construct across multiple projects. Use project templates as a base to modify project content and schedule as required for various projects.

### To create a new template:

1. Launch Agile <Web Client >.
2. Click the **Create New** drop-down menu.
3. Select **Projects > New**. The **Create New** dialog appears.
4. In the Create New dialog, from the **Type** list, select **Project**. Additional fields appear.
5. Enter the **Name** of the template.
6. Enter the **Description** of the template, if required.
7. From the **Delegated Owner** palette, select the delegated owner.
8. In the **Project State** list, select **Template**.
9. Select a **Duration Type**.
10. From the **Calendar** palette, select a **Schedule Start Date**.
11. Enter the **Schedule Duration** in days. The **Schedule End Date** is an auto-populated value.

12. Click **Save**. The **General Info** tab of the new project appears. Fill in information on the various project tabs, as required.

**Identifying the Template Used to Create a Project**

If a project is created from a template, a link to the template is provided in the **Created from Template** field in the **General Info** tab of the project and its child activities. You can click on this link to open the **Template** that was used to create the **Project**.

After creating a project from a template, if you add child activities to this project, the **Created from Template** field for these activities will be blank as these are not created from the template.

- If you save an existing template as a **Proposed** or **Active** project, the **Created from Template** field shows the name of the original template.
- If you save an existing template as another template, the field is left blank.
- If you perform a **Save As** operation on any level lower than the root level, the field is left blank.

**Adding Activities**

You can add activities such as Project, Program, Phase, Task, Gate, or Milestone from Gantt Chart or Web Client.

**Add Activities using Gantt Chart**

You can add activities to a **Project** from the Gantt Chart using the **Insert Activity** options on the main toolbar or the right-click menu.

Alternately, you can use the quicker options listed below.

**To add an activity in Gantt Chart:**

1. Select the row under which you want to add an activity.
2. Press the **Insert** key on your keyboard. This inserts a new row below the row currently selected.
3. Type the name of the activity in the newly created blank row.
   - The activity created belongs to the **Task** subclass. To add an activity of a specific subclass, use the shortcut key **Ctrl+Alt+A**.
4. In the **Activity** dialog that opens, select a subclass for the activity.
5. Specify the **Start Date** and **End Date**. The **Schedule Duration** field will automatically display the number of days based on the start and end date. You can also specify the start date and enter the total number of days of your project in the **Schedule Duration** field; the end date is automatically calculated.
6. Click **OK** to add the activity.
Add Activities using Web Client

You can add activities from the Schedule tab of a Project, Program, or Phase. Navigate to the activity in which you want to add an activity.

To add an activity using Web Client:
1. Click the Schedule Tab.
2. Click Add.
3. In the Create New dialog, from the Type list, select the Type of activity.
4. In the remaining fields which appear, type the mandatory information such as Name, Owner, Schedule dates, and Duration Type as applicable.
5. Enter the optional fields, as required.
6. Click Save. The activities appear as a table in the Schedule Tab.

Adding Gates

A Gate is a zero duration activity which signifies completion of a major activity similar to a Milestone. A Gate can be added in the Gantt Chart or Web Client to enable checks or control, for completing tasks on schedule before a new task can start. A dependency should be created to achieve this. See Creating and Editing Dependencies in Gantt on page 94.

To add a Gate in Gantt Chart:
1. Select an activity on the tabular view pane.
2. From the right-click menu, click Insert Gate. Or, simply click the Gate icon on the tool bar. You can also use the shortcut key Alt+G.
3. In the dialog that opens, enter a name for the gate and specify the End Date.
4. Click OK to add the gate.

To add a Gate in Web Client:
1. Navigate to the activity in which you want to add a gate.
2. Click the Schedule tab.
3. Click Add.
4. In the Create New dialog, from the Type list, select Gate. The remaining fields appear.
5. Enter the Name of the gate.
6. Enter the Description of the gate, if required.
7. In the Delegated Owner palette, select a Delegated owner, if you want to delegate the ownership of the gate.
8. In the Calendar palette, select a Schedule End Date for the gate.
9. Click Save. The details of the gate appear in the Schedule tab as a row of data.
Adding Milestones

A Milestone is a zero effort activity identical to a Gate, which marks the completion of a set of activities including gates. Usually, milestones are not directly dependent on deliverables. Milestones can contribute to dependencies in projects where more than one sub-projects are involved and the milestone of one project drives the progress of another.

To add a Milestone in Web Client:
1. Navigate to the activity in which you want to add a milestone.
2. Click the Schedule tab.
3. Click Add.
4. In the Create New dialog, from the Type list, select Milestone. The remaining fields appear.
5. Enter the Name of the milestone.
6. Enter the Description of the milestone, if required.
7. In the Delegated Owner palette, select a Delegated owner, if you want to delegate the ownership of the milestone.
8. In the Calendar palette, select a Schedule End Date for the milestone.
9. Click Save. The details of the milestone appear in the Schedule tab as a row of data.

Editing Data

You can perform the following data-editing actions within the Gantt Chart:

- **Copy and Paste from Excel** - You can copy and paste a project directly from an Excel sheet into the Gantt tabular pane. To do this, data in the Excel sheet should be in the field format shown below.

<table>
<thead>
<tr>
<th>Sub-class</th>
<th>Name</th>
<th>Schedule Start</th>
<th>Schedule End</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;Activity type&gt;</td>
<td>&lt;Program Name&gt;</td>
<td>&lt;date format as per User Preference in Agile&gt;</td>
<td>&lt;date format as per User Preference in Agile&gt;</td>
</tr>
</tbody>
</table>

**Note** The data to be copied and pasted should contain the activity type such as Program, Phase, Task or Gate, the project name and the start and end dates of the project. (For Gates, the **Start Date** is considered as the **End Date** in Agile). These fields are mandatory. Ensure you do not select the header row when copying from Excel.

- **Copy and Paste Activities** - You can copy and paste single or multiple activities in the tabular view.
  - To copy, select the activity or activities, and click Copy in the right-click menu, or click the Copy icon on the toolbar.
  - To paste, place your cursor on the destination row and select Paste in the right-click menu, or click the Paste icon on the toolbar.

- **Copy and Paste Content** - Content must be pasted in a relevant destination. For example, you cannot copy a text field into a date format field.

- **Fill-up / Fill-down** - You can replicate content such as activity names or dates on the tabular view.
This action copies the text of the selected cell to adjoining cells you select.

- To fill-up or fill-down, place your cursor on the corner of the selected cell. The cursor changes into cross-hair shape. Drag the cross-hair cursor up or down, to replicate the same text in the cells above or below.

**Note** You cannot fill dates up or down if there is a dependency attached to the activity, and the fill action results in the **Successor** date falling before the **Predecessor** date.

- **View Program Information** - You can view an activity’s general information, Page One, and Page Two details from the Gantt Chart.
  - To view project information, right-click a project activity and select **Properties**.

The Web Client offers the following options to edit data in the tables:

- Copy
- Paste
- Fill-up
- Fill-down

These options are available in the **More** menu of the Team, Content and Attachment tabs of a project.

**Note** For more information, see the *Getting Started with Agile PLM User Guide*.

### Deleting Project Elements

You need appropriate privileges to delete the project elements. An owner may delete a Phase, Task, Deliverable, or Gate. When deleted, Discussions and File Folders are removed only from the project, not from the system. They are retained as standalone objects in Agile. When you delete a project element from the Recycle Bin, it is deleted from the database. For more information on deleting Agile objects, see *Deleting Agile Objects* on page 161.

**To delete a project element:**

1. Select the row of the object you want to remove.
2. Click the **Remove** button. The **Reason** palette appears.
3. In the **Reason Codes** list, select a **Reason Code**.
4. In the **Comments** field, enter comments as appropriate. This option becomes available only if the corresponding SmartRule - *Enable Comments for Deleting, Archiving & Delegating* - is enabled in Java Client. For details, see the *Agile PLM Administrator Guide*.
5. Click **OK**.

The **Reason Code** and **Comments** fields are optional. This information is recorded in the **History** tab of the object. When you delete a child object, the reason for deletion appears in the **History** tab of the parent object.

Alternatively, you can also use the **Actions > Delete** menu command to delete a selected project element.
Setting Ownership to Resource Pools

Organizations have projects spanning across departments and hence efficient resource management for these projects require an owner for the Resource Pool. A user group that is associated to a resource pool is owned by the user that created the user group, by default. However, you can modify the ownership of a given resource pool.

To set ownership to a Resource Pool:

1. Navigate to Tools and Settings > Address Book > User Groups.
2. In the table, click the Name of the user group that is a Resource Pool. The user group page appears.
3. In the General Info tab, click Edit.
4. From the Owner palette, select the owner of the resource pool.
5. Click Save.

If the User Group that you select is not a resource pool already:

1. In the General Info tab, select Yes in the resource pool list.
2. From the Owner palette, select the owner of the resource pool.
3. Click Save.

Managing Content

In PPM, 'content' refers to deliverables associated with the project. Any project or project object that has a lifecycle phase or a workflow assigned to it can be added as a deliverable, as well as any file added as an attachment in the Content tab. Examples of content are Programs, Projects, Phases, Templates, and files or URL references.

Important As a best practice, it is recommended that the attachments tab in Agile PPM activities and gates be disabled. Agile PPM provides a unique tab, the Content Tab, that should be used for all project content, including attachments, for projects.

Note Discussions, Users, and User groups are the only objects that cannot be added as deliverables.

This section describes content objects and key functions such as adding new content, marking content as 'Mandatory', and working with the Content tab.

Adding Content

You can add activities and gates as deliverables on other activities and gates. You can also set rules to ensure the completion of one activity before another. For example, if you want to ensure the completion of an activity before a gate is opened, you can add that activity as a deliverable for the gate to open. You can even restrict one gate from opening before another gate is opened, by
adding the prior gate as a deliverable to the subsequent gate.

For more information on defining rules, refer Defining Rules for Content on page 69.

When adding Projects as deliverables to other projects, they can be Proposed or Active.

Templates can also be deliverables. For a project that has its own copies of deliverables, a template can be a deliverable on tasks.

- If an external root project is a deliverable for a template, it should also be of type Template.
- You cannot add an object that causes a circular relationship as a deliverable. For example, you cannot mandate that Task1 is a deliverable for Task2 to reach completion, and Task2 is a deliverable for Task1 to reach completion.
- In order to add an object, you must have Create privilege for that object, as well as Modify privilege on the Relationships.Name attribute for that object.

To add content to an activity:

1. Navigate to the activity to which you want to add content.
2. Click the Content Tab.
3. Select Add >Object in the Add drop-down menu. A search field appears.
4. Click the Create to Add icon next to the search field.
5. Alternatively, click the Search icon to search and add an object as content to this activity. The object appears on the Content tab.
6. Select the Type of content to create as a deliverable. The related fields appear.
7. Complete the required information in the appropriate fields.
8. Click Add.

The added content appears in the Content Tab.

Note You can use the combination of Ctrl + I keys to view the Create to Add icon and the Search field.

To add content to an activity using custom search:

1. Use the icon or use Ctrl+Shift+Q keys and specify the search criteria.
2. Click Navigator on the Search Results pane, so the search results appear on the left navigation pane.
3. Navigate to the Content tab of the activity to which you want to add content.
4. Drag and drop the objects you want to add, from the Navigation pane into the Content tab.

You can also drag an object from the Recently Visited list on the left pane and add it to an activity.

If the content you want to add is already part of another project, you can copy the content from another project (Use More > Copy) and paste (Use More > Paste) it into the current project. You can also add Files and URLs as content to an activity.
To add files:
1. Click Add > Files in the Content Tab.
2. In the File Upload and Download Method dialog, select a preferred method to work with the files.
3. Click Browse to locate the files on your hard drive.
4. Enter Description, if required.
5. Select Unzip if you want the .zip files to be unzipped.
   \[Note\] You can add up to five files in a File Folder.
6. If you want to add all the selected files to the same File Folder, select Add all files to a single file folder check box.
7. Click Add. The selected files display in the Content tab.

To add URLs:
1. Click Add > URLs in the Content Tab. The Add URL dialog box appears.
2. Type the URL you want to add as content.
   \[Note\] Do not delete the prefix http:// in the URL fields.
3. If you want to view the URL before the addition, click Preview.
4. Enter the Description for the URL, if required.
5. If you want to store all the added URLs in a single File Folder, select Add all URLs to a single File folder.
6. Click Add. The selected URLs display in the Content tab.

Setting Mandatory Content

The Content tab of the activity has project deliverables such as Change Orders, Problem Reports, Items, Documents, Digital Files, activities, gates or URLs. One or more of these deliverables may be required due to regulatory mandates (from agencies such as the FDA), certifications (such as ISO), or approvals (such as Underwriters Laboratory), and cannot be overlooked or deleted by the project managers.

For example, a product may require an Underwriters Laboratory listing prior to moving into production, and this document is a deliverable for the task assigned to deliver it. You can mark this content as 'Mandatory', to ensure that this deliverable and its related task cannot be deleted by the project manager. Only an Agile PPM administrator or user with the appropriate privileges can delete this task from the project tree.

\[Note\] This action is restricted to users who have the Activities.Content.Mandatory Applied To property on the Modify privilege mask. For more information, see Modify Privilege Mask Applied To Properties that Control Specific User Actions.

To set mandatory content:
1. Navigate to the activity that has the requisite content.
2. Click the **Content Tab**.

3. Click on the row that displays the content to be mandated.

4. Double-click on the corresponding cell in the **Mandatory** column.

5. In the list, select **Yes**. Click any other cell to save the modified value.

You can set rules on the contents of any activity to ensure a check on the availability of the Project artifacts. For more information, refer the section on [Defining Rules for Content](#) on page 69.

### Setting Up AutoNumbering

AutoNumbers are the unique identifiers for PPM objects. The AutoNumbers of deliverables are dependent on the AutoNumber preset for each type of deliverable. In PPM, the Web Client does not allow you to modify the AutoNumbers.

For more information on AutoNumbers, refer the section on [Duplicating Deliverables from a Project Template](#) on page 70. For information on setting up AutoNumbering in Agile PLM, refer the [Agile PLM Administration Guide](#).

### Personalizing Views for Content

The **Personalize** menu in the Content Tab enables you to set your preferences for the content table.

The following personalization settings are possible for the content table:

- **Sort**: Sort the displayed data by three different attributes in ascending or descending order.
- **Filter**: Filter the displayed data by one or more column-specific search strings.
- **Format**: Choose the fields or columns to be displayed on the table.
- **Properties**: Display the details specific to the current View selected in the **Views** list.

For detailed information on personalizing table views, refer to the [Getting Started with Agile PLM Guide](#).

In the Content tab of any activity, you can personalize views based on the keywords of the root project.

**To choose keywords:**

1. In the root project, click the **General Info** tab.

2. Click **Edit**.

3. In the **Status Information** section, select the keywords applicable to the project from the **Project Keywords** palette.

   **Note** If you do not see the keyword of your choice, add it to the Keyword list in Java Client.

4. Click **Save**.

Your keywords appear in the **Views** list, in the **Content Tab** of the root Project. In addition, the keywords appear in the **More > Add Keyword** menu.
To personalize views based on Keyword:
1. Navigate to the content table that you want to personalize.
2. Select a content row.
3. Click More > Add Keyword.
4. Select a Keyword appropriate to the selected content.
5. In the Views list, select the Keyword. The content table lists only those content objects that contain the selected keyword.

**Note** In the contents table, the Keyword column of the content row displays the keyword associated with the content.

### Defining Rules for Content

You can set Relationship Rules on content to ensure dependency criteria. Consider an example scenario, where one of the activities in your project needs to be 'Complete' before another begins. This change of status contributes to the dependency in the scenario. Relationship rules define the relationship between the status of the content and activity, and the nature of the action triggered when the rule is satisfied.

**To set relationship rules for the content in an activity:**
1. Navigate to the activity that has the requisite content.
2. Click the Content tab.
3. To select a content row, click the row handler on the row.
4. Click Edit Rule.
5. In the Relationship Rule palette, select the content status from the list.
   
   Example: Document 1 is Review

6. Select the corresponding Activity status that you want to set.
   
   Example: Set Activity to Complete

   **Note** After a rule is set, you cannot change the workflow of the activity without removing the rule.

7. Click Save.

In the Relationship Rule palette, to remove a Relationship Rule, click Remove. To return to the Content tab, click Cancel.

You can also add Rules for Content, using the Quick View dialog of the added content.

**To add a rule using Quick View dialog:**
1. Place the mouse cursor on the Name of the content.
2. Click the Quick View call out to view the details of the content in a Quick View dialog.
3. Click Add Rule link in the dialog to set a relationship rule.
4. In the Relationship Rule palette, select the Content Status from the list.
Example: If Document 1 is Review
5. Select the corresponding Activity status that you want to set.
   Example: Set Activity to Complete
6. Click Save.

**Duplicating Deliverables from a Project Template**

There are certain considerations you need to remember when you create a project from a Template as described in *Creating a Project* on page 73. These are provided here for your reference.

**Content Objects**

- While creating a Project from a Template, you can opt to duplicate or clone the Content objects from the template project. To do this, select the **Content** checkbox in the Optional tab section of Create new > Project > From Template > Create New dialog.

- If the **Content** check box is selected, copies are created for all deliverables in the template. The project and all its child activities will reference the newly created copies and not the original deliverables in the template. For example, a content object such as a Marketing Requirements Document that was available in the template is duplicated in the new project, with the file attached from the template.

- If the **Content** check box is not selected, there are no copies of deliverables created, and no links are provided to any deliverables on the template.

- If the **Content** object does not have a **Rule**, only the link is copied and this link will point to the same object as in the template. For example, a **Content** object such as a Standard Operating Procedure (SOP) document, where it is not necessary to create a new object and only a link to the controlled document is necessary.

- In general, copies are not created for all objects that do not have a Save as functionality. All deliverable objects for which copies cannot be automatically created are listed in the error log window.

**AutoNumbers**

- If multiple AutoNumbers exist on a content object and the system does not know which one to use, content is not created and an error is reported.

- Within the template, ensure that an AutoNumber is set for each deliverable. Deliverable AutoNumbers for the created project are automatically selected based on the AutoNumber chosen for the original deliverable in the template.

- The AutoNumbers attribute is not filled in Proposed or Active type projects. If such projects are saved as templates, you need to fill in the AutoNumber attribute in the template again.

- Copies are not created for deliverables where the AutoNumber field is left blank. Templates use the AutoNumber attribute of a particular content to determine the name of the deliverable to be created.

- For all classes, if the same object is a deliverable for multiple activities and/or gates in the template, the copy of the object is created for the first activity / gate for which it is a deliverable,
and a link to this copy is provided for all other subsequent activities or gates for which the same object is a deliverable.

For example, let’s say that a document DOC00341 is a deliverable that is referenced twice in a template, on Task1 and Task2. When a project is created from this template, a new copy of the original deliverable in the template is created - DOC00982 for Task1. This document will be a deliverable for Task2 as well, following the same pattern as in the template that the project is created from.

**Required Fields**

- All required fields are copied from the original deliverable to the newly created copy.

**Tabs**

- For all subclasses, Cover Page, Page Two, Page Three and Attachments tabs are copied.

  For example, if an assembly is a deliverable on one of the tasks, the only tabs that are copied are Page One, Page Two, Page Three and Attachments. The BOM tab is not copied over.

**Activities and Gates**

- When internal activities and gates in the template are used as deliverables, corresponding copies are created in the newly created project tree and referenced as deliverables in the other activities and gates as defined in the template.

- When activities and gates within a template or source project are added as deliverables to later activities and gates in the template, the deliverables on a project created from the template will also reference corresponding activities on the newly created project.

  For example, if Task1 is a deliverable of Task2 in the template, then for any project that is created from the template, Task1 in the project will be a deliverable of Task2 in the project. This is one approach of implementing hard exit on gates, that is, ensuring certain activities are completed or certain gates are opened before another specific activity is completed or gate is opened.

**Root Projects**

- Only the root projects of Template type are allowed as deliverables for activities and gates within a template.

  - If an external root template is a deliverable on a task of a template, a new project deliverable is created as a copy of the original template deliverable. This copy of the original project deliverable has the project tree structure in place, but no deliverables. When creating copies of external root templates, only General Info, Page Two, Page Three, Attachments, Dependencies and Schedule tabs are copied.

    Team and Content tabs are not copied.

External root templates, if used as deliverables multiple times, are cloned only once, similar to internal activities and gates.
Templates

- If the user chooses to create a proposed project from a template, all templates that are deliverables of this template are created as proposed projects that are deliverables of the newly created proposed project. (The same applies if you choose to create an Active project from a template. For the copies, only the name of the root project is changed; the names of the activities and gates remain the same. The activities and gates numbers, however, are system-generated and unique.

- Copies of external activity deliverables that are not root templates are not created due to the fact that non-root activities cannot exist by themselves. In this case, the deliverables on the project created from the template will reference the original deliverables on the template for such objects.
Creating and Managing Projects

This chapter includes the following:

- Creating a Project.......................................................... 73
- Editing a Project.............................................................. 76
- Activating a Project.......................................................... 79
- Working with Project Content ........................................... 80
- Managing Resources....................................................... 82
- Managing Schedules........................................................ 93
- Managing Discussions..................................................... 99
- Archiving Projects........................................................... 102

Creating and managing projects in PPM involves using Web Client or Gantt to:

- Create, edit, activate, and baseline a project
- Work with project content
- Assign resources and allocate activities
- Establish dependencies and reschedule activities
- Initiate and respond to discussions

Creating a Project

You can create a project using Web Client or Gantt.

Using Gantt Chart

You can create a new Active or Proposed project from the File menu or an existing template in Gantt.

To create a project using the File menu in Gantt:

1. Launch Gantt Chart. See Launching Gantt on page 49.
2. Click File > New. The New Project window opens with the standard duration of one day.
3. To rename the project, double-click the name of the project.
4. Click File > Save. The project is Active by default.

Note  Right-click on the project name in Gantt and click Properties to modify the various properties of the project.
To quickly create a project using data from a spreadsheet:

1. Ensure that the data in the spreadsheet is in the following format:

<table>
<thead>
<tr>
<th>Activity Type</th>
<th>Name</th>
<th>Schedule Start Date</th>
<th>Schedule End Date</th>
</tr>
</thead>
</table>

Dates should be in the mm/dd/yy format.

2. Copy the required rows from the spreadsheet.

3. Launch Gantt Chart. See Launching Gantt on page 49.

4. Click File > New.

5. Select the default row that appears and paste the rows you copied (Press CTRL+V or right-click and select Paste). Errors, if any, are reported at the bottom of the window.

6. The project is copied over. Click File > Save.

To create a project from an existing template in Gantt Chart:

1. Click File > Open to view the Activity window.

2. In the Find From list, select Root Templates.

3. If you know the name of the template, enter the Name, or click Find.

4. Click on a row to select the template.

5. Click OK to view the new project based on the selected template.

6. Click File > Save as File to save the project on the disk.

7. In the Save as File Options dialog, enter the Name and Description for the new project.

8. Select Active or Proposed from the Project State List.

9. Click OK and select the destination folder for the new project.

The new project does not have the Page Two and Page Three attributes copied from the template. The content from the Attachments and Content tabs are not copied when you save a new project from a template using Gantt.

Using Web Client

You can create a project from Web Client using the following:

- The Create New menu
- The Save As menu
- An existing project template

In the Web Client, the Create New menu enables you to create a new project.

To create a new project using the Create menu:

1. Launch Agile Web Client.

2. Click the <Create new> drop-down menu.
4. In the Create New dialog, select Project from the Type list.
5. Enter the Name of the project.
6. Enter the Description for the project, if required.
7. From the Delegated Owner list, select the new owner for the project. The default owner of the project is the logged-in user.
8. Select Proposed in the Project State list. You can change the status to Active when you are ready to roll out the project. Your selection here can have implications on the AutoNumber attributes of the new project. For more details, see Cloning Deliverables on page 70.
9. In the Schedule section, select Duration Type, Schedule Start Date, and Schedule End Date. The Schedule Duration is automatically calculated as the difference between the start and end dates.
10. Click Save.

The Actions > Save As menu enables you to save an existing template as an 'Active' or 'Proposed' project. The default type of the project is Active.

To create a project using the Save As menu:
1. Navigate to the Template or Program which you want to save as a new project.
2. Click the Actions > Save As menu.
3. In the Save As dialog, enter the Name of the project.
4. Enter the Description for the project, if required.
5. Select Proposed in the Project State list. You can change the status to Active when you are ready to roll out the project. Your selection here can have implications on the AutoNumber attributes of the new project. For more details, see Duplicating Deliverables from a Project Template on page 70.
6. Select the optional components of the project or template whose contents you want to copy to the new project.
7. If your template or project has a lot of content to be copied, select the Run As a Background Process check box. You can then continue working on other projects while the new project is being created. A notification is sent to you when the process completes. You can open the project directly from the notification link.
8. If you want to mark this project as the baseline version, select the Kick-off Baseline check box.
9. Click Save.

You can create a new project from an existing template, to save a lot of time in entering all project-related information afresh.

To create a new project object from an existing template:
1. Launch Agile Web Client.
2. Click the <Create new> drop-down menu.
3. Select Projects > From Template.
4. In the Create New dialog, from the Templates palette Select Template. The remaining fields appear.
5. Enter the Name of the project.
6. Enter the Description for the project.
7. From the Owner list, select the new owner for the project. The default owner of any activity in the project is the owner specified for that activity in the template.
8. If you want this user to own all the child project-objects, select the Apply as owner for this level and below checkbox.
9. Select the Start Date or End Date option. Use the Calendar palette to select the Schedule date.
10. Select Proposed in the Project State list. You can change the status to Active when you are ready to roll out the project. Your selection here can have implications on the AutoNumber attributes of the new project. For more details, see Duplicating Deliverables from a Project Template on page 70.
11. Select the optional components of the template whose contents you want to copy to the new project.
12. If your template has a lot of content to be copied, select the Run As a Background Process checkbox. You can then continue working on other projects while the new project is being created. You receive a notification when the process completes. You can open the project directly from the notification link.
13. If you want to mark this project as the baseline version, select the Kick-off Baseline.
14. Click Save.

Editing a Project

You can edit the information in the project page tabs such as General Info, Schedule, Team, Dependency, Content and Collaboration. In multi-user environments, sometimes, more than one user edits the same task in a project. In addition, concurrent users may need to edit multiple tasks in the same project tree.

Editing Project Objects Concurrently

The Agile PPM solution is designed to manage large projects with hundreds of activities and numerous team members. It is possible for multiple users to edit the following:

- Multiple tasks in the same project tree structure at the same time.
- The same task at the same time.

Editing Multiple Tasks in the Same Project Tree

When multiple tasks in the same project tree are edited at the same time, the edit modifications may have affects on objects higher in the project tree (rollup) or lower in the project tree (rolldown).

Editing Tasks with a Predecessor and Successor Relationship

When a parent task is rescheduled to a specific end date that end date rolls down to the child objects. You can also edit a child object end date, which then extends the bounds of the parent object (by rollup to the parent object). As each user makes and saves his modifications, the
necessary rollup or rolldown takes place.

**Note** In this scenario, it is possible for a user to enter a specific date on the edit page, yet see a different date upon save, because of the rollup or rolldown caused by another user’s edits. However, the schedule remains accurate.

**Examples**

- Task B (owned by Bob) is a predecessor to task A (owned by Mark). Bob and Mark are editing the schedule dates of their tasks at the same time, and save their edits one right after the other. If the new edited dates of the first saved task cause the dates of the second saved task to change, the person saving the second task is presented with a message explaining that the dates he entered will be changed and he can accept the change or cancel.

- Mary is editing a parent activity and several other users are editing several child activities at the same time. Mary reschedules the specific end date of the parent activity. At the same time, some of the child activities have been modified in such a way that the end date of the parent activity is extended. As each edited activity is saved, the dates for the parent or child activity are updated correctly for schedule accuracy. It is possible that a user may save his activity and see a different date than the one he entered on the edit page, but the schedule is accurate.

- New roll-up data overwrites a common parent or root activity.
  
  Susan owns task C and Fred owns task D. Both task C and task D have a common parent, task M, thus they are both in the same tree structure. Both Susan and Fred are editing their tasks, modifying data that rolls up to parent task M (percent complete, cost, or status data). Fred saves task D and task M is rescheduled according to Fred’s edits. Then Susan saves task C, and task M is again rescheduled, this time according to Susan’s edits.

**Multiple Users Editing the Same Task**

To keep other users from editing roll-up or roll-down attributes of the object you want to edit, use the feature in Web Client. Locking an object means that only you can edit rollup and rolldown attributes and other users who edit the object are “locked out”. Although they can edit attributes that do not rollup and rolldown, they cannot edit roll-up and roll-down attributes until you have finished your edits and you have unlocked the object.

**Note** When you use **Launch in Microsoft Project** or **Gantt Chart**, Agile automatically locks the project. When you update from Gantt Chart or Microsoft Project, Agile automatically unlocks the project.

In Web Client, when you use **Edit** on the **General Info**, you must click **[ ]** before you click **Edit**, if you want to lock the object. The differences between locked editing and unlocked editing are explained below.

**Locking Tasks for Editing**

When a user (Mary) locks the task before entering edit mode, Agile provides the following safeguards when a second user (Carl) edits the same task:

- Carl sees a message “This activity is currently locked by another user. For this reason some fields will not be editable.”
While in edit mode, Carl can edit only non-rollup attributes on the General Info, Page Two, and Page Three. Carl can save his edits. When Mary saves her edits, Carl’s edits may be overwritten. The most recent update of non-rollup attributes overwrites the others.

The Name attribute on the General Info is an exception. Even though it is not a rollup attribute, when the task is locked, only the lock user may edit this attribute.

**Note** When you lock an object, its dependencies (both external and internal) are locked; the successors and their children are locked.

**To lock and edit an activity object:**

1. Open the object you want to edit.
2. Click Lock.
3. Click Edit on the General Info tab.
4. Edit the fields as required.
5. Click Save on the General Info tab.
6. Click Unlock.

**Editing Unlocked Tasks**

If you do not lock a task before editing it, the same safeguards do not apply.

For example, let’s assume we have two users, Joe and Carl. When Joe enters edit mode for a task first, and Carl then enters edit mode, the following applies:

- The second user, Carl, does not see a warning that another user is in edit mode.
- Regardless of who entered edit mode first, the user who saves first will update the Agile database with his modified data. The second user who saves receives the following error message: “The current object has been modified by another user, please try again. If you want to ensure that your changes are saved, please lock the object prior to editing.”
- If the unlocked parent object has been rescheduled to a specific end date, and any child objects have been modified in a manner that extends the bounds of the parent, no messages are presented, and each modification is saved. The appropriate roll-up or roll-down date modifications are performed. It is possible that the date information that a user saves might not match the date he entered (due to edits made by a different user), but the schedule information is correct.
- The exception to the above behavior is when two users edit the task status (use the Change Status button) or two users add to the Schedule at the same time. Multiple status changes and schedule additions are accepted and saved when done in parallel.

**Reviewing Changes**

After making changes to a project offline or online, you can review your changes using an HTML report before saving the project. This feature is available only in Gantt Chart.
To review your changes to a project:

1. From the Tools menu of the Gantt Chart, select Show Changes.
   A new window opens, showing a comparative view of changes recorded on the server and on the Gantt Chart. Activities that have been modified, added or deleted are indicated by the colors shown in the legend below the table. A gray icon indicates a modified object.

2. To see details of changes made to an activity or gate, click its name. A pop-up window shows Page One, Page Two, Page Three, Schedule and Resource information with old and new values. Scroll down to see all changes.

3. To view details of any modifications made to your project schedule, allocated resources, dependencies, Page One, Page Two or Page Three fields, click the appropriate icon in the respective columns.

Undoing Changes

The Gantt Chart allows you to undo any action that you perform, except Save. You can also undo actions such as the opening of a project. The Edit menu displays contextual Undo or Redo options based on the current action.

Only one undo or redo operation is supported per action. You can also use the shortcut key Ctrl+Z to undo an action. Pressing Ctrl+Z a second time will redo the action.

Activating a Project

A project can be in the Proposed state until the requirements such as schedule, team, and content are fixed. When all the project stakeholders agree with the key aspects of the project specifications, you can activate the project.

When you change a project to Active, Agile PPM does the following:
- Opens the project to activity by team members
- Places an active load against all resources and resource pools based on team definitions and allocations
- Starts calculating standard budgeted labor costs
- Places assigned activities in the assignment lists of project participants.

Note Changing a project to Active does not change the status of the project to "In Process".

To activate a project:

1. Navigate to the proposed project or template which you want to activate.
2. In the General Info tab, click Edit.
3. In the Activities Information section, select Active from the Template list.
4. Click Save.

Note You can change the status and report time against activities, only in an Active project.
Working with Project Content

The **Content** tab in the project page lists all content specific to the project. This section discusses ways to view and update content in Web Client.

**Viewing Content**

You can manipulate the **Content** tab view in several ways to display the objects you wish to focus on:

- **Display all Levels**: Select this checkbox in the top right corner of the **Content** tab to ensure that your view displays objects at all levels of the project hierarchy below the current level.

- **Views**: You can use the options in the **Views** drop-down list to filter the view by attributes that you configure. By default, the list includes options such as Complete, Pending, and Rule Not Specified. A Pending deliverable is an object which has not yet met the specified rule criteria, and a Completed deliverable is an object that has met the rule criteria.
  - To change the name of any of these views:
    - Click the **Personalize** button.
    - In the **Properties** tab of the Table dialog that opens, edit the **Name**.
    - Click **Save**.

  **Note**  A view can be deleted only by the owner of the root project.

- To add objects to a view, select the objects, click **More Actions > Add Keyword**, and select one of the available keywords.

  **Note**  Content that you mark with the **Important Content** keyword will also display in the **Project Summary** page.

- To add more views, go to **Personalize > Save As**, enter a name for the new view in the **Name** field, and click **Save**. The newly created view appears in the **Views** list.

  **Note**  Only the project owner can create a new view. Program team members can add content to existing views.

- To bookmark a selected content object, use the **More > Bookmark** option.

- To subscribe to notifications on attribute changes for a selected item, use the **More > Subscribe** option.

- To create a change order for an item, select the item and use the **More > Create Change** option.

- **Preview**: Click **Quick View** on any object to see details of that object in the **Quick View** window. Within this window, you can take several actions on the object, such as:
  - View a selected revision.
  - View, add, edit, or remove a rule, to ensure hard dependencies.
  - Add, remove, check out, or view a file attachment in multiple formats.
  - **Create Change** for an item.
Updating Content

In the **Content** tab of the project page, you can do the following:

- Edit rules
- Edit content details
- Change views
- Add mandatory content on template programs
- Assign keywords

**Note** In addition, the **Quick View** dialog also allows these activities.

**To edit a rule:**

1. Select a content row for which you want to update the rule.
2. Click **Edit Rule**.
3. In the **Relationship** palette that appears, select a status of the content folder and a corresponding status of the project.
4. Click **Save**.

The updated rule appears in the **Rule** column of the selected content row.

**To edit content details:**

1. Click the **Name** in the content row, the details of which you want to modify. The **Folder** page appears.
2. Edit the details in the **Title block** as appropriate.
3. Click **Save**.

**Note** You can also remove content (a new URL or file) from the **Content** tab and post new content.

**To change views:**

In the **Content** tab, select a view from the **Views** list. This displays content specific to the selected view only.

**To add mandatory content:**

1. In a content row, double-click a cell in the **Mandatory** column. A drop-down list appears.
2. Select **Yes** from the list to mark the content mandatory.

When you generate a new 'Active' or 'Proposed' project from a template with defined mandatory deliverables, these deliverables cannot be deleted from the new project.
To assign keywords:
1. Select a content row.
2. Click More > Add keyword and choose a keyword.
3. The Project Keywords in the General Info tab appear in the More > Add Keyword choices.

The keyword you select appears in the Keywords column of the content row. Select a keyword from the Views list in the Content Tab, to view the content relevant to the selected keyword.

Note  The Add Keyword menu is not available if you have not added Project Keywords. To add Project Keywords, edit the Project Keywords field in the General Info tab of the project.

Managing Resources

Resource Management activities for a project in PPM include:
- Adding resources to the project
- Assigning activities to the resources
- Monitoring resource utilization
- Substituting resources
- Delegating ownership of activities based on resource utilization
- Searching for timesheets
- Removing resources

Adding Resources

You can add resources to a project using Web Client or Gantt.

Adding Resources using Web Client

In Web Client, you can add resources to a project using the Team or Schedule tab. The Team tab enables you to add a user group or a resource pool to a project.

Adding Team Members from Schedule Tab

You can select single or multiple activities and add team members or resources (the default allocation is 100%).

To add team members to an activity from the Schedule tab:
1. Select one or more activities and select Edit > Add Resources.
2. In the Add Resources dialog, launch the New Members palette and select the resources you want to add.
3. In the Team Member type section, specify the resource allocation details.
   a. To add the selected users as resources (with a specific % allocation):
Select the **Resource with % Allocation** option. The default allocation is 100%. You can enter the desired allocation percentage.

b. To add the selected users as team members (with a zero % allocation):
   
   Select the **Add as Team Member only** option.

c. Launch the **Roles** palette to select the appropriate roles for the selected resources.

4. Select **Apply to this level and below** if you want the settings to apply to the current object and child objects.

5. Click **Add**.

**Adding Team Members from Team Tab**

You can add users or user groups as team members using the Team tab.

**To add team members and apply roles:**

1. In the **Team** tab of the project, click **Add**.

2. In the **Add Resources** dialog, launch the **New Members** palette and select resources you want to add.

   **Note** Before you select a resource or user group, you can review resource utilization details. To do this, click the **Utilization Report** button. This opens a window where you can review resource utilization details based on query criteria. You need to have **Team.Name** as an **AppliedTo** property within the **Modify** privilege to be able to assign members from a resource pool or user group.

3. In the Team Member type section, specify the resource allocation details.
   
a. To add the selected users as resources (with a specific % allocation):
      
      Select the **Resource with % Allocation** option. The default allocation is 100%. You can enter the desired allocation percentage. The maximum allocation percentage is 400. You can change this setting in Java Client.

   b. To add the selected users as team members (with a zero % allocation):
      
      Select the **Add as Team Member only** option.

   c. Launch the **Roles** palette to select the appropriate roles for the selected resources.
      
      The roles available for selection are roles assigned to you (the login user) that have an associated PPM privilege.

4. Select **Apply to this level and below** if you want the settings to apply to the current object and child objects.

5. Click **Add**.

The selected resources and assigned roles are displayed in the **Team** tab. People added as resources, are also added as team members automatically. When you complete the addition of resources, each of the selected resources receives a notification in their **Notifications** tab.

If you add a resource pool or user group, the pool owner receives a notification. The request also appears in their **My Assignments** tab. Each resource can accept or reject the request. When the resource accepts or rejects the request, the Resource Pool owner receives a notification.
Note: The % Allocation is divided among the selected users. If there is a fraction of a percent, the percentage is rounded off to the next lowest whole number, discarding the fractions of a percent.

For example, if the resource pool was assigned at 100% allocation, and you select three users, each user will be assigned 33%. If you remove the three users and reassign the % Allocation back to the resource pool, the % Allocation for the pool will be 99% – the fractions of a percent are discarded. However, you can select the appropriate rows in the table and double-click the % Allocation cell to adjust the percentages for the users assigned from the resource pool, or (if you have assigned allocation back to the resource pool) adjust the percentage for the resource pool.

Note: For information on working with the Address Book Palette, refer to the Address Book Palette on page 46. In the New palette window, the user groups that are already added to the team table are not available for selection, in the drop-down menu. Similarly, the Search within a User Group option in the drop down menu does not display the user groups already added to the team table.

Adding Resources using Gantt

You can assign resources to your project from within Gantt. Resource Management allows you to allocate resources to various projects and also split resources between projects.

To add resources to your project:

1. Select an activity and click 🔄 on the toolbar. The Manage Resources dialog opens.

2. In the Manage Resources dialog:
   1. To add a resource, click 🔄. This creates a new row in the table. To enter a value in the new row under the Name column, double-click the cell and choose a resource name from the list of values that appears.

   To add resources from a resource address book, click 📁. Click Find to view all the resources from the selected resource list. Use the Find From drop-down list to select a resource list from your existing resource sheets, for example, an existing resource pool or resource sheet list. Resources or resource pools that have already been added do not appear in the search results.
Depending upon your selection, more options become available. Click Options to perform a parametric search to find resources. For more information on Parametric Search, see the Agile PLM Getting Started Guide.

2. Click OK. Selected resources appear in the Manage Resources table.

3. In the Roles column, specify the role for each resource. To change cell values, double-click the cell and click . In the dialog that opens, select a role from the Available Roles column, move it to the Selected Roles column, and click OK.

4. In the % Allocation column, enter the percentage of the resource’s time that you want to allocate for this activity. If the resource rejects the activity assignment, an icon is displayed in the Rejected column.

| Note | The percentage (%) allocation for a full-time resource who is assigned to only one activity is 100%. If the resource is being shared across multiple projects, the percentage allocated would vary depending on the time allocation towards each project or activity. |

3. To assign a resource, select the row and click Apply.

Before you assign resources, you can confirm availability of each resource. See Viewing Resource Utilization on page 85.

**Viewing Resource Utilization**

Resource utilization information is required to make informed decisions during the allocation of tasks to resources. PPM provides the following resource utilization reports:

- Project Resource Utilization Chart
- Resource Utilization Report

**Viewing Project Resource Utilization Chart**

Project Resource Utilization chart enables you to view the overall resource utilization for the project in a given period of time.

**To view the Project Resource Utilization Chart in the Web Client:**

1. In the program or project page, click Actions > Reports and Analytics > Project Resource Utilization menu.
2. In the Project Resource Utilization window, the Resource Utilization chart appears as per the default filter criteria.

   You can modify the fields such as Report Type, Start Date, End Date, Reporting Intervals, Display Values by, Pool, and Chart Type to view resource utilization specific to the modified filter criteria.

3. Click Print to view the Project Resource Utilization report in a different window and print the report.
4. Click Export to csv to view the Resource Utilization report in Microsoft Excel.
Viewing Resource Utilization Reports

The Resource Utilization chart helps you to view resource availability, before you assign a resource to a particular activity. You can view resource utilization reports in both Web Client and Gantt.

**Viewing Resource Utilization Reports using Web Client**

In Web Client, you can view the Resource Utilization reports from the following:

- Dashboard
- Team tab

**To view the resource utilization report for a resource pool from the Dashboard:**

1. In the **Resources** widget, click 📈 in the row. The **User Group Utilization** window appears with the resource pool utilization chart and fields to specify filter criteria.
2. You can specify filter criteria as required, to view the **User Group Utilization** report.

**To view the resource utilization for a particular resource or resource pool from the Team tab:**

1. In the **Team** tab, select a row in the table.
2. Click **Utilization** to view the percentage utilization of the resource or resource pool in a graphical chart.

**Note** The results in the chart are based on the filter criteria. You can modify the filter criteria to view resource utilization according to your need.

**Viewing Resource Utilization Reports using Gantt**

Gantt users can view the Resource Utilization Reports from the Task Assignment menu on the left Navigation pane.

**To view the resource utilization for a particular resource or resource pool in Gantt Chart:**

1. Select an activity.
2. Click **Task Assignment** in the left Navigation pane or click 📈 to view the **Manage Resources** and **Resource Utilization** windows.
3. Select a resource row in the **Manage Resources** window and see the corresponding **Resource Utilization report** in the **Resource Utilization** window.

**Editing Team Member Attributes**

In the Web Client, you can edit the team member attributes such as resource pool, role and allocated percentage of effort.

**To edit a team member's resource pool, roles, and % allocation:**

1. In the **Team** tab, select the rows that you want to modify.
2. Double-click in the **Assigned From** cell.
3. Launch the **Assigned From** palette to select a different Resource pool, if required.
4. Double-click the **Roles** cell.
5. Launch the **Roles** palette to select a different Role, if required.
6. Double-click the **% Allocation** cell.
7. Enter a different **% Allocation**, if required.
8. Click anywhere outside the Team table to exit the edit mode and save the entries.
9. Click **Utilization** to view the User Group Utilization report. This report provides information on the time utilized by the resource based on the percentage of the allocated time.

The team member attributes in the Team table are:

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Name of team member or group.</td>
</tr>
<tr>
<td><strong>Assigned From</strong></td>
<td>The name of the pool from which the resource is assigned. If the resource is assigned to multiple pools, the appropriate pool can be selected.</td>
</tr>
<tr>
<td></td>
<td>If the team member belongs to a user group in which the Resource Pool is set to 'No', then the corresponding 'Assigned from' field in the Team tab is blank.</td>
</tr>
<tr>
<td></td>
<td>If the team member belongs to a user group defined as 'Personal', with the Resource Pool value set to 'No', then the corresponding 'Assigned from' field in the Team tab is blank.</td>
</tr>
<tr>
<td></td>
<td>The General Info tab of a user group name displays the values of properties such as, 'Global/Personal' and 'Resource Pool'. Click <strong>My Settings &gt; Address Book &gt; User groups &gt; User group name</strong> to navigate to the General Info tab of any specific user group.</td>
</tr>
<tr>
<td><strong>Note</strong></td>
<td>For best results in managing resource utilization, Agile recommends that a user be assigned as a member of only one resource pool.</td>
</tr>
<tr>
<td>Roles</td>
<td>Program-specific roles assigned to team member for this activity.</td>
</tr>
<tr>
<td>Days Effort</td>
<td>Days effort corresponds to the total sum for the resource or group.</td>
</tr>
<tr>
<td><strong>Is Resource</strong></td>
<td>Identifies the user as a resource or just a team member with no time allocated to the activity. This Information is dependent on % allocation of Resource/Team Member / User Group. If % allocation is greater than 0, it is Yes, otherwise No.</td>
</tr>
<tr>
<td>Rejected flag</td>
<td>This indicates that the resource or pool has rejected the request.</td>
</tr>
<tr>
<td><strong>% Allocation</strong></td>
<td>For both Fixed and Effort Driven duration type, this value determines utilization of a resource or group.</td>
</tr>
<tr>
<td>Pool Owner</td>
<td>Name of the resource pool owner, if there is one.</td>
</tr>
<tr>
<td><strong>Actual Hours</strong></td>
<td>The number of actual hours (duration) the team member has worked.</td>
</tr>
<tr>
<td></td>
<td>▪ Reported Actual Hours are rolled up and compared to Estimated Duration and Scheduled Duration.</td>
</tr>
<tr>
<td></td>
<td>▪ Actual hours are also used to determine the labor cost per activity. Actual hours are multiplied by the resource rate to determine the current applied cost of each resource. These totals by resource are added up to determine the applied cost per activity, and are then rolled up to the top to create labor costs for all parent objects.</td>
</tr>
</tbody>
</table>
Assigning Tasks to Resources

You can choose to assign more than one task to multiple resources or split one task among multiple resources, based on your knowledge of the resource pool utilization. For information on resource utilization reports refer to Viewing Resource Utilization on page 85.

Bulk Assigning Tasks to a Resource

You can bulk assign several tasks to a single resource if necessary. For example, a project manager can bulk assign a set of tasks to a particular resource pool owner. This resource pool owner can then assign these tasks to members of the resource pool.

To bulk assign tasks to a resource:

1. In Web Client, click the name of the resource pool to view resource details. You can use the Search options to search for a particular user group by name.
   You can also find the name of the resource pool in the Dashboard > Resources widget, My Settings > User Group page, and the project page Team tab.
2. In the User Group page, click the Assignments tab to view all the assignments and percentage allocation for the user group.
3. Use the Personalize menu to filter table display.
4. Select the assignments that you want to bulk assign to a resource.
5. Click Assign.
6. In the Activity Assignments dialog that opens, select the option button on the Allocate cell of a user to assign the selected assignments. The selected user becomes the owner of the selected assignments. The allocation percentage for this user is the sum of allocation percentages of all the assignments.
7. Click Finish.

**Note** View the existing assignment list and user group utilization details before you assign tasks to a resource. Use Actions > Reports and Analytics > Assignments List Report to view the list of assignments for all resources in the user group. Use Actions > Reports and Analytics > User Group Utilization Report to view a report of the resource utilization for the user group.

**Important** It is recommended to verify your allocations using the same reports after you finish assigning tasks to the resources.

Splitting a Task Among Several Resources

As a resource pool owner, you have more visibility into the utilization status of each resource in your pool. Once a task has been assigned to your resource pool, you can split the % allocation of the task across several resources.

To split a task across several resources:

2. In the Assignments tab, select the task and click Assign.
3. In the Activity Assignments dialog that opens, double-click the Allocate cell in the resource row to make it editable.

4. Enter the percentage allocation for all resources that share the assignment.

5. Click Finish.

**Changing Ownership of Tasks in Projects Created from Templates**

When you create a project from a template, if the owner of any activity except the root activity is defined in the template as a resource pool, the owner of the newly created (duplicated) activity will also be that resource pool. To change the owner of any activity or gate from a resource pool to an individual user, the owner of the resource pool must assign a user to the task owned by the pool.

**To change ownership of a task to a resource pool member:**

2. Click on the resource pool name to view assignments.
3. In the Assignments tab, select the task you want to reassign, and click Assign.
4. In the Activity Assignments dialog, select the option button in the Change Ownership column for the new owner of the task.
5. Click Finish.

The task can also be split between several users within a pool, from the Assignments tab of the user group. See Splitting a Task Among Several Resources on page 88.

**Removing Resources**

If your resource utilization report shows excess allocation for a resource, or if a resource is not available for the project, you can remove the resource from the project using Gantt or Web Client.

**To remove assigned resources in Gantt Chart:**

1. In the Manage Resources dialog, select a resource or multiple resources to delete.
2. Click ![Delete](image). A message prompts you to confirm deletion.
3. Click Yes to confirm.
4. In the dialog that opens, select either of the following:
   - **Delete resource and re-assign % allocation to pools (if applicable)** - Select this option if you want to delete the resource and re-assign the resource allocation percentage to other resources in the project resource pool.
   - **Delete resource and discard % allocation** - Select this option if you do not want to re-assign the resource allocation percentage.

The selected resources are removed as per your specification.

**Note** In the Manage Resources dialog, a black check mark next to the resource name indicates that the resource is allocated to all selected tasks. If the resource is allocated to at least one task, but not all tasks, the check mark will be gray.
To remove assigned resources in Web Client:
1. In the Team tab, select one or multiple resources to delete.
2. Click Remove.
3. In the Remove Team Members dialog, select either of the following options:
   - **Remove only resources without a percent allocation** - Select this option if you want to delete the resources without the resource allocation percentage.
   - **Remove resources and assign their percent allocation to their resource pool if applicable** - Select this option if you want to delete the resource and re-assign the resource allocation percentage to other resources in the project resource pool.
   - **Remove resources and discard their percent allocation** - Select this option if you do not want to re-assign the resource allocation percentage.
4. Click OK.
   The selected resources are removed according to your specification.

Delegating Ownership

When you create a project element, by default, you are the owner. The Delegate command enables you to change ownership of a project element.

**Note**
An owner of a higher-level project element retains ownership of lower level items reporting to it, even when ownership of the lower level is delegated to another team member.

You can delegate ownership of an activity to a selected resource. In this way, you can assign an owner to each task in your project. When you delegate an owner to a task, a request is sent to the owner for approval. See also: "My Assignments".

Once the delegated owner accepts the request, that resource owns the task and the delegated field becomes blank.

To delegate ownership of a project element from Web Client:

1. Open the project object you want to assign to a new owner.
2. Choose Actions > Delegate.
3. In the Delegate dialog:
   1. You can optionally specify the reason for this action, for later use (Filtering data for reports, for example.).
      - In the Reason Code field, select an option from the list.
      - In the Comments field, enter comments as appropriate.
   2. Select a new owner from the table. If the intended new owner is not listed, click Add.
   3. In the Users field, enter the first few letters of the user's name and then select the name from the list that pops up. Or click 📚 to launch the address book and select the user.
   4. In the Roles field, use the palette to select a role and click Save.
   5. Click Delegate to assign ownership to the new owner.
A gray icon appears beside the General Info tab link. In the Delegated Owner field, the icon appears next to the delegated user’s name.

In the delegated user’s Home page, there is a delegation notification in the Notifications tab, and a corresponding request in the My Assignments tab. Once the delegation is accepted, the icon is cleared and the Delegated Owner field is blank as the delegated owner has become the owner of the activity.

If the delegated owner has not yet accepted the delegation, you can use Actions > Delegate to choose a different user as the delegated owner.

**Note** To cancel the delegation, use Actions > Delegate and select the original owner as the delegate.

<table>
<thead>
<tr>
<th>Action or condition</th>
<th>Results or consequences</th>
</tr>
</thead>
<tbody>
<tr>
<td>The activity is locked.</td>
<td>The Delegate menu appears inactive when you click Actions menu.</td>
</tr>
<tr>
<td><strong>Note:</strong> To unlock an activity, click the Unlock button.</td>
<td></td>
</tr>
<tr>
<td>The project is not active (the Template field setting on the General Info tab is not equal to Active). Or The project is active, but its status is Not Started.</td>
<td>No delegations are sent to the delegated owners. Delegations are sent only when the project is Active.</td>
</tr>
<tr>
<td><strong>Note:</strong> To start a project (move it to the In Process status), change the status of one of its leaf activities. You cannot directly change the status of an activity if it has subordinate activities.</td>
<td></td>
</tr>
<tr>
<td>A current team member is selected as the new owner, but has not yet accepted.</td>
<td>◦ The new owner’s name appears in the Delegated Owner field on the General Info tab. ◦ The gray icon appears beside the General Info tab name indicating that the project has been delegated, but the delegation has not been accepted.</td>
</tr>
<tr>
<td>A user who is not a current team member is selected as the new owner, but has not yet accepted.</td>
<td>◦ The new owner’s name appears in the Delegated Owner field on the General Info tab. ◦ The gray icon appears beside the General Info tab name indicating that the project has been delegated, but the delegation has not been accepted. ◦ Because the delegation has not yet been accepted, the new owner does not appear on the Team tab.</td>
</tr>
<tr>
<td>The delegated user accepts the delegation in the My Assignments tab.</td>
<td>◦ The gray icon beside the General Info tab name is removed. ◦ If the delegated owner was not a current team member, he is added as a team member on the Team tab. ◦ On the Team tab, the Agile PPM default owner role is automatically added to the delegated owner’s assigned roles. By default, the default owner role is the Program</td>
</tr>
</tbody>
</table>

v9.3.0.2
Manager role, however, your Agile administrator may set a different role. For more information, see the Agile PLM Administrator Guide.

| The delegated user rejects the delegation. | ▪ The icon beside the General Info tab name is removed.  
▪ The Delegated Owner field on the General Info tab is empty. |

**To delegate ownership of a project element from Gantt Chart:**

1. Select the activity or task. The Delegate Owner icon is enabled.
2. Click 🔄. A list of default resources is displayed.
3. Select the resource from the list, or click 🔄 to select resources from the Address Book.
4. Click OK to delegate ownership.
5. You can optionally enter a reason for the delegation and comments in the Reason for Delegation column. Double-click within the column row to open a dialog where you can enter these details.

**Note** When you save the current updates to the Gantt chart, the Reason for Delegation field appears blank. The information you entered is recorded in the History tab.

**Substituting Resources**

You can use the Actions > Substitute Resource command to substitute one resource for another.

**To substitute one resource for another:**

   Alternatively, 
   Click Substitute button in the Team tab.
2. In the Substitute Resource dialog, select a Resource to Remove from the list. The list contains all team members including those assigned to child activities.
3. In the Substitute To Resource palette, select a Replacement Resource.
4. If you want to substitute the resource in all the child activities, select the Apply to Children checkbox.
5. Click Substitute. The replaced resource’s role is assigned to the substituted resource.

**Note** You can substitute a resource on a completed activity only if the % allocation is zero. For information on working with the Address Book Palette, refer to the Address Book Palette on page 46. In the Substitute To Resource palette, the user groups that are already added to the team table are not available for selection, in the drop-down menu. Similarly, the Search within a User Group option in the drop down menu does not display the user groups already added to the team table.
Searching for Timesheets

You can search for timesheets only if you have the Update All Timesheets privilege and you log in as Administrator.

To search for timesheets:

1. On the Timesheet tab, click More >Timesheet Search.
   
   You can search for timesheets by one or more of the following attributes:
   
   - **User(s)** - Launch the Timesheet search users to select a resource, or several resources.
   - **Programs** - Launch the Timesheet search Programs to select a project, or several projects.
   - **Date Between** - Launch the Calendar to choose the From and To dates. This displays the timesheets that fall within a particular period.

   **Note** A blank search, where you do not choose any attributes as criteria, will return all timesheets recorded in the system.

2. Click Search. The search results display in a table.

3. To sort the results by a listed attribute, click on the relevant column heading. By default, the list is sorted by Name.

4. To export selected rows to another project for analysis or computing in the Comma Separated Values format, click Export(csv). To export selected rows to another project for analysis or computing in the Microsoft Excel format, click Export(xls). You can then download the results to a local drive on your computer.

5. To print search results, click Print.

Managing Schedules

Managing schedules in PPM involves:

- Creating dependencies between activities or projects
- Rescheduling project dates
- Creating baselines

You can establish dependencies between activities within your project schedule. A dependency between activities mandates that one activity's schedule is driven by the predecessor's schedule. You can also establish and change dependencies using the Gantt Chart. See Creating and Editing Dependencies.

Creating and Editing Dependencies

Dependencies in Agile PPM control the schedule timing of any two tasks in a project time line linked through a dependency. Dependencies do not control the activity in those tasks. To control the activity between two activities and/or gates, you can use content relationships and rules.

Dependencies can be offset positively or negatively through the use of a time buffer.
Creating and Editing Dependencies in Web Client

The Dependencies tab in the Agile Web Client displays a list of all the predecessor (Dependent Upon) and successor (Required for) activities in the project. The Web Client also allows you to create external dependencies to other projects and tasks not in the current project time line. If you establish such external dependencies, links to these also appear.

This tab page has the following buttons:

- **Add** - Enables you to add a dependency to the selected activity. Dependencies can be made between activities in the same project or other projects.
- **Remove** - Deletes the selected object. The Remove button affects only the selected activities in the current page.

Navigate to the activity for which you want to create dependency.

**To create dependencies:**

1. Click the Dependencies Tab.
2. Click **Add**. The Add Dependency dialog appears.
3. In the Root Project palette, select the Root Project which has the predecessor activity.
4. In the next dialog, if you want to view a filtered list of Activities, select the Type of the predecessor activity. The default selection is ‘All’.
5. Click **Continue**.
6. In the Activities palette, select the predecessor activity.
7. In the Type list, select a dependency relationship.
8. Enter the Time Buffer between the finish of the Predecessor activity and the beginning of the successor activity, if required.
9. Click **Finish**.

For quick editing of dependencies, use the Gantt Chart view. See also Creating and Editing Dependencies in Gantt on page 94.

**Note** You can create external dependencies only in Web Client.

For information on types of dependency relationships and time buffers, see Establishing Dependencies.

Creating and Editing Dependencies in Gantt

You can create a dependency between two activities in the Gantt Chart. By default, all project schedules begin on the start date of the first task and finish based on the date of the last task to complete. When dependencies are created, the Gantt Chart adjusts the schedule appropriately. Dependencies can change the project’s finish date.
To create a dependency:
1. Click the Create Dependency icon on the toolbar. The cursor turns into a cross-hair pointer.
2. Drag the cross-hair pointer from the start point of the task to its end point. The direction you drag and the start point or end point of the task you select determines the dependency type.

Note If you need to create a dependency between two tasks that are not close to each other, you can type the dependency directly into the predecessor column. Type the predecessor's task ID no. (shown on the right-hand side of the tabular view) in the Predecessor column in the tabular view pane.

You can also create a Dependency using the Edit > Create Dependency menu command.

To edit a dependency:
1. Double-click the dependency arrow link on the graphical view of the Gantt Chart or select Edit > Edit Dependency.
2. Select the type of dependency from the Types drop-down menu.

Types of Dependencies

There are four types of Dependencies:

- Finish to Start (FS)
- Start to Start (SS)
- Finish to Finish (FF)
- Start to Finish (SF)
For example, if the Predecessor task is **Task A** and the Successor task is **Task B**:

- **Finish to Start**: In an FS scenario, the Schedule Finish date of Task A determines the Schedule Start date of Task B.
- **Start to Start**: In an SS scenario, the Schedule Start date of Task A determines the Schedule Start date of Task B.

**Note** If you want to maintain a schedule which enforces the parallel scheduling of tasks, use the SS dependency type.

- **Finish to Finish**: In an FF scenario, the Schedule Finish date of Task A determines the Schedule Finish date of Task B.
- **Start to Finish**: In an SF scenario, the Schedule Start date of Task A determines the Schedule Finish date of Task B.

**Dependency Time Buffer**

A buffer can be inserted to maintain a gap between a predecessor and its successors. Positive or negative values are accepted for the buffer.

When creating or editing a dependency, you can enter a value in the **Time Buffer** field that represents “slack time” between the control dates of the predecessor and successor activities or gates.

You can also create and change dependencies from the Gantt Chart view. See [Creating and Editing Dependencies in Gantt](on page 94).

**Editing Display Order**

You can change the order in which tasks or phases appear on the **Schedule Page** tab.

**To edit the sequence of the Program elements on the Schedule tab:**

1. On the **Schedule** tab, select **More > Change Display Order**. The Change Display Order dialog appears.
2. In the boxes in the **Order** column, enter a number that represents the order in which you want the corresponding project elements to appear on the **Schedule** tab.
3. Click **Save**.

**Rescheduling a Program**

While other Schedule tab edit functions allow you to select and modify rows in the schedule table, the **More > Move Schedule** menu acts on the currently displayed object only, not on the rows in the schedule table.

**To reschedule your Program:**

1. From the Schedule tab, select **More > Move Schedule**. The Move Schedule Dates dialog opens.
2. To move the scheduled dates of a project element, do one of the following:
   - Select the **Start Date** or **End Date** options and use the calendar to select new dates.
• Select the Forward or Back options, as appropriate, and specify the number of days by which the schedule needs to move.

3. Click Save to reschedule the project.

When you move the end date of a project to reschedule it, errors occur if there is slack between the activities. To avoid this, you can do either of the following:

- Quantify the slack in the Time Buffer field. See Dependency Time Buffer on page 96.
- Remove slack. The quickest way to do this is to launch the Gantt Chart for the project and use the Edit > Remove Slack command. This action adjusts project dates to give you a 'best fit' schedule.

Note This error can also occur if you reschedule a parent project by moving the end date and the end dates of any child activities fall on weekend dates.

Creating a Baseline

You can create Baselines to capture schedule and resource snapshots of a project at regular intervals of time, for project tracking. Baselines are permanent reference points against which you can compare the updated task structure and changes to schedule, budgeted costs, and resource allocations. To be able to create baselines, your Agile administrator must assign you Modify privilege on the Schedule.Name attribute.

Baselines can be created only on the root project object. If you want to take snapshots of extensive project data during the planning phase, you need to save multiple baselines. For example, you may want to do this at major planning milestones.

When you open the project, all saved baselines for that project appear in the Version list on the Schedule tab. Baselines are versioned for easy identification.

To compare the current project against a saved baseline, select it in the Version list. The details of the selected baseline are displayed next to the Version field.

Note If the baseline description exceeds 15 characters, it appears truncated. To view the complete description, place the cursor over the truncated description. A tool tip displays the complete baseline description.

You can create two types of special baselines:

- Kickoff Baseline: This is the very first baseline of a project. The kickoff baseline can be used as the preliminary version, against which you can compare the subsequently created baselines. Agile PPM provides you the option to mark the current version of a project as a kickoff baseline when you perform any of the following actions:
  • Create a new baseline from the Schedule tab.
  • Create a new project from a template.
  • Change the Template setting on the General Info tab of a project to Active.
  • Save a project using the Save As command on the Actions menu.

- Plan Of Record: This is a special type of baseline which you may want to create at major milestones during the execution of the project.
Note: The version number of a kickoff baseline and/or a plan of record baseline appears suffixed with an asterisk ("* ").

To create a baseline:
1. From the Schedule tab of a root project, click Create Baseline on the drop-down menu adjacent to the Baseline list.
2. In the Create Baseline dialog:
   a. Enter a Description for the baseline. This description appears in the Baseline list.
   b. To mark it as your Kickoff Baseline, select the Kickoff Baseline check box.
   c. To mark it as a Plan of Record baseline, select the Plan of Record check box.
   d. Click Save to save the baseline.

To remove a baseline:
1. Select the baseline in the Version list.
2. Click Remove Baseline on the drop-down menu adjacent to the Baseline list.

When you remove a baseline, the references to the baseline for all objects in the tree are also removed.

Comparing Baselines

Baseline comparison can be done using either of the following:
- Using the Compare Baselines feature.
- Using the Baseline Comparison report.

To compare baselines using the Compare Baselines feature:
1. From the Actions menu of a project, click Compare Baselines. A new window displays all the baselines created for the project.
2. Select a baseline. A list of baselines against which you can compare the selected baseline appears to the right.
3. Select a baseline from this list for comparison. You can compare the selected baseline only against the current project, or against a baseline that was created after the selected baseline.
4. Click Compare. A new window opens, showing a comparative view of the selected baselines. Activities that have been modified, added or deleted are indicated by the colors shown in the legend below the table. A 🔴 icon indicates a modified object.
   - To see details of changes made to an activity or gate, click its name. A pop-up window shows General Info, Schedule and Resource information with old and new values. Scroll down to see all changes.
   - To view details of any modifications made to your project schedule, allocated resources, or General Info fields, click the appropriate icon in the respective column.
To compare baselines using the Baseline Comparison Report:
1. In the left navigation pane, choose Analytics and Reports.
2. Under Standard Reports, navigate to Program & Portfolio Reports > Program Reports, and choose Baseline Comparison Report.
3. Execute this report to compare selected baselines. For more information on running reports, see related documentation in Getting Started with Agile PLM.

Managing Discussions

Managing Discussions in PPM involves:
- Adding, viewing, and joining a discussion
- Replying to discussions
- Viewing action items that were assigned during a discussion

Discussions Table

The Discussions table in Collaboration > Discussions tab displays important information about each discussion. The column heading with the action item 📝 icon indicates 🔴 on the rows which have action items associated with the Discussion. Click the 🔴 icon or click the Subject of the discussion to open it.

Adding Discussions

You can add a new discussion or reply to an existing discussion from the Web Client.

To add a new discussion:
1. Open the activity, and click Collaboration > Discussions tab.
2. Click Add and choose the 📝 Create New icon.
3. In the Create New dialog, select Discussion from the Type drop-down list.
4. Enter a Subject for the discussion.
5. Type the Message you want to send.
6. From the Priority drop-down list, set the discussion priority.
7. In the Notify List palette, select the users who need to receive notification of this discussion.
8. Click Add.

To search and add an existing discussion:
1. Open the activity, and click the Collaboration > Discussions tab.
2. Click Add and choose the 🔍 Search option.
3. In the Discussions Search palette, search for one or more existing discussions.
4. In the search results, double-click on the discussions you want to add to the activity.
You can run multiple searches to find and select additional discussions.

**Replying to Discussions**

You or your team members or notified users can reply to discussions.

**To reply to discussions:**

1. Open the activity, and click the **Collaboration > Discussions** tab.
2. Click the discussion name to open it.
   
   **Note** In the **Schedule** tab of the root project object, the discussions column indicated by 🔄 icon, displays the symbol 🔴 for all activities that have discussions.
3. On the **Discussions** tab, select the discussion you want to reply to.
   
   **Note** You can view the discussion thread in the preview pane just below the Discussion table on the **Collaboration > Discussions** tab.
4. Click the **Reply** button in the preview pane. Enter your message and the list of people to notify, and click **Send**.

**To add a comment to an existing reply:**

1. Open the activity, and click the **Collaboration > Discussions** tab.
2. Click the 🔄 symbol in the discussion row for which you want to add a comment. In the discussion page, the **Discussion** tab displays the reply thread.
3. Click **Reply** to add a comment to the existing response.
4. Modify the subject, type a Message, and select the users to notify, if required.
5. Click **Send**.

Your reply is added as the latest response in the ongoing discussion thread.

**Replying to Discussions from your Home Page**

When a discussion appears in your Notifications tab on the home page, you can open the discussion object and either add a reply or add a comment to an existing reply.

**To reply to Discussions from your Home page:**

1. In your **Notifications** tab, click the link in the **Regarding** cell on a discussion row to open the discussion item.
   
   **Note** The 🔄 icon identifies the discussions in the Notification table.
2. In the **Discussion** tab of the Discussion page, click **Reply**.
3. Add the reply message and the list of people to notify, and click **Save**.
Replying to Discussions from the Project Summary Page

A list of recent discussions specific to the project appears in the Summary page of a project.

To reply to a discussion from the Project Summary page:

1. Navigate to the Summary page of a project.
2. In the Recent Discussions widget, select a discussion row to view the discussion thread within the widget.
3. Click Reply to respond to the discussion.
4. Modify the subject, type a message, and select users to notify in the Reply to Discussion window.
5. Click Send.
6. Click Cancel to exit from the Reply to Discussion window without sending the response.

Viewing Discussion Replies

In the Web Client, navigate to the program or project page to view the replies to a discussion.

To see a list of replies to a discussion

1. Click Summary.
2. In the Recent Discussions widget, click a discussion to view the reply thread.

Alternatively:

1. Within the Collaboration tab, open the Discussion view.
2. Click the icon or the subject of discussion on any row. The discussion page appears with the reply thread.
   Or
   Click a discussion row to view the reply thread in the preview pane below the Discussion table.

Removing Discussions

After you finish all your discussions, you can remove the discussion objects.

To remove discussions:

1. Open the activity, and click the Collaboration > Discussions tab.
2. Select the discussion row you want to remove.
3. Click Remove.

The discussion object is removed from the activity.

To delete discussions from the Actions menu:

1. Open the activity, and click the Collaboration > Discussions tab.
2. Click the Subject of discussion. The discussion page appears.
3. Click Actions > Delete menu.
4. Click **OK** on the Confirmation message box.

The discussion is deleted from Agile PLM database, if this discussion is not active in any other PPM activity.

**Viewing Action Items**

In the Web Client, you can access action item details from the **Collaboration > Action Items** by clicking the name of the action item.

- The list of action items in the table is a combined list of the action items associated with the project and the action items associated with the listed discussions.
- The **Belongs To** column and icon indicate whether the action item is associated with a discussion object or with a project object. Click the link in the **Belongs To** column to open the object.

Click the name of the action item in the **Subject** column to open the action item.

**To add an Action Item:**

1. Open the activity and click the **Collaboration > Discussions** tab.
2. Click **Add**.
3. In the **Create Action Item** dialog, enter the action item information. Fields that are in **boldface** are required.
4. Click **Create**.

The action item will appear in the **Notifications** and **My Assignments** tabs of the user to whom it is assigned.

**Note**
The **Action Items** tab displays all action items related to the current activity, including those action items created on the associated discussion objects. If you have configured flex fields for the activity class, ensure that the same configuration is done for the Gates and Discussions classes as well. The list values that display in the flex fields columns of the Action Items table will be the values you configured for the activity class.

**Archiving Projects**

Projects are archived by changing the root-level project’s archive status.

You can change the archive status of a root-level project from the **Actions** menu. Archiving old data can improve system performance. The archived project’s data remains searchable.

**Note**
Archiving requires the **Projects-Generalinfo- Archived** attribute enabled for the **Modify All Projects, Programs, Phases, Tasks and Gates** privilege in Java Client.

**To change the archive status:**

1. Select a root-level object.
2. Select **Actions > Archive**.
3. You can optionally specify the reason for this action, for later use (Filtering data for reports, for example.). This information is stored in the History tab of the object.
   - In the Reason Code field, select an option from the list.
   - In the Comments field, enter comments as appropriate.

   **Note**  This option becomes available only if the corresponding SmartRule is enabled in Java Client. For details, see the *Agile PLM Administrator Guide*.

When a project is archived, it is removed from all active project lists and from the project navigation tree. All buttons and Actions menu choices are grayed out, except for Actions > Unarchive. You can select this option to remove the archive status.

   **Note**  You can also change the archive status for Completed and Canceled projects.
Accepting Assignments

You can use the Home page My Assignments tab Accept function to accept multiple activities or action items at one time. The accept action applies to:

- Activities where you are the delegated owner.
- Project activities assigned to you.
- Action items whose status is Not Accepted and you are the assignee.

To accept assignments on the My Assignment tab:

1. Click the Home button 🏡 to display the Home page.
2. Click the My Assignments tab to display your list of assignments.
3. Select one or more rows in the table.
4. Click the Accept button.

   The selected objects are accepted.

Declining Assignments

You can use the Home page My Assignments tab Decline function to decline multiple activities or action items at one time. The decline action applies to the:

- Activities where you are the delegated owner.
- Action items whose status is Not Accepted and you are the assignee.

Note When you decline an activity, you must enter a reason.
To decline assignments on the My Assignment tab:

1. Click the Home button  to display the Home page.
2. Click the My Assignments tab to display your list of assignments.
3. Select one or more rows in the table.
4. Click the Decline button.
5. If one or more of the selected rows are activities, you must enter a reason why you are declining the activities. Enter your reason in the pop-up dialog and click Send.

Editing Assignments

You can edit the assignment attributes in the My Assignments tab table. You must have the appropriate Modify privileges for the editable fields.

For example, depending on your privileges, for an activity, you can edit the Status, Percent Complete, Actual Hours, and Due Date.

To edit My Assignment table rows:

1. Click the Home button  to display the Home page.
2. Click the My Assignments tab to display your list of assignments.
3. Locate the row of the assignment you want to edit.
4. Within the row, double-click a table cell to make the field editable.
5. Make the desired modifications.

Note: The editable fields are determined by which fields your Agile administrator has included in the assignments table and your modify privileges.

6. To duplicate an existing cell value across multiple cells:
   1. Select the range of cells that you want to fill with the same value.
   2. To deselect a cell within the range, press CTRL and click on the cell.
   3. From the More drop-down menu, choose Fill Up or Fill Down as appropriate.
   4. When you are finished, click Save.

Mark Assignments Complete

You can use the Home page My Assignments tab Mark Complete function to mark as complete multiple activities or action items at one time.

Note: If you have not accepted an action item, you cannot mark it as complete. Accept the action item first, then mark it as complete.

When you mark an activity as complete, the Percent Complete field is automatically set to 100%.
To mark assignments as complete on the My Assignments tab:

1. Click the Home button 🏡 to display the Home page.
2. Click the My Assignments tab to display your list of assignments.
3. Select one or more rows in the table.
4. Click the Mark Complete button.

The selected assignments are marked complete.

Flagging Assignments

On the Home page My Assignments tab, the flag icon included in each row is a useful assignment management tool. Because you can sort assignments according to whether or not they are flagged, you can use the flag to indicate assignments that you want to track differently from other assignments. The flags on your assignment table appear only on your My Assignments tab, so you can decide how you wish to use them.

To set or unset the flag in a single assignments table row:

1. Click the Home button 🏡 to display the Home page.
2. Click the My Assignments tab to display your list of assignments.
3. Click the flag icon in the row you want.
   - If the flag is not set 🟢, clicking it toggles the flag to set: 🟢.
   - If the flag is set 🟢, clicking it toggles the flag to not set: 🟢.

To set the flags in multiple assignments table rows:

1. Click the My Assignments tab to display your list of assignments.
   - If desired, use the Views drop-down list or the filter to sort which assignment rows are displayed.
2. Select the rows you want to flag.
3. Choose More > Add to Flagged View.

To unset the flags in multiple assignments table rows in the flagged view:

1. Click the My Assignments tab to display your list of assignments.
2. In the Views drop-down list, choose Flagged.
3. In the flagged assignments view, select the rows you want.
4. Choose More > Remove from View.

Reporting Time

A resource who has been assigned tasks on one or more projects can use the Timesheet feature to report actual hours spent on each task. Reporting can be done on a daily or weekly basis. To be able to report time, the Detailed Timesheet Entry SmartRule must be set to Allow in Java Client, and
Timesheet tab visibility must be enabled in your user preference settings.

When a team member enters time data against a particular project task in the Timesheet, the hours reported are added to the Actual Hours recorded on the Team tab for that task. The labor cost and any other information impacted by the number of hours this resource has worked on the project are then automatically recalculated.

**Note** You can only report time against a leaf-level task that is In Process. You cannot report time against a root project. Only In Process tasks will be displayed in the Timesheet tab.

To **report time against a particular task**:

1. In the Timesheet tab, select the row for the task.
2. Enter actual hours worked in the columns for each day of the week. Double-click within the cell to make it editable. You can also simply fill in the **Total** column with actual hours for the whole week. For example, if you fill in 40 hours in the **Total** column, this value is equally distributed as 8 hours each for Monday through Friday.
3. Click **Save** to save your data.

**Subscribing to Events**

The events you can subscribe to vary per object. Product Portfolio Management has the following Activity-specific subscription events that do not apply to other objects:

- Add Discussion
- Reply to Discussion
- Add News
- Add Action Item
- Modify Schedule

The **Apply to Children** checkbox in activities and gates “push” a subscription to all child objects. If you subscribe to an activity that has a schedule and select this checkbox, you will automatically subscribe to all of the activity's projects, programs, phases, and tasks (that is, any object created in the out-of-box subclasses of Activities class). Since **Page Two** and **Page Three** fields can be defined differently for projects, programs, phases, and tasks, any of the attributes that do not apply are ignored.

**Changing Workflow Status**

The workflow status of leaf objects (objects that have no children) can be changed using the **Change Status** button. The status of parent objects cannot be changed directly, since it is changed by rolling up the status from leaf-level objects. You must have the appropriate privileges; by default, the Program Manager and Program Administrator roles have the required privileges.
The **Change Status** button is only available for objects whose **Template** field is Active in the **General Info** tab. You cannot change the status of objects whose **Template** field is Proposed or Template. Changing the **Template** field must be done at the parent level, and child objects are automatically moved to the **Template** value of the parent.
Status Tracking

Agile PPM enables project status tracking according to criteria set up within Agile Java Client Administrator. Health Status values are rolled up for all objects that are configured to report health status. To ensure health status values are rolled up, the Rollup Health Status attribute must be set to Yes in the object’s General Info tab.

The following status elements are rolled upward:

- Overall
- Schedule
- Cost
- Resource
- Quality

Parent objects derive their status from the status of their child objects. If any one child of a project object is Off Track, the parent project is set to Off Track. If the Quality Status of a child object is Below Quality, the parent object is also set to Below Quality. Health attributes are maintained in Java Client Administrator settings, and each value has an activation period or value.

Default Health Statuses

The following table shows default schedule, cost, resource, and quality health statuses.

<table>
<thead>
<tr>
<th>Status</th>
<th>Values</th>
<th>What triggers change?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overall</td>
<td>On Track (green), Needs Attention (yellow), Off Track (red)</td>
<td>Corresponds to the most negative setting of the four health statuses for any project. If any one of the other statuses is red, Overall status will be red.</td>
</tr>
<tr>
<td>Schedule</td>
<td>On Track (green), Needs Attention (yellow), Off Track (red)</td>
<td>Within the Java Client you can create a setting to trigger a health status change if there is schedule slippage of a certain number of days. The default setting for the Health Status to change from Not Started or On Track to Needs Attention is 1-5 days. If the task is overdue for more than 5 days, the status changes to Off</td>
</tr>
<tr>
<td>Status</td>
<td>Values</td>
<td>What triggers change?</td>
</tr>
<tr>
<td>--------</td>
<td>--------</td>
<td>-----------------------</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Track. To learn how to configure these settings, see the <em>Agile Administrator Guide</em>.</td>
</tr>
<tr>
<td>Cost</td>
<td>On Budget (green), Off Budget (yellow), Over Budget (red)</td>
<td>Cost status is calculated based on the percentage of deviation from the original cost as set in the cost status node in Agile Administrator.</td>
</tr>
<tr>
<td>Resource</td>
<td>Staffed (green), Understaffed (yellow), Not Staffed (red)</td>
<td>Resource status is an editable field in the General Info tab of a project object which can be edited by a user with appropriate privileges, usually the project owner.</td>
</tr>
<tr>
<td>Quality</td>
<td>Meets (green), Below (yellow), Poor (red)</td>
<td>Quality status is an editable field in the General Info tab of a project object which can be edited by a user with appropriate privileges, usually the project owner.</td>
</tr>
</tbody>
</table>

### How Status Roll-Up works

A number of attributes are passed upward from child objects to parents, in a process called rolling up.

The attributes that are rolled up include:

- Activity workflow status
- Health statuses
- Scheduled dates and scheduled duration
- Actual start/end dates and actual duration
- Estimated start/end dates and estimated duration
- Days effort
- Percent complete

The rolling up of values starts with leaf nodes (child objects that have no children) that are not either Complete or Canceled, and moves upward to parent objects. If any leaf node object is determined to be Off Track, the parent object is considered to be Off Track.

Parent object fields that reflect rolled-up status of child objects, such as Days Effort or Scheduled Dates, cannot be edited because it is automatically rolled up from lower levels in the hierarchy. Status can only be edited at the lowest levels (leaf nodes).

**Note**  
The only way you can change the status of a parent object at the project level is to cancel the project using the *Actions > Change to Canceled* menu command. Once canceled, a project can be reset to the Not Started state, using *Actions > Change to Not Started*.  

---

**Status**

**Values**

**What triggers change?**

- Track. To learn how to configure these settings, see the *Agile Administrator Guide*.

- Cost status is calculated based on the percentage of deviation from the original cost as set in the cost status node in Agile Administrator.

- Resource status is an editable field in the General Info tab of a project object which can be edited by a user with appropriate privileges, usually the project owner.

- Quality status is an editable field in the General Info tab of a project object which can be edited by a user with appropriate privileges, usually the project owner.
Workflow Status

Agile Web Client uses a workflow stamp in the upper right of the General Info tab to indicate the workflow status of an activity. The Agile administrator defines the name of each status in each workflow.

The default project workflow statuses are:

- Not Started
- In Process
- Complete
- Canceled

Your company may have its own customized workflows and status stamps, as displayed in the Workflow tab. For further information see "Workflow Routings".

If a user has the appropriate privileges, they can use the Change Status button to change an activity’s status, promoting it to the next lifecycle state.

**Important** Since lifecycle status of parent objects is rolled up from lower levels, you can only use the Change Status button to change status on individual leaf node objects (objects with no children). You cannot promote an activity whose Template field setting is Template or Proposed.

Rules for Parent Status

The following rules apply for parent object status change:

- Parent object workflows are affected when any of the related child workflows start. For example, if one child activity is in the In Process state, then Parent status is In Process.
- Parent object workflows are affected when all related child objects workflows complete. For example, if all activities are Complete, then parent status is Complete.
- When custom workflows are used, the rollup is governed by the transition between the Status Type, not necessarily a change in the step. For example, a workflow with seven steps can roll up to a parent with three steps because each has only one transition between the “Pending” and “Review” type (Pending, Review, Complete, and Cancel are the Status Types).

For leaf-node objects, you can click the Change Status button to change the workflow status (provided you have the required role).

To change the workflow status of the parent activity, open a leaf-level child activity and click the Change Status button to change the workflow status of the leaf-level activity.

**Note** You cannot use the Change Status button to change the workflow status of an activity that has children (subordinate activities).

For more information about workflows, see Getting Started with Agile PLM and the Agile PLM Administrator Guide.
Cost Status

Agile PPM enables you to calculate four types of project costs as listed below. Each of these costs have Actual, Budgeted and Estimated categories. There are 12 cost fields in total; all appear on the General Info tab.

- **Labor Costs** - Actual and Budgeted Labor costs are automatically calculated. Budgeted Labor Cost uses scheduled duration, % allocation, and the users’ resource pool rate, and man hours (8 hours per day) to calculate labor cost per resource assignment. These are summed for multiple resources assigned to an activity.

  If an activity has a resource assigned, and has lower-level objects with Labor costs, then it is summed at the parent level and not replaced. Budgeted and Actual Labor Costs are always calculated in this way. However, Estimated Labor Cost can be editable at all levels. If not edited, it is rolled up by default.

- **Capital Expenses** - Can be both rolled up, as well as edited values, depending on whether the Agile administrator has enabled the Calculate/Roll-up flag on each cost field.

- **Fixed Costs** - Works in the same way as Capital Expenses.

- **Flex Costs** - These cost fields can be customized as per your business requirement in Administrator. For example, you could call it Setup Costs, and use it for calculation of project setup costs. Works in the same way as Capital Expenses and Fixed Costs.

**Note** While calculating labor costs, if a Resource is not assigned to a Resource Pool, the user’s individual Labor Rate is used. The labor rate must be defined for the resource in the User Settings before you add the resource to a project.

How Total Cost is Determined

Total Cost fields that appear on the General Info tab are calculated values and cannot be edited. Total Cost is the sum of the four cost types: Labor Cost, Capital Expenses, Fixed Cost and Flex Cost.

For example, Total Actual Cost is the sum of:

- Actual Labor Cost
- Actual Capital Expenses
- Actual Fixed Cost
- Actual Flex Cost

In the same manner, Total Estimated Cost is the sum of Estimated Labor Cost, Estimated Capital Expenses, Estimated Fixed Cost, and Estimated Flex Cost. Total Budgeted Cost is the sum of Budgeted Labor Cost, Budgeted Capital Expenses, Budgeted Fixed Cost, and Budgeted Flex Cost.

By default, cost information for each field will be rolled up through the project structure such that cost at the summary or parent task is a summation of the cost values of its child objects. If cost (Budgeted Labor Cost and Actual Labor Cost) is incurred at the Summary task level, then the cost is the summation of costs at the summary task level and the child levels below the summary task. There are flags (not visible by default) that can be enabled to allow users to determine whether or
not they want the parent/summary task's values to be calculated/rolled up or edited manually.

As you can see in the example below, if a cost is associated with the leaf node it gets added to the parent node. The total cost of the entire Program can be obtained in this manner.

In this diagram, the cost for Phase 2 is $30, which is the sum of the costs for its leaf-level objects. You can also edit Cost at the parent node level for Phase 2.

**Costs Included in Baselines**

All Cost fields are part of the baseline. Ten Calculate flags are also baselined. Budgeted and Actual Labor costs do not have the calculate/roll-up flags as they are always calculated and rolled up. See also [Enabling the Calculate Attributes](#) on page 135.

Use the Baseline Comparison Report in the Agile Standard Reports to compare these values.

**Reports**

**About Agile Standard Reports**

Reports allow you to display the values of your Agile projects and product records. By accessing this information and summarizing it in a meaningful way, reports provide insight into your business
processes and can help guide better-informed decisions. Agile PLM provides a robust reporting platform that allows you to:

- Measure and monitor business performance using standard out-of-the-box reports. These standard reports capture the best practices in product lifecycle management business processes.
- Configure reports with Agile’s custom reporting to obtain the specific information you need.
- Use a single point of access to all relevant reports—even those developed outside of the Agile PLM application—through Agile’s external reporting capability.

For detailed information about using all types of Agile reports, see the *Getting Started with Agile PLM Guide*, which includes information about:

- How your roles and privileges affect reports
- Report object tabs
- Creating and modifying report layouts
- Creating custom and external reports
- Running, scheduling, saving, and deleting reports
- Report output window

**Note** Your browser may have default security settings that compromise report display. If you are using Internet Explorer with Windows XP, add the Agile site URL as a trusted site within the *Tools > Internet Options > Security* tab to enable proper downloading of reports.

### Agile Standard Reports for PPM

This section discusses the Agile standard reports that are included as part of Agile Product Portfolio Management.

**To access project reports:**

1. In the left pane, click *Reports* to display the Reports folder structure.
2. Expand the *Reports and Analytics* tree and navigate to *Standard Reports > Program & Portfolio Reports*. Agile PPM standard reports are organized into subfolder under the *Program and Portfolio Reports* folder.
3. Click on the report you wish to view. Available reports are listed here for your reference. For details on selecting report parameters, using searches, and executing reports, see the *Getting Started with Agile PLM Guide*.

**Note** Reports for projects that are Complete or Canceled are not listed for selection.
<table>
<thead>
<tr>
<th>PPM Report Folder</th>
<th>Report</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Project Reports</strong></td>
<td>Project Schedule</td>
<td>The schedule report of all the activities of the selected root project.</td>
</tr>
<tr>
<td></td>
<td>Project Off Track Activities</td>
<td>Report of all the activities based on the selected health status within the selected root project.</td>
</tr>
<tr>
<td></td>
<td>Project Top Discussions</td>
<td>Report of all open discussions with priority you select, within the root project you select.</td>
</tr>
<tr>
<td></td>
<td>Project Open Action Items</td>
<td>Report of all the open action items associated with discussions and tasks of the selected root project.</td>
</tr>
<tr>
<td></td>
<td>Project Actual vs. Budgeted Cost</td>
<td>Report of the Actual Cost and Budgeted Cost for the selected project.</td>
</tr>
<tr>
<td></td>
<td>Project User Assignments</td>
<td>Report of assignments of a selected user within a selected root project.</td>
</tr>
<tr>
<td></td>
<td>Project Documents</td>
<td>Report of all the documents of the selected root project.</td>
</tr>
<tr>
<td></td>
<td>Project Deliverable Gate</td>
<td>Report of all the Gates and their dependent tasks and deliverables in the selected root projects.</td>
</tr>
<tr>
<td></td>
<td>Baseline Comparison</td>
<td>Report of comparison of the baselines for the selected project.</td>
</tr>
<tr>
<td></td>
<td>All Cancelled Activities</td>
<td>Report of all canceled activities that have been recorded in the system.</td>
</tr>
<tr>
<td><strong>End User Reports</strong></td>
<td>My Discussions</td>
<td>All open discussions owned by you with the priority selected when you execute the report.</td>
</tr>
<tr>
<td></td>
<td>My Open Action Items</td>
<td>All the open action items associated with issues and tasks that are assigned to you.</td>
</tr>
<tr>
<td></td>
<td>User Time</td>
<td>All the projects where the specified user has entered Actual Time.</td>
</tr>
<tr>
<td></td>
<td>My Documents</td>
<td>All the documents for which you are the Creator or Checkout User.</td>
</tr>
<tr>
<td></td>
<td>My Activities and Utilization</td>
<td>All your task assignments.</td>
</tr>
<tr>
<td><strong>Resource Pool Reports</strong></td>
<td>Pool Member Report</td>
<td>Report of all the resources of the selected resource pool.</td>
</tr>
<tr>
<td>PPM Report Folder</td>
<td>Report</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>----------------------------</td>
<td>------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>Resource Pool Consumption</td>
<td>Report of the resource pool consumption during the specified time period.</td>
</tr>
<tr>
<td></td>
<td>Resource Pool Utilization</td>
<td>Report of all your task assignments for all root projects and projects.</td>
</tr>
<tr>
<td><strong>Portfolio Reports</strong></td>
<td>Portfolio Status</td>
<td>Status report of all the root projects to which you have access.</td>
</tr>
<tr>
<td></td>
<td>Portfolio Cost</td>
<td>Cost report of all the root projects to which you have access.</td>
</tr>
<tr>
<td></td>
<td>Portfolio Cross Program Dependencies</td>
<td>Report of all the activities that have external dependencies.</td>
</tr>
<tr>
<td></td>
<td>Portfolio Deliverable Gate</td>
<td>Report of all the Gates and their dependent tasks and deliverables in the portfolio of root projects.</td>
</tr>
<tr>
<td></td>
<td>Portfolio Priority Discussions</td>
<td>Report of all the open discussions in your portfolio of projects.</td>
</tr>
</tbody>
</table>
This chapter includes the following:

- Before You Begin .................................................................................................................. 119
- Working with Imported Microsoft Project Files ..................................................................... 119
- Working Offline on a PPM Project ........................................................................................ 121
- Microsoft Project Troubleshooting Tips .............................................................................. 122

Agile PPM supports integration with Microsoft Project to enable customers to publish projects from Microsoft Project into PPM and vice versa. As a best practice, it is recommended that customers use the Gantt Chart in offline mode instead of Microsoft Project, as the editing of Page One, Page Two, and Page Three attributes is not supported in Microsoft Project.

Before You Begin

- Make sure all your Microsoft Project team members exist in the Agile database
- If your work site has previously used PPM 8.5 or 9.0, uninstall the 8.5 or 9.0 macros.
- Make sure you have the Microsoft Project Privilege assigned to you by your Agile administrator.

To uninstall the Agile PPM 8.5 or 9.0 macros:
1. Open Microsoft Project.
2. Select Tools > Organizer > Modules.
3. Open Global.mpt and delete the Get File and XML macros.

Working with Imported Microsoft Project Files

You can import a project in Microsoft Project file format into Agile PPM and vice versa. This section describes this feature in detail along with the requisites such as Synchronization with Microsoft Project and Mapping of Resources.

If you have Microsoft Project 98 or 2000 project files with which you would like to work, open them in Microsoft Project 2002 or 2003 to automatically convert the project files to the appropriate format. For more information, select Help > Microsoft Project Help in the Microsoft Project menu.

Setting Up Microsoft Project Synchronization

To begin using the Agile menu in MSP, you must have launched a PPM project from Agile PLM to Microsoft Project at least once. The Agile plug-in is automatically installed when you first launch a PPM project to Microsoft Project.
The figure below shows the Agile Menu item on the Microsoft Project menu.

Creating a PPM Project from an Existing Microsoft Project File

You can use an existing Microsoft Project plan that contains only one Level 1 task, as the basis for an Agile PPM project object. (All tasks must be rolled up under a single project; PPM transforms that project into the root project object.)

**To create a PPM project from an existing Microsoft Project file:**

1. Open the target file in Microsoft Project.
2. Choose Agile > Publish to PPM. The Agile PLM Publish page appears.

Alternatively, you can save the Microsoft project file as an .xml file and use this file to publish the project.

**To create a PPM project from an existing Microsoft Project file saved as an .xml file:**

1. Open the target file in Microsoft Project.
2. In the Microsoft Project menu, select **File > Save As** to save the project file as an .xml file.
3. Move to the Agile **Tools and Settings** menu and select **Microsoft Project Publish**.
4. In the dialog that opens, browse and locate the Microsoft Project .xml file you want to publish.
5. Click **Publish**.

**Important** If you want PPM to take care of the scheduling for a project published from Microsoft Project, you must ensure that the Schedule Editor is set to PPM in the Web Client. You can reset the Schedule Editor in the project's General Info tab.

Mapping Resources

If your Microsoft Project file contains users or user groups that are not in the Agile system, you are prompted to map these resources to existing users during the publish process.

In the Map Resources dialog, the **File Resource** column lists the unmapped users. Use the search palette in the **System User** column to locate the appropriate Agile system users to whom you want to map these resources. You can also optionally assign roles to each of the mapped users in the **Assign Role** column.

When you finish mapping resources, click **Publish** to complete publishing.
Launching a PPM Project in Microsoft Project

You can launch a PPM project in Microsoft Project if you have the appropriate privileges. For details of required privileges, see the Agile Administrator Guide.

To launch a PPM project in Microsoft Project:
1. Open the project you wish to launch.
2. From the Actions menu, choose Microsoft Project > Launch as Read Only or choose Microsoft Project > Launch in Edit Mode. Microsoft Project opens.
3. Specify that the file should be launched As a New Project.
4. Click Finish.

Read Only and Edit Modes

You can launch or save a PPM project in Read Only or Edit mode. The mode you choose can affect project data.

- **Read Only Mode**
  
  When you launch a PPM project in Microsoft Project using Launch as Read Only, it allows you to view, print, or analyze a PPM project in Microsoft Project without altering the project data in Agile PPM. In Microsoft Project you can perform any edit, modification, or analysis actions you choose. You can save the Microsoft Project file in any local or network directory to which you have access.

  You cannot, however, publish the launched-as-read-only project back into Agile PPM. When you launch as read-only, the PPM project is not locked, the Lock User field remains empty, and the Schedule Editor field remains set to PPM. It is therefore possible for another user to modify the PPM project by using any of the available Agile PPM edit methods: Edit in PPM, edit in Microsoft Project (Launch in Edit Mode), or edit in Gantt Chart.

  The Microsoft Project file that you create when you use Launch as Read Only is not updated or affected by any subsequent edits or modifications made to the PPM project file.

- **Edit Mode**
  
  When you launch a PPM project in Microsoft Project using Launch in Edit Mode, the PPM project is automatically locked so that no other user can modify it. Your name appears in the Lock User field, and the Schedule Editor field is set to Microsoft Project.

  You are able to publish the launched-in-edit-mode project back into Agile PPM.

  The same considerations apply when you save a PPM project using the Save As XML menu commands.

  For more information about locking projects, see “Multiple Users Editing the Same Task”.
Working Offline on a PPM Project

If you do not have Microsoft Project installed on your computer, you can save your PPM project to your local drive as an XML file, and work on it offline. You can access this file from a machine on your network which has Microsoft Project installed, view or edit it offline, and then publish your changes back to PPM when you are online again.

You can use either of the following commands to save your project as an XML file:
- Save as XML - Read Only
- Save as XML - Edit Mode
  
  For considerations that you should be aware of before you choose Read Only or Edit mode, see "Read Only and Edit Modes".

To save your project as an XML file:
1. Open the project you wish to save.
2. From the Actions menu, choose Microsoft Project > Save as XML - Read only or Save as XML - Edit.
3. Download the file to your local drive.

Note: If you are using Windows XP with Internet Explorer 7, default security settings for file downloads may result in duplication of History records during the Save as XML - Read only operation. To prevent this: Ensure that the Web Client URL is added under Tools > Internet Options > Trusted Sites > Sites. Under Custom Level settings, select Enable for "Automatic prompting for file downloads".

Microsoft Project Troubleshooting Tips

If Microsoft Project sync does not work, you may want to reinstall the Agile PPM menu. To do so, you need to manually remove the preexisting Agile menu by doing the following:

To see a list of active COM add-ins for Microsoft Project:
1. Go to Tools > Customize > Toolbars. The "Customize" window opens.
2. From the Commands tab, within the left-hand list, select Tools.
3. Locate "COM Add-Ins" in the right-hand list.
4. Drag and drop "COM Add-Ins" from the list onto the menu bar.
5. Close the Customize window.
6. Click the newly added COM Add-Ins menu. A list of all the installed add-ins is displayed.

To manually uninstall a COM Add-In from Microsoft Project:
1. Click the COM Add-Ins menu to see a list of COM Add-Ins.
2. Select the add-in you wish to uninstall.
3. Click the Remove button to uninstall the selected add-in.
Other things that might cause difficulty with integration:

- Split-task resource assignments
- Use of actual dates vs. scheduled dates
- Customized calendars and working days
- Constraint types such as Must Finish On are not maintained in the Agile system after you Publish from Microsoft Project. Therefore, launching the plan back into Microsoft Project will result in different dates than those in the initial Microsoft Project plan.
- Microsoft Project allows duration to be entered in hours. PPM uses days as the lowest unit of time. Therefore, accuracy issues are compounded with heavy usage of tasks that are less than one day's duration.
- The Agile PPM project name must be at outline level one in Microsoft Project. All Agile PPM subtasks, phases, and gates must be indented under level one in Microsoft Project.
- Within Microsoft Project, each resource for your project needs to be assigned a certain % allocation within the Resource tab of the relevant Task. The maximum value you can enter for this field is configured in Java Client. The default setting is 400. If you enter a value greater than the maximum value setting, errors result when you publish to PPM. This maximum value for % allocation can be reset in Java Client (Team attributes) if required.

**Note** Microsoft Project outline numbers are not imported into Agile PPM.

### Deleting Objects in Microsoft Project

You can delete projects, phases or tasks in Microsoft Project by using the Microsoft Project features.

When you update Agile PPM with the changes you have made in Microsoft Project, Agile PPM checks your assigned Delete privileges to ensure that you are allowed to delete projects, programs, phases, or gates in Agile PPM. If you have deleted activities in Microsoft Project that you are not allowed to delete in Agile PPM, none of your Microsoft Project changes are written to the Agile database, and you will see an error message telling you that you do not have the appropriate privileges.

**Note** If the publish to PPM fails because you do not have the appropriate Delete privileges, you will not be able to go back to the original project tree in Microsoft Project. However, you can go back to Agile PPM and launch Microsoft Project again.

If you are not able to delete specific types of PPM objects in Agile PPM, you will also not be able to delete them in Microsoft Project and update the Agile database.

### Transferring Microsoft Project Work Values to PPM

To ensure the accurate mapping of work values from Microsoft Project to a PPM project, some data manipulation is required.

- **Days Effort** - In Agile PPM, days effort is always calculated based on the % allocation and duration. Unlike in Microsoft Project, Agile PPM requires an allocation to a resource or resource
pool in order for days effort to be populated. To ensure that effort data values without resource or resource pool allocation are not lost while publishing tasks from Microsoft Project, your Agile administrator can set up and define a generic resource pool to hold the work/days effort values. If your Agile administrator has defined the generic resource pool, you will notice that tasks which satisfy these conditions have a generic resource pool associated to them on the Team tab.

- **Custom Subclasses** - While creating new tasks in MSP for a PPM project, you can override the default subclass values in the Text29 column with custom subclass values specified in the Java Client.

- **Page Two Attributes** - To ensure the correct mapping of Page Two attributes, you must edit the appropriate values in the MSP/Agile PPM mapping file (MSPSyncMapping.properties on the Agile server) provided by Agile. Page Three attributes cannot be mapped.

| Caution | Data in the Text30 column should not be tampered with, as this could interfere with the synchronization process and cause errors. |

For detailed information on any of the above, see the topic on Product Portfolio Management settings in the *Agile PLM Administrator Guide*.

| Note | Within Microsoft Project, the % allocation for a resource should be a value between 0 and 400 to ensure error-free data mapping. The default maximum value for the corresponding field in PPM is 400. If you wish to assign a higher value, you can change the default configuration for the Team attributes in Java Client as appropriate. To learn how to modify attributes, see the *Agile PLM Administrator Guide*. |
Chapter 8

Import and Export

This chapter includes the following:

- Importing Data .......................................................... 125
- Importing Projects and Project Content ........................................... 127
- Exporting Data ........................................................................ 130

Agile PLM provides the capability to import or export PLM data by the use of Import and Export wizards. To import or export Agile data, you must have the appropriate privileges.

For generic information on importing and exporting data in Agile PLM, see the *Agile PLM Import Export Guide*. If you have questions about privileges that are not covered in this guide, contact your Agile PLM administrator or refer to the *Agile PLM Administrator Guide*.

Importing Data

The Import wizard enables you to add and update large files (product content) from other formats into Agile PPM. Import not only brings in legacy data that is required to start your business processes within Agile, but also enables you to update product content periodically. The Import process must be implemented appropriately to reap the value of Agile solutions.

You can create large data source files and quickly upload them in bulk into Agile through the import procedures described here. Prior to import, you can set preferences to specify the conditions for import.

The Import Wizard allows you to import the following objects into Agile PPM:

- projects and project content such as Discussions or Action Items
- User Groups
- Users

**Note** Discussion and Action items can only be created and not updated. You cannot update or modify existing data.

Before You Begin

Before you import data from source files into Agile PPM:

- **Make sure you have the appropriate Agile PPM user license and privileges.** To import Agile data, you must have Create, Discover, Read, and Modify and Import privileges for each type of Agile object you are importing. You also need to have the Import privilege options enabled in Java Client. If you have questions about privileges, contact your Agile administrator or refer to the *Agile PLM Administrator Guide*. To launch Import, you must have the My User Profile role, Read User privilege and Import privilege.

- **Make sure you understand the specifications for each field.** Certain fields are mandatory; therefore
you need to map them in the Import wizard fields. Fields also have data types, which determine how the data should be formatted, and maximum lengths, which the Agile PPM system validates on import. These are set in the Import Wizard Preferences.

- **Make sure that your data is in the correct file format.** If you are importing data from text files, check your source data to make sure that it is in a supported file format, and matches the Import Preferences settings. For details, see “Supported File Formats”. To create aXML files, use Agile Content Service (ACS), Agile Integration Services (AIS), or create an aXML file from the Export command. You can view aXML files in any XML viewer, including Internet Explorer.

- **Make sure the Agile PPM system has sufficient hard disk space** for importing large data files or create an aXML file from Export Wizard.

**Persistence of Import Settings**

When you use the Import Wizard in Web Client, the data stays as long as you maintain the session. The settings that persist include:

- Import preference settings
- Source file configuration
- Selected content to import
- Selected mapping file
- Selected transformation file
- Selected change number

When you choose a different source file, the selected content, mapping file, and transformation file are reset.

**Importing Large Data Files**

Before importing a large file, clear the Log Transformations preference checkbox for faster results. If you are importing large amounts of data during one import session, you should perform the session during non-business hours - when system usage is low. After the import session is finished, you can view the log file in a browser or save it to a file.

For more information, see the *Import and Export Guide*.

**Supported File Formats**

You can import and export data in several file formats. The following file formats are supported:

<table>
<thead>
<tr>
<th>Use File Type</th>
<th>Description</th>
<th>To Import</th>
</tr>
</thead>
<tbody>
<tr>
<td>Delimited Text File (.dtf)</td>
<td>A standard flat text file where each field data is delimited by a special character, such as a comma or a tab.</td>
<td>Any object.</td>
</tr>
</tbody>
</table>
### Use File Type

<table>
<thead>
<tr>
<th>Use File Type</th>
<th>Description</th>
<th>To Import</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agile XML (.axml)</td>
<td>Agile's proprietary XML format that includes data not supported by PDX.</td>
<td>Users, User Groups, and Discussions</td>
</tr>
<tr>
<td>MS Project Export File (.xml)</td>
<td>XML data exported from Microsoft Project for import to Agile. For more information about this format, see the Agile Import and Export Guide.</td>
<td>Projects and project objects created in Microsoft Project.</td>
</tr>
</tbody>
</table>

### Data Transformation

Before you import data, you may need to transform the values in some fields to make them compatible with the Agile system. You can use a Transformation Definition file to perform this transformation. Transformation definition files are especially helpful for importing data from PDX or aXML packages. Generally, PDX or aXML packages are read-only. You cannot change the values contained in an archived file. If there are data inconsistencies in a PDX or aXML package, you must try to correct them using a transformation definition file.

A transformation definition file is a comma-delimited text file. Optionally, you can qualify text strings in the file using double-quotes ("'). The file must contain a set of required fields needed to transform import data.

The Import wizard does not support transformation definition files created with previous Agile Product Cost Management or Agile Product Collaboration releases.

Transformation definition files are optional for importing data. If the source data does not need to be modified, you can skip the Data Transformation step in the Import Wizard. Transformation file step is used only in case of aXML data as it cannot be modified in any other tool.

### Importing Projects and Project Content

To launch the Import function, choose **Tools and Settings > Import**. This opens the Import Wizard that guides you through the import procedure. Importing is done in the following sequence:

1. Define import preferences.
2. Select the source file to be imported and specify file type.
3. Select the content from the list of contents that can be imported.
4. Map source fields to target solution fields to store the imported data.
5. Transform source field data into the Agile format.
6. Review the information that you have entered and start the import.

An Import log records the process, and logs the results and errors.

Each step of the import procedure is described in detail in the following sections.
Define Import Preferences

Preference settings allow you to set different conditions to run the import. The Import wizard has several preference settings that you can set from any step in the wizard. These settings persist during the current Agile PLM client session, but they are not permanently saved with each user’s profile.

Note These settings are optional; you can complete the import without specifying preferences.

To set import preferences:
1. Click the Preferences button at the bottom left corner of the Import wizard. The Import Preference window appears.
2. Select one of the following from the list:
   • Parsing and Validation Options
   • Business Rule Options
   • Default Types
   • AutoNumber Sources
     Depending on the option you choose, the wizard displays a list of values that you can define. For complete details on the impact of each setting you define, see the Agile Import and Export Guide.
3. Select preference settings and click OK.

File Selection

The File Selection step in the Import Wizard lets you select the source file to be imported and configure it for import.

To select the source file for the import:
1. In the Import File field, click Browse to select the file from your local drive. Ensure that the file you select is in one of the supported formats. Depending on the format of the file you choose, additional configuration fields appear.
2. Select the appropriate options for your import as described in the table below.

<table>
<thead>
<tr>
<th>Field Name</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Template Type</td>
<td>Select the template type of your import file.</td>
</tr>
<tr>
<td>Select Worksheet (for Excel files)</td>
<td>Excel files consists of several sheets in a single file. In case more than 1 sheet exists, you can specify the sheet number here.</td>
</tr>
<tr>
<td>Field Delimiter</td>
<td>Select the appropriate field delimiter which will separate figures or text within the file.</td>
</tr>
<tr>
<td>Text Qualifier</td>
<td>Select the symbol which will qualify the data as text and not figures.</td>
</tr>
<tr>
<td>Field Name</td>
<td>Action</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Location of Header Row</td>
<td>Specify the row number within the worksheet which contains the text to be used as the header row.</td>
</tr>
<tr>
<td>Location of Last Row</td>
<td>Specify the row number in the worksheet to be taken as the last row to import data. This can be used if you want to import a table format file which may contain multiple object types. Import will only load specified data based on header row and last row specified. This can also be used if the import sheet is too long and you do not want all the content to be imported.</td>
</tr>
<tr>
<td>File Encoding</td>
<td>Specify File encoding.</td>
</tr>
</tbody>
</table>

3. Click **Next**.

### Specify File Content

The third step of the import wizard enables you to:

- Specify the objects that you wish to import.
- Select mapping and data transformation methods to use.

#### To select project content to be imported:

1. Click **Project** to view the options available.
2. Select the content object you wish to import. You can only select one object at a time.
3. Click **Next** to move to the next step.

#### To select mapping and transformation methods:

1. Under Data Mapping, select one of the following options to define mapping specifications:
   - **Define attribute mapping in next step** - If you wish to map each field manually, select this option.
   - **Use a saved mapping file** - If you already have an existing mapping file which corresponds to the file which is being imported, select this option. Then click **Browse** to locate and select the saved mapping file from your directory.

2. Under Data Transformation, select one of the following options to define transformation specifications:
   - **Do not Perform any Transformations** - If you are not importing an aXML file, select this option.
   - **Use a saved transformation file** - If you are importing an aXML file, select this option. Then click **Browse** and select a Transformation Definition file from your directory. You can also use the transformation template that Agile provides, if you wish. To do this, click **Download Transformation Template**. Save the file onto your computer and then select it for use in the import.

**Note** Any transformation that occurs during an import session is recorded in the Import Log file. For more information on transformation files, see [Data Transformation](#) on page 127.
3. Click **Next** to move to the next step.

**Specify Attribute Mapping**

You can now map fields in the source data to Agile fields. The left column (Import Fields) lists the fields in the header row of the import source file. The data fields that can be imported are displayed in the right column (Agile Fields) categorized as Activities and Gates. Only fields that you map will be imported. The remaining data will not be included.

**To map source fields to Agile fields:**

1. Click **Expand All** to view all the fields listed under Agile fields. Mandatory fields for creating a project are displayed in **bold**. Required fields appear in **green**.

2. Click once on a field in the left column to select it. Click on the corresponding Agile field in the right column to create the mapping. The mapped field appears next to the Agile field for your reference.

3. Continue mapping each field. Ensure that all required fields are mapped.
   
   If you have mapped the same import field more than once, the word **multiple** appears next to the field. To remove an incorrect mapping, click the **x** symbol next to the field name.

4. When you finish mapping source fields to Agile fields, you can choose to save this mapping file for future use. If you wish to do this, click **Save As** and save the file to your local drive.

5. To review import settings, click **Next**.

**Review Import Settings and Begin Import**

The final step of the Import Wizard allows you to review all the specified import settings so that you can go back and make changes if necessary.

1. To check if your data is in order, click **Validate**.

2. To begin the import, click **Import**. The source data is imported into Agile PPM. To cancel the process, click **Cancel**.

   An Import Log displays the results of the import action and error messages. To keep a record of the import errors, click **Save Log**.

3. To return to Agile Web Client, click **Close**.

**Exporting Data**

The Export Wizard enables the extraction of projects and other objects from Agile PLM into formats such as Microsoft Excel worksheets, comma-delimited text, PDX Packages or aXML Packages, for distribution to customers or vendors.

You can export the following types of objects from Agile PPM:

- Discussions
- Root Projects
- Users and User Groups
You can also export a project, make modifications to P1, P2 and P3 fields, and then import it back into Agile.

**To start the Export wizard from Agile Web Client:**
1. Open an object to export.
2. Choose **Tools and Settings > Export**.

**To start the Export wizard from Agile Java Client:**
1. Open a root project to export.
2. Choose **Actions > Export**.
3. Search for objects that can be exported, and select one or more objects in the Search Results page.
4. Choose **Tools > Export**.

**To export a project or PPM object:**
1. In the Select Objects to Extract page, from the **Format** drop-down list, select the format to which you want to export data.
2. In the **Site** field, select a site. To export data for all sites, select **All**.
   
   **Note** The **Site** field is only available if your Agile system includes the Sites server license.

3. To identify the projects or other Agile objects for export, click **Add**. An Add Objects dialog opens, where you can search and locate objects.
4. Select the objects you wish to export and click **Next**.
5. You can now provide filter conditions for the export:
   a. To define your own filter conditions, select the **Create custom filter** option and click **Next**. Then select the individual tabs for the content you want to export or select **Select All** to export all content. Click **Next** to continue.
   b. To use a pre-defined filter for each of the selected objects, select the **Use predefined filter** option. Select the filter you want from the drop-down list for each object. To review details of each filter, select the filter and click **Details**. Once you make your selection, click **Next**.

6. In the next step, enter export header information for your reference.
7. To complete the export, click **Export**. Specify a directory or location to save your export data when prompted.

   A confirmation dialog displays to indicate that the export is complete. If there are errors, an error log is displayed.
Configuring Product Portfolio Management

This chapter includes the following:

- Administration in Agile Java Client .......................................................... 133
- Administration in Agile Web Client .......................................................... 155
- Setting Up Microsoft Project Integration ................................................. 157

Agile PLM is highly configurable and provides administrators considerable flexibility in determining the display and behavior of various Agile objects to suit discrete business needs. Configuration options are available both in Agile Java Client and Agile Web Client.

Administration in Agile Java Client

The administrative features in Agile’s Java Client help you configure and adapt Agile PLM to fit the way you already do business. Administrator nodes let you manage users and tailor aspects of Agile PLM to meet your company’s requirements.

Detailed instructions on how to carry out all Agile PLM administration tasks are provided in the Agile PLM Administrator Guide. Some configuration settings that are required for Product Portfolio Management are listed here. You must be familiar with administering Agile objects in order to carry out the PPM configuration tasks described here.

Product Portfolio Management Configuration Checklist

Use the following checklist to configure Agile PLM server settings for Product Portfolio Management. For instructions on how to carry out these configuration tasks, refer the Agile PLM Administrator Guide.

- **Configure the Projects Class** — Change base class and class names according to your business requirement. Enable, disable, or rename Page Two tabs and attributes.
- **Configure Subclasses of the Projects Class** — Configure the Page Three tab and attributes. Create new autonumbers or modify predefined autonumbers.
- **Customize Lists** — Create new lists or modify predefined lists to display attributes for user selection.
- **Configure Criteria** — Define the criteria by which workflow and access control should be determined.
- **Configure Workflows** — Define the workflows you require to facilitate your business processes.
- **Define Users** — Define the users and resource pools (user groups) who will participate in projects.
- **Configure Roles and Privileges** — Assign those users appropriate roles, such as Program
Manager, Program Team Member, Program Administrator etc. Check the privileges assigned to the predefined roles and modify if necessary.

- **Configure SmartRules** — Make sure you properly configure SmartRules related to MSP integration, timesheet entries, adding activities to completed Projects, commenting, and other SmartRules related to workflows.

- **Configure Notifications** — Configure settings for the predefined notifications or create new ones.

- **Configure My Assignments** — Define the attributes that should display in your My Assignments tab. Enable, disable or rename the attributes as appropriate.

- **Define Company Profile** — Specify the name, address, phone number, URL, and the corporate currency for your company.

- **Define Currency Exchange Rates** — Ensure that currency exchange rates are current to reflect accurate project costs.

- **Configure the Dashboard** — Define what tabs and tables you want displayed in the Dashboard.

- **Configure Status Indicators** — Define status attributes for Schedule, Cost, Quality, and Resource status tracking.

- **Configure Default Roles** - Specify which Agile PLM roles are assigned automatically to users when a task is delegated to them or when a Microsoft Project is published to Agile PPM.

- **Configure Quick View for Projects** - Configure the display of the Quick View dialog that provides details of the project object. Define what fields and action buttons should display to facilitate user action.

- **Configure Events** - Define custom actions that should occur before, after, or during predefined events.

- **Set Up Task Configuration** - Schedule execution of project-specific background tasks.

### Notes on Data Settings

The following section provides information you need to keep in mind while configuring classes and sub-classes in Agile PLM.

#### Object Classes for Deliverables

The objects that a user can specify as a deliverable are determined by several factors:

- If the appropriate Agile solution is installed at your site. For example, in order to select a Declaration, Agile PG&C must be installed at your site.

- Whether the user has the appropriate privileges to discover and read the object.

<table>
<thead>
<tr>
<th>Class</th>
<th>Target Event Attribute</th>
<th>Notes</th>
<th>Deliverables tab table</th>
<th>Add by</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item base class</td>
<td>Lifecycle</td>
<td>Defined in Agile Administrator Classes node, Lifecycle Phases tab.</td>
<td>Affected By</td>
<td>Search, Create New</td>
</tr>
<tr>
<td>Class</td>
<td>Target Event Attribute</td>
<td>Notes</td>
<td>Deliverables tab table</td>
<td>Add by</td>
</tr>
<tr>
<td>---------------</td>
<td>------------------------</td>
<td>------------------------------------------------------------</td>
<td>------------------------</td>
<td>---------</td>
</tr>
<tr>
<td>Changes base class</td>
<td>Workflow.Status</td>
<td>Target status list is dependent on the workflow that has been selected for the specified object.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Manufacturer Part class</td>
<td>Lifecycle</td>
<td>Defined in Agile Administrator Classes node, Lifecycle Phases tab. Not controlled by the Agile change process.</td>
<td>Affected By Affects</td>
<td>Search Create New</td>
</tr>
<tr>
<td>Manufacturer class</td>
<td>Lifecycle</td>
<td>Defined in Agile Administrator Classes node, Lifecycle Phases tab. Not controlled by the Agile change process.</td>
<td>Affected By Affects</td>
<td>Search Create New</td>
</tr>
<tr>
<td>File Folder base class</td>
<td>Lifecycle</td>
<td>Defined in Agile Administrator Classes node, Lifecycle Phases tab. Not controlled by the Agile change process.</td>
<td>Affected By Affects</td>
<td>Search Create New</td>
</tr>
<tr>
<td>PSR base class</td>
<td>Workflow.Status</td>
<td>Target status list is dependent on the workflow that has been selected for the specified object.</td>
<td>Affected By Affects</td>
<td>Search Create New</td>
</tr>
<tr>
<td>QCR base class</td>
<td>Workflow.Status</td>
<td>Target status is dependent on the workflow that has been selected for the specified object.</td>
<td>Affected By Affects</td>
<td>Search Create New</td>
</tr>
</tbody>
</table>

**Enabling the Calculate Attributes**

By default, all costs are calculated. However, by enabling the General Info tab Calculate attributes, the end user can choose whether to use the calculated cost or a cost value that he enters. The Calculate attributes are list type attributes that use a Yes/No selection list. When the Calculate attributes are disabled (not visible), the default setting is Yes (calculate). See also [How Total Cost is Calculated](#) on page 114.

With the exception of Labor costs, each of the cost fields shown in the table below has an associated Calculate attribute. You can enable all the Calculate attributes or only the Calculate attributes you want to use.

If the Calculate attribute is visible and the end user has the privilege to modify the attribute, he has
the option to select Yes or No.

- **Yes** — When rolling up the costs of the current activity to its parent activity, use the calculated cost of the current activity’s children.

- **No** — When rolling up the costs of the current activity to its parent activity, do not use the calculated cost, rather, use the cost entered in the cost field. In this case, there will be no rollups. Instead, cost will be calculated based on the values specified for the parent activity.

To use a Calculate attribute you must:

- Enable the appropriate Calculate attribute of the object’s General Info tab. ([Settings > Data Settings > Classes](#))

- Edit the appropriate Modify privilege masks by adding the Calculate attribute to the Applied To property of the privilege mask. ([Settings > User Settings > Privileges > Modify](#))

For example, in order to use the Yes/No selection list for **Calculate Capital Cost - Budget** on the General Info tab of Activities, the user must have a Modify privilege mask for Activities that includes **Activity.General Info.Calculate Capital Cost - Budget** in the Applied To property.

The following table shows the cost attributes, their associated Calculate attributes, and the Modify privilege mask attributes that must be added to the Modify privilege mask Applied To property.

<table>
<thead>
<tr>
<th>General Info tab Cost attribute:</th>
<th>Enable the associated General Info tab Calculate attribute:</th>
<th>Add to the appropriate Modify privilege mask Applied To property:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actual Labor Cost</td>
<td>Actual Labor Cost and Budgeted Labor Cost are always calculated. Estimated Labor Cost to Completion can be edited on the General Info tab; it is not calculated. No Calculate attributes are provided for labor costs.</td>
<td>(Not applicable)</td>
</tr>
<tr>
<td>Budgeted Labor Cost</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Estimated Labor Cost to Completion</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
### General Info Tab

<table>
<thead>
<tr>
<th>General Info tab</th>
<th>Enable the associated General Info tab Calculate attribute:</th>
<th>Add to the appropriate Modify privilege mask Applied To property:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Actual Fixed Cost</td>
<td>Calculate Fixed Cost - Actual</td>
<td>&lt;object&gt;.General Info.Calculate Fixed Cost - Actual</td>
</tr>
<tr>
<td>Budgeted Fixed Cost</td>
<td>Calculate Fixed Cost - Budget</td>
<td>&lt;object&gt;.General Info.Calculate Fixed Cost - Budget</td>
</tr>
<tr>
<td>Estimated Fixed Cost to Completion</td>
<td>Calculate Fixed Cost - EAC</td>
<td>&lt;object&gt;.General Info. Calculate Fixed Cost - EAC</td>
</tr>
<tr>
<td>Actual Flex Cost</td>
<td>Calculate Flex Cost - Actual</td>
<td>&lt;object&gt;.General Info.Calculate Flex Cost - Actual</td>
</tr>
<tr>
<td>Budgeted Flex Cost</td>
<td>Calculate Flex Cost - Budget</td>
<td>&lt;object&gt;.General Info.Calculate Flex Cost - Budget</td>
</tr>
<tr>
<td>Estimated Flex Cost to Completion</td>
<td>Calculate Flex Cost - EAC</td>
<td>&lt;object&gt;.General Info. Calculate Flex Cost - EAC</td>
</tr>
</tbody>
</table>

### Variances Displayed in the General Info Tab Summary Table

The following variance calculations appear in the summary table at the top of the General Info tab of Activity objects and Gate objects. Use the Classes node to make the variance calculations visible in the summary table by enabling the attributes. Work days indicate the variance in scheduled days of work. Calendar days indicate the variance according to days on the calendar. A four week variance would appear as 20 work days and 28 calendar days.

If Actual and Estimated date fields are blank, no variance calculations are performed for those attributes.

Use the Classes node to choose which variance calculations will be visible in the summary table by enabling or disabling the attributes. In addition, you can use the Applied To property of PPM object Read privilege masks to control which users can read these attributes.

<table>
<thead>
<tr>
<th>Variance attribute</th>
<th>Difference between</th>
</tr>
</thead>
<tbody>
<tr>
<td>Estimated Start Variance Work Days</td>
<td>Estimated Start Date - Scheduled Start date (in work days)</td>
</tr>
<tr>
<td>Estimated Duration Variance Work Days</td>
<td>Estimated Duration - Schedule Duration (in work days)</td>
</tr>
<tr>
<td>Estimated Finish Variance Work Days</td>
<td>Estimated Finish Date - Scheduled Finish date (in work days)</td>
</tr>
<tr>
<td>Estimated Start Variance Calendar Days</td>
<td>Estimated Start Date - Scheduled Start date (in calendar days)</td>
</tr>
<tr>
<td>Estimated Duration Variance Calendar Days</td>
<td>Estimated Duration - Schedule Duration (in calendar days)</td>
</tr>
</tbody>
</table>
### Notes on Setting Up Roles

The following section provides information you need to keep in mind while setting up Roles for users.

#### Default Roles Assigned Automatically to Agile PPM Users

The Default Role node allows you to specify which Agile PLM roles are assigned automatically to users when a task is delegated to them or when a Microsoft Project, along with its users and roles, is published to Agile PLM.

**Note**

Access to the Default Role node requires that the administrator user have PPM Default Role selected in the Applied To property of that user’s Administrator privilege mask. For more information, see the *Agile PLM Administrator Guide*.

When you open the Default Role node, the Default Role window appears. It lists two Agile PPM roles:

- **Default MSP Synchronization Role** — Controls the role assigned to a user from a Microsoft Project that was published to Agile PLM. By default, the user is assigned the Program Team Member role.

- **Default Object Owner Role** — Controls the role assigned to a user when another user delegates a task to him. By default, the user is assigned the Program Manager role.

  The Default Object Owner Role is also assigned to the object owner in the Team tab when an activity is created. When an activity is delegated, the role is assigned to the delegated owner only after the delegated owner accepts the delegation.

You can change the roles used for Microsoft Project synchronization or task delegation. By default, available roles you can choose are:

<table>
<thead>
<tr>
<th>Variance attribute</th>
<th>Difference between</th>
</tr>
</thead>
<tbody>
<tr>
<td>Estimated Finish Variance Calendar Days</td>
<td>Estimated Finish Date - Scheduled Finish date (in calendar days)</td>
</tr>
<tr>
<td>Actual Start Variance Work Days</td>
<td>Actual Start Date - Scheduled Start date (in work days)</td>
</tr>
<tr>
<td>Actual Duration Variance Work Days</td>
<td>Actual Duration - Schedule Duration (in work days)</td>
</tr>
<tr>
<td>Actual Finish Variance Work Days</td>
<td>Actual Finish Date - Scheduled Finish date (in work days)</td>
</tr>
<tr>
<td>Actual Start Variance Calendar Days</td>
<td>Actual Start Date - Scheduled Start date (in calendar days)</td>
</tr>
<tr>
<td>Actual Duration Variance Calendar Days</td>
<td>Actual Duration - Schedule Duration (in calendar days)</td>
</tr>
<tr>
<td>Actual Finish Variance Calendar Days</td>
<td>Actual Finish Date - Scheduled Finish date (in calendar days)</td>
</tr>
</tbody>
</table>
Chapter 9: Configuring Product Portfolio Management

- Change Analyst
- Program Team Member
- Program Manager
- Resource Pool Owner
- Program Administrator

**Note** If you have modified the Agile PPM roles or defined additional roles for Agile PPM, the list of roles in the Default Role Role(s) lists may differ from the list above. For more information, see “How the Lists of Available Agile PPM Roles are Determined” below.

**To change default roles used for Microsoft Project synchronization and task delegation:**

2. Double-click the Default MSP Synchronization Role to open it.
3. Click the Role(s) list and select a role.
4. Click Save.
5. Click Close to close the window.
6. In the Default Role window, double-click the Default Object Owner Role to open it.
7. Click the Role(s) list and select a role.
8. Click Save.
9. Click Close to close the window.

**How the Lists of Available Agile PPM Roles are Determined**

There are several actions in Agile PLM where the Agile administrator or the end user is required to select an Agile PPM role from a list. Agile PPM role-selection actions include:

- When the Agile administrator selects the Default MSP Synchronization Role or the Default Object Owner Role, as described above.
- When the end user adds team members or resources to the Team tab of an activity.

The Agile PPM roles that appear in these lists are roles assigned to the login user that include at least one privilege mask with an object type of activities or gates. For example, the Agile-supplied Change Analyst role includes the privilege mask Subscribe to Gates Class; therefore, the Change Analyst role appears in the list of available PPM roles. If you were to remove that privilege mask (thus removing all activity and gate privilege masks) from the Change Analyst role, the Change Analyst role would no longer appear on the list of available Agile PPM roles.

**Note** End users do not need to have these PPM roles assigned at the system level (that is, in the Roles property of their User Profiles), as these roles are applied only on specific Agile PPM objects.
Notes on Assigning PPM-specific Privileges

The following section provides information on PPM-specific privileges and what you must keep in mind while assigning these privileges to users.

Create from Template Privilege

This privilege, enabled for the Program Administrator and Program Manager roles, allows the user to create a project from an existing template. Users who do not have either of the “Program” roles will also need to have the following privileges in order to use the Create from Template privilege:

- Read privilege for the template that is being accessed
- Create privilege to create subclasses in the template

Microsoft Project Privilege

Depending on the AppliedTo property of a Microsoft Project privilege mask, the Microsoft Project privilege allows the user to perform specific tasks between Microsoft Project and Agile PPM. By default, this privilege mask is enabled for the Program Administrator and Program Manager roles.

This privilege contains five properties in the Applied To field.

- Launch in Edit Mode — launch a PPM project Microsoft Project in Edit mode
- Launch in Read Only — launch a PPM project Microsoft Project in Read Only mode
- Publish from MS Project — publish from Microsoft Project
- Save As XML–Edit — save PPM project data in XML in Edit mode
- Save As XML–Read Only — save PPM project data in XML in Read Only mode

To enable these properties, move the required properties from the Choices list to the Selected list.

Note Before Agile PLM Release. 9.2.2, the Modify privilege contained the capability to access MS Project, which is now broken out to the Microsoft Project privilege. In addition to this privilege, you must enable General Info.Lock User and General Info.Schedule Editor in the Modify privilege to access MS Project in PPM Gantt Chart.

Update All Timesheets Privilege

This privilege is enabled for the Timesheet Administrator role, and allows the user to administer all timesheets recorded in Agile PLM. With this privilege, a user can do the following:

- Search and view timesheets for other users.
- View all tasks for a selected user, then view and change timesheet data recorded for each task.

Note This privilege overrides system privileges for viewing tasks. The user need not be a team member on the task in order to perform these actions.
Adding Project Contents in Modify Privilege

**Note** In PLM 9.2.2, the Relationships tab was renamed to Content, for PPM objects. However, in the Projects classes, the properties under the Content tab are displayed under the Attributes: Relationships tab.

You can add other objects or contents to an existing project such as Customers, File Folders and so on. To enable this privilege, two properties have been added – `Content.Name` and `Content.Rule`. The `AppliedTo` property of any Modify privilege mask can be tailored to permit the user to add content (that is, add relationships) or add a Content rule (that is, add a rule to a relationship) based on the `Name` and `Rule` attributes, respectively, being enabled in the `AppliedTo` property.

To enable the ability to add content (`Name` attribute) and content rules (`Rule` attribute), in the Modify privilege mask’s `AppliedTo` property, move `Content.Name` and `Content.Rule` properties from the `Choices` list to the `Selected` list. These properties are displayed in the `AppliedTo` property list as `Activity.Content.Name` and `Activity.Content.Rule`, and as `Gates.Content.Name` and `Gates.Content.Rule`. (Note that in other classes, the format will read, for example, `Substances.Relationships.Name`.)

For more details on the `AppliedTo` property, see the section, "AppliedTo Capability" in the Agile PLM Administrator Guide.

Accessing Gantt Charts

In Agile PLM 9.2, the Gantt base privilege was removed. The Gantt capability is now covered by Read Program Schedule and Modify Program Schedule privilege masks. For more information, see the following section.

Modify Privilege Mask Applied To Properties that Control Specific User Actions

Agile PLM uses Modify privilege mask `Applied To` properties to determine and control certain specific user actions and capabilities in Agile PPM. For example, if a user has a role that includes a Modify privilege mask for activities and the `AppliedTo` property includes the `Activities.Schedule.Name` attribute, then that user is able to use the `Add` function on the `Schedule` tab.

Agile PLM roles and privilege masks allow you to define very specific and narrow Agile PPM user capabilities if required. For detailed information about privilege masks, see Agile PLM Administrator Guide.

The following table lists the Modify privilege mask `Applied To` properties and which PPM actions they control.

**Note** This table uses `<object>` as a place holder for the class or subclass name in the `Applied To` attribute column. The actual class or subclass name in any privilege mask is determined by the reusable criteria specified in the privilege mask. If you view the example privilege masks mentioned in the Notes column, the `AppliedTo` properties will be appropriate for that specific privilege mask (for example, `Activities.General Info.Lock User`).
<table>
<thead>
<tr>
<th>Action or capability provided</th>
<th>Applied To attribute</th>
<th>Example Privilege Mask / notes</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Object-level actions</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Lock and Unlock</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Cancel Locked Project</td>
<td>&lt;object&gt;.General Info.Locked From Program</td>
<td>Example - Cancel Lock Program.</td>
</tr>
<tr>
<td><strong>Unlock</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Allows user to cancel the</td>
<td></td>
<td></td>
</tr>
<tr>
<td>locked condition of a</td>
<td></td>
<td></td>
</tr>
<tr>
<td>project that was locked by</td>
<td></td>
<td></td>
</tr>
<tr>
<td>a different user.</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Edit the Gantt chart</strong></td>
<td>&lt;object&gt;.General Info.Lock User and &lt;object&gt;.General Info.Schedule Editor</td>
<td>Example - Modify Program Schedule (for Lock User). and Example - Read Program Schedule (for Schedule Editor). Note that the user requires modify privilege for both of these attributes in order to edit the Gantt chart.</td>
</tr>
<tr>
<td><strong>Gantt Chart</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Read the Gantt chart</strong></td>
<td>&lt;object&gt;.General Info.Schedule Editor (and the user does not also have &lt;object&gt;.General Info.Lock User)</td>
<td>Example - Read Program Schedule. If the user has Modify applied to General Info.Schedule Editor, but he lacks Modify applied to Lock User, he will be able to open and read the Gantt chart, but he will not be able to edit the Gantt chart.</td>
</tr>
<tr>
<td><strong>Gantt Chart</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Save as XML</strong></td>
<td>&lt;object&gt;.General Info.Schedule Editor</td>
<td>Example - Read Program Schedule. Note that this is a Modify type privilege mask, not a Read type privilege mask. <strong>Note</strong>: Save as XML and Launch in Edit Mode set the Schedule Editor attribute to MSP. This disables the roll-up of dates in Agile PPM.</td>
</tr>
<tr>
<td><strong>Microsoft® Project &gt; Save</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>As XML</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Launch in Microsoft</strong></td>
<td>&lt;object&gt;.General Info.Schedule Editor</td>
<td>Example - Read Program Schedule. Note that this is a Modify type privilege mask, not a Read type privilege mask.</td>
</tr>
<tr>
<td><strong>Project in read-only mode</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Microsoft® Project &gt;</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Launch as Read Only</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Action or capability provided</td>
<td>Applied To attribute</td>
<td>Example Privilege Mask / notes</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>----------------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td>Launch in Microsoft Project in edit mode (Microsoft® Project &gt; Launch in Edit Mode)</td>
<td>&lt;object&gt;.General Info.Schedule Editor and &lt;object&gt;.General Info.Lock User</td>
<td>Example - Read Program Schedule. Note that this is a Modify type privilege mask, not a Read type privilege mask. and Example - Modify Program Schedule. <strong>Note:</strong> Save as XML and Launch in Edit Mode set the Schedule Editor attribute to MSP. This disables the roll-up of dates in Agile PPM.</td>
</tr>
<tr>
<td>Substitute Resource Actions &gt; Substitute Resource</td>
<td>&lt;object&gt;.Team.Name</td>
<td>Example - Modify All Projects, Programs, Phases, Tasks and Gates.</td>
</tr>
<tr>
<td>Change Archive Status Actions &gt; Change Archive Status</td>
<td>&lt;object&gt;.General Info.Archived</td>
<td>Example - Modify All Projects, Programs, Phases, Tasks and Gates.</td>
</tr>
<tr>
<td>Delegate Delegate an activity (you are the owner) to a different owner Actions &gt; Delegate</td>
<td>&lt;object&gt;.General Info.Delegated Owner</td>
<td>Example - Modify All Projects, Programs, Phases, Tasks and Gates.</td>
</tr>
<tr>
<td>Delete Delete the current object Actions &gt; Delete</td>
<td>Always requires a Delete privilege mask for the current object where the delete action is performed in Agile PPM. Requires Delete privileges for subordinate objects on the current object’s Schedule tab. If there is a parent object, Delete of the current object also requires the following: Delete privilege mask for the parent object.</td>
<td>When the current PPM object is deleted in Agile PPM Web Client, all three privilege masks are required (if there is a parent object). - Current object Delete privilege - Children objects Delete privileges - Parent object Delete privilege - Parent object Modify Schedule.Name</td>
</tr>
<tr>
<td><strong>Action or capability provided</strong></td>
<td><strong>Applied To attribute</strong></td>
<td><strong>Example Privilege Mask / notes</strong></td>
</tr>
<tr>
<td>-------------------------------</td>
<td>--------------------------</td>
<td>-----------------------------------</td>
</tr>
<tr>
<td>Modify privilege mask for the parent object: <code>&lt;parent object&gt;</code>.Schedule.Name</td>
<td>Example - Modify Programs, Example - Modify Phases, Example - Modify Tasks.</td>
<td></td>
</tr>
<tr>
<td><strong>Schedule tab actions</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Add activities</strong></td>
<td><code>&lt;object&gt;</code>.Schedule.Name</td>
<td>The user must have Modify privilege applied to Schedule.Name for the object where the Delete activities action (on the Schedule tab) is performed. Also requires Delete privileges for the deleted objects and their children. Example - Modify Programs, Example - Modify Phases, Example - Modify Tasks. <strong>Note:</strong> Delete privileges for the current objects are not required.</td>
</tr>
<tr>
<td><strong>Delete activities</strong></td>
<td><code>&lt;object&gt;</code>.Schedule.Name for the current Schedule tab object. Requires Delete privileges for the deleted object and the deleted object’s subordinate objects.</td>
<td>Example - Modify All Projects, Programs, Phases, Tasks and Gates.</td>
</tr>
<tr>
<td><strong>Edit &gt; Dependencies</strong></td>
<td><code>&lt;object&gt;</code>. Dependencies Dependent Upon.Name for the object in Schedule tab row that is being edited.</td>
<td>Example - Modify All Projects, Programs, Phases, Tasks and Gates.</td>
</tr>
<tr>
<td><strong>Edit &gt; Reschedule</strong></td>
<td><code>&lt;object&gt;</code>.General Info. Schedule Start Date and <code>&lt;object&gt;</code>.General Info. Schedule End Date</td>
<td>The user must have ‘Modify’ privilege masks that allow him to modify the Schedule Start Date and Schedule End Date of the object where the Reschedule action (on the Schedule tab) is performed. Example - Modify All Projects, Programs, Phases, Tasks, and Gates.</td>
</tr>
<tr>
<td>Action or capability provided</td>
<td>Applied To attribute</td>
<td>Example Privilege Mask / notes</td>
</tr>
<tr>
<td>------------------------------</td>
<td>----------------------</td>
<td>-------------------------------</td>
</tr>
<tr>
<td>Edit &gt; Add Team</td>
<td>&lt;object&gt;.Team.Name</td>
<td>Example - Modify Programs,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example - Modify Phases,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example - Modify Tasks.</td>
</tr>
<tr>
<td>Create Baseline</td>
<td>&lt;object&gt;.Schedule.Name</td>
<td>Example - Modify Programs,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example - Modify Phases,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example - Modify Tasks.</td>
</tr>
<tr>
<td>Remove Baseline</td>
<td>&lt;object&gt;.Schedule.Name</td>
<td>Example - Modify Programs,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example - Modify Phases,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example - Modify Tasks.</td>
</tr>
</tbody>
</table>

**Dependencies tab actions**

<table>
<thead>
<tr>
<th>Action</th>
<th>Applied To attribute</th>
<th>Example Privilege Mask / notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add activities</td>
<td>&lt;object&gt;.Schedule.Name</td>
<td>Example - Modify Programs,</td>
</tr>
<tr>
<td>Add button</td>
<td></td>
<td>Example - Modify Phases,</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Example - Modify Tasks.</td>
</tr>
<tr>
<td>Add or remove dependencies</td>
<td>&lt;object&gt;. Dependencies Dependent Upon.Name</td>
<td>Example - Modify All Projects, Programs, Phases, Tasks and Gates.</td>
</tr>
<tr>
<td>Add button</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Remove button</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Team tab actions**

<table>
<thead>
<tr>
<th>Action</th>
<th>Applied To attribute</th>
<th>Example Privilege Mask / notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add team members</td>
<td>&lt;object&gt;.Team.Name</td>
<td>Example - Modify All Projects, Programs, Phases, Tasks and Gates.</td>
</tr>
<tr>
<td>Add button</td>
<td></td>
<td>Modify privilege for attribute Team.Name allows the user only to add or to remove team members.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>In order to edit the Team table, the user must have additional modify privileges for the specific Team table attributes; refer to the row below.</td>
</tr>
<tr>
<td>Edit team member</td>
<td>&lt;object&gt;.Team.%_Allocation &lt;object&gt;.Team.Actual_Hours &lt;object&gt;.Team.Assigned From &lt;object&gt;.Team.Roles</td>
<td>In order to edit the Team table, the user must also have a modify privilege mask with explicit Applied To properties for the specific Team table attributes that needs to be edited, for example, Actual Hours.</td>
</tr>
</tbody>
</table>

**Content tab actions**
<table>
<thead>
<tr>
<th>Action or capability provided</th>
<th>Applied To attribute</th>
<th>Example Privilege Mask / notes</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set mandatory content</td>
<td>Activities.Content.Mandatory</td>
<td>To be able to make a Yes/No selection in the <strong>Content</strong> tab <strong>Mandatory</strong> column, the user must have a modify privilege mask with explicit Applied To properties for the <strong>Mandatory</strong> attribute.</td>
</tr>
</tbody>
</table>

**About Privileges for Gantt Chart and Microsoft Project**

The table above includes definitions of the Modify privilege masks necessary to grant users:

- The ability to open an Agile PPM activity in Gantt Chart and, therefore, edit that activity and its children, including creating new children.
- The ability to Launch in Microsoft Project an Agile PPM activity and, therefore, edit that activity and its children, as well as create new children.

When activities are edited in Gantt or Microsoft Project, Agile Create privilege masks and Modify privilege masks pertaining to the editing of the contents of specific fields cannot be checked within the Gantt or Microsoft Project applications. For example, it is possible that a user may not be able to create a particular Agile PPM subclass when working in Agile PPM, but he will be able to create that subclass in Gantt or Microsoft Project. In a similar manner, a user may not be able to edit the content of specific Agile PPM object attributes when working in Agile PPM, but he will be able to edit those fields in Gantt or Microsoft Project.

**Caution** If you wish to precisely limit the create and modify attribute privileges of some users, then do not give those users the ability to edit in Gantt or Microsoft Project. Gantt and Microsoft Project edit capabilities are more appropriate for Agile PPM users requiring broad create and modify capabilities.

**Delete Object Privileges for Gantt Chart and Microsoft Project**

When a user edits an Agile PPM project in the Gantt Chart or he uses **Microsoft Project > Launch in Edit Mode** to edit in Microsoft Project, he can perform many actions including deleting objects (activities or gates), changing the parent, changing dates or adding dependencies.

When the user uploads his changes to the Agile PPM server (**Update** function in Gantt Chart, **Agile > Publish to PPM** in Microsoft Project), Agile PLM checks to ensure that the user has the appropriate delete privilege masks for all activities and gates deleted. If the user does not have the appropriate delete privilege mask for an object that was deleted in Gantt Chart or Microsoft Project, none of the modifications made will be written to the Agile database. An error message informs the user that the action requires the necessary delete privileges.

Therefore, you can define mandated activities in Agile PPM, that is, activities that cannot be deleted from a project. This is enforced by configuring Delete privilege masks that do not allow users to delete mandated activities. See [Setting Up Restricted Delete Privileges](#) on page 147.
Setting Up Restricted Delete Privileges

The Agile-supplied Delete privileges masks are very broad, for example, Delete All Programs, Phases, and Gates allows the user to delete any object in the Projects base class, with no restriction. To create a restricted Delete privilege mask, create a reusable criterion that defines the objects the user will be allowed to delete, then use that criteria to create a Delete privilege mask. (For more information about reusable criteria and privilege masks, see the Agile PLM Administrator Guide).

When a user modifies a PPM project in the Gantt Chart or in Microsoft Project, the restricted Delete privilege masks are applied when the user updates or publishes back to Agile PPM.

Here are some examples of how you might set up and use restricted Delete privilege masks:

- Create a specific subclass for mandated activities that you will not allow to be deleted. You can then create reusable criteria that either exclude the mandated subclass, or include all subclasses except the mandated subclass.
  - Object Type: Activities
    General Info. Activities Type Not Equal to Mandated Task
  Where Mandated Task is a subclass you created to use for tasks that cannot be deleted. This allows all other Activities subclasses to be deleted, but Mandated Tasks cannot be deleted.
  - Create individual criteria and individual Delete privilege masks for each subclass, but do not create or assign a Delete privilege mask for the Mandated Task subclass. For example, you might create Delete privilege masks using the reusable criteria:
    Object Type: Programs
    Object Type: Phase
    Object Type: Task
    (No Delete privilege mask created for Mandated Task.)

- Define an object attribute that determines whether the task is mandated or not. This allows users to define mandated tasks on a case-by-case basis. This designation can be set up in a template and new projects copied from the template will carry over the value.

Once you have defined the attribute, you can create reusable criteria that evaluate the contents of that attribute. For example:

Page Two.List01 Not Equal to Mandated

Where Page Two.List01 is a list field that you have defined in order to set whether an activity is mandated or not.

Additionally:

- You must define a list for the Page Two.List01 attribute, for example, list selections Mandated and Non-Mandated.
- In order to limit who may edit the Page Two.List01 attribute, you must create and assign Modify privilege masks that allow and disallow the ability to change whether or not a task is mandated. Including Page Two.List01 in the Applied To property of a Modify privilege mask allows the user to change this attribute. Typically, you will allow very few users to change this attribute.
**Caution**  If you plan to use restricted Delete privileges for Agile PPM, remove any broadly-defined Delete privilege masks from the Agile PPM roles.

Agile privilege masks are additive. If a user has a Delete privilege mask that restricts delete privileges for Mandated Task subclass objects, but he also has the **Delete All Programs, Phases, and Gates** privilege mask (which allows him to delete any object in the Programs base class), then the user will be able to delete Mandated Task subclass objects.

**Settings Required for Menu Command: Actions > Change to Canceled**

The **Actions > Change to Canceled** menu command allows users to cancel the displayed project object and automatically cancel all its children (change workflow status to Canceled). In addition, users can also cancel leaf node objects by using the **Change Status** button.

Regardless of which method the user chooses, his ability to change the workflow status of a PPM object (including cancelling a PPM object) is determined both by the workflow status property Valid Manual Next Status setting and by the user's assigned Change Status privilege masks.

The Agile-supplied default Change Status privilege masks for PPM objects provide the ability to change statuses from any status to any other status. If you use custom Change Status privilege masks for PPM objects, review them to verify that the end users will be able to perform a top-level cancellation.

**Enabling Assign Action in User Groups**

Resource Pool owners can assign pending assignments to resources across projects from the **User Groups** page in Agile Web Client. User groups that have resources with percentage allocation to any project appear in this tab. When you click on a user group name a set of tabs display details of that user group. Under the Assignments tab, you can select a user and click **Assign** to assign a task.

This Assign action button is made available based on a setting in the Agile Java Client.

**To enable the Assign action button:**

1. In the Java Client Admin tab, navigate to **User Settings > Privileges**.
2. Double-click on **Modify**.
3. Search and locate the **Modify User Groups** privilege. Double-click on the table row to view details.
4. Click the down arrow next to the **Applied to** field.
5. Move **User groups.Assignments.Name** from the **Choices** list to the **Selected** list and click **Save**. For details on the AppliedTo property, see the topic "AppliedTo Capability" in the **Agile PLM Administrator Guide**.

**Note**  The **User Groups > Assignments** tab is not available for configuration in Java Client.
Notes on Setting Up SmartRules

The following section provides information you need to keep in mind while setting up SmartRules.

Automatic Installation from PPM SmartRule

Auto-Installs From PPM is a SmartRule that can be set to Allow, Disallow, or Warning. This SmartRule controls the automatic installation of Microsoft Project (2002 and 2003) DLLs into a user’s system Registry. Installation of the DLLs enables seamless publishing using an Agile menu within Microsoft Project. Auto-Installs From PPM also controls the installation of Sun’s JRE for the java-based Gantt Chart. The JRE is required to launch the Gantt Chart.

The default setting for Auto-Installs From PPM SmartRule is Allow. Set this to Disallow if your company does not want any applications to be automatically installed.

Note: If end users do not have Administrator rights on their PCs, you should consider setting Auto-Installs From PPM to Disallow and have your IT organization load the DLLs and/or JRE.

If Auto-Installs From PPM is set to Allow and a user does not have Administrator rights on his PC, selecting the Gantt Chart or Microsoft Project buttons in Agile PPM will initiate the installation process but it will not successfully install. This will happen every time a user selects one of these buttons and will become a usability issue.

IT departments can do system-wide installations of the JRE or Microsoft Project DLLs, in which case, the functionality of the Microsoft Project integration and Gantt Chart will be fully supported regardless of the setting of this SmartRule. Auto-Installs From PPM SmartRule governs only the automatic installation of the JRE or Microsoft Project DLLs; it does not govern the launch of these applications.

Configuring Status Display

Status tracking for projects is achieved by the use of appropriate status indicator settings in Java Client. These can be configured to display the types of statuses you want to monitor, using names, icons, colors, and other settings of your choice.

Status Nodes

The Status nodes provide visibility into whether a project’s targets in the areas of Schedule, Cost, Quality, and Resources are currently being met (the 1 value), currently not being met (the 2 value), or are seriously off the target (the 3 value).

Note: The Rollup Health Status attribute on the General Info tab of an activity object determines whether that activity object is included in the rollup. By default, statuses from leaf node activities (tasks with no children) roll up to higher levels in the project structure (Rollup Health Status = Yes). The user can determine which objects are excluded from the rollup by editing the Rollup Health Status attribute on the General Info tab to No. This enables the user to include or exclude a selected activity in the rollup.
Changing the Status Names the User Sees

In Agile PPM Web Client, the health statuses are attributes on the General Info tab. They are also reported in the health status indicators in the upper right of the activity window. By default, these are named: Overall Status, Schedule Status, Cost Status, Resource Status, and Quality Status.

To change the labels or names that appear in Agile PLM Web Client, modify the names of the health status attributes on the General Info tab of Activities or Gates class.

For example, to change the name of the Activities object’s Cost Status attribute to Accounting Status, change its name on the Classes node. The new name, Accounting Status, appears on the Activities object’s General Info tab; it also appears in the health status indicators in the upper right of the activity window.

Modifying Status Node Settings

When you open one of the Status nodes (Schedule, Cost, Quality, or Resource), the appropriate Status window appears. The properties on the main table are Order (1, 2, or 3), Name, Description, and Enabled. The buttons are Create and Delete.

When you double-click anywhere in the row of a status table, the object opens to the General Information tab. You can edit the fields in this window as necessary.

Note: Quality and Resource status are not programmatically set by Agile PPM. These fields can be renamed and used for other status purposes, such as Risk. These are subjective ratings. Cost and Schedule status are always calculated according to the thresholds set. It is not possible to turn off this automatic calculation.

Schedule Status

The Schedule Status window reports the status of the project regarding schedule.

Note: The Overdue Value can be either a positive number or a negative number.

The Overdue Value can be either days or a percentage of the duration.

To set the Overdue Type (Days or Percentage):

1. In Agile Administrator, open the Schedule Status node under Settings | System Settings | Product Portfolio Management.

   The Schedule Status window opens with the General tab displayed on top.

2. On the General tab, in the Overdue Type drop-down list, select either Days or Percentage.

3. When you are finished, click Save.

To modify the Schedule Status values:

1. In Agile Administrator, open the Schedule Status node under Settings | System Settings | Product Portfolio Management.

   The Schedule Status window opens with the General tab displayed.

2. Click the Status tab to display the schedule statuses.
3. Double-click the status row you want to modify. The schedule status window is displayed.
4. Make the desired modifications.

**Note** It is important that you follow the guidelines explained in the section “Schedule Status Guidelines” in the *Agile PLM Administrator Guide*.

5. When you are finished, click *Save*.

**Schedule Status Guidelines**

The following table shows the default Schedule Status settings (Overdue Type = Days).

<table>
<thead>
<tr>
<th>Order</th>
<th>Name</th>
<th>Description</th>
<th>Overdue Value</th>
<th>Icon</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>On Track</td>
<td>On Track</td>
<td>0</td>
<td>Green</td>
</tr>
<tr>
<td>2</td>
<td>Needs Attention</td>
<td>Needs Attention</td>
<td>1</td>
<td>Yellow</td>
</tr>
<tr>
<td>3</td>
<td>Off Track</td>
<td>Off Track</td>
<td>5</td>
<td>Red</td>
</tr>
</tbody>
</table>

In order for the schedule status to evaluate correctly, follow these rules when setting the *Overdue Value* attributes:

- All three states (On Track, Needs Attention, and Off Track) *must* have a value for *Day_Overdue*. A blank value is not valid, however, zero (0) is a valid value.
- The *Overdue Value* values must be ascending values that follow the order. That is, On Track (1) must have the lowest value, Needs Attention (2) must have a higher value than On Track, and Off Track (3) must have a higher value than Needs Attention.
- The above rules apply for both Overdue Type = Days and Overdue Type = Percentage.
- The following tables show some examples of valid *Overdue Value* settings:

**Overdue Value settings, Days:**

<table>
<thead>
<tr>
<th>Order</th>
<th>Name</th>
<th>Overdue Value Days</th>
<th>Overdue Value Days</th>
<th>Overdue Value Days</th>
<th>Overdue Value Days</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>On Track</td>
<td>−10</td>
<td>−5</td>
<td>0</td>
<td>5</td>
</tr>
<tr>
<td>2</td>
<td>Needs Attention</td>
<td>−5</td>
<td>0</td>
<td>5</td>
<td>10</td>
</tr>
<tr>
<td>3</td>
<td>Off Track</td>
<td>0</td>
<td>5</td>
<td>10</td>
<td>15</td>
</tr>
</tbody>
</table>

**Overdue Value settings, %**
How Schedule Status is Determined

If the activity’s workflow status is Not Started, Schedule Status is determined by comparing the current date against the calculation of the Scheduled Start Date and the Overdue Value.

If the activity’s workflow status is In Process, Schedule Status is determined by comparing the current date against the calculation of the Scheduled End Date and the Overdue Value. The following examples illustrate how Needs Attention and Off Track statuses are determined:

<table>
<thead>
<tr>
<th>Overdue Value Days</th>
<th>Overdue Value % of Duration</th>
<th>Task Duration</th>
<th>Calculation</th>
<th>Schedule Status changes when the current date is...</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>10</td>
<td>Scheduled End Date + 5</td>
<td>5 days after the scheduled end date</td>
<td></td>
</tr>
<tr>
<td>−5</td>
<td>10</td>
<td>Scheduled End Date − 5</td>
<td>5 days before the scheduled end date</td>
<td></td>
</tr>
<tr>
<td>0</td>
<td>10</td>
<td>Scheduled End Date</td>
<td>On the scheduled end date</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>2</td>
<td>Scheduled End Date + 5</td>
<td>5 days after the scheduled end date</td>
<td></td>
</tr>
<tr>
<td>−5</td>
<td>2</td>
<td>Scheduled End Date − 5</td>
<td>5 days before the scheduled end date (not dependent on duration)</td>
<td></td>
</tr>
<tr>
<td>−150</td>
<td>10</td>
<td>−150% * 10 = −15 days</td>
<td>15 days before the scheduled end date</td>
<td></td>
</tr>
<tr>
<td>−100</td>
<td>10</td>
<td>−100% * 10 = −10 days</td>
<td>10 days before the scheduled end date</td>
<td></td>
</tr>
<tr>
<td>−50</td>
<td>10</td>
<td>−50% * 10 = −5 days</td>
<td>5 days before the scheduled end date</td>
<td></td>
</tr>
<tr>
<td>0</td>
<td>10</td>
<td>0% * 10 = 0 days</td>
<td>On the scheduled end date</td>
<td></td>
</tr>
<tr>
<td>50</td>
<td>10</td>
<td>50% * 10 = 5 days</td>
<td>5 days after the scheduled end date</td>
<td></td>
</tr>
<tr>
<td>100</td>
<td>10</td>
<td>100% * 10 = 10 days</td>
<td>10 days after the scheduled end date</td>
<td></td>
</tr>
<tr>
<td>150</td>
<td>10</td>
<td>150% * 10 = 15 days</td>
<td>15 days after the scheduled end date</td>
<td></td>
</tr>
</tbody>
</table>

Cost Status

The Cost Status window reports the status of the project regarding cost and budget. Total Cost is the sum of the four cost types: Labor Cost, Capital Expenses, Fixed Cost and Flex Cost. The Cost Status color indicator is based on comparing Total Budgeted Cost to the sum of Total Actual Cost and Total Estimated to Completion and determining the percentage over Total Budgeted Cost.
**Note**  The Percentage value cannot be a negative number.

<table>
<thead>
<tr>
<th>Order</th>
<th>Name</th>
<th>Description</th>
<th>Percentage</th>
<th>Icon</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>On Budget</td>
<td>On Budget</td>
<td>0</td>
<td>Green</td>
</tr>
<tr>
<td>2</td>
<td>Off Budget</td>
<td>Off Budget</td>
<td>5</td>
<td>Yellow</td>
</tr>
<tr>
<td>3</td>
<td>Over Budget</td>
<td>Over Budget</td>
<td>10</td>
<td>Red</td>
</tr>
</tbody>
</table>

**Quality Status**

The Quality Status window reports the status of the project regarding issues of quality.

<table>
<thead>
<tr>
<th>Order</th>
<th>Name</th>
<th>Description</th>
<th>Icon</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Meets Quality</td>
<td>Meets Quality</td>
<td>Green</td>
</tr>
<tr>
<td>2</td>
<td>Below Quality</td>
<td>Below Quality</td>
<td>Yellow</td>
</tr>
<tr>
<td>3</td>
<td>Poor Quality</td>
<td>Poor Quality</td>
<td>Red</td>
</tr>
</tbody>
</table>

**Resource Status**

The Resource Status window reports the status of the team, or users with similar skill sets. Resource status allows you to evaluate the assignment of resources to programs and to help manage employees’ workloads.

<table>
<thead>
<tr>
<th>Order</th>
<th>Name</th>
<th>Description</th>
<th>Icon</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Staffed</td>
<td>Staffed</td>
<td>Green</td>
</tr>
<tr>
<td>2</td>
<td>Under Staffed</td>
<td>Under Staffed</td>
<td>Yellow</td>
</tr>
<tr>
<td>3</td>
<td>Not Staffed</td>
<td>Not Staffed</td>
<td>Red</td>
</tr>
</tbody>
</table>

**Configuring UI Data Display**

In Web Client, you can click on the Quick View tool tip that appears when you place your mouse cursor over an object to see details of that object. The task editing dialog that opens allows the user to view and edit subclass details. As an administrator, you can define the primary fields that task owners are required to edit and design how these fields should display. Task owners can then edit task details without having to navigate to the task details.

To configure the display, you must first define and select each component that you want to display in the dialog, such as attribute groups, tables and action menus. Think of attribute groups, tables, and actions as the building blocks of the task editing dialog. These can be combined in different ways to form different layouts. All you have to do is select the components, and assemble them into specific layouts. One layout can be associated to any one subclass.
The configuration for this is done in the UI Configuration Data node of the Java Client Admin tab.

**UI Configuration Data**

**To configure a Quick View dialog:**
1. Navigate to **System Settings > Product Portfolio Management**.
2. Click **UI Configuration Data**. The UI Configuration window opens.
3. Configure the following:
   - Attribute Groups
   - Configure Tables
   - Configure Action Groups
4. Assign a layout.

**To configure an attribute group:**
1. Click **Attribute Groups**.
2. Provide a name for the group. For example, “Cost” or “Schedule”.
3. From the **Available Attributes** list, select the attributes that you want to display. You can use the drop-down list to filter the attributes by subclass. Make sure the Name field is in one of the attribute groups to ensure that it is in the header.
4. Use the forward arrow button to move the selected attributes to the **Selected Attributes** area. You can reorder the selected attributes using the arrow buttons.
5. Click **Add** to add the selected attributes to the dialog.

**To configure tables:**
1. Click **Tables**.
2. Choose a table and provide a display name for it. For example, “Relationships”.
3. From the **Available Columns** list, select the columns that you want to display.
4. Use the forward arrow button to move the selected columns to the **Selected Columns** area. You can reorder the selected columns using the arrow buttons.
5. Click **Add** to add the selected columns to the dialog.

**To configure Action Groups:**
1. Click **Action Groups**.
2. Provide a name for the group. For example, “Task Actions”.
3. From the **Available Actions** list, select the actions that you want to display for workflow sign-offs. For example, Approve, Reject, and Mark Complete.
   a. To add a process extension to an action, click **New**. In the dialog that opens, specify the Action Name and then select a process extension to apply.
   b. To change the name of a selected action, click **Edit** and enter a new name for the action in the dialog that opens.
   c. To delete a selected action name, click **Delete**. You can only delete action names that you created.
4. Use the forward arrow button to move the selected actions to the Selected Actions area. You can reorder the selected actions using the arrow buttons.

5. Click Add to add the selected actions to the dialog.

**To assign a layout:**

1. Click Layout.

2. In the Define Layout For field, choose the object for which you want to assign a layout. For example, Program.

3. Select the desired attribute group, table and action group.

4. Use the forward arrow button to move your selections to the Form area. You can reorder the components using the arrow buttons.

5. Click Add to assign the layout for the specified object.

You can verify the results of your configuration actions in the Project Summary page.

## Administration in Agile Web Client

A limited amount of configuration can be performed for PPM in Agile Web Client, primarily related to object display.

### Configuring Project Summary Display

You can configure the layout and widgets of the Summary page if you have the Administrator privilege with "PPM Summary Page Configuration" as an AppliedTo value. This configuration applies to all Activities across the Agile PLM system.

**To configure the Project Summary widget:**

1. On the Summary page, click Configure.

2. To avoid displaying this widget in the Summary page, deselect the check box next to the widget name.

3. To configure the data that appears in the widget, click the Edit link that appears at the top right corner.

   - For Project Summary and Project Gates widgets, you need to manually configure the fields that are displayed. Select the fields you want from the Hidden Fields column on the left and move them to the Displayed Fields column on the right. You can reorder the displayed fields using the up and down arrows.

   - For all other widgets, you can only edit the widget name.

4. After you make changes to a widget, click Apply for the changes to take effect.

5. Click Save to save your settings, or click Cancel to revert to the default settings. Saved settings are immediately reflected on the Project Summary page.
Configuring the Dashboard

Each Dashboard tab contains a set of configurable widgets that display information in tables and charts. You can configure which of these widgets should display in each tab and where they should appear.

**To configure each Dashboard tab:**
1. In Agile Web Client Tools and Settings > Administration menu, choose Dashboard Configuration.
2. In the Configure Tab field, select the tab you wish to configure. The widgets available for the selected tab are displayed in the Available Content column.
3. Move the widgets you want displayed to the Row columns.
4. Use the direction arrows to reorder the widgets as desired.
5. When you finish configuring all the tabs, click Save.
6. To exit the configuration window, click Close.
7. Refresh the Dashboard to see your changes.

Personalizing the Project Summary Page

You can personalize the Project Summary page to display chosen widgets only, in the order in which you want to see them.

The Summary page offers a two-column view - one wide and one narrow. Each column contains a set of configurable widgets.

**To personalize summary page widgets:**
1. On the Project Summary page, click Personalize. Two sets of configurable widgets are displayed.
2. To avoid displaying a widget in the Summary page, deselect the check box next to the widget name.
3. To change the order in which the widgets display, drag each one up or down to the desired location.
4. After you make changes, click Save for the changes to take effect.

Configuring Timesheet Display

The Timesheet feature enables you to view records of actual time reported against all In Process projects in the system. Project managers with appropriate privileges can view time transactions reported against a project or group of projects, in order to conduct audits across projects, business units, or other criteria.

The Timesheet tab is visible only if your user settings are configured appropriately.

**To display the Timesheet tab:**
1. Click My Settings on the left panel.
2. In the **Preferences** tab, click **Edit** to make the fields editable.

3. Under **Display Preferences**, change the **Show Timesheet** option to **Yes**.

   The Timesheet tab is now displayed next to My Assignments.

   **Note**  
   When you change preference settings, you must log out and then log in again for the changes to become effective.

### Setting Up Microsoft Project Integration

**Note**  
In Agile PLM 9.2.1, integration with Microsoft Project 98 and 2000 project files is no longer supported. Microsoft has discontinued support for these versions. If users have Microsoft Project 98 or 2000 project files with which they would like to work, users must open the files in Microsoft Project 2002 or 2003 to automatically convert the project files to the appropriate format. For more information, select **Help > Microsoft Project Help** in the Microsoft Project 2002 or 2003 menu.

Integration with Microsoft Project 2002 and 2003 is supported. See **Automatic Installation from PPM SmartRule** on page 149 for more information about automatic installation of the appropriate DLLs.

See also:

- **Modify Privilege Mask Applied To Properties that Control Specific User Actions** for information about modify privilege mask properties that control access to Microsoft Project integration features.
- **Transferring Microsoft Project Work Values to Agile PPM as Days Effort** on page 159
- **Using Custom Agile PPM Subclasses in Microsoft Project 2002 and 2003** on page 159
- **Attribute Mapping** on page 157

### Attribute Mapping

The Agile-provided MSP/Agile PPM mapping file (MSPSyncMapping.properties on the Agile server) provides synchronization mapping between Agile PPM objects and Microsoft Project.

For Activities and Gates, you can edit the mapping file as described here. Only TEXT and DATE EXTENDED ATTRIBUTES, DEADLINE attribute (task level attribute) are supported. They can be mapped to out-of-the-box TEXT, and DATE FLEX FIELDS on Page Two. Page Three attributes cannot be mapped.

The attribute mapping should be in the following format:

```
<key> = [<Mapping 1>],[<Mapping 2>],[<Mapping3>],..[<Mapping n>]
```

where

- `<key>` represents the class for which the attribute mapping is defined. It can only have the following values:
  - "msp.pe.attribute.activities.map" for Activity class
"msp.pe.attribute.gates.map" for Gate class

<Mapping 1>, <Mapping 2>, <Mapping 3>,..., <Mapping n> represents one attribute mapping definition.

All individual attribute mapping definitions above (every <Mapping n>) should be in the following format.

<Field Name> | ExtendedAttribute.<Field Name> = PAGE_TWO.<DB Column Name>

where

<Field Name> represents the MSP attribute name with the following notation:

- Use <Field Name> notation to specify MSP task level attributes (currently only Deadline is supported).
- Use ExtendedAttribute.<Field Name> notation to specify MSP Extended attributes.

<DB Column Name> represents the PAGE_TWO table's column name in the Agile database. This is available in the attribute property of the attribute in Java Client Administrator under the Data Settings > Classes node.

For each extended attribute mapped from MSP, you need to specify the field ID associated with it. The field IDs for each of the MSP extended attributes used for mapping definition should be specified in the following format:

msp.attribute.ExtendedAttribute.<Field Name>.id = <Field ID>

where

<Field Name> represents the MSP Extended Attribute's name.

<Field ID> represents the unique integer(ID) defined in MSP that is associated with the extended attribute. After enabling the extended attribute in MSP, the field ID can be obtained from the Project Element's ExtendedAttributes tag in the .xml file.

A sample format is provided here. You can extend this format if you want to map more extended attributes from MSP.

msp.pe.attribute.activities.map=[ExtendedAttribute.Text1 = PAGE_TWO.TEXT11], \\
[ExtendedAttribute.Date1 = PAGE_TWO.DATE01], \\
[Deadline = PAGE_TWO.DATE02]
msp.pe.attribute.gates.map=[ExtendedAttribute.Text1 = PAGE_TWO.TEXT11], \\
[ExtendedAttribute.Date1 = PAGE_TWO.DATE01], \\
[Deadline = PAGE_TWO.DATE02]
msp.attribute.ExtendedAttribute.Text1.id = 188743731
msp.attribute.ExtendedAttribute.Date1.id = 188743945

Note: If the mapping definition is not in the format specified, the corresponding definition will be IGNORED and an error message will be logged in the server console. NO USER EXCEPTION will be shown.
Using Custom Agile PPM Subclasses in Microsoft Project

If you have defined custom Agile PPM subclasses, users can specify those subclasses in Microsoft by using Microsoft Project column Text29.

To enable the use of custom Agile PPM subclasses in Microsoft Project 2002 or 2003:

1. In Microsoft Project, right-click on the column headers.
2. Select Insert Column.
3. Select Text29 for the field name. The default Agile PPM subclass names are displayed.
4. As you create new tasks and enter them, you can type in this field the name of any custom Agile PPM activity subclass. If you leave the field blank, the Agile PPM default subclasses are used.

Note The subclass name you enter must be spelled correctly; if the name is not spelled correctly, the out-of-box default subclass names will be displayed.

Transferring Microsoft Project Work Values to Agile PPM as Days Effort

In Agile, days effort is always calculated based on the % allocation and duration. Agile requires an allocation to a resource or resource pool in order for days effort to be populated. To handle the publishing of tasks from Microsoft Project, where work values are entered, you can set up a global resource pool to hold the work/days effort values. If you set up a global resource pool, users will notice that tasks which satisfy these conditions have a global resource pool associated to them on the Team tab.

To set up the global resource pool:

1. Enter the resource pool name in the MSPSyncMapping.properties file.
2. Restart the server.
3. Create the resource pool ensuring that:
   a. You use the name you entered in the MSPSyncMapping.properties file.
   b. The resource pool is a Global resource pool.

   The resource pool must be created as Global in order to enable the mapping.

Important This mapping is ignored and work values are discarded if either of the following is true:

   The resource pool name is configured in the properties file, but the resource pool does not exist (not created).

   The resource pool name is configured in the properties file and the resource pool has been created, but it does not meet the criteria; it is not a Global resource pool.
Deleting Agile Objects

This Appendix includes the following:

- Soft-Deleting an Object ................................................................. 162
- Undeleting an Object ................................................................. 162
- Hard-Deleting an Object ............................................................. 162

Java Client and Web Client support “soft” and “hard” deletes for many Agile object classes. When you soft-delete an object in the database, it is not permanently deleted. A soft-deleted object is marked “Deleted” in the database, and its object number or name is reserved. You cannot create another object with the same type and number or name as a soft-deleted object.

When you run a search, soft-deleted objects do not appear in the search results table. To locate soft-deleted objects, you must run the predefined deleted object searches in the Recycle Bin Searches folder.

**Note** You have access to the Recycle Bin Searches folder if Recycle Bin Searches is included in the Searches field of your user profile. If you have the appropriate privileges, you can edit your user profile and add Recycle Bin Searches to the list of searches in the Searches field. If you do not have the appropriate privileges to modify the Searches field in your user profile, ask the Agile administrator to modify your user profile.

A hard-deleted object is permanently removed from the database.

**Caution** You cannot undelete a hard-deleted object.

In order to soft-delete, hard-delete or undelete an Agile object:

- You must have the appropriate Delete or Undelete privileges for that object.
- All relationships and subscriptions must be removed.
- The object must meet any additional conditions that determine whether it can be deleted or undeleted.
  
  In general, if deleting or undeleting an object would cause the compromise of data integrity, the delete or undelete action is disabled.

This section contains the following topics:

- Soft-Deleting an Object on page 162
- Undeleting an Object on page 162
- Hard-Deleting an Object on page 162
Soft-Deleting an Object

When an object is soft-deleted, it is no longer available for use. However, until it is hard-deleted, its number or name is reserved in the Agile database and cannot be reused.

**To soft-delete an object in Java Client:**
1. Select and open the object you want to delete.
2. Click the Delete button \( \times \), and respond Yes to the confirmation prompt.

The object is soft-deleted.

**To soft-delete an object in Web Client:**
1. Select and open the object you want to delete.
2. Choose Actions > Delete, and respond OK to the confirmation prompt.

The object is soft-deleted.

See also: Deleting Agile Objects, Undeleting an Object on page 162, and Hard-deleting an Object on page 162.

Undeleting an Object

If you have the appropriate privileges, you can undelete soft-deleted objects.

**To undelete an object in Java Client:**
1. Run the appropriate Deleted `<objects>` search from the Recycle Bin Searches folder.
2. Open the deleted object you want to restore.
3. Click the Undelete button \( \times \).

**To undelete an object in Web Client:**
1. Run the appropriate Deleted `<objects>` search from the Recycle Bin Searches folder.
2. Open the deleted object you want to restore.
3. Choose Actions > Undelete.

**Note** You can click the Navigator button in the search results table to display the search result object links in the left pane NAVIGATOR drawer.

See also: Deleting Agile Objects, Soft Deleting an Object on page 162, and Hard-deleting an Object on page 162.
Hard-Deleting an Object

Soft-deleted objects still exist in the database. To remove an object permanently, you must hard-delete it. While an object is still only soft-deleted, you can undelete it. Run the appropriate Deleted object search from the Recycle Bin Searches folder.

To hard-delete a soft-deleted object (if you have the appropriate privileges) in Java Client:
1. Run the appropriate Deleted <objects> search from the Recycle Bin Searches folder.
2. Open the object.
3. Click the Delete Object button, and respond Yes to the confirmation prompt.

To hard-delete a soft-deleted object (if you have the appropriate privileges) in Web Client:
1. Run the appropriate Deleted <objects> search from the Recycle Bin Searches folder.
2. Select the one or more object rows in the search results table.
3. Click the Delete button.
4. In response to the warning prompt, choose Continue, then click Finish.
5. Or, you can hard-delete one object at a time:
   • Open the object.
   • Choose Actions > Delete, and respond OK to the confirmation prompt.

Note You can click the Navigator button in the search results table to display the search results object links in the left pane Navigator drawer.

See also: Deleting Agile Objects, Undeleting an Object on page 162, and Soft Deleting an Object on page 162.