ホーム

www.oracle.com

新機能

最新の機能については、ESSO-LMのリリース・ノートを参照してください。

ヘルプの内容

  • コンソールの概要
  • 初回の設定
  • グローバル・エージェント設定
  • トラブルシューティング

最新のドキュメント

オンライン・ドキュメンテーション・センターにある最新のESSO-LMドキュメントを参照してください。

Copyright ©2006-2010, Oracle.All rights reserved.

バージョン11.1.1.2.0


概要および機能

Oracle Enterprise Single Sign-on Logon Manager （ESSO-LM）では、ユーザーは1つのパスワードを使用して、社内ネットワークとインターネットの両方のあらゆるアプリケーションにログオンできます。ESSO-LMの使用には、プログラミングやネットワーク・インフラストラクチャの追加は必要ありません。ESSO-LMはそのままで動作し、Windows、Web、プロプライエタリおよびホストベースのあらゆるアプリケーションに対応するため、統合のための費用と負荷が発生せず、ITおよびヘルプ・デスクのコストが削減されます。

ESSO-LMは、ユーザーにかわり、ユーザーのデスクトップからログオン・リクエストに直接応答することによって機能するインテリジェント・エージェント・ソフトウェアです。このエージェントは、直接および自動的に正しい資格証明（ユーザー名/IDやパスワードなどのフィールド）を指定することによって、各ソフトウェア・アプリケーションのログオン・リクエストに応答します。厳密な認証メカニズムによって、エージェントへのアクセスが制御されるため、指定されたユーザーのみがアクセスできます。

機能 | 利点
シングル・サインオン | ネットワーク、アプリケーションおよびWebサイトにログオンするための1つのパスワードを提供します。
認証方式の選択肢 | WindowsのログオンまたはLDAPディレクトリ・サーバーのログオンを使用して認証を行います(ESSO-AM は、主要な認証として、スマート・カードのような厳密な認証方式を採用しています）。
可動性のサポート | ユーザーは、任意のワークステーションからログオンでき、ディレクトリ・サーバー、データベース・システム、ファイル・システムおよびWindowsのローミング・プロファイルを経由して、自分のESSO-LM資格証明を使用できます。（ESSO-AMユーザーは、スマート・カードを使用してログオンできます） 。
ワークステーションの共有 | 複数のユーザーが同じワークステーションを共有できます。
パスワードの自動変更 | ユーザーが自分の新しいパスワードを選択するか、またはエージェントが承認済のパスワード・ルール（パスワード・ポリシー）を使用して自動的にパスワードを選択することができます。
厳密な認証 | ソフト・トークンをベースにした2つの要素による認証によって、不当なアクセスから保護されます。
イベント・ロギング | ログオンやパスワード変更などのイベントを自動的にログに記録します。
自動プロンプト | パスワードで保護された新しいアプリケーションをユーザーが使用しようとした場合に、ログオンを構成するように自動的に求めます。
資格証明の共有 | 複数のアプリケーションが同じ資格証明を共有できます。
集中管理 | すべての構成および設定は、ESSO-LM Administrative Consoleを経由して集中管理できます。
自動バックアップ/リストア | ディレクトリ・サーバー、リレーショナル・データベース、ファイル・システムなどのリモートの場所に、ユーザー資格証明を自動的にバックアップし、システムがクラッシュした後、ユーザー資格証明を自動的にリストアします。
ログオンのユーザー構成 | 管理者によって事前定義されたログオン以外に、ユーザーは、他のアプリケーションおよびWebサイトに対して必要となる個別ログオンを追加できます。
カスタマイズ | ユーザー設定など、ユーザーの操作環境の多くの側面をカスタマイズして、組織のセキュリティ要件およびユーザー集団の高度な技術に製品を適応させることができます。
セキュアなアーキテクチャ | エージェントは非常にセキュアに設計されているため、管理者はパスワードの漏洩を回避できます。また、最新の暗号化アルゴリズムが呼び出され、改ざん耐性モジュールが使用されます。


ESSO-LMの新機能

ESSO-LM 11.1.1.2.0の新機能

ESSO-LMバージョン11.1.1.2.0は、Oracle Enterprise Single Sign-on Logon Manager AgentおよびESSO-LM Administrative Consoleの最新版です。このリリースの新機能については、ESSO-LM のリリース・ノートを参照してください。


コンソールの概要

コンソールについて

ESSO-LM Administrative Consoleでは、次に示すほとんどのエージェント・オプションのエージェント構成およびサーバー構成を両方実行できます。

  • 次のものの作成、管理および配置の簡略化
  • アプリケーション構成およびアプリケーション構成リスト
  • 資格証明共有グループ
  • パスワード・ポリシー
  • バルク追加リスト
  • エージェント構成設定（レジストリ設定を使用）
  • シンクロナイザ拡張の設定および管理の簡略化
  • LDAPディレクトリ・サーバー（Tivoli Directory Server、Novell eDirectory、Oracle Directory Server、Sun Java System Directory Server、OpenLDAPディレクトリ・サーバーを含む）
  • Microsoft Active Directory Serverシステム（Application Modeを含む）
  • リレーショナル・データベース・システム（Microsoft SQL Server、IBM DB2、Oracle 9i/10gを含む）
  • ファイル・システム

コンソールでは、構成ファイルまたはレジストリを手動で編集する必要がなくなりました。これに関連して、不要なキーに触ったり、または無効なパラメータを入力するなどのエラーが発生することもなくなりました。

コンソールの機能は、いくつかの領域に分類されます。次に、その領域と関連項目を示します。

アクション | コンソールの機能 | 関連項目
アプリケーション構成の作成および管理 | Applications | アプリケーション・ログオンの構成に関する項
パスワード生成ポリシーの作成および管理 | Password Generation Policies | パスワード・ポリシーの設定
パスフレーズ・セットの作成および管理 | Passphrase Questions | パスフレーズ・セット
資格証明共有グループの作成および管理 | Credential Sharing Groups | 資格証明共有グループの作成
バルク追加リストの作成および管理 | 「Applications」の「Bulk Add」タブ | はじめて使用する場合
エージェント構成設定 | Global Agent Settings | グローバル・エージェント設定の構成
シンクロナイザ拡張の設定および管理 | Synchronization | 同期
リポジトリの設定および管理 | Repository | リポジトリ


対象読者

このマニュアルの内容は、ESSO-LMの計画、実装および配置を担当する経験豊富な管理者を対象としています。管理者は、シングル・サインオンの概念（パスワード・ポリシー、ログオン方式、資格証明共有グループ、アプリケーション構成など）を理解し、ディレクトリ・サーバー、データベースおよびリポジトリの構成に精通していることが求められます。また、インストールおよび構成手順を実行する担当者は、社内のシステム標準を熟知している必要があります。読者は、セキュリティ管理における定型業務を実行できる必要があります。


製品概要

ESSO-LM では、特有のプロセスを使用して、資格証明に対するリクエストの検出、必要な応答の分析、信頼性の高い応答、イベントのロギングおよび設定の管理を行います。

アーキテクチャ/モジュール

ESSO-LMコンポーネントのアーキテクチャでは、柔軟性を最大限に発揮して、組織のニーズに対応します。

ESSO-LMのアーキテクチャは、認証、暗号化、インテリジェント・エージェント・レスポンス、コア（ストレージを含む）、資格証明の同期、イベント・ロギング、 その他のコンポーネントという7つの領域で構成されています。さらに、ESSO-LM Administrative Consoleによって管理が容易になります。

認証

認証は、システムがユーザーを検証してESSO-LMにアクセスできるようにする方法です。認証は、（1）認証方式自体、（2）認証サービス、および（3）ESSO-LMの認証方式APIの3つのレイヤーで構成されています。システムがユーザーの検証を行った後、そのユーザー検証情報がコア・シェルに渡されます。

ESSO-LMでは、次の認証方式が提供されています。

  • Windowsドメイン（同じパスワードがネットワークへのログオンに使用される）
  • Windows Authentication v2
  • LDAP Directory Server
  • LDAP Directory Server v2
  • Authentication Manager

ESSO-AMでは、次の認証方式が提供されています。

  • Entrust Entelligence
  • Proximity Card
  • Read-Only Smart Card
  • RSA SecurID
  • Smart Card

サポートする認証方式、各コンピュータにインストールする認証方式、および各ユーザーに対して有効にする認証方式を決定します（デフォルトでは、Windows Domainがインストールされています）。

詳細は、「Windows認証用の構成」を参照してください。

[ ダイアグラム表示 ]

暗号化

暗号化によって、データ・ストアのユーザー資格証明が保護されます。シェル（コア）は、適切なCrypto Libraryアルゴリズムに基づいて、資格証明を暗号化または復号化するように要求します。エージェントは、自動的に資格証明を新しいアルゴリズム/強度（Triple-DESからAESなど）に移行します。

ESSO-LMでは、様々な暗号化アルゴリズムおよびアルゴリズム強度がサポートされており、企業、法律、セキュリティ、パフォーマンスなどの要件に対応しています。

ESSO-LMでは、いくつかの一般的なアルゴリズムが提供されています。

  • Cobra 128ビット
  • Blowfish 448ビット
  • Triple-DES 168ビット
  • AES 256ビット
  • Triple-DES（MS CAPI）（すべてのOS）
  • Triple-DES（MS CAPI）（XP/2003のみ）
  • RC-4（MS CAPI）（すべてのOS）
  • RC-4（MS CAPI）（XP/2003のみ）
  • AES（MS CAPI）（XP/2003のみ）

その他のアルゴリズムも暗号化モジュールとして機能します。

ユーザーが使用できる暗号化アルゴリズム、および新規または変更された資格証明で使用すべき暗号化を決定します（デフォルト: Triple-DES）。

デフォルトのアルゴリズムおよび強度の設定の詳細は、セキュリティの制御の設定に関する項を参照してください。

先頭

インテリジェント・エージェント・レスポンス

アプリケーションが資格証明のリクエストを提示すると、エージェントはこのイベントを検出し、適切なアクションを判断して、正しい資格証明を返します。これらの評価を実行するインタフェースがインテリジェント・エージェント・レスポンスです。このインテリジェント・エージェント・レスポンスがアクセス・マネージャと接続して、適切な資格証明を各アプリケーションに提供します。アクセス・マネージャはシェルから資格証明を取得します。

Windowsサポートは自動インストールされます。Webアプリケーションまたはホスト・アプリケーション（あるいはその両方）のサポートをインストールするかどうかを決定します（デフォルトでは、すべてのモジュールがインストールされていますが、ホストのサポートは無効になっています）。

ESSO-LMでは、組み込まれている一般的なアプリケーションの構成情報が提供されています。

組込みアプリケーションの詳細は、含まれているアプリケーションの構成に関する項を参照してください。他のアプリケーション構成の追加の詳細は、アプリケーション・ログオンの構成に関する項を参照してください。

先頭

アプリケーション構成

ESSO-LMは、デフォルトのインストール設定で動作します。ただし、ESSO-LMには柔軟性があるため、あらゆる組織に固有のニーズにも対応できます。最も一般的にカスタマイズされた機能を次に示します。

  • 事前定義されたログオン: 事前定義されたログオン・リストからユーザーが選択できるようにすることによって、操作性を改善します。アプリケーションには、Windowsアプリケーション、ホスト・アプリケーションおよびWebアプリケーションがあります。
  • 可動性のサポート: 位置の透過性と自動バックアップおよびリストアを実現します。
  • イベント・ロギング: ログオンやパスワード変更などの様々なイベントをESSO-LMがログに記録できるようにします。
  • はじめて使用する場合: ユーザー設定プロセスをカスタマイズして、組織のニーズへの対応と操作性の改善を行います。
  • パスワード・ポリシー: 企業のセキュリティ・ポリシーの伝播、セキュリティの改善、および自動化されているときの操作性の改善を行います。
  • ESSO-LM設定: UIの制御、セキュリティの実装、機能の有効化、無効化と構成などを行います。

これらの各決定は、計画、配置、使用、管理の各段階に影響を与えます。

先頭

ホスト・エミュレータ

ESSO-LMでは、多数のホスト・エミュレータがサポートされています。ホスト・エミュレータがある場合は、どのホスト・エミュレータをエージェントが認識するかを決定します（デフォルトでは、エージェントは、サポートされているすべてのエミュレータに対して機能しますが、エミュレータによっては、エミュレータの構成が必要になる場合があります）。

ESSO-LMを配置する前に、エージェントとともに機能するようにホスト・エミュレータを構成することをお薦めします。

ホスト・エミュレータの詳細は、「ホスト・エミュレータの構成」を参照してください。

先頭

コア（ストレージを含む）

優先暗号化アルゴリズムを使用して、エージェントはユーザー資格証明を暗号化し、暗号化されたローカルの資格証明ストレージにローカルに格納します。エージェントは、ディスク上やメモリー内に、暗号化されていない状態で資格証明を保持することはありません。資格証明はユーザー固有のセキュアなデータベース・ファイルに格納されます。このファイルに格納されるのは、ユーザー資格証明、ユーザー設定、構成に関する追加情報の各セットを暗号化したレコードです。

先頭

資格証明の同期

エージェントは、ユーザーの資格証明および設定をローカルに格納しますが、この資格証明および設定をリモート・ファイル・システム、ディレクトリ、データベース、デバイスなどと同期することができます。同期の対象にできるのは、（すべてのユーザー資格証明が格納されている）ユーザーのデータベース・ファイル全体またはデータベース内の個々のレコードです。同期は、ローカル資格証明ストレージまたは設定の変更によって発生します。同期は、同期APIを経由して、任意のストレージ・メカニズムに対して拡張することもできます。

エージェント管理は、同期コンポーネントを経由して全面サポートされています。また、管理者は、集中ストレージ・メカニズムを使用して、更新された設定および構成データをエージェントに動的に配信できます。

先頭

同期拡張

エージェントは様々な同期拡張を行うため、ユーザーは任意のデスクトップから自分の資格証明にアクセスできます。

ESSO-LMに含まれているシンクロナイザ拡張は、次のとおりです。

  • 次のようなLDAP対応のディレクトリ・サーバー
  • IBM Tivoli Directory Server
  • Oracle Directory Server
  • Novell eDirectory
  • Sun Java System Directory Server
  • OpenLDAPディレクトリ・サーバー
  • Microsoft Active Directory Server
  • 次のようなSQL対応のリレーショナル・データベース・システム
  • Microsoft SQL Server
  • IBM DB2
  • Oracle
特定のバージョンの情報については、最新のESSO-LMのリリース・ノートを参照してください。

ESSO-LMには、リモートのネットワーク・ドライブ共有などで、1つのファイル・システムをサポートするシンクロナイザ拡張もあります。

各コンピュータにインストールする同期モジュール、各ユーザーに対して有効にするモジュール、および各拡張の構成方法を決定します。（デフォルトでは、シンクロナイザ・モジュールはインストールされていますが、同期拡張はインストールされていません）

  • 可動性の詳細は、「可動性の構成」を参照してください。
  • 同期の詳細は、ユーザー資格証明および設定の格納に関する項を参照してください。
  • ディレクトリ・サーバーの詳細は、「ディレクトリ・サーバー同期サポート」を参照してください。
  • データベース・システムの詳細は、「データベース同期サポート」を参照してください。
  • ファイル・システム同期拡張の詳細は、「ファイル・システム同期サポート」を参照してください。

先頭

イベント・ロギング

エージェントは、シェルからの通知を受けて、資格証明の使用、資格証明の変更、グローバルな資格証明イベント、エージェントのイベント、エージェント機能の使用を含む、すべてのSSOシステム・イベントをログに記録できます。また、エージェントは、指定されたフィールドをログに記録することもできます。イベントは、ローカルに記録することも、イベント・ロギングAPIを経由して任意の外部の宛先に記録することもできます。これらの宛先には、SNMPサービス、（Windowsイベント・ログを経由して表示するための）Windowsサーバー、簡略化されたな解析および報告を行うためのローカルのXMLログ・ファイルがあります。

エージェントは、イベント・ロギングAPIを使用して、すべてのイベントをログに記録できます。

ESSO-LMは様々なイベント・ロギング拡張を行います。ローカルとリモートの両方のサーバーに書き込むイベント・ロギング拡張には、次の2つがあります。

  • ローカル・ファイル拡張: 書込み先はXMLファイル
  • Windowsイベント・ロギング拡張: 書込み先はWindowsイベント・ロギング・サーバー
  • Oracleから追加の拡張をリリースする可能性があり（SNMPやOracleなど）、ユーザー独自の拡張を作成することもできます。

各コンピュータにインストールするイベント・ロギング・モジュール、各ユーザーに対して有効にするモジュール、拡張の構成方法、これらの拡張にエージェントが書き込む頻度、エージェントがキャッシュするデータの量、エージェントによるログの書込み先などを決定します（デフォルトでは、イベント・ロギング・モジュールはインストールされておらず、ロギングも行われません）。

詳細は、「イベント・ロギング」を参照してください。

先頭

その他のコンポーネント

ESSO-LMには、次のようなその他のモジュールも含まれています。

バックアップ/リストア

資格証明の同期を実行しないユーザーのために、バックアップ/リストア・コンポーネントによって、ユーザー資格証明をアーカイブおよびリストアすることができます。

CitrixおよびWindows Terminal Servicesのツール

環境によっては、Citrix MetaFrameまたはWindows Terminal Servicesの環境でエージェントを使用する必要があります。このような環境でESSO-LMが各セッション内で適切に対話できるように、追加のコンポーネントが提供されています。

インストーラ・パッケージ

ESSO-LMは、Windows Installerパッケージに含まれており、そのテクノロジの柔軟性を活かし、配置とカスタマイズが簡単にできるようになっています。

先頭

共通のシナリオ

はじめて使用する場合

エージェントは、ユーザーに対して、事前定義されたアプリケーションの現在の資格証明を入力するように要求できます。資格証明がある場合は、どの資格証明を要求するかを決定します（デフォルトでは、エージェントは、どのアプリケーションの資格証明も要求しません）。

はじめて使用する場合の問題の詳細は、「はじめて使用する場合（バルク追加）」を参照してください。

ユーザー作業モード

ESSO-LMでは、「One Workstation, One or Multiple Users」から「Frequent Movement Among Many Workstations」、および常時接続から頻繁な切断までの作業モードがサポートされています。

はじめて使用する場合の問題の詳細は、「ユーザー作業モード」を参照してください。

操作とセキュリティ

ESSO-LMでは、組織に適した操作性とセキュリティのバランスを選択できます。

はじめて使用する場合の問題の詳細は、操作性の制御の設定に関する項を参照してください。

パッケージング/配信/インストール

ESSO-LMは、ほとんどの配置ツールおよび配置メソッドをサポートしています。どのコンポーネントをどのデスクトップに配置するかを決定します。

配置の詳細は、エージェントの配置に関する項を参照してください。

先頭

リソース

ESSO-LMでは、プログラミング・ファイル、設定およびデータが、すべて次の場所に格納されます。

  • %ProgramFiles%\Passlogix\v-GO SSOディレクトリには、ESSO-LMプログラム・ファイルが含まれています。（デフォルトは、C:\Program Files\Passlogix\ESSO-LMです）
  • %ProgramFiles%\Passlogix\v-GO SSO\Consoleディレクトリには、ESSO-LM Administrative Consoleプログラム・ファイルが含まれています。（デフォルトは、C:\Program Files\Passlogix\v-GO SSO\Consoleです）
  • %ProgramFiles%\Passlogix\SSO File Sync Serviceディレクトリには、SSO File Sync Serviceプログラム・ファイルが含まれています。（デフォルトは、C:\Program Files\Passlogix\SSO File Sync Serviceです）
  • %AppData%\Passlogixディレクトリには、ユーザー・データ・ファイルが含まれています。（デフォルトは、OSによって異なります。Windows 2000では、C:\Documents and Settings\%UserName%\%AppData%\Passlogixです）
  • HKCUレジストリ・ツリーには、ユーザーのデフォルト設定が格納されます。
  • HKEY_LOCAL_MACHINE\SOFTWARE\Passlogix registryレジストリ・ツリーには、優先設定（ユーザー設定より優先される設定）およびESSO-LMのデフォルトが格納されます。
  • ディレクトリ・サーバー上のSSOLocatorオブジェクトによって、各ユーザーの資格証明が格納されている場所（SSOConfigオブジェクト）がESSO-LMに指示されます。
  • ディレクトリ・サーバー上のSSOConfigオブジェクトおよびファイル・システム上の類似オブジェクトには、優先設定およびユーザー・データが格納されます。

SSOConfigオブジェクトの設定は、レジストリの設定より優先されます。

デフォルト名はSSOConfigですが、任意の名前に変更できます。

先頭


重要な項目

ESSO-LMを配置する前の考慮事項

ここでは、ESSO-LMの配置および管理に関する重要な概念および考慮事項について説明します。

ユーザー作業ノード | 様々な構成で作業するエージェント側のサポート・ユーザーを設定する様々な方法、および各シナリオで構成を最適化する方法についての理解
構成 | 様々な構成で作業するサーバー側のサポート・ユーザーを設定する様々な方法、および各シナリオで構成を最適化する方法についての理解
ロールアウト | ESSO-LMを組織にロールアウトするときのプロセスおよび問題についての理解
管理 | ESSO-LMの配置に関するロールアウト後の問題についての理解


ユーザー作業モード

ユーザーは、次のような様々な作業モードでコンピュータにアクセスします。

  • 複数のユーザーが常に特定のワークステーションを使用し、単一のユーザーである場合
  • 複数のユーザーが、制限された数のワークステーション間を頻繁に移動する場合（ある部門の看護師など）、または1日または数時間ごとに別のワークステーションに移動する場合（コールセンターなど）
  • 複数のユーザーが（シフトなどで）単一のワークステーションを共有する場合。このようなワークステーションは、スマート・カードなどのトークンを使用してログオンする複数のユーザーによってKioskとして使用されます。
  • ユーザーが常時ネットワークに接続していない場合

ESSO-LMでは、前述のすべてのシナリオがサポートされ、ユーザーの最も一般的なシナリオ用に最適化できます（デフォルトでは、ユーザーは常に特定のワークステーションを使用しますが、他のユーザーと共有しています）。

1台のワークステーションに1人のユーザー

ユーザーが常に特定のワークステーションを使用する場合は、SSOシンクロナイザ拡張を使用して、そのユーザーの資格証明をリモートの場所にバックアップできます。詳細は、「同期」を参照してください

また、バックアップ/リストア機能モジュールでは、リモート・リポジトリを使用しなくてもワークステーションに資格証明を保存できます。バックアップ/リストア・モジュールは、デフォルトではインストールされていません。ユーザーが手動でバックアップを実行するか、またはバックアップを自動化できます。詳細は、「ファイルベースのバックアップ/リストア」を参照してください。

少数のワークステーション間で頻繁に移動

ユーザーが少数のワークステーション間を頻繁に移動する場合でも、それらの少数のワークステーションが常に使用されている場合は、ESSO-LM資格証明をサポートする基本的なオプションが2つあります。

推奨するオプションは、リモートSSOリポジトリを使用する方法です。エージェントの起動および資格証明の変更のいずれを実行しても、すべてのレコードに対してレコード・レベルの比較（同期）が強制的に実行されます。その結果、常にユーザーはできるかぎり最新の資格証明を持つことになります。

もう1つのオプションは、ネットワーク・ファイル共有への自動サイレント・バックアップ を構成する方法です。適切に構成すると、エージェントでは、資格証明が変更されるたびに（リフレッシュ・タスク）、リモート・ストア（ネットワーク・ドライブ）へのサイレント・バックアップが実行されます。最初にエージェントが起動すると、リモート・ストアがローカル・ストアより新しいかどうかが確認されます。新しい場合は、サイレント・リストアが実行されます。いずれの場合も、ユーザーは現行の資格証明を保持します。これは、（レコード・レベルではなく）ファイル・レベルの比較であるため、ユーザーが同時に2台以上のコンピュータにログオンする場合、このオプションは安全ではありません。

多数のワークステーション間で頻繁に移動

ユーザーが多数のワークステーション間で頻繁に移動する場合は、資格証明をサポートする基本的なオプションが2つあります。

推奨するオプションは、リモートSSO同期リポジトリを使用する方法です。エージェントの起動および資格証明の変更のいずれを実行しても、すべてのレコードに対してレコード・レベルの比較（同期）が強制的に実行されます。その結果、常にユーザーはできるかぎり最新の資格証明を持つことになります。また、セキュリティを強化し、使用ディスク領域を削減するには、「Delete Local Cache (on Shutdown)」オプションを有効にします。

または、Windows環境がすでにWindowsローミング・プロファイルを使用して設定されている場合、ユーザー・データは%AppData%ファイル・ディレクトリに追加されるため、自動的にユーザーが使用可能になります。ただし、Windowsローミング・プロファイルには非常に帯域幅を消費するという特徴があるため、SSO資格証明とともに使用することはお薦めしません。

1台のワークステーションに多数のユーザー

単一のワークステーションに、多数のユーザーがアクセスする場合があります（Kioskなど）。Kioskにログオンするには、スマート・カード（またはその他のトークン）およびPINを使用できます（ESSO-AMのみ）。これらのユーザーがリモートSSOリポジトリにアクセスできるようにするために、ssoSCDetectユーティリティを使用して、スマート・カードをリーダーに挿入するたびに、ESSO-LM Agentを起動させ、プライマリ・ログオンを要求するようにできます。スマート・カードを取り外すと、ユーザーは自動的にエージェントからログアウトされます。詳細は、「ssoSCDetect（スマート・カード監視ユーティリティ）」を参照してください。

切断

ユーザーがラップトップを使用しているか、またはリモートの場所にいる場合は、長時間ネットワークから切断されたままでいることがよくあります。

ESSO-LM Agentでは、資格証明がローカルに保存されるため、ネットワーク接続を使用できないモバイル・ユーザーに完全な独立性がもたらされます。ユーザー資格証明および設定の格納やイベント・ロギングなどのESSO-LMモジュールでは、不定期の再接続がサポートされているため、信頼性が保証されます。

ファイルベースのバックアップ/リストアでは、ユーザーは自分自身のデータをフロッピーやZipドライブに保存できます。ESSO-AMでは、ユーザーは自分自身のデータをスマート・カードに保存できます。

ESSO-LMシンクロナイザ拡張は、「Disconnected Operation」を含む同期オプションを使用するオフライン・ユーザー用に構成されます（可動性の制御の設定に関する項を参照）。

操作性とセキュリティ

セキュリティ: ロックダウンとユーザーの自由

組織のポリシーに適したセキュリティとリスク/信頼レベルのバランスをとるように、ESSO-LMをカスタマイズできます。たとえば、ユーザーが特定の処置を実行する必要がある組織もあれば、それほどセキュリティを意識していない組織もあります。

操作性: ユーザーの柔軟性と簡易性

組織のポリシーに適した操作性とユーザーのスキル・レベルのバランスをとるように、ESSO-LMをカスタマイズできます。たとえば、最も簡単なユーザー・インタフェース以外は使用できないユーザーが多数の組織もあれば、より経験のあるユーザーを雇い、その環境で柔軟性を確保しようとする組織もあります。

その他の設定

ESSO-LMは多数の方法でカスタマイズでき、ユーザー、コンピュータまたはグループのレベルでこれらの設定を強制的に実行できます（グループ・レベルには、企業全体が含まれる場合があります）。詳細は、「グローバル・エージェント設定」を参照してください。


可動性の構成

ある組織では、非常に集約された方法（たとえば、1つの親オブジェクトの下にすべてのユーザー・データ・ストア・オブジェクト）でSSOリポジトリ・コンポーネント（ディレクトリ・サーバー、リレーショナル・データベース、ファイル・システム共有）を構成します。他の組織では、分散された構造（たとえば、部門、場所、従業員のレベルごとに1つの親オブジェクト）を使用します。いずれの組織にも、現在および将来のネットワーク・トポロジによって異なる長所と短所があります。一般的な長所と短所は、次のとおりです。

集約

長所

短所

  • グローバルに構成しやすい。
  • 管理しやすい。
  • ロード・バランスが難しい。
  • ユーザーの母集団が分散され、ユーザー・データがローカルでレプリケートされない場合（たとえば、New York のサーバー上のデータを東京から検索する場合）は、帯域幅を多く消費する。
分散

長所

短所

  • 詳細に設定できる（ユーザーごとのセキュリティなど）。
  • リソースを簡単に再割当てできる（たとえば、ユーザーが別のサーバーの近くに移動したときに、ユーザー・データ・オブジェクトも移動し、いくつかのサーバーにデータを分割する）。
  • 管理が難しい。
  • 1つのデータ・セットで間違いをしやすく、その不一致に気付きにくい。

ESSO-PG

ESSO-PR

Oracle Enterprise Single Sign-on Password Reset

ESSO-LM

Oracle Enterprise Single Sign-on Logon Manager

FTU

First Time Useウィザード

はじめて使用する場合のシナリオ

ユーザーがはじめて使用する場合のシナリオは、ESSO-LMリポジトリから制御できます。はじめて使用する場合のシナリオを決定してから、ESSO-LMリポジトリにオブジェクトをプッシュします。集約された環境を使用している場合、必要なオブジェクトは1つのみです。分散された環境を使用している場合は、各グループの要件を満たすように、はじめて使用する場合のシナリオの構成をカスタマイズできます。詳細は、「はじめて使用する場合（バルク追加）」を参照してください。

システム構成

ESSO-LM構成は、ESSO-LMリポジトリから設定できます。優先設定を決定してから、ESSO-LMリポジトリにオブジェクトをプッシュします。集約された環境を使用している場合、必要なオブジェクトは1つのみであるため、理想的なトップ・ダウン方式でセキュリティを制御できます。分散された環境を使用している場合は、各グループの要件を満たすように、設定をカスタマイズできます。詳細は、可動性の制御の設定に関する項を参照してください。

アプリケーション構成

アプリケーション構成は、ESSO-LMリポジトリから設定できます。アプリケーション構成を決定してから、ESSO-LMリポジトリにオブジェクトをプッシュします。集約された環境を使用している場合、必要なオブジェクトは1つのみです。分散された環境を使用している場合は、各グループの要件を満たすように、サポートされるアプリケーションのリストをカスタマイズできます。詳細は、アプリケーション・ログオンの構成に関する項を参照してください。


ソフトウェアのロールアウト

基本

基本機能にアクセスすると、ESSO-LMに自分自身を認識させることができます。つまり、コンピュータにログオンすると、エージェントによってその他すべてのアプリケーションにもログオンされます。

この例を確認するには、いくつかの事前定義されたアプリケーション（OutlookやLotus Notes 4/5など）およびWebサイト（Yahoo!やEudoraMail.comなど）に応答するエージェントを監視します。標準構成でESSO-LMをインストールしてから、これらのアプリケーションを起動します。

アプリケーション構成

いくつかの事前定義されたアプリケーションおよび一般的なWebサイトにエージェントが応答するのを確認した後、パスワードで保護されたほぼすべてのアプリケーションを検出し、それに応答するように、エージェントを簡単に構成できます。


管理

はじめて配置した後、更新およびアップグレードのためにESSO-LMモジュールの配置を引き続き管理できます。これには、Administrative Consoleまたは現行のユーザー独自の配置方法を使用します。

ESSO-LM構成
ディレクトリ・サーバーおよびデータベース・システム | Administrative Consoleを使用して、SSOAdminOverrideオブジェクトを変更します。
ファイル・システム | 現行のファイル・システム管理ツールまたはAdministrative Consoleを使用して、優先設定を変更します。
ローカル | ドメイン管理ツール、配置ツール、RegEditなどを使用して、HKLMハイブを変更します。
アプリケーション構成
ディレクトリ・サーバーおよびデータベース・システム | Administrative Consoleを使用して、SSOentlistオブジェクトおよび（オプションで）SSOftulistオブジェクトを変更します。
ファイル・システム | Administrative Consoleを使用して、entlistファイルおよび（オプションで）ftulistファイルを変更します。
ローカル | Administrative Consoleを使用して、entlist.iniファイルおよび（オプションで）ftulist.iniファイルを変更します。
設定
ロールアウト後の設定変更

Administrative Consoleを使用して、優先設定をESSO-LM同期リポジトリ（ディレクトリ・サーバー、データベース、ファイル・システムなど）にプッシュします。

ドメイン管理ツール、配置ツール、RegEditなどを使用して、レジストリの変更を配置します。

ユーザー・データ
ディレクトリ・サーバー | 現行のディレクトリ管理ツールを使用して、ユーザー・オブジェクトを移動し、（必要に応じて）ユーザーのSSOLocatorを変更または追加します。
ファイル・システム | 現行のネットワーク管理ツール（またはWindowsエクスプローラ）を使用して、ユーザー・ファイルのディレクトリ・ツリーを移動し、（必要に応じて）ユーザー・ファイルの保存場所を変更します。
ローカル | ドメイン管理ツール、配置ツール、RegEditなどを使用して、ユーザー・ファイルの保存場所を変更します。
ユーザー資格証明の管理
ローカル | ユーザー資格証明の削除 ドメイン管理ツール、配置ツール、Windowsエクスプローラなどを使用して、ユーザーがアクセスするすべてのコンピュータ上のユーザーの%AppData%\SSOディレクトリから、%AppData%\Passlogixファイルを削除します。
ディレクトリ・サーバー | ユーザー資格証明の削除 現行のディレクトリ管理ツールを使用して、ディレクトリからユーザー・オブジェクトを削除し、Windows管理アクセスを使用して、ユーザーがアクセスするすべてのコンピュータ上のユーザーの%AppData%\SSOファイル・ディレクトリから%AppData%\Passlogixファイルを削除することによって、ユーザー資格証明を削除します。 ユーザー・オブジェクトの移動 現行のディレクトリ管理ツールを使用してユーザー・オブジェクトを移動し、（必要に応じて）ユーザーのSSOLocatorを変更または追加します。
ファイル・システム | ユーザー資格証明の削除 現行のネットワーク管理ツールまたはWindowsエクスプローラを使用して、ファイル・システムからユーザー・ファイルを削除し、Windows管理アクセスを使用して、ユーザーがアクセスするすべてのコンピュータ上のユーザーの%AppData%\Passlogixファイル・ディレクトリ・ツリーから%UserName% AML.mdb ファイルを削除することによって、ユーザー資格証明を削除します。


グローバル・エージェント設定の構成

ESSO-LMの構成

次の項では、特定の環境をサポートするようにESSO-LMを構成する方法について説明します。

  • Windows認証
  • ディレクトリ・サーバー
  • データベース
  • ファイル・システム
  • Citrix MetaFrame


Windows認証

Windows認証用の構成

ESSO-LMでは、プライマリ・ログオン方法（認証方式）としてWindows認証がサポートされています。これにより、真のシングル・サインオンが実現します。エージェントでは、Windowsログオン資格証明を認証として使用できます。ESSO-LMでこれをサポートするには、管理者は2つの問題を認識している必要があります。

  • OSには128ビットの暗号化をインストールする必要があること。
  • 管理者はユーザー・レベルのプロファイルを有効にする必要があること。

Microsoft Windows 2000/XPでは、ユーザー・レベルのプロファイルのサポートは、インストール時に設定される基本機能の一部です。

128ビットの暗号化の確認

OSの暗号化の強度を確認するには、Microsoft Internet Explorerを起動して、「ヘルプ」>「バージョン情報」を選択します。「暗号強度」が128ビットである必要があります。

OSが128ビットでない場合は、Microsoftから更新をダウンロードします。

http://www.microsoft.com/windows/ie/ie6/downloads/recommended/128bit/default.mspx.


ディレクトリ・サーバー: エージェントの構成

ここでは、リポジトリとしてディレクトリ・サーバーを使用するようにESSO-LMを構成するために必要な設定について説明します。構成は、サポートされているすべてのディレクトリ・サーバーで同一です。相違点は次のとおりです。

  • ESSO-LMによるディレクトリ・サーバー・リソースの使用方法の詳細は、「ディレクトリ・サーバー同期サポート」を参照してください。
  • 関連するレジストリ・エントリの詳細は、「優先設定」を参照してください。

LDAP AUIとLDAP Directory Server拡張の両方がインストールされている場合は、AUI\LDAPとExtensions\SyncManager\Syncs\%LDAP%の両方に値が存在する必要があります。
  1. ESSO-LMがサーバーを指すようにします。
  2. 次のいずれかを実行します。
    • 左側のペインの「Global Agent Settings」から、レジストリ・エントリの既存の設定を選択します。
    • 設定の保存済セットをインポートします（「File」>「Registry」>「Import」）。
    • レジストリ設定の新しいセットを作成します（「Insert」>「Global Agent Settings」）。
  3. コンソールの左側のペインで、設定のセットを選択して開き、「Synchronization」を選択して開きます（必要に応じて、適切な拡張を追加します）。適切な拡張を選択して開いた後、「Servers」を選択して開きます。
  4. 右側のペインで、「Servers」、「...」ボタンの順に選択し、サーバー名またはIPアドレスを入力して「OK」をクリックします。
Microsoft Active Directoryサーバーの場合（アプリケーション・モード以外）:
  • Active Directory拡張に対してサーバーが入力されておらず、ユーザー・アカウントがActive Directoryドメインにある場合は、ESSO-LMでは、サーバーの検出にADドメイン・リソースが使用されます。グローバル・エージェント設定に1台以上のサーバーが指定されている場合は、ESSO-LMでは、サーバーの検出に「Servers」リストが使用されます。
  • 特に構成されていないかぎり、ESSO-LMは、ローカルなサブネットに割り当てられている優先ドメイン・コントローラの名前をドメイン・ネーム・サーバー（DNS）に問い合せます。
  • 複数のサーバーでActive Directoryネットワークを構築している場合は、レプリケーションを有効にして、ESSO-LMスキーマ拡張および関連オブジェクトが含まれるようにしてください。これで、ESSO-LMでは必ず接続先の各サーバー上でSSO情報が検索されるようになります。
  • Microsoft Active Directoryサーバーに対して1台以上のサーバーが指定されている場合は、IPアドレスではなくサーバー名を使用します。

Microsoft Active Directoryサーバーのアプリケーション・モードの場合:

  • ADAMサービスに対して、少なくとも1台のサーバーを指定する必要があります。
  • portパラメータ（myserver.com:9890など）を使用して、単一サーバーで実行しているADAMの特定インスタンスを指定します。
  • アプリケーション・テンプレートは、ADAMインスタンスのrootにではなく、特定のOUに存在する必要があります。
  5. ESSO-LMがユーザー・パスを指すようにします。
  6. 左側のペインで、適切な拡張を選択してから、次のいずれかを実行します。
    • LDAP拡張の場合は、「Required」を選択します。
    • Active Directory拡張の場合は、「Advanced」を選択します。
  7. 右側のペインで、「User Paths」、「...」ボタンの順に選択し、ユーザー・パスを入力して「OK」をクリックします。
  8. SSLを有効化または無効化します。
  9. 左側のペインで、適切な拡張を選択します。
  10. 右側のペインで、次のようにSSLオプションを選択します。
  11. SSLを使用する場合は、「SSL」（ LDAPまたはActive Directory用）を選択し、「Connect via SSL」を選択します（デフォルトはポート#636）。?
  • デフォルトでは、SSLは有効ではありません。セキュアでないデフォルト・ポートは#389です。
  • 非標準のポートを設定するには、「Servers」設定を使用します（LDAPまたはActive Directory用）。
  12. SSLを使用する場合は、「When SSL Fails」（LDAPまたはActive Directory用）を適切に選択します。
Novell eDirectoryの場合

Novell eDirectoryおよびその他の環境に関して、重要な注意事項が2つあります。ユーザーのドメイン名の書式が

cn=%UserName%,ou=people,dc=Oracle,dc=com

であり、次の書式

namingattribute =%UserName%,ou=people,dc=Oracle,dc=com

でない（namingattributeは任意の文字列）場合、次の処理を実行します。

  1. 左側のペインで、適切な拡張を選択してから、「Advanced」を選択します。
  2. 「Naming Attribute string」を選択し、値をCNに設定します。
  3. 「Alternate User ID location」を選択し、値をuid=%user%,pathに設定します。pathは、オブジェクトへのパスの後半部分です。次に例を示します。

uid=johnd,ou=people,dc=Company,dc=com.


ファイル・システム: エージェントの構成

ここでは、アプリケーション・ログオン、グローバル・エージェント設定およびユーザー資格証明とネットワーク・ファイル共有の同期がとられるようにESSO-LM Agentを初期構成するために必要な設定について説明します。

次に説明する構成設定は、エージェント・ソフトウェアの一般的な配置の一環として（MSIインストーラ・ファイルを変更して）、またはエージェントの配置後に（クライアント・ワークステーションのレジストリにマージできるレジストリ・エントリ対応ファイル（.REG）を配信して）、クライアント・ワークステーションに配信できます。

  • ESSO-LM Agentロールアウトについては、「配置オプション」を参照してください。
  • ESSO-LMによるファイル・システム・リソースの使用方法の詳細は、「ファイル・システム同期サポート」を参照してください。

  • 関連するレジストリ・エントリの詳細は、「優先設定」を参照してください。

    1. サーバーへのESSO-LM Agentの指定

    2. 次のいずれかを実行します。

      • 設定の保存済セットをインポートします（「Registry」を選択し、「File」メニューから「Import」を選択します）。
      • レジストリ設定の新しいセットを作成します（「Insert」メニューから「Global Agent Settings」を選択します）。
      • レジストリ・エントリの既存の設定を選択します（「Global Agent Settings」の下の左側のペインで該当するエントリを選択します）。
    3. 左側のペインで、レジストリ設定のセットを選択して開き、「Synchronization」を選択して開き、（必要に応じて）適切な拡張を追加します。適切な拡張を選択して開いた後、「Required」を選択します。
    4. 右側のペインで、「Server」を選択した後、サーバー名またはIPアドレスを入力して「OK」をクリックします。
    5. エージェントに設定をエクスポートします。
    6. グローバル・エージェント設定をクライアント・ワークステーションに初めて配信する場合の方法を選択します。
    7. これらの設定が含まれるように、ESSO-LM AgentをインストールするMSIパッケージをカスタマイズします。
    8. コンソールから、エクスポートする.REGファイルを配信します。ファイル・アイコンをダブルクリックすると、REGファイルをクライアント・ワークステーションのレジストリとローカルでマージできます。


データベース同期: エージェントの構成

次に説明する構成設定は、エージェント・ソフトウェアの一般的な配置の一環として（MSIインストーラ・ファイルを変更して）、またはエージェントの配置後に（クライアント・ワークステーションのレジストリにマージするレジストリ・エントリ対応ファイル（.REG）を配信して）、クライアント・ワークステーションに配信できます。

  • ESSO-LM Agentロールアウトについては、「配置オプション」を参照してください。
  • ESSO-LMによるデータベース・サーバー・リソースの使用方法の詳細は、「データベース同期サポート」を参照してください。
  • 関連するレジストリ・エントリの詳細は、「優先設定」を参照してください。
    1. ESSO-LMがデータベース・サーバーを指すようにします。
    2. 次のいずれかを実行します。
      • レジストリ・エントリの既存の設定を選択します（「Global Agent Settings」の下の左側のペインで該当するエントリを選択します）。
      • 設定の保存済セットをインポートします（「File」メニューから「Registry」、「Import」の順に選択します）。
      • レジストリ設定の新しいセットを作成します（「Insert」メニューから「Global Agent Settings」を選択します）。
    3. 左側のペインで、レジストリ設定のセットを選択して開き、「Synchronization」を選択して開き、（必要に応じて）適切な拡張を追加します。適切な拡張を選択して開いた後、「Servers」を選択して開きます。
    4. 右側のペインで、「Servers」、「...」ボタンの順に選択し、データベース・サーバー名を入力して「OK」をクリックします。
    5. クライアント・ワークステーションに初めて配信する場合の方法を選択して、設定をエージェントにエクスポートします。
      • これらの設定が含まれるように、ESSO-LM AgentをインストールするMSIパッケージをカスタマイズします。
      • コンソールから、エクスポートする.REGファイルを配信します。ファイル・アイコンをダブルクリックすると、REGファイルをクライアント・ワークステーションのレジストリとローカルでマージできます。


ロール/グループのサポート

ロール/グループ・サポート（ディレクトリ・サーバーのみ）

ディレクトリ・サーバー同期インストールでは、ESSO-LMでは、アプリケーション・ログオン、パスワード変更ポリシー、グローバル・エージェント設定、パスフレーズ質問セットを含む各構成に対してロール/グループ・アクセス制御がサポートされています。 この機能を有効にすると、Windowsセキュリティで使用されているアクセス制御リストと同様に、アクセス制御リストを、それぞれのログオン、ポリシー、設定および質問セットに割り当てることができます。

ロール/グループ・サポート対応の構成は、標準のESSO-LM構成オブジェクト（EntList、FTUlistおよびAdminOverride）と同様に、シンクロナイザ・コンテナ・オブジェクトにエクスポートされます。ロール/グループ・サポートが有効で、アクセス制御されたこれらのオブジェクトがコンテナに存在する場合は、標準オブジェクトが上書きされます。ロール/グループ・サポートを構成するには、次の手順を実行します。

  1. 次のグローバル・エージェント設定を構成して、ロール/グループ・セキュリティ・サポートを有効にし、エージェントを更新します。
Synchronization

Enable role/group security support

アプリケーション・ログオン、パスワード・ポリシー、グローバル・エージェント設定およびパスフレーズ質問セットに対するロール/グループ・サポートを有効にします。

オプション:

  • Do not use role/group security （デフォルト）
  • Use role group security.
「Synchronization」>選択されたsync>「Advanced」

Configuration Objects Base Locations

（LDAP、Active Directory、ADAM）

ロール/グループ対応の構成オブジェクトの検索を開始する場所を指定します。検索は、指定の場所（複数可）から下に向かって（ルートから離れて）行われます。この設定のエントリがない場合、検索はルートから開始されます。

  2. 各構成にアクセス権を指定します。

    構成（アプリケーション・ログオン、パスワード・ポリシー、グローバル・エージェント設定およびパスフレーズ質問セット）ごとに「Security」タブを使用して、アクセス権を持つ必要があるユーザーおよびグループを指定します。

  3. シンクロナイザ・コンテナに構成をエクスポートします。
  4. シンクロナイザ・ディレクトリに接続します。
  5. 右側のペインで、コンテナ・オブジェクトを右クリックし、ショートカット・メニューから「Configure SSO Support」を選択して、ウィザードを起動します。
  6. 「Data Source」として「Administrative Console」 を選択します。
  7. 「Advanced Support」を選択し、ウィザードの手順を完了して、アクセス制御された個々のオブジェクトとして構成オブジェクトをエクスポートします。

パフォーマンスとセキュリティを最大にするために、次の操作を実行することをお薦めします。

  • ユーザーの組織でロール/グループ・サポートが必要でないことが明白である場合を除いて、「Enable role/group security support」が「Do not use...」に設定されていることを確認します。
  • セキュリティを最大にするには、「Configuration Objects Base Locations」に指定された場所（LDAP、Active Directory、ADAM）にあるディレクトリ・ツリーには、ユーザーが書込み可能な領域がないことを確認します。
  • パフォーマンスを最大にするには、「Configuration Objects Base Locations」に、必ず1つ以上の場所を指定します。これにより、サーバー全体が検索されなくなります。
  • 検索の負荷と長さを最小にするには、「Configuration Objects Base Locations」に指定された場所にあるディレクトリ・ツリーには、不要なデータはできるだけ保存しないでください。


事前定義のアプリケーション・ログオンの配布

ESSO-LMは、幅広いログオン・シナリオを認識し、それに応答します。事前に、またはシナリオが発生したときに、ユーザーは各ログオンを構成できます。ユーザーがログオンを構成するときに、エージェントによって事前定義されたアプリケーションのリストが表示されます。ユーザーは、このリストからアプリケーションを選択したり、リストにないアプリケーション用にログオンを作成できます。

事前定義されたアプリケーションによって、ユーザーの構成が容易になり、ログオンおよびパスワード変更のリクエストの認識と応答の両方の信頼性が高くなります。

多数の一般的なWindowsアプリケーション用に事前構成されたアプリケーション・ログオンは、ログオンの構成のすべてまたは一部を含むテンプレートの形式でAdministrative Consoleに含まれています。（Plugin\LogonMgrディレクトリのインストール・ディレクトリにある）applist.iniファイルには、ネットワークおよびWebポップアップ・ログオン・ダイアログ・ボックス用、および多数のオンライン・サービス・プロバイダ用に事前定義されたログオンが含まれています。

事前定義ログオンの追加

  1. コンソールの構成機能を使用して、アプリケーション・ログオンを作成します（次の「関連項目」を参照）。
  2. INIファイルまたは対応する同期オブジェクトとして、entlistを作成および配置します。
    • 「Export to INI file」 を使用して、entlist.iniファイルを作成します。
    • 「Configure SSO Support」を使用して、e ntlist同期オブジェクトを作成します。
  3. 次のいずれかを実行します。
    • アプリケーション・ログオンの配置に同期を使用する場合は、「Location of entlist.ini file」設定を使用しないでください。シンクロナイザによって、ユーザーの%AppData%\Passlogixディレクトリでentlist.iniおよびftulist.iniが自動的に検索されます。
    • アプリケーション・ログオンの配置に同期を使用しない場合は、End User Experience/Environmentの下にある「Location of entlist.ini file」設定を使用します。

管理者はentlist.iniを作成する必要があります。エージェントでは自動的に作成されません。


アプリケーション構成ファイルの理解

ESSO-LMでは、通常は各ユーザーの%AppData%\Passlogixディレクトリ（C:\Documents and Settings\username\Application Data\Passlogixなど）に格納されているaelist.iniという名前のファイルで、アプリケーション・ログオンの指示が保存されます。エージェントによって、次の2つのコンポーネント・ファイルをマージしてaelist.iniファイルが作成されます。

  • entlist.ini: Windows、Webサイトおよびメインフレーム/ホスト・アプリケーション用にカスタマイズされたログオンを組織に導入するために、コンソールを使用して作成します。エージェントのシンクロナイザ拡張によって、%AppData%\Passlogixにentlist.iniが配置されます。
  • applist.ini: エージェントのインストール・パッケージに含まれ、ネットワークおよびWebポップアップ・ログオン・ダイアログ用、および多数のオンライン・サービス・プロバイダ用に事前定義されたログオンが含まれます。applist.iniファイルは、エージェントのインストール・ディレクトリに格納されています。

WindowsおよびWebアプリケーション用に事前構成されたログオンは、コンソール・テンプレートで提供されます。

すべてのESSO-LM構成ファイル（entlist.iniおよびftulist.iniを含む）は、コンソールでのみ作成および編集できます。

エージェントでのentlist.iniの使用方法

%AppData%\Passlogixディレクトリにaelist.iniを作成するために、エージェントによってentlist.iniとapplist.iniがマージされます。エージェントでは、定期的（エージェントの起動時など）にaelist.iniが上書きされます。その後、エージェントではaelist.iniを使用して、既知のアプリケーションが検出されます。

シンクロナイザ拡張（ディレクトリ・サーバーやファイル・システムなど）を使用する場合は、リモート・オブジェクトによって任意のローカルentlist.iniファイルが上書きされ、その後にapplist.iniとマージされます。

リモート・オブジェクトまたはローカルentlist.iniファイルがない場合、エージェントではaelist.iniファイルは作成されずにapplist.iniが使用されます。

エージェントが動作している間は、entlist.iniまたはSSOentlistオブジェクトを変更できます。新規aelist.iniを作成するためにエージェントで再度マージを強制的に実行するには、ログオン・マネージャで「Refresh」を選択します。

アプリケーション・ログオンの作成および配布の詳細は、次の項を参照してください。

  • テンプレートからのログオンの作成:
  • Windowsアプリケーションの追加
  • Webアプリケーションの追加
  • ホスト/メインフレーム・アプリケーションの追加
  • 「Add Application」ダイアログ・ボックス
  • ログオンの配布:
  • 事前定義のアプリケーション・ログオンの配布
  • 管理
  • 優先設定オブジェクト

エージェントでのaetlist.iniの使用方法

マージャから生成されたファイルaelist.iniには、すべての構成済アプリケーションに対するログオンおよびパスワード変更のイベントの識別や応答に必要な情報がすべて含まれています。次の情報が含まれます。

  • 「Error Loop」設定などのアプリケーション・タイプの設定（指定された期間内にエージェントがログオンを再試行する回数など）
  • アプリケーション固有の構成情報（アプリケーション実行可能ファイル名またはWebサイトのURL、「Password Policies」パスワード変更の動作、「Error Loop」設定、データファイル拡張など）
  • ログオンおよびパスワード変更のシナリオに関するシナリオ固有の構成情報（ウィンドウ・ダイアログのタイトル文字列、フォーム名、資格証明の場所など）
  • ダイアログ固有のマッチング設定（文字列や制御が存在するかどうかなど）
  • その他の設定（3番目または4番目のフィールドの名前など）

マージされたファイルaelist.iniには、構成する各アプリケーションのログオンおよびパスワード変更のイベントを一意に識別し、それに応答するために必要な情報がすべて含まれている階層構造があります。ログオンは、次のように構成されています。

[*他のアプリケーション] Section1=Application logon 1 Section2=Application logon 2 | このセクションは、管理者が定義した2つのWindowsアプリケーションを参照します。このアプリケーションは、ファイルの後半で定義されます。詳細は、「Windowsアプリケーションの追加」を参照してください。
[*メインフレーム] Section1=Host logon 1 Section2=Host logon 2 & | このセクションは、2つのホスト/メインフレーム・アプリケーションを参照します。このアプリケーションは、ファイルの後半で定義されます。詳細は、メインフレーム・アプリケーションの追加に関する項を参照してください。
[*共有グループ] Section1=Shared Group 1 Section2=Shared Group 2 & SectionN=Shared Group N & | このセクションは、資格証明の共有に使用される2つのグループを参照します。詳細は、「資格証明共有グループの作成」を参照してください。
[*PasswordPolicies] & | このセクションは、パスワード・ポリシーを有効にします。詳細は、「パスワード・ポリシーの設定」を参照してください。

entlist.iniのアプリケーション構成を使用すると、エージェントは、組織に固有のアプリケーションからのログオンおよびパスワード変更のリクエストを自動的に認識および応答できます。

これがローカル・ファイルとして存在するか、またはリモート・オブジェクトからダウンロードされる場合、エージェントは、entlistオブジェクト（使用可能な場合）をentlist.iniファイルにダウンロードし、ダウンロードしたentlist.iniファイルまたはローカルのentlist.iniファイルをpplist.ini（ユーザーが使用できる事前定義されたアプリケーションの完全リスト）にOracleで指定されたファイルと結合して、aelist.iniを作成します。（entlist.iniファイルが存在しない場合、エージェントはapplist.iniを使用します。）

applist.iniへの更新はOracleによって提供されるため、applist.iniは変更しないことをお薦めします。将来のESSO-LMのリリースで、applist.iniの変更が上書きされる可能性があるため、Oracleではユーザーによるapplist.iniへの変更が将来のリリースでサポートされる保証はありません。

ESSO-LMを使用して事前構成されたアプリケーション・テンプレート

次の表には、Administrative Consoleに含まれる事前構成されたアプリケーション・ログオン、およびそのログオンをエージェントに配置する前に管理者が指定する必要がある情報を示します。

アプリケーション ログオン・フォーム
Microsoft Word
  • Microsoft Word Logon
  • Microsoft Word 2000 Logon
  • Microsoft Word 2003 Logon
MSダイヤルアップ・ネットワーキング
  • MS Dial-Up Networking Logon（管理者がWindowTitleを指定）
Netscape Mail
  • Netscape Mail Logon
  • Netscape Mail 7.1 Logon
PKZIP
  • PKZIP Logon
  • PKZIP v8 Logon
Siebel Sales
  • Siebel Sales Logon
  • Siebel Sales Change Password
Adobe Acrobat Reader
  • Adobe Acrobat Unlock
ICQ
  • ICQ Logon - Registration
  • ICQ Logon
Meeting Maker
  • MM 7.3 Logon
  • MM 5.5.2 Logon
  • MM 8.0 Logon
WinZip
  • WinZip Set Password Confirm
  • WinZip Set/Use Password
  • WinZip 9.0 Decrypt File(s) Password
Yahoo! Messenger
  • Yahoo! Messenger Logon
Oracle
  • Oracle Logon
  • Oracle 10g SQL*Plus Logon
MS SQL
  • MS SQL Logon
Novell GroupWise
  • Novell GroupWise Logon
  • Novell GroupWise 6.5 Logon
Microsoft FrontPage
  • Microsoft FrontPage Logon
Visual SourceSafe
  • VSS Logon
  • VSS Change Password
OpenNetwork Directory Smart
  • OpenNetwork Directory Smart Logon（管理者がURLを指定）
Oblix NetPoint
  • Oblix NetPoint Logon（管理者がURLを指定）
Citrix ICA Client/Program Neighborhood（2-field）
  • CICA2 Logon（管理者がWindowTitleを指定）
Citrix NFuse Classic（2-field）
  • CNFC2 Logon（管理者がURLを指定）
Act
  • Act Logon（管理者がWindowTitleを指定）
  • Act Set Password
QuickBooks Pro
  • QBP Change Password
  • QBP Logon
QuickBooks Pro（Password-Only）
  • QBPPO Change Password
  • QBPPO Logon
Lotus Organizer
  • Lotus Organizer Logon（管理者がWindowTitleを指定）
Citrix Program Neighborhood Agent（3-field）
  • CPN3 Logon
GoldMine
  • GoldMine Logon
  • GoldMine Clhange Password
Citrix NFuse Classic（3-field）
  • CNFC3 Logon（管理者がURLを指定）
Citrix Program Neighborhood Agent（2-field）
  • CPN2 Logon
Citrix ICA Client/Program Neighborhood（3-field）
  • CICA3 Logon（管理者がWindowTitleを指定）
AIM
  • AIM Logon
Eudora
  • Eudora Logon
  • Eudora Change
  • Eudora Confirm
Lotus Notes
  • Lotus Notes
Microsoft Outlook
  • Logon
  • Change Password
Microsoft Outlook 2003
  • Logon
  • Change Password
MSN Messenger
  • MSN Messenger Logon
Windows Logon
  • WL MPR Logon
  • WL MPR Change Password
  • WL WinLogon Logon
  • WL WinLogon Change Password
ICQ 4.0
  • ICQ 4.0 Logon（パスワードのみ）


アプリケーションの設定に関する一般的なガイドライン

アプリケーションの設定および構成を最も簡単に実行できるのは次の場合です。

  • コンソールと同じワークステーションにターゲット・アプリケーションがある場合。
  • 構成中に動作している他のアプリケーション数が最小限の場合。
  • アプリケーション構成の作成およびテストを容易にするには、次の手順を実行します。
  • シンクロナイザ拡張を使用しないようにワークステーションを構成します。
  • コンソールでアプリケーション構成を作成してから、（「Tools」メニューにある）「Export Apps to Agent」を使用して、ローカルのentlist.iniファイルを上書きします。
  • ログイン・マネージャを表示したままにして、コンソールからのエクスポートが完了するたびに「Refresh」を選択します。
  • 新しい構成がエージェントで正しく動作するかどうかを確認するために、アプリケーション・ログオン・ダイアログ・ボックスを起動します。

アプリケーション・ログインのリクエストにエージェントが応答するときに、それを無視するようにエージェントに指示します。


Windowsアプリケーションの追加

Windowsアプリケーションを構成する最も簡単で適切な方法は、「Windows Form」ウィザードを使用することです。

Windowsログオンの構成を開始する前に、アプリケーションの構成に関する「一般的なガイドライン」を参照してください。

特殊な問題および設定

Windowsアプリケーションは、通常とは異なる方法で動作したり、特殊な要件がある場合があります。このようなシナリオに対応するために、Administrative Consoleでは次の追加構成オプションが提供されています。

特殊な構成の設定

「Fields」タブ （新規または選択したログオン・フォーム用）
SendKeys

次のWindowsアプリケーションには「SendKeys」オプションを使用します。

  • Windowsメッセージ・キューから、または通常エージェントによって資格認証の送信に使用されるその他の技術を使用して資格証明を受信できない
  • コントロールIDを持つ標準のWindowsコントロールを使用しない
  • コントロールを動的に生成するか、またはWindowsコントロールを使用しない（Flashアプリケーションなど）
「Miscellaneous」タブ （新規または選択したログオン・フォーム用）
Allowable Class | このログオンを実行するために必要なログオンまたはパスワード変更ウィンドウのクラスを識別するには、「Allowable Class」オプションを使用します。これは、非標準のクラス名を持つログオン変更ウィンドウまたはパスワード変更ウィンドウをアプリケーションで表示する場合に役立ちます。
Ignore this Window Class

次のアプリケーションでは、「Ignore Window Class」オプションを使用します。

  • 非表示のログオンまたはパスワード変更のダイアログを使用する。
  • 重複するダイアログを示す。
Attach to window's Message Queue | 資格証明の送信中にターゲット・ログオン・ウィンドウへのフォーカスを維持するには、「Attach to...」オプションを使用します。
Preset Focus | フィールドにデータを入力する前に、エージェントによってフィールドにフォーカスを設定するには、「Preset Focus」オプションを使用します。
「Miscellaneous」タブ （選択したアプリケーション用）
Service Logon | Windowsサービス（ユーザー領域ではなくシステム領域にあるサービス）として動作するアプリケーションをエージェントで検出するには、「Service Logon」オプションを選択します。
Third/Fourth Field Label | 追加フィールドの表示にエージェントが使用するテキスト・ラベルを指定するには、これらのオプションを使用します。
File extension for Icon | ログオンと関連付けるWindowsファイル拡張子を指定するには、このオプションを使用します。これにより、エージェントがその拡張子にアイコンをマッピングします。


Webアプリケーションの追加

ESSO-LMは、事前定義されたWebアプリケーション用のログオンとパスワード変更のリクエストを検出し、応答します。Windowsおよびホスト/メインフレーム・アプリケーションと同様に、管理者はentlist.iniにセクションを追加して、Webアプリケーションを定義します。

エージェントは、WebページのHTMLコード内の指定された場所にあるデータの特定文字列を認識します。このデータは、Webサイトのログオンとパスワード変更の画面の検出方法、ユーザー資格証明を入力する場所およびこれらの資格証明の送信方法を示します。

Webアプリケーションを構成する最も簡単で適切な方法は、「Web Form」ウィザードを使用することです。この手順を開始する前に、アプリケーションの構成に関する「一般的なガイドライン」を参照してください。

Webアプリケーションでは、同じページ、同じURL内の別のページまたは別のURLに、ログオンおよびパスワード変更のフォームを含めることができます。また、ログオンは、別のURLにある同じフォームまたは別のURLにある別のフォームに含めることもできます。

ユーザーのローカル・ストアにログオンがすでに含まれているサイトの構成を追加すると、そのユーザーの構成が新しい構成によって上書きされます。ユーザーは、このアプリケーション用の資格証明を再度入力する必要があります。

そのユーザーは、ログオン・マネージャで古いログオンを引き続き参照できます。


ホスト/メインフレーム・アプリケーションの追加

ESSO-LMでは、次のようなホスト・エミュレータを使用して、ホスト/メインフレーム・アプリケーションへのシングル・サインオン機能が実装されています。

  • HLLAPI（High-Level Language Application Programming Interface）を実装する。
  • ダイアログを表示できる組込みスクリプト言語を持つ。

ホスト・エミュレータを使用すると、エンド・ユーザーはWindowsワークステーションからメインフレーム、AS/400、OS/390、UNIXまたはその他のホスト・ベースのセッションに接続できます。ESSO-LMは、特定の画面にあるデータの特定文字列を検索してターミナル画面を認識します。

ESSO-LMでホスト・エミュレータを認識するには、Administrative Consoleの「Host/Mainframe Apps」ダイアログ・ボックスにある「MFEnable」を選択して、メインフレーム・サポートを有効にします。

すべてのホスト/メインフレーム・アプリケーションは、事前定義される必要があります。ESSO-LMのエンド・ユーザーがホスト/メインフレーム・アプリケーションを定義することはできません。また、ESSO-LMでホスト・エミュレータを認識するには、管理者がホスト・エミュレータ自体も構成する必要があります。いずれのホスト・エミュレータでも、他のホスト・エミュレータを使用して作成されたアプリケーション・ログオンを使用できます。ESSO-LMでサポートされているエミュレータの構成の詳細は、「ホスト・エミュレータの構成」を参照してください。

ログオンを作成する最も簡単な方法は、テキストを選択でき、選択した行および列の座標が表示されるホスト・エミュレータを使用することです。

HLLAPIはサポートされていないが、スクリプト言語は持っているエミュレータを構成する方法については、オラクル社に問い合せてください。

HLLAPIはサポートされていないが、スクリプト言語は持っているエミュレータを構成する方法については、オラクル社に問い合せてください。

HLLAPIを実装していないか、またはスクリプト言語を持っていないエミュレータの場合は、（ウィンドウ・タイトルでフォームが検出されるように、）ユーザー資格証明を指定するSendKeysを使用して、Windowsアプリケーションとしてホスト/メインフレーム・アプリケーションを構成できる場合もあります。詳細は、「Windowsアプリケーションの追加: 特殊な問題」を参照してください。

ホスト/メインフレーム・アプリケーションの追加

ホスト/メインフレーム・アプリケーションを構成する最も簡単で適切な方法は、「Host/Mainframe Form」ウィザードを使用することです。この手順を開始する前に、アプリケーションの構成に関する「一般的なガイドライン」を参照してください。

ホスト/メインフレーム・アプリケーションの手動構成

次に、ホスト/メインフレーム・ログオンを手動で構成または変更する手順について説明します。詳細は、個々のダイアログおよびコントロールを参照してください。この手順を開始する前に、アプリケーションの構成に関する「一般的なガイドライン」を参照してください。

  1. アプリケーションを起動し、ホスト・エミュレータを構成します。詳細は、「ホスト・エミュレータの構成」を参照してください。
  2. Administrative Consoleで、次のいずれかを実行します。

    • 新しいホスト/メインフレーム・アプリケーション・ログオンを作成します。

      または

    • 左側のペインで、「Applications」をクリックし、ホスト/メインフレーム・アプリケーションを選択します。右側のペインで、「General」タブをクリックします。
  3. 「Host/Mainframe」フォーム構成ダイアログ・ボックスの「General」タブで、次のようにします。
    1. リストからログオン・フォームを選択し、「Edit」をクリックします。
    2. このページが一意に識別できるように、1つ以上のテキスト・マッチング・キャプションを指定します。キャプションを特定するテキスト文字列、およびその開始行数と開始列数を指定します。
    3. 資格証明について「Fields」を指定します。「Edit」（「Fields」の下）をクリックして「SendKeys (Host/Mainframe)」ダイアログ・ボックスを表示します。フィールドごとに開始の行/列、および送信するキーストロークを指定します。
  4. 資格証明フィールドを入力するたびに発生する一時停止を端末レスポンス時間に含める必要がある場合は、「Options」タブを選択し、「Delay Field」に一時停止するミリ秒数を入力します。
  5. 追加のログオン画面ごとに前述の手順を繰り返します。
  6. パスワード変更情報を追加するには、ターゲット・アプリケーションの「Password Change」タブおよびパスワード変更ダイアログで処理を繰り返します。


Javaアプリケーションの追加

Javaアプリケーションおよびアプレットの追加

「Windows Form」ウィザードを使用すると、Javaアプリケーション・ログオンおよびJavaアプレット・ログオン（Webページ）を構成できます。通常、作成および配置の手順は、JavaアプリケーションでもWindowsアプリケーションでも同じです。

Javaログオンの構成を開始する前に、アプリケーションの構成に関する「一般的なガイドライン」を参照してください。

エージェントでJavaアプリケーション・ログオンを検出および使用するには、ESSO-LMをインストールする前に、Javaランタイム環境（JRE）をワークステーションにインストールする必要があります。ESSO-LMをインストールするときにJREが存在しない場合は、エージェントのJava Helperコンポーネントをインストールできません。


Telnetアプリケーションの追加

ESSO-LMでは、メインフレーム/ホスト・エミュレータによって実装されているHLLAPI（High-Level Language Application Programming Interface）を使用したTelnetセッションがサポートされています。サポートされているエミュレータの最新のリストは、ESSO-LMのリリース・ノートを参照してください。

通常、Telnetアプリケーション用のログオンを構成することは、ホスト/メインフレーム・アプリケーションの追加と基本的に同じですが、次のような例外があります。

  • 通常、ホスト・アプリケーションでは、一定の位置にテキスト・キャプションおよびデータ・フィールドが表示され、 テキスト・マッチング および行/列の絶対座標を使用したログオン・フォームとして、ESSO-LMで画面を検出できます。対照的に、Telnetアプリケーション（そのログオン画面も含む）は、スクロールするテキスト・ウィンドウで表示されます。ESSO-LMでマッチングを行う（およびログオンを開始する）ためのテキスト・キャプションの画面位置は、カーソルに対して相対的な行番号（上に行くとマイナス、下に行くとプラス）および絶対的な列番号で設定する必要があります。次の例を参照してください。
  • キャプションの座標のいずれかまたは両方が不明の場合は、任意の行（および固定列）にあるテキストと一致する行の設定に対して、任意の列（およびカーソルに対して相対的な行）にあるテキストと一致する列の設定に対して、または画面上の任意の場所にあるテキストと一致する両方の設定に対してアスタリスク（*）を使用できます。
  • Telnetログオンに資格証明が指定されると、ESSO-LMでは、フィールドのマッチング用の行および列の座標設定は無視されます。ただし、その設定はログオン構成に存在する必要があります。Telnetログオンのすべての資格証明フィールドには、行と列の両方の座標に対する値として1を使用します
  • Telnetログオン資格証明が正しく入力されるために、ESSO-LMではタイミングのロジックが有効になっています。（ホスト/メインフレーム・ログオン・フォームを構成する 「Options」タブ にある）「Delay Field」設定には、各アクションの間でエージェントが一時停止するタイミングをミリ秒単位で指定します。
HLLAPI構成の詳細は、「ホスト・エミュレータの構成」を参照してください。

Telnetアプリケーション・ログオンの追加

Telnetアプリケーションを構成する最も簡単で適切な方法は、「Host/Mainframe Form」ウィザードを使用することです。この手順を開始する前に、アプリケーションの構成に関する「一般的なガイドライン」を参照してください。

Telnetアプリケーション・ログオンの手動構成

次に、Telnetログオンを手動で構成または変更する手順について説明します。詳細は、個々のダイアログおよびコントロールを参照してください。この手順を開始する前に、アプリケーションの構成に関する「一般的なガイドライン」を参照してください。

  1. アプリケーションを起動し、ホスト・エミュレータを構成します。
  2. Administrative Consoleで、次のいずれかを実行します。

    • 新しいホスト/メインフレーム・アプリケーション・ログオンを作成します。

      または

    • 左側のペインで、「Applications」をクリックし、ホスト/メインフレーム・アプリケーションを選択します。
  3. 右側のペインで、「General」タブをクリックします。
  4. リストからログオン・フォームを選択し、「Edit」をクリックします。
  5. 「Host/Mainframe」フォーム構成ダイアログ・ボックスの「General」タブで、次のようにします。
    1. このページが一意に識別できるように、1つ以上のテキスト・マッチング・キャプションを指定します。キャプションを特定するテキスト文字列、およびその開始行数と開始列数を指定します。
      • 行番号は、現在のカーソル位置に対して相対的である必要があり、負の整数を使用できます。次の例を参照してください。
      • 列番号は、絶対的な位置です。
      • また、行または列には、ワイルドカードとしてアスタリスク（*）を使用できます。
    2. 資格証明について「Fields」を指定します。「Fields」で、「Edit」をクリックします。 「SendKeys (Host/Mainframe)」ダイアログ・ボックスで、各フィールドを選択し、各フィールドの「Row」および「Column」を1に設定します。必要に応じて、各フィールド・エントリに従う必要がある追加のキーストロークを指定します。
  6. 資格証明フィールドを入力するたびに発生する一時停止を端末レスポンス時間に含める必要がある場合は、「Options」タブを選択し、「Delay Field」に一時停止するミリ秒数を入力します。
  7. 追加のログオン・フォームごとに前述の手順を繰り返します。
  8. パスワード変更情報を追加するには、ターゲット・アプリケーションの「Password Change」タブおよびパスワード変更ダイアログ・ボックスで処理を繰り返します。

テキスト・マッチングの例

Telnetアプリケーションのテキストはスクロールするため、行の位置はカーソルの行（常に行1である）に対して相対的に設定する必要があります。したがって、カーソルの2行上にあるキャプション（「Welcome to VAX/VMS_V6.1」）の行座標は-2です。キャプション・テキストの開始の列は、絶対座標で設定されます。この例では9です。

画面のテキスト列
 | 123456789022345678903234567890123
行# | 123456789012345678901234567890123
-4 |
-3 |
-2 | Welcome_to_VAX/VMS_V6.1_
-1 |
1 | Username: _
2 |
3 |
4 |

ESSO-LMでこのサンプル画面を識別するには、これらのテキスト・マッチング条件を（「Text Matching」ダイアログ・ボックスを使用して）設定します。

一致1
テキスト | Welcome to VAX/VMS V6.1
行 | -2
列 | 9
一致2
テキスト | Username:
行 | 1
列 | 1


はじめて使用する場合（バルク追加）

はじめて製品をインストールした後、「First-Time Use」ウィザードでは、設定プロセスを完了するために様々な項目を入力する必要があります。複数の認証方式がインストールされている場合、ユーザーは「Primary Logon Method」を選択するように求められます。また、ESSO-LMによって、ユーザー・ストアに即時に移入するために、アプリケーションのユーザー名/IDおよびパスワードを入力するように求められる場合もあります。

バルク追加を使用するには、「First-Time Use」を有効にする必要があります。

「First-Time Use」ウィザードの構成設定は、ftulist.iniファイルで指定されます。エンド・ユーザーは、既存のログオンに対する資格証明（ユーザー名/ID、パスワード、3番目のフィールド）を入力するように求められる場合もあります。はじめて使用する場合の構成と事前定義のログオンを組み合せると、インストール直後にシングル・サインオンを使用できます。または、アプリケーションを実行するたびにログオンを個々に構成することもできます。

すべてのESSO-LM構成ファイル（entlist.iniおよびftulist.iniを含む）は、ESSO-LM Administrative Consoleでのみ作成および編集できます。

バルク追加へのアプリケーションの指定

バルク追加で使用するには、アプリケーションを個別に構成する必要があります。「バルク追加用のログオンを有効にする手順」 を参照してください。
  1. 左側のペインでアプリケーションを選択し、右側のペインで「Bulk-Add」タブを選択します。
  2. 「Add」をクリックします。
  3. 「Select Application」ダイアログ・ボックスから、このグループに追加するアプリケーションを選択します。（複数のエントリを選択するには、[Ctrl]または[Shift]を押しながらクリックします。）
  4. 「OK」をクリックします。
  5. 「Date Stamp」をyyyymmdd形式（たとえば2003年6月15日の場合は20030615）で入力または編集します。この日付が、指定したエージェントが設定を完了した最終日付より後の場合は、新しいログオンを追加するための設定ウィザードが起動します。
バルク追加するようにログオンを有効にする手順
  1. 左側のペインで「Applications」を選択してから、アプリケーションを選択します。
  2. 右側のペインで、「Bulk add」タブをクリックします。
  3. 「Enable Bulk-Add capability for this application」を選択します。
  4. 確認のためにユーザーが1つ以上のフィールドを再入力する必要がある場合は、適切な「Confirm」設定を選択します。


テンプレートの作成および使用

多数の一般的なWindowsアプリケーション用に事前構成されたアプリケーション・ログオンは、テンプレートの形式でコンソールに含まれています。

また、コンソールで作成したアプリケーション・ログオンをテンプレートに変換することもできます。

テンプレートには、事前構成されたログオンを作成および管理する場合に、次の2つの実用的な利点があります。

  • テンプレートに基づいて新規ログオンを作成する場合、特定のログオン設定のグループをスタータ・セットとして保存、共有および再利用できます。テンプレートは、「Add Application」ダイアログ・ボックスにオプションとして表示されます。
  • テンプレートのソース・ログオンを変更する場合は、「Tools」メニューの「Update Applications」コマンドを使用すると、そのテンプレートに基づいてログオンへの変更を簡単に適用できます。

テンプレートを作成するには、次の手順を実行します。

  • 「Tools」メニューの「Manage Templates」ダイアログ・ボックスで、既存のアプリケーション・ログオンを選択します。
  • 後で上書きできる（アプリケーションおよび各フォーム用の）ログオン設定を選択します。「Edit Template」ダイアログ・ボックスの「Overriding Settings」タブを使用します（「Manage Templates」ダイアログの「Edit」をクリックします）。WebおよびWindowsアプリケーションの場合は、（「Supply Info」タブで）ログオン構成を完了するためにテンプレート・ユーザーが入力する必要がある設定を選択することもできます。
  • コンソールのプログラム・ディレクトリ（通常は、C:\Program Files\Passlogix\SSO Administrative Console\Templates）にあるTemplatesフォルダに、現行のファイルを保存します。

テンプレートを使用すると、「Add Application」ダイアログ・ボックスの「Applications」ドロップダウン・リストからログオンを選択して作成できます。構成を完了するために追加情報が必要な場合には、プロンプトが表示されます。

元のテンプレートに対して行った変更でアプリケーション・ログオンを更新できます。アプリケーションが含まれるコンソールのXMLファイルを開き、「Tools」メニューから「Update Applications」コマンドを選択します。


Citrix環境でのESSO-LMの構成

Citrix MetaFrameでのESSO-LMのデフォルト・インストール

ESSO-LMのデフォルト・インストール・プロセスでは、ESSO-LMがCitrix環境で機能するために必要なコンポーネントが自動的に検出され、インストールされます。このインストール・プロセスによって、そのCitrixサーバーで公開されたすべてのアプリケーションに対するESSO-LMサポートが有効になります。

Citrix MetaFrameへのESSO-LMのインストール

  1. ターミナル・サーバーに管理者としてログオンし、すべてのアプリケーションを閉じます。
  2. 「スタート」、「ファイル名を指定して実行」をクリックします。
  3. 「ファイル名を指定して実行」ダイアログ・ウィンドウで、cmdと入力し、[Enter]を押します。
  4. コマンド・プロンプト・ウィンドウで、change user/installと入力し、[Enter]を押します。
  5. 環境に適したインストール・オプションを選択して、ESSO-LMをインストールします。
  6. インストールの完了後、コマンド・プロンプトでchange user/executeと入力します。

Citrixでの特定アプリケーション用のESSO-LMの制御

次の項では、ESSO-LMのデフォルト・インストールを変更する方法、およびCitrix環境で特定のアプリケーション用にESSO-LMを有効にする方法について説明します。このプロセスには、2つの手順があります。最初の手順では、グローバルESSO-LMサポートを削除します。2つ目の手順では、公開アプリケーション構成を使用して、SSO対応にするアプリケーションを指定します。

グローバルESSO-LMサポートの削除

  1. 「スタート」、「ファイル名を指定して実行」をクリックします。
  2. 「ファイル名を指定して実行」ダイアログ・ウィンドウで、Regeditと入力し、[Enter]を押します。
  3. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogonに移動します。
  4. 右側のペインで文字列値「AppSetup」を右クリックし、「修正」を選択します。
  5. SSOLauncherを参照しているこのエントリ内の値データを削除します。(C:\Program Files\Passlogix\v-GO SSO\wts\ssolauncher.exe /nossoshutdown）
  6. ESSO-LMのWindows Authentication v1を使用している場合は、Passlogixレジストリ・ハイブにCheckForParentProcessキーを追加します。これにより、認証イベントがESSO-LMにハンドオフされます。

HKEY_LOCAL_MACHINE\SOFTWARE\Passlogix\AUI\WinAuth\

DWORD:

CheckForParentProcess

Value=0

AppSetupからssolauncher.exeを削除すると、公開アプリケーション構成に指定しないかぎり、このCitrixサーバー上のいずれのアプリケーションでも機能しないようにESSO-LMが構成されます。

公開アプリケーション構成（SSOLauncher）を使用したSSO対応アプリケーションの指定

ESSO-LMサポートはグローバルで無効になっているため、公開済のアプリケーション・プロパティにSSOLauncher.exeコマンドを追加することによって、ESSO-LMサポートとともに公開するアプリケーションを指定する必要があります。

  1. Citrix管理コンソールを開きます。
  2. ESSO-LMに対して有効にするアプリケーションを公開/検索します。
  3. 公開したアプリケーションを右クリックし、プロパティを選択します。
  4. 「Application Location」タブで、コマンドラインの前に次の構文を追加します。
    C:\Program Files\Passlogix\v-GO SSO\wts\SSOLauncher.exe/application

SSOLauncher.exeのコマンドが、公開済のアプリケーションのコマンドラインに追加されます（置き換えられるわけではありません）。

アプリケーションACTのコマンドライン構文の例を次に示します。

C:\Program Files\Passlogix\v-GO SSO\wts\SSOLauncher.exe" /application C:\Program Files\ACT\act.exe

この例は、ESSO-LMとACTの両方がCitrixサーバーのC:\ドライブにインストールされていることを前提としています。

詳細は、「MetaFrame XPサーバーのSSOLauncher」を参照してください。

MetaFrameモニタリングの有効化

ESSO-LMにおいて終了するはずのセッションが接続したままにならないように、ESSO-LMをCitrix MetaFrameで監視できるようにするには、次のレジストリ・ツリーに移動します。

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet
  \Control\Citrix\Wfshell\TWI

LogoffCheckSysModulesという名前のエントリが存在する場合は、これにssoshell.exeを追加します。たとえば、app1.exe,app2.exeは、app1.exe,app2.exe,ssoshell.exeに変更します。

エントリが存在しない場合は、LogoffCheckSysModulesを文字列型として作成し、ssoshell.exeに設定します。


SSOLauncher

MetaFrame XPサーバー用のSSOLauncher

このユーティリティを使用すると、Citrix MetaFrame XP環境で公開済のアプリケーションを使用して、ESSO-LMの配布を制御できます。

ssolauncherユーティリティを使用するには、次の手順を実行します。

  1. WINNT\system32フォルダにssolauncherユーティリティをコピーします。そうしない場合は、ssolauncherが存在するフルパスを含める必要があります。
  2. これで、ssolauncherユーティリティを使用してESSO-LMで実行するアプリケーションを管理できます。Citrix公開アプリケーション管理コンソールにアクセスし、アプリケーション定義のコマンドラインを使用してssolauncherコマンドを発行すると、アプリケーションごとにESSO-LMを実行できます。
ssolauncherコマンドは、コマンドラインの前に適用されます。
例

ssolauncher.exe /application "C:\Program Files\Internet Explorer\EXPLORER.EXE"

ssolauncherのコマンドは、次のとおりです。

コマンド | 使用方法
/application | 実行するアプリケーションのフルパス。これは必須です。
/command | コマンド・パラメータをアプリケーションに指定する場合に使用します。これはオプションです。
/directory | 作業ディレクトリをアプリケーションに指定する場合に使用します。これはオプションです。
/wait | アプリケーションが停止するまで待機する時間（ミリ秒）。これはオプションです。指定しない場合、ssolauncherはアプリケーションが終了するまで永久に待機します。
/verbose | ssolauncherでエラーが発生した場合にエラー・メッセージを示すダイアログ・ボックスを指定します。
/nossoshutdown | アプリケーションが完了したときに、ssoを停止しないようにします。
/SSOCOMMAND LOGON | ESSO-LMシステム・トレイ・アイコンにある「Log On Using ESSO-LM」トリガーにコマンドを発行する場合に使用します。

AIMを起動するコマンドラインの例を次に示します。

ssolauncher.exe /verbose /application "C:\Program Files\AIM95\aim.exe" /directory "C:\Program Files\AIM95"

コマンドに「\」文字が含まれる場合は、コマンドを引用符で囲む必要があります。


サーバーの構成

ESSO-LM用のサーバーの構成

次の項では、ESSO-LM配置用のサーバーおよび同期とイベント・ロギングのサポートを構成する方法について説明します。

  • ディレクトリ・サーバーの構成: 次のLDAPサービス用
  • IBM Tivoli Directory Server
  • Microsoft Active DirectoryおよびADAM
  • Novell eDirectory
  • Oracle Directory Server
  • Sun Java System Directory Server
  • Open LDAP Directory Server
  • データベース・システムの構成: Microsoft SQL Server、IBM DB2およびOracleデータベース・システム用
  • ファイル・システムの構成: UNC（Universal Naming Convention）に準拠したネットワーク・ドライブまたはデバイス用
  • イベント・ロギング: ESSO-LMイベント・ログ・メッセージを受信するようにMicrosoft Windows 2000またはXPを構成


ディレクトリ・サーバー: サーバーの構成

ここでは、ESSO-LMと連携して動作するようにディレクトリ･サーバーを拡張する方法について説明します。このプロセスによって、一部のディレクトリ関連のタスクが容易になりますが、管理者がディレクトリ・サービスの計画や配置に関する知識を持っていることが前提となります。このドキュメントでは、ESSO-LMの配置に固有の概念のみを取り上げます。

ESSO-LMによるディレクトリ・サーバー・リソースの使用方法の詳細は、「ディレクトリ・サーバー同期サポート」を参照してください。

ESSO-LM用にディレクトリ・サーバーを構成するには、Administrative Consoleを使用してスキーマを拡張し、ディレクトリ構造にオブジェクトを設定する必要があります。

ディレクトリ・サーバーに接続するときに、管理者権限が付与された認証情報を入力する必要があります。この情報には、ディレクトリ・タイプ、サーバー名またはIPアドレス（IPアドレスはMicrosoft Active Directoryサーバーにとっては有効でない場合もあります）、ポート、SSL使用の選択、ユーザーIDおよびパスワードが含まれます。

ユーザーIDは、DN形式で指定する必要があります。次に例を示します。

uid=yourname,ou=Administrators,ou=TopologyManagement,o=NetscapeRoot

ディレクトリ操作は、Microsoft Windows 2000またはXPから実行する必要があります。

ADAM（Active Directory/アプリケーション・モード）リポジトリについて

次の手順を開始する前に、ADAMサーバー・インスタンスをインストールして実行しておく必要があります。

アプリケーション・ディレクトリ・パーティション（次の手順2）のネーミング・コンテキストは、組織単位（ou）である必要があります。「ADAM Setup Wizard」パネルで指定される例は、cn（コンテナ名）を示しています。
  1. ディレクトリ・スキーマを拡張します。

スキーマを拡張する前後にディレクトリのバックアップを実行することをお薦めします。ただし、スキーマを拡張するためにユーザーの接続を切断したり、スキーマの拡張後にサーバーを再起動する必要はありません。
  2. 「Repository」メニューから、「Extend Schema」を選択します。
  3. 「Connect to Repository」ダイアログ・ボックスで必要な接続情報を入力または選択し、「OK」をクリックします。コンソールによって、リポジトリへのバインド、属性およびオブジェクト・クラスの追加、正常に完了したサーバー構成の確認が行われます。
  4. 追加のサーバーごとに繰り返します。

  5. コンテナ・オブジェクトを作成します。

    コンテナ・オブジェクト（通常は、vgoconfig（organizationUnitクラス）という名前）には、優先設定およびPeopleという名前のコンテナ・オブジェクトが保持されます。Peopleコンテナ・オブジェクト（organizationUnitクラス）には、各ユーザーのコンテナ・オブジェクト（SSOUserDataクラス）が含まれ、これらの各ユーザー・コンテナ・オブジェクトには、ユーザー資格証明および設定（SSOSecretクラス）が保持されます。

    コンソールは、適切なセキュリティを備えたコンテナ・オブジェクトを作成し、適切なセキュリティを備えたPeopleコンテナ・オブジェクトを作成し、Peopleコンテナ・オブジェクトに適切なセキュリティを備えた優先設定を配置する場合に使用します。
  6. コンソールの左側のペインで、「Repository」を右クリックし、ショートカット・メニューから「Connect to」を選択します。
  7. 必要な接続情報を入力または選択して、「OK」をクリックします。
  8. 右側のペインで、Peopleオブジェクトおよび優先設定の作成先となるコンテナ・オブジェクトにナビゲートします。
  9. 必要に応じて、新しいコンテナ・オブジェクトを作成します。
  • 親コンテナ・オブジェクトを右クリックし、ショートカット・メニューから「New Container」を選択します。
  • 新しいコンテナ・オブジェクトの名前を入力し、その名前を選択します。
  • コンテナ・オブジェクト（Peopleコンテナ・オブジェクトおよび優先設定が存在するオブジェクト）を右クリックし、ショートカット・メニューから「Configure SSO Support」を選択します。
  • 優先設定のデータソースを選択し、要求された情報を指定します。
  • Administrative Console
  • データファイル
  10. 構成手順が完了すると、新しく作成されたPeopleオブジェクト、および優先設定のエントリがリポジトリ・ペインに表示されます。必要に応じて、任意のオブジェクトを右クリックし、「Refresh」を選択します。
  11. 追加のコンテナ・オブジェクトごとにこの手順を繰り返します。
  12. ロケータ・オブジェクトを作成します。
「ディレクトリ構造」に示すとおり、ESSO-LMがディレクトリ・サーバーに接続すると、エージェントがユーザー資格証明を保存できる場所を指すSSOLocatorオブジェクトが検索されます。Defaultという名前のSSOLocatorClassオブジェクトが、ツリーのいずれかの場所に存在する必要があります。必要に応じて、特定のユーザーに固有のSSOLocatorClassオブジェクトを作成できます。
  1. コンソールの左側のペインで、「Repository」を右クリックし、ショートカット・メニューから「Connect to」を選択します。
  2. 必要な接続情報を入力または選択して、「OK」をクリックします。
  3. 右側のペインで、Peopleオブジェクトおよび優先設定の作成先となるコンテナ・オブジェクトにナビゲートします。
  4. 必要に応じて、新しいコンテナ・オブジェクトを作成します。

  • 親コンテナ・オブジェクトを右クリックし、ショートカット・メニューから「New Container」を選択します。
  • 新しいコンテナ・オブジェクトの名前を入力し、その名前を選択します。

  1. 右側のペインで、ロケータを追加するコンテナにナビゲートします。
  2. コンテナを右クリックし、ショートカット・メニューから「Add Locator Object」を選択します。
  3. ロケータ名を指定します（ユーザーごとに固有のロケータが1つずつ存在しない場合は、すべてのユーザーにデフォルトを入力します）。
  4. ターゲットのPeopleコンテナ・オブジェクトの親コンテナ・オブジェクトにナビゲートして（またはそのパスを指定して）、「OK」をクリックします。新しく作成されたSSOLocatorオブジェクトが、指定した名前で表示されます。必要に応じて、任意のオブジェクトを右クリックし、「Refresh」を選択します。
  5. 追加のSSOLocatorオブジェクトごとに繰り返します。


ファイル・システム: サーバーの構成

ここでは、ESSO-LMと連携して動作するようにファイル・システムを拡張する方法について説明します。このプロセスによって、一部のタスクが容易になりますが、管理者がファイル・システム共有の計画と配置に関する知識を持っていることが前提となります。このドキュメントでは、ESSO-LMの配置に固有の概念のみを取り上げます。

ESSO-LMによるファイル・システム・リソースの使用方法の詳細は、「ファイル・システム同期サポート」を参照してください。

ESSO-LM用にファイル・システム共有を構成するには、コンソールを使用して、ディレクトリ構造にオブジェクトを設定する必要があります。

ファイル・システムに接続するときに、管理者権限が付与された認証情報を入力する必要があります。この情報には、シンクロナイザ拡張タイプ、UNCパス、ユーザーIDおよびパスワードが含まれます。

ユーザーIDは、ドメイン名の形式で指定する必要があります。たとえば、yourdomain\yournameです。

コンテナ・オブジェクトの作成

通常、コンテナ・オブジェクトは、UNC形式のファイル・システム共有です。次に例を示します。

\\Server\Share

または、パスで共有を示すこともできます。次に例を示します。

\\Server\Share\Path\subPath

コンテナ・オブジェクトには、優先設定およびPeopleという名前のコンテナ・オブジェクトが保持されます。

  • Peopleコンテナ・オブジェクトは、各ユーザー用のコンテナ・オブジェクトが含まれるファイル・フォルダです（権限: User=Full、Server\Administrators=Full）。
  • これらの各ユーザー・コンテナ・オブジェクトには、SSOUserDataという名前のコンテナ・オブジェクトが保持されます。
  • 各SSOUserDataコンテナ・オブジェクトには、SSOSecretDataオブジェクト（ファイル）のユーザー設定および各アプリケーション資格証明用のコンテナ・オブジェクトが保持されます。
  • これらの各コンテナ・オブジェクトには、1つのアプリケーション用のユーザー資格証明（SSOSecretDataという名前のファイル）が含まれます。

コンソールは、適切なセキュリティを備えたコンテナ・オブジェクトを作成し、適切なセキュリティを備えたPeopleコンテナ・オブジェクトを作成し、Peopleコンテナ・オブジェクトに適切なセキュリティを備えた優先設定を配置する場合に使用します。

  1. コンソールの左側のペインで、「Repository」を右クリックし、ショートカット・メニューから「Connect to」を選択します。
  2. 必要な接続情報を入力または選択して、「OK」をクリックします。
  3. 右側のペインで、Peopleオブジェクトおよび優先設定の作成先となるコンテナ・オブジェクトにナビゲートします。
  4. 必要に応じて、新しいコンテナ・オブジェクトを作成します。
    1. 親コンテナ・オブジェクトを右クリックし、ショートカット・メニューから「New Container」を選択します。
    2. 新しいコンテナ・オブジェクトの名前を入力し、その名前を選択します。
  5. コンテナ・オブジェクト（Peopleコンテナ・オブジェクトおよび優先設定が存在するオブジェクト）を右クリックし、ショートカット・メニューから「Configure SSO Support」を選択します。
  6. 優先設定のデータソースを選択し、要求された情報を指定します。
    • Administrative Console
    • データファイル
  7. 構成手順が完了すると、新しく作成されたPeopleオブジェクト、および優先設定のエントリがリポジトリ・ペインに表示されます。必要に応じて、任意のオブジェクトを右クリックし、「Refresh」を選択します。
  8. 追加のコンテナ・オブジェクトごとにこの手順を繰り返します。


データベース同期: サーバーの構成

ここでは、ESSO-LMと連携して動作するようにリレーショナル・データベース･サーバーを構成する方法について説明します。リレーショナル・データベースの管理と操作に関する基本知識があることを前提としています。このドキュメントでは、ESSO-LMの配置に固有の概念のみを取り上げます。

ESSO-LMによるデータベース・サーバー・リソースの使用方法の詳細は、「データベース同期サポート」を参照してください。

データベース同期用にESSO-LMを構成するには、ESSO-LM Administrative Consoleを使用してデータベース・スキーマを拡張し、コンテナ・オブジェクトを作成する必要があります。

  1. データベース・スキーマを拡張します。

スキーマを拡張する前後にデータベースのバックアップを実行します。
  1. 「Repository」メニューから「Extend Schema」を選択します。
  2. 「Connect to Repository」ダイアログ・ボックスで必要な接続情報を入力または選択し、「OK」をクリックします。コンソールがデータベース・サーバーに接続するには、管理者レベルの認証接続が必要です。コンソールによって、データベースに接続され、必要なオブジェクトが作成され、正常終了した構成が確認されます。

SQLサーバーでは、スキーマの拡張時にデータベースが存在しない場合は、スキーマの拡張機能によってデータベースが作成されます。IBM DB2の設定手順については、ここをクリックしてください。
  2. 追加のサーバーごとに繰り返します。
  3. コンテナ・オブジェクトを作成します。

コンテナ・オブジェクト（通常は、SSOConfigという名前）には、優先設定のデフォルト設定およびPeopleという名前のコンテナ・オブジェクトが保持されます。Peopleコンテナ・オブジェクトには、各ユーザーのコンテナ・オブジェクトが含まれ、これらの各ユーザー・コンテナ・オブジェクトには、ユーザー資格証明および設定が保持されます。

ESSO-LM Administrative Consoleは、コンテナ・オブジェクトを作成し、Peopleコンテナ・オブジェクトを作成し、Peopleコンテナ・オブジェクトに適切なセキュリティを備えた優先設定を配置する場合に使用します。

  1. コンソールの左側のペインで、「Repository」を右クリックし、ショートカット・メニューから「Connect to」を選択します。
  2. 必要な接続情報を入力または選択して、「OK」をクリックします。
  3. 右側のペインで、Peopleオブジェクトおよび優先設定の作成先となるコンテナ・オブジェクトにナビゲートします。
  4. 必要に応じて、新しいコンテナ・オブジェクトを作成します。
  5. 親コンテナ・オブジェクトを右クリックし、ショートカット・メニューから「New Container」を選択します。
  6. 新しいコンテナ・オブジェクトの名前を入力し、その名前を選択します。
  7. コンテナ・オブジェクト（Peopleコンテナ・オブジェクトおよび優先設定が存在するオブジェクト）を右クリックし、ショートカット・メニューから「Configure SSO Support」を選択します。
  8. 優先設定のデータソースを選択し、要求された情報を指定します。

    • データファイル

    • Administrative Console
  9. 構成手順が完了すると、新しく作成されたPeopleオブジェクト、および優先設定のエントリがリポジトリ・ペインに表示されます。必要に応じて、任意のオブジェクトを右クリックし、「Refresh」を選択します。
  10. 追加のコンテナ・オブジェクトごとにこの手順を繰り返します。


パスワード・ポリシーの設定

ESSO-LMを使用すると、管理者は自動パスワード生成を制御するポリシーを設定できます。パスワード・ポリシーによって、組織のセキュリティを保証する一方で、ユーザー・ログオンが容易になります。

大部分のアプリケーションには、パスワードの長さや、番号やシンボルなどを使用できるかどうかに関する制約があります。ESSO-LMのパスワード生成機能では、事前定義された一連の制約に従ってランダムな文字列で構成され、パスワード・ポリシーとして保存されるパスワードが自動的に作成されるため、アプリケーション・ログオンのセキュリティが強化されます。各ポリシーは、複数のアプリケーション（サブスクライバ）に適用できます。

事前定義されたパスワード・ポリシーを使用すると、パスワードの変更を完全に自動化でき、複雑なパスワード、定期的なパスワードの変更、ユーザーには知られないアプリケーション固有のパスワードなどの高度なセキュリティ・スキーマを実装できます。

作成したポリシーによってパスワードの作成が難しくなったか、または不可能になった場合、ESSO-LMでは最大5秒間のパスワードの作成が試行され、その後、パスワードが作成できなかったことがユーザーに通知されます。「Test Password Policy」ダイアログ・ボックスを使用すると、特定のポリシーで生成されたパスワードをプレビューできます。


資格証明共有グループの作成

資格証明共有グループを使用すると、ユーザーは、1つのアプリケーションで行われた資格証明の変更を他の指定したアプリケーションに自動的に適用できます。

ESSO-LMで共有グループのメンバーである任意のアプリケーションに対する資格証明の変更が処理されると、その資格証明の変更が他のすべてのグループ・メンバーに自動的に適用されます。任意の数のWindows、メインフレーム/ホストおよびWebアプリケーションまたはそれらの組合せでは、単一の資格証明を共有できます。Windows（ドメイン）またはディレクトリ・サーバー（ LDAP）の認証方式が使用される場合は、同様に、選択されたアプリケーションでは単一の資格証明が認証方式と共有されます。

資格証明共有グループを有効にしないかぎり、エージェントへの最初の配置の場合のみ、アプリケーションは資格証明を共有します。「Required Password Change」設定でこのパラメータを設定します。「Advanced Password Change」設定で、資格証明を共有するアプリケーションについてユーザーが管理することを許可または禁止できます。

たとえば、古いメインフレーム・アプリケーションに対して新しいWebインタフェースが実装されている企業があります。これらの2台の間で資格証明を共有するには、資格証明共有グループを使用する方法があります。アプリケーション間で共通の資格証明が共有される場合があります（インターネット・アプリケーションや電子メール・アプリケーションなど）。これらのアプリケーションは、同一の資格証明共有グループに属している必要があります。

共有グループを作成および管理するための手順については、「資格証明共有グループ」を参照してください。

Windows認証方式のパスワードは、Domainという名前の事前定義されたグループにあります。

LDAPディレクトリ・サーバーの認証方式は、LDAPという名前の事前定義されたグループにあります。

事前定義されたアプリケーションのサポート

現在、ESSO-LM Administrative Consoleでは、事前定義されたアプリケーション（デフォルトの構成ファイルapplist.iniに含まれるアプリケーション）を資格証明共有グループに追加することはできません。共有グループを識別するentlist.ini（カスタム・アプリケーションの構成ファイル）に同じ名前のセクションを作成することによって、手動でこれを実行する必要があります。次の例では、Internet Explorerポップアップ・アプリケーションを資格証明共有グループOurServerに追加します。

例:

[~Internet Explorer Pop-up XP]
Group=OurServer


ユーザー・データの格納

ESSO-LMでは、...\Application Data\Passlogixフォルダにユーザー資格証明がローカルに保存されます。グローバル・エージェント設定は、ローカル・マシン・レジストリ・キー（HKLM）に保存されます。ユーザーが変更した設定は、現在のユーザー・レジストリ・キー（HKCU）に保存されます。

また、ESSO-LMでは、ファイル（.bkv）への資格証明および設定の完全バックアップも実行できます。バックアップは、ユーザーによって手動で、または管理構成によって自動的に実行できます）。この機能の詳細は、 「ファイルベースのバックアップ/リストア」 を参照してください。

さらに、ESSO-LMでは、各ユーザー資格証明をファイル・システム、データベース、ディレクトリ・サーバーなどのリモート・ソースと同期化することもできます。これらのリモート・ソースでは、エージェントにアプリケーション・ログオン、はじめて使用する場合の（設定）情報および管理優先設定（グローバル・エージェント設定）を指定できます。この機能の詳細は、「同期」を参照してください。

ユーザー・オブジェクトへの資格証明の保存（Active Directoryのみ）

Active Directoryのインストール時に、標準のvgoconfigコンテナではなく、ユーザー・オブジェクトの下にユーザー・データを保存するようにESSO-LMを構成できます。このように構成するには、次の手順を実行します。

  1. （「Repository」メニューの）「Enable Storing Credentials under User Object」コマンドを使用して、ユーザー資格証明コンテナがユーザー・オブジェクトの子として許可されるようにディレクトリ・スキーマを更新します。また、このコマンドによって、資格証明コンテナを作成する権限をユーザーに付与するように、ルート・ディレクトリのセキュリティ設定が変更されます。
  2. 次のいずれかを実行します。
  3. （「Add Locator Object」ダイアログ・ボックスで）「Store data under the user objects」オプションを選択して、ユーザー・オブジェクト（複数可）を指すvgolocatorオブジェクト（このロケータを使用するすべてのユーザー、または識別名で特定されるユーザーの場合はデフォルト）を作成します。
  4. （「Active Directory」-「Advanced」設定で）「Location for storing user credentials」エージェント設定を使用し、vgolocatorオブジェクトを無視して、常にユーザー・オブジェクトの下に資格証明を保存するようにエージェントを構成します。


ファイルベースのバックアップ/リストア

バックアップ/リストア・モジュールがインストールされている場合は、コンソールを使用して、ユーザー資格証明および設定の別の場所への完全バックアップ、およびその場所からの完全リストアを実行できます。バックアップ/リストアは、（ユーザーによって）手動で、または（管理構成によって）自動的に実行できます。また、選択可能なバックアップ/リストア（古い情報の上に新しい情報を書き込む）も、（管理構成によって）自動的に実行できます。

バックアップ/リストア・モジュールがインストールされている場合、ユーザーは手動バックアップ、任意の場所（フロッピー・ドライブでも可）への保存および任意のパスワード（1文字のパスワードでも可）の選択を実行できます。

自動バックアップ

エージェントをユーザー資格証明および設定の完全バックアップを実行するように構成できます。このバックアップは、コマンドラインから（したがって、atまたはtimedジョブから）、または特定のエージェント・イベント（起動タスク、リフレッシュ・タスクなど）を構成することによってトリガーできます。

コマンドライン自動バックアップ

コマンドライン自動バックアップをトリガーするには、次の構文を使用してコマンドラインからエージェントを実行します（現在エージェントを実行中の場合も、この構文を使用します）。

ssoshell.exe/mobility /backup [path] /silent &それぞれの意味は次のとおりです。&
[path] | バックアップ・ファイルが保存されているディレクトリへの実際のパス。デフォルトは、最後にコマンドライン・バックアップ・ファイルが保存されたディレクトリ、または 「Default Backup path 」（End-User ExperienceEnvironmentの下）が指すディレクトリです。
` | バックアップの実行時にバックアップ/リストア・ウィザードを表示しません。

\\FS\Backup\Privateのネットワーク共有への完全なサイレント・バックアップを実行するには、次のコマンドを実行します。

ssoshell.exe/mobility /backup "\FS1\Backup\Private" /silent

最後に使用された場所、または 「Default Backup path」（End-User Experience\Environmentの下）が指す場所にバックアップするには、次のコマンドを実行します。

ssoshell.exe/mobility /backup /silent

イベント・ドリブン自動バックアップ

特定のエージェント・イベント時に自動バックアップを実行するようにエージェントを構成するには、目的のバックアップを実行するために必要なコマンドライン文字列を指定します。次に、適切なタスクを設定します。たとえば、資格証明が変更されるたびにバックアップを実行するには、（End-User Experience\Advanced\Special Tasksにある）「When logons change」を実行するタスクをコマンドライン文字列に設定します。

強制リストア

ユーザー資格証明および設定の完全リストアを実行して既存のデータを置き換えるように、エージェントを構成できます。このリストアは、コマンドラインから（リモートrunコマンドを使用）、または特定のエージェント・イベント（起動タスクなど）を構成することによってトリガーできます。

コマンドライン強制リストア

コマンドライン自動バックアップをトリガーするには、次の構文を使用してコマンドラインからエージェントを実行します（現在エージェントを実行中の場合も、この構文を使用します）。

ssoshell.exe/mobility /restore [path] /silent &それぞれの意味は次のとおりです。&
[path] | バックアップ・ファイルが保存されているディレクトリへのパス。デフォルトは、最後にコマンドライン・バックアップ・ファイルが保存されたディレクトリ、または 「Default Backup path」（End-User ExperienceEnvironmentの下）が指すディレクトリです。
/silent | バックアップの実行時にバックアップ/リストア・ウィザードを表示しません。

\\FS\Backup\Privateのネットワーク共有からの完全なサイレント・リストアを実行するには、次のコマンドを実行します。
ssoshell.exe/mobility /restore "\FS1\Backup\Private" /silent

最後に使用された場所、または「Default Backup path」（End-User Experience\Environmentの下）が指す場所からリストアするには、次のコマンドを実行します。

ssoshell.exe/mobility /restore /silent

イベント・ドリブン強制リストア

特定のエージェント・イベント時に強制リストアを実行するには、目的のリストアを実行するために必要なコマンドライン文字列を指定します。次に、適切なタスクを設定します。たとえば、起動時にリストアを実行するには、（End-User Experience\Advanced\Special Tasksにある）「After Agent starts up」を実行するタスクをコマンドライン文字列に設定します。


同期

シンクロナイザ拡張を使用すると、エンド・ユーザーのローカル・ストア（ワークステーション上）とリモートSSOリポジトリ（ファイル・システム共有、リレーショナル・データベースまたはディレクトリ・サーバー）のストアの間で、資格証明を同期化できます。また、この拡張を使用すると、ローカル・エージェント設定の管理優先設定、アプリケーション・ログオン構成（entlist.iniより優先され、applist.iniとマージされる）およびバルク追加リスト（ftulist.iniより優先される）を配置できます。詳細は、「優先設定」を参照してください。

シンクロナイザ拡張は、ディレクトリ・サーバー、データベース・サーバー、ファイル・システムおよびその他のストレージ・デバイスと通信します。各タイプの拡張には、独自の構成に関する要件があります。ESSO-LMでは、次の拡張がサポートされています。

  • Microsoft Active Directoryサーバー（アプリケーション・モードを含む）
  • LDAPに準拠したディレクトリ・サーバー（IBM Tivoli Directory Server、Novell eDirectory、Oracle Directory Server、Sun Java System Directory Server、OpenLDAP Directory Serverを含む）
  • リレーショナル・データベース（Microsoft SQL Server、IBM DB2、Oracle 9i/10gを含む）
  • ネットワーク・ファイル・システム

シンクロナイザ拡張では、次のタスクを実行できます。

  • 宛先のデバイス/リソース/ストアへの接続（またはバインド）
  • 優先設定の検索（管理優先設定、アプリケーション構成情報、およびはじめて使用する場合の構成情報）
  • ローカル・ユーザー・ストア（資格証明）とリモート・ストアとの同期化

ESSO-LMでは、各拡張を複数回使用することができるため、複数の構成をサポートできます。たとえば、LDAPディレクトリ・サーバーおよびファイル・システムのシンクロナイザ拡張がインストールされている場合、エージェントは資格証明をLDAPディレクトリ・サーバーとファイル・システムと同期化し、両方から優先設定をダウンロードします。この手順の詳細は、「複数のシンクロナイザ拡張」を参照してください。


ディレクトリ・サーバー同期サポート

コンソールでは、次のようなLDAPディレクトリ・サーバーがサポートされています。

  • IBM Tivoli Directory Server
  • Microsoft Active Directory（アプリケーション・モードを含む）
  • Novell eDirectory
  • Oracle Directory Server
  • Sun Java System Directory Server
  • Open LDAP Directory Server

ESSO-LMでは、管理構成、可動性およびバックアップでディレクトリ・サーバー・リソースが使用されます。管理者は、新規のレジストリentlist.iniおよびftulist.ini（バルク追加）の設定、または既存の設定の更新を行うために優先構成を配置できます。ユーザーは資格証明（バックアップ用）を保存して、複数のコンピュータ間を移動できます（可動性）。ESSO-LMがディレクトリ・サーバーに接続すると、特定のディレクトリ構造を使用して、ユーザーの資格証明および優先設定が格納されている場所が判断されます。

各ディレクトリ・サーバーには、プラットフォーム固有の構成に関する問題があります。それらの問題については、各構成の項で説明します。

ディレクトリ構造

各ディレクトリ内では、ESSO-LMは次のオブジェクト構造を使用します。

[ ダイアグラム表示]

ユーザーが最初にディレクトリ・サーバーに接続すると、ディレクトリ・ツリー上の特定のパスを検索するようにシステムが構成されます。次のプロセスを使用して、エージェントはSSOConfigオブジェクトを検索できます。SSOConfigオブジェクトには、優先設定およびPeopleオブジェクトが含まれています。Peopleオブジェクトには、ユーザーの設定、プリファレンスおよび資格証明が含まれています。

ユーザー・オブジェクトの検索および作成

ここでは、ESSO-LMがユーザー・オブジェクトや構成情報の検索で使用する方法、およびこれらのオブジェクトの作成方法について説明します。

エージェントは、ユーザー資格証明を格納および検索する特定オブジェクトを検索する必要があります。最初に接続に成功した後、エージェントによって、次の場所にあるユーザー・レジストリにオブジェクトDNが記録されます。

HKCU\...\Extensions\SyncManager\%Extension%:Root

%Extension%は、「Sync Order」で指定された任意の名前にすることができます（「同期」を参照）。ただし、特定のワークステーションからはじめて接続するときは、ユーザー・オブジェクトが移動するか、またはユーザー・レジストリにこの情報が含まれていない場合は、エージェントがユーザー・オブジェクトを検索する必要があります。

ESSO-LMでは、ディレクトリ・サーバーにユーザー資格証明を保存するための最適な場所を検索するために3つの方法が使用されます。各方法では、指定された識別名が検索されます。後の2つの方法では、ルートに向かってディレクトリ・ツリーを移動し、関連する情報を持つ親オブジェクトが検索されます。

  • 1番目の方法では、指定された場所でユーザー・オブジェクト（CN=%UserName%,OU=People）が検索されます。
  • 2番目の方法では、適切な場所へのユーザー固有のポインタ・オブジェクト（CN=%UserName%,OU=SSOLocator）が検索されます。存在しない場合は、エージェントによってオブジェクトが検出されるか、またはエージェントによってルートが確認されるまでツリーを移動します。
  • 3番目の方法では、適切な場所へのデフォルト・ポインタ（CN=default,OU=SSOLocator）が検索されます。存在しない場合は、エージェントによってオブジェクトが検出されるか、またはエージェントによってルートが確認されるまでツリーを移動します。

いずれの方法も成功しなかった場合、ユーザーはディレクトリ・サーバーに資格証明を保存できません（既存のローカル資格証明は使用可能です）。

%UserName%変数は、ユーザー・システムのユーザー名/IDからMicrosoft Active Directoryに自動的に設定されます。LDAPディレクトリ・サーバーの場合、%UserName%変数は、ユーザーがディレクトリ・サーバーへのバインドを実行するユーザー名/IDから設定されます。

方法1: ESSO-LMによるユーザー・オブジェクトの検索

ESSO-LMでは、最初に、OU=Peopleオブジェクト内で、ルート・レジストリ・キーで指定されたユーザー・オブジェクトCN=%UserName%が検索されます（前述の説明を参照）。

次のようにレジストリ・キーを設定すると、

OU=SSOConfig,OU=QA,OU=Eng,OU=Company,DC=com,

エージェントは次の項目を検索します。

CN=%UserName%,OU=People,OU=SSOConfig,OU=QA,OU=Eng,OU=Company,DC=com.

ルート・レジストリ・キーが設定されていない場合、エージェントは、

HKLM\...\Extensions\SyncManager\%Extension%

で「User Paths」（Synchronization\LDAP\Requiredを参照）または「Naming Attribute string」（Synchronization\LDAP\Advancedを参照）を検索します。これらは、エージェントが検索する場所を指します。

たとえば、次のようにUserPath1を設定するとします。

CN=users,DC=Company,DC=com

エージェントは次の項目を検索します。

CN=%UserName%,OU=People,OU=SSOConfig,OU=QA,OU=Eng,OU=Company,DC=com

方法2: ESSO-LMによるユーザー・ポインタの検索

ユーザー・オブジェクトが存在しない場合、次にESSO-LMでは、SSOConfigオブジェクトと同じオブジェクト内で、SSOLocatorオブジェクトが検索されます。したがって、前述の例を続行すると、エージェントは次の項目を検索します。

CN=%UserName%,OU=SSOLocator,OU=QA,OU=Eng,DC=Company,DC=com

ユーザー・ポインタが存在しない場合、エージェントはルートに向かってツリーを移動し、最初に次の場所を検索します。

CN=%UserName%,OU=SSOLocator,OU=Eng,DC=Company,DC=com

その後、次の項目を検索します。

CN=%UserName%,OU=SSOLocator,DC=Company,DC=com

ユーザーCNを持つSSOLocatorオブジェクトが存在する場合は、ユーザー資格証明が保存されている場所を指します。エージェントによって、この情報はユーザーのルート・レジストリ・キーに記録され、今後のログオンではその場所が検索されます。

ポインタでディレクトリ・ツリーの任意の場所を示すことができることに注意してください。たとえば、次の場所のポインタは、

CN=%UserName%,OU=SSOLocator,OU=Eng,DC=Company,DC=com

次の場所にあるユーザー・オブジェクトを指すことができます。

CN=%UserName%,OU=People,OU=SSOConfig,OU=Sales,DC=Company,DC=com.

方法3: ESSO-LMによるデフォルト・ポインタの検索

ユーザー・ポインタが存在しない場合、次にESSO-LMでは、各SSOLocatorオブジェクト内で、デフォルト・オブジェクトが検索されます。前述の例を続行すると、エージェントは次の項目を検索します。

CN=default,OU=SSOLocator,OU=QA,OU=Eng,DC=Company,DC=com

CN=defaultのSSOLocatorオブジェクトが存在する場合は、ユーザー資格証明がデフォルトで保存されている場所を指します。エージェントによって、この情報はユーザーのルート・レジストリ・キーに記録され、今後のログオンではその場所が検索されます。デフォルト・オブジェクトには、OU=People,OU=SSOConfig,OU=Sales,DC=Company,DC=comなどがあります。


ファイル・システム同期サポート

コンソールでは、UNC（Universal Naming Convention）で指定できる任意のネットワーク・ドライブ/デバイスとのファイル・システム同期がサポートされています。また、ファイル・システム同期を使用すると、複数のユーザーが単一のワークステーションを共有するKioskユーザーのシナリオもサポートできます。

ファイル・システム構造

ユーザーが最初にファイル・システムに接続すると、特定のパスを検索するようにコンピュータが構成されます。次に、エージェントはSSOConfigオブジェクトを検索するように指示されます。SSOConfigオブジェクトには、優先設定およびPeopleオブジェクトが含まれています。Peopleオブジェクトには、ユーザーの設定、プリファレンスおよび資格証明が含まれています。


データベース同期サポート

ESSO-LM Administrative Consoleでは、クライアント・ワークステーションとリレーショナル・データベース・サーバー間のユーザー資格証明、アプリケーション・ログオンおよびグローバル・エージェント設定の同期がサポートされています。サポートされているサーバーには、Microsoft SQLServer 2000、IBM DB2、Oracle 9i/10gがあります。

このタイプの同期では、ESSO-LM構成オブジェクトおよびユーザー・データ・コンテナは、ESSO-LM固有の表のデータベース・レコードとしてサーバーに保存されます。

  • SSO_ADMINでは、コンソールで作成した次のような構成オブジェクトがレコードとして保存されます。
  • EntList（アプリケーション・ログオン）、FTUList（セットアップ・ウィザード構成）
  • AdminOverride（グローバル・エージェント設定）

同期中、すべてのワークステーション・ユーザーは、この表から自分自身のログオンを読み取り上書きします。管理者のみが（コンソールを使用して）書き込むことができます。これらの構成オブジェクトは、ファイル・システムおよびディレクトリ・サーバーのシンクロナイザの場合と同じ階層レイアウトでコンソールに表示されます。

  • SSO_USERSでは、ユーザー資格証明、プリファレンスおよび同期の状態がレコードとして保存されます。同期中、ユーザーは自分自身のレコードを読み取り、書き込みます。現在ログオンしているユーザーのレコードにのみアクセスできます。コンソールでは、各ユーザーのレコードはユーザー・コンテナ内に表示されます。

ESSO-LMがデータベース・サーバーに接続すると、構成オブジェクトおよび優先設定が（SSO_ADMINから）読み取られ、（SSO_USERSの）ユーザー・データが同期化されます。

データベース同期を構成する手順は、その他の同期方法と似ています。

  1. データベース・スキーマを拡張して、前述の2つの表を作成します。
  2. コンテナ・オブジェクト SSOConfigオブジェクトを作成します。このオブジェクトには、優先設定およびPeopleオブジェクトが含まれています。Peopleオブジェクトには、ユーザーの設定、プリファレンスおよび資格証明のためのユーザー・コンテナが含まれています。


複数のシンクロナイザのサポート

ESSO-LMでは、複数のシンクロナイザ拡張および同じ拡張の複数の構成との同期化がサポートされています。いずれの場合も、エージェントでは、最初の拡張との同期、次に各従属拡張との同期の完了が試行されます。

優先設定が各拡張に存在する場合があります。エージェントが優先設定を含む複数の拡張を処理する方法の詳細は、「優先設定の複数セットの処理」 を参照してください。

%AD%、%LDAP%および%File%はそれぞれの拡張を表し、%Extension%はそれらの拡張のいずれかを表します。

複数のシンクロナイザ拡張

ESSO-LMでは、複数のシンクロナイザ拡張の同時使用がサポートされています。たとえば、エージェントは最初にMicrosoft Active Directoryサーバーと同期化し、次にSun Java System Directory Server、最後にファイル・システムのシンクロナイザと同期化できます。ESSO-AM の場合、その後エージェントはスマート・カードと同期化できます。

これを有効にするには、次の手順を実行します。

  1. 目的のシンクロナイザ拡張でESSO-LMをインストールします。
  2. コンソールで、グローバル・エージェント設定の既存セットを選択するか、または新しいセットを作成します。
  3. 左側のペインで、グローバル・エージェント設定を開き、「Synchronization」を右クリックし、「Manage Synchronizers」を選択します。
  4. 「Synchronizers」ダイアログ・ボックスで「Add」を選択し、この拡張に名前を付け、拡張タイプ（Active Directory、ファイル・システム、LDAPなど）を選択した後、「OK」をクリックします。
  5. 追加のシンクロナイザ拡張ごとに前の手順を繰り返し、必要に応じて並べ替えます。
  6. シンクロナイザごとに、左側のペインでそのシンクロナイザを選択し、右側のペインで、パスが選択され、指定の場所が正しいことを確認します。

ユーザーが複数の拡張を区別できるように、DisplayNameレジストリのエントリを設定することをお薦めします。

同一のシンクロナイザ拡張の複数の構成

ESSO-LMでは、複数の構成で指定された拡張の使用がサポートされています。たとえば、あるLDAPディレクトリ・サーバーの構成をSun Java System Directory Server用に、別のLDAPディレクトリ・サーバーの構成をNovell eDirectory用にすることができます。

これを有効にするには、次の手順を実行します。

  1. 目的のシンクロナイザ拡張でESSO-LMをインストールします。
  2. コンソールで、グローバル・エージェント設定の既存セットを選択するか、または新しいセットを作成します。
  3. 左側のペインで、グローバル・エージェント設定を開き、「Synchronization」を右クリックし、「Manage Synchronizers」を選択します。
  4. 「Synchronizers」ダイアログ・ボックスで「Add」を選択し、この拡張に名前を付け、拡張タイプLDAPを選択した後、「OK」をクリックします。
  5. 追加のシンクロナイザ拡張ごとに前の手順を繰り返し、必要に応じて並べ替えます。
  6. シンクロナイザごとに、左側のペインでそのシンクロナイザを選択し、右側のペインで、パスが選択され、指定の場所が正しいことを確認します。

ユーザーが複数の拡張を区別できるように、DisplayNameレジストリのエントリを設定することをお薦めします。


ローミング・プロファイル同期

「Roaming Profile Synchronization」> 「Required」

コンソールでは、ファイル・システム同期がサポートされています。ローミング・プロファイル・シンクロナイザ拡張では、ローミング・プロファイルがサポートされています。これは、次の条件を満たす配置で使用します。

  • ユーザーが、サーバーでローミング・プロファイルを使用するように設定されている。
  • 「Delete Local Cache」設定がまだ同期可能になっていない。
  • V1認証を使用している場合。

前述の条件が存在する場合は、次のようにローミング・プロファイル環境を設定します。

  1. ESSO-LMが、インストールされている同期拡張の1つがローミング同期拡張であるマルチ同期環境で稼働するように設定します。マルチ同期環境とは、2つ以上の同期拡張がインストールされている同期環境のことです。たとえば、AD同期拡張を使用する場合は、AD同期拡張およびローミング・プロファイル拡張をインストールする必要があります。
  2. ローミング・プロファイル・シンクロナイザ拡張は、同期構成順序で先頭に位置するシンクロナイザである必要があります。この順序を設定するには、「Global Agent Settings」> 「Live」を順に展開し、「Synchronization」をクリックします。「Sync Order」フィールドに移動し、「...」ボタンをクリックします。シンクロナイザ・パネルで、ROAMSyncExtが1番目で、使用中の他の同期タイプ（ActiveDirectoryなど）が2番目であることを確認します。
  3. AD同期設定、またはローミング・プロファイルで使用されている他の同期に変更を加える必要はありません。
  4. 「Roaming Profiles」パネルで、「Extension」ロケーション・ボックスを選択し、「...」ボタンをクリックします。拡張の場所にナビゲートし、選択します。


優先設定オブジェクト

構成オブジェクト

シンクロナイザ拡張では、グローバル・エージェント設定（管理優先設定）、アプリケーション構成情報（EntList）、およびはじめて使用する場合のシナリオ（FTUlist）の優先構成をダウンロードできます。これらの各オブジェクトには、ローカルで対応するものがあります。

設定タイプ | ローカルで対応するもの | ディレクトリ・サーバー/データベース・オブジェクトの名前 | ファイル・システム・オブジェクトの名前
管理優先設定 | HKLMの下のレジストリ・エントリ | SSOAdminOverride | AdminOverride
アプリケーション・ログオン構成情報 | entlist.iniファイル | SSOentlist | entlist
はじめて使用する場合の構成情報（バルク追加情報など） | ftulist.iniファイル | SSOftulist | ftulist

後の2つのタイプのオブジェクトは、ローカルで対応するもの（entlist.iniおよびftulist.ini）と形式およびレイアウトが似ています。最初のタイプのオブジェクトの構文は、次のとおりです。

[HKLM\Software\Passlogix]

REQUIRED: RegistryPath\RegistryPath:KeyName=TYPE:Value

この形式は、コンソールによってエクスポートされます。

例:

[HKLM\Software\Passlogix]

Shell:AutoBackupPath=STRING:\\FS\Home

Shell:ShowAccessBtn=DWORD:1

Extensions\AccessManager:ReauthOnReveal=DWORD:0

ディレクトリ・サーバーのインストール中、ロール・グループ・ベースのアクセスのサポートとともにこの構成情報を有効にできます。

サーバーURLなどの特定の設定が優先されることはできません。そのため、管理優先設定オブジェクトから永久に除外されます。「優先設定: レジストリ・エントリ」の表は、設定が優先される設定から除外されているかどうかを表します。

優先設定の複数セットとの連携

エージェントでは、少なくとも各優先設定のいずれかを持つ拡張が検索されるまで、各拡張からの各タイプの優先設定の検索が試行されます。優先設定がダウンロードされた後、エージェントでは、その優先設定のその他の拡張の問合せは実行されません。

サンプル・シナリオ

例:
  • 順序: Ext1、Ext2、Ext3、Ext4
  • Ext1には、管理優先設定があります。
  • Ext2には、管理優先設定、entlist.iniファイル、およびはじめて使用する場合の情報ファイルがあります。
  • Ext3には、管理優先設定がありません。
  • Ext4には、管理優先設定、およびはじめて使用する場合の情報ファイルがあります。
シナリオA
  • Ext1が接続され、管理優先設定がダウンロードされ、同期化されます。
  • Ext2が接続され、アプリケーション構成情報およびはじめて使用する場合の構成情報がダウンロードされ、同期化されます。
  • Ext3が接続され、同期化されます。
  • Ext4が接続され、同期化されます。
シナリオB
  • Ext1が失敗します。
  • Ext2が接続され、管理優先設定、アプリケーション構成情報およびはじめて使用する場合の構成情報がダウンロードされ、同期化されます。
  • Ext3が接続され、同期化されます。
  • Ext4が接続され、同期化されます。
シナリオC
  • Ext1が失敗します。
  • Ext2が失敗します。
  • Ext3が接続され、同期化されます。
  • Ext4が接続され、管理優先設定およびはじめて使用する場合の構成情報がダウンロードされ、同期化されます。


イベント・ロギング

この項では、コンソールのイベント・ロギング機能および設定プロセスについて説明します。イベント・ロギングでは、次のような様々なユーザー・イベントが監視されます。

  • エージェントの起動/停止
  • ログオン
  • パスワード変更
  • 資格証明の追加、変更および削除
  • 認証方式の変更
  • バックアップおよびリストア
  • 資格証明の同期
  • 設定の変更
  • ヘルプ・システムの使用

コンソールを使用すると、ログに記録されるイベントの内容、記録される場所と時間、およびログのローカル・コピーを保持するかどうかを制御できます。拡張を追加すると、様々なログの保存先や形式が許可されます。


イベント・ロギング: エージェントの構成

イベント・ロギング: エージェント構成

イベント・ロギングは、ESSO-LMのオプション機能です。デフォルトでは、インストールされません。

イベント・ロギングをインストールするには、「Custom Install」を選択し、イベント・マネージャと、使用するイベント・ロギング拡張を「Extensions」選択肢で有効にします。インストール後、イベント・ロギングおよびインストールされた拡張に対して、特定のパラメータを設定する必要があります。

グローバル設定は、HKLM\...\Extensions\EventManagerに設定されます。

拡張固有の設定は、HKLM\...\Extensions\EventManager\%Extension%に設定されます。

ESSO-LMには、ローカル（XML）・ファイル拡張（Local Storage）およびWindowsイベント・ロギング拡張（WindowsEvent）が含まれています。

グローバル設定

イベントが発生すると、事前に定義された時間が経過するまで、そのイベントがキャッシュされます。この時点で、イベントはフィルタリングされ、適切な拡張に送信されます。各拡張への転送に成功すると、そのイベントはキャッシュから消去されます。

「Global Agent Settings」>[選択したセット]>「Event Manager」の下
Filter | ログに記録するイベント・タイプおよび特定のイベントを指定します。すべての拡張に同じグローバル・フィルタの値を指定したり、拡張ごとに異なるグローバル・フィルタの値を指定できます。
Retry | キャッシュされたイベントをイベント拡張に連続して記録しようとする間、エージェントが待機する間隔（分）を指定します。すべての拡張のデフォルト値は30分です。

ローカル・ファイル拡張

ローカル・アクセスのイベント・マネージャ拡張は、ローカル・ファイル拡張です。この拡張によって、フィルタリングされたイベント・データを含むXMLファイル%UserName%.eventlog.xmlが作成されます。このファイルは、ユーザーのAMLファイルと同じディレクトリ（%AppData%\Passlogix）に保存され、最近のリリースのブラウザで読むことができます。

「Global Agent Settings」>[選択したセット]>「Event Manager」の下
Filter | ローカル（XML）ファイルのロギング拡張に記録するイベントを指定します。
Retry | ローカル（XML）ファイルのロギング拡張に対する再試行間隔（分）を指定します。デフォルトは30分です。

次の例は、単一のログオン・イベントを含むイベント・ログの生のXMLを示します。

例:

<EVENTLOG>

<event>

<type>Info</type>

<category>Logon</category>

<timestamp>4/25/2002 5:46:06 PM</timestamp>

<appname>ACT</appname>

<username>SSOUser</username>

</event>

</EVENTLOG>

Windowsイベント・ロギング拡張

Windowsイベント・ロギング拡張は、Microsoft Windows 2000およびXPにビルドされているWindowsイベント・ロギングに依存しています。ログを表示するには、イベント・ビューアを起動します（たとえば、eventvwr.exeを実行します）。ESSO-LMエントリは、アプリケーション・ログに保存されます。サーバーは適切に構成されている必要があります。

「Global Agent Settings」>[選択したセット]>「Event Manager」>「WindowsEvent」の下
Event Server | Windowsイベント・ロギング拡張のサーバー名（\\を省略します。たとえば、\\fileserverではなく、fileserverと指定します）。このサーバー名を指定しないと、ロギングはローカル・コンピュータで実行されます。 サーバーは、アクセス権および制限に応じて、ユーザーのアカウントおよびユーザーのコンピュータとの信頼関係を持つ必要があります。
Filter | Windowsイベント・ロギング拡張に記録するイベントを指定します。
Retry | Windowsイベント・ロギング拡張に対する再試行間の間隔（分）を指定します。


イベント・ロギング: サーバーの構成

イベント・ロギング: サーバー構成

ESSO-LMロギングを受信するWindowsイベント・サーバーの構成

Microsoft Windows 2000またはXPサーバーをイベント・ログ・メッセージを受信するように構成するには、そのサーバー上にエージェントをインストールするか、エージェント・インストールからサーバーにSSOeventmessage.dllをコピー（できればSystem32ディレクトリに）します。次の場所に、次の4つのレジストリ・キーを作成します。

HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Eventlog\Application\v-GO Single Sign-On

EventMessageFile | STRING | ファイル名を含めたSSOeventmessage.dllファイルへのフルパス（%WinDir%\System32\SSOeventmessage.dllを推奨)
TypesSupported | DWORD | 7
CategoryMessageFile | STRING | ファイル名を含めたSSOeventmessage.dllファイルへのフルパス（%WinDir%\System32\SSOeventmessage.dllを推奨)
CategoryCount | DWORD | 4


Windowsイベント・ログベースのレポート

ESSO-LMの大規模な配置では、ユーザー・アクションと各アクションについての情報（日付、時間、ユーザーの名前など）の頻繁な監査が必要になることがあります。ESSO-LMは、この情報をWindowsイベント・ログのメカニズムを使用して記録するため、ユーザーは既存のインフラストラクチャを活用して、システム全体の監査のためのソース・データを簡単に収集できます。

ESSO-LMによって記録されるイベント・ログ・データを使用すると、次のことが可能になります。

  • ログオン、パスワード変更など、ESSO-LMユーザーのアクションの追跡。これには、アクションのタイプ、ADアカウント名、日付、時間、アクションの実行に使用される資格証明などの関連情報が含まれます（当てはまる場合）。
  • 各ユーザーがこれまでのアプリケーションへのログオンに使用した資格証明の追跡。これは、許可なく資格証明を共有しているユーザーによる不当なアクセス試行を検出するのに役立ちます。
  • ESSO-LM管理者のアクションの追跡。たとえば、誤って構成されたテンプレートがリポジトリにプッシュされた場合、その特定のESSO-LMオブジェクトに対して更新が行われた日時と、その更新者を特定できます。
  • アプリケーション使用率の追跡。イベント・ログ・データを使用すると、ユーザー、時間および日付ごとにアプリケーション使用率を分析できます。このような情報は、大規模な配置でロード・バランシングを設定するときなど、システム負荷の評価に役立ちます。

技術的な前提条件

必須のイベント・データは、Active Directoryリポジトリをホストしているマシンに記録されます。このデータに基づいてレポートを生成するには、次の操作を実行する必要があります。

  1. 次のレジストリ値を設定して、Active Directoryインスタンスに必要な詳細度のログ・レベルを有効にします。
    • パス: HKLM\SYSTEM\CurrentControlSet\Services\<AD_instance>\Diagnostics
    • キー: 8 Directory Access (DWORD)
    • 値: 0x00000005（16進数）
  2. Win32_NTLogEventハンドラを問い合せ、イベントタイプSSO EventMgrで問合せをフィルタ処理します。これは、Windowsイベント・ログにデータを記録するときにESSO-LMで使用されるイベント・タイプです。


エージェントの配置

ESSO-LMの配置

この項では、ネットワーク環境でESSO-LMをパッケージング、配置および管理するためのオプションについて説明します。

  • Microsoft Windows Installer（MSI）パッケージ
  • 配置オプション
  • 管理
  • ユーザー資格証明および設定の格納
  • ファイルベースのバックアップ/リストア


Microsoft Windows Installer（MSI）パッケージ

ESSO-LMは、MSIパッケージ（Microsoftやその他のベンダーのインストーラで使用される標準形式）として出荷されます。他の多数のインストーラは、MSIファイルを読み取ることができます。ESSO-LM設定MSIの内容の詳細は、「MSIパッケージの内容」を参照してください。

Microsoft Windows Installerは、Microsoft Windows 2000/XPコンピュータにサービス（Windowsインストーラ）として存在します（Microsoftナレッジ・ベース文書#q255905を参照）。次のような特殊な要件を満たすように、MSIパッケージをカスタマイズできます。

  • カスタム・アプリケーションおよびESSO-LM Agent構成を指定する。
  • エンド・ユーザーがエージェントをインストールする前に、一部のオプションまたはコンポーネント（別の認証方式など）を非アクティブ化する。
  • 複雑な環境（バイオメトリック・セキュリティ・デバイスまたは一般的でないネットワーク・トポロジを使用している環境など）に対応するためにオプションまたはコンポーネントを追加する。

これらの要件を満たすために、次のオプションがあります。

  • コマンドライン・インストールの使用。
  • インストーラ・パッケージのカスタマイズ。
  • インストーラでのコンソールで作成されたログオンおよびグローバル・エージェント設定の追加。
  • サード・パーティの配置ツールを使用した配置。


配置オプション

この項では、デフォルトのMSIパッケージの使用について次の観点から説明します。

  • 出荷時のMSIパッケージでのインストールの実行
  • コマンドラインからのMSIパッケージの起動
  • リモート・インストール
  • MSIパッケージの編集
  • コンソールで作成されたログオンおよび設定のMSIパッケージへの追加
  • 代替ツールおよびメソッド

出荷時のMSIパッケージでのインストールの実行

出荷時のMSIパッケージを使用してインストールを実行するには、ESSO-LMのCD-ROMを挿入し、そのCD-ROMまたはネットワーク共有からsetupプログラムを実行してプロンプトに従います。環境はそれぞれ異なり、環境ごとに様々な要件があるため、カスタム・インストールを実行して、目的のコンポーネントを選択することをお薦めします。

コマンドラインからのインストール

MSIパッケージはコマンドラインからインストールできます。インストールを行うには、適切なパラメータを指定してセットアップ・プログラムを実行します。コマンドラインの構成要素は、実行可能ファイル名、InstallShieldパラメータ（たとえば、サイレント・インストールの場合は「/s」）およびESSO-LM機能名です。

ProductName.exe（ProductNameはインストールするソフトウェア） [/s] /v"[/qn ] ADDLOCAL="FeatureName""

/s | InstallShieldはサイレントになります（オプション）。
/v"&hellip;" | InstallShieldは、次のパラメータをMSIパッケージに渡します。
/qn | MSIパッケージは、通知なしでインストールされます（オプション）。
RUNVGO | インストール後にエージェントを起動するかどうかを指定します（「YES」または「NO」）。
MDAC | MDACをインストールするかどうかを指定します（「YES」または「NO」）。
ADDLOCAL "FeatureNames" | FeatureNamesは、インストールするESSO-LM機能のカンマで区切られたリストです。指定可能なリストの値については、「MSIパッケージの内容」を参照してください。
引用符は重要です。引用符は、MSI機能の前後（/vの後と行の最後）およびMSI機能内の各値の前後（"NO"や"Core"など）に付ける必要があります。

例:

コア、Windows認証方式、Microsoft Internet Explorerまたはホストのサポートなし、およびMicrosoft Active Directoryシンクロナイザをインストール（視覚的なサインの表示なし）してから、次のようにエージェントを起動します。

ProductName.exe /s /v"/qn RUNVGO="YES"
ADDLOCAL="Core,Authenticators,SLA,LogonMgr,SetupMgr,SyncMgr,AD_Sync,English_Pack""

MSIパッケージのリモート・インストール

コンピュータにESSO-LMをリモートでインストールするために、システムが次の条件を満たしていることを確認します。

  • Windowsインストーラが、リモート・コンピュータに存在する必要があります。
  • MSIパッケージから、リモート・コンピュータにアクセスできる必要があります。
  • リモート・インストールを実行するユーザーは、リモート・コンピュータへの管理者アクセス権を持っている必要があります。

MSIパッケージの編集

組織によっては、Oracle提供のオプションのコンポーネントを指定しない状態、または追加コンポーネント（代替認証方式など）を指定した状態で、MSIパッケージを配布します。

MSIパッケージをカスタマイズするには、MSIパッケージ・エディタを使用します。一般的なMSIパッケージ・エディタには、次のようなものがあります。

  • InstallShield AdminStudioおよびInstallShield Update Service
  • Wise Package Studio
  • Microsoft Orca

コンソールで作成されたアプリケーション・ログオンおよびグローバル・エージェント設定の追加

コンソールを使用すると、変更済のESSO-LMインストール・パッケージを作成することもできます。この機能を使用して作成した変更済のMSIパッケージには、次の項目を含めることができます。

  • entlist.iniファイルまたは現在のコンソール構成から選択されたアプリケーション・ログオン
  • 管理優先設定（.ini）ファイルまたは現在のコンソール構成からのエージェント設定

これを実行するには、「Tools」メニューの「Generate MSI」コマンドを使用します。

その他の配置ツールの使用

ESSO-LMは、次のような様々な配置メソッドおよびツールと連携して動作します。

  • 手動インストール（たとえば、CD-ROMまたはネットワーク共有から）
  • Microsoft Windows Installer（MSI）サービス（ローカルまたはリモート・インストール）
  • ネットワーク・リモート・インストール（ファイルのコピー、リモートからのレジストリ・エントリのデスクトップへのインストールなど）
  • Microsoft SMS
  • IBM Tivoli
  • Attachmate NetWizard
  • Intel LANDesk
  • Novadigm Radia/EDM
  • Novell ZENworks
  • HP OpenView
  • Seagate Desktop Management Suite
  • McAfee ZAC Suite
  • Veritas WinINSTALL


コンソールのメイン・メニュー・コマンド

次の表では、コンソールのメイン・メニューに用意されているコマンド、およびそれに対応するキーボードおよびマウスのショートカットについて説明します。

メニュー | コマンド | 説明 | ショートカット
File | New | 新しい構成を開始します | [Ctrl]+[N]
Open | Open | [Ctrl]+[O]
Merge

現在の構成（アプリケーション、パスワード生成ポリシー、資格証明共有グループ）を構成ファイルとマージします。

マージしたファイルに現在の構成の項目と同じ名前の項目が含まれている場合は、「Import/Merge Conflict」ダイアログ・ボックスが開きます。インポートする項目を選択し、「OK」をクリックします。
インポートしたファイルに現在の構成の既存セットと同じ名前のグローバル・エージェント設定セットが含まれている場合は、インポートしたセットに「<既存設定>のコピー」という名前が付与されます。
Save | 現在の構成をファイル（XML）に保存します。 | [Ctrl]+[S]
Save As | 現在の構成のコピーを別のファイルに保存します。
Import

構成を管理優先設定オブジェクト（INI）・ファイルまたはレジストリ・エントリ（REG）・ファイルからグローバル・エージェント設定の新しいセットとしてインポートします。

インポートしたファイルに現在の構成の項目と同じ名前の項目（アプリケーション、ポリシー、グループ）が含まれている場合は、「Import/Merge Conflict」ダイアログ・ボックスが表示されます。

「Applications」を右クリックし、「Import」を選択します。

または[Ctrl]+[I]

グローバル・エージェント設定をローカル・マシン・レジストリからコンソールにLiveという名前のセットとしてインポートするには、「Import from HKLM」を選択します。
Export 選択したアプリケーション、およびすべてのパスワード・ポリシーとグループをentlist.iniファイル（アプリケーション・ログオンの保存場所）にエクスポートします。

「Applications」を右クリックして「Export」を選択するか、または[Ctrl]+[E]。

メニュー | コマンド | 説明 | ショートカット
Edit | Delete | 左側のペインで選択されている項目を削除します。削除を確定するには「Yes」、取り消すには「No」をクリックします。 | [Del]
メニュー | コマンド | 説明 | ショートカット
Insert | Application | 新しいアプリケーション構成を追加します。「Add Application」ダイアログ・ボックスが表示されます。 | 「Applications」を右クリックし、「New Windows App」、「New Web App」または「New Host App」を選択します。
Password Generation Policy

新しいパスワード生成ポリシーを追加します。「Add Password Policy」ダイアログ・ボックスが表示されます。

  • 「Policy Name」に値を入力し、「OK」をクリックします。
 「Password Generation Policy」を右クリックし、「New Policy」を選択します。
Passphrase Questions

新しいパスフレーズ・セットを追加します。「Add Passphrase Set」ダイアログ・ボックスが表示されます。

「Passphrase Set Name」に値を入力し、「OK」をクリックします。

 「Passphrase Questions」を右クリックして、「New Passphrase Set」を選択します。
Credential Sharing Group

新しい資格証明共有グループを追加します。「Add Sharing Group」ダイアログ・ボックスが表示されます。

  • 「Group Name」に値を入力し、「OK」をクリックします。
  • 「Policy Name」に値を入力し、「OK」をクリックします。
 「Credential Sharing Group」を右クリックし、「New Group」を選択します。
Global Agent Settings | 現在の構成をファイル（XML）に保存します。 | 「Global Agent Settings」を右クリックし、「New Settings」を選択します。
Sync Extension | 現在の構成のコピーを別のファイルに保存します。 | 「Synchronization」を右クリックし、「Manage Synchronizers」を選択します。
メニュー | コマンド | 説明
Repository | Extend Schema | 同期リポジトリに接続し、新しい同期スキーマを作成します（LDAPおよびデータベース同期サポート用）。「Connect to Repository」ダイアログ・ボックスが表示されます。
 | Use Short Names | 選択または選択解除して、「Repository」ウィンドウ・ツリー・ビューのユーザー資格証明コンテナの表示/非表示を切り替えます。
 | Show User Credential Containers | 選択または選択解除して、「Repository」ウィンドウ・ツリー・ビューのESSO-LMユーザー資格証明コンテナの表示/非表示を切り替えます。
メニュー | コマンド | 説明
Tools | Publish to Repository | 「Publish to Repository」ダイアログ・ボックスが開きます。ここでは、公開するオブジェクトを同時に複数選択できます。
 | Export Apps to Agent | ローカルにインストールしたエージェントの事前構成ログオンのリストに、現在のコンソール・セッションのアプリケーション・ログオンを追加します。このオプションによって、ローカルのentlist.iniファイル以外に、オプションでftulist.ini（はじめて使用する場合）ファイルも更新されます。
 | Write Global Agent Settings to HKLM | グローバル・エージェント設定をローカル・マシン・レジストリにエクスポートします。確認メッセージが表示されます。
 | Generate Customized MSI | エージェント構成をWindows Installerパッケージとして配布するための.msiファイルを作成します。「Generate MSI」ダイアログ・ボックスが表示されます。
 | Manage Templates | アプリケーション・ログオンのテンプレートを作成、変更および削除します。「Manage Templates」ダイアログ・ボックスが表示されます。
 | Update Applications | アプリケーションの作成後に変更が加えられたテンプレートに基づいて、アプリケーションを更新します。「Update Applications」ダイアログ・ボックスが表示されます。
 | Modify Configuration | ローカルにインストールしたESSO-LM Agentの構成（INI）ファイルを参照または編集します。Applistを選択するか、MfrmList、FTUlistまたはEntListを開きます。それ以外のINIファイルの場合は名前を指定して開きます。


アプリケーション

アプリケーション構成情報を表示し、ログオン設定へのアクセスを提供します。

左側のペインで「Applications」をクリックすると、右側のペインに次のタブが表示されます。

  • 現時点で構成されているログオンを表示する「Application List」。

  • 「Bulk Add」（複数のログオン配置）コントロール。
  • 左側のペインで「Applications」を右クリックすると、次のオプションが含まれるショートカット・メニューが表示されます。
New Windows App | 新しいWindowsアプリケーションを構成します。「Add Application」ダイアログ・ボックスが表示されます。
New Web App | 新しいWebサイト・アプリケーションを構成します。「Add Application」ダイアログ・ボックスが表示されます。
New Host App | 新しいメインフレーム・アプリケーションを構成します。「Add Application」ダイアログ・ボックスが表示されます。
Import | .REGファイルまたは.INIファイルの保存済アプリケーション構成を開きます。
Export | 1つ以上のアプリケーション構成をINIファイルに保存します。


「Applications List」タブ

アプリケーションのリスト

ESSO-LMで使用するように構成されたログオンを持つアプリケーションのリストを表示します。

  • 新しいアプリケーションを追加するには、「Add」 をクリックします。
  • リスト内のアプリケーションのログオン構成を変更するには、アプリケーションをクリックし、「Edit」 をクリックします。
  • 1つ以上のログオン構成を削除するには、アプリケーションをクリックし（複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします）、「Delete」をクリックします。


「Add Application」ダイアログ・ボックス

「Add Application」ダイアログは、新しいアプリケーション・ログオンを構成する場合に使用します。最初からアプリケーション・ログオンを定義したり、一部またはすべてのログオン設定値が事前構成されている格納済のテンプレートを使用できます。

アプリケーションを追加する手順

  1. 新しいログオンの名前を入力します。
  2. 「Application Type」で、次のいずれかを選択します。
    • Windows
    • Web
    • Host/Mainframe
  3. 次のいずれかを実行します。
    • 「Application」ドロップダウン・リストからテンプレートを選択し、「Next」をクリックして、ログオンの完了に必要な追加情報を指定します。
    • 「Application」で「New [type] Application」を選択したままにして、「Finish」をクリックし、最初からログオンを作成します。
  4. このアプリケーションがRSA（SecurID/SoftID）トークンによる認証を必要とする場合は、「RSA securID」チェック・ボックスを選択します。
  5. 「Finish」をクリックします。

選択したアプリケーション・タイプのフォーム・ウィザードが起動します。詳細は、「「Windows Form」ウィザード」、「「Web Form」ウィザード」または「「Host/Mainframe Form」ウィザード」を参照してください。


テンプレートからのアプリケーションの追加

このウィザード・ページは、アプリケーション・ログオン・テンプレートに用意されていないアプリケーション・ログオン構成設定を指定する場合に使用します。ログオンの完成に必要な設定には、左側のペインに赤いXのマークが付いています。

  1. ダイアログ・ボックスの左側のペインで、赤いXのマークが付いたログオン設定項目をクリックします。右側のペインに、設定を指定するためのダイアログ・ボックスが表示されます。
  2. 必要な設定を入力または選択します。設定が完了すると、赤いXが緑のチェックマークに置き換わります。
  3. 「Finish」をクリックしてウィザードを閉じ、新しいアプリケーションを追加します。


新しいWindowsまたはJavaアプリケーション

新しいWindows/Javaアプリケーション

新しいWindowsログオンまたはJavaログオンの構成

  1. 左側のペインで「Applications」を右クリックし、ショートカット・メニューから「New Windows App」を選択します。「Windows」オプションが選択された状態で「Add Application」ダイアログ・ボックスが表示されます。
  2. 新しいログオンの名前を入力し、「OK」をクリックします。「Windows Form」ウィザード（新しいログオン・フォーム構成用）が表示されます。

詳細は、「Windowsアプリケーションの追加」を参照してください。


「Windows Form」ウィザード

「Windows Form」ウィザードは、次のタスクを実行する場合に使用します。

  • Windowsアプリケーション、JavaアプレットおよびJavaアプリケーションの 新しいログオンを構成します。
  • 既存のログオンに新しいフォームを追加します。
  • 自動パスワード変更のフォームを作成します。
  • 別のウィンドウで表示されるパスワード確認フィールドをサポートするためのフォームを作成します。
  • パスワード変更の成功と失敗の自動検出用フォームを作成します。

「Windows Form」ウィザードでは、アプリケーション自体を使用して、そのフォーム、個々のフィールドおよび送信（OK）ボタンを識別できます。

この手順を開始する前に、アプリケーションの構成に関する「一般的なガイドライン」を参照してください。 また、Windowsアプリケーション・ログオンの構成に固有の情報については、「Windowsアプリケーションの追加」を参照してください。

フォームを構成するには、次のように実行します。

  1. ターゲット・アプリケーションを起動し、ターゲット・フォームにナビゲートします。コンソールとターゲット・アプリケーションのウィンドウを同時に参照できるように配置します。
  2. フォーム・ウィザードで、構成するフォームのタイプを選択します。使用可能なオプションは、次のとおりです。
    • Logon。ログオン・フォームを構成します。
    • Password Change。 パスワード変更フォームを構成します。
    • Password confirmation。 別ウィンドウに「Confirm password」フィールドを表示するアプリケーション用の新しいパスワード確認フォームを構成します。
    • Password change success。ターゲット・アプリケーションのパスワード変更成功メッセージに対応するフォームを構成します。このフォームは資格証明を取り込まないため、「Windows Form」ウィザードの「Credentials」ページはスキップされます。パスワード変更成功メッセージが検出されると、ESSO-LM は自動的に新しい資格証明を保存します。
    • Password Change failure。ターゲット・アプリケーションのパスワード変更失敗メッセージに対応するフォームを構成し、パスワード変更失敗メッセージが検出された場合は資格証明を再度取り込みます。このオプションを選択した場合は、「Windows Form」ウィザードの「Credentials」ページが表示されます。そこで必要なフィールドを構成します。
  3. 「Application Window」リストで、構成するウィンドウを選択します。外枠が点滅しているのが、選択したアプリケーション・ウィンドウです。
  4. 正しいウィンドウを選択していることを確認し、「Next」をクリックします。
  5. 「Credential Fields」ページ・リストで、「Detect Fields」ボタンをクリックします。ウィザードによって資格証明フィールドの検出および構成が試行され、次のようにマークが付けられます。
    • Username/ID
    • Password（ログオン・フォームのみ）
    • Old Password（パスワード変更フォームのみ）
    • New password（パスワード変更フォームのみ）
    • Confirm new password（パスワード変更およびパスワード確認フォームのみ）
    • 「Submit」ボタン
  6. ウィザードで正しいフィールドが選択されたことを確認します。必要に応じて、選択内容を変更できます。
    1. 構成するフィールド（ログオン・ウィンドウの「user ID」フィールドなど）を選択します。アプリケーションのウィンドウで外枠が点滅しているのが、現在の選択に対応したフィールドです。

    2. 正しいフィールドが選択されていることを確認してから、選択した項目を右クリックし、ショートカット・メニューからフィールド・タイプ（「UserID」など）を選択します。項目の左側に、対応するアイコンが表示されます。項目を選択解除するには、その項目を右クリックし、ショートカット・メニューから「None」を選択します。

      パスワード変更成功フォームは資格証明を取り込みません。したがって、フィールドを構成する必要はありません。この場合、「Credential Fields」ページが表示されないため、手順8に進みます。

      「Class」列および「Text」列でフィールドを確認できます。たとえば、テキスト・ボックスは「Class」に「Edit」と表示されます。また、パスワード・フィールドは、通常、「Text」の値が「*** HIDDEN ***」となります。
  7. ログオン・フォームの完成に必要なフィールドごとに、このプロセスを繰り返します。最大4つのフィールドをまとめて構成できます。
  8. 必要なフィールドおよびボタンを構成したことを確認し、「Next」をクリックします。サマリー・ページが開き、構成内容が一覧表示されます。
  9. 次のいずれかを実行します。
    • 「Back」をクリックして、前のページに戻り、必要な変更を行います。
    • 「Finish」をクリックして、ログオン構成を完了し、フォーム・ウィザードを閉じます。


「Application」ウィンドウ

「Application」ウィンドウ（「Windows Form」ウィザード）

フォーム・ウィザードのこのページは、アプリケーションのログオンまたはパスワード/PIN変更ウィンドウを選択する場合に使用します。

Windowsアプリケーションを構成する手順の詳細は、「「Windows Form」ウィザード」を参照してください。

コントロール

Window List | 現在のアプリケーションのウィンドウを表示します。列ヘッダーをクリックすると、リストがソートされます。
Show hidden window | 非表示のウィンドウを「Window List」に含める場合に選択します。
Refresh | リストを更新します。
Back | 前のウィザード・ページに戻ります。
Next | 次のウィザード・ページに進みます。


「Credential」フィールド

「Credential」フィールド （「Windows Form」ウィザード）

フォーム・ウィザードのこのページは、アプリケーションのログオンまたはパスワード変更ウィンドウのフィールドを選択する場合に使用します。

Windowsアプリケーションを構成する手順の詳細は、「「Windows Form」ウィザード」を参照してください。

Credential Fields

現在選択しているアプリケーション・ウィンドウのフィールドが表示されます。ヘッダー（「Class」、「ID」または「Text」）をクリックすると、リストがソートされます。リスト内のフィールドを右クリックすると、フィールド・タイプのショートカット・メニューおよび送信コントロールが表示されます。

  • UserID
  • Password
  • Third Field
  • Fourth Field
  • Confirm New Password
  • OK（送信コントロール）

Refresh

フィールド・リストを更新します。

Use "Send Keys" for this form, do not use Control IDs

エージェントが、コントロールIDによって個々のフィールドをアドレス指定するのではなく、キーストロークの組合せとしてこのフォームにログオン・データを転送することを示します。詳細は、「SendKeys」を参照してください。

Use ordinals instead of control IDs | エージェントが、ネイティブ・コントロールIDによって個々のフィールドをアドレス指定するのではなく、ESSO-LMによって割り当てられた番号付けされた一連のコントロールIDとして、このフォームにデータを転送することを示します。
Detect Fields | フィールド・リストをスキャンし、そのリストをフィールド・タイプと照合します。 通常、「Detect Fields」は、一般的なアプリケーションで正確に機能しますが、フィールド・タイプが適切であるかどうかは確認する必要があります。
Refresh | フィールド・リストを更新します。
Back | 前のウィザード・ページに戻ります。
Next | 次のウィザード・ページに進みます。


サマリー

ウィザードの結果を表示します。次のいずれかを実行します。

  • 「Finish」をクリックして、設定を保存し、ウィザードを閉じます。

    または

  • 「Back」をクリックして、前のページに戻り、設定を変更します。


RSA SecurID用「Windows Form」ウィザード

「Windows Form」ウィザード（RSA SecurIDアプリケーション用）

「Windows Form」ウィザードは、次のタスクを実行する場合に使用します。

  • RSA SecurID Windowsアプリケーション用の新しいログオンを構成します。
  • 既存のRSA SecurIDログオンに新しいフォームを追加します。
  • 自動PIN変更のフォームを作成します。
  • 別ウィンドウに表示されるPIN確認フィールドをサポートするためのフォームを作成します。
  • PIN変更の成功と失敗の自動検出用フォームを作成します。

「Windows Form」ウィザードでは、アプリケーション自体を使用して、そのフォーム、個々のフィールドおよび送信（OK）ボタンを識別できます。

この手順を開始する前に、アプリケーションの構成に関する「一般的なガイドライン」を参照してください。 また、Windowsアプリケーション・ログオンの構成に固有の情報については、「Windowsアプリケーションの追加」を参照してください。

フォームを構成するには、次のように実行します。

  1. ターゲット・アプリケーションを起動し、ターゲット・フォームにナビゲートします。コンソールとターゲット・アプリケーションのウィンドウを同時に参照できるように配置します。
  2. フォーム・ウィザードで、構成するフォームのタイプを選択します。使用可能なオプションは、次のとおりです。
    • SecurID Logon: SecurIDlogonフォームを構成します。
    • PIN Change: PIN変更フォームを構成します。
    • Confirm PIN: 別ウィンドウに「Confirm PIN」フィールドを表示するアプリケーション用の新しいPIN確認フォームを構成します。
    • PIN Change Success: ターゲット・アプリケーションのPIN変更成功メッセージに相当するフォームを構成します。このフォームは資格証明を取り込まないため、「Windows Form」ウィザードの「Credentials」ページはスキップされます。PIN 変更成功メッセージが検出されると、ESSO-LM は自動的に新しい資格証明を保存します。
  3. PIN Change Failure: ターゲット・アプリケーションのPIN変更失敗メッセージに相当するフォームで、PIN変更失敗メッセージが検出された場合は資格証明を再度取り込みます。このオプションを選択した場合は、「Windows Form」ウィザードの「Credentials」ページが表示されます。そこで必要なフィールドを構成します。
  4. 「Application Window」リストで、構成するウィンドウを選択します。外枠が点滅しているのが、選択したアプリケーション・ウィンドウです。
  5. 正しいウィンドウを選択していることを確認し、「Next」をクリックします。
  6. 「Credential fields」ページで、資格証明フィールドごとに次のように実行します。
    1. 構成するフィールド（ログオン・ウィンドウの「user ID」フィールドなど）を選択します。アプリケーションのウィンドウで外枠が点滅しているのが、現在の選択に対応したフィールドです。

    2. 正しいフィールドが選択されていることを確認してから、選択した項目を右クリックし、ショートカット・メニューからログオン・フィールド・タイプ（「UserID」など）を選択します。項目の左側に、対応するアイコンが表示されます。項目を選択解除するには、その項目を右クリックし、ショートカット・メニューから「None」を選択します。

      新規PIN 承認フォームは資格証明を取り込みません。したがって、フィールドを構成する必要はありません。この場合、「Credential Fields」ページが表示されないため、手順7に進みます。

      「Class」列および「Text」列でフィールドを確認できます。たとえば、テキスト・ボックスは「Class」に「Edit」と表示されます。また、PINフィールドは、通常、「Text」の値が「*** HIDDEN ***」となります。

  7. ログオン・フォームの完成に必要なフィールドごとに、このプロセスを繰り返します。最大4つのフィールドをまとめて構成できます。
  8. 必要なフィールドおよびボタンを構成したことを確認し、「Next」をクリックします。サマリー・ページが開き、構成内容が一覧表示されます。
  9. 次のいずれかを実行します。
    • 「Back」をクリックして、前のページに戻り、必要な変更を行います。
    • 「Finish」をクリックして、ログオン構成を完了し、フォーム・ウィザードを閉じます。


「General」タブ

「General」タブ （Windowsログオン・フォームの構成用）

「General」（Windows）タブは、Windowsアプリケーション・ログオン構成に関するプログラム情報およびウィンドウ情報を変更する場合に使用します。

  • 「AppPathKeys」および「Window Titles」リスト内のエントリを追加、編集または削除して、手動でログオンを構成できます。
  • また、「Windows Form」ウィザードを使用して、ポイントおよびクリックによってウィンドウ、タイトルおよびフィールドを定義できます。

コントロール

Name | アプリケーション・ログオン・フォームの名前。
AppPathKeys | 実行中のプロセスと照合するために、このログオンに関連付けられているアプリケーションを識別するWindowsレジストリ・キー。（通常は、Eudora.exeなど、アプリケーション実行可能ファイルの名前）
Window Titles | ログオン・リクエストを特定するためにログオン・ウィンドウ・タイトルと照合されるテキスト。 「Choose」をクリックして、現在実行中のアプリケーション・ウィンドウからタイトルを選択します。
Disabled | このWindowsテンプレートを無効にする場合に選択します。このコントロールをソート順序機能とともに使用して、特定のWebポップアップを無効にできます。 この機能は、正規表現またはワイルド・カードを使用して定義された多数のウィンドウ・タイトルがアプリケーションに含まれるにもかかわらず、それらのウィンドウ・タイトルの中で、応答されるものが少数である場合に役に立ちます。管理者は、応答する多数のテンプレートを作成するかわりに、（正規表現またはワイルドカードを使用して）照合するウィンドウ・タイトルを定義した後で、一致しないウィンドウ・タイトル用に無効なテンプレートを作成して、それらのウィンドウ・タイトルを除外できます。
Wizard | 「Windows Form」ウィザード を起動して、視覚的にアプリケーションを構成します。

「Windows Form」ウィザードを使用してアプリケーションを構成する手順

  • 「Wizard」をクリックします。

アプリケーションを手動で構成する手順

  1. アプリケーションの名前を入力します。
  2. 「AppPathkey」グループで、「Add」をクリックします。
  3. 「Add AppPath Key」ダイアログ・ボックスで、有効なアプリケーション・キー（通常は、Eudora.exeなど、アプリケーション実行可能ファイルの名前）を入力します。「OK」をクリックします。
  4. 「Window Titles」グループで、「Add」をクリックします。ウィンドウ・タイトルを入力するか、または「Choose」をクリックして「Select Window」ダイアログ・ボックスを開き、現在実行中のアプリケーション・ウィンドウからタイトルを選択します。
  5. 「OK」をクリックします。


ウィンドウ・タイトルの選択

「Select Window」ダイアログは、アプリケーションのログオンまたはパスワード変更ウィンドウのタイトルを選択する場合に使用します。

  • ログオンまたはパスワード変更ウィンドウを選択し、 「OK」をクリックします。

コントロール

Window List | 現在のアプリケーションのウィンドウを表示します。列ヘッダーをクリックすると、リストがソートされます。
Show hidden window | 非表示のウィンドウを「Window List」に含める場合に選択します。


「Fields」タブ

「Fields」タブ（Windowsログオン・フォームの構成用）

「Fields」（Windows）タブは、エージェントがログオン・フォームのフィールドをどのように操作するかを定義する場合に使用します。現在選択しているアプリケーション・フォームに対して、次のいずれかを識別できます。

  • 最大4つのログオン・フィールド（ユーザーIDやパスワードなど）。コントロールIDを使用します。
  • ログオン・フォームに値を代入して送信するキーストロークの組合せ（オプションで時間も送信可能）。SendKeysを使用します。

コントロール

Transfer method
(choose one) 		Control ID : 標準のWindowsコントロールIDを使用して、資格証明を識別し、フィールドに転送します。フィールドを追加し、そのコントロールIDを入力するには「Add」をクリックします。既存のフィールド設定を変更するには「Edit」をクリックします。

SendKeys : キーストロークの組合せをフォームに転送して、フィールドを構成します。「Edit」をクリックして、キーストロークの組合せを入力または変更します。

SendKeys using Journal Hook : ジャーナル・フックを使用してキーストロークの組合せをフォームに転送して、フィールドを構成します。「Edit」をクリックして、キーストロークの組合せを入力または変更します。
Fields

このログオン・フォーム用に構成された転送方法があるフィールド。 次の処理を実行できます。

  • フィールドを選択し、「Edit」をクリックして「Control ID」または「SendKeys」設定を変更します。
  • 「Add」をクリックしてフィールドを追加します（「Control ID」のみ）


「Fields」タブ

ControlID

「Control ID」ダイアログ・ボックスは、ESSO-LMの応答を構成するために、ログオン・フォームのフィールドおよび送信ボタンを識別する場合に使用します。

コントロール
コントロール
Field

コントロールによって表される資格証明データを選択するか、またはそのコントロールを送信（OK）ボタンであると指定します。

  • UserID
  • Password
  • Third Field
  • Fourth Field
  • OK（送信コントロール）
Control ID | 選択したフィールドまたはボタンのコントロールIDを入力します。
Skip field if control is disabled | このオプションを選択すると、選択したフィールドがユーザー・エントリを受け入れないように設定されている場合に、エージェントがデータを入力できなくなります。


SendKeys（Windowsアプリケーション・ログオン用）

「SendKeys」ダイアログ・ボックスは、ESSO-LMがログオン・フォームに転送するキーストロークの組合せを指定する場合に使用します。

次のWindowsアプリケーションには「SendKeys」オプションを使用します。

  • Windowsメッセージ・キューから、または通常エージェントによって資格認証の送信に使用されるその他の技術を使用して資格証明を受信できない。
  • コントロールIDを持つ標準のWindowsコントロールを使用しない。
  • コントロールを動的に生成するか、またはWindowsコントロールを使用しない （Flashアプリケーションなど）。

「SendKeys」ダイアログ・ボックスの右側のペインの「New Actions」リスト・ボックスには、アクションごとのキーストローク・オプションが用意されています。SendKeysを構成するアクションを選択し、アクションごとに必要なオプションを選択または入力します。「Insert」ボタンをクリックして、キーストロークの組合せにキーまたはアクションを追加します。

東アジア言語のアプリケーションの場合: 東アジア言語（中国語、日本語、韓国語）アプリケーションのテンプレートにSendKeysを使用して情報を追加する場合、[Tab]キーを押して次のフィールドに進む前に、[Enter]キーを押す必要があります。[Enter]キーを押すことは、フィールドへの入力が完了したことをインプット・メソッド・エディターに知らせ、IMEによる資格証明フィールドの識別を可能にします。

東アジア言語用のジャーナル・フックSendKeysは、ESSO-LMと互換性がありません。

左側のペインの「Current Actions」リストに、選択内容が表示されます。

  • キーストロークの組合せの順序を変更するには、項目を選択し、上矢印または下矢印をクリックしてその項目を移動します。
  • 項目を削除するには、その項目を選択し、「Delete」をクリックします。
  • 項目を編集するには、その項目を選択し、「Edit」をクリックします。「Edit Action」ダイアログが開きます。必要に応じてフィールドを編集し、「OK」をクリックします。

コントロール

新しいアクション コントロール Description
Fields

Field Type

キーストロークの組合せに追加する資格証明項目をリストから選択します。

  • UserID
  • Password
  • Third Field
  • Fourth Field
  • Old Password
  • New Password
  • Confirm New Password

Character to insert after field

フィールドへの入力後に自動的に挿入するキーストロークを選択します。

  • None（キーストロークなし）
  • Enter（フォームを送信する場合）
  • Tab（カーソルを進める場合）

後述の「Special Keys」を参照してください。

Inject directly into control

コントロールに直接資格証明を挿入します。「...」ボタンをクリックして、「Choose Control ID」 ダイアログ・ボックスを開きます。

SendKeysを使用する場合、アプリケーションはWindowsアプリケーションとみなされます。「Choose Control ID」ダイアログ・ボックスに表示されるコントロールは、ESSO-LMが検索できるあらゆるWindowsコントロールを示します。

Insert

キーストロークの組合せに現在の選択内容を追加します。

Click

Click at a coordinate

指定されたX, Y座標でマウス・クリックをシミュレートします。

X: マウス・クリックのX座標を選択します。

Y: マウス・クリックのY座標を選択します。

Relative to the: マウス・クリックが基準とする場所を選択します。

  • Screen
  • Active Window

Mouse button: クリックするマウスボタンを選択します。

  • Left
  • Middle
  • Right

Click on a control

このオプションは、指定した座標でのクリックと似ていますが、ESSO-LMがコントロールの場所を把握し、コントロールの中心でクリックをシミュレートする点が異なります。「...」ボタンをクリックして、「Choose Control ID」 ダイアログ・ボックスを開きます。

SendKeysを使用する場合、アプリケーションはWindowsアプリケーションとみなされます。「Choose Control ID」ダイアログ・ボックスに表示されるコントロールは、ESSO-LMが検索できるあらゆるWindowsコントロールを示します。

Insert

キーストロークの組合せにクリックによる選択を追加します。

Run Task

Command line to run

実行するコマンドラインを入力します。この機能を使用すると、キーストロークの入力中にプログラムを実行できます。

  • ウィンドウ・ハンドルをコマンドラインに追加して、現在作業中のウィンドウ・ハンドルをスクリプトに通知できます。
    $(HWND)
  • 環境変数もコマンドラインに追加できます。
    $(USERDOMAIN)\$(USERNAME)

「...」ボタンをクリックして、「Choose Control ID」ダイアログ・ボックスを開きます。

仮想キー・コードをコマンドラインで使用することはできません（最初のバッククォート文字でコマンドラインが終了します）。

Expected return code

予想されるリターン・コードを入力します。この値が返されなかった場合は、Sendkeysスクリプトの残りの部分が破棄されます。

Time out (sec.)

タスクが完了するまで待機するミリ秒数を入力します。このタイムアウトに達しなかった場合は、Sendkeysスクリプトの残りの部分が破棄されます。最大タイムアウト時間は5秒です。

Insert

キーストロークの組合せにタスクを追加します。

Delay

Length of delay (in seconds)

キーストローク間の遅延を入力または選択します。

Insert

キーストロークの組合せに遅延を追加します。

Set Focus

Set focus to control

コントロールにフォーカスを設定します。「...」ボタンをクリックして、「Choose Control ID」 ダイアログ・ボックスを開きます。

SendKeysを使用する場合、アプリケーションはWindowsアプリケーションとみなされます。「Choose Control ID」ダイアログ・ボックスに表示されるコントロールは、ESSO-LMが検索できるあらゆるWindowsコントロールを示します。

Insert

キーストロークの組合せにフォーカスを追加します。

Text

Enter text to insert

キーストロークの組合せに追加するリテラル・テキストを入力します。

Insert

キーストロークの組合せにテキストを追加します。

Special Keys

Category/Keys

左側のリストからキーストローク・カテゴリ（移動キーなど）を選択し、 右側のリストから具体的なキー（[Page Down]など）を選択します。

Key Press

単一のキーストロークとしてキーを挿入します（デフォルト）。

Key Down/Up

キーを押して解放するという1組のアクションとしてキーを挿入します。このオプションを使用すると、これらのアクション間に他のキーストロークを挿入して、あるキーの入力時に1つ以上の別のキーを押したままにすることができます。たとえば、フォーカスを特定のテキスト・ボックスに移動するホット・キーの組合せを作成できます。

たとえば、キーストローク[Alt]+[P]を挿入するには、「Key Down/Up」オプションを選択し、カテゴリとして「Modifier」、キーとして「Alt」をそれぞれ選択し、「Insert」をクリックします。これにより、[Down:Alt]と[Up:Alt]の2つのアクションが挿入されます。

「Text」タブを選択し、テキスト・ボックスにPと入力します。 左側のペインで、「[Up:Alt]」を選択し、「Insert」をクリックします。Pが2つの[Alt]キー・アクションの間に挿入され、[Alt]+[P]が生成されます。

Insert

キーストロークの組合せにキーストロークを追加します。


「Matching」ダイアログ

「Matching」ダイアログ・ボックス

このダイアログ・ボックスは、同じ資格証明データを使用する類似したターゲット・フォームをエージェントが区別するために一致基準を作成する場合に使用します。これにより、エージェントは、1組のユーザー資格証明をこのような複数のフォームに適切に適用できます。このダイアログ・ボックスを表示するには、「Matching」タブ （Windowsログオン・フォームの構成用）の 「Add」をクリックします。

一致基準を作成する最も簡単で効率的な方法は、「Control Match」ウィザードを使用することです。ウィザードを使用すると、ターゲット・フォーム自体から要素を選択して、一致基準を指定できます。また、手動で一致基準を作成および変更することもできます。

ウィザードを使用した一致基準の作成

  • 「Wizard」をクリックし、画面の指示に従います。

手動での一致基準の作成または変更

  1. 「Match name」に一致名を入力し、ターゲット・フォームのタイプを選択します。
  2. ターゲット・フォームに表示する「Window Titles」を追加または編集するか、あるいは「Use Titles from Main」を選択します。
  3. 「Control Matching」の項目を追加または編集します。これらの項目は、フォーム・オブジェクトのプロパティ（テキスト・キャプションやコントロール・クラスなど）に基づく基準となります。また、これらの項目でターゲット・フォームを一意に識別できます。
  4. ターゲット・フォームの資格証明フィールドの「Control IDs」を追加または編集します。
  5. 「OK」をクリックします。
コントロール
Match Name | 一致名を入力または編集します。
Type

照合するフォームのタイプを選択します。

  • Logon
  • Change Password
  • Confirm (Password)
  • Ignore
Windows Titles | このログオンの「General」タブでウィンドウ・タイトルをコピーするには「Use Titles from Main」をクリックし、タイトルを手動で入力するには「Add」をクリックします。
Control Matching | 「Control Matching」ダイアログ・ボックスを表示するには、「Add」をクリックします（または照合する項目を選択し、「Edit」をクリックします）。
Control ID | 「Control ID」ダイアログ・ボックスを表示するには、「Add」をクリックします（またはコントロールID項目を選択し、「Edit」をクリックします）。
Wizard | 「Control Match」ウィザードを起動します。


ウィンドウ・タイトルの追加/編集

このダイアログ・ボックスは、エージェントがウィンドウ・タイトルで特定のアプリケーション・ウィンドウ（ログオン・エントリやパスワード変更など）を検出するために使用するテキスト文字列を追加または変更する場合に使用します。

照合するウィンドウ・タイトルを指定するには、次の手順を実行します。

  1. 次のいずれかを選択します（後述の「表現の照合」を参照）。
    • Exact match
    • Use wildcards（これは、ESSO-KMには適用されません。）
    • Use regular expression（これは、ESSO-KMには適用されません。）
  2. 「Window Title」または照合する表現を入力（または編集）します。
  3. 「OK」をクリックします。

表現の照合

URLのテキストが変化するアプリケーションの場合は、部分文字列や正規表現を使用して、その可変テキストの照合方法を指定できます。

ワイルド・カード
  • ? （疑問符）は、任意の1文字と一致します。
  • * （アスタリスク）は、0個以上の任意の文字と一致します。
これは、ESSO-KMには適用されません。
正規表現

正規表現のセットを使用して、エージェントが一致とみなす文字列パターンを指定できます。

これは、ESSO-KMには適用されません。

環境変数の照合

URLに（ワークステーションのオペレーティング・システムのDOMAINUSER環境変数から取得するなどして）ユーザーの名前を使用しているアプリケーションの場合は、一致基準として「Exact」を選択し、一致文字列に次の置換トークンのいずれかを含めます。

%DOMAINUSER% | この環境変数から導出されるものと同じユーザー名
%UC%%DOMAINUSER% | すべて大文字に変換されたユーザー名
%LC%%DOMAINUSER% | すべて小文字に変換されたユーザー名
例

この「Window Title」エントリは、ユーザー名が含まれているパスワード変更ウィンドウのタイトルと一致します。

パスワードの期限切れ - %UC%%DOMAINUSER%


コントロールの照合の追加/編集

コントロールの照合

「Control Matching」ダイアログ・ボックスは、ターゲット・フォームのコントロールのプロパティ（テキスト・キャプションやコントロール・スタイルなど）に基づく一致基準を指定する場合に使用します。

コントロール
Control ID | コントロールの数値識別子を入力します。
Match Condition | コントロールのプロパティを1つ選択し、関係（「Equals」、「Not Equal」、「Equals regular expression」または「Not equals regular expression」）を選択します。次に、一致させる（または一致させない）条件を入力または選択します。各プロパティの有効な条件は、次のとおりです。
 | Class | 編集または静的コントロール。
 | Style | コントロールに適用される集約されたスタイルの10進数識別子。
 | Text | リテラル文字列。

ダイアログ・ボックスを保存して終了するには「OK」をクリックし、変更内容を保存しないで終了するには「Cancel」をクリックします。


コントロールIDの追加/編集

「Control ID」ダイアログ・ボックス（「Windows Fields」タブ）

「Control ID」ダイアログ・ボックスは、エージェントの応答を構成するために、ログオン・フォームのフィールドおよび送信ボタンを識別する場合に使用します。

コントロール

Field

コントロールによって表される資格証明データを選択するか、またはそのコントロールを送信（OK）ボタンであると指定します。

  • UserID
  • Password
  • Third Field
  • Fourth Field
  • OK（送信コントロール）
Control ID フィールドまたはボタンのコントロールIDを入力します。
Control Type

コントロール・タイプを選択します。

  • Edit（テキスト・ボックス）
  • Combo（ドロップダウン・リスト・ボックス）
  • List
ほとんどの場合、「Windows Form」ウィザードを使用して、フィールドおよびコントロールIDを識別できます。


「Control Match」ウィザード

「Control Match」ウィザードは、一致基準をターゲット・アプリケーションのウィンドウおよびコントロールから選択して定義する場合に使用します。エージェントは、一致基準を使用して現在選択しているログオンに類似したターゲット・フォーム（パスワード変更ダイアログなど）を識別します。エージェントは、元のログオンと同じ資格証明を使用して、一致したターゲット・フォームにデータを提供します。また、一致基準を使用すると、現在のログオンに類似しており、エージェントで無視する必要があるターゲット・フォームを指定することもできます。

一致基準を作成するウィザードの使用

  1. ターゲット・アプリケーションを起動し、ターゲット・フォームにナビゲートします。コンソールとターゲット・アプリケーションのウィンドウを同時に参照できるように配置します。
  2. フォームの「Match Type」を選択し、画面の指示またはヘルプ・トピックに従います。
    • Ignore
    • Logon
    • Password Change
    • Password Confirm
    • Password Change Success
    • Password Change Failure

詳細は、「Matching」タブを参照してください。

「Control Match」ウィザードを表示するには、次の手順を実行します。

  1. 「Matching」タブの「Add」を選択します（Windowsログオン・フォームを構成する場合）。「Matching」ダイアログ・ボックスが表示されます。
  2. 「Wizard」をクリックします。


無視するアプリケーション・ウィンドウ

このウィザード・ページは、エージェントで認識する必要があるアプリケーション・ウィンドウを選択する場合に使用します。

  1. エージェントで無視するアプリケーション・ウィンドウを「Window List」から 選択します。
  2. 「Next」をクリックして、「Match Fields」ページを表示します。

コントロール

Window List | 現在のアプリケーションのウィンドウを表示します。列ヘッダーをクリックすると、リストがソートされます。
Show hidden window | 非表示のウィンドウを「Window List」に含める場合に選択します。
Refresh | リストを更新します。
Back | 前のウィザード・ページに戻ります。
Next | 次のウィザード・ページに進みます。


無視する一致フィールド

このウィザード・ページは、一致フィールドのセットを選択する場合に使用します。このセットとは、エージェントが認識する必要があるアプリケーション・ウィンドウを一意に識別する、1つ以上のウィンドウ・オブジェクトのことです。 一致フィールドは、そのクラス（編集や静的などコントロールのタイプ）、スタイル（番号で識別されるプロパティの集約）またはテキストに基づいて識別できます。

  1. フィールド・リストで、フィールドを右クリックし、一致基準を選択します。
  2. 「Next」をクリックして、「Summary」ページを表示します。

コントロール

Match Fields

現在選択しているアプリケーション・ウィンドウのフィールドが表示されます。ヘッダー（「Class」、「ID」、「Text」または「Style」）をクリックすると、リストがソートされます。 リストのフィールドを右クリックして、一致基準のショートカット・メニューを表示します。

  • None（フィールドを選択解除します）
  • Class
  • Style
  • Text
Use ordinals instead of control IDs | エージェントが、ネイティブ・コントロールIDによって個々のフィールドをアドレス指定するのではなく、ESSO-LMによって割り当てられた番号付けされた一連のコントロールIDとして、このフォームにデータを転送することを示します。
Refresh | リストを更新します。
Back | 前のウィザード・ページに戻ります。
Next | 次のウィザード・ページに進みます。


ログオン・アプリケーション・ウィンドウ

このウィザード・ページは、エージェントで認識する必要があるアプリケーション・ウィンドウを選択する場合に使用します。

  1. エージェントでログオン・フォームとして認識するアプリケーション・ウィンドウを「Window List」から 選択します。
  2. 「Next」をクリックして、「Match Fields」ページを表示します。
Window List | 現在のアプリケーションのウィンドウを表示します。列ヘッダーをクリックすると、リストがソートされます。
Show hidden window | 非表示のウィンドウを「Window List」に含める場合に選択します。
Refresh | リストを更新します。
Back | 前のウィザード・ページに戻ります。
Next | 次のウィザード・ページに進みます。


ログオン一致フィールド

このウィザード・ページは、一致フィールドのセットを選択する場合に使用します。このセットとは、エージェントが認識する必要があるアプリケーション・ウィンドウを一意に識別する、1つ以上のウィンドウ・オブジェクトのことです。 一致フィールドは、そのクラス（編集や静的などコントロールのタイプ）、スタイル（番号で識別されるプロパティの集約）またはテキストに基づいて識別できます。

  1. フィールド・リストで、フィールドを右クリックし、一致基準を選択します。
  2. 「Next」をクリックして、「Credentials」ページを表示します。

コントロール

Match Fields

現在選択しているアプリケーション・ウィンドウのフィールドが表示されます。ヘッダー（「Class」、「ID」、「Text」または「Style」）をクリックすると、リストがソートされます。 リストのフィールドを右クリックして、フィールド・タイプのショートカット・メニューを表示します。

  • None（フィールドを選択解除します）
  • Class
  • Style
  • Text
Use ordinals instead of control IDs | エージェントが、ネイティブ・コントロールIDによって個々のフィールドをアドレス指定するのではなく、ESSO-LMによって割り当てられた番号付けされた一連のコントロールIDとして、このフォームにデータを転送することを示します。
Refresh | リストを更新します。
Back | 前のウィザード・ページに戻ります。
Next | 次のウィザード・ページに進みます。


ログオン資格証明

このウィザード・ページは、エージェントが資格証明データを提供する必要があるフィールドを識別する場合に使用します。

  1. フィールド・リストで、フィールドを右クリックし、資格証明を選択します。
  2. 「Next」をクリックして、「Summary」ページを表示します。

コントロール

Credential Fields

現在選択しているアプリケーション・ウィンドウのフィールドが表示されます。ヘッダー（「Class」、「ID」、「Text」または「Style」）をクリックすると、リストがソートされます。 リストのフィールドを右クリックして、フィールド・タイプのショートカット・メニューを表示します。

  • None（フィールドを選択解除します）
  • UserID
  • Password
  • Third Field
  • Fourth Field
Use ordinals instead of control IDs | エージェントが、ネイティブ・コントロールIDによって個々のフィールドをアドレス指定するのではなく、ESSO-LMによって割り当てられた番号付けされた一連のコントロールIDとして、このフォームにデータを転送することを示します。
Refresh | リストを更新します。
Back | 前のウィザード・ページに戻ります。
Next | 次のウィザード・ページに進みます。


パスワード変更のアプリケーション・ウィンドウ

このウィザード・ページは、エージェントで認識する必要があるアプリケーション・ウィンドウを選択する場合に使用します。

  1. エージェントでパスワード変更フォームとして認識するアプリケーション・ウィンドウを「Window List」から選択します。
  2. 「Next」をクリックして、「Match Fields」ページを表示します。
Window List | 現在のアプリケーションのウィンドウを表示します。列ヘッダーをクリックすると、リストがソートされます。
Show hidden window | 非表示のウィンドウを「Window List」に含める場合に選択します。
Refresh | リストを更新します。
Back | 前のウィザード・ページに戻ります。
Next | 次のウィザード・ページに進みます。


パスワード変更の一致フィールド

このウィザード・ページは、一致フィールドのセットを選択する場合に使用します。このセットとは、エージェントが認識する必要があるアプリケーション・ウィンドウを一意に識別する、1つ以上のウィンドウ・オブジェクトのことです。一致フィールドは、そのクラス（編集や静的などコントロールのタイプ）、スタイル（番号で識別されるプロパティの集約）またはテキストに基づいて識別できます。

  1. フィールド・リストで、フィールドを右クリックし、一致基準を選択します。
  2. 「Next」をクリックして、「Credentials」ページを表示します。

コントロール

Match Fields

現在選択しているアプリケーション・ウィンドウのフィールドが表示されます。ヘッダー（「Class」、「ID」、「Text」または「Style」）をクリックすると、リストがソートされます。 リストのフィールドを右クリックして、フィールド・タイプのショートカット・メニューを表示します。

  • None（フィールドを選択解除します）
  • Class
  • Style
  • Text
Use ordinals instead of control IDs | エージェントが、ネイティブ・コントロールIDによって個々のフィールドをアドレス指定するのではなく、ESSO-LMによって割り当てられた番号付けされた一連のコントロールIDとして、このフォームにデータを転送することを示します。
Refresh | リストを更新します。
Back | 前のウィザード・ページに戻ります。
Next | 次のウィザード・ページに進みます。


パスワード変更の資格証明

このウィザード・ページは、エージェントが資格証明データを提供する必要があるフィールドを識別する場合に使用します。

  1. フィールド・リストで、フィールドを右クリックし、資格証明を選択します。
  2. 「Next」をクリックして、「Summary」ページを表示します。

コントロール

Credential Fields

現在選択しているアプリケーション・ウィンドウのフィールドが表示されます。ヘッダー（「Class」、「ID」、「Text」または「Style」）をクリックすると、リストがソートされます。 リストのフィールドを右クリックして、フィールド・タイプのショートカット・メニューを表示します。

  • None（フィールドを選択解除します）
  • UserID
  • Old Password/PIN
  • New Password/PIN
  • Confirm PasswordPIN
Use ordinals instead of control IDs | エージェントが、ネイティブ・コントロールIDによって個々のフィールドをアドレス指定するのではなく、ESSO-LMによって割り当てられた番号付けされた一連のコントロールIDとして、このフォームにデータを転送することを示します。
Refresh | リストを更新します。
Back | 前のウィザード・ページに戻ります。
Next | 次のウィザード・ページに進みます。


パスワード確認のアプリケーション・ウィンドウ

このウィザード・ページは、エージェントで認識する必要があるアプリケーション・ウィンドウを選択する場合に使用します。

  1. エージェントでパスワード確認フォームとして認識する アプリケーション・ウィンドウを「Window List」から選択します。
  2. 「Next」をクリックして、「Match Fields」ページを表示します。

Window List | 現在のアプリケーションのウィンドウを表示します。列ヘッダーをクリックすると、リストがソートされます。
Show hidden window | 非表示のウィンドウを「Window List」に含める場合に選択します。

Refresh | リストを更新します。
Back | 前のウィザード・ページに戻ります。
Next | 次のウィザード・ページに進みます。


パスワード確認の一致フィールド

このウィザード・ページは、一致フィールドのセットを選択する場合に使用します。このセットとは、エージェントが認識する必要があるアプリケーション・ウィンドウを一意に識別する、1つ以上のウィンドウ・オブジェクトのことです。 一致フィールドは、そのクラス（編集や静的などコントロールのタイプ）、スタイル（番号で識別されるプロパティの集約）またはテキストに基づいて識別できます。

  1. フィールド・リストで、フィールドを右クリックし、一致基準を選択します。
  2. 「Next」をクリックして、「Credentials」ページを表示します。

コントロール

Match Fields

現在選択しているアプリケーション・ウィンドウのフィールドが表示されます。ヘッダー（「Class」、「ID」、「Text」または「Style」）をクリックすると、リストがソートされます。 リストのフィールドを右クリックして、フィールド・タイプのショートカット・メニューを表示します。

  • None（フィールドを選択解除します）
  • Class
  • Style
  • Text
Use ordinals instead of control IDs | エージェントが、ネイティブ・コントロールIDによって個々のフィールドをアドレス指定するのではなく、ESSO-LMによって割り当てられた番号付けされた一連のコントロールIDとして、このフォームにデータを転送することを示します。
Refresh | リストを更新します。
Back | 前のウィザード・ページに戻ります。
Next | 次のウィザード・ページに進みます。


パスワード確認の資格証明

このウィザード・ページは、エージェントが資格証明データを提供する必要があるフィールドを識別する場合に使用します。

  1. フィールド・リストで、フィールドを右クリックし、資格証明を選択します。
  2. 「Next」をクリックして、「Summary」ページを表示します。

コントロール

Credential Fields

現在選択しているアプリケーション・ウィンドウのフィールドが表示されます。ヘッダー（「Class」、「ID」、「Text」または「Style」）をクリックすると、リストがソートされます。 リストのフィールドを右クリックして、フィールド・タイプのショートカット・メニューを表示します。

  • None（フィールドを選択解除します）
  • UserID
  • Old Password/PIN
  • New Password/PIN
  • Confirm PasswordPIN
Use ordinals instead of control IDs | エージェントが、ネイティブ・コントロールIDによって個々のフィールドをアドレス指定するのではなく、ESSO-LMによって割り当てられた番号付けされた一連のコントロールIDとして、このフォームにデータを転送することを示します。
Refresh | リストを更新します。
Back | 前のウィザード・ページに戻ります。
Next | 次のウィザード・ページに進みます。


「Miscellaneous」タブ（Windowsログオン用）

「Miscellaneous」タブ（Windowsログオン・フォームの構成用）

「Miscellaneous」（Windows）タブは、現在選択されているアプリケーション・ログオン・フォームのプロパティを特殊な構成用に調整する場合に使用します。

コントロール

Allowable Class | このログオンを実行するために必要なログオンまたはパスワード変更ウィンドウ・クラスを識別する場合は、「Choose」をクリックします。 これは、ログオンまたはパスワード変更ウィンドウに非標準のクラス名が付与されているアプリケーションに役立ちます。 「Select Window」ダイアログが表示されます。
Regular Expression | 「Allowable Class」で正規表現を使用する場合に選択します。
Ignore this Window Class | ログオンの実行時に無視するログオンまたはパスワード変更ウィンドウを選択する場合は「Choose」をクリックします。 これは、非表示のログオンまたはパスワード変更ダイアログ・ボックスを使用するアプリケーション、またはダイアログの複製が存在するアプリケーションに役立ちます。「Select Window」ダイアログ・ボックスが表示されます。
Regular Expression | 「Ignore this Window Class」で正規表現を使用する場合に選択します。
Attach to window's Message Queue | ターゲット・ウィンドウを保持したまま資格証明を送信する場合に選択します。
Preset Focus | エージェントがデータをログオン・フィールドに配置する前に、ログオン・フィールドにフォーカスを設定する場合に選択します。
System Logon | （予約済）
Use WM_CHAR messages to fill controls | アプリケーションによっては、設定済のテキスト・コマンドではなくキーボードからパスワードを入力する必要があります。この設定を有効にすると、コントロール内にテキストを設定することによって、別の方法でキーボード入力をシミュレートできます。
Sort Order | 正規表現を含むウィンドウ・クラス・タイトルをESSO-LMがテンプレート内で確認する順序を指定します。ソート順序を設定することによって、正確性が低い一致を除くことなく、検索の効率が向上します。ソート順序をテンプレートに割り当てない場合、ESSO-LMは昇順（値の小さい方を最初に確認する）でテンプレートを確認します。デフォルトは1000です。


新しいWebアプリケーション

新しいWebアプリケーションのログオンの構成

  1. 左側のペインで「Applications」を右クリックし、ショートカット・メニューから「New Web App」を選択します。「Web」オプションが選択された状態で「Add Application」ダイアログ・ボックスが表示されます。
  2. 新しいログオンの名前を入力し、「OK」をクリックします。「Web Form」ウィザード（新しいログオン・フォームの構成用）が表示されます。

詳細は、「Webアプリケーションの追加」を参照してください。


「Web Form」ウィザード

「Web Form」ウィザードでは、Webアプリケーション自体を参照して、そのログオンまたはパスワード変更ウィンドウ、個々のフィールドおよび送信（OK）ボタンの識別子を取得できます。 「Web Form」ウィザードを表示するには、次の手順を実行します。

  1. 新しいWebアプリケーションを作成します。
  2. 「New Web Application」構成ダイアログで、「Wizard」をクリックします。「Web Form」ウィザードが表示されます。
解像度が800x600のワークステーションを使用している場合、「Web Form」ウィザードの下部にあるボタンは表示されません。また、この解像度では、ウィザードが開始するまでに時間がかかります。ワークステーションの解像度を高く設定することをお薦めします。

Webアプリケーションの構成

  1. 表示されるダイアログ・ボックスで、構成するアプリケーション・フォームのタイプを選択します。使用可能なオプションは、次のとおりです。
  2. Logon。ログオン・フォームを構成します。
  3. Password Change。パスワード変更フォームを構成します。
  4. Password change success。ターゲット・アプリケーションのパスワード変更成功メッセージに対応するフォームを構成します。このフォームは資格証明を取り込まないため、「Web Form」ウィザードの「Credentials」ページはスキップされます。パスワード変更成功メッセージが検出されると、ESSO-LM は自動的に新しい資格証明を保存します。
  5. Password Change failure。ターゲット・アプリケーションのパスワード変更失敗メッセージに対応するフォームを構成し、パスワード変更失敗メッセージが検出された場合は資格証明を再度取り込みます。このオプションを選択した場合は、「Web Form」ウィザードの「Credentials」ページが表示されます。そこで必要なフィールドを構成します。
既存のフォームを編集している場合、このダイアログ・ボックスは表示されません。
  6. 「Web Form」ウィザードで、WebサイトのWebアドレス（URL）を入力し、「Go」をクリックします。ウィザードの最上部のペインは、Webブラウザ・ウィンドウとして機能します。必要に応じて、ウィザードのウィンドウ・サイズを変更できます。
  7. 最上部のペインで、Webサイトのログオン・フォームにナビゲートします。Webページで1つ以上のフォームが検出された場合は、ウィザードの最下部のペインにフォームおよびその要素（フィールドおよびボタン）が一覧表示されます。
  8. 「Detect Fields」ボタンをクリックします。ウィザードによって資格証明フィールドの検出および構成が試行され、次のようにマークが付けられます。
    • Username/ID
    • Password
    • Old Password（パスワード変更フォームのみ）
    • New Password（パスワード変更フォームのみ）
    • 「Submit」ボタン
  9. ウィザードで正しいフィールドが選択されたことを確認します。必要に応じて、選択内容を変更できます。
    1. 既存のテンプレートを編集している場合、右下にある「Form Type」ドロップダウンを使用してフォーム・タイプを変更することもできます。その場合、テンプレートの再構成（フィールドの再割当てなど）が必要になることに注意してください。フォーム・タイプを選択すると、選択したフォーム・タイプに関連するフィールドのみが表示されます。
    2. 最下部のペインのリストで、フィールドを特定し、選択します。（「Element」および「Type」の説明で詳細を確認できます。）最上部のペインで外枠が点滅しているのが、選択したフィールドまたはボタンです。
    3. 正しいフィールドが選択されていることを確認してから、選択した項目を右クリックし、ショートカット・メニューから適切なメニュー項目（「UserID」など）を選択します。アイコンが、項目の左側に表示されます。項目を選択解除するには、その項目を右クリックし、ショートカット・メニューから「None」を選択します。
  10. ログオン・フォームの完成に必要なフィールドごとに、このプロセスを繰り返します。最大4つのフィールドをまとめて構成できます。
  11. ログオンに必要なフィールドごとに、前述の2つの手順を繰り返します。最大4つのフィールドをまとめて構成できます。
  12. 構成の完了後、「OK」をクリックしてその構成を保存し、「Web Form」ウィザードを閉じます。


RSA SecurID用「Web Form」ウィザード

「Web Form」ウィザード（RSA SecurIDアプリケーション用）

「Web Form」ウィザードは、次のタスクを実行する場合に使用します。

  • RSA SecurID Windowsアプリケーション用の新しいログオンを構成します。
  • 既存のRSA SecurIDログオンに新しいフォームを追加します。
  • 自動PIN変更のフォームを作成します。
  • PIN変更の成功と失敗の自動検出用フォームを作成します。

「Web Form」ウィザードでは、Webアプリケーション自体を参照して、そのフォームおよびウィンドウ、個々のフィールドおよび送信（OK）ボタンの識別子を取得できます。 「Web Form」ウィザードを表示するには、次の手順を実行します。

  1. 新しいWebアプリケーションを作成します。「Add Application」ダイアログで「RSA SecurID」チェック・ボックスを選択してください。
  2. 「New Web Application」構成ダイアログで、「Wizard」をクリックします。「Web Form」ウィザードが表示されます。
解像度が800x600のワークステーションを使用している場合、「Web Form」ウィザードの下部にあるボタンは表示されません。また、この解像度では、ウィザードが開始するまでに時間がかかります。ワークステーションの解像度を高く設定することをお薦めします。

Webアプリケーションの構成

  1. 表示されるダイアログ・ボックスで、構成するアプリケーション・フォームのタイプを選択します。使用可能なオプションは、次のとおりです。
  2. SecurID Logon 。SecurIDログオン・フォームを構成します。
  3. PIN Change。PIN変更フォームを構成します。
  4. PIN change success。ターゲット・アプリケーションのPIN変更成功メッセージに対応するフォームを構成します。このフォームは資格証明を取り込まないため、「Web Form」ウィザードの「Credentials」ページはスキップされます。PIN変更成功メッセージが検出されると、ESSO-LM は自動的に新しい資格証明を保存します。
  5. PIN change failure。ターゲット・アプリケーションのPIN変更失敗メッセージに対応するフォームを構成し、PIN変更失敗メッセージが検出された場合は資格証明を再度取り込みます。このオプションを選択した場合は、「Web Form」ウィザードの「Credentials」ページが表示されます。そこで必要なフィールドを構成します。
既存のフォームを編集している場合、このダイアログ・ボックスは表示されません。
  6. 「Web Form」ウィザードで、WebサイトのWebアドレス（URL）を入力し、「Go」をクリックします。ウィザードの最上部のペインは、Webブラウザ・ウィンドウとして機能します。必要に応じて、ウィザードのウィンドウ・サイズを変更できます。
  7. 最上部のペインで、Webサイトのログオン・フォームにナビゲートします。Webページで1つ以上のフォームが検出された場合は、ウィザードの最下部のペインにフォームおよびその要素（フィールドおよびボタン）が一覧表示されます。
  8. 「Detect Fields」ボタンをクリックします。ウィザードによって資格証明フィールドの検出および構成が試行され、次のようにマークが付けられます。
    • SecurID Username
    • Passcode
    • Tokencode
    • Old PIN（PIN変更およびPIN変更失敗フォームのみ）
    • New PIN（PIN変更およびPIN変更失敗フォームのみ）
    • 「Submit」ボタン
  9. ウィザードで正しいフィールドが選択されたことを確認します。必要に応じて、選択内容を変更できます。
    1. 既存のテンプレートを編集している場合、右下にある「Form Type」ドロップダウンを使用してフォーム・タイプを変更することもできます。その場合、テンプレートの再構成（フィールドの再割当てなど）が必要になることに注意してください。フォーム・タイプを選択すると、選択したフォーム・タイプに関連するフィールドのみが表示されます。
    2. 最下部のペインのリストで、フィールドを特定し、選択します。（「Element」および「Type」の説明で詳細を確認できます。）最上部のペインで外枠が点滅しているのが、選択したフィールドまたはボタンです。
    3. 正しいフィールドが選択されていることを確認してから、選択した項目を右クリックし、ショートカット・メニューから適切なメニュー項目（「SecurID Username」 など）を選択します。アイコンが、項目の左側に表示されます。項目を選択解除するには、その項目を右クリックし、ショートカット・メニューから「None」を選択します。
  10. ログオン・フォームの完成に必要なフィールドごとに、このプロセスを繰り返します。最大4つのフィールドをまとめて構成できます。
  11. ログオンに必要なフィールドごとに、前述の2つの手順を繰り返します。最大4つのフィールドをまとめて構成できます。
  12. 構成の完了後、「OK」をクリックしてその構成を保存し、「Web Form」ウィザードを閉じます。


「General」タブ

「General」タブ（Webログオン・フォームの構成用）

「General」（Web）ダイアログ・ボックスは、Webアプリケーション・ログオン構成に関するプログラム情報およびウィンドウ情報を変更する場合に使用します。

  • 「URL」リストおよび「Fields」リスト内のエントリを追加、編集または削除して、手動でログオンを構成できます。

または

  • 「Web Form」ウィザードを使用して、ポイントおよびクリックによってURL、フォームおよびフィールドを定義できます。

コントロール

Name | アプリケーションの名前を入力します。
URL | 構成するログオンまたはパスワード変更フォームの1つ以上のURL（Uniform Resource Locator。一般的にWebアドレスと呼ばれる）。「URL」ダイアログ・ボックスを表示するには、「Add」をクリックします（または一致項目を選択し、「Edit」をクリックします）。
Fields | 1つ以上の資格証明フィールド（送信ボタンを含む）およびその識別情報。「Web Fields」ダイアログ・ボックスを表示するには、「Add」をクリックします（または一致項目を選択し、「Edit」をクリックします）。
Auto Submit | 資格証明を指定した後、このアプリケーション・ログオンに対して、エージェントによって自動的に「OK」が選択されるようにする場合に選択します。
Dynamic Page | テンプレートのWebページが動的な内容を含むことを示すために、チェックします。
Disabled | エージェントでこのアプリケーション・ログオン構成を無視する場合に選択します。このアプリケーションのログオン構成を有効にするには、このチェック・ボックスの選択を解除します。
Wizard | フォーム・ウィザードを起動して、視覚的にアプリケーションを構成します。


「Matching」タブ（Webアプリケーションの構成用）

Web用の「Matching」タブは、同じWebアプリケーション（通常、マルチフォーム・ポータル・ページ）内でログオン・フォーム、パスワード変更フォームまたはパスワード確認フォーム（ここではターゲット・フォームと呼びます）を区別する場合に使用します。エージェントは、ここで指定した一致基準を使用して、類似したフォームを区別します。

このタブは、通常、検出一致基準を調整する場合に使用します。検出一致基準とは、あるページの特定に使用する一連のHTMLタグおよび値のことです。これにより、検出一致基準のサブセットを使用するオフセット一致を作成し、そのページで目的のログオン・フォームまたはパスワード変更フォームを特定できます。

このタブを表示する手順

  • 新しいWebアプリケーション・ログオンを作成します。

または

  1. 左側のペインで「Applications」をクリックし、Webアプリケーションを選択します。
  2. 右側のペインで、「General」タブをクリックします。
  3. リストからフォームを選択し、「Edit」をクリックします。
  4. 「Web」フォーム構成ダイアログ・ボックスの「General」タブで、「Matching」タブを選択します。

検出一致基準の作成または変更

  1. 「Detection Match」リストで、次のいずれかを実行します。
    • 新しい一致基準を作成するには、「Add」をクリックします。
    • 既存の一致を変更するには、一致を選択し、「Edit」をクリックします。
  2. 「Edit Match」 ダイアログ・ボックスで必要な情報を入力または選択し、「OK」をクリックしてこのダイアログ・ボックスに戻ります。
  3. 必要に応じて、一致基準の順序を調整します。
    1. 移動する一致を選択します。
    2. 上矢印または下矢印をクリックします。
  4. 「OK」をクリックします。

オフセット一致

オフセット一致は、ポータルWebページでのみ使用します。

このタイプの一致は複数のウィンドウを持つポータル・ページで使用され、ユーザーはこのウィンドウを再編成、追加および削除することができます。照合しているサイトがポータルでない場合は、このパネルのオフセット一致セクションを空白のままにしておきます。

通常の一致検出では、フォームは常に同じ順序で表示される必要があります。オフセット一致では、フォーム（ウィンドウのように見えます）を再編成でき、特定のウィンドウを他のすべてのウィンドウから分離できます。これはポータル・ページにのみ適用されます。これらのページは動的で、フィールド名ではなく序数値が照合に使用されるためです。

「Offset Start」フィールドを使用して、どの一致結果のフォームをフォーム・オフセットに使用するかをESSO-LMに伝えます。オフセット開始値は、オフセット一致の数である必要があります。たとえば、オフセット一致が3つある場合、オフセット開始値は3になります。

オフセット一致基準の作成または変更

  1. 「Offset Match」リストで、次のいずれかを実行します。
    • 定義した検出一致基準をコピーするには、「Copy from Detection」をクリックします。
    • 新しい一致基準を作成するには、「Add」をクリックします。
    • 既存の一致を変更するには、一致を選択し、「Edit」をクリックします。
  2. 「Edit Match」ダイアログ・ボックスで、必要な情報を入力または選択し、「OK」をクリックしてこのダイアログ・ボックスに戻ります。
  3. 必要に応じて、一致基準の順序を調整します。
    1. 移動する一致を選択します。
    2. 上矢印または下矢印をクリックします。
    3. 「Offset Start」を選択します。
  4. 「OK」をクリックします。


一致の編集（Webフォーム用）

このダイアログ・ボックスは、選択したWebフォームの一致基準を作成または変更する場合に使用します。

Tag | HTMLタグ・タイプを入力します。たとえば、表セルの場合は<TD>と入力します。
Match Tag Instance | 「Tag」の特定のインスタンスと照合する場合に選択します。この場合、そのインスタンスの番号を選択します。たとえば、ページの3番目の表セルと照合する場合は3を選択します。
Criteria

基準タイプを1つ選択します。

  • Text。タグ要素のプレーン・テキスト（InnerText）の内容（Enter your passwordなど）
  • HTML。タグ要素のリッチ・テキスト（InnerHTML）の内容（「<b>Enter your password</b>」など）。
  • Property: タグ要素のHTML属性（id =passwordなど）。
Value | 照合する「Criteria」のテキストを入力します。
Match Whole Value | 「Value」の厳密な照合を実施する場合に選択します（つまり、タグ要素に余分なテキストを追加すると、照合は失敗します）。
Operation

一致と一致の関係を選択します。

  • And。この一致は、フォームの識別に必要な複数の一致のうちの1つです。
  • Or。この一致のみでフォームを識別します。
  • Not。この一致は、フォームを除外します。

AND、ORまたはNOT演算子を使用して、エージェントがWeb一致の組合せに応答する条件を指定します。

ANDで一致する値を一致基準に割り当てた場合、ページに応答するための条件がエージェントに存在する必要があります。そのため、いくつかのフィールドがAND演算子に割り当てられている場合は、それらすべての基準が存在する必要があります。

ORで一致する値を複数の一致基準に割り当てた場合、いずれかの基準が存在する場合にエージェントが応答します。

NOT演算子は、照合を実行するときの除外を指定する場合に使用します。エージェントは、NOT基準の条件が存在しないかぎり、AND演算子およびOR演算子を割り当てたすべての基準に応答します。エージェントは、NOT演算子で特定されたインスタンスを除外します。


URLの追加/編集

このプロンプトは、構成するログオン/パスワード変更フォームのURL（Uniform Resource Locator。一般的にWebアドレスと呼ばれる）を指定する場合に使用します。

マッチング用のURLを指定する方法

  1. 次のいずれかを選択します（後述の「表現の照合」を参照）。
  2. Exact
  3. Wildcard（これは、ESSO-KMには適用されません。）
    • Regular Expression（これは、ESSO-KMには適用されません。）
  4. 「URL」または照合の表現を入力（または編集）します。
  5. 「OK」をクリックします。

表現の照合

URLのテキストが変化するアプリケーションの場合は、部分文字列や正規表現を使用して、その可変テキストの照合方法を指定できます。

ワイルド・カード
  • ? （疑問符）は、任意の1文字と一致します。
  • * （アスタリスク）は、0個以上の任意の文字と一致します。
これは、ESSO-KMには適用されません。
正規表現

正規表現のセットを使用して、エージェントが一致とみなす文字列パターンを指定できます。

これは、ESSO-KMには適用されません。

環境変数の照合

URLに（ワークステーションのオペレーティング・システムのDOMAINUSER環境変数から取得するなどして）ユーザーの名前を使用しているアプリケーションの場合は、一致基準として「Exact」を選択し、一致文字列に次の置換トークンのいずれかを含めます。

%DOMAINUSER% | この環境変数から導出されるものと同じユーザー名
%UC%%DOMAINUSER% | すべて大文字に変換されたユーザー名
%LC%%DOMAINUSER% | すべて小文字に変換されたユーザー名
例

このURLエントリは、ユーザー名が含まれているパスワード変更ウィンドウのタイトルと一致します。

パスワードの期限切れ - %UC%%DOMAINUSER%


Webフィールドの追加/編集

Webフィールド

このダイアログ・ボックスは、Webフォームに資格証明フィールドまたは「Submit」ボタンを指定する場合に使用します。

Function

資格証明タイプを選択します。

  • UserID
  • Password
  • Third Field
  • Fourth Field
  • New Password
  • Confirm New Password
  • Submit
Frame | フィールドが表示されるブラウザ・フレームのターゲット名を入力します（ターゲット・ページの親フレームセットの<frame>要素にNAME属性で指定されます）。
Form | フィールドが表示されるフォームの名前を入力します（ターゲット・ページの<form>要素にNAME属性で指定されます）。
Field identification | 「...」ボタンを選択して「Field Identification」ダイアログ・ボックスを表示します。ここで照合するフィールドのタイプを選択できます。
Field type | フィールド・タイプ（フィールドの<input>要素のtype属性に対応）、または「Submit」ボタンとして使用されるハイパーリンク・アンカー・タグ（<A HREF=...>）を選択します。
資格証明タイプ | <INPUT TYPE=...> オプション
UserID | Text
Password | Password
Third Field | Select-One
Fourth Field | Select-Multiple
New Password
Confirm New Password
Submit | Submit
Image
Button
アンカー（<A HREF...>タグ


「Field Identification」ダイアログ・ボックス

この画面を使用して、エージェントに認識させるフィールドのタイプを指定します。次の中から適切なラジオ・ボタンを選択します。

  • Use field name: フィールドに一貫性があり、「ユーザー」や「電子メール」という名前を付けられたラベル持つWebサイトを選択します。
  • User ordinal number: 変化するフィールド番号を動的なWebページの序数で置き換える場合に選択します。詳細は、「動的IDおよび序数コントロールID」を参照してください。
  • Use matching: ユーザーによってフィールド索引が異なるWebサイトを選択します。次の表で説明する選択肢から選択します。
Tag | HTMLタグ・タイプを入力します。たとえば、表セルの場合は<TD>と入力します。
Match Tag Instance | 「Tag」の特定のインスタンスと照合する場合に選択します。この場合、そのインスタンスの番号を選択します。たとえば、ページの3番目の表セルと照合する場合は3を選択します。
Criteria

基準タイプを1つ選択します。

  • Text。タグ要素のプレーン・テキスト（InnerText）の内容（「Enter your password」など）。
  • HTML。タグ要素のリッチ・テキスト（InnerHTML）の内容（「<b>Enter your password</b>」など）。
  • Attribute。ボックスに、タグ要素のHTML属性（「id =password」など）を入力します。
Value | 照合する「Criteria」のテキストを入力します。
Match Whole Value | 前のフィールドに入力した「Value」の厳密な照合を実施する場合に選択します（つまり、タグ要素に余分なテキストを追加すると、照合は失敗します）。
Use regular expression

照合する正規表現を選択します。


「Miscellaneous」タブ（選択されたWebアプリケーション用）

「Miscellaneous」タブの「Submit Delay」

Webページには、ページがロードされ、有効になるまでにしばらく時間がかかるフォームが含まれる場合があります。この場合、ESSO-LMによる資格証明の送信が早すぎる場合があります。これを回避するには、「Miscellaneous」タブの「Submit Delay」設定で、すべてのフォームが有効になるまでの時間を設定します。

Submit Delay (milliseconds) エージェントが資格証明を送信するまでに待機する時間をミリ秒単位で入力します。


新しいホスト/メインフレーム・アプリケーション

このダイアログ・ボックスは、ホスト/メインフレーム・アプリケーションの新しいログオンを構成する場合に使用します。

手順全体については、「メインフレーム・アプリケーションの追加」を参照してください。

新しいホスト/メインフレーム・アプリケーションの構成

  1. ターゲット・アプリケーションを起動します。
  2. 左側のペインで「Applications」を右クリックし、ショートカット・メニューから「New Host App」を選択します。
  3. 「Host/Mainframe」オプションが選択された状態で「Add Application」ダイアログ・ボックスが表示されます。
  4. 「Add Application」ダイアログ・ボックスで、新しいログオンの名前を入力し、「OK」をクリックします。「Host/Mainframe Form」ウィザード（新しいログオン・フォームの構成用）が表示されます。

詳細は、「メインフレーム・アプリケーションの追加」を参照してください。


「Host/Mainframe Form」ウィザード

「Host/Mainframe Form」ウィザードは、次のタスクを実行する場合に使用します。

  • ホスト/メインフレーム・エミュレータまたはTelnet（スクロール画面）アプリケーションの新しいログオンを構成します。
  • 既存のログオンに新しいフォームを追加します。
  • 自動パスワード変更のフォームを作成します。
  • パスワード変更の成功および失敗を検出するフォームを作成します。

「Host/Mainframe Form」ウィザードでは、アプリケーション自体を使用して、そのログオン/パスワード変更ウィンドウ、および個別のユーザー名/ID、パスワードおよびその他のフィールドを識別できます。 ログオンを作成するための一般的な手順は、次のとおりです。

  1. ターゲットのエミュレータまたはTelnetアプリケーションを起動します。
  2. フォーム・タイプおよび画面のタイプを選択します。
  3. アプリケーションのログオン/パスワード変更画面のテキストをコピーし、コンソールに貼り付けます。
  4. その画面がログオン/パスワード変更フォームであることを示す画面キャプションのテキストおよび位置を指定します。
  5. 個別のユーザー名/ID、パスワードおよびその他のフィールドの位置（Telnetアプリケーションの場合は順序）を指定します。
  6. 構成を確認し、「Back」ボタンおよび「Next」ボタンを使用して、必要に応じて変更を加えます。
  7. ホスト/メインフレーム・ログオンの設定を手動で変更するには、「General」タブ（ホスト/メインフレーム・ログオン・フォームの構成用）を使用します。
  8. この手順を開始する前に、アプリケーションの構成に関する「一般的なガイドライン」を参照してください。 また、ホスト/メインフレーム・ログオンの作成および構成に関する具体的な説明については、「ホスト/メインフレーム・アプリケーションの追加」を参照してください。

ホスト/メインフレーム・アプリケーションの構成

ホスト/メインフレーム・エミュレータまたはTelnetで、ターゲット・アプリケーションを起動します。

  1. コンソールで、次のいずれかを実行します。
    • 新しいホスト/メインフレーム・アプリケーション・ログオンを作成します。
    • 既存のホスト・メインフレーム・アプリケーションを選択し、「General」タブの「Add」をクリックします。
  2. 「Host/Mainframe」ウィザードで、フォーム・タイプを選択します。 使用可能なオプションは、次のとおりです。
    • Logon:ログオン・フォームを構成します。
    • Password Change:パスワード変更フォームを構成します。
    • Password change success:ターゲット・アプリケーションのパスワード変更成功メッセージに対応するフォームを構成します。このフォームは資格証明を取り込まないため、「Host/Mainframe」ウィザードの「Credentials」ページはスキップされます。パスワード変更成功メッセージが検出されると、ESSO-LM は自動的に新しい資格証明を保存します。
    • Password change failure:ターゲット・アプリケーションのパスワード変更失敗メッセージに対応するフォームで、パスワード変更失敗メッセージが検出された場合は資格証明を再度取り込みます。このオプションを選択した場合は、「Host/Mainframe」の「Credentials」ページが表示されます。そこで必要なフィールドを構成します。
  3. 「Screen Type」ウィザード・ページで、次のいずれかを実行します。
    • ログオン・フォームが静的なテキスト・ページとして存在するホスト/メインフレーム・エミュレータでアプリケーションを実行している場合は、「Fixed Screen」 を選択します。
    • ログオン情報を一連のプロンプトとしてリクエストするTelnetまたはその他のスクロール画面コンソールでアプリケーションを実行している場合は、「Scrolling Screen」 を選択します。
  4. ターゲット・アプリケーション上に開いている「Paste Screen Text」ページで、画面テキスト全体を選択し、Windowsクリップボードにコピーします。
エミュレータには、コピーのコマンドまたはボタンが用意されているもの、および[Ctrl]キーを押しながら[C]キーを押してコピーするものがあります。Windows Telnetでは、テキストを選択して「Enter」を選択します。
  5. コンソールの「Paste Screen Text」ページで、「Paste Text」をクリックしてウィザード・ページのテキストを貼り付け、「Next」をクリックします。

エミュレータ画面で復帰改行文字を使用しない場合は、適切なテキスト・ラップが設定されるように「Characters per Line」を調整します。
  6. 「Cursor Position」ページで、矢印キーをクリックまたは使用して、Telnetアプリケーションのウィンドウでテキスト・カーソルが表示される正確な位置にカーソルを配置します。
  7. 「Next」をクリックして、次のウィザード・ページを表示します。
  8. 「Text to Match」ウィザード・ページで、画面がログオンまたはパスワード変更フォームであることを示すテキスト・ブロックを選択します。選択範囲を右クリックし、「Add as Text Match」をクリックします。追加のテキスト・ブロックごとにこの手順を繰り返します。
  9. 選択が完了したら、「Next」をクリックして、次のウィザード・ページを表示します。
  10. 「Fields」ウィザード・ページで、次のいずれかを実行します。
    • 固定画面ログオンの場合、テキスト・カーソルをフィールドの開始位置に置きます。右クリックし、ショートカット・メニューからフィールド・タイプ（「Username/ID」、「Password」、「Third Field」、「Fourth Field」）を選択します。必須フィールドごとにこの手順を繰り返します。
    • スクロール画面の場合、テキスト・カーソルをプロンプト入力位置に置きます。「Add」をクリックし、要求された最初のフィールド・タイプを選択します。必須プロンプトごとにこの手順を繰り返します。
  11. 選択が完了したら、「Next」をクリックして、サマリー・ページを表示します。
  12. 構成を確認します。変更を加えるには、「Back」ボタンおよび「Next」ボタンを使用して、ページを表示します。
  13. 構成が完了したら、「Finish」をクリックします。


RSA SecurID用「Host/Mainframe Form」ウィザード

「Host/Mainframe Form」ウィザード

「Host/Mainframe Form」ウィザードは、次のタスクを実行する場合に使用します。

  • ホスト/メインフレーム・エミュレータまたはTelnet（スクロール画面）アプリケーションの新しいログオンを構成します。
  • 既存のログオンに新しいフォームを追加します。
  • 自動PIN変更のフォームを作成します。
  • PIN変更の成功および失敗検出用のフォームを作成します。

「Host/Mainframe Form」ウィザードでは、アプリケーション自体を使用して、そのウィンドウおよびフィールドを識別できます。 ログオンを作成するための一般的な手順は、次のとおりです。

  1. ターゲットのエミュレータまたはTelnetアプリケーションを起動します。
  2. フォーム・タイプおよび画面のタイプを選択します。
  3. アプリケーションによって表示されたフォームのテキストをコピーし、コンソールに貼り付けます。
  4. その画面が選択されたフォームであることを示す画面キャプションのテキストおよび位置を指定します。
  5. 個別のユーザー名/ID、PINおよびその他のフィールドの位置（Telnetアプリケーションの場合は順序）を指定します。
  6. 構成を確認し、「Back」ボタンおよび「Next」ボタンを使用して、必要に応じて変更を加えます。

ホスト/メインフレーム・ログオンの設定を手動で変更するには、「General」タブ（ホスト/メインフレーム・ログオン・フォームの構成用）を使用します。

この手順を開始する前に、アプリケーションの構成に関する「一般的なガイドライン」を参照してください。 また、ホスト/メインフレーム・ログオンの作成および構成に関する具体的な説明については、「ホスト/メインフレーム・アプリケーションの追加」を参照してください。

ホスト/メインフレーム・アプリケーションの構成

ホスト/メインフレーム・エミュレータまたはTelnetで、ターゲット・アプリケーションを起動します。

  1. コンソールで、次のいずれかを実行します。
    • 新しいホスト/メインフレーム・アプリケーション・ログオンを作成します。「Add Application」ダイアログで「RSA SecurID」チェック・ボックスを選択してください。
    • 既存のホスト・メインフレーム・アプリケーションを選択し、「General」タブの「Add」をクリックします。
  2. 「Host/Mainframe」ウィザードで、フォーム・タイプを選択します。 使用可能なオプションは、次のとおりです。
    • Logon: ログオン・フォームを構成します。
    • PIN change: PIN変更フォームを構成します。
    • PIN change success: ターゲット・アプリケーションのPIN変更成功メッセージに対応するフォームを構成します。このフォームは資格証明を取り込まないため、「Host/Mainframe」ウィザードの「Credentials」ページはスキップされます。PIN変更成功メッセージが検出されると、ESSO-LM は自動的に新しい資格証明を保存します。
    • PIN change failure: ターゲット・アプリケーションのPIN変更失敗メッセージに対応するフォームを構成し、PIN変更失敗メッセージが検出された場合は資格証明を再度取り込みます。このオプションを選択した場合は、「Host/Mainframe」ウィザードの「Credentials」ページが表示されます。そこで必要なフィールドを構成します。
  3. 「Screen Type」ウィザード・ページで、次のいずれかを実行します。
    • ログオン・フォームが静的なテキスト・ページとして存在するホスト/メインフレーム・エミュレータでアプリケーションを実行している場合は、「Fixed Screen」 を選択します。
    • ログオン情報を一連のプロンプトとしてリクエストするTelnetまたはその他のスクロール画面コンソールでアプリケーションを実行している場合は、「Scrolling Screen」 を選択します。
  4. ターゲット・アプリケーション上に開いている「Paste Screen Text」ページで、画面テキスト全体を選択し、Windowsクリップボードにコピーします。
エミュレータには、コピーのコマンドまたはボタンが用意されているもの、および[Ctrl]キーを押しながら[C]キーを押してコピーするものがあります。Windows Telnetでは、テキストを選択して「Enter」を選択します。
  5. コンソールの「Paste Screen Text」ページで、「Paste Text」をクリックしてウィザード・ページのテキストを貼り付け、「Next」をクリックします。

エミュレータ画面で復帰改行文字を使用しない場合は、適切なテキスト・ラップが設定されるように「Characters per Line」を調整します。
  6. 「Cursor Position」ページで、矢印キーをクリックまたは使用して、Telnetアプリケーションのウィンドウでテキスト・カーソルが表示される正確な位置にカーソルを配置します。
  7. 「Next」をクリックして、次のウィザード・ページを表示します。
  8. 「Text to Match」ウィザード・ページで、画面がログオンまたはパスワード変更フォームであることを示すテキスト・ブロックを選択します。選択範囲を右クリックし、「Add as Text Match」をクリックします。追加のテキスト・ブロックごとにこの手順を繰り返します。
  9. 選択が完了したら、「Next」をクリックして、次のウィザード・ページを表示します。
  10. 「Fields」ウィザード・ページで、次のいずれかを実行します。
    • 固定画面ログオンの場合、テキスト・カーソルをフィールドの開始位置に置きます。右クリックし、ショートカット・メニューからフィールド・タイプ（「Username/ID」、「Password」、「Third Field」、「Fourth Field」）を選択します。必須フィールドごとにこの手順を繰り返します。
    • スクロール画面の場合、テキスト・カーソルをプロンプト入力位置に置きます。「Add」をクリックし、要求された最初のフィールド・タイプを選択します。必須プロンプトごとにこの手順を繰り返します。
  11. 選択が完了したら、「Next」をクリックして、サマリー・ページを表示します。
  12. 構成を確認します。変更を加えるには、「Back」ボタンおよび「Next」ボタンを使用して、ページを表示します。
  13. 構成が完了したら、「Finish」をクリックします。


「General」タブ（ホスト/メインフレーム・ログオン・フォームの構成用）

このダイアログ・ボックスは、ホスト/メインフレーム・アプリケーション・ログオン・フォームに関する情報を変更する場合に使用します。

Telnetアプリケーションのログオンの構成については、「Telnetアプリケーションの追加」 を参照してください。
コントロール
Form Name | アプリケーション・ログオン・フォームの名前。この名前は編集することができます。
Text Matching | エージェントがこのフォームを特定するために使用するリテラル・テキスト文字列、その文字列の先頭文字の画面座標（行番号および列番号）を表示します。新しいテキスト識別子を指定するには「Add」をクリックし、既存のものを変更するには「Edit」をクリックします。
Fields | ESSO-LMがホスト・アプリケーションのログオン・フォームに転送するキーストロークの組合せを表示します。キーストロークの組合せを追加または変更するには、「Edit」をクリックして、「SendKeys(Host/Mainframe)」 ダイアログ・ボックスを表示します。
Wizard | 「Host/Mainframe Form」ウィザードを起動して、視覚的にアプリケーションを構成します。


テキスト・マッチング（ホスト/メインフレーム・ログオン・フォーム）

「Text Matching」ダイアログ・ボックスは、画面がログオンまたはパスワード変更フォームであることを示す画面キャプションのテキストおよび位置を指定する場合に使用します。

また、テキストの先頭文字の場所（行番号および列番号）を指定する必要もあります。テキストの行番号および列番号を検索するには、セッション・ウィンドウの最下部にあるステータス・バーのカーソル位置インジケータを使用します。

Telnetアプリケーションの場合は、カーソル位置を基準とする行座標を使用します。例については、「Telnetアプリケーションの追加」を参照してください。また、行または列（あるいはその両方）のワイルド・カード・マッチングにアスタリスクを使用できます。

照合するエントリを作成した後、「OK」をクリックします。

コントロール

Row | テキストの先頭文字の行番号（画面の垂直座標）を入力します。 Telnetアプリケーション（ホスト・エミュレータ対応）の場合、この値はカーソル位置を基準としており、負の値（カーソルより上の行を示す）またはアスタリスク（*）（画面の任意の行を示す）になることがあります。
Column | テキストの先頭文字の列番号（画面の水平座標）を入力します。Telnetアプリケーション（ホスト・エミュレータ対応）の場合、この設定は画面の任意の列を示すアスタリスク（*）になることがあります。
Text | 照合するテキストの文字列を入力します。


フィールド/アクションの編集（ホスト・メインフレーム）

フィールド/アクションの編集（ホスト・メインフレーム・アプリケーション・ログオン用）

「Edit Fields/Actions」ダイアログ・ボックスは、ESSO-LMがホスト・アプリケーションのログオン・フォームに転送するキーストロークの組合せを指定する場合に使用します。

「Edit Fields/Actions」ダイアログ・ボックスの右側のペインの各タブには、キーストローク・オプションがあります。各タブで必要なオプションを選択または入力します。「Insert」ボタンをクリックして、キーストロークの組合せにキーまたはアクションを追加します。

左側のペインのリストに選択内容が表示されます。キーストロークの組合せの順序を変更するには、項目を選択し、上矢印または下矢印をクリックしてその項目を移動します。項目を変更するには、その項目を選択し、「Edit」をクリックして「Fields」 ダイアログ・ボックスを表示します。項目を削除するには、その項目を選択し、「Delete」をクリックします。

コントロール

「Fields」タブ

Select fields to insert

キーストロークの組合せに追加する資格証明項目をリストから選択します。

  • UserID
  • Password
  • Third Field
  • Fourth Field
  • New Password
  • Confirm New Password

Insert this character after field

フィールドへの入力後に自動的に挿入するキーストロークを選択します。

  • None（キーストロークなし）
  • Tab（カーソルを進める場合）
  • Enter（フォームを送信する場合）

後述の「Special Keys」を参照してください。

Row/Column

テキスト入力フィールドの先頭文字の行座標および列座標を入力します。
列番号が可変の場合（たとえば、ほとんどのUNIXシステムには、パスワードを変更すると「New Password」および「Confirm Password」フィールド・ラベルの一部として影響を受けるユーザー名があります）、ESSO-LMが常に正しい場所に資格証明を取り込むことができるように、正規表現を使用してフィールド・ラベルの可変部分にワイルドカードを指定できます。

Insert

キーストロークの組合せに現在の選択内容を追加します。
「Text」タブ

Enter text to insert

キーストロークの組合せに追加するリテラル・テキストを入力します。

Insert

キーストロークの組合せにテキストを追加します。
「Delay」タブタブ

Length of delay(in seconds)

キーストローク間の遅延を入力または選択します。

Insert

キーストロークの組合せに遅延を追加します。
「Special Keys」タブ

Category/Key

左側のリストからキーストローク・カテゴリ（移動キーなど）を選択し、右側のリストから具体的なキー（[Page Down]など）を選択します。

Insert

キーストロークの組合せにキーストロークを追加します。


「Options」タブ

「Options」タブ（ホスト/メインフレーム・ログオン・フォームの構成用）

ホスト/メインフレームの「Options」タブは、ホスト/メインフレーム・ログオンのエミュレータ・オプションを設定する場合に使用します。

このタブを表示するには、次のいずれかを実行します。

  1. 新しいホスト/メインフレーム・アプリケーション・ログオンを作成します。

または

  1. 左側のペインで、「Applications」をクリックし、ホスト/メインフレーム・アプリケーションを選択します。
  2. 右側のペインで、「General」タブをクリックします。
  3. リストからログオン・フォームを選択し、「Edit」をクリックします。
  4. 「Host/Mainframe」フォーム構成ダイアログ・ボックスの「General」タブで、「Options」タブを選択します。

コントロール

Delay Field (ms) アクション（フィールドに値を入力するなど）とアクションの間でエージェントが一時停止する遅延（ミリ秒）を入力します（デフォルトは0ミリ秒）。
Screen Type

次のいずれかを選択します。

  • 静的な（スクロールしない）ターミナル・エミュレーション画面の場合は、「Fixed」を選択します。
  • スクロールするターミナル・エミュレーション画面（Telnetなど）の場合は、「Scrolling」を選択します。
Column Position of Cursor ログオンまたはパスワード変更を開始する場合のテキスト・カーソルの開始列番号を入力します。
この位置が可変の場合（たとえば、ほとんどのUNIXシステムには、パスワードを変更すると「New Password」および「Confirm Password」フィールド・ラベルの一部として影響を受けるユーザー名があります）、ESSO-LMが常に正しい場所に資格証明を取り込むことができるように、正規表現を使用してフィールド・ラベルの可変部分にワイルドカードを指定できます。


「Bulk Add」タブ

詳細は、「はじめて使用する場合（バルク追加）」を参照してください。

バルク追加へのアプリケーションの指定

バルク追加で使用するには、アプリケーションを個別に構成する必要があります。「バルク追加用のログオンを有効にする手順」を参照してください。
  1. 左側のペインで「Applications」をクリックし、右側のペインで「Bulk-Add」タブをクリックします。
  2. 「Add」をクリックします。 「Select Application」ダイアログ・ボックスが表示されます。
  3. このグループに追加するアプリケーションを選択します （複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします）。
  4. 「OK」をクリックします。
  5. 「Version Stamp」をyyyymmdd形式（たとえば2003年6月15日の場合は20030615）で入力または編集します。 この日付が、指定したエージェントが設定を完了した最終日付より後の場合は、新しいログオンを追加するための設定ウィザードが起動します。


アプリケーション（選択済）

選択したアプリケーション

構成済のアプリケーションを表します。右側のペインの各タブを使用して、このログオンのプロパティを参照または変更できます。

参照または編集するログオンを選択する手順:

  1. 左側のペインで「Applications」をクリックし、右側のペインで「Applications List」タブをクリックします。
  2. リストからアプリケーションを選択し、「Edit」をクリックします。

または

  1. 左側のペインで、「Applications」アイコンの横のプラス記号（+）をクリックし（または「Applications」をダブルクリックして）、構成済のログオンを表示します。
  2. 次のいずれかを実行します。

    • ログオン・アイコンをクリックして選択します。右側のペインに、「General」タブが表示されます。

      または

    • ログオン・アイコンを右クリックして、次のオプションが含まれるショートカット・メニューを表示します。

New Form | 選択したアプリケーション・ログオンの新しいフォームを追加します。選択したアプリケーション・タイプに応じた構成ダイアログが表示されます。
Delete | 選択したログオンを削除します。
Make copy | 選択したログオンを複製します。
Rename | 選択したログオンの名前を変更します。


「General」タブ（選択したアプリケーション用）

「General」タブは、選択したアプリケーションのフォームまたはフィールドの構成を追加または変更する場合に使用します。

Description | Agent Logon Managerの「Description」フィールドに表示されるオプションのテキスト・コメントを入力します。たとえば、"Email."=です。
Reference

Agent Logon Managerの「Reference」フィールドに表示されるオプションのテキスト・コメントを入力します。たとえば、バージョン1.0です。

クライアント側では、このフィールドは読取り専用です。
Add | 選択したアプリケーションの新しいフォームを追加します。選択したアプリケーション・タイプに応じた構成ダイアログ・ボックスが表示されます。
Edit | 既存のログオン・フォームを変更します。「Forms」ウィンドウからフォームを選択し、「Edit」をクリックします。選択したアプリケーション・タイプに応じた構成ダイアログが表示されます。
Delete | フォームを削除します。「Forms」ウィンドウからフォームを選択し、「Delete」をクリックします。リストにフォームが1つのみ表示されている場合は、そのフォームを削除するとアプリケーションが完全に削除されます。
Add [Edit] Notes | オプションのコメントまたはドキュメントを入力または変更します。
Deny response

エージェントがこのフォームに応答しないようにする場合は、このボタンを選択します。

テンプレートでいずれかのフォームを無効にすると、すべてのテンプレートが無効になります。


「Bulk Add」タブ（選択したアプリケーション用）

このタブは、現在選択しているアプリケーションの特殊な構成に使用します。 詳細は、「「Bulk-Add」タブ」（全般）を参照してください。

Enable Bulk-Add capability for this application | このアプリケーションをバルク追加に含める場合に選択します。
Confirm UserID during Bulk-Add | バルク追加の実行時、ユーザーにユーザー名を確認するよう求める場合に選択します。
Confirm Password during Bulk-Add | バルク追加の実行時、ユーザーにパスワードを確認するよう求める場合に選択します。
Confirm Third Field during Bulk-Add | バルク追加の実行時、ユーザーに3番目のフィールド情報を確認するよう求める場合に選択します。
Confirm Fourth Field during Bulk-Add | バルク追加の実行時、ユーザーに4番目のフィールド情報を確認するよう求める場合に選択します。


「Authentication」タブ（選択したアプリケーション用）

このタブは、ESSO-AMがインストールされている場合にのみ表示されます。ESSO-AMは、Oracleとは別に使用可能なESSO-LMへのアドオン・モジュールです。

このタブを使用して、選択したアプリケーションの最小の認証グレードを設定します。

選択したアプリケーションにESSO-LMがログオンするには、使用しているプライマリ・ログオン方法の認証グレードがこの値以上である必要があります。

エンド・ユーザーのプライマリ・ログオン方法の認証グレードが、このアプリケーションに設定されている最小グレードより低い場合、ユーザーがアプリケーションへのアクセスをリクエストすると、ESSO-LMはユーザーに対して、より高いグレードでの認証を要求します。要求されたグレードでのログインが成功した場合にのみ、アクセス権が付与されます。

プライマリ・ログオン方法の認証グレードを設定するには、認証グレード設定を使用します。

Minimum Authentication Grade エンド・ユーザーのプライマリ・ログオン方法に設定する必要がある最小認証グレードの数値を選択または入力します。デフォルトは1です。


「Error Loop」タブ（選択したアプリケーション用）

「Error Loop」タブ（選択したログオン用）

「Error Loop」タブ（選択したアプリケーションの下）は、個々のアプリケーションの「Logon Error (Error Loop)」ダイアログ・ボックスの外観および動作を制御する場合に使用します。

  • すべてのアプリケーションを対象にエラー・ループをグローバルに設定するには、「Error Loop」グローバル・エージェント設定を使用します（「Error Loop (End-User Experience - Response」を参照）。
  • アプリケーション・タイプごとにエラー・ループを設定するには、各タイプ（Windows、Web、ホスト/メインフレーム）に「Error Loop」グローバル・エージェント設定を使用します。

コントロール

Logon Timeout (sec.)

[TimeOut]

「Logon Error」ダイアログを表示するまでに、連続ログオン試行を許可する最大時間（秒）。デフォルトは30です。

「Logon Timeout」を0に設定した場合は、ログオン・エラー（入力した資格証明が不適切など）が発生しても、「Logon Error」ダイアログ・ボックスは表示されません。

Max. Retries

[MaxRetry]

「Logon Error」ダイアログ・ボックスを表示するまでに、（初回の試行後）再試行を許可する最大回数。デフォルトは1です。

Hide "Confirm Password"

[HideConfirmPW]

「Logon Error」ダイアログ・ボックスのパスワード確認フィールドを非表示にするかどうかを決定します。デフォルトは「No」です。
（グローバル・レジストリの該当部分は大カッコで囲んで示されています。）


「Password Change」タブ（選択したアプリケーション用）

「Password Change」タブは、エージェントによるパスワード変更の管理方法を制御するためのオプションを設定または変更する場合に使用します。

エージェントは、表示される場所が同じ画面かダイアログ・ボックスの別のタブかによって、ログオン・フィールドとパスワード変更フィールドを区別します。このタイプの画面で、エージェントは「Action Chooser」ダイアログ・ボックスを介してパスワード変更かログオンを選択することをユーザーに求めます。ユーザーがパスワードを変更する必要がない期間を設定できます。つまり、その期間、「Action Chooser」は表示されません。

コントロール

パスワード変更オプション
Wizard Behavior

アプリケーションがエンド・ユーザーにパスワードの変更を求めたときに、エージェントがどのように応答するかを制御します。オプションは、次のとおりです。

  • Prompt User: 「Password Change」ウィザードに従うようにユーザーに求めます。
  • Manual w/Auto Option: ユーザーに新しいパスワードを選択するように求めます。ただし、「Password Change」ウィザードでパスワードが自動生成されます。
  • Auto only: 自動的に新しいパスワードを生成します。ユーザーは新しいパスワードを選択できません。
  • Auto w/Manual Option: 自動的に新しいパスワードを生成します。ただし、ユーザーは事前に新しいパスワードを選択できます。
  • Quietly Generate and Submit Password: ユーザーに入力を求めることなく、パスワードを生成および送信します。
  • Manual only: ユーザーに新しいパスワードを選択するように求めます。「Password Change」ウィザードでパスワードが自動生成されることはありません。
Enable Password verify pop-up dialog | パスワード変更を検証するポップアップ・ダイアログ・ボックスを表示する場合にこのボックスを選択します。このボックスでは、パスワードが変更されたことを再度確認します。
Lock focus to password change dialog

有効にした場合、デスクトップ・フォーカスがパスワード変更ダイアログにロックされ、ユーザーがダイアログを完了または終了するまでターゲット・アプリケーションと対話しないようにします。

これはESSO-LMバージョン11.1.1.1.0での新しい設定です。
Prohibit cancelling a password change

有効にした場合、パスワード変更ダイアログの「Cancel」ボタンが無効になり、ユーザーがパスワード変更プロセスをキャンセルできなくなります。

これはESSO-LMバージョン11.1.1.1.0での新しい設定です。
Password Generation Policy | パスワード生成ポリシーを選択します。複数のアプリケーションをポリシーにサブスクライブするには、「ポリシー・サブスクライバ」を参照してください。
Credential Sharing Group | 資格証明共有グループを選択します。複数のアプリケーションをパスワード・グループに割り当てるには、「資格証明共有グループ」を参照してください。
バイパス・ログオン・チューザ

パスワード変更を開始するときに、ログオン・チューザを表示するかどうかを制御します。有効にした場合、選択した条件を満たすとすぐにパスワード変更ダイアログが表示されます。使用可能な条件を次に示します。

オプション:

  • 最新のログオンが同じアプリケーション・インスタンスに対するものだったとき。
  • 同じアプリケーションへの最新のログオンがx秒以内に発生したとき。
2番目の条件を選択した場合、タイムアウトの長さを秒単位を指定する必要があります。有効な範囲は、1から999999秒です。

これはESSO-LMバージョン11.1.1.1.0での新しい設定です。

パスワードの期限切れオプション
Enable Password Expiration | このチェック・ボックスは、指定した期間後にユーザーにパスワードの変更を求める場合に選択します。
Number of days until password expires | ユーザーのパスワードの有効日数を入力または選択します。
Run this command when the password expires | 「Number of days」設定が経過した後でユーザーがログオンしようとしたときに呼び出すフルパスおよびコマンドを入力します（または「Browse」をクリックして、実行可能ファイルの場所を指定します）。 （例: C:\Program Files\PassChange\passchange.exe。）
アクション・チューザの猶予期間
Days エージェントが「Action Chooser」ダイアログ・ボックスを表示しない猶予期間の長さ（日単位）を入力します。
Automatically proceed with password change

有効にした場合、猶予期間が切れてパスワード変更が自動的に起動すると、アクション・チューザはバイパスされます。

このオプションは、猶予期間の指定後にのみ使用できます。

これはESSO-LMバージョン11.1.1.1.0での新しい設定です。


「Events」タブ（選択したアプリケーション用）

このタブを使用して、ログオン・イベントの追加およびログオン・イベントを取り巻く環境を構成を行います。

Add Logon Event

Run this command when a logon for this application is added

この設定では、アプリケーションの「Add Logon」ウィザードの完了後、すぐに実行するプロセス（exe、Web、スクリプトなど）を定義できます。

たとえば、この設定を使用すると、資格証明をエージェントに入力した直後にパスワード変更アプリケーションを起動して、アプリケーション・パスワードをただちに変更できます。

入力するコマンドを検索するには、「Browse」ボタンをクリックします。

Pre Logon Event
Run this command before a logon for this application is used | この設定では、各ログオン・インスタンスの前に発生するログオン前のタスクを定義でき、現在のログオン試行についての情報をこのプロセスから送信できます。結果として生成された終了コードの情報は、資格証明の送信を続行するか、ログオン・プロセスを中断するかの指示をログオン・マネージャに出します。 たとえば、APIをコールするスクリプトを実行したり、アプリケーションがログオンに必要な状態にあることを確認するタスクを実行したり、許可または禁止アプリケーションのリストでユーザー名を確認するとします。 入力するコマンドを検索するには、「Browse」ボタンをクリックします。
Failure Return Code | エージェントは、このフィールドに設定されている数以上のエラーを返しているログオンを無視します。設定を高くすると、アプリケーションが複数のエラー・コードを返すことができるようになります。この設定のデフォルトは1です。
Time out | タスクが完了するのをエージェントが待機する時間をミリ秒単位で指定します。この設定は、1.000ミリ秒から5.000ミリ秒（デフォルト）まで増加します。タスクが指定された時間内に完了しなかった場合、タスクは終了し、ログオンは発生しません。
実行するアプリケーションのフルパスを指定し、そのパスを二重引用符で囲むことをお薦めします。たとえば、"C:\Program Files\My Tools\checktool.exe"です。


「Miscellaneous」タブ（選択したアプリケーション用）

このタブは、現在選択しているアプリケーションの特殊な構成の場合に使用します。

その他の設定

Allow Masked Fields to Be Revealed

ウィザードおよびプロパティ・ページのマスクしたフィールドに対して「Reveal」ボタンを有効にする場合に選択します。

Force Reauthentication

このアプリケーションに資格証明を提供する前に、再認証を受けることをユーザーに求める場合に選択します。

Auto Submit

資格証明を指定した後、このアプリケーション・ログオンに対して、エージェントによって自動的に「OK」が選択されるようにする場合に選択します。

Service Logon

Windowsサービス（ユーザー領域ではなくシステム領域にあるサービス）として動作するアプリケーションをエージェントで検出する場合に選択します。

Auto-Recognize

エージェントにアプリケーションおよびWebサイトを認識させ、ユーザーを自動的にログオンさせる場合に選択します。この設定を選択または選択解除した場合、その設定はグローバル・エージェント設定より優先されます。この設定を選択すると、ユーザーはログオン・マネージャからこの設定を構成できます。この設定を選択解除すると、ユーザーはログオン・マネージャからこの設定にアクセスできません。

この設定がチェックでなく緑色のボックスの場合は、ユーザーがログオン・マネージャからこの設定を構成できることを意味します。

Mask Third Field

 アプリケーション・ログオンの3番目のフィールドをマスクする場合に選択します。この設定は、「New Logon」プロパティ、「Error Loop Dialog」、「Logon Properties」および「FTU Entry」の各ページの3番目のフィールドの外観に影響します。このボックスはデフォルトで選択されています（3番目のフィールドはマスクされます）。

Mask Fourth Field

 アプリケーション・ログオンの4番目のフィールドをマスクする場合に選択します。この設定は、「New Logon」プロパティ、「Error Loop Dialog」、「Logon Properties」および「FTU Entry」の各ページの4番目のフィールドの外観に影響します。このボックスはデフォルトで選択されています（4番目のフィールドはマスクされます）。
Prohibit disabling the addition of new logons

このアプリケーションの「New Logon」ダイアログ・ボックスで「Disable」ボタンをアクティブにするかどうかを指定します。有効にした場合、「Disable」ボタンは非アクティブになり、エージェントによって自動プロンプトが表示された場合に、ユーザーはこのアプリケーションで新しいログオンを追加できなくなります。無効にした場合、「Disable」ボタンをクリックすると、エージェントの設定ダイアログの除外リストにこのアプリケーションが追加されます。

オプション:

  • Yes
  • No（デフォルト）

この設定は、バージョン 11.1.1.1.0 で変更されました。

Prohibit canceling the addition of new logons

このアプリケーションの「New Logon」ダイアログ・ボックスで「Cancel」ボタンをアクティブにするかどうかを指定します。有効にした場合、「Cancel」ボタンは非アクティブになり、エージェントによって自動プロンプトが表示された場合に、ユーザーはこのアプリケーションで新しいログオンを追加できなくなります。無効にした場合、「Cancel」ボタンをクリックすると、次回このアプリケーションが検出されるまで、ログオン追加が遅延されます。

オプション:

  • Yes
  • No（デフォルト）

File extension (for Icon)

ログオンに関連付けられているWindowsファイルの拡張子を入力します。エージェントに対して、構成にアイコンをマップするように指示します。

ConfigName

新しいログオンの初期構成名（Windowsアプリケーションのみ）を作成するためのテキストが含まれているウィンドウおよびコントロールを選択する場合は「Choose」をクリックします。

UserID Field Label

エージェントがユーザー名/IDフィールドに使用するテキスト・ラベルを入力します。

Password Field Label

エージェントがパスワード・フィールドに使用するテキスト・ラベルを入力します。

3rd Field Label

エージェントが3番目のログオン・フィールドを表示するときに使用するテキスト・ラベルを入力します。

4th Field Label

エージェントが4番目のログオン・フィールドを表示するときに使用するテキスト・ラベルを入力します。
SendKeysの設定
Delay Char この設定を使用して、SendKeysでの各クリックの間にミリ秒単位で遅延を追加します。これにより、資格証明の送信が遅くなります。この設定は、資格証明の入力を認識するために追加の時間を必要とするアプリケーションで役立ちます。
ログオン・ループ猶予期間

None

ログオン・プロンプトの間に猶予期間がありません。初回のログオン後、ユーザーは自動的にログオンされます。（デフォルト）
Prompt ログオン猶予期間が期限切れでない場合は、アプリケーションに再度ログオンするかどうかを尋ねるプロンプトが表示されます。
Silent

エージェントは猶予期間が期限が切れるまでアプリケーションを無視し、猶予期間が切れるまで資格証明を取り込みません。

Minutes

猶予期間の長さを分単位で設定します。

Reset for each process

有効にした場合、プロセスが起動されるたびに猶予期間はリセットされます。これによって、猶予期間が期限切れでない場合も、アプリケーションを閉じたり再起動するときに、ESSO-LMによってユーザーはアプリケーションにログオンします。

無効にした場合は、猶予期間が新しいプロセスごとにリセットされることはありません。猶予期間が期限が切れるまで、ESSO-LMは再起動されたアプリケーションにユーザーのログオンを試行することはありません。（これが無効に設定され、猶予期間が期限切れでない場合、「Prompt/Silent」オプションが「Prompt」に設定されていると、ユーザーは再度ログオンするように要求されます。）


コントロールIDの選択

ConfigNameウィザードは、アプリケーション・ログオンの初期名として使用するログオン・ウィンドウのテキスト・コントロールを選択する場合に使用します。この機能を使用して、ログオン・ウィンドウに表示されるログオンに可変テキスト項目（アカウント名など）付きの名前を付与します（ログオンがエージェントに追加されるときに付与されます）。

  1. 使用するテキスト・コントロールが含まれているウィンドウを選択し、「Next」をクリックします。
  2. ログオンの初期構成名として使用するテキスト項目が含まれているコントロールを選択します。「Finish」をクリックします。

コントロール（アプリケーション・ウィンドウ）

Window List | 現在のアプリケーションのウィンドウを表示します。列ヘッダーをクリックすると、リストがソートされます。
Show hidden window | 非表示のウィンドウを「Window List」に含める場合に指定します。
Next | 次のウィザード・ページに進みます。

コントロール（ConfigNameコントロール）

Control List | 現在選択しているアプリケーション・ウィンドウのコントロールを表示します。ヘッダー（「Class」、「ID」または「Text」）をクリックすると、リストがソートされます。
Use ordinals instead of control IDs | エージェントが、ネイティブ・コントロールIDによって個々のフィールドをアドレス指定するのではなく、ESSO-LMによって割り当てられた番号付けされた一連のコントロールIDとして、このフォームにデータを転送することを示します。
Refresh | フィールド・リストを更新します。
Back | 前のウィザード・ページに戻ります。


「Security」タブ（ロール/グループ・サポート用）

このタブは、現在選択している構成項目へのアクセス権を設定する場合に使用します。次の項目へのアクセス権を割り当てることができます。

  • アプリケーション・ログオン（関連付けられた資格証明共有グループを含む）
  • パスワード生成ポリシー
  • グローバル・エージェント設定
  • パスフレーズ質問セット
Active Directoryドメインのセキュリティを向上させるには、ドメイン管理者の名前を右クリックし、「DENY」を選択します。これにより、アプリケーション・テンプレートがドメイン管理者に自動的に送信されることはなくなります。

コントロール

Directory | ターゲット・ディレクトリ・サーバーを選択します。
アクセス情報:
Name | このアイテムに現在アクセスできるグループまたはユーザーが表示されます。
ID | ユーザー・アカウント名。
Access | ユーザーまたはグループが、現在選択している項目に対して読取り/書込みアクセス権を持つのか、または読取り専用アクセス権を持つのかを示します。ユーザーまたはグループのアクセス権を変更するには、ユーザーまたはグループを右クリックし、ショートカット・メニューから「Read」または「Read/Write」を選択します。
アクション:
Add | 「Add User or Group」 （LDAPまたはActive Directoryの場合）が表示されたら、現在選択されているアイテムにアクセスする必要があるユーザーまたはグループを選択します。
Remove | 選択したユーザーまたはグループがリストから削除されます。削除するユーザーまたはグループを選択します。複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします。


選択したアプリケーション用の「Provisioning」タブ

「Provisioning」タブ（ロール/グループ・サポート用）

このタブから、権限の追加および削除を行うことができます。また、権限に対するアクセス権のレベル（アプリケーションの追加/変更/削除）も選択できます。

コントロール

Directory | ターゲット・ディレクトリ・サーバーを選択します。
アクセス情報:
Name | このアイテムに現在アクセスできるグループまたはユーザーが表示されます。
ID | ユーザー・アカウント名が表示されます。
Access | ユーザーまたはグループに付与されている権限（ログオンの追加、変更または削除）を示します。ユーザーまたはグループのアクセス権を変更するには、ユーザーまたはグループを右クリックし、ショートカット・メニューから「Add Logon」、「Modify Logon」または「Delete Logon」を選択します。
アクション
Copy permissions to | このボタンを使用すると、現行のアプリケーションのプロビジョニング権限を複数のアプリケーションに簡単に適用できます。このボタンをクリックすると、すべてのアプリケーションが示されているダイアログ・ページが表示されます。これらのプロビジョニング権限をコピーするアプリケーションを選択します。複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします。「OK」をクリックします。
Add | 「Add User or Group」ダイアログ・ボックス（LDAPまたはActive Directoryの場合）が表示されたら、現在選択されているアイテムにアクセスする必要があるユーザーまたはグループを選択します。
Remove | 選択したユーザーまたはグループがリストから削除されます。削除するユーザーまたはグループを選択します。複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします。

「Add User or Group」ダイアログ・ボックス

「Select User or Group」ダイアログ・ボックスは、使用しているディレクトリ・サーバーによって異なります。

  • LDAP
  • Active Directory/ADAM

LDAP

現行の構成アイテム（「Add Logon」、「Modify Logon」または「Delete Logon」）用のアクセス・リストに追加する個々のユーザーまたはユーザー・グループを選択する場合は、次のダイアログ・ボックスを使用します。

コントロール

Search Base | ユーザー/グループのアカウントの検索を開始するベース・ディレクトリ（最上位のディレクトリ）。ベース・ディレクトリのすべてのサブディレクトリが検索されます。場所を入力するか、または「Change」をクリックしてディレクトリ・ツリーを参照します。
Change | 検索用のベース・ディレクトリを参照するために「Select Search Base」ダイアログ・ボックスが表示されます。このダイアログ・ボックスは、ユーザー/グループの名前を検索するためのベース・ディレクトリ（最上位のディレクトリ）を参照および選択する場合に使用します。終了したら、「OK」をクリックします。
Search | ベース・ディレクトリ内のユーザーおよびグループの検索が開始されます。
Users or Groups | 検索結果が表示されます。現行の構成アイテム用のアクセス・リストに追加する名前を選択します。複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします。アクセス・リストへの選択したアイテムのコピーを終了したら、「OK」をクリックします。

Active Directory/ADAM

現行の構成アイテム（「Add Logon」、「Modify Logon」または「Delete Logon」）用のアクセス・リストに追加する個々のユーザーまたはユーザー・グループを選択する場合は、次のダイアログ・ボックスを使用します。

コントロール

List Names From | Active Directoryのドメインまたはサーバーを選択します。
Names | 選択したドメインまたはサーバー用のユーザーおよびグループの名前が表示されます。アクセス・リストに追加する名前を1つ以上選択します。
Add | 「Names」リストで選択したユーザーおよびグループが「Add Names」リストにコピーされます。複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします。
Members | 「Names」でグループを選択した場合は、「Global Group Membership」ダイアログ・ボックスが表示されます。このダイアログ・ボックスには、選択したグループのメンバーが表示されます。
Search | 特定のユーザーまたはグループ用の1つ以上のドメインを検索するための「Find Account」ダイアログ・ボックスが表示されます。
Add Names | この時点までに追加したユーザーまたはグループの名前が表示されます。これらの名前を現行の構成アイテム用のアクセス・リストに追加する場合は、「OK」をクリックします。注意: このリスト内のユーザー名は、入力または編集できます。ただし、エントリのアカウント名が有効かどうかが確認され、アカウントが重複して選択されている場合は、「OK」をクリックすると、重複しているアカウントが自動的に削除されます。


MSIの生成

構成したアプリケーション・ログオンまたはエージェント構成設定（あるいはその両方）を追加するために、既存のMSIパッケージから新しい.MSIファイル（Windows Installerパッケージ）を作成します。

「Generate MSI」は、通常、ESSO-LM.の初期デスクトップ・インストールにログオンまたは設定を含めるようにESSO-LMインストール・パッケージ（ESSO-LM配布ディスクの\Full\setup.msi）を変更する場合に使用します。作成するMSIファイルに含めることができるものは次のとおりです。

  • entlist.iniファイルまたは現在のコンソール構成から選択されたアプリケーション・ログオン
  • 管理優先設定（.ini）ファイルまたは現在のコンソール構成からのエージェント設定

MSIパッケージの生成

  1. ベース（入力）および出力.msiファイルの名前を選択または入力します。
  2. 次のいずれかまたは両方を実行します。

    • .msiパッケージに含める1つ以上の構成済アプリケーションを選択します。

      または

    • .msiパッケージに含めるグローバル・エージェント設定のセットを選択します。
  3. 「OK」をクリックします。
ファイル
Base (MSI)... | カスタマイズするベース・インストーラ・パッケージ。ファイル名を入力するか、または「...」ボタンをクリックして.msiファイルを選択します。
Output (MSI)... | エンド・ユーザーに送信するカスタマイズ済インストーラ・パッケージ。ファイル名を入力するか、または「...」ボタンをクリックして既存の.msiファイルを選択します。
構成
アプリケーション | パッケージ化するアプリケーション。「Configure Applications」ダイアログ・ボックスを表示する場合は「Choose」をクリックします。
グローバル・エージェント設定 | パッケージするグローバル・エージェント設定のセット。「Configure Global Agent Settings」ダイアログ・ボックスを表示する場合は「Choose」をクリックします。


INIファイルへのエクスポート

  1. 選択したアプリケーション、およびすべてのパスワード・ポリシーとグループをentlist.iniファイル（アプリケーション・ログオンの保存場所）にエクスポートします。
  2. 次のいずれかを実行します。

    • エクスポートするアプリケーションを選択し（複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします）、「OK」をクリックします。

      または

    • 「Export All」をクリックして、リストされたアプリケーションをすべてエクスポートします。
  3. 選択したアプリケーションがバルク追加に対応している場合は、「Create First-Time-Use file」を選択して、バルク追加（ftulist.ini）ファイルを生成できます。
  4. 「OK」をクリックします。「Export EntList file」ダイアログ・ボックスが表示されます。
  5. そのファイルのフォルダを検索してフォルダを開き、ファイルに名前を付与して「Save」をクリックします。
  6. はじめて使用する場合のファイルの作成を選択した場合は、「Export First-Time Use」ダイアログ・ボックスが表示されます。ファイルのフォルダを検索して開き（必要に応じてファイル名を変更し）、「Save」をクリックします。


EntListファイルのエクスポート

エクスポートしたアプリケーション構成ファイル（enlist.ini）をディスクに保存します。「Export EntList file」ダイアログは、「Export to INI file」ダイアログ・ボックスを使用してアプリケーション・ログオン情報をエクスポートする場合に表示されます。

  1. そのファイルのフォルダを検索してフォルダを開き、ファイルに名前を付与して「Save」をクリックします。
  2. はじめて使用する場合のファイルの作成を選択した場合は、「Export First-Time Use」ダイアログ・ボックスが表示されます。ファイルのフォルダを検索して開き（必要に応じてファイル名を変更し）、「Save」をクリックします。


First-Time Useのエクスポート

はじめて使用する場合のファイル（ftulist.ini）をディスクに保存します。「Export First-Time Use」ダイアログ・ボックスは、enlist.iniファイルへのアプリケーション・ログオン情報のエクスポート時に、はじめて使用する場合のファイルを作成するときに表示されます。

  1. ファイルのフォルダを検索して開き（必要に応じてファイル名を変更し）ます。
  2. 「Save」をクリックします。


インポート/マージの競合

マージしたファイルに現在の構成の項目と同じ名前の項目が含まれている場合に「Import/Merge Conflict」ダイアログ・ボックスが表示されます。

  • インポートする項目を選択し、「OK」をクリックします。

    選択した項目で、現在の同じ名前の項目が上書きされます。


テンプレートの管理

このダイアログ・ボックスを使用して、アプリケーション・ログオンのテンプレートを作成、変更および削除します。このダイアログ・ボックスを表示するには、「Tools」メニューの「Manage Templates」をクリックします。

テンプレートを作成する場合は、完全なテンプレート名が別のテンプレート名の最初の部分と厳密に一致しないことを確認してください。片方の名前がもう一方の名前の一部になっている2つのテンプレートをエージェントが見つけた場合、エージェントは名前の短い方のテンプレートを認識します。

たとえば、2つのテンプレートがABCとABDという名前の場合、この問題は発生しません。ただし、1つのテンプレートがABCという名前で、さらにABC_Dという名前のテンプレートが存在する場合は、どちらのアプリケーションが開いているかにかかわらず、エージェントはABCテンプレートのみを認識し、ABC_Dテンプレートを無視します。

アプリケーションからの新しいテンプレートの作成

  1. 「Add」をクリックして、アプリケーション・ログオンから新しいテンプレートを作成します。
  2. 「Select Applications」ダイアログ・ボックスで、テンプレートの基礎とするアプリケーションを選択します。
  3. 「OK」をクリックします。「Edit Template」ダイアログ・ボックスで、管理者が指定する必要がある設定、およびテンプレートの優先設定を指定できます。

既存のテンプレートの変更

  • リストからアプリケーションを選択し、「Edit」をクリックします。「Edit Template」ダイアログ・ボックスで、管理者が指定する必要がある設定、およびテンプレートの優先設定を変更できます。

テンプレートの削除

  • リストからアプリケーションを選択し、「Remove」をクリックします。


「Override Settings」タブ（「Edit Template」ダイアログ・ボックス）

このタブは、テンプレートに基づくすべてのログオンで、このテンプレートが更新する設定を選択する場合に使用します。アプリケーション・ログオン構成のすべてのフォームに適用されるグローバル優先設定を選択できます。また、個々のフォームで固有の優先設定を選択することもできます。

左側のペインには、アプリケーションおよびそのコンポーネント・フォームの階層が表示されます。

  • アプリケーションのグローバル優先設定は、各アプリケーション・タイプの一般的な構成設定に対応しています。
  • フォーム固有の設定は、個々のログオンの構成コントロールに対応しています。

右側のペインに「Setting」の両タイプが一覧表示され、設定を行うアプリケーション構成ダイアログ・ボックスに対応した「Category」も表示されます。設定ごとの情報については、それぞれのダイアログ・ボックスまたはタブを参照してください。

Applications | General Error Loop Password Change Miscellaneous
Windows forms | General Fields Matching Miscellaneous
Web forms | General Matching
Mainframe/Host forms | General Options

このタブを表示する手順

  1. 「Tools」メニューから「Manage Templates」を選択します。
  2. 次のいずれかを実行します。

  • 新しいテンプレートを追加します。

    または

  • 既存のテンプレートを選択し、「Edit」をクリックします。

  3. 「Edit Templates」ダイアログ・ボックスで、「Overriding Settings」タブを選択します。


「Supply Info」タブ（「Edit Template」ダイアログ・ボックス）

このタブは、このテンプレートに基づくアプリケーション・ログオンを完成するために、管理者が指定する必要がある情報を指定する場合に使用します。すべての項目を選択するか、またはチェック・ボックスを選択して項目を個別に選択することができます。


アプリケーションの更新（テンプレートから）

このダイアログ・ボックスは、ログオンの作成後に変更されたテンプレートに基づいて、アプリケーション・ログオンを更新する場合に使用します。テンプレートを変更したログオンのみがリストに表示されます。更新するアプリケーションを選択し（複数のアプリケーションを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします）、「Update」をクリックします。


動的コントロールIDおよび序数コントロールID

アプリケーションによっては、アプリケーションの起動ごとに各フィールドのコントロールIDを変更します。ESSO-LMには、これらの動的なコントロールIDを置き換えるために序数のID番号を割り当てるオプションがあります。これによって、アプリケーションの起動ごとにコントロールIDは変更されなくなります。

ESSO-LMは、デフォルトで.NETアプリケーションに必須の序数フィールドIDを割り当てます。これにはコントロールIDのネイティブ・サポートはありません。

ESSO-LMでの序数コントロールIDの割り当ての構成

  1. ESSO-LM Administrative Consoleを起動します。
  2. ESSO-LM Agentを一時停止します。
  3. テンプレートを作成するアプリケーションを起動します。
  4. テンプレート・ウィザードを起動します。

  5. 「Logon」を選択します。

    「Credential Fields」画面に、各フィールドのコントロールIDが表示されます。動的コントロールIDを持つアプリケーションの場合、このID番号は起動ごとに異なります。（これは.NETアプリケーションにはあてはまりません。.NETアプリケーションはネイティブ・コントロールIDを持ちません。）

  6. 「Use ordinals instead of control IDs」を選択します。
    • 「Credential Fields」画面にフィールドが表示されます。ネイティブ（動的）・コントロールIDを使用するかわりに、場所の順序によってコントロールIDを割り当てます。
    • ネイティブ・コントロールIDをサポートするアプリケーションの場合、「Use ordinals instead of control IDs」を選択すると、アプリケーション・ウィンドウでコントロールを列挙することによって、コントロールIDの検出が行われます。「ID」列にはフィールドの序数が格納され、表示がリフレッシュされます。
    • 序数IDを使用しない場合、動的コントロールIDがデフォルトとして表示されます（ただし、.NETアプリケーションは除きます。このアプリケーションの序数はすでに表示されています）
    • 「Use 'Send Keys' for this form.Do not use Control ID」を選択すると、「Use ordinals instead of control IDs」オプションを使用できなくなります。
  7. IDに割り当てるフィールドを決定する数値フィールドの値を選択します。そのフィールドは、点滅する境界線で囲まれます。フィールド名（「Username」、「Password」など）を選択するには、ドロップダウン・メニューを右クリックします。


セッションの管理

Oracle Enterprise Single Sign-on Kiosk Manager

アクションとセッション・ステートを作成するには、次の手順を実行します。

  1. 「Create Action」をクリックして、新しいアクションを作成します。

    アクションによって、プログラムの実行、.Netメソッドのコール、特定のアプリケーションの終了、特定のアプリケーション・リスト以外のすべての終了など、なんらかの処理を実行するようにESSO-KMに指示します。

  2. 「Create Session State」をクリックして、新しいセッション・ステートを作成します。

    「セッション・ステート」とは、アクションに関連付けるイベントのリストです。たとえば、定義済のセッション・ステートは、セッション終了時にこのアクション・リストを実行するようにESSO-KMに指示します。セッション・ステートは、ログオン・セッションの開始時、どのアクションを実行するかなど、ログオン・セッションで実行するアクションを定義します。また、ログオン・セッションの終了時に、どのアクションを実行するかも定義します。


Create Session Action List

「Oracle Enterprise Single Sign-on Kiosk Manager」 > 「Add List」ダイアログ・ボックス

このダイアログを使用して、アクション・リストを作成します。「List Type」を選択して、「Name」を入力します。終了したら、「OK」をクリックします。

3つのタイプのアクションを作成できます。

  • 終了リスト:
    終了リストは、セッション終了時にESSO-KMによって閉じるアプリケーションのリストです。
  • 実行リスト:
    実行リストは、コールする.Net APIか、ESSO-KMによって実行するコマンドラインのスクリプトです。
  • 特別なアクション・リスト:
    特別なアクション・リストは、アプリケーションの位置指定や、このアプリケーションによるアクションの実行順番など、アプリケーション・ウィンドウの処理方法を指定します。


特別なアクション

「Oracle Enterprise Single Sign-on Kiosk Manager」 > 「Special Actions」

このパネルを使用して、アプリケーション・ウィンドウの処理方法（アプリケーションの位置指定や、このアプリケーションによるアクションの実行順番など）を指定します。

アプリケーション・ウィンドウが特別なアクション・リストに表示されない場合は、非表示になります。

コントロール

AppPathKeys

実行中のプロセスと照合するために、このログオンに関連付けられているアプリケーションを識別するWindowsレジストリ・キー。（通常は、Notepad.exeなど、アプリケーション実行可能ファイルの名前）

Window Titles | ログオン・リクエストを識別するためにログオン・ウィンドウ・タイトルと照合されるテキスト。
Reposition Application

この設定とその下にあるオプションによって、アプリケーションの位置を指定できます。このチェック・ボックスの状態で、この設定の下にリストされるアクションがアプリケーション・ウィンドウに適用されるかどうかが決定します。

オプション:

  • Maximize
  • Minimize
  • Restore
  • Move to。アプリケーションの位置の座標を入力します。
  • Resize。アプリケーションの位置の幅と高さを入力します。
Sort Order | この設定によって、特別なアクションが実行される順番が決定します。これによって、複数のウィンドウの位置が変更されたときに、優先ウィンドウを最前面にして、前面に表示するウィンドウを特定の順番で表示できるようになります。
Bring to foreground | この設定によって、アプリケーション・ウィンドウが常にアプリケーション・ウィンドウの順番の先頭になります。
Shared Application | このボックスをチェックすると、ユーザー・セッション間でアプリケーションを共有できるようになります。たとえば、Notepad.exeが共用アプリケーションとして指定され、user1がノートパッドでドキュメントを開いた後、セッションをロックすると、user2がセッションを開始するとき、ノートパッドは実行していることになります。その後、user2がノートパッドを閉じ、セッションをロックする場合、user1が再度ログオンしたとき、ノートパッドは実行していません。
Disabled | このチェック・ボックスを選択して、このリストを無効にします。リストを無効にすると、元のリストを削除しなくてもリストの設定を保持できます。これによって、引き続き設定を参照でき、他のリストでその設定を使用することもできます。

アプリケーションの構成

  1. 「AppPath Keys」ボックスで、「Add」をクリックします。「Process Path Key」ダイアログ・ボックスが表示されます。
  2. 有効なアプリケーション・キー（通常は、Notepad.exeなど、アプリケーション実行可能ファイルの名前）を入力します。「OK」をクリックします。
  3. セッション終了時に終了するアプリケーションのリストに、アプリケーションが追加されました。セッション終了時にESSO-KMによってこれらのアプリケーションが終了されます。
  4. このリストのアプリケーションを変更または削除するには、「Edit」ボタンおよび「Delete」ボタンを使用します。
  5. 「Window Titles」ボックスで、「Add」をクリックします。「Windows Title」ダイアログ・ボックスが表示されます。
  6. 有効なウィンドウ・タイトルを入力します。「OK」をクリックします。

照合するウィンドウ・タイトルを指定するには、次の手順を実行します。

  1. 正確なウィンドウ・タイトルを入力（または編集）します。
  2. 「OK」をクリックします。


終了するセッションのリスト

「Oracle Enterprise Single Sign-on Kiosk Manager」 > 「Terminate List」

このパネルは、セッション終了時にESSO-KMによって閉じるアプリケーションのリストを作成する場合に使用します。

コントロール

AppPathKeys

実行中のプロセスと照合するために、このログオンに関連付けられているアプリケーションを識別するWindowsレジストリ・キー。（通常は、Notepad.exeなど、アプリケーション実行可能ファイルの名前）

Window Titles | ログオン・リクエストを識別するためにログオン・ウィンドウ・タイトルと照合されるテキスト。
Process Termination Type

セッション終了時に閉じるアプリケーションの終了方法を選択します。

  • Keystroke Sequence
  • .Net SendKeys
  • SendKeys: キーストロークの組合せをフォームに転送して、フィールドを構成します。「Edit」をクリックして、キーストロークの組合せを入力または変更します。
  • SendKeys using Journal Hook: ジャーナル・フックを使用してキーストロークの組合せをフォームに転送して、フィールドを構成します。「Edit」をクリックして、キーストロークの組合せを入力または変更します。
  • Process closure requests
  • Process termination
一連のキーストロークを使用してアプリケーションを終了すると、エンド・ユーザーの画面でちらつきが発生します。このちらつきは、アプリケーションの終了にsendkeysを使用しているために発生します。
Disabled | このチェック・ボックスを選択して、このリストを無効にします。リストを無効にすると、元のリストを削除しなくてもリストの設定を保持できます。これによって、引き続き設定を参照でき、他のリストでその設定を使用することもできます。

アプリケーションの構成

  1. 「AppPath Keys」ボックスで、「Add」をクリックします。「Process Path Key」ダイアログ・ボックスが表示されます。
  2. 有効なアプリケーション・キー（通常は、Notepad.exeなど、アプリケーション実行可能ファイルの名前）を入力します。「OK」をクリックします。
  3. セッション終了時に終了するアプリケーションのリストに、アプリケーションが追加されました。セッション終了時にESSO-KMによってこれらのアプリケーションが終了されます。
  4. このリストのアプリケーションを変更または削除するには、「Edit」ボタンおよび「Delete」ボタンを使用します。
  5. 「Window Titles」ボックスで、「Add」をクリックします。「Windows Title」ダイアログ・ボックスが表示されます。
  6. 有効なウィンドウ・タイトルを入力します。「OK」をクリックします。

照合するウィンドウ・タイトルを指定するには、次の手順を実行します。

  1. 正確なウィンドウ・タイトルを入力（または編集）します。
  2. 「OK」をクリックします。


マネージャのセション・ステートのアクション・タブ

「Oracle Enterprise Single Sign-on Kiosk Manager」>「Session States」>「Actions」タブ

「Actions」タブには、このセッション・ステートに関連付けられているすべてのアクションのリストが含まれます。新しく作成されたセッション・ステートの場合、このパネルは空です。アクションをセッション・ステートに関連付けると、アクションがこのパネルに表示されます。

このパネルを使用して、アクションを作成、編集、関連付け、編集および削除します。

「Actions」タブを使用するには、次の手順を実行します。

  • 新しいアクション・リストを定義するには、「Create」をクリックします。アクション・リストには、終了リストと実行リストの2種類があります。このパネルから作成した新しいアクションは、このセッション・ステートに自動的に追加されます。
  • 定義したアクションをこのセッション・ステートに関連付けるには、「Associate」 をクリックして、リストからアクションを選択します。
  • アクションを変更するには、選択して「Edit」をクリックします。
  • セッション・ステートからアクションを削除するには、「Delete」をクリックします。これによって、アクション・リストからではなく、現在のセッション・ステートからアクションが削除されます。


セッション実行リスト

「Oracle Enterprise Single Sign-on Kiosk Manager」 > 「Run List」

このパネルを使用して、コールする.Net APIか、ESSO-KMによって実行するコマンドラインのスクリプトを定義します。

コマンド

実行する「.Net API」または「Script」コマンドを選択します。

.Net API | Assembly | 「...」をクリックして、使用する.Netアセンブリを検索します。アセンブリがロードされます。
Class | ドロップダウン・ボックスを使用して、.Netクラスを選択します。選択されたアセンブリで使用可能な.Netクラスがリストされます。
Method

ドロップダウン・ボックスを使用して、コールするメソッドを選択します。選択されたクラスで使用可能な.Netメソッドがリストされます。メソッドは次のシグネチャにかぎられ、パラメータをとったり、値を戻すことはありません。

void MethodName();

スクリプトとは異なり、メソッドが戻るまで処理は続行されません。

サンプル.Net APIを表示するにはここをクリックしてください。

.NET APIコールは同期されます（ESSO-KMはコールが完了するまで待機します）。
Script

実行するESSO-KMのコマンドライン・スクリプトを入力します。このリストに複数のコマンドが含まれる場合は、前のタスクが完了するまで待たずに、また前のタスクのリターン・コードを確認せずに各行が開始します。

コマンドライン・コールは非同期です（ESSO-KMを含む他のタスクとパラレルに実行されます）。
Disabled | このチェック・ボックスを選択して、このリストを無効にします。リストを無効にすると、元のリストを削除しなくてもリストの設定を保持できます。これによって、引き続き設定を参照でき、他のリストにその設定をコピーすることもできます。


セッション・ステートの概要

「Oracle Enterprise Single Sign-on Kiosk Manager」>「Session States」

このパネルには、作成済のセッション・ステートのリストが含まれます。セッション・ステートとは、アクションに関連付けるイベントのリストです。たとえば、定義済のセッション・ステートは、セッション終了時にこのアクション・リストを実行するようにESSO-KMに指示します。セッション・ステートは、ログオン・セッションの開始や終了時、どのアクションを実行するかなど、ログオン・セッションで実行するアクションを定義します。

このパネルを使用して、セッション・ステートを作成、編集、コピーおよび削除します。

セッション・ステートを追加するには、次の手順を実行します。

  • 「Create」をクリックして、新しいセッション・ステートを追加します。

    または

  • セッション・ステートを選択します。
  • 「Edit」をクリックして、このセッション・ステートが応答するイベントおよび認証方式を選択します。「Edit」コマンドでは、このステートに選択されたイベントおよび認証方式にどのアクションを関連付けるかを選択することもできます。

セッション・ステートをコピーするには、次の手順を実行します。

  • 「Copy」をクリックして、セッション・ステートのコピーを作成します。名前を変更するには、左側のペインでセッション・ステートを右クリックし、「Rename」をクリックします。左側のペインでセッション・ステートを右クリックして、「Copy」をクリックしても、コピーを実行できます。

セッション・ステートを削除するには、次の手順を実行します。

  1. 「Delete」をクリックして、セッション・ステートを削除します。ステートが削除される前に、確認メッセージが表示されます。


セッション・ステートの追加

「Oracle Enterprise Single Sign-on Kiosk Manager」>「Add Session State」

このダイアログ・ボックスを使用して、新しいセッション・ステートを追加して、名前を付けます。セッション・ステート名を入力し、「OK」をクリックします。


「Events」タブ

「Oracle Enterprise Single Sign-on Kiosk Manager」>「Session States」>「Events」タブ

「Events」タブには、ESSO-KMが応答できるすべてのイベントのリストと、カスタム・イベントを追加するオプションが含まれます。リストされている各イベントの隣にはチェック・ボックスがあり、チェックされていれば、このイベントが発生したときに、関連付けられたアクション・リストを実行することを示します。新しいセッション・ステートが作成されると、「Session End」がデフォルトでチェックされています。

イベントの作成には2つの方法があります。

  • 「Add」ボタンをクリックして、独自のカスタム・イベントを作成します。「Edit」ボタンを使用してカスタム・イベント名を編集し、「Delete」ボタンを使用してカスタム・イベントを削除します。

または

  • このセッション・ステートに対して事前定義されたイベントを選択します。使用可能なイベントは次のとおりです。
    • After Session Unlocked
      このイベントは、認証が行われた後にセッションをロック解除したときに実行されます。認証が取り消されると、このイベントはトリガーされません。
    • AM Device In
      このイベントは、SSOデバイス・モニターが有効で、監視対象の認証方式が検出された場合（たとえば、スマート・カードが挿入されたり、生態認証装置が監視範囲内にある場合）にトリガーされます。
    • AM Device Out
      このイベントは、SSOデバイス・モニターが有効で、監視対象の認証方式が検出された場合（たとえば、スマート・カードが削除されたり、生態認証装置が監視範囲からなくなった場合）にトリガーされます。 このイベントは、次の場合にトリガーされます。
      • セッションは開いているか、ロックされている
      • 「Device-In」イベントがセッションを開始した
    • AM Grace Period
      このイベントは、猶予期間ファンクションを使用する認証方式が使用されている場合に、その猶予期間内にユーザーがオープン・セッションに戻るとトリガーされます。
    • Authenticator Logon
      このイベントは、認証方式がログオンを受け入れたときに発生します。たとえば、WinAuthの正しいパスワードまたはスマート・カードの正しいPINが入力されたときです。
    • Authenticator Timeout
      このイベントは、ESSO-LMの内部タイマーの有効期限が切れたときにトリガーされます。
    • Before Session Unlocked
      このイベントは、ユーザーがセッションをロック解除した後、認証が行われる前にトリガーされます。
    • Cached Credential Session Start
      このイベントは、セッションが開始し、ローカル・コンピュータに格納された資格証明をユーザーがキャッシュ済の場合にトリガーされます。
    • Session End
      このイベントは、セッションが終了してタイマーの期限が切れたとき、または別のユーザーがセッションを開始したときにトリガーされます。
    • Session Locked
      このイベントは、ユーザーがシステム・トレイから手動でセッションをロックしたときにトリガーされます。
    • Session Start
      このイベントは、ユーザーが新しいセッションを開始したときにトリガーされます。
    • Time Expired
      このイベントは、ロックされたセッションのタイマーが00:00:00になったときにトリガーされます。
    • Transparent Screen Displayed
      このイベントは、透過的ロックが開始され、画面がロック・モードでユーザーに表示されたときにトリガーされます。
    • Transparent Screen Hidden
      このイベントは、透過的ロックが終了したときに発生します。
    • User Change
      このイベントは、ユーザーがESSO-KMにログインしたときにトリガーされます。このイベントは、.Netオブジェクトに次の2つのプロパティを設定します。プロパティが存在しない場合は何も発生しません。
      • UserName。 syncユーザー名。
      • DomainName。syncドメイン名。

ESSO-AMイベントは、イベント・タイプを示すESSO-KMに認証方式によってメッセージが送信されたときに実行されます。


「Session Authenticator」タブ

「Oracle Enterprise Single Sign-on Kiosk Manager」>「Session States」>「Authenticators」タブ

「Authenticators」タブには、カスタム認証方式を追加するためのオプションの他に、ESSO-LMがサポートするすべての認証方式のリストも含まれます。各認証方式の隣にはチェック・ボックスがあり、チェックされていれば、選択されたイベントが発生したときや、選択された認証方式でユーザーが認証されたときに、関連付けられたアクション・リストを実行することを示します。

新しいセッション・ステートが作成されると、すべての認証方式はデフォルトでチェックされています。

認証方式の選択には2つの方法があります。

  • 「Add」ボタンをクリックして、独自のカスタム認証方式を作成します。「Edit」ボタンを使用してカスタム・イベント認証方式を編集し、「Delete」ボタンを使用してカスタム認証方式を削除します。
  • このセッション・ステートに対して事前定義された認証方式を選択します。使用可能な認証方式は次のとおりです。
    • Authentication Manager
    • Entrust
    • LDAP
    • LDAP v2
    • Proximity Card
    • Read-Only Smart Card
    • SecurID
    • Smart Card
    • Windows Logon
    • Windows Logon v2


セッション・ステートのセキュリティ

「Oracle Enterprise Single Sign-on Kiosk Manager」>「Session States」>「Security」タブ

「Security」タブを使用して、このセッション・ステートへのアクセス権を設定します。次の項目へのアクセス権を割り当てることができます。

  • アプリケーション・ログオン（関連付けられた資格証明共有グループを含む）
  • パスワード生成ポリシー
  • グローバル・エージェント設定
  • パスフレーズ質問セット
セキュリティ・タブは、「Role/Group Security」が有効な場合にのみ表示されます。

コントロール

Directory | ターゲット・ディレクトリ・サーバーを選択します。
アクセス情報
Name | 対象となっているセッション・ステートに現在アクセスできるグループまたはユーザーが表示されます。
ID | ユーザー・アカウント名。
Access | ユーザーまたはグループが、現在選択しているセッション・ステートに対して読取り/書込みアクセス権を持つのか、または読取り専用アクセス権を持つのかを示します。ユーザーまたはグループのアクセス権を変更するには、ユーザーまたはグループを右クリックし、ショートカット・メニューから「Read」または「Read/Write」を選択します。
アクション
Add | 「Add User or Group」（LDAPまたはActive Directoryの場合）が表示されたら、現在選択されているセッション・ステートにアクセスする必要があるユーザーまたはグループを選択します。
Remove | 選択したユーザーまたはグループがリストから削除されます。削除するユーザーまたはグループを選択します。複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします。


プロビジョニングの概要

Oracle Enterprise Single Sign-on Provisioning Gateway

Oracle Enterprise Single Sign-on Provisioning Gateway（PM）を使用すると、管理者は、プロビジョニング・システムを使用してESSO-LMにユーザーのIDおよびパスワードを自動的にプロビジョニングできます。管理者は、プロビジョニング・システム内の特定のアプリケーションのIDおよびパスワードを追加、変更および削除し、その変更をESSO-LMに反映させることができます。また、保護されているすべてのアプリケーションへのユーザーによるアクセスを回避するために、プロビジョニング・システムからESSO-LM内のすべてのユーザー名およびパスワードを削除することもできます。

次のESSO-PG設定が、コンソールで構成されます。

  • 「Provisioning」タブ（ロール/グループ・サポート用）
  • 「Provisioning App」タブ（ロール/グループ・サポート用）
ESSO-PGは、Oracleとは別に使用可能なESSO-LMへのアドオン・モジュールです。

ESSO-PGの詳細は、ESSO-PG製品のドキュメントを参照してください。

ESSO-PG Administrative Consoleへのアクセス

  • Webブラウザを開き、次のURLを入力します（serverhostは、ESSO-PGがインストールされているサーバーに置き換えます）。
    https://serverhost/ESSO-PG console/overview.aspx


パスフレーズ・セット

パスワードのリセットをリクエストするときに、ユーザーに表示される質問のグループを作成できます。パスフレーズ・セットと呼ばれるこれらのグループは、「Passphrase Questions」画面を使用して作成、構成、変更および削除します。

このオプションは、Windows Authenticator v2およびLDAP Authenticator v2に対してのみ使用します。

このオプションは、スマート・カード認証（SCAuth）用のESSO-AMで使用します。


パスフレーズ・セットの追加

パスフレーズ・セットを追加する手順

  1. 次のいずれかを実行します。

    • 左側のペインで「Passphrase Questions」を右クリックし、ショートカット・メニューから「New Passphrase」を選択します。

      または

    • 右側のペインで右クリックし、ショートカット・メニューから「New Passphrase」を選択します。

      または

    • 右側のペインの下部にある「Add」ボタンをクリックします。

      または

    • 「INSERT」メニューから、「Passphrase」を選択します。
  2. 「Add Passphrase Set」ダイアログ・ボックスでパスフレーズ・セット名を入力し、「OK」をクリックします。
  3. 右側のペインの「Questions」タブを使用して、現在のパスフレーズ・セットに質問を追加します。


パスフレーズ・セットの削除

パスフレーズ・セットを削除するには、次のいずれかを実行します。

  1. 左側のペインで、「Passphrase Questions」を選択します。
  2. 右側のペインのパスフレーズ・セットのリストから、セットを選択し、「Delete」ボタンをクリックします。

または

  • セットを選択して右クリックし、ショートカット・メニューから「Delete」を選択します。

または

  1. 左側のペインで「Passphrase Questions」をダブルクリックします（または「+」記号をクリックします）。
  2. 展開された「Passphrase Questions」メニューから、既存のパスフレーズ・セットを右クリックし、ショートカット・メニューから「Delete」を選択します。


パスフレーズ・セットの変更

パスフレーズ・セットを変更する手順

  1. 「Passphrase Questions」メニューの下のパスフレーズ・セットをダブルクリックします。そのセットの質問は、右側のペインの「Questions」タブに表示されます。
    • セットに質問を追加するには、「Add」ボタンをクリックし、「Add a Question」ダイアログ・ボックスで質問を入力します。「OK」をクリックします。
    • セットの質問を編集するには、それを選択して「Edit」ボタンをクリックします。「Add a Question」ダイアログ・ボックスで質問を変更します。「OK」をクリックします。
    • セットの質問を削除するには、それを選択して「Remove」ボタンをクリックします。ESSO-LMから、削除の確認を求められます。「OK」をクリックします。


デフォルトのパスフレーズ・セットの設定

このオプションは、パスフレーズ・セットをデフォルトとして指定する場合に使用します。デフォルト・セットには、ユーザーが「First-Time Use」（FTU）の使用時に応答するパスフレーズ質問が含まれています。FTUウィザードは、次の場合に起動されます。

  • インストール後にはじめてエージェントを起動したとき

または

  • 管理者がftulistオブジェクトを配置するとき（ftulist.iniファイルなど）。

はじめて使用する場合、ESSO-LMユーザーはパスフレーズ質問を選択し、応答を指定します。ユーザーがプライマリ・ログオン・パスワードを後で変更する場合、この格納されたパスフレーズ応答を使用してESSO-LMの認証を再設定できます。次回シングル・サインオンの再認証が必要なときに、ユーザーが新しいパスワードを入力すると、ESSO-LMによってユーザーのアイデンティティを確認するためのパスフレーズ質問が表示されます。

エージェントは、1つのパスフレーズ・セットのみを使用します。ユーザーに応答してもらう質問セットを決定し、デフォルトのパスフレーズ・セットとして指定する必要があります。デフォルトとして指定するセットは、ftulistに書き込まれる唯一のセットです。

Administrative Consoleにftulistをインポートし、パスフレーズ・セットを変更してから、そのftulistをリポジトリに再エクスポートする場合は、そのパスフレーズ・セットをデフォルトとして再設定しないと、エクスポートに含められません。

デフォルトのパスフレーズ・セットを割り当てるには、次のいずれかを実行します。

  • 右側のペインでセット名を右クリックし、ショートカット・メニューから「Set As Default」を選択します。

または

  • 左側のペインでセット名を右クリックし、ショートカット・メニューの「Set As Default」を選択します。
    パスフレーズ・セット名は右側と左側の両方ペインで太字で表示され、デフォルトのセットであることを示しています。


パスフレーズの「Questions」タブ

「Questions」タブ

「Questions」タブは、選択されたパスフレーズ・セットの質問と設定を管理する場合に使用します。左側のペインからこのタブを表示するには、「Passphrase Questions」を選択して、太字で表示される「Default Set」を選択します。

パスフレーズ・セットに質問を追加する手順

  1. ドロップダウン・メニューから言語を選択します。
  2. 「Add」をクリックするか、「Insert」メニューから「Passphrase」を選択します。
  3. 「Add Question」ダイアログ・ボックスに、質問を入力します。
  4. 応答の最小長を選択または入力します。
  5. 「OK」をクリックします。

コントロール

Language | パスフレーズ質問の言語を選択します。
Default Question | 現在のデフォルトのパスフレーズ質問のリストを表示します（これはデフォルトで選択されています）。新しいパスフレーズ質問が追加されると、デフォルトのパスフレーズの選択が解除されます。選択すると、デフォルトのパスフレーズは現在のパスフレーズ・セットに対して無効になります。選択を解除すると、デフォルトのパスフレーズは現在のパスフレーズ・セットに対して有効になります。
Enabled Question | 現在のパスフレーズ質問のリストを表示します。選択されている項目は、現在のセットに対して有効なパスフレーズです。パスフレーズを無効にするには、チェック・ボックスをクリックして選択を解除します。パスフレーズ質問を変更するには、それをダブルクリックするか、選択して「Edit」をクリックします。
Add | 新しいパスフレーズ質問を追加します。「Add Question」ダイアログ・ボックスが表示されます。
Remove | 選択されたパスフレーズ質問を削除します。確認プロンプトが表示されます。
Edit | 選択されたパスフレーズ質問を変更します。「Edit Question」ダイアログ・ボックスが表示されます。
Set This Passphrase Set as Default | 現在のセットをデフォルトとして設定します。左側のペインで、デフォルトのパスフレーズ・セットの名前が太字で表示されます。
削除と無効 | パスフレーズ質問を作成して配置し、エンド・ユーザーによる使用を開始したら、そのパスフレーズ質問を削除しないでください。ユーザーが削除されたパスフレーズ質問を選択していた場合、パスワードを変更すると、ESSO-LM資格証明にアクセスできなくなります。使用中のパスフレーズ質問を取り除いて、はじめて使用する場合に表示されないようにするには、削除するのではなく、「Questions」タブのリストのそのチェック・ボックスの選択を解除することでその質問を無効にします。


パスワード生成ポリシー

現在使用可能なパスワード生成ポリシーを表示し、ポリシー設定へのアクセスを提供します。現在のパスワード・ポリシーを右側のペインに表示するには、左側のペインで「Password Generation Policy」をクリックします。

詳細は、「パスワード・ポリシーの設定」を参照してください。

新しいパスワード・ポリシーを追加する手順

  1. 次のいずれかを実行します。

    • 右側のペインで「Add」をクリックします。

      または

    • 左側のペインで「Password Generation Policy」を右クリックし、ショートカット・メニューの「New Policy」をクリックします。
  2. 「Policy Name」に値を入力し、「OK」をクリックします。右側のペインに「Policy Subscribers」タブが表示され、新しいポリシーを使用するアプリケーションを追加できます。

リスト内のパスワード・ポリシーの構成を変更する手順

  • ポリシーをクリックし、「Edit」をクリックします。右側のペインに、「Policy Subscribers」タブが表示されます。

1つ以上のパスワード・ポリシーを削除する手順

  • ポリシーを選択し（複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします）、「Remove」をクリックします。


パスワード・ポリシーの追加

このダイアログ・ボックスは、新しいパスワード生成ポリシーを追加して名前を付ける場合に使用します。

  • 「Policy Name」に値を入力し、「OK」をクリックします。


パスワード・ポリシー（選択済）

選択済のパスワード・ポリシー

構成済パスワード生成ポリシーを表します。右側のペインのタブを使用すると、このポリシーのプロパティを参照または変更し、このポリシーを使用するアプリケーションを追加または削除できます。

詳細は、「パスワード・ポリシーの設定」を参照してください。

表示または編集するポリシー・パスワードの選択

  1. 左側のペインで、「Password Generation Policies」をクリックします。
  2. 右側のペインのリストからポリシーを選択し、「Edit」をクリックします。右側のペインに、「Policy Subscribers」タブが表示されます。

または

  1. 左側のペインで、「Password Generation Policies」アイコンの横のプラス記号（+）をクリックし（または「Password Generation Policies」をダブルクリックして）、構成済のログオンを表示します。
  2. 次のいずれかを実行します。
    • ポリシー・アイコンをクリックして選択します。右側のペインに、「Policy Subscribers」タブが表示されます。
    • ポリシー・アイコンをクリックして選択します。右側のペインに、「Policy Subscribers」タブが表示されます。
Delete | 選択したポリシーを削除します。
Make copy | 選択したポリシーを複製します。
Rename | 選択したポリシーの名前を変更します。


パスワードの「Policy Subscribers」タブ

ポリシー・サブスクライバ

「Policy Subscribers」タブは、選択したパスワード生成ポリシーを使用するアプリケーションを追加または管理する場合に使用します。

詳細は、「パスワード・ポリシーの設定」を参照してください。

ポリシーにアプリケーションを追加する手順

  1. 「Add」をクリックします。「Select Applications」ダイアログ・ボックスが表示されます。
  2. このポリシーを使用するアプリケーションを選択します。（複数のエントリを選択するには、[Ctrl]または[Shift]を押しながらクリックします。）
  3. 「OK」をクリックします。

ポリシーからアプリケーションを削除するには、ポリシーを選択し（複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします）、「Remove」をクリックします。

メモを入力するには、「Add Notes」をクリックします。


パスワードの制約

「Password Constraints」タブ

「Password Constraints」タブは、パスワードに使用可能な文字の種類、数、位置および繰返しを設定または変更する場合に使用します。これらの制約は、選択したポリシーをサブスクライブするアプリケーション用にESSO-LMが自動生成する新しいパスワードに適用されます。

このポリシーのパスワード制約に基づいたテスト・パスワードを表示するには、「Test Policy」ボタンをクリックします。

詳細は、「パスワード・ポリシーの設定」を参照してください。

パスワード制約を設定する手順

  1. 次のいずれかを実行します。
  • パスワード・ポリシーを選択します。

または

  • 新しいパスワード・ポリシーを作成します。
  2. 右側のペインで、「Password Constraints」タブをクリックします。
  3. 表示されたコントロールから制約オプションを選択します。

パスワードの制約オプション

Length Constraint
Minimum Length | パスワードに使用する最小文字数（1から128）。デフォルトは8です。
Maximum Length | パスワードに使用できる最大文字数（1から128）。デフォルトは8です。
Repeat Constraint
Maximum repeated non-consecutive characters | パスワード内で特定の文字を任意の位置で繰り返すことができる最大回数（0から127）。デフォルトは7です。
Maximum repeated consecutive characters | パスワード内で特定の文字を連続して（その文字に隣接して）繰り返すことができる回数（0から127）。デフォルトは7です。
英字
Allow Uppercase Characters | パスワードでの大文字の使用を許可する場合に選択し、許可する最小文字数を入力または選択します。
Allow Lowercase Characters | パスワードでの子文字の使用を許可する場合に選択し、許可する最小文字数を入力または選択します。
数字
Allow Numeric Characters | パスワードでの数字の使用を許可する場合に選択し、許可する最小および最大文字数を入力または選択します。
Can Start Password | 数字で始まるパスワードを許可する場合に選択します。デフォルトでは、パスワードの先頭に数字を使用できます。
Can End Password | 数字で終わるパスワードを許可する場合に選択します。デフォルトでは、パスワードの末尾に数字を使用できます。
特殊文字
Allow Special Characters | 特殊文字（英数字以外）の使用を許可する場合に「Allow Special Characters」を選択し、許可する最小および最大文字数を入力または選択します。デフォルトでは、特殊文字は許可されていません。
Can Start Password | 特殊文字で始まるパスワードを許可する場合に選択します。デフォルトでは、パスワードの先頭に特殊文字を使用できます。
Can End Password | 特殊文字で終わるパスワードを許可する場合に選択しますデフォルトでは、パスワードの末尾に特殊文字を使用できません。
Other Characters
パスワードでのその他の文字の使用を許可する場合に選択します。
Excluded Characters
パスワードから除外する特定の文字を入力します。
Previous Password Constraints
Password must not be the same as previous password | 前のパスワードの再利用を防ぐ場合に選択します。
Limit the amount of characters that are the same as the previous password | 前のパスワードからの文字の繰り返しを制限する場合に選択します。
Number of characters that can be the same from the previous password

前のパスワードからの一部の文字の再利用を許可する場合、許可する最大文字数を選択します。

ESSO-LMは、1つの文字が複数回使用されても同じ文字と認識します。したがって、新しいパスワードでその文字を複数回使用することが可能です。

前のパスワードにAが3つ含まれる場合に、前のパスワードから1文字を再利用可能に指定すると、ESSO-LMによって、新しいパスワードでAを複数回使用することが許可されます。
Test Policy
「Test Password Policy」ダイアログ・ボックスを表示します。ここでは、現在のポリシー設定に基づくテスト・パスワードのセットを生成および表示できます。

この設定は、バージョン11.1.1.1.0で変更されました。


資格証明共有グループ

現在使用可能な資格証明共有グループを表示し、グループ設定へのアクセスを提供します。

詳細は、「資格証明共有グループの作成」を参照してください。

資格証明共有グループの作成

  1. 左側のペインで「Credential Sharing Groups」を選択して、現在のパスワード・グループを右側のペインに表示します。
  2. 次のいずれかを実行します。
  3. 右側のペインで「Add」をクリックします。
  4. 左側のペインで「Credential Sharing Groups」を右クリックし、ショートカット・メニューから「New Group」を選択します。
  5. 「Add Sharing Group」ダイアログ・ボックスで、「Group Name」 を入力し、「OK」をクリックします。
  6. 右側のペインの「Add」をクリックして、グループにアプリケーションを追加します。詳細は、「パスワード・グループにアプリケーションを追加する手順」を参照してください。

表示または編集の共有グループの選択

  1. 左側のペインで「Credential Sharing Groups」を選択します。

    • 右側のペインのリストからグループを選択し、「Edit」をクリックします。

      または

    • 左側のペインで、「Credential Sharing Groups」アイコンの横のプラス記号（+）をクリックして（または「Credential Sharing Groups」をダブルクリックして）、構成済のグループを表示します。
  2. 次のいずれかを実行します。

    • グループ・アイコンを選択します。右側のペインに、このグループのアプリケーションのリストが表示されます。

      または

    • グループ・アイコンを右クリックして、次のオプションが含まれるショートカット・メニューを表示します。

      • Delete。選択したグループを削除します。
      • Rename。選択したグループの名前を変更します。

共有グループの削除

  • グループを選択し（複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします）、「Remove」をクリックします。

デフォルト・グループ、ドメインまたはLDAPは削除できません。


共有フィールドの編集

「Edit Shared Fields」ダイアログ・ボックスは、資格証明共有グループに含めるフィールドを指定する場合に使用します。含めるフィールドに隣接するボックスを選択するか、または隣接するボックスの選択を解除してそのフィールドを除外します。

Username | 資格証明共有グループにユーザー名を含める場合に選択します。 資格証明共有グループからユーザー名を除外する場合は選択を解除します。
Password | 資格証明共有グループにパスワードを含める場合に選択します。 資格証明共有グループからパスワードを除外する場合は選択を解除します。
Third Field | 資格証明共有グループに3つ目のフィールドを含める場合に選択します。 資格証明共有グループから3つ目のフィールドを除外する場合は選択を解除します。
Fourth Field | 資格証明共有グループに4つ目のフィールドを含める場合に選択します。 資格証明共有グループから4つ目のフィールドを除外する場合は選択を解除します。


ドメイン

ドメイン共有グループ

ドメイン共有グループとは、Windows認証用に事前定義された資格証明共有グループのことです。

このパネルの使用方法の詳細は、「共有グループにアプリケーションを追加する手順」を参照してください。

ドメイン資格証明共有グループを選択する手順

  1. 左側のペインで「Credential Sharing Groups」を選択します。

  2. 右側のペインのリストから「Domain」を選択し、「Edit」をクリックします。

    または

  1. 左側のペインで、「Credential Sharing Groups」アイコンの横のプラス記号（+）をクリックして（または「Credential Sharing Groups」をダブルクリックして）、構成済のグループを表示します。
  2. 「Domain」をクリックします。


LDAPパスワード

LDAP共有グループ

LDAP共有グループとは、ディレクトリ・サービス認証用に事前定義された資格証明共有グループのことです。このパネルの使用方法の詳細は、「共有グループにアプリケーションを追加する手順」を参照してください。

LDAP資格証明共有グループを選択する手順

  1. 左側のペインで「Credential Sharing Groups」をクリックします。

  2. 右側のペインのリストから「LDAP」を選択し、「Edit」をクリックします。

    または

  1. 左側のペインで、「Credential Sharing Groups」アイコンの横のプラス記号（+）をクリックして（または「Credential Sharing Groups」をダブルクリックして）、構成済のグループを表示します。
  2. 「LDAP」をクリックします。


選択済の資格証明共有グループ

構成済の資格証明共有グループを表します。右側のペインのリストを使用して、選択したグループに対してアプリケーションを追加または削除します。「Add Notes」をクリックしてメモを入力します。

詳細は、「資格証明共有グループの作成」を参照してください。

共有グループにアプリケーションを追加する手順

  1. 「Add」をクリックします。「Select Application」ダイアログ・ボックスが表示されます。
  2. アプリケーションを選択して、選択されたグループに含めます。（複数のエントリを選択するには、[Ctrl]または[Shift]を押しながらクリックします。）
  3. 「OK」をクリックします。

共有グループのアプリケーションを編集する手順

  1. 右上の「Edit Sharing Fields」をクリックします。「Edit Sharing Group」ダイアログ・ボックスが表示されます。
  2. 選択したグループで共有する資格証明を選択します。次の資格証明を共有できます。
    • Username
    • Password（グループ作成時に自動的にチェックされます）
    • Third Field
    • Fourth Field
  3. 「OK」をクリックします。
  4. 「Shared Fields」が左上に表示されます。
ヒント:
  • すべてのチェック・ボックスの選択を解除すると、この共有グループを削除するかどうかを尋ねられます。
  • この共有グループに属するアプリケーションにフィールドが含まれていない場合は、チェック・ボックスの選択を解除しないでください。これにより、後でここに戻ってチェック・ボックスを選択しなくても、このフィールドを共有する新しいアプリケーションを追加できます。

共有グループからアプリケーションを削除する手順

  1. 選択したグループから削除するアプリケーションを選択します。（複数のエントリを選択するには、[Ctrl]または[Shift]を押しながらクリックします。）
  2. 「Remove」をクリックします。


グローバル・エージェント設定の作成

グローバル・エージェント設定

「Global Agent Settings」には、エージェント構成情報が含まれており、保存済のグローバル・エージェント設定セットへのアクセスが提供されます。

  1. 左側のペインで「Global Agent Settings」をクリックすると、グローバル・エージェント設定セットのリストが右側のペインに表示されます。
  2. 左側のペインで「Global Agent Settings」を右クリックすると、次のオプションが含まれるショートカット・メニューが表示されます。

New Settings | 新しいグローバル・エージェント設定セットを作成します。「Add Set of Settings」ダイアログ・ボックスが表示されます。
Import | 外部ソースからグローバル・エージェント設定セットをインポートします。
 | From File | 管理優先設定オブジェクト（INI）ファイルまたは登録エントリ（REG）ファイルから設定セットをインポートします。このファイルにナビゲートし、「Open」をクリックします。
 | From Live HKLM | ローカル・マシン・レジストリ（HKLM）から現在のエージェント構成をLiveという名前の設定セットとしてインポートします。

インポートした設定が現在の構成の既存セットと同じ名前である場合は、インポートしたセットに「既存の設定のコピー」という名前が付与されます。

このバージョンのコンソールを英語以外のOSにインストールした場合は、「New Settings」オプションを使用しないでください。かわりに、「Import」オプションを使用してください。「New Settings」オプションを使用すると、同期拡張のパスが無効なパスを指し、同期が失敗します。


設定セットの追加

このダイアログ・ボックスは、新しいグローバル・エージェント設定セットを追加して名前を付ける場合に使用します。

  • 「Set of Settings Name」に値を入力し、「OK」をクリックします。

このダイアログ・ボックスを表示する手順

  • 「Global Agent Settings」を右クリックし、ショートカット・メニューから「New Settings」を選択します。

    または

  • 「Insert」メニューから「Global Agent Settings」を選択します。


選択済のグローバル・エージェント設定のセット

保存済のグローバル・エージェント設定のセット（デスクトップでのESSO-LMの動作を変更するデフォルトやスイッチなどの構成情報）を表します。右側のペインのリストの項目をダブルクリックして個々の設定を表示または変更します。「Add Notes」をクリックして、設定のセットに関するメモを入力します。

グローバル・エージェント設定のセットの表示

  1. 次のいずれかを実行します。

  • 左側のペインで「Global Agent Settings」をクリックし、右側のペインから設定セットをダブルクリックします。

    または

  • 左側のペインで、「Global Agent Settings」アイコンの横のプラス記号（+）をクリックして（または「Global Agent Settings」をダブルクリックして）、設定セットを表示します。
  3. 次のいずれかを実行します。

  • 「Global Agent Settings」アイコンを選択します。右側のペインに、個々の設定のリストが表示されます。

    または

  • 「Global Agent Settings」アイコンを右クリックして、次のオプションが含まれるショートカット・メニューを表示します。

Export | 選択した設定セットをレジストリ・ファイルまたは管理優先設定オブジェクトに保存します。
Write to Live HKLM | ローカル・マシン・レジストリ（HKLM）に現在のエージェント構成をエクスポートします。
Delete | 選択した設定セットを削除します。
Make copy | 選択した設定セットを複製します。
Rename | 選択した設定セットの名前を変更します。


エンド・ユーザー側の動作設定

「End-User Experience」設定では、エージェントとエンド・ユーザーおよび他のプログラムとの対話など、エージェントをWindowsアプリケーションとして制御します。

Show the Tray Icon

この設定では、システム・トレイにESSO-LMトレイ・アイコンを表示するかどうかを指定します。

オプション:

  • Do not show
  • Show（デフォルト）

Title Bar Button

この設定では、すべてのウィンドウ/ダイアログ・タイトル・バーにESSO-LMタイトル・バー・ボタンを表示するかどうかを指定します。

オプション:

  • Do not show（デフォルト）
  • Show

Title Bar Button- Always show for:

タイトルバー・アイコンが常に表示されるアプリケーションのリストを（notepad.exeなど、実行可能ファイル名で）入力します。この設定は、前述の「Title Bar Button」設定より優先されます。

「...」ボタンをクリックして、アプリケーション名を入力します。アプリケーション名は改行で区切ります。

Title Bar Button Menu

この設定では、ESSO-LMの「Title Bar Button」メニューを表示するかどうかを決定します。

オプション:

  • Do not show
  • Show（タイトル・バー・ボタン設定が有効な場合[デフォルト]）

Title Bar Button tooltip

「Title Bar Button」上にマウスを置くと表示されるヒント・テキスト。デフォルトは「ESSO-LM」です。

Tray Icon Tooltip

トレイ・アイコン・ラベルに指定するテキスト。推奨される用途: Citrix MetaFrame Serverセッションごとにラベルを指定します。デフォルトは「ESSO-LM」です。

Tray Icon Tooltip: Show System Name

トレイ・アイコン名の後にコンピュータ名を表示します。TrayIconNameが設定されていない場合、または設定されていても空/NULLでない場合は、空白-ダッシュ-空白で構成される文字列がコンピュータ名の前に挿入されます。

オプション:

  • Do not show（デフォルト）
  • Show

Tray Icon: Use which icon

この設定では、システム・トレイに標準のESSO-LMアイコンと別のサーバー・アイコンのどちらを表示するかを指定します。

オプション:

  • Standard（デフォルト）
  • Server

Use strict window detection

この設定では、厳密なウィンドウ検出を制御します。この設定を有効にすると、ESSO-LMは非表示のウィンドウおよび最小化されたウィンドウに応答しなくなります。

オプション:

  • No（デフォルト）
  • Yes

このエントリは必須ではありません。


End-User Experience\Environment

環境（エンド・ユーザー側の動作設定）

「End-User Experience Environment」設定では、エージェントおよびその言語サポートで使用される重要なディレクトリ・パスを制御します。

Default Backup path

サイレント・バックアップのデフォルトのバックアップ・パス。ここで指定しないと（かつコマンドラインで指定しないと）、デフォルトでユーザーのアプリケーション・データ・ディレクトリ%AppData%\Passlogixが使用されます。

Language

エージェントで使用する言語。デフォルトは英語です。

その他の値は、ローカライズされたバージョンに応じて使用可能です。

オプション:

  • Brazilian Portuguese
  • Czech
  • Dutch
  • English
  • Finnish
  • French
  • German
  • Italian
  • Japanese
  • Korean
  • Polish
  • Simplified Chinese
  • Spanish

Location of entlist.ini file

entlist.iniファイルの完全修飾パスおよびファイル名。これは、コンソールで作成した事前構成アプリケーション・ログオンを配置するときに同期を使用しない場合にのみ設定します。詳細は、アプリケーション・ログオンの構成に関する項を参照してください。

SubLanguage

「Language」で設定する言語の設定。

その他の値は、ローカライズされたバージョンに応じて使用可能です。

表示フォントで、指定した言語の目的の文字がサポートされている必要があります。デフォルトはENGです。

オプション:

  • ENG Default support
  • DBL Extended support


End-User Experience\Password Change\Required

必須（「End-User Experience」-「Password Change」）

「Required Password Change」設定では、ログオン間での資格証明の共有を許可します。詳細は、「資格証明共有グループの作成」を参照してください。

Credential Sharing Groups

オプション:

  • Disabled（デフォルト）: エージェントへの最初の配置の場合のみ、テンプレートは資格証明を共有します。その後、テンプレートは独立して動作し、資格証明は共有されません。
  • Enabled: 最初の配置以降もテンプレートは資格証明を共有します。


End-User Experience\Password Change\Change Policies

変更ポリシー（「End-User Experience」-「Password Change」）

「Password Change Policies」設定では、パスワード変更ポリシーの定義に使用する文字セット、およびデフォルトのパスワード変更ポリシーとして使用する管理者定義ポリシーを制御します。

Characters: Lowercase | パスワード・ポリシー内で小文字の英字として許可する文字のリスト。（デフォルトは、abcdefghijklmnopqrstuvwxyzです）
Characters: Numeric | パスワード・ポリシー内で数字として許可する文字のリスト。（デフォルトは、1234567890です）
Characters: Special | パスワードに許可する英数字以外の（特殊）文字のリスト（デフォルトは、!@#$^&*()_-+=[]\|,?です）。
Characters: Uppercase | パスワード・ポリシー内で大文字の英字として許可する文字のリスト。（デフォルトは、ABCDEFGHIJKLMNOPQRSTUVWXYZです）
Default Policy | デフォルトのパスワード・ポリシーを含むentlist.iniのセクションの名前。（entlist.iniでポリシーが指定されていない場合、ESSO-LMはapplist.iniのポリシーをデフォルトにします。）


End-User Experience\Password Change\Common

共通（「End-User Experience」-「Password Change」）

「Common Password Change」設定では、エージェントのパスワード変更ウィザードのユーザー・インタフェースを制御します。

Default Change Password Wizard behavior

ユーザーがパスワード変更を行うパスワード変更ウィザードの動作を設定します。

オプション:

  • Prompt: パスワード変更ウィザードに従うようにユーザーに求めます（デフォルト）。
  • Manual, offer auto: ユーザーに新しいパスワードを選択するように求めます。ただし、パスワード変更ウィザードでパスワードが自動生成されます。
  • Auto, offer manual: 新しいパスワードを自動生成します。ただし、ユーザーは新しいパスワードを選択できます。
  • Manual only: ユーザーに新しいパスワードを選択するように求めます。パスワード変更ウィザードでパスワードが自動生成されることはありません。
Default pop-up dialog text

ユーザーがパスワードを変更した後に表示するテキストを指定します。

デフォルトのテキストを変更するには、チェック・ボックスを選択して現在のテキストを選択し、新しいテキストを入力します。デフォルトのテキストに戻すには、チェック・ボックスの選択を解除します。

デフォルトのテキストは、「After closing this message, verify that the application accepted the password.Select OK if it was accepted, if rejected please try again.」です。


End-User Experience\Password Change\Advanced

拡張（「End-User Experience」-「Password Change」）

「Advanced Password Change」設定では、資格証明共有および自動パスワード生成の拡張機能を制御します。

Allow user to exclude logons from sharing groups

ESSO-LMユーザーは、管理者が割り当てた資格証明共有グループからアプリケーション・ログオンを除外できます。このオプションを許可すると、「New Logon and Properties」ダイアログ・ボックスにチェック・ボックスが表示され、ユーザーは資格証明共有グループからのアカウントを省略することを選択できるようになります。

オプション:

  • Do not allow（デフォルト）
  • Allow
Change passwords automatically

パスワード変更プロセスで、ユーザーに与えられる制御のレベルを指定します。

オプション:

  • No - full control: ESSO-LMはパスワードを自動的に変更しません。ユーザーがパスワード変更を開始する必要があります。
  • Yes, with user confirmation - partial control: ESSO-LMはパスワード変更を自動的に開始し、ユーザーに対し、自動生成パスワードを受け入れるか、別のパスワードの生成を要求するか、パスワードを手動で入力するかを要求します。
  • Yes, without user confirmation - no control: ESSO-LMはパスワード変更を自動的に開始し、パスワードを生成し、ユーザーの介入を許可することなくアプリケーションに生成したパスワードを送信します。
Notify Primary Logon Method

資格証明共有グループの資格証明を変更したときに、現在の認証方式に資格証明共有を適用します。

オプション:

  • Do not notify the Authenticator（デフォルト）
  • Notify the Authenticator

現在、資格証明共有は、Windows Authenticatorバージョン2およびLDAP Authenticatorバージョン2でのみサポートされています。

エンド・ユーザーに新しいパスワードが通知されないため、共有グループのアプリケーションのパスワードを変更するときには、自動パスワード生成を使用しないでください。


End-User Experience\Response

レスポンス（エンド・ユーザー側の動作設定）

一般的な「Response」設定では、エンド・ユーザーが新しいログオンの資格証明を指定した場合、およびログオンを必要とするアプリケーションが検出された場合のエージェントの動作を制御します。また、管理者以外のユーザーが作成したアプリケーションのログオンをエンド・ユーザーが作成できるかどうかも制御できます。

Automatically logon to applications

アプリケーションに自動的に資格証明を提供します。

オプション:

  • Do not automatically provide credentials
  • Automatically provide credentials（デフォルト）
「Automatically provide credentials」を選択すると、「Agent's Response settings」タブの「Auto-Recognize」設定をユーザーがオフする機能が無効になります。
Display "Add another logon" checkbox

追加ウィザードの「Add another logon」チェック・ボックスの表示を有効または無効にします。

オプション:

  • Disable（デフォルト）
  • Enable

Enable Auto-Prompt

新しいアプリケーションが検出された場合に、ログオンを追加することをユーザーに自動的に求めるかどうかを指定します。

オプション:

  • Yes。資格証明が格納されていないアプリケーションが起動すると、「New Logon」ダイアログ・ボックスが表示されます。（デフォルト）
  • No。「New Logon」ダイアログ・ボックスを表示せずに、資格証明が格納されていないアプリケーションを起動します。

Limit user to predefined applications

ユーザーは、事前定義されていないアプリケーションの資格証明を追加できます。

オプション:

  • Predefined apps only。ユーザーは、不明なアプリケーションの資格証明を追加できません。
  • Unlimited。ユーザーは、不明なアプリケーションの資格証明を追加できます（デフォルト）。

Logon to waiting applications upon agent startup

エージェントの起動時に、すでにログオン・フォームが存在するWindowsアプリケーションまたはJavaアプリケーションに資格証明を送信できます。

エージェントは、ポーリングを使用してログオン・エントリを導出するWebアプリケーションおよびホスト/メインフレーム・アプリケーションには常に資格証明を送信します。これらのアプリケーションは、この設定の影響を受けません。

オプション:

  • Do not logon（デフォルト）
  • Logon at startup
Prohibit canceling the addition of new logons

資格証明の入力を遅延するために「Cancel」ボタンをクリックする、または「New Logon」ダイアログ・ボックスを閉じるという選択肢をユーザーに与えるかどうかを指定します。これにより、現在のアプリケーションに対するアクセスが許可され、次回の適切なインスタンスで資格証明を入力するようにユーザーは再度要求されます。

オプション:

  • No。ユーザーはアプリケーション・ログオンを遅延できます。（デフォルト）
  • Yes。ユーザーはアプリケーション・ログオンを遅延できません。

Prohibit disabling the addition of new logons

「New Logon」ダイアログ・ボックスで「Disable」ボタンが使用可能かどうかを指定します。ユーザーはアプリケーションの資格証明の追加を永久に拒否できます。アプリケーションを無効にすると、そのアプリケーションはエージェント設定の「Exclusions」リストに追加されます。

オプション:

  • Yes。ユーザーはアプリケーションを除外できません。
  • No。ユーザーはアプリケーションを除外できます。（デフォルト）

SendKeys Event Interval

SendKeysキー・イベント間で許可する最小時間を指定します。キーストロークが失われることがある東部言語でこれは特に役立ちます。

オプション:

  • Best Speed (0 ms)
  • Typical For Eastern Languages (60 ms)
  • Use For Slow System (80 ms)
  • Use For Very Slow System (120 ms)

ESSO-LMは、ジャーナル・フックSendKeysを使用した資格証明の送信をサポートしていません。

Utilize the just-added Logon

アプリケーションの構成後に、そのアプリケーションにログオンするかどうかを指定します（その資格証明を追加します）。

オプション:

  • Do not log on to an application after adding its credentials.
  • Log on to an application after adding its credentials（デフォルト）


End-User Experience\Response\Error Loop

エラー・ループ（「End-User Experience」-「Response」）

「Error Loop」設定では、指定した資格証明が正しくない場合のエージェントのデフォルト動作を制御します。ユーザーがログオンの作成時に間違ったパスワードを入力したり、別のコンピュータからアプリケーション・パスワードを変更した場合は、通常、ログオン・エラーが発生します。ログオン・エラーが発生した場合は、「Logon Error」ダイアログ・ボックスが表示され、ユーザーは正しい資格証明を入力および保存できます。

「Error Loop」コントロールを使用して、次のアプリケーション・タイプ用にエラー・ループを設定します。

Windows

Web

ホスト/メインフレーム

特定のアプリケーションにエラー・ループを設定するには、「Applications」>「Error Loop」を選択します。
Maximum retries before prompting | 「Logon Error」ダイアログ・ボックスを表示するまでに、（初回の試行後）再試行を許可する最大回数を指定します。デフォルトは1です。この設定は、資格証明セットごとに適用されます。
Maximum time for retries before prompting | 「Logon Error」ダイアログ・ボックスを表示するまでに、連続ログオン試行を許可する最大時間（秒）を指定します。デフォルトは30です。この設定は、資格証明セットごとに適用されます。
Require password confirmation when modifying password | 「Logon Error」ダイアログ・ボックスに「Confirm Password」フィールドを表示するかどうかを指定します。デフォルトでは、パスワード確認が必須になっています。


End-User Experience\Response\Host/Mainframe Apps

ホスト/メインフレーム・アプリケーション（「End-User Experience」-「Response」）

「Host/Mainframe Response」設定では、ホスト/メインフレーム・アプリケーションと連携する場合のエージェントの動作を制御します。

16-bit screen capture attempts

16ビット・スクリーン・キャプチャの試行回数。割り当てられた回数の試行に失敗した場合、32ビット方式に戻します。（デフォルトは5です）

Credential Request Delay Interval

ユーザーにメインフレーム・セッション用のログオンの作成を求めるまでの間隔（ミリ秒）。

ユーザーがメインフレーム・セッションにログオンしようとしたものの、その対応する構成済アプリケーションに保存済パスワードがない場合には、ESSO-LMは、次のような質問を表示します。「There are no matching Logons for this mainframe session.」「Would you like to create one now?」ユーザーが「No」を選択した場合は、次回ユーザーがメインフレーム画面で任意キーを押したときに、ESSO-LMは再度ユーザーに同じ質問を表示します。この遅延設定は、ESSO-LMが再度質問を表示するまで待機する時間です（デフォルトは60000です）。

Host/Mainframe support

ホスト/メインフレーム・サポートを有効にします。詳細は、メインフレーム・アプリケーションの追加に関する項を参照してください。

オプション:

  • Host/mainframe support disabled.
  • Host/mainframe support enabled（デフォルト）

Polling Interval

エージェントがホスト・エミュレータにインスタンス間で変更が加えられているかどうかを確認する間隔（ミリ秒）。値を低くすると、使用するCPU時間が増えます。値を高くすると、画面が表示されてからエージェントが資格証明を提供するまでの時間が長くなります（デフォルトは700です）。


End-User Experience\Response\\JavaApps

Javaアプリケーション（「End-User Experience」-「Response」）

「Java Apps Response」設定では、Javaアプリケーションと連携する場合のエージェントの動作を制御します。

Delay after Java runtime startup | Javaの起動時に、JHOがウィンドウ・イベントをリスニングするまでに待機する時間（ミリ秒）。遅延を追加すると、Javaの実行時の初期化で発生する時間の競合を解決できます。デフォルトは0です。
Delay between retries | JHOが次の再試行まで待機する時間（ミリ秒）。デフォルトは500です。
Excluded Java versions | 正規表現としてリストされている、除外するJavaのバージョン。1行に1つの表現を入力します。 これはESSO-LMバージョン11.1.1.1.0での新しい設定です。
Maximum times to retry credential injection | 資格証明挿入の再試行回数。デフォルトは0です。
Time allowed for Java applets to load | Javaアプレットがブラウザに完全にロードされるまでエージェントが待機する最大時間（秒）。デフォルトは6です。


End-User Experience\Response\Web Apps

Webアプリケーション（「End-User Experience」-「Response」）

「Web Applications Response」設定では、Webアプリケーションと連携する場合のエージェントの動作を制御します。

一部のWebアプリケーションには、起動するたびに変わる項目が含まれるため、動的なWebページの再スキャン、変更の検出および適切な応答を行うために、Webテンプレートを構成できます。

Activate Tab

ログオン・フィールドを識別するタブのアクティブ化を有効/無効にします。
Allowed Dynamic Web Pages | エージェントが許可する動的なWebページを指定します。「...」ボタンをクリックして、これらのURLに一致する正規表現を入力します。
Allowed Web Pages

エージェントが許可するWebページを指定します。「...」ボタンをクリックして、URLに一致する正規表現を入力します。

この機能は、事前定義されたアプリケーションまたはWebアプリケーションにユーザーを制限する場合にのみ使用します。

Applications to ignore

BHOがログオンの検索時にスキップするアプリケーションのカンマ区切りリスト。

Border Appearance

Web資格証明フィールドの枠線のデフォルトの色、サイズおよびスタイルを設定します（デフォルトでは、赤の6ピクセルの実線）。詳細は、「ブラウザの外観」を参照してください。

Limit user to predefined Web apps

管理者によって事前定義されていないWebアプリケーション（不明なアプリケーション）の資格証明をユーザーが追加することを許可するかどうかを示します。

オプション:

  • Predefined apps only: 管理者が指定したWebアプリケーションにのみ応答します。ユーザーは、不明なWebアプリケーションの資格証明を追加できません。
  • Unlimited: すべてのWebアプリケーションに応答します。（デフォルト）
  • Manually add undefined: 管理者によって指定されていないWebアプリケーションの資格証明をユーザーが追加できます。
  • この設定は「End-User Experience」>「Response」ページの「Limit user to predefined applications」と連携して動作します。これらの設定は、次のように連携して動作します。
    • 「Limit user to predefined applications」が「Limit」に設定されている場合:
      この設定の設定値にかかわらず、ユーザーは事前定義されたWindowsアプリケーションおよびWebアプリケーションに制限されます。
    • 「Limit user to predefined applications」が「Do not Limit」に設定されていて、この設定が「Limit」に設定されている場合:
      ユーザーは事前定義されたWebアプリケーションに制限されます。ユーザーは、不明なWindowsアプリケーションをその場で追加できます。

    Respond to IE Modal Dialogs

    モーダル・ダイアログまたはHTMLアプリケーションとして表示するWebページにエージェントが応答できるようにするには、この設定を有効にします。

    Registry Location: Extensions\AccessManager\BHO:RespondToIEModalDialogs

    Scroll Into View

    ログオン・フィールドを表示するために、ブラウザ・ウィンドウのスクロールを有効/無効にします。

    Show Border

    ログオン時にWebフォームの資格証明フィールドの周囲にハイライトした枠線を表示します。

    オプション:

    • Disable the border around fields.
    • Enable the border around fields（デフォルト）

    URL Matching Precision

    一致基準として使用するURLのレベルの数。

    オプション:

    （Web URLの場合、http://mail.company.com）

    • Match to *company.com（デフォルト）
    • Match to *mail.company.com
    Web Pages to Ignore | エージェントが無視する必要があるWebサイトのカンマ区切りのリスト。「...」をクリックして、これらのURLに一致する正規表現を入力します。


End-User Experience\Response\Windows Apps

Windowsアプリケーション（「End-User Experience」-「Response」）

「Windows Applications Response」設定では、Windowsアプリケーションと連携する場合のエージェントの動作を制御します。

Ignored Window Classes for Applications

エージェントがアプリケーションとして認識しないウィンドウ・クラス名のリスト。この設定では、ESSO-LMに対して特定のウィンドウ・クラスをグローバルに無視するように指示できます。

Limit user to predefined Windows apps

管理者によって事前定義されていないWindowsアプリケーション（不明なアプリケーション）の資格証明をユーザーが追加することを許可するかどうかを示します。

オプション:

  • Predefined apps only。ユーザーは、不明なWindowsアプリケーションの資格証明を追加できません。
  • Unlimited。ユーザーは、不明なWindowsアプリケーションの資格証明を追加できます（デフォルト）。

この設定は、「End-User Experience」>「Response」の「Limit user to predefined applications」と連携して動作します。これらの設定は、次のように連携して動作します。

  • 「End-User Experience」> 「Response」>「Limit user to predefined applications」が「Predefined apps only」に設定されている場合:
    この設定の設定値にかかわらず、ユーザーは事前定義されたWindowsアプリケーションに制限されます。
  • 「End-User Experience」> 「Response」>「Limit user to predefined applications」が「Unlimited」に設定されていて、この設定が「Predefined apps only」に設定されている場合:
    ユーザーは事前定義されたWindowsアプリケーションに制限されます。ユーザーは、不明なWebアプリケーションをその場で追加できます。

Retry for a Window Title Match

表示が遅いダイアログ・ボックスまたはアプリケーションでは、この設定はエージェントがウィンドウ・タイトルの一致を何回試みるか（1/2秒間隔）を示します。ウィンドウ・タイトルがこの時間の後で変更された場合、変更は無視されます。デフォルトは6です。

Supported Window Classes for Applications

エージェントがアプリケーションとして認識するウィンドウ・クラス名のリスト。この設定は、エージェントをこのリストに制限することによってパフォーマンスを高めるために用意されています。動的なウィンドウ・クラスのサポートを有効にするには、デフォルト設定を削除してこの値をNULLに設定します。デフォルトは、#32770;Dialog; ThunderRT5FormDC; ThunderRT6FormDCです。

Supported Window Classes for Services

エージェントがWindowsサービスとして認識するウィンドウ・クラス名のリスト。この設定は、エージェントをこのリストに制限することによってパフォーマンスを高めるために用意されています。動的なウィンドウ・クラスのサポートを有効にするには、デフォルト設定を削除してこの値をNULLに設定します。デフォルトは、#32770;Dialog; ThunderRT5FormDC; ThunderRT6FormDCです。


End-User Experience\Setup Wizard

設定ウィザード（エンド・ユーザー側の動作設定）

「Setup Wizard」設定では、はじめて使用する場合に起動される「Setup Wizard」の動作を制御します。詳細は、「はじめて使用する場合」を参照してください。

Enable/disable First-Time-Use (FTU) wizard

はじめて使用する場合の呼出し時に「Setup Wizard」を起動するかどうかを制御します。

オプション:

  • Do not hide（デフォルト）
  • Hide

複数の認証方式（プライマリ・ログオン方法）をインストールした場合は、リストに最初に記載された認証方式が、自動的にエンド・ユーザーのプライマリ・ログオン方法として選択されます。

バルク追加機能を使用するために、FTUウィザードを有効にしておく必要があります。

Selected Primary Logon

プライマリ・ログオン方法として選択したログオン方法を有効にし、それ以外のインストール済のログオン方法を非表示にします。デフォルトは選択なしです（エンド・ユーザーが各自のプライマリ・ログオン方法を選択します）。

プライマリ・ログオン方法の選択メニューを非表示にするには、「Enable/Disable First-Time-Use (FTU) Wizard」設定を使用します。プライマリ・ログオン方法の選択ページが非表示で、この設定が空白である場合は、リストに最初にインストールされたログオン方法が自動的に選択されます。

Skip "selection" page if only one Primary Logon Method installed

認証方式を1つのみ（プライマリ・ログオン方法）インストールした場合は、「Setup Wizard」で「Select Primary Logon Method」手順を非表示にします。

オプション:

  • Do not hide/skip the Select step of the Setup Wizard（デフォルト）
  • Hide/skip the Select step of the Setup Wizard


End-User Experience\Advanced

拡張（エンド・ユーザー側の動作設定）

「Advanced End-User Experience」設定では、ログオン実行時のエージェントの外観、および「Logon Manager」ダイアログ・ボックスと「Logon Chooser」ダイアログ・ボックスに表示される情報の外観を制御します。

Logon Animation's duration

アニメーション・スピナーを表示する（応答を一時停止する）時間（ミリ秒）。値を0（デフォルト）にすると、スピナーは無効になります。

Logon Chooser Columns

「...」をクリックすると「Edit Columns」ダイアログ・ボックスが表示され、エージェントの「Logon Chooser」ダイアログ・ボックスに表示する列の外観および順序を選択できます。デフォルトは「Username/ID」、「Application Name」および「Description」です。

  • Username/ID
  • Application Name
  • Description

My Accounts columns for "Details" view

「...」をクリックすると「Edit Columns」ダイアログ・ボックスが表示され、エージェントの「Logon Manager」に表示する列の外観および順序を選択できます。

  • Application Name
  • URL/Module
  • Username/ID
  • Password
  • Modified
  • Last Used
  • Description
  • Reference
  • Group
  • Third Field
  • Fourth Field

デフォルトでは、「Third Field」および「Fourth Field」を除き、すべての列が前述の順序で表示されます。

My Accounts Refresh button

「Logon Manager Refresh」ボタンを表示します。

オプション:

  • Disable the Refresh button
  • Enable the Refresh button（デフォルト）

User can shut down ESSO-LM from the System Tray Icon Menu

この設定を有効（デフォルト）にすると、エンド・ユーザーはシステム・トレイ・アイコン・メニューから「Shutdown ESSO-LM」を選択して、エージェントを停止できます。無効にすると、このメニュー項目は使用できません。

オプション:

  • Do not allow shutdown from menu
  • Allow shutdown from menu（デフォルト）


End-User Experience\Advanced\Performance

パフォーマンス（「End-User Experience」）

「Advanced Performance」設定では、エージェントがいつどのようにユーザー資格証明およびその他のデータを保存するかを微調整できます。1番目および3番目の設定は、「Store user data on disk in encrypted file」を「Do not store」に設定している場合にのみ適用されます。これにより、エージェントのパフォーマンスが最適化されます。ただし、この設定はデフォルトでは、 ESSO-LMの以前のバージョンとの互換性のため、「Store user data in disk file」に設定されています。

Increase user data storage priority

ユーザー・データ（資格証明など）に対する変更を保存するための処理の優先順位を設定します。ワークステーションのCPUの使用率が頻繁に100%になる場合にのみ、「Increase processing priority」に設定します。

オプション:

  • Increase processing priority
  • Do not increase processing priority（デフォルト）

Maxiumum time before forced SSO process shutdown (ms)

SSOプロセス（satellites）が強制停止されるまで待機する時間間隔（ミリ秒）を設定します。

ESSO-LMが停止に時間がかかり、停止時間が問題となる場合に役に立ちます。

この設定は、デフォルトの5000ミリ秒（5秒）から最小値の500ミリ秒（0.5秒）の範囲で調整できます。

Set delay for first update (after startup) to stored user data (ms)

ESSO-LMを起動してから内部データベースにユーザー・データ（資格証明など）の変更を書き込むまでの待機時間（ミリ秒）を設定します。デフォルトは5000ミリ秒です。

Set delay for storing user data (ms)

内部データベースにユーザー・データ（資格証明など）の変更を書き込むまでの待機時間（ミリ秒）を設定します。デフォルトは500ミリ秒です。

Store user data on disk in encrypted file

ユーザー・データ（資格証明など）のコピーを各ユーザーのApplication Dataフォルダの暗号化されたデータベース・ファイルにローカルに保存します。

オプション:

  • Store user data in a disk file（デフォルト）
  • Do not store user data in disk file


特別なタスク（「End-User Experience」>「Advanced」）

「Special Tasks」設定では、特定のエージェント・アクションが発生したときに実行するタスク（コマンドのリスト）を制御します。タスクのセットごとに、チェック・ボックスを選択し「...」をクリックして「Edit List」ダイアログ・ボックスを開きます。各行にコマンドを1つ入力します。[Enter]キーを押して各行を終了します。他のデリミタ文字を使用しないでください。1つずつ順に実行されます。

タスクがすべて完了するまで、ESSO-LMは応答しません。

After Agent starts up | バックグラウンド・タスクが開始されるたびに実行するコマンド（タスクバー・トレイ・アイコン）。
Before Agent starts | エージェント・プロセスの開始前に実行されるコマンド。このようなタスクが失敗した場合（License:PreCheckに作成されるレジストリ値で示されます）、エージェントは続行しません。
When logons are deleted | ユーザーがアプリケーション構成を削除するたびに実行されるコマンド。
When logons change (add, delete, copy, modify) | ユーザーが資格証明および構成を変更するたびに実行されるコマンド。


レポーティング拡張

レポーティング

この設定を使用して、レポーティング拡張のパスを指定します。

Extension Location ReportingExt.dllを指すレポーティング・データベース拡張のパス\ファイル名。


Event Logging\SysLog

Syslog（イベント・ロギング）

「Syslog」設定では、エージェントがプログラム・イベントを記録する方法を制御します。

Cache Retry Interval

Syslog拡張に対する再試行間隔（分）を指定します。デフォルトは30分です。

Extension Location

Syslog拡張へのパスを指定します。デフォルトのパスは、C:\Program Files\Passlogix\v-GO SSO\Plugin\EventMgr\SyslogExt.dllです。

Of logged events, limit Syslog extension to:

（rootフィルタ設定によって記録されたイベントのうち）Syslog拡張に記録するイベントを区切るイベント・ロギング・フィルタ。「...」ボタンをクリックして、記録するイベントのリストを表示します。

Send messages to which host?

メッセージを送信するホスト名を指定します。ホスト名またはドット付きのIP v4アドレスを使用できます。0.0.0.0を使用すると、syslogデーモンへの送信が無効になります。255.255.255.255を使用すると、ブロードキャスト・メッセージを受信するように設定されているすべてのデーモンに送信されます。ブロードキャストはルーターを越えることはできないため、送信先はローカル・ネットワーク上である必要があります。デフォルトはlocalhostです。

Send messages to which port?

syslogメッセージの接続先ポートを番号で指定します。デフォルトのポートは1468です。

Send messages via TCP or UDP?

メッセージの送信に使用するプロトコルをTCPまたはUDPから指定します。UDPプロトコルはコネクションレスのため、指定されたホスト名およびポートでsyslogデーモンが接続できるかどうかを判断することはできないことに注意してください。

UseTCPパラメータを「Use UDP」に設定すると、Syslog拡張は成功および失敗のどちらの場合でもS_OKを返します。Syslog拡張が正しい状態を返すようにする必要がある場合は、SyslogデーモンでTCPを有効にして、このパラメータを「Use TCP」に設定します。

オプション:

  • TCP (use 1) [default]
  • UDP (use 0)


Event Logging\Database

データベース（イベント・ロギング）

「Database Event Logging」メニューを使用して、ログ・データを送信するサーバー・インスタンスおよび表名と、データベースに書き込むフィールドを指定します。

フィールドに加えて、ユーザーはサーバー・インスタンスおよび表名を指定する必要があります。これらは、以前はデータベース設定で定義されていたので、データベース・フィールドには不要でした。各フィールドにデータベースおよび表名が指定されていないと、イベントはデータベースへ書き込まれません。

「XML File Event Logging」設定では、ローカルにログを記録するイベントを指定できます。また、ローカル・ロギング拡張へのデフォルト・パスを変更し、ロギング・キャッシュの再試行間隔を変更できます。

Cache Retry Interval | ローカル（XML）・ファイル・ロギングの再試行間隔（分）。デフォルトは30分です。
Default Server | 他のサーバーが指定されない場合にデータベース・ログが書き込まれるサーバー。（OLE DB接続文字列）
Default Table | 他の表が指定されない場合にデータベース・ログが書き込まれる表。
Extension location | ローカル（XML）・ファイル・ロギング拡張XMLEvent.dllへのパス/ファイル名。（デフォルトのパスは、C:\Program Files\Passlogix\v-GO SSO\Plugin\EventMgr\XMLEvent.dllです）
Events to log | （rootフィルタ設定によって記録されたイベントのうち）データベース拡張に記録するイベントを区切るイベント・ロギング・フィルタ。「...」ボタンをクリックして、記録するイベントのリストを表示します。
Servers | 「...」ボタンをクリックして、データベース・サーバーに入るウィンドウを開きます。1行に1つずつで、OLE DBの書式（Provider=sqloledb; Data Source=myServerName; Initial Catalog=myDatabaseName; User Id=myUsername; Password=myPassword）が使用されます。

イベントをデータベースに書き込むためには、データベース・フィールドにデータベース・インスタンスおよび表名を指定する必要があります。


GlobalAS_Event Logging_Database Event Fields

イベント・フィールド

「Event Fields」画面を使用して、表示させるフィールドにデータを割り当てます。

データベース・インスタンスまたは表名を指定しない場合、「Database」画面で指定したデフォルトのデータベースおよび表にデータが書き込まれます。

AppName | ボックスを選択し、AppNameを書き込むフィールドの番号を割り当てます。
Category | ボックスを選択し、Categoryを書き込むフィールドの番号を割り当てます。
Field1 | ボックスを選択し、Field1に表示するデータ・フィールドを指定します。
Field10 | ボックスを選択し、Field10に表示するデータ・フィールドを指定します。
Field2 | ボックスを選択し、Field2に表示するデータ・フィールドを指定します。
Field3 | ボックスを選択し、Field3に表示するデータ・フィールドを指定します。
Field4 | ボックスを選択し、Field4に表示するデータ・フィールドを指定します。
Field5 | ボックスを選択し、Field5に表示するデータ・フィールドを指定します。
Field6 | ボックスを選択し、Field6に表示するデータ・フィールドを指定します。
Field7 | ボックスを選択し、Field7に表示するデータ・フィールドを指定します。
Field8 | ボックスを選択し、Field8に表示するデータ・フィールドを指定します。
Field9 | ボックスを選択し、Field9に表示するデータ・フィールドを指定します。
Time Stamp | ボックスを選択し、Time Stampを書き込むフィールドの番号を割り当てます。
Type | ボックスを選択し、Typeを書き込むフィールドの番号を割り当てます。


Event Logging\Windows Event Viewer

Windowsイベント・ビューア（イベント・ロギング）

「Windows Event Viewer」設定では、イベント・ロギングをリモート・サーバーで実行するように設定できます。

Windows Event Logging Server

Windowsイベント・ロギング拡張のサーバー名（先頭に\\文字を指定しないでください）。このサーバー名を指定しないと、ロギングはローカル・コンピュータで実行されます。

サーバーは、アクセス権および制限に応じて、ユーザーのアカウントおよびユーザーのコンピュータとの信頼関係を持つ必要があります。


Event Logging\Windows Event Viewer\Advanced

拡張（「Event Logging」 - 「Windows Event Viewer」）

「Advanced Windows Event Viewer」設定では、ログを記録するイベントを指定できます。また、Windowsイベント・ロギング拡張およびWindowsイベント・メッセージ・コンポーネントへのデフォルト・パスを変更し、ロギング・キャッシュの再試行間隔を変更できます。

Cache Retry Interval | Windowsイベント・ロギングの再試行間隔（分）。デフォルトは30分です。
Extension location | Windowsイベント・ロギング拡張WindowsEvent.dllへのパス/ファイル名。 （デフォルトのパスは、C:\Program Files\Passlogix\v-GO SSO \Plugin\EventMgr\WindowsEvent.dllです）
Of logged events, limit for Windows server to | Windows Event Serverにログを記録するイベントを指定するための「Event Logging Filter」を表示します。「...」をクリックしてイベントのチェックリストを表示します。


Event Logging\XML File

XMLファイル（イベント・ロギング）

「XML File Event Logging」設定では、ローカルにログを記録するイベントを指定できます。また、ローカル・ロギング拡張へのデフォルト・パスを変更し、ロギング・キャッシュの再試行間隔を変更できます。

Cache Retry Interval | ローカル（XML）・ファイル・ロギングの再試行間隔（分）。デフォルトは30分です。
Extension location | ローカル（XML）・ファイル・ロギング拡張XMLEvent.dllへのパス/ファイル名。 （デフォルトのパスは、C:\Program Files\Passlogix\v-GO SSO \Plugin\EventMgr\XMLEvent.dllです）
Of logged events, limit for XML file to | ローカル（XML）・ファイル・ロギング拡張にログを記録するイベントを指定するための「Event Logging Filter」を表示します。「...」をクリックしてイベントのチェックリストを表示します。


Event Logging\Advanced

拡張（イベント・ロギング）

「Advanced Event Logging」設定では、ロギング拡張およびイベント・メッセージ・コンポーネントへのデフォルト・パスを変更できます。また、ロギング・キャッシュの再試行間隔およびサイズを変更できます。

Cache Limit | キャッシュするイベント・ログ・エントリの最大数。デフォルトは200エントリです。
Cache Retry Interval | すべてのイベント・ロギング拡張の再試行間隔（分）。デフォルトは30分です。
Event Server Message Library location | Windows Event Viewerでイベントの表示に使用されるイベント・メッセージ・ライブラリSSOeventmessage.dllへのパス/ファイル名。 （デフォルトのパスは、C:\Program Files\Passlogix\v-GO SSO \Plugin\EventMgr\SSOeventmessage.dllです）
Extension location | イベント・ロギング拡張eventmgr.dllへのパス/ファイル名。 （デフォルトのパスは、C:\Program Files\Passlogix\v-GO SSO \Plugin\EventMgr\eventmgr.dllです）
Shutdown Delay | 停止イベントがイベント・ログに書き込まれるまで待機する最大時間（ミリ秒）。 デフォルトは0で、書込みが完成するまで待機します。
Shutdown Immediately | 設定した場合、停止イベントがイベント・ログに書き込まれるまで待機しません。 リセットした場合（デフォルト）、停止イベントがイベント・ログに書き込まれるまで待機します。


Primary Logon Methods\MultiAuth|Enrollment

登録（「Primary Logon Methods」\「Authentication Manager」）

「Authentication Manager Enrollment」設定では、マルチ認証方式プライマリ・ログオンで使用できるプライマリ・ログオン方法（認証方式）を指定します。

このページの設定によって、Authentication Manager をプライマリ・ログオン方法として選択した場合に、ユーザーが「First Time Use」ウィザードで特定のログオン方法を設定する必要があるかどうかが決まります。

各「Primary Logon Methods」について、次のいずれかを選択します。

  • Optional。ESSO-LMでは、このログオンを構成するか、またはスキップするかを選択できます。ユーザーがログオン要求を遅延した場合は、ESSO-LMによって再度要求されることはありません。
  • Incremental。 ESSO-LM では、このログオンを構成するか、またはスキップするかを選択できます。ユーザーがログオン要求を遅延した場合は、ESSO-LMによってアプリケーションが起動するたびに資格証明が要求されます。
  • Required。ユーザーはこのログオンを構成する必要があります。このログオンが構成されない場合、ユーザーは登録を完了できなくなります。
  • Disabled。ログオン方式は、FTUウィザードでユーザーに表示されません。
Entrust | ユーザーがプライマリ・ログオン方法として「Entrust」を設定する必要があるかどうかを選択します。
LDAP | ユーザーがプライマリ・ログオン方法として「LDAP」を設定する必要があるかどうかを選択します。
LDAP v2 | ユーザーがプライマリ・ログオン方法として「LDAP v2」を設定する必要があるかどうかを選択します。
Proximity Card | ユーザーがプライマリ・ログオン方法として「Proximity Card」を設定する必要があるかどうかを選択します。
Read-Only Smart Card | ユーザーがプライマリ・ログオン方法として「Read-Only Smart Card」を設定する必要があるかどうかを選択します。
RSA SecurID | ユーザーがプライマリ・ログオン方法として「RSA SecurID」を設定する必要があるかどうかを選択します。
Smart Card | ユーザーがプライマリ・ログオン方法として「Smart Card」を設定する必要があるかどうかを選択します。
Windows | ユーザーがプライマリ・ログオン方法として「Windows」を設定する必要があるかどうかを選択します。
Windows v2 | ユーザーがプライマリ・ログオン方法として「Windows v2」を設定する必要があるかどうかを選択します。


Primary Logon Methods\MultiAuth|Grade

グレード（「Primary Logon Methods」\「Authentication Manager」）

「Authentication Manager Grade」設定では、各プライマリ・ログオン方法の認証グレードを指定します。

認証グレードは数値です。

  • 認証グレードが有効になっており、グレード・レベルが指定されていない場合、認証グレードは自動的にグレード・レベル1に初期設定されます。
  • 高いグレード・レベルが指定されると、リクエストされる認証レベルが強くなります。
  • グレードのスケールは任意に構成できます。たとえば、予期された通常の使用例では、スケールは1から3になりますが、必要に応じて、1から5、または1からnにすることができます。1より小さいすべてのグレードは、1に変換されます。

Authentication Managerをプライマリ・ログオン方法として選択した場合、マルチ認証方式ログオンでは、使用した認証方式にグレードをマップすることで、認証グレードをサポートしています。

ユーザーが低すぎるグレード・レベルで資格証明にアクセスしようとする場合、より高いグレードで認証するように求められ、成功した場合のみアクセス権を取得できます。

ロックアウトは、ESSO-LMの通常の認証ロックアウト・ポリシーによって発生します。グレード別認証では、SSOのコア認証プロセスを使用するため、これは必然的に発生します。

ログオン方法ごとにグレード値（>=1）を数値で設定します。

Entrust | この設定は、認証グレードを「Entrust」に割り当てます。この値は、マルチ認証方式プライマリ・ログオンに使用されます。グレード値を数値で設定します（>=1）。
LDAP | この設定は、認証グレードを「LDAP」に割り当てます。この値は、マルチ認証方式プライマリ・ログオンに使用されます。グレード値を数値で設定します（>=1）。
LDAP v2 | この設定は、認証グレードを「LDAP v2」に割り当てます。この値は、マルチ認証方式プライマリ・ログオンに使用されます。グレード値を数値で設定します（>=1）。
Proximity Card | この設定は、認証グレードを「Proximity Card」に割り当てます。この値は、マルチ認証方式プライマリ・ログオンに使用されます。グレード値を数値で設定します（>=1）。
Read-Only Smart Card | この設定は、認証グレードを「Read-Only Smart Card」に割り当てます。この値は、マルチ認証方式プライマリ・ログオンに使用されます。グレード値を数値で設定します（>=1）。
RSA SecurID | この設定は、認証グレードを「RSA SecurID」に割り当てます。この値は、マルチ認証方式プライマリ・ログオンに使用されます。グレード値を数値で設定します（>=1）。
Smart Card | この設定は、認証グレードを「Smart Card」に割り当てます。この値は、マルチ認証方式プライマリ・ログオンに使用されます。グレード値を数値で設定します（>=1）。
Windows | この設定は、認証グレードを「Windows」に割り当てます。この値は、マルチ認証方式プライマリ・ログオンに使用されます。グレード値を数値で設定します（>=1）。
Windows v2 | この設定は、認証グレードを「Windows v2」に割り当てます。この値は、マルチ認証方式プライマリ・ログオンに使用されます。グレード値を数値で設定します（>=1）。


Primary Logon Methods\MultiAuth|Order

順序（「Primary Logon Methods」\「Authentication Manager」）

「Primary Logon Methods」としてAuthentication Managerが選択されている場合、「Authentication Manager Order」設定では、インストールされているログオン方式が再認証時にエンド・ユーザーに表示される順序を指定します。

プライマリ・ログオン方法ごとに、FTU/ログオン順序でのログオン方法の位置を示す数値を選択または入力します。

Allowed number of logon methods | この設定では、ユーザーに表示されるログオン方法の最大数を設定できます。このログオン方式の数がユーザーに表示（およびスキップ）された後、「Choose Logon」ダイアログ・ボックスが表示されます。 デフォルトは1です。 この設定は、マルチ認証方式プライマリ・ログオンにのみ使用されます。
Entrust | この設定によって「Entrust」の並び位置が設定されます。これは、再認証時にエンド・ユーザーに「Entrust」を表示する順序となります。この設定は、マルチ認証方式ログオンにのみ使用されます。 デフォルトは4です。
LDAP | この設定によって、「LDAP」の並び位置が設定されます。これは、再認証時にエンド・ユーザーに「LDAP」を表示する順序となります。この設定は、マルチ認証方式ログオンにのみ使用されます。 デフォルトは3です。
LDAP v2 | この設定によって、「LDAP v2」の並び位置が設定されます。これは、再認証時にエンド・ユーザーに「LDAP v2」を表示する順序となります。この設定は、マルチ認証方式ログオンにのみ使用されます。 デフォルトは3です。
Proximity Card | この設定によって、「Proximity Card」の並び位置が設定されます。これは、再認証時にエンド・ユーザーに「Proximity Card」を表示する順序となります。この設定は、マルチ認証方式ログオンにのみ使用されます。 デフォルトは6です。
Read-Only Smart Card | この設定によって、「Read-Only Smart Card」の並び位置が設定されます。これは、再認証時にエンド・ユーザーに「Read-Only Smart Card」を表示する順序となります。この設定は、マルチ認証方式ログオンにのみ使用されます。 デフォルトは1です。
RSA SecurID | この設定によって、「RSA SecurID」の並び位置が設定されます。これは、再認証時にエンド・ユーザーに「RSA SecurID」を表示する順序となります。この設定は、マルチ認証方式ログオンにのみ使用されます。 デフォルトは6です。
Smart Card | この設定によって、「Smart Card」の並び位置が設定されます。これは、再認証時にエンド・ユーザーに「Smart Card」を表示する順序となります。この設定は、マルチ認証方式ログオンにのみ使用されます。 デフォルトは1です。
Windows | この設定によって、「Windows」の並び位置が設定されます。これは、再認証時にエンド・ユーザーに「Windows」を表示する順序となります。この設定は、マルチ認証方式ログオンにのみ使用されます。 デフォルトは2です。
Windows v2 | この設定によって、「Windows v2」の並び位置が設定されます。これは、再認証時にエンド・ユーザーに「Windows v2」を表示する順序となります。この設定は、マルチ認証方式ログオンにのみ使用されます。 デフォルトは2です。


Primary Logon Methods\LDAP\Required

必須（「Primary Logon Methods」 - 「LDAP」 - 「Required」）

「Required LDAP Primary Logon Methods」設定は、標準のLDAP認証を有効にするための主要なコントロールです。これらの設定は、エージェントがLDAPをプライマリ・ログオン方法として使用するために使用する必要があります。

Directory Type 特定のタイプのディレクトリ・サーバー。ディレクトリ・サーバーが示されていない場合は、「Generic LDAP Directory」を選択します。

Servers

computer[:port]形式で試行するサーバー（1行に1台のサーバー）。computerには、サーバー名またはIPを指定します。portを省略した場合は、デフォルト（SSLは636、SSL以外は389）が使用されます。例: 127.0.0.1127.0.0.1:456somewhereelse.com:8080 anotherplace.com

この拡張が機能するには、少なくとも1台のサーバーを指定する必要があります。

ポート値を指定する場合は、SyncManager\Syncs\%LDAP%:SSLFallbackを参照してください。

SSL

SSL経由で接続する場合に選択します。

オプション:

  • Connect without SSL (insecure) (default port #389)
  • Connect via SSL (default port #636)（デフォルト設定）

User Paths

ユーザー・アカウントの場所を示す完全修飾されたパス。検索するパスの数に制限はありません。この拡張機能では、ユーザー・アカウントを検索して、そのパスを順に検索します。見つからない場合は、ディレクトリ・ツリーが検索されます。

この拡張が機能するには、「Naming Attribute string」の値または「User Paths」の1つ以上の値を指定する必要があります。

「User Paths」を使用する場合は、「Alternate User ID location」を使用しないでください。


Primary Logon Methods\LDAP\Advanced

拡張（「Primary Logon Methods」 - 「LDAP」 - 「Advanced」）

「Advanced LDAP Primary Logon Methods」設定では、標準のLDAP認証を有効にする拡張オプションを制御します。

Active Directory: Domain name support enabled

Active Directoryドメイン名サポートを有効にします。エンド・ユーザーは、プライマリ・ログオンでドメイン名（domainname\usernameなど）を指定できます。また、管理者はデフォルト・ドメイン名を指定して（「Active Directory: Set domain name」を参照）、エンド・ユーザーがユーザー名のみでログオンできるようにすることができます。ドメインを指定しない場合は、ローカル・ワークステーションのドメインが使用されます。

オプション:

  • Do not use AD domain names（デフォルト）
  • Use AD domain names

Active Directory: Set domain name

ユーザー名/ID資格証明にドメインを指定していない場合に、プライマリ・ログオンに使用するActive Directoryドメイン名（domainname\usernameなど）。この設定は、「Active Directory: Domain name support enabled」を「Use AD domain names」に設定している場合にのみ使用されます。ドメイン名サポートが有効で、この設定が空白である（エンド・ユーザーがドメインを指定していない）場合は、ローカル・ワークステーションのドメインが使用されます。

Alternate User ID location

ユーザー名以外の属性でユーザーを検証するときに、該当するユーザー・オブジェクトが存在する場所を示します。

例:

ログオンの従業員ID番号でユーザーの認証を行い（empid属性に対する検証）、ユーザー・オブジェクトがou=people,dc=computerにある場合は、この場所を次のように設定します。

empid=%user,ou=people,dc=computer

次のようには設定しないでください。

uid=user,ou=people,dc=computer

Novell eDirectoryの場合、「Alternate User ID location」は、次のように設定します。

uid=%user,path to the object%

「Naming Attribute string」を使用する場合は、「User Paths」を使用し、「Alternate User ID location」は使用しないでください。

BIND Timeout

LDAP BINDコールをタイムアウトする時間（ミリ秒）（デフォルトはオペレーティング・システムによって異なります）。

Change Password Window SubTitle Name

この設定は、この認証方式のLDAP v1変更パスワード・ウィンドウのサブタイトル名をカスタマイズする場合に使用します。

このエントリは必須ではありません。
Change Password Window Title Name

この設定は、この認証方式のLDAP v1変更パスワード・ウィンドウのタイトル名をカスタマイズする場合に使用します。

このエントリは必須ではありません。
Custom image for authentication prompt

ファイル名を含めて、イメージの完全修飾されたパスを入力するか、「...」をクリックし、イメージ・ファイルを参照します。

このイメージに設定されたディメンションは、幅は300ピクセル、高さは100ピクセルです。これらのディメンションは変更できません。イメージがこれより小さい場合はこの領域の中央に配置され、大きい場合は4辺が同等に切り取られます。

これはESSO-LMバージョン11.1.1.1.0での新しい設定です。
Enable Directory Search for users ユーザー・アカウントのディレクトリ検索を有効または無効にします。指定されたパスにユーザー・アカウントが見つからない場合は、その場所から下方向にディレクトリ・ツリーが検索されます。「User Paths」または「Alternate User ID location」のいずれを使用していても、検索は実行されます。

Naming Attribute string

「User Paths」の前に付加する文字列。

ユーザーのドメイン名が次の形式である場合は必須です。

cn=%UserName%,ou=people,dc=computer&n bsp;

次の形式の場合は、必須ではありません。

namingattribute=%UserName%,ou=people,dc=computer

（namingattributeは任意の文字列です)。必要に応じて、cnに設定します。

Novell eDirectoryの場合、「Alternate User ID location」はuid=%user,path to the object%のように設定します。

「Naming Attribute string」を使用する場合は、「User Paths」を使用し、「Alternate User ID location」は使用しないでください。

Share credentials with other Primary Logon Methods

この設定によって、同じ資格証明を持つ認証方式を使用する場合に、認証が重複して発生しないようにできます。

この設定では認証方式の資格証明をリンクするため、資格証明が同じ場合は、ユーザーが再入力しなくてもその資格証明が再利用されます。

資格証明を共有する認証方式のカンマ区切りリストを入力します（例: WinAuth, MSAuth）。

他の認証方式名を指定するには、その認証方式のレジストリ（HKLM\Software\Passlogix\AUIの下）にリストされている名前を参照してください。
Share credentials with synchronizers

この設定は、認証方式と1つ以上のシンクロナイザが同じ資格証明を使用する場合に、二重認証が発生しないようにする方法を提供します。

資格証明を共有するシンクロナイザののカンマ区切りリストを入力します（例: ADEXT, LDAPEXT）。

他のシンクロナイザ名を指定するには、そのシンクロナイザのレジストリ（HKLM\Software\Passlogix\Extensions\SyncManagerの下）にリストされている名前を参照してください。
Show user path

有効にした場合、ユーザーが認証を求められると、「User path」フィールドが表示されます。

オプション:

  • Yes（デフォルト）
  • No

これはESSO-LMバージョン11.1.1.1.0での新しい設定です。

SSL Fallback

SSL接続に失敗したときのセキュアでない接続へのフォールバック。

オプション:

  • Do not connect if the SSL connection fails（デフォルト）
  • Connect without SSL (insecure) if the SSL connection fails

SSLFallbackを選択し、「Servers」に示されているサーバーのいずれかにポート指定が含まれている場合は、フォールバック・ポートを「Servers」の追加のエントリとして指定する必要があります。

例:

SSL接続に対してmycomputer.com:1272が指定されている場合は、次のように、追加のエントリがフォールバック・ポートを指す必要があります。

  • Server1=mycomputer.com:1272 : セキュアなSSLポート
  • Server2=mycomputer.com:389: フォールバック・ポート

Window Title Name

この認証方式のウィンドウのタイトル名をカスタマイズするには、この設定を使用します。

このエントリは必須ではありません。


Primary Logon Methods\LDAP v2\Required

必須（「Primary Logon Methods」 - 「LDAP version 2」 - 「Required」）

「Required LDAP v2 Primary Logon Methods」設定は、LDAPバージョン2認証を有効にするための主要なコントロールです。これらの設定は、エージェントがLDAP v2をプライマリ・ログオン方法として使用するために使用する必要があります。

Servers

computer[:port]形式で試行するサーバー（1行に1台のサーバー）。computerには、サーバー名またはIPを指定します。portを省略した場合は、デフォルト（SSLは636、SSL以外は389）が使用されます。たとえば、127.0.0.1 127.0.0.1:456 somewhereelse.com:8080 anotherplace.comなどです。注意: この拡張が機能するには、少なくとも1台のサーバーを指定する必要があります。

ポート値を指定する場合は、SyncManager\Syncs\%LDAP%:SSLFallbackを参照してください。

SSL

SSL経由で接続する場合に選択します。

オプション:

  • Connect without SSL (insecure) (default port #389)
  • Connect via SSL (default port #636)（デフォルト設定）

User Paths

ユーザー・アカウントの場所を示す完全修飾されたパス。検索するパスの数に制限はありません。この拡張機能では、ユーザー・アカウントを検索して、そのパスを順に検索します。見つからない場合は、ディレクトリ・ツリーが検索されます。注意: この拡張が機能するには、「Naming Attribute string」の値または「User Paths」の1つ以上の値を指定する必要があります。

「User Paths」を使用する場合は、「Alternate User ID location」を使用しないでください。


Primary Logon Methods\LDAP2\Advanced

拡張（「Primary Logon Methods」 - 「LDAP version 2」 - 「Advanced」）

「Advanced LDAP Primary Logon Methods」設定では、LDAPバージョン2認証を有効にする拡張オプションを制御します。

Alternate User ID location

ユーザー名以外の属性でユーザーを検証するときに、該当するユーザー・オブジェクトが存在する場所を示します。

例:

ログオンの従業員ID番号でユーザーの認証を行い（empid属性に対する検証）、ユーザー・オブジェクトがou=people,dc=computerにある場合は、この場所を次のように設定します。

empid=%user,ou=people,dc=computer

次のようには設定しないでください。

uid=user,ou=people,dc=computer

Novell eDirectoryの場合、「Alternate User ID location」は、次のように設定します。

uid=%user, path to the object%

「Alternate User ID location」を使用する場合は、「Naming Attribute string」および「User Paths」を使用しないでください。

BIND Timeout

LDAP BINDコールをタイムアウトする時間（ミリ秒）（デフォルトはオペレーティング・システムによって異なります）。

Custom image for authentication prompt

ファイル名を含めて、イメージの完全修飾されたパスを入力するか、「...」をクリックし、イメージ・ファイルを参照します。

このイメージに設定されたディメンションは、幅は300ピクセル、高さは100ピクセルです。これらのディメンションは変更できません。イメージがこれより小さい場合はこの領域の中央に配置され、大きい場合は4辺が同等に切り取られます。

これはESSO-LMバージョン11.1.1.1.0での新しい設定です。

Include in "LDAP" credential sharing group

LDAP認証方式からLDAP資格証明共有グループの資格証明への資格証明変更を共有します。この設定では、資格証明共有を有効にする必要があります。共有グループの設定を参照してください。

オプション:

  • Do not share credential changes from the LDAPauth authenticator to credentials in the Group LDAP
  • Share credential changes from the LDAPauth authenticator to credentials in the Group LDAP（デフォルト）

Naming Attribute string

UserPathsの前に付加する文字列。ユーザーのドメイン名が次の形式である場合は必須です。

cn=%UserName%,ou=people,dc=computer&n bsp;

次の形式の場合は、必須ではありません。

namingattribute=%UserName%,ou=people,dc=computer

（namingattributeは任意の文字列です)。必要に応じて、cnに設定します。

Novell eDirectoryの場合、「Alternate User ID location」はuid=%user,path to the object%のように設定します。

「Naming Attribute string」を使用する場合は、「User Paths」を使用し、「Alternate User ID location」は使用しないでください。

Passphrase

セキュリティを強化するため、パスフレーズのチャレンジを有効にします。ユーザーは、はじめて使用するときにパスフレーズへの応答を指定する必要があります。これはデフォルト設定です。

オプション:

  • Disable
  • Enable（デフォルト）

Share credentials with other Primary Logon Methods

この設定によって、同じ資格証明を持つ認証方式を使用する場合に、認証が重複して発生しないようにできます。

この設定では認証方式の資格証明をリンクするため、資格証明が同じ場合は、ユーザーが再入力しなくてもその資格証明が再利用されます。

資格証明を共有する認証方式のカンマ区切りリストを入力します（例: WinAuth,MSAuth）。

他の認証方式名を指定するには、その認証方式のレジストリ（HKLM\Software\Passlogix\AUIの下）にリストされている名前を参照してください。
Share credentials with synchronizers

この設定は、認証方式と1つ以上のシンクロナイザが同じ資格証明を使用する場合に、二重認証が発生しないようにする方法を提供します。

資格証明を共有するシンクロナイザののカンマ区切りリストを入力します（例: ADEXT, LDAPEXT）。

他のシンクロナイザ名を指定するには、そのシンクロナイザのレジストリ（HKLM\Software\Passlogix\Extensions\SyncManagerの下）にリストされている名前を参照してください。
Show user path

「Yes」に設定した場合、ユーザーが認証を求められると「User path」フィールドが表示されます。

オプション:

  • Yes（デフォルト）
  • No

これはESSO-LMバージョン11.1.1.1.0での新しい設定です。

SSL Fallback

SSL接続に失敗したときのセキュアでない接続へのフォールバック。

オプション:

  • Do not connect if the SSL connection fails（デフォルト）
  • Connect without SSL (insecure) if the SSL connection fails

SSLFallbackを選択し、「Servers」に示されているサーバーのいずれかにポート指定が含まれている場合は、フォールバック・ポートを「Servers」の追加のエントリとして指定する必要があります。

例:

SSL接続に対してmycomputer.com:1272が指定されている場合は、次のように、追加のエントリがフォールバック・ポートを指す必要があります。

  • Server1=mycomputer.com:1272 : セキュアなSSLポート
  • Server2=mycomputer.com:389 : フォールバック・ポート

Windows Title Name

この認証方式のウィンドウのタイトル名をカスタマイズするには、この設定を使用します。

このエントリは必須ではありません。


Primary Logon Methods\Proximity Card

「Primary Logon Methods」 - 「Proximity Card」

近接型ICカード設定は、近接型ICカード設定を構成する場合に使用します。

Alphanumeric PIN Requirements

ユーザー定義PINの英数字要件。

オプション:

  • Numbers only
  • Letters only
  • Numbers and letters（デフォルト）

Card Family

近接型ICカードのファミリ・タイプ。

オプション:

  • HID ISO/DUO PROX（デフォルト）
  • iClass
  • Indala/EM

Maximum PIN Length

ユーザー定義PINの最大長。デフォルトは8です。

Maximum PIN Retries

認証が失敗するまでの正しいPINの試行回数。デフォルトは3です。

Minimum PIN Length

ユーザー定義PINの最小長。デフォルトは4です。

Reader Name

使用する近接型ICカード・リーダーの名前。

オプション:

  • Omnikey CardMan 5125
  • Omnikey CardMan 5121
  • Omnikey CardMan 5321
  • RFIdeas（すべてのリーダー）

Second Factor Authentication

認証の2番目の要素として、Active Directoryパスワードまたはユーザー定義PINのどちらを使用するか。

オプション:

  • AD Password（デフォルト）
  • User Defined PIN


Primary Logon Methods\ROSC\Advanced

拡張（「Primary Logon Methods」 - 「Read-Only Smart Card」）

「Read-Only Smart Card Primary Logon Methods」設定では、読取り専用スマート・カード認証を有効にする拡張オプションを制御します。

Lock ESSO-KM session on removal

セッション所有者がスマート・カード・リーダーからスマート・カードを取り外した場合に、ESSO-KMがセッションをロックするかどうかが構成されます。デフォルトでは、この値は「lock」に設定されています。ロックしない設定になっている場合は、ESSO-KMセッションは、スマート・カードを取り外してもオープンしたままになります。この設定は、従業員が、常にスマート・カードを表示する必要があるため、リーダーにスマート・カードをはめ込んだままにしておくことができない場合に役に立ちます。

オプション:

  • 0 Do not lock
  • 1 Lock（デフォルト）

Reg Node: AUI\ROSCauth:LockSMOnRemoval

Passphrase

リセット・パスフレーズの使用を許可します。パスフレーズは、ユーザーによってダイアログ・ボックスでユーザーがパスフレーズを入力するか、またはカード上のデフォルト以外の最新の暗号化証明書によって指定できます。

オプション:

  • 0 Disable
  • 1 Enable (using a dialog box)（デフォルト）
  • 2 Enable (using the card's certificate)

Reg Node: AUI\ROSCauth:ResetEnable

PKCS #11 Library Path

この設定を使用して、PKCS#11標準を実装するスマート・カード・ミドルウェア・ファイルへのパスを構成します。

このエントリは、スマートカードでESSO-KMを使用している場合のみ必須です。
Reset Certificate Object Identifier

この設定はオプションです。デフォルトでは、認証方式は、証明書ベースのパスフレーズ機能に対応しているカード上にある最新の有効な暗号化証明書を選択します。この設定を使用して、パスフレーズ機能で使用する特定の証明書を識別するオブジェクト識別子を構成します。認証方式は、スマートカード上の各証明書のEnhanced Key Usage属性で、このオブジェクト識別子を検索します。

このパスフレーズ・オプションは、カードの証明書を使用して「Enable」に設定する必要があります。

Reg Node: AUI\ROSCAuth:ResetCertOID

Store Synchronization

Secure Data Storageを使用してユーザーの同期レポジトリ資格証明を格納するかどうかを構成します。

Secure Data Storageを有効にし、構成する必要があります。

オプション:

  • Do not store credentials（デフォルト）
  • Store credentials

Reg Node: AUI\ROSCauth:StoreSyncCreds


Primary Logon Methods\Secure Data Storage

「Primary Logon Methods」 - 「Secure Data Storage」

次の設定は、セキュアなデータ記憶域設定を構成する場合に使用します。

Data Storage Location データが格納されるリポジトリの場所への完全修飾されたパス。
Enable Data Storage

ユーザー同期資格証明をリポジトリに安全に格納するかどうかを構成します。

オプション:

  • Disable（デフォルト）
  • Enable


Primary Logon Methods\Smart Card\Advanced

拡張（「Primary Logon Methods」 - 「Smart Card」）

「Smart Card Primary Logon Methods」設定では、スマート・カード認証を有効にする拡張オプションを制御します。

Lock ESSO-KM session on removal

この設定によって、セッション所有者がスマート・カード・リーダーからスマート・カードを取り外した場合にESSO-KMでセッションをロックするかどうかが構成されます。デフォルトでは、この値は「lock」に設定されています。ロックしない設定になっている場合は、ESSO-KMセッションは、スマート・カードを取り外してもオープンしたままになります。この設定は、従業員が、常にスマート・カードを表示する必要があるため、リーダーにスマート・カードをはめ込んだままにしておくことができない場合に役に立ちます。

オプション:

  • lock（デフォルト）
  • Do not lock

Reg Node: AUI\SCauth:LockSMOnRemoval

Passphrase

セキュリティを強化するため、パスフレーズのチャレンジを有効にします。パスフレーズは、ダイアログ・ボックスでユーザーがパスフレーズを入力するか（デフォルト設定）、またはカード上のデフォルト以外の最新の暗号化証明書によって指定できます。

デフォルトの設定では、「First Time Use」でユーザーがパスフレーズの応答を指定する必要があります。

オプション:

  • Disable
  • Enable using a dialog box（デフォルト）
  • Enable using the card's certificate

Reg Node: AUI\SCauth:ResetEnable

PKCS #11 Library Path

この設定を使用して、PKCS#11標準を実装するスマート・カード・ミドルウェア・ファイルへのパスを構成します。

このエントリは、次の「Smartcard Library」設定をPKCS#11に設定した場合、またはESSO-KMでスマート・カードを使用している場合のみ必須です。
Reset Certificate Object Identifier

この設定はオプションです。デフォルトでは、認証方式は、証明書ベースのパスフレーズ機能に対応しているカード上にある最新の有効な暗号化証明書を選択します。この設定を使用して、パスフレーズ機能で使用する特定の証明書を識別するオブジェクト識別子を構成します。認証方式は、スマートカード上の各証明書のEnhanced Key Usage属性で、このオブジェクト識別子を検索します。

このパスフレーズ・オプションは、カードの証明書を使用して「Enable」に設定する必要があります。

Reg Node: AUI\SCAuth:ResetCertOID

Smartcard Library

スマート・カード上で暗号化操作を実行するために、暗号サービス・プロバイダ（CSP）またはPKCS #11ライブラリを使用するかどうかを構成します。デフォルトでは、CSPを使用します。

Reg Node: AUI\SCAuth:SmartCardAPI

Store Synchronization Credentials

スマート・カードにユーザーの同期リポジトリ資格証明を格納するかどうかを構成します。

ESSO-KMとともにスマート・カード認証を使用する場合、または読取り専用のスマート・カード認証方式を使用する場合（あるいはその両方）に、資格証明を格納します。

読取り/書込み操作では認証プロセスの時間が追加されるため、スマート・カード上に資格証明を格納しない場合はパフォーマンスが向上します。

オプション:

  • 0 Disable（デフォルト）
  • 1 Enable

Reg Node: AUI\SCauth:StoreSyncCreds

Use the default certificate for authentication

カードのデフォルトのログオン証明書（管理者が指定した）を認証に使用します。有効でない場合（デフォルト）、カード上のSSOコンテナの公開鍵/秘密鍵を使用（および必要に応じて作成）します。

オプション:

  • Use SSO-generated keys（デフォルト）
  • Use the default logon certificate

Reg Node: AUI\SCauth:UseCertOnCard

Whether to store the PIN

スマート・カードPINを保存するか（この結果、AgentがPINを要求する場合があります）、スマート・カード・ドライバでPINの要求を処理するかを指定します。

オプション:

  • Do not store PIN（デフォルト）
  • Store PIN

Reg Node: AUI\SCauth:AuthOptions

Windows Subtitle Name

この認証方式のウィンドウのサブタイトル名をカスタマイズするには、この設定を使用します。

このエントリは必須ではありません。

Reg Node: AUI\SCAuth:WindowSubTitle

Windows Title Name

この認証方式のウィンドウのタイトル名をカスタマイズするには、この設定を使用します。

このエントリは必須ではありません。

Reg Node: AUI\SCAuth:WindowTitle


Primary Logon Methods\Windows

Windows（プライマリ・ログオン方法）

「Windows Primary Logon Methods」設定では、標準のWindows認証を制御します。

When user's Windows password changes...

新しいWindowsパスワードが使用中のときには、ユーザーに古いWindowsパスワードの入力を求めます。この設定は、デフォルトでは無効になっています。

オプション:

  • Do not require the old Windows password（デフォルト）
  • Require the old Windows password


Primary Logon Methods\Windows\Advanced

拡張（「Primary Logon Methods」 - 「Windows」）

Custom image for authentication prompt

ファイル名を含めて、イメージの完全修飾されたパスを入力するか、「...」をクリックし、イメージ・ファイルを参照します。

このイメージに設定されたディメンションは、幅は300ピクセル、高さは100ピクセルです。これらのディメンションは変更できません。イメージがこれより小さい場合はこの領域の中央に配置され、大きい場合は4辺が同等に切り取られます。

これはESSO-LMバージョン11.1.1.1.0での新しい設定です。
Share credentials with other Primary Logon Methods

この設定によって、同じ資格証明を持つ認証方式を使用する場合に、認証が重複して発生しないようにできます。

この設定では認証方式の資格証明をリンクするため、資格証明が同じ場合は、ユーザーが再入力しなくてもその資格証明が再利用されます。

資格証明を共有する認証方式のカンマ区切りリストを入力します（例: WinAuth, MSAuth）。

他の認証方式名を指定するには、その認証方式のレジストリ（HKLM\Software\Passlogix\AUIの下）にリストされている名前を参照してください。
Share credentials with synchronizers

この設定は、認証方式と1つ以上のシンクロナイザが同じ資格証明を使用する場合に、二重認証が発生しないようにする方法を提供します。

資格証明を共有するシンクロナイザののカンマ区切りリストを入力します（例: ADEXT, LDAPEXT）。

他のシンクロナイザ名を指定するには、そのシンクロナイザのレジストリ（HKLM\Software\Passlogix\Extensions\SyncManagerの下）にリストされている名前を参照してください。
Window Subtitle Name

この認証方式のウィンドウのサブタイトル名をカスタマイズするには、この設定を使用します。

このエントリは必須ではありません。
Window Title Name

この認証方式のウィンドウのタイトル名をカスタマイズするには、この設定を使用します。

このエントリは必須ではありません。


Primary Logon Methods\Windows v2

Windows v2（プライマリ・ログオン方法）

「Windows v2 Primary Logon Methods」設定は、Windows Authenticatorバージョン2の主要なコントロールです。

Include in "Domain" Credential Sharing Group

MS Windows認証方式とドメイン資格証明共有グループの資格証明との間で資格証明変更を共有します。この設定では、資格証明共有を有効にする必要があります。「Required Password Change」の共有グループの設定を参照してください。

オプション:

  • Credential sharing between this authenticator and group Domain is disabled
  • Credential sharing between this authenticator and group Domain is enabled（デフォルト）
Reauthentication dialog

ESSO-LMがエンド・ユーザーに再認証を求めるときに使用する方法を選択します。

オプション:

  • UseESSO-LM dialog: エージェント自体のダイアログを使用して再認証を行います。認証が成功するまで、ESSO-LM機能は停止します（デフォルト）。
  • Use GINA: Windows GINA認証方式ダイアログを使用して再認証を行います。認証が成功するまで、ワークステーションはロックされます。
Use Windows Data Protection

パスフレーズの要件をなくすには「On」に設定します。ただし、ユーザーによるパスワード変更は可能です。

これは、DPAPI対応の（フルADなど）インフラストラクチャでのみ実行可能です。


Primary Logon Methods\Windows v2\Advanced

拡張（「Primary Logon Methods」 - 「Windows version 2」）

「Advanced Windows v2 Primary Logon Methods」設定は、Windows Authenticatorバージョン2の拡張オプションを制御します。

Custom image for authentication prompt

ファイル名を含めて、イメージの完全修飾されたパスを入力するか、「...」をクリックし、イメージ・ファイルを参照します。

このイメージに設定されたディメンションは、幅は300ピクセル、高さは100ピクセルです。これらのディメンションは変更できません。イメージがこれより小さい場合はこの領域の中央に配置され、大きい場合は4辺が同等に切り取られます。

これはESSO-LMバージョン11.1.1.1.0での新しい設定です。
Passphrase

セキュリティを強化するため、パスフレーズのチャレンジを有効にします。ユーザーは、はじめて使用するときにパスフレーズへの応答を指定する必要があります。これはデフォルト設定です。

オプション:

  • Disable
  • Enable（デフォルト）
Passphrase: Checkbox Message

この設定は、ユーザーに同意を求める形式のダイアログ・チェック・ボックスをカスタマイズする場合に使用します。

ダイアログを終了するには、このチェック・ボックスを選択する必要があります。このチェック・ボックスを選択するまで、「OK」ボタンは無効になります。

（デフォルト: I have read and understand the provisions listed above）
Passphrase: Message

この設定は、ユーザーに同意を求める形式のダイアログ・ボックスを表示して、ユーザーがそのダイアログ内のチェック・ボックスを選択しないかぎり続行できないようにする場合に使用します。この設定は、ユーザーが入力するパスフレーズの重要性を示す場合などに使用します。

このメッセージには、複数行にまたがって最大180文字を含めることができます。文字列\nは、復帰改行文字に置き換えられます。この設定を設定しないと、このダイアログ・ボックスはスキップされます。
Passphrase: Message Dialog Title | この設定は、ユーザーに同意を求める形式のダイアログ・タイトルをカスタマイズする場合に使用します。
Passphrase: Minimum Length | パスフレーズに必要とされる長さのデフォルト。特定の質問に最小限必要な長さを設定した場合は、この設定より優先されます。デフォルトは8です。
Passphrase: Reset with old password

この設定を有効にすると、ユーザーは前のパスワードをWindows Auth v2で自分のパスフレーズとして再利用できます。

オプション:

  • Disable（デフォルト）
  • Enable（前のパスワードをパスフレーズ・プロセスで使用できます）
Passphrase: User can change passphrase

この設定を有効にすると、ユーザーはWindows Auth v2で確認の質問に対する応答を変更できます。

オプション:

  • Yes（デフォルト）
  • No
Share credentials with other Primary Logon Methods

この設定によって、同じ資格証明を持つ認証方式を使用する場合に、認証が重複して発生しないようにできます。

この設定では認証方式の資格証明をリンクするため、資格証明が同じ場合は、ユーザーが再入力しなくてもその資格証明が再利用されます。

資格証明を共有する認証方式のカンマ区切りリストを入力します（例: WinAuth, MSAuth）。

他の認証方式名を指定するには、その認証方式のレジストリ（HKLM\Software\Passlogix\AUIの下）にリストされている名前を参照してください。
Share credentials with synchronizers

この設定は、認証方式と1つ以上のシンクロナイザが同じ資格証明を使用する場合に、二重認証が発生しないようにする方法を提供します。

資格証明を共有するシンクロナイザののカンマ区切りリストを入力します（例: ADEXT, LDAPEXT）。

他のシンクロナイザ名を指定するには、そのシンクロナイザのレジストリ（HKLM\Software\Passlogix\Extensions\SyncManagerの下）にリストされている名前を参照してください。
Skip reset re-enrollment when using old password to reset

ユーザーがESSO-LMのパスフレーズ・プロンプトをスキップできるかどうかを設定します。この機能を有効にした場合は、ユーザーが以前のWindowsパスワードを入力すると、以後ESSO-LMはユーザーに新しいパスフレーズの入力を求めなくなります。デフォルトでは、無効になっています。

この機能を有効にすると、ESSO-LMに対する完全ロックアウトが発生する可能性があります。ロックアウトは、ユーザーがパスフレーズとWindowsパスワードを忘れてしまった場合に発生します。この場合、ユーザーはESSO-LMから完全にロックアウトされます。

オプション:

  • Disable（デフォルト）
  • Enable
Window SubTitle Name

この認証方式のウィンドウのサブタイトル名をカスタマイズするには、この設定を使用します。

このエントリは必須ではありません。
Window Title Name

この認証方式のウィンドウのタイトル名をカスタマイズするには、この設定を使用します。

このエントリは必須ではありません。


レポーティング

レポーティング・ツールを使用すると、ユーザー・アクティビティに関するレポートを生成できます。このツールの使用の詳細は、ESSO-LMのレポーティングに関するドキュメントを参照してください。

Batch Size | データベースのストアド・プロシージャに一度に送信されるイベントのグループ・サイズを定義します。デフォルトは100です。たとえば、レポーティング・サービスのキャッシュに1000個のイベントがあり、バッチ・サイズが100の場合、データベースのストアド・プロシージャを10回コールすることになります。
Cache Limit | キャッシュされるレポーティング・イベントの数。この数に達した場合、最も古いイベントが破棄されます。デフォルトは1000です。たとえば、バッチ・サイズが100で、エンド・ユーザーのシステムがレポーティング・サービスに接続できない場合、イベントは記録され続けます。1000に達した場合は、最も古いイベントが破棄されます。
Retry Interval | イベントをデータベースにオフロードするレポーティング・サービスのキャッシュの順次処理間のタイムアウトを分単位で定義します。デフォルトは30です。間隔はデータベースの接続負荷を減らすために必要です。


レポーティング・データベース

このタブで、レポーティング・データベースの設定を構成します。

Connection String | OLE DB形式のデータベース接続文字列: Provider=sqloledb; Data Source=myServerName; Initial Catalog=myDatabaseName; User Id=myUsername; Password=myPassword
Extension Location | ReportingDBExt.dllを指すレポーティング・データベース拡張のパス\ファイル名。
Stored Procedure | データベースのストアド・プロシージャの名前。エンコード済イベントがデータベースに送信されると、XMLファイルをデコードするためにストアド・プロシージャがコールされ、イベントがデータベースに格納されます。


Security\Common

共通（セキュリティ）

「Common Security」設定では、エンド・ユーザーによるプライマリ・ログオン・パスワードの再入力を必要とする頻度を制御します。

Reauthentication timer

次の再認証リクエストまでの時間（ミリ秒）。

4,294,967,295（0xFFFFFFFF）に設定した場合は、期限切れになることはなく、強制認証の場合を除いて、ユーザーは再認証を受ける必要がありません。

クライアント側のインストールのデフォルト値は900000です（15分）。

クライアント側のインストールのデフォルト値は900000です（15分）。

Terminal Services環境のデフォルト値は4,294,967,295です（無効）。


Security\Advanced

拡張（セキュリティ）

「Advanced Security」設定では、エンド・ユーザーがアプリケーション・ログオン・パスワード、優先する暗号化プロバイダおよび暗号化の強度を参照するためのアクセスを制御します。

Allow user to reveal masked fields

ユーザーはウィザードおよびプロパティ・ページでパスワードを表示できます。

オプション:

  • Allow（デフォルト）
  • Do not allow
Default encryption algorithm

暗号化のアルゴリズムおよび強度を選択します。

オプション:

  • Cobra 128-bit
  • Cobra 128-bit (also)
  • Blowfish 448-bit
  • Triple-DES 168-bit
  • AES 256-bit
  • Triple-DES (MS CAPI) (ALL OSs)（デフォルト）
  • Triple-DES (MS CAPI) (XP/2003 only)
  • RC-4 (MS CAPI) (All OSs)
  • RC-4 (MS CAPI) (XP/2003 only)
  • AES (MS CAPI) (XP/2003 only)

Windows XP/2003でのみサポートされるオプションを指定して「PreferredCSP」を設定すると、別のオペレーティング・システムで実行中のESSO-LM Agentが無効になります。
Obfuscate length of masked fields

暗号化されたフィールドを、不明瞭化されたデータの長さとは異なる空白文字で表示するかどうかを指定します。

オプション:

  • Yes.Hides length of masked fields.（デフォルト）
  • No. Displays the actual length of masked fields.

これはESSO-LMバージョン11.1.1.1.0での新しい設定です。
Require reauthentication before updating account credentials

有効にした場合、再確証タイマーが期限切れでない場合でも、格納されたアプリケーション資格証明を更新する前に、ユーザーにESSO-LM資格証明の提供を強制します。

これはESSO-LMバージョン11.1.1.1.0での新しい設定です。
Require reauthentication to reveal masked fields

ユーザーがLogon Managerおよびダイアログで「Reveal」または「Reveal All」を選択した場合には、再認証を求めます。

オプション:

  • Do not require reauthentication
  • Require reauthentication（デフォルト）


セッションの概要

Oracle Enterprise Single Sign-on Kiosk Manager

Kiosk Managerの設定によって、ESSO-KMの操作を制御できます。

Allow administrator to close ESSO-KM

これはESSO-LMバージョン7.0.10.1.4.1.0での新しい設定です。

この設定では、Kiosk環境で管理者がESSO-KMを閉じることができるかどうかを決定します。

有効にした場合、管理者は資格証明を入力することを求められます。エージェントを閉じることができるのは、管理者の資格証明だけです。

オプション:

  • No
  • Yes（デフォルト）
Close suspended session after how many seconds

ESSO-KMがセッションを閉じるまでの非アクティブな時間（秒）を入力します。デフォルトは600です。
Close sync/auth dialog after how many seconds

ESSO-KMが同期ダイアログまたは認証ダイアログを閉じるまでの非アクティブな時間（秒）を入力します。デフォルトは600です。
Desktop Status Window

これはESSO-LMバージョン7.0.10.1.4.1.0での新しい設定です。

このステータス・ウィンドウは、ESSO-KMセッション中に表示されます。現在のセッション所有者の名前が表示され、ユーザーに便利なように「Lock Session」ボタンがあり、デスクトップから1クリックでセッションをロックできます。

オプション:

  • Hidden（デフォルト）
  • Display
Event Log Machine Name

ESSO-KMのイベントが記録されるローカル・マシンの名前を入力します。

Event Log Name

ESSO-KMのイベントが記録されるWindowsイベント・ログの名前を入力します。

Lock session on screen saver timeout

この設定では、スクリーン・セーバー・タイムアウトが発生した場合に、ESSO-KMがセッションをロックするかどうかを決定します。

オプション:

  • No（デフォルト）
  • Yes

この値を「Yes」に設定するか、この値が存在しない（デフォルト値）場合、ESSO-KMはスクリーン・セーバー・タイムアウトが発生した後に、セッションをロックします。

この値を「No」に設定した場合、セッションの制御にデバイス検出が使用されたときは、ESSO-KMはセッションをロックしません。
Maximum number of sessions

一度に許可されるセッションの最大数を指定します。

ゼロを設定した場合は、1つのセッションとして解釈されます。

この設定には最大数はありません。
Number of times to process termination

ESSO-KMがアプリケーションの停止を実行する回数を入力します。ここでは停止処理を、順序に関係なく指定された回数（または停止が完了するまで）繰り返すように設定します。これによってESSO-KMは、停止処理中にアプリケーションが複数の画面を表示している場合にも対応することができます。デフォルトは1です。

Prepopulate at
Startup

起動時に事前移入手順を実行するかどうかを指定します。認証方式でこの手順が必要であり、ESSO-AMがインストールされていない場合は、この設定によってESSO-KMによる必要な事前移入の実行が可能になり、同期マネージャによる再認証が不要になります。

セッションの開始時、device-inイベントを受信しESSO-AMがインストールされている場合に事前移入を実行するか、セッション開始時に常に事前移入を実行するか、または事前移入を実行しないかを選択します。デフォルトでは、device-inイベントを受信し、ESSO-AMがインストールされている場合に事前移入を実行します。
Restart computer

この設定では、ESSO-KM Desktop Managerにおけるコンピュータ再起動オプションの有効または無効を指定します。「Administrator must supply password」を選択することによって、管理者のみがコンピュータを再起動する権限を持つようにもできます。

ここで有効と設定されていても、Kioskアカウントに十分な権限がないと無効になります。

オプション:

  • Disable（デフォルト）
  • Enable
  • Administrator must supply password
Shutdown computer

この設定では、ESSO-KM Desktop Managerにおけるコンピュータ停止オプションの有効または無効を指定します。「Administrator must supply password」を選択することによって、管理者のみがコンピュータを停止する権限を持つようにもできます。

ここで有効と設定されていても、Kioskアカウントに十分な権限がないと無効になります。

オプション:

  • Disable（デフォルト）
  • Enable
  • Administrator must supply password
Status Window X coordinate

これはESSO-LMバージョン7.0.10.1.4.1.0での新しい設定です。

Xによりステータス・ウィンドウが調整されます。これは、デスクトップ上のステータス・ウィンドウの水平位置です。

負の値はレジストリ中の大きな正の数によって表示されます。例: -1 = 4294967295および-2 = 4294967294

Status Window Y coordinate

これはESSO-LMバージョン7.0.10.1.4.1.0での新しい設定です。

Yによりステータス・ウィンドウが調整されます。これは、デスクトップ上のステータス・ウィンドウの垂直位置です。

負の値はレジストリ中の大きな正の数によって表示されます。例: -1 = 4294967295および-2 = 4294967294
Track Memory Consumption

これはESSO-LMバージョン7.0.10.1.4.1.0での新しい設定です。

この設定では、ESSO-KMが自動的にセッションを閉じるメモリー使用量のレベルを決定します。システムのメモリー使用量がこの値に設定した割合に達した場合、ESSO-KMは最も古いユーザー・セッションを自動的に閉じます。

Minimum = 0（無効）

Maximum = 100

デフォルトは90です。
Transparent Display After Cancel

これはESSO-LMバージョン7.0.10.1.4.1.0での新しい設定です。

この設定は、取消し後に表示する機能を有効にするかどうかを決定します。

無効にした場合、ESSO-KMは非アクティブなタイマーに戻り、デスクトップをいつ表示するかを決定します。

有効にした場合、認証または同期ダイアログが取り消されると、デスクトップはすぐに見えるようになります。

この機能が動作するには、後述の「Transparent Lock」設定を有効にする必要があります。

オプション:

  • Disable（デフォルト）
  • Enable
Transparent Lock

これはESSO-LMバージョン7.0.10.1.4.1.0での新しい設定です。

この設定では、透過的な画面ロック機能を有効にするかどうかを決定します。透過的な画面ロックは、表示モードでデスクトップ入力（キーボードおよびマウス）をロックする機能を提供するため、たとえば、セッションを開始することなく監視アプリケーションの表示が可能です。

キーボード入力およびマウス入力をロックします。

複数のセッションを実行している場合、透過的な画面ロックが機能すると、最後にアクティブなセッションが表示されます。

オプション:

  • Disabled（デフォルト）
  • Show desktop with active session。アクティブなセッションが実行中であれば、透過的な画面ロックが有効になります。
  • Show desktop。このオプションが選択された場合、透過的な画面ロックはアクティブなセッションの有無にかかわらず有効になります。

「Show desktop with active session」に設定した場合、アクティブなセッションがある場合にのみ、透過的な画面ロックが有効になります。
Transparent Lock Time

これはESSO-LMバージョン7.0.10.1.4.1.0での新しい設定です。

この設定では、デスクトップを表示する前にマウスおよびキーボードの非アクティブな状態を待機する秒数を決定します（デフォルトは5です）。

この機能が動作するには、前述の「Transparent Lock」設定を有効にする必要があります。
Transparent Only Recognize Ctrl-Alt-Delete

これはESSO-LMバージョン7.0.10.1.4.1.0での新しい設定です。

この設定では、[Ctrl]キーを押しながら[Alt]キーと[Delete]キーをクリックすることが、透過的な画面ロックを終了してDesktop Managerを表示する唯一の方法とするかどうかを決定します。

無効にした場合は、すべてのキーボード・アクティビティまたはマウス・アクティビティで、Desktop Managerを表示します。

有効にした場合、すべてのキーボード・アクティビティおよびマウス・アクティビティは無視されます。[Ctrl]キーを押しながら[Alt]キーと[Delete]キーをクリックすることおよびdevice-inをサポートする認証方式のみが、Desktop Managerを表示する方法として認識されます。

オプション:

  • Disable（デフォルト）
  • Enable


キャッシュされた資格証明

キャッシュされた資格証明（Oracle Enterprise Single Sign-on Kiosk Manager）

「Cached Credentials」設定を使用して、ESSO-KMがどのように資格証明を格納し、使用するかを制御します。

Expiration Date | この設定は、キャッシュされた資格証明が保持される日数を決定します。0(ゼロ）は、この機能が無効であることを示します。デフォルトは30です。
Storage Path | キャッシュされた資格証明を格納するデフォルトのフォルダ。デフォルトは空の文字列です。この値が空の場合、デフォルトのフォルダはC:\Documents and Settings\Kiosk User\Local Settings\Passlogix\CachedCredentials\ESSO-KM Userです。
Use cached credentials | この設定は、キャッシュされた資格証明を使用するかどうかを決定します。有効な場合、ESSO-KMにログインしているユーザーには、キャッシュされたユーザーのリストが表示され、そこから選択を行うことができます。無効な場合、リストは表示されません。ユーザーは、テキスト入力ユーザー・フィールドにユーザー名を入力します。デフォルトでは、キャッシュされた資格証明を有効にします。これによってESSO-KMのパフォーマンスが向上します。


セッションの拡張設定

拡張（Oracle Enterprise Single Sign-on Kiosk Manager）

Oracle Enterprise Single Sign-on Kiosk Managerの「Advanced」設定では、ESSO-KMによって表示される確認メッセージを制御します。

Show confirmation message when restarting kiosk | この設定では、Kioskの再起動を選択した後に、ユーザーに確認メッセージが表示されるかどうかを指定します。
Show confirmation message when shutting down kiosk | この設定では、Kioskの停止を選択した後に、ユーザーに確認メッセージが表示されるかどうかを指定します。


バックグラウンド・イメージ

バックグラウンド・イメージ（Oracle Enterprise Single Sign-on Kiosk Manager \ デスクトップ）

このパネルを使用して、ESSO-KM Desktop Managerにバックグラウンド・イメージをアップロードします。

Image height (in pixels) | イメージの高さ（ピクセル）。デフォルトは300です。
Image Placement

ロゴ・イメージの配置。

オプション:

  • Normal。イメージは座標の左上に配置され、指定した高さおよび幅より大きい場合は一部が切り取られます。
  • Autosize。イメージは、座標の左上に配置されます。
  • Center。イメージは座標の中心に配置され、指定した高さおよび幅より大きい場合は一部が切り取られます。
  • Stretch。イメージは指定した座標に合わせて拡大または縮小されます。
  • Maximize。イメージは、全画面サイズまで引き伸ばされます。
Image width (in pixels) | イメージの幅（ピクセル）。デフォルトは300です。
Image X coordinate (in pixels)

Xによりイメージが調整されます。

負の値はレジストリ中の大きな正の数によって表示されます。例: -1 = 4294967295および-2 = 4294967294
Image Y coordinate (in pixels)

Yによりイメージが調整されます。

負の値はレジストリ中の大きな正の数によって表示されます。例: -1 = 4294967295および-2 = 4294967294
Location of the image file | イメージ・ファイルの完全修飾されたパスおよびファイル名。ファイルを検索するには、「...」ボタンをクリックします。


テキスト・メッセージ

テキスト・メッセージ（Oracle Enterprise Single Sign-on Kiosk Manager \ デスクトップ）

このパネルを使用して、ESSO-KM Desktop Managerにメッセージ（HIPAAコンプライアンス通知など）をアップロードします。このメッセージはDesktop Managerがアクティブなときに表示されます。

関連するサイズには、次のようなものがあります。

Desktop Managerのログオン・ウィンドウのサイズ

幅＝476ピクセル

高さ＝404ピクセル

Desktop Managerのログオン・ウィンドウの起点

X起点＝（画面幅 - 476）/2

Y起点＝（画面高 - 404）/2

Desktop Managerのログオン・ウィンドウのエクステント（右下角）

Xエクステント＝X起点＋476－1

Yエクステント＝Y起点＋404－1

800×600表示の例を次に示します。

Desktop Managerのログオン・ウィンドウのサイズは次のとおりです。

幅: 476ピクセル、高さ: 404ピクセル。

800×600表示では、座標161、97に表示されます。

詳細は、ESSO-KMの管理ガイドを参照してください。
Text Message | ESSO-KMのDesktop Managerで使用するメッセージ・テキストです。このメッセージはDesktop Managerがアクティブなときに表示されます。
Text Message Autosize

これはESSO-LMバージョン7.0.10.1.4.1.0での新しい設定です。

テキスト・メッセージを自動調整するかどうかを選択します。この設定では、メッセージのサイズに基づいて、コントロールのサイズを自動的に設定します。

オプション:

  • Yes
  • No

Text Message Color Background

これはESSO-LMバージョン7.0.10.1.4.1.0での新しい設定です。

省略記号「...」ボタンをクリックして、テキスト・メッセージのバックグラウンド・カラーを選択します。
Text Message Color Foreground

これはESSO-LMバージョン7.0.10.1.4.1.0での新しい設定です。

省略記号「...」ボタンをクリックして、テキスト・メッセージのフォアグラウンド・カラーを選択します。
Text Message Font Name

*これはバージョン 10.1.4.1.0 での新しい設定です。

テキスト・メッセージを表示するためのフォント。ドロップダウン・リストからフォントを選択します。

Text Message Font Size

*これはバージョン 10.1.4.1.0 での新しい設定です。

テキスト・メッセージを表示するためのフォント・サイズ。

Text Message Font Style

*これはバージョン 10.1.4.1.0 での新しい設定です。

テキスト・メッセージを表示するためのフォント・スタイル。

オプション:

  • Regular
  • Bold
  • Italic
Text Message height (in pixels) | MOTDの高さ（ピクセル）。デフォルトは300です。
Text Message width (in pixels) | MOTDの幅（ピクセル）。デフォルトは300です。
Text Message X coordinate (in pixels)

Xによりテキスト・メッセージが調整されます。

負の値はレジストリ中の大きな正の数によって表示されます。例: -1 = 4294967295および-2 = 4294967294
Text Message Y coordinate (in pixels)

Yによりテキスト・メッセージが調整されます。

負の値はレジストリ中の大きな正の数によって表示されます。例: -1 = 4294967295および-2 = 4294967294


エージェントの同期の設定

「Synchronization」設定は、すべてのシンクロナイザ拡張を対象とした資格証明同期に関する一般的なオプションです。これらの設定は、次の機能を制御する場合に使用します。

パフォーマンス・オプション
  • Sync Order
  • Aggressive Synchronization
  • Optimized Synchronization
  • Interval for automatic re-sync
  • Re-sync when network or connection status changes
  • Wait for synchronization at startup
  • ローミング・プロファイル同期サポート
ユーザー可動性オプション
  • Delete local cache
  • Deleted-credential cleanup
  • Disconnected operation
セキュリティおよび管理オプション
  • Enable role/group security support
Aggressive Synchronization

アグレッシブ同期を許可するかどうかを指定します。許可した場合、ユーザーが最新の資格証明または設定を必要とするアクションを実行したとき（アプリケーションが資格証明をリクエストしたときなど）は、常にエージェントが同期を実行します。

「Aggressive Synchronization」は、クライアント・コンピュータおよびサーバー・コンピュータのパフォーマンスに重大な影響を与えます。

オプション:

  • Do not allow Aggressive Sync（デフォルト）
  • Allow Aggressive Sync
Delete local cache

エージェントを停止したときに、ユーザーのデータ・フォルダおよびレジストリ・キーが削除されます。

オプション:

  • Do not delete the user's data（デフォルト）
  • Delete the user's data
Deleted-credential cleanup | 削除のマークを付けた後で実際に資格証明を削除するまでの日数（デフォルトは30日です）。
Disconnected Operation

ESSO-LMがシンクロナイザ拡張に接続できず、ローカル・キャッシュが存在していない場合は、はじめて使用する場合の設定を実行するかどうかを指定します。このチェックは、/backgroundパラメータで実行したとき（起動時など）に行われます。

オプション:

  • Do not continue running
  • Allow disconnected operation（デフォルト）
Enable role/group security support

アプリケーション・ログオン、パスワード・ポリシー、グローバル・エージェント設定およびパスフレーズ質問セットに対するロール/グループ・サポートを有効にします。

オプション:

  • Do not use role/group security （デフォルト）
  • Use role group security.
Interval for automatic re-sync | 自動再同期の間隔（分）。この間隔は、ユーザー生成の同期イベントが発生しているかどうかに関係なく適用されます。値を0（デフォルト）にすると、この設定は無効になります。
Optimized Synchronization

ESSO-LMは、自分で資格証明および設定を検索するのではなく、最適化された方法を使用して（チェックサム・ルーチンを使用して）、変更後の資格証明または設定を検出できます。

オプション:

  • Disable optimized synchronization（資格証明および設定を検索して変更を検出します）
  • Enable optimized synchronization（チェックサム・ルーチンを使用して変更を検出します（デフォルト））
Re-sync when network or connection status changes

ネットワーク接続ステータスの変更監視を有効または無効にします。有効にすると、エージェントはステータス変更が発生したとき（ネットワークへの再接続など）に再同期を実行します。

オプション:

  • Ignore network status changes
  • Watch for and re-sync on network status changes（デフォルト）
Sync Order

使用する同期拡張の順序を設定します。値を指定しないと、すべての拡張が（予測不可能な順序で）使用されます。

例:

LDAPExt,ADExt FileSync Remote,AD,FileSync Local,SmartCard MySmartCard,ADExt,ADExtRemote
Wait for synchronization at startup

起動時に同期を待機するかどうかを指定します。待機した場合、ユーザーのデータが必ず最新の状態になります。

注意: クライアント・ワークステーションのパフォーマンスにわずかに影響を与えます。

オプション:

  • Wait for sync（デフォルト）
  • 同期を待機しません。


Synchronization\AD\Required

必須（「Synchronization」 - 「Active Directory」）

「Required Active Directory Synchronization」設定は、すべてのActive Directoryシンクロナイザ拡張に対して指定する必要があります。

Extension location

Active Directoryシンクロナイザ拡張のパス\ファイル名。

（デフォルトは、C:\Program Files\Passlogix\Plugin\SyncMgr\ADEXT\adsyncです）
SSL

SSLで接続します。

オプション:

  • Connect without SSL (insecure), default to port #389（デフォルト）
  • Connect via SSL, default to port #636


Synchronization\AD\Advanced

拡張（「Synchronization」 - 「Active Directory」）

「Advanced Active Directory Synchronization」設定では、すべてのActive Directoryシンクロナイザ拡張を対象とした拡張オプションを制御します。

Change Password Window Subtitle Name

この設定は、このシンクロナイザのActive Directory変更パスワード・ウィンドウのサブタイトル名をカスタマイズする場合に使用します。

このエントリは必須ではありません。

Change Password Window Title Name

この設定は、このシンクロナイザのActive Directory変更パスワード・ウィンドウのタイトル名をカスタマイズする場合に使用します。

このエントリは必須ではありません。

Configuration Objects Base Locations

ロール/グループ対応の構成オブジェクトの検索を開始する場所を指定します。指定した場所から下方向に検索が行われます。エントリがない場合、検索はベースの場所から開始されます。

Credentials to use

Active Directoryサーバーに対する認証時に使用する資格証明。

オプション:

  • Use local computer credentials only
  • Use Active Directory server account only（「User Paths」の設定をお薦めします）。
  • Try local computer credentials; if it fails, use Active Directory server account（デフォルト）

Descriptive name

ログオン・ダイアログ・ボックスのタイトルです。同じ名前を持つ複数のシンクロナイザ拡張を区別するために用意されています。

このエントリは必須ではありません。

Location for storing user credentials

ロケータ・オブジェクトを使用しない場合に、ユーザー資格証明コンテナを自分のディレクトリ・ユーザー・オブジェクトの下に保存することを有効にします。無効である場合（デフォルト）、ロケータ・オブジェクトに指定したとおりに資格証明が保存されます。

この設定では、ディレクトリ・スキーマを更新し、ディレクトリ・ルート・セキュリティ設定を変更する必要があります。このためには、「Repository」メニューの「Enable Storing Credentials under User Object」コマンドを使用します。

オプション:

  • Store user credentials as specified by locator object（デフォルト）
  • Store user credentials under respective directory user objects

Logon attempts

再試行ダイアログをユーザーに示す回数（デフォルトは3です）。

Prepend Domain when naming objects

ユーザーのコンテナに名前を付ける際にユーザー名にユーザーのドメインを追加することを有効/無効にします。たとえば、ドメインcompanyおよびユーザーjameskの場合、コンテナは、このフラグを無効にするとjameskと名付けられ、このフラグを有効にするとcompany.jameskと名付けられます。

「Prepend Domain」を有効にした場合は、（「Repository」メニューの）「Enable Storing Credentials under User Object」を有効にしないでください。ユーザー・オブジェクトへの資格証明の格納を有効にする場合は、このオプションを無効にする必要があります（デフォルト）。両方のオプションを有効にすると、同期が行われなくなります。

Prompt when disconnected

同期イベントが失敗した場合、ユーザーは確認/通知なしでオフラインで作業できます。

オプション:

  • Prompt/notify the user（デフォルト）
  • Do not prompt

Search for locator and override objects

エージェントがロケータおよび優先オブジェクトを検索する方法を制御します。

オプション:

  • Search all servers for locator/override
  • Limit locator/override search to the server root（デフォルト）

Servers

同期を行うために接続するサーバーおよび接続順序を指定します。チェック・ボックスを選択し、「...」をクリックして「Edit List」ダイアログ・ボックスを開きます。各行にサーバー名を1つ入力します。[Enter]キーを押して各行を終了します。他のデリミタ文字を使用しないでください。

有効な形式は、ネットワークのDNS構成によって決まります。

computername]port[:

または

[]port][:tld[domainname.]host.

例:

sales

sales:389

ourdomain.net

sales.ourdomain.net

sales.ourdomain.net:389

Active Directory拡張に対してサーバーが入力されておらず、ユーザー・アカウントがActive Directoryドメインにある場合は、ESSO-LMでは、サーバーの検出にADドメイン・リソースが使用されます。1台以上のサーバーが指定されている場合は、ESSO-LMでは、サーバーの検出に「Servers」リストが使用されます。

特に構成されていないかぎり、ESSO-LMは、ローカルなサブネットに割り当てられている優先ドメイン・コントローラの名前をドメイン・ネーム・サーバー（DNS）に問い合せます。

複数のサーバーでActive Directoryネットワークを構築している場合は、レプリケーションを有効にして、SSOスキーマ拡張および関連オブジェクトが含まれるようにしてください。これで、ESSO-LMでは必ず接続先の各サーバー上でSSO情報が検索されるようになります。Active Directoryではコンピュータ名（IPアドレスではなく）を使用する必要があります。

ポート値を指定する場合は、「SSLFallback」を参照してください。

Share credentials with other Primary Logon Methods

この設定によって、同じ資格証明を持つシンクロナイザと認証方式を使用する場合に、認証が重複して発生しないようにできます。

この設定ではシンクロナイザと認証方式の資格証明をリンクするため、資格証明が同じ場合は、ユーザーが再入力しなくてもその資格証明が再利用されます。

資格証明を共有する認証方式のカンマ区切りリストを入力します（例: WinAuth,MSAuth）。

他の認証方式名を指定するには、その認証方式のレジストリ（HKLM\Software\Passlogix\AUIの下）にリストされている名前を参照してください。

User Paths

ユーザー・アカウントの場所を示す完全修飾されたパス。検索するパスの数に制限はありません。この拡張機能では、ユーザー・アカウントを検索して、そのパスを順に検索します。見つからない場合は、ディレクトリ・ツリーが検索されます。注意: この拡張では、このエントリは必須ではありません。

When SSL fails

SSL接続に失敗したときのセキュアでない接続へのフォールバック。

SSLFallback=1で、サーバーのいずれかにポート指定が含まれている場合は、フォールバック・ポートを「Servers」の追加のエントリとして指定する必要があります。たとえば、SSL接続に対してmycomputer.com:1272が指定されている場合は、追加のエントリが、mycomputer.com:1272 ;My secure SSL Port

mycomputer.com:389 ;My fallback portというように、フォールバック・ポートを指す必要があります。

オプション:

  • Do not connect if the SSL connection fails
  • Connect without SSL (insecure) if the SSL connection fails


Synchronization\ADAM\Required

必須（「Synchronization」 - 「ADAM」）

「Required ADAM Synchronization」設定は、すべてのADAMシンクロナイザ拡張に対して指定する必要があります。

Extension location

Active Directoryシンクロナイザ拡張のパス\ファイル名。

（デフォルトは、C:\Program Files\Passlogix\v-GO SSO
\Plugin\SyncMgr\ADAMext\ADAMsyncExt.dllです）

Servers

同期を行うために接続するサーバー（とポート）および接続順序を指定します。チェック・ボックスを選択し、「...」をクリックして「Edit List」ダイアログ・ボックスを開きます。各行にサーバー名を1つ入力します。[Enter]キーを押して各行を終了します。他のデリミタ文字を使用しないでください。

有効な形式は、ネットワークのDNS構成によって決まります。ターゲット・サーバー上のADAMの特定のインスタンスを指定するには、portパラメータを使用します。

computername]port[:

または

[]port][:tld[domainname.]host.

例:

sales
sales:389
ourdomain.net
sales.ourdomain.net
sales.ourdomain.net:389

この拡張が機能するには、少なくとも1台のサーバーを指定する必要があります。

ADAMではコンピュータ名（IPアドレスではなく）を使用する必要があります。


Synchronization\ADAM\Advanced

拡張（「Synchronization」 - 「ADAM」）

「Advanced ADAM Synchronization」設定では、すべてのADAMシンクロナイザ拡張を対象とした拡張オプションを制御します。

Change Password Window SubTitle Name

この設定は、このシンクロナイザのADAM変更パスワード・ウィンドウのサブタイトル名をカスタマイズする場合に使用します。

このエントリは必須ではありません。
Change Password Window Title Name

この設定は、このシンクロナイザのADAM変更パスワード・ウィンドウのタイトル名をカスタマイズする場合に使用します。

このエントリは必須ではありません。
Configuration Objects Base Locations ロール/グループ対応の構成オブジェクトの検索を開始する場所を指定します。指定した場所から下方向に検索が行われます。エントリがない場合、検索はベースの場所から開始されます。
Credentials to use

ADAMサーバーに対する認証時に使用する資格証明。

オプション:

  • Connect to ADAM with current user name
  • Use ADAM server account only
  • Try local computer credentials; if it fails, use ADAM server account（デフォルト）
Descriptive Name

ログオン・ダイアログ・ボックスのタイトルです。同じ名前を持つ複数のシンクロナイザ拡張を区別するために用意されています。

このエントリは必須ではありません。
Prepend Domain when naming objects

ユーザーのコンテナに名前を付ける際にユーザー名にユーザーのドメインを追加することを有効にします。たとえば、ドメインcompanyおよびユーザーjameskの場合、コンテナは、このフラグを無効にするとjameskと名付けられ、このフラグを有効にするとcompany.jameskと名付けられます。

オプション:

  • Disable（デフォルト）
  • Enable
Prompt when disconnected

同期イベントが失敗した場合、ユーザーは確認/通知なしでオフラインで作業できます。

オプション:

  • Prompt/notify the user（デフォルト）
  • Do not prompt
Share credentials with Primary Logon Methods

この設定によって、同じ資格証明を持つシンクロナイザと認証方式を使用する場合に、認証が重複して発生しないようにできます。

この設定ではシンクロナイザと認証方式の資格証明をリンクするため、資格証明が同じ場合は、ユーザーが再入力しなくてもその資格証明が再利用されます。

資格証明を共有する認証方式のカンマ区切りリストを入力します（例: WinAuth, MSAuth）。
User domain name to use

「Prepend Domain when naming objects」を有効にしたときに、コンテナ名で使用するドメイン名（DomainName.UserNameなど）。ユーザーは、ログオン・ダイアログで別のドメインを指定できます。

例:

ユーザー・ドメインが「MyDomain」であり（「Prepend Domain」が有効）、ユーザーがjameskとしてログオンした場合は、コンテナ名としてMyDomain.jameskが使用されます。ユーザーがAltDomain\jameskとしてログオンした場合は、コンテナ名としてAltDomain.jameskが使用されます。


Synchronization\DB\Required

必須（「Synchronization」 - 「Database」）

「Required Database Synchronization」設定は、すべてのデータベース・シンクロナイザ拡張に対して設定する必要があります。

Extension location

データベース・シンクロナイザ拡張のパス\ファイル名。

（デフォルトは、C:\Program Files\Passlogix\v -GO SSO

 \Plugin\SyncMgr\DBEXT\DBExt.dllです）
Servers

同期を行うために接続するデータベース・サーバーおよび接続順序を指定します。チェック・ボックスを選択し、「...」をクリックして「Edit List」ダイアログ・ボックスを開きます。各行に1台のデータベース・サーバーの完全接続アドレス（computerName.dbServerName）を入力します。[Enter]キーを押して各行を終了します。他のデリミタ文字を使用しないでください。

この拡張が機能するには、少なくとも1台のサーバーを指定する必要があります。

Oracle用:

  • Oracleデータベースに接続するには、次の接続文字列を使用します。
  • Provider=OraOLEDB.Oracle;Data Source=%MachineName%;Extended Properties='OSAuthent=1'この場合、Data Sourceの値は構成ごとに異なります。
  • Oracleデータベースに接続するには、Oracle 10gクライアントをAdministrative Consoleと同じマシン上にインストールする必要があります。

SQL Server用:

複数のインスタンスのホストであるSQLサーバーに接続するには、次の接続文字列を使用します（手動で改行を入力する必要はありません）。

Provider=SQLOLEDB; Data Source="ServerName\Instance"; Initial Catalog="DatabaseName";

Trusted_Connection=Yes


Synchronization\DB\Advanced

拡張（「Synchronization」 - 「DBEXT/ORA」）

「Advanced Database/Oracle Synchronization」設定では、すべてのデータベース/Oracleシンクロナイザ拡張を対象とした拡張オプションを制御します。

Append Domain when naming objects

ユーザーのコンテナに名前を付ける際にユーザー名にユーザーのドメインを追加することを有効にします。たとえば、ドメインcompanyおよびユーザーjameskの場合、コンテナは、このフラグを無効にするとjameskと名付けられ、このフラグを有効にするとjamesk.companyと名付けられます。（デフォルトは0です）

オプション:

  • Disable
  • Enable


必須

必須（「Synchronization」 - 「File System」）

「Required File System Synchronization」設定は、すべてのファイル・システム・シンクロナイザ拡張に対して指定する必要があります。

Extension location

ファイル・システム・シンクロナイザ拡張のパス\ファイル名。

（デフォルトは、 C:\Program Files \Passlogix\v-GO SSO
\Plugin\SyncMgr\FileSyncExt\filesync.dll です）

Server

同期化のために試行するUNCパスのリスト。この拡張が機能するには、少なくとも1台のサーバーを指定する必要があります。

例:

\\FS1\Users
\FS2\Extras
D:\Backup

ファイル・システム拡張では、適切なUNCパスを使用する必要があります。

ESSO-LM4.0では、1つのパスのみをサポートしています。


拡張

拡張（「Synchronization」 - 「File System」）

「Advanced File System Synchronization」設定では、すべてのファイル・システム・シンクロナイザ拡張を対象とした拡張オプションを制御します。

Descriptive name

ログオン・ダイアログのタイトルです。同じ名前を持つ複数のシンクロナイザ拡張を区別するために用意されています。

このエントリは必須ではありません。
Logon attempts 「Retry」ダイアログ・ボックスをユーザーに示す回数（デフォルトは3です）。
Prepend Domain when naming user folders

ユーザーのコンテナに名前を付ける際にユーザー名にユーザーのドメインを追加することを有効/無効にします。たとえば、ドメインcompanyおよびユーザーjameskの場合、コンテナは、このフラグを無効にするとjameskと名付けられ、このフラグを有効にするとOracle.jameskと名付けられます。

Prompt when disconnected

同期イベントが失敗した場合、ユーザーは確認または通知なしでオフラインで作業できます。

オプション:

  • Prompt/notify the user（デフォルト）
  • Do not prompt


Synchronization\IBM\Required

必須 （「Synchronization」 - 「IBM」）

「Required IBM Synchronization」設定は、すべてのIBMシンクロナイザ拡張に対して指定する必要があります。

Directory Type

特定のタイプのディレクトリ・サーバー。ディレクトリ・サーバーが示されていない場合は、アップグレード時に下位互換性用の「Unspecified LDAP Directory」（デフォルト）を選択します。それ以外の場合は、「Generic LDAP Directory」を選択します。

オプション:

  • Unspecified LDAP Directory（LDAPのデフォルト）
  • Novell eDirectory
  • Generic LDAP Directory
  • Sun Java System Directory
  • IBM Tivoli Directory Server（IBMのデフォルト）
  • Oracle Directory Server
Extension location

LDAP Directory Serverシンクロナイザ拡張のパス\ファイル名。

（デフォルト・パスは、C:\Program Files\Passlogix\v-GO SSO \
\Plugin\SyncMgr\LDAPEXT\ldapsync.dllです）
Servers

同期を行うために接続するサーバーおよび接続順序を指定します。チェック・ボックスを選択し、「...」をクリックして「Edit List」ダイアログ・ボックスを開きます。各行にサーバーを1つ入力します。[Enter]キーを押して各行を終了します。他のデリミタ文字を使用しないでください。

形式は次のとおりです。

computer],port[:

それぞれの意味は次のとおりです。

computerは、サーバー名またはIPです。

portが指定されていない場合は、デフォルト（SSLは636、SSL以外は389）が使用されます。

例:

127.0.0.1
127.0.0.1:456
somewhereelse.com:8080
anotherplace.com

この拡張が機能するには、少なくとも1台のサーバーを指定する必要があります。

ポートを指定する場合は、「SSLFallback」を参照してください。
SSL

SSL経由で接続する場合に選択します。

オプション:

  • Connect without SSL (insecure; default port #389)（デフォルト）
  • Connect via SSL (default port #636)
User Paths

ユーザー・アカウントの場所を示す完全修飾されたパス。検索するパスの数に制限はありません。この拡張機能では、ユーザー・アカウントを検索して、そのパスを順に検索します。見つからない場合は、ディレクトリ・ツリーが検索されます。

この拡張が機能するには、「Naming Attribute string」の値または「User Paths」の1つ以上の値を指定する必要があります。

「User Paths」を使用する場合は、「Alternate User ID location」を使用しないでください。


Synchronization\IBM\Advanced

拡張（「Synchronization」 - 「IBM」）

「Advanced LDAP/IBM Synchronization」設定では、すべてのIBMシンクロナイザ拡張を対象とした拡張オプションを制御します。

Alternate User ID location

ユーザー名以外の属性でユーザーを検証するときに、該当するユーザー・オブジェクトが存在する場所を示します。

例:

ログオンの従業員ID番号でユーザーの認証を行い（empid属性に対する検証）、ユーザー・オブジェクトがou=people,dc=computerにある場合は、この場所を次のように設定します。

empid=%user,ou=people,dc=computer

次のようには設定しないでください。

uid=user,ou=people,dc=computer

Novell eDirectoryの場合、「Alternate User ID location」は、次のように設定します。

uid=%user,path to the object%

「Alternate User ID location」を使用する場合は、「Naming Attribute string」および「User Paths」を使用しないでください。
BIND Timeout

LDAP BINDコールをタイムアウトする時間（ミリ秒）（デフォルトはオペレーティング・システムによって異なります）。

Configuration Objects Base Locations

ロール/グループ対応の構成オブジェクトの検索を開始する場所を指定します。指定した場所から下方向に検索が行われます。この設定のエントリがない場合、検索はベースの場所から開始されます。

Descriptive name

ログオン・ダイアログのタイトルです。同じ名前を持つ複数のシンクロナイザ拡張を区別するために用意されています。

このエントリは必須ではありません。
DSAME disabled-account support

Sun Java System Directory Server（以前のiPlanet Directory Server Access Management Edition（DSAME））の無効アカウントを認識します。

オプション:

  • The server is not a Sun Java System Directory Server（デフォルト）
  • The server is a Sun Java System Directory Server
Logon attempts

再試行ダイアログをユーザーに示す回数（デフォルトは3です）。

Naming Attribute string

「UserPaths」の前に付加する文字列。ユーザーのドメイン名が次の形式である場合は必須です。

cn=%UserName%,ou=people,dc=computer&n bsp;

次の形式の場合は、必須ではありません。

namingattribute=%UserName%,ou=people,dc=computer

（namingattributeは任意の文字列です)。必要に応じて、cnに設定します。

Novell eDirectoryの場合は、この値を通常cnに設定する必要があります。

「Naming Attribute string」を使用する場合は、「User Paths」を使用し、「Alternate User ID location」は使用しないでください。
Prompt when disconnected

同期イベントが失敗した場合、ユーザーは確認/通知なしでオフラインで作業できます。

オプション:

  • Prompt/notify the user（デフォルト）
  • Do not prompt
When SSL fails

SSL接続に失敗したときのセキュアでない接続へのフォールバック。

オプション:

  • Do not connect if the SSL connection fails（デフォルト）
  • Connect without SSL (insecure) if the SSL connection fails

SSLFallbackを選択し、「Servers」に示されているサーバーのいずれかにポート指定が含まれている場合は、フォールバック・ポートを「Servers」の追加のエントリとして指定する必要があります。

例:

SSL接続に対してmycomputer.com:1272が指定されている場合は、次のように、追加のエントリがフォールバック・ポートを指す必要があります。

Server1=mycomputer.com:1272 : セキュアなSSLポート

Server2=mycomputer.com:389 : フォールバック・ポート


Synchronization\LDAP\Required

必須（「Synchronization」 - 「LDAP」）

「Required LDAP/IBM Synchronization」設定は、 すべてのLDAPシンクロナイザ拡張に対して設定する必要があります。

Directory Type

特定のタイプのディレクトリ・サーバー。ディレクトリ・サーバーが示されていない場合は、アップグレード時に下位互換性用の「Unspecified LDAP Directory」（デフォルト）を選択します。それ以外の場合は、「Generic LDAP Directory」を選択します。

オプション:

  • Unspecified LDAP Directory（LDAPのデフォルト）
  • Novell eDirectory
  • Generic LDAP Directory
  • Sun Java System Directory
  • IBM Tivoli Directory Server（IBMのデフォルト）
  • Oracle Directory Server
Extension location

LDAP/IBM Directory Serverシンクロナイザ拡張のパス\ファイル名。

（デフォルト・パスは、 C:\Program Files \Passlogix\v-GO SSO \
\Plugin\SyncMgr\LDAPEXT\ldapsync.dll です）
Servers

同期を行うために接続するサーバーおよび接続順序を指定します。チェック・ボックスを選択し、「...」をクリックして「Edit List」ダイアログ・ボックスを開きます。各行にサーバーを1つ入力します。[Enter]キーを押して各行を終了します。他のデリミタ文字を使用しないでください。

形式は次のとおりです。

computer],port[:

それぞれの意味は次のとおりです。

computerは、サーバー名またはIPです。

portが指定されていない場合は、デフォルト（SSLは636、SSL以外は389）が使用されます。

例:

127.0.0.1
127.0.0.1:456
somewhereelse.com:8080
anotherplace.com

この拡張が機能するには、少なくとも1台のサーバーを指定する必要があります。

ポートを指定する場合は、「SSLFallback」を参照してください。
SSL

SSL経由で接続する場合に選択します。

オプション:

  • Connect without SSL (insecure; default port #389)（デフォルト）
  • Connect via SSL (default port #636)
User Paths

LDAPディレクトリ検索が有効でない場合の、ユーザー・アカウントの場所を示す完全修飾されたパス。検索するパスの数に制限はありません。この拡張機能では、ユーザー・アカウントを検索して、そのパスを順に検索します。LDAPディレクトリ検索を使用するときに、指定したUserPathでユーザー・アカウントが見つからない場合は、そのパスから下方向にディレクトリ・ツリーが検索されます。

この拡張が機能するには、「Naming Attribute string」の値または「User Paths」の1つ以上の値を指定する必要があります。

「User Paths」を使用する場合は、「Alternate User ID location」を使用しないでください。


Synchronization\LDAP\Advanced

拡張（「Synchronization」 - 「LDAP」）

「Advanced LDAP/IBM Synchronization」設定では、すべてのLDAPシンクロナイザ拡張を対象とした拡張オプションを制御します。

特定のユーザー・アカウントを検索する前後に、ディレクトリにバインドできます。バインドの前にユーザー・アカウントを検索すると、ESSO-LMは指定したユーザー・パスから検索を開始し、ユーザー・アカウントが見つかるまでディレクトリ・ツリーの下方に検索を続け、そのディレクトリにバインドします。または、すべてのパスを検索します。ESSO-LMが指定したユーザー・アカウントを見つけられない場合、システムの構成が正しくないので管理者に連絡するようにというメッセージが表示されます。

通常、ESSO-LMはLDAPディレクトリに対して匿名バインディングを使用しますが、匿名バインディングが無効な場合にユーザーを検索するために、参照専用アカウントを作成することもできます。そのような場合、アカウント名はユーザーの名前でないため、すぐに特定できません（たとえば、従業員IDや社会保障番号などの場合があります）。代替ユーザーIDオプションが有効になっている場合、参照専用アカウントによってユーザー検索が容易になります。このオプションでは代替ユーザーIDに属しているユーザーを特定します。「Alternate User ID location」、「BIND User Name」および「BIND User Password」設定を使用して、参照専用アカウントを構成します。

Admin Group DN | 管理グループの識別名。この値はACI内にあります。例: cn=configuration administrators,ou=groups,ou=topologymanagement,o=netscaperoot
Alternate User ID location

ユーザー名以外の属性でユーザーを検証するときに、該当するユーザー・オブジェクトが存在する場所を示します。

例:

ログオンの従業員ID番号でユーザーの認証を行い（empid属性に対する検証）、ユーザー・オブジェクトがou=people,dc=computerにある場合は、この場所を次のように設定します。

empid=%user,ou=people,dc=computer

次のようには設定しないでください。

uid=user,ou=people,dc=computer

Novell eDirectoryの場合、「Alternate User ID location」は、次のように設定します。
uid=%user,path to the object%

「Naming Attribute string」を使用する場合は、「User Paths」を使用し、「Alternate User ID location」は使用しないでください。
BIND Timeout | LDAP BINDコールをタイムアウトする時間（ミリ秒）（デフォルトはオペレーティング・システムによって異なります）。
BIND User DN

LDAP参照専用アカウントのユーザーDNを指定します。これは、「uid=%username%,ou=people,dc=%CompanyName%」という形式にする必要があります（この場合、uid=jsmith、ou=people、dc=yourcompany、dc=comなどです）。

LDAPディレクトリ検索機能をディレクトリで有効にするには、匿名バインディングが必要です。匿名バインディングが有効でない場合は、このアカウントを使用してディレクトリ検索を実行する必要があります。「User Paths」または「Alternate User ID location」のいずれを使用していても、検索は実行されます。
BIND User Password

LDAP参照専用アカウントのユーザー・パスワードを指定します。

LDAPディレクトリ検索機能をディレクトリで有効にするには、匿名バインディングが必要です。匿名バインディングが有効でない場合は、このアカウントを使用してディレクトリ検索を実行する必要があります。「User Paths」または「Alternate User ID location」のいずれを使用していても、検索は実行されます。
Configuration Objects Base Locations

ロールまたはグループ対応の構成オブジェクトの検索を開始する場所を指定します。検索は指定された場所から始まり、ツリーの下方向に進みます。この設定のエントリがない場合、検索はベースの場所から開始されます。

Descriptive name

ログオン・ダイアログのタイトルです。同じ名前を持つ複数のシンクロナイザ拡張を区別するために用意されています。

このエントリは必須ではありません。
DSAME disabled-account support

Sun Java System Directory Server（以前のiPlanet Directory Server Access Management Edition（DSAME））の無効アカウントを認識します。

オプション:

  • The server is not a Sun Java System Directory Server（デフォルト）
  • The server is a Sun Java System Directory Server
Enable Directory Search for users | ユーザー・アカウントのディレクトリ検索を有効または無効にします。指定されたパスにユーザー・アカウントが見つからない場合は、その場所から下方向にディレクトリ・ツリーが検索されます。「User Paths」または「Alternate User ID location」のいずれを使用していても、検索は実行されます。
Logon attempts

同期ダイアログをユーザーに示す回数。デフォルトは3です。つまり、誤った資格証明を送信した場合、同期ダイアログが最大で3回表示されます。

Naming Attribute string

「UserPaths」の前に付加する文字列。ユーザーのドメイン名が次の形式である場合は必須です。

cn=%UserName%,ou=people,dc=computer&n bsp;

次の形式の場合は、必須ではありません。

namingattribute=%UserName%,ou=people,dc=computer

（namingattributeは任意の文字列です)。必要に応じて、cnに設定します。

Novell eDirectoryの場合は、この値を通常cnに設定する必要があります。

「Naming Attribute string」を使用する場合は、「User Paths」を使用し、「Alternate User ID location」は使用しないでください。
Prompt when disconnected

同期イベントが失敗した場合、ユーザーは確認または通知なしでオフラインで作業できます。

オプション:

  • Prompt/notify the user（デフォルト）
  • Do not prompt
Security Version

この設定はAdmin Group DN設定とともに使用し、配布された環境用のLDAPユーザー資格証明を格納するためにESSO-LMが使用するPeopleコンテナのセキュリティ権限の更新を可能にします。

この設定を行うには、次の手順を実行します。

  1. 新しいセキュリティで使用される新しいAdmin Group DNを提供します。これは、セキュリティ・グループの識別名です。
  2. Security Versionを現在の値より1つ高い値に設定します。
  3. 設定を配布します。

次回ESSO-LMが同期を実行するとき、セキュリティが新しいAdmin Group DNに更新され、現在の内部のSecurity Versionが設定された値に設定されます。これにより、セキュリティの更新が一度だけ強制的に実行されます。

この設定は、セキュリティ変更時の通常のアップグレード・パスとして使用されるという意味ではありません。様々なサーバー用のメカニズムのかわりに使用することをお薦めします。
Share credentials with Primary Logon Method

この設定によって、同じ資格証明を持つシンクロナイザと認証方式を使用する場合に、認証が重複して発生しないようにできます。

この設定ではシンクロナイザと認証方式の資格証明をリンクするため、資格証明が同じ場合は、ユーザーが再入力しなくてもその資格証明が再利用されます。

資格証明を共有する認証方式のカンマ区切りリストを入力します（例: WinAuth, MSAuth）。

他の認証方式名を指定するには、その認証方式のレジストリ（HKLM\Software\Passlogix\AUIの下）にリストされている名前を参照してください。
Show user path

「Yes」に設定した場合、ユーザーが認証を求められると「User path」フィールドが表示されます。

オプション:

  • Yes（デフォルト）
  • No

これはESSO-LMバージョン11.1.1.1.0での新しい設定です。
When SSL fails SSL接続に失敗したときのセキュアでない接続へのフォールバック。

オプション:

  • Do not connect if the SSL connection fails（デフォルト）
  • Connect without SSL (insecure) if the SSL connection fails

SSLFallbackを選択し、「Servers」に示されているサーバーのいずれかにポート指定が含まれている場合は、フォールバック・ポートを「Servers」の追加のエントリとして指定する必要があります。

例:

SSL接続に対してmycomputer.com:1272が指定されている場合は、次のように、追加のエントリがフォールバック・ポートを指す必要があります。

Server1=mycomputer.com:1272 : セキュアなSSLポート

Server2=mycomputer.com:389 : フォールバック・ポート


Synchronization\Ora\Required

必須（「Synchronization」 - 「ORA」）

「Required Oracle Synchronization」設定は、すべてのOracleシンクロナイザ拡張に対して指定する必要があります。

Extension location

データベース・シンクロナイザ拡張のパス\ファイル名。

（デフォルトは、C:\Program Files\Passlogix\v-GO SSO
 \Plugin\SyncMgr\DBEXT\DBExt.dllです）
Servers

同期を行うために接続するデータベース・サーバーおよび接続順序を指定します。チェック・ボックスを選択し、「...」をクリックして「Edit List」ダイアログ・ボックスを開きます。各行に1台のデータベース・サーバーの完全接続アドレス（computerName.dbServerName）を入力します。[Enter]キーを押して各行を終了します。他のデリミタ文字を使用しないでください。

この拡張が機能するには、少なくとも1台のサーバーを指定する必要があります。

Oracleデータベースに接続するには、次の接続文字列を使用します。

Provider=OraOLEDB.Oracle;Data Source=%MachineName%;Extended Properties='OSAuthent=1'

この場合、Data Sourceの値は構成ごとに異なります。

Oracleデータベースに接続するには、Oracle 10gクライアントをAdministrative Consoleと同じマシン上にインストールする必要があります。


Synchronization\Ora\Advanced

拡張（「Synchronization」 - 「DBEXT/ORA」）

「Advanced Database/Oracle Synchronization」設定では、すべてのデータベース/Oracleシンクロナイザ拡張を対象とした拡張オプションを制御します。

Append Domain when naming objects

ユーザーのコンテナに名前を付ける際にユーザー名にユーザーのドメインを追加することを有効にします。たとえば、ドメインcompanyおよびユーザーjameskの場合、コンテナは、このフラグを無効にするとjameskと名付けられ、このフラグを有効にするとjamesk.companyと名付けられます。（デフォルトは0です）

オプション:

  • Disable
  • Enable


リポジトリ

同期リポジトリへの接続を表示および提供します。

  • 現在のSSO同期リポジトリを表示するには、左側のペインの「Repository」をクリックします。

または、どの接続もアクティブでない場合は、次の操作を実行します。

  • 左側のペインで「Repository」を右クリックし、ショートカット・メニューから「Connect to...」を選択します。

リポジトリに関するアクションおよびオプション

右側のペインの「Repository」ウィンドウでオブジェクトを右クリックすると、コマンドおよびオプションが含まれるショートカット・メニューが表示されます。

コンテナを選択した場合

Publish SSO Objects Here | 「Publish to Repository」ダイアログ・ボックスを開きます。ここで、アプリケーション・テンプレートおよびリポジトリに優先するエージェント設定などの構成オブジェクトを公開できます。 これはESSO-LMバージョン11.1.1.1.0での新しい設定です。
Bring Multiple Objects to Console | 現在のコンソール設定にインポートする複数の構成オブジェクトを選択可能なリストを表示します。 これはESSO-LMバージョン11.1.1.1.0での新しい設定です。
Add Locator Object | ロケータ・オブジェクトを作成します（ディレクトリ・サーバーのみ）。
Create People Container | Microsoft Active Directory以外のディレクトリ・システム上でアプリケーションの資格証明記憶域に使用されるou=Peopleコンテナを作成します。 これはESSO-LMバージョン11.1.1.1.0での新しい設定です。
New Container | 選択したコンテナ内に新しいコンテナを作成します。
Delete | コンテナおよびその中のすべてのオブジェクトを削除します。
Refresh | ディレクトリのウィンドウを更新します。

優先オブジェクトを選択した場合

Configure

コンソール設定またはデータファイルから管理優先設定オブジェクトを作成します。

View

選択したオブジェクトを素早く表示し、そのオブジェクトをINIファイルに保存するためのオプションも示します。

Bring to Console

現在のコンソール設定にオブジェクトをインポートします。

  • インポートしたファイルに現在の構成の項目と同じ名前の項目（アプリケーション、ポリシー、グループ）が含まれている場合は、「Import/Merge Conflict」ダイアログ・ボックスが表示されます。
  • インポートしたファイルに現在の構成の既存セットと同じ名前のグローバル・エージェント設定セットが含まれている場合は、インポートしたセットに「既存の設定のコピー」という名前が付与されます。

Save as File

ローカルのINIファイルにオブジェクトを保存します。

Delete

オブジェクトをリポジトリから削除します。


コンテナの追加

新しいコンテナ

このプロンプトを使用して、現在のリポジトリの選択したノードで、新しいコンテナ・オブジェクトに名前を付けます。

新しいコンテナに名前を付けるには、次の手順を実行します。

  • コンテナ名を入力し、「OK」をクリックします。

詳細は、「リポジトリ」を参照してください。


コンソールへの複数のオブジェクトのインポート

コンソールにインポートするオブジェクトの選択

このダイアログ・ボックスは、選択したコンテナおよびその子コンテナに格納されているすべてのオブジェクトをフラット・リストで表示します。さらに、現在の「Administrative Console」設定にインポートする複数のオブジェクトを選択できます。

リストから複数のオブジェクトを選択して、Administrative Consoleにインポートするには、次の手順を実行します。

  • 目的の各オブジェクトを[Ctrl]キーを押しながらクリックします。

    または

  1. 目的の範囲にある最初のオブジェクトと最後のオブジェクトを[Shift]キーを押しながらクリックします。
  2. 「OK」をクリックします。


リポジトリの参照

このダイアログ・ボックスでは、現在接続しているディレクトリ・サーバーの階層にある、特定のターゲット・リポジトリ・コンテナにナビゲートできます。また、必要に応じて、異なるサーバーに接続することもできます。

ターゲット・リポジトリ・コンテナを選択するには、次の手順を実行します。

  1. （オプション）Administrative Consoleが現在接続しているディレクトリ・サーバーが目的のターゲット・サーバーでない場合は、「Change Server」をクリックして接続情報に入力し、「OK」をクリックして目的のサーバーに接続します。
  2. ディレクトリ・ツリーで、ターゲット・コンテナにナビゲートして選択します。
  3. 「OK」をクリックします。

これはESSO-LMバージョン11.1.1.1.0で変更された設定です。


SSOサポートの構成（データファイルから）

ESSO-LMサポートの構成（データファイルから）

このウィザード・ページは、1つ以上のデータファイルをソースとして使用して、選択したシンクロナイザ・コンテナにエージェント構成をエクスポートする場合に使用します。エクスポートできるものは次のとおりです。

  • 1つ以上のアプリケーション・ログオン
  • はじめて使用する場合（バルク追加）のオブジェクト
  • グローバル・エージェント設定セット（.iniファイルまたは.regファイルから）

データファイルからの管理優先設定のエクスポート

  1. エクスポートする各管理優先設定オブジェクトのソースとして、ファイル名を入力（または「Browse」を選択してデータファイルを選択）します。エクスポートできるものは次のとおりです。

    • First-Time-Use（ftulist.iniファイルから）

    • Admin Overrides（有効なINIファイルまたはREGファイルから）
    • Applications（entlist.iniファイルから）
  2. 「Next」をクリックします。ウィザードに優先構成の要約が表示されます。
  3. 「Finish」をクリックしてエクスポートを完了します。


リポジトリへの接続

ESSO-LM Administrative Consoleを同期リポジトリに接続します。

同期リポジトリへの接続

  1. 「Repository」を右クリックし、ショートカット・メニューから「Connect to」を選択します。
  2. 必要な接続情報を入力または選択して、「OK」をクリックします。

接続コントロール

SyncPathまたはServer Name

  • 「Repository Type」でディレクトリ・サービスを選択した場合は、サーバー名()を入力または選択します。

    または

  • 「Repository Type」でデータベースを選択した場合は、インスタンス名（Oracle用）、またはバックスラッシュで区切られたサーバー名とインスタンス名（SQL Server用）を入力または選択します。

    または

  • 「Repository Type」でファイル・サービスを選択した場合は、同期フォルダへのパスを入力または選択します。

「Edit List」 を選択して、ドロップダウン・リストからディレクトリ/サーバーを削除できます。

SQL Serverの場合、データベース・サーバーが接続先のコンピュータ上の唯一のインスタンスであるときには、コンピュータ名のみを入力します。ターゲット・コンピュータに複数のデータベース・サーバー・インスタンスがある場合は、完全接続アドレス（computerName\dbServerName）を入力します。

ドライブ名およびディレクトリ・パスとしてでなく、UNCパスとしてファイル・システム・サーバーを指定する必要があります。例: D:\ShareNameではなく\\ServerName\ShareName

Repository Type

ドロップダウン・リストから「File System Sync」、ディレクトリ・サービスまたはデータベース・サーバーを選択します。

「OpenLDAP Directory Server」を選択したときに、Extend Schema Statusエラーが表示された場合は、スキーマを手動で拡張します。
Port | （ディレクトリ・サーバーのみ）ポート番号を入力します。
Database | （データベース・サーバーのみ）接続先のデータベースの名前。既存のデータベースの名前を入力します（デフォルトはvGOSSO）。
Use secure channel (SSL) | Secure Socket Layerを有効にする場合に選択します（ディレクトリ・サーバーのみ）。
User ID | ユーザー名を入力します。
Password | パスワードを入力します。


リポジトリ・リストの編集

コンソールにインポートするオブジェクトの選択

このダイアログ・ボックスには、最近使用されたターゲット・リポジトリのリストが表示され、リストから不要なエントリを削除できます。

リストから不要なエントリを削除するには、次の手順を実行します。

  1. リストのエントリを選択します。
  2. 「Delete」をクリックします。
  3. 他の不要なリスト・エントリに対して、手順1から2を繰り返します。
  4. 終了したら、「OK」をクリックします。

これはESSO-LMバージョン11.1.1.1.0での新しい設定です。


サーバー・リストの編集

このダイアログ・ボックスは、「Connect to Repository」ダイアログ・ボックスの「Server Name」ドロップダウン・ボックスにリストされるサーバーを削除する場合に使用します。

  • サーバーを選択して「Delete」をクリックします。終了したら、「OK」をクリックします。


手動によるOpenLDAPスキーマ拡張

「Connect to Repository」ダイアログ・ボックスで、「OpenLDAP Directory Server」が「Repository Type」として選択され、Extend Schema Statusステータス・エラーが表示された場合は、スキーマを手動で拡張する必要があります。

表示されるエラー・メッセージは、次のとおりです。

============= ERROR =============
Automated schema extention is not supported by this server.Use the file located at "C:\Program Files\Passlogix\v-GO SSO Administrative Console\DirectorySchema\vgo\OLDAP\sso.schema" to extend the schema manually.
Extend Schema ABORTED!

このエラーが表示された場合、手動でスキーマを拡張するために、次の手順を実行します。

  1. sso.schemaファイルをOpenLDAPサーバーにコピーします。sso.schemファイルは、次の場所にあります。
    C:\Program Files\Passlogix\v-GO SSO Administrative Console\DirectorySchema\vgo\OLDAP\sso.schema
  2. sso.schemaファイルを次のディレクトリ（または、OpenLDAP構成の他のスキーマ・ディレクトリ）に配置します。
    /usr/local/etc/openldap/schema
  3. 新しいスキーマ・ファイルを含むために、OpenLDAP構成ファイルを変更する必要があります。ファイルを開き、次の行を追加します。
    include <path>/sso.schema
    <path>は前の手順で指定したパスです。

UNIXマシンでは、このファイルをslapd.confと呼びます。


リポジトリへの公開

このダイアログ・ボックスでは、選択したターゲット・コンテナに、選択した構成オブジェクトをディレクトリ形式の階層（デフォルト）、またはフラット形式の構成ファイルとして公開できます。

目的のオブジェクトを選択して、リポジトリに公開するには、次の手順を実行します。

  1. 「Available configuration objects」リストで、目的のオブジェクトにナビゲートし、選択します。
オブジェクトが構成されているカテゴリのみが、このリストに表示されます。たとえば、パスワード生成ポリシーが存在しない場合、対応するカテゴリはこのリストには表示されません。
  2. 「>>」をクリックし、選択したオブジェクトを公開予定リストの「Selected」オブジェクトに移動します。（このリストからオブジェクトを削除して公開しないようにするには、オブジェクトを選択して、「<<」をクリックします。）
  3. （オプション）ターゲット・コンテナで右クリックして「Publish SSO Objects Here」コマンドを起動しなかった場合は、「Target repository」ドロップダウン・リストから目的のコンテナを選択します。

リストにターゲット・コンテナのパスが表示されない場合、「Browse」をクリックして目的のコンテナを検索して選択します。

このリストから不要なエントリを削除するには、リストで「Edit list」オプションを選択します。
  4. （オプション）構成オブジェクトをフラット形式で格納する必要がある環境の場合は、個々のオブジェクトとしてでなく、構成ファイルで「Store selected items」チェック・ボックスを選択します。
ターゲット・コンテナに存在する場合、このオプションを選択することで、既存の構成ファイルに格納されているすべての項目が上書きされます。
  5. （オプション）はじめて使用するオブジェクト（FTUList）を作成する場合、対応するチェック・ボックスを選択します。
このオプションは、手順4で構成オブジェクトをフラット形式で格納することを選択した場合にのみアクティブになります。
  6. 「Publish」をクリックします。コンソールは、選択したオブジェクトをターゲット・リポジトリに公開します。
公開プロセスが完了するまで、ダイアログを終了したり、コンソールを閉じないでください。オブジェクトが公開されると、ダイアログは自動的に閉じます。

オブジェクトまたはオブジェクトのグループを即時に公開するには、左側のツリーでオブジェクトを選択し、コンテキスト・メニューから「Publish」（単一のオブジェクトおよびグループ）または「Publish To」（単一のオブジェクトのみ）を選択します。

これにより、「Publish to Repository」ダイアログを起動し、公開されるオブジェクトのリストに、自動的にオブジェクトを追加します。次のことに注意してください。

  • 「Publish」オプションを選択した場合、「Publish to Repository」ダイアログが表示されます。
  • 「Publish To」を選択してリポジトリを選択した場合、選択したオブジェクトはそのリポジトリに自動的に公開されます。「Publish to Repository」ダイアログは表示されません。（選択したリポジトリに現在接続していない場合は、ディレクトリ・サーバーに対する認証が求められます。）

これはESSO-LMバージョン11.1.1.1.0で変更された機能です。


選択可能なバックアップ・コマンドライン同期

選択可能なバックアップ/リストア

ユーザー資格証明のローカル・ストアとリモートのバックアップ・ファイルを比較して、古いセットの上に新しいセットを書き込むようにエージェントを構成することができます。この選択可能なバックアップ/リストア（または同期化）は、コマンドラインから（したがって、atまたはtimedジョブから）、または特定のエージェント・イベント（起動タスク、リフレッシュ・タスクなど）を構成することによってトリガーできます。

資格証明の個々のセットは比較されません。同期の詳細は、「同期」を参照してください。

コマンドライン同期

コマンドライン同期をトリガーするには、次の構文を使用してコマンドラインからエージェントを実行します（現在エージェントを実行中の場合も、この構文を使用します）。

ssoshell.exe /mobility /sync [path] /silent

説明:

[path] | バックアップ・ファイルが保存されているディレクトリへの実際のパスです。（デフォルトは、最後にコマンドライン・バックアップ・ファイルが保存されたディレクトリ、またはShell:AutoBackupPathが指す場所です。）
/silent | バックアップ/リストアの実行時にバックアップ/リストア・ウィザードを表示しません。

\\FS\Backup\Privateのネットワーク共有からの完全なサイレント同期化を実行するには、次のコマンドを実行します。

ssoshell.exe /mobility /sync "\FS1\Backup\Private" /silent

最後に使用された場所、またはShell:AutoBackupPathが指す場所に同期化するには、次のコマンドを実行します。

ssoshell.exe /mobility /sync /silent


SSOサポートの構成

ESSO-LMサポートの構成

「Configure SSO Support」ウィザードは、ファイル・システム、データベースまたはディレクトリ・サービスのシンクロナイザを使用して、エンド・ユーザーに管理優先設定およびアプリケーション構成を配置する場合に使用します。エクスポートできるオブジェクトは、次のとおりです。

  • 1つ以上のアプリケーション・ログオン
  • はじめて使用する場合（バルク追加）のオブジェクト
  • グローバル・エージェント設定のセット。

「Configure SSO Support」ウィザードを使用すると、現在のコンソール設定または1つ以上のデータファイルから、選択したシンクロナイザ・コンテナ・オブジェクトに、優先設定を容易にエクスポートできます。

詳細は、「同期」を参照してください。

シンクロナイザ・コンテナへの管理優先設定のエクスポート

  1. ESSO-LMシンクロナイザ・リポジトリに接続します。
  2. 右側のペインで、コンテナ・オブジェクトを右クリックし、ショートカット・メニューから「Configure SSO Support」を選択して、ウィザードを起動します。
  3. 管理優先設定のデータソースを選択し、要求された情報を指定します。
    • Administrative Console
    • データファイル


SSOサポートの構成（コンソールから）

ESSO-LMサポートの構成（コンソールから）

このウィザード・ページは、現在のコンソール設定をソースとして使用して、選択したシンクロナイザ・コンテナにエージェント構成をエクスポートする場合に使用します。エクスポートできるものは次のとおりです。

  • 1つ以上のアプリケーション・ログオン
  • はじめて使用する場合（バルク追加）のオブジェクト
  • グローバル・エージェント設定のセット。

コンソールからの管理優先設定のエクスポート

  1. 次のいずれかを実行します。

    • 「Send All Applications」を選択します

      または

    1. 「Send Some Applications」を選択し、次の処理を実行します。

    2. 「Select Apps」をクリックします。

      または

    1. 「Select Applications」ダイアログ・ボックスから、送信するアプリケーションを選択して「OK」をクリックします。
    2. 「Send No Apps」を選択します。
  2. 必要に応じて、「Create First-Time-Use (FTUList) object」を選択します。
  3. 必要に応じて、「Admin. Overrides」ドロップダウン・リスト・ボックスからグローバル・エージェント設定セットを選択します。
  4. 「Next」を選択します。ウィザードに優先構成の要約が表示されます。
  5. 「Finish」を選択してエクスポートを完了します。

ウィザード・ページの表示

  1. ESSO-LMリポジトリに接続します。
  2. 右側のペインで、コンテナ・オブジェクトを右クリックし、ショートカット・メニューから「Configure SSO Support」を選択して、ウィザードを起動します。
  3. 「Administrative Console」を選択します。


ロケータ・オブジェクトの追加

「Add Locator Object」ダイアログ・ボックスは、ロケータを作成する場合に使用します。ロケータとは、エージェントにユーザー資格証明が保存されている（または保存できる）コンテナを示すためのディレクトリ・オブジェクトのことです。すべてのエンド・ユーザー用のデフォルト・ロケータを作成したり、特定のエンド・ユーザー用のロケータを作成できます。

詳細は、ディレクトリ・サーバー: ロケータ・オブジェクトの作成に関する項を参照してください。

コントロール

Locator Name | すべてのユーザーのロケータを作成するには、defaultと入力します。特定のエンド・ユーザーのロケータを作成するには、ユーザーの識別名を入力します。
Forwarding Location | ユーザー資格証明が保存されているコンテナにナビゲートします。「OK」をクリックします。
Store data under the user objects (AD only)

（Active Directoryのみ）このチェック・ボックスは、特定のユーザー（「Locator Name」がdefaultの場合はすべてのユーザー）の資格証明を特定の「Forwarding Location」ではなく、各ユーザー・オブジェクトの下のコンテナに保存する場合に選択します。

この設定では、ディレクトリ・スキーマを更新し、ディレクトリ・ルート・セキュリティ設定を変更する必要があります。このためには、「Repository」メニューの「Enable Storing Credentials under User Object」コマンドを使用します。

この設定を使用すると、ユーザーを個別に指定して、そのユーザーの資格証明のみを各ユーザー・オブジェクトの下に保存できます。それ以外のユーザーの資格証明は、デフォルト・ロケータで指定したとおりに保存されます。

ロケータ・オブジェクトを使用しないですべてのユーザーの資格証明を自分のユーザー・オブジェクトの下に保存するには、「Location for storing user credentials」設定（Synchronization\Selected Active Directory sync\Advancedの下）を使用します。


構成オブジェクトの表示

オブジェクトの表示

このダイアログ・ボックスを使用して、選択した構成オブジェクトの内容を表示します。INI（テキスト）ファイルにオブジェクトを保存するには、「Save To」をクリックします。詳細は、「リポジトリ」を参照してください。

表示された構成情報を編集できます。ただし、変更はINIファイルに保存されるだけでオブジェクト自体には保存できません。


アドオン・モジュール

ESSO-LMアドオン・モジュール

個々の環境に合わせてESSO-LM機能をカスタマイズするために、Oracleでは、いくつかのアドオン・モジュールが提供されます。ESSO-LM Administrative Consoleには、これらのアドオン・モジュールに固有の設定が存在します。これらの設定は、対応するモジュールでのみ機能します。

Oracle Enterprise Single Sign-on Authentication Manager | Oracle Enterprise Single Sign-on Authentication Manager（ESSO-AM）では、厳密な認証および複数の認証方式がサポートされています。管理者はレベルとしてグレードを定義して、使用している認証方式に基づいてアプリケーションに対するアクセス権を制限できます。
Oracle Enterprise Single Sign-on Provisioning Gateway | Oracle Enterprise Single Sign-on Provisioning Gateway（ESSO-PG）を使用すると、管理者は、プロビジョニング・システムを使用してESSO-LMにユーザーのユーザー名およびパスワードを自動的にプロビジョニングできます。管理者は、プロビジョニング・システム内の特定のアプリケーションのユーザー名およびパスワードを追加、変更および削除し、その変更をESSO-LMに反映させることができます。
Oracle Enterprise Single Sign-on Kiosk Manager | Oracle Enterprise Single Sign-on Kiosk Manager（ESSO-KM）は、Kiosk環境のユーザー・セッションを管理します。
ESSO Shared Accounts Manager | ESSO Shared Accounts Manager（ESSO-SAM）は、管理者、一時的な作業者、およびアカウントIDを共有する他のユーザーに、システムおよびアプリケーションのアクセス権を提供します。


Authentication Manager

Oracle Enterprise Single Sign-on Authentication Manager

Oracle Enterprise Single Sign-on Authentication Manager（ESSO-AM）は、組織で使用すると、スマート・カード、バイオメトリック・デバイス、Entrust認証方式などの厳密認証を自社のアプリケーションすべてに対してシームレスに結び付けることができます。ユーザーはその時々において多様な認証方式を使用し、使用する認証方式がアプリケーション・アクセスを制御します。

ESSO-AMは、Oracleとは別に使用可能なESSO-LMへのアドオン・モジュールです。

ESSO-AMによって、ESSO-LMに次の3つの機能が追加されます。

  • 初期認証、再認証、強制認証などのすべての認証イベントに対して、スマート・カードや生体認証装置などの様々な強力な認証方式がサポートされます。
  • 複数の認証方式のサポートによって、次のことが可能になります。
  • エンド・ユーザーを認証するための複数のログオン方式
  • グレード別認証のサポート
  • エンド・ユーザーがオンザフライで複数のログオン方式を併用および照合できるようにする代替ログオン方式。
  • 認証方式およびアプリケーションに対するグレードまたはレベルの定義。これによって、提示された認証方式の種類に基づき、ユーザーが実行できるESSO-AM機能を制御することができるようになります。

複数の認証方式のサポート

複数認証によって、エンド・ユーザーの認証に、複数のログオン方式を使用できるようになります。この機能によって、グレード別認証方式と代替認証方式をサポートできる認証方式を利用できます。

ESSO-AMの複数の認証方式の特徴は、次のとおりです。

  • 様々な認証方式を使用して認証を受け入れます。
  • グレード別認証をサポートします。
  • ユーザー・セッション中（最初のログオンからログアウトまでの間）、複数の認証方式を交互に使用できます。
  • 複数の認証方式をセッション間で交互に使用できます。
  • 管理者は次のことができます。
  • 複数の認証方式の使用の有効化または無効化
  • デフォルトのプライマリ認証方式の指定
  • 登録に必要な認証方式の指定
  • 使用している認証方式の強度に基づくアプリケーションへのアクセス制限
  • 複数の認証方式の単一セッションでの交互の使用の有効化または無効化
  • セッション間での複数の認証方式の交互使用の有効化または無効化。


グレード別認証

グレード別認証によって、ESSO-AMでの認証に対してグレードまたはレベルを定義できます。グレード別認証によって、提示された認証方式の種類に基づき、ESSO-AMユーザーが実行できる機能を制御することができるようになります。レベルまたはグレードは、特定のイベントまたはアクティビティに対して、適切な水準の認証が行われたことを保証するために使用することができます。

アプリケーション・レベルの認証グレードの構成

アプリケーションの構成

認証グレードは数値です。認証グレードが有効になっており、グレード・レベルが指定されていない場合、認証グレードは自動的にグレード・レベル1に初期設定されます。高いグレード・レベルが指定されると、リクエストされる認証レベルが強くなります。

グレードのスケールは、任意に構成できます。たとえば、想定される通常の使用例では1から3のスケールになる場合でも、必要に応じて柔軟に、1から5、または1からnにすることができます。一貫性を保つため、1未満のグレードは、すべて1に変更されます。

ESSO-AMでは、使用される認証方式とグレードをマッピングすることにより、認証グレードをサポートします。デフォルトでは、ほとんどの認証方式で、それぞれのグレード・レベルをサポートしていないため、特定の認証方式によってグレード・レベルを管理する必要があります。

ユーザーが低すぎるグレード・レベルで資格証明にアクセスしようとする場合、より高いグレードで認証するように求められ、成功した場合のみアクセス権を取得できます。

ロックアウトは、通常の認証ロックアウト・ポリシーによって発生します。グレード別認証では、SSOのコア認証プロセスを使用するため、これは必然的に発生します。

グレード別認証および複数のプライマリ・ログオン方法には、潜在的なセキュリティの問題が存在します。複数認証が異なるグレードを使用してセットアップされていると、グレードの低い認証方式を使用するユーザーが、プライマリ・ログオン方法を複数認証から単一認証に変更できます。その結果、高いグレードが必要なログオンに対するアクセス権が与えられます。

この潜在的な問題は、コンソールでの設定によって回避できます。

「Global Agent Settings」アイコンを右クリックし、ショートカット・メニューを表示して、「Import」を選択し、「From Live HKLM」をクリックします。

リストをインポートした後、「Live」、「End User Experience」の順に展開し、「Setup Wizard」をクリックします。「Selected Primary Logon」（Registry Location: AUI:Selected）設定を「Authentication Manager」に設定します。これが選択されているかぎり、ユーザーはプライマリ・ログオン方法を変更できません。

ESSO-AMのグレード別認証

  • 多数の認証グレードまたはレベルをサポートします。
  • アプリケーションごとの認証グレードに必要な設定をサポートします。
  • 再認証を要求するSSOプロセスで、設定が必要な認証グレードをサポートします。
  • すべてのアプリケーションの認証レベルの管理設定をサポートします。
  • 認証方式のグレードの管理設定をサポートします。
  • グレード別認証イベントのロギングをサポートします。
  • 管理者は次のことができます。
  • グレード別認証のサポートの有効化または無効化
  • アプリケーションごとのグレード別認証の構成

ESSO-AMおよびグレード別認証

  • ESSO-AMは、エンド・ユーザーが直近の認証要求に使用した認証方式に基づき、ユーザーが開始するアプリケーション・ログオンを制御します。直近の認証要求とは、最初のログオン、直近の再認証、またはESSO-AMが要求した強制認証をいいます。
  • ESSO-AMの認証グレーディング・スキームには、様々な認証方式をマッピングするスキームと、それとは別にアプリケーション・ログオンをマッピングするスキームがあります。ESSO-AMでは、使用された認証方式のグレードがアプリケーション・ログオンのグレードと等しいか、それ以上である場合にのみ、ユーザーは、アプリケーションへのログオンを許可されます。
  • ユーザーが認証要求に十分な水準のグレードでの認証方式で応じない場合、ESSO-AMは、十分な水準のグレードの認証方式による再認証、またはログオン要求の取消しを要求します。
  • ユーザーが不十分なグレードの認証方式を使用して、ログオン要求または機能の実行を繰り返し試みた場合、ESSO-AMでは、ユーザーをロックし、Event Managerにイベントを記録して、ユーザーおよび管理者に通知します。
  • アプリケーション・ログオンに強力な認証を必要とするように構成しても、ユーザーがESSO-AMをインストールしていなければ（企業には強力な認証がデプロイされていても、ユーザーにはデプロイされていない場合など）、ユーザーはそれらのアプリケーションにアクセスできません。
  • Logon Managerは、直近の認証要求に使用した認証方式に応じて、その時点で使用可能なアプリケーション・ログオンを表示するだけです。
  • ESSO-AMの次の機能は、直近の認証要求で使用した認証方式のグレードに基づき、アクセスできるように、またはアクセスできないように構成できます。
  • System Tray: Logon Manager
  • Logon Manager: Delete、PropertiesおよびReveal All関数
  • Logon Manager | Properties Page: Reveal Password関数
  • 使用した認証のグレードではReveal All関数を使用できる場合でも、示されるパスワードは、Reveal All関数の認証に使用したグレードと同等以下のグレードであるアプリケーションのパスワードのみです。


セッション管理の概要

Kiosk Manager

Oracle Enterprise Single Sign-on Kiosk Manager（ESSO-KM）は、Kiosk環境のユーザー・セッションを管理します。次のESSO-KM設定が、ESSO-LM Administrative Consoleで構成されます。

  • アクション
  • セッション・ステート
  • 一般的な操作設定
  • 確認メッセージ
  • ESSO-KM Desktop Manager UIカスタマイズ
  • ESSO-KM Desktop Managerのテキスト・メッセージ
ESSO-KMは、Oracleとは別に使用可能なESSO-LMへのアドオン・モジュールです。ESSO-KMの詳細は、ESSO-KM製品のドキュメントを参照してください。


SM SendKeys形式

Oracle Enterprise Single Sign-on Kiosk Manager - SendKeys形式

一連のキーストロークを使用してアプリケーションを終了すると、エンド・ユーザーの画面でちらつきが発生します。このちらつきは、アプリケーションの終了にSendKeysを使用しているために発生します。

それぞれのキーは、1つ以上の文字で表されます。キーボードの1文字を指定するには、その文字自体を使用します。たとえば、文字Aを表すには、メソッドに文字列「A」を渡します。複数の文字を表すには、先行する文字にそれぞれの追加文字を付加します。文字A、BおよびCを表すには、パラメータを「ABC」と指定します。

SendKeysでは、プラス記号（+）、カレット（^）、パーセント記号（%）、チルダ（~）および丸カッコ()に特殊な意味があります。これらのいずれかの文字を指定するには、中カッコ{}で囲みます。たとえば、プラス記号を指定するには、{+}を使用します。中カッコを指定するには、{{}と{}}を使用します。SendKeysでは大カッコ[ ]に特殊な意味はありませんが、大カッコは中カッコで囲む必要があります。他のアプリケーションでは大カッコに特殊な意味があり、動的データ交換（DDE）の発生時には重大な意味を持つ場合があります。

[Enter]や[Tab]などのキーを押した場合の表示されない文字、および文字ではなくアクションを表すキーを指定するには、次の表に示すコードを使用します。

キー | コード
BACKSPACE | {BACKSPACE}、{BS}または{BKSP}
BREAK | {BREAK}
CAPS LOCK | {CAPSLOCK}
DELまたはDELETE | {DELETE}または{DEL}
下矢印 | {DOWN}
END | {END}
ENTER | {ENTER}または~
ESC | {ESC}
HELP | {HELP}
HOME | {HOME}
INSまたはINSERT | {INSERT}または{INS}
左矢印 | {LEFT}
NUM LOCK | {NUMLOCK}
PAGE DOWN | {PGDN}
PAGE UP | {PGUP}
PRINT SCREEN | {PRTSC}（将来の使用のために予約済）
右矢印 | {RIGHT}
SCROLL LOCK | {SCROLLLOCK}
TAB | {TAB}
上矢印 | {UP}
F1 | {F1}
F2 | {F2}
F3 | {F3}
F4 | {F4}
F5 | {F5}
F6 | {F6}
F7 | {F7}
F8 | {F8}
F9 | {F9}
F10 | {F10}
F11 | {F11}
F12 | {F12}
F13 | {F13}
F14 | {F14}
F15 | {F15}
F16 | {F16}
キーパッドの加算 | {ADD}
キーパッドの減算 | {SUBTRACT}
キーパッドの乗算 | {MULTIPLY}
キーパッドの除算 | {DIVIDE}

[Shift]、[Ctrl]、[Alt]の各キーを任意に組み合せたキーを指定するには、そのキー・コードの前に、次のコードを1つ以上置きます。

キー・コード

SHIFT +

CTRL ^

ALT %

[Shift]、[Ctrl]、[Alt]の任意の組合せを押しながら他の複数のキーを押すことを指定するには、それらのキーのコードを丸カッコで囲みます。たとえば、[Shift]を押しながら[E]および[C]を押すことを指定するには、「+(EC)」を使用します。[Shift]を押しながら[E]を押した後、[Shift]を押さないで[C]を押すことを指定するには、「+EC」を使用します。

繰返しキーを指定するには、{キー 数字}という形式を使用します。キーと数字の間には空白を入れる必要があります。たとえば、{LEFT 42}は左矢印キーを42回押すという意味であり、{h 10}は[H]を10回押すという意味です。

前述のSendKeys以外に、waitコマンドもあります。waitコマンドは{WAIT number} という形式で、numberは遅延をミリ秒単位の数で表したものです。waitは文字列の任意の場所（先頭、中間、末尾）に置き、必要に応じていくつでも使用できます。

たとえば、[Ctrl]+[Shift]+[F7]を送信し、5秒待機してから[Alt]+[F4]を送信する場合、形式は次のとおりです。

^+{F7}{WAIT 5000}%{F4}

© 2001-2002 Microsoft Corporation.All rights reserved.


プロビジョニングの管理

このノードを使用して、ユーザーのプロビジョニング権限を管理します。権限の設定には次の2つのタブを使用します。

  • Default Rights
  • Delete SSO User Right

Default Rights

このタブを使用して、作成した新しいアプリケーションそれぞれに対してプロビジョニング権限を定義します。この機能によって、作成した各アプリケーションに対して標準の権限が設定されます。アプリケーションを作成するたびに、必要に応じて権限を変更します。

コントロール
Directory | ターゲット・ディレクトリ・サーバーを選択します。
アクセス情報:
Name | このアイテムに現在アクセスできるグループまたはユーザーが表示されます。
ID | ユーザー・アカウント名が表示されます。
Access | ユーザーまたはグループに付与されている権限（ログオンの追加、変更または削除）を示します。ユーザーまたはグループのアクセス権を変更するには、ユーザーまたはグループを右クリックし、ショートカット・メニューから「Add Logon」、「Modify Logon」または「Delete Logon」を選択します。
アクション
Copy permissions to | このボタンを使用すると、現行のアプリケーションのプロビジョニング権限を複数のアプリケーションに簡単に適用できます。このボタンをクリックすると、すべてのアプリケーションが示されているダイアログ・ページが表示されます。これらのプロビジョニング権限をコピーするアプリケーションを選択します。複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします。「OK」をクリックします。
Add | 「Add User or Group」ダイアログ・ボックス（LDAPまたはActive Directoryの場合）が表示されたら、現在選択されているアイテムにアクセスする必要があるユーザーまたはグループを選択します。
Remove | 選択したユーザーまたはグループがリストから削除されます。削除するユーザーまたはグループを選択します。複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします。

「Add User or Group」ダイアログ・ボックス

「Select User or Group」ダイアログ・ボックスは、使用しているディレクトリ・サーバーによって異なります。

  • LDAP
  • Active Directory/ADAM

LDAP

現行の構成アイテム（「Add Logon」、「Modify Logon」または「Delete Logon」）用のアクセス・リストに追加する個々のユーザーまたはユーザー・グループを選択する場合は、次のダイアログ・ボックスを使用します。

コントロール
Search Base | ユーザー/グループのアカウントの検索を開始するベース・ディレクトリ（最上位のディレクトリ）。ベース・ディレクトリのすべてのサブディレクトリが検索されます。場所を入力するか、または「Change」をクリックしてディレクトリ・ツリーを参照します。
Change | 検索用のベース・ディレクトリを参照するために「Select Search Base」ダイアログ・ボックスが表示されます。このダイアログ・ボックスは、ユーザー/グループの名前を検索するためのベース・ディレクトリ（最上位のディレクトリ）を参照および選択する場合に使用します。終了したら、「OK」をクリックします。
Search | ベース・ディレクトリ内のユーザーおよびグループの検索が開始されます。
Users or Groups | 検索結果が表示されます。現行の構成アイテム用のアクセス・リストに追加する名前を選択します。複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします。アクセス・リストへの選択したアイテムのコピーを終了したら、「OK」をクリックします。

Active Directory/ADAM

現行の構成アイテム（「Add Logon」、「Modify Logon」または「Delete Logon」）用のアクセス・リストに追加する個々のユーザーまたはユーザー・グループを選択する場合は、次のダイアログ・ボックスを使用します。

コントロール
List Names From | Active Directoryのドメインまたはサーバーを選択します。
Names | 選択したドメインまたはサーバー用のユーザーおよびグループの名前が表示されます。アクセス・リストに追加する名前を1つ以上選択します。
Add | 「Names」リストで選択したユーザーおよびグループが「Add Names」リストにコピーされます。複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします。
Members | 「Names」でグループを選択した場合は、「Global Group Membership」ダイアログ・ボックスが表示されます。このダイアログ・ボックスには、選択したグループのメンバーが表示されます。
Search | 特定のユーザーまたはグループ用の1つ以上のドメインを検索するための「Find Account」ダイアログ・ボックスが表示されます。
Add Names | この時点までに追加したユーザーまたはグループの名前が表示されます。これらの名前を現行の構成アイテム用のアクセス・リストに追加する場合は、「OK」をクリックします。注意: このリスト内のユーザー名は、入力または編集できます。ただし、エントリのアカウント名が有効かどうかが確認され、アカウントが重複して選択されている場合は、「OK」をクリックすると、重複しているアカウントが自動的に削除されます。

Delete SSO User Right

このタブを使用して、ESSO-PG Administrative ConsoleでSSOユーザー削除権限を付与するユーザーを定義します。コントロールは、「Default Rights」タブの場合と同様に機能します。


目次

ESSO-LM Administrative Consoleのリファレンス項目

グローバル・エージェント設定

レジストリ設定および管理優先設定の設定

優先設定

ホスト・エミュレータの構成

Telnetサポート

Attachmate EXTRA!

BlueZone Web-to-Host

BOSaNOVA

Ericom PowerTerm

G&R Glink

Hummingbird HostExplorer

IBM Client Access

IBM Client Access Express

IBM Host On-Demand

Microsoft Internet Explorerの場合

Host On-Demandの場合

IBM Personal Communications

Jolly Giant QWS3270 PLUS

NetManage Rumba

Net SoftのNS Elite

Newhart Systems BLUES 2000

Novell LAN Workplace

PuTTY

Scanpak Aviva for Desktops

Seagull Bluezone

WRQ Reflection

Zephyr PC to Host

Zephyr Web to Host

SAPの構成

コマンドライン・オプション

Windowsイベント・ロギング・サーバーの構成

Windowsイベント・ロギング拡張

ディレクトリ・サーバー・スキーマ定義

vGOSecret

vGOUserDataオブジェクト

vGOConfigオブジェクト

vGOLocatorClass

entlist.iniキー

ルート・キー

Application Typeセクションのキー

Windowsアプリケーション・キー

SectionNサブセクションのWindowsアプリケーション・キー

MatchNサブセクションのWindowsアプリケーション・キー

ホスト/メインフレーム・アプリケーション・キー

ホスト・アプリケーション: PageNサブセクションのキー

Webアプリケーション・キー

SectionNサブセクションのWebアプリケーション・キー

パスワード・ポリシー・キー

エラー・ループ

ftulist.iniキー

ルート・キー

Password Windowsセクションのキー

My Logonsセクションのキー

Bulk Add Logonセクションのキー

MSIパッケージの内容

事前構成されたアプリケーションおよびテンプレート

トラブルシューティング

インストール

Authenticators

シンクロナイザ拡張

アンインストール

エージェントのパフォーマンス

アプリケーション・レスポンス

認証

初期認証

再認証

アプリケーション構成

すべてのアプリケーション

Windowsアプリケーション

Webアプリケーション

ホスト・アプリケーション

資格証明共有グループ

シンクロナイザ拡張

ディレクトリ拡張

ファイル・システム・サーバー

イベント・ロギング


アプリケーションの互換性に関する考慮事項

オラクル社では、テンプレートを提供しているアプリケーションのみを公式にテストおよびサポートしていますが、Windows、Web、Javaアプリケーションおよびメインフレーム/AS400エミュレータ用のビジネス・アプリケーションおよび生産性アプリケーションの大多数は、非常に高い確率で使用できます。サポート・チームは、あるアプリケーションが現状のままではESSO-LMと互換性がないと判別されないかぎり、あるいは互換性がないと決定されるまで、アプリケーション・テンプレートの構成を支援します。

次の表には、ESSO-LMにサポートの問題があることが知られているアプリケーションの特徴を示します。

高リスク | 中リスク
アプリケーション・テンプレートの構成がほとんどの場合で失敗してしまうアプリケーションの特徴 | SSOの機能が不完全になってしまうことがあるか、サインオンまたはパスワードを変更するためにエンドユーザー側でアクションが必要な場合があるアプリケーションの特徴
  • XWindows
  • Flashアプリケーション
  • 以前のJava（1.3.1より前）
  • HLLAPI以外のエミュレータ
  • HLLAPIをすでに使用しているエミュレータ・アプリケーション（HLLAPIに接続できるアプリケーションが1つのみのエミュレータとともに使用されている場合）
  • DOS GUIアプリケーションおよびCMDで動作しないDOSアプリケーション
  • 次のようなWebアプリケーション
  • SendKeysを必要とする
  • 遅延を必要とする
  • ESSO-LMは、ページが完全にロードしたと認識するまで、資格証明を取り込みません。一部のWebサイトでは、ブラウザからするとページは完全にロードされたように見えますが、フィールドでは資格証明の取り込み準備がまだ整っていません。
  • （ログオンのループ、無視、パスワード変更などの）問題を修正するためにマッチングを必要とするが、マッチングに一意の基準を使用できないアプリケーション。
  • ターミナル・サーバーまたはCitrixでホストされるアプリケーション（ESSO-LMをターミナル・サーバーまたはCitrixボックスにインストールできない場合）。
  • 「OK」ボタンがなくなり、[Enter]が受け入れられないアプリケーション。ESSO-LMでは送信を処理できません。ユーザーは資格証明を手動で送信するか、SendKeysを使用する必要があります。
  • ログオンまたはパスワード変更フィールドがダイアログ・ボックス・タブに存在するアプリケーション。Windowsアプリケーションの場合は、SendKeysを使用できます。
  • ログオンまたはパスワード変更にアクション（チェック・ボックスなど）を必要とするアプリケーション。Windowsアプリケーションの場合は、SendKeysを使用できます。
  • パスワード変更: 他のユーザー・プロファイル情報フィールドがパスワード変更フィールドとともに存在するアプリケーション。ESSO-LMは、パスワード変更を処理し、他のフィールドをバイパスします。
  • ターゲット・アプリケーションのウィンドウ・タイトルが作成後に変更されるが、その変更がログオン画面がアクティブになる前に行われるアプリケーション。
  • ログオン・フィールドが他のログオンまたは資格証明入力フィールドとともに同じページ上にあるアプリケーション。ESSO-LMは、複数のログオンが同じ画面上にある場合、それらを区別できません。
  • 「Submit」ボタンが完全修飾されたパスを持つイメージ・タグ内にあり、[Enter]が受け入れられないアプリケーション。イメージ・パスが変更されると、ESSO-LMは資格証明を適切に挿入および送信しなくなります。
  • パスワード変更:
  • ESSO-LMがユーザー・ログオンをログに記録し、ログオン画面でのパスワード変更をバイパスするアプリケーション（サービスとしての実行や、タイトル・バーの変更など）。
  • アプリケーションのパスワード・ポリシーがSSOの機能と一致しておらず、ユーザーがパスワードを選択する必要があるアプリケーション（アプリケーションにパスワードの履歴またはディクショナリ要件がある場合など）
  • Windowsアプリケーションの場合のSendKeys（Webアプリケーションのリスクは高く、メインフレーム・アプリケーションはパスワード変更を消失します）。
  • ログオン・ループ: アプリケーションはログオフ後に、まったく同じログオン画面を表示します。これは、回避する必要があります。
  • Firefoxポップアップ・ウィンドウ。ESSO-LMがこれらのウィンドウを検出できるのは、「Limit users to predefined applications」が「Do not limit」に設定されている場合のみです。
  • ESSO-LM 10.1.4.0.4より前のバージョン:
  • サービス・ログオン機能をも必要とする動的なウィンドウ・クラスを持つアプリケーション（サービスとしての実行や、タイトル・バーの変更など）
  • 動的なコントロールID
  • ターゲット資格証明で重複するコントロールID


事前構成されたアプリケーションおよびテンプレート

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

WindowsおよびWebアプリケーション用に事前構成されたログオンは、コンソール・テンプレートで提供されます。共通ネットワーク/Webポップアップ・ログオンの構成およびオンライン・サービス・ログオンの構成は、インストール・ディレクトリにある構成ファイルapplist.iniに保存されます。

以前のESSO-LMバージョンで、クライアントのapplist.iniに保存されていた事前定義のアプリケーション・ログオンは、現在はテンプレートとしてESSO-LM Administrative Consoleに保存されています。詳細は、以前の製品バージョンとの互換性に関する説明を参照してください。

次のアプリケーションは、ESSO-LM Administrative Consoleのテンプレートとして、またはapplist.iniの一部としてESSO-LMに含まれています。

コンソール・テンプレートがあるアプリケーション

次のアプリケーションは、動作するように構成されていますが、ユーザー構成に追加する必要があります。これらのいくつかは、ご使用の環境に対応するように、カスタマイズする必要があります（たとえば、内部のURLまたはアプリケーション・ウィンドウ・タイトルを指定します）。

アプリケーション ログオン・フォーム
Microsoft Word
  • Microsoft Word Logon
MSダイヤルアップ・ネットワーキング
  • MS Dial-Up Networking Logon（管理者がWindowTitleを指定）
Netscape Mail
  • Netscape Mail Logon
PKZIP
  • PKZIP Logon
Siebel Sales
  • Siebel Sales Logon
  • Siebel Sales Change Password
Adobe Acrobat Reader
  • Adobe Acrobat Unlock
ICQ
  • ICQ Logon - Registration
  • ICQ Logon
Meeting Maker
  • MM Logon
WinZip
  • WinZip Set Password Confirm
  • WinZip Set/Use Password
  • WinZip Decrypt File(s) Password
Yahoo! Messenger
  • Yahoo! Messenger Logon
Oracle
  • Oracle Logon
  • Oracle 10g SQL*Plus Logon
MS SQL
  • MS SQL Logon
Novell GroupWise
  • Novell GroupWise Logon
Microsoft FrontPage
  • Microsoft FrontPage Logon
Visual SourceSafe
  • VSS Logon
  • VSS Change Password
OpenNetwork Directory Smart
  • OpenNetwork Directory Smart Logon（管理者がURLを指定）
Oblix NetPoint
  • Oblix NetPoint Logon（管理者がURLを指定）
Citrix ICA Client/Program Neighborhood（2-field）
  • CICA2 Logon（管理者がWindowTitleを指定）
Citrix NFuse Classic（2-field）
  • CNFC2 Logon（管理者がURLを指定）
Act
  • Act Logon（管理者がWindowTitleを指定）
  • Act Set Password
QuickBooks Pro
  • QBP Change Password
  • QBP Logon
QuickBooks Pro（Password-Only）
  • QBPPO Change Password
  • QBPPO Logon
Lotus Organizer
  • Lotus Organizer Logon（管理者がWindowTitleを指定）
Citrix Program Neighborhood Agent（3-field）
  • CPN3 Logon
GoldMine
  • GoldMine Logon
  • GoldMine Clhange Password
Citrix NFuse Classic（3-field）
  • CNFC3 Logon（管理者がURLを指定）
Citrix Program Neighborhood Agent（2-field）
  • CPN2 Logon
Citrix ICA Client/Program Neighborhood（3-field）
  • CICA3 Logon（管理者がWindowTitleを指定）
AIM
  • AIM Logon
Eudora
  • Eudora Logon
  • Eudora Change
  • Eudora Confirm
Lotus Notes
  • Lotus Notes
Microsoft Outlook
  • Logon
  • Change Password
Microsoft Outlook
  • Logon
  • Change Password
MSN Messenger
  • MSN Messenger Logon
Windows Logon
  • WL MPR Logon
  • WL MPR Change Password
  • WL WinLogon Logon
  • WL WinLogon Change Password
ICQ
  • ICQ Logon（パスワードのみ）

applist.ini内の事前構成されたログオン

オンライン・サービス

  • AOL
  • Compuserve
  • Earthlink
  • MSN
  • Prodigy
  • ATT WorldNet
  • Internet Explorerログオン


バックアップおよびリストア

情報は、コマンドラインまたはファイルのいずれからもバックアップおよびリストアできます。これらの手順の詳細は、「コマンドライン・オプション」または「ファイルベースのバックアップ/リストア」を参照してください。


文字キー・コード

文字コード

VTabKeyNのコード（Windows）

コード | 意味
`DELAY=N` | Nは、遅延時間（ミリ秒）です
`VKEY=N` | Nは、送信する仮想キー・コードです

次の例で送信されるのは、[Tab]、[End]、空白、1.5秒の遅延、ログオン・ユーザー名、空白、ユーザー名/ID、[Home]、0.35秒の遅延、[Tab]およびパスワードです。

VTabKey1=`VKEY=9``VKEY=35` `DELAY=1500`Logon username`VKEY=32`

VTabKey2=`VKEY=36``DELAY=350``VKEY=9`

VirtualKeyCodeおよびVKEYのコード（Windows）

これらのコードは、特定のキーストロークをWindowsログオンまたはパスワード変更フォーム・フィールドに送信するために、アプリケーション構成ファイル（entlist.ini）で使用されます。ここに示されているコードは参考用です。「SendKeys (Windows)」ダイアログ・ボックスを使用して、Windowsアプリケーションのキーストロークを指定します。詳細は、「Windowsアプリケーションの追加」を参照してください。

キー | コード | キー | コード | キー | コード | キー | コード
Break | 3 | 5 | 53 | V | 86 | F5 | 116
Backspace | 8 | 6 | 54 | W | 87 | F6 | 117
Tab | 9 | 7 | 55 | X | 88 | F7 | 118
Clear | 12 | 8 | 56 | Y | 89 | F8 | 119
Enter | 13 | 9 | 57 | Z | 90 | F9 | 120
Shift | 16 | A | 65 | 左側のウィンドウ | 91 | F10 | 121
Ctrl | 17 | B | 66 | 右側のウィンドウ | 92 | F11 | 122
Alt | 18 | C | 67 | 数字キーパッド0 | 96 | F12 | 123
Caps Lock | 20 | D | 68 | 数字キーパッド1 | 97 | F13 | 124
Esc | 27 | E | 69 | 数字キーパッド2 | 98 | F14 | 125
Spacebar | 32 | F | 70 | 数字キーパッド3 | 99 | F15 | 126
Page Up | 33 | G | 71 | 数字キーパッド4 | 100 | F16 | 127
Page Down | 34 | H | 72 | 数字キーパッド5 | 101 | F17 | 128
End | 35 | I | 73 | 数字キーパッド6 | 102 | F18 | 129
Home | 36 | J | 74 | 数字キーパッド7 | 103 | F19 | 130
← | 37 | K | 75 | 数字キーパッド8 | 104 | F20 | 131
↑ | 38 | L | 76 | 数字キーパッド9 | 105 | F21 | 132
→ | 39 | M | 77 | アスタリスク（*） | 106 | F22 | 133
↓ | 40 | N | 78 | プラス(+) | 107 | F23 | 134
Print Scrn | 44 | O | 79 | マイナス(-) | 109 | F24 | 135
ヘルプ | 47 | P | 80 | ピリオド(.) | 110 | Num Lock | 144
0 | 48 | Q | 81 | スラッシュ（/） | 111 | Scroll Lock | 145
1 | 49 | R | 82 | F1 | 112 | 左側の[Shift] | 160
2 | 50 | S | 83 | F2 | 113 | 右側の[Shift] | 161
3 | 51 | T | 84 | F3 | 114 | 左側の[Ctrl] | 162
4 | 52 | U | 85 | F4 | 115 | 右側の[Ctrl] | 163

PreKeyおよびTabKeyのコード（ホスト/HLLAPI）

これらのコードは、特定のキーストロークをHLLAPI対応メインフレーム/ホスト・ログオンまたはパスワード変更フォーム・フィールドに送信するために、アプリケーション構成ファイル（entlist.ini）で使用されます。ここに示されているコードは参考用です。「SendKeys (Host/Mainframe)」ダイアログ・ボックスを使用して、ホスト・アプリケーションのキーストロークを指定します。詳細は、「ホスト/メインフレーム・アプリケーションの追加」を参照してください。

文字/コマンド | コード | 文字/コマンド | コード | 文字/コマンド | コード
Alt Cursor | @$ | Local Print | @P | PF12/F12 | @c
Backspace | @< | Reset | @R | PF13/F13 | @d
@ | @@ | Shift | @S | PF14/F14 | @e
Alt | @A | Dup | @S@x | PF15/F15 | @f
Field - | @A@- | Field Mark | @S@y | PF16/F16 | @g
Field + | @A@+ | Tab（右方向のTab） | @T | PF17/F17 | @h
Field Exit | @A@E | Cursor Up | @U | PF18/F18 | @i
Alt Cursor | @$ | Cursor Down | @V | PF19/F19 | @j
Erase Input | @A@F | Cursor Left | @L | PF20/F20 | @k
Sys Request | @A@H | Cursor Right | @Z | PF21/F21 | @l
Insert Toggle | @A@I | Page Up | @u | PF22/F22 | @m
Cursor Select | @A@J | Page Down | @v | PF23/F23 | @n
Attention | @A@Q | End | @q | PF24/F24 | @o
Print Screen | @A@T | Home | @0 | PA1 | @x
Hexadecimal | @A@X | PF1/F1 | @1 | PA2 | @y
[Cmd]/[Func]キー | @A@Y | PF2/F2 | @2 | PA3 | @z
Print（PC） | @A@t | PF3/F3 | @3 | PA4 | @+
Back/左方向のTab | @B | PF4/F4 | @4 | PA5 | @%
Clear | @C | PF5/F5 | @5 | PA6 | @&
Delete | @D | PF6/F6 | @6 | PA7 | @'
Enter | @E | PF7/F7 | @7 | PA8 | @(
Erase EOF | @F | PF8/F8 | @8 | PA9 | @)
Help | @H | PF9/F9 | @9 | PA10 | @*
Insert | @I | PF10/F10 | @a |  |
New Line | @N | PF11/F11 | @b |  |


ディレクトリ・サーバー・スキーマ定義

ディレクトリ・サーバー・コンテナ、クラス・オブジェクト、これらの権限および属性は、次のとおりです。

vGOSecret

すべてのユーザーの機密情報を保存します。これには、ログオン資格証明に加え、削除されたすべてのオブジェクトを保存するオブジェクトが含まれています。このオブジェクトは、補助クラスとしてSSOUserDataオブジェクトに追加されます。すべてのユーザーがこのオブジェクトを読み取ることができますが、所有者のみがこのオブジェクトに書き込むことができ、所有者または管理者のみがこのオブジェクトを削除できます。

権限: 権限はvGOUserDataオブジェクトから継承されます。

属性名 | 構文 | フラグ
vGOSecretData | 大/小文字を区別しない文字列 | 単一値設定、同期
vGOSharedSecretDN | 未使用
他のオプションの属性 | ou、dn、cn、o

vGOUserDataオブジェクト

保護された個別/個人の資格証明をユーザーが保存できるコンテナです。

権限: ユーザーには、自分のユーザー・オブジェクトのこれらの属性に対する書込みアクセス権があります。管理者には完全な権限がありますが、機密情報は暗号化されているため、読み取ることはできません。

属性名 | 構文 | フラグ
vGOSecretData | 大/小文字を区別しない文字列 | 単一値設定、同期
vGORoleDN | 未使用
他のオプションの属性 | ou、dn、cn、o

vGOConfigオブジェクト

エージェントが必要とするすべての構成情報を保持するために使用します。この構成情報には、アプリケーション・サポート・リスト、メインフレーム/ホスト・アプリケーション・サポート・リスト、はじめて使用する場合の設定のインストラクション、パスワード・ポリシーおよび管理優先設定が含まれています。これらのすべての設定によって、エージェントの動作が制御されます。

権限: すべてのユーザーには、このオブジェクト内の属性に対する読取り専用アクセス権があります。管理者には完全な権限があります。

属性名 | 構文 | フラグ
vGOConfigType | 大/小文字を区別しない文字列 | 単一値設定、同期
vGOConfigData | 大/小文字を区別しない文字列 | 単一値設定、同期
vGORoleDN | 未使用
他のオプションの属性 | ou、dn、cn、o

vGOLocatorClass

ユーザー資格証明を保存する場所を指定するために使用します。

権限: すべてのユーザーには、このクラスのオブジェクトに関して、これらの属性に対する読取り/比較/検索アクセス権があります。管理者には完全な権限があります。

属性名 | 構文 | フラグ
vGOLocatorAttribute | 大/小文字を区別しない文字列 | 単一設定値
他のオプションの属性 | dn、cn、o


ホスト・エミュレータの構成

ホスト・エミュレータの構成によるHLLAPIセッション短縮名の有効化

ESSO-LMには、組込みHLLAPIサポート（高水準言語アプリケーション・プログラミング・インタフェース）を使用する、次のホスト/端末エミュレータのシングル・サインオン機能があります。次の項では、各エミュレータでHLLAPIサポートを有効にする方法について説明します。

  • Telnet Support
  • Attachmate Extra!/ myExtra!/Xtra!X-Treme
  • BlueZone Web-to-Host
  • BOSaNOVA
  • Ericom PowerTerm
  • G&R Glink
  • Hummingbird HostExplorer
  • IBM Client Access
  • IBM Client Access Express
  • IBM Host on-Demand
  • IBM Personal Communications
  • Jolly Giant QWS3270 PLUS
  • NetManage Rumba
  • Net SoftのNS/Elite
  • Newhart Systems BLUES 2000
  • Novell LAN Workplace
  • PuTTY
  • Scanpak Aviva for Desktops
  • Seagull Bluezone
  • WRQ Reflection
  • Zephyr PC to Host
  • Zephyr Web to Host
HLLAPIサポートを実装していないエミュレータの場合は、（ウィンドウ・タイトルでフォームが検出されるように、）ユーザー資格証明を指定するSendKeysを使用して、Windowsアプリケーションとしてホスト/メインフレーム・アプリケーションを構成できる場合もあります。 詳細は、「Windowsアプリケーションの追加: 特殊な問題」を参照してください。


Attachmate EXTRA!

Attachmate Extra!/myExtra!

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

Attachmate EXTRA!の各セッションをESSO-LMで動作するように設定するには、次の手順を実行します。

エミュレータの場合:
  1. セッションを開きます。
  2. 「Options」メニューから「Global Preferences」を選択します。
  3. 「Advanced」、「Short name」（Aなど）、「Browse」、セッション・ドキュメントの順に選択し、「OK」をクリックします。

この設定は、各セッションの構成ファイルとともに保存する必要があります。

メインフレームまたはホスト・セッションの終了後も、バックグラウンド・プロセスが実行されたままになる場合があります。これにより、自動ログオン・プロセスが中断され、セッションが再開できない場合があります。


BlueZone Web-to-Hostエミュレータ

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

BlueZone Web-to-Hostエミュレータをインストールして構成するには、次の手順を実行します。

  1. BlueZone Web-to-Host設定を起動します。
  2. セットアップ・タイプ・セクションで、「Install BlueZone Web-to-Host」を選択し、「Next」をクリックします。
  3. エンド・ユーザー・ライセンス契約をよく読みます。条件に同意する場合は、「Yes, I agree with the terms of this software license」の横にあるボタンを選択し、「Next」をクリックします。
  4. ソフトウェアをインストールする場所を選択します。インストーラのデフォルトは、C:ドライブのProgram Filesディレクトリです。
  5. Seagull Activation File（SAF）の場所をインストーラに指示するか、SAFがインストールされていない場合は、空白のままにします。
  6. 使用するプログラム・グループをインストーラで作成するかどうか、およびBlueZone Web-to-Hostウィザードのデスクトップ・ショートカットを作成するかどうかを選択して、「Next」をクリックします。
  7. 「Sites」ダイアログ・ボックスで、ドロップダウン・メニューからサイトの言語を選択します。
  8. 次のいずれかを実行します。
    • 「Create」をクリックし、パスとフォルダ名を入力します。
    • 「Import」をクリックして、インポートするサイトに移動します。
    • 「Copy」をクリックして、コピーするサイトに移動します。
    • 「Upgrade」をクリックして、アップグレードするサイトに移動します。
    • 既存のサイトを削除する場合は、サイトを選択して「Delete」をクリックします。
  9. 「Launch Folders」ダイアログ・ボックスで既存の起動フォルダを選択するか、「Create」をクリックして新しいフォルダを作成します。「Next」をクリックします。
  10. 「New BlueZone Launch Folder」ダイアログ・ボックスで、フォルダ名前を入力し、標準のWeb-to-Hostとして配布するか提供されているデスクトップとして配布するかを、フォルダ・オプションから選択します。「OK」をクリックします。
  11. 「Launch Folders」ダイアログ・ボックスに戻ると、新しい起動フォルダが表示されているので、「Next」をクリックします。
  12. 「Sessions」ダイアログ・ボックスで、「Create」をクリックします。
  13. 「New BlueZone Session」ダイアログ・ボックスで、ドロップダウン・メニューから「Mainframe Display」を選択し、「OK」をクリックします。
  14. セッションの名前を入力し、既存のプロファイルを使用するかどうかを指定します。既存のプロファイルを選択します（該当する場合）。ローカルへの保存を許可するかどうかを選択します。「OK」をクリックします。
  15. 「Define New Connection」ダイアログ・ボックスで、接続情報を入力し、「OK」をクリックします。
  16. 「Session Properties」ウィンドウで情報を確認します。変更する情報を編集します。終了したら「OK」をクリックします。
  17. 「BlueZone Mainframe Display」で「Session」を選択し、「Connect」をクリックします。

このエミュレータは、バージョン11.1.1.1.0で新しくサポートされました。


BOSaNOVA

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

ESSO-LMでは、BOSaNOVAエミュレータがサポートされています。BOSaNOVAがESSO-LMで動作するための設定手順は必要ありません。

ESSO-LMでのBOSaNOVAエミュレータの使用には既知の問題があります。エミュレーションを閉じるとき、次の警告メッセージが表示されます。「There are active applications connected to the emulation via the HLLAPI/DDE interface.Closing the emulation now may cause unpredictable results.Are you sure?」

「Yes」をクリックすると、ESSO-LMはBOSaNOVAエミュレータへの応答を停止するため、エミュレータを再起動する必要があります。再起動には、さらに数秒かかる場合があることに注意してください。この問題は、エミュレーションを閉じる前にESSO-LMを停止し、エミュレータを閉じた後、ESSO-LMを再起動することによって解決することもできます。


Reference\Ericom_PowerTerm

Ericom PowerTerm

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

Ericom PowerTermをESSO-LMで動作するように設定するには、次の手順を実行します。

エミュレータの場合:

  1. 「Setup」メニューから「Terminal」を選択します。
  2. 「General」タブを選択します。
  3. 「HLLAPI Names」で、「Short」を一意の値に設定します。
  4. 「OK」をクリックします。
PowerTerm InterConnect、PlusおよびLite版でESSO-LMサポートを有効にするには、エージェントのホスト/メインフレーム構成ファイルMfrmList.iniにエミュレータへの完全で正確なパスを指定する必要があります。メインフレーム構成のデフォルト・パスは、 C:\Program Files\Ericom Software\PowerTermです。

これらのいずれかのバージョンのPowerTermエミュレータが他のディレクトリやドライブにインストールされている場合は、MfrmList.iniでこのデフォルト・パスを変更する必要があります。このファイルは、コンソールでのみ編集できます。

  1. 「Tools」メニューで「Modify Configuration」を指し、「MfrmList」をクリックします。
  2. INIエディタで、「Section」ドロップダウン・リストからEricom PowerTerm Lite/Plus/InterConnect選択します。
  3. ValueName=では、必要に応じてエミュレータへのパスを編集します。
  4. 「Save」をクリックし（再起動するように求められた場合は「OK」をクリックします）、「Close」をクリックします。


G&R Glink

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

G&R GlinkをESSO-LMで動作するように設定するには、次の手順を実行します。

  1. G&R Glinkインストール・パス内のGLWin\WHLLAPIディレクトリにあるglHLLAPI.iniファイルで短縮名を構成します。このファイルを有効にするには、ユーザーの%WinDir%ディレクトリにコピーする必要があります。短縮名を参照する値（次の形式を参照）を除き、デフォルト値は変更しないことをお薦めします。

A]
Name=HLLAPI詳細名
Config=構成ファイル名

「A」は短縮名を表します。


Hummingbird Host Explorer

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

Hummingbird HostExplorerをESSO-LMで動作するように設定するには、次の手順を実行します。

エミュレータの場合:
  1. 「Options」メニューから「API Settings」を選択します。
  2. 「HLLAPI Options」で、「Update screen after PS update」を選択します。
  3. 「EHLLAPI Compatibility」で、「Attachmate」を選択します。
  4. 「OK」をクリックします。


IBM Client Access

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

ESSO-LMでは、IBM Client Accessがサポートされています。 IBM Client AccessがESSO-LMで動作するための設定手順は必要ありません。


IBM Client Access Express

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

ESSO-LMでは、IBM Client Access Expressがサポートされています。 IBM Client Access ExpressがESSO-LMで動作するための設定手順は必要ありません。


IBM Host On-Demand

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

IBM Host On-DemandのESSO-LMサポートは、Microsoft Windows、Microsoft Internet ExplorerまたはMozilla Firefox、および更新されたJVM（Java仮想マシン）を使用してテスト済です。Microsoft Internet Explorerがインストールされている場合は、JVMを更新しないでください。

これらの方法に関して、構成されたセッションをクライアントが保存できない場合があるという問題があります。セッションを使用するたびに自動起動名を入力するのは非常に面倒です。かわりに、次に説明するように、管理者はクライアントが使用できる既存のセッションを複製し、複製したセッションをHLLAPI対応にできます。これにより、クライアントは標準とHLLAPI対応の両方のセッションを使用できるようになります。

IBM Host On-DemandをESSO-LM動作するように設定するには、次の手順を実行します。

Microsoft Internet ExplorerまたはMozilla Firefoxの場合

  1. ブラウザを起動します。
  2. IBM FixCentralにアクセスし、IBM Host On-Demandの特定のバージョンのHost On-Demand EHLLAPI Bridge Downloadをダウンロードします。
  3. ダウンロードしたファイルをESSO-LMインストール・ディレクトリに解凍します。
  4. Ehllapibridge.exeをインストールします。
  5. 「ツール」メニューから「インターネット オプション」を選択します。
  6. 「詳細設定」タブを選択します。
  7. 「Microsoft VM」で、「Java console enabled (requires restart)」を選択します。
  8. 「適用」をクリックし、次に「OK」をクリックします。必要に応じて、ブラウザを終了します。
  9. コンピュータを再起動します。

Host On-Demandの場合

  1. 個々のセッションをHost On-DemandアプレットによってHLLAPIイネーブラを実行するように構成します。
  2. メニューから「Properties」を選択します。
  3. 「Advanced」タブを選択します。
  4. 「Auto-Start」ドロップダウン・リスト・ボックスから「Applet」を選択します。
  5. 「Name」テキスト・ボックスにcom.ibm.eNetwork.hllbridge.HLLAPIEnablerと入力します。
  6. 「Parameter (Optional)」テキスト・ボックスにENABLE_PCSAPI=YESと入力します。
  7. 「Auto-start HLLAPI Enabler」チェック・ボックスで「Yes」を選択します。
  8. または、「Assist」、「Run applet」の順に選択してセッションを開始した後、このアプレットを実行します。


IBM Personal Communications

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

IBM Personal CommunicationsをESSO-LMで動作するように設定するには、次の手順を実行します。

  1. エミュレータの「Edit」 メニューから、「Preferences」を指定し、「API Settings」を選択します。
  2. 「DDE/EHLLAPI」チェック・ボックスを選択します。
  3. 「OK」をクリックします。


Jolly Giant QWS3270 PLUS

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

ESSO-LMでは、Jolly Giant QWS3270 PLUSエミュレータがサポートされています。 Jolly Giant QWS3270 PLUSがESSO-LMで動作するための設定手順は必要ありません。


NetManage Rumba

NetManager Rumba

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。
エミュレータでのNetManageの設定手順
  1. 「Options」メニューから「API」を選択します。
  2. 「Identification」タブを選択します。
  3. 「Session Short Name」を設定します。
  4. 「OK」をクリックします。

NetManage Rumbaには、HLLAPIが不完全に実装されている可能性があります。NetManage Rumbaでは、Presentation Space（エミュレータ画面）に接続して表示させることはできますが、2つ以上のセッションの接続はサポートされていません。ESSO-LMでは、最後に起動されたセッションへのシングル・サインオン・サポートのみが提供されています。


Net SoftのNS/Elite

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

ESSO-LMでは、Net SoftのNS/Eliteがサポートされています。NS/EliteがESSO-LMで動作するための設定手順は必要ありません。


Newhart Systems BLUES 2000

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

ESSO-LMでは、Newhart Systems BLUES 2000Sエミュレータがサポートされています。Newhart Systems BLUES 2000SがESSO-LMで動作するための設定手順は必要ありません。


Novell LAN Workplace

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

Novell LAN Workplace Proに対するESSO-LMサポートを有効にするには、エージェントのホスト/メインフレーム構成ファイルMfrmList.iniにエミュレータへの完全で正確なパスを指定する必要があります。メインフレーム構成のデフォルト・パスは、c:\Program Files\Novell\LAN Workplace\Terminals\Binです。

Novell LAN Workplaceエミュレータが他のディレクトリやドライブにインストールされている場合は、MfrmList.iniでこのデフォルト・パスを変更する必要があります。このファイルは、ESSO-LM Administrative Consoleでのみ編集できます。

  1. 「Tools」メニューで「Modify Configuration」を指し、「MfrmList」をクリックします。
  2. INIエディタで、「Section」ドロップダウン・リストからNovell LAN Workplace Pro 5.2を選択します。
  3. ValueName=では、必要に応じてエミュレータへのパスを編集します。
  4. 「Save」をクリックし（再起動するように求められた場合は「OK」をクリックします）、「Close」をクリックします。


PuTTY

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

PuTTYターミナル・エミュレータ用アプリケーション・テンプレートの作成

PuTTYおよびESSO-LMでのPuTTYのサポートが設計された方法により、PuTTYを介してアクセスするアプリケーションのテンプレートを作成する場合は、次の情報を考慮する必要があります。

PuTTYベースのテンプレートを作成する場合は、PuTTYのCopy All to Clipboard機能を使用します。

PuTTYは、固定画面アプリケーションをスクロール画面として扱います

PuTTYはすべてのアプリケーションをスクロール画面として扱うため、対象のアプリケーションが固定画面であっても、スクロール画面テンプレートを作成する必要があります。

PuTTYはカーソル位置の検出または設定をサポートしない

PuTTYはカーソル位置の検出も設定もできないため、テンプレートを作成する際は、次の手順を実行する必要があります。

  • 固定画面アプリケーション。タブや空白などの適切なキーボード文字を送信することによって、目的の行と列に手動でカーソルを配置するようにテンプレートを構成します。
  • スクロール画面アプリケーション。カーソルが常に画面の最終行の最後の文字の後の空白を1つ追加した場所にあると仮定してテンプレートを構成します。

PuTTYの画面はすぐに更新されない

ホストエコー（入力した文字は最初にサーバーに送信され、その後、ターミナルに戻されて表示されます）によって、PuTTYはすぐに画面を更新しないため、フィールドの変更時または資格証明の送信時（あるいはその両方）に、エコーの待機時間に応じて遅延を追加することが必要です。送信アクションで遅延が必要な場合は、自動送信機能を無効にする必要があります。


Scanpak Aviva for Desktops

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

ESSO-LMでは、Scanpak Aviva for Desktops（以前のEicon Aviva）がサポートされています。 Scanpak Aviva for DesktopsをESSO-LMで動作するように設定するには、次の手順を実行します。

エミュレータの場合:

  1. 「Settings」を選択し、メニューから「Properties」を選択します。
  2. 「Automation」を選択します。
  3. 「Choose first available short name」チェック・ボックスが選択されていることを確認します。

セッション・パラメータおよび宛先パラメータのみを構成する必要があります。


WRQ Reflection

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

WRQ ReflectionをESSO-LMで動作するように設定するには、次の手順を実行します。

エミュレータの場合:

  1. 「Setup」を選択し、メニューから「Terminal」を選択します。
  2. 「Short」および「Long」の「HLLAPI names」を設定します （「Short」は一意である必要があります。「Long」はプログラムで使用できる任意の名前を設定できます）。
  3. 「OK」をクリックします。


Zephyr PC to Host

Zephyr PC to HostZephyr to PC Host

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

PassportをESSO-LMで動作するように設定するには、次の手順を実行します。

エミュレータの場合:

  1. 「Communication」を選択し、メニューから「Setup」を選択します。
  2. 「HLLAPI」を選択します（「Automatically Select」が選択されている場合、追加の手順は必要ありません）。「Manually Specify」が選択されている場合は、「Short Name」または「Long Name」を選択する必要があります。


Zephyr Web to Host

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

ESSO-LMでは、Passport Web to Hostがサポートされています。Web to HostがESSO-LMで動作するための設定手順は必要ありません。


SAPの構成

ESSO-LMでは、SAPアプリケーションがサポートされています。ESSO-LMがSAPアプリケーションと連携するには、スクリプトを有効にする必要があります。（ご使用の環境では、スクリプトがデフォルトで無効になっている場合があることに注意してください。）次の構成変更は、ESSO-LMを実行するすべてのSAPデスクトップに対して行う必要があります。これらの構成変更を行わなかった場合、エンド・ユーザーは、ESSO-LMを停止しないかぎりSAPエラーを受信します。SAPをESSO-LMで動作するように設定するには、次の手順を実行します。

SAPをESSO-LMで動作するように設定する手順

クライアントの構成

  • SAP Client（SAPGUI Front End）をオープンしてログオンします。
  • 「SAP Easy Access」画面で、「Options」ダイアログ・ボックスを開きます。（[Alt]を押しながら[F12]を押すか、または任意のSAP画面の標準ツールバーから「Customizing of local layout」を選択します）。
  • 「Scripting」タブを選択します。
  • 「User Settings」で、「Enable Scripting」が選択されていること、および「Notify when a script attaches to a running GUI」が選択されていないことを確認します。
  • 「Apply」をクリックします。

サーバーの構成

  • SAPアプリケーション・サーバーをオープンします。
  • トランザクションRZ11を開始します。
  • 「Maintain Profile Parameters」画面で、「Param. Name」にsapgui/user_scriptingと入力し、「Display」をクリックします。
  • 「Display Profile Parameter Attributes」画面で、「Application」ツールバーから「Change Value」を選択します。
  • 「Change Parameter Value」画面で、「New Value」フィールドにTRUEと入力します。
  • 「Save」（左下隅）をクリックします。

レジストリの編集

  • レジストリを開きます。
  • HKCU\software\SAP\SAPGUI Front\SAP Frontend Server\Security:WarnOnAttachにドリルダウンします。
  • WarnOnAttachの値を0（ゼロ）に設定します。
  • ESSO-LMでSAPアプリケーションを使用するすべてのデスクトップにこの変更を適用します。

このプロセスにはSAP Helperが必要です。ESSO-LM Agent Installerを実行し、「Custom Setup」を選択して「Extensions」ツリーを展開し、「Logon Manager」にドリルダウンします。「SAP Helper」を選択し、「This Feature will be installed on the local hard drive」を選択します。「Next」を選択し、画面の指示に従ってインストールを完了します。


コマンドライン・オプション

コマンドラインからESSO-LMを起動して、特定のタスクを実行できます。

大カッコ内の項目は、このセクションでのみ使用するオプションです。

タスク | 用途/説明
バックアップ | ssoshell.exe /mobility /backup [path] /silent [confirm]
 | 例: [path] | バックアップ・ファイルが保存されているディレクトリへの実際のパスです。（デフォルトは、最後にコマンドライン・バックアップ・ファイルが保存されたディレクトリ、またはShell:AutoBackupPathが指す場所です。）
 | 例: silent | バックアップの実行時にバックアップ/リストア・ウィザードを表示しません。
 | 例: [confirm] | すべてのダイアログ・ボックスを表示します。サイレント・バックアップの実行時、confirmスイッチがない場合、「Yes/No」ダイアログ・ボックスは表示されず、エージェントのデフォルトは「Yes」となります（確認ダイアログの例: "Overwrite backup file?"）。
ログオン・マネージャ | ssoshell.exe
 | 例 | ログオン・マネージャを表示します
FTUなし | ssoshell.exe /background /noftu
 | 説明 | コンピュータへのログオン時にエージェントが2回起動されるのを回避します。HKLM\Software\Microsoft\Windows NT\Current Version\WinlogonにあるUserinitレジストリ・キーで有効にします。
 | 説明 | コンピュータへのログオン時にエージェントが2回起動されるのを回避します。HKLM\Software\Microsoft\Windows NT\Current Version\WinlogonにあるUserinitレジストリ・キーで有効にします。
 | 説明 | /noftuを使用すると、Windows Startupフォルダにエージェントを格納していないユーザーに対してエージェントは実行されません。これにより、管理者は、特定のコンピュータのすべてのユーザーではなく特定のユーザーに対してのみESSO-LMをロール・アウトできます。
 | 説明 | このコマンドは、Microsoft Windows 2000/XPにのみ適用されます。
オプション | ssoshell.exe /options
 | 例 | 「Settings」プロパティ・ページを表示します。
リストア | ssoshell.exe /mobility /restore [path] /silent [confirm]
 | 例: [path] | バックアップ・ファイルが保存されているディレクトリへの実際のパスです。（デフォルトは、最後にコマンドライン・バックアップ・ファイルが保存されたディレクトリ、またはShell:AutoBackupPathが指す場所です。）
 | 例: silent | バックアップの実行時にバックアップ/リストア・ウィザードを表示しません。
 | 例: [confirm] | すべてのダイアログ・ボックスを表示します。サイレント・バックアップの実行時、confirmスイッチがない場合、「Yes/No」ダイアログ・ボックスは表示されず、エージェントのデフォルトは「Yes」となります。（確認ダイアログの例: "Backup file has been restored"）
 | 例: 注意 | デフォルトで送信されるリストア・パスワードはWindowsパスワードです。リストア・コマンドは起動タスクで実行されます（Shell\Tasks:StartupTaskNを参照）。
設定 | ssoshell.exe /setupmgr
 | 例 | 設定ウィザードを表示します。
停止 | ssoshell.exe /shutdown
起動 | ssoshell.exe /background
同期化 | ssoshell.exe /syncmgr /sync | Sync Orderリストの最初のシンクロナイザとの同期を実行します（グローバル・エージェント設定の同期を参照）。ログオンを表示して、リストの最初に記載されているシンクロナイザに接続します。


ssoSCDetect（スマート・カード監視ユーティリティ）

スマート・カード監視ユーティリティ（ssoSCDetect.exe ）

ユーティリティ・プログラムssoSCDetectでは、ワークステーションのスマート・カード・リーダーを監視します。これにより、ワークステーションを複数ユーザーKioskとして使用し、スマート・カードによって認証されたすべてのユーザーのリモートSSO資格証明ストアにアクセスして同期化できるようになります。

ユーザーがカードをリーダーに挿入すると、ssoSCDetectユーティリティによってエージェントが起動され、ユーザーのプライマリ・ログオン資格証明が求められます。次に、ユーティリティによってユーザーの資格証明がリモート・リポジトリと同期化されます。ユーザーが（たとえば、リーダーからカードを取り出して）ワークステーションからログアウトすると、ssoSCDetectによってエージェントが停止されます。

ユーティリティを実行するには、ESSO-LM CDのUtilitiesディレクトリからESSO-LMインストール・ディレクトリ（%ProgramFiles%/Passlogix/v-GO SSO）に実行可能ファイルssoSCDetect.exeをコピーし、プログラムを起動します。

SSO Kiosk操作に推奨されるグローバル・エージェント設定

最高のパフォーマンスとセキュリティを得るには、Kioskとして設定されたワークステーションで実行されているESSO-LM Agentに、次のグローバル・エージェント設定を適用する必要があります。

User Paths （Active Directoryのみ）最高のパフォーマンスを得るには、1つ以上の完全修飾パスを指定して、ユーザー・アカウントの検索を開始します。Synchronization\Active Directoryの「Advanced」オプションを参照してください。


Windowsイベント・ロギング・サーバーの構成

Windowsイベント・ロギング拡張

Microsoft Windows 2000またはXPサーバーでイベント・ログ・メッセージを受信するように構成するには、次の手順を実行します。

  • そのサーバーにエージェントをインストールします。

    または

  1. SSOeventmessage.dllをエージェント・インストールからサーバー（System32ディレクトリを推奨）にコピーします。
  2. HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Eventlog\Application\v-GO SSOに、次のレジストリ・キーを作成します。
名前 | EventMessageFile
型 | STRING
値 | ファイル名を含めたSSOeventmessage.dllファイルへのフルパス（%WinDir%\System32\SSOeventmessage.dllを推奨)
名前 | TypesSupported
型 | DWORD
値 | 7
名前 | CategoryMessageFile
型 | STRING
値 | ファイル名を含めたSSOeventmessage.dllファイルへのフルパス（%WinDir%\System32\SSOeventmessage.dllを推奨)
名前 | CategoryCount
型 | DWORD
値 | 4


DB2のセットアップ

IBM DB2のセットアップ

ESSO-LMの中央リポジトリ・スキーマを拡張し、中央リポジトリとしてIBM DB2を準備するには、この項の手順に従います。

IBM DB2のセットアップ要件:

  • ローカル・マシンでIBM DB2クライアントをインストールする必要があります。
  • DB2クライアントには、OLE DB（Object Linking and Embedding Database）サポートがインストールされ、構成されている必要があります。このサポートは、様々なデータソースに格納されているデータにアプリケーションが一様にアクセスできるようにする一連のインタフェースを提供します。OLE DBサポートをインストールするには、DB2セットアップ・ウィザードを実行して、「Client support」>「Interfaces」>「OLE DB Support」にナビゲートします。詳細は、DB2のドキュメントを参照してください。
  • スキーマを拡張するユーザーとして現在（Windowsに）ログイン中のユーザーには、リポジトリに接続し、スキーマを拡張するために、データベースに対する適切な権限が必要です。DB2ユーザー・アカウントには、データベース管理者権限が必要です。
  • DB2管理者は、vGOSSOというデータベースを作成する必要があります。
  • これらの手順の詳細は、IBM DB2のドキュメントを参照してください。

データベース・スキーマの拡張

  1. Administrative Consoleを開きます。
  2. 「Repository」メニューから、「Extend Schema」を選択します。
  3. 「Connect to Repository」メニューから、必要なIBM DB2接続情報を入力または選択します。
  4. Server name: サーバー名を入力します。
  5. Repository Type: DB2データベースを選択します。
  6. Port:: デフォルトのポート（通常、50000）でない場合は、ポート番号のみを入力する必要があります。ポートがデフォルトである場合、このフィールドは空白のままでかまいません。

  7. 「OK」をクリックします。
コンソールをデータベース・サーバーに接続するには、管理者レベルの認証が必要です。コンソールはデータベースに接続され、必要なオブジェクトを作成して、構成が成功したことを確認します。

スキーマの拡張機能は、次のSQLコマンドを使用して、スキーマを拡張します。

CREATE SCHEMA vGOSSO;

CREATE TABLE vGOSSO.SSO_ADMIN (ConfigType VARCHAR(128) NOT NULL, Data CLOB, PRIMARY KEY(ConfigType));

CREATE TABLE vGOSSO.SSO_USERS (UserID VARCHAR(128) NOT NULL, ObjectID VARCHAR(255) NOT NULL, Data CLOB, PRIMARY KEY (UserID, ObjectID));
  8. スキーマを拡張したら、DB2データベース内のSSO_USERS表とその索引に対する完全な権限と、SSO_ADMIN表とその索引に対する読取り専用の権限を付与する必要があります。

SSOサポートの構成

  1. コンソールの左側のペインで、「Repository」を右クリックし、ショートカット・メニューから「Connect to」を選択します。
  2. 必要な接続情報を入力または選択して、「OK」をクリックします。
  3. 右側のペインで、ルート（サーバー名）にナビゲートします。
  4. ルートを右クリックして、ショートカット・メニューから「Configure SSO Support」を選択します。ルートの下には「People」コンテナ・オブジェクトがすでに存在します。
  5. 管理優先設定のデータソースを選択し、要求された情報を指定します。
  6. 「Administrative Console」。このウィザード・ページは、現在のコンソール設定をソースとして使用して、選択したシンクロナイザ・コンテナにエージェント構成をエクスポートする場合に使用します。
  7. 「Data File」。このウィザード・ページは、1つ以上のデータファイルをソースとして使用して、選択したシンクロナイザ・コンテナにエージェント構成をエクスポートする場合に使用します。
  8. 構成手順を実行すると、優先設定のエントリが「Repository」ペインに表示されます。必要に応じて、任意のオブジェクトを右クリックし、「Refresh」を選択します。

IBM DB2データベースに接続するために必要な設定

「Required Database Synchronization」設定は、すべてのデータベース・シンクロナイザ拡張に対して設定する必要があります。

シンクロナイザを追加して、IBM DB2用に構成するには、次の手順を実行します。

  1. コンソールを開いて、グローバル・エージェント設定のセットを選択します。
  2. 「Synchronization」>「DBExt」>「Required」を展開します。
  3. 次の情報を入力します。
    • Extension location: これが選択されていることを確認します。これは、IBM DB2データベース・シンクロナイザ拡張のパス\ファイル名です。
      （デフォルトは、C:\Program Files\LocalDirectory\v-GO SSO\Plugin\SyncMgr\ DBEXT\DBExt.dllです）
    • Servers:: 接続して同期させるために、データベース・サーバーの接続文字列を指定します。チェック・ボックスを選択し、「...」をクリックして「Edit List」ダイアログ・ボックスを開きます。各行に1台のデータベース・サーバーの完全接続文字列を入力します。[Enter]を押して各行を終了します。他のデリミタ文字を使用しないでください。

この拡張が機能するには、少なくとも1つの接続文字列を指定する必要があります。

IBM DB2データベースに接続するには、次の接続文字列を使用します。
Provider=IBMDADB2;Data Source=vGOSSO;CurrentSchema=vGOSSO;Location=<DB2ServerName>[:port];Extended Properties="trusted_connection=yes"。<DB2ServerName>はサーバーの名前、[:port]はオプションのポートです。
  4. 「Synchronization」>「DBExt」>「Advanced」を展開します。「Advanced Database Synchronization」設定では、すべてのデータベース・シンクロナイザ拡張を対象とした拡張オプションを制御します。この設定は必須ではありません。

Append Domain when naming objects: ユーザーのコンテナに名前を付ける際にユーザー名にユーザーのドメインを追加することを有効にします。たとえば、ドメインcompanyおよびユーザーuser1の場合、コンテナは、このフラグを無効にするとuser1と名付けられ、このフラグを有効にするとuser1.companyと名付けられます。デフォルトでは、「Disable」に設定されています。この機能を有効にするには、「Enable」を選択します。


エラー・ループのクイック・リファレンス

この項は、基本的なエラー・ループ設定のクイック・リファレンスとして使用してください。

これらの設定をAdministrative Consoleで構成してください。表は参考用です。

設定は、グローバルからアプリケーション・タイプ、アプリケーションへと下方に継承されます。詳細な設定は、一般的な設定より優先されます（アプリケーションはアプリケーション・タイプより優先され、アプリケーション・タイプはグローバルより優先されます）。

セキュリティ設定（MaskPWなど）では、グローバル、アプリケーション・タイプ、アプリケーションのいずれに設定されているかにかかわらず、最も安全な設定が使用されます。

アプリケーション・タイプ設定は、entlist.ini [*Root]セクションに配置します。

例

[*Root]

AppsTimeout=8

WebMaxRetry=3

アプリケーション設定は、特定のアプリケーションのentlist.iniセクションに配置します。

例

[Payroll]

WindowTitle1=Payroll

MaxRetry=3

Timeout=30

IDCtrl=203

...

グローバル（レジストリ） | アプリケーション・タイプ（[*Root]）
パラメータの意味 | Extensions\ AccessManager\ Dlg | Windows | Web | ホスト/メインフレーム | アプリケーション | デフォルト
「Error Loop」ダイアログ・ボックスが表示されるまでの最大再試行回数（最初の試行後） | MaxRetry | AppsMaxRetry | WebMaxRetry | MainframeMaxRetry | MaxRetry | 1
「Error Loop」ダイアログ・ボックスが表示されるまでの連続したログオン試行の最長時間 | Timeout | AppsTimeout | WebTimeout | MainframeTimeout | Timeout | 30
「Error Loop」ダイアログ・ボックスでパスワード確認フィールドを非表示にするかどうかを示す設定 | HideConfirmPW | AppsHideConfirmPW | WebHideConfirmPW | MainframeHideConfirmPW | HideConfirmPW | 0 （非表示にしません）


MSIパッケージの内容

この項では、各パッケージ機能の基本内容について説明します。表示名および説明は、インストーラのカスタム表示のとおりです。機能の詳細は、パッケージを確認してください。

子パッケージにはすべての親パッケージが必要です。たとえば、LDAP_SyncにはSyncMgrが必要です。

必須機能は太字で表示されています。また、出荷時の認証方式である必要はありませんが、1つ以上の認証方式をインストールする必要があります。その他の機能はすべてオプションです。ただし、Internet Explorerコンポーネントをインストールすることをお薦めします。

表示名 | 説明 | 機能名
Application | 必要なファイルおよび設定 | Core
Logon Methods | SSO認証サポート | Authenticators
Windows Logon | Microsoft Windows Authenticator | SLA
Windows Logon v2 | Microsoft Windows Authenticatorバージョン2 | MSauth
GINA | Oracle GINA（Windows Authenticator v2とともに必要） | SSOGina
LDAP | LDAP Authenticator | LDAP
LDAP v2 | LDAP Authenticatorバージョン2 | LDAPauth
Authentication Manager | 複数認証サポート | MultiAuth
Extensions | ESSO-LMプラグイン | Extensions
Backup/Restore Manager | ESSO-LM資格証明と設定のバックアップおよびリストア用プラグイン | BackupMgr
Logon Manager | ログオン/資格証明リクエスト・イベント用プラグイン | LogonMgr
Internet Explorer Helper | Internet Explorer資格証明リクエスト統合 | InternetExplorer
Mozilla Browser Helper | Mozilla Firefox資格証明リクエスト統合 | MozillaHelper
Mainframe Emulator Helper | メインフレーム・セッション資格証明リクエスト・エミュレータ統合 | MainframeEmulators
Console Window Support | ESSO-LMのメインフレーム・プラグインのコンソール・ウィンドウ（コマンド・プロンプト）のサポート。 |
Legacy Emulator Support | HLLAPIベースの16ビットのレガシー・エミュレータのサポート。 |
Java Helper | Java仮想マシン・セッション資格証明リクエスト統合 | JavaHelper
SAP Helper | SAPアプリケーション資格証明リクエスト統合 | SAPHelper
Setup Manager | 初期ESSO-LM体験設定用プラグイン | SetupMgr
Synchronization Manager | 追加データソースとの資格証明/設定の同期用プラグイン | SyncMgr
Active Directory Synchronizer | Active Directory同期サポート | AD_Sync
LDAP Synchronizer | LDAPディレクトリ同期サポート | LDAP_Sync
ADAM Synchronizer | Active Directory/アプリケーション・モード同期サポート | ADAM_sync
File System Synchronizer | ファイル・システム同期サポート | File_Sync
Database Synchronizer | SQLリレーショナル・データベース同期サポート | DB_Sync
Roaming Profile Sync | ローミング・プロファイル同期サポート |
Event Manager | イベント・マネージャ用プラグイン | EventMgr
XML | ローカル・ファイル拡張用プラグイン | LocalFileExt
Windows Event Extension | Windowsイベント拡張用プラグイン | WindowsEventExt


ftulist.iniキー

ftulist.iniでは、ユーザーが初めてエージェントを起動したときにエージェントによって実行される特殊なアクションを決定します。ファイルはローカル・ファイル、ディレクトリ・サーバーまたはデータベース・オブジェクトとして存在できます。同期によって配置された場合、ftulist.iniは%AppData/Passlogix%ディレクトリに格納されます。

すべてのESSO-LM構成ファイル（entlist.iniおよびftulist.iniを含む）は、Administrative Consoleでのみ作成および編集できます。次の項の情報は参考用です。

次の項の表は、ftulist.iniの各セクションのキーおよび許容値を示します。

  • ftulist.iniのルート・キー
  • Password Windowsセクションのキー
  • My Logonsセクションのキー
  • Bulk Add Logonセクションのキー


ftulist.iniのルート・キー

ルート・キー

次の値は、必ず[FTU]セクション内で使用される必須の設定です。

例

[FTU]

Ver=20020523

Step1=Password Windows

Step2=My Logons

はじめて使用する場合のキー | 説明 | 許容値
Ver = %s | 必須。最後のftulist.iniファイルの日付の文字列。このキーの値がユーザーのレジストリ（HKCU\&\Extensions\SetupManager:Completed内）の10進値よりも大きい（新しい）場合、ユーザーが次回エージェントを起動したときにバルク追加リストが表示されます。 例: 20020523 | %s =yyyymmdd（年-月-日）形式の日付を10進数で表現した文字列。例: 2002年5月23日の場合は20020523
Step1 = %s | 必須。変更不可。Primary Logon Methodを起動するセクションをコールします。このモジュールは、ユーザーに認証方式の選択を強制します。 | %s = "Password Windows"
Step2 = %s | 必須。変更不可。 アクセス・マネージャを起動するセクションをコールします。このモジュールは、資格証明のバルク追加を有効にします。 | %s = "My Logons"


Password Windowsセクションのキー

次の値は、必ず[Password Windows]セクション内で使用します。

例

[Password Windows]

ExtensionName=<core>

Action1=Password Window

はじめて使用する場合のキー | 説明 | 許容値
ExtensionName = %s | 必須。変更不可。拡張モジュールの内部名。 | %s = "<core>"
Action1 = %s | 必須。変更不可。 プライマリ・ログオン方法を起動します。 このモジュールは、ユーザーに認証方式を選択することを強制します。 | %s = "Password Window"


My Logonsセクションのキー

次の値は、必ず[My Logons]セクション内で使用される必須の設定です。

例

[My Logons]

ExtensionName=AccessManager

Section1=Corporate Win App

Section2=Intranet

&

はじめて使用する場合のキー | 説明 | 許容値
ExtensionName = %s | 必須。変更不可。拡張モジュールの内部名。 | %s = "AccessManager"
Section%d = %s | 必須。変更不可。バルク追加ウィザードに含めるログオンを指定します。 | %d = 連続した整数 %s = アプリケーション・ログオン・セクション名; 関連するログオン・クラス・セクションへのリンク


Bulk Add Logonセクションのキー

次の値は必須で、各バルク追加ログオン・セクション内で使用します。

例

[My Logons]

ExtensionName=AccessManager

Section1=Corporate Win App

Section2=Intranet

[Intranet]

ConfigKey=*Other Webs

ConfigName=Corporate Intranet

FTU_NeedID=0

FTU_NeedOther=0

FTU_NeedPwd=1

FTU_CONFIRMID=0

FTU_CONFIRMOTHER=0

FTU_CONFIRMPASSWORD=1

URL=Corp Intranet

はじめて使用する場合のキー | 説明 | 許容値
ConfigKey = %s | entlist.iniのログオン構成へのリンク。 | %s = entlist.iniまたはapplist.iniのアプリケーション・ログオン・セクション名。ホスト/メインフレーム・ログオンには[*Mainframe]を、Webログオンには[*Other Webs]を、オンライン・サービス・ログオンには[*Online Services]を、その他のWindowsアプリケーション・ログオンには[*Other Apps]を使用します。
ConfigName = %s | ログオンを説明するためにはじめて使用する場合のウィザードで使用する名前。 | %s = アプリケーション・ログオン名
Description = %s | ログオンを説明するためにログオン・マネージャで使用する名前。 | %s = アプリケーション・ログオン名
FTU_CONFIRMID = %b | はじめて使用する場合のウィザードでユーザーがユーザー名/IDを確認する必要があるかどうかを示すフラグ（オプション）。 | %b = 0; ユーザーはユーザー名/IDを確認する必要はありません（デフォルト）。 %b = 1; ユーザーはユーザー名/IDを確認する必要があります。
FTU_CONFIRMOTHER = %b | 3番目のフィールドがある場合、はじめて使用する場合のウィザードでユーザーが3番目のフィールドを確認する必要があるかどうかを示すフラグ（オプション）。 | %b = 0; ユーザーは3番目のフィールドを確認する必要はありません（デフォルト）。 %b = 1; ユーザーは3番目のフィールドを確認する必要があります。
FTU_CONFIRMPASSWORD = %b | はじめて使用する場合のウィザードでユーザーがパスワードを確認する必要があるかどうかを示すフラグ（オプション）。 | %b = 0; ユーザーはパスワードを確認する必要はありません（デフォルト）。 %b = 1; ユーザーはパスワードを確認する必要があります。
FTU_NeedID = %b | アプリケーションにユーザー名/IDが必要かどうかを示すフラグ。 | %b = 0; アプリケーションにはユーザー名/IDは必要ありません。 %b = 1; ログオンにはユーザー名/IDが必要です（デフォルト）。
FTU_NeedOther = %b | アプリケーションに3番目のフィールドが必要かどうかを示すフラグ（オプション）。 | %b = 0; アプリケーションには3番目のフィールドは必要ありません。 %b = 1; アプリケーションには3番目のフィールドが必要です（デフォルト）。
FTU_NeedPwd = %b | アプリケーションにパスワードが必要かどうかを示すフラグ。 | %b = 0; アプリケーションにはパスワードは必要ありません。 %b = 1; ログオンにはパスワードが必要です（デフォルト）。
URL = %s | Webまたはホスト・アプリケーションのentlist.ini内のセクション名、またはentlist.iniで事前定義されていないWebサイトのURL。 | %s = Web/ホスト・セクション名、またはWeb URL。


entlist.iniキー

entlist.iniのキー

管理者は、entlist.iniファイルを格納するディレクトリを指定します。ほとんどの場合、このディレクトリは、ESSO-LMプログラム・ディレクトリ下のサブディレクトリである必要があります。

すべてのESSO-LM構成ファイル（entlist.iniおよびftulist.iniを含む）は、Administrative Consoleでのみ作成および編集できます。次の項の情報は参考用です。

これは、ローカルentlist.iniファイルより優先されるシンクロナイザ・オブジェクトに対して使用される形式でもあります。

ディレクトリベースのオブジェクトによって、エージェントはすべてのローカルentlist.iniファイルを無視するようになります。ダウンロード時に、リモート・オブジェクト（ある場合）はローカルentlist.iniファイルを上書きします。

次に、entlist.iniとapplist.iniがマージされて、%AppData%\Passlogixディレクトリに新しいファイル（aelist.ini）が作成されます。aelist.iniファイルは、ESSO-LMの起動時や、applist.iniとentlist.iniを再度マージするときなど、定期的に上書きされます。その後、エージェントはaelist.iniを使用して既知のアプリケーションを検出します。

次の項の表は、entlist.iniの各セクションのキーおよび許容値を示します。

  • entlist.iniのルート・キー
  • Windowsアプリケーション・キー
  • Webアプリケーション・キー
  • ホスト/メインフレーム・アプリケーション・キー
  • パスワード・ポリシー・キー


entlist.iniのルート・キー

ルート・キー

次の値は、必ず[*Root]セクション内で使用します。

例

[*Root]

Section1=*Other Apps

Section2=*Other Webs

Section3=*Mainframe

AppsMaxRetry=1

WebMaxRetry=3

HostMaxRetry=2

WebTimeout=90

&

グローバル・アプリケーション・キー 説明 許容値

[*Root]

アプリケーション・タイプ（ログオン・クラス）が導出されるルート・セクション。

該当なし

AppsHideConfirmPW = %b

すべてのWindowsアプリケーションの「Logon Error」ダイアログのパスワード確認フィールドを非表示にするかどうかを示します。

%b = 0; 確認フィールドを非表示にしません（デフォルト）。

%b = 1; 確認フィールドを非表示にします。

AppsMaxRetry = %d

「Logon Error」ダイアログ・ボックスを表示する前に、エージェントが行うすべてのWindowsアプリケーションのログオンの再試行回数を示します。

%d = 再試行の数（デフォルトは1）

AppsTimeout = %d

ログオンが連続して試行されている場合の、すべてのWindowsアプリケーションのエラー・ループ検出がトリガーされるまでの最大時間を示します。

%d = 秒単位の時間（デフォルトは30）

MainframeHideConfirmPW = %b

すべてのホスト・アプリケーションの「Logon Error」ダイアログ・ボックスのパスワード確認フィールドを非表示にするかどうかを示します。

%b = 0; 確認フィールドを非表示にしません（デフォルト）。

%b = 1; 確認フィールドを非表示にします。

MainframeMaxRetry = %d

「Logon Error」ダイアログ・ボックスを表示する前に、エージェントが行うすべてのホスト・アプリケーションのログオンの再試行回数を示します。

%d = 再試行の数（デフォルトは1）

MainframeTimeout = %d

ログオンが連続して試行されている場合の、すべてのホスト・アプリケーションのエラー・ループ検出がトリガーされるまでの最大時間を示します。

%d = 秒単位の時間（デフォルトは30）

Section%d = %s

サポートされているサブセクションの宣言。

*Other Webs、*Online Servicesおよび*Other Appsはapplist.iniで定義するため、entlist.iniの[*Root]で定義する必要はありません。

%d = 連続した整数
%s = *Other Apps | （Windowsアプリケーション）
%s = *Mainframe | （ホスト/メインフレーム・アプリケーション）
%s = *Other Webs | （事前定義のWebアプリケーション）
%s = *Online Services

WebHideConfirmPW = %b

すべてのWebアプリケーションの「Logon Error」ダイアログのパスワード確認フィールドを非表示にするかどうかを示します。

%b = 0; 確認フィールドを非表示にしません（デフォルト）。

%b = 1; 確認フィールドを非表示にします。

WebMaxRetry = %d

「Logon Error」ダイアログ・ボックスを表示する前に、エージェントが行うすべてのWebアプリケーションのログオンの再試行回数を示します。

%d = 再試行の数（デフォルトは1）

WebTimeout = %d

ログオンが連続して試行されている場合の、すべてのWebアプリケーションのエラー・ループ検出がトリガーされるまでの最長時間を決定します。

%d = 秒単位の時間（デフォルトは30）

Application Typeセクションのキー

これらの設定は、事前定義されたアプリケーションのリストの区切りとなるWindows、Webおよびホスト・アプリケーション・セクションに使用します。

例

[*Other Apps]

Section1=Corporate WinApp

&

[*Other Webs]

Section1=Corporate Intranet

&

[*Mainframe]

Section1=Corporate Mainframe

グローバル・アプリケーション・キー 説明 許容値

[%s]

アプリケーション・カテゴリ・セクションを識別するセクション・ヘッダー。

%s = [*Other Apps] | （Windowsアプリケーション）
%s = [*Mainframe] | （ホスト/メインフレーム・アプリケーション）
%s = [*Other Webs] | （事前定義のWebアプリケーション）

Section%d = %s

アプリケーション・セクションの宣言。

%d = 連続した整数

%s = セクション名


Windowsアプリケーション・キー

次の値は、[*Other Apps]セクション内に記述されているアプリケーション内で使用します。

例

[*Other Apps]

Section1=Corporate WinApp

&

[Corporate WinApp]

（次のキー）

Windowsアプリケーション・キー 説明 許容値

AllowReveal = %b

ウィザードおよびプロパティ・ページのパスワード用の「Reveal」ボタンを有効または無効にするフラグ。

%b = 0; 無効

%b = 1; 有効（デフォルト）

AppPathKey%d = %s

実行中のプロセスと照合するために、ログオンに関連付けられているアプリケーションを識別するWindowsレジストリ・キー。ログオン・リクエストの正確な一致のためにWindowTitleと組み合せて使用します。複数のレジストリ・キーを単一のログオンに関連付けられるように、%dを1で始まる数字に置き換えます。

%d = 連続した整数

%s = Windowsレジストリで使用されるアプリケーション名文字列
（通常は、実行可能ファイルの名と一致）

AutoOK = %b

ログオン・データの挿入後にこのアプリケーション・ログオンに対する「OK」を自動的に選択するようエージェントに指示するフラグ。

%b = 0; 無効

%b = 1; 有効（デフォルト）

ChangeTitle%d = %s

パスワード変更リクエストを指定するためにパスワード変更ウィンドウ・タイトルと照合されるテキスト。単一のパスワード変更リクエストについて複数のウィンドウを指定できるように、%dを1で始まる数字に置き換えます。

各ChangeTitleエントリに対して、重複したWindowTitleエントリが必要です。

%d = 連続した整数

%s = ウィンドウ・タイトル文字列

ChgCtrl0 = %d

パスワード変更リクエスト・ウィンドウで、ユーザー名/IDフィールドを識別するために使用するコントロールID。

%d = -1; 変更リクエストにユーザー名/IDは必要ありません。

%d = 1; 変更リクエストにはユーザー名/IDが必要ですが、このリクエストはSendKeysを使用してアプリケーションに送信されます。この値を1にした場合は、それ以外のすべてのコントロールID（IDCtrl、PassKeyCtrl、OtherCtrl1、OtherCtrl2、OKCtrl、ChgCtrl1、ChgCtrl2およびChgCtrl3）も1または-1にする必要があります。

%d = 2 - 99,999; コントロールID値

ChgCtrl1 = %d

パスワード変更リクエスト・ウィンドウで、旧パスワード・フィールドを識別するために使用するコントロールID。

%d = -1; 変更リクエストに旧パスワードは必要ありません。

%d = 1; 変更リクエストにはパスワードが必要ですが、このリクエストはSendKeysを使用してアプリケーションに送信されます。この値を1にした場合は、それ以外のすべてのコントロールIDも1または-1にする必要があります。

%d = 2 - 99,999; コントロールID値

ChgCtrl2 = %d

パスワード変更リクエスト・ウィンドウで、新しいパスワード・フィールドを識別するために使用するコントロールID。

%d = -1; 変更リクエストに新しいパスワードは必要ありません。

%d = 1; 変更リクエストにはパスワードが必要ですが、このリクエストはSendKeysを使用してアプリケーションに送信されます。この値を1にした場合は、それ以外のすべてのコントロールIDも1または-1にする必要があります。

%d = 2 - 99,999; コントロールID値

ChgCtrl3 = %d

パスワード変更リクエスト・ウィンドウで、パスワード確認フィールドを識別するために使用するコントロールID。

%d = -1; 変更リクエストに新規パスワードの確認エントリは必要ありません。

%d = 1; 変更リクエストには新規パスワードの確認エントリが必要ですが、このリクエストはSendKeysを使用してアプリケーションに送信されます。この値を1にした場合は、それ以外のすべてのコントロールIDも1または-1にする必要があります。

%d = 2 - 99,999; コントロールID値

ConfigName = %d

ユーザーがこのログオンを追加するときに、初期構成名の作成に使用するテキストを含むコントロールを識別するコントロールID。

%d = 1 - 99,999; コントロールID値

CPWFlag = %d

特定のアプリケーションでユーザーがパスワード変更を要求された場合のパスワード変更ウィザードの動作を設定します。このキーは、パスワード変更サブセクションではなく、アプリケーションのルート・セクションに指定します。

この設定は、レジストリを使用して、すべてのアプリケーションを対象にグローバルに設定することもできます。該当する説明を参照してください。

%d = 1; ユーザーにパスワード変更ウィザードに従うように求めます（デフォルト）。

%d = 2; ユーザーに手動で新しいパスワードを入力するように求めるだけでなく、エージェントに自動的にパスワードを生成させるオプションも提供します。

%d = 4; 自動的に新しいパスワードを生成するだけでなく、手動で新しいパスワードを作成するオプションも提供します。

%d = 10; ユーザーに手動で新しいパスワードを入力するように求めます。エージェントに自動的にパスワードを生成させるオプションは提供しません。

%d = 12; 自動的に新しいパスワードを生成します。手動で新しいパスワードを作成するオプションは提供しません。

CtrlOrder = %s1, %s2, %s3&

UseSendKeysを有効にしたときにフィールドが送信される順序を指定します。 たとえば、CtrlOrder = OtherCtrl1, IDCtrl, PassKeyCtrlを指定すると、ダイアログ・ボックスのタブの順序がOtherCtrl1、IDCtrl、PassKeyCtrlとなるようにエージェントに指示されます。

ログオンでは、デフォルトの順序はIDCtrl、PassKeyCtrl、OtherCtrl1、OtherCtrl2です。

Tony/Drew: What is CtrlOrder default for password change scenario?

パスワード変更では、デフォルトの順序はChgCtrl0、ChgCtrl1、ChgCtrl2、ChgCtrl3です。

この設定は、UseSendKeysが有効で、Windowsアプリケーションのみを使用する場合にかぎり適用されます。

%s1 = 最初のフィールドが送信されます。

%s2 = 2番目のフィールドが送信されます。

%s3 = 3番目のフィールドが送信されます。

など

Description = %s

このアプリケーションについて説明するテキストで、ログオン・マネージャの「Description」フィールドにも保存されます。

%s = 任意の文字列

ExtMap = %s

ログオンに関連付けられているWindowsファイル拡張子。エージェントが構成にアイコンをマップできるようにします。

%s = ファイル拡張子を表す3文字の文字列

ForceReauth = %b

このアプリケーションに資格証明を提供する前に、再認証を受けることをユーザーに強制します。

すべてのサブセクションに適用されます。複数セクションのパスワード変更シナリオでは、ユーザーは複数回再認証を受ける必要があります。

%b = 0; 再認証は必要ありません（デフォルト）。

%b = 1; 再認証が必要です。

Group = %s

このアプリケーションが属するグループ・セクション名。 資格証明共有グループ用に構成する場合に使用します。 特殊な値には、次のものがあります。

LDAP: アプリケーションでは、LDAPディレクトリ・サーバー認証方式パスワードが使用されます。

ドメイン: アプリケーションでは、Windows認証方式パスワードが使用されます。

グループを使用可能にするには、Windowsレジストリ・エントリPWSEnable=1を設定する必要があります。

%s = アプリケーションが所属するアプリケーション・グループのセクション名。

HideConfirmPW = %b

「Logon Error」ダイアログ・ボックスのパスワード確認フィールドを非表示にするかどうかを決定します。

%b = 0; 確認フィールドを非表示にしません（デフォルト）。

%b = 1; 確認フィールドを非表示にします。

IDCtrl = %d

ユーザー名/IDコントロール・フィールド、またはユーザー名/IDデータを適切なユーザー名/IDコントロールに提供するメカニズム、あるいはその両方を識別します。

%d = 0; ユーザーは、アプリケーションの設定中にエージェントの指示ツール・メカニズムを使用する必要があります（デフォルト）。

%d = -1; アプリケーションにはユーザー名/IDは必要ありません。

%d = 1; アプリケーションにはユーザー名/IDが必要ですが、このリクエストはSendKeysを使用してアプリケーションに送信されます。 この値を1にした場合は、それ以外のすべてのコントロールID（PassKeyCtrl、OtherCtrl1、OtherCtrl2、OKCtrl、ChgCtrl0、ChgCtrl1、ChgCtrl2およびChgCtrl3）も1または-1にする必要があります。

%d = 2 - 99,999; ユーザー名/IDコントロールID値

IDCtrlType = %d

ユーザー名/IDコントロール・フィールドのコントロール・タイプを識別します。

%d = 0; 編集コントロール（デフォルト）

%d = 1; コンボボックス・コントロール

%d = 2; リストボックス・コントロール

IgnoreClassName = %s

資格証明の送信時に無視する必要があるログオンまたはパスワード変更ウィンドウのクラス名を識別します。アプリケーションに2番目の非表示のログオンまたはパスワード変更ウィンドウが含まれている場合に使用します。

%s = クラス名文字列

InteractionMode = %b

エージェントがアプリケーションのウィンドウのメッセージ・キューにアタッチするのを回避します。

%b = 0; 無効（デフォルト）

%b = 1; 有効

Match%d = %s

アプリケーションへの一致セクションにマップします。同じアプリケーションに、複数のログオンおよびパスワード変更画面がある場合に使用します。この方法は、アプリケーション内の複数の画面に対して1セットのユーザー資格証明がある場合に最も役立ちます。この方法を使用することにより、一致セクションをログオンやパスワード変更（選択と手動）用に設定したり、無視するように設定できます。

%d = 連続した整数

%s = アプリケーション・ログオン名（ログオン定義セクション）

MaxRetry = %d

「Logon Error」ダイアログ・ボックスを表示する前に、エージェントが行うログオンの再試行回数を決定します。

%d = 再試行の数（デフォルトは1）

ModuleName%d = %s

実行中のプロセスと照合するために、ログオンに関連付けられているアプリケーション・モジュール名。 特定のアプリケーション・ログオン、またはパスワード変更リクエストを識別するために、WindowTitleキーと組み合せて使用します。 複数のアプリケーション・モジュールを単一のログオンに関連付けられるように、%dを1で始まる数字に置き換えます。

%d = 連続した整数

%s = アプリケーション名文字列
（通常は、実行可能ファイル名と一致）

OKCtrl = %d

このアプリケーションの「OK」ボタンのコントロールIDを識別します。

%d = 1; エージェントの内部ロジックを使用します（デフォルト）

%d = 2 - 99,999; 「OK」ボタンのコントロールID

%d = -1; ユーザーは手動で「OK」を選択する必要があります。

OtherCtrl1 = %d

3番目のログオン・フィールドのコントロールID、または追加のフィールド・データを適切なコントロールに提供するメカニズム、あるいはその両方を識別します。

%d = -1; アプリケーションには3番目のフィールドは必要ありません。

%d = 1; アプリケーションには3番目のフィールドが必要ですが、このリクエストはSendKeysを使用してアプリケーションに送信されます。 この値を1にした場合は、それ以外のすべてのコントロールIDも1または-1にする必要があります。

%d = 2 - 99,999; 3番目のフィールドのコントロールID値; SendKeysを使用する場合は、任意の値にできます。

OtherCtrl1Type = %d

3番目のログオン・フィールドのコントロール・タイプを識別します。

%d = 0; 編集コントロール（デフォルト）

%d = 1; コンボボックス・コントロール

%d = 2; リストボックス・コントロール

OtherCtrl2 = %d

4番目のログオン・フィールドのコントロールID、または追加のフィールド・データを適切なコントロールに提供するメカニズム、あるいはその両方を識別します。

%d = -1; アプリケーションには4番目のフィールドは必要ありません。

%d = 1; アプリケーションには4番目のフィールドが必要ですが、このリクエストはSendKeysを使用してアプリケーションに送信されます。 この値を1にした場合は、それ以外のすべてのコントロールIDも1または-1にする必要があります。

%d = 2 - 99,999; 4番目のフィールド・コントロールID値; SendKeysを使用する場合は、任意の値にできます。

OtherCtrl2Type = %d

4番目のログオン・フィールドのコントロール・タイプを識別します。

%d = 0; 編集コントロール（デフォルト）

%d = 1; コンボボックス・コントロール

%d = 2; リストボックス・コントロール

OtherLabel1 = %s

3番目のログオン・フィールドを表示するときにエージェントによって使用されるテキスト・ラベル。

%s = エージェントが表示するテキスト

OtherLabel2 = %s

4番目のログオン・フィールドを表示するときにエージェントによって使用されるテキスト・ラベル。

%s = エージェントが表示するテキスト

ParentKey1 = %s

サブセクションをその親セクションにマップします。

%s = 親アプリケーション/セクション名

PassKeyCtrl = %d

パスワード・コントロール・フィールド、またはパスワード・データを適切なパスワード・コントロールに提供するメカニズム、あるいはその両方を識別します。

%d = 0; ユーザーは、アプリケーションの設定中にエージェントの指示ツール・メカニズムを使用する必要があります。

%d = -1; アプリケーションにはパスワードは必要ありません。

%d = 1; アプリケーションにはパスワードが必要ですが、このリクエストはSendKeysを使用してアプリケーションに送信されます。 この値を1にした場合は、それ以外のすべてのコントロールIDも1または-1にする必要があります。

%d = 2 - 99,999; パスワード・コントロールID値; SendKeysを使用する場合は、任意の値にできます。

PassKeyCtrlType = %d

パスワード・コントロール・フィールドのコントロール・タイプを識別します。

%d = 0; 編集コントロール（デフォルト）

%d = 1; コンボボックス・コントロール

%d = 2; リストボックス・コントロール

PassPolicy = %s

このアプリケーション・ログオン構成に関連付けるパスワード・ポリシーのセクションを識別します。

%s = ポリシー・セクション名

PresetFocusAll = %b

エージェントがログオン・フィールドに実際にデータを配置する前に、そのフィールドにフォーカスを設定するかどうかを指定します。

%b = 0; 無効（デフォルト）

%b = 1; 有効

QuietGenerator = %b

このフラグを設定すると、エージェントによって自動的にパスワード変更リクエストが処理されますが、ユーザーにはパスワード変更リクエストが処理されたことは通知されません。

%b = 0; ユーザーの操作が不要なジェネレータは使用しません。ユーザーの操作を必要とする標準のパスワード変更プロセスを使用します（デフォルト）。

%b = 1; ユーザーの操作が不要なジェネレータを使用します。

Section%d = %s

アプリケーション・サブセクションの宣言。

%d = 連続した整数

%s = サブセクション名

SystemLogon = %b

予約語。 ログオン・セクションがシステム・ログオン・セクションであるかどうかを識別するフラグ。

%b = 0; システム・ログオン・セクションではありません（デフォルト）。

%b = 1; システム・ログオン・セクションです。

Timeout = %d

ログオンが連続して試行されている場合の、エラー・ループ検出がトリガーされるまでの最長期間を決定します。

%d = 秒単位の時間（デフォルトは30）

UseSendKeys = %b

キーストロークによってアプリケーションにフィールドを送信します。

UseSendKeysを選択した場合、必要に応じて、IDCtrl、PassKeyCtrl、OtherCtrl1、OtherCtrl2、および（存在する場合）ChgCtrl0、ChgCtrl1、ChgCtrl2、ChgCtrl3変数をすべて1に設定する必要があります。

%b = 0; SendKeysを使用しません; コントロールIDを使用します（デフォルト）。

%b = 1; SendKeysを使用します。

VTabKey%d0 = %d1

各資格証明フィールドの前後に送信する文字/遅延シーケンスを指定します。

フィールドは、CtrlOrderに指定した順序で送信されます。

UseSendKeysも有効にする必要があります。

指定した値として何も送信しない場合は、``（1行に2つのバッククオート）という値を指定します。

%d0 = 1; 最初の資格証明フィールドの前に送信するシーケンス

%d0 = 2; 最初のフィールドの後かつ2番目のフィールドの前に送信するシーケンス

- その他; %dは無関係

%d1 = 送信（表示）するコード・シーケンス（デフォルトは標準のタブ・キー）

VTabKeyPWC%d0 = %d1

各資格証明フィールドの前後に送信する文字/遅延シーケンスを指定します。

フィールドは、CtrlOrderに指定した順序で送信されます。

UseSendKeysも有効にする必要があります。

指定した値として何も送信しない場合は、``（2つのバッククオート）という値を指定します。

%d0 = 1; 最初の資格証明フィールドの前に送信するシーケンス

%d0 = 2; 最初のフィールドの後かつ2番目のフィールドの前に送信するシーケンス

- その他; %dは無関係

%d1 = 送信（表示）するコード・シーケンス（デフォルトは標準のタブ・キー）

WindowTitle%d = %s

ログオン・リクエストを識別するためにログオン・ウィンドウ・タイトルと照合されるテキスト。単一のログオンについて複数のウィンドウを指定できるように、%dを1で始まる数字に置き換えます。

%d = 連続した整数

%s = ウィンドウ・タイトル文字列

SectionNサブセクションのWindowsアプリケーション・キー

次の値は、SectionNによって区切られているサブセクション内で使用します。

例

[Corporate WinApp]

Section1=~Corporate WinApp Logon

Section2=~Corporate WinApp Password Change

&

[~Corporate WinApp Logon]

（次のキー）

Windowsアプリケーション・キー | 説明 | 許容値
AppPathKey%d = %s | （前述の親セクションを参照） | （前述の親セクションを参照）
ChangeTitle%d = %s | （前述の親セクションを参照） | （前述の親セクションを参照）
ChgCtrl0 = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
ChgCtrl1 = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
ChgCtrl2 = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
ChgCtrl3 = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
CtrlOrder = %s1, %s2, %s3& | （前述の親セクションを参照） | （前述の親セクションを参照）
IDCtrl = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
IDCtrlType = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
IgnoreClassName = %s | （前述の親セクションを参照） | （前述の親セクションを参照）
InteractionMode = %b | （前述の親セクションを参照） | （前述の親セクションを参照）
Match%d = %s | （前述の親セクションを参照） | （前述の親セクションを参照）
ModuleName%d = %s | （前述の親セクションを参照） | （前述の親セクションを参照）
OKCtrl = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
OtherCtrl1 = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
OtherCtrl1Type = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
OtherCtrl2 = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
OtherCtrl2Type = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
ParentKey1 = %s | （前述の親セクションを参照） | （前述の親セクションを参照）
PassKeyCtrl = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
PassKeyCtrlType = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
VTabKey%d0 = %d1 | （前述の親セクションを参照） | （前述の親セクションを参照）
VTabKeyPWC%d0 = %d1 | （前述の親セクションを参照） | （前述の親セクションを参照）
UseSendKeys = %b | （前述の親セクションを参照） | （前述の親セクションを参照）
WindowTitle%d = %s | （前述の親セクションを参照） | （前述の親セクションを参照）

MatchNサブセクションのWindowsアプリケーション・キー

次の値は、MatchNによって区切られているサブセクション内で使用します。

例

[Corporate WinApp

Section1=~Whatever subsection

Match1=~Corporate WinApp Logon Match

Match2=~Corporate WinApp Ignore Match

&

[~Corporate WinApp Ignore Match]

（次のキー）

一致セクションのキー 説明 許容値

ChangeTitle%d = %s

（前述の親セクションを参照）

（前述の親セクションを参照）

ChgCtrl0 = %d

（前述の親セクションを参照）

（前述の親セクションを参照）

ChgCtrl1 = %d

（前述の親セクションを参照）

（前述の親セクションを参照）

ChgCtrl2 = %d

（前述の親セクションを参照）

（前述の親セクションを参照）

ChgCtrl3 = %d

（前述の親セクションを参照）

（前述の親セクションを参照）

Field%d0 = %d1,%s1,%s2,%s3

フィールドの一致基準。1つの画面に対して複数の一致基準を設定できるように、%d1は1で始まる数字に置き換えます。%d2は一致基準のコントロールIDに置き換えます。 %s1はコントロール・タイプに置き換えます。%s2は比較演算子に置き換えます。 %s3は比較値に置き換えます。

%d0 = 連続した整数

%d1 = 一致基準のコントロールID

%s1 = %s3に適切な値を入れて、コントロール・タイプを次のようにできます。

テキスト | コントロールからの実際のテキスト
スタイル | コントロールのスタイルの数値
クラス | コントロールのクラス（通常は、「Edit」または「Static」）
Edit | 編集またはコンボボックス・コントロール
Static | 静的コントロール（テキスト・ラベルなど）

%s2 = 比較演算子を次のようにできます。

EQ | 等しい
NE | 等しくない

%s3 = 比較値

IDCtrl = %d

（前述の親セクションを参照）

（前述の親セクションを参照）

OKCtrl = %d

（前述の親セクションを参照）

（前述の親セクションを参照）

OtherCtrl1 = %d

（前述の親セクションを参照）

（前述の親セクションを参照）

OtherCtrl2 = %d

（前述の親セクションを参照）

（前述の親セクションを参照）

ParentKey1 = %s

（前述の親セクションを参照）

（前述の親セクションを参照）

PassKeyCtrl = %d

（前述の親セクションを参照）

（前述の親セクションを参照）

Type = %s

イベントのタイプ。

%s = タイプの文字列

Logon | ログオン・イベント
Change | パスワード変更イベント
Confirm | 新しいパスワードの確認
Ignore | アプリケーションのすべてのイベントのバイパス

WindowTitle%d = %s

（前述の親セクションを参照）

（前述の親セクションを参照）


ホスト/メインフレーム・アプリケーション・キー

次の値は、[*Mainframe]セクション内に記述されているアプリケーション内で使用します。

行/列値がある次のすべてのキーの場合、行/列値は1で始まります（左上は1,1となります）。

Telnetの場合、値は1,1にする必要があります。
例

[*Mainframe]

Section1=Corporate Mainframe

&

[Corporate Mainframe]

（次のキー）

ホスト・アプリケーション・キー 説明 許容値

AllowReveal = %b

ウィザードおよびプロパティ・ページのパスワード用の「Reveal」ボタンを有効または無効にするフラグ。

%b = 0; 無効

%b = 1; 有効（デフォルト）

AltTabKey = %d

資格証明をホスト・エミュレータに送信する方法を示すフラグ。 通常、資格証明はダイレクトHLLAPIコールによって送信されますが、この設定では別の方法を使用することを指定します。この設定を1に設定した場合は、2つのフィールドの間で[Enter]キーを押します。通常、この設定は、新しいパスワードと確認パスワードを2つの画面に分けるパスワード変更画面に使用します。

通常、%d=1は新しいパスワード・フィールドと確認パスワードを2つの画面に分けるパスワード変更で使用します。

%d = 0; HLLAPIを使用して、資格証明を資格証明フィールドに直接送信します（デフォルト）。

%d = 1; 2つのフィールド間で、[Tab]キーと[Enter]キーを置き換えます。

%d = 2; HLLAPI SendKeysを使用し、CtrlOrder、PreKeyおよびTabKeyNのサポートを有効にします。この設定は、標準以外の資格証明デリミタがあるログオンの場合に役立ちます。

AutoOK = %b

ログオン・データの挿入後にこのアプリケーション・ログオンに対する[Enter]を自動的に送信するようエージェントに指示します。

%b = 0; 無効

%b = 1; 有効（デフォルト）

CPWFlag = %d

特定のアプリケーションでユーザーがパスワード変更を要求された場合のパスワード変更ウィザードの動作を設定します。このキーは、パスワード変更サブセクションではなく、アプリケーションのルート・セクションに指定します。

この設定は、レジストリを使用して、すべてのアプリケーションを対象にグローバルに設定することもできます。該当する説明を参照してください。

%d = 1; ユーザーにパスワード変更ウィザードに従うように求めます（デフォルト）。

%d = 2; ユーザーに手動で新しいパスワードを入力するように求めるだけでなく、エージェントに自動的にパスワードを生成させるオプションも提供します。

%d = 4; 自動的に新しいパスワードを生成するだけでなく、手動で新しいパスワードを作成するオプションも提供します。

%d = 10; ユーザーに手動で新しいパスワードを入力するように求めます。エージェントに自動的にパスワードを生成させるオプションは提供しません。

%d = 12; 自動的に新しいパスワードを生成します。手動で新しいパスワードを作成するオプションは提供しません。

CtrlOrder = %s1,%s2,%s3,%s4,%s5

AltTabKey=2の場合にフィールドが送信される順序を決定します。

たとえば、CtrlOrder=OtherField1,IDField,PassFieldを指定すると、ダイアログ・ボックス内の順序がOtherField1、IDField、PassFieldとなるようにエージェントに指示されます。

%s1 = 最初のフィールドが送信されます（デフォルトはIDField）。

%s2 = 2番目のフィールドが送信されます（デフォルトはPassField）。

%s3 = 3番目のフィールドが送信されます（デフォルトはOtherField1）。

%s4 = 4番目のフィールドが送信されます（デフォルトはNewPWField）。

%s5 = 5番目のフィールドが送信されます（デフォルトはNewPWField2）。

%s6 = 6番目のフィールドが送信されます（デフォルトはOtherField2）。

DelayField = %d

アクション（フィールドに値を入力するなど）とアクションの間でエージェントが遅延する数値（ミリ秒）。

%d = 整数値（ミリ秒）

Description = %s

このアプリケーションについて説明するテキストで、ログオン・マネージャの「Description」フィールドにも保存されます。

%s = 任意の文字列

Field%d0 = %d1, %d2, %s

ホスト/メインフレーム・ログオンを識別するために画面に表示されているテキスト・フィールドと照合する文字列。ログオンを一意に識別するために複数のテキスト文字列を使用できるように、%d0を1で始まる数字に置き換えます。Telnetアプリケーションの場合は、値を1,1にする必要があります。

%d0 = 連続した整数

%d1 = 最初のテキスト文字列の行

%d2 = 最初のテキスト文字列の列

%s = テキスト文字列

ForceReauth = %b

このアプリケーションに資格証明を提供する前に、再認証を受けることをユーザーに強制します。

すべてのサブセクションに適用されます。複数セクションのパスワード変更シナリオでは、ユーザーは複数回再認証を受ける必要があります。

%b = 0; 再認証は必要ありません（デフォルト）。

%b = 1; 再認証が必要です。

Group = %s

このアプリケーションが属するグループ・セクション名。 資格証明共有グループ用に構成する場合に使用します。 特殊な値には、次のものがあります。

LDAP: アプリケーションでは、LDAPディレクトリ・サーバー認証方式パスワードが使用されます。

ドメイン: アプリケーションでは、Windows認証方式パスワードが使用されます。

詳細は、該当する説明を参照してください。

グループを使用可能にするには、Windowsレジストリ・エントリPWSEnable=1を設定する必要があります。

%s = アプリケーションが所属するアプリケーション・グループのセクション名。

HideConfirmPW = %b

「Logon Error」ダイアログのパスワード確認フィールドを非表示にするかどうかを決定します。

%b = 0; 確認フィールドを非表示にしません（デフォルト）。

%b = 1; 確認フィールドを非表示にします。

IDField = %d1, %d2

ホスト/メインフレーム・ログオン画面に表示されているユーザー名/IDフィールドの最初の入力文字の場所。 Telnetアプリケーションの場合、この値はオプションで無視されます。 フィールドが存在しない場合は、1,0に設定します。

%d1 = 最初のテキスト文字列の行

%d2 = 最初のテキスト文字列の列

MaxRetry = %d

「Logon Error」ダイアログを表示する前に、エージェントが行うログオンの再試行回数を決定します。

%d = 再試行の数（デフォルトは1）

NewPWField = %d1,%d2

新しいパスワード・フィールドの場所を識別するキー値のペア。

%d1 = 最初のテキスト文字列の行

%d2 = 最初のテキスト文字列の列

NewPWField2 = %d1,%d2

新しいパスワード確認フィールドの場所を識別するキー値のペア。 オプションです。 必要な新しいパスワード・フィールドが1つのみである場合は必要ありません。

%d1 = 最初のテキスト文字列の行

%d2 = 最初のテキスト文字列の列

OtherField1 = %d1, %d2

ホスト/メインフレーム・ログオン画面に表示されている3番目のログオン・フィールドの最初の入力文字の場所。 Telnetアプリケーションの場合、この値はオプションで無視されます。

%d1 = 最初のテキスト文字列の行

%d2 = 最初のテキスト文字列の列

OtherField2 = %d1, %d2

ホスト/メインフレーム・ログオン画面に表示されている4番目のログオン・フィールドの最初の入力文字の場所。Telnetアプリケーションの場合、この値はオプションで無視されます。

%d1 = 最初のテキスト文字列の行

%d2 = 最初のテキスト文字列の列

OtherLabel1 = %s

3番目のログオン・フィールドに対してエージェント内で表示されるラベル。

%s = テキスト文字列

OtherLabel2 = %s

4番目のログオン・フィールドに対してエージェント内で表示されるラベル。

%s = テキスト文字列

Page%d = %s

1つのホスト/メインフレーム・アプリケーションの複数のページに使用されるサブセクションへのポインタ。1つのアプリケーション・ログオンに複数のページがある場合があります。

%d = 連続した整数

%s = サブセクション名

ParentKey1 = %s

サブセクションをその親セクションにマップします。

%s = 親アプリケーション/セクション名

PassField = %d1, %d2

ホスト/メインフレーム・ログオン画面に表示されているパスワード・フィールドの最初の入力文字の場所。Telnetアプリケーションの場合、値は1,1にする必要があります。フィールドが存在しない場合は、1,0に設定します。

%d1 = 最初のテキスト文字列の行

%d2 = 最初のテキスト文字列の列

PassPolicy = %s

このアプリケーション・ログオン構成に関連付けるパスワード・ポリシーのセクションを識別します。

%s = ポリシー・セクション名

PreKey = %d

すべての資格証明の送信前に送信する必要があるものを定義する文字とニーモニックの文字列。

文字またはASCIIニーモニック（あるいはその両方）の任意の組合せ。最大長は25文字です。

QuietGenerator = %b

このフラグを設定すると、エージェントによって自動的にパスワード変更リクエストが処理されますが、ユーザーにはパスワード変更リクエストが処理されたことは通知されません。

%b = 0; ユーザーの操作が不要なジェネレータは使用しません。ユーザーの操作を必要とする標準のパスワード変更プロセスを使用します（デフォルト）。

%b = 1; ユーザーの操作が不要なジェネレータを使用します。

TabKey1 = %d

IDFieldの送信後に送信する必要があるものを定義する文字とニーモニックの文字列。

文字またはASCIIニーモニック（あるいはその両方）の任意の組合せ。最大長は25文字です。

TabKey2 = %d

PassFieldの送信後に送信する必要があるものを定義する文字とニーモニックの文字列。

文字またはASCIIニーモニック（あるいはその両方）の任意の組合せ。最大長は25文字です。

TabKey3 = %d

OtherField1の送信後に送信する必要があるものを定義する文字とニーモニックの文字列。

文字またはASCIIニーモニック（あるいはその両方）の任意の組合せ。最大長は25文字です。

TabKey4 = %d

NewPWFieldの送信後に送信する必要があるものを定義する文字とニーモニックの文字列。

文字またはASCIIニーモニック（あるいはその両方）の任意の組合せ。最大長は25文字です。

TabKey5 = %d

NewPWField2の送信後に送信する必要があるものを定義する文字とニーモニックの文字列。

文字またはASCIIニーモニック（あるいはその両方）の任意の組合せ。最大長は25文字です。

TabKey6 = %d

OtherField2の送信後に送信する必要があるものを定義する文字とニーモニックの文字列。

文字またはASCIIニーモニック（あるいはその両方）の任意の組合せ。 最大長は25文字です。

Timeout = %d

ログオンが連続して試行されている場合の、エラー・ループ検出がトリガーされるまでの最長期間を決定します。

%d = 秒単位の時間（デフォルトは30）

ホスト・アプリケーション: PageNサブセクションのキー

次の値は、PageNによって区切られているサブセクション内で使用します。

例

[Corporate Mainframe]

Page1=~Corporate Mainframe Logon

Page2=~Corporate Mainframe Password Change

[~Corporate Mainframe Logon]

（次のキー）

ホスト・アプリケーション・キー | 説明 | 許容値
AllowReveal = %b | （前述の親セクションを参照） | （前述の親セクションを参照）
AltTabKey = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
AutoOK = %b | （前述の親セクションを参照） | （前述の親セクションを参照）
CPWFlag = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
CtrlOrder = %s1,%s2,%s3,%s4,%s5 | （前述の親セクションを参照） | （前述の親セクションを参照）
DelayField = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
Description = %s | （前述の親セクションを参照） | （前述の親セクションを参照）
Field%d0 = %d1, %d2, %s | （前述の親セクションを参照） | （前述の親セクションを参照）
ForceReauth = %b | （前述の親セクションを参照） | （前述の親セクションを参照）
Group = %s | （前述の親セクションを参照） | （前述の親セクションを参照）
HideConfirmPW = %b | （前述の親セクションを参照） | （前述の親セクションを参照）
IDField = %d1, %d2 | （前述の親セクションを参照） | （前述の親セクションを参照）
MaskPW = %b | （前述の親セクションを参照） | （前述の親セクションを参照）
MaxRetry = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
NewPWField = %d1,%d2 | （前述の親セクションを参照） | （前述の親セクションを参照）
NewPWField2 = %d1,%d2 | （前述の親セクションを参照） | （前述の親セクションを参照）
OtherField1 = %d1, %d2 | （前述の親セクションを参照） | （前述の親セクションを参照）
OtherField2 = %d1, %d2 | （前述の親セクションを参照） | （前述の親セクションを参照）
OtherLabel1 = %s | （前述の親セクションを参照） | （前述の親セクションを参照）
OtherLabel2 = %s | （前述の親セクションを参照） | （前述の親セクションを参照）
Page%d = %s | （前述の親セクションを参照） | （前述の親セクションを参照）
ParentKey1 = %s | （前述の親セクションを参照） | （前述の親セクションを参照）
PassField = %d1, %d2 | （前述の親セクションを参照） | （前述の親セクションを参照）
PassPolicy = %s | （前述の親セクションを参照） | （前述の親セクションを参照）
PreKey = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
QuietGenerator = %b | （前述の親セクションを参照） | （前述の親セクションを参照）
TabKey1 = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
TabKey2 = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
TabKey3 = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
TabKey4 = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
TabKey5 = %d | （前述の親セクションを参照） | （前述の親セクションを参照）
Timeout = %d | （前述の親セクションを参照） | （前述の親セクションを参照）


Webアプリケーション・キー

次の値は、[*Other Webs]セクション内に記述されているアプリケーション内で使用します。

例

[*Mainframe]

Section1=Corporate Mainframe

&

[Corporate Mainframe]

（次のキー）

Webアプリケーション・キー 説明 許容値

AllowReveal = %b

ウィザードおよびプロパティ・ページのパスワード用の「Reveal」ボタンを有効または無効にするフラグ。

%b = 0; 無効

%b = 1; 有効（デフォルト）

AutoOK = %b

ログオン・データの挿入後にこのアプリケーション・ログオンに対する[Enter]を自動的に送信するようエージェントに指示します。

%b = 0; 無効

%b = 1; 有効（デフォルト）

CPWFlag = %d

特定のアプリケーションでユーザーがパスワード変更を要求された場合のパスワード変更ウィザードの動作を設定します。このキーは、パスワード変更サブセクションではなく、アプリケーションのルート・セクションに指定します。

この設定は、レジストリを使用して、すべてのアプリケーションを対象にグローバルに設定することもできます。

%d = 1; ユーザーにパスワード変更ウィザードに従うように求めます（デフォルト）。

%d = 2; ユーザーに手動で新しいパスワードを入力するように求めるだけでなく、エージェントに自動的にパスワードを生成させるオプションも提供します。

%d = 4; 自動的に新しいパスワードを生成するだけでなく、手動で新しいパスワードを作成するオプションも提供します。

%d = 10; ユーザーに手動で新しいパスワードを入力するように求めます。エージェントに自動的にパスワードを生成させるオプションは提供しません。

%d = 12; 自動的に新しいパスワードを生成します。手動で新しいパスワードを作成するオプションは提供しません。

Description = %s

このアプリケーションについて説明するテキストで、ログオン・マネージャの「Description」フィールドにも保存されます。

%s = 任意の文字列

ForceReauth = %b

このアプリケーションに資格証明を提供する前に、再認証を受けることをユーザーに強制します。

すべてのサブセクションに適用されます。複数セクションのパスワード変更シナリオでは、ユーザーは複数回再認証を受ける必要があります。

%b = 0; 再認証は必要ありません（デフォルト）。

%b = 1; 再認証が必要です。

Group = %s

このアプリケーションが所属するグループ・セクション名。資格証明共有グループ用に構成する場合に使用します。特殊な値には、次のものがあります。

LDAP: アプリケーションでは、LDAPディレクトリ・サーバー認証方式パスワードが使用されます。

ドメイン: アプリケーションでは、Windows認証方式パスワードが使用されます。

詳細は、該当する説明を参照してください。

グループを使用可能にするには、Windowsレジストリ・エントリPWSEnable=1を設定する必要があります。

%s = アプリケーションが所属するアプリケーション・グループのセクション名。

HideConfirmPW = %b

「Logon Error」ダイアログのパスワード確認フィールドを非表示にするかどうかを決定します。

%b = 0; 確認フィールドを非表示にしません（デフォルト）。

%b = 1; 確認フィールドを非表示にします。

IDField = %s1,%s2,%s3,%s4

ユーザー名/IDを入力するためのフィールドのID。

フレーム/フォーム/フィールドの名前が数字のみで構成されている場合は、列挙値を使用する必要があります。

%s1 = フレーム名/番号

%s2 = フォーム名/番号

%s3 = フィールド名/番号

%s4 = フィールド・タイプ（テキスト/パスワード）

MaxRetry = %d

「Logon Error」ダイアログを表示する前に、エージェントが行うログオンの再試行回数を決定します。

%d = 再試行の数（デフォルトは1）

NewPWField = %s1,%s2,%s3,%s4

新しいパスワードを入力するためのフィールドのID。

%s1 = フレーム名/番号

%s2 = フォーム名/番号

%s3 = フィールド名/番号

%s4 = フィールド・タイプ（テキスト/パスワード）

NewPWField2 = %s1,%s2,%s3,%s4

新しいパスワードを確認するためのフィールドのID。

%s1 = フレーム名/番号

%s2 = フォーム名/番号

%s3 = フィールド名/番号

%s4 = フィールド・タイプ（テキスト/パスワード）

OtherField1 = %s1,%s2,%s3,%s4

3番目のログオン・フィールドのID。

%s1 = フレーム名/番号

%s2 = フォーム名/番号

%s3 = フィールド名/番号

%s4 = フィールド・タイプ（テキスト/パスワード）

OtherField2 = %s1,%s2,%s3,%s4

4番目のログオン・フィールドのID。

%s1 = フレーム名/番号

%s2 = フォーム名/番号

%s3 = フィールド名/番号

%s4 = フィールド・タイプ（テキスト/パスワード）

OtherLabel1 = %s

3番目のログオン・フィールドに対してエージェント内で表示されるラベル。

%s = テキスト文字列

OtherLabel2 = %s

4番目のログオン・フィールドに対してエージェント内で表示されるラベル。

%s = テキスト文字列

ParentKey1 = %s

サブセクションをその親セクションにマップします。

%s = 親アプリケーション/セクション名

PassField = %s1,%s2,%s3,%s4

パスワードを入力するためのフィールドのID。

%s1 = フレーム名/番号

%s2 = フォーム名/番号

%s3 = フィールド名/番号

%s4 = フィールド・タイプ（テキスト/パスワード）

PassPolicy = %s

このアプリケーション・ログオン構成に関連付けるパスワード・ポリシーのセクションを識別します。

%s = ポリシー・セクション名

QuietGenerator = %b

このフラグを設定すると、エージェントによって自動的にパスワード変更リクエストが処理されますが、ユーザーにはパスワード変更リクエストが処理されたことは通知されません。

%b = 0; ユーザーの操作が不要なジェネレータは使用しません。ユーザーの操作を必要とする標準のパスワード変更プロセスを使用します（デフォルト）。

%b = 1; ユーザーの操作が不要なジェネレータを使用します。

Section%d = %s

アプリケーション・サブセクションの宣言。

%d = 連続した整数

%s = サブセクション名

StrictURLCheck = %b

URLの正確な（大/小文字を区別しない）一致を必要とするか、文字列の部分一致を使用するかを決定します。

%b = 0; 文字列の部分一致を使用します（デフォルト）。

%b = 1; 正確な一致を使用します。

SubmitField = %s1,%s2,%s3,%s4

「Submit」ボタン（または同等のもの）のID。

値の形式は、フレーム名/番号、フォーム名/番号、フィールド名/番号/URL、およびフィールド・タイプです。フィールド・タイプがイメージの場合、フィールド名は完全かつ正確なURLにする必要があります。

このエントリはオプションです。指定しない場合、エージェントでは独自の内部検索ロジックによってこのボタンが特定され、押されます。

%s1 = フレーム名/番号

%s2 = フォーム名/番号

%s3 = フィールド名/番号/URL

%s4 = フィールド・タイプ（送信/イメージ）

Timeout = %d

ログオンが連続して試行されている場合の、エラー・ループ検出がトリガーされるまでの最長期間を決定します。

%d = 秒単位の時間（デフォルトは30）

URL%d = %s

Webサイトのログオン・ページのアドレス。

注意: Webアドレスが空白や特殊文字で構成されている場合は、URL引用方法（RFC 2396）を使用してWebアドレスを定義します。 これは、URLの各空白に%20を代用し、 : / , . = ? @以外のすべての文字に、同様の%でエスケープされたASCII 16進値を代用することを意味します。

%d = 1で始まる連続した整数

%s = Web URL

SectionNサブセクションのWebアプリケーション・キー

次の値は、SectionNによって区切られているサブセクション内で使用します。

例

[Corporate WebApp]

Section1=~Corporate Intranet Logon #1

Section2=~Corporate Intranet Logon #2

&

[~Corporate Intranet Logon #1]

（次のキー）

Webアプリケーション・キー | 説明 | 許容値
IDField = %s1,%s2,%s3,%s4 | （前述の親セクションを参照） | （前述の親セクションを参照）
NewPWField = %s1,%s2,%s3,%s4 | （前述の親セクションを参照） | （前述の親セクションを参照）
NewPWField2 = %s1,%s2,%s3,%s4 | （前述の親セクションを参照） | （前述の親セクションを参照）
OtherField1 = %s1,%s2,%s3,%s4 | （前述の親セクションを参照） | （前述の親セクションを参照）
OtherField2 = %s1,%s2,%s3,%s4 | （前述の親セクションを参照） | （前述の親セクションを参照）
ParentKey1 = %s | （前述の親セクションを参照） | （前述の親セクションを参照）
PassField = %s1,%s2,%s3,%s4 | （前述の親セクションを参照） | （前述の親セクションを参照）
SubmitField = %s1,%s2,%s3,%s4 | （前述の親セクションを参照） | （前述の親セクションを参照）
URL%d = %s | （前述の親セクションを参照） | （前述の親セクションを参照）


パスワード・ポリシー・キー

次の値は、[*PasswordPolicies]内のSectionNによって区切られているサブセクション内で使用します。

例

[*PasswordPolicies

Section1=A policy

Section2=PIN

Section3=Windows

&

[A policy]

（次のキー）

パスワード・ポリシー・キー | 説明 | 許容値
ALPHA = %s | パスワードの生成時にアルファベット文字を使用するようにエージェントに指示するフラグ。 | %s = U; 大文字のアルファベット文字のみを使用します。 %s = L; 小文字のアルファベット文字のみを使用します。 %s = UL; 大文字と小文字を使用します（デフォルト）。 %s =（なし）;アルファベット文字を使用しません。
NAME = %s | このパスワード・ポリシーのわかりやすい名前。 | %s = 任意の文字列
NUMCONSMAX = %d | パスワード内で特定の文字を連続して（その文字に隣接して）繰り返すことができる回数。 | %d = 0から127（デフォルトは8）
NUMERIC = %b | パスワードの生成時に数字を使用するようにエージェントに指示するフラグ。 | %b = 0; 数字を使用しません（デフォルト）。 %b = 1; 数字を使用します。
NUMFLAGFIRST = %b | 数字をパスワードの先頭にできるかどうかを示すフラグ。 | %b = 0; 数字を先頭にすることはできません（デフォルト）。 %b = 1; 数字を先頭にできます。
NUMFLAGLAST = %b | 数字をパスワードの末尾にできるかどうかを示すフラグ。 | %b = 0; 数字を末尾にすることはできません（デフォルト）。 %b = 1; 数字を末尾にできます。
NUMRPTMAX = %d | パスワード内で文字を繰り返すことができる回数。 | %d = 0から127（デフォルトは8）
NUMSIZE = %d | 数字の最大数。 | %d = 0から128（デフォルトは0）
NUMSIZEMIN = %d | 数字の最小数。 | %d = 0から128（デフォルトは0）
SBYE = %s | このパスワードの生成時に除外する特殊文字のリスト。 | %s = 次のような、除外する特殊文字の任意の文字列 !@#$ 通常使用されるが、除外できる特殊文字のリストを保持するWindowsレジストリ・キーのペアは、AccessManager:SpecialCharsです。
SCHARFLAGFIRST = %b | 特殊文字をパスワードの先頭にできるかどうかを示すフラグ。 | %b = 0; 特殊文字を先頭にすることはできません（デフォルト）。 %b = 1; 特殊文字を末尾にできます。
SCHARFLAGLAST = %b | 特殊文字をパスワードの末尾にできるかどうかを示すフラグ。 | %b = 0; 特殊文字を末尾にすることはできません（デフォルト）。 %b = 1; 特殊文字を先頭にできます。
SCHARS = %b | パスワードの生成時に特殊文字を使用するようにエージェントに指示するフラグ。 | %b = 0; 特殊文字を使用しません（デフォルト）。 %b = 1; 特殊文字を使用します。
SCHARSIZE = %d | 特殊文字の最大数。 | %d = 0から128（デフォルトは0）
SCHARSIZEMIN = %d | 特殊文字の最小数。 | %d = 0から128（デフォルトは0）
SIZE = %d | パスワードの合計最大長。 | %d = 1から255（デフォルトは8）
SIZEMIN = %d | パスワードの合計最小長。 | %d = 1から255（デフォルトは8）


グローバル・エージェント設定

「Settings」ダイアログの使用、ローカル・ワークステーションでのWindowsレジストリ設定、およびシンクロナイザ拡張での管理優先設定の指定によって、ESSO-LMの各種機能と動作を集中定義できます。

これらの設定をコンソールで構成してください。表は参考用です。

レジストリ設定は、エージェント、Administrative Consoleによって、RegEdit Windowsユーティリティおよび集中管理されたソフトウェア配布メカニズムを使用して設定できます。レジストリ設定は、次のWindowsレジストリの場所にあります。

  • コンピュータ固有の設定用のHKLM\...\
  • ユーザー固有の設定用のHKCU\...\

シンクロナイザ拡張の管理優先設定オブジェクトでは、HKLM\... Windowsレジストリ設定より優先される設定を指定します。このレジストリ設定は、HKCU\...\ Windowsレジストリ設定より優先されます。

 | 例:
シンクロナイザ拡張オブジェクト | Extensions\AccessManager:MFEnable=DWORD:0
優先 |
コンピュータ固有のレジストリの場所（HKLM\...\） | HKLM\...\Extensions\AccessManager:MFEnable
優先 |
ユーザー固有のレジストリの場所（HKCU\...\）? または ESSO-LM の「Settings」ダイアログのユーザー設定「Mainframe Enable」 | HKCU\...\Extensions\AccessManager:MFEnable

レジストリ設定および管理優先設定の設定

Administrative Consoleを使用してHKLM\&\値を構成し、シンクロナイザ拡張に配置できます。

  1. Administrative Consoleで、設定の新しいセットを作成（「Global Agent Settings」を右クリックして「New Settings」を選択）するか、保存されている設定のセットをロード（「Agent Settings」を右クリックして「Import」を選択）するか、または既存の設定のセットを選択（左側のペインで既存の設定のセットを選択）します。

  2. 左側のペインで、設定のセットを選択して開き、該当するレジストリ・キーを選択して開きます

    Extensions\で始まるレジストリ・エントリは、Administrative Consoleでは最初のExtensions\なしで表示されます。
  3. 右側のペインで、該当するレジストリ値を選択し、チェック・ボックスを選択して値を入力します。
  4. 該当する形式（管理優先設定またはHKLMレジストリ形式）にエクスポートします。
  5. 左側のペインで設定のセットを選択します。
  6. 「File」メニューから「Export」を選択し、エクスポート形式を選択します。

管理優先設定ファイルをシンクロナイザ拡張に配置するには、次の項を参照してください。

  • ディレクトリ・サーバー・サポート
  • データベース同期サポート
  • ファイル・サーバー・サポート

HKLMレジストリ形式ファイルを使用するには、そのファイルを起動する（たとえば、エクスプローラからファイルをダブルクリックして）か、インポートする（たとえば、RegEditから）か、または配置ツールを使用して配置します。


優先設定: レジストリ値

次の表に、各レジストリの場所と次の情報を示します（該当する場合）。

  • 表示パス（コンソールの左側のペインのナビゲータのノード）および表示名（右側のペインのプロパティ・シートの設定）。
  • 実際のレジストリ・パスと値の名前、および設定、デフォルト、オプションの説明（実際の値とその定義）。
  • 設定を優先させることができるかどうか（つまり、管理優先設定オブジェクトまたはファイルに含めることができるかどうか）。
  • レジストリ・タイプ（DWORD、文字列またはバイナリ）およびデータ型。
表示パス | 表示名 | 説明テキスト | 優先可能 | オプション | デフォルト | レジストリ・タイプ | データ型
End-User Experience | Show the Tray Icon | Shell:ShowTrayIcon: トレイ・アイコンを表示するかどうか。 | はい | 0 表示しません 1 表示します | デフォルト: 1 | dword |
End-User Experience | Title Bar Button | Shell:ShowAccessBtn: ウィンドウ/ダイアログのタイトル・バーにタイトル・バー・ボタンを表示するかどうか。 | はい | 0 表示しません 1 表示します | デフォルト: 0 | dword |
End-User Experience | Title Bar Button Menu | Shell:ShowAccessBtnMenu: タイトル・バー・ボタンからメニューを表示するかどうか。 | はい | 0 表示しません 1 表示します | デフォルト: 1 | dword |
End-User Experience | Tray Icon tooltip | Shell:TrayIconName: トレイ・アイコン・ラベルに表示されるテキスト。（推奨される用途: 各Citrix Metaframe/Terminal Services/リモート・サーバー/セッションへのラベル付け。） | はい |  | デフォルト: Oracle Enterprise Single Sign-on Logon Manager | 文字列 | 文字列
End-User Experience | Tray Icon tooltip: Show System Name | Shell:TrayIconDisplaySysName: トレイ・アイコン名の後にコンピュータ名を表示するかどうか。TrayIconNameが設定されていない場合、または設定されていても空/NULLでない場合は、空白-ダッシュ-空白で構成される文字列がコンピュータ名の前に挿入されます。 | はい | 0 表示しません 1 表示します | デフォルト: 0 | dword |
End-User Experience\Advanced | Logon Animation's duration | Shell:AutoLogonAnimationTime: アニメーション・スピナーを表示する（応答を一時停止する）時間（ミリ秒）。注意: 値が0の場合、スピナーは無効になります。 | はい |  | デフォルト: 0 | dword | 整数
End-User Experience\Advanced | Logon Chooser Columns | Extensions\AccessManager\LogonChooser:Columns: ログオン・チューザに表示される列の順序。 | はい | 1 ユーザー名/ID 2 アプリケーション名 3 説明 | デフォルト: 1,2,3 | 文字列 |
End-User Experience\Advanced | Logon Manager "Details" Columns | Extensions\AccessManager\LogonManager:Columns: ログオン・マネージャの「Details」ビューで表示される列および使用される順序。 | はい | 1 アプリケーション名 2 URL/モジュール 3 ユーザー名/ID 4 パスワード 5 変更 6 最後の使用 7 説明 8 グループ 9 3番目のフィールド 10 4番目のフィールド | デフォルト: 1,2,3,4,5,6,7,8 | 文字列 |
End-User Experience\Advanced | Logon Manager Refresh button | Extensions\AccessManager:AllowRefresh: ログオン・マネージャの「Refresh」ボタンを有効/無効にします。 | はい | 0 無効 1 有効 | デフォルト: 1 | dword |
End-User Experience\Advanced | User can shut down ESSO-LM from the System Tray Icon Menu | Shell:AllowShutdown: 有効（デフォルト）にすると、エンド・ユーザーはシステム・トレイ・アイコン・メニューから「Shutdown ESSO-LM」を選択して、エージェントを停止できます。無効にすると、このメニュー項目は使用できません（グレーアウトされます）。 | はい | 0 メニューからの停止を許可しません 1 メニューからの停止を許可します | デフォルト: 1 | dword |
End-User Experience\Advanced\Performance | Increase user data storage priority | Extensions\StorageManager\InMemShr:ThreadPriority: ユーザー・データ（資格証明など）への変更を保存するための処理優先順位を高くします。ワークステーションのCPUの使用率が頻繁に100%になる場合にのみ、「Increase」に設定します。 | はい | 1 処理優先順位を高くします 0 処理優先順位を高くしません | デフォルト: 0 | dword |
End-User Experience\Advanced\Performance | Set delay for first update (after startup) to stored user data (ms) | Extensions\StorageManager\InMemShr:IntitialThreadDelay: ESSO-LMを起動してから内部データベースにユーザー・データ（資格証明など）の変更を書き込むまでの待機時間（ミリ秒）を設定します。 | はい |  | デフォルト: 5000 | dword | 整数
End-User Experience\Advanced\Performance | Set delay for storing user data (ms) | Extensions\StorageManager\InMemShr:ThreadDelay: 内部データベースにユーザー・データ（資格証明など）の変更を書き込むまでの待機時間（ミリ秒）を設定します。 | はい |  | デフォルト: 500 | dword | 整数
End-User Experience\Advanced\Performance | Store user data on disk in encrypted file | Extensions\StorageManager\InMemShr:LocalStorage: ユーザー・データ（資格証明など）のコピーを各ユーザーのApplication Dataフォルダの暗号化されたデータベース・ファイルにローカルに保存します。 | はい | 1 ユーザー・データをディスク・ファイルに保存します 0 ユーザー・データをディスク・ファイルに保存しません | デフォルト: 1 | dword |
End-User Experience\Advanced\Special Tasks | After Agent starts up | Shell\Tasks:StartupTaskN: バックグラウンド・タスクが開始されるたびに実行するコマンド（タスクバー・トレイ・アイコン）。 | はい |  | デフォルト: なし | 文字列 |
End-User Experience\Advanced\Special Tasks | Before Agent starts | Shell\Tasks:PreTaskN: エージェント・プロセスの開始前に実行されるコマンド。注意: このようなタスクが失敗した場合（License:PreCheckに作成されるレジストリ値で示されます）、エージェントは続行しません。 | はい |  | デフォルト: なし | 文字列 |
End-User Experience\Advanced\Special Tasks | When logons are deleted | Shell\Tasks:DeletionTaskN: ユーザーがアプリケーション構成を削除するたびに実行されるコマンド。 | はい |  | デフォルト: なし | 文字列 |
End-User Experience\Advanced\Special Tasks | When logons change (add, delete, copy, modify) | Shell\Tasks:RefreshTaskN: 資格証明およびユーザー構成が変更されるたびに実行されるコマンド。 | はい |  | デフォルト: なし | 文字列 |
End-User Experience\Environment | Default Backup path | Shell:AutoBackupPath: サイレント・バックアップのデフォルトのバックアップ・パス。このパスが存在せず、コマンドライン内で指定されない場合、ユーザーのアプリケーション・データ・ディレクトリ（%AppData%\SSO）が使用されます。 | はい |  | デフォルト: なし | 文字列 | ファイル名
End-User Experience\Environment | Language | [Root]:Language: 使用する言語。注意: 他の値も、ローカライズされたバージョンに応じて使用可能です。注意: 表示フォントで、指定の言語の目的の文字がサポートされている必要があります。 | はい | ENG 英語 | デフォルト: ENG | 文字列 |
End-User Experience\Environment | Location of entlist.ini file | Extensions\AccessManager:EntList: entlist.iniファイルの完全修飾パスおよびファイル名。 | はい |  | デフォルト: なし | 文字列 | ファイル名
End-User Experience\Environment | SubLanguage | [Root]:SubLanguage: 「Language」で設定する言語の言語設定。注意: 他の値も、ローカライズされたバージョンに応じて使用可能です。注意: 表示フォントで、指定の言語の目的の文字がサポートされている必要があります。 | はい | ENG デフォルト・サポート DBL 拡張サポート | デフォルト: ENG | 文字列 |
End-User Experience\Password Change\Advanced | Allow user to exclude logons from password groups | Extensions\AccessManager:AllowExcludePWSG: エンド・ユーザーは、割り当てられた資格証明共有グループからアプリケーション・ログオンを除外できます。 | はい | 0 許可しません 1 許可します | デフォルト: 0 | dword |
End-User Experience\Password Change\Advanced | Notify Primary Logon Method | AUI:ShareToAuth: 資格証明共有グループの資格証明を変更したときに、現在の認証方式に資格証明共有を適用します。注意: 現在、Windows Authenticator v2およびLDAP Authenticator v2に対してのみサポートされています。注意: ユーザーには新しいパスワードが通知されないため、共有グループのアプリケーションのパスワードを変更するときには、自動パスワード生成を使用しないことをお薦めします。 | はい | 0 認証方式に通知しません 1 認証方式に通知します | デフォルト: 0 | dword |
End-User Experience\Password Change\Advanced | Quietly Change Passwords | Extensions\AccessManager:QuietGenerator: ユーザーにパスワード変更を通知するかどうか。 | はい | 0 ユーザーに通知します 1 ユーザーに通知しません | デフォルト: 0 | dword |
End-User Experience\Password Change\Change Policies | Characters: Lowercase | Extensions\AccessManager:LowerAlphaChars: パスワード・ポリシー内で小文字の英字として許可する文字のリスト。 | はい |  | デフォルト: abcdefghijklmnopqrstuvwxyz | 文字列 | UniqueChars
End-User Experience\Password Change\Change Policies | Characters: Numeric | Extensions\AccessManager:NumericChars: パスワード・ポリシー内で数字として許可する文字のリスト。 | はい |  | デフォルト: 1234567890 | 文字列 | UniqueChars
End-User Experience\Password Change\Change Policies | Characters: Special | Extensions\AccessManager:SpecialChars: パスワード・ポリシー内で特殊文字として許可する文字のリスト。 | はい |  | デフォルト: !@#$^&*_-+=[]\|,? | 文字列 | UniqueChars
End-User Experience\Password Change\Change Policies | Characters: Uppercase | Extensions\AccessManager:UpperAlphaChars: パスワード・ポリシー内で大文字のアルファベット文字として許可する文字のリスト。 | はい |  | デフォルト: ABCDEFGHIJKLMNOPQRSTUVWXYZ | 文字列 | UniqueChars
End-User Experience\Password Change\Change Policies | Default Policy | Extensions\AccessManager:DefaultPolicy: デフォルトのパスワード・ポリシーを含むentlist.iniのセクションの名前。（entlist.iniでポリシーが指定されていない場合、applist.iniのデフォルトのポリシーが使用されます。） | はい |  | デフォルト: なし | 文字列 | PasswordPolicy
End-User Experience\Password Change\Common | Default Change Password Wizard behavior | Extensions\AccessManager:CPWFlag: ユーザーがパスワード変更リクエストを受け取った際のパスワード変更ウィザードの動作を設定します。 | はい | 1 確認します 2 手動（自動を提示） 4 自動（手動を提示） 10 手動のみ 12 自動のみ | デフォルト: 1 | dword |
End-User Experience\Password Change\Required | Password Groups | Extensions\AccessManager:PWSEnable: グループ内の資格証明間での資格証明共有を有効/無効にします。（この設定が有効でない場合、資格証明共有グループは使用されません。）注意: ドメイン・グループを使用し、かつWindows Authenticator v2をそのグループに含める場合は、AUI\Windows Authenticator v2:PWSEnableを無効にしないでください。注意: LDAPグループを使用し、かつLDAP Authenticator v2をグループに含める場合は、AUI\LDAP Authenticator v2:PWSEnableを無効にしないでください。 | はい | 0 無効 1 有効 | デフォルト: 0 | dword |
End-User Experience\Response | Automatically logon to applications | Shell:UseActiveLogin: アプリケーションに自動的に資格証明を提供するかどうか。 | はい | 0 自動的に資格証明を提供しません。 1 自動的に資格証明を提供します。 | デフォルト: 1 | dword |
End-User Experience\Response | Display "Add another logon" checkbox | Extensions\AccessManager:ShowAddAdditionalLogon: 追加ウィザードの「Add another logon」チェック・ボックスの表示を有効/無効にします。 | はい | 0 無効 1 有効 | デフォルト: 0 | dword |
End-User Experience\Response | Limit user to predefined applications | Extensions\AccessManager:AllowUnknown: ユーザーが、事前定義されていないアプリケーションの資格証明を追加できるかどうか。 | はい | 0 制限します 1 制限しません | デフォルト: 1 | dword |
End-User Experience\Response | Logon to waiting applications upon agent startup | Shell:LogonOnStartup: エージェントの起動時に、すでにログオン・フォームが存在するWindowsアプリケーションまたはJavaアプリケーションに資格証明を送信できます。注意: Webおよびホスト/メインフレーム・アプリケーションのログオンは、この設定の影響を受けません。 | はい | 0 ログオンしません 1 起動時にログオンします | デフォルト: 0 | dword |
End-User Experience\Response | Prompt user to add new logons | Shell:UseAutoSense: 新しいアプリケーションが検出されたときに、ユーザーがログオンを追加するかどうかを確認するかどうか。 | はい | 0 確認しません 1 確認します | デフォルト: 1 | dword |
End-User Experience\Response | Time allowed for Java applets to load | Extensions\AccessManage:MaxAppletLoadTime: Javaアプレットがブラウザに完全にロードされるのをエージェントが待機する最大時間（秒単位）。 | はい |  | デフォルト: 6 | dword | 整数
End-User Experience\Response | Utilize the just-added Logon | Extensions\AccessManager:LogonAfterConfig: アプリケーションの構成後、そのアプリケーションに（資格証明を追加して）ログオンするかどうか。注意: アプリケーション構成固有の設定が優先されます。 | はい | 0 ログオンしません 1 ログオンします | デフォルト: 1 | dword |
End-User Experience\Response\Error Loop | Maximum retries before prompting | Extensions\AccessManager\Dlg:MaxRetry: 「Error Loop」ダイアログを表示するまでのログオンの再試行回数。注意: アプリケーション・タイプおよびアプリケーション構成固有の設定が優先されます。注意: これは資格証明の各セット用です。 | はい |  | デフォルト: 1 | dword | 整数
End-User Experience\Response\Error Loop | Maximum time for retries before prompting | Extensions\AccessManager\Dlg:Timeout: 「Error Loop」ダイアログが表示されるまでの、すべてのログオン連続試行最大秒数。注意: アプリケーション・タイプおよびアプリケーション構成固有の設定が優先されます。注意: これは資格証明の各セット用です。 | はい |  | デフォルト: 30 | dword | 整数
End-User Experience\Response\Error Loop | Require password confirmation when modifying password | Extensions\AccessManager\Dlg:HideConfirmPW: 「Logon Error」ダイアログに「Confirm Password」フィールドを表示するかどうかを指定します。デフォルトでは、パスワード確認が「Require」となります。注意: アプリケーション・タイプおよびアプリケーション構成固有の設定が優先されます。 | はい | 0 必要 1 不要 | デフォルト: 0 | dword |
End-User Experience\Response\Host/Mainframe Apps | Host/Mainframe support | Extensions\AccessManager:MFEnable: ホスト/メインフレームのサポートを有効/無効にします。 | はい | 0 無効 1 有効 | デフォルト: 1 | dword |
End-User Experience\Response\Host/Mainframe Apps | Polling Interval | Extensions\AccessManager\MHO:CycleInterval: エージェントがホスト・エミュレータに変更が加えられているかどうかを確認する間隔（ミリ秒）。値を低くすると、使用するCPU時間が増えます。値を高くすると、画面が表示されてからエージェントが資格証明を提供するまでの時間が長くなります。 | はい |  | デフォルト: 700 | dword | 整数
End-User Experience\Response\Host/Mainframe Apps\Error Loop | Maximum retries before prompting | Extensions\AccessManager\Dlg:MainframeMaxRetry: ホスト/メインフレーム・ログオンのログオン再試行回数を制御します。 | はい |  | デフォルト: 1 | dword | 整数
End-User Experience\Response\Host/Mainframe Apps\Error Loop | Maximum time for retries before prompting | Extensions\AccessManager\Dlg:MainframeTimeout: メインフレームのタイムアウトを制御します。デフォルトは30秒です。 | はい |  | デフォルト: 30 | dword | 整数
End-User Experience\Response\Host/Mainframe Apps\Error Loop | Require password confirmation when modifying password | Extensions\AccessManager\Dlg:MainframeHideConfirmPW: ホスト/メインフレーム・ログオンの「Logon Error」ダイアログに「Confirm Password」フィールドを表示するかどうかを指定します。デフォルトでは、パスワード確認が「Require」となります。 | はい | 0 必要 1 不要 | デフォルト: 0 | dword |
End-User Experience\Response\Web Apps | Border Appearance | Extensions\AccessManager\BHO:FeedbackColor: デフォルトの枠線の色/サイズ/スタイル。 | はい |  | デフォルト: 赤6px実線 | 文字列 | 文字列
End-User Experience\Response\Web Apps | Show Border | Extensions\AccessManager\BHO:ShowBorder: フィールド周囲の枠線を有効/無効にします。 | はい | 0 無効 1 有効 | デフォルト: 1 | dword |
End-User Experience\Response\Web Apps | URL Matching Precision | Extensions\AccessManager:DNLevelsToMatch: 一致基準として使用されるURLのレベル数。注意: 2より小さい値は2として扱われます。Web URL http://mail.Passlogix.comでは、2=*Passlogix.comと一致、3=*mail.Passlogix.comと一致します。 | はい |  | デフォルト: 2 | dword | 整数
End-User Experience\Response\Web Apps\Error Loop | Maximum retries before prompting | Extensions\AccessManager\Dlg:WebMaxRetry: Webの再試行を制御します。デフォルト値は1です。 | はい |  | デフォルト: 1 | dword | 整数
End-User Experience\Response\Web Apps\Error Loop | Maximum time for retries before prompting | Extensions\AccessManager\Dlg:WebTimeout: Webのタイムアウトを制御します。デフォルトは30秒です。 | はい |  | デフォルト: 30 | dword | 整数
End-User Experience\Response\Web Apps\Error Loop | Require password confirmation when modifying password | Extensions\AccessManager\Dlg:WebHideConfirmPW: Webログオンの「Logon Error」ダイアログに「Confirm Password」フィールドを表示するかどうかを指定します。デフォルトでは、パスワード確認が「Require」となります。 | はい | 0 必要 1 不要 | デフォルト: 0 | dword |
End-User Experience\Response\Windows Apps | Supported Window Classes for Applications | Extensions\AccessManager:AppClasses: アプリケーションとして認識されるデフォルトのウィンドウ・クラス名。 | はい |  | デフォルト: #32770;Dialog;ThunderRT5FormDC; ThunderRT6FormDC | 文字列 | 文字列
End-User Experience\Response\Windows Apps | Supported Window Classes for Services | Extensions\AccessManager:ServiceClasses: サービスとして認識されるデフォルトのウィンドウ・クラス名。 | はい |  | デフォルト: #32770;Dialog;ThunderRT5FormDC; ThunderRT6FormDC | 文字列 | 文字列
End-User Experience\Response\Windows Apps | Wait for a Window Title | Extensions\AccessManager:EmptyTitleRetryCount: 表示が遅いダイアログ/アプリケーションに対し、この値は、ウィンドウ・タイトルが表示されるまでエージェントが待機する時間（1/2秒単位）です。ウィンドウ・タイトルがこの間隔で表示されない場合には、ダイアログは無視されます。値を大きくすると、使用するCPUサイクルが増加します。 | はい |  | デフォルト: 6 | dword | 整数
End-User Experience\Response\Windows Apps\Error Loop | Maximum retries before prompting | Extensions\AccessManager\Dlg:AppsMaxRetry: アプリケーションの再試行を制御します。デフォルト値は1です。 | はい |  | デフォルト: 1 | dword | 整数
End-User Experience\Response\Windows Apps\Error Loop | Maximum time for retries before prompting | Extensions\AccessManager\Dlg:AppsTimeout: アプリケーションのタイムアウトを制御します。デフォルトは30秒です。 | はい |  | デフォルト: 30 | dword | 整数
End-User Experience\Response\Windows Apps\Error Loop | Require password confirmation when modifying password | Extensions\AccessManager\Dlg:AppsHideConfirmPW: Windowsログオンの「Logon Error」ダイアログに「Confirm Password」フィールドを表示するかどうかを指定します。デフォルトでは、パスワード確認が「Require」となります。 | はい | 0 必要 1 不要 | デフォルト: 0 | dword |
End-User Experience\Setup Wizard | Enable/disable First-Time-Use (FTU) wizard. | Extensions\SetUpManager:HideWizard: はじめて使用する場合の呼出し時に「Setup Wizard」を表示するかどうかを制御します。注意: 複数の認証方式（プライマリ・ログオン方法）をインストールした場合は、リストに最初に記載された認証方式が、自動的にエンド・ユーザーのプライマリ・ログオン方法として選択されます。 | はい | 0 非表示にしません 1 非表示にします | デフォルト: 0 | dword |
End-User Experience\Setup Wizard | Selected Primary Logon | AUI:Selected: プライマリ・ログオン方法として選択したログオン方法を有効にし、それ以外のインストール済のログオン方法を非表示にします。デフォルトは選択なしです（エンド・ユーザーが各自のプライマリ・ログオン方法を選択します）。注意: プライマリ・ログオン方法の選択メニューを非表示にするには、「Enable/Disable First-Time-Use (FTU) Wizard」設定を使用します。プライマリ・ログオン方法の選択ページが非表示で、この設定が空白である場合は、リストに最初にインストールされたログオン方法が自動的に選択されます。 | はい | なし MSauth Windows v2 WinAuth Windows LDAP LDAP LDAPauth LDAP v2 MultiAuth Authentication Manager | デフォルト: なし | 文字列 |
End-User Experience\Setup Wizard | Skip "selection" page if only one Primary Logon Method installed | AUI:HideSingleSelection: 1つのプライマリ・ログオン方法のみインストールした場合は、「Setup Wizard」で「Select Primary Logon Method」手順を非表示にします。 | はい | 0 設定ウィザードの選択手順を非表示およびスキップしません。 1 設定ウィザードの選択手順を非表示/スキップします。 | デフォルト: 0 | dword |
Event Logging | Select events to log: | Extensions\EventManager:Filter: ログに記録するイベントを区切るイベント・ロギング・フィルタ。 | はい | 4 資格証明編集 8 資格証明削除 10 資格証明コピー 20 資格証明追加 100 プロビジョニング 200 起動/停止 400 ヘルプ 800 設定変更 1000 再認証 20000 ログオン・フィールド: システム・ユーザー名 40000 ログオン・フィールド: システム・ドメイン 80000 ログオン・フィールド: 3番目のフィールド 100000 ログオン・フィールド: ユーザー名 200000 ログオン・フィールド: 4番目のフィールド 800000 アプリケーション・パスワード変更 1000000 プライマリ・ログオン方法変更 4000000 バックアップ/リストア 40000000 イベント・タイプ: 情報 | デフォルト: 0 | dword |
Event Logging\Advanced | Cache Limit | Extensions\EventManager:CacheLimit: 古いイベントが廃棄されるまでにキャッシュされるイベント・ログ・エントリの最大数。 | はい |  | デフォルト: 200 | dword | 整数
Event Logging\Advanced | Cache Retry Interval | Extensions\EventManager:Retry: すべてのイベント・ロギング拡張の再試行間の間隔（分）。 | はい |  | デフォルト: 30 | dword | 整数
Event Logging\Advanced | Event Server Message Library location | Extensions\EventManager:EventMessagePath: Windows Event Viewerでイベントの表示に使用されるイベント・メッセージ・ライブラリへのパス/ファイル名。 | いいえ |  | デフォルト: C:\Program Files\Passlogix\v-GO SSO\Plugin\EventMgr\SSOeventmessage.dll | 文字列 | ファイル名
Event Logging\Advanced | Extension location | Extensions\EventManager:Path: イベント・ロギング拡張（eventmgr.dll）へのパス/ファイル名。 | いいえ |  | デフォルト: C:\Program Files\Passlogix\v-GO SSO\Plugin\EventMgr\eventmgr.dll | 文字列 | ファイル名
Event Logging\Windows Event Viewer | Windows Event Logging Server | Extensions\EventManager\WindowsEvent:EventServer: Windowsイベント・ロギング拡張のサーバー名（先頭に\\文字を使用しないでください）。ない場合は、ローカル・コンピュータにログインします。サーバーは、アクセス権および制限に応じて、ユーザーのアカウントおよびユーザーのコンピュータとの信頼関係を持つ必要があります。 | いいえ |  | デフォルト: なし | 文字列 | 文字列
Event Logging\Windows Event Viewer\Advanced | Cache Retry Interval | Extensions\EventManager\WindowsEvent:Retry: Windowsイベント・ロギング拡張に対する再試行間の間隔（分）を指定します。 | はい |  | デフォルト: 30 | dword | 整数
Event Logging\Windows Event Viewer\Advanced | Extension location | Extensions\EventManager\Logs:WindowsEvent: Windowsイベント・ロギング拡張WindowsEvent.dllへのパス/ファイル名。 | いいえ |  | デフォルト: C:\Program Files\Passlogix\v-GO SSO\Plugin\EventMgr\WindowsEvent.dll | 文字列 | ファイル名
Event Logging\Windows Event Viewer\Advanced | Of logged events, limit for Windows server to: | Extensions\EventManager\WindowsEvent:Filter: （rootフィルタ設定によって記録されたイベントのうち）Windowsイベント・ロギング拡張に記録するイベントを区切るイベント・ロギング・フィルタ。 | はい | 4 資格証明編集 8 資格証明削除 10 資格証明コピー 20 資格証明追加 100 プロビジョニング 200 起動/停止 400 ヘルプ 800 設定変更 1000 再認証 20000 ログオン・フィールド: システム・ユーザー名 40000 ログオン・フィールド: システム・ドメイン 80000 ログオン・フィールド: 3番目のフィールド 100000 ログオン・フィールド: ユーザー名 200000 ログオン・フィールド: 4番目のフィールド 800000 アプリケーション・パスワード変更 1000000 プライマリ・ログオン方法変更 4000000 バックアップ/リストア 40000000 イベント・タイプ: 情報 | デフォルト: 0 | dword |
Event Logging\XML File | Cache Retry Interval | Extensions\EventManager\LocalStorage:Retry: ローカル（XML）ファイルのロギング拡張に対する再試行間隔（分）。 | はい |  | デフォルト: 30 | dword | 整数
Event Logging\XML File | Extension location | Extensions\EventManager\Logs:LocalStorage: ローカル（XML）ファイル・ロギング拡張XMLEvent.dllへのパス/ファイル名。 | いいえ |  | デフォルト: C:\Program Files\Passlogix\v-GO SSO\Plugin\EventMgr\XMLEvent.dll | 文字列 | ファイル名
Event Logging\XML File | Of logged events, limit for XML file to: | Extensions\EventManager\LocalStorage:Filter: （rootフィルタ設定によって記録されたイベントのうち）ローカル（XML）ファイル・ロギング拡張に記録するイベントを区切るイベント・ロギング・フィルタ。 | はい | 4 資格証明編集 8 資格証明削除 10 資格証明コピー 20 資格証明追加 100 プロビジョニング 200 起動/停止 400 ヘルプ 800 設定変更 1000 再認証 20000 ログオン・フィールド: システム・ユーザー名 40000 ログオン・フィールド: システム・ドメイン 80000 ログオン・フィールド: 3番目のフィールド 100000 ログオン・フィールド: ユーザー名 200000 ログオン・フィールド: 4番目のフィールド 800000 アプリケーション・パスワード変更 1000000 プライマリ・ログオン方法変更 4000000 バックアップ/リストア 40000000 イベント・タイプ: 情報 | デフォルト: 0 | dword |
Primary Logon Methods\Authentication Manager | Allowed number of logon methods | AUI\MultiAuth:MaxPreferred: この設定では、ユーザーに表示されるログオン方法の最大数を設定できます。このログオン方式の数がユーザーに表示（およびスキップ）された後、「Choose Logon」ダイアログ・ボックスが表示されます。デフォルトは1です。この設定は、マルチ認証方式プライマリ・ログオンにのみ使用されます。注意: この設定は、ESSO-AMにのみ適用されます。 | はい |  | デフォルト: 1 | dword | 整数
Primary Logon Methods\LDAP v2\Advanced | Alternate User ID location | AUI\LDAPauth:UserLocation: ユーザー名以外の属性でユーザーを検証するときに、該当するユーザー・オブジェクトが存在する場所を示します。例: ログオンの従業員ID番号でユーザーの認証を行い（empid属性に対する検証）、ユーザー・オブジェクトがou=people,dc=computerにある場合は、UserLocationをuid=user,ou=people,dc=computerではなくempid=%user,ou=people,dc=computerに設定します。注意: Novell eDirectoryの場合、UserLocationはuid=%user,オブジェクトへのパスである必要があります。注意: UserLocationを使用する場合は、UserPrependおよびUserPathsを使用しないでください。 | はい |  | デフォルト: なし | 文字列 | 文字列
Primary Logon Methods\LDAP v2\Advanced | Authenticator Grade | AUI\LDAPauth:AuthGrade: このプライマリ・ログオン方法に認証グレードを割り当てます。この値は、マルチレベル認証に使用されます。注意: この設定は、ESSO-AMにのみ適用されます。 | はい |  | デフォルト: 1 | dword | 整数
Primary Logon Methods\LDAP v2\Advanced | BIND Timeout | AUI\LDAPauth:Timeout: LDAP BINDコールのタイムアウト（ミリ秒）。 | はい |  | デフォルト: オペレーティング・システムによって異なります。 | dword | 整数
Primary Logon Methods\LDAP v2\Advanced | Include in "LDAP" credential sharing group | AUI\LDAPauth:PWSEnable: プライマリ・ログオン方法からグループ・ドメイン内の資格証明への資格証明共有を有効にします。（また、AccessManager:PWSEnableを有効にする必要があります。） | はい | 0 無効 1 有効 | デフォルト: 1 | dword |
Primary Logon Methods\LDAP v2\Advanced | Naming Attribute string | AUI\LDAPauth:UserPrepend: ユーザーのDNの形式がnamingattribute=%UserName%,ou=people,dc=computer（namingattributeは任意の文字列）ではなく、cn=%UserName%,ou=people,dc=computerである場合、UserPathsの前に付加する文字列。注意: Novell eDirectoryの場合は、この値を通常cnに設定する必要があります。注意: UserPrependを使用する場合は、UserPathNを使用し、UserPrependは使用しないでください。 | はい |  | デフォルト: なし | 文字列 | 文字列
Primary Logon Methods\LDAP v2\Advanced | Passphrase | AUI\LDAPauth:ResetEnable: リセット・パスフレーズの使用を許可します。 | はい | 0 無効 1 有効 | デフォルト: 1 | dword |
Primary Logon Methods\LDAP v2\Advanced | When SSL fails | AUI\LDAPauth:SSLFallback: SSL接続に失敗したときのセキュアでない接続にフォールバックするかどうか。注意: 1に設定し、サーバーのいずれかにポート指定が含まれている場合は、フォールバック・ポートを「Servers」の追加のエントリとして指定する必要があります。たとえば、SSL接続に対してmycomputer.com:1272が指定されている場合は、追加のエントリが、mycomputer.com:1272 ;My secure SSL Port mycomputer.com:389 ;My fallback portというように、フォールバック・ポートを指す必要があります。 | はい | 0 SSL接続が失敗した場合は、接続しません 1 SSL接続が失敗した場合は、SSLなしで接続します（セキュアではありません） | デフォルト: 0 | dword |
Primary Logon Methods\LDAP v2\Required | Servers | AUI\LDAPauth\Servers:ServerN: computer[:port]形式で試行するサーバー（1行に1台のサーバー）。computerには、サーバー名またはIPを指定します。portを省略した場合は、デフォルト（SSLは636、SSL以外は389）が使用されます。たとえば、127.0.0.1 127.0.0.1:456 somewhereelse.com:8080 anotherplace.comなどです。注意: この拡張が機能するには、少なくとも1台のサーバーを指定する必要があります。注意: ポート値を指定する場合は、SyncManager\Syncs\%LDAP%:SSLFallbackを参照してください。 | いいえ |  | デフォルト: なし | 文字列 |
Primary Logon Methods\LDAP v2\Required | SSL | AUI\LDAPauth:UseSSL: SSLで接続します。 | はい | 0 SSLなしで接続します（セキュアではありません）（デフォルトのポート番号389） 1 SSLで接続します（デフォルトのポート番号636） | デフォルト: 1 | dword |
Primary Logon Methods\LDAP v2\Required | User Paths | AUI\LDAPauth:UserPathN: ユーザー・アカウントの場所を示す完全修飾されたパス。検索するパスの数に制限はありません。この拡張機能では、ユーザー・アカウントを検索して、そのパスを順に検索します。見つからない場合は、ディレクトリ・ツリーが検索されます。注意: この拡張が機能するには、「UserPrepend」の値または「UserPaths」の1つ以上の値を指定する必要があります。注意: UserPathsを使用する場合は、UserLocationを使用しないでください。 | はい |  | デフォルト: なし | 文字列 |
Primary Logon Methods\LDAP\Advanced | Active Directory: Domain name support enabled | AUI\LDAPauth:UsingAD: Active Directoryドメイン名サポートを有効にします。エンド・ユーザーは、プライマリ・ログオンでドメイン名（domainname\usernameなど）を指定できます。また、管理者はデフォルト・ドメイン名を指定して（「Active Directory: Set domain name」を参照）、エンド・ユーザーがユーザー名のみでログオンできるようにすることができます。ドメインを指定しない場合は、ローカル・ワークステーションのドメインが使用されます。 | はい | 0 ADドメイン名を使用しません 1 ADドメイン名を使用します | デフォルト: 0 | dword |
Primary Logon Methods\LDAP\Advanced | Active Directory: Set domain name | AUI\LDAP:ADDomain: ユーザー名/ID資格証明にドメインを指定していない場合に、プライマリ・ログオンに使用するActive Directoryドメイン名（domainname\usernameなど）。この設定は、「Active Directory: Domain name support enabled」を「Use AD domain names」に設定している場合にのみ使用されます。ドメイン名サポートが有効で、この設定が空白である（エンド・ユーザーがドメインを指定していない）場合は、ローカル・ワークステーションのドメインが使用されます。 | はい |  | デフォルト: なし | 文字列 | 文字列
Primary Logon Methods\LDAP\Advanced | Alternate User ID location | AUI\LDAP:UserLocation: ユーザー名以外の属性でユーザーを検証するときに、該当するユーザー・オブジェクトが存在する場所を示します。例: ログオンの従業員ID番号でユーザーの認証を行い（empid属性に対する検証）、ユーザー・オブジェクトがou=people,dc=computerにある場合は、UserLocationをuid=user,ou=people,dc=computerではなくempid=%user,ou=people,dc=computerに設定します。注意: Novell eDirectoryの場合、UserLocationはuid=%user,オブジェクトへのパスである必要があります。注意: UserLocationを使用する場合は、UserPrependおよびUserPathsを使用しないでください。 | はい |  | デフォルト: なし | 文字列 | 文字列
Primary Logon Methods\LDAP\Advanced | Authenticator Grade | AUI\LDAP:AuthGrade: このプライマリ・ログオン方法に認証グレードを割り当てます。この値は、マルチレベル認証に使用されます。注意: この設定は、ESSO-AMにのみ適用されます。 | はい |  | デフォルト: 1 | dword | 整数
Primary Logon Methods\LDAP\Advanced | BIND Timeout | AUI\LDAP:Timeout: LDAP BINDコールのタイムアウト（ミリ秒）。 | はい |  | デフォルト: オペレーティング・システムによって異なります。 | dword | 整数
Primary Logon Methods\LDAP\Advanced | Naming Attribute string | AUI\LDAP:UserPrepend: ユーザーのDNの形式がnamingattribute=%UserName%,ou=people,dc=computer（namingattributeは任意の文字列）ではなく、cn=%UserName%,ou=people,dc=computerである場合、UserPathsの前に付加する文字列。注意: Novell eDirectoryの場合は、この値を通常cnに設定する必要があります。注意: UserPrependを使用する場合は、UserPathNを使用し、UserPrependは使用しないでください。 | はい |  | デフォルト: なし | 文字列 | 文字列
Primary Logon Methods\LDAP\Advanced | SSL Fallback | AUI\LDAP:SSLFallback: SSL接続に失敗したときのセキュアでない接続へのフォールバック。注意: 1に設定し、サーバーのいずれかにポート指定が含まれている場合は、フォールバック・ポートを「Servers」の追加のエントリとして指定する必要があります。たとえば、SSL接続に対してmycomputer.com:1272が指定されている場合は、追加のエントリが、mycomputer.com:1272 ;My secure SSL Port mycomputer.com:389 ;My fallback portというように、フォールバック・ポートを指す必要があります。 | はい | 0 SSL接続が失敗した場合は、接続しません 1 SSL接続が失敗した場合は、SSLなしで接続します（セキュアではありません） | デフォルト: 0 | dword |
Primary Logon Methods\LDAP\Required | Servers | AUI\LDAP\Servers:ServerN: computer[:port]形式で試行するサーバー（1行に1台のサーバー）。computerには、サーバー名またはIPを指定します。portを省略した場合は、デフォルト（SSLは636、SSL以外は389）が使用されます。たとえば、127.0.0.1 127.0.0.1:456 somewhereelse.com:8080 anotherplace.comなどです。注意: この拡張が機能するには、少なくとも1台のサーバーを指定する必要があります。注意: ポート値を指定する場合は、SyncManager\Syncs\%LDAP%:SSLFallbackを参照してください。 | いいえ |  | デフォルト: なし | 文字列 |
Primary Logon Methods\LDAP\Required | SSL | AUI\LDAP:UseSSL: SSLで接続するかどうか。 | はい | 0 SSLなしで接続します（セキュアではありません）（デフォルトのポート番号389） 1 SSLで接続します（デフォルトのポート番号636） | デフォルト: 1 | dword |
Primary Logon Methods\LDAP\Required | User Paths | AUI\LDAP:UserPathN: ユーザー・アカウントの場所を示す完全修飾されたパス。検索するパスの数に制限はありません。この拡張機能では、ユーザー・アカウントを検索して、そのパスを順に検索します。見つからない場合は、ディレクトリ・ツリーが検索されます。注意: この拡張が機能するには、「UserPrepend」の値または「UserPaths」の1つ以上の値を指定する必要があります。注意: UserPathsを使用する場合は、UserLocationを使用しないでください。 | はい |  | デフォルト: なし | 文字列 |
Primary Logon Methods\Windows | When user's Windows password changes... | AUI\WinAuth:PWEnable: 新しいパスワードが使用されている場合に旧パスワードの入力を要求して、セキュリティを強化します。 | はい | 0 Windowsの旧パスワードを要求しません 1 Windowsの旧パスワードを要求します | デフォルト: 0 | dword |
Primary Logon Methods\Windows v2 | Include in "Domain" credential sharing group | AUI\MSauth:PWSEnable: : プライマリ・ログオン方法からグループ・ドメイン内の資格証明への資格証明共有を有効にします。（また、AccessManager:PWSEnableを有効にする必要があります。） | はい | 0 無効 1 有効 | デフォルト: 1 | dword |
Primary Logon Methods\Windows v2 | Reauthentication dialog | AUI\MSauth:AuthOptions: ユーザーが再認証を必要とする方法を決定します。 | はい | 0 ESSO-LMダイアログを使用します 1 GINAを使用します | デフォルト: 0 | dword |
Primary Logon Methods\Windows v2\Advanced | Authenticator Grade | AUI\MSauth:AuthGrade: このプライマリ・ログオン方法に認証グレードを割り当てます。この値は、マルチレベル認証に使用されます。注意: この設定は、ESSO-AMにのみ適用されます。 | はい |  | デフォルト: 1 | dword | 整数
Primary Logon Methods\Windows v2\Advanced | MultiAuth: Require set up for multi-authentication | AUI\MSauth:AuthState: プライマリ・ログオン方法としてMultiAuthが選択された場合、はじめて使用する場合に、ユーザーにこのログオン方法の設定を要求するかどうかを決定します。この設定は、複数の認証方式プライマリ・ログオンにのみ使用されます。 | はい | 0 複数の認証方式の使用についてこのログオン方法を無効にします 1 ユーザーにはこのログオン方法を設定するオプションがあります 2 ユーザーはこのログオン方法の設定を要求されます | デフォルト: 1 | dword |
Primary Logon Methods\Windows v2\Advanced | Passphrase | AUI\MSauth:ResetEnable: リセット・パスフレーズの使用を許可します。 | はい | 0 無効 1 有効 | デフォルト: 1 | dword |
Primary Logon Methods\Windows\Advanced | Authenticator Grade | AUI\WinAuth:AuthGrade: このプライマリ・ログオン方法に認証グレードを割り当てます。この値は、マルチレベル認証に使用されます。注意: この設定は、ESSO-AMにのみ適用されます。 | はい |  | デフォルト: 1 | dword | 整数
Security\Advanced | Allow Password Revealing | Extensions\AccessManager:AllowReveal: ユーザーがウィザードおよびプロパティ・ページでパスワードを表示できるかどうか。注意: この設定またはアプリケーション構成固有の設定で、表示を許可しないように設定した場合、パスワードは表示されません。 | はい | 0 許可しません 1 許可します | デフォルト: 1 | dword |
Security\Advanced | Default encryption | CSP:PreferredCS: 新しい資格証明/変更された資格証明の暗号化アルゴリズム/強度を選択します。注意: この設定をXP/2003のみでサポートされている値に設定した場合、他のOS上のエージェントは無効になります。 | はい | 0 Cobra 128ビット 512 Cobra 128ビット（同様） 513 Blowfish 448ビット 1028 Triple-DES 168ビット 1285 AES 256ビット 25700 Triple-DES（MS CAPI）（すべてのOS） 25723 Triple-DES（MS CAPI）（XP/2003のみ） 25956 RC-4（MS CAPI）（すべてのOS） 25979 RC-4（MS CAPI）（XP/2003のみ） 26491 AES（MS CAPI）（XP/2003のみ） | デフォルト: 25700 | dword |
Security\Advanced | Require reauthentication to Reveal passwords | Extensions\AccessManager:ReauthOnReveal: ユーザーがLogon Managerおよびダイアログで「Reveal」または「Reveal All」を選択した場合に再認証を必要とするかどうか。 | はい | 0 再認証を必要としません 1 再認証を必要とします | デフォルト: 1 | dword |
Security\Common | Reauthentication timer | Extensions\AccessManager:AutoLogin: 再認証リクエストの間隔（ミリ秒）4,294,967,295（0xFFFFFFFF）に設定した場合は、期限切れになることはなく、強制認証の場合を除いて、ユーザーは再認証を受ける必要がありません。注意: クライアント側のインストールのデフォルト値は900,000（15分）、Terminal Services環境でのデフォルトは4,294,967,295（無効）になります。 | はい |  | デフォルト: 900000 | dword | 整数
Synchronization | Aggressive Synchronization | Extensions\SyncManager:AggressiveSync: 最新の資格証明または使用可能な設定を必要とするいずれかのアクション（アプリケーションが資格証明を要求するなど）をユーザーが実行するたびに、常にシステムに同期を実行させるアグレッシブ同期を許可するかどうかを決定します。注意: クライアントおよびサーバー・コンピュータの両方のパフォーマンスに大きな影響を与えます。 | はい | 0 許可しません 1 許可します | デフォルト: 0 | dword |
Synchronization | Delete local cache | Shell:CleanupOnShutdown: エージェントを停止したときに、ユーザーのデータ・ファイルおよびレジストリ・キーを削除するかどうか。 | はい | 0 削除しません 1 削除します | デフォルト: 0 | dword |
Synchronization | Deleted-credential cleanup | Shell:nDelDays: 資格証明が削除された後に、資格証明の「削除」フラグが保持されるまでの時間（日）。 | はい |  | デフォルト: 30 | dword | 整数
Synchronization | Disconnected Operation | Extensions\SyncManager:AllowDisconnected: ESSO-LMがシンクロナイザ拡張に接続できず、ローカル・キャッシュが存在していない場合は、はじめて使用する場合の設定を実行するかどうかを指定します。このチェックは、/backgroundパラメータで実行したとき（起動時など）に行われます。 | はい | 0 実行を続行しません 1 切断操作を許可します | デフォルト: 1 | dword |
Synchronization | Enable role/group security support | Extensions\SyncManager:RetrieveCO: アプリケーション・ログオン、パスワード・ポリシー、グローバル・エージェント設定およびパスフレーズ質問セットに対するロール/グループ・サポートを有効にします。 | はい | 0 ロール/グループ・セキュリティを使用しません。 1 ロール/グループ・セキュリティを使用します | デフォルト: 0 | dword |
Synchronization | Interval for automatic re-sync | Extensions\SyncManager:CycleInterval: 自動再同期の間隔（分）。ユーザー生成の同期イベントがあるかどうかにかかわらず発生します。値を0にすると、この設定は無効になります。 | はい |  | デフォルト: 0 | dword | 整数
Synchronization | Optimized Synchronization | Extensions\SyncManager:OptimizedSync: 最適化同期（すべての資格証明/設定を検索するのではなく、チェックサムを使用して変更された資格証明/設定を決定）を有効/無効にします。 | はい | 0 無効 1 有効 | デフォルト: 1 | dword |
Synchronization | Re-sync when network or connection status changes | Shell:MonitorNetwork: ネットワーク接続ステータスの変更監視を有効/無効にします。有効にすると、エージェントはステータス変更が発生したとき（ネットワークへの再接続など）に再同期を実行します。 | はい | 0 ネットワーク・ステータスの変更を無視します 1 ネットワーク・ステータスの変更を監視し、再同期を実行します | デフォルト: 1 | dword |
Synchronization | Sync Order | Extensions\SyncManager:SyncOrder: 同期拡張と同期化する順序（タイプではなく拡張名による）。例: SalesADAM,CorporateLDAP,CorporateAD FileSync Remote,AD,FileSync Local,SomethingElse CorpDir,CorpADAM,ADRemote。注意: 値を指定しない場合、すべての拡張が（予測できない順序で）使用されます。 | はい |  | デフォルト: なし | 文字列 | シンクロナイザ
Synchronization | Wait for synchronization at startup | Extensions\SyncManager:WaitForStartupSync: 起動時に同期を待機するかどうかを指定します。待機した場合、ユーザーのデータが必ず最新の状態になります。注意: クライアント・コンピュータのパフォーマンスにわずかに影響を与えます。 | はい | 1 同期を待機します 0 同期を待機しません | デフォルト: 1 | dword |
Synchronization\%AD%\Advanced | Configuration Objects Base Locations | Extensions\SyncManager\Syncs\%AD%\COBaseLocations:LocationN: 構成オブジェクトの検索を開始する場所。指定した場所から下方向に検索が行われます。エントリがない場合、検索はベースの場所から開始されます。 | いいえ |  | デフォルト: なし | 文字列 |
Synchronization\%AD%\Advanced | Credentials to use | Extensions\SyncManager\Syncs\%AD%:AuthType: Active Directoryサーバーに対する認証時に使用する資格証明。 | はい | 0 ローカル・コンピュータの資格証明のみを使用します 1 Active Directoryサーバーのアカウントのみを使用します（UserPathNの設定をお薦めします） 2 ローカル・コンピュータの資格証明を試し、失敗した場合は、Active Directoryサーバーのアカウントを使用します | デフォルト: 2 | dword |
Synchronization\%AD%\Advanced | Descriptive name | Extensions\SyncManager\Syncs\%AD%:DisplayName: ログオン・ダイアログのタイトルです。同じ名前を持つ複数のシンクロナイザ拡張を区別するために用意されています。注意: このエントリは必須ではありません。 | はい |  | デフォルト: なし | 文字列 | 文字列
Synchronization\%AD%\Advanced | Location for storing user credentials | Extensions\SyncManager\Syncs\%AD%:LocateInUser: ユーザー資格証明コンテナを各自のディレクトリ・ユーザー・オブジェクトの下に保存するため、ロケータ・オブジェクトを使用しません。無効である場合（デフォルト）、ロケータ・オブジェクトに指定したとおりに資格証明が保存されます。 | はい | 0 ロケータ・オブジェクトに指定したとおりにユーザー資格証明を保存します 1 ユーザー資格証明を各ディレクトリ・ユーザー・オブジェクトに保存します | デフォルト: 0 | dword |
Synchronization\%AD%\Advanced | Logon attempts | Extensions\SyncManager\Syncs\%AD%:RetryLockCount: 再試行ダイアログをユーザーに示す回数。 | はい |  | デフォルト: 3 | dword | 整数
Synchronization\%AD%\Advanced | Prepend Domain when naming objects | Extensions\SyncManager\Syncs\%AD%:AppendDomain: ユーザーのコンテナに名前を付ける際にユーザー名にユーザーのドメインを追加することを有効にします。たとえば、ドメインpasslogixおよびユーザーjameskの場合、コンテナは、このフラグを無効にするとjameskと名付けられ、このフラグを有効にするとpasslogix.jameskと名付けられます。注意: 「Prepend Domain」を有効にした場合は、（「Directory」メニューの）「Enable Storing Credentials under User Object」を有効にしないでください。ユーザー・オブジェクトへの資格証明の格納を有効にする場合は、このオプションを無効にする必要があります（デフォルト）。両方のオプションを有効にすると、同期が行われなくなります。 | はい | 0 無効 1 有効 | デフォルト: 0 | dword |
Synchronization\%AD%\Advanced | Prompt when disconnected | Extensions\SyncManager\Syncs\%AD%:AllowOffline: 同期イベントが失敗した場合、ユーザーは確認/通知なしでオフラインで作業できます。 | はい | 0 ユーザーに確認/通知します。 1 確認しません | デフォルト: 0 | dword |
Synchronization\%AD%\Advanced | Search for locator and override objects | Extensions\SyncManager\Syncs\%AD%:StopAtRoot: エージェントがロケータおよび優先オブジェクトを検索する方法を制御します。 | はい | 0 すべてのサーバーのロケータ/優先オブジェクトを検索します。 1 サーバー・ルートへのロケータ/優先オブジェクトの検索を制限します。 | デフォルト: 1 | 文字列 |
Synchronization\%AD%\Advanced | Servers | Extensions\SyncManager\Syncs\%AD%\Servers:ServerN: computer[:port]形式で試行するサーバー（1行に1台のサーバー）。computerには、サーバー名を指定します。portを省略した場合は、デフォルト（SSLは636、SSL以外は389）が使用されます。例: somewhereclose.com also.somewhereclose.com somewhereelse.com:8080 anotherplace.comなどです。注意: この拡張が機能するには、少なくとも1台のサーバーを指定する必要があります。注意: Active Directoryではコンピュータ名（IPアドレスではなく）を使用する必要があります。注意: ポート値を指定する場合は、SyncManager\Syncs\%LDAP%:SSLFallbackを参照してください。 | いいえ |  | デフォルト: なし | 文字列 |
Synchronization\%AD%\Advanced | User Paths | Extensions\SyncManager\Syncs\%AD%:UserPathN: ユーザー・アカウントの場所を示す完全修飾されたパス。検索するパスの数に制限はありません。この拡張機能では、ユーザー・アカウントを検索して、そのパスを順に検索します。見つからない場合は、ディレクトリ・ツリーが検索されます。注意: この拡張では、このエントリは必須ではありません。 | はい |  | デフォルト: なし | 文字列 |
Synchronization\%AD%\Advanced | When SSL fails | Extensions\SyncManager\Syncs\%AD%:SSLFallback: SSL接続に失敗したときのセキュアでない接続へのフォールバック。注意: SSLFallback=1で、サーバーのいずれかにポート指定が含まれている場合は、フォールバック・ポートを「Servers」の追加のエントリとして指定する必要があります。たとえば、SSL接続に対してmycomputer.com:1272が指定されている場合は、追加のエントリが、mycomputer.com:1272 ;My secure SSL Port mycomputer.com:389 ;My fallback portというように、フォールバック・ポートを指す必要があります。 | はい | 0 SSL接続が失敗した場合は、接続しません。 1 SSL接続が失敗した場合は、SSLなしで接続します（セキュアではありません）。 | デフォルト: なし | dword |
Synchronization\%AD%\Required | Extension location | Extensions\SyncManager\Syncs\%AD%:Path: Active Directoryシンクロナイザ拡張のパス\ファイル名。 | いいえ |  | デフォルト: C:\Program Files\Passlogix\v-GO SSO\Plugin\SyncMgr\ADEXT\adsync.dll | 文字列 | ファイル名
Synchronization\%AD%\Required | SSL | Extensions\SyncManager\Syncs\%AD%:UseSSL: SSLでの接続。 | はい | 0 SSLなしで接続します（セキュアではありません）（デフォルトのポート番号389）。 1 SSLで接続します（デフォルトのポート番号636）。 | デフォルト: 1 | dword |
Synchronization\%ADAM%\Advanced | Configuration Objects Base Locations | Extensions\SyncManager\Syncs\%ADAM%\COBaseLocations:LocationN: 構成オブジェクトの検索を開始する場所。指定した場所から下方向に検索が行われます。エントリがない場合、検索はベースの場所から開始されます。 | いいえ |  | デフォルト: なし | 文字列 |
Synchronization\%ADAM%\Advanced | Credentials to use | Extensions\SyncManager\Syncs\%AD%:AuthType: ADAMサーバーに対する認証時に使用する資格証明。 | はい | 0 現在のユーザー名でADAMに接続します 1 ADAMサーバーのアカウントのみを使用します 2 ローカル・コンピュータの資格証明を試し、失敗した場合は、ADAMサーバーのアカウントを使用します | デフォルト: 2 | dword |
Synchronization\%ADAM%\Advanced | Prepend Domain when naming objects | Extensions\SyncManager\Syncs\%ADAM%:AppendDomain: ユーザーのコンテナに名前を付ける際にユーザー名にユーザーのドメインを追加することを有効にします。たとえば、ドメインpasslogixおよびユーザーjameskの場合、コンテナは、このフラグを無効にするとjameskと名付けられ、このフラグを有効にするとpasslogix.jameskと名付けられます。 | はい | 0 無効 1 有効 | デフォルト: 0 | dword |
Synchronization\%ADAM%\Advanced | Prompt when disconnected | Extensions\SyncManager\Syncs\%ADAM%:AllowOffline: 同期イベントが失敗した場合、ユーザーは確認/通知なしでオフラインで作業できます。 | はい | 0 ユーザーに確認/通知します。 1 確認しません | デフォルト: 0 | dword |
Synchronization\%ADAM%\Advanced | User domain name to use | Extensions\SyncManager\Syncs\%ADAM%:UserDomain: 「Prepend Domain」を有効にしたときに、コンテナ名で使用するドメイン名（DomainName.UserNameなど）。ユーザーは、ログイン・ダイアログで別のドメインを指定できます。例: ユーザー・ドメインが「MyDomain」であり（「Prepend Domain」を有効にしています）、ユーザーがjameskとしてログオンした場合は、コンテナ名としてMyDomain.jameskが使用されます。ユーザーがHISDOMAIN\jameskとしてログオンした場合は、コンテナ名としてHISDOMAIN.jameskが使用されます。 | はい |  | デフォルト: なし | 文字列 | 文字列
Synchronization\%ADAM%\Required | Extension location | Extensions\SyncManager\Syncs\%ADAM%:Path: Active Directoryシンクロナイザ拡張のパス\ファイル名。 | いいえ |  | デフォルト: C:\Program Files\Passlogix\v-GO SSO\Plugin\SyncMgr\ADAMext\ADAMsyncExt.dll | 文字列 | ファイル名
Synchronization\%ADAM%\Required | Servers | Extensions\SyncManager\Syncs\%ADAM%\Servers:ServerN: computer[:port]形式で試行するサーバー（1行に1台のサーバー）。computerには、サーバー名を指定します。portを省略した場合は、デフォルト（SSLは636、SSL以外は389）が使用されます。例: somewhereclose.com also.somewhereclose.com somewhereelse.com:8080 anotherplace.comなどです。注意: この拡張が機能するには、少なくとも1台のサーバーを指定する必要があります。注意: Active Directoryではコンピュータ名（IPアドレスではなく）を使用する必要があります。注意: ポート値を指定する場合は、SyncManager\Syncs\%LDAP%:SSLFallbackを参照してください。 | いいえ |  | デフォルト: なし | 文字列 |
Synchronization\%DB%\Advanced | Append Domain when naming objects | Extensions\SyncManager\Syncs\%DB%:AppendDomain: ユーザーのコンテナに名前を付ける際にユーザー名にユーザーのドメインを追加することを有効にします。たとえば、ドメインpasslogixおよびユーザーjameskの場合、コンテナは、このフラグを無効にするとjameskと名付けられ、このフラグを有効にするとjamesk.passlogixと名付けられます。 | はい | 0 無効 1 有効 | デフォルト: 0 | dword |
Synchronization\%DB%\Required | Extension location | Extensions\SyncManager\Syncs\%DB%:Path: データベース・シンクロナイザ拡張のパス\ファイル名。 | いいえ |  | デフォルト: C:\Program Files\Passlogix\v-GO SSO\Plugin\SyncMgr\DBEXT\DBExt.dll | 文字列 | ファイル名
Synchronization\%DB%\Required | Servers | Extensions\SyncManager\Syncs\%DB%\Servers:Server: 接続文字列形式で試行するサーバーのサーバー・リスト（1行に1台のサーバー）。注意: この拡張が機能するには、少なくとも1台のサーバーを指定する必要があります。 | いいえ |  | デフォルト: なし | 文字列 |
Synchronization\%File%\Advanced | Descriptive name | Extensions\SyncManager\Syncs\%File%:DisplayName: ログオン・ダイアログのタイトルです。同じ名前を持つ複数のシンクロナイザ拡張を区別するために用意されています。注意: このエントリは必須ではありません。 | はい |  | デフォルト: なし | 文字列 | 文字列
Synchronization\%File%\Advanced | Logon attempts | Extensions\SyncManager\Syncs\%File%:RetryLockCount: 再試行ダイアログをユーザーに示す回数。 | はい |  | デフォルト: 3 | dword | 整数
Synchronization\%File%\Advanced | Prepend Domain when naming user folders | Extensions\SyncManager\Syncs\%File%:AppendDomain: ユーザーのコンテナに名前を付ける際にユーザー名にユーザーのドメインを追加することを有効にします。たとえば、ドメインpasslogixおよびユーザーjameskの場合、コンテナは、このフラグを無効にするとjameskと名付けられ、このフラグを有効にするとpasslogix.jameskと名付けられます。 | はい | 0 無効 1 有効 | デフォルト: 1 | dword |
Synchronization\%File%\Advanced | Prompt when disconnected | Extensions\SyncManager\Syncs\%File%:AllowOffline: 同期イベントが失敗した場合、ユーザーは確認/通知なしでオフラインで作業できます。 | はい | 0 ユーザーに確認/通知します。 1 確認しません | デフォルト: 0 | dword |
Synchronization\%File%\Required | Extension location | Extensions\SyncManager\Syncs\%File%:Path: ファイル・システム・シンクロナイザ拡張のパス\ファイル名。 | いいえ |  | デフォルト: C:\Program Files\Passlogix\v-GO SSO\Plugin\SyncMgr\FileSyncExt\filesync.dll | 文字列 | ファイル名
Synchronization\%File%\Required | Server | Extensions\SyncManager\Syncs\%File%\Servers:Server1: 試行するUNCパス。例: \\FS1\Users \\FS2\Extras D:\Backup。注意: この拡張が機能するには、Server1を指定する必要があります。注意: ファイル・システム拡張では、適切なUNCパスを使用する必要があります。注意: ESSO-LM 4.0では、1つのパスのみをサポートしています。フェイルオーバーはサポートされていません。 | いいえ |  | デフォルト: なし | 文字列 | 文字列
Synchronization\%LDAP%\Advanced | Admin Group DN | Extensions\SyncManager\Syncs\%LDAP%:AdminGroup: 管理グループのDN。この値はACI内にあります。例: cn=configuration administrators,ou=groups,ou=topologymanagement,o=netscaperoot | はい |  | デフォルト: なし | 文字列 | 文字列
Synchronization\%LDAP%\Advanced | Alternate User ID location | Extensions\SyncManager\Syncs\%LDAP%:UserLocation: ユーザー名以外の属性でユーザーを検証するときに、該当するユーザー・オブジェクトが存在する場所を示すために使用します。例: ログオンの従業員ID番号でユーザーの認証を行い（empid属性に対する検証）、ユーザー・オブジェクトがou=people,dc=computerにある場合は、UserLocationをuid=user,ou=people,dc=computerではなくempid=%user,ou=people,dc=computerに設定します。注意: Novell eDirectoryの場合、UserLocationはuid=%user,オブジェクトへのパスである必要があります。注意: UserLocationを使用する場合は、UserPrependおよびUserPathsを使用しないでください。 | はい |  | デフォルト: なし | 文字列 | 文字列
Synchronization\%LDAP%\Advanced | BIND Timeout | Extensions\SyncManager\Syncs\%LDAP%:Timeout: LDAP BINDコールのタイムアウト（ミリ秒）。 | はい |  | デフォルト: オペレーティング・システムによって異なります。 | dword | 整数
Synchronization\%LDAP%\Advanced | Configuration Objects Base Locations | Extensions\SyncManager\Syncs\%LDAP%\COBaseLocations:LocationN: 構成オブジェクトの検索を開始する場所。指定した場所から下方向に検索が行われます。エントリがない場合、検索はベースの場所から開始されます。 | いいえ |  | デフォルト: なし | 文字列 |
Synchronization\%LDAP%\Advanced | Descriptive name | Extensions\SyncManager\Syncs\%LDAP%:DisplayName: ログオン・ダイアログのタイトルです。同じ名前を持つ複数のシンクロナイザ拡張を区別するために用意されています。注意: このエントリは必須ではありません。 | はい |  | デフォルト: なし | 文字列 | 文字列
Synchronization\%LDAP%\Advanced | DSAME disabled-account support | Extensions\SyncManager\Syncs\%LDAP%:UsingDSAME: Sun Java System Identity Server（以前のiPlanet Directory Server Access Management Edition（DSAME））の無効アカウントを認識します。 | はい | 0 このサーバーは、Sun Java System Identity Serverではありません。 1 このサーバーは、Sun Java System Identity Serverです。 | デフォルト: 0 | dword |
Synchronization\%LDAP%\Advanced | Logon attempts | Extensions\SyncManager\Syncs\%LDAP%:RetryLockCount: 再試行ダイアログをユーザーに示す回数。 | はい |  | デフォルト: 3 | dword | 整数
Synchronization\%LDAP%\Advanced | Naming Attribute string | Extensions\SyncManager\Syncs\%LDAP%:UserPrepend: ユーザーのDNの形式がnamingattribute=%UserName%,ou=people,dc=computer（namingattributeは任意の文字列）ではなく、cn=%UserName%,ou=people,dc=computerである場合、UserPathsの前に付加する文字列。注意: Novell eDirectoryの場合は、この値を通常cnに設定する必要があります。注意: UserPrependを使用する場合は、UserPathNを使用し、UserPrependは使用しないでください。 | はい |  | デフォルト: なし | 文字列 | 文字列
Synchronization\%LDAP%\Advanced | Prompt when disconnected | Extensions\SyncManager\Syncs\%LDAP%:AllowOffline: 同期イベントが失敗した場合、ユーザーは確認/通知なしでオフラインで作業できます。 | はい | 0 ユーザーに確認/通知します。 1 確認しません | デフォルト: 0 | dword |
Synchronization\%LDAP%\Advanced | Security Version | Extensions\SyncManager\Syncs\%LDAP%:SecurityVersion: この値が:SecurityUpgradeより大きい場合は、新しい:AdminGroup値でACIを更新します。 | はい |  | デフォルト: なし | dword | 整数
Synchronization\%LDAP%\Advanced | When SSL fails | Extensions\SyncManager\Syncs\%LDAP%:SSLFallback: SSL接続に失敗したときのセキュアでない接続へのフォールバック。注意: SSLFallback=1で、サーバーのいずれかにポート指定が含まれている場合は、フォールバック・ポートを「Servers」の追加のエントリとして指定する必要があります。たとえば、SSL接続に対してmycomputer.com:1272が指定されている場合は、追加のエントリが、mycomputer.com:1272 ;My secure SSL Port mycomputer.com:389 ;My fallback portというように、フォールバック・ポートを指す必要があります。 | はい | 0 SSL接続が失敗した場合は、接続しません。 1 SSL接続が失敗した場合は、SSLなしで接続します（セキュアではありません）。 | デフォルト: なし | dword |
Synchronization\%LDAP%\Required | Directory Type | Extensions\SyncManager\Syncs\%LDAP%:DirectoryType: ディレクトリ・サーバーの特定のタイプ。ディレクトリ・サーバーが示されていない場合は、アップグレード時に下位互換性用の「Unspecified LDAP Directory」を選択します。それ以外の場合は、「Generic LDAP Directory」を選択します。 | はい | 0 未指定のLDAPディレクトリ 3 Novell eDirectory 4 Novell NDS 5 汎用LDAPディレクトリ 8 Sun Java System Directory 9 IBM Tivoli Directory Server 10 Oracle Internet Directory | デフォルト: 0 | dword |
Synchronization\%LDAP%\Required | Extension location | Extensions\SyncManager\Syncs\%LDAP%:Path: LDAPディレクトリ・サーバー・シンクロナイザ拡張のパス\ファイル名。 | いいえ |  | デフォルト: C:\Program Files\Passlogix\v-GO SSO\Plugin\SyncMgr\LDAP\ldapsync.dll | 文字列 | ファイル名
Synchronization\%LDAP%\Required | Servers | Extensions\SyncManager\Syncs\%LDAP%\Servers:ServerN: computer[:port]形式で試行するサーバーのリスト（1行に1台のサーバー）。computerには、サーバー名またはIPを指定します。portを省略した場合は、デフォルト（SSLは636、SSL以外は389）が使用されます。たとえば、127.0.0.1 127.0.0.1:456 somewhereelse.com:8080 anotherplace.comなどです。注意: この拡張が機能するには、少なくとも1台のサーバーを指定する必要があります。注意: ポート値を指定する場合は、SyncManager\Syncs\%LDAP%:SSLFallbackを参照してください。 | いいえ |  | デフォルト: なし | 文字列 |
Synchronization\%LDAP%\Required | SSL | Extensions\SyncManager\Syncs\%LDAP%:UseSSL: SSLでの接続。 | はい | 0 SSLなしで接続します（セキュアではありません）（デフォルトのポート番号389）。 1 SSLで接続します（デフォルトのポート番号636）。 | デフォルト: 1 | dword |
Synchronization\%LDAP%\Required | User Paths | Extensions\SyncManager\Syncs\%LDAP%:UserPathN: ユーザー・アカウントの場所を示す完全修飾されたパス。検索するパスの数に制限はありません。この拡張機能では、ユーザー・アカウントを検索して、そのパスを順に検索します。見つからない場合は、ディレクトリ・ツリーが検索されます。注意: この拡張が機能するには、「UserPrepend」の値または「UserPaths」の1つ以上の値を指定する必要があります。注意: UserPathsを使用する場合は、UserLocationを使用しないでください。 | はい |  | デフォルト: なし | 文字列 |
Event Logging \Syslog | Send messages to which host? | Extensions\EventManager\Syslog:RemoteAddress: メッセージの送信先のホスト名を入力します。ホスト名またはドット付きのIP v4アドレスを使用できます。0.0.0.0を使用すると、syslogデーモンへの送信が無効になります。255.255.255.255を使用すると、ブロードキャスト・メッセージを受信するように設定されているすべてのデーモンに送信されます。ブロードキャストはルーターを越えることはできないため、送信先はローカル・ネットワーク上である必要があります。 | いいえ |  | デフォルト: なし | 文字列 |
Extensions\EventManager\Database | Default Server | Extensions\EventManager\Database:Default Server: 他のサーバーが指定されていない場合は、データベース・ログが書き込まれるサーバー。（OLE DB接続文字列） | いいえ |  | デフォルト: Server1 | 文字列 |
Extensions\EventManager\Database | Servers | Extensions\EventManager\Database\Servers:ServerN: データベース・サーバーのリスト。1行に1つずつで、OLE DBの書式（Provider=sqloledb; Data Source=myServerName; Initial Catalog=myDatabaseName; User Id=myUsername; Password=myPassword）が使用されます。 | いいえ |  | デフォルト: なし | 文字列 |
Extensions\EventManager\Logs | Extension location | Extensions\EventManager\Logs:Database: データベース拡張（DatabaseExt.dll）へのパス。 | いいえ |  | デフォルト: C:\Program Files\Passlogix\v-GO SSO\Plugin\EventMgr\DatabaseExt.dll | 文字列 |
Extensions\EventManager\Logs | Extension location | Extensions\EventManager\Logs:Syslog: Syslog拡張（SyslogExt.dll）へのSyslogパス。 | いいえ |  | デフォルト: C:\Program Files\Passlogix\v-GO SSO\Plugin\EventMgr\SyslogExt.dll | 文字列 |
WebViewer\EventManager\Logs | Extension location | WebViewer\EventManager\Logs:Syslog: Web ViewerのSyslog拡張（Syslog.dll）へのパス/ファイル名。 | いいえ |  | デフォルト: C:\Program Files\Passlogix\SSOWebViewer\bin\Syslog.dll | 文字列 |
WebViewer\EventManager\Logs | Extension location | WebViewer\EventManager\Logs:WindowsEvent: Web ViewerのWindowsイベント・ロギング拡張（WindowsEvent.dll）へのパス/ファイル名。 | いいえ |  | デフォルト: C:\Program Files\Passlogix\SSOWebViewer\bin\WindowsEvent.dll | 文字列 |
WebViewer\EventManager\Logs | Extension location | WebViewer\EventManager\Logs:LocalStorage: Web Viewerのローカル（XML）・ファイル・ロギング拡張（XMLEvent.dll）へのパス/ファイル名。 | いいえ |  | デフォルト: C:\Program Files\Passlogix\SSOWebViewer\bin\XMLEvent.dll | 文字列 |


トラブルシューティング

インストール

認証方式

シンクロナイザ拡張

アンインストール

エージェントのパフォーマンス

アプリケーション・レスポンス

認証

初期認証

再認証

アプリケーション構成

すべてのアプリケーション

Windowsアプリケーション

Webアプリケーション

ホスト・アプリケーション

イベント・ロギング

Windowsイベント・ビューア

資格証明共有グループ

シンクロナイザ拡張

ディレクトリ拡張

ファイル・システム・サーバー

ローミング・プロファイル拡張


正規表現構文

次の演算子およびメタ文字を使用して、エージェントが特定のアプリケーション・ウィンドウを検出する場合に使用するテキスト文字列のパターンを指定できます。詳細は、「ウィンドウ・タイトルの追加/編集」を参照してください。

次の説明は、.NET正規表現リファレンスに準拠しています。正規表現の詳細な説明と構文については、Microsoft Developer Network Webサイト（www.msdn.microsoft.com）を参照してください。

グループ化
[ ] | 大カッコ内のいずれかの文字と一致する文字クラスを示します。例: [abc]は、a、bおよびcと一致します。
( ) | 文字グループ化演算子を示します。例: (\d+,)*\d+は、カンマで区切られた数字のリストと一致します（1や1,23,456など）。
{ } | 一致クラスを示します。
| | 2つの式を区切り、そのうちの1つが一致します（たとえば、T｜theはTheまたはtheと一致します）。
照合
. | 任意の1文字と一致します。
^ | 文字クラスの先頭に^がある場合、その文字クラスは否定されます。否定された文字クラスは、大カッコ内の文字以外の任意の文字と一致します。例: [^abc]は、a、bおよびc以外のすべての文字と一致します。 正規表現の先頭に^がある場合、入力の先頭と一致します（たとえば、^[abc]は、a、bまたはcで始まる入力のみと一致します）。
$ | 正規表現の末尾にある$は、入力の最後と一致します。例: [0-9]$は、入力の最後の数字と一致します。
- | 文字クラスで、 ハイフンは文字の範囲を示します。例: [0-9]は、0から9の任意の数字と一致します。
繰返し演算子
! | 後に続く式を否定します。
? | 前にある式がオプションであることを示します。1回一致するか、またはまったく一致しません。 例: [0-9][0-9]?は、2および12と一致します。
+ | 前にある式が1回以上一致することを示します。例: [0-9]+は、1、13、666などと一致します。
* | 前にある式が0回以上一致することを示します。
??, +?, *? | ?、+および*の最短マッチを行います。できるかぎり多く一致する最長マッチと異なり、これらの最短マッチではできるかぎり少なく一致します。例: 入力を<abc><def>とすると、<.*?>が<abc>と一致するのに対して、<.*>は<abc><def>と一致します。
エスケープおよび表記

\

次の文字がリテラルに解釈されることを強制するエスケープ文字。例: [0-9]+は1つ以上の数字と一致しますが、[0-9]\+は後にプラス文字の後にくる数字と一致します。

\の後に数字のnがある場合は、n番目の一致グループ（0から始まる）と一致します。例: <{.*?}>.*?</\0>は、<head>Contents</head>と一致します。

\は、次の表で説明する略称にも使用します。

表記 | 意味 | 一致
\a | 任意の英数字文字 | [a-z A-Z 0-9]
\b | 空白（ブランク） | [ \\t]
\c | 任意のアルファベット文字 | [a-z A-Z]
\d | 任意の10進数字 | [0-9]
\h | 任意の16進数字 | [0-9 a-f A-F]
\n | 新しい行 | \r|\r?\n
\q | 引用符付き文字列 | \"[^\"]*\"|\'[^\']*\'
\w | 単純な単語 | [a-z A-Z]+
\z | 整数 | [0-9]+


トラブルシューティング: インストール

インストール

認証方式

認証方式を選択しても、インストールされません。
  • デフォルトでは、インストーラはシステムで機能しない認証方式をインストールしません。 たとえば、Entrust Entelligenceクライアントがインストールされていない場合、Entrust PKI用の認証方式はインストールされません（Entrust EntelligenceはESSO-AMでのみ使用できます）。

シンクロナイザ拡張

Microsoft Active Directory拡張を選択しても、インストールされません。
  • デフォルトでは、インストーラはシステムで機能しないシンクロナイザ拡張をインストールしません。 たとえば、Microsoft Active Directoryクライアントがインストールされていない場合、Microsoft Active Directory Server用のシンクロナイザ拡張はインストールされません。

アンインストール

アンインストール後、ユーザー資格証明が残ります。

  • 標準のアンインストールでは、現在のユーザーの資格証明のみを削除できます。単純なバッチ・ファイルで、他の資格証明の削除を処理できます。たとえば、Windows 2000では、次のようになります。

    CD /D %UsersProfile%

    CD .

    (*.*)の/D %Zでは、Del /F/S/Q "%Z\Application Data\SSO"を実行します。

  • 他のユーザーのレジストリ・エントリは手動で削除する必要があります。 これは、RegEditまたはRegEdit32（RegEdt32.exe）で行うか、次の*.regファイルを各ユーザーに送信して実行できます。

    Windows Registry Editorバージョン5.00

    HKey_Current_User\Software\Passlogix]


トラブルシューティング: エージェントのパフォーマンス

エージェントのパフォーマンス

アプリケーション・レスポンス

エージェントの実行中は、エージェントの応答速度が遅くなるか、アプリケーションの速度が遅くなるか、アプリケーション内の特定の機能の処理が遅くなります。

  • 一部のアンチウィルス・ソフトウェア・プログラムでは、エージェント・モジュールが非常に頻繁にチェックされます。 この問題を解決するには、ssoshell.exeまたは%ProgramFiles%\Passlogix\v-GO SSOディレクトリ・ツリー（あるいはその両方）のチェックを無効にします。
  • 一部のアンチウィルス・ソフトウェア・プログラムでは、*.mdbファイルが非常に頻繁にチェックされます。 エージェントはユーザー資格証明を*.mdbファイルに保存します。この問題を解決するには、*.mdbファイル、%UserName% aml.mdbファイル、または%AppData%\Passlogixディレクトリ内のファイル（あるいはそのすべて）のチェックを無効にします。


トラブルシューティング: 認証

認証

初期認証

ユーザーは異なるドメイン/ワークグループ・アカウントでコンピュータにログオンしますが、同じ資格証明が表示されます。

  • 問題は、ローカル・コンピュータのWindowsアカウントが、ドメイン/ワークグループ・アカウントではなく、ユーザーのレジストリ・ハイブ（HKCU）を提供することです。解決策として、CleanupOnShutdown機能を使用することや、各ドメイン/ワークグループ・ログオンに異なるWindowsアカウントを使用することがあります。

再認証

ユーザーが再認証を求められません。

  • Extensions\AccessManager:AutoLoginを目的の値に設定していることを確認します。この値はミリ秒単位であり、値が900000の場合（クライアント側のインストールのデフォルト）は15分になります。

ユーザーが頻繁に再認証を受ける必要があります。

  • Extensions\AccessManager:AutoLoginを目的の値に設定していることを確認します。この値はミリ秒単位であり、値が900000の場合（クライアント側のインストールのデフォルト）は15分になります。
  • その他の再認証強制設定が適切に設定されていることを確認します。これらの設定には、次のものが含まれています。
  • 優先設定: Extensions\AccessManager:ReauthOnReveal
  • アプリケーション構成設定: ForceReauth


トラブルシューティング: アプリケーション構成

アプリケーション構成

すべてのアプリケーション

アップグレード後は、エージェントは既存のログオン資格証明を認識しません。

エージェントのアップグレード後、ユーザーが以前に資格証明を提供したアプリケーションが機能しないという報告がユーザーから行われます。かわりに、構成されたログオンに資格証明が対応していないことを通知するメッセージ・ボックスが表示されます。アプリケーションは、ログオン・マネージャにグレーのイタリック体のテキストで表示されます。

  • バルク追加リストを作成して、ユーザーのentlist.iniを更新します。また、ESSO-LMでは、WindowsおよびWebアプリケーションの事前構成されたログオンが、エージェントのapplist.iniではなく、コンソール・テンプレートに提供されていることに注意してください。コンソール・テンプレートを使用して、必要なアプリケーション・ログオンを作成します。次に、バルク追加リストを作成して、ユーザーのentlist.iniを更新します。

資格証明を追加すると、事前定義されたアプリケーションのリストのアプリケーションが使用できなくなります。

  • エージェントを停止し、ssoshell.exeプロセスが実行中でないことを確認し、エージェントを再起動します。

ユーザー認証なしでエージェントを起動し、ログオン・マネージャを開くことができます。

  • エージェントを停止し、実行中のssoshell.exeプロセスまたはSSObho.exeプロセスを強制終了し、エージェントを再起動します。

Windowsアプリケーション

事前定義のWindowsアプリケーション

エージェントがパスワード変更ウィンドウを認識しない

エージェントがアプリケーションの構成済パスワード変更ダイアログに応答しません。

この問題は、パスワード変更フォームのウィンドウ・タイトルをメイン・ログオン・フォームのウィンドウ・タイトル一致リストに追加することで改善できます。

  • コンソールの左側のペインでアプリケーションを選択し、「General」タブをクリックします。アプリケーションのパスワード変更フォームをダブルクリックし、フォーム構成用のダイアログ・ボックスを開きます。フォームのウィンドウ・タイトルに注意し、「Cancel」をクリックします。アプリケーションのログオン・フォームをダブルクリックし、「Window Titles」で「Add」をクリックします。パスワード変更フォームのウィンドウ・タイトルを入力して「OK」をクリックした後、「OK」をクリックしてフォーム構成ダイアログ・ボックスを閉じます。

ログオンの重複または誤ったウィンドウ

エージェントがアプリケーションに2回応答するか、以前は表示されていなかったウィンドウまたは誤ったウィンドウに応答します。
  • 1つ以上の（追加の）一致セクションおよびフィールド・キーを使用して、より正確な一致基準を指定します。
  • アプリケーション構成の「Miscellaneous」タブ（参照）の「Ignore this Window Class」で、無視する必要があるウィンドウ・クラスを指定します。
エージェントが、いずれのWindowsアプリケーションにも応答しません。
  • エージェントを停止し、実行中のssoshell.exeプロセスまたはSSObho.exeプロセスを強制終了し、エージェントを再起動します。
エージェントが、特定のWindowsアプリケーションにも応答しません。
  • 使用する一致基準を少なくします。
  • 数字のアプリケーション構成値が、16進数ではなく、10進数であることを確認します。
  • 文字列のアプリケーション構成値が、アプリケーション・ダイアログ・ボックス内の正確な文字列であることを確認します。
  • 複数のセクションを使用する場合は、1つのセクションでテストを行ってみます。
エージェントは資格証明を提供しますが、送信はしません。
  • アプリケーション構成の「Miscellaneous」タブで「Auto Submit」が設定され、特定の資格証明のセットで「AutoOK」が設定されていることを確認します。

SendKeysに関する問題

Webアプリケーション

任意のWebアプリケーションへの応答

エージェントが特定のWebページを検出しない、または応答しません。
  • ページにパスワード・フィールド（パスワードのフィールド・タイプ）があることを確認します。パスワード・フィールドがない場合、エージェントはそのページを無視します。
  • SSObho.exeが実行中であることを確認します。
  • Java、JavaScriptまたはActiveX（あるいはそのすべて）のサポートを無効にします。
特定のWebページに対してエージェントの応答速度が遅くなります。
  • ページへのロードが終了していることを確認します。エージェントは、ページへのロードが完全に終了するまでそのページに応答しません。
  • イメージをオフにします。
  • Java、JavaScriptまたはActiveX（あるいはそのすべて）のサポートを無効にします。
エージェントがロードしたWebアプリケーションに応答しません。
  1. エージェントを起動し、タイトル・バーのボタン｜からエージェントをトリガーします。
  2. ESSO-LMまたは [ÿ]+[L]を使用してログオンします。
  3. ブラウザのページをリフレッシュします。
エージェントがESSO-LMを使用して選択したログオンに応答しません。
  • このようにWebアプリケーションに応答しないというエージェントの既知の問題があります。この場合、エージェントは他のトリガーを介して応答します。
ブラウザが別のアプリケーションに組み込まれている場合、エージェントはそのブラウザがWindowsアプリケーションであるかのように応答することがあります。
SSObho.exeが実行されません。

エージェントがWebページを適切に認識しない場合は、SSObho.exeが実行中であることを確認します。実行中でない場合、エージェントはユーザーがTerminal Servicesセッション中であると認識することがあります。この問題を修正するには、次の手順を実行します。

  1. エージェントを停止します。（Task ManagerでSSO*タスクが実行中でないことを確認します。）
  2. エージェントをアンインストールします。
  3. ユーザーのコンピュータに次のファイルがないことを確認します。
    • SSOwts.exe
    • SSOwts.exe
    • SSOwts.exe

  4. レジストリのシステム・ハイブのRegEdit（HKEY_CURRENT_USERやHKEY_USERSのNOTなど）を使用して、SSO、vGOおよびPasslogixへのリファレンスを検索します。すべての不適切なリファレンス（特に次のリファレンス）を削除します。

    HKEY_LOCAL_MACHINE\SOFTWARE\Passlogixとその子

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Browser Helper Objects\{04EB19CE-B3B3-11D2-8A09-006008C7059E}とその子

    HKEY_CLASSES_ROOT\CLSID\{04EB19CE-B3B3-11D2-8A09-006008C7059E}とその子

    HKEY_CLASSES_ROOT\AppID\SSO WTS.EXEとその子

    HKEY_CLASSES_ROOT\AppID\{6B9E3EFF-C54A-472C-821B-6FC464B58235}とその子

    HKEY_CLASSES_ROOT\SSObho.HelperObjectとその子

    HKEY_CLASSES_ROOT\SSObho.HelperObject.1とその子

  5. エージェントを再インストールします。

Webアプリケーションの事前定義時

エージェントは資格証明を提供しますが、送信はしません。
  • 「Submit」フィールドがイメージ・タイプの場合は、プロトコルを含めてURLが正確であることを確認します。
  • 「Submit」フィールドが存在しない場合は、追加します。
エージェントは、ページを送信するのではなく、別のページへのリンクまたはそれ以外のアクション（取消し/消去など）をトリガーします。
  • アプリケーション構成に「Submit」フィールドを追加します。
Webページで4つ以上のフィールドが使用されます（たとえば、3つのフィールドとしての社会保険番号およびパスワード）。
  • ログオンを2つ（またはそれ以上）に分割します。次に、ユーザーは（ログオン・チューザで）パスワードがない資格証明を選択し（自動送信を無効にして）、パスワードがある資格証明を選択します。

事前定義されていないWebアプリケーション

エージェントは資格証明を提供しますが、送信はしません。
  • 資格証明を要求しているウィンドウにシステムのフォーカスを置き続けます。別のウィンドウに切り替えた場合、エージェントは資格証明を提供しますが、ページに送信の指示を出すことは行いません。
エージェントは、ページを送信するのではなく、別のページへのリンクまたはそれ以外のアクション（取消し/消去など）をトリガーします。
  • 資格証明の自動送信をオフにして、ページ送信を手動でトリガーします。
  • 「Submit」フィールドを指定して、ページを事前定義します。
  • 資格証明を追加する場合は、URLではなくウィンドウ・タイトルが保存されます。
    • SSObho.exeが実行中であることを確認します。（前述の説明を参照。）

    ホスト・アプリケーション

    任意のホスト・アプリケーションへの応答

    エージェントが、いずれのホスト・アプリケーションにも応答しません。
    • エージェントを停止し、実行中のssoshell.exeプロセスまたはSSObho.exeプロセスを強制終了し、エージェントを再起動します。
    • ホスト・エミュレータで、HLLAPIが適切に有効化されていることを確認します。
    • MFEnable=1であることを確認します。
    • 座標が左上隅を基準としていることを確認します。左上隅とは（1,1）（行1、列1）です。
    エージェントが、いずれのTelnetアプリケーションにも応答しません。
    • ホスト・エミュレータで、HLLAPIまたはスクリプト言語によるTelnetがサポートされていることを確認します。注意: エージェントでは、HLLAPIによるTelnetは、ScanPak AvivaおよびNetManage Rumbaに対してのみサポートされています。

    特定のホスト・アプリケーションへの応答

    1つ以上の資格証明フィールドが挿入されていないか、一部のみ挿入されています。
    • 座標が左上隅を基準としていることを確認します。左上隅とは（1,1）（行1、列1）です。
    • アプリケーション構成座標が、資格証明が挿入される正確な場所と一致していることを確認します。通常、フィールド・プロンプトの後にスペースがあり（ユーザー名:スペースなど）、スペースの後に資格証明フィールドを挿入する必要があります。
    • フィールド間に特殊文字列が使用されている場合は、文字列が有効であること、および「Delay Field」が十分大きい値に設定されていることを確認します。
    エージェントが特定のホスト・アプリケーションに応答しません。
    • 座標が左上隅を基準としていることを確認します。左上隅とは（1,1）（行1、列1）です。
    • 使用する一致基準を少なくします。
    エージェントが特定のTelnetアプリケーションに応答しません。
    • すべてのフィールドの座標が（1,1）に設定されていることを確認します。


トラブルシューティング: イベント・ロギング

イベント・ロギング

すべての拡張

イベントが記録されません。
  • フィルタ設定が設定されていません。0xFFFFFFFFを設定（すべてのイベントを記録）し、エージェントを再起動してテストします。
  • エージェントは再試行設定（デフォルトは30分）に達していません。デフォルトから値を変更するには、Extensions\EventManager:RetryまたはExtensions\EventManager\%Extension%:Retryをより小さい値に設定します。イベント・ロギングが行われていることを確認するには、ユーザーの%UserName% AML.mdbファイルを開き、SSOSection列で、CacheItemで始まる名前を持つエントリ（CacheItem1など）を検索します。これらの項目はイベントで、再試行時間に達するまでキャッシュされます。 キャッシュされたイベントは、再試行時に拡張に送信されます。
誤ったイベントが記録されます。
  • フィルタ設定が適切に設定されていません。 イベント・ロギング・フィルタ を確認し、正確なビット順序およびバイナリから16進/10進への変換に注意します。

Windowsイベント・ビューア

資格証明がサーバーに到達しません。
  • サーバー名が適切に設定されていません。先頭に\\文字を使用しないでください。適切なNetBIOS名（TCP/IP名ではなく）を指定してください。
資格証明がサーバーに到達しません。
  • サーバー名が適切に設定されていません。 先頭に\\文字を使用しないでください。適切なNetBIOS名（TCP/IP名ではなく）を指定してください。
サーバー上の資格証明が欠落しています。カテゴリおよびイベント・ラベルは数字のみで、次のような説明が表示されます。「ソース（ESSO-LM）内のイベントID（###）の説明が見つかりません。

ローカル・コンピュータに、必要なレジストリ情報、またはリモート・コンピュータからのメッセージを表示するメッセージDLLファイルがない可能性があります。次の情報はイベントの一部です。」

  • サーバーが適切に構成されていません。サーバーの構成方法については、「Windowsイベント・ロギング拡張」を参照してください。


使用状況レポート

「Usage Report」ダイアログ・ボックス

使用状況レポートは、ユーザーやアプリケーションのアクセスの監視、および問題のトラブルシューティングに役立ちます。

このダイアログ・ボックスを使用して、ユーザー、アプリケーション、変更日および最終使用日の情報が記載された使用状況レポートを生成します。「Output File」フィールドで、出力ファイルのわかりやすい名前を入力し、「Browse」ボタン使用してレポートを保存する場所を選択します。必要に応じて、「Include header row」ボックスを選択し、レポートにヘッダー行を含めます。


トラブルシューティング: 資格証明共有グループ

資格証明共有グループ

資格証明共有グループが機能しません。
  • Extensions\AccessManager:PWSEnable=1であることを確認します。
ドメインまたはLDAPグループのアプリケーション内でパスワードが変更されても、その変更については、認証方式に通知されません。
  • AUI:ShareToAuth=1であることを確認します。


トラブルシューティング: シンクロナイザ拡張

すべてのシンクロナイザ拡張

ディレクトリ拡張: すべてのディレクトリ・サポート

ユーザー接続

SSL経由で接続できません。
  • ディレクトリ接続がSSLなしで機能することを確認します。
ユーザーがディレクトリにオブジェクトを作成できません。
  • ユーザーがディレクトリに接続していることを確認します。
  • UserPathsが有効な場所を指していることを確認します。
  • ユーザーのSSOlocatorオブジェクトが、特にそのユーザーに対して、またはデフォルト・オブジェクトとして存在しません。 デフォルト・オブジェクトをUserPathsが指す場所に置きます。うまく配置できた場合は、デフォルト・オブジェクトをツリーの上の方へ移動したり、ユーザー固有のオブジェクトをツリーに置くことができます。

管理オブジェクト

管理オブジェクト（vGOAdminOverride、vGOentlist、vGOftulist）を変更できません。

既存のオブジェクトは上書きできません。 かわりに、古いオブジェクトを削除し、新しいオブジェクトをプッシュします。

ユーザー・オブジェクト

  • Microsoft Active Directory Server
  • Sun Java System Directory Server
  • Novell eDirectory

ファイル・システム・サーバー

ユーザー接続

ユーザーがディレクトリにオブジェクトを作成できません。
  • ユーザーがファイル・システム共有ディレクトリに（エクスプローラなどで）接続できることを確認します。


共有グループの追加

このダイアログ・ボックスは、新しい資格証明共有グループを追加して名前を付ける場合に使用します。

  • 共有グループを追加するには、「Group Name」に値を入力して、「OK」をクリックします。

このダイアログ・ボックスを表示する手順

  • 「Credential Sharing Group」を右クリックし、ショートカット・メニューから「New Group」を選択します。

    または

  • 「Insert」メニューから「CredentialSharing Group」を選択します。


同期の追加

「Add Synchronizer」ダイアログ・ボックスは、エージェントの検索リストにシンクロナイザを含める場合に使用します。（グローバル・エージェント設定のセットを選択して使用できます）。

  1. 新しいシンクロナイザの名前を入力します。
  2. リストから「Sync Type」を選択します。
  3. 「OK」をクリックしてシンクロナイザを追加し、「Synchronizers」ダイアログ・ボックスに戻ります。

このダイアログ・ボックスを表示する手順

  1. グローバル・エージェント設定のセットを選択します。
  2. 次のいずれかを実行します。

    • 「Synchronization」を右クリックし、ショートカット・メニューから「Manage Synchronizers」を選択します。

      または

    • 「Insert」メニューから「Synchronizer」を選択します。
  3. 「Add」をクリックします。「Add Synchronizer」ダイアログ・ボックスが表示されます。


複数の認証方式のサポート

複数認証によって、エンド・ユーザーの認証に、複数のログオン方式を使用できるようになります。この機能によって、グレード別認証方式と代替認証方式をサポートできる認証方式を利用できます。

(ESSO-AMの複数の認証方式の特徴は、次のとおりです。

  • 様々な認証方式を使用して認証を受け入れます。
  • グレード別認証をサポートします。
  • ユーザー・セッション中（最初のログオンからログアウトまでの間）、複数の認証方式を交互に使用できます。
  • 複数の認証方式をセッション間で交互に使用できます。
  • 管理者は次のことができます。
  • 複数の認証方式の使用の有効化または無効化
  • デフォルトのプライマリ認証方式の指定
  • 登録に必要な認証方式の指定
  • 使用している認証方式の強度に基づくアプリケーションへのアクセス制限
  • 複数の認証方式の単一セッションでの交互の使用の有効化または無効化
  • セッション間での複数の認証方式の交互使用の有効化または無効化。


メモの追加/編集

このダイアログ・ボックスは、選択した構成アイテムまたは設定についてのメモを追加または変更する場合に使用します。

  • メモを入力または編集して、「OK」をクリックします。

このダイアログは、次の構成アイテムとともに使用します。

  • 「General」タブ（選択したアプリケーション用）
  • パスワードの「Policy Subscribers」タブ
  • Selected Credential Sharing group
  • Selected Set of Global Agent Settings


ADAMインスタンスのインストール

  1. ADAMSetup.exeを起動します
  2. 一意のインスタンスを選択し、「Next」をクリックします。
  3. インスタンス名を入力し、「Next」をクリックします。
  4. ポート番号として10000および10001を指定して（思い出しやすいように10,000のレンジを使用）、「Next」をクリックします。
  5. ルートDN（OU=SSPR, DC=Oracle,DC=Comなど）を指定して、「Next」をクリックします。
  6. 簡単に見つけられるベースの場所（%RootDrive%\ADAM\Instanceなど）を指定して、「Next」をクリックします。
  7. 実行権限を指定して、「Next」をクリックします。
  8. 管理権限を指定して、「Next」をクリックします。
  9. 「Do not import LDIF files for this instance of ADAM」を選択して、「Next」をクリックします。
  10. 進むように求められたら、「Next」をクリックします。
  11. 「Finish」をクリックします。


グローバル・エージェント設定の構成（MSIパッケージ用）

グローバル・エージェント設定の構成

「Configure Global Agent Settings」ダイアログ・ボックスを使用して、同期またはカスタマイズ済Windowsインストーラ・パッケージ（.msiファイル）用にAdminOverrideオブジェクトに含めるグローバル・エージェント設定のセットを選択します。

次のいずれかを実行します。

現在のコンソール構成からのグローバル・エージェント設定の配置またはパッケージ化

  1. 「Use Administrative Console as Source」を選択します。
  2. ドロップダウン・リストから設定のセットを選択します。
  3. 「OK」をクリックします。

ファイルからのグローバル・エージェント設定の配置またはパッケージ化

  1. 「Use File as Source」を選択します。
  2. .INIファイルのパスとファイル名を入力するか、または「Browse」をクリックして特定します。
  3. 「OK」をクリックします。

AdminOverrideオブジェクト用にこのダイアログ・ボックスを表示する手順

  • シンクロナイザ・リポジトリに接続し、AdminOverrideオブジェクトを右クリックして、ショートカット・メニューから「Configure」を選択します。

MSIパッケージの作成用にこのダイアログ・ボックスを表示する手順

  • 「Insert」メニューから「Generate Customized MSI」を選択し、「Global Agent Settings」の横にある「Configuration」グループで「Choose」を選択します。


列の編集

「Edit Columns」ダイアログ・ボックスは、エージェントの「Logon Manager」および「Logon Chooser」ダイアログ・ボックスの列として表示されるログオンの詳細を選択および順序変更する場合に使用します。

  • 詳細列を追加するには、「Available」リストで列を選択して「>>」をクリックし、選択項目を「Selected」リストに移動します。
  • 詳細列を削除するには、「Selected」リストで列を選択して「<<」をクリックし、選択項目を「Available」リストに移動します。
  • 列の順序を変更するには、「Available」リストで列を選択して、「Up」または「Dn」をクリックします。


イベント・ロギング・フィルタ

イベント・ロギング: フィルタ・オプション

ログに記録するイベントを選択して、「OK」をクリックします。次の表では、フィルタを機能ごとに分類しています。

イベント・ロギングを有効にするには、「Event Types Info」を選択する必要があります。

タイプ | 名前
ユーザー・データへの変更（資格証明） | Credential Add
 | Credential Copy
 | Credential Delete
 | Credential Edit
使用されたエージェント制御（機能） | Help
 | Reauthentication
 | Settings Change
 | Startup / Shutdown
入力された資格証明データ（ログオン） | Logon Field: Fourth Field
 | Logon Field: System Domain
 | Logon Field: System Username
 | Logon Field: Third Field
 | Logon Field: Username
 | Sync User Information
エージェントのアクションと変更（アプリケーション） | Primary Logon Method Change
 | Backup/Restore
 | Application Password Change
イベント・タイプ | Event Types Info（イベント・ロギングを有効にするには、選択する必要があります）


ADユーザーまたはグループの選択（ADロール/グループ・サポート用）

ユーザーまたはグループの追加（Active Directoryのロール/グループ・サポート用）

このダイアログ・ボックスは、現在の構成アイテム（アプリケーション・ログオン、パスワード・ポリシー、グローバル・エージェント設定またはパスフレーズ・セット）のアクセス・リストに追加する個々のユーザーまたはユーザー・グループを選択する場合に使用します。

コントロール
List Names From | Active Directoryのドメインまたはサーバーを選択します。
Names | 選択したドメインまたはサーバー用のユーザーおよびグループの名前が表示されます。アクセス・リストに追加する名前を1つ以上選択します。
Add

「Names」リストで選択したユーザーおよびグループが「Add Names」リストにコピーされます。複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします。
Members | 「Names」でグループを選択した場合は、「Global Group Membership」ダイアログ・ボックスが表示されます。このダイアログ・ボックスには、選択したグループのメンバーが表示されます。
Search | 特定のユーザーまたはグループ用の1つ以上のドメインを検索するための「Find Account」ダイアログ・ボックスが表示されます。
Add Names

この時点までに追加したユーザーまたはグループの名前が表示されます。これらの名前を現行の構成アイテム用のアクセス・リストに追加する場合は、「OK」をクリックします。

このリスト内のユーザー名は、入力または編集できます。ただし、エントリのアカウント名が有効かどうかが確認され、アカウントが重複して選択されている場合は、「OK」をクリックすると、重複しているアカウントが自動的に削除されます。


グローバル・グループ・メンバーシップ（ADロール/グループ・サポート用）

「Global Group Membership」ダイアログ・ボックスには、「Add User or Group」ダイアログ・ボックスで選択されたグループのメンバーのリストが表示されます。このダイアログ・ボックスは、現在の構成アイテムのアクセス制御リストに追加する個々のメンバーを選択する場合に使用します。（複数のエントリを選択するには、[Ctrl]または[Shift]を押しながらクリックします。）「Add User or Group」ダイアログ・ボックスで、「Add」をクリックして、選択した名前を「Names」リストにコピーします。


アカウントの検索（ADロール/グループ・サポート用）

アカウントの検索（Active Directoryロール/グループ・サポート用）

「Find Account」ダイアログ・ボックスは、特定のドメイン内または複数のドメイン全体で特定の個々のユーザー・アカウントまたはユーザー・グループを検索し、検索結果の一部または全体を、現在の構成アイテム（アプリケーション・ログオン、パスワード・ポリシー、グローバル・エージェント設定またはパスフレーズ・セット）のアクセス制御リストに追加する場合に使用します。

1. 名前を検索する
Find a User or Group | 検索するユーザーまたはグループの名前を入力します。ユーザー/グループ名の完全一致のみ可能です。
Search All/Search Only in | すべての使用可能なドメイン（下のリスト・ボックスに表示される）を検索するか、検索する特定のドメインを選択します。複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします。
Search | ユーザー/グループ名の検索を開始します。
2. リストに結果を追加する
Search Results | 検索基準と一致するユーザー・アカウントおよびグループ・アカウントをリストします。
Add | 「Add User or Group」ダイアログ・ボックスで、「Search Results」リストで選択したユーザーおよびグループを「Add Names」リストに追加します。複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします。


SSOサポートの構成: アプリケーションおよびパスワード・ポリシーの選択

ESSO-LMサポートの構成: アプリケーション、パスワード・ポリシーおよびセッション・リストの選択

ウィザードのこのページは、現在の同期リポジトリに配置する現在のコンソール・セッションから、アプリケーション・ログオン、パスワード・ポリシーおよびESSO-KMリストを選択する場合に使用します。すべてのアプリケーションとポリシーを選択したり、アプリケーションおよびポリシーを個別に選択したり、どちらか一方のリストから項目を削除できます。選択が完了したら、「Next」を選択して続行します。

リスト
Applications | 配置するアプリケーション・ログオン構成をリストします。
Password Generation Policies | 配置するパスワード・ポリシーをリストします。
ESSO-KM Application List | 配置するESSO-KMアプリケーション・リストをリストします。
コントロール
Applications | 配置するアプリケーション・ログオン構成をリストします。
Password Generation Policies | 配置するパスワード・ポリシーをリストします。
ESSO-KM Application List | 配置するESSO-KMアプリケーション・リストをリストします。


SSOサポートの構成: グローバル・エージェント設定の選択

ESSO-LMサポートの構成: グローバル・エージェント設定の選択

このウィザード・ページは、現在のESSO-LM同期リポジトリに配置するには現在のコンソール・セッションからグローバル・エージェント設定のセットを選択する場合に使用します。

  1. リストから、「Global Agent Settings」のセットを選択します。
  2. 「Next」を選択して続行します。


ユーザーまたはグループの選択（LDAPロール/グループ・サポート用）

ユーザーまたはグループの追加（LDAPロール/グループ・サポート用）

このダイアログ・ボックスは、現行の構成アイテム（アプリケーション・ログオン、パスワード・ポリシー、グローバル・エージェント設定およびパスフレーズ・セット）用のアクセス・リストに追加する個々のユーザーまたはユーザー・グループを選択する場合に使用します。

コントロール

Search Base | ユーザー/グループのアカウントの検索を開始するベース・ディレクトリ（最上位のディレクトリ）。ベース・ディレクトリのすべてのサブディレクトリが検索されます。場所を入力するか、または「Change」をクリックしてディレクトリ・ツリーを参照します。
Change | 検索用のベース・ディレクトリを参照するために「Select Search Base」ダイアログ・ボックスが表示されます。
Search | ベース・ディレクトリ内のユーザーおよびグループの検索が開始されます。
Users and Groups | 検索結果が表示されます。現行の構成アイテム用のアクセス・リストに追加する名前を選択します。複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします。アクセス・リストへの選択したアイテムのコピーを終了したら、「OK」をクリックします。


検索ベースの選択（LDAPロール/グループ・サポート用）

このダイアログ・ボックスは、ユーザー/グループの名前を検索するためのベース・ディレクトリ（最上位のディレクトリ）を参照および選択する場合に使用します。終了して「Select Users or Groups」ダイアログ・ボックスに戻る場合は、「OK」をクリックします。


SSOサポートの構成: パスフレーズ質問の配置

ESSO-LMサポートの構成: パスフレーズ質問の配置

このウィザード・ページは、現在のコンソール・セッションから現在の同期リポジトリにパスフレーズ質問を配置する場合に使用します。詳細は、「パスフレーズ質問」を参照してください。

Send the Passphrase questions このチェック・ボックスは、パスフレーズ質問の現在のセットを配置する場合に選択します。続行するには「Next」を選択します。


SSOサポートの構成: サマリー

サマリー（SSOサポートの構成）

フォーム・ウィザードのこのページは、構成の確認に使用します。変更を加えるには、「Back」ボタンおよび「Next」ボタンを使用して、ページを表示します。構成が完了したら、「Finish」を選択します。


SSOサポートの構成: ロール/グループ・サポート

ESSO-LMサポートの構成: ロール/グループ・サポートのモードの選択

このウィザード・ページには、ESSO-LM構成情報のロール/グループ・アクセス制御サポートを適用するためのオプションが表示されます。

「Standard mode」（デフォルト）を選択すると、構成情報は、EntList（ログオンとポリシー用）、FTUList（バルク追加とパスフレーズ質問用）およびAdminOverride（グローバル・エージェント設定）という標準のESSO-LMオブジェクトとしてディレクトリに格納されます。

「Advanced mode」を選択して、ロール/グループ・サポートを有効にします。すべてのアプリケーション・ログオン、パスワード・ポリシー、グローバル・エージェント設定およびパスフレーズ質問のセットが、現在の同期リポジトリに個々のオブジェクトとして追加されます。

Enable Role/Group Support
  • このチェック・ボックスは、すべてのログオン、ポリシー、グローバル・エージェント設定およびパスフレーズのロール/グループ・アクセス制御設定を実施する場合に選択します。
  • アクセス制御を実施せずに構成情報を配置する場合は、このチェック・ボックスの選択を解除します。続行するには「Next」をクリックします。


End-User Experience\Response\Host/Mainframe Apps\Error Loop

エラー・ループ（「End-User Experience」-「Response」-「Host/Mainframe」）

「Host/Mainframe Error Loop」設定では、ホスト/メインフレーム・ログオンに指定した資格証明が正しくない場合のエージェントのデフォルト動作を制御します。

アプリケーション固有の設定は、これらの設定より優先されます。

Maximum retries before prompting | ホスト/メインフレーム・ログオンのログオン再試行回数を制御します。デフォルトは1です。
Maximum time for retries before prompting | ホスト/メインフレーム・ログオンのタイムアウトを制御します。デフォルトは30秒です。
Require password confirmation when modifying password | ホスト/メインフレーム・ログオンの「Logon Error」ダイアログ・ボックスに「Confirm Password」フィールドを表示するかどうかを示します。デフォルトでは、パスワード確認が必須になっています。


End-User Experience\Response\Web Apps\Error Loop

エラー・ループ（「End-User Experience」-「Response」-「Web」）

「Web Error Loop」設定では、Webログオンに指定した資格証明が正しくない場合のエージェントのデフォルト動作を制御します。

アプリケーション固有の設定は、これらの設定より優先されます。

Maximum retries before prompting | Webログオンのログオン再試行回数を制御します。デフォルトは1です。
Maximum time for retries before prompting | Webログオンのタイムアウトを制御します。デフォルトは30秒です。
Require password confirmation when modifying password | Webログオンの「Logon Error」ダイアログ・ボックスに「Confirm Password」フィールドを表示するかどうかを示します。デフォルトでは、パスワード確認が必須になっています。


End-User Experience\Response\Windows Apps\Error Loop

エラー・ループ（「End-User Experience」-「Response」-「Windows」）

「Windows Error Loop」設定では、Windowsログオンに指定した資格証明が正しくない場合のエージェントのデフォルト動作を制御します。

アプリケーション固有の設定は、これらの設定より優先されます。

Maximum retries before prompting | Windowsログオンのログオン再試行回数を制御します。デフォルトは1です。
Maximum time for retries before prompting | Windowsログオンのタイムアウトを制御します。デフォルトは30秒です。
Require password confirmation when modifying password | Windowsログオンの「Logon Error」ダイアログ・ボックスに「Confirm Password」フィールドを表示するかどうかを示します。デフォルトでは、パスワード確認が必須になっています。


イベント・ロギング

「Event Logging」設定では、エージェントがプログラム・イベントを記録する方法を制御します。

  • ローカルなロギング用の各種オプションを設定するには、「XML File」（Event Logging）設定を使用します。
  • Windowsイベント・ロギング用の各種オプションを設定するには、「Advanced」（「Event Logging」>「Windows Event Viewer」）設定を使用します。
Select events to log: ログを記録するイベントを指定するための「Event Logging Filter」を表示します。「...」をクリックしてイベントのチェックリストを表示します。


リストの編集

このダイアログ・ボックスを使用して、ウィンドウ・タイトル・バー（たとえば、サーバー）に記載される項目を入力します。

  1. 各行に1つの項目を入力します。各行の最後で[Enter]キーを押します。他のデリミタ文字を使用しないでください。
  2. 終了したら、「OK」をクリックします。

このダイアログ・ボックスは、次のグローバル・エージェント設定とともに使用します。

LDAP Synchronizer | UserPaths
LDAP Synchronizer Servers | Servers
LDAP Authenticator Servers | Servers
Active Directory Synchronizer | UserPaths
Active Directory Synchronizer Servers | Servers
Database Synchronizer Servers | Servers
Shell Tasks | Deletion Tasks PreTasks RefreshTasks StartupTasks


シンクロナイザ

使用可能な現行のシンクロナイザと、エージェントがシンクロナイザを検索するときの順序を表示します。

シンクロナイザーを追加する手順:

  • 「Add」をクリックします。「Add Synchronizer」ダイアログ・ボックスが表示されます。

検索順序を変更する手順:

  • シンクロナイザを選択し、上または下ボタンをクリックして位置を変更します。

このダイアログ・ボックスを表示する手順

  1. グローバル・エージェント設定のセットを選択します。
  2. 次のいずれかを実行します。

    • 「Synchronization」を右クリックし、ショートカット・メニューから「Manage Synchronizers」を選択します。

      または

    • 「Insert」メニューから「Synchronizer」を選択します。
    • 「Insert」メニューから「Synchronizer」を選択します。


エクスポート形式

このダイアログ・ボックスは、選択した設定のセットの出力形式を選択する場合に使用します。

オプション

Administrative Override Object | 設定を、管理優先設定オブジェクト（INI）ファイルとしてエクスポートします。
HKLM Registry | 設定を、レジストリ・エントリ（REG）ファイルとしてエクスポートします。
Both | 両方のファイル・タイプをエクスポートします。
「Unicode encoding (.REG format only)」 | .REGファイルをUnicode形式でエクスポートします。

グローバル・エージェント設定のセットのエクスポート

  1. （オプション）必要に応じて、.REGファイルに対して「Unicode format」を選択します。
  2. オプションをクリックします。
  3. 「File Save」ダイアログ・ボックスで、各ファイルのフォルダを見つけて開き、ファイルに名前を付けて、「Save」をクリックします。


「Host/Mainframe」ウィザード（「Cursor Position」）870

カーソル位置（「Host/Mainframe Form」ウィザード

フォーム・ウィザードのこのページは、スクロール画面を使用するホスト/メインフレーム・アプリケーションのログオン/パスワード変更フォームに対するカーソルの行および列を示す場合に使用します。

  1. 矢印キーをクリックまたは使用して、Telnetアプリケーションのウィンドウでテキスト・カーソルが表示される正確な位置にカーソルを配置します。
  2. 「Next」をクリックして、次のウィザード・ページを表示します。「Back」をクリックして、画面のテキストを再度貼り付けます。

ホスト/メインフレーム・アプリケーション・ログオンの構成手順の概要は、「「Host/Mainframe Form」ウィザード」を参照してください。


フィールドの照合 - 固定画面（「Host/Mainframe Form」ウィザード）

フォーム・ウィザードのこのページは、固定画面ログオンまたはパスワード変更フォームのフィールドを定義する場合に使用します。

  1. フィールドの開始位置に、カーソルを置きます。
  2. 右クリックし、ショートカット・メニューからフィールド・タイプ（「Username/ID」、「Password」、「Third Field」、「Fourth Field」）を選択します。必須フィールドごとにこの手順を繰り返します。
  3. 定義済のフィールドを削除するには、「Remove」をクリックします。
  4. フィールド間を移動する場合は「Tab Character」を選択します。オプションは「Tab」、「Enter」および「None」です。
  5. 選択が完了したら、「Next」をクリックして、サマリー・ページを表示します。「Back」をクリックして、フォーム自体の照合テキストを変更します。

ホスト/メインフレーム・アプリケーション・ログオンの構成手順の概要は、「「Host/Mainframe Form」ウィザード」を参照してください。


フィールドの照合 - スクロール画面（「Host/Mainframe」ウィザード）

フィールドの照合 - スクロール画面（「Host/Mainframe Form」ウィザード）

フォーム・ウィザードのこのページは、テキストの位置、およびスクロール画面ログオンまたはパスワード変更フォームのログオン・プロンプトの順序を定義する場合に使用します。

  1. コンソールの「Fields wizard」ページで、プロンプト入力位置にカーソルを置きます。「Add」をクリックし、要求された最初のフィールド・タイプを選択します。必須プロンプトごとにこの手順を繰り返します。
  2. 定義済のフィールドの設定を変更するには、「Edit」をクリックします。
  3. 定義済のフィールドを削除するには、「Remove」をクリックします。
  4. 選択が完了したら、「Next」をクリックして、「Summary」ページを表示します。「Back」をクリックして、フォーム自体の照合テキストを変更します。

ホスト/メインフレーム・アプリケーション・ログオンの構成手順の概要は、「「Host/Mainframe Form」ウィザード」を参照してください。


画面テキストの貼付け（「Host/Mainframe Formウィザード」）

フォーム・ウィザードのこのページは、ホスト/メインフレーム・アプリケーションのログオンまたはパスワード変更画面のテキストを構成用コンソールに貼り付ける場合に使用します。

  1. ホスト/メインフレーム・エミュレータまたはTelnetで、ターゲット・アプリケーションを起動します。
  2. ターゲット・アプリケーションで、画面テキスト全体を選択し、Windowsクリップボードにコピーします。
エミュレータには、コピーのコマンドまたはボタンが用意されているもの、および[Ctrl]キーを押しながら[C]キーを押してコピーするものがあります。Windows Telnetでは、テキストを選択して「Enter」を選択します。
  3. コンソールで、「Paste Text」をクリックします。
エミュレータ画面で復帰改行文字を使用しない場合は、適切なテキスト・ラップが設定されるように「Characters per Line」を調整します。
  4. 「Next」をクリックして次のウィザード・ページを表示するか、「Back」をクリックして画面タイプを変更します。

ホスト/メインフレーム・アプリケーション・ログオンの構成手順の概要は、「「Host/Mainframe Form」ウィザード」を参照してください。


context\HostWizard_Screen

画面タイプ（「Host/Mainframe Form」ウィザード）

フォーム・ウィザードのこのページは、ホスト/メインフレーム・アプリケーションのログオンまたはパスワード変更ウィンドウの画面タイプを選択する場合に使用します。

次のいずれかを選択します。

  • Fixed Screen。ログオン・フォームが静的なテキスト・ページとして存在するホスト/メインフレーム・エミュレータでアプリケーションを実行する場合。
  • Scrolling Screen。ログオン情報を一連のプロンプトとしてリクエストするTelnetまたはその他のスクロール画面コンソールでアプリケーションを実行している場合。

このウィザード・セッションで画面タイプをすでに選択済の場合は、「Next」をクリックして次のウィザード・ページを表示します。「Back」をクリックして、フォーム・タイプを変更します。

ホスト/メインフレーム・アプリケーション・ログオンの構成手順の概要は、「「Host/Mainframe Form」ウィザード」を参照してください。


サマリー（「Host/Mainframe Host」ウィザード）

フォーム・ウィザードのこのページは、構成の確認に使用します。変更を加えるには、「Back」ボタンおよび「Next」ボタンを使用して、ページを表示します。構成が完了したら、「Finish」をクリックします。


略語および用語

次のリストは、一般的に使用される略語および用語を示します。

略称または用語 | 正式名称
Administrative Console | ESSO-LM Administrative Console
エージェント | ESSO-LM Agent
FTU | First Time Useウィザード
ESSO-AM | Oracle Enterprise Single Sign-on Authentication Manager
ESSO-Anywhere | Oracle Enterprise Single Sign-on Anywhere
ESSO-PG | Oracle Enterprise Single Sign-on Provisioning Gateway
ESSO-KM | Oracle Enterprise Single Sign-on Kiosk Manager
ESSO-LM | Oracle Enterprise Single Sign-on Logon Manager
ESSO-PR | Oracle Enterprise Single Sign-on Password Reset


サポート情報

このドキュメントの情報に関するご質問、ご意見または誤記のご報告については、すべて次の連絡先からお寄せください。

Passlogix, Inc.

75 Broad Street, Suite 815

New York, NY 10004 USA

電話: (212) 825-9100

Fax: (212) 825-0326

電子メール: info@passlogix.com

Web: http://www.passlogix.com

カスタマ・サポートへのお問合せについては、次の連絡先をご利用ください。

電子メール: Support@passlogix.com

米国: (888) 713-5470

ヨーロッパ・中東・アフリカ : 00 44 (0)808 2342735

オーストラリア: +61 1800 153 807


一致のオフセットの例

オフセット一致の例

3つのウィンドウを含むポータル・ページの例を、次に示します。目的は、「Sales Database」ウィンドウにログオンすることです。それには、ページでそのウィンドウを他のすべてのウィンドウから分離します。

大部分のポータル・サイトと同様に、ユーザーはウィンドウの再編成や、ウィンドウの追加または削除を行って、ウィンドウの順序および有無を変更することができます。これは、検出一致およびオフセット一致の両方（全体でWeb一致と呼ばれる）を使用して実行できます。次の例では、オフセット一致について説明します。

ブラウザのツールバーで「View」>「Source」をクリックすると表示されるHTMLフラグメントを次に示します（このHTMLは重要な要素を示すために大幅に簡略化されています）。

<div name="portalLogon1">

<p>

Accounting Database

</p>

<form>

Username: <input type="text" name="username">

Password: <input type="password" name="password">

<input type="submit">

</form>

</div>

<div name="weatherStation">

<form>

Zip Code: <input type="text" name="zipCode">

<input type="submit">

</form>

<p>Temperature is now 72°</p>

</div>

<div name="ortalLogon2">

<p>

Sales Database

</p>

<form>

Username: <input type="text" name="username">

Password: <input type="password" name="password">

<input type="submit">

</form>

</div>

各ウィンドウは<div>タグで表され、各<div>タグは名前属性を持ちます。この名前属性を、自分のタスクに関係のないウィンドウをフィルタで除外する場合に使用します。

これを行うには、オフセット一致を追加して、単語portalLogonを含む名前属性を持つすべての<div>タグを検索します。「Add」をクリックして、この基準と一致させます。

次の例では、すべてのウィンドウがフィルタ処理されて、2つのportalLogonウィンドウ以外は除外されます。エージェントは、次のウィンドウのみに絞ります。

<div name="portalLogon1">

...

</div>

<div name="portalLogon2">

...

</div>

「Sales Database」ウィンドウを分離するには、別のオフセット一致フォームを追加する必要があります。HTMLソースは、分離するウィンドウにはテキストSales Databaseを含む<p>タグが含まれていることを示しています。「Add」をクリックして、この基準と一致させます。

エージェントは、次の1つのウィンドウのみを認識します。

<div name="portalLogon2">

...

</div>

対象のウィンドウが分離されるため、追加する必要がある一致はこれで全部です。

残りのタスクは、「Offset Start」値を設定することです。これを設定するには、必要なフォームが表示される一致を決定します。次の例では、2つの一致があります。

最初の一致は<div>タグ、2つ目の一致は<p>タグと一致します。この一致では、form>タグは、<div>タグに<含まれているため、表示されます。

<div name="portalLogon2">

...

<form>

...

</form>

</div>

2つ目の一致では、<form>タグは、<p>タグに含まれないため、表示できません。

<p>

Sales Database

</p>

「Offset Match」を2に設定することはできません。1に設定する必要があります。この設定では、次のように、このフィールドのフォーム・オフセットが最初の一致（<div>一致）に対して相対的であることがエージェントに示されます。

<div name="portalLogon2">

<p>

Sales Database

</p>

<form>

Username: <input type="text" name="username">

Password: <input type="password" name="password">

<input type="submit">

</form>

</div>

「Fields」リスト（「General」タブで見つかる）のすべてのフォーム・オフセットおよびフィールド・オフセットは、前述のHTMLに対して相対的です。


パスフレーズ質問の編集

このダイアログ・ボックスは、First-Time Use の使用時に表示されるパスフレーズ質問を追加または編集する場合に使用します。First-Time Useは、(a)インストール後に初めてエージェントを起動したとき、または(b)管理者がftulistオブジェクト（ftulist.iniファイルなど）を配置したときに起動されるセットアップ・ウィザードです。このオプションは、Windows Authenticator v2およびLDAP Authenticator v2に対してのみ使用します。In ESSO-AMでは、このオプションは、スマート・カード認証（SCAuth）に使用されます。

はじめて使用する場合、ESSO-LMユーザーはパスフレーズ質問を選択し、応答を指定します。ユーザーがプライマリ・ログオン・パスワードを後で変更する場合、この格納されたパスフレーズ応答を使用してESSO-LMの認証を再設定できます。次回シングル・サインオンの再認証が必要なときに、ユーザーが新しいパスワードを入力すると、ESSO-LMによってユーザーのアイデンティティを確認するためのパスフレーズ質問が表示されます。

Windows/LDAP Authenticatorのパスフレーズの追加

  1. 「Language」を選択し、「Add」をクリックします。
  2. 「Edit Question」ダイアログ・ボックスで、Questionを入力します。
  3. 応答の「Minimum Length」を選択または入力します。
  4. 「OK」をクリックします。

コントロール

Language | パスフレーズ質問の言語を選択します。
Enabled/Question | 現在のパスフレーズ質問のリストを表示します。選択されている項目は、現在のパスワード・セットに対して有効なパスフレーズです。パスフレーズを無効にするには、チェック・ボックスをクリックして選択を解除します（後述の注意を参照）。パスフレーズ質問を変更するには、それをダブルクリックするか、選択して「Edit」をクリックします。
Add | 新しいパスフレーズ質問を追加します。「Edit Question」ダイアログ・ボックスが表示されます。
Remove | 選択されているパスフレーズ質問を削除します。確認プロンプトが表示されます。後述の注意を参照してください。
Edit | 選択されたパスフレーズ質問を変更します。「Edit Question」ダイアログ・ボックスが表示されます。
削除と無効。パスフレーズ質問を作成して配置し、エンド・ユーザーによる使用を開始したら、そのパスフレーズ質問を削除しないでください。ユーザーが削除されたパスフレーズ質問を選択していた場合、パスワードを変更すると、ESSO-LM資格証明にアクセスできなくなります。使用中のパスフレーズ質問を取り除いて、はじめて使用する場合に表示されないようにするには、削除するのではなく、「Tools」>「Edit Passphrase Questions」ダイアログ・ボックスのリストのそのチェック・ボックスの選択を解除することでその質問を無効にします。


パスフレーズ質問の追加

質問の編集（パスフレーズ用）

  1. 「Question」を入力します。
  2. 応答の「Minimum Length」を選択または入力します。
  3. 「OK」をクリックします。


パスワードの変更

「Password Change」タブ（選択したアプリケーション用）

「Password Change」タブは、エージェントによるパスワード変更の管理方法を制御するためのオプションを設定または変更する場合に使用します。

エージェントは、表示される場所が同じ画面かダイアログ・ボックスの別のタブかによって、ログオン・フィールドとパスワード変更フィールドを区別します。このタイプの画面で、エージェントは「Action Chooser」ダイアログ・ボックスを介してパスワード変更かログオンを選択することをユーザーに求めます。ユーザーがパスワードを変更する必要がない期間を設定できます。つまり、その期間、「Action Chooser」は表示されません。

コントロール

パスワード変更オプション
Wizard Behavior

アプリケーションがエンド・ユーザーにパスワードの変更を求めたときに、エージェントがどのように応答するかを制御します。オプションは、次のとおりです。

  • Prompt User: 「Password Change」ウィザードに従うようにユーザーに求めます。
  • Manual w/Auto Option: ユーザーに新しいパスワードを選択するように求めます。ただし、「Password Change」ウィザードでパスワードが自動生成されます。
  • Auto only: 自動的に新しいパスワードを生成します。ユーザーは新しいパスワードを選択できません。
  • Auto w/Manual Option: 自動的に新しいパスワードを生成します。ただし、ユーザーは事前に新しいパスワードを選択できます。
  • Quietly Generate and Submit Password: ユーザーに入力を求めることなく、パスワードを生成および送信します。
  • Manual only: ユーザーに新しいパスワードを選択するように求めます。「Password Change」ウィザードでパスワードが自動生成されることはありません。
Enable Password verify pop-up dialog | パスワード変更を検証するポップアップ・ダイアログ・ボックスを表示する場合にこのボックスを選択します。このボックスでは、パスワードが変更されたことを再度確認します。
Password Generation Policy | パスワード生成ポリシーを選択します。複数のアプリケーションをポリシーにサブスクライブするには、「ポリシー・サブスクライバ」を参照してください。
Credential Sharing Group | 資格証明共有グループを選択します。複数のアプリケーションをパスワード・グループに割り当てるには、「資格証明共有グループ」を参照してください。
パスワードの期限切れオプション
Enable Password Expiration | このチェック・ボックスは、指定した期間後にユーザーにパスワードの変更を求める場合に選択します。
Number of days until password expires | ユーザーのパスワードの有効日数を入力または選択します。
Run this command when the password expires | 「Number of days」設定が経過した後でユーザーがログオンしようとしたときに呼び出すフルパスおよびコマンドを入力します（または「Browse」をクリックして、実行可能ファイルの場所を指定します）。 （例: C:\Program Files\PassChange\passchange.exe。）
アクション・チューザの猶予期間
Days エージェントが「Action Chooser」ダイアログ・ボックスを表示しない猶予期間の長さ（日単位）を入力します。


パスワード生成ポリシー

現在使用可能なパスワード生成ポリシーを表示し、ポリシー設定へのアクセスを提供します。現在のパスワード・ポリシーを右側のペインに表示するには、左側のペインで「Password Generation Policy」をクリックします。

詳細は、「パスワード・ポリシーの設定」を参照してください。

新しいパスワード・ポリシーを追加する手順

  1. 次のいずれかを実行します。
  • 右側のペインで「Add」をクリックします。

または

  • 左側のペインで「Password Generation Policy」を右クリックし、ショートカット・メニューの「New Policy」をクリックします。
  2. 「Policy Name」に値を入力し、「OK」をクリックします。右側のペインに「Policy Subscribers」タブが表示され、新しいポリシーを使用するアプリケーションを追加できます。

リスト内のパスワード・ポリシーの構成を変更する手順

  1. ポリシーをクリックし、「Edit」をクリックします。右側のペインに、「Policy Subscribers」タブが表示されます。

1つ以上のパスワード・ポリシーを削除する手順

  1. ポリシーを選択し（複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします）、「Remove」をクリックします。


Test_Password_Policy

テスト・パスワード・ポリシー

「Test Password Policy」ダイアログ・ボックスを使用して、現在選択されているパスワード・ポリシーに基づいてテスト・パスワードのセットを生成します。これによって、エージェントが、このポリシーをサブスクライブするアプリケーションからのパスワード変更リクエストにどのように応じるかをプレビューできます。生成するテスト・パスワードの数を選択できます。

設定したパスワード制約が矛盾する場合、または制限が強すぎてパスワードを生成できない場合は、テストに合格しなかったパスワード数とその理由を示すメッセージが表示されます。

テスト・パスワードの生成

  1. 「Number of test passwords to generate」を選択または入力します。
  2. 「Generate Passwords」をクリックします。出力ウィンドウにテスト・パスワードが表示されます。
  3. 終了したら、「Done」をクリックしてダイアログ・ボックスを閉じます。


SmartCardAuth

スマート・カード認証（SCAuth）

1535/プロパティ・シート

このダイアログ・ボックスの設定を使用して、ESSO-LMがスマート・カードを介してどのようにユーザーを認証するかを指定します。

コントロール
ResetEnable セキュリティを強化するため、パスフレーズのチャレンジを有効にします。ユーザーは、はじめて使用するときにパスフレーズへの応答を指定する必要があります。これはデフォルト設定です。


アーキテクチャ

Copyright ©2006-2010, Oracle.All rights reserved.

バージョン11.1.1.2.0


枠線の値

Webログオン資格証明フィールドの枠線の値

「Feedback Color」の値は、カスケード・スタイル・シート（CSS）のborder属性の標準に従います。次の表には、有効な色とそのRGB値が示されています。これらの値が使用される「Feedback Color」設定については、Web Applications（「End-User Experience」-「Response」）を参照してください。

Width

  • Thin
  • Medium
  • Thick
  • ピクセル、インチなどの単位（例: 3px.）。

Style

  • none
  • dotted
  • dashed
  • solid
  • double
  • groove
  • ridge
  • inset
  • outset

Color

色のキーワードまたはRGB値。一般的な例を次に示します。

キーワード | 対応するRGB | キーワード | 対応するRGB
aqua | #00FFFF | navy | #000080
black | #000000 | olive | #808000
blue | #0000FF | purple | #800080
fuchsia | #FF00FF | red | #FF0000
gray | #808080 | silver | #C0C0C0
green | #008000 | teal | #008080
lime | #00FF00 | white | #FFFFFF
maroon | #800000 | yellow | #FFFF00


ディレクトリ・ツリー

Copyright ©2006-2010, Oracle.All rights reserved.

バージョン11.1.1.2.0


images\Directory_Tree1_vml

[テキストに戻ります]


SSLサポート

ESSO-LMでは、Secure Sockets Layer（SSL）の使用がサポートされ、これがデフォルトで有効になっています。SSLを使用するかどうかを決定する場合は、次のことを考慮します。

  • ESSO-LMは、ユーザーが構成した認証方式を介してすべての資格証明をローカルで暗号化し、これらの資格証明を暗号化された形式で送信および格納します。
  • パススルー認証を使用するリポジトリの場合（Active Directory、ADAMなど）、ESSO-LMは中央リポジトリで（リポジトリに認証を含めて）すべてのトランザクションを保護します。資格証明は、どのようなタイプであっても、クリアテキストで送信されることはありません。
  • ESSO-KMとともにLDAPリポジトリまたはパススルー・リポジトリを使用する場合、SSLが有効でないと、リポジトリ認証はクリアテキストLDAPトランザクションになります。この認証がセキュアである必要がある場合は、クライアントとリポジトリ間のトランザクションでSSLを有効にします。

SSL証明書の設定の詳細は、次のドキュメントを参照してください。

  • Microsoft Active Directory Server: Microsoft MSDN
  • Sun Java System Directory Server: Sun Java System Directory Serverの管理者ガイド
  • Novell eDirectory: eDirectory 8.5の管理ガイド

SSLの構成は、レジストリ・キーUseSSLおよびSSLFallbackを使用して行います。


Seagull BlueZone

サポートされているバージョンの完全リストについては、ESSO-LMの最新のリリース・ノートを参照してください。

ESSO-LMでは、Seagull BlueZoneがサポートされています。設定手順は必要ありません。


アプリケーションの構成（MSIパッケージ用）

アプリケーションの構成

「Configure Applications」ダイアログ・ボックスを使用して、同期用またはカスタマイズしたWindows Installerパッケージ（.msiファイル）用のEntListオブジェクトに含めるアプリケーション・ログオンを選択します。

次のいずれかを実行します。

現在のコンソール構成からのアプリケーション・ログオンの配置またはパッケージ化

  1. 「Use Administrative Console as Source」を選択します。
  2. 次のいずれかを実行します。

    • 「Send All Applications」を選択します。

      または

    • 「Send Some Applications」を選択し、次の処理を実行します。
  3. 「Select Apps」をクリックします。
  4. 「Select Applications」ダイアログ・ボックスで、パッケージ化するアプリケーションを選択し、「OK」をクリックします。
  5. 必要に応じて、「Create First-Time-Use (FTUList) object」を選択します。
  6. 「OK」をクリックします。

ファイルからのアプリケーション・ログオンの配置またはパッケージ化

  1. 「Use file as Source」を選択します。
  2. 次のいずれかまたは両方を実行します。
    • 「Application (EntList.ini)」ファイルのパスおよびファイル名を入力するか、「Browse」をクリックしてファイルを検索します。
    • 「First-Time Use (FTUList.ini)」ファイルのパスおよびファイル名を入力するか、「Browse」をクリックしてファイルを検索します。
  3. 「OK」をクリックします。


セション・マネージャ・アクション

Oracle Enterprise Single Sign-on Kiosk Manager Actions

このパネルには、作成済のアクションのリストが含まれます。アクションによって、プログラムの実行、.Netメソッドのコール、特定のアプリケーションの終了など、なんらかの処理を実行するようにESSO-KMに指示します。

このパネルを使用してアクション・リストを作成、編集、コピーおよび削除するには、次の手順を実行します。

  1. 「Create」をクリックして、新しいアクション・リストを定義します。終了リスト、実行リストおよび特別なアクション・リストの3つのタイプのアクションを作成できます。

    または

  1. アクション名を選択して、次の手順を実行します。
    • 「Edit」をクリックしてこのアクションを変更します。
    • 「Copy」をクリックしてアクションのコピーを作成します。名前を変更するには、左側のペインでアクションを右クリックし、「Rename」をクリックします。左側のペインでアクションを右クリックして、「Copy」をクリックしても、コピーを実行できます。
    • 「Delete」をクリックして、アクションを削除します。アクションが削除される前に、確認メッセージ・ダイアログが表示されます。このアクションがセッション・ステートに関連付けられている場合は、セッション・ステートからも削除されます。


カスタム認証方式の追加

カスタム認証方式を使用すると、その認証方式に基づいてイベントをフィルタ処理できます。カスタム認証方式を追加するには、「Authenticators」タブで「Add」ボタンをクリックします。「Custom Authenticator」ダイアログ・ボックスが開きます。

  1. 「Authenticator Name」を入力します。この認証方式名が表示されます。
  2. 「Authenticator Value」を入力します。認証方式の値は、コード内で認証方式を識別できる名前です。認証方式自体から導出される名前にします。たとえば、Windows Authenticator v1の値がWinAuth、Windows Authenticator v2の値がMSAuth、Smart Cardの値がSCAuthなどです。
  3. 「OK」をクリックします。


カスタム・イベントの追加

カスタム・イベントを追加するには、「Events」タブで「Add」ボタンをクリックします。「Custom Event」ダイアログ・ボックスが開きます。

  1. 「Event Name」を入力します。このイベント名が表示されます。
  2. 「Event Value」を入力します。外部アプリケーションによってカスタム・イベントが生成され、メッセージがESSO-KMの非表示ウィンドウに送信されます。値は他のアプリケーションが送信するカスタム値です。
  3. 「OK」をクリックします。


セッション実行リストのnetapiの例

「ユーザー変更」イベントのプロパティを含む.Net APIサンプルC#コード。

using System;

using System.Collections.Generic;

using System.Text;

using System.Windows.Forms;

namespace ClassLibraryTest

{

public class TestClass

{

private string m_userName;

private string m_domainName;

public string UserName

{

set

{

m_userName = value;

}

get

{

return m_userName;

}

}

public string DomainName

{

set

{

m_domainName = value;

}

get

{

return m_domainName;

}

}

public void UserChange()

{

MessageBox.Show("UserChange called with user: " + DomainName + "\\" + UserName);

}

public void SessionStart()

{

MessageBox.Show("SessionStart called");

}

public void SessionEnd()

{

MessageBox.Show("SessionEnd called");

}

public void SessionLocked()

{

MessageBox.Show("SessionLocked called");

}

public void SessionUnlocked()

{

MessageBox.Show("SessionUnlocked called");

}

public void PreSessionUnlocked()

{

MessageBox.Show("PreSessionUnlocked called");

}

public void AuthLogon()

{

MessageBox.Show("AuthLogon called");

}

public void AuthTimeout()

{

MessageBox.Show("AuthTimeout called");

}

public void DeviceIn()

{

MessageBox.Show("DeviceIn called");

}

public void DeviceOut()

{

MessageBox.Show("DeviceOut called");

}

public void GracePeriod()

{

MessageBox.Show("GracePeriod called");

}

}

}


セッション選択アクション・リスト

「Oracle Enterprise Single Sign-on Kiosk Manager」>「Actions」>「Associate Select Actions」

このダイアログ・ボックスを使用して、このセッション・ステートに関連付ける1つ以上のアクションを選択します。このセッション・ステートに追加するアクションを選択します（複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします）。「OK」をクリックします。

アクションがこのセッション・ステートに関連付けられていて、新しいアクションを追加する場合は、すべてのアクションを再度選択する必要があります。そうしないと、アクション・リストは新しく選択されたアクションで置き換えられます。


SMを使用したLeaveDefaultへのアプリケーションの追加

「Oracle Enterprise Single Sign-on Kiosk Manager」>「Keep Running List」>「Select Default Applications」

このダイアログ・ボックスを使用して、セッション終了時も稼働を続けるアプリケーションのリストにデフォルトのアプリケーションを追加します。

  • セッション終了時も稼働を続けるアプリケーションを選択し、「OK」をクリックします。

    その後、「AppPath Keys」ダイアログ・ボックスに選択されたアプリケーションがリストされます。


SMを使用したAppPathKeysの追加

Process Path Key

Process Path Keyは、プロセスの実行可能ファイル名です。たとえば、Internet ExplorerのProcess Path Keyは、IEXPLORER.EXEになります。このダイアログを使用して、アプリケーションのリストにアプリケーションを追加します。

  • Process Path Keyを入力して、「OK」をクリックします。

    その後、「AppPath Keys」ダイアログ・ボックスでProcess Path Keyが作成されます。


「General」タブ（選択したポリシー用）

左側のペインでポリシーを選択すると、右側のペインには「General」および「Security」の2つのタブが表示されます。

選択したポリシーの「General」タブからは、そのポリシーについて、近接型ICカードとスマート・カードに対して構成されている設定の数を確認できます。具体的には、このタブには次の情報が表示されます。

  • Path: 関連する設定のグループを構成する各要素の名前。この場合は、近接型ICカードとスマート・カード。
  • Set: 構成されている設定の数（設定がそのデフォルト値に設定されている場合も含まれます）。
  • Total: 構成されている設定の合計数。
  • Add Notes: 「Notes」ダイアログ・ボックスを起動します。

設定を構成した後、左側のペインでポリシーを再選択すると、変更された設定の概要が「General」タブに表示されます。「Path」および「Set」列のテキストが青色のテキストに変わり、ポリシーへの変更箇所がハイライト表示されます。


新しいUAMポリシー・セット

新しいUAMポリシーの作成

新しいUAMポリシーを作成するには、次のいずれかを実行します。

  • 左側のペインで、「Authentication Manager」をクリックします。右側のペインで、「Policies」を選択し、画面の下部にある「Add Policy」をクリックします。

    または

  • 左側のペインで、「Universal Authentication Manager」を展開し、「Policies」を選択します。画面の下部にある「Add」ボタンをクリックします。

    または

  • 左側のペインで、「Policies」を右クリックして、「New Policy」を選択します。

    または

  • 「Insert」メニューから「UAM Policy」を選択します。

メッセージ・ボックスが開き、ポリシーに名前を付けるように求められます。ポリシーの名前を入力し、「OK」をクリックします。「Policies」ノードを拡張すると、ここで作成したポリシーが表示されます。

「General」タブおよび「Security」タブ

ポリシーの名前をクリックすると、右側のペインに「General」および「Security」の2つのタブが開きます。「General」タブには、ポリシーに関する一般情報が表示されます。「Security」タブには、ポリシー･セットに関するセキュリティ情報が表示されます。詳細は、「「General」タブ（選択したポリシー用）」および「「Security」タブ（選択したポリシー用）」を参照してください。

近接型ICカードおよびスマート・カードの設定

ポリシー・セットのノードを展開します。ポリシー名の下に「Proximity」および「Smart Card」のオプションが表示されます。これらのオプションを使用すると、その特定のポリシー・セット内の近接型ICカード・ユーザーとスマートカード・ユーザーの設定を構成できます。詳細は、「近接型ICカード設定」および「スマート・カード設定」を参照してください。

UAMポリシーの公開

新しいUAMポリシーを作成し、その設定を構成した後、Active Directoryに接続すると、そのポリシーを公開できます。

  1. 左側のペインで、「Repository」をクリックします。
  2. UAMリポジトリの場所に移動します（「CN=Program Data, CN= Passlogix, CN=UAM, CN=Policies」）。
  3. ポリシーを適用するActive Directoryグループまたはユーザーの名前で新しいUAMポリシー・コンテナを作成します。
  4. 左側のペインでポリシー名を右クリックして、「Publish」を選択します。「Publish to Repository」ダイアログ・ボックスが開きます。
  5. 「Target Repository」フィールドで、ポリシーのターゲットとして作成したユーザーまたはユーザー・グループ・コンテナを選択します。
  6. 「Publish」クリックして、ポリシーを公開します。「Cancel」をクリックすると、公開が取り消され、リポジトリに戻ります。
コンソールを使用すると、それぞれのポリシーを複数のActive Directoryユーザー・グループまたはユーザー（あるいは、その両方）に公開できますが、各ユーザーまたはユーザー・グループに適用されるのは1つのポリシーのみである場合があります。


近接型ICカード設定

選択したポリシーの「Proximity Card」を選択すると、ページが開き、編集する近接型ICカード設定が表示されます。すべての設定は、デフォルトで無効にされています。また、デフォルト値が設定されています。設定を変更するには、設定の横にあるチェック・ボックスを選択して、ドロップダウン・メニューからオプションを選択します。次の設定を構成できます。

  • Enrollment Prompt: 登録するようにユーザーに求めるかどうか、登録が任意であるか必須であるかを制御します。

    オプション:

    • Optional（デフォルト）
    • Required
    • Never

  • PIN Allowed Characters: ユーザーが近接型ICカードに関連付けられるPINを登録する際に許可される文字。オプションは、数値のみ、英数字またはすべての文字です。

    オプション:

    • Any characters（デフォルト）
    • Alphanumeric only
    • Numeric only

  • PIN Minimum Length: 近接型ICカードPINの許容最小長。

    オプション:

    • 可能な値は4から16（デフォルトは4）

  • PIN Required: ユーザーがカードに関連付けられるPINを登録し、認証のためにPINを送信する必要があるかどうかを制御するセキュリティ設定。

    オプション:

    • Yes（デフォルト）
    • No

  • Removal Action: 近接型ICカードがリーダーから外されたときに、コンピュータがどのように反応するかを制御します。

    オプション:

    • Lock Workstation（デフォルト）
    • Force Logoff
    • No Action


「Security」タブ（選択したポリシー用）

左側のペインでポリシーを選択すると、右側のペインには「General」および「Security」の2つのタブが表示されます。

選択したポリシーの「Security」タブから、Active Directoryデータベースのオブジェクトに対するユーザーまたはユーザー・グループのアクセスを変更できます。アクセス権を変更するには、「Security」タブをクリックします。ユーザーまたはユーザー・グループの名前を右クリックして、ショートカットメニューから「Read」または「Read/Write」を選択します。

  • Directory: ユーザー・データが格納される特定のActive Directoryサーバーを示します。このフィールドのドロップダウン・リストからユーザーまたはユーザー・グループのActive Directoryサーバーを選択します。
  • Name: データベース・オブジェクトに現在アクセスできるグループまたはユーザーを表示します。
  • ID: ユーザー・アカウント名を示します。
  • Access: ユーザーまたはグループが読取り/書込みアクセス権を持つのか、または読取り専用アクセス権を持つのかを示します。
  • Copy Permissions To...: データベース・オブジェクトに設定されている権限を、別のアプリケーション・テンプレートにコピーできるようにします。このボタンをクリックし、権限を適用するアプリケーション・テンプレートを選択します。
  • Add: 現在選択されているポリシーにアクセスする必要があるユーザーまたはグループを選択するための、「Add User or Group」ダイアログ・ボックス（LDAPまたはActive Directoryの場合）を表示します。
  • Remove: 選択したユーザーまたはグループをリストから削除します。削除するユーザーまたはグループを選択します。複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします。


スマート・カード設定

選択したポリシーの「Smart Card」を選択すると、ページが開き、編集するスマート・カード設定が表示されます。すべての設定は、デフォルトで無効にされています。また、デフォルト値が設定されています。設定を変更するには、設定の横にあるチェック・ボックスを選択して、ドロップダウン・メニューからオプションを選択します。次の設定を構成できます。

  • Enrollment Prompt: 登録するようにユーザーに求めるかどうか、登録が任意であるか必須であるかを制御します。

    オプション:

    • Optional（デフォルト）
    • Required
    • Never

  • PIN Required: スマート・カードでの認証のためにユーザーがPINを送信する必要があるかどうかを決定します。

    オプション:

    • Yes（デフォルト）
    • No
  • Removal Action: スマート・カードがカード・リーダーから外されたときに、コンピュータがどのように反応するかを制御します。


UAMポリシー

ポリシーは、Active Directoryドメインに接続されるワークステーションにログオンするActive Directoryユーザーにつて、権限、制限、および登録とログオン・ルールの施行を制御します。作成する各ポリシーには、ユーザーとユーザー・グループに適用できる、v-GO UAMを使用するための一意の条件セットが含まれます。

左側のペインの「Universal Authentication Manager」で、「Policies」を選択します。右側のペインには、次の項目が表示されます。

  • Setting Name: ポリシーに指定する名前。
  • Items Set: そのポリシーに構成されている設定（詳細）の数。
  • Total Items: 構成に使用できる設定の合計数。
  • Add: このボタンをクリックすると、新しいポリシーが作成されます。
  • Remove: このボタンをクリックすると、リストからポリシーが削除されます。

ポリシーの設定を変更する手順

  • 右側のペインで、ポリシー名をダブルクリックします。

    または

  • 左側のペインで、「Policies」を展開します。「Policies」の下で、ポリシー名をダブルクリックします。ポリシー名で、変更する要素（「Proximity Card」または「Smart Card」）をクリックします。


Universal Authentication Manager

v-GO Universal Authentication Managerを使用すると、企業は、Microsoft WindowsおよびActive Directoryネットワークへのネイティブのパスワード・ログオンの使用を、より強力かつ簡単な認証方式に置き換えることができます。また、v-GO UAMシステムでは、2つの要素による認証方式を提供することで、従来のパスワード認証を超える企業のセキュリティが実現されます。v-GO UAMでは、ユーザーの識別および認証に使用される資格証明を迅速かつ安全に登録できます。v-GO UAMでは、スマート・カードおよびパッシブ近接型ICカードという、2つの組込み型の構成可能な認証方式が提供されます。v-GO UAMは、スマート・カードまたは近接型ICカードから簡単に得られるデータの一部をユーザー・アカウントと関連付けるため、カードまたはトークンを使用して、ユーザーを識別および認証できます。

スマート・カード

スマート・カードは、クレジット・カード・サイズのトークンであり、データを安全に格納および処理できるチップまたは組込み回路が内蔵されています。また、スマート・カードに格納される情報は、識別および認証にも使用できます。v-GO UAMでは、スマート・カード・チップにデータを書き込むことなく、ユーザー・ログオンと認証のためにスマート・カードの登録と使用が可能です。また、v-GO UAMは、より強力なユーザー認証のログオン時にスマート・カードPINを必要とするオプションもサポートします。

近接型ICカード

パッシブ近接型ICカードまたはトークンは識別オブジェクト（職場でのIDバッジなど）であり、カード読取りデバイスが検出および解読できる回路が内蔵されています。近接型ICカードがリーダー付近に置かれると、リーダーはトークンの存在を感知し、特定のユーザーに関連付けられている識別情報を認識します。このv-GO UAM方式には、近接型ICトークンに関連付けられるPINを登録することをユーザーに要求するオプションが含まれています。このように構成されると、v-GO UAMは、ユーザーのログオン時に、トークンに関連付けられている登録済PINを入力するように求めます。これによって、ユーザー認証が強化されます。

UAMユーザーのポリシーの構成

v-GO UAM管理者は、ESSO-LM Administrative Consoleを使用することで、1か所からv-GO UAMポリシー設定を構成および適用できます。ESSO-LM Administrative Consoleには、管理者がポリシーを構成できるようにするv-GO UAM機能が含まれています。これらのポリシーでは、様々なユーザーおよびユーザー・グループに対してスマート・カードおよび近接型ICカード認証がどのように動作するかが指定されます。


「Select Applications」の追加

「Select Application」、「Password Policies」または「Session List」ダイアログ・ボックス

「Select Applications」（あるいは「Password Policies」または「Session List」）ダイアログ・ボックスを使用して、次のいずれかを行います。

  • グループまたはポリシーに含めるアプリケーション・ログオン構成、またはインストーラ・パッケージへのエクスポート用のアプリケーション・ログオン構成を1つ以上選択します。
  • ロール/グループ・サポートを使用したディレクトリへの配置のために、個々のアプリケーションとパスワード・ポリシーを選択します。
  • 送信する「Oracle Enterprise Single Sign-on Kiosk Manager」アプリケーション・リストを追加します。

グループまたはパッケージへのアプリケーション、ポリシーまたはセッション・リストの追加

  1. このグループに追加するアプリケーションを選択します（複数のエントリを選択するには、[Ctrl]キーまたは[Shift]キーを押しながらクリックします）。
  2. 「OK」をクリックします。
  3. 次のいずれかのダイアログ・ボックスで「Add」をクリックし、「Select Applications」を開きます。
    • 「Bulk Add」タブ
    • 「Policy Subscribers」タブ
    • Selected credential sharing group
    • Configure Applications（「Generate MSI」）
    • Manage Templates
    • Configure SSO Support: Select Applications and Password Policies


サーバー・リストの編集

このダイアログ・ボックスは、「Connect to Repository」ダイアログ・ボックスの「Server Name」ドロップダウン・ボックスにリストされるサーバーを削除する場合に使用します。

  1. サーバーを選択して「Delete」をクリックします。
  2. 終了したら、「OK」をクリックします。


Error_Loop_Apps

「Error Loop」タブ（アプリケーション・タイプごと）

「Error Loop」タブ（Applicationsの下）は、個々のアプリケーション・タイプ（Windows、Web、ホスト/メインフレーム）の「Logon Error (Error Loop)」ダイアログ・ボックスの外観および動作を制御する場合に使用します。

  • すべてのアプリケーションを対象にエラー・ループをグローバルに設定するには、「Error Loop」プロパティ・シートの設定を使用します。
  • 個々のアプリケーションを対象にエラー・ループを設定するには、「Error Loop tab for each application」の設定を使用します。

>詳細は、繰返しログオン試行の制御の設定に関する項を参照してください。

コントロール

Logon Timeout (sec.)

[TimeOut]

「Logon Error」ダイアログ・ボックスを表示するまでに、連続ログオン試行を許可する最大時間（秒）。デフォルトは3です。

Max. Retries

[MaxRetry]

「Logon Error」ダイアログ・ボックスを表示するまでに、（初回の試行後）再試行を許可する最大回数。デフォルトは1です。

「Logon Timeout」を0に設定した場合は、ログオン・エラー（入力した資格証明が不適切など）が発生しても、「Logon Error」ダイアログ・ボックスは表示されません。

Hide "Confirm Password"

[HideConformPW]

「Logon Error」ダイアログ・ボックスのパスワード確認フィールドを非表示にするかどうかを決定します。デフォルトは「No」です。
（グローバル・レジストリの該当部分は大カッコで囲んで示されています。）


First_Time_Use_Apps

「First Time Use」 タブ

「First Time Use」（「Applications」の下）を使用して、設定ウィザードの特定の動作を制御します。

「First Time Use」タブを表示する手順:

  • 左側のペインで「Applications」をクリックし、右側のペインで「First Time Use」タブをクリックします。

コントロール

Minimize number of steps during Setup Wizard

インストール後、設定ウィザードでESSO-LMを設定するために必要な最小ページ数を表示する場合に選択します。

このオプションを選択した場合、次のようになります。

  • 1つの（デフォルトの）プライマリ・ログオン方法のみが使用可能です。複数の認証方式がインストールされている場合、レジストリの1番目の認証方式のみがユーザー設定用に表示されます。
  • バルク追加アプリケーションはユーザー選択用には表示されません。
  • 設定ウィザードの最後にサマリー画面は表示されません。

このオプションを選択しない場合、次のようになります。

  • インストール済のすべての認証方式がユーザー設定用に表示されます。
  • バルク追加アプリケーションがユーザー選択用に表示されます。
  • 設定ウィザードの最後にサマリー画面が表示されます。


「Matching」タブ（Webアプリケーションの構成用）

「Matching」タブ（選択したWebアプリケーション用）

「Matching」（Web）タブは、同じWebアプリケーションの類似したフォームを区別する場合に使用します。サポート対象のフォーム・タイプ（ここではターゲット・フォームと呼びます）は、次のとおりです。

  • Logon
  • Password change
  • Password change success
  • Password change failure

このタブは、通常、検出一致基準を調整する場合に使用します。検出一致基準とは、あるページの特定に使用する一連のHTMLタグおよび値のことです。これにより、検出一致基準のサブセットを使用するオフセット一致を作成し、そのページで目的のログオン・フォームまたはパスワード変更フォームを特定できます。

このタブを表示する手順

  • 新しいWebアプリケーション・ログオンを作成します。

    または

  1. 左側のペインで「Applications」をクリックし、Webアプリケーションを選択します。
  2. 右側のペインで、「General」タブをクリックします。
  3. リストからフォームを選択し、「Edit」をクリックします。
  4. 「Web」フォーム構成ダイアログ・ボックスの「General」タブで、「Matching」タブを選択します。

検出一致基準の作成または変更

  1. 「Detection Match」リストで、次のいずれかを実行します。
  2. 新しい一致基準を作成するには、「Add」をクリックします。
  3. 既存の一致を変更するには、一致を選択し、「Edit」をクリックします。
  4. 「Edit Match」ダイアログ・ボックスで必要な情報を入力または選択し、「OK」をクリックしてこのダイアログ・ボックスに戻ります。
  5. 必要に応じて、一致基準の順序を調整します。
  6. 移動する一致を選択します。
  7. 上矢印または下矢印をクリックします。
  8. 「OK」をクリックします。

AND、ORまたはNOT演算子を使用して、エージェントがWeb一致の組合せに応答する条件を指定します。

ANDで一致する値を一致基準に割り当てた場合、ページに応答するための条件がエージェントに存在する必要があります。そのため、いくつかのフィールドがAND演算子に割り当てられている場合は、それらすべての基準が存在する必要があります。

ORで一致する値を複数の一致基準に割り当てた場合、いずれかの基準が存在する場合にエージェントが応答します。

NOT演算子は、照合を実行するときの除外を指定する場合に使用します。エージェントは、NOT基準の条件が存在しないかぎり、AND演算子およびOR演算子を割り当てたすべての基準に応答します。エージェントは、NOT演算子で特定されたインスタンスを除外します。

オフセット一致

オフセット一致は、ポータルWebページでのみ使用します。

このタイプの一致は複数のウィンドウを持つポータル・ページで使用され、ユーザーはこのウィンドウを再編成、追加および削除することができます。照合しているサイトがポータルでない場合は、このパネルのオフセット一致セクションを空白のままにしておきます。

通常の一致検出では、フォームは常に同じ順序で表示される必要があります。オフセット一致では、フォーム（ウィンドウのように見えます）を再編成でき、特定のウィンドウを他のすべてのウィンドウから分離できます。これはポータル・ページにのみ適用されます。これらのページは動的で、フィールド名ではなく序数値が照合に使用されるためです。

「Offset Start」フィールドを使用して、どの一致結果のフォームをフォーム・オフセットに使用するかをESSO-LMに伝えます。オフセット開始値は、オフセット一致の数である必要があります。たとえば、オフセット一致が3つある場合、オフセット開始値は3になります。

オフセット一致基準の作成または変更

  1. 「Offset Match」リストで、次のいずれかを実行します。
    • 定義した検出一致基準をコピーするには、「Copy from Detection」をクリックします。
    • 新しい一致基準を作成するには、「Add」をクリックします。
    • 既存の一致を変更するには、一致を選択し、「Edit」をクリックします。
  2. 「Edit Match」ダイアログ・ボックスで、必要な情報を入力または選択し、「OK」をクリックしてこのダイアログ・ボックスに戻ります。
  3. 必要に応じて、一致基準の順序を調整します。
  4. 移動する一致を選択します。
  5. 上矢印または下矢印をクリックします。
  6. 「Offset Start」を選択します。
  7. 「OK」をクリックします。


「Matching」タブ

「Matching」タブ （Windowsアプリケーション構成用）

「Matching」（Windows）タブは、同じWindowsアプリケーション内にある類似したフォームを区別する場合に使用します。サポート対象のフォーム・タイプ（ここではターゲット・フォームと呼びます）は、次のとおりです。

  • Logon
  • Password change
  • Password confirmation
  • Password change success
  • Password change failure

エージェントは、ユーザー指定の一致基準を使用して、類似フォームを区別します。これにより、エージェントは1組のユーザー資格証明をこのような複数のフォームに適切に適用できます。また、マッチングを使用して、エージェントで無視するフォームを識別できます。

次のいずれかを実行します。

  • 新しい一致基準を作成するには、「Add」をクリックします。

    または

  • 「Match」を選択し、「Edit」をクリックします。

    「Matching」ダイアログ・ボックスが表示されます。

一致基準を作成する最も簡単で効率的な方法は、「Control Match」ウィザードを使用することです。ウィザードを使用すると、ターゲット・フォーム自体から要素を選択して、一致基準を指定できます。また、手動で一致基準を作成および変更することもできます。


フィールド（ホスト/メインフレーム・ログオン・フォーム）

フィールドの追加または編集

「Fields」ダイアログ・ボックスを使用して、ログオンまたはパスワード変更フォームの資格証明フィールドを指定します。

また、フィールドの先頭文字の場所（行番号および列番号）を指定する必要もあります。フィールドの開始行番号および開始列番号を検索するには、セッション・ウィンドウの最下部にあるステータス・バーのカーソル位置インジケータを使用します。エントリを作成した後、「OK」をクリックします。

詳細は、「ホスト/メインフレーム・アプリケーションの追加」を参照してください。

コントロール

Function

フィールド・タイプを選択します。

  • UserID
  • Password/OldPassword
  • Third Field
  • Fourth Field
  • New Password
  • Confirm New Password
Row | （固定画面アプリケーションのみ）フィールドの先頭文字の行番号（画面の垂直座標）を入力します。
Column | （固定画面アプリケーションのみ）フィールドの先頭文字の行番号（画面の水平座標）を入力します。列番号が可変の場合（たとえば、ほとんどのUNIXシステムには、パスワードを変更すると「New Password」および「Confirm Password」フィールド・ラベルの一部として影響を受けるユーザー名があります）、ESSO-LM が常に正しい場所に資格証明を取り込むことができるように、正規表現を使用してフィールド・ラベルの可変部分にワイルドカードを指定できます。


Citrix_Environment_Install

Citrix環境でのESSO-LMの構成

Citrix MetaFrameでのESSO-LMのデフォルト・インストール

ESSO-LMのデフォルト・インストール・プロセスでは、ESSO-LMがCitrix環境で機能するために必要なコンポーネントが自動的に検出され、インストールされます。 このインストール・プロセスによって、そのCitrixサーバーで公開されたすべてのアプリケーションに対するESSO-LMサポートが有効になります。

Citrix MetaFrameへのESSO-LMのインストール

  1. ターミナル・サーバーに管理者としてログオンし、すべてのアプリケーションを閉じます。
  2. 「スタート」、「ファイル名を指定して実行」をクリックします。
  3. 「ファイル名を指定して実行」ダイアログ・ボックスのドロップ・ダウン・リストからcmdを選択し、[Enter]を押します。
  4. コマンド・プロンプトで、change user /installと入力し、[Enter]を押します。
  5. 環境に適したインストール・オプションを選択して、ESSO-LMをインストールします。
  6. インストールの完了後、コマンド・プロンプトでchange user /executeと入力します。

Citrixでの特定アプリケーション用のESSO-LMの制御

次の項では、ESSO-LMのデフォルト・インストールを変更する方法、およびCitrix環境で特定のアプリケーション用にESSO-LMを有効にする方法について説明します。 このプロセスには、2つの手順があります。 最初の手順では、グローバルESSO-LMサポートを削除します。 2つ目の手順では、公開アプリケーション構成を使用して、SSO対応にするアプリケーションを指定します。

グローバルESSO-LMサポートの削除

  1. 「スタート」、「ファイル名を指定して実行」をクリックします。
  2. 「ファイル名を指定して実行」ダイアログ・ボックスで、Regeditと入力し、[Enter]を押します。
  3. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogonを参照します。
  4. 右側のペインで「AppSetup」文字列値を右クリックし、「修正」を選択します。
  5. SSOLauncherを参照しているこのエントリ内の値データを削除します （C:\Program Files\Passlogix\v-GO SSO\wts\ssolauncher.exe /nossoshutdown）。
  6. Windows Authentication v1を使用している場合は、Passlogixレジストリ・ハイブにCheckForParentProcessキーを追加します。これにより、認証イベントがESSO-LMにハンドオフされます。

HKEY_LOCAL_MACHINE\SOFTWARE\Passlogix\AUI\WinAuth\

DWORD:

CheckForParentProcess

Value=0

AppSetupからssolauncher.exeを削除すると、公開アプリケーション構成に指定しないかぎり、このCitrixサーバー上のいずれのアプリケーションでも機能しないようにESSO-LMが構成されます。

公開アプリケーション構成（SSOLauncher）を使用したSSO対応アプリケーションの指定

ESSO-LMはグローバルで無効になっているため、公開済のアプリケーション・プロパティにSSOLauncher.exeコマンドを追加することによって、ESSO-LMサポートとともに公開するアプリケーションを指定する必要があります。

  1. Citrix管理コンソールを開きます。
  2. シングル・サインオンを有効にするアプリケーションを検索して公開します。
  3. 公開したアプリケーションを右クリックし、プロパティを選択します。
  4. 「Application Location」タブを選択します。
  5. コマンドラインの前に「C:\Program Files\Passlogix\v-GO SSO\wts\SSOLauncher.exe/application」という構文を追加します。

SSOLauncher.exeのコマンドが、公開済のアプリケーションのコマンドラインに追加されます（置き換えられるわけではありません）。

アプリケーションACTのコマンドライン構文の例を次に示します。

C:\Program Files\Passlogix\v-GO SSO\wts\SSOLauncher.exe" /application C:\ProgramFiles\ACT\act.exe

この例は、ESSO-LMとACTの両方がCitrixサーバーのC:\ドライブにインストールされていることを前提としています。

詳細は、「MetaFrame XPサーバーのSSOLauncher」を参照してください。


context\HostWizard_TextMatch

照合するテキスト（「Host/Mainframe Form」ウィザード）

フォーム・ウィザードのこのページは、画面がログオンまたはパスワード変更フォームであることを識別するテキストを示す場合に使用します。

  1. 画面がログオンまたはパスワード変更フォームであることを示すテキスト・ブロックを選択します。選択範囲を右クリックし、「Add as Text Match」を選択します。
  2. 追加のテキスト・ブロックごとにこの手順を繰り返します。
  3. テキストの一致を削除するには、下部のペインで一致した項目を選択して、「Remove」をクリックします。
  4. 「Next」をクリックして、フォーム・フィールドを定義します。「Back」をクリックして、前のウィザード・ページを表示します。

ホストおよびメインフレーム・アプリケーション・ログオンの構成手順の概要は、「「Host/Mainframe Form」ウィザード」を参照してください。


「Credential」フィールド

「Credential」フィールド（RSA-securIDアプリケーション用「Windows Form」ウィザード）

フォーム・ウィザードのこのページは、アプリケーションのログオンまたはパスワード変更ウィンドウのフィールドを選択する場合に使用します。

Windowsアプリケーションを構成する手順の詳細は、「「Windows Form」ウィザード（RSA-securIDアプリケーション）」を参照してください。

Credential Fields

現在選択しているアプリケーション・ウィンドウのフィールドが表示されます。ヘッダー（「Class」、「ID」または「Text」）をクリックすると、リストがソートされます。リスト内のフィールドを右クリックすると、フィールド・タイプのショートカット・メニューおよび送信コントロールが表示されます。

  • SecurID Username
  • Passcode
  • Tokencode
  • Next Passcode
  • Next Tokencode
  • Confirm New PIN
  • SecurID Other Field
  • OK（送信コントロール）

Refresh

フィールド・リストを更新します。

Use "Send Keys" for this form, do not use Control IDs

エージェントが、コントロールIDによって個々のフィールドをアドレス指定するのではなく、キーストロークの組合せとしてこのフォームにログオン・データを転送することを示します。詳細は、「SendKeys」を参照してください。

Refresh | フィールド・リストを更新します。
Back | 前のウィザード・ページに戻ります。
Next | 次のウィザード・ページに進みます。


WindowsアプリケーションのセッションでのSendKeys

Kiosk Manager SendKeys（Windowsアプリケーション用）

「SendKeys」ダイアログ・ボックスは、ESSO-KMがログオン・フォームに転送するキーストロークの組合せを指定する場合に使用します。

Telnetアプリケーションのログオンの構成については、「Telnetアプリケーションの追加」を参照してください。

「SendKeys」ダイアログの右側のペインの各タブには、キーストローク・オプションがあります。各タブで必要なオプションを選択または入力します。「Insert」ボタンをクリックして、キーストロークの組合せにキーまたはアクションを追加します。

左側のペインのリストに選択内容が表示されます。キーストロークの組合せの順序を変更するには、項目を選択し、上矢印または下矢印をクリックしてその項目を移動します。項目を削除するには、その項目を選択し、「Remove」をクリックします。

コントロール

「Text」タブ

Enter text to insert

キーストロークの組合せに追加するリテラル・テキストを入力します。

Insert

キーストロークの組合せにテキストを追加します。

「Delay」タブ

Length of delay (in seconds)

キーストローク間の遅延を入力または選択します。

Insert

キーストロークの組合せに遅延を追加します。

「Special Keys」タブ

Category/Keys

左側のリストからキーストローク・カテゴリ（移動キーなど）を選択し、 右側のリストから具体的なキー（[Page Down]など）を選択します。

Key Press

単一のキーストロークとしてキーを挿入します（デフォルト）。

Key Down/Up

キーを押して解放するという1組のアクションとしてキーを挿入します。このオプションを使用すると、これらのアクション間に他のキーストロークを挿入して、あるキーの入力時に1つ以上の別のキーを押したままにすることができます。たとえば、フォーカスを特定のテキスト・ボックスに移動するホット・キーの組合せを作成できます。

たとえば、キーストローク[Alt]+[P]を挿入するには、「Key Down/Up」オプションを選択し、カテゴリとして「Modifier」、キーとして「Alt」をそれぞれ選択し、「Insert」をクリックします。これにより、[Down:Alt]と[Up:Alt]の2つのアクションが挿入されます。「Text」タブを選択し、テキスト・ボックスにPと入力します。左側のペインで、「[Up:Alt]」を選択し、「Insert」をクリックします。Pが2つの[Alt]キー・アクションの間に挿入され、[Alt]+[P]が生成されます。

Insert

キーストロークの組合せにキーストロークを追加します。


「Matching」タブ

「Matching」タブ （Windowsログオン・フォームの構成用）

「Matching」（Windows）タブは、現在選択しているログオンのユーザー資格証明を同じアプリケーション内の他のログオン・フォーム、パスワード変更フォームまたはパスワード確認フォームにマップする場合に使用します （ここでは、これらのフォームをターゲット・フォームと呼びます）。エージェントは、ユーザー指定の一致基準を使用して、同じ資格証明データを使用する類似フォームを区別します。 これにより、エージェントは1組のユーザー資格証明をこのような複数のフォームに適切に適用できます。また、マッチングを使用して、エージェントで無視するフォームを識別できます。

次のいずれかを実行します。

  • 新しい一致基準を作成するには、「Add」をクリックします。

    または

  • 「Match」を選択し、「Edit」をクリックします。

「Matching」ダイアログ・ボックスが表示されます。

一致基準を作成する最も簡単で効率的な方法は、「Control Match」ウィザードを使用することです。ウィザードを使用すると、ターゲット・フォーム自体から要素を選択して、一致基準を指定できます。また、手動で一致基準を作成および変更することもできます。


ウィンドウ・クラスの選択

ウィンドウ[Class]の選択

「Select Window」ダイアログ・ボックスでは、画面上のウィンドウのクラス名を選択できます。 このダイアログ・ボックスを使用して、エージェントが許可または無視するウィンドウ・クラスを指定します。

「Select Window」ダイアログ・ボックスは、「Miscellaneous」タブ（Windowsログオン用）で、次のいずれかのオプションを選択した場合に表示されます。

  • Allowable Class: エージェントがログオン実行時に存在する必要がある、ログオンまたはパスワード変更ウィンドウ・クラスを選択します。
  • Ignore this Window Class: 資格証明フィールドの検索時に無視されるべき、ログオンまたはパスワード変更ウィンドウ・クラスを選択します。
コントロール
Window List | 現在のアプリケーションのウィンドウを表示します。列ヘッダーをクリックすると、リストがソートされます。
Show hidden window | 非表示のウィンドウを「Window List」に含める場合に選択します。