MySQL Enterprise Monitor 8.0.16 Manual

3.2.4 MySQL Enterprise Monitor Repository

MySQL Enterprise Service Manager requires a repository to store its data. The installer optionally installs a local, clean repository for this purpose. However, you can choose not to install the bundled MySQL Server and use another repository instead. This repository can be installed on the same machine as MySQL Enterprise Service Manager, or on a remote machine.

Important

It is strongly recommended that you use the bundled MySQL instance as MySQL Enterprise Monitor's repository. Only use an external repository if you have a compelling business reason for doing so.

The bundled MySQL instance has been comprehensively tested and tuned for use with MySQL Enterprise Service Manager

MySQL Enterprise Monitor upgrade installer can only upgrade a bundled MySQL, not an external one.

The various scripts delivered with MySQL Enterprise Service Manager only work with the bundled MySQL instance.

If you intend to use an alternative MySQL instance for your MySQL Enterprise Service Manager repository, the repository instance must be present before starting MySQL Enterprise Monitor installation.

Important

It is strongly recommended you use a clean installation of MySQL Server as the Enterprise Service Manager repository and do not use this server for any other purpose.

You must make several configuration changes to enable it for use as the repository.

Ensure the following:

You must ensure the following in the MySQL Server configuration:

Important

If you are using a MySQL Server repository other than the installation bundled with MySQL Enterprise Service Manager installation, the installer checks your MySQL Server for the following, minimum requirements:

  • MySQL Server version: versions older then MySQL 5.7.9 are not supported.

    If you intend to use MySQL 8, it is not possible to use any version preceding MySQL 8.0.13. That is, it is not possible to use 8.0.0 to 8.0.4 as repository.

  • SSL: SSL must be enabled on the MySQL Server.

  • For MySQL 5.7, innodb_file_format: innodb_file_format must be set to barracuda. This variable is deprecated in MySQL 8 and is not checked.

  • innodb_file_per_table: innodb_file_per_table must be enabled.

  • Solaris platforms: the Oracle Developer Studio 12.6 Runtime libraries must be installed.

    For more information, see Installing MySQL on Solaris Using a Solaris PKG.

If any checks fail, the installer displays an error and cannot proceed until the configuration is corrected.

The upgrade process performs the same checks.

To check your repository for compatibility, before upgrading, use MySQL Enterprise Service Manager configuration utility. For more information, see Section 10.1, “Service Manager Configuration Utilities”.