Stellent.IBPM.Interop.Common.ActionModifiers

Objects
ActionModifierLibrarian
ActionModifiers
IActionModifier
SelectItem
SelectItems
Verb
Verbs

Constants
VerbType


ActionModifierLibrarian

ActionModifierLibrarian Object

Provides the management for Action Modifiers

The ActionModifierLibrarian manages the ActionModifiers available on a given system. Its central function is when given a MIMEType, to hand out an ActionModifiers collection of ActionModifier objects which support that MIMEType.


ActionModifiers Property (ActionModifierLibrarian)

Returns an ActionModifiers collection filled with ActionModifier objects which matched the supplied Filter.

Settings and Return Values

Returns an Object value evaluating to an ActionModifiers collection

Remarks

This property is read-only.


EnumMimeTypes method

method EnumMimeTypes

Return Type

A Variant value.

Return Type

A Boolean value.

Syntax

object.EnumMimeTypes

The EnumMimeTypes method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type ActionModifierLibrarian.


SetMIMEFilter method

method SetMIMEFilter

Return Type

A Boolean value.

Syntax

object.SetMIMEFilter(newVal As Variant)

The SetMIMEFilter method syntax has these parts:

Part | Description
object | An expression evaluating to an object of type ActionModifierLibrarian.
newVal | Variant


ActionModifiers

ActionModifiers Collection

A collection of ActionModifier objects matching a given filter criteria.

An ActionModifiers collection is always obtained from the ActionModiferLibrarian ActionModifiers property. The librarian fills the collection matching the pre-specified Filter.


Item Method (ActionModifiers)

Indicates a specific member of a collection by ordinal number.

Return Type

Returns an object.

Syntax

Set object = collection.Item ( Index )

Parameters

Part | Description
Index | A long expression that evaluated to the ordinal number of an object in a collection.

Remarks

Use the Item property to return a specific object in a collection. The index for a collection always starts at one and goes up to the value of the collections Count Property. If Item cannot find an object in the collection corresponding to the Index argument, an error occurs. The Item property is the default property for all collections; therefore, the following syntax forms are interchangeable:

collection.Item (Index)

collection (Index)


Count Property (ActionModifiers)

Indicates the number of objects in a collection.

Return Value

Returns a Long value.

Remarks

Use the Count property to determine how many objects are in a given collection.

Because numbering for members of a collection begins with one, you should always code loops starting with the one member and ending with the value of the Count. If you are using Microsoft Visual Basic and want to loop through the members of a collection without checking the Count property, use the For Each...Next command.

If the Count property is zero, there are no objects in the collection.


IActionModifier

IActionModifier Object

The IActionModifier interface defines how an Action Modifier interacts with IBPM.

This interface is the base interface that describes the minimum required functionality for an Action Modifier. In general, Action Modifier implementations will extend this interface with implementation-specific features.

This interface allows an Action Modifier to provide basic information about itself.


Caption Property (IActionModifier)

Represents the display name of the Action Modifier.

Settings and Return Values

Returns a String value.

Remarks

This property is read-only


Description Property (IActionModifier)

Represents a textual description of the Action Modifier.

Settings and Return Values

Returns a String value.

Remarks

This property is read-only.


Picture Property (IActionModifier)

Provides an icon that can be used to graphically represent the Action Modifier.

Settings and Return Values

Returns an object reference that evaluates to a Picture object.

Remarks

This property is read-only


ToolTipText Property (IActionModifier)

Represents a short textual description of the Action Modifier that is suitable for use as a Tool Tip.

Settings and Return Values

Returns a String value.

Remarks

This property is read-only


Verbs Property (IActionModifier)

Represents the collection of Verbs that are applicable to the specified SelectItem.

Syntax

verbs = object.Verbs(UserToken As UserToken, SelectItem As SelectItem, Context As String, MultiSelect As Boolean)

Parameters

Part | Description
UserToken | The active UserToken.
SelectItem | A document against which all returned Verbs should be applicable.
Context | Reserved for future use
MultiSelect | An indication of whether or not the returned Verbs should be able to accept a SelectItems collection (as opposed to a single SelectItem) when invoked

Remarks

This property is read-only.


SelectItem

SelectItem Object

A item selected to be sent to an ActionModifier verb.


Description Property (SelectItem)

Sets a textual description for the SelectItem.

Settings and Return Values

Sets or returns a String value.

Remarks

None


DocumentId Property (SelectItem)

Sets a DocumentId object for the SelectItem.

Settings and Return Values

Sets or returns an Object value evaluating to a DocumentId object.

Remarks

None


IndexId Property (SelectItem)

Sets a IndexId object for the SelectItem.

Settings and Return Values

Sets or returns an Object value evaluating to a IndexId object.

Remarks

None


MetaData Property (SelectItem)

Sets a Dictionary object containing any additional data which an Action Handler may optionally use.

Settings and Return Values

Sets or returns an Object value evaluating to a Dictionary object.

Remarks

None


SelectItems

SelectItems Collection

Represents the list of items for which an action is to be invoked.

The container must build up a collection of select items, to pass into Verb.Invoke method. The items in the collection will represent the item on which the verb action is to occur.


Add Method (SelectItems)

Adds an item to a SelectItems collection.

Return Type

None

Syntax

object.Add(SelectItem As Object)

Parameters

Part | Description
SelectItem | An object reference evaluating to a SelectItems object.


Item Method (SelectItems)

Indicates a specific member of a collection by ordinal number.

Return Type

Returns an object.

Syntax

Set object = collection.Item ( Index )

Parameters

Part | Description
Index | A Long expression that evaluates to the ordinal number of an object in a collection.

Remarks

Use the Item property to return a specific object in a collection. The index for a collection always starts at one and goes up to the value of the collections Count Property. If Item cannot find an object in the collection corresponding to the Index argument, an error occurs. The Item property is the default property for all collections; therefore, the following syntax forms are interchangeable:

collection.Item (Index)

collection (Index)


Remove Method (SelectItems)

Removes a SelectItem object from the collection, specified by ordinal number

Return Type

None

Syntax

object.Remove(Index As Long)

Parameters

Part | Description
Index | A Long value specifying the item to be removed


RemoveAll Method (SelectItems)

Clears the collection of all SelectItem objects.

Return Type

None

Syntax

object.RemoveAll ()


Count Property (SelectItems)

Indicates the number of objects in a collection.

Settings and Return Values

Returns a Long value.

Remarks

Use the Count property to determine how many objects are in a given collection.

Because numbering for members of a collection begins with one, you should always code loops starting with one and ending with the value of the Count. If you are using Microsoft Visual Basic and want to loop through the members of a collection without checking the Count property, use the For Each...Next command.

If the Count property is zero, there are no objects in the collection.

This property is read only.


Verb

Verb Object

Represents an action which can be performed on a given set of Documents.


Invoke Method (Verb)

Invokes the Verb action.

Return Type

None

Syntax

object.Invoke(UserToken as Object, SelectItems As Object)

Parameters

Part | Description
UserToken | The active UserToken.
SelectItems | An object reference evaluating to a SelectItems object.

Remarks

None


Caption Property (Verb)

A text string that the container application may optionally use to display caption text associated with the verb.

Settings and Return Values

Sets and returns an String value.

Remarks

This property is typically used as the menu item text for the verb. This property is a Read Only property that returns what has been coded into the IActionModifier

This property should only be set from within an ActionModifer implementation.


Description Property (Verb)

A text string that the container application may optionally use to display description text associated with the verb.

Settings and Return Values

Sets and returns an String value.

Remarks

This property should only be set from within and ActionModifer implementation. This property is a Read Only property that returns what has been coded into the IActionModifier.


InvokeHelper Property (Verb)

A helper object to which the Verb can defer its Invoke functionality.

Settings and Return Values

An object reference evaluating to IVerbInvokeHelper.

Remarks

By default, Verb.Invoke interprets the VerbId property as a MessageId for Tag Message that is to be sent to an action handler tool. This is useful if the desired verb behavior has a tool already associated with the action and the tool can receive the message (i.e. some sort of viewer tool.) Since the message is sent through IBPM Messaging, the tool must set up to listen for the message.

There are instances where the handling of the verb does not require any sort of external tool, or the tool itself cannot be message enabled. In this case the ActionModifier implementer can also implement an IVerbInvokeHelper. The ActionModifier would then set the InvokeHelper property on the Verb at the time it is handing out the Verbs collection. Once the container calls the Verb.Invoke, the verb will then defer the handling of the action to the helper, rather than sending the message.


Picture Property (Verb)

A picture object that the container application may optionally use to display an icon next to the verb selection.

Settings and Return Values

Sets and returns an object reference which evaluates to an IPicture.

Remarks

This property should only be set from within and ActionModifer implementation. This property is a Read Only property that returns what has been coded into the IActionModifier.


ToolTipText Property (Verb)

A text string that the container application may optionally use to display tool tip text associated with the verb.

Settings and Return Values

Sets and returns a String Value.

Remarks

This property should only be set from within and ActionModifer implementation. This property is a Read Only property that returns what has been coded into the IActionModifier.


Type Property (Verb)

Settings and Return Values

Returns a VerbType value.

Remarks

This property allows the verb type to be associated with a default action within the hosting application. For instance, Verb types of otOpen are generally associated with a double click operation. Verbs of type otCustom have no pre-determined meaning.


VerbId Property (Verb)

A unique identifier for the Verb.

Settings and Return Values

Sets and returns a String value.

Remarks

This property is primarily used to uniquely identify the Verb. If no InvokeHelper is supplied, by default Verb.Invoke interprets VerbId as the MessageId for the TagMsg that is to be sent to the Action Handler tool associated with this verb.


Verbs

Verbs Collection

The collection of Verb objects as provided by an ActionModifier.


Add Method (Verbs)

Adds a new verb to a Verbs collection.

Return Type

Returns an object reference evaluation to a Verb object.

Syntax

object.Add(VerbType As VerbType)

Parameters

Part | Description
VerbType | VerbType


Item Method

Item Method (Verbs)

Indicates a specific member of a collection by ordinal number.

Return Type

Returns an object.

Syntax

Set object = collection.Item ( Index )

Parameters

Part | Description
Index | A long expression that evaluates to the ordinal number of an object in a collection.

Remarks

Use the Item property to return a specific object in a collection. The index for a collection always starts at one and goes up to the value of the collections Count Property. If Item cannot find an object in the collection corresponding to the Index argument, an error occurs. The Item property is the default property for all collections; therefore, the following syntax forms are interchangeable:

collection.Item (Index)

collection (Index)


Remove Method (Verbs)

Remove Method

Removes a Verb object from the collection, specified by ordinal number.

Return Type

None

Syntax

object.Remove(Index As Long)

Parameters

Part | Description
Index | A long value specifying the item to be removed.


RemoveAll Method (Verbs)

Removes all Verbs from the collection.

Return Type

None

Syntax

object.RemoveAll

Parameters

None


Count Property (Verbs)

Indicates the number of objects in a collection.

Return Value

Returns a Long value.

Remarks

Use the Count property to determine how many objects are in a given collection.

Because numbering for members of a collection begins with one, you should always code loops starting with the one member and ending with the value of the Count. If you are using Microsoft Visual Basic and want to loop through the members of a collection without checking the Count property, use the For Each...Next command.

If the Count property is zero, there are no objects in the collection.


VerbType enumeration

Members

Constant | Value
vtCustom | 0
vtOpen | 1
vtPrint | 2


IMIMETypeActionModifier

IMIMETypeActionModifier Object

The IMIMETypeActionModifier interface is an extension of the IActionModifier interface that is specific to documents that can be identified via a MIMEType.


Caption Property (IMIMETypeActionModifier)

Represents the display name of the Action Modifier.

Settings and Return Values

Returns a String value.

Remarks

This property is read-only.


Description Property (IMIMETypeActionModifier)

Represents a textual description of the Action Modifier.

Settings and Return Values

Returns a String value.

Remarks

This property is read-only.


Picture Property (IMIMETypeActionModifier)

Provides an icon that can be used to graphically represent the Action Modifier.

Settings and Return Values

Returns an object reference that evaluates to a Picture object.

Remarks

This property is read-only.


SupportedMIMETypes Property (IMIMETypeActionModifier)

Represents the MIME types supported by the IMIMETypeActionModifier.

Settings and Return Values

Returns an array of Strings indicating the supported MIME types.

Remarks

This property is read-only.


ToolTipText Property (IMIMETypeActionModifier)

Represents a short textual description of the Action Modifier that is suitable for use as a Tool Tip.

Settings and Return Values

Returns a String value.

Remarks

This property is read-only.


Verbs Property (IMIMETypeActionModifier)

Represents the collection of Verbs that are applicable to the specified SelectItem.

Syntax

verbs = object.Verbs(UserToken As UserToken, SelectItem As SelectItem, Context As String, MultiSelect As Boolean)

Parameters

Part | Description
UserToken | The active UserToken.
SelectItem | A document against which all returned Verbs should be applicable.
Context | Reserved for future use
MultiSelect | An indication of whether or not the returned Verbs should be able to accept a SelectItems collection (as opposed to a single SelectItem) when invoked

Remarks

This property is read-only.


IVerbInvokeHelper

IVerbInvokeHelper Interface

The Interface for supporting a custom Verb.Invoke implementation.


Invoke (IVerbInvokeHelper)

Invoke Method (IVerbInvokeHelper)

Invoke is a method used to perform the action.

Return Type

None

Syntax

Set object = collection.Invoke ( )

Parameters

Part | Description
UserToken | The active UserToken.
SelectItems | The selected documents upon which to invoke the action.
Verb | The action to invoke.

Remarks

None


otFilterType Enumeration

Members

Constant | Value
otFilterType_MIME | 0