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This document provides late-breaking information as well as information that is not yet part of the formal documentation.

This document contains the following sections:

	
Changes for Release 3.0 from Release 2.1.1


	
Supported TimesTen releases and platforms


	
Prerequisites


	
Known problems and limitations






Changes for Release 3.0 from Release 2.1.1

	
When you use a named connection to connect to a TimesTen database, you no longer have to select the Save Password check box in the connection's New/Select Database Connection dialog box to view the DDL statement for any database element such as a table or view in the element's SQL tab.


	
You no longer have to select the Save Password check box in a named connection's New/Select Database Connection dialog box to perform any cache group operations such as creating or loading a cache group.






New features in Release 3.0

	
You can use the Schema Browser for filtering and narrowing the list of objects displayed.


	
You can create and drop internal and external TimesTen database users. You can grant system privileges to a new user that you are creating. You can grant system privileges to or revoke system privileges from an existing user. You can change the password of an existing internal user.


	
You can generate the following TimesTen reports:

	
Data source attribute settings and database version


	
Names of all database objects accessible to the user connected to the TimesTen database


	
Count of all database objects by owner and type accessible to the user connected to the TimesTen database


	
Names of all public and private synonyms


	
Program unit arguments, source code search and source code line counts for PL/SQL packages, procedures and functions


	
System and object privileges granted to the user connected to the TimesTen database


	
Privileges granted to the PUBLIC role


	
Names of all tables and columns accessible to the user connected to the TimesTen database


	
Names of all tables owned by the user connected to the TimesTen database


	
Listing of all internal and external database users


	
Names of all indexes owned by the user connected to the TimesTen database


	
Names of all indexes accessible to the user connected to the TimesTen database





	
You can create and drop private synonyms. You can export the definition of a private synonym to a file or to SQL Worksheet. You can display the details of a private synonym.


	
You can create and drop public synonyms. You can display the details of a public synonym.


	
You can create and drop materialized view logs. You can display the details of a materialized view log.


	
You can create a hash index when:

	
Adding a primary key to a table


	
Changing the type of index on the columns of a table's existing primary key





	
You can cache an Oracle table that has a unique index but no primary key defined on it.


	
You can cache an Oracle private synonym.


	
You can update table and column statistics used by the query optimizer for all tables owned by the user connected to the TimesTen database.


	
You can compile invalid or all PL/SQL packages, procedures and functions.


	
You can specify cascade delete when adding a foreign key to a table.


	
You can view and update the data in a table's column using display editors. You can use text editor, binary editor, or Date and Timestamp editor to update data in the data grid.











Supported TimesTen releases and platforms

SQL Developer 3.0 is available on 32-bit and 64-bit Microsoft Windows and Linux systems. SQL Developer 3.0 supports Oracle TimesTen In-Memory Database and Oracle In-Memory Database Cache Releases 11.2.1.4.0 and later, and can be used to connect to a TimesTen database that resides on any platform that is supported by the TimesTen software.






Prerequisites

Before you can use SQL Developer to connect to a TimesTen database:

	
Install 11.2.1.4.0 or later release of the TimesTen Data Manager or TimesTen Client on the same system as SQL Developer. If SQL Developer will be used to connect to a local database, at minimum install the TimesTen Data Manager on the same system as SQL Developer. If SQL Developer will be used to connect to a remote database, at minimum install the TimesTen Client on the same system as SQL Developer.


	
Execute the TimesTen_install_dir/bin/ttenv.sh or TimesTen_install_dir/bin/ttenv.csh shell script on Linux systems, or the TimesTen_install_dir\bin\ttenv.bat batch file on Microsoft Windows systems to set the TimesTen environment variables before starting SQL Developer.


	
Make sure the CLASSPATH environment variable includes the proper TimesTen JDBC driver file (TimesTen_install_dir/lib/ttjdbc6.jar on Linux systems or TimesTen_install_dir\lib\ttjdbc6.jar on Microsoft Windows systems). SQL Developer 3.0 requires Java Development Kit (JDK) 6 be installed.









Known problems and limitations

	
If you do not select "Autocommit," then TimesTen SQL operations within the Connections navigator are not always automatically committed. You must issue an explicit commit by either selecting Commit or by issuing the commit command in SQL Worksheet. If TimesTen encounters errors in your transaction, you must explicitly roll back the transaction by either selecting Rollback or by issuing the rollback command in SQL Worksheet.

If "Autocommit" is selected, then TimesTen SQL operations within the Connections navigator are automatically committed. A transaction in the SQL Worksheet is also automatically committed if there are no open tables in the transaction. If there are open tables, then the transaction in the worksheet is not automatically committed and you must issue an explicit commit by either selecting Commit or by issuing the commit command in SQL Worksheet.

To enable "Autocommit," select Tools > Preferences. In the Preferences dialog box, click the + to the left of the Database node to expand the node and select Advanced.


	
Setting the passthrough level to a value other than 0 can affect the SQL operations in the Connections navigator. Make sure this setting is reset to 0 when switching from issuing passthrough operations in SQL Worksheet back to the Connections navigator.

You can also create an unshared worksheet which uses a separate database connection from the Connections navigator so that a particular passthrough level setting applies only to that worksheet. From a shared worksheet, click the Unshared SQL Worksheet icon or press Ctrl+Shift+N to create an unshared worksheet.


	
If you click the + to the left of the Indexes node to view the list of indexes and then click the name of the index with the characteristics you want to view, you cannot view the index's DDL statement, because the SQL tab is missing. To view the CREATE INDEX statement, from the index's underlying table or materialized view, click the SQL tab.


	
TimesTen error 2963 (Inconsistent datatypes: (NUMBER,CHAR) are not compatible in expression) is returned when you attempt specify a numeric value filter on a numeric column. To specify a filter value for a numeric column, click the + to the left of the Tables node to view the list of tables, and then click the name of a table that contains a numeric column. In the Data tab of the table, click the name of a numeric column. In the Filter field, enter a numeric value and press the Enter key.


	
Before you export data from a table in a format that is compatible with the TimesTen ttBulkCp utility, set the format for DATE and TIMESTAMP data using the following instructions:

	
Select Tools > Preferences.


	
In the Preferences dialog box click the + to the left of the Database node to expand the node.


	
Select NLS.


	
In the Date Format field, specify RRRR-MM-DD


	
In the Timestamp Format field, specify DD-MON-RRRR HH24:MI:SSXFF




To export data from a table in a format that the ttBulkCp utility recognizes, right-click the name of the table and select Unload. After you select Unload, step 1 (Source/Destination) of the Unload Wizard appears. In the Format drop-down menu, select ttbulkcp. After you complete step 1, click the Next button to advance to step 2 (Specify Data) of the Unload Wizard. After you complete step 2, click the Next button to advance to step 3 (Unload Summary). Click the Finish button to complete the data export operation.

You can change the DATE and TIMESTAMP data format back to their original settings after the data has been exported.


	
In TimesTen 11g releases up to and including 11.2.1.5, a user that has not been granted the ADMIN privilege cannot create PL/SQL objects such as procedures, functions and packages even if the user has been granted the CREATE PROCEDURE or CREATE ANY PROCEDURE privilege. The workaround is to grant the SELECT privilege on the SYS.SYSTEM_PRIVILEGE_MAP system table to the PUBLIC role.


	
In TimesTen 11g releases up to and including 11.2.1.4, an "agent status cannot be determined" error is returned when you attempt to start the cache agent or the replication agent as a user that has not been granted the ADMIN privilege. The same error is returned when you attempt to perform an operation that is to be processed by the cache agent such as loading or refreshing a cache group.

In TimesTen Releases 11.2.1.5.0 and later, granting the CACHE_MANAGER privilege to the user is sufficient to perform these operations.


	
The hierarchical profile and debugging of PL/SQL procedures and functions in a TimesTen database are not supported.









Documentation Accessibility

Our goal is to make Oracle products, services, and supporting documentation accessible to all users, including users that are disabled. To that end, our documentation includes features that make information available to users of assistive technology. This documentation is available in HTML format, and contains markup to facilitate access by the disabled community. Accessibility standards will continue to evolve over time, and Oracle is actively engaged with other market-leading technology vendors to address technical obstacles so that our documentation can be accessible to all of our customers. For more information, visit the Oracle Accessibility Program Web site at http://www.oracle.com/accessibility/.


Accessibility of Code Examples in Documentation

Screen readers may not always correctly read the code examples in this document. The conventions for writing code require that closing braces should appear on an otherwise empty line; however, some screen readers may not always read a line of text that consists solely of a bracket or brace.


Accessibility of Links to External Web Sites in Documentation

This documentation may contain links to Web sites of other companies or organizations that Oracle does not own or control. Oracle neither evaluates nor makes any representations regarding the accessibility of these Web sites.


Access to Oracle Support

Oracle customers have access to electronic support through My Oracle Support. For information, visit http://www.oracle.com/support/contact.html or visit http://www.oracle.com/accessibility/support.html if you are hearing impaired.
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Oracle Legal Notices

Copyright Notice

Copyright © 1994-2014, Oracle and/or its affiliates. All rights reserved.

Trademark Notice

Oracle and Java are registered trademarks of Oracle and/or its affiliates. Other names may be trademarks of their respective owners.

Intel and Intel Xeon are trademarks or registered trademarks of Intel Corporation. All SPARC trademarks are used under license and are trademarks or registered trademarks of SPARC International, Inc. AMD, Opteron, the AMD logo, and the AMD Opteron logo are trademarks or registered trademarks of Advanced Micro Devices. UNIX is a registered trademark of The Open Group.

License Restrictions Warranty/Consequential Damages Disclaimer
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Warranty Disclaimer
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Restricted Rights Notice

If this is software or related documentation that is delivered to the U.S. Government or anyone licensing it on behalf of the U.S. Government, the following notice is applicable:
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Hazardous Applications Notice

This software or hardware is developed for general use in a variety of information management applications. It is not developed or intended for use in any inherently dangerous applications, including applications that may create a risk of personal injury. If you use this software or hardware in dangerous applications, then you shall be responsible to take all appropriate fail-safe, backup, redundancy, and other measures to ensure its safe use. Oracle Corporation and its affiliates disclaim any liability for any damages caused by use of this software or hardware in dangerous applications.

Third-Party Content, Products, and Services Disclaimer

This software or hardware and documentation may provide access to or information on content, products, and services from third parties. Oracle Corporation and its affiliates are not responsible for and expressly disclaim all warranties of any kind with respect to third-party content, products, and services. Oracle Corporation and its affiliates will not be responsible for any loss, costs, or damages incurred due to your access to or use of third-party content, products, or services.

Alpha and Beta Draft Documentation Notice

If this document is in preproduction status:

This documentation is in preproduction status and is intended for demonstration and preliminary use only. It may not be specific to the hardware on which you are using the software. Oracle Corporation and its affiliates are not responsible for and expressly disclaim all warranties of any kind with respect to this documentation and will not be responsible for any loss, costs, or damages incurred due to the use of this documentation.
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