
Part No. E12898-03

Copyright © 1996, 2009, Oracle and/or its affiliates. All rights reserved.

Primary Author: Mildred Wang
Contributing Author: Melody Yang
Contributor: Mohan Arthur, Sachin Kothe, Jayalaxmi Muralidharan, Ramkumar Sekar

Oracle is a registered trademark of Oracle Corporation and/or its affiliates. Other names may be trademarks of their respective owners.

This software and related documentation are provided under a license agreement containing restrictions on use and disclosure and are protected by intellectual property laws. Except as expressly permitted in your license agreement or allowed by law, you may not use, copy, reproduce, translate, broadcast, modify, license, transmit, distribute, exhibit, perform, publish or display any part, in any form, or by any means. Reverse engineering, disassembly, or decompilation of this software, unless required by law for interoperability, is prohibited.

The information contained herein is subject to change without notice and is not warranted to be error-free. If you find any errors, please report them to us in writing.

If this software or related documentation is delivered to the U.S. Government or anyone licensing it on behalf of the U.S. Government, the following notice is applicable:

U.S. GOVERNMENT RIGHTS
Programs, software, databases, and related documentation and technical data delivered to U.S. Government customers are “commercial computer software” or “commercial technical data” pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As such, the use, duplication, disclosure, modification, and adaptation shall be subject to the restrictions and license terms set forth in the applicable Government contract, and, to the extent applicable by the terms of the Government contract, the additional rights set forth in FAR 52.227-19, Commercial Computer Software License (December 2007). Oracle USA, Inc., 500 Oracle Parkway, Redwood City, CA 94065.

This software is developed for general use in a variety of information management applications. It is not developed or intended for use in any inherently dangerous applications, including applications which may create a risk of personal injury. If you use this software in dangerous applications, then you shall be responsible to take all appropriate fail-safe, backup, redundancy and other measures to ensure the safe use of this software. Oracle Corporation and its affiliates disclaim any liability for any damages caused by use of this software in dangerous applications.

This software and documentation may provide access to or information on content, products and services from third parties. Oracle Corporation and its affiliates are not responsible for and expressly disclaim all warranties of any kind with respect to third party content, products and services. Oracle Corporation and its affiliates will not be responsible for any loss, costs, or damages incurred due to your access to or use of third party content, products or services.
Contents

Send Us Your Comments

Preface

1 Implementing the Oracle CRM Technology Foundation
   Implementing the Oracle CRM Technology Foundation........................................... 1-1

2 Understanding the System Administrator Console
   System Administrator Console Overview........................................................................ 2-1
   Understanding Security.................................................................................................. 2-1
   Understanding the Interapplication Bar.......................................................................... 2-3
   Understanding Cache.................................................................................................... 2-5
   Understanding Declarative Page Flows.......................................................................... 2-5
   Understanding Declarative Components......................................................................... 2-6

3 Using the Security Subtab
   Managing Security........................................................................................................ 3-1
   Managing Permissions.................................................................................................... 3-1
   Creating Permissions..................................................................................................... 3-2
   Assigning a Permission to Roles.................................................................................... 3-3
   Managing Roles............................................................................................................. 3-4
   Creating Roles............................................................................................................... 3-5
   Mapping Permissions to a Role....................................................................................... 3-5

4 Using the Site Preferences Subtab
   Setting Up the Interapplication Bar.............................................................................. 4-1
5 Using the System Subtab
 Using the System Subtab........................................................................... 5-1
 Setting Up Sessions...................................................................................... 5-1
 Setting Up Cookies...................................................................................... 5-2
 Setting Up the Self Service User................................................................. 5-2
 Setting Up Property Categories................................................................. 5-3
 Setting Up Password Expiration............................................................... 5-4
 Managing Properties.................................................................................. 5-4
 Editing the Details of Keys......................................................................... 5-4
 Setting Up Page Flow Logging................................................................. 5-5
 Viewing Page Flow Logging Reports....................................................... 5-6
 Migrating Page Flow Data.......................................................................... 5-7
 Setting Page Flow Buffer Size and Flush Interval..................................... 5-8

6 Using the Deployment Tab
 Viewing Jserv Statistics.............................................................................. 6-1

7 Using the Declarative Page Flows Subtab
 Using Declarative Page Flows.................................................................... 7-1
 Managing Physical Pages............................................................................ 7-2
 Editing Physical Page Details................................................................. 7-2
 Managing Logical Pages........................................................................... 7-3
 Editing Logical Page Details......................................................... 7-4
 Managing Rules......................................................................................... 7-5
 Editing Rule Details.................................................................................. 7-6
 Managing Business Flows................................................................. 7-7
 Editing Business Flow Details............................................................. 7-8
 Creating a New Business Flow................................................................. 7-8
 Updating an Existing Business Flow...................................................... 7-9
 Creating Flow Branches........................................................................... 7-10
 Duplicating Business Flows................................................................. 7-11
 Viewing Flow Versions........................................................................... 7-12

8 Using the Declarative Components Subtab
 Using Declarative Components.................................................................. 8-1
 Managing Components............................................................................ 8-2
Send Us Your Comments

Part No. E12898-03

Oracle welcomes customers’ comments and suggestions on the quality and usefulness of this document. Your feedback is important, and helps us to best meet your needs as a user of our products. For example:

- Are the implementation steps correct and complete?
- Did you understand the context of the procedures?
- Did you find any errors in the information?
- Does the structure of the information help you with your tasks?
- Do you need different information or graphics? If so, where, and in what format?
- Are the examples correct? Do you need more examples?

If you find any errors or have any other suggestions for improvement, then please tell us your name, the name of the company who has licensed our products, the title and part number of the documentation and the chapter, section, and page number (if available).

Note: Before sending us your comments, you might like to check that you have the latest version of the document and if any concerns are already addressed. To do this, access the new Oracle E-Business Suite Release Online Documentation CD available on My Oracle Support and www.oracle.com. It contains the most current Documentation Library plus all documents revised or released recently.

Send your comments to us using the electronic mail address: appsdoc_us@oracle.com

Please give your name, address, electronic mail address, and telephone number (optional).

If you need assistance with Oracle software, then please contact your support representative or Oracle Support Services.

If you require training or instruction in using Oracle software, then please contact your Oracle local office and inquire about our Oracle University offerings. A list of Oracle offices is available on our Web site at www.oracle.com.
Preface

Intended Audience


This guide assumes you have a working knowledge of the following:

- The principles and customary practices of your business area.
- Computer desktop application usage and terminology.

If you have never used Oracle E-Business Suite, we suggest you attend one or more of the Oracle E-Business Suite training classes available through Oracle University.

See Related Information Sources on page x for more Oracle E-Business Suite product information.

Deaf/Hard of Hearing Access to Oracle Support Services

To reach Oracle Support Services, use a telecommunications relay service (TRS) to call Oracle Support at 1.800.223.1711. An Oracle Support Services engineer will handle technical issues and provide customer support according to the Oracle service request process. Information about TRS is available at http://www.fcc.gov/cgb/consumerfacts/trs.html, and a list of phone numbers is available at http://www.fcc.gov/cgb/dro/trsphonebk.html.

Documentation Accessibility

Our goal is to make Oracle products, services, and supporting documentation accessible to all users, including users that are disabled. To that end, our documentation includes features that make information available to users of assistive technology. This documentation is available in HTML format, and contains markup to facilitate access by
the disabled community. Accessibility standards will continue to evolve over time, and Oracle is actively engaged with other market-leading technology vendors to address technical obstacles so that our documentation can be accessible to all of our customers. For more information, visit the Oracle Accessibility Program Web site at http://www.oracle.com/accessibility/.

Accessibility of Code Examples in Documentation

Screen readers may not always correctly read the code examples in this document. The conventions for writing code require that closing braces should appear on an otherwise empty line; however, some screen readers may not always read a line of text that consists solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation

This documentation may contain links to Web sites of other companies or organizations that Oracle does not own or control. Oracle neither evaluates nor makes any representations regarding the accessibility of these Web sites.

Structure

1 Implementing the Oracle CRM Technology Foundation
2 Understanding the System Administrator Console
3 Using the Security Subtab
4 Using the Site Preferences Subtab
5 Using the System Subtab
6 Using the Deployment Tab
7 Using the Declarative Page Flows Subtab
8 Using the Declarative Components Subtab
9 Using the Homepage Subtab
10 Setting Profile Options

Related Information Sources

This book is included on the Oracle E-Business Suite Documentation Library, which is supplied in the Release 12.1 Media Pack. You can download soft-copy documentation as PDF files from the Oracle Technology Network at http://www.oracle.com/technology/documentation/. The Oracle E-Business Suite Release 12.1 Documentation Library contains the latest information, including any documents that have changed significantly between releases. If substantial changes to this book are necessary, a revised version will be made available on the “virtual” documentation library on My Oracle Support (formerly OracleMetaLink).

If this guide refers you to other Oracle E-Business Suite documentation, use only the latest Release 12.1 versions of those guides.

Online Documentation
All Oracle E-Business Suite documentation is available online (HTML or PDF).

- **Online Help** - Online help patches (HTML) are available on My Oracle Support.

- **PDF Documentation** - See the Oracle E-Business Suite Documentation Library for current PDF documentation for your product with each release. The Oracle E-Business Suite Documentation Library is also available on My Oracle Support and is updated frequently.

- **Release Notes** - For information about changes in this release, including new features, known issues, and other details, see the release notes for the relevant product, available on My Oracle Support.


**Related Guides**

You should have the following related books on hand. Depending on the requirements of your particular installation, you may also need additional manuals or guides.

**Oracle E-Business Suite System Administrator's Guide Documentation Set**


This guide explains how to navigate, enter data, query, and run reports using the user interface (UI) of Oracle E-Business Suite. This guide also includes information on setting user profiles, as well as running and reviewing concurrent requests.

**Integration Repository**

The Oracle Integration Repository is a compilation of information about the service endpoints exposed by the Oracle E-Business Suite of applications. It provides a
complete catalog of Oracle E-Business Suite's business service interfaces. The tool lets users easily discover and deploy the appropriate business service interface for integration with any system, application, or business partner.

The Oracle Integration Repository is shipped as part of the E-Business Suite. As your instance is patched, the repository is automatically updated with content appropriate for the precise revisions of interfaces in your environment.

Do Not Use Database Tools to Modify Oracle E-Business Suite Data

Oracle STRONGLY RECOMMENDS that you never use SQL*Plus, Oracle Data Browser, database triggers, or any other tool to modify Oracle E-Business Suite data unless otherwise instructed.

Oracle provides powerful tools you can use to create, store, change, retrieve, and maintain information in an Oracle database. But if you use Oracle tools such as SQL*Plus to modify Oracle E-Business Suite data, you risk destroying the integrity of your data and you lose the ability to audit changes to your data.

Because Oracle E-Business Suite tables are interrelated, any change you make using an Oracle E-Business Suite form can update many tables at once. But when you modify Oracle E-Business Suite data using anything other than Oracle E-Business Suite, you may change a row in one table without making corresponding changes in related tables. If your tables get out of synchronization with each other, you risk retrieving erroneous information and you risk unpredictable results throughout Oracle E-Business Suite.

When you use Oracle E-Business Suite to modify your data, Oracle E-Business Suite automatically checks that your changes are valid. Oracle E-Business Suite also keeps track of who changes information. If you enter information into database tables using database tools, you may store invalid information. You also lose the ability to track who has changed your information because SQL*Plus and other database tools do not keep a record of changes.
Implementing the Oracle CRM Technology Foundation

Introduction
The Oracle CRM Technology Foundation (JTT) provides Java-based infrastructure software that is used to develop e-business solutions such as Sales, Marketing, Service, e-Commerce, Contracts, and Interaction Center applications. It offers a common platform for developing applications with HTML and Java. It also provides user-friendly screens for centralized setup and administration. This web-based interface is called the System Administrator Console.

This chapter describes how to successfully implement the Oracle CRM Technology Foundation. The rest of this manual describes how to work successfully with the System Administrator Console.

Implementation Summary
The implementation process for the Oracle CRM Technology Foundation includes the following tasks:
• Changing the System Administrator Password
• (Optional) Configuring System Settings
• (Optional) Configuring Display Preferences
• (Optional) Implementing Custom Style Sheets
Changing the System Administrator Password

Upon shipment, the system administrator identity has "sysadmin" as both its user name and its password. We strongly recommend that you change the password immediately after installation is completed. For information on how to change passwords, please see: Changing Your Password, page 10-2.

Configuring System Settings

For information on how to define system-level properties such as sessions, cookies, and logging, please refer to Using the System Subtab, page 5-1.

Configuring Display Preferences

For information on how to set up display preferences such as language, currency, and time zone, please see Setting Display Preferences, page 10-1.

Implementing Custom Style Sheets

This is an optional procedure.

Style Sheet Profile Option

After a user logs in, the style sheet used for the UI is determined by the value of the profile \texttt{JTF\_PROFILE\_DEFAULT\_CSS}. This profile can have values at site level, responsibility level or user level. The site level value is set to \texttt{jtfucss.css} by default. A system administrator can set values based on site, responsibilities, or users.

Users and Style Sheets

If enabled, users can select a style sheet from the user profile page. Users reach this page by navigating from the Profile link to Display Preferences > Display Style. The style sheet that a user chooses is saved as a user-level value of the profile \texttt{JTF\_PROFILE\_DEFAULT\_CSS}. If a value is set at the user level, that overrides the responsibility or site level value.

To create a list of available style sheets on the user profile page, the system administrator creates a type of Application Object Library Lookups named \texttt{JTF\_STYLE\_SHEET\_LOOKUP\_TYPE} through Oracle JInitiator. The User Name of the type can be any name meaningful to the system administrator, but the type must exactly be \texttt{JTF\_STYLE\_SHEET\_LOOKUP\_TYPE}. The application this type belongs to is usually CRM Foundation. This look-up type may have multiple codes.

Each code of this type represents a style sheet. The meaning of the code is displayed in the drop-down list on the user profile page. For example, say a code named \texttt{mystyle.css} has the meaning \textbf{My Personal Style} as its meaning, and another code named \texttt{teamstyle.css} has the meaning \textbf{Team Style}. In this case, users will see \textbf{My Personal}
Style and Team Style in the Display Style drop-down list. If a certain user selects the style My Personal Style, then from that point on the stylesheet mystyle.css is used.

Note that setting profile values or lookup data requires you to stop and restart the Java server for changes to take effect. In contrast, making a style sheet choice on the user profile page takes effect immediately.
Understanding the System Administrator Console

System Administrator Console Overview

The System Administrator Console is a Web-based user interface that is associated with the system administrator responsibility. It is used during the development, implementation, and maintenance phases of an application or deployment. During the development phase, developers and consultants use the System Administrator Console to seed out-of-the-box capabilities and features. These include, but are not limited to, users, permissions, roles, session parameters, page flows, and diagnostic tests. During the implementation phase, consultants or implementation engineers use the System Administrator Console to configure out-of-the-box capabilities and features to meet the particular needs of each customer deployment. During the maintenance phase, IT professionals use the System Administrator Console to troubleshoot deployment problems, tune deployment performance, and monitor system activity.

Features are divided into the following areas for the System Administrator Console:

- Users
- Settings, including Security, Site Preferences, and System.
- Deployment, including System Statistics
- Design, including Page Flows, Declarative Components, and Homepage

For information on setting up users, see the Oracle CRM User Management and Spreadtable online help available under Applied Technology in the Contents tab.

Understanding Security

In the Security subtab, which is located under the Settings tab, you can control access to application resources and view security-related alerts.
This section offers an introduction to Security Framework concepts. For step-by-step instructions on how to use the Security screens, please see the topic Managing Security, page 3-1.

**Terminology**

The following table explains important Security concepts.

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Permission</td>
<td>A permission is a unit of privilege that is granted to a user. It usually serves to grant a certain type of access to a resource. Resources are application elements such as JSP pages, objects, or methods of objects. A resource can have unique permissions for each way that it can be accessed. A permission is implemented as a string. If a resource is protected by a permission, then any user accessing the resource must have the permission required to access it. Permission names are case-sensitive. Permissions cannot be directly assigned to users. Instead, permissions are grouped into roles and roles are then assigned to users. In the Security subtab, you can view, create, and delete permissions. You can also specify which permissions are mapped to each role, and vice versa.</td>
</tr>
</tbody>
</table>
Understanding the System Administrator Console

Term | Definition
--- | ---
Roles | A role is a group of permissions which can be assigned to a user. Like permissions, roles are implemented as strings. Role names are not case-sensitive. For example, let’s suppose there is a JSP page "abc.jsp" that requires the permission "PERM_ABC." A user logs in and tries to access abc.jsp, but he or she can’t do that unless he or she has permission "PERM_ABC." You want the user to be able to access the page, so you assign the role "ROLE_ABC" (which contains permission "PERM_ABC") to the user. When given the appropriate role, the user is able to access the page. In the Security subtab, you can view, create, and delete roles. You can also specify which roles are mapped to each permission, and vice versa.

Understanding the Interapplication Bar

In the Site Preferences subtab, which is located under the Settings tab, you can set up the Interapplication Bar.

This section offers an introduction to Interapplication Bar concepts. For step-by-step instructions on how to use the Interapplication Bar screens, please see the topic Setting Up the Interapplication Bar, page 4-1.

Terminology

The following table explains important Interapplication Bar concepts.
### Interapplication Bar Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Interapplication Bar</td>
<td>The Interapplication Bar (also sometimes referred to as the Application Switcher) allows end users to seamlessly switch between applications within the E-Business Suite. It is a set of customizable links that displays at the top of every page in HTML-based CRM applications. Each customizable link is called a &quot;navigation group.&quot; For example, a system administrator might want to create a navigation group called &quot;Sales.&quot; In the System Administrator Console, he or she can map sales-related applications such as Sales Online, TeleSales, and Sales Compensation to the navigation group called &quot;Sales.&quot; (Similarly, he or she could create a navigation group called &quot;Marketing&quot; and map applications such as Marketing Online, iMarketing, and Campaign Management to it.) When an end user logs in who has responsibilities for sales applications, the end user will see &quot;Sales&quot; as a link in the Interapplication Bar. In the Profile screens, the end user can configure which responsibility he or she wants to associate with the &quot;Sales&quot; navigation group. From then on, when the end user is working in the E-Business Suite, he or she can click the &quot;Sales&quot; link at any time to easily switch to his or her sales responsibility.</td>
</tr>
<tr>
<td>Navigation Group</td>
<td>A navigation group is a customizable group of applications with defined responsibility settings. Each navigation group is represented as a link within the Interapplication Bar. In the Site Preferences subtab, you (as the system administrator) can map CRM applications into navigation groups. Additionally, from the navigation group setup screen, you can create, delete, activate, deactivate, and specify the display order of navigation groups. After you have set up navigation groups for a deployment, based on their granted responsibilities, end users will be able to associate each navigation group with one of their responsibilities.</td>
</tr>
</tbody>
</table>
Understanding Cache

For information on using the cache features, see Caching Framework, Oracle E-Business Suite System Administrator’s Guide - Configuration.

Understanding Declarative Page Flows

In the Declarative Page Flow subtab, which is located under the Design tab, you can set up and manage the components of the Declarative Page Flows Framework: Physical Pages, Logical Pages, Rules, and Business Flows.


Overview

The Declarative Page Flows Framework enables you to customize, upgrade, and troubleshoot the content and flow of JSPs within an application without making any modifications to actual code. The Declarative Page Flows Framework is based on the abstraction of JSPs into named logical entities. Consequently, you can achieve efficient management of content and flows by utilizing the screens provided in the System Administrator Console.

Terminology

The following table explains important Declarative Page Flow concepts.

### Declarative Page Flow Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Physical Page</td>
<td>The name of a JavaServer Page (JSP). In the Declarative Flows subtab, you can view, register, and modify Physical Pages.</td>
</tr>
<tr>
<td>Logical Page</td>
<td>A named logical entity that has one or more Physical Pages mapped to it. Usually, each Logical Page represents a node within a Business Flow. In the Declarative Flows subtab, you can view, create, and modify Logical Pages.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Rule</td>
<td>A rule is defined by parameters and conditions and determines which Physical Page needs to be rendered or which Logical Page needs to display next. Rules evaluate to true when all of their conditions evaluate to true. You can utilize Rules to customize the page-to-page behavior of a Business Flow. In the Declarative Flows subtab, you can view, create, and modify Rules.</td>
</tr>
<tr>
<td>Business Flow</td>
<td>A sequential set of linked Logical Pages that usually corresponds to a business task. Business Flows can be linear or nonlinear, depending on whether or not there are context-sensitive conditions. Branching conditions are evaluated at each node. In the Declarative Flows subtab, you can view, create, modify, clone, and preview Business Flows.</td>
</tr>
<tr>
<td>Flow Cloning</td>
<td>In order to facilitate the easy upgrade of business flows which have been customized by a customer, a business flow can be cloned, thus creating a Flow Family of related business flows. In the Declarative Flows subtab, the Clone Flow screen allows you to generate duplicates of a given flow.</td>
</tr>
<tr>
<td>Flow Families</td>
<td>A flow family consists of an original business flow, a clone of the original business flow, and any customized clones which have been made. In the Declarative Flows subtab, the Flow Families screen allows you to view the contents of a Flow Family and select which flow is active.</td>
</tr>
</tbody>
</table>

**Understanding Declarative Components**

In the **Declarative Components** subtab, which is located under the **Design** tab, you can create and manage declarative UI components (Bins, Graphs, Reports, Graph/Report combinations, and LOVs) and their security settings.

This section offers an introduction to Declarative Components concepts. For step-by-step instructions on how to use the Declarative Components screens, please see...
Overview

The Declarative Components Framework allows you to quickly build UI components that display application-specific data in personalizable Bins, Graphs, Reports, Graph/Reports, or LOVs. The coding requirements are minimal to nonexistent and the components can be published on Oracle applications.

Terminology

The following table explains important Declarative Components concepts.

### Declarative Components Terms

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Metadata</td>
<td>The Declarative Components Framework relies on the accurate definition of metadata. The framework uses the metadata to capture information about component headers, footers, columns, and other attributes. In the Declarative Components subtab, you can define the metadata for bins, reports, graphs, graph/report combinations, LOVs, and parameters.</td>
</tr>
<tr>
<td>Bin</td>
<td>Bins are small reports which display high level summary information in a tabular format. They generally display information regarding a single metric, such as “time period.” If enabled and the appropriate security features are assigned, you can choose which bins to display on the home page and also choose the order in which multiple bins are displayed. In the Declarative Components subtab, you can view, create, modify, and remove Bins.</td>
</tr>
<tr>
<td>Report</td>
<td>Reports are similar to bins. They display information in a tabular format. In the Declarative Components subtab, you can view, create, modify, and remove Reports. Optionally, you can do the same for Graph/Report combinations.</td>
</tr>
<tr>
<td>Term</td>
<td>Definition</td>
</tr>
<tr>
<td>------</td>
<td>------------</td>
</tr>
<tr>
<td>Graph</td>
<td>A graph is a diagram that represents data pictorially. In the Declarative Components subtab, you can view, create, modify, and remove Graphs. Optionally, you can do the same for Graph/Report combinations.</td>
</tr>
<tr>
<td>LOV</td>
<td>The LOVs that you create can be used across applications. LOV means &quot;list of values.&quot; It is a UI component that facilitates the completion of a text entry field when there are numerous values that may be assigned. LOVs are a useful alternative to drop-down lists, particularly in cases where displaying a long list of selections in a drop-down list would require excessive scrolling. In short, when using a LOV to complete a text entry field, you type a query into the field and then click a button labeled &quot;Go.&quot; This opens a screen where you view a list of values that match the query you submitted. You can then select the value that you desire and return to the original screen, where what you selected will populate the original text entry field. In the Declarative Components subtab, you can view, create, modify, and remove LOVs.</td>
</tr>
</tbody>
</table>
Using the Security Subtab

Managing Security

You can perform the following tasks from the Security subtab:

- Managing Permissions, page 3-1
  - Creating Permissions, page 3-2
  - Assigning a Permission to Roles, page 3-3
- Managing Roles, page 3-4
  - Creating Roles, page 3-5
  - Mapping Permissions to a Role, page 3-5

For an introduction to Security concepts, please see Understanding Security, page 2-1.

Managing Permissions

Use this procedure to manage permissions. A permission has a name and a description. For an introduction to permissions and roles, please see Understanding Security, page 2-1.

Warning: Do not remove the predefined permissions that are built into the System Administrator Console. These predefined permissions are essential for stable and reliable performance of all Oracle CRM modules. Removal of these permissions could cause serious or fatal performance problems.
Steps:
1. In the Settings tab, navigate to Security > Access Controls > Permissions.

2. If you want to create a new permission, then click Create. This opens the page where you edit the details of a new permission.

3. If you want to search for a permission, then:
   1. Type a search phrase into the Find Permission field.
   2. Click Go to display the search results.

4. To change which rows display in the table, you have the following options:
   1. Click the Previous or Next buttons.
   2. Choose an entry range from the drop-down list.

5. If you want to assign a permission to roles, then click the name of a permission in the table. This opens the page where you assign a permission to roles.

6. If you want to delete a permission, then:
   1. Select the appropriate check box in the Remove column of the table.
   2. Click Update to save.

   The permission is removed.

Related Topics
Creating Permissions, page 3-2
Assigning a Permission to Roles, page 3-3
Managing Security, page 3-1

Creating Permissions

Use this procedure to create a new permission. For an introduction to permissions and roles, please see Understanding Security, page 2-1.

Steps:
1. In the Settings tab, navigate to Security > Access Controls > Permissions, then click Create.
2. Type a new permission name into the **Name** field. The first two or three letters of a permission name correspond to the module shortcode. Permission names must be unique.

3. Type a description of the permission into the **Description** field.

4. Click **Create** to save your work. The new permission is filed in alphabetical order.

**Related Topics**

- Managing Permissions, page 3-1
- Assigning a Permission to Roles, page 3-3
- Managing Security, page 3-1

**Assigning a Permission to Roles**

Use this procedure to assign a permission to one or more roles. For an introduction to permissions and roles, please see **Understanding Security**, page 2-1.

**Steps:**

1. In the **Settings** tab, navigate to **Security > Access Controls > Permissions**, then click the name of a permission in the table.

2. Choose the name of a role in one list and click > or < to move it to the other list.

3. Repeat step 2 as desired.

4. If you want to move all items in the **Available Roles** list to the **Assigned Roles** list, then click >>. This assigns the permission to all roles.

5. If you want to move all items in the **Assigned Roles** list to the **Available Roles** list, then click <<. This removes the permission from all roles.

6. Optionally, click **Restore** to reset the fields to their original values.

7. Click **Update** to save. The permission will be assigned to the roles specified in the **Assigned Roles** list.

**Related Topics**

- Creating Permissions, page 3-2
- Managing Permissions, page 3-1
- Managing Security, page 3-1
Managing Roles

Use this procedure to manage roles. A role is a grouping of one or more permissions. For an introduction to permissions and roles, please see Understanding Security, page 2-1.

**Step:**
1. In the Settings tab, navigate to Security > Access Controls > Roles.

2. If you want to create a new role, then click Create. This opens the page where you edit the details of a new role.

3. If you want to search for a role, then:
   1. Type a search phrase into the Find Role field.
   2. Click Go to display the search results.

4. To change which rows display in the table, you have the following options:
   1. Click the Previous or Next buttons.
   2. Choose an entry range from the drop-down list.

5. If you want to map permissions to a particular role, then click an entry in the Name column of the table. This opens the page where you map permissions to a role.

6. If you want to delete a role, then:
   1. Select the appropriate check box in the Remove column of the table. If the check box is disabled, then you cannot remove the role. For example, seeded roles cannot be deleted.
   2. Click Update to save.
   3. You will be asked to confirm that you want to delete the role. To cancel, click Cancel. To delete the role, click Update.

      The role is removed and revoked from all users who are assigned to the role.

**Related Topics**

Creating Roles, page 3-5
Mapping Permissions to a Role, page 3-5
Managing Security, page 3-1
Creating Roles

Use this procedure to create a new role. For an introduction to permissions and roles, please see Understanding Security, page 2-1.

Step:
1. In the Settings tab, navigate to Security > Access Controls > Roles, then click Create.
2. Type a new role name into the Name field.
   The first two or three letters of a role name correspond to the module shortcode. Role names must be unique.
3. Type a description of the role into the Description field.
4. Click Create to save. The new role is filed in alphabetical order.

Related Topics

Mapping Permissions to a Role, page 3-5
Managing Roles, page 3-4
Managing Security, page 3-1

Mapping Permissions to a Role

Use this procedure to map permissions to a role. A role is a grouping of one or more permissions. For an introduction to permissions and roles, please see Understanding Security, page 2-1.

Steps:
1. In the Settings tab, navigate to Security > Access Controls > Roles, then click the name of a role in the table.
2. Choose the name of a permission in one list and click > or < to move it to the other list.
3. Repeat step 2 as desired.
4. If you want to move all items in the Available Permissions list to the Assigned Permissions list, then click >>. This assigns the role to all permissions.
5. If you want to move all items in the Assigned Permissions list to the Available
Permissions list, then click <<. This removes the role from all permissions.

6. Click Update to save.

Related Topics

Creating Roles, page 3-5
Managing Roles, page 3-4
Managing Security, page 3-1
Using the Site Preferences Subtab

Setting Up the Interapplication Bar

You can perform the following tasks from the Site Preferences subtab:

• Setting Up Navigation Groups, page 4-1

• Editing Navigation Group Details, page 4-2

For an introduction to the Interapplication Bar, please see the topic Understanding the Interapplication Bar, page 2-3.

Setting Up Navigation Groups

Use the following procedure to set up navigation groups, which represent customizable sets of applications with defined responsibility settings. They act as links in the Interapplication Bar. The Interapplication Bar is the set of navigation groups that displays at the top of every page in HTML-based CRM applications. For an introduction to the Interapplication Bar, please see the topic Understanding the Interapplication Bar, page 2-3.

Steps:
1. In the Settings tab, navigate to Site Preferences > Interapplication Bar > Navigation Group Setup.

2. To create a new navigation group, do the following:
   1. Type a name and description into an empty row in the table.

   2. In the Status column, choose Active from the drop-down list if you want the navigation group to display in the Interapplication Bar. Choose Inactive if you do not want it to display.
3. In the **Display Order** column, use the drop-down list to select the navigation group's placement in the Interapplication Bar.

   If a navigation group called "Sales" is has a display order of 0, one called "Marketing" has a display order of 1, and another called "Service" has a display order of 2, then the Interapplication Bar will look like the following: **Sales**
   **Marketing**  **Service**, provided the end user has responsibilities within all three navigation groups. (For example, if the end user does not have any responsibilities for service applications, then he or she will not see **Service**.)
   (Note that if your deployment is in a language that reads from right to left, then 0 will set the navigation group at the far right hand side of the screen, and so on.)

4. Click **Update** to save your work.

5. Click the icon in the **Detail** column to map CRM applications to this navigation group.

3. To edit an existing navigation group, please see steps 2b - 2e.

4. To delete a navigation group from the table, do the following:
   1. Select the check box in the **Remove** column that corresponds to the navigation group that you want to delete.
   2. Click **Update**.

**Related Topics**

**Editing Navigation Group Details**, page 4-2

**Editing Navigation Group Details**

Use this procedure to map CRM applications to navigation groups. A navigation group is a customizable set of applications with defined responsibility settings that is launched when you click its link in the Interapplication Bar. The Interapplication Bar displays at the top of every page in HTML-based CRM applications. For an introduction to the Interapplication Bar, please see the topic Understanding the Interapplication Bar, page 2-3.

**Steps:**

1. There are two ways to access this page:
   - In the **Settings** tab, navigate to **Site Preferences > Interapplication Bar > Navigation Group Details**.
• In the Settings tab, navigate to Site Preferences > Interapplication Bar > Navigation Group Setup, then click the icon in the Detail column that corresponds to the navigation group you are working with.

2. If you came to this page by way of the first method above, then you will need to choose a navigation group from the drop-down list before you can begin selecting applications.

3. Choose the name of an application in one list and click > or < to move it to the other list.

4. Repeat step 3 as desired.

5. If you want to move all Available Applications to the Selected Applications list, then click >>.

6. If you want to move all Assigned Applications to the Selected Applications list, then click <<.

7. Click Update to save.

Related Topics
Setting Up Navigation Groups, page 4-1
Using the System Subtab

In the System subtab, you can define the system level properties that you need to set up during deployment. You can reconfigure the properties later as necessary.

You can perform the following tasks from the System subtab:

- Setting Up Sessions, page 5-1
- Setting Up Cookies, page 5-2
- Setting Up the Self Service User, page 5-2
- Setting Up Property Categories, page 5-3
- Managing Properties, page 5-4
- Editing the Details of Keys, page 5-4

**Note:** For information on logging, see the *Oracle E-Business Suite System Administrator’s Guide Documentation Set.*

Setting Up Sessions

Use this procedure to set up sessions. Sessions are a system property that carries user identity and credentials throughout the duration of a user’s activity. For security purposes, user sessions can be set to expire according to three rules:

- A specified number of hours has passed since the session began.
- A specified number of minutes has passed since the user’s last activity, such as
clicking a button. This setting is intended to prevent unauthorized users from taking advantage of an unattended session.

- A specified number of "hits" have occurred during the session. A hit means a user action such as submitting a query or clicking a link. This setting is also intended to limit damage in case of an intrusion.

### Setting Up Cookies

Use this procedure to set up cookies. Cookies are a system property that stores session information about users and systems.

**Steps:**

1. In the **Settings** tab, navigate to **System > Properties > Cookies**.

2. Use the drop-down list labeled **Mode** to set whether a browser cookie or URL rewriting is used.

   Browser cookies are the recommended setting, for the following reasons:
   - A cookie stores up to 4K of data, while a URL can only store 2K of data.
   - Using URL rewriting prohibits any customizations that rely on cookies. For example, some customized pages in the iStore application rely upon a cookie.

3. Type the encryption key into the **Encryption Key** field. Encryption keys are a means to protect the information stored in cookies. A key is usually an alphanumeric string of twenty to thirty characters.

4. Type a number into the **Expiration Time** field. This is the number of expiration units (time intervals) that pass before the cookie expires. Set the expiration unit below.

5. Choose **Day(s)**, **Hour(s)**, or **Minute(s)** from the **Expiration Unit** drop-down list.

6. Click **Update** to save.

**Related Topics**

Using the System Subtab, page 5-1

### Setting Up the Self Service User

Use this procedure to set up the self service user. You must set up the self service user after deploying applications. The self service user is also known as the "guest user." It
represents an internal user who is granted certain responsibilities and permissions so that new users can be given the appropriate responsibilities and permissions during the self-registration process.

**Steps:**
1. In the **Settings** tab, navigate to **System > Properties > Self Service User**.
2. Enter a name for the self service user and set a password. All three fields are required.
3. Click **Update** to save.

**Related Topics**

Using the System Subtab, page 5-1

**Setting Up Property Categories**

Use this procedure to set up applications in the system properties framework. In this procedure, you will assign roles to have either read or update permission for a given application (AKA category). For an introduction to permissions and roles, please see **Understanding Security**, page 2-1.

**Steps:**
1. In the **Settings** tab, navigate to **System > Properties > Category**.
2. Choose an application from the **Application Name** drop-down list.
   
   **Note:** This list displays the full names of applications (for example, "Oracle Enterprise Asset Management"). However, in the Properties screen where you manage properties, the drop-down list displays only the abbreviated application shortname (such as "EAM").

3. Choose **Read** or **Update** from the **READ/UPDATE** drop-down list, depending on what type of permission you will be granting.
4. Click **Next**. This opens the page where you can map the permission to one or more roles.

**Related Topics**

Using the System Subtab, page 5-1

Assigning a Permission to Roles, page 3-3
**Setting Up Password Expiration**

*Note:* This page no longer controls password expiration.

---

**Managing Properties**

Use this procedure to manage properties. A property is a key/value pair that is application-specific. A key is what is used by an application to retrieve data. Keys are unique, but can have multiple values. Values are the content or data that binds to a particular key. You can view, create, modify, delete, and copy properties.

**Steps:**
1. In the **Settings** tab, navigate to **System > Properties > Advanced**.
2. Choose a application shortname from the **View** drop-down list. The page will refresh to display the properties registered for that module.
   
   If your desired application shortname does not appear in the drop-down list, you will need to do the procedure Setting Up Property Categories, page 5-3.
3. If you want to create a key, then click **Create**. This opens the page where you specify the details of a new key.
4. If you want to view or modify the details of a key, then click a key name in the table. This opens the page where you view or edit the details of an existing key.
5. If you want to remove a key, then:
   1. Select the appropriate check box in the **Remove** column of the table.
   2. Click **Update** to save.

**Related Topics**

Using the System Subtab, page 5-1

Editing the Details of Keys, page 5-4

---

**Editing the Details of Keys**

Use this procedure to edit the details of new or existing keys. A property is a key/value pair that is application-specific. A key is what is used by an application to retrieve data. Keys are unique, but can have multiple values. Values are the content or data that binds
to a particular key.

**Steps:**

1. In the **Settings** tab, navigate to **System > Properties > Advanced**, then either click **Create** or click the name of a key in the table.

2. Type a key name into the **Key** field.

3. Edit the table.
   1. Type values into the **Value** fields as desired.
   2. Type sequence numbers into the **Sequence** fields as desired.
   3. If you want to remove a value, then select the appropriate check box in the **Remove** column.
   4. Optionally, click **More Rows** to add empty rows to the table.

4. If you want to resequence the key, then click **Resequence**.

5. If you want to copy the key, then click **Copy Key**.

6. If you are creating a new key and want to clear the fields, then click **Clear**.

7. If you are editing an existing key and want to restore the fields to their original settings, then click **Restore**.

8. Click **Update** to save.

**Related Topics**

- Using the System Subtab, page 5-1
- Managing Properties, page 5-4

**Setting Up Page Flow Logging**

Use this procedure to configure page flow logging.

**Steps:**

1. In the **Settings** tab, navigate to **System > Properties > Page Flow Logging > Configuration**.

2. To turn page flow logging on or off, use the **Enabled** drop-down list.
3. To specify which request attributes to log, check or uncheck the check boxes in the **Select Request Attributes to Log** area. You can choose to log one or more of the following request attributes for each application page that is accessed:

- Client browser information
- Application parameters
- Client language (character encoding, language, character set)
- JTF session cookie
- All other incoming HTTP headers
- All other incoming cookies

4. In the **Only log these Applications** area, you can specify which applications are logged. Use the arrow buttons to move application names between the **Disabled** list and the **Enabled** list.

5. In the **Only log these Business Flows** area, to specify which business flows are logged. Use the arrow buttons to move application names between the **Disabled** list and the **Enabled** list.

6. Click **Update** to save. Configuration changes will take effect when all the JVMs that use page flow logging are restarted.

**Related Topics**

- Using the System Subtab, page 5-1
- Viewing Page Flow Logging Reports, page 5-6
- Migrating Page Flow Data, page 5-7
- Setting Page Flow Buffer Size and Flush Interval, page 5-8

**Viewing Page Flow Logging Reports**

Use this procedure to view page flow logging reports.

**Note:** You must migrate the page flow data from a staging area to the mining area before the materialized views can be refreshed for UI reports. Please see the procedure Migrating Page Flow Data, page 5-7.
Steps:
1. To view the screen which displays the reports, in the Settings tab, navigate to System > Properties > Page Flow Logging > Reports.

2. Consult the tables provided to view data about application usage and middle-tier usage.

3. Optionally, to customize the dates that display in a table, click Edit. Using the date picker widgets provided, choose your desired date range and click Update to save.

4. If desired, you can drill down into the generated report table to view detailed reports on page hits, sessions, and users.

Related Topics
Using the System Subtab, page 5-1
Migrating Page Flow Data, page 5-7
Setting Page Flow Buffer Size and Flush Interval, page 5-8
Setting Up Page Flow Logging, page 5-5

Migrating Page Flow Data
Use this procedure to migrate page flow data. Page flow data is logged in the database in a staging area. This data needs to be migrated to the mining area before the materialized views can be refreshed for the UI reports.

Steps:
1. Log in to Forms (JInitiator) with the CRM Administrator, Vision Enterprises responsibility.

2. Navigate to Concurrent > Requests.

3. Double-click Requests.

4. Click Submit a New Request or Run.

5. Select Request Set.

6. Click OK.

7. In the Request field, enter Page Flow. Then press the Tab key on your keyboard to select Page Flow Data Migration and Refresh.
8. Schedule and submit the request.

What's Next

After the Concurrent Request-Set completes, you should be able to view the latest data reports and statistics in the System Administrator Console UI. To do so, please see the procedure Viewing Page Flow Logging Reports, page 5-6.

Related Topics

Using the System Subtab, page 5-1
Viewing Page Flow Logging Reports, page 5-6
Setting Page Flow Buffer Size and Flush Interval, page 5-8
Setting Up Page Flow Logging, page 5-5

Setting Page Flow Buffer Size and Flush Interval

Use this procedure to set the buffer size and flush interval for page flow logging. Page flow data is buffered within each JVM and periodically asynchronously flushed to the database. The flush is triggered by two parameters: a time interval and the maximum number of page log accesses in the buffer. The data is flushed to the database when the specified flush interval is reached, or when the number of page log accesses exceeds the configured buffer size.

Steps:
1. In the Settings tab, navigate to System > Advanced.
2. In the View field, select JTF.
3. In the Key column, find the property JTF_PF_BUFFER_SIZE.
4. To change the value from the default (5 page hits), click JTF_PF_BUFFER_SIZE and modify the value as desired. Click Update to save.
5. In the Key column, find the property JTF_PF_FLUSH_INTERVAL.
6. To change the value from the default (30 seconds), click JTF_PF_FLUSH_INTERVAL and modify the value as desired. Click Update to save.

Note: Your application JSPs must use the standard JTF JSP header and footer includes for the page hits to be logged. If your
application does not use the JTF include JSPs, then you can still use this feature. However, your JSPs will need to call the appropriate JTF APIs at the start and end of the HTTP request-response.

Related Topics

Using the System Subtab, page 5-1
Viewing Page Flow Logging Reports, page 5-6
Migrating Page Flow Data, page 5-7
Setting Up Page Flow Logging, page 5-5
Using the Deployment Tab

Viewing Jserv Statistics

Use this procedure to view the Jserv statistics of a particular host.

Steps:
1. In the Deployment tab, navigate to System Statistics > Jserv Statistics.
2. Select a node from the poplist.
3. The data provided is as follows:
   1. Memory: Displays the total amount of memory in the Java Virtual Machine and amount of free memory in the system.
   2. Threads: Displays the total number of active threads in the current thread’s thread group.
   3. Connection Pool: Displays the status of the database connection pool, including the maximum connection pool size, the current connection pool size, and the number of connections being used.
   4. Session: Displays information about the servlet session, including the number of stateful sessions, the number of concurrent user requests, the total number of ICX sessions, and the applications installed in this middle tier (specified by application short name).
   5. Services In Use: Displays information about each application, including the service descriptor, the maximum number of services, the number of current services, and the number of services in use.
Using the Declarative Page Flows Subtab

Using Declarative Page Flows

The Introduction page for Declarative Flows is the starting point for setting up and using Declarative Page Flows. The Declarative Page Flows framework enables you to customize, upgrade, and troubleshoot the content and flow of JSPs, without having to modify code. The key concept of the framework involves the abstraction of JSPs into named logical entities, called Logical Pages. The components of the Declarative Page Flows framework are Physical Pages, Logical Pages, Rules, and Business Flows.

You can perform the following tasks from the Declarative Page Flows subtab:

- Managing Physical Pages, page 7-2
  - Editing Physical Page Details, page 7-2

- Managing Logical Pages, page 7-3
  - Editing Logical Page Details, page 7-4

- Managing Rules, page 7-5
  - Editing Rule Details, page 7-6

- Managing Business Flows, page 7-7
  - Editing Business Flow Details, page 7-8
  - Creating Flow Branches, page 7-10
  - Duplicating Flows, page 7-11
  - Viewing Flow Versions, page 7-12

For an introduction to Declarative Page Flows concepts, please see Understanding
Managing Physical Pages

The main page for Physical Pages is the starting point for viewing, registering, and updating Physical Pages. Physical Pages are JavaServer Pages (JSPs). Use this procedure to manage Physical Pages. For an introduction to Declarative Page Flows concepts, please see Understanding Declarative Page Flows, page 2-5.

**Steps:**
1. In the Design tab, navigate to **Declarative Page Flows > Physical Pages**.
2. If you want to change which Physical Pages display in the table, then:
   1. To make Physical Pages from all applications to display in the table, then choose **All** from the drop-down list at the top of the table.
   2. If you want to filter the table by application, then choose a module prefix from the drop-down list labeled **View** at the top of the table.
   3. If you want to search the table of Physical Pages, then type the name of a Physical Page or part of the name of a Physical Page into the text input field.
   4. Click **Go**. The results display in the table.
3. If you want to register a Physical Page, then click **Create**. This opens the page where you edit the details of a new Physical Page.
4. If you want to update an existing Physical Page, then click its name in the table. This opens the page where you edit the details of an existing Physical Page.

**Related Topics**
- Editing Physical Page Details, page 7-2
- Using Declarative Page Flows, page 7-1

**Editing Physical Page Details**

On the details page for Physical Pages, you complete the procedures of either registering or updating Physical Pages. Use this procedure to edit the details of new or existing Physical Pages. For an introduction to Declarative Page Flows concepts, please see Understanding Declarative Page Flows, page 2-5.
**Steps:**
1. In the **Design** tab, navigate to **Declarative Page Flows > Physical Pages**, then either click **Create** to register a new page or click the name of a JSP to modify its details.

2. Type into the **Name** field to edit the name of the Physical Page.

3. Type into the **Description** field to edit the description of the Physical Page. This field is optional.

4. If you are registering a new Physical Page, then choose an application from the **Application** drop-down list. If you are updating an existing Physical Page, then you cannot edit this field. It is permanently set when you create the Physical Page.

5. If you are registering a new Physical Page, then click **Create** to save.

6. If you are updating an existing Physical Page, then click **Update** to save.

**Related Topics**
- Managing Physical Pages, page 7-2
- Using Declarative Page Flows, page 7-1

**Managing Logical Pages**

The main page for Logical Pages is the starting point for viewing, creating, and updating Logical Pages. Logical Pages can be utilized either stand-alone or to represent nodes in a Business Flow. One or more Physical Pages map to each Logical Page. Use this procedure to manage Logical Pages. For an introduction to Declarative Page Flows concepts, please see **Understanding Declarative Page Flows**, page 2-5.

**Steps:**
1. In the **Design** tab, navigate to **Declarative Page Flows > Logical Pages**.

2. If you want to change which Logical Pages display in the table, then:
   1. If you want to allow Physical Pages from all applications to display in the table, then choose **All** from the drop-down list labeled **View** at the top of the table.
   2. If you want to filter the table by application, then choose a module prefix from the drop-down list labeled **View** at the top of the table.
   3. If you want to search the table of Physical Pages, then type the name of a Physical Page or part of the name of a Physical Page into the text input field.
4. Click Go. The results display in the table.

3. If you want to create a Logical Page, then click Create. This opens the page where you edit the details of a new Logical Page.

4. If you want to update an existing Logical Page, then click its name in the table. This opens the page where you edit the details of an existing Logical Page.

Related Topics

Editing Logical Page Details, page 7-4
Using Declarative Page Flows, page 7-1

Editing Logical Page Details

On the details page for Logical Pages, you complete the procedures of either creating or updating Logical Pages. Use this procedure to edit the details of new or existing Logical Pages. For an introduction to Declarative Page Flows concepts, please see Understanding Declarative Page Flows, page 2-5.

Steps:
1. In the Design tab, navigate to Declarative Page Flows > Logical Pages, then either click Create or click a page name in the table.

2. Type into the Name field to edit the name of the Logical Page.

3. Type into the Description field to edit the description of the Logical Page. This field is optional.

4. If you are creating a new Logical Page, then choose an application from the Application drop-down list. If you are updating an existing Logical Page, then you cannot edit this field. It is permanently set when you create the Rule.

5. Edit the Page Controller field if you do not want to use the default Java class which is prefilled in the field. The class designated here implements the Logical Page Controller interface and provides values to evaluate Rules.

6. Type into the Default Physical Page field to edit the name of the Physical Page that displays when none of the Rules evaluate to true. Optionally, click Go to choose from a list of values.

7. Edit the Page Display Rules table; one row in the table represents one Rule:
   1. Type into the Sequence column to edit the order in which the Rules are
evaluated.

2. Type into the Rule Name column to edit the name of the Rule. Optionally, click Go to choose from a list of values.

3. Type into the Description column to edit the description of the Rule.

4. Type into the Physical column to edit the name of the Physical Page that is associated with the Rule. Optionally, click Go to choose from a list of values.

8. Repeat step 7 as desired.

9. Optionally, click Add Rows to add empty rows to the table.

10. If you are creating a new Logical Page, then click Create to save.

11. If you are updating an existing Logical Page, then click Update to save.

Related Topics

Managing Logical Pages, page 7-3
Using Declarative Page Flows, page 7-1

Managing Rules

The main page for Rules is the starting point for viewing, creating, and updating Rules. In the context of a Logical Page, Rules determine either what Physical Page needs to be rendered or what Logical Page displays next. Use this procedure to manage Rules. For an introduction to Declarative Page Flows concepts, please see Understanding Declarative Page Flows, page 2-5.

Steps:
1. In the Design tab, navigate to Declarative Page Flows > Rules.

2. If you want to change which Rules display in the table, then:
   1. If you want Rules from all applications to display in the table, then choose All from the drop-down list labeled View at the top of the table.

   2. If you want to filter the table by application, then choose a module prefix from the drop-down list labeled View at the top of the table.

   3. If you want to search the table of Rules, then type the name of a Rule or part of the name of a Rule into the text input field.
4. Click **Go**. The results display in the table.

3. If you want to create a Physical Page, then click **Create**. This opens the page where you edit the details of a new Rule.

4. If you want to update an existing Rule, then click its name in the table. This opens the page where you edit the details of an existing Rule.

**Related Topics**

- Editing Rule Details, page 7-6
- Using Declarative Page Flows, page 7-1

**Editing Rule Details**

On the details page for Rules, you complete the procedures of either creating or updating Rules. Use this procedure to edit the details of new or existing Rules. For an introduction to Declarative Page Flows concepts, please see Understanding Declarative Page Flows, page 2-5.

**Steps:**

1. In the **Design** tab, navigate to **Declarative Page Flows > Rules**, then either click **Create** or click a Rule name in the table.

2. Type into the **Name** field to edit the name of the Rule. If you are working with an existing Rule, then you cannot edit this field.

3. Type into the **Description** field to edit the description of the Rule. This field is optional.

4. If you are creating a new Rule, then choose an application from the **Application** drop-down list. If you are updating an existing Rule, then you cannot edit this field. It is permanently set when you create the Rule.

5. Edit the Rule Conditions table; one row in the table represents one Rule Condition:
   1. Type a parameter into the **Parameter** column.
   2. Choose an operator from the drop-down list in the **Condition** column.
   3. Type a value into the **Value** column.

6. Repeat step 5 as desired.
7. Optionally, click **Add Rows** to add empty rows to the table.

8. If you are creating a new Rule, then click **Create** to save.

9. If you are updating an existing Rule, then click **Update** to save.

**Related Topics**

- Managing Rules, page 7-5
- Using Declarative Page Flows, page 7-1

**Managing Business Flows**

The main page for Business Flows is the starting point for viewing, creating, updating, previewing, and cloning Business Flows. Business Flows are page display sequences that address specific business processes. For example, you can create a Business Flow for the process of purchasing an item from an online store, or you can create a Business Flow for the process of resolving a user’s service request. Business Flows can be either linear or branched in structure. Use this procedure to manage Business Flows. For an introduction to Declarative Page Flows concepts, please see Understanding Declarative Page Flows, page 2-5.

**Steps:**

1. In the **Design** tab, navigate to **Declarative Page Flows > Business Flows**.

2. If you want to change which Business Flows display in the table, then:
   
   1. If you want Business Flows from all applications to display in the table, then choose **All** from the drop-down list labeled **View** at the top of the table.
   
   2. If you want to filter the table by application, then choose a module prefix from the drop-down list labeled **View** at the top of the table.
   
   3. If you want to search the table of Business Flows, then type the name of a Business Flow or part of the name of a Business Flow into the text input field.

   4. Click **Go**. The results display in the table.

3. To update an existing Business Flow, click its name in the table.

4. To create a branch in this Business Flow, click the icon in the **Create Flow Branch** column.

5. To preview an existing Business Flow, click the icon in the **Preview** column.
6. To view the different versions of a flow, then click the icon in the View Versions column.

7. If you want to create a Business Flow, then click Create Flow.

8. If you want to create a duplicate of a flow, then click Duplicate Flow.

Related Topics

- Editing Business Flow Details, page 7-8
- Creating Flow Branches, page 7-10
- Duplicating Flows, page 7-11
- Viewing Flow Versions, page 7-12
- Using Declarative Page Flows, page 7-1

Editing Business Flow Details

On the details page for Business Flows, you can edit the basic settings of new or existing Business Flows. After using this page, you can open the Map Flows page to define the conditional branches in the Business Flow. Use one of the following procedures:

- Creating a New Business Flow, page 7-8
- Updating an Existing Business Flow, page 7-9

For an introduction to Declarative Page Flows concepts, please see Understanding Declarative Page Flows, page 2-5.

Creating a New Business Flow

Use this procedure to edit the basic settings of a new business flow. For an introduction to Declarative Page Flows concepts, please see Understanding Declarative Page Flows, page 2-5.

Steps:
1. In the Design tab, navigate to Declarative Page Flows > Business Flows, then click Create.

2. Type a flow name into the Name field.

3. Choose an application from the Application drop-down list.

4. Optionally, type a description into the Description field.
5. Optionally, select the **Secure** check box if the flow is to use HTTPS.

6. Edit the **Finalization Class** field if you want use a Java class other than the default Finalization Class (which is prefilled in the field). The class designated here implements the FlowFinalizer interface and executes at the end of the Business Flow.

7. Type the name of the Logical Page that should be invoked after the completion of the flow into the **Page to Display After Completing the Flow** field. Optionally, click **Go** to choose from a list of values.

8. Type the name of the first Logical Page in the flow into the **First Page of the Flow** field. Optionally, click **Go** to choose from a list of values.

9. Optionally, edit the **Default Flow Sequence** table; if the flow you are creating is linear, then complete this table. If the flow you are creating has conditional branches, then proceed to step 10.
   1. Type numbers into the **Sequence** fields to indicate the page order within the flow.
   2. Click **Go** to choose a Logical Page to set as the **Next Logical**. When you make your choice, the **Next Logical** and **Description** fields will automatically fill.
   3. Repeat step b as desired. If needed, click **Add Rows** to add additional rows to the table.

10. Click **Create** to save.

11. Click **Create Flow Branch**. This opens the page where you define the conditional branches of a nonlinear flow.

12. Optionally, click **View Flow Versions** to view all the versions of this business flow.

**Related Topics**

Managing Business Flows, page 7-7

Using Declarative Page Flows, page 7-1

**Updating an Existing Business Flow**

Use this procedure to edit the basic settings of an existing business flow. For an introduction to Declarative Page Flows concepts, please see Understanding Declarative Page Flows, page 2-5.
Steps:
1. In the Design tab, navigate to Declarative Page Flows > Business Flows, then click a flow name in the table.

2. Optionally, type a flow description into the Description field.

3. Optionally, select the Secure check box if the flow is to use HTTPS.

4. Type the name of the Finalization Class into the Finalization Class field. This is the name of a Java class. The class implements the FlowFinalizer interface and executes at the end of the Business Flow.

5. Type the name of the Logical Page that should be invoked after the completion of the flow into the Page to Display after Completing the Flow field. Optionally, click Go to choose from a list of values.

6. Type the name of the first Logical Page in the flow into the First Page of the Flow field. Optionally, click Go to choose from a list of values.

7. If the flow you are working with is linear (does not contain any conditional branches), then you can define the flow sequence in the Default Flow table.

8. Click Update to save.

9. If the flow you are working with is nonlinear (contains one or more conditional branches), then click Create Flow Branch to begin defining the branches of the flow.

10. To view the different versions of this flow, click View Flow Versions.

Related Topics
Managing Business Flows, page 7-7
Using Declarative Page Flows, page 7-1

Creating Flow Branches
Business Flows are page display sequences that address specific business processes. The Create Flow Branch page allows you to define conditional branches within nonlinear business flows. Use this procedure to set the sequences of Logical Pages within Business Flows. For an introduction to Declarative Page Flows concepts, please see Understanding Declarative Page Flows, page 2-5.

Steps:
1. Choose a Logical Page from the Current Logical drop-down list. The Current
Logical Page is the name of the Logical Page that you are setting up on this screen. After you save your work, you can repeat this entire procedure with another Logical Page within the Business Flow.

2. In the **Default Next Logical** field, type the name of the Logical Page that displays if there are no Rules in the table below, or if none of the Rules in the table below evaluate to "true." Optionally, click **Go** to choose from a list of values.

3. Edit the **Logical Node Rules** table.
   1. Type numbers into the **Sequence** fields to set the order in which the Rules are evaluated.
   2. In the **Next Logical** fields, type the name of the Logical Page that you want to display after the Current Logical Page, only if the Rule in the next column evaluates to "true." Optionally, click **Go** to choose from a list of values.
   3. In the **Rule Name** fields, type name of the Rule that controls whether or not the Logical Page in the previous column displays. Optionally, click **Go** to choose from a list of values.

4. Optionally, click **Add Rows** to add empty rows to the table.

5. If you are creating a new Current Logical Page setup, then click **Create** to save. This opens another **Create Flow Branch** page where you can repeat this entire procedure with another Current Logical Page.

6. If you are updating an existing Flow Branch setup, then click **Update** to save. This opens another **Create Flow Branch** page where you can repeat this entire procedure with another Current Logical Page.

7. If you have no more Current Logical Pages to set up, then click **Finish**. This completes the procedures of either creating or updating Business Flows.

**Related Topics**

- Managing Business Flows, page 7-7
- Using Declarative Page Flows, page 7-1

**Duplicating Business Flows**

Use this procedure to duplicate business flows. For an introduction to Declarative Page Flows concepts, please see Understanding Declarative Page Flows, page 2-5.
Steps:
1. In the Design tab, navigate to Declarative Page Flows > Business Flows, then click Duplicate Flow.

2. Click Go to choose the flow from a list of values. Edit the name of the flow if desired.

3. Click Duplicate to generate a duplicate of the flow. The Flow Details page automatically opens, where you can edit the details of the duplicate flow.

Related Topics
Managing Business Flows, page 7-7
Using Declarative Page Flows, page 7-1

Viewing Flow Versions
Use this procedure to view all of the versions of a given business flow. For an introduction to Declarative Page Flows concepts, please see Understanding Declarative Page Flows, page 2-5.

Steps:
1. Choose which of the flows will be "active" by selecting the appropriate radio button in the table.

2. Click Update to save.

3. Optionally, click a flow name in the table.
   This opens the page where you can edit the basic details of an existing flow.

Related Topics
Managing Business Flows, page 7-7
Using Declarative Page Flows, page 7-1
Using Declarative Components

The Declarative Components framework enables you to quickly develop bins, graphs, reports, graph/report combinations, and LOVs that can be personalized by end users. Key features of the Declarative Components framework include the uniform look and feel of all UI components, compatibility with multiple data sources, and built in security.

You can perform the following tasks from the Declarative Components subtab:

• Managing Components, page 8-2
  • Previewing Components, page 8-3

• Registering Components, page 8-4
  • Editing Component Metadata, page 8-5

• Defining Bin or Report Columns, page 8-8
  • Editing Bin or Report Column Details, page 8-9

• Managing LOV Columns, page 8-10
  • Editing LOV Column Details, page 8-11

• Defining Graph Metadata, page 8-13
  • Managing Graph Columns, page 8-16
    • Editing Graph Column Details, page 8-17

• Managing Parameters, page 8-18
Managing Components

The main page for Declarative Components is the starting point for viewing, creating, modifying, and previewing bins, graphs, reports, graph/report combinations, and LOVs. Use this procedure to manage Declarative Components. For an introduction to Declarative Components concepts, please see the topic Understanding Declarative Components, page 2-6.

Steps:

1. In the Design tab, navigate to Declarative Components > Components.

2. If you want to change the contents of the table, then:
   1. To filter the table by application, choose an application from the Application drop-down list at the top of the page.
   2. To filter the table by component type, then choose All or a component type from the drop-down list at the top of the page.
   3. If you want to search by component code, then type the component code into the text entry field and click Go.
   4. Click First, Previous, Next, and Last to navigate within the table.

3. If you want to create a component, then click Create. This opens the page where you register a new component.

4. If you want to preview a component, then click Preview. This opens the page where you preview a component.

5. If you want to update or modify a component, then click its component code in the
table. This opens the page where you update the registration of a component.

6. If you want to set the status of a component, then:
   1. In the **Action** column, choose **Remove, Enabled**, or **Disabled**.

   Removing a component deletes it. You cannot delete a LOV component if it is being used by other components. Enabling a component makes it available for display. Disabling a component makes it unavailable for display or for selection from the homepage.

   2. Click **Update** to save.

**Related Topics**

Previewing Components, page 8-3
Registering Components, page 8-4
Using Declarative Components, page 8-1

**Previewing Components**

Use this procedure to preview a declarative component. For an introduction to Declarative Components concepts, please see the topic Understanding Declarative Components, page 2-6.

**Steps:**

1. In the **Design** tab, navigate to **Declarative Components > Components**, then click **Preview**.

2. View the preview.

   In the case of a LOV component, the Preview does not have validations.

3. When you are finished, click **OK** to return to the main components page.

**Related Topics**

Managing Components, page 8-2
Registering Components, page 8-4
Using Declarative Components, page 8-1
Registering Components

Use this procedure to edit the registration details of a new or existing component. For an introduction to Declarative Components concepts, please see the topic Understanding Declarative Components, page 2-6.

Steps:

1. In the Design tab, navigate to Declarative Components > Components, then either click Create or click a component code in the table.

2. If you are creating a new component, then choose an application from the Application drop-down list at the top of the page. If you are updating an existing component, this field is not editable.

3. If you are creating a new component, then choose Bin, Report, Graph, Graph Report, or LOV from the Component Type drop-down list. If you are updating an existing component, this field is not editable.

4. If you are creating a new component, then type a component code into the Component Code field. If you are updating an existing component, this field is not editable.

   The maximum length of a component code is 26 characters. A component code must be unique and it cannot contain any spaces or nonalphanumeric characters except underscore (_). It is recommended to prefix the component code with the application short name. For example, JTF_component_code.

5. Type a descriptive component name into the Component Name field.

6. Optionally, type a description into the Description field.

   If you want to enable the component, then select the Enable check box. If you want to disable the component, then deselect the Enable check box. Enabling a component makes it available for display. Disabling a component makes it unavailable for display or for selection from the homepage.

7. If you want to allow the component to be a candidate for display as a Portlet in Oracle Portal, then select the Show as Portlet check box. If you deselect this check box, then the component will not be shown in the list of available components for Portlet enabling.

8. Optionally, type an image filename into the Image Filename field.

   If defined, this image is displayed with the Bin Title. The image that you specify must exist in the image file location (/OA_MEDIA/).

9. Ignore the Metadata Source area. The only choice for the Type field is AK. The
Declarative Components framework uses the AK Runtime Dictionary to store metadata.

10. Optionally, click **Restore** to restore the fields to their original settings.

11. Click **Update** to save.

12. Click **Next**. This opens the page where you can begin editing the metadata associated with this component.

**Related Topics**

- Managing Components, page 8-2
- Editing Component Metadata, page 8-5
- Using Declarative Components, page 8-1

**Editing Component Metadata**

Use this procedure to edit the Pre-Process type, Data Source, Title, and other general settings (such as headers and footers) of a new or existing Declarative Component. This procedure takes place after you have completed the Registering Components, page 8-4 procedure. For an introduction to Declarative Components concepts, please see the topic Understanding Declarative Components, page 2-6.

**Steps:**

1. Edit the **Pre-Process** area:
   
   1. If you want to execute a PL/SQL procedure or Java method before the Declarative Components framework extracts the data content for this component, then choose **Java Class Name** or **PL/SQL Procedure** from the **Type** drop-down list.
      
      If you do not require a preprocessing event, then leave this field blank and skip to step 2.

   2. Type the preprocessing PL/SQL procedure or Java method into the **Name** field. The procedure name should be of the format `procedure_name.package_name`, where the package name is the fully qualified package name.

2. Edit the **Data Source Provider** area:
   
   1. If you are editing a Bin, Report, Graph, or Graph Report, then choose **HTML**, **Class Name**, or **SQL Query** from the **Type** drop-down list.
      
      If you are editing a LOV component, then choose **Class Name** or **SQL Query**
2. Type HTML code, a SQL query, or the name of a Java class that implements the DataSource interface into the Name field. If you use a SQL query, then the SELECT statement must not end with a semicolon (;).

3. If you are editing a Bin, Report, Graph, or Graph Report, then edit the Custom Edit Link area. This feature is not available for LOVs.

   1. If you do not want a Custom Edit Link, then leave this section blank and skip to step 4. This generates the default Edit link that navigates you to the Personalization and Runtime Parameter section.

   2. If you want the Custom Edit Link to have a constant value, then choose Constant from the Type drop-down list.

   If you want the Custom Edit Link to be dynamically generated by a PL/SQL procedure or Java method, then choose PL/SQL or Java from the Type drop-down list.

   3. If the Custom Edit Link is constant, then type the name of the JSP file into the Name field. If the Custom Edit Link is dynamically generated, then type the name of the PL/SQL package.procedure or Java Class.method into the Name field.

      The PL/SQL procedure must take in a single DEFAULT NULL VARCHAR2 argument and return a VARCHAR2. The Java method should take in a ParameterList and return a String.

   4. If you do not want the Edit link to be generated, then choose Constant from in the Type drop-down list and leave the Name field blank.

4. Edit the Title area:

   1. If you want the component title to have a constant value, then choose Constant from the Type drop-down list.

   If you want the component title to be dynamically generated by a PL/SQL procedure or Java method, then choose PL/SQL or Java from the Type drop-down list.

   2. If the component title is constant, then type the title text into the Name field. If the component title is dynamically generated, then type the name of the PL/SQL procedure or Java method into the Name field.

      The PL/SQL procedure must return a value of the type VARCHAR2.

   3. Choose Left, Right, or Center from the Alignment drop-down list to set how...
the component title is aligned.

4. If you are editing a Bin, Report, Graph, or Graph Report and want to allow the end user to personalize the component title, then select the check box labeled Personalizable.

5. If you are editing a Bin, Report, Graph, or Graph Report, then edit the Header area. This feature is not available for LOVs:

1. If you want the header to have a constant value, then choose Constant from the Type drop-down list.

   If you want the header to be dynamically generated by a PL/SQL procedure or Java method, then choose PL/SQL or Java from the Type drop-down list.

2. If the header is constant, then type the text into the Name field. If the header is dynamically generated, then type the name of the PL/SQL procedure or Java method into the Name field.

   The PL/SQL procedure must return a value of the type VARCHAR2.

3. Choose Left, Right, or Center from the Alignment drop-down list to set how the header is aligned.

4. If you want to allow the end user to personalize the header, then select the check box labeled Personalizable.

6. If you are editing a Bin, Report, Graph, or Graph Report, then edit the Footer area. This feature is not available for LOVs:

1. If you want the footer to have a constant value, then choose Constant from the Type drop-down list.

   If you want the footer to be dynamically generated by a PL/SQL procedure or Java method, then choose PL/SQL or Java from the Type drop-down list.

2. If the footer is constant, then type the text into the Name field. If the footer is dynamically generated, then type the name of the PL/SQL procedure or Java method into the Name field.

   The PL/SQL procedure must return a value of the type VARCHAR2.

3. Choose Left, Right, or Center from the Alignment drop-down list to set how the footer is aligned.

4. If you want to allow the end user to personalize the footer, then select the check box labeled Personalizable.

7. Click Update to save.
8. Optionally, click Next to save and move on to screens where you can further define the columns and settings of the component.

Related Topics

Defining Bin or Report Columns, page 8-8
Managing LOV Columns, page 8-10
Defining Graph Metadata, page 8-13
Using Declarative Components, page 8-1

Defining Bin or Report Columns

Use this procedure to manage the columns in a new or existing bin or report component. This does not apply to components with a HTML Data Source Type. For an introduction to Declarative Components concepts, please see the topic Understanding Declarative Components, page 2-6.

Steps:

1. To navigate to this page:
   1. In the Design tab, navigate to Declarative Components > Components.
   2. Locate your desired bin or report in the table. Click its component code in the table.
   3. Click the Next button, once on the Component Registration page and again on the Component Metadata page to open the Component Columns page.

2. Select or deselect the check box labeled Number Of Rows to enable or disable allowing the end user to personalize the number of rows displayed.

3. Select or deselect the check box labeled Number Of Columns to enable or disable allowing the end user to personalize the number of columns displayed.

4. If you want to set the status of a column, then choose Enabled or Disabled from the Action column. Enabling a component makes it available for display. Disabling a component makes it unavailable for display.

5. Type integers into the Display Order column to set the display order (from left to right) of the columns in the Bin or Report. Make sure that the values of this field are sequential.

6. Click Update to save.
7. Optionally, click Next. This opens the page where you manage the parameters of the component.

8. If you want to edit the details of a column, then click its name in the table. This opens the page where you edit the details of a column.

Related Topics
Managing Parameters, page 8-18
Using Declarative Components, page 8-1

Editing Bin or Report Column Details
Use this procedure to edit the details of columns in bin or report components. For an introduction to Declarative Components concepts, please see the topic Understanding Declarative Components, page 2-6.

Steps:
1. To navigate to this page:
   1. In the Design tab, navigate to Declarative Components > Components.
   2. Locate your desired bin or report in the table. Click its component code in the table.
   3. Click the Next button, once on the Component Registration page and again on the Component Metadata page to open the Component Columns page.
   4. Click a column name in the table to open the column details page.

2. Optionally, type a brief description of the column into the Description field.

3. Type an integer into the Display Order field to set the display order of the column.

4. Edit the Label area:
   1. If you want the column label to have a constant value, then choose Constant from the Type drop-down list.
      If you want the column label to be dynamically generated by a PL/SQL procedure or Java method, then choose PL/SQL or Java from the Type drop-down list.
   2. If the column label is constant, then type the text into the Method field. If the column label is dynamically generated, then type the name of the PL/SQL
procedure or Java method into the Method field.
The PL/SQL procedure must return a value of the type VARCHAR2. The Java method must be of the format ClassName.MethodName.

3. Choose Left, Right, or Center from the Horizontal Alignment drop-down list to set how the column label is aligned.

4. Select the check box labeled Raw Column if you want to display the column as a raw column.

5. If you selected the Raw Column check box, then type the appropriate URL into the URL field.

6. Choose the name of the ID column associated with the hyperlink from the ID column drop-down list.

7. Type a value into the Low Watermark field. When the component is displayed, any values below the Low Watermark value will display in a negative color.

8. Type a value into the High Watermark field. When the component is displayed, any values above the High Watermark value will display in a positive color.

5. Click Update to save.

6. Click Component Columns to return to the page that lists the component's columns.

Related Topics
Defining Bin or Report Columns, page 8-8
Using Declarative Components, page 8-1

Managing LOV Columns
Use this procedure to manage the columns in a new or existing LOV component. For an introduction to Declarative Components concepts, please see the topic Understanding Declarative Components, page 2-6.

The LOVs that you create can be used across applications. LOV means "list of values." It is a UI component that facilitates the completion of a text entry field when there are numerous values that may be assigned. LOVs are a useful alternative to drop-down lists, particularly in cases where displaying a long list of selections in a drop-down list would require excessive scrolling.

In short, when using a LOV to complete a text entry field, you type a query into the field and then click a button labeled Go. This opens a screen where you view a list of
values that match the query you submitted. You can then select the value that you
desire and return to the original screen, where what you selected will populate the
original text entry field.

**Steps:**
1. To navigate to this page:
   1. In the **Design** tab, navigate to **Declarative Components > Components**.
   2. Locate your desired LOV in the table. Click its component code in the table.
   3. Click the **Next** button, once on the **Component Registration** page and again on
      the **Component Metadata** page to open the **LOV Columns List** page.

2. Choose a radio button in the **Select** column of the table to specify that column as
   searchable.

3. Choose **Enabled** or **Disabled** from the **Action** column in the table to make the
   column available or unavailable for display.

4. Type an integer into the **Display Order** field to set the display order of the column.
   Make sure that the values of this field are sequential.

5. Click **Update** to save. Note that you do not define parameters for LOV components.

6. If you want to edit the details of a column, then click its name in the table. This
   opens the page where you edit the details of a column.

**Related Topics**

- Editing LOV Column Details, page 8-11
- Using Declarative Components, page 8-1

**Editing LOV Column Details**

Use this procedure to edit the details of columns in a new or existing LOV component.
For an introduction to Declarative Components concepts, please see the topic
**Understanding Declarative Components**, page 2-6.

The LOVs that you create can be used across applications. LOV means "list of values." It
is a UI component that facilitates the completion of a text entry field when there are
numerous values that may be assigned. LOVs are a useful alternative to drop-down
lists, particularly in cases where displaying a long list of selections in a drop-down list
would require excessive scrolling.

In short, when using a LOV to complete a text entry field, you type a query into the
field and then click a button labeled "Go." This opens a screen where you view a list of values that match the query you submitted. You can then select the value that you desire and return to the original screen, where what you selected will populate the original text entry field.

Steps:
1. To navigate to this page:
   1. In the Design tab, navigate to Declarative Components > Components.
   2. Locate your desired LOV in the table. Click its component code in the table.
   3. Click the Next button, once on the Component Registration page and again on the Component Metadata page to open the LOV Columns List page.
   4. Click a column name in the table to open the column details page.

2. Optionally, type a brief description of the column into the Description field.

3. Type an integer into the Display Order field to set the display order of the column.

4. Choose a column type of Date, Number, or Varchar2 from the Column Type drop-down list.

5. If the column is searchable on the main LOV columns page, then the check box fields for Display and Carry Over are automatically selected and cannot be deselected. If the column is not searchable on the main LOV columns page, then you can select or deselect these two check boxes.

6. Edit the Label area:
   1. If you want the column label to have a constant value, then choose Constant from the Type drop-down list.

      If you want the column label to be dynamically generated by a PL/SQL procedure or Java method, then choose PL/SQL or Java from the Type drop-down list.

   2. If the column label is constant, then type the text into the Method field. If the column label is dynamically generated, then type the name of the PL/SQL procedure or Java method into the Method field.

      The PL/SQL procedure must return a value of the type VARCHAR2. The Java method must be of the format ClassName.MethodName.

7. If the column is searchable on the main LOV columns page, then you will see a section for Validation Rules. If the column is not searchable on the main LOV columns page, then this feature is not available.
1. If you want to choose a Javascript Validation Type, then select Error or Warning from the drop-down list. Otherwise, leave the field blank.

2. In the Min. Characters field, type an integer representing the minimum number of characters the user is required to submit when using the LOV component.

3. In the Min. Characters before % field, type an integer representing the minimum number of characters the user is required to submit before the wildcard character (%) when using the LOV component.

4. Select or deselect the Auto Append % check box to choose whether or not to automatically append any queries submitted by the user with the wildcard character (%).

5. If you want to specify the case of the value when it populates the original text entry field, then choose Lowercase or Uppercase from the Change Case drop-down list.

8. Click Update to save. Note that you do not define parameters for LOV components.

9. Optionally, click LOV Column List to return to the page that lists the component’s columns.

**Related Topics**

Managing LOV Columns, page 8-10

Using Declarative Components, page 8-1

**Defining Graph Metadata**

Use this procedure to edit the X-axis, Y-axis, and other basic settings of a new or existing graph component. For an introduction to Declarative Components concepts, please see the topic Understanding Declarative Components, page 2-6.

**Steps:**

1. To navigate to this page:
   1. In the Design tab, navigate to Declarative Components > Components.
   2. Locate your desired graph or graph-report in the table. Click its component code in the table.
   3. Click the Next button, once on the Component Registration page and again on the Component Metadata page to open the Graph Metadata page.
2. Optionally, type a description of the graph into the Description field.

3. If you want the graph title to have a constant value, then choose Constant from the Type drop-down list.
   If you want the graph title to be dynamically generated by a PL/SQL procedure or Java method, then choose PL/SQL or Java from the Type drop-down list.

4. If the graph title is constant, then type the text into the Method field. If the column label is dynamically generated, then type the name of the PL/SQL procedure or Java method into the Method field.
   The PL/SQL procedure must return a value of the type VARCHAR2. The Java method must be of the format ClassName.MethodName.

5. Choose a graph type from the Graph Type drop-down list.

6. If you want to allow the end user to personalize the graph type, then select the check box labeled Allow Personalization?

7. If you want the graph to display in 2D, then select the check box labeled Display in 2-D?

8. If you want to display or not display a grid, then choose an option from the Display Grid drop-down list.

9. To set how the graph legend displays, choose an option from the Graph Legend drop-down list. Set the position of the graph legend in the Legend Position drop-down list.

10. Type pixel values into the Graph Height and Graph Width fields.

11. Type a number into the Graph Color field to set the graph color.

12. Edit the X-axis section:
   1. If you want the X-axis label to have a constant value, then choose Constant Value from the Label Type drop-down list.
      If you want the X-axis label to be dynamically generated by a PL/SQL procedure or Java method, then choose PL/SQL or Java from the Label Type drop-down list.

   2. If the X-axis label is constant, then type the text into the Method field. If the X-axis label is dynamically generated, then type the name of the PL/SQL procedure or Java method into the Method field.
      The PL/SQL procedure must return a value of the type VARCHAR2. The Java method must be of the format ClassName.MethodName.
3. Choose **Vertical**, **Horizontal** or **Slanting** from the **Tick Label Orientation** drop-down list.
   Vertical orientation tilts the tick label 90 degrees. Horizontal orientation tilts the tick label 180 degrees. Slanted orientation tilts the tick label 270 degrees.

4. Choose the amount of tick labels you want to display in the **Tick Label Interval** drop-down list.

13. Edit the **Y-axis** section:

1. If you want the Y-axis label to have a constant value, then choose **Constant Value** from the **Label Type** drop-down list.
   If you want the Y-axis label to be dynamically generated by a PL/SQL procedure or Java method, then choose **PL/SQL** or **Java** from the **Label Type** drop-down list.

2. If the Y-axis label is constant, then type the text into the **Method** field. If the Y-axis label is dynamically generated, then type the name of the PL/SQL procedure or Java method into the **Method** field.
   The PL/SQL procedure must return a value of the type VARCHAR2. Java method must be of the format ClassName.MethodName.

3. Choose **Vertical**, **Horizontal** or **Slanting** from the **Tick Label Orientation** drop-down list.
   Vertical orientation tilts the tick label 90 degrees. Horizontal orientation tilts the tick label 180 degrees. Slanted orientation tilts the tick label 270 degrees.

4. To display the Y-axis as currency, select the **Display Currency?** check box.

5. Choose **Yes** or **No** from the **Auto Scaling** drop-down list.
   If you choose Yes, then the minimum and maximum values displayed on the Y-axis are determined by BI Beans, depending on the graph data. If you choose No, then the minimum and maximum values displayed on the Y-axis are specified manually.

6. If you chose No in the previous step, then type an integer into the **Tick Interval** field to specify the interval on the Y-axis scale.

7. If you chose No in the previous step, then enter integers into the **Minimum Value** and **Maximum Value** fields.

14. Click **Update** to save.

15. Click **Next** to open the page where you manage the columns of the graph.
Managing Graph Columns

Use this procedure to view, update, and remove columns in a graph component. For an introduction to Declarative Components concepts, please see the topic Understanding Declarative Components, page 2-6.

Steps:
1. To navigate to this page:
   1. In the Design tab, navigate to Declarative Components > Components.
   2. Locate your desired graph or graph-report in the table. Click its component code in the table.
   3. Click the Next button, once on the Component Registration page and again on the Component Metadata page to open the Graph Metadata page.
   4. Click Next a third time to open the Graph Columns page.

2. If you want to set the status of a column, then choose Enabled or Disabled from the Action column.

   Enabling a component makes it available for display. Disabling a component makes it unavailable for display.

3. For each column, choose X-axis, Y-axis, or SubX-axis from the Axis drop-down list.

4. Type integers into the Sequence fields to set the sequence of the columns.

5. Click Update to save.

6. Optionally, click Next.
   This opens the page where you manage the parameters of the component.

7. If you want to edit the details of a column, then click its name in the table.
   This opens the page where you edit the details of a column.
Related Topics
Managing Parameters, page 8-18
Editing Graph Column Details, page 8-17
Using Declarative Components, page 8-1

Editing Graph Column Details
Use this procedure to edit the details of new or existing columns in graph components. For an introduction to Declarative Components concepts, please see the topic Understanding Declarative Components, page 2-6.

Steps:
1. To navigate to this page:
   1. In the Design tab, navigate to Declarative Components > Components.
   2. Locate your desired graph or graph-report in the table. Click its component code in the table.
   3. Click the Next button, once on the Component Registration page and again on the Component Metadata page to open the Graph Metadata page.
   4. Click Next a third time to open the Graph Columns page.
   5. Click a column name in the table.

2. Optionally, type a description into the Description field.

3. Edit the Label section:
   1. If you want the column label to have a constant value, then choose Constant Value from the Type drop-down list.
      If you want the column label to be dynamically generated by a PL/SQL procedure or Java method, then choose PL/SQL or Java from the Type drop-down list.

   2. If the column label is constant, then type the text into the Method field. If the column label is dynamically generated, then type the name of the PL/SQL procedure or Java method into the Method field.
      The PL/SQL procedure must return a value of the type VARCHAR2. The Java method must be of the format ClassName.MethodName.
4. Edit the Axis section:
   1. Choose X-axis, Y-axis, or SubX-axis from the Plot drop-down list.
   2. Type the appropriate integer into the Sequence field.
      The sequence number is with respect to axis information. It is the indexing information for columns mapped on the same axis. For example, if COL1 and COL3 are plotted on the Y-axis, then they should have the sequence numbers 1 and 2, respectively. COL2 plotted on the X-axis should have the sequence number 1.

5. Click Update to save.

6. Click Graph Columns to return to the page that lists the component's columns.

Related Topics
Managing Graph Columns, page 8-16
Using Declarative Components, page 8-1

Managing Parameters
Use this procedure to create, update, and remove component parameters. You can define date pickers (calendars), text input fields, drop-down lists, multi-select lists, and hidden fields. For an introduction to Declarative Components concepts, please see the topic Understanding Declarative Components, page 2-6.

Steps:
1. You reach this page by clicking Next from the column summary page of a component. Please see Defining Bin or Report Columns, page 8-8 and Managing Graph Columns, page 8-16.

2. If you want to create a parameter, then click Create Parameter.
   This opens the page where you edit the details of a new parameter.

3. If you want to delete a parameter, then select the appropriate check box in the Remove column of the table.

4. Type integers into the Sequence fields to set the order in which the parameters will be rendered. This order is also used in parameter value resolution.

5. Click Update to save.

6. If you want to edit the details of a parameter, then click its name in the table.
This opens the page where you edit the details of an existing parameter.

Related Topics

Using Declarative Components, page 8-1

Editing Parameter Metadata

Use this procedure to edit the details of a new or existing component parameter. For an introduction to Declarative Components concepts, please see the topic Understanding Declarative Components, page 2-6.

Steps:

1. You reach this page from the Component Parameters page: Click either a parameter name or the Create Parameters button.

2. Type a unique parameter name into the Parameter Name field (this field is not editable if you are working with a parameter that already has been defined).

3. Type a label for the parameter in to the Label field.

4. Select the Enable? check box if you want to enable the parameter.

5. Optionally, type a brief description into the Description field.

6. If you want the parameter to be rendered on the parameter page, then select the check box labeled Enable.

7. If you want to allow the end user to personalize the parameter, then select the check box labeled Personalizable.

8. Choose VARCHAR2, Number, or Date from the Parameter Data Type drop-down list.

9. Choose Calendar, Drop Down, Hidden, LOV, Multiselect, or Text from the Item Style drop-down list.

   For drop-down lists, you are responsible for writing a well-tuned query that will return the number of rows as recommended by the UI team. For hidden fields, the end user will not see the parameter, but you can use the value as needed (for example, passing ID columns).

10. If you chose the Item Style Drop Down in step 6, then type the appropriate source SQL query into the SQL for Dropdown field.

11. If you chose the Item Style LOV in step 6, then the screen refreshes to display a
section about LOV details. This section includes fields for **LOV App Id**, **LOV Component Code**, and **Mapped LOV Column**:

1. Choose an LOV App Id from the drop-down list. This is the application that owns the LOV component. When you have chosen the application, the screen refreshes to display a list of LOV components specific to that application.

2. Choose a LOV component from the list of available choices. The screen refreshes to display the list of searchable columns that can be mapped to the current parameter.

3. Choose the Searchable LOV column and map it to this parameter.

4. You may need to create additional parameters if you want to carry over ID Columns.

12. If you chose the Item Style LOV in step 6 and there is a LOV parameter already defined for this component, then the screen refreshes to display a drop-down list called **Related LOV Parameter**. The drop-down list contains all the LOV parameters that have been defined for this component:

   1. Choose a LOV parameter as the Related LOV parameter. The screen refreshes to display a list of the Carried Over Column(s) of the chosen LOV parameter.

   2. The **Mapped LOV Column** drop-down list displays the LOV Columns that have been defined to be carried over. Therefore, you can use the value of this Mapped LOV Column, for example, in a Data Source Query.

13. If available, edit the **Default Value Setting** section:

   1. Choose **Constant**, **PL/SQL**, or **Java** from the **Type** drop-down list.

   2. If you chose **Constant** in step a, then type the text of the default value into the **Name** field.

      If you chose **PL/SQL** in step a, then type the complete signature of a PL/SQL function, including any package name, into the **Name** field. This function must return a Varchar2. For example, `My_Package.Get_Default_Value(?P_Context)`. Optionally, the function can take a `p_context` as an argument.

      If you chose **Java** in step a, then type the signature of a Java method into the **Name** field, in the format `package_name.function_name`. This method must return a string.

14. Click **Update** to save.

15. Optionally, click Component **Parameter** to return to the page that lists the component’s parameters.
Related Topics

Managing Parameters, page 8-18
Using Declarative Components, page 8-1

Managing Component Security

Use this procedure to manage component security assignments. For an introduction to Declarative Components concepts, please see the topic Understanding Declarative Components, page 2-6.

Steps:
1. In the Design tab, navigate to Declarative Components > Component Security.

2. Choose a radio button, Component to Responsibilities or Responsibility to Components.

3. Click Next.

This opens the page where you choose either the component that you will be mapping to responsibilities or the responsibility that you will be assigning to components.

Related Topics

Assigning a Component to Responsibilities, page 8-21
Assigning a Responsibility to Components, page 8-22
Using Declarative Components, page 8-1

Assigning a Component to Responsibilities

Use this procedure to assign a component to one or more responsibilities. For an introduction to Declarative Components concepts, please see the topic Understanding Declarative Components, page 2-6.

Steps:
1. In the Design tab, navigate to Declarative Components > Component Security, then select the radio button labeled Component to Responsibilities.

2. Choose an application from the Application Code drop-down list.

3. Choose a component code from the Component Code drop-down list.
4. Click **Next** to continue.

**Related Topics**

- Selecting Responsibilities, page 8-22
- Managing Component Security, page 8-21
- Using Declarative Components, page 8-1

**Selecting Responsibilities**

Use this procedure to select which responsibilities will apply to the component that you have chosen. This procedure takes place after you have completed the Assigning a Component to Responsibilities, page 8-21 procedure. For an introduction to Declarative Components concepts, please see the topic Understanding Declarative Components, page 2-6.

**Steps:**

1. Choose the name of a responsibility in one list and click >or < to move it to the other list.
2. Repeat step 1 as desired.
3. If you want to move all **Available Responsibilities** to the **Selected Responsibilities** list, then click >>.
4. If you want to move all **Selected Responsibilities** to the **Available Responsibilities** list, then click <<.
5. Optionally, choose an application from the **Responsibility App Code** drop-down list.
6. Optionally, click **Restore** to reset the fields to their original settings.
7. Click **Update** to save.

**Related Topics**

- Managing Component Security, page 8-21
- Using Declarative Components, page 8-1

**Assigning a Responsibility to Components**

Use this procedure to assign a responsibility to one or more components. For an
introduction to Declarative Components concepts, please see the topic Understanding Declarative Components, page 2-6.

**Steps:**
1. In the Design tab, navigate to Declarative Components > Component Security, then select the radio button labeled Responsibility to Components.
2. Choose an application from the Responsibility App Code drop-down list.
3. Choose a responsibility from the Responsibility drop-down list.
4. Click Next to continue.

**Related Topics**
- Selecting Components, page 8-23
- Managing Component Security, page 8-21
- Using Declarative Components, page 8-1

**Selecting Components**

Use this procedure to select which components will apply to the responsibility that you have chosen. This procedure takes place after you have completed the procedure Assigning a Responsibility to Components, page 8-22. For an introduction to Declarative Components concepts, please see the topic Understanding Declarative Components, page 2-6.

**Steps:**
1. Choose the name of a component in one list and click > or < to move it to the other list.
2. Repeat step 1 as desired.
3. If you want to move all Available Components to the Selected Components list, then click >>.
4. If you want to move all Selected Components to the Available Components list, then click <<.
5. Optionally, choose an application from the Component App Code drop-down list.
6. Optionally, click Restore to reset the fields to their original settings.
7. Click Update to save.
Related Topics

Managing Component Security, page 8-21
Using Declarative Components, page 8-1
Using the Homepage Subtab

Configuring Default Homepages

Use this procedure to set up default homepages for users who do not personalize their homepages. If a homepage is configured for a particular responsibility, then all users of that responsibility who have not already personalized their homepages will see this configuration by default. As soon as a user personalizes his or her homepage, then the default configuration will no longer be seen. A homepage has either two columns or three columns. Components in a column are selected from an available list and laid out vertically. For more information on UI components, please see Understanding Declarative Components, page 2-6.

Steps:
1. In the Design tab, navigate to Homepage > Configuration.
2. Choose an application name from the Select an application drop-down list.
3. Choose a responsibility from the Select a responsibility drop-down list.
4. Choose a layout, either Two Columns or Three Columns, from the Select a layout drop-down list. Once you have set the value of this field, do not change it again unless you are willing to lose all edits you have made to the column setup lists below.
5. Set up the bins and modules that will display in each column as follows:
   1. Choose the name of a bin or module in one list and click > or < to move it to the other list.
   2. Repeat the previous step as desired.
   3. If you want to move all bins or modules from one list to the other, then click >>
or <<.

4. In a Displayed Bins or Displayed Modules list, you can highlight and entry and then click the up and down arrows to set the order in which bins or modules displays in that column.

6. Click Update to save.
Setting Profile Options

Setting Navigation Preferences

Use this procedure to set navigation preferences.

Steps:
1. Click the Profile button, then select Navigation Preferences.
2. If you want to change your current responsibility, then choose an option from the Current Responsibility drop-down list.
3. If you want to set default responsibilities for registered Navigation Groups, then choose from the drop-down lists in the Default Responsibility column.
   For information on Navigation Groups, please see Understanding the Interapplication Bar, page 2-3 and Setting Up the Interapplication Bar, page 4-1.
4. Optionally, click Restore to reset the fields to their original settings.
5. Click Update to save.

Setting Display Preferences

Use this procedure to set display preferences.

Steps:
1. Click the Profile button, then select Display Preferences.
2. Choose options from the drop-down lists in the General Display section to select language, currency, date format, time zone, and display style settings.
3. Choose numbers from the drop-down lists in the **Table Display** section to select how many rows to display per page and how many blank rows to display per table.

4. In the **Search Display** section, choose the radio button that suits how you want the Quick Find to return results.

5. Optionally, click **Restore** to reset the fields to their original settings.

6. Click **Update** to save.

### Setting Up the Quick Menu

The Quick Menu is a feature that allows you to display links to your most frequently visited pages on the Introduction pages of every subtab in the System Administrator Console. Use this procedure to choose which pages have links in the Quick Menu and also turn the Quick Menu on or off.

**Steps:**

1. Click the **Profile** button, then select **Quick Menu**.

2. Select or deselect the check box labeled **Display the Quick Menu** to turn the Quick Menu on or off.

3. Choose the name of a menu in one list and click > or < to move it to the other list.

4. Repeat step 3 as desired.

5. If you want to move all **Available Menus** to the **Favorite Menus** list, then click >>.

6. If you want to move all **Favorite Menus** to the **Available Menus** list, then click <<.

7. Optionally, click the up and down arrows to change the sequence of menus in the Favorite Menus list.

8. Optionally, click **Restore** to reset the fields to their original settings.

9. Click **Update** to save.

### Changing Your Password

Use this procedure to change your password.

**Steps:**

1. Click the **Profile** button, then select **Change Password**.
2. Type your current password into the **Current Password** field.

3. Type your new password into the **New Password** field.
   Passwords must be at least six characters long.

4. Retype your new password into the **Re-Enter New Password** field.

5. Optionally, click **Restore** to reset the fields to their original settings.

6. Click **Update** to save.

**Setting Personal Information**

Use this procedure to edit your personal information.

**Steps:**

1. Click the **Profile** button, then select **Personal Information**.

2. Edit the fields as desired.

3. Optionally, click **Restore** to reset the fields to their original settings.

4. Click **Update** to save.

**Setting Address Information**

Use this procedure to edit your address information.

**Steps:**

1. Click the **Profile** button, then select **Address Information**.

2. Edit the fields as desired.

3. Optionally, click **Restore** to reset the fields to their original settings.

4. Click **Update** to save.

**Viewing Quick Find Search Results**

The Quick Find feature appears underneath each page's tabs. Use this procedure to view the results of a Quick Find search operation.
Prerequisites

1. Choose an item from the Quick Find drop-down list.

2. Type a search query into the text input field.

3. Click Go.

Steps:

1. The search results display.

   **Note:** If in the Display Preferences page you have selected the option "Go to record detail when there is one result," then you will not see this page. Instead, you will bypass this page and be automatically redirected to the page that resulted from your search.

2. Click one of the links offered to you in the Search Results list.

   You will be redirected to the associated record detail page.