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Oracle Healthcare Provider Supply Chain Analytics (OHPSCA) is an analytical
reporting application. OHPSCA generates both predefined and custom reports of key
metrics across the provider supply chain spectrum.

OHPSCA is built on top of Oracle Business Intelligence Enterprise Edition (OBIEE)
infrastructure. This document presents instructions for installing OHPSCA. It also
describes the tasks that you must complete before you can install the OHPSCA
application.

This guide contains the following sections:

1. Technology Stack and System Requirements on page 1

Prerequisite Software on page 2

Installing Oracle Healthcare Provider Supply Chain Analytics on page 3
Accessing Oracle Healthcare Provider Supply Chain Analytics on page 6
Finding Information and Patches on My Oracle Support on page 7

Finding Oracle Documentation on page 9
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Documentation Accessibility on page 10

1 Technology Stack and System Requirements
The required technology stack for OHPSCA consists of the following products:

s Oracle Database 11.2.0.1
s Oracle Business Intelligence Enterprise Edition (OBIEE) 10.1.3.4.1

Table 1 System Requirements References

Product Reference

Oracle Database 11.1.0.7 Database Installation Guide for <platform>

Oracle Business Intelligence Enterprise Edition System Requirements and Supported Platforms for Ora-
(OBIEE) 10.1.3.4.1 cle Business Intelligence Suite Enterprise Edition
Other Technology Stack Components My Oracle Support / Certifications

Note: It is important to get the technology stack products from the
OHPSCA media pack because newer versions of the technology stack
products may have become available but may not be compatible with
OHPSCA.




Figure 1 Oracle Healthcare Provider Supply Chain Analytics Technology Stack
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1.1 Supported Browsers

OHPSCA supports those Internet browsers supported by OBIEE. For a list of the
browsers supported by OBIEE, refer to System Requirements and Supported Platforms for
Oracle Business Intelligence Suite Enterprise Edition.

1.2 Supported Platforms

OHPSCA supports the following platforms:

= Microsoft Windows32 (Windows 2003/ Windows 2008)
»  Oracle Solaris on SPARC (64-bit)

s HP-UX Itanium

s Linux x86

= IBM AIX 6.1 PowerPC (64-bit)

» Exadata 2.0

2 Prerequisite Software

Before you can install the OHPSCA application, you must complete the following
pre-installation tasks:

1 Install Oracle Database 11.2.0.1
Follow the instructions in Database Installation Guide for <platform>.

1 Install Oracle Business Intelligence Enterprise Edition (OBIEE) 10.1.3.4.1 with the
following components:

- Oracle Business Intelligence Server (Supported only on Windows and Unix)

- Oracle Business Intelligence Presentation Services (Supported on Windows
and Unix)

- Oracle Business Intelligence Client Tools (Supported only on Windows)




Notes:

Oracle recommends that you enable HTTPS on the middle-tier
computer that is hosting the Web services, since the trusted user name
and password that are passed can be intercepted.

The rest of the instructions in Section 3 assume that OBIEE is installed
on Windows32 in the c:\oracleBI and c:\oracleBldata folder and on
UNIX in the /oracleBI and /oracleBldata folders.

3 Installing Oracle Healthcare Provider Supply Chain Analytics
To install the OHPSCA application on Windows and Unix:

1. Create a directory on the server and copy the contents of the software folder on the
media to this directory.

2. Install the Oracle database.
3. Connect to the database as the SYSTEM user.

4. Run the CREATE_PSCA_USER.SQL script. This script creates two users EHA_
PSCA and EHA_PSCA_RPD.

5. The script prompts for the Default_Table_Space name. Enter the default tablespace
for the users. You can enter any valid tablespace name for the users. Oracle
recommends that you use the Apps tablespace APPS_TS_TX_DATA as the default
tablespace.

The script also prompts for both the OHPSCA user passwords. Enter valid
passwords for both the users and continue.

6. Inspect the log file create_PSCA_user_<DB_name>.log located in the working
directory for errors. <DB_name> is the database name.

7. Connect to the database as the new user EHA_PSCA with the following
credentials:

Username: EHA_PSCA
Password: Enter the same password entered in the step 5.

8. Run the DDL script, EHA_PSCA_DDL_1.0.sq], to create the database objects such
as tables, views, indexes, procedures, functions, constraints, and triggers.

9. The script prompts for the Index_Table_Space for the EHA_PSCA user. Enter the
tablespace for the indexes. You can enter any valid tablespace name. Oracle
recommends that you use the Apps tablespace APPS_TS_TX_IDX as the index
table space.

10. Inspect the log file PSCA_DDL_1_<DB_name>.log located in the working directory
for errors. <DB_name> is the database name.

11. Run the EHA_PSCA_INSERT_SEED_DATA.SQL script. The script inserts seed
data for OHPSCA application into the database. Inspect this log file after each step
to see the output log and check for errors during the setup.

12. Inspect the log file PSCA_insert_seed_data_<DB_name>.log located in the working
directory for errors. <DB_name> is the database name.

13. Connect to the database as the new user EHA_PSCA_RPD with the following
credentials:




14.

15.

16.

17.

18.
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20.

21.

22,

Username: EHA_PSCA_RPD
Password: Enter the same password entered in the step 5.

Run the EHA_PSCA_SYNONYMS.SQL script. The script creates synonyms for all
the OHPSCA tables created in the EHA_PSCA schema.

Place the OracleHealthcarePSCAnalyticsApps.rpd in the following folder:
s Windows32 - <DRIVE>:\OracleBI\server\Repository
s UNIX - OracleBl/server/Repository

Modify the repository section of the following file to include an entry for the RPD
file:

s Windows32 - <DRIVE>:\OracleBI\server\Config \NQSConfig.INI
s UNIX - /OracleBl/server/Config/NQSConfig INI

For example,
Star=OracleHealthcarePSCAnalyticsApps.rpd, DEFAULT;
Unzip OracleHealthcarePSCAnalyticsApps.zip in the following folder:
s Windows32 - <DRIVE>:\OracleBldata\web\catalog

s UNIX - /OracleBldata/web/catalog

Modify the catalog path line in the following file to point it to the correct Web
Catalog;:

s Windows32 - <DRIVE>:\OracleBldata\web\config\instanceconfig.xml
s UNIX- OracleBldata/web/config/instanceconfig.xml
For example,

s Windows32 -
<CatalogPath><DRIVE>:\OracleBIdata\web\catalog\OracleHealt
hcarePSCAnalyticsApps</CatalogPath>

s Unix-
<CatalogPath>/OracleBIdata/web/catalog/OracleHealthcarePSC
AnalyticsApps</CatalogPath>

Unzip s_psca.zip to extract the s_psca folder in:

s Windows32 - <DRIVE>:\OracleBI\web\app\res
s UNIX- /OracleBl/web/app/res

Unzip s_psca.zip to extract the s_psca folder in:

s Windows32 - <DRIVE>:\OracleBI\oc4j_
bi\j2ee\home\applications\analytics\analytics\res

s UNIX - /OracleBI/oc4j_bi/j2ee /home/applications/analytics /analytics/res
Unzip help.zip in:

s Windows32 - <DRIVE>:\OracleBI\web\app\res\help

s UNIX- /OracleBl/web/app/res/help

Unzip help.zip in:




23.

24.

25.

26.
27.

28.

s Windows32 - <DRIVE>:\OracleBI\oc4j_
bi\j2ee\home\applications\analytics\analytics \res\help

s UNIX- /OracleBI/oc4j_
bi/j2ee/home/applications/analytics/analytics /res/help

In the Oracle BI Administration Tool, open the newly installed Oracle BI
repository (OracleHealthcarePSCAnalyticsApps.rpd) in the offline mode to
configure static variables and database connections.

Note: Oracle BI Administration Tool is supported only on Windows.
If Oracle Healthcare Provider Supply Chain Analytics is installed on
Unix, copy OracleHealthcarePSCAnalyticsApps.rpd to a Windows
system to perform modifications described in the following sections.
Once the modifications are complete, copy the
OracleHealthcarePSCAnalyticsApps.rpd back to the Unix system.

1. In the Oracle BI Administration Tool, select File > Open > Offline.
2. Navigate to the OracleHealthcarePSCAnalyticsApps.rpd, and then click Open.

In the Open Offline dialog box, enter the following credentials to log into the
OracleHealthcarePSCAnalyticsApps.rpd file, and then click OK.

Username: Administrator
Password: SADMIN

Do the following to change the default password using the Oracle Business
Intelligence Administration Tool:

1. Select Manage > Security

In the Security Manager dialog box, select Users in the left pane.

In the right pane, right-click the user whose password you want to change.
Select Properties from the shortcut menu.

In the User tab, enter the new password.
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In the Confirm Password text box, type the password again, and then click
OK.

In the Oracle BI Administration Tool, select Manage > Variables.

In the Variable Manager dialog box, expand the Repository > Variable in the left
pane, then click Static.

Double-click and modify the following static variables:

Table 2 Static Variables

Variable Name Instruction
OLAP_DSN Enter the Service Name of database hosting OHPSCA database
schema.




Table 2 (Cont.) Static Variables

Variable Name Instruction

OLAP_USER Enter the name of OHPSCA read-only database schema, for exam-

ple, EHA_PSCA_RPD.

OLAPTBO Enter the name of OHPSCA read-only database schema, for exam-

ple, EHA_PSCA_RPD.

LOW_VALUE_PO Enter the value of the low value purchase order. Any purchase

order having value less than this value is considered a low value
purchase order.

29.
30.
31.

32.
33.
34.

35.
36.

37.

38.

Click OK after each modification.
Close the Variable Manager.
Modify the connection pools in the RPD as following:

1. In the physical layer, expand the EHI Applications Data Warehouse node and
double-click EHI Applications Data Warehouse Connection Pool.

2. Change the password to the password of the EHA_PSCA user.
3. Click OK.

4. Expand the Externalized Metadata Strings node and double-click Internal
System Connection Pool.

5. Change the password to the password of the EHA_PSCA user.
6. Click OK.

From the File menu, select Save to save the rpd.

Navigate to<OracleBldata>\web\config.

Add the following settings after </ AdvancedReporting> tag in the
instanceconfig.xml file:

<ReportAggregateEnabled>true</ReportAggregateEnabled>
<HardenXSS>false</HardenXSS>
Save instanceconfig.xml.

Start the OC4] manually, in the Windows Start Menu, select All Programs >
Oracle Business Intelligence > Start OC4]J.

Start the Oracle BI Java Host, Oracle BI Server, and Oracle BI Presentation Server
services from Windows Start Menu, select Control Panel > Administration Tools
> Services.

To start Oracle Business Intelligence, in the Windows Start menu, select All
Programs > Oracle Business Intelligence > Presentation Services.

4 Accessing Oracle Healthcare Provider Supply Chain Analytics

Your security privileges determine what reports you can see and what you can do in
OHPSCA. To log in to OHPSCA, you must have a browser on your computer and a
URL, username, and password provided by your company.

4.1 Logging In

1.

Open your browser and enter the URL provided by your company.




Figure 2 displays the OHPSCA login page.

Figure 2 Oracle Healthcare Provider Supply Chain Analytics Login Page
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2. Enter the following user ID and password.
Username: Administrator
Password: SADMIN

3. Click Login.

After your login credentials are authenticated, your default dashboard page is
displayed.

5 Finding Information and Patches on My Oracle Support

Your source for the latest information about Oracle Healthcare Provider Supply Chain
Analytics is Oracle Support's self-service Web site, My Oracle Support (formerly
MetaLink).

Before you install and use an Oracle software release, always visit the My Oracle
Support Web site for the latest information, including alerts, release notes,
documentation, and patches.

5.1 Creating a My Oracle Support Account

You must register at My Oracle Support to obtain a user name and password account
before you can enter the Web site.

To register for My Oracle Support:




1. Open a Web browser to http: //support.oracle.com

2. Click the Register here link to create a My Oracle Support account. The
registration page opens.

3. Follow the instructions on the registration page.

5.2 Signing In to My Oracle Support

To sign in to My Oracle Support:

1. Open a Web browser to http://support.oracle.com.
2. Click Sign In.

3. Enter your user name and password.
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Click Go to open the My Oracle Support home page.

5.3 Searching for Knowledge Articles by ID Number or Text String

The fastest way to search for product documentation, release notes, and white papers
is by the article ID number.

To search by the article ID number:
1. Signin to My Oracle Support at http://support.oracle.com
2. Locate the Search box in the upper right corner of the My Oracle Support page.

3. (Click the sources icon to the left of the search box, and then select Article ID from
the list.

4. Enter the article ID number in the text box.

5. Click the magnifying glass icon to the right of the search box (or press the Enter
key) to execute your search.

The Knowledge page displays the results of your search. If the article is found,
click the link to view the abstract, text, attachments, and related products.

In addition to searching by article ID, you can use the following My Oracle Support
tools to browse and search the knowledge base:

s Product Focus — On the Knowledge page, you can drill into a product area
through the Browse Knowledge menu on the left side of the page. In the Browse
any Product, By Name field, type in part of the product name, and then select the
product from the list. Alternatively, you can click the arrow icon to view the
complete list of Oracle products and then select your product. This option lets you
focus your browsing and searching on a specific product or set of products.

= Refine Search — Once you have results from a search, use the Refine Search
options on the right side of the Knowledge page to narrow your search and make
the results more relevant.

= Advanced Search — You can specify one or more search criteria, such as source,
exact phrase, and related product, to find knowledge articles and documentation.

5.4 Finding Patches on My Oracle Support

Be sure to check My Oracle Support for the latest patches, if any, for your product. You
can search for patches by patch ID or number, or by product or family.




To locate and download a patch:
1. Signin to My Oracle Support at http://support.oracle.com
2. Click the Patches & Updates tab.

The Patches & Updates page opens and displays the Patch Search region. You have
the following options:

s In the Patch ID or Number is field, enter the primary bug number of the patch
you want. This option is useful if you already know the patch number.

= To find a patch by product name, release, and platform, click the Product or
Family link to enter one or more search criteria.

3. (Click Search to execute your query. The Patch Search Results page opens.

4. Click the patch ID number. The system displays details about the patch. In
addition, you can view the Read Me file before downloading the patch.

5. Click Download. Follow the instructions on the screen to download, save, and
install the patch files.

5.5 Finding Certification Information

Certifications provide access to product certification information for Oracle and third
party products. A product is certified for support on a specific release of an operating
system on a particular hardware platform, for example, Oracle Database 10g Release 2
(10.2.0.1.0) on Sun Solaris 10 (SPARC). To find certification information:

1. Signin to My Oracle Support at http://support.oracle.com

2. Click the Certifications tab. The Certifications page opens and displays the Find
Certifications region.

3. InSelect Product, enter Oracle Healthcare Provider Supply Chain
Analytics.

4. Click the Go to Certifications icon.
The right pane displays the certification information.

5. Select a certification to view the certification details.

6 Finding Oracle Documentation

The Oracle Web site contains links to all Oracle user and reference documentation. You
can view or download a single document or an entire product library.

6.1 Finding Oracle Health Sciences Documentation

To get user documentation for Oracle Health Sciences applications, go to the Oracle
Health Sciences documentation page at:

http://www.oracle.com/technetwork/documentation/hsgbu-154445.htm
1

Note: Always check the Oracle Health Sciences Documentation page
to ensure you have the latest updates to the documentation.




6.2 Finding Other Oracle Documentation

To get user documentation for other Oracle products:
1. Go to the following Web page:
http://www.oracle.com/technology/documentation/index.html

Alternatively, you can go to http: //www.oracle. com, point to the Support tab,
and then click Documentation.

2. Scroll to the product you need and click the link.

3. Click the link for the documentation you need.

7 Documentation Accessibility

Our goal is to make Oracle products, services, and supporting documentation
accessible to all users, including users that are disabled. To that end, our
documentation includes features that make information available to users of assistive
technology. This documentation is available in HTML format, and contains markup to
facilitate access by the disabled community. Accessibility standards will continue to
evolve over time, and Oracle is actively engaged with other market-leading
technology vendors to address technical obstacles so that our documentation can be
accessible to all of our customers. For more information, visit the Oracle Accessibility
Program Web site at http: //www.Oracle.com/accessibility/.

Accessibility of Code Examples in Documentation

Screen readers may not always correctly read the code examples in this document. The
conventions for writing code require that closing braces should appear on an
otherwise empty line; however, some screen readers may not always read a line of text
that consists solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation

This documentation may contain links to Web sites of other companies or
organizations that Oracle does not own or control. Oracle neither evaluates nor makes
any representations regarding the accessibility of these Web sites.

Deaf/Hard of Hearing Access to Oracle Support Services

To reach Oracle Support Services, use a telecommunications relay service (TRS) to call
Oracle Support at 1.800.223.1711. An Oracle Support Services engineer will handle
technical issues and provide customer support according to the Oracle service request
process. Information about TRS is available at
http://www.fcc.gov/cgb/consumerfacts/trs.html, and a list of phone
numbers is available at http: //www. fcc.gov/cgb/dro/trsphonebk.html.
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