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Preface

Audience
This document is intended for all Argus Insight administrators who need to install the 
Argus Insight application.

Documentation Accessibility
Our goal is to make Oracle products, services, and supporting documentation 
accessible to all users, including users that are disabled. To that end, our 
documentation includes features that make information available to users of assistive 
technology. This documentation is available in HTML format, and contains markup to 
facilitate access by the disabled community. Accessibility standards will continue to 
evolve over time, and Oracle is actively engaged with other market-leading 
technology vendors to address technical obstacles so that our documentation can be 
accessible to all of our customers. For more information, visit the Oracle Accessibility 
Program Web site at http://www.oracle.com/accessibility/.

Accessibility of Code Examples in Documentation
Screen readers may not always correctly read the code examples in this document. The 
conventions for writing code require that closing braces should appear on an 
otherwise empty line; however, some screen readers may not always read a line of text 
that consists solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation
This documentation may contain links to Web sites of other companies or 
organizations that Oracle does not own or control. Oracle neither evaluates nor makes 
any representations regarding the accessibility of these Web sites.

Access to Oracle Support
Oracle customers have access to electronic support through My Oracle Support.  For 
information, visit http://www.oracle.com/support/contact.html or visit 
http://www.oracle.com/accessibility/support.html if you are hearing 
impaired.

Conventions
The following text conventions are used in this document:
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Convention Meaning

boldface Boldface type indicates graphical user interface elements associated 
with an action, or terms defined in text or the glossary.

italic Italic type indicates book titles, emphasis, or placeholder variables for 
which you supply particular values.

monospace Monospace type indicates commands within a paragraph, URLs, code 
in examples, text that appears on the screen, or text that you enter.
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1Introduction

Introduction
Argus Insight is a highly optimized reporting module that compliments Argus Safety. 
The Argus Insight Extract Transfer and Load (ETL) engine extracts data from the 
Argus Safety database and populates a data warehouse in a format to enable efficient 
querying. The various query, drill-down, and output features of Argus Insight let you 
analyze your safety, workflow, or product data from all angles and produce reports 
that provide immediate business impact and maximum efficiency in decision-making.

The following table describes the conventions that are used in this manual.

This chapter includes the following topics:

■ Argus Insight Product Overview

■ Hardware and Software Requirements

Argus Insight Product Overview
In Argus Insight, you can generate a report in either of the following ways:

■ Through a query, retrieve a set of specific type of cases (Case Series) from the 
datamart and then run the report on only those cases.

Use these Argus Insight components to retrieve the Case Series: Query By Example 
(QBE), Filters, and Advanced Conditions. Next, run one of these reports on the Case 

Convention Description

Bold User interface elements like Buttons, Dialog boxes, Check boxes, Combo boxes, 
Drop-down lists, Labels, Option (Radio) buttons, Tabs, Text boxes, etc.

Note: Information that should be noted before proceeding.

Important! Important information that must be noted to ensure accurate, reliable, or safe 
behavior of the system.

Tip: Information that enables easier completion of the current task or helps in 
completing other tasks.

Note: Power Reports has been renamed Argus Insight and the two 
terms have been used interchangeably in this document.
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Series: the built-in Standard Reports or the custom reports you create and store in 
the Report WriterLibrary.

■ Run the report on all the cases in the datamart.

Use these Argus Insight components to directly query the datamart and run reports: 
Cubes and Report Writer. Another component that directly generates reports from the 
datamart is Dashboard Indicators. Dashboard Indicators are pre-configured by the 
administrator.

The following flowchart shows the typical for generating a report.

The table that follows describes the various components of Argus Insight:

Component Description

Query by Example 
(QBE)

Lets you create simple queries by entering specific values in fields on a 
form that looks substantially like the Argus Safety case form

Filters Lets you create queries by selecting a set of predefined fields and 
specifying multiple values in a field

Advanced 
Conditions

Lets you create complex queries by selecting any of the various different 
fields in the datamart and applying Boolean and Set operations on them

Case Series A list of cases that match the query criteria

Standard Reports Predefined reports built into Argus Insight

These reports are grouped into these categories:

■ Compliance

■ Management

■ Pharmacovigilance

■ Configuration

■ General

Typically, these reports are run on the Case Series
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Hardware and Software Requirements
The following table summarizes the hardware and software requirements for Argus 
Insight components.

Report Writer Lets you query the datamart and create custom reports by selecting any 
datamart fields as report columns. In the report output, you can apply 
filters, create nested groupings, and perform operations such as sort, total, 
count, and drill

The custom reports you create can be stored in the Report Writer Library 
or added to the Argus Insight application; you can run the stored reports 
on a Case Series.

Cubes Lets you run complex queries on the datamart and statistically analyze, 
drill-down, and explore the results

Argus Insight has six predefined Cubes: Reporting -Compliance, 
Workflow, Pharmacovigilance-PV Detail, Pharmacovigilance-PV General, 
Pharmacovigilance-PV Clinical, and Pharmacovigilance-PV Interaction

Dashboard Indicators Special reports that provide an insight into key parameters that let you 
monitor product performance and workflow efficiency.

Dashboard Indicator reports are pre-configured by the administrator and 
are generated directly from the datamart.

Hardware and Software Requirements

Argus Insight Web Server Software Requirements:

■ Operating System: Windows 2003/2008 Server - Service Pack 2 
(Standard / Enterprise)

■ SOAP Tookit 3.0

■ Oracle v11.1.0.7 (Client) (with SQL Plus, SQL Loader, Oracle and 
OLEDB Objects)

■ Oracle Data Provider for .Net v11.1.0.7.20

■ Microsoft Internet Explorer 7.0/8.0

■ IIS 6.0/7.0

■ Note: For IIS 7.0, IIS 6.0 compatibility pack should also be installed.

■ Dotnet Framework 3.5 Service Pack 1

■ Microsoft Visual C++ 2008 Redistributable

■ MSXML 6.0

Note: The Web server should be configured for SMTP. 

Hardware Requirements:

■ Up to 5000 cases in the system: 2x2.6 GHz, 4 GB Memory

■ More than 5000 cases in the system: 4x2 GHz, 8 GB Memory

Component Description
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Cognos Server Software Requirements:

■ Operating System: Windows 2003/2008 Server - Service Pack 2 
(Standard / Enterprise)

■ Oracle Client v11.1.0.7 (with SQL Plus, SQL Loader, Oracle and 
OLEDB Objects)

■ Oracle Data Provider v11.1.0.7.20

■ Microsoft Internet Explorer 7.0/8.0

■ IIS 6.0/7.0 (With ASP.Net)

■ Note: For IIS 7.0, IIS 6.0 compatibility pack should also be installed.

■ SOAP Toolkit 3.0

■ Cognos 8.4.1 BI Server (Default installation with all components except 
Cognos Content Database)

■ Cognos 8.4.1 BI Modeling (Default installation with all components)

■ Cognos 8.4.1 SDK (Default installation with all components)

Note: Argus Insight 6.0 does not support Cognos 8.3.

Software Requirements for Cubes with Cognos 8:

■ Cognos 8.4.1 Transformer (For Cubes other than Cognos Series 7.4) 
(Default installation with all components)

Software Requirements for Cubes with Cognos Series 7.4:

■ Directory Server for Cubes 7.4 (supplementary software)

■ Power Play Enterprise Server 7.4 MR2 (Default installation with all 
components)

■ Power Play Transformer 7.4 MR2 (Default installation with all 
components except Architect)

Hardware Requirements:

■ Up to 5000 cases in the system: 2x2.6 GHz processors, 4 GB Memory

■ More than 5000 cases in the system: 4x2 GHz processors, 8 GB 
Memory

Database Server Software Requirements:

■ Operating System: Windows 2003/2008 - Service Pack 2 (Standard/ 
Enterprise)

■ Oracle Server v11.1.0.7 (Enterprise)

Hardware Requirements:

■ Up to 5000 cases in the system: 2x2 GHz, 4 GB Memory

■ More than 5000 cases in the system: 4x2 GHz, 16 GB Memory

Argus Insight Client Software Requirements:

■ Microsoft Excel 2003 SP2/2007

■ Adobe Acrobat Reader v7.0/8.1.0/9.0

■ Windows XP Professional - Service Pack 3/ Windows Vista Service 
Pack 1

■ Microsoft Internet Explorer 6.0 SP3 (XP) / 7.0 SP3 (XP and Vista)/8.0

Hardware Requirements:

■ 2.0 GHz Minimum, 1 GB Memory

Hardware and Software Requirements
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Important Installation Information
Before installing Argus Insight you need to be aware of the following:

■ All softwares must be installed using the language as English. For example, if 
Oracle is installed in a language other than English, the registry entries are created 
with different names. Hence, to avoid errors, install all softwares in English.

■ Ensure that you have disabled the firewall on the Cognos Web Server. If the 
firewall is enabled, ensure that Cognos is accessible from other machines on the 
network.

■ Ensure that either you have disabled the firewall on the Argus Insight Web Server 
or you have added the Argus Insight Port Number in the Windows Firewall 
Exception list. The default Port Number for Argus Insight is 8084.

■ Cookies must be enabled to the lowest possible security level on Argus Insight 
client to run the Argus Insight.

■ Single Sign-on will work only if the password for all the applications (Argus, 
Console, Argus Insight etc.) is same.

■ All the servers used should be in the same time zone.

■ Single Sign On (through SiteMinder) in Argus Safety does not work if Cognos is 
LDAP enabled. In this scenario, you will be presented with the Argus Insight 
Login screen.

■ Windows 2003 Service Pack 2 should be executed after the IIS installation. If 
Windows 2003 Service Pack 2 is already installed before the IIS installation, then 
make sure to re-run the Windows 2003 Service Pack 2 after the IIS installation.

■ Oracle client should be installed with the default Oracle Home Name, provided by 
the Oracle installer. Failure to do so can display an error message, stating that the 
Oracle OLE DB provider was not found during installation.

■ Javascript must be enabled on Argus Insight Client machine.

■ Make sure that the Internet Explorer setting Allow script-initiated windows 
without size or position constraints is enabled on the client machine at the 
following location:

■ Internet Explorer -> Tools -> Internet Options -> Security Tab -> Custom Level -> 
Miscellaneous.

■ Argus Insight URL must be added to the trusted sites on the Client machine.

■ On the Argus Insight Web Server, Oracle Client installation should be done after 
the installation of the Dotnet Framework.

■ All the servers must have the default language settings enabled for US English.

■ During installation verification, the system shows that files from Cognos 8 folder 
are missing. Users can ignore this error.

■ If you are unable to open the Cognos Report Writer from Argus Insight using 
Internet Explorer 8, execute the following steps on each Argus Insight client 
machine where this issue is encountered:

Open Internet Explorer and go to Tools -> Internet Options.

Click the Security tab and add the Argus Insight URL under Trusted Sites -> Sites.

Within the Security tab, go to Trusted Sites and click Custom Level -> Scripting -> 
Enable XSS Filter.
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Select the Disable radio button and click OK.

Click OK in Internet Options to save the changes and exit.

■ Execute the procedure below to enable this feature.

Run regedit in the run command

Go to HKEY_USERS -> .DEFAULT -> Control Panel-> International

Select sCountry from the right pane. Set this entry as United States.

Press OK to overwrite.

Reboot the server.

These settings will set the language for the default user profile as U.S. English.
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2Installation Procedures

This chapter explains how to install Argus Insight on the Web Server and Cognos 
Server. Before you begin, make sure you have read the Hardware and Software 
Requirements topic.

Follow these installation procedures in the order in which they appear:

■ Install Argus Insight Components on the Web Server

■ Install Argus Insight Components on the Cognos Server

2.1 Install Argus Insight Components on the Web Server
Before running the Argus Insight Installer, make sure you have created the Argus 
Insight database instance and that it is running. Also, the database should have been 
created by using the character set of your Argus Safety database.

The Argus Insight installer installs these components:

■ Argus Insight v6.0 application

■ Universes, Dashboards, Standard Reports, and Cubes

■ Schema Creation Tool

2.1.1 Prerequisites

Please ensure that the following settings are configured in IIS before running the 
installer.

1. On the Argus Insight Web Server Desktop, select Start > Programs > 
Administrative Tools > Internet Services Manager.

2. The Internet Information Services window appears.

Caution: On the Argus Insight Web Server, make IUSR_
<MACHINE NAME> user a member of the Administrators group. 
On a Windows 2008 Server, make IUSR a member of the 
Administrators group.
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3. Expand the control tree item corresponding to the Web Service Extensions and 
configure the settings, as displayed in the right pane.

Follow these steps to run the Installer and install the preceding components:

1. Log on to the Argus Insight Web Server as an Admin user.

2. Insert the Argus Insight v6.0 CD into the CD-ROM drive of your Argus Insight 
Web Server or copy the Argus Insight software locally on the Insight web server.

3. Click Launch.exe.

4. Click Installation Wizard.

Note: Perform the same settings on the Cognos Server.



Install Argus Insight Components on the Web Server

Installation Procedures 2-3

5. When the system opens the following dialog, click Next>.

6. Select Cognos 8 and click Next>.
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7. Select the Argus Insight Web Server option. Click Next>.

8. Enter User Name and Company Name. Click Next.
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9. Select the required checkboxes, as per the components you want to install. Click 
Next.

10. Click Next to accept the default installation location: C:\Program Files\Oracle. 
Click Browse if you want to specify an alternate installation location.
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11. Click Install to start the installation.

12. When the system opens the following screen, enter the name of the host database 
server where the Argus Insight datamart is located. Click Next>.
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13. When the system opens the following screen, enter instance name for the Argus 
Insight datamart. Click Next>.

14. Enter the database port number you want to assign to the Argus Insight database. 
Click Next>.
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15. When the system presents the following message, wait while the Installation 
Wizard updates the TNSNAME.ORA file.

16. Enter the password for APR_USER.
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17. When the system opens the following screen, re-enter the password for APR_
USER for verification.

18. When the system opens the following dialog box, enter the port number you want 
to assign to the Argus Insight Web site. Click Next.

Note: This database user provides initial database access to 
application user (APR_APP) of Argus Insight. In previous versions, 
this user was having a hardcoded password which has been removed 
in this version. Please make sure that this password is same on all 
machines where any Argus Insight components are stored.

You will be prompted to create/update this user during schema 
creation. You can modify this password by running the Argus Insight 
installer using modify option. For information about updating the 
APR_USER password see "Updating the APR_User Password".



Install Argus Insight Components on the Web Server

Installation Procedures 2-10

19. When the system opens the following dialog box, click Finish.

20. The system presents the following message. Click OK to restart the Argus Insight 
Web Server.
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2.1.2 Updating the APR_User Password
Please make sure to do the following before updating the password for APR_USER on 
any of the Insight server:

■ Stop the Argus Insight and Argus Perceptive Services

■ Stop IIS on the Insight Web server and Cognos server

■ Stop the Cognos service on Cognos server

■ Update the password of APR_USER on database level

You can modify the password for APR_USER on any Insight server by running the 
Argus Insight installer.

1. Start the Argus Insight installer.

2. When the system opens the following dialog box, select Modify. Click Next>.

3. When the system opens the following dialog box, select Change the password for 
APR_USER. Click Next>.
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4. When the system opens the following dialog box, enter the APR_USER password. 
Click Next>.

5. When the system opens the following dialog box, enter the APR_USER password 
a second time for verification. Click Next>.
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The password of APR_USER is updated successfully.

2.1.3 Configuring the Cognos 8 Software Development Kit (SDK)
Use the following procedure to configure the Cognos 8 SDK:

1. Copy the CDK.dll from Cognos Server placed at C:\Program 
Files\Cognos\c8\sdk.

2. Paste this file in <Insight Installation Directory>/Oracle/ArgusInsight/Bin folder.

3. Register this file using regsvr32 command from command prompt.

2.2 Install Argus Insight Components on the Cognos Server
Before performing this installation be aware of the following:

■ This installation is required only if you are using different servers for Argus 
Insight and Cognos 8/Cognos Cubes.

■ If you are using Cognos Series 7.4 software, install this component on the server 
where the Series 7.4 software is installed.

Use the following procedure to install Argus Insight components on the Cognos 8 
Server:

1. Log on to the Cube Server as an Admin user.

2. Insert the Argus Insight v6.0 CD into the CD-ROM drive of your Cognos Server to 
start the installation program or copy the Argus Insight software locally on the 
Cognos server.

3. Click Launch.exe.
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4. When the system opens the following dialog box, click Installation Wizard to start 
the installation.

5. When the system opens the following dialog box, click Next>.

6. When the system opens the following dialog box, click Cognos 8. Click Next>.
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7. When the system opens the following dialog box, click Cognos Server. Click 
Next>.

8. Enter User Name and Company Name. Click Next.
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9. When the system opens the following dialog box, click the Cognos Cube Files and 
Cognos Server Files check boxes to select them. Click Next.
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10. When the system opens the following dialog box, click Next to accept the default 
installation location: C:\Program Files\Oracle. Click Browse if you want to 
specify an alternate installation location.

11. When the system opens the following dialog box, click Install.

12. The installer installs the selected components.
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13. When the system opens the following dialog box, enter the host name of the 
database server where the Argus Insight datamart is located. Click Next>.

14. When the system opens the following dialog box, enter the name of the Argus 
Insight datamart. Click Next>.
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15. When the system opens the following dialog box, enter the database port number 
you want to assign to the Argus Insight database. Click Next>.

16. Wait while the Installation Wizard updates the TNSName.ORA file.

17. When the system opens the following dialog box, enter the APR_USER password. 
Click Next.
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18. When the system opens the following dialog box, re-enter the password for APR_
USER password for verification. Click Next>.

19. When the system opens the following dialog box, click Finish to complete the 
installation.

Note: This database user is used for providing initial database access 
to application user(APR_APP) of Argus Insight. In previous versions, 
this user was having a hardcoded password which has been removed 
in this version. Please make sure that this password is same on all 
machines where any components of Argus Insight are stored.
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20. When the system displays the following message, click OK to restart the Cognos 8 
Server.
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3Create the Argus Insight Datamart Structure

The Argus Insight Schema Creation Tool lets you create the Argus Insight Datamart 
structure. It creates a link between your source Argus database and your new Argus 
Insight Datamart. The ETL process uses this link to transfer data from your Argus 
database to the Argus Insight Datamart for reporting purposes. During this process, 
you are required to create four database users: one for logging in to the Argus Insight 
application, two other users who are schema owners, and one for supporting Private 
DB Links.

Before you run the schema creation tool, contact your Database Administrator (DBA) 
to verify these database parameter values in the Database configuration file for the 
Argus Insight database:

■ global_name = false

■ job_queue_processes=10

■ Add "SET ARRAYSIZE 5000" in file glogin.sql ($ORACLE_
HOME/sqlplus/admin/glogin.sql)

3.1 Argus Insight Database Parameters
The following table lists the minimum values required on different Database 
Parameters for Argus Insight. The Database Administrator should monitor these 
values to increase/decrease the parameters.

Note: The Argus Insight database must be created with same 
Character Set as the Argus Safety Database. Make sure you have 
installed that requisite software as explained in the Hardware and 
Software Requirements topic.

S. No.

Argus Insight 
Database 
Instance 
Parameters

Small (Less 
than 30,000 
Cases)

Medium (30,000 
- 200,000 Cases)

Large (200,000 
- 1 Million 
Cases)

Very Large 
(More than 1 
Million 
Cases)

RemarksValue Value Value Value

1 Shared_Pool_Size Default Default Default Default

2 DB_Block_Buffers 
(Size in MB) / DB_
Cache_Size

Default Default Default Default
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3 DB_Block_Size 
(bytes)

Default Default Default Default

4 SGA_Target 1 GB 2.5 GB 3.5 GB 4.5 GB The 32-bit 
architectur
e allows 
for 4 GB of 
physical 
memory 
to be 
addressed, 
DBAs are 
requested 
to verify 
the 
maximum 
addressabl
e RAM for 
their 
respective 
architectur
es.

5 SGA_Max_Size >= value for 
SGA_TARGET

>= value for 
SGA_TARGET

>= value for 
SGA_TARGET

>= value for 
SGA_TARGET

6 PGA_
AGGREGATE_
TARGET

0.5 GB 2 GB 3 GB 4 GB

7 CURSOR_
SHARING

EXACT EXACT EXACT EXACT

8 OPTIMIZER_
SECURE_VIEW_
MERGING

TRUE TRUE TRUE TRUE

9 WORKAREA_
SIZE_POLICY

AUTO AUTO AUTO AUTO

10 QUERY_
REWRITE_
ENABLED (If 
Computing 
Statistics regularly)

TRUE TRUE TRUE TRUE

QUERY_
REWRITE_
ENABLED (If Not 
Computing 
Statistics regularly)

FALSE FALSE FALSE FALSE

11 QUERY_
REWRITE_
INTEGRITY

Default Default Default Default

12 GLOBAL_NAME False False False False

13 PARALLEL_MAX_
SERVERS

16 32 Default Default

14 OPTIMIZER_
MODE

ALL_ROWS ALL_ROWS ALL_ROWS ALL_ROWS

15 COMPATIBLE (For 
Oracle 10g)

10.2.0.1 or 
Higher

10.2.0.1 or Higher 10.2.0.1 or 
Higher

10.2.0.1 or 
Higher

16 COMPATIBLE (For 
Oracle 11g)

11.1.0.6 or Higher 11.1.0.6 or Higher 11.1.0.6 or 
Higher

11.1.0.6 or 
Higher

S. No.

Argus Insight 
Database 
Instance 
Parameters

Small (Less 
than 30,000 
Cases)

Medium (30,000 
- 200,000 Cases)

Large (200,000 
- 1 Million 
Cases)

Very Large 
(More than 1 
Million 
Cases)

RemarksValue Value Value Value
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3.2 Argus Insight Mart Tablespaces
The following are the Tablespaces for Argus Insight MART.

17 UNDO_
MANAGEMENT

AUTO AUTO AUTO AUTO

18 NLS_LENGTH_
SEMANTICS

CHAR CHAR CHAR CHAR

S. No.

Argus Insight 
Database I/O 
Configuration

Small Medium Large Very Large

RemarksValue Value Value Value

1 Number and Size 
of Redo Log Files

Default 3 X 500 MB 5 X 500 MB 5 X 500 MB Depends on the 
characteristics of the I/O 
subsystem like the I/O 
bandwidth, Storage 
Disks type, RAID Level, 
etc. (Oracle recommends 
RAID 1+0 or similar)

2 TEMP Tablespace 
size

32 GB 32 GB 64 GB 128 GB

3 Undo Tablespace 
size

16 GB 32 GB 64 GB 128 GB The recommended 
UNDO Tablespace size is 
based on the projections 
with the following two 
Parameter values:

RETENTION=NOGUAR
ANTEE

UNDO_
RETENTION=900 
(seconds)

S. No.

Argus Insight 
Database Server 
Configuration

Small Medium Large Very Large

RemarksValue Value Value Value

1 RAM 4-8 GB 8-16 GB 16-32 GB 16-32 GB

2 CPU Equivalent 
to 2-4 Dual 
Core, 3GHz

Equivalent to 
4-8 Dual 
Core, 3GHz

Equivalent 
to 16 Dual 
Core, 3GHz

Equivalent to 
24 Dual Core, 
3GHz

Note: The Argus Insight Database and Argus Database TNS names 
entry must be available in both Argus Insight Database Server and 
Argus Safety Database Server. Argus Safety Database TNS should also 
be present in the Argus Insight Web server.

S. No.

Argus Insight 
Database 
Instance 
Parameters

Small (Less 
than 30,000 
Cases)

Medium (30,000 
- 200,000 Cases)

Large (200,000 
- 1 Million 
Cases)

Very Large 
(More than 1 
Million 
Cases)

RemarksValue Value Value Value
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S.No. Tablespace S.No. Tablespace

1 APR_CFG_DATA_01 19 APR_MRPT_DATA_02

2 APR_MCAS_DATA_01 20 APR_MRPT_DATA_03

3 APR_MCAS_DATA_02 21 APR_MRPT_INDEX_01

4 APR_MCAS_INDEX_01 22 APR_MRPT_INDEX_02

5 APR_MCAS_INDEX_02 23 APR_MRPT_INDEX_03

6 APR_MCAS_LOB_01 24 APR_MWHOC_DATA_01

7 APR_MCFG_DATA_01 25 APR_MWHOC_INDEX_01

8 APR_MCFG_INDEX_01 26 APR_SESM_DATA_01

9 APR_MCFG_LOB_01 27 APR_SESM_INDEX_01

10 APR_MCFG_LOG_01 28 APR_SESM_LOB_01

11 APR_MEDM_DATA_01 29 APR_STAGE_DATA_01

12 APR_MEDM_INDEX_01 30 APR_STAGE_DATA_02

13 APR_MEDM_LOB_01 31 APR_STAGE_DATA_03

14 APR_MFACT_DATA_01 32 APR_STAGE_INDEX_01

15 APR_MFACT_DATA_02 33 APR_STAGE_INDEX_02

16 APR_MFACT_INDEX_01 34 APR_STAGE_INDEX_03

17 APR_MFACT_INDEX_02 35 APR_STAGE_LOB_01

18 APR_MRPT_DATA_01 36 APR_SWHOC_DATA_01

S.No. Tablespace

37 APR_MCAS_HIST_DATA_01

38 APR_MCAS_HIST_DATA_02

39 APR_MCAS_HIST_INDEX_01

40 APR_MCAS_HIST_LOB_01

41 APR_MCFG_HIST_INDEX_01

42 APR_MCFG_HIST_LOB_01

43 APR_MFACT_HIST_DATA_01

44 APR_MFACT_HIST_DATA_02

45 APR_MFACT_HIST_INDEX_01

46 APR_MFACT_HIST_INDEX_02

47 APR_MRPT_HIST_DATA_01

48 APR_MRPT_HIST_DATA_02

49 APR_MRPT_HIST_DATA_03

50 APR_MRPT_HIST_INDEX_01

51 APR_MRPT_HIST_INDEX_02

52 APR_MRPT_HIST_INDEX_03
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3.3 Creating the Database Schema
Use the following procedure to create the database schema and run the Initial ETL.

1. Log in (RDC) to Insight Web Server after installing Argus Insight 6.0 application 
using build.

INSTALLDIR: - Default is "C:\Program Files\Oracle"

3.3.1 Creating Users and Roles in the Argus Safety Database
1. Run the schema creation tool.

2. Click Argus User Creation.

3. When the system opens the following dialog box, enter the Argus Safety database 
instance name and password for "SYSTEM". Click OK.

4. When the system opens the following dialog box, click New User.
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5. When the system opens the following dialog box, enter the name of the Argus 
Safety user you wish to create in the New User Name field. Click OK.

6. When the system redisplays the following dialog box, click New Role.

7. When the system opens the following dialog box, enter the name of the role to 
create in the New Role field. Click OK.

8. When the system opens the following dialog box, select New User Name and 
New Role from the dropdown menu as 'INSIGHT_RO_USER' and 'INSIGHT_RO_
ROLE'.

9. When the system opens the following dialog box, click Browse to select the 
location for the log files.

10. When the system opens the following dialog box, enter the name of the log file 
where you want to store the user creation information in the File name field.

Note: You must create the INSIGHT_RO_USER and INSIGHT_RO_
ROLE even if they already exist in the Argus Safety schema. Make the 
appropriate selection in step 8 below for New User Name and New 
Role drop downs and proceed.
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11. When the system returns to the following dialog box, click OK.

12. When the system opens the following screen, verify that the information on the 
screen is correct and press Enter.
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13. When the system displays the following screen, verify that the information is 
correct and press Enter to complete the installation.

14. When the system displays the following message, click OK.

15. When the system redisplays the following dialog box, click View Log File.
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16. When the system displays the log file, verify the log file for any errors during read 
only user creation.

17. Close the log file.

18. Click Close button to close the 'Argus Safety Read Only User Creation' dialog.

3.3.2 Creating a New Database Schema
Use the following procedures to create or upgrade the database schema, as applicable.

3.3.2.1 Clearing the Cache
If you are using the same DB Installer used to create an earlier schema, you must clear 
its cache. Use the following procedure to clear the cache.
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1. Press and hold the CTRL key and right-click the mouse.

2. When the system presents the following dialog box, click Yes.

The system logs the action in the createlog.rtf file.

3.3.2.2 Creating a New Schema for Argus Insight
Use the following procedure to create a new schema for Argus Insight:

1. Go to Start>Programs>Oracle>Argus Insight>Schema Creation Tool.

2. When the system opens the following dialog box, click Create Schema.

Note: You mustconvert the Oracle parameter NLS_LENGTH_
SEMENTICS to CHAR in the Argus Insight data mart and restart the 
database instance. You will not be able to proceed further without 
changing the NLS_LENGTH_SEMENTICS to CHAR.
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3. When the system opens the following dialog box:

■ Enter the SYSTEM user password in the Password field.

■ Type the TNS Entry for the Insight Database in the Database field.

■ Click OK.

4. The system displays the following message if the NLS_LENGTH_SEMANTICS 
parameter is not set to CHAR. You must set this parameter before you can 
proceed.

5. When the system opens the following dialog box, set the APR_MART password. 
Click OK.

6. When the system opens the following dialog box, set the APR_APP password. 
Click OK.
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7. When the system opens the Argus Insight Schema Creation Options screen, click 
New User to create the following users:

■ APR_STAGE

■ APR_LOGIN

■ APR_HIST

■ APR_MART_DB_LINK_USER

Note: This user will be used for all the application access and 
reporting. The password for this user is stored in encrypted form in 
CMN_PROFILE table. We cannot change password of this user as it 
will break down the Insight application access. If you wish to change 
the password for this user, please contact Oracle support for getting 
encrypted value of new password.
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8. When the system opens the New User dialog box, do the following:

a. Enter one of the following names in the New User Name field:

– APR_STAGE

– APR_LOGIN

– APR_MART_DB_LINK_USER

– APR_HIST

b. Enter the user password in the New User Password field.

c. For verification, enter the user password in the Re-enter Password field.

d. Click OK.

e. The system redisplays the Argus Insight Schema Creation Options screen.

f. Repeat Step 7 and Steps 8a through 8d until you have created all four (4) users.
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9. When the system redisplays the Argus Insight Schema Creation Options screen, 
click New Role to create the following user roles:

a. APR_ROLE

b. APR_MART_DB_LINK_ROLE

c. APR_APP_ROLE

10. When the system opens the New Role dialog box, do the following:
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a. Enter one of the following names in the New Role field:

– APR_ROLE

– APR_MART_DB_LINK_ROLE

– APR_APP_ROLE

b. Click OK.

c. The system redisplays the Argus Insight Schema Creation Options screen.

d. Repeat Step 9 and Steps 10a through 10c until you have created all three (3) 
roles.

11. When the system redisplays the Argus Insight Schema Creation Options screen:

a. Select APR_MART_DB_LINK_USER in the Database Link Schema Owner 
field of MART Database Link Information section.

b. Select APR_MART_DB_LINK_ROLE in the Database Link Role field of 
MART Database Link Information section.

c. Enter INSIGHT_RO_USER in the Database Link Schema Owner field of 
Argus Database Link Information section.

12. Click Generate.

Note: Enter the insight read only user name in 'Database Link 
Schema Owner' text box of Argus Safety link information, created 
using 'Argus User Creation'. Button.
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13. When the system prompts for staging user's password (APR_STAGE user's 
password), enter the password and click OK.

Note: If you want to change the password for APR_USER, edit the 
entries for APR_USER password textbox.

Note: The system displays the following message if the MART 
Character set is not same as the Argus character set. Please make sure 
the character sets for Argus Insight and Argus Safety database are the 
same.
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14. Click Yes to proceed with schema creation (not recommended) else press No.

15. When the system displays the following message, follow these steps:

a. If you do not have remote access to SYS User, follow the instructions given in 
the message box "Check SYS Access" provided above. After executing the ai_
sys{grant}.sql through SYS user, Click No and go to Step 16 of this procedure.

b. If you do have remote access to SYS user, click Yes and go to Step 15 of this 
procedure.

16. When the system opens the following dialog box, provide the SYS user password 
and click OK.

Note:

■ If character set of Argus Safety database is UTF and Insight 
database is ISO, the ETL process may fail due to different 
character set.

■ If character set of Argus Safety database is ISO and Insight 
database is UTF, then we can proceed by ignoring the character set 
difference.
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17. The system opens the Tablespace Creation screen as follows:

■ Schema Creation Tool will automatically select the Delimiter Character for the 
Directories radio button, based on the Database Server Operating System.

■ Provide the datafile path in "Enter Database Server Directory….." Textbox (For 
e.g. /u01/app/oracle/SMTEST, PLEASE MAKE SURE THIS DIRECTORY 
EXISTS) and click on button "Generate Datafile path and name".

■ It will fill "Complete Path and Datafile" textboxes for all table spaces.

18. Click Create Tablespace to create all table spaces.

19. Wait while the system creates the table spaces.

20. When the system opens the following window, click Continue to Start Schema 
Creation.
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21. When the system displays the following window, schema creation is complete. 
Click Finish.

3.3.2.3 Loading Factory Data
Use the following procedure to load the factory data:

1. Click Factory Data to load the factory data.
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2. The system displays the following message when it finishes loading the factory 
data.

3.3.3 Upgrading an Existing Argus Insight Schema
This section provides instructions for the upgrading from the following:

Argus Insight v5.1/5.1.1 to Argus Insight v6.0

1. Go to Start > Programs > Oracle > Argus Insight > Schema Creation Tool.

Note: Before upgrading a schema, ensure that you have validated 
the schema with the CTL file of the existing Argus Insight version. For 
example, before upgrading from Argus Insight 5.1 to Argus Insight 
6.0, validate the schema for Argus Insight 5.1.

Note: We recommend that you stop the Cognos service on Cognos 
server before starting the schema upgrade. You can start the Cognos 
service once schema upgrade is complete.
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2. Follow the instructions given in section "Creating Users and Roles in the Argus 
Insight Database" for creating Argus User and Role before proceeding for the DB 
Upgrade.

3. Once Argus User and role creation is complete, Click DB Upgrade.

4. When the system opens the following dialog box, do the following:

■ Enter the SYSTEM user password in the Password field.

■ Enter the TNS Entry for the Argus Insight Database in the Database field.

■ Click OK.

5. When the system opens the Upgrade Parameters window, enter the following 
information:

a. Type passwords in the following fields:

– SYS Owner Password

– Mart Schema Owner Password

– Application Owner Password

– History Owner Password

– Staging Schema Owner Password
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Click Next.

6. When the system opens the following window, click Add to add a new data file to 
an existing tablespace.

Note: As shown in the tool tip, enter the password for APR_USER 
only if you wish to modify it, otherwise leave this field blank.
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7. On clicking Add, the system opens the following dialog box. Enter the new data 
file name in the Database File Name field. Click OK.

8. Perform the above two steps to add all the tablespaces.

9. After adding and creating all the needed tablespaces and data files, click Next.
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10. When the system opens the following window, click Continue to start the 
upgrade.

11. When the system completes the upgrade, click OK.

12. The system opens the following screen. Click Finish to complete the upgrade.
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3.3.3.1 Using the User Password Update Utility

Execute the following steps if you wish to use the Upgrade utility:

1. Go to the <Insight_Install_Path>\Database\DBInstaller folder and double-click 
AIPwdUpdate.exe. The following screen is displayed.

2. Enter the database name and click Update User Passwords. On successful update, 
the following dialog is displayed. 

Note: If you have upgraded Argus Insight 6.0 using an Argus Safety 
version earlier than the 6.0 version, and have then upgraded Argus 
Safety to its 6.0 version, you need to execute the User Password 
Update Utility. To use this utility, click the AIPwdUpdate.exe present 
in the \Oracle\Database\DBInstaller folder.
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3. Click OK. The password process has been updated successfully. 

3.4 Validate the Schema
Use the following procedure to validate the database schema:

1. Click Schema Validation to validate the schema.

2. When the system opens the following dialog box, enter the SYSTEM password and 
MART instance name and click OK.

3. When the system opens the following dialog box, click Browse to the right of the 
Validation CTL Folder and File field.
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4. When the system opens the following window, select the validation CTL file. Click 
Open.

5. When the system redisplays the following dialog box, click Browse to the right of 
the Select Log Files Folder field.
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6. When the system opens the following dialog box, select the Log files folder. Click 
OK.

7. Click Validate Schema.

8. The system displays a series of command screens as follows. Press Enter when 
prompted to do so.
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9. When the system opens the following dialog box, click OK.

10. When the system displays the log file, verify the log file for any schema 
discrepancies.
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3.5 Create DB Link from Argus Safety to Argus Insight Database
Use the following procedure to create the database link from the Argus Safety 
database to the Argus Insight database.

1. Go to Start>Programs>Oracle>Argus Insight>Schema Creation Tool.

2. Click Argus DBLink.

3. When the system opens the following dialog box, enter the information for the 
Argus Safety database. Click OK.

4. When the system opens the following dialog box, enter the following:
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Under Argus Safety Information:

■ Select the Argus Safety Schema Owner in the Schema Owner field.

■ Select the Argus Safety role in the Safety Role field.

■ Select the Insight_RO_Role in the Read Only Role field.

Under Argus Insight Information:

■ Enter the name of the Argus Insight database in the Database field.

■ Enter the name of the RO user in the RO user field.

■ Enter the password for the RO user in the RO User Password field.

■ Click Browse.

5. When the system opens the following window, select the Log File for storing the 
DBLink creation information. Click Save.
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6. When the system returns to the following dialog box, click OK.

7. When the system opens the following dialog boxes:

■ Enter the ARGUS_APP database information. Click OK.

■ Enter the SYSTEM database information. Click OK.

8. When the system opens the following command screen, press Enter to finish.

9. When the system opens the following dialog verify the log files. Click OK.
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4Configure the Argus Insight Application

This chapter provides information for configuring the Argus Insight application and 
the Argus Insight scheduling service. 

4.1 Configure the Argus Insight Application Profile Switches
Use the following procedure to configure the Argus Insight profile switches. For more 
information about setting common profiles switches, see the CMN_PROFILE Guide 
(CMN_PROFILE.pdf).

1. Log on with administrative rights to a workstation from where you can access the 
Argus Insight application.

2. Start Internet Explorer.

3. In the Address bar, type the URL http://<Argus Insight Web Server Name> :< 
port number>/default.asp and press Enter.

4. When the system opens the Argus Insight login screen:
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a. Type administrator in the User Name field.

b. Type password in the Password field.

c. Click Login.

5. When the system opens the following window, click the Tools tab in the 
upper-right corner of the main to open the Administration Tools page.

6. Click the List Maintenance tab. When the system opens the List Maintenance tab:

Note: If you have logged-in to the system for the first time, it is 
recommended that you change your login credentials. For account 
security reasons, ensure that you change your password after logging 
in for the first time.
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a. Select Profile Switches from the List Maintenance Items list. 

b. Select COMPANY LOGO PATH from the Attributes list.

c. Click Modify.

7. When the system opens the following dialog box:

a. Enter http://argusinsightwebserver:8084/apr_logo.jpg in the Value field. This 
is the company logo path name.

b. Click OK to save the modification and return to the List Maintenance tab.

8. Select COGNOS CUBE SERVER from the Attributes list on the List Maintenance 
tab. Click Modify.

9. When the system opens the following dialog box:

a. Type the Cognos 8/Cognos Cube Server name in the Value field. 
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b. Click OK to save the modification and return to the List Maintenance tab. 

10. Select Cognos Cube Version from the Attributes list on the List Maintenance tab. 
Click Modify.

11. When the system opens the following dialog box:

a. Depending on the Cube version, enter COGNOS8 or SERIES7 in the Values 
field

b. Click OK.

12. Select COGNOS SERVER from the Attributes list on the List Maintenance tab. 
Click Modify.

13. When the system opens the following dialog box:

Note: Enter Cognos 8 Server name if you are using Cognos 8 
Transformer.

Enter Cognos Cube Server name if you are using Cognos Series 7.4 
softwares.
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a. Enter the Cognos 8 server name and Port number in the Value field in the 
following format:  ServerName:PortNumber.

b. Click OK to save the modification and return to the List Maintenance tab.

14. Select COGNOS CUBE Password from the Attributes list on the List Maintenance 
tab. Click Modify.

15. When the system opens the following dialog box:

Note: Value of Cognos server will be like Cognos 8 Server:Cognos 8 
Port number (srv001:9300). 9300 is the default port for Cognos 8 
application.
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a. Enter the Cognos Cube password in the Value field. This is the password you 
specify in Access Manager Administration.

b. For verification, re-enter the password in the Confirm Password field.

c. Click OK to save the modification and return to the List Maintenance tab.

16. Select COGNOS CUBE USER from the Attributes List on the List Maintenance tab. 
Click Modify.

17. When the system opens the following dialog box:

Note: The values listed in the preceding configuration apply only if 
you are using Series 7 software for Cubes.
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a. Enter the name of Cognos Cube User. The default is administrator.

b. Click OK to save the modification and return to the List Maintenance tab. 

18. Select ARGUS INSIGHT SERVER from the Attributes List on the List Maintenance 
tab. Click Modify.

19. When the system opens the following dialog box:

a. Enter the name of Argus Insight Server in the Values field. 

b. Click OK to save the modification and return to the List Maintenance tab.

20. Select POPULATE CUBES FACT DATA from the Attributes List on the List 
Maintenance tab. Click Modify.

21. When the system opens the following dialog box:
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a. Enter the value as “1” or “3” in the Value field. 

b. Click OK to save the modification and return to the List Maintenance tab.

22. Select POPULATE AFFILIATE DATA from the Attributes List on the List 
Maintenance tab. Click Modify.

23. When the system opens the following dialog box:

Note: For Argus Insight with BOXI, set this value to 1.

For Argus Insight with Cognos, set this value to 2.

For populating all tables of cubes, set this value to 3. 
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a. Enter the value of the Affiliate data in the Value field. 

b. Click OK to save the modification and return to the List Maintenance tab.

24. Select POPULATE DLL SLL REPORTS TABLE DATA from the Attributes List on 
the List Maintenance tab. Click Modify.

25. When the system opens the following dialog box:

a. Enter the value of the DLL SLL Reports Table Data in the Value field.

– Click OK to save the modification and return to the List Maintenance tab.

26. Select POPULATE INTERCHANGE DATA from the Attributes List on the List 
Maintenance tab. Click Modify.

27. When the system opens the following dialog box:
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a. Enter the value of the Interchange Data in the Value field. 

b. Click OK to save the modification and return to the List Maintenance tab.

28. Select POPULATE WHO DRUG C DATA from the Attributes List on the List 
Maintenance tab. Click Modify.

29. When the system opens the following dialog box:

a. Enter the value of the Populate WHO Drug C Data in the Value field. If you 
want to populate the WHO Drug C tables, enter 1; otherwise, enter a 0.

b. Click OK to save the modification and return to the List Maintenance tab.

30. Select WHO DRUG BROWSER FORMAT from the Attributes List on the List 
Maintenance tab. Click Modify.

31. When the system opens the following dialog box:
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a. Enter the value of the WHO Drug Browser Format in the Value field. This 
entry will be used to open the WHO Drug B/C Format, as configured in the 
following dialog box.

b. Click OK to save the modification and return to the List Maintenance tab.

32. Select ETL EMAIL SETUP from the Attributes List on the List Maintenance tab. 
Click Modify.

33. When the system opens the following dialog box:

a. Enter the value for the ETL Email Setup in the Value field. 

b. Click OK to save the modification and return to the List Maintenance tab.
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34. Select ETL EMAIL SENDER ADDRESS from the Attributes List on the List 
Maintenance tab. Click Modify.

35. When the system opens the following dialog box:

a. Enter the email address of the person sending ETL status email messages in 
the Value field.

b. Click OK to save the modification and return to the List Maintenance tab.

36. Select ETL EMAIL RECEIVER ADDRESS from the Attributes List on the List 
Maintenance tab. Click Modify.

37. When the system opens the following dialog box:
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a. Enter the email address of the person receiving ETL status email messages in 
the Value field. 

b. Click OK to save the modification and return to the List Maintenance tab.

38. Select Populate Perceptive Data from List Maintenance tab to populate the 
Perceptive data.

a. Enter the Perceptive data population switch value in the Value field.
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b. Click OK to save the modification and return to the List Maintenance tab.

39. Populate Optional Table switches used for different Argus Insight Reports

Set the following switches to “1” only if you are using the corresponding reports 
as mentioned with the switch name.

POPULATE RPT_REG_REPORTS COLUMNS:

0 = Extra columns of table RPT_REG_REPORTS will NOT be populated, 1 = Extra 
columns of table RPT_REG_REPORTS will be populated (These columns are used 
in Business Objects version, Compliance category report "Regulatory Submission 
and Distribution Compliance")

POPULATE NARRATIVE LANGUAGES TABLE:

0 = Tables RPT_CNL_MLINGUAL and RPT_CNL_ENGLISH will NOT be 
populated, 1 = Tables RPT_CNL_MLINGUAL and RPT_CNL_ENGLISH will be 
populated. These tables are used by General Category Reports 'Case Narrative 
Listing - Multilingual" and "Case Narrative Listing - English".

POPULATE DATA QUALITY INDICATOR:

0= Table DATA_QUALITY_INDICATOR required for Data Quality Indicator 
report will NOT be populated, 1 = Table DATA_QUALITY_INDICATOR required 
for “Data Quality Indicator report” will be populated. 

Note: Ensure that you run the initial ETL after updating any of the ETL Population 
switches. The only exception to this is the Populate WHO Drug C Data switch, for 
which you need not run the initial ETL.

Select LOGO IMAGE from Attributes List on the List Maintenance tab to configure 
the logo for Argus Reports.

a. Enter the logo image path from Insight Web Server in the Value field. For 
example, enter the Value as C:\apr_logo.gif. Ensure that the size of this file is 
155x53 pixels. 
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b. Click OK to save the modification and return to the List Maintenance tab.

40. Select DAYS TO LOCK from the Attributes List on the List Maintenance tab. Click 
Modify.

41. When the system opens the following dialog box:

a. Enter an appropriate value in the Value field. 

b. Click OK to save the modification and return to the List Maintenance tab.

42. Select FOLLOW-UP ACTION CODE from the Attributes List on the List 
Maintenance tab. Click Modify.

43. When the system opens the following dialog box:

Note: The following profile switch configuration steps need to be 
performed only by customers who are using the validation package 
supplied by Oracle.
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a. Enter the Follow-up Action Code in the Value field. 

b. Click OK to save the modification and return to the List Maintenance tab.

44. Select FOLLOW GEN from the Attributes List on the List Maintenance tab. Click 
Modify.

45. When the system opens the dialog box:

a. Select Follow-Gen from the list box.

b. Click OK to save the modification and return to the List Maintenance tab.

4.1.1 Configuring Workflow Management
Use the following procedure to configure workflow management for the Argus Insight 
application. Workflow is company-specific and your company may not use all the 
Workflow states.

1. Select Workflow Management from the List Maintenance Items list.
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2. Select Archiving States from the Attributes list. Click Modify.

3. When the system opens the following dialog box:

a. Select Germany Expediting Reporting, US-Reporting and Japan Reporting 
from the list on the left.

b. Click > to add them as Archiving States.

c. Click OK to save the modification and return to the List Maintenance tab.

4. Select Data Entry Complete from the Attributes list on the List Maintenance tab. 
Click Modify.

5. When the system opens the following dialog box:
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a. Select Germany Data Validation, US-Validation, and Japan Validation from the 
list on the left.

b. Click > to add them as Data Entry Complete.

c. Click OK to save the modification and return to the List Maintenance tab.

d. Remove the Closed item from the list on the right by selecting Closed and 
clicking <. 

e. Click OK to save the modification and return to the List Maintenance page.

6. Select Assessment Complete from the Attributes list on the List Maintenance tab. 
Click Modify.

7. When the system opens the following dialog box:

a. Select Germany Medical Review, US Medical Review, and Japan Medical 
Review from the list on the left.

b. Click > to add them as Assessment Complete.

c. Click OK to save the modification and return to the List Maintenance tab.
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d. Remove the Closed item from the list on the right by selecting Closed and 
clicking <. 

e. Click OK to save the modification and return to the List Maintenance page.

8. Select Approval Complete from the Attributes list on the List Maintenance tab. 
Click Modify.

9. When the system opens the following dialog box:

a. Select Germany Medical Review, US Medical Review, and Japan Medical 
Review from the list on the left.

b. Click > to add them as Approval Complete.

c. Click OK to save the modification and return to the List Maintenance tab.

d. Remove the Closed item from the list on the right by selecting Closed and 
clicking <. 

e. Click OK to save the modification and return to the List Maintenance page.

10. Click the Logout icon in the upper-left corner of the page to exit Argus Insight.

4.1.2 Configuring the Product Datasheet
Use the following procedure to configure the product datasheet.

1. Login to Argus Insight.

2. Go to Admin Tools -> List Maintenance tab.
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3. Select Datasheet fields from the attribute list.

4. Specify the DATASHEET BPI, EMEA, IB and PI fields value column of CASE_
PRODUCT through Profile Switches as shown in the following illustration.

4.1.3 Configuring the Investigational Datasheet/Marketed Datasheet /Date Difference 
Band 

In order to get dimensional data from the Medical Analysis, Clinical Trial Analysis, 
and Overdose-Pregnancy-Interaction cubes, these attributes must be configured before 
initial ETL

■ Investigational Datasheet

The Listedness of the events corresponding to the configured investigational 
datasheet will be displayed in the "Event Listedness" dimension of the Clinical 
Trial Analysis Cube.

■ Marketed Datasheet 

The Listedness of the events corresponding to the configured Marketed datasheet 
will be displayed in the "Event Listedness" dimensions of the Medical Analysis 
and Overdose-Pregnancy-Interaction Cubes.

■ Date Difference Band 

The Listedness of the events corresponding to the configured Date Difference 
Band allows the user to configure the highest value of the dimensions which have 

Note: These attributes need to be configured before Initial ETL, in 
order to get data in dimensions with respect to the Medical Analysis, 
Clinical Trial Analysis and Overdose-Pregnancy-Interaction Cubes.
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Date Difference columns as data source in Administration Statistics and 
Submission Statistics Cube

For specific information on configuring Investigational Datasheet, Marketed 
Datasheet and Date Difference Band, please refer the Configuration base 
document (CBD) provided with the CD.

4.1.4 Configuring Duration Value Bands
In Argus Insight, the time values (entered in Argus Safety) in the Product Tab > Drug 
Duration of Administration, Events Tab > Time to Onset from First Dose, and Events 
Tab > Time to Onset from Last Dose fields can be mapped to specific ranges called 
Duration Value Bands. This enables you to specify querying criteria based on ranges 
instead of specific values for the above fields.

The Duration Values Bands item on the List Maintenance page enables you to 
configure the duration value bands in the hours, days, weeks, months, and years 
categories. In each category, the system enables you to specify multiple ranges by 
entering maximum and minimum value for each range item. Any value that falls 
within a configured range will map to that range.

In the Duration Value Bands Configuration dialog box, you can delete an existing 
range by clicking the Delete icon or you can modify a range by editing the values in 
the Higher Range (<) columns. Note that the lowest band cannot be deleted. 
Additionally, the highest value band includes values that are greater than the highest 
range value that you specify. To add a range, enter a higher range compared to the 
previous highest range in Higher Range (<) and press TAB. This adds a new row.

If you delete an intermediate range, the system automatically converts the highest 
value of the deleted to the lowest value in the next range. The range labels do not 
change.

Use the following procedure to configure Duration Values Bands.

1. On the List Maintenance tab, select the Duration Values Bands item from the List 
Maintenance Items list.

Note: Duration Value Band configuration must be done before 
running the Initial ETL.

If Duration Value Bands are modified after Initial ETL, you must 
re-run the Initial ETL.



Configure the Argus Insight Application Profile Switches

Configure the Argus Insight Application 4-22

The Attributes list displays the existing categories. These are default categories 
and cannot be modified.

2. Select an Attributes category. Click Modify.

3. When the system opens the Duration Value Bands Configuration dialog box, the 
system displays the factory-configure date ranges.
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■ The Label column is the name of the range.

■ The Lower Range (>=) and Higher Range (<) columns contain the minimum 
and maximum values, respectively.

a. Modify these values as appropriate.

b. Click OK to save the changes.

4.1.5 Configuring Derivation Functions
Argus Insight lets you create a new List Maintenance item and derive specific cases to 
this item based on case attributes. These attributes are supplied to the system as an 
SQL.

For example, you can create a new List Maintenance item called Report Type 1 and 
derive to this item, all the cases that have the Report Type attribute as Spontaneous, 
Literature, and Compassionate Use. As a result, the Report Type 1 List Maintenance 
item appears as an option in the query tool interface corresponding to the Report Type 
attribute. When you select the Report Type 1 from the Report Type list and execute 
your query, the system returns only those cases that have the report type attribute as 
Spontaneous, Literature, and Compassionate Use.

You can also create a specialized List Maintenance item called Report Type 1 US and 
derive to this item, all the cases that have the Report Type attribute as Spontaneous, 
Literature, and Compassionate Use and the Country of Incidence attribute as United 
States.

The Argus Field Mapping derivation rules are applicable as follows:

ANALYSIS->BfArM Information -> Causality

ANALYSIS->Case Assessment -> Listedness Determination

ANALYSIS->Case Assessment -> Case Outcome

ANALYSIS->Case Assessment -> Case Seriousness

EVENTS->Event Information -> Lack of Efficacy

GENERAL->General Information ->Report Type

GENERAL->General Information -> Pregnancy

PATIENT->Patient Information -> Age Group

PATIENT->Patient Information -> Patient weight BMI desc

PATIENT->Patient Information -> Patient Gender

PRODUCTS->Product Drug -> Derived Overdose

PRODUCTS->Product Drug -> Derived Drug Abuse

PRODUCTS->Product Drug ->Derived Drug Interaction

PRODUCTS->Product Drug ->Last daily dose

Note: There can be situations where two different List Maintenance 
items you create contain similar attributes in the SQL criteria. In this 
case, you can assign a priority level to individual List Maintenance 
items. The priority level determines which LM item SQL is executed 
first.
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Use the following procedure to configure derivation functions:

■ In the List Maintenance tab page, select the Derivation Functions item from the 
List Maintenance Items list.

■ The Attributes list displays the existing categories. This is a default category and 
cannot be modified.

■ Select All Derivations. Click Modify.

When the system opens the Derivation Fields dialog box, use the icons (described 
below) to add/delete/rearrange rows in the Derivation Fields window.

The following table lists and describes the fields that display in the Derivation Fields 
dialog box.

Note: Age Group, Causality, Last daily dose and Report Type are 
comma separated Derivation rules.

Click on... To...

add a row above

add a row below

delete a row

arrange rows
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Field Description

LM Table This field is the table name of the selected Argus field i.e. 
automatically populated.

Suppress Suppress functionality is available for fields associated with the list 
maintenance data. When suppress is enabled for a field, the 
corresponding list maintenance values which are not present in any 
case are deleted and thus not available for querying.

Note: This is applicable only if the condition specified in the SQL text 
box covers all the cases having the selected LM field.

Value This is a textbox which captures the value for the new derivation 
field.

Note: For the following rules the system expects the user to enter the 
rule's new value as a comma separated value.

Make sure that the values for the rules are entered as follows. 
Unexpected results and/or ETL error may result if the values are not 
entered as specified.

Age Group rule Parameters: VALUE, GROUP_LOW, GROUP_HIGH

Parameter Parameter Description

VALUE New value for the rule

GROUP_LOW Lower value of the Group

GROUP_HIGH Higher value of the Group

Example: NewAgeGroup,25,50

If you do not want to specify the High 
Value then the comma is mandatory in 
the end. For example, Unknown,70,

Causality Parameters: VALUE, REPORTABILITY

Parameter Parameter Description

VALUE New value for the rule

REPORTABILITY Lower value of the Group

Example: NewCausality,1

Last Daily Dose Parameters: VALUE, DAILY_DOSE_SORTING_ORDER

Parameter Parameter Description
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4.1.6 Configuring the Argus Insight Scheduling Service
Use the following procedure to configure the Argus Insight scheduling service.

 Log on to the Argus Insight Server as an Admin user.

VALUE New value for the rule

DAILY_ DOSE_SORTING_ORDER 1 or 2 or 3 and so on to define the sorting order if there are more than 
1 rule for Last Daily Dose field

Examples:

Example:1 -> 0to1,1

Example:2 -> 2to3,2

Example:3 -> 5to8,3

Report Type Parameters: VALUE, INC_LIT, INC_TRIAL,ABRV

Parameter Description

VALUE New value for the rule

INC_LIT 1 if Literature Report Type else 0

INC_TRIAL 1 if Clinical Trial Report Type else 0

ABRV A 3 letter abbreviation for the Report Type

Example: NewReportType,0,1,NRT

Priority This field captures the priority for a list of derivation rules applied to 
a single LM field. The value should be from 1 to 255.

Note: The priority for derivation rules applicable to a single LM filed 
should be unique.

SQL Specify the SQL statement to capture the cases for which the 
derivation rule is applicable.

Note: The SQL statement should follow the correct syntax.

The UI does not validate the length of the new values against the 
database. Make sure that new values being inserted into the MART 
do not exceed the limit defined in the database.

The SQL query configured against a rule should only have the 
primary key column name(s) of the field in the SELECT clause. It 
should also not contain the table name.

Example:

select case_id from rpt_case where ….. (CORRECT)

select rpt_case.case_id from rpt_case where …. (INCORRECT)

Make sure that there is only one space after the select clause in the 
SQL query.

Example:

select case_id, seq_num from rpt_product where ….. (CORRECT)

select case_id, seq_num from rpt_product where …. (INCORRECT)

Make sure that no oracle keyword (such as distinct) is used after the 
select clause in the SQL query.

Example:

select case_id, seq_num from rpt_product where ….. (CORRECT)

select distinct case_id, seq_num from rpt_product where.. 
(INCORRECT)

Field Description
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 Open the MailConfig.xml in Notepad from the following location on the Argus 
Insight Web Server:

<Argus Insight Installation Path>/<Bin folder>

 Modify the tags in the MailConfig.xml file as follows:

Save the file and close it.

4.1.6.1 Starting Argus Insight Service
1. Go to Start->Run on the Argus Insight web server.

2. Type Sevices.msc in the textbox and press enter.

3. Services window will be displayed on the screen.

4. Go to Argus Insight Service.

Existing Tag Modify To

<AdminId>Administrator@oracle.net</Ad
minId>

<AdminId><EmailID></AdminId> where EmailID is the email ID 
used for sending Scheduled Reports

<epwd>Password</epwd> <epwd><Email Password></AdminId> where Email Password is 
the email access password for the email ID provided in 
<AdminId><EmailID></AdminId>

If you want to send emails to external domains, provide a valid 
password. Else, you can enter any value as password.

Secure Connections require a valid password.

<SMTPServer>172.16.10.46</SMTPServer> <SMTPServer><Mail Server IP></SMTPServer> where Mail Server 
IP is the IP address of your Email Server

<Authenticate>NO</Authenticate> <Authenticate> User Authentication for sending Emails 
</Authenticate>

If a secure connection is needed ,mark this entry as YES.

If a non- secure connection is needed, mark this as NO.

Example: Dominos server should mark this entry as no and 
Microsoft Exchange server should mark this entry as either yes or 
no

<MaxMailSizeKB>1024</MaxMailSizeKB> Maximum size allowed for mail attachment on email server.

<SMTPPORT>25</SMTPPORT> <SMTPPORT><Port Number></SMTPPORT>

where Port Number is the SMTP Port Number

<SMTPConnTimeOut>100</ 
SMTPConnTimeOut>

< SMTPConnTimeOut><TimeOutin Seconds></ 
SMTPConnTimeOut >

where Timeout is the time in seconds for SMTP Connection 
Timeout.

<ReplyTo>administrator@oracle.net</Repl
yTo

<ReplyTo><EmailID></ReplyTo where EmailID is the id to which 
the reply will be sent via e-mail

FailedRecipientsMailTo <FailedRecipientsMailTo>EmailID</FailedRecipientsMailTo>

Configure the email address of user who will receive email for 
information regarding un-delivered emails due to invalid email id 
or any other error.

<OracleService_InsightURL> <OracleService_InsightURL> contains URL for Argus Insight 
application for accessing reports which can not be sent to 
configured mail id due to mail size limit.
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5. Right click the Argus Insight Service and select properties.

6. Set the startup type as Automatic.

7. Start the Argus Insight Service.

8. Press OK to close the Argus Insight Service Properties dialog window.

IMPORTANT! Ensure that the user who runs this service has administrative 
privileges. If the user does not have administrative privileges, either the Scheduled 
CIOMS Reports might not return or an LDAP user might not be able to log in to the 
Argus Insight web application.

4.1.7 Configuring the CIOMS and MedWatch Reports
These are required settings because PwReports.exe file is responsible for LDAP 
authentication along with CIOMS and MedWatch reports.

1. Go to Start -> Run and type dcomcnfg and press Enter.

2. In the tree under Console root>Component Services>Computer>My 
Computer>DCOM Config.

Note: For changing the interval of different service tasks, please 
modify the entries in Service.config file present under Bin folder of 
Insight. All the times mentioned in this file are in seconds.
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3. Right click on  PwReports and select Properties. The following dialog box is 
displayed.
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4. Click the Security tab.

5. When the system opens the Security tab:



Configure the Argus Insight Application Profile Switches

Configure the Argus Insight Application 4-31

a. In the Launch and Activation Permissions section, click Customize. 

b. Click Edit.

6. When the system opens the following dialog box, click Add.
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7. When the system opens the following dialog box:
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a. Locate the Enter the object names to select section

b. Add <machine_name>\IUSR_<machine_name>. On a Windows 2008 Server, 
add <machine_name>\IUSR.

c. Click OK.

8. When the system opens the following dialog box:

a. Select the newly created Internet Guest Account.

b. Check all the permissions.

c. Click OK

9. Exit the Component Services program.

4.1.8 Configure the IIS File download limit
Use the following procedure to configure the IIS file download limit for Windows 
2003.

1. Go to the Internet Information Services (IIS) Manager.

2. Go to Start -> Run. Type iisreset -stop to stop the IIS service.

3. Go to C:\Windows\system32\inetsrv\metabase.xml file. 

4. By default, this file has this entry: AspBufferingLimit = "4194304". This limits the 
download size to 4,194,304 bytes (4 MB).

5. Change this size to a large value (such as 200000000 for 200 MB) to allow your 
Windows 2003 server to send large downloads.

6. Start the IIS service. Go to Start -> Run. Type iisreset -start to start the IIS service.

Use the following procedure to configure the IIS file download limit for Windows 
2008.
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1. Go to the Internet Information Services (IIS) Manager.

2. Double-click ASP in the right pane. The following page appears:

Expand Limit Properties and change the Response Buffering Limit from its 
default value of 4 MB to a large value such as 200000000 (200 MB).
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Click Apply to save the changed value. 

3. Restart the IIS service. Go to Start -> Run. Type iisreset to restart the IIS service.

Configuring the ASPMaxRequestEntityAllowed Value (Optional Setting)

This setting is required only if end-users are using custom SQLs in advanced 
conditions, with more than 70,000 characters. If any AJAX error appears while saving 
the Custom SQLs of these many characters, update the 
ASPMaxRequestEntityAllowed value of the MetaBase.xml file. This ensures that the 
ASP can post that much data onto the server. 

There are two ways of updating this value: 

1. By updating the MetaBase.xml:

    a) Stop the IIS. Use "iisreset /stop" at command prompt 

    b) Go to \WINDOWS\system32\inetsrv 

    c) Open the MetaBase.xml file in notepad 

    d) Edit the Value of ASPMaxRequestEntityAllowed and set it to 500000 

    e) Save the file and restart the IIS. Use "iisreset /start" at command prompt. 

2. By using the DOS Prompt: 

   a) At a command prompt, type the following command, and then press ENTER: 

     cd drive:\inetpub\adminscripts 

Note that in this command to change folders, the drive is only a placeholder for the 
hard disk where IIS is installed. 

   b) On the command prompt, type the following command, and press ENTER: 
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  cscript adsutil.vbs set w3svc/ASPMaxRequestEntityAllowed 500000 

The maximum value is 1,073,741,824 bytes. Set this value to the lowest possible value 
that allows for the functionality that you want. 

c) On the command prompt, type the iisreset command, and press ENTER. 

4.2 Copy Configuration: Exporting and Importing Data
Before configuring export and import functions, be aware of the following:

■ Before importing or exporting to or from a network drive, verify that you have 
mapped the network drive. This tool does not support direct access to network 
drives.

■ Before copying Argus Data, incremental ETL should be completed on Source 
Insight Database from Source Argus.

■ It is assumed that the configuration of the instance of Argus used to run Initial and 
Incremental ETL on the source Insight DataMart will also be copied and applied 
on the new Argus Instance which will be associated with the new Insight 
DataMart.

■ Data must be imported after loading Factory Data and before running Initial ETL 
on destination environment.

4.2.1 Exporting Data
Use the following procedure to export data.

1. Go to Start>Programs>Oracle>Argus Insight>Schema Creation Tool.

2. Click Export Data. 

3. When the system opens the Export Utility dialog box, enter the name of the 
Schema Owner, the Schema Password, and the Database name.
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4. If you want to retain the default values for the Export Dump, Log, and PAR files, 
go to Step 6 and then to Step 9.

5. If you want to configure the export file name and location, perform steps 7 and 8.

6. Click Export, to retain the default values of the Export Dump, Log and PAR files.

7. To configure the export file name and location, click the ... button, next to the 
Export Dump File Name.
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8. When the system opens the Export Dump File dialog box:

1. Navigate to the appropriate location and enter the export file name in the File 
name field.

2. Click Save.

9. When the system redisplays the Export Utility dialog box, click Export to retain 
the default file name and continue. 

Note: You can configure the Log File names in a similar manner.

Note: Do not change the parameter file name and location.



Copy Configuration: Exporting and Importing Data

Configure the Argus Insight Application 4-39

10. The system displays a series of command screens. When prompted to do so, 
perform the appropriate actions. 

11. When the system opens the following dialog box, click OK to verify the log files 
are at the location in the dialog.
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12. When the system displays the following message, click OK and verify the log files 
are at the location displayed in the dialog. 

4.2.2 Importing Data
Use the following procedure to import data.

1. Go to Start>Programs>Oracle>Argus Insight>Schema Creation Tool.

2. When the system opens the Schema Creation Tool, click Import Data.

3. When the system opens the Import Utility dialog box, enter the name of the 
Schema Owner, the Schema Password, and the Database name.

1. To configure the Dump file name and location, click the ... button next to the 
Dump File Name to configure the Dump file name and location.



Copy Configuration: Exporting and Importing Data

Configure the Argus Insight Application 4-41

2. When the system opens the Import Dump File dialog box, navigate to the 
appropriate location and select the Dump File Name.

3. When the system opens the Import Dump File dialog box, click Open.
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4. When the system redisplays the Import Utility dialog box, click Import.

5. When the system opens the following dialog box, click OK to proceed.
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6. The system displays a series of command screens. Press Enter when prompted to 
do so.

7. When the system presents the following dialog box, click OK and verify that the 
log files are at the location specified in the dialog box.
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This chapter describes the steps required to run and work with the Initial ETL.

5.1 Running the Initial ETL
Before running the Initial ETL, ensure that Auto extend is set to ON for all the Data 
files in the database that are related to Staging and Mart. You should also be aware of 
the following:

■ Because the initial ETL requires a huge amount of Temp space, set the Temp space 
to 100 GB to prevent data errors. After completing the Initial ETL reduce the temp 
space to 30 GB.

■ After the Initial ETL completes, the balancing log may show differences between 
the Argus/Stage and MART table counts. This is because of the derivation rules 
applied to the datamart.

■ The system may display the following message:

Warning !!! - Could not locate MedDRA-J User in the Argus Database.

Ignore this warning for all MedDRA tables.

■ Do not run incremental ETL for more than 50,000 cases. Run the Initial ETL again 
if the number of cases exceeds 50,000.

Use the following procedure to run the initial ETL.

1. Log on to the Argus Insight Web Server as an Admin user.

2. Select Start > Programs > Oracle > Argus Insight > Schema Creation Tool.
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3. When the system opens the Schema Creation Tool, click Initial ETL.

4. When the system opens the Oracle Database Connect dialog box, enter the APR_
MART password and database name in their respective fields. Click OK.

5. When the system opens the Initial ETL Status dialog box, click Start ETL to start 
the Initial ETL process.
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6. When the system opens the Initial ETL Configuration Check dialog box, click Yes 
if these items have already been configured.

7. The system presents a processing dialog box showing the ETL start time, current 
process in execution, and the progress bar while ETL is in progress. 

Stop ETL and Close buttons are also available.
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a. You can halt execution of Initial ETL process by clicking Stop ETL.

b. Click Continue to continue the stopped ETL process.

8. When the system shows the Initial ETL process completes successfully with 100% 
displayed in the progress bar, click Balancing Logs.

9. When the system opens the Balancing Logs dialog box, click OK.

10. The system presents a command screen.

Note:  Closing the Schema Creation Tool application does not impact 
the execution of ETL process.

Ignore option is not available for stopped process.

Click Stop ETL to halt the ETL process.

Click Continue to continue the stopped ETL process.
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11. When the system opens the following dialog box showing the location of the 
balancing log reports generated with the report names, click OK.

12. Click Run ETL  (from the Initial ETL Status dialog, as shown in Step 8) if you want 
to start the Initial ETL process from the beginning after confirmation message and 
APR_MART password input.

a. Click Continue to continue the failed Initial ETL procedure.

b. Ignore option is also available to ignore the failed Initial ETL process.

c. Click Restart ETL to start the Initial ETL process from beginning after 
confirmation message and APR_MART password input.

5.1.1 Closing the Initial ETL Status dialog
Use the following procedure to close the Initial ETL Status dialog.

1. Click Close.
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2. When the system opens the Close Application dialog box, click OK.

5.1.2 Stopping the Execution of ETL
Use the following procedure to halt the execution of the Initial ETL process:

1. Click Stop ETL. 

2. When the system opens the Stop ETL confirmation dialog box, click OK.



Running the Initial ETL

ETL 5-7

3. The system redisplays the Initial ETL Status dialog box.

5.1.3 Run ETL
Use the following procedure to start the ETL process from the beginning.

1. Click Run ETL.

2. When the system opens the Run ETL dialog box, click OK.
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3. The following dialog is displayed. Enter the APR_MART password and click OK.

4. The initial ETL process starts from the beginning.

5.1.4 Options available for a Failed ETL
1. You can choose any of the following options for the failed Initial ETL process.

■ Click Continue to continue the failed Initial ETL procedure.

■ Click Ignore to ignore the failed Initial ETL process.

■ Click Modify Attributes of ETL Data Exclusion if PRE_REQ_CHECK_FLAG 
switch is set to ABORT.

5.1.5 Continuing the Failed Initial ETL Process
Use the following procedure to continue a failed ETL procedure. Execute the following 
steps to continue the Initial ETL process from the failed ETL procedure.

Note: These modifications must be done before running the Initial 
ETL process.
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2. Double-click on the ETL error to view the Error Data dialog containing the details 
of that error. Click OK.

3. Right-click on the ETL Error and click Copy to copy the error data. 

4. Click Continue to continue the failed ETL process.

5. When the system opens the Continue ETL dialog box, click OK.

6. The system continues with the ETL process (if no errors are found).

7. The system continues executing the initial ETL.
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5.1.6 Ignoring the Failed Initial ETL Process
Use the following procedure to start the Initial ETL process by ignoring the failed 
Initial ETL procedure:

1. When the system opens the Initial ETL Status dialog box, click Ignore.

2. When the system opens the Ignore Error dialog box, click OK.

3. The system starts the Initial ETL from the next process.
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5.1.7 Modifying the Attributes of ETL Data Exclusion
Use the following procedure to modify ETL Data Exclusion attributes. You must 
modify these attributes before ETL execution.

1. Log on to the Argus Insight Web Server as an Admin user.

2. Select Tools > List Maintenance > Profile Switches > ETL Data Exclusion.

3. Click Modify.

4. When the system opens the following dialog box do one of the following and click 
OK:
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■ Enter IGNORE in the Value field if you want to continue the ETL process and 
skip cases with erroneous data.

■ Enter ABORT in the Value field if you want the ETL process to abort when it 
encounters cases with erroneous data.

5.1.8 Restart the Initial ETL Process
Use the following procedure to restart the the Initial ETL process starting from after 
the confirmation message and APR_MART password input:

1. When the system opens the following dialog box, click Restart ETL.
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2. When the system opens the Restart ETL dialog box, click OK.

3. When the system opens the Oracle Database Connect dialog box:

■ Enter the APR_MART password in the Password field.

■ Enter the database name in the Database field.

■ Click OK.

4. When the system opens The Initial ETL Configuration Check dialog box, click Yes 
if the listed items have already been configured.

5. The system proceeds with the ETL process. When the system finishes the ETL 
process, click Close.
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The chapter describes steps to configure and work on the Cognos 8 environment.

6.1 Configuring the Cognos 8 Environment
Before attempting to configure the environment, verify that you have installed all 
required hardware and software. For more information, see the Hardware and 
Software Requirements section.

6.1.1 Configuring IIS on the Cognos 8 Server

If you are using Microsoft Windows 2003 on the Cognos 8 Server, use the following 
procedure to configure IIS 6.0:

1. On the Cognos 8 Server, select Start > Programs > Administrative Tools > Internet 
Information Services (IIS) Manager.

2. When the Internet Information Services window opens, expand the control tree 
item corresponding to the Web Service Extensions and configure the settings, as 
shown in the right pane.

Note: You must configure the Cognos 8 environment in the order 
shown in this document.

Note: If you are using Microsoft Windows 2008 on Cognos 8 Server, 
refer to the embedded document for details on configuring IIS 7.0. 

Double-click on the icon displayed in this note to open the document. 
Alternatively, you can also right-click the icon and click Save 
Embedded File to Disk... to save the document locally.

After configuring IIS 7.0 as per the steps listed in the embedded 
document, see Section 6.1.2, "Configuring the Java Database 
Components (JDBC) in the Cognos 8 Environment" for the next steps 
to be followed.
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3. Select Web Sites > Default Web Site and right click to open the popup menu.

4. Select New > Virtual Directory . . . from the menu.

5. When the system opens the following dialog box, click Next>. 
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6. When the system opens the following dialog box, enter the alias for the Web 
virtual directory in the Alias field. Click Next>.

7. When the system opens the following dialog box:
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a. Click Browse and navigate to the following directory: 

<Cognos Installation Path on Web Server>\Cognos\c8\webcontent 

b. Select the appropriate directory and click OK.

c. Click Next.

8. When the system opens the following dialog box:
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a. Click the Read and Run scripts checkboxes.

b. Verify that the other checkboxes are clear.

c. Click Next.

9. When the system opens the following dialog box, click Finish.
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10. The Internet Information Services window appears.

11. In the left pane of the Internet Information Services window, right-click the 
COGNOS8 item.

12. From the context menu that appears, select New > Virtual Directory.

13. When the system opens the following dialog box, click Next.
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14. Enter the Alias for the for the Web virtual directory in the Alias field. Click Next.

15. When the system opens the following dialog box:

a. Click Browse to select the location that has content for publishing.

b. Navigate to the following location:

<Cognos Installation Path on Web Server>\Cognos\c8\cgi-bin
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c. Click OK to return to the dialog box and click Next.

16. When the system opens the following dialog box:

a. Check the Read, Run scripts (such as ASP), and Execute (such as ISAPI 
application or CGI) check boxes.

b. Verify that all other check boxes are clear.

c. Click Next.

17. When the system opens the following dialog box, click Finish.
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18. When the system redisplays the Internet Information Services window, click Close.

Select Start>Run>iisreset and click OK to reset the IIS.

6.1.2 Configuring the Java Database Components (JDBC) in the Cognos 8 Environment
Use the following procedure to configure the JDBC in the Cognos 8 environment.

1. Copy the Classes12. zip file from the Oracle installation path  
C:\oracle\product\10.2.0\client_1\jdbc\lib” to the following location on the 
Cognos 8 environment:

<Cognos Installation Path>\c8\webapps\p2pd\web-inf\lib

2. In the Cognos 8 environment, rename the copied Classes12.zip file to Classes12.jar.

6.1.3 Authentication Settings for Cubes and Report Writer
Copy the PR.asp file from the following location on the Argus Insight Web Server:

\\<Argus Insight Installation Path>ArgusInsight\ASP\Reports to the following path 
on the Cognos 8 Server:

\\<Cognos 8 Installation>Cognos\c8\cgi-bin

Note: If you are using the Oracle 11g Client, copy the ojdbc14.jar file 
from the following location:

C:\app\Administrator\product\11.1.0\client_
1\sqldeveloper\jdbc\lib
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6.1.4 Configuring Custom Java Authentication
Use the following procedure to configure custom Java authentication.

1. Copy the CAM_AAA_JDBC_PowerReports.jar file from the following location

\\<Cognos 8 Server>\<Argus Insight Installation Path>\Java 
Authentication\JDBC_PowerReports

to this location on the Cognos8 Server:

\\<Cognos 8 InstallationPath>\ c8\webapps\p2pd\WEB-INF\lib

2. Copy the JDBC_Config_PowerReports.properties file from this location:

\\<Cognos 8 Server>\<Argus Insight Installation Path>\Java 
Authentication\JDBC_PowerReports 

to this location on the Cognos8 Server:

\\<Cognos 8 Installation Path>\c8\Configuration

3. Open the JDBC_Config_PowerReports.properties file in Notepad.

Modify the existing values of the parameters in the JDBC_Config_
PowerReports.properties file as shown in the following table.

4. Save and close the file.

5. Copy the file ContentStore.zip from this location:

\\<Cognos 8 Server Name>\<Argus Insight Installation Path>\Cognos 
8\Contentstore

to this location on the Cognos 8 Server:

<Cognos 8 Installation Path>\C8\Deployment

6.2 Configuring the Cognos 8 Environment
Use the following procedure to configure the Cognos 8 environment.

1. Select Start > Programs > IBM Cognos 8 > IBM Cognos Configuration to open the 
IBM Cognos Configuration window.

Parameter Value to Enter

Server Enter the IP address or the name of the Database Server.

SID Enter the instance name of the Argus Insight datamart.

Port Enter the database port number.

Note: The windows that are displayed during the Cognos 8 
configuration are labeled as either IBM Cognos 8 or Cognos 8. Both 
labels refer to the same Cognos configuration.
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2. Select the Environment group in the control tree.

3. Verify that the values of the environment attributes in the right pane are set as 
shown in the following table:

Item Value

Sort Buffer Size in MB 16

Gateway URI http://localhost:80/cognos8/cgi-bin/cognos.cgi

Dispatcher URI for Gateway http://localhost:9300/p2pd/servlet/dispatch/ext
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4. In the control tree, select the Logging sub-group under the Environment group.

5. Verify that the items in the right pane display the following values. Modify the 
values if they are not as specified below:

6. In the control tree, select Security > Authentication > Cognos.

Controller URI for gateway http://localhost:80/cognos8/controllerServer

External dispatcher URI http://localhost:9300/p2pd/servlet/dispatch

Internal dispatcher URI http://localhost:9300/p2pd/servlet/dispatch

Content Manager URIs http://localhost:9300/p2pd/servlet

Dispatcher URI for external 
applications

http://localhost:9300/p2pd/servlet/dispatch

Item Value

Local Log Server Port Number 9362

Enable TCP False

Local Log Server worker Thread 10

Item Value
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7. Verify that the item in the right pane displays the following value. Modify the 
value if it is not set, as shown below:

■ Item: Allow anonymous access?

■ Value: True

8. In the left pane, click IBM Cognos Application Firewall to change the value of 
Enable CAF validation? to False.

9. In the control tree, select Data Access > Content Manager.
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10. Right-click the Content Store item in the left pane. Select Delete from the popup 
menu.

11. When the system opens the following dialog box, click Yes.

12. Go to Data Access>Content Manager and right-click Content Store and select New 
Resource > Database.
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13. When the system opens the New Resource Database dialog box:

■ Type CNTSTORE in the Name field. This is the name of the database resource.

■ Select Oracle database from the Type drop-down list.

■ Click OK.

14. When the system opens the IBM Cognos Configuration window:
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■ In the right pane, enter the value for the Database Server and port Number as:

<Database Server Name>:1521

where:

Database Server Name is the name of the server where your content store 
database is stored.

■ Select User ID and password item, and click the icon that appears next to it.

15. When the system opens the following dialog box:

■ Type the User ID for the content store database user in the User ID field.

■ Type the password for the content store database user in the Password field.

■ For verification, re-enter the password in the Confirm password field.

■ Click OK.



Configuring the Cognos 8 Environment

Cognos 6-17

16. When the system opens the IBM Cognos Configuration window, enter the 
database instance name for the Cognos 8 repository in the Service Name field.

6.2.1 Creating Namespace for Argus Insight Authentication
Use the following procedure to create the Namespace for Argus Insight authentication.

1. In the IBM Cognos Configuration window, right-click on Authentication under 
Security, and select New Resource>Namespace.

Note: The contents store database user is created in the Cognos 
content store database. This user is given grants of Connect, Resource 
and DBA. The character set of the Cognos content store database 
should only be UTF.

Make sure that the content store database entry is added in the 
TNSNames.ora file on the Cognos 8 server.
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2. When the system opens the New Resource – Namespace dialog box:

■ Type PowerReports in the Name field.

■ Type Custom Java Provider in the Type field.

■ Click OK.

3. When the system opens the PowerReports - Namespace - Resource Properties 
screen:
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■ Enter the values (case sensitive) for the items as shown in the following table:

■ Click the Save icon in the IBM Cognos Configuration window toolbar to save 
the configuration settings.

4. When the system opens the following dialog box, click Close.

5. Click the Start icon in the IBM Cognos Configuration screen to run the Cognos 8 
service.

Item Value

Namespace ID PowerReports

Java class name JDBCPowerReports
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6. If the system displays the following message, click OK to continue.

7. Ignore the warning if it appears due to mail server connection failure, as shown in 
the following dialog box.

8. Click Continue to ignore the Mail Server Connection Warning displayed above. If 
the warning(s) appear due to reasons other than mail server connection failure, 
please check your configuration again.

9. Click Close to exit.

10. Click File>Exit to exit from the IBM Cognos 8 configuration.

6.3 Importing the Content Repository
Use the following procedure to import the content repository to the database.

1. Log on to the IBM Cognos 8 Server as an Admin user.

2. Start Internet Explorer.

3. Enter the URL in the following format and press Enter: http://< Cognos 8 
Server>/cognos8

4. When the system opens the following window, click Administer IBM Cognos 
Content. 
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5. When the system opens the IBM Cognos Administration screen, click the 
Configuration tab.

6. When the system opens the Data Source Connection window, click Content 
Administration.

7. When the system opens the Content Administration window, click the New 
Import icon.

Note:  If your security settings on the server do not permit you to 
view the Cognos connection, add the site URL (http://<Cognos 8 
Server>/cognos8) to the list of local intranet sites.
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8. When the system opens the following window, click Next.

9. When the system opens the following window, type password in the Password 
field and click OK.

10. When the system opens the following window, click Next>.

11. When the system opens the following window, click the Name checkbox to select 
all the checkboxes in this category.
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12. When the system opens the following window, click Next>.

13. When the system opens the following window, verify that your settings are the 
same as the setting shown in the following illustration. Click Next>.
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14. When the system opens the next window, verify that your settings are the same as 
those shown in the following illustration. Click Next>.

15. When the system opens the following window, click Next>.

16. When the system opens the following window, click Finish.
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17. When the system opens the following window, click the Upgrade all report 
specifications to the latest version radio button and click Run.

18. When the system opens the following window, click OK.

19. Verify the import as follows:

a. Click More corresponding to the newly imported ContentStore.

b. Click View run history to view the deployment history.

c. Verify that the Status column displays the status as Succeeded.

d. Click Close to exit.

20. The repository import is complete.
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Use the following procedure to configure Cognos Security:

1. Set up an Administrator user in the Cognos environment. An administrative user 
is an Insight user who is part of system administrator role.

2. Log in to Argus Insight as the Administrator.

3. Go to Admin tools.

4. When the system opens the following dialog box, enter the value for Cognos 
Admin User in the Value field. Click OK. and Cognos Admin Password 
respectively.

5. When the system opens the following dialog box:

Note: Set up an Administrator user in the Cognos environment. An 
administrative user is an Insight user who is part of system 
administrator role.
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■ Type the Administrator Password in the Value field.

■ For verification, type the Administrator Password in the Confirm Password 
field.

■ Click OK.

6. Before configuring Cognos User Role Name, verify that the following List 
Maintenance entries are configured.
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■ COGNOS SERVER

■ COGNOS ADMIN USER

■ COGNOS ADMIN PASSWORD

This role will have all rights required to run various parts of Argus Insight 
application. All Insight users will become part of this role during their first 
login.

7. When the system opens the following dialog box, type the Cognos User Role 
Name you want to create in Cognos environment in the Value field. Click OK.
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8. The system adds the newly configured role to Analysis Users, Query User, and 
Author roles.

7.1  Configuring the LDAP Settings
This section contains instruction for integrating the LDAP authentication with Argus 
Insight and Cognos. Follow the installation procedures in the order in which they 
appear.

7.1.1 Configuring LDAP for Active DirectoryConfiguring the Active Directory
Use the following procedure to configure the Active Directory on the Cognos 8 server.

1. Go to Cognos server and open the Cognos configuration.

2. Add a NameSpace under Security->Authentication and select the Type as Active 
Directory.

3. Configure the Active Directory NameSpace.

4. Provide the Bind credentials, save the configuration, and restart the Cognos 
service.
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5. Click Modify and set the value to 1.

7.1.2 Configuring LDAP in COGNOS for SunOne
Use the following procedure to configure LDAP for Active Directory.

1. Configure SunOne on Cognos 8 server.

2. Go to Cognos server and open the Cognos configuration.

3. Add a NameSpace under Security->Authentication and select the Type as LDAP.

4. Configure the SunOne NameSpace.

5. Enter NameSpaceID, Host and Port, Base Distinguish Name, user lookup as 
"uid=$(user ID)" and unique identifier as "uid" as shown above. No need to enter 
any bind credentials.
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6. Save the Cognos configuration and restart the Cognos service.

7.1.3 Setting Up the Cognos LDAP Configuration in Insight
1. Go to Tools > List Maintenance > LDAP.

2. Select "Cognos LDAP Name Space Configuration" and click Modify.
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3. When the system opens the following dialog box, click Add.

4. When the system opens the following dialog box:
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a. Type the namespace ID in the Namespace ID field.

This is the namespace identifier for Active Directory or SunOne (which ever 
you have configured in Cognos)

b. Type the user name in the User Name field.

This is a Cognos and Insight user that is part of a configured LDAP namespace 
in Cognos and is a Cognos administrator.

c. Type the Password in the Password field.

This is the password for the configured Cognos administrator user.

d. For verification, type the password in the Confirm Password field.

e. Click OK to save the Cognos LDAP Name Space configuration.

7.1.4 Set Up LDAP Configuration in Argus Insight
Use the following procedure to set up the LDAP configuration in Argus Insight.

1. Go to Tools > List Maintenance to open the List Maintenance tab.

2. When the system opens the List Maintenance tab, select LDAP in the left pane.

3. Select LDAP Configuration from the right pane of the tab. Click Modify.
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4. When the system opens the following dialog box:

■ Locate the Enable LDAP at system level field and click the Yes option button.

■ Click Add.

5. When the system opens the following dialog box, set the parameters.

Note: All the LDAP configuration imported from Argus Safety via 
ETL is in read-only mode.
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The following table lists and describes the parameters.

7.2 Editing Sign On and Setting Connection Paths
This section provides information about the following:

■ Editing Sign On

Parameter Name Description

LDAP Server Alias Enter a unique name to identify the LDAP server configuration.

Server Name Enter the name of the LDAP server.

Port Number Enter the LDAP server port number.

BaseDN Enter the Base DN for configured LDAP server (distinguish Name).

Time Out(Sec) Enter a value for LDAP search timeout.

UserDN(ex. CN=..,OU=..,DC=..,): Enter the complete UserDN for the LDAP search user. Argus Insight 
uses this user to search for users in the complete LDAP directory for 
authentication.

Password Enter password for the LDAP search user.

LDAP Search Key(ex. CN,uid): Enter SAMAccountName for Active Directory Server

Enter uid for SUNONE server

This value can CN also based on LDAP server configuration

Note:

■ If you check the "Force anonymous binding for search?", the 
search user DN and password are not required.

■ If Cognos is LDAP enabled, select the corresponding Cognos 
Namespace from the Cognos Name Space dropdown.

■ Cognos LDAP does not work if Insight is single sign-on enabled 
using site minder.
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■ Setting Cube Datasource Connections

■ Activating the PowerReports Namespace

7.2.1 Editing Sign On
This topic has instructions on importing the content repository to the database.

1. Log on to the Cognos 8 Server as an Admin user.

2. Start Internet Explorer.

3. Enter the URL in the following format and press Enter:http://< Cognos 8 
Server>/cognos8

4. When the system opens the following window, click Administer IBM Cognos 
Content.

5. When the system opens the IBM Cognos Administration window, click the 
Configuration tab.

6. When the system opens the Data Source Connection window, click PRMART.

Note: If your security settings on the server do not permit you to 
view the Cognos connection, add the site URL (http://<Cognos 8 
Server>/cognos8) to the list of local intranet sites.
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7. When the system opens the following window, click More link to the right of the 
PRMART link.

8. When the system opens the following window, click View signons.

9. When the system opens the following window, click the More link.

10. When the system opens the following window, click Set properties.

11. When the system opens the following window, click the Signon tab.
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12. When the system opens the following window, click Edit the signon . . . .

13. When the system opens the following window:

■ Type APR_APP user ID in the User ID field.

■ Type the APR_APP user password in the Password field.

■ For verification, type the password in the Confirm Password field.

■ Click OK to set the password.

14. When the system opens the following window, click OK.

15. When the system opens the following window, click the PRMART link.
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16. When the system opens the following window, click More . . . ..

17. When the system opens the following window, click Set properties.

18. When the system opens the following window, click the Connection tab.

19. When the system opens the following window, click the pencil icon to edit the 
connection string.
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20. In the SQL*Net connect string, set the following:

■ Set the Host as the Argus Insight Database Server Name.

■ Set the Port as the Argus Insight Database Port Number

■ Set the Service_Name as the Argus Insight Database Instance Name.

■ Click Test the connection.

21. When the system opens the following window, click Test.

22. When the system opens the following window, click Close.
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23. Click Close on the screen that gets displayed.

24. Click OK.

25. Click OK on the screen that gets displayed.

7.2.2 Setting Cube Datasource Connections
This topic has instructions on changing the Cubes Connection Path:

Use the following procedure for Changing the Cube Path in DataSource (Not Required 
for Cognos Series 7 customers). Make the following changes to all the cubes present in 
the datasource directory except PRMART.

1. Log on to the Cognos 8 Server as an Admin user.

2. Start Internet Explorer.

3. Enter the URL in the following format http://<Cognos 8 Server>/cognos8. Press 
Enter.

4. When the system opens the following window, click Administer Cognos content.

5. When the system opens the Cognos Administration window, click the 
Configuration tab.

Note: If your security settings on the server do not permit you to 
view the Cognos connection, add the site URL (http://<Cognos 8 
Server>/cognos8) to the list of local intranet sites.
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6. When the system opens the Data Source Connection window, click a Cube Name.

7. Click the Cube Name (such as Administration Statistics).

8. Click the More . . . link.

9. When the system opens the following window, click Set properties.

10. Click the Connections tab.

11. When the system opens the Connections tab:
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■ Edit the Connection String for the cube (Give the path of your installation 
directory).

■ Click the pencil icon to edit the Connection String

12. When the system opens the following window:

■ In the Windows Location, enter the following path <Argus Insight installation 
Directory>/ArgusInsight/Cognos/PPES/<Cube Folder 
Name>/<CubeName>.mdc

■ Click Test the connection.

■ Click OK to apply the changes.

7.2.3 Activating the PowerReports Namespace
Use the following procedure to activate the PowerReports Namespace.

1. Open the Cognos 8 configuration.

2. Go to Start > Programs > Cognos 8 > Cognos Configuration.

3. When the system opens the Cognos Configuration window, select 
Security>Authentication>Cognos.
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4. When the system opens the following window, go to the right pane and set Allow 
Anonymous access? to False.

5. Click Actions > Restart to restart the Cognos 8 service.

6. When the system opens the confirmation dialog box, click Yes to save the modified 
configuration settings. Click Yes.
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7. If any warnings exist, the following screen may appear during the Cognos service 
restart. If the warnings appear to be the result of a mail server connection failure, 
click OK to ignore the warnings and continue.

8. Ignore the warning if it appears due to mail server connection failure, as shown in 
the following dialog box.

9. Click Continue to ignore the Mail Server Connection Warning displayed above. If 
the warning(s) appear due to reasons other than mail server connection failure, 
please check your configuration again.

10. When the system opens the following dialog box, click Close to exit the Cognos 
configuration.
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8Configuring Cognos Cubes

This chapter provides information about the following:

■ Setting Up Cognos 8 Cubes

■ Configuring Cognos Cubes

■ Configuring IIS and Drill-Through on the Cube Server

■ Setting Up Batch Generation for Cubes

■ Additional Cubes Configuration

8.1 Setting Up Cognos 8 Cubes
This section is intended for the use of Cognos 8 users. If you are using Cognos Series 
7.4 software, this section is not required.

Use this procedure to schedule the process that generates Cubes-on-the-fly.

1. In the Cognos 8 Server, go to <Argus Insight 
Directory>\ArgusInsight\Cognos\Cubes\PublishDemandCube folder.

2. In the DemandPublish.bat and DemandSource.bat files, set the following:

a. JAVA_Home to the Java_Home path on the Cognos 8 server.

b. JAR_Home to your <Argus Insight 
Directory>\ArgusInsight\Cognos\Cubes\PublishDemandCube\lib
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3. Save both files and exit.

4. Go to <Argus Insight 
Directory>\ArgusInsight\Cognos\Cubes\BatchGeneration-Cubes folder.

5. Open the GenerateCubes.cfg file.
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6. Set the following parameters in the GenerateCubes.cfg file:

7. Save and close the configuration file.

8. Go to the <Cognos8 installation path>\c8\configuration folder and open the 
cogtr.xml file.

9. Modify this file to set the following parameters:

10. The following table describes the new parameters in this file:

Parameter Description

ArgusInsightPath This is the Argus Insight installation path; include the 
ArgusInsight folder in the string:

<Argus Insight Installation path>\ArgusInsight

CognosPath This is the location of the Cognos 8 installation bin folder:

<Cognos 8 installation path>\c8\bin

ServerName This is the name or IP address of the Cognos 8 server. If the 
Cognos 8 server is running on a port other than the default port, 
then the parameter values should be entered in this format: 
ServerName:PortNumber. For example, Cog8Server:9300

CubeSaveDir This is the path of the Argus Insight installation directory. This 
provides the path for saving the cube output files on their exact 
location.

CubeDataSourceDir This is the path of the Argus Insight installation directory. This 
provides the path for the datasource files which are used for cube 
generation.

Note: Although the paths may contains whitespaces, make sure 
there is no white space between the parameter name, the "=" sign, and 
the value.
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11. Go to the <Cognos8 installation path>\c8\cs7Gateways\bin folder and open the 
cs7g.ini file.

12. Add the following configuration item in the cs7g.ini file:

[Databases]

Power Reports=^User ID:^?Password:;LOCAL;OR;ORACLE@apr_
app@PRMART/manager@COLSEQ=

where:

■ APR_APP is the DataMart Application Owner

■ PRMART is the Alias Name for the Argus Insight DataMart

■ Manager is the Password for the APR_APP user.

13. Save the file and exit.

14. Go to Start > Programs > Cognos 8 > Cognos Configuration.

15. When the system opens the Cognos Configuration window appears, click Restart 
to restart the Cognos 8 service.

Parameter Description

CubeSaveDirectory This is the path of the Argus Insight installation directory. This 
provides the relative path for saving the cube output files on their 
exact location.

DataSourceDirectory This is the path of the Argus Insight installation directory. This 
provides the relative path for the datasource files which are used for 
cube generation.

DataWorkDirectory Any path on the Cognos 8 server, which will be used to store some 
temporary files during cube generation.

LogFileDirectory Any path on the Cognos 8 server, where all the cube generation log 
files will be saved.

ModelSaveDirectory This is the path of the Argus Insight installation directory. This 
provides the relative path for saving the cube model files during 
cube generation.

ModelWorkDirectory Any path on the Cognos 8 server, which will be used to store some 
temporary files during cube generation.
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16. If any warnings exist during the Cognos service restart, the following screen may 
appear. Click Yes to ignore these warning if they appear to be the result of a mail 
server connection failure.

17. When the system opens the following dialog box, click Close to exit the Cognos 
configuration.
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8.1.1 Configuring the PowerPlay Enterprise Server
This section is for the user of Cognos Series 7.4 users. If you are using Cognos Series 8 
software, this section is not required. Use the following procedure to configure the 
PowerPlay Enterprise Server. Follow the installation procedures in the order in which 
they appear.

8.1.1.1 Configuring Cognos Cubes
1. Select Start> Program > Cognos Series 7 Version 4 > Tools > Configuration 

Manager.

2. When the system opens the following window, select File>Open Current 
Configuration.

3. When the system opens the following window:



Setting Up Cognos 8 Cubes

Configuring Cognos Cubes 8-8

■ Select the Services > Cognos Application Firewall > General control tree item 
in the left pane.

■ In the right pane, verify that Firewall enabled is set to False

4. Open Configuration Manager and go to Services -> UDA->General:

■ Set the window view to Advanced to view the properties.

■ Set Memory Size of Sort Buffer = 1024
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■ Set the List of Temporary Directories to a system drive with approximately 20 
GB of free space.

5. Select Services->PowerPlay Data Services->Cache.

■ Set Write Cache Size = 65536.

■ Set Read Cache Size = 65536.

■ Set Object Cache Size = 10000.

■ Set Flush Percentage = 1000.

6. Select Cognos PowerPlay->General.
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■ Set Read Cache Size to 65536

7. Add the Fetch Number of Rows value to the <PPES installation 
directory>\cer5\Bin\Cogdmor.ini file:

8. Fetch Number of Rows=100

9. Add the following text in Cognos.ini, located at <PPES installation directory>:

10. Power Reports=^User 
ID:^?Password:;LOCAL;OR;ORACLE@%s@PRMART/%s@COLSEQ=

11. Open <PPES installation directory>\cer5\Data\Bin\trnsfrmr.ini> file and set the 
MultiFileCubeThreshold key to the following value:

■ MultiFileCubeThreshold=10000000

12. Set the path for Cubes.

13. Add or edit the values of following entries in trnsfrmr.ini located at following 
location:

<PPES installation Directory>\Cer5\Data\Bin\trnsfrmr.ini

■ DataSourceDirectory=<Argus Insight installation Directory>\ArgusInsight\

■ CubeSaveDirectory=<Argus Insight installation Directory>\ArgusInsight\

■ ModelSaveDirectory=<Argus Insight installation Directory>\ArgusInsight\

■ DataWorkDirectory= any Directory which exists on system. Eg.c:\Temp1

■ ModelWorkDirectory= any Directory which exists on system. Eg.c:\Temp1

Note: If the transfrmr.ini file is not present at the specified location, 
open the Transformer from Start>Programs>Cognos Series 7 Version 
4> Tools.



Setting Up Cognos 8 Cubes

Configuring Cognos Cubes 8-11

■ LogFileDirectory=c:\temp\cubes\logs. This directory will contain all the logs 
for cube generation

14. Select the machine name from the left pane.

15. Select Actions > Validate Selection from the menu bar.

16. When the system opens the following dialog box, click Yes.

17. When the system opens the following dialog box, click OK.

18. Select Actions > Apply Selection.

19. When the system opens the following dialog box, click Yes.

20. When the system opens the following dialog box, click OK.
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21. Select File > Exit.

8.1.1.1.1 Cubes Configuration  

Use the following procedure to configure cubes.

1. Select Start > Program > Cognos Series 7 Version 4 > Tools > Access Manager 
Administration.

2. When the system opens the Access Manager- Administration window

■ Expand the Directory Servers folder and click Server Name>Default.

■ Enter the User name and Password, if prompted to do so.

3. When the system opens the following window, right click Data Source> Add 
Database to add a new database.
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4. When the system opens the following dialog box:

■ Type Power Reports in the Name field.

■ Click the Connection tab.

5. When the system opens the Connection tab:



Setting Up Cognos 8 Cubes

Configuring Cognos Cubes 8-14

■ Select the database type as Oracle.

■ Click Edit

6. When the system opens the following dialog box:

■ Type PRMART in the Enter SQL * Net Connect String field.

■ Click OK to exit the window.

7. Click OK to exit from the Database Properties window.

8. Go to Data Sources->Power Reports and right-click Signons.

9. Select Add Database Signon from the popup menu.
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10. When the system opens the following dialog box:

■ Type apr_app in the User ID field.

■ Type the apr_app password in the Password field.

■ Retype the password in the Verify Password field.

■ Click OK to save and exit.

11. Go to the Cubes Server Name> Default.

12. Right click on the default namespace and select Properties.

13. When the system opens the following dialog box, click the Signons tab.
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14. When the system opens the Signons tab, locate the Active Signons section and 
click the Both option button.

15. Click Settings to open the Settings tab.
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■ Click Use the following account for anonymous access option button and type 
Administrator in the associated text box.

■ Click OK

16. Go to Cubes Server Name-> Default->Users:

17. Right-click Administrator (Anonymous user).

18. Click Properties.

19. When the system opens the following dialog box:
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■ Click the User Signons tab.

■ On the User Signons tab, verify that the following field attributes are enabled, 
as shown in the following illustration.

■ Click Add.

20. When the system opens the following dialog box:

■ Type the domain user name in the text box.

■ Verify that the user is part of the Administrator group on the Cognos 8 server.

■ Click OK.

21. When the system opens the following dialog box:
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■ Click the Access tab

■ Click the Power Reports checkbox to select it.

■ Click Set . . . .

22. When the system opens the following dialog box:

■ Select apr_mart.

■ Click OK to save and exit.

23. Click OK again to close the Administrator (Anonymous user) Properties dialog.

24. Keep the Access Manager window open and go to the Configuration Manager.

■ Restart the services from Configuration Manager.

■ Exit the Configuration Manager window and the Access Manager window.

8.2 Configuring IIS and Drill-Through on the Cube Server
This section is intended for use by Cognos Series 7.4 users. This section is not required 
if you are using Cognos Series 8 software.

Use the following procedure to configure IIS on the Cube Server.
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1. On the Cube Server desktop, go to Start > Settings > Control Panel > 
Administrative Tools > Internet Services Manager:

2. Expand the control tree item corresponding to the Power Reports Web Server 
name.

3. Right-click Default Website>New>Virtual Directory. . . .

4. When the system opens the following dialog box, click Next>.
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5. When the system opens the following dialog box:

■ Type Cognos in the Alias field.

■ Click Next>.
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6. When the system opens the following directory:

■ Click Browse.

■ Select the following location: <Cognos Installation Path on Cube 
Server>\cer5\webcontent. Click OK

■ Click Next>.

7. When the system opens the following dialog box:
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■ Click the Read Run scripts (such as ASP), Execute (such as ISAPI 
applications of CGI), and Browse checkboxes.

■ Click

■ Click Next>.

8. When the system opens the following dialog box, click Finish.
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9. When the system opens the following window, expand the Default Web Site 
folder in the control tree.

10. Right-click the Cognos>New>Virtual Directory . . .
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11. When the system starts the Virtual Directory Creation Wizard, click Next>.
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12. When the system opens the following dialog box:

■ Type cgi-bin in the Alias field.

■ Click Next>.

13. When the system opens the following dialog box:
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■ Click Browse.

■ Select <Cognos Installation Path on Cube Server>\cer5\cgi-bin from the 
window and click OK.

■ Click Next>.

14. When the system opens the following dialog box:
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Check the following checkboxes:

■ Read

■ Run scripts (such as ASP)

■ Execute (such as ISAPI applications or CGI)

■ Browse

15. Click Next.
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16. When the system opens the following dialog box, click Finish.

17. The system opens the WWW Configuration dialog box.

18. Close the Internet Information Services window.
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8.2.1 Configuring Cubes
Use the following procedure to configure the Cognos Cubes for Cognos Series Version 
7.4.

1. On the Cubes Server desktop, go to Start > Program Files > Cognos Series 7 
Version 4> Cognos Server Administration.

2. Click the OLAP Cubes and Reports link.

3. Select the Cube Server Name from the Server name list box. Click OK.

4. When the system opens the following dialog box, click Yes.
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5. When the system opens the following dialog box:

■ Type the Cognos User ID in the User ID field.

■ Type the password in the Password field.

■ Click Log On.

6. When the system opens the following dialog box, check all the checkboxes. Click 
OK.

7. When the system opens the PowerPlay Enterprise Server Administration 
window:
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■ Right-click the Cube Server name in the left pane of the Server Administration 
window.

■ Select Properties from the popup menu.

8. When the system opens the Server Properties dialog box, click Settings.
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9. The system opens the Settings tab.

Set the values for the items on the Settings tab as shown in the following table. 
Click Apply.
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10. Select the Report Settings tab.

Setting Name Value to Enter / Select

Options

Resource (/ppwb) location <Cognos Installation Path>\cer5\webcontent\ppwb

Imported Reports Folder Imported Reports Folder

Temporary files location <Cognos Installation Path>\cer5\ppservertemp

Temporary directory clean-up

Interval (min)

15

Security dialog box Disabled

Administrator email address Leave this field blank.

Selection of preferences Disabled

Auditing level Detail

Fetch files 0

Maximum Restrict Client

Connections

50

Restrict Connection Idle

Timeout (min)

60

Table of Contents Enabled

Prompt for User Class Enabled

Silent User Class Switch Disabled

PowerPlay Web Explorer

Temporary File Deletion Interval(s) 900

Alerts Disabled

PowerPlay Web Viewer

Temporary File Deletion Interval (days) 30

Publishing

Default Portal Upfront

Delete related Cognos ReportNet object 
when deleting local cubes

Enabled
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11. Set the values for the items in the Report Settings tab page as shown in the 
following table. Click Apply to apply the settings.

12. Click OK.

13. Select the Cube Server name in the left pane of the Server Administration window.

14. From the menu bar, select Insert > Folder.

15. When the system opens the Folder Properties dialog box , click the General tab.

Setting Name Value to Enter / Select

Drill Through

PowerPlay Cubes Enabled

Cognos 
ReportNet/Cognos8

Enabled
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■ Enter PowerReports in the Name text box.

■ Specify the following path in the Folder source field:

<Argus Insight Installation Path>/Cognos/PPESCubes

■ Click the Cube Settings tab.

16. The system opens the Cube Settings tab.
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17. Set the values for the items in the Cube Settings tab, as specified in the following 
table. Click Apply.

18. Select Server>Exit from the menu bar to close the Server Administration window.

Setting Name Value to Enter / Select

Drill Through

Save as Power Cube Enabled

PowerPlay Cubes Enabled

PowerPlay Window Target <Cube Server Name>:8010

Cognos

ReportNet/Cognos8 Server

http//<Cognos8 Server>/cognos8/cgi-bin/cognos.cgi

Cognos

ReportNet/Cognos8

Enabled

Cognos

ReportNet/Cognos8 Folder

/content/folder[@name='ArgusInsight']/folder[@name='DrillThro
ugh']

Cognos Report Net Assistance Disabled
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19. Copy the ppwbcustom.js file from the following location: \\<Argus Insight Web 
Server>\<Argus Insight Installation Path>\ASP\include\js to the following 
location on the Cube Server: <Cognos Installation Path>\cer5\webcontent\ppwb

20. Go to <Argus Insight 
Directory>\ArgusInsight\Cognos\Cubes\BatchGeneration-Cubes folder.

21. Open the GenerateCubes.cfg file.

22. Set the following parameters in the GenerateCubes.cfg file:

23. Save and close the configuration file.

Parameter Description

PowerReportsPath This is the Argus Insight installation path; include the 
ArgusInsight folder in the string:

<Argus Insight Installation path>\ArgusInsight

CognosPath This is the location of the Cognos 8 installation bin folder:

<Cognos Cubes installation path>\cer5\bin

ServerName This is the name or IP address of the Cognos Cubes Server. 
Enter the parameter values in this format: 
ServerName:PortNumber. For example, 
CognosCubeServer:8010.

Note: Although the paths may contains whitespaces, make sure 
there is no white space between the parameter name, the "=" sign, and 
the value.
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8.2.2 Setting Up Batch Generation for Cubes
Although the ETL process updates the datamart on a regular basis, you need to 
separately update each Cube after the incremental ETL process is completed. To do 
this, set up a batch process to update the Cubes installed as part of the Argus Insight 
application. The batch process performs the following tasks:

■ Updates Cube data

The system updates Cube data with the latest data from the datamart.

■ Copies the updated Cubes in the backup folder

The system copies the updated Cubes into a backup folder that contains 
subfolders for each Cube; the backup folder path is as follows:

<Argus Insight Installation path>\ArgusInsight\cognos\backup\PPESCubes

For example: C:\Program Files 
\Oracle\ArgusInsight\Cognos\backup\PPESCubes

■ Copies the updated Cubes in the published folder

The system copies the updated Cubes into the published folder at this location:

<Argus Insight Installation path>\ArgusInsight\cognos\PPESCubes

For example: C:\Program Files\Oracle\ArgusInsight\Cognos\PPESCubes

Schedule individual tasks to update each Cube. To improve the performance of the 
batch process, make sure that individual batch execution processes do not overlap 
with each other.

8.2.2.1 Setting up Batch Generation through Task Manager:
This section provides information for using Windows Task Manager to schedule batch 
generation. Use the following procedure to set up batch for each of the five Cubes.

1. On the Cognos8/Cube Server, select Start > Settings > Control Panel.

2. When the system opens the Control Panel window, double-click Scheduled Tasks.
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3. When the system opens the Scheduled Tasks dialog box, double-click Add 
Scheduled Task.

Note: The appearance of Scheduled Tasks in Microsoft Windows 
2008 is differently from the Scheduled Tasks in Microsoft Windows 
2003.
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4. When the system opens the Scheduled Task Wizard dialog box, click Next>.

5. When the system opens the following dialog box, click Browse.
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6. When the system opens the following window:

■ Navigate to the following location: <Argus Insight Installation 
Drive>\ProgramFiles\Oracle\ArgusInsight\Cognos\Cubes\PublishDemand
Cube

■ Select the CubeGenMonitor.exe file.

■ Click Open.

7. When the system opens the following dialog box:
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■ Type the Cube Name in the text box.

■ Locate Perform this task and select the frequency for refreshing the Cube.

■ Click Next.

8. When the system opens the following dialog box, select the start time and day. 
Click Next>.

Note: You can assign any name to the task, but we recommend that 
the name be similar to the name of the Cube you are scheduling. The 
following:

Cube Name Cube ID

Medical Analysis 7

Clinical Trial Analysis 8

Overdose-Pregnancy-Interaction 9

Submission Statistics 10

Administration Statistics 11
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9. When the system opens the following dialog box:

■ Type the name of the user authorized to run this task in the Enter the user 
name field.

■ Type the user password in the Enter the password field.

■ For verification, type the password in the Confirm password field.

■ Click Next>.

10. When the system opens the following dialog box check the Open advance 
properties for this task when I click Finish check box. Click Finish.
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11. Double-click the Medical Analysis tab and open from the Scheduled Tasks. When 
the system opens the following dialog box, enter the run-time parameter for this 
task in the following format:

<Argus Insight installation path> 
\ArgusInsight\Cognos\Cubes\PublishDemandCube\CubeGenMonitor.exe 
<Cube ID> <

where:

CubeID identifies the Cube for which you are scheduling the batch generation.

12. The following table lists the Cube ID for each cube and provides examples of the 
run-time parameter to enter.
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13. When the system opens the following dialog box:

■ Type the password for the Cognos 8 Server admin user in the Password field.

■ For verification, type the password in the Confirm Password field.

■ Click OK.

14. When the system displays the following dialog:

Cube Name CubeID Example Run-Time Parameter

Medical Analysis 7 "C:\Program 
Files\Oracle\ArgusInsight\Cognos\Cubes\
PublishDemandCube\CubeGenMonitor.exe" 
7

Clinical Trial Analysis 8 "C:\Program 
Files\Oracle\ArgusInsight\Cognos\Cubes\
PublishDemandCube\CubeGenMonitor.exe" 
8

Overdose-Pregnancy-Interaction 9 "C:\Program 
Files\Oracle\ArgusInsight\Cognos\Cubes\
PublishDemandCube\CubeGenMonitor.exe" 
9

Submission Statistics 10 "C:\Program 
Files\Oracle\ArgusInsight\Cognos\Cubes\
PublishDemandCube\CubeGenMonitor.exe" 
10

Administration Statistics 11 "C:\Program 
Files\Oracle\ArgusInsight\Cognos\Cubes\
PublishDemandCube\CubeGenMonitor.exe" 
11
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■ Click the Schedule tab.

■ Set the appropriate schedule options.

■ Click the Settings tab.

15. When the system opens the Settings tab, set the options as shown in the following 
illustration. Click OK.
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16. The system creates the new scheduled task CubeGenMoitor (or Cube Name you 
have specified).

17. Repeat Steps 1 through 15 to schedule batch generation for the remaining cubes.

8.2.2.2 Setting up Batch Generation for Demand Cubes
Use the following procedure to set up batch generation for Demand Cubes.

1. Log on to the Cube Server as an Admin user.

2. On the Cube Server, select Start > Settings > Control Panel. Double-click 
Scheduled Tasks.

3. When the system opens the following dialog box, double-click Add Scheduled 
Task.
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4. When the system opens the following dialog box, click Next>.

5. When the system opens the following dialog box, click Browse.
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6. Navigate to the following location: <Argus Insight Installation 
Path>\ArgusInsight\Cognos\Cubes\PublishDemandCube.

7. Select the CubeGenMonitor.exe file. Click Open.

8. When the system opens the following dialog box, select Daily. Click Next.
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9. When the system opens the following dialog box, set the start time, frequency, and 
start date for the process, as appropriate. Click Next>.

10. When the system opens the following dialog box:
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■ Type the User ID in the Enter the user name field.

■ Type the user password in the Enter the password field.

■ For verification, type the password in the Confirm password field.

■ Click Next>.

11. When the system opens the following dialog box, click Open advanced properties 
for this task when I click Finsh checkbox. Click Finish.

12. Double-click the created task from the Scheduled Tasks. Select the Schedule tab. 
Click Advanced.

13. When the system opens the following dialog box:
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■ Check the Repeat Task checkbox.

■ Set how often the task will be executed.

■ Click the Duration option button and enter the duration as 24 hours.

■ Click OK.

14. Select the Settings tab. Do the following:

■ Verify that the Stop the task if it runs for checkbox is checked.

■ Enter the number of hours and minutes.
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15. Click OK.

8.3 Additional Cubes Configuration
This topic has instructions on configuring the cubes.

8.3.1 Configuring Cognos 8 Cubes in Non-Shared environment
1. Configure the Coggtr.xml file as shown below.

The following table describes the new parameters in this file:

2. Go to <Argus Insight 
Directory>\ArgusInsight\Cognos\Cubes\BatchGeneration-Cubes folder.

3. Open the GenerateCubes.cfg file.

4. Set the following parameters in the GenerateCubes.cfg file:

Note: This value can increase depending upon the size of the case 
series used to generate a cube.

Parameter Description

CubeSaveDirectory This is the path on the Cognos 8 server for storing the output file 
generated as result of cube generation process. This is the path of 
the Argus Insight installation directory in a non-shared 
environment. It provides the relative path for saving the cube 
output files on their exact location.

DataSourceDirectory This is the path of the Argus Insight installation directory in a 
non-shared environment. This provides the relative path for the 
datasource files which are used for cube generation.

DataWorkDirectory Any path on the Cognos 8 server, which will be used to store 
some temporary files during cube generation.

LogFileDirectory Any path on the Cognos 8 server, where all the cube generation 
log files will be saved.

ModelSaveDirectory This is the path of the Argus Insight installation directory. This 
provides the relative path for saving the cube model files during 
cube generation.

ModelWorkDirectory Any path on the Cognos 8 server, which will be used to store 
some temporary files during cube generation.
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5. Restart the Cognos configuration services after applying the above settings.

8.3.2 Configuring Series 7.4 Cubes in an Unshared Environment
Use the following procedure to configure Series 7.5 Cubes in an unshared 
environment,

1. Configure the trnsfrmr.ini file as shown below.

Parameter Description

ArgusInsightPath This is the Argus Insight installation 
path; include the ArgusInsight 
folder in the string:

<Argus Insight Installation 
path>\ArgusInsight

CognosPath This is the location of the Cognos 8 
installation bin folder:

<Cognos 8 installation 
path>\c8\bin

ServerName This is the name or IP address of the 
Cognos 8 server. If the Cognos 8 
server is running on a port other 
than the default port, then the 
parameter values should be entered 
in this format: 
ServerName:PortNumber. For 
example, Cog8Server:9300

CubeSaveDir This value corresponds to 
CubeSaveDirectory attribute of 
Coggtr.xml file. This value will be 
same as value of CubeSaveDirectory 
in Coggtr.xml file i.e. <Argus Insight 
Installation path>\ArgusInsight

CubeDataSourceDir This value corresponds to 
DataSourceDirectory attribute of 
Coggtr.xml file. This value will be 
same as value of 
DataSourceDirectory in Coggtr.xml 
file i.e. <Argus Insight Installation 
path>\ArgusInsight
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The following table describes the new parameters in this file:

2. Go to <Argus Insight 
Directory>\ArgusInsight\Cognos\Cubes\BatchGeneration-Cubes folder.

3. Open the GenerateCubes.cfg file.

4. Set the following parameters in the GenerateCubes.cfg file:

Parameter Description

CubeSaveDirectory This is the path on the cube server for storing the output file 
generated as result of cube generation process. This is the path 
of the Argus Insight installation directory in a non-shared 
environment. It provides the relative path for saving the cube 
output files on their exact location.

DataSourceDirectory This is the path of the Argus Insight installation directory. This 
provides the relative path for the data source files which are 
used for cube generation.

DataWorkDirectory Any path on the Cognos Cube server, which will be used to 
store some temporary files during cube generation.

LogFileDirectory Any path on the Cognos Cube server, where all the cube 
generation log files will be saved.

ModelSaveDirectory This is the path of the Argus Insight installation directory. This 
provides the relative path for saving the cube model files 
during cube generation.

ModelWorkDirectory Any path on the Cognos Cube server, which will be used to 
store some temporary files during cube generation.

Parameter Description

ArgusInsightPath This is the Argus Insight installation path; include the 
ArgusInsight folder in the string:

<Argus Insight Installation path>\ArgusInsight
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5. Restart the configuration manager service after applying the above settings.

8.3.3 Configuring Cognos 8 Cubes in Shared environment
1. Configure the Coggtr.xml file as shown below.

The following table describes the new parameters in this file:

CognosPath This is the location of the PPES installation bin folder:

<PPES installation path>\cer5\bin

ServerName This is the name of the Cognos Cube server. If the Cognos Cube 
server is running on a port other than the default port, then the 
parameter values should be entered in this format: 
ServerName:PortNumber. For example, CubeServer:8010

CubeSaveDir This value corresponds to CubeSaveDirectory attribute of 
trnsfrmr.ini file. This value will be same as value of 
CubeSaveDirectory in trnsfrmr.ini file i.e. <Argus Insight 
Installation path>\ArgusInsight

CubeDataSourceDir This value corresponds to DataSourceDirectory attribute of 
trnsfrmr.ini file. This value will be same as value of 
DataSourceDirectory in trnsfrmr.ini file i.e. <Argus Insight 
Installation path>\ArgusInsight

Parameter Description

CubeSaveDirectory This is the path on the cube server for storing the output file 
generated as result of cube generation process.

DataSourceDirectory This provides the relative path for the datasource files which are 
used for cube generation.

DataWorkDirectory Any path on the Cognos 8 server, which will be used to store 
some temporary files during cube generation.

LogFileDirectory Any path on the Cognos 8 server, where all the cube generation 
log files will be saved.

ModelSaveDirectory This provides the relative path for saving the cube model files 
during cube generation.

ModelWorkDirectory Any path on the Cognos 8 server, which will be used to store 
some temporary files during cube generation.

Note: The path for the DataSourceDirectory and the 
ModelSaveDirectory should always be same whether they are in a 
shared or unshared environment.

Parameter Description
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2. Copy the COGNOS folder present under <Argus Insight Installation 
Directory>\ArgusInsight folder and paste the entire COGNOS folder on the path 
provided for DataSourceDirectory and ModelSaveDirectory attributes.

3. Make sure that path provided for CubeSaveDirectory exists on the server.

4. Go to <DataSourceDirectory>\Cognos\Cubes\BatchGeneration-Cubes folder.

5. Open the GenerateCubes.cfg file.

6. Set the following parameters in the GenerateCubes.cfg file:

7. Schedule the cubes for generation using files present in the 
<DataSourceDirectory>\Cognos\Cubes\BatchGeneration-Cubes folder. 
Demand cubes will be scheduled using CubeGenMonitor.exe file present under 
<DataSourceDirectory>\Cognos\Cubes\PublishDemandCube folder.

8. All other configurations remain same.

9. Restart the Cognos configuration services after applying the above settings.

8.3.4 Configuring Series 7.4 Cubes in Shared environment
1. Configure the trnsfrmr.ini file as shown below. 

Parameter Description

ArgusInsightPath This is the Argus Insight installation path; include the 
ArgusInsight folder in the string:

<Argus Insight Installation path>\ArgusInsight

CognosPath This is the location of the Cognos 8 installation bin folder:

<Cognos 8 installation path>\c8\bin

ServerName This is the name or IP address of the Cognos 8 server. If the 
Cognos 8 server is running on a port other than the default 
port, then the parameter values should be entered in this 
format: ServerName:PortNumber. For example, 
Cog8Server:9300

CubeSaveDir This value corresponds to CubeSaveDirectory attribute of 
Coggtr.xml file. This value will be same as value of 
CubeSaveDirectory in Coggtr.xml file i.e. <Path of 
CubeSaveDirectory>.

CubeDataSourceDir This value corresponds to DataSourceDirectory attribute of 
Coggtr.xml file. This value will be same as value of 
DataSourceDirectory in Coggtr.xml file i.e. <Path of 
DataSourceDirectory >
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The following table describes the new parameters in this file:

2. Copy the COGNOS folder present in the <Argus Insight Installation 
Directory>\ArgusInsight folder and paste the entire COGNOS folder on the path 
provided for DataSourceDirectory and ModelSaveDirectory attributes.

3. Make sure that path provided for CubeSaveDirectory exists on the server.

4. Go to <DataSourceDirectory>\Cognos\Cubes\BatchGeneration-Cubes folder.

5. Open the GenerateCubes.cfg file.

6. Set the following parameters in the GenerateCubes.cfg file:

Parameter Description

CubeSaveDirectory This is the path on the cube server for storing the output file 
generated as result of cube generation process.

DataSourceDirectory This provides the relative path for the datasource files which are 
used for cube generation.

DataWorkDirectory Any path on the Cognos Cube server, which will be used to store 
some temporary files during cube generation.

LogFileDirectory Any path on the Cognos Cube server, where all the cube 
generation log files will be saved.

ModelSaveDirectory This provides the relative path for saving the cube model files 
during cube generation.

ModelWorkDirectory Any path on the Cognos Cube server, which will be used to store 
some temporary files during cube generation.

Note: The path for the DataSourceDirectory and the 
ModelSaveDirectory should always be same whether they are in a 
shared or unshared environment.
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7. Schedule the cubes for generation using files present in the 
"<DataSourceDirectory>\Cognos\Cubes\BatchGeneration-Cubes" folder.

8. Demand cubes will be scheduled using "CubeGenMonitor.exe" file present under 
"<DataSourceDirectory>\Cognos\Cubes\PublishDemandCube" folder.

9. All other configurations remain same.

10. Restart the configuration manager service after applying the above settings.

Parameter Description

ArgusInsightPath This is the Argus Insight installation path; include the 
ArgusInsight folder in the string:

<Argus Insight Installation path>\ArgusInsight

CognosPath This is the location of the Cognos 8 installation bin folder:

<PPES installation path>\cer5\bin

ServerName This is the name of the Cognos Cube server. If the Cognos Cube 
server is running on a port other than the default port, then the 
parameter values should be entered in this format: 
ServerName:PortNumber. For example, CubeServer:8010

CubeSaveDir This value corresponds to CubeSaveDirectory attribute of 
trnsfrmr.ini file. This value will be same as value of 
CubeSaveDirectory in trnsfrmr.ini file i.e. <Path of 
CubeSaveDirectory>.

CubeDataSourceDir This value corresponds to DataSourceDirectory attribute of 
trnsfrmr.ini file. This value will be same as value of 
DataSourceDirectory in trnsfrmr.ini file i.e. <Path of 
DataSourceDirectory >. This is the path where we have copied 
the entire COGNOS folder from Argus Insight installation 
directory.
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9Un-Installing Argus Insight

Follow these steps to perform the un-installation of Argus Insight:

■ Log on to the Argus Insight Web Server as an Admin user.

■ Go to Add/Remove programs using control panel.

■ Click Remove button corresponding to Argus Insight.

■ Select Remove (3rd option) and click Next.
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■ A warning message will be displayed "Do you want to completely remove the 
selected application and all of its features"?

■ Select Yes to continue.

■ System will uninstall the Argus Insight application and will ask to restart the 
Argus Insight web server.
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■ Click OK to restart the Argus Insight web server

■ Log on to Argus Insight web server as Admin user once it is up again

■ Go to Argus Insight installation directory (Where Insight was installed before 
un-installation).

■ Remove the Argus Insight folder completely from this location.

■ Reset the IIS before starting the installation of Argus Insight again.

Follow the same steps as mentioned above for un-installing Argus Insight from 
Cognos/Cube server.
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